إضافة خصائص محددة مسبقا إلى مكون، الاتصال أو نوع

الملاحة: كثافات سكانية والعمارة الخاص> عقارات>

إضافة خصائص محددة مسبقا إلى مكون، الاتصال أو نوع

إرسال التعليقات حول هذا الموضوع.

المكتبات القياسية من الخصائص يمكن تحديد وتعيين إلى أي شيء آخر في الهندسة المعمارية. ومن المعروف أن هذه المكتبات كما المعايير. باستخدام المعايير، تحتاج فقط إلى جمع خصائص أنظمة محددة - الخصائص القياسية هي هناك بالفعل.

على سبيل المثال خصائص الأداء القياسية من Microsoft Windows 2000 يمكن حفظ باعتباره معياروأسند إلى أي مكون من مكونات (أو اتصالات، وليس ذلك من شأنه أن يكون نموذجي) باستخدام نظام التشغيل مايكروسوفت ويندوز 2000.

لإضافة معيارإلى مكون، الاتصال أو نوع

1. انقر بزر الماوس الأيمنعلى المكون / اتصال / نوع.

2. اختار عين معيار.

3. اختار ا معيارمن القائمة.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | تغيير خصائص عنصر، الاتصال أو نوع | خواص الركام

© 2001-2015 Avolution بي تي واي المحدودة جميع الحقوق محفوظة.


خواص الركام

الملاحة: كثافات سكانية والعمارة الخاص> عقارات>

خواص الركام

إرسال التعليقات حول هذا الموضوع.

العملية "الحصى الممتلكات"يسمح لك بإضافة قيم الخصائص المتشابهة معا والكتابة (أو إضافة) النتيجة في خصائص العنصر الأصلي الذي تم اختياره. كما يسمح لك لتحديد نطاق التجميع وعما إذا كان لتحديث خصائص كل العناصر الفرعية أم لا.

لخواص الركام

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. انقر بزر الماوس الأيمن على عنصر (بنية، وهو مكون أو اتصال) التي للقيام التجميع وحدد خصائص الإجمالية.

3. اختيار واحد من الخيارات الحصى (اجتياز جميع المستويات الفرعية أو فقط مباشر المستوى الفرعي). إذا كنت قد اخترت اجتياز جميع المستويات الفرعية، يمكنك أيضا اختيار الخيار ما إذا كان ل مستويات الفرعية التحديث.

o اجتياز جميع المستويات الفرعيةيعني أن نطاق التجميع سوف تشمل العناصر في جميع المستويات في إطار العنصر الذي اخترته.

o مستويات الفرعية التحديثيمكن أن يتم إلا إذا كنت قد اخترت أيضا خيار اجتياز جميع المستويات الفرعية. وهذا يعني أنه أثناء تجميع الخصائص من أسفل إلى أعلى، كما سيتم تحديثها نتيجة الإجمالية على كل المستويات في كل من العناصر المقابلة.

o فقط مباشر المستوى الفرعييعني فقط خصائص العناصر مباشرة تحت العنصر المختار سيتم تجميعها.

o اختار تتضمن معيار الممتلكاتإذا كنت ترغب في الخصائص المحددة في المعايير ليتم تضمينها. خلاف ذلك، لن يستخدم إلا في الخصائص الفريدة لكل حالة المكون.

4. اختيار الخصائص التي ترغب في تجميع. يتم تجميعها في بهم أنواع.

5. انقر على التالى زر.

6. اختيار الخيار ما إذا كان ل قيم الاستبدال أو إضافة القيمفي العنصر المختار.

o قيم الاستبدالسوف أكتب نتائج مباشرة في خصائص العنصر المختار.

o إضافة القيمسيضيف النتائج إلى الخصائص الموجودة في العنصر المختار.

أنظر أيضا

إضافة خصائص محددة مسبقا إلى مكون، الاتصال أو نوع | تغيير خصائص عنصر، الاتصال أو نوع | تقييم بنية بك


الفرق العمارة وتزامن

الملاحة: تحليل بنية بك>

الفرق العمارة وتزامن

إرسال التعليقات حول هذا الموضوع.

عندما يكون لديك 2 أو أكثر من أبنية، إما التطورات أو أبنية أساسية، يمكنك بصريا "مهرجان دبي السينمائي الدولي" البنى باستخدام اثنين كتالوج أو الرسم البياني مقارنة أو ميزة الفرق الهندسة المعمارية. هذا مفيد بشكل خاص لاكتشاف / التغييرات الدقيقة المصنوعة من العمارة إلى أخرى كما كنت تتطور البنى وتطوير خرائط طريق في ABACUS إعادة اكتشاف.

إلى عرض "مهرجان دبي السينمائي الدولي" مع العمارة آخر عن طريق رسم تخطيطي

1. ضمان لديك ملف ABACUS مفتوحة .

2. تضمن لك لديك 2 ما لا يقل عن أبنية في المشروع.

3. فتح الرسم البياني كنت ترغب في مقارنة لبنية أخرى.

4. انقر على زر "قارن هذا مخطط لمحتويات العمارة آخر" على شريط الأدوات مخطط.

5. اختيار العمارة أخرى من القائمة المنسدلة للمقارنة.

6. كما يمكنك تحديد ما هي الاختلافات تظهر من خلال النقر على زر 'الاختلاف' على شريط الأدوات مخطط وإلغاء تحديد الخيارات، على سبيل المثال تغيرت / واضاف / غير معروف و غير محدد / تزامن الموصى بها/ الحفاظ الموصى بها.

ملاحظة

وسيتم تسليط الضوء مكونات والاتصالات على الرسم البياني في أحمر, أخضر أو بنفسجي حيث هناك اختلافات بين محتوى غير مرئية على الرسم البياني الحالي والمضمون في العمارة أخرى. أحمر يستخدم فيها فمن المستحسن أن مزامنة الخلافات (أنظر أدناه)، أخضر يستخدم حيث لا ينصح لمزامنة الخلافات، وهذا هو الاحتفاظ بها (انظر أدناه)، و بنفسجي يستخدم حيث لا يمكن ABACUS تقديم توصية حول المزامنة الاختلافات (انظر أدناه). فقط مقارنة محتوى مرئي على الرسم حتى إذا كان الشرح يظهر قيمة خاصية مستودع وأن يتم تغيير قيمة عنصر معين أو سيتم عرض الاتصال في أحمر خافت, الأخضر خافت أو ضعاف الأرجواني ورمزا '*' هو موضح في الجزء العلوي الأيسر للمكونات، ولكن إذا تغيرت بعض قيمة العقار مستودع الأساسية الأخرى التي لا يتم عرض في الشرح ثم سيتم إعطاء أي إشارة. المحتوى الذي يحدث في المخطط الحالي ولكن سيتم عرض أي مباراة وجدت في الهندسة المعمارية المقارنة في أحمر قوي, أخضر قوي أو الأرجواني قويةورمز '+' أظهرت في الجزء العلوي الأيسر للمكونات. يتم مطابقة حسب نوع واسم عنصر بحيث إذا تم تغيير نوع أو اسم مكون أو الاتصال في العمارة أخرى سيتم العثور على أي تطابق. كما لا توجد وسيلة لتحديد موثوق ما إذا كان قد ثبت محتوى إضافي من الهندسة المعمارية الأخرى على الرسم البياني الحالي (على سبيل المثال واجهة إضافية بين 2 مكونات كما هو موضح أدناه في رسم تخطيطي من العمارة المقارنة على اليمين)، وهذه الاختلافات ليست تعرض لمخططات (يتم عرضها لكتالوجات حسب أدناه). وتحوم فوق كل عنصر متغير إظهار الفرق في تلميح الأدوات. تحوم فوق الرمز '*' في أعلى يسار الرسم البياني يقدم ملخصا للتغيرات (أو أي تغييرات) بين المحتوى والرسم ومحتويات العمارة أخرى.

اللون أسطورة

· أخضر يشير العناصر التي لا ينصح لمزامنة الخلافات، وهذا هو لابقائهم.

· أحمر يشير البنود التي يستحب للمزامنة الخلافات.

· بنفسجي يشير البنود التي لا يمكن ABACUS تقديم توصية حول المزامنة الخلافات.

إلى مزامنة ('مزامنة') المحتوى من الهندسة المعمارية واحد مع آخر عن طريق رسم تخطيطي

1. ضمان لديك ملف ABACUS مفتوحة .

2. تضمن لك لديك 2 ما لا يقل عن أبنية في المشروع.

3. فتح الرسم البياني كنت ترغب في مقارنة لبنية أخرى.

4. انقر على زر "قارن هذا كتالوج لمحتويات العمارة آخر" على شريط الأدوات رسم بياني.

5. اختيار العمارة أخرى من القائمة المنسدلة للمقارنة.

ملاحظة

انظر أعلاه للطريقة يظهر ABACUS في "مهرجان دبي السينمائي الدولي" بين أبنية 2 في الكتالوج. في كيفية معينة أحمر يستخدم حيث غيرأوصت لمزامنة الخلافات، أخضر يستخدم أين هو ليسأوصت لمزامنة الخلافات و بنفسجي يستخدم حيث لا يمكن ABACUS تقديم توصية حول المزامنة الخلافات.

6. بزر الماوس الأيمن فوق عنصر المخطط (أو العناصر باستخدام التحول أو قماش الرسم البياني لمزامنة جميع) يدل على "مهرجان دبي السينمائي الدولي"، ثم حدد عنصر القائمة المزامنة.

ملاحظة

لن يتم تطبيق أية تغييرات التزامن إلى العمارة التي ينتمي إليها حاليا في التركيز التسويقي. لتطبيق التغييرات إلى بنية أخرى يجب استخدام التسويقي في الهندسة المعمارية الأخرى. وعلاوة على ذلك، سوف يكون المستخدمون قادرين فقط لتطبيق التغييرات تزامن إذا كانت لديك إذن للقيام بذلك .

ملاحظة

واعتمادا على المكان الذي بزر الماوس الأيمن فوق عنصر القائمة عرض توجيهات بشأن ما يجري بالضبط لتكون متزامنة.مثلا بزر الماوس الأيمن فوق عنصر واحد في الرسم البياني سوف فقط مزامنة هذا المكون. في حين بزر الماوس الأيمن فوق قماش الرسم واختيار ومزامنة جميع مزامنة كافة الخلافات معروضة حاليا.

إلى عرض "مهرجان دبي السينمائي الدولي" مع العمارة آخر عن طريق كتالوج

1. ضمان لديك ملف ABACUS مفتوحة .

2. تضمن لك لديك 2 ما لا يقل عن أبنية في المشروع.

3. فتح النشرة المصورة التي ترغب في مقارنة لبنية أخرى.

4. انقر على زر "قارن هذا كتالوج لمحتويات العمارة آخر" على شريط الأدوات كتالوج.

5. اختيار العمارة أخرى من القائمة المنسدلة للمقارنة.

6. كما يمكنك تحديد ما هي الاختلافات تظهر من خلال النقر على زر 'الاختلاف' على شريط الأدوات مخطط وخيارات unselecting، على سبيل المثال تغيرت / واضاف / غير معروف و غير محدد / تزامن الموصى بها/ الحفاظ الموصى بها.

ملاحظة

وسيتم تسليط الضوء الخلايا في النشرة المصورة في أحمر, أخضر أو بنفسجي حيث هناك اختلافات بين المحتوى في فهرس الحالي ومحتوى مطابق في العمارة أخرى. أحمر يستخدم فيها فمن المستحسن أن مزامنة الخلافات (أنظر أدناه)، أخضر يستخدم حيث لا ينصح لمزامنة الخلافات، وهذا هو الاحتفاظ بها (انظر أدناه)، و بنفسجي يستخدم حيث لا يمكن ABACUS تقديم توصية حول المزامنة الاختلافات (انظر أدناه). فقط يتم مقارنة الصفوف والأعمدة مرئية في كتالوج لذلك إذا كان هناك فرق في صف واحد وراء الصفوف معروضة حاليا أو قيمة في العمود الذي لا يتم عرض ديه فارق ثم سوف تتم الإشارة إلى أي فرق. حيث القيمة في خلية فردية مختلفة مع الخلية مطابق في العمارة مقارنة سيتم تسليط الضوء الحدود الخلية. كما سيتم المظللة محدد رأس العمود والصف في ضعاف الأرجوانيوتظهر مع رمز '*'. يمكن النقر عليها هذه '* رموز للانتقال إلى الفرق المقبل في عمود أو صف على التوالي. وسوف يعرض الصفوف التي تحدث في الكتالوج الحالي ولكن تم العثور على أي مباراة في العمارة مقارنة مع رمز '+' في محدد الصف على اليسار وحدود الصف بأكمله سيتم تسليط الضوء عليها. وسيتم عرض الصفوف التي كانت ستحدث في الإصدار العمارة المقارنة من الكتالوج (أي بنفس مرشحات الخ) ولكن يتم العثور على أي مباراة في الهندسة المعمارية الحالية مع - الرمز في محدد الصف على اليسار، حدود '' وسيتم تسليط الضوء على الصف بأكمله وسوف يتم عرض محتويات الخلايا الصفوف بأكملها في ضعاف الأرجوانيوضرب من خلال، على سبيل المثال 08:00 حتي 06:00. يتم مطابقة حسب نوع واسم عنصر بحيث إذا تم تغيير نوع أو اسم مكون أو الاتصال في العمارة أخرى سيتم العثور على أي تطابق. وتحوم فوق كل عنصر متغير إظهار الفرق في تلميح الأدوات. تحوم فوق الرمز '*' في أعلى يسار الرسم البياني موجزا للتغيرات (أو أي تغييرات) بين المحتوى والرسم ومحتويات العمارة أخرى.

اللون أسطورة

· أخضر يشير العناصر التي لا ينصح لمزامنة الخلافات، وهذا هو لابقائهم.

· أحمر يشير البنود التي يستحب للمزامنة الخلافات.

· بنفسجي يشير البنود التي لا يمكن ABACUS تقديم توصية حول المزامنة الخلافات.

إلى مزامنة ('مزامنة') المحتوى من الهندسة المعمارية واحد مع آخر عبر كتالوج

1. ضمان لديك ملف ABACUS مفتوحة .

2. تضمن لك لديك 2 ما لا يقل عن أبنية في المشروع.

3. فتح النشرة المصورة التي ترغب في مقارنة لبنية أخرى.

4. انقر على زر "قارن هذا كتالوج لمحتويات العمارة آخر" على شريط الأدوات كتالوج.

5. اختيار العمارة أخرى من القائمة المنسدلة للمقارنة.

ملاحظة

انظر أعلاه للطريقة يظهر ABACUS في "مهرجان دبي السينمائي الدولي" بين أبنية 2 في الكتالوج. في كيفية معينة أحمر يستخدم حيث غيرأوصت لمزامنة الخلافات، أخضر يستخدم أين هو ليسأوصت لمزامنة الخلافات و بنفسجي يستخدم حيث لا يمكن ABACUS تقديم توصية حول المزامنة الخلافات.

6. بزر الماوس الأيمن فوق الخلية، عمود أو صف متجهة (أو سلع متعددة باستخدام التحول أو Ctrl + A لكل شيء) مما يدل على "مهرجان دبي السينمائي الدولي"، ثم حدد عنصر القائمة المزامنة.

ملاحظة

لن يتم تطبيق أية تغييرات التزامن إلى العمارة التي ينتمي إليها حاليا في التركيز التسويقي. لتطبيق التغييرات إلى بنية أخرى يجب استخدام التسويقي في الهندسة المعمارية الأخرى. وعلاوة على ذلك، سوف يكون المستخدمون قادرين فقط لتطبيق التغييرات تزامن إذا كانت لديك إذن للقيام بذلك .

ملاحظة

اعتمادا على المكان الذي بزر الماوس الأيمن (أي خلية أو عمود أو صف العنوان) وعنصر القائمة عرض توجيهات بشأن ما يجري بالضبط لتكون متزامنة.مثلا بزر الماوس الأيمن فوق خاصية واحدة أو الخلية مكون المرفقة في النشرة المصورة ومزامنة فقط تلك الممتلكات أو مكون المرفقة. في حين بزر الماوس الأيمن فوق صف عنوان (أو عناوين باستخدام التحول) سيتم مزامنة الصف بأكمله (أو الصفوف). النقر بالزر الأيمن ورأس العمود مزامنة جميع الخلافات في هذا العمود.

لعرض 'مهرجان دبي السينمائي الدولي'من 2 كامل أبنية

1. ضمان لديك ملف ABACUS مفتوحة .

2. تضمن لك لديك 2 ما لا يقل عن أبنية في المشروع.

3. اختار أدوات| الفرق العمارة ....

4. في مربع الحوار الذي يظهر حدد أولا / من وثانيا / للأبنية للمقارنة.

5. اضغط على حسنا زر.

الفرق العمارة

اللون أسطورة

· أخضريشير إلى أن عقدة أضيف في الثانية / العمارة.

· أحمريشير إلى أنه تم حذف عقدة في الثانية / العمارة.

· أزرقيشير إلى أن عقدة لديه سمات مختلفة (مثل الخصائص أو معايير) في الثانية / العمارة.

· أصفريشير إلى أن عقدة الخلافات في أبنائها في الثانية / لبنية ذلك ينبغي توسيع العقدة.

ملاحظة

يمكنك بزر الماوس الأيمن فوق و"عرض في مستكشف" على كافة العقد لرؤية تعطى التفاصيل ومزيد من المعلومات حول الاختلافات في لوحة ملخص الاختلافات عند تحديد عقدة.

أنظر أيضا

تحليل بنية بك | عرض مخطط زمن الاستجابة | عرض مصفوفة مخطط التشتت من أبنية بك تطورت | تطور فن العمارة الخاص


تغيير خصائص عنصر، الاتصال أو نوع

الملاحة: كثافات سكانية والعمارة الخاص> عقارات>

تغيير خصائص عنصر، الاتصال أو نوع

إرسال التعليقات حول هذا الموضوع.

خصائص وعادة ما تكون متطلبات النظام التي قمت بتعريفها، أو نتائج التقييمات ABACUS. (عندما يؤدي ABACUS تقييماته، فإنه يكتب الخصائص إلى الملف مرة أخرى.) وبعبارة أخرى، الخصائص هي الأشياء التي نعرف حول النظام الخاص بك، أو الأشياء التي تستخدم ABACUS لمعرفة ذلك.

لتغيير قيمة الخاصية عنصر، الاتصال أو نوع

1. انقرعلى المكون / اتصال / نوع (خصائصه سيعرض في إطار خصائص إلى اليمين).

2. انقرلتسليط الضوء على العقار الذي تريد تغييره.

3. اكتبقيمة جديدة.

مهم

أيضا، يتم تعريف العديد من الخصائص باستخدام المعايير . عن طريق تغيير خاصية داخل معيار، لا فقط تغيير الكائن الحالي، يمكنك أيضا تغيير رئيسي معيار (تحت معايير فيأعلى الشجرة). قبل القيام بذلك، تحقق ما المكونات الأخرى، وصلات أو أنواع يستخدمون معيار، لأن التغيير قد لا تكون ذات صلة لهم- يمكنك استخدام إطار المراجع لهذا.

تلميح

يمكنك تغيير خصائص اتصال من داخل الفرع مكونات الشجرة (والعكس بالعكس). لذلك، على سبيل المثال، إذا كنت تبحث في ما وصلات تعلق على عنصر، وكنت أدرك لديك لتغيير واحد، يمكنك.

لإضافة خصائص جديدة للعنصر أو اتصال (عبر نوع)

ملاحظة

لا يمكن إلا أن خصائص تضاف إلى أنواع ومكونات أو اتصالات من نوع "وراثة" تلك الخصائص.

1. انقرعلى نوع (خصائصه سيعرض في إطار خصائص إلى اليمين).

2. انقرعلى زر إضافة في الجزء العلوي من النافذة الملكية لإضافة صف في الجزء العلوي من الشبكة الملكية للخاصية الجديدة.

3. أضف اكتبللخاصية الجديدة.

4. أضف اسمللخاصية الجديدة.

5. أضف القيمة الافتراضيةللخاصية الجديدة.

6. أضف وحدةللخاصية الجديدة.

7. تعيين نوع البياناتللخاصية الجديدة.

ملاحظة

حقل نوع بيانات يمكن استخدامها لتقييد القيم الصالحة التي خاصية يمكن أن يكون. بمعنى أن؛ النص، صحيح، عشري، تاريخ / وقت، منطقية أو قائمة.

o A نصالخاصية هي واحدة يحتوي على عدد غير محدود من الشخصيات وليس لديها قيود على قيمة أساسا.إذا كانت قيمة العقار ارتباط تشعبي تشكيلها بشكل صحيح (أي عناوين تحتاج لتبدأ واحدة من 5سلاسل؛ HTTP: // أو https: //، وبروتوكول نقل الملفات: //, ملف:أو \\ وأييجب إدخال مساحات مع '٪ 20') ثم الارتباط نقر (عن طريق السيطرة + نقرة).

o ل عدد صحيحيجب أن يكون العقار رقم كله إما إيجابية أو سلبيةويمكن أن تحتوي على نقطة، والفضاء، الفاصلة أو فاصلة لتجميع الأرقام تبعا لفي المشروع إعدادات المنطقة من عند ملف | خيارات المشروع.إعدادات المنطقة و.صافي طريقة Long.TryParse غير تستخدم لتحديد صالحة عدد صحيح القيم.

o A عدد عشرييمكن أن تحتوي العقار فترة أو فاصلة لالرمز العشري وربما تحتوي على نقطة، والفضاء، الفاصلة أو فاصلة لتجميع الأرقام تبعا لفي المشروع إعدادات المنطقة من عند ملف | خيارات المشروع.إعدادات المنطقة و.صافي طريقة Decimal.TryParse غير تستخدم لتحديد صالحة عدد عشري القيم.

o A تاريخ / وقتتسمح المنشأة إما التسجيل جزء أو دوام جزئي أو كليهما. المنطقة إعداداتوصافي طريقة DateTime.TryParse تستخدم أساسا لتحديد تاريخ و / أو وقت القيم الصالحة. ومع ذلك، فإن تاريخ جزءا جدت يتطلب على الأقل يوم و(سيتم يفترض السنة أن تكون السنة الحالية) الشهر أو الشهر والسنة أجزاء لتكون صالحة. أي. يونيو، Q3 2010 أو حتى 2010 فقط غير صالحة. في حين أنه لن تختلف مع إعدادات إقليمية مختلفة، وعادة يوم والشهر والسنة أجزاء يمكن فصلها مع الفضاء، فاصلة، شرطة ('-') أو مائل ('/'). الجزء يوم عادة هو عدد صحيح من 1 إلى 31. الجزء شهر عادة عدد صحيح من 1 إلى 12، صالح اختصار 3 إلكتروني للأشهر (مثل يناير، فبراير، مارس) أو اسم شهر كامل (على سبيل المثال يناير، فبراير ، مارس، يسير، يتقدم). الجزء السنة هو عادة رقم موجب 4 أرقام لكن 1، وتقبل 2 و 3 سنوات وفقا لأرقام الإعدادات في لوحة التحكم-> الإقليمية واللغة خيارات> خيارات- الإقليمي <تخصيص (زر) -> Date-> التقويم. وعادة ما يتم تفسيرها على النحو التالي؛ يتم تفسير 0-29 كما 2000-2029، 30-99 كما 1930-1999 و100-999 كما 100-999. سوف يتم الكشف عن التواريخ غير صالحة مثل 31 يونيو 2010 و31/9/2010. الجزء الوقت إن وجدت يتطلب ساعات والدقائق جزءا اختياريا وجزء ثواني. هي الساعات والدقائق والثواني أجزاء اختياري عادة فصل بنقطتين (':') والجزء ثانية يمكن أن تكون محددة مع العلامة العشرية ('.'). لمزيد من المعلومات حول تنسيقات صالحة يرجى الرجوع إلى قسم ملاحظات على صافي طريقة DateTime.TryParse .

تلميح

فمن المستحسن استخدام ما لا يقل عن تنسيق اسم شهر 3 حرف (أي "يوليو" أو "يوليو") لقيم التاريخ بدلا من التنسيق العددي (أي "7" أو "07")، وهذه القيم سوف تحقق عبر معظم مناطق اعتمادا على لمشروع إعدادات المنطقة من عند ملف | خيارات المشروع. أي. فمن المستحسن استخدام "15 يوليو 2010" بدلا من "15/7/2010" أو "2010/07/15". مع هذا المثال، "15/7/2010" ستفشل التحقق من صحة "الإنكليزية (الولايات المتحدة)" و "2010/07/15" ستفشل ل"الإنكليزية (المملكة المتحدة)، ولكن" 15 يوليو 2010 "ستمر ل كلاهما.

o A منطقيةالملكية يمكن أن تكون إما صحيح أو خطأ.فمن قضية حساسة صحيح جدا أو FALSE يمكن أن تستخدم أيضا ولكن نعم، لا، 1، 0 الخ سوف تفشل كل أية قيود الملكية.

o A قائمةتسمح المنشأة عبارة عن مجموعة من القيم المحددة مسبقا مثل منخفضة | المتوسط ​​| ارتفاع أو الاحتفاظ | تحديث | إعادة تصميم | التقاعد ومجموعة من القيم يأتي من حقل الوحدة للخاصية إما فاصلة أو أنبوب '|' قيم مفصولة. ويمكن اعتبار العقار ليكون ترتيبي (في مقابل الاسمي، الفاصل الزمني أو نسبة) لأنه عند استخدامها على الرسوم البيانية ولون العناصر على رسم بيانيالصورة و3DS يتم التعامل مع القيم ببساطة في تصاعدي (أو تنازلي) النظام. هذا هو يتم رسم القيم في الصعود (أو تنازلي) النظام على محاور التخطيط أو نطاقات اللون.

8. يمكن تعيين نوع البيانات لتكون تعطيل, حذر أو فرضبالنقر بزر الماوس الأيمن فوق الحقل نوع البيانات لأي مكان آخر من النص، والذي يسمح أي حرف لذلك لا يمكن أن يكون من أي وقت مضى غير صحيح.

9. تعيين مطلوبالعلم للخاصية الجديدة.

ملاحظة

حقل مطلوب يمكن استخدامها للإشارة إلى ما إذا كانت قيمة تحتاج إلى إدخالها للخاصية. هذا هو أنه لا يمكن أن تكون فارغة أو فارغة. خاطئةهو الافتراضي وتعني الملكية يمكن أن تكون فارغة أو فارغة، حقيقييعني أن الخاصية يجب أن يكون لها قيمة ولا يمكن أن تكون فارغة أو فارغة. المطلوب يمكن تعيين لتكون تعطيل, حذر أو فرضبالنقر بزر الماوس الأيمن فوق حقل مطلوب إذا كان قد تم تعيينها إلى True.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | إضافة خصائص محددة مسبقا إلى مكون، الاتصال أو نوع | خواص الركام


تغيير عنصر / نوع الاتصال في

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

تغيير عنصر / نوع الاتصال في

إرسال التعليقات حول هذا الموضوع.

وتستخدم أنواع عنصر والاتصال أساسا لأغراض التصنيف. يمكنك استخدام أنواع كمرشحات عند عرض الهندسة المعمارية الخاصة بك. على سبيل المثال، بدلا من مشاهدة كل شيء، يمكن أن تقوم بعرض مكونات التطبيق فقط.

لتغيير العنصر / نوع الاتصال في

1. انقر بزر الماوس الأيمنعلى العنصر أو اتصال.

2. اختار تغيير نوع.

3. اختيار نوع مختلف من القائمة.

تلميح

عند تغيير نوع، قد تحصل بعض جديدة المعاييرأو الممتلكات (كل ما يرتبط مع نوع - راجع فرع أنواع من شجرة). الموجودة لديك المعايير وخصائص ستبقى دون تغيير. يمكنك إنشاء أنواع جديدة الخاصة وتعيين مجموعات خاصة بك المعايير وخصائص لهم.

أنظر أيضا

خلق نوع جديد | يعيش سكان العمارة الخاص - نظرة عامة | تحليل العمارة بك


تغيير إعدادات المنطقة على المشروع

الملاحة: كثافات سكانية والعمارة الخاص> عقارات>

تغيير إعدادات المنطقة على المشروع

إرسال التعليقات حول هذا الموضوع.

قيم العقارات تتطلب التنسيق المتاح في مناطق مختلفة لتتناسب مع أي قيود نوع البيانات لعدد صحيح، عشري والتاريخ / الوقت الخصائص. على سبيل المثال في استراليا عشري "123456 نقطة سبعة ثمانية تسعة" يتمثل ب "123،456.789"، بينما في ألمانيا أنه سيكون represnted باسم "123.456،789" في فرنسا وانه سيكون " 123 456789 ".وبالمثل، في الولايات المتحدة في "الثاني من ديسمبر 1970" يمثل موعدا قصيرة باسم "1970/12/02" ولكن في المملكة المتحدة ويمثل ذلك بأنه "1970/02/12" و في بولندا ب "1970-1912 -02 ". وفقا لذلك، والعمل مع مشروع ABACUS عبر المناطق مطلوب إعداد عمومي لكل مشروع ABACUS.

تغيير إعدادات منطقة مشروع ABACUS ل

1. ضمان لديك ملف ABACUS فتح.

2. اختار ملف | خيارات المشروع ... ومن مربع الحوار الذي يظهر حدد منطقةو انقر فوق موافق. ملاحظة: يرجى الرجوع إلى أدناه للحصول على الإعدادات الافتراضية الإقليمية.

ملاحظة

إذا كنت لا ترى خيارات المشروع ... عنصر القائمةثم لم يكن لديك مصمم والمسؤول إضافةsو لا يمكنك تغيير المنطقة للمشروع.أيضا، إذا تم تعيين أي المنطقة (أي منطقة في خيارات المشروع هو "بلا (منطقة نظام) ') ثم كل مايكروسوفت ويندوز الإعدادات الحالية ثقافة المستخدم (أي الإعدادات الإقليمية)تستخدم للتحقق من الخصائص.

التخلف المنطقة

يسرد الجدول التالي الافتراضات لكل منطقة على النحو المنصوص خلال ملف | خيارات المشروع ...عنصر القائمة.يرجى الاطلاع على الجدول أدناه للحصول على قائمة الرموز المستخدمة.

منطقة | رمز عشري | تجميع الأرقام | إشارة سلبية | وقت قصير | وقت طويل | AM / PM رمز | التاريخ القصير | تاريخ طويل
الإنجليزية (أستراليا) | . | , | - | HH: مم | HH: MM: SS | AM | مساء | DD / MM / س س س س | ي ي ش ش ش ش س س س س
الإنجليزية (المملكة المتحدة) | . | , | - | HH: مم | HH: MM: SS | AM | PM | DD / MM / س س س س | ي ي ش ش ش ش س س س س
انجليزية الولايات المتحدة) | . | , | - | ح: مم ترينيداد وتوباغو | ح: مم: ق ق ر ر | AM | PM | M / د / س س س س | DDDD، MMMM د د، س س س س
الفرنسية (فرنسا) | , | الفضاء | - | HH: مم | HH: MM: SS | | | DD / MM / س س س س | DDDD د ش ش ش ش س س س س
الألمانية (ألمانيا) | , | . | - | HH: مم | HH: MM: SS | | | dd.MM.yyyy | DDDD، د. MMMM س س س س
الإيطالية (إيطاليا) | , | . | - | HH: مم | HH: MM: SS | | | DD / MM / س س س س | DDDD د ش ش ش ش س س س س
الإسبانية (إسبانيا) | , | . | - | H: مم | H: MM: SS | | | DD / MM / س س س س | DDDD، ي 'دي' MMMM 'دي' س س س س
الإنكليزية (كندا) | . | , | - | ح: مم ترينيداد وتوباغو | ح: مم: ق ق ر ر | AM | PM | DD / MM / س س س س | MMMM-DD-yyyy إنهاء
الفرنسية (كندا) | , | الفضاء | - | HH: مم | HH: MM: SS | | | س س س س-MM-DD | د MMMM س س س س
العربية (الإمارات العربية المتحدة.) | . | , | - | صاحب السمو: مم ترينيداد وتوباغو | HH: MM: SS ترينيداد وتوباغو | ص | م | DD / MM / س س س س | ي ي ش ش ش ش، س س س س
العربية (المملكة العربية السعودية) | . | , | - | صاحب السمو: مم ترينيداد وتوباغو | HH: MM: SS ترينيداد وتوباغو | ص | م | يوم / شهر / سنة | ي / ش ش ش ش / س س س س
الإنكليزية (جنوب أفريقيا) | , | الفضاء | - | صاحب السمو: مم ترينيداد وتوباغو | HH: MM: SS ترينيداد وتوباغو | AM | PM | س س س س / MM / DD | ي ي ش ش ش ش س س س س
الإنجليزية (نيوزيلندا) | . | , | - | ح: مم ترينيداد وتوباغو | ح: مم: ق ق ر ر | صباح | عصرا. | د / MM / س س س س | DDDD، د MMMM س س س س
الإنجليزية (الهند) | . | , | - | HH: مم | HH: MM: SS | AM | PM | DD-MM-س س س س | ي ي ش ش ش ش س س س س
الألمانية (سويسرا) | . | ' | - | HH: مم | HH: MM: SS | | | dd.MM.yyyy | DDDD، د. MMMM س س س س
الفرنسية (بلجيكا) | , | . | - | HH: مم | HH: MM: SS | | | د / MM / س س س س | DDDD د ش ش ش ش س س س س
الهولندية (بلجيكا) | , | . | - | H: مم | H: MM: SS | | | د / MM / س س س س | DDDD د ش ش ش ش س س س س
التشيكية (جمهورية التشيك) | , | الفضاء | - | H: مم | H: MM: SS | DOP |. استنفاد الأوزون. | d.M.yyyy | د. MMMM س س س س
الدانماركية (الدنمارك) | , | . | - | HH: مم | HH: MM: SS | | | DD-MM-س س س س | د. MMMM س س س س
اليونانية (اليونان) | , | . | - | ح: مم ترينيداد وتوباغو | ح: مم: ق ق ر ر | πμ | μμ | د / M / س س س س | DDDD، د MMMM س س س س
الفنلندية (فنلندا) | , | الفضاء | - | H: مم | H: MM: SS | | | d.M.yyyy | د. س س س س MMMM'ta "
الهنغارية (المجر) | , | الفضاء | - | H: مم | H: MM: SS | دي |. دو. | yyyy.MM.dd. | س س س س. MMMM د.
الهولندية (هولندا) | , | . | - | H: مم | H: MM: SS | | | د-M-سنة | DDDD د ش ش ش ش س س س س
النرويجية، النرويجية (النرويج) | , | الفضاء | - | HH: مم | HH: MM: SS | | | dd.MM.yyyy | د. MMMM س س س س
البولندية (بولندا) | , | الفضاء | - | HH: مم | HH: MM: SS | | | س س س س-MM-DD | د MMMM س س س س
الروسية (روسيا) | , | الفضاء | - | H: مم | H: MM: SS | | | dd.MM.yyyy | د MMMM س س س س "г."
السويدية (السويد) | , | الفضاء | - | HH: مم | HH: MM: SS | | | س س س س-MM-DD | "دن" د ش ش ش ش س س س س
كوريا (كوريا) | . | , | - | ترينيداد وتوباغو ح: مم | ترينيداد وتوباغو ح: MM: SS | 오전 | 오후 | س س س س-MM-DD | س س س س "년 'M' 월 'د' 일" DDDD
العبرية (إسرائيل) | . | , | - | HH: مم | HH: MM: SS | AM | PM | DD / MM / س س س س | DDDD ي ي ش ش ش ش س س س س

يتم استخدام الرموز التالية لتحديد كيف يتم عرض التواريخ والأوقات:

رموز الوقت |
h | ساعة (ح ح يعرض ساعة مع صفر بادئ)
m | الدقيقة (مم يعرض دقيقة مع صفر بادئ)
s | الثانية (يعرض SS الثاني مع إحدى الشركات الرائدة في صفر)
ترينيداد وتوباغو | صباحا أو مساء
ح / H | عرض الوقت 12 أو 24 ساعة
تاريخ الرموز |
د، ي | يوم
DDD، DDDD | يوم من أيام الأسبوع
M | شهر
y | سنة

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | تغيير خصائص عنصر، الاتصال أو نوع | إضافة خصائص محددة مسبقا إلى مكون، الاتصال أو نوع


خيارات سطر الأوامر

الملاحة: مرجع>

خيارات سطر الأوامر

إرسال التعليقات حول هذا الموضوع.

يمكنك تنفيذ مختلف العمليات ABACUS مباشرة من سطر الأوامر مع العملية الأكثر شيوعا هي فتح ملف مشروع معين ونشره إلى HTML.

على وجه التحديد، استخدام سطر الأوامر من ABACUS هو على النحو التالي؛

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ المستخدم "USER" / تمر "PASS"]

جدال | الوصف
ProjectFile | وProjectFile يمكن أن تكون إما ملف ABACUS مشروع (.abacus)، ملف مكتبة (.abacuslib)، ملف XML (. XML) أو MS الوصول DB (.MDB) وعلى الملف المحدد إما أن فتح (إذا .abacus أو .abacuslib ) أو مشروع جديد تم إنشاؤه (إذا XML أو ملف .MDB).
OptionalFile | وOptionalFile يمكن أن يكون إما النصي ABACUS (.abacusscript، .vb أو .cs)، الماكرو (.abacusmac) أو ملف مكتبة (.abacuslib) وعلى الملف المحدد إما أن يتم تشغيلها بعد فتح ProjectFile (إذا .abacusscript، .vb أو .cs أو .abacusmac) أو ببساطة فتحت (إذا .abacuslib).
/ exitOnCompletion | سيتم إنهاء ABACUS وإذا لزم الأمر حفظ وارتكاب أية تغييرات على مشاريع .abacus مفتوحة على الانتهاء من أي برنامج نصي أو الماكرو. ملاحظة: هذا العلم هو القضية الحساسة لذلك تأكد من استخدام 'O' الكبيرة و'C' في النص كما هو مبين.
/ dontShowDialogs | سيمنع ABACUS الطبعة المؤسسة (EE) الحوارات إعلام التحديث من الظهور عند فتح المشروع. ملاحظة: هذا العلم هو القضية الحساسة لذلك تأكد من استخدام الأحرف الكبيرة "S" و "D" في النص كما هو مبين.
/ المستخدم "USER" / تمرير "PASS" | سيتم استخدام اسم المستخدم وكلمة المرور PASS لتسجيل الدخول إلى المشروع مع، تجاوز أية بيانات اعتماد المستخدم المحفوظة. ملاحظة: يجب وضع علامات اقتباس مزدوجة حول USER PASS والأعلام ويمكن استخدامها اثنين من علامات الاقتباس المزدوجة للهروب التنصيص في المستخدم أو PASS الأعلام.

مثلا;

ABACUS.exe "البيانات \ Example.abacus" "النصية \PublishExample.رموز"/ exitOnCompletion / dontShowDialogs / المستخدم "العامة" / تمرير "123456"

متى تشغيل من الدليل حيث ال ABACUS.exe ثنائي غير تقع سوف فتح المشروع مثال وتسجيل الدخول باسم المستخدم مع كلمة السر ملفه 123456 (كما هو موضح هنا ) ونشره إلى HTML ثم قم بإغلاق المشروع جميع دون أن تظهر أية مربعات حوار على طول الطريق (على سبيل المثال 'التحديث بنجاح' أو 'لا توجد تحديثات متاحة "لمشاريع المؤسسة).

مثلا;

ABACUS.exe "البيانات \ Example.abacus" "النصية \كتالوج التفوق استيراد.رموز"/ exitOnCompletion / dontShowDialogs

متى تشغيل من الدليل حيث ال ABACUS.exe ثنائي غير تقع سوف فتح المشروع مثال واستيراد "خوادم (2014 الفعلية). XLSX" ملف MS Excel إلى كتالوج "خوادم" من "2014 الفعلية" الهندسة المعمارية للمشروع دون أن تظهر أية مربعات حوار على طول الطريق ومن ثم إغلاق المشروع على الانتهاء. إذا كانت العملية بإجراء تغييرات على المشروع ثم عند إغلاق يتم حفظ التغييرات محليا وإذا ارتكب مشروع المؤسسة إلى خادم المؤسسة.

ملاحظة

تأكد من استخدام حرف اقتباس مزدوجة الصحيح كما أن هناك عدة في معيار مجموعة أحرف ASCII ويندوز موجه الأوامر فقط ستعمل بشكل صحيح مع واحدة صحيحة. المزدوج رمز الحرف الاقتباس الصحيح هو عشري 34 (عشري 22).هذا هو ما يستخدم في المثال أعلاه لذا لا تتردد في نسخ / لصق من هناك.


النسخ واللصق

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

النسخ واللصق

إرسال التعليقات حول هذا الموضوع.

يمكنك نسخ كل أو جزء من العمارة ولصقه في موقع مختلف في الشجرة.

لنسخ

1. انقر بزر الماوس الأيمنعلى هذا البند كنت ترغب في نسخها.

2. اختار نسخ.

للصق

1. انتقل الشجرة للعثور على المكان الذي ترغب في لصق العنصر.

2. انقر بزر الماوس الأيمنعلى الفرع الذي تريده أن يظهر في الداخل.

3. اختار لصق.

4. سيتم نسخ هذا البند مع الاسم الأصلي (إلا إذا قمت بنسخه إلى فرع الأصلي - ثم سوف يطلق عليه 'نسخ من ...').

أنظر أيضا

كيفية بنية ممثلة في ABACUS


الرسوم البيانية النسخ

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

الرسوم البيانية النسخ

إرسال التعليقات حول هذا الموضوع.

هناك 2 السيناريوهات الأساسية لنسخ مخطط القائمة؛ داخل العمارة، أو عبر أبنية.

إلى نسخرسم تخطيطيداخل العمارة

1. ضمان لديكملف ABACUS مفتوحةتحتوي بك العمارة بالسكانمع واحد على الأقل رسم بياني.

2. توسيع ال الرسوم البيانية فرع (وأي مطلوب مجموعة الرسم) من معين هندسة معماريةقسم من شجرة.

3. حدد الرسم الذي تريد نسخه ثم اضغط CTRL + C أو انقر بزر الماوس الأيمنوحدد نسخ من القائمة.

ملاحظة

A نسخة من سيتم إضافة رسم بياني ل الرسوم البيانيةفرع لل نفسه هندسة معمارية. سيكون لديها "نسخ من" إلحاق بداية اسم، والتي يمكنك تغيير في وقت لاحق F2 الضغط أو النقر بزر الماوس الأيمن على ذلكواختيار إعادة تسمية.

إلى نسخ رسم تخطيطي عبر أبنية

1. ضمان لديكملف ABACUS مفتوحةتحتوي بك العمارة بالسكانsمع واحد على الأقل رسم بياني.

2. توسيع ال الرسوم البيانية فرع (وأي مطلوب مجموعة الرسم) من ال هندسة معماريةقسم من شجرةلبنية الذي يحتوي على الرسم البياني التي ترغب في نسخها.

3. حدد الرسم الذي تريد نسخه وعلى خصائص عامةنافذة مذكرة وجهة نظر أن المخطط مرتبط (في مجال النوع).

4. الآن، وسع ال الرسوم البيانية فرع (وأي مطلوب مجموعة الرسم) من ال هندسة معماريةقسم من شجرةلبنية الأخرى التي ترغب في نسخ الرسم البياني إلى.

5. انقر بزر الماوس الأيمن ال الرسوم البيانية عقدة (أو مجموعة الرسم) وحدد إنشاء مخطط .... في مربع الحوار الذي يظهر حدد وجهة نظر الذي سجلته في الخطوة 3 أعلاه في القائمة المنسدلة في أعلى اليمين. ترك كل شيء كما هو وانقر حسنا. في مربع الحوار مخطط اسم إدخال اسم لل(ليكون قريبا) نسخ الرسم. ملاحظة: سيتم فتح قماش الرسم فارغة وفقا لوجهة نظر المختار.

6. العودة إلى الرسم البياني الذي ترغب في نسخ وفتح ذلك عن طريق النقر بزر الماوس الأيمنالعقدة واختيار فتح أو ببساطة النقر المزدوجذلك.

7. حدد الخلفية قماش الرسم التخطيطي كنت ترغب في نسخ والصحافة CTRL + A. سيؤدي هذا إلى تحديد كل العناصر على هذا المخطط. الآن اضغط CTRL + Cلنسخ المحتوى إلى الحافظة.

8. الآن، والعودة إلى الرسم البياني فارغ في العمارة كنت ترغب في نسخ المحتوى إلى، حدد الخلفيةقماش وإما انقر بزر الماوس الأيمنوحدد لصق أو لمجرد الضغط CTRL + Vللصق المحتوى. بعد فترة وجيزة وسوف تكون جميع لصق محتوى في مخطط جديد فارغ.

ملاحظة

سيتم إضافة عناصر إلى المستوى الأعلى من الهيكل الجديد، وسوف تحتاج إلى إعادة ترتيب أو اندمجت مع المحتوى الموجود وفقا لذلك.

أنظر أيضا

أداة الرسم | يعيش سكان العمارة بك | تحليل العمارة بك


إنشاء عنصر جديد / نوع الاتصال أو نوع المجموعة

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

إنشاء عنصر جديد / نوع الاتصال أو نوع المجموعة

إرسال التعليقات حول هذا الموضوع.

وتستخدم أنواع عنصر والاتصال أساسا لأغراض التصنيف. يمكنك استخدام أنواع كمرشحات عند عرض الهندسة المعمارية الخاصة بك. على سبيل المثال، بدلا من مشاهدة كل شيء، يمكن أن تقوم بعرض مكونات التطبيق فقط.

لإنشاء عنصر جديد / نوع اتصال

ملاحظة

لإضافة أنواع أو مجموعات نوع في مشروع ABACUS ترخيص المستخدم يحتاج مصمم إضافة على القدرة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

1. توسيع أنواعفرع الشجرة.

2. انقر بزر الماوس الأيمن على أنواع المكونات (أو أنواع الاتصال).

3. اختار إضافة نوع مكون (أو إضافة نوع الاتصال) أو إنشاء مجموعة.

تلميح

مرة واحدة كنت قد خلقت نوع، يجب عليك تغيير الرمز الخاص به (انظر أدناه)، وإضافة الخصائص و المعايير لذلك لمكون أو حالات الاتصال "وراثة".

لتغيير رمز لمكون / نوع اتصال

ملاحظة

لتغيير الرموز لأنواع في مشروع ABACUS ترخيص المستخدم يحتاج مصمم إضافة على القدرة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

1. انقر بزر الماوس الأيمنعلى مكون النوع (أو نوع الاتصال) كنت ترغب في تغيير رمز.

2. اختار تغيير أيقونة.

3. في استعراض الحوار تحديد أيقونة للموقع واختيار ملف الصورة ثم انقر فوق فتح.

ملاحظة

هل يمكن أن يكون صورة رمز مخصص من أي حجم ولكن دائما يمكن تحجيمها لتناسب إلى صورة 16X16 بكسل في إطار مستكشف. حتى إذا كان لديك الأصلي صورة رمز مخصص ليست المتساوية في الارتفاع والعرض سوف تمدد رمز إطار مستكشف الخاصة بك. وفقا لذلك، يجب أن تكون الصور المخصصة 16X16 بكسل على الأقل، وإذا كنت ترغب في الاحتفاظ الشكل الدقيق لرمز مخصص تأكد من صورتك رمز مخصص يساوي الطول والعرض بالبكسل (16X16 أو أكبر). يجب عليك أيضا أن تكون حذرا حول عدم وجود الملونة "بكسل" تسير على طول الطريق إلى الحدود للصورة رمز مخصص لأنها سوف ننظر الفقراء في إطار مستكشف مع رموز المجاورة "النزيف" إلى بعضها البعض. وفقا لذلك، يجب أن تترك ما لا يقل عن حدود بيضاء 1 بكسل.

تلميح

يمكنك ان تجعل صورتك رمز مخصص لمنظمة البن الدولية، BMP. أو gif و jpg أو تنسيق ملف بابوا نيو غينيا ولكن بسبب وجود قيود في نظام التشغيل Windows شكل منظمة البن الدولية فقط والمعاينة في الحوار ABACUS اختر أيقونة إذا كان لديك الخيار عرض القائمة تحديد إلى أي شيء آخر من الصور المصغرة.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | تحليل العمارة بك


إنشاء أو تكرار بنية

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

إنشاء أو تكرار بنية

إرسال التعليقات حول هذا الموضوع.

هل يمكن أن يكون أي عدد من أبنية في ملف ABACUS واحد. عادة، سوف تقوم بإنشاء بنية جديدة في كل مرة تريد نموذج وتقييم تطور النظام الخاص بك.

لخلق بنية جديدة

1. انقر بزر الماوس الأيمنعلى أبنيةفرع الشجرة.

2. اختار العمارة جديدة.

لإنشاء نسخة من بنية القائمة

1. انقر بزر الماوس الأيمنعلى الهندسة المعمارية.

2. اختار نسخ.

3. انقر بزر الماوس الأيمنعلى أبنيةفرع الشجرة.

4. اختار لصق.

5. وسوف يطلق على الهيكل الجديد "نسخة من ... '.

أن تتطور بنية القائمة

1. انقر بزر الماوس الأيمنعلى الهندسة المعمارية.

2. اختار تتطور.

3. وسوف يطلق على الهيكل الجديد '... 0.1.

ملاحظة

هناك وصفا مفصلا عن أبنية المتطورة هنا .

أنظر أيضا

كيفية بنية ممثلة في ABACUS | تطور فن العمارة الخاص


تقارير مخصصة

الملاحة: الإبلاغ عن الهندسة المعمارية بك>

تقارير مخصصة

إرسال التعليقات حول هذا الموضوع.

تسمح تقارير مخصصة ABACUS 'لك لإنشاء تقارير مخصصة شكلي تماما. ويمكن أن تشمل تقارير الصور والرسومات المخصصة وكذلك تفاصيل أي مكون من مكونات، وصلات أو سمات من مستودع ABACUS فضلا عن النتائج التحليلية المفصلة من مختلف المحاكاة (بما في ذلك TCO والأداء والموثوقية). بالإضافة إلى ذلك، يمكن أن تحتوي التقارير والرسوم البيانية والرسوم البيانية، والفهارس، المصفوفات / الجداول المحورية، وخرائط، وأجهزة القياس، sparklines والحانات البيانات والمؤشرات (على سبيل المثال حركة أضواء).

ملاحظة

في حين يمكن لأي مستخدم فتح تقارير مخصصة القائمة، رس تكوين تقارير يحتاج ترخيص المستخدم تقرير التكوين القدرة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

لعرض عرف تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان(الصورة).

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةسيتم عرض نافذة.

تقارير مخصصةنافذة

3. حدد موجود تقريرالذي تريد لعرضهم من تقارير المتاحة قسم.

4. انقر تشغيل التقرير.سيتم فتح التقرير في Microsoft تقرير عارض ورس انتقل من خلال صفحات التقرير، انقر على الرموز [image] تقع على شريط الأدوات في أعلى الزاوية اليسرى من الشاشة.

ملاحظة

انت تستطيع حفظ التقرير إلى أشكال مختلفة بالضغط على تصدير رمز التقرير [image] تقع في شريط الأدوات. يمكنك اختيار لتصدير في الأشكال التالية: تفوق, PDFو كلمة. الرجاء حفظ التقرير في الموقع المطلوب لاستخدامها لاحقا. إذا تم إجراء تغييرات على الهندسة المعمارية في مرحلة لاحقة، وسوف يكون التقرير الجديد إلى أن يتم إنشاء لتعكس التغييرات.

إلى تحرير البيانات مستودع التي يتم إرسالها إلى a عرف تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان(الصورة).

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةنافذة (ظاهر في الاعلى) سيتم عرض.

ملاحظة

في حين يمكن لأي مستخدم فتح تقارير مخصصة القائمة، رس تكوين البيانات التي يتم إرسالها إلى تقرير مخصص يحتاج ترخيص المستخدم تقرير التكوين القدرة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

3. حدد موجود تقريرالذي تريد لعرضهم من تقارير المتاحة قسم.

4. انقر طقم تحرير البيانات. ال محرر مجموعة البياناتسيتم عرض نافذة.ويظهر هذا الإطار مجموعة من مجموعات البيانات التي يجري إرسالها إلى تقرير مخصص. في المثال التالي هناك ثلاثة (3)؛

· مجموعة البيانات ApplicationProxy أن يتم تحديد كل التفاصيل لجميع مكونات التطبيق في '2015 الفعلية "العمارة (بما في ذلك الخصائص على معايير وأي مكون من مكونات المرفقة)،

· مجموعة بيانات TwoDViewProxy أن يتم تحديد واحد أو أكثر من المخططات حيث يطابق اسم 'التطبيق المناظر الطبيعية (أستراليا)'،

· مجموعة بيانات TargetProxy أن يتم تحديد كل التفاصيل لكافة الاتصالات المستهدفة في '2015 الفعلية "العمارة (بما في ذلك المكونات المرفقة).

محرر مجموعة البياناتنافذة

ملاحظة

سيتم استخدام اسم الاستعلام عن اسم الإدراجات في Microsoft منشئ التقرير (انظر أدناه). يحدد مجال تضمين ما إذا كانت مجموعة البيانات إما على عنصر واحد، مجموعة من العناصر، جميع أنواع المكونات وجميع أنواع الاتصال، واحد أو أكثر من البنى، واحد أو أكثر من مخططات أو واحد أو أكثر من المخططات البيانية. ل 'مجموعة من عناصر "مجموعات بيانات يتم توفير الزر تصفية التي عند النقر عليها يفتح العنصر تصفية النافذة التي تسمح لك لتطبيق عدة مرشحات للعودة العناصر الوحيدة من بعض البنى، و / أو لبعض أنواع، و / أو مع بعض المعايير ، و / أو تعلق على مكونات معينة، و / أو مع بعض الآباء والأمهات، و / أو في بعض المخططات، و / أو في بعض المخططات البيانية و / أو مع قيم العقارات معينة. لغيرها من أنواع مجموعة البيانات يتم توفير حقل الاسم واستخدام اختر زر يمكنك اختيار الكائن (ق) ليتم تضمينها مع مجموعة البيانات.

ملاحظة

يتم تخزين مجموعات البيانات فيالبيانات مجموعات ملف (.XML)مع نفس اسم الملف قاعدة كما لالمرتبطة ملف تعريف التقرير (.التجمع). حالة عدم وجود هذا الملف في محرر مجموعة البيانات وتعبئة تلقائيا مع أي أسماء الاستعلام الموجودة في ملف تعريف التقرير (.التجمع)والجديد البيانات مجموعات ملف (.XML)سيتم إنشاء مرة واحدة ويعرف أأ قائمة صالحة للاستفسار.

3. إذا كنت ترغب في حذف مجموعة البيانات الموجودة ثم حدد استعلام حذف زر.

4. إذا كنت ترغب في إضافة مجموعة بيانات جديدة ثم انقر فوق ل إضافة مجموعة بيانات جديدةزر وتكوين مجموعة البيانات وفقا للملاحظة أعلاه.

إلى إنشاء مخصص جديد تقرير(من قالب)

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان.

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةنافذة (ظاهر في الاعلى) سيتم عرض.

3. انقر جديد وحدد إما A4 - صورة, A4- المناظر الطبيعية, A3 - صورة, A3- المناظر الطبيعية, الولايات المتحدة الرسالة - صورة, رسالة الولايات المتحدة - المناظر الطبيعية, التابلويد الأمريكية - صورة أو التابلويد الولايات المتحدة - المناظر الطبيعيةاعتمادا على التوجه التقرير وحجم الورق الذي هو المطلوب.

4. انتقل إلى موقع لحفظ ملف تعريف تقرير (.rdl / .rdlc) وملف مجموعة البيانات مطابقة (. XML) وانقر حفظ. هذا سيضيف تقرير مخصص جديد إلى قسم التقارير المتوفرة من النافذة تقارير مخصصة وأنه يمكن فتحها أو تحريرها كما هو موضح أعلاه.

إلى إضافة مخصص موجود تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان.

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةنافذة (ظاهر في الاعلى) سيتم عرض.

3. انقر إضافة واستعرض وصولا إلى موقع ملف تعريف تقرير (.rdl / .rdlc) وانقر فتح. هذا سيضيف تقرير مخصص جديد إلى قسم التقارير المتوفرة من النافذة تقارير مخصصة وأنه يمكن فتحها أو تحريرها كما هو موضح أعلاه.

ملاحظة

ومن المفترض أن ملف مجموعة البيانات مطابقة (. XML) موجود في نفس الموقع مثل ملف تعريف التقرير.

إلى نسخ مخصصة موجودة تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان.

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةنافذة (ظاهر في الاعلى) سيتم عرض.

3. حدد موجود تقريرالذي تريد لنسخ من تقارير المتاحة قسم.

4. انقر نسخ ونسخة من التقرير المختار (اسمه 'نسخة من ...') ستضاف إلى قسم التقارير المتوفرة من النافذة تقارير مخصصة وأنه يمكن فتحها أو تحريرها كما هو موضح أعلاه.

ملاحظة

من خلال ذلك سوف تقوم بإنشاء نسخة من تقرير ل تقرير تعريف ملف (.rdl / .rdlc) وكذلك ل مطابقة ملف مجموعة البيانات (. XML)(إن وجد).

إلى إزالة مخصص موجود تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان.

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةنافذة (ظاهر في الاعلى) سيتم عرض.

3. حدد موجود تقريرالذي تريد لإزالة من تقارير المتاحةقسم وانقر إزالة.

ملاحظة

عند إزالة التقرير أنه لم يعد يظهر في قائمة التقرير. ومع ذلك، فإن هذا لا حذف تقرير تعريف التقرير ملف (.rdl / .rdlc) أو مجموعة البيانات ملف(. XML). إذا لزم الأمر، وحذف هذه الملفات لا يمكن أن يتحقق من خلال نظام الملفات.

إلى إعادة تسمية مخصص موجود تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان.

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةنافذة (ظاهر في الاعلى) سيتم عرض.

3. حدد موجود تقريرالذي تريد إعادة تسمية في ال تقارير المتاحةقسم وانقر إعادة تسمية.

4. أدخل اسما جديدا للتقرير.

ملاحظة

سيتم تسمية كل ملف تعريف تقرير (.rdl / .rdlc) وملف مجموعة البيانات مطابقة (. XML) وفقا ل.

إلى تحرير تصميم عرف تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان.

2. اختار أدخل| تقرير مخصصأو انقر على إنشاء تقرير مخصص زر في شريط الأدوات. ال تقارير مخصصةنافذة (ظاهر في الاعلى) سيتم عرض.

ملاحظة

في حين يمكن لأي مستخدم فتح تقارير مخصصة القائمة، رس تكوين تصميم وتقارير مخصصة يحتاج ترخيص المستخدم تقرير التكوين القدرة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.بالإضافة إلى ذلك، مايكروسوفت تقرير منشئ 3.0 هو مطلوب لتصميم التقارير ويمكن تحميلها مجانا من هنا .

3. حدد موجود تقريرالذي تريد لعرضهم من تقارير المتاحة قسم.

4. انقر تحرير تقرير.سيتم فتح التقرير في Microsoft تقرير منشئ 3.0. للحصول على تعليمات محددة وبعض "النصائح والحيل 'على بعض المهام أكثر شيوعا مع تصميم التقارير يرجى الرجوع إلى الأقسام التالية. للحصول على تعليمات عامة عن تصميم التقارير يرجى الرجوع إلى منشئ التقرير Microsoft صفحات 3.0 مساعدة هنا .

إضافة جداول لتقريرك

1. ضمان لديك ملف تقرير ABACUS مخصص الوضوح (.rdl / .rdlc) مفتوحة في Microsoft تقرير منشئ 3.0.

2. اختار ال أدخل التبويب في "الشريط" في الجزء العلوي، ثم انقر على جدول زرفي القسم المناطق البيانات وحدد إدراج جدول.

3. الآن اسحب المؤشرللموقف على القماش التقرير حيث تريد الزاوية العلوية اليسرى من الجدول إلى وضعها. انقر على قماش. افتراضيا ستضاف الجدول مع صف الرأس ثم مجموعة من التفاصيل (يستخدم مجموعة لتنظيم عرض مجموعة بيانات التقرير). لإزالة مجموعة، إما حذف صف أو حذف المجموعة صف في شريط الأدوات التجمع.

تلميحs

الصيغ / يتم تحريرها التعبير في خلايا الجدول عن طريق تحديد الخلية ثم بزر الماوس الأيمن فوق << EXPR >> النص واختيار التعبير .... يتم فرز الصفوف في الجدول باختيار الجدول ومن ثم تصفح وصولا الى اخرى -> حقل SortExpressions في لوحة خصائص والدخول تعبير. لصف الإجمالي في نهاية جدول إضافة صف بعد (وخارجها) التجمع ثم استخدام التعبير التالي = SUM (الحقول!اسم.القيمة)حيث 'اسم' هو الحقل الذي بلغ. لتطبيق التلوين لاستخدام الأعمدة في "معهد التمويل الدولي" في بيان BackgroundColor خاصية. لإضافة مقياس بمثابة خلية في الجدول أولا إدراج مقياس في خلية ومن ثم انخفاض حقول البيانات المطلوبة للقياس. عند تحرير ارتفاع والاعراض من صفوف الجدول، تأكد من تحديد الصف الصحيح، ومن ثم مرر مؤشر الماوس الخاص بك حول خطوط رمادية حتى تحصل على السهم لأعلى / أسفل المؤشر، ثم تغيير حجمه.

مضيفا المخططات البيانية لتقريرك

1. ضمان لديك ملف تعريف تقرير ABACUS مخصص (.rdl / .rdlc) مفتوحة في Microsoft تقرير منشئ 3.0.

2. اختار ال أدخل التبويب في "الشريط" في الجزء العلوي، ثم انقر على الرسم البياني زرفي القسم المناطق البيانات وحدد إدراج الرسم البياني.

3. الآن اسحب المؤشرللموقف على القماش التقرير حيث تريد الزاوية العلوية اليسرى من التخطيط إلى وضعها. انقر على قماش وثم اختر الرسم البيانيالتي تحتاجها من الخيارات وانقر حسنا.

تلميحs

لعرض ممتلكات باعتبارها الشرح على الخرائط، انقر بزر الماوس الأيمن على الرسم البياني وتحديد تسميات إظهار البيانات، ثم اختيار واحد من التسميات التي تم إضافتها وتعيين متفرقات -> UseValueAsLabel إلى خطأ في لوحة خصائص وإضافة تعبير (على سبيل المثال = Name.Value الحقول) في متفرقات -> العلامة. خصيصا ل الرسوم البيانية فقاعة؛ يتم عرض الرسوم البيانية فقاعة تحت عنوان مبعثر الرسم البياني. إسقاط X محور الملكية في حقول السلسلة (أو إضافة في خصائص السلسلة). إسقاط Y محور الملكية في حقول البيانات (أو إضافة في خصائص السلسلة). استخدام خاصية لتحديد حجم فقاعة، إسقاط هذا في حقول البيانات (أو إضافة في خصائص السلسلة). الرسوم البيانية فقاعة غير قادرة على عرض إذا كان هناك الكثير من البيانات (200+ البنود)، وأحيانا يؤدي هذا التقرير بأكمله لعدم عرضه. نوع علامة - تعيين إلى الدائرة. افتراضيا، عند إسقاط الحقول إلى حقول البيانات، فإنه يضيف لهم مجموع()الصيغة، لذلك إزالة هذا. خصيصا ل الرسوم البيانية مكدسة / الجدول الزمني / مخططات جانت؛ لمخطط جانت استخدام الرسم البياني نطاق وإضافة خصائص كقيم العالية والمنخفضة في حقول البيانات. هل يمكن أن يكون متعددة "الحانات" عن طريق إضافة المزيد والمزيد من النطاقات، حيث تبلغ قيمة منخفضة لأحد تطابق قيمة عالية لآخر. خصيصا ل الرسوم البيانية الدائرية؛ لالرسوم البيانية الدائرية الإجمالية، إسقاط البيانات إلى الفئة المجالات وفي مجالات البيانات، إضافة الصيغة = CountRows (). تصفية أي القيم 0 (مثلا على الخرائط التكلفة)، وإلا التسميات لهذه لا تزال تظهر على الرسم البياني.

باستخدام عبارة معهد التمويل الدولي لإضافة الألوان إلى الجداول والرسوم البيانية

1. ضمان لديك ملف تعريف تقرير ABACUS مخصص (.rdl / .rdlc) مفتوحة في Microsoft تقرير منشئ 3.0.

2. بزر الماوس الأيمن فوق خلية في الجدول للون والنقر خصائص مربع النص.

3. اختار تعبئة وانقر على الفوركسزر على يمين التسمية لون التعبئة وفي مجموعة تعبير لحقل BackgroundColor يدخل تعبير، على سبيل المثال = معهد التمويل الدولي (الحقول! InformationStatus.Value = "الاحتفاظ"، "LightGreen"، معهد التمويل الدولي (الحقول! InformationStatus.Value = "إعادة تصميم"، "الأصفر"، معهد التمويل الدولي (الحقول! InformationStatus.Value = "تحديث"، "أورانج"، " سمك السلمون"))). هذا يغير لون الخلفية إلى اللون الأخضر الفاتح لكل خلية التي تحتوي على حالة "الاحتفاظ"، الصفراء لكل خلية التي تحتوي على الحالة "إعادة تصميم"، البرتقال سوف تكون ملونة لكل خلية التي تحتوي على حالة "تحميل" وأي قيمة حالة أخرى في "سالمون".

ملاحظة

الألوان يمكن أن تضاف للالخرائط عن طريق تحديد سلسلة على الرسم البياني ثم تحديد المظهر -> الملكية اللون (أو الخرائط فقاعة المظهر -> ماركر -> الملكية اللون) للتعبير مشابه للمثال المذكور أعلاه.

أشياء يمكن أن تضع في الاعتبار عند تصميم التقارير المخصصة

· لأنه يتم إرسال كافة خصائص باستثناء عدد صحيح كسلسلة من ABACUS للمشاهد التقرير إذا كنت تريد أن تفعل أي "تعبيرات" معهم (مثل الفجوة الملكية واحدا تلو آخر أو نوع) تحتاج إلى تحويلها إلى عشري أو التسجيل غيرها للحصول على الخلفية ، هذه المقالة هي إشارة جيدة. مثلا = CDate (الحقول! LifecycleEndDate.Value) ملاحظة: يرجى التأكد من أن يتم تعيين لغة التقرير إلى EN-GB (كما هو موضح أدناه) لقبول يوم / شهر / سنة كما تتوقع تنسيق ملم / يوم / سنة افتراضيا، وبالتالي ستفشل 31/7/2011 التحويل. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (CostTotalCosttoOwnnext5years.Value الحقول!، 0)

· إذا وجدت أن كنت تناضل من أجل الحفاظ على كل من الجداول والرسوم البيانية على صفحة واحدة، وهناك عدد قليل من الطرق الرئيسية لإدارة الفضاء المستند:

· استراحة الصفحة - التأكد من أن هذا الإعداد الجدول هو خارج عن كل الجدول الذي ترغب في أن تكون على نفس الصفحة.

· الاحتفاظ معا - تأكد من هذا الإعداد الجدول هو صحيح لكل جدول التي ترغب في أن تكون على نفس الصفحة.

· عندما تتحرك الامور، فمن الأسهل للتصغير باستخدام جهاز التحكم في أسفل اليمين من الصفحة ثم متعددة العناصر والسحب حدد

· للصف الصورة في الجدول، تأكد من أن "الحجم" | تم تعيين "تحجيم" الملكية إلى 'صالح' وإلا فإن الصورة قد تبدو كبيرة جدا، أو أنها سوف تمتد بشكل سيئ.

· إلى تكرار صف رأس جدول في كل صفحةمن التقرير:

1. الوضع المتقدم مفتوحة في الجزء التجمعات. (انقر على السهم الموجود على يمين العمود المجموعات وتحديد الوضع المتقدم).

2. وفي مجال المجموعات صف (مجموعات لا عمود)، انقر على مجموعة ثابتة، الذي يسلط الضوء على نص المقابلة في tablix. من خلال النقر كل مجموعة ثابتة حتى يسلط الضوء على رأس العمود أقصى اليمين. هذا هو عادة أول مجموعة ثابتة المدرجة.

3. في إطار خصائص تعيين الخاصية RepeatOnNewPage إلى True.

4. تأكد من أن يتم تعيين الخاصية إلى KeepWithGroup بعد.

· تغيير اعدادات اللغةفي خصائص تقرير لتتناسب مع الأشكال البيانات التي تحتاجها، على سبيل المثال EN-GB لإنتاج UK تنسيق التاريخ (يوم / شهر / سنة).

أنظر أيضا

تحليل بنية بك


Customising واجهة ABACUS

الملاحة: مقدمة في ABACUS>

Customising واجهة ABACUS

إرسال التعليقات حول هذا الموضوع.

يمكنك تغيير مظهر وسلوك واجهة ABACUS بطرق عديدة. يشمل ABACUS عدة مجموعات إعدادات محددة مسبقا التي يمكنك استخدامها لتطبيق مجموعة من تخصيصات إلى الواجهة. وبالإضافة إلى ذلك، يمكنك إجراء تخصيصات الفردية لعناصر مثل ويندوز، وأشرطة، مفاتيح الاختصار، وخيارات شاشات العرض المختلفة.

ترتيب وحوض ويندوز

لديك العديد من الخيارات لترتيب النوافذ في واجهة لABACUS، بما في ذلك ما يلي:

· نوافذ التبويب قفص الاتهام.

· نوافذ قفص الاتهام إلى حافة إطار في واجهة.

· التقليل من ويندوز أداة على طول حافة الواجهة.

· إعادة تعيين نافذة الايداع للتخطيط الافتراضية.

ويندوز لرسو السفن

عندما نافذة غير قابل للإرساء، ويمكن تثبيتها على جانب واحد من إطار في واجهة أو أنها يمكن أن تكون مرتبة على أجزاء كلفه ضمن الإطار. يظهر دليل الماس عند سحب النوافذ من موقعها الحالي إلى موقع آخر في واجهة. دليل الماس يسمح لك بسرعة إعادة إرساء-نافذة على أحد الجوانب الأربعة من الإطار أو في وسط باعتبارها جزء كلفه. عندما نافذة هو انفصل أو لا يمكن تركيبه، فإنه يطفو على أعلى الإطارات الأخرى.

إلى قفص الاتهام ويندوز

1. انقر فوق الإطار الذي تريد أن ترسو، لوضع التركيز عليه.

2. على نافذةالقائمة، انقر فوق يمكن تركيبه.

3. اسحب الإطار من موقعه الحالي نحو منتصف الإطار الذي تريد أن ترسو معها.

يظهر دليل الماس. السهام أربعة من نقطة الماس نحو أربع حواف الإطار ومركز تمثل جزء كلفه.

تلميح

لنقل إطار يمكن تركيبه دون انقطاع في مكانه، اضغط على CTRL أثناء سحب عليه.

4. عندما تكون النافذة تقوم بسحب يصل إلى الموضع حيث تريد أن ترسو عليه، حرك المؤشر فوق الجزء المقابل من دليل الماس. يظهر مخطط النافذة في مجال معين.

5. لإرساء نافذة في موقف مبين، حرر زر الماوس.

على سبيل المثال، إذا المستكشفورست على الحافة اليسرى من واجهة وتريد أن ترسو على الحافة اليمنى، وكنت اسحب المستكشفنحو منتصف واجهة، حرك المؤشر على الجانب الأيمن من دليل الماس، ثم حرر زر الماوس.

يعد الحد من ويندوز

ويندوز (سواء كانت أداة ويندوز - تظهر على عرضالقائمة، أو وثيقة ويندوز - تظهر على نافذةالقائمة) دعم ميزة تسمى إخفاء تلقائي. إخفاء تلقائي يتيح لك أن ترى أكثر من الهندسة المعمارية الخاصة بك في وقت واحد عن طريق تقليل النوافذ على طول حواف الواجهة عندما لا تكون قيد الاستعمال.

لتشغيل السيارات إخفاء

1. انقر فوق الإطار الذي تريد إخفاء لوضع التركيز عليه.

2. على نافذةالقائمة، انقر فوق اخفاء تلقائي.

- أو -

2. انقر فوق رمز الدبوس على شريط عنوان النافذة.

إخفاء تلقائي تمكين

عندما يفقد نافذة خفية التركيز التلقائي، فإنه ينزلق تلقائيا إلى علامة التبويب على حافة الواجهة. في حين أن الإطار خفية السيارات، اسمها ورمز مرئية على علامة تبويب على حافة الواجهة. لعرض نافذة مخبأة السيارات، حرك المؤشر فوق علامة التبويب. نافذة الشرائح إلى العرض مرة أخرى وجاهزا للاستخدام.

ملاحظة

لا يمكن إرساء إطار هذا هو خفية السيارات. إلى إرساء إطار ستحتاج إلى إيقاف إخفاء تلقائي كما هو موضح أدناه.

لإيقاف السيارات إخفاء

1. انقر فوق الإطار الذي تريد أن تبقي واضحة لوضع التركيز عليه.

2. على نافذةالقائمة، انقر فوق اخفاء تلقائيلمسح علامة الاختيار.

- أو -

2. انقر فوق رمز الدبوس على شريط عنوان النافذة.

السيارات إخفاء معاقين

تلميح

النوافذ التي لديها إخفاء تلقائي تمكين الشريحة مؤقتا في الرأي عندما يكون نافذة التركيز. لإخفاء النافذة مرة أخرى، حدد عنصر خارج الإطار الحالي. مرة واحدة يفقد نافذة التركيز، فإنه ينزلق مرة أخرى للخروج من الرأي.

إعادة تعيين ويندوز تخطيطات

يمكنك العودة واجهة لتخطيط الإطار الافتراضي باستخدام إعادة تخطيط النافذة أمر. عند تشغيل هذا الأمر، تحدث الإجراءات التالية:

· يتم نقل جميع النوافذ لمواقف الافتراضية.

· يتم إغلاق النوافذ التي أغلقت في تخطيط الإطار الافتراضي من قبل الأمر.

· يتم فتح النوافذ المفتوحة في تخطيط الإطار الافتراضي من قبل الأمر.

· مصنوعة النوافذ التي كانت مخبأة / مرئية في تخطيط الإطار الافتراضي مخفية / مرئية من قبل الأمر.

لإعادة تعيين نافذة الايداع للتخطيط الافتراضية

1. على نوافذالقائمة، انقر فوق إعادة تخطيط النافذة.

القوائم وأشرطة الأدوات Customising

يمكنك تغيير تخطيط، والموقف، ومحتوى القوائم وأشرطة الأدوات في واجهة. يمكنك أيضا إضافة أزرار إلى أشرطة الأدوات وتغيير الرمز المخصص لأي زر.

إنشاء أشرطة أدوات جديدة

لإنشاء شريط أدوات جديد

1. على أدواتالقائمة، اختر تخصيص.

2. في تخصيصمربع الحوار، حدد أشرطة الأدواتعلامة التبويب.

3. أختر جديد.

4. في جديد شريط الأدواتمربع الحوار، اكتب اسما لشريط الأدوات.

5. أختر حسنا.

لإضافة زر أمر إلى قائمة أو شريط الأدوات

1. على أدواتالقائمة، اختر تخصيص.

2. في تخصيصمربع الحوار، حدد الأوامرعلامة التبويب.

3. حدد فئة واسحب الأمر من مربع الحوار إلى القائمة أو شريط الأدوات.

4. أختر إغلاق.

تلميح

الضغط باستمرار على مفتاح بديل يسمح لك لتخصيص أوامر سريعة، كما لو كان الحوار تخصيص مفتوحا.

أنظر أيضا

واجهة ABACUS


تحديد والتحقق من صحة القيود

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

تحديد والتحقق من صحة القيود

إرسال التعليقات حول هذا الموضوع.

يمكن تقييد هيكل وخصائص بنية باستخدام القيود. القيود يمكن تطبيقها على أنواع المكونات وأنواع الاتصال لتقييد بنية العمارة بطريقتين. الطريقة الأولى هي لتقييد التسلسل الهرميعن طريق تحديد "يجب يجب أن يكون الوالد / الطفل" و "يجب يجب أن يكون الطفل / الأم" العلاقات. والطريقة الثانية هي تقييد البنيةعن طريق تحديد "يجب يجب إرفاق مكون / لاتصال" و "يجب أن يجب إرفاق اتصال / لعنصر" العلاقات. وعلاوة على ذلك، فإن القيود يمكن تطبيقها على خصائص أنواع عنصر، أنواع الاتصال والقوالب وجهات النظر، أبنية، الرسوم البيانيةوترى 3D لتقييد الهندسة المعمارية (ق) بطريقتين إضافية. الطريقة الأولى هي تعيين نوع البياناتمن الممتلكات لتقييد القيم الصالحة التي يمكن أن يكون لها، وهي: النص، صحيح، عشري، تاريخ / وقت، منطقية أو قائمة. والطريقة الثانية هي لتعيين مطلوبحالة الملكية للإشارة إلى ما إذا كانت قيمة تحتاج إلى إدخالها للخاصية (ملاحظة: تنطبق القيود المطلوبة فقط لخصائص عنصر واتصال أنواع). يتم توفير المزيد من المعلومات عن القيود العقارات في تغيير خصائص عنصر، الاتصال أو نوع موضوع التعليمات. مرة واحدة وقد تم تحديد المعوقات، فمن الممكن للتحقق من صحة العمارة ضد القيود. سوف ABACUS تحذير من أي القيود التي قد انتهكت.

المفتاح لتحديد أي عقبة (ق) لتحديد يكمن في اللغة الدقيقة المستخدمة لوصف القيد. لقيود التسلسل الهرمي هم عادة من النموذج "الأسماءيمكن / أن / يجب أن تتحلل إلى ن الأسماء" أو "الأسماءيمكن / أن / يجب تجميعها من قبل الأسماء"الخ على سبيل المثال،"الإداراتيجب أن تتحلل إلى فرق" أو "تطبيقاتيمكن أن تتحلل إلى وحدات"على سبيل القيود طوبولوجيا أنها عادة ما تكون من النموذج"الأسماءيمكن / ينبغي / يجب الفعل الأسماء". على سبيل المثال، "العملياتيمكن أن يكون يؤديها فرق" أو "تطبيقاتهي استضافتها على خوادم"الآن، يمكنك ان ترى في كل القيد هناك يمكن / ينبغي / يتعين" تصفيات "المختلفة، وهذه يمكن أن تكون من 3 أنواع.

· اختياري- وهذه سوف عادة استخدام الكلمات / العبارات مثل؛ "يجوز"، "يمكن"، "قد"، "اختياريا" الخ

· موصى به- وهذه سوف عادة استخدام الكلمات / العبارات مثل؛ "يجب"، "موصى بها"، "نصح" الخ

· إلزامي- وهذه سوف عادة استخدام الكلمات / العبارات مثل؛ "لا بد منه"، "هو"، "هي"، "لديه"، أن "تقدم"، وغيرها

اعتمادا على نوع القيد (التسلسل الهرمي أو طوبولوجيا) وتصفيات المستخدمة في وصف ذلك، ينبغي تحديد القيد معين (ق) (انظر أدناه). للمثال التسلسل الهرمي المذكور أعلاه "الإداراتيجب أن تتحلل إلى فرق"ينبغي للمرء أن تعريف" الرئيسي يجب أن يكون الطفل "القيد وتعيين الإنفاذ الذي القسري. على سبيل المثال طوبولوجيا أعلاه"العملياتيمكن أن يكون يؤديها فرق"ينبغي للمرء أن إنشاء اثنين فقط (2)" يجب أن ترفق اتصال لمكون "القيود على حد سواء من يؤديها نوع الاتصال على وجه التحديد، وينصح القيود التالية إلى تعريف (انظر أدناه) لمختلف الخيارات.

· القيود التسلسل الهرمي.

o الأسماء A يمكن أن يكونمتحللة في الأسماء B، أو الأسماء B يمكن أن يكونتجميعها من قبل الأسماء A أو الأسماء B يجب ان يكونتجميعها من قبل الأسماء A- تعريف "يجب أن يكون الآباء والأبناء" القيد مع نوع الطفل بأنه نون B، نوع الأم كما نون ألف وإنفاذ كما حذر.

ملاحظة

وهذا يعني أنه في حالة وجود طفل، فإنه ينبغي أن يكون أحد الوالدين من نوع معين. إذا لم يكن كذلك، سوف تحصل على تحذير.

o الأسماء A يجب ان يكونمتحللة في الأسماء B- تعريف "يجب أن يكون الوالد الطفل" القيد مع نوع الأم كما نون A، نوع الطفل بأنه نون B وإنفاذ كما حذر.

ملاحظة

وهذا يعني أنه في حالة وجود أحد الوالدين، وكان ينبغي أن يكون الأطفال من نوع معين. إذا لم يكن كذلك، سوف تحصل على تحذير.

o الأسماء A لا بد وأنمتحللة في الأسماء B- تعريف "يجب أن يكون الوالد الطفل" عقبة مع نوع الأم كما نون A، نوع الطفل بأنه نون B والإنفاذ القسري.

ملاحظة

وهذا يعني أنه في حالة وجود أحد الوالدين، فإنه يجب أن يكون الأطفال من نوع معين. إن لم يكن سوف تحصل على خطأ.

o الأسماء A لا بد وأنتجميعها من قبل الأسماء B- تعريف "يجب أن يكون الآباء والأبناء" القيد مع نوع الطفل بأنه نون A، نوع الأم كما نون B والإنفاذ القسري.

ملاحظة

وهذا يعني أنه في حالة وجود طفل، فإنه يجب أن يكون أحد الوالدين من نوع معين. إذا لم يكن كذلك، سوف تحصل على خطأ.

· القيود طوبولوجيا.

o الأسماء A يمكن أن يكون الفعل الأسماء B- تحديد اثنين (2) "يجب أن ترفق اتصال لمكون" القيود. أولها مع نهاية مصدر نوع الاتصال الفعلتعلق على إسم وهناك نوع عنصر وإنفاذ تعيين القسري. كانت الثانية مع نهاية المغسلة من نوع الاتصال الفعلتعلق نون نوع المكون B وإنفاذ تعيين القسري.

ملاحظة

وهذا يعني أنه في حالة وجود الاتصال، فإنه يجب ربط مكونات أنواع معينة. إن لم يكن سوف تحصل على خطأ. عموما هذا يضمن أن هذه المكونات يمكن أن لا تزال موجودة وليس ان تكون مرتبطة مع بعضها البعض. ولكن إذا كانت متصلة، يجب استخدام وصلات من النوع الصحيح.

o الأسماء A يجب ان يكون الفعل الأسماء B- تحديد اثنين (2) "يجب أن ترفق المكونات لاتصال" القيود. أولها مع نون وهناك نوع مكون تعلق على نهاية مصدر لل الفعلنوع الاتصال ومجموعة إنفاذ إلى حذر. كانت الثانية مع نون نوع المكون B تعلق على نهاية بالوعة لل الفعلنوع الاتصال ومجموعة إنفاذ إلى حذر. بالإضافة إلى ذلك، تعريف "يجب أن ترفق اتصال لمكون" اثنين (2) القيود. أولها مع نهاية مصدر نوع الاتصال الفعلتعلق على إسم وهناك نوع عنصر وإنفاذ تعيين القسري. كانت الثانية مع نهاية المغسلة من نوع الاتصال الفعلتعلق نون نوع المكون B وإنفاذ تعيين القسري.

ملاحظة

هذا يعني أنه إذا مكونات أي نوع موجودة، وأنها يجب أن تعلق على اتصال من نوع معين. إن لم يكن ستحصل على التحذير. وبالإضافة إلى ذلك، وهذا يعني أنه في حالة وجود اتصال، يجب أن تكون متصلا عناصر من النوع المحدد. إن لم يكن سوف تحصل على خطأ. عموما هذا يضمن أنه إذا مكونات هذه الأنواع موجودة، وسوف تحصل تحذيرات إذا لم تكن متصلة مع بعضها البعض.

o الأسماء A لا بد وأن الفعل الأسماء B- تحديد اثنين (2) "يجب أن ترفق المكونات لاتصال" القيود. أولها مع نون وهناك نوع مكون تعلق على نهاية مصدر لل الفعلنوع الاتصال وإنفاذ لتعيين القسري. كانت الثانية مع نون نوع المكون B تعلق على نهاية بالوعة لل الفعلنوع الاتصال وإنفاذ لتعيين القسري. بالإضافة إلى ذلك، تعريف "يجب أن ترفق اتصال لمكون" اثنين (2) القيود. أولها مع نهاية مصدر نوع الاتصال الفعلتعلق على إسم وهناك نوع عنصر وإنفاذ تعيين القسري. كانت الثانية مع نهاية المغسلة من نوع الاتصال الفعلتعلق نون نوع المكون B وإنفاذ تعيين القسري.

ملاحظة

هذا يعني أنه إذا مكونات أي نوع موجودة، وأنها يجب أن تعلق على اتصال من نوع معين. إن لم يكن سوف تحصل على خطأ. وبالإضافة إلى ذلك، وهذا يعني أنه في حالة وجود اتصال، يجب أن تكون متصلا عناصر من النوع المحدد. إن لم يكن سوف تحصل على خطأ. عموما هذا يضمن أنه إذا مكونات هذه الأنواع موجودة، سوف تحصل أخطاء إذا لم تكن متصلة مع بعضها البعض.

لتحديد القيد

1. ضمان لديك ملف ABACUSالعراء و نافذة المستكشفعرض.

2. في شجرة المستكشف توسيع أنواع | أنواع المكوناتأو توسيع أنواع | أنواع الاتصال.

3. انقر بزر الماوس الأيمننوع العنصر أو نوع الاتصال وحدد إضافة القيد.

إضافة القيد

لتحديد القيد التسلسل الهرمي، حيث يجب أن يكون أحد الوالدين للطفل محدد

4. على إضافة القيدنافذة وضع علامة في إنشاء القيدمربع تحت الأم يجب ان يكون القيد الطفل منطقة.

5. حدد نوع العنصرمن مربع القائمة المنسدلة التي تريد تعيين مثل الطفل من نوع المكون المحدد في الخطوة 3.

ملاحظة

إذا كان هناك بالفعل تمكين "الرئيسي يجب ان يكون الطفل" القيد تعريف عن الوالد نوع عنصر ونوع المكون طفل آخر بعد ذلك سيتم التعامل هذا القيد الجديد باعتباره "و". هذا هو يجب أن يكون نوع والد الطفل من النوع A ونوع الطفل B، إلى أي مستوى إنفاذ (مثل ذوي الاحتياجات الخاصة، حذر أو القسري - راجع الخطوة 7) والمحددة لكل القيد.

6. اختياريا، يمكنك أن تحدد الحد الأدنى والحد الأقصى لعدد من العناصر من نوع المكون المحدد الذي يجب أن يكون الأطفال من نوع المكون اليمين النقر في الخطوة 3.

7. اختيار ما إذا كنت تريد أن يكون القيد تعطيل, حذر أو فرض.

ملاحظة

سيتم تجاهل القيود معاقين من التحقق من صحة القيد، والقيود حذر تنتج تحذير في إطار التحقق إذا تم اكتشافها وسوف القيود القسري ينتج خطأ في نافذة التحقق إذا تم اكتشافها. وعلاوة على ذلك، يجب ان تحل جميع أخطاء أمام مشروع الخادم يمكن أن ترتكب المشروع.

8. انقر حسنا.

ملاحظة

سيتم عرض القيد في شجرة المستكشف تحت نوع المكون اليمين النقر في الخطوة 3. السهم يدل على اتجاه القيد وفي هذه الحالة سوف يشير إلى أسفل واليمين. هو لون القفل فقا لما إذا كان العائق هو معطل (الرمادي)، حذر (الصفراء) أو القسري (الحمراء).

يجب أن يكون الوالدين الطفل حذر القيد

لتحديد القيد التسلسل الهرمي، حيث يجب أن يكون الطفل أحد الوالدين محدد

4. على إضافة القيدنافذة وضع علامة في إنشاء القيدمربع تحت الطفل يجب ان يكون القيد الوالد منطقة.

5. حدد نوع العنصرمن مربع القائمة المنسدلة التي تريد تحديد كأصل من نوع عنصر بالنقر بزر الفأرة الأيمن في الخطوة 3.

ملاحظة

إذا كان هناك بالفعل تمكين "يجب أن الطفل لديك الرئيسي" عقبة محددة لنوع العنصر طفل وآخر الوالدين نوع المكون ثم سيتم التعامل مع هذا القيد الجديد باعتباره "OR". هذا هو يجب أن يكون نوع الطفل من نوع الأم A أونوع الأم B، ومستوى تنفيذ (على سبيل المثال حذر أو القسري - راجع الخطوة التالية) يجب أن يكون نفس القيود القسري إلا ستتجاوز دائما تلك حذر.

6. اختيار ما إذا كنت تريد أن يكون القيد تعطيل, حذر أو فرض.

ملاحظة

سيتم تجاهل القيود معاقين من التحقق من صحة القيد، والقيود حذر تنتج تحذير في إطار التحقق إذا تم اكتشافها وسوف القيود القسري ينتج خطأ في نافذة التحقق إذا تم اكتشافها. وعلاوة على ذلك، يجب ان تحل جميع أخطاء أمام مشروع الخادم يمكن أن ترتكب المشروع.

7. انقر حسنا.

ملاحظة

سيتم عرض عائقا في طريقة عرض المستكشف تحت نوع المكون المختارة في الخطوة 5. السهم يدل على اتجاه القيد وفي هذه الحالة سوف يشير صعودا واليسار. هو لون القفل فقا لما إذا كان العائق هو معطل (الرمادي)، حذر (الصفراء) أو القسري (الحمراء).

يجب أن يكون الطفل الأم حذر القيد

لتحديد القيد طوبولوجيا، حيث يجب إرفاق مكون إلى اتصال معينة

4. على إضافة القيدنافذة وضع علامة في إنشاء القيدمربع تحت العنصر يجب أن ترفق القيد منطقة.

5. حدد نوع الاتصالمن مربع القائمة المنسدلة التي تريد تحديد كاتصال المرفقة نوع عنصر بالنقر بزر الفأرة الأيمن في الخطوة 3. (أو حدد نوع العنصرمن مربع القائمة المنسدلة التي تريد تحديد باعتبارها العنصر المرفقة إذا كنت في الخطوة 3 بالنقر بزر الفأرة الأيمن على نوع الاتصال).

ملاحظة

إذا كان هناك بالفعل عقبة تمكين "المكون يجب أن ترفق 'محددة لنوع العنصر واتصال آخر اكتب ثم سيتم التعامل مع هذا القيد الجديد باعتباره" و ". ويجب أن يرفق أن نوع المكون لنوع الاتصال A واتصال نوع B، إلى أي مستوى إنفاذ (مثل ذوي الاحتياجات الخاصة، حذر أو القسري - راجع الخطوة 7) والمحددة لكل القيد.

6. اختياريا يمكنك تحديد اتصال دورالذي تريد إضافة إلى القيد. Sانتخاب محددة دور (أي إما مصدر أو بالوعة) من مربع القائمة المنسدلة.

7. اختيار ما إذا كنت تريد أن يكون القيد تعطيل, حذر أو فرض.

ملاحظة

سيتم تجاهل القيود معاقين من التحقق من صحة القيد، والقيود حذر تنتج تحذير في إطار التحقق إذا تم اكتشافها وسوف القيود القسري ينتج خطأ في نافذة التحقق إذا تم اكتشافها. وعلاوة على ذلك، يجب ان تحل جميع أخطاء أمام مشروع الخادم يمكن أن ترتكب المشروع.

8. انقر حسنا.

لتحديد القيد طوبولوجيا، حيث يجب أن ترفق اتصال لمكون معين

4. على إضافة القيدنافذة وضع علامة في إنشاء القيدمربع تحت اتصال يجب أن ترفق القيد منطقة.

5. حدد نوع الاتصالمن مربع القائمة المنسدلة التي تريد تحديد كاتصال المرفقة نوع عنصر بالنقر بزر الفأرة الأيمن في الخطوة 3. (أو حدد نوع العنصرمن مربع القائمة المنسدلة التي تريد تحديد باعتبارها العنصر المرفقة إذا كنت في الخطوة 3 بالنقر بزر الفأرة الأيمن على نوع الاتصال).

ملاحظة

إذا كان هناك بالفعل تمكين "اتصال يجب أن ترفق 'القيد المحددة لنوع الاتصال ونوع مكون آخر باستخدام نفس اتصال دور(أي إما مصدر أو بالوعة)، ثم سيتم التعامل مع هذا القيد الجديد باعتباره "OR". ويجب أن يرفق أن نوع الاتصال لنوع المكون A أونوع المكون B، ومستوى تنفيذ (على سبيل المثال حذر أو القسري - راجع الخطوة 7) يجب أن يكون نفس القيود القسري إلا ستتجاوز دائما تلك حذر. نلاحظ أيضا، أنه إذا كانت هناك قيود متعددة التي لديها اتصال دورعلى النحو المحدد 'أي' (في مقابل وجه التحديد مصدر أو بالوعة) ثم يجب أن ترفق كل نهاية اتصال لواحد من أنواع المكون المحدد في القيود.

6. اختياريا يمكنك تحديد اتصال دورالذي تريد إضافة إلى القيد. Sانتخاب محددة دور (أي إما مصدر أو بالوعة) من مربع القائمة المنسدلة.

ملاحظة

إما المصدر أو دور بالوعة يحتاج إلى أن يتم اختيار صراحة ل التعلق العمود لتكون التقنى ليتم عرضها في أحد مكونات فهرس .

7. اختيار ما إذا كنت تريد أن يكون القيد تعطيل, حذر أو فرض.

ملاحظة

سيتم تجاهل القيود معاقين من التحقق من صحة القيد، والقيود حذر تنتج تحذير في إطار التحقق إذا تم اكتشافها وسوف القيود القسري ينتج خطأ في نافذة التحقق إذا تم اكتشافها. وعلاوة على ذلك، يجب ان تحل جميع أخطاء أمام مشروع الخادم يمكن أن ترتكب المشروع.

8. انقر حسنا.

في الوقت الحالى التحقق من نموذج و قيودالتحقق من صحة

ABACUS يتضمنفي الوقت الحقيقي نموذج تدقيق و ميزة التحقق من الصحة لل على الفور عرض آثار عملية مستخدم معين سيكون على التحذيرات والأخطاء مع المشروع الحالي، نظرا لأي التسلسل الهرمي و البنية القيود التي تم تعريفها. وتجدر الإشارة إلى أن جميع أخطاء يجب أن تحل قبل ل مشروع الخادم يمكن أن ترتكب المشروع.

ميزة التحقق من صحة ضيق الوقت الحقيقي هو أكثر ما يلفت الانتباه عند ملء مع الرسوم التوضيحية أو مباشرة في إطار مستكشف. على وجه الخصوص، خلال العمليات التالية، يتم إعطاء التوجيه باستخدام يسلط الضوء على اللون لتأثير العملية سوف يكون على التحذيرات والأخطاء مع المشروع الحالي;

1. عندما سحب العناصر على الأرض أو حول مخطط لون الوالد (أو ربط) المكون (إن وجدت) سيتم تلوين الحدود وفقا للمخطط هو موضح أدناه.

2. عند توصيل المكونات باستخدام بزر الماوس الأيمن فوق السحب | الاتصال ميزة قائمة أنواع الاتصال المتاحة والملونة وفقا للمخطط هو موضح أدناه.

3. عند توصيل المكونات على الرسوم البيانية باستخدام الوضع رابط المؤشر سيتغير الألوان وفقا لمخطط موضح أدناه.

4. عند إضافة المكونات الفرعية هو اللون قائمة المتاحة أنواع المكونات وفقا للمخطط هو موضح أدناه.

بشكل عام يتم استخدام الألوان التالية للإشارة إلى آثار والعملية لدى المستخدم على التحذيرات والأخطاء مع المشروع الحالي.

أسود : لا تأثير على تحذيرات أو أخطاء.

أخضر : وتعتبر هذه العملية بشكل واضح بالتطابق معالتسلسل الهرمي وطوبولوجيا القيود المحددة للمشروع.

أحمر : وتعتبر هذه العملية بشكل واضح في خرق للوالتسلسل الهرمي وطوبولوجيا القيود المحددة للمشروع ويؤدي إلى تحذيرات و / أو أخطاء.

خلفية التحقق من نموذج و قيودالتحقق من صحة

ABACUS يتضمن ميزة التحقق من صحة لعرض كل التحذيرات والأخطاء مع المشروع الحالي، بسبب أي القيود التي تم تعريفها. وتجدر الإشارة إلى أن جميع أخطاء يجب أن تحل قبل ل مشروع الخادم يمكن أن ترتكب المشروع.

ملاحظة

يحتاج التحقق ليتم تشغيلها يدويا عن طريق "التحقق من صحة / تحقق القيود مشروع 'زر على شريط الأدوات الرئيسي . يتم إخفاء نافذة التحقق افتراضياولكن سوف تظهر عند النقر فوق زر شريط الأدوات. شاهد Customising واجهة لكيفية إظهار ذلك، ويحتمل أن تتركه عرض بشكل دائم. أيضا، يمكنك النقر نقرا مزدوجا فوق أي صف في إطار المصادقة على "القفز" على العناصر ذات الصلة في المشروع.

نافذة التحقق من صحة

ووصف الأعمدة الافتراضية في إطار المصادقة على النحو التالي؛

تحذير أو خطأ: هذا العمود يعرض رمز ما إذا كانت المخالفة تحذير (مثلث أصفر مع علامة تعجب) أو خطأ (دائرة حمراء مع الصليب).

عدد: هذا العمود يعرض عدد المخالفة.

ملاحظة

وتظهر انتهاكات 200 فقط في كل مرة وإذا كان هناك أكثر من 200 حالة انتهاك في مشروع ابدأ، السابق، التالي والملاحين الصف النهاية في أعلى اليمين من النافذة يمكن استخدامها لتصفح انتهاكات إضافية.

الوصف: هذا هو وصف كامل للانتهاك بما في ذلك الكيان والقيد المعنية.

كيان: هذا العمود يعرض الكيان تهم انتهاك.

اكتب: هذا العمود يعرض نوع عنصر للكيان.

هندسة معمارية: هذا العمود يعرض العمارة ضمن الذي وقع فيه الانتهاك.

الكشف عن: هذا العمود يعرض الوقت الذي تم الكشف عن هذا الانتهاك.

تلميح

ومن المفيد لفرز تنازلي حسب العمود الكشف (كما هو موضح في الحوار أعلاه) لضمان ظهور الانتهاكات الأخيرة في 'رأس' من القائمة.

هناك عدة خيارات المستخدم لتغيير سلوك التحقق من صحة النموذج الخلفية. على سبيل المثال رo تغيير الألوان المستخدمة لانتهاكات القيد إلى شيء آخر غير الافتراضي أحمر، انقر على أدوات | الخيارات ... ثم انتقل إلى ال التحقق من صحةعلامة التبويب، و ضبط الألوان عبر تغيير أزرار.

التحقق من صحة خيارات

للتحقق من صحة القيود يدويا

1. انقر بزر الماوس الأيمنعلى أبنيةعقدة، أي العمارة أو في أي مكان سواء في مكونات أو روابطجزء من عرض المستكشف وحدد تحقق من القيود.

التحقق من صحة القيود

2. انقر على تفاصيلزر على تحذيراتنافذة لرؤية أين تنتهك العمارة أي القيود التي تم تعريفها.

ملاحظة

وتظهر انتهاكات فقط لتلك القيود التي تم وضعها لحذر أو القسري. وعلاوة على ذلك صيغة التحذير ستشمل "ينبغي" إذا كان القيد مجرد تحذير أو 'يجب' إذا لم تطبق.

3. انقر حسنا.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا


حذف عنصر أو اتصال

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

حذف عنصر أو اتصال

إرسال التعليقات حول هذا الموضوع.

لحذف عنصر أو اتصال

1. انقر بزر الماوس الأيمنعلى العنصر أو اتصال.

2. اختار حذف.

الحذر

سوف ABACUS يحذرك التي ستتأثر الآراء الحذف ويطلب منك تأكيد الحذف. وذلك لأن العناصر قد تكون موجودة على العديد من الرسوم البيانية وأنه يدفع إلى ما تحقق من الحذف المقترح سوف يؤثر.

تلميح

إذا قمت بحذف عنصر، كما سيتم حذف كافة مكوناتها الفرعية. يمكنك اختيار لحذف الاتصالات الداخلية والخارجية إلى عنصر. إذا اخترت عدم حذفها، واتصالات انها المرفق لستبقى، لكنها لن تكون المرفقة. جميع المكونات والاتصالات هي من خاصة اكتب . حذف عنصر / اتصال ليس له أي تأثير على نوع (في فرع أنواع من شجرة). وبالمثل، إذا كان المكون / اتصال له معيار تعيين، والحذف يكون له أي تأثير على درجة الماجستير في فرع المعايير.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة


وجهات نظر الرسم البياني

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

وجهات نظر الرسم البياني

إرسال التعليقات حول هذا الموضوع.

عشروجهات النظر هالميزة يضمن أن المكونات والاتصالات التي تمت إضافتها إلى الرسم يجب أن يكون اقتران نوع تعرف سابقا قبل أن يمكن أن تضاف إلى رسم تخطيطي. تسمح هذه الميزة لتقييد أنواع الرسوم البيانية التي يمكن استخلاصها من خلال الحد من الأشكال والروابط التي ترتبط مع مكونات و روابطالموجودة داخل العمارة الخاصة بك.

تمكين أو تعطيل فرض الرسم وجهات النظر

القدرة على فرض وجهات نظر الرسم البياني يتم تمكين تلقائيا بشكل افتراضي. لتعطيل / تمكين هذه الميزة انقر فوق أدوات | الخيارات ...| ال رسم بيانيعلامة التبويب، وقم بإلغاء تحديد / حدد فرض رسم بياني وجهات النظرخانة الاختيار وفقا لذلك.

ملاحظة

إذا كنت لا ترى "فرض رسم بياني وجهات النظر'الخيار على علامة التبويب مخطط ثم لم يكن لديك مصمم إضافة على والخيار افتراضيا.

إنشاء مخطط قابل للتنفيذ وجهة نظر

1. ضمان لديك ملف ABACUS مفتوحة مع مستكشفعرض الرأي.

2. في طريقة عرض المستكشف انقر على الحق في عرضنقطةsوانقر على خلق وجهة نظر رسم بياني

3. ال وجهة نظر رسم بيانيسيتم عرض نافذة.

4. تعيين اسم ذات صلة وجهة نظر رسم بيانيولاحظ أن وجهة نظر يتم حفظ تحت وجهات النظرقسم المستكشف.

5. ال وجهة نظر رسم بيانيسيتم عرض نافذة.

6. الآن انقر واسحب أنواع عنصر ذات الصلة وأنواع الاتصال في أبنية الخاصة بك على الأشكال وجهة نظر انت تريد. أنواع المكوناتيجب أن ننجر إلى ل شكل في الأشكالالتبويب، في حين أنواع الاتصاليجب أن ننجر إلى واحدة من الأشكال أسلوب 5 الخط في موصلاتعلامة التبويب.

7. لانقاذ وجهة نظر رسم بيانيقمت بإنشائها انقر على [image] في أعلى الزاوية اليمنى من الخاص بك وجهة نظر رسم بيانينافذة.

ملاحظة

ال وجهة نظر رسم بيانييمكن أن تعدل عن طريق النقر بزر الماوس الأيمن على وجهة نظر واختيار فتح أو النقر المزدوج ال وجهة نظر.

Synchonising وجهة نظر تحديث مع المخططات

1. ضمان لديك ملف ABACUS فتح.

2. إما بزر الماوس الأيمن فوق جهة نظر في المستكشف نافذة تحت التلوي نموذج | وجهات النظروحدد تزامن مخطط تعيينات ...

- أو -

3. إغلاق وجهة نظر مفتوح وتحديثها النافذة وحدد نعم فعلا في مزامنة إلى وجهة نظرالحوار الذي يتم عرضه.

4. ال وجهة نظر المزامنةسيتم عرض الحوار كما هو مبين أدناه.

مربعات

· إضافة تعيينات مفقود- أي شكل جديد (لنوع المكون) أو موصل (لنوع الاتصال) الجمعيات التي تمت إضافتها إلى وجهة نظرستضاف إلى المقابلة الرسم البيانيالصورة (أي على مرسامالصورة)أن ترتبط وجهة نظر.

· تحديث القائمةتعيينات- أي جوانب محدثة من الشكل الموجود (لنوع المكون) أو موصل (لنوع الاتصال) جمعيات وجهة نظر(على سبيل المثال اللون، أنماط الخطوط) وسيتم تحديث في المقابلة الرسم البيانيالصورة (أي على مرسامالصورة)أن ترتبط وجهة نظر.

· إزالة إضافيةتعيينات- أي شكل إضافي (لنوع المكون) أو موصل (لنوع الاتصال) الجمعيات التي تمت إضافتها الى ال الرسوم البيانية (أي الإستنسل بهم) ولكن ليست في وجهة نظرسيتم إزالتها من المقابلة الرسم البيانيالصورة (أي على مرسامالصورة)أن ترتبط وجهة نظر.

· الكتابة المحلية لإعدادات إضافية أو تحديث تعيينات (الاختلافات فقط)- أي جوانب محدثة من الشكل الموجود (لنوع المكون) أو موصل (لنوع الاتصال) جمعيات وجهة نظر(على سبيل المثال اللون، أنماط الخطوط) سيتم تطبيقها على العناصر المقابلة على المخططات التي تم ربطها إلى وجهة نظر.يتم تطبيق "الاختلافات" المحدثة التي أدخلت على وجهة نظر فقط لذلك أي إعدادات المحلية الموجودة في الرسم البياني التي لم يتم تحديثها في وجهة نظر ستبقى دون تغيير.

· [image] الشروح – على النحو الوارد أعلاه لكن على وجه التحديد لشروحه.

أنظر أيضا

أداة الرسم | يعيش سكان العمارة بك | تحليل العمارة بك


رسم ملامح أداة

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

رسم ملامح أداة

إرسال التعليقات حول هذا الموضوع.

أداة رسم تدعم عددا من الميزات الرسم.

التكبير

حجم الرسم البياني يمكن تغييرها باستخدام وظيفة التكبير.

لتقليل الحجم أو "تكبير"

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. صحافة السيطرةو'=' مفتاح.

- أو -

2. حدد تقريبزر على Diagramشريط الأدوات.

- أو -

2. صحافة السيطرةولفة عجلة الماوس إلى الأمام. ملاحظة: في هذا الوضع قماش والتكبير التي أوصلتنا إلى ما الماوس تحوم فوق قماش.

لزيادة حجم أو "تصغير"

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. صحافة السيطرةو'-' مفتاح.

- أو -

2. حدد تصغيرزر على Diagramشريط الأدوات.

- أو -

2. صحافة السيطرةولفة عجلة الماوس الى الوراء. ملاحظة: في هذا الوضع قماش والتكبير الخارج من حيث الماوس تحوم فوق قماش.

لصناعة السيارات في تخطيط

يمكن تعديل تخطيط المكونات في الرسم البياني تلقائيا.

لوضع جميع مكونات oن رسم تخطيطي

1. Cلعق ال تخطيط رسم بيانيزر على شريط الأدوات رسم بياني.

2. اختار إما شعاعي تخطيط أو تخطيط الشبكة.

ملاحظة

سوف تخطيط شعاعي استخدام ما يسمى "القوة الموجهة" خوارزمية بحيث يتم رسمها عناصر متصلة معا بينما يجبر عناصر غير مترابطة بعضها البعض. سوف تخطيط الشبكة استخدام خوارزمية ثابتة العرض والارتفاع تباعد. لأنها تتيح أولا للمستخدم أن يختار المخطط العام نسبة الارتفاع (على سبيل المثال 16: 9، A4 (صورة)، رسالة (المناظر الطبيعية)) ثم التباعد في الجانبين وبين الأعمدة والصفوف كما هو مبين أدناه.مع تخطيط الشبكة أية اتصالات بين مكونات لا تؤثر على تخطيط لأنها ببساطة يرتب العناصر أبجديا (بأسمائها) من أعلى اليسار إلى أسفل اليمين من اللوحة القماشية. مع كل خوارزميات لا يتم نقل الأشكال حر.

لوضع الأطفال مكونات في س الد واحدن رسم تخطيطي

1. انقر بزر الماوس الأيمنعنصر رفيع المستوى الذي الأطفال كنت ترغب في صناعة السيارات في التخطيط.

2. اختار الأطفال تخطيط.

ملاحظة

افتراضيا يستخدم فقط خوارزمية تخطيط شعاعي.

تغيير العنصر جماليات احب اللون، الشفافية، الظلال ودوران

جميع عناصر المخطط لها الجماليات التي يمكن التلاعب بها كما تريد. في حالة من الأشكال المرتبطة بها، هذه الجوانب يمكن تعيين لكل نوعوفي معظم الحالات أيضا في المثال. في حالة من الأشكال حر، هذه الخصائص يمكن تعيين في المثالعلى القماش.

ملاحظة

أي في جوانب سبيل المثال والتي تم وضعها لالأشكال المرتبطة بها سوف تكون 'الكتابة' إذا تم تغيير نفس الجانب لنوع المقابلة.

لتغيير لون شكل المرتبطة أو شكل حر

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو شكل حر على القماش.

3. اختار تغيير اللون.

4. حدد ثابت اللونزر (إن وجدت).

5. اختيار اللون الأساسي أو تعريف لون مخصص في الحوار وانقر حسنا.

- أو -

4. حدد التدرجزر (إن وجدت).

5. اختر إما أفقي، عمودي، إلى الأمام أو الخلف قطري قطري للاتجاه الانحدار في القائمة المنسدلة وانقر حسنا.

6. اختيار اللون الأساسي أو تعريف لون مخصص في الحوار ل بدايةو النهايةوانقر حسنا.

ملاحظة

سوف ABACUS لون المقدمة من شكل إذا؛
أ) هو شكل 'بسيط' مع عنصر رسومي الكامن واحد (مثل دائرة، مستطيل، مضلع الخ)، أو
ب) هو شكل 'معقد' مع subshapes الكامنة متعددة كلها نفس اللون / التدرج كما بعضها البعض أو subshapes يكون LockScale = مجموعة الحقيقي.
إذا لم يتم استيفاء الشروط المذكورة أعلاه ثم هو لون الخلفية من الشكل.

لتعيين لون شكل المرتبطة فقا لخاصية

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل(ليس على قماش الرسم).

3. اختار تغيير اللون.

4. حدد باستخدام الملكية زر الراديو.

5. تحديد الملكية عن طريق النقر على زر '...' على يمين مربع النص.

6. حدد نطاق زر الراديو.

7. ضبط دقيقةو ماكسالقيم كما تريد. ملاحظة: سيتم عرض أي قيمة أقل من الحد الأدنى لقيمة كلون مين وستعرض أي قيمة فوق الحد الأقصى كلون ماكس. أيضا، عند استخدام منطقية، قائمة أو تاريخ / وقت خصائص يتم تحويل القيم إلى مؤشر على النحو التالي؛ منطقية (خطأ = 0، صحيح = 1)، قائمة (وادي صحيح من 1 إلى n لكل قيمة صالحة في ترتيب تصاعدي بهم المحددة في مجال وحدات) وتاريخ / الوقت (عدد الأيام منذ 1 يناير 1900 - بما في ذلك الكسور العشرية ل الساعات والدقائق والثواني أجزاء - وإذا كان التاريخ هو ما قبل عام 1990 وهو رقم سالب).

8. اختيار اللون الأساسي أو تعريف لون مخصص في الحوار ل دقيقةو ماكسوانقر حسنا.

تلميح

إذا أخضر (RGB - 128،255،0) يتم اختياره كلون مين و أحمر يتم اختيار كلون ماكس لخاصية مع مجموعة قيمة - (255،0،0 RGB) 1 إلى 4ثم قيمة 1سيتم عرضها على النحو أخضر، قيمة 2 مثل أصفر, 3 مثل البرتقاليو 4 مثل أحمر.

بدلا من ذلك، لمجموعة ممتلكات 1 إلى 3قيمة 1سيكون على النحو أخضر، قيمة 2 مثل كهرمانو 3 مثل أحمرويعرف أيضا باسم "إشارات المرور" أو المركز الاستشاري.

لمجموعة ممتلكات 1-5 إذا أزرق (RGB - 0،0،255) يتم اختياره كلون مين و أحمر يتم اختيار مثل ماكس اللون وقيمة من 1 على النحو - (255،0،0 RGB) أزرق، قيمة 2 كما مائية، قيمة 3 كما أخضر، قيمة 4 كما أصفر وقيمة 5 كما أحمر.

لمجموعة ممتلكات 1-6 إذا البنفسجي (RGB - 255،0،255) يتم اختياره كلون مين و أحمر يتم اختيار مثل ماكس اللون وقيمة من 1 على النحو - (255،0،0 RGB) البنفسجي، قيمة 2 كما أزرق، قيمة 3 كما مائية، قيمة 4 كما أخضر، قيمة 5 كما أصفر وقيمة من 6 كما أحمر.

وأخيرا، لمجموعة ممتلكات 1-7 فإن قيمة 1 على النحو البنفسجي، قيمة 2 كما ازرق غامق، قيمة 3 كما أزرق فاتح، قيمة 4 كما أزرق أخضر، قيمة 5 كما أخضر، قيمة 6 كما كهرمان وقيمة 7 كما أحمر

ملاحظة

راجع الملاحظة أعلاه على الصدارة مقابل تلوين الخلفية.

- أو -

7. حدد القيمة المحددة زر الراديو.

8. انقر على تحرير الألوان زر.

9. حدد كل قيمة بدوره وانقر تعيين اللونلتحديد لون معين لكل قيمة.

ملاحظة

مجموعة من القيم لعناصر موجودة على المخطط سيتم المأهولة قبل.

10. لإضافة أي ألوان قيمة إضافية لتلك (على سبيل المثال بعد أن أعيد تشكيل مجموعة الملكية) بالسكان قبل نقرة إضافة القيمة.

لتغيير الشفافية لون شكل المرتبطة أو شكل حر

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو شكل حر على القماش.

3. اختار تغيير اللون.

4. في لوحة الشفافية تعيين شريط التمرير الأعلى إلى الشفافية المطلوبة للون القاعدة.

5. إذا كان يتم استخدام التدرج أو عن طريق خيارات الملكية، في لوحة الشفافية تعيين شريط التمرير أسفل إلى الشفافية المطلوبة للون الثاني.

6. انقر حسنا.

لمشاهدة، لعرض ظلالإلى جميع ال المرتبطة الأشكال في الرسم البياني

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكوناتعلامة التبويب إطار الاستنسل.

3. اختار إضافة ظلال.

إلى عرض بظلالها على شكل عنصر أو شكل حر

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. الصحيح-انقرعلى شكل مكون أو حر على القماش.

3. اختار إضافة ظلال.

لتدوير الأشكال عنصر والأشكال شكل حر في المخططات

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. حدد الشكل مكون أو شكل حر على القماش تريد تدوير.

3. انقر بزر الماوس الأيمنفي الشكل وحدد تناوبثم حدد زاوية ذات الصلة تريد تدوير الشكل عن طريق.

متغير عنصر الشروح وتسميات نصية FREEFORM

جميع عناصر المخطط لها الشروح التي يمكن التلاعب بها كما تريد. في حالة من الأشكال المرتبطة بها، هذه الجوانب يمكن تعيين لكل نوعوفي معظم الحالات أيضا في المثال. في حالة من الأشكال حروالموصلات، الالتسميات النصية يمكن تعيين في المثالعلى القماش.ثمانية (8) قد يتم عرض أنواع مختلفة من الشروح لعناصر الرسم البياني (أي الاسم والنوع والقيمة الملكية، علامة الملكية، مكونات المرفقة، الأطفال (لمكونات فقط) والمعايير والطوابع (مكون، تم التعديل بواسطة الخ)) في عشرين خمسة (25) مواقف مختلفة (على سبيل المثال مركز - الأعلى خارج، داخل يقم - المركز الحق خارج - القاع خارج).

ملاحظة

أي في جوانب سبيل المثال والتي تم وضعها لالأشكال المرتبطة بها سوف تكون 'الكتابة' إذا تم تغيير نفس الجانب لنوع المقابلة.وعلاوة على ذلك، حيث تحتل 2 أو أكثر من الشروح نفس الموقف سوى خط واحد، نمط الخط، لون الخط والحجم ويمكن استخدام وفاصل (مثل فاصلة، والفضاء، الخط الجديد) يجب أن يكون محددا.

لمشاهدة، لعرض اسم أو نوع لعنصر المرتبطة أو اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو موصل على القماش.

3. اختار الشروح.

ملاحظة

لشكل فرد المرتبطة أو موصل على القماش سوف تحتاج إلى تحديد تجاوز استنسل الشروحمربع في المرة الأولى.

4. حدد جديد الشرح في شريط الأدوات واختر اسم أو اكتب.

5. في مربع الحوار الذي يظهر حدد الخيارات العرض التي يتم المطلوب بما في ذلك بين قوسين ونمط الخط، الخط، لون الخط والحجم. أيضا، حدد الخيارات التخطيط الذي يتم المطلوب بما في ذلك التخطيط الأفقي والرأسي (أي موقف الشرح) وزاوية (أي دوران). اختار حسنا.

لإظهار خاصية القيمة لعنصر المرتبطة أو اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو موصل على القماش.

3. اختار الشروح.

ملاحظة

لشكل فرد المرتبطة أو موصل على القماش سوف تحتاج إلى تحديد تجاوز استنسل الشروحمربع في المرة الأولى.

4. حدد جديد الشرح في شريط الأدوات واختر قيمة الممتلكات.

5. في مربع الحوار الذي يظهر حدد الخاصية بالضغط على العقار: '...' زر واختيار خاصية في الحوار تحديد خاصيةوحدد حسنا. حدد الخيارات العرض التي يتم المطلوب بما في ذلك بين قوسين ونمط الخط، الخط، لون الخط والحجم. أيضا، حدد الخيارات التخطيط الذي يتم المطلوب بما في ذلك التخطيط الأفقي والرأسي (أي موقف الشرح) وزاوية (أي دوران). اختار حسنا.

لإظهار خاصية علامة لعنصر المرتبطة أو اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو موصل على القماش.

3. اختار الشروح.

ملاحظة

لشكل فرد المرتبطة أو موصل على القماش سوف تحتاج إلى تحديد تجاوز استنسل الشروحمربع في المرة الأولى.

4. حدد جديد الشرح في شريط الأدوات واختر ماركر الملكية.

5. في مربع الحوار الذي يظهر حدد الخاصية بالضغط على العقار: '...' زر واختيار خاصية في الحوار تحديد خاصيةوحدد حسنا. تعيين نصف قطرها علامة في بكسل وطريقة التلوين إما اللون بواسطة المدى أو اللون بواسطة الممتلكات وضبط الألوان والواجبات. أيضا، حدد الخيارات التخطيط الذي يتم المطلوب بما في ذلك التخطيط الأفقي والرأسي (أي موقف الشرح) وزاوية (أي دوران). اختار حسنا.

لمشاهدة، لعرض المكونات المرفقة لعنصر المرتبطة أو اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو موصل على القماش.

3. اختار الشروح.

ملاحظة

لشكل فرد المرتبطة أو موصل على القماش سوف تحتاج إلى تحديد تجاوز استنسل الشروحمربع في المرة الأولى.

4. حدد جديد الشرح في شريط الأدوات واختر مكونات المرفقة.

5. في مربع الحوار الذي يظهر، لمكونات المرتبطة اختر نوع المكون المرفقة بالضغط على المرفقة: '...' زر واختيار نوع المكون في الحوار تعيين نوع مكونوحدد حسنا. حدد نوع الاتصال يعلق بالضغط على طريق متصلة: '...' زر واختيار نوع الاتصال في الحوار تعيين نوع اتصالوحدد حسنا.للاتصالات المرتبطة حدد نهاية الاتصال عن طريق اختيار المصدر أو بالوعة من نهاية اتصال: سحب إلى أسفل القائمة. لكل مكونات والاتصالات المرتبطة حدد خيارات العرض التي يتم المطلوب بما في ذلك بين قوسين ونمط الخط، الخط، لون الخط والحجم. أيضا، حدد الخيارات التخطيط الذي يتم المطلوب بما في ذلك التخطيط الأفقي والرأسي (أي موقف الشرح) وزاوية (أي دوران). اختار حسنا.

لمشاهدة، لعرض الاطفال لعنصر المرتبطة

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكوناتعلامة التبويب إطار الاستنسل أو شكل المرتبطة على القماش.

3. اختار الشروح.

ملاحظة

لشكل المرتبطة الفردي على القماش سوف تحتاج إلى تحديد تجاوز استنسل الشروحمربع في المرة الأولى.

4. حدد جديد الشرح في شريط الأدوات واختر الأطفال.

5. في مربع الحوار الذي يظهر حدد الخيارات العرض التي يتم المطلوب بما في ذلك بين قوسين ونمط الخط، الخط، لون الخط والحجم. أيضا، حدد الخيارات التخطيط الذي يتم المطلوب بما في ذلك التخطيط الأفقي والرأسي (أي موقف الشرح) وزاوية (أي دوران). اختار حسنا.

لمشاهدة، لعرض المعايير لعنصر المرتبطة أو اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو موصل على القماش.

3. اختار الشروح.

ملاحظة

لشكل فرد المرتبطة أو موصل على القماش سوف تحتاج إلى تحديد تجاوز استنسل الشروحمربع في المرة الأولى.

4. حدد جديد الشرح في شريط الأدوات واختر المعايير.

5. في مربع الحوار الذي يظهر حدد الخيارات العرض التي يتم المطلوب بما في ذلك بين قوسين ونمط الخط، الخط، لون الخط والحجم. أيضا، حدد الخيارات التخطيط الذي يتم المطلوب بما في ذلك التخطيط الأفقي والرأسي (أي موقف الشرح) وزاوية (أي دوران). اختار حسنا.

لمشاهدة، لعرض الطوابع الزمنية لعنصر المرتبطة أو اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل المرتبطة بها أو الموصل في مكونات أو روابطعلامة التبويب إطار الاستنسل أو شكل المرتبطة أو موصل على القماش.

3. اختار الشروح.

ملاحظة

لشكل فرد المرتبطة أو موصل على القماش سوف تحتاج إلى تحديد تجاوز استنسل الشروحمربع في المرة الأولى.

4. حدد جديد الشرح في شريط الأدوات واختر خلق، خلق من قبل، ماركر إنشاء أو تعديل أو التعديل بواسطة أو التعديل ماركر.

5. في مربع الحوار الذي يظهر، إن لم يكن علامة، حدد الخيارات العرض التي يتم المطلوب بما في ذلك بين قوسين ونمط الخط، الخط، لون الخط والحجم. إذا علامة، تعيين نصف قطرها علامة في بكسل وطريقة التلوين إما اللون بواسطة المدى أو اللون بواسطة الملكية ومجموعة الألوان الواجبات. أيضا، حدد الخيارات التخطيط الذي يتم المطلوب بما في ذلك التخطيط الأفقي والرأسي (أي موقف الشرح) وزاوية (أي دوران). اختار حسنا.

لتغيير نمط الخط من شكل حرأو موصل

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل حر أو موصل على القماش. ملاحظة: إذا كان الموصل تسمية النص لا تظهر بعد ذلك لإظهار اتصالأو تسمية النص: انقر بزر الماوس الأيمنويربطأووحدد الشرح | مشاهدة الشرح.

3. اختار تغيير الخط.

4. حدد نمط الخط، والخط الحجم في الحوار وتحديد حسنا.

لتغيير الخط اللون من شكل حرأو موصل

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل حر أو موصل على القماش. ملاحظة: إذا كان الموصل تسمية النص لا تظهر بعد ذلك لإظهار اتصالأو تسمية النص: انقر بزر الماوس الأيمنويربطأووحدد الشرح | مشاهدة الشرح.

3. اختار تغيير الخط اللون.

4. حدد الخطاللون (والأشكال ارتباط اللون) بالضغط على '...' زر واختيار اللون في مربع الحوار وحدد حسنا.

5. حدد شفافية التسمية النص عن طريق ضبط المنزلق مع 0 كونها شفافة تماما و 255 كونها مبهمة تماما.

لتدوير تسمية نص شكل حرأو موصل

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. انقر بزر الماوس الأيمنعلى شكل حر أو موصل على القماش. ملاحظة: إذا كان الموصل تسمية النص لا تظهر بعد ذلك لإظهار اتصالأو تسمية النص: انقر بزر الماوس الأيمنويربطأووحدد الشرح | مشاهدة الشرح.

3. اختار تناوبثم حدد زاوية ذات الصلة تريد تدوير تسمية النص بواسطة.

أنظر أيضا

أداة الرسم | يعيش سكان العمارة بك | تحليل العمارة بك


محاكاة التكلفة الإجمالية للملكية (TCO)

الملاحة: محاكاة العمارة الخاص> الطيران التشبيهي>

محاكاة التكلفة الإجمالية للملكية (TCO)

إرسال التعليقات حول هذا الموضوع.

خلفية

التكلفة الإجمالية للملكية (TCO) هو تقدير المالي، والمصممة لقياس مجموع تكبد تكاليف دورة الحياة (من الاستحواذ على وقف تشغيل / التخلص منها) المرتبطة الأصول المملوكة. TCO يعكس ليس فقط تكاليف الشراء، فإنه يشمل أيضا جميع الجوانب الأخرى في مواصلة استخدام وصيانة الأصول.

يستخدم TCO لتحديد جهد وتكاليف الميزانية اللازمة للإنفاق على هذا النظام. وهناك طريقة بسيطة من النمذجة في ABACUS لTCO هي كسر نظام تكنولوجيا المعلومات وصولا إلى المكونات. يمكننا بعد ذلك معرفة كم في المتوسط ​​يكلف لتشغيل واحدة من هذه المكونات. بعد هذا يمكننا أن ثم عاملا في تكاليف مختلفة اعتمادا على ما إذا كان نظام تكنولوجيا المعلومات هو evolvable أو مفتوحة وما إذا كان النظام هو بالفعل وتشغيلها، والعامل الرئيسي هو أن تنظر إلى تكاليف الصيانة وربما تكلفة بإقفالها.

مثال

الرسم البياني على سبيل المثال حساب

المكون تحت منظمة أو مستواها له هذه الخصائص:

· FTE= 100 $ 000 / سنة

· دعم الجهد= 0.01 FTE + 0.001 FTE / سنة = 1000 $ + 100 $ / سنة

· تكلفة الصيانة= 100 $ - 10 $ / سنة

· تكلفة رأس المال= 2000 $

· تثبيت الجهد= 2 FTE / أيام = 0.01 FTE / سنة = 1000 $

المكون تحت منظمة له هذه الخصائص:

· تثبيت الأفق= -2 سنوات (أي تم تثبيت نظام 2 سنة قبل الحاضر)

· عمر= 3 سنوات

عندما تثبيت الأفق + عمر <= 0 لا يوجد المزيد من تكاليف الصيانة.

الحسابات

الحسابات هي كما يلي:

ملاحظة

TC = تكلفة سنويا. SE = دعم الجهد. MC = تكلفة الصيانة.

· التكلفة المبدئية التكلفة = رأس المال + تثبيت الجهد= 2000 + 1000 = 3000 $

· في تي = -2 (خلال 1st العام)، TC = التكلفة الأولية + SE + MC= 3000 + 1000 + 100 = 4100 $

· في ر = -1، TC = SE + MC= (1000 + 100) + (100-10) = 1190 $

· في تي = 0، TC = (1000 + 200) + (100-20) = 1280 $

· في ر = 1 (السنة النهائية)، TC = (1000 + 300) + (100-30) = 1370 $

الرسم البياني على سبيل المثال حساب

TCO هي مجموع كل التكاليف الحالية والمستقبلية حتى تم الاستغناء عنها النظام.

· في تي = -2 (خلال 1st العام)، TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· في ر = -1، TCO = 1190 + 1280 + 1370 = 3840 $

· في تي = 0، TCO = 1280 + 1370 = 2650 $

· في ر = 1 (السنة النهائية)، TCO = 1370 $

عوامل التكلفة الرئيسية

عوامل التكلفة الرئيسية التي يجب أخذها في الاعتبار عند حساب TCO للأصل في ABACUS هي:

· اقتناء الأجهزة- التكلفة الأولية للمعدات (تكلفة رأس المال).

· برنامج اكتساب- التكلفة الأولية الترخيص للبرمجيات (تكلفة رأس المال).

· تركيب- التكاليف المرتبطة الإعداد الأولي.

· تدريب- التكلفة المرتبطة بائع للتدريب الخارجي بعد الإعداد الأولي.

· الدعم- التكلفة المرتبطة بدعم داخلي.

· صيانة- تكاليف لاستبدال أو الترقية البائع عقود الصيانة واللوازم وتكاليف التعافي من الكوارث.

· البنية التحتية- التكاليف المرتبطة تدعم الأصول.

ABACUS مثال تمثيل عوامل التكلفة الرئيسية

تشغيل محاكاة التكلفة

لمحاكاة العمارة الخاص من حيث التكلفة

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. اختار تحليل| كلفة.

3. اختر ال العمارة (ق)كنت ترغب أن تدرج في التقييم.

ملاحظة

افتراضيا، سوف ABACUS حدد العمارة (ق) التي لا بد من إعادة محاكاة بسبب أي عقارا أو التغييرات الهيكلية تلقائيا.ويظهر هذا في تسليط الضوء على أحمر على شريط أدوات المحاكاة .

4. حدد عملةمن المنسدلة.

5. حرك ال سنوات لحسابالتمرير إلى عدد السنوات اللازمة.

ملاحظة

افتراضيا، إذا كانت سنوات لحساب أكثر من 1 سنة سيتم تلقائيا احتساب التكاليف لكل سنة على حدة (ومجموعة من الخصائص وأضاف / محدث) ثم تحسب أيضا القيمة التراكمية لعدد كامل من السنين. إذا كنت بحاجة فقط القيمة التراكمية ثم قم بإلغاء تحديد حساب التكاليف لكل سنةالخيار كما هو موضح أدناه لانقاذ على عدد من العقارات في المشروع.

6. اختيار ما إذا كنت تريد ترك حساب التكاليف لكل سنةفحص أو قم بإلغاء تحديدها.

7. انقر التالى.

8. اختياريا اختيار روابطكنت أتمنى أن تنسب تكاليف جنبا إلى جنب كجزء من التقييم.

ملاحظة

باستخدام التكلفة | عزوالعقارات في تكاليف الاتصالات يمكن أن يكون ينسب من مكون تعلق على نهاية بالوعة للاتصال المكون تعلق على نهاية المصدر(أي تكلفة | العزو = "تنزل الى المصدر")، أو من مكون تعلق على مصدر نهاية الاتصال إلى عنصر تعلق على بالوعة النهاية(أي تكلفة | العزو = "المصدر إلى بالوعة"). بالإضافة إلى ذلك، سوف ABACUS تحديد تلقائيا تلك الاتصالات مع السلوك | العلاقة = "العمليات" أو "الدعم"واتجاه إسناد سيكون "تنزل الى المصدر '. وعلاوة على ذلك، فإن التكاليف قسمته وفقا لأي سلوك | ٪ أو التكلفة | ٪ الخصائص على وصلات، أو بدلا من ذلك حيث هناك اتصالات متعددة من بالوعة إلى مصادر عديدةأو مصدر لكثير من المصارفوفقا لأي سلوك | خصائص المعالجة على مكونات المصدرأو تغرق المكونات على التوالي.

9. انقر إنهاءوستحصل على تحذيرالحوار.

10. اختياريا استكشاف تحذيرات بالضغط التفاصيل >>.

11. انقر أكمل.

ملاحظة

عند هذه النقطة، سوف ABACUS إجراء تقييم ليشطب من العمارة (ق) على أساس النشاط وبعد وقت قصير (مع أشرطة التقدم لردود الفعل) سيظهر مربع حوار حساب كامل.

12. انقر حسناالاعتراف التقييم.

تلميح

للدورات التدريبية ومزيد من المساعدة على التكلفة محاكاة يرجى الرجوع إلى Avolution الجماعة .

مكون و / أو اتصال الممتلكات

يسرد الجدول التالي المكون و / أو اتصال الخصائص المطلوبة لتقييم تكلفة.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز إدخال خاصية صف محدد ( [image] ) مع تلميح "التكلفة الإدخال". وهناك تغيير في أي من هذه "الإدخال" خصائص والتغيرات الهيكلية المختلفة إلى المخزون يؤدي إلى محاكاة التكلفة تتطلب إعادة المحاكاة كما هو مبين في أحمر على شريط أدوات المحاكاة .

اكتب

اسم

القيمة الافتراضية

وحدة

نوع البيانات

مطلوب

الوصف

كلفة

تثبيت الأفق

0

سنوات

عدد صحيح

حقيقي

يحدد متى المكون أو اتصال وقد تم، أو سيتم تثبيتها.

· قيمة 0 (الافتراضي) إلى أن عنصر أو اتصال يتم تثبيت في العام الحالي.

· A قيمة أقل من 0 إلى أن المكون أو اتصال وقد تم تركيب في الماضي.

· قيمة أكبر من 0 إلى أن المكون أو اتصال سوف يتم تركيبها في المستقبل.

كلفة

عمر

0

سنوات

عدد صحيح

حقيقي

يحدد طول الفترة الزمنية التي المكون أو اتصال ستبقى في العملية، وبعد ذلك سيتم تفكيكها.

كلفة

FTE

100،000.00

$ / سنة

عدد عشري

خاطئة

التكلفة السنوية لكل موظف بدوام كامل.

إذا لم يتم العثور على هذه الخاصية في عنصرنفسها أو في حالة الاتصالات المكون تعلق على نهاية بالوعة للاتصالسيتم البحث عنه والمكونات الأخرى.

أولا، أي "بالوعة" مكونs في نهاية a اتصال مع "تدعم" العلاقة لعنصر سيتم البحث، تليها أن "بالوعة" الأم المكونالصورة.

إذا لم يتم العثور على الممتلكات FTE، المكون الأموبعد ذلك يتم البحث -components. إذا كان لا يزال لم يتم العثور FTE، يتم استخدام القيمة الافتراضية.

يرجى ملاحظة: FTE هو فقط خاصية الإدخال صالحة على المكونات.

كلفة

التكلفة الصيانة (ثابت)

0.00

$ / سنة

عدد عشري

خاطئة

تكلفة سنوية ثابتة للحفاظ على عنصرأو اتصال.

كلفة

التكلفة الصيانة (متغير)

0.00

$ / سنة

عدد عشري

خاطئة

المبلغ الذي التكلفة الإجمالية للحفاظ على عنصر أو اتصال سيتغير كل عام.

على سبيل المثال، قيمة $ -500 إلى أن تكاليف الصيانة الكلية تنخفض بمقدار 500 $ سنويا، في حين أن قيمة 500 $ إلى أن مجموع الزيادات تكاليف الصيانة بنسبة 500 $ سنويا.

كلفة

دعم جهد (الثابتة)

0.00

FTE / سنة

عدد عشري

خاطئة

جهود سنوي ثابت من دعم العنصرأو اتصالالمحدد من حيث الشخص عاما.

كلفة

دعم جهد (متغير)

0.00

FTE / سنة

عدد عشري

خاطئة

المبلغ الذي الجهد الكلي للدعم العنصر أو اتصال سيتغير كل عام.

على سبيل المثال، قيمة -0.01 تشير إلى أن جهود الدعم الكامل ينخفض ​​بنسبة 0.01 شخص سنوات كل سنة، في حين أن قيمة 0.01 تشير إلى أن مجموع الزيادات جهد الدعم بنسبة 0.01 في كل عام.

كلفة

تكلفة رأس المال

0.00

$

عدد عشري

خاطئة

التكلفة الأولية لشراء العنصرأو اتصال.

كلفة

تثبيت الجهد

0.00

FTE

عدد عشري

خاطئة

الجهد المطلوب، في شخص عاما، لتثبيت المكونأو اتصال.

يسرد الجدول التالي المكون و / أو اتصال الخصائص التي هي الناتج من قبل مقيم TCO. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح 'التكلفة الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة التكلفة يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

ملاحظة

حيث تحتاج خصائص الإخراج من مقيم TCO أن يكون "تقريب" "النصف المستديرة حتى" نهج (يشار إليها أيضا باسم 'المصرفيين التقريب) يستخدم.وتستخدم هذه التقنية إلى حل أكثر بالتساوي أي 0.5 يجري تقريب "التعادل فواصل" ونتيجة لأعلى أو لأسفل إلى أقرب حتى نتيجة لذلك، بدلا من التقريب دائما أعلى أو لأسفل وانحراف نتيجة. أي. 2.5 يتم تقريب وصولا الى 2، في حين يتم تقريب 3.5 تصل إلى 4، وليس لهم على حد سواء يجري إما تقريب وصولا الى 2 و 3 أو تقريب تصل إلى 3 و 4.

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
كلفة | التكلفة الإجمالية لامتلاك - سنوات س القادمة. | $ | عدد صحيح | خاطئة | التكلفة الإجمالية للملكية المقبل xسنوات، حيث x هو طول الوقت المحدد عند تشغيل مقيم. وهذا يشمل تكلفة المكون أو الاتصال في المعايير ومكوناتها الفرعيةأو وصلات فرعية(أي الأطفال) وأية تكاليف تعزى.
كلفة | التكلفة الإجمالية لامتلاك (المحلي) - بجوار س سنوات. | $ | عدد صحيح | خاطئة | تكلفة "المحلية" الملكية خلال الفترة القادمة xسنوات، حيث xهو طول الوقت المحدد عند تشغيل مقيم. هذا لا ليستشمل تكلفة المكونات الفرعية للمكون أو وصلات فرعية الاتصال في (أيالأطفال) أو أي تكاليف المنسوبة.
كلفة | التكلفة الإجمالية لامتلاك (الأطفال) - العاشر المقبل سنوات. | $ | عدد صحيح | خاطئة | تكلفة "الأطفال" الملكية خلال الفترة القادمة xسنوات، حيث x هو طول الوقت المحدد عند تشغيل مقيم. هذا فقط يشمل تكلفة المكونات الفرعية للمكون أو وصلات فرعية الاتصال في (أي الأطفال).
كلفة | التكلفة الإجمالية لامتلاك (ينسب) - بجوار س سنوات. | $ | عدد صحيح | خاطئة | تكلفة "يعزى" الملكية خلال الفترة القادمة xسنوات، حيث x هو طول الوقت المحدد عند تشغيل مقيم. هذا فقط يتضمن أية تكاليف تنسب من المكونات المرفقة(والتي قد تشمل بالطبع يعزى التكاليف من أية اتصالات المرفقة).

يسرد الجدول التالي المكون و / أو اتصال الخصائص التي هي الناتج من قبل مقيم TCOإذا كان حساب لكل سنة التكاليف يتم تحديد الخيار. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح 'التكلفة الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة التكلفة يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

ملاحظة

راجع الملاحظة أعلاه على التقريب ممكن من خصائص الانتاج.

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
كلفة | التكلفة الإجمالية لامتلاك - عامس. | $ | عدد صحيح | خاطئة | التكلفة الإجمالية للملكية إلى سنة xحيث x هو عن كل سنة المحدد عند تشغيل مقيم. وهذا يشمل تكلفة المكونأو الاتصال في المعايير ومكوناتها الفرعية أو وصلات فرعية (أي الأطفال) وأية تكاليف تعزى.
كلفة | التكلفة الإجمالية لامتلاك (المحلي) - سنةس. | $ | عدد صحيح | خاطئة | تكلفة "المحلية" الملكية لمدة سنة x، أين xغير عن كل سنة المحدد عند تشغيل مقيم. هذا لا ليستشمل تكلفة المكونات الفرعية للمكون أو وصلات فرعية الاتصال في (أي الأطفال) أو أي تكاليف المنسوبة.
كلفة | التكلفة الإجمالية لامتلاك (الأطفال) - سنةس. | $ | عدد صحيح | خاطئة | تكلفة "الأطفال" الملكية لمدة سنة xحيث x هو عن كل سنة المحدد عند تشغيل مقيم. هذا فقط يشمل تكلفة المكونات الفرعية للمكون أو اتصال الفرعي الاتصال في (أي الأطفال).
كلفة | التكلفة الإجمالية لامتلاك (ينسب) - سنةس. | $ | عدد صحيح | خاطئة | تكلفة "يعزى" الملكية لمدة سنة xحيث x هو عن كل سنة المحدد عند تشغيل مقيم. هذا فقط يتضمن أية تكاليف تنسب من المكونات المرفقة(والتي قد تشمل بالطبع يعزى التكاليف من أية اتصالات المرفقة).

إضافي خصائص اتصال

يسرد الجدول التالي إضافي خصائص الاتصال التي مطلوبة من قبل مقيم TCO. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز إدخال خاصية صف محدد ( [image] ) مع تلميح "التكلفة / الأداء الإدخال" أو مجرد "التكلفة الإدخال". وهناك تغيير في أي من هذه "الإدخال" خصائص والتغيرات الهيكلية المختلفة إلى المخزون يؤدي إلى التكلفة و / أو محاكاة الأداء تتطلب إعادة المحاكاة كما هو مبين في أحمر على شريط أدوات المحاكاة .

اكتب | اسم | القيمة الافتراضية | وحدة | نوع البيانات | مطلوب | الوصف
كلفة | عزو | تنزل الى المصدر | [المصدر إلى بالوعة | تنزل الى المصدر] | بحث / قائمة | حقيقي | إذا "المصدر إلى بالوعة"، هذا الصدد سوف لديك لديك كلفةsعزا "جنبا إلى جنب" هو من مصدرعنصر لل بالوعة مكون. بدلا من ذلك، إذا "تنزل الى المصدر"، هذا الصدد سوف والتكاليف وعزت "جنبا إلى جنب" هو من مكون إلى مكون بالوعة المصدر.
سلوك | علاقة | الدعم | [العمليات | تدعم] | بحث / قائمة | خاطئة | إذا كان "الدعم"، ويشير هذا الصدد إلى أن يتم اعتماد عنصر "مصدر" من قبل مكون "تغرق". بالإضافة إلى ذلك، إذا إما "الدعم" أو "العمليات" ثم سيتم تلقائيا اختيار الوصلة في الاتصالات لديها تكاليفها وعزت "جنبا إلى جنب" من مكون إلى مكون بالوعة المصدر.
كلفة | % | 100.0 | % | عدد عشري | خاطئة | يشير إلى نسبة من تكاليف مكونات المصارف والتي يمكن أن يعزى إلى المكون المصدر. لا تحتاج القيم٪ لتضيف ما يصل الى 100٪ ويتم استخدامه ببساطة لقياس "التكلفة الإجمالية لامتلاك - سنوات س المقبلة". الملكية (انظر أعلاه) من مكون بالوعة حيث يعود ذلك إلى المكون المصدر.

خصائص العمارة

يسرد الجدول التالي الخصائص المعمارية التي هي الناتج من قبل مقيم TCO. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح 'التكلفة الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة التكلفة يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

ملاحظة

راجع الملاحظة أعلاه على التقريب ممكن من خصائص الانتاج.

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
كلفة | التكلفة الإجمالية لامتلاك - سنوات س القادمة. | $ | عدد صحيح | خاطئة | التكلفة الإجمالية للملكية العمارة بأكملها على مدى السنوات المقبلة س.

يسرد الجدول التالي الخصائص المعمارية التي هي الناتج من قبل مقيم TCOإذا كان حساب لكل سنة التكاليف يتم تحديد الخيار. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح 'التكلفة الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة التكلفة يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

ملاحظة

راجع الملاحظة أعلاه على التقريب ممكن من خصائص الانتاج.

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
كلفة | التكلفة الإجمالية لامتلاك - سنةس. | $ | عدد صحيح | خاطئة | التكلفة الإجمالية للملكية إلى العمارة بأكملها لمدة سنة x إلى المستقبل.


محاكاة الجزئية

الملاحة: محاكاة العمارة الخاص> الطيران التشبيهي>

محاكاة الجزئية

إرسال التعليقات حول هذا الموضوع.

جهاز محاكاة نمطية بحساب عدد الاتصالات الواردة والصادرة لكل مكون.

لمحاكاة العمارة الخاص من حيث نمطية

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. اختار تحليل| نمطية.

3. اختر ال العمارة (ق)كنت ترغب أن تدرج في التقييم.

ملاحظة

افتراضيا، سوف ABACUS حدد العمارة (ق) التي لا بد من إعادة محاكاة بسبب أي تغييرات الهيكلية الكامنة تلقائيا.ويظهر هذا في تسليط الضوء على أحمر على شريط أدوات المحاكاة .

4. انقر التالى.

5. اختر ال أنواع الاتصال (الصورة)كنت ترغب أن تدرج في التقييم.

6. انقر التالى.

7. اختياريا تخصيص أسماء الخصائص لحساب النتائج.

8. انقر إنهاء.

ملاحظة

عند هذه النقطة، سوف ABACUS إجراء التقييم الهيكلي للهندسة (ق) وبعد وقت قصير (مع أشرطة التقدم لردود الفعل) سيظهر مربع حوار حساب كامل.

9. انقر حسناالاعتراف التقييم.

تلميح

للدورات التدريبية ومزيد من المساعدة على تقييم نمطية يرجى الرجوع إلى Avolution الجماعة .

خصائص عنصر

يسرد الجدول التالي الخصائص المكونة التي هي الناتج من قبل مقيم نمطية.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح 'نمطية الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي قديمة بسبب التغير الهيكلي الأساسي للمستودع ومحاكاة نمطية يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | نوع البيانات | مطلوب | الوصف
نمطية | اقتران مروحة في (المحلي) | عدد صحيح | خاطئة | عدد الاتصالات التي مروحة إلى هذا العنصر.
نمطية | اقتران مروحة من (محلي) | عدد صحيح | خاطئة | عدد الاتصالات التي مروحة من هذا العنصر.
نمطية | اقتران مروحة في | عدد صحيح | خاطئة | عدد الاتصالات التي مروحة إلى هذا العنصر، بما في ذلك الاتصالات التي مروحة إلى مكونات فرعية.
نمطية | اقتران مروحة من | عدد صحيح | خاطئة | عدد الاتصالات التي مروحة من هذا العنصر، بما في ذلك الاتصالات التي مروحة إلى مكونات فرعية.


محاكاة الانفتاح

الملاحة: محاكاة العمارة الخاص> الطيران التشبيهي>

محاكاة الانفتاح

إرسال التعليقات حول هذا الموضوع.

جهاز محاكاة الانفتاح تحدد الدرجة التي والهندسة المعمارية وعناصرها هي 'فتح'، وهذا هو، وقدرة النظام على التعامل مع استبدال المكونات مع تأثير ضئيل.

لمحاكاة العمارة الخاص من حيث الانفتاح

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. حدد تحليل | انفتاح.

3. اختر ال العمارة (ق)كنت ترغب أن تدرج في التقييم.

ملاحظة

افتراضيا، سوف ABACUS حدد العمارة الأولى التي لا بد من إعادة محاكاة بسبب أي عقارا أو التغييرات الهيكلية تلقائيا.ويظهر هذا في تسليط الضوء على أحمر على شريط أدوات المحاكاة .

4. انقر إنهاءوستحصل على تحذيرالحوار.

5. اختياريا استكشاف تحذيرات بالضغط التفاصيل >>.

6. انقر أكمل.

ملاحظة

عند هذه النقطة، سوف ABACUS إجراء التقييم الهيكلي للهندسة (ق) وبعد وقت قصير (مع أشرطة التقدم لردود الفعل) سيظهر مربع حوار حساب كامل.

7. انقر حسناالاعتراف المحاكاة.

تلميح

للدورات التدريبية ومزيد من المساعدة على تقييم الانفتاح يرجى الرجوع إلى Avolution الجماعة .

عنصر واتصال خصائص قياسية

يسرد الجدول التالي عنصر والاتصال خصائص المعايير المطلوبة لتقييم الانفتاح.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز إدخال خاصية صف محدد ( [image] ) مع تلميح "الإدخال الانفتاح". وهناك تغيير في أي من هذه "الإدخال" الخصائص في مستودع يؤدي إلى محاكاة الانفتاح التي تتطلب إعادة المحاكاة كما هو مبين في أحمر على شريط أدوات المحاكاة .

اكتب | اسم | القيمة الافتراضية | وحدة | نوع البيانات | مطلوب | الوصف
انفتاح | المعايير القياسية النضج-منظمة مستوى |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | مستوى مسؤول هيئة المعايير 0:التنظيمي / الملكية 1:كونسورتيوم / فعلية 2:الوطني / العسكرية 3:دولي
انفتاح | المعايير القياسية النضج الوضع |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | مستوى الموافقة تحقيق مع هيئة المعايير 0:العامل التابع للجنة / مشروع 1:مشروع العام / Balloted 2:مشروع المؤقت 3: وافق
انفتاح | المعايير القياسية النضج الاستقرار |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | غير المرجح أن تغير المعيار؟ 0:مستوى عفا عليها الزمن 1:موضوع غاية لتغيير في القادم 1-2 سنوات 2:تعرف التغيير / التحديثات إلى الميزات الموجودة 3:درجة عالية من الاستقرار (أي تغيير في غضون 2 عاما)
انفتاح | المعايير القياسية النضج-بائع الدعم |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | بائع الدعم 0:لا توجد منتجات أو شركات تدعم المعيار 1:واحد أو أكثر من البائعين أن تنفيذ جزء من معيار 2:أكثر من بائع واحد مع المنتجات التي تنفذ جميع أجزاء القياسية 3:الكثير من البائعين مع المنتجات التي تنفذ جميع أجزاء القياسية
انفتاح | المعايير القياسية وضوح-وثائق |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | جودة الوثائق القياسية 0:فقير 1: معرض 2: جيد 3: ممتاز
انفتاح | المعايير القياسية وضوح-معيار العرض |  |  | عدد صحيح | خاطئة | عدد من الميزات. عد من أدنى مستوى الميزات القياسية - سادس
انفتاح | المعايير القياسية وضوح-SM |  | % | عدد عشري | خاطئة | النسبة المئوية من إجمالي عدد الميزات التي هي إلزامية
انفتاح | المعايير القياسية وضوح، حتى |  | % | عدد عشري | خاطئة | النسبة المئوية من إجمالي عدد الميزات التي اختيارية
انفتاح | المعايير القياسية وضوح-SC |  | % | عدد عشري | خاطئة | النسبة المئوية من إجمالي عدد من الميزات التي تم تعريفها بشروط
انفتاح | الملفات الشخصية للالملف التوثيق-وثائق |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | جودة الوثائق القياسية 0:لا شيء 1:فقير 2: معرض 3: ممتاز
انفتاح | الملفات الشخصية للالملف التوثيق-الدقة |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | لا تعكس وثائق التصميم الفعلي للنظام؟ ما هو مستوى من الميزات الشخصي المستخدمة في النظام؟ 0:أي ميزات 1:بعض الملامح 2:معظم ميزات 3:كافة الميزات
انفتاح | الملفات الشخصية للالملف الوثائق النضج |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | هو ملف ناضجة ومتاحة؟ 0: مخصصة 1:القائمة على المشاريع 2:التنظيمي 3: عامة
انفتاح | لمحات-الملف-وضوح صريح العرض |  |  | عدد صحيح | خاطئة | عدد من الميزات القياسية المحددة كما هو مطلوب في الملف الشخصي
انفتاح | الملفات الشخصية للالملف وضوح-PM |  | % | عدد عشري | خاطئة | النسبة المئوية من الميزات الإلزامية في الملف الشخصي
انفتاح | الملفات الشخصية للالملف وضوح بو |  | % | عدد عشري | خاطئة | نسبة اختياري ملامح من الملف الشخصي
انفتاح | الملفات الشخصية للالملف وضوح-PC |  | % | عدد عشري | خاطئة | ميزات نسبة مشروط المحددة في الملف الشخصي
انفتاح | الملفات الشخصية للالملف وضوح-التغطية |  | % | عدد عشري | خاطئة | النسبة المئوية من الميزات القياسية موجهة تحديدا في الملف الشخصي
انفتاح | الملفات الشخصية للالملف ملحقات تمديد العرض |  |  | عدد صحيح | خاطئة | عدد غير القياسية الميزات التي يحددها الشخصي
انفتاح | الملفات الشخصية للالملف ملحقات التغطية |  | % | عدد عشري | خاطئة | النسبة المئوية للملحقات المفصلة في الملف الشخصي
انفتاح | توافر المنتجات المنتج والتوافق، عدد المنتجات |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | عدد من المنتجات التي تدعم ميزات الإلزامية للمعيار 0:لا توجد منتجات تدعم المعيار 1:واحد أو أكثر من المنتجات تنفيذ جزء من معيار 2:أكثر من منتج واحد بتنفيذ كافة أجزاء من معيار 3:العديد من المنتجات أكثر من واحد بتنفيذ كافة أجزاء من معيار
انفتاح | توافر المنتجات المنتج والتوافق، تطبيق التوافق |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | ما هو مستوى التوافق لم المنتجات يجب أن المعيار؟ 0:لا شيء 1:ادعى 2:تظاهر 3:شهادة وتظاهر
انفتاح | توافر المنتجات المنتج والمطابقة مطابقة الجودة |  | [0 | 1 | 2 | 3] | بحث / قائمة | خاطئة | نوعية اختبار التوافق 0:لا شيء 1:في منزل اختبار من قبل المطور المنتج 2:اختبارات مستقلة (مثل NIST) 3:تبين في سياق المنتجات ذات الصلة

مكون اتصال وخصائص العمارة

يسرد الجدول التالي المكون، واتصال والانتاج خصائص العمارة من قبل مقيم الانفتاح. كافة الخصائص التالية تقييم إلى ما بين صفر (0) وثلاثة (3)، صفر (0) كونها الأقل مرغوب فيه وثلاثة (3) كونها أكثر من المرغوب فيه.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح "الانفتاح الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لتغيير الخاصية الأساسية للمستودع ومحاكاة الانفتاح يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | نوع البيانات | مطلوب | الوصف
انفتاح | انفتاح | عدد عشري | خاطئة | تقييم شامل للانفتاح العنصر.
انفتاح | النضج المعايير القياسية | عدد عشري | خاطئة | الحالة الراهنة للمعيار، مما يعكس سواء تم أو لم يتم الموافقة عليها، منذ متى كان في استخدامها ومدى قبوله هو داخل مجتمع المطورين.
انفتاح | المعايير القياسية وضوح | عدد عشري | خاطئة | ووضوح المعايير، الأمر الذي يعكس الغموض المحتمل في المعايير التي تلت
انفتاح | الملفات الشخصية للالملف التوثيق | عدد عشري | خاطئة | تم تطوير مدى واجهة ملف الوثائق وإذا كانت وثائق الملف الشخصي يعكس تصميم النظام الفعلي و / أو نظام تنفيذها
انفتاح | الملفات الشخصية للوضوح الملف الشخصي | عدد عشري | خاطئة | مستوى التفاصيل الواردة في لمحة / ملف مواصفات
انفتاح | الملفات الشخصية للالملف ملحقات | عدد عشري | خاطئة | وإلى أي مدى ملف يتوافق مع المعايير التي يستند عليها
انفتاح | المنتجات توافر المنتج والتوافق | عدد عشري | خاطئة | أم لا يوجد منتجات نحو يتفق معيار مفتوح متاحة للاستخدام في المشروع


محاكاة الأداء

الملاحة: محاكاة العمارة الخاص> الطيران التشبيهي>

محاكاة الأداء

إرسال التعليقات حول هذا الموضوع.

خلفية

مقيم المعماري للأداء هو محاكاة الحدث المنفصلة التي تعمل من خلال محاكاة تدفق الرسائل (أو الرموز) في جميع أنحاء بنية. ويستمد النظرية وراء هذا من الأبحاث التي أجريت من قبل جامعة التكنولوجيا في سيدني، وتقوم على نماذج الطبقات الشبكة في قائمة الانتظار(LQNM)، موقوت وملونة بيتري نتس(TCPN) و آخر دورة رسم تخطيطي(ACD).

في محاكاة أداء ABACUS، هو الدافع المعالجة على عنصر واحد إلى حد كبير من الرسائل تمريرها إليه من مكون آخر. المبادئ الكامنة وراء هذه التقنية يمكن أن يفهم في أربعة أجزاء رئيسية:

1. ال رسالة-مركزيةوعلى غرار الاتصالات في ABACUS باستخدام منطقي(أو غير مباشرة) وصلات. اتصالات منطقية تحدد السلوك (تردد والبيانات) من الرسائل التي يتم تمريرها بين المكونات. وخير مثال الاتصالات المنطقية تدفقات تسلسل بين اثنين (2) العمليات التجارية أو واجهات منطقية بين اثنين (2) التطبيقات.

2. يتم نقل الرسائل المنطقية إلى وجهتهم عبر التسلسل الهرمي(مثل swimlanes الموارد) أو مباشرةالاتصالات (مثل الأسلاك المادية). للقيام بذلك يمكن توجيه ما يصل، عبر وتتراجع التسلسل الهرمي (نهج الطبقات) لمتابعة مسار مباشر.

3. الاخلاص للنموذج يمكن تعديلها لتناسب. على سبيل المثال، يمكن تقسيم عملية أسفل حتى الآن ان كل هذه العملية الابتدائية وظيفة لها بصمة معالجة منفصلة. بدلا من ذلك، قد تكون كافية لجعل قيمة واحدة فقط للعملية برمتها، الأمر الذي يعكس متوسطاستجابة التجهيز لرسالة.

4. الفعلية معالجةيتم تنفيذ إلا من خلال العناصر التي لديها (أو هي) معالج. أما المعالج هو شيء عام، ويمكن أن تكون وحدة المعالجة المركزية، شخص، وحدة تنظيمية أو أي شيء آخر غير قادرة على تنفيذ العمل. على سبيل المثال، عملية تجارية لا يفعل أي المعالجة الفعلية. يتم ذلك عن طريق أول "معالج" فإنه يقع في التسلسل الهرمي إما الأم (إذا تم استخدام التدوين swimlane) أو شبكة التجهيز لها (إذا تم استخدام منهج المعالجة الموزعة).

يتم إجراء تقييم من خلال محاكاة (المحدد) حركة المرور في النظام، بحيث يتم محاكاة كل اتصال مرة واحدة على الأقل. يتم إنشاء أوقات وصول الرسائل بشكل عشوائي فيما يتعلق تيرتها المحدد. نموذج يحاكي تجهيز الموارد والخلاف وقوائم انتظار الرسائل، وجمع الإحصاءات على طول الطريق وخصائص الإنتاج المختلفة.

الرئيسية عوامل الأداء الإدخال

1. تردد- التردد الذي يحدث الاتصال.

2. معالجة- مقدار الوقت لإكمال تنفيذ عملية واحدة. قد يكون هذا في الساعات والدقائق والأيام والعمليات الخ

3. سرعة- سرعة موارد المعالج. وهذا هو، كم عدد الدورات / تعليمات / الإجراءات التي يمكن القيام بها في وحدة واحدة من الزمن. من المهم أن تكون متسقة مع الوحدات المستخدمة للتجهيز.

4. المعالجات- عدد من موارد المعالج. المعالجات يمكن أن يكون الناس، وحدة المعالجة المركزية، والمنظمات الخارجية الخ

الرئيسية عوامل الأداء الناتج

1. الإنتاجية- عدد الرسائل لكل وحدة وقت من خلال الاتصال. ويمكن مقارنة هذه القيمة الفعلية مع القيم المتوقعة / النظرية (أي تردد) للاستدلال تشبع النظام.

2. رسالة أسعار- عدد الرسائل لكل وحدة وقت من خلال مكون. هذا هو مجموع الرسائل الواردة والصادرة جميع المكونات ".

3. استجابة- الحد الأدنى / متوسط ​​/ أقصى الكمون لهذا الاتصال. هذا هو مجموع كل الإختفاء المرصودة للاتصال من المصدر إلى الحوض وأي الطابور والتجهيز (والكمون إلى المصدر إذا ثنائي الاتجاه).

4. استخدام- الاستفادة من مكون. هذا وسوف تكون 0٪ إذا كان العنصر هو ليس جهاز / المعالج (أي أنه ليس لديها معالجات وخصائص السرعة المحددة أعلاه).

في حين يتم إجراء محاكاة الحدث منفصلة لحساب مختلف خصائص الإخراج، كما هو موضح أعلاه، الصيغة التالية يمكن استخدامها بوصفها التحقق الخام من النتائج (التي لا تشبع النظام):

UTILISATION = مجموع تردد عن كافة الاتصالات الواردة * تجهيز / (سرعة * المعالجات)

وربما كان أفضل أثبت المفهوم الشامل من خلال النظر في الرسم البياني التالي، مما يدل على اثنين من أداء الفوقية نماذج مختلفة. النمط الأيسر هو تدوين الكلاسيكية swimlane 'مع مهام معالجة أساس هرمي داخل موارد المعالج بهم. الحق أسلوب اليد هو تدوين "توزيع" مع معالجة المهام المتصلة عبر اتصال العمليات لموارد المعالج بهم. هذه الرموز الأخير يسمح موارد المعالج متعددة لمهمة معالجة معينة، خلافا للتدوين swimlane محدودة.

ملاحظة

يظهر على كل نموذج الفوقية هي خصائص الإدخال (باللون الأحمر) وخصائص الإخراج (باللون الأزرق):

أداء الفوقية نماذج: Swimlane مقابل تدوين الموزعة

تشغيل محاكاة الأداء

لمحاكاة العمارة الخاص من حيث الأداء

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. اختار تحليل| أداءأو انقر فوق زر شريط الأدوات.

3. حدد هندسة معماريةكنت ترغب في تقييم من القائمة المنسدلة.

ملاحظة

افتراضيا، سوف ABACUS حدد العمارة الأولى التي لا بد من إعادة محاكاة بسبب أي عقارا أو التغييرات الهيكلية تلقائيا.ويظهر هذا في تسليط الضوء على أحمر على شريط أدوات المحاكاة .

4. حدد مكوناتو روابطكنت ترغب في تقييم، من نافذة اختيار عنصر قياسي .

5. تعيين وقت تشغيل عامل المقياسالمنزلق.

ملاحظة

والقيم العليا تسفر عن أكثر إحصائيا نتائج متسقة ولكن يستغرق وقتا أطول لحساب.

إضافي مربع الى ال نافذة اختيار عنصر قياسي

· Sافي تحولت نموذج سوف حفظ نسخة من إصدار RBD تحولت من المشروع في نفس المجلد مثل المشروع الحالي وإلحاق "_transformed" إلى اسم المشروع.ويمكن استخدام هذا المشروع تحولت لتشخيص بالتفصيل محاكاة الموثوقية التي تقوم بها ABACUS.

خيارات أخرى لل نافذة اختيار عنصر قياسي

· وقت تشغيل عامل المقياس يسيطر على محاكاة الوقت ودقة مع أعلى قيم المحصولجيأكثر إحصائيا نتائج متسقة ولكن مع الأخذ قتا أطول ل اركض.

ملاحظة

عندما يحسب ABACUS الوقت المحاكاة أنها ستحدد أبطأ وتيرة الاتصال غير المباشر التي تم تحديدها لتكون محاكاة وثم 'الاحماء' عن الفترة (أي 1 على تردد) من هذا الاتصال (بدء المولدات رسالة دورية لكافة الاتصالات عشوائيا خلال هذا الوقت الاحماء، ومنحهم كل فرصة لبدء) ثم محاكاة للمرة وقت تشغيل عامل المقياس الفترة من هذا الصدد. أو (1 / التردد) وقت الاحماء + (1 / التردد) * مدة الفيلم مقياس عامل الوقت المحاكاة. هذا هو التأكد من أن يتم البدء أن كافة الاتصالات قبل أن يتم جمع الإحصاءات وثم لا يزال محاكاة أبطأ اتصال مرة واحدة على الأقل في المحاكاة. مثلا إذا أبطأ الاتصال غير المباشر لديه تردد من 0،033 وحدات الزمن (أو حوالي مرة كل شهر إذا كانت وحدات الوقت هي أيام) ثم فإن الوقت الاحماء تكون 30.3 وحدات الزمن والوقت المحاكاة سيكون 30.3 وحدات الوقت مرة الوقت تشغيل عامل المقياس.

6. انقر إنهاءوستحصل على تحذيرالحوار.

7. اختياريا استكشاف تحذيرات بالضغط التفاصيل >>.

8. انقر أكمل.

ملاحظة

عند هذه النقطة، سوف ABACUS إجراء محاكاة منفصلة الحدث من الهندسة المعمارية وبعد وقت قصير (مع أشرطة التقدم لردود الفعل) سيظهر مربع حوار حساب كامل.

9. انقر حسناالاعتراف المحاكاة.

تلميح

للدورات التدريبية ومزيد من المساعدة على محاكاة الأداء يرجى الرجوع إلى Avolution الجماعة .

خصائص عنصر

يسرد الجدول التالي الخصائص المطلوبة لتقييم الأداء. يتم البحث الخصائص لأول مرة في الحالات المكونات، ثم المعايير مكون وإذا لم يتم العثور على يتم استخدام الافتراضي.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز إدخال خاصية صف محدد ( [image] ) مع تلميح "أداء الإدخال". وهناك تغيير في أي من هذه "الإدخال" خصائص والتغيرات الهيكلية المختلفة إلى المخزون يؤدي إلى محاكاة الأداء تتطلب إعادة المحاكاة كما هو مبين في أحمر على شريط أدوات المحاكاة .

اكتب | اسم | القيمة الافتراضية | وحدة | نوع البيانات | مطلوب | الوصف
سلوك | b_pack | 0.0 |  | عدد عشري | خاطئة | الوقت الخدمة الثابتة لحزمة في ثوان. هذا العقار هو عادة المحدد كنوع قياسي ومن ثم تستخدم لحالات مكون متعددة. على سبيل المثال، كوربا لديها b_pack = 0.23 مللي ثانية.
سلوك | m_pack | 0.0 |  | عدد عشري | خاطئة | الوقت خدمة متغير لحزمة في ثواني / بايت. هذا العقار هو عادة المحدد كنوع قياسي ومن ثم تستخدم لحالات مكون متعددة.
سلوك | b_unpack | 0.0 |  | عدد عشري | خاطئة | الوقت الخدمة الثابتة إلى فك في ثوان. هذا العقار هو عادةالمحدد كنوع قياسي ومن ثم تستخدم لحالات مكون متعددة.
سلوك | m_unpack | 0.0 |  | عدد عشري | خاطئة | الوقت خدمة متغير إلى فك في ثواني / بايت. هذا العقار هو عادةالمحدد كنوع قياسي ومن ثم تستخدم لحالات مكون متعددة.
سلوك | معالجة | 0.0 |  | عدد عشري | حقيقي | مقدار الوقت لإكمال تنفيذ عملية واحدة. قد يكون هذا في الساعات والدقائق والأيام والعمليات الخ
سلوك | المعالجات | 1 |  | عدد صحيح | حقيقي | عدد موارد المعالج. المعالجات يمكن أن يكون الناس، وحدة المعالجة المركزية، والمنظمات الخارجية الخ
سلوك | سرعة | 100 |  | عدد صحيح | حقيقي | سرعة موارد المعالج. وهذا هو، كم عدد الدورات / تعليمات / الإجراءات التي يمكن القيام بها في وحدة واحدة من الزمن. من المهم أن تكون متسقة مع الوحدات المستخدمة للتجهيز.
سلوك | k_bkgd | 0.0 |  | عدد عشري | خاطئة | معالجة الخلفية على العنصر. هذا وتستخدم لضبط النتائج لتتوافق مع أي تعويضات ثابتة ل٪. هذا يمكن ربما يمكن تجاهلها.

يسرد الجدول التالي إخراج خصائص مكون من مقيم الأداء. يتم إنشاء مجموعة من هذه الخصائص المكونة لكل مكون على كل تشغيل الأداء.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح الأدوات "الأداء الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة الأداء يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
سلوك | رسالة أسعار |  | عدد عشري | خاطئة | عدد الرسائل لكل وحدة الزمن من خلال المكون. هذا هو مجموع الرسائل الواردة والصادرة جميع المكونات ".
سلوك | عرض النطاق الترددي |  | عدد عشري | خاطئة | عرض النطاق الترددي الكلي من خلال عنصر. المبالغ المستحقة على الرسائل الواردة والصادرة على السواء.
سلوك | استخدام | % | عدد عشري | خاطئة | الاستفادة من العنصر. هذا وسوف تكون 0٪ إذا كان العنصر هو ليس جهاز / المعالج (أي انها لا تملك معالجات وخصائص السرعة المحددة أعلاه)

خصائص اتصال

يسرد الجدول التالي الخصائص المطلوبة لتقييم الأداء. يتم البحث الخصائص لأول مرة في حالات اتصال، ثم المعايير اتصال وإذا لم يتم العثور على يتم استخدام الافتراضي.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز إدخال خاصية صف محدد ( [image] ) مع تلميح "أداء الإدخال" أو "التكلفة / الأداء الإدخال". وهناك تغيير في أي من هذه "الإدخال" خصائص والتغيرات الهيكلية المختلفة إلى المخزون يؤدي إلى محاكاة الأداء و / أو تكلفة محاكاة تتطلب إعادة المحاكاة كما هو مبين في أحمر على شريط أدوات المحاكاة .

اكتب

اسم

القيمة الافتراضية

وحدة

نوع البيانات

مطلوب

الوصف

سلوك

طيب القلب

ثنائية الاتجاه

[ثنائي الاتجاه | أحادي الاتجاه]

بحث / قائمة

حقيقي

ما إذا كان الاتصال هو في اتجاهين (ثنائي الاتجاه) أو في اتجاه واحد (أحادي الاتجاه).

القيم المسموح بها لهذا العقار هي "ثنائية الاتجاه" أو "أحادي الاتجاه".

ثنائي الاتجاه يعني رسائل طلب / استجابة متزامن في حين الوسائل أحادي الاتجاه لغير متزامن "الحدث" واحد.

سلوك

التجريد

غير مباشر

[غير مباشر | مباشرة]

بحث / قائمة

حقيقي

سواء كان الاتصال البدني أو منطقية. الاتصالات المباشرة "أنابيب" المادية بين المكونات التي تتدفق صلات منطقية على طول.

القيم المسموح بها لهذا العقار هي "مباشرة" أو "غير المباشرة".

إذا كانت القيمة "مباشرة" ثم الاتصال لا تحتاج إلى أي خصائص أخرى (باستثناء خصائص نوع وتجريد).

البيانات

L_app1

0

عدد صحيح

خاطئة

طلب / حجم الحدث في بايت.

وكل اتصال وعادة ما يكون قيمة محددة لهذا الغرض. في كوربا، والأحداث هي ثنائية الاتجاه في الواقع ودائما لديها بايت 12 يعترف (L_app2). إذا كان اتصال أحادي الاتجاه الصحيح ثم يستبعد الملكية L_app2.

البيانات

L_app2

0

عدد صحيح

خاطئة

استجابة / يعترفون حجم بالبايت.

وكل اتصال وعادة ما يكون قيمة محددة لهذا الغرض. وهناك اتصال أحادي الاتجاه لا يكون L_app2.

سلوك

تردد

1

عدد عشري

حقيقي

التردد الذي يحدث الاتصال.

وكل اتصال وعادة ما يكون قيمة محددة لهذا الغرض. إذا تم ترك التردد الملكية من ثم يتم استخدام الافتراضي.

سلوك

علاقة

العمليات

[العمليات | تدعم]

بحث / قائمة

خاطئة

الاتصالات التي لديها "العمليات" الملكية تشير إلى أن عنصر في بداية الاتصال سيتم تحويلها إلى معالجتها في عنصر في نهاية الاتصال. في الواقع يتم نقل عنصر "مصدر" لتصبح الطفل المكون "مصدر" (الاتصالات المرفقة هي أيضا "جر" مع هذه الخطوة).

في حالة وجود "عمليات" الملكية ثم سيتم تجاهل كافة الخصائص اتصال أخرى، باستثناء اختياري الممتلكات "٪" هو موضح أدناه.

سلوك

%

100.0

عدد عشري

خاطئة

الاتصالات التي لديها "العمليات" الملكية (المذكورة أعلاه) يمكن أن يكون اختياريا خاصية "٪" للدلالة على نسبة من المعالجة التي يمكن أن يعزى إلى عنصر الوجهة. وبهذه الطريقة يمكن معالجة عنصر مصدر واحد بواسطة مكونات الوجهة متعددة في مختلف٪ الصورة. لا تحتاج القيم٪ لتضيف ما يصل الى 100٪ ويتم استخدامه ببساطة لتوسيع نطاق الملكية "معالجة" (انظر أعلاه) للمكون المصدر الذي يتم تحويله ليصبح الطفل العنصر الوجهة.

يسرد الجدول التالي الخصائص التي تم إنشاؤها بواسطة مقيم الأداء. يتم إنشاء مجموعة من هذه الخصائص اتصال لكل اتصال في كل شوط الأداء.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح الأدوات "الأداء الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة الأداء يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
سلوك | عرض النطاق الترددي |  | عدد عشري | خاطئة | عرض النطاق الترددي الكلي للاتصال. ويحسب هذا فقط من أجل اتصالات غير مباشرة وهي في جوهرها (L_app1 + L_app2) * الإنتاجية.
سلوك | عرض النطاق الترددي 1/2 |  | عدد عشري | خاطئة | عرض النطاق الترددي خصيصا لالصادرة (1) والواردة (2) رسائل الاتصال. ويحسب هذا فقط من أجل اتصالات غير مباشرة وغير أساسا L_app1 * الإنتاجية وL_app2 * الإنتاجية.
سلوك | الإنتاجية |  | عدد عشري | خاطئة | عدد الرسائل لكل وحدة وقت من خلال الاتصال. ويمكن مقارنة هذه القيمة الفعلية مع القيم المتوقعة / النظرية (أي تردد) للاستدلال تشبع النظام.
سلوك | منجز | % | عدد عشري | خاطئة | النسبة المئوية لمعالجة الرسائل التي تكمل بنجاح للاتصال. ويحسب هذا فقط من أجل اتصالات غير مباشرة وغير الإنتاجية / التردد. في بعض الأحيان قيمة مكتمل تجاوزت 100٪ لأن العشوائية النتائج جيل الرسالة في أعلى قليلا الجيل رسالة تردد من المحدد.
سلوك | استجابة (مين / افي / ماكس) |  | عدد عشري | خاطئة | الحد الأدنى / متوسط ​​/ أقصى الكمون. ويحسب هذا فقط من أجل اتصالات غير مباشرة وغير الكمون الملحوظ للاتصال من مصدر لإغراق وأي الطابور والتجهيز (والكمون إلى المصدر إذا ثنائي الاتجاه).

خصائص العمارة

يسرد الجدول التالي الخصائص على نطاق المنظومة المعمارية التي تم إنشاؤها بواسطة مقيم الأداء. وهناك مجموعة واحدة من خصائص العمارة هي "تجميع" لتشغيل كل الأداء.وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح الأدوات "الأداء الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة الأداء يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
سلوك | رسالة أسعار |  | عدد عشري | خاطئة | عدد الرسائل لكل وحدة وقت من خلال المكونات في الهندسة المعمارية. هذا هو مجموع الرسائل الواردة والصادرة جميع المكونات ".
سلوك | الإنتاجية |  | عدد عشري | خاطئة | عدد الرسائل لكل وحدة الزمن من خلال الاتصالات في الهندسة المعمارية. هذا هو مجموع الانتاجية كافة الاتصالات غير المباشرة "ويمكن مقارنة هذه القيمة الفعلية مع القيم المتوقعة / النظرية (أي تردد) للاستدلال تشبع النظام.
سلوك | عرض النطاق الترددي |  | عدد عشري | خاطئة | عرض النطاق الترددي الكلي. مجموع عرض النطاق الترددي الصدد الهندسة المعمارية.
سلوك | استخدام | % | عدد عشري | خاطئة | الاستفادة من جميع المكونات. يمكن أن يكون أكبر من 100٪ كما أنها ليست سوى مجموع كل utilisations المكون الهندسة المعمارية.
سلوك | استجابة (مين / افي / ماكس) |  | عدد عشري | خاطئة | الحد الأدنى / متوسط ​​/ أقصى الكمون. مجموع كل الإختفاء وحظ للاتصالات في الهندسة المعمارية من المصدر إلى تغرق (والعودة إلى المصدر إذا ثنائي الاتجاه).


محاكاة الموثوقية والتوفر

الملاحة: محاكاة العمارة الخاص> الطيران التشبيهي>

محاكاة الموثوقية والتوفر

إرسال التعليقات حول هذا الموضوع.

خلفية

والموثوقية مقيم يحسب موثوقية العمارة باستخدام مكونات المدخلات والاتصالات.

لمكونات وصلات مباشرة، ويستند الاعتماد على متوسط ​​الوقت بين الفشل (MTBF). المتغيرات الوحيدة اللازمة لحساب موثوقية العناصر المعمارية هي:

· ال MTBFالقيمة (في سنوات)؛

· ال يعني الوقت لإصلاح (MTTR)فشل (في سنوات)؛ و

· لفترة محددة من الوقت لاختبار الموثوقية أكثر.

وبالنظر إلى الصيغة المستخدمة في حساب الثبات على النحو التالي:

الموثوقية = -e (-y × العمر)
حيث y = 1 ÷ MTBF

ويستند توافر المكونات والاتصالات على MTBF وMTTR. لاحظ أن توفر، على عكس الموثوقية، لا يتأثر الفترة الزمنية التي يتم اختباره.

توافر = MTBF / (MTBF + MTTR)

بينما الأساليب التي تحول الموثوقية كتلة رسم تخطيطي(باستخدام سلسلة بسيطة وبنيات موازية) تعطي أكثر النتائج الدقيقة، وهذه الأساليب أصبحت غاية ايمعملي عندما نحاول حساب موثوقية للبعثات داخل شبكات ضخمة الآلاف من العناصر. وعلاوة على ذلك، فإن هذه المقاربات التحويلية كسر للعديد من الهياكل المشتركة، مثل شبكة "تنسجم".

ال مونتي كارلويسمح طريقة موثوقية وتوافر نظام للحجم التعسفي والتعقيد إلى أن تحسب. طريقة مونت كارلو يحاكي العديد من السيناريوهات ووأو كل سيناريو حالة عشوائية، متاح أو غير متوفره، تم تعيينه إلى كل عنصر المادي. ويستند احتمال وجود عنصر معين كونها في حالة المتاحة على موثوقية / توافر عنصر.

على سبيل المثال، عنصر مع توافر 90٪ من المتوقع أن تكون متاحة في ما يقرب من 90٪ من الحالات. وبالتالي يمكن تقدير موثوقية الاتصال غير المباشر وتوفر مثل نسبة scenarios- عشوائي التي مسار من العناصر موجود في الوالية المتاحة من المصدر إلى الوجهة.

ملاحظة

منذ يستند حساب موثوقية المحلية ومدى توافر الإمكانية عند معلمات مختلفة وصيغ مختلفة (وبالتالي يؤدي إلى قيم مختلفة)، فمن الضروري تعيين كل عنصر اثنانالدول، واحدة لحجز واحدة لالموثوقية. حساب توافر يستخدم الدولة توفر في كل سيناريو، في حين أن حساب موثوقية يستخدم الدولة الموثوقية في كل سيناريو.

يستخدم مقيم موثوقية تقنية محاكاة مونت كارلو للعمل على موثوقية بنية معينة. يتم وضع العمارة من خلال الآلاف من عمليات المحاكاة الفردية والنتائج جدولة لاستخلاص قياس الموثوقية. كما ذكر أعلاه، مونتي كارلو هي أسرع طريقة لمحاكاة شبكات أكبر وستعمل مع أي المعقدة (مثل مزجها) هيكل.

مقيم بإخراج أربع قيم:

1. بعثة الموثوقيةعلى مدى عدد من السنوات.

2. توفر من هندسة معمارية;

3. الموثوقية من المكون المحليعلى مدى عدد من السنوات. و

4. توفر من المكون المحلي.

مقيم يعمل بها احتمال ال مكون أو عمل اتصال (أي عدم التقصير) والوقت اللازم لإصلاحه.

كيف المعايير مع MTBFs و / أو MTTRs تمت معالجتهم

إذا عنصر (مكون أو اتصال) لديها معايير مع MTBF تعيين و / أو MTTR القيم، وتستخدم هذه القيم أيضا في حساب موثوقية المحلية وتوفر عنصر كاتصال سلسلة.

على سبيل المثال، إذا كان عنصر A، مع معايير تعيين B, Cو Dكل ديك MTBF وMTTR قيمة محلي الموثوقية = R(A)× R(B) × R(C) × R(D)، أين R = موثوقية المحسوبة (باستخدام الصيغة) المكون / المعاييرو محلي فائدةالقدرة = ا(A)× ا(B) × ا(C) × ا(D)، أين A = تحسب فائدةالقدرة (باستخدام الصيغة) المكون / المعايير. وهذا هو، إذا كان العنصر لديه ثلاثة معايير كل مع MTBF وMTTR القيمةs، وأيضا MTBF وMTTR القيمةsلخواص العنصر، وموثوقية المحلية وتوافره وتعطى كقيمة سلسلة من كل من المعايير والعنصر نفسه.

وكمثال آخر، إذا كان عنصر Aلديها معايير تعيين B, Cو Dولكن المعيار الوحيد Bعلى حد سواء لMTBF وقيمة MTTR، في حين أن معيار Cليس لديها سوى قيمة MTBF ومستوى Dليس لديها سوى قيمة MTTR محلي الموثوقية = R (A)× R (B)× R (C)، أين R= موثوقية المحسوبة (باستخدام الصيغة) المكون / المعايير والمحلية توفر = A (A)× A (B)× A (C)، أين A= توافر المحسوبة (باستخدام الصيغة) المكون / المعايير ولكن في حساب A (C) لأن معيار له قيمة MTBF فقط أنها 'البحث'لقيمة MTTR مطابقة (ق) وسوف تضيف كل MTTR تقدر أنه يرى أن ارتداء'ر أنفسهم لها قيمة MTBF المطابقة، حتى في هذه الحالة فإنه استخدم القيمة MTTR القياسية D. إذا كان هناك معيار آخر، ويقول E، مع مجرد قيمة MTTR فضلا ثم A (C)ستستخدم MTBF من Cمع MTTR من Dو Eوأضاف معا. إذا معيار آخر، ويقول F، كان مجرد قيمة MTBF ثم A (F)من شأنه أيضا أن استخدام MTTR من Dو Eوأضاف معا.

حساب بعثة الموثوقية

أثناء حساب موثوقية المحلية هي مسألة باستخدام صيغة بسيطة، وحساب من الاتصالات غير المباشرة (مهمة) ليس من السهل، خصوصا بعد أن نكون قد شبكات معقدة وكبيرة من مسارات المتداخلة (اتصالات) والمكونات.

اتخاذ شبكة كاملة في الاعتبار

كما الاتصالات غير المباشرة لا تمثل اتصال فعلي، يجب علينا معرفة كيف يمكن الحصول على العنصر المصدر إلى عنصر وجهتها. وهذا يعني النظر في الشبكة بالكامل وجميع الطرق المختلفة (ومسارات) المكون مصدرنا يمكن أن تتخذ للوصول إلى العنصر الوجهة (بالوعة).

ملاحظة

طالما هناك على الأقل واحد كاملمسار من المصدر إلى الوجهة، فإن المهمة ستكون ناجحةويشار إلى اتصال غير مباشر لكاتصال مغلق.

فهم مصفوفة لينك

لمعرفة أي مكونات / اتصالات مباشرة تتصل ما، نحن بحاجة إلى الحرفية للتحقق بسرعة ما إذا كان يتم توصيل مبنيين في اتجاه معين. هذه هي وظيفة مصفوفة الارتباط. وباختصار، فإن مصفوفة الارتباط هو مجموعة الأبعاد من متغيرات منطقية التي تنص على ما إذا كان عنصر معين يمكن أن تصل إلى مكون آخر مباشرة. حجمه يساوي مربع من العدد الكلي للمكونات في الشبكة.

A بسيطة الموثوقية رسم بياني (RBD)

ذات صلة مصفوفة لالموثوقية رسم بياني (RBD)

وليس كل التوصيلات ثنائية الاتجاه (الذهاب في كلا الاتجاهين)، فمن المهم معرفة كيفية قراءة مصفوفة الارتباط بشكل صحيح. في التقييم موثوقية، فإن الحجة الأولى هي المصدر والحجة الثانية هي الوجهة (بالوعة).

ولذلك إذا كان الارتباط مصفوفة (A، B) = صحيح فإن ذلك يعني أن هناك يمكن الحصول على B مباشرة (أحادي الاتجاه). B يمكن الحصول على A إذا إلا إذا مصفوفة الارتباط (B، A) = TRUE. إذا كان هذا صحيحا، وهذا يعني اتصال ثنائية الاتجاه.

في المثال المذكور فوق:

· مصدر 1 يمكن أن تصل إلى المقصد 0 (مصدر 1 والوجهة 0 يعطي نتيجة صحيح)؛ و

· المصدر 0 يمكن أن تصل إلى المقصد 1 (0 المصدر والوجهة 1 يعطي نتيجة صحيح)، والرابط بين 0 و 1 هو ثنائي الاتجاه.

· المصدر 2 لا يمكن أن تصل إلى المقصد 1 (المصدر 2 و 1 الوجهة يعطي نتيجة خطأ) حتى عندما المصدر 1 يمكن أن تصل إلى المقصد 2 (مصدر 1 و 2 الوجهة يعطي نتيجة صحيح). هذا يعني أن الارتباط بين 1 و 2 هو أحادي الاتجاه.

فهم الموثوقية رسم بياني

الرسم التخطيطي كتلة الموثوقية (RBD) بتغليف هيكل نموذج الكائن بأكمله من حيث الكتل والروابط. كل كتلة يمثل أحد العناصر التي لديها إمكانية فشل أو نجاح وفقا لارتباطات / المسارات التي ربطها. كل من المكونات والاتصالات يمكن أن تصبح "كتلة" في RBD.

مثال RBD كتل وسريعة

الرقم يمثل أعلاه مثال RBD. خط أحمر متقطع يمثل مهمة واحدة 4 إلى 1. ملاحظة كيف أن هناك اثنين فقط من المسارات الممكنة لبعثة 4-1.

النظر في الطريق 4-3 إلى 0-1، والطريق 4-7 إلى 1. كتل منقط 2، 5و6 تمثيل الكتل التي لا تؤثر على فشل / عدم الفشل لمهمة 4 إلى 1. لا تعتبر أنها ويتم تجاهل. هذا هو المهم بالنسبة لمعظم البعثات سيكون هناك عدد كبير من القطع الزائدة عن الحاجة التي لن تؤثر على نجاح بعثة معينة. هذا هو أكثر وضوحا في شبكات أكبر حيث عدد القطع الزائدة سيجعل نتائج المحاكاة غير دقيقة.

لتسريع وقت المحاكاة، وضمان الحصول على نتائج أكثر دقة، فإنه من الضروري مجردة من RBD بأكمله وتستخدم فقط العناصر التي تؤثر على نجاح البعثة.

ملاحظة

والطريق / مسار واحد لا يمكن ان يستمر من خلال أي مكون مرتين.

في هذه المرحلة يمكننا إنشاء مصفوفة الارتباط وإجراء محاكاة مونت كارلو.

حساب العمارة التوفر

توافر العمارة هو احتمال أن كافة الاتصالات غير المباشرة سوف تكون متاحة في أي وقت من الأوقات. يتم تحديد مدى توافر كل اتصال غير مباشر خلال كل التكرار من محاكاة مونت كارلو، ولكن هذه الاتصالات غير المباشرة (عادة) تعتمد على نفس مجموعة من العناصر المادية. ولذلك، ببساطة مجموعها هذه الكميات المتاحة الفردية أن "المزدوج العد" هذه الكميات المتاحة من الامم المتحدة و، وإعطاء تشاؤما توافر العمارة بشكل عام. بدلا من ذلك، يتم احتساب توافر بنية الشامل من خلال النظر في كل تكرار ورؤية ما إذا كانت العناصر المتورطة في الاتصالات غير المباشرة لمصلحة المتاحة. ومن ثم تجميع هذه النتائج في نهاية المحاكاة.

تشغيل محاكاة الموثوقية

لمحاكاة العمارة الخاص من حيث الموثوقية

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. اختار تحليل| الموثوقية.

3. حدد هندسة معماريةكنت ترغب في تقييم من القائمة المنسدلة.

ملاحظة

افتراضيا، سوف ABACUS حدد العمارة الأولى التي لا بد من إعادة محاكاة بسبب أي عقارا أو التغييرات الهيكلية تلقائيا.ويظهر هذا في تسليط الضوء على أحمر على شريط أدوات المحاكاة .

4. حدد مكوناتو روابطكنت ترغب في تقييم من نافذة اختيار عنصر قياسي باستخدام 'عرض اتصالات المباشرة "و" إظهار العمليات اتصالات "مرشحات الراديو على زر في الجزء السفلي الأيسر من مربع الحوار لمساعدة معك الاختيار.

إضافي مربع الى ال نافذة اختيار عنصر قياسي

· Sافي تحولت نموذج سوف حفظ نسخة من إصدار RBD تحولت من المشروع في نفس المجلد مثل المشروع الحالي وإلحاق "_transformed" إلى اسم المشروع.ويمكن استخدام هذا المشروع تحولت لتشخيص بالتفصيل محاكاة الموثوقية التي تقوم بها ABACUS.

براديو إضافيةأزرار الى ال نافذة اختيار عنصر قياسي

· عرض وصلات مباشرة سيتم تعيين تلقائيا اتصال ديه مرشح عقار للخاصية نوع = السلوك، اسم = التجريد والقيمة = مباشرة.يتم تحديد هذا الخيار افتراضيا والإيدز اختيار الاتصالات "المباشرة" كما هو موضح أعلاه وأدناه.

· مشاهدة العمليات اتصالات سيتم تلقائيا تعيين اتصال ديه مرشح عقار للخاصية نوع = السلوك، اسم = العلاقة والقيمة = العمليات.هذا الخيار الإيدز اختيار الاتصالات "المباشرة" كما هو موضح أعلاه وأدناه.

5. انقر التالى.

6. اختر ال البعثاتأي اتصالات التي ترغب في تضمينها في المحاكاة.

7. تعيين وقت تشغيل عامل المقياسالمنزلق.

ملاحظة

والقيم العليا تسفر عن أكثر إحصائيا نتائج متسقة ولكن يستغرق وقتا أطول لحساب.

مربعات

· تبين اتصالات مغلقة سوف تصفية تلقائيا المتاحة صلات لتشمل فقط تلك التي لديها واحد على الأقل المسار الفعلي الكامل من العنصر المصدر إلى عنصر جهة وفقا لاختيار RBD المذكورة أعلاه.

· عرض اتصالات غير المباشرة سيتم تعيين تلقائيا اتصال ديه مرشح عقار للخاصية نوع = السلوك، اسم = التجريد والقيمة = غير المباشرة.يتم تحديد هذا الخيار افتراضيا والإيدز اختيار اتصالات "غير المباشرة" أو بعثة كما هو موضح أعلاه وأدناه.

أزرار

· جميعيختار كل روابط.

· عكسيتم إزالة جميع المحدد حاليا روابط ويختار كل تلك التي لم يتم اختيارها.

· لا شيءيتم إزالة جميع روابط.

خيارات أخرى

· وقت تشغيل عامل المقياس يسيطر على محاكاة الوقت ودقة مع أعلى قيم المحصولجيأكثر إحصائيا نتائج متسقة ولكن مع الأخذ قتا أطول ل اركض.

ملاحظة

عندما يحسب ABACUS عدد التكرارات لمحاكاة فإنه سيتم تحديد العنصر الأكثر موثوقية غير موثوق بها تماما ومن ثم محاكاة للمرة وقت تشغيل عامل المقياس 1 على عدم توفر هذا العنصر زائد 1 التكرار. أو (MTBF + MTTR) / MTTR * وقت تشغيل عامل المقياس + 1. هذا هو التأكد من أن هذا العنصر لا يزال يفشل مرة واحدة على الأقل في المحاكاة. مثلا إذا كان العنصر الأكثر موثوقية غير موثوق بها تماما لديه MTBF من 10،000 ساعة وMTTR من 8 ساعات ثم فإن المحاكاة تأخذ (10000 + 8) / 8 = 1251 مرة من عامل تشغيل الساعة مقياس + 1 التكرار.

· سنوات لمحاكاة الأمام يحدد عدد السنوات لالموثوقية البعثة تحسب ل.

· Nبني مصفر من المواضيعديtermines عدد المواضيع المعالجة لاستخدامها لمحاكاة مونت كارلو.هذا الخيار سوف تتخلف لتتناسب مع عدد من وحدات المعالجة المركزية المتوفرة / النوى (بما في ذلك النوى الترابط) لتقليل الوقت المحاكاة بشكل عام.

8. انقر إنهاءوستحصل على تحذيرالحوار.

9. اختياريا استكشاف تحذيرات بالضغط التفاصيل >>.

10. انقر أكمل.

ملاحظة

عند هذه النقطة، سوف ABACUS إجراء مونتي كارلومحاكاة العمارة وبعد وقت قصير (مع أشرطة التقدم لردود الفعل) سيظهر مربع حوار حساب كامل.

11. انقر حسناالاعتراف المحاكاة.

تلميح

للدورات التدريبية ومزيد من المساعدة على الموثوقية محاكاة يرجى الرجوع إلى Avolution الجماعة .

خصائص عنصر واتصال

يسرد الجدول التالي المكون و 'مباشرة'خصائص الاتصال المطلوبة لتقييم الموثوقية. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز إدخال خاصية صف محدد ( [image] ) مع تلميح "الإدخال الموثوقية. وهناك تغيير في أي من هذه "الإدخال" خصائص والتغيرات الهيكلية المختلفة إلى المخزون يؤدي إلى محاكاة الموثوقية التي تتطلب إعادة المحاكاة كما هو مبين في أحمر على شريط أدوات المحاكاة .

اكتب | اسم | القيمة الافتراضية | وحدة | نوع البيانات | مطلوب | الوصف
الموثوقية | MTBF | ∞ | سنوات أو أسابيع أو أيام أو ساعات | عدد عشري | حقيقي | الوقت نفسه قبل فشل عنصر. ملاحظة: يمكن التعبير عن القيم في وحدات من السنوات والأسابيع والأيام أو ساعة، ويتم تحويلها بعد '24 / 7 'توافر مفهوم النحو التالي؛ - 1 سنة = 52 أسبوعا أو 365 يوما أو 8760 ساعة - 1 = 7 أيام في الأسبوع أو 168 ساعة - 1 يوم = 24 ساعة
الموثوقية | MTTR | 0 | سنوات أو أسابيع أو أيام أو ساعات | عدد عشري | حقيقي | ومتوسط ​​الوقت لاصلاح العنصر. ملاحظة: يمكن التعبير عن القيم في وحدات من السنوات والأسابيع والأيام أو ساعة، ويتم تحويلها بعد '24 / 7 'توافر مفهوم النحو التالي؛ - 1 سنة = 52 أسبوعا أو 365 يوما أو 8760 ساعة - 1 = 7 أيام في الأسبوع أو 168 ساعة - 1 يوم = 24 ساعة

يسرد الجدول التالي المكون و 'مباشرة' الناتج خصائص الاتصال من قبل مقيم الموثوقية. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح "الاعتمادية الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة الموثوقية يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
الموثوقية | الموثوقية - س سنوات |  | عدد عشري | خاطئة | احتمال أن لن تفشل عنصر في غضون السنوات المقبلة س. هذا هو قيمة بين 0 و 1.
الموثوقية | موثوقية - س سنوات |  | عدد عشري | خاطئة | احتمال أن ستفشل عنصر في غضون السنوات المقبلة س. هذا هو قيمة بين 0 و 1.
الموثوقية | توفر | % | عدد عشري | خاطئة | توافر المحسوبة للعنصر أو اتصال. هذا هو قيمة بين 0٪ و 100٪.
الموثوقية | عدم | % | عدد عشري | خاطئة | عدم توفر المحسوبة للعنصر أو اتصال. هذا هو قيمة بين 0٪ و 100٪.

يسرد الجدول التالي 'غير مباشر'الناتج خصائص الاتصال من قبل مقيم الموثوقية. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح "الاعتمادية الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة الموثوقية يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
الموثوقية | بعثة الموثوقية - س سنوات |  | عدد عشري | خاطئة | احتمال أن لن يفشل الاتصال غير المباشر خلال السنوات القادمة س. هذا هو قيمة بين 0 و 1.
الموثوقية | بعثة عدم موثوقية - س سنوات |  | عدد عشري | خاطئة | احتمال أن سيفشل الاتصال غير المباشر خلال السنوات القادمة س. هذا هو قيمة بين 0 و 1.
الموثوقية | توفر | % | عدد عشري | خاطئة | توافر المحسوبة على اتصال غير مباشر. هذا هو قيمة بين 0٪ و 100٪.
الموثوقية | عدم | % | عدد عشري | خاطئة | عدم توفر المحسوبة على اتصال غير مباشر. هذا هو قيمة بين 0٪ و 100٪.

خصائص العمارة

يسرد الجدول التالي إخراج خصائص العمارة من قبل مقيم الموثوقية. وسيتم عرض هذه الخصائص في إطار خصائص مع رمز الانتاج الملكية صف محدد ( [image] ) مع تلميح "الاعتمادية الناتج. سوف السهم على رمز الضوء أحمر ( [image] ) عندما تكون هذه الخصائص هي من الموعد المحدد لخاصية الكامنة أو التغيير الهيكلي للمستودع ومحاكاة الموثوقية يتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

اكتب | اسم | وحدة | نوع البيانات | مطلوب | الوصف
الموثوقية | توفر | % | عدد عشري | خاطئة | توافر كافة الاتصالات غير المباشرة التي تم إدراجها في التقييم. وهذا يعني أن احتمال أن جميعسوف الاتصالات غير المباشرة ستكون متاحة عند نقطة معينة من الزمن. هذا هو قيمة بين 0٪ و 100٪. ملاحظة: هذا ليس ضرب من التوفر اتصال الفردية وهذا من شأنه أن يكون "العد المزدوج" من الامم المتحدة وتوافر العناصر ذات الصلة.
الموثوقية | عدم | % | عدد عشري | خاطئة | عدم توفر الاتصالات غير المباشرة التي تم إدراجها في التقييم. وهذا يعني أن احتمال أن واحد على الأقلوالاتصال غير المباشر تكون متوفرة عند نقطة معينة من الزمن. هذا هو قيمة بين 0٪ و 100٪. ملاحظة: هذا ليس ضرب من unavailabilities اتصال الفرد وهذا من شأنه أن يكون "العد المزدوج" من الامم المتحدة وتوافر العناصر ذات الصلة.
الموثوقية | بعثة الموثوقية - س سنوات |  | عدد عشري | خاطئة | احتمال أن كافة الاتصالات غير المباشرة التي تم تضمينها في التقييم سوف لا تفشل في غضون المقبل xسنوات. هذا هو قيمة بين 0 و 1. ملاحظة: هذا ليس ضرب من المصداقية اتصال الفردية وهذا من شأنه أن يكون "العد المزدوج" من الامم المتحدة وتوافر العناصر ذات الصلة.
الموثوقية | بعثة عدم موثوقية - س سنوات |  | عدد عشري | خاطئة | احتمال أن واحدا على الأقل من الاتصالات غير المباشرة التي تم تضمينها في تقييم ستفشل داخل المقبل xسنوات. هذا هو قيمة بين 0 و 1. ملاحظة: هذا ليس ضرب من unreliabilities اتصال الفرد وهذا من شأنه أن يكون "العد المزدوج" من الامم المتحدة وتوافر العناصر ذات الصلة.


محاكاة العمارة بك

الملاحة: محاكاة العمارة بك>

محاكاة العمارة بك

إرسال التعليقات حول هذا الموضوع.

وبمجرد الانتهاء من بالسكان وتحليلها العمارة الخاص بك، فإنك تكون مستعدا لاستخدام ABACUS لتحديد ما إذا كان سيجتمع العمارة احتياجاتك الكمية الخاصة بك. وهذا يتطلب محاكاة. لمحاكاة العمارة الخاصة بك يجب أن تقرر أولا على نوع المعلومات التي تريدها لاكتشاف. وغالبا ما يشار إلى هذه الأنواع من المعلومات على أنها مؤشرات الأداء الرئيسية، أو مؤشرات الأداء الرئيسية. على سبيل المثال، هل تريد لتحليل الأداء، evolvability، والانفتاح، أو هل تريد لجمع المقاييس مثل التكلفة الإجمالية للملكية. كل هذه المعلومات يمكن كشف بطريقة أو بأخرى. وبمجرد الانتهاء من هذه البيانات، سوف تكون قادرا على تحليل بنية بك في مجموعة متنوعة من الأشكال الرسومية (أو تحليل القيم الجديدة مباشرة).

هناك ثلاثة خيارات لمحاكاة العمارة الخاص بك:

· مقاييس بسيطة ;

· محاكاة مدمجة مسبقا ؛ أو

· البرمجة .

مقاييس بسيطة

كل عنصر في الهندسة المعمارية لديه خصائص - وكثير منها قد تكون مخصصة لطلبك من ABACUS. هذه الخصائص تمثل الخصائص المختلفة للمكونات. في بعض الحالات، مجرد جمع هذه المقاييس (لبناء KPI و) يمكن أن يكون كافيا لاقول لكم معلومات هامة حول الهندسة المعمارية الخاصة بك. على سبيل المثال، KLOCS، أو آلاف من خطوط للقانون، وقد استخدمت على نطاق واسع كإجراء من التعقيد. وفي حالات أخرى، قد ترغب في تصدير البيانات وتحليلها باستخدام أداة أخرى. بالإضافة إلى ذلك، قد ترغب في جمع خصائص بعد أداء نوع آخر من المحاكاة.

خصائص يمكن جمعها من خلال عملية تجميع . ويضيف تجميع الخصائص الفرعية المحددة إلى ما مجموعه وهو ما ينعكس في مكون الأم. تجميع يعمل فقط على المكونات التي تحتوي على مكونات فرعية.

الصالات بنيت قبل

هناك خمسة المحاكاة بنيت قبل التي يمكن استخدامها مع ABACUS. انها:

· أداء؛

· نمطية.

· التكلفة الإجمالية للملكية (TCO)؛

· الانفتاح. و

· الموثوقية.

ملاحظة

سوف ABACUS تسليط الضوء تلقائيا أي من هذه المحاكاة تحتاج إلى إعادة تشغيل من خلال أحمر تسليط الضوء على شريط أدوات المحاكاة .

البرمجة

توفر البرمجة المرونة لمحاكاة العمارة بطرق مخصصة. بواسطة كتابة النصوص يمكنك تنفيذ عمليات المحاكاة وراء التيار في قدرة مبنية من ABACUS. طراز كائن ABACUS كامل متاح في محرك البرمجة، لذلك كنت محدودة فقط من قدرتك على كتابة البرامج النصية!

النصي Visual Basic هي لغة البرمجة التي تدعمها ABACUS، لأنه يوفر ميزات البرمجة الأساسية في شكل بسيط إلى حد معقول.

أنظر أيضا

تصدير العمارة بك | خواص الركام | مخطوطات الكتابة


تطور فن العمارة الخاص

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

تطور فن العمارة الخاص

إرسال التعليقات حول هذا الموضوع.

أبنية يمكن تطورت بشكل واضح وتسلسل هرمي للأبنية خلق. وهكذا من خلال تطوير بنية بك في ABACUS، يمكن إنشاء عدد من الحلول المعمارية المتقدمة، مقارنة ويحدد الخط. الأهداف (أو المقاييس) يمكن تعريف أي عدد من الخصائص المعمارية للأبنية القائمة.

وهناك طريقة بسيطة للنظر في تطور بنية هي الربط بينها وبين مفهوم العمارة أصل أفريقي. عندما تطورت بنية، ل نسخالهيكل الأم تم إنشاؤه. يمكن أن يقال هذه النسخة أن تكون مباشرة السليلمن الأصل الأم هندسة معمارية.

ملاحظة

في هذه الوثائق تساعد على الانترنت ومجموعة أدوات ABACUS نفسه، فإن مصطلح تتطورهو أكثر شيوعا من مصطلح السليليرجى ملاحظة أن كلا الرجوع إلى نفس الوظيفة.

أن تتطور بنية القائمة

1. ضمان لديك ملف ABACUSالعراء و نافذة المستكشفعرض.

2. حدد العمارة ذات الصلة كنت تريد أن تتطور من شجرة المستكشف.

3. انقر بزر الماوس الأيمنعلى الهندسة المعمارية وحدد تتطورمن القائمة.

تطور العمارة المختار

4. سيظهر العمارة تطورت تحت العمارة المحدد.

تطورت العمارة

ملاحظة

العمارة تطورت يمكن إعادة تسمية عن طريق النقر بزر الماوس الأيمن على الهندسة المعمارية واختيار إعادة تسمية.وعلاوة على ذلك، فإن جميع المخططات والفهارس في الهندسة المعمارية تطورت سيتم تعيين تلقائيا إلى "مهرجان دبي السينمائي الدولي ضد البنية الأساسية الذي تطورت منه.

وضع أهداف للهندسة المعمارية بك تطورت

وضع أهداف للهندسة المعمارية بك تطورت يسمح لك لخلق معايير لتقييم تطور البنى الخاص بك. ويتم تحديد الأهداف من خلال أنواع الملكية وأسماء تلك الخصائص الموجودة في العمارة بك تطورت. ويمكن أيضا أن تحدد أهداف يدويا، وأضاف إليكم الهندسة المعمارية. اتبع الخطوات التالية لتحديد الأهداف.

تحديد الأهداف من الخصائص الموجودة للهندسة المعمارية بك تطورت

1. ضمان لديك ملف ABACUSالعراء و نافذة المستكشفعرض.

2. اختر Tools | حدد الأهدافمن شريط القائمة الرئيسية.

3. ال الهدف الإدخالسوف نافذة عرض.

الهدف نافذة الإدخال

4. اضغط على موجود زر.

5. ال تحديد خاصيةسوف نافذة عرض.

6. تحديد الخاصية التي تريد تعيين كهدف للهندسة المعمارية بك تطورت وانقر على حسنا زر.

7. ستظهر الهدف المحدد الآن في الهدف الإدخالنافذة.

8. حدد الهدف وانقر على تحرير زر.

9. ال تحرير هدفسوف نافذة عرض.

ملاحظة

يسمح هذا الإطار لك بتغيير اسم الخاصية والنوع الذي هدف ستعكس، فضلا عن أسوأ وأفضل قيمة (أو أدنى / أقصى قدر من القيم) لهذه الخاصية. تم العثور على هذه القيم من خلال مقارنة جميع أبنية والعثور على أصغر وأكبر قيمة في كل لأن خاصية معينة. ويمكن أيضا أن هذه القيم يمكن تعريف يدويا. على سبيل المثال، إذا كنت لتحديد هدف لالخاصية المسماة استجابة (افي)والنوع سلوك، يمكن أن أسوأ وأفضل قيمة الخاص يعكس سرعة المعاملات اللازمة لأداء الأمثل (أفضل قيمة) وسرعة المعاملات اللازمة لالتطبيقات الرئيسية الوحيدة التي سيتم تجهيزها (أسوأ القيمة).

10. مرة واحدة وقد تم تحديد القيم ذات الصلة، حدد حسنا.

تحديد الأهداف من الخصائص الجديدة للهندسة المعمارية بك تطورت

1. ضمان لديك ملف ABACUSالعراء و نافذة المستكشفعرض.

2. اختر Tools | حدد الأهدافمن شريط القائمة الرئيسية.

3. ال الهدف الإدخالسوف نافذة عرض.

4. اضغط على جديد زر.

5. ال هدف جديدسوف نافذة عرض.

ملاحظة

يسمح هذا الإطار لك لتحديد اسم الخاصية والنوع الذي هدف ستعكس، فضلا عن أسوأ وأفضل قيمة (أو أدنى / أقصى قدر من القيم) لهذه الخاصية. على سبيل المثال، إذا كنت لتحديد هدف لخاصية مسماة استجابة (افي)والنوع سلوك، يمكن أن أسوأ وأفضل قيمة الخاص يعكس سرعة المعاملات اللازمة لأداء الأمثل (أفضل قيمة) وسرعة المعاملات اللازمة لالتطبيقات الرئيسية الوحيدة التي سيتم تجهيزها (أسوأ القيمة).

6. مرة واحدة وقد تم تحديد القيم ذات الصلة، حدد حسنا.

7. A الحوار ل إضافة إلى كل أبنيةسيعرض على النحو التالي:

8. اضغط على نعم فعلالإضافة هدف كخاصية لجميع أبنية ذات الصلة. وهذا يضمن أن هدف المعرفة حديثا وخصائصه ستضاف إلى جميع أبنية في الملف. إذا كنت لا ترغب تشمل العقارات في أبنية، يمكنك النقر على لا.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | عرض قطعة نجم أبنية بك تطورت | عرض مؤامرة مبعثر من أبنية بك تطورت


توسيع وانهيار الشجرة

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

توسيع وانهيار الشجرة

إرسال التعليقات حول هذا الموضوع.

عندما عقدة في شجرة تحتوي على مكونات فرعية ومجموعات، وسوف يكون صغير [image] أو [image] التوقيع على يساره. يمكنك النقر فوق [image] توسيع عقدة ومعرفة مكوناتها الفرعية والاتصالات. وبالمثل، يمكنك النقر فوق [image] لطي العقدة لإخفاء مكونات الفرعية والاتصالات (من أجل بذل المزيد من غرفة أو جعل شجرة أسهل للفهم).

بدلا من ذلك، يمكنك توسيع عقدة بأكملها، في هذه الحالة سوف يتم توسيع كل من العقد الفرعية، والعقد الفرعية الخاصة بهم، ولهم ... الخ وبالمثل، يمكن أن تنهار عقدة كامل - إغلاق مستويات متعددة في وقت واحد .

بالإضافة إلى ذلك، هناك خيارات لتوسيع فقط أبنية، العناصر (أي مكونات والاتصالات)، والمكونات أو اتصالات.

لتوسيع أو طي عقدة بأكملها (والعقد الفرعية، الخ)

1. انقر بزر الماوس الأيمنعلى العقدة.

2. اختار توسيع | جميع أو انهيار.

لتوسيع كل من الهندسة المعمارية (ق)

1. انقر بزر الماوس الأيمنعلى البنى أو بنية.

2. اختار توسيع | جميع.

لتوسيع العناصر

1. انقر بزر الماوس الأيمنعلى البنى أو بنية.

2. اختار توسيع | عناصر.

لتوسيع مكونات

1. انقر بزر الماوس الأيمنعلى مكونات عنصر أو مكون فرعي.

2. اختار توسيع | مكونات | جميع.

لتوسيع الاتصالات

1. انقر بزر الماوس الأيمنعلى اتصالات، اتصال أو اتصال الفرعية.

2. اختار توسيع | اتصالات | جميع.


تصدير العمارة بك

الملاحة: الإبلاغ عن الهندسة المعمارية بك>

تصدير العمارة بك

إرسال التعليقات حول هذا الموضوع.

ABACUS يسمح لك إلىتصدير العمارة ل.MDB (مايكروسوفت أكسس)، MS SQL Server و .abacus (ملف ABACUS)، و. XLS (مايكروسوفت إكسل) الشكل. يمكنك أيضا تصدير بك رسم بيانيالصورة لPNG، JPG، SVG (قابلة للتطوير الرسومات الموجهة)، TIFF، GIF وتنسيق BMP وتقاريرك إلى .html (HTML)، قوات الدفاع الشعبي (أدوبي أكروبات)، و .xls (مايكروسوفت إكسل) و .doc (مايكروسوفت وورد) و . RTF (نص منسق) الأشكال. هذا يسمح لك لتحليل وعرض الهندسة المعمارية وبياناته في أي بالطريقة التي تريدها.

لتصدير العمارة ل.MDB (مايكروسوفت أكسس)

1. ضمان لديك ملف ABACUS فتح.

2. اضغط على ملف قائمة الطعام.

3. اختار تصدير، وثم إلى MDB.

4. يحيط علما التحذير ثم انقر فوق حسنا.

5. اكتب اسما للملف.

6. انقر على حفظ زر.

ملاحظة

تنسيق تصدير قاعدة البيانات .MDB هو الخاصة ABACUS وأي تغييرات المخطط سيؤدي إلى عدم القدرة على إعادة الاستيراد. لطفا أنظر ملء مع MS الوصول للحصول على وصف المخطط MS الوصول.

لتصدير العمارة ل MS SQL خادم

1. ضمان لديك ملف ABACUS فتح.

2. اضغط على ملف قائمة الطعام.

3. اختار تصدير، وثم لMS SQL خادم.

4. في مربع الحوار الذي يظهر فوق تصدير فارغ MDB ...زر واستيراد هذا إلى ملقم قاعدة البيانات MS SQL خادم.

5. ملء معلومات قاعدة البيانات وسلسلة الاتصال.

6. انقر على تصدير زر.

ملاحظة

تنسيق تصدير MS SQL خادمقاعدة البيانات الخاصة ABACUS وأي تغييرات المخطط سيؤدي إلى عدم القدرة على إعادة الاستيراد. لطفا أنظر ملء مع MS الوصول للحصول على وصف مخطط قاعدة البيانات.

لتصدير العمارة ل. XLS (ملف إكسل)

1. ضمان لديك ملف ABACUS مفتوحة ، وهو المستكشف عرض ، و وأضافت العمارة .

2. ضمان لديك ملف اكسل استيراد / تصدير التكوين محددة.

3. انقر بزر الماوس الأيمنعلى بنية في النموذج الخاص بك أو أي جزء من مكوناتعقدة (داخل بنية معينة) التي ترغب في تصدير إلى ملف تكوين إكسل.

4. اختار تصدير | إلى التفوق ... من القائمة.

5. ال حدد ملف إكسل استيراد / تصدير تكوين لاستخدامسيتم عرض نافذة.

6. حدد ملف التكوين ذات الصلة لطراز المعماري الخاص بك وانقر على فتح زر.

7. إذا لم تفعل ذلك تلقائيا، خريطة المكونات أعلى مستوى في فن العمارة الحالية لل مجموعة رقم(كما هو موضح سابقا) وانقر على تصدير....

المثال المستوى الأعلى المكون رسم الخرائط

8. اختيار الموقع واسم الملف لملف Excel وانقر على حفظ زر.

لتصدير العمارة ل.abacus (ملف ABACUS)

1. ضمان لديك ملف ABACUS فتح.

2. انقر بزر الماوس الأيمنعلى عقدة العمارة، أي العمارة في النموذج الخاص بك أو أي جزء من شجرة المكونات.

3. اختار تصدير | إلى ملف...من القائمة.

4. اختيار الموقع واسم الملف ثم انقر فوق حفظ زر.

ملاحظة

يمكنك استيراد ملف ABACUS مرة أخرى إلى ABACUS التي كتبها الخطوات التالية 1-2أعلاه واختيار ثم استيراد | من عند ملف.... بعد تحديد الملف الذي تريد استيراده، سوف يطلب منك كيف كنت ترغب في استيراد المعايير وأنواع. يمكنك استيراد المعايير وأنواع إما المعايير وأنواع جديدة أو دمجها. الإعداد الافتراضي هو للمعايير وأنواع المراد دمجها مع المعايير وأنواع القائمة إذا كانت موجودة بالفعل في حياتك مشروع.

لتصدير العمارة ل. XML

1. ضمان لديك ملف ABACUS فتح.

2. انقر بزر الماوس الأيمنعلى عقدة العمارة، أي العمارة في النموذج الخاص بك أو أي جزء من شجرة المكونات.

3. اختار تصدير | إلى XML ...من القائمة. بدلا من ذلك يمكنك الضغط على القائمة ملف| تصدير| إلى XML ...

4. اختيار الموقع واسم الملف ثم انقر فوق حفظ زر.

ملاحظة

يمكنك استيراد ملف XML مرة أخرى إلى ABACUS التي كتبها الخطوات التالية 1-2أعلاه واختيار ثم استيراد | من عند XML .... بعد تحديد ملف XML الذي تريد استيراده، سوف يطلب منك كيف كنت ترغب في استيراد المعايير وأنواع. يمكنك استيراد المعايير وأنواع إما المعايير وأنواع جديدة أو دمجها. الإعداد الافتراضي هو للمعايير وأنواع المراد دمجها مع المعايير وأنواع القائمة إذا كانت موجودة بالفعل في حياتك مشروع.

لتصدير الرسم التخطيطي لPNG، JPG، SVG، TIFF، GIF أو BMP

1. ضمان لديك ملف ABACUS فتح.

2. افتح ال رسم بيانيكنت ترغب في تصدير.

3. اضغط على تصدير Diagramزر على رسم بياني شريط الأدوات.

4. ال تصدير مخططستظهر نافذة.

5. حدد تصفحزر لحفظ التصور في الموقع المطلوب.

6. حدد حفظ كنوعسحب إلى أسفل القائمة لاختيار نوع الملف.

7. انقر على حفظ زر.

لتصدير تقرير لقوات الدفاع الشعبي (أدوبي أكروبات)، و .xls (مايكروسوفت إكسل) أو.DOC (مايكروسوفت وورد)

1. ضمان لديك ملف ABACUS فتح.

2. إنشاء تقرير كنت ترغب في تصدير.

3. اضغط على تصديرزر على شريط الأدوات التقارير.

4. اختار إكسل، PDF أو Wordمن مربع القائمة المنسدلة.

5. انتظر بضع لحظات في حين أن صادرات التقرير.

6. اختيار الموقع واسم الملف ثم انقر فوق حفظ زر.


العثور على واستبدال البنود الخاصة بك في الهندسة المعمارية

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

العثور على واستبدال البنود الخاصة بك في الهندسة المعمارية

إرسال التعليقات حول هذا الموضوع.

باستطاعتك العثور واستبدال مكون معين، والاتصال، اكتب، ومعيار أو الممتلكات باستخدام ABACUS 'البحث واستبدال منشأة.

العثور على البند

1. انقر فوق عقدة من شجرة كنت ترغب في البحث داخل.

2. اختار تحرير| إيجادأو اضغط على CTRL + F.

3. دخول النص ل البندالعثور في 'البحث عن ما هو المجال.

4. انقر بحث عن التالي.

إلى يحل محل عنصر

1. انقر فوق عقدة من شجرة كنت ترغب في البحث داخل.

2. اختار تحرير| يحل محلأو اضغط على CTRL + H.

3. دخول النص ل البندالعثور في "البحث ما الميدانية والنص ليحل محله مع في 'استبدال' الميدان (أو ترك أي شيء إذا كان الحقل فارغ).

4. انقر بحث عن التاليللعثور على المثيل الأول من النص "البحث ما وانقر يحل محل لتحل محل هذه الحالة مع النص "استبدال" أو النقر استبدال جميعلاستبدال جميع الحالات.

لديك خيارات ل:

o تطابق قضيته،

o مطابقة الكلمة بأكملها،

o بحث عن بداية المشروع،

o تجاهل أبنية - وهذا هو فن العمارة الليمفاوية أنفسهم. ستظل البحث أي عقد تحت العقد العمارة مثل المكونات والاتصالات،

o تجاهل مكونات - وهذا هو العنصر الليمفاوية أنفسهم،

o تجاهل الاتصالات - وهذا هو اتصال الليمفاوية أنفسهم،

o تجاهل المعايير - وهذا هو سيتم تجاهل كافة العقد الهندسة المعمارية، والمكون والاتصال القياسية،

o تجاهل أنواع - وهذا هو نوع الليمفاوية أنفسهم. ستظل البحث أي العقد القيد تحت العقد نوع،

o تجاهل القوالب ومحتوياتها - وهذا هو القالب الليمفاوية أنفسهم وكذلك أي مكون قالب والعقد اتصال تحتها،

o تجاهل خصائص - هذا هو كل أنواع الملكية، وأسماء وقيم وحدات من جميع عناصر النموذج سيتم تجاهلها،

o تجاهل الوصف - وهذا هو سيتم تجاهل شروح جميع عناصر النموذج.

أنظر أيضا

كيفية بنية ممثلة في ABACUS


مساعدة في لغات أخرى

الملاحة: مقدمة في ABACUS>

مساعدة في لغات أخرى

إرسال التعليقات حول هذا الموضوع.

ABACUS المساعدة متوفرة في مختلف لغات أخرى / ترجمة ويمكن تنزيلها من الروابط أدناه.

إلى استبدال ملف التعليمات ABACUS الحاليمع ملف تعليمات مترجمة يرجى اتباع الخطوات التالية:

1. حفظ ملف المساعدة من الرابط ذي الصلة أدناه.

2. إعادة تسمية ملف المساعدة لABACUS.chm.

3. فتح ملف عن طريق النقر المزدوج فوقه وإذا كان "فتح ملف - تحذير أمان" الحوار يظهر ثم قم بإلغاء تحديد "السؤال دوما قبل فتح ملف" الخيار وانقر فوق فتح.

4. إغلاق الملف.

5. استبدال الملف ABACUS.chm في مجلد ملفات البرنامج ABACUS، وعادة "C: \ ملفات البرنامج \ Avolution \ ABACUS" أو "C: ملفات البرنامج \(x86) و\ Avolution \ ABACUS".

ملاحظة

وسوف تستمر في سياق مساعدة حساسة للعمل مع ملفات المساعدة ترجمتها.

ملفات المساعدة ABACUS بلغات أخرى:

· العربية / العربية .

· البلغارية / български .

· الصينية (المبسطة) / 中文 (简体) .

· تشيكي / CESKÁ .

· دانماركي / DANSK .

· الإستونية / EESTI .

· اللغة الفنلندية / سومين .

· اللغة الفرنسية / الفرنسية .

· ألماني / الألمانية .

· المجري / العربية العربية .

· أيسلندي / أيسلندي .

· الأندونيسية / أندونيسيا .

· الإيطالي / الايطالية .

· اليابانية / 日本 の .

· اللاتفية / LATVIJAS .

· الماليزي / ماليزيا .

· المالطية / شراب الشعير i .

· Norweigen / Norweigen .

· بولندي / بو lska .

· البرتغالية / PORTUGUÊS .

· الروسية / русский .

· السلوفاكية / Slovenskí .

· سلوفيني / Slovenski .

· الأسبانية / ESPAÑOLES .

· اللغة السويدية / العربية العربية .

· اللغة التركية / تورك .

· ويلزي / Cymraeg .

أنظر أيضا

ماذا ABACUS تفعل؟


كيفية بنية ممثلة في ABACUS؟

الملاحة: مقدمة في ABACUS>

كيفية بنية ممثلة في ABACUS؟

إرسال التعليقات حول هذا الموضوع.

في ABACUS، أنت نموذج العمارة الخاصة بك. للبساطة، ونحن نسمي هذا النموذج المعماري والهندسة المعمارية.

ويوضح الرسم البياني أدناه كيفية بنية نموذجية ل 5مكونات (في التسلسل الهرمي) سوف ترتبط بها 2 وصلات تكون ممثلة في ABACUS.

كيف يتم تمثيل بنية بسيطة في ABACUS

هل يمكن أن يكون أي عدد من أبنية في ملف ABACUS واحد.

العمارة الأولى في شجرة

عادة، سوف تقوم بإنشاء بنية جديدة وقتما تشاء لتقييم التغيير. على سبيل المثال، وكنت نموذج العمارة الموجودة لديك أولا - هذا سيكون الهندسة المعمارية الأولى في شجرة. قد نسميها 'الحالي'.

الثاني

عندما تريد نموذج وتقييم التغيير إلى العمارة الموجودة لديك (مثل زيادة متطلبات) كنت إنشاء هيكل جديد. إن أسهل طريقة للقيام بذلك هو إنشاء نسخة من "الحالي" وتسميته "تطور 1 محاولة 1". وستكون هذه الهندسة المعمارية الثانية في الشجرة. إذا التقييمات الخاصة بك من "تطور 1 محاولة 1" ناجحة، يمكنك تسميته إلى مجرد "تطور 1".

الثالث

إذا "تطور 1 محاولة 1 'لا تلبي الاحتياجات الخاصة بك، يمكنك إنشاء نسخة منه، تسميته إلى" تطور 1 محاولة 2 "، وحاول مرة أخرى. وستكون هذه العمارة الثالثة في الشجرة.

أنظر أيضا

ماذا ABACUS تفعل؟ | كيف نفعل ذلك (لمحة عامة) | ما هي الهندسة المعمارية؟ | العمل مع الملفات ABACUS | إنشاء أو تكرار بنية


كيفية استخدام ABACUS (لمحة عامة)

الملاحة: مقدمة في ABACUS>

كيفية استخدام ABACUS (لمحة عامة)

إرسال التعليقات حول هذا الموضوع.

يوفر هذا الموضوع نظرة عامة أساسية من المهام المعنية باستخدام ABACUS.

ويوضح الرسم البياني التالي عملية التحليل القائم على الهندسة المعمارية التي توفر ABACUS لتطور بنية الحالية لهيكل جديد أو هدف.

عملية ABACUS

استخدام ABACUS:

1. التدقيق - قبل استخدام ABACUS، يجب عليك جمع كل المعلومات التي لديك حول الهندسة المعمارية، ومتطلباته.

· هندسة معمارية - التعرف على المكونات المحتملة من الهندسة المعمارية وكيفية تفاعلها. يجب أن يكون هناك سوى عدد قليل من العناصر على أعلى مستوى. وتسمى هذه "المكونات الأساسية". حتى البنى الأكثر تعقيدا وينبغي أن يكون أقل من 10 عناصر أساسية. مثلا المكونات الأساسية للبنية شركة التأمين قد تكون السياسات والإيصالات، والمطالبات، والمدفوعات.

· المتطلبات- عليك أن تعرف ما هو متوقع من الهندسة المعمارية من أجل تحديد ما إذا كان مرضيا. مثلا عدد الصفقات في الساعة.

· أين تجد ذلك؟ - قد تأتي هذه المعلومات من متطلبات المواصفات وثائق التصميم والمقابلات مع أصحاب المصلحة، رمز نشرها، وما إلى ذلك أساسا أي مادة المتوفرة تقدم ABACUS المعلومات حول الهندسة المعمارية.

2. أهل -استخدام ABACUS لنموذج العمارة الخاص وتحديد الاحتياجات وسيتم قياس العمارة ضد.

· هندسة معمارية - في ABACUS عليك البدء مع بنية فارغة - لديك ل أهلذلك. وهذا يعني إدخال كافة المعلومات العمارة التي قمت بجمعها أعلاه. يمكنك ملء العمارة يدويا (باستخدام القائمة بزر الماوس الأيمن)، أو يمكنك ملء تلقائيا (من برنامج Microsoft Visio، اكسل، أكسس الخ). عادة سيتم ملؤها أعلى معظم المستويات (أكثر تجريدا) من الهندسة المعمارية يدويا، وسوف يتم ملؤها المستويات الدنيا (أكثر واقعية) تلقائيا.

· المتطلبات - كما يمكنك إضافة مكونات والاتصالات الخاصة بك، يمكنك تحديد خصائصها. في معظم الحالات، سوف يكون هذه الخصائص متطلبات الهندسة المعمارية. على سبيل المثال، إذا سيكون لديك 1250 MIPS عقدة / العنقودية، سوف تقوم بإضافة عقدة كمكون، ثم إضافة خاصية الأداء، وتعيين قيمة 1250 MIPS.

3. يحلل - استخدام ABACUS لتحليل بأناقة وتصور بنية معقدة من الهندسة المعمارية الخاصة بك. أنت يمكن تحليل بنية الخاص في عدد من الطرق أو من عدد من وجهات النظر، بما في ذلك الرسوم البيانية، 3D ومستكشف. بدلا من ذلك قد ترغب في استخدام بعض وجهات النظر أكثر تحديدا على النحو التالي:

· رسم العمارة بك - للحصول على الأداء (زمن الاستجابة، وعرض النطاق الترددي، الخ)، والتكلفة (بار، فطيرة، الخ) أو evolvability (الفضاء القدرة، مفاضلة، الخ) وجهات النظر.

· إنشاء تقرير حول العمارة الخاصة بك.

4. محاكاة - استخدام ABACUS لمحاكاة العمارة الخاص بك الأداء، وتوافر، والتكلفة، والانفتاح، الخ

· للقيام بذلك، قم بتشغيل أحد المحاكاة. ABACUS يقيم بك العمارة ضد الاحتياجات الخاصة بكعن طريق إجراء المحاكاة. يقرأ ويحلل البنية الحالية، ويدير المحاكاة، ويحسب بعض الخصائص الجديدة. ثم يتم حفظ هذه الخصائص إلى الهندسة المعمارية. الخصائص الجديدة هي البيانات التي تحاول تحليل، مثل استخدام، زمن الاستجابة، وعرض النطاق الترددي، وتوافر٪، TCO الخ

5. مهندس- استخدام ABACUS للإجابة على مختلف "ماذا لو" السيناريوهات والسيطرة على تطور العمارة الخاصة بك. الهندسة هي عملية تكرار نشر - تحليل - محاكاة دورة.

· في هذه المرحلة، كنت'هاءربما وضعت فهم العمارة الحالية وسلط الضوء على المناطق التي تحتاج إلى تطوير. في كثير من الأحيان، ومع ذلك، سوف تحتاج إلى تكرار نشر - تحليل - عملية محاكاة عدة مرات. وربما يكون هذا لأنه قد يستغرق بضعة التكرار قبل أن تجد العمارة المستهدفة. أيضا، إذا العمارة الخاص معقدة جدا، قد ترغب في تكرار العملية لكل "مستوى" المعماري.

6. خطةمستقبل الهندسة المعمارية باستخدام المعلومات التي يقدمها ABACUS.

ملاحظة

إذا كنت لا تحاول أن تتطور بنية القائمة، قد تحتاج إلى تكرار بعض الخطوات عدة مرات، وبترتيب مختلف. ذلك يعتمد على ما كنت تحاول القيام به. على سبيل المثال، إذا كنت تصميم هيكل جديد، ربما عليك ملء فقط العمارة مرة واحدة، ومن ثم استخدام ABACUS على مدى فترة طويلة من الزمن لتوجيه التطور المستقبلي (ق) من الهندسة المعمارية. من ناحية أخرى، إذا كنت شراء عمارة جديدة ولها العديد من البدائل للاختيار من بينها، ستحتاج إلى اكتشاف وتعبئة لكل من البدائل، ومن ثم تحليل ومحاكاة كل واحد مستقل قبل إجراء مقارنة النهائية في النهاية.

أنظر أيضا

ماذا ABACUS تفعل؟ | ما هي الهندسة المعمارية؟ | كيفية بنية ممثلة في ABACUS؟ | يعيش سكان العمارة بك | تحليل بنية بك | محاكاة العمارة بك


استيراد إلى العمارة بك

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

استيراد إلى العمارة بك

إرسال التعليقات حول هذا الموضوع.

ABACUS يسمح لك لاستيراد العمارة بك من .abacus (ملف ABACUS)، . XML (شظية XML ABACUS أو ملف XML ArchiMate تبادل اللغة)، .vsd (برنامج Microsoft Visio) شكل، و . XLS (مايكروسوفت إكسل) الشكل. هذا يسمح لك ل بناء العمارة بك من مصادر خارجية بسرعة.

إلى استيراد العمارة بك من عند.abacus (ملف ABACUS)

1. ضمان لديك ملف ABACUS فتح.

2. انقر بزر الماوس الأيمنعلى عقدة العمارة، أي العمارة في النموذج الخاص بك أو أي جزء من شجرة المكونات.

3. اختار استيراد| من عند ملف...من القائمة.

4. اختيار الموقع و و.abacus ملف وانقر على فتح زر.

ملاحظة

بعد تحديد الملف الذي تريد استيراده، سوف يطلب منك كيف كنت ترغب في استيراد المعايير, أنواعوجهات النظر. يمكنك استيراد المعايير, أنواع وجهات النظر إما معايير جديدة أو دمجها, أنواعوجهات النظر. الإعداد الافتراضي هو للمعايير, أنواع وجهات النظر المراد دمجها مع المعايير القائمة, أنواع وجهات النظر إذا كانت موجودة بالفعل (مع نفس الاسم الدقيق) في الخاص مشروع.

إلى استيرادالعمارة بك من عند. XML (شظية ABACUS XML أو ملف XML ArchiMate تبادل اللغة)

1. ضمان لديك ملف ABACUS فتح.

2. انقر بزر الماوس الأيمنعلى عقدة العمارة، أي العمارة في النموذج الخاص بك أو أي جزء من شجرة المكونات.

3. اختار استيراد| من عند XML ...من القائمة.

4. اختيار الموقع و و. XML ملف وانقر فتح زر.

ملاحظة

سوف ABACUS استيراد فقط تم تكوينه بشكل صحيح ABACUS جزء XML أو ملف XML ArchiMate تبادل اللغة. بعد تحديد ملف XML الذي تريد استيراده، سوف يطلب منك كيف كنت ترغب في استيراد المعايير, أنواعوجهات النظر. يمكنك استيراد المعايير, أنواع وجهات النظر إما معايير جديدة أو دمجها, أنواعوجهات النظر. الإعداد الافتراضي هو للمعايير, أنواع وجهات النظر المراد دمجها مع المعايير القائمة, أنواع وجهات النظر إذا كانت موجودة بالفعل (مع نفس الاسم الدقيق) في الخاص مشروع.

إلى استيرادالعمارة بك من عند.VSD(برنامج Visio ملف) شاهد هنا .

إلى استيرادالعمارة بك من عند. XLS (ملف إكسل) شاهد هنا .


استيراد أنواع ومستويات من مكتبة

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

استيراد أنواع ومستويات من مكتبة

إرسال التعليقات حول هذا الموضوع.

يمكنك استيراد أنواع ومستويات من ملف مكتبة ABACUS. يمكنك أيضا تصدير أنواع ومستويات من ملف ABACUS الخاص بك إلى ملف مكتبة ABACUS.

لاستيراد أنواع ومستويات من مكتبة في الهندسة المعمارية بك

1. ضمان لديك ملف ABACUSالعراء و نافذة المستكشفعرض.

2. حدد ملف | فتحفتح ملف مكتبة ABACUS.

3. ستفتح مكتبة ABACUS في ورقة كلفه الثانية في إطار مستكشف وسيكون لديك ل إرساء هذه الورقة كلفه لتكون قادرة على سحب والإفلات منه إلى ملف ABACUS الأصلي.

4. السحب والإفلاتأنواع ومستويات من مكتبة في الهندسة المعمارية الخاصة بك.

- أو -

1. حدد ملف | جديد ...

2. إنشاء لجنة جديدة ملف ABACUSعلى أساس ملف مكتبة ABACUS.

لتصدير أنواع ومستويات من العمارة بك في مكتبة

1. ضمان لديك ملف ABACUS افتح ال نافذة المستكشفعرض، وهو ملف مكتبة ABACUSالعراء و نافذة المكتبةعرض.

2. السحب والإفلاتأنواع ومستويات من العمارة بك في المكتبة.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا


واجهة ABACUS

الملاحة: مقدمة في ABACUS>

واجهة ABACUS

إرسال التعليقات حول هذا الموضوع.

عند بدء تشغيل ABACUS، سترى الشاشة الرئيسية، وهي فارغة باستثناء القوائم وشريط الأدوات في الأعلى، نافذة مستكشف فارغة وشريط العنوان. وهذه الشاشة أن يكون مركزا للتفاعل مع ABACUS.

العناصر الرئيسية هي:

· القوائم الرئيسية

· أشرطة الأدوات

· حق انقر القائمة

· المستكشف والممتلكات ويندوز

· شريط الحالة

القوائم الرئيسية

يتم ترتيب القوائم في ترتيب منطقي.

وتوصف القوائم على النحو التالي؛

· القائمة ملف- من القائمة ملف يسمح لك إنشاء أو فتح، إغلاق، حفظ وتصدير ونشر ملفات ABACUS. كما يسمح لك لخلق ومفتوحة، وثيقة وحفظ الملفات مكتبة ABACUS.

· القائمة تحرير- من القائمة تحرير يسمح لك لقطع ونسخ ولصق، حذف، إعادة تسمية، والعثور على وفرز العناصروالتراجع / إعادة العمليات.

· عرض القائمة- القائمة عرض يسمح لك لفتح أو إغلاق واجهة ويندوز المختلفة، ووضع شريط، انتقل الأمام وإلى الوراء، انتقل إلى وجهات نظر محددة وإدارتها لوحات.

· القائمة إدراج- من القائمة إدراج يسمح لك لإضافة الجديد المعاييروالقوالب، وأنواع، والعناصر، وعرضنقطةsوالكتالوجات، والرسوم البيانية، الرسوم البيانيةوالتقارير والمصفوفات.

· القائمة تحليل- القائمة تحليل تسمح لك بتشغيل التقييمات ضد بنية بما في ذلك؛ الأداء والتكلفة، والموثوقية، نمطية والانفتاح.

· القائمة أدوات- من القائمة أدوات تسمح لك لتشغيل البرامج النصية, الأهداف المحددة لبنيةوأداء والهندسة المعمارية 'مهرجان دبي السينمائي الدولي ". يمكنك أيضا تعديل خيارات البرنامج وتخصيص واجهة من القائمة أداة.

· قائمة النافذة- في القائمة إطار يسمح لك ان ترسو، وترتيب، إظهار وإخفاء النوافذ المفتوحة لديك.

· القائمة تعليمات- من القائمة تعليمات يمكنك الوصول إلى هذا الملف مساعدة ABACUS. يمكنك الوصول إلى موقع على شبكة الإنترنت، وجهة نظركم رخصة الاتفاق وعرض تفاصيل عامة عن ABACUS بما في ذلك نسخة من البرنامج والدعم والاتصال ABACUS التفاصيل. يمكنك توفير التغذية المرتدة عن طريق صفحة إخطار القضية. إذا لزم الأمر، يمكنك إدخال مفتاح التسجيل عن طريق القائمة تعليمات.

هذا هو النظام الذي سوف تتبع عادة عندما كنت تنفيذ المهام الخاصة بك;بمجرد إنشاء أو فتح ملف، عليك عادة تعبئة العمارة، ثم رأيهو (في مستكشف، والرسوم البيانية، 3D، الرسوم البيانية، وما إلى ذلك). عند هذه النقطة، عليك إما تشغيل مقيم، أو عليك تكرار هذه العملية مع نفس العمارة أو الهندسة المعمارية المختلفة. (شاهد كيفية استخدام ABACUS (لمحة عامة) للمزيد من التفاصيل.)

ننظر لها من خلال القوائم الرئيسية ونحاول أن نتخيل كيف سيكون تطبيقها على النظام الخاص بك.

ملاحظة

انت تستطيع تخصيص القوائم الخاصة بك في أي وقت.

أشرطة الأدوات

افتراضيا هناك أشرطة الأدوات التالية:

· شريط الأدوات الرئيسي -

· ال محاكاة شريط الأدوات -

· شريط الأدوات مشاهدة -

· ال أداة الرسم البيانيشريط (إذا كان رسم بياني مفتوح) -

· ماكرو تسجيل شريط الأدوات -

ننظر لها من خلال أزرار على كل الأدوات التي تحوم فوقهم لرؤية أداة معلومات سرية (الاختصار-مفتاح).

ملاحظة

لن يؤدي إلا إلى أزرار معينة تكون نشطة اعتمادا على ما قمت بتحديده في إطار مستكشف ويمكنك تخصيص أشرطة الأدوات في أي وقت.بالإضافة إلى ذلك، فإن "التحقق من صحة / تحقق القيود مشروع" الموجود على شريط الأدوات الرئيسية وسوف الأزرار على شريط الأدوات محاكاة الضوء أحمر عندما تغير إلى المخزون الأساسي يتطلب إعادة التحقق من صحة المشروع أو إعادة محاكاة ذلك محاكاة على التوالي. تحوم فوق الزر لمعرفة أي أبنية تتأثر.

القائمة بزر الماوس الأيمن فوق

القوائم وأشرطة الأدوات الرئيسية هي ليستستخدم في كل شيء، وإن كان. غالبا ما يكون أكثر ملاءمة لاستخدام قائمة السياق انقر بزر الماوس الأيمن لعمليات مختلفة. (أيضا، وليس كل الأوامر المتوفرة من خلال النقر بزر الماوس الأيمن تتوفر عبر القوائم وأشرطة الأدوات، أو أوامر لوحة المفاتيح الرئيسية.)

على سبيل المثال، وبمجرد إنشاء ملف، وكان لديك مخطط الشجرة العمارة الخاصة بك، فمن الأفضل أن انقر بالزر الايمن على البنى في شجرة لإضافة هيكل جديد. وبالمثل، يجب عليك بزر الماوس الأيمن فوق مكونات لإضافة مكون جديد. انقر بزر الماوس الأيمن على عدد قليل من الأشياء في شجرة لمعرفة ما يمكنك القيام به.

تلميح

عموما، عليك استخدام القوائم الرئيسية لتنفيذ المزيد من المهام رفيعة المستوى، مثل تقييم بنية بك. المهام ذات المستوى المنخفض - مثل إضافة مكونات والاتصالات الفردية - تتم باستخدام أشرطة الأدوات و / أو بزر الماوس الأيمن فوق القائمة.

المستكشف وخصائص ويندوز

عند فتح أو إنشاء ملف، فإن مخطط الشجرة عرض في إطار مستكشف. انها نافذة العمارة الخاصة بك. وعند تحديد عناصر داخل إطار مستكشف ثلاثة نوافذ أخرى. خصائص عامة، المراجعوإطارات خصائص سيتم تحديث لتعكس المعلومات التفصيلية حول اختيارك.

ملاحظة

خصائص عامة، المراجعومخفية إطارات خصائص افتراضيا. شاهد Customising واجهة لكيفية إظهار لهم وربما تركها عرضها بشكل دائم.

بينما كنت بناء العمارة الخاص بك، وإكسبلورر وخصائص ويندوز هي تمثيل أكثر فائدة. لأنه يمكن انهار وتوسعت على النحو المطلوب، وأنها لا تصبح مرهقة.

في إطار مستكشف لديه شجرة (وشريط الحالة) وإطارات خصائص لها 5أقسام:

· اكتب

· المعايير

· الوصف

· المراجع

· الممتلكات

وتعتبر ABACUS كل هذه الأمور لتكون جزءا من الهندسة المعمارية.

شجرة

هذا القسم يحتوي على شجرة مقسمة إلى 3 مناطق على النحو التالي:

1. التلوي نموذج

· المعايير- إذا مكونات عديدة لها نفس مجموعة من الخصائص، يمكنك تحديد مجموعة مقدما، وبعد ذلك فقط إسناد ذلك إلى المكونات. الشيء نفسه ينطبق على الاتصالات وأي من العناصر الأخرى. يتم تخزين هذه مجموعة من الخصائص القياسية في المعاييرفرع الشجرة. بدلا من تحديد كل الممتلكات لكل مكون، وكل الممتلكات لكل اتصال وغيرها، فقط تعيين معيار. على سبيل المثال الخصائص القياسية لل يونكس HP / UXيمكن حفظها كصورة معيار وأسند إلى أي المكونات باستخدام يونكس HP / UXنظام التشغيل كما هو موضح ل OS01 الخادم في الصورة فوق.

· الأنواع - هذا الفرع من شجرة هي مكتبة من أنواع المكونات والاتصالات التي يمكن استخدامها. وتستخدم أنواع لتحديد نموذج الفوقية للهندسة المعمارية الخاصة بك وللتصنيف وتصفية عند عرض الهندسة المعمارية الخاصة بك. كما أنها تحدد نموذج لما المعاييروخصائص والقيود المكونات الخاصة بك / الاتصالات يمكن أن يكون.

· وجهات النظر- عرضنقطةالصورة يمكن أن تنشأ من المخططات القائمة ويمكن استخدامها لإنشاء مخططات جديدة.هم الإستنسل الرسم البياني.

· النماذج - متجر القوالب إعادة صالحة للاستخدام أنماط من المكونات والاتصالات جنبا إلى جنب مع الطريقة التي يتم تمثيلها أو عرضها. ويمكن وصفه أنه "مصغرة" أبنية أو الحلول التي يمكن وضعها في أبنية القائمة.

2. أبنية -أبنية فرع من الشجرة هو المكان الذي بناء هندسة معمارية (ق) من النظام الخاص بك. (وهذا ما يسمى ملء العمارة.) هل يمكن أن يكون أي عدد من أبنية في ملف ABACUS واحد.

3. لوحات - فرع لوحات المعلومات من الشجرة حيث يمكنك الوصول إلى أي حفظ لوحات للمشروع.

ملاحظة

العناصر الموجودة في شجرة مستكشف التي كان بها تحديث إذن إزالة (أي أنها للقراءة فقط) وترد في الرمادي.

اكتب

هذا القسم يدل على عنصر أو اتصال نوع معين من العنصر المحدد حاليا في الشجرة.

المعايير

يوفر هذا القسم قائمة لل المعايير للعنصر المحدد حاليا في الشجرة.

الوصف

يوفر هذا القسم وصفا موجزا للعنصر المحدد في شجرة. ويمكن أيضا أية ارتباطات تشعبية ذات الصلة أن تضاف إلى هذا القسم. وتشمل هذه المواقع أو مسارات مطلقة المحلية لافتا إلى مزيد من المعلومات حول عنصر معين. كما يسمح خطوط متعددة. وصلات صالحة تحتاج لتبدأ واحدة من 5 سلاسل؛ HTTP: // أو https: //، وبروتوكول نقل الملفات: //، ملف: /// أو ميلتو :.

تلميح

للارتباطات التشعبية مع مسافات، يمكن للمستخدمين اكتب في URL أو مسار، حدد النص المطلوب و انقر بزر الماوس الأيمن| الارتباط التشعبي. سيؤدي ذلك إلى تغيير أي مسافات لل ٪ 20لذلك كله URL أو مسار ستعمل بشكل صحيح.

خلق والتعديل

هؤلاء قسمs تزودالمستخدم والتاريخ / الوقت لإنشاء والتعديل الأخير ل، العنصر المحدد حاليا في الشجرة.

المراجع

يوفر هذا القسم قائمة لل مكونات الصادرة والواردة للعنصر المحدد حاليا في الشجرة.ويدل أيضا على الرسوم البيانية، 3D وجهات النظر الرسم البياني الذي يظهر العنصر المحدد حاليا. إذا تم تحديد رسم تخطيطي لأنه يبين وجهة نظر جدت للحصول على الرسم البياني وجهات النظر بشكل عام فإنه يظهر أي لوحات العدادات يظهر الرأي فيها. وعندما قياسي المحدد في شجرة فإنه يدل على استخدام المعيار أنواع، مكونات والاتصالات.

الممتلكات

هذا القسم هو المكان الذي تحدد خصائص العناصر داخل العمارة الخاصة بك، مثل الطريقة التي تتطلب من أداء، وعدد من الأسطر من التعليمات البرمجية لديها، ونسبة هذه السطور التي هي التعليقات، الخ

و"الإدخال" و "الناتج" خصائص بنيت قبل المحاكاة وسوف يعرض في إطار خصائص مع رمز إدخال خاصية صف محدد ( [image] ) ورمز الإخراج ( [image] ) على التوالي مع تلميح يدل على سبيل المثال التي بنيت قبل محاكاة يرتبط العقار ل، 'نمطية إخراج "أو" الإدخال الأداء ". سوف السهم على الرموز الناتج تسليط الضوء أحمر ( [image] ) عند الخاصية غير محدثة بسبب عقارا أو التغيير الهيكلي إلى المخزون مع محاكاة تتطلب إعادة المحاكاة وفقا ل أحمر تسليط الضوء على شريط أدوات المحاكاة .

شريط الحالة

في الجزء الأيسر من شريط يظهر المسار الكامل إلى عنصر مستودع حاليا في التركيز، وإما اختيار في إطار مستكشف أو على رسم بياني قماش. هذا هو بحيث المكان الدقيق في التسلسل الهرمي مستودع لعنصر معين يمكن دائما أن تحدد بسهولة. اليد اليمنى جزء من شريط يظهر مختلف الرسائل التشغيلية مثل "فتح ملف ABACUS الناجح" و "حساب التكلفة مكتمل".

أنظر أيضا

كيف نفعل ذلك (لمحة عامة) | Customising واجهة | ما هي الهندسة المعمارية؟ | كيفية بنية ممثلة في ABACUS؟ | العمل مع الملفات ABACUS


ماذا ABACUS تفعل؟

الملاحة: مقدمة في ABACUS>

ماذا ABACUS تفعل؟

إرسال التعليقات حول هذا الموضوع.

للمساعدة في اللغات الأخرى / ترجمة يرجى الضغط هنا .

ABACUS يأخذ تخمين العمل للخروج من التعامل مع الحلول والنظم والبرمجيات والمعلومات والتكنولوجيا، والعمليات التجارية و / أو المؤسسات بأكملها (يشار إليها مجتمعة ب أبنية). يمكن أن تساعدك على تصميم عملي، رصد ومحاكاة وتحليل وتصور بك هندسة معمارية عبر الاقتداء به، تحليلها بطرق بديهية (مثل الرسوم البيانية والرسوم البيانية و3D) ثم تقييم ضد متطلبات غير وظيفية الخاص بك.

ملاحظة

متطلبات غير وظيفيةهي تلك المتطلبات التي لا تتصل مباشرة كيف يعمل المنتج. بدلا من ذلك، انهم قلقون مع جيدا كيف تعمل. وتشمل متطلبات غير وظيفية أشياء مثل الأداء، والانفتاح، evolvability، والجودة، والتدرجية، نمطية، الخ (على العكس من المتطلبات الوظيفية مثل، بدوره على ضوء ذلك عند النقر على هذا الزر). تقليديا، كانت متطلبات غير وظيفية من الصعب - إن لم يكن من المستحيل - أن تقيس. في الواقع، ABACUS هو المنتج الوحيد الذي يمكن بموضوعية وقياس وبكميات كبيرة الثلاثة الأولى - أداء, انفتاحو evolvability.

ببساطة، تقوم بإدخال الهندسة المعمارية وما تحتاج أن تفعله. ABACUS ثم يخبرك إذا انها لن تفعل كما هو مطلوب، ويشير إلى أي نقاط ضعف أو ثغرات.

توجه ABACUS على مدى 20 عاما لبحوث النظم وسنوات عديدة أخرى من نظرية النظم المعمول بها. فهو يوفر لك قابلة للقياس، يمكن الاعتماد عليها، إجابات موضوعية، لذلك كنت لا تعتمد على تقييم شخصي.

ABACUS لتقف على Architecture-BASED Analysis, Communication و Understanding من Systems ق. يمكن أن تساعدك مع أي بنية كبيرة الحجم، لكنها تستخدم عادة لمدة أربعة (4) أشياء:

· تتطورالعمارة الحالية. على سبيل المثال، إذا العمارة الموجودة تفتقر الأداء، سوف ABACUS تصور العمارة بالنسبة لك، وتحديد المشاكل (الاختناقات، وما إلى ذلك)، ثم أقول لكم بالضبطكيفية تحسين الهندسة المعمارية.

· تصميمهيكل جديد. على سبيل المثال، إذا كنت بحاجة إلى بنية جديدة تماما، وكنت تصميم بنفسك، سوف ABACUS اقول لكم بالضبطما المكونات التي تحتاج إليها وكيف يجب أن تكون متصلا.

· شراءهيكل جديد. على سبيل المثال، إذا كنت قد دعا للمناقصات على تصميم هيكل جديد، وكنت اختيار بين ثلاثة تصاميم، سوف ABACUS اقول لكم بالضبطأي واحد يناسب متطلباتك أفضل.

· الجمع بينأبنية الحالية القائمة. على سبيل المثال، إذا كنت بحاجة إلى الجمع بين اثنين أو أكثر من أبنية منفصلة، ​​وABACUS إرشادك.

أنظر أيضا

كيف نفعل ذلك (لمحة عامة) | ما هي الهندسة المعمارية؟ | كيفية بنية ممثلة في ABACUS؟


باستخدام وصلات في رسم تخطيطي

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

باستخدام وصلات في رسم تخطيطي

إرسال التعليقات حول هذا الموضوع.

الأشكال (شكل حر ومكونات) وموصلات (شكل حر أو وصلات) ضمن المخططات يمكن ربطها تمثيل الموجودة لديك المعمارية في ABACUS، فضلا عن الملفات الخارجية / المجلدات وعناوين المواقع. ويمكن بعد هذه الروابط أن تدار (إنشاء أو تعديل وحذف) عن طريق مجموعة أدوات ABACUS. هذه الميزة يمكن استخدامها لتعزيز الملاحة والفهم العام للهندسة المعمارية بك شكل تخطيطي.

لإضافة وصلات إلى الرسم البياني الخاص بك

1. تأكد أن لديك موجود مخطط مفتوح .

2. حدد الشكل ذات الصلة أو موصل من الرسم البياني الخاص بك.

3. انقر بزر الماوس الأيمنعلى شكلأو موصل.

4. اختار روابط مفتوحةو الروابطيظهر إطار.

5. اضغط على إضافةرمز و رابط جديديظهر إطار.

6. حدد صلة الفهرس | مصفوفة | رسم بياني| 3D مشاهدة| الرسم البيانيأزرار الراديو، ثم حدد صلة التسويقي، مصفوفة، رسم بياني, 3Dأو الرسم البياني عرض في الهندسة المعمارية الحالية من رابط ل القائمة المنسدلة.

- أو -

6. حدد موقع الكترونيزر الراديو ثم، أدخل URL ذات الصلة (مثل HTTP: //www.avolutionالبرمجياتكوم /)في الميدان لتصل إلى صفحة ويب. عناوين صالحة تحتاج لتبدأ واحدة من 5سلاسل؛ HTTP: // أو https: //، وبروتوكول نقل الملفات: //, ملف: أو \\. يجب إدخال أية فراغات مع '٪ 20'.

- أو -

6. حدد ملف المطلق | ملف النسبي زر الراديوالصورة،ثم انقر على '...'زر لتصفح عن ملف خارجي لتصل إلى الرسم البياني الخاص بك.

7. انقر حسناوسيتم عرض وصلة جديدة في إطار الروابط. ملاحظة: نافذة سريعة يمكن تغيير حجم لمعرفة الاسم الكامل إذا لزم الأمر.

8. كرر الخطوات 5-7لخلق المزيد من الروابط.

9. لمتابعة الرابط إنشاؤها، حدد الارتباط ذات الصلة المعروضة في الروابطنافذة وانقر افتح الرابط.

ملاحظة

عندما ويجري عرض شروح متعددة ل شكل أو موصل يتم عرض الارتباط على الشرح الأول في قائمة الشروح في الحوار تحرير الشروح.

لتتبع الروابط من الرسم البياني الخاص بك

1. تأكد أن لديك موجود مخطط مفتوح .

2. حدد الشكل ذات الصلة أو موصل من الرسم البياني الخاص بك.

3. انقرعلى الوصلة الإلكترونية ذات الصلة (الأزرق وشدد اسم عنصر) على شكل أو موصل في الرسم البياني لفتح وعرض الحلقة الأولى من الشكلأو موصل.ملاحظة: المؤشر يجب أن تتغير إلى "اليد" عند هذا العنوان هو على استعداد ليكون النقر.

- أو -

3. حدد الشكل ذات الصلة أو موصل من الرسم البياني الخاص بك.

4. انقر بزر الماوس الأيمنعلى شكلأو موصل.

5. اختار روابط مفتوحة و ال الروابطيظهر إطار.

6. حدد الارتباط ذات الصلة التي ترغب في عرضها.

7. اضغط على افتح الرابطزر لفتح وعرض الرابط ذي الصلة.

لحذف الروابط في الرسم التخطيطي

1. تأكد أن لديك موجود مخطط مفتوح .

2. حدد الشكل ذات الصلةأو موصلمن الرسم البياني الخاص بك.

3. انقر بزر الماوس الأيمنعلى شكلأو موصل.

4. اختار روابط مفتوحة و ال الروابطيظهر إطار.

5. حدد الارتباط ذات الصلة التي يجب حذفها.

6. اضغط على حذف زر. وتتم إزالة الارتباط من الروابط نافذة.

وصلات المنظمة في الرسم التخطيطي

يمكنك اختيار أي ربط الرسم البياني، ملف خارجي، أو يتم عرض URL الويب عند تسمية الشكل هو السيطرة + النقر في الرسم البياني.

1. تأكد أن لديك موجود مخطط مفتوح .

2. حدد الشكل ذات الصلة أو موصل من الرسم البياني الخاص بك.

3. انقر بزر الماوس الأيمنعلى شكلأو موصل.

4. اختار روابط مفتوحة و ال الروابطيظهر إطار.

5. لتعديل ترتيب الارتباطات انقر على تحريك لأعلى | تحريك لأسفلالأزرار على الجانب الأيمن من الروابطنافذة.

6. الرابط الأول الذي يظهر على الجانب الأيسر من الروابطنافذة هو الرابط الذي يعرض عند CTRL + نقرةشكل الوصلة الإلكترونية أو موصل اسم.

أنظر أيضا

يعيش سكان العمارة بك | يعيش سكان العمارة يدويا | تحليل العمارة بك


التلاعب رسم تخطيطي

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

التلاعب رسم تخطيطي

إرسال التعليقات حول هذا الموضوع.

مرة واحدة وقد تم إنشاء الرسم البياني، والعناصر التي تظهر في أنه يمكن إعادة ترتيب وإعادة الحجم كما تريد.

لنقل عنصر في رسم تخطيطي

1. تأكد أن لديك موجود مخطط مفتوح .

2. النقر وعقدأي مكون لتحريكه. إذا كان العنصر لديه نخبة من أحد الوالدين، وسيتم تسليط الضوء على عنصر الأم.

3. باعتبارها العنصر هوجر من المكون الأم، وأكثر من المكونات الأخرى، وسوف تصبح أبرز الآباء المحتملين. نظام الألوان المستخدمة يدل على تأثير العملية سوف يكون على التحذيرات والأخطاء مع المشروع الحالي، ويوصف في تحديد والتحقق من صحة القيود . بهذه الطريقة، يمكنك التنقل بيانيا التسلسل الهرمي من 'عرض الخطة ".

4. إطلاقزر الماوس لإسقاط عنصر في موقعه الجديد.

ملاحظة

يمكنك أيضا استخدام لوحة المفاتيح لإعادة وضع العناصر على قماش الرسم. ببساطة اختيار عنصر أو شكل حر الشكل الذي تريد نقل واستخدام مفاتيح الأسهم الموجودة على لوحة المفاتيح لتحريك الشكل إلى المكان المطلوب.

لاحظ أيضا أنه عندما سحب عنصر بالماوس على عنصر آخر، وسلط الضوء على عنصر الأم المحتملين عند الزاوية العليا اليسرى من عنصر تقوم بسحب تتداخل مكون آخر.

تلميح

شكل حر و الأشكال العائمة يمكن طلب من قبل النقر بزر الماوس الأيمنواختيار اجلب للمقدمة أو إرسال إلى الخلفمن القائمة. ومن المهم أن نلاحظ أن الأشكال عنصر يمكن تحويلها إلى الأشكال التي كتبها حر النقر بزر الماوس الأيمنعلى شكل عنصرا محددا واختيار تحويل إلى FREEFORM.

لتغيير حجم عنصر في رسم تخطيطي

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر الانتظار السحبواحد من مقابض عنصر وتغيير الشكل إلى الحجم المطلوب.

3. بدلا من ذلك للحفاظ على نسبة العرض إلى الارتفاع الشكل، خفض تحول + انقر الانتظار السحب.

لنقل الاتصال في الرسم

1. تأكد أن لديك موجود مخطط مفتوح .

2. النقر وعقدأي اتصال لتحريكه.

3. إطلاقزر الماوس لإسقاط عنصر في موقعه الجديد.

ملاحظة

يمكنك نقل فقط الاتصالات التي لم تعلق على أي مكونات. إذا تعلق بها، يمكنك فقط نقل نهاية خاليةs، أو إعادة توجيه اتصال .

حذف مكونات واتصالات

عند حذف عنصر أو اتصال من الرسم البياني، لديك خيار لحذفه من العمارة بأكملها. سيتم إزالة أي مكون التي يتم حذفها من العمارة تلقائيا من أي مخططات أخرى حيث يبدو. منذ الحالات حر تظهر فقط في رسم تخطيطي واحد، حذفها لا يؤثر على نموذج معماري أو أي مخطط آخر.

لحذف عنصر أو اتصال من الرسم البياني

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقرعلى أي اتصال المرتبطة أو مكون لتحديده.

3. اضغط على حذفمفتاح لحذفه من الرسم البياني، أو تحول + حذفحذفه من نموذج كامل.

- أو -

2. انقر بزر الماوس الأيمن على أي عنصر أو مكون المرتبطة. ستظهر قائمة السياق.

3. اختار حذف من مشاهدة أو حذف من هندسة معماريةمن قائمة السياق.

ملاحظة

إذا كان العنصر الذي ترغب في حذف من وجهة نظر ليس لديه أطفال، وتحدث فقط على هذا الرأي، وABACUS تسأل ما إذا كنت تريد حذف عنصر من مستودع كذلك.

الحذر

عند حذف عنصر من النموذج الذي يحتوي على عناصر الطفل، والأطفال كما سيتم حذف يحتمل أن تكون وفقا للحوار تحذير.

مكونات دمج

قد ترغب في دمج عنصرين القائمة على نفس الرسم البياني (وداخل الهيكل). ويمكن أن يتم ذلك لأسباب عديدة، على سبيل المثال، ملقمين موجودة داخل الشركة infrastructure- H01 و H02. يتم تمثيل هذه الخوادم اثنين واثنين من عناصر منفصلة داخل العمارة. H0وقد اعتبرت 1 لا لزوم لها، وبالتالي غير أن خرجت من الخدمة. جميع التطبيقات الموجودة تعمل على H01 هي أن تحولت إلى H02 (لا يزال في لجنة). ويمكن بعد ذلك أن ينعكس هذا التغيير عن طريق عمل "دمج" عنصرين H01 و H02 على الرسم البياني (و داخل العمارة).

لمناقشة مفصلة حول دمج يرجى الرجوع إلى دمج عناصر الموضوع هنا .

لدمج عنصرين القائمة

1. تأكد أن لديك موجود مخطط مفتوح .

2. انقر بزر الماوس الأيمن-عقدعلى المكون الذي تريد دمج و سحبوضعها على المكون الذي تريد دمجها مع. تأكد من أبرز الخطوط العريضة للمكون جهة الحمراء تشير إلى أن يتم تحديده.

3. اختار دمج | الحفاظ على الوجهة أو الكتابة فوق الوجهةمن القائمة.

ملاحظة

ال الحفاظ على الوجهةالخيار يحافظ على قيم خصائص المكون الوجهة إذا كانت موجودة على العنصر الأصلي أيضا.

ال الكتابة فوق الوجهةخيار الكتابة خصائص المكون الوجهة مع أية خصائص مشتركة من العنصر الأصلي.

تغيير اتصالات

الاتصالات هو مبين في الرسم البياني دائماتعكس هيكل على النحو المحدد في العمارة نفسها. أداة رسم يسمح لك لفصل الاتصالات من المكونات، نقلها، منحنى لهم، وإعادة الطريق، منهم وإعادة نعلق لهم المكونات الأخرى.

فصل / إرفاق اتصال من / إلى مكون

1. تأكد أن لديك موجود مخطط مفتوح .

2. النقر وعقدعلى أي اتصال.

3. اختار الاتصال النهاية (أي. مصدر أو بالوعة) التي ترغب في فصل / إرفاق. ملاحظة: يشار إلى نهايات اتصال مع دوائر بيضاء صغيرة وتحوم فوق الدائرة البيضاء لثانية واحدة يؤدي إلى "تلميح" لتظهر مع فيما يخصه دور اسم(أي إما مصدر أو بالوعة).

4. سحبالاتصال ينتهي إلى موقع جديد (إما مكانا شاغرا أو مكون) والافراج عن زر الماوس.

ملاحظة

عندما يتم وضع نهاية الاتصال عبر عنصرا صالحا، وسلط الضوء على الخطوط العريضة للمكون الوجهة مع مخطط متقطع. نظام الألوان المستخدمة يدل على تأثير العملية سوف يكون على التحذيرات والأخطاء مع المشروع الحالي، ويوصف في تحديد والتحقق من صحة القيود . بعد إطلاق سراحه أن نهاية الe اتصال والمكون ترتبط تلقائيا(أو المرفق)، ينعكس وهذا في النموذج المعماري.

لإعادة توجيه اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. ضع مؤشر الماوس فوق اتصال.

3. امسك ال نوبةمفتاح خفض و انقرزر الماوس لوضع نقطة ربط الاتصال. حرر نوبة مفتاح. يمكنك إزالة نقطة الربط عن طريق القيام بنفس العملية.

4. إضغط و اسحبنقطة الربط لتغيير مسار الاتصال.

تلميح

استخدامبديل مفتاح بدلا من نوبةالمفتاح لخلق صلات المتعامدة.

إلى منحنى أو تصويب اتصال

1. تأكد أن لديك موجود مخطط مفتوح .

2. ضع مؤشر الماوس فوق اتصال.

3. انقر بزر الماوس الأيمن تانه الصدد وفي سياق القائمة التي تظهر حدد منحنى, متعامد أو مباشرة.

تلميح

كافة الاتصالاتمن يمكن تعيين نوع معين على الرسم البياني للمنحني، متعامد أو مستقيم بالنقر بزر الفأرة الأيمن على خط يرتبط لنوع على علامة التبويب اتصالات من الاستنسل النافذةوالمنحنى اختيار ومتعامد أو مستقيم.

إلى ترسو على نقطة محددة على حافة شكل

1. تأكد أن لديك موجود مخطط مفتوح .

2. حدد اتصال.

3. ضع مؤشر الماوس فوق و"نقطة بيضاء 'في نهاية اتصال.

4. انقر بزر الماوس الأيمن تانه نهاية الصدد وفي سياق القائمة التي تظهر حدد مرساة نقطة النهاية إلى شكل.نقل نهاية الصدد إلى الموقع الرغبة على حافة الشكل.

أو

امسك ال السيطرةمفتاح خفض و cلعق والسحب ال نهاية اتصال يشير إلى الموقع الرغبة على حافة الشكل.

ملاحظة

اتصالات سوف المفاجئة للاعتراض الفعلي للشكلها متصل بدلا من المربع المحيط من هذا الشكل.

أنظر أيضا

أداة الرسم | يعيش سكان العمارة بك | تحليل العمارة بك


دمج البنود

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

دمج البنود

إرسال التعليقات حول هذا الموضوع.

عندما كنت دمج العناصر؟

هل دمج العناصر عندما يكون لديك اثنين (أو أكثر) الكائنات في النموذج الخاص بك التي من الأفضل أن يمثله مثيل واحد. هناك العديد من الحالات التي قد ترغب في القيام بذلك، بما في ذلك:

· ونتيجة لاستيراد مجموعة جديدة من المعلومات في النموذج الخاص بك والتي قد مكررة أو تنسخ المعلومات الموجودة. على سبيل المثال إذا قمت باستيراد نسخة محدثة من جدول إلى النموذج الخاص بك.

· على مر الزمن مكررة للعنصر 'نفس' تم إنشاؤها والتي ترغب في تنظيف هذه التكرارات.

· إذا كنت تقوم ماذا لو السيناريو والعناصر التي يتم نمذجة تقوم بدمج فعلا في الواقع. على سبيل المثال، إذا كنت تقوم بدمج إدارتين في المؤسسة الخاصة بك، أو إذا كنت تقوم بدمج خادمين.

ما يمكن دمجها؟

الأنواع التالية من عناصر الدعم الذي اندمج:

· المعايير

· عنصر واتصال أنواع

· مكونات واتصالات

كيفية دمج العناصر

لبدء الدمج، وذلك باستخدام زر الماوس الأيمن، اسحب عنصر واحد في مستكشف على آخر. العنصر الذي سحب هو المصدر، والعنصر الذي قمت بسحب على غير الوجهة. على تحرير زر الفأرة الأيمن وسيتم تقديمك مع القائمة التي يمكنك من خلالها اختيار لدمج هذين البندين. سيكون لديك لاختيار ما إذا كنت ترغب في الاحتفاظ أو الكتابة الوجهة. وكذلك شرح هذا أدناه.

القائمة بزر الماوس الأيمن السحب دمج

ما هو الفرق بين الحفاظ على والكتابة الوجهة؟

حكرا أو الكتابة الخيار يملي ما يحدث إذا كان الاسم، الوصف أو خصائص بين مباراة المصدر والبنود الوجهة.

إذا ما تم اختيار المحافظة الوجهة

· سيتم الاحتفاظ اسم الوجهة والوصف.

· يتم إضافة أي خصائص التي لا توجد إلا في المصدر إلى الوجهة.

إذا تم اختيار الكتابة الوجهة:

· سيتم الكتابة فوق اسم الوجهة من المصدر.

· الوجهة الوصف سيتم الكتابة من المصدر، إلا إذا كان مصدر الوصف فارغ.

· يتم إضافة أي خصائص التي لا توجد إلا في المصدر إلى الوجهة.

· سيتم الكتابة فوق الوحدة القيمة وأية خصائص موجودة في كل من المصدر والمقصد من المصدر، ما لم قيمة المصدر أو وحدة فارغة.

حالات خاصة

· أنواع: عند دمج أنواع، يتم دمج الأذونات، بطريقة "متشائمة"، بحيث لو الإذن على مصدر لا وجود لها على الوجهة، ستضاف إليها، وإذا لم توجد في الوجهة، ثم إذا كان الفرد لم إذن لمجموعة المستخدم (تكوين، اقرأ، تحديث أو حذف) لا تتطابق (منح واحد، ونفى واحدة)، ثم ستحرم من هذا الإذن.

· مكونات: عند دمج المكونات، يتم ترحيل مكونات فرعية من المصدر إلى الوجهة، واندمجت مع المكونات الفرعية في الوجهة إذا أسمائهم متطابقة، بغض النظر عن نوع.وعلاوة على ذلك، سيتم الجمع بين عدة مكونات فرعية من مصدر بنفس الاسم إلى مكون فرعي واحد في الوجهة.

· روابط: إن اتصالات على مستوى عال أنفسهم يجب أن لديهما نفس المرفقات (أو عدمه) الذي يسمح به للدمجها. عند دمج الاتصالات، يتم ترحيل الاتصالات فرعية من المصدر إلى الوجهة، واندمجت مع وصلات فرعية في الوجهة إذا أسمائهم متطابقة ومرفقاتها متطابقة. إذا المرفقات ليست متطابقة، سيتم إضافة مصدر وصلات فرعية إلى الوجهة دون الاندماج مع اتصالات المطابقة الموجودة بالفعل. هذا هو بحيث يتم فقدان أية مرفقات.


الملاحة في مخطط 3D

الملاحة: تحليل بنية بك> الرسوم البيانية 3D>

الملاحة في مخطط 3D

إرسال التعليقات حول هذا الموضوع.

ABACUS يسمح لك التنقل بسهولة من خلال الهندسة المعمارية الخاصة بك في 3D. تجربة مشابهة للطيران. هناك وضعان للملاحة:

· مراقبة الوضع الأساسي (افتراضي)؛ و

· مراقبة الوضع المتقدم - تغيير هذا الوضع من خلال اختيار التحكم| مراقبة الوضع المتقدم.

ملاحظة

للتبديل بين التحكم الأساسية ومراقبة أوضاع متقدمة، يمكنك استخدام F4وظائف اختصار لوحة المفاتيح.

وضع التحكم الأساسية

· عقد الزر الأيسر وتحريك الماوس إلى الأمام أو الخلف يغير الملعب.

· عقد الزر الأيسر وتحريك الماوس إلى اليمين أو اليسار يتغير ياو.

· عقد الزر الأيمن وتحريك الماوس المقالي في الرأي؛

· عقد كل من الأزرار أسفل وتحريك الماوس إلى الأمام أو الخلف، الأزيز ويخرجون من العمارة. و

· عقد كل من الأزرار أسفل وتحريك الماوس إلى اليمين أو اليسار، لفات اليسار واليمين.

- أو -

· الضغط على السهم الايسرعلى لوحة المفاتيح أو لوحة المفاتيح الرقمية سوف يتحول اليسار،

· الضغط على السهم الأيمنعلى لوحة المفاتيح أو لوحة المفاتيح الرقمية ويمينا.

· الضغط على سهم للاعلىعلى لوحة المفاتيح أو لوحة المفاتيح الرقمية وتكبير؛

· الضغط على السهم لأسفلعلى لوحة المفاتيح أو لوحة المفاتيح الرقمية والتصغير.

· الضغط أعلى الصفحةعلى لوحة المفاتيح أو لوحة المفاتيح الرقمية سوف الملعب حتى. و

· الضغط اسفل الصفحةعلى لوحة المفاتيح أو لوحة المفاتيح الرقمية سوف الملعب إلى أسفل.

مراقبة الوضع المتقدم

· متحركالماوس إلى الأمام والخلف، وصعودا وهبوطا، يتغير الملعب وياو (على التوالي).

· الضغط W أو سهم للاعلىالأزيز في (إلى الأمام) إلى بنية.

· الضغط S أو السهم لأسفلالأزيز من (الخلف) من العمارة.

· الضغط A أو السهم الايسرلفات إلى اليسار.

· الضغط D أو السهم الأيمنلفات إلى اليمين.

· الضغط Q أو اسفل الصفحةيرفع العرض (عن طريق خفض منظور)؛ و

· الضغط E أو أعلى الصفحةيقلل من وجهة النظر (عن طريق رفع وجهة نظر).

مراقبة الوضع التفاعلي

بالضغط مع الاستمرار على مفتاح التحولعلى لوحة المفاتيح يتجاوز الوضع الحالي (الأساسية أو المتقدمة) لدخول وضع التحكم التفاعلي. في هذا الوضع ما يلي ممكن:

· لفةمؤشر الماوس فوق عنصر أو اتصال لرؤية مكون أو اسم الاتصال؛ و

· انقرعلى عنصر لزوم في هذا المكون.

· إضغط و اسحبعلى عنصر لتدوير العرض حول هذا المكون. و

· انقر بزر الماوس الأيمنمكون أو الاتصال وحدد عرض في مستكشفلرؤية هذا المكون أو موقع الاتصال في الشجرة.

ضوابط مشتركة

· استخدام ALT-ENTER / ESCلتبديل وضع ملء الشاشة؛

· استخدام F2لتغيير طريقة العرض. هذا ويمكن أيضا الوصول إليها في عرض قائمة الطعام.

· استخدام عجلة الماوس أو +/-لتغيير السرعة. يشار إلى السرعة عن طريق رقم في الزاوية السفلى اليسرى - يظهر فقط عندما يتغير. 1 هو الأبطأ و 100 هو الأسرع.


فتح رسم تخطيطي

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

فتح رسم تخطيطي

إرسال التعليقات حول هذا الموضوع.

الرسم الاستنسل وقماش النوافذ تظهر تلقائيا عند فتح رسم تخطيطي أو خلق. وبالمثل، عند إغلاق الرسم البياني، ورقة كلفه المقابلة في إطار قماش يختفي وإذا لم رسومات أخرى مفتوحة ثم يتم إغلاق إطار الاستنسل.

إلى خلقرسم تخطيطي جديد

1. ضمان لديكملف ABACUS مفتوحةتحتوي بك العمارة بالسكان.

2. اضغط على Diagramأيقونة في شريط الأدوات عرض.

- أو -

2. اختار أدخل| Diagram.

- أو -

2. انقر بزر الماوس الأيمن ال الرسوم البيانيةفرع معين هندسة معماريةقسم من الشجرة وحدد خلق رسم بياني.

3. حدد هندسة معماريةتريد التركيز على من القائمة المنسدلة. ملاحظة: سوف يكون بالفعل اختيار الهيكل بالنسبة لك إذا كنت تستخدم الخطوة 3 أعلاه لفتح رسم تخطيطي جديد.

4. حدد وجهة نظر تريد استخدامه من القائمة المنسدلة. ملاحظة: ستكون وجهة نظر المختار تصفية مكونات وقوائم الاتصالات فقط هي التي تتوفر على وجهة نظر.

5. اختياريا تحديد طريقة عرض من تصفية حسب مشاهدةسحب إلى أسفل القائمة لتختر مسبقا مكونات والاتصالات من وجهة النظر المختارة. ملاحظة: هذا هو فعال باستخدام طريقة العرض اختيرت استعلام محفوظ.

6. حدد تصميم إما أن يكون شعاعي أو شبكة.

7. حدد مكوناتو روابطالتي تريدها في الرسم البياني من نافذة اختيار عنصر قياسي .

8. انقر حسنا.

ملاحظة

ستضاف رسم تخطيطي جديد ل الرسوم البيانيةفرع من الهندسة المعمارية. وسيكون لهذا الاسم الافتراضي، والتي يمكنك تغيير في وقت لاحق بالنقر بزر الماوس الأيمن على ذلك.وعلاوة على ذلك، سيتم حفظ الدولة الأخيرة من المرشحات عنصر واختيار اتصال مع الرسم البياني توفير بفعالية 'استعلام' المستخدمة لإنشاء رسم بياني.

لفتح مخطط موجود

1. في العمارة بالسكان محددة، قم بتوسيع الرسوم البيانيةفرع الشجرة.

2. انقر نقرا مزدوجا فوق الرسم البياني الذي تريد فتحه.

لحفظ الرسم البياني

1. تأكد أن لديك رسم تخطيطي جديد أو موجود فتحويمكنك إجراء التغييرات اللازمة. ملاحظة: نجمية '*' سوف يظهر بعد اسم طريقة العرض في رأس ورقة كلفه إذا كانت هناك تغييرات ليتم حفظها.

2. في طريقة عرض المستكشف انقر على حفظزر أو حصلت على ملف| حفظأو خفض CTRL + Sلحفظ جميع التغييرات في مجال العمارة والكتابة إلى ملف.

لحفظ الرسم باعتباره وجهة نظر

1. تأكد أن لديك مخطط الموجودة في ملف ABACUS الخاص بك.

2. انقر بزر الماوس الأيمنالرسم البياني في الرسوم البيانيةجزء من شجرة.

3. اختار حفظ باسم وجهة نظر رسم بياني.

4. أدخل اسما لموقعك الجديد وجهة نظر رسم بيانيوانقر حسنا.

أنظر أيضا

أداة الرسم | يعيش سكان العمارة بك | تحليل العمارة بك


ملء باستخدام الكتالوجات

الملاحة: كثافات سكانية والعمارة الخاصة بك>

ملء باستخدام الكتالوجات

إرسال التعليقات حول هذا الموضوع.

A فهرس يسمح لك لعرض وتحرير مكونات أو اتصالات وممتلكاتهم بطريقة جداول بسيطة.

إلى إنشاء كتالوج جديد عرض في ABACUS

ملاحظة

في حين يمكن لكافة المستخدمين المهندس المعماري خلق الكتالوجات الجديدة، لحفظ التغييرات إلى إعدادات وكتالوج القائمة في ترخيص المستخدم يحتاج مصمم إضافة على القدرة. هذا هو "حماية" تكوين فهارس القائمة التي قد تكون مشتركة من قبل العديد من المستخدمين. ومع ذلك، يستخدم المهندس المعماري دون مصمم إضافة على اختيار ما زالت إلى "حفظ باسم" أية إعدادات جديدة إلى كتالوج جديد. وبالطبع جميع التراخيص يمكن للمستخدم اختيار "تجاهل" أي تغييرات على كتالوج القائمة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى مصمم إضافة على القدرة. وتذكر، وهذا هو مجرد إعدادات كتالوج، كل التعديلات التي أدخلت على البيانات في كتالوج وتطبيقها على الفور إلى المخزون، بغض النظر.

1. اختر إدراج | فهرس.

2. في <العمارة>المنسدلة حدد العمارة التي تحتوي على مكونات أوالاتصالات التي ترغب في عرضها.

3. في <نوع العنصر>المنسدلة حدد المكون أو نوع الاتصال التي ترغب في أن الحالات المذكورة بأنها "الصفوف' في الفهرس.

4. ال فهرس سوف يتم ملؤها معصف لكل مثيل من مكون أو الاتصال المحدد نوع.

ملاحظة

افتراضيا أقصى اليسار مسار التسلسل الهرميعمود (أي التسلسل الهرمي للمكونات الوالدين أو اتصالات فوق الحالات المختارة) و2 اسم عمود (أي قائمة عنصر أو اتصال الحالات المختارة) يتم تجميد إلى اليسار من الكتالوج. لتغيير العمود تجمد اسحب فاصل عمود إلى يمين العمود اسم. انت تستطيع إعادة ترتيبأعمدة ببساطة عن طريق سحب وإسقاط عناوين الأعمدة الخاصة بهم. خلايا الأعمدة مع تسطير الأزرق هي وصلات إلى العناصر الأخرى في المشروع والارتباطات التشعبية يمكن اتباعها عن طريق الضغط باستمرار على Ctrl والنقر على الروابط. يمكن أن تكون الأعمدة مخفي بالنقر بزر الماوس الأيمن فوق رأس العمود واختيار العمود | إخفاء العمود. الأعمدة المخفية يمكن _تم إظهار بالضغط على تكوين زر شريط الأدوات الأعمدة واستخدام أعمدة تكوين الحوار كما هو موضح أدناه، أو عن طريق اختيار السهم الجزء الأسفل من تكوين زر شريط الأدوات أعمدة وبشكل فردي تحديد العمود سرية (ق) من إما عامة، خصائص أو المرفقات المجموعات. يمكن أن تكون الصفوف مجمعة بواسطة قيم العمود عن طريق سحب رأس العمود في شريط تجمع الأزرق في الجزء العلوي من الكتالوج. في أي وقت يمكنك النقر المزدوج على محدد الصف كتالوجو اقفز إلىعنصر المقابلةأو اتصالفي إطار مستكشف.قيم الخلايا الملكية هي بالخط العريض حيث أنهم مختلفون إلى الإعدادات الافتراضية، و المائل حيث أنها للقراءة فقط. قد يكون الطابع الزمني والممتلكات والمرفقة أعمدة مكون ملون وفقا لقيم الخلية أو قيمة العقار مكون المرفقة عن طريق بزر الماوس الأيمن فوق رأس العمود واختيار العمود | تغيير اللون ... ثم اللون بواسطة الطابع الزمني أو خيار اللون بواسطة الممتلكات، ولكن فقط القائمة، صحيح، عشري، منطقية أو تاريخ / وقت ونوع البيانات خصائص اللون. قد تكون قيم الملكية للأعمدة مكون المرفقة أظهرت بالنقر بزر الماوس الأيمن فوق رأس العمود واختيار العمود | معرض العقارات ... ثم الخيار معرض العقارات. وأخيرا، حيث هناك القيود المطلوبة تعيين عمود الممتلكات هذه قد تظهر مع <مطلوب>سلسلة (جنبا إلى جنب مع تلوين وفقا لمستويات إنفاذها) بالنقر بزر الماوس الأيمن فوق رأس العمود واختيار العمود | إظهار <مطلوب>.

فهرس

إلى إضافة أعمدة / المعرض ل a فهرس عرض في ABACUS

1. تأكد من أن لديك عرض كتالوج فتح.

2. الأعمدة المخفية يمكن _تم إظهار بشكل فردي عن طريق النقر على السهم على حق تكوين أعمدة زر شريط الأدواتوتحديد العمود مخبأة إما من جنرال لواء, الممتلكات أو مرفقات المجموعات.

ملاحظة

سيتم عرض علامة التجزئة المقبل إلى الأعمدة معروضة حاليا للكتالوج.بالإضافة إلى ذلك، سوف فقط بعض المرفقات تكون متاحة تحت المرفقات القسم وفقا ل القيود التي تم تعريفها في المشروع. على وجه الخصوص، لمرفق لتكون متاحة ليتم عرضها في نشرة مكون يجب تحديد نوع مكون للكتالوج إما مصدر أو بالوعة (وليس 'أي') قيدا من "صلة يجب ان ترفق" للاتصال نوع، ويجب أن يكون هناك أيضا واحد على الأقل نوع المكون المحدد إما مصدر أو بالوعة (وليس 'أي') من "نهاية" أخرى من نفس نوع الاتصال.

- أو -

2. أعمدة متعددة يمكن _تم إظهار (أو أمر أو ثابتة) بالضغط على تكوين أعمدة زر شريط الأدواتوباستخدام أعمدة تكوين الحوار هو مبين أدناه.

ملاحظة

وتظهر الأعمدة المعروضة حاليا في لوحة على الجهة اليمنى الأعمدة المتاحة هو مبين في اللوحة على اليسار. قد تتم تصفيته الأعمدة المتاحة وفقا ل حدد الأعمدة المتوفرة منسحب إلى أسفل، وأنها يمكن أن تضاف عن طريق تحديدها في لوحة على اليسار والنقر على إضافة زر في المنتصف الفريقين.

تكوين الحوار أعمدة

إلى إزالة / إخفاء الأعمدة من فهرس عرض في ABACUS

1. تأكد من أن لديك عرض كتالوج فتح.

2. بزر الماوس الأيمن فوق رأس العمود للعمود كنت ترغب في إزالة / إخفاء وحدد العمود | إخفاء العمود.

- أو -

2. أعمدة متعددة يمكن أن تكون مخفية (أو أمر أو ثابتة) بالضغط على تكوين أعمدة زر شريط الأدواتوباستخدام أعمدة تكوين الحوار هو مبين أعلاه.

ملاحظة

وتظهر الأعمدة المعروضة حاليا في لوحة على الجهة اليمنى الأعمدة المتاحة هو مبين في اللوحة على اليسار. قد تكون مخفية الأعمدة المعروضة حاليا عن طريق تحديد العمود في لوحة على اليمين والنقر على إزالة زر في المنتصف الفريقين.

لنشر استخدام فهرس عرض في ABACUS

1. إلى أضف مكون أو الاتصالمن النوع المحدد إلى ال كتالوج (والمشروع) انقر على إضافة مكون جديد / اضافة جديد زر شريط أدوات اتصال. الصف ينبغي يبدو و مكون أو سيتم إنشاء اتصال على أعلى مستوى من المكونات أو مجموعة الاتصالات للعمارة الذي تم اختياره.

ملاحظة

تم إضافة مكونات والاتصالات الجديدة افتراضيا في المستوى الأعلى من مكونات أو اتصالات جمع العمارة المختار. لتغيير الأصل من مكونات أو وصلات جديدة بزر الماوس الأيمن فوق الخلية مسار التسلسل الهرمي للمكون أو اتصالات صف جديد وحدد التغيير الرئيسي ...واختيار الوالدين المطلوب (مع الأخذ علما تسليط الضوء على القيد ).

ملاحظة

صفوف جديدة / إضافة عناصر مباشرة إلى التسويقي عن طريق "إضافة جديد" زر، لصقها في الفهرس، أو تم إنشاؤها عن طريق استيراد إلى النشرة المصورة من MS Excel هي معفاة من تصفية حتى يتم إغلاق التسويقي. هذا هو السماح لأي تحرير الضروري من قيم العمود التي قد لا تفي بالمعايير التصفية الحالية للكتالوج. يشار إلى هذه الصفوف عنصر الجديدة بواسطة رمز '+' في الخلية محدد الصف في بداية الصف، الذي هو لون أخضر إذا كان العنصر يجتمع حاليا معايير الترشيح حفظها من الكتالوج (أي سوف تبقى على كتالوج إذا إعادة فتح)، و أحمر إذا لم يحدث ذلك.

2. إلى إزالة مكون أو الاتصالمن النوع المحدد من عند ال كتالوج (والمشروع) حدد الصف وإما ديل اضغط على مفتاح أو بزر الماوس الأيمن فوق محدد الصف وحدد حذف من العمارة. ال صف يجب أن تختفي من الكتالوج و سيتم حذف من المشروع.

إلى فلتر باستخدام فهرس عرض في ABACUS

1. تأكد من أن لديك عرض كتالوج فتح.

2. إذا كان الصف مرشح لا يظهر في الجزء العلوي من الكتالوج ثم انقر على مشاهدة تصفية رأس الصفزر في شريط الأدوات.

3. في العمود تريد لإضافة محددات تصفية، انقر نقرا مزدوجا فوق الخلية الصف مرشح حيث يظهر '(الكل)'.

4. ل الطابع الزمني، مسار التسلسل الهرمي، اسم أو الوصفأعمدة العامة أو النص، صحيح، عشري، منطقية أو تاريخ / وقتأعمدة الملكية انقر فوق الزر ... الذي يظهر في حق الخلية الصف تصفية وأدخل القيم الخلية التي ينبغي أن تدرج في الكتالوج.

ملاحظة

يتم تنفيذ مطابقة كما لو يتم تطبيقها '*' البدل تلقائيا قبل وبعد أي قيم السلسلة بحيث أن دخول "القط" (بدون علامات التنصيص) وتشمل الصفوف مع "بوبقط'،'قطامرأة "أو" تطبيق صحيفةقطأيون "الخ متعددة / 'أو' قد تكون دخلت القيم على خطوط جديدة باستخدام CTRL + أدخل. لعدد صحيح والأعمدة الملكية العشرية "و" قد يتم تضمين منطق باستخدام '&"(بدون علامات التنصيص) وأكبر من / أقل من غيرها المنطق يمكن إدراجها باستخدام '> ='،'>'،'<'و'<="(بدون علامات التنصيص) على سبيل المثال '> = 50000 & <90000'. قد يتم تضمين غير فارغة الصفوف قيمتها عن طريق إدخال '(غير فراغات)"(بدون علامات التنصيص) ويمكن إدراج صفوف قيمة فارغة عن طريق إدخال '(الفراغات)"(بدون علامات التنصيص).وأخيرا، جميع المرشحات التي كتبها الحالة الافتراضية حساسة جدا "القط" (بدون علامات التنصيص) وتشمل الصفوف مع 'القط'، 'القط' أو 'CAT' وما إلى ذلك للحصول على حالة مطابقة حساسة، أدخل "(حالة)"(بدون علامات التنصيص) قبل سلسلة مثل سوف "(القضية) القط (بدون علامات التنصيص) يشمل فقط الصفوف مع 'القط' فى كلماتها.

5. ل مرفقاتالأعمدة، المعايير الأعمدة أو قائمة أعمدة العقار إضغط على زر السهم لأسفل الذي يظهر في حق الخلية الصف تصفية وحدد القيم خلية من خانات الاختيار التي ينبغي أن تدرج في الكتالوج.

ملاحظة

أن '(تحديد الكل)' خانة تمكين كافة خانات أخرى، في الواقع بما في ذلك جميع الصفوف المتاحة. سيتضمن "(غير الفراغات)" مربع أي غير فارغة الصفوف الكرام. سيتضمن "(الفراغات)" مربع أي فارغا قيمتها الصفوف. وأخيرا، إلغاء تحديد أي خانات محددة قيمتها تلقائيا إلغاء تحديد "(تحديد الكل)" و "(غير فراغات) 'خانات من أجل التناسق.

6. انقر حسنا لتطبيق عامل التصفية.

إلى تعطيل / تمكين التصفية على a فهرس عرض في ABACUS

1. تأكد من أن لديك عرض كتالوج فتح مع فلتر تطبيقي.

2. انقر فوق خانة الاختيار إلى اليسار من الصف التصفية.

إلى إزالة عامل تصفية من a فهرس عرض في ABACUS

1. تأكد من أن لديك عرض كتالوج فتح مع فلتر تطبيقي.

2. لإزالة عامل تصفية عمود فردي بزر الماوس الأيمن فوق رأس العمود وحدد العمود | واضح تصفية.

3. لإزالة جميع المرشحات انقر فوق خيارات زر في شريط الأدوات واختر إعدادات تصفية واضحة.

لإنقاذ / حفظ باسم aعرض كتالوج

ملاحظة

في حين يمكن لكافة المستخدمين المهندس المعماري خلق الكتالوجات الجديدة، لحفظ التغييرات إلى إعدادات وكتالوج القائمة في ترخيص المستخدم يحتاج مصمم إضافة على القدرة. هذا هو "حماية" تكوين فهارس القائمة التي قد تكون مشتركة من قبل العديد من المستخدمين. ومع ذلك، يستخدم المهندس المعماري دون مصمم إضافة على اختيار ما زالت إلى "حفظ باسم" أية إعدادات جديدة إلى كتالوج جديد. وبالطبع جميع التراخيص يمكن للمستخدم اختيار "تجاهل" أي تغييرات على كتالوج القائمة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى مصمم إضافة على القدرة.وتذكر، وهذا هو مجرد إعدادات كتالوج، كل التعديلات التي أدخلت على البيانات في كتالوج وتطبيقها على الفور إلى المخزون، بغض النظر.

1. تأكد أن لديك جديد أو القائمة عرض كتالوج فتحويمكنك إجراء التغييرات اللازمة.

2. في عرض كتالوجانقر فوق شريط الأدوات على حفظزر لانقاذ عرض كتالوج وأية تغييرات التنسيق.

ملاحظة

إذا لم يكن لديك زر حفظ في شريط الأدوات عرض كتالوج ثم لم يكن لديك مصمم إضافة على وكنت فقط قادرة على حفظ باسمأي إعدادات تغييرات على كتالوج جديد عندما تذهب لإغلاق كتالوج القائمة.

3. إذا ال فهرس اسميبدو الحوار (نظرا لكونها كتالوج جديد) أدخل اسما لل فهرس والصحافة حسنا.

إلى التصدير إلى إكسل كتالوج

1. تأكد من أن لديك عرض كتالوج فتح.

2. انقر على تصدير إلى Excel جداول البيانات كتالوجزر في شريط الأدوات.

3. اختيار اسم الملف لحفظ كتالوج MS Excel كما. انقر حفظ.

ملاحظة

افتراضيا اسم الملف الذي تم تصديره كتالوج إكسل سوف يكون اسم كتالوج مع إضافة اسم العمارة بين قوسين، على سبيل المثال "المشاريع (2014 الفعلية). XLSX. يمكنك تغيير أي شيء من هذا، بما في ذلك ما إذا كان تنسيق الملف هو أن تكون. XLSX أو. XLS. يتم تضمين اسم العمارة لتذكير المستخدم أن كل كتالوج يحتوي على محتوى معين (أي معرفات في العمود A والصف 1) للسماح لها أن تكون مستديرة تعثرت مرة أخرى في استخدام استيراد من مايكروسوفت إكسل كتالوج حسب أدناه.

ملاحظة

افتراضيا العمود A مخفي داخل تصديرها كتالوج MS Excel يحتوي على معرف فريد لكل عنصر من العناصر في مستودع ABACUS. وهذا يسمح أي التغييرات التي يتم إجراؤها داخل MS Excel إلى أن "يقابل حتى 'إلى العناصر الموجودة داخل ABACUS على استيراد (انظر أدناه). ومع ذلك، فإن استخدام هذا معرف فريد إلى "تطابق" الصفوف قد يتم تجاوز مع الخارجية | هوية شخصيةالملكية على العنصر. وهذا هو، إذا كان العنصر لديه الخارجية | خاصية المعرف ويتم تضمينه في الكتالوج على التصدير ثم قيم الخارجية | وسيتم استخدام العمود ID لمتابعة المباراة الصفوف على استيراد (انظر أدناه)، وسيتم تجاهل القيم ID فريدة من نوعها في العمود A مخفي (ويمكن حتى ان تكون فارغة). العمود A مخفي يجب أن تبقى نفسها، ومع ذلك، لا سيما القيمة في الخلية A1. وعلاوة على ذلك، عند إضافة إسم البائع الخارجية إلى جمع عنصر ABACUS القائمة نوصي إضافتها كخاصية مختلفة لأول مرة، على سبيل المثال الخارجية | درجة الحرارة ومن ثم إعادة تسمية الملكية لجهات خارجية | هوية شخصية. وإلا سيتم إضافة عناصر مكررة.

التنسيق كتالوجويتم تصدير افتراضيا، ولكن لكتالوجات كبيرة وهذا قد يؤدي في تصدير يجري بطيئا جدا. وفقا لذلك، في أدوات | الخيارات ...ثم على ال فهرسعلامة التبويب،كنت قادرا على تقليل كمية التنسيق الذي يتم تصديره كما هو مبين في علامة التبويب فهرس أدناه، وبالتالي تسريع عملية التصدير.

تصدير كتالوج خيارات

4. يتم عرض الحوار تصدير مكتمل. انقر حسنا.

تصديرها إلى إكسل كتالوج

إلى الاستيراد من مايكروسوفت إكسل كتالوج

ملاحظة

افتراضيا العمود A مخفي داخل تصدير الخدمات مايكروسوفت إكسل (انظر أعلاه) يحتوي على معرف فريد لكل عنصر من العناصر في مستودع ABACUS. وهذا يسمح أي التغييرات التي يتم إجراؤها داخل MS Excel إلى أن "يقابل حتى 'إلى العناصر الموجودة داخل ABACUS على الاستيراد. ومع ذلك، فإن استخدام هذا معرف فريد إلى "تطابق" الصفوف قد يتم تجاوز مع الخارجية | هوية شخصيةالملكية على العنصر. وهذا هو، إذا كان العنصر لديه الخارجية | خاصية المعرف ويتم تضمينه في الكتالوج على تصدير (انظر أعلاه) ثم قيم الخارجية | وسيتم استخدام العمود ID لمتابعة المباراة الصفوف على الاستيراد والقيم ID فريدة من نوعها في العمود A مخفي سيتم تجاهل (ويمكن حتى ان تكون فارغة). العمود A مخفي يجب أن تبقى نفسها، ومع ذلك، لا سيما القيمة في الخلية A1. وعلاوة على ذلك، عند إضافة إسم البائع الخارجية إلى جمع عنصر ABACUS القائمة نوصي إضافتها كخاصية مختلفة لأول مرة، على سبيل المثال الخارجية | درجة الحرارة ومن ثم إعادة تسمية الملكية لجهات خارجية | هوية شخصية. وإلا سيتم إضافة عناصر مكررة.

1. تأكد من أن لديك عرض كتالوج فتح.

2. انقر على الاستيراد من إكسل كتالوج جدولزر في شريط الأدوات.

3. اختيار اسم الملف إلى استيراد كتالوج MS Excel من. انقر فتح.

4. أخطاء جديدة الكشف عن و / أو أخطاء الجديدة / تحذيرات الكشف قد تظهر الحوارات عن أي محتوى جديد (أي الصفوف في مايكروسوفت إكسل) التي تم إضافتها. يحيط علما الأخطاء / التحذيرات وانقر حسنا.

5. يتم عرض الحوار استيراد مكتمل وأنه قد تظهر تحذيرات بسبب استيراد (انظر الملاحظات أدناه). انقر حسنا.

ملاحظة

للأعمدة مكون تعيين معايير أو تعلق، يجب أن إدخالات جديدة من خلال كتالوج إكسل تتطابق تماما مع اسم معيار قائم أو مكون من النوع الصحيح لهذه المهمة أو اتصال لإضافتها. سيتم استخدام أول مباراة اسمه وسوف أي إدخالات لا مثيل لها توليد تحذيرا حسب أدناه. وعلاوة على ذلك، في حين يتم إعطاء تحذيرات على إعادة الاستيراد، العناصر لا يتم حذفمن ABACUS إذا لم تكن موجودة في الكتالوج مايكروسوفت إكسل. هذا هو لأنه لا يوجد الطريقة التي ABACUS يمكن معرفة ما إذا كان مكون تعيين قياسي أو تعلق موجود في المشروع ABACUS لكنه غير موجود في كتالوج MS Excel بسبب أنه قد تم حذفه من كتالوج إكسل أو قد أضيفت إلى ABACUS تم تصدير المشروع منذ الكتالوج. وفقا لذلك، وإذا كان يرغب مستخدمين بسهولة 'كشف' التي أضيفت الاتصالات أثناء عملية الاستيراد أنها يمكن أن إنشاء خاصية المطلوبة على نوع الاتصال وضعه افتراضي إلى فارغة بحيث سيتم حذر من أي اتصالات جديدة في كل مرة استيراد اكتمال.

ملاحظة

عند استيراد كتالوج MS Excel قد يتم عرض التحذيرات المختلفة. أولا، إذا تم إضافة عمود جديد إلى Excel الذي لا يتطابق مع "جملة" لخاصية أو مكون المرفقة سيتم تجاهل العمود. وبعد ذلك، سيتم عرض خط سطرا تحذيرات عن أية مشكلات مع البيانات في كل صف من كتالوج إكسل. تبدأ هذه التحذيرات مع رقم الصف بين قوسين معقوفين وإذا كان ذلك مناسبا تسمية عمود (أي "[23، J] ... 'لالصف 23، العمود J) ويمكن أن تشير إلى العناصر المحذوفة، معايير لا تضاهى أو أسماء مكون المرفقة (التي يتم تجاهل حسب المذكرة أعلاه) أو معرف غير صالح أو فارغ تتعلق صف جديد / عنصر (التي ستضاف). عن مقالة مفصلة عن ملء ABACUS باستخدام الفهارس إكسل يرجى الرجوع إلى Avolution الجماعة أو الدورة التدريبية مدير المحفظة المالية.

ملاحظة

تم إضافة مكونات والاتصالات الجديدة افتراضيا في المستوى الأعلى من مكونات أو اتصالات جمع العمارة المختار. لتغيير الأصل من مكونات أو وصلات جديدة بزر الماوس الأيمن فوق الخلية مسار التسلسل الهرمي للمكون أو اتصالات صف جديد وحدد التغيير الرئيسي ...واختيار الوالدين المطلوب (مع الأخذ علما تسليط الضوء على القيد ).

ملاحظة

وأضافت العناصر مباشرة إلى الكتالوج عبر "إضافة جديدة" زر، لصقها في الفهرس، أو تم إنشاؤها عن طريق استيراد إلى النشرة المصورة من MS Excel هي معفاة من تصفية حتى يتم إغلاق التسويقي. هذا هو السماح لأي تحرير الضروري من قيم العمود التي قد لا تفي بالمعايير التصفية الحالية للكتالوج. يشار إلى هذه الصفوف عنصر الجديدة بواسطة رمز '+' في الخلية محدد الصف في بداية الصف، الذي هو لون أخضر إذا كان العنصر يجتمع حاليا معايير الترشيح حفظها من الكتالوج (أي سوف تبقى على كتالوج إذا إعادة فتح)، و أحمر إذا لم يحدث ذلك.

إلى مقارنة محتوى التسويقي مع العمارة آخر

1. يرجى الرجوع إلى الموضوع هنا .

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | يعيش سكان العمارة بك من برنامج Visio | يعيش سكان العمارة بك من إكسل


ملء استخدام المصفوفات

الملاحة: كثافات سكانية والعمارة الخاصة بك>

ملء استخدام المصفوفات

إرسال التعليقات حول هذا الموضوع.

مصفوفة يسمح لك لعرض وتحرير 'مباشرة' اتصالات بين المكونات بطريقة جداول بسيطةوعرض أيضا "مسار غير مباشر" بين المكونات وفقا لأية عناصر وسيطة (وصلات).

إلى خلق وجهة نظر مصفوفة في ABACUS

ملاحظة

في حين يمكن لكافة المستخدمين مهندس إنشاء مصفوفات لإنقاذهم و / أو إعداداتها ل ترخيص المستخدم يحتاج مصمم إضافة على القدرة. هذا هو "حماية" تكوين مصفوفات القائمة التي قد تكون مشتركة من قبل العديد من المستخدمين. ومع ذلك، يستخدم المهندس المعماري دون مصمم إضافة على اختيار ما زالت إلى "حفظ باسم" أية إعدادات جديدة لمصفوفة جديدة. وبالطبع جميع التراخيص يمكن للمستخدم اختيار "تجاهل" أي تغييرات على مصفوفة القائمة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

1. اختر إدراج | مصفوفة.

2. في rchitecturه>المنسدلة حدد العمارة التي تحتوي على مكونات والاتصالات التي ترغب في عرضها.

3. في <مصدراكتب>المنسدلة تحديد نوع العنصر الذي ترغب في الحصول على الحالات المذكورة بأنها "الصفوف' على الجهة اليسرىمن المصفوفة.

4. في <بالوعةاكتب>المنسدلة تحديد نوع العنصر الذي ترغب في الحصول على الحالات المذكورة بأنها "الأعمدة' في أعلىمن المصفوفة.

5. في <نوع مسار (ق)> اسحب للأسفل هناك أساسا اثنين من "وسائط" مصفوفة يمكنك تحديد ...

اتصالات 'مباشرة' المصفوفات

6. ببساطة لياليمنتخب واحد (1) أو أكثر الاتصال أنواع على الجانب الأيمن من القائمة التي تظهر إذا كنت أتمنى أن نرى في 'خلايا' من المصفوفة إذا كانن صريحيوجد اتصال من عمودي/ 'صف"عنصر من المصفوفة إلى أفقي/ 'عمود"عنصر من المصفوفة.

ملاحظة

الاتصالات الوحيدة مع مصدر نهاية مرفق ل عمودي/ 'صف"عنصر وبالوعة نهاية تعلق على أفقي/ 'عمود"وسوف يعرض المكون. تبديل مصدرو بالوعةاختيارات نوع المكونة لعرض الاتصالات في الاتجاه المعاكس.

7. سوف يتم ملؤها المصفوفة مع 'X' في الخلايا (أو قيمة العقار - انظر الملاحظة أدناه) إذا كان هناك اتصال من عمودي/ 'صف'عنصر من المصفوفة إلى أفقي/ 'عمود"عنصر من المصفوفة.

ملاحظة

وللمصفوفات كبيرة أن تظهر فقط كحد أقصى من 100 الصفوف أو الأعمدة (بما في ذلك انهار الصفوف / الأعمدة) في وقت واحد كما هو مبين من قبل 'R' ومؤشرات 'C' في الخلية رأس أعلى اليسار على التوالي. لعرض صفوف إضافية تستخدم أشرطة التمرير. في أي وقت يمكنك النقر المزدوج على عمودي/ 'صف' أو هوريزونتآل / 'عمود' مكون عناوين و اقفز إلىمكونات المقابلة في إطار مستكشف.والدي عمودي/ 'صف' و أفقي/ 'عمود' مكونكما هو مبين الصورة اختياريا كما تتجه الصفوف / الأعمدة مع عنوان عنوان الرمادي. عندما انهار (عن طريق النقر واحد الخلية العنوان) في حالة وجود أطفال المرفقات بعد ذلك 'X' سوف يكون اختياريا يظهر إذا كانت تعلق جميع الأطفال أو سوف يكون اختياريا أبدت 'O' إذا كانت تعلق بعض الأطفال فقط. قد تكون الخلايا ملون وفقا لقيمة العقار من الاتصالات عن طريق النقر على الخيارات 'والعتاد عجلة "في أعلى يمين شريط الأدوات مصفوفة واختيار إعدادات اللون ... وبعد ذلك على زر تحرير واختيار اللون الطابع الزمني أو اللون بواسطة الخاصية الخيار واختيار عقار، ومجموعة قيمة الحد الأدنى والحد الأقصى واختيار الألوان، ولكن فقط القائمة، صحيح، عشري، منطقية أو تاريخ / وقت ونوع البيانات خصائص اللون. وإذا انهار تكون ملونة الخلية وفقا لمتوسط ​​قيمة العقار من الاتصالات. بدلا من 'X'، قد تكون قيم الملكية للخلايا أظهرت بالضغط على خيارات "عجلة والعتاد" في أعلى يمين شريط الأدوات مصفوفة واختيار إظهار الإعدادات القيمة ... وبعد ذلك على زر تحرير وتحديد خيار عرض الممتلكات واختيار الممتلكات.

وصلات مباشرة مصفوفة تبين ملقمات حيث تتم استضافة التطبيقات مع التلوين والممتلكات التي أظهرت بدلا من عام 'X'

- أو -

اتصالات "غير المباشرة" المصفوفات

6. Sمنتخبسلسلة من الاتصال أنواع و أنواع عنصرعلى اليمين واليسار الجانب من القائمة التي تظهر إذا كنت أتمنى أن نرى في 'خلايا' من المصفوفة إذا كانن طريق غير مباشر من المكونات الموصولةالوجود من عمودي/ 'صف"عنصر من المصفوفة إلى أفقي/ 'عمود"عنصر من المصفوفة.

ملاحظة

أي مسار صحيح أن يتضمن العناصر المحددة في قائمة مسار ثسوء يتم عرضهابغض النظر عن اتجاه الاتصالات الأساسية، ومع ذلك، عند اختيار مسار الأولو عناصر مشاركة المختارة يجب أن تكون أنواع الاتصال. علاوة على ذلك، النظام من العناصر التي تم اختيارها يظهر مع بادئة عدديةفي ساحة ('[]') بين قوسين ويمكن إدراج نوع معين مرات موتليبليفي مسار (كما هو مبين من خلال البادئة العددية). يتم تفسير اختيار متتالية من أنواع مكون أو أنواع الاتصال باعتبارها 'أو'مسار والتسلسل الهرمي للمكونات المرفقة قد يتم تضمين اختياريا عن طريق التحقق من 'كما بحث الآباء المرفقات / أطفالخانة الاختيار ". تبديل مصدرو بالوعةاختيارات نوع المكونة لعرض مسارات في الاتجاه المعاكس.

7. سوف يتم ملؤها المصفوفة معمسار / مجموعة من المكوناتفي الخلايا إذا كان هناك مسار من عمودي/ 'صف'عنصر من المصفوفة إلى أفقي/ 'عمود"عنصر من المصفوفة.

ملاحظة

وللمصفوفات كبيرة أن تظهر فقط كحد أقصى من 100 الصفوف أو الأعمدة (بما في ذلك انهار الصفوف / الأعمدة) في وقت واحد كما هو مبين من قبل 'R' ومؤشرات 'C' في الخلية رأس أعلى اليسار على التوالي. لعرض صفوف إضافية تستخدم أشرطة التمرير. في أي وقت يمكنك النقر المزدوج على عمودي/ 'صف' أو هوريزونتآل / 'عمود' مكون عناوين و اقفز إلىمكونات المقابلة في إطار مستكشف.والدي عمودي/ 'صف' و أفقي/ 'عمود' مكونكما هو مبين الصورة اختياريا كما تتجه الصفوف / الأعمدة مع عنوان عنوان الرمادي. عندما انهار (عن طريق النقر واحد الخلية العنوان) في حالة وجود أي مسارات الأطفال بعد ذلك 'X' سوف يكون اختياريا يظهر إذا كانت تعلق جميع الأطفال أو سوف يكون اختياريا أبدت 'O' إلا إذا كان بعض الأطفال لديهم المسارات. قد تكون مكونات مسار غير المباشرة ملون وفقا لقيمة العقار من المكونات من خلال النقر على خيارات "والعتاد عجلة" في أعلى يمين شريط الأدوات مصفوفة واختيار إعدادات اللون ... وبعد ذلك على زر تحرير واختيار اللون الطابع الزمني أو اللون بواسطة الخاصية الخيار واختيار عقار، ومجموعة قيمة الحد الأدنى والحد الأقصى واختيار الألوان، ولكن فقط القائمة، صحيح، عشري، منطقية أو تاريخ / وقت ونوع البيانات خصائص اللون. قد تكون قيم الملكية لمكونات مسار غير المباشرة أظهرت بالضغط على خيارات "عجلة والعتاد" في أعلى يمين شريط الأدوات مصفوفة واختيار إظهار الإعدادات القيمة ... وبعد ذلك على زر تحرير وتحديد خيار عرض الممتلكات واختيار الممتلكات.

الاتصالات غير المباشرة مصفوفة تبين التطبيقات التي تنفيذ خدمة معينة من قبل وزارة

إلى فلتروجهة نظر مصفوفة في ABACUS

1. تأكد أن لديك جديد عرض مصفوفة فتح.

2. انقر تصفية محاور 'قمع' في أعلى يمين شريط الأدوات المصفوفة.

3. على المصدر و / أو علامات التبويب بالوعة إضافة اسم، خاصية، الوصف، هرمي أو المرشحات القياسية من خلال النقر على زر إضافة، واختيار خاصية إذا لزم الأمر والنقر حسنا. حدد الخيارات ذات الصلة في لوحة كلمات / الأصناف باستخدام المنطق / جملة كما هو موضح في المذكرة أدناه. فإن لوحة المعاينة تلقائيا إلى عرض نتائج المجموعة الحالية من المرشحات.

ملاحظة

ل الطابع الزمني، مسار التسلسل الهرمي، اسم أو الوصفمرشحات أو النص، صحيح، عشري، منطقية أو تاريخ / وقتيتم تنفيذ الفلاتر الملكية مطابقة كما لو يتم تطبيقها '*' البدل تلقائيا قبل وبعد أي قيم السلسلة بحيث أن دخول "القط" (بدون علامات التنصيص) وتشمل الصفوف مع "بوبقط'،'قطامرأة "أو" تطبيق صحيفةقطأيون "الخ متعددة / 'أو' قد تكون دخلت القيم على خطوط جديدة باستخدام CTRL + أدخل. ل عدد صحيح و عدد عشري مرشحات الملكية "و" قد يتم تضمين منطق باستخدام '&"(بدون علامات التنصيص) وأكبر من / أقل من غيرها المنطق يمكن إدراجها باستخدام '> ='،'>'،'<'و'<="(بدون علامات التنصيص) على سبيل المثال '> = 50000 & <90000'. قد يتم تضمين غير فارغة الصفوف قيمتها عن طريق إدخال '(غير فراغات)"(بدون علامات التنصيص) ويمكن إدراج صفوف قيمة فارغة عن طريق إدخال '(الفراغات)"(بدون علامات التنصيص).ل المعايير أو قائمة الملكية المرشحات سوف '(تحديد الكل)' خانة تمكين كافة خانات أخرى، في الواقع بما في ذلك جميع العناصر المتاحة. سيتضمن "(غير الفراغات)" مربع أي عناصر الملكية غير فارغة الكرام. سيتضمن "(الفراغات)" مربع أي ممتلكات فارغة عناصر الكرام. وإلغاء تحديد أي خانات محددة قيمتها سيتم تلقائيا إلغاء تحديد "(تحديد الكل)" و "(الفراغات غير) 'خانات من أجل التناسق. وأخيرا، جميع المرشحات التي كتبها الحالة الافتراضية حساسة جدا "القط" (بدون علامات التنصيص) وتشمل العناصر مع 'القط'، 'القط' أو 'CAT' وما إلى ذلك للحصول على حالة مطابقة حساسة، أدخل "(حالة)"(بدون علامات التنصيص) قبل سلسلة مثل سوف "(القضية) القط (بدون علامات التنصيص) يشمل فقط العناصر مع 'القط' فى كلماتها.

لنشر باستخدام طريقة عرض مصفوفة في ABACUS

ملاحظة

يمكنك فقط إضافة / إزالة اتصالات حيث تم استخدام نوع اتصال واحد لمسار المذكورة أعلاه.

1. إلى إضافة اتصالمن النوع المحدد بين عمودي/ 'صف"عنصر و أفقي/ 'عمود"عنصر من المصفوفة، حيث ل'غير موجود X' بالفعل(أو قيمة خاصية إظهار - انظر الملاحظة أعلاه)، انقر نقرا مزدوجا فوق الخلية. يجب أن يظهر 'X' (أو قيمة العقار - انظر الملاحظة أعلاه) وسيتم إنشاء اتصال على أعلى مستوى من مجموعة الاتصالات للعمارة الذي تم اختياره.

ملاحظة

سيكون اسم للاتصال اتصال اسم نوع وحسب الإعداد نوع الاتصال من المصفوفة وإذا كانت قيمة الممتلكات التي يتم عرضها بدلا من 'X' القيمة الافتراضية للخاصية يتم عرضها.

2. إلى تعديل قيمة خاصية إظهارعلى الاتصال بين a عمودي/ 'صف"عنصر و أفقي/ 'عمود"عنصر من المصفوفة، انقر نقرا مزدوجا فوق الخلية، أو بزر الماوس الأيمن فوق الخلية واختر تحرير قيمة ...، وتعديل قيمة في الحوار تغيير القيمة.

3. إلى إزالة اتصالمن النوع المحدد بين عمودي/ 'صف"عنصر و أفقي/ 'عمود"عنصر من المصفوفة، حيث من 'X' موجود مسبقا(أو قيمة خاصية إظهار - انظر الملاحظة أعلاه), الصحيح-انقر فوق الخليةوحدد قطع الاتصال. وX يجب أن تختفي وسيتم حذف الاتصال من المشروع.

لإنقاذ / حفظ باسم aعرض مصفوفة

ملاحظة

في حين يمكن لكافة المستخدمين مهندس إنشاء مصفوفات لإنقاذهم و / أو إعداداتها ل ترخيص المستخدم يحتاج مصمم إضافة على القدرة. هذا هو "حماية" تكوين مصفوفات القائمة التي قد تكون مشتركة من قبل العديد من المستخدمين. ومع ذلك، يستخدم المهندس المعماري دون مصمم إضافة على اختيار ما زالت إلى "حفظ باسم" أية إعدادات جديدة لمصفوفة جديدة. وبالطبع جميع التراخيص يمكن للمستخدم اختيار "تجاهل" أي تغييرات على مصفوفة القائمة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى مصمم إضافة على القدرة.وتذكر، وهذا هو مجرد إعدادات مصفوفة، وجميع التعديلات التي أدخلت على البيانات في مصفوفة يتم تطبيقها على الفور إلى المخزون، بغض النظر.

1. تأكد أن لديك جديد عرض مصفوفة فتحويمكنك إجراء التغييرات اللازمة.

2. في عرض مصفوفةانقر فوق شريط الأدوات على أقصى اليسار حفظ مصفوفةزر لانقاذ عرض مصفوفة وأية تغييرات التنسيق.

ملاحظة

إذا لم يكن لديك زر حفظ في شريط الأدوات عرض مصفوفة ثم لم يكن لديك مصمم إضافة على وكنت فقط قادرة على حفظ باسمأي إعدادات تغييرات على مصفوفة جديدة عندما تذهب لإغلاق مصفوفة القائمة.

3. إذا ال مصفوفة اسمالحوار الذي يظهر (نظرا لكونها مصفوفة جديدة) أدخل اسما لل مصفوفةوالصحافة حسنا.

إلى التصدير إلى مصفوفة إكسل

1. تأكد من أن لديك عرض مصفوفة فتح.

2. انقر على تصدير إلى Excelزر في شريط الأدوات.

3. اختيار اسم الملف لحفظ المصفوفة MS Excel كما. انقر حفظ.

ملاحظة

افتراضيا اسم الملف الذي تم تصديره مصفوفة إكسل سوف يكون اسم مصفوفة مع إضافة اسم العمارة بين قوسين، على سبيل المثال "التطبيقات المستضافة على خوادم (2014 الفعلية). XLSX. يمكنك تغيير أي شيء من هذا، بما في ذلك ما إذا كان تنسيق الملف هو أن تكون. XLSX أو. XLS.

التنسيق مصفوفةويتم تصدير افتراضيا، ولكن، للمصفوفات كبيرة وهذا قد يؤدي في تصدير يجري بطيئا جدا. وفقا لذلك، في أدوات | الخيارات ...ثم على ال مصفوفةعلامة التبويب،كنت قادرا على تقليل كمية التنسيق الذي يتم تصديره كما هو مبين في علامة التبويب مصفوفة أدناه، وبالتالي تسريع عملية التصدير.

تصدير مصفوفة خيارات

4. يتم عرض الحوار تصدير مكتمل. انقر حسنا.

تصديرها إلى مصفوفة إكسل

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | يعيش سكان العمارة بك من برنامج Visio | يعيش سكان العمارة بك من إكسل


ملء رسم تخطيطي

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

ملء رسم تخطيطي

إرسال التعليقات حول هذا الموضوع.

الرسومات في ABACUS هي أكثر من مجرد تمثيل التعسفي. يتم تخصيص أنها آراء الهندسة المعمارية، وتنسيق وترتيب لإظهار معنى خاص.

أداة رسم يفرض على الهيكل الهرمي للهيكل، بحيث يتم تداخل مكونات بصريا ضمن مكونات أخرى - إعطاء فعليا "عرض خطة 'العناصر. مرة واحدة وقد تم تعريف عنصر أو اتصال في الهندسة المعمارية، ويمكن استخدامه في أي عدد من المخططات المختلفة. الأهم من ذلك، يرتبط ارتباطا وثيقا أداة رسم نموذج معماري، بحيث تنعكس التغييرات القيام به في أي واحد دائما في الآخر.

الأداة يعمل عن طريق ربط الأشكال مع أنواع معينة من الاتصال والعنصر المحدد في المقطع أنواع من العمارة. هذه الجمعيات تختلف تبعا لنوع من الرسم البياني الانجرار، وأنه من الممكن أن نوع واحد من عنصر (أو اتصال) قد يكون لها تمثيلات مختلفة في الرسوم البيانية المختلفة، اعتمادا على السياق.

لإنشاء ارتباط بين الشكل ومكون أو نوع الاتصال

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح .

2. تعظيم تطبيق ABACUS، و تكوين أبعاد النافذة كما تريدها.

3. حدد علامة التبويب الأشكالأو علامة التبويب الموصلات في إطار الاستنسل.

4. في اكتبفرع مستكشف، حدد موقع العنصر أو نوع الاتصال الذي ترغب في اقترانه الشكل أو الموصل.

5. حدد العنصر نوع اختيار من الشجرة، اسحبه لأكثر من علامة التبويب الأشكال أو علامة التبويب موصلات، و وضعها في شكل أو موصلكنت ترغب في استخدامها.

ملاحظة

يمكنك التحقق من وجود ارتباط قمت بإنشائها من خلال تحديد مكونات أو علامة التبويب اتصالات في إطار الاستنسل، والتي تظهر عناصر مرتبطة حاليا.

لإضافة أشكال جديدة إلى حسابك في الرسوم البيانية / مكتبة

1. إنشاء رسم تخطيطي MS برنامج Visio مع الأشكال التي تريد إضافة إلى الرسم البياني الخاص بك، و استيراد الرسم MS برنامج Visio .

تلميح

ومن المهم ما الحجم الذي جعل الشكل الرئيسي في برنامج Visio MS لأن الحجم قماش ABACUS في بكسل وحدة فقط المليمترات MS برنامج Visio تحويل granularly إلى بكسل على 4 بكسل إلى 1 نسبة ملليمتر. وعلاوة على ذلك، الافتراضي الأشكال ABACUS وعادة ما تكون 60 بكسل عالية جدا، بحيث يترجم إلى 15 ميليمتر في برنامج Visio MS. وهذا يعني وينصح سيد حجم شكل MS في برنامج Visioغير 25MM واسعة من قبل خفض 15mm عاليةلأن هذا ما سيترجم إلى 100 بكسل من ارتفاع في ABACUS 60 بكسل.

تلميح

إذا كنت تريد أن يكون لها 'رمز' قليلا في أعلى الزاوية اليسرى من شكل بعد ذلك يمكنك ببساطة خلق 'رمز' في الماجستير شكل MS برنامج Visio باستخدام لوحة MS برنامج Visio أداة الرسم (لاحظ أن خطوط بسيطة فقط، والدوائر ويتم دعم المستطيلات وغير معتمدة الأشكال النقطية / نقطية على وجه الخصوص). وعلاوة على ذلك، إذا كنت ترغب في أن تكون أيقونة ثابت في حجم / حجمضمن الشكل في ABACUS ثم يمكنك مجموعة 'رمز' في الماجستير شكل MS برنامج Visio عن طريق اختيار جميع عناصرها، بزر الماوس الأيمن فوق عنصر واحد، واختيار الشكل | مجموعة، ثم انقر بزر الماوس الأيمن فوق الشكل مجمعة واختيار البيانات | تشكيل البيانات ...، واختيار نعم في مربع الحوار الذي يظهر ثم إضافة خاصية مع تسمية لتعيين LockScale(لاحظ الأحرف الكبيرة 'L' و 'S')، واكتب تعيين ل منطقية والقيمة المتوقع أن يكون صحيح (لاحظ أنه هو كل شيء في الأحرف الكبيرة).

تلميح

إذا كنت تريد أن يكون جزء من شكل مجمدة من التوسع أفقيا أو رأسيا (كما هو الحال مع شكل 'swimlane') ثم يمكنك النقر بزر الماوس الأيمن فوق جزء (ق) للسيد شكل MS Visio الذي تريد المجمدة من التوسع وحدد البيانات | تشكيل البيانات ...، واختيار نعم في مربع الحوار الذي يظهر ثم إضافة خاصية مع تسمية لتعيين LockXScale أو LockYScale (لاحظ الأحرف الكبيرة 'L' و 'S')، واكتب تعيين ل منطقية والقيمة المتوقع أن يكون صحيح (لاحظ أنه هو كل شيء في الأحرف الكبيرة)، لتأمين التوسع الأفقي أو الرأسي على التوالي.

تلميح

للسماح للتلوين الشكل في ABACUS بعد استيراد بدلا من الشكل يجري دائما لون ثابت فإنه من المستحسن أن تجعل ملء سيد MS برنامج Visio الشكل شفاف ثم استخدم قدرة يحمل في ثناياه عوامل في ABACUS للون الخلفية والشكل. هذا يعمل فقط مع المستطيل أو شبه مستطيل (مثل مستطيل مستدير الزوايا) الأشكال كما سيتم تلوين الخلفية مستطيلة بأكملها.

2. فتح الرسم البياني المقابلة وحدد علامة التبويب مكوناتفي إطار الاستنسل.

3. لكل شكل الجديد الذي تريد أن تتيح لمخططات أخرى انقر بزر الماوس الأيمنشكل وحدد إضافة إلى مكتبة الأشكال. وهذا سيجعل من شكل المتاحة على علامة التبويب الأشكال في إطار الاستنسل.

4. ربط نوع العنصر المناسب مع شكل جديد من مكتبة الأشكال وفقا للخطوات المذكورة أعلاه.

ملاحظة

بسيطة فقط ومعتمدة الأشكال في ABACUS في الوقت الراهن "ناقلات القائم على"، لا يتم اعتماد أي الصور النقطية. ومع ذلك، أدوات مثل ناقلات ماجيك ( www.vectormagic.com ) المتوفرة التي سيتم تحويل بسهولة الصور النقطية إلى الأشكال ناقلات القائم (أي تنسيق SVG) التي يمكن فتحها في برنامج Visio MS، وبالتالي الاستفادة منها في ABACUS وفقا للتعليمات المذكورة أعلاه.

مضيفامكونات واتصالات

أداة رسم يسمح لك ل إضافة مكونات والاتصالات الموجودة من المستودع أو إنشاء مكونات واتصالات جديدة كما كنت رسم تخطيطي. كما يتم إنشاء مكونات والاتصالات في الرسوم البيانية، وأضاف في وقت واحد كانت في مستودع. يوجد ثلاثة أوصى طرق لإضافة عناصر إلى رسم تخطيطيوأوصى ثلاث طرق لإضافة وصلات إلى رسم تخطيطي:

إنشاء مكون جديد تماما أو الاتصال على رسم تخطيطيمن الاستنسل

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. حدد مكونات أو روابطالتبويب في إطار الاستنسل لرؤية الأشكال المرتبطة بها. فقط هذه الأشكال يمكن استخدامها لخلق عناصر النموذج الجديد.

3. إضغط و اسحبواحدة من يرتبط الأشكال المتاحة على قماش الرسم. سوف يظهر عنصر جديد على القماش وفي شجرة المستكشف.

4. ابدأ الكتابةاسم العنصر الجديد في مربع الحوار وأي عناصر القائمة التي يقابل واقترح ويمكن اختيار بدلا من إضافة عنصر جديد إلى الهندسة المعمارية.

5. انقر حسنا.

6. إذا أسقطت شكل على عنصر القائمة، بعد ذلك سوف تصبح إما طفل من هذا المكون (إذا جاء شكل من مكوناتعلامة التبويب)، أو سوف تعلق على هذا العنصر (إذا جاء شكل من روابطعلامة التبويب).

ملاحظة

فمن الضروري في بعض الأحيان إلى ضبط عنصر جديد أو اتصال في مكان مختلف في التسلسل الهرمي المعماري باستخدام المستكشف.

لوضع عنصر القائمة أو اتصال من مستودع على الرسم البياني

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. تأكد من أن لديك كل أداة رسم ومستكشف ويندوز للعرض.

3. في مستكشف، حدد موقع مكون أو الاتصال(عنصر) التي أود أن أضيف إلى الرسم التخطيطي.

4. إضغط و اسحبمع العنصر المختار على الرسم البياني. وهناك شكل يمثل العنصر تظهر على قماش.

ملاحظة

إذا يرتبط نوع من العنصر المختار بالفعل مع الشكل، سيظهر الشكل المقابل على القماش. إذا، ومع ذلك، لا يوجد أي ارتباط تحديدا لهذا عنصر معين، وشكل الافتراضي (المستطيل) تظهر على القماش إلا إذا فرض رسم بياني وجهات النظر الخيار هو عليه في هذه الحالة لن يتم إضافة الشكل إلى الرسم التخطيطي.

تلميح

عندما يتم وضع عنصر على الرسم البياني التي يتم توصيلها إلى مكون آخر بالفعل على الرسم البياني، فإن أداة رسم الاستعلام إذا كنت ترغب في عرض الاتصال (ق) بينهما. أيضا، إذا كان هناك أي أبناء المكون سوف أداة رسم الاستعلام إذا كنت ترغب لتشمل الأطفال، بطريقة متكررة.

إلى إنشاء اتصال بين 2 مكونات أو المكونة الموصولة على الرسم البياني باستخدام موصل ديناميكي

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. يحوم أكثر من عنصر في المخطط الذي ترغب في الاتصال مكون آخر وستلاحظ 2 تظهر الرموز خارج العلوي الأيسر من حدود الشكل كما هو مبين أدناه. ملاحظة: رمز العلوي لإنشاء اتصال حيث العنصر حامت هو أن يكون مصدر، رمز القول هي لإنشاء اتصال حيث العنصر حامت هو أن يكون الحوض.

3. خطوة المؤشر فوق رمز والمطلوب إضغط و اسحبرمز إلى أكثر إما عبر فضاء آخر مكون أو مجانا على القماش كما هو موضح أدناه.

4. للاتصال عنصر القائمة اختر يرفق الى...عنصر في القائمة المنبثقة، وإذا تصفح المطلوبة إلى القائمة الفرعية للاختيار من بينها أنواع الاتصال المتاحة.

- أو -

4. إنشاء مكون متصل اختار من جديد...العناصر الموجودة في القائمة المنبثقة، وإذا تصفح المطلوبة إلى القائمة الفرعية للاختيار من بينها أنواع الاتصال المتاحة كما هو مبين أدناه. ابدأ الكتابةاسم العنصر الجديد في مربع الحوار وأي عناصر القائمة التي يقابل واقترح ويمكن اختيار بدلا من إضافة عنصر جديد إلى الهندسة المعمارية.

ملاحظة

ويخضع توافر العناصر في القائمة المنبثقة والقائمة الفرعية من قبل القيود في نموذج ميتا.هذا ليس سوى مصدر صالح أو تغرق أنواع المكونات على النحو الذي يحدده القيود اتصال ستعرض كما إرفاق إلى ... وبنود جديدة ... القائمة.

إلى إعادة فتح الحوار اختيار عنصر ووضع مكونات أو اتصالات من مستودع موجود على الرسم البياني

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. انقر ال فتح العنصر اختيارزر في شريط الأدوات رسم بياني. ملاحظة: الحوار اختيار عنصر ستفتح مع دولة مشاركة من أي مرشحات المحفوظة.

3. اختيار أي محتوى إضافي هذا هو المطلوب لتضاف إلى الرسم البياني وانقر حسنا. ملاحظة: سيتم إضافة محتوى جديد إلى مساحة واضحة على القماش والرسم يمكن أن يكون في وقت لاحق وضعت مرة أخرى عبر تخطيط رسم بيانيزر في شريط الأدوات رسم بياني.

باستخدام الحرةشكلالأشكال

غالبا ما يكون من المرغوب فيه إنشاء العناصر البصرية في رسم تخطيطي لأسباب جمالية بحتة. هذه العناصر قد تساعد على تحسين تخطيط ومظهر الرسم البياني، ولكن لم يكن لديهم أهمية المعمارية صارمة. أداة رسم يسمح باستخدام الأشكال حر لتوفير رسم المرونة.

لإضافة شكل حر لرسم تخطيطي

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. حدد الأشكال أو موصلاتالتبويب في إطار الاستنسل.

3. إضغط و اسحبواحدة من الأشكال المتاحة أو وصلات على قماش الرسم. سوف يظهر عنصر جديد على قماش - ولكن ليسفي شجرة المستكشف.

ملاحظة

الأشكال حر هي 'غير المصاحب' الأشكال، وليس لديهم ارتباط مع أي مكون أو الاتصال في نموذج معماري معين.

إلى عرض معلومات المخزون في شكل حرابنرسم تخطيطي

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. انقر بزر الماوس الأيمنشكل حر وحدد الشرح | عرض.

3. اختيار عرض إما اسم رسم بياني, رسم بياني الوصف, الرسم البياني الملكية, اسم جهة نظر أو اسم العمارة.

ملاحظة

والنص في شكل حر تلقائيا بتحديث مع تغير بيانات المخزون الأساسية.وبهذه الطريقة رسم تخطيطي "كتلة عنوان 'يمكن أن تنشأ عنه، ومن ثم نسخها بسهولة عبر والرسوم البيانية.

باستخدام الأشكال العائمة

الأشكال العائمة هي في الأساس وسيلة أخرى لتمثيل المكونات في رسم تخطيطي. النظر في التنظيم مع الانقسامات الرئيسية: CEO، التسويق، المبيعات والتنمية.

شجرة مشاهدة

قد تكون هذه الانقسامات ممثلة بصريا بطريقة الطبقات:

الطبقات مشاهدة

أو أنها قد تكون ممثلة بصريا في ترنحت / عائم طريقة لإظهار التسلسل الهرمي:

ترنحت / عائم عرض

يستخدم التمثيل الأخير مفهوم الأشكال العائمة.

لتحويل شكل عنصر الطبقات في شكل عائم

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. حدد مكونفي الرسم التخطيطي الذي تريده أن يمثل شكلا عائمة أو شكل المرتبطة في مكوناتعلامة التبويب إطار الاستنسل تريد كل الحالات كأشكال العائمة.

3. بزر الماوس الأيمن فوق الشكل وحدد تطفو مكون من قائمة السياق التي تظهر. لاحظ ترأس الماس اتصالمن مكون الوالد (الوالدين) إلى عنصر عائم (ق).

4. إضغط و اسحبالمكون إلى المكان المطلوب. عندما عائميتم تحديد العنصر سيكون له المخطط الأزرق.

لتحويل شكل عنصر عائم في شكل الطبقات

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. حدد مكونفي الرسم التخطيطي الذي يجري حاليا كما هو موضح في الشكل العائمة أو شكل المرتبطة في مكوناتعلامة التبويب إطار الاستنسل تريد كل الحالات كأشكال الطبقات.

3. إضغط و اسحبالمكون العائمة (ق) إلى الوالد (الوالدين) (وفقا لل ترأس الماس اتصال). ملاحظة: إذا كنت لا تفعل هذا ثم عند تحويل عنصر (ق) إلى أن الطبقات قد تتأثر التسلسل الهرمي للنموذج الخاص بك.

4. بزر الماوس الأيمن فوق الشكل وإلغاء تحديد تطفو مكون من قائمة السياق التي تظهر. لاحظ أن ترأس الماس اتصالمن والمكون الوالد (الوالدين) إلى عنصر عائم (ق) تختفي.

النسخ المتماثلة

أداة رسم يسمح لك ل إضافة نفس المكون إلى رسم تخطيطي عدة مرات مع كل حالة بصرية إضافية من المكون على الرسم البياني يشار إلى نسخة طبق الأصل. هذا هو مفيد خاصة للرسوم البيانية حيث عنصرا لديها عدد كبير من الاتصالات المرتبطة به وأنه من الأفضل لإظهار عنصر في مواقع متعددة أقرب إلى الأصل من كل من الاتصالات، أو الرسوم البيانية حيث علاقة واحد لكثير عنصر هو الأفضل لإظهار باستخدام ميزة العائمة (المذكورة أعلاه) مع عنصر في مواقع متعددة على رأس 'العديد' مكونات أنها مرتبطة.

ملاحظة

يمكنك إرفاق / فصل وصلات إلى / من مثيل الأصلي للعنصر على الرسم البياني (كما هو الحال دائما) ولكن أيضا إلى أي من النسخ المتماثلة، ولكن عندما يتم إضافة وصلات تلقائيا إلى رسم تخطيطي فإنها تعلق بها إلى المقام الأول للعنصر على الرسم البياني افتراضيا.

ملاحظة

يمكن دمج النسخ المتماثلة مع بعضها البعض من خلال انقر بزر الماوس الأيمن واسحباختيار ثم دمج النسخ طبق الأصلومع ذلك، دمج نسخة طبق الأصل مع مكون آخر سيؤدي في أي النسخ المتماثلة الأخرى تختفي من الرسم التخطيطي.

ملاحظة

لا يوجد فرق بين المرئي الأصلي مثيل مكون على الرسم البياني وأي النسخ المتماثلة. وعلاوة على ذلك، فإن القائمة بزر الماوس الأيمن فوق المكون الأصلي على الرسم البياني وأي النسخ المتماثلة متطابقة، مع مثلا عرض في مستكشفتأخذك إلى نفس المكون في عرض شجرة مستودع (الملقب نموذج). ومع ذلك، بزر الماوس الأيمن فوق عنصر في عرض شجرة من المستودع واختيار توجه إلىوالتصفح لرسم تخطيطي مع النسخ المتماثلة دائما يأخذك إلى 'أقدم' مثيل المكون على الرسم البياني. عادة سيكون هذا المثال الأصلي الذي تمت إضافته إلى الرسم التخطيطي ولكن إذا تم حذف هذا المثيل الأصلي في وقت لاحق أو دمجها مع نسخة طبق الأصل ثم الانتقال إلى سيقفز إلى أقدم من النسخ المتماثلة المتبقية التي تمت إضافتها.

إلى إضافة نسخة طبق الأصل ل رسم بياني

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. بزر الماوس الأيمن فوق عنصر موجود على الرسم البياني واختر إنشاء نسخة متماثلة.سيتم إنشاء نسخة طبق الأصل من العنصر المحدد إلى اليمين من العنصر الأصلي.

- أو -

حدد عنصر القائمة على رسم تخطيطي والصحافة CTRL + Cأو بزر الماوس الأيمن فوق عنصر موجود على الرسم البياني واختر نسخ. الآن بزر الماوس الأيمن فوق الموقع على الرسم البياني الذي تريد النسخة المتماثلة وحدد لصق كما المقلدة. ملاحظة: عند الضغط على Ctrl + V (أو النقر بزر الماوس الأيمن واختيار لصق) إنشاء نسخة من العنصر الأصلي NOT نسخة طبق الأصل.

- أو -

إضغط و اسحبمكون من مشاهدة شجرة مستودع (الملقب نموذج) على الرسم البياني حيث المكون موجود مسبقا.

تكوين اتصال قبعات / ينتهي

أداة رسم يسمح لك ل تعيين رمز المستخدمة في نهايات خطوط الاتصال إما إلى رمز ثابت أو رمز تعتمد على خاصية على اتصال نفسها.وهذا مفيد بشكل خاص للمخططات التي تتطلب اتجاه اتصال ليتم عرضها، أو الرسوم البيانية حيث يرد أصل من الاتصال (أو الاتجاه) في خاصية على اتصال نفسها، على سبيل المثال '، واحد لكثير' مقابل 'كثير لكثير "(أو" المصدر إلى بالوعة' مقابل 'بالوعة إلى مصدر').

إلى تكوين قبعات اتصال / ينتهي في رسم تخطيطي

1. تأكد من أن لديك الجديدة أو القائمة مخطط مفتوح.

2. حدد ربطالأيوناتالتبويب في إطار الاستنسل.

3. اليمين جلعق واحد من يرتبط أنواع الاتصال وحدد تكوين قبعات ....

4. للاتصال ثابت كاب / نهاية في أي مصدر أو يغرق نهاية الاتصال تأكد من صلة ثابت يتم تحديد زر ثم حدد رمز نهاية اتصال من المنسدلة، على سبيل المثال "رأس السهم" أو "الماس".

- أو -

لالقائم على الملكية اتصال كاب / نهاية في أي مصدر أو يغرق نهاية الاتصال تأكد من صلة باستخدام الملكيةيتم تحديد زر الراديو، ثم انقر على '...' زر وحدد الخاصية المطلوبة ثم بجانب كل رمز نهاية اتصال إدخال قيم الخصائص التي رمز اتصال معينة هي التي سيتم عرضها.

ملاحظة

قيم العقارات متعددة للاتصال نهاية رمز معين قد تكون دخلت مفصولة بفواصل.مثلا الحوار ادناه يبين أنه إذا كان "البيانات | أصل "الملكية يحتوي على قيمة" واحد لكثير "ثم في نهاية مصدر اتصال سوف يكون اثنين من خط السكتات الدماغية من خلال ذلك وسوف نهاية بالوعة للاتصال يكون السكتة الدماغية سطر واحد من خلال ذلك وبعد ذلك مروحة من كل اثنين خط السكتات الدماغية في نهاية المطاف.

تكوين قبعات الحوار

أنظر أيضا

أداة الرسم | يعيش سكان العمارة بك | تحليل العمارة بك


يعيش سكان العمارة بك

الملاحة: كثافات سكانية والعمارة الخاصة بك>

يعيش سكان العمارة بك

إرسال التعليقات حول هذا الموضوع.

ومن المعروف أن عملية بناء نموذج للعمارة ك ملء. مرة واحدة كنت قد اكتشفت العمارة الخاصة بك، وحددت الاحتياجات الخاصة بك، كنت على استعداد للنموذج العمارة بك في ABACUS.

أثناء السكان، عليك إدخال كافة التفاصيل تعرفه عن الهندسة المعمارية بك وما هو مطلوب منه.

لنشر العمارة الخاص

1. ضمان لديك ملف ABACUS مفتوحة ، وهو المستكشف عرض ، و وأضافت العمارة .

2. ملء يدويا مكونات عالية المستوى واتصالات للهندسة المعمارية الخاصة بك. وعادة ما تكون هذه المكونات واتصالات أكثر تجريدا.

- أو -

2. تعبئة بيانيا مكونات والاتصالات التي ترغب انظر تمثل بيانيا، وذلك باستخدام الرسم أداة .

قد تريد أيضا

3. تعبئة باستخدام الكتالوجات - يمكنك عرض و مكونات و الاتصالات بطريقة جداول بسيطة.

4. تعبئة باستخدام المصفوفات - يمكنك عرض وتحرير العلاقات بين المكونات بطريقة جداول بسيطة.

5. نشر من Microsoft Access - يمكنك استيراد الهندسة المعمارية من وتصدير ل مايكروسوفت أكسس.

6. نشر من برنامج Microsoft Visio - يمكنك استيراد الهندسة المعمارية من وتصدير ل برنامج Microsoft Visio.

7. نشر من مايكروسوفت إكسل - يمكنك استيراد الهندسة المعمارية من وتصدير ل مايكروسوفت اكسل.

8. نشر من مايكروسوفت شير - يمكنك استيراد الهندسة المعمارية من وتصدير ل مايكروسوفت SQL خادم.

9. نشر من Microsoft SQL Server - يمكنك استيراد بنية من Microsoft SQL Server.

10. الاستيراد من XML - يمكنك استيراد الهندسة المعمارية من شظية XML ABACUS أو ملف XML ArchiMate تبادل اللغة.

أنظر أيضا

يعيش سكان العمارة يدويا | أداة الرسم | يعيش سكان العمارة بك من Microsoft Access | يعيش سكان العمارة بك من برنامج Microsoft Visio | يعيش سكان العمارة من Microsoft إكسل


يعيش سكان العمارة بك من Microsoft Access

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية من منتجات Microsoft>

يعيش سكان العمارة بك من Microsoft Access

إرسال التعليقات حول هذا الموضوع.

يمكنك تصدير العمارة بك إلى Microsoft Access لأداء أغراض العامة الحسابات، التلاعب أو تقارير عن الهندسة المعمارية الخاصة بك. يمكنك بعد ذلك استيراد العمارة مرة أخرى إلى ABACUS.

ملاحظة

يتطلب فتح من الوصول / تصدير إلى قاعدة بيانات ميزة مايكروسوفت أكسس 2000أو تثبيت أحدث على الكمبيوتر.

لتصدير العمارة بك إلى Microsoft Access

1. ضمان لديك ملف ABACUS افتح ال المستكشفعرض، و هندسة معماريةوأضاف.

2. حدد ملف | تصدير | إلى قاعدة بيانات.

3. يحيط علما حوار تحذير كما هو موضح أعلاه ثم انقر فوق نعم للمتابعة.

4. تحديد موقع واسم ملف قاعدة البيانات.

لاستيراد العمارة التلاعب في ABACUS

1. ضمان لديك ABACUS مفتوحة.

2. حدد ملف | جديد وحدد من Accessمن مربع الحوار الذي يظهر ثم انقر فوق موافق.

3. تصفح لملف قاعدة البيانات التي ترغب في استيرادها.

ABACUS "MS الوصول مخطط قاعدة البيانات

يوجد ABACUS في قلب لهان الأنطولوجيا / التلوي التلوي نموذج مكون من مكونات، اتصالات والقيود. وقد اشتق هذا النهج "CCC" من النهج القياسية مختلف تطويرها من عام 1960 وبلغت ذروتها فصاعدا في معيار IEEE الدولي 1471، والذي ساهم المؤسسون Avolution ل. تنطبق الأوليات التالية:

1. ABACUS يحتوي المكتبات من المعايير(أو معايير), مكونو أنواع الاتصال, القيود, وجهات النظر, النماذج (أو أنماط) و كثير أبنية.

2. المعايير, أنواعو وجهات النظر قديكون منطقيا مجمعة للراحة.

3. أبنية يمكن أن يحتويالعديد من نسل أبنية(أو التطورات).

4. كل هندسة معمارية يحتويكثير مكوناتو روابطمن المؤكد أنواعومختلف عدد المشاهدات.

5. مكوناتو روابطيمكن أن يكون فاسد إلى مكونات فرعيةو اتصالات الفرعية.

6. كل مكونغير تعلقأي عدد من روابطولكن كل الاتصاليمكن أن يكون فقط تعلقبحد أقصى اثنين مكونات.

7. مكوناتو روابط تستطيع لديك المعايير مع الممتلكاتمثل المعلومات والأداء والاعتمادية، والتكلفة الخ

8. أبنية, مكوناتو روابط تستطيع لديك محددة الممتلكاتمثل المعلومات والأداء والاعتمادية، والتكلفة الخ

9. القيود تستطيع توجد بين مكونات أو روابط أو ضد الممتلكات.

10. النماذجهي التراكيب القياسية مكونو أنواع الاتصال.

11. وجهات النظرهي جمعيات القياسية مكونو أنواع الاتصالإلى الملاحظات.

12. عدد المشاهداتهي تمثيلات بصرية مكوناتو روابط.

وMS الوصول الكيان التالية مخطط العلاقة (ERD) يوثق النواةأبنية، التطورات، أنواع عنصر / اتصال (والمجموعات)، مكونات / اتصالات والفرعية المفاهيم مكون / اتصال.

قاعدة بيانات مخطط الأساسية

ملاحظة

لم يتم فرض التكامل المرجعي على العلاقة بين الجدول مكونات والجدول اتصالات (ل 'المرفق' بين مصدر معين أو بالوعة مكون واتصال). وذلك لأن اتصال يمكن أن توجد بدون مرفقات المكون. نحن يمكن أن يضاف إلى جدول "مرفق" ولكن لمصلحة من البساطة قرر ضد ذلك. بالطبع هذا يعني أن أي تحرير للمكون معرفات أو حذف الصفوف مكون كل ذلك معا سيؤدي إلى بيانات غير صحيحة. سوف ABACUS التعامل مع أي عدم صحة على الواردات من خلال تجاهل بيانات غير صحيحة.

وفيما يلي MS الوصول ERD يوثق الممتلكاتمفاهيم لتصميمات، أنواع المكونات / اتصال ومكوناتها / اتصالات.

قاعدة بيانات خصائص المخطط

وفيما يلي MS الوصول ERD يوثق المعاييرمفهوم البنى، أنواع المكونات / اتصال ومكوناتها / اتصالات.ملاحظة: الجداول لا تزال تستخدم مصطلح "التنفيذ" وفقا الإصدارات السابقة من ABACUS.

المعايير مخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق القيودمفهوم للمكون أنواع / اتصال.

القيودمخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق وجهات النظر مفهوم ل أبنية.ملاحظة: الجداول لا تزال تستخدم مصطلح "TwoDTempl 'كما في الإصدارات السابقة من ABACUS.

وجهات النظرمخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق الكتالوجاتمفهوم ل أبنية.

الكتالوجاتمخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق المصفوفاتمفهوم ل أبنية.

المصفوفاتمخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق الرسوم البيانيةمفهوم ل أبنية.ملاحظة: الجداول لا تزال تستخدم مصطلح "TwoD 'كما في الإصدارات السابقة من ABACUS.

ملاحظة

نوع مكون / اتصال لالاستنسل رسم الخرائط شكل وشكل أجزاء FREEFORM من MS الوصول ERD قد حذفت من أجل الوضوح.

الرسوم البيانيةمخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق 3D المشاهداتمفهوم ل أبنية.

3D المشاهداتمخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق الرسوم البيانيةمفهوم ل أبنية.

الرسوم البيانيةمخطط قاعدة البيانات

وفيما يلي MS الوصول ERD يوثق لوحات مفهوم.

لوحاتمخطط قاعدة البيانات

ABACUS "MS الوصول الاستفسارات

وشملت مع قاعدة البيانات MS الوصول العديد من الاستفسارات مفيدة على النحو التالي؛

· كومبس من قبل الدعائم- هذا الاستعلام يسرد كافة المكونات في المشروع (من العمارة والنوع) ويشمل جميع الخصائص كما الأعمدة. استخدام هذا الاستعلام مع مرشحات / المقاييس على نوع عنصر و / أو الهندسة المعمارية لإنتاج جداول "نموذجية" لكل نوع المكون مع ممتلكاتهم.

· الأمراض المنقولة جنسيا عن طريق الدعائم- يسرد هذا الاستعلام عن المعايير التي يتم استخدامها، وعدد من تواجدات معيار ويشمل جميع الخصائص كما الأعمدة. استخدام هذا الاستعلام كما نشرة معايير.

· الدعائم التي كتبها أنواع- يسرد هذا الاستعلام عن خصائص المكونات و٪ التامة لهم من قبل كل نوع المكون كأعمدة. استخدام هذا الاستعلام لتحديد ما إذا كانت خصائص معينة يتم الحفاظ عليها.

· أنواع كتبها الدعائم- يسرد هذا الاستعلام عن أنواع عنصر ويتضمن٪ كاملة من كافة الخصائص كأعمدة. استخدام هذا الاستعلام لتحديد ما إذا كانت خصائص معينة يتم الحفاظ عليها.

· نوع عدد- يسرد هذا الاستعلام عن أنواع عنصر ويتضمن عدد من الحوادث من كل نوع في ترتيب تنازلي. استخدام هذا الاستعلام لتحديد شعبية من كل نوع في المشروع.

ملاحظة على العمل مع حقول المذكرة في MS Access

يتم تعريف مكونات، اتصالات والحقول اسم المعايير في الجداول كحقول مذكرة للسماح لعدد غير محدود من الشخصيات، وفقا ABACUS. لمكونات الاتصال وهذا يسبب بعض القضايا لأن لديهم أيضا حقل معرف فريد للمرجع، ولكن لمعايير هذا يسبب بعض المشاكل عند محاولة ربط الجداول لأنك لا تستطيع أن تنضم حقول المذكرة في MS Access. بدلا من ذلك، يمكنك تعيين أين معايير شرط لتحقيق التأثير نفسه كما هو مبين في منشئ الاستعلام البصرية وقصاصات SQL المقابلة دون أن قائمة من جميع المعايير الموروثة خصائص كل مكونات في المشروع ABACUS تصديرها.

حقل المذكرة "ينضم" في منشئ الاستعلام البصرية

اختر Components.Architecture_Id، Components.Id، Components.Name، ComponentImplementationLinks.Name، ImplementationProperties.Type، ImplementationProperties.Name، ImplementationProperties.Value، ImplementationProperties.Unit

من المكونات الداخلية الانضمام ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) AND (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id)، تطبيقات INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

WHERE (((ComponentImplementationLinks.Name) = [تطبيقات] [اسم]))؛

حقل المذكرة "ينضم" في SQL

ملاحظة على توليد تلقائيا معرفات ABACUS في MS Access

مختلف الجداول ABACUS MS الوصول تتطلب فريد ID صحيح طويل حتى يتم توفير وسيلة VB بسيط للمساعدة في توليد هذه. يتم توفير طريقتين ResetCounter () وGetNextCounter () داخل ABACUS "MS الوصول DB واستخدامها على النحو التالي؛ ResetCounter () سيتم تعيين العداد إلى 0. GetNextCounter () سيعود العداد التالية في التسلسل.

طرق استغلال والوصول MS "هوس" أنه حتى لو كنت استدعاء الأسلوب ResetCounter () لإدراج كل صف (أي عند أيضا تشغيل وظيفة GetNextCounter ()) لأن وظيفة ResetCounter () ليس لديها أية معلمات تشغيله فقط مرة واحدة، وبالتالي لا إعادة تعيين العداد لكل إدراج صف واحد. وأيضا بسبب نفس "نزوة" لديك لتمرير أي متغير العمود القديم إلى وظيفة GetNextCounter () لخداع عليه في تشغيل كل مرة.

وهناك أيضا حيلة لتكون قادرة على تشغيل وظيفة ResetCounter () في إدراج في بيان SQL لأنك غير قادر على مجرد أنها قد يجلس هناك كعمود من تلقاء نفسها، مثل إذا كان استعلام تحديد. فمن المستحسن لجعل ResetCounter () دعوة جزء واحد من الحقول الأخرى بواسطة وصل إلى النهاية، لأنه يعود دائما لاغيا أي حال.

وفيما يلي استخدام SQL نموذجية من الطرق لإضافة قائمة من أنواع مكون من جدول / استعلام يسمى 'مكون قائمة النوع.

INSERT INTOComponentTypes (هوية والاسم والوصف)

SELECT GetNextCounter ([مكون قائمة نوع] .name)AS إيد، [مكون قائمة نوع] .name AS الاسم، [مكون النوع قائمة]. الوصف و ResetCounter ()AS الوصف

من عند[مكون النوع قائمة]؛

ABACUS ID جيل / عداد في SQL

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | يعيش سكان العمارة بك من برنامج Visio | يعيش سكان العمارة بك من إكسل


يعيش سكان العمارة من Microsoft إكسل

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية من منتجات Microsoft>

يعيش سكان العمارة من Microsoft إكسل

إرسال التعليقات حول هذا الموضوع.

يمكنك استيراد العمارة بك من جداول البيانات إكسل (. XLS أو. XLSX ملف). المستورد اكسل يسمح لك خريطة قوائم مكون واتصالات مع أنواع والمعايير والخصائص والخصائص القياسية عن طريق اختيار الأعمدة في جدول البيانات التي تحتوي على البيانات ذات الصلة.غير أنه من تقنية أكثر تقدما من النهج الموصى بهلاستيراد من مايكروسوفت إكسل الذي هو عن طريق كتالوجات كما وصفت هنا .

ملاحظة

يتطلب استيراد من / تصدير إلى Excel ميزة مايكروسوفت اكسل 2003أو تثبيت أحدث على الكمبيوتر.

وتتمثل المهمة الرئيسية للمستورد إكسل هو السماح لك لتحديد ملف التكوين (أي بنية هرمية من طراز المعماري الخاص بك). مخازن ملف التكوين تعيين المحفوظة مسبقا من ملف Excel إلى ملف ABACUS. مرة واحدة محددة، يتم استخدام ملف التكوين المحفوظ في وقت لاحق لمواصلة استيراد والتصدير إلى ملفات. XLS.

ملاحظة

الخطوات الموضحة في الأقسام أدناه خصيصا للمستخدمين الذين لديهم حتى الآن لتحديد وحفظ ملف التكوين والاستيراد من التفوق للمرة الأولى. يجب إنشاء وحفظ ملف تكوين لاستخدام التصدير إلى التفوق وظيفة.

لاستيراد جدول بيانات Excel إلى ABACUS

1. ضمان لديك ABACUS مفتوحة.

2. حدد ملف | جديد واختر من تفوقمن مربع الحوار الذي يظهر ثم انقر فوق موافق.

ملاحظة

إذا كنت ترغب في استيراد إلى مشروع ABACUS القائمة ثم إما بزر الماوس الأيمن فوق العقدة مكونات داخل العمارة، أو بزر الماوس الأيمن فوق عنصر فردي داخل العمارة ثم حدد استيراد | من اكسل.

3. ال استيراد جداول اكسلسيتم عرض نافذة

استيراد جداول اكسل النافذة

4. انقر على فتح ملف إكسلالرمز وتصفح عن ملف Excel كنت ترغب في استيرادها.

5. اختر ال ورقة عملكنت ترغب في استيراد من مربع القائمة المنسدلة.

ملاحظة

بعد فتح ملف Excel، يمكنك استخدام معاينة البياناتالتبويب لعرض الأعمدة والصفوف 25 الأولى من جدول البيانات. من هنا يمكنك الحصول على أرقام العمود اللازمة لملء مكوناتو روابطعلامة التبويب.

يمكنك أيضا تحديد ما إذا كنت تريد عناصر في جدول بيانات Excel التي سيتم استيرادها مع حساسية القضية. ببساطة وضع علامة في الاستيراد مع حساسية القضيةالخيار (افتراضيا هو علامة هذا دائما) وسيتم استيراد جدول البيانات وفقا لذلك.

عينة ملف إكسل

ملاحظة

في هذا المثال سنقوم باستيراد البنية التحتية بسيطة والناس الهندسة المعمارية من البيانات إكسل هو مبين في الصورة أعلاه. سيتم إجراء اتصالات بين "المسؤولين" و "خوادم" أن هؤلاء الناس إدارته.

لنشر علامة التبويب مكونات

هذا القسم هو لتحديد أنواع المكونة والهيكل الهرمي لملف التكوين.

1. حدد مكوناتعلامة التبويب. إعادة تسمية مجموعة IDعن طريق تجاوز (لا شيء) القيمة

ملاحظة

هذه الميزة تسمح لك لتحديد مختلف تماما مجموعاتلمكونات منفصلة وظيفيا. كما هو مبين في الصورة أدناه، قد ترغب في التمييز بين مكونات البنية التحتية الخاصة بك من مكونات الشعب بك. إذا كانت هناك علاقات (اتصالات) بين هذه المجموعات منفصلة من المكونات، التي يمكن تعريفها تحت روابطعلامة التبويب. في وقت لاحق في هذا المثال سنقوم تعريف اتصالات من نوع "تدير" بين البنية التحتية والناس مجموعات.

يمكنك أيضا تحديد ما إذا كنت ترغب في إضافة المستوى الأعلى تجمعالمكون لجميع عناصر المجموعة. ببساطة وضع علامة في المجموعة تحت تعيين معرفالخيار (افتراضيا هذا هو unticked) وسيتم استيراد جدول البيانات وفقا لذلك.

تعيين مجموعة ID

2. مرة واحدة في مجموعاتوقد تم تحديد حدد مجموعةتريد نشر وتوسيع بالضغط على [+] لافته.

3. اختار مستويات مكونات في هذه المجموعةمن القائمة الموسعة.

4. ال عنصر التسلسل الهرمي للمجموعات: مجموعة IDسوف تظهر نافذة لذلك مجموعة.

عنصر التسلسل الهرمي والقيم تعيين (مجموعة ID: البنية التحتية)

5. إعادة تسمية عدد الصعيدالعمود عن طريق تجاوز (لا شيء) القيمة.

ملاحظة

ال عدد الصعيدالعمود يسمح لك لتعيين التسلسل الهرمي إلى المكونات الخاصة بك. كل مستوى يتوافق مع طبقة داخل العمارة الخاصة بك حيث المستوى الأول هو أعلى أكثر الأم مستوى. على سبيل المثال، عدد مستوى "1" يتوافق مع أعلى طبقة الهرمية، عدد مستوى "2" هو الطفل من مستوى الرقم "1"، وهلم جرا.

6. اختيار وتعيين العمود ذات الصلة من جداول البيانات إكسل على كل عدد الصعيدقبل دخوله تحت عمود مكون عمود.

ملاحظة

يمكنك اختيار لاستبعاد بعض الصفوف التي كنت لا تريد أن تكون ممثلة في الهندسة المعمارية الخاصة بك. قد تكون هذه رؤوس الأعمدة أو الصفوف الفارغة، وما إلى ذلك لاستبعاد الصفوف استخدام الصفوف استثناء:مربع النص بالقرب من أعلى الزاوية اليمنى من النافذة. في هذا المثال قمنا استبعاد الصف 1 لأنه يحتوي على رؤوس الأعمدة لدينا.

7. يمكنك اختيار لإضافة وصف لمكونات الخاص بك عن طريق الكتابة فوق (لا شيء)القيمة في وصف العمود.

ملاحظة

هذا الوصف هو ما سوف يظهر في ABACUS تحت خصائص عامةالقسم | الوصف حقل، مجال.

8. إذا عمود جدول معين لديه أكثر من عنصر واحد في كل خلية (إدخالها باستخدام-أدخل البديل أو CHAR (10) الأوامر) ثم وضع علامة في مربع تحت علاج خطوط جديدة ومكونات منفصلة. سيتم استيراد كل سطر كمكونات منفصلة.

تلميح

استيراد "مصفوفة" من مجموعة من الأعمدة، حيث من 'X' في خلية "المصفوفة" معين (الخلايا B2: D2 أقول) يعني أن العنصر المحدد من قبل صف (في الخلية A2 يقول) متصلة المكون التي يحددها عمود "العنوان" (في الصف 1 مثلا)، صيغة بسيطة يمكن استخدامها. أدخل الصيغة التالية لكل صف في عمود خارج خلايا المصفوفة (العمود F القول)؛ = IF (B2 = ""، ""، B 1 $ & CHAR (10)) وIF (C2 = ""، ""، C $ 1 & CHAR (10)) وIF (D2 = ""، ""، D 1 $ & CHAR (10)). ثم انشاء مجموعة الاتصال كما هو موضح أدناه بين المكونات التي يحددها صف (في العمود A أقول) وتلك التي وصفها هذه الصيغة (في العمود F يقول). مما لا شك فيه للتحقق من علاج خطوط جديدة ومكونات منفصلةالخيار عندما يتم استيراد المكونات من الصيغة. لأكثر تقدما استيراد مصفوفة، بما في ذلك عناوين مع طبقات متعددة من التسلسل الهرمي أو الخلايا مع اختلاف القيم من مجرد 'X' عادي، يرجى الاتصال دعم Avolution .

9. ملء بقية الأعمدة حسب الحاجة.

ملاحظة

يمكنك اختيار الحصول على نوع من الصفوف العمود بوضع علامة في مربع تحت الحصول على نوع من العمودعمود والدخول العمود ذات الصلة من جداول البيانات إكسل تحت العنصر نوع القيمة أو العمود عمود. هذا وسوف استيراد جميع المكونات في هذا العمود ومجموعة منهم لنوع المعرفة في العمود. بدلا من ذلك، وكما هو الحال مع لقطة الشاشة أعلاه وأدناه، يمكنك اختيار لاستخدام / محدد مسبقا اسم نوع ثابت عن طريق إدخال اسم نوع تحت العنصر نوع القيمة أو العمودعمود والتأكد من مربع الاختيار الامم المتحدة وفحصها.

عنصر التسلسل الهرمي والقيم تعيين (مجموعة ID: الناس)

ملاحظة

في هذا المثال أردنا أن يكون شبكاتنا والناس التجمعات في المستوى 1 من العمارة. على المستوى 2 نود أن يكون خدمتنا والشعب المسؤولة عن إدارة هذه الخوادم. ال مكوناتوقد شغل في التبويب وفقا لذلك، كما هو مبين في اثنين من لقطات أعلاه. في الصورة الأولى أعلاه حددنا مستوى 1 (تجمع الشبكة) ومستوى 2 (الخادم) مكونات البنية التحتية مجموعة. وفي لقطة مباشرة فوق حددنا مستوى 1 (الناس التجمع) ومستوى 2 (الناس المسؤولة) مكونات الشعب مجموعة.

بدلا من ذلك، ل الناسمجموعة، بدلا من استخدام العمود C كتجمع الناس، ونحن يمكن أن تستخدم ل المجموعة تحت تعيين معرفالخيار في أعلى علامة التبويب مكونات مستوى ومن ثم دخلت للتو واحدة الناس المستوى الفرعي من العمود D. هذا هو مبين في الصورة ادناه.

عنصر التسلسل الهرمي وتعيين القيم باستخدام الخيار المجموعة تحت تعيين معرف (ID مجموعة: الناس)

10. مرة واحدة وقد تم التعرف على المكونات، حدد مستوى المكون الذي تريد تجميع الخصائص و / أو معايير وتوسيع بالضغط على [+] لافته.

11. اختار خصائص مكونات في هذا المستوىأو معايير مكون في هذا المستوىمن القائمة الموسعة وتعبئة الأعمدة ذات الصلة حسب الحاجة.

مكونات ملء

ملاحظة

خصائص مكونات في هذا المستوىيسمح لك لتحديد خصائص المكونات على المستوى الذي تم اختياره. معايير مكون في هذا المستوىيسمح لك لتحديد المعايير وممتلكاتهم القياسية لعناصر على المستوى الذي تم اختياره.

12. كرر الخطوات 2-11حتى تم ملؤها جميع المستويات المكونة لجميع محددة مجموعات. استخدم السهم إلى الخلف بالقرب من أعلى الزاوية اليمنى من النافذة لتنقل إلى مجموعاتالذي قمت بتعريفه في وقت سابق.

لنشر علامة التبويب اتصالات

هذا القسم هو لتحديد أنواع الاتصال والهيكل الهرمي لملف التكوين.

1. حدد روابطعلامة التبويب. لكل مجموعة من الاتصالات لديك لتحديد عنصر مجموعةأن كنت تريد أن تكون مكونات المصدر والمكونات مجموعةكنت تريد أن تكون مكونات الوجهة.

2. تحت مصدر مكون ID مجموعة دخول مجموعةالاسم الذي يتوافق مع مجموعةالمعرفة في وقت سابق مكوناتعلامة التبويب. تحت مصدر العنصر عدد مستوىأدخل رقم المقابلة لمستوى المكون الذي ترغب في الاتصال في نهاية مصدر الاتصال.

3. الآن اختيار أي مكون مجموعة سيكون في نهاية جهة الاتصال. تحت المقصد مكون ID مجموعة دخول مجموعةالاسم الذي يتوافق مع مجموعةالمعرفة في مكوناتعلامة التبويب. تحت جهة العنصر عدد مستوىأدخل رقم المقابلة لمستوى المكون الذي ترغب في الاتصال في نهاية جهة الاتصال.

ملاحظة

في هذا المثال نود أن ربط الأشخاص المسؤولين عن إدارة الخوادم إلى خوادم يقومون بإدارته. وتم تحديد الأشخاص المسؤولين في مجلس الشعب مجموعةكما تم تحديد مستوى 2 مكونات بينما الملقمات في البنية التحتية مجموعةعن مستوى 2 المكونات. ال روابطوقد شغل في التبويب وفقا لذلك، كما هو مبين في الصورة أدناه.

اتصالات تبويب الجزء 1 من 2

4. إذا كنت انتقل إلى الحق، وسوف تجد خيارات إضافية لاستيراد الاتصالات الخاصة بك. الحصول على نوع من العمودو اتصال نوع القيمة أو العمودتعمل بنفس الطريقة بالنسبة لل مكوناتعلامة التبويب.

5. إذا كان مصدر مكون ID مجموعة و ال مصدر العنصر عدد مستوىهي نفس المقصد مكون ID مجموعة و ال جهة العنصر عدد مستوى(على سبيل المثال إذا كنت متصلا أنواع عنصر نفسها، مثل إجراء اتصالات من الخوادم إلى خوادم أخرى) ثم تحتاج إلى أن يكون عمود آخر في جدول البيانات الذي يحتوي على أسماء هذه الخوادم المتكررة. في هذه الحالة هل وضع هذا العمود في جدول جهة تتكرر في العمود عمود. إذا كان في هذا العمود جدول قمت بإدخال أكثر من عنصر واحد متصل لكل خلية ثم وضع علامة في مربع تحت علاج خطوط جديدة ومكونات منفصلة.

اتصالات تبويب الجزء 2 من 2

6. مرة واحدة وقد تم تحديد الاتصالات حدد الاتصال الذي تريد تجميع الخصائص و / أو معايير وتوسيع بالضغط على [+] لافته.

7. اختار خصائص هذه الاتصالات أو معايير لهذه الاتصالاتمن القائمة الموسعة وتعبئة الأعمدة ذات الصلة حسب الحاجة.

ملاحظة

خصائص هذه الاتصالاتيسمح لك لتحديد خصائص مجموعة الاتصال الذي تم اختياره. معايير لهذه الاتصالاتيسمح لك لتحديد المعايير وممتلكاتهم قياسية لمجموعة الاتصال الذي تم اختياره.

8. كرر الخطوات 2-7حتى يتم تعريف جميع المجموعات الصدد.

9. عند الانتهاء من تحديد مجموعة اتصال، انقر على إنهاءسيتم إنشاء زر والهندسة المعمارية من ملف إكسل المستوردة. في المثال أعلاه سيؤدي في العمارة هو موضح في الصورة ادناه.

العمارة عينة مستوردة من إكسل

10. الآن حفظ التكوين تعيينها إلى ملف بالضغط على حفظ التكوين رمز. التكوين المحفوظة يمكن استرجاعها في وقت لاحق من خلال النقر على فتح تكوينرمز بالقرب من أعلى الزاوية اليسرى من النافذة.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | يعيش سكان العمارة من الدخول | يعيش سكان العمارة بك من برنامج Visio


يعيش سكان العمارة بك من مايكروسوفت شير

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية من منتجات Microsoft>

يعيش سكان العمارة بك من مايكروسوفت شير

إرسال التعليقات حول هذا الموضوع.

انت تستطيع تزامن العمارة بك مع مايكروسوفت قوائم SharePoint. ينطوي التزامن إما إنشاء قوائم SharePoint جديدة (وأعمدتها) من ABACUS أنواعها، خصائصها والمرفقات، أو تعيين قوائم SharePoint القائمة (وأعمدتها) إلى ABACUS أنواعها، خصائصها والمرفقات، ثم إما إرسال المحتوى من ABACUS إلى SharePoint أو SharePoint لABACUS.

ملاحظة

ال شير مزامنة تتطلب الميزة التي ا مايكروسوفت شير 2010، 2013 أو شير اون لاين الموقع متاح للاتصال ومزامنة مع.في حين أن ميزة شير مزامنة يمكن إنشاء قوائم (مع الأعمدة) على موقع SharePoint من أي مشروع ABACUS، يمكن Avolution أيضا توفير مختلف قوالب موقع SharePoint لدعم الأطر القياسية (على سبيل المثال TOGAF، ArchiMate، ITIL الخ) لذا يرجى الاتصال دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

إلى إنشاء قائمة SharePoint جديدة وتعيين ذلك إلى ABACUS مكون أو نوع الاتصال

1. ضمان لديك ABACUS مفتوحة.

2. اختار أدوات | شير مزامنة.

3. انقر على تعيين جديدزر والحوار الخرائط شير كما هو مبين أدناه سوف تظهر.

4. أدخل URL الموقع، اسم المستخدم وكلمة للموقع SharePoint وانقر ربط.

ملاحظة

A صالح شير 'مشرف' أو مطلوب حساب "المساهم" لمزامنة من وإلى SharePoint وحساب "القارئ" سيتم السماح فقط متزامنة من SharePoint.

5. حدد ABACUS مكون أو نوع الاتصال لتعيين من حدد نوع اسحب للأسفل.

6. انقر على اضف جديدزر وبعد ذلك لكل ABACUS مكون أو نوع الاتصال الجانب الذي ترغب في تعيينه إلى المقابلة حقل قائمة SharePoint تحديد عنصر في اللوحة اليسرى وفي اللوحة اليمنى إدخال الجديد اسم قائمة SharePoint في العمود قائمة جديدة (فقط في المرة الأولى) ، ثم اسم العمود شير في اسم العمود (أو استخدام الافتراضي) وانقر عين كل مرة.

ملاحظة

كحد أدنى للسماح سيتم تعيين تزامن ABACUS EEID، الهندسة المعمارية، والجوانب اسم تلقائيا إلى عدد SharePoint و اثنين (2) خط واحد من النص (ويعرف أيضا باسم النص) الأعمدة على التوالي. هذه لا يمكن أن يكون غير معين. وعلاوة على ذلك، يمكن في الوقت الراهن سوى بعض الجوانب ABACUS يتم تعيينها إلى الأعمدة شير معينة، وسيتم تعيين نوع العمود المنسدلة تلقائيا إلى المطلوب شير نوع العمود.وهي:

· ABACUS 'مسار التسلسل الهرمي إلى SharePoint خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة (ملاحظة: شير سطر واحد من النص (ويعرف أيضا باسم النص) الأعمدة تدعم فقط 255 حرف بحيث لا تكون مفضل)،

· ABACUS "مكونات تعلق على أعمدة بحث في SharePoint (ملاحظة: يجب أن يكون موجودا بالفعل رسم الخرائط لقائمة للمكونات أنفسهم المرفقة)،

· نص ووصف خصائص ABACUS "إلى SharePoint خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة (ملاحظة: شير سطر واحد من النص (ويعرف أيضا باسم النص) الأعمدة تدعم فقط 255 حرف بحيث لا تكون مفضل)،

· ABACUS 'عشري أو عدد صحيح الخصائص إلى أعمدة شير رقم،

· ABACUS "قائمة الخصائص إلى أعمدة شير اختيار (ملاحظة: شير لا تفرض القيم الاختيار بحيث لا يحتاج نوع قائمة البيانات التي سيتم تنفيذها في ABACUS)،

· ABACUS التاريخ / خصائص الوقت إلى SharePoint خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة (ملاحظة: شير التاريخ والأعمدة الوقت لا يمكن أن تستخدم حتى الآن بسبب دعم شير وغير متناسقة لتوقيت / الإعدادات الإقليمية)،

· ABACUS "خصائص منطقية إلى SharePoint نعم / لا (ويعرف أيضا باسم منطقية) الأعمدة.

المعايير المرتبطة عنصر ABACUS لا يمكن تعيينها إلى الأعمدة قائمة SharePoint حتى الآن.

7. اختار إنشاء الخرائط.

إلى إنشاء تعيين جديد بين عنصر ABACUS أو نوع الاتصال وقائمة SharePoint القائمة

1. ضمان لديك ABACUS مفتوحة.

2. اختار أدوات | شير مزامنة.

3. انقر على تعيين جديدزر والحوار الخرائط شير كما هو مبين أدناه سوف تظهر.

4. أدخل URL الموقع، اسم المستخدم وكلمة للموقع SharePoint وانقر ربط.

ملاحظة

A صالح شير 'مشرف' أو مطلوب حساب "المساهم" لمزامنة من وإلى SharePoint وحساب "القارئ" سيتم السماح فقط متزامنة من SharePoint.

5. حدد ABACUS مكون أو نوع الاتصال لتعيين من حدد نوع اسحب للأسفل.

6. حدد قائمة موقع SharePoint لتعيين من اختر قائمة اسحب للأسفل.

7. لكل ABACUS مكون أو نوع الاتصال الجوانب التي ترغب في تعيين لائحة المقابلة شير عموده تحديد عنصر في اللوحة اليسرى واليمنى على التوالي، وفريق انقر عين.

ملاحظة

كحد أدنى للسماح تزامن ABACUS EEID، الهندسة المعمارية، والجوانب اسم تحتاج ليتم تعيينها إلى رقم شير ثم للعمارة واسم إما سطر واحد من النص (الملقب نص) أو خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة على التوالي. حتى أن يتم ذلك على زر تعيين اصنع لن يكون ممكنا. وعلاوة على ذلك، يمكن في الوقت الراهن سوى بعض الجوانب ABACUS يتم تعيينها إلى الأعمدة شير معينة.وهي:

· الجانب ABACUS "العمارة إلى شير سطر واحد من النص (الملقب نص) أو خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة (هذا مطلوب لرسم خرائط محددة المحتوى كما هو موضح أدناه)،

· ABACUS 'مسار التسلسل الهرمي إلى SharePoint سطر واحد من النص (الملقب نص) أو خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة (ملاحظة: شير سطر واحد من النص (ويعرف أيضا باسم النص) الأعمدة تدعم فقط 255 حرف سيتم اقتطاع ذلك أي أحرف إضافية وبالتالي فمن المستحسن لتحويلها إلى خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة في SharePoint قبل التعيين)،

· ABACUS "مكونات تعلق على أعمدة بحث في SharePoint (ملاحظة: يجب أن يكون موجودا بالفعل رسم الخرائط لقائمة للمكونات أنفسهم المرفقة)،

· نص ووصف خصائص ABACUS "إلى SharePoint سطر واحد من النص (الملقب نص) أو خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة (ملاحظة: شير سطر واحد من النص (ويعرف أيضا باسم النص) الأعمدة تدعم فقط 255 حرف سيتم اقتطاع ذلك أي أحرف إضافية وبالتالي فمن المستحسن لتحويلها إلى خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة في SharePoint قبل التعيين)،

· ABACUS 'عشري أو عدد صحيح الخصائص إلى SharePoint عدد الأعمدة (ملاحظة: أعمدة شير محسوبة يمكن أن تستخدم إلا أنها سوف تكون فقط قادرة على متزامنة من SharePoint لABACUS محاولة مزامنة "إلى" عمود محسوب سيؤدي إلى تحذير وفقا أدناه) ،

· ABACUS "قائمة الخصائص إلى أعمدة شير الاختيار،

· ABACUS التاريخ / خصائص الوقت إلى SharePoint خطوط متعددة من النص (ويعرف أيضا باسم ملاحظة) الأعمدة (ملاحظة: شير التاريخ والأعمدة الوقت لا يمكن استخدام بسبب دعم شير وغير متناسقة لتوقيت / الإعدادات الإقليمية)،

· ABACUS "خصائص منطقية إلى SharePoint نعم / لا (ويعرف أيضا باسم منطقية) الأعمدة.

المعايير المرتبطة عنصر ABACUS لا يمكن تعيينها إلى الأعمدة قائمة SharePoint حتى الآن. والعملات شير، والشخص أو المجموعة، ارتباط تشعبي أو صورة، نتائج مهمة، بيانات خارجية وأعمدة الفوقية المدارة لا يمكن تعيينها إلى الجوانب ABACUS حتى الآن.

8. اختار إنشاء الخرائط.

إلى تزامنMicrosoft الخاص بك قائمة SharePoint (ق)إلى ABACUS

1. ضمان لديك ABACUS مفتوحة.

2. اختار أدوات | شير مزامنة.

ملاحظة

إلى مزامنة قائمة SharePoint معمشروع ABACUS يحتاج ترخيص المستخدم شير مزامنةإضافة على القدرة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

3. حدد رسم الخرائط SharePoint موجودة (أو تعيينات باستخدام اضغط مفتاح Ctrlأو اختر الكلزر) من شير تعييناتلوحةكما هو مبين في العينة قطة فوق. ملاحظة: نحن هنا فقط تظهر 'هدف (أو شرط)' ABACUS نوع عنصر التعيين إلى قائمة SharePoint دعا الأهداف اختياره.

4. حدد الهندسة المعمارية (ق) التي تريد مزامنة المحتوى مع من مزامنة المحتويات من البنىلوحة كما هو مبين في العينة قطة فوق. ملاحظة: نحن هنا فقط تظهر "2015 الفعلية" العمارة يجري مزامنة.

5. حدد المزامنة من SP زر.

ملاحظة

إذا كانت أوراق اعتماد موقع SharePoint ليست "كل محفوظ" لرسم الخرائط (ق) اختار ثم فإن دخول إلى الحوار شير تظهر يسأل ل URL الموقع, اسم االمستخدم و / أو الرمز السري.يرجى إدخال هذه. وعلاوة على ذلك، سوف تشمل تزامن أية تعيينات أخرى مطلوبة لمكونات / أعمدة البحث المرفقة. وسيتم عرض أي تعيينات إضافية التي تم تضمينها تلقائيا في الحوار كما في أدناه.

6. على مزامنة بنجاح ستظهر نتائج الحوار شير مزامنة كما هو مبين أدناه سرد التغييرات وأي تحذيرات. انقر حسنا.

إلى مزامنة من ABACUS ل Microsoft الخاص بك قائمة SharePoint (ق)

1. ضمان لديك ABACUS مفتوحة.

2. اختار أدوات | شير مزامنة.

ملاحظة

إلى مزامنة قائمة SharePoint معمشروع ABACUS يحتاج ترخيص المستخدم شير مزامنةإضافة على القدرة. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

3. حدد رسم الخرائط SharePoint موجودة (أو تعيينات باستخدام اضغط مفتاح Ctrlأو اختر الكلزر) من شير تعييناتلوحةكما هو مبين في العينة قطة فوق. ملاحظة: نحن هنا فقط تظهر 'هدف (أو شرط)' ABACUS نوع عنصر التعيين إلى قائمة SharePoint دعا الأهداف اختياره.

4. حدد الهندسة المعمارية (ق) التي تريد مزامنة المحتوى مع من مزامنة المحتويات من البنىلوحة كما هو مبين في العينة قطة فوق. ملاحظة: نحن هنا فقط تظهر "2015 الفعلية" العمارة يجري مزامنة.

5. حدد المزامنة لSP زر.

ملاحظة

إذا كانت أوراق اعتماد موقع SharePoint ليست "كل محفوظ" لرسم الخرائط (ق) اختار ثم فإن دخول إلى الحوار شير تظهر يسأل ل URL الموقع, اسم االمستخدم و / أو الرمز السري.يرجى إدخال هذه. وعلاوة على ذلك، سوف تشمل تزامن أية تعيينات أخرى مطلوبة لمكونات / أعمدة البحث المرفقة. وسيتم عرض أي تعيينات إضافية التي تم تضمينها تلقائيا في الحوار كما في أدناه.

6. على مزامنة بنجاح ستظهر نتائج الحوار شير مزامنة كما هو مبين أدناه سرد التغييرات وأي تحذيرات. انقر حسنا.

ملاحظة

سوف ABACUS تحديث الأعمدة شير مع قيم فارغة حتى لو "مطلوب أن هذا العمود على معلومات" ومن المقرر أن نعم في SharePoint. وذلك لأن شير لا يعرض هذا الإعداد خارجيا. إذا كان هذا هو أن منعت فمن المستحسن أن مصمم ABACUS يضع القيد مطلوب صحيح والقسري لخاصية معينة باستخدام ABACUS " قيود خاصية .

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | يعيش سكان العمارة بك من برنامج Visio | يعيش سكان العمارة بك من إكسل


يعيش سكان العمارة بك من Microsoft SQL Server

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية من منتجات Microsoft>

يعيش سكان العمارة بك من Microsoft SQL Server

إرسال التعليقات حول هذا الموضوع.

يمكنك استيراد العمارة لديك من بيانات Microsoft SQL Server. لديك خيار لاستيراد فقط الجداول والعلاقات المستوردة بشكل فعال مجرد هيكل عام لقاعدة البيانات أو الجداول، الصفوف والعلاقات التي ستستورد ليس فقط بنية ولكن البيانات كذلك.

ملاحظة

يتطلب من SQL Server الذي ميزة مايكروسوفت SQL خادم 20052008، 2008 R2، 2012 أو 2014المثبت على جهاز الكمبيوتر.

لاستيراد بيانات Microsoft SQL Server الخاص بك إلى ABACUS

1. ضمان لديك ABACUS مفتوحة.

2. حدد ملف | جديد وحدد من SQL Serverمن مربع الحوار الذي يظهر ثم انقر فوق موافق.

3. في مربع الحوار استيراد SQL Server الذي يبدو تعيين "MACHINENAME" و "SQLINSTANCE" قيم سلسلة الاتصال متغير والقيمة "DBNAME 'المتغير اسم قاعدة البيانات إلى قيمها الصحيحة كما هو مبين في الصورة عينة أدناه.

4. تعيين متغير اسم قاعدة البيانات إلى نفس قيمة المتغير كتالوج الأولية المحددة في الخطوة أعلاه، كما هو مبين في الصورة عينة أدناه.

5. اضغط على زر اختبار الاتصال والجداول لاستيراد يجب أن يتم ملؤها الجزء من الحوار مع جداول قاعدة البيانات المتاحة، كما هو مبين في الصورة عينة أدناه.

6. حدد الجداول التي ترغب في استيراد إما عن طريق اختيار منهم على حدة أو باستخدام جميع، لا يوجد وأزرار المقلوب على يمين مربع الحوار.

ملاحظة

فقط مفتاح العلاقات الخارجية القائمة بين الجداول التي تحددها سوف تحصل المستوردة.

7. باستخدام زر استيراد نمط تحديد ما إذا كنت ترغب في استيراد فقط الجداول والعلاقات بينهما أو الجداول، الصفوف، وعلى علاقات محددة بين الصفوف.

ملاحظة

الخيار الأول يستورد جداول كمكونات لل'الجدول' نوع والعلاقات بين أي اثنين من الجداول (من المفاتيح الخارجية) يتم استيراد وصلات من نوع 'العلاقة الجدول ". هذا هو 'ERD' عرض النمط الكلاسيكي من جداول النظام. الخيار الثاني يستورد صفوف الجدول كما منفصلة مكونات فرعية من نوع "جدول الصف" مع خصائص المقابلة لكل من الأعمدة / الحقول والعلاقات بين صفوف الجدول من نوع 'العلاقة الجدول ". وعلاوة على ذلك، إذا كان هناك عمود / حقل يسمى 'اسم' ثم يستخدم هذا لتسمية الفردية صف الجدول المكونات الفرعية.

8. حدد استيراد ... زر.

9. بعد فترة قصيرة من الزمن (مع شريط التقدم لردود الفعل) سيتم إنشاء مشروع ABACUS جديد مع الجداول، صفوف الجدول (إذا تم تحديد الخيار الثاني في الخطوة أعلاه) والعلاقات من بيانات Microsoft SQL Server.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | يعيش سكان العمارة بك من برنامج Visio | يعيش سكان العمارة بك من إكسل


يعيش سكان العمارة بك من برنامج Microsoft Visio

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية من منتجات Microsoft>

يعيش سكان العمارة بك من برنامج Microsoft Visio

إرسال التعليقات حول هذا الموضوع.

يمكنك استيراد العمارة بك من برنامج Microsoft Visio. سيتم استيراد الأشكال في رسم Visio كمكونات في ABACUS. سيتم استيراد الاتصالات في رسم Visio وصلات وسيتم استيراد الرسم نفسه في ABACUS كما رسم تخطيطي. وعلاوة على ذلك، سيتم استيراد أي خصائص مخصصة في رسم Visio من الخصائص مع مفتاح ترتيب معين لنوع العقار، تسمية إلى اسم الفكرية والقيمة إلى قيمة العقار.

ملاحظة

استيراد من ميزة برنامج Visio يتطلب أن برنامج Microsoft Visio 2003أو تثبيت أحدث على الكمبيوتر.

لاستيراد رسومات Visio الخاص بك إلى ABACUS

1. ضمان لديك ABACUS مفتوحة.

2. حدد ملف | جديد وحدد من visioمن مربع الحوار الذي يظهر ثم انقر فوق موافق.

ملاحظة

إذا كنت ترغب في استيراد إلى مشروع ABACUS القائمة ثم إما بزر الماوس الأيمن فوق العقدة مكونات داخل العمارة، أو بزر الماوس الأيمن فوق عنصر فردي داخل العمارة ثم حدد استيراد | من برنامج Visio.

3. تصفح لملف Visio التي ترغب في استيرادها.

ملاحظة

وفيما يلي بعض القواعد البسيطة أو الممارسات الموصى بها عند بناء (أو تعديل) لMS رسم Visio للاستيراد إلى ABACUS.

1. خطوط أو اتصالات يجب أن تكون الروابط الفعلية، وليس الأشكال.

· خلاف ذلك ABACUS ستستورد فقط منهم كعناصر وبناء على ذلك لن يتم "تعلق" إلى أي شيء.

· إذا كنت بحاجة إلى القيام ببعض التوجيه "الذكية" (أي بخلاف خط مستقيم) ثم استخدم الرابط الحيوي على الاستنسل الأشكال الأساسية، سوف ABACUS استيراد النقاط التوجيه / مرساة غرامة.

· في محاولة لتجنب استخدام "شبكة الطوق" و "إيثرنت" الأشكال من شبكة وملحقات الاستنسل الذي يسمح الكثير من المكونات إلى أن "توصيل" لذلك. في حين نستورد المرفقات غرامة وصلات الشكل الأصلي لا يزال "توسيع" لتعكس المرفقات. استخدام فصل "محور / حافلة" شكل مستقل (بدون رابط "الساقين") ثم قم بتوصيل صراحة كل مكون إلى محور / حافلة مع موصلات منفصلة.

· إذا كان خط أو اتصال يتصرف مثل الشكل، انقر على الحق في ذلك والذهاب إلى "تنسيق | السلوك ... "وتأكد من أن يتم تعيين نمط التفاعل على الخط (1 الأبعاد).

2. المكونات يجب أن تكون الأشكال NOT الموصلات.

· خلاف ذلك ABACUS سوف استيرادها فقط وصلات وبالتالي ستفقد جميع المعلومات الشكل.

· إذا كان العنصر يتصرف مثل الموصل، انقر على الحق في ذلك والذهاب إلى "تنسيق | السلوك ... "وتأكد من أن يتم تعيين نمط التفاعل إلى مربع (2-الأبعاد).

3. تحتاج طرفي الموصل لضمها إلى الأشكال، لا تطوف في الخلفية وراء الشكل.

· إذا لم يكن لتوصيل وصلات إلى الأشكال ثم ABACUS لا يوجد لديه وسيلة لمعرفة ان كنت تهدف إلى إرفاق موصل بالنظر إلى الشكل / عنصر وفقا لانها ستترك هذه الغاية من الاتصال الامم المتحدة المرفقة.

4. يجب تسميات الأشكال أن يكون (حيثما أمكن ذلك) تسمية نص يحمل في ثناياه عوامل للشكل، وليس مربع نص منفصل على الرسم.

· سوف تحصل على استيراد مربعات النص منفصلة ABACUS كمكونات في حد ذاتها، وبينما يمكنك دمج عنصر "التسمية" مع المكون الحقيقي في ABACUS، أو مجرد تحويل عنصر "التسمية" لشكل حر (أي ليس العنصر نفسه) فمن الأفضل لتجنب هذه الخطوات.

5. استخدام نفس شكل قاعدة لكل مثيل من نفس النوع، لا يكون كسول واستخدام المستطيل في بعض الأحيان وصندوق غيرها من الإستنسل شكل مختلف.

· يستخدم ABACUS شكل قاعدة واللون الأساسي لتحديد فريد أنواع عنصر والاتصال في الرسم لذلك "المستطيل الأحمر" و "مربع أحمر" سوف تحصل المستوردة نوعين مكون منفصلة. هذه الأنواع المكونة يمكن دمجها في ABACUS ولكن من الأفضل لتجنب هذه الخطوات.

6. كليا تغليف "الأطفال" ضمن الأشكال عن "الآباء"، لا تترك لهم شنقا على الحافة.

· سوف ABACUS الكشف عن أي الشكل الذي يتم تغليف بالكامل داخل شكل آخر وهو طفل من الوالدين لذلك تأكد من شكل كامل، بما في ذلك الجزء التسمية، والمغلقة.

7. لا موقف شكل تداخل اثنين من الأشكال الأخرى.

· إذا كان شكل يتداخل اثنين من الأشكال الأخرى، سواء كان "التجمع" / المستطيل الخلفية أو خلاف ذلك، سيتم استيرادها من قبل ABACUS باعتباره المكون الذي هو طفل من لا الأشكال المتراكبة ولكن بمجرد تحديد عنصر في أداة الرسم ABACUS " ، ويرجع ذلك إلى الجزء العلوي الأيسر كونها مكونات نقطة مرجعية، وسوف يصبح طفل من اليسار تتداخل شكل / المكون.

8. محاولة التقليل من استخدام الملاحظات النصية على الرسم لأن الحصول على استيراد هذه كمكونات في حد ذاتها، وسوف تحتاج إلى تحويلها إلى أشكال حر في ABACUS. التفكير في ما إذا كانوا حقا اسم عنصر القائمة أو اتصال.

9. في حين ABACUS يدعم الغني / ملون / الأشكال ناقلات القائم، في محاولة للحد من استخدام الصور النقطية والأشكال الخارجية وملفات التعريف المحسن عن الأشكال كما يفعل حاليا ABACUSليسدعم هذه الأنواع. وسوف يتم استيرادها على شكل مستطيلات بيضاء بسيطة.

10. في محاولة لتجنب الإرجاع (التحول العائد) في التسميات لانها مستورده وكما هو مبين طابع خاص "[]" في ABACUS لاسم المكون.

11. محاولة للحد من الألوان المختلفة التي تستخدم لأشكال من نفس النوع. كما ذكر أعلاه، اللون الأساسي وقاعدة الشكل بشكل فريد مكون والاتصال أنواع وبالتالي فإن أكثر التباين هناك المزيد من دمج وتوحيد التي سوف تحتاج إلى القيام به بعد استيراد في ABACUS.

12. كن حذرا مع الأشكال شغل لأنه إذا شغل شكل كل وسيلة لزوايا ثم تلوين في وقت لاحق في ABACUS لن يكون لها تأثير.

13. عن الأشكال القائم على خط معقدة يجب عليك استخدام المضلع الذي يتم إنشاؤه من خلال وجود خطوط تبدأ حيث ينتهي سابقتها ومن ثم في النهاية يعود إلى نقطة البداية. إذا رغبت في ذلك، يمكنك استخدام ملء وخط العرض لجعل نظرة المضلع مثل "السهم" أو أيا كان الشكل الذي تريد.

14. تأكد من أن ID الأشكال في MS برنامج Visio هو مفيد ليس فقط Shape.xx. هذا هو للتحرير باستخدام بزر الماوس الأيمن فوق "إظهار ورقة" والذي يتوفر في برنامج Visio MS وضع المطور (تمكين من خلال أدوات | خيارات في برنامج Visio MS).

15. الحذف وأقواسضمن الأشكالمعتمدة في ABACUS لكن غير معتمدة حاليا نوربس والمفاتيح.

16. تأكد من تجميع شكل كامل في MS برنامج Visio أو أنه سيتم استيرادها إلى عدة مكونات / أنواع.

17. محاولة التقليل من استخدام الأشكال استدارة داخل subshapes لأنها سوف بعض الأحيان لا يتم استيرادها بشكل صحيح.

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | يعيش سكان العمارة يدويا | يعيش سكان العمارة من الدخول | يعيش سكان العمارة بك من إكسل


يعيش سكان العمارة يدويا

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا>

يعيش سكان العمارة يدويا

إرسال التعليقات حول هذا الموضوع.

والمكونات واتصالات للهندسة المعمارية الخاصة بك على مستوى أعلى ربما تحتاج إلى أن يتم ملؤها يدويا. وعادة ما تكون هذه المكونات واتصالات أكثر تجريدا.

لملء العمارة يدويا

1. ضمان لديك ملف ABACUSمفتوحة، مستكشفعرض، و وأضافت العمارة .

2. إضافة عنصر. لفعل هذا، انقر بزر الماوس الأيمنعلى منطقة الشجرة التي تريد نشر، واختر إضافة العنصر الفرعي ...، أو انقر على عنصر جديدزر على عرض شريط الأدوات . لا يمكن إلا أن تضاف المكونات ضمن الفرع مكونات الشجرة. تريد مخطط الشجرة ليكون تمثيلا دقيقا للعمارة الخاص بك. عند اكتشاف الهندسة المعمارية الخاص بك، فإنك قد علمت بالضبط كيف يناسب جميع معا. ستحتاج هذه المعرفة عند إضافة مكونات والاتصالات الخاصة بك. إذا كنت تقوم بإضافة العنصر الأول الخاص بك، عليك إضافته مباشرة إلى فرع المكونات. بقية المكونات الخاصة بك يمكن أن تكون على نفس المستوى في شجرة، أو أنها يمكن أن تكون المكونات الفرعية لأول مرة.

3. تحديث قيمخصائصكل عنصر كما يمكنك إضافته. لفعل هذا، انقرعلى العنصر، وتحرير خصائص المعروضة في نافذة الخصائص(عادة) إلى اليمين. الخصائص هي عموما أشياء مثل المتطلبات، قدرة المعالجة، وما إلى ذلك عند تقييم ABACUS العمارة الخاصة بك، فإنه سيتم حساب بعض خصائص جديدة، وحفظها مرة أخرى إلى الهندسة المعمارية. الخصائص الجديدة هي البيانات التي تحاول تحليل، مثل استخدام، زمن الاستجابة، وعرض النطاق الترددي، الخ

4. إضافة اتصالاتكو تحديثممتلكاتهمكما تذهب - تماما كما تفعل لمكونات (ولكن تحت فرع اتصالات من شجرة).

5. يرفقالاتصالات ومكوناتها. للقيام بذلك، حدد موقع الاتصال، انقر على واحدة من ل ينتهي أو الأدوار واسحبه عنصر. بدلا من ذلك، انقر على عنصر واسحبه على واحد من الاتصال في الأدوار (أي إما مصدر أو بالوعة). أو يمكنك النقر بزر الماوس الأيمن فوق واسحب مكون على مكون آخر وحدد اتصل ب. أو ببساطة بزر الماوس الأيمن فوق العنصر وحدد ربط .... عند سحب اتصال دور، ستلاحظ رمز الاختصار عند النقطة مكون يمكنك إرفاقه. وهذا يدل على أنك لا عمل نسخة، كنت مجرد إرفاقها. تأكد من أنك إرفاقه مكون الوجهة الصحيحة. على سبيل المثال، إذا كان مصدر اتصال ل دور، اسحبه قيام المكون المصدر (أي المكون الذي هو مصدر تدفق البيانات).

تلميح

إعادة ترتيب الكيانات داخل العمارة الخاصة بك (على سبيل المثال المكونات واتصالات وغيرها) في مستكشفمن السهل جدا. ببساطة انقر| عقد| سحبالكيان والمكان المناسب حيث المطلوب في فن العمارة الخاص بك. كما يتيح وظيفة إعادة ترتيب لك أن تضع كيانات داخل هرمية مختلفة من الهندسة المعمارية الخاصة بك.

قد تريد أيضا

6. إضافة معايير (مجموعات معدة سلفا من خصائص - المسبقة) لديك المكونات، وصلات أو أنواع

7. تغيير خصائص عنصر، الاتصال أو نوع

8. التراجع والإعادة العمليات

9. تغيير نوع مكون أو اتصال

10. إنشاء نوع جديد أو نوع المجموعة

11. حذف مكون أو اتصال

12. إنشاء مكررة أو تتطور بنية

13. أنواع الاستيراد والمعايير من مكتبة

14. الاستيراد من ملف ABACUS آخر، XML، إكسل أو Visio

15. نسخ و لصق أجزاء (أو كل) من الهندسة المعمارية بك

16. بحث واستبدال البنود الخاصة بك في الهندسة المعمارية

17. توسيع الانهيار بعض أو كل من العقد في الشجرة

18. دمج العناصر

19. حدد و التحقق من صحة القيود للحد من هيكل العمارة بك

20. تطور فن العمارة الخاص لإنشاء العديد من الحلول المعمارية للمقارنة وخط الأساس

أنظر أيضا

يعيش سكان العمارة الخاص - نظرة عامة | إنشاء ملف جديد


نشر على الويب

الملاحة: الإبلاغ عن الهندسة المعمارية بك>

نشر على الويب

إرسال التعليقات حول هذا الموضوع.

ABACUS 'نشر إلى ميزة الويب تتيح النماذج المعمارية ليتم عرضه عبر موقع ويب آمن. ويتم تصدير أبنية إلى تنسيق HTML، وهي مصممة لتعكس الشكل والمظهر من Explorer في ABACUS. المشاهدات (بما في ذلك الكتالوجات، الرسوم البيانية، 3D والمخططات البيانية) ويتم تصدير أيضا الى عرض نماذج باستخدام متصفح الانترنت.

ملاحظة

حاليا، لا يتم نشر وجهات النظر ومصفوفات.

لنشر النماذج المعمارية الخاصة بك على شبكة الإنترنت

1. ضمان أن يكون لديك صلة ملف ABACUSمفتوحة، تحتوي على العمارة بالسكانالتي تريد نشرها على شبكة الإنترنت.

2. اختار ملف| نشر ....

3. ال نشر لتكوين ويبسوف نافذة عرض.

نشر إلى تكوين ويب

4. افتراضيا يتم تحديد كافة أجزاء من نموذج بما في ذلك عرض شجرة، و المعاييروأنواع، قوالب والهندسة المعمارية (ق). قم بإلغاء أي أجزاء كنت لا تريد نشر على شبكة الإنترنت، بما في ذلك أي آراء فردية داخل العمارة (ق).

تلميح

إذا كنت ترغب في إخفاء عناصر محددة، الاتصالات و / أو ممتلكاتهم فمن المستحسن أن مسؤول يخلق دور ل'العامة' باستخدام ميزة الوصول المستند إلى الدور ABACUS " ثم يزيل إذن القراءة من تلك الأنواع المكونة، أنواع الاتصال و / أو خصائص أنهم لا يرغبون في نشر. ثم يجب تسجيل المستخدم في إطار هذا الدور وتنشر على شبكة الإنترنت كما ABACUS سوف تنشر العناصر التي إذن قراءة مجموعة للدور فقط. وعلاوة على ذلك، يمكن للمستخدمين السيارات تنشر من سطر الأوامر كما هو موضح هنا .

ملاحظة

تستطيع تحديد كافة الأجزاء المعروضة من خلال النقر على جميعزر أو عكس الاختيار عن طريق النقر على عكس زر. يمكنك أيضا النقر على لا شيءزر لمسح اختيارك.

ملاحظة

اذا أنت قم بإلغاء تحديد خيار عرض شجرةثم سيتم نشر أي إطار شجرة (انظر أدناه). وفقا لذلك، يجب عليك اختيار صفحة البداية فقا للخطوة 6 أدناه أو بعد نشر ستحتاج إلى تخصيص إما على مستوى عال. ا) index.html وملف عن طريق تغيير "إطار SRC =" mainPage.html "اسم =" element_details "" خط لربط مباشرة إلى صفحة HTML ذات الصلة ضمن المجلد المحتوى، أو ب) mainPage.htmlمن خلال توفير ارتباط تشعبي أو إعادة توجيه إلى صفحة HTML ذات الصلة ضمن المجلد المحتوى.

5. انقر على خيار زر وما يلي خيارات الناشرسوف الحوار عرضهم.

نشرخيارات إيه

6. Sانتخاب 3D، رسم بيانيوالتخطيطات صيغ وعما إذا كان لإظهار العنوان والوصف أو خصائص آراء من الخيارات المتاحة (راجع الملاحظة أدناه للتعليقات على مختلف الأشكال).

7. إذا كنت ترغب في تعيين صفحة البداية من طراز نشرت على وجهة نظر معينة ثم التحقق من استخدام عرض باسم صفحة البدءالخيار وانتقل إلى عرض عن طريق '...' الزر الذي يصبح ممكنا.

ملاحظة

فقط وجهات مختارة في القسم المناطق حسب الخطوة 4 تتوفر لتعيين كصفحة بداية أعلاه.

8. إذا كنت ترغب في الحصول على ردود الفعل على صفحات معينة في النموذج نشر ثم تأكد من أن البريد الإلكتروني ملاحظاتيتم تحديد الخيار, إدخال عنوان البريد الإلكتروني في عنوان البريد الإلكتروني خانة النصوتحرير البريد الإلكتروني الجسمالقسم حسب الاقتضاء. إذا كنت لا ترغب في أن يكون أرسلت ردود الفعل ثم قم بإلغاء تحديد البريد الإلكتروني ملاحظاتالخيار وترك النص فارغا.

9. اضغط على حسنا زر.

10. اضغط على تصفح زر.

11. ال تصفح لمجلدسوف نافذة عرض.

12. حدد الموقع الذي تريد تخزين ملف HTML المستوى الأعلى (وأي الملفات التي تم إنشاؤها تلقائيا).

ملاحظة

انها فكرة جيدة لإنشاء مجلد معين (عادة تسمى "منشور") باستخدام إنشاء مجلد جديدزر في أسفل مربع الحوار لتخزين ملف HTML ذات المستوى الأعلى وأي الملفات التي تم إنشاؤها تلقائيا.

13. اضغط على حسنا زر.

14. سوف مسار المجلد عرض في دليل خانة النص.

15. اضغط على إنهاء زر.

- أو -

15. أدخل مسار المجلد في دليلالنص حيث تريد تخزين ملف HTML المستوى الأعلى (وأي الملفات التي تم إنشاؤها تلقائيا).

16. اضغط على إنهاء زر.

ملاحظة

تصدير الرسوم البيانيةفشل في بعض الأحيان للغاية، في معظم الأحيان عندما يكون الكمبيوتر من الذاكرة (عادة عند استخدام ملفات كبيرة جدا). ستتم إعادة تصدير فشلت مرة واحدة. سوف يكون هناك تحذير واحد لمحاولة أولية فشلت، والإنذار الثاني في حالة فشل إعادة المحاولة. لذلك، إذا التحذيرات الوحيدة هي "فشلت محاولة أولية" منها، وتنشر كانت ناجحة. إذا فشلت إعادة المحاولة، حاول نشر جزء أصغر من ملف أو تحرير بعض ذاكرة النظام.

يمكن للملف HTML حفظ (الصورة) الآن أن يكون عرض من موقعه أو نسخها إلى موقع ويب آمن.

نشر إلى ويب في Internet Explorer10

أي وصلات والتي تم إنشاؤها في النموذج الأصلي أن استمر في النموذج المنشورة وسوف النقر على الرابط اتبع الرابط إلى وجهتها (إذا تم نشرها). وعلاوة على ذلك، فإن أي عناصر في المخططات المنشورة التي لا ارتباط تشعبي بالفعل في النموذج الأصلي تشعبيا إلى العناصر المقابلة لها في نظر شجرة (إذا تم نشرها)، والنقر على عنصر في الرسم البياني نشرت سيكون التركيز القفز إلى الموقع ذات الصلة في شجرة. هذه الميزة مشابهة ل"عرض في مستكشف" بزر الماوس الأيمن فوق ميزة في ABACUS.

ملاحظة

توصي Avolution بشدة يجب استخدام صيغ البرامج والملفات التالية للاستفادة الكاملة من نشر إلى وظائف ويب في ABACUS:

1. إنترنت إكسبلورر (80.0 وما فوق)لعرض وجهة النظر المستكشف المنشورة. موزيلا فايرفوكس (30.0 أو في وقت لاحق)ويوصى أيضا ويؤيد تماماومع ذلك، إذا باستخدام تنسيق SVG الموصى بها للمخططات ثم في فايرفوكس 9 يمكنك استخدام فقط SVG الأصلي دعم المشاهد التي للأسف لا يسمح التكبير أو بالغسل.

2. أدوبي SVG عارض 3.0 في المكونات (تنزيل من هنا ) و SVGتنسيق ملف للنشر الرسوم البيانية. شكل صورة SVG ل الرسوم البيانيةويوصى ل. SVG هو شكل صورة ناقلات القائم، وبالتالي هو 'خسارة أقل "وتبدو أفضل بكثير في أي مستوى التكبير معين من أي من غيرها من الأشكال، يمكن استيراد SVG إلى MS Visio أو يمكن أن يكون أسرع SVG إلى أي مستوى أو قرار ، SVG ديه صلات إلى العرض التسلسلي للاتصالات (وليس فقط مكونات)، SVG يطبع دائما في أفضل قرار، و، SVG حوالي نصف حجم الملف من الأشكال الأخرى. PNG هو توصية المقبلة، ولكن، كما هو تنسيق rasterised في بعض مستويات التكبير سيتم فقدان وضوح الرأي والنقر الاتصالات على المخططات لن تقفز مرة أخرى إلى الموقع المناسب في الشجرة. تم تخيف BMP كما في حين أنه هو "فقدان أقل" تنسيق حجم الملف هو 100X التي من غيرها من الأشكال والصور 20MB ليست غير عادية.

المفاضلة مع SVG هو أن المشاهد SVG سوف تحتاج إلى تثبيت وتحتاج إلى تأكد من أن زمر .svg صورة / SVG + XML يتم إضافة أنواع MIME ملقم ويب. بعد تركيب المشاهد SVG مايكروسوفت إنترنت إكسبلورر سيطلب منك قبول اتفاقية الترخيص المشاهد وبعد ذلك يجب أن تعمل بشكل جيد. وحينموزيلا فايرفوكس يدعم ملفات SVG أصلا، لا يزال أوصى أدوبي المساعدلتكون قادرة على تكبير الرسوم البيانية إذا كنت تستخدم فايرفوكس 8 أو في وقت سابق (إذا كنت تستخدم فايرفوكس 9 لا يمكنك تعطيل SVG المشاهد الأصلي). مرة واحدة وقد تم تشغيل التثبيت لأدوبي البرنامج المساعد، والخطوات التالية مطلوبة استخدامه في فايرفوكس:

· فتح فايرفوكس وإدخال "حول: التكوين" (بدون علامتي اقتباس) في شريط URL.

· انتقل لأسفل والعثور على العقار svg.enabled(إذا كنت تستخدم فايرفوكس 9 ثم عرض SVG الأصلي لا يمكن أن يكون تعطيل وعدم وجود هذا العقار). انقر مرتين على ذلك لتعطيله.

· الآن نجد الدليل حيث تم تثبيت البرنامج المساعد SVG (على سبيل المثال C: \ ملفات البرنامج \ الملفات المشتركة \ أدوبي \ SVG عارض 30.0 \)

· نسخ الملفات NPSVG3.dll و ال NPSVG3الرمز البريدي ولصقها في الدليل الإضافات فايرفوكس (على سبيل المثال C: \ ملفات البرنامج \ موزيلا فايرفوكس \ الإضافات)

· إغلاق كافة مثيلات فايرفوكس

3. ABACUS 3D عارض Avolution ل(3.1 وما فوق)و .abacus3D Avolution لتنسيق ملف للآراء نشرت 3D. بينما ال كورتونا VRML عميل المكونات في (2.0 وما فوق)هو متاح لعرض الإصدارات VRML من الآراء المنشورة أنها ليست حرة للاستخدام التجاري ومازال يتطلب التثبيت من جانب العميل. عارض 3D ABACUS هو أكثر ميزة الغنية من أي مشاهد VRML ومتاح مجانا للتحميل من هنا . في كلتا الحالتين تأكد من إضافة .vrml X-العالم / X-فرمل و.abacus3d التطبيق / الثماني تيار لأنواع MIME ملقم ويب.

4. PNGتنسيق الملف آراء الرسم البياني المنشورة. ينصح شكل صورة PNG آراء الرسم البياني لأنه في حين أنه هو شكل rasterised وهناك "خسارة" للمفاضلة بين حجم الملف وضوح الرسم البياني هو عادة أفضل. تم تخيف BMP كما في حين أنه هو "فقدان أقل" تنسيق حجم الملف 20x والتي من غيرها من الأشكال والرسوم البيانية بعد 2Mb ليست غير عادية.

إذا كنت ترغب في تغيير الشكل والمظهر من صفحات الويب، ويمكنك تحرير ملف صفحة البداية اسمه mainPage.html وملف ورقة أنماط اسمه abacus.css. سوف تجد هذه الملفات في نفس المجلد حيث اخترت حفظ الملف HTML المستوى الأعلى. لمزيد من المعلومات حول بنية والخياطة من الناتج نشرت انظر القسم التالي.

هيكل ABACUS نشر نماذج

ويتمحور نموذج نشرت ABACUS على النحو التالي:

1. يحتوي المجلد على مستوى عال عدة ملفات وعلى افتراض أن جميع الخيارات مدرجة في ABACUS نشر إلى تكوين ويب الحوار أنه سيتضمن فهرس.أتش تي أم ألجعل ملف يتكون من ثلاثة أطر؛ treeView.html, findNode.html و mainPage.html وثم shortcutError.htmlصفحة. يتم ملؤها من قبل treeView.html tree.js, tree_items.jsو tree_tpl.js ملفات جافا سكريبت تقع ضمن المجلد تشمل (ناقش أدناه) ويعيد شجرة Explorer من ABACUS. هو مدعوم من قبل findNode.html ال find.js ملف جافا سكريبت تقع تحت تشمل مجلد (مبين أدناه)، وأنه سوف ابحث فروع شجرة بدلا من مجرد عقد مرئية. Tانه mainPage.html هي صفحة HTML الثابتة التي يمكن أن تكون مصممة مع شعارات الشركات وما شابه ذلكوسيتم عرض ما لم يتم اختيار صفحة البداية عندما نشر.وأخيرا، صفحة shortcutError.html هي الصفحة المقصودة لأي اختصارات مكسورة من شجرة بسبب الصفحات المناسبة لا يتم نشرها.

تلميح

يمكنك تخطي mainPage.html تماما من قبل اختيار لاستخدام صفحة البداية عندما نشر أو تعديل الملف index.html و لتشير مباشرة إلى وجهة نظر معينة (مثلا) عن طريق تحرير SRC إطار = "mainPage.html" خط لتشير مباشرة إلى العرض الأول في العمارة الأولى، وعادة "إطار" المخطط.

2. ط المستوى الأعلىNCLUDEمجلد يحتوي علىجي مختلف جافا سكريبت (شبيبة) ورقة الأنماط المتتالية (المغلق) الملفات المستخدمة من قبل ملفات .html في جميع أنحاء نموذج المنشورة.

3. يحتوي المجلد المحتوى على مستوى عال، حسب الترتيب الأبجدي;

· ا '3D عدد المشاهدات' مجلد معمرقمةصفحة HTML وملف VRML أو abacus3d لكل من وجهات النظر 3D المنشورة. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· ل أبنية مجلد مع صفحة HTML مرقمة لكل العمارة التي تم نشرها. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· A الكتالوجات المجلد الذي يحتوي على صفحة HTML مرقمة لكل من الفهارس المنشورة. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· A الرسوم البيانية مجلد معمرقمةصفحة HTML وPNG، JPG الخ ملف لكل الآراء المنشورة الرسم البياني. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· A مكونات المجلد الذي يحتوي علىمرقمةصفحة HTML لكل من المكونات المنشورة. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· A روابط المجلد الذي يحتوي علىمرقمةصفحة HTML لكل من اتصالات المنشورة. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· A الرسوم البيانية المجلد الذي يحتوي علىمرقمةصفحة HTML وPNG، SVG الخ ملف لكل من نشرها الرسوم البيانية. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· ل الرموز الفرعية-مجلد مع الصور المختلفة المستخدمة في نموذج المنشورة.

· A المعايير المجلد الفرعي معمرقمةصفحة HTML لأي المعاييرالتي تم نشرها. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

· A النماذج الفرعية-مجلد مع مجموعة من مرقمة مجلدات فرعية لكل قالب نشرت من المشروع. داخل كل مجلد الفرعي هو مكونات ومجلد اتصالات وضمن هذه هي صفحة HTML مرقمة لكل مكون والاتصال من القالب. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم المجلد / الملف.

· A أنواع المجلد الفرعي مع المكونات والمجلدات الفرعية اتصال معمرقمةصفحة HTML لأي مكون وأنواع الاتصال التي تم نشرهاومجموعة من مرقمة مجلدات فرعية لكل نوع المنشورة من المشروع الذي يحتوي على صفحة HTML لكل من القيود. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم المجلد / الملف.

· A عرضنقطةs المجلد الفرعي ومرقمةصفحة HTML لأي من مشاهدةنقطةالصورة التي تم نشرها. راجع الملاحظة أدناه للحصول على معلومات عن نظام ترقيم الملف.

ملاحظة

ترقيم صفحات HTML (و في بعض الحالات ملفات الصور) تطابق فريد هوية شخصية لكل كائن المستودع الذي كان تعيين عند كان مكونضمن ABACUS (المشار إليها باسم EEIDs). لا يتغير هذا الرقم حتى مثل الرسوم البيانية، وأنواع، مكونات إلخ هي تحديث أنهم سوفالإبقاء على نفس الرقم كما كان من قبل. في كل حال، فإن صلة الكائن مستودعويمكن الاطلاع على اسم قرب بدء صفحة HTML بين <ح 1> ... علامات HTML.

تقييد الوصول إلى صفحات معينة / المشاهدات مع IIS

في حالة استخدام IIS كما خادم الويب الخاص بك لنموذج نشرت، وكنت قد تكون قادرة على تقييد الوصول إلى صفحات معينة / المناظر استخدام الأسلوب أدناه:

1. إنشاء موقع على شبكة الانترنت في IIS (آخر واحد إذا كان هناك وجود واحد كنت لا تريد أن تتدخل).

2. تغيير الوصول Properties-> دليل بالأمن> مجهول - الوصول المجهول ازل، واستخدام مصادقة الوصول.

3. إذا كان هذا هو مجرد خادم العادي مع عدم وجود مضاعفات مجال الخ، ثم يجب عليك استخدام خيار "Windows المتكاملة المصادقة" التي من شأنها ثم استخدام أجهزة الخادم المستخدمين المحليين / تسجيل الدخول باسم التوثيق، وفقط إضافة مستخدمين إلى الكمبيوتر المحلي (والحرص على ان كنت على بينة من الآثار، أمنيا، إضافة مستخدمين جدد إلى الجهاز، على سبيل المثال اعتمادا على ما إذا كان الوصول البعيد هو الإعداد للجهاز، وما إلى ذلك).

4. إضافة أذونات إلى ملفات معينة / المجلدات كما هو مطلوب. انقر على الحق في الملفات الفردية / مجلدات -> خصائص، وضبط أذونات الأمان كما تفعل عادة للملفات / مجلدات.

قد تختلف هذه اعتمادا على ما هو إصدار IIS وما محددة نظام التشغيل ويندوز على الخادم، وإذا كان لديك مجال أو غيرها من الإعداد مختلفة.

أنظر أيضا

يعيش سكان العمارة بك | تحليل بنية بك


تسجيل ABACUS

الملاحة: مرجع>

تسجيل ABACUS

إرسال التعليقات حول هذا الموضوع.

عند بدء تشغيل ABACUS (أو بعد ترخيص مؤقت قد انتهت صلاحيتها) سوف تحتاج إلى تسجيل التطبيق على خادم ترخيص Avolution باستخدام مفتاح ترخيص فريدة من نوعها التي تقدمها بمسؤول ABACUS المحلي أو مباشرة من Avolution. إذا لم يكن لديك مفتاح ترخيص يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution .

للتسجيل مع مفتاح الترخيص

1. بعد التثبيت، بدء ABACUSإما عن طريق النقر المزدوج فوق الاختصار على سطح المكتب أو من قائمة ابدأ.

2. في مربع الحوار الذي يظهر التسجيل دخول مفتاح الترخيص 26 حرفالتي تقدمها بمسؤول ABACUS المحلي أو دعم Avolution ، أو انقر تصفح...وحدد عاد الملف .dlsc موقعة من دعم Avolution وفقا للملاحظة في الخطوة 4 أدناه. في حالة استخدام ملف .dlsc قعت بشكل صحيح يجب ABACUS بدء حسب الخطوة 5 أدناه.

تلميح

يمكنك لصق مفتاح الترخيص في الحوار عن طريق نسخها إلى الحافظة ويندوز ثم اختيار الخلفية من الحوار والضغط على Ctrl + V.

الحوار تسجيل

3. انقر حسناوإذا كان مفتاح الترخيص ل صحيح ABACUS مفتاح الترخيصسوف ABACUS الآن محاولة الاتصال خادم ترخيص Avolution لمصادقة مفتاح الترخيص.

ملاحظة

إذا كنت تحصل على كود التثبيت غير صالحخطأ تسجيل هو الأكثر احتمالا أن كنت قد كتبته رمز غير صحيح. محاولة نسخ ولصق رمز وفقا لنصيحة المذكورة أعلاه.

الاتصال خادم ترخيص Avolution

4. انقر حسناوبعد فترة وجيزة من الوقت يجب أن ABACUS تسجيل بنجاح.

تم التسجيل بنجاح

ملاحظة

إذا كنت تحصل على لا يمكن الاتصال خادم ترخيصخطأ تسجيل هو الأكثر احتمالا أن جدار الحماية (أو غيرها من التدابير الأمنية) على الشبكة تمنع الوصول إلى خادم ترخيص Avolution ل. انقر حسناحفظ الملف .dlsc إلى الجهاز المحلي ثم إما البريد الإلكتروني الملف .dlsc ل دعم Avolution وننتظر المزيد من التعليماتأو محاولة تسجيل ملف الترخيص نفسك باستخدام العنوان التالي - http://licensing.avolutionsoftware.com/LicenceSign/ .

لا يمكن الاتصال بخادم ترخيص

فتح توقيع رخصة صفحة ويب

دليل الترخيص توقيع صفحة ويب

بدلا من ذلك، إذا كنت تحصل على وقد استخدم هذا الرمز التثبيت على مزيد من الأنظمة من المسموح به في ترخيصخطأ تسجيل فمن المرجح أن الجهاز المحلي تم بناؤها منذ آخر مسجل ABACUS أو تحاول تسجيل مع مفتاح ترخيص مستخدم آخر. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution .

وقد تم بالفعل استخدام رمز التثبيت

5. انقر حسناوإذا كان مسجلا بنجاح يجب ABACUS فتح مع شاشة الترحيب .

أنظر أيضا

دعم Avolution | ماذا ABACUS تفعل؟


معيار اختيار العنصر

الملاحة: تحليل بنية بك>

معيار اختيار العنصر

إرسال التعليقات حول هذا الموضوع.

عند إنشاء رسم تخطيطي، 3D رأي، تقرير,تخطيط قياسيأو تشغيل المحاكاة، يتم استخدام نافذة اختيار عنصر قياسي لتحديد العناصر التي تريد تحليلها / الرأي.

نافذة معيار اختيار العنصر

Pulldowns

· مرشح من قبل عرض سوف تتضمن العنصرالصورة من وجهة نظر المحفوظة مسبقا (أي مخطط، مخطط، 3D). وبهذه الطريقة يمكنك تنفيذ مجمع "الانضمام" استفسارات علاج رأي آخر بأنه 'استعلام' حفظها.

مربعات

· مشاهدة مستوياتمجموعة إرادة العنصر وفقا لمستوى الذي وقوعها في الشجرة. المستوى 1 هو أعلى مستوى معظم.

· مشاهدة أنواعإرادة مجموعة العناصر وفقا لأنواع التي هم عليها.

· الآباء المحددوتشمل عناصر الأم لأية عناصر مختارة. وبهذه الطريقة يمكنك التأكد من ذلك فحسب التسلسل الهرمي فوق أي الأطفال ستدرج ل"أسفل إلى أعلى" الاختيار.

· أطفال المحددوسوف تشمل الأطفال عناصر من أي عناصر مختارة. وبهذه الطريقة يمكنك التأكد من ذلك فحسب التسلسل الهرمي تحت أي الآباء وسوف تدرج ل"من أعلى إلى أسفل" الاختيار.

· مباريات اسم القيمةوسوف تشمل فقط تلك العناصر التي لها اسم تحتوي على السلسلة المحددة (يرجى ملاحظة: أحرف البدل (أي و*) يمكن استخدامها؟). وبهذه الطريقة يمكنك تشكيل الاستعلام "الدلالي".

· يوجد نوع العقار / اسم / القيمةوسوف تشمل فقط تلك العناصر التي لديها نوع العقار، اسم والقيمة التي تحتوي على سلسلة معينة إما بشكل مباشر على العنصر أو على معاييرها (يرجى ملاحظة ما يلي:؟.؟ أحرف البدل (أي و*) يمكن استخدامها على سبيل المثال * في مجال القيمة سوف تقديم كل العناصر التي لديها قيمة غير فارغة لخاصية معينة). وبهذه الطريقة يمكنك تشكيل الاستعلام "الدلالي".

· لديه معياروسوف تشمل فقط تلك العناصر التي لها اسم قياسي تحتوي على السلسلة المحددة (يرجى ملاحظة: أحرف البدل (أي و*) يمكن استخدامها على سبيل المثال HP * سيعطي جميع العناصر لمعيار واحد على الأقل بدءا من رسائل H وP؟). وبهذه الطريقة يمكنك تشكيل الاستعلام "الدلالي".

· المكونات / اتصالات تعلق المختارةوسوف تشمل أي عناصر تعلق على تلك التي تم اختيارها. وبهذه الطريقة يمكن تحديد "دعوة شجرة" أو "تأثير التحليل".

ملاحظة

إذا كان لديك على حد سواء مشاهدة مستوياتو مشاهدة أنواعاختيار ثم يمكنك اختيار أن يكون مستويات عرض أول شجرة أو أنواع أول من الزر الذي سيظهر فوق خانات اثنين.

تلميح

مرة واحدة يتم تحديد عنصر في النافذة الموحدة عنصر التحديد، فإنه لن يكون خاضعا لأية تغييرات أخرى مرشح حتى يتم إلغاء تحديد ذلك. لأنه ليس هناك أي وسيلة الأم للبحث عن مجموعتين مختلفتين من العناصر في وقت واحد (على سبيل المثال مكونات لمعيار A أو معيار B)، يمكنك أولا عن وجود مجموعة واحدة، تحديد المكونات المطلوبة، ومن ثم إجراء البحث الثاني عن المجموعة الثانية .

أزرار

· جميعتحديد كافة العناصر.

· عكسيتم إزالة جميع العناصر المحددة حاليا ويختار كل تلك التي لم يتم اختيارها.

· لا شيءيتم إزالة جميع العناصر.

· إضافة تصفيةيحدد محتوى الناتجة من إعدادات التصفية الحالية ويسمح اختيار محتوى إضافي على نحو فعال لوأو الانضمام التصفية.

أنظر أيضا

تحليل بنية بك


أداة الرسم

الملاحة: كثافات سكانية والهندسة المعمارية بك> استخدام رسومات>

أداة الرسم

إرسال التعليقات حول هذا الموضوع.

أداة رسم يسمح لخلق مجموعة متنوعة واسعة من الخطط المعمارية والمخططات. المهندسين المعماريين استخدام تقليديا مجموعة من الرسومات المختلفة لتسجيل ونقل تصميم بنية. ثنائي الأبعاد (2D) الرسوم البيانية هي الطريقة المعتادة لتوثيق والتواصل أجزاء مختلفة من النظام. أنواع الرسومات المعتادة المستخدمة في أنظمة المشاريع هي:

· نماذج الأعمال العملية والمخططات.

· الرسوم البيانية منظمة.

· الرسوم البيانية التعاون؛

· كيان العلاقة (ER) الرسوم البيانية.

· رسم تخطيطي لتدفق البيانات (في DFD)؛

· مخططات الطبقة.

· IDEF (دمج عدة من أعلاه)؛ و

· UML (دمج عدة من أعلاه).

هناك حقا لا حدود لأنواع من الرسوم البيانية التي يمكن إنشاؤها. ABACUS يحاول الموازنة بين المرونة الرسم البياني مع الحفاظ على سلامة بنية وأشكاله التمثيل.

البيئة الرسم هو كلفه ونافذة يمكن تركيبه داخل التطبيق ABACUS الرئيسي. ويتضمن هذا الإطار قماش حيث يأخذ الرسم المكان وعندما إطار الرسم مفتوح الثانية نافذة يمكن تركيبه ، إطار الاستنسل، للعرض مع مجموعة من الإستنسل الرسم. الجزء الاستنسل ديه 4 علامات التبويب: المكونات واتصالات والأشكال والروابط. يظهر قماش كما خلفية بيضاء مع خطوط الشبكة غرامة (مفيدة للتخطيط).

وتتمثل المكونات عن طريق مجموعة من الأشكال، في حين يتم رسمها اتصالات كخطوط موجهة. اتصالات نعلق على المكونات باستخدام الأدوار (أي إما مصدر أو بالوعة) على الرغم من أن هذه ليست معروضة لأسباب جمالية.

تلميح

بينما الرسوم البيانيةهي مفيدة جدا لإظهار أجزاء مختلفة من النظام، وأنها محدودة في تطويره، وهذا هو السبب يستخدم ABACUS 3D لتصور هياكل النظام المعقدة.

قد ترغب في

1. افتح ال المخططات أداة

2. إنشاء رسم تخطيطي جديد جزء من بنية بك

3. نسخ رسم تخطيطي داخل أو عبر أبنية

4. إضافة مكونات إلى رسم تخطيطي

5. إنشاء مكونات وصلات جديدة في الهندسة المعمارية الخاص بك (شكل تخطيطي) باستخدام أداة الرسم

6. حذف العناصر من رسم تخطيطي

7. نعلق والتلاعب اتصالات

8. تغيير خصائص العرض مكونات والاتصالات.

9. باستخدام وصلات في رسم بياني

10. فرض نوع الجمعيات و وجهات النظر وذلك لتقييد أنواع الرسوم البيانية التي يمكن استخلاصها.

أنظر أيضا

يعيش سكان العمارة بك | يعيش سكان العمارة يدويا | تحليل العمارة بك


عنوان الصفحة

ABACUS

إخلاء مسؤولية

Avolution بي تي واي المحدودة يجعل أية بيانات أو ضمانات فيما يتعلق بهذا الدليل، وإلى أقصى حد يسمح به القانون، ويحد من صراحة مسؤوليته عن الإخلال بأي الضمان التي قد تكون ضمنية إلى استبدال هذا الدليل مع آخر. وعلاوة على ذلك، Avolution بي تي واي المحدودة تحتفظ لنفسها بالحق في مراجعة هذه النشرة في أي وقت دون أن يترتب على الالتزام بإخطار أي شخص من المراجعة.

حقوق الطبع والنشر

حقوق الطبع والنشر 2001-2015Avolution بي تي واي المحدودة جميع الحقوق محفوظة.

العلامات التجارية

جعلت Avolution شركة خاصة محدودة كل جهد لتوفير معلومات حول العلامات التجارية في أسماء الشركات والمنتجات والخدمات المذكورة في هذا الدليل. وقد استمدت العلامات التجارية المعروضة أدناه من مصادر مختلفة.

مايكروسوفت ويندوز، والوصول، برنامج Visio، إكسل، SQL Server و إنترنت إكسبلوررهي علامات تجارية لشركة Microsoft Corporation.

لاحظ العام:

وتستخدم بعض أسماء المنتجات المستخدمة في هذا الدليل للتعريف فقط وقد تكون علامات تجارية لشركات كل منهما.

ديسمبر 2015طبعة لAvolution ABACUS النسخة 4.5.

اليدوية مراجعة 1.0

ولدت، وطبع، وملزمة في أستراليا.


ABACUS تركيب الشروط المسبقة

الملاحة: مرجع>

ABACUS تركيب الشروط المسبقة

إرسال التعليقات حول هذا الموضوع.

معلومات بخصوص برنامج Visio استيراد والتفوق استيراد / تصدير

يتطلب ABACUS أن يتم تثبيت Microsoft Office من أجل تنفيذ عمليات التفوق استيراد / تصدير و Visio استيراد. يرجى التحقق من أن Microsoft Office 2003 أو أحدثتم تثبيت بشكل صحيح. إذا كنت تواجه المزيد من المشاكل، يرجى الاتصال ب دعم Avolution .

من أجل أداء برنامج Visio استيراد والتفوق استيراد / تصدير العمليات، يستخدم ABACUS مكتب إمكانية التشغيل المتداخل جمعيات الابتدائية مايكروسوفت (بيا). ABACUS حاليا تأتي مغلفة مع المجالس اللازمة لأداء التفوق استيراد / تصدير و Visio استيراد.

معلومات بخصوص SQL خادم استيراد

يتطلب ABACUS أن مايكروسوفت SQL خادم 20052008، 2008 R2، 2012 أو 2014يتم تثبيت من أجل البدء في مشروع جديد من SQL Server. يرجى التحقق من أن مايكروسوفت SQL خادم 20052008، 2008 R2، 2012 أو 2014تم تثبيت بشكل صحيح. إذا كنت تواجه المزيد من المشاكل، يرجى الاتصال ب دعم Avolution .

أخطاء الافتتاحي متلائمة 3D

إذا عارض 3D ABACUS لا عمل لك، قد يكون في عداد المفقودين في SlimDX دايركت وقت التشغيل (تثبيت كجزء من كامل EXE ABACUS تثبيت). هذا ويمكن تحميل هنا . إذا كان لديك 64bit نسخة من ويندوز، قد تحتاج أيضا إلى تثبيت هذا .

أخطاء التحرير ABACUS عرف تقارير

يتطلب تحرير ABACUS "تقارير مخصص تقرير منشئ 3.0 ليتم تثبيتها. يتم بناؤها ABACUS ومنشئ التقرير على الإطار الصافي 4.0 مايكروسوفت، وبينما هم على حد سواء لا تتطلب الإطار الصافي 3.5 مايكروسوفت، مايكروسوفت قد تكوين منشئ التقرير MSI بشكل غير صحيح على المضي قدما فقط إذا تم تثبيت الإطار الصافي مايكروسوفت 3.5.

وفقا لذلك، Avolution لديه نسخة محررة من ملف MSI تثبيت منشئ التقرير الذي لا يتطلب الإطار الصافي 3.5 مايكروسوفت، وهذا يمكن تحميلها هنا .

الأصلي مايكروسوفت منشئ التقرير MSI يمكن تحميلها هنا . إذا لم يكن لديك بالفعل مايكروسوفت الإطار الصافي 3.5 الذي سيتطلب، يمكنك تحميل البرنامج هنا . ملاحظة: للمنشآت متعددة، وحاليا تثبيت من الإطار الصافي مايكروسوفت 3،5 من هنا قد يكون أكثر ملاءمة.


التراجع والإعادة

الملاحة: كثافات سكانية والعمارة الخاص> كثافات سكانية يدويا> خيارات إضافية>

التراجع والإعادة

إرسال التعليقات حول هذا الموضوع.

مثل العديد من التطبيقات الحديثة، ABACUS يدعم القدرة على حد سواء التراجع وإعادة تغييرات المستخدم الأخيرة التي أدخلت على مشروع مفتوح. التراجع عن التغيير الأخير، ببساطة تنشيط الأمر التراجع. التغييرات التي تم التراجع عنها يمكن إعادة بنائه من خلال تفعيل الأمر الإعادة. التغيير الأكثر التراجع مؤخرا تطبيق إعادة.

تحذير

التغييرات التراجع ليست قادرة على إعادة تطبيق إذا تم إجراء مزيد من التغييرات على المشروع منذ أن التراجع.

ملاحظة

في حين أن الغالبية العظمى من التغييرات تدعم التراجع / إعادة في الوقت الحقيقي، وبعض رسم بياني تغييرات الاستنسل، مثل إنشاء نوع-الشكل / جمعية الخط جديدة أو تغيير سمة لون الجمعيات، ليست قادرة على نقضه فورا. في هذه الحالات، يجب إغلاق الرسم التخطيطي المعدل (المشار إليها بعلامة النجمة) قبل أن يتم التراجع عنها هذه التغييرات.

التراجع والإعادة مواقع القيادة

ويمكن الوصول إلى أوامر التراجع وإعادة من ثلاثة مواقع مختلفة:

· من القائمة تحرير

· شريط الأدوات قياسي

· مفاتيح اختصار لوحة المفاتيح CTRL + Z(التراجع) و CTRL + Y(إعادته)

تلميح

والتراجع وإعادة الأزرار الموجودة على شريط الأدوات القياسي تقديم القوائم المنسدلة التي تظهر التغييرات أحدث 10 التي يمكن التراجع عنها، وقد تم إعادة بنائه على التوالي. كما أنها وسيلة سهلة لالتراجع / إعادة تغييرات متعددة في وقت واحد.


باستخدام وحدات الماكرو

الملاحة: محاكاة العمارة بك>

باستخدام وحدات الماكرو

إرسال التعليقات حول هذا الموضوع.

إذا كنت تنفيذ مهمة مرارا وتكرارا في ABACUS، يمكنك أتمتة المهام باستخدام ماكرو. وفقا لذلك، ماكرو ABACUS هو عبارة عن سلسلة من العمليات التي سجلت يمكن أن يكون ردها في أي وقت.

تسجيل ماكرو

1. اختر Tools | تسجيل ماكروأو اضغط بدلا من ذلك ALT + F10.

2. البدء في تنفيذ العمليات التي ترغب في تسجيل.

تحذير

في هذا الوقت، وهناك بعض المشكلات المعروفة مع تسجيل الماكرو. يرجى اتخاذ هذه بعين الاعتبار عند تسجيل وحدات الماكرو:

· حاليا وحدات الماكرو مجرد تسجيل ضربات المفاتيح مايكروسوفت ويندوز، الماوس تحركاتك ونقرات الماوس. ولكن نظرا لقيود مع مسجل الماكرو نفسها، وهناك بعض المفاتيح التي لا تسجل دائما. وتشمل هذه:

· [تبويب]

· [السيطرة]

· [البديل]

· [زر Esc فى الكيبورد]

· [بداية]

· [F1] إلى [F12]

· ولذلك فمن المستحسن أن تحقق من أن اختصار لوحة المفاتيح يتم تسجيلها من قبل مسجل الماكرو قبل تسجيل تسلسل كبير من الأحداث التي قد تعتمد على هذا العمل اختصار لوحة المفاتيح.

· حاليا بسبب قيود مع مسجل الماكرو، ولم يتم التعامل معها قوائم السياق بشكل صحيح من قبل ABACUS عندما يتم فتحها من قبل العمل التي سجلتها مسجل الماكرو. عند فتح قائمة السياق، يجب تنفيذ إحدى الوظائف المدرجة في قائمة السياق عبر قائمة السياق، وإلا قد تبقى قائمة السياق مفتوحة أثناء التشغيل، مما قد يؤدي إلى إجراءات غير مقصودة أو الإجراءات التي يمكن أن تتسبب في حدوث أخطاء في ABACUS.

· لاحظ أن طرق طبيعية لإغلاق قائمة السياق (مثل الضغط على [خروج] على لوحة المفاتيح، أو في أي مكان آخر على الشاشة بالضغط اليسار) قد لا يكون فعلا إغلاق قائمة السياق أثناء تشغيل ماكرو.

تلميح

في الحوارات، بدلا من استخدام نقرات الماوس، فمن المستحسن استخدام مفتاح Tab للتنقل من خلال التحكم المتوفرة ومفاتيح المؤشر لتحديد عناصر القائمة المنسدلة أو خيارات زر الراديو وشريط الفضاء لتحديد / إلغاء تحديد الاختيار مربعات.

لإيقاف تسجيل ماكرو

1. صحافة ALT + F9أو بدلا من ذلك حدد أدوات | وقف ماكرو.

2. في حفظ ماكرو واستعراض الحوار إلى موقع واختيار اسم ماكرو ABACUS (ملف .abacusmac) وانقر فوق حفظ.

ملاحظة

باستخدام أدوات| وقف ماكرووسوف تشمل هذه العملية في الماكرو المسجلة. ولذلك، فمن المستحسن أن المستخدمين أصبح بارعا في استخدام البديل + وظيفة المفتاح خيارات للعمل مع وحدات الماكرو حتى لا يشمل عمليات الكلي غير المرغوب فيها في وحدات الماكرو أنفسهم.

تلميح

كما كانت وحدات الماكرو غير قابلة للتحرير حاليا فمن المستحسن لتسجيل المهام طويلة على شكل سلسلة من وحدات الماكرو منفصلة باستخدام مفتاح Alt + F10 / البديل + F9 "أزواج".

لتشغيل ماكرو المسجلة

1. اختر Tools | تشغيل ماكروأو اضغط بدلا من ذلك ALT + F8.

2. في استعراض الحوار ماكرو مفتوحة إلى موقع واختيار اسم ماكرو ABACUS (ملف .abacusmac) وانقر فوق فتح.

تحذير

عند فتح ماكرو ABACUS، إذا كنت انقر نقرا مزدوجا على ملف ماكرو من مربع حوار الاستعراض لفتحه، مسجل الماكرو قد عقد على الزر الأيسر للماوس في حالة الأيسر النقر حتى سجلت اليسرى مزدوجا فوق تجاوز هذه الحالة.

ملاحظة

سرعة تشغيل الماكرو يمكن تعيين في علامة التبويب العامة، في إطار أدوات| خياراتإما عادي (افتراضي)، سريعة أو بطيئة. كلا لا ينصح سرعات القراءة السريعة والبطيئة لأنها سوف إعادة وحدات الماكرو المسجلة في حوالي 100 مرة و1 / 100th في الوقت الحقيقي، على التوالي. وسرعة التشغيل العادية لا يزال اعادتها الماكرو ما يقرب من 30٪ أسرع من سرعة تسجيلها لذلك فمن المستحسن أثناء تسجيل وقفة لفترة قصيرة بعد أي مهام معالجة مطولة لضمان أنه في تشغيل لا يتم تنفيذ العملية التالية أمام مهمة معالجة ديها منجز.

إلى التوقف عن اللعب ماكرو المسجلة

1. صحافة ALT + F9.


عرض رسم بياني 3D

الملاحة: تحليل بنية بك> الرسوم البيانية 3D>

عرض رسم بياني 3D

إرسال التعليقات حول هذا الموضوع.

ABACUS يسمح لك لعرض العمارة ك عرض 3D حيث ترتبط مكونات وخصائص اتصال مع الألوان والأشكال والأحجام.

لعرض وجهة نظر 3D الهندسة المعمارية بك

1. ضمان لديك فتح ملف ABACUSتحتوي بك العمارة بالسكان.

2. توسيع عدد المشاهداتفرع الشجرة.

3. توسيع 3Dفرع الشجرة.

4. انقر نقرا مزدوجا فوق التصور الذي تريد فتحه.

- أو -

1. ضمان لديك فتح ملف ABACUSتحتوي بك العمارة بالسكان.

2. اختار أدخل| 3Dأو انقر فوق زر شريط الأدوات.

3. فتح موجودالتصور (.abacus3d)

- أو -

1. ضمان لديك فتح ملف ABACUSتحتوي بك العمارة بالسكان.

2. اختار أدخل| 3Dأو انقر فوق زر شريط الأدوات.

3. إنشاء التصور الجديد:

· حدد هندسة معماريةكنت ترغب في عرض من القائمة المنسدلة.

· حدد مكوناتو روابطتريد أن تدرج في الرسم البياني من نافذة اختيار عنصر قياسي .

· الألوان المنتسبين والأشكال والأحجام مع أنواع المكوناتو الممتلكات.

· الألوان والأشكال مع زميلة أنواع الاتصالو الممتلكات.

لتصدير طريقة عرض 3D

1. ضمان لديك فتح عرض 3D القائمة.

2. في القوائم المنسدلة لعرض 3D لتحديد ملف | تصدير...واختار نوع الموقع وملف لملف التصور (.abacus3d، .vrml أو .html).

3. انقر حفظ.

أنظر أيضا

تحليل بنية بك | الملاحة في 3D | أداة المخططات


عرض مخطط فقاعة

الملاحة: تحليل بنية بك> الرسوم البيانية مخصص>

عرض مخطط فقاعة

إرسال التعليقات حول هذا الموضوع.

مخطط فقاعة يسمح لك لمقارنة ما يصل الى 5 الأبعاد (أي X، Y، حجم فقاعة / دائرة نصف قطرها، لون فقاعة وفقاعة لون الحدود) في عرض واحد.

لعرض الرسم البياني فقاعة

1. ضمان لديك ملف ABACUS مفتوحة .

2. اختار أدخل| الرسم البياني| ال المخططات المخصصةعلامة التبويب | فقاعة الرسم البياني.

3. في أبنيةالقسم وضع علامة في أبنية (إن وجدت) التي ترغب في رسم، انقر فوق التالى.

4. حدد مكوناتو روابطالتي تريدها في الرسم البياني (إن وجدت) من نافذة اختيار عنصر قياسي ، ثم انقر فوق التالى.

5. حدد X-محورالملكية، ثم انقر فوق التالى.

ملاحظة

فقط صحيح، عشري، تاريخ / وقت، منطقية وخصائص قائمة يمكن استخدامها للمحور X. وعلاوة على ذلك، يتم رسم من اليسار إلى اليمين صحيح، عشري والتاريخ / الوقت خصائص على طول محور تحجيم وفقا لقيمة العقار، ومع ذلك، يتم رسم منطقية وقائمة خصائص ببساطة من اليسار إلى اليمين في الترتيب الدقيق (أو في ترتيب عكسي إذا تم التحقق من الخيار لعكس النظام) المحددة للخاصية بغض النظر عن قيمهم. مثلا منخفض | المتوسط ​​| ارتفاع أو 1، 2، 4، 8، 16.

6. حدد Y المحورالملكية، ثم انقر فوق التالى.

ملاحظة

فقط صحيح، عشري، تاريخ / وقت، منطقية وخصائص قائمة يمكن استخدامها للمحور Y. وعلاوة على ذلك، يتم رسم صحيح، عشري والتاريخ / الوقت خصائص أسفل إلى أعلى على طول محور تحجيم وفقا لقيمة العقار، ومع ذلك، يتم رسم منطقية وقائمة خصائص ببساطة من أسفل إلى أعلى في الترتيب الدقيق (أو في ترتيب عكسي إذا تم التحقق من الخيار لعكس النظام) المحددة للخاصية بغض النظر عن قيمهم. مثلا منخفض | المتوسط ​​| ارتفاع أو 1، 2، 4، 8، 16.

7. حدد حجم فقاعة / دائرة نصف قطرهاالملكية، ثم انقر فوق التالى.

ملاحظة

فقط صحيح، عشري، منطقية وخصائص قائمة يمكن استخدامها لفقاعة حجم / دائرة نصف قطرها. وعلاوة على ذلك، صحيح وخصائص العشرية يؤدي إلى حجم فقاعة / دائرة نصف قطرها تحجيمها وفقا لقيمة العقار، ولكن منطقية وقائمة خصائص تؤدي إلى زيادات متساوية خطوة من فقاعة حجم / نصف قطر في الترتيب الدقيق (أو في ترتيب عكسي إذا يتم التحقق من الخيار لعكس النظام) المحددة للخاصية بغض النظر عن قيمهم. مثلا منخفض | المتوسط ​​| ارتفاع أو 1، 2، 4، 8، 16.

8. حدد إما لون فقاعة ثابت أو ربط خاصية مع لون فقاعة، ثم انقر فوق التالى.

ملاحظة

فقط صحيح، عشري، منطقية وخصائص قائمة يمكن استخدامها للون فقاعة. وعلاوة على ذلك، صحيح وخصائص العشرية يسفر عن لون فقاعة داخل النطاق المختار تحجيمها وفقا لقيمة العقار، ولكن منطقية وقائمة خصائص تؤدي إلى زيادات متساوية خطوة من لون فقاعة داخل النطاق المختار في الترتيب الدقيق المحددة لل الملكية بغض النظر عن قيمهم. مثلا منخفض | المتوسط ​​| ارتفاع أو 1، 2، 4، 8، 16.

9. حدد إما لا لون الحدود فقاعة أو ربط خاصية مع لون الحدود فقاعة، ثم انقر فوق إنهاء.

ملاحظة

فقط صحيح، عشري، منطقية وخصائص قائمة يمكن استخدامها للون الحدود فقاعة. وعلاوة على ذلك، صحيح وخصائص العشرية يؤدي إلى لون الحدود فقاعة داخل النطاق المختار تحجيمها وفقا لقيمة العقار، ولكن منطقية وقائمة خصائص تؤدي إلى زيادات متساوية خطوة من لون الحدود فقاعة داخل النطاق المختار في الترتيب الدقيق المحدد للخاصية بغض النظر عن قيمهم. مثلا منخفض | المتوسط ​​| ارتفاع أو 1، 2، 4، 8، 16.

التخطيط الفقاعي

لحفظ الرسم البياني فقاعة

ملاحظة

لا يمكن حفظ المخططات فقاعة إذا كانت تحتوي على مكونات والاتصالات، وكلها يجب أن تكون من بنية واحدة ضمن المشروع الحالي فقط.

1. تأكد من أن لديك مخطط جديد أو موجود فقاعة فتحويمكنك إجراء التغييرات اللازمة.

2. في شريط الأدوات رسم انقر على أقصى اليسار حفظ الرسم البيانيزر لحفظ الرسم البياني وأي تغييرات التنسيق.

3. في اسم الرسم البيانيالحوار الذي يظهر إدخال اسم للتخطيط فقاعة والصحافة حسنا.

لتصدير التخطيط الفقاعي

1. ضمان لديك فتح الرسم البياني فقاعة الحالية.

2. في شريط الأدوات انقر على الرسم البياني 2 من اليسار حفظ باسم BMPاختار زر وموقع للتخطيط.

3. انقر حفظ.

أنظر أيضا

تحليل بنية بك


عرض مخطط مساحة القدرة

الملاحة: تحليل بنية بك> الرسوم البيانية مخصص>

عرض مخطط مساحة القدرة

إرسال التعليقات حول هذا الموضوع.

رسم بياني الفضاء القدرة يسمح لك لعرض ما إذا كان بنية بك يفي قدرة النظام المطلوب فيما يتعلق بخواص التي تم تحديدها خلال عملية تحليل متطلبات النظام.

لعرض الرسم البياني الفضاء القدرة

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان، والتي لديك تقييمالعمارة الخاصة بك.

2. اختار أدخل| الرسم البياني| المخططات المخصصة| الفضاء القدرة. (ال الرسم البياني الفضاء القدرة على تكوينسوف الحوار عرض).

3. في أبنيةالقسم وضع علامة في أبنية كنت ترغب في الرسم البياني، ثم انقر فوق التالى.

4. في الممتلكاتمنطقة، وضع علامة في الخصائص المعمارية التي ترغب مدرجة في محاور المخطط.

5. في قدرةمنطقة، على كل الممتلكات المدرجة من الخطوة السابقة، حدد ما إذا كان أي الحد الأدنى أو حدود القدرة القصوى موجودة وقيم تلك الحدود. القيم الافتراضية هي القيم الدنيا والقصوى تقييمها للأبنية أو الهدف للخاصية إذا كان قد تم تعيينه.

لتصدير الرسم البياني الفضاء القدرة

1. ضمان أن يكون لديك القائمة القدرة على الرسم البياني الفضاء فتح.

2. في شريط الأدوات رسم انقر على أقصى اليسار حفظ باسم BMPاختار زر وموقع للتخطيط.

3. انقر حفظ.

أنظر أيضا

تحليل بنية بك | عرض مخطط زمن الاستجابة


التقارير الموحدة

الملاحة: الإبلاغ عن الهندسة المعمارية بك>

التقارير الموحدة

إرسال التعليقات حول هذا الموضوع.

ABACUS " معيار تسمح التقارير التي للحصول على قائمة من المكونات والاتصالات في واحد أو أكثر من أبنية الخاص بك. ويتضمن التقرير كافة المعلومات المتعلقة مكونات وصلات مختارة، بما في ذلك معلومات عن العنصر أو مكان الاتصال في التسلسل الهرمي، نوع، والمعايير والوصف والممتلكات ومرفقاتها.

ملاحظة

محتوى التقرير غيرشكليمن خلال الحوار خيارات تقرير موضح أدناه، ومع ذلك، رس معرفة مزيد من المعلومات حول كيفية إنشاء عرف شكلي تماما تقاريرباستخدام ABACUS تقارير مخصصة، من فضلك الرجوع إلى الموضوع هنا أو اتصال دعم Avolution .

لعرض معيار تقرير

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان(الصورة).

2. اختار أدخل| تقرير معيارأو انقر على إنشاء تقرير ستاندرد زر في شريط الأدوات. ال تقرير التكوينسيتم عرض نافذة.

نافذة تكوين تقرير

3. حدد أبنية, مكوناتو روابطالتي تريدها في التقرير من نافذة تكوين تقرير.يرجى الرجوع إلى عنصر اختيار قياسي هنا موضوع للمساعدة.

4. الآن انقر على خياراتزر و خيارات تقريرسوف نافذة عرض.

خيارات تقرير نافذة

5. يمكنك اختيار عرض صفحة جديدة لكل عنصر، ال اطبع تاريخ, طباعة الوقت, أرقام الصفحاتوعما إذا كان ل تشمل العنوان في رأسالتقرير بوضع علامة / unticking خانات الاختيار ذات الصلة. قد تحتاج أيضا إلى تخصيص عنوان ومؤلف كتاب عن طريق تحرير عنوان التقريرو مؤلف مربعات النص. يمكنك أيضا اختيار المحتوى الذي يتم عرضه على تقرير موقوتة / unticking خانات الاختيار تحت تقرير المحتوىقسم من النافذة. بمجرد الانتهاء انقر على حسنا.

6. الآن انقر على إنهاءفي إطار تكوين التقرير.

لتفسير تقرير للعرض

المثال تقرير ولدت مع شرح موجز

للتنقل عبر صفحات التقرير، انقر على الرموز [image] تقع على شريط الأدوات في أعلى الزاوية اليسرى من الشاشة.

ملاحظة

انت تستطيع حفظ التقرير إلى أشكال مختلفة بالضغط على تصدير رمز التقرير [image] تقع في شريط الأدوات. يمكنك اختيار لتصدير في الأشكال التالية: تفوق, PDFو كلمة. الرجاء حفظ التقرير في الموقع المطلوب لاستخدامها لاحقا. إذا تم إجراء تغييرات على الهندسة المعمارية في مرحلة لاحقة، وسوف يكون التقرير الجديد إلى أن يتم إنشاء لتعكس التغييرات.

أنظر أيضا

تحليل بنية بك


عرض مخطط زمن الاستجابة

الملاحة: تحليل بنية بك> الرسوم البيانية مخصص>

عرض مخطط زمن الاستجابة

إرسال التعليقات حول هذا الموضوع.

رسم بياني وقت استجابة يسمح لك بمشاهدة ما إذا كان يتم معالجة اتصالاتك بمعدل المطلوب (أي في غضون المهلة التي حددوها).

لعرض الرسم البياني وقت الاستجابة

1. ضمان لديك ملف ABACUS مفتوحة تحتوي بك العمارة بالسكان، والتي لديك تقييمالعمارة الخاصة بك.

2. اختار أدخل| الرسم البياني| المخططات المخصصة| وقت الاستجابة. (ال استجابة الوقت مخطط التكوينسوف الحوار عرض).

3. من أبنيةالقائمة المنسدلة، حدد العمارة كنت ترغب في رسم.

4. في روابطمنطقة، وضع علامة في الاتصالات التي ترغب المدرجة في الرسم البياني.

5. ال نوع نطاقمنطقة، حدد خطيإذا كنت ترغب في المحور الرأسي (زمن الاستجابة) ليتم عرضها كما تقدم خطي - يتم تخصيص كل جزء من الوقت على حصة متساوية من المحور. اختار وغاريتميإذا كنت تريد أن يظهر على شكل متوالية لوغاريتمي - كل جزء من محور يمثل فترات أطول من الزمن على نحو متزايد في مستوى اعلى محور تذهب. (يتم تحديد نسبة الزيادة بها قاعدةقمت بتحديد).

استجابة الرسم البياني وقت الرأسي مقياس محور

لتصدير الرسم البياني وقت الاستجابة

1. ضمان أن يكون لديك القائمة زمن الاستجابة الرسم البياني فتح.

2. في شريط الأدوات رسم انقر على أقصى اليسار حفظ باسم BMPاختار زر وموقع للتخطيط.

3. انقر حفظ.

أنظر أيضا

تحليل بنية بك | عرض مخطط مساحة القدرة


عرض مؤامرة مبعثر من أبنية بك تطورت

الملاحة: تحليل بنية بك> الرسوم البيانية مخصص>

عرض مؤامرة مبعثر من أبنية بك تطورت

إرسال التعليقات حول هذا الموضوع.

مرة واحدة وقد تطورت بنية ومحددة الأهداف، وعندئذ يمكن تصور وبالمقارنة مع الهندسة المعمارية الأصلية باستخدام المصفوفات مخطط التشتت. ويعرض هذا القسم كيفية إنشاء وفهم خصائص مصفوفة مخطط التشتت.

لعرض مصفوفة مخطط التشتت من أبنية بك تطورت

1. ضمان لديك ملف ABACUS مفتوحة .

2. ضمان لديك تطورتو حدد الأهدافللهندسة المعمارية الخاصة بك على النحو المبين في تطور فن العمارة الخاص

3. اختار أدخل| الرسم البياني| ال المخططات المخصصةعلامة التبويب | مصفوفة مخطط التشتت.

4. اضغط على إنهاء زر.

5. ال مؤامرة مبعثرمع تطور المعرفة من أبنية والأهداف سيتم عرضها.

ملاحظة

معارض المنطقة على الجانب الأيسر من مصفوفة مخطط التشتت إعدادات مصفوفة مخطط التشتت عرضها. ويشمل هذا الهيكل الذي تم تطورت (في هذه الحالة "ABC المحدودة كما هو 2010") وكذلك الأهداف التي تم وضعها لذلك الهندسة المعمارية. ستلاحظون أن الأهداف التي لديها علامة التجزئة بجانبها وممثلة X و Y محاور مصفوفة مخطط التشتت (على سبيل المثال KPI- تكلفة، KPI - الجودة وKPI - وقت). تستطيع إلغاء تحديد هذه الأهداف في أي لحظة من الزمن لإخراجها من المصفوفة مخطط التشتت.

النقاط الزرقاء التي تظهر على قطعة الخاص بك في المصفوفة تمثل قيمة تطبيع، على النحو الذي تحدده قيمة أفضل وأسوأ (المبين في إطار وضع أهداف للهندسة المعمارية بك تطورت ). وتتمثل هذه القيم في الفضاء جودة.

تتم مقارنة اثنين من أهداف محددة ضد بعضها البعض في مصفوفة مخطط التشتت ويتم تكرار العملية حتى يتم مقارنة كل أهداف (على سبيل المثال المؤامرة الأولى من المصفوفة في الرسم البياني أعلاه يقارن KPI - التكلفةالهدف مع KPI - الجودة هدف. والثاني هو كلفة ضد مرة والمؤامرة الأخيرة جودة ضد مرة. يتم عرض التسميات هدف ذات الصلة في أعلى ويمين أو كل صف من المؤامرات.).

6. حدد أبنيةزر الراديو إذا كنت ترغب في عرض مقاييس للأبنية الفردية.

7. حدد التطوراتزر الراديو إذا كنت ترغب في عرض التغييرات طبيعية من الهيكل الأصلي (على سبيل المثال كما هو 2010) إلى بنية تطورت (ق) (على سبيل المثال إلى أن 2011 - إستراتيجية ألف وإلى أن 2011 - استراتيجية B).

أنظر أيضا

تحليل بنية بك | عرض مخطط زمن الاستجابة | عرض قطعة نجم أبنية بك تطورت | تطور فن العمارة الخاص


عرض مخطط قياسي

الملاحة: تحليل بنية بك> الرسوم البيانية القياسية>

عرض مخطط قياسي

إرسال التعليقات حول هذا الموضوع.

وتشمل المخططات ABACUS 'القياسية الخط، بار، عمود، المنطقة، مبعثر، فطيرة، منحنى، باريتو، خطوة، والسطح، والرادار، المكعب، دونات، الهرم، الكنتورية والخرائط منطقة منحنى. بمجرد اختيار نوع التخطيط الذي تريد، والباقي من عملية عرض كل من هذه المخططات هو نفسه.

لعرض تخطيط قياسي للهندسة المعمارية الخاصة بك

1. ضمان لديك فتح ملف ABACUSتحتوي بك العمارة بالسكان، والتي لديك تقييمالعمارة الخاصة بك.

2. اختار أدخل| الرسم البيانيأو انقر فوق زر شريط الأدوات. ال الرسوم البيانيةسيتم عرض نافذة.

الرسوم البيانية النافذة

3. حدد نوع التخطيط الذي تريده وتعيين خيارات التخطيط، ثم انقر فوق التالى.

خيارات الرسم البياني

o مكدسةسوف تظهر العلاقة بين العناصر الفردية إلى الكل. يمكنك استخدام الرسم البياني مكدسة عندما كنت تخطط لدينا سلسلة بيانات متعددة (أي خصائص متعددة) وعندما تريد التأكيد على المجموع.

o مكدسة 100٪ومقارنة نسبة مساهمة كل قيمة وبين المجموع عبر الفئات. يمكنك استخدام 100٪ الرسم البياني مكدسة عندما كنت تخطط لديك عدة سلاسل البيانات (أي خصائص متعددة) وكنت أريد أن أؤكد المساهمات في العموم، لا سيما إذا كان مجموع هو نفسه بالنسبة لكل عنصر.

o 3D الرسم البيانيببساطة عرض نقاط البيانات في شكل 3-D لعلم الجمال. إذا كنت ترغب في عرض سلسلة البيانات على طول البعد 3 / ض محور ثم استخدام الخيار السلسلة العنقودية هو موضح أدناه.

o سلسلة التي كتبها الملكيةسيتم عرض سلسلة بيانات عن كل الممتلكات التي تم تحديدها في نهاية المطاف. إذا كان هذا لم يتم التحقق منه بعد ذلك سوف تصبح خصائص الفئات وسوف تكون سلسلة البيانات لكل عنصر الذي تم تحديده.

o الرسم البياني تدويروتناوب على الرسم البياني 90 درجة في اتجاه عقارب الساعة التي تتبادل x و y محاور. يتوفر هذا الخيار فقط للخطوط، والخطوة مكعب الرسوم البيانيةوهي مفيدة بشكل خاص لصنع الخرائط المعلم كما هو موضح في الطرف الثاني أدناه. ملاحظة: العمود والرسوم البيانية بار بالفعل "استدارة" إصدارات بعضها البعض.

o السلسلة العنقوديةسيتم عرض سلسلة بيانات متعددة على طول البعد 3 / ض محور. هذا الخيار متاح فقط لعمود، بار ومكعب الرسوم البيانيةوهي مفيدة بشكل خاص لصنع الخرائط أسلوب جانت كما هو موضح في تلميح الأول أدناه.

تلميح

يمكنك إنشاء مخطط جانتمع قضبان أفقية تظهر الوقت / التاريخ خصائص العناصر المختلفة عن طريق اختيار نوع شريط الرسم البياني ثم تحديد الخيار السلسلة العنقودية.وعلاوة على ذلك، مرة واحدة تم إنشاؤها، ويمكن إجراء أقصى اليسار شريط على الرسم البياني للغير مرئية من قبل تلوين أنه أبيض بالنقر بزر الماوس الأيمن فوق أحد البارات، واختيار اللون من القائمة التي تظهر واختيار من أعلى إلى اليسار لون من لوحة. بالإضافة إلى ذلك الحدود لأقصى اليسار شريط ويمكن إجراء 'غير مرئية' بالنقر بزر الماوس الأيمن فوق أحد البارات، واختيار خصائص ... وعلى علامة التبويب سلسلة في مربع الحوار الذي يظهر تغيير تأثير الحدود إلى بلا واللون إلى الأعلى لون -left من لوحة.

تلميح

يمكنك إنشاء معلم الرسم البيانيمع الأشكال صغيرة تظهر الوقت / التاريخ خصائص العناصر المختلفة عن طريق اختيار نوع الرسم البياني مكعب ومن ثم اختيار الرسم البياني تدوير والخيارات السلسلة العنقودية.وعلاوة على ذلك، مرة واحدة تم إنشاؤها، مكعبات يمكن تغيير إلى أشكال أخرى بالنقر بزر الفأرة الأيمن واحدة من المكعبات في سلسلة بيانات معينة، وتحديد خصائص ... وعلى علامة التبويب سلسلة في مربع الحوار الذي يظهر تغيير شريط إما اسطوانة أو مخروط . ملاحظة: يمكن أن تستخدم أيضا قيمة العرض الفجوة إلى 'تقليص' الرموز على الرسم البياني للحد من التداخل، وارتفاع عدد أقل تداخل سيكون هناك.

4. في أبنيةالقسم وضع علامة في الهندسة المعمارية / ثانية كنت ترغب في رسم خصائص مستوى العمارة ل، ثم انقر فوق التالى.

ملاحظة

اختيار خصائص مستوى العمارة الخطوة اختيارية تماما ويجب أن يستعمل فقط عندما تريد رسم صراحة خصائص مستوى العمارة نفسها.لا يحتاج بنية التي سيتم اختيارها لثم تشمل عنصر أو اتصال خصائص في الخطوة التالية.

5. حدد مكوناتو روابطالتي تريدها في التخطيط من نافذة اختيار عنصر قياسي ، ثم انقر فوق التالى.

6. حدد الممتلكاتالتي تريدها في الرسم البياني وانقر إنهاء.

خيارات الرسم البياني

o تشمل الخصائص القياسية سوف تظهر الخصائص الموروثة من المعايير المتاحة للاختيار.

o خصائص الإجمالية سوف عد الفرق بين القيم سلسلة ورسم تلك النتائج بدلا من القيم الفردية أنفسهم.ويتوفر هذا الخيار فقط إذا تم اختيار السلسلة التي خيار الملكية في الخطوة 3 أعلاه.

تلميح

الخصائص المتوفرة للرسم تعتمد على العناصر التي تختارها.

لحفظ الرسم البياني

ملاحظة

لا يمكن حفظ المخططات إذا كانت تحتوي على مكونات والاتصالات، وكلها يجب أن تكون من بنية واحدة ضمن المشروع الحالي فقط.

1. تأكد من أن لديك مخطط جديد أو موجود فتحويمكنك إجراء التغييرات اللازمة.

2. في شريط الأدوات رسم انقر على أقصى اليسار حفظ الرسم البيانيزر لحفظ الرسم البياني وأي تغييرات التنسيق.

3. في اسم الرسم البيانيالحوار الذي يظهر إدخال اسم للتخطيط والصحافة حسنا.

لتصدير الرسم البياني

1. ضمان أن يكون لديك القائمة الرسم البياني فتح.

2. في شريط الأدوات انقر على الرسم البياني 2 من اليسار حفظ باسم BMPاختار زر وموقع للتخطيط.

3. انقر حفظ.

أنظر أيضا

تحليل بنية بك | عرض مخطط زمن الاستجابة | عرض مخطط مساحة القدرة


عرض قطعة نجم أبنية بك تطورت

الملاحة: تحليل بنية بك> الرسوم البيانية مخصص>

عرض قطعة نجم أبنية بك تطورت

إرسال التعليقات حول هذا الموضوع.

مرة واحدة وقد تطورت بنية ومحددة الأهداف، وعندئذ يمكن تصور وبالمقارنة مع الهندسة المعمارية الأصلية باستخدام قطع نجوم. ويعرض هذا القسم كيفية إنشاء ومعالجتها مؤامرة نجوم.

لمشاهدة مؤامرة نجم أبنية بك تطورت

1. ضمان لديك ملف ABACUS مفتوحة .

2. ضمان لديك تطورتو حدد الأهدافللهندسة المعمارية الخاصة بك على النحو المبين في تطور فن العمارة الخاص

3. اختار أدخل| الرسم البياني| ال المخططات المخصصةعلامة التبويب | نجمة مؤامرة.

4. اضغط على إنهاء زر.

5. ال نجمة مؤامرةمع أبنية تطورت وتعيين سيتم عرض الأهداف. ملاحظة: قد يتم تعديل أوضاعها محاور المؤامرة نجمة بالنقر والسحب المحاور إلى منطقة أخرى داخل حدود الفضاء نجم نوعية المؤامرة.

ملاحظة

معارض المنطقة على الجانب الأيسر من مؤامرة نجمة إعدادات مؤامرة نجوم المعروضة. ويشمل هذا الهيكل الذي تم تطورت (في هذه الحالة "ABC المحدودة كما هو 2010") وكذلك الأهداف التي تم وضعها لذلك الهندسة المعمارية. ستلاحظون أن الأهداف التي لديها علامة التجزئة بجانبها وممثلة على النحو محاور مؤامرة نجوم (على سبيل المثال KPI- تكلفة، KPI - الجودة وKPI - وقت). تستطيع إلغاء تحديد هذه الأهداف في أي لحظة من الزمن لإخراجها من المؤامرة نجوم.

في "النقاط" الحمراء والخضراء التي تظهر على مؤامرة نجمك تمثل قيمة تطبيع، على النحو الذي تحدده قيمة أفضل وأسوأ (المبين في إطار وضع أهداف للهندسة المعمارية بك تطورت ) لبنية رفيعة المستوى المحدد وأي تطورات منه. وتتمثل هذه القيم في الفضاء جودة.

كما هو مبين في الصورة أعلاه، فمن الواضح للعيان أن الهيكل الأصلي (كما هو 2010) والفقراء كلفة، في حين أن الخيار تطورت الأول (إلى أن 2011 - الاستراتيجية A) تحركت داخل مساحة الجودة لتحسين كلفة, الجودة والوقتأهداف. الخيار بدلا من ذلك، تطورت الثانية (إلى أن 2011 - استراتيجية B)، في حين تحسنت أيضا كلفة حجم التحسن هو أقل من ذلك إستراتيجية A لكن كلا من الجودة والوقت الأهداف قد تحسنت أكثر من مع استراتيجية A.في هذه الحالة مهندس معماري قد أختر استراتيجية A خلال استراتيجية Bكما توصيتهمومزيد من التطور هذا الخيار (ليكون 2012 - الاستراتيجية A).

6. إلغاء تحديد عرض التطوراتخانة الاختيار لإخفاء الخط (ق) التي تمثل التطور (ق) بين الأصلي (على سبيل المثال كما هو 2010) وتطورت (على سبيل المثال إلى أن 2011 - استراتيجيةA) الهندسة المعمارية (ق).

7. حدد مشاهدة العصيخانة الاختيار لعرض حجم النسبي لكل سمة الجودة (الأهداف التي تم تحديدها على كل محاور) لكل الهندسة المعمارية.

8. حدد إظهار الأسماء العمارةخانة الاختيار إذا كنت تريد أن أسماء الهيكل الأصلي وتطورت زائر لتظهر على مؤامرة نجوم.

أنظر أيضا

تحليل بنية بك | عرض مخطط زمن الاستجابة | عرض مصفوفة مخطط التشتت من أبنية بك تطورت | تطور فن العمارة الخاص


تحليل بنية بك

الملاحة: تحليل بنية بك>

تحليل بنية بك

إرسال التعليقات حول هذا الموضوع.

وبمجرد الانتهاء من السكان (واختياريا محاكاة) العمارة الخاص بك، فإنك تكون مستعدا لاستخدام ABACUS لتحليلها. من خلال تحليل ذلك، يمكنك تحديد ما إذا كان سيجتمع العمارة احتياجاتك الخاصة بك.

يمكنك تحليل بنية بك في مجموعة متنوعة من طرق مختلفة:

· رسم بياني

· 3D رأي

· الرسوم البيانية القياسية (فطيرة، خط، العمود، وبار، الخ)

· المخططات المخصصة ( وقت الاستجابة , الفضاء القدرة , مؤامرة نجمة , مخطط التشتت مصفوفة و التخطيط الفقاعي )

· هندسة معمارية مهرجان دبي السينمائي الدولي

ملاحظة

عند إنشاء رسم تخطيطي، 3D رأي، تقرير أو تخطيط قياسي، و نافذة اختيار عنصر قياسي يستخدم لتحديد العناصر التي تريد عرضها.

أنظر أيضا

يعيش سكان العمارة بك | محاكاة العمارة بك | ال المخططات أداة


ما هي الهندسة المعمارية؟

الملاحة: مقدمة في ABACUS>

ما هي الهندسة المعمارية؟

إرسال التعليقات حول هذا الموضوع.

الهندسة المعمارية هي مجردة مفهوم- ليس المادية شيء. انها وصفا غني وشامل أو فهم بنية النظام - التقاط المكونات وكيف كنت متصلا (التفاعل). لأن مفهوم العمارة هي حتى يشمل الجميع، فمن الأساسي أن تكلفة، وتوافر، evolvability، والانفتاح، وأداء النظام. A العمارة الصوت هو شرط مسبق لنظام الصوت.

في ABACUS، أنت نموذج العمارة الخاصة بك. للبساطة، ونحن نسمي هذا النموذج المعماري والهندسة المعمارية.

ويوضح الرسم البياني أدناه بنية نموذجية ل 5مكونات (في التسلسل الهرمي) ترتبط بها 2 الاتصالات. التسميات تشير إلى أسماء بالنظر إلى أجزاء مختلفة من الهندسة المعمارية في ABACUS.

A العمارة بسيطة

وتعتبر ABACUS كل هذه الأمور لتكون جزءا من الهيكل:

· مكوناتتمثل كيانات العمارة بك الذي يمكن وصفه بأنه "الأشياء". لشركة التأمين، ومكونات قد تكون أنظمة لمعالجة السياسات، والمطالبات، والمدفوعات، والإيصالات.

· روابطتمثل العلاقات بين هذه المكونات. على سبيل المثال، في إحدى شركات التأمين، يتم إنشاء إيصالات لسياسات صحيحة، وادعاءات ضد سياسات صحيحة، ومطالبات صحيحة يؤدي إلى المدفوعات. عند التفكير معماريا - وخاصة عند استخدام ABACUS - وصلات لا تقل أهمية عن المكونات، ويتم التعامل معها بطريقة متطابقة تقريبا.

· كل شيء في شجرة يمكن أن يكون الممتلكات. الخصائص هي أشياء مثل الطريقة التي تتطلب النظام الخاص بك لأداء، وعدد من الأسطر من التعليمات البرمجية لديها، ونسبة هذه السطور التي هي التعليقات، الخ تعتبر ABACUS كل هذه الأمور لتكون جزءا من الهيكل.

· باستخدام التسلسلات الهرمية (أي. المكونات الفرعية و وصلات فرعية)، يمكنك إخفاء المعلومات ودي يؤلف العمارة الخاصة بك. نموذج معماري ABACUS مرنة للغاية. أي مكون على أي مستوى يمكن أن تكون ذات صلة إلى أي مكون آخر في أي مستوى آخر من قبل أي اتصال على أي مستوى.

· التعلقهي العملية التي مكونات الموانئ لا بد أن اتصالالأدوار. الموانئ و الأدوار هي واجهةsبين مكونات والاتصالات. يتم استخدامها لتوصيل وصلات إلى المكونات. اتصالات لديها مصدر وبالوعة دور(تيسير تدفق البيانات من العنصر المصدر إلى عنصر بالوعة)والمفاهيمية، مكونات لها الموانئ. لالبساطة، ولكن في ABACUS لا تظهر الموانئ المكون، وترفق الأدوار اتصال مباشرة الى مكونات أنفسهم.

· مكونات والاتصالات هي من بعض اكتب. هذا هو أساسا لأغراض التصنيف. على سبيل المثال السياسات والمطالبات، والمدفوعات، والإيصالات هي مكونات من نوع 'النظام'. سياسات صحيحة، مطالبات صحيحة، وما هي اتصالات من نوع 'عملية'. نوع تعيينه لعنصر أو اتصال يوفر نموذجا لخصائص ومعايير لديه. على سبيل المثال، وهو نوع مكون ملقم قد يكون 'جعل و الموديل " معياروالخاصية عنوان IP. على عكس أدوات جامدة أخرى مع العلائقية قاعدة البيانات الأساسية (RDB) في نهاية العام، في ABACUS يمكنك إنشاء بحرية أنواع جديدة الخاصة وتعيين مجموعات خاصة بك من خصائص ومعايير لهم.

· المكتبات القياسية من الخصائص يمكن تحديد وتعيين إلى أي شيء آخر في الهندسة المعمارية. ومن المعروف أن هذه المكتبات كما المعايير. باستخدام المعايير، تحتاج فقط إلى جمع خصائص أنظمة محددة - الخصائص القياسية هي هناك بالفعل. على سبيل المثال يمكن تعيين خصائص الأداء القياسية من Microsoft Windows 2000 إلى أي مكونات تستخدم نظام التشغيل مايكروسوفت ويندوز 2000.

أنظر أيضا

كيفية بنية ممثلة في ABACUS؟ | ماذا ABACUS تفعل؟ | كيف نفعل ذلك (لمحة عامة) | خلق نوع جديد


العمل مع المؤسسة ملقم

الملاحة: الإدارة>

العمل مع المؤسسة ملقم

إرسال التعليقات حول هذا الموضوع.

ABACUS المؤسسة الخادم على حد سواء "غير تأمين" النهج التعاوني، ولكن واحدة 'قطع' أيضا. ABACUS هو "عدم تأمين 'لأنه لا إجبار الملف المراد تأمينه من قبل مستخدم واحد لذلك ليتم تحديثه. كل مستخدم لديه من النسخة المحلية الخاصة من الملف، وأنها إجراء تغييرات وحفظ الملفات الخاصة بهم، وتسجل هذه التغييرات وتخزينها لحين يرغب المستخدم لارتكابها إلى الملقم.

ABACUS هو "قطع" بمعنى أنك لا تحتاج أن تكون متصلا إلى ملقم أو تحتاج إلى الوصول إلى الشبكة في حين تعمل على الملف. ABACUS يتطلب الوصول إلى الخادم فقط عند تنفيذ عمليات مثل إنشاء ملف، أو إجراء تحقيق، جنبا إلى جنب مع العمليات على ملف موجود - التحديث، ارتكاب، أو عرض سجل من الماضي يرتكب. غير مطلوب الوصول إلى الخادم للعمل على الملف، والتغييرات ليست إرسالها إلى خادم فورا (وهذا يسمح لك لتجاهل التغييرات بسهولة إذا قمت بخطأ ما). عند حفظ الملف الخاص بك، كنت 'مجرد' إنقاذ الخاص بك نسخ محليا - أنها ليست حتى ارتكاب تلك التغيرات المحلية (التغييرات التي تم إجراؤها منذ بك آخر يرتكبون) يتم إرسالها إلى الخادم.

إنشاء ملف المشاريع الجديدة

لإنشاء ملف المشاريع الجديدة، حدد ملف| جديد ...ومن ثم اختيار واحد من الخيارين الأولين تحت قسم المشاريع النموذجية لل الحوار مشروع جديد (أي إما ملف المؤسسة فارغ، أو إنشاء واحدة من ملف ABACUS الحالية). الخيار الثالث هو "الخروج" من شخص آخر ملف المؤسسة أنشأت بالفعل، وسيتم تغطية هذا في المقطع التالي.

عند اختيار إنشاء ملف المشاريع الجديدة، سيتم منحك الحوار الذي سوف يسمح لك لاستعراض المكان في الخادم مستودع كنت ترغب في تخزين الملفات الخاصة بك. وسيكون عليها أيضا مسار الملف موجود ودخل اسم حتى أعلى إذا اخترت "من النموذج الحالي" من مربع الحوار مشروع جديد والموردة ملف.

URL: هذا هو URL إلى خادم مستودع الخاص بك حيث يتم تخزين ملفات ABACUS المؤسسة. يجب عليك أن تسأل الشخص الذي يدير خادم ما ينبغي أن يكون هذا URL.

الصورة أعلاه توضح مستودع مع أربعة (4) مشاريع ABACUS المشاريع القائمة، بعد دخول URL والضغط على Enter. أنت سوف نرى بعد إنشاء ملف المشاريع الجديدة، على لقطة المقبلة ل 'الخروج'، سيكون هناك مجلد آخر والملف تحت هذا المخزون.

ملاحظة

إذا كنت تستخدم HTTPS (SSL) الخادم، وليس لديها خادم شهادة SSL صالحة (مشتركة لإنترانت أو غير عامة خوادم نظرا ل ال تكلفة شهادة SSLs) سيكون هناك خطوة إضافية لاتخاذها. وسوف يطلب منك أن تقبل بشكل دائم كافة الاتصالات إلى ذلك الملقم في مربع الحوار الذي دفعها (وسوف تظهر أيضا أكثر قليلا من المعلومات عن الخادم). للقيام بذلك، اكتب 'ع' (بدون علامات الاقتباس) ثم اضغط على Enter. سوف ABACUS يطفو على رسالة تذكير لك هذا قبل أن تظهر في مربع الحوار.

ملاحظة

قد يطلب منك تسجيل الدخول إلى الملقم في هذه الحالة الشخص الذي هو إدارة الخادميمكن أن توفر اسم المستخدم وكلمة المرور الخادم. أيضا، واعتماد تسجيل الدخول لأي الملقمات التي قمت بتوصيل يتم حفظها لذلك إذا لأي سبب من الأسباب فإنها تحتاج إلى أن يتم مسح يمكن القيام بذلك عن طريق أدوات | خياراتثم على جنرال لواء التبويب عن طريق النقر إعادة تعيين التخريب المحفوظة تسجيل الدخولواختيار الملقم من القائمة المنسدلة والنقر واضح تسجيل الدخولواختيار موافق في مربع الحوار الذي يظهر.

ملاحظة

وخلافا لقطة هو مبين أعلاه، يتم تضمين عادة مشروع ABACUS واحد في كل ABACUS مستودع لأنه إذا تم إنشاء أكثر من 1 ABACUS المشروع في واحد ABACUS مستودع، ويجري تقاسم أرقام سجل التغيير ABACUS في جميع مشاريع ABACUS وهذا قد يربك المستخدمين.

متصفحك المفضل: هذا يؤثر على كل المجلد واسم الملف الذي سيتم استخدامه (إذا لم تتخذ بالفعل) عند إنشاء ملف على الخادم مستودع. لاحظ أنه يتم إنشاء مجلد جديد تلقائيا على خادم مستودع لكل ملف (لأسباب تتعلق بالأداء، يتم إنشاء ملفات ABACUS المشاريع في المجلد الخاص بهم ضمن الموقع تصفحها لفي الحوار).

تخزين نسخ العمل في الدليل: عندما يتم إنشاء ملف المشاريع في الخادم مستودع، تحتاج ملفات العمل المحلية ليتم إنشاؤه على جهاز الكمبيوتر الخاص بك، حتى تتمكن من العمل على الملف دون اتصال بالشبكة. هذا هو المكان الذي سوف استعرض للوصول إلى عندما تريد فتح / إعادة فتح ملف ABACUS المؤسسة.

الخروج من المؤسسة ملف موجود

اذا كان شخص ما قد خلقت بالفعل ملف المشاريع الجديدة، يمكن أن 'الخروج' هذا الملف، الذي بتحميل نسخة محلية ويضع الملفات الضرورية لذلك ABACUS يعترف هذا كملف المشاريع لك. الحوار هو مماثل لمشروع حوار ملف جديد. أدخل URL مستودع (يمكن تضمين الدلائل في URL)، حدد الملف المطلوب، ثم انقر فوق موافق. موضوع هذه المذكرة أدناه رانه ملف وبعد ذلك يتم فتح.

ملاحظة

قد يطلب منك تسجيل الدخول إلى الملقم في هذه الحالة الشخص الذي هو إدارة الخادميمكن أن توفر اسم المستخدم وكلمة المرور الخادم. أيضا، واعتماد تسجيل الدخول لأي الملقمات التي قمت بتوصيل يتم حفظها لذلك إذا لأي سبب من الأسباب فإنها تحتاج إلى أن يتم مسح يمكن القيام بذلك عن طريق أدوات | خياراتثم على جنرال لواء التبويب عن طريق النقر إعادة تعيين التخريب المحفوظة تسجيل الدخولواختيار الملقم من القائمة المنسدلة والنقر واضح تسجيل الدخولواختيار موافق في مربع الحوار الذي يظهر.

الاختلافات المؤسسة الملف

عندما يكون لديك إنشاء ملف المشاريع (إما واحدة جديدة، أو عن طريق "الخروج" من ملف تم إنشاؤه من قبل شخص آخر)، سيتم إنشاء مجلد للملف، وأنها سوف تحتوي عادة هذه 3 أنواع رئيسية من الملفات:

· '.abacus' ملف- وهذا هو الملف ABACUS نفسها. التغييرات التي تجريها محليا ليست حفظ فورا إلى هذا الملف، هو مكتوب فقط عند ارتكاب. هذا الملف هو «طبيعية» ملف ABACUS، فإنه يمكن أن تعطى للمستخدمين غير EE-كمشروع مستقل (بدون ملف .log)، أو استخدامها كنقطة انطلاق لملف EE الجديد.

· الملف '.changes "- المستوى المحلي (غير ملتزم) التغييرات التي أدخلت على الملف. إذا كان هذا الملف مفقود، وهذا يعني أنه لا توجد تغييرات محلية.

· '.ملف تسجيل- هذا الملف يحتوي فقط على التغييرات التي تم إجراؤها من قبل المستخدم الماضي (محتويات ملف .changes المستخدم عند ارتكاب).

ملاحظة

هناك العديد من الملفات الأخرى التي قد تنشأ أثناء التحديث وارتكاب العمليات، وهي: ‘.changesbefore' ملف- هذا الملف هو نسخة من ملف .changes بعد أن تم إجراء تحديث ويستخدم للتوفيق بين أي نزاعات ID بين التحديث وأي المحلي (غير ملتزم) تلقائيا التغييرات قبل ارتكاب؛ ‘.دعم' ملف- هذا الملف هو نسخة من ملف .changes قبل يحفظ المستخدم أكثر المحلية (غير ملتزم) تغييرات على ملف .changes. و ‘.خطأ' ملف- هذا الملف هو نسخة من ملف .changes إذا كان هناك أي مشكلة تسبب ABACUS أن تفشل لفتح ملف .abacus واختار المستخدم للعودة التغييرات الخاصة بهم.قد يتم تجاهل هذه الملفات.

فتح ملف

لفتح ملف، تحتاج فقط لاستعراض المكان الذي اخترته لتخزين نسخة العمل، وفتح ملف ABACUS التي يتم تخزينها هناك. عندما يرى ABACUS أن هناك .ملف السجل (وربما .ملف التغييرات إذا قمت بإجراء تغييرات)، فإنه سيتم معالجة الملف كملف المؤسسة.

تحديث ملف

أداءو'تحديث' ن معرفة ما اذا كان يقع إلى نسخة أحدث من ملف على الخادم. إذا كان هناك، فإنه سيتم إغلاق الملف الحالي وتحديث للملف أحدث من الخادم، وتحميل بعض الملفات المؤقتة التي لديها عدد كامتداد - على سبيل المثال 'Demo.125. هذه الملفات هي الإصدارات القديمة من ملف .log، وتستخدم لتحديد ما هي التغييرات التي تم إجراؤها على ملف منذ آخر مرة قمت تحديثه. وهذا مطلوب للكشف عن أي صراعات قد تكون وقعت حتى تتمكن من حلها.

إذا أثناء عملية التحديث أي الصراعات تم ايجادها، وسوف تحتاج لحلها قبل أن تتمكن من فتح الملف مرة أخرى (يمكنك إلغاء لكن سيطلب منك لحل الصراعات مرة أخرىفي المرة التالية التي تفتح الملف).

حفظ ملف

عند حفظ ملف، وهذا يلحق أي التغييرات التي قمت بها إلى ملف .changes. هو لاتعديل الملف .abacus في هذه المرحلة - فقط عندما يرتكب الملف إلى الخادم سوف تكون مكتوبة على (أو عندما تتلقى التحديث من الخادم).

أين هو "حفظ باسم"؟

ليس هناك مفهوم حفظ باسم لملفات المشاريع. يمكنك إلا أن نسخ نسخة العمل الخاص بك .abacus الملف، مع الأخذ في الاعتبار أنه لن يكون التغيرات المحلية في ذلك.

حل النزاعات

إذا كان المستخدمين الآخرين يكون للتغيرات ملتزمة الملف في جزء مماثل من الملف لكم، قد يكون هناك بعض الصراعات بين التغييرات الخاصة بهم ولك. على سبيل المثال، قد مستخدم آخر حذف العنصر الذي كنت قد تحديث خاصية على. تحتاج إلى إما التراجع عن تغيرها (إذا كنت متأكدا من أنه ينبغي لهمليس وقد حدث)، أو تجاهل التغيير (قد ثم انتقل إلى الملف وإعادة التغيير).

على وجه التحديد هناك 4 فئات من النزاعات التي يمكن أن تحدث.

1. حذف - عند حذف مستخدم واحد كائن التغييرات مستخدم آخر. مثلا العضو A حذف عنصر ولكن المستخدم B تغيير اسم العنصر أو المتصلة به أو إضافة عنصر الطفل على أنه الخ

2. سمة - عندما اثنين من المستخدمين على حد سواء تغيير نفسها 'سمة' بالضبط من كائن. مثلا كلا A المستخدم والمستخدم ب تغيير اسم مكون أو وصفه أو قيمة واحدة من خصائصه الخ

3. مرجع - عندما تتغير اثنين من المستخدمين نفس "مرجعية" بالضبط كائن إلى كائن آخر له. مثلا تغير كل من العضو والعضو B نوع عنصر أو مكون المصدر / بالوعة تعلق على اتصال أو وجهة نظر مرتبطة لرسم تخطيطي الخ

4. جمع - عندما تتغير اثنين من المستخدمين على "جمع" لكائن. مثلا كلا A المستخدم والمستخدم ب انتقلت مكون من أحد الوالدين إلى آخر، أو إعادة ترتيب مجموعة من المكونات الأطفال.

ملاحظة

يتم حل النزاعات غير منطقي مختلف تلقائيا من قبل ABACUS للحد من النفقات العامة على المستخدمين.على سبيل المثال يتم حل أية إعدادات عموم التكبير متضاربة عن مخططات للحفاظ على أحدث إعدادات عموم التكبير.

ارتكاب التغييرات

عندما اخترت لارتكاب التغييرات، الملف ABACUS من الخادم يتم فتح، الخاص بك محلي يتم تنفيذ التغييراتضدها، وثم المحلية الخاصة بك يتم الكتابة ملف .abacus مع واحد يحتوي على التغييرات في ذلك. ملف التغييرات ثم الكتابة فوق الملف .log، ويتم إرسال كل ملف .abacus وملف .log إلى الملقم.إذا كان ارتكاب غير ناجحة الالتزام الحوار رسالة كما هو موضح أدناه مقدمة للدخول في رسالة مع يرتكبها.

عرض سجل التغييرات

إلى عرض سجل التغييرات ل مشروع مشروع، اختار ملف| عرض السجل...

أقصى مقالات دخول: هذا سوف الافتراضية إلى الإدخالات ال 10 الماضية ولكن يمكن استرجاعها إدخالات إضافية عن طريق تغيير قيمة والنقر على استرداد زر.

المراجعة: تيسرد العمود ه مراجعة أرقام مراجعة ملتزمة ملقم المؤسسة، افتراضيا، بترتيب زمني عكسي.

ملاحظة

قد لا تكون الأرقام مراجعة مستمرة كما ABACUS سيتم سرد فقط تلزم في حين أن نفس التخريب مستودع قد تستخدم لمشاريع ABACUS أخرى و / أو غيرها من تطبيقات التحكم في الإصدار.

التاريخ: تيسرد ه تاريخ العمود التاريخ الذي تم تلتزم المراجعة إلى ملقم المؤسسة.

مرة: تيسرد العمود ه الوقت الوقت من اليوم (في 24 ساعة الشكل) أن تنقيح ملتزمة ملقم المؤسسة.

مؤلف: تيسرد العمود ه المؤلف اسم الدخول مايكروسوفت ويندوز للمستخدم أن يقوم أمر التنفيذ تليها بهم ABACUS اسم المستخدم ، أو "مجهول" إذا لم يتم مصادقة المستخدم وسمح للمستخدمين المجهولين الوصول إلى مشروع المؤسسة في وقت ارتكاب.

سجل الرسائل: تيسرد العمود ه سجل الرسائل على ارتكاب الرسالة التي تم توفيرها مع المراجعة وفقا للالحوار هو مبين أعلاه.

حمل مراجعة XX كملف ABACUS مستقل: إذا قمت بتحديد المراجعة الواردة في الجدول ثم انقر فوق الزر تنزيل سوف تكون قادرة على استخراج اختيار ABACUS مراجعة المشروع من الخادم وإنقاذ بأنها قائمة بذاتها مشروع محلي / ABACUS.

ملاحظة

لاسترجاع إلى المراجعة السابقة يرجى الاطلاع على Avolution المادة المجتمع .

(المشرف) تحميل ملف XML دخول للمراجعة XX: يمكن للمستخدمين لديها القدرة مدير ABACUS اختيار المراجعة الواردة في الجدول ثم انقر على زر التحميل لاستخراج المشروع ABACUS اختارت الالتزام ملف السجل من الخادم وحفظه كملف. XML.

عرض لمراجعة الحسابات من التغييرات

إلى عرض لمراجعة الحسابات من تغييرات على أي عنصر معين (أي مكون، والاتصال، وعرض، والأطفال الخ) ل مشروع مشروع, بزر الماوس الأيمن فوق عنصر و اختار التدقيق تريل...، مجموعة من و إلى مجموعة مراجعة وانقر البحث عن.

ملاحظة

مرة واحدة يتم حذف عنصر من المشروع الذي لم يعد قادرا على الوصول إلى معلومات محددة لمراجعة الحسابات حول ذلك العنصر. يمكنك، ومع ذلك، لا يزال الوصول إلى مكون "الأم" (على سبيل المثال)، وانظر درب معلومات تدقيق ثبوتية للحذف (في هذه الحالة سرد معرف العنصر الذي تم حذفه).وعلاوة على ذلك، مكون / المرفقات اتصال هو "الملكية" للاتصالات حتى تغيير عنصر المرفقة من خلال نافذة Explorer أو على رسم تخطيطي سوف تظهر في مراجعة الحسابات للاتصال NOT المكون، وحذف الاتصال وإنشاء اتصال جديد (كما يحدث إذا كنت بزر الماوس الأيمن فوق "Unattach" ثم "ربط ... 'في الفهارس) سيؤدي إلى فقدان المعلومات لمراجعة الحسابات للعنصر الأصلي - مرفق اتصال تماما.

ملاحظة

افتراضيا مراجعة الحسابات سوف تحقق متكرر لإجراء تغييرات في أي من الأطفال من العنصر المحدد. وهذا قد يؤدي في أوقات استجابة طويلة وفقا لذلك مراجعة الحسابات يمكن أن يقتصر على العنصر نفسه عن طريق إلغاء تحديد العودية الخيار تحت خيارات التدقيق"عجلة والعتاد" زر في شريط الأدوات في الحوار التدقيق تريل.

من مراجعة: هذا سوف الافتراضي إلى أول / أقدم تنقيح متاح للمشروع على ملقم المؤسسة.

إلى مراجعة: هذا سوف الافتراضي إلى الماضي / معظم التنقيح الأخير المتاح للمشروع على ملقم المؤسسة.

ملاحظة

بعد تحديد من و إلى مراجعة مجموعة انقر فوق الزر بحث لاسترداد أي تغييرات محددة إلى العنصر المختار.

المراجعة: تيسرد العمود ه مراجعة أرقام مراجعة ملتزمة ملقم المؤسسة، بشكل افتراضي، في الترتيب الزمني إلى الأمام.

ملاحظة

هي أرقام المراجعة من غير المرجح أن تكون مستمرة كما سيتم عرض فقط التنقيحات ذات الصلة إلى العنصر المختار وفقط ABACUS يرتكب سيتم سرد في حين أن نفس التخريب مستودع قد تستخدم لمشاريع ABACUS أخرى و / أو تطبيقات التحكم في الإصدار.

التاريخ: تيسرد ه تاريخ العمود التاريخ الذي تم اتخاذ إجراء المستخدم.

ملاحظة

التاريخ المبين هو التاريخ الذي تدخل من المستخدم، وليس التاريخ الذي ارتكبت فيه المراجعة إلى ملقم المؤسسة. وعليه، فإن التاريخ قد تسبق المراجعة المقابلة كرست التاريخ المبين مع ملف | عرض دخول ... أمر.

مرة: تيسرد العمود ه الوقت الوقت من اليوم (في 24 ساعة الشكل) التي تم فيها إجراء المستخدم.

ملاحظة

الوقت المعروض هو الوقت عمل المستخدم، وليس وقت ارتكاب المراجعة إلى ملقم المؤسسة. وبناء على ذلك، فإن الوقت سيكون على الارجح تسبق المراجعة المقابل ارتكاب الوقت تظهر مع ملف | عرض دخول ... أمر.

مؤلف: تيسرد العمود ه الكاتب المستخدم أن تنفيذ الإجراء مايكروسوفت ويندوز اسم الدخول تليها بهم ABACUS اسم المستخدم ، أو "مجهول" إذا لم يتم مصادقة المستخدم وسمح للمستخدمين المجهولين الوصول إلى مشروع المؤسسة في وقت إجراء المستخدم.

ملاحظة

الكاتب المدرجة في المراجعة تريل الحوار قد لا تتطابق بالضرورة عن الكاتب المدرجة في الحوار عرض السجل فوق لنفس المراجعة. وذلك لأن القوائم الحوار عرض السجل وتسجيل في مستخدم في وقت ارتكاب بينما القوائم الحوار المراجعة تريل للتسجيل في مستخدم في وقت إجراء المستخدم، وأنه من الممكن أن يكون مستخدم واحد إجراء تغييرات وإرسال أبنائهم. ملف التغييرات إلى مستخدم آخر على ارتكاب - كما هو الحال عندما مستخدم خارجية (مثل Avolution) هو العمل على مشروع EE.

تفاصيل: تيسرد تفاصيل البريد العمود التفاصيل الدقيقة لإجراء المستخدم كما هو مسجل في ملقم المؤسسة.

تلميح

ومن المفيد مجموعة من العمود مراجعة (كما هو موضح في الحوار أعلاه) و / أو العمود إجراء المستخدم إلى بسهولة تصنيف تغييرات على عنصر الفائدة.

استخدام البرمجة مع ملفات المشاريع

إذا كنت تستخدم البرمجة مع ملفات المشاريع، يجب أن تكون على بينة من كيفية حذف كائن بشكل صحيح من النموذج. عموما، عند حذف كائن، سوف استدعاء الأسلوب .Delete () على ذلك، وليس فقط إزالته من الأصل.

مثلا إذا كنت قد comp1 كأصل لل comp2 وكنت ترغب في حذف comp2 في السيناريو الخاص بك، يجب عليك الاتصال comp2.Delete ()، بدلا من comp1.Components.Remove (comp2).

يمكنك استخدام إزالة إذا كنت تنوي إضافة الكائن comp2 إلى مكان آخر داخل الهيكل، ولكن لا ينبغي أن تستخدم إذا كان القصد من ذلك هو حذف الكائن.

هناك استثناء لهذا، لأنه عندما كنت ترغب في إزالة كائن أن "يعيش" في أي مكان آخر في النموذج. عندما كنت ترغب في إزالة مثيل القياسية من العمارة / العنصر / اتصال، وعندئذ يمكنك القيام بذلك عن طريق إزالته من مثيل القياسية جمع - arch1.تطبيقاتأزل (عفريت) - لأن حذفها سوف إزالته من جميع الحالات.

صحيح باستخدام حذف في البرامج النصية مهم جدا لأنه إذا تمت إزالة كائن من objectmodel ويقم بإضافة إعادة، فإنه لن يكون قادرا على أن يكون موجودا، ولكن لأنه لم يكن على وجه التحديد 'حذف'، كشف النزاعات وحلها سوف لا كشف بشكل صحيح نزاع إذا كان مستخدم آخر في محاولة لاستخدام هذا الكائن في أي من التغييرات الخاصة بهم، وسوف تكون النتيجة النهائية مجموعة تالف من التغييرات لهذا المستخدم.

أنظر أيضا

كيفية بنية ممثلة في ABACUS؟


العمل مع الملفات ABACUS

الملاحة: مقدمة في ABACUS>

العمل مع الملفات ABACUS

إرسال التعليقات حول هذا الموضوع.

ملف ABACUS هو وعاء للنموذج الخاص بك هندسة معمارية . ضمن ملف ABACUS واحد، يمكنك نموذج أي عدد من أبنية أي عدد من المرات.

عند أول فتح ABACUS، لا توجد ملفات مفتوحة. للعمل على الهندسة المعمارية، لديك إما إنشاء ملف جديد أو فتح ملف موجود.

عند فتح أو إنشاء ملف جديد، وشجرة في نافذة المستكشف عرض تلقائيا. يوضح لك هذا الرأي المستكشف العمارة بك حتى الآن. عند إغلاق الملف، وشجرة في نافذة المستكشف تختفي أيضا.

لإنشاء ملف ABACUS جديد

1. اختار ملف| جديد ...

2. في مربع الحوار مشروع جديد الذي يظهر (كما هو موضح أدناه) أخترإما إنشاء نموذج فارغ، وهذا نموذج من مكتبة ABACUS القياسية ، وهذا نموذج من مكتبة ABACUS العرف، وهذا نموذج من XML، MS الوصول , MS برنامج Visio , إكسل , MS SQL خادم ، وهو مشروع الخادم نموذج أو مكتبة ABACUS مخصص (ملف .abacuslib).

3. اضغط على حسنازر ومتابعة الحوارات التي قد تظهر.

تلميح

لن يطلب منك اسم الملف حتى يتم حفظ أو إغلاقه. انها فكرة جيدة لحفظ الملف بمجرد إنشائه. ثم سوف لا يكون لديك ما يدعو للقلق حول تسمية ذلك في وقت لاحق في عملية عندما كنت في التركيز على أشياء أخرى معقدة (مثل ملء العمارة الخاص بك).

إنشاء مشروع جديد

ABACUS المكتبات القياسية

ABACUS يدعم أكثر 10بعضها موضح أدناه 0 الأطر العامة والرموز. عند اختيار لإنشاء مشروع جديد من مستخدمي المكتبة القياسية يكون بداية سريعة لوضع النماذج ضمن إنشاء إطار الاستفادة الكاملة من أي نوع من أنواع عنصر المعرفة، والصفات والترميزات وجهات النظر والقوالب أو الأنماط. تتوفر بحرية المكتبات القياسية إضافية من خلال الجماعة Avolution هنا .

مشروع جديد من المكتبة القياسية

حفظ ملف ABACUS جديد

1. اختار ملف| حفظ باسم

تلميح

يمكن أن يكون أي أسماء الطول، ويمكن أن تحتوي على أية أحرف أبجدية رقمية والمساحات. أنهم لا يمكن أن تحتوي على حرف تيلدا (~)، والأنابيب (|) حرف، علامة الاستفهام، أو الحروف المستخدمة عادة لوصف مسار مثل مائل (\) - إلا كجزء من المسار (؟).

لفتح ملف ABACUS القائمة

1. اختار ملف| فتح

ملاحظة

إذا كنت فتح ملف من موقع شبكة مشترك مفتوح بالفعل إلى مستخدم آخر، سوف ABACUS توفر لك الوصول للقراءة فقط. عند استخدام ABACUS مع قراءة فقط الوصول، وأنك لن تكون قادرة على إجراء عمليات الكتابة، مثل ملء العمارة الخاصة بك وتشغيل المقيمين. يمكنك، ومع ذلك، عرض العمارة باستخدام طريقة عرض المستكشف وجهات النظر 3D.

أنظر أيضا

كيفية بنية ممثلة في ABACUS؟


العمل مع لوحات المعلومات

الملاحة: الإدارة>

العمل مع لوحات المعلومات

إرسال التعليقات حول هذا الموضوع.

يمكن لمشاريع ABACUS يكون أي تكوين وجهات النظر (على سبيل المثال الرسوم البيانيةوالرسوم البيانية وغيرها) حفظها في لوحة القيادة ويمكن لهذه وحات حفظها يكون على النحو الافتراضي بدأت 'الشاشة' على فتح مشروع و / أو تعيين محددة مجموعة المستخدم وقدم لأعضاء تلك المجموعة مستخدم عند تسجيل الدخول إلى مشروع ABACUS.

ملاحظة

لتكوين لوحات في مشروع ABACUS الترخيص يحتاج المستخدم القدرة المسؤول. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

عرض لوحات المعلومات

مثال تطبيق إدارة المحافظ (APM) لوحة أجهزة القياس

لعرض لوحة المحفوظة

1. اختار عرض| لوحات

2. حدد لوحة القيادة حفظها من قائمة لوحات المتاحة.

ملاحظة

وبمجرد اختيار ABACUS ستبني آراء المطلوبة لوحة القيادة وهذا قد يستغرق بضع ثوان. يرجى التحلي بالصبر.

إدارة لوحات المعلومات

إدارة لوحات المعلومات

لخلق لوحة جديدة

1. فتح وجهات النظر المطلوبة و ترتيب وترسو نوافذ على النحو المطلوب للوحة القيادة.

2. اختار عرض| لوحات| إدارة لوحات المعلومات ...

ملاحظة

إذا كنت لا ترى عنصر القائمة إدارة لوحات المعلومات ثم لم يكن لديك القدرة المسؤول. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

3. في مربع الحوار الذي يظهر حدد خلقزر وأدخل اسم لوحة في خلق حوار جديد لوحة التحكم الرئيسية.

4. اضغط على حسنا زر.

لحذف لوحة القائمة

1. اختار عرض| لوحات| إدارة لوحات المعلومات ...

2. في مربع الحوار الذي يظهر حدد لوحة كنت ترغب في حذف من القائمة وحدد حذف زر.

ملاحظة

وحذف لوحة القيادة أيضا حذف أي تعيينات مجموعة المستخدم لأن لوحة أجهزة القياس.

3. اضغط على حسنا زر.

لتحل محل لوحة القائمة

1. فتح وجهات النظر المطلوبة و ترتيب وترسو نوافذ على النحو المطلوب للوحة القيادة استبدال.

2. اختار عرض| لوحات| إدارة لوحات المعلومات ...

3. في مربع الحوار الذي يظهر حدد لوحة كنت ترغب في استبدال من القائمة وحدد يحل محل زر.

4. اضغط على حسناالزر ليعترف الحوار لوحة استبدال.

تعيين لوحةكافتراض شاشة البدء

1. اختار عرض| لوحات| إدارة لوحات المعلومات ...

2. في مربع الحوار الذي يظهر حدد لوحة من القائمة التي ترغب في تعيين كما 'الشاشة' بداية الافتراضيةوحدد تعيين ... زر.

3. في مربع الحوار الذي يظهر حدد <مشروع افتراضي> دخول في المجموعات العمود العضو.

ملاحظة

فقط لوحة أجهزة القياس واحدة يمكن تعيين باسم <افتراضي مشروع> بداية 'الشاشة' حتى إعادة التعيين سيتم إزالة <افتراضي مشروع> تكليف من لوحة القيادة السابقة.وعلاوة على ذلك، إذا يقوم المستخدم بتسجيل الدخول كعضو من مجموعة المستخدم يحتوي على لوحة أجهزة القياس المخصصة ثم سيتم فتح لوحة التحكم المخصصة بدلا من لوحة القيادة المشروع الافتراضي.

4. اضغط على حسنا زر.

لتعيين مجموعة مستخدمي لوحة التحكم الرئيسية

1. اختار عرض| لوحات| إدارة لوحات المعلومات ...

2. في مربع الحوار الذي يظهر حدد لوحة من القائمة التي ترغب في تعيين مجموعة المستخدم إلى وحدد تعيين ... زر.

3. في مربع الحوار الذي يظهر حدد مجموعة مستخدمي (أو مجموعات)كنت ترغب في تعيين لوحة باسم "البدء" الشاشة ل.

ملاحظة

وإذا تم تعيين مجموعة مستخدمي نفس لوحات متعددة ثم يمكن استخدامها المهمة الأولى في القائمة.

4. اضغط على حسنا زر.

لإلغاء تعيين مجموعة مستخدمي لوحة من

1. اختار عرض| لوحات| إدارة لوحات المعلومات ...

2. في مربع الحوار الذي يظهر توسيع هذا البند لوحة من لائحة كنت ترغب في إلغاء تعيين مجموعة المستخدم من.

3. حدد مجموعة العضو كنت ترغب في إلغاء تعيين وتحديد إلغاء تعيين زر.

4. اضغط على حسنا زر.

أذونات الإعداد

ضوابط يمكن تعيين لوحات للسماح لوحة القيادة لتكون للعرض، للتحديث و / أو deleteableلمجموعات المستخدمين معين.

إدارة أذونات

لتعيين الإذن لوحة التحكم الرئيسية

1. اختار عرض| لوحات| إدارة لوحات المعلومات ...

2. في مربع الحوار الذي يظهر حدد لوحة من القائمة التي ترغب في تعيين أذونات وحدد ضوابط ... زر.

3. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

4. افتراضيا سترى أن للقراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

5. اضغط على حسنا زر.

أنظر أيضا

Customising واجهة ABACUS | العمل مع ضوابط


العمل مع ضوابط

الملاحة: الإدارة>

العمل مع ضوابط

إرسال التعليقات حول هذا الموضوع.

يمكن أن يكون مشروعا ABACUS المستند إلى الدورتعيين أذونات لكل عنصر داخل المستودع. على وجه التحديد، غرامة الحبيبات Create-Read-Update-Dذف (CRUD) الأذونات يمكن تعيين في "كائن" (أي مكون أو الاتصال)، ونظرا لسمة (أي الملكية) المستويات.

نظرة عامة

عند العمل مع ABACUS المؤسسة الخادم ، ABACUS يقدم غرامة الحبيبات، وأذونات CRUD القائم على دور للسيطرة على وصول العديد من المستخدمين إلى المخزون.

ملاحظة

لتكوين أذونات في مشروع ABACUS الترخيص يحتاج المستخدم القدرة المسؤول. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

ضوابط يمكن تعيين لأبنية، وعنصر اتصال أنواع وخصائص (عبر أنواعها)، والقوالب، وجهات النظر و الرسوم البيانية والفهارس، والمصفوفات والرسوم البيانية و3D عدد المشاهدات. عندما يتم تعيين الأذونات لمكون أو اتصال نوع كل الحالات من هذا النوع في أي أبنية في هذا المشروع "وراثة" هذه الأذونات. وبالمثل، عندما يتم تعيين إذن لخاصية عنصر أو نوع الاتصال، وخاصية معينة على حالات مكون أو الاتصال في أي أبنية في هذا المشروع "وراثة" هذه الأذونات. وفقا لذلك، سيتم تطبيق أذونات معينة إلى جهات النظر حول التي توجد فيها تلك العناصر. عندما يتم تعيين أذونات الرسم البياني، وعرض و / أو محتويات عرض نفسه لديك أذونات مختلفة المطبق عليه.

ملاحظة

بشكل افتراضي يتم تعيين أي أذونات للعناصر ضمن مشروع ABACUS. هذا هو كل العناصر هي Createable، يمكن قراءتها، للتحديث وDeleteable من قبل كافة المستخدمين. في هذه الطريقة التي ينبغي أن تعتبر إلا الأذونات لعنصر معين في المستودع عندما إذن معين هو أن تكون مقيدلمجموعة المستخدم معينة. على سبيل المثال، إذا تم إضافة أذونات لمجموعة من المستخدمين نظرا إلى كائن (على سبيل المثال نوع عنصر)، ولكن مع ترك كافة الأذونات مكنت، ثم وهذا هو وظيفيا نفسه كما لو أن مجموعة من المستخدمين لم يكن وأضاف إلى الكائن.

ضوابط لا يمكنيتم تعيين لحالات محددة من عناصر معمارية و. على سبيل المثال، لا يمكنك إجراء مكون تطبيق واحد للتحديث ولكن ليس آخر. لتحقيق فعالية هذه الأذونات "الملك محددة" ومع ذلك، يمكن للمسؤول بإعداد أنواع العناصر المحددة لمجالات معينة، على سبيل المثال 'التطبيق - مجال CRM "أنواع عنصر و' التطبيق - مجال HR"، ثم قم بتعيين أذونات لكل نوع وفقا لذلك. يمكنك جعل أنواع معينة التجمع من أجل كل مجال ومن ثم إزالة إذن التحديث لنوع مجموعة مجال محدد، وهذا سوف تحد من الإبداعات داخل والحذف من هذا التجمع ولكن ليس تحديث للأطفال. بالطبع إذا كانت مخبأة التجمع نطاق محدد عن طريق إزالة إذن القراءة ثم الأطفال سوف تكون مخفية، وبالتالي غير قابل للتحديث. بدلا من ذلك، إذا تم استخدام وجهات النظر (وليس اكسبلورر) في المقام الأول لإدارة / عرض المخزون الخاص بك، يمكن إنشاء وجهة نظر معينة لكل مجال، ثم مدير يمكن تعيين الأذونات لكل رأي وفقا لذلك.

إدارة المستخدمين والمجموعات

يتم تعريف الأذونات في دور أو مجموعةمستوى، بدلا من مستوى مستخدم فردي، حتى أنه في حين أن عضوية المجموعات قد تتغير، وأذونات يمكن أن تبقى ثابتة. بالطبع إذا كنت ترغب في الحصول على إذن مستخدم معين ثم ببساطة جعلها مجموعة، أو بتعبير أدق إنشاء مجموعة مع هذا المستخدم كعضو الوحيد.

وتجدر الإشارة إلى أن المجموعات الذري، وهذا هو أنها لا يمكن أن ترث الأذونات أو المستخدمين من واحد إلى آخر، وإذا كان المستخدم ينتمي إلى مجموعات متعددة ثم معظم "متشائم" إذن مجموعة الأسبقية على أساس كل حالة على حدة لكل إذن الفردية (أي خلق المزيد--تحديث-حذف). على سبيل المثال إذا كان المستخدم نفسه هو عضو في المجموعة الأولى والمجموعة الثانية والمجموعة A للتو خلق، إذن القراءة لأنواع عنصر التطبيق بينما المجموعة الثانية تمت قراءة تحديث فقط إذن لأنواع عنصر التطبيق ثم لن يكون لها سوى قراءة المستخدم إذن ل حالات مكون التطبيق.

وعلاوة على ذلك، افتراضيا، المستخدمين المجهولين(وهذا هو للمستخدمين الذين لم يعرف أو الذين لم تقم بتسجيل الدخول) لديها الوصول الكاملللمشروع. هذا هو التأكد من أن الوصول متاح في التكوين الأولي. لمنع وصول المستخدمين المجهولين ببساطة قم بإلغاء تحديد "السماح بالوصول الكامل المستخدم المجهول إلى الملف 'الخيار في إدارة المستخدمين / المجموعات الحوار هو مبين أدناه. عندما المستخدمين المجهولين دون رادع سوف يكون قادرا على رؤية جزء معايير أي مشروع فقط.

وأخيرا، يتم تنفيذ المصادقة المستخدم إذا تم التحقق من خيار "استخدام Windows اسم المستخدم تسجيل الدخول" ضد ويندوز اسم المستخدم محدودة على جهاز كل مستخدم على اسم المستخدم ودخلت كما في أدناه. هذا هو إذا كان ويندوز المستخدم الدخول لجهاز المستخدم المعطى كما هو معمول به اسم مستخدم صالح ثم لا يلزم كلمة المرور و مصادقة المستخدم تلقائيا. ملاحظة: هذا يسمح بفعالية استخدام ويندوز الدليل النشط (AD) المصادقة.

ملاحظة

أنه نظرا يتم تحديد أذونات فقط عندما تحتاج إلى أن تؤخذ بعيدا (مقيد) من مستخدم، أي مستخدم ليست عضوا في مجموعة، أو أي مجموعة لديها أي ضوابط محددة لذلك ضد أي أجسام، سيكون لديك حق الوصول الكامل إلى المشروع.

المستخدمين ومجموعات المستخدمين

لإنشاء مستخدم جديد

1. اختار ملف| إدارة المستخدمين / المجموعات

ملاحظة

إذا كنت لا ترى إدارة المستخدمين / المجموعات عنصر القائمة ثم لم يكن لديك القدرة المسؤول. يرجى الاتصال بمسؤول ABACUS المحلي أو دعم Avolution إذا كنت تحتاج إلى هذه القدرة.

2. في مربع الحوار الذي يظهر حدد إضافة مستخدمزر وإدخال اسم المستخدم وكلمة المرور في خلق فرص عمل جديدة الحوار مستخدم. ملاحظة: أسماء المستخدمين وكلمات المرور حساسة لحالة الأحرف.

ملاحظة

وإذا تم التحقق خيار "استخدام Windows اسم المستخدم تسجيل الدخول" كما هو موضح أعلاه ثم يمكن إدخال كلمة مرور وهمية كما المصادقة يتم تنفيذها وفقا لنافذة المستخدم لاسم المستخدم تسجيل الدخول فقط.

2. افتراضيا سترى أن يمكن للمستخدمين تغيير كلمة المرور الخاصة بهم. إذا لزم الأمر، ومدير ABACUS قد يزيل ال بالنسبة للمستخدمين القدرة على تعيين كلمة المرور الخاصة بهم بواسطة إلغاء تحديدخانات الاختيار.

ملاحظة

إذا يمكن للمستخدمين تغيير كلمة المرور الخاصة بهم سيكون لديهم ملف | تغيير كلمة المرور...عنصر القائمة للقيام بذلك.أيضا، يجب أن تدرك أنه إذا استخدم عدة أشخاص في نفس اسم المستخدم ثم مستخدم واحد قد تغيير كلمة المرور بحيث لا يمكن للأشخاص الآخرين الدخول بعد ذلك. الممارسة وفقا لذلك، فمن المستحسن أن يكون ل اسم المستخدم واحد لكل شخص الفعلي.

4. اختياريا، أدخل عنوان البريد الالكتروني, موقع ورقم الهاتف للمستخدمين للرجوع إليها في المستقبل.

5. اضغط على حسنازر في خلق فرص عمل جديدة الحوار مستخدم.

6. اضغط على حسنا زر.

ملاحظة

وبمجرد الانتهاء من إنشاء المستخدم الخاص بك أولا يجب عليك أن تنظر عرقلة وصول المستخدمين المجهولين من خلال إلغاء تحديد "السماح بالوصول الكامل المستخدم المجهول إلى الملف 'الخيار في إدارة المستخدمين / الحوار مجموعات.أيضا، مرة واحدة تم إنشاء المستخدم (وإذا كان مشروع المؤسسة، وتغيير ملتزمة الخادم)، في المرة القادمة يتم فتح المشروع سيتم دفع المستخدمين ل تسجيل الدخول للوصول إلى الموثقحسب الحوار هو مبين أدناه. إذا كان تسجيل الدخول تلقائيا مع هذه التفاصيليتم فحص الخيار ثم سيذكر اسم المستخدم / كلمة المرور لهذا المشروع وتطبيقه في كل مرة على فتح. لمسح تسجيل الدخول حفظ حدد ملف | واضح المحفوظة تسجيل الدخولبعد فتح وسيطلب منك للدخول مرة أخرى التالية التي تفتح المشروع.

تسجيل الدخول

لحذف العضو القائمة

1. اختار ملف| إدارة المستخدمين / المجموعات

2. في مربع الحوار الذي يظهر حدد اسم العضو في لوحة المستخدمين التي ترغب في حذف ثم حدد حذف العضو زر.

3. اضغط على حسنا زر.

لإنشاء مجموعة جديدة

1. اختار ملف| إدارة المستخدمين / المجموعات

2. في مربع الحوار الذي يظهر حدد إضافة مجموعةزر وإدخال اسم المجموعة في لوحة المجموعات.

ملاحظة

يجب أن تكون أسماء مجموعة فريدة من نوعها.

3. اضغط على حسنا زر.

إلى نسخ القائمة مجموعة

1. اختار ملف| إدارة المستخدمين / المجموعات

2. في مربع الحوار الذي يظهر حدد نسخ مجموعة زر.

ملاحظة

سيتم مجموعة مكررة تم إنشاؤها مسبوقة ب "صورة".افتراضيا سيتم تكرار كافة الأذونات من مجموعة نسخ ل"نسخة من" مجموعة بما في ذلك أي مهمة المستخدم.

3. إعادة تسمية "نسخة من" مجموعة حسب الاقتضاء باستخدام تحرير المجموعةأو بطء انقر نقرا مزدوجا فوق.

لحذف مجموعة موجودة

1. اختار ملف| إدارة المستخدمين / المجموعات

2. في مربع الحوار الذي يظهر حدد اسم المجموعة في لوحة المجموعات التي ترغب في حذف ثم حدد حذف المجموعة زر.

ملاحظة

كما سيتم إزالة أي مهام العضو في المجموعة.

3. اضغط على حسنا زر.

تعيين مستخدم إلى مجموعة

1. اختار ملف| إدارة المستخدمين / المجموعات

2. في مربع الحوار الذي يظهر حدد اسم العضو في لوحة المستخدمين التي ترغب في تعيين لمجموعة و السحب والإفلاتوضعها على اسم المجموعة في لوحة المجموعات التي ترغب في تخصيصها ل.

3. اضغط على حسنا زر.

ملاحظة

المجموعة (ق) التي يمكن للمستخدم يتم تعيين ترد لمن خلال توسيع اسم المستخدم في لوحة المستخدمينوتعرض المستخدمين التي تم تعيينها إلى مجموعة عن طريق توسيع اسم المجموعة في لوحة المجموعات. على سبيل المثال، في الصورة أعلاه، يتم تعيين "AS1-استرالي" المستخدم إلى ثلاثة (3) مجموعات، وهي: "التطبيق دعم الفريق 1"، "الفعلية" و "أستراليا".

لإلغاء تعيين العضو من المجموعة

1. اختار ملف| إدارة المستخدمين / المجموعات

2. في مربع الحوار الذي يظهر بتوسيع اسم المجموعة التي تحتوي على احالة العضو الذي ترغب في إلغاء تعيين وتحديد اسم المستخدم.

3. اضغط على إلغاء تعيين العضو زر.

4. اضغط على حسنا زر.

لاستيراد المستخدمين و / أو المجموعات (وأي ضوابط مطابقة)

1. اختار ملف| إدارة المستخدمين / المجموعات

2. اضغط على استيراد زر.

3. في مربع الحوار الذي يظهر تصفحلوفتح المشروع ABACUS الذي يحتوي على المستخدمين و / أو المجموعات (وضوابط) كنت ترغب في استيراد إلى المشروع الحالي وانقر فتح. سيتم استيراد المستخدمين والمجموعات ويظهر الحوار استيراد نتائج يلخص استيراد المستخدمين و / أو المجموعات. اضغط على حسنا زر.

ملاحظة

إذا كان المستخدمون المستوردة أو مجموعات موجودة بالفعل في المشروع الحالي ثم سيتم دمجها مع المستخدمين أو المجموعات الموجودة.

4. اضغط على حسنازر الرجوع في الرئيسية إدارة المستخدمين / الحوار مجموعات.

5. إذا كان هناك أي أنواع المطابقة، وجهات نظر، قوالب أو أبنية بين المشروع الحالي ومشروع ABACUS الذي تستورد منه، مع استكمال الأذونات التي لم تكن موجودة بالفعل في المشروع الحالي، يتم استيراد الأذونات والحوار استيراد نتائج الثاني يبدو يلخص الاستيراد. اضغط على حسنا زر.

ملاحظة

تضاف أذونات فقط إلى أنواع القائمة (وخصائصها)، وجهات نظر، قوالب أو أبنية للمجموعات حيث أذونات لم تكن موجودة أصلا للمجموعة. إما لأن المجموعة هي جديدة أو موجودة في المجموعة بالفعل في المشروع الحالي لكن لم يتم تعيين أي أذونات أن المجموعة لهذا البند. ليس هناك 'دمج' من أذونات مطابقة البنود حيث أذونات موجودة بالفعل للفريق في المشروع الحالي.

أذونات الإعداد

ضوابط يمكن تعيين لأبنية، وعنصر اتصال أنواع وخصائص (عبر أنواعها)، والقوالب، وجهات النظر و الرسوم البيانية والفهارس، والمصفوفات والرسوم البيانية لد 3D عدد المشاهدات. عندما يتم تعيين الأذونات لمكون أو اتصال نوع كل الحالات من هذا النوع في أي أبنية في هذا المشروع "وراثة" هذه الأذونات. وبالمثل، عندما يتم تعيين إذن لخاصية عنصر أو نوع الاتصال، وخاصية معينة على حالات مكون أو الاتصال في أي أبنية في هذا المشروع "وراثة" هذه الأذونات. وفقا لذلك، سيتم تطبيق أذونات معينة إلى جهات النظر حول التي توجد فيها تلك العناصر. عندما يتم تعيين أذونات الرسم البياني، وعرض و / أو محتويات عرض نفسه لديك أذونات مختلفة المطبق عليه.

إدارة أذونات

لتعيين الإذن للمكون (أو اتصال) اكتب

1. توسيع أنواعفرع الشجرة.

2. توسيع عنصر (أو اتصال) أنواعفرع الشجرة.

3. توسيع المجموعاتحيثما كان ذلك ضروريا.

4. انقر بزر الماوس الأيمنعلى عنصر (أو اتصال) اكتبكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

5. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

6. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

ملاحظة

إنشاء إذن يحكم أيضا عندما يمكنك نسخ عنصر. وفقا لذلك، لتكون قادرة على نسخ عنصر يتطلب خلق إذن لجميع أبنائها (منذ لنسخ العنصر يعني نسخ كل شيء دونه). إزالة تحديث إذن من عنصر يزيل القدرة على تعديل نوع نفسها، حتى إذا كان المستخدم لديه مصمم إضافة على و كما يزيل إذن تحديث لجميع خصائصه. يجب أن يكون العنصر الأصلي تحديث إذن لتكون قادرة على إنشاء أي عناصر أو الأطفال حذف ل موجود عناصر الأطفال. حذف إذن لعنصر يتطلب أيضا حذف إذن لجميع أبنائها. حذف إذن لمكونات يتطلب أيضا تحديث إذن من كافة الاتصالات المرفقة.وأخيرا، وإزالة إذن حذف من عنصر يزيل القدرة على حذف نوع نفسها، حتى إذا كان المستخدم لديه مصمم الإضافة.

7. اضغط على حسنا زر.

لتعيين الإذن لمجموعة من المكونات (أو اتصال) أنواع

1. توسيع أنواعفرع الشجرة.

2. توسيع عنصر (أو اتصال) أنواعفرع الشجرة.

3. انقر بزر الماوس الأيمنعلى مجموعةالذي يحتوي على مكون (أو اتصال) أنواع التي ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

6. اضغط على حسنا زر.

7. في مربع الحوار الذي يظهر فوق نعم فعلا زر.

لتعيين الإذن للعقار

1. توسيع أنواعفرع الشجرة.

2. توسيع عنصر (أو اتصال) أنواعفرع الشجرة.

3. توسيع المجموعاتحيثما كان ذلك ضروريا.

4. حدد العنصر (أو اتصال) النوع الذي يحتوي على الخاصية التي ترغب في تعيين الأذونات ل.

5. في إطار خصائص انقر بزر الماوس الأيمنعلى الملكيةكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

6. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

7. افتراضيا سترى أن أذونات القراءة وتحديث كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

ملاحظة

وتظهر الخصائص التي كان لها إذن تحديث إزالتها في المائلفي إطار خصائصوقيمها لا يمكن أن يتم تحديثه من قبل هذا الدور. أيضا، والقدرة على تعديل تفاصيل خاصية (مثل الاسم وحدات الخ) تتطلب كلا إذن تحديث على الممتلكات و مصمم الإضافة.

8. اضغط على حسنا زر.

لتعيين الإذن لقالب

1. توسيع النماذجفرع الشجرة.

2. استعرض للوصول إلى قالبان كنت مهتما في.

3. انقر بزر الماوس الأيمنعلى قالبكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إذن القراءة هو متاح. إزالة الإذن من قبل إلغاء تحديدخانة الاختيار.

6. اضغط على حسنا زر.

لتعيين الإذن لوجهة نظر

1. توسيع وجهات النظرفرع الشجرة.

2. توسيع المجموعاتحيثما كان ذلك ضروريا.

3. انقر بزر الماوس الأيمنعلى وجهة نظركنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

6. اضغط على حسنا زر.

لتعيين الإذن لالعمارة

1. توسيع أبنيةفرع الشجرة.

2. توسيع ل هندسة معماريةان كنت مهتما في.

3. انقر بزر الماوس الأيمنعلى هندسة معماريةكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إذن القراءة هو متاح. إزالة الإذن من قبل إلغاء تحديدخانة الاختيار.

6. اضغط على حسنا زر.

لتعيين الإذن ل فهرس

1. توسيع الكتالوجاتفرع من الهندسة المعمارية كنت مهتما في.

2. توسيع المجموعاتحيثما كان ذلك ضروريا.

3. انقر بزر الماوس الأيمنعلى فهرسكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

6. اضغط على حسنا زر.

لتعيين الإذن ل مصفوفة

1. توسيع المصفوفاتفرع من الهندسة المعمارية كنت مهتما في.

2. توسيع المجموعاتحيثما كان ذلك ضروريا.

3. انقر بزر الماوس الأيمنعلى مصفوفةكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

6. اضغط على حسنا زر.

لتعيين الإذن لرسم بياني

1. توسيع الرسوم البيانيةفرع من الهندسة المعمارية كنت مهتما في.

2. توسيع المجموعاتحيثما كان ذلك ضروريا.

3. انقر بزر الماوس الأيمنعلى رسم بيانيكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

ملاحظة

في حين يمكنك تعيين الأذونات CRUD مباشرة لرسم تخطيطي، تجدر الإشارة إلى أن أذونات العناصر على الرسم البياني قد تؤثر على أذونات لعرض نفسها. على سبيل المثال، إذا كان هناك حتى مجرد عنصر واحد على وجهة النظر التي تمت زيارتها مقروءة أو تحديث إذن من إزالتها ثم الرسم البياني سيكون إذن تحديث في إزالتها. هذا بسبب؛ أ) لن يتم عرض العناصر على وجهة النظر التي كان لها إذن القراءة على إزالة على وجهة نظر ترك "المساحة البيضاء" حيث قد وضع على خلاف ذلك بعض العناصر الجديدة إذا كان الرأي للتحديث، وب) العناصر على الرأي القائل بأن وقد انخفضت تحديث إذنهم إزالة يمكن بعد ذلك عناصر أخرى على لهم أن يصيروا أولاد إذا كان الرأي للتحديث. أيضا، إنشاء وإذن تحديث لرسم تخطيطي يتطلب من جميع العناصر على طريقة العرض لديها إذن القراءة والمكونات لديهم إذن تحديث (وذلك لأن لتحريك مكون على مكون آخر، يجب أن تكون قادرا على تحديثه لأنه سوف يصبح الطفل).

6. اضغط على حسنا زر.

لتعيين الإذن لعرض 3D

1. توسيع 3D المشاهداتفرع من الهندسة المعمارية كنت مهتما في.

2. توسيع المجموعاتحيثما كان ذلك ضروريا.

3. انقر بزر الماوس الأيمنعلى 3D مشاهدةكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

6. اضغط على حسنا زر.

لتعيين الإذن ل الرسم البياني

1. توسيع الرسوم البيانيةفرع من الهندسة المعمارية كنت مهتما في.

2. توسيع المجموعاتحيثما كان ذلك ضروريا.

3. انقر بزر الماوس الأيمنعلى الرسم البيانيكنت ترغب في تعيين أذونات وحدد تحرير أذونات.

4. في مربع الحوار الذي يظهر انقر على إضافة ...زر وحدد مجموعةكنت أود أن أضيف إما عن طريق النقر المزدوج فوقه أو تحديده والنقر على حسنا زر.

5. افتراضيا سترى أن إنشاء، قراءة وتحديث وحذف أذونات كل ما هو متاح. إزالة الأذونات إلغاء تحديدخانات الاختيار ذات الصلة.

6. اضغط على حسنا زر.

أنظر أيضا

كيفية بنية ممثلة في ABACUS؟


مخطوطات الكتابة

الملاحة: محاكاة العمارة بك>

مخطوطات الكتابة

إرسال التعليقات حول هذا الموضوع.

محرر البرامج النصية هو أداة بسيطة وعملية لكتابة وتنفيذ VB أو C # النصي ضد ملف ABACUS المفتوحة حاليا(لا يتم اعتماد المكتبات في البرمجة). كان لديه ملف المعتاد فتح، إغلاق وحفظ أوامر، حتى تتمكن من حفظ واسترجاع النصوص تكتب. كما أن لديها تشغيل والتصحيح المرفق الأساسي. مدير سيناريو يسمح لك لتنفيذ بسهولة مختلف النصوص التي قمت بكتابتها من خلال وضع قائمة البند لهم مباشرة في القائمة أدوات.

للوصول إلى محرر

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. اختار أدوات | محرر البرامج النصيةونافذة محرر البرامج النصية وفتح. ثم إما؛

3. فتح النصي الموجود عبر ملف | فتح في القوائم محرر البرامج النصية،

أو

3. فتح برنامج نصي مثال عن طريق مثال البند في القوائم محرر البرامج النصية،

أو

3. تعيين اللغة الافتراضية إما VB أو C # عن طريق لغة البند في القوائم محرر البرامج النصية،

أو

3. تعليمات البرمجة مفتوحة محددة عبر مساعدة البند في القوائم محرر البرامج النصية

عند كتابة البرامج النصية، يجب أن تلتزم إما VB أو C # بناء الجملةوفقا لوضع إطار البند اللغة في القوائم محرر البرامج النصية.

ملاحظة:

· استخدام وظائف VB القياسية مثل MsgBox ()يجب تضمين واردات Microsoft.VisualBasicبيان في بداية البرنامج النصي. لم يكن ذلك ضروريا قبل الإصدار 3.0 من ABACUS.

· لا تشمل هذه المساعدة من المعلومات حول كيفية كتابة السيناريو VB، كما أنه لا يتضمن أي إشارة VB. لا تتردد في كتابة البرامج النصية الخاصة في IDE المفضلة لديك أو المحرر، ثم نسخها ولصقها في محرر البرامج النصية.

عند بدء تشغيل محرر البرامج النصية، فإن محرر يكون فارغا. يمكنك الوصول إلى هيكل عظمي النصي من خلال القائمة أمثلة. في المرة الأولى التي تبدأ محرر البرامج النصية الخاصة بك، يجب عليك تشغيل الهيكل العظمي قالب لمعرفة أنه يعمل. بالإضافة إلى ذلك، هناك نوعان من سبيل المثال البرامج النصية التي يمكن الوصول إليها من خلال القائمة أمثلة.

لكتابة السيناريو مفيد سوف تحتاج إلى الرجوع إلى ABACUS ObjectModel. إتاحتها لالسيناريو الخاص بك عن طريق تضمين واردات ABACUS.ObjectModelبيان على رأس السيناريو الخاص بك. يتم تضمين إشارة كاملة إلى طراز كائن ABACUS كامل مع محرر البرامج النصية. يمكنك العثور عليها عن طريق اختيار مساعدة | المحتوياتمن نافذة محرر البرامج النصية.

ويتضمن المحرر النصي العديد من الخصائص المفيدة لكتابة النصوص، بما في ذلك الإكمال التلقائي كما هو موضح في الصورة ادناه. ومع ذلك، لتجربة المستخدم حتى أغنى MS البصرية ستوديو يمكن أن تكون متكاملة مع ABACUS وهناك إرشادات مفصلة متاح هنا .

محرر نصي مع الإكمال التلقائي

لاستخدام إدارة سكربت

1. ضمان لديك ملف ABACUS، التي تحتوي على الخاص العمارة بالسكان, فتح.

2. اختر Tools | مدير النصي.

3. اضغط على إضافةرمز و فتحيظهر إطار.

4. انتقل إلى ABACUS سيناريو (.abacusscript، .vb أو .cs) الملف الذي تريد إضافته إلى القائمة أدوات.

5. انقر حسناوسيتم عرض اشارة الى البرنامج النصي في إطار إدارة البرامج النصية. أدخل اسم للبرنامج النصي كما يحلو لك أن يظهر في القائمة أدوات. ملاحظة: إطار إدارة سيناريو يمكن تغيير حجم لرؤية المسار الكامل إذا لزم الأمر.

6. كرر الخطوات 3-5لإنشاء ارتباطات إلى مزيد من البرامج النصية ABACUS.

7. انقر إغلاقلإغلاق إدارة البرامج النصية ونلاحظ أن السيناريو ABACUS (الصورة) تظهر الآن ضمن القائمة أدوات.

لتشغيل برنامج نصي

إما؛

1. فتح، اكتب في، أو نسخ ولصق في البرنامج النصي الذي تريد تشغيله، لذلك هو ظاهر في النافذة الرئيسية لل محرر البرامج النصية.

2. انقر على اركض زر.

3. إذا السيناريو الخاص بك يحتوي على أخطاء، سوف يكون من الخطأ وصف القسم في الجزء السفلي من محرر سرد التفاصيل بما في ذلك أرقام الأسطر. ملاحظة: كل خطأ فردي في خطأ الوصف القسم يمكن أن يكون النقر المزدوج ليأخذك إلى الخط المقابل في البرنامج النصي.

- أو -

1. اختار أدواتوبعد ذلك اسم ABACUS سيناريو عنصر القائمة كما تم إنشاؤها باستخدام مدير النصي.

2. إذا السيناريو الخاص بك يحتوي على أخطاء، سيتم فتح محرر مع محتويات النصي هو مبين في الإطار الرئيسي (أبرزت في خط الخطأ الأول) ووصف الخطأ القسم في الجزء السفلي من محرر سوف قائمة تفاصيل أو الخطأ (ق) بما في ذلك أرقام الأسطر. ملاحظة: كل خطأ فردي في خطأ الوصف القسم يمكن أن يكون النقر المزدوج ليأخذك إلى الخط المقابل في البرنامج النصي.

أخطاء البرمجة تجميع

تحدث أخطاء ترجمة عند بناء جملة من التعليمات البرمجية النصية غير صحيحة. سوف تظهر هذه الأخطاء في الجزء السفلي من النافذة في القسم الخطأ، مع وصف الخطأ، ورقم السطر. هو رقم السطر الذي يميز الخطأ تجميع من خطأ وقت التشغيل (انظر أدناه)، والتي لن يكون لها رقم السطر. أخطاء ترجمة يمكن النقر المزدوج للانتقال إلى وتسليط الضوء على خط محدد في السؤال.

أخطاء وقت التشغيل البرمجة (هام)

تحدث أخطاء وقت التشغيل بعد أن تم تجميع التعليمات البرمجية النصية بنجاح دون أخطاء، ولكن حدث خطأ في وقت التشغيل (انظر الأمثلة إلى مزيد من الانخفاض). أخطاء وقت التشغيل مهمة لأنها يمكن أن تؤدي إلى نماذج تالفة عند الكائنات التي تم إنشاؤها والمشار إليه من قبل كائنات أخرى في هذا النموذج، ليست نفسها جزءا من نموذج (عادة بسبب حدوث خطأ وقت التشغيل قبل التعليمة البرمجية التي من شأنها أن وضعتها في نموذج في مكان ما، أعدم).

إذا السيناريو الخاص بك يخلق الأشياء التي يمكن ان تضاف للنموذج، يمكنك تجنب الفساد الناجم عن خطأ وقت التشغيل عن طريق حفظ السيناريو الخاص بك، وإغلاق البرمجة، وإجراء عملية التراجع عن التغييرات التي تم إنشاؤها من قبل البرنامج النصي (إذا تنفيذ البرنامج النصي لم يكتمل عادة ). ومع ذلك، هناك أيضا طرق أخرى لتجنب أي تلف يحدث (انظر أدناه). ملاحظة: أي النصوص التي تقرأ فقط من النموذج ولا الكتابة إليه، هي آمنة ولن يسبب أي مشاكل، بغض النظر عما إذا أخطاء وقت التشغيل تحدث أثناء تنفيذها.

لتجنب الفساد، عند كتابة التعليمات البرمجية النصية التي يتم إنشاء كائنات وإضافتها إلى طراز كائن، يقترح أن الكائنات تضاف إلى نموذج في أقرب وقت ممكن إذا تم الرجوع إليها من قبل كائنات أخرى.

على سبيل المثال، إذا كنت تقوم بإنشاء اتصال جديد، و2 مكونات جديدة، ومن ثم إرفاقها معا، فمن الأفضل لخلق العنصر الأول، إضافة إلى نموذج، ثم الثانية وإضافته، ثم قم بإنشاء اتصال و إضافته، ثم أخيرا إنشاء المرفقات. هذا يعني أنه إذا كان لا بد من خطأ وقت التشغيل الذي يقطع تنفيذ البرنامج النصي هناك، كل الأشياء المطلوبة لتكون في objectmodel قبل إنشاء مرفق، هي في النموذج. قد يحدث تلف إذا، على سبيل المثال، قد أضيفت فقط الاتصال، المرفقات المقدمة، ثم حدث خطأ في وقت التشغيل قبل النصي أخيرا أضافت عناصر جديدة إلى model.Corruption يمكن أن يحدث كلما كائن الذي تتم الإشارة إليه من قبل كائن آخر في وobjectmodel، هو في حد ذاته ليس في objectmodel.

وتشمل أخطاء وقت التشغيل سبيل المثال:

· مرجع كائن لم يتم تعيين إلى مثيل كائن - يحدث هذا عندما متغير كائن هو مرجع فارغة، ويتم استخدام أسلوب أو خاصية على هذا الكائن. ويمكن التحقق من المراجع فارغة كتبها 'إذا objectVariable شيء ثم ... "

· وكان المؤشر خارج حدود الصفيف - يحدث هذا عندما يتم الوصول مجموعة مع فهرس ما هو خارج حدود - على سبيل المثال أقل من 0 أو يساوي أو أكبر من طول / كونت مجموعة. مجموعة أو طول مجموعة يمكن التحقق من الخصائص. طول أو .Count على التوالي.

· لا يوجد تصريح استثناء - ليس لديك إذن ل... - يحدث هذا واحد إذا لم يكن لديك إذن لإجراء التغيير نظرا

· استثناء المفتاح الأساسي - مكرر / مفقود اسم / ID - سيحدث هذا واحد إذا تم إجراء تغيير سمة فريدة يتعارض مع كائن آخر. مثلا يجب أن تكون أبنية فريدة من نوعها بالاسم، وبالمثل مع المعايير.

· تكامل استثناء - وضع حقل مرجع إلى كائن وهو غير صالح. مثلا مضيفا 'لا شيء' أو باطل وهو طفل لكثير من المجموعات في objectmodel.

· صفر طول استثناء - قد يحدث هذا إذا حاولت تعيين اسم كائن إلى سلسلة فارغة. تتطلب معظم الكائنات أسمائهم أن يكون على الأقل 1 حرف.

واردات البيانات

لاحظ أنه في بداية البرامج النصية هيكل عظمي هناك عبارات مثل واردات ABACUS.ObjectModel. لن تتضمن هذه البيانات دلل التي لم يتم الرجوع إليها بالفعل من قبل البرنامج النصي - الغرض منها هو توفير "اختصار" إلى الحاجة إلى تحديد الاسم بالكامل من فئة.

على سبيل المثال، لتعريف متغير من نوع CComponent (تمثل عنصرا في ABACUS)، مع واردات ABACUS.ObjectModelبيان نحو الجزء العلوي من السيناريو، ويتطلب فقط أن يعلن عنها شركات قاتمة كما CComponent، لأن المترجم يعرف أن ننظر في مساحة الاسم ABACUS.ObjectModel لفئة CComponent. دون بيان الواردات، فإنه سيتعين عليها أن يعلن عنها خافت شركات كما ABACUS.ObjectModel.CComponent. جمعية (مثل mscorlib.dll، أو System.Windows.Forms.dll) يمكن أن تحتوي على مساحة أكثر من واحد - بيان الواردات لهذه النطاقات، وليس للجمعيات أنفسهم. الجمعية ABACUS.ObjectModel.dll يحتوي فقط على ABACUS.ObjectModel مساحة اسم واحد يمكن الوصول إليها عبر برمجة.

التجميعات المشار إليها تلقائيا

يتم الرجوع إليها DLLs التالية تلقائيا عن طريق برمجة:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (المشار إليها ضمنا من قبل مترجم)

· ABACUS.ObjectModel.dll

لجعل مراجع إضافية إما المجالس NET الأخرى، أو المجالس الخاصة بك، راجع المقطع التالي على #بيان ImportDLL.

#بيان ImportDLL

ابتداء من عام ABACUS 3.1، يمكنك الرجوع المجالس الإضافية التي قد تحتاجها من أجل البرمجة باستخدام ل #بيان ImportDLL. على سبيل المثال، إذا أردت الوصول إلى DLL مخصصة لك والاستفادة من وظائف في ذلك، هل وضعه في الدليل ABACUS ويشمل البيان بوصفه السطر الأول (ق) في السيناريو الخاص بك. إذا كان ملف DLL .NET، ثم عادة لا تحتاج إلى إدخال المسار بالكامل، فقط DLL.

· #ImportDLL C: \ ملفات البرنامج \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

بعض الأشياء الأخرى إلى ملاحظة ما يلي:

1. لأن دلس بحاجة إلى الاطلاع على ترجمة ووقت التشغيل، وهذا يحد من الطلب (غير .NET) دلس إلى وضعها في مجلد البرنامج ABACUS فقط.

2. #يجب أن تكون البيانات ImportDLL السطر الأول (ق) من برنامج نصي - إذا كان لديك 5 البيانات، ومن ثم ينبغي أن يكون على خطوط 5 الأولى من السيناريو

3. ل #بيان ImportDLL توضع في أي مكان ولكن الأسطر الأولى من السيناريو (على سبيل المثال إذا كان وضعه بعد تعليق أو بيان الواردات) لن تعمل بشكل صحيح و / أو قد تسبب أخطاء مترجم غير ذات صلة.

#ImportDLL مع جمعيات مكتب

إذا كان لديك تثبيت Microsoft Office، والسيناريو الخاص بك يتطلب المجالس مكتب إمكانية التشغيل المتداخل، فمن الممكن الرجوع لهم ببساطة عن طريق استخدام #ImportDLL مع اسم التجمع (كما هو موضح أدناه, مثلا #ImportDLL إكسل). باستخدام هذا الأسلوب له ميزة أنه ليس لديها مسار دلل المطلق لاستخدامها، وبالتالي فإن السيناريو هو أكثر المحمولة (يجب أن تعمل على كل من Office 2003 و 2007 دون تحرير النصي).

عند استخدام هذه الميزة، يتم البحث في GAC (جلوبل التخزين المؤقت للتجميع) لتجميع إمكانية التشغيل المتداخل، ويجمع النصي مع المسار إلى ذلك التجمع إن وجدت. إذا لم تكن العثور عليها، والبرمجة تحقق الدليل برنامج ABACUS (الذي يحتوي على برنامج Excel و Visio interops فقط). إذا لم يتم العثور على إمكانية التشغيل المتداخل طلب قبل هذا الوقت، ويظهر تحذير.

وعادة ما يتم تثبيت interops في GAC إذا كنت قد قمت بتثبيت Microsoft Office قبل تثبيت .NET Framework (والذي هو جزء من تركيب ABACUS الكامل). يمكنك تثبيتها قبل تنفيذ خيار التغيير من أجل Microsoft Office من إضافة / إزالة البرامج، واختيار الخيارات برمجة .NET. لمزيد من المعلومات، راجع هذا مقالة على MSDN.

المجالس التي يتم دعم هذا الاختصار هي:

· وصول

· Access.Dao

· تفوق

· رسم بياني

· MSProject

· اوت لوك

· OutlookViewCtl

· OWC11

· عرض تقديمي

· الناشر

· SmartTag

· برنامج Visio

· Visio.SaveAsWeb

· VisOcx

· كلمة

Iتي ليس من الواضح تماما إذا كانت كل التجمعات المذكورة أعلاه هي مفيدة، havebeen شملت الغرف في هذه الميزة regardeless عن بعض المستخدمين فبراير لديهم حاجة حتى لجمعيات غامضة.

انظر أيضا

محاكاة العمارة بك