Добавяне на предварително зададени свойства към компонент, връзка или тип

Navigation: Запълването на архитектурата> Имоти>

Добавяне на предварително зададени свойства към компонент, връзка или тип

Изпратете коментари по тази тема.

Стандартните библиотеки на имоти могат да бъдат определени и възложени на нещо друго в архитектурата. Тези библиотеки са известни като Стандарти, Като се използва Стандарти, Само трябва да се съберат конкретни системи свойства - стандартните свойства са вече там.

Например стандартните характеристики на изпълнение на Microsoft Windows 2000 могат да бъдат записани катоСтандарти възлага на всички компоненти (или връзки, а не, че това би било типично) използване на операционната система Microsoft Windows 2000.

За да добавитестандарткъм компонент, връзка или тип

1. Кликнете с десния бутонна компонент / връзка / тип.

2. Изберете Присвояване Стандарт.

3. Изберете aСтандартот списъка.

Вижте също

Запълването на архитектурата - Преглед | Промяна на свойствата на компонент, връзка или тип | Обобщените имоти

© 2001-2015 Avolution Pty Ltd. Всички права запазени.


Обобщените имоти

Navigation: Запълването на архитектурата> Имоти>

Обобщените имоти

Изпратете коментари по тази тема.

Операцията "Комплексно Имоти"Ви позволява да добавяте стойности на подобни имоти заедно и пишат (или добавяне) резултата в имоти избрания майка елемента. Той също така ви позволява да се определи обхватът на обобщаване и дали да актуализирате свойствата на всички под-елементи или не.

За свойствата на агрегат

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Щракнете с десния бутон върху елемент (архитектура, компонент или връзка), в която да се направи на обединената и изберете Обобщените имоти.

3. Изберете една от опциите Инертни (Traverse Всички поднива или Само Direct Sub-Level). Ако сте избрали Traverse Всички поднива, Можете също така да изберете опцията дали да Актуализация поднива.

o Traverse Всички подниваозначава, че обхватът на агрегация ще включва всички елементи в нивата по избрания елемент.

o Актуализация подниваможе да стане само, ако вие също сте избрали опцията Traverse Всички поднива, Това означава, че докато вие се обединят имоти от дъното нагоре, съвкупният резултат на всяко ниво също ще бъде актуализиран във всяка от съответните елементи.

o Само Direct Sub-Levelозначава, че само свойствата на елементите, разположени директно под избрания елемент ще бъдат обобщени.

o Изберете Включи СтандартИмотиако искате свойствата, определени в стандарти да бъдат включени. В противен случай, само уникални за всеки компонент, например, ще бъдат използвани.

4. Изберете кой свойства желаете да се обединят. Те са групирани в тяхната Видове.

5. Щракнете върху Следващиябутон.

6. Изберете опцията дали да Стойности за заменяне или Добави Ценностив избрания елемент.

o Стойности за заменянеще напиша резултатите директно в свойствата на избрания елемент.

o Добави Ценностище добави резултатите на съществуващите свойствата на избрания елемент.

Вижте също

Добавяне на предварително зададени свойства към компонент, връзка или тип | Промяна на свойствата на компонент, връзка или тип | Оценяване си архитектура


Архитектура Diff и Sync

Navigation: Анализирайки си архитектура>

Архитектура Diff и Sync

Изпратете коментари по тази тема.

Когато имате 2 или повече архитектури, или като еволюции и изходни архитектури, можете визуално "раз" двете архитектури, използващи стоките или диаграма Сравнение или Архитектура Diff функция. Това е особено полезно за откриване / повторното откриване на точните промени, направени от една архитектура на друг, докато се развива архитектури и развиват пътни карти в ABACUS.

Да се покаже "разл" с друга архитектура чрез диаграма

1. Уверете се, че имате ABACUS отворен файл .

2. Уверете се, вие имам най-малко 2 архитектури в проекта.

3. Отваряне на диаграмата, която искате да се сравни с друга архитектура.

4. Щракнете върху бутона "Сравни този Диаграма на съдържанието на друга архитектура" в лентата с инструменти Диаграма.

5. Изберете друга архитектура от падащия списък-надолу, за да се сравни с.

6. Можете да филтрирате какви разлики са показани като кликнете бутона "разликите" в лентата с инструменти Диаграма и премахнете отметката опции, напр Променен / Добавено / Unknown и Неопределен / Sync Препоръчано/ Дръжте Препоръчано.

Забележка

Компоненти и връзки по схемата ще бъдат подчертани в червен, зелен или лилаво когато са налице различия между съдържанието, което се вижда на настоящата схема и съдържанието в друга архитектура. Червен се използва, когато се препоръчва да се синхронизира разликите (виж по-долу), Зелен Използва се, когато той не се препоръчва да се синхронизира различията, че е им (виж по-долу) се запази и Лилаво Използва се, когато ABACUS не може да направи препоръка за синхронизиране на разликите (виж по-долу). Само видимата съдържанието на диаграмата се сравнява така че ако анотация се показва на стойност хранилище собственост и тази стойност се променя дадения компонент или връзка ще бъде показан в Слабата червена, слаб зелен или слаб лилаво и символ "*", показан в горния ляв ъгъл за компоненти, обаче, ако някой друг основната стойност хранилище имот се промени, че не се показва в анотация след това ще бъде даден няма индикация. Съдържание, което се случва на сегашната схема, но не е мач е намерена в сравнение архитектура ще бъде показан в силни червено, силна зелено или силна лилавои символ "+" показва горе-ляво за компоненти. Matching се извършва от типово и името на това, че ако вида или името на компонента, или връзката се е променило в друга архитектура не е мач ще бъде намерен. Тъй като няма начин за надеждно определяне дали допълнително съдържание от друга структура би била показана на настоящата схема (например допълнителен интерфейс между 2 компоненти, както е показано по-долу на схема от сравнението архитектура отдясно), тези разлики не са показано на схеми (те са показани за каталози по-долу). Застанал над всяка променената позиция ще покаже разликата в подсказка. Кръжи над символа "*" в горния ляв ъгъл на диаграмата се съдържа обобщение на промените (или никакви промени) между съдържанието на диаграмата и съдържанието на друга архитектура.

Цвят Legend

· Зелен показва, елементи, които не се препоръчват за синхронизиране на различията, които е да ги държи.

· Червен показва, елементи, които се препоръчва да се синхронизира разликите.

· Лилаво показва, изделия когато ABACUS не могат да направят препоръка за синхронизиране на различията.

Да се синхронизирате ("синхронизация") съдържание от една архитектура с друг чрез диаграма

1. Уверете се, че имате ABACUS отворен файл .

2. Уверете се, вие имам най-малко 2 архитектури в проекта.

3. Отваряне на диаграмата, която искате да се сравни с друга архитектура.

4. Щракнете върху бутона "Сравни този каталог на съдържанието на друга архитектура" в лентата с инструменти Диаграма.

5. Изберете друга архитектура от падащия списък-надолу, за да се сравни с.

Забележка

Вижте по-горе за начина, по който ABACUS показва "разл" между 2 архитектури в каталога. По-специално как Червен Използва се, когато еПрепоръчва се да се синхронизира различията, Зелен се използва, когато е неПрепоръчва се да се синхронизира на различията и Лилаво Използва се, когато ABACUS не може да направи препоръка за синхронизиране на различията.

6. Щракнете с десния бутон диаграма елемент (или елементи, използващи Shift или диаграма платното да Sync All), показващ "раз" и изберете опцията в менюто Sync.

Забележка

Всички промени синхронизация ще се прилагат само по отношение на архитектура, която каталога в момента на фокус принадлежи. За да приложите промените към друга архитектура трябва да използват стоките в друга архитектура. Освен това, потребителите ще могат да кандидатстват за синхронизация промени, ако само те имат разрешение за това .

Забележка

В зависимост от това къде сте с десния бутон върху елемента от менюто ще покаже какво точно насоки ще бъдат синхронизирани.Например Десния щракване един компонент на схемата само ще синхронизира този компонент. Като има предвид, щракване с десния бутон на диаграма платното и изберете Sync All ще синхронизира всички в момента показват разликите.

Да се покаже "разл" с друга архитектура чрез каталог

1. Уверете се, че имате ABACUS отворен файл .

2. Уверете се, вие имам най-малко 2 архитектури в проекта.

3. Отворете каталога желаете да се сравни с друга архитектура.

4. Щракнете върху бутона "Сравни този каталог на съдържанието на друга архитектура" в лентата с инструменти Каталог.

5. Изберете друга архитектура от падащия списък-надолу, за да се сравни с.

6. Можете да филтрирате какви разлики са показани като кликнете бутона "разликите" в лентата с инструменти Диаграма и махнете опции, например Променен / Добавено / Unknown и Неопределен / Sync Препоръчано/ Дръжте Препоръчано.

Забележка

Клетките в каталога ще бъдат подчертани в червен, зелен или лилаво когато са налице различия между съдържанието в текущия каталог и съдържанието на съвпадение в другата архитектура. Червен се използва, когато се препоръчва да се синхронизира разликите (виж по-долу), Зелен Използва се, когато той не се препоръчва да се синхронизира различията, че е им (виж по-долу) се запази и Лилаво Използва се, когато ABACUS не може да направи препоръка за синхронизиране на разликите (виж по-долу). Само видимите редове и колони в каталога се сравняват така че ако има разлика в един ред отвъд момента показани редовете или стойност в колона, която не се показва има ли разлика тогава няма разлика ще бъде посочен. Когато стойността в индивидуална клетка е различна с съвпадение на клетката в сравнение архитектура ще се маркира границата клетка. Селекторът на глава и ред колона също ще бъде засенчена в слаб лилавои изобразяват със символа "*". Тези "*" символи могат да се кликне да преминете към следващия разликата в колона или ред, съответно. Редове, което се извършва в текущия каталог, но не е мач е намерена в сравнение архитектура ще бъдат показани със символ на '+' в селектора на ред в ляво и границата на целия ред ще бъде осветен. Редове, които биха възникнали в сравнение архитектура е версия на каталога (т.е. със същите филтри и т.н.), но не е мач е намерена в сегашната архитектура ще бъдат показвани с - символ в селектора на ред в ляво, на границата на '' целия ред ще се маркира и съдържанието на цели редове клетки ще бъдат показани в слаб лилавои стреля-чрез, например 8 ч до 18:00, Matching се извършва от типово и името на това, че ако вида или името на компонента, или връзката се е променило в друга архитектура не е мач ще бъде намерен. Застанал над всяка променената позиция ще покаже разликата в подсказка. Кръжи над символа "*" в горния ляв ъгъл на диаграмата се съдържа обобщение на промените (или никакви промени) между съдържанието на диаграмата и съдържанието на друга архитектура.

Цвят Legend

· Зелен показва, елементи, които не се препоръчват за синхронизиране на различията, които е да ги държи.

· Червен показва, елементи, които се препоръчва да се синхронизира разликите.

· Лилаво показва, изделия когато ABACUS не могат да направят препоръка за синхронизиране на различията.

Да се синхронизирате ("синхронизация") съдържание от една архитектура с друг чрез каталог

1. Уверете се, че имате ABACUS отворен файл .

2. Уверете се, вие имам най-малко 2 архитектури в проекта.

3. Отворете каталога желаете да се сравни с друга архитектура.

4. Щракнете върху бутона "Сравни този каталог на съдържанието на друга архитектура" в лентата с инструменти Каталог.

5. Изберете друга архитектура от падащия списък-надолу, за да се сравни с.

Забележка

Вижте по-горе за начина, по който ABACUS показва "разл" между 2 архитектури в каталога. По-специално как Червен Използва се, когато еПрепоръчва се да се синхронизира различията, Зелен се използва, когато е неПрепоръчва се да се синхронизира на различията и Лилаво Използва се, когато ABACUS не може да направи препоръка за синхронизиране на различията.

6. Щракнете с десния бутон на клетка, колона или ред позиция (или няколко елемента, използващи Shift или Ctrl + A за всичко), показващ "раз" и изберете опцията в менюто Sync.

Забележка

Всички промени синхронизация ще се прилагат само по отношение на архитектура, която каталога в момента на фокус принадлежи. За да приложите промените към друга архитектура трябва да използват стоките в друга архитектура. Освен това, потребителите ще могат да кандидатстват за синхронизация промени, ако само те имат разрешение за това .

Забележка

В зависимост от това къде сте десен клик (т.е. една клетка, колона или позиция ред) елемент от менюто ще покаже какво точно насоки ще бъдат синхронизирани.Например Десния щракване единна собственост или прикрепени компонент на клетките в каталога ще се синхронизира само това имущество или прикрепени компонент. Като има предвид, щракване с десния бутон подред позиция (или позиции, използвайки Shift) ще синхронизират целия ред (или редове). Десния щракване с глава колона ще се синхронизира всички различия в тази графа.

За да видите 'разл'2 цяло архитектури

1. Уверете се, че имате ABACUS отворен файл .

2. Уверете се, вие имам най-малко 2 архитектури в проекта.

3. Изберете Инструменти| Архитектура Diff ....

4. В диалоговия прозорец, който се появява изберете първия / От втория и / За архитектури за сравнение.

5. Кликнете върху Добребутон.

Архитектура Diff

Цвят Legend

· Зеленпоказва, че възелът е добавен във втория / архитектурата.

· Червенпоказва, че възелът е била изтрита във втория / За архитектура.

· Синпоказва, че възелът има различни параметри (напр свойства или стандарти) във втората / до архитектура.

· Жълтпоказва, че възел има разлики в деца във втория / архитектурата така трябва да се разшири възел.

Забележка

Можете да щракнете с десния бутон и "Show в Explorer" на всички възли, за да видите детайли и повече информация се дава на различията в Разлики Резюме панел, когато е избран възел.

Вижте също

Анализирайки си архитектура | Преглед на диаграма, време за реакция | Преглед разсеяно матрица от вашите еволюирали архитектури | Развиващите си архитектура


Промяна на свойствата на компонент, връзка или тип

Navigation: Запълването на архитектурата> Имоти>

Промяна на свойствата на компонент, връзка или тип

Изпратете коментари по тази тема.

Информацията обикновено са системните изисквания, които дефинирате, или резултатите от оценките на ABACUS ". (Когато ABACUS изпълнява своите оценки, той пише имоти обратно към файла.) С други думи, имоти са нещата, които знаят за вашата система, или нещата, които използвате ABACUS, за да разберете.

За да промените стойността на имота на компонент, връзка или тип

1. Кликнетена компонент / връзка / тип (неговите качества ще показват в прозореца Properties на дясно).

2. Кликнетеза да маркирате имота, който искате да промените.

3. Типнова стойност.

Важно

Също така, много имоти се определят с помощта на Стандарти , Чрез промяна на имот в рамките наСтандарт, Не само промените текущия обект, можете също да промените капитана Стандарт (под Стандарти вна върха на дървото). Преди да направи това, да проверите какво в други компоненти, връзки или типове използвате Стандарт, Тъй като промяната може да не е свързана с тях- Можете да използвате прозореца Референции за това.

Бакшиш

Можете да промените свойствата на свързване е в рамките на клона Компоненти на дърво (и обратно). Така, например, ако търсите в това, което връзки са прикрепени към компонент, и ти осъзнаваш, че трябва да се промени една, можете.

За добавяне на нови свойства за компонент или връзка (чрез вида)

Забележка

Информацията може да се прибавят само към видове и техните компоненти или връзки от типа "наследи" тези имоти.

1. Кликнетеот вида (неговите качества ще показват в прозореца Properties на дясно).

2. Кликнетевърху бутона Add в горната част на прозореца на имота, за да добавите един ред в горната част на таблицата с имот за новата вещ.

3. Добави Типза новия имот.

4. Добави Имеза новия имот.

5. Добави Стойност по подразбиранеза новия имот.

6. Добави Мерна единицаза новия имот.

7. Задайте Тип на даннитеза новия имот.

Забележка

Полето Тип Данните могат да се използват за ограничаване на валидните стойности, които един имот може да има. Това е; Текст, Integer, Decimal, Date / Time, Boolean или Списък.

o A Текстсобственост е тази, която има неограничен брой символи и по същество все още няма ограничения по отношение на стойността.Ако стойността на имота е правилно оформена хипервръзка (т.е. URL адреси трябва да се започне с един от 5струни; HTTP: //, HTTPS: //, FTP: //,файл:или \\ и всякаквапространства следва да бъдат вписани с "% 20"), След това връзката се кликва (чрез Ctrl + клик).

o An Цяло числособственост трябва да е цяло число или положителни или отрицателнии може да съдържа един период, пространство, апостроф или запетая за цифри групиране в зависимост от проекта Регионални настройки от File | Опции на проекта.Настройките на региона и на.Нето Метод Long.TryParse е използва за определяне на валиден Цяло числоценности.

o A Десетиченимот може да съдържа период или запетая за десетични символа и може да съдържа един период, пространство, апостроф или запетая за цифри групиране в зависимост от проекта Регионални настройки от File | Опции на проекта.Настройките на региона и на.Нето Метод Decimal.TryParse е използва за определяне на валиден Десетичен ценности.

o A Време за срещасобственост позволява на всяка една Дата част или Time част или и двете. Регионът настройкии .Net Метод DateTime.TryParse са предимно използва за определяне на валидни за дата и / или час ценности. Въпреки това, Дата част, ако е приложимо, изисква най-малко на ден и месец (на годината ще се приеме за текущата година) или месец и година части, за да бъдат валидни. Т.е. Юни Q3 2010 или дори само 2010 са невалидни. Макар че това ще се различават с различни регионални настройки, обикновено частите Ден, месец и година, могат да се разделят с интервал, запетая, тире ("-") или наклонена черта ("/"). Част на деня обикновено е цяло число от 1 до 31. Частта за месец обикновено е цяло число от 1 до 12, валиден 3 писмо съкращение за месеците (напр Яну, Feb, Mar) или името на цял месец (напр януари, февруари , Март). Година част е обикновено 4-цифрен номер, но положително 1, 2 и 3 двуцифрени години са приети в съответствие с настройките в Control Panel-> Регионална и Language Options-> Options- Регионално> Персонализиране (бутон) -> Дата-> Календар. Обикновено те се тълкуват, както следва; 0-29 се тълкува в смисъл, 2000-2029, 30-99, както и 1930-1999 100-999 както 100-999. Невалидни дати като 31 Юни 2010 и 31/9/2010 ще бъдат открити. Частта на времето, ако е приложимо, изисква един часове и минути част и евентуално Seconds част. Часовете, минутите и незадължителните Секунди части обикновено са разделени с двоеточие (":") и Seconds част може да бъде определен с десетична запетая ("."). За допълнителна информация за валидните формати моля вижте секцията Забележки за .Net Метод DateTime.TryParse .

Бакшиш

Препоръчително е да се използват най-малко 3 писмо име месеца формат (т.е. "Юли" или "юли") за дата ценности, а не на числения форматиране (т.е. "7" или "07"), тъй като тези стойности ще валидират през повечето региони в зависимост на проекта Регионални настройки от File | Опции на проекта.Т.е. препоръчително е да се използва "15-ти юли 2010", а не "15/7/2010" или "07.15.2010". С този пример, "15/7/2010" ще се провали валидиране за "English (United States)" и "07.15.2010" ще се провали за "English (United Kingdom)" обаче "15 Юли, 2010" ще мине за и двамата.

o A Булевасобственост може да бъде или Вярно или невярно.Той е нечувствителен толкова вярно или невярно може да се използва обаче Да, Не, 1, 0 т.н. всички ще успеят никакви ограничения собственост.

o A Списъкимот позволява събирането на предварително определени стойности, като Low | Medium | Високо или Запазва | Обнови | Редизайн | Пенсионират и диапазона на стойностите идва от областта на Unit за имота или като запетайка или тръба "|" разделят стойности. Имотът може да се счита за реден (за разлика от номиналната, интервал или съотношение), защото, когато се използва по класациите и да цвят елементи на диаграмаите и 3ds стойностите се третират просто във възходящ (или низходящ) ред. Ето стойности се нанасят във възходящ (или низходящ) ред на структура оси или цветови гами.

8. Типът на данните може да се настрои да бъде хора с увреждания, Предупреден или Принудителнокликнете с десен бутон Type полето за всяка настройка, различна от текст, който позволява никакви символи, така че никога не може да са неправилни на данните.

9. Задайте Длъженфлаг за новия имот.

Забележка

The Задължително поле може да се използва, за да се посочи дали на стойност не трябва да бъде вписан за имота. Това е, че тя не може да бъде празно или празна. Фалшиве по подразбиране и означава имотът може да бъде празно или празен, Вярноозначава, че имотът трябва да има стойност и не може да бъде празно или празно. Необходимата може да бъде настроен да бъде хора с увреждания, Предупреден или Принудителнокликнете с десен бутон поле Задължително, ако е бил зададен на True.

Вижте също

Запълването на архитектурата - Преглед | Добавяне на предварително зададени свойства към компонент, връзка или тип | Обобщените имоти


Промяна компонент / Вид връзка на

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Промяна компонент / Вид връзка на

Изпратете коментари по тази тема.

Компоненти и свързване видове се използват главно за целите на класирането. Можете да използвате видове филтри, както когато гледате вашата архитектура. Например, вместо да гледате цялото това нещо, можете да видите само на компоненти за нанасяне.

За да промените компонент / Вид връзка на

1. Кликнете с десния бутонна компонента или връзката.

2. Изберете Change Type.

3. Изберете различен тип от списъка.

Бакшиш

Когато промените от тип, може да получите някои нови стандартиили свойства (каквото и да е свързано с тип - виж Типове клон на дървото). Вашият съществуващата стандарти и имоти ще останат непроменени. Можете да създадете свои собствени нови видове и да се определят свои собствени комбинации от стандарти и свойства за тях.

Вижте също

Създаване на нов тип | Запълването на архитектурата - Преглед | Анализ Вашата архитектура


Промяна на настройките Регион на проекта

Navigation: Запълването на архитектурата> Имоти>

Промяна на настройките Регион на проекта

Изпратете коментари по тази тема.

Стойности за имота изисква определена форматиране в различни региони, за да отговаря на всякакви Тип Data ограничения за Integer, Decimal и Date / Time свойства. Например в Австралия десетичната "двадесет и сто и три хиляди четиристотин петдесет и шест точка седем осем девет" е представен като "123,456.789", докато в Германия тя ще бъде represnted като "123.456,789" и във Франция, че ще бъде " 123 456789 ".По същия начин, в САЩ на "втория от декември 1970" е представена като кратък срок като "02.12.1970", но в Обединеното кралство той е представен като "02.12.1970" и в Полша като "1970-12 -02 ". Съответно, за да работите с проект ABACUS в отделните региони е необходима глобална настройка за проект ABACUS.

За да промените настройки на проекта ABACUS на Регион

1. Уверете се, че имате ABACUS файлотворен.

2. Изберете File | Опции проекта ... и от диалоговия прозорец, който се появява изберете Област и кликнете OK, Забележка: Моля, направете справка в раздела по-долу за регионалните настройки по подразбиране.

Забележка

Ако не виждате Опции проекта ... елемент от менютотогава не е нужно Проектанта и Administrator добавкаs и не можете да променяте регион на проекта.Също така, ако не е настроен Region (т.е. на региона в Options на проекта е "Няма (System област)"), то тогава всеки Настройки на сегашната култура на потребителя MS Windows (т.е. Регионално Settings)се използват за валидиране на имотите.

Регион подразбиране

Таблицата по-долу изброява по подразбиране за всеки регион, както е през анализатора File | Опции проекта ...елемент от менюто.Моля вижте по-долу таблица за списък на символите, използвани.

Област | Decimal Symbol | Групиране Digit | Минус | Кратко време | Дълго време | AM / PM символ | Кратко Дата | Long Дата
English (Австралия) | . | , | - | HH: mm | HH: мм: сс | AM | PM | дд / мм / гггг | дд MMMM гггг
English (United Kingdom) | . | , | - | HH: mm | HH: мм: сс | AM | PM | дд / мм / гггг | дд MMMM гггг
English (United States) | . | , | - | з: mm TT | ч: мм: сс TT | AM | PM | M / г / гггг | DDDD, MMMM дд гггг
Френски (Франция) | , | пространство | - | HH: mm | HH: мм: сс | | | дд / мм / гггг | DDDD г MMMM гггг
Немски (Германия) | , | . | - | HH: mm | HH: мм: сс | | | Опушен | DDDD, г. MMMM гггг
Италиански (Италия) | , | . | - | HH: mm | HH: мм: сс | | | дд / мм / гггг | DDDD г MMMM гггг
Испански (Испания) | , | . | - | H: mm | H: мм: сс | | | дд / мм / гггг | DDDD, дд "де" ММММ "де" гггг
English (Канада) | . | , | - | з: mm TT | ч: мм: сс TT | AM | PM | дд / мм / гггг | ММММ-дд-уу
Френски (Канада) | , | пространство | - | HH: mm | HH: мм: сс | | | YYYY-MM-DD | г MMMM гггг
Arabic (U.A.E.) | . | , | - | чч: мм TT | чч: мм: сс TT | ص | م | дд / мм / гггг | дд MMMM, гггг
Arabic (Саудитска Арабия) | . | , | - | чч: мм TT | чч: мм: сс TT | ص | م | дд / мм / гг | дд / MMMM / гггг
English (Южна Африка) | , | пространство | - | чч: мм TT | чч: мм: сс TT | AM | PM | гггг / мм / дд | дд MMMM гггг
English (Нова Зеландия) | . | , | - | з: mm TT | ч: мм: сс TT | ч | p.m. | г / мм / гггг | DDDD, D MMMM гггг
English (Индия) | . | , | - | HH: mm | HH: мм: сс | AM | PM | дд-ММ-гггг | дд MMMM гггг
Немски (Швейцария) | . | ' | - | HH: mm | HH: мм: сс | | | Опушен | DDDD, г. MMMM гггг
Френски (Белгия) | , | . | - | HH: mm | HH: мм: сс | | | г / мм / гггг | DDDD г MMMM гггг
Холандски (Белгия) | , | . | - | H: mm | H: мм: сс | | | г / мм / гггг | DDDD г MMMM гггг
Чехия (Чехия) | , | пространство | - | H: mm | H: мм: сс | DOP |. ОРП. | d.M.yyyy | д. MMMM гггг
Датски (Дания) | , | . | - | HH: mm | HH: мм: сс | | | дд-ММ-гггг | д. MMMM гггг
Гръцки (Гърция) | , | . | - | з: mm TT | ч: мм: сс TT | πμ | μμ | г / M / гггг | DDDD, D MMMM гггг
Фински (Финландия) | , | пространство | - | H: mm | H: мм: сс | | | d.M.yyyy | д. Гггг MMMM'ta "
Унгарски (Унгария) | , | пространство | - | H: mm | H: мм: сс | де |. дю. | yyyy.MM.dd. | гггг. MMMM г.
Холандски (Холандия) | , | . | - | H: mm | H: мм: сс | | | D-M-гггг | DDDD г MMMM гггг
Норвежки, книжовен (Норвегия) | , | пространство | - | HH: mm | HH: мм: сс | | | Опушен | д. MMMM гггг
Polish (Poland) | , | пространство | - | HH: mm | HH: мм: сс | | | YYYY-MM-DD | г MMMM гггг
Руски (Русия) | , | пространство | - | H: mm | H: мм: сс | | | Опушен | г MMMM гггг "г."
Шведски (Швеция) | , | пространство | - | HH: mm | HH: мм: сс | | | YYYY-MM-DD | "бърлога" D MMMM гггг
Корейски (Корея) | . | , | - | TT з: mm | ТТ ч: мм: сс | 오전 | 오후 | YYYY-MM-DD | гггг "년" М "월" г "일" DDDD
Иврит (Израел) | . | , | - | HH: mm | HH: мм: сс | AM | PM | дд / мм / гггг | DDDD дд MMMM гггг

Следните символи се използват, за да определят как се показват дати и часове:

Час символа |
h | Час (чч показва час с водеща нула)
m | Minute (mm показва минутите с водеща нула)
s | Втори (СС показва втората с водеща нула)
TT | А.М. или P.M.
з / H | 12 или 24 часов дисплей време
Дата символа |
D, DD | Ден
DDD, DDDD | Ден от седмицата
M | Месец
y | Година

Вижте също

Запълването на архитектурата - Преглед | Промяна на свойствата на компонент, връзка или тип | Добавяне на предварително зададени свойства към компонент, връзка или тип


Опции на командния ред

Navigation: Референтен>

Опции на командния ред

Изпратете коментари по тази тема.

Можете да извършвате различни операции ABACUS директно от командния ред с най-честата операция е да се отвори конкретен проект файл и да го публикувате в HTML.

По-конкретно, използването на команди на ABACUS е, както следва;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ потребител "USER" / мине "PASS"]

Аргумент | Описание
ProjectFile | The ProjectFile може да бъде или файл на ABACUS проект (.abacus), библиотека файл (.abacuslib), XML файл (.xml) или MS Access DB (.mdb) и даден файл или ще бъде отворен (ако .abacus или .abacuslib ) или нов проект, създаден (ако .xml или .mdb файл).
OptionalFile | The OptionalFile може да бъде или ABACUS скрипт (.abacusscript, .vb или .cs), макро (.abacusmac) или файл библиотека (.abacuslib) и даден файл или ще се стартира след отваряне на ProjectFile (ако .abacusscript, .vb или .cs или .abacusmac) или просто отварят (ако .abacuslib).
/ exitOnCompletion | Ще излезете ABACUS и, ако се изисква спасяване и извършване на каквито и да било промени в проектите отворени .abacus за завършване на всяко скрипт или макрос. Забележка: Този флаг е чувствителна, така че не забравяйте да използвате главна "O" и "C" в текста, както е показано.
/ dontShowDialogs | Ще се предотврати ABACUS Enterprise Edition (EE) диалогови прозорци за известяване актуализация показването при отваряне на проект. Забележка: Този флаг е чувствителна, така че не забравяйте да използвате главна "S" и "D" в текста, както е показано.
/ потребител "USER" / мине "PASS" | Потребителско име и парола USER ПРЕДАЙ ще се използва за влизане в проекта с императивни всички записани пълномощията на потребителя. Забележка: Двойни кавички трябва да бъдат поставени около потребителя и PASS знамена и две двойни кавички могат да бъдат използвани, за да избягат в двойни кавички или потребителската или PASS знамената.

Например;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.хб"/ exitOnCompletion / dontShowDialogs / потребител "Public" / мине "123456"

кога тече от директорията, в която на ABACUS.exe двоичен е намира се ще отворен Пример проекта и влезте като потребител Public с парола 123456 (както е описано тук ), Публикува тя да HTML и след това затворете проекта всичко, без да показват никакви диалози по протежение на пътя (например "Актуализация успешен" или "Няма достъпни актуализации" за проекти на предприятието).

Например;

ABACUS.exe "Data \ Example.abacus" "Scripts \Каталог Excel Import.хб"/ exitOnCompletion / dontShowDialogs

кога тече от директорията, в която на ABACUS.exe двоичен е намира се ще отворен Пример проекта и да импортирате "сървъри (2014 Жилищна) .xlsx" MS Excel файл в каталога "Servers" на "Жилищна 2014" Архитектурата на проекта, без да показват никакви диалози по протежение на пътя и след затварянето на проекта при завършването. Ако операцията прави промени в проекта след това при затваряне на промените се запазват локално и ако един проект Enterprise ангажира с Enterprise Server,.

Забележка

Не забравяйте да използвате правилния двойни кавички характер, тъй като има няколко в стандартния набор ASCII характер и Windows Command Prompt ще работи само с правилно правилния. Правилният двойна кода цитат герой е Decimal 34 (Шестнадесетично 22).Това е, което се използва в примера по-горе, така че не се колебайте да копирате / го поставете от там.


Копиране и поставяне

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Копиране и поставяне

Изпратете коментари по тази тема.

Можете да копирате част или цялата си архитектура и да го поставите на друго място в дървото.

За да копирате

1. Кликнете с десния бутонвърху елемента, който искате да копирате.

2. Изберете копие.

За да поставите

1. Отидете на дървото, за да намерите мястото, което искате да поставите елемента.

2. Кликнете с десния бутонна клона, който искате да се появи в рамките на.

3. Изберете Паста.

4. Продуктът ще се копира с оригиналното име (освен ако не сте го копирате в оригиналната клона - тогава тя ще се нарича "Копие на ...").

Вижте също

Как се архитектура, представена в ABACUS


Копиране на диаграми

Navigation: Запълването на архитектурата> Използване Рисунки>

Копиране на диаграми

Изпратете коментари по тази тема.

Има 2 основни сценарии за копиране на съществуваща схема; в рамките на архитектурата, или през архитектури.

Да се копиедиаграмав рамките на архитектурата

1. Уверете се, че иматеABACUS отворен файлсъдържаща вашето населена архитектурас най-малко една диаграма.

2. Разширяванена Diagramsклон (и всички необходими Диаграма групи) на даден Архитектурасечение на дървото.

3. Изберете диаграмата, която искате да копирате, и след това натиснете Ctrl + C или Кликнете с десния бутони изберете копие от менюто.

Забележка

A копие от диаграма ще бъде добавен към Diagramsклон на един и същ архитектура. Той ще има "Копие на" приложена към началото на името, Които можете да промените по-късно от натиснете F2 или щракване с десния бутон върху негои изберете Rename.

Да се копирате диаграма цяла архитектури

1. Уверете се, че иматеABACUS отворен файлсъдържаща вашето населена архитектураsс най-малко една диаграма.

2. Разширяванена Diagramsклон (и всички необходими Диаграма групи) на на Архитектурасечение на дървотоза архитектурата, която съдържа диаграмата, която искате да копирате.

3. Изберете диаграмата, която искате да копирате и относно Общи имотипрозорец за сведение на Гледна точка че диаграмата е свързано с (в полето Тип).

4. Сега, разширяванена Diagramsклон (и всички необходими Диаграма групи) на на Архитектурасечение на дървотоза друга архитектура, която искате да копирате на диаграмата в.

5. Кликнете с десния бутонна Diagrams възел (или Диаграма група) И изберете Създайте Диаграма ..., В диалоговия прозорец, който се появява изберете Гледна точка Беше отбелязано, че в стъпка 3 по-горе в падащото меню в горния десен ъгъл. Остави всичко друго, както е и натиснете Добре, В диалоговия прозорец Диаграма Име на въведете име за (скоро ще бъде) копират диаграмата. Забележка: A празно диаграма платно в зависимост от избрания гледна точка ще бъде открита.

6. Назад към диаграмата, която искате да копирате и отворите, че от щракване с десния бутонвъзела и подбора Отворено или просто двукратно щракванетова.

7. Изберете фона платно на диаграмата, която искате да копирате, и натиснете Ctrl + A, Това ще избере всички елементи на тази схема. Сега натиснете Ctrl + Cда копирате съдържанието на клипборда.

8. Сега се върнете в празно диаграмата в архитектурата, който искате да копирате съдържанието в, изберете фонаплатно и или Кликнете с десния бутони изберете Паста или просто да натиснете Ctrl + Vда поставите съдържанието. След кратко време, съдържанието на всички ще бъде поставен в нов празен диаграмата.

Забележка

Elements ще бъдат добавени към най-високо ниво на новата архитектура и ще трябва да бъдат повторно организирано или сля със съществуващото съдържание съответно.

Вижте също

Инструментът Drawing | Запълването на архитектурата | Анализ Вашата архитектура


Създаване на нов компонент / връзка Type или Type Group

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Създаване на нов компонент / връзка Type или Type Group

Изпратете коментари по тази тема.

Компоненти и свързване видове се използват главно за целите на класирането. Можете да използвате видове филтри, както когато гледате вашата архитектура. Например, вместо да гледате цялото това нещо, можете да видите само на компоненти за нанасяне.

За да създадете нов компонент / връзка Type

Забележка

За да добавите типове или тип групи в проект ABACUS лиценза за употреба трябва Designer добавка способност. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

1. Разгънете Видовеклон на дървото.

2. Кликнете с десния бутонна Компонент Видове (или Типове връзки).

3. Изберете Добави Компонент Type (или Добави Тип на връзката) или Създайте Group.

Бакшиш

След като сте създали тип, трябва да се промени неговата икона (виж по-долу) и да добавите свойства и стандарти на него за компонент или инстанции за свързване към "наследяват".

За да промените иконата за компонент / връзка Type

Забележка

За да промените иконите за видове в проект ABACUS лиценза за употреба трябва Designer добавка способност. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

1. Кликнете с десния бутон на Component Type (или Тип на връзката), Който искате да промените иконата за.

2. Изберете Change Icon.

3. В диалоговия сърфирате в Select Икона на място и изберете файл с изображение и кликнете Open.

Забележка

Можете да имате потребителска икона образ на всякакви размери, но тя винаги ще бъде увеличен, за да до 16x16 пиксела изображението в прозореца Explorer. Така че, ако си оригинален потребителска икона образ не е със същата височина и ширина вашия Window Explorer икона ще бъде опъната. Съответно, персонализирани изображения трябва да са най-малко 16x16 пиксела и ако искате да се запази точната форма на иконата обичай се уверете, че вашата потребителска икона образ е еднаква височина и ширина в пиксели (16x16 или по-големи). Вие също трябва да бъдат внимателни, за да не оцветени "пиксели" ще целия път до границата на изображението потребителска икона като тя ще изглежда лошо в прозореца Explorer с прилежащите икони "кървене" един в друг. Съответно, трябва да оставите поне един пиксел бял кант.

Бакшиш

Можете да направите вашата потребителска икона образ на .ico, .bmp, .gif, .jpg или .png формат файл, но поради ограничения в Windows само .ico формат ще визуализирате в диалога ABACUS Изберете Icon ако имате опцията View Menu настроен на нещо различно от Thumbnails.

Вижте също

Запълването на архитектурата - Преглед | Анализ Вашата архитектура


Създаване или копиране на архитектурата

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Създаване или копиране на архитектурата

Изпратете коментари по тази тема.

Можете да имате неограничен брой архитектури в един ABACUS файл. Обикновено, вие ще създадете нова архитектура всеки път, когато искате да моделирате и оцени еволюция на вашата система.

За да създадете нова архитектура

1. Кликнете с десния бутон на Архитектуриклон на дървото.

2. Изберете New Архитектура.

За да създадете копие на съществуваща архитектура

1. Кликнете с десния бутонна архитектурата.

2. Изберете копие.

3. Кликнете с десния бутон на Архитектуриклон на дървото.

4. Изберете Паста.

5. Новата структура ще се нарича "Копие от ....

За да се развива съществуваща архитектура

1. Кликнете с десния бутонна архитектурата.

2. Изберете Evolve.

3. Новата структура ще се нарича "... 0.1".

Забележка

Налице е подробно описание на променящите архитектури тук .

Вижте също

Как се архитектура, представена в ABACUS | Развиващите си архитектура


Персонализирани отчети

Навигация: Представяне на информация за вашата архитектура>

Персонализирани отчети

Изпратете коментари по тази тема.

Персонализирани отчети ABACUS "ви позволяват да създавате напълно конфигурируеми персонализирани отчети. Докладите могат да включват персонализирани изображения и графики, както и подробно описание на всички компоненти, връзки или атрибути от хранилище ABACUS както и подробни аналитични резултати от различни симулации (включително TCO, производителност и надеждност). Допълнително, доклади могат да съдържат диаграми, графики, каталози, матрици / осеви таблици, карти, габарити, sparklines, барове данни и показатели (например трафик светлини).

Забележка

Докато всеки потребител може да отвори съществуващи персонализирани отчети, то конфигуриране доклади лицензията за нуждите на потребителите на Доклад Configuration способност. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

За да видите обичай доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура(с).

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетиЩе се появи прозорец.

Персонализирани отчетипрозорец

3. Изберетесъществуващ Докладкойто искате за да се покаже от Налични Reportsраздел.

4. Кликнете Run Доклад.Докладът ще бъде открит в Microsoft Доклад Viewer и то Навигирайте чрез страниците на доклада, кликнете върху иконите [image] намира в лентата с инструменти в горния ляв ъгъл на екрана.

Забележка

Можеш спасяване Докладът различни формати Кликни върху Износ икона доклад [image] намира се в В лентата с инструменти. Можете да изберете да изнасят в следните формати: Excel, PDF и Дума, Моля, запишете отчета в желаното място за по-нататъшна употреба. Ако са направени промени в архитектурата на по-късен етап, нов доклад ще трябва да бъде създаден, за да се отразят промените.

Да се редактирате данните на хранилище, което се изпраща на a обичай доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура(с).

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетипрозорец (посочено по-горе) ще бъдат показани.

Забележка

Докато всеки потребител може да отвори съществуващи персонализирани отчети, то конфигуриране данните, които се изпращат на персонализиран отчет лицензията за нуждите на потребителите на Доклад Configuration способност. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

3. Изберетесъществуващ Докладкойто искате за да се покаже от Налични Reportsраздел.

4. Кликнете Комплекти Edit Data. The Data Set EditorЩе се появи прозорец.Този прозорец показва събирането на групи от данни, които в момента се изпращат до персонализиран отчет. В примера по-долу има три (3);

· един ApplicationProxy набор от данни, които се уточняват всички подробности за всички компоненти за кандидатстване в "2015 Край на" архитектура (включително свойствата на техните стандарти и всички свързани компоненти),

· набор TwoDViewProxy данни, които се посочват една или повече Diagrams когато наименованието мачове "Application Landscape (Австралия)",

· а TargetProxy набор от данни, които се уточняват всички подробности за всички Целеви връзки в "2015 Край на" архитектура (включително приложените компоненти).

Data Set Editorпрозорец

Забележка

Името Query ще се използва за името Dataset в Microsoft Report Builder (виж по-долу). Полето Включи се уточнява дали данните са нито един елемент, а Събиране на елементи, всички съставни Видове, Всички типове връзки, един или повече архитектури, една или повече схеми или един или повече с класации. За "Съвкупността от елементи" на данните определя се предоставя един бутон Филтър които при кликване се отваря прозорецът Филтър Element, който ви позволява да прилагате множество филтри, за да се върне само елементи от някои архитектури, и / или на определени видове, и / или с определени стандарти , и / или прикрепена към определени компоненти, и / или с някои родители, и / или в някои Diagrams, и / или в някои класации и / или с дадени стойности на имота. За останалите видове набор от данни се предоставя полето Име, и с помощта на бутона за избор можете да изберете обекта (ите), за да бъдат включени в масива от данни.

Забележка

Наборите от данни, които се съхраняват вЗадава файл Data (.XML)със същото име като база файл единасоцииран Доклад Definition файл (.RDL), Ако този файл не съществува набор от данни редактор автоматично ще се пренесат с някакви имена от заявките, които съществуват в Доклад Definition файл (.RDL)и нова Задава файл Data (.XML)Ще бъде създаден веднъж аа валиден списък на заявки е определена.

3. Ако желаете да изтриете съществуващ набор от данни след това изберете Изтрий Queryбутон.

4. Ако желаете да добавите нов набор от данни, след което щракнете върху бутона Добави New Data Setбутон и изберете данните, описани по-горе забележката.

Да се създадете ново доклад(от шаблон)

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура.

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетипрозорец (посочено по-горе) ще бъдат показани.

3. Кликнете Нов и изберете или A4 - Portrait, A4- Landscape, A3 - Portrait, A3- Landscape, US Letter - Portrait, US Letter - Landscape, US Tabloid - Portrait или US Tabloid - Landscapeв зависимост от доклада ориентация и размера на хартията, която се желае.

4. Намерете мястото, за да спаси Доклад Definition файл (.rdl / .rdlc) и съвпадение Set Data файл (.xml) и кликнете Save, Това ще добави нов персонализиран отчет към Available секцията Доклади на прозореца на персонализирани отчети и може да отвори или редактирали, както е описано по-горе.

Да се добавите съществуващ обичай доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура.

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетипрозорец (посочено по-горе) ще бъдат показани.

3. Кликнете Добави и отидете на местоположението на Definition файл Доклад (.rdl / .rdlc) и кликнете Отворено, Това ще добави нов персонализиран отчет към Available секцията Доклади на прозореца на персонализирани отчети и може да отвори или редактирали, както е описано по-горе.

Забележка

Предполага се, че файл Комплект съвпадение на данните (.xml) съществува в същото място като файл за дефиниране на доклада.

Да се копирате съществуващ обичай доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура.

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетипрозорец (посочено по-горе) ще бъдат показани.

3. Изберетесъществуващ Докладкойто искате да копирате от Налични Reportsраздел.

4. Кликнете копие и ще бъде добавено копие от доклада за мача (наречен "Копие на ...") към Available секцията Доклади на прозореца на персонализирани отчети и може да отвори или редактирали, както е описано по-горе.

Забележка

По този начин вие ще създадете копие на доклада Доклад Definition досие (.rdl / .rdlc) както и неговото съвпадение Set Data файл (.xml)(ако има такъв).

Да се премахнете съществуващ обичай доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура.

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетипрозорец (посочено по-горе) ще бъдат показани.

3. Изберетесъществуващ Докладкойто искате да премахна от Налични Reportsточка и клик Премахни.

Забележка

Когато премахнете доклад вече няма да се появява в списъка на доклад. Все пак, това не ще изтрие доклад на доклад Definition досие (.rdl / .rdlc) или Set Data досие(.xml), Ако е необходимо, изтриване на тези файлове може да се постигне чрез файловата система.

Да се преименувате съществуващ обичай доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура.

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетипрозорец (посочено по-горе) ще бъдат показани.

3. Изберетесъществуващ Докладкойто искате да преименува в на Налични Reportsточка и клик Преименувам.

4. Въведете ново име за доклада.

Забележка

Както Доклад Definition файл (.rdl / .rdlc) и съвпадение Set Data файл (.xml) ще бъде преименуван съответно.

Да се редактирате проектирането на обичай доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура.

2. Изберете Insert| Персонализиран отчетили натиснете Създаване на персонализиран отчет лента с инструменти бутон. The Персонализирани отчетипрозорец (посочено по-горе) ще бъдат показани.

Забележка

Докато всеки потребител може да отвори съществуващи персонализирани отчети, то конфигуриране проектиране на персонализирани отчети лицензията за нуждите на потребителите на Доклад Configuration способност. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.В допълнение, Microsoft Report Builder 3.0 се изисква да се изработи доклади и може да бъде изтеглен безплатно от тук .

3. Изберетесъществуващ Докладкойто искате за да се покаже от Налични Reportsраздел.

4. Кликнете Edit Доклад.Докладът ще бъде открит в Microsoft Report Builder 3.0. За конкретна помощ и някои "съвети и трикове" на някои от най-често срещаните задачи с проектиране доклади, моля, вижте по-долу раздели. За обща помощ на проектирането доклади моля, вижте Microsoft да Report Builder 3.0 помощни страници тук .

Добавянето Маси за отчета си

1. Уверете се, че имате Определение файл на ABACUS персонализиран отчет (.rdl / .rdlc) отворена в Microsoft Report Builder 3.0.

2. Изберетена Insert в раздела "лента" в горната част, след това щракнете върху Маса бутонв раздела за данни и регионите Избор Insert Table.

3. Сега плъзнете курсорана позицията на платното в доклада, където искате горния ляв ъгъл на масата, за да пуснат. Кликнете на платното, По подразбиране таблицата ще бъдат добавени с заглавен ред, а след това група подробности (група се използва за организиране на оглед на доклад от данни). За да премахнете групата, или да изтриете ред или изтриете Row Групата в лентата с инструменти обединение.

Бакшишs

Формули / Expressions в клетките на таблицата са редактирани, като изберете клетката след щракване с десния бутон на << Expr >> текста и изберете Expression .... Сортиране редове в таблица се извършва чрез избор на масата и след това да разглеждате надолу към Другия -> SortExpressions поле в Properties панела и въвеждане на изразяване. За общо ред в края на една маса добавите един ред, след като (и извън) групирането и след това използвайте следния израз = Sum (Fields!Име.Value)където "Име" е областта да бъде в размер на. За да кандидатствате колорит колони използват "IIF" изявление в имота BackgroundColor. За да добавите габарит като клетка в таблица на първо поставете габарита в клетка и след това спад полета за данни, необходими за габарита. При редактиране на височината и ширината на таблични редове, гарантира сте избрали правилния ред, и след това да задържите курсора на мишката около сивите линии, докато не получите стрелка нагоре / надолу курсора, след промяна на размера.

Добавянето Charts да си доклад

1. Уверете се, че имате сметало персонализиран отчет Definition файл (.rdl / .rdlc) отворена в Microsoft Report Builder 3.0.

2. Изберетена Insert в раздела "лента" в горната част, след това щракнете върху Диаграма бутонв раздела за данни и регионите Избор Insert Chart.

3. Сега плъзнете курсорана позицията на платното в доклада, където искате горния ляв ъгъл на графиката да поставя. Кликнете на платното и тогава изберете графикатаимате нужда от опциите и натиснете Добре.

Бакшишs

За да покажете на имот като анотация на графиките, десен бутон върху графиката и изберете Labels Show данни, след това изберете един от етикетите, които са били добавени и задайте Misc -> UseValueAsLabel до лъжливо в панела Properties и добавете изразяване (напр = Name.Value) в Разни Fields -> Label. Конкретно за балон диаграми; Bubble диаграми са показани в позицията, Scatter диаграма. Капка X ос имот в Серия полета (или да добавите в Серия Properties). Капка Y ос собственост на полетата за данни (или да добавите в Серия Properties). За да използвате един имот да се определи размера на мехурчетата, пуснете този на полетата за данни (или да добавите в Серия Properties). Bubble диаграми не са в състояние да се покаже, ако има твърде много данни (200 + статии), понякога това причинява целия доклад, за да не се покаже. Marker Type - Задава се кръг. По подразбиране, когато отпадане полета на полетата с данни, тя ги добавя с сума ()формула, така че да премахнеш. Конкретно за Stacked диаграми / Timeline / диаграми на Гант; За диаграма на Гант използвате диаграма спектър и добавяне свойства, високи и ниски стойности в полетата с данни. Можете да имате множество "решетки" чрез добавяне на повече и повече вериги, където Low стойността за един съвпадат с висока стойност за друг. Конкретно за Кръгови диаграми; За съвкупните кръгови диаграми, пуснете данните в Категория области и в области с данни, добавете формулата = CountRows (), Филтриране на всякакви 0 стойности (например върху графиките на разходите), в противен случай етикетите за тях все още ще се появяват на картата.

Използването на изявление IIF да добавят цветове към таблици и графики

1. Уверете се, че имате сметало персонализиран отчет Definition файл (.rdl / .rdlc) отворена в Microsoft Report Builder 3.0.

2. Щракнете с десния бутон на клетката в таблицата за боядисване и натискането Текст Box Properties.

3. Изберете Напълнете и натиснете FXбутона в дясно от етикета на цвят Fill и в комплекса израз за BackgroundColor поле въведете израз, напр = IIF (Fields! InformationStatus.Value = "Запазване", "LightGreen", IIF (Fields! InformationStatus.Value = "Редизайн", "Yellow", IIF (Fields! InformationStatus.Value = "Refresh", "Orange", " сьомга "))), Това променя цвета на фона на светло зелено за всяка клетка, която съдържа статута "Запазване", жълта за всяка клетка, която съдържа статута "Редизайн", Orange за всяка клетка, която съдържа статуса 'Refresh' и всяка друга стойност статут ще бъде оцветен в "Сьомга".

Забележка

Цветовете могат да се добавят за класации, като изберете серията на графиката и след това настройка на външния вид -> Color имот (или за балон диаграми появяването -> Marker -> Color собственост) към израз, подобен на горния пример.

Неща, за да имат предвид при проектирането на персонализирани отчети

· Тъй като всички имоти, с изключение на Integer са изпратени като низ от ABACUS да зрителя доклад, ако искате да направите някакви "изрази" с тях (като разделение един имот от друг или вид), което трябва да ги конвертирате в десетична или Дата т.н. За фон , тази статия е добра отправна точка. Например = CDate (Fields! LifecycleEndDate.Value) Забележка: Моля, уверете се, че езикът доклад е настроен на ен-GB (както е описано по-долу), за да приемете дд / мм / гггг, тъй като очаква мм / дд / гггг формат по подразбиране и съответно 31/7/2011 ще се провали реализация. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Ако установите, че сте се борят да запази всички таблици и графики на една страница, Има няколко основни начина за управление на вашия документ пространство:

· Page Break - Уверете се, че тази настройка маса е изключен за всяка таблица, която искате да бъде на същата страница.

· Дръжте Заедно - Гарантиране на тази настройка на маса е вярно за всяка маса, който искате да бъде на същата страница.

· Когато се движи нещата, той е по-лесно да се отдалечите използвате контрола в долния десен ъгъл на страницата и след това мулти изберете елементи и драг

· За реда на изображението в таблица, се уверете, че "Size" | Property "Оразмеряване" е настроен на "Fit" В противен случай изображението може да се появи твърде голям, или той ще бъде силно опъната.

· Да се повтарят заглавен ред на таблица на всяка страницана доклада:

1. Open Advanced Mode в прозореца на обединения. (Щракнете върху стрелката вдясно от колоната групи и изберете Advanced Mode.)

2. В зоната на Row групи (не Колона групи), кликнете върху една Static група, в която се подчертава, съответстваща текстовото поле в tablix. Кликнете през всеки Static група, докато той подчертава най-лявата колона заглавието. Това обикновено е първият Статично група, изброени.

3. В прозореца Properties, задайте имота RepeatOnNewPage да True.

4. Уверете се, че имотът KeepWithGroup е настроен да След.

· Променете езиковите настройкив Съобщи свойства да съответства форматите за данни, изискват от вас, например ен-GB за производство на формата на датата UK (дд / мм / гггг).

Вижте също

Анализирайки си архитектура


Персонализиране на интерфейса ABACUS

Navigation: Въведение в ABACUS>

Персонализиране на интерфейса ABACUS

Изпратете коментари по тази тема.

Можете да промените външния вид и поведението на интерфейса ABACUS по много начини. ABACUS включва няколко комбинации предварително зададени настройки, които можете да използвате, за да се прилага на група за персонализация на интерфейса. В допълнение, можете да направите индивидуални за персонализация на елементи като прозорци, ленти с инструменти, клавишни комбинации, както и опции за различни дисплеи.

Подредете и Dock Windows

Вие имате много възможности за организиране на прозорци в интерфейса за ABACUS, включително следното:

· Tab-разтоварните прозорци.

· Товаро-разтоварни прозорци към ръба на рамката в интерфейса.

· Минимизиране инструмент прозорци по протежение на ръба на интерфейса.

· Reset прозорец разположение, за да оформлението по подразбиране.

Докинг Windows

Когато прозорец е закачват, може да бъде закрепена към единия край на рамка в интерфейса или може да се раздели на стъкла разположени в рамката. Водач диамант се появява, когато плъзнете прозорци от сегашното им място на друго място в интерфейса. Водещата диамант ви позволява бързо отново акостира на прозорец на една от четирите страни на рамката или в центъра като табове стъкло. Когато един прозорец е скрита или не закачват, той ще се покаже на върха на други прозорци.

За да се скачи прозорци

1. Щракнете върху прозореца, който искате да акостира, за да се получи това се съсредоточи.

2. На Прозорецменюто, щракнете Закачват.

3. Плъзнете прозореца от сегашното си място към средата на рамката, която искате да го скачи с.

Появява се за употреба диамант. Четирите стрелите на точката диамант към четирите ръба на рамката и центъра представлява прозореца на табове.

Бакшиш

За да преместите закачват прозорец, без да го скъсат на мястото си, натиснете CTRL, докато го плъзнете.

4. Когато прозорецът, който влачеше достигне до положение, в което искате да го закачите, преместете показалеца върху съответната част от ориентировъчната диаманта. Кратко описание на прозореца се появява в определения район.

5. За да закачите на прозореца в положението посочено, отпуснете бутона на мишката.

Например, ако Изследователе закачен в левия край на интерфейса и искате да го закачите в десния край, ще плъзнете Изследователкъм средата на интерфейса, преместете показалеца върху дясната страна на водещия диаманта, а след това отпуснете бутона на мишката.

Минимизиране Windows

Windows (независимо дали те са Tool Windows - появява на Изгледменюто, или Документ Windows - появява на Прозорецменю) подкрепя функция, наречена Auto Hide. Auto Hide ви позволява да видите повече от вашата архитектура в един момент чрез минимизиране прозорци по ръбовете на интерфейса, когато не са в употреба.

За включване на Auto Hide

1. Кликнете на прозореца, който искате да се скрие, за да даде тя се съсредоточи.

2. На Прозорецменюто, щракнете Auto Hide.

- или -

2. Кликнете върху иконата на кабърче върху заглавната лента на прозореца.

Auto Hide Enabled

Когато един прозорец автоматично скрити губи фокус, той автоматично се плъзга обратно към раздела си на ръба на интерфейса. Докато един прозорец е авто-скрити, неговото име и икона са видими върху раздела в края на интерфейса. За да се покаже прозорец авто-скрити, преместете показалеца върху раздела. Прозорецът се плъзга обратно в оглед и е готов за употреба.

Забележка

Прозорец, който е авто-скрито не може да бъде закачен. За да закачите прозорец ще трябва да изключите Auto Hide, както е описано по-долу.

За да изключите Auto Hide

1. Щракнете върху прозореца, който искате да запазите видими за да се получи това се съсредоточи.

2. На Прозорецменюто, щракнете Auto Hideда махнете отметката.

- или -

2. Кликнете върху иконата на кабърче върху заглавната лента на прозореца.

Auto Hide Disabled

Бакшиш

Windows, които имат Auto Hide скрипт временно плъзнете в полезрението когато прозорецът е на фокус. За да скриете прозореца отново, изберете елемент извън текущия прозорец. След прозореца губи фокус, тя се плъзга назад, изглед.

Нулиране на Windows Layouts

Можете да се върнете на интерфейса към оформлението на прозореца по подразбиране с помощта на Reset Window Layoutкоманда. Когато изпълните тази команда, следните действия се появят:

· Всички прозорци са се преместили в позициите си по подразбиране.

· Прозорци, които са затворени в оформлението на прозореца по подразбиране са затворени от командата.

· Windows, които са отворени в оформлението на прозореца по подразбиране се отварят чрез командата.

· Windows, които са скрити / видими в оформлението на прозореца подразбиране се правят скрити / видимо от командата.

За да възстановите прозорец разположение, за да оформлението по подразбиране

1. На Windowsменюто, щракнете Reset Window Layout.

Персонализиране на менюта и ленти с инструменти

Можете да промените оформлението, позицията и съдържанието на менюта и ленти с инструменти в интерфейса. Можете да добавите бутони за лентите с инструменти и промяна на целевите иконата за всеки бутон.

Създаване на нови ленти с инструменти

За да създадете нова лента с инструменти

1. На Инструментименюто, изберете Персонализирайте.

2. В Персонализирайтедиалогов прозорец, изберете Toolbarsраздел.

3. Изберете си Нов.

4. В Нов Toolbarдиалогов прозорец, въведете име на лентата с инструменти.

5. Изберете си Добре.

За да добавите бутон команда в меню или лента с инструменти

1. На Инструментименюто, изберете Персонализирайте.

2. В Персонализирайтедиалогов прозорец, изберете Commandsраздел.

3. Изберете категория и плъзнете команда от диалоговия прозорец на менюто или лентата с инструменти.

4. Изберете си затварям.

Бакшиш

Задържането на клавиша Alt-ви позволява да бързо да персонализирате команди като че диалоговия прозорец Customize беше отворена.

Вижте също

Интерфейсът на ABACUS


Дефиниране и Validating Ограничения

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Дефиниране и Validating Ограничения

Изпратете коментари по тази тема.

Структурата и свойствата на архитектура могат да бъдат ограничени чрез използване на ограничения. Ограничения могат да се прилагат за съставни типове и видове свързване да се ограничи структурата на архитектура по два начина. Първият начин е да се ограничи йерархиячрез определяне на "майка трябва / трябва да има дете" и "дете трябва / трябва да има майки" взаимоотношения. Вторият начин е да се ограничи топологиячрез определяне на "компонент трябва / трябва да бъде прикрепен към връзка" и "връзка следва да / трябва да бъде прикрепен към компонент" взаимоотношения. Освен това ограниченията могат да бъдат приложени към свойствата на вида съставни, типове връзки, бланки, гледни точки, архитектури, диаграмии 3D изгледи да ограничи архитектура (и) в две допълнителни начини. Първият начин е да настроите тип даннина имота, за да ограничите валидни стойности, че тя може да има, а именно; Текст, Integer, Decimal, Date / Time, Boolean или Списък. Вторият начин е да настроите изисквастатут на имота, за да се посочи дали на стойност не трябва да бъде вписан за имота (Забележка: Задължителните ограничения се прилагат само за имоти за компонент и за свързване видове). Допълнителна информация за ограниченията на имотите е осигурено в Промяна на свойствата на компонент, връзка или тип помощна тема. След като са определени ограничения, е възможно да се валидира архитектура срещу ограничения. ABACUS ще предупреди за каквито и да било ограничения, които са били нарушени.

Ключът към определяне кои ограничение (я), за да се определи лъжи в точния език, използван за описване на ограничението. За йерархията ограничения те обикновено са от вида "съществителниможе / трябва / трябва да се разлага на п съществителни" или "съществителниможе / трябва / трябва да бъде събирана от съществителни"И т.н. Например,"Методичнотрябва да се разделят на Отбори" или "Приложениямогат да се разделят на Модули". За топология ограничения те обикновено са под формата на"съществителниможе / трябва / мъст глагол съществителни". Например, "Процеси може да бъде изпълнен от Отбори" или "Приложениясте хоства на Сървъри. "Сега, можете да видите във всяка принуда има различни може / трябва / трябва да" класирали "и те могат да бъдат от 3 вида;

· Незадължителен- Те обикновено ще използва думи / фрази обичат; "може", "мога", "би могло", "евентуално" и т.н.

· Препоръчано- Те обикновено ще използва думи / фрази обичат; "трябва", "препоръчва", "посъветва" и т.н.

· Задължителен- Те обикновено ще използва думи / фрази обичат; "мъст", "е", "са", "има", "трябва" и т.н.

В зависимост от вида на ограничение (йерархия или топология) и квалификации, използвани в него, описващ специфично ограничение (ите) трябва да бъде определена (виж по-долу). За по-горе йерархия пример за "Методичнотрябва да се разделят на Отбори"Човек трябва да се определи" "принуда и определи изпълнението да бъде изпълнено. За над топология примера на" майка трябва да има детеПроцеси може да бъде изпълнен от Отбори. "Човек трябва да се създаде само две (2)" Connection трябва да бъде прикрепен към Component "ограничения за двата края на осъществяваната от тип връзка конкретно, следните ограничения, се препоръчва да бъде определена (виж по-долу), за различните варианти;

· Йерархията ограничения;

o Съществителните A може да бъдеразлага на Съществителните B, или Съществителните B може да бъдеобобщена Съществителните A или Съществителните B би трябвалообобщена Съществителните A- Определяне на "Child трябва да има майка" ограничение с типа на детето, както Noun B, тип родител като Noun A и изпълнение, както Предупреден.

Забележка

Това означава, че ако съществува едно дете, то трябва да има родител на определен вид. Ако не, вие ще получите предупреждение.

o Съществителните A би трябвалоразлага на Съществителните B- Определяне на "майка трябва да има дете" ограничение с типа, както е майка Noun A, тип дете като Noun B и изпълнение, както Предупреден.

Забележка

Това означава, че ако съществува майка, тя трябва да има деца от определен тип. Ако не, вие ще получите предупреждение.

o Съществителните A трябва да еразлага на Съществителните B- Определяне на "майка трябва да има дете" ограничение с типа, както е майка Noun A, тип дете като Noun B и изпълнение, както насилствено.

Забележка

Това означава, че ако съществува родител, той трябва да има деца от определен тип. Ако не сте, ще получите съобщение за грешка.

o Съществителните A трябва да еобобщена Съществителните B- Определяне на "Child трябва да има майка" ограничение с типа на детето, както Noun A, тип родител като Noun B и изпълнение, както насилствено.

Забележка

Това означава, че ако съществува едно дете, тя трябва да има майка на определен тип. Ако не, вие ще получите съобщение за грешка.

· Топология ограничения;

o Съществителните A може да бъде глагол Съществителните B- Определете две (2) "Connection трябва да бъде прикрепен към компоненти" ограничения. Първият същество с Source края на тип връзка глаголприкрепен към съществителното тип A компонент и изпълнение настроен на насилствено. Вторият същество с Sink края на тип връзка глаголприкрепен към Noun тип B компонент и изпълнение настроен на насилствено.

Забележка

Това означава, че ако съществува връзка с това трябва да се свърже компоненти на някои видове. Ако не можете да получите съобщение за грешка. Като цяло това гарантира, че тези компоненти могат да съществуват още и не бъдат свързани един с друг. Въпреки това, ако те са свързани, трябва да се използват връзки на правилния тип.

o Съществителните A би трябвало глагол Съществителните B- Определете две (2) "Компонент трябва да бъде прикрепен към връзката 'ограничения. Първият е с Noun A типово прикрепен към Source края на глаголтип връзка и набор правоприлагането да Предупреден. Вторият същество с Noun тип B компонент прикрепен към Sink края на глаголтип връзка и набор правоприлагането да Предупреден. Освен това, се определят две (2) "Connection трябва да бъде прикрепен към компоненти" ограничения. Първият същество с Source края на тип връзка глаголприкрепен към съществителното тип A компонент и изпълнение настроен на насилствено. Вторият същество с Sink края на тип връзка глаголприкрепен към Noun тип B компонент и изпълнение настроен на насилствено.

Забележка

Това означава, че ако съществуват елементи на двата типа, те трябва да се отдава на връзка на определен вид. Ако не можете да получите предупреждение. В допълнение, това означава, че ако съществува връзката, тя трябва да бъде свързан към компонентите на определения вид. Ако не сте, ще получите съобщение за грешка. Като цяло това ще гарантира, че ако съществуват компоненти на тези видове, вие ще получите предупреждения, ако те не са свързани един с друг.

o Съществителните A трябва да е глагол Съществителните B- Определете две (2) "Компонент трябва да бъде прикрепен към връзката 'ограничения. Първият е с Noun A типово прикрепен към Source края на глаголтип връзка и изпълнението настроен на насилствено. Вторият същество с Noun тип B компонент прикрепен към Sink края на глаголтип връзка и изпълнението настроен на насилствено. Освен това, се определят две (2) "Connection трябва да бъде прикрепен към компоненти" ограничения. Първият същество с Source края на тип връзка глаголприкрепен към съществителното тип A компонент и изпълнение настроен на насилствено. Вторият същество с Sink края на тип връзка глаголприкрепен към Noun тип B компонент и изпълнение настроен на насилствено.

Забележка

Това означава, че ако съществуват елементи на двата типа, те трябва да бъдат прикрепени към свързване на определен тип. Ако не сте, ще получите съобщение за грешка. В допълнение, това означава, че ако съществува връзката, тя трябва да бъде свързан към компонентите на определения вид. Ако не сте, ще получите съобщение за грешка. Като цяло това ще гарантира, че ако съществуват компоненти на тези видове, вие ще получите грешки, ако те не са свързани един с друг.

За да зададете ограничение

1. Уверете се, че имате ABACUS файлотворена и Window Explorerпоказва.

2. В изследовател дървото се разширява Видове | Компонент Видовеили разширяване Видове | Типове връзки.

3. Кликнете с десния бутонтип компонент или типа връзка и изберете Добави Constraint.

Добавяне на ограничение

За да определите йерархия ограничение, когато един родител трябва да има специфично дете

4. На Добави Constraintмаркирай прозорец Създайте Constraintквадратчето съгласно РСТ Майка трябва да е Ограничение Childплощ.

5. Изберете типовоот падащото меню, за което искате да зададете като детето на типа на компонент, избран в стъпка 3.

Забележка

Ако има вече е активирана "майка трябва да е Child" ограничение, определена за типа компонент майка и друг тип дете компонент след това ново ограничение ще се третира като "И". Това е типът трябва да е родител на дете тип A иТип на детето B, какъвто и да е изпълнение ниво (напр Disabled, Предупреден или принудително - вижте стъпка 7) е посочена за всяко ограничение.

6. По желание може да се определи минимален и максимален брой компоненти от типа на компонент е посочено, че трябва да бъдете синове на типа на компонент десния кликнали в стъпка 3.

7. Изберете дали искате ограничението да е хора с увреждания, Предупреден или Принудително.

Забележка

Увреждания ограничения ще бъдат игнорирани от ограничаващата валидиране предупреди ограничения ще доведат до предупреждение в прозореца за потвърждаване, ако те не са открити и да бъдат прилагани ограничения ще произвеждат Грешка в прозореца за потвърждаване, ако те не са открити. Освен това, всички грешки трябва да бъдат решени преди Начинание Сървър проект може да бъде извършено.

8. Кликнете Добре.

Забележка

Ограничението ще бъде показан в изследовател дървото под типовото десния щракнали на стъпка 3. Стрелката означава посоката на ограничението и в този случай ще сочи надолу и надясно. Катинарът е оцветена според това дали ограничението е Disabled (сиво), Предупреден (жълт) или насилствено (червено).

Родител трябва да има дете, предупреди ограничение

За да определите йерархия ограничение, когато едно дете трябва да има специфично майка

4. На Добави Constraintмаркирай прозорец Създайте Constraintквадратчето съгласно РСТ Дете Трябва да има майка Constraintплощ.

5. Изберете типовоот падащото меню, за което искате да зададете като родител на типа на компонент десния кликнали в стъпка 3.

Забележка

Ако има вече е активирана "Child Трябва да има майка" ограничение, определена за вида на детската компонента и друга майка типово след това ново ограничение ще се третира като "ИЛИ". Това е типът трябва да е дете на майка тип A илимайка тип B, и нивото на изпълнение (напр Предупреден или принудително - виж следващата стъпка) трябва да са същите, наложени ограничения по друг начин винаги ще имат приоритет предупредиха такива.

6. Изберете дали искате ограничението да е хора с увреждания, Предупреден или Принудително.

Забележка

Увреждания ограничения ще бъдат игнорирани от ограничаващата валидиране предупреди ограничения ще доведат до предупреждение в прозореца за потвърждаване, ако те не са открити и да бъдат прилагани ограничения ще произвеждат Грешка в прозореца за потвърждаване, ако те не са открити. Освен това, всички грешки трябва да бъдат решени преди Начинание Сървър проект може да бъде извършено.

7. Кликнете Добре.

Забележка

Ограничението ще бъде показан в изгледа на изследовател по типа на компонент, избран в стъпка 5. Стрелката означава посоката на ограничението и в този случай ще сочи нагоре и наляво. Катинарът е оцветена според това дали ограничението е Disabled (сиво), Предупреден (жълт) или насилствено (червено).

Дете трябва да има майка предупреди ограничение

За да дефинирате топология ограничение, където трябва да бъде приложен компонент към конкретна връзка

4. На Добави Constraintмаркирай прозорец Създайте Constraintквадратчето съгласно РСТ Компонент трябва да бъде приложен Constraintплощ.

5. Изберете тип връзкаот падащото меню, за което искате да зададете като прикачен връзката на типа компонент десния щракнали на стъпка 3. (Или изберете типовоот падащото меню, за което искате да зададете като прикачен компонент, ако в стъпка 3 сте кликнали тип връзка.)

Забележка

Ако вече има включен "Component трябва да бъде приложен" ограничение, определена за типа компонент и друг тип връзка, то това ново ограничение ще се третира като "И". Това е типът компонент трябва да бъде прикрепен към тип връзка A иВид връзка B, какъвто и да е изпълнение ниво (напр Disabled, Предупреден или принудително - вижте стъпка 7) е посочена за всяко ограничение.

6. По желание можете да изберете връзка ролякойто искате да добавите към ограничението. Sизбира спецификата роля (т.е. или Source или Sink) от падащото меню.

7. Изберете дали искате ограничението да е хора с увреждания, Предупреден или Принудително.

Забележка

Увреждания ограничения ще бъдат игнорирани от ограничаващата валидиране предупреди ограничения ще доведат до предупреждение в прозореца за потвърждаване, ако те не са открити и да бъдат прилагани ограничения ще произвеждат Грешка в прозореца за потвърждаване, ако те не са открити. Освен това, всички грешки трябва да бъдат решени преди Начинание Сървър проект може да бъде извършено.

8. Кликнете Добре.

За да дефинирате топология ограничение, където трябва да бъде приложен на връзка към специфичния компонент

4. На Добави Constraintмаркирай прозорец Създайте Constraintквадратчето съгласно РСТ Connection трябва да бъде приложен Constraintплощ.

5. Изберете тип връзкаот падащото меню, за което искате да зададете като прикачен връзката на типа компонент десния щракнали на стъпка 3. (Или изберете типовоот падащото меню, за което искате да зададете като прикачен компонент, ако в стъпка 3 сте кликнали тип връзка.)

Забележка

Ако вече има включен "Connection трябва да бъде приложен" ограничение, определена за типа на връзката, а друг компонент тип, използващи същата връзка роля(т.е. или Източник или Sink), след това ново ограничение ще се третира като "ИЛИ". Това е вид връзка трябва да бъде прикрепен към типа компонент A илитипово B, и нивото на изпълнение (напр Предупреден или принудително - вижте стъпка 7) трябва да са същите, наложени ограничения по друг начин винаги ще имат приоритет предупредиха такива. Забележете също, че ако има множество ограничения, които имат връзка роляпосочено като "всяка" (за разлика от специфично източник или мивка) след всеки край на свързване трябва да бъде прикрепен към един от видовете компоненти, посочени в ограничения.

6. По желание можете да изберете връзка ролякойто искате да добавите към ограничението. Sизбира спецификата роля (т.е. или Източник или Мивка) от падащото меню.

Забележка

Или един извор или Sink роля трябва да бъде изрично избран за Привързаност колона за налични да се показва в компонент каталог .

7. Изберете дали искате ограничението да е хора с увреждания, Предупреден или Принудително.

Забележка

Увреждания ограничения ще бъдат игнорирани от ограничаващата валидиране предупреди ограничения ще доведат до предупреждение в прозореца за потвърждаване, ако те не са открити и да бъдат прилагани ограничения ще произвеждат Грешка в прозореца за потвърждаване, ако те не са открити. Освен това, всички грешки трябва да бъдат решени преди Начинание Сървър проект може да бъде извършено.

8. Кликнете Добре.

Реално време модел проверка и ограничениеутвърждаване

ABACUS включвав реално време Model Проверка и Валидиране функция, за да веднага показ ефектите дадена операция потребителят ще имат на предупрежденията и грешки с настоящия проект, дължащи се на всеки йерархия и топология ограничения, които са били определени. Трябва да се отбележи, че всички Грешки трябва да бъдат решени преди Начинание Сървър проект може да бъде извършено.

Функцията валидиране ограничение в реално време е най-забележимо при попълването с диаграми или директно в прозореца на Explorer. По-специално, по време на следните операции, са дадени указания с помощта на цветни акценти по отношение на действието на операцията ще има върху предупрежденията и грешки с настоящия проект;

1. Когато плъзгане елементи върху или около диаграма цвета на родителя (или свързване) компонент (ако има такъв) граница ще бъдат оцветени съгласно схемата, описана по-долу.

2. Когато свързвате компоненти с помощта на десния бутон на мишката плъзнете | Свържете За да се отличава списъка с наличните типове връзки е оцветен в съответствие със схемата, описана по-долу.

3. Когато свързвате компоненти на диаграми с помощта на режима Connector на курсора се променя цветовете в съответствие със схемата, описана по-долу.

4. При добавяне на подкомпоненти списъка с наличните Видове Компонент е оцветен в съответствие със схемата, описана по-долу.

В общи линии следните цветове се използват за указване на последиците операция на потребител ще има върху предупрежденията и грешки с настоящия проект;

Черен : Няма въздействие върху предупреждения или грешки.

Зелен : Операцията е изрично в съответствие съсопределената йерархия и топология ограничения за проекта.

Червен : Операцията е изрично в нарушение наопределената йерархия и топология ограничения за проекта и ще доведат до предупреждение и / или грешки.

Заден план модел проверка и ограничениеутвърждаване

ABACUS включва Характеристика на утвърждаване, за да изведете всички предупреждения и грешки с настоящия проект, поради каквито и да било ограничения, които са били определени. Трябва да се отбележи, че всички Грешки трябва да бъдат решени преди Начинание Сървър проект може да бъде извършено.

Забележка

Валидиране трябва да се кандидатира ръчно чрез "валидира / Проверете Ограничения проект 'бутона на Главна лента с инструменти , Прозорецът Validation е скрит по подразбиранено ще се появи, когато бутона на лентата с инструменти е кликнал, Виждам Персонализиране на интерфейса за това как да го свалям и потенциално го оставете постоянно показва. Също така, можете да щракнете двукратно върху всеки ред в прозореца за потвърждаване на "скок" на съответния елемент в проекта.

Прозорец за потвърждаване

Колони по подразбиране в прозореца за потвърждаване са описани, както следва;

Предупреждение или Error: В тази графа се показва икона за това дали нарушението е предупреждение (жълт триъгълник с удивителен знак) или Error (червен кръг с кръст).

Номер: Тази колона показва номера на нарушение.

Забележка

Само на 200 нарушения са показани в даден момент и ако има повече от 200 нарушения в проект на Start, предх, Следващ и End редови мореплаватели в горния десен ъгъл на прозореца могат да бъдат използвани, за да прегледате допълнителните нарушения.

Описание: Това е пълно описание на нарушението, включително за предприятието и Ограничението съответната.

Единица: Тази колона показва лице на загриженост от страна на нарушението.

Тип: Тази колона показва типа елемент за предприятието.

Архитектура: Тази колона показва архитектура, в която е извършено нарушението.

Установена: Тази колона показва времето, което се открива на нарушението.

Бакшиш

Полезно е да се подреди в низходящ ред от Установена колоната (както е показано в диалога по-горе), за да се гарантира най-скорошните нарушения се появяват в "върха" на списъка.

Има няколко варианта на потребителя да променя поведението на валидирането на фона модел. Например To промяна на цветовете, използвани за нарушения ограничение на нещо различно от по подразбиране Червен, Кликнете на инструменти | Опции ... След това отидете на на Утвърждаванев раздела, а задаване на цветове посредством Промяна бутони.

Утвърждаване опции

За да потвърдите ръчно ограничения

1. Кликнете с десния бутон на Архитектуривъзел, всяка архитектура или някъде или в Елементи или Connectionsчаст от изгледа на изследовател и Select Проверете Ограничения.

Валидиране на ограничения

2. Щракнете върху Детайлибутона на Предупрежденияпрозорец, за да видите къде архитектурата нарушава никакви ограничения, които са били определени.

Забележка

Нарушенията са показани само за тези ограничения, които са създадени, за да Предупреден или изпълнено. Освен това формулировката на предупреждението ще включва "следва", ако ограничението е само предупреждение или "мъст", ако е била приложена.

3. Кликнете Добре.

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно


Изтриване на елемент или връзка

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Изтриване на елемент или връзка

Изпратете коментари по тази тема.

За да изтриете даден компонент или връзка

1. Кликнете с десния бутонна компонента или връзката.

2. Изберете Изтривам.

Внимание

ABACUS ще ви предупреди, която е видяна ще бъдат засегнати от заличаването и да ви помоля да потвърдите изтриването. Това е така, защото елементи могат да съществуват на много диаграми и че си струва да се провери какво предложеното заличаване ще се отрази.

Бакшиш

Ако изтриете елемент, всички негови под-компоненти също ще бъдат изтрити. Можете да изберете да изтриете вътрешни и външни връзки към компонента. Ако решите да не ги изтриете, връзките, че е прикрепен да ще остане, но те вече няма да бъдат прикрепени. Всички компоненти и връзки са на определено Тип , Изтриването на компонент / връзката не оказва влияние върху Type (Видове в клона на дървото). По същия начин, ако компонентът / връзката има Стандарт възложени, заличаване няма да окаже въздействие върху капитана в бранша стандарти.

Вижте също

Запълването на архитектурата - Преглед


Диаграма Гледни точки

Navigation: Запълването на архитектурата> Използване Рисунки>

Диаграма Гледни точки

Изпратете коментари по тази тема.

Thд гледни точкиФункцията гарантира, че компоненти и връзки, които се добавят към схема трябва да имат асоциация тип дефинирани по-горе, преди да бъде добавен в диаграма. Тази функция дава възможност за ограничаване на видовете диаграми, които могат да бъдат изготвени чрез ограничаване на формите и конекторите, които са свързани с компоненти и Connectionsсъществуваща в рамките на вашата архитектура.

Активиране или деактивиране на строгото прилагане на схема гледни точки

Способността да се наложат диаграма гледни точки автоматично се активира по подразбиране. За да деактивирате / активирате тази функция, кликнете върху Tools | Опции ...| на Диаграмав раздела, и отменете избора / изберете Привеждане в изпълнение на диаграма Гледни точкипроверите съответно кутия.

Забележка

Ако не виждате "наложат Диаграма Гледни точки"Опция в раздела Диаграма тогава не е нужно Проектанта добавка и опция е включена по подразбиране.

Създаване изпълнимо диаграма гледна точка

1. Уверете се, че имате ABACUS файл открита с изследователизглед показва.

2. В екрана на изследовател десен бутон върху Изгледточкаsи кликнете върху Създавам Диаграма Гледна точка

3. The Диаграма Гледна точкаЩе се появи прозорец.

4. Присвояване на съответното име на диаграма гледна точкаи имайте предвид, че гледна точка се съхраняват в Гледни точкираздел на изследовател.

5. The Диаграма Гледна точкаЩе се появи прозорец.

6. Сега кликнете и плъзнете съответните видове компоненти и тип свързване във вашите архитектури върху Гледна точка форми искаш. Компонент видоветрябва да се влачат следформав формираздела, като същевременно типове връзкитрябва да се влачат върху една от формите стил 5 линияв съединителираздел.

7. За да запаметите диаграма гледна точкасте създали кликнете върху [image] в горния десен ъгъл на вашия Диаграма Гледна точкапрозорец.

Забележка

The диаграма гледна точкамогат да бъдат редактирани от дясно щракване върху гледна точка и селектиране Отворено или двукратно щракванена гледна точка.

Synchonising актуализиран гледна точка с диаграми

1. Уверете се, че имате ABACUS файл отворен.

2. Или щракнете с десния бутон гледна точка в Изследовател прозореца под Мета-модел | Гледни точкии изберете Синхронизиране Диаграма Съответствия ...

- или -

3. затварям на открито и актуализиран гледна точка прозорец и изберете Дав Синхронизирайте да Гледна точкадиалогов прозорец, който се показва.

4. The Гледна точка СинхронизацияПоявява се диалогов прозорец, както е показано по-долу.

Чек боксове

· Добави Липсващи Съответствия- Всяка нова форма (за типово) или съединител (за тип връзка) сдружения, които са били добавени да гледна точкаще бъде добавен към съответната схемаS (т.е. тяхнаташаблонс) че са свързани с гледна точка.

· Актуализация СъществуващаСъответствия- Всякакви редактирани аспекти на съществуващата форма (до типа на компонент) или съединител (за тип връзка) сдружения за гледна точка(например цвят, стилове на шрифта) ще се актуализира в съответната схемаS (т.е. тяхнаташаблонс) че са свързани с гледна точка.

· Махни ExtraСъответствия- Всяка допълнителна форма (за типово) или съединител (за тип връзка) сдружения, които са били добавени към диаграми (т.е. техните восъчни листове), но не са в гледна точкаще бъде отстранен от съответната схемаS (т.е. тяхнаташаблонс) че са свързани с гледна точка.

· Презаписване Local Settings за добавен или актуализиран съпоставяния (Разлики Only)- Всякакви редактирани аспекти на съществуващата форма (до типа на компонент) или съединител (за тип връзка) сдружения за гледна точка(например цвят, стилове шрифт) ще се прилага към съответните елементи на диаграми, които са свързани гледна точка.Само се прилагат актуализираните "различията", направени на гледна точка, така че всички съществуващи местни настройки в диаграмата, които не са били актуализирани през гледната точка ще останат непроменени.

· [image] Анотации – Както по-горе, но специално за анотациите.

Вижте също

Инструментът Drawing | Запълването на архитектурата | Анализ Вашата архитектура


Рисуване Особености на инструменти

Navigation: Запълването на архитектурата> Използване Рисунки>

Рисуване Особености на инструменти

Изпратете коментари по тази тема.

Инструментът Drawing поддържа определен брой чертожни функции.

Увеличение

Мащабът на диаграмата може да се променя с помощта на функцията за мащабиране.

За да намалите мащаба или "приближаване"

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Преса Ctrlи "=" ключ.

- или -

2. Изберете Приближавамбутона на Diagramлента с инструменти.

- или -

2. Преса Ctrlи преобръщане колелцето на мишката напред, Забележка: В този режим на платното ще увеличите към мястото, където мишката е кръжи над платното.

За да увеличите мащаба, или "отдалечаване"

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Преса Ctrlи "-" ключ.

- или -

2. Изберете Отдалечавамбутона на Diagramлента с инструменти.

- или -

2. Преса Ctrlи преобръщане колелцето на мишката назад, Забележка: В този режим на платното ще я навън, от където на мишката се носеше над платното.

Auto-оформление

Разположението на компоненти в схемата могат да бъдат променени автоматично.

За оформлението всички елементи oN диаграма

1. Cлижа на Layout Диаграмабутон в лентата с инструменти Диаграма.

2. Изберетевсеки Radial Layout или Grid Layout.

Забележка

Оформлението на Radial ще използва това, което се нарича "сила насочена" алгоритъм, така че свързаните компоненти са съставени заедно, докато не са свързани компоненти са принудени от друг. Оформлението на Grid ще използва фиксирана ширина и височина междуредие алгоритъм. Това от една страна позволява на потребителя да избере общата схема Aspect Ratio (например 16: 9, A4 (Портрет), Letter (Landscape)) и след това разстоянието от двете страни, както и между колоните и редовете, както е показано по-долу.С Grid оформление всякакви връзки между компонентите не оказват влияние върху оформлението, тъй като урежда само компонентите по азбучен ред (по име) от горния ляв до долния десен ъгъл на платното. С двете алгоритми свободна форма форми не се местят.

За оформлението деца елементи в един родител оN диаграма

1. Кликнете с десния бутонкомпонент на високо равнище, чиито деца желаете да авто-оформление.

2. Изберете Експонация Деца.

Забележка

По подразбиране се използва само оформление алгоритъм на радиалните.

Промяна Element Естетика като Цвят, Прозрачност, Shadows и Rotation

Всички елементи са диаграма естетика, които могат да бъдат манипулирани по желание. В случай на свързаните форми, тези аспекти могат да бъдат настроени по види в повечето случаи и Например за, В случай на свободна форма форми, тези свойства могат да бъдат определени Например завърху платното.

Забележка

Всеки един аспекти инстанция, които са били определени за свързаните с тях форми ще бъдат "презаписани", ако същата аспект е променило за съответния вид.

За да смените цвета на свързано форма или свободна форма форма

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или свободна форма форма на платното.

3. Изберете Промени Colour.

4. Изберете Фиксирана Colourбутон за избор (ако е приложимо).

5. Изберете Basic Colour или Дефинирайте персонализирана Colour в диалоговия прозорец и щракнете Добре.

- или -

4. Изберете Градиентбутон за избор (ако е приложимо).

5. Изберете или хоризонтални, вертикални, Forward Диагонал или назад по диагонал за градиент посоката, в падащото меню и кликнете Добре.

6. Изберете Basic Colour или Дефинирайте персонализирана Colour в диалоговия прозорец за Начало и Крайи кликнете Добре.

Забележка

ABACUS ще оцвети на преден план във форма, ако;
а) това е "проста" форма с единична основната графичен елемент (например кръг, правоъгълник, многоъгълник и т.н.), или
б) това е "сложна" форма с множество базови subshapes, че всички са на един и същи цвят / градиент, както помежду си или на subshapes имат LockScale = TRUE набор.
Ако тези условия не са изпълнени след това на фона на формата е оцветен.

За да зададете цвят на свързано форма според имот

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон(НЕ върху платното за рисуване).

3. Изберете Промени Colour.

4. Изберете Използването на имота радио бутон.

5. Изберете един имот, като кликнете върху "..." бутона в дясно от текстовото поле.

6. Изберете Диапазон радио бутон.

7. Регулирайте Min и Maxстойности по желание. Забележка: всяка стойност под минималната стойност ще бъде показан като цвят Min и всяка стойност над максимално ще бъде показан като Max цвят. Също така, когато се използва Булева, Списък или Date / Time свойства на ценностите се превръщат в индекс, както следва; Булев (False = 0, True = 1), Списък (цяло число долина от 1 до п за всяка валидна стойност в техния възходящ ред, определен в полето Units) и Дата / Час (брой дни след 1 януари 1900 - включително десетични дроби за часове, минути секунди порции - и ако датата е предварително 1990 г. е отрицателно число).

8. Изберете Basic Colour или Дефинирайте персонализирана Colour в диалоговия прозорец за Min и Maxи кликнете Добре.

Бакшиш

Ако Зелен (RGB - 128,255,0) е избран като цвят минути и Червен (RGB - 255,0,0) е избран като Max цвета на имот с стойност гама от 1 да се 4След това стойността на 1ще се показва като Зелен, На стойност 2 като Жълт, 3 като Оранжев и 4 като Червен.

Алтернативно, на имот кръг 1 да се 3на стойност 1ще бъде като Зелен, На стойност 2 като Кехлибар и 3 като Червенизвестен още като "светофар" или статут RAG.

За имот гама от 1 до 5, ако Син (RGB - 0,0,255) е избран като цвят минути и Червен (RGB - 255,0,0) е избран като Макс оцветите стойност 1 ще бъде като Син, На стойност 2, когато Aqua, На стойност 3, когато ЗеленНа стойност от 4 като Жълт на стойност 5, когато Червен.

За имот гама от 1 до 6, ако Виолетов (RGB - 255,0,255) е избран като цвят минути и Червен (RGB - 255,0,0) е избран като Макс оцветите стойност 1 ще бъде като Виолетов, На стойност 2, когато Син, На стойност 3, когато AquaНа стойност от 4 като ЗеленНа стойност от 5 като Жълт на стойност 6, когато Червен.

И накрая, за собственост диапазона от 1 до 7 стойност 1 ще бъде като Виолетов, На стойност 2, когато Тъмно синьо, На стойност 3, когато Светло синьоНа стойност от 4 като Blue GreenНа стойност от 5 като ЗеленНа стойност от 6 като Кехлибар на стойност 7, когато Червен

Забележка

Виж бележката по-горе на преден план в сравнение фон оцветяване.

- или -

7. Изберете Специфична Value радио бутон.

8. Щракнете върху Edit Coloursбутон.

9. Изберете всяка стойност на свой ред и натиснете Определете Colourда зададете специфичен цвят за всяка стойност.

Забележка

Диапазонът на стойностите на елементите, намиращи се на схема ще бъде предварително населена.

10. За да добавите допълнителни цветове стойност на тези предварително населена (например след обхвата на имот е преконфигурира) клик Добави Value.

За да промените прозрачността на цветовете на свързано форма или свободна форма форма

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или свободна форма форма на платното.

3. Изберете Промени Colour.

4. В панела Transparency настроите горната плъзгача на желаната прозрачност на основния цвят.

5. Ако се използват градиента или с помощта на опциите за имота, в панела Transparency определя долната плъзгача на желаната прозрачност за втория цвят.

6. Кликнете Добре.

Да покажа сенки за Всички от асоцииран фигури в диаграма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементираздел на прозореца на шаблон.

3. Изберете Добави Сенки.

Да се покажем сянка върху форма компонент или свободна форма форма

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Дясно-Кликнетена компонент или свободна форма формата на платното на.

3. Изберете Добави Сенки.

За да завъртите съставни форми и свободна форма фигури в диаграми

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Изберете компонент формата или свободна форма форма на платното искате да завъртите.

3. Кликнете с десния бутонпо форма и изберете Rotateи след това изберете съответния ъгъл искате да завъртите фигурата от.

Смяна Element анотации и Freeform Текстови етикети

Всички елементи имат диаграма анотации които могат да бъдат манипулирани по желание. В случай на свързаните форми, тези аспекти могат да бъдат настроени по види в повечето случаи и Например за, В случай на свободно-формии съединители, Натекстови етикети може да се настрои Например завърху платното.Осем (8) различни видове анотации могат да се изведат за диаграма елементи (т.е. име, тип, Собственост Стойност, Property Marker, Прикачените Components, деца (за само компоненти), стандарти и времеви отпечатъци (Създаден, променено от т.н.)) в двадесет и пет (25) различни позиции (напр Centre - Извън Top, Inside оставяли - Centre, Извън Right - Извън Bottom).

Забележка

Всеки един аспекти инстанция, които са били определени за свързаните с тях форми ще бъдат "презаписани", ако същата аспект е променило за съответния вид.Освен това, когато 2 или повече пояснения заемат същата позиция могат да бъдат използвани само един Font, Font стил, цвят и размер на шрифта и Separator (например запетая, интервал, нов ред) трябва да бъде избран.

Да покажа името и вида за асоцииран компонент или връзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или съединител на платното.

3. Изберете Анотации.

Забележка

За индивидуална форма, свързана с или съединител на платното, ще трябва да изберете Замяна Stencil анотацииквадратчето за първи път.

4. Изберете New Анотация в лентата с инструменти и изберете Име или Тип.

5. В диалоговия прозорец, който се появява, изберете опциите на дисплея, които са желани включително скоби и стила на шрифта, шрифт, цвят и размер на шрифта. Също така, изберете опциите за оформление, които са желани включително хоризонтално и вертикално положение (т.е. анотация позиция) и ъгъла (т.е. въртене). Изберете Добре.

За да покажете на имот стойност за асоцииран компонент или връзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или съединител на платното.

3. Изберете Анотации.

Забележка

За индивидуална форма, свързана с или съединител на платното, ще трябва да изберете Замяна Stencil анотацииквадратчето за първи път.

4. Изберете New Анотация в лентата с инструменти и изберете Цена на имота.

5. В диалоговия прозорец, който се появява изберете имота, като кликнете на Обекта: "..." бутона и избора на имот в диалоговия прозорец Select A Propertyи изберете Добре. Изберете опциите за дисплея, които са желани включително скоби и стила на шрифта, шрифт, цвят и размер на шрифта. Също така, изберете опциите за оформление, които са желани включително хоризонтално и вертикално положение (т.е. анотация позиция) и ъгъла (т.е. въртене). Изберете Добре.

За да покажете на имот маркер за асоцииран компонент или връзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или съединител на платното.

3. Изберете Анотации.

Забележка

За индивидуална форма, свързана с или съединител на платното, ще трябва да изберете Замяна Stencil анотацииквадратчето за първи път.

4. Изберете New Анотация в лентата с инструменти и изберете Property Marker.

5. В диалоговия прозорец, който се появява изберете имота, като кликнете на Обекта: "..." бутона и избора на имот в диалоговия прозорец Select A Propertyи изберете Добре. Определете радиуса на маркера в пиксели и метода на оцветяване или да Colour Чрез Range или Colour До имота и определя задачите на цветове. Също така, изберете опциите за оформление, които са желани включително хоризонтално и вертикално положение (т.е. анотация позиция) и ъгъла (т.е. въртене). Изберете Добре.

Да покажа прикрепени компоненти за асоцииран компонент или връзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или съединител на платното.

3. Изберете Анотации.

Забележка

За индивидуална форма, свързана с или съединител на платното, ще трябва да изберете Замяна Stencil анотацииквадратчето за първи път.

4. Изберете New Анотация в лентата с инструменти и изберете Прикачените Components.

5. В диалоговия прозорец, който се появява, за свързаните с тях компоненти изберете прикачения типа компонент, като кликнете върху Приложено: "..." бутона и избора на типа на компонент в диалоговия прозорец Set Component Typeи изберете Добре. Изберете прикачения тип връзка, като кликнете върху свързани чрез: "..." бутон и избирате типа връзка в диалоговия прозорец Set Тип на връзкатаи изберете Добре.За свързаните връзки изберете края на връзката, като изберете Source или Мивка от края на връзката: падащо меню. За двата свързаните компоненти и връзки изберете опциите на дисплея, които са желани включително скоби и стила на шрифта, шрифт, цвят и размер на шрифта. Също така, изберете опциите за оформление, които са желани включително хоризонтално и вертикално положение (т.е. анотация позиция) и ъгъла (т.е. въртене). Изберете Добре.

Да покажа децата за асоцииран компонент

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементираздел на прозореца на шаблон или свързана с форма на платното.

3. Изберете Анотации.

Забележка

За индивидуална свързана форма на платното, ще трябва да изберете Замяна Stencil анотацииквадратчето за първи път.

4. Изберете New Анотация в лентата с инструменти и изберете Деца.

5. В диалоговия прозорец, който се появява, изберете опциите на дисплея, които са желани включително скоби и стила на шрифта, шрифт, цвят и размер на шрифта. Също така, изберете опциите за оформление, които са желани включително хоризонтално и вертикално положение (т.е. анотация позиция) и ъгъла (т.е. въртене). Изберете Добре.

Да покажа стандартите за асоцииран компонент или връзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или съединител на платното.

3. Изберете Анотации.

Забележка

За индивидуална форма, свързана с или съединител на платното, ще трябва да изберете Замяна Stencil анотацииквадратчето за първи път.

4. Изберете New Анотация в лентата с инструменти и изберете Стандарти.

5. В диалоговия прозорец, който се появява, изберете опциите на дисплея, които са желани включително скоби и стила на шрифта, шрифт, цвят и размер на шрифта. Също така, изберете опциите за оформление, които са желани включително хоризонтално и вертикално положение (т.е. анотация позиция) и ъгъла (т.е. въртене). Изберете Добре.

Да покажа на времеви отпечатъци за асоцииран компонент или връзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете с десния бутонна асоцииран форма или конектор в Елементи или Connectionsраздел на прозореца на шаблон или асоциирана форма или съединител на платното.

3. Изберете Анотации.

Забележка

За индивидуална форма, свързана с или съединител на платното, ще трябва да изберете Замяна Stencil анотацииквадратчето за първи път.

4. Изберете New Анотация в лентата с инструменти и изберете Създаден, създадени от Създаден Marker, Modified, променено от или модифицирана Marker.

5. В диалоговия прозорец, който се появява, ако не е маркер, изберете опциите на дисплея, които са желани включително скоби и стила на шрифта, шрифт, цвят и размер на шрифта. Ако маркер, определен радиус на маркера в пиксели и метода на оцветяване или да Colour Чрез Range или Colour До имота и определя задачите на цветове. Също така, изберете опциите за оформление, които са желани включително хоризонтално и вертикално положение (т.е. анотация позиция) и ъгъла (т.е. въртене). Изберете Добре.

За да промените стила на шрифта на свободна форма формаили съединител

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Кликнете с десния бутонна свободна форма форма или съединител върху платното. Забележка: Ако съединител етикет текст не се покаже след това да покаже захранващиятили етикет на текст: Кликнете с десния бутонСвързванеилии изберете Анотация | Покажи Анотация.

3. Изберете Промяна на шрифта.

4. Изберете стил на шрифта, шрифт и размер, в диалоговия прозорец и изберете Добре.

За да промените шрифта цвят на свободна форма формаили съединител

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Кликнете с десния бутонна свободна форма форма или съединител върху платното. Забележка: Ако съединител етикет текст не се покаже след това да покаже захранващиятили етикет на текст: Кликнете с десния бутонСвързванеилии изберете Анотация | Покажи Анотация.

3. Изберете Промяна Font Colour.

4. Изберете FontColour (и за форми на Link Цвят), като щракнете върху "..." бутона и избор на цвят в диалога и Select Добре.

5. Изберете прозрачността на етикета на текст чрез регулиране на плъзгача с 0 е напълно прозрачна и 255 са напълно непрозрачни.

За да завъртите текст етикета на свободна форма формаили съединител

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Кликнете с десния бутонна свободна форма форма или съединител върху платното. Забележка: Ако съединител етикет текст не се покаже след това да покаже захранващиятили етикет на текст: Кликнете с десния бутонСвързванеилии изберете Анотация | Покажи Анотация.

3. Изберете Rotateи след това изберете съответния ъгъл, който искате да завъртите етикет на текст от.

Вижте също

Инструментът Drawing | Запълването на архитектурата | Анализ Вашата архитектура


Симулиране обща цена на притежание (TCO)

Navigation: Симулиране си архитектура> Тренажори>

Симулиране обща цена на притежание (TCO)

Изпратете коментари по тази тема.

Заден план

Обща цена на притежание (TCO) е финансов разчет, предназначен за измерване на общите разходи, направени на жизнения цикъл (от придобиването до извеждането от експлоатация / изхвърляне), свързани с притежаваните активи. TCO отразява не само на разходите за покупка, тя включва и всички други аспекти в по-нататъшното използване и поддръжката на актива.

TCO се използва за определяне на усилията и бюджет струва необходимо да се харчат за една система. Един прост начин за моделиране в ABACUS за TCO е да се прекъсне IT система по компоненти. След това можем да разберете колко средно струва да тече един от тези компоненти. След това ние ще могат да фактор в различни разходи в зависимост от това дали на ИТ системата е evolvable или отворен и т.н. Ако системата е вече създаден и работи, основният фактор е да се помисли за разходите за поддръжка и може би разходите за извеждане от експлоатация.

Пример

Диаграма за пример Изчисление

Компонентът под Организация или неговия стандарт има следните свойства:

· FTE= 100 000 $ / год

· Подкрепа Effort= 0.01 FTE + 0.001 FTE / год = 1000 $ + 100 $ / год

· Поддръжка Cost= 100 $ - 10 $ / год

· Capital Cost= 2000 $

· Инсталирайте Effort= 2 FTE / ден = 0.01 FTE / год = 1000 $

Компонентът по организация има тези свойства:

· Инсталирайте Horizon= -2 Години (т.е. Системата е инсталирана 2 години преди настоящето)

· Продължителност на живота= 3 години

Кога Инсталирайте Horizon + Живот <= 0 , Не е по-евтина поддръжка.

Изчисления

Изчисленията са, както следва:

Забележка

TC = стойността на година. SE = Support усилие. MC = разходи за поддръжка.

· Първоначални разходи = Capital Cost + Инсталирайте Effort= 2000 + 1000 = 3000 $

· При Т = -2 (през първата година), TC = Първоначални разходи + SE + MC= 3000 + 1000 + 100 = 4100 $

· При Т = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1 190 $

· При Т = 0, ТС = (1000 + 200) + (100 - 20) = 1280 $

· В т = 1 (последната година), TC = (1000 + 300) + (100-30) = 1370 $

Графика за пример Изчисление

TCO е сумата на всички настоящи и бъдещи разходи, докато системата е била изведена от експлоатация.

· В т = -2 (по време на първата година), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· В т = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· В т = 0, TCO = 1,280 + 1,370 = 2650 $

· В т = 1 (последната година), TCO = 1370 $

Ключови фактори за разходите

Ключовите фактори за разходите, които се вземат предвид при изчисляване на ТСО на даден актив в ABACUS са:

· Hardware Придобиване- Първоначални разходи за оборудване (капиталовите разходи) на.

· Software Придобиване- Първоначални разходи за лиценза за софтуер (капиталовите разходи).

· Монтаж- Разходи, свързани с първоначалната настройка.

· Обучение- Разходите, свързани с външно обучение продавач след първоначалната настройка.

· Подкрепа- Разходи, свързани с вътрешна подкрепа.

· Поддръжка- Разходи за подмяна или модернизация продавача договори за поддръжка, консумативи и разходи за възстановяване след бедствие.

· Инфраструктура- Разходи, свързани с подкрепа на актива.

ABACUS Пример Представителство на Ключови фактори за разходите

Работещи симулатора на Cost

За да се симулира си архитектура по отношение на разходите

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Изберете Анализ| Цена.

3. Избери Архитектура (S)желаете да включите в оценката.

Забележка

По подразбиране, ABACUS автоматично ще избере архитектура (и), за които е необходимо повторно симулация поради появата на базовия имот или структурни промени.Това Отбелязването е показан в Червен на Лента с инструменти Simulation .

4. Изберете Валутаот падащото.

5. Преместете Години да изчисляватплъзгача на броя на годините, необходими.

Забележка

По подразбиране, ако годините за изчисляване е повече от 1 година разходите ще бъдат автоматично изчислява за всяка отделна година (и колекция от свойства добавя / актуализирани) и след това кумулативна стойност за целия броя на годините, също се изчислява. Ако се изисква само кумулативната стойност след това махнете отметката от Изчислете Per-Година Разходивариант, както е описано по-долу, за да спестите от броя на имоти в проекта.

6. Изберете дали да напусне Изчислете Per-Година Разходипроверява или да го махнете.

7. Кликнете Следващия.

8. По желание изберете най- Connectionsжелаете да се припише на разходите заедно като част от оценката.

Забележка

Използвайки Разходите | Приписванесобственост върху разходите за връзки може да бъде приписва от компонент, прикрепен към края на мивка връзката с компонент, прикрепен към края на източник(т.е. Cost | Attribution = "Sink към източник"), или от компонент прикрепен към източник край на връзката с компонент прикрепен към мивка край(т.е. Cost | Attribution = "Source да потънат"), Освен това, ABACUS автоматично ще избере тези връзки с поведение | Връзка = "процеси" или "опори"и посоката на авторството ще бъде "Мивка за източник", Освен това разходи разпределено съгласно всяка поведение | % Или Cost | % Свойства на връзките, или алтернативно, където има множество връзки от мивка с много източнициили източник на много мивки, Съгласно всяка поведение | Обработка на имоти на компонентите на изходнитеили мивка компоненти съответно.

9. Кликнете завършеки вие ще получите Вниманиедиалогов прозорец.

10. По желание опознаването на предупрежденията, като щракнете Детайли >>.

11. Кликнете продължи.

Забележка

В този момент, ABACUS ще извърши остойностяване оценка, основан на дейности на архитектурата (и) и след кратко време (с напредъка барове за обратна връзка) ще се появи на изчисление пълна диалоговия.

12. Кликнете Добреда признае оценката.

Бакшиш

За курсове за обучение и допълнителна помощ на Cost Simulation се обърнете към Avolution Общността .

Компонент и / или Connection Имоти

В следващата таблица са компонента и / или връзка свойства, необходими за оценка на разходите.Тези свойства ще бъдат показани в прозореца Properties с икона на входния селектор на имот ред ( [image] ) С подсказка "Input Cost". A промяна в някое от тези "вход" свойства и различни структурни промени в хранилището ще доведе до симулатора на Cost изискващи повторна симулация, както е посочено в Червен на Лента с инструменти Simulation .

Тип

Име

Стойност по подразбиране

Мерна единица

Тип на данните

Длъжен

Описание

Цена

Инсталирайте Horizon

0

години

Цяло число

Вярно

Задава когато компонентът или връзка е била или ще бъде инсталиран.

· Стойност 0 (по подразбиране) показва, че компонентът или връзка се инсталира през текущата година.

· Стойност по-малка от 0 означава, че компонентът или връзка е била инсталирана в миналото.

· Стойност по-голяма от 0 означава, че компонентът или връзка ще бъде инсталиран в бъдеще.

Цена

Продължителност на живота

0

години

Цяло число

Вярно

Задава продължителността на периода, в който компонентът или връзка ще остане в експлоатация, след което ще бъдат изведени от експлоатация.

Цена

FTE

100,000.00

$ / година

Десетичен

Фалшив

Годишните разходи на всеки служител Full Time.

Ако този имот не се намира в компонентасамостоятелно или в случая на свързване на компонент, прикрепен към края на мивка връзката, Ще се търси в други компоненти.

Първо, всеки "мивка" компонентs в края на a връзка с "опори" отношения на компонента, ще се търси, последвано от че "мивка" майка на компонентас.

Ако не бъде намерен на имота FTE, на компонента родител-components след това ще се търсят. Ако все още не е намерен FTE, се използва стойността по подразбиране.

Обърнете внимание: FTE е само валиден вход имот на компоненти.

Цена

Поддръжка Cost (фиксирана)

0.00

$ / година

Десетичен

Фалшив

Годишните разходи за поддържане на определен компонентили връзка.

Цена

Поддръжка Cost (променлива)

0.00

$ / година

Десетичен

Фалшив

Сумата, с която общата стойност на поддържането на компонента или връзка ще се променят всяка година.

Така например, на стойност $ -500 показва, че общите разходи за поддръжка понижава с $ 500 всяка година, докато на стойност $ 500, показва, че общото увеличение на разходите за поддръжка по $ 500 всяка година.

Цена

Подкрепа Effort (фиксирана)

0.00

FTE / година

Десетичен

Фалшив

Годишният фиксирана усилия за подкрепа на компонентаили връзка, Определен по отношение на човеко-години.

Цена

Подкрепа Effort (променлива)

0.00

FTE / година

Десетичен

Фалшив

Сумата, с която общото усилие за подкрепа на компонента или връзка ще се променят всяка година.

Така например, на стойност -0.01 показва, че общото усилие подкрепа намалява с 0.01 човекогодини всяка година, докато на стойност 0.01 показва, че увеличението на общия подкрепа усилия от 0.01 всяка година.

Цена

Capital Cost

0.00

$

Десетичен

Фалшив

Първоначалната цена за закупуване на компонентаили връзка.

Цена

Инсталирайте Effort

0.00

FTE

Десетичен

Фалшив

Изисква Усилията, в човеко-години, за да инсталирате компонентаили връзка.

В следващата таблица са компонента и / или връзка свойства, които се извеждат от оценителя TCO. Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Cost Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и симулатор на разходите изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Забележка

Когато изходните имотите от оценителя TCO трябва да бъде "закръглена" на "Round половина дори" подход (наричан също "банкери" закръгляване) се използва.Тази техника се използва за по-равномерно разрешаване на всеки 0.5 "вратовръзки разбива", като резултатът се закръглява нагоре или надолу до най-близкото дори резултат, а не винаги се закръгляне нагоре или надолу и изопачаване на резултата. Т.е. 2.5 се закръглява надолу до 2, а 3.5 се закръглява до 4, а не да ги както се било закръглява надолу до 2 и 3 или закръглена до 3 и 4.

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Цена | Обща стойност на собственост - следващите х години. | $ | Цяло число | Фалшив | Общата стойност на собствеността върху следващия xгодини, където х е продължителността на времето, определено, когато работи на оценителя. Това включва разходите на компонента или свързване на стандарти, под-компонентиили под-връзки(т.е. деца) и всякакви приписани разходи.
Цена | Обща стойност на собственост (местно) - следващата х години. | $ | Цяло число | Фалшив | The "местни" Цената на собственост върху следващия xгодини, където xе продължителността на времето, определено, когато работи на оценителя. Това прави нее включена цената на подкомпоненти към тях, или свързване на под-връзки (т.е.деца) или всяка приписани разходи.
Цена | Обща стойност на собственост (деца) - следващата х години. | $ | Цяло число | Фалшив | The "деца" Цената на собственост върху следващия xгодини, където х е продължителността на времето, определено, когато работи на оценителя. Това само включва разходите за подкомпоненти към тях, или свързване на под-връзки (т.е. деца).
Цена | Обща стойност на собственост (приписва) - следващата х години. | $ | Цяло число | Фалшив | The "приписани" Цената на собственост върху следващия xгодини, където х е продължителността на времето, определено, когато работи на оценителя. Това само включва всички отнесени разходи от приложените компоненти(които могат да включват, разбира се дължи на разходите от всички прикрепени връзки).

В следващата таблица са компонента и / или връзка свойства, които се извеждат от оценителя TCOако Изчисли Per-Годината разноски опция е избрана. Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Cost Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и симулатор на разходите изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Забележка

Виж бележката по-горе относно възможната закръглянето на високопродуктивни качества.

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Цена | Обща стойност на собственост - годинах. | $ | Цяло число | Фалшив | Общата стойност на собствеността за година x, Където х е за всяка година посочено, когато работи на оценителя. Това включва разходите на компонентаили свързване на стандарти, под-компоненти или под-връзки (т.е. деца) и всякакви приписани разходи.
Цена | Обща стойност на собственост (местно) - годинах. | $ | Цяло число | Фалшив | The "местни" цена на притежание за година x, където xе за всяка година посочено, когато работи на оценителя. Това прави нее включена цената на подкомпоненти към тях, или свързване на под-връзки (т.е. деца) или всяка приписани разходи.
Цена | Обща стойност на собственост (деца) - годинах. | $ | Цяло число | Фалшив | На "децата" цена на притежание за година x, Където х е за всяка година посочено, когато работи на оценителя. Това само включва разходите за подкомпоненти към тях, или свързване на под-връзка (т.е. деца).
Цена | Обща стойност на собственост (приписва) - годинах. | $ | Цяло число | Фалшив | The "приписани" цена на притежание за година x, Където х е за всяка година посочено, когато работи на оценителя. Това само включва всички отнесени разходи от приложените компоненти(които могат да включват, разбира се дължи на разходите от всички прикрепени връзки).

Допълнителен Connection Properties

Следните списъци трапезни допълнителен свойства на свързване, които се изискват от оценителя TCO. Тези свойства ще бъдат показани в прозореца Properties с икона на входния селектор на имот ред ( [image] ) С подсказка "Input Cost / производителност" или просто "Input Cost". A промяна в някое от тези "вход" свойства и различни структурни промени в хранилището ще доведе до разходи и / или Симулатор Изпълнение изисква повторно симулация, както е посочено в Червен на Лента с инструменти Simulation .

Тип | Име | Стойност по подразбиране | Мерна единица | Тип на данните | Длъжен | Описание
Цена | Приписване | Мивка за Source | [Източник за мивка | Мивка за Source] | Търсене / Списък | Вярно | Ако "Източник на мивка", Тази връзка ще имам имам ценаsприписва "заедно" то от източниккомпонент към мивка компонент, Алтернативно, ако "Мивка за Source", Тази връзка ще са разходи се приписват "заедно" то от мивка компонент на източника.
Поведение | Взаимоотношение | опори | [процеси | подкрепя] | Търсене / Списък | Фалшив | Ако "поддържа", показва, че тази връзка "източник" компонент се поддържа от "мивка" компонент. Освен това, ако някоя "опори" или "процеси" след това връзката автоматично ще бъдат избрани във връзките да имат разходите си приписват "заедно" от мивка компонент към източника.
Цена | % | 100.0 | % | Десетичен | Фалшив | Показва, делът на разходите за мивка компоненти, които ще бъдат възложени на източника. Стойностите на% не трябва да се добавят до 100% и тя просто се използва за мащабиране на "обща стойност на собственост -. Х следващите години" имот (виж по-горе) от мивка компонент, тъй като се дължи на източника.

Архитектура Имоти

Таблицата по-долу изброява архитектурни качества, които се извеждат от оценителя TCO. Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Cost Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и симулатор на разходите изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Забележка

Виж бележката по-горе относно възможната закръглянето на високопродуктивни качества.

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Цена | Обща стойност на собственост - следващите х години. | $ | Цяло число | Фалшив | Общата стойност на собствеността на цялата архитектура през следващите х години.

Таблицата по-долу изброява архитектурни качества, които се извеждат от оценителя TCOако Изчисли Per-Годината разноски опция е избрана. Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Cost Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и симулатор на разходите изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Забележка

Виж бележката по-горе относно възможната закръглянето на високопродуктивни качества.

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Цена | Обща стойност на собственост - годинах. | $ | Цяло число | Фалшив | Общата стойност на собствеността за цялата архитектура за година xв бъдещето.


Симулиране модулност

Navigation: Симулиране си архитектура> Тренажори>

Симулиране модулност

Изпратете коментари по тази тема.

Симулаторът на модулност изчислява броя на входящите и изходящите връзки за всеки компонент.

За да се симулира си архитектура по отношение на модулността

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Изберете Анализ| Модулност.

3. Избери Архитектура (S)желаете да включите в оценката.

Забележка

По подразбиране, ABACUS автоматично ще избере архитектура (и), за които е необходимо повторно симулация поради някакви основните структурни промени.Това Отбелязването е показан в Червен на Лента с инструменти Simulation .

4. Кликнете Следващия.

5. Избери Видове на връзката (ите)желаете да включите в оценката.

6. Кликнете Следващия.

7. По желание персонализирате имената на собственост за резултатите от изчисление.

8. Кликнете завършек.

Забележка

В този момент, ABACUS ще извърши структурна оценка на архитектурата (и) и след кратко време (с напредъка барове за обратна връзка) ще се появи на изчисление пълна диалоговия.

9. Кликнете Добреда признае оценката.

Бакшиш

За курсове за обучение и допълнителна помощ за модулност оценка се обърнете към Avolution Общността .

Компонент имоти

В следващата таблица са съставните имотите, които се извеждат от модулност оценител.Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "модулност Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради основна структурна промяна на регистъра и на симулатора модулност изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Тип на данните | Длъжен | Описание
Модулност | Съединител-фен в (местно) | Цяло число | Фалшив | Броят на свързванията, че фен на този компонент.
Модулност | Съединител-фен навън (местно) | Цяло число | Фалшив | Броят на свързванията, че фен от този компонент.
Модулност | Съединител-фен в | Цяло число | Фалшив | Броят на свързванията, че фен на този компонент, включително връзки, че фен на под-компоненти.
Модулност | Съединител-фен на | Цяло число | Фалшив | Броят на свързванията, че фен от този компонент, включително връзки, че фен на под-компоненти.


Симулиране Откритостта

Navigation: Симулиране си архитектура> Тренажори>

Симулиране Откритостта

Изпратете коментари по тази тема.

Симулаторът на откритост определя степента, до която една архитектура и неговите елементи са "отворени", което означава, че способността на системата да се справят с подмяна на компоненти с минимално въздействие.

За да се симулира си архитектура по отношение на отвореността

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Изберете Анализ | Откритост.

3. Избери Архитектура (S)желаете да включите в оценката.

Забележка

По подразбиране, ABACUS автоматично ще избере първата архитектура, за които е необходимо повторно симулация поради появата на базовия имот или структурни промени.Това Отбелязването е показан в Червен на Лента с инструменти Simulation .

4. Кликнете завършеки вие ще получите Вниманиедиалогов прозорец.

5. По желание опознаването на предупрежденията, като щракнете Детайли >>.

6. Кликнете продължи.

Забележка

В този момент, ABACUS ще извърши структурна оценка на архитектурата (и) и след кратко време (с напредъка барове за обратна връзка) ще се появи на изчисление пълна диалоговия.

7. Кликнете Добреда потвърдя симулацията.

Бакшиш

За курсове за обучение и допълнителна помощ на оценка Откритостта се обърнете към Avolution Общността .

Компоненти и свързване Стандартни Properties

В следващата таблица са стандартни свойства на компонентите и връзка изисква да се оцени откритост.Тези свойства ще бъдат показани в прозореца Properties с икона на входния селектор на имот ред ( [image] ) С подсказка "Откритост Input". A промяна в някое от тези "вход" имоти в хранилището ще доведе до симулатора Откритостта изискващи повторна симулация, както е посочено в Червен на Лента с инструменти Simulation .

Тип | Име | Стойност по подразбиране | Мерна единица | Тип на данните | Длъжен | Описание
Откритост | Стандарти-Standard Maturity Level-Организация |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Ниво на отговорния орган по стандартизация 0:Организационна / Proprietary 1:Консорциум / Defacto 2:National / Военни 3:Международен
Откритост | Стандарти-Standard Maturity-Status |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Ниво Одобрение постига с стандарти тялото 0:Проект на работната / Комисия 1:Public Проект / изтеглен 2:Временното Проект 3:Одобрен
Откритост | Стандарти-Standard Maturity-стабилност |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Е стандартът вероятно да се промени? 0:Standard остарели 1:Силно подлежи на промяна в следващата 1 до 2 години 2:Известна промяна / промени на съществуващите функции 3:Силно стабилна (без промяна в рамките на 2 години)
Откритост | Стандарти-Standard Maturity-Vendor Support |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Търговец Support 0:Няма продукти или доставчици поддържат стандарта 1:Един или повече доставчици, които прилагат част на стандарта 2:Повече от един продавач, с продукти, които изпълняват всички части на стандарт 3:Много повече от един продавач, с продукти, които изпълняват всички части на стандарт
Откритост | Стандарти-Standard категоричност-Документация |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Качество на стандартната документация 0:Беден 1:Справедлив 2:Добър 3:Отличен
Откритост | Стандарти-Standard категоричност-Standard Width |  |  | Цяло число | Фалшив | Брой функции. Броят на най-ниските стандартни ниво характеристики - Sf
Откритост | Стандарти-Standard категоричност-Sm |  | % | Десетичен | Фалшив | Процент от общия брой функции, които са задължителни за попълване
Откритост | Стандарти-Standard категоричност-така |  | % | Десетичен | Фалшив | Процент от общия брой функции, които не са задължителни
Откритост | Стандарти-Standard категоричност-Sc |  | % | Десетичен | Фалшив | Процент от общия брой функции, които са дефинирана условно
Откритост | Profiles-профил Documentation-Документация |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Качество на стандартната документация 0: Никой 1:Беден 2:Справедлив 3:Отличен
Откритост | Profiles-профил Documentation-Точност |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Има ли документация отразява действителния дизайн система? Какво ниво на профила функции се използват в системата? 0:Не функции 1:Някои функции 2:Повечето функции 3:Всички функции
Откритост | Profiles-профил Documentation-Maturity |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Дали профила зрял и достъпно? 0:Временна 1:Въз основа на проекта 2:Организационна 3:Публичен
Откритост | Profiles-профил категоричност-Explicit Width |  |  | Цяло число | Фалшив | Брой на стандартни функции, определени, както се изисква в профила
Откритост | Profiles-профил категоричност-Pm |  | % | Десетичен | Фалшив | Процент от ЗАДЪЛЖИТЕЛНИ функции в профила
Откритост | Profiles-профил категоричност-Po |  | % | Десетичен | Фалшив | Процент на допълнителни функции в профил
Откритост | Profiles-профил категоричност-Pc |  | % | Десетичен | Фалшив | Процент дефинирана условно функции в профила
Откритост | Profiles-профил категоричност-Покритие |  | % | Десетичен | Фалшив | Процент от стандартни функции са подробно разгледани в профила
Откритост | Profiles-профил Extensions-Extension Width |  |  | Цяло число | Фалшив | Брой на нестандартни функции, определен от профила
Откритост | Profiles-профил Extensions-Покритие |  | % | Десетичен | Фалшив | Процент на разширения подробно в профила
Откритост | Продукти-Каталог Наличност и Conformance-Брой на продукти |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Брой продукти в подкрепа на задължителните характеристики на стандарта 0:Няма продукти поддържат стандарта 1:Един или повече продукти прилагат част на стандарта 2:Повече от един продукт изпълнява всички части на стандарта 3:Много повече от един продукт изпълнява всички части на стандарта
Откритост | Продукти-Каталог Наличност и Conformance-Application Conformance |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Какво ниво на съответствие се продукти са в съответствие със стандарта? 0: Никой 1:Заявените 2:Доказвам 3:Сертифицирани и демонстрираше
Откритост | Продукти-Каталог Наличност и Conformance-Conformance Quality |  | [0 | 1 | 2 | 3] | Търсене / Списък | Фалшив | Качество на изпитването за съответствие 0: Никой 1:В къща тестване от разработчик на продукти 2:Независими изследвания (например NIST) 3:Доказвам в контекста на съответния продукт

Компонент, Connection и Архитектура Имоти

Таблицата по-долу изброява компонент, връзката и архитектурни качества изхода от откритост оценител. Всички от следните свойства оцени до между нула (0) и три (3), нула (0) е най-малкото желателно и три (3) е най-желаната.Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Откритост Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради промяна основната имот на хранилището и симулатора Откритостта изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Тип на данните | Длъжен | Описание
Откритост | Откритост | Десетичен | Фалшив | Цялостна оценка на откритост покупка.
Откритост | Стандарти-Standard Maturity | Десетичен | Фалшив | Сегашното състояние на стандарта, което отразява или не е бил одобрен, колко време е било използвано и колко добре прието, че е в рамките на общността на разработчиците.
Откритост | Стандарти-Standard категоричност | Десетичен | Фалшив | The категоричност на стандартите, което отразява потенциалната неяснотата в последвалите стандарти
Откритост | Profiles-профил Документация | Десетичен | Фалшив | Степента, в която интерфейс профил документация е разработена и дали документацията на профила отразява същинското проектиране на системата и / или внедрената система
Откритост | Profiles-профил категоричност | Десетичен | Фалшив | Нивото на детайлност, предоставена в профил / профил спецификация
Откритост | Профили профил Extensions | Десетичен | Фалшив | Степента, до която профила отговаря на стандарта, на които се основава
Откритост | Продукти-Каталог Наличност и Conformance | Десетичен | Фалшив | Независимо дали има или не са отворени стандартни съвместимите продукти, достъпни за използване в проекта


Симулиране на ефективността

Navigation: Симулиране си архитектура> Тренажори>

Симулиране на ефективността

Изпратете коментари по тази тема.

Заден план

Архитектурният оценител за изпълнение е дискретна събитие симулатор, който работи чрез симулиране на потока от съобщения (или символи) в цялата архитектура. Теорията зад това се извлича от изследване направено от Техническия университет, Сидни, и се основава на Layered Queuing Мрежови Models(LQNM), Timed и Цветни Петри-Nets(TCPN) и Дейност цикъл Diagrams(ACD).

В симулацията работоспособност ABACUS, преработка на един компонент се дължи до голяма степен на съобщения преминали към него от друг компонент. Принципите, които стоят зад тази техника могат да бъдат разбрани в четири основни части:

1. The съобщение-ориентиранакомуникация се моделира в ABACUS използвайки логичен(или индиректен) връзки. Логически връзки определят поведението (честота и данни) на съобщенията, преминали между компонентите. Един добър пример за логически връзки ще бъде последователността потоци между две (2) бизнес процеси или логическите интерфейси между две (2) приложения.

2. Логическите съобщения са транспортирани до местоназначението си чрез йерархия(като ресурси swimlanes) или директенвръзки (като физически проводници). За да направите това те могат да бъдат пренасочени до, могат да отстъпи йерархията (слоеста подход) да следват прекия път.

3. The достоверността на модела може да се регулира, за да отговарят. Например, процес, могат да бъдат разделени до такава степен, така че всеки елементарен процес и функция има отделна обработка отпечатък. Алтернативно, може да е достатъчно, за да има само една стойност за целия процес, отразяващ среденобработка на отговор на съобщение.

4. Действителната обработкасе извършва само от компоненти, които имат (или са) процесор. Процесорът е нещо родово, и може да бъде CPU, човек, организационна единица или нещо друго, което е в състояние да осъществява дейност. Например, един бизнес процес не направя някоя действителна преработка; това се прави от първия "преработвател" тя е локализирана в някой от родителите си йерархия (ако се използва swimlane нотация) или неговата преработка мрежа (ако се използва разпределена обработка нотация).

Оценяването се извършва чрез симулиране на (определен) Трафикът в системата, така че всяка връзка се симулира най-малко веднъж. Пристигане времена на съобщенията са случайно генерирани по отношение на тяхната определена честота. Моделът симулира преработка на ресурсите и раздора и нареждане на опашка на съобщенията, събиране на статистически данни по протежение на пътя и различни изходни свойства.

Ключови фактори за въвеждане на ефективността

1. Честота- Честотата, при която протича връзката.

2. Обработване- Размерът на времето за изпълнение, за да завършите един процес. Това може да е в час, минути, дни, операции и т.н.

3. Скорост- Скоростта на процесора ресурс. Това е, колко цикъла / инструкции / действия той може да изпълнява в една единица време. Важно е да бъде в съответствие с единиците, използвани за обработка.

4. Процесори- Броят на процесорни ресурси. Преработвателите могат да бъдат хора, процесора, външни организации и т.н.

Ключови Изходни Изпълнение Фактори

1. Пропускателна способност- Броят на съобщенията за единица време през Връзка, Това действителната стойност може да бъде в сравнение с очакваните / теоретичните стойности (т.е. честота), за да се извлече насищане на системата.

2. Съобщението Курсове- Броят на съобщенията за единица време през компонент, Това е сумата на входящите и изходящите съобщения на всички компоненти.

3. Отговор- Минималната / средното / максимална латентност за това Връзка, Това е сумата от всички наблюдавани латентността за връзката от извора до мивката и всяко изчакване и обработката (и латентност обратно към източника, ако двупосочен).

4. Усвояване- Използването на компонент, Това ще бъде 0%, ако компонентът не е устройство / процесор (т.е. той не разполага с преработвателите и скорост свойства, определени по-горе).

Докато отделен случай се извършва симулация за изчисляване на различни изходни свойства, както е описано по-горе, със следната формула може да се използва като груб проверка на резултатите (където системата не е запълнен):

Усвояване = сумата от Frequency за всички входящи връзки * Processing / (Speed ​​* процесори)

Цялостната концепция е може би най демонстрира чрез спазване на следната диаграма, която показва две различни характеристики мета-модели. Лявата ръка стил е класически "swimlane" нотация с изпълняваните задачи, базирани йерархично в рамките на своите процесорни ресурси. Полето Стилът на ръка е "разпределена" нотация с обработката на заданието свързани чрез процесите на присъединяване към тяхната процесорен ресурс. Последното нотация позволява множество процесорни ресурси за дадена задача за обработка, за разлика от ограничен нотация swimlane.

Забележка

Показани от всяка мета-модел са входните свойства (в червено) и изходните свойства (в синьо):

Експлоатационни мета-модели: Swimlane срещу Разпределени нотация

Работещи симулатора на ефективността

За да се симулира си архитектура по отношение на производителност

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Изберете Анализ| производителностили щракнете върху бутона в лентата с инструменти.

3. Изберете Архитектуражелаете да се оцени от падащото меню.

Забележка

По подразбиране, ABACUS автоматично ще избере първата архитектура, за които е необходимо повторно симулация поради появата на базовия имот или структурни промени.Това Отбелязването е показан в Червен на Лента с инструменти Simulation .

4. Изберете Елементи и Connectionsжелаете да се оцени, от прозорец за избор на стандартен елемент .

5. Задайте Run Time Scale Factorслайдер.

Забележка

По-високи стойности ще доведат до по-статистически последователни резултати, но отнемат повече време, за да се изчисли.

Допълнителен Checkbox към прозорец за избор на стандартен елемент

· SАве Преобразен Model ще запишете копие на RBD трансформирана версия на проекта в същата папка, като текущия проект и прилага "_transformed" до името на проекта.Това трансформира проект може да се използва за диагностика в подробности симулация на надеждност, предприета от ABACUS.

Други възможности на прозорец за избор на стандартен елемент

· Run Time Scale Factor Контрол на времето за симулация и точността, с по-висока стойности добивINGпо статистически последователни резултати, но като по-дълго време, за да тичам.

Забележка

Когато ABACUS изчислява времето за симулация ще определи най-бавния непряко свързване честота, която бе избрана да бъде симулирано и след това "загрявка" за периода (т.е. 1 над честотата) на тази връзка (започване периодични генератори съобщения за всички връзки на случаен принцип през това време за загряване, което им дава всички шансове да започне) и след това симулира за Run Time Scale Factor пъти периода на тази връзка. Или (1 / Frequency) време за загряване + (1 / Frequency) * Run Time Scale Factor симулация време. Това е, за да се уверите, че това, че всички връзки са започнали преди се събират статистически данни и след това най-бавния връзката все още е симулирано най-малко веднъж в симулация. Например Ако най-бавния косвена връзка има Честота на 0.033 времеви единици (или ок веднъж месечно, ако времеви единици са дни), след това времето за загряване ще бъде 30.3 времеви единици, а времето за симулация ще бъде 30.3 времеви единици пъти Run време Scale Factor на.

6. Кликнете завършеки вие ще получите Вниманиедиалогов прозорец.

7. По желание опознаването на предупрежденията, като щракнете Детайли >>.

8. Кликнете продължи.

Забележка

В този момент, ABACUS ще изпълнява дискретна проява симулация на архитектурата и след кратко време (с напредъка барове за обратна връзка) изчисление пълна диалоговия ще се появи.

9. Кликнете Добреда потвърдя симулацията.

Бакшиш

За курсове за обучение и допълнителна помощ на Simulation Изпълнение Моля обърнете се към Avolution Общността .

Компонент имоти

В следващата таблица са качествата, необходими за оценка на изпълнението. Информацията се търси на първо място в Компонент инстанции, и ако не е намерен, се използват след това на Стандартите на компоненти по подразбиране.Тези свойства ще бъдат показани в прозореца Properties с икона на входния селектор на имот ред ( [image] ) С подсказка "Input производителност". A промяна в някое от тези "вход" свойства и различни структурни промени в хранилището ще доведе в симулатора на ефективността изисква повторна симулация, както е посочено в Червен на Лента с инструменти Simulation .

Тип | Име | Стойност по подразбиране | Мерна единица | Тип на данните | Длъжен | Описание
Поведение | b_pack | 0.0 |  | Десетичен | Фалшив | Фиксирано време за обслужване да се опаковат в секунди. Този имот обикновено определен като стандартен тип и след това се използва за множество случаи на отделните компоненти. Например, CORBA има b_pack = 0.23 милисекунди.
Поведение | m_pack | 0.0 |  | Десетичен | Фалшив | Времето за променлива услуга да се опаковат в секунда / байт. Този имот обикновено определен като стандартен тип и след това се използва за множество случаи на отделните компоненти.
Поведение | b_unpack | 0.0 |  | Десетичен | Фалшив | Фиксирано време за обслужване да разопаковате в секунди. Този имот обикновеноопределен като стандартен тип и след това се използва за множество случаи на отделните компоненти.
Поведение | m_unpack | 0.0 |  | Десетичен | Фалшив | Времето за променлива услуга да разопаковате в секунда / байт. Този имот обикновеноопределен като стандартен тип и след това се използва за множество случаи на отделните компоненти.
Поведение | Обработване | 0.0 |  | Десетичен | Вярно | Размерът на времето за изпълнение, за да завършите един процес. Това може да е в час, минути, дни, операции и т.н.
Поведение | Процесори | 1 |  | Цяло число | Вярно | Броят на процесор ресурси. Преработвателите могат да бъдат лица, процесора, външни организации и т.н.
Поведение | Скорост | 100 |  | Цяло число | Вярно | Скоростта на процесор ресурс. Това е, колко цикъла / инструкции / действия той може да изпълнява в една единица време. Важно е да бъде в съответствие с единиците, използвани за обработка.
Поведение | k_bkgd | 0.0 |  | Десетичен | Фалшив | Обработка на фона на компонента. Това се използва за регулиране на резултатите в посрещането на всички фиксирани компенсации за%. Това най-вероятно могат да бъдат пренебрегнати.

В следващата таблица са компонент свойства изход от оценител на изпълнението. Набор от тези съставни свойства се генерира за всеки компонент на всяко изпълнение план.Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Output производителност". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и симулатор на ефективността на работата изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Поведение | Съобщението Курсове |  | Десетичен | Фалшив | Броят на съобщенията за единица време чрез компонента. Това е сумата на входящите и изходящите съобщения на всички компоненти.
Поведение | Bandwidth |  | Десетичен | Фалшив | Обща широчина на честотната лента чрез компонента. Сумата се дължи както на входящи и изходящи съобщения.
Поведение | Усвояване | % | Десетичен | Фалшив | Усвояването на компонента. Това ще бъде 0%, ако компонентът не е устройство / процесор (т.е. То не трябва процесори и Скоростни свойства, определени по-горе)

Connection Properties

В следващата таблица са качествата, необходими за оценка на изпълнението. Информацията се търсят първо в случаите на връзката, след това стандартите за връзка и ако не е намерен, се използва по подразбиране.Тези свойства ще бъдат показани в прозореца Properties с икона на входния селектор на имот ред ( [image] ) С подсказка "Input Изпълнение" или "Разходи Input / производителност". A промяна в някое от тези "вход" свойства и различни структурни промени в хранилището ще доведе до симулатора на ефективността и / или Разходите симулатор изисква повторно симулация, както е посочено в Червен на Лента с инструменти Simulation .

Тип

Име

Стойност по подразбиране

Мерна единица

Тип на данните

Длъжен

Описание

Поведение

Вид

двупосочна

[двупосочна | еднопосочен]

Търсене / Списък

Вярно

Независимо дали връзката е двупосочна (двупосочно) или еднопосочна (еднопосочно).

Допустимите стойности за този имот са "двупосочни" или "еднопосочни".

Двупосочен означава синхронни съобщения заявка / отговор, докато еднопосочен път единна асинхронен "събитие".

Поведение

Абстракция

непряк

[непряка | директна]

Търсене / Списък

Вярно

Независимо дали връзката е физическо или логически. Директни връзки са физически "тръби" между два компонента, които логически връзки текат заедно.

Допустимите стойности за този имот са "преки" или "непреки".

Ако стойността е "пряко", след това връзката не се нуждае от никакви други свойства (с изключение на имотите Любезни и абстракция).

Данни

L_app1

0

Цяло число

Фалшив

Заявка / размер събитие в байтове.

Всяка връзка обикновено ще има специфична стойност за това. В CORBA, събития всъщност са двупосочни и винаги са с 12 байта потвърдя (L_app2). Ако това е вярно еднопосочна връзка след това остави имота L_app2.

Данни

L_app2

0

Цяло число

Фалшив

Response / признае размера в байтове.

Всяка връзка обикновено ще има специфична стойност за това. A еднопосочна връзка няма да има L_app2.

Поведение

Честота

1

Десетичен

Вярно

Честотата, с която се появява връзката.

Всяка връзка обикновено ще има специфична стойност за това. Ако честотата на имот е изолиран след това се използва по подразбиране.

Поведение

Взаимоотношение

процеси

[процеси | подкрепя]

Търсене / Списък

Фалшив

Съединения, които имат "процеси" показват, че имота компонент в началото на връзката ще бъде трансформирана да бъдат преработени в компонент в края на връзката. В смисъл на "източник" компонент се мести, за да станете дете на "потънат" компонент (приложените връзки са също "влачат" с този ход).

Ако "процеси" собственост съществува тогава всички други свойства на свързване ще бъдат игнорирани, освен по желание "%" Имотът е описано по-долу.

Поведение

%

100.0

Десетичен

Фалшив

Връзките, които имат "процеси" имота (описан по-горе) може евентуално да имат "%" собственост да се посочи делът на обработката, които ще бъдат приписани на компонент дестинация. По този начин един компонент източник могат да бъдат обработени от множество компоненти дестинация в различни%-те години. Стойностите на% не трябва да се добавят до 100% и тя просто се използва за мащабиране на "обработка" собственост (виж по-горе) за източник на компонентите като тя се трансформира, за да станете дете на компонента на дестинация.

В следващата таблица са свойствата, генерирани от оценител на изпълнението. Набор от тези свързващи свойства се генерира за всяка връзка по всяко изпълнение план.Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Output производителност". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и симулатор на ефективността на работата изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Поведение | Bandwidth |  | Десетичен | Фалшив | Общата честотната лента на връзката. Това се изчислява само за косвени връзки и е по същество (L_app1 + L_app2) * Пропускателна способност.
Поведение | Bandwidth 1/2 |  | Десетичен | Фалшив | В честотна лента специално за изходящи (1) и входящи (2) съобщения на връзката. Това се изчислява само за косвени връзки и е по същество L_app1 * Пропускателна и L_app2 * Пропускателна способност.
Поведение | Пропускателна способност |  | Десетичен | Фалшив | Броят на съобщенията за единица време през връзката. Това действителната стойност може да бъде в сравнение с очакваните / теоретичните стойности (т.е. честота), за да се извлече насищане на системата.
Поведение | Завършен | % | Десетичен | Фалшив | Процентът на съобщения, които завършат успешно за обработка за връзката. Това се изчислява само за косвени връзки и е Пропускателна / честота. Понякога Завършен стойност надвишава 100%, защото случайността на резултати поколение съобщение в малко по-висока честота на генериране на съобщения от определен.
Поведение | Отговор (Min / Ave / Max) |  | Десетичен | Фалшив | Минималният / средното / максимална латентност. Това се изчислява само за косвени връзки и е наблюдаваното латентността за връзка от източника до мивка и всяко изчакване и обработката (и латентност обратно към източника, ако двупосочен).

Архитектура Имоти

В следващата таблица са архитектурните качества на цялата система, генерирани от оценител на изпълнението. Един единствен набор от имоти за архитектурата са "обобщена" за всяко изпълнение план.Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Output производителност". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и симулатор на ефективността на работата изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Поведение | Съобщението Курсове |  | Десетичен | Фалшив | Броят на съобщенията за единица време през компонентите в архитектурата. Това е сумата на входящите и изходящите съобщения на всички компоненти.
Поведение | Пропускателна способност |  | Десетичен | Фалшив | Броят на съобщенията за единица време през връзките в архитектурата. Това е сумата от всички пропусквателни непреките линии "и това действителната стойност, може да се прави сравнение с очакваните / теоретичните стойности (т.е. честота) за да се заключи, насищане на системата.
Поведение | Bandwidth |  | Десетичен | Фалшив | Общата честотната лента. Сума от ленти връзка архитектурата му.
Поведение | Усвояване | % | Десетичен | Фалшив | Усвояването на всички компоненти. Може ли да бъде по-голяма от 100%, тъй като е само сумата от всички компоненти начина на използване на архитектурата му.
Поведение | Отговор (Min / Ave / Max) |  | Десетичен | Фалшив | Минималният / средното / максимална латентност. Сума от всички наблюдавани латентността за връзки архитектурата си от източник, за да потъне (и обратно до източника, ако двупосочен).


Симулиране Надеждност и достъпност

Navigation: Симулиране си архитектура> Тренажори>

Симулиране Надеждност и достъпност

Изпратете коментари по тази тема.

Заден план

The Надеждност Оценителят изчислява надеждността на архитектурата с помощта на входните елементи и връзки.

За компоненти и директни връзки, надеждност се базира Mean Time Между Неспазването (MTBF). Единствените показатели, необходими за изчисляване на надеждността на архитектурни елементи са:

· The MTBFстойност (в години);

· The Средното време за ремонт (MTTR)неизправност (в години); и

· Определеният срок за тестване Надеждност свърши.

Формулата, използвана при изчисляване на надеждността се дава като:

Надеждност = -e (-y × възраст)
Когато у = 1 ÷ MTBF

Наличието на компоненти и връзки се базира на MTBF и MTTR. Имайте предвид, че наличността, за разлика от надеждност, не се влияе от периода от време, за който в момента се тества.

Наличност = MTBF / (MTBF + MTTR)

Докато методи, които трансформират Надеждност блокови диаграми(с помощта на проста серия и паралелни структури) даде най-точните резултати, тези методи стават силно Импрактична, когато ние се опитваме да се изчисли на надеждността за мисии в рамките на огромни мрежи от хиляди елементи. Освен това, тези трансформационни подходи разграждат в продължение на много общи структури, като например мрежови "дупки".

The Монте Карлометод позволява надеждността и достъпността на система за произволна големина и сложност да бъде изчислена. Методът на Монте Карло симулира много сценарии и еили всеки сценарий случайна държава, на разположение или Няма, Се определя на всеки физически елемент. Вероятността за даден елемент е на разположение в състояние се базира на надеждност / наличност на компонента.

Например, компонент с наличността 90% може да се очаква да бъде на разположение в приблизително 90% от сценарии. Надеждност и годност за непряка връзка може да бъде оценена като делът на случаен scenarios-, за които съществува пътя на елементи в достъпно държавно от източника до местоназначението.

Забележка

Тъй като изчисляването на местно надеждност и наличност се основава на различни параметри и различни формули (и по този начин води до различни стойности), е необходимо да се определя всеки елемент двамачленки, по един за свободни стаи и един за надеждност. Изчисляването на наличността използва състоянието за наличност във всеки сценарий, има предвид, че изчисляването на надеждност използва държавата на надеждност при всеки сценарий.

Оценител на надеждност използва техниката за симулация Монте Карло, за да работят на надеждността на дадена архитектура. Архитектурата е преминал през хиляди отделни симулации и резултатите таблични да извлекат мярка надеждност. Както бе споменато по-горе, Монте Карло е най-бързият техника за симулиране на по-големи мрежи и ще работи с всяка сложна (т.е. око) структура.

Оценителят извежда четири стойности:

1. Мисия Надеждноств продължение на няколко години;

2. Наличност от архитектура;

3. Надеждност от местно компонентв продължение на няколко години; и

4. Наличност от местно компонент.

Оценителят работи, за вероятността от на компонент или работеща връзка (т.е. Не че не) и времето, необходимо за ремонт.

Как стандарти с MTBFs и / или MTTRs се третират

Ако даден елемент (компонент или връзка) има стандарти с целеви MTBF и / или MTTR стойности, тези стойности също са използвани при изчисляването на местната надеждността и наличността на елемент като връзка серии.

Например, ако компонент A, С възложените стандарти B, C, и Dвсеки има MTBF и MTTR стойност, Local Надеждност = R(A)× R(B) × R(C) × R(D), където R = Изчислява надеждност (като се използва формулата) на компонента / стандарти и Местен Ползаспособност = A(A)× A(B) × A(C) × A(D), където A = Изчислява ползаспособност (като се използва формулата) на компонента / стандарти. Това е, ако елемент има три стандарта всеки с MTBF и MTTR стойностsИ също MTBF и MTTR стойностsза свойствата на елемента, местната надеждността и avilability е даден като поредица стойност на всеки от стандартите и самия елемент.

Като друг пример, ако компонент Aима определени стандарти B, C, и Dно само стандартна Bима както MTBF и стойност MTTR, а стандартната Cима само стойност на MTBF и стандартна Dима само една стойност MTTR, Local Надеждност = R (А)× R (B)× R (C), където R= Изчислява надеждност (с помощта на формулата) на компоненти / стандарти и местните Наличност = А (А)× А (B)× А (С), където A= Изчислява достъпност (с помощта на формулата) на компоненти / стандарти, но при изчисляването A (C), защото стандартът има само една стойност MTBF него 'търсения'за стойността на съвпадение MTTR (ите) и ще добави всички MTTR стойности установи, че дон'тон от своя страна имат MTBF стойност съвпадение, така че в този случай тя ще се използва стойността на стандартната MTTR D, Ако имаше друг стандарт, да речем E, Само с една стойност MTTR както тогава А (С)ще използва MTBF от Cс MTTR на D и Eсумират. Ако друг стандарт, да речем F, Имаше само една стойност MTBF тогава А (F)също така ще използва MTTR на D и Eсумират.

Изчисляване Mission Надеждност

Докато изчисляване местно надеждност е въпрос на използване на една проста формула, изчисляването на непреките връзки (командировъчни) не е толкова лесно, особено след като имаме сложни и големи мрежи от преплетени пътеки (връзки) и компоненти.

Прием на цялата мрежа се вземат предвид

Тъй като косвени връзки не представляват физическа връзка, ние трябва да разберете как източника може да стигнем до местоназначението си компонент. А това означава да се разглеждат цялата мрежа и всички различни начини (и пътеките) нашият източник компонент може да предприеме, за да достигне целевия компонент (мивка).

Забележка

Докато съществува поне един пъленпът от източника до местоназначението, мисията ще бъде успешнои косвена връзка е посочен като Closed връзка.

Разбирането на Link Матрицата

За да се знае кои компоненти / директни връзки са свързани с това, което ние трябва артефакт бързо да провери дали два блока са свързани в определена посока. Това е функция на матрицата на връзка. Накратко, матрицата на линк е двуизмерно масив от булеви променливи, които се посочва, дали даден компонент може да достигне до друг компонент директно. Размерът им е равна на квадрата на общия брой на компонентите в мрежата.

A Simple Надеждност Block Diagram (RBD)

Свързани Link Matrix за Надеждност Block Diagram (RBD)

Тъй като не всички връзки са двупосочни (става и в двете посоки), важно е да знаете как да се чете матрицата на линк правилно. В надеждност оценител, първият аргумент е източник и на втория аргумент е дестинация (мивка).

Ето защо, ако матричен линк (A, B) = True то това означава, че A могат да получат до точка Б директно (еднопосочно). B може да стигнем до А ако само ако връзката матрица (B, A) = True. Ако това е вярно, това означава, двупосочен връзка.

В дадения пример горе:

· Източник 1 може да достигне до местоназначението 0 (Източник 1 и 0 Дестинация дава резултат от True); и

· Източник 0 може да достигне до местоназначението 1 (Източник 0 и Destination 1 дава резултат от True), като връзката между 0 и 1 е двупосочна.

· Източник 2 не може да достигне местоназначението 1 (Source 2 и Destination 1 дава резултат на False), дори когато източни- 1 може да достигне до местоназначението 2 (Източник 1 и Destination 2 дава резултат от True). Това означава, че връзката между 1 и 2 е еднопосочно.

Разбирането на Надеждност блок схема

Диаграмата на надеждност блок (RBD) капсулира структурата на целия обект, модел по отношение на блокове и връзки. Всеки блок представлява елемент, който има възможност за провал или успех в съответствие с връзки / пътеки, които ги свързват. И двата компонента и връзки могат да се превърнат в "блок" в басейновата дирекция.

Пример RBD Блокове и връзки

Цифрата горе представлява пример RBD. Прекъснатата червената линия представлява една мисия 4 към 1. Забележка как има само два възможни пътища за мисията 4-1.

Разглеждане на маршрута 4-3 от 0 до 1, и по маршрута 4 до 7 към 1. пунктирани блокове 2, 5и 6 представляват блокове, които не влияят на провал / не-провала на мисията 4 към 1. Те ​​не се считат и се игнорират. Това е важно, тъй като за повечето мисии ще има голям брой съкратени блокове, които няма да се отрази успех определена мисия. Това е по-очевидно в по-големи мрежи, при което броят на съкратените блокове ще направи резултатите от симулацията неточна.

За да се ускори симулация време, и да се осигури по-точни резултати, е необходимо да се абстрахират от цялата басейновата дирекция и използвайте само елементите, които влияят върху успеха на мисията му.

Забележка

Един единствен път / път не може да мине през всеки компонент два пъти.

На този етап можем да създадем една матрица връзка и извършване на Монте Карло симулация.

Изчисляване Architecture Наличност

Наличието на архитектурата е вероятността, че всички косвени връзки ще бъдат на разположение във всяка точка във времето. Наличието на всяка непряка връзка се определя по време на всяка итерация на симулацията Монте Карло, обаче тези косвени връзки (обикновено) разчитат на същия набор от физически елементи. Ето защо, просто Обобщаването на тези индивидуални наличности би "двойно броене" тези ООН-наличности, като песимистичен общата наличност архитектура. Алтернативно, общата наличност архитектура се изчислява, като погледнете на всяка итерация и видя дали елементите, включени в непреки връзки на интерес са на разположение. И след това се сумират тези резултати в края на симулацията.

Работещи симулатора Надеждност

За да се симулира си архитектура по отношение на надеждност

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Изберете Анализ| Надеждност.

3. Изберете Архитектуражелаете да се оцени от падащото меню.

Забележка

По подразбиране, ABACUS автоматично ще избере първата архитектура, за които е необходимо повторно симулация поради появата на базовия имот или структурни промени.Това Отбелязването е показан в Червен на Лента с инструменти Simulation .

4. Изберете Елементи и Connectionsжелаете да се оцени от прозорец за избор на стандартен елемент използване на "Показване на директни връзки" и "Покажи процесите Connections" радио-бутон филтрите в долния ляв ъгъл на диалоговия прозорец, за да се подпомогне с вас избор.

Допълнителен Checkbox към прозорец за избор на стандартен елемент

· SАве Преобразен Model ще запишете копие на RBD трансформирана версия на проекта в същата папка, като текущия проект и прилага "_transformed" до името на проекта.Това трансформира проект може да се използва за диагностика в подробности симулация на надеждност, предприета от ABACUS.

Допълнителна радио-Копчета към прозорец за избор на стандартен елемент

· Покажи Директни връзки автоматично установява връзката се филтър Имоти за имот Type = Поведение, Наименование = Abstraction и Value = пряка.Тази опция е избрана по подразбиране и подпомага избора на "преки" връзки, както са описани по-горе и по-долу.

· Покажи Процеси Connections автоматично установява връзката се филтър Имоти за имот Type = Поведение, Име = запознанството и Value = процеси.Този вариант подпомага избора на "директни" връзки, както е описано по-горе и по-долу.

5. Кликнете Следващия.

6. Избери Мисиит.е. Connections които желаете да включите в симулация.

7. Задайте Run Time Scale Factorслайдер.

Забележка

По-високи стойности ще доведат до по-статистически последователни резултати, но отнемат повече време, за да се изчисли.

Чек боксове

· Шоу Затворени Connections ще автоматично филтриране на наличните връзки само за включване на тези, които имат най-малко един пълен физически път от източника до компонента на дестинация по селекцията RBD е описано по-горе.

· Покажи Косвени Connections автоматично установява връзката се филтър Имоти за имот Type = Поведение, Наименование = Abstraction и Value = непряка.Тази опция е избрана по подразбиране и подпомага избора на "косвени" или Мисия връзки, както е описано по-горе и по-долу.

Копчета

· Всичкиизбира цялата връзки.

· Обръщанеdeselects всички текущо избрания връзки и избира всички тези, които не бяха избрани.

· Никойdeselects всички връзки.

Други възможности

· Run Time Scale Factor Контрол на времето за симулация и точността, с по-висока стойности добивINGпо статистически последователни резултати, но като по-дълго време, за да тичам.

Забележка

Когато ABACUS изчислява броя на повторения, за да се симулира това ще определи най-надежден елемент, който не е напълно надеждна и след това симулира за Run Time Scale Factor пъти 1 над липсата на този елемент плюс 1 итерация. Или (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Това е, за да се уверите, че този елемент все още не най-малко веднъж в симулация. Например Ако най-надежден елемент, който не е напълно надеждна има MTBF от 10,000 часа и MTTR от 8 часа след симулацията ще се (10 000 + 8) / 8 = 1251 пъти фактор Run време Scale + 1 повторения.

· Години да симулира Ahead определя броя на годините, за Mission надеждност, за да се изчисли за.

· Nумбра на Threadsдеtermines броят на теми обработка да се използва за симулация Монте Карло.Тази опция по подразбиране ще съответства на броя на наличните процесори / сърцевини (включително хипер-резби ядра), за да се намали общото време за симулация.

8. Кликнете завършеки вие ще получите Вниманиедиалогов прозорец.

9. По желание опознаването на предупрежденията, като щракнете Детайли >>.

10. Кликнете продължи.

Забележка

В този момент, ABACUS ще извърши Монте Карлосимулация на архитектурата и след кратко време (с напредъка барове за обратна връзка) ще се появи на изчисление пълна диалоговия.

11. Кликнете Добреда потвърдя симулацията.

Бакшиш

За курсове за обучение и допълнителна помощ за Надеждност Simulation се обърнете към Avolution Общността .

Компоненти и Connection Properties

В следващата таблица са компонента и"пряка"свързващи свойства, необходими за оценка на надеждността. Тези свойства ще бъдат показани в прозореца Properties с икона на входния селектор на имот ред ( [image] ) С подсказка "Input Надеждност". A промяна в някое от тези "вход" свойства и различни структурни промени в хранилището ще доведе до симулатора Надеждност изискващи повторна симулация, както е посочено в Червен на Лента с инструменти Simulation .

Тип | Име | Стойност по подразбиране | Мерна единица | Тип на данните | Длъжен | Описание
Надеждност | MTBF | ∞ | години, седмици, дни или часове | Десетичен | Вярно | Средното време преди повреда на елемента. Забележка: Стойностите могат да бъдат изразени в единици от години, седмици, дни или часове и се преобразуват следната концепция '24 / 7 "свободни, както следва; - 1 година = 52 седмици или 365 дни или 8760 часа - 1 седмица = 7 дни или 168 часа - 1 ден = 24 часа
Надеждност | MTTR | 0 | години, седмици, дни или часове | Десетичен | Вярно | Средното време за ремонт на елемента. Забележка: Стойностите могат да бъдат изразени в единици от години, седмици, дни или часове и се преобразуват следната концепция '24 / 7 "свободни, както следва; - 1 година = 52 седмици или 365 дни или 8760 часа - 1 седмица = 7 дни или 168 часа - 1 ден = 24 часа

В следващата таблица са компонента и"пряка" свързващи свойства изход от надеждност оценител. Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Надеждност Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и на симулатора Надеждност изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Надеждност | Надеждност - х години |  | Десетичен | Фалшив | Вероятността, че елементът няма да успеят в рамките на следващите х години. Това е стойност между 0 и 1.
Надеждност | Ненадеждност - х години |  | Десетичен | Фалшив | Вероятността, че елементът ще се провали в рамките на следващите х години. Това е стойност между 0 и 1.
Надеждност | Наличност | % | Десетичен | Фалшив | Изчислената наличието на компонента или връзката. Това е на стойност между 0% и 100%.
Надеждност | Невъзможност | % | Десетичен | Фалшив | Изчислената липсата на компонента или връзката. Това е на стойност между 0% и 100%.

Таблицата по-долу изброява 'непряк'свързващи свойства изход от надеждност оценител. Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Надеждност Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и на симулатора Надеждност изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Надеждност | Мисия Надеждност - х години |  | Десетичен | Фалшив | Вероятността, че непряка връзка няма да успеят в рамките на следващите х години. Това е стойност между 0 и 1.
Надеждност | Мисия Ненадеждност - х години |  | Десетичен | Фалшив | Вероятността, че непряка връзка ще се провали в рамките на следващите х години. Това е стойност между 0 и 1.
Надеждност | Наличност | % | Десетичен | Фалшив | Изчислената наличието на непряка връзка. Това е на стойност между 0% и 100%.
Надеждност | Невъзможност | % | Десетичен | Фалшив | Изчислената липсата на непряка връзка. Това е на стойност между 0% и 100%.

Архитектура Имоти

В следващата таблица са изход архитектура имоти от надеждност оценител. Тези свойства ще бъдат показани в прозореца Properties с икона селектор изход имот ред ( [image] ) С подсказка "Надеждност Output". Стрелката върху иконата ще подчертае Червен ( [image] ), Когато тези имоти са остарели поради базовия имот или структурна промяна на регистъра и на симулатора Надеждност изисква повторна симулация според Червен подчертавайки относно Лента с инструменти Simulation .

Тип | Име | Мерна единица | Тип на данните | Длъжен | Описание
Надеждност | Наличност | % | Десетичен | Фалшив | Наличието на всички косвени връзки, които са били включени в оценката. Това означава, че вероятността всичкикосвени връзки ще бъдат на разположение в даден момент от времето. Това е на стойност между 0% и 100%. Забележка: Това не е размножаването на отделните наличности връзка, тъй като това би било "двойно отчитане" на ООН наличието на съответните компоненти.
Надеждност | Невъзможност | % | Десетичен | Фалшив | Липсата на непреки връзки, които са били включени в оценката. Това означава, че вероятността поне единнепряка връзка няма да бъде достъпна в даден момент от времето. Това е на стойност между 0% и 100%. Забележка: Това не е размножаването на отделните unavailabilities връзка, тъй като това би било "двойно отчитане" на ООН наличието на съответните компоненти.
Надеждност | Мисия Надеждност - х години |  | Десетичен | Фалшив | Вероятността, че всички от косвени връзки, които са били включени в оценката няма да се провали в рамките на следващия xгодини. Това е на стойност между 0 и 1. Забележка: Това не е размножаването на отделните reliabilities връзка, тъй като това би било "двойно отчитане" на ООН наличието на съответните компоненти.
Надеждност | Мисия Ненадеждност - х години |  | Десетичен | Фалшив | Вероятността, че най-малко един от косвени връзки, които са включени в оценката ще се провали в рамките на следващия xгодини. Това е на стойност между 0 и 1. Забележка: Това не е размножаването на отделните unreliabilities връзка, тъй като това би било "двойно отчитане" на ООН наличието на съответните компоненти.


Симулиране си архитектура

Navigation: Симулиране си архитектура>

Симулиране си архитектура

Изпратете коментари по тази тема.

След като сте населена и се анализира вашата архитектура, готови ли сте да използвате ABACUS да се определи, ако вашата архитектура ще отговарят на вашите нужди количествени. Това изисква симулация, За да се симулира си архитектура, първо трябва да вземе решение за вида на информацията, която искате да откриете. Тези видове информация, често се споменават като KPI е, или ключови показатели за изпълнението. Например, искате ли да се анализира ефективността, evolvability, и откритостта, или не искате да се съберат показатели като общата цена на притежание. Цялата тази информация може да се открие по някакъв начин. След като имате тази информация, вие ще бъдете в състояние да анализира вашата архитектура в различни графични формати (или анализира новите стойности директно).

Има три възможности за симулиране на вашата архитектура:

· Прости метрики ;

· Предварително вградени симулатори ; или

· Scripting .

Прости Metrics

Всеки компонент във вашата архитектура има свойства - много от които могат да бъдат персонализирани за кандидатстването на ABACUS. Тези свойства представляват различни характеристики на компонентите. В някои случаи, просто събиране на тези показатели (KPI е да се изгради) може да бъде достатъчно, за да ви кажа, важна информация за вашата архитектура. Например, KLOCS или Хиляди реда код, са били широко използвани като мярка за сложност. В други случаи може да искате да експортиране на данните и да го анализира с помощта на друг инструмент. В допълнение, може да искате да се съберат свойства след извършване на друг вид симулация.

Информацията може да бъде събрана чрез процеса на агрегация , Сумиране добавя определени подсектори имоти на обща което е отразено в родителското компонент. Сумиране работи само на компоненти, които съдържат под-компоненти.

Предварително вградени Симулатори

Има пет предварително изграден симулатори, които могат да се използват с ABACUS. Тези са:

· Производителност;

· Модулност;

· Обща цена на притежание (TCO);

· Откритостта; и

· Надеждност.

Забележка

ABACUS автоматично ще подчертае кои от тези симулатори трябва да бъдат повторно преминава през Червен подчертавайки относно Лента с инструменти Simulation .

Scripting

Scripting осигурява гъвкавост, за да се симулира си архитектура в потребителски начини. От писане на скриптове можете да извършвате симулации отвъд ток в построена капацитет от ABACUS. Целият обект ABACUS Моделът се предлага с двигател скриптове, така че можете да се ограничават само от способността ви да пишете скриптове!

Visual Basic скрипт е скриптов език подкрепена от ABACUS, тъй като тя осигурява важни функции за програмиране в разумно прост формат.

Вижте също

Експорт си архитектура | Обобщените имоти | Писане на скриптове


Развиващите си архитектура

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Развиващите си архитектура

Изпратете коментари по тази тема.

Архитектури могат да бъдат категорично еволюирали и йерархия архитектури създадени. По този начин чрез развиващата си архитектура в ABACUS, могат да бъдат създадени редица съвременни архитектурни решения, в сравнение и baselined. Цели (или метрика) могат да бъдат определени за всеки брой на архитектурни имоти за съществуващите архитектури.

Един прост начин да се разгледа развитието на архитектурата е да го свържа с концепцията за потомък архитектура, Когато една архитектура, е еволюирал, а копиена архитектурата майка е създаден. Това копие може да се каже, че е пряка потомъкна оригинала родителархитектура.

Забележка

В този онлайн помощна документация и ABACUS самия комплект инструменти, терминът еволюиратпо-често се използва от срока потомъкМоля, имайте предвид, че и двете се отнасят до същата функционалност.

За да се развива съществуваща архитектура

1. Уверете се, че имате ABACUS файлотворена и Window Explorerпоказва.

2. Изберете съответната архитектура, която искате да се развива от изследовател дървото.

3. Кликнете с десния бутонна архитектурата и Select Evolveот менюто.

Развиване на Chosen Архитектура

4. В еволюира архитектура ще се появи по-долу избрания архитектура.

Evolved Architecture

Забележка

В еволюира архитектурата може да се преименува с десния бутон върху архитектурата и подбора Преименувам.Освен това, всички схеми и каталози в еволюира архитектура ще бъде автоматично се задават в "раз" спрямо основния архитектура че той е еволюирал от.

Поставяне на цели за вашия еволюира архитектура

Поставяне на цели за вашия еволюира архитектура позволява да се създаде критерии за оценка на развитието на вашите архитектури. Цели се определят от вида на собственост и имената на тези имоти, съществуващи във вашия еволюира архитектура. Цели също могат да бъдат определени ръчно и се добавят към вас архитектура. Следвайте стъпките по-долу, за да си поставям цели.

Поставяне на цели от съществуващите свойства за вашия еволюира архитектура

1. Уверете се, че имате ABACUS файлотворена и Window Explorerпоказва.

2. Изберете Инструменти | Поставяне на целиОт лентата на главното меню.

3. The Гол Inputпрозорец ще покаже.

Гол Input Window

4. Кликнете върху Съществуващбутон.

5. The Изберете A Propertyпрозорец ще покаже.

6. Изберете един имот, който искате да зададете като цел за вашия еволюира архитектура и кликнете върху Добребутон.

7. Избраният Целта сега ще се появи в Гол Inputпрозорец.

8. Изберете целта и кликнете на редактирамбутон.

9. The Edit Goalпрозорец ще покаже.

Забележка

Този прозорец ви позволява да промените името на собственост и вида, че целта ще се отрази, както и най-лошото и най-доброто на стойността (или минимум / максимални стойности) за този имот. Тези стойности са намерени чрез сравняване на всички архитектури и намирането на най-малката и най-голямата стойност на всеки за тази специфична собственост. Тези стойности могат да се определят ръчно. Например, ако ви се налага да си постави за цел за имота име Отговор (Ave)и от типа Поведение, Най-лошото и най-добрия си стойност може да се отрази на скоростта на операциите, необходими за оптимална работа (най-висока стойност), а скоростта на сделката е необходимо само за основни приложения, за да бъдат обработени (лошия стойност).

10. След като съответните стойности са били определени, изберете Добре.

Поставяне на цели от нови свойства за вашия еволюира архитектура

1. Уверете се, че имате ABACUS файлотворена и Window Explorerпоказва.

2. Изберете Инструменти | Поставяне на целиОт лентата на главното меню.

3. The Гол Inputпрозорец ще покаже.

4. Кликнете върху Новбутон.

5. The New Goalпрозорец ще покаже.

Забележка

Този прозорец ви позволява да определите името на собственост и вида, че целта ще се отрази, както и най-лошото и най-добрата стойност (или минимални / максимални стойности) за този имот. Например, ако ви се налага да си постави за цел на имот име Отговор (Ave)и от типа Поведение, Най-лошото и най-добрия си стойност може да се отрази на скоростта на операциите, необходими за оптимална работа (най-висока стойност), а скоростта на сделката е необходимо само за основни приложения, за да бъдат обработени (лошия стойност).

6. След като съответните стойности са били определени, изберете Добре.

7. Диалогов да Добави към всички архитектурище се покаже като по-долу:

8. Кликнете върху Дада добавите целта като свойство на всички съответни архитектури. Това гарантира, че новодефинираната гол и неговите свойства ще бъдат добавени към всички архитектури във файла. Ако не желаете да включва собствеността на архитектури, можете да кликнете върху Не.

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Преглед на парцел звезда на вашите еволюирали архитектури | Преглед на диаграмата на разсейване на вашите еволюирали архитектури


Разширяване и свиване на дървото

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Разширяване и свиване на дървото

Изпратете коментари по тази тема.

Когато един възел в дървото съдържа под-компоненти и колекции, то ще има малък [image] или [image] влезте в своя ляв. Можете да щракнете върху [image] за разширяване на възел и да видите неговите под-компоненти и връзки. По същия начин, можете да щракнете върху [image] до колапс на възел, за да се скрие под-компоненти и връзките (с цел да се направи повече място или направете дървото лесно да се разбере).

Освен това, можете да разширите целия възел, в който случай всички негови под-възли също ще бъде разширена, а техните под-възли, и тяхно ... и т.н. Също така, можете да се срине целия възел - затваряне на няколко нива наведнъж ,

Освен това, има опции за разширяване само архитектури, елементи (т.е. компонентите и връзките), компонентите или връзки.

За да се разшири или да се срине целия възел (и неговите под-възли и т.н.)

1. Кликнете с десния бутонна възел.

2. Изберете Разширяване | Всички илиКолапс.

Да се ​​разшири всички архитектура (и)

1. Кликнете с десния бутонна архитектури или архитектура.

2. Изберете Разширяване | Всички.

Да се ​​разшири елементи

1. Кликнете с десния бутонна архитектури или архитектура.

2. Изберете Разширяване | Елементи.

Да се ​​разшири компоненти

1. Кликнете с десния бутонза компоненти, компонент или под-компонент.

2. Изберете Разширяване | Компоненти | Всички.

Да се ​​разшири връзки

1. Кликнете с десния бутонна Connections, връзка или под-връзка.

2. Изберете Разширяване | Connections | Всички.


Експорт си Architecture

Навигация: Представяне на информация за вашата архитектура>

Експорт си Architecture

Изпратете коментари по тази тема.

ABACUS ви позволява да сеекспортирате архитектура да .mdb (Microsoft Access), MS SQL Server, .abacus (ABACUS файл), и .xls (Microsoft Excel) формат. Можете също така да експортирате диаграмаите към PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF и BMP формат и отчетите си до .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) и .rtf (Rich Text Format) формати. Това ви позволява да се анализира и да видите архитектура и неговите данни по никакъв начин искате.

За да експортирате архитектура, за да .mdb (Microsoft Access)

1. Уверете се, че имате ABACUS файлотворена.

2. Кликнете върху Пиламеню.

3. Изберете Износ, и тогава За да MDB.

4. Обърнете внимание на предупреждението и кликнете Добре.

5. Въведете име за файла.

6. Щракнете върху SaveБътън.

Забележка

Форматът за износ на базата данни е .mdb специфични за ABACUS и всички промени на схеми ще доведе до невъзможност за повторен внос. Моля виж Запълването с MS Access за описание на схемата на MS Access.

За да експортирате архитектура MS SQL Server

1. Уверете се, че имате ABACUS файлотворена.

2. Кликнете върху Пиламеню.

3. Изберете Износ, и тогава За MS SQL Server.

4. В диалоговия прозорец, който се появява върху раздела Export Blank MDB ...бутон и импорт на този във вашия MS SQL Server база данни на сървъра.

5. Попълнете информацията от базата данни и връзка низ.

6. Щракнете върху ИзносБътън.

Забележка

Форматът на износа на MS SQL Serverбаза данни е специфични за ABACUS и всички промени на схеми ще доведе до невъзможност за повторен внос. Моля виж Запълването с MS Access за описание на схемата на базата данни.

За да експортирате архитектура, за да .xls (файл Excel)

1. Уверете се, че имате ABACUS отворен файл , Една Показва изследовател И на архитектура добавя .

2. Уверете се, че имате Import / Export Configuration Excel File определени.

3. Кликнете с десния бутонна архитектура в своя модел или някоя част от Елементивъзел (в рамките на дадена архитектура), който искате да експортирате в конфигурационния файл на Excel.

4. Изберете Износ | Да се Excel ... от менюто.

5. The Изберете Import / Export Configuration Excel File да използвамеЩе се появи прозорец.

6. Изберете съответния конфигурационен файл за вашия архитектурен модел и щракнете върху Отворенобутон.

7. Ако не става автоматично, така, карта компонентите най-високо ниво в сегашната си архитектура на Id Set(както е дефинирано предварително) и кликнете върху Export ....

Пример Top-Level Component Mapping

8. Изберете място и име на файла Excel и натиснете Saveбутон.

За да експортирате архитектура, за да .abacus (ABACUS файл)

1. Уверете се, че имате ABACUS файлотворена.

2. Кликнете с десния бутонпо Архитектура възел, всяка архитектура в своя модел или част от дървото компоненти.

3. Изберете Износ | Да се Файл ...от менюто.

4. Изберете място и името на файла и натиснете Saveбутон.

Забележка

Можете да импортирате файл ABACUS обратно в ABACUS от следните стъпки 12по-горе и след това изберете Import | От Файл ..., След като сте избрали файла, който искате да импортирате, ще бъдете попитани как бихте искали да внасят стандартите и видовете. Можете да импортирате стандарти и типове като нови или слети стандарти и типове. Настройката по подразбиране е за стандарти и видове, за да се слеят със съществуващите стандарти и типове, ако те вече съществуват във вашия проект.

За да експортирате архитектура, за да .xml

1. Уверете се, че имате ABACUS файлотворена.

2. Кликнете с десния бутонна Architecture възел, всяка архитектура в своя модел или някоя част от Компонент дървото.

3. Изберете Износ | Да се XML ...от менюто. Също така, можете да кликнете върху менюто Пила| Износ| Да се XML ...

4. Изберете място и името на файла и натиснете Saveбутон.

Забележка

Можете да импортирате XML файл обратно в ABACUS от следните стъпки 12по-горе и след това изберете Import | От XML ..., След като сте избрали XML файл, който искате да импортирате, ще бъдете попитани как бихте искали да внасят стандартите и видовете. Можете да импортирате стандарти и типове като нови или слети стандарти и типове. Настройката по подразбиране е за стандарти и видове, за да се слеят със съществуващите стандарти и типове, ако те вече съществуват във вашия проект.

За да експортирате вашата схема за PNG, JPG, SVG, TIFF, GIF или BMP

1. Уверете се, че имате ABACUS файлотворена.

2. Отвори диаграмабихте искали да изнасят.

3. Кликнете върху Export Diagramбутона на Диаграма лента с инструменти.

4. The Export ДиаграмаЩе се появи прозорец.

5. Изберете Пасабутон, за да спаси визуализацията на желаното място.

6. Изберете Запиши като типпадащото меню, за да изберете типа на файла.

7. Щракнете върху Saveбутон.

За да експортирате вашия доклад .pdf (Adobe Acrobat), .xls (Microsoft Excel) или.doc (Microsoft Word)

1. Уверете се, че имате ABACUS файлотворена.

2. Създавам доклад бихте искали да изнасят.

3. Кликнете върху Износбутон на лентата с инструменти за отчети.

4. Изберете Excel, PDF или Wordот падащото меню.

5. Изчакайте няколко минути, докато износът на отчета.

6. Изберете място и името на файла и натиснете Saveбутон.


Намиране и заместване на стоки във Вашата архитектура

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Намиране и заместване на стоки във Вашата архитектура

Изпратете коментари по тази тема.

Можете да намерите и заместване специфичен компонент, връзка, вид, стандарт или имущество чрез използване на ABACUS "Намери и заместване съоръжението.

За да намерите обект

1. Кликнете на възел от дървото, което искате да търсите в срок.

2. Изберете редактирам| Намирамили натиснете Ctrl + F.

3. Въведете текст за елементада се намери в полето "Намерихте".

4. Кликнете Намерете Следваща.

Да се сменете артикул

1. Кликнете на възел от дървото, което искате да търсите в срок.

2. Изберете редактирам| Заменетеили натиснете Ctrl + H.

3. Въведете текст заелементада се намери в "разберете какво" поле и текстът да го замени с в "Замести с" поле (или нищо, ако полето се оставя празно).

4. Кликнете Намерете Следващада се намери на първо място от текста на "Намерихте" и кликнете Заменете да замени този случай с текст "Замяна с" или щракнете Замяна на всичкида замени всички инстанции.

Вие имате възможност да:

o Съвпадение своя случай,

o Съвпадение цялата дума,

o Търсене от началото на проекта,

o Игнорирайте архитектури - това е архитектурата самите възли. Всички възли под възли архитектура като компонентите и връзките все още ще се търсят,

o Пренебрегват компоненти - това е компонент се възли,

o Игнорирайте връзки - това е връзката самите възли,

o Игнорирайте стандарти - това е всички архитектурни, компоненти и свързване стандартни възли ще бъдат игнорирани,

o Пренебрегват видове - че е тип се възли. Никакви ограничения възли под на лимфните тип все още ще се търсят,

o Игнориране на шаблони и съдържание - това е шаблона самите възли, както и всеки шаблон за компоненти и възли за свързване под тях,

o Игнориране на имоти - това е всички типове имоти, имената, ценностите и звена на всички елементи на модела ще бъдат игнорирани,

o Игнорирайте описания - това е описанието на всички елементи на модела ще бъдат игнорирани.

Вижте също

Как се архитектура, представена в ABACUS


Помощ на други езици

Navigation: Въведение в ABACUS>

Помощ на други езици

Изпратете коментари по тази тема.

ABACUS помощ е на разположение в различни други езици / Преводи и може да бъде изтеглен от линка по-долу.

Да се замени сегашната помощ ABACUS файлс преведените помощен файл, моля, следвайте тези стъпки:

1. Спестете помощния файл от съответния линка по-долу.

2. Преименуване на помощния файл към ABACUS.chm.

3. Отворете файла, като го двукратно щракване и ако "Open File - Security Warning" и след това се появява диалогов прозорец махнете "Винаги питай, преди да отворите файла" опцията и натиснете Open.

4. Затворете файла.

5. Заменете файла ABACUS.chm в папката програмните файлове на ABACUS, обикновено "C: \ Program Files \ Avolution \ ABACUS" или "C: \ Program Files(x86)\ Avolution \ ABACUS".

Забележка

Context зависима помощ ще продължи да работи с преведени помощните файлове.

ABACUS помощни файлове на други езици:

· Арабски / العربية .

· български / български .

· Chinese (Simplified) / 中文 (简体) .

· Чешки / Česká .

· Датски / Dansk .

· Естонски / Eesti .

· Фински / Suomen .

· Френски / Français .

· Немски / Deutsch .

· Унгарски / Маджарски .

· Исландски / Исландски .

· Индонезийски / Индонезия .

· Италиански / Italiano .

· Японски / 日本 の .

· Латвийски / Latvijas .

· Малайзийски / Малайзия .

· Малтийски / Малц i .

· Norweigen / Norweigen .

· Полски / Po lska .

· Португалски / Português .

· Руски / русский .

· Словашки / Словенски .

· Словенски / Slovenski .

· Испански / Españoles .

· Шведски / Svenska .

· Турски / Türk .

· Уелски / Cymraeg .

Вижте също

Какво означава ABACUS направя?


Как се архитектура, представена в ABACUS?

Navigation: Въведение в ABACUS>

Как се архитектура, представена в ABACUS?

Изпратете коментари по тази тема.

В ABACUS, можете моделира вашата архитектура. За простота, ние наричаме това архитектурен модел на архитектура.

Диаграмата по-долу показва как една типична архитектура 5елементи (в йерархия) свързан с 2 връзки ще бъдат представени в ABACUS.

Как проста архитектура е представена в ABACUS

Можете да имате неограничен брой архитектури в един ABACUS файл.

Първата структура на дървото

Обикновено ще се създаде нова архитектура, когато искате да се оцени промяната. Например, бихте моделира съществуващата си архитектура първо - това ще бъде първият архитектура в дървото. Можете да го наречем "Current".

Вторият

Когато искате да моделирате и оцени промяна в съществуващия си архитектура (например, нарастване на изискванията), че ще се създаде нова архитектура. Най-лесният начин да направите това е да се създаде копие на "Current" и го преименувайте "Evolution 1 Опит 1". Това ще бъде втората архитектура в дървото. Ако оценките си от "Evolution 1 Опит 1" са успешни, можете да го преименувате на просто "Evolution 1".

Третият

Ако "Evolution 1 Опит 1" не отговаря на вашите изисквания, можете да създадете копие от него, го преименувайте на "Evolution 1 Опит 2", и опитайте отново. Това ще бъде третата архитектура в дървото.

Вижте също

Какво означава ABACUS направя? | Как го правиш (Преглед) | Какво е архитектура? | Работа с файлове ABACUS | Създаване или копиране на архитектурата


Как да използвате ABACUS (Преглед)

Navigation: Въведение в ABACUS>

Как да използвате ABACUS (Преглед)

Изпратете коментари по тази тема.

Тази тема предоставя основен преглед на задачите, свързани с използване на ABACUS.

Следната диаграма илюстрира процеса на архитектурата на базата анализ, който ABACUS предвижда развиващата текущ архитектура в нов или целева архитектура.

Процесът ABACUS

За да използвате ABACUS:

1. Одит - Преди да използвате ABACUS, трябва да събере цялата информация, която имате за архитектурата, както и неговите изисквания.

· Архитектура - Идентифициране на потенциални компоненти на архитектурата и как те си взаимодействат. Трябва да има само няколко компонента на най-високо ниво. Те се наричат ​​"основни компоненти". Дори и най-сложните архитектури трябва да имат по-малко от 10 основни компоненти. например Съществените елементи на архитектурата на застрахователна компания може да са политиките, разписки, искове, задължения и плащанията.

· Изисквания- Трябва да знаете какво се очаква от архитектурата, за да се определи дали е задоволителна. например Брой сделки за час.

· Къде го намери? - Тази информация може да дойде от изисквания спецификации, дизайн документи, интервюта със заинтересованите страни, разгърнато кода и т.н. По принцип всеки материал, който е на разположение предлага ABACUS информация за архитектурата.

2. Заселвам -Използвайте ABACUS да моделират си архитектура и да се уточнят изискванията на архитектурата ще бъдат сравнявани.

· Архитектура - В ABACUS да започнете с празен архитектура - просто трябва да населявамтова. Това означава въвеждане на цялата информация за архитектура сте събрали по-горе. Можете да попълните вашата архитектура ръчно (с помощта на десния бутон на мишката), или можете да го пренесат автоматично (от Microsoft Visio, Excel, Access и т.н.). Обикновено най-горното нива (по-абстрактни) на архитектурата ще бъде населените ръчно, и по-ниските нива (по-конкретни) ще бъдат населените автоматично.

· Изисквания - Както можете да добавите свои компоненти и връзки, вие определяте техните свойства. В повечето случаи, тези свойства ще бъдат изискванията на архитектурата. Например, ако вие ще имате 1250 MIPS възел / клъстер, трябва да добавите възел като компонент, след това добавете имота производителност, и определяне на стойността на 1250 MIPS.

3. Анализирайте - Използвайте ABACUS да елегантно анализира и визуализира сложната структура на вашата архитектура. Вие може да анализира архитектура в редица начини или от няколко гледни точки, включително диаграми, 3D и Explorer. Алтернативно може да искате да използвате някои по-специфични възгледи, както следва:

· Графика си архитектура - да получи изпълнение (време за реакция, трафик и т.н.), разходи (бар, баница и т.н.) или evolvability (способност пространство, компромис и т.н.) възгледи.

· Създайте нов доклад за вашата архитектура.

4. Симулирам - Използвайте ABACUS да симулира си архитектура на производителността, достъпността на разходите, откритост и т.н.

· За да направите това, изпълнете едно от симулатори. ABACUS оценява си архитектура срещу вашите изискваниячрез провеждане на симулация. Той чете и анализира текущото архитектура, тече симулации, и изчислява някои нови свойства. Тези свойства се запазват обратно към архитектурата. Новите свойства са данните, които се опитвате да се анализира, като например използване, време за реакция, трафик, наличност%, TCO т.н.

5. Инженер- Използвайте ABACUS да отговорим на различните "какво ако" сценарии и контролира развитието на вашата архитектура. Engineering е процес на повтаряне на Запълни - Анализират - Симулирацикъл.

· В този момент, виесъмВероятно разработен разбиране на настоящата структура и подчерта областите, които трябва да се развива. Доста често, обаче, ще трябва да повторите пренесат - Анализират - Симулира процес няколко пъти. Това най-вероятно ще бъде, защото това може да отнеме няколко повторения, преди да открие най-Target архитектура. Също така, ако си архитектура е много сложна, може да искате да повторите процедурата за всяка архитектурна "ниво".

6. Планбъдещето на вашата архитектура с помощта на информацията, предоставена от ABACUS.

Забележка

Ако не се опитвате да се развива съществуваща архитектура, може да се наложи да повторя някои стъпки няколко пъти, и в различен ред. Тя зависи от това какво се опитвате задачи. Например, ако сте проектиране на нова архитектура, най-вероятно ще се пренесат само си архитектура веднъж, а след това използвайте ABACUS в продължение на дълъг период от време, за да направлява бъдещото развитие (и) на архитектурата. От друга страна, ако сте закупуване на нова архитектура и има няколко алтернативи за избор, ще трябва да открият и Запълни за всяка от алтернативите, а след това Анализирайте и Симулира всяка една поотделно, преди да изпълните финалната сравнение в край.

Вижте също

Какво означава ABACUS направя? | Какво е архитектура? | Как се архитектура, представена в ABACUS? | Запълването на архитектурата | Анализирайки си архитектура | Симулиране си архитектура


Внос във вашия Architecture

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Внос във вашия Architecture

Изпратете коментари по тази тема.

ABACUS ви позволява внос в Вашата архитектура от .abacus (ABACUS файл), .xml (сметало XML фрагмент или ArchiMate Interchange Language XML файл), .vsd (Microsoft Visio) формат, както и .xls (Microsoft Excel) формат. Това ви позволява да изгради своя архитектура от външни източници, бързо.

Да се внос Вашата архитектура от.abacus (ABACUS файл)

1. Уверете се, че имате ABACUS файлотворена.

2. Кликнете с десния бутонпо Архитектура възел, всяка архитектура в своя модел или част от дървото компоненти.

3. Изберете Внос| От Файл ...от менюто.

4. Изберете място, и на .abacus досие и натиснете Отворенобутон.

Забележка

След като сте избрали файла, който искате да импортирате, ще бъдете попитани как бихте искали да внасят стандартите, видовеи гледни точки, Можете да импортирате стандарти, видове и гледни точки като нови или слети стандарти, видовеи гледни точки, Настройката по подразбиране е за стандарти, видове и гледни точки да се слеят със съществуващите стандарти, видове и гледни точки ако те вече съществуват (със същата точното наименование) във вашия проект.

Да се вносВашата архитектура от.xml (на ABACUS XML фрагмент или ArchiMate Interchange Language XML файл)

1. Уверете се, че имате ABACUS файлотворена.

2. Кликнете с десния бутонна Architecture възел, всяка архитектура в своя модел или някоя част от Компонент дървото.

3. Изберете Внос| От XML ...от менюто.

4. Изберете място, и на .xml файл и натиснете Отворенобутон.

Забележка

ABACUS само ще импортира правилно оформена ABACUS XML фрагмент или ArchiMate Interchange Language XML файл. След като сте избрали XML файл, който искате да импортирате, ще бъдете попитани как бихте искали да внасят стандартите, видовеи гледни точки, Можете да импортирате стандарти, видове и гледни точки като нови или слети стандарти, видовеи гледни точки, Настройката по подразбиране е за стандарти, видове и гледни точки да се слеят със съществуващите стандарти, видове и гледни точки ако те вече съществуват (със същата точното наименование) във вашия проект.

Да се вносВашата архитектура от,VSD(Visioфайл)виж тук .

Да се вносВашата архитектура от.xls (файл Excel)виж тук .


Внос видове и стандарти от библиотека

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Внос видове и стандарти от библиотека

Изпратете коментари по тази тема.

Можете да импортирате видове и стандарти от библиотека файл ABACUS. Можете също така да експортирате видове и стандарти от вашия ABACUS файл към библиотека файл ABACUS.

За да импортирате видове и стандарти от библиотека във вашия архитектура

1. Уверете се, че имате ABACUS файлотворена и Window Explorerпоказва.

2. Изберете File | Отвореноза отваряне на ABACUS библиотека файл.

3. The ABACUS библиотека ще бъде открита в секунда табове лист в прозореца на Explorer и ще трябва да се откачване този табове лист да бъде в състояние да влачите и пускате от него към оригиналната ABACUS файл.

4. Влачене и пусканевидове и стандарти от библиотеката във вашата архитектура.

- или -

1. Изберете File | New ...

2. Създаване на нова ABACUS файлосновават на ABACUS библиотека файл.

За да експортирате видове и стандарти от вашия архитектура в библиотека

1. Уверете се, че имате ABACUS файл отвори Window Explorerпоказва, едно ABACUS библиотека файлотворена и Библиотека Windowпоказва.

2. Влачене и пусканевидове и стандарти от вашата архитектура в библиотеката.

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно


Интерфейсът на ABACUS

Navigation: Въведение в ABACUS>

Интерфейсът на ABACUS

Изпратете коментари по тази тема.

Когато започнете ABACUS, ще видите главния екран, който е празен с изключение на менютата и лентата с инструменти в горната част, празен Explorer прозорец и от заглавието-бара. Този екран ще бъде център на взаимодействието ви с ABACUS.

Основните елементи са:

· основните менюта

· лентите с инструменти

· десния бутон на мишката

· експлоръра и собственост прозорците

· лентата на състоянието

Главните менюта

Менютата са подредени в логическа последователност.

Менютата са описани, както следва;

· Меню File- Менюто File ви позволява да създавате, отваряне, затваряне, спаси, износ и публикуват ABACUS файлове. Той също така ви позволява да създавате, отваряне, затваряне и спести ABACUS Библиотечните файлове.

· Edit менюто- Менюто Edit ви позволява да режете, копиране, поставяне, изтриване, преименуване, намери и да сортирате елементии отмените / ремонтирам операции.

· Вижте меню- Виж Менюто ви позволява да отворите или затворите различни интерфейс Windows и статус бараПридвижете напред и назад, отидете на конкретни виждания и управлява табла.

· Меню Insert- Менюто Insert ви позволява да добавите нова стандарти, Шаблони, видове, елементи, изгледточкаs, Каталози, диаграми, диаграми, Доклади и матрици.

· Меню Анализ- Менюто Анализ ви позволява да стартирате оценки срещу една архитектура, включително; производителност, цена, надеждност, модулност и откритост.

· Менюто Tools- Менюто Tools ви позволява да стартирате скриптове, поставените цели за архитектуратаи да изпълнява и архитектура "раз", Можете също така да променяте опциите на програмата и да персонализирате интерфейса от менюто инструмент.

· Window менюто- Менюто на прозореца ви позволява да закачите, организира, шоу и скриване на прозорците, които сте отворили.

· Help менюто- От менюто Help можете да получите достъп до този ABACUS помощен файл. Можете да влезете в уеб сайта, да прегледате Разрешително споразумение и общи видите подробности за ABACUS включително версията на софтуера и ABACUS подкрепа и данните за контакт. Можете да осигуряват обратна връзка от страницата за уведомяване въпрос. Ако е необходимо, можете да въведете ключова регистрация чрез менюто Помощ.

Това е реда, който обикновено ще последва, когато сте извършване на вашите задачи;След като сте създали или започна досие, Обикновено ще се пренесат си архитектура, а след това изгледтя (в Explorer, диаграми, 3D графики и т.н.). В този момент, вие или ще изпълнявате оценител, Или ще повторете процеса с една и съща архитектура или различна архитектура. (Виж Как да използвате ABACUS (Преглед) за повече подробности.)

Да погледнем чрез основните менюта и да се опитаме да си представим как ще ги прилага за вашата система.

Забележка

Можеш Персонализирайте вашите менюта по всяко време.

Лентите с инструменти

По подразбиране има следните лентите с инструменти;

· Главна лента с инструменти -

· на Симулация лента с инструменти -

· Виж на лентата с инструменти -

· на Диаграма инструментбар (ако диаграма е отворена) -

· Макрос Записване лента с инструменти -

Да погледнем чрез бутоните на всяка лента с инструменти с надвиснали над тях, за да видите инструмент-върхът (пряк-ключ).

Забележка

Само определени бутони ще бъдат активни в зависимост от това, което сте избрали в прозореца на Explorer и можете Персонализирайте вашите ленти с инструменти по всяко време.Освен това, "валидира / Проверете Ограничения на проекта" бутон на лентата с инструменти Main и бутоните на лентата с инструменти за симулация ще подчертаят Червен При обновяване на основната хранилището изисква повторно валидиране на проекта или повторна симулация на този симулатор съответно. Задръжте показалеца върху бутона, за да се види кои архитектури са засегнати.

Менюто на десния бутон на мишката

Главните менюта и ленти с инструменти са неизползва за всичко, все пак. Тя често е по-удобно да се използва контекстното меню щракнете с десния бутон на различни операции. (Също така, не всички достъпни чрез щракване с десния бутон команди са достъпни чрез основните менюта, ленти с инструменти, или клавишни команди.)

Например, след като веднъж сте създали файл, а вие имате едно дърво диаграма на вашата архитектура, по-добре е да щракнете с десния бутон върху архитектури в дървото, за да добавите нова архитектура. По същия начин, трябва да щракнете с десния бутон върху Components да добавите нов компонент. Щракнете с десния бутон върху няколко неща в дървото, за да видите какво можете да направите.

Бакшиш

Обикновено, вие ще използвате основните менюта за извършване на повече задачи на високо ниво, като оценката си архитектура. Задачите на ниско ниво - като добавяне на отделните компоненти и връзки - се извършва с помощта лентите с инструменти и / или щракване с десния бутон меню.

Изследовател и свойства прозорци

Когато отворите или да създадете файл, дървовидната диаграма ще се покаже в прозореца на Explorer. Това е прозорец към вашата архитектура. И както можете да изберете елементи в рамките на прозореца на Explorer трима други прозорци; Общите Properties, ПрепраткиИмоти и прозорци ще се актуализират, за да се отразят подробна информация за вашия избор.

Забележка

Общите Properties, ПрепраткиИмоти и прозорци са скрити по подразбиране. Виждам Персонализиране на интерфейса за това как да ги свалям и потенциално да ги остави за постоянно показва.

Докато сте изграждането си архитектура, на Windows Explorer и имоти са най-полезни представителство. Тъй като те могат да се сгъва и разгъва, както се изисква, и те не тромава.

Прозорецът Explorer има Tree (и лентата на състоянието) на, а прозорците са с Имоти 5раздела:

· Тип

· Стандарти

· Описание

· Препратки

· Имоти

ABACUS счита всички тези неща, за да бъде част от архитектурата.

Дърво

Този раздел има едно дърво групирани в 3 области както следва:

1. Мета-модел

· Стандарти- Ако множество компоненти имат един и същ набор от имоти, можете да определите комплекта авансово, а след това просто да я възложи на компонентите. Същото важи и за връзки и всеки един от другите елементи. Този набор от стандартни свойства се запазват в Стандартиклон на дървото. Вместо да определят всеки имот за всеки компонент и всеки имот за всяка връзка и т.н., просто присвоява стандарт, Например, стандартни характеристики на Unix-HP / UXможе да се запише като Стандарт и възлага на всички компоненти, като се използва Unix-HP / UXоперационна система, както е показано за OS01 сървъра на скрийншота горе.

· Видове - Този клон на дървото е библиотека на видовете компоненти и връзки можете да използвате. Видове се използват за определяне на мета-модел за вашата архитектура и за класифициране и филтриране при гледане на вашата архитектура. Те също така се определи образец за това, което стандарти, Имоти и ограничения вашите компоненти / връзки могат да имат.

· Гледни точки- Изгледточкаите могат да бъдат създадени от съществуващи схеми и може да се използва за създаване на нови диаграми.Те са диаграма шаблони.

· Templates - Templates магазин повторно използваема модели на компоненти и връзки, заедно с начина, по който те са представени или разгледана. Те могат да се мисли като "мини" архитектури или решения, които могат да бъдат поставени в съществуващите архитектури.

2. Архитектури -Архитектури клон на дървото е мястото, където градите архитектура (ите) на вашата система. (Това се нарича населяване на архитектурата.) Можете да имате неограничен брой архитектури в един ABACUS файл.

3. Dashboards - Клон The Dashboards на дървото е мястото, където можете да получите достъп до всеки записан табла за проекта.

Забележка

Позиции в дървото Explorer, които са имали Разрешение Актуализация отстранен (т.е. те са само за четене), са показани в сиво.

Тип

В този раздел се обозначава специфичен компонент или връзка вида на избрания в момента елемент в дървото.

Стандарти

Този раздел предоставя списък на стандарти за текущо избрания елемент в дървото.

Описание

Този раздел предоставя кратко описание на избрания елемент в дървото. Всякакви свързани хипервръзки могат също да се прибавят към този раздел. Те включват уеб сайтове или местни абсолютни пътища, сочещи към допълнителна информация за даден елемент. Множество линии са позволени също. Валидни хипервръзки трябва да се започне с един от 5 струни; HTTP: //, HTTPS: //, FTP: //, файл: /// или за mailto :.

Бакшиш

За хипервръзки с интервалите, потребителите могат да пишат в URL или пътеката, изберете желания текст и Кликнете с десния бутон| Hyperlink, Това ще се промени всякакви пространства до 20%така че целият URL или пътя да работи коректно.

Създаден и Променено

Тези разделsпредоставипотребителя и дата / час за създаването на, и последната модификация да, текущо избрания елемент в дървото.

Препратки

Този раздел предоставя списък на изходящи и входящи компоненти за текущо избрания елемент в дървото.Той също така показва, диаграмите, 3D и възгледите Chart, че текущо избрания елемент се появява. Ако е избрана диаграма показва гледната точка, ако е приложимо, за диаграмата и за гледка като цяло тя показва никакви Dashboards мнението появява. И когато Standard е избран в дървото той показва използването на стандарта по видове, компоненти и връзки.

Имоти

Този раздел е мястото, където се определят характеристиките на елементите в рамките на Вашата архитектура, подобно на начина, по който се изисква тя да изпълнява, броят на реда код го има, процентът на тези линии, които са коментари и т.н.

На "входа" и "изхода" свойства на предварително изграден симулатори ще бъде показан в прозореца Properties с икона на входния селектор на имот ред ( [image] ) И иконата изход ( [image] ) Съответно с подсказка посочва кои предварително изграден симулатор на имота е свързано с, напр "Модулност Output" или "Input производителност". Стрелката върху иконите изход ще подчертае Червен ( [image] ), Когато имотът не е актуална поради базовия имот или структурна промяна на регистъра с симулатора се налага повторно симулация според Червен подчертаване на Лента с инструменти Simulation .

Лентата на състоянието

Лявата част на лентата за състоянието показва пълния път до хранилище елемент в момента на фокус, или избрани в прозореца на Explorer или върху диаграма платно. Това е така, на точното място в йерархията хранилище за дадения елемент винаги може лесно да се определи. Дясната ръка част на лентата за състоянието показва различни оперативни съобщения като "Open File ABACUS Успешно" и "Разходи Изчисляване Завършен".

Вижте също

Как го правиш (Преглед) | Персонализиране на интерфейса | Какво е архитектура? | Как се архитектура, представена в ABACUS? | Работа с файлове ABACUS


Какво означава ABACUS направя?

Navigation: Въведение в ABACUS>

Какво означава ABACUS направя?

Изпратете коментари по тази тема.

За помощ и на други езици / преводи, моля, кликнете тук .

ABACUS застъпва предположение-работа от справяне с решения, системи, софтуер, информация, технологии, бизнес процеси и / или цели предприятия (наричани архитектури). Той може да ви помогне да проектирате прагматично, наблюдение, симулира, анализира и визуализира си архитектура чрез моделиране, да го анализира през интуитивни начини (напр чертежи, диаграми и 3D) и след това оценяване срещу вашите нефункционални изисквания.

Забележка

Нефункционални изискванияса тези изисквания, които не са пряко свързани с КАК продукт работи. Вместо това, те са загрижени за това колко добре работи. Нефункционалните изисквания включват такива неща като производителност, откритост, evolvability, качество, скалируемост, модулност и т.н. (за разлика от функционалните изисквания като, включете тази светлина, когато този бутон е щракване). Традиционно, нефункционални изисквания бяха трудни - ако не и невъзможно - да се измери. В действителност, ABACUS е единственият продукт, който може да се измери обективно и количествено първите три - производителност, откритост, и evolvability.

Казано по-просто, като влезете в архитектурата и това, което ви е необходима, за да се направи. ABACUS след това ви казва, ако това ще направим, както се изисква, и посочва, всякакви слабости или пропуски.

ABACUS черпи от над 20 години на изследвания системи и много повече години, установен теорията на системите. Тя ви дава количествено, надеждни и обективни отговори, така че не сте се разчита на субективна преценка.

ABACUS щандове за Architecture-BАУЕР AНАЛИЗ, Communication и Understanding на Systems. Тя може да ви помогне с всеки голям мащаб архитектура, но това е обикновено се използва в продължение на четири (4) неща:

· Evolvingток архитектура. Например, ако вашата съществуваща архитектура липсва производителност, ABACUS ще се визуализира на архитектурата за вас, идентифициране на проблемите (тесните места, и т.н.), а след това да ви кажа точнокак да се подобри архитектура.

· Проектираненова архитектура. Например, ако имате нужда от изцяло нова архитектура, и вие сте го проектиране себе си, ще ви кажа, ABACUS точнокакви компоненти имате нужда и как те трябва да бъдат свързани.

· Закупуваненова архитектура. Например, ако сте обяви търг за проектиране на нова архитектура, и сте избора между три дизайна, ABACUS ще ви кажа, точнокой отговаря на вашите изисквания най-добрите.

· Комбиниранетосега съществуващите архитектури. Например, ако имате нужда да комбинирате две или повече отделни архитектури, ABACUS ще ви води.

Вижте също

Как го правиш (Преглед) | Какво е архитектура? | Как се архитектура, представена в ABACUS?


Използване на връзки в Diagrams

Navigation: Запълването на архитектурата> Използване Рисунки>

Използване на връзки в Diagrams

Изпратете коментари по тази тема.

Shapes (в свободна форма и компоненти) и конектори (свободна форма или връзки) в рамките на диаграми могат да бъдат свързани с вашите съществуващи архитектурни представителства в ABACUS, както и външни файлове / папки и URL адреси. Тези връзки могат да бъдат управлявани (създаден, модифициран и заличава) чрез набор от инструменти ABACUS. Тази функция може да се използва за подобряване на навигацията и цялостното разбиране на вашата архитектура схематично.

За да добавите връзки към вашия диаграма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Изберете съответната форма или съединител от вашата схема.

3. Кликнете с десния бутонот форматаили съединител.

4. Изберете Отворени връзкии ЗвенаПоявява се прозорец.

5. Кликнете върху Добавиикона и New LinkПоявява се прозорец.

6. Изберете съответната Каталог | Matrix | Диаграма| 3D View| Диаграмарадио бутони, а след това изберете съответните стоките, матрици, диаграма, 3Dили диаграма изглед в сегашната архитектура от Препратка към падащо меню.

- или -

6. Изберете Уебсайтбутон за избор тогава, въведете съответния URL (например HTTP: //www.avolutionсофтуер.com /)в областта за връзка към уеб страница. Валидни URL адреси трябва да се започне с един от 5струни; HTTP: //, HTTPS: //, FTP: //,файл: или \\, Всички помещения следва да бъдат вписани с "% 20".

- или -

6. Изберете Absolute File | Относителна File радио бутонс,След това кликнете върху '..."Бутон, за да сърфирате за външен файл за връзка към вашата схема.

7. Кликнете Добреи новата връзка ще бъде показан в прозореца на връзки. Забележка: Прозорецът връзки може да се преоразмерява, за да видите пълното име, ако е необходимо.

8. Повторете стъпки 5-7за създаване на повече връзки.

9. За да следваме създаден връзката, изберете съответния линк показва в Звенапрозорец и кликване Open Link.

Забележка

Кога множество анотации са показани за форма или съединител връзката се показва на първа анотация в списък на анотации в диалога Edit анотации.

За да следвате връзки от вашата схема

1. Уверете се, че имате съществуваща диаграма отворена .

2. Изберете съответната форма или съединител от вашата схема.

3. Кликнетена съответния хипервръзка (синьо подчерта име компонент) на форма или съединител в диаграмата, за да отворите и видите първия линк от форматаили съединител.Забележка: Курсорът трябва да се промени на "ръка", когато връзката е готова да се кликне.

- или -

3. Изберете съответната форма или съединител от вашата схема.

4. Кликнете с десния бутонот форматаили съединител.

5. Изберете Отворени връзкии ЗвенаПоявява се прозорец.

6. Изберете съответния линк, който бихте искали да видите.

7. Кликнете върху Open Linkбутон, за да отворите и видите съответния линк.

За да изтриете връзки в диаграма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Изберете съответната формаили съединителот вашата схема.

3. Кликнете с десния бутонот форматаили съединител.

4. Изберете Отворени връзкии ЗвенаПоявява се прозорец.

5. Изберете съответния линк, който трябва да бъде заличена.

6. Кликнете върху Изтривамбутон. и връзката се отстранява от Звена прозорец.

Организиране на връзки в диаграма

Можете да изберете кои свързана диаграма, външен файл или уеб URL се показва, когато етикет на форма е Ctrl + кликнали на диаграмата.

1. Уверете се, че имате съществуваща диаграма отворена .

2. Изберете съответната форма или съединител от вашата схема.

3. Кликнете с десния бутонот форматаили съединител.

4. Изберете Отворени връзкии ЗвенаПоявява се прозорец.

5. За да промените реда на връзките кликнете върху Премести нагоре | Премести надолукопчета от дясната страна на Звенапрозорец.

6. Първият линк, който се появява в лявата страна на Звенапрозорец е връзката, която показва, когато Ctrl + Clickхиперсвързан форма или съединител име.

Вижте също

Запълването на архитектурата | Запълването на архитектурата ръчно | Анализ Вашата архитектура


Манипулиране Diagrams

Navigation: Запълването на архитектурата> Използване Рисунки>

Манипулиране Diagrams

Изпратете коментари по тази тема.

След като се създаде схема, елементите, които се съдържат в него може да бъде ре-образно и повторно размер по желание.

За да преместите елемент в диаграма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете и задръжтевсеки компонент, за да го преместите. Ако избрания компонент има майка, на майка компонент ще бъде осветен.

3. Като елемент евлачат от нейната майка компонент, и в сравнение с други компоненти, "потенциални" родителите ще стане подчертани. Цветовата схема, използвана показва ефекта на операцията ще има върху предупрежденията и грешки с настоящия проект и е описан в Дефиниране и Validating Ограничения , По този начин, графично можете да се придвижвате в йерархията от "поглед отгоре".

4. Изпусканебутона на мишката да се откажа от елемент в новото му място.

Забележка

Можете също така да използвате клавиатурата, за да се възстанови позициите елементи върху платното за рисуване. Просто изберете формата на компонент или свободна форма, която искате да преместите и използвайте клавишите със стрелки, разположени на клавиатурата да се движат с формата на желаното място.

Също така имайте предвид, че когато плъзнете компонент с мишката върху друг компонент, а "потенциал" майка компонент е подчертано, когато в горния ляв ъгъл на компонента, който се влачеше припокрива друг компонент.

Бакшиш

Рисуван и Плаващи форми може да се поръча от щракване с десния бутони селектиране Изнасяне на преден план или Изнасяне на заден планот менюто. Важно е да се отбележи, че съставните фигури може да се превърне в свободна форма фигури от щракване с десния бутонна специфична форма и избираща компонент Конвертиране в свободна форма.

За да преоразмерите компонент в диаграма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете, задръж-драгедин от дръжки към тях, и преоразмеряване на формата до желания размер.

3. Алтернативно да поддържа съотношение на формата си, натиснете Shift + Click-задържане-драг.

За да преместите връзка в диаграма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете и задръжтевсякаква връзка, за да го преместите.

3. Изпусканебутона на мишката да се откажа от елемент в новото му място.

Забележка

Можете да преместите само връзки, които не са прикрепени към всички компоненти. Ако те са свързани, можете да се движи само на свободния крайs, или повторното маршрут връзката .

Изтриването Компоненти и Connections

При изтриване компонент или връзка от диаграма, имате опцията да го изтриете от цялата архитектура. Всеки компонент, който се изтрива от архитектурата ще бъдат премахнати автоматично от всички други схеми в които се срещат. Тъй като свободна форма случаи се появяват само в една схема, изтриване тях не влияе на архитектурния модел или друга схема.

За да изтриете даден компонент или връзка от диаграма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнетена всяко свързано с връзката или компонент, за да го изберете.

3. Натиснете Изтривамключ за да го изтриете от диаграмата, или Shift + Deleteда го изтриете от целия модел.

- или -

2. Щракнете с десния бутон върху всички свързани с елемент или компонент. Ще се появи контекстно меню.

3. Изберете Изтрий от View или Изтрий от Архитектураот контекстното меню.

Забележка

Ако елементът, който желаете да изтриете, от гледката е без деца, и се среща само на това мнение, ABACUS ще ви попита дали искате да изтриете елемент от хранилището, както добре.

Внимание

При изтриване на компонент от модела, който има деца, компоненти, децата също ще бъдат изтривани потенциално според диалога предупреждение.

Обединяване Components

Вие може да искате да се слеят два компонента съществуващи на същата схема (и в архитектурата), Това може да стане по много причини, например, Две сървъри съществува в рамките на една компания инфраструктура- H01 и Н02. Тези два сървъра са представени като два отделни компонента, в рамките на една архитектура. H01 е счита за ненужна и следователно е да бъдат изведени от експлоатация. Всички съществуващи приложения, работещи на H01, трябва да бъдат пренасочени към H02 (все още в комисия). Тази промяна може да бъде отразено чрез действието на "сливащи" двата компонента Н01 и Н02 на диаграмата (и в архитектурата).

За подробна дискусия относно сливането се обърнете към Сливане артикули темата тук .

За да се слеят две съществуващи компоненти

1. Уверете се, че имате съществуваща диаграма отворена .

2. Щракнете с десния бутон-задръжтена компонента, който желаете да се слеят и влачато върху компонента, който желаете да го слее с. Уверете се, че очертанията на компонента на дестинация е маркиран в червено, за да покаже, че той е избран.

3. Изберете Обединяване | Съхрани Destination или Презаписване Destinationот менюто.

Забележка

The Съхрани Destinationопция запазва стойностите на свойствата на кацане към тях, ако те съществуват от компонента произход, както добре.

The Презаписване Destinationопция презаписва свойства на дестинация компонент с някакви общи свойства от компонента произход.

Промяна Connections

Съединенията, показани в схема винагиотразява структурата, както е определено в самата структура. Инструментът Drawing ви позволява да се отделят връзки от компоненти, да ги преместите, крива тях, повторно ги маршрут и ги свържете отново с други компоненти.

За да откачите / прикачите връзка от / към компонент

1. Уверете се, че имате съществуваща диаграма отворена .

2. Кликнете и задръжтена всяка връзка.

3. Изберетевръзката край(т.е. Източник или Sink), Който бихте искали да се отделят / приложете. Забележка: Краищата на връзката са указани с малки бели кръгове и кръжи над бял кръг за втора ще предизвика "подсказка" да се яви със съответните роляиме(т.е. или Source или Sink).

4. Влачавръзката приключи на ново място (или на свободна място или компонент) и отпуснете бутона на мишката.

Забележка

Когато в края на връзка се поставя върху валиден компонент, очертанията на компонента на дестинация се маркира с пунктир контур. Цветовата схема, използвана показва ефекта на операцията ще има върху предупрежденията и грешки с настоящия проект и е описан в Дефиниране и Validating Ограничения , Веднъж освободени че в края на тияe връзка и компонента автоматично се свързва(или приложен), И това е отразено в архитектурния модел.

За повторно маршрут на връзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Поставете показалеца на мишката върху връзката.

3. Задръжте Промянанадолу и Кликнетебутона на мишката, за да поставите точката на свързване на котва. Отпуснете Промяна ключ. Можете да премахнете точката на котва, като направите една и съща операция.

4. Щракнете и плъзнететочката на котва да премаршрутират връзката.

Бакшиш

ИзползвайAlt ключ, вместо на Промянаключ за създаване на ортогонални връзки.

Да се крива или изправетевръзка

1. Уверете се, че имате съществуваща диаграма отворена .

2. Поставете показалеца на мишката върху връзката.

3. Кликнете с десния бутон TТой връзка и в контекстното меню, което се появява изберете Крива, Ортогонален или Прав.

Бакшиш

Всички връзкиот даден тип на диаграмата може да се настрои да Curved, ортогонално или Straight кликнете с десен бутон на свързана линия за типа относно Раздел Connections от Прозорец за шаблонии избираща Curve, ортогонално или Straight.

Да се котва върху определена точка на ръба на форма

1. Уверете се, че имате съществуваща диаграма отворена .

2. Изберете връзка.

3. Поставете показалеца на мишката върху на "бялата точка" в края на на връзка.

4. Кликнете с десния бутон TТой край връзка и в контекстното меню, което се появява изберете Котва Endpoint да Shape.Преместете края на връзката на местоположението на желанието на ръба на формата.

ИЛИ

Задръжте Ctrlнадолу и cоближе и плъзнетена край връзка точка до Местоположението на желанието на ръба на формата.

Забележка

Connections ще щракнат на действителната пресечната от техните свързани форма вместо на наказателното поле на тази форма очертаващ.

Вижте също

Инструментът Drawing | Запълването на архитектурата | Анализ Вашата архитектура


Сливане на предмети

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Сливане на предмети

Изпратете коментари по тази тема.

Когато бихте слеят предмети?

Вие ще се слеят елементи, когато имате две (или повече) обекти в модела си, че са най-добре представени само с един единствен екземпляр. Има много ситуации, когато може да искате да направите това, в това число:

· В резултат на вноса на нов набор от информация в своя модел, който може да дублира или заменя съществуващата информация. Така например, ако внасят актуализирана версия на електронна таблица във вашия модел.

· С течение на времето дубликати на "същото" компонент са създадени и които искате да почистите тези дубликати.

· Ако изпълнявате едно какво-IF сценарий и елементите, които са за моделиране са действително обединяване в реалност. Така например, ако се сливат два отдела в организацията ви, или ако се сливат два сървъра.

Какво може да се слеят?

Следните видове елементи на подпомогане сливат:

· Стандарти

· Компоненти и свързване Видове

· Компоненти и Connections

Как да се слеят елементи

За да започне сливат, с десния бутон на мишката, плъзнете един артикул в изследовател на друг. Елементът, който влачеше е източникът, и елемента, който плъзнете е дестинация. При освобождаване на десния бутон на мишката ще бъде представен с меню, от което можете да изберете да слее двете позиции. Вие ще трябва да изберете дали искате да се запази или да презапишете дестинацията. Това е обяснено по-долу.

Десния бутон на драг The сливат

Каква е разликата между запазването и презаписване на дестинацията?

Опцията за запазване или презапишете диктува какво се случва, ако име, описание или Properties между източник и дестинация предмети мач.

Ако Боатин Destination е избрано

· В дестинацията Име и описание ще бъде запазена.

· Всички имоти, които съществуват само в източника, се добавят към дестинацията.

Ако Overwrite Дестинация се избира:

· Име Дестинацията ще бъде презаписана от източника.

· Дестинацията е Description ще бъдат презаписани от източника, освен ако източникът на Description е празно.

· Всички имоти, които съществуват само в източника, се добавят към дестинацията.

· Стойността и Звеното за всички имоти, които съществуват в двата източника и дестинацията ще бъде презаписана от източника, освен ако Value източника или Unit е празно.

Специални случаи

· Видове: Когато сливането видове, разрешенията се обединяват, в "песимистичен" начин, така че, ако разрешението на източника не е съществувала от дестинацията, тя ще бъде добавена, и ако тя не съществува в дестинацията, а след това, ако физическото лице Разрешение за потребителска група (Създаване, Read, обновяване или изтриване) не съвпадна (една отпуска, една отрече), тогава това разрешение ще бъде отказан.

· Елементи: Когато сливането компоненти, под-компоненти на източника са мигрирали към местоназначението, и се обединяват със подкомпоненти в дестинацията, ако имената им са идентични, Независимо от техния вид.Освен това, няколко под-компоненти на източника със същото име, ще бъдат обединени в един единствен подкомпонент в дестинацията.

· Connections: Най-горното ниво самите връзки и двете трябва да имат същите прикачените файлове (или липсата на такава), за да се позволи да се слеят. Когато сливането връзки, под-връзките на източника са мигрирали към местоназначението, и се сливат с под-връзки в местоназначение, ако имената им са идентични Итяхното закрепване са идентични. Ако приставки, които не са идентични, изходните под-връзки ще бъдат добавени към местоназначението, без да се слива с съвпадение на връзките, които вече присъстват. Това е така, че никакви привързаности са загубени.


Навигация в 3D диаграма

Navigation: Анализирайки си архитектура> 3D диаграми>

Навигация в 3D диаграма

Изпратете коментари по тази тема.

ABACUS позволява лесно да навигирате през вашата архитектура в 3D. Опитът е подобно на летене. Има два режима на корабоплаване:

· Basic Control Mode (Default); и

· Advanced Control Mode - промяна в този режим, като изберете Контрол| Advanced Mode Control.

Забележка

За да превключвате между Basic Control и Advanced Control Modes, можете да използвате F4клавишна комбинация функционалност.

Basic Mode Control

· Като държите левия бутон и преместване на мишката напред или назад променя терена;

· Като държите левия бутон и преместване на мишката наляво или надясно, променя отклонението;

· Холдинг десен бутон и се движат тигани на мишката на мнение;

· Провеждане на двата бутона надолу и преместване на мишката напред или назад, отдалечава и излиза на архитектурата; и

· Провеждане на двата бутона надолу и преместване на мишката наляво или надясно, ролки наляво и надясно.

- или -

· Натискането на Left Arrowна клавиатурата или цифровата клавиатура ще се превърне лявата;

· Натискането на Right Arrowна клавиатурата или цифровата клавиатура ще се обърни на дясно;

· Натискането на Стрелка нагорена клавиатурата или цифровата клавиатура, ще увеличите;

· Натискането на Стрелка надолуна клавиатурата или цифровата клавиатура, ще намалите мащаба;

· Натискане Page Upна клавиатурата или цифровата клавиатура ще разпъват до; и

· Натискане Страница надолуна клавиатурата или цифровата клавиатура ще разпъват надолу.

Advanced Mode Control

· Движещмишката напред и назад и нагоре и надолу, променя терена и отклонението (съответно);

· Натискане W или Стрелка нагореотдалечава в (напред) на архитектурата;

· Натискане S или Стрелка надолуотдалечава от (назад) от архитектурата;

· Натискане A или Left Arrowрула от ляво;

· Натискане D или Right Arrowролки на дясно;

· Натискане Q или Страница надолуповишава мнението (чрез намаляване на перспектива); и

· Натискане E или Page Upпонижава изгледа (чрез повдигане на перспектива).

Interactive Mode Control

Натиснете и задържите клавиш за смяна на регистърана клавиатурата има предимство текущия режим (Basic или Advanced), за да влезете в режим на интерактивен контрол. В този режим е възможно следното:

· Ролкакурсора на мишката върху един компонент или връзка, за да видите този компонент или името връзка е;

· Кликнетена компонент, за да се фокусирам върху този компонент;

· Щракнете и плъзнетена компонент, за да завъртите изгледа около този компонент; и

· Кликнете с десния бутонкомпонент или връзка и изберете Покажи В Explorerда се види, че компонентът или местоположение връзка в дървото.

Общи контроли

· Употреба ALT-ENTER / ESCза да превключите в режим на цял екран;

· Употреба F2да промените режима на дисплея. Това може да се стигне и в ИзгледMenu.

· Използвай колелцето на мишката или +/-за промяна на скоростта. Скоростта е обозначен с номер в долния ляв ъгъл - показва се само, когато тя се променя. 1 е най-бавният и 100 е най-бързо.


Откриване Diagrams

Navigation: Запълването на архитектурата> Използване Рисунки>

Откриване Diagrams

Изпратете коментари по тази тема.

Тегленето на шаблони и платно прозорците се появява автоматично, когато диаграма е отворена или е създал. По същия начин, когато диаграма е затворен, съответстваща табове лист в прозореца платно изчезва и ако няма повече рисунки са отворени тогава прозореца шаблон е затворен.

Да се създадетенова схема

1. Уверете се, че иматеABACUS отворен файлсъдържаща вашето населена архитектура.

2. Кликнете върху Diagramикона в лентата с инструменти на View.

- или -

2. Изберете Insert| Diagram.

- или -

2. Кликнете с десния бутонна Diagramsклон на даден Архитектурасечение на дървото и Select Създавам Диаграма.

3. Изберете Архитектураискате да се съсредоточи върху от падащото меню. Забележка: архитектурата вече ще бъдат избрани за вас, ако сте използвали Стъпка 3 по-горе, за да отворите нова схема.

4. Изберете Гледна точка искате да използвате от падащото меню. Забележка: избраният гледна точка ще филтрира компонентите и връзки списъците да бъдат тези, само достъпно на гледна точка.

5. По желание изберете изглед от Филтър по Viewпадащото меню, за да изберете предварително компонентите и връзките от избрания изглед. Забележка: това е ефективно използване на мача изгледа като запазена заявка.

6. Изберете Оформление да бъде или Радиален или Решетка.

7. Изберете Елементи и Connectionsкойто искате в диаграмата от прозорец за избор на стандартен елемент .

8. Кликнете Добре.

Забележка

Нова схема ще бъде добавен към Diagramsклон на архитектурата. Той ще има име по подразбиране, която можете да промените по-късно кликнете с десен бутон върху него.Освен това, последното състояние на филтрите съставните и подбор връзка ще бъде записан с диаграмата ефективно спестяване на "заявка" се използва за създаване на диаграмата.

За да отворите съществуваща Диаграма

1. В конкретния населеното архитектура, разширите Diagramsклон на дървото.

2. Кликнете два пъти диаграмата, която искате да отворите.

За записване на диаграма

1. Уверете се, че имате нов или съществуващ диаграма отворени сте направили необходимите промени. Забележка: звездичка "*" ще бъде показана след името на оглед в табове заглавната страница, ако има промени, за да бъдат спасени.

2. В екрана на изследовател, кликнете върху Saveбутон или трябва да Пила| Saveили натиснете Ctrl + Sда запазите всички промени в архитектурата и напишете го във файл.

За да запазите диаграма като гледна точка

1. Уверете се, че имате съществуваща диаграма във вашата ABACUS файл.

2. Кликнете с десния бутондиаграмата в Diagramsчаст от дървото.

3. Изберете Запази като Диаграма Гледна точка.

4. Въведете име за новия си диаграма гледна точкаи кликнете Добре.

Вижте също

Инструментът Drawing | Запълването на архитектурата | Анализ Вашата архитектура


Запълването използващи Каталози

Navigation: Запълването на архитектурата>

Запълването използващи Каталози

Изпратете коментари по тази тема.

A каталог ви позволява да разглеждате и редактирате компоненти или връзки и техните свойства по прост табличен начин.

Да се създаване на нов каталог видите в ABACUS

Забележка

Докато всички участници Архитект могат да създават нови Каталози, за да спаси промени в настройките на съществуващ каталог е на лиценз за употреба трябва Designer добавка способност. Това е за "закрила" на конфигурацията на съществуващите Каталози, които могат да бъдат споделени от много потребители. Въпреки това, без да се използва архитект дизайнер добавка все още може да избере да "Save As" всички нови настройки на нов каталог. И разбира се всички потребителски лицензи могат да избират "да изхвърли" всички промени в съществуващ каталог. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда Дизайнер добавка способност. И не забравяйте, това е само на настройките на Каталога, всички редакции, направени по отношение на данните в каталога са незабавно приложени към хранилището, независимо.

1. Изберете Insert | Каталог.

2. В падащо изберете архитектура, която съдържа компонентите иливръзки, които искате да видите.

3. В падащо изберете компонента или тип връзка който искате да са случаите, посочени като "редове' в каталога.

4. The каталог ще бъде населена сред за всяко копие на избрания компонент или типа връзка.

Забележка

По подразбиране най-лявата Йерархия Pathколона (т.е. йерархията на компоненти майки или връзки над избрани инстанции) и на 2-ри Име колона (т.е. списъка на избрания компонент или свързване инстанции) са замразени в ляво от каталога. За смяна на колоната замръзване плъзнете сепаратор колона вдясно от колоната Име. Можеш повторна поръчкаколони просто придърпват техните заглавия на колоните. Клетките на колони с един син подчертаване са хипервръзки с други елементи в проекта и хипервръзки може да бъде последвано от задържане на Ctrl и щракнете върху връзките. Колоните могат да бъдат скрит кликнете с десен бутон заглавието на колона и изберете Колона | Скриване на колона. Скрити колони могат да бъдат _Възстановени са досега скрити като кликнете на бутона Колони лентата Configure и използване Колони Конфигуриране диалоговия както е показано по-долу, или чрез избор на стрелка надолу част на бутона Колони лентата Configure и индивидуално избиране на скрита колона (и) или от Генералния, Имоти или приставки колекции. Редове могат да бъдат групирани от техните колона стойности чрез плъзгане заглавието на колоната в синята групиране лента в горната част на каталога. По всяко време можете да щракнете два пъти върху селектор на стоките ред и скочи досъответния компонентили връзкав прозореца на Explorer.Клетъчни Property стойности са удебелен когато те са различни за тези по подразбиране, и наклонен където те са само за четене. Клеймото, недвижими имоти и Прикачените колони компонент може да се оцветен в съответствие със стойностите клетъчни или стойността имот прикачен компонент чрез щракване с десния бутон заглавието на колона и изберете Колона | Промени Colour ... и тогава Цветът от клеймо или опция Colour До имота, обаче, само Списък, Integer, Decimal, Boolean или Date / Time тип данни свойства ще оцветят. Стойността на имотите за Прикачените колони компонент може да се показана кликнете с десен бутон заглавието на колона и изберете Колона | Покажи Property ... и след това опцията Show имота. И най-накрая, когато са налице Задължителните ограничения определен за колона имот те могат да бъдат показани с <Задължително>низ (заедно с оцветители според нивата им по прилагане) с десния бутон върху заглавието на колона и изберете Колона | Покажи <Задължително>.

Каталог

Да се добавяне / покажи колони a Каталог гледка в ABACUS

1. Уверете се, че имате Каталог оглед отворен.

2. Скрити колони могат да бъдат индивидуално _Възстановени са досега скрити, като кликнете върху стрелка отдясно на Колони бутона Configure лента с инструментии избор на скрита колона или от Общ, Имоти или Прикачени файлове колекции.

Забележка

A отметка ще бъдат показани в непосредствена близост до момента показват, колони за каталога.Освен това, само някои прикачени файлове ще бъдат на разположение в рамките Приложения раздел според ограничения които са определени в проекта си. По-специално, за прикачен файл да бъде на разположение, за да бъдат показани в каталог компонент типа на компонент за каталога трябва да бъдат посочени или като източник или мивка (НЕ на "Всеки") на "връзка трябва да бъде приложен" ограничението за връзка тип, и трябва да има поне един тип компонент е посочено, или като източник или мивка (НЕ на "някакви"), от друга "края" на същия тип връзка.

- ИЛИ -

2. Няколко колони могат да бъдат _Възстановени са досега скрити (или поръчани или фиксирани), като кликнете върху Конфигуриране Колони бутон на лентатаи използване Колони Конфигуриране диалоговия показано по-долу.

Забележка

Показаните в момента колоните са показани в панела в дясно с наличните колони, показани в панела вляво. Наличните колоните могат да бъдат филтрирани според Изберете Налични Колони Отпадащи и те могат да бъдат добавени, като ги изберете в панела отляво и кликнете върху връзката Добави бутон inbetween двата панела.

Конфигуриране на диалоговия Колони

Да се премахнете / скриване на колони от по- Каталог гледка в ABACUS

1. Уверете се, че имате Каталог оглед отворен.

2. Щракнете с десния бутон заглавието на колоната за колоната, която искате да премахнете / скрий и изберете Колона | Hide Column.

- ИЛИ -

2. Няколко колони могат да бъдат скрити (или поръчани или фиксирани), като кликнете върху Конфигуриране Колони бутон на лентатаи използване Колони Конфигуриране диалоговия показан по-горе.

Забележка

Показаните в момента колоните са показани в панела в дясно с наличните колони, показани в панела вляво. Показаните в момента колоните могат да бъдат скрити, като изберете колоната в панела в дясно и кликнете върху връзката Премахни бутон inbetween двата панела.

За да се пренесат с помощта на Каталог гледка в ABACUS

1. Да се добавите компонент или Връзкана избрания вид да сена стоките (и проекти) щракнете върху Add New Компонент / Add New бутон на лентата Connection. Редът трябва се появяват и компонент или връзка ще бъде създаден най-високо ниво на Компоненти или Събиране Connections за избрания архитектура.

Забележка

Нови компоненти и връзки, се добавят по подразбиране най-високо ниво на компоненти или Connections събирането на избраната архитектура на. За промяна на родителя на нови компоненти или връзки с десния бутон върху Йерархия Path клетката за новия компонент или връзки ред и изберете Промени майка ...и изберете желания родител (като се запознае с ограничение Отбелязването ).

Забележка

Нови редове / елементи добавят директно към каталог чрез "Нова" бутон, поставен в каталога, или да е създадена през импортиране в каталога от MS Excel са освободени от филтриране, докато каталога е затворен. Това е да се даде възможност на всички необходими за редактиране на стойностите на колони, които не могат да отговарят на съществуващите критерии за филтриране на каталога. Тези нови елементи редове са обозначени със символ "+" в селектор ред клетка в началото на редицата, който е оцветен зелен ако елемент в момента отговаря на критериите, записани за филтриране на каталога (т.е. ще остане на стоките, ако повторно отвори), и червен ако това не стане.

2. Да се премахнете компонент или Връзкана избрания вид отна стоките (и проекти) изберете реда и или натиснете клавиша Del или щракнете с десния бутон върху цифрата и изберете Изтрий от Архитектура, The ред трябва да изчезне от каталога и то ще бъде изтрит от проекта.

Да се филтър като се използва Каталог гледка в ABACUS

1. Уверете се, че имате Каталог оглед отворен.

2. Ако редицата филтър не се показва в горната част на каталога След това кликнете върху Покажи Филтър Header Rowлента с инструменти бутон.

3. В колоната, която искате да добавите филтър, щракнете двукратно върху клетката на филтъра ред, където той показва "(All)".

4. За Клеймо, Йерархия Path, Име или Описаниеобщи колони или Текст, Integer, Decimal, Булева или Време за срещаколони имоти щракнете върху бутона ..., който се появява в правото на ред клетка на филтъра и влизат стойностите на клетките, които трябва да бъдат включени в каталога.

Забележка

Matching се извършва така, сякаш "*" уайлд карти се прилагат автоматично, преди и след всяко низови стойности, така че на запис на "котка" (без кавичките) ще включва редове с "Бобкотка','коткажена "или" прилакоткайон "и т.н. Multiple /" или "стойности могат да бъдат вписани нови линии, използващи Ctrl + Enter, За Integer и десетични колони собственост "и" логика може да се включи с помощта на "&"(Без кавичките) и по-голяма от / по-малко от т.н. логика могат да бъдат включени посредством"> =','>','<' и '<="(Без кавичките), например '> = 50000 & <90000 ". Non-празни оценяват редове могат да бъдат включени, като въведете "(Non-Заготовки)"(Без кавичките) и празни оценяват редове могат да бъдат включени, като въведете"(Заготовки)"(Без кавичките).И накрая, всички филтри са с дело подразбиране нечувствителен така "котка" (без кавичките) ще включва редове с "котка", "Cat" или "CAT" и т.н. За малки и големи букви съвпадение, въведете "(Case)"(Без кавичките) преди низ напр "(Case) Cat" (без кавичките) ще включва само редове с "Cat" в тях.

5. За Прикачени файловеколони, Стандарти колони или Списък колони имоти щракнете на бутона стрелка надолу, което се появява в правото на ред клетка на филтъра и се избират стойностите клетъчни от квадратчетата, които следва да бъдат включени в каталога.

Забележка

The "(Select All)" квадратчето ще даде възможност на всички останали квадратчетата, които са в сила, включително всички налични редовете. The "(Non-Заготовки)" квадратчето ще включва всякакви не-празен оценяват редове. The "(Заготовки)" квадратчето ще включва празни редове ценен. И накрая, махнете отметката някакви конкретни ценен отметки автоматично ще избирай на "(Избор на всички)" и "(Non-Заготовки)" отметки за съгласуваност.

6. Кликнете Добре да приложите филтъра.

Да се деактивирате / активирате филтрирането на a Каталог гледка в ABACUS

1. Уверете се, че имате Каталог оглед отворен с филтър приложен.

2. Кликнете квадратчето отляво на реда филтър.

Да се Премахване на филтър от a Каталог гледка в ABACUS

1. Уверете се, че имате Каталог оглед отворен с филтър приложен.

2. За да премахнете индивидуален филтър колона с десния бутон върху заглавието на колоната и изберете Колона | Clear Filtering.

3. За да премахнете всички филтри щракнете на Опции лента с инструменти бутон и изберете Ясно Filter Settings.

Да запазя / Запази като aКаталог оглед

Забележка

Докато всички участници Архитект могат да създават нови Каталози, за да спаси промени в настройките на съществуващ каталог е на лиценз за употреба трябва Designer добавка способност. Това е за "закрила" на конфигурацията на съществуващите Каталози, които могат да бъдат споделени от много потребители. Въпреки това, без да се използва архитект дизайнер добавка все още може да избере да "Save As" всички нови настройки на нов каталог. И разбира се всички потребителски лицензи могат да избират "да изхвърли" всички промени в съществуващ каталог. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда Дизайнер добавка способност.И не забравяйте, това е само на настройките на Каталога, всички редакции, направени по отношение на данните в каталога са незабавно приложени към хранилището, независимо.

1. Уверете се, че имате нов или съществуващ каталог оглед отворени сте направили необходимите промени.

2. В Каталог огледлентата с инструменти кликнете върху Saveбутона, за да запишете Каталог оглед и всякакви промени във форматирането.

Забележка

Ако не разполагате с бутона Save в лентата с инструменти на Каталог оглед тогава не е нужно Проектанта добавка и вие сте само в състояние да Запази катовсички настройки се променя в нов стоките, когато отидете да затворите съществуващия каталога.

3. Ако на КаталогИмеПоявява се диалоговият (поради бъдеш нов каталог) въведете име за каталог и натиснете Добре.

Да се износ към MS Excel стоките

1. Уверете се, че имате Каталог оглед отворен.

2. Щракнете върху Експорт в Excel таблици Каталоглента с инструменти бутон.

3. Изберете име на файл, за да запишете каталога на MS Excel като. Кликнете Save.

Забележка

По подразбиране изнасяния MS Excel каталога на името на файла ще бъде името на Каталог суфикс с наименованието на архитектурата в скоби, напр "Проекти (2014 Жилищна) .xlsx". Можете да промените някоя от това, включително дали форматът на файла е да бъде .xlsx или .xls. Името на Architecture е включена, за да напомни на потребителя, че всеки каталог има специфично съдържание (т.е. IDs в колона А и ред 1), за да може тя да бъде кръгла препъна назад в използването Внос от MS Excel стоките по-долу.

Забележка

По подразбиране скритата колона А в рамките на изнесено каталога MS Excel съдържа уникалния идентификационен код, за всеки един от елементите в хранилището ABACUS. Това позволява на всички промени, които са направени в рамките на MS Excel, за да бъде "съвпадащи нагоре" към съществуващите елементи в рамките на ABACUS върху вноса (виж по-долу). Въпреки това, използването на този уникален идентификатор на "мач" редове може да бъде преодоляно с Външно | документ за самоличностсобственост върху елемента. Това означава, че ако има външен елемент | ID собственост и е включена в каталога на износа след това стойностите на външния | ID колона ще бъде използвана за мач редовете при внос (виж по-долу) и уникалните идентификационни стойностите в скритата колона А ще бъдат игнорирани (и дори може да бъде празно). Скритият колона със себе си, трябва да остане, обаче, по-специално стойността в клетка A1. Освен това, при добавяне на външни ID за съществуваща колекция ABACUS елемент ние препоръчваме да ги добавите като друг имот за първи път, напр Външно | Temp и след преименуването на имота да External | ДОКУМЕНТ ЗА САМОЛИЧНОСТ. В противен случай ще бъдат добавени дублиращи се елементи.

Каталог на форматиранесе изнася по подразбиране, обаче, за големи каталози това може да доведе до износа е доста бавен. Съответно, в Tools | Опции ...Оттогава на Каталограздела,вие сте в състояние да се намали количеството на форматиране, което се изнася, както е показано в раздела Каталог долу, като по този начин ускоряване на износа.

Каталог на износа опции

4. Показва се Export Завършен диалоговия. Кликнете Добре.

Изнесени в MS Excel стоките

Да се внос от MS Excel стоките

Забележка

По подразбиране скритата колона А в рамките на изнесено каталога MS Excel (виж по-горе) съдържа уникалния идентификационен код, за всеки един от елементите в хранилището ABACUS. Това позволява на всички промени, които са направени в рамките на MS Excel, за да бъде "съвпадащи нагоре" към съществуващите елементи в рамките на ABACUS за внос. Въпреки това, използването на този уникален идентификатор на "мач" редове може да бъде преодоляно с Външно | документ за самоличностсобственост върху елемента. Това означава, че ако има външен елемент | ID собственост и е включена в каталога на износа (виж по-горе), след това стойностите на външния | ID колона ще бъде използвана за мач редовете на вноса и уникалните идентификационни стойности в скрита колона А ще бъдат игнорирани (и дори може да бъде празно). Скритият колона със себе си, трябва да остане, обаче, по-специално стойността в клетка A1. Освен това, при добавяне на външни ID за съществуваща колекция ABACUS елемент ние препоръчваме да ги добавите като друг имот за първи път, напр Външно | Temp и след преименуването на имота да External | ДОКУМЕНТ ЗА САМОЛИЧНОСТ. В противен случай ще бъдат добавени дублиращи се елементи.

1. Уверете се, че имате Каталог оглед отворен.

2. Щракнете върху Внос от Excel електронна таблица Каталоглента с инструменти бутон.

3. Изберете име на файл, за да импортирате каталога MS Excel от. Кликнете Отворено.

4. Нови грешки, открити и / или нови Грешки / Предупреждения Откритите диалози могат да се появят за всяко ново съдържание (т.е. редове в MS Excel), които се добавят. Обърнете внимание на грешките / предупреждения и кликнете Добре.

5. Диалоговия An Import Завършен се показва и може да покаже предупреждения, дължими на вноса (виж бележките по-долу). Кликнете Добре.

Забележка

За възложените стандарти или прикрепени колоните на компоненти, нови записи чрез каталога MS Excel трябва да съвпадат точно име на съществуваща Standard или Component на правилния тип за прехвърляне или връзката да бъде добавен. Първото име Мачът ще се използва и всички непосрещнати записи ще генерира предупреждение по-долу. Освен това, докато предупреждения са дадени на повторен внос, елементи са Не изтритот ABACUS ако те не присъстват в каталога на MS Excel. Това е така, защото няма начин, че ABACUS да знам дали съществува определен стандарт или прикрепени компонент в проекта ABACUS но не съществува в каталога MS Excel, тъй като тя е била изтрита от каталога MS Excel или е бил добавен към ABACUS проект, тъй като каталога е било изнесено. Съответно, ако потребителите искат да имат лесен "откриване", които са били добавени връзки по време на процеса на импортиране те могат просто да се създаде необходимата имот от типа на връзката и да е по подразбиране за заготовка, така че те ще бъдат предупредени за всички нови връзки, всеки път импорт е завършена.

Забележка

Когато вносител каталог MS Excel различни предупреждения могат да бъдат показани. На първо място, ако една нова колона се добавя към Excel, която не съответства на "синтаксис" на имот или прикрепени компонент колоната ще бъдат игнорирани. На следващо място, ще бъдат показани ред по ред предупреждения за някакви проблеми с данните за всеки ред от каталога Excel. Тези предупреждения започват с номера на реда в квадратни скоби и ако е уместно етикета на колоната (т.е. "[23, J] ..." за ред 23, колона J) и могат да се позовават на изтрити елементи, ненадминати стандарти или прикрепени имена на компоненти (които са игнорирани, както на бележка по-горе) или невалидни или празно ID, свързана с нов ред / елемент (който ще бъде добавен). За подробна статия за населяване ABACUS използвайки каталози Excel се обърнете към Avolution Общността или курс за обучение на портфолио мениджър.

Забележка

Нови компоненти и връзки, се добавят по подразбиране най-високо ниво на компоненти или Connections събирането на избраната архитектура на. За промяна на родителя на нови компоненти или връзки с десния бутон върху Йерархия Path клетката за новия компонент или връзки ред и изберете Промени майка ...и изберете желания родител (като се запознае с ограничение Отбелязването ).

Забележка

Елементи добавят директно към каталог чрез "Нова" бутон, поставен в каталога, или да е създадена през импортиране в каталога от MS Excel са освободени от филтриране, докато каталога е затворен. Това е да се даде възможност на всички необходими за редактиране на стойностите на колони, които не могат да отговарят на съществуващите критерии за филтриране на каталога. Тези нови елементи редове са обозначени със символ "+" в селектор ред клетка в началото на редицата, който е оцветен зелен ако елемент в момента отговаря на критериите, записани за филтриране на каталога (т.е. ще остане на стоките, ако повторно отвори), и червен ако това не стане.

Да се сравни съдържанието на каталог с друга архитектура

1. Моля, отнесете се към темата тук .

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Запълването на архитектура от Visio | Запълването на архитектура от Excel


Запълването използващи Матрици

Navigation: Запълването на архитектурата>

Запълването използващи Матрици

Изпратете коментари по тази тема.

A матричен ви позволява да разглеждате и редактирате "пряка" връзки между компонентите по прост начин табличнаи също така да видите "косвен път" между устройствата според всички междинни компоненти (и връзки).

Да се създадете оглед Matrix в ABACUS

Забележка

Докато всички участници Архитект могат да създават Матрици за тях и / или техните настройки спести лиценз за употреба трябва Designer добавка способност. Това е "защита" конфигурацията на съществуващите матрици, които могат да бъдат споделяни от много потребители. Въпреки това, без да се използва архитект дизайнер добавка все още може да избере да "Save As" всички нови настройки на нов Matrix. И разбира се всички потребителски лицензи могат да избират "да изхвърли" всички промени в съществуващ Matrix. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

1. Изберете Insert | Матрица.

2. В rchitecturд>падащо изберете архитектура, която съдържа елементите и връзките, които искате да видите.

3. В <ИзточникВъведете>падащо изберете типа на компонент, който искате да имате, за случаите, посочени като "редове' проби отлявона матрицата.

4. В <МивкаВъведете>падащо изберете типа на компонент, който искате да имате, за случаите, посочени като "колони' в горнатана матрицата.

5. В падащо там са основно два "режима" на матрицата можете да определите ...

Връзки "Директни" матрици

6. Просто еновоизбран една (1) или по- Връзка видове от дясната страна на менюто, което се появява, ако искате да видите в "клетки" на матрицата, акоп изричнасъществува връзка от Вертикален/ "ред"Компонент на матрицата на Хоризонтален/ "колона"Компонент на матрицата.

Забележка

Само връзки с източника край, закрепен към Вертикален/ "ред"Компонентен и мивка, прикрепен към Хоризонтален/ "колона"Компонент ще бъде показано. Превключете Източник и Мивкатипа на компонент селекции, за да видите връзките в обратната посока.

7. Матрицата се попълва с "X" в клетките (или стойността на имота - виж забележката по-долу) ако има връзка от Вертикален/ "ред "компонент на матрицата на Хоризонтален/ "колона"Компонент на матрицата.

Забележка

За по-големи матрици само максимум 100 редове или колони (включително сринаха редове / колони) ще бъде показан по време, както се вижда от "R" и показателите "С" в горния ляв удар с глава на клетката съответно. За да видите допълнителни редове използват лентите за превъртане. По всяко време можете да щракнете два пъти върху Вертикален/ "ред' или HorizontАл / "колона' компонент рубрики и скочи досъответните компоненти в прозореца на Explorer.Родителите на вертикалната/ "ред' и Хоризонтален/ "колона' компонентите са също евентуално показани като позиция редове / колони със сива челното заглавие. Когато се срина (с еднократно щракване на позиция клетката), ако децата прикачени файлове съществували тогава "Х", евентуално ще се показва, ако са били приложени всички деца или "О", евентуално ще се показва, ако само някои от децата са били прикрепени. Клетките могат да бъдат оцветен според стойността на имота на връзките, като щракнете върху Настройки "зъбно колело" в горния десен ъгъл на лентата с инструменти на матрица и избор Цветови настройки ... и след това бутона Edit и изберете Цветът от клеймо или Colour Чрез Property вариант и избор на собственост, диапазон от стойности на Min и Max и избират цветове, обаче, само Списък, Integer, Decimal, Boolean или Date / Time тип данни свойства ще оцветят. Ако се срина на клетката ще бъде оцветен в зависимост от средната стойност собственост на връзките. Вместо "Х", стойността на имотите за клетките могат да бъдат показана като щракнете върху Настройки "зъбно колело" в горния десен ъгъл на лентата с инструменти на матрица и изберете Покажи Settings стойност ... и след това бутона Edit и изберете опцията Show собственост и избора на имот.

Директни връзки матрица показва сървърите, където Заявленията се хостват с оцветяване и един имот се показват вместо родово "Х"

- ИЛИ -

"Непреки" връзки матрици

6. Sновоизбранпоследователност на Връзка видове и видове съставниот дясната и лявата страна на менюто, което се появява, ако искате да видите в "клетки" на матрицата, акоп непряк път на свързани компонентисъществува от Вертикален/ "ред"Компонент на матрицата на Хоризонтален/ "колона"Компонент на матрицата.

Забележка

Всеки валиден път, който включва елементите, избрани в менюто път wболен бъдат показанинезависимо от посоката на основните връзки, обаче, когато се избира пътя на първо и последните елементи трябва да бъде избран типове връзки. Освен това, поръчка на елементите, които са избрани е показано с числения префиксв квадрат ("[]") скоби и даден тип могат да бъдат включени mutliple пътипо пътя (както е посочено от цифров код). Последователен избор на вида съставни или типове връзки се тълкува като 'ИЛИ'път и йерархията на приложените компоненти могат евентуално да бъдат включени чрез проверка на "Също така търси за свързване родители / деца"Квадратче. Превключете Източник и Мивкатипа на компонент селекции, за да видите пътеки в обратна посока.

7. Матрицата се попълва спът / събиране на компонентив клетките, ако е налице път от Вертикален/ "ред "компонент на матрицата на Хоризонтален/ "колона"Компонент на матрицата.

Забележка

За по-големи матрици само максимум 100 редове или колони (включително сринаха редове / колони) ще бъде показан по време, както се вижда от "R" и показателите "С" в горния ляв удар с глава на клетката съответно. За да видите допълнителни редове използват лентите за превъртане. По всяко време можете да щракнете два пъти върху Вертикален/ "ред' или HorizontАл / "колона' компонент рубрики и скочи досъответните компоненти в прозореца на Explorer.Родителите на вертикалната/ "ред' и Хоризонтален/ "колона' компонентите са също евентуално показани като позиция редове / колони със сива челното заглавие. Когато се срина (с еднократно щракване на позиция клетката), ако всички деца пътеки са съществували тогава "Х", евентуално ще се показва, ако са били приложени всички деца или "О", евентуално ще се показва, ако само някои от децата имаше пътеки. Компонентите на косвените пътя могат да бъдат оцветен според стойността на имота на компонентите, като щракнете върху Настройки "зъбно колело" в горния десен ъгъл на лентата с инструменти на матрица и избор Цветови настройки ... и след това бутона Edit и изберете Цветът от клеймо или Colour Чрез Property вариант и избор на собственост, диапазон от стойности на Min и Max и избират цветове, обаче, само Списък, Integer, Decimal, Boolean или Date / Time тип данни свойства ще оцветят. Стойността на имотите за компонентите на косвените пътя могат да бъдат показана като щракнете върху Настройки "зъбно колело" в горния десен ъгъл на лентата с инструменти на матрица и изберете Покажи Settings стойност ... и след това бутона Edit и изберете опцията Show собственост и избора на имот.

Непряко връзки матрица показва приложенията, които се изпълняват на дадена услуга от катедра

Да се филтъроглед Matrix в ABACUS

1. Уверете се, че имате нов Изглед Matrix отворен.

2. Кликнете върху Филтриране на оси "фуния" в горния десен ъгъл на лентата с инструменти на матрица.

3. На Източника и / или разделите Мивка добавете име, Имоти, Описание, Йерархия или стандартни филтри, като щракнете върху бутона Add, избора на имот, ако е необходимо, и щракване Добре, Изберете съответните опциите в ключови думи / артикули, панел, използващи логика / синтаксис, както е описано в бележката по-долу. Визуализация панел ще се актуализира автоматично да покаже резултатите от текущия набор от филтри.

Забележка

За Клеймо, Йерархия Path, Име или Описаниефилтри или Текст, Integer, Decimal, Булева или Време за срещафилтри собственост съвпадение се извършва така, сякаш "*" уайлд карти се прилагат автоматично, преди и след всяко низови стойности, така че на запис на "котка" (без кавичките) ще включва редове с "Бобкотка','коткажена "или" прилакоткайон "и т.н. Multiple /" или "стойности могат да бъдат вписани нови линии, използващи Ctrl + Enter, За Цяло число и Десетичен филтри собственост "и" логика могат да бъдат включени като се използва "&"(Без кавичките) и по-голяма от / по-малко от т.н. логика могат да бъдат включени посредством"> =','>','<' и '<="(Без кавичките), например '> = 50000 & <90000 ". Non-празни оценяват редове могат да бъдат включени, като въведете "(Non-Заготовки)"(Без кавичките) и празни оценяват редове могат да бъдат включени, като въведете"(Заготовки)"(Без кавичките). За Стандарти или Списък имот филтри The "(Select All)" квадратчето ще даде възможност на всички останали квадратчетата, които са в сила, включително всички налични елементи. The "(Non-Заготовки)" квадратчето ще включва всички елементи, които не са празни имоти ценен. The "(Заготовки)" квадратчето ще включва всяко празно имот оценяват елементи. И махнете отметката някакви конкретни ценен отметки автоматично ще избирай на "(Select All)" и "(не-Заготовки)" квадратчетата за съгласуваност. И накрая, всички филтри са с дело подразбиране нечувствителен така "котка" (без кавичките) ще включва елементи с "котка", "Cat" или "CAT" и т.н. За малки и големи букви съвпадение, въведете "(Case)"(Без кавичките) преди низ напр "(Case) Cat" (без кавичките) ще включва само елементи с "Cat" в тях.

За да се пренесат при използване оглед Matrix в ABACUS

Забележка

Можете да добавите / премахнете връзки, където един единствен тип връзка е била използвана за Пътя, описан по-горе.

1. Да се добавите връзкаот избрания тип между Вертикален/ "ред"Компонент и Хоризонтален/ "колона"Компонент на матрицата, когато" вече не съществува X '(или показана стойността на имота - виж забележката по-горе), Щракнете двукратно върху клетката. "Х" трябва да се появи (или стойността на имота - виж забележката по-горе) и връзка ще бъде създаден най-високо ниво на събиране на Connections за избрания архитектура.

Забележка

Името на връзката ще бъде връзка тип име по настройката за типа връзка на матрицата и ако стойността на имота се показва вместо "Х" стойността по подразбиране на имота ще бъдат показани.

2. Да се редактирате показана стойността на имотана връзката между a Вертикален/ "ред"Компонент и Хоризонтален/ "колона"Компонент на матрицата, Щракнете двукратно върху клетката, или щракнете с десния бутон на клетката и изберете Edit Value ... и редактирате стойността в диалоговия прозорец Промяна Value.

3. Да се Премахване на връзкаот избрания тип между Вертикален/ "ред"Компонент и Хоризонтален/ "колона"Компонент на матрицата, когато" вече съществува X '(или показана стойността на имота - виж забележката по-горе), дяснокликнете на клеткатаи изберете Disconnect, The X трябва да изчезне и връзката ще бъде изтрит от проекта.

Да запазя / Запази като aИзглед Matrix

Забележка

Докато всички участници Архитект могат да създават Матрици за тях и / или техните настройки спести лиценз за употреба трябва Designer добавка способност. Това е "защита" конфигурацията на съществуващите матрици, които могат да бъдат споделяни от много потребители. Въпреки това, без да се използва архитект дизайнер добавка все още може да избере да "Save As" всички нови настройки на нов Matrix. И разбира се всички потребителски лицензи могат да избират "да изхвърли" всички промени в съществуващ Matrix. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда Дизайнер добавка способност.И не забравяйте, това е само на настройките на Матрицата, всички редакции, направени до данните в Матрицата се отразяват незабавно хранилището, независимо.

1. Уверете се, че имате нов Изглед Matrix отворени сте направили необходимите промени.

2. В Изглед Matrixлентата с инструменти кликнете върху най-левия Save Матрицабутона, за да запишете Изглед Matrix и всякакви промени във форматирането.

Забележка

Ако не разполагате с бутона Save в лентата с инструменти на оглед Matrix тогава не е нужно Проектанта добавка и вие сте само в състояние да Запази катовсички настройки се променя на нова матрица, когато отидете да затворите съществуващия матрицата.

3. Ако на МатрицаИмедиалогов прозорец, който се появява (поради е нова матрица) въведете име за матрицаи натиснете Добре.

Да се износ за матричен MS Excel

1. Уверете се, че имате Изглед Matrix отворен.

2. Щракнете върху Експорт в Excelлента с инструменти бутон.

3. Изберете име на файл, за да спаси матрица MS Excel като. Кликнете Save.

Забележка

По подразбиране името на файла изнасяния MS Excel матрицата ще бъде името на Matrix суфикс с наименованието на архитектурата в скоби, напр "Заявленията хоствани на сървъри (2014 Жилищна) .xlsx". Можете да промените някоя от това, включително дали форматът на файла е да бъде .xlsx или .xls.

Форматиране Matrixсе изнася по подразбиране, обаче, за големи матрици това може да доведе до износа е доста бавен. Съответно, в Tools | Опции ...Оттогава на Матрицараздела,вие сте в състояние да се намали количеството на форматиране, което се изнася, както е показано в раздела Matrix-долу, като по този начин ускоряване на износа.

Matrix износ опции

4. Показва се Export Завършен диалоговия. Кликнете Добре.

Изнесени в матрица MS Excel

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Запълването на архитектура от Visio | Запълването на архитектура от Excel


Населяващи Diagrams

Navigation: Запълването на архитектурата> Използване Рисунки>

Населяващи Diagrams

Изпратете коментари по тази тема.

Рисунки в ABACUS са повече от просто произволни представителства. Те са персонализирани гледка към архитектурата, форматирана и подредени да покаже специално значение.

Инструментът Drawing налага йерархичната структура на архитектурата, така че компонентите са визуално вложени в рамките на други компоненти - ефективно дава "поглед отгоре" на елементите. След като компонент или свързване е определено в архитектурата, тя може да се използва всякакъв брой различни схеми. Важно е, че инструментът за чертане е тясно свързана с архитектурния модел, така че промените направени в нито една винаги са отразени в другата.

Инструментът работи чрез свързване със специфични форми и начини на свързване на компонентите, определени в раздел Видове на архитектурата. Тези асоциации варират в зависимост от вида на диаграма се изготвя, и е възможно един вид на компонент (или връзка) може да има различни изображения на различни схеми, в зависимост от контекста.

За да се създаде връзка между форма и компонент или Вид връзка

1. Уверете се, че имате нов или съществуващ диаграма отворена .

2. Максимизиране на заявлението ABACUS, и конфигурирате пропорциите на прозорците както вие желаете.

3. Изберете Таб Shapesили Таб Connectors в прозореца на шаблон.

4. В Типклон на Explorer, намерете компонент или типа връзка, която искате да асоциирате с форма или съединител.

5. Изберете избрания тип елемент от дървото, което го плъзнете към раздела Shapes или раздела конектори, и го пуснете върху формата или съединителябихте искали да използвате.

Забележка

Можете да проверите сдружение сте създали чрез избиране на компоненти или раздела Connections в прозореца на шаблони, които показват, свързани в момента елементи.

За добавяне на нови форми, за да си диаграми / библиотека

1. Създаване на MS Visio диаграми с формите, които искате да добавите към вашата схема и внасят диаграмата MS Visio .

Бакшиш

Важно е какъв размер ще е господар формата на MS Visio, защото платното ABACUS е оразмерено в пиксели и само на милиметри единици в MS Visio съединяващи малки елементи на пиксела за 4 пиксела до съотношение 1 милиметър. Освен това, по подразбиране ABACUS формите на обикновено са 60 пиксела висока, така че се превежда до 15 милиметра в MS Visio. Значение на препоръчително майстор размер на формата в MS Visioе 25 мм от 15 мм високатъй като това ще означава 100 пиксела широчина от 60 пиксела с високо съдържание на ABACUS.

Бакшиш

Ако искате да имате малко "икона" в горния ляв ъгъл на формата след това можете просто да се създаде "икона" в майсторския MS Visio форма, използвайки палитрата на MS Visio Drawing Tool (имайте предвид, че само прости линии, окръжности и правоъгълници са подкрепени и разложено / растерни форми, по-специално, не се поддържат). Освен това, ако искате да бъде иконата фиксиран в размер / скалав рамките на формата в ABACUS след това можете да група на "иконата" в майсторския MS Visio форма, като изберете всички елементи, щракнете с десния бутон един елемент, като изберете Shape | Група, след щракване с десния бутон на групирани форма и избор на данните | Оформете Data ..., избор Да в диалоговия прозорец, който се появява и след добавяне на терен с Знака настроен на LockScale(обърнете внимание на главни букви "L" и "S"), тип настроен на Булева и на стойността, определена да бъде ВЯРНО (имайте предвид, че всичко е с главни букви).

Бакшиш

Ако искате да имате една част от формата замразени от мащабиране хоризонтално или вертикално (както е характерно с "swimlane" форма), след това можете да щракнете с десния бутон на частта (ите) на господаря MS Visio формата, която искате замразени от мащабиране и изберете данните | Оформете Data ..., избор Да в диалоговия прозорец, който се появява и след добавяне на терен с Знака настроен на LockXScale или LockYScale (обърнете внимание на главни букви "L" и "S"), тип настроен на Булева и на стойността, определена да бъде ВЯРНО (имайте предвид, че всичко е с главни букви), за заключени хоризонтално или вертикално мащабиране съответно.

Бакшиш

За да се даде възможност на оцветяването на формата в ABACUS след вносител, а не формата винаги е фиксиран цвят е препоръчително да се направи майстор MS Visio формата на запълване прозрачен и след това да използвате вградения в способността ABACUS да цвят фон форма е. Това работи само с правоъгълник или почти правоъгълник (напр заоблени правоъгълници) форми, както и цялата правоъгълна фона ще бъде оцветена.

2. Отворете съответната схема и изберете Таб Componentsв прозореца на шаблон.

3. За всяка нова форма, която искате да се предоставя на други диаграми Кликнете с десния бутонформата и Select Добави в Shapes Library, Това ще направи формата на разположение в раздела Shapes в прозореца на шаблон.

4. Сътрудник на съответния тип компонент с новата форма от библиотеката Shapes според стъпките, описани по-горе.

Забележка

Само прост и "вектор-базиран" форми се поддържат в ABACUS в момента, т.е. растерни изображения не се поддържат. Въпреки това, инструменти като Vector Меджик ( www.vectormagic.com ) Са на разположение, които лесно ще конвертирате растерни изображения във векторни форми (т.е. SVG формат), които могат да бъдат открити в MS Visio и следователно, използвани в ABACUS според инструкциите по-горе.

ДобавянетоКомпоненти и Connections

Инструментът ви позволява да Drawing добави съществуващите компоненти и връзки от хранилището или създаване на нови компоненти и връзки, както е в момента на създаване на диаграми. Като компоненти и връзки са създадени в диаграми, те се прибавят едновременно в хранилище, Има три препоръчва начини за добавяне на компоненти на диаграмаи три препоръчва начини за добавяне на връзки към диаграма:

За да се създаде напълно нов компонент или връзка на диаграмаот шаблона

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Изберете Елементи или Connectionsраздел в прозореца на шаблон, за да видите свързаните форми. Само тези форми могат да бъдат използвани за създаване на нови образци на елементи.

3. Щракнете и плъзнетеедин от най-добрите, свързани фигури върху платното за рисуване. Новият елемент ще се появи на платното и в изследовател дървото.

4. Започнете да пишетеиме за нов елемент в диалоговия прозорец и всички съществуващи елементи, които са съчетани са предложени и могат да бъдат избрани, а не добавяне на нов елемент в архитектурата.

5. Кликнете Добре.

6. Ако една форма отпадна върху съществуващ компонент, след това тя или ще се превърне в дете на този компонент (ако формата дойде от Елементираздела), или ще бъде приложен към този компонент (ако формата дойде от Connectionsтаб).

Забележка

Понякога е необходимо да се коригира нов компонент или връзката в друго населено място в архитектурния йерархия с помощта на изследовател.

За да се постави един съществуващ компонент или връзката от хранилище върху диаграма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Бъдете сигурни, че имате и инструмента за чертане и Explorer прозорци Видима.

3. В Explorer, намерете компонент или Връзка(елемент), който искате да добавите към диаграмата.

4. Щракнете и плъзнетеизбрания елемент върху диаграмата. A форма, представляваща елемент ще се появи на платното.

Забележка

Ако видът на избрания елемент вече е свързан с формата, съответната форма ще се появи на платното. Ако, обаче, не е определена асоциация за конкретния елемент, форма по подразбиране (правоъгълник) ще се появи на платното, освен ако Привеждане в изпълнение на диаграма Гледни точки опция е в този случай няма да бъдат добавени под формата на диаграма.

Бакшиш

Когато съставна част се поставя на диаграма, която е свързана с друг компонент вече на диаграмата, инструментът за чертане ще запита, ако искате да покаже връзката (ите) между тях. Също така, ако има някакви деца на компонента на инструмента за чертане ще запита, ако бихте искали да се включат децата, в рекурсивен начин.

Да се създаване на връзка между 2 компоненти или свързан компонент на диаграма, използвайки динамичен конектор

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Кръжа над компонент на диаграмата, която искате да се свържете с друг компонент и ще забележите 2 икони се показват извън горния десен ъгъл на границата на формата, както е показано по-долу. Забележка: Горният иконата е за създаване на връзка, където кръжаха компонент е да бъде източник, долната иконата е за създаване на връзка, където кръжаха компонент е да бъде мивката.

3. Ход курсора върху желаната икона и щракнете и плъзнетеиконата до над или през друг компонент или свободно пространство на платното, както е показано по-долу.

4. За да се свържете към съществуващ компонент избере най- Прикрепете към ...елемент в падащото меню и ако е необходимо, за да разглеждате подменюто да изберете от наличните видове свързване.

- или -

4. За да създадете свързан компонент е избрал New ...елементи в падащото меню и ако е необходимо, за да разглеждате подменюто да изберат една от наличните видове свързване, както е показано по-долу. Започнете да пишетеиме за нов елемент в диалоговия прозорец и всички съществуващи елементи, които са съчетани са предложени и могат да бъдат избрани, а не добавяне на нов елемент в архитектурата.

Забележка

Наличието на елементи в менюто поп-нагоре и подменю се регулира от ограничения в мета-модел.Това е само валиден източник или потъват съставни типове както се определя от ограничения за връзка ще бъде представен като отдават на ... и опциите, New ... меню.

Да се повторното отворите диалоговия прозорец за избор на елемент и поставете съществуващите компоненти или връзки от хранилището на диаграма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Кликнете на Open Selection Elementбутон в лентата с инструменти Диаграма. Забележка: прозорец за избор на елемент Ще се отвори с последното състояние на всички филтри спасени.

3. Изберете някоя допълнителното съдържание, което е желателно да се добави към диаграмата и кликнете Добре, Забележка: новото съдържание ще бъдат добавени към свободно пространство на платното, както и схемата може да бъде впоследствие изложи отново чрез Layout Диаграмабутон в лентата с инструменти Диаграма.

Използването FreeформаShapes

Често е желателно да се създаде визуални елементи в схема за чисто естетични причини. Тези елементи могат да помогнат за подобряване на оформлението и външния вид на диаграма, но те не трябва стриктно архитектурно значение. Инструментът Drawing позволява използването на свободна форма фигури, за да се осигури изготвянето гъвкавост.

За да добавите свободна форма форма на диаграма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Изберете Shapes или Съединителираздел в прозореца на шаблон.

3. Щракнете и плъзнетеедин от най-добрите форми или конекторите върху платното за рисуване. Новият елемент ще се появи на платното - но неизследовател в дървото.

Забележка

Freeform форми са "не-свързани" форми, като те нямат връзка с всеки конкретен компонент или връзка в архитектурния модел.

Да се показване на информация в хранилището свободна форма формае надиаграма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Кликнете с десния бутонна свободна форма Формата и Select Анотация | Показ.

3. Изберете да се показва или Диаграма Име, Диаграма Описание, Диаграма на имота, Гледна точка Име или Архитектура Име.

Забележка

Текстът в свободна форма ще се актуализира автоматично, тъй като основните хранилища промените данни.По този начин може да се създаде схема "заглавието блок" за, а след това лесно да се копира целия, диаграми.

Използването Плаващи Shapes

Плаващи форми са по същество друг начин да представляват компоненти в диаграма. Помислете за една организация с ключови подразделения: CEO, маркетинг, продажби и развитие.

Tree View

Тези отделения могат да бъдат визуално представени в слоеста начин:

Layered View

Или могат да бъдат визуално представени в шахматно / Плаваща начин да покаже йерархия:

Залитна / Плаващ Изглед

Последният представяне използва понятието плаващи форми.

За да се превърне форма слоеста компонент в плаваща форма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Изберете компонентвъв вашата диаграма, която искате да представляват като плаващ форма или асоциирана форма в Елементираздел на прозореца на шаблона, който искате всички инстанции като плаващи форми.

3. Щракнете с десния бутон на формата и изберете Float Component от контекстното меню, което се появява. Обърнете внимание на диамант изпратена връзкаот основния компонент (и) на плаващия компонент (и).

4. Щракнете и плъзнетекомпонента на желаното място. Когато плаващкомпонент е избран тя ще има един син контур.

За да се превърне форма плаващ компонент в слоеста форма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Изберете компонентвъв вашата диаграма, която в момента се показва като плаваща форма или асоциирана форма в Елементираздел на прозореца на шаблона, който искате всички инстанции като пластове форми.

3. Щракнете и плъзнетеплаващия компонент (и), обратно на родителя (ите) (в зависимост от диамант изпратена връзка). Забележка: Ако не направите това, тогава когато конвертирате компонент (и), за да се върне на пластове йерархията на вашия модел могат да бъдат засегнати.

4. Щракнете с десния бутон на формата и не избирай Float Component от контекстното меню, което се появява. Имайте предвид, че диамант изпратена връзкаот основния компонент (и) на плаващия компонент (и) ще изчезне.

Реплики

Инструментът ви позволява да Drawing добавете същия компонент на диаграма няколко пъти с всеки допълнителен визуален например на компонента на схемата по-долу копие. Това е особено полезно за диаграми където компонент има голям брой връзки, свързани с него, и е за предпочитане да се покаже компонент на различни места по-близо до началото на всяка от връзките, или за схеми, където един към много отношения от компонент е за предпочитане да се използва покаже плаващия функцията (описано по-горе) с компонент на различни места на върха на "много" компоненти се свързани.

Забележка

Може да придават / отделят връзки към / от първоначалния модел на компонента на диаграма (както винаги), но също така и да е от копия, обаче, когато съединения се добавят автоматично диаграма те са закачени, и на първо място от компонента на диаграмата по подразбиране.

Забележка

Реплики могат да се слеят един с друг, като десния бутон на мишката и плъзнетеслед това изберете Обединяване на РепликиОбаче, сливане реплика с различен компонент ще доведе до други копия изчезват от диаграмата.

Забележка

Не съществува визуална разлика между първоначалната инстанция на компонент на диаграма, както и всички копия. Освен това десния бутон на мишката, за първоначалния компонент в диаграма и всяко копие е идентичен, с например Покажи в ExplorerПриемате ли да същия компонент в Tree View на хранилището (известен още като модела). Въпреки това, щракнете с десния бутон на компонента в Tree View на хранилището и избор Отидете ви сърфиране в схема с реплики винаги ще ви отведе до "най-старият" модел на компонента на диаграмата. Обикновено това ще бъде оригиналния модел, който е добавен в диаграмата, но ако това оригиналния модел впоследствие е била изтрита или се слива с една реплика след Go To ще скочи до най-старият от останалите копия, които са били добавени.

Да се добави реплика към диаграма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Щракнете с десния бутон на съществуващ компонент на диаграмата и изберете Създайте Replica.А копие на избрания компонент ще бъде създаден надясно от първоначалното компонент.

- ИЛИ -

Изберете съществуващ компонент върху диаграмата и натиснете Ctrl + Cили щракнете с десния бутон на съществуващ компонент на диаграмата и изберете копие, Сега щракнете с десния бутон на местоположението на диаграмата, която искате реплика и изберете Поставете като Replica, Забележка: С натискането на Ctrl + V (или щракване с десния бутон и изберете Paste) ще се създаде копие на оригиналния компонент НЕ реплика.

- ИЛИ -

Щракнете и плъзнетекомпонент от Tree View на хранилището (известен още като модела) върху диаграма, където вече съществува компонента.

Конфигуриране на връзката Капачки / Завършва

Инструментът ви позволява да Drawing определен символ, използван в краищата на свързващите линии или до определен символ или символ зависи от един имот на самата връзка.Това е особено полезно за схеми, където се изисква по посока на връзка за да се покаже, или за диаграми където Броят на елементите на връзката (или по посока) се съдържа в собственост на самата връзка, напр "One-към-много хора" срещу "много-към-много хора" (или "Source да потънат" срещу "Sink към източник").

Да се конфигурирате свързване капачки / завършва на диаграма

1. Уверете се, че имате нов или съществуващ диаграма отворена.

2. Изберете Свържетейонираздел в прозореца на шаблон.

3. Right-слижа един от свързана типове връзки и изберете Конфигуриране Caps ....

4. За фиксирана връзка капачка / прекратяване или при източника или потъва край на връзката се уверете, че съответните Неподвижен радио бутон е избран и след това изберете крайната връзка символа от падащото, напр "Arrow Head" или "Diamond".

- ИЛИ -

За имот, базирани връзка капачка / прекратяване или при източника или потъва край на връзката се уверете, че съответните Използването на имотае избран радио бутона, след това кликнете на "..." бутона и изберете необходимата имота и след това в непосредствена близост до всеки край връзка символ въведете стойностите на имотите, за които специфичната символ връзка трябва да бъде показано.

Забележка

Множество собственост стойности за даден краен символ връзка може да се впише, разделени със запетая.Например диалога по-долу показва, че ако "Данни | Кардиналност "имущество е на стойност" One-към-много "и след това на изходния край на връзката ще има две линия инсулти през него и мивка края на връзката ще има един ред инсулт през него и след това фен-от две Онлайн инсулти в края.

Configure Чушка диалоговия

Вижте също

Инструментът Drawing | Запълването на архитектурата | Анализ Вашата архитектура


Запълването на архитектурата

Navigation: Запълването на архитектурата>

Запълването на архитектурата

Изпратете коментари по тази тема.

В процеса на изграждане на модела на вашата архитектура е известен като населяване, След като сте открили вашата архитектура и идентифицирани вашите изисквания, готови ли сте да моделирате вашата архитектура в ABACUS.

По време на населението, ще влязат всички подробности, които познавате за вашата архитектура и какво се изисква от него.

За да се пренесат си архитектура

1. Уверете се, че имате ABACUS отворен файл , Една Показва изследовател И на архитектура добавя .

2. Ръчно пренесат компонентите на по-високо ниво и връзките на вашата архитектура. Обикновено това ще бъде най-абстрактни елементи и връзки.

- или -

2. Графично пренесат компонентите и връзките, които бихте искали виж представени схематично, като се използва Рисуване Tool .

Може би ще искате да

3. Запълни използвайки Каталози - Можете да преглеждате и компоненти и връзки в една проста таблична начин.

4. Запълни използвайки Матрици - Можете да разглеждате и редактирате връзките между компонентите в една проста таблична начин.

5. Запълни от Microsoft Access - Можете да импортирате архитектура от и износ за Microsoft Access.

6. Запълни от Microsoft Visio - Можете да импортирате архитектура от и износ за Microsoft Visio.

7. Запълни от Microsoft Excel - Можете да импортирате архитектура от и износ за Microsoft Excel.

8. Запълни от Microsoft SharePoint - Можете да импортирате архитектура от и износ за Microsoft SQL Server.

9. Запълни от Microsoft SQL Server - Можете да импортирате архитектура от Microsoft SQL Server.

10. Внос от XML - Можете да импортирате архитектура от ABACUS XML фрагмент или ArchiMate Interchange Language XML файл.

Вижте също

Запълването на архитектурата ръчно | Инструментът Drawing | Запълването на архитектура от Microsoft Access | Запълването на архитектура от Microsoft Visio | Запълването на архитектура от Microsoft Excel


Запълването на архитектура от Microsoft Access

Navigation: Запълването на архитектурата> Запълването от продукти на Майкрософт>

Запълването на архитектура от Microsoft Access

Изпратете коментари по тази тема.

Можете да експортирате архитектура за Microsoft Access да изпълнява общи команди изчисления, манипулации или доклади на вашата архитектура. След това можете да импортирате архитектурата обратно в ABACUS.

Забележка

The Open от Access / Export да Database функция изисква Microsoft Access 2000или по-нова е инсталирана на компютъра.

За да експортирате архитектура Microsoft Access

1. Уверете се, че имате ABACUS файл отвори ИзследователПоказва, и архитектурадобавя.

2. Изберете File | Износ | За да Database.

3. Обърнете внимание на диалога за предупреждение, както е описано по-горе и щракнете върху Да, за да продължите.

4. Изберете място и име на файла с базата данни.

За да импортирате манипулираната архитектура в ABACUS

1. Уверете се, че имате ABACUS отворена.

2. Изберете File | New и изберете От Accessот диалоговия прозорец, който се появява и кликнете OK.

3. Преглед за търсене на файлове на базата данни, която искате да импортирате.

ABACUS "Schema MS Access Database

ABACUS има в сърцето си нап онтология / мета-мета-модел, съставен от компоненти, Connections и ограничения. Този подход "CCC" е получен от различни стандартни подходи, разработени от 1960-те години насам завършва с международния стандарт IEEE 1471, които основатели Avolution допринесоха да. Прилагат се следните примитиви;

1. ABACUS съдържа Библиотеки на Стандарти(или стандарти), Компонент и Типове връзки, Ограничения, Гледни точки, Templates (или Patterns) и много Архитектури.

2. Стандарти, Видове и Гледни точки можеда бъде логически Групираниза удобство.

3. Архитектури може да съдържамного потомък Архитектури(или еволюции).

4. Всеки Архитектура съдържамного Елементи и Connectionsна определен Видовеи различни Прегледи.

5. Елементи и Connections може да бъде разлагав Под-Components и Под-Connections.

6. Всеки Компоненте приложен къмпроизволен брой Connectionsно всеки Връзкаможе да бъде само приложен къммаксимум два Елементи.

7. Елементи и Connectionsмога имам Стандартис Имотикато информация, производителност, надеждност, Cost т.н.

8. Архитектури, Елементи и Connectionsмога имамспецифичен Имотикато информация, производителност, надеждност, Cost т.н.

9. Ограничениямога съществува между Елементи или Connections или срещу Имоти.

10. Templatesса стандартни състави Компонент и Типове връзки.

11. Гледни точкиса стандартни сдружения на Компонент и Типове връзкида означения.

12. Прегледиса визуално представяне на Елементи и Connections.

Следната MS Access Entity Връзки Диаграма (ERD) документите за сърцевинаАрхитектури, Еволюции, Видове Компонент / връзка (и групи), Components / Connections и Възложени концепции Компонент / Connection.

Основна схема на база данни за

Забележка

Референтен почтеност не е изпълнена за връзката между масата на компоненти и таблицата на Connections (за "запор" между дадена Source или Sink Component и Connection). Това е така, защото връзка може да съществува без компоненти приспособления. Можехме да добавя "запор" на маса, но в интерес на простотата реши срещу това. Разбира се, това означава, че всяка редакция на документи за самоличност на компоненти или изтриване на Компонент редове всички заедно ще доведе до неверни данни. ABACUS ще се справят с всяка неточност при внос от игнориране на неверни данни.

Следната MS Access ERD документите за Имотиконцепции за архитектури, Видове Компонент / връзка и части / Connections.

Имоти схема на база данни

Следната MS Access ERD документите за Стандартиконцепция за архитектури, Видове Компонент / връзка и части / Connections.Забележка: В таблиците все още използват термина "Изпълнение", както на предишните версии на ABACUS.

Стандарти схема на база данни

Следната MS Access ERD документите за Ограниченияконцепция за Компонент Видове / Connection.

Ограничениясхема на база данни

Следната MS Access ERD документите за Гледни точки концепция за Архитектури.Забележка: В таблиците все още използват термина "TwoDTempl", както на предишните версии на ABACUS.

Гледни точкисхема на база данни

Следната MS Access ERD документите за Каталозиконцепция за Архитектури.

Каталозисхема на база данни

Следната MS Access ERD документите за Матрициконцепция за Архитектури.

Матрицисхема на база данни

Следната MS Access ERD документите за Diagramsконцепция за Архитектури.Забележка: В таблиците все още използват термина "TwoD", както на предишните версии на ABACUS.

Забележка

Типовото / Connection да шаблон форма картографиране и Freeform форма порции от MS Access ERD са с пропуснати за по-голяма яснота.

Diagramsсхема на база данни

Следната MS Access ERD документите за 3D Прегледиконцепция за Архитектури.

3D Прегледисхема на база данни

Следната MS Access ERD документите за Графикиконцепция за Архитектури.

Графикисхема на база данни

Следната MS Access ERD документите за Dashboardsконцепция.

Dashboardsсхема на база данни

ABACUS "MS AccessЗаявки

Заедно с база данни на MS Access няколко полезни заявки, както следва;

· Comps от подпори- Тази заявка съдържа всички компоненти в проекта (от архитектура и вид) и включва всички имоти, като колони. Използвайте този въпрос с филтри / критерии; от типа на компонент и / или архитектура, за да произвеждат "типични" таблици за всеки компонент тип с техните свойства.

· ППБ чрез подпори- Тази заявка изброява всички стандарти, които са в употреба, броят на случаи на стандарта и включва всички имоти, като колони. Използвайте този въпрос като стандарти на стоките.

· Подпори по видове- Този въпрос се изброяват всички съставни свойства и тяхната% завършена от всеки тип компонент като колони. Използвайте този въпрос, за да се определи дали специфични свойства се поддържат.

· Видове на Подпори- Тази заявка са изброени всички видове съставни и включва пълна% от всички имоти, като колони. Използвайте този въпрос, за да се определи дали специфични свойства се поддържат.

· Тип Count- Тази заявка са изброени всички видове съставни и включва броя на събитията от всеки тип в низходящ ред. Използвайте този въпрос да се определи популярността на всеки тип в проекта.

Бележка за работа с Memo полета в MS Access

Компонентите, връзки и Име стандарти полета в таблиците се определят като допълнителни области, за да се даде възможност за неограничен брой символи, както на ABACUS. За съставните елементи и връзките с това се нанасят няколко въпроса, защото те също имат уникален ID поле, указващ, но и за стандартите това причинява някои проблеми, когато се опитват да се присъединят към таблици, защото не можете да се присъедините към мемо полета в MS Access. Освен това, можете да зададете А, където критериите за клауза да се постигне същия ефект, както е показано на Visual Query Builder и съответните SQL откъси под този списък на всички наследените стандарти свойства за всички компоненти в изнасяния проекта ABACUS.

Memo поле "се присъединява към" в Visual Query Builder

ИЗБЕРЕТЕ Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

ОТ Components INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) И (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Реализациите INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

КЪДЕ (((ComponentImplementationLinks.Name) = [Реализациите] [Name]).);

Memo поле "се присъединява към" в SQL

Бележка за автоматично генериране на ABACUS IDs в MS Access

Различни маси ABACUS MS Access изискват уникална дълго число ID, така се осигурява прост метод VB за подпомагане в генерирането на тези. Два метода ResetCounter () и GetNextCounter () се предоставят в рамките на MS Access DB ABACUS "и тяхното използване е както следва; ResetCounter () ще определи тезгяха обратно в 0. GetNextCounter () ще върне следващата тезгяха в последователността.

Методите експлоатират "приумица" на MS Access, че дори ако се обадите на метода на ResetCounter () за всеки ред вложка (т.е. когато изпълнявате функцията GetNextCounter ()), защото функцията ResetCounter () не са изпитали някакви параметри тя просто тече го веднъж и затова не нулира брояча на всеки ред вложка. И също така, защото на една и съща "каприз", което трябва да премине всички стари променлива колона към функцията GetNextCounter (), за да го накараме да работи всеки път.

Има и един трик, за да е в състояние да изпълнява функцията ResetCounter () в една вложка в SQL изявление, защото не можеш просто да го седи там като колона по себе си, като, ако това е въпрос изберете. Препоръчително е да се направи ResetCounter () повикване част на една от другите области, чрез слепване до края, тъй като тя винаги се връща нулев или иначе.

По-долу е типичен SQL използване на методите, които да добавите списък с типовете елементи от таблица / заявка, наречена "Component Type Списък".

INSERT INTOComponentTypes (Id, Име, Описание)

SELECT GetNextCounter ([Component Type List] .name)AS Id, [Component Type List] .name AS име, [Component Type List] .description & ResetCounter ()AS Описание

ОТ[Component Type List];

ABACUS ID поколение / Counter в SQL

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Запълването на архитектура от Visio | Запълването на архитектура от Excel


Запълването на архитектура от Microsoft Excel

Navigation: Запълването на архитектурата> Запълването от продукти на Майкрософт>

Запълването на архитектура от Microsoft Excel

Изпратете коментари по тази тема.

Можете да импортирате вашата архитектура от програма за таблици (.xls или .xlsx файл). Вносителят Excel ви позволява да картографира списъци на компонент и връзки с видове, стандарти, свойства и стандартни свойства, като изберете колоните в електронната таблица, които съдържат съответните данни.Тя обаче е по-напреднала техника от препоръчителен подходза внос от MS Excel, която е направо каталози както е описано тук .

Забележка

The Внос от / Експорт в Excel функция изисква Microsoft Excel 2003или по-нова е инсталирана на компютъра.

Основната функция на вносителя Excel е да ви позволи да се определи файл конфигурация (т.е. йерархичната структура на вашия архитектурен модел). Конфигурационния файл съхранява предварително записан картографиране от даден Excel файл към ABACUS файл. След като е определено, запазения конфигурационния файл се използва по-късно за по-нататъшно импортиране и експортиране на да .xls файлове.

Забележка

Стъпките, показани в разделите по-долу, са специално за потребители, които все още трябва да се определи и спести конфигурационен файл и внасят от ексел за първи път. Трябва да създавате и записвате конфигурационен файл за използване на износа да се отличат функция.

За да импортирате електронни таблици Excel в ABACUS

1. Уверете се, че имате ABACUS отворена.

2. Изберете File | Нов и изберете от Excelот диалоговия прозорец, който се появява и кликнете OK.

Забележка

Ако искате да импортирате в съществуващ проект ABACUS след това или щракнете с десния бутон на Components възел в рамките на архитектурата, или щракнете с десния бутон на отделен компонент в рамките на един Архитектура и след това изберете Import | От Excel.

3. The Внос Excel SpreadsheetЩе се появи прозорец

Внос Excel Spreadsheet Window

4. Щракнете върху Open File Excelикона и разглеждате за Excel файл, който искате да импортирате.

5. Избери Работен листискате да импортирате от падащото меню.

Забележка

След отваряне на файла Excel, можете да използвате Преглед на даннитераздел, за да видите колоните и първите 25 реда от вашата електронна таблица. От тук можете да получите номера на колоната, необходими, за да попълните Елементи и Connectionsраздел.

Можете също така да изберете дали искате или не компоненти в една електронна таблица Excel, за да бъдат внесени с калъф чувствителност. Просто маркирай Внос със случай на чувствителносттавариант (по подразбиране това е винаги отметка) и електронната таблица ще бъдат внесени по съответния начин.

Sample Excel File

Забележка

В този пример, ние ще внасяме прост инфраструктура и архитектура Хората от данните в Excel, показани в горната снимка. Connections ще бъдат направени между "Хората Отговорни" и "Сървъри", че тези хора управляват.

За да се пренесат върху раздела Components

Този раздел е за определяне на типовете елементи и йерархичната структура на конфигурационния файл.

1. Изберете Елементираздел. Преименувайте Set IDс императивни на (нула)стойност

Забележка

Тази функция позволява да се определи напълно различна Комплектиза функционално отделни компоненти. Както е показано на снимката по-долу, може да искате да се разграничат вашите Инфраструктурни компоненти от вашите хора компоненти. Ако има отношения (връзки) между тези отделни набора от компоненти, те могат да бъдат определени съгласно Connectionsраздел. По-късно в този пример, ние ще определи връзки от тип "администрира" между инфраструктурата и народна Комплекти.

Можете също така да изберете дали искате или не, за да добавите най-високо ниво Групировкакомпонент за всички елементи на комплекта. Просто маркирай Група Под Set IDвариант (по подразбиране това е unticked) и електронната таблица ще бъдат внесени по съответния начин.

Присвояване Set ID

2. След Комплектиса дефинирани изберете Определетеискате да се пренесат и разшири, като кликнете относно [+] знак.

3. Изберете Нива на съставките на този Setот разширената списъка.

4. The Компонент Йерархия Задава: Set IDЩе се появи прозорец за това Определете.

Компонент Йерархия и се дават стойности (Set ID: Инфраструктура)

5. Преименувайте Ниво Номерколона с императивни на (нула)стойност.

Забележка

The Ниво Номерколона ви позволява да зададете йерархия на вашите компоненти. Всяко ниво съответства на един слой в рамките на вашата архитектура, при която на първо ниво е най-отгоре родителниво. Например, Level номер "1" съответства на най-горния слой йерархична, Level номер "2" е дете на Level номер "1" и така нататък.

6. Изберете и възлага съответната колона от таблица Excel за всеки Ниво Номеркато го въведете съгласно РСТ Компонент Columnколона.

Забележка

Можете да изберете да се изключат някои редове, които не искат да бъдат представлявани в архитектурата. Това може да са заглавията на колоните, празни редове, и т.н. За да се изключи редове използвайте Редове да Изолирайте:текстово поле в близост до горния десен ъгъл на прозореца. В този пример са изключени ред 1, защото тя съдържа нашите заглавия на колони.

7. Можете да изберете да добавите описания на вашите компоненти от презаписване на (нула)стойност в Описание Column.

Забележка

Това описание е това, което ще се появи в ABACUS съгласно РСТ Общи имотираздел | Описаниеобласт.

8. Ако дадена колона таблица има повече от един компонент на клетка (въвеждани с Alt-Enter или CHAR (10) команда), след това поставете отметка в квадратчето отдолу Отнасяйте Нови Lines като отделни компоненти, Всеки ред ще бъдат внесени като отделни компоненти.

Бакшиш

За да импортирате "матрица" от колекция от колони, където "Х" в дадена "матрица" клетки (клетки B2: D2 казват) предполага, че компонентът, определен от ред (в клетка A2 каже) е свързан към компонента определена от колона "позиция" (в ред 1 Say), може да се използва проста формула. Въвеждане следната формула за всеки ред в колона над матрица клетки (колона F каже); = IF (B2 = "", "", B $ 1 & CHAR (10)) и IF (C2 = "", "", C $ 1 & CHAR (10)) и IF (D2 = "", "", D $ 1 & CHAR (10)). Тогава се създаде комплект за свързване, както е описано по-долу между компонентите, посочени от ред (в колона А се каже) и тези, описани от тази формула (в колона F се каже). Не забравяйте да проверите на Отнасяйте Нови Lines като отделни компонентиопция, когато компонентите от формулата се внасят. За по-напредналите матричен внос, включително позиции с много слоеве от йерархия или клетки с различни стойности, отколкото просто обикновен 'X', моля, свържете се с Подкрепа Avolution .

9. Попълване на останалата част на колоните, както е необходимо.

Забележка

Можете да изберете да получите вида от редовете на колоните, като отбележите в квадратчето съгласно РСТ Вземете Type От Колонаколона и въвеждане на съответната колона от таблица Excel съгласно РСТ Component Type Value или Columnколона. Това ще импортира всички компоненти в тази колона и да ги оставят да вида, определен в колоната. Алтернативно, и както с екрана изстрел по-горе и по-долу, можете да изберете да използвате фиксирана / предварително определен име на тип, като въведете името на вид под митнически Component Type Value или Columnколона и като се уверите в квадратчето е ООН проверява.

Компонент Йерархия и се дават стойности (Set ID: Хората)

Забележка

В този пример искаме да имаме нашите мрежи и хората обединения на ниво 1 на архитектурата. На ниво 2 искаме да имаме нашите сървъри и хората, отговорни за прилагане на тези сървъри. The Елементираздел е попълнен съответно, както е показано на скрийншота горните два. В първия скрийншота по-горе ние сме определено ниво 1 (групиране на мрежата) и ниво 2 (сървър) компонентите за инфраструктура Определете, И на скрийншота непосредствено над сме определили за ниво 1 (хората групиране) и ниво 2 (хора, отговорни) компонентите за народна Определете.

Алтернативно, за ХораSet, вместо да използва колона C като Хората групиране, бихме могли да са използвали Група Под Set IDопция в раздела топ ниво компоненти и след това просто влезе един Хората подниво от Колона D. Това е показано на снимката по-долу.

Компонент Йерархия и се дават стойности, използващи Group Под Set ID опция (Set ID: Хората)

10. След като компонентите са били идентифицирани, изберете ниво на компонента, който искате да се пренесат на свойствата и / или стандартите на и разшири, като кликнете относно [+] знак.

11. Изберете Имоти на компоненти на това нивоили Компонент стандарти на това нивоот експандиран списъка и попълните съответните колони, колкото е необходимо.

Населяващи Components

Забележка

Имоти на компоненти на това нивови позволява да дефинирате имоти за компоненти на избраното ниво. Компонент стандарти на това нивопозволява да се определят стандарти и техните стандартни свойства за компоненти на избраното ниво.

12. Повторете стъпки 2-11докато всички съставни нива са населените за всички дефинирани Комплекти, Използвайте стрелката назад горния десен ъгъл на прозореца, за да навигирате обратно към Комплектикоято определено по-рано.

За да се пренесат върху раздела Връзки

Този раздел е за определяне на типовете свързване и йерархичната структура на конфигурационния файл.

1. Изберете Connectionsраздел. За всеки набор от връзки, което трябва да се идентифицират на компонента Определетече искаш да бъдеш източника и компонента Определетеискате да сте в компонентите на местоназначение.

2. Под Източник Component Set IDвъведете Определетеиме, което съответства на Определетеопределено по-рано в Елементираздел. Под Източник Component Level Номервъведете числото, съответстващо на нивото на компонента, който искате да се свържете към източник на края на връзката.

3. Сега изберете кои компоненти група ще бъде в дестинация края на връзката. Под Дестинация Component Set IDвъведете Определетеиме, което съответства на Определетедефинирани в Елементираздел. Под Дестинация Component Level Номервъведете числото, съответстващо на нивото на компонента, който искате да се свържете към дестинация края на връзката.

Забележка

В този пример ние искаме да се свърже хората, отговорни за администрирането на сървъри до сървърите, които те управляват. Хората, отговорни са били определени по народна Определететъй като нивото на 2 компонента, като същевременно сървърите са били определени по Инфраструктура Определетекато ниво 2 компонента. The Connectionsраздел е попълнен съответно, както е показано на снимката по-долу.

Connections Tab част 1 от 2

4. Ако преминете към правото, ще намерите допълнителни възможности за внос на вашите връзки. Вземете Type От Колона и Connection Type Value или Columnработят по същия начин, както и за Елементираздел.

5. Ако Източник Component Set IDи Източник Component Level Номерса същите като на Дестинация Component Set IDи Дестинация Component Level Номер(например, ако се свързвате същите видове компоненти, като например създаване на връзки от сървърите на други сървъри), тогава трябва да има друга колона в електронната таблица, която съдържа имената на тези сървъри повтарят. В тази ситуация ще се сложи това таблица колона в Дестинация повтарят в колонаколона. Ако в тази колона електронна таблица, която сте въвели повече от един свързан компонент на клетка след това поставете отметка в квадратчето отдолу Отнасяйте Нови Lines като отделни компоненти.

Connections Tab Част 2 от 2

6. След като връзките са идентифицирани изберете връзката, която искате да се пренесат на свойствата и / или стандартите на и разшири, като кликнете относно [+] знак.

7. Изберете Информацията за тези връзки или Стандарти за тези Connectionsот експандиран списъка и попълните съответните колони, колкото е необходимо.

Забележка

Информацията за тези връзкипозволява да се дефинират свойства за избрания връзка групата. Стандарти за тези връзкипозволява да се определят стандарти и техните стандартни свойства за избрания връзка групата.

8. Повторете стъпки 2-7докато са били определени всички групи на свързване.

9. Когато сте готови с определянето групи за връзка, щракнете с завършекбутон и си архитектура ще бъде създаден от внесени файл Excel. Примерът по-горе ще доведе до архитектурата е показано на снимката по-долу.

Sample Architecture Внос от Excel

10. Сега запазете картирани конфигурация във файл, като щракнете относно Save Configurationикона. Вашият запазена конфигурация може да бъде възстановен по-късно, като кликнете относно Отваряне на Configurationикона горния ляв ъгъл на прозореца.

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Запълването на архитектура от Access | Запълването на архитектура от Visio


Запълването на архитектура от Microsoft SharePoint

Navigation: Запълването на архитектурата> Запълването от продукти на Майкрософт>

Запълването на архитектура от Microsoft SharePoint

Изпратете коментари по тази тема.

Можеш синхронизирам Вашата архитектура сMicrosoft Списъци на SharePoint. Синхронизация включва или създаването на нови списъци на SharePoint (и техните колони) от ABACUS видове, техните свойства и приспособления, или определяне на съществуващи списъци на SharePoint (и техните колони) да ABACUS видове, техните свойства и прикачени файлове, след това или изпращане на съдържание от ABACUS да SharePoint или SharePoint да ABACUS.

Забележка

The SharePoint Sync функция изисква a Microsoft SharePoint 2010, 2013 или SharePoint Online Сайтът е достъпна за да се свържете и да се синхронизира с.Докато функцията за SharePoint Sync можете да създавате списъци (с колони) за създаване на сайтове на SharePoint от всеки проект ABACUS, Avolution също може да осигури различни шаблони на сайтове SharePoint в подкрепа на стандартните рамки (напр TOGAF, ArchiMate, ITIL и т.н.), така че, моля свържете Подкрепа Avolution ако имате нужда от тази възможност.

Да се създадете нов списък SharePoint и карта на компонент или Вид връзка на ABACUS

1. Уверете се, че имате ABACUS отворена.

2. Изберете Tools | SharePoint Sync.

3. Щракнете върху New Mappingбутон и прозорец за SharePoint Mapping, както е показано по-долу ще се появи.

4. Въведете URL на сайта, потребителско име и парола за сайта на SharePoint и кликнете Свържете.

Забележка

Валидна SharePoint "админ" или профил "сътрудник" е необходимо да се синхронизира от и до SharePoint и акаунт за "читател" ще позволи само синхронизация от SharePoint.

5. Изберете компонент или типа връзка ABACUS да картографира от Select Typeпадащо.

6. Щракнете върху Добави новбутон и след това за всеки компонент или тип връзка аспект ABACUS желаете да съставят карта на съответното поле списъка SharePoint изберете елемент в левия панел и в дясното поле въведете новото име в списъка SharePoint в колоната New List (само първия път) , а след това името на колоната SharePoint в колона Наименование (или да използвате по подразбиране) и кликнете Присвояване всеки път.

Забележка

Като минимум, за да се даде възможност за синхронизация на ABACUS EEID, Архитектура и Име аспекти ще бъдат автоматично преобразувани към SharePoint Брой и две (2) един ред текст (известен още като Text) колони съответно една. Това не може да бъде незададен. Освен това, само някои аспекти ABACUS понастоящем може да бъде съпоставена с някои колони SharePoint и Column Type падащото ще бъде автоматично се настройва на необходимия тип колона SharePoint.А именно;

· Йерархия Path ABACUS "да SharePoint Няколко реда текст (известен още като Note) колони (Забележка: SharePoint един ред текст (известен още като текст) колони поддържат само 255 символа, така че те не са за предпочитане),

· ABACUS "Attached Компоненти за колони SharePoint търсене (Забележка: A картографиране трябва вече да съществува до списък за приложените самите компоненти),

· ABACUS "Текстови и Описание на имоти за SharePoint Няколко реда текст (известен още като Note) колони (Забележка: SharePoint един ред текст (известен още като текст) колони поддържат само 255 символа, така че те не са за предпочитане),

· ABACUS "десетични или Integer свойства на колони SharePoint номер,

· ABACUS "Списък с имоти на колони SharePoint Choice (Забележка: SharePoint не налага стойностите на избор, така типа Списък на данни не е необходимо да се изпълнява в ABACUS),

· ABACUS "Дата / Час свойства на SharePoint Няколко реда текст (известен още като Note) колони (Забележка: SharePoint Дата и колони Час не могат да бъдат използвани като все още дължи на несъвместима помощ SharePoint за часовата зона / настройки за регионализация),

· ABACUS "Булева свойства на SharePoint Да / Не (известен още като булеви) колони.

Associated стандарти сметало елемент не може да бъде съпоставена с SharePoint списък колони като все още.

7. Изберете Създайте Mapping.

Да се създаване на нов картографиране между компонент ABACUS или тип връзка и съществуващ списък SharePoint

1. Уверете се, че имате ABACUS отворена.

2. Изберете Tools | SharePoint Sync.

3. Щракнете върху New Mappingбутон и прозорец за SharePoint Mapping, както е показано по-долу ще се появи.

4. Въведете URL на сайта, потребителско име и парола за сайта на SharePoint и кликнете Свържете.

Забележка

Валидна SharePoint "админ" или профил "сътрудник" е необходимо да се синхронизира от и до SharePoint и акаунт за "читател" ще позволи само синхронизация от SharePoint.

5. Изберете компонент или типа връзка ABACUS да картографира от Select Typeпадащо.

6. Изберете списъка на сайт на SharePoint да картографира от Изберете Списъкпадащо.

7. За всеки компонент или тип връзка аспект ABACUS желаете да картографира към своя списък колона съответния SharePoint изберете елемент в панела отляво и десния панел съответно и кликнете Присвояване.

Забележка

Като минимум, за да се даде възможност за синхронизация на ABACUS EEID, Архитектура и Име аспекти трябва да бъде съпоставена с SharePoint номер едно, а след това за архитектура и име да било един ред текст (известен още като Text) или на няколко реда текст (известен още като Note) колони съответно. Докато това се прави бутона Mapping Създаване няма да бъде включен. Освен това, само някои аспекти ABACUS понастоящем може да бъде съпоставена с някои колони SharePoint.А именно;

· ABACUS "Архитектура аспект на SharePoint един ред текст (известен още като Text) или на няколко реда текст (известен още като Note) колони (това се изисква за съдържанието специфична картографиране, както е описано по-долу),

· Йерархия Path ABACUS "да SharePoint един ред текст (известен още като Text) или на няколко реда текст (известен още като Note) колони (Забележка: SharePoint един ред текст (известен още като Text) колони поддържат само 255 символа така че всички допълнителни персонажи ще бъдат пресечени и следователно се препоръчва да ги конвертирате в текст на няколко реда (известен още като Note) колони в SharePoint преди картографиране),

· ABACUS "Attached Компоненти за колони SharePoint търсене (Забележка: A картографиране трябва вече да съществува до списък за приложените самите компоненти),

· ABACUS "Текстови и Описание на имоти за SharePoint един ред текст (известен още като Text) или на няколко реда текст (известен още като Note) колони (Забележка: SharePoint един ред текст (известен още като Text) колони поддържат само 255 символа така че всички допълнителни персонажи ще бъде орязан и затова се препоръчва да ги конвертирате в текст на няколко реда (известен още като Note) колони в SharePoint преди картографиране),

· ABACUS "десетични или Integer свойства на SharePoint Брой колони (Забележка:. SharePoint Изчислено колони могат да бъдат използвани, но те ще бъдат в състояние само да се синхронизира от SharePoint да ABACUS Опитвайки се да синхронизирате" на "калкулирана колона ще доведе до предупреждение по-долу) ,

· ABACUS "Списък с имоти на колони SharePoint избор,

· ABACUS "Дата / Час свойства на SharePoint Няколко реда текст (известен още като Note) колони (Забележка: SharePoint Дата и колони време не могат да се използват, поради противоречие подкрепа SharePoint за часовата зона / настройки за регионализация),

· ABACUS "Булева свойства на SharePoint Да / Не (известен още като булеви) колони.

Associated стандарти сметало елемент не може да бъде съпоставена с SharePoint списък колони като все още. И валути SharePoint е, човек или група, Hyperlink или Picture, Task Резултат, External Data и успя колони метаданни не може да бъде съпоставена с аспекти ABACUS като все още.

8. Изберете Създайте Mapping.

Да се синхронизирамВашата Microsoft Списък (и) SharePointв ABACUS

1. Уверете се, че имате ABACUS отворена.

2. Изберете Tools | SharePoint Sync.

Забележка

Да се синхронизирате списък на SharePoint сПроект ABACUS нуждае лиценза за употреба на SharePoint Syncдобавка способности. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

3. Изберете съществуващ картографиране SharePoint (или съпоставяне, използващи Ctrl-кликили Избери всичкибутон) от SharePoint Съответствияпанелкакто е показано на снимката на пробата по-горе. Забележка: Тук ние показваме само "Гол (или изискване)" ABACUS типово картиране към списък с SharePoint наречени Цели са избрани.

4. Изберете архитектура (и), които искате да синхронизирате съдържание с от Синхронизиране на съдържание от архитектурипанел, както е показано на скрийншота на пробата по-горе. Забележка: Тук ние показваме само "2015 Край на" архитектура синхронизират.

5. Изберете Sync От SPбутон.

Забележка

Ако пълномощията на сайта SharePoint не "All Saved" са за картографиране (и) за мача после Login да диалоговия SharePoint ще се появи молба за URL на сайта, Потребителско име и / или Парола.Моля, въведете тях. Освен това, синхронизация ще включва всякакви други преобразувания, които са необходими за прикрепени компоненти / справка колони. Всички допълнителни преобразувания, които са включени автоматично ще бъдат показани в диалога по-долу.

6. При успешно синхронизиране диалоговия Резултати на SharePoint Sync ще се появи, както е показано по-долу списък на промените, както и всички предупреждения. Кликнете Добре.

Да се синхронизирате от ABACUS да Вашата Microsoft Списък (и) SharePoint

1. Уверете се, че имате ABACUS отворена.

2. Изберете Tools | SharePoint Sync.

Забележка

Да се синхронизирате списък на SharePoint сПроект ABACUS нуждае лиценза за употреба на SharePoint Syncдобавка способности. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

3. Изберете съществуващ картографиране SharePoint (или съпоставяне, използващи Ctrl-кликили Избери всичкибутон) от SharePoint Съответствияпанелкакто е показано на снимката на пробата по-горе. Забележка: Тук ние показваме само "Гол (или изискване)" ABACUS типово картиране към списък с SharePoint наречени Цели са избрани.

4. Изберете архитектура (и), които искате да синхронизирате съдържание с от Синхронизиране на съдържание от архитектурипанел, както е показано на скрийншота на пробата по-горе. Забележка: Тук ние показваме само "2015 Край на" архитектура синхронизират.

5. Изберете Sync За да SPбутон.

Забележка

Ако пълномощията на сайта SharePoint не "All Saved" са за картографиране (и) за мача после Login да диалоговия SharePoint ще се появи молба за URL на сайта, Потребителско име и / или Парола.Моля, въведете тях. Освен това, синхронизация ще включва всякакви други преобразувания, които са необходими за прикрепени компоненти / справка колони. Всички допълнителни преобразувания, които са включени автоматично ще бъдат показани в диалога по-долу.

6. При успешно синхронизиране диалоговия Резултати на SharePoint Sync ще се появи, както е показано по-долу списък на промените, както и всички предупреждения. Кликнете Добре.

Забележка

ABACUS ще актуализира SharePoint колони с празни стойности, дори и ако "да изиска тази колона съдържа информация" е настроено на Да в SharePoint. Това е така, защото SharePoint не излага тази настройка външно. Ако това е, за да бъде предотвратено това се препоръчва на ABACUS Designer задава Задължително ограничение до True и насилствено за дадения имота използвайки ABACUS " ограничение особеност .

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Запълването на архитектура от Visio | Запълването на архитектура от Excel


Запълването на архитектура от Microsoft SQL Server

Navigation: Запълването на архитектурата> Запълването от продукти на Майкрософт>

Запълването на архитектура от Microsoft SQL Server

Изпратете коментари по тази тема.

Можете да импортирате вашата архитектура от базата данни на Microsoft SQL Server. Имате право на избор просто да импортирате таблиците и взаимоотношения ефективно вносителки само родовото структурата на базата данни или таблиците, редове и взаимоотношения, които ще внасят не само структурата, но данните, както добре.

Забележка

The От SQL функцията Сървър изисква Microsoft SQL Server 2005, 2008 г., 2008 R2, 2012 г. или 2014е инсталирана на компютъра.

За да импортирате вашата база данни Microsoft SQL Server в ABACUS

1. Уверете се, че имате ABACUS отворена.

2. Изберете File | New и изберете От SQL Serverот диалоговия прозорец, който се появява и кликнете OK.

3. В диалоговия прозорец Import сървър SQL, който се появява зададете "ИмеНаМашина" и ценности "SQLINSTANCE" на Connection String променлива и стойността "DBNAME" на променливата Database Име на техните правилни стойности, както е показано на снимката по-долу на пробата.

4. Определете променливата Database Име на на същата стойност, както Първоначално променливата Catalog определен в стъпка по-горе, както е показано на снимката по-долу на пробата.

5. Натиснете бутона на Test Connection и таблиците да внасят част от диалога трябва да бъде населена с наличните таблици на базата данни, както е показано на снимката по-долу на пробата.

6. Изберете таблиците, които искате да импортирате от които поотделно или ги изберете с помощта на всички, None и бутоните Преобръщане на правото на диалоговия прозорец.

Забележка

Само Ключови отношения, които съществуват между таблиците, които сте избрали, ще се внасят чужди.

7. Използване на бутона Import Style радио изберете дали искате да импортирате само таблиците и връзките между тях, или таблици, техните редове и специфичните отношения между редове.

Забележка

Първият вариант внася таблиците като компоненти на "маса" тип и взаимоотношенията между всеки две таблици (от чуждестранните ключовете) се внасят като връзки на "Таблица връзка" вида. Това е класически "ERD" изглед стил на масите на системата. Вторият вариант внася Редове Таблица като отделни под-компоненти от типа "Таблица Row" със свойства, съответстващи на всяка от колоните / полета и с отношенията между редовете таблица за "Таблица връзка" вида. Освен това, ако има колона / поле, наречено "Име", то това се използва, за да назовем отделните Таблица Row под-компоненти.

8. Изберете ... бутона Import.

9. След кратък период от време (с прогрес бар за обратна връзка) нов проект ABACUS ще бъде създаден с таблици, редове от таблицата (ако вторият вариант бе избран в стъпка по-горе) и Връзки от базата данни на Microsoft SQL Server.

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Запълването на архитектура от Visio | Запълването на архитектура от Excel


Запълването на архитектура от Microsoft Visio

Navigation: Запълването на архитектурата> Запълването от продукти на Майкрософт>

Запълването на архитектура от Microsoft Visio

Изпратете коментари по тази тема.

Можете да импортирате вашата архитектура от Microsoft Visio. Shapes от вашата Visio рисунка ще бъдат внесени като компоненти в ABACUS. Connections в твоята Visio рисунка ще бъдат внесени като връзки и самата рисунка ще бъде внесен в ABACUS като диаграма. Освен това, всички потребителски свойства във вашия Visio рисунка ще бъдат внесени като имоти с Sort ключ съпоставена с Вид на имота, Знака за Името на имота и стойността на имота стойност.

Забележка

На вноса от Visio функция изисква Microsoft Visio 2003или по-нова е инсталирана на компютъра.

За да импортирате вашите Visio рисунки в ABACUS

1. Уверете се, че имате ABACUS отворена.

2. Изберете File | New и изберете От Visioот диалоговия прозорец, който се появява и кликнете OK.

Забележка

Ако искате да импортирате в съществуващ проект ABACUS след това или щракнете с десния бутон на Components възел в рамките на архитектурата, или щракнете с десния бутон на отделен компонент в рамките на един Архитектура и след това изберете Import | От Visio.

3. Преглед за търсене на файл Visio, който искате да импортирате.

Забележка

По-долу са някои прости правила или препоръчителни практики при конструиране (или модифициране) на MS Visio рисунка за внос в ABACUS.

1. Линиите или връзки трябва да бъдат действителни конектори, а не форми.

· В противен случай просто ще ABACUS ги внесе като компоненти и съответно те няма да бъдат "прикрепен" към нищо.

· Ако е необходимо да се направят някои "умни" маршрутизация (т.е. различни от права линия), след това използвайте Dynamic съединител на шаблон Basic Shapes, ABACUS ще импортира точките за маршрутизиране / анкерни глоба.

· Опитайте се да се избегне използването на "Ring мрежа" и "Ethernet" фигури от шаблона Network и периферия, която позволява на много компоненти, които да бъдат "свързани" с него. Докато ние внасяме прикачените файлове глоба като връзки за оригиналната форма е все още "разширена", за да отрази прикачените файлове. Използвайте отдели отделна "хъб / автобус" форма (без конектора "крака") и след това изрично всяко свързване към главината / автобуса с отделни съединители.

· Ако една линия или връзка се държи като форма, десен бутон върху него и отидете на "Format | Behavior ... "и се уверете, че стилът Взаимодействие е настроен да Line (1 двумерен).

2. Компонентите трябва да бъдат форми НЕ съединители.

· В противен случай просто ще ABACUS ги внесе като връзки и съответно цялата информация за формата, ще бъдат загубени.

· Ако компонент се държи като съединител, десен бутон върху него и отидете на "Format | Поведение ... "и се уверете, че стилът Взаимодействие е настроен да Box (2-измерна).

3. Накрайници за съединители трябва да бъдат прикрепени към форми, НЕ витае във фонов режим зад форма.

· Ако не се свържете конекторите към формите тогава ABACUS има няма как да знае, че сте възнамерявали да прикачите дадената конектор към форма / компонент и съответно той ще напусне този край на връзката ООН приложен.

4. Етикети за форми трябва да бъдат (където е възможно) етикет вграден текст за формата, не отделно текстово поле на чертежа.

· Отделни текстови полета ще се внасят от ABACUS като компоненти сами по себе си и докато можете да се слеят компонента "етикет" с реалния компонент в ABACUS, или просто да конвертирате компонент "етикет" на свободна форма форма (т.е. не на самия компонент) най-добре е да се избегнат тези стъпки.

5. Използвайте същата базова форма за всяко копие от същия тип, не се мързеливи и да използва правоъгълник понякога и кутия други от различни шаблони форма.

· ABACUS използва базовата форма и основата му цвят, за да може еднозначно да идентифицира типа на компоненти и свързване на чертежа така "червена правоъгълник" и "червена кутия" ще се внасят като два отделни видове компоненти. Тези съставни типове могат да бъдат обединени в ABACUS но най-добре е да се избегнат тези стъпки.

6. Изцяло капсулиране "детски" форми в рамките на своите "родители", НЕ оставяйте ги надвесен над ръба.

· ABACUS ще открие всякаква форма, че той изцяло е капсулиран в друга форма, като дете на родителя, затова се уверете, че целият формата, включително частта на етикета, е затворена.

7. НЕ позиционирате форма припокриващи две други форми.

· Ако една форма припокрива две други форми, било то "групиране" / фон правоъгълник или по друг начин, той ще бъде внесен от ABACUS като компонент, който е дете на нито препокриващи форми, но веднага след като си изберете компонента в ABACUS "инструмент за рисуване , благодарение на най-ляво е компонентите референтна точка, то ще стане дете на ляво припокриват форма / компонент.

8. Опитайте се да се сведе до минимум използването на текстови бележки върху чертежа, защото те ще се внасят като компоненти сами по себе си и ще трябва да се превръща в свободна форма фигури в ABACUS. Помислете дали те наистина са на името на съществуващ компонент или връзка.

9. Докато ABACUS поддържа богата / цветни / векторно базирани форми, се опитват да сведат до минимум използването на растерни изображения, чужди форми и Enhanced метафайлове за фигури като ABACUS момента правинеподкрепа на тези видове. Те ще бъдат внесени като обикновени бели правоъгълници.

10. Опитайте се да избягвате превоз връща (Shift-връщане) в етикетите, тъй като те се внасят и показана като специален знак "[]" в ABACUS за име на компонент.

11. Опитайте се да се сведе до минимум различните цветове, които се използват за фигури от същия тип. Както бе споменато по-горе, основен цвят и база форма еднозначно идентифицира компоненти и свързване видове, така че по-промяната там е по-обединяването и укрепването, че ще трябва да се направи след вноса в ABACUS.

12. Бъдете внимателни с пълни форми, защото ако една форма се запълва целия път до ъглите след това го оцветяване по-късно в ABACUS няма да има ефект.

13. За сложни форми линия базирани вие трябва да използвате полигон, който е създаден от линии като се започва, когато предишната приключи и след това в крайна сметка да се върне в началната точка. Ако желаете, можете да използвате за пълнене и ред широчина да направи полигон вид като "стрела" или каквото и да форма, която искате.

14. Уверете се, че идентификацията на фигури в MS Visio е значимо не само Shape.xx. Това може да се редактира с помощта на десния бутон върху "Show Shapesheet", която е на разположение в режим MS Visio разработчик (активиран чрез Tools | Options в MS Visio).

15. Елипсите и дъгив рамките на формисе поддържат в ABACUS но NURBS сплайни и в момента не се поддържат.

16. Уверете се, че цялата форма е групирана в MS Visio или тя ще се внасят като няколко компоненти / видове.

17. Опитайте се да се сведе до минимум използването на завъртените форми в рамките subshapes тъй като понякога те няма да бъдат внасяни правилно.

Вижте също

Запълването на архитектурата - Преглед | Запълването на архитектурата ръчно | Запълването на архитектура от Access | Запълването на архитектура от Excel


Запълването на архитектурата ръчно

Navigation: Запълването на архитектурата> Запълването ръчно>

Запълването на архитектурата ръчно

Изпратете коментари по тази тема.

Компонентите и връзките на вашата архитектура на по-високо ниво, вероятно ще трябва да се попълва ръчно. Обикновено това ще бъде най-абстрактни елементи и връзки.

За да се пренесат ръчно си архитектура

1. Уверете се, че имате ABACUS файлотворен, един изследователПоказва, и архитектура добавя .

2. Добави компонент. Да го направя, Кликнете с десния бутонна територията на дървото, което искате да се пренесат и изберете Добави Sub-Component ...Или натиснете New Componentбутона на Преглед на лентата с инструменти , Компоненти могат да се добавят само в клона Компоненти на дървото. Вие искате вашето дърво диаграма, за да бъде точно представяне на вашата архитектура. Когато открих си архитектура, ще са се научили как точно всичко си пасва. Ще имате нужда от това знание, когато добавите вашите компоненти и връзки. Ако добавяте първата си компонент, ще го добавите в бранша компоненти. Останалата част от устройствата може да бъде или на същото ниво в дървото, или те могат да бъдат под-компоненти на първата.

3. Актуализиране на ценностите насвойстватана всяка съставка, която можете да го добавите. Да го направя, кликванена компонент, и редактирате свойствата показва в Прозорец Properties(обикновено) надясно. Информацията обикновено са неща като изисквания, капацитета на преработка и т.н. Когато ABACUS оценява вашата архитектура, тя ще изчисли някои нови свойства, и да ги запишете обратно към архитектурата. Новите свойства са данните, които се опитвате да се анализира, като например използване, време за реакция, трафик и т.н.

4. Добави връзки и актуализациятехните свойствакакто и да отидете - точно както правите за компоненти (но в рамките на бранша Connections на дървото).

5. Прикрепетевръзки и компоненти. За да направите това, намерете връзката, кликнете върху една от неговите завършва или роли , И да го плъзнете върху компонент. Алтернативно, кликнете върху компонент и да го плъзнете в един от най-връзка-те роли (т.е. или Source или Sink), Или можете да щракнете с десния бутон и плъзнете компонент на друг компонент и изберете Свържете се с, Или просто да щракнете с десния бутон и изберете компонент Свържете ..., Когато плъзгате връзка роля, Вие ще забележите, символ на пряк път, когато посочите най компонент можете да го прикрепите към. Това показва, че вие ​​не сте прави копие, вие просто го прикачва. Уверете се, че сте го прикрепите към правилната дестинация компонент. Например, ако това е Източник на връзка на роляПлъзнете го направя източника (т.е. компонент, който е източникът на потока от данни).

Бакшиш

Re-поръчване на лица в рамките на вашата архитектура (напр Components, Connections и т.н.) в изследователе доста лесно. Просто Кликнете| Държа| Влачасъответното лице и мястото, където желаната от вашата архитектура. Функционалността за преподреждане също ви позволява да поставите образувания в рамките на различни йерархии на вашата архитектура.

Може би ще искате да

6. Добави стандарти (предварително конфигурирани комплекти от имоти - пресети) до вашите компоненти, връзки или типове

7. Промяна на свойствата на компонент, връзка или тип

8. Отмяна и Redo оперативна дейност

9. Промените типа на компонент или връзка

10. Създаване на нов тип или тип Group

11. Изтривам компонент или връзка

12. Създаване, дублират или еволюират архитектура

13. Видове Внос и стандарти от библиотека

14. Внос от друг файл ABACUS, XML, Excel или Visio

15. Копиране и поставяне части (или всички) на вашата архитектура

16. Търсене и заместване продукти във Вашата архитектура

17. Expand / Collapse някои или всички възли в дървото

18. Сливам предметите

19. Дефинирайте и Ратифицирам Ограничения за ограничаване на структурата на вашата архитектура

20. Evolve си архитектура да се създадат няколко архитектурни решения, за да сравните и изходното ниво

Вижте също

Запълването на архитектурата - Преглед | Създаване на нов файл


Публикуване в Web

Навигация: Представяне на информация за вашата архитектура>

Публикуване в Web

Изпратете коментари по тази тема.

ABACUS "Публикуване в Web функция позволява архитектурни модели, за да бъдат разглеждани чрез сигурна уеб сайт. Архитектури се изнасят в HTML формат и са предназначени да отразяват облика на експлоръра в ABACUS. Прегледи (включително Каталози, Diagrams, 3D и Charts) също се изнасят формати Предавания чрез интернет браузър.

Забележка

В момента, гледни точки и матрици не са публикувани.

За да публикувате вашите архитектурни модели в интернет

1. Уверете се, че имате съответните ABACUS файлотворена, съдържащ населена архитектуракоито искате да публикувате в интернет.

2. Изберете Пила| Публикуване на ....

3. The Публикуване в Web Configurationпрозорец ще покаже.

Публикуване в Web Configuration

4. По подразбиране всички части на модела са избрани включително Tree View, на Стандарти, Видовете, бланки и архитектура (и). Махнете отметката от всички части, които не искате да се публикува в интернет, включително всякакви индивидуални мнения в рамките на архитектурата (и).

Бакшиш

Ако искате да скриете специфични компоненти, връзки и / или техните свойства се препоръчва администратор създава роля на "Public", използвайки Ролеви функция достъп ABACUS " и след това се премахва разрешение прочетен от тези съставни типове, видове и / или свойства на връзката, че те не желаят да бъдат публикувани. След това потребителят трябва да влезете в системата под тази роля и публикуват в уеб, както ABACUS ще публикува само елементи, които са прочетени разрешение избран за ролята. Освен това, потребителите могат да публикуват автоматично от командния ред, както е описано тук .

Забележка

Можете да изберете всички части показани като кликнете относно Всичкибутон или обърнете своя избор, като кликнете относно Обръщанебутон. Можете също така да кликнете върху Никойбутон, за да изчистите своя избор.

Забележка

Ако ти махнете отметката от опцията Tree Viewтогава не е дърво конструкция (виж по-долу) ще бъде публикувана. Съответно, вие трябва да изберете начална страница, съгласно етап 6 по-долу, или след публикуване ще трябва да персонализирате или най-високо ниво; a) index.htmlфайл чрез промяна на "рамкова SRC =" mainPage.html "име =" element_details "" линия, за да свързват пряко към съответната HTML страница в папката Content, или б) mainPage.htmlчрез предоставяне на хипервръзка или пренасочи към съответния HTML страница в папката Content.

5. Щракнете върху Опция бутон и следното Опции на издателядиалоговия ще покаже.

ПубликувамОпции НЛП

6. Sизбира 3D, ДиаграмаГрафики и формати и дали да се покаже заглавие, описание или Properties за мненията от наличните опции (виж бележката по-долу за коментари по различните формати).

7. Ако желаете да зададете начална страница на публикувани модел на определена гледна след това проверете Използвайте View Както Start Pageопция и разглеждане на становището чрез "..." бутона, който става активиран.

Забележка

Само възгледите избрани в раздела за райони по Стъпка 4 по-горе са на разположение, за да бъде определен като начална страница.

8. Ако желаете да получите обратна връзка за определени страници в публикувания модел след това се уверете, че Email Обратна връзкаопция е избрана, въведете имейл адреса си в Имейл адрес текстово полеи редактирайте Email Bodyсечение, както е уместно, Ако не желаят да имат обратна връзка, изпратено след това махнете отметката от Email Обратна връзкавариант и да оставите текстовото поле.

9. Кликнете върху Добребутон.

10. Кликнете върху Пасабутон.

11. The Преглед за папкапрозорец ще покаже.

12. Изберете мястото, което искате да съхраните HTML файл най-високо ниво (и всякакви автоматично генерирани файлове).

Забележка

Това е добра идея да се създаде специална папка (обикновено се нарича "От") с помощта на Направи New Folderбутона в долната част на диалоговия прозорец, за да запазите най-високо ниво HTML файл и всякакви автоматично генерирани файлове.

13. Кликнете върху Добребутон.

14. Пътеката на папката ще се покаже в Указател текстово поле.

15. Кликнете върху завършекбутон.

- или -

15. Въведете пътя на папката в Указателкойто виждаш там, където искате да съхраните HTML файл най-високо ниво (и всякакви автоматично генерирани файлове).

16. Кликнете върху завършекбутон.

Забележка

Експорт на Diagramsмного рядко се провали, най-често, когато компютърът е на паметта (обикновено при използване на много големи файлове). Провален износ ще се повтаря веднъж. Ще има едно предупреждение за неуспешен Начален опит, и второ предупреждение, ако повторното опит е неуспешен. Ето защо, ако единствените предупрежденията са "Начален опит се провали" такива, за да публикува е била успешна. Ако повторното опит е неуспешен опитайте да публикува малка част от вашия файл или безплатно до някаква системна памет.

Запазената HTML файл (а), сега може да бъде гледка от неговото местоположение или копирани на защитен уеб сайт.

Публикуване в Web в Internet Explorer10

всяка хипервръзки които са създадени в оригиналния модел ще се запази и през публикувания модел и кликнете на линка ще следвайте връзката към местоназначението си (ако е бил публикуван). Освен това, всички елементи в публикуваните диаграми, които все още не са хиперлинк в оригиналния модел ще чрез хиперлинк обратно към съответните им елементи в екрана Tree (ако е бил публикуван) и като щракнете върху елемент в публикуваната схема фокусът ще скочи обратно към на съответното място в дървото. Тази функция е подобна на "Шоуто В Explorer" десен бутон функцията в ABACUS.

Забележка

Avolution настоятелно препоръчва следните софтуерни и файлови формати трябва да бъдат използвани за пълното използване на Публикуване в Web функционалност в ABACUS:

1. Internet Explorer (80.0 и по-горе)за да видите публикувано мнението изследовател. Mozilla Firefox (30.0 или по-късно)Препоръчва се също така и напълно подкрепенаВъпреки това, ако се използва препоръчаният SVG формат за диаграми след това в Firefox 9 можете да използвате само зрител подкрепата на родния SVG, които за съжаление не позволява мащабиране или канче.

2. Adobe SVG Viewer 3.0 плъг-ин (изтеглите от тук ) и SVGфайлов формат за публикуваните диаграми, Форматът за SVG за диаграмисе препоръчва, защото; SVG е графичен формат вектор-базиран и затова е "загуба-малко" и изглежда много по-добре във всеки един голям мащаб, отколкото някоя от другите формати, SVG могат да бъдат внасяни в MS Visio, SVG могат да бъдат увеличени и да е ниво или резолюция , SVG има връзки обратно към дървовидния изглед за връзките (не само компонентите), SVG винаги отпечатва най-добра резолюция, и, SVG е около половината на размера на файла на други формати. PNG е следващата препоръка, обаче, тъй като това е растеризирани формат при определени нива на увеличение на яснотата на мнение, ще бъдат загубени и кликнете връзки на диаграми не ще скочи обратно към съответното място в дървото. BMP е препоръчително като същевременно тя е "загуба-малко" форматирате размерът на файла е 100 пъти тази на другите формати и 20MB изображенията не са нещо необичайно.

Компромис с SVG е, че един зрител SVG ще трябва да бъде инсталиран и трябва да уверете се, че .svg изображение / SVG + XML се добавя MIME видове уеб сървъра. След инсталирането на зрителя SVG Microsoft Internet Explorer ще ви помоля да приемете лицензионното споразумение на зрителя, а след това тя трябва да работи добре. И в същото времеMozilla Firefox поддържа SVG файлове роден, на Adobe плъгин все още се препоръчвада бъде в състояние да я увеличите диаграмите, ако използвате Firefox 8 или по-рано (ако използвате Firefox 9 не можете да забраните на родния зрител SVG), След като инсталацията за Adobe плъгин е работил, следващите стъпки са необходими да я използват в Firefox:

· Отворете Firefox и въведете "за: довереник" (без кавички) в бара URL.

· Превъртете надолу, за да намерите имота svg.enabled(ако използвате Firefox 9 тогава родния гледане SVG не може да бъде деактивиран и този имот не съществува), Кликнете два пъти върху него, за да го изключите.

· Сега разбери директорията, където е инсталирана на SVG плъгин (например C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30.0 \)

· Копирайте файловете NPSVG3.dll и на NPSVG3.zip и ги поставете в директорията на Firefox плъгини (напр C: \ Program Files \ Mozilla Firefox \ плъгини)

· Затворете всички случаи на Firefox

3. ABACUS 3D Viewer Avolution му (3.1 и по-горе) и .abacus3D Avolution сифайлов формат за публикуваните 3D изгледа. Докато Cortona VRML Client приставка (2.0 и по-горе)е на разположение, за да видите VRML версии на публикуваните възгледи не е безплатно за търговска употреба и все още се нуждае от страна на клиента инсталация. The ABACUS 3D Viewer е по-богат на функции, отколкото всеки VRML зрителя и е свободно достъпна за сваляне от тук , И в двата случая се уверете, че добави .vrml х-свят / х-VRML и .abacus3d прилагане / октет поток към MIME видове уеб сървъра.

4. PNGфайлов формат за публикуваните възгледите графика. Форматът за изображения за възгледите на графиката се препоръчва, защото макар и да е растеризирани формат и там е "загуба" компромисът между размера на файла и графика яснота обикновено е най-добрия. BMP е препоръчително като същевременно тя е "загуба-малко" форматирате размерът на файла е 20x, че от другите формати и 2MB класациите не са необичайни.

Ако искате да промените външния вид и усещане на уеб страници, можете да редактирате файла началната страница на име mainPage.html и файл на стилов лист с име abacus.css. Тук ще намерите тези файлове в същата папка, където сте избрали да запазите най-високо ниво HTML файл. За повече информация относно структурата и адаптирането на публикувани изхода вижте следващия раздел.

Структурата на ABACUS публикувани модели

The ABACUS публикувани модел е структуриран по следния начин:

1. Папката най-високо ниво съдържа няколко файла и ако приемем всички опции са включени в ABACUS Публикуване в Web Configuration диалоговия тя ще включва индекс.HTMLфайл, съставен от три кадъра; treeView.html, findNode.html и mainPage.html и тогава shortcutError.htmlстраница, The treeView.html е населена от tree.js, tree_items.js и tree_tpl.js JavaScript файлове, намиращи се в папката включва (обсъдени по-долу) и репликира дървото Explorer от ABACUS. The findNode.html се захранва отна find.js JavaScript файл, намиращ се под включват папка (обсъдени по-долу) и да го ще търси клоните на дървото, а не само на видимите възли. Tтой mainPage.html е статичен HTML страница, която може да бъде съобразена с корпоративни лога и други подобнии ще бъде показано, освен ако начало страница се избира при публикуване.И накрая, на страницата shortcutError.html е целевата страница за всякакви счупени команди за бърз достъп от дървото поради подходящите страници не се публикуват.

Бакшиш

Можете да пропуснете mainPage.html изцяло от избрахте да използвате старова при публикуване или модифициране на файла index.html към точка директно към даден изглед (да речем), като редактирате конструкция SRC = "mainPage.html" линия до точка директно на пръв поглед в първата архитектура, типично за "рамка" диаграма.

2. Аз най-високо нивоВключванепапка съдържаINGразлични JavaScript (.js) и каскаден стил лист (.css) файлове, използвани от .html файлове през целия публикувани модел.

3. Папката най-високо ниво Content съдържаПо азбучен ред;

· A '3D Прегледи' папка сномериранHTML страница и VRML или abacus3d файл за всеки от публикуваните 3D изгледи, Виж бележката по-долу за информация относно схемата за номериране на файлове.

· An Архитектури папка с номерирани HTML страница за всяка архитектура, която е публикувана. Виж бележката по-долу за информация относно схемата за номериране на файлове.

· A Каталози папка, съдържаща номериран HTML страница за всеки от публикувани каталози. Виж бележката по-долу за информация относно схемата за номериране на файлове.

· A Графики папка сномериранHTML страница и PNG, JPG и т.н. файл за всеки от публикуваните възгледите Графика, Виж бележката по-долу за информация относно схемата за номериране на файлове.

· A Елементи папка, съдържащаномериранHTML страница за всеки от компонентите публикувани, Виж бележката по-долу за информация относно схемата за номериране на файлове.

· A Connections папка, съдържащаномериранHTML страница за всеки от публикуват връзки, Виж бележката по-долу за информация относно схемата за номериране на файлове.

· A Diagrams папка, съдържащаномериранHTML страница и PNG, SVG и др файл за всеки от публикуваните диаграми. Виж бележката по-долу за информация относно схемата за номериране на файлове.

· An икони под-папка с различни изображения, използвани в публикувана модел.

· A Стандарти подпапка сномериранHTML страница за всеки стандартикоито са били публикувани. Виж бележката по-долу за информация относно схемата за номериране на файлове.

· A Templates подводница-folder с колекция от номерирани подпапки за всеки шаблон публикувана от проекта. В рамките на всяка подпапка е Components и папка Connections и в тях е номериран HTML страница за всеки компонент и свързване на шаблона. Виж бележката по-долу за информация относно схемата за номериране на папката / файла.

· A Видове подпапка с Component иConnection подпапки сномериранHTML страница за всеки компонент иТипове връзки, които са публикувании колекция от номерирани подпапки за всеки тип публикувана от проекта, съдържащ HTML страница за всяко от ограниченията,. Виж бележката по-долу за информация относно схемата за номериране на папката / файла.

· A Изгледточкаs подпапка иномериранHTML страница за всеки от изгледаточкаите, които са били публикувани. Виж бележката по-долу за информация относно схемата за номериране на файлове.

Забележка

Номерирането на HTML страници (и в някои случаи графични файлове), съответства на единствен по рода си документ за самоличност за всеки обект, който е хранилище задаване кога беше създаденив рамките на ABACUS (по-нататък EEIDs), Това ID не се променя, така че като диаграми, видове, елементи и т.н. сте актуализиран те щезапази същата идентификация, както преди. Във всеки случай, съответната хранилище обектИмето може да бъде намерена в близост до началото на HTML страницата, между ... HTML тагове.

Ограничаване на достъпа до определени страници / Виждания с IIS

Ако се използва IIS като вашия уеб сървър за публикуваната модел, може да имате възможност да ограничите достъпа до определени страници / възгледи, използващи метода по-долу:

1. Създаване на уеб сайт в IIS (още един, ако има съществуваща такава не искате да се намесва).

2. Промяна на Properties-> Directory Сигурност> Anonymous достъпа - махнете анонимен достъп и използване заверено достъп.

3. Ако това е просто един нормален сървър без никакви усложнения на домейни и т.н., тогава трябва да използвате опцията "интегрирани прозорци удостоверяване", които след това ще използва сървърните машини местните потребители / опитите за влизане като на автентичността, и просто да добавите потребители към локалния компютър (като внимавате че сте наясно с последиците, сигурността мъдър, за добавяне на нови потребители към машината, например в зависимост от това дали отдалечен достъп е настроена за машината, и т.н.).

4. Добави разрешения за конкретните файлове / папки, както се изисква. Кликнете с десния бутон на отделните файлове / папки -> Имоти и коригира разрешения за сигурност както обикновено за файлове / папки.

Това може да се различава в зависимост от това коя версия на IIS и какви конкретни Windows OS е на сървъра, както и дали имате домейн или друга различна настройка.

Вижте също

Запълването на архитектурата | Анализирайки си архитектура


Регистриране на ABACUS

Navigation: Референтен>

Регистриране на ABACUS

Изпратете коментари по тази тема.

При първото стартиране на ABACUS (или след временен лиценз е изтекъл), ще трябва да се регистрират заявлението срещу сървърен лиценз Avolution, използвайки уникална лицензен ключ, предоставен от вашия местен ABACUS администратор или директно от Avolution. Ако не разполагате с лицензен ключ, моля свържете се с местния ABACUS администратор или Подкрепа Avolution .

За да се регистрирате с лицензен ключ

1. След инсталацията, започнете ABACUSили чрез двукратно щракване върху иконата на работния плот или от менюто Start на Windows.

2. В диалоговия прозорец за регистрация, която се появява, въведете 26 герой лицензионен ключпредоставена от вашия местен ABACUS администратор или Подкрепа Avolution Или кликване Browse ...и изберете подписано .dlsc файл се върна от Подкрепа Avolution според бележка към Стъпка 4 по-долу. Ако се използва правилно, подписано .dlsc файл ABACUS трябва да започне по стъпка 5 по-долу.

Бакшиш

Можете да поставите лицензния ключ в диалоговия прозорец, като го копирате в клипборда на Windows и след това избор на фона на диалоговия прозорец и натиснете Ctrl + V.

Диалоговия Регистрация

3. Кликнете Добреи ако ключът лиценз е валидно ABACUS лицензионен ключABACUS сега ще се опита да се свърже с лиценз за сървър Avolution за удостоверяване на лицензния ключ.

Забележка

Ако получите съобщение за Монтаж Code е невалиденрегистрация грешка, че е най-вероятно, че сте въвели кода неправилно. Опитайте копирате и поставите кода, както на върха споменато по-горе.

Връзка на Avolution License Server

4. Кликнете Добреи след кратък период от време ABACUS да се регистрирате успешно.

Успешно Регистрация

Забележка

Ако получите Не може да се свържете с лиценз за сървъррегистрация грешка, че е най-вероятно, че защитната стена (или други мерки за сигурност) на вашата мрежа не позволяват достъп до сървърен лиценз Avolution му. Кликнете Добре, Запишете файла на вашия .dlsc локалната машина и след това всеки приятел на .dlsc файла Подкрепа Avolution и да изчака по-нататъшни инструкцииили се опитват да подпише разрешителното подаде себе си с помощта на следния адрес - http://licensing.avolutionsoftware.com/LicenceSign/ .

Не може да се свържете с лиценз сървър

Отворете уеб страницата на подписване License

Manual License подписване уеб страница

Алтернативно, ако получите Тази инсталация код е била използвана на повече системи, отколкото е позволено от лицензарегистрация грешка е вероятно, че вашата локална машина е възстановен от последното регистрирано ABACUS или се опитвате да се регистрирате с лицензен ключ на друг потребител. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution .

Монтаж код вече е била използвана

5. Кликнете Добреи ако е регистриран успешно ABACUS трябва да се отвори с Welcome Screen .

Вижте също

Подкрепа Avolution | Какво означава ABACUS направя?


Standard Selection Element

Navigation: Анализирайки си архитектура>

Standard Selection Element

Изпратете коментари по тази тема.

При създаване на диаграми, 3D изглед, Доклад,стандартна диаграмаили провеждане на симулация, А стандартната прозорецът за избор на елемент се използва за избор елементи, които искате да се анализира / изглед.

Window Standard Selection Element

Pulldowns

· Филтър по View ще включва елементаите от предварително записан изглед (т.е. Diagram, графика, 3D). По този начин можете да извършвате сложни "се присъедини към" заявки чрез третиране на друг изглед като спаси "заявка".

Чек боксове

· Покажи Ниваволя група на елемента в зависимост от нивото, с което те се случват в дървото. Ниво 1 е най-най-ниво.

· Покажи Видовеволя група елементи съгласно видовете, че те са.

· Родителите на избранияще включва елементите, майки на всички избрани елементи. По този начин можете да се гарантира, че само йерархията над всички деца ще бъдат включени за "отдолу-нагоре" селекция.

· Децата на избранияще включва децата елементи от всякакви избрани елементи. По този начин можете да се гарантира, че само йерархията под всякакви родители ще бъдат включени за "отгоре-надолу" селекция.

· Име мачове Valueще включва само онези елементи, които имат име, съдържаща определен низ (Моля, имайте предвид: Wildcards (т.е. и *) може да се използва?). По този начин можете да се образува "семантична" заявка.

· Има Property Type / Име / Valueще включва само онези елементи, които имат Тип имот, име и стойност, съдържаща определен низ или директно върху елемента или на нейните стандарти (Моля, имайте предвид:?.? Wildcards (т.е. и *) може да се използва Eg * в полето за стойност ще даде на всички елементи, които имат не-празна стойност за даден имот). По този начин можете да се образува "семантична" заявка.

· Има Standardще включва само онези елементи, които имат Standard име, съдържаща определен низ (Моля, имайте предвид: Wildcards (т.е. и *) може да се използва например HP * ще даде на всички елементи с най-малко един Standard започне с буквите H и P?.). По този начин можете да се образува "семантична" заявка.

· Компоненти / Connections прикрепена към избранатаще включва всички елементи, прикрепени към тези, които са избрани. По този начин може да бъде избран за "кол-дърво" или "удар анализ".

Забележка

Ако имате и Покажи Нива и Покажи Видовеизбрани след това можете да изберете да имате дърво покажи нивата на първа или видове за първи път от бутона, който ще се появи по-горе двете отметки.

Бакшиш

След като даден елемент е избран в прозореца Standard Selection Element, той няма да бъде предмет на по-нататъшни промени филтър, докато не се изключи от избора. Тъй като не е роден начин за търсене на два различни набора от елементи наведнъж (напр Съставки с Standard A OR Standard B), можете да търсите първо за един комплект, изберете желаните компоненти, за да извършите втори търсене на втория сет ,

Копчета

· Всичкиизбира всички елементи.

· Обръщанеdeselects всички текущо избраните елементи и избира всички онези, които не са били избрани.

· Никойdeselects всички елементи.

· Добавяне на филтъризбира получената съдържанието на текущите настройки за филтриране и позволява избор на допълнително съдържание като ефективно на И или JOIN филтър.

Вижте също

Анализирайки си архитектура


Инструментът Drawing

Navigation: Запълването на архитектурата> Използване Рисунки>

Инструментът Drawing

Изпратете коментари по тази тема.

Инструментът Drawing позволява създаването на голямо разнообразие от архитектурни схеми и диаграми. Архитекти традиционно използват набор от различни рисунки за записване и предаване на дизайна на архитектурата. Двумерни (2D) диаграми са по обичайния начин на документиране и съобщаване на различни части на една система. Типични видове чертежи, използвани в корпоративни системи са:

· Бизнес модели на процеси и диаграми;

· Организационните схеми;

· Collaboration диаграми;

· Entity-запознанството (ER) диаграми;

· Data-Flow Diagrams (DFD му);

· Клас диаграми;

· IDEF (включващ няколко от по-горе); и

· UML (включващ няколко от по-горе).

Там наистина не е ограничение за вида на диаграмите, които могат да бъдат създадени. ABACUS се опитва да балансира диаграма гъвкавост, като същевременно се запази целостта на архитектурата и нейните форми на представителство.

Средата за рисуване е табове и закачват прозорец вътре в основното приложение ABACUS. Този прозорец съдържа платно, където рисунката се провежда и когато изготвянето прозорецът е отворен втори закачват прозорец , Прозореца на шаблон, може да се види с набор от чертожни листове. Прозорецът на шаблона има 4 раздела: компоненти, връзки, форми и конектори. Платното се появява като бял фон с фини линии на мрежата (полезни за оформление).

Компоненти са представени от един набор от форми, а връзките са привлечени като насочени линии. Connections отдават на компоненти, използвайки роли (т.е. или Source или Sink) въпреки че те не са показани за естетически причини.

Бакшиш

В същото време диаграмиса много полезни за показване различни части на една система, те са ограничени в тяхната скалируемост, което е и причината ABACUS използва 3D да визуализират сложни системни структури.

Вие може да искате да

1. Отвори Диаграми Инструмент

2. Създаване на нова схема на част от вашата архитектура

3. Копирайте диаграма в или извън архитектури

4. Добави компоненти на диаграма

5. Създаване на нови компоненти и връзки във вашата архитектура (схематично) с помощта на инструмента за рисуване

6. Изтриване на компоненти от схема

7. Прикрепете & манипулира връзки

8. Променете показване на имоти компоненти и връзки.

9. Използвайки връзките в диаграма

10. Наложете тип асоциации и гледни точки така че да се ограничат видовете диаграми, които могат да се направят.

Вижте също

Запълването на архитектурата | Запълването на архитектурата ръчно | Анализ Вашата архитектура


Главна страница

ABACUS

Опровержение

Avolution Pty Ltd не поема ангажименти или гаранции по отношение на това ръководство, а в максималната степен, позволена от закона, изрично ограничава отговорността си за нарушаване на никаква гаранция, че може да се предполага до замяната на това ръководство с друго. Освен това, Avolution Pty Ltd си запазва правото да ревизира тази публикация, по всяко време, без да понесе задължение за уведомяване за всяко лице на преразглеждането.

Авторско право

Copyright 2001-2015Avolution Pty Ltd. Всички права запазени.

Търговски марки

Avolution Pty Ltd е положил всички усилия да предоставят информация, запазена марка за имена на компании, продукти и услуги, посочени в това ръководство. Търговски марки показани по-долу са получени от различни източници.

Microsoft Windows, Access, Visio, Excel, SQL Server и Internet Explorerса търговски марки на Microsoft Corporation.

Обща забележка:

Някои имена на продукти, използвани в това ръководство са използвани само за идентификационни цели и могат да бъдат търговски марки на съответните компании.

Декември 2015Edition за Avolution ABACUS Version 4.5.

Manual Revision 1.0

Образувани, печатни и обвързана в Австралия.


ABACUS Монтаж предпоставки

Navigation: Референтен>

ABACUS Монтаж предпоставки

Изпратете коментари по тази тема.

Информация Относно Visio Внос и Excel Import / Export

ABACUS изисква Microsoft Office се инсталира, за да извършвате операции с Excel Import / Export и Visio за внос. Моля, потвърдете, че Microsoft Office 2003 или по-новае инсталиран правилно. Ако изпитвате по-нататъшни проблеми, за контакти Подкрепа Avolution .

За да изпълняват операции Visio внос и Excel за внос / износ, ABACUS използва Microsoft Office Основно Interop асамблеи (PIA-те години). ABACUS момента идва опаковани с църквите, необходими за извършване на Excel Import / Export и Visio Import.

Информация Относно SQL сървър Import

ABACUS изисква Microsoft SQL Server 2005, 2008 г., 2008 R2, 2012 г. или 2014е инсталирана, за да започне нов проект От SQL Server. Моля, потвърдете, че Microsoft SQL Server 2005, 2008 г., 2008 R2, 2012 г. или 2014е инсталиран правилно. Ако изпитвате по-нататъшни проблеми, за контакти Подкрепа Avolution .

Грешки Работно 3D визуализации

Ако ABACUS 3D Viewer не работи за вас, вие може да липсват на SlimDX DirectX Runtime (инсталиран като част от пълния ABACUS EXE инсталиране). Това може да бъде свален тук , Ако имате 64bit версия на Windows, може да се наложи да инсталирате това .

Грешки Редакция ABACUS Обичай Доклади

Редакция ABACUS "персонализирани отчети изисква Report Builder 3.0 да бъдат инсталирани. ABACUS и Report Builder са построени върху .NET Framework 4.0 Microsoft, и докато те двамата не се изисква .NET Framework 3.5 Microsoft, Microsoft е неправилно конфигуриран на Report Builder MSI да се пристъпи само ако .NET Framework 3.5 на Microsoft е инсталиран.

Съответно Avolution има редактираната версия на инсталацията Report Builder MSI файл, който не изисква .NET Framework 3.5 Microsoft, това може да бъде свален тук .

Оригиналният Microsoft Report Builder MSI може да бъде свален тук , Ако все още нямате Microsoft .NET Framework 3.5, които ще са необходими, можете да го изтеглите тук , Забележка: За няколко инсталации, офлайн инсталиране на .NET Framework 3.5 на Microsoft от тук може да бъде по-подходящо.


Отмяна и Redo

Navigation: Запълването на архитектурата> Запълването ръчно> Допълнителни опции>

Отмяна и Redo

Изпратете коментари по тази тема.

Подобно на много съвременни приложения, ABACUS поддържа способността да отмените както и да направите последните промени, направени от потребителя към отворен проект. За да отмените последната промяна, просто активирате командата връщане. Промените, които са били отменени могат да се върнат назад чрез активиране на командата ремонтирам; повторно прилагане на най-наскоро отмени промяната.

Внимание

Отменено промени не са в състояние да се повтаря, ако по-нататъшни промени са направени по проекта, тъй като се отмени.

Забележка

Докато по-голямата част от промените поддръжка отмените / ремонтирам в реално време, някои диаграма шаблони промени, като например създаването на нов тип-Shape / Line сдружение или промяна на цвета атрибут за асоцииране, не са в състояние да бъде отменено веднага. В тези случаи, модифицираният Диаграма (означени със звездичка) трябва да бъде затворен, преди тези промени може да бъде отменено.

Отмяна и Redo места командни

Команди Отмени и Повтори могат да бъдат достъпни от три различни места:

· В менюто Edit

· Стандартната инструментална лента

· клавишите клавишната комбинация CTRL + Z(връщане) и CTRL + Y(ремонтирам)

Бакшиш

Отмени и Повтори бутони на стандартната лента с инструменти предоставя падащи списъци, показващи 10-те най-новите промени, които могат да бъдат отменени и са били съответно започва няколко пъти. Те също са удобен начин да отмените / ремонтирам няколко промени наведнъж.


Използване на макроси

Navigation: Симулиране си архитектура>

Използване на макроси

Изпратете коментари по тази тема.

Ако изпълни дадена задача многократно в ABACUS, можете да автоматизирате задачата с помощта на макро. Съответно, сметало макро е записана серия от операции, които могат да се възпроизвеждат по всяко време.

Записване на Macro

1. Изберете Инструменти | Record Macroили алтернативно натиснете Alt + F10.

2. Започнете извършване на операции, които искате да запишете.

Внимание

По това време, има някои известни проблеми със записването на макроравнище. Вземи под внимание, че те, когато записвате вашите макроси:

· В момента макроси просто запишете вашите Microsoft Windows клавиши, мишка-движения и кликвания на мишката. Въпреки това, поради ограничения със самото устройство макро, има някои клавиши, които не винаги са записани. Те включват:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] да [F12]

· Поради това е препоръчително да се провери, че клавишна комбинация се записва от записването на макроси преди запис голяма поредица от събития, които могат да зависят от които клавишна комбинация работен.

· В момента поради ограничения със записването на макроси, контекстни менюта не се борави правилно с ABACUS когато те са отворени от действия, записани от записващото устройство на макроравнище. Когато отворите контекстното меню, трябва да изпълнява една от функциите, изброени в контекстното меню чрез контекстното меню, в противен случай контекстното меню могат да останат отворени по време на възпроизвеждане, което може да доведе до нежелани действия или действия, които биха могли да причинят грешки в ABACUS.

· Имайте предвид, че нормални методи за затваряне на контекстното меню (например натискане на [Esc] на клавиатурата, или ляво щракване някъде другаде на екрана) не може действително да затворите контекстното меню по време на възпроизвеждане на макро.

Бакшиш

В диалози, а не с помощта кликвания на мишката, се препоръчва да използвате клавиша Tab, за да се движат през наличните контроли и стрелките, за да изберете от падащото опции в менюто или опции радио бутон и лентата на Space, за да изберете / дьо изберете чек кутии.

За да спрете записа на Macro

1. Преса Alt + F9или алтернативно изберете Tools | Спрете Macro.

2. В Save макрос като диалоговия разглеждане на място и изберете ABACUS макро (.abacusmac файл) името на файла и щракнете върху Запиши.

Забележка

Използвайки Инструменти| Спрете Macroще включва тази операция в записания макрос. Поради това се препоръчва на потребителите да станат владеят с помощта на опциите на ключови Alt + Функция за работа с макроси, така че да не се включва нежелани макро операции в самите макроси.

Бакшиш

Както макросите в момента не са редактируеми се препоръчва да се запише продължителни задачи като поредица от отделни макроси, използващи Alt + F10 / Alt + F9 "двойки".

За възпроизвеждане на записани Macro

1. Изберете Инструменти | Playback Macroили алтернативно натиснете Alt + F8.

2. В Open Macro диалоговия отидете до местоположение и изберете ABACUS макро (.abacusmac файл) името на файла и натиснете Open.

Внимание

При откриване на ABACUS макро, ако кликнете два пъти върху файл макро от диалога за избор, за да го отворите, рекордерът макро може да задържите бутона на лявата мишката в ляво-кликнали състояние до записан щракнете с левия бутон замени на този държавни.

Забележка

Скоростта на възпроизвеждане на макрос може да се зададе в раздела Общи под Инструменти| Опцииили като Normal (по подразбиране), бързо или бавно. И двете бърза и бавна скорост на възпроизвеждане не се препоръчват, тъй като те ще се преиграе на записаните макроси при приблизително 100 пъти и 1/100 в реално време, съответно. Нормална скорост на възпроизвеждане все още ще се преиграе на макро приблизително 30% по-бързо от скоростта записана така че се препоръчва по време на запис, за да спрем за кратко време, след като всички продължителни задачи за обработка за да се гарантира, че на възпроизвеждане следващата операция не се изпълнява преди задачата на обработка има завършена.

За спиране изпълняването записана Macro

1. Преса Alt + F9.


Преглед на 3D диаграми

Navigation: Анализирайки си архитектура> 3D диаграми>

Преглед на 3D диаграми

Изпратете коментари по тази тема.

ABACUS ви позволява да видите вашия архитектурата като 3D изглед, където на елементи и съединителни свойства са свързани с цветове, форми и размери.

За да видите 3D изглед на вашата архитектура

1. Уверете се, че имате отворете файла ABACUSсъдържаща вашето населена архитектура.

2. Разгънете Прегледиклон на дървото.

3. Разгънете 3Dклон на дървото.

4. Кликнете два пъти визуализацията, която искате да отворите.

- или -

1. Уверете се, че имате отворете файла ABACUSсъдържаща вашето населена архитектура.

2. Изберете Insert| 3Dили щракнете върху бутона в лентата с инструменти.

3. Открийте си съществуващвизуализация (.abacus3d)

- или -

1. Уверете се, че имате отворете файла ABACUSсъдържаща вашето населена архитектура.

2. Изберете Insert| 3Dили щракнете върху бутона в лентата с инструменти.

3. Създаване на нова визуализация:

· Изберете Архитектуракойто искате да видите от падащото меню.

· Изберете Елементи и Connectionsискате да включите в диаграмата от прозорец за избор на стандартен елемент .

· Сътрудник цветове, форми и размери с Компонент Видове и Имоти.

· Сътрудник цветове и форми с Типове връзки и Имоти.

За да експортирате 3D изглед

1. Уверете се, че имате отваряне на съществуващ 3D изглед.

2. В менюта падащи 3D изгледа му изберете File | Export ...и избра място и файлов тип за файла визуализация (.abacus3d, .vrml или .html).

3. Кликнете Save.

Вижте също

Анализирайки си архитектура | Навигация в 3D | The диаграми Tool


Преглед на диаграма балон

Navigation: Анализирайки си архитектура> Персонализирани карти>

Преглед на диаграма балон

Изпратете коментари по тази тема.

Диаграма балон ви позволява да сравнявате до 5 размери (т.е. X, Y, размер балон / радиус, цвят балон и граничен цвят балон) в един изглед.

За да видите диаграма балон

1. Уверете се, че имате ABACUS отворен файл .

2. Изберете Insert| Диаграма| на Персонализирани Chartsтаб | Bubble Chart.

3. В Архитектурираздел, маркирай архитектури (ако има такива), които искате да начертае, след което щракнете върху Следващия.

4. Изберете Елементи и Connectionsкойто искате в диаграмата (ако има такива) от прозорец за избор на стандартен елемент , След което щракнете върху Следващия.

5. Изберете Абсцисасобственост, след което щракнете върху Следващия.

Забележка

Само Integer, Decimal, Date / Time, Булева и Списък на имоти може да се използва за Х-оста. Освен това, Integer, десетични и дата / час на имоти се нанасят отляво-надясно по оста мащаб в зависимост от стойността на имота, обаче, булеви и Списък свойства са просто начертани наляво-надясно в точния ред (или в обратен ред, ако се проверява възможността да се обърне реда) са определени за имота, независимо от техните стойности. Например Low | Medium | Високо или 1, 2, 4, 8, 16.

6. Изберете Ординатасобственост, след което щракнете върху Следващия.

Забележка

Само Integer, Decimal, Date / Time, Булева и Списък на имоти може да се използва за Y-оста. Освен това, Integer, десетични и дата / час на имоти се нанасят отдолу до горе по оста мащаб в зависимост от стойността на имота, обаче, булеви и Списък свойства са просто нанасят отдолу-към-отгоре в точния ред (или в обратен ред, ако се проверява възможността да се обърне реда) са определени за имота, независимо от техните стойности. Например Low | Medium | Високо или 1, 2, 4, 8, 16.

7. Изберете размера на мехурчетата / радиуссобственост, след което щракнете върху Следващия.

Забележка

Само Integer, Decimal, Булева и Списък на имоти може да се използва за балон размер / радиус. Освен това, Integer и десетични свойства водят до размера на мехурчетата / радиус мащаб в зависимост от стойността на имота, обаче, булеви и Списък свойства водят до еднакви стъпка увеличения на балон размер / радиуса в точния ред (или в обратен ред, ако опцията да обърне реда се проверява) е определен за имота, независимо от техните стойности. Например Low | Medium | Високо или 1, 2, 4, 8, 16.

8. Изберете или на Цвят на фиксирана балон или сдружават имот с цвета на балона, След което щракнете върху Следващия.

Забележка

Само Integer, Decimal, Булева и Списък на имоти може да се използва за цвят на балон. Освен това, Integer и десетични свойства водят в цвят балон в рамките на избрания обхват мащаб в зависимост от стойността на имота, обаче, булеви и Списък свойства водят до еднакви стъпка увеличения на цвета на балона в рамките на избрания обхват в точния ред, определени за имот, независимо от техните стойности. Например Low | Medium | Високо или 1, 2, 4, 8, 16.

9. Изберете или без граница балон цвят или сдружават имот с граничния балон цвят, След което щракнете върху завършек.

Забележка

Само Integer, Decimal, Булева и Списък на имоти може да се използва за граничен балон цвят. Освен това, Integer и десетични свойства водят до граничния балон цвят в рамките на избрания обхват мащаб в зависимост от стойността на имота, обаче, булеви и Списък свойства водят до еднакви стъпка увеличения на граничния балон цвета на рамките на избрания обхват в точния ред, определени за имота, независимо от техните стойности. Например Low | Medium | Високо или 1, 2, 4, 8, 16.

Bubble чарт

За да запазите диаграма балон

Забележка

Bubble графики могат да бъдат спасени само ако те съдържат само компоненти и връзки, всички от които трябва да са от един архитектура в рамките на настоящия проект.

1. Уверете се, че имате нов или съществуващ чарт балон отворени сте направили необходимите промени.

2. В лентата с инструменти на графиката кликнете върху най-левия Save Chartбутон, за да спести на графиката и всякакви промени във форматирането.

3. В Графика Наименованиедиалогов прозорец, който се появява, въведете име за графиката на балон и натиснете Добре.

За да експортирате диаграма балон

1. Уверете се, че имате отворите съществуваща диаграма балон.

2. В лентата с инструменти Диаграма щракнете на 2-ри от ляво Запиши като BMPбутон и изберете местоположението за графиката.

3. Кликнете Save.

Вижте също

Анализирайки си архитектура


Преглед способност пространство чарт

Navigation: Анализирайки си архитектура> Персонализирани карти>

Преглед способност пространство чарт

Изпратете коментари по тази тема.

A Space Capability графика ви позволява да видите дали вашата архитектура отговаря на изискваната способност на системата по отношение на имоти, установени по време на процеса анализ на изискванията на системата.

За да видите способност пространство чарт

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура, И че имате оценяваниВашата архитектура.

2. Изберете Insert| Диаграма| Персонализирани Charts| Capability Space, (The Capability Space Chart Configдиалоговия ще покаже.)

3. В Архитектурираздел, маркирай архитектури, които искате да чарт, след което щракнете върху Следващия.

4. В Имотиплощ, маркирай архитектурни качества бихте искали включени като осите на графиката.

5. В Способностплощ, за всеки имот, включени от предишния етап, изберете дали някоя минимална или максимална граница способности съществуват и ценностите на тези граници. Стойностите по подразбиране са минималните и максималните стойности, оценявани за архитектури или гол за имота ако е бил зададен.

За да експортирате способност пространство чарт

1. Уверете се, че имате съществуваща способност пространство чартотворена.

2. В лентата с инструменти на графиката кликнете върху най-левия Запиши като BMPбутон и изберете местоположението за графиката.

3. Кликнете Save.

Вижте също

Анализирайки си архитектура | Преглед на диаграма, време за реакция


Стандартни Reports

Навигация: Представяне на информация за вашата архитектура>

Стандартни Reports

Изпратете коментари по тази тема.

ABACUS " стандарт доклади ви позволяват да получите списък на компонентите и връзките в една или повече от вашите архитектури. В доклада се съдържа цялата информация, свързана с компонентите и връзките избрани, включително информация за компонент или мястото връзка в йерархията, вида, стандарти, описание, свойства и допълненията към нея.

Забележка

Съдържанието на доклада еконфигурируемипрез прозореца доклад опции описано по-долу, обаче, то разберете повече информация за това как да се създаде напълно конфигурируеми потребителски докладиизползване на ABACUS Персонализирани отчети, Моля те вижте темата тук или контакт Подкрепа Avolution .

За да видите стандарт доклад

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура(с).

2. Изберете Insert| Standard Докладили натиснете Създайте Standard Доклад лента с инструменти бутон. The Доклад ConfigurationЩе се появи прозорец.

Доклад прозорец Configuration

3. Изберете Архитектури, Елементи и Connectionsкойто искате в доклада от Доклад Configuration Window.Моля обърнете се към Standard Избор на Element тук тема за помощ.

4. Сега кликнете върху Опциибутон и Съобщи Optionsпрозорец ще покаже.

Доклад Options прозорец

5. Можете да изберете да се показва Нова страница за всеки Element, На Дата на Печат, Print Time, Номера на страниции дали да включват титлата в хедърана доклада, като отбележите / начина: да изключите съответните клетки проверка. Можете също така да искате да персонализирате заглавието и автора, като се редактира Доклад Title и Автор текстови полета. Можете също да изберете какво съдържание се показва в доклада, като отбележите / начина: да изключите квадратчетата под Доклад Contentраздел на прозореца. След като сте готови, кликнете върху Добре.

6. Сега кликнете върху завършекв прозореца на отчета за конфигурацията.

Да се ​​тълкува вижда доклада

Пример Образувани Доклад с кратки обяснения

Да преминавате през страниците на доклада, кликнете върху иконите [image] намира в лентата с инструменти в горния ляв ъгъл на екрана.

Забележка

Можеш спасяване Докладът различни формати Кликни върху Износ икона доклад [image] намира се в В лентата с инструменти. Можете да изберете да изнасят в следните формати: Excel, PDF и Дума, Моля, запишете отчета в желаното място за по-нататъшна употреба. Ако са направени промени в архитектурата на по-късен етап, нов доклад ще трябва да бъде създаден, за да се отразят промените.

Вижте също

Анализирайки си архитектура


Преглед на диаграма, време за реакция

Navigation: Анализирайки си архитектура> Персонализирани карти>

Преглед на диаграма, време за реакция

Изпратете коментари по тази тема.

Време за реакция графика ви позволява да видите дали вашите връзки са в процес на обработване на необходимото процент (т.е. в рамките на крайния срок им).

За да видите диаграма време за реакция

1. Уверете се, че имате ABACUS отворен файл съдържаща вашето населена архитектура, И че имате оценяваниВашата архитектура.

2. Изберете Insert| Диаграма| Персонализирани Charts| Време за реакция, (The Response Time Chart Configдиалоговия ще покаже.)

3. От Архитектурипадащия списък, изберете архитектурата желаете да начертае.

4. В Connectionsплощ, отбележете връзките бихте искали, включени в класацията.

5. The Scale Типплощ, изберете Линеенако искате вертикалната ос (време за реакция), за да се покаже като линейна прогресия - всеки сегмент от време се разпределя равен дял от оста. Изберете Логаритмичнаако искате да го показва като логаритмична прогресия - всеки сегмент на ос представлява все по-дълги периоди от време, толкова по-високо нагоре по оста и да отидете. (Размерът на увеличението се определя от Базаизберете.)

Отговор на диаграма време вертикална скала ос

За да експортирате диаграма време за реакция

1. Уверете се, че имате съществуваща отговор чарт времеотворена.

2. В лентата с инструменти на графиката кликнете върху най-левия Запиши като BMPбутон и изберете местоположението за графиката.

3. Кликнете Save.

Вижте също

Анализирайки си архитектура | Преглед способност пространство чарт


Преглед на диаграмата на разсейване на вашите еволюирали архитектури

Navigation: Анализирайки си архитектура> Персонализирани карти>

Преглед на диаграмата на разсейване на вашите еволюирали архитектури

Изпратете коментари по тази тема.

След архитектура е развило и целите са определени, то може да се визуализира и в сравнение с оригиналната архитектура използване разсеяно матрици. Този раздел очертава как да създадете и да разберат характеристиките на матрица разсеяно.

За да видите разсеяно Matrix от вашите еволюирали архитектури

1. Уверете се, че имате ABACUS отворен файл .

2. Уверете се, че имате еволюира и поставяне на целиза вашата архитектура, както е описан по Развиващите си архитектура

3. Изберете Insert| Диаграма| на Персонализирани Chartsтаб | Разсеяно Matrix.

4. Кликнете върху завършекбутон.

5. The Scatter Парцелс дефинирани еволюцията на архитектури и гола ще бъдат показани.

Забележка

Площта на лявата страна на матрицата на разсеяно показва настройките на матрица разсеяно показва. Това включва архитектура, която е развила (в този случай "АВС ООД As-Is 2010"), Както и целите, които са били определени за тази архитектура. Ще забележите, че целите, които имат отметка в непосредствена близост до тях са представени като х и у оси на матрица разсеяно (напр KPI- Разходите, KPI - Качество и KPI - Time). Можете да развързвам тези цели във всеки момент от време, за да ги премахнете от матрицата на разсеяно.

Сините точки, които се появяват на вашия парцел в матрицата представляват нормализирана стойност, както се определя от най-добрите и най-лошото качество (описан по Поставяне на цели за вашия еволюира архитектура ). Тези стойности са представени в Quality Space.

Две определени цели се сравняват един срещу друг в матрица разсеяно и процесът се повтаря, докато всички цели са сравнени (например Първият участък на матрицата в диаграмата сравнява KPI - Costгол с KPI - Quality гол. Вторият е Цена срещу Време и последния участък е Качество срещу Време, Съответните етикети на целта са показани в горната и дясната или всеки ред на парцели.).

6. Изберете Архитектурибутон за избор, ако искате да покажете показателите за отделните архитектури.

7. Изберете Оборотирадио бутон, ако искате да покажете нормализирани промените от оригиналната архитектура (напр As-Is 2010) Към еволюира архитектура (и) (например, To-Бъдете 2011 - Стратегия А и To-Бъдете 2011 - Стратегия B).

Вижте също

Анализирайки си архитектура | Преглед на диаграма, време за реакция | Преглед на парцел звезда на вашите еволюирали архитектури | Развиващите си архитектура


Преглед на стандартна диаграма

Navigation: Анализирайки си архитектура> Стандартни карти>

Преглед на стандартна диаграма

Изпратете коментари по тази тема.

ABACUS "стандартни диаграми включват линия, бар, колона, площ, разпръсна, пай, крива, Парето, стъпка, повърхностни, радари, куб, поничка, пирамида, контур и диаграми площ крива. След като сте избрали вида на графиката, която искате, а останалата част от процеса за гледане на всеки един от тези карти е един и същ.

За да видите стандартна схема на вашата архитектура

1. Уверете се, че имате отворете файла ABACUSсъдържаща вашето населена архитектура, И че имате оценяваниВашата архитектура.

2. Изберете Insert| Диаграмаили щракнете върху бутона в лентата с инструменти. The ГрафикиЩе се появи прозорец.

Графики прозорец

3. Изберете вида на графиката, която искате и задаване на опции за графика, а след това щракнете върху Следващия.

Опции Графика

o Подреденище покаже връзката на отделните елементи в цялото. Можете да използвате подредени диаграма, когато планирате да имате няколко серии данни (т.е. множество свойства) и когато искате да се подчертае общата сума.

o Подредени 100%ще сравни процента всяка стойност допринася за общо целия категории. Можете да използвате 100% подредени диаграма, когато планирате да имате няколко серии данни (т.е. множество свойства) и искате да се подчертае приноса към цялото, особено ако общият сбор е един и същ за всеки елемент.

o 3D графикапросто ще покаже точките с данни в 3-D формат за естетика. Ако желаете да се покаже серия от данни, заедно с третото измерение / г-ос и след това използвайте опцията Cluster Series е описано по-долу.

o Серия от имотаще покаже серия данни за всеки имот, който в крайна сметка е избран. Ако това не е отметнато тогава имотите ще станат категориите и серия от данни ще бъде за всеки елемент, който е избран.

o Rotate Chartще се завърти на 90 градуса по часовниковата стрелка графиката като сменяте Х и У оси. Тази опция е достъпна само за линиите, стъпка и Cube класациитеи е особено полезен за получаване на Milestone диаграми, както е описано във втория край под, Забележка: Колона и Бар графики са вече "въртят" версии на всяка друга.

o Cluster Seriesще покаже множество данни серия заедно измерение трети / г-ос. Тази опция е достъпна само за колоните, лентите и Cube диаграмии е особено полезен за получаване на Гант стил графики, както е описано в първата под върха.

Бакшиш

Можете да създадете Диаграма на Гантс хоризонтални ленти, показващи време / дата на имоти за различни елементи, като изберете вид Bar диаграма и след това изберете опцията Cluster Series,Освен това, след като е създаден, най-лявата лента на графиката може да се направи "невидима", като го оцветяване бяло с десния бутон върху един от баровете, избор Colour от менюто, което се появява и избора на най-горния ляв цвят от палитрата. Освен границата за най-лявата лента може да се направи "невидима" кликнете с десен бутон един от баровете, като изберете Properties ... и в раздела Series в диалоговия прозорец, който се появява промяна на граничен ефект да None и Colour до върха -left цвят от палитрата.

Бакшиш

Можете да създадете Milestone чартс малки фигури, показващи време / дата на имоти за различни елементи, като изберете вид Cube диаграма и след това изберете Chart Rotate и Cluster Серия опции,Освен това, след като е създаден, кубчета могат да се променят към други форми с десния бутон върху един от кубовете в една и съща серия на данни и изберете Properties ... и в раздела Series в диалоговия прозорец, който се появява промяна на бар или да Cylinder или Cone , Забележка: ширина Стойността на Gap може да се използва, за да "свие" символите на графиката, за да се намали припокриването, толкова по-голям броят на по-малко припокриване ще бъде там.

4. В Архитектурираздел, отбележете архитектура / и желаете да начертае свойствата на архитектурата ниво за, а след това щракнете върху Следващия.

Забележка

Избор архитектура ниво имоти е изцяло по избор стъпка и трябва да се използва само, когато искате изрично да начертае самите свойствата на архитектурата ниво.Една архитектура не е необходимо да бъде избран до тогава да включва компоненти или свързване имоти в следващия етап.

5. Изберете Елементи и Connectionsкойто искате в диаграмата от прозорец за избор на стандартен елемент , След което щракнете върху Следващия.

6. Изберете Имотиискате в чарта и кликнете завършек.

Опции Графика

o Включват стандартни свойства ще показват наследените имоти предлагани от наличните за избор стандарти.

o Обобщените имоти ще брои вариацията между стойностите на редове и начертае тези резултати, за разлика от индивида самите стойности.Тази опция е достъпна само ако и серията от вариант на имота е избран в стъпка 3 по-горе.

Бакшиш

На разположение за диаграми свойства зависят от елементите, които сте избрали.

За записване на диаграма

Забележка

Графики могат да бъдат спасени само ако те съдържат само компоненти и връзки, всички от които трябва да са от един архитектура в рамките на настоящия проект.

1. Уверете се, че имате нов или съществуващ чарт отворени сте направили необходимите промени.

2. В лентата с инструменти на графиката кликнете върху най-левия Save Chartбутон, за да спести на графиката и всякакви промени във форматирането.

3. В Графика Наименованиедиалогов прозорец, който се появява, въведете име за графиката и натиснете Добре.

За да експортирате чарт

1. Уверете се, че имате съществуваща диаграмаотворена.

2. В лентата с инструменти Диаграма щракнете на 2-ри от ляво Запиши като BMPбутон и изберете местоположението за графиката.

3. Кликнете Save.

Вижте също

Анализирайки си архитектура | Преглед на диаграма, време за реакция | Преглед способност пространство чарт


Преглед на парцел звезда на вашите еволюирали архитектури

Navigation: Анализирайки си архитектура> Персонализирани карти>

Преглед на парцел звезда на вашите еволюирали архитектури

Изпратете коментари по тази тема.

След архитектура е развило и целите са определени, то може да се визуализира и в сравнение с оригиналната архитектура използване звездни парцели. Този раздел очертава как да създавате и манипулирате звезда парцел.

За да видите един парцел звезда на вашите еволюирали архитектури

1. Уверете се, че имате ABACUS отворен файл .

2. Уверете се, че имате еволюира и поставяне на целиза вашата архитектура, както е описан по Развиващите си архитектура

3. Изберете Insert| Диаграма| на Персонализирани Chartsтаб | Star Парцел.

4. Кликнете върху завършекбутон.

5. The Star Парцелс еволюирали архитектури и задайте ще бъдат показани цели. Забележка: Осите на звезда Парцелът може да се мести, като щракнете и плъзнете осите към друг район, в границите на пространството за качество парцел звезда.

Забележка

Площта на лявата страна на звездната парцела показва настройките на парцела звездата показва. Това включва архитектура, която е развила (в този случай "АВС ООД As-Is 2010"), Както и целите, които са били определени за тази архитектура. Ще забележите, че целите, които имат отметка в непосредствена близост до тях са представени като оси на звезда парцела (напр KPI- Разходите, KPI - Качество и KPI - Time). Можете да развързвам тези цели във всеки момент от време, за да ги премахнете от звезда парцела.

Червените и зелените "точки", които се появяват на вашия звезден парцел представляват нормализирана стойност, както се определя от най-добрите и най-лошото качество (описан по Поставяне на цели за вашия еволюира архитектура ) За избраната архитектура най-високо ниво и всички еволюции на него. Тези стойности са представени в Quality Space.

Както е посочено в изображението по-горе, това се вижда ясно, че оригиналната архитектура (As-Is 2010) Е с лошо Цена, Докато първият еволюира опцията (To-Бъдете 2011 - Стратегия A) Е преместен в рамките на пространството на качеството и от подобряване на Цена, Качество и Timeголове. Алтернативно, вторият еволюира вариант (To-Бъдете 2011 - Стратегия B), докато той също се е подобрило Цена степента на подобрение е по-малка от тази на Стратегия A но и двете цели за качество и време са подобрени с повече от Strategy A.В този случай един архитект може Изберете си Стратегия A над Стратегия Bтъй като тяхната препоръкаи по-нататък да се развива, че вариант (To-Бъдете 2012 - Стратегия A).

6. Отменете Покажи еволюцииотметне квадратче, за да се скрие на линията (и), представляваща еволюцията (и) между оригинала (напр As-Is 2010) И еволюирали (например To-Бъдете 2011 - СтратегияА) архитектура (и).

7. Изберете Показване на пръчициотметне квадратче, за да се покаже относителната величина на всеки атрибут на качеството (целите, които са определени за всеки оси) за всяка архитектура.

8. Изберете Покажи Архитектура Именаотметне квадратче, ако искате да имената на оригиналния и еволюира архитектура (и) да се появи на звезда парцела.

Вижте също

Анализирайки си архитектура | Преглед на диаграма, време за реакция | Преглед разсеяно матрица от вашите еволюирали архитектури | Развиващите си архитектура


Анализирайки си архитектура

Navigation: Анализирайки си архитектура>

Анализирайки си архитектура

Изпратете коментари по тази тема.

След като сте населена (и евентуално симулирани) си архитектура, готови ли сте да използвате ABACUS да го анализира. Чрез него се анализира, може да се определи, ако вашата архитектура ще отговарят на вашите нужди.

Можете да анализирате вашата архитектура в най-различни начини:

· Диаграма

· 3D изглед

· стандартни графики (пай, ред, колона, бар и т.н.)

· персонализирани карти ( време за реакция , способност пространство , звезден парцел , разсеяно матрица и балон чарт )

· Архитектура Diff

Забележка

При създаване на диаграми, 3D изглед, Доклад или стандартна диаграма, на прозорец за избор на стандартен елемент се използва, за да изберете елементи, които искате да видите.

Вижте също

Запълването на архитектурата | Симулиране си архитектура | The Диаграми Инструмент


Какво е архитектура?

Navigation: Въведение в ABACUS>

Какво е архитектура?

Изпратете коментари по тази тема.

Архитектура е абстрактен понятие- Не физическа нещо, Това е една богата и изчерпателно описание или разбиране на структурата на система - улавяне на компоненти и как те са свързани (взаимодействат). Тъй като понятието архитектура е толкова всеобхватна, че е от основно значение за разходите, наличността, evolvability, откритостта и ефективността на системата. A звук архитектура е предпоставка за стабилна система.

В ABACUS, можете моделира вашата архитектура. За простота, ние наричаме това архитектурен модел на архитектура.

Диаграмата по-долу показва типична архитектура 5елементи (в йерархия) свързан с 2 връзки. Етикетите да посочат имената дадени на различните части на архитектурата в ABACUS.

А просто архитектура

ABACUS счита всички тези неща, за да бъде част от архитектурата:

· Елементипредставляват субектите на вашата архитектура които бихте могли да се опише като "неща". За една застрахователна компания, компонентите могат да бъдат системите за обработка на политики, искове, плащания и постъпления.

· Connectionsпредставляват връзките между тези компоненти. Така например, в една застрахователна компания, разписки се генерират по уважителни политики, претенциите са предявени срещу валидни политики и валидни претенции водят до плащания. Когато мисля архитектурно - особено при използване на ABACUS - връзките са толкова важни, колкото компоненти, и те са разгледани в почти идентична начин.

· Всичко в дървото може да има Имоти, Имоти са неща като начина, по който се изисква вашата система, за да извършите това броят на реда код го има, процентът на тези линии, които са коментари и др ABACUS счита всички тези неща, за да бъде част от архитектурата.

· Като се използва йерархии(т.е. подкомпоненти и под-връзки), Можете да скриете информация и де-композирате архитектура. Архитектурният модел ABACUS е изключително гъвкава. Всеки компонент на всяко ниво могат да бъдат свързани с всеки друг компонент на всяко друго ниво от всяка връзка на всяко ниво.

· Привързаносте операция, чрез която компоненти пристанища са длъжни да връзкароли. Ports и Роли са интерфейсаsмежду съставните елементи и връзките. Те се използват за закрепване връзки с компоненти. Connections имат Source и Sink роля(улесняване на потока от данни от източника на мивка компонент)и концептуално, компоненти имат пристанища. За простота, обаче, в ABACUS съставни пристанища не са показани и роли за връзка са пряко свързани и със самите компоненти.

· Компоненти и връзки са на определена Тип, Това е главно за целите на класирането. Например политиките, претенции, плащания и постъпления са компоненти на "System" вида. Валидните политики, валидни претенции, и т.н. са връзки на "транзакция" вида. Типа назначен компонент или връзка дава образец за имотите и стандарти, които има. Например, въведете Сървър компонент може да има "Направи & Model" стандарти IP Адрес недвижими имоти. За разлика от други твърди инструменти с основен релационна база данни (RDB) обратно в края, в ABACUS можете свободно да създадете свои собствени нови видове и да се определят свои собствени комбинации от свойства и стандарти за тях.

· Стандартните библиотеки на имоти могат да бъдат определени и възложени на нещо друго в архитектурата. Тези библиотеки са известни като Стандарти, Като се използва Стандарти, Само трябва да се съберат конкретни системи свойства - стандартните свойства са вече там. Например стандартните характеристики на изпълнение на Microsoft Windows 2000 могат да бъдат причислени към каквото и компоненти използват операционната система Microsoft Windows 2000.

Вижте също

Как се архитектура, представена в ABACUS? | Какво означава ABACUS направя? | Как го правиш (Преглед) | Създаване на нов тип


Работа с Enterprise Server

Navigation: Администрация>

Работа с Enterprise Server

Изпратете коментари по тази тема.

ABACUS Enterprise Сървър е едновременно "не-заключване" подход на сътрудничество, но на "изключен" един също. ABACUS е "не-заключване", понеже това не принуди файла да бъде заключена от един потребител, за да бъде актуализиран. Всеки потребител има собствено локално копие на файла, и тъй като те правят промени и спаси своя файл, тези промени се записват и съхраняват в случаите, когато потребителят желае да ги ангажират със сървъра.

ABACUS е "изключен", в смисъл, че не е нужно да бъдат свързани със сървъра или нужда от достъп до мрежата, докато работят на даден файл. ABACUS изисква достъп до сървъра само при извършване на операции като създаване на файла, или изпълнението на касата, заедно с операциите на съществуващ файл - актуализация, извършване, или за гледане на дневника на миналото ангажира. Достъп до сървъра не се изисква да работят по преписката, и вашите промени не са изпратена до сървъра веднага (това позволява лесно да отхвърлите вашите промени, ако сте допуснали грешка). Когато запишете файла си, вие сте "просто" спасяването си копие локално - то не е, докато не се ангажира, че вашите локални промени (промени, направени след последния си комит), се изпраща на сървъра.

Създаване на File New Enterprise

За да създадете нов файл Enterprise, изберете Пила| New ...и след това изберете една от първите две опции в раздела Enterprise модел на New Project диалоговия (т.е. или празен файл Enterprise, или да създадете един от съществуващ ABACUS файл). Третият вариант е да "Checkout" файл Enterprise някой друг вече е създал, това ще бъде покрит в следващия раздел.

Когато решите да създадете нов файл Enterprise, ще ви бъде даден диалогов прозорец, който ще ви позволи да разглеждате, където върху хранилище сървър искате да съхранявате вашите файлове. Той също така ще има съществуващ файл пътя и наименование, вписано до върха, ако сте избрали "От съществуващия модел" от диалоговия прозорец New Project и доставени файл.

URL: Това е URL адреса на вашия сървър хранилище, където се съхраняват файловете ABACUS на предприятието. Трябва да попитате лицето, което ще отговаря за управлението на сървъра какво трябва да бъде този URL.

Снимката по-горе показва хранилище с четири (4) съществуваща проекти ABACUS на предприятието, след въвеждане на URL и натиснете Enter. Вие Ще видите, след като създадете нов файл Enterprise, на следващия скрийншота за "Checkout", няма да има друга папка и файл по това хранилище.

Забележка

Ако използвате HTTPS (SSL) сървър, а сървъра не разполага с валиден сертификат SSL (обща за интранет или непублични сървъри, дължащи се на на цена на SSL сертификатs) Ще има една допълнителна стъпка да предприеме. Вие ще трябва да приеме окончателно всички връзки към сървъра, че в диалога, който се появи (тя също така ще покаже малко повече информация за сървъра). За да направите това, въведете "р" (без кавичките) и натиснете Enter. ABACUS ще се появи съобщение, което ви напомня за това, преди да показва диалоговия прозорец.

Забележка

Може да се наложи да влезете в сървъра, като в този случай на лицето, което е управление на сървърможе да осигури на сървъра потребителско име и парола. Също така, на пълномощията за вход за всички сървъри, които сте свързани към сме спасени, така че ако по някаква причина те трябва да бъдат изчистени това може да стане чрез Tools | Опциии след това на Общ раздела, като щракнете Reset Subversion Запазени Входи избор на сървър от падащия списък и щракнете върху бутона Clear Входи изберете OK в диалоговия прозорец, който се появява.

Забележка

За разлика от скрийншота, показана по-горе, обикновено единично ABACUS Project е включено във всеки ABACUS Repository, защото ако са повече от 1 ABACUS Project е създаден в един ABACUS Repository, промяна лог номерата на ABACUS са споделени между всички ABACUS Проекти и това може да обърка потребителите.

Предпочитан Велик: Това се отразява както на папката и името на файла, който ще се използва (ако вече не е взето) при създаването на файла на хранилище сървъра. Имайте предвид, че се създава нова папка автоматично на хранилище сървъра за всеки файл (от съображения за успешно представяне, ABACUS предприятието файлове са създадени в тяхната собствена папка под местоположението Прегледан в диалога).

Съхранявайте Работната Copy в Directory: Когато файл Enterprise е създадена в хранилище, сървър, трябва местните работни файлове, за да бъде създаден на вашия компютър, така че можете да работите върху файла, без да бъдат свързани към мрежата. Това е мястото, което ще отидете до когато искате да отворите / повторно отворен файл ABACUS Enterprise.

Поръчката съществуващо предприятие на файла

Ако някой вече е създаден нов файл Enterprise, можете да "касата" този файл, който изтегля локално копие и определя необходимите файлове, така ABACUS признава това като файл Enterprise. Диалогът е подобен на New Enterprise File Dialog. Въведете URL адреса на хранилището (поддиректории могат да бъдат включени в URL), изберете желания файл и натиснете OK. При спазване на бележката под ттой подаде след това ще се отвори.

Забележка

Може да се наложи да влезете в сървъра, като в този случай на лицето, което е управление на сървърможе да осигури на сървъра потребителско име и парола. Също така, на пълномощията за вход за всички сървъри, които сте свързани към сме спасени, така че ако по някаква причина те трябва да бъдат изчистени това може да стане чрез Tools | Опциии след това на Общ раздела, като щракнете Reset Subversion Запазени Входи избор на сървър от падащия списък и щракнете върху бутона Clear Входи изберете OK в диалоговия прозорец, който се появява.

Enterprise файлови Разлики

Когато сте създали файл Enterprise (или нов, или чрез "касата" на файл, създаден от някой друг), папка ще бъде създаден за файла, и то често ще съдържа следните 3 основни типове файлове:

· ".abacus" Файл- Това е самия файл ABACUS. Промените, които правите на местно ниво не са веднага запазена в този файл, защото е писано само за това кога да се ангажират. Този файл е "нормално" ABACUS файл, той може да се дава на потребители, които не ЕЕкато самостоятелен проект (без .log файла), Или да се използва като отправна точка за нов EE файл.

· Файлът ".changes"- Местните (неангажирани) промените, направени в файла. Ако този файл липсва, това означава, че няма локални промени.

· ".log" Файл- Този файл има само промените, които бяха направени от последния потребител (съдържанието на .changes файл на потребителя, когато те извършили).

Забележка

Има различни други файлове, които могат да бъдат създадени по време на актуализацията и да се ангажират процеси, а именно; ‘.changesbefore"Файл- Този файл е копие на файла на .changes след актуализация е извършена и се използва за автоматично примири никакви лични конфликти между актуализацията и всеки местен (неусвоени) промени, преди да се ангажират; ‘.backup"Файл- Този файл е копие на файла на .changes преди потребителят да спестява повече местни (неангажирани) промените на файла .changes; и ‘.error"Файл- Този файл е копие на .changes подаде, ако имаше всички въпроси, които предизвикват ABACUS да успеят да отворите файла .abacus и потребителят е избрал да се върне техните промени.Тези файлове могат да бъдат пренебрегнати.

При отваряне на файла

За да отворите файл, само трябва да отидете до къде сте избрали да съхранявате работното копие, и отворете файла ABACUS, която се съхранява там. Когато ABACUS вижда, че е налице .лог файл (а може би и по- .промени подават, ако сте направили промени), тя ще се лекува файла като файл Enterprise.

Актуализиране на файла

Извършване нап "актуализиране" ще провери дали по-нова версия на даден файл се намира на сървъра. Ако има, тя ще затвори текущата си файл, актуализирайте до по-нова файл от сървъра, и изтегляне на някои временни файлове, които имат редица като разширение - напр "Demo.125". Тези файлове са по-стари версии на .log файла, и се използват за да се определи какви са били направени промени във файл, тъй като последният актуален. Това е необходимо, за да се открият всякакви конфликти, които могат да са настъпили, така че можете да ги разрешите.

Ако по време на процеса на актуализация всеки конфликтиНе бяха намерени, Ще трябва да ги решим, преди да можете да отворите файла ви отново (можете да отмените но Вие ще бъдете помолени да разрешат конфликтите отновоследващия път, когато отворите файла).

Запис на файла

Когато запишете файл, това добавя всички промени, които сте направили към досието на .changes. То непроменяте файла .abacus на този етап - само когато файлът е поела ангажимент към сървъра ще бъде да го написал над (или когато получавате актуална информация от сървъра).

Къде е "Save As"?

Липсва концепция на Запиши като за предприятието файлове. Можете, обаче, да, да копирате вашия работен екземпляр .abacus файл, като се има предвид, че той няма да има вашите локални промени в него.

Разрешаване на конфликти

Ако други потребители са извършили промени на файла по подобен част от досието за вас, може да има някои конфликти между техните промени и твоя. Например, друг потребител може да изтриете компонент, който сте имали актуализиране на имот на, Трябва или да отмените тяхната промяна (ако сте сигурни, че техните следване да се случи), или отхвърлите климата (тогава може да се върне обратно в преписката и ремонтирам си на климата).

Конкретно има 4 класа на конфликти, които могат да възникнат;

1. Изтривам - Когато един потребител изтрива обект друг потребител промени. Например Потребителят A заличава компонент но User B сменя името на компонента, или свързани с него, или да се добави едно дете компонент към него и т.н.

2. Атрибут - Когато двама потребители и двете се променят точно същото "атрибут" на даден обект. Например И двете User A и B Потребителят променя името компонент или неговото описание или стойността на един от неговите свойства и т.н.

3. Препратка - Когато двама потребители се променят точно същото "препратката" обект има друг предмет. Например И двете User A и B Потребителят променена тип компонент или източник / мивка компонент, свързан към връзка или свързана гледна точка за диаграми и т.н.

4. Колекция - Когато двама потребители се променят "събиране" за обект. Например И двете User A и B Потребителят премества компонент от един родител в друга или повторно нареди колекция от детски компоненти.

Забележка

Различни незначителни конфликти се решават автоматично от ABACUS да се намали натоварването на потребители.Например всички противоречащи настройки пан-мащабиране за диаграми са решени да поддържат най-новите настройки пан-мащабиране.

Ангажираност Промени

Когато решите да се ангажират вашите промени, файлът ABACUS от сървъра се отваря, си местен се извършват променисрещу него, и тогава вашия местен .abacus файл се презаписва с такъв, който има вашите промени в него. Вашите промени подават след това се записва върху .log файла и двете .abacus файл и на .log файла се изпраща на сървъра.Ако се ангажират е успешна една Ангажиране диалоговия ЛС, както е показано по-долу е предоставена, за да въведете съобщение с комит.

Преглед на Log на промените

Да се видите дневник на промените на Начинание проектИзберете Пила| View Log...

Максимални Вход влизанияТози подразбиране ще последните 10 вписвания, но допълнителни записи могат да бъдат намерени чрез промяна на стойността и кликнете върху връзката Изтегли бутон.

Ревизия: Thколона д Revision изброява номерата на редакция, извършени до сървъра Enterprise, по подразбиране, в обратен хронологичен ред.

Забележка

Номерата на редакция може да не са непрекъснати, както сметало, извършва ще бъдат изброени само докато същият Subversion хранилището може да се използва за други проекти ABACUS и / или други приложения за контрол на версиите.

Дата: Thд Дата колона изброява датата че преразглеждането е било извършено към сървъра Enterprise.

Време: Thколона д Time списъци от времето на деня (в 24-часов формат), че преразглеждането е било извършено към сървъра Enterprise.

Автор: Thд Автор колона изброява името за влизане на Microsoft Windows за потребителя, че е извършил комит последвано от тяхното ABACUS потребителско име Или "Anonymous", ако потребителят не е идентифициран и анонимни потребители бяха оставени достъп до проекта на Enterprise към момента на комит.

Вход Message: Thколона д Вход Message изброява съобщение ангажират, че е снабден с преразглеждането по диалога, показан по-горе.

Download редакция XX като самостоятелен файл ABACUS: Ако изберете дадена редакция в таблицата и след това щракнете върху бутона Download ще можете да извлечете избрания ABACUS преразглеждане на проекта от сървъра и да го запишете като местен / самостоятелен проект ABACUS.

Забележка

За да се връщам към предишната редакция, моля вижте това Статия Avolution общността .

(Admin) Изтегли XML файл Вход за редакция XX: Потребителите с Administrator способността на ABACUS могат да изберат дадена редакция в таблицата и след това щракнете върху бутона Изтегли за извличане на избрания проект ABACUS ангажират лог файл от сървъра и да го запишете като .xml файл.

Преглед на одитната пътека на промените

Да се разглеждане на одитна пътека на промените в даден елемент (т.е. компонент, връзка, гледката, децата и т.н.) на един Начинание проект, щракнете с десния бутон на елемента и изберете Audit Trail...Задайте от и до кръг Ревизия и кликване Търсене.

Забележка

След като даден елемент бъде изтрит от проекта вече не сте в състояние да получите достъп до конкретна информация одитна пътека за този елемент. Можете, обаче, все още достъп до компонента "майка" (например) и да видите информация одитна пътека относно заличаването (в този случай листинг идентификацията на елемент, който е заличен).Освен това, Component / закрепване Connection е "собственост" на връзките, така променящите прикачен компонент през прозореца на Explorer или върху Diagrams ще покаже в одитната следа за връзка НЕ ​​компонента и изтриване на връзка и създаване на нова връзка (като се случва, ако щракнете с десния бутон "Unattach" и след това "Свързване на ..." в каталози), ще доведе до загуба на информация одитна пътека за първоначалния компонент - запор връзка напълно.

Забележка

По подразбиране одитната следа рекурсивно ще проверява за промени в някое от децата на избрания елемент. Това може да доведе до дълги времена за реакция и съответно проследяването на одита може да бъде ограничено до самия елемент като премахнете Рекурсивно Възможността за избор по Опции за одит"зъбно колело" бутон на лентата в диалога Audit Trail.

От RevisionТози подразбиране ще се първата / старият разположение за проекта на сървъра Enterprise преразглеждане.

За да RevisionТози подразбиране ще последната / Последната версия на разположение за проекта на сървъра Enterprise.

Забележка

След като зададете от и до преразглеждане обхват кликнете върху бутона за търсене, за да изтеглите всички специфични промени на избрания елемент.

Ревизия: Thколона д Revision изброява номерата на редакция, извършени до сървъра Enterprise, по подразбиране, в хронологичен ред напред.

Забележка

Номерата на редакция е малко вероятно да бъде непрекъснато, тъй като само ревизиите, свързани с избрания елемент ще бъдат показани и само на ABACUS ангажира ще бъдат изброени, докато същият Subversion хранилището може да се използва за други проекти ABACUS и / или приложения за контрол на версиите.

Дата: Thд Дата колона изброява датата, на която е направена жалбата за употреба.

Забележка

Датата е показана датата на действие на потребителя, а не датата на преразглеждането е било извършено към сървъра Enterprise. Съответно, може да предхожда датата на съответното преразглеждане комит дата е показано с File | Виж Log ...команда.

Време: Thколона д Time списъци от времето на деня (в 24-часов формат), което е направено действията на потребителя.

Забележка

Показаното време е времето за действие на потребителя, а не по време на преразглеждането е било извършено към сървъра Enterprise. Съответно, времето вероятно ще предшества съответния преразглеждането ангажират времето показано с File | Виж Log ...команда.

Автор: Thд Автор колона списъци на потребителя, че извършва Microsoft Windows име за влизане в действие на последвано от тяхното ABACUS потребителско име Или "Anonymous", ако потребителят не е идентифициран и анонимни потребители бяха оставени достъп до проекта на Enterprise по време на действието на потребителя.

Забележка

Авторът вписана в диалога Audit Trail не е задължително да съвпада с автора, изброени в диалоговия прозорец View Log-горе за същия преразглеждане. Това е така, защото диалогови списъци View Вход на влезли в системата потребител по време на ангажират докато диалогови списъците за одитна пътека на влезли в системата потребител по време на действието на потребителя, и е възможно да има един потребител да прави промени и да изпрати своето. промени файла на друг потребител да се ангажира - както е в случая, когато външен потребител (като Avolution) е да се работи по проект EE.

Детайли: Thд Детайли колона изброява точните детайли на действията на потребителя, както е записано в сървъра Enterprise.

Бакшиш

Полезно е да се група от колоната Revision (както е показано в диалога по-горе) и / или колона Потребителят Action да се лесно класифицира промените в елемент на интереси.

Използването на Scripting с предприятието файлове

Ако използвате скриптове с предприятието файлове, трябва да сте наясно за това как правилно да изтриете обект от модела. Обикновено, когато изтривате обект, ще се обадя на метода на .Delete () върху него, а не само да го извадите от неговата майка.

Например ако бяхте comp1 като родител на comp2 и желаете да изтриете comp2 във вашия скрипт, трябва да се обадите comp2.Delete (), а не comp1.Components.Remove (comp2).

Можете да използвате премахне, ако възнамерявате да добавите comp2 обект на друго място в рамките на архитектурата, но това не трябва да се използва, ако намерението е да изтриете обекта.

Налице е изключение от това, защото, когато искате да премахнете обект, който "живее" на друго място в този модел. Когато искате да премахнете стандартен например от архитектура / компонент / връзка, тогава вие ще го направите, като го извадите от инстанция на стандартна колекция - arch1.Реализациите.Демонтирайте (ИМП) - защото това изтриване ще го премахнете от всички инстанции.

Правилно използване на Изтриване на скриптове е важно, защото, ако един обект е изваден от objectmodel, а не отново да добавя, тогава тя няма да бъде в състояние да се намира, но тъй като това не е конкретно "изтрит", Conflict Resolution Detection и не ще разпознава правилно конфликт, ако друг потребител е да се опитате да използвате този предмет в някоя от техните промени, а крайният резултат ще бъде повреден набор от промени за този потребител.

Вижте също

Как се архитектура, представена в ABACUS?


Работа с файлове ABACUS

Navigation: Въведение в ABACUS>

Работа с файлове ABACUS

Изпратете коментари по тази тема.

Сметало файл е контейнер за модела на вашия архитектура , В рамките на една-единствена ABACUS файл, можете да моделирате произволен брой архитектури неограничен брой пъти.

Когато за пръв път отворите ABACUS, няма файлове отворени. Да работи в сферата на архитектурата, трябва или да създадете нов файл, или отваряне на съществуващ файл.

Когато отворите или да създадете нов файл, дърво в прозореца на Explorer ще покаже автоматично. Това мнение изследовател ви показва вашата архитектура към днешна дата. Когато затворите файла, дървото в прозореца на Explorer също ще изчезне.

За да създадете нов файл ABACUS

1. Изберете Пила| New ...

2. В диалоговия прозорец New Project, който се появява (както е показано по-долу) Изберете сиили да създадете празен модел, образец от стандартна ABACUS библиотека , Модел от обичай ABACUS библиотека, модел от XML, MS Access , MS Visio , MS Excel , MS SQL Server , Една Начинание Сървър модел или потребителски ABACUS библиотека (.abacuslib файл).

3. Кликнете върху Добребутон и следвайте всички диалогови прозорци, които могат да се появят.

Бакшиш

Вие няма да бъдете помолени да назоват файла, докато не спаси или да го затворите. Това е добра идея да се запишете файла си, веднага след като го създадете. Тогава няма да се налага да се притеснявате за това именуване по-късно в процеса, когато сте се концентрира върху други сложни неща (като населяващи си архитектура).

Създаване на нов проект

ABACUS Стандартните библиотеки

ABACUS поддържа над 100 обществените рамки и анотации някои от които са показани по-долу. При избора да създадете нов проект от стандартен читатели имат бърз старт за моделиране в рамките на установяване рамка като се възползват пълноценно от всички определени типове елементи, атрибути, анотации, гледни точки и шаблони или модели. Допълнителни стандартни библиотеки са свободно достъпни чрез Avolution общност тук .

Нов проект от Standard Library

За да запаметите нов ABACUS файл

1. Изберете Пила| Запази като

Бакшиш

Имената на файловете могат да бъдат с всякаква дължина, и могат да съдържат никакви букви, цифри и интервали. Те не могат да съдържат тилда (~) характер, на тръбата (|) характер, въпросителния знак, или героите обикновено се използва за описание пътя като наклонена черта (\) - освен като част от пътя (?).

За да отворите съществуваща ABACUS файл

1. Изберете Пила| Отворено

Забележка

Ако при отваряне на файла, от място на споделена мрежа, която вече е отворен на друг потребител, ABACUS ще ви осигури достъп само за четене. При използване на ABACUS с достъп само за четене, няма да бъде в състояние да изпълнява операциите запис, като например попълване си архитектура и течаща оценители. Можете, обаче, да прегледате в архитектурата, използвайки изгледа на изследовател и 3D изгледи.

Вижте също

Как се архитектура, представена в ABACUS?


Работа с Dashboards

Navigation: Администрация>

Работа с Dashboards

Изпратете коментари по тази тема.

Проекти ABACUS могат да имат всякаква конфигурация на мнения (напр диаграми, Графики и т.н.), записани като таблото и тези, записани табла могат да бъдат задайте по подразбиране започва със "Екран" за откриване на проект и / или свързани с конкретна потребителска група и бе представен на членовете на тази група потребители, когато те влезте в проект ABACUS.

Забележка

За да конфигурирате табла в проект ABACUS лицензията за нуждите на потребителите възможността за Administrator. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

Преглед на Dashboards

Един пример Application Management Portfolio (APM) таблото

За да видите запазена Dashboard

1. Изберете Изглед| Dashboards

2. Изберете записано таблото от списъка на наличните информационни табла.

Забележка

След като бъде избран ABACUS ще изгради становищата, необходими за арматурното табло и това може да отнеме няколко секунди. Моля, бъдете търпеливи.

Управление Dashboards

Управление Dashboards

За да създадете нов Dashboard

1. Отваряне на необходимите възгледи и организира и док прозорци, които се изискват за таблото.

2. Изберете Изглед| Dashboards| Управление Dashboards ...

Забележка

Ако не виждате менюто на Управление Dashboards тогава не е нужно способността на Administrator. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

3. В диалоговия прозорец, който се появява изберете Създавамбутон и въведете името на Dashboard в диалоговия прозорец New Dashboard Създаване.

4. Кликнете върху Добребутон.

За да изтриете съществуващ Dashboard

1. Изберете Изглед| Dashboards| Управление Dashboards ...

2. В диалоговия прозорец, който се появява изберете таблото за управление, който искате да изтриете от списъка и изберете Изтривамбутон.

Забележка

Изтриване на таблото също ще изтрие всички потребителското групови задачи за тази таблото.

3. Кликнете върху Добребутон.

За да подмените съществуващ Dashboard

1. Отваряне на необходимите възгледи и организира и док прозорци, които се изискват за подмяна таблото.

2. Изберете Изглед| Dashboards| Управление Dashboards ...

3. В диалоговия прозорец, който се появява изберете таблото за управление, който искате да се замени от списъка и изберете Заменетебутон.

4. Кликнете върху Добребутон, за да признае диалога Dashboard Заменен.

За да присвоите Dashboardкато Start Screen по подразбиране

1. Изберете Изглед| Dashboards| Управление Dashboards ...

2. В диалоговия прозорец, който се появява изберете таблото от списъка, който искате да присвоите като начало по подразбиране "Екран"и изберете Присвояване на ...бутон.

3. В диалоговия прозорец, който се появява изберете влизане в групи колона User.

Забележка

Само един на бордното табло се определя като започне "екран", така повторно задача ще премахне задача от предходната таблото.Освен това, ако потребителят се регистрира като член на група потребители, които има назначен таблото тогава назначен таблото ще бъде открит на мястото на таблото на проекта подразбиране.

4. Кликнете върху Добребутон.

За да присвоите User Group към Dashboard

1. Изберете Изглед| Dashboards| Управление Dashboards ...

2. В диалоговия прозорец, който се появява изберете таблото от списъка, който искате да зададете потребителска група с и изберете Присвояване на ...бутон.

3. В диалоговия прозорец, който се появява изберете User Group (или групи)който искате да зададете на таблото като "стартира" екран за.

Забележка

Ако една и съща група потребители е назначен множество табла ще се използва първата задача в списъка.

4. Кликнете върху Добребутон.

За да отмените а User Group от Dashboard

1. Изберете Изглед| Dashboards| Управление Dashboards ...

2. В диалоговия прозорец, който се появява разширите покупка Dashboard от списъка, който искате да отмените потребителска група от.

3. Изберете групата на потребителя, който искате да отмените и изберете Отменитебутон.

4. Кликнете върху Добребутон.

Определяне на разрешения

Разрешения могат да бъдат определени за табла за да се позволи на таблото, за да може да се вижда, Обновяващ и / или deleteableв съответствие с дадени потребителски групи.

Разрешения за управление

За задаване на разрешение за Dashboard

1. Изберете Изглед| Dashboards| Управление Dashboards ...

2. В диалоговия прозорец, който се появява изберете таблото от списъка, който искате да зададете разрешения за и изберете Permissions ...бутон.

3. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

4. По подразбиране ще видите, че Read, актуализацията и Изтрий разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

5. Кликнете върху Добребутон.

Вижте също

Персонализиране на интерфейса ABACUS | Работа с Permissions


Работа с Permissions

Navigation: Администрация>

Работа с Permissions

Изпратете коментари по тази тема.

Проекти могат да имат ABACUS роля базираниразрешения, определени за всеки елемент в рамките на хранилището. По-конкретно, финозърнеста Create-RЕАД,Update-Delete (CRUD) Разрешения могат да бъдат определени на "обекта" (т.е. компонент или връзка), гледката и атрибута (т.е. собственост) нива.

Преглед

Когато се работи с ABACUS Enterprise Сървър , ABACUS осигурява фин, роля базирани боклук разрешения, за да контролират достъпа на множество потребители да хранилището.

Забележка

За да конфигурирате разрешения в проект ABACUS лицензията за нуждите на потребителите възможността за Administrator. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

Разрешения могат да бъдат настроени за архитектури, елементи и съединителни видове, свойства (чрез техните видове), шаблони, гледни точки и диаграми, каталози, матрици, диаграми и 3Dгледания, Когато разрешения са дадени за компонент или Вид връзка на всички случаи на този вид във всички архитектури в този проект "наследи" тези разрешения. По същия начин, когато разрешение е определен за един имот на компонент или тип връзка, дадената собственост на случаите на компонентите или свързване в каквито и архитектури в този проект "наследи" тези разрешения. Съответно, определени разрешения ще бъдат приложени към възгледите на която съществуват тези елементи. Когато разрешенията са определени за диаграма, гледката и / или съдържанието на самата гледка има различни разрешения, прилагани за нея.

Забележка

По подразбиране не са определени разрешения за елементите в рамките на проект ABACUS. Това е като всички елементи са Createable, разбираеми, обновяващ и Deleteable от всички потребители. По този начин следва да се считат само разрешения за даден елемент в хранилището когато определен разрешение да бъде ограниченза определена група потребители. Например, ако се прибавят разрешения за дадена група потребители до обект (например тип компонент), но остана с всички разрешения скрипт, то това е функционално същите като ако тази потребителска група не е добавя към обекта.

Permissions не могада се настрои за конкретни случаи на елементи от архитектурата на. Например, не можете да направите един компонент Application обновяващ поредното не. За да се постигне ефективно тези "домейни" специфични разрешения обаче Администратора може да се създадат специфични типове елементи за дадените области, напр "Заявление - CRM домейн" видове компоненти и "Заявление - HR домейн", а след това е определил правата за всеки тип съответно. Можете да направите конкретни видове групиране за всеки домейн и след това извадете актуализация разрешение за домейн-специфични типа група и това ще ограничи творения в рамките и заличаванията от това обединение, но не се актуализира на децата. Разбира се, ако обединение на домейн-специфично е била скрита чрез премахване прочети разрешение тогава децата ще бъдат скрити и по този начин не-обновяващ. Алтернативно, ако е видяна (а не изследовател) се използват главно за управление / виж хранилище, даден изглед за всеки домейн може да бъде установена, а след това на администратор може да зададете разрешения за всяка гледна съответно.

Управление на потребители и групи

Разрешения са определени в роля или групаниво, за разлика от индивидуалното ниво потребител, така че докато членството на групите може да се промени, разрешенията могат да остават фиксирани. Разбира се, ако искате специално разрешение за употреба след това просто да ги направят група, или по-точно се създаде група с този потребител като единствен елемент.

Трябва да се отбележи, че групи са атомен, Което означава, че не могат да наследят разрешения или потребители от един на друг, и ако потребителят принадлежи към няколко групи след това "най-песимистичния" разрешение група ще има предимство по случай по случай поотделно за всеки отделен разрешение (т.е. Създаване -Read-Актуализация-Delete). Например, ако един и същ потребител е член на група А и група Б и група А току-що Създаване-Read разрешение за типове Application съставни докато Група B е само за четене Актуализация разрешение за типове Application съставни тогава потребителят само ще са прочетени разрешение за Application съставни случаи.

Освен това, по подразбиране, анонимни потребители(това е потребителите, които не са определени или които не са влизали в) имат пълен достъпкъм проекта. Това е да се осигури достъп е наличен в първоначалната конфигурация. За да блокирате достъпа на анонимни потребители просто махнете отметката от "Позволи на анонимен потребител пълен достъп до досието" опция в Управление на потребители / групи диалоговия показано по-долу. Когато непроверени анонимни потребители ще имат възможност да видят част стандарти на всеки проект, само.

И накрая, ако се проверява опцията "Използвайте Windows име Login" потребителско име удостоверяване се извършва срещу Windows име влизания на машина на всеки потребител срещу потребителско име те години влезе по-долу. Това е, ако Windows име за вход за машина дадена на потребителя съществува като валидно потребителско име след това не се изисква парола и потребителят автоматично се заверяват. Забележка: това позволява ефективно използване на Windows Active Directory (AD) удостоверяване.

Забележка

Като се има предвид, че разрешения се определят само когато те се нуждаят, за да се отнеме (ограничен) от потребител, всеки потребител, който не е член на група, или всяка група, която все още няма разрешения, определени за това от всякакви обекти, ще има пълен достъп до Проектът.

Потребители и потребителски групи

За да създадете нов потребител

1. Изберете Пила| Управление на потребители / групи

Забележка

Ако не виждате Управление на потребители / групи елемент от менюто тогава не е нужно способността на Administrator. Моля, свържете се с местния ABACUS администратор или Подкрепа Avolution ако имате нужда от тази възможност.

2. В диалоговия прозорец, който се появява изберете Добавяне на потребителбутон и въведете потребителско име и парола в диалоговия прозорец User Създаване New. Забележка: Потребителските имена и пароли са чувствителни.

Забележка

Ако опцията "Използвайте Windows име Идентифицирайте се проверява, както е описано по-горе след това сляпо парола може да се впише като удостоверяване ще се осъществява в съответствие с единствената Window е на потребителя Потребител Вход.

2. По подразбиране ще видите, че Потребителите могат да променят своя собствена парола. Ако е необходимо, администраторът може да премахне ABACUSна способността на потребителите да определят свои собствени парола от махнете отметкатаквадратчетата.

Забележка

Ако потребителите могат да сменят паролата си те ще имат File | Промяна на парола ...елемент от менюто, за да го направят.Също така, имайте предвид, че ако много хора използват същото потребителско име след това един потребител може да промените паролата, така че няма други хора могат да влизат след това. Съответно, се препоръчва практиката да има едно име на един истински човек.

4. По избор, въведете имейл адреса, Място и телефонен номер за потребителите за бъдещи справки.

5. Кликнете върху Добребутона в диалоговия прозорец User Създаване New.

6. Кликнете върху Добребутон.

Забележка

След като сте създали първата си потребител трябва да имате предвид блокиране на достъпа от анонимни потребители като премахнете отметката от "Позволете анонимен потребител пълен достъп до досието" опция в / диалоговия прозорец Управление Потребители Групи.Също така, след като потребителят е създал (и ако един проект Enterprise, промяната ангажира със сървъра), следващия път, когато проектът е отворен потребители ще бъдат подканени да Вход за автентифициран достъппо диалога, показан по-долу. Ако Влез автоматично с тези подробностиопция се проверява след потребителското име / комбинацията парола ще бъде запомнен с проекта и прилага всеки път при отваряне. За да изчистите запазена вход изберете File | Clear Saved Входслед отваряне и ще бъдете подканени да влезете отново следващия път, когато отворите проекта.

вход

За да изтриете съществуващ User

1. Изберете Пила| Управление на потребители / групи

2. В диалоговия прозорец, който се появява, изберете User името в програмата Потребители панел, който искате да изтриете, и след това изберете Изтриване на потребителябутон.

3. Кликнете върху Добребутон.

За да създадете нова група

1. Изберете Пила| Управление на потребители / групи

2. В диалоговия прозорец, който се появява изберете Добави Groupбутон и въведете име на групата в групи панел.

Забележка

Група имена трябва да са уникални.

3. Кликнете върху Добребутон.

Да се копирате съществуващаГрупа

1. Изберете Пила| Управление на потребители / групи

2. В диалоговия прозорец, който се появява изберете копиеГрупабутон.

Забележка

Дубликат група ще бъде създадена с представка "Копие на".По подразбиране всички разрешения от копирания групата ще бъдат дублирани за "копие на" група, включваща всеки потребител задача.

3. Преименуване на "копие на" група, както е подходящо, използвайки Edit Groupили бавно двойно кликване.

За да изтриете съществуващ Group

1. Изберете Пила| Управление на потребители / групи

2. В диалоговия прозорец, който се появява изберете името на Група в групите панел, който искате да изтриете, и след това изберете Изтриване на групабутон.

Забележка

Всеки потребител задачи към групата също ще бъдат премахнати.

3. Кликнете върху Добребутон.

За да присвоите на потребителя до Group

1. Изберете Пила| Управление на потребители / групи

2. В диалоговия прозорец, който се появява, изберете User името в програмата Потребители панел, който искате да присвоите на група и плъзгане и пускането върху името Group в групи панел, който искате да я възлага.

3. Кликнете върху Добребутон.

Забележка

В групата (ите), които потребителят е назначена да се показват чрез разширяване на Прякор в панела Потребителии потребителите, които са възложени на една група са показани чрез разширяване името на Група в групи панел. Например, в горната снимка, на "AS1-Aus" потребителя се определя на три (3) групи, а именно; "App Support Team 1", "Край" и "Австралия".

За да отмените Потребител от Група

1. Изберете Пила| Управление на потребители / групи

2. В диалоговия прозорец, който се появява разширите името на групата, която съдържа заданието за потребителя, който искате да отмените и изберете User име.

3. Кликнете върху Отмените Userбутон.

4. Кликнете върху Добребутон.

За да импортирате потребители и / или групи (и всички съвпадение на Permissions)

1. Изберете Пила| Управление на потребители / групи

2. Кликнете върху Вносбутон.

3. В диалоговия прозорец, който се появява Пасада и отвори проекта, който съдържа ABACUS на ползвателите и / или групи (и разрешения), които искате да импортирате в настоящия проект и кликнете Отворено, На потребители и групи, ще бъдат внесени и диалоговия за внос Резултати появява обобщаване на вноса на ползвателите и / или групи. Кликнете върху Добребутон.

Забележка

Ако внесените потребители или групи вече са съществували в текущия проект след това те ще се слеят със съществуващите потребители или групи.

4. Кликнете върху Добребутона за връщане в главната Управление на потребители / диалоговия групи.

5. Ако има някакви Видове съвпадение, гледни точки, шаблони или архитектури между настоящия проект и проекта ABACUS да се импортират от, пълни с разрешения, които вече не съществуват в настоящия проект, разрешенията се внасят и диалогови втора Вносни Резултати Появява се обобщават вноса. Кликнете върху Добребутон.

Забележка

Разрешения се прибавят само към съществуващите видове (и техните Properties), гледни точки, шаблони или архитектури за групите, където разрешенията не вече съществуват за Групата. Или защото групата е нова или Групата е съществувало още в настоящия проект, но не и разрешения са били възложени за тази група към тази статия. Няма "сливане", на разрешения за подобни продукти, когато разрешения вече са съществували в продължение на Групата в настоящия проект.

Определяне на разрешения

Разрешения могат да бъдат настроени за архитектури, елементи и съединителни видове, свойства (чрез техните видове), шаблони, гледни точки и диаграми, каталози, матрици, диаграми наг 3Dгледания, Когато разрешения са дадени за компонент или Вид връзка на всички случаи на този вид във всички архитектури в този проект "наследи" тези разрешения. По същия начин, когато разрешение е определен за един имот на компонент или тип връзка, дадената собственост на случаите на компонентите или свързване в каквито и архитектури в този проект "наследи" тези разрешения. Съответно, определени разрешения ще бъдат приложени към възгледите на която съществуват тези елементи. Когато разрешенията са определени за диаграма, гледката и / или съдържанието на самата гледка има различни разрешения, прилагани за нея.

Разрешения за управление

За задаване на разрешение за Component (или Connection) Тип

1. Разгънете Видовеклон на дървото.

2. Разгънете Компонент (или връзка) Видовеклон на дървото.

3. Разширяване Групикогато е необходимо.

4. Кликнете с десния бутон на Компонент (или Connection) Типжелаете да зададете разрешения за и изберете Редактирай Permissions.

5. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

6. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

Забележка

Създайте разрешение урежда също така, когато можете да копирате елемент. Съответно, за да бъде в състояние да копирате елемент изисква Създаване разрешение за всички свои деца (тъй като, за да копирате елемент означава копиране на всичко под него). Премахване на разрешение, актуална информация от един елемент премахва възможността за промяна на самата тип, дори ако потребителят има дизайнер добавка и Също така премахва Актуализация разрешение за всички негови свойства. А майка елемент трябва да има разрешение Актуализация да бъде в състояние да Създаване на всякакви детски елементи или Изтрий си съществуващ детски елементи. Изтриване на разрешение за даден елемент също изисква Изтрий разрешение за всички свои деца. Изтриване на разрешение за компоненти също изисква разрешение Актуализация на всички прикрепени връзки.И накрая, премахване Delete разрешение от елемент премахва възможността за изтриване на самия вид, дори ако потребителят има Проектанта добавка.

7. Кликнете върху Добребутон.

За да зададете разрешение за група от Component (или Connection) Типове

1. Разгънете Видовеклон на дървото.

2. Разгънете Компонент (или връзка) Видовеклон на дървото.

3. Кликнете с десния бутон на Групакойто съдържа компонент (или връзка) Видове, които искате да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

6. Кликнете върху Добребутон.

7. В диалоговия прозорец, който се появява върху раздела Дабутон.

За задаване на разрешение за имота

1. Разгънете Видовеклон на дървото.

2. Разгънете Компонент (или връзка) Видовеклон на дървото.

3. Разширяване Групикогато е необходимо.

4. Изберете Component (или Connection) Вид, който съдържа имота, който искате да зададете разрешения за най.

5. В прозореца Свойства Кликнете с десния бутон на Имотжелаете да зададете разрешения за и изберете Редактирай Permissions.

6. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

7. По подразбиране ще видите, че най-четени и актуализиране на разрешителните са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

Забележка

Имоти, които са имали разрешение за обновяване отстранява са показани в курсивв прозореца Properties наи техните стойности не могат да бъдат редактирани от тази роля, Също така, способността за модифициране на данните за имот (например името, възли и т.н.) изисква както разрешението Актуализация на имота и Дизайнер добавка.

8. Кликнете върху Добребутон.

За задаване на разрешение за Template

1. Разгънете Templatesклон на дървото.

2. Преглед на Шаблонче вие ​​се интересувате.

3. Кликнете с десния бутон на Шаблонжелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране ще видите, че разрешението Read е на разположение. Премахване на разрешение от махнете отметкатаквадратчето.

6. Кликнете върху Добребутон.

За задаване на разрешение за Гледна точка

1. Разгънете Гледни точкиклон на дървото.

2. Разширяване Групикогато е необходимо.

3. Кликнете с десния бутон на Гледна точкажелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

6. Кликнете върху Добребутон.

За да зададете разрешението на Архитектура

1. Разгънете Архитектуриклон на дървото.

2. Разширяване на Архитектураче вие ​​се интересувате.

3. Кликнете с десния бутон на Архитектуражелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране ще видите, че разрешението Read е на разположение. Премахване на разрешение от махнете отметкатаквадратчето.

6. Кликнете върху Добребутон.

За задаване на разрешение за Каталог

1. Разгънете Каталозиклон на архитектурата ви интересува.

2. Разширяване Групикогато е необходимо.

3. Кликнете с десния бутон на Каталогжелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

6. Кликнете върху Добребутон.

За задаване на разрешение за Матрица

1. Разгънете Матрициклон на архитектурата ви интересува.

2. Разширяване Групикогато е необходимо.

3. Кликнете с десния бутон на Матрицажелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

6. Кликнете върху Добребутон.

За задаване на разрешение за Диаграма

1. Разгънете Diagramsклон на архитектурата ви интересува.

2. Разширяване Групикогато е необходимо.

3. Кликнете с десния бутон на Диаграмажелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

Забележка

Въпреки че можете да зададете разрешения за боклук директно за диаграма, трябва да се отбележи, че разрешенията на елементите на диаграмата могат да засегнат разрешенията за самия екран. Например, ако има дори само един елемент на мнение, че е имал своя Read или обновяване разрешение отстранява след диаграмата ще има разрешение Актуализация отстранен. Това е така, защото; а) елементите на мнение, че са имали своя Read разрешение отстранен, няма да бъдат показани на мнение, оставяйки "празно пространство", където в противен случай може поставите някои нови елементи, ако гледката беше актуализирана и б) елементите на мнение, че са имали разрешение от тях Актуализация отстранен след това може да има и други елементи спадна върху тях, за да станат деца, ако гледката беше актуализирана. Също така, Създаване и обновяване на разрешение за диаграма изисква всички елементи на мнение, имат разрешение Прочетете и компонентите имат разрешение за Update (това е така, защото, за да се движат компонент на друг компонент, трябва да бъде в състояние да го актуализира, тъй като тя ще стане дете).

6. Кликнете върху Добребутон.

За задаване на разрешение за 3D View

1. Разгънете 3D Прегледиклон на архитектурата ви интересува.

2. Разширяване Групикогато е необходимо.

3. Кликнете с десния бутон на 3D Viewжелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

6. Кликнете върху Добребутон.

За задаване на разрешение за Диаграма

1. Разгънете Графикиклон на архитектурата ви интересува.

2. Разширяване Групикогато е необходимо.

3. Кликнете с десния бутон на Диаграмажелаете да зададете разрешения за и изберете Редактирай Permissions.

4. В диалоговия прозорец, който се появява, кликнете върху Добави ...бутон и изберете Групажелаете да добавите или чрез него двукратно щракване или да го изберете и натиснете на Добребутон.

5. По подразбиране, ще видите, че създавате, Read, обновяване и изтриване на разрешения са на разположение. Махни от разрешенията махнете отметкатасъответните квадратчета.

6. Кликнете върху Добребутон.

Вижте също

Как се архитектура, представена в ABACUS?


Писането на сценарии

Navigation: Симулиране си архитектура>

Писането на сценарии

Изпратете коментари по тази тема.

The Script Editor е проста и функционална програма за писане и изпълнение на VB или C # скрипт се изправя срещу В момента се отвори ABACUS файл(Libraries не се поддържат в скриптове). Той има обичайната File Open, Close и Save команди, така че можете да запишете и извличане на скриптове, които пишете. Тя също има една основна тече и отстраняване на грешки съоръжението. Управителят Script позволява лесно да изпълнява различни скриптове, които сте написали чрез поставяне на меню-т за тях директно в менюто Tools.

За да влезете в Script Editor

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Изберете Инструменти | Script Editorи прозореца на Script Editor ще се отвори. След това или;

3. Отваряне на съществуващ скрипт чрез Пила | Отворено От менютата на Script Editor,

или

3. Отворете Пример скрипта посредством Пример артикул в менютата на Script Editor,

или

3. Настройване на езика по подразбиране или да VB или C # чрез Език артикул в менютата на Script Editor,

или

3. Open включили специфични Help чрез Помощ артикул в менютата на Script Editor

Когато пишете скриптове, трябва да се придържат към или на VB или C # синтаксиспо настройката в показателя Language в менюто на Script Editor.

ЗАБЕЛЕЖКА:

· За да използвате стандартните функции като VB MsgBox ()Трябва да включите Вносът Microsoft.VisualBasicдекларация в началото на скрипта. Това не е необходимо, преди Версия 3.0 на ABACUS.

· Тази помощ не включва информация за това как да пиша VB скрипт, нито пък съдържа позоваване VB. Чувствайте се свободни да пишете скриптове в любимия си IDE или редактор, а след това ги копирайте и поставете в редактора Script.

При първото стартиране на редактора на скриптове, редактора на скриптове ще бъде празен. Можете да получите достъп до скелет скрипт чрез менюто Примери. Първият път, когато стартирате вашия Script Editor, трябва да тичам скелета за шаблони, за да видите, че тя работи. В допълнение, има две примерни скриптове, които могат да бъдат достъпни чрез менюто примери.

За да напишете полезен скрипт ще ви трябва за указване на ABACUS ObjectModel. Тя се предоставя на разположение на вашия скрипт чрез включване на Вносът ABACUS.ObjectModelДекларация в главата на вашия скрипт. Пълен наръчник за целия ABACUS обектния модел е включена в Script Editor. Можете да го намерите, като изберете Помощ | Съдържаниеот прозореца на Script Editor.

Редакторът на скрипт включва много полезни функции за писане на скриптове, включително AutoComplete както е показано на снимката по-долу. Въпреки това, за още по-богат потребителски опит MS Visual Studio може да се интегрира с ABACUS и подробни инструкции са налични тук .

Script Editor с AutoComplete

За да използвате Мениджър Script

1. Уверете се, че имате файла ABACUS, Което съдържа Вашата населена архитектура, отворен.

2. Изберете Инструменти | Script мениджъра.

3. Кликнете върху Добавиикона и ОтвореноПоявява се прозорец.

4. Преглед на ABACUS Script (.abacusscript, .vb Или .cs) Файл, който искате да добавите към менюто Tools.

5. Кликнете Добреи позоваване на сценария ще бъде показан в прозореца на Script Manager. Въведете името на сценария, както желаете да се появи в менюто Tools. Забележка: Прозорецът Script мениджъра може да се преоразмерява, за да видите пълния път, ако е необходимо.

6. Повторете стъпки 3-5да се създадат връзки към повече ABACUS скриптове.

7. Кликнете затварямза затваряне на управителя Script и имайте предвид, че сценария (ите) ABACUS сега се появяват в менюто Tools.

За да изпълните скрипт

Или;

1. Open, напишете или копирате и поставите в сценария искате да стартирате, така че тя се показва в главния прозорец на Script Editor.

2. Щракнете върху Runбутон.

3. Ако вашият скрипт съдържа грешки, Error Description раздела в дъното на редактора на скриптове ще направи списък на детайлите, включително номерата на редовете. ЗАБЕЛЕЖКА: Всяка индивидуална грешка в Описание секцията Error може да бъде двойно щракване да ви отведе до съответната линия в сценария.

- или -

1. Изберете Инструментии след това Име на ABACUS Script елемент от менюто, както е създаден с Script мениджъра.

2. Ако вашият скрипт съдържа грешки, редактора на скриптове ще бъде открит със съдържанието на сценария показан в главния прозорец (подчертано в ред на първата грешка) и Error Description раздела в дъното на Script Editor ще изброим детайлите или грешката (ите), включително номерата на редовете. ЗАБЕЛЕЖКА: Всяка индивидуална грешка в Описание секцията Error може да бъде двойно щракване да ви отведе до съответната линия в сценария.

Scripting съставяне Грешки

Компилация грешки се случват, когато синтаксиса на кода на скрипта не е правилна. Тези грешки ще се показват в долната част на прозореца в раздела за грешка, заедно с описание на грешката, и номер на ред. Това е номера на линията, която отличава грешка компилация от Runtime грешка (виж по-долу), които няма да има номер на ред. Компилация грешки могат да бъдат двойно кликнали, за да отидете и да се подчертае специфичната линия под въпрос.

Scripting Времетраене грешки (Важно)

Времетраене грешки възникват след кода на скрипта е успешно съставила без грешки, но възникне грешка по време на изпълнение (виж примери за определяне на допълнителни). Времетраене грешки са важни, тъй като те могат да доведат до повредени модели, когато се създава предмети и цитирани от други обекти в модела, не са сами част от модела (обикновено, защото по време на работа грешка е възникнала преди най-кода, който нямаше да ги пуснат в модела някъде, е бил екзекутиран).

Ако вашият скрипт създава предмети, за да бъде добавен към модел, можете да се избегне корупцията причинена от грешка при изпълнение чрез спестяване на вашия скрипт, затваряне на скриптове, и извършване на връщане на промените, които са били създадени от сценария (ако изпълнението на скрипта не завърши нормално ). Въпреки това, има и други начини за избягване на всяко корупцията срещащи се (виж по-долу). Забележка: Всички скриптове, които просто четат от модела и не пишат в нея, са безопасни и няма да има никакви проблеми, независимо от това дали се случват по време на работа по време на грешки тяхното изпълнение.

За да се избегне корупцията, когато пишете скрипт код, който е създаване на обекти и да ги добавите към модела на обекта, се предполага, че обектите се добавят към модела възможно най-скоро, ако те са посочени от други обекти.

Например, ако желаете да създадете нова връзка, и 2 нови компоненти, а след това ще ги обвърже заедно, това е най-добре да се създаде първият компонент, да го добавите към модела, а след това на втория и да го добавите, и след това да създадете връзката и да го добавите, и след това най-накрая създаде прикачените файлове. Това означава, че ако имаше да бъде по време на работа грешка, която да прекъсне изпълнението на скрипт, всички обекти, които са необходими, за да бъде в objectmodel преди се създава прикачен файл, са в модела. Корупцията може да се случи, ако, например, е бил добавен само връзката, прикачените файлове, направени, и след това възникна грешка при изпълнение на скрипта, преди най-накрая добавя нови елементи към model.Corruption може да се случи, когато един обект, който е посочен от друг обект в на objectmodel, не е себе си в objectmodel.

Грешки по време на работа Пример включват:

· Референтен обект не е конфигуриран да инстанция на обект - това се случва, когато една променлива обект е нулева справка и се използва метод или свойство на този обект. Null справки могат да бъдат проверени от "Ако objectVariable нищо Тогава ..."

· Индексът е извън границите на масива - това се случва, когато масив се осъществява достъп с индекс, който се намира извън пределите - напр по-малко от или равно на 0 или по-голяма от дължината / граф на масива. Array или дължина Collection може да се провери от свойствата .Length или .Count съответно.

· Не Разрешение Изключение - Вие нямате разрешение да ... - това се случва, ако нямате разрешение да направи дадена промяна

· Първичен ключ Изключение - Duplicate / Липсва Име / ID - това ще се случи, ако промяната е направена, за да уникален атрибут, който е в противоречие с друг обект. Например Архитектури трябва да са уникални по име, също със стандартите.

· Референтен Integrity Изключение - Задаване на референтен поле към обект, който не е валиден. Например добавяне на "нищо" или нищожна като дете на много от колекциите в objectmodel.

· Нулева Дължина Exception - това може да се случи, ако се опитате да зададете името на предмет към празен низ. Повечето обекти изискват техните имена да имат най-малко един герой.

Внос отчети

Забележете, че в началото на скелета скриптове има изявления като Вносът ABACUS.ObjectModel, Тези твърдения не ще включват DLL, който вече не е посочен от сценария - тяхната цел е да се осигури "пряк път", за да се налага да се уточни цялото име на клас.

Например, за да се декларира променлива от тип CComponent (представляваща компонент в ABACUS), с Вносът ABACUS.ObjectModelДекларация към върха на скрипта, ще изисква само тя да бъде обявена като мъждивата комп като CComponent, Защото компилаторът знае да погледне в пространството от имена ABACUS.ObjectModel за класа CComponent. Без отчета за внос, тя ще трябва да бъдат декларирани като Дим комп като ABACUS.ObjectModel.CComponent, Съвкупност (като mscorlib.dll или System.Windows.Forms.dll) може да съдържа повече от едно пространство от имена - изявлението Вносът е за тези пространства от имена, а не за самите събрания. Монтажът ABACUS.ObjectModel.dll има само единната ABACUS.ObjectModel пространство от имена, достъпен чрез Scripting.

Автоматично съотнесени събрания

Следните DLLs се сравняват автоматично от Scripting:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (имплицитно посочен от компилатора)

· ABACUS.ObjectModel.dll

За да направите допълнителни препратки към било други .NET възли, или вашите собствени модули, вижте следващия раздел относно #Декларация ImportDLL.

#ImportDLL резюме

Започвайки през ABACUS 3.1, можете да справки допълнителни модули, които може да изискват за скриптове с използването на #Декларация ImportDLL. Например, ако искате да получите достъп до потребителски DLL твой и да използват функционалността в него, можете да го поставите в указателя за ABACUS и включва декларацията като първа линия (и) в скрипта. Ако става дума за .NET DLL, а след това обикновено не е нужно да въведете целия път, точно на DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Някои други неща, за да обърнат внимание:

1. Тъй като DLLs трябва да бъдат намерени по време на компилация и по време на работа, това ограничава по поръчка (на .NET) DLLs да бъдат пуснати в единствената програма папката ABACUS.

2. #ImportDLL отчети трябва да са на първа линия (и) на сценария - ако имате 5 акта, а след това те трябва да бъдат на първите 5 линии на скрипта

3. An #Декларация ImportDLL постави навсякъде, но първите редове на скрипта (например, ако тя се поставя след коментар или изявление Вносът) няма да работят правилно и / или може да причини несвързани грешки компилатора.

#ImportDLL с Office Изпълнения

Ако имате инсталиран Microsoft Office, и скрипта ви изисква монтиране на Office работна съвместимост, е възможно да ги справки просто чрез използване на #ImportDLL с името на сглобяване (както са изброени по-долу, например #ImportDLL Excel). Използването на този метод има предимството, че абсолютно DLL път не трябва да се използва, така че сценарият е по-преносим (трябва да работи както на Office 2003 и 2007 г., без да редактирате скрипта).

Когато използвате тази функция, на GAC (Global събрание Cache) се претърсва за сглобяването Interop, а сценарият компилира с пътя до сглобяването, ако е намерен. Ако това не е намерено, скриптове ще провери програма указателя за ABACUS (който съдържа Excel и Visio interops само). Ако исканата Interop не е намерена по това време, се активира предупреждение.

На interops обикновено не се инсталират в GAC, ако имате инсталиран Microsoft Office преди да инсталирате Framework (която е част от пълна инсталация ABACUS). Можете да ги инсталирате чрез извършване опцията Change за Microsoft Office от Add / Remove Programs, и изберете .NET програмиране опции. За повече информация, вижте това статия на MSDN.

Касетите за които е подкрепен този пряк път, са:

· Достъп

· Access.Dao

· Excel

· Диаграма

· MSProject

· Перспектива

· OutlookViewCtl

· Owc11

· PowerPoint

· Издател

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Дума

Iт не е съвсем ясно, ако всички тези събрания са полезни, стаи havebeen включени в тази функция regardeless като някои потребители Фев имат нужда дори неясни събрания.

Вижте също

Симулиране си архитектура