Co ABACUS dělat?

Navigace: Úvod do ABACUS>

Co ABACUS dělat?

Odeslat připomínky na toto téma.

Pro pomoc v jiných jazycích / překlady klikněte zde .

ABACUS se hádat-pracovat ven z jednání s řešení, systémy, software, informace, technologie, obchodních procesů a / nebo celých podniků (souhrnně označované jako architektury). To vám může pomoci pragmaticky navrhovat, sledování, simulovat, analyzovat a vizualizovat architektura modelováním to, analyzuje jej intuitivními způsoby (např grafy, diagramy a 3D), a pak ocení to proti svým non-funkční požadavky.

Poznámka

Non-funkční požadavkyjsou ty požadavky, které přímo nesouvisejí se, jak produkt funguje. Místo toho, oni jsou znepokojeni tím, jak dobře to funguje. Non-funkční požadavky zahrnují takové věci jako výkon, otevřenost, Evolvability, kvalitu, škálovatelnost, modularita, apod (na rozdíl od funkčních požadavků, jako je, zapněte světlo při klepnutí na toto tlačítko). Tradičně, non-funkční požadavky bylo obtížné - ne-li nemožné, - pro měření. Ve skutečnosti, ABACUS je jediným produktem, který lze objektivně a kvantifikovatelně měření první tři - výkon, otevřenost, a evolvability.

Jednoduše řečeno, zadáte architekturu a co ji budete potřebovat udělat. ABACUS pak vám řekne, jestli to bude dělat, jak je požadováno, a poukazuje na to, slabé stránky či mezery.

ABACUS čerpá z více než 20 letech výzkumu systémů a mnoho dalších let zavedeného teorie systémů. To vám dává kvantifikovatelné, spolehlivé a objektivní odpovědi, takže nejste spoléhat na subjektivním posouzení.

ABACUS je zkratka pro Architecture-Based AOZBOR, COMUNIKACE a Understanding z Systems. To vám může pomoci s jakýmkoliv velkém měřítku architektuře, ale to je obecně používáno pro čtyři (4) věci:

· Vyvíjející seproud architektura. Například, pokud vaše stávající architektura postrádá výkonnost, ABACUS bude představit architekturu pro vás, pojmenuje problémy (úzká místa, etc.), a pak vám říct, přesnějak zlepšit architekturu.

· Projektovánínová architektura. Například, pokud potřebujete zcela novou architekturu, a že jej máte na projektování sami, ABACUS vám řeknou, přesnějaké komponenty budete potřebovat a jak by měly být připojeny.

· Nákupnová architektura. Například, pokud jste volali k účasti v soutěži na návrh nové architektury, a vy jste se rozhodli mezi tři návrhy, ABACUS vám řeknou, přesněkterý vyhovuje vašim požadavkům nejlepší.

· KombinaceSoučasné stávající architektury. Například, pokud potřebujete spojit dva nebo více oddělených architektury, ABACUS vás.

Viz také

Jak to děláte (přehled) | Co je to architektura? | Jak se architektura zastoupena v ABACUS?

© 2001-2015 Avolution Pty Ltd. Všechna práva vyhrazena.


Jak používat počitadlo (přehled)

Navigace: Úvod do ABACUS>

Jak používat počitadlo (přehled)

Odeslat připomínky na toto téma.

Toto téma obsahuje základní přehled o úkolech, které se zabývají pomocí Abacus.

Následující diagram ilustruje architekturu na bázi analýzy proces, který ABACUS zajišťuje vyvíjející aktuálního architekturu do nové nebo cílové architektury.

Počítadlo proces

Chcete-li používat počítadlo:

1. Audit - Před použitím Abacus, je třeba shromáždit všechny informace, které máte o architektuře, a jeho požadavky.

· Architektura - Identifikovat potenciální komponenty architektury a jak jsou vzájemně propojeny. Tam by mělo být jen několik komponentů na špičkové úrovni. Jedná se o tzv "základními složkami". Dokonce i ty nejsložitější architektury by měl mít méně než 10 základní složky. např. Základními prvky architektury pojišťovny může být politika, stvrzenky, nároky, a platby.

· Požadavky- Musíte vědět, co se očekává od architektury za účelem zjištění, zda je uspokojivý. např. Počet transakcí za hodinu.

· Kde ho najdete? - Tyto informace mohou pocházet od specifikací požadavků, projektové dokumentace, rozhovory se zainteresovanými subjekty, nasazené kódu, atd podstatě jakýkoliv materiál, který je k dispozici nabízí ABACUS informace o architektuře.

2. Osídlit -Použijte Abacus modelovat vaší architektury a specifikovat požadavky architektura bude poměřován.

· Architektura - V ABACUS začnete s prázdným architekturou - musíte osídlit to. To znamená, že zadávání všechny informace o architektuře jste shromáždili v předchozím seznamu. Můžete naplnit svou architekturu ručně (pomocí pravého tlačítka myši), nebo můžete automaticky naplnit ji (z aplikace Microsoft Visio, Excel, Access atd). Typicky top-většina levelů (více abstraktní) této architektury se vyplní ručně, a nižší úrovně (konkrétnější) se vyplní automaticky.

· Požadavky - Jak můžete přidat součásti a připojení, zadáte jejich vlastnosti. Ve většině případů se tyto vlastnosti požadavky architektury. Například, pokud budete mít 1250 MIPS uzlu / cluster, měli byste přidat uzel jako součást, přidejte vlastnost výkon, a přiřadit hodnotu 1250 MIPS.

3. Analyzovat - Použijte Abacus se elegantně analýzu a vizualizaci složitou strukturu vaší architektuře. Ty může analyzovat architektury v mnoha způsoby, nebo z řady hledisek, včetně diagramy, 3D a Explorer. Nebo budete chtít používat některá konkrétnější názory takto:

· Graf vaší architektury - dostat výkon (doba odezvy, šířku pásma, etc.), náklady (bar, koláče, atd.), Nebo evolvability (schopnost prostor, trade-off, atd.), Výhled.

· Vytvořit zprávu o vaší architektuře.

4. Simulovat - Použijte Abacus simulovat vaši architekturu je výkon, dostupnost, náklady, otevřenost, atd

· Chcete-li to provést, spusťte některý z simulátorů. ABACUS hodnotí Váš architektura proti vašim požadavkůmprovedením simulace. To čte a analyzuje současný architekturu, běží simulace a vypočítává některé nové vlastnosti. Tyto vlastnosti jsou pak uloženy zpět do architektury. Tyto nové vlastnosti jsou údaje se snažíte analyzovat, jako je využití, doba odezvy, šířka pásma,% dostupnost, atd TCO

5. Inženýr- Použijte ABACUS odpovědět různé "co kdyby" scénářů a kontrolovat vývoj vaší architektuře. Engineering je proces opakují Naplnit - Analýza - Simulovat cyklus.

· V tomto bodě, vy'jsempravděpodobně vyvinul pochopení aktuální architektury, a upozornil na oblasti, které potřebujete vyvíjet. Docela často, nicméně, budete muset opakovat naplnit - Analýza - simulovat proces několikrát. To bude pravděpodobně proto, že může trvat několik iterací, než najdete cílové architektury. Také, pokud vaše architektura je velmi složité, možná budete chtít, aby proces opakovat pro každou architektonickou "úroveň".

6. Plánbudoucnost vaší architektuře na základě informací poskytnutých ABACUS.

Poznámka

Pokud Nesnažíme se vyvíjet stávající architektury, možná budete muset opakovat některé kroky několikrát, a v jiném pořadí. Záleží na tom, co se snažíte do. Například, pokud jste navrhování nové architektury, budete pravděpodobně jen naplnění vaší architektury jednou, a pak použijte počítadlo po dlouhou dobu, jako vodítko pro další vývoj (y) architektury. Na druhou stranu, pokud si kupujete novou architekturu a mají několik alternativ na výběr, budete muset objevit a vyplnění pro každou z alternativ, a poté analyzovat a simulovat každý z nich nezávisle na sobě před provedením konečné srovnání na konec.

Viz také

Co ABACUS dělat? | Co je to architektura? | Jak se architektura zastoupena v ABACUS? | Naplnění vaší architektury | Analýza vaší architektury | Simulace vaší architektury


Co je to architektura?

Navigace: Úvod do ABACUS>

Co je to architektura?

Odeslat připomínky na toto téma.

Architektura je abstraktní pojem- Není fyzickou věc, Je to bohatý a úplný popis nebo pochopení struktury systému - zachycení komponenty a jak jsou spojeny (interakci). Vzhledem k tomu, pojem architektura je tak všeobjímající, to je zásadní pro náklady, dostupnost, Evolvability, otevřenosti a výkonu systému. Zvuk architektura je předpokladem zvukového systému.

V ABACUS, modelovat svou architekturu. Pro jednoduchost nazýváme tento architektonický model architektura.

Obrázek níže ukazuje typickou architekturu 5komponenty (v hierarchii) propojeny 2 připojení. Etikety uvést jména uvedené různé části architektury v ABACUS.

Jednoduchý architektura

ABACUS domnívá se, všechny tyto věci být součástí architektury:

· Komponentypředstavují entity vaší architektuře které byste mohli popsat jako "věci". Pro pojišťovny, součásti by mohly být systémy pro zpracování politik, nároky, platby a příjmy.

· Připojenípředstavují vztahy mezi těmito komponenty. Například, v pojišťovně, příjmy jsou generovány pro platné politiky, tvrzení, proti platné politiky, a platné požadavky vyústí v platbách. Při přemýšlení architektonicky - zvláště při použití Abacus - spoje jsou stejně důležité jako složkami, a oni jsou řešeny v téměř stejným způsobem.

· Všechno ve stromu může mít Vlastnosti, Vlastnosti jsou věci jako, jak budete potřebovat váš systém plnit, počet řádků kódu to má, procento těchto linek, které jsou poznámky, atd ABACUS se domnívá, všechny tyto věci být součástí architektury.

· Používáním hierarchie (tj. dílčí komponenty a sub-spoje), Můžete skrýt informace a de-vytvořte architekturu. Počítadlo architektonický model je velmi flexibilní. Každá složka na jakékoliv úrovni může být ve spojení s jakýmkoli jiným komponentě v jakékoli jiné úrovni jakékoliv spojení na jakékoliv úrovni.

· Přílohaje operace, při které se součásti porty jsou vázány na připojenírole. Porty a Role jsou rozhranísmezi součástmi a přípojek. Používají se k upevnění spojení do složek. Připojení mít zdroj a umyvadlo role(usnadnit tok dat ze zdrojové komponenty ke komponentě dřezu)a koncepčně, komponenty mají porty. Pro jednoduchost, nicméně, v ABACUS komponent porty nejsou zobrazeny a spojení role jsou přímo připojeny k samotných komponent.

· Komponenty a konektory jsou určité Typ, To je hlavně pro účely klasifikace. Například politik, pohledávky, platby, a příjmy jsou součástí typu "systém". Platné politiky, platné nároky, atd., Jsou spoje typu "transakce". Type přidělen na součásti nebo připojení poskytuje šablonu pro vlastností a normy to má. Například typ součást serveru může mít "značky a modelu" normaa IP adresy vlastnost. Na rozdíl od jiných pevných nástrojů, se základní relační databázi údajů (RDB) back-end, v ABACUS můžete volně vytvářet své vlastní nové typy a přiřadit vlastní kombinace vlastností a standardů k nim.

· Standardní knihovny nemovitostí mohou být specifikovány a přiřazeny k něčemu jinému v architektuře. Tyto knihovny jsou známé jako Normy, Používáním Normy, Jen je třeba shromáždit specifické systémy vlastnosti - standardní vlastnosti jsou již tam. Například standardní výkonové charakteristiky systému Microsoft Windows 2000 mohou být přiřazeny na cokoliv komponenty používají operační systém Microsoft Windows 2000.

Viz také

Jak se architektura zastoupena v ABACUS? | Co ABACUS dělat? | Jak to děláte (přehled) | Vytvoření nového typu


Rozhraní ABACUS

Navigace: Úvod do ABACUS>

Rozhraní ABACUS

Odeslat připomínky na toto téma.

Při spuštění Abacus, uvidíte hlavní obrazovku, která je prázdná, až na menu a panelu nástrojů v horní, prázdné okno Průzkumníka a titulní-bar. Tato obrazovka bude centrem vašeho interakce s ABACUS.

Hlavními prvky jsou:

· hlavní menu

· panely nástrojů

· pravé tlačítko menu

· Průzkumníka a majetkové windows

· stavový řádek

Hlavní menu

Nabídky jsou uspořádány v logickém pořadí.

Tyto nabídky jsou popsány níže;

· Nabídka Soubor- Nabídka Soubor vám umožní vytvořit, otevřít, zavřít, uložit, exportovat a publikovat počítadlo souborů. To také umožňuje vytvořit, otevřít, zavřít a uložit soubory ABACUS knihovny.

· Menu Úpravy- Úpravy menu umožňuje vyjmout, kopírovat, vložit, odstranit, přejmenovat, najít a třídit prvkya undo / redo operací.

· Zobrazení Menu- Nabídka View umožňuje otevření nebo zavření různých rozhraní systému Windows a stavový pruhPřejděte dopředu a dozadu, jděte na specifických pohledů a spravovat panely.

· Nabídka Vložit- V nabídce Vložit umožňuje přidávat nové Normy, Šablony, druhy, prvky, výhledbods, Katalogy, diagramy, grafy, Zprávy a matice.

· Menu Analysis- Nabídka analýzy umožňuje spuštění hodnocení proti architektury včetně; výkon, náklady, spolehlivost, modularita a otevřenost.

· Nabídka Nástroje- Nabídka Nástroje umožňuje spuštění skriptování, stanovených cílů pro architekturua provádět a architektura "diff", Můžete také upravit nastavení programu a přizpůsobit rozhraní z menu nástroje.

· Menu Okno- Nabídka Okno umožňuje ukotvit, uspořádat, skrýt zobrazení otevřených oken.

· Menu Nápověda- Z nabídky Nápověda můžete přistupovat tento soubor nápovědy ABACUS. Můžete přístup na webovou stránku, zobrazit vaše licence Dohoda a zobrazit obecné informace o ABACUS, včetně verze softwaru a Abacus podporu a detaily kontaktu. Zpětnou vazbu můžete poskytnout přes stránku problému oznámení. V případě potřeby můžete zadat registrační klíč přes menu Nápověda.

Toto je pořadí, budete obvykle následovat, když jste plnění úkolů;Poté, co jste vytvořili, nebo otevřeno soubor, Budete normálně naplnění vaší architektury, pak pohledto (v Exploreru, diagramy, 3D, grafy, atd.) V tomto okamžiku budete buď spustit hodnotitel, Nebo budete opakovat proces se stejnou architekturou, nebo jinou architekturu. (Vidět Jak používat počitadlo (přehled) pro další podrobnosti.)

Podívejte se přes hlavní menu a zkuste si představit, jak budete aplikovat do svého systému.

Poznámka

Můžeš Upravte si menu kdykoliv.

Panely nástrojů

Ve výchozím nastavení jsou tyto panely nástrojů;

· V hlavním panelu nástrojů -

· Simulace Panel nástrojů -

· View panel nástrojů -

· Diagram nástrojbar (v případě, že diagram je otevřený) -

· makro Záznam Panel nástrojů -

Podívejte se prostřednictvím tlačítek na každém panelu nástrojů vznášející se nad nimi vidět břitu (zkratka-klíč).

Poznámka

Pouze některé tlačítka bude aktivní v závislosti na tom, co jste vybrali v okně Průzkumníka a můžete Upravit panely nástrojů kdykoliv.Navíc "Ověřit / kontrolní podmínky projektu" tlačítko na hlavním panelu nástrojů a tlačítka na panelu nástrojů Simulation zdůrazní Červený když změna podkladové úložiště vyžaduje opakovanou validaci projektu nebo re-simulaci tohoto simulátoru resp. Umístěte ukazatel myši na tlačítko zjistit, které architektury jsou ovlivněny.

V nabídce klepněte pravým tlačítkem myši

Hlavní menu a nástrojové lišty jsou nepoužívá pro všechno, ačkoli. Často je vhodnější použít kontextovou nabídku klepnutím pravým tlačítkem myši pro různé operace. (Také, ne všechny příkazy jsou k dispozici prostřednictvím pravým tlačítkem myši jsou dostupné přes hlavní nabídky, panely nástrojů nebo klávesové zkratky.)

Například, jakmile jste vytvořili soubor, a budete mít strom schéma vaší architektuře, je lepší klikněte pravým tlačítkem myši na architekturách ve stromu přidat novou architekturu. Podobně, měli byste pravým tlačítkem myši na součásti pro přidání nové komponenty. Klepněte pravým tlačítkem myši na pár věcí ve stromu, aby viděli, co můžete udělat.

Tip

Obecně platí, že budete používat hlavní menu provádět více úkolů na vysoké úrovni, stejně jako hodnocení vaší architekturu. Úkoly jsou low-level - jako přidávání jednotlivých složek a připojení - se provádí pomocí panelů nástrojů a / nebo nabídku klepnutím pravým tlačítkem myši.

Průzkumníka a vlastnosti oken

Při otevření nebo vytvořit soubor, bude strom schéma se zobrazí v okně Průzkumníka. Je to okno do vaší architektuře. A jak si vybrat prvky v okně Průzkumníka tři ostatní okna; obecné vlastnostiReference,a Vlastnosti okna bude aktualizovat tak, aby odrážely informace o vašem výběru.

Poznámka

Všeobecné vlastnostiReference,Vlastnosti a okna jsou ve výchozím nastavení skryty. Vidět Přizpůsobení rozhraní na to, jak jim odkrýt a případně nechat je trvale zobrazen.

I když jste budování své architektury, Explorer a vlastnosti okna jsou nejužitečnější reprezentace. Vzhledem k tomu, že mohou být zhroutil a rozšiřovat podle potřeby, a nemají stal těžkopádným.

Okno Explorer má Tree (a stavový řádek) a okna Vlastnosti mají 5sekce:

· Typ

· Normy

· Popis

· Reference

· Vlastnosti

ABACUS domnívá se, všechny tyto věci být součástí architektury.

Strom

Tato sekce má strom rozděleny do 3 oblastí jak následuje:

1. Meta-Model

· Normy- Jestliže velký komponenty mají stejnou sadu vlastností, můžete definovat sadu up-front, a pak už jen přiřadit ke komponentám. Totéž platí pro připojení a některé z dalších prvků. Tyto sady standardních vlastností jsou uloženy v Normyvětev stromu. Místo toho, aby definování každá vlastnost pro každou složku, a každá vlastnost pro každé připojení atd, jen přiřadit norma, Například standardní charakteristiky Unix-HP / UXlze uložit jako Norma a přiřazena žádnému komponenty pomocí Unix-HP / UXoperačního systému, jak je znázorněno pro OS01 server v screenshotu výše.

· Typy - Tato větev stromu je knihovna typů součástí a spojů, které můžete použít. Typy slouží k definování meta-model pro svoji architekturu a pro klasifikaci a filtrování při prohlížení vaší architektury. Oni také určit šablonu pro to, co Normy, Vlastnosti a omezení své komponenty / spoje mohou mít.

· Úhly pohledu- Pohledbods mohou být vytvořeny z existujících grafů a mohou být použity k vytvoření nových diagramy.Jsou diagram šablony.

· Šablony - Šablony obchod re-použitelná vzory komponentů a spojení spolu se způsobem, v němž jsou zastoupeny nebo pohledu. Mohou být myšlenka jako "mini", architektury nebo řešení, které mohou být umístěny do stávajících architektur.

2. Architektury -Architektur větev stromu je místo, kde budete budovat architektura (y) vašeho systému. (To se nazývá vyplnění architektury.) Můžete mít libovolný počet architektur v jediném souboru ABACUS.

3. Dashboards - Panelů dashboard větev stromu je místo, kde můžete přistupovat jakýkoli uloženo dashboardy pro tento projekt.

Poznámka

Položky ve stromu Průzkumníku, které měly své Aktualizace povolení odstraněny (tj jsou pouze pro čtení) jsou zobrazeny šedě.

Typ

Tato část označuje specifické složky nebo spojení typu aktuálně vybraného prvku ve stromě.

Normy

Tato část obsahuje seznam těch Normy pro aktuálně vybraného prvku ve stromě.

Popis

Tato část obsahuje stručný popis vybraného prvku ve stromu. Všechny související hypertextové odkazy mohou být také přidány do této sekce. Mezi ně patří weby nebo místní absolutní cesty ukazující na další informace o daném prvku. Více linky jsou také povoleny. Platné hypertextové odkazy je třeba začít s jednou z 5 řetězců; http: //, https: //, ftp: //, file: /// nebo mailto :.

Tip

Pro hypertextové odkazy s mezerami, mohou uživatelé zadat URL nebo cesty, vyberte požadovaný text a Klikněte pravým tlačítkem myši| Hypertextový odkaz, To se změní na mezery % 20takže se celá adresa URL nebo cesta bude fungovat správně.

Vytvořil a Modified

Tyto sekces poskytnoutuživatele a datum / čas vytvoření a poslední úpravy, aktuálně vybraný prvek ve stromu.

Reference

Tato část obsahuje seznam těch odchozí i příchozí komponenty pro aktuálně vybraného prvku ve stromě.To také ukazuje diagramy, 3D a pohledy graf, který aktuálně vybraný prvek se objeví v. Pokud je vybrán graf ukazuje hlediska v případě potřeby pro diagram a pro pohledy obecně se zobrazí nějaké Dashboards pohled objeví. A když standard je vybrán ve stromu ukazuje využití standardu podle typů, součástí a spojů.

Vlastnosti

Tato sekce je místo, kde můžete definovat charakteristiky prvky uvnitř Vaše architektura, stejně jako, jak budete potřebovat to provést, počet řádků kódu má, procento těchto linek, které jsou poznámky, atd

Tyto "vstupní" a "výstupní" vlastnosti pre-postavený simulátory se zobrazí v okně Vlastnosti s ikonou vstup nemovitost voliče řádku ( [image] ) A výstup ikona ( [image] ) Respektive s popisku označující který pre-postavený simulátor vlastnost souvisí, např "Modularita Output" nebo "Input Performance". Šipka na výstupních ikony zdůrazní Červený ( [image] ), Když je vlastnost je zastaralá v důsledku dané nemovitosti či strukturální změny úložiště s simulátoru vyžadující re-simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Stavový řádek

Levá část stavového řádku zobrazuje úplnou cestu k úložišti prvek v současné době in-zaměření, a to buď vybrán v okně Průzkumníka, nebo na diagram plátno. Je tomu tak proto, že přesné místo v úložišti hierarchii pro daný prvek může být vždy snadno určit. Pravá část stavového řádku zobrazuje různé provozní zprávy, jako například "Otevřít ABACUS File úspěšné" a "Kalkulace nákladů Dokončeno".

Viz také

Jak to děláte (přehled) | Přizpůsobení rozhraní | Co je to architektura? | Jak se architektura zastoupena v ABACUS? | Práce se soubory ABACUS


Přizpůsobení rozhraní ABACUS

Navigace: Úvod do ABACUS>

Přizpůsobení rozhraní ABACUS

Odeslat připomínky na toto téma.

Můžete změnit vzhled a chování rozhraní ABACUS v mnoha ohledech. ABACUS obsahuje několik předdefinovaných nastavení kombinací, které můžete použít použít skupinu customizaci k rozhraní. Kromě toho můžete provést individuální customizace na položky, jako jsou okna, panely nástrojů, klávesové zkratky, a možnosti různé displeje.

Uspořádat a Dock Windows

Máte mnoho možností pro aranžování výloh v rámci rozhraní pro ABACUS, včetně následujících:

· Tab-dok okna.

· Dock okna na okraj rámu v rozhraní.

· Minimalizace okna nástroj podél okraje rozhraní.

· Obnovit umístění okna na výchozí rozvržení.

Dokovací Windows

Pokud je okno ukotvitelných, může být připevněna k jedné straně rámu v rámci rozhraní nebo může být uspořádána na kartami tabulí v rámu. Průvodce diamant objeví při přetažení okna z jejich aktuálního umístění do jiného umístění v rozhraní. Vodicí diamant umožňuje rychle znovu ukotvit okno na jedné ze čtyř stran rámu nebo ve středu jako kartami panelu. Když je okno Nekupírovaný nebo ne ukotvitelných, plave nad ostatní okna.

Chcete-li ukotvit okna

1. Klepněte na okno, které chcete ukotvit, dát se zaměřit.

2. Na Oknomenu, klikněte na tlačítko Ukotvitelných.

3. Přetáhněte okno z jeho aktuálního umístění směrem ke středu snímku, který chcete ukotvit se.

Zobrazí se Průvodce diamant. Čtyři šipky diamantového bodu směrem čtyř okrajů rámu a středu představuje panel v panelech.

Tip

Chcete-li přesunout ukotvené okno, aniž by zaklapnutím na místo, stiskněte kombinaci kláves CTRL při přetahování jej.

4. Když se okno, které přetahujete dosáhne polohy, kde ji chcete ukotvit, přesuňte ukazatel myši na odpovídající části vodícího diamantu. Nástin okna se zobrazí ve vymezené oblasti.

5. Chcete-li ukotvit okno do polohy označené, uvolněte tlačítko myši.

Například, pokud Badatelje ukotven na levém okraji rozhraní a chcete ukotvit na pravém okraji, by přetahování Badatelsměrem ke středu rozhraní, přesuňte ukazatel myši na pravé straně vodícího diamantu, a pak uvolněte tlačítko myši.

Minimalizace Windows

Windows (ať už jsou nástroj Windows - objevit se na Pohledmenu, nebo Dokument Windows - objevit se na Oknomenu) podporuje funkci nazvanou Auto Hide. Auto Hide umožňuje vidět více z vaší architektuře najednou díky minimalizaci oken podél okrajů rozhraní, když se nepoužívá.

Chcete-li zapnout automatické Skrýt

1. Klepněte na okno, které chcete skrýt, aby se zaměřit.

2. Na Oknomenu, klikněte na tlačítko Auto Hide.

- nebo -

2. Klikněte na ikonu připínáček v záhlaví okna.

Auto Hide Povoleno

Když ztratí fokus okno auto-skryta, to se automaticky zasune zpět na záložku na okraji rozhraní. Zatímco okno je auto-skrytá, její název a ikony jsou viditelné na kartě na okraji rozhraní. Chcete-li zobrazit okno automatické skryté, přesuňte ukazatel myši na kartě. Okno zasune zpět do zorného pole a je připraven k použití.

Poznámka

Se okno, které je automatické skryté nemůže být ukotven. Chcete-li ukotvit okno, budete muset vypnout Schovávat jak je popsáno níže.

Chcete-li vypnout Schovávat

1. Klepněte na okno, které chcete zachovat viditelné, aby se zaměřit.

2. Na Oknomenu, klikněte na tlačítko Auto Hidezrušte zaškrtnutí políčka.

- nebo -

2. Klikněte na ikonu připínáček v záhlaví okna.

Auto Skrýt Disabled

Tip

Windows, které mají Schovávat povoleno dočasně sklouznout do pohledu, když okno má fokus. Chcete-li znovu skrýt okno, vyberte položku mimo aktuální okno. Jakmile se okno ztratí fokus, že sklouzne zpět pohledu.

Resetování Windows rozvržení

Můžete vrátit rozhraní výchozím rozvržení okna pomocí Obnovit rozvržení okna příkaz. Při spuštění tohoto příkazu, dojde k následujícím akcím:

· Všechna okna jsou přesunuty do výchozích pozic.

· Windows, které jsou uzavřeny ve výchozím rozvržení okna jsou uzavřeny příkazem.

· Windows, které jsou otevřené v výchozím rozvržení okna se otevírají příkazem.

· Windows, které jsou skryté / viditelné ve výchozím rozvržení okna jsou skryté / viditelný příkazem.

Chcete-li obnovit umístění okna na výchozí rozvržení

1. Na Windowsmenu, klikněte na tlačítko Obnovit rozvržení okna.

Přizpůsobení nabídek a panelů nástrojů

Můžete změnit rozložení, umístění a obsah nabídek a panelů nástrojů v rozhraní. Můžete také přidat tlačítka do panelů nástrojů a změnit přiřazenou ikonu libovolného tlačítka.

Vytvoření nové panely nástrojů

Chcete-li vytvořit nový panel nástrojů

1. Na Nástrojemenu, zvolte Přizpůsobení.

2. V VlastníDialogové okno, vyberte Panely nástrojůTab.

3. Vybrat Nový.

4. V Nový Panel nástrojůDialogové okno, zadejte název panelu nástrojů.

5. Vybrat Dobře.

Chcete-li přidat příkazové tlačítko nabídky nebo panelu nástrojů

1. Na Nástrojemenu, zvolte Přizpůsobení.

2. V VlastníDialogové okno, vyberte PříkazyTab.

3. Vyberte kategorii a přetáhněte příkaz z dialogového okna do nabídky nebo panelu nástrojů.

4. Vybrat V blízkosti.

Tip

Podržením klávesy Alt klíč umožňuje rychlé přizpůsobení příkazy, jako by se dialogové okno Vlastní byly otevřené.

Viz také

Rozhraní ABACUS


Práce se soubory ABACUS

Navigace: Úvod do ABACUS>

Práce se soubory ABACUS

Odeslat připomínky na toto téma.

Soubor ABACUS je kontejner pro model vašeho architektura , V rámci jednoho souboru ABACUS, můžete modelovat libovolný počet architektur libovolný počet časů.

Při prvním otevření Abacus, že jsou otevřené žádné soubory. Chcete-li pracovat na vaší architektuře, musíte buď vytvořit nový soubor, nebo otevřít existující soubor.

Při otevření nebo vytvořit nový soubor, bude strom v okně Explorer automaticky zobrazit. Tento pohled Explorer ukazuje vaši architekturu k dnešnímu dni. Při zavření souboru, bude strom v okně Průzkumníka také zmizí.

Chcete-li vytvořit nový soubor ABACUS

1. Vybrat Soubor| Nový ...

2. V dialogovém okně Nový projekt, který se zobrazí (jak je uvedeno níže) Vybratbuď vytvořit prázdnou modelu, model z A Standardní ABACUS knihovna , Model z vlastní ABACUS knihovny, model z XML, MS Access , MS Visio , MS Excel , MS SQL Server , Což Podnik Server Model nebo vlastní ABACUS knihovny (.abacuslib soubor).

3. Klikněte na Dobřetlačítko a postupujte podle dialogy, které se mohou objevit.

Tip

Nebudete vyzváni k zadání názvu souboru, dokud uložit nebo zavřít. Je to dobrý nápad, uložit soubor, jakmile si ho vytvořit. Pak nebudete muset starat o pojmenování ji později v procesu, když jste se zaměřením na jiné složité věci (jako vyplnění vaší architektury).

Vytvořit nový projekt

ABACUS Standardní knihovny

ABACUS podporuje více než 100 veřejná rámců a zápisy z nichž některé jsou uvedeny níže. Při výběru pro vytvoření nového projektu ze standardní uživatelé knihovny mají rychlý start do modelování v rámci stanovení rámce plně využívat veškerých definovaných typů prvků, atributů, notace, názory a šablony nebo vzory. Další standardní knihovny jsou volně k dispozici prostřednictvím Avolution Společenství zde .

Nový projekt ze standardní knihovny

Chcete-li uložit nový soubor ABACUS

1. Vybrat Soubor| Uložit jako

Tip

Názvy souborů mohou mít libovolnou délku, a může obsahovat libovolné alfanumerické znaky a mezery. Nemohou obsahovat vlnovky (~) charakter, potrubí (|) znak otazník, nebo znaky se běžně používá pro popis cesty, jako je zpětné lomítko (\) - s výjimkou jako součást cesty (?).

Chcete-li otevřít existující soubor ABACUS

1. Vybrat Soubor| Otevřít

Poznámka

Pokud otevíráte soubor ze sdíleného síťového umístění, které je již otevřen jiným uživatelem, bude ABACUS poskytne přístup pouze pro čtení. Při použití Abacus s přístupem pouze pro čtení, nebudete moci provádět operace zápisu, jako je naplnění vaší architektury a běží hodnotitelů. Můžete však zobrazit architekturu pomocí zobrazení Průzkumníka a 3D pohledy.

Viz také

Jak se architektura zastoupena v ABACUS?


Jak se architektura zastoupena v ABACUS?

Navigace: Úvod do ABACUS>

Jak se architektura zastoupena v ABACUS?

Odeslat připomínky na toto téma.

V ABACUS, modelovat svou architekturu. Pro jednoduchost nazýváme tento architektonický model architektura.

Níže uvedený graf ukazuje, jak typickou architekturu 5komponenty (v hierarchii) propojeny 2 spojů by být zastoupeny v ABACUS.

Jak jednoduché architektura je zastoupena v ABACUS

Můžete mít libovolný počet architektur v jediném souboru ABACUS.

První architektura ve stromu

Obvykle byste vytvořit novou architekturu, kdykoli budete chtít vyhodnotit změnu. Například, měli byste modelovat své stávající architektury První z nich - to by byl první architektura ve stromu. Dalo by se nazvat "Current".

Druhý

Pokud chcete modelovat a vyhodnocovat změnu vašeho stávajícího architektury (např zvýšené nároky) byste vytvořit novou architekturu. Nejjednodušší způsob, jak to udělat, by bylo vytvořit kopii "Current" a přejmenujte jej "vývoj 1 Pokus 1". To by byl druhý architektura ve stromu. Pokud vaše hodnocení "vývoj 1 Pokus 1 'jsou úspěšné, můžete přejmenovat ji jednoduše" Evolution 1'.

Třetí

Pokud je "Evolution 1 pokus 1 'nesplňuje vaše požadavky, můžete vytvořit kopii, přejmenovat ji na" Evolution 1 Pokus 2 ", a zkuste to znovu. To by bylo třetí architektura ve stromu.

Viz také

Co ABACUS dělat? | Jak to děláte (přehled) | Co je to architektura? | Práce se soubory ABACUS | Vytvoření nebo duplikování architekturu


Pomoc v jiných jazycích

Navigace: Úvod do ABACUS>

Pomoc v jiných jazycích

Odeslat připomínky na toto téma.

POČITADLO nápověda je k dispozici v různých jiných jazycích / překlady a lze jej stáhnout z níže uvedených odkazů.

Na nahradit aktuální ABACUS soubor nápovědys přeloženého souboru nápovědy postupujte podle následujících kroků:

1. Uložte soubor nápovědy z příslušné odkaz níže.

2. Přejmenujte soubor nápovědy na ABACUS.chm.

3. Otevřete soubor poklepáním, a pokud za "Otevřít soubor - upozornění zabezpečení" zobrazí dialogové okno a pak zrušte zaškrtnutí "Vždy zobrazit dotaz před otevřením souboru" možnost a klepněte na tlačítko Otevřít.

4. Zavřete soubor.

5. Nahradit soubor ABACUS.chm do složky Program Files ABACUS, typicky "C: \ Program Files \ Avolution \ ABACUS" nebo "C: \ Program Files(x86)\ Avolution \ ABACUS".

Poznámka

Kontextová nápověda bude i nadále spolupracovat s přeloženými soubory nápovědy.

Soubory nápovědy Abacus v jiných jazycích:

· arabština / العربية .

· bulharský / български .

· Chinese (Simplified) / 中文 (简体) .

· čeština / Česká .

· dánština / Dansk .

· estonština / Eesti .

· Finský / Suomen .

· francouzština / Français .

· Němec / Deutsch .

· maďarský / Magyar .

· islandský / islandský .

· indonéština / Indonésie .

· italština / Italiano .

· japonský / 日本 の .

· lotyšský / Latvijas .

· Malajské / Malajsie .

· maltština / Slad i .

· Norweigen / Norweigen .

· polština / Po lska .

· Portugalština / Português .

· ruština / русский .

· Slovák / Slovenskí .

· slovinský / Slovenski .

· španělština / Españoles .

· švédský / Svenska .

· turečtina / Turek .

· velština / Cymraeg .

Viz také

Co ABACUS dělat?


Naplnění vaší architektury

Navigace: Naplnění vaší architektury>

Naplnění vaší architektury

Odeslat připomínky na toto téma.

Proces budování model vašeho architektury, je známý jako Osazování, Poté, co jste objevili vaší architektury a identifikovat vaše požadavky, jste připraveni na váš model architektury v ABACUS.

Během populace, budete zadat všechny podrobnosti, které znáte o své architektuře a co je potřebné z toho.

K naplnění vaší architektury

1. Zkontrolujte, zda máte ABACUS otevřít soubor , Což Zobrazí explorer , A architektura přidané .

2. Ruční vyplnění složky vyšší úrovně a přípojky vaší architektuře. Obvykle se bude jednat o více abstraktní prvky a spoje.

- nebo -

2. Graficky naplnit komponenty a spoje, které byste chtěli viz schematicky, s použitím Průvlak .

Můžete také chtít, aby

3. Naplnit pomocí Katalogy - Si můžete prohlédnout a komponenty a připojení v jednoduchým způsobem. tabulkové

4. Naplnit pomocí Matice - Můžete zobrazit a upravit propojení mezi komponenty jednoduchým tabulkové způsobem.

5. Naplnit z aplikace Microsoft Access - Můžete importovat architekturu od a export do Microsoft Access.

6. Naplnit z Microsoft Visio - Můžete importovat architekturu od a export do Microsoft Visio.

7. Naplnit z aplikace Microsoft Excel - Můžete importovat architekturu od a export do Microsoft Excel.

8. Naplnit z Microsoft SharePoint - Můžete importovat architekturu od a export do Microsoft SQL Server.

9. Naplnit z Microsoft SQL Server - Můžete importovat architektury z Microsoft SQL Server.

10. Import z XML - Můžete importovat architektury z XML fragmentu ABACUS nebo XML souboru ArchiMate Interchange Jazyk.

Viz také

Naplnění vaší architektury ručně | Nástroje pro kreslení | Naplnění vaší architektury z aplikace Microsoft Access | Naplnění vaší architektury z aplikace Microsoft Visio | Naplnění vaší architektury z aplikace Microsoft Excel


Naplnění vaší architektury ručně

Navigace: Naplnění vaší architektury> Naplnění ručně>

Naplnění vaší architektury ručně

Odeslat připomínky na toto téma.

Komponenty vyšší úrovně a spojení vaší architektury bude pravděpodobně muset být naplněna manuálně. Obvykle se bude jednat o více abstraktní prvky a spoje.

Chcete-li ručně naplnění vaší architektury

1. Zkontrolujte, zda máte ABACUS souborOpen, badatelZobrazí, a architektura přidané .

2. Přidejte komponentu. Udělat toto, Klikněte pravým tlačítkem myšina oblast stromu chcete naplnit, a zvolte Přidejte Sub-Component ..., Nebo klikněte na New ComponentTlačítko na Zobrazit panel nástrojů , Komponenty mohou být přidány pouze pod větve součásti stromu. Chcete, aby vaše strom diagram být přesná reprezentace vaší architektuře. Když se objevil svou architekturu, budete se naučili, přesně tak, jak to všechno do sebe zapadá. Budete potřebovat tyto znalosti, když přidáte své komponenty a připojení. Pokud přidáváte první komponenty, budete jej přidat přímo do pobočky Components. Zbytek vašich komponent může být buď na stejné úrovni ve stromu, nebo mohou být dílčí komponenty jako první.

3. Aktualizujte hodnotyvlastnostikaždé složky, jak jej přidat. Udělat toto, cvaknutína součásti, a upravit vlastnosti zobrazené v Okno Vlastnosti(typicky) na pravé straně. Vlastnosti jsou obecně věci jako požadavky, zpracovatelských kapacit apod Když ABACUS vyhodnotí vaší architektury, bude to počítat některé nové vlastnosti, a uložit je zpět do architektury. Tyto nové vlastnosti jsou údaje se snažíte analyzovat, jako je využití, doba odezvy, šířka pásma, atd

4. Přidejte vaše připojení a aktualizovatjejich vlastnostias you go - stejně jako vy pro komponenty (ale pod připojení větev stromu).

5. Připojitspoje a komponenty. Chcete-li to provést, vyhledejte připojení, klikněte na jednu z jeho ukončí nebo role , A přetáhněte ji na komponentu. Případně klikněte na složku a přetáhněte ji na jednu ze spojení je role (tj. buď Source nebo Sink), Nebo můžete klepnout pravým tlačítkem myši a přetáhněte složku do jiné složky a vyberte Připojit k, Nebo jednoduše klikněte pravým tlačítkem myši na složku a vyberte Připojit..., Když přetáhnete připojení role, Zjistíte, symbol zkratku Když ukážete na součást můžete připojit k. To znamená, že nejste dělat kopie, jste jen jeho připojení. Ujistěte se, že jste jej připojit ke správné cílové složky. Například, pokud je to spojení je Zdroj role, Jeho přetažením do zdrojové zařízení (tj součást, která je zdrojem toku dat).

Tip

Re-objednat entity přímo ve Vašem architektury (např komponenty, připojení atd) v badatelje poměrně snadné. Jednoduše Klepněte na tlačítko| Držet| Táhnoutpříslušný subjekt, a místo, kde žádoucí ve vaší architektuře. Funkce re-uspořádání také umožňuje umístit subjekty v různých hierarchií vaší architektuře.

Můžete také chtít, aby

6. Přidat standardů (přednastavené sady vlastností - předvolby) na vaše komponenty, připojení nebo typy

7. Změnit vlastnosti konstrukční části, připojení nebo typu

8. Undo a Redo Operace

9. Změnit typ konstrukční části nebo spojení

10. Vytvoření nového typu nebo typu Group

11. Vymazat komponenta nebo připojení

12. Vytvořte, duplicitní nebo vyvíjet architektura

13. Dovozní typy a standardy z knihovny

14. Import z jiného souboru ABACUS, XML, Excel nebo Visio

15. Kopírování a vkládání části (nebo všechny) z vaší architektuře

16. Najít a nahradit položky v architektuře

17. Rozbalit / sbalit některé nebo všechny z uzlů ve stromu

18. Spojit položky

19. Definovat a Ověřit Omezení omezit strukturu vaší architektury

20. Evolve vaší architektury vytvořit několik architektonických řešení pro porovnání a základní linie

Viz také

Naplnění vaší architektury - Přehled | Vytvoření nového souboru


Undo a Redo

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Undo a Redo

Odeslat připomínky na toto téma.

Stejně jako mnoho moderních aplikacích, ABACUS podporuje schopnost jak zpět a opakovat poslední uživatelské změny do otevřeného projektu. Chcete-li vzít zpět poslední změnu, jednoduše aktivovat příkaz Zpět. Změny, které byly vrátit zpět může být přepracován aktivací příkazu redo; re-použití naposledy vrátit zpět změny.

Varování

Undone změny nejsou schopni být znovu, pokud jsou další jsou provedeny změny v projektu, protože se vrátit zpět.

Poznámka

Zatímco drtivá většina podporovat změny vrátit zpět / vpřed v reálném čase, někteří diagram vzorníku změny, jako například vytvoření nového typu Tvar / sdružení nebo změnu o přidružení barev atribut, nejsou schopni okamžitě vrátit zpět. V těchto případech, modifikovaný Diagram (označeno hvězdičkou), musí být uzavřen, aby tyto změny lze vrátit zpět.

Undo a Redo velitelských míst

Příkazy Zpět a Znovu lze přistupovat z třech různých místech:

· V nabídce Úpravy

· panel nástrojů Standardní

· klávesnici klávesové zkratky CTRL + Z(undo) a CTRL + Y (předělat)

Tip

UNDO a znovu tlačítek na panelu nástrojů Standardní poskytnout rozbalovací seznamy zobrazující 10 posledních změn, které lze vrátit zpět a byly předělány, resp. Oni jsou také praktický způsob, jak se vrátit zpět / vpřed více změn najednou.


Změna komponentní / typ připojení je

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Změna komponentní / typ připojení je

Odeslat připomínky na toto téma.

Typy komponent a připojení se používají především pro účely klasifikace. Můžete použít typy jako filtry při prohlížení architektury. Například, namísto pohledu na celou věc, můžete zobrazit pouze součástí aplikace.

Chcete-li změnit komponentní / typ připojení je

1. Klikněte pravým tlačítkem myšisoučásti nebo připojení.

2. Vybrat Změnit typ.

3. Zvolte jiný typ ze seznamu.

Tip

Když změníte typ, můžete získat některé nové Normynebo vlastnosti (co je spojené s typem - viz typy větev stromu). Vaše stávající Normy a vlastnosti zůstanou nezměněny. Můžete si vytvořit své vlastní nové typy a přiřadit vlastní kombinace Normy a vlastnosti na ně.

Viz také

Vytvoření nového typu | Naplnění vaší architektury - Přehled | Analýza Vaše architektura


Vytvoření nové komponenty / Typ připojení nebo typu Group

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Vytvoření nové komponenty / Typ připojení nebo typu Group

Odeslat připomínky na toto téma.

Typy komponent a připojení se používají především pro účely klasifikace. Můžete použít typy jako filtry při prohlížení architektury. Například, namísto pohledu na celou věc, můžete zobrazit pouze součástí aplikace.

Chcete-li vytvořit novou součást / Typ připojení

Poznámka

Chcete-li přidat typy nebo skupiny typů v projektu ABACUS licence uživatel potřebuje Designer add-on schopnosti. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

1. Rozbalte Druhyvětev stromu.

2. Klikněte pravým tlačítkem myši na Component Druhy (nebo Typy připojení).

3. Vybrat Přidat Component Type (nebo Přidat typu připojení) nebo Vytvořit skupinu.

Tip

Poté, co jste vytvořili typ, měli byste změnit jeho ikonu (viz níže) a přidat Vlastnosti a Normy jemu pro součásti nebo instance připojení k "Zdědit".

Chcete-li změnit ikonu pro konstrukční část / Typ připojení

Poznámka

Chcete-li změnit ikony pro typy v projektu ABACUS licence uživatel potřebuje Designer add-on schopnosti. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

1. Klikněte pravým tlačítkem myši na Component Type (nebo Typ připojení) Chcete-li změnit ikonu.

2. Vybrat Změnit ikonu.

3. V dialogovém okně Procházet Vybrat ikonu umístění a vyberte soubor s obrázkem a klepněte na tlačítko Otevřít.

Poznámka

Můžete mít vlastní obrázek ikony libovolné velikosti, ale to bude vždy být zmenšen, aby se vešly na obrázek 16x16 pixelů v okně Průzkumníka. Takže pokud vaše původní vlastní obrázek ikony není stejné výšky a šířky bude ikona Explorer Okno se protáhl. V souladu s tím, vlastní obrazy by měla být nejméně 16x16 pixelů, a pokud chcete zachovat přesný tvar ikony vlastní ujistěte se, že vaše vlastní obrázek ikony je stejná výška a šířka v pixelech (16x16 nebo větší). Také byste měli být opatrní, o které nemají barevný 'obrazových bodů "jít celou cestu na hranici vlastní ikonu obrázku, jak to bude vypadat chudí v okně Průzkumníka s přilehlými ikonami" krvácení "do sebe. Proto byste měli nechat alespoň 1 pixel bílý okraj.

Tip

Můžete si vytvořit svůj vlastní obrázek ikony ICO, BMP, GIF, JPG nebo PNG formát souboru, ale vzhledem k omezení v systému Windows pouze ICO formátu bude náhled v dialogovém okně ABACUS Select Icon, pokud máte možnost View menu nastaven na jinou než miniatury.

Viz také

Naplnění vaší architektury - Přehled | Analýza Vaše architektura


Odstranění komponenty nebo spojení

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Odstranění komponenty nebo spojení

Odeslat připomínky na toto téma.

Chcete-li odstranit složku nebo spojení

1. Klikněte pravým tlačítkem myšisoučásti nebo připojení.

2. Vybrat Vymazat.

Pozor

ABACUS vás bude varovat, které pohledy budou ovlivněny vypuštěním a požádá vás k potvrzení odstranění. To je proto, že prvky mohou existovat na mnoha diagramy a vyplatí se zkontrolovat, co navrhované vypuštění bude mít vliv.

Tip

Pokud odstraníte složku, budou odstraněny také všechny jeho dílčích komponent. Můžete se rozhodnout odstranit interní a externí připojení k součásti. Pokud se rozhodnete je odstranit, připojení je to připojený na zůstanou, ale budou už ne být připojen. Všechny součásti a spoje jsou zvláštní Typ , Smazání komponentní / připojení nemá žádný vliv na typu (v typech větev stromu). Podobně, v případě, že složka a / nebo spojení má Norma přidělen, vymazání nebude mít žádný dopad na mistra v oborových norem.

Viz také

Naplnění vaší architektury - Přehled


Vytvoření nebo duplikování architekturu

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Vytvoření nebo duplikování architekturu

Odeslat připomínky na toto téma.

Můžete mít libovolný počet architektur v jediném souboru ABACUS. Obvykle byste vytvořit novou architekturu pokaždé, když chcete modelovat a vyhodnotit vývoj vašeho systému.

Chcete-li vytvořit novou architekturu

1. Klikněte pravým tlačítkem myši na Architekturyvětev stromu.

2. Vybrat Nová architektura.

Chcete-li vytvořit kopii existující architektury

1. Klikněte pravým tlačítkem myšina architektuře.

2. Vybrat Kopie.

3. Klikněte pravým tlačítkem myši na Architekturyvětev stromu.

4. Vybrat Vložit.

5. Nová architektura se bude jmenovat "Kopie ...".

Pro další vývoj stávající architektury

1. Klikněte pravým tlačítkem myšina architektuře.

2. Vybrat Rozvíjet se.

3. Nová architektura se bude jmenovat "... 0,1".

Poznámka

K dispozici je podrobný popis na vyvíjející se architekturách zde .

Viz také

Jak se architektura zastoupena v ABACUS | Vyvíjející vaší architektury


Import do své architektury

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Import do své architektury

Odeslat připomínky na toto téma.

ABACUS umožňuje dovážet do Vaše architektura Z .abacus (ABACUS soubor), XML (XML fragment ABACUS nebo XML soubor ArchiMate Interchange Language), VSD (Microsoft Visio), formát, a XLS (Microsoft Excel) formát. To vám umožní budovat svůj architektury z vnějších zdrojů rychle.

Na importovat Vaše architektura z.abacus (ABACUS soubor)

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Klikněte pravým tlačítkem myšina uzlu Architecture, libovolné počítačové architektuře, ve vašem modelu nebo jakákoli část složek stromu.

3. Vybrat Importovat| Z Soubor...z menu.

4. Vyberte si místo a .abacus soubor a klepněte na tlačítko Otevřít tlačítko.

Poznámka

Poté, co jste vybrali soubor, který chcete importovat, budete dotázáni, jak byste chtěli importovat normy, typya vyhlídky, Můžete importovat standardy, typy a vyhlídky buď jako nových nebo sloučené normy, typya vyhlídky, Výchozí nastavení je pro standardy, typy a vyhlídky se spojil s existujícími standardy, typy a vyhlídky pokud již existují (se stejným přesný název) ve vašem projekt.

Na importovatVaše architektura z.xml (fragment ABACUS XML nebo XML soubor ArchiMate Interchange Language)

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Klikněte pravým tlačítkem myšina uzlu Architecture, libovolné počítačové architektuře, ve vašem modelu nebo jeho část z komponent stromu.

3. Vybrat Importovat| Z XML ...z menu.

4. Vyberte si místo a XML souboru a klepněte na tlačítko Otevřít tlačítko.

Poznámka

ABACUS se bude dovážet pouze správně vytvořený ABACUS XML fragment nebo XML soubor ArchiMate Interchange Language. Poté, co jste vybrali soubor XML, který chcete importovat, budete dotázáni, jak byste chtěli importovat normy, typya vyhlídky, Můžete importovat standardy, typy a vyhlídky buď jako nových nebo sloučené normy, typya vyhlídky, Výchozí nastavení je pro standardy, typy a vyhlídky se spojil s existujícími standardy, typy a vyhlídky pokud již existují (se stejným přesný název) ve vašem projekt.

Na importovatVaše architektura z,VSD(Visio soubor) vidět zde .

Na importovatVaše architektura zXLS (Excel soubor) vidět zde .


Import typy a standardy z knihovny

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Import typy a standardy z knihovny

Odeslat připomínky na toto téma.

Můžete importovat typy a standardy ze souboru knihovny ABACUS. Můžete také exportovat typů a normy ze souboru ABACUS do souboru knihovny ABACUS.

Chcete-li importovat typy a standardy z knihovny do vaší architektuře

1. Zkontrolujte, zda máte ABACUS souborotevřené a Okno Průzkumníkazobrazeny.

2. Vyberte File | OtevřítChcete-li otevřít ABACUS soubor knihovny.

3. Počítadlo knihovna se otevře v druhém záložkách listu v okně Průzkumníka, a budete muset oddokování tento kartami list aby bylo možné drag-and-drop z něj do původního ABACUS souboru.

4. Táhni a pusťtypy a standardy z knihovny do vaší architektuře.

- nebo -

1. Vyberte File | Nový ...

2. Vytvořit nový ABACUS souborzaložený na ABACUS soubor knihovny.

Chcete-li exportovat typy a standardy z architektury do knihovny

1. Zkontrolujte, zda máte ABACUS souborotevřený, Okno Průzkumníkazobrazena, což ABACUS soubor knihovnyotevřené a Okno knihovnyzobrazeny.

2. Táhni a pusťtypy a standardy z vašeho architektury do knihovny.

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně


Kopírování a vkládání

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Kopírování a vkládání

Odeslat připomínky na toto téma.

Můžete kopírovat část nebo všechny své architektury a vložit ho na jiném místě ve stromu.

Chcete-li zkopírovat

1. Klikněte pravým tlačítkem myšina položku, kterou chtěli zkopírovat.

2. Vybrat Kopie.

Chcete-li vložit

1. Přejděte strom najít místo, které chcete vložit položku.

2. Klikněte pravým tlačítkem myšina větvi chcete, aby se objeví v.

3. Vybrat Vložit.

4. Položka bude zkopírován s původním názvem (pokud ji zkopírovat do původní větve - pak to bude jmenovat "Kopie ...").

Viz také

Jak se architektura zastoupena v ABACUS


Vyhledání a nahrazení položky v architektuře

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Vyhledání a nahrazení položky v architektuře

Odeslat připomínky na toto téma.

Můžeš najít a nahradit pro určitou složku, připojení, typ, standardní nebo vlastnost pomocí Abacus "Najít a nahradit zařízení.

Chcete-li najít položku

1. Klepněte na uzel stromu, který chcete hledat v.

2. Vybrat Edit| Naléztnebo stiskněte Ctrl + F.

3. Zadejte text pro položkanajít v "Najít co" pole.

4. Klepněte na tlačítko Najít další.

Na nahradit položka

1. Klepněte na uzel stromu, který chcete hledat v.

2. Vybrat Edit| Nahraditnebo stiskněte Ctrl + H.

3. Zadejte text pro položkanajít v 'Najít co pole a text nahradit jej v' Nahradit 'pole (nebo-li na poli nic není ponecháno prázdné).

4. Klepněte na tlačítko Najít dalšínajít první instance "Najít co 'text a klikněte na tlačítko Nahradit nahradit tento výskyt s 'Nahradit' text nebo klepněte na tlačítko Nahradit všekterý nahradí všechny instance.

Máte možnosti pro:

o Přizpůsobte svůj případ,

o Přizpůsobte celé slovo,

o Hledat od začátku projektu,

o Ignorovat architektury - to je architektura uzly sami. Všechny uzly pod uzlů architektury, jako jsou komponenty a spojení bude stále hledal,

o Ignorovat komponenty - to je součást uzly sami,

o Ignorovat připojení - to je spojení uzly sami,

o Ignorovat norem - to je všechny standardní uzly architektura, komponenty a připojení budou ignorovány,

o Ignorovat typů - to je typ uzly sami. Jakékoli omezovači uzly pod uzly typu bude stále hledal,

o Ignorovat šablony a obsah -, že je šablona uzly sebe, jakož i některá část šablony a uzly připojení pod nimi,

o Ignorovat vlastnosti - to je všechny typy vlastnictví, jména, hodnoty a jednotky všech prvků tohoto modelu budou ignorovány,

o Ignorovat popisy - to je popisy všech prvků údajů modelu budou ignorovány.

Viz také

Jak se architektura zastoupena v ABACUS


Rozbalení a sbalení strom

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Rozbalení a sbalení strom

Odeslat připomínky na toto téma.

Když uzel ve stromě obsahuje dílčí komponenty a sbírek, bude to mít malý [image] nebo [image] podepsat na jeho levé straně. Můžete klikněte na tlačítko [image] rozbalte uzel a vidět jeho dílčí části a připojení. Podobně, můžete kliknout na [image] kolaps uzel skrýt dílčí komponenty a spojení (tak, aby více prostoru, nebo aby strom srozumitelnější).

Případně můžete rozšířit celý uzel, ve kterém případě všech jejích dílčích uzlů budou rovněž rozšířené, a jejich sub-uzly a jejich ... atd. Stejně tak můžete sbalit celý uzel - uzavření více úrovní najednou ,

Dále, tam jsou možnosti na rozšíření pouze architektury, prvky (tj komponenty a přípojky), součásti nebo připojení.

Chcete-li rozbalit nebo sbalit celý uzel (a jeho sub-uzly, atd.)

1. Klikněte pravým tlačítkem myšiv uzlu.

2. Vybrat Rozbalit | Vše nebo Kolaps.

Chcete-li rozbalit všechny architektury (y)

1. Klikněte pravým tlačítkem myšiNa architekturách a architektury.

2. Vybrat Rozbalit | Vše.

Chcete-li rozbalit prvky

1. Klikněte pravým tlačítkem myšiNa architekturách a architektury.

2. Vybrat Rozbalit | Prvky.

Pro rozšíření komponent

1. Klikněte pravým tlačítkem myšina součástky, komponenty nebo dílčí komponenty.

2. Vybrat Rozbalit | Komponenty | Vše.

Chcete-li rozšířit připojení

1. Klikněte pravým tlačítkem myšina připojení, připojení nebo dílčího připojení.

2. Vybrat Rozbalit | Připojení | Vše.


Slučování položek

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Slučování položek

Odeslat připomínky na toto téma.

Kdy byste sloučit položky?

Ty by se sloučit položky, když máte dvě (nebo více) objekty v modelu, které jsou nejlépe reprezentovány jedné instance. Existuje mnoho situací, kdy budete chtít udělat, včetně:

· V důsledku importu novou sadu informací do modelu která by mohla zdvojit nebo nahradí stávající informace. Například pokud importovat aktualizovanou verzi tabulky do svého modelu.

· Postupem času byly vytvořeny duplikáty "stejné" složky a chcete vyčistit tyto duplikáty.

· Pokud provádíte what-if scénáře a položky jste modelování skutečně sloučení v realitě. Například, pokud jste sloučení dvou oddělení ve vaší organizaci, nebo pokud sloučení dvou serverů.

Co může být sloučeny?

Následující typy položek podporují sloučeny:

· Normy

· Komponent a typy spojení

· Komponenty a připojení

Jak sloučit položky

Chcete-li zahájit sloučení, pomocí pravého tlačítka myši, přetáhněte jednu položku v Průzkumníku na druhou. Položka přetahujete je zdrojem, a položky, které přetáhnete na je cíl. Po uvolnění pravé tlačítko myši, objeví se vám s menu, ze kterého si můžete vybrat, aby Sloučit dvě položky. Budete muset vybrat, zda chcete zachovat nebo přepsat cíle. Toto je dále vysvětlen níže.

Nabídka pravého drag merge

Jaký je rozdíl mezi zachování a přepsání cíl?

Zachovat nebo přepsat možnost určuje, co se stane v případě, že název, popis nebo vlastnosti mezi zdrojovou a cílovou položky utkání.

Je-li zvolena Zachovat Destination

· Cílovém Jméno a popis budou zachovány.

· Všechny vlastnosti, které existují pouze ve zdroji jsou přidány do cíle.

Pokud Přepsat cíl je vybrán:

· Cílového Jméno bude přepsán od zdroje.

· Místo určení se Popis bude přepsáno ze zdroje, pokud nemá zdroj v Popis je prázdný.

· Všechny vlastnosti, které existují pouze ve zdroji jsou přidány do cíle.

· Hodnota a jednotka žádné vlastnosti, které existují v obou zdroj a cíl bude přepsáno ze zdroje, pokud nemá zdroj v Value Unit nebo je prázdné.

Zvláštní případy

· Druhy: Při slučování typů, oprávnění jsou sloučeny, v "pesimistické" způsobem, tak, že v případě, že oprávnění na zdroji neexistoval na místě určení, že by být přidáno, a pokud je to existují v lokalitě, pak v případě, že jedinec oprávnění pro skupinu uživatelů (vytvářet, číst, aktualizovat nebo mazat) neodpovídá (jeden uděleno, jeden popřel), pak, že povolení bude odepřeno.

· Komponenty: Při slučování komponentů, sub-komponenty zdroje jsou přeneseny na místo určení, a se spojil s sub-složek v určení, pokud jejich jména jsou shodné, Bez ohledu na jejich typ.Kromě toho bude více sub-komponenty zdroj se stejným názvem být spojeny do jedné dílčí komponenty v cílové zemi.

· Připojení: Nejvyšší úrovni samotné připojení musí oba mají stejné přílohy (nebo jeho nedostatek), aby jim bylo umožněno být sloučeny. Při slučování připojení sub-přípojky zdroje jsou přeneseny na místo určení, a se spojil s dílčími připojení v určení, pokud jejich jména jsou shodné Ajejich přílohy jsou identické. Pokud přílohy nejsou totožné, bude zdroj dílčí připojení být přidána do cíle, aniž by se spojovat s odpovídajícími připojení již přítomných. To je tak, aby žádné přílohy jsou ztraceny.


Definování a ověřování Omezení

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Definování a ověřování Omezení

Odeslat připomínky na toto téma.

Struktura a vlastnosti architektury může být omezeno pomocí vazeb. Omezení lze aplikovat na typy komponent a typy připojení omezit strukturu architektury v dvěma způsoby. Prvním způsobem je omezit hierarchiedefinováním "rodič by měl / musí mít dítě" a "dítě by mělo / musí mít mateřská" vztahy. Druhým způsobem je omezit topologiedefinováním "složka by měla / musí být připojen k připojení" a "připojení by mělo / musí být připojen k složka" vztahů. Kromě toho omezení mohou být aplikovány na vlastnosti typů komponent, typy připojení, šablony, pohledy, architektury, diagramya 3D prohlídky omezit architektury (y) v dalších dvou směrech. První způsob je nastavit datový typnemovitosti omezit platné hodnoty, že může mít, a to; Text, Integer, desítkové, datum / čas, Boolean nebo List. Druhý způsob je nastavit požadovanýStav nemovitosti k označení, zda je hodnota, je třeba zadat pro vlastnost (Poznámka: Požadované omezení se vztahují pouze na vlastnosti pro komponent a připojení typy). Další informace o omezeních nemovitost je nabízena v Změna vlastností komponenty, připojení nebo typu téma nápovědy. Poté, co byly definovány omezení, je možno ověřit architektury proti omezení. ABACUS bude varovat o všech omezeních, které byly porušeny.

Klíčem k určení toho, které podmínka (podmínky), aby se definovat spočívá v přesném jazyk použitý k popisu omezení. Pro hierarchických omezení jsou obvykle ve formě "podstatná jménamůže / by měla / musí být rozložen do n podstatná jména" nebo "podstatná jménamůže / by / musí být seskupeny podle podstatná jména"Atd. Například"Oddělenímusí být rozložen do Týmy" nebo "Aplikacelze rozdělit na Moduly". Pro topologie omezením, že jsou typicky ve formě"podstatná jménamůže / by / musí sloveso podstatná jména". Například, "Procesy může být provádí Týmy" nebo "Aplikacejsou hostuje Servery". Nyní můžete vidět v každé omezení existují různé CAN / měla by se / musí" kvalifikační "a tyto mohou být 3 typů;

· Volitelný- Ty budou typicky používat slova / fráze líbí; "může", "může", "mohl", "popřípadě" atd.

· Doporučená- Ty budou typicky používat slova / fráze líbí; "by měly", "doporučil", "poradil" atd.

· Povinné- Ty budou typicky používat slova / fráze líbí; "musí", "je", "jsou", "má", "musí" atd.

V závislosti na typu omezení (hierarchie nebo topologie) a kvalifikaci používané v popisu to, specifická vazba (s), by měl být definován (viz níže). Pro výše uvedené hierarchie příkladem "Oddělenímusí být rozložen do Týmy"Jeden by měl definovat" Parent, musí mít dítě "omezení a nastavit výkon má být vykonán. Pro výše uvedený příklad topologie"Procesy může být provádí Týmy. "Je třeba vytvořit pouze dva (2)" Připojení musí být připojen k Component "omezení, která pro obou koncích provedeno podle typu připojení Konkrétně se jedná o následující omezení se doporučuje být definovány (viz níže), pro různé možnosti;

· Hierarchie omezení;

o Podstatná jména může býtrozložen do Podstatná jména B, nebo Podstatná jména B může býtseskupených podle Podstatná jména nebo Podstatná jména B mělo byseskupených podle Podstatná jména- Definovat "Dítě musí mít rodič" omezení s typem dětské substantivum B, mateřská typu substantivum A a prosazování, jak je varoval.

Poznámka

To znamená, že pokud dítě existuje, měl by mít rodiče určitého typu. Pokud ne, budete na to upozorněni.

o Podstatná jména mělo byrozložen do Podstatná jména B- Definovat "Parent musí mít dítě" omezení s mateřskou typem substantivum A, typ dětské substantivum B a prosazování, jak je varoval.

Poznámka

To znamená, že pokud rodič existuje, měl by mít děti určitého typu. Pokud ne, budete na to upozorněni.

o Podstatná jména musí býtrozložen do Podstatná jména B- Definujte "rodič musí mít dítě" omezení s mateřskou typem substantivum A, typ dětské substantivum B a vymáhání, jaké prosazována.

Poznámka

To znamená, že pokud rodič existuje, musí mít děti určitého typu. Pokud ne, budete mít chybu.

o Podstatná jména musí býtseskupených podle Podstatná jména B- Definovat "Dítě musí mít rodič" omezení s typem dětské substantivum A, mateřská typu substantivum B a vymáhání, jaké prosazována.

Poznámka

To znamená, že pokud dítě existuje, musí mít rodiče určitého typu. Pokud ne, dostanete chybu.

· Omezení topologie;

o Podstatná jména může být sloveso Podstatná jména B- Definovat dvě (2) "Připojení musí být připojen k složka" omezení. První bytost se zdrojem koncem typu připojení slovesopřipojené k podstatnému jménu A typu konstrukční části a prosazování nastavena na vymáhány. Druhá bytost s dřezu koncem typu připojení slovesopřipojené k Noun typu konstrukční části, B a výkonu nastaveným na vymáhány.

Poznámka

To znamená, že v případě, že existuje spojení, musí se spojit součásti určitých typů. Pokud ne, budete mít chybu. Celkově tím je zajištěno, že tyto složky mohou stále existují, a nesmí být připojeny k sobě navzájem. Nicméně v případě, že jsou připojeny, je nutno použít spoje správného typu.

o Podstatná jména mělo by sloveso Podstatná jména B- Definovat dvě (2) "Component musí být připojen k připojení" omezení. První byl s Noun Typ komponent připojený ke zdrojovému konci slovesoTyp připojení a prosazování set do varoval. Druhá bytost s Noun typu konstrukční části B připojena k umyvadlu konci slovesoTyp připojení a prosazování set do varoval. Kromě toho, definovat dvě (2) "Připojení musí být připojen k složka" omezení. První bytost se zdrojem koncem typu připojení slovesopřipojené k podstatnému jménu A typu konstrukční části a prosazování nastavena na vymáhány. Druhá bytost s dřezu koncem typu připojení slovesopřipojené k Noun typu konstrukční části, B a výkonu nastaveným na vymáhány.

Poznámka

To znamená, že pokud existují součásti obou typů, by měly být připojeny k připojení určitého druhu. Pokud ne, budete na to upozorněni. Kromě toho, to znamená, že v případě, že existuje spojení, musí být připojen k komponent daného typu. Pokud ne, budete mít chybu. Celkově toto je zajištěno, že pokud existují složky těchto typů, získáte varování v případě, že nejsou připojeny k sobě navzájem.

o Podstatná jména musí být sloveso Podstatná jména B- Definovat dvě (2) "Component musí být připojen k připojení" omezení. První byl s Noun Typ komponent připojený ke zdrojovému konci slovesoTyp připojení a vymáhání nastavena na vymáhány. Druhá bytost s Noun typu konstrukční části B připojena k umyvadlu konci slovesoTyp připojení a vymáhání nastavena na vymáhány. Kromě toho, definovat dvě (2) "Připojení musí být připojen k složka" omezení. První bytost se zdrojem koncem typu připojení slovesopřipojené k podstatnému jménu A typu konstrukční části a prosazování nastavena na vymáhány. Druhá bytost s dřezu koncem typu připojení slovesopřipojené k Noun typu konstrukční části, B a výkonu nastaveným na vymáhány.

Poznámka

To znamená, že pokud existují součásti obou typů, musí být připojena k připojení určitého druhu. Pokud ne, budete mít chybu. Kromě toho, to znamená, že v případě, že existuje spojení, musí být připojen k komponent daného typu. Pokud ne, budete mít chybu. Celkově toto je zajištěno, že pokud existují složky těchto typů, dostaneme chyby, pokud nejsou navzájem spojeny.

Chcete-li definovat omezení

1. Zkontrolujte, zda máte ABACUS souborotevřené a Okno Průzkumníkazobrazeny.

2. Ve stromu explorer expandovat Druhy | Component Druhynebo rozšířit Druhy | Typy připojení.

3. Klikněte pravým tlačítkem myšitypu složka nebo typ připojení a zvolte Přidat Vazba.

Přidání omezení

Chcete-li definovat hierarchie omezení, kdy musí rodič mít konkrétní dítě

4. Na Přidat VazbaOkno zaškrtnout Vytvoření Constraintcheckbox v rámci Rodič musí mít dítě Vazba plocha.

5. Vyberte typu konstrukční částiz rozevíracího seznamu, který chcete označit jako dítě typu konstrukční části, vybrané v kroku 3.

Poznámka

Pokud je již aktivován "mateřským Must Have Child" omezení definované pro mateřskou typu konstrukční části a další dítě typu konstrukční části, pak se tato nová omezení bude kvalifikována jako "a". To je typ, musí být rodič typu dítěti atyp dítě B, na jakékoliv úrovni vymáhání (např Disabled varoval, nebo Vynucená - viz krok 7) je stanovena pro každou omezení.

6. Volitelně lze definovat minimální a maximální počet složek typu konstrukční části, upřesnil, že musí být děti typu konstrukční části klepli pravým tlačítkem myši v kroku 3.

7. Vyberte, zda chcete, aby omezení Zakázáno, Varoval nebo Vynucený.

Poznámka

Tělesně omezení budou ignorovány z omezovači validace, bude varoval omezení produkovat varování v okně Ověření, pokud jsou zjištěny a prosazována omezení bude vyrábět chyba v okně Ověření, pokud jsou zjištěny. Dále, všechny chyby musí být vyřešeny před přijetím Podnik Server projekt může být spáchán.

8. Klepněte na tlačítko Dobře.

Poznámka

Omezení se zobrazí ve stromu explorer podle typu konstrukční klepli pravým tlačítkem myši v kroku 3. Šipka označuje směr omezení, a v tomto případě bude směřovat dolů a doprava. Visací zámek je zbarven podle toho, zda omezení je Disabled (šedá), Varoval (žlutá) nebo vykonáno (červená).

Rodič musí mít dítě varoval omezení

Chcete-li definovat hierarchie omezení, kdy musí dítě mít konkrétní rodiče

4. Na Přidat VazbaOkno zaškrtnout Vytvoření Constraintcheckbox v rámci Dítě musí mít Parent Vazba plocha.

5. Vyberte typu konstrukční částiz rozevíracího seznamu, který chcete označit jako rodič typu konstrukční části klepli pravým tlačítkem myši v kroku 3.

Poznámka

Pokud je již aktivován "Dítě musí mít mateřskou" omezení definované pro daný typ dětské komponent a další mateřskou typu konstrukční části, pak se tato nová omezení bude posuzována jako "nebo". To je typ, musí být dítě rodič typu A neborodič typu B, a úroveň výkonu (např upozorněni nebo vykonáno - viz další krok) by měla být stejná jinak vynucené omezení bude vždy přednost varoval ty.

6. Vyberte, zda chcete, aby omezení Zakázáno, Varoval nebo Vynucený.

Poznámka

Tělesně omezení budou ignorovány z omezovači validace, bude varoval omezení produkovat varování v okně Ověření, pokud jsou zjištěny a prosazována omezení bude vyrábět chyba v okně Ověření, pokud jsou zjištěny. Dále, všechny chyby musí být vyřešeny před přijetím Podnik Server projekt může být spáchán.

7. Klepněte na tlačítko Dobře.

Poznámka

Omezení se zobrazí v zobrazení Průzkumník podle typu konstrukční zvoleného v kroku 5. Šipka označuje směr omezení, a v tomto případě bude ukazovat nahoru a doleva. Visací zámek je zbarven podle toho, zda omezení je Disabled (šedá), Varoval (žlutá) nebo vykonáno (červená).

Dítě musí mít mateřskou varoval omezení

Pro definování topologie omezení, pokud musí být součást připojena k konkrétní připojení

4. Na Přidat VazbaOkno zaškrtnout Vytvoření Constraintcheckbox v rámci Součást musí být přiložena Vazba plocha.

5. Vyberte Typ připojeníz rozevíracího seznamu, který chcete označit jako přiloženého připojení typu konstrukční klepli pravým tlačítkem myši v kroku 3 (nebo vyberte typu konstrukční částiz rozevíracího seznamu, který chcete označit jako připojené komponenty, pokud v kroku 3 jste klikli pravým tlačítkem na typ připojení.)

Poznámka

Pokud je již aktivován "Component musí být připojen" omezení definovaná pro typ konstrukční části a jiným typem připojení pak bude tato nová omezení být zacházeno jako "a". To znamená, musí být typu konstrukční části připojena k typu připojení aTyp připojení B, na jakékoliv úrovni vymáhání (např Disabled varoval, nebo Vynucená - viz krok 7) je stanovena pro každou omezení.

6. Volitelně si můžete vybrat připojení rolekteré chcete přidat do vazby. Svolit konkrétní role (tj. buď Source nebo Sink) z rozevíracího seznamu.

7. Vyberte, zda chcete, aby omezení Zakázáno, Varoval nebo Vynucený.

Poznámka

Tělesně omezení budou ignorovány z omezovači validace, bude varoval omezení produkovat varování v okně Ověření, pokud jsou zjištěny a prosazována omezení bude vyrábět chyba v okně Ověření, pokud jsou zjištěny. Dále, všechny chyby musí být vyřešeny před přijetím Podnik Server projekt může být spáchán.

8. Klepněte na tlačítko Dobře.

Pro definování topologie omezení, pokud musí být spojení připojena k specifické komponenty

4. Na Přidat VazbaOkno zaškrtnout Vytvoření Constraintcheckbox v rámci Připojení musí být přiložena s omezujícími podmínkami plocha.

5. Vyberte Typ připojeníz rozevíracího seznamu, který chcete označit jako přiloženého připojení typu konstrukční klepli pravým tlačítkem myši v kroku 3 (nebo vyberte typu konstrukční částiz rozevíracího seznamu, který chcete označit jako připojené komponenty, pokud v kroku 3 jste klikli pravým tlačítkem na typ připojení.)

Poznámka

Pokud je již aktivován "Připojení musí být připojen" omezení definovaná pro typ připojení a jiného typu konstrukční části za použití stejné připojení role(tj. buď Source nebo Sink), pak se tato nová omezení bude zacházeno jako "OR". To je nutno uvést druh spojení připojena ke složce typu A nebotypu konstrukční části B, a úroveň výkonu (např upozorněni nebo vykonáno - viz krok 7), by měla být stejná jinak vynucené omezení bude vždy přednost varoval ty. Všimněte si také, že pokud existuje více omezení, které mají připojení rolespecifikován jako "Každý" (na rozdíl od specificky Source nebo dřez), pak oba konce spojení musí být připojen k jednomu z typů složek specifikovaných v omezení.

6. Volitelně si můžete vybrat připojení rolekteré chcete přidat do vazby. Svolit konkrétní role (tj. buď Zdroj nebo Dřez) z rozevíracího seznamu.

Poznámka

Buď Source nebo Sink role musí být výslovně vybraných pro Příloha sloupec se skladem, které mají být zobrazeny v komponentě katalog .

7. Vyberte, zda chcete, aby omezení Zakázáno, Varoval nebo Vynucený.

Poznámka

Tělesně omezení budou ignorovány z omezovači validace, bude varoval omezení produkovat varování v okně Ověření, pokud jsou zjištěny a prosazována omezení bude vyrábět chyba v okně Ověření, pokud jsou zjištěny. Dále, všechny chyby musí být vyřešeny před přijetím Podnik Server projekt může být spáchán.

8. Klepněte na tlačítko Dobře.

Reálný čas model checking a nátlak ověřování

ABacus zahrnujereal-time model Kontrola a Ověření funkce na ihned zobrazit účinky dané operace bude mít uživatel na varování a chyby s aktuálním projektu, v důsledku jakéhokoliv hierarchie a topologie omezení, které byly definovány. Je třeba poznamenat, že všechny chyby musí být vyřešeny před přijetím Podnik Server projekt může být spáchán.

Funkce validace omezení v reálném čase je nejvíce patrné při vyplnění s diagramy nebo přímo v okně Průzkumníka. Zejména během následujících operací, jsou uvedeny pokyny pomocí barevných světel, pokud jde o efekt operace bude mít na varování a chyby s aktuálním projektu;

1. Při přetahování prvků na nebo kolem diagramu barvy mateřské společnosti (nebo připojování) komponenty (pokud existuje) border budou zbarveny podle schématu popsaného níže.

2. Při připojení komponentů pomocí pravým tlačítkem myši táhnout | Připojte k rysu seznam dostupných typů připojení je zbarvená podle schématu popsaného níže.

3. Při připojování součásti na diagramu pomocí režimu Connector kurzor se bude měnit barvy podle schématu popsaného níže.

4. Při přidávání dílčí komponenty se seznam dostupných typů součástí je zbarven podle schématu popsaného níže.

Obecně tyto barvy jsou použity pro indikaci účinků uživatel operace bude mít na varování a chyb s aktuálním projektu;

Černý : Žádný dopad na varování nebo chyby.

Zelená : Operace je výslovně v souladu sdefinované hierarchie a topologie omezení pro projekt.

Červený : Operace je výslovně v rozporu sdefinované hierarchie a topologie omezení pro projekt, a bude mít za následek varování a / nebo chyby.

Pozadí model checking a nátlak ověřování

ABACUS zahrnuje Funkce Validation zobrazit všechny varování a chyby s aktuálním projektu, kvůli jakýchkoli omezení, které byly definovány. Je třeba poznamenat, že všechny chyby musí být vyřešeny před přijetím Podnik Server projekt může být spáchán.

Poznámka

Ověření musí být ručně spustit pomocí "Potvrdit / kontrolní podmínky projekt" tlačítko na Hlavní panel nástrojů , Okno Ověření je ve výchozím nastavení skrytýale se objeví, když je tlačítko na panelu nástrojů klepnutí, Vidět Přizpůsobení rozhraní na to, jak jej zobrazit a případně nechat trvale zobrazeny. Také můžete poklepáním na libovolný řádek v okně Ověření na "skok" k příslušné prvek v projektu.

Ověření okno

Výchozí sloupce okna Ověření jsou popsány níže;

Varování nebo Chyba: Tento sloupec zobrazí ikonu, zda je porušení je varování (žlutý trojúhelník s vykřičníkem), nebo chyby (červené kolečko s křížkem).

Číslo: Tento sloupec zobrazuje číslo narušení.

Poznámka

Pouze 200 porušení jsou zobrazeny v čase, a pokud existuje více než 200 porušení v projektu Start, Předchozí, Další a konec řady navigátory v pravém horním rohu okna lze použít k prohlížení další porušování lidských práv.

Popis: Toto je úplný popis porušení, včetně osobou a Omezení se týká.

Bytost: Tento sloupec zobrazuje Subjekt znepokojuje porušení.

Typ: Tento sloupec zobrazuje typ prvku pro osoby.

Architektura: Tento sloupec zobrazuje architekturu, ve které k porušení došlo.

Zjištěno: Tento sloupec zobrazuje čas, který byl detekován porušení.

Tip

Je užitečné Seřadit sestupně podle detekovaného kolony (jak je uvedeno v dialogu výše), aby zajistily, že nejnovější porušení se objeví v "top" seznamu.

Existuje několik možností uživateli změnit chování validace pozadí modelu. Například to změnit barvy použité pro porušení podmínek na jinou hodnotu než výchozí Červený, Klikněte na tlačítko na Nástroje | Možnosti ... pak jít do Ověřováníkarta, a nastavit barvy pomocí Přeměna tlačítka.

Ověřování Možnosti

Chcete-li ručně ověřit omezení

1. Klikněte pravým tlačítkem myši na Architekturyuzel na libovolné počítačové architektuře nebo kdekoli buď Komponenty nebo Připojeníčást zobrazení průzkumníka a zvolte Zkontrolujte Omezení.

Ověřit omezení

2. Klepněte na tlačítko PodrobnostiTlačítko na Upozorněníokna vidět, kde architektura porušuje jakákoli omezení, které byly definovány.

Poznámka

Přestupky jsou zobrazeny pouze u těch omezení, které byly stanoveny na Varoval nebo vykonáno. Navíc znění varování bude zahrnovat "měl by" v případě, že omezení bylo jen varování, nebo "musí", pokud to bylo prosazeno.

3. Klepněte na tlačítko Dobře.

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně


Vyvíjející vaší architektury

Navigace: Naplnění vaší architektury> Naplnění ručně> další možnosti>

Vyvíjející vaší architektury

Odeslat připomínky na toto téma.

Architektury může být explicitně vyvíjel a hierarchie architektur vytvořena. Tak by vyvíjející svou architekturu v ABACUS, může být vytvořena řada pokročilých architektonických řešení, srovnání a baselined. Cíle (nebo metriky) lze definovat pro libovolný počet architektonických vlastností pro stávající architektury.

Jednoduchý způsob, jak vzít v úvahu vývoj architektury, je to souvisí s konceptem potomek architektura, Když je architektura se vyvinula, je kopiemateřské architektury je vytvořen. Tento výtisk může být řekl, aby přímý potomekoriginálu rodič architektura.

Poznámka

V tomto on-line dokumentaci nápovědy a Abacus sada nástrojů sám, termín rozvíjet seje více běžně používaný než pojem potomekUpozorňujeme, že obě odkazují na stejnou funkci.

Pro další vývoj stávající architektury

1. Zkontrolujte, zda máte ABACUS souborotevřené a Okno Průzkumníkazobrazeny.

2. Vyberte příslušnou architekturu, kterou chcete vyvíjet z Průzkumníka stromu.

3. Klikněte pravým tlačítkem myšina architekturu a vyberte Rozvíjet sez menu.

Vyvíjející The Chosen Architecture

4. Vyvinutého architektura se objeví pod vybranou architektury.

Evolved Architektura

Poznámka

Vyvinutého architektura může být přejmenován kliknutím pravým tlačítkem myši na architekturu a výběru Přejmenovat.Navíc, všechny diagramy a katalogy v architektuře se vyvinul se automaticky nastaví na "diff" proti základní architektury že byl vyvinut z.

Stanovení cílů pro váš vyvinul architekturu

Stanovení cílů pro váš vyvinula architekturu umožňuje vytvořit kritéria pro posouzení vývoje svých architektur. Cíle jsou stanoveny typy vlastnictví a názvy těchto vlastností existujících v vyvinulo architektuře. Cíle mohou být také ručně definovány a přidal k vám architektuře. Postupujte podle pokynů stanovených cílů.

Stanovení cílů z existujících vlastností pro vaši vyvinul architekturu

1. Zkontrolujte, zda máte ABACUS souborotevřené a Okno Průzkumníkazobrazeny.

2. Vyberte Nástroje | Stanovených cílůZ hlavního menu.

3. Cíl VstupZobrazí se okno.

Cíl okno vstupního

4. Klikněte na Existující tlačítko.

5. Vyberte vlastnostZobrazí se okno.

6. Vyberte vlastnost, kterou chcete nastavit jako cíl pro vyvinulo architekturu a klikněte na tlačítko Dobře tlačítko.

7. Zvolený cíl se nyní zobrazí v Cíl Vstup okno.

8. Vyberte cíl a klikněte na Edit tlačítko.

9. Upravit GoalZobrazí se okno.

Poznámka

Toto okno umožňuje změnit název vlastnosti a typ, který gól bude odrážet, stejně jako nejhorší a nejlepší hodnoty (nebo minimální / maximální hodnoty), pro tuto vlastnost. Tyto hodnoty jsou nalezeny porovnáváním všech architekturách a najít nejmenší a největší hodnotu v každé pro tuto specifickou vlastnost. Tyto hodnoty mohou být také ručně definovány. Například, pokud jste měli stanovila cíl pro vlastnost s názvem Response (Ave)a typu ChováníVaše nejhorší a nejlepší hodnota by mohla odrážet rychlost transakce potřebné pro optimální výkon (nejlepší hodnota) a rychlost transakcí potřebné pouze pro hlavní aplikace ke zpracování (nejhorší hodnota).

10. Poté, co byly definovány příslušné hodnoty, vyberte Dobře.

Stanovení cílů z nových vlastností pro vaši vyvinul architekturu

1. Zkontrolujte, zda máte ABACUS souborotevřené a Okno Průzkumníkazobrazeny.

2. Vyberte Nástroje | Stanovených cílůZ hlavního menu.

3. Cíl VstupZobrazí se okno.

4. Klikněte na Nový tlačítko.

5. Nový cílZobrazí se okno.

Poznámka

Toto okno umožňuje definovat název vlastnosti a typ, který gól bude odrážet, stejně jako nejhorší a nejlepší hodnotu (nebo minimální / maximální hodnoty) pro tuto vlastnost. Například, pokud jste měli nastavit cíl pro vlastnost s názvem Response (Ave)a typu ChováníVaše nejhorší a nejlepší hodnota by mohla odrážet rychlost transakce potřebné pro optimální výkon (nejlepší hodnota) a rychlost transakcí potřebné pouze pro hlavní aplikace ke zpracování (nejhorší hodnota).

6. Poté, co byly definovány příslušné hodnoty, vyberte Dobře.

7. Dialog, Přidat do všech architekturáchzobrazí jak je uvedeno níže:

8. Klikněte na Anopřidat cíl jako majetku na všech příslušných architektur. Tím je zajištěno, že nově definovaný cíl a jeho vlastnosti budou přidány do všech architektur v souboru. Pokud si nepřejete zahrnout nemovitost v architekturách, můžete kliknout na Ne.

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Zobrazení hvězda spiknutí svých vyvinutých architektur | Zobrazení bodový graf vašich vyvinutých architektur


Nástroje pro kreslení

Navigace: Naplnění vaší architektury> Použití výkresů>

Nástroje pro kreslení

Odeslat připomínky na toto téma.

Nástroje pro kreslení umožňuje vytvoření široké škály architektonických schémat a diagramů. Architekti tradičně používají řadu různých kreseb pro záznam a zprostředkovat návrh architektury. Dvourozměrné (2D) diagramy jsou obvyklý způsob, jak dokumentovat a komunikovat různé části systému. Typickými kresby používaných v podnikové systémy jsou:

· Business procesní modely a diagramy;

· Organizační schémata;

· Spolupráce diagramy;

· Entity-Relationship (ER) diagramy;

· Data-vývojové diagramy (DFD je);

· Diagramů tříd;

· IDEF (zahrnující několik z výše uvedených); a

· UML (zahrnující několik z výše uvedených).

Tam opravdu není žádný limit na druhy diagramů, které lze vytvořit. ABACUS se snaží vyrovnat flexibilitu diagram při zachování integrity architektury a jeho forem reprezentace.

Kresba prostředí je kartami a ukotvené okno, uvnitř hlavní ABACUS aplikaci. Toto okno obsahuje plátno, kde se kresba koná, a když je otevřené okno výkresu druhý ukotvené okno, , Okno šablony, je viditelný se souborem výkresu šablon. Panel šablona má 4 záložky: Prvky, přípojky, tvary a konektory. Plátno se jeví jako bílé pozadí s jemnými čarami (užitečné pro rozvržení).

Komponenty jsou reprezentovány rozsahu tvarů, přičemž spoje jsou nakresleny jako namířených linek. Připojení připojit k součásti pomocí role (tj. buď Source nebo Sink) které však nejsou zobrazeny z estetických důvodů.

Tip

A zároveň diagramyjsou velmi užitečné pro zobrazení různých částí systému, které jsou ve svých škálovatelnosti, což je důvod, proč ABACUS používá 3D vizualizaci složité struktury systému.

Možná budete chtít

1. Otevřete Diagramů Nástroj

2. Vytvořit nový diagram na část vaší architektuře

3. Kopírovat diagram uvnitř nebo napříč architekturách

4. Přidejte komponenty diagramu

5. Vytvoření nové komponenty a spoje v architektuře (schematicky) pomocí nástroje pro kreslení

6. Odstranění komponenty z diagramu

7. Připojit & manipulovat spoje

8. Změna vlastnosti zobrazení součástek a spojů.

9. Pomocí odkazů v diagram

10. Vynutit přidružení typu a názory tak, aby se omezit typy diagramů, které lze vyvodit.

Viz také

Naplnění vaší architektury | Naplnění vaší architektury ručně | Analýza Vaše architektura


Otevření diagramy

Navigace: Naplnění vaší architektury> Použití výkresů>

Otevření diagramy

Odeslat připomínky na toto téma.

Na kreslení vzorníku a plátno okna se zobrazí automaticky, pokud je diagram otevření nebo vytvoření. Podobně, když je diagram uzavřen, odpovídající kartami list v okně plátně zmizí a v případě, žádné další výkresy jsou otevřená, je okno šablony je uzavřen.

Na vytvořitnový diagram

1. Zkontrolujte, zda máteABACUS otevřít souborobsahující Váš obydlený architektura.

2. Klikněte na Diagramikonu v panelu nástrojů Zobrazení.

- nebo -

2. Vybrat Vložit| Diagram.

- nebo -

2. Klikněte pravým tlačítkem myši Diagramyvětev dané Architekturačást stromu a vyberte Vytvořit Diagram.

3. Vyberte ArchitekturaChcete se zaměřit na z rozbalovacího menu. Poznámka: architektura bude již vybrán pro vás, pokud jste použili výše uvedeném kroku 3 a otevřete nový diagram.

4. Vyberte Hledisko chcete použít z rozbalovacího menu. Poznámka: zvolená hledisko bude filtrovat komponenty a seznamy přípojky být dostupné k pohledu jen.

5. Volitelně si vybrat pohled z Filtrovat podle Viewpull-down menu, aby předběžně vybrala komponenty a připojení z vybraného pohledu. Poznámka: toto je efektivně využívat vybrané zobrazení jako uloženého dotazu.

6. Vyberte Vyložit být buď Radiální nebo Mřížka.

7. Vyberte Komponenty a Připojeníže chcete v diagramu podaná okno pro výběr standardním prvkem .

8. Klepněte na tlačítko Dobře.

Poznámka

Nové schéma bude přidána do Diagramyobor architektury. To bude mít výchozí název, který můžete později změnit kliknutím pravým tlačítkem myši na něj.Kromě toho bude poslední stav komponent a výběru připojení filtruje být uložen s schéma účinně uložení "dotaz", použitý k vytvoření diagramu.

Chcete-li otevřít existující diagram

1. V konkrétním obydlené architektury, rozbalte Diagramyvětev stromu.

2. Dvojklik diagram, který chcete otevřít.

Chcete-li uložit diagram

1. Ujistěte se, že máte novou nebo stávající diagram otevříta vy jste provedli nezbytné změny. Poznámka: hvězdičku "*" se zobrazí za názvem pohledu v záložkách hlavičce sumou, pokud dojde ke změnám, které mají být uloženy.

2. V zobrazení průzkumníka klikněte na Uložittlačítko nebo se dostal do Soubor| Uložitnebo sešlápněte Ctrl + Suložit všechny změny v architektuře a zapsat jej do souboru.

Chcete-li uložit diagram formě hledisko

1. Ujistěte se, že máte existující schéma ve vašem souboru ABACUS.

2. Klikněte pravým tlačítkem myšiSchéma v Diagramyčást stromu.

3. Vybrat Uložit jako Diagram Viewpoint.

4. Zadejte název pro váš nový diagram hlediskoa klepněte na tlačítko Dobře.

Viz také

Nástroje pro kreslení | Naplnění vaší architektury | Analýza Vaše architektura


Kopírování diagramy

Navigace: Naplnění vaší architektury> Použití výkresů>

Kopírování diagramy

Odeslat připomínky na toto téma.

K dispozici jsou 2 základní scénáře do zkopírováním existující schéma; v architektuře, nebo přes architektury.

Na kopieschémav rámci architektury

1. Zkontrolujte, zda máteABACUS otevřít souborobsahující Váš obydlený architekturas alespoň jedním diagram.

2. Rozšířit Diagramy větev (a případně zajistit potřebné Diagram skupiny) z dané Architekturačást stromu.

3. Vyberte diagram, který chcete zkopírovat, a poté stiskněte tlačítko Ctrl + C nebo klikněte pravým tlačítkem myšia vyberte Kopie z nabídky.

Poznámka

A kopii rozhodnutí schéma bude přidána do Diagramyvětev z stejný architektura. To bude mít "Kopie" připojena na začátek názvu, Který můžete změnit později stisknutím F2 nebo klepnutí pravým tlačítkem myši na něja výběrem Přejmenovat.

Na kopírovat diagram přes architektury

1. Zkontrolujte, zda máteABACUS otevřít souborobsahující Váš obydlený architekturass alespoň jedním diagram.

2. Rozšířit Diagramy větev (a případně zajistit potřebné Diagram skupiny) z Architekturačást stromupro architekturu, která obsahuje diagram, který chcete kopírovat.

3. Vyberte diagram, který chcete zkopírovat, a na Obecné vlastnostiOkno Poznámka Hledisko že diagram je spojen s (v poli Typ).

4. Teď, rozšířit Diagramy větev (a případně zajistit potřebné Diagram skupiny) z Architekturačást stromupro ostatní architektury, který chcete zkopírovat do diagramu.

5. Klikněte pravým tlačítkem myši Diagramy uzel (nebo Diagram skupina) A zvolte Vytvořit diagram ..., V dialogovém okně, které se objeví vyberte Hledisko která byla zaznamenána v kroku 3 výše v rozbalovací nabídce v pravém horním rohu. Nechte vše ostatní, jako je a klepněte na tlačítko Dobře, V dialogu Diagram Název zadejte název (brzy být) kopírovány diagramu. Poznámka: prázdný diagram plátno podle zvoleného hlediska se otevře.

6. Vraťte se do schématu, které chcete kopírovat, a otevřít, že klepnutí pravým tlačítkem myšiuzel a výběru Otevřít nebo jednoduše poklepáním to.

7. Vyberte pozadí plátno diagramu, který chcete kopírovat, a stiskněte Ctrl + A, Tím se vyberou všechny prvky na tomto diagramu. Nyní stiskněte Ctrl + Ckopírovat obsah do schránky.

8. Nyní se vraťte do prázdného diagramu v architektuře, kterou chcete zkopírovat obsah do, zvolit pozadíplátno a buď klikněte pravým tlačítkem myšia vyberte Vložit nebo jednoduše stiskněte Ctrl + Vvložit obsah. Po krátké době se obsah všechno bude vložen do nového prázdného diagramu.

Poznámka

Prvky bude přidána do nejvyšší úrovně nové architektury a budou muset být re-zařídil nebo sloučeny s existující obsah v souladu s.

Viz také

Nástroje pro kreslení | Naplnění vaší architektury | Analýza Vaše architektura


Naplnění Diagramy

Navigace: Naplnění vaší architektury> Použití výkresů>

Naplnění Diagramy

Odeslat připomínky na toto téma.

Výkresy v ABACUS jsou více než jen libovolných reprezentací. Jsou přizpůsobené pohledy na architekturu, formátované a uspořádány tak, aby ukázat zvláštní význam.

Nástroje pro kreslení vynucuje hierarchickou strukturu architektury, takže komponenty jsou vizuálně vnořeny do dalších komponent - efektivně dává "půdorys" těchto prvků. Jakmile je složka nebo spojení byla definována v architektuře, je možné jej použít v libovolném počtu různých diagramů. Důležité je, že Průvlak je úzce spojeno s architektonického modelu, takže změny provedené buď v jednom, jsou vždy projeví v druhé.

Nástroj funguje tak, že spojením tvary s konkrétním spojení a komponent typů definovaných v části Typy architektury. Tyto asociace se liší v závislosti na typu diagramu, že je přitahován, a je možné, že jeden typ složky (či spojení) mohou mít různé reprezentace v různých schématech, v závislosti na kontextu.

Chcete-li nastavit asociaci mezi tvarem a součást nebo typu připojení

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Maximalizovat aplikaci ABACUS, a nakonfigurovat okna proporce jak si přejete.

3. Vyberte Karta Tvary nebo Karta Konektory v okně vzorníku.

4. V Typvětev Explorer, vyhledejte komponent nebo typ připojení, který chcete spojit s tvarem nebo konektor.

5. Vyberte vybraný typ prvku ze stromu, přetáhněte ji přes na kartu tvarů nebo kartě Konektory, a umístěte jej do tvaru nebo konektorubyste chtěli použít.

Poznámka

Můžete si ověřit, sdružení, které jste vytvořili výběrem komponent nebo kartu připojení v okně vzorníku, které ukazují aktuálně spojené prvky.

Chcete-li přidat nové tvary diagramů / knihovny

1. Vytvořte diagram aplikace Visio MS s tvary, které chcete přidat do diagramu a importovat schéma MS Visio .

Tip

Je důležité, jakou velikost stránky jak hlavní tvar MS Visio, protože ABACUS plátno je dimenzován v pixelech a pouze jednotky Milimetry v MS Visio převést granularly do pixelů na 4 pixely 1 milimetr poměru. Kromě toho, výchozí Abacus tvary jsou typicky 60 pixelů vysoká, takže se promítá do 15 milimetrů v MS Visio. Považované za vhodné mistr velikost tvar MS Visioje 25mm široký a 15 mm vysokéjak to bude překládat do 100 pixelů a výškou 60 pixelů v ABACUS.

Tip

Chcete-li mít "ikonu" trochu v levém horním rohu tvaru, pak můžete jednoduše vytvořit "ikonu" v hlavním tvaru MS Visio pomocí palety MS Visio Drawing Tool (Všimněte si, že pouze jednoduché linky, kruhy a obdélníky jsou podporovány a rastrovat / bitmapové tvary zejména nejsou podporovány). Navíc, pokud chcete, aby ikona být pevná ve velikosti / měřítkuve tvaru v ABACUS pak můžete seskupit "ikona" v hlavním MS Visio tvaru výběrem všechny její prvky, klepnutím pravým tlačítkem myši jeden prvek, výběr Tvar | Skupina, klepněte pravým tlačítkem myši na seskupené tvar a výběr dat | Tvar data ..., vyberete Ano v dialogovém okně, které se objeví, a pak se přidá vlastnost se štítkem nastaveným na LockScale(všimněte si velké písmeno "L" a "S"), typ nastavit na Boolean a hodnota nastaven na PRAVDA (všimněte si, že je vše v velkými písmeny).

Tip

Chcete-li mít část tvaru zmrazené od měřítka vodorovně nebo svisle (jak je typický s 'swimlane "tvar), pak můžete kliknout pravým tlačítkem myši na část (y) z obrazce MS Visio, které chcete zmrazený od měřítka a vyberte data | Tvar data ..., vyberete Ano v dialogovém okně, které se objeví, a pak se přidá vlastnost se štítkem nastaveným na LockXScale nebo LockYScale (všimněte si velké písmeno "L" a "S"), typ nastavit na Boolean a hodnota nastaven na PRAVDA (všimněte si, že je vše v velkými písmeny), za zamčené vodorovné nebo svislé měřítko, resp.

Tip

Aby bylo možné zbarvení tvaru v ABACUS po importu spíše než tvar vždy být pevná barva, je vhodné, aby se výplň master MS Visio obrazec průhledný a pak použít vestavěný schopnosti v ABACUS na barvu pozadí obrazce. To pracuje pouze s obdélníku nebo blízko-obdélníku (např zaoblený obdélník) tvarů, jako celá obdélníkové pozadí budou zbarveny.

2. Otevřete odpovídající schéma a vyberte Záložka Komponentyv okně vzorníku.

3. Pro každý nový tvar, který chcete zpřístupnit ostatním diagramy Klikněte pravým tlačítkem myšitvar a zvolte Přidat do Tvary knihovny, To umožní, aby tvar k dispozici na kartě tvary v okně vzorníku.

4. Přidružit příslušný typu konstrukční části s novým tvarem z knihovny tvarech dle výše popsaných kroků.

Poznámka

Pouze jednoduchý a "vektorový" tvary jsou podporovány v ABACUS v okamžiku, tj rastry nejsou podporovány. Nicméně, nástroje jako Vector magie ( www.vectormagic.com ), Jsou k dispozici, které budou snadno převádět rastrových obrázků do tvarů na bázi vektorů (tj formátu SVG), které lze otevřít v programu MS Visio, a proto využívaných v ABACUS dle výše uvedených pokynů.

PřidáníKomponenty a připojení

Nástroje pro kreslení umožňuje přidat existující komponenty a připojení z úložiště nebo vytvářet nové komponenty a připojení, jak jste výkresu diagramu. Jako komponenty a spoje jsou vytvořeny v diagramech, jsou současně přidány do sklad, Tady jsou Tři doporučené způsoby přidávání složek do diagramua tři doporučené způsoby přidávání připojení ke schématu:

Chcete-li vytvořit úplně novou složku nebo připojení na diagramuz šablony

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Vyberte Komponenty nebo PřipojeníKarta v okně vzorníku vidět související tvary. Pouze tyto tvary mohou být použity k vytvoření nové prvky modelu.

3. Klepněte na tlačítko a přetáhnětejednou z dostupných souvisejících tvarů na kreslicí plátno. Novým prvkem se objeví na plátně, a ve stromu explorer.

4. Začněte psátnázev pro nový prvek v dialogovém okně a všechny existující prvky, které jsou přizpůsobeny jsou navrženy a mohou být zvoleny, spíše než přidat nový prvek do architektury.

5. Klepněte na tlačítko Dobře.

6. Byl-li tvar klesla na existující komponenty, pak to bude buď stane dítětem, že komponenta (v případě, že tvar přišel z Komponentykarta), nebo bude připojena k této komponentě (pokud tvar přišel z Připojeníkarta).

Poznámka

Někdy je nutné nastavit nové komponenty nebo připojení na jiné místo v architektonickém hierarchii pomocí průzkumníka.

Chcete-li umístit existující složku nebo připojení ze sklad na diagramu

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Ujistěte se, že máte oba nástroje pro kreslení a Windows Explorer zobrazit.

3. V Průzkumníku, vyhledejte komponent nebo spojení(element) byste chtěli přidat do diagramu.

4. Klepněte na tlačítko a přetáhnětezvolený element na diagramu. Tvar zastupující prvek objeví na plátně.

Poznámka

Pokud je typ zvoleného prvku je již spojen s tvarem, objeví se na plátně odpovídající tvar. Pokud však není definována asociace pro daný prvek, zobrazí se na plátně ledaže A výchozí tvar (obdélník) Vynutit diagram Úhly pohledu možnost je v tomto případě je tvar nebude přidána do diagramu.

Tip

Když je součást umístěná na diagram, který je připojen k jiné součásti již na diagramu, bude Průvlak dotaz, pokud si přejete ukazují připojení (y) mezi nimi. Také, pokud existují nějaké děti složky nástroje pro kreslení bude dotaz, zda byste chtěli zahrnout děti, v rekurzivní způsobem.

Na vytvořit spojení mezi 2 složek nebo připojeného zařízení na diagramu pomocí dynamického konektor

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Vznášet se přes komponentu na schématu, které chcete připojit k jiné součásti a uvidíte 2 ikony mimo pravé horní hranice tvaru, jak je uvedeno níže. Poznámka: Horní Ikona je pro vytvoření spojení, kde se pohybovala složka má být zdrojem, ikona dno je pro vytvoření spojení, kde se pohybovala složka má být dřez.

3. Hýbat se kurzor na požadovanou ikonu a klepněte a přetáhněteikona na více než jeden přes další složka nebo volného místa na plátně, jak je uvedeno níže.

4. Chcete-li se připojit k existující komponentě vybrat Připojit k ...položka v pop-up menu a v případě potřeby přejděte do podnabídky vyberte z dostupných typů připojení.

- nebo -

4. Chcete-li vytvořit připojený komponent vybral od Nový...položky v rozbalovací nabídce a v případě potřeby přejděte do podnabídky vybrat z dostupných typů připojení, jak je uvedeno níže. Začněte psátnázev pro nový prvek v dialogovém okně a všechny existující prvky, které jsou přizpůsobeny jsou navrženy a mohou být zvoleny, spíše než přidat nový prvek do architektury.

Poznámka

Dostupnost položek v menu pop-up a sub-menu je řízeno omezení v meta-model.To je pouze platný zdroj nebo potopit typy komponent jak bylo stanoveno omezení připojení budou prezentovány jako Připojit k ... a položky Nový ... menu.

Na re-otevřete dialogové okno pro výběr prvku a umístit existující komponenty nebo připojení z úložiště na diagram

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Klepněte na tlačítko Otevřené výběrové ElementTlačítko v panelu nástrojů diagramu. Poznámka: dialog pro výběr element se otevře s posledním stavem jakýchkoliv filtrů uložených.

3. Vyberte si jakékoliv další obsah, který je žádoucí, aby být přidány do schématu a klikněte na tlačítko Dobře, Poznámka: Nový obsah bude přidána do volného prostoru na plátně a diagram může být dodatečně stanoveno znovu přes Layout DiagramTlačítko v panelu nástrojů diagramu.

Použití zdarmaformulářTvary

Často je žádoucí vytvořit vizuální prvky v diagramu z čistě estetických důvodů. Tyto prvky mohou pomoci zlepšit uspořádání a vzhledu diagramu, přesto nemají striktní architektonický význam. Nástroje pro kreslení umožňuje použití volných tvarů poskytovat kreslení flexibilitu.

Chcete-li přidat volného tvaru tvar diagramu

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Vyberte Tvary nebo KonektoryKarta v okně vzorníku.

3. Klepněte na tlačítko a přetáhnětejeden z dostupných tvarů nebo konektory na kreslicí plátno. Novým prvkem se objeví na plátně - ale neve stromu explorer.

Poznámka

Volné tvary jsou "non-spojený 'tvary, protože nemají žádnou spojitost s konkrétní součásti nebo připojení do architektonického modelu.

Na zobrazí úložiště informací v netradiční tvarsynschéma

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Klikněte pravým tlačítkem myšikreslení od ruky tvar a zvolte Anotace | Zobrazit.

3. Zvolit zobrazení buď Diagram Jméno, Diagram Popis, Diagram Property, Viewpoint Jméno nebo Architektura Jméno.

Poznámka

Text v FreeForm se automaticky aktualizuje jako podkladové úložiště datových změn.Tímto způsobem lze vytvořit schéma 'title block "pro, a pak snadno kopírovat mezi, diagramy.

Použití Plovoucí tvarů

Plovoucí tvary jsou v podstatě dalším způsobem, jak představují komponenty v diagramu. Zvažte organizaci s klíčovými divizí: generální ředitel, marketing, prodej a rozvoj.

Zobrazení stromu

Tyto mezistěny mohou být vizuálně zastoupen ve vrstvené způsobem:

Layered View

Nebo mohou být vizuálně zastoupeny v střídavě / plovoucí způsobem ukázat hierarchii:

Potácel / Plovoucí Pohled

Ten reprezentace používá koncept plovoucích tvarů.

Chcete-li převést vrstveného tvar komponentu do plovoucí tvaru

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Vyberte komponentv diagramu chcete reprezentovat jako plovoucí tvar nebo přidružené kondici ve KomponentyZáložka okně vzorníku chcete, aby všechny instance jako plovoucí tvarů.

3. Klepněte pravým tlačítkem myši na tvar a vyberte Float Component z kontextového menu, které se objeví. Všimněte si, že diamant v čele připojeníz nadřazené složky (složek) na plovoucí složky (složek).

4. Klepněte na tlačítko a přetáhnětesložka na požadované místo. Když se plovoucíkomponenta je vybrána bude mít modrý obrys.

Chcete-li převést plovoucí tvar komponentu do vrstvené tvaru

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Vyberte komponentv diagramu, který je v současné době znázorněn jako plovoucí tvar nebo přidružené tvaru ve KomponentyZáložka okně vzorníku, kterou chcete všechny instance jako vrstvené tvary.

3. Klepněte na tlačítko a přetáhněteplovoucí složka (y) zpět na rodiče (s) (v závislosti na diamant v čele připojení). Poznámka: Pokud nemáte to pak při převodu komponentu (y) zpět k bytí vrstvené by mohla být ovlivněna hierarchie modelu.

4. Klepněte pravým tlačítkem myši na tvar a zrušte Float Component z kontextového menu, které se objeví. Všimněte si, že diamant v čele připojeníod mateřské složka (y), na plovoucí složky (složek) zmizí.

Repliky

Nástroje pro kreslení umožňuje přidat stejný komponentu do diagramu několikrát s každou další vizuální instance složky na diagramu uvedeného jako replika. To je užitečné zejména pro diagramy, kdy se složka má velký počet připojení k ní připojených, a je výhodné, aby ukazují komponentu v různých místech blíže k původu každého připojení, nebo pro diagramy, kde vztah one-to-many konstrukční části, je vhodnější pro zobrazení pomocí plovoucí funkce (popsaného výše), s komponentou ve více místech na horní straně "mnoha" složky je v souvislosti s.

Poznámka

Je možné připojit / odpojit připojení do / z původní instance složky na diagramu (jako vždy), ale také na kteroukoli z replik, nicméně, když se spojení automaticky přidány do diagramu jsou připojeny k první instanci součásti na obrázku ve výchozím nastavení.

Poznámka

Repliky mohou být sloučeny s navzájem Klepněte pravým tlačítkem myši a přetáhnětepoté výběrem Sloučit replikyNicméně, sloučení repliku s jinou složkou bude mít za následek žádné další repliky mizí z diagramu.

Poznámka

Neexistuje žádný vizuální rozdíl mezi původní instanci součásti na diagramu a všechny repliky. Kromě toho, klepněte pravým tlačítkem myši menu pro původní složku na diagramu a jakékoli replik je shodný, například s Zobrazit v Průzkumníkukterá vás do stejné složky v zobrazení stromu úložiště (aka modelu). Nicméně, pravým tlačítkem myši na složku v zobrazení stromu úložiště a výběru Jíta prohlížení diagramu s replikami bude vždy se dostanete na "nejstarší" instanci součásti na diagramu. Obvykle to bude originální instance, která byla přidána do schématu, ale v případě, že původní instance byla následně odstraněna nebo se spojil s replikou pak jít do skočí na nejstarší ze zbývajících replik, které byly přidány.

Na Přidání repliky do A diagram

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Klepněte pravým tlačítkem na existující komponenty v diagramu a vyberte Vytvořit repliku.Replika zvoleného komponentu bude vytvořen na pravé straně původní složka.

- NEBO -

Vyberte existující komponentu na diagramu a stiskněte Ctrl + Cnebo pravým tlačítkem myši na existující komponenty v diagramu a vyberte Kopie, Nyní klikněte pravým tlačítkem myši na místo na schématu, které chcete repliky a vyberte Vložit jako Replica, Poznámka: Stisknutím Ctrl + V (nebo klepnutím pravým tlačítkem myši a vyberete Vložit) vytvoří kopii původního dílu ne replika.

- NEBO -

Klepněte na tlačítko a přetáhnětesložku ze stromu Pohled na úložiště (aka modelu) na grafu, kde je složka již existuje.

Konfigurace Connection Čepice / Končí

Nástroje pro kreslení umožňuje nastavit užít značka na koncích připojovacích potrubí buď na pevné symbol nebo symbol v závislosti na vlastnosti na spojení samotné.To je zvláště užitečné pro diagramy, kde je požadováno směr připojení, které mají být zobrazeny, nebo pro diagramy, kde mohutnost připojení (nebo směr) je obsažena v majetku na samotné připojení, např "One-to-Many" vs. "Many-to-Many" (nebo "Source potopit" vs "propadem na zdroj").

Na Konfigurace připojení čepice / končí schéma

1. Ujistěte se, že máte nové nebo existující diagram open.

2. Vyberte PřipojitiontyKarta v okně vzorníku.

3. Pravým-clízat jeden z spojené typy připojení a vyberte Konfigurovat Čepice ....

4. Pro pevné připojení CAP / konci buď na zdroj nebo potopit konec připojení ujistěte se, že příslušné Pevná je vybrán přepínač a vyberte symbol ukončení připojení z pull down, např "Arrow Head" nebo "Diamond".

- NEBO -

U nemovitostí založené na spojení CAP / konci buď na zdroj nebo potopit konec připojení ujistěte se, že příslušné Použití vlastnostje vybrán přepínač, poté klikněte na tlačítko "..." a vyberte požadovanou vlastnost a pak se vedle každého symbolu koncovým připojovacím zadejte majetkové hodnoty, pro které mají specifický symbol spojení, které mají být zobrazeny.

Poznámka

Více majetkové hodnoty pro dané připojení koncového symbolu lze zadat oddělené čárkami. Např. Níže dialog ukazuje, že pokud "údaje | Mohutnost 'nemovitost má hodnotu "One-to-Many" pak zdroj konec spojení bude mít dvě linky tahy přes to a konec umyvadla připojení bude mít jednu linku mrtvici přes to, a pak fan-out dvou linka tahy na konci.

Konfigurace Caps dialog

Viz také

Nástroje pro kreslení | Naplnění vaší architektury | Analýza Vaše architektura


Manipulace Diagramy

Navigace: Naplnění vaší architektury> Použití výkresů>

Manipulace Diagramy

Odeslat připomínky na toto téma.

Jakmile je diagram byl vytvořen, prvky, které se objevují v něm může být přepracován a re-sized jak je požadováno.

Chcete-li přesunout komponentu v diagramu

1. Ujistěte se, že máte existující diagram open .

2. Klepněte na tlačítko a držtejakákoli složka se pohybovat. Pokud vybraná složka má rodiče, bude mateřská komponenta se zvýrazní.

3. Vzhledem k tomu, element jevlekl od své mateřské komponenty, a nad ostatními složkami, "potenciální" rodiče se zvýrazní. Barevné schéma používané udává efekt operace bude mít na varování a chyb s aktuální projekt a je popsán v Definování a ověřování Omezení , Tímto způsobem můžete graficky procházet hierarchii z "půdorysu".

4. Uvolněnítlačítko myši k poklesu prvek v jeho novém umístění.

Poznámka

Můžete také použít klávesnici znovu polohy prvků na kreslicí plátno. Jednoduše vyberte požadované zařízení nebo volné formě tvar, který chcete přesunout, a pomocí šipek umístěných na klávesnici pro pohyb tvar na požadované místo.

Také si všimněte, že při přetahování komponentu s myší nad jiné součásti, "potenciální" mateřským složka je zvýrazněn, když je levý horní roh komponenty přetahujete překrývá další součást.

Tip

Volné a Plovoucí tvary lze objednat klepnutí pravým tlačítkem myšia výběru Přenést do popředí nebo Přenést dozaduz menu. Je důležité poznamenat, že tvary součásti mohou být konvertovány na volné formy tvarů klepnutí pravým tlačítkem myšiNa specifického tvaru komponent a volbou Převést na FreeForm.

Chcete-li změnit velikost komponenty v diagramu

1. Ujistěte se, že máte existující diagram open .

2. Click-hold-táhnoutjeden z držadel této komponenty a velikost tvar na požadovanou velikost.

3. Alternativně pro zachování poměru stran obrazce, sešlápněte SHIFT + kliknutí-držení-drag.

Chcete-li přesunout připojení v diagramu

1. Ujistěte se, že máte existující diagram open .

2. Klepněte na tlačítko a držtejakékoliv spojení se pohybovat.

3. Uvolněnítlačítko myši k poklesu prvek v jeho novém umístění.

Poznámka

Můžete se pohybovat pouze připojení, které nejsou připojeny k libovolné součásti. Pokud jsou připojeny, můžete přesunout pouze na volný konecs, nebo přesměrovávají připojení .

Odstranění komponenty a připojení

Při mazání součást nebo spojení z diagramu, máte možnost jej odstranit z celé architektury. Každá součást, která je odstraněn z architektury budou automaticky odstraněny z jakýchkoli jiných diagramů, kde se objeví. Vzhledem k tomu, freeform instance se pouze v jednom grafu, mazat neovlivňuje architektonický model, nebo jakékoliv jiné schéma.

Chcete-li odstranit složku nebo připojení ze diagramu

1. Ujistěte se, že máte existující diagram open .

2. Klepněte na tlačítkoNa každém souvisejícím připojení nebo součásti, vyberte jej.

3. Stiskněte tlačítko VymazatKlíčem k jeho odstranění z grafu, nebo Shift + Deleteodstranit z celého modelu.

- nebo -

2. Klepněte pravým tlačítkem myši na libovolný prvek nebo přidružené součásti. Objeví se kontextové menu.

3. Vybrat Odstranit z pohledu nebo Odstranit z Architekturaz kontextové nabídky.

Poznámka

V případě, že prvek, který chcete odstranit z pohledu nemá žádné děti a dochází pouze v tomto pohledu, ABACUS se zeptá, zda chcete odstranit prvek z úložiště stejně.

Pozor

Při odstranění komponenty z modelu, který má podřízené složky, děti budou také potenciálně vymazán podle dialogu varování.

Sloučení Components

Možná budete chtít sloučit dvě složky existující na stejném diagramu (a v rámci architektury), To může být provedeno z mnoha důvodů, například, Dva servery existuje v rámci firemního Infrastruktura: H01 a H02. Tyto dva servery jsou reprezentovány jako dvě samostatné součásti v rámci architektury. H01 byl považovány za zbytečné, a proto má být vyřazena z provozu. Všechny stávající aplikace běžící na H01 se mají převést na H02 (ještě v pověření). Tato změna může být potom odráží působením "spojujících" dvou složek H01 a H02 v diagramu (a v rámci architektury).

Pro podrobnější diskusi o slučování naleznete fúzujících tématu položky zde .

Chcete-li sloučit dvě existující komponenty

1. Ujistěte se, že máte existující diagram open .

2. Klepněte pravým tlačítkem myši, držetna komponentu, kterou chcete sloučit a táhnoutto na komponentu chcete sloučit s. Ujistěte se, že obrys cílové složky je zvýrazněna červeně, což znamená, že je vybrána.

3. Vybrat Sloučit | Zachovat Cíl nebo Přepsat Destinationz menu.

Poznámka

Zachovat Cílmetoda zachovává hodnoty vlastností cílového komponenty v případě, že existují na zařízení pro původní stejně.

Přepsat Destinationmožnost přepíše vlastnosti cílového komponenty s jakýmikoli společných vlastností ze zařízení původu.

Změna připojení

Připojení znázorněná v diagramu vždyodrážejí strukturu, jak je definována v architektuře samotné. Kreslení nástroj umožňuje odpojit připojení z komponent, přesunout, křivka je, re-cesta je a re-připojit je k ostatních složek.

Chcete-li odpojit / připojit spojení z / do komponenty

1. Ujistěte se, že máte existující diagram open .

2. Klepněte na tlačítko a držtena libovolném připojení.

3. Vybratpřipojení konec (tj. Source nebo Sink), Který byste chtěli odpojit / připojit. Poznámka: konce připojení jsou označeny s malými bílými kruhy a vznášející se nad bílým kruhem na vteřinu způsobí 'tooltip "se zobrazí s příslušnou role jméno(tj. buď Source nebo Sink).

4. Táhnoutpřipojení konec do nového umístění (buď prázdné místo nebo složku) a uvolněte tlačítko myši.

Poznámka

Je-li konec spojení umístěn nad platnou složky, obrys cílové složky je zvýrazněn přerušovanou obrysem. Barevné schéma používané udává efekt operace bude mít na varování a chyb s aktuální projekt a je popsán v Definování a ověřování Omezení , Jednou povolený že konec the připojení a složka jsou automaticky spojeny(nebo v příloze), A to se odráží v architektonickém modelu.

Chcete-li přesměrovat připojení

1. Ujistěte se, že máte existující diagram open .

2. Umístěte ukazatel myši nad připojení.

3. Držte Posunklávesa dolů a Klepněte na tlačítkotlačítka myši umístit spojení kotevní bod. Uvolněte Posun klíč. Můžete odstranit kotevní bod, tím, že dělá stejnou operaci.

4. Click-a-táhnoutkotevní bod přesměrovat připojení.

Tip

PoužitíAlt key namísto PosunKlíčem k vytvoření ortogonální připojení.

Na Křivka nebo narovnatpřipojení

1. Ujistěte se, že máte existující diagram open .

2. Umístěte ukazatel myši nad připojení.

3. Klikněte pravým tlačítkem myšiTon připojení a v kontextovém menu, které se objeví vyberte Křivka, Ortogonální nebo Rovně.

Tip

Všechny přípojkydaného typu na obrázku lze nastavit na zakřivené, ortogonální nebo Straight klepnutím pravým tlačítkem myši na přidružený linku pro typ na straně Karta Připojeníz Okně vzorníkua výběru Curve, ortogonální nebo Straight.

Na zakotvit na konkrétní bod na okraji tvaru

1. Ujistěte se, že máte existující diagram open .

2. Vyberte připojení.

3. Umístěte ukazatel myši "Bílé dot 'na konci připojení.

4. Klikněte pravým tlačítkem myšiTže spojení konec a v kontextovém menu, které se objeví vyberte Ukotvují koncový bod na tvar.Přemístění konce připojení do žádané lokalitě na okraji tvaru.

NEBO

Držte Ctrlklávesa dolů a clízat-a-táhnout konec spojení ukázat na touha umístění na okraji tvaru.

Poznámka

Připojení se přichytí do ohraničovacího rámečku tohoto tvaru skutečného průsečíku jejich připojeného tvaru místo.

Viz také

Nástroje pro kreslení | Naplnění vaší architektury | Analýza Vaše architektura


Kreslení Funkce Tool

Navigace: Naplnění vaší architektury> Použití výkresů>

Kreslení Funkce Tool

Odeslat připomínky na toto téma.

Nástroje pro kreslení podporuje řadu funkcí pro kreslení.

Zvětšení

Měřítko diagramu lze změnit pomocí funkce zoom.

Chcete-li zmenšit měřítko nebo "přiblížení"

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Press Ctrla "=" klíč.

- nebo -

2. Vyberte PřiblížitTlačítko na Diagram Panel nástrojů.

- nebo -

2. Press Ctrla otáčením kolečka myši vpřed, Poznámka: V tomto režimu se plátno přiblíží k místu, kde je myš umístěna nad plátnem.

Chcete-li zvýšit měřítko nebo "oddálit"

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Press Ctrla "-" klíč.

- nebo -

2. Vyberte OddálitTlačítko na Diagram Panel nástrojů.

- nebo -

2. Press Ctrla otáčením kolečka myši zaostalý, Poznámka: V tomto režimu se plátno přiblíží ven z místa, kde je myš umístěna nad plátnem.

Auto-layout

Uspořádání složek v diagramu lze upravit automaticky.

Chcete-li rozvržení vše komponenty on schéma

1. Clízat Layout DiagramTlačítko na panelu nástrojů Diagram.

2. Vybratbuď Radiální Layout nebo Layout Grid.

Poznámka

Rozložení Radial bude používat to, co se nazývá "vyšší-režie", algoritmus tak, že připojená zařízení jsou sestaveny dohromady, zatímco nesouvisející komponenty jsou nuceni od sebe. Rozložení Grid bude použít pevnou šířku a výšku řádkování algoritmus. To za prvé umožňuje uživateli zvolit celkové schéma poměr stran (například 16: 9, A4 (výšku), Letter (šířku)), a pak je vzdálenost po stranách a mezi sloupců a řádků, jak je uvedeno níže.S mřížkou rozvržení případné spojení mezi složkami nemají vliv na rozložení, jak to prostě uspořádá komponenty abecedně (podle názvu) shora-vlevo na dolním rohu plátna. S oběma algoritmy volných tvarů nejsou přesunuty.

Chcete-li rozvržení děti komponenty v jedné mateřské On schéma

1. Klikněte pravým tlačítkem myšisoučástka na vysoké úrovni, jejichž děti si přejete automatické rozložení.

2. Vybrat Rozvržení Děti.

Poznámka

Ve výchozím nastavení se používá pouze rozvržení algoritmus Radial.

Změna prvku Estetika jako Barva, Transparentnost, Stíny a rotace

Všechny prvky mají estetiku diagram, který může být manipulována, jak je požadováno. V případě přidružených tvarů, tyto aspekty mohou být nastaveny podle typua ve většině případů i každou instanci, V případě volných tvarů, tyto vlastnosti mohou být nastaveny každou instancina plátně.

Poznámka

Jakékoliv za aspektů, například, které byly stanoveny pro přidružené tvary budou "přepsány" pokud je stejný poměr se změní pro příslušný typ.

Chcete-li změnit barvu přidruženého tvaru nebo od ruky tvar

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo netradiční tvar na plátně.

3. Vybrat Change Color.

4. Vyberte Pevné Barvapřepínač (v případě potřeby).

5. Vyberte si Základní Barva nebo definovat vlastní Barva v dialogovém okně a klepněte na tlačítko Dobře.

- nebo -

4. Vyberte Gradientpřepínač (v případě potřeby).

5. Vyberte si buď horizontální, vertikální, vpřed nebo vzad Diagonal Diagonal k přechodu směru v rozbalovací a klikněte na tlačítko Dobře.

6. Vyberte si Základní Barva nebo definovat vlastní Barva v dialogu pro Start a Koneca klepněte na tlačítko Dobře.

Poznámka

ABACUS bude barva popředí tvaru, pokud;
a) se jedná o "jednoduché" tvar s jedním základním grafickém prvku (např kruh, obdélník, mnohoúhelník atd), nebo
b) se jedná o "komplexní" tvar s více podkladových subshapes, které jsou všechny stejné barvy / sklon jako navzájem nebo subshapes mají LockScale = TRUE set.
Pokud výše uvedené podmínky nejsou splněny, pak pozadí tvaru je zbarven.

Chcete-li nastavit barvu přidruženého tvaru podle nemovitosti

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku(NE na kreslicí plátno).

3. Vybrat Change Color.

4. Vyberte Použití vlastnostpřepínač.

5. Vyberte vlastnost kliknutím na tlačítko "..." napravo od textového pole.

6. Vyberte Rozsah přepínač.

7. Nastavte Min a Maxhodnoty, jak je požadováno. Poznámka: jakákoli hodnota nižší než minimální hodnota se zobrazí jako barva Min a libovolná hodnota vyšší než maximální se zobrazí jako Max barvu. Také při použití Boolean, Seznam nebo Datum / Čas vlastnosti hodnoty jsou převedeny na index takto; Boolean (False = 0, True = 1), seznam (celé číslo vale 1 až N pro každý platnou hodnotu ve svém vzestupném pořadí uvedeném v poli Units) a / času (počet dní od 1. ledna 1900 Datum - včetně desetinných míst hodiny, minuty, sekundy části - a pokud je datum pre-1990 je záporné číslo).

8. Vyberte si Základní Barva nebo definovat vlastní Barva v dialogu pro Min a Maxa klepněte na tlačítko Dobře.

Tip

Li Zelená (RGB - 128,255,0) je vybrán jako barvu Min a Červený (RGB - 255,0,0) je vybrán jako Max barva pro vlastnost s hodnotou rozsahem 1 na 4pak hodnota 1se zobrazí jako Zelená, Hodnota 2 jako Žlutá, 3 jako Pomerančový a 4 jako Červený.

Alternativně, pro řadu vlastností 1 na 3Hodnota 1bude as Zelená, Hodnota 2 jako Jantar a 3 jako Červenýaka "Dopravní Lights" nebo stav RAG.

Pro rozsah vlastností od 1 do 5, pokud Modrý (RGB - 0,0,255) je vybrán jako barvu Min a Červený (RGB - 255,0,0) je vybrán jako Max barvy hodnota 1 bude as Modrý, Hodnota 2 as Aqua, Hodnota 3 as Zelená, Hodnota 4, as Žlutá a hodnota 5 as Červený.

Pro rozsah vlastností od 1 do 6, pokud Fialový (RGB - 255,0,255) je vybrán jako barvu Min a Červený (RGB - 255,0,0) je vybrán jako Max barvy hodnota 1 bude as Fialový, Hodnota 2 as Modrý, Hodnota 3 as Aqua, Hodnota 4, as Zelená, Hodnota 5 as Žlutá a hodnota 6 as Červený.

A konečně, pro řadu vlastností 1 až 7 hodnota 1 bude as Fialový, Hodnota 2 as Tmavě modrá, Hodnota 3 as Světle modrá, Hodnota 4, as Modrozelená, Hodnota 5 as Zelená, Hodnota 6 as Jantar a hodnotu 7 as Červený

Poznámka

Viz poznámka výše na popředí proti pozadí zbarvení.

- nebo -

7. Vyberte Konkrétní hodnotypřepínač.

8. Klepněte na tlačítko Upravit barvy tlačítko.

9. Vyberte každou hodnotu v pořadí a klepněte na tlačítko Set Colournastavit konkrétní barvy pro každou hodnotu.

Poznámka

Rozsah hodnot pro prvků přítomných v diagramu budou předběžně naplněna.

10. Chcete-li přidat další barvy hodnotu těm, kteří pre-obydlený (například po rozsah majetek byl překonfigurována) Klepněte na tlačítko Přidat hodnotu.

Chcete-li změnit průhlednost barev přidružené tvaru nebo od ruky tvar

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo netradiční tvar na plátně.

3. Vybrat Change Color.

4. V panelu Průhlednost nastavit horní posuvník na požadovanou transparentnost pro základní barvy.

5. V případě, že Gradient nebo Používání možností vlastnictví jsou používány, v panelu Průhlednost nastavte spodní posuvník na požadovanou transparentnost pro druhou barvou.

6. Klepněte na tlačítko Dobře.

Ukázat stíny pro všechny spojená tvary v diagramu

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v KomponentyZáložka okně vzorníku.

3. Vybrat Přidat Stíny.

Na vykazují stín na tvar součást nebo netradiční tvar

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Právo-Clickna konstrukční části nebo volných tvarů na plátně.

3. Vybrat Přidat Stíny.

Chcete-li otočit tvary součásti a volné tvary podobě, v diagramech

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Vyberte tvar konstrukční části nebo netradiční tvar na plátno, kterou chcete otočit.

3. Klikněte pravým tlačítkem myšio tvaru a vyberte Střídata pak vyberte příslušnou úhel, který chcete otočit tvar pomocí.

Měnící se Element Anotace a Volné textové popisky

Všechny prvky mají diagram anotace která může být manipulována, jak je požadováno. V případě přidružených tvarů, tyto aspekty mohou být nastaveny podle typua ve většině případů i každou instanci, V případě volných tvarůa konektorySetextové popisky může být nastaveno každou instancina plátně.Osm (8) různé typy anotací mohou být zobrazeny na diagram prvky (jméno, typ, Vlastnost Hodnota, Nemovitosti Marker, stavební díly, Děti (pouze pro komponenty), normy a časových razítek (Vytvořeno, upravený atd)) ve dvacet pět (25) různé polohy (např Centre - Mimo Top, Inside vlevo - centrum, pravé vnější - vnější straně dna).

Poznámka

Jakékoliv za aspektů, například, které byly stanoveny pro přidružené tvary budou "přepsány" pokud je stejný poměr se změní pro příslušný typ.Kromě toho, pokud 2 nebo více anotace na stejné pozici pouze jediná písma, styl písma, barvu písma a velikost může být použit a oddělovač (např čárka, mezera, nový řádek) musí být vybrán.

Ukázat název nebo typ pro přidruženou komponentu nebo připojení

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo konektor na plátně.

3. Vybrat Anotace.

Poznámka

Pro individuální spojená tvaru nebo konektoru na plátně, budete muset vybrat Přepsat Stencil anotacepolíčko poprvé.

4. Vyberte nové anotace v panelu nástrojů a vyberte Jméno nebo Typ.

5. V dialogovém okně, které se objeví vyberte možnosti zobrazení, které jsou žádoucí, včetně držáků a styl písma, písma, barvu písma a velikost. Také, vyberte možnosti rozvržení, které jsou žádoucí, včetně vodorovného a svislého nastavení (tj poloha anotace) a úhlu (tj rotace). Vybrat Dobře.

Chcete-li zobrazit nemovitosti hodnota pro přidruženou komponentu nebo připojení

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo konektor na plátně.

3. Vybrat Anotace.

Poznámka

Pro individuální spojená tvaru nebo konektoru na plátně, budete muset vybrat Přepsat Stencil anotacepolíčko poprvé.

4. Vyberte nové anotace v panelu nástrojů a vyberte Vlastnost Hodnota.

5. V dialogovém okně, které se objeví vyberte vlastnost klepnutím objektu: tlačítko '...' a výběrem vlastnost v dialogovém okně vyberte vlastnosta vyberte Dobře. Vyberte možnosti zobrazení, které jsou žádoucí, včetně držáků a styl písma, písma, barvu písma a velikost. Také, vyberte možnosti rozvržení, které jsou žádoucí, včetně vodorovného a svislého nastavení (tj poloha anotace) a úhlu (tj rotace). Vybrat Dobře.

Chcete-li zobrazit nemovitosti fix pro přidruženou komponentu nebo připojení

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo konektor na plátně.

3. Vybrat Anotace.

Poznámka

Pro individuální spojená tvaru nebo konektoru na plátně, budete muset vybrat Přepsat Stencil anotacepolíčko poprvé.

4. Vyberte nové anotace v panelu nástrojů a vyberte Nemovitosti: Marker.

5. V dialogovém okně, které se objeví vyberte vlastnost klepnutím objektu: tlačítko '...' a výběrem vlastnost v dialogovém okně vyberte vlastnosta vyberte Dobře. Nastavte poloměr značky v obrazových bodech a způsobu barvení na obou barev rozsahem nebo Colour majetkem a nastavit přiřazení barvy. Také, vyberte možnosti rozvržení, které jsou žádoucí, včetně vodorovného a svislého nastavení (tj poloha anotace) a úhlu (tj rotace). Vybrat Dobře.

Ukázat připojené komponenty pro přidruženou komponentu nebo připojení

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo konektor na plátně.

3. Vybrat Anotace.

Poznámka

Pro individuální spojená tvaru nebo konektoru na plátně, budete muset vybrat Přepsat Stencil anotacepolíčko poprvé.

4. Vyberte nové anotace v panelu nástrojů a vyberte Komponenty Přiložené.

5. V dialogovém okně, které se objeví, vyberte pro přidružené komponenty připojené typu konstrukční části klepnutím na tlačítko 'připevněno: ...' a výběr typu konstrukční části v dialogovém okně Set Component Typea vyberte Dobře. Vyberte připojený typ připojení klepnutím na připojený přes: "..." tlačítko a zvolíte typ spojení v dialogovém okně Nastavení typu připojenía vyberte Dobře.Pro spojených připojení vyberte konec připojení výběrem zdroje nebo dřez z Upínání: rozbalovacím menu. Pro obě přidružené komponenty a připojení vybrat možnosti zobrazení, které jsou žádoucí, včetně držáků a styl písma, písma, barvu písma a velikost. Také, vyberte možnosti rozvržení, které jsou žádoucí, včetně vodorovného a svislého nastavení (tj poloha anotace) a úhlu (tj rotace). Vybrat Dobře.

Ukázat děti pro přidružené komponenty

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v KomponentyZáložka okně vzorníku, nebo spojený tvar na plátně.

3. Vybrat Anotace.

Poznámka

Pro individuální přidružené tvaru na plátně, budete muset vybrat Přepsat Stencil anotacepolíčko poprvé.

4. Vyberte nové anotace v panelu nástrojů a vyberte Děti.

5. V dialogovém okně, které se objeví vyberte možnosti zobrazení, které jsou žádoucí, včetně držáků a styl písma, písma, barvu písma a velikost. Také, vyberte možnosti rozvržení, které jsou žádoucí, včetně vodorovného a svislého nastavení (tj poloha anotace) a úhlu (tj rotace). Vybrat Dobře.

Ukázat normy pro přidruženou komponentu nebo připojení

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo konektor na plátně.

3. Vybrat Anotace.

Poznámka

Pro individuální spojená tvaru nebo konektoru na plátně, budete muset vybrat Přepsat Stencil anotacepolíčko poprvé.

4. Vyberte nové anotace v panelu nástrojů a vyberte Normy.

5. V dialogovém okně, které se objeví vyberte možnosti zobrazení, které jsou žádoucí, včetně držáků a styl písma, písma, barvu písma a velikost. Také, vyberte možnosti rozvržení, které jsou žádoucí, včetně vodorovného a svislého nastavení (tj poloha anotace) a úhlu (tj rotace). Vybrat Dobře.

Ukázat časová razítka pro přidruženou komponentu nebo připojení

1. Ujistěte se, že máte existující diagram open .

2. Klikněte pravým tlačítkem myšina přidružené tvaru nebo konektoru v Komponenty nebo PřipojeníZáložka okně vzorníku nebo přidružené tvar nebo konektor na plátně.

3. Vybrat Anotace.

Poznámka

Pro individuální spojená tvaru nebo konektoru na plátně, budete muset vybrat Přepsat Stencil anotacepolíčko poprvé.

4. Vyberte nové anotace v panelu nástrojů a vyberte Vytvořeno, Vytvořeno, Vytvořeno Marker, Modified, upravený nebo modifikované Marker.

5. V dialogovém okně, které se objeví, ne-li značky, vyberte možnosti zobrazení, které jsou žádoucí, včetně držáků a styl písma, písma, barvu písma a velikost. Pokud marker, nastavte poloměr značky v obrazových bodech a způsobu barvení na obou barev rozsahem nebo Colour majetkem a nastavit přiřazení barvy. Také, vyberte možnosti rozvržení, které jsou žádoucí, včetně vodorovného a svislého nastavení (tj poloha anotace) a úhlu (tj rotace). Vybrat Dobře.

Chcete-li změnit styl písma volného tvaru tvarunebo konektor

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Klikněte pravým tlačítkem myšina volného tvaru tvaru nebo konektor na plátně. Poznámka: V případě, že Konektor Text štítku se nevykazují pak ukázat connectnebo text štítku: Klikněte pravým tlačítkem myšiconnectneboa vyberte Anotace | Show Anotace.

3. Vybrat Změnit písmo.

4. Vyberte styl písma, písmo a velikost v dialogovém okně a vyberte Dobře.

Chcete-li změnit písmo barva z volného tvaru tvarnebo konektor

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Klikněte pravým tlačítkem myšina volného tvaru tvaru nebo konektor na plátně. Poznámka: V případě, že Konektor Text štítku se nevykazují pak ukázat connectnebo text štítku: Klikněte pravým tlačítkem myšiconnectneboa vyberte Anotace | Show Anotace.

3. Vybrat Přeměna Písmo Barva.

4. Vyberte písmoColour (a pro tvary Link barva) kliknutím na tlačítko "..." a výběru barvy v dialogovém okně a vyberte Dobře.

5. Vyberte Průhlednost textového popisku úpravou jezdce s 0 je plně transparentní a 255 je plně neprůhledná.

Chcete-li otočit textový popisek o volného tvaru tvarunebo konektor

1. Ujistěte se, že máte nové nebo existující diagram open .

2. Klikněte pravým tlačítkem myšina volného tvaru tvaru nebo konektor na plátně. Poznámka: V případě, že Konektor Text štítku se nevykazují pak ukázat connectnebo text štítku: Klikněte pravým tlačítkem myšiconnectneboa vyberte Anotace | Show Anotace.

3. Vybrat Střídata pak vyberte příslušnou úhlu chcete pro otočení text štítku podle.

Viz také

Nástroje pro kreslení | Naplnění vaší architektury | Analýza Vaše architektura


Pomocí odkazů v diagramech

Navigace: Naplnění vaší architektury> Použití výkresů>

Pomocí odkazů v diagramech

Odeslat připomínky na toto téma.

Tvary (volné formě a symboly) a konektory (volné formě nebo připojení) v diagramech lze propojit s vaší stávající architektonické zastoupení v ABACUS, jakož i externích souborů / složek a adres URL. Tyto odkazy pak mohou být řízeny (vytvořen, upravovat a mazat) přes ABACUS sady nástrojů. Tuto funkci lze použít ke zvýšení navigace a celkové pochopení vaší architektuře schematicky.

Chcete-li přidat odkazy na diagramu

1. Ujistěte se, že máte existující diagram open .

2. Vyberte odpovídající tvar nebo konektor z diagramu.

3. Klikněte pravým tlačítkem myšina tvarunebo konektor.

4. Vybrat Otevřené Odkazya OdkazyZobrazí se okno.

5. Klikněte na PřidatIkona a New LinkZobrazí se okno.

6. Vyberte příslušný Katalog | Matrix | Diagram| 3D zobrazení| Schémapřepínací tlačítka, poté vyberte příslušný katalog, matice, diagram, 3Dnebo graf Pohled v současné architektury z Odkaz nadrop-down menu.

- nebo -

6. Vyberte webová stránkapřepínač poté, zadejte příslušnou adresu URL (např. http: //www.avolutionsoftware.com /)V poli odkaz na webovou stránku. Platné adresy URL je třeba začít s jedním z 5řetězce; http: //, https: //, ftp: //, soubor: nebo \\, Veškeré prostory by měly být zadány s '% 20'.

- nebo -

6. Vyberte Absolutní File | Relativní Souborpřepínačs,pak klikněte na '..."Tlačítka vyhledejte externího souboru odkazy na diagramu.

7. Klepněte na tlačítko Dobřea nový odkaz se zobrazí v okně odkazy. Poznámka: Okno Links může být zvětšena v případě potřeby vidět celé jméno.

8. Opakujte kroky 5-7vytvořit více odkazů.

9. Chcete-li na odkaz vytvořený, vyberte příslušný odkaz zobrazí v Odkazyokno a klepněte na tlačítko Otevřít odkaz.

Poznámka

Kdy více anotace jsou uvedené pro tvar nebo konektor odkaz je uveden na prvním anotaci v seznamu anotací v dialogu Upravit anotace.

Chcete-li sledovat odkazy z diagramu

1. Ujistěte se, že máte existující diagram open .

2. Vyberte odpovídající tvar nebo konektor z diagramu.

3. Klepněte na tlačítkona příslušný hypertextový odkaz (modrý podtržený název komponentu) na tvar nebo konektor v diagramu otevřít a zobrazit první odkaz z tvarunebo konektor.Poznámka: Kurzor by se měl změnit na "ruku", pokud je odkaz je připraven být kliknul.

- nebo -

3. Vyberte odpovídající tvar nebo konektor z diagramu.

4. Klikněte pravým tlačítkem myšina tvarunebo konektor.

5. Vybrat Otevřené Odkazya OdkazyZobrazí se okno.

6. Vyberte příslušný odkaz, který chcete zobrazit.

7. Klikněte na Otevřít odkaztlačítko pro otevření a zobrazení na příslušný odkaz.

Chcete-li odstranit odkazy v diagramu

1. Ujistěte se, že máte existující diagram open .

2. Vyberte odpovídající tvarnebo konektorz diagramu.

3. Klikněte pravým tlačítkem myšina tvarunebo konektor.

4. Vybrat Otevřené Odkazya OdkazyZobrazí se okno.

5. Vyberte příslušného odkazu, který musí být odstraněny.

6. Klikněte na Vymazat tlačítko. a vazba je odstraněn z Odkazy okno.

Pořádání odkazy v diagramu

Můžete si vybrat, které souvisí diagram, externí soubor, nebo webové URL se zobrazí, když tvar etiketa je Ctrl + klepnutí na obrázku.

1. Ujistěte se, že máte existující diagram open .

2. Vyberte odpovídající tvar nebo konektor z diagramu.

3. Klikněte pravým tlačítkem myšina tvarunebo konektor.

4. Vybrat Otevřené Odkazya OdkazyZobrazí se okno.

5. Chcete-li změnit pořadí odkazů klikněte na Přesunout nahoru | Posunout dolůTlačítka na pravé straně Odkazy okno.

6. První odkaz, který se objeví na levé straně OdkazyOkno je odkaz, který se zobrazí, když vás Ctrl + Clickhypertextovými odkazy tvar nebo konektor jméno.

Viz také

Naplnění vaší architektury | Naplnění vaší architektury ručně | Analýza Vaše architektura


Diagram Úhly pohledu

Navigace: Naplnění vaší architektury> Použití výkresů>

Diagram Úhly pohledu

Odeslat připomínky na toto téma.

The názoryfunkce zajišťuje, že složky a spojů, které se přidávají do diagramu, musí mít typ sdružení bylo definováno dříve, než mohou být přidány do diagramu. Tato funkce umožňuje omezení typů grafů, které lze čerpat omezením tvary a konektory, které jsou spojeny s komponentami a PřipojeníStávající přímo ve Vašem architektury.

Povolení nebo zakázání Prosazování diagramu názory

Schopnost prosadit diagram názory je automaticky ve výchozím nastavení povolena. Chcete-li zakázat / povolit tuto funkci, klikněte na Nástroje | Možnosti ...| DiagramKarta a zrušte výběr / výběr Vynutit diagram Úhly pohleduzaškrtnutí políčka podle toho.

Poznámka

Pokud nevidíte "Vynutit diagram Úhly pohledu"Možnost na kartě Diagram pak nemáte Návrhář doplněk a možnost je ve výchozím nastavení.

Vytvoření vykonatelný diagram hledisko

1. Zkontrolujte, zda máte ABACUS soubor otevřené s badatelZobrazí pohled.

2. V zobrazení Průzkumníka klikněte pravým tlačítkem myši na Pohledbodsa klikněte na Vytvořit Diagram Viewpoint

3. Diagram Viewpointse zobrazí okno.

4. Přiřadit odpovídající jméno na diagram hlediskoa vědomí, že hledisko je uložena pod Úhly pohledučást průzkumník.

5. Diagram Viewpointse zobrazí okno.

6. Nyní klepněte a přetáhněte příslušné typy komponent a typy spojení ve vašich architekturách Na tvary Viewpoint chceš. Component typyje třeba přetáhnout tvarv tvaryKarta, zatímco typy připojeníje třeba přetáhnout jeden z tvarů k 5 řádek styluv konektoryTab.

7. Chcete-li uložit diagram hlediskojste vytvořili, klikněte na [image] v pravém horním rohu Diagram Viewpoint okno.

Poznámka

diagram hlediskomohou být editovány kliknutím pravým tlačítkem myši na straně hledisko a výběru Otevřít nebo poklepáním hledisko.

Synchonising aktualizované stanovisko s diagramy

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Buď klepněte pravým tlačítkem na pohled ve Badatel Okno pod Meta-Model | Úhly pohledua vyberte Sync Diagram mapování ...

- nebo -

3. V blízkosti otevřené a aktualizované hledisko okno a zvolte Anov Synchronizace se Viewpointdialog, který se zobrazí.

4. Viewpoint Synchronizacese zobrazí dialogové okno, jak je uvedeno níže.

Checkboxes

· Přidat chybějící mapování- Jakýkoliv nový tvar (typu konstrukční části), nebo konektor (typu připojení), asociací, které byly přidány k pohledubude přidán do Odpovídající diagrams (tj. jejich šablonas) že jsou spojeny s hlediska.

· Aktualizaci existujícíchMapování- Všechny aktualizované aspekty stávajícího tvaru (až typu konstrukční části) nebo konektor (na typu připojení) asociace pro hledisko(např barvy, fonty) budou aktualizovány v Odpovídající diagrams (tj. jejich šablonas) že jsou spojeny s hlediska.

· Odstranit ExtraMapování- Jakékoli další tvar (typu konstrukční části), nebo konektor (typu připojení), asociací, které byly přidány k diagramy (tj jejich šablony), ale nejsou v hlediskobudou odstraněny z Odpovídající diagrams (tj. jejich šablonas) že jsou spojeny s hlediska.

· Přepsat Místní nastavení pro přidány nebo aktualizovány mapování (Differences Only)- Všechny aktualizované aspekty stávajícího tvaru (až typu konstrukční části) nebo konektor (na typu připojení) asociace pro hledisko(např barvy, fonty) se použije na odpovídající prvky na obrázcích, které jsou spojeny s pohledu.Jsou použity pouze aktualizovanou databázi "rozdíly" provedené pohledu, takže všechny existující místní nastavení v diagramu, které nebyly aktualizovány v pohledu zůstane beze změny.

· [image] Anotace – Jak je uvedeno výše, ale speciálně pro poznámky.

Viz také

Nástroje pro kreslení | Naplnění vaší architektury | Analýza Vaše architektura


Naplnění pomocí Katalogy

Navigace: Naplnění vaší architektury>

Naplnění pomocí Katalogy

Odeslat připomínky na toto téma.

A katalog vám umožní prohlížet a upravovat komponenty nebo připojení a jejich vlastnosti jednoduchým způsobem tabulky.

Na vytvořit nový Katalog zobrazit v POČITADLO

Poznámka

Zatímco všichni uživatelé architekt může vytvořit nové Katalogy, uložit změny nastavení existujícího Katalog je uživatelská licence potřebuje Designer add-on schopnosti. To je "chránit" konfiguraci stávajících katalogů, které mohou být sdíleny mnoho uživatelů. Nicméně, Architekt používá bez Návrhář doplněk může ještě zvolit "Uložit jako" každé nové nastavení do nového katalogu. A samozřejmě všechny licence Uživatel si může vybrat "zbavit se" případných změn stávajícího katalogu. Obraťte se na místního správce ABACUS nebo Podpora Avolution pokud vyžadujete Návrhář doplněk schopnost. A pamatujte si, to je jen nastavení katalogu, všechny úpravy provedené na základě údajů v katalogu jsou okamžitě aplikovány na úložiště, bez ohledu na to.

1. Vyberte Vložit | Katalog.

2. V pull-down vyberte architekturu, která obsahuje komponenty nebospoje, kterou chcete zobrazit.

3. V pull-down vyberte komponentu nebo typ připojení že si přejete, aby byly případy, uveden jako "řádky' v katalogu.

4. katalog se vyplní sřádek pro každou instanci vybraného zařízení nebo typu připojení.

Poznámka

Ve výchozím nastavení je nejvíce vlevo Hierarchie Pathsloupec (tj hierarchii mateřských komponent nebo spojení výše uvedených vybraných případech) a 2. Jméno sloupec (tj seznamu vybraného zařízení nebo připojení instance), jsou zmrazeny na levé straně katalogu. Chcete-li změnit sloupec zmrazení přetáhněte oddělovač sloupce napravo od názvu sloupce. Můžeš re-pořadísloupce jednoduše přetažením jejich záhlaví sloupců. Buňky sloupů s modrým podtržením jsou hypertextové odkazy k dalším prvkům v projektu a hypertextové odkazy může být následován podržením klávesy Ctrl a klepnutím na následující odkazy. Sloupce mohou být skrytý klepnutím pravým tlačítkem myši na záhlaví sloupce a výběrem sloupec | Skrýt sloupec. Skryté sloupce lze neskrytý kliknutím na tlačítko panelu nástrojů Sloupce Konfigurovat a pomocí sloupce Konfigurovat dialog, jak je uvedeno níže, nebo výběrem šipky dolů část tlačítka panelu nástrojů Sloupce Konfigurovat a individuálně výběrem skryté sloupce (y) z obou generálního, Vlastnosti nebo přípojky sbírky. Řádky mohou být seskupeny podle jejich hodnot sloupců přetažením záhlaví sloupce do modré seskupení řádku v horní části katalogu. Kdykoliv můžete poklepat na Volič katalog řádek a skok naodpovídající složkanebo připojeníV okně Průzkumníka.Nemovitosti jsou hodnoty buněk tučně kde oni jsou odlišné od výchozí hodnoty, a kurzívou kde oni jsou jen pro čtení. Časové razítko, nemovitosti a Přiložené sloupce složka může být barevný v souladu s hodnotami buněk nebo hodnota připojené komponenty majetku klepnutím pravým tlačítkem myši na záhlaví sloupce a výběrem sloupec | Change Color ... a potom Colour o razítko nebo volbou Colour majetkem, avšak pouze Seznam, Integer, desítkové, Boolean nebo Datum / Čas Vlastnosti typ dat bude barvu. Majetkové hodnoty pro připojené sloupy složka může být zobrazeno klepnutím pravým tlačítkem myši na záhlaví sloupce a výběrem sloupec | Zobrazit zařízení ... a pak možnost Zobrazit zařízení. A nakonec, tam, kde jsou Požadované omezení nastavení pro sloupec vlastností mohou být tyto zobrazeny s string (spolu s barvivy, podle úrovně jejich vymáhání) klepnutím pravým tlačítkem myši na záhlaví sloupce a výběrem sloupec | Zobrazit .

Katalog

Na přidat / zobrazit sloupce a Katalog Zobrazit v ABACUS

1. Ujistěte se, že máte Katalogové zobrazení otevřít.

2. Skryté sloupce může být individuálně neskrytý kliknutím na tlačítko šipka na pravé straně sloupců tlačítko panelu nástrojů Konfigurovata výběrem skrytý sloupec z buď Generál, Vlastnosti nebo Přílohy sbírky.

Poznámka

Zatržítkem se zobrazí vedle aktuálně zobrazené sloupce pro katalog.Kromě toho bude k dispozici v rámci Přílohy pouze některé přílohy část v závislosti na omezení které jsou definovány v projektu. Zejména pro přílohu k dispozici, které mají být uvedeny v katalogu komponent typu konstrukční části pro katalog musí být zadán buď jako zdroj, nebo dřez (není "Jakékoli") o "spojení musí být připojen" omezení pro připojení typu, a musí být také alespoň jeden typ konstrukční části specifikován buď jako zdroj, nebo dřez (není "Jakékoli"), druhého 'end' stejného typu připojení.

- NEBO -

2. Více sloupců lze neskrytý (nebo objednat nebo pevné) kliknutím na tlačítko Konfigurace Sloupce tlačítko panelu nástrojůa používat Konfigurovat sloupce dialog uvedený níže.

Poznámka

Právě zobrazené sloupce jsou zobrazeny v panelu na pravé straně pomocí dostupných sloupců, znázorněných na panelu na levé straně. Dostupné sloupce mohou být filtrovány podle Vyberte Dostupné sloupcůpull-down a mohou být přidány jejich výběrem v panelu na levé straně a klikněte na Přidat Tlačítko inbetween oběma panely.

Konfigurace dialogové okno Sloupce

Na odstranit / skrýt sloupce z Katalog Zobrazit v ABACUS

1. Ujistěte se, že máte Katalogové zobrazení otevřít.

2. Klepněte pravým tlačítkem myši na záhlaví sloupce pro sloupec, který chcete odstranit / skrýt a vyberte Sloupec | Hide Column.

- NEBO -

2. Více sloupců mohou být skryté (nebo objednat nebo pevné) kliknutím na tlačítko Konfigurace Sloupce tlačítko panelu nástrojůa používat Konfigurovat sloupce dialog uvedený výše.

Poznámka

Právě zobrazené sloupce jsou zobrazeny v panelu na pravé straně pomocí dostupných sloupců, znázorněných na panelu na levé straně. Aktuálně zobrazené sloupce mohou být skryty výběrem sloupec v panelu na pravé straně a klikněte na Odstranit Tlačítko inbetween oběma panely.

K naplnění pomocí Katalog Zobrazit v ABACUS

1. Na přidat součást nebo spojenízvoleného typu na Katalog (a projekt), klepněte na tlačítko Přidat nový komponentní / tlačítko Přidat nový panel nástrojů Connection. Řádek by měl se objeví a součást nebo Připojení bude vytvořen na nejvyšší úrovni Součásti nebo Připojení sbírka pro zvolený Architecture.

Poznámka

Nové komponenty a spoje jsou přidány ve výchozím nastavení na nejvyšší úrovni komponentů nebo připojení sbírky zvolené architektury. Chcete-li změnit rodič nových konstrukčních částí nebo připojení klepněte pravým tlačítkem myši hierarchii cesta buňky pro novou komponentu, nebo připojení řádku a zvolte Změnit Parent ...a zvolte požadovaný rodiče (které berou na vědomí omezení zvýraznění ).

Poznámka

Nové řádky / prvky, přidávat přímo do katalogu přes "Přidat nový" tlačítko, vložit do katalogu, nebo vytvořené prostřednictvím dovozu do katalogu z MS Excel jsou osvobozeny od filtrování, dokud není uzavřen katalog. To je umožnit veškeré potřebné úpravy hodnot sloupců, které mohou nesplňují stávající kritéria filtrování tohoto katalogu. Tyto nové prvek řádky jsou označeny symbolem "+" v voliče řádku buňky na začátku řádku, který je zbarven zelená v případě, že v současné době splňuje element uložené filtrovací kritéria tohoto katalogu (tj zůstane v katalogu knihovny, pokud re-otevřeno), a červený pokud tomu tak není.

2. Na odebrání součást nebo spojenízvoleného typu z Katalog (a projekt), zvolte řádek a buď stiskněte klávesu Del nebo pravým tlačítkem myši na volič řádku a zvolte Odstranit z architektury, řádek by měl zmizet z katalogu a to bude vymazán z projektu.

Na filtr za použití Katalog Zobrazit v ABACUS

1. Ujistěte se, že máte Katalogové zobrazení otevřít.

2. Pokud se filtr řádek se nezobrazuje v horní části katalogu poté klikněte na tlačítko Show Filter záhlavímtlačítko na panelu nástrojů.

3. Ve sloupci chcete přidat filtr, poklepejte na filtr řádku buňky, kde se ukazuje "(vše)".

4. Pro Časové razítko, hierarchie Path, Jméno nebo Popisvšeobecné sloupce nebo Text, Integer, desítkové, Boolean nebo Datum ČasPokoje sloupce klepněte na tlačítko ..., který se zobrazí v pravé části filtru řádku buňky a zadejte hodnoty buněk, které by měly být zahrnuty do katalogu.

Poznámka

Přizpůsobení se provádí, jako kdyby "*" zástupné znaky jsou automaticky použita před a po každé hodnoty řetězce tak, že vstup "kočkou" (bez uvozovek) by měly zahrnovat řádky s "bobkočka','kočkažena "nebo" Applikočkaion "atd. Vícenásobné /" nebo "hodnoty mohou být zapsány na nových tratích s využitím Ctrl + Enter, Pro Integer a desetinná vlastnictví sloupcích "a" může být logika zahrnuty použitím "&"(Bez uvozovek) a vyšší než / méně než etc logiky mohou být zahrnuty pomocí '> =','>','<' a '<="(Bez uvozovek), např. '> = 50000 & <90000 ". Non-prázdné oceňované řady mohou být zahrnuty zadáním "(Non-Prázdné)"(Bez uvozovek) a prázdné řádky v hodnotě mohou být zahrnuty zadáním"(Prázdné)"(Bez uvozovek).A konečně, všechny filtry jsou ve výchozím nastavení malá a velká písmena, takže "kočkou" (bez uvozovek) by měly zahrnovat řádky s "kočkou", "kočkou" nebo "kočkou" atd pro případ citlivé vyhovující, zadejte "(Pouzdro)"(Bez uvozovek) před řetězec např. "(Rozsudek) Cat" (bez uvozovek) by měly zahrnovat pouze řádky s "kočkou" v nich.

5. Pro Přílohysloupy, Normy sloupce nebo Seznam Pokoje sloupce klepněte na tlačítko se šipkou dolů, která se zobrazí v pravé části filtru řádku buňky a vyberte hodnoty buněk z políček, které by měly být zahrnuty do katalogu.

Poznámka

"(Vybrat vše)" políčka umožní všechny ostatní zaškrtávací políčka, ve skutečnosti včetně všech dostupných řadách. "(Non-Prázdné)" políčko bude zahrnovat žádné neprázdné oceňují řádků. "(Prázdné)" políčko bude obsahovat žádné prázdné řádky oceněny. A konečně, zrušením zaškrtnutí políčka žádné konkrétní oceněny automaticky odškrtněte "(vybrat vše)" a "(Non-prázdná místa)," zaškrtávacích políček pro konzistenci.

6. Klepněte na tlačítko Dobře použít filtr.

Na povolit / zakázat filtrování a Katalog Zobrazit v ABACUS

1. Ujistěte se, že máte Katalogové zobrazení otevřít s filtr aplikovaný.

2. Zaškrtněte políčko vlevo od filtru řádku.

Na odstranit filtr z a Katalog Zobrazit v ABACUS

1. Ujistěte se, že máte Katalogové zobrazení otevřít s filtr aplikovaný.

2. Chcete-li odstranit jednotlivé sloupec filtr klikněte pravým tlačítkem myši na záhlaví sloupce a vyberte Sloupec | Clear Filtrování.

3. Chcete-li odebrat všechny filtry klikněte na tlačítko Možnosti panel nástrojů tlačítko a zvolte Vymazat nastavení filtrů.

Zachránit / uložit jako aKatalogové zobrazení

Poznámka

Zatímco všichni uživatelé architekt může vytvořit nové Katalogy, uložit změny nastavení existujícího Katalog je uživatelská licence potřebuje Designer add-on schopnosti. To je "chránit" konfiguraci stávajících katalogů, které mohou být sdíleny mnoho uživatelů. Nicméně, Architekt používá bez Návrhář doplněk může ještě zvolit "Uložit jako" každé nové nastavení do nového katalogu. A samozřejmě všechny licence Uživatel si může vybrat "zbavit se" případných změn stávajícího katalogu. Obraťte se na místního správce ABACUS nebo Podpora Avolution pokud vyžadujete Návrhář doplněk schopnost.A pamatujte si, to je jen nastavení katalogu, všechny úpravy provedené na základě údajů v katalogu jsou okamžitě aplikovány na úložiště, bez ohledu na to.

1. Ujistěte se, že máte novou nebo stávající Katalogové zobrazení otevříta vy jste provedli nezbytné změny.

2. V Katalogové zobrazenípanelu klepněte na tlačítko na Uložittlačítko pro uložení Katalogové zobrazení a veškeré změny formátování.

Poznámka

Pokud nemáte tlačítko Uložit na panelu nástrojů Katalogové zobrazení pak nemáte Návrhář doplněk a jste schopni jen Uložit jakožádné nastavení se změní do nového katalogu, když jdete na zavření stávajícího katalog.

3. Li Katalog JménoZobrazí se dialogové okno (kvůli tomu, že nový katalog) zadejte název pro katalog a stiskněte tlačítko Dobře.

Na export do katalogu MS Excel

1. Ujistěte se, že máte Katalogové zobrazení otevřít.

2. Klepněte na tlačítko Export do Excelu katalog tabulkytlačítko na panelu nástrojů.

3. Zvolte název souboru, který chcete uložit katalog MS Excel jako. Klepněte na tlačítko Uložit.

Poznámka

Ve výchozím nastavení exportovaného MS Excel katalogový filename bude jméno katalog suffixed názvem Architecture v závorce, např "Projekty (2.014 Actual) XLSX". Můžete změnit cokoli z toho, včetně toho, zda je formát souboru bude XLSX nebo XLS. Jméno Architektura je součástí upozornit uživatele, že každý katalog má konkrétní obsah (tj ID ve sloupci A a řádku 1), který umožňuje, aby byl kulatý, zakopl zpět pomocí Importovat z katalogu MS Excel dle níže.

Poznámka

Ve výchozím nastavení skryté Sloupec A v rámci vyváženého katalogu MS Excel obsahuje jedinečný identifikátor pro každý z prvků v úložišti ABACUS. To umožní, aby změny provedené v MS Excel, které mají být "uzavřeno" se stávajícími prvky v rámci ABACUS při dovozu (viz níže). Nicméně, použití této jedinečné ID na "sladit" řádků může být vyřazen s Externí | IDnemovitosti na prvku. To znamená, že v případě, že prvek má externí | ID vlastnictví a je zahrnuta do katalogu vývozu jsou hodnoty na externím | ID sloupec bude použit k sladit řádků při dovozu (viz níže) a jedinečný identifikátor hodnoty ve skrytém sloupci A budou ignorovány (a může být i prázdný). Skrytý Sloupec A sama o sobě musí zůstat, nicméně, zejména hodnota v buňce A1. Navíc, při přidávání externích id do existující kolekce ABACUS prvků doporučujeme přidat je jako jiný majetek jako první, např Externí | Temp a potom jej přejmenuje vlastnost k externímu | ID. V opačném případě budou přidány duplicitní prvky.

Katalog formátováníje exportován ve výchozím nastavení, ale pro velké katalogy to může mít za následek, že export docela pomalý. V souladu s tím, v Nástroje | Možnosti ...pak na KatalogKarta,jste schopni snížit množství formátování, které je vyvezeno, jak je uvedeno na kartě katalog níže, čímž se urychlí export.

Katalog export Možnosti

4. Zobrazí se dialogové okno Export Dokončeno. Klepněte na tlačítko Dobře.

Exportován do katalogu MS Excel

Na import z katalogu MS Excel

Poznámka

Ve výchozím nastavení skryté Sloupec A v rámci vyváženého katalogu MS Excel (viz výše), obsahuje jedinečný identifikátor pro každý z prvků v úložišti ABACUS. To umožní, aby změny provedené v MS Excel, které mají být "uzavřeno" se stávajícími prvky v rámci ABACUS při dovozu. Nicméně, použití této jedinečné ID na "sladit" řádků může být vyřazen s Externí | IDnemovitosti na prvku. To znamená, že v případě, že prvek má externí | ID vlastnictví a je zahrnuta v katalogu na vývozu (viz výše), pak hodnoty externího | ID sloupec bude použit k sladit řádky v případě dovozu a jedinečné hodnoty ID ve skrytém sloupci A budou ignorovány (a může být i prázdný). Skrytý Sloupec A sama o sobě musí zůstat, nicméně, zejména hodnota v buňce A1. Navíc, při přidávání externích id do existující kolekce ABACUS prvků doporučujeme přidat je jako jiný majetek jako první, např Externí | Temp a potom jej přejmenuje vlastnost k externímu | ID. V opačném případě budou přidány duplicitní prvky.

1. Ujistěte se, že máte Katalogové zobrazení otevřít.

2. Klepněte na tlačítko Import z Excel katalog tabulkytlačítko na panelu nástrojů.

3. Zvolte název souboru, který chcete importovat katalog MS Excel z. Klepněte na tlačítko Otevřít.

4. Nové Chyby zjištěné a / nebo nové chyby / varování Zjištěno dialogy se mohou objevit na jakýkoliv nový obsah (tj řádky v MS Excel), která byla přidána. Vezměte na vědomí chyb / varování a klepněte na tlačítko Dobře.

5. Zobrazí se dialogové dokončení importu se zobrazí a může ukázat varování v důsledku dovozu (viz poznámky níže). Klepněte na tlačítko Dobře.

Poznámka

U přidělených standardy nebo připojených sloupů Příslušenství, nové položky v katalogu přes MS Excel musí odpovídat přesně jméno stávajícího standardu nebo jeho součást správného typu pro postoupení nebo připojení, které se doplňují. První s názvem Zápas bude použit a všechny neuzavřené položky bude generovat upozornění dle níže. Kromě toho, zatímco varování jsou uvedeny na re-import, prvky jsou není odstraněnz ABACUS v případě, že nejsou přítomny v katalogu MS Excel. To je proto, že neexistuje žádný způsob, že ABACUS může vědět, zda je přiřazen standardní nebo připojené Component existuje v rámci projektu ABACUS, ale neexistuje v katalogu MS Excel, protože to byla vymazána z katalogu MS Excel nebo byla přidána do počítadla Projekt od katalogu bylo vyvezeno. V souladu s tím, pokud uživatelé chtějí snadno "odhalit", které byly během procesu importu přidá připojení mohou jednoduše vytvořit požadovaný majetek na typu připojení a nastavení je výchozí, aby prázdné tak, že budou varováni o všech nových připojení pokaždé, když se dovozní je dokončena.

Poznámka

Při importu katalogu MS Excel může být zobrazena různá varování. Za prvé, pokud nový sloupec byl přidán do aplikace Excel, které neodpovídá "syntaxi" pro vlastnost nebo připojené komponenty sloupec bude ignorován. Dále bude varování řádek po řádku se zobrazí u všech emisí s údaji o každém řádku katalogu Excel. Tato varování začít s číslem řádku v hranatých závorkách a pokud je to relevantní nadpisu sloupce (tj "[23, j] ..." pro řádek 23, sloupec J) a může odkazovat na smazaných položek, neuzavřené norem nebo připojených jmen Component (což jsou ignorovány podle poznámky výše) nebo neplatné nebo prázdné ID týkající se nového řádku / prvku (který bude doplněno). Podrobný článek o vyplnění Abacus pomocí katalogů Excel najdete v části Avolution Community nebo školení Portfolio Manager.

Poznámka

Nové komponenty a spoje jsou přidány ve výchozím nastavení na nejvyšší úrovni komponentů nebo připojení sbírky zvolené architektury. Chcete-li změnit rodič nových konstrukčních částí nebo připojení klepněte pravým tlačítkem myši hierarchii cesta buňky pro novou komponentu, nebo připojení řádku a zvolte Změnit Parent ...a zvolte požadovaný rodiče (které berou na vědomí omezení zvýraznění ).

Poznámka

Prvky přidán přímo do katalogu přes "Přidat nový" tlačítko, vložit do katalogu, nebo vytvořené prostřednictvím dovozu do katalogu z MS Excel jsou osvobozeny od filtrování, dokud není uzavřen katalog. To je umožnit veškeré potřebné úpravy hodnot sloupců, které mohou nesplňují stávající kritéria filtrování tohoto katalogu. Tyto nové prvek řádky jsou označeny symbolem "+" v voliče řádku buňky na začátku řádku, který je zbarven zelená v případě, že v současné době splňuje element uložené filtrovací kritéria tohoto katalogu (tj zůstane v katalogu knihovny, pokud re-otevřeno), a červený pokud tomu tak není.

Na porovnat obsah katalogu s jinou architekturou

1. Podívejte se prosím na téma zde .

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Naplnění vaší architektury od aplikace Visio | Naplnění vaší architektury z aplikace Excel


Naplnění pomocí Matice

Navigace: Naplnění vaší architektury>

Naplnění pomocí Matice

Odeslat připomínky na toto téma.

Matrice vám umožní prohlížet a upravovat 'řídit' propojení mezi komponenty v jednoduché tabulkové způsobema také zobrazit "nepřímý cestu" mezi složkami podle jakéhokoli zprostředkujícího složek (a spojů).

Na vytvořit pohled Matrix v ABACUS

Poznámka

Zatímco všichni uživatelé architekt může vytvořit Matice s nimi a / nebo jejich nastavení Uložit uživatelská licence potřebuje Designer add-on schopnosti. To je "chránit" konfiguraci stávajících matic, které mohou být sdíleny mnoho uživatelů. Nicméně, Architekt používá bez Návrhář doplněk může ještě zvolit "Uložit jako" každé nové nastavení do nového Matrix. A samozřejmě všechny licence Uživatel si může vybrat "zbavit se" případných změn stávajícího Matrix. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

1. Vyberte Vložit | Matice.

2. V rchitecture>pull-down vyberte architekturu, která obsahuje komponenty a připojení, které chcete zobrazit.

3. V <ZdrojTyp>pull-down vyberte typ komponenty, které chcete mít instance uvedeny jako "řádky' dole vlevomatrice.

4. V <DřezTyp>pull-down vyberte typ komponenty, které chcete mít instance uvedeny jako "sloupce' přes hornímatrice.

5. V strhnout V zásadě existují dvě "režimy" matrice lze definovat ...

Připojení "přímé" matrice

6. Jednoduše tozvolit jeden (1) nebo více spojení typy Na pravé straně menu, které se objeví v případě, Chcete-li vidět v "buňkách" matrice, pokud: an explicitníSpojení existuje od Vertikální/ "řádek"Složkou matrice do Horizontální/ "sloupec"Složkou matrice.

Poznámka

Pouze spojení s zdrojem konec připevněný k Vertikální/ "řádek"Komponent a umyvadlo konec připojený k Horizontální/ "sloupec"Se zobrazí složka. Switch Zdroj a Dřezkomponent výběry typ zobrazení spojení v opačném směru.

7. Matice bude naplněn "X" v buňkách (nebo majetkové hodnoty - viz poznámka níže) pokud je spojení od Vertikální/ "řádek'složkou matrice u The Horizontální/ "sloupec"Složkou matrice.

Poznámka

U velkých matic se zobrazí v době, jak je znázorněno na 'R' a ukazatelů 'C' v levé horní buňky záhlaví, respektive jen maximálně 100 řádků nebo sloupců (včetně zřícených řádků / sloupců). Chcete-li zobrazit další řádky použijte posuvníky. Kdykoliv můžete poklepat na Vertikální/ "řádek' nebo Horizontal / "sloupec' komponent nadpisy a skok naodpovídající komponenty v okně Průzkumníka.Rodiče vertikálního/ "řádek' a Horizontální/ "sloupec' komponents jsou také volitelně zobrazeny jako nadpis řádky / sloupce s šedou titulem čísla. Když se zhroutil (jediným kliknutím na nadpis buněk), pokud děti přílohy existovala pak s "X" se volitelně být zobrazeno, pokud byly připojeny všechny děti, nebo "O" se volitelně být zobrazeno, pokud některé z dětí byly připojeny pouze. Buňky mohou být barevný podle hodnoty nemovitosti přípojek kliknutím na Options 'ozubeného kola "v pravém horním rohu panelu nástrojů matice a výběrem Nastavení barev ... a potom na tlačítko Upravit a výběrem Barva razítko nebo Colour majetkem volbu pomocí a volbou nemovitost, rozsahu min a Max hodnoty a výběru barev, avšak pouze Seznam, Integer, desítkové, Boolean nebo Datum / Čas Vlastnosti typ dat bude barvu. Pokud se zhroutil buňka bude barevně v závislosti na průměrné hodnoty vlastnosti spojení. Místo toho, aby "X", může být majetkové hodnoty pro buňky zobrazeno kliknutím na Options 'ozubeného kola "v pravém horním rohu panelu nástrojů matice a výběrem Zobrazit nastavení hodnot ... a potom na tlačítko Upravit a vyberete možnost Zobrazit zařízení a výběrem nemovitosti.

Přímá spojení matice ukazující servery, kde jsou aplikace hostované s zbarvení a majetku, který je prokázáno, namísto obecný "X"

- NEBO -

"Nepřímou" Připojení matice

6. Szvolitposloupnost spojení typy a typy komponentna pravé a levé straně menu, které se objeví v případě, Chcete-li vidět v "buňkách" matrice, pokud: an nepřímá cesta připojených komponentůexistují od Vertikální/ "řádek"Složkou matrice do Horizontální/ "sloupec"Složkou matrice.

Poznámka

Jakákoliv platná cesta, která zahrnuje prvky vybrané v nabídce dráhy wšpatně se zobrazíbez ohledu na směr podkladových spojů, nicméně, při výběru se dráha První a Poslední prvky musí být vybrány typy připojení. Kromě toho objednávka z prvků, které byly vybrány je zobrazen s číselné prefixv náměstí ("[]") držáky a daný typ může být zahrnut zahrnuje více krátv dráze (jak je uvedeno v číselné prefix). Postupný výběr typů komponent nebo typů připojení je interpretován jako 'NEBO'cesta a hierarchie připojených komponent může být případně zahrnuty zaškrtnutím 'Hledat také příloh rodiče / děti"Zaškrtávací políčko. Switch Zdroj a Dřezkomponent výběry typu zobrazíte Cesty v opačném směru.

7. Matice se vyplní scesta / kolekce komponentv buňkách, pokud je cesta z Vertikální/ "řádek'složkou matrice u The Horizontální/ "sloupec"Složkou matrice.

Poznámka

U velkých matic se zobrazí v době, jak je znázorněno na 'R' a ukazatelů 'C' v levé horní buňky záhlaví, respektive jen maximálně 100 řádků nebo sloupců (včetně zřícených řádků / sloupců). Chcete-li zobrazit další řádky použijte posuvníky. Kdykoliv můžete poklepat na Vertikální/ "řádek' nebo Horizontal / "sloupec' komponent nadpisy a skok naodpovídající komponenty v okně Průzkumníka.Rodiče vertikálního/ "řádek' a Horizontální/ "sloupec' komponents jsou také volitelně zobrazeny jako nadpis řádky / sloupce s šedou titulem čísla. Když se zhroutil (jediným kliknutím na nadpis buněk), pokud nějaké děti cesty existovaly pak s "X" se volitelně být zobrazeno, pokud byly připojeny všechny děti, nebo "O" bude případně se zobrazí pouze tehdy, pokud některé z dětí mělo cesty. Nepřímé složky může být cesta barevný podle hodnoty nemovitosti složek klepnutím na Options 'ozubeného kola "v pravém horním rohu panelu nástrojů matice a výběrem Nastavení barev ... a potom na tlačítko Upravit a výběrem Barva razítko nebo Colour majetkem volbu pomocí a volbou nemovitost, rozsahu min a Max hodnoty a výběru barev, avšak pouze Seznam, Integer, desítkové, Boolean nebo Datum / Čas Vlastnosti typ dat bude barvu. Hodnoty majetku za nepřímé složek může být cesta zobrazeno kliknutím na Options 'ozubeného kola "v pravém horním rohu panelu nástrojů matice a výběrem Zobrazit nastavení hodnot ... a potom na tlačítko Upravit a vyberete možnost Zobrazit zařízení a výběrem nemovitosti.

Nepřímé připojení matice ukazuje aplikace, které implementují danou službu podle oddělení

Na filtrpohled Matrix v ABACUS

1. Ujistěte se, že máte novou Matrix pohled otevřít.

2. Klepněte na filtr os "trychtýř" v pravém horním rohu panelu nástrojů matice.

3. O zdroji a / nebo karet Dřezové přidat jméno, majetku, popis, hierarchie nebo standardních filtrů klepnutím na tlačítko Přidat, výběrem nemovitosti v případě potřeby a kliknutím Dobře, Vyberte příslušné volby v panelu Klíčová slova / položek pomocí logiky / syntaxe, jak je popsáno v následující poznámce. Náhled panel se automaticky aktualizuje, aby ukazují výsledky aktuální sady filtrů.

Poznámka

Pro Časové razítko, hierarchie Path, Jméno nebo Popisfiltry nebo Text, Integer, desítkové, Boolean nebo Datum ČasPokoje filtry odpovídající se provádí, jako kdyby "*" zástupné znaky jsou automaticky použita před a po každé hodnoty řetězce tak, že vstup "kočkou" (bez uvozovek) by měly zahrnovat řádky s "bobkočka','kočkažena "nebo" Applikočkaion "atd. Vícenásobné /" nebo "hodnoty mohou být zapsány na nových tratích s využitím Ctrl + Enter, Pro Celé číslo a Desetinný nemovitostí filtry "a" logika mohou být zahrnuty pomocí "&"(Bez uvozovek) a vyšší než / méně než etc logiky mohou být zahrnuty pomocí '> =','>','<' a '<="(Bez uvozovek), např. '> = 50000 & <90000 ". Non-prázdné oceňované řady mohou být zahrnuty zadáním "(Non-Prázdné)"(Bez uvozovek) a prázdné řádky v hodnotě mohou být zahrnuty zadáním"(Prázdné)"(Bez uvozovek). Pro Normy nebo Seznam Vlastnost Filtry "(Vybrat vše)" políčka umožní všechny ostatní zaškrtávací políčka, ve skutečnosti včetně všech dostupných prvků. "(Non-Prázdné)" políčko bude obsahovat všechny non-prázdné nemovitost ocení prvky. "(Prázdné)" políčko bude obsahovat žádné prázdné nemovitost ocení prvky. A odškrtnutí žádná specifická oceňují políčka automaticky zrušte výběr "(Vybrat vše)" a "(non-Prázdné)" zaškrtávací políčka pro konzistenci. A konečně, všechny filtry jsou ve výchozím nastavení malá a velká písmena, takže "kočkou" (bez uvozovek) by měly zahrnovat prvky s "kočkou", "kočkou" nebo "kočkou" atd pro případ citlivé vyhovující, zadejte "(Pouzdro)"(Bez uvozovek) před řetězec např. "(Rozsudek) Cat" (bez uvozovek) by měly zahrnovat pouze prvky s "kočkou" v nich.

K naplnění pomocí zobrazení Matrix v ABACUS

Poznámka

Můžete přidat / odebrat připojení, kde má jediný typ připojení byly použity pro cestu výše popsaného.

1. Na přidání připojenízvoleného typu mezi A Vertikální/ "řádek"Komponent a Horizontální/ "sloupec"Složkou matrice, kde" dosud neexistuje X '(nebo Zobrazená hodnota nemovitosti - viz poznámka výše)Dvakrát klikněte na buňku. By se měl objevit "X" (nebo hodnota nemovitosti - viz poznámka výše) a spojení bude vytvořen na nejvyšší úrovni kolekce připojení pro zvolený Architecture.

Poznámka

Název připojení bude Název typu připojení dle nastavení typu připojení matrice a je-li majetkové hodnoty je zobrazeno místo "X" výchozí hodnotu pro vlastnost se zobrazí.

2. Na upravit zobrazenou hodnotu vlastnostina spojení mezi a Vertikální/ "řádek"Komponent a Horizontální/ "sloupec"Složkou matriceDvakrát klikněte na buňku, nebo klepněte pravým tlačítkem myši na buňku a zvolte Upravit hodnotu ..., a upravit hodnotu v dialogovém okně Změnit hodnoty.

3. Na Odebrání připojenízvoleného typu mezi A Vertikální/ "řádek"Komponent a Horizontální/ "sloupec"Složkou matrice, kde" X ", již existuje(nebo Zobrazená hodnota nemovitosti - viz poznámka výše), právo-klepněte na buňkua zvolte Odpojit, X by měl zmizet a spojení bude odstraněn z projektu.

Zachránit / uložit jako aMatrix pohled

Poznámka

Zatímco všichni uživatelé architekt může vytvořit Matice s nimi a / nebo jejich nastavení Uložit uživatelská licence potřebuje Designer add-on schopnosti. To je "chránit" konfiguraci stávajících matic, které mohou být sdíleny mnoho uživatelů. Nicméně, Architekt používá bez Návrhář doplněk může ještě zvolit "Uložit jako" každé nové nastavení do nového Matrix. A samozřejmě všechny licence Uživatel si může vybrat "zbavit se" případných změn stávajícího Matrix. Obraťte se na místního správce ABACUS nebo Podpora Avolution pokud vyžadujete Návrhář doplněk schopnost.A pamatujte si, to je jen nastavení Matrix, všechny úpravy provedené na data v Matrixu jsou okamžitě aplikovány na úložiště, bez ohledu na to.

1. Ujistěte se, že máte novou Matrix pohled otevříta vy jste provedli nezbytné změny.

2. V Matrix pohledPanel nástrojů klikněte na zcela vlevo Uložit Maticetlačítko pro uložení Matrix pohled a veškeré změny formátování.

Poznámka

Pokud nemáte tlačítko Uložit na panelu nástrojů Matrix pohledu pak nemáte Návrhář doplněk a jste schopni jen Uložit jakožádné nastavení se změní na novou matici, když jdete na zavření stávající matice.

3. Li Matice JménoDialog, který se objeví (kvůli tomu, že nové matrix) zadejte název pro maticea stiskněte tlačítko Dobře.

Na Export do MS Excel matice

1. Ujistěte se, že máte Matrix pohled otevřít.

2. Klepněte na tlačítko Export do Excelutlačítko na panelu nástrojů.

3. Zvolte název souboru pro uložení matice MS Excel jako. Klepněte na tlačítko Uložit.

Poznámka

Ve výchozím nastavení exportovaného MS Excel Matrix filename bude název Matrix suffixed názvem Architecture v závorce, např "Žádosti hostované na serverech (v roce 2014 Actual) XLSX". Můžete změnit cokoli z toho, včetně toho, zda je formát souboru bude XLSX nebo XLS.

Formátování Matrixje exportován ve výchozím nastavení, ale pro velké matice to může mít za následek, že export docela pomalý. V souladu s tím, v Nástroje | Možnosti ...pak na MaticeKarta,jste schopni snížit množství formátování, které je vyvezeno, jak je uvedeno na kartě pod Matrix, čímž se urychlí export.

Export Matrix Možnosti

4. Zobrazí se dialogové okno Export Dokončeno. Klepněte na tlačítko Dobře.

Exportovat do MS Excel matice

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Naplnění vaší architektury od aplikace Visio | Naplnění vaší architektury z aplikace Excel


Naplnění vaší architektury z aplikace Microsoft Access

Navigace: Naplnění vaší architektury> Naplnění z produktů společnosti Microsoft>

Naplnění vaší architektury z aplikace Microsoft Access

Odeslat připomínky na toto téma.

Můžete exportovat architekturu do aplikace Microsoft Access provádět výpočty pro všeobecné použití, manipulace nebo zprávy o vašem architektuře. Potom můžete importovat architekturu zpět do ABACUS.

Poznámka

Open od Access / Export do databáze funkce vyžaduje, aby Microsoft Access 2000nebo novější je nainstalována v počítači.

Chcete-li exportovat vaší architektury do aplikace Microsoft Access

1. Zkontrolujte, zda máte ABACUS souborotevřený, BadatelZobrazí, a architekturadodal.

2. Vyberte File | Vývozní | Do databáze.

3. Vezměte na vědomí dialogu varování, jak bylo popsáno výše, a pokračujte klepnutím na tlačítko Ano.

4. Vyberte umístění a název souboru pro soubor databáze.

Chcete-li importovat manipulovaný architekturu do ABACUS

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vyberte File | Nové a vyberte Od Accessz dialogu, který se objeví, a klikněte na tlačítko OK.

3. Vyhledejte soubor databáze, který chcete importovat.

MS Access Database Schema Abacus '

ABACUS má na své srdce An ontologie / meta-meta-modelu skládá z komponentů, připojení a omezení. Tento "CCC" přístup byl odvozen z různých standardních přístupů vyvinutých od 1960 roku kulminovat v mezinárodním standardu IEEE 1471, který Avolution Zakladatelé přispěl k. Následující primitiva platí;

1. POČITADLO Obsahuje Knihovny z Normy(nebo norem), Komponent a Typy připojení, Omezení, Úhly pohledu, Šablony (nebo Vzory) a mnoho Architektury.

2. Normy, Druhy a Úhly pohledu smětlogicky Seskupenopro pohodlí.

3. Architektury může obsahovatmnoho potomek Architektury(nebo Evolutions).

4. Každý Architektura Obsahuje mnoho Komponenty a Připojeníněkterých Druhya různé Zobrazení.

5. Komponenty a Připojení může být rozkládá do Dílčí komponenty a Dílčí Připojení.

6. Každý Komponentje připojený klibovolný počet Připojeníale každý Spojenímůže být jen připojený knejvýše dvě Komponenty.

7. Komponenty a Připojení plechovka mít Normy s Vlastnostijako jsou informace, výkon, spolehlivost, cena atd.

8. Architektury, Komponenty a Připojení plechovka mít konkrétní Vlastnostijako jsou informace, výkon, spolehlivost, cena atd.

9. Omezení plechovka existují mezi Komponenty nebo Připojení nebo proti Vlastnosti.

10. Šablonyjsou standardní složení Komponent a Typy připojení.

11. Úhly pohledujsou standardní sdružení Komponent a Typy připojenído záznamů.

12. Zobrazeníjsou vizuální reprezentace Komponenty a Připojení.

Následující MS Access Entity Relationship Diagram (ERD) dokumentuje jádroArchitektury, Evoluce, Druhy Component / připojení (a skupiny), komponenty / Spojovací a Sub komponentní / připojení koncepty.

Schéma databáze Jádro

Poznámka

Referenční integrita nebyla vynucena na vztah mezi tabulky Komponenty a tabulka připojení (pro "připojení" mezi danou Source nebo Sink komponenty a připojení). To je proto, že spojení může existovat bez přídavných součástí. Mohli jsme přidali "přílohu" tabulku, ale v zájmu zjednodušení se rozhodl proti tomu. Samozřejmě to znamená, že jakýkoliv editace komponent IDS nebo mazání komponent řádků všichni spolu bude mít za následek nesprávné údaje. ABACUS zvládne jakoukoliv nesprávnosti na dovozu ignorováním nesprávná data.

Následující MS Access ERD dokumentuje Vlastnostikoncepty pro architektury, typy Component / připojení a komponenty / Připojení.

Vlastnosti schématu databáze

Následující MS Access ERD dokumentuje Normykoncept pro architektury, typy Component / připojení a komponenty / Připojení.Poznámka: Tabulky nadále používat termín "provedení" podle předchozích verzí ABACUS.

Standardy schématu databáze

Následující MS Access ERD dokumentuje Omezeníkoncepce pro komponent typů / připojení.

OmezeníSchéma databáze

Následující MS Access ERD dokumentuje Úhly pohledu koncepce Architektury.Poznámka: Tabulky nadále používat termín "TwoDTempl 'podle předchozích verzí ABACUS.

Úhly pohleduSchéma databáze

Následující MS Access ERD dokumentuje Katalogykoncepce Architektury.

KatalogySchéma databáze

Následující MS Access ERD dokumentuje Maticekoncepce Architektury.

MaticeSchéma databáze

Následující MS Access ERD dokumentuje Diagramykoncepce Architektury.Poznámka: Tabulky nadále používat termín "TwoD 'podle předchozích verzí ABACUS.

Poznámka

Component / Typ připojení k vzorníku tvar mapování a volného tvaru tvar částí MS Access ERD byly pro přehlednost vynechány.

DiagramySchéma databáze

Následující MS Access ERD dokumentuje 3D Prohlídkykoncepce Architektury.

3D ProhlídkySchéma databáze

Následující MS Access ERD dokumentuje Grafykoncepce Architektury.

GrafySchéma databáze

Následující MS Access ERD dokumentuje Dashboards pojem.

DashboardsSchéma databáze

Abacus 'MS AccessDotazy

Součástí databáze MS Access je několik užitečných dotazy takto;

· Comps podle rekvizity- Tento dotaz uvádí všechny komponenty v projektu (podle architektury a typu) a zahrnuje všechny vlastnosti jako sloupce. Použijte tento dotaz s filtry / kritérii na typu konstrukční části a / nebo architektury produkovat "typické" tabulky pro každý typ konstrukční části se jejich vlastností.

· Pohlavní choroby podle rekvizity- Tento dotaz uvedeny všechny standardy, které jsou v provozu, počet výskytů normy a zahrnuje všechny vlastnosti jako sloupce. Pomocí tohoto dotazu jako na standardech katalogu.

· Rekvizity podle druhů- Tento dotaz obsahuje seznam všech komponent a jejich vlastnosti% kompletní každého typu konstrukční části, jako sloupy. Pomocí tohoto dotazu k určení, zda jsou zachovány specifické vlastnosti.

· Typy podle rekvizity- Tento dotaz zobrazí všechny typy komponent a obsahuje kompletní% ze všech vlastností jako sloupce. Pomocí tohoto dotazu k určení, zda jsou zachovány specifické vlastnosti.

· Typ Count- Tento dotaz zobrazí všechny typy komponent a zahrnuje počet výskytů každého typu v sestupném pořadí. Pomocí tohoto dotazu určit popularitu každého typu v projektu.

Poznámka k práci s polí typu Memo v MS Access

Komponenty, připojení a standardy jména polí v tabulkách jsou definovány jako pole memo umožnit neomezený počet znaků, podle ABACUS. Pro součásti a spoje Tato způsobuje několik problémů, protože mají také jedinečné ID pole pro odkazování, ale i pro standardy to způsobuje několik problémů při pokusu o spojení tabulek, protože nemůžete připojit memo polí v MS Access. Případně můžete nastavit WHERE kritéria klauzule dosažení stejného účinku, jak je uvedeno v Visual Query Builder a odpovídající SQL, který umístíte níže uvedeného seznamu se všechny zděděné Standardy vlastnosti pro všechny komponenty v exportovaném projektu ABACUS.

Memo pole "připojí" Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Od komponent INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) AND (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Implementace INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

WHERE (((ComponentImplementationLinks.Name) = [Implementace] [název]).);

Memo pole "připojí" v SQL

Poznámka k automatické generování ID počítadlo v MS Access

Různé tabulky ABACUS MS Access vyžadují unikátní dlouhé celé číslo ID, takže jednoduchá metoda VB se poskytuje pomoc při vytváření těchto. Dvě metody ResetCounter () a GetNextCounter () jsou poskytovány v rámci Abacus 'MS Access DB a jejich použití je následující; ResetCounter () nastaví počítadlo zpět na 0. GetNextCounter () vrátí další čítače v pořadí.

Metody vytěžit co nejvíce z MS Access "vtípek", že iv případě, že volání metody ResetCounter () pro každý řádek vložku (tedy pokud jste také spustit funkci GetNextCounter ()), protože funkce ResetCounter (), nemá žádné parametry, to prostě běží to jednou, a proto nemá vynulovat čítač pro každý řádek vložkou. A také proto, že ze stejného "vtípek", musíte projít všechny staré proměnné sloupce funkci GetNextCounter (), aby oklamat jej do chodu pokaždé.

K dispozici je také trik, aby byli schopni provozovat funkci v úložné ResetCounter () do příkazu SQL, protože nemůžete jen mít to sedí tam jako sloupec na jeho vlastní, jako kdyby to byl výběrový dotaz. Doporučuje se, aby se ResetCounter () volání část jedné z dalších oblastí, concatenating ji až do konce, jak to vždy vrací null stejně.

Níže je typický SQL použití metod doplnit seznam typů složky z tabulky / dotazu s názvem "Component Type seznam".

INSERT INTOComponentTypes (id, jméno, popis)

SELECT GetNextCounter ([Component Type List] .name)AS Id, [Component Type List] .name jako jméno, [Component Type List] .description & ResetCounter ()AS Popis

Z[Component Type List];

ABACUS ID / Counter generace SQL

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Naplnění vaší architektury od aplikace Visio | Naplnění vaší architektury z aplikace Excel


Naplnění vaší architektury z aplikace Microsoft Visio

Navigace: Naplnění vaší architektury> Naplnění z produktů společnosti Microsoft>

Naplnění vaší architektury z aplikace Microsoft Visio

Odeslat připomínky na toto téma.

Můžete importovat vaší architektury z aplikace Microsoft Visio. Obrazců ve výkresu aplikace Visio budou importovány jako komponenty do ABACUS. Připojení ve výkresu aplikace Visio bude importovány jako spojení a kresba samotná budou importovány do ABACUS jako diagramu. Kromě toho budou všechny vlastní vlastnosti ve výkresu aplikace Visio být dovezena jako vlastnosti s klíč třídění mapované do vlastnosti typu, Label ke jménu majetku a k hodnotě majetku.

Poznámka

Import z funkce Visio vyžaduje, aby Microsoft Visio 2003nebo novější je nainstalována v počítači.

Chcete-li importovat výkresy aplikace Visio do ABACUS

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vyberte File | Nové a vyberte Od Visioz dialogu, který se objeví, a klikněte na tlačítko OK.

Poznámka

Chcete-li importovat do existujícího projektu ABACUS pak buď pravým tlačítkem myši na uzel Součásti v architektuře, nebo pravým tlačítkem myši na jednotlivé součásti v rámci architektury a poté vyberte příkaz Import | Z aplikace Visio.

3. Vyhledejte soubor Visio, který chcete importovat.

Poznámka

Níže jsou uvedeny několik jednoduchých pravidel nebo doporučených postupů při výstavbě (a jejich úpravách) MS Visio výkres pro dovoz do ABACUS.

1. Čáry nebo připojení musí být skutečné konektory, ne tvary.

· V opačném případě ABACUS bude jen importovat jako součásti, a proto nebudou "připojeny" k ničemu.

· Pokud potřebujete udělat nějaké "chytré" směrování (tedy jiné než přímce), pak použijte Dynamic konektoru na základní tvary vzorníku, budou ABACUS importovat směrování / kotevní body v pořádku.

· Snažte se vyhnout pomocí "sítě Ring" a "Ethernet" tvary ze vzorníku sítě a periferních zařízení, které umožňuje mnoho složek, které mají být "připojen" k tomu. Zatímco my import přílohy v pořádku, připojení k původní tvar je stále "rozšířená", aby odrážel přílohy. Použijte oddělit samostatný "rozbočovač / autobusem" tvar (bez konektoru "nohy") a pak explicitně připojovat jednotlivé komponenty do náboje / autobusu se samostatnými konektory.

· Pokud řádek nebo připojení se chová jako tvaru, klikněte pravým tlačítkem na něj a jít na "Format | Chování ... "a ujistěte se, že interakce styl je nastaven na Line (1-rozměrné).

2. Komponenty musí být tvary NOT konektory.

· V opačném případě ABACUS bude jen importovat jako spojení, a proto všechny informace o tvar budou ztraceny.

· Pokud součást chová jako konektor, klikněte pravým tlačítkem na něj a jít na "Format | Chování ... "a ujistěte se, že interakce styl je nastaven na Box (2-rozměrné).

3. Konce konektoru musí být připojena k tvarům, NOT obíhajících v pozadí za tvaru.

· Pokud nechcete připojit konektory tvary pak ABACUS nemá žádný způsob, jak vědět, že jste v úmyslu připojit daný konektor k tvaru / složky, a proto to nechám, že konec připojení Un-připojené.

4. Etikety na tvary by měly být (pokud možno) vestavěný textový popisek pro tvar, není samostatným textové pole na výkresu.

· Samostatné textová pole dostane dovážen ABACUS jako složky v jejich vlastní pravý, a zatímco vy můžete sloučit "label" složku s reálným komponenty v ABACUS, nebo jen převést "label" komponenty do polygonální tvar (tedy ne složka sama o sobě) to je nejlepší se vyhnout těchto kroků.

5. Použijte stejný základní tvar pro každou instanci stejného typu, nebuďte líní a použít obdélník a někdy box jiní z různých tvarů šablon.

· ABACUS používá tvar základny a jeho základní barvu, aby jednoznačně identifikovat komponent a typy spojení ve výkresu takže "červený obdélník" a "červené pole" dostane dovážené jako dvě samostatné typy komponent. Tyto typy komponent mohou být sloučeny v ABACUS, ale to je nejlepší se vyhnout těchto kroků.

6. Zcela zapouzdřit "děti" tvary uvnitř jejich "rodiče", nenechávejte je viset přes okraj.

· ABACUS zjistí jakýkoliv tvar, který je zcela zapouzdřený v rámci jiného tvaru jako dítě z mateřské společnosti, takže ujistěte se, že celý tvar, včetně štítku část, je uzavřena.

7. Neumisťujte tvar překrývající další dva tvary.

· Pokud tvar překrývá dvě jiné tvary, ať už je to "seskupení" / pozadí obdélník nebo jinak, bude dovážena ABACUS jako součást, která je dítětem ani o překrývajících se tvarů, ale jakmile vyberete komponentu v Abacus 'kreslicího nástroje , vzhledem k levém horním rohu jsou komponenty referenční bod, stane se dítě po levé straně překrývala tvar / složku.

8. Snažte se minimalizovat používání textových poznámek na výkresu, protože to dostane importovány jako součásti v jejich vlastní pravý, a budou muset být převedeny na volných tvarů v ABACUS. Přemýšlejte o tom, zda jsou skutečně název existující složky nebo připojení.

9. Zatímco ABACUS podporuje bohatý / barevné / tvary vektor založené, snaží minimalizovat používání bitmap, zahraničních tvarů a lepší metasouborů pro tvarů ABACUS v současné době dělánepodporují tyto typy. Budou importovány jako jednoduché bílé obdélníky.

10. Snažte se vyhnout carriage vrátí (Shift-Return) na štítcích, jak jsou importovány a zobrazeny jako speciální znak "[]" v ABACUS k názvu komponenty.

11. Se snaží minimalizovat různé barvy, které se používají pro tvary stejného typu. Jak bylo uvedeno výše, základní barvy a základní tvar jednoznačně identifikuje komponent a typy spojení, takže čím více variace je zde více zanikající a konsolidace, které budou muset být provedeno po dovozu v ABACUS.

12. Buďte opatrní s vyplněné tvary, protože pokud je tvar naplnil celou cestu do rohů a pak ji zbarvení později v ABACUS nebude mít žádný vliv.

13. U složitějších tvarů linkami musíte použít polygon, který je vytvořen tím, že řádky začínající kde ten předchozí skončí a pak se nakonec vrací do výchozího bodu. Pokud chcete, můžete použít výplně a čáry na šířku, aby polygon vypadat jako "šipka" nebo cokoliv tvar chcete.

14. Ujistěte se, že tvary ID v MS Visio je smysluplný nejen Shape.xx. To je upravitelný pomocí pravým tlačítkem myši na "Zobrazit tabulku ShapeSheet", který je k dispozici v režimu MS Visio pro vývojáře (umožněno prostřednictvím Nástroje | Možnosti v MS Visio).

15. Elipsy a obloukyv rámci tvarůjsou podporovány v ABACUS ale NURBS a spline jsou v současné době nejsou podporovány.

16. Ujistěte se, že celý tvar je seskupena v MS Visio nebo to dostane importovány jako několika složek / typů.

17. Snažte se minimalizovat používání otočených tvarů v subshapes, jak budou někdy ne být importovány správně.

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Naplnění vaší architektury z aplikace Access | Naplnění vaší architektury z aplikace Excel


Naplnění vaší architektury z aplikace Microsoft Excel

Navigace: Naplnění vaší architektury> Naplnění z produktů společnosti Microsoft>

Naplnění vaší architektury z aplikace Microsoft Excel

Odeslat připomínky na toto téma.

Můžete importovat architekturu z tabulky aplikace Excel (XLS nebo XLSX soubor). Dovozce Excel umožňuje mapovat seznamy složky a spojení s typy, standardy, vlastnosti a standardní vlastnosti výběrem sloupce v tabulce vaší které obsahují relevantní data.Přitom se jedná o více, než je pokročilá technika doporučený postuppro import z MS Excel, který je prostřednictvím katalogy jak je popsáno zde .

Poznámka

Import z / Export do aplikace Excel funkce vyžaduje, aby Microsoft Excel 2003nebo novější je nainstalována v počítači.

Hlavní funkcí dovozce Excel je, aby vám umožní definovat konfigurační soubor (tj hierarchické struktuře vašeho architektonického modelu). Konfigurační soubor ukládá dříve uložený mapování ze souboru aplikace Excel do souboru ABACUS. Jakmile se jednou určí uložen konfigurační soubor je později použít pro další importu a exportu do XLS.

Poznámka

Kroky uvedené v následujících kapitolách jsou speciálně pro uživatele, kteří mají ještě definovat a uložit konfigurační soubor a je import z Excelu poprvé. Musíte vytvořit a uložit konfigurační soubor používat Exportovat do aplikace Excel funkce.

Chcete-li importovat tabulky aplikace Excel do ABACUS

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vyberte File | Nový a vyberte Vynikatz dialogu, který se objeví, a klikněte na tlačítko OK.

Poznámka

Chcete-li importovat do existujícího projektu ABACUS pak buď pravým tlačítkem myši na uzel Součásti v architektuře, nebo pravým tlačítkem myši na jednotlivé součásti v rámci architektury a poté vyberte příkaz Import | Od Excel.

3. Dovoz ExcelZobrazí se okno

Dovoz Excel okno Tabulka

4. Klepněte na tlačítko Otevřít soubor Excelikonu a vyhledejte soubor aplikace Excel, kterou chcete importovat.

5. Vyber Pracovní listChcete-li importovat z rozevíracího seznamu.

Poznámka

Po otevření souboru aplikace Excel, můžete použít Náhled datKarta pro zobrazení sloupců a prvních 25 řádků vaší tabulky. Odtud můžete získat čísla sloupců potřebné k vyplnění Komponenty a PřipojeníTab.

Můžete si také vybrat, zda chcete nebo nechcete komponenty tabulkový procesor Excel, které mají být dovezeny s citlivostí případu. Jednoduše zaškrtněte Dovoz se rozlišováníMožnost (ve výchozím nastavení toto je vždy zaškrtnuto) a tabulkový procesor bude odpovídajícím způsobem importovány.

Ukázkový Excel File

Poznámka

V tomto příkladu budeme dovážet jednoduché infrastruktury a lidové architektury z dat Excelu uvedených ve výše uvedeném obrázku. Připojení bude provedeno mezi "lidé zodpovědní" a "servery", které tito lidé spravují.

K naplnění na kartu součásti

Tato sekce je určena pro definování typy komponent a hierarchickou strukturu pro konfiguračního souboru.

1. Vyberte KomponentyTab. Přejmenovat Set IDpřepsáním (null) hodnota

Poznámka

Tato funkce umožňuje definovat úplně jinak Soupravypro funkčně oddělených složek. Jak je vidět na následujícím obrázku, možná budete chtít odlišit komponent infrastruktury z vašich lidí komponent. Pokud existují vztahy (spojení) mezi těmito oddělenými soubory komponent, které mohou být definovány v rámci PřipojeníTab. Později v tomto příkladu budeme definovat spojení typu "spravuje" mezi infrastrukturou a lidé Soupravy.

Můžete si také vybrat, zda chcete nebo nechcete přidat nejvyšší úrovně Seskupeníkomponenta pro všechny prvky soupravy. Jednoduše zaškrtněte Skupina Pod Set IDMožnost (ve výchozím nastavení je to unticked) a tabulkový procesor bude odpovídajícím způsobem importovány.

Přiřazení Set ID

2. Jakmile je SoupravyByly definovány vybrat SouborChcete-li naplnit a rozšířit kliknutím na [+] znamení.

3. Vybrat Úrovně komponentů v této saděV rozbalené seznamu.

4. Součást Hierarchie sady: Set IDObjeví se okno pro to Soubor.

Komponenta hierarchie a přiřazení hodnot (Set ID: Infrastructure)

5. Přejmenovat Level NumberSloupec přepsáním (null) hodnota.

Poznámka

Level NumberSloupec umožňuje přiřadit hierarchii na komponenty. Každá úroveň odpovídá vrstvě ve vaší architektury, přičemž první úroveň je nejvyšší nejvíce rodič úroveň. Například úroveň Číslo "1" odpovídá nejvyšší hierarchické vrstvě, Level číslo "2" je dítětem úroveň číslo "1", a tak dále.

6. Vyberte a přiřaďte odpovídající sloupec z tabulky aplikace Excel k sobě Level Numberzadáním pod Komponenta Sloupec sloupec.

Poznámka

Můžete si vybrat, vyloučit určité řádky, které nechcete být zastoupen v architektuře. Ty mohou být záhlaví sloupců, prázdné řádky, atd Chcete-li vyloučit řádky použít Řádky pro vyloučení:Textové pole v blízkosti pravém horním rohu okna. V tomto příkladu jsme vyloučeni řádek 1, protože obsahuje naše záhlaví sloupců.

7. Můžete si vybrat, přidat popisy komponentům přepsáním (null)hodnota v Popis Sloupec.

Poznámka

Tento popis je to, co se objeví v ABACUS pod Obecné vlastnostisekce | Popis pole.

8. Pokud daný tabulkový sloupec obsahuje více než jednu složku na buňku (zadat pomocí Alt-Enter nebo CHAR (10) příkaz) a pak zaškrtněte políčko pod Dopřejte nových tratí jako samostatné součásti, Každý řádek budou importovány jako samostatné komponenty.

Tip

Chcete-li importovat "matrici" z kolekce sloupců, kde "X" v daném "matrice" buňky (buňky B2: D2 Say) vyžaduje, aby se části stanovená řadě (v buňce A2 říci,) je připojen na součást specifikován sloupci "nadpisem" (v řádku 1 Say), jednoduchý vzorec může být použit. Vstup do následující vzorec pro každý řádek v koloně za matrice buněk (sloupec F říci); = KDYŽ (B2 = "", "", B $ 1 CHAR (10)) a IF (C2 = "", "", C $ 1 CHAR (10)) a IF (D2 = "", "", D $ 1 a CHAR (10)). Pak nastavit připojení nastavit, jak je popsáno níže mezi komponenty specifikovaných řádku (ve sloupci A říkat) a popsané tímto vzorcem (uvedené ve sloupci F říct). Ujistěte se, že zkontrolovat Dopřejte nových tratí jako samostatné součástimožnost, pokud jsou dováženy komponenty ze vzorce. Pro pokročilejší matrice dovoz, včetně okruhů s několika vrstev hierarchie nebo buněk rozličné hodnoty, než jen obyčejný "X", obraťte se prosím Podpora Avolution .

9. Vyplnit ve zbytku sloupců podle potřeby.

Poznámka

Můžete si vybrat, získat typ z řad sloupců zaškrtnutím políčka pod Získat typu ze sloupcesloupec a zadáním příslušného sloupec z tabulky aplikace Excel v rámci cíle Součást Typ Hodnota nebo Sloupec sloupec. To bude importovat všechny komponenty v daném sloupci a nastavit na typu definovaného ve sloupci. Alternativně, a stejně jako snímek obrazovky nad a pod, můžete si vybrat použít pevnou / předdefinovaný název typu zadáním názvu typu v rámci Součást Typ Hodnota nebo Sloupecsloupec a ujistěte se, že políčko je un-zkontrolovat.

Komponenta hierarchie a přiřazení hodnot (Set ID: People)

Poznámka

V tomto příkladu chceme mít naše sítě a lidé seskupení na úrovni 1 architektury. Na úrovni 2 si přejeme, aby naše servery a osob odpovědných za správu těchto serverů. Komponentytab byly vyplněny odpovídajícím způsobem, jak je znázorněno ve dvou výše uvedených obrazovky. V prvním obrázku výše jsme definovali 1 (síťová seskupování) a na úroveň 2 (server) součásti úrovně pro infrastrukturu Soubor, A na obrázku bezprostředně nad jsme definovali úrovni 1 (lidi seskupení) a 2 (osoby odpovědné) komponenty úrovně pro lidi Soubor.

Alternativně, pro LidéSet, spíše než používat sloupec C jako Lidé seskupení, mohli jsme používán Skupina Pod Set IDna kartě Součásti na horní úrovni, a pak už jen vstoupil jeden lid sub-level z sloupci D. To je znázorněno na následujícím obrázku.

Komponenta hierarchie a přiřazení hodnot pomocí volby Skupina Podle Set ID (Nastavit ID: People)

10. Poté, co byly identifikovány komponenty, vyberte požadovanou úroveň zařízení, které chcete naplnit vlastnosti a / nebo standardy a rozšířit kliknutím na [+] znamení.

11. Vybrat Vlastnosti komponenty na této úrovni nebo Standardy na této úrovni komponentze rozšířené seznamu a do příslušných sloupců, kolik je potřeba.

Naplnění Components

Poznámka

Vlastnosti komponenty na této úrovniumožňuje definovat vlastnosti pro komponenty na zvolené úrovni. Standardy na této úrovni komponentumožňuje definovat standardy a jejich standardní vlastnosti pro komponenty na zvolené úrovni.

12. Opakujte kroky 2-11dokud nebudou naplněna všechny úrovně komponenty pro všechny definované Soupravy, Navigovat zpět do pomocí šipky zpět poblíž pravém horním rohu okna Soupravykterý jste definovali dříve.

K naplnění na kartu Připojení

Tato sekce je určena pro definování typy připojení a hierarchickou strukturu pro konfiguračního souboru.

1. Vyberte PřipojeníTab. Pro každý soubor spojů je nutné identifikovat komponentu Souborže chcete být zdrojové komponenty a komponenta SouborChcete být složky cílové.

2. Vespod Zdroj Component Set IDzadejte Soubornázev, který se vztahuje na Soubordefinované dříve ve KomponentyTab. Vespod Zdroj Component Number Levelzadejte číslo odpovídající úrovni složky, které chcete připojit ve zdrojovém konci připojení.

3. Nyní si vybrat, které komponenta skupina bude na cílovém konci spojení. Vespod Cíl Component Set IDzadejte Soubornázev, který se vztahuje na Soubordefinovány v KomponentyTab. Vespod Cíl Component Number Levelzadejte číslo odpovídající úrovni složky, které chcete připojit na cílovém konci připojení.

Poznámka

V tomto příkladu chceme spojit osoby odpovědné za správu serverů na servery, které spravují. Lidé odpovědní byly definovány z Čínské lidové republiky Souborjako úroveň 2 komponenty, zatímco servery byly definovány v infrastruktury Souborjako úroveň 2 komponenty. PřipojeníKarta byly vyplněny odpovídajícím způsobem, jak je uvedeno v následujícím obrázku.

Připojení Tab část 1 ze 2

4. Pokud přejdete na pravé straně, najdete další možnosti pro import vaše připojení. Získat typu ze sloupce a Typ připojení Hodnota nebo Sloupecpracovat stejným způsobem jako pro KomponentyTab.

5. V případě, že Zdroj Component Set IDa Zdroj Component Number Leveljsou stejné jako Cíl Component Set IDa Cíl Component Number Level(například pokud se připojujete stejné typy komponent, jako je například vytváření připojení od serverů do jiných serverů), pak musíte mít další sloupec ve své tabulce, která obsahuje jména těch serverů opakovaných. V této situaci byste dal, že tabulkový sloupec v Cíl Opakované ve sloupci sloupec. Je-li v tomto tabulkovém sloupci jste zadali více než jednu připojené zařízení na buňku, zaškrtněte políčko pod Dopřejte nových tratí jako samostatné součásti.

Připojení Tab část 2 ze 2

6. Po připojení byly zjištěny vyberte připojení, které chcete naplnit vlastnosti a / nebo standardy a rozšířit kliknutím na [+] znamení.

7. Vybrat Vlastnosti těchto spojení nebo Normy pro tato připojeníze rozšířené seznamu a do příslušných sloupců, kolik je potřeba.

Poznámka

Vlastnosti těchto spojeníumožňuje definovat vlastnosti pro vybrané připojení skupiny. Standardy pro tyto spojeumožňuje definovat standardy a jejich standardní vlastnosti pro vybrané připojení skupiny.

8. Opakujte kroky 2-7dokud byly definovány všechny skupiny spojení.

9. Po dokončení definování skupin připojení, klikněte na tlačítko DokončitTlačítko a vaše architektura bude vytvořen ze souboru importovaného Excel. Ve výše uvedeném příkladu bude mít za následek architektury znázorněné na obrázku níže.

Ukázka Architektura Dovezený z Excelu

10. Nyní uložte namapované konfigurace do souboru kliknutím na tlačítko Uložit konfiguraci ikona. Vaše uložené nastavení mohou být vyvolány později kliknutím na Otevření konfiguraceikona poblíž levém horním rohu okna.

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Naplnění vaší architektury z aplikace Access | Naplnění vaší architektury od aplikace Visio


Naplnění vaší architektury z aplikace Microsoft SharePoint

Navigace: Naplnění vaší architektury> Naplnění z produktů společnosti Microsoft>

Naplnění vaší architektury z aplikace Microsoft SharePoint

Odeslat připomínky na toto téma.

Můžeš synchronizovat Vaše architektura sMicrosoft Seznamy služby SharePoint. Synchronizace znamená buď vytvořením nové seznamy služby SharePoint (a jejich sloupce) z typů Abacus, jejich vlastnosti a příloh, nebo mapování existujících seznamů SharePoint (a jejich sloupce) pro typy Abacus, jejich vlastnosti a příloh, potom buď odesílání obsahu z ABACUS do SharePoint nebo SharePoint k ABACUS.

Poznámka

SharePoint Sync funkce vyžaduje, aby A Microsoft SharePoint 2010, 2013 nebo SharePoint Online site je k dispozici připojení a synchronizovat.Zatímco funkce SharePoint Sync můžete vytvořit seznamy (s sloupců) na webu služby SharePoint z jakéhokoliv projektu ABACUS, Avolution mohou také poskytovat různé šablony webů SharePoint na podporu standardních rámců (např TOGAF, ArchiMate, ITIL atd), takže prosím kontaktujte Podpora Avolution Požadujete-li tuto funkci.

Na vytvořit nový seznam SharePoint a mapovat na ABACUS komponent nebo typu připojení

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vybrat Nástroje | SharePoint Sync.

3. Klepněte na tlačítko New mapováníTlačítko a mapování dialogové okno SharePoint, jak je uvedeno níže objeví.

4. Zadejte adresu URL webu, uživatelské jméno a heslo pro web služby SharePoint a klepněte na tlačítko Připojit.

Poznámka

Platný sharepoint "admin" nebo účtem "přispěvatele" je vyžadováno pro synchronizaci z a do SharePoint a účet "čtenáře" umožňuje pouze synchronizaci z SharePoint.

5. Vyberte počítadlo komponent nebo typ připojení k mapování od Zvolte typ strhnout.

6. Klepněte na tlačítko Přidat novýtlačítko a pak pro každou ABACUS konstrukční části nebo typu připojení aspekt, který chcete mapovat na odpovídající pole v seznamu SharePoint vyberte položku v levém panelu av pravém panelu zadejte nový název seznamu SharePoint v novém seznamu sloupce (pouze poprvé) , pak je název SharePoint sloupce ve sloupci název (nebo použijte výchozí) a klepněte na tlačítko Přiřadit pokaždé.

Poznámka

Jako minimum umožňující synchronizaci počítadla EEID, Architektura a jména aspekty budou automaticky mapovány na SharePoint číslo a dva (2) jeden řádek textu (aka Text) sloupců resp. Tyto nemohou být unassigned. Navíc pouze určité aspekty Abacus současné době mohou být mapovány na určité sloupce SharePoint a Sloupec Typ pull-down se automaticky nastaví na požadovaný typ sloupce SharePoint. A to;

· Abacus 'Hierarchie Cesta k SharePoint více řádků textu (aka Poznámka) sloupců (Poznámka: SharePoint jeden řádek textu (aka Textové) sloupce podporují pouze 255 znaků, takže nejsou přednostní),

· Počítadlo "Připojené komponenty pro SharePoint vyhledávací sloupce (Poznámka: Mapování již musí existovat na základě seznamu pro připojené komponenty samotných),

· Abakus 'text a Popis vlastnosti na SharePoint více řádků textu (aka Poznámka) Sloupy (Poznámka: SharePoint jeden řádek textu (aka Textové) sloupce podporují pouze 255 znaků, takže nejsou přednostní),

· Počítadlo "desítkové nebo Integer vlastnosti na SharePoint Počet sloupců,

· Počítadlo "Seznam vlastností pro SharePoint Choice sloupce (Poznámka: SharePoint nevynucuje volba hodnoty, takže není potřeba typ seznamu údajů, které mají být vykonána v ABACUS),

· Abacus 'datum / čas vlastnosti na SharePoint více řádků textu (aka Poznámka) sloupců (Poznámka: SharePoint datum a čas sloupce nelze použít jako dosud vzhledem k nekonzistentním podpoře SharePoint je pro časové pásmo / nastavení regionalizace),

· Počítadlo "logické vlastnosti na SharePoint ano / ne (aka Boolean) sloupců.

Počítadla prvku související normy nemůže být mapovány do sloupců seznamu SharePoint dosud.

7. Vybrat Vytvořit mapování.

Na vytvořit nové mapování mezi komponentou ABACUS nebo typ připojení a existujícího seznamu služby SharePoint

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vybrat Nástroje | SharePoint Sync.

3. Klepněte na tlačítko New mapováníTlačítko a mapování dialogové okno SharePoint, jak je uvedeno níže objeví.

4. Zadejte adresu URL webu, uživatelské jméno a heslo pro web služby SharePoint a klepněte na tlačítko Připojit.

Poznámka

Platný sharepoint "admin" nebo účtem "přispěvatele" je vyžadováno pro synchronizaci z a do SharePoint a účet "čtenáře" umožňuje pouze synchronizaci z SharePoint.

5. Vyberte počítadlo komponent nebo typ připojení k mapování od Zvolte typ strhnout.

6. Vyberte seznam webů SharePoint mapovat od Zvolte Seznam strhnout.

7. Pro každou ABACUS konstrukční části nebo typu připojení aspekt chcete mapovat do svého seznamu sloupec odpovídající služby SharePoint vyberte položku v levém panelu a pravý panel, respektive a klikněte na tlačítko Přiřadit.

Poznámka

Jako minimum umožnění potřebovat synchronizace počítadla EEID, Architektura a jména aspekty, které mají být mapovány na SharePoint číslo a pak se pro architekturu a název buď jeden řádek textu (aka Text), nebo více řádků textu (aka poznámky) sloupců resp. Do té doby se provádí na tlačítko Vytvořit mapování nebude povolena. Navíc pouze určité aspekty Abacus současné době mohou být mapovány na určité sloupců SharePoint. A to;

· ABACUS "Architektura aspekt SharePoint jeden řádek textu (aka Text), nebo více řádků textu (aka Poznámka) sloupců (to je nutné pro konkrétní mapování obsahu, jak je popsáno níže),

· Abacus 'Hierarchie Cesta k SharePoint jeden řádek textu (aka Text), nebo více řádků textu (aka Poznámka) sloupců (Poznámka: SharePoint jeden řádek textu (aka Text) opěrných sloupech pouze 255 znaků, takže jakoukoli případnou další znaky budou zkráceny, a proto doporučuje se je převést na více řádků textu (aka Poznámka) sloupce v SharePoint před mapování),

· Počítadlo "Připojené komponenty pro SharePoint vyhledávací sloupce (Poznámka: Mapování již musí existovat na základě seznamu pro připojené komponenty samotných),

· Abakus 'text a Popis vlastnosti na SharePoint jeden řádek textu (aka Text), nebo více řádků textu (aka Poznámka) sloupců (Poznámka: SharePoint jeden řádek textu (aka Text) opěrných sloupech pouze 255 znaků, takže jakoukoli případnou další znaky budou zkráceny a proto je vhodné je převést na více řádků textu (aka Poznámka) sloupce v SharePoint před mapování),

· Počítadlo "desítkové nebo Integer vlastnosti na SharePoint Počet sloupců (Poznámka:. SharePoint Vypočtené sloupce lze použít však budou moci pouze synchronizovány z SharePoint ABACUS Snažím se synchronizovat" na "výpočtový sloupec bude mít za následek varování dle níže) ,

· Počítadlo "Seznam vlastností pro SharePoint Choice sloupy,

· Abacus 'datum / čas vlastnosti na SharePoint více řádků textu (aka Poznámka) sloupců (Poznámka: SharePoint datum a čas sloupce nelze použít vzhledem k nekonzistentním podpoře SharePoint je pro časové pásmo / nastavení regionalizace),

· Počítadlo "logické vlastnosti na SharePoint ano / ne (aka Boolean) sloupců.

Počítadla prvku související normy nemůže být mapovány do sloupců seznamu SharePoint dosud. A SharePoint je měna, osoba nebo skupina, hypertextový odkaz nebo obrázek, výsledek úloh, externí data a řízené sloupce metadat nemohou být mapovány na aspekty Abacus dosud.

8. Vybrat Vytvořit mapování.

Na synchronizovatVaše Microsoft Seznam (y) SharePointdo ABACUS

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vybrat Nástroje | SharePoint Sync.

Poznámka

Na synchronizovat seznam SharePoint sProjekt ABACUS licence uživatel potřebuje SharePoint Syncadd-on schopnosti. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

3. Vyberte existující mapování SharePoint (nebo mapování pomocí Klávesou Ctrl nebo Vybrat všetlačítko) z SharePoint mapování paneljak je znázorněno na vzorku snímku výše. Poznámka: Zde ukážeme jen "Cíl (nebo požadavek)" ABACUS typu konstrukční mapování do seznamu služby SharePoint je vybrán tzv Góly.

4. Vyberte Architektura (y), který chcete synchronizovat obsah s od Synchronizovat obsah z architekturypanel as je uvedeno v ukázkovém snímku výše. Poznámka: zde se ukazují jen "2015 Actual" architektura se synchronizují.

5. Vyberte Sync z SP tlačítko.

Poznámka

Pokud pověřovací SharePoint nejsou "všechny uložené" pro mapování (y) pak Přihlášení do dialogu SharePoint s dotazem pro Site URL, Uživatelské jméno a / nebo Heslo.Prosím, zadejte je. Dále bude synchronizace žádné jiné mapování, které jsou požadovány pro připojené komponenty / vyhledávací sloupce. Jakékoliv další mapování, které jsou automaticky zahrnuty budou zobrazeny v dialogu dle níže.

6. Na úspěšnou synchronizaci se objeví dialogové okno Výsledky SharePoint Sync, jak je uvedeno níže seznam změn a varování. Klepněte na tlačítko Dobře.

Na synchronizaci z ABACUS do Vaše Microsoft Seznam (y) SharePoint

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vybrat Nástroje | SharePoint Sync.

Poznámka

Na synchronizovat seznam SharePoint sProjekt ABACUS licence uživatel potřebuje SharePoint Syncadd-on schopnosti. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

3. Vyberte existující mapování SharePoint (nebo mapování pomocí Klávesou Ctrl nebo Vybrat všetlačítko) z SharePoint mapování paneljak je znázorněno na vzorku snímku výše. Poznámka: Zde ukážeme jen "Cíl (nebo požadavek)" ABACUS typu konstrukční mapování do seznamu služby SharePoint je vybrán tzv Góly.

4. Vyberte Architektura (y), který chcete synchronizovat obsah s od Synchronizovat obsah z architekturypanel as je uvedeno v ukázkovém snímku výše. Poznámka: zde se ukazují jen "2015 Actual" architektura se synchronizují.

5. Vyberte Sync pro SP tlačítko.

Poznámka

Pokud pověřovací SharePoint nejsou "všechny uložené" pro mapování (y) pak Přihlášení do dialogu SharePoint s dotazem pro Site URL, Uživatelské jméno a / nebo Heslo.Prosím, zadejte je. Dále bude synchronizace žádné jiné mapování, které jsou požadovány pro připojené komponenty / vyhledávací sloupce. Jakékoliv další mapování, které jsou automaticky zahrnuty budou zobrazeny v dialogu dle níže.

6. Na úspěšnou synchronizaci se objeví dialogové okno Výsledky SharePoint Sync, jak je uvedeno níže seznam změn a varování. Klepněte na tlačítko Dobře.

Poznámka

ABACUS bude aktualizovat SharePoint sloupců s prázdnými hodnotami, i když "Požadovat, aby tento sloupec obsahuje informace" je nastavena na hodnotu Ano v SharePoint. Důvodem je, že SharePoint nevystavuje toto nastavení externě. Pokud je to třeba zabránit je doporučeno, že ABACUS Designer nastaví Požadované omezení na hodnotu true a uplatňuje daném pozemku pomocí Abacus " nátlak rys .

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Naplnění vaší architektury od aplikace Visio | Naplnění vaší architektury z aplikace Excel


Naplnění svou architekturu od Microsoft SQL Server

Navigace: Naplnění vaší architektury> Naplnění z produktů společnosti Microsoft>

Naplnění svou architekturu od Microsoft SQL Server

Odeslat připomínky na toto téma.

Můžete importovat architekturu z databáze Microsoft SQL Server. Máte na výběr jen importovat tabulky a vztahy ve skutečnosti dovážejí pouze obecný strukturu databáze a tabulek, řádků a vztahů, které se dovážejí nejen strukturu, ale data stejně.

Poznámka

Od SQL Server funkce vyžaduje, Microsoft SQL Server 2005, 2008, 2008 R2, 2012 nebo 2014je nainstalován v počítači.

Chcete-li importovat databázi serveru Microsoft SQL do ABACUS

1. Zkontrolujte, zda máte ABACUS otevřený.

2. Vyberte File | Nové a vyberte Od SQL Serverz dialogu, který se objeví, a klikněte na tlačítko OK.

3. V dialogovém okně Importovat SQL Server, který se objeví nastavit "název_počítače" a hodnoty "SQLINSTANCE 'řetězce připojení proměnné a hodnota" dbname "v Název databáze proměnné na jejich správné hodnoty, jak je uvedeno v ukázkovém snímku níže.

4. Nastavit Database název proměnné na stejnou hodnotu jako je počáteční katalog proměnné stanovené v kroku výše, jak je uvedeno ve vzorku snímku níže.

5. Stiskněte tlačítko Test spojení a tabulky importovat část dialogu by měl být naplněn dostupných databázových tabulek, jak je uvedeno v ukázkovém snímku níže.

6. Vyberte tabulky, které chcete importovat buď jednotlivě, nebo pomocí vyberete All, None a obraťte tlačítek napravo v dialogu.

Poznámka

Pouze klíčové vztahy Zahraniční které existují mezi stoly, které vyberete dostane importována.

7. Pomocí přepínač Importovat styl vyberte, zda chcete importovat jen ty tabulky a vztahy mezi nimi, nebo tabulkách, jejich řádky a konkrétních vztazích mezi řádky.

Poznámka

První možnost importuje tabulky jako komponenty typu "tabulky" a vztazích mezi jakýmikoli dvěma tabulkami (z cizí klíče) jsou importovány jako spojení typu "Tabulka Relation". Jedná se o klasický "ERD" styl pohled systémových tabulek. Druhá možnost importuje řádky tabulky jako jednotlivé dílčí komponenty typu "řádku tabulky" s vlastnostmi odpovídajícími jednotlivé sloupce / pole a vztahy mezi řádky tabulky typu "Tabulka Relation". Kromě toho, pokud je sloupec / pole s názvem "Jméno" pak se používá pro pojmenování jednotlivých řádek tabulky dílčí komponenty.

8. Vyberte ... tlačítko Import.

9. Po krátkém čase (s barem pro zpětnou vazbu o pokroku), bude nový projekt ABACUS být vytvořen s tabulkami, řádky tabulky (v případě, že druhá možnost byla vybrána v kroku výše) a vztahy z databáze Microsoft SQL Server.

Viz také

Naplnění vaší architektury - Přehled | Naplnění vaší architektury ručně | Naplnění vaší architektury od aplikace Visio | Naplnění vaší architektury z aplikace Excel


Přidání přednastavených vlastností komponentní, připojení nebo typu

Navigace: Naplnění vaší architektury> Vlastnosti>

Přidání přednastavených vlastností komponentní, připojení nebo typu

Odeslat připomínky na toto téma.

Standardní knihovny nemovitostí mohou být specifikovány a přiřazeny k něčemu jinému v architektuře. Tyto knihovny jsou známé jako Normy, Používáním Normy, Jen je třeba shromáždit specifické systémy vlastnosti - standardní vlastnosti jsou již tam.

Například standardní výkonové charakteristiky systému Microsoft Windows 2000 lze uložit jako Normaa přidělen k libovolné součásti (nebo spoje, ne že by to bylo typické) používáte operační systém Microsoft Windows 2000.

Chcete-li přidat normado složky, připojení nebo typu

1. Klikněte pravým tlačítkem myšina konstrukční části / připojení / typu.

2. Vybrat Přiřadit Norma.

3. Vybrat A Normaze seznamu.

Viz také

Naplnění vaší architektury - Přehled | Změna vlastností komponenty, připojení nebo typu | Souhrnné vlastnosti


Změna vlastností komponenty, připojení nebo typu

Navigace: Naplnění vaší architektury> Vlastnosti>

Změna vlastností komponenty, připojení nebo typu

Odeslat připomínky na toto téma.

Vlastnosti jsou typicky systémové požadavky, které definujete, nebo výsledky hodnocení Abacus '. (Když ABACUS plní své hodnocení, zapíše vlastnosti zpět do souboru). Jinými slovy, vlastnosti jsou věci, které vědět o vašem systému, nebo věci, které se používají Abacus zjistit.

Chcete-li změnit hodnotu vlastnosti komponenty, připojení nebo typu

1. Klepněte na tlačítkona konstrukční části / připojení / typ (její vlastnosti se zobrazí v okně Vlastnosti vpravo).

2. Klepněte na tlačítkooznačte vlastnost, kterou chcete změnit.

3. Typnová hodnota.

Důležitý

Také, mnoho vlastnosti jsou definovány pomocí Normy , Změnou nemovitosti do jiného Norma, Můžete nejen změnit aktuální objekt, můžete také změnit pána Norma (pod Norem nav horní části stromu). Než to uděláte, zkontrolovat, co ostatní komponenty, přípojky nebo typy používáte Norma, Protože změna nemusí být relevantní pro ně- Můžete použít okno odkazy na toto.

Tip

Můžete měnit vlastnosti připojení zv rámci pobočky složek stromu (a naopak). Tak například, pokud se díváte na to, co spoje jsou připojeny ke komponentě, a uvědomíte si, musíte změnit jeden, můžete.

Chcete-li přidat nové vlastnosti komponenty nebo připojení (prostřednictvím typu)

Poznámka

Vlastnosti lze přidat pouze na typy a složky nebo spojení typu "zdědí" tyto vlastnosti.

1. Klepněte na tlačítkotypu (jeho vlastnosti se zobrazí v okně Vlastnosti vpravo).

2. Klepněte na tlačítkona tlačítko Přidat v horní části okna vlastností přidat řádek v horní části vlastností sítě pro novou vlastnost.

3. Přidat Typpro nové vlastnosti.

4. Přidat Jménopro nové vlastnosti.

5. Přidat Výchozí hodnotapro nové vlastnosti.

6. Přidat Jednotkapro nové vlastnosti.

7. Nastavení Datový typpro nové vlastnosti.

Poznámka

Datový typ pole lze použít k omezení platné hodnoty, že nemovitost může mít. To je; Text, Integer, desítkové, datum / čas, Boolean nebo List.

o A Textvlastnost je ten, který má neomezený počet znaků, a v podstatě nemá žádné omezení na hodnotu.Pokud je hodnota vlastnosti je správně vytvořený hypertextový odkaz (tj URL je třeba začít s jedním z 5řetězce; http: //, https: //, ftp: //, soubor:nebo \\ a jakékoliprostory by měly být zadány s '% 20'), Pak je odkaz kliknout (přes CTRL + kliknutí).

o Celé číslonemovitost musí být celou řadu buď pozitivní, nebo negativnía mohou obsahovat tečku, mezeru, apostrof nebo čárka pro seskupování číslic v závislosti na projektu Nastavení regionu z Soubor | Možnosti projektu.Nastavení kraje a.Síť Metoda Long.TryParse je použita pro určení platnosti Celé čísloHodnoty.

o A Desetinnývlastnost může obsahovat období nebo čárka pro symbol desetinné čárky a mohou obsahovat tečku, mezeru, apostrof nebo čárka pro seskupování číslic v závislosti na projektu Nastavení regionu z Soubor | Možnosti projektu.Nastavení kraje a.Síť Metoda Decimal.TryParse je použita pro určení platnosti Desetinný Hodnoty.

o A Datum Časvlastnost umožňuje buď část data nebo doby část nebo obojí. RegionNastavenía .NET Metoda DateTime.TryParse jsou primárně využívány pro stanovení platné datum a / nebo časové hodnoty. Date však část případně vyžaduje alespoň den a měsíc (rok bude považovat za aktuální rok) nebo měsíc a rok součásti platná. Tj. Června Q3 2010, nebo dokonce jen 2010 jsou neplatné. I když to bude lišit s různými místní nastavení, typicky den, měsíc a rok části mohou být odděleny mezerou, čárkou, čárka ("-"), nebo lomítkem ("/"). Část Day typicky je celé číslo od 1 do 31. Měsíc část je typicky celé číslo od 1 do 12, platný 3 zkratka dopisu za měsíce (např Led, únor, březen), nebo, je název celý měsíc (např leden, únor , Pochod). Rok část je typicky kladné číslo 4 číslice, ale 1, 2 a 3 roky číslice jsou přijímány podle nastavení v Ovládací panely-> místní a jazykové Options> Regionální Options> Úprava (tlačítko) -> Date- datum> Kalendář. Typicky oni jsou interpretovány následovně; 0-29 je interpretován jako 2000-2029, 30 až 99, jako 1930-1999 a 100-999 jako 100-999. Bude detekována neplatná data, jako je 31. června 2010 a 31/9/2010. The Time část případně vyžaduje hodinách a minutách část a případně Seconds část. Hodiny, minuty a volitelné Sekundy díly jsou obvykle odděleny s dvojtečkou (":") a Seconds část může být zadán s desetinné čárky ('.'). Další informace o platných formátech naleznete v části poznámky na rozhraní .NET Metoda DateTime.TryParse .

Tip

Doporučuje se použít alespoň 3 dopis název měsíce ve formátu (tj "července" nebo "července") pro hodnoty data spíše než číselné formátování (tj "7" nebo "07"), protože tyto hodnoty bude ověřovat přes většinu regionů v závislosti na projektu Nastavení regionu z Soubor | Možnosti projektu. Tj. je doporučeno použít "15 Čer 2010" spíše než "15/7/2010" nebo "7/15/2010". U tohoto příkladu, "15/7/2010" by nezdaří potvrzení pro "Angličtina (USA)" a "7/15/2010" by nezdaří na "angličtinu (Spojené království)", nicméně "15 Čer 2010" by se vydávat za obě.

o A Booleanmajetek může být buď true nebo false.Je to malá a velká písmena, takže TRUE nebo FALSE mohou být také použity však ano, ne, 1, 0 atd bude vše selže jakákoli omezení vlastnictví.

o A Seznamvlastnost umožňuje sbírku přednastavených hodnot jako je nízká | Střední | Vysoký nebo Zachovat | Obnovit | Redesign | Důchodu a rozsah hodnot pochází z pole Unit pro vlastnost buď jako čárka nebo potrubí '|' oddělené hodnoty. Vlastnost může být považován za pořadový (na rozdíl od jmenovité, intervalu nebo poměr), protože při použití na grafech a vybarvovat prvky, na diagrams a 3ds hodnoty jsou ošetřeny pouze v vzestupně nebo sestupně) (objednávky. To je hodnoty jsou vyneseny ve vzestupném (nebo sestupně) pořadí na grafu os nebo barevného rozsahu.

8. Datový typ lze nastavit, aby se Zakázáno, Varoval nebo Vynucenýklepnutím pravým tlačítkem myši na pole Typ dat pro jakékoli jiné nastavení než text, který umožňuje žádné znaky, takže nemůže nikdy být nesprávné.

9. Nastavení Požadovanýpříznak pro nové nemovitosti.

Poznámka

Požadovaná pole může být používán k označení, zda hodnota je třeba zadat pro vlastnost. To znamená, že to nemůže být prázdné nebo prázdný. Falešnýje výchozí a znamená, že nemovitost může být prázdný nebo prázdné, Pravdaznamená, že majetek by měl mít hodnotu a nemůže být prázdná nebo prázdné. Na požadovanou může být nastavena tak, aby Zakázáno, Varoval nebo Vynucenýklepnutím pravým tlačítkem myši na pole Povinné, pokud byl nastaven na hodnotu TRUE.

Viz také

Naplnění vaší architektury - Přehled | Přidání přednastavených vlastností komponentní, připojení nebo typu | Souhrnné vlastnosti


Změna nastavení regionu na projekt

Navigace: Naplnění vaší architektury> Vlastnosti>

Změna nastavení regionu na projekt

Odeslat připomínky na toto téma.

Majetkové hodnoty vyžadují určité formátování v různých oblastech, aby odpovídaly jakýkoli Typ dat omezení pro Integer, desítkové a datum / čas Vlastnosti. Například v Austrálii desítkové "123456 bod Sedm Osm Devět" je reprezentován jako "123,456.789", zatímco v Německu to bylo by zastupovali jako "123.456,789", a ve Francii, že by bylo " 123 456789 ".Podobně, v USA "Druhý z prosince 1970" je reprezentován jako krátké datum jako "12/2/1970", ale ve Spojeném království je zastoupena jako "2/12/1970", a v Polsku jako "1970 - 1912 -02 ". V souladu s tím pracovat s projektem ABACUS napříč regiony je nutný globální nastavení na projekt ABACUS.

Změnit nastavení regionu projektu Abacus

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Vybrat Soubor | Možnosti projektu ... a z dialogového okna, které se objeví vyberte Kraj a klepněte na tlačítko OK, Poznámka: Viz níže pro regionální výchozí sekce.

Poznámka

Pokud nevidíte Možnosti projektu ... položka menupak nemáte Designer a Administrator doplněks a nemůžete změnit region projektu.Také, pokud žádný region nastaven (tj kraje v možnosti projektu je "None (System region)"), pak každý Nastavení aktuální kultura MS Windows uživatele (tj Regional Settings)jsou používány k ověření vlastností.

Region výchozí

V následující tabulce jsou uvedeny výchozí hodnoty pro každý region, jak nastavit pomocí Soubor | Možnosti projektu ...položka menu.Pro seznam použitých symbolů Prosím, viz níže uvedená tabulka.

Kraj | Desetinné Symbol | Digit seskupení | Záporné znaménko | Krátká doba | Dlouho | AM / PM symbol | Short Date | Long Date
Angličtina (Austrálie) | . | , | - | Hh: mm | HH: mm: ss | AM | ODPOLEDNE | dd / MM / YYYY | dd MMMM yyyy
Angličtina (Spojené království) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / MM / YYYY | dd MMMM yyyy
Angličtina (Spojené státy) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / rrrr | dddd, MMMM dd, yyyy
Francouzština (Francie) | , | plocha | - | Hh: mm | HH: mm: ss | | | dd / MM / YYYY | dddd MMMM d rrrr
Němčina (Německo) | , | . | - | Hh: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM rrrr
Italian (Italy) | , | . | - | Hh: mm | HH: mm: ss | | | dd / MM / YYYY | dddd MMMM d rrrr
Španělština (Španělsko) | , | . | - | H: mm | H: mm: ss | | | dd / MM / YYYY | dddd, dd "de" mmmm "de 'yyyy
Angličtina (Kanada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / MM / YYYY | MMMM-dd-yy
Francouzština (Kanada) | , | plocha | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM rrrr
Arabština (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / YYYY | dd MMMM, rrrr
Arabština (Saúdská Arábie) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / yy | dd / MMMM / rrrr
Angličtina (Jižní Afrika) | , | plocha | - | hh: mm tt | hh: mm: ss tt | AM | PM | YYYY / MM / dd | dd MMMM yyyy
Angličtina (Nový Zéland) | . | , | - | h: mm tt | h: mm: ss tt | A. M. | p.m. | d / MM / YYYY | dddd, MMMM d rrrr
Angličtina (Indie) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd-MM-YYYY | dd MMMM yyyy
Němčina (Švýcarsko) | . | ' | - | Hh: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM rrrr
Francouzština (Belgie) | , | . | - | Hh: mm | HH: mm: ss | | | d / MM / YYYY | dddd MMMM d rrrr
Dutch (Belgie) | , | . | - | H: mm | H: mm: ss | | | d / MM / YYYY | dddd MMMM d rrrr
Česká (Česká republika) | , | plocha | - | H: mm | H: mm: ss | dop. | odp. | d.M.yyyy | d. MMMM rrrr
Dánština (Dánsko) | , | . | - | Hh: mm | HH: mm: ss | | | dd-MM-YYYY | d. MMMM rrrr
Řecký (Řecko) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / rrrr | dddd, MMMM d rrrr
Finský (Finsko) | , | plocha | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'yyyy
Hungarian (Maďarsko) | , | plocha | - | H: mm | H: mm: ss | de. | du. | yyyy.MM.dd. | rrrr. MMMM d.
Dutch (Netherlands) | , | . | - | H: mm | H: mm: ss | | | d-M-yyyy | dddd MMMM d rrrr
Norština, Bokmål (Norsko) | , | plocha | - | Hh: mm | HH: mm: ss | | | dd.MM.yyyy | d. MMMM rrrr
Polish (Poland) | , | plocha | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM rrrr
Ruská (Rusko) | , | plocha | - | H: mm | H: mm: ss | | | dd.MM.yyyy | d MMMM rrrr "г."
Švédština (Švédsko) | , | plocha | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | "den" d MMMM rrrr
Korean (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | yyyy-MM-dd | YYYY "년 'M' 월 'd' 일" dddd
Hebrejština (Israel) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / MM / YYYY | dddd MMMM dd yyyy

Následující symboly se používají k určení, jak jsou zobrazeny data a časy:

Časové symboly |
h | Hour (hh zobrazuje hodiny s nulou na začátku)
m | Minute (mm zobrazuje minutu s nulou na začátku)
s | Druhý (ss zobrazuje na druhém místě s nulou na začátku)
tt | DOPOLEDNE. nebo P.M.
h / H | 12 nebo 24 hodin zobrazení času
Datum symboly |
d, dd | Den
ddd, dddd | Den v týdnu
M | Měsíc
y | Rok

Viz také

Naplnění vaší architektury - Přehled | Změna vlastností komponenty, připojení nebo typu | Přidání přednastavených vlastností komponentní, připojení nebo typu


Souhrnné vlastnosti

Navigace: Naplnění vaší architektury> Vlastnosti>

Souhrnné vlastnosti

Odeslat připomínky na toto téma.

Operace "Aggregate Vlastnosti"Vám umožní přidat hodnoty podobnými vlastnostmi spolu a psát (nebo přidat) výsledek do vlastností zvoleného rodičovského elementu je. To také umožňuje definovat rozsah agregace a zda aktualizovat vlastnosti všech dílčích prvků nebo ne.

Chcete-li souhrnných vlastnostech

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Klepněte pravým tlačítkem myši na prvek (architekturu, součást nebo spojení), ve kterém k tomu agregace a vyberte Souhrnné Properties.

3. Vyberte si jednu z možností Souhrnné (Traverse všech podúrovní nebo Pouze Direct Sub-Level). Pokud jste zvolili Traverse všech podúrovní, Můžete také zvolit možnost, zda se má Aktualizace podúrovní.

o Traverse všech podúrovníZnamená to, že rozsah agregace bude obsahovat prvky ve všech úrovních pod Vámi vybraného prvku.

o Aktualizace podúrovnímůže být provedeno pouze tehdy, pokud jste také vybrali možnost Traverse všech podúrovní, To znamená, že zatímco agregovat vlastnosti od zdola nahoru, souhrnným výsledkem na každém stupni se také aktualizuje do každého z příslušných prvků.

o Pouze Direct Sub-LevelZnamená to, že pouze vlastnosti prvků přímo pod vybraný prvek bude sčítat.

o Vybrat Patří NormaVlastnostiPokud chcete, aby vlastnosti definované v Normy které mají být zahrnuty. V opačném případě bude použit pouze vlastnosti specifické pro každou instanci komponenty.

4. Vyberte si, které vlastnosti chcete agregovat. Ty jsou seskupeny do jejich Druhy.

5. Klepněte na tlačítko Další tlačítko.

6. Zvolte možnost, zda se má Přepsat Hodnoty nebo Přidejte hodnotydo vybraný prvek.

o Přepsat Hodnotyzapíše výsledky přímo do vlastností vybraný prvek.

o Přidejte hodnotypřidá výsledky do stávajících vlastností vybraný prvek.

Viz také

Přidání přednastavených vlastností komponentní, připojení nebo typu | Změna vlastností komponenty, připojení nebo typu | Vyhodnocení vaší architektury


Analýza vaší architektury

Navigace: Analýza vaší architektury>

Analýza vaší architektury

Odeslat připomínky na toto téma.

Poté, co jste obydlený (a volitelně simulované) vaší architektury, jste připraveni k použití Abacus analyzovat. Tím, že analyzuje, můžete zjistit, zda váš architektura bude vyhovovat vašim potřebám.

Lze analyzovat architektury v mnoha různými způsoby:

· Diagram

· 3D pohled

· standardní grafy (koláč, řádek, sloupec, bar, atd.)

· vlastní grafy ( Doba odezvy , Schopnost prostor , hvězda plot , Scatterplot matice a bublina graf )

· Architektura Diff

Poznámka

Při vytváření diagramu, 3D pohled, Zpráva nebo standardní grafu, okno pro výběr standardním prvkem slouží k výběru prvků, které chcete zobrazit.

Viz také

Naplnění vaší architektury | Simulace vaší architektury | Diagramů Nástroj


Standardní výběr Element

Navigace: Analýza vaší architektury>

Standardní výběr Element

Odeslat připomínky na toto téma.

Při vytváření diagramu, 3D pohled, zpráva,standardní schémanebo spuštění simulace, Standardní výběr prvek okno slouží k výběru prvků, které chcete analyzovat / pohled.

Okno Standardní Selection Element

Stahování kladky

· Filtr by Výhled bude patří prveks z dříve uloženého pohledu (tj diagram, graf, 3D). Tímto způsobem můžete provádět složité "připojit" dotazů ošetřením další pohled jako uložený "dotaz '.

Checkboxes

· Zobrazit Úrovněbude skupina prvek v závislosti na úrovni, která se vyskytují ve stromu. Úroveň 1 je nejvyšší nejvíce úrovni.

· Zobrazit Druhybude skupina prvky podle typů, které jsou.

· Rodiče vybránabude obsahovat nadřazené složky veškerých vybraných prvků. Tímto způsobem můžete zajistit, že pouze hierarchie výše případných dětí budou zahrnuty na "zdola nahoru" výběru.

· Děti vybránabude patřit dětem složky veškerých vybraných prvků. Tímto způsobem můžete zajistit, že pouze hierarchie pod všemi rodiči budou zahrnuty na "top-down" výběru.

· Jméno zápasy Hodnotabude obsahovat pouze ty prvky, které mají název obsahuje zadaný řetězec (Poznámka: zástupné znaky (tj a *), mohou být použity?). Tímto způsobem můžete tvořit "sémantický" dotaz.

· Má Typ nemovitosti / Název / hodnotabude obsahovat pouze ty prvky, které mají vlastnost typ, název a hodnoty obsahující zadaný řetězec a to buď přímo na prvku nebo na jeho standardech (Pozor prosím:?.? zástupné znaky (tj a *) lze využít např * v poli Hodnota bude dát všechny prvky, které mají neprázdné hodnoty pro danou nemovitostí). Tímto způsobem můžete tvořit "sémantický" dotaz.

· Má standardníbude obsahovat pouze ty prvky, které mají standardní název obsahuje zadaný řetězec (Poznámka: zástupné znaky (tj a *) lze použít např HP * dám všechny prvky s alespoň jednou Standardní začínající písmeny H a P?.). Tímto způsobem můžete tvořit "sémantický" dotaz.

· Komponenty / Připojení připojena do vybranéhobude zahrnovat všechna připojená prvků na ty, které byly vybrány. Tímto způsobem může být vybrána "call-tree" nebo "dopad analýza".

Poznámka

Máte-li oba Zobrazit Úrovně a Zobrazit Druhyvybrána pak si můžete vybrat, zda se strom zobrazují úrovně první nebo typy nejprve tlačítko, které se objeví nad dvěma zaškrtávacích políček.

Tip

Jakmile je vybraná položka v okně standardní výběr Element, nebude podléhat žádným dalším změnám filtru, dokud není zrušen. Protože neexistuje žádný nativní způsob, jak hledat dvěma různými soubory prvků najednou (např komponenty se standardní A nebo standardní B), můžete hledat nejprve v rámci jedné skupiny, vyberte požadované součásti, a poté provést druhou pátrání po druhé sady ,

Tlačítka

· Vševybere všechny elementy.

· Obrátitzruší všechny aktuálně vybrané prvky a vybere všechny ty, které nebyly vybrány.

· Žádnýzruší všechny prvky.

· Přidat filtrvybere výsledný obsah aktuálního nastavení filtru a umožňuje výběr dodatečného obsahu stejně účinně An a nebo se připojit filtr.

Viz také

Analýza vaší architektury


Zobrazení 3D diagram

Navigace: Analýza vaší architektury> 3D diagramy>

Zobrazení 3D diagram

Odeslat připomínky na toto téma.

ABACUS umožňuje zobrazit vaši architekturu jako 3D zobrazení, kde jsou komponenty a připojení vlastnosti spojené s barvami, tvary a velikosti.

Chcete-li zobrazit 3D pohled na vaší architektuře

1. Ujistěte se, že máte otevřete soubor ABACUSobsahující Váš obydlený architektura.

2. Rozbalte Zobrazenívětev stromu.

3. Rozbalte 3Dvětev stromu.

4. Dvojklik Vizualizace chcete otevřít.

- nebo -

1. Ujistěte se, že máte otevřete soubor ABACUSobsahující Váš obydlený architektura.

2. Vybrat Vložit| 3Dnebo klepněte na tlačítko na panelu nástrojů.

3. Otevřete existujícívizualizace (.abacus3d)

- nebo -

1. Ujistěte se, že máte otevřete soubor ABACUSobsahující Váš obydlený architektura.

2. Vybrat Vložit| 3Dnebo klepněte na tlačítko na panelu nástrojů.

3. Vytvoření nové vizualizace:

· Vyberte ArchitekturaChcete-li zobrazit z rozbalovacího menu.

· Vyberte Komponenty a PřipojeníChcete-li zahrnout do schématu z okno pro výběr standardním prvkem .

· Přidružené barvy, tvary a velikosti s Component Druhy a Vlastnosti.

· Přidružení barvy a tvary s Typy připojení a Vlastnosti.

Chcete-li exportovat 3D pohled

1. Ujistěte se, že máte otevřít existující 3D pohled.

2. U roletových nabídek 3D pohledu vybereme Soubor | Vývozní...a vybral umístění a typ souboru pro soubor vizualizace (.abacus3d, .vrml nebo .html).

3. Klepněte na tlačítko Uložit.

Viz také

Analýza vaší architektury | Navigace ve 3D | Diagramů Tool


Navigace ve 3D diagram

Navigace: Analýza vaší architektury> 3D diagramy>

Navigace ve 3D diagram

Odeslat připomínky na toto téma.

ABACUS umožňuje snadno procházet vaší architektury ve 3D. Zážitek je podobný létání. Existují dva režimy navigace:

· Základní ovládací režim (výchozí); a

· Advanced Control Mode - změna do tohoto režimu zvolením Řízení| Mode Control Advanced.

Poznámka

Pro přepínání mezi základní ovládání a pokročilé režimy Control, můžete použít F4klávesové zkratky funkce.

Základní režim ovládání

· Držení levého tlačítka a pohybem myší dopředu nebo dozadu změní hřiště;

· Držení levého tlačítka a pohybem myši doleva nebo doprava změní vybočit;

· Držení pravého tlačítka a pohybem pánve myš názor;

· Uchopte obě tlačítka dolů a pohybem myší dopředu nebo dozadu, přiblíží a ven z architektury; a

· Uchopte obě tlačítka dolů a pohybem myši doleva nebo doprava, rohlíky doleva a doprava.

- nebo -

· Stisknutím Šipka vlevona klávesnici nebo numerické klávesnici bude odbočíme vlevo;

· Stisknutím Šipka dopravana klávesnici nebo numerické klávesnici bude odbočit vpravo;

· Stisknutím Šipka nahoruna klávesnici nebo numerické klávesnici se přiblížíte;

· Stisknutím Down Arrowna klávesnici nebo numerické klávesnici se vzdálíte;

· Stisknutí Page Upna klávesnici nebo numerické klávesnici bude rozteč nahoru; a

· Stisknutí Page Downna klávesnici nebo numerické klávesnici bude nadhazovat dolů.

Mode Control Advanced

· Stěhovánímyš dopředu a dozadu a nahoru a dolů, změní hřiště a vybočit (v tomto pořadí);

· Stisknutí W nebo Šipka nahoruzvětší (vpřed) k architektuře;

· Stisknutí S nebo Down Arrowoddálí (zpětně), od architektury;

· Stisknutí A nebo Šipka vlevorohlíky vlevo;

· Stisknutí D nebo Šipka dopravavalí doprava;

· Stisknutí Q nebo Page Downpovyšuje názor (snížením výhledu); a

· Stisknutí E nebo Page Upsnižuje výhled (tím, že zvýší perspektivu).

Mode Control Interactive

Stisknutím a přidržením klávesu Shiftna klávesnici potlačí aktuální režim (Basic nebo Advanced) pro vstup do režimu interaktivní ovládání. V tomto režimu je možné, doplňuje:

· Váleckurzor myši nad komponentu nebo připojení k vidění součást nebo název připojení je;

· Klepněte na tlačítkona komponenty pro zvětšení na tuto složku;

· Click-a-táhnoutna komponentu otočíte zobrazení kolem tuto složku; a

· Klikněte pravým tlačítkem myšikomponenta nebo připojení a zvolte Zobrazit v Průzkumníkovividět, že komponenty nebo místo připojení v stromu.

Společné kontroly

· Použití ALT-ENTER / ESCpro přepnutí do režimu celé obrazovky;

· Použití F2změnit režim zobrazení. To může být také přístup přes Pohled Menu.

· Použití kolečkem myši nebo +/-pro změnu rychlosti. Rychlost je označen číslem v levém dolním rohu - zobrazí pouze v případě, že se mění. 1 je nejpomalejší a 100 je nejrychlejší.


Zobrazení standardní graf

Navigace: Analýza vaší architektury> Standardní grafy>

Zobrazení standardní graf

Odeslat připomínky na toto téma.

Standardní grafy Abacus 'patří linka, bar, sloupec, oblast, rozptyl, koláč, křivka, Pareto, krok, povrch, radar, krychle, koblihy, pyramidy, kontury a křivka plochy grafů. Jakmile jste si vybrali typ grafu, který chcete, zbytek procesu pro prohlížení každý z těchto grafů je stejný.

Chcete-li zobrazit standardní graf vaší architektuře

1. Ujistěte se, že máte otevřete soubor ABACUSobsahující Váš obydlený architektura, A že máte hodnocenoVaše architektura.

2. Vybrat Vložit| Schémanebo klepněte na tlačítko na panelu nástrojů. Grafyse zobrazí okno.

Okno Grafy

3. Vyberte typ grafu, který chcete a nastavit Možnosti grafu, pak klepněte na tlačítko Další.

Možnosti Graf

o Skládanýukáže vztah jednotlivých položek k celku. Můžete použít skládaný graf, když máte v plánu na více datových řad (tj více vlastností) a chcete-li zdůraznit celkem.

o Skládaný 100%porovná procento je každá hodnota přispívá k celkově přes kategorií. Můžete použít 100% skládaný graf si, když máte v plánu na více datových řad (tj více vlastností) a chcete-li zdůraznit příspěvky do celku, a to zejména v případě, že celková je stejná pro každý prvek.

o 3D grafjednoduše zobrazit datových bodů ve formátu 3-D pro estetiku. Chcete-li zobrazit datové řady podél rozměru 3rd / osa Z a pak použijte volbu Series clusteru popsané níže.

o Řada majetkemzobrazí datové řady pro každou vlastnost, která je nakonec vybrán. Pokud je to Nekontrolovaná pak vlastnosti budou kategorie a datové řady bude pro každý prvek, který je vybrán.

o Otočit Chartbude otáčet grafem o 90 stupňů doprava záměnou os x a y. Tato možnost je k dispozici pouze pro Lines, STEP a Cube grafya je zvláště vhodný pro výrobu Milestone grafy, jak je popsáno v druhém hrotu níže, Poznámka: Sloupec a sloupcové grafy již 'otáčí' verze navzájem.

o Řada Clusterzobrazí více datových řad podél rozměru 3rd / osa Z. Tato možnost je k dispozici pouze pro sloupce, bar a Cube grafya je zvláště vhodný pro výrobu Ganttovy stylu grafy, jak je popsáno v první Tip níže.

Tip

Můžete si vytvořit Ganttův diagrams vodorovnými pruhy zobrazující čas / datum vlastnosti různých prvků výběrem typu sloupcový graf a potom vybráním volby Series Cluster,Kromě toho, jakmile vytvořil, nejvíce vlevo bar na grafu může být "neviditelný" zbarvením ji bílou klepnutím pravým tlačítkem myši na jednu z tyčí, výběr barva z nabídky, která se objeví, a výběrem levý horní barvu z palety. Navíc hranice pro nejvíce vlevo baru si můžete být "neviditelný" kliknutím pravým tlačítkem myši na jednu z tyčí, výběrem vlastnosti ... a na kartě řady v dialogovém okně, které se objeví měnící pohraniční efektu na Žádný a Barva na začátek -left barvu z palety.

Tip

Můžete si vytvořit Milestone grafs malými tvary ukazující čas / datum vlastnosti různých prvků výběrem typu grafu Cube a výběrem Otočit Chart a možnosti řady Cluster,Kromě toho, jakmile vytvořil, kostky lze změnit na jiných tvarů kliknutím pravým tlačítkem myši na jednu z kostek v dané datové řady a výběrem vlastnosti ... a na kartě řady v dialogovém okně, které se objeví Změna Bar buď válce nebo kužele , Poznámka: Šířka hodnota Gap může být také použit na "smršťovací" symbolů na grafu snížit překrývání, čím vyšší je číslo, tím menší překrývající se bude.

4. V Architekturyoddíl, zaškrtněte architektura / s, kterou chcete zmapovat vlastnosti na úrovni architektury pro, pak klepněte na tlačítko Další.

Poznámka

Volba vlastností úrovni architektury je zcela volitelný krok a měly by se používat pouze v případě, že chcete explicitně zmapovat vlastnosti sám úrovni architektury.Architektura, nemusí být zvoleny tak, aby pak uvádět komponent nebo připojení vlastnosti v dalším kroku.

5. Vyberte Komponenty a Připojeníkteré chcete v grafu podaná okno pro výběr standardním prvkem , Pak klepněte na tlačítko Další.

6. Vyberte VlastnostiChcete v tabulce a klikněte na tlačítko Dokončit.

Možnosti Graf

o Zahrnout standardní vlastnosti bude ukazují děděné vlastnosti od norem jsou k dispozici pro výběr.

o Souhrnné Properties bude počítat rozptyl mezi hodnotami řady a zmapovat tyto výsledky na rozdíl od jednotlivých hodnot sami.Tato volba je dostupná pouze v případě, byla vybrána řada možností vlastnictví od v kroku 3 výše.

Tip

Vlastnosti k dispozici pro zmapování závisí na prvky, které vyberete.

Chcete-li uložit graf

Poznámka

Grafy lze uložit pouze tehdy, pokud obsahují pouze komponenty a přípojky, z nichž všechny musí být z jedné architektury v rámci aktuálního projektu.

1. Ujistěte se, že máte novou nebo stávající graf otevříta vy jste provedli nezbytné změny.

2. Na panelu nástrojů grafu klikněte na zcela vlevo Save ChartTlačítko pro uložení graf a všechny změny formátování.

3. V Graf Názevdialogové okno, které se objeví zadejte název pro graf a stiskněte Dobře.

Chcete-li exportovat graf

1. Ujistěte se, že máte existující schéma otevřít.

2. V panelu nástrojů graf klikněte na 2. zleva Uložit jako BMPTlačítko a vybral místo pro graf.

3. Klepněte na tlačítko Uložit.

Viz také

Analýza vaší architektury | Zobrazení doba odezvy graf | Zobrazení schopnost prostor graf


Zobrazení schopnost prostor graf

Navigace: Analýza vaší architektury> Vlastní grafy>

Zobrazení schopnost prostor graf

Odeslat připomínky na toto téma.

Schopností Space graf umožňuje zobrazit, zda váš architektura splňuje požadované schopnosti systému s ohledem na vlastnosti zjištěné během procesu analýzy požadavků systému.

Chcete-li zobrazit schopností prostor graf

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura, A že máte hodnocenoVaše architektura.

2. Vybrat Vložit| Schéma| Vlastní Charts| Schopnost Space, (THE Schopnost Space Graf Configdialog se zobrazí.)

3. V Architekturyoddíl, zaškrtněte architektury, které chcete grafu, pak klepněte na tlačítko Další.

4. V VlastnostiOblast, zaškrtněte architektonické vlastnosti byste rádi zahrnuty jako osy grafu.

5. V Schopnostprostor pro každou majetku zahrnutého z předchozího kroku, vyberte, zda některý minimální nebo maximální limity schopností existují a hodnoty těchto limitů. Výchozí hodnoty jsou minimální a maximální hodnoty vyhodnocené za architektur, nebo Cílem pro vlastnost v případě, že byl nastaven.

Chcete-li exportovat schopností prostor graf

1. Ujistěte se, že máte existující Schopnost prostor graf otevřít.

2. Na panelu nástrojů grafu klikněte na zcela vlevo Uložit jako BMPTlačítko a vybral místo pro graf.

3. Klepněte na tlačítko Uložit.

Viz také

Analýza vaší architektury | Zobrazení doba odezvy graf


Zobrazení doba odezvy graf

Navigace: Analýza vaší architektury> Vlastní grafy>

Zobrazení doba odezvy graf

Odeslat připomínky na toto téma.

Dobou odezvy graf umožňuje zobrazit, zda vaše připojení jsou zpracovávány na požadované rychlosti (tj v rámci své lhůtě).

Chcete-li zobrazit dobu odezvy graf

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura, A že máte hodnocenoVaše architektura.

2. Vybrat Vložit| Schéma| Vlastní Charts| Doba odezvy, (THE Doba odezvy Graf Configdialog se zobrazí.)

3. Z Architekturyrozevíracím seznamu vyberte architekturu, kterou chcete do grafu.

4. V PřipojeníOblast, zaškrtněte připojení byste rádi zahrnuty v tabulce.

5. Scale Typeoblast, vyberte Lineárnípokud chcete, aby svislé osy (doba odezvy), který má být zobrazen jako lineární průběh - každý segment času je přidělen stejný podíl osy. Vybrat Logaritmicképokud chcete zobrazit jako logaritmické progrese - každý segment osy představuje stále delší dobu čím vyšší nahoru ose jdete. (Rychlost nárůstu určí podle Bázesi vyberete.)

Doba odezvy graf svislé měřítko osa

Chcete-li exportovat dobou odezvy graf

1. Ujistěte se, že máte existující doba odezvy graf otevřít.

2. Na panelu nástrojů grafu klikněte na zcela vlevo Uložit jako BMPTlačítko a vybral místo pro graf.

3. Klepněte na tlačítko Uložit.

Viz také

Analýza vaší architektury | Zobrazení schopnost prostor graf


Zobrazení hvězda spiknutí svých vyvinutých architektur

Navigace: Analýza vaší architektury> Vlastní grafy>

Zobrazení hvězda spiknutí svých vyvinutých architektur

Odeslat připomínky na toto téma.

Jakmile je architektura byla vyvinula a cíle jsou definovány, pak lze vizualizovat a ve srovnání s původní architektury použití hvězdicových grafy. Tato část popisuje, jak vytvořit a manipulovat s hvězda spiknutí.

Chcete-li zobrazit hvězdy spiknutí svých vyvinutých architektur

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Ujistěte se, že máte vyvinuly a stanovených cílůpro vaši architekturu, jak je uvedeno v Vyvíjející vaší architektury

3. Vybrat Vložit| Schéma| Vlastní ChartsZáložka | Hvězda Plot.

4. Klikněte na Dokončit tlačítko.

5. Hvězda Plots vyvinutými architektury a nastavení se zobrazí cíle. Poznámka: Osy hvězdy pozemku lze přemístit klepnutím a tažením os do jiné oblasti v mezích hvězdné kvality plot prostoru.

Poznámka

Oblast na levé straně hvězdy pozemku ukazuje nastavení hvězdy pozemku zobrazené. To zahrnuje architekturu, která byla se vyvinul (v tomto případě "ABC Ltd As-Is 2010"), Stejně jako cíle, které byly stanoveny pro tuto architekturu. Budete na vědomí, že cíle, které mají zatržítkem vedle nich jsou reprezentovány jako osy hvězdy pozemku (např KPI- Náklady, KPI - kvalita a KPI - Time). Můžete zrušte zaškrtnutí těchto cílů na každém okamžiku k jejich odstranění z hvězdného pozemku.

Červená a zelená "tečky", které se objeví na vašem hvězdy pozemku představují normalizovanou hodnotu, jak je stanoveno v nejlepší a nejhorší hodnota (uvedeno pod Stanovení cílů pro váš vyvinul architekturu ) Pro zvolenou architekturu nejvyšší úrovni a na všech vývojem toho. Tyto hodnoty jsou zastoupeny v Kvalita Space.

Jak je uvedeno na obrázku výše, je jasně vidět, že původní architektury (As-Is 2.010) Má špatnou Náklady, Zatímco první vyvinul možnost (To-Be 2011 - strategii pro) Se přestěhovala do kvality prostor pro zlepšení Náklady, Kvalita a Timecílů. Alternativně, druhá možnost se vyvinul (To-Be 2011 - Strategie B), zatímco to také zlepšila Náklady velikost zlepšení je menší než u Strategie A ale oba cíle kvalitě a termínu byly zlepšeny více než u strategie A.V tomto případě architekt smět vybrat Strategii pro přes Strategie Bjako jejich doporučenía dále rozvíjet tuto možnost (To-Be 2012 - Strategie A).

6. Zrušte Zobrazit Evolutionspolíčko skrýt řádek (y), což představuje vývoj (y) mezi původní (např As-Is 2.010) A vyvinuly (např. To-Be 2011 - StrategieA) architektura (y).

7. Vyberte Zobrazit Stickspolíčko pro zobrazení relativní velikost každého atributu kvality (cíle, které byly definovány na každé osách) pro každou architekturu.

8. Vyberte Zobrazit Architektura jménaZaškrtněte políčko, chcete-li jména původního a vyvinula se architektury (y) se objeví na hvězdy pozemku.

Viz také

Analýza vaší architektury | Zobrazení doba odezvy graf | Zobrazení Scatterplot matici vašich vyvinutých architektur | Vyvíjející vaší architektury


Zobrazení bodový graf vašich vyvinutých architektur

Navigace: Analýza vaší architektury> Vlastní grafy>

Zobrazení bodový graf vašich vyvinutých architektur

Odeslat připomínky na toto téma.

Jakmile je architektura byla vyvinula a cíle jsou definovány, pak lze vizualizovat a ve srovnání s původní architekturou pomocí Scatterplot matic. Tato část popisuje, jak vytvořit a pochopit charakteristiky Scatterplot matice.

Chcete-li zobrazit Scatterplot Matrix vašich vyvinutých architektur

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Ujistěte se, že máte vyvinuly a stanovených cílůpro vaši architekturu, jak je uvedeno v Vyvíjející vaší architektury

3. Vybrat Vložit| Schéma| Vlastní ChartsZáložka | Scatterplot Matrix.

4. Klikněte na Dokončit tlačítko.

5. Bodový diagrams definovanou vývojem architektur a cílů se zobrazí.

Poznámka

Oblast na levé straně Scatterplot matrice ukazuje nastavení Scatterplot matice zobrazené. To zahrnuje architekturu, která byla se vyvinul (v tomto případě "ABC Ltd As-Is 2010"), Stejně jako cíle, které byly stanoveny pro tuto architekturu. Budete na vědomí, že cíle, které mají zatržítkem vedle nich jsou reprezentovány jako X a Y osy Scatterplot matrice (např KPI- Náklady, KPI - kvalita a KPI - Time). Můžete zrušte zaškrtnutí těchto cílů na každém okamžiku k jejich odstranění z Scatterplot matrice.

Modré tečky, které se objeví na vašem pozemku v matrici představují normalizovanou hodnotu, jak je stanoveno v nejlepší a nejhorší hodnota (uvedeno pod Stanovení cílů pro váš vyvinul architekturu ). Tyto hodnoty jsou zastoupeny v Kvalita Space.

Dva stanovené cíle jsou porovnávány proti sobě v Scatterplot matrici a celý proces se opakuje, až se ve srovnání všechny cíle (např se první typ matrice ve výše uvedeném schématu porovnává KPI - NákladyCílem s KPI - Kvalita fotbalová branka. Druhým je Náklady proti Čas a poslední zápletka je Kvalitní proti Čas, Příslušné Brankové štítky jsou zobrazeny v horní a pravé nebo každý řádek pozemků.).

6. Vyberte Architekturypřepínač, chcete-li zobrazit metriky pro jednotlivé architektury.

7. Vyberte Evolutionspřepínač, pokud chcete zobrazit normalizovaných změny z původní architektury (např As-Is 2.010) Na vyvinutou architektury (y) (např. To-Be 2011 - Strategie A a K-Be 2011 - Strategie B).

Viz také

Analýza vaší architektury | Zobrazení doba odezvy graf | Zobrazení hvězda spiknutí svých vyvinutých architektur | Vyvíjející vaší architektury


Zobrazení bublinový graf

Navigace: Analýza vaší architektury> Vlastní grafy>

Zobrazení bublinový graf

Odeslat připomínky na toto téma.

Bublina graf vám umožňuje porovnat až 5 rozměrů (tj X, Y, velikost bublina / poloměru, bublina barev a bublina hranic barevných), v jednom pohledu.

Chcete-li zobrazit bublina graf

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Vybrat Vložit| Schéma| Vlastní ChartsZáložka | Bubble Graf.

3. V Architekturyoddíl, zaškrtněte architektur (pokud existuje), který chcete mapovat, klepněte na tlačítko Další.

4. Vyberte Komponenty a Připojeníkteré chcete v grafu (pokud existuje) z okno pro výběr standardním prvkem , Pak klepněte na tlačítko Další.

5. Vyberte X-osamajetek, pak klepněte na tlačítko Další.

Poznámka

Pouze Integer, desítkové, datum / čas, Boolean a vlastnosti List může být použit pro osu X. Kromě toho, Integer, desítkové a datum / čas vlastnosti jsou vyneseny zleva doprava podél osy poměru k hodnotě majetku, nicméně, logické a Seznam vlastnosti jsou prostě vyneseny zleva doprava v přesném pořadí (nebo v v obráceném pořadí, pokud je zaškrtnuto možnost obrátit pořadí) definované pro vlastnost bez ohledu na jejich hodnot. Např. Nízký | Střední | Vysoký nebo 1, 2, 4, 8, 16.

6. Vyberte Y-osymajetek, pak klepněte na tlačítko Další.

Poznámka

Pouze Integer, desítkové, datum / čas, Boolean a vlastnosti List mohou být použity k ose Y. Kromě toho, Integer, desítkové a datum / čas vlastnosti jsou vyneseny zdola-to-top podél osy poměru k hodnotě majetku, nicméně, logické a Seznam vlastnosti jsou prostě vyneseny zdola-to-top v přesném pořadí (nebo v v obráceném pořadí, pokud je zaškrtnuto možnost obrátit pořadí) definované pro vlastnost bez ohledu na jejich hodnot. Např. Nízký | Střední | Vysoký nebo 1, 2, 4, 8, 16.

7. Vyberte Velikost bubliny / radiusmajetek, pak klepněte na tlačítko Další.

Poznámka

Pouze Integer, desítkové, Boolean a vlastnosti List mohou být použity pro bubliny velikost / poloměru. Kromě toho, Integer a desetinná vlastnosti vedou k velikosti bubble / poloměru poměru k hodnotě majetku, nicméně, logické a Seznam vlastnosti vedou ve stejném kroku zvyšování bubliny velikost / poloměru v přesném pořadí (nebo v opačném pořadí, pokud možnost obrátit pořadí je zaškrtnuto) definované pro vlastnost bez ohledu na jejich hodnot. Např. Nízký | Střední | Vysoký nebo 1, 2, 4, 8, 16.

8. Zvolte buď pevná bublina barva nebo spojovat nemovitost s bublinovou barvou, Pak klepněte na tlačítko Další.

Poznámka

Pouze Integer, desítkové, Boolean a vlastnosti List mohou být použity pro bubliny barvu. Kromě toho, Integer a desetinná vlastnosti vedou v bublině barev v rámci zvoleného rozsahu poměru k hodnotě majetku, nicméně, logické a Seznam vlastnosti vedou ve stejném kroku zvyšování bubliny barvy v rámci zvoleného rozsahu v přesném pořadí stanoveném pro vlastnost, bez ohledu na jejich hodnot. Např. Nízký | Střední | Vysoký nebo 1, 2, 4, 8, 16.

9. Vyberte buď žádná bublina hranice barva nebo přidružit nemovitost s bublina hranic barvou, Pak klepněte na tlačítko Dokončit.

Poznámka

Pouze Integer, desítkové, Boolean a vlastnosti List může být použit pro bubble hraniční barvu. Kromě toho, Integer a desetinná vlastnosti vyústit v bublinkové barvu ohraničení v rámci zvoleného rozsahu poměru k hodnotě majetku, nicméně, logické a Seznam vlastnosti vedou ve stejném kroku zvyšování bublina barvu ohraničení v rámci zvoleného rozsahu v přesném pořadí definovaných pro vlastnost bez ohledu na jejich hodnot. Např. Nízký | Střední | Vysoký nebo 1, 2, 4, 8, 16.

Bubble graf

Chcete-li uložit bublina graf

Poznámka

Bubble grafy lze uložit pouze tehdy, pokud obsahují pouze komponenty a přípojky, z nichž všechny musí být z jedné architektury v rámci aktuálního projektu.

1. Ujistěte se, že máte novou nebo stávající bublina graf otevříta vy jste provedli nezbytné změny.

2. Na panelu nástrojů grafu klikněte na zcela vlevo Save ChartTlačítko pro uložení graf a všechny změny formátování.

3. V Graf Názevdialogové okno, které se objeví zadejte název bublina graf a stiskněte Dobře.

Chcete-li exportovat bublina graf

1. Ujistěte se, že máte otevřít existující bubliny graf.

2. V panelu nástrojů graf klikněte na 2. zleva Uložit jako BMPTlačítko a vybral místo pro graf.

3. Klepněte na tlačítko Uložit.

Viz také

Analýza vaší architektury


Architektura Diff a synchronizace

Navigace: Analýza vaší architektury>

Architektura Diff a synchronizace

Odeslat připomínky na toto téma.

Pokud máte 2 nebo více architektur, buď jako evoluce nebo základních architektur, můžete vizuálně "diff" dvě architektury s použitím katalog nebo diagram Srovnání nebo Architektura Diff vlastnost. To je zvláště užitečné pro prohlídky / re-objevovat přesné změny z jedné architektuře do druhého, jak jste se vyvíjejí struktury a rozvoj plánů pro ABACUS.

Na zobrazit "diff" s jinou architekturou pomocí diagramu

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Ujistěte se, mít minimálně 2 architektury v projektu.

3. Otevřete diagram, který chcete porovnat na jiné architektuře.

4. Klepnutím na tlačítko "Porovnat Toto schéma na obsah jiného architektury" na panelu nástrojů diagramu.

5. Vyberte jiné architektuře z rozevíracího seznamu srovnávat s.

6. Můžete filtrovat, jaké rozdíly jsou zobrazeny po kliknutí na tlačítko "rozdíly" na panelu nástrojů Diagram a zrušením výběru možnosti, například Změnil / vedlejší / Unknown a Neurčitý / Sync Doporučené/ Mějte Doporučená.

Poznámka

Komponenty a připojení na diagramu budou zvýrazněny červený, zelená nebo nachový tam, kde jsou rozdíly mezi obsahem, který je viditelný na aktuálním diagramem a obsah v druhém architektuře. Červený se používá tam, kde je doporučeno synchronizovat rozdíly (viz níže), Zelená Používá se tam, kde se nedoporučuje synchronizovat rozdíly, které je držet je (viz níže) a Purple se používá pokud ABACUS nelze učinit doporučení o synchronizaci rozdílů (viz níže). Viditelná obsah na obrázku je ve srovnání pouze tehdy, pokud anotace vykazují hodnotu vlastnosti úložiště, a tato hodnota se mění dané součásti nebo připojení se zobrazí v slabý červený, slabý zelený nebo slabé fialové a symbol A '*' můžete vidět na obrázku vlevo nahoře pro složky, nicméně, pokud nějaká jiná základní hodnota úložiště vlastnost změněna, který není uveden v anotaci pak žádný náznak, bude poskytnuta. Obsah, který se vyskytuje na aktuálním schématu, ale je nalezena žádná shoda ve srovnávací architektuře bude zobrazen v silná červená, silný zelený nebo silný fialováa symbol '+' zobrazen v levém horním pro komponenty. Přizpůsobení se provádí pomocí typu konstrukční části, a jména tak, že v případě, že typ nebo název složky nebo připojení změnil v ostatních architektury bude shoda nalezena. Protože neexistuje způsob, jak spolehlivě určit, zda další obsah z druhého architektury by bylo prokázáno na aktuální schématu (např Další rozhraní mezi 2 složek, jak je uvedeno níže v diagramu z porovnání architektury na pravé straně), tyto rozdíly nejsou je znázorněno na schématech (jsou uvedeny pro katalogy dle níže). Vznášející se nad každou změněné položky se zobrazí rozdíl v popisku. Vznášející se nad symbolem "*" v levém horním diagramu je uveden přehled změn (nebo žádné změny) mezi obsahem schématu a obsahu druhé architektury.

Colour Legend

· Zelená indikuje položky, které není doporučeno synchronizovat rozdíly, které je, aby jim.

· Červený indikuje položky, které se doporučuje, aby synchronizovat rozdíly.

· Purple indikuje položky, kde ABACUS nemůže dát doporučení o synchronizaci rozdílů.

Na synchronizovat (synchronizační) obsahu z jedné architektury s jinou přes diagramu

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Ujistěte se, mít minimálně 2 architektury v projektu.

3. Otevřete diagram chcete porovnat na jiné architektuře.

4. Klepnutím na tlačítko "Porovnat tento katalog k obsahu jiného architektury" na panelu nástrojů Diagram.

5. Vyberte jiné architektuře ze seznamu drop-down srovnávat s.

Poznámka

Viz výše pro cestu ABACUS ukazuje "diff" mezi 2 architektur v katalogu. Především jak Červený se používá tam, kde to jeDoporučuje se synchronizovat rozdíly, Zelená se používá tam, kde je to neDoporučuje se synchronizovat rozdíly a Purple se používá pokud ABACUS nelze učinit doporučení o synchronizaci rozdílů.

6. Klepněte pravým tlačítkem myši na diagramu prvek (nebo prvky, pomocí Shift nebo diagramu plátno synchronizovat vše) zobrazující "diff" a vyberte položku Sync.

Poznámka

Jakékoli změny synchronizační budou použity pouze na architekturu, která právě v centru pozornosti katalogu patří. Chcete-li použít změny na druhou architekturu, kterou je třeba použít katalog v jiné architektuře. Navíc, uživatelé budou moci v případě, aby se změny synchronizace jen oni má k tomu oprávnění .

Poznámka

V závislosti na tom, kde jste pravým tlačítkem myši na položku nabídky se zobrazí pokyny o tom, co přesně se bude synchronizovat. Např. Pravým tlačítkem myši jediným prvkem v diagramu budou synchronizovat pouze této součásti. Vzhledem k tomu, klepnutím pravým tlačítkem myši na diagram plátno a výběrem Sync Všechno bude synchronizovat všechny aktuálně zobrazené rozdíly v.

Na zobrazit "diff" s jinou architekturou prostřednictvím katalogu

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Ujistěte se, mít minimálně 2 architektury v projektu.

3. Otevřete katalog, který chcete porovnat na jiné architektuře.

4. Klepnutím na tlačítko "Porovnat tento katalog k obsahu jiného architektury 'na katalog panelu nástrojů.

5. Vyberte jiné architektuře z rozevíracího seznamu srovnávat s.

6. Můžete filtrovat, jaké rozdíly jsou zobrazeny po kliknutí na tlačítko "rozdíly" na panelu nástrojů diagramu a odebráním možnosti, např Změnil / vedlejší / Unknown a Neurčitý / Sync Doporučené/ Mějte Doporučená.

Poznámka

Buňky v katalogu budou zvýrazněny červený, zelená nebo nachový tam, kde jsou rozdíly mezi obsahu v aktuálním katalogu a odpovídajícího obsahu v druhém architektuře. Červený se používá tam, kde je doporučeno synchronizovat rozdíly (viz níže), Zelená Používá se tam, kde se nedoporučuje synchronizovat rozdíly, které je držet je (viz níže) a Purple se používá pokud ABACUS nelze učinit doporučení o synchronizaci rozdílů (viz níže). Jsou porovnávány pouze viditelné řádky a sloupce v katalogu, takže v případě, že je rozdíl v řadě nad rámec v současné době publikovány řádků nebo hodnota ve sloupci, který není znázorněn má rozdíl pak žádný rozdíl bude uvedeno. V případě, že hodnota v individuální buňce se liší s odpovídající buňkou ve srovnávací architektuře bude zvýrazněna hranice buňka. Volič záhlaví sloupce a řádku bude také ve stínu v slabé fialovéa zobrazuje se symbolem "*". Tyto "*" mohou být symboly klikli pro skok na další rozdíl ve sloupci nebo řádku, resp. Řádky, které se vyskytuje v aktuálním katalogu, ale je nalezena žádná shoda ve srovnávací architektuře se zobrazí se symbolem '+' v selektoru řadě nalevo a hranicí celý řádek se zvýrazní. Řádky, které by došlo v porovnání architektuře verzi katalogu (tj se stejnými filtry, atd), ale je nalezena žádná shoda v současné architektuře se zobrazí s - symbolem volič řádku vlevo, hranice '' celý řádek se zvýrazní a obsah celé řádky buňky se zobrazí v slabé fialovéa udeřil-through, např. 8 do 6pm, Přizpůsobení se provádí pomocí typu konstrukční části, a jména tak, že v případě, že typ nebo název složky nebo připojení změnil v ostatních architektury bude shoda nalezena. Vznášející se nad každou změněné položky se zobrazí rozdíl v popisku. Vznášející se nad symbolem "*" v levém horním diagramu je uveden přehled změn (nebo žádné změny) mezi obsahem diagramu a obsah ostatních architektury.

Colour Legend

· Zelená indikuje položky, které není doporučeno synchronizovat rozdíly, které je, aby jim.

· Červený indikuje položky, které se doporučuje, aby synchronizovat rozdíly.

· Purple indikuje položky, kde ABACUS nemůže dát doporučení o synchronizaci rozdílů.

Na synchronizovat (synchronizační) obsahu z jedné architektury s jinou přes katalog

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Ujistěte se, mít minimálně 2 architektury v projektu.

3. Otevřete katalog, který chcete porovnat na jiné architektuře.

4. Klepnutím na tlačítko "Porovnat tento katalog k obsahu jiného architektury" na katalog nástrojů.

5. Vyberte jiné architektuře ze seznamu drop-down srovnávat s.

Poznámka

Viz výše pro cestu ABACUS ukazuje "diff" mezi 2 architektur v katalogu. Především jak Červený se používá tam, kde to jeDoporučuje se synchronizovat rozdíly, Zelená se používá tam, kde je to neDoporučuje se synchronizovat rozdíly a Purple se používá pokud ABACUS nelze učinit doporučení o synchronizaci rozdílů.

6. Klepněte pravým tlačítkem myši na buňku sloupce nebo řádku čísel (nebo více položek pomocí Shift nebo Ctrl + A pro všechno) zobrazující "diff" a vyberte položku Sync.

Poznámka

Jakékoli změny synchronizační budou použity pouze na architekturu, která právě v centru pozornosti katalogu patří. Chcete-li použít změny na druhou architekturu, kterou je třeba použít katalog v jiné architektuře. Navíc, uživatelé budou moci v případě, aby se změny synchronizace jen oni má k tomu oprávnění .

Poznámka

V závislosti na tom, kde pravým tlačítkem myši (tj buňky, sloupec nebo řádek záhlaví) položka menu se zobrazí pokyny o tom, co přesně se bude synchronizovat. Např. Pravým tlačítkem myši jedinou vlastnost nebo připojené komponenty buňku v katalogu budou synchronizovat pouze, že majetek nebo připojené komponenty. Vzhledem k tomu, klepnutím pravým tlačítkem myši na řádek záhlaví (nebo čísel pomocí Shift), bude synchronizovat celý řádek (nebo řádky). Pravým tlačítkem myši na záhlaví sloupce se bude synchronizovat všechny rozdíly v tomto sloupci.

Chcete-li zobrazit 'diff'2 celý architektury

1. Zkontrolujte, zda máte ABACUS otevřít soubor .

2. Ujistěte se, mít minimálně 2 architektury v projektu.

3. Vybrat Nástroje| Architektura Diff ....

4. V dialogovém okně, které se objeví vyberte první / Od a druhým / Pro architektur pro porovnání.

5. Klikněte na Dobře tlačítko.

Architektura Diff

Colour Legend

· Zelenáznamená, že uzel byl přidán v druhém / To architektury.

· Červenýindikuje, že uzel byl odstraněn ve druhém / k architektuře.

· Modrýindikuje, že uzel má různé atributy (např vlastností nebo norem) v druhém / k architektuře.

· Žlutáindikuje, že uzel má rozdíly ve svých dětí v druhém / s architekturou, takže uzel by měl být rozšířen.

Poznámka

Můžete pravým tlačítkem myši a "Show v Průzkumníku" na všech uzlech, aby zobrazit podrobnosti a další informace jsou uvedeny na rozdíly v rozdílech Souhrn panelu, když je vybrán uzel.

Viz také

Analýza vaší architektury | Zobrazení doba odezvy graf | Zobrazení Scatterplot matici vašich vyvinutých architektur | Vyvíjející vaší architektury


Simulace vaší architektury

Navigace: Simulace vaší architektury>

Simulace vaší architektury

Odeslat připomínky na toto téma.

Poté, co jste obydlených a analyzovány vaší architektury, jste připraveni k použití Abacus na zjistit, zda váš architektura bude vyhovovat vašim potřebám kvantitativní. To vyžaduje Simulace, Pro simulaci vaší architektury, musíte nejprve rozhodnout o druhu informací, které chcete najít. Tyto typy informací, jsou často označovány jako KPI, nebo klíčových ukazatelů výkonnosti. Například, chcete analyzovat výkon, evolvability, a otevřenost, nebo chcete získat metriky, jako jsou celkové náklady na vlastnictví. Všechny tyto informace mohou být odhalen nějakým způsobem. Jakmile máte tato data, budete schopni analyzovat vaší architektury v různých grafických formátů (nebo analyzovat nové hodnoty přímo).

Existují tři možnosti pro simulaci vaší architektury:

· Jednoduché metriky ;

· Pre-postavené simulátory ; nebo

· Scripting .

Jednoduché Metrics

Každá složka v architektuře má vlastnosti - z nichž mnohé mohou být zvyk vaší aplikaci ABACUS. Tyto vlastnosti představují různé vlastnosti komponentů. V některých případech, jednoduše shromažďování těchto metriky (stavět KPI), může být dost, aby vám říct, důležité informace o vaší architektuře. Například, KLOCS, nebo tisíce řádků kódu, byly široce používány jako míra složitosti. V jiných případech, možná budete chtít export dat a analyzovat jej pomocí jiného nástroje. Navíc, možná budete chtít sbírat vlastností po provedení jiný druh simulace.

Vlastnosti mohou být shromažďovány prostřednictvím procesu agregace , Agregace dodává uvedené podvlastnosti celkem, který se odráží v nadřazené složky. Agregace funguje pouze u komponent, které obsahují dílčí komponenty.

Pre-postavené Simulátory

Existuje pět přednastavených simulátory, které mohou být použity s ABACUS. Tyto jsou:

· Výkon;

· Modularita;

· Celkové náklady na vlastnictví (TCO);

· Otevřenost; a

· Spolehlivost.

Poznámka

ABACUS automaticky zvýrazní, které z těchto simulátorů je třeba znovu spustit prostřednictvím Červený zvýraznění na Panel nástrojů Simulace .

Scripting

Skriptování poskytuje flexibilitu pro simulaci vaší architektury ve vlastních cestách. Podle psaní skriptů můžete provádět simulace mimo proud v vybudované kapacity ABACUS. Celý model objektu ABACUS je k dispozici skriptovací engine, takže jste omezeni pouze na vaší schopnosti psát skripty!

Visual Basic Script je skriptovací jazyk podporován ABACUS, neboť poskytuje základní programovací funkce v přiměřeně jednoduchém formátu.

Viz také

Export vaší architektury | Souhrnné vlastnosti | Psaní skriptů


Psaní skriptů

Navigace: Simulace vaší architektury>

Psaní skriptů

Odeslat připomínky na toto téma.

Script Editor je jednoduchý a funkční nástroj pro psaní a spouštění VB nebo C # skript proti V současné době otevřený soubor ABACUS(Knihovny nejsou podporovány v skriptování). To má obvyklý soubor otevřít, zavřít a Uložit příkazy, takže si můžete uložit a načítat skripty píšete. Má také základní spouštění a ladění zařízení. Script Manager umožňuje snadno spouštět různé skripty, které jste napsali umístěním menu položku pro ně přímo v menu Nástroje.

Pro přístup k editoru Script

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Vybrat Nástroje | Script Editora okno Script Editor se otevře. Poté buď;

3. Otevření existujícího skriptu přes Soubor | Otevřít v menu dramaturg,

nebo

3. Otevřete Příklad skriptu prostřednictvím Příklad položka v menu dramaturg,

nebo

3. Nastavit výchozí jazyk buď VB nebo C # prostřednictvím Jazyk položka v menu dramaturg,

nebo

3. Otevřený skriptovací konkrétní pomoc na Pomoc položka v menu dramaturg

Při psaní skriptů, musíte dodržovat buď VB nebo C # syntaxpodle nastavení pod položkou jazyka v nabídkách dramaturg.

POZNÁMKA:

· Chcete-li použít standardní VB funkcí jako MsgBox ()Musí obsahovat Dovoz Microsoft.VisualBasicprohlášení na začátku skriptu. To nebylo nutné před verze 3.0 ABACUS.

· Tato pomoc neobsahuje informace o tom, jak psát VB skript, ani to obsahovat odkaz VB. Neváhejte a psát skripty ve vašem oblíbeném IDE nebo editor, potom zkopírovat a vložit je do tohoto programu.

Při prvním spuštění tohoto programu, bude Editor Script být prázdný. Můžete přistupovat kostry skriptu přes menu příklady. Při prvním spuštění editoru, měli byste spustit šablonu kostru vidět, že to funguje. Kromě toho existují dva příklad skripty, které mohou být přístupné přes menu příklady.

Chcete-li napsat užitečný skript budete muset odkazovat ABACUS ObjectModel. Je k dispozici skriptu by včetně Dovoz ABACUS.ObjectModelprohlášení v čele skriptu. Kompletní odkaz na celý model objektu ABACUS je součástí tohoto programu. Najdete ji výběrem Nápověda | Obsahz okna Script Editor.

Editor skript obsahuje mnoho užitečných funkcí pro psaní skriptů, včetně dokončování jak je znázorněno na následujícím obrázku. Nicméně, pro ještě bohatší uživatelské zkušenosti MS Visual Studio mohou být integrovány s ABACUS a podrobné pokyny jsou k dispozici zde .

Script Editor se automatické dokončování

Chcete-li použít Správce skriptů

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Vyberte Nástroje | Správce skriptů.

3. Klikněte na PřidatIkona a OtevřítZobrazí se okno.

4. Vyhledejte ABACUS Script (.abacusscript, VB nebo .cs), Soubor, který chcete přidat do nabídky Nástroje.

5. Klepněte na tlačítko Dobřea odkaz na skriptu se zobrazí v okně Script Manager. Zadejte název skriptu, jak si přejete, aby se v nabídce Nástroje. Poznámka: Okno Správce skriptů může být zvětšena vidět úplnou cestu v případě potřeby.

6. Opakujte kroky 3-5vytvářet odkazy na více Abacus skripty.

7. Klepněte na tlačítko V blízkostizavřít Script Manager a Všimněte si, že skript (y) ABACUS nyní zobrazí v nabídce Nástroje.

Chcete-li spustit skript

Buď;

1. Open, zadejte nebo zkopírujte a vložte do skriptu, který chcete spustit, tak to se zobrazí v hlavním okně Script Editor.

2. Klepněte na tlačítko Běh tlačítko.

3. Pokud skript obsahuje chyby, bude chyby Popis sekce v dolní části editoru skriptů uvádět podrobnosti včetně čísla řádku. POZNÁMKA: Každý jednotlivý chyba v Chyba Popis úseku může být poklepání, aby vás na příslušný řádek ve skriptu.

- nebo -

1. Vybrat Nástrojea pak se Název ABACUS Script položka menu jak byl vytvořen s Správce skriptů.

2. Pokud skript obsahuje chyby, bude editor skript se otevře s obsahem skriptu zobrazené v hlavním okně (zvýrazněno na řádku první chybě) a Chyba Popis sekce v dolní části editoru skriptu vypíše údaje nebo chyba (y), včetně čísla řádku. POZNÁMKA: Každý jednotlivý chyba v Chyba Popis úseku může být poklepání, aby vás na příslušný řádek ve skriptu.

Skriptování chyby kompilace

Chybám kompilace dochází, když syntaxe kódu skriptu není správný. Tyto chyby se zobrazí v dolní části okna v části chyb, s popisem chyby, a číslo řádku. Je to číslo řádku, který odlišuje chybu kompilace z chyby Runtime (viz níže), které nebudou mít číslo řádku. Chyby kompilace může být poklepání na skok a zvýraznit konkrétní řádek v otázce.

Scripting Runtime chyby (Důležitý)

Runtime chyby dojít po kódu skriptu byl úspěšně sestaven bez chyb, ale dojde k chybě při běhu programu (viz příklady stanoví další). Runtime chyby jsou důležité, protože může dojít k poškození modelech, když se objekty vytvořené a odkazované jinými objekty v modelu, nejsou samy o sobě součástí modelu (obvykle proto, že došlo k chybě runtime před kódem, který by umístil je v modelu Někde byl popraven).

Pokud váš skript vytváří objekty, které se přidávají do modelu, můžete se vyhnout poškození způsobené runtime chyba uložením skriptu, zavírání skriptování, a provedením undo změn, které byly vytvořeny pomocí skriptu (v případě spuštění skriptu nebyla dokončena normálně ). Nicméně, existují i ​​jiné způsoby, aby se zabránilo korupci vyskytující (viz níže). Poznámka: Všechny skripty, které pouze čtou z modelu a nepište na něj, jsou bezpečné a nezpůsobí žádné problémy, bez ohledu na to, zda se objeví runtime chyby při jejich provádění.

Aby nedošlo k poškození, při psaní kódu skriptu, který vytváří objekty a jejich přidání do objektový model, to je navrhl, že objekty jsou přidány do modelu co nejdříve, pokud se odkazuje jinými objekty.

Například, pokud vytváříte nové připojení, a 2 nové složky, a poté je připojování k sobě, je nejlepší vytvořit první složku, přidejte ji k modelu, pak druhý a přidejte ji, a pak vytvořit spojení a přidat, a nakonec vytvořit přílohy. To znamená, že pokud by došlo k chybě runtime, který přeruší spuštění skriptu, všechny objekty, které jsou nutné, aby se v objectmodel před vytvořením příloha, jsou v modelu. Může dojít k poškození, pokud například, bylo přidáno pouze spojení, provedeny přílohy, a potom došlo k chybě runtime před skript nakonec přidány nové součásti na model.Corruption může dojít, když je objekt, na který odkazuje jiný objekt v objectmodel, je, že není v objectmodel.

Příklad runtime chyby patří:

· Odkaz na objekt není nastaven na instanci objektu - toto nastane, když proměnná objektu je null reference, a je používána metoda nebo vlastnost k tomuto objektu. Nulové odkazy lze zkontrolovat "Jestliže objectVariable není nic Pak ..."

· Index byl mimo hranice pole - to nastane, když je pole získáván s indexem, který je mimo hranice - např méně než 0 ° C, nebo se rovná nebo je větší než délka / Count pole. Array nebo délky kolekce lze ověřit vlastnosti .Length nebo .Count, resp.

· Bez oprávnění Výjimka - Nemáte povolení k ... - tohle dochází, pokud nemáte oprávnění k provádění dané změny

· Primární klíč Výjimka - Duplicate / chybějící Jméno / ID - tohle dojde, pokud je provedena změna na unikátní atribut, který je v rozporu s jiným objektem. Např. Architektury musí být jedinečné jménem, ​​podobně se standardy.

· Referenční integrita Výjimka - nastavení pole odkaz na objekt, který není platný. Např. přidávání "nic", nebo null jako dítě k mnoha sbírek v objectmodel.

· Zero Length Výjimka - to může dojít, pokud se pokusíte se nastavit název objektu na prázdný řetězec. Většina objektů vyžadují, aby jejich jména mít alespoň 1 znak.

Dovoz prohlášení

Všimněte si, že na začátku skeletu skriptů jsou příkazy, jako jsou Dovoz ABACUS.ObjectModel, Tato prohlášení nebude obsahovat DLL, která již není odkazovaný skriptem - jejich cílem je poskytnout "zástupce", aby museli zadat celý název třídy.

Například, deklarovat proměnnou typu CKomponentní (reprezentující komponenty v ABACUS), přičemž Dovoz ABACUS.ObjectModelprohlášení směrem k horní části skriptu, by vyžadoval pouze to, aby byl deklarován jako dim comp as CKomponentní, Protože kompilátor ví, že se podívat ve jmenném prostoru ABACUS.ObjectModel pro třídu CKomponentní. Bez příkazu Imports, musel by být deklarován jako dim comp as ABACUS.ObjectModel.CComponent, Sestava (jako je mscorlib.dll, nebo System.Windows.Forms.dll) může obsahovat více než jeden názvů - prohlášení Imports je na těchto oborů názvů, není pro samotné sestavy. Sestava ABACUS.ObjectModel.dll má pouze jediný ABACUS.ObjectModel jmenný prostor přístupný prostřednictvím skriptování.

Automaticky odkazované sestavy

Následující DLL jsou odkazoval se automaticky skriptování:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.visualbasic.dll (implicitně odkazuje překladač)

· ABACUS.ObjectModel.dll

Chcete-li další odkazy buď jinými .NET sestav, nebo vlastní sestavy, naleznete v následující části na straně #ImportDLL prohlášení.

#ImportDLL Prohlášení

Od roku ABACUS 3.1, můžete odkaz další sestavy, které můžete potřebovat pro skriptování s užíváním #ImportDLL prohlášení. Například, pokud jste chtěli, aby přístup k vlastní DLL tvůj a využít funkce v něm, by jej umístit do adresáře ABACUS a zahrnují prohlášení jako první řádek (y) ve vašem skriptu. Pokud se jedná o .NET dll, pak normálně nemusíte zadávat celou cestu, jen DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.xml.dll

Některé další věci na vědomí:

1. Protože dll musí být nalezen při kompilaci a běhu, to omezuje vlastní (ne) .NET dll byly umístěny pouze ve složce programu ABACUS.

2. #ImportDLL prohlášení musí být první řádek (y) ze skriptu - pokud máte 5 prohlášení, pak by měla být na prvních 5 řádků skriptu

3. #Prohlášení o ImportDLL umístěny kdekoli, ale První řádky skriptu (například pokud byla umístěna po komentář nebo příkaz Imports) nebude fungovat správně a / nebo může způsobit nesouvisející chyby kompilátoru.

#ImportDLL s Office Sestavy

Pokud máte nainstalován Microsoft Office, a váš skript vyžaduje sestavy Office Interop, je možné je odkazovat jednoduše pomocí #ImportDLL s názvem sestavení (jak je uvedeno níže, např. #ImportDLL Excel). Při použití této metody má tu výhodu, že absolutní dll cesta nemá být použit, takže skript je přenosný (měl by fungovat jak na Office 2003 a 2007 bez úprav scénář).

Použijete-li tuto funkci, GAC (Global Assembly Cache) je vyhledán sestavení interop, a skript kompiluje s cestou k tomuto shromáždění v případě nálezu. Pokud to není nalezen, bude skriptování zkontrolujte adresář programu ABACUS (který obsahuje Excel a Visio interops pouze). V případě, že požadovaná interop není nalezen do této doby, zobrazí se varovný.

Tyto interops obvykle nejsou nainstalovány v GAC, pokud jste nainstalovali sadu Microsoft Office před instalací rozhraní .NET Framework (která je součástí úplné instalace ABACUS). Si můžete nainstalovat provedením Změnit volbu pro sadu Microsoft Office z Přidat / Odebrat programy a vyberte volby programovatelnosti rozhraní .NET. Pro více informací, vidět článek na webu MSDN.

Sestavy, pro které je podporován tento zástupce, jsou:

· Přístup

· Access.Dao

· Vynikat

· Graf

· MSProject

· Výhled

· OutlookViewCtl

· OWC11

· PowerPoint

· Vydavatel

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Slovo

It, není zcela jasné, zda všechny výše uvedené sestavy jsou užitečné, pokoje havebeen zahrnuty v tomto celovečerním regardeless jako někteří uživatelé Feb mají potřebu i temných sestav.

Viz také

Simulace vaší architektury


Použití makra

Navigace: Simulace vaší architektury>

Použití makra

Odeslat připomínky na toto téma.

Pokud provedete úkol opakovaně ABACUS, můžete automatizovat úkol pomocí makra. V souladu s tím makro ABACUS je zaznamenané řady operací, které mohou být přehrány kdykoliv.

Záznam makra

1. Vyberte Nástroje | Záznam makranebo alternativně stisknout Alt + F10.

2. Začněte provádění operací, které chcete nahrávat.

Varování

V tomto okamžiku, tam jsou některé známé problémy s makro nahrávání. Prosím, aby na tyto v úvahu při nahrávání maker:

· V současné době makra jen zaznamenávat vaše stisky kláves Microsoft Windows, myš-pohyby a klepnutí myší. Nicméně, vzhledem k omezením s záznam maker samotné, tam jsou některé úhozy, které nejsou vždy zaznamenány. Mezi ně patří:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] až [F12]

· Proto se doporučuje, abyste si ověřili, že klávesová zkratka je zaznamenán záznam makra před záznamu velkého sled událostí, které mohou záviset na tom klávesové zkratky práci.

· V současné době vzhledem k omezením s záznam maker, kontextové nabídky nejsou správně zpracovány ABACUS, když jsou otevřeny žalobou zaznamenaných záznam maker. Když otevřete kontextovou nabídku, musíte provést jednu z funkcí uvedených v kontextovém menu pomocí kontextového menu, jinak se kontextové menu, může zůstat otevřena během přehrávání, což může vést k nezamýšleným akce nebo akcí, které by mohly způsobit chyby při ABACUS.

· Všimněte si, že normální metody zavření kontextové menu (např stiskem [Esc] na klávesnici, nebo vlevo-klikem jinam na obrazovce), může ve skutečnosti není ukončena kontextové menu během přehrávání makra.

Tip

V dialozích, nikoli pomocí kliknutí myší, je doporučeno použít klávesu Tab k procházení dostupných ovládacích prvků a kurzorových tlačítek vyberte rozevírací položky nabídky nebo možnosti přepínač a mezerníku select / de-Zaškrtněte boxy.

Pro zastavení záznamu makra

1. Press Alt + F9nebo alternativně zvolte Nástroje | Zastavit Makro.

2. V Uložit makro jako dialogu přejděte do umístění a vyberte ABACUS makro (.abacusmac souboru) název souboru a klepněte na tlačítko Uložit.

Poznámka

Použitím Nástroje| Zastavit Makrobude obsahovat tuto operaci v zaznamenané makro. Proto se doporučuje, aby uživatelé získání odborné způsobilosti v používání možností klávesu Alt + funkce pro práci s makry, aby nedošlo k nechtěné zahrnout makro operace v samotných maker.

Tip

Protože makra nejsou v současné době upravovat je doporučeno zaznamenat zdlouhavé úkoly jako série samostatných maker klávesami Alt + F10 / ALT + F9 "páry".

Chcete-li přehrávat zaznamenané makro

1. Vyberte Nástroje | Přehrávání Makronebo alternativně stisknout Alt + F8.

2. V dialogovém okně Makro Otevřít přejděte do umístění a vyberte ABACUS makro (.abacusmac souboru) název souboru a klepněte na tlačítko Otevřít.

Varování

Při otevírání makro ABACUS, pokud jste double-klikněte na soubor makro z dialogového okna procházení otevřít, makro rekordér může držet levé tlačítko myši v levém klikli stavu až do nahraného klikněte levým tlačítkem myši přepíše tento stát.

Poznámka

Rychlost přehrávání makra lze nastavit na kartě Obecné v části Nástroje| Možnostibuď jako Normal (výchozí nastavení), rychle nebo pomalu. Jak rychlé a pomalé rychlosti přehrávání se nedoporučuje, protože se budou přehrávat zaznamenané makra při cca 100 časech a 1 / 100. reálném čase, resp. Normální rychlost přehrávání bude stále přehrávat makro přibližně o 30% rychleji než zaznamenaná rychlost, takže se doporučuje při nahrávání se zastaví na krátkou dobu po veškerých dlouhých úloh zpracování, aby zajistily, že na přehrávání další operace není proveden před úkol zpracování má dokončena.

Zastavení přehrávání zaznamenané makro

1. Press Alt + F9.


Simulace Performance

Navigace: Simulace vaší architektury> Simulátory>

Simulace Performance

Odeslat připomínky na toto téma.

Pozadí

Architektonická Hodnotitel pro výkon je diskrétní simulátor událost, která pracuje tím, že simuluje tok zpráv (nebo tokenů) v rámci celé architektury. Teorie za tímto je odvozen z výzkumu provedeném na University of Technology, Sydney, a je založen na Síťové Layered Queuing Modely(LQNM), Dočasný a barevné Petriho sítě(TCPN) a Aktivita Taktovací diagramy(ACD).

V simulaci výkonu ABACUS, zpracování na jednu složku je většinou způsobován předávané zprávy, které jí z jiného komponentu. Principy za této techniky je možné chápat do čtyř hlavních částí:

1. message-centricKomunikace je modelován v ABACUS použitím logický(nebo nepřímé) připojení. Logické spojení definovat chování (frekvence a data) zpráv předávaných mezi komponenty. Dobrým příkladem logických spojů by sekvence toky mezi dvěma (2), obchodních procesů nebo logických rozhraní mezi dvěma (2) aplikací.

2. Logické zprávy jsou přepravovány na místo určení prostřednictvím hierarchie(jako je například swimlanes zdroje), nebo říditspoje (například fyzickými kabely). K tomu mohou být směrovány nahoru, přes dělat a zpět dolů hierarchii (odstupňovaný přístup), následovat přímou cestu.

3. Věrnost modelu lze nastavit tak, aby vyhovovaly. Například proces může být rozdělen dolů tak daleko tak, aby každé jednotlivé základní proces a funkce má samostatnou stopu. Alternativně může být stačí mít pouze jednu hodnotu pro celý proces, což je odrazem průměrzpracování odpověď na zprávu.

4. Skutečná zpracováníse provádí pouze jednotlivými složkami, které (nebo jsou) procesoru. Procesor je obecný věc, a může být CPU, osoba, organizační složka, nebo cokoli jiného, ​​který je schopen provádět práce. Například obchodní proces nedělá žádné skutečné zpracování; toto se provádí pomocí první "procesor", se to v jedné své mateřské hierarchie (pokud je použit swimlane notace) nebo jeho sítě pro zpracování (je-li použit distribuované zpracování notace).

Toto vyhodnocení simulováním (určené) provozu v systému, tak, že každá přípojka je simulována alespoň jednou. Doba příjezdu zpráv se náhodně generované s ohledem na jejich zadané frekvenci. Tento model simuluje zpracování zdrojů a konflikty a řazení zpráv do fronty, shromažďování statistik po cestě jsou různé výstupních vlastností.

Klíčové faktory Vstupní výkon

1. Frekvence- Frekvence, při které dojde k připojení.

2. Zpracování- Množství času pro dokončení provedení jeden proces. To může být v hodiny, minuty, dny, operace atd.

3. Rychlost- Rychlost zdroje procesoru. To znamená, že to, kolik cyklů / instrukce / akce se může provádět v jedné jednotce času. Je důležité, aby byly v souladu s jednotkami používanými pro zpracování.

4. Procesory- Počet prostředků procesoru. Zpracovatelé mohli být lidé, CPU, externí organizace atd

Klíčové faktory Výstupní výkon

1. Propustnost- Počet zpráv za jednotku času prostřednictvím opatření spojení, Tato skutečná hodnota může být v porovnání s očekávanými / teoretické hodnoty (tj Frequency) odvodit nasycení systému.

2. Zpráva Rate- Počet zpráv za jednotku času prostřednictvím opatření komponent, Jedná se o součet příchozích a odchozích zpráv všechny komponenty.

3. Odpověď- Minimální / průměrná / maximální latence pro tento spojení, Jedná se o součet všech sledovaných čekacích dob pro připojení od pramene k dřezu a jakékoli Queuing a zpracování (a latence zpět ke zdroji, pokud obousměrně).

4. Využití- K využití komponent, To bude 0%, pokud součást není zařízení / procesor (tj nemá procesory a vlastnosti Speed ​​definované výše).

Zatímco diskrétní simulace události se provádí pro výpočet různých výstupní vlastnosti, jak je popsáno výše, může být níže uvedený vzorec použit jako hrubý ověření výsledků (kde je systém není nasycených):

Využití = součet frekvence pro všechny příchozí připojení * Zpracování / (* Rychlost procesory)

Celková koncepce je možná nejlépe demonstroval tím, že zvažuje následující diagram, který ukazuje dva různé výkonnostní meta-modelů. Styl Levá ruka je klasický "swimlane" notace se zpracováním úkoly hierarchicky založených v rámci svých procesorových zdrojů. Pravá ruka styl je "distribuované" notace s úkoly zpracování připojených přes spojení procesů k jejich prostředku procesoru. Tento druhý zápis umožňuje více prostředků procesoru pro daný úkol zpracování, na rozdíl od omezené swimlane notace.

Poznámka

Zobrazovat na každém meta-modelu jsou vstupní vlastnosti (v červeném) a výstupní vlastnosti (modře):

Výkonnostní meta-modely: Swimlane proti distribuovaného notace

Spuštění simulátoru výkonu

Pro simulaci vaší architektury z hlediska výkonu

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Vybrat Analýza| Výkonnebo klepněte na tlačítko na panelu nástrojů.

3. Vyberte ArchitekturaChcete-li zhodnotit z rozbalovacího menu.

Poznámka

Ve výchozím nastavení bude ABACUS automaticky vyberte první architekturu, pro které je z důvodu požaduje nové simulace na jakékoli dané nemovitosti či strukturálních změn.Toto zvýraznění je uvedeno v Červený na Panel nástrojů Simulace .

4. Vyberte Komponenty a PřipojeníChcete-li zhodnotit, od okno pro výběr standardním prvkem .

5. Nastavení Run Time Scale Factorslider.

Poznámka

Vyšší hodnoty přinese více statisticky konzistentní výsledky, ale trvat delší dobu pro výpočet.

Další Checkboxk okno pro výběr standardním prvkem

· Save převáděl model bude uložit kopii RBD transformovaného verze projektu ve stejné složce jako aktuální projekt a přidat "_transformed" k názvu projektu.Tento transformovaný projekt lze využít k diagnostice podrobně simulaci spolehlivosti podnikané ABACUS.

Další možnosti znovu na okno pro výběr standardním prvkem

· Run Time Scale Factor reguluje doba, simulace a přesnost s vyšším Hodnoty výnosIngvíce statisticky konzistentní výsledky, ale převzetí delší čas běh.

Poznámka

Při ABACUS vypočítá čas simulace, že bude určovat nejpomalejší nepřímé souvislosti frekvence, která byla vybrána být simulována a poté "warm-up" pro období (tj 1 nad frekvenci) tímto spojením (zahájení pravidelné generátory zpráv pro všechny připojení náhodně Během této zahřívací doba, což jim všem šanci iniciovat), a potom simulovat na Run Time Scale Factor násobek periody tomto ohledu. Nebo (1 / frekvence) Doba zahřívání + (1 / frekvence) * Run Time Scale Factor simulační čas. To je, aby se ujistil, že, že všechny spoje jsou zahájeny před statistické údaje shromažďovány, a pak nejpomalejší připojení je stále simulována alespoň jednou v simulaci. Např. V případě, že nejpomalejší nepřímé spojení má frekvenci 0,033 časových jednotek (nebo circa jednou za měsíc, pokud se časové jednotky jsou dny), pak warm-up čas bude 30,3 časové jednotky a doba simulace bude 30,3 časové jednotky krát Scale Factor Doba chodu.

6. Klepněte na tlačítko Dokončita získáte Varování dialog.

7. Volitelně prozkoumat varování kliknutím Podrobnosti >>.

8. Klepněte na tlačítko Pokračovat.

Poznámka

V tomto bodě, ABACUS bude provádět simulace diskrétních událostí architektury a po krátké době (s tyčí pro zpětnou vazbu o pokroku), zobrazí se dialogové okno výpočet kompletní.

9. Klepněte na tlačítko Dobřeuznat simulaci.

Tip

Pro pořádání školení a další pomoc na výkon Simulace najdete na Avolution Community .

Vlastnosti Component

V následující tabulce jsou uvedeny vlastnosti potřebné k hodnocení výkonnosti. Nemovitosti jsou vyhledávány jako první v komponentě případech, a pokud není nalezen, je výchozí používá, pak standardy komponent.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou vstup nemovitost voliče řádku ( [image] ) S bublině "vstupní výkon". Změna na některou z těchto "vstup" vlastností a různých strukturálních změn v úložišti bude mít za následek simulátoru Performance vyžadující opětovné simulace, jak je uvedeno v Červený na Panel nástrojů Simulace .

Typ | Jméno | Výchozí hodnota | Jednotka | Datový typ | Požadovaný | Popis
Chování | b_pack | 0.0 |  | Desetinný | Falešný | Pevná doba provozu na balení během několika sekund. Tato vlastnost je typicky zadán jako standardního typu, a pak použít pro instance více komponent. Například, CORBA má b_pack = 0,23 ms.
Chování | m_pack | 0.0 |  | Desetinný | Falešný | Proměnná Doba služba balení v sekund / byte. Tato vlastnost je typicky zadán jako standardního typu, a pak použít pro instance více komponent.
Chování | b_unpack | 0.0 |  | Desetinný | Falešný | Pevná doba služby rozbalit v sekundách. Tato vlastnost je typickyzadán jako standardního typu, a pak použít pro instance více komponent.
Chování | m_unpack | 0.0 |  | Desetinný | Falešný | Proměnná Doba služba rozbalit v sekund / byte. Tato vlastnost je typickyzadán jako standardního typu, a pak použít pro instance více komponent.
Chování | Zpracování | 0.0 |  | Desetinný | Pravda | Množství doby provedení k dokončení jeden proces. To může být v hodiny, minuty, dny, operace atd.
Chování | Procesory | 1 |  | Celé číslo | Pravda | Počet zdrojů procesoru. Zpracovatelé mohli být lidé, CPU, externí organizace atd
Chování | Rychlost | 100 |  | Celé číslo | Pravda | Rychlost zdroje procesoru. To znamená, že to, kolik cyklů / instrukce / akce se může provádět v jedné jednotce času. Je důležité, aby byly v souladu s jednotkami používanými pro zpracování.
Chování | k_bkgd | 0.0 |  | Desetinný | Falešný | Zpracování na pozadí na komponentu. To se používá k úpravě výsledků, aby odpovídaly žádné pevné offsety%. To může být pravděpodobně ignorovány.

V následující tabulce jsou pro komponentní výstup vlastností výkonem hodnotitele. Soubor těchto vlastností složek jsou generovány pro každou složku v každém výkonu běhu.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Performance Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a simulátoru výkon vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Chování | Zpráva Rate |  | Desetinný | Falešný | Počet zpráv, za jednotku času prostřednictvím složky. Jedná se o součet příchozích a odchozích zpráv všechny komponenty.
Chování | Šířka pásma |  | Desetinný | Falešný | Celková šířka pásma skrz součást. Součet kvůli oběma příchozí a odchozí zprávy.
Chování | Využití | % | Desetinný | Falešný | Využití komponenty. To bude 0%, pokud součást není zařízení / procesor (tj Nemá procesory a vlastnosti Rychlost definovány výše)

Vlastnosti připojení

V následující tabulce jsou uvedeny vlastnosti potřebné k hodnocení výkonnosti. Nemovitosti jsou vyhledávány jako první v případech spojení, pak se spojení standardů a pokud není nalezen, je výchozí používá.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou vstup nemovitost voliče řádku ( [image] ) Se v popisku "Vstup Performance" nebo "Ekonomický vstupní / výkon". Změna na některou z těchto "vstup" vlastností a různých strukturálních změn úložiště bude mít za následek simulátoru výkonu a / nebo Náklady simulátor vyžadující opětovné simulace, jak je uvedeno v Červený na Panel nástrojů Simulace .

Typ

Jméno

Výchozí hodnota

Jednotka

Datový typ

Požadovaný

Popis

Chování

Druh

obousměrný

[obousměrný | jednosměrný]

Vyhledávání / List

Pravda

Zda je připojení obousměrný (obousměrně), nebo jednosměrné (jednosměrný).

Povolené hodnoty pro tuto vlastnost jsou "obousměrná" nebo "jednosměrný".

Obousměrné znamená synchronní zprávy požadavku / odpovědi vzhledem k tomu, jednosměrné prostředky jeden asynchronní "událost".

Chování

Abstrakce

nepřímý

[nepřímé | řídit]

Vyhledávání / List

Pravda

Zda je připojení fyzické nebo logické. Přímá spojení jsou fyzické "roury" mezi dvěma složkami, že logické připojení proudí dál.

Povolené hodnoty pro tuto vlastnost jsou "přímé" nebo "nepřímé".

Pokud je hodnota "direct", pak se spojení nepotřebuje žádné další vlastnosti (s výjimkou vlastností Kind a abstrakce).

Data

L_app1

0

Celé číslo

Falešný

Poptávka / velikost události v bytech.

Každé spojení obvykle mají zvláštní hodnotu pro toto. V CORBA události jsou vlastně obousměrná a vždy mají 12 byte potvrdit (L_app2). Pokud je pravda, jednosměrný spojení pak vynechat vlastnost L_app2.

Data

L_app2

0

Celé číslo

Falešný

Odpověď / potvrdit velikost v bajtech.

Každé spojení obvykle mají zvláštní hodnotu pro toto. Jednosměrný spojení nebude mít L_app2.

Chování

Frekvence

1

Desetinný

Pravda

Frekvence, při které dojde k připojení.

Každé spojení obvykle mají zvláštní hodnotu pro toto. Pokud vlastnost Frekvence je vynechán, pak výchozí používá.

Chování

Vztah

procesy

[procesy | podporuje]

Vyhledávání / List

Falešný

Připojení, které mají "procesy" vlastnictví ukazují, že složka na začátku spojení, se převedou na zpracovatelný při složky na konci spojení. Ve skutečnosti je "zdrojem" složka se stěhoval, aby se stal dítětem "potopit" složky (připojené přípojky jsou také "přetáhnout" s tímto pohybem).

Pokud se "procesy" vlastnost existuje pak všechny ostatní vlastnosti připojení se ignorují, s výjimkou volitelného "%" vlastnictví je popsán níže.

Chování

%

100.0

Desetinný

Falešný

Připojení, které mají "Procesy" vlastnictví (popsaného výše) může volitelně mít "%" vlastnictví k indikaci podíl zpracování, které bude přiděleno do cílové složky. Tímto způsobem může být jediný zdroj komponenta zpracovává více součástí cílových na různých% očím. V% hodnoty není nutné přidat až 100%, a to je prostě používají pro kalibraci "zpracování" vlastnictví (viz výše) pro zdrojové komponenty, jak to je transformováno, aby se stal dítětem cílové složky.

V následující tabulce jsou uvedeny vlastnosti generované výkonu hodnotitelem. Soubor těchto vlastností připojení jsou generovány pro každé spojení na každé výkon běhu.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Performance Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a simulátoru výkon vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Chování | Šířka pásma |  | Desetinný | Falešný | Celková šířka pásma pro připojení. Toto je počítána pouze pro nepřímé připojení a je v podstatě (L_app1 + L_app2) * propustnost.
Chování | Šířka pásma dvěina |  | Desetinný | Falešný | Šířka pásma speciálně pro odchozí (1) a příchozích (2) zprávy o připojení. Toto je počítána pouze pro nepřímé připojení a je v podstatě L_app1 * Propustnost a L_app2 * propustnost.
Chování | Propustnost |  | Desetinný | Falešný | Počet zpráv za jednotku času prostřednictvím připojení. Tato skutečná hodnota může být v porovnání s očekávanými / teoretické hodnoty (tj Frequency) odvodit nasycení systému.
Chování | Dokončeno | % | Desetinný | Falešný | Procento zpráv, které úspěšně dokončí zpracování pro připojení. Toto je počítána pouze pro nepřímé připojení a je Propustnost / frekvence. Občas Dokončeno hodnota překročí 100%, protože náhodnost výsledků generace zprávu v mírně zvýšenou četností generační zprávu, než je uvedeno.
Chování | Odpověď (Min / Ave / Max) |  | Desetinný | Falešný | Minimální / průměrná / maximální latence. Toto je počítána pouze pro nepřímé připojení a je pozorovaný latence pro připojení od zdroje do dřezu a jakékoliv Queuing a zpracování (a latence zpět ke zdroji, pokud obousměrně).

Vlastnosti Architektura

V následující tabulce jsou uvedeny v rámci celého systému architektonické vlastnosti generované výkonu hodnotitelem. Jednotný soubor vlastností pro architektury jsou "agregovány" Pro každý výkon běh.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Performance Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a simulátoru výkon vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Chování | Zpráva Rate |  | Desetinný | Falešný | Počet zpráv, za jednotku času z částí v architektuře. Jedná se o součet příchozích a odchozích zpráv všechny komponenty.
Chování | Propustnost |  | Desetinný | Falešný | Počet zpráv, za jednotku času přes spojení v architektuře. To je suma výkony všech nepřímých Connections "a tato skutečná hodnota může být v porovnání s očekávanými / teoretické hodnoty (tj frekvence) odvodit nasycení systému.
Chování | Šířka pásma |  | Desetinný | Falešný | Celková šířka pásma. Součet připojovacích pásma architektury je.
Chování | Využití | % | Desetinný | Falešný | Využití všech složek. Může být vyšší než 100%, jak je to jen součet všech dílčích utilisations architekturu je.
Chování | Odpověď (Min / Ave / Max) |  | Desetinný | Falešný | Minimální / průměrná / maximální latence. Součet všech pozorovaných čekacích dob pro připojení architektuře se od zdroje ke dnu (a zpět ke zdroji, pokud obousměrně).


Simulace Modularita

Navigace: Simulace vaší architektury> Simulátory>

Simulace Modularita

Odeslat připomínky na toto téma.

Modularita simulátor vypočítá počet příchozích a odchozích připojení pro každou složku.

Pro simulaci vaší architektury z hlediska modularity

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Vybrat Analýza| Modularita.

3. Vyber Architektura (y)Chcete-li zahrnout do hodnocení.

Poznámka

Ve výchozím nastavení bude ABACUS automaticky vybere architektura (y), pro které je z důvodu požaduje nové simulace na jakékoliv základové změny struktury,.Toto zvýraznění je uvedeno v Červený na Panel nástrojů Simulace .

4. Klepněte na tlačítko Další.

5. Vyber Typy připojení (y)Chcete-li zahrnout do hodnocení.

6. Klepněte na tlačítko Další.

7. Volitelně upravit názvy vlastností pro výsledky výpočtů.

8. Klepněte na tlačítko Dokončit.

Poznámka

V tomto bodě, ABACUS bude provádět strukturální vyhodnocení architektury (ů) a po krátké době (s bary pokroku pro zpětnou vazbu), zobrazí se dialogové okno výpočet kompletní.

9. Klepněte na tlačítko Dobřeuznat hodnocení.

Tip

Pro pořádání školení a další pomoc na Modularita ohodnocení najdete na Avolution Community .

Vlastnosti Component

V následující tabulce jsou uvedeny součásti vlastnosti, které jsou na výstup modularity hodnotitelem.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Modularita Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku základní strukturální změny úložiště a modularita simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Datový typ | Požadovaný | Popis
Modularita | Spojka-fan v (místní) | Celé číslo | Falešný | Počet spojení, které ventilátor do této složky.
Modularita | Spojka-fan out (místní) | Celé číslo | Falešný | Počet spojení, které vybíhají z této složky.
Modularita | Spojka-fan v | Celé číslo | Falešný | Počet spojení, které ventilátor do této složky, včetně přípojek, že ventilátor do dílčích komponent.
Modularita | Spojka-fan out | Celé číslo | Falešný | Počet připojení, které vybíhají z této složky, včetně přípojek, že ventilátor do dílčích komponent.


Simulace celkové náklady na vlastnictví (TCO)

Navigace: Simulace vaší architektury> Simulátory>

Simulace celkové náklady na vlastnictví (TCO)

Odeslat připomínky na toto téma.

Pozadí

Celkové náklady na vlastnictví (TCO) je finanční odhad, slouží k měření nákladů celkové vynaložené životního cyklu (od pořízení po vyřazení z provozu / likvidace) spojené s vlastněných aktiv. TCO nejen odráží náklady na nákup, ale také zahrnuje všechny ostatní aspekty při dalším použití a údržbu majetku.

TCO se používá pro stanovení úsilí a náklady na rozpočet nutné vynaložit na systému. Jednoduchý způsob modelování v ABACUS na TCO je rozbít IT systému dolů do složek. Můžeme pak zjistit, kolik průměrně stojí spustit jednu z těchto složek. Poté jsme mohli pak faktor v různých nákladů v závislosti na tom, zda IT systém je evolvable nebo otevřený atd. Pokud je systém již v provozu, hlavním faktorem, aby zvážila, náklady na údržbu a snad nákladů pro vyřazení.

Příklad

Diagram pro příklad výpočtu

Složka podle organizace nebo její normy má tyto vlastnosti:

· FTE= 100 000 $ / rok

· Podpora úsilí= 0,01 FTE + 0,001 FTE / yr = $ 1000 + $ 100 / yr

· Náklady na údržbu= $ 100 - $ 10 / yr

· Kapitálové náklady= 2000 $

· Instalace Effort= 2 FTE / dní = 0,01 FTE / yr = $ 1000

Složka podle organizace má tyto vlastnosti:

· Instalace Horizon= -2 Let (tj byl systém instalován 2 roky před darem)

· Životnost= 3 roky

Kdy Instalace Horizon + Životnost <= 0 , Není tam žádný další náklady na údržbu.

Výpočty

Výpočty jsou následující:

Poznámka

TC = náklady za rok. SE = podpora úsilí. MC = náklady na údržbu.

· Počáteční náklady = kapitálové náklady + Install Effort= 2000 + 1.000 = 3.000 $

· V čase t = 2 (v průběhu 1 roku), TC = počáteční náklady + SE + MC= 3.000 + 1.000 + 100 = 4100 $

· V čase t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1.190 $

· V čase t = 0, TC = (1.000 + 200) + (100 - 20) = 1280 $

· V čase t = 1 (poslední rok), TC = (1000 + 300) + (100-30) = 1370 $

Graf pro příkladu výpočtu

TCO je součet všech současných a budoucích nákladů, dokud není vyřazení z provozu systému.

· V čase t = -2 (během 1. ročníku), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· V čase t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· V čase t = 0, TCO = 1.280 + 1.370 = 2.650 $

· V čase t = 1 (poslední rok), TCO = $ 1370

Hlavní nákladové faktory

Klíčové nákladové faktory je třeba vzít v úvahu při výpočtu celkových nákladů na vlastnictví aktiva v ABACUS jsou:

· Hardware Acquisition- Počáteční náklady na vybavení (kapitálové náklady) na.

· Software Acquisition- Počáteční náklady na licence na software (kapitálové náklady).

· Instalace- Náklady spojené s úvodním nastavení.

· Výcvik- Náklady spojené se externí školení prodejců po počátečním nastavení.

· Podpora- Náklady spojené s vnitřní podpory.

· Údržba- Náklady se vyměňovat nebo vylepšovat dodavatele servisní smlouvy, dodávky a náklady na obnovení po havárii.

· Infrastruktura- Náklady spojené s podporu aktivum.

ABACUS Příklad Zastoupení klíčových nákladových faktorů

Spuštění Cost simulátor

Pro simulaci vaší architektury z hlediska nákladů

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Vybrat Analýza| Náklady.

3. Vyber Architektura (y)Chcete-li zahrnout do hodnocení.

Poznámka

Ve výchozím nastavení bude ABACUS automaticky vybere architektura (y), pro které je z důvodu požaduje nové simulace na jakékoli dané nemovitosti či strukturálních změn.Toto zvýraznění je uvedeno v Červený na Panel nástrojů Simulace .

4. Vyberte Měnaod stahovací.

5. Přesunout Roky k výpočtuposuvník na počet let potřebných.

Poznámka

Ve výchozím nastavení, pokud let pro výpočet je více než 1 rok budou automaticky vypočítá náklady pro každou jednotlivou rok (a sbírka vlastností přidáno / aktualizováno), a pak se souhrnná hodnota pro celou řadu let také vypočítat. Pokud je vyžadována pouze souhrnná hodnota pak zrušte zaškrtnutí políčka Vypočítat a rok Nákladymožností, jak je popsáno níže, jak ušetřit na počtu nemovitostí v projektu.

6. Vyberte, zda chcete nechat Vypočítat a rok Nákladykontrolovány, nebo zrušte jej.

7. Klepněte na tlačítko Další.

8. Volitelně vybrat PřipojeníChcete-li přiřadit náklady spolu jako součást hodnocení.

Poznámka

Používání Náklady | Přisuzovánínemovitost na nákladech Connections může být přidělený z komponenty připojené ke konci umyvadla připojení k součásti připojené ke zdroji konec(tj Náklady | Attribution = "Sink ke zdroji"), nebo z komponenty připojené k zdroj Konec připojení k součásti připojené k dřez konec(tj. Náklady | Attribution = "Zdroj Sink"), Dále, ABACUS automaticky vybere ty spoje s Chování | Vztah = "procesy" nebo "podporuje"a směr přičtení bude "propadem na zdroje", Kromě toho jsou náklady rozděluje podle kteréhokoliv z chování | % Nebo pořizovací cena | % Reality na připojení, případně tam, kde jsou více připojení od dřezu mnoha zdrojůnebo zdroj mnoha dřezy, Podle kteréhokoliv z chování | Zpracování reality na zdrojové komponentynebo dřez komponent, resp.

9. Klepněte na tlačítko Dokončita získáte Varování dialog.

10. Volitelně prozkoumat varování kliknutím Podrobnosti >>.

11. Klepněte na tlačítko Pokračovat.

Poznámka

V tomto bodě, ABACUS bude provádět podle činností kalkulace vyhodnocení architektury (ů) a po krátké době (s bary pokroku pro zpětnou vazbu), zobrazí se dialogové okno výpočet kompletní.

12. Klepněte na tlačítko Dobřeuznat hodnocení.

Tip

Pro pořádání školení a další pomoc na náklady Simulace najdete na Avolution Community .

Komponent a / nebo připojení Vlastnosti

V následující tabulce jsou uvedeny komponenty a / nebo připojení požadované vlastnosti vyhodnotit náklady.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou vstup nemovitost voliče řádku ( [image] ) S bublině "Ekonomický vstupní". Změna na některou z těchto "vstup" vlastností a různých strukturálních změn úložiště bude mít za následek náklady simulátoru vyžadující re-simulace, jak je uvedeno v Červený na Panel nástrojů Simulace .

Typ

Jméno

Výchozí hodnota

Jednotka

Datový typ

Požadovaný

Popis

Náklady

Instalace Horizon

0

léta

Celé číslo

Pravda

Určuje, kdy komponenta nebo připojení byl nebo bude nainstalován.

· Hodnota 0 (výchozí) označuje, že složka nebo připojení je instalována v běžném roce.

· Hodnota menší než 0 naznačuje, že složky nebo připojení byl nainstalován v minulosti.

· Hodnota vyšší než 0 označuje, že složky nebo připojení budou instalovány v budoucnu.

Náklady

Životnost

0

léta

Celé číslo

Pravda

Určuje délku času, ve kterém složka nebo připojení zůstane v provozu, po kterém bude vyřazeno z provozu.

Náklady

FTE

100.000,00

$ / rok

Desetinný

Falešný

Roční náklady na každého Hlavní pracovní poměr.

Pokud tato vlastnost není nalezen ve složcesamotný nebo v případě připojení komponentu připevněna na konci dřezu spoje, Bude hledat v ostatních složek.

Za prvé, jakýkoli "umyvadlo" komponents na konci a Spojení s "podporuje" vztah ke komponentě budou hledány, následovaný že "propadem" komponenty rodičes.

Pokud vlastnost FTE není nalezen, komponenty rodič-components pak bude prohledávat. Pokud stále není nalezen FTE, je použita výchozí hodnota.

Upozornění: FTE je pouze platný vstup nemovitost na komponenty.

Náklady

Náklady na údržbu (pevné)

0.00

$ / rok

Desetinný

Falešný

Roční fixní náklady na údržbu na komponentunebo připojení.

Náklady

Náklady na údržbu (variabilní)

0.00

$ / rok

Desetinný

Falešný

Částka, o niž se celkové náklady na údržbu na komponentu nebo připojení se bude měnit každý rok.

Například, hodnota $ -500 znamená, že celkové náklady na údržbu klesá každý rok $ 500, zatímco hodnota 500 $ ukazuje, že celkové náklady na údržbu se zvyšuje každým rokem $ 500.

Náklady

Podpora úsilí (pevné)

0.00

FTE / rok

Desetinný

Falešný

Roční pevný úsilí podporovat komponentynebo připojení, Které jsou uvedeny v podmínkách osoboroků.

Náklady

Podpora úsilí (variabilní)

0.00

FTE / rok

Desetinný

Falešný

Částka, o kterou celková intenzita nosných komponentu nebo připojení se bude měnit každý rok.

Například hodnota -0.01 ukazuje, že celková podpora úsilí klesá o 0,01 osoby letech každý rok, zatímco hodnota 0,01 znamená, že se zvyšuje celková podpora úsilí o 0,01 každý rok.

Náklady

Kapitálové náklady

0.00

$

Desetinný

Falešný

Počáteční náklady na nákup komponentynebo připojení.

Náklady

Instalace Effort

0.00

FTE

Desetinný

Falešný

Úsilí povinna v osobo-roků, nainstalovat součástnebo připojení.

V následující tabulce jsou uvedeny komponenty a / nebo připojení Vlastnosti, které jsou na výstup TCO hodnotitele. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Cost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a náklady simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Poznámka

Tam, kde musí být výstupní vlastnosti z TCO hodnotitele "zaoblené" "kulatého polovinu dokonce" přístup (označovaný také jako "bankéři" zaokrouhlení) je používán.Tato technika se používá k rovnoměrněji vyřešení .5 'tie-breaky "s výsledkem být zaokrouhlena nahoru nebo dolů na nejbližší dokonce Výsledkem je, spíše než vždy zaokrouhlení směrem nahoru nebo dolů, a zkosení výsledek. Tj. 2.5 se zaokrouhlí dolů na 2, zatímco 3.5 se zaokrouhluje na 4, spíše než oni oba jsou buď zaokrouhlí dolů na 2 a 3 nebo zaokrouhluje nahoru na 3 a 4.

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Náklady | Celkové náklady na vlastní - dalších x let. | $ | Celé číslo | Falešný | Celkové náklady na vlastnictví během příštích xlet, kde x je délka doby zadán při spuštění hodnotitelem. To zahrnuje náklady na součásti nebo připojení je normy, sub-komponentynebo sub-spoje(tj. děti) a jakékoliv připisovaných náklady.
Náklady | Celkové náklady pro účely vlastnictví (místní) - další x let. | $ | Celé číslo | Falešný | "Místní" náklady na vlastnictví během příštích xlet, pokud xje délka doby zadán při spuštění hodnotitel. To dělá nezahrnují náklady na dílčích komponent této komponenty nebo sub-spoje připojení v systému (tj.děti) nebo jakékoli připisovaných náklady.
Náklady | Celkové náklady pro účely vlastnictví (děti) - další x let. | $ | Celé číslo | Falešný | Náklady na "děti" vlastnictví během příštích xlet, kde x je délka doby zadán při spuštění hodnotitelem. Tento pouze zahrnuje náklady na dílčích komponent této komponenty nebo sub-spoje připojení v systému (tj. děti).
Náklady | Celkové náklady pro účely vlastnictví (připsaný) - další x let. | $ | Celé číslo | Falešný | "Připsat" náklady na vlastnictví během příštích xlet, kde x je délka doby zadán při spuštění hodnotitelem. Tento pouze zahrnuje veškeré náklady připisovány z připojených komponentů(který může samozřejmě zahrnovat přiřazena nákladům od všech připojených připojení).

V následující tabulce jsou uvedeny komponenty a / nebo připojení Vlastnosti, které jsou na výstup TCO hodnotitelev případě, že Vypočítat Per-Year náklady je vybrána možnost. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Cost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a náklady simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Poznámka

Viz poznámka výše o možném zaokrouhlení výstupních vlastností.

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Náklady | Celkové náklady na vlastní - rokx. | $ | Celé číslo | Falešný | Celkové náklady na vlastnictví pro rok x, Kde x je za každý rok zadán při spuštění hodnotitel. To zahrnuje náklady na součástinebo připojení je normy, sub-komponenty nebo sub-spoje (tj. děti) a jakékoliv připisovaných náklady.
Náklady | Celkové náklady pro účely vlastnictví (místní) - rokx. | $ | Celé číslo | Falešný | "Místní" náklady na vlastnictví pro rok x, kde xje za každý rok zadán při spuštění hodnotitel. To dělá nezahrnují náklady na dílčích komponent této komponenty nebo sub-spoje připojení v systému (tj. děti) nebo jakékoli připisovaných náklady.
Náklady | Celkové náklady pro účely vlastnictví (děti) - rokx. | $ | Celé číslo | Falešný | Klávesy "děti" náklady na vlastnictví pro rok x, Kde x je za každý rok zadán při spuštění hodnotitel. Tento pouze zahrnuje náklady na dílčích komponent této komponenty nebo připojení v sub-přípojka (tj. děti).
Náklady | Celkové náklady pro účely vlastnictví (připsaný) - rokx. | $ | Celé číslo | Falešný | "Připsat" náklady na vlastnictví pro rok x, Kde x je za každý rok zadán při spuštění hodnotitel. Tento pouze zahrnuje veškeré náklady připisovány z připojených komponentů(který může samozřejmě zahrnovat přiřazena nákladům od všech připojených připojení).

Další Vlastnosti připojení

V následující tabulce další vlastnosti připojení, které jsou vyžadovány TCO hodnotitele. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou vstup nemovitost voliče řádku ( [image] ) S bublině "Vstupní cena / výkon" nebo jen "Ekonomický vstupní". Změna na některou z těchto "vstup" vlastností a různých strukturálních změn úložiště bude mít v ceně a / nebo Výkon simulátor vyžadující opětovné simulace, jak je uvedeno v Červený na Panel nástrojů Simulace .

Typ | Jméno | Výchozí hodnota | Jednotka | Datový typ | Požadovaný | Popis
Náklady | Přisuzování | Dřez na zdroj | [Zdroj potopit | Dřez na zdroj] | Vyhledávání / List | Pravda | Li "Zdroj Sink", Toto spojení bude mít mít nákladyspřidělený "spolu" to z zdrojkomponent do dřez komponent, Alternativně, pokud "Dřez na zdroj", Toto spojení bude byly náklady připsat "spolu" to z dřezu složky k zdrojové komponenty.
Chování | Vztah | podpěry | [procesy | podporuje] | Vyhledávání / List | Falešný | Je-li "podpěry", toto spojení znamená, že "zdroj" složka je podporován "umyvadlem" složky. Navíc pokud buď "podporuje" nebo "procesy", pak bude spojení automaticky vybrané ve spojeních, aby jejich náklady připsat 'po' od dřezu komponenty ke zdrojovému komponentu.
Náklady | % | 100.0 | % | Desetinný | Falešný | Udává podíl nákladů dřezu součásti, které budou připisovány na zdrojové komponenty. V% hodnoty není nutné přidat až 100%, a to je prostě použitý na změnu velikosti "Celkové náklady na vlastní -. Další x let" nemovitostí (viz výše), z komponenty výlevky tak, jak je přičítáno zdrojové komponentě.

Vlastnosti Architektura

V následující tabulce jsou uvedeny vlastnosti, architektury, které jsou na výstup TCO hodnotitelem. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Cost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a náklady simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Poznámka

Viz poznámka výše o možném zaokrouhlení výstupních vlastností.

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Náklady | Celkové náklady na vlastní - dalších x let. | $ | Celé číslo | Falešný | Celkové náklady na vlastnictví celé architektury v příštích x letech.

V následující tabulce jsou uvedeny vlastnosti, architektury, které jsou na výstup TCO hodnotitelev případě, že Vypočítat Per-Year náklady je vybrána možnost. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Cost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a náklady simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Poznámka

Viz poznámka výše o možném zaokrouhlení výstupních vlastností.

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Náklady | Celkové náklady na vlastní - rokx. | $ | Celé číslo | Falešný | Celkové náklady na vlastnictví pro celá architektura pro rok xdo budoucnosti.


Simulace Spolehlivost a dostupnost

Navigace: Simulace vaší architektury> Simulátory>

Simulace Spolehlivost a dostupnost

Odeslat připomínky na toto téma.

Pozadí

Spolehlivost Hodnotitel vypočítá spolehlivost architektury pomocí vstupních komponent a připojení.

Pro komponenty a přímým spojením, spolehlivost je založena na Střední doba mezi poruchami (MTBF). Jediné proměnné potřebné pro výpočet spolehlivosti architektonických prvků jsou:

· MTBFhodnota (v letech);

· Střední doba opravy (MTTR)selhání (v letech); a

· Definovaná doba si chcete otestovat spolehlivost přes.

Vzorec použitý při výpočtu spolehlivosti je dána jako:

Spolehlivost = -e (-y x věk)
Tam, kde y = 1 ÷ MTBF

Dostupnost součástek a spojů je založen na MTBF a MTTR. Všimněte si, že dostupnost, na rozdíl od spolehlivosti, není ovlivněna dobu, pro který je testován.

Dostupnost = MTBF / (MTBF + MTTR)

Zatímco metody, které převádějí Spolehlivost Bloková schémata(pomocí jednoduché série a paralelní konstrukce), dát nejvíce přesné výsledky, tyto metody stávají vysoce impraktický když se snažíme také k výpočtu spolehlivosti pro mise v rámci velkých sítí tisíců prvků. Kromě toho tyto transformační přístupy rozebrat pro mnoho běžných konstrukcí, jako jsou síťové "ok".

Monte Carlometoda umožňuje spolehlivost a dostupnost systému libovolné velikosti a složitosti být vypočtena. Metoda Monte Carlo simuluje řadu scénářů a fnebo každý scénář náhodný stát, dostupný nebo nedostupné, Je přiřazen ke každé fyzický prvek. Pravděpodobnost daného prvkem je v dostupném stavu je založen na spolehlivosti / dostupnosti komponenty.

Například, komponenta s 90% dostupností lze očekávat, že bude k dispozici v přibližně 90% scénářů. Spolehlivost a dostupnost nepřímé souvislosti může být proto odhadnuta jako podíl náhodné scenarios-, u nichž cesta prvků existuje ve dostupného výkazu ze zdroje k cíli.

Poznámka

Vzhledem k tomu, výpočet místní spolehlivosti a dostupnosti je založen na různých parametrů a různých vzorců (a tedy má za následek různé hodnoty), je nutné přiřadit každému prvku dvastavy, jeden pro dostupnost, a jeden pro spolehlivost. Výpočet dostupnosti používá stav dostupnosti v každém případě, že výpočet spolehlivosti využívá stav spolehlivost v každé situaci.

Spolehlivost Hodnotitel používá Monte Carlo simulační techniku ​​vypracovat spolehlivost konkrétní architektury. Architektura je podroben tisíců jednotlivých simulací a výsledky tabelovány odvodit spolehlivosti opatření. Jak bylo uvedeno výše, Monte Carlo je nejrychlejší metoda pro simulaci větších sítí a bude pracovat v každém složitém (tj propojené) struktury.

Hodnotitel výstupy čtyři hodnoty:

1. Mise Spolehlivostv průběhu několika let;

2. Dostupnostz architektura;

3. Spolehlivostz Místní složkav průběhu několika let; a

4. Dostupnostz Místní složka.

Hodnotitel vyjde pravděpodobnost součást nebo funkční připojení (tj. ne selhání) a čas potřebný na opravu.

Jak norem s MTBFs a / nebo MTTRs zachází

Pokud prvek (komponenta nebo připojení) má standardů s přiřazenou MTBF a / nebo MTTR hodnoty, tyto hodnoty se také používají při výpočtu místního spolehlivosti a dostupnost prvku jako spojení řad.

Například, je-li komponenta A, S přiřazenými standardy B, C, a Dkaždý mají MTBF a MTTR hodnota, místní Spolehlivost = R(A)× R(B) × R(C) × R(D), kde R = Vypočtená spolehlivost (podle vzorce) složek / norem a Místní Užitekschopnost = A(A)× A(B) × A(C) × A(D), kde A = Vypočtená užitekSchopnost (pomocí vzorce) součásti / normami. To znamená, že pokud prvek má tři úrovně každý s MTBF a MTTR hodnotas, A také MTBF a MTTR hodnotaspro vlastnosti elementovýma, místní spolehlivost a ohledem dostupnosti se podává jako série hodnoty každé z norem a samotného prvku.

Jako další příklad, je-li komponenta Amá přiřazené standardy B, C, a Dale pouze standardní Bmá jak MTBF a hodnotu MTTR, zatímco standardní Cmá pouze MTBF hodnotu a standardní Dmá pouze hodnotu MTTR, Místní Spolehlivost = R (A)× R (B)× R (C), kde R= Vypočtená spolehlivost (podle vzorce) složek / normy a místní Dostupnost = A (A)× A (B)× A (C), kde A= Vypočtená dostupnost (podle vzorce) složek / normami, ale ve výpočtu (C), protože standard má pouze hodnotu MTBF je 'vyhledávání'pro hodnotu odpovídající MTTR (y) a dodá všechny hodnoty MTTR zjistí, že don't samy mají hodnotu MTBF odpovídající, takže v tomto případě by použít hodnotu MTTR standardních D, Pokud tam byl další standard, říkají E, Pouze s hodnotou MTTR i poté A (C)by používal MTBF Cs MTTR z D a Esčítají. Pokud jiného standardu, řekněme F, Měl jen hodnotu MTBF poté A (F)by se také použít MTTR z D a Esčítají.

Výpočet Mission Spolehlivost

Při výpočtu místní spolehlivost, je věc pomocí jednoduchého vzorce, výpočet nepřímých připojení (mise) není tak snadné, zvláště jakmile budeme mít složité a velké sítě prokládaných cest (připojení) a komponenty.

Vezmeme-li v úvahu celou síť

Vzhledem k tomu, nepřímé spojení nepředstavují fyzické připojení, musíme zjistit, jak zdrojová komponenta může dostat do cílové složky. A to znamená při pohledu na celé sítě a všech různých způsobů, jak (a cest), náš zdroj komponenta může přijmout k dosažení cílové složky (umyvadlo).

Poznámka

Tak dlouho, jak je zde alespoň jeden kompletníCesta od zdroje k cíli, bude mise úspěšnáa nepřímé spojení se označuje jako uzavřený spojení.

Pochopení Link Matrix

Vědět, které součásti / přímé spoje jsou spojeny s tím, co, potřebujeme artefakt rychle kontrolovat, zda jsou dva bloky spojeny v určitém směru. Tato funkce článkového matrice. Stručně řečeno, spojení matice je dvourozměrné pole booleovských proměnných, které stanoví, zda je konkrétní složka může dosáhnout další krok přímo. Jeho velikost je rovna čtverci celkového počtu součástí v síti.

Jednoduchý Spolehlivost Blokové schéma (RBD)

Související Link Matrix pro blokový diagram spolehlivosti (RBD)

Protože ne všechny spoje jsou obousměrné (bude v obou směrech), je důležité vědět, jak správně číst propojení matici. V spolehlivosti hodnotitele, první argument je zdroj a druhý argument je cíl (umyvadlo).

Pokud tedy odkaz matice (A, B) = pravda, pak to znamená, že můžete dostat do B přímo (jednosměrná). B může dostat do A kdyby jen v případě, odkaz matice (B, A) = true. Pokud je to pravda, to znamená obousměrné spojení.

Ve výše uvedeném příkladu výše:

· Zdroj 1 může dosáhnout cíle 0 (zdroj 1 a Destination 0 dává výsledek true); a

· Source 0 může dosáhnout cíle 1 (zdroj 0 a Cíl 1 dává výsledek true), jako je souvislost mezi 0 a 1 je obousměrný.

· Zdroj 2 nelze dosáhnout cíle 1 (zdroj 2 a Cíl 1 dává výsledek False), i když zdroj 1 může dosáhnout cílového 2 (zdroj 1 a cíl 2 dává výsledek True). To znamená, že je spojení mezi 1 a 2 je uni-řídící.

Pochopení spolehlivost Block Diagram

Spolehlivost blokový diagram (RBD) zapouzdřuje strukturu celého modelu objektu, pokud jde o bloky a odkazů. Každý blok představuje prvek, který má možnost úspěšnosti nebo neúspěšnosti v závislosti na Odkazy / cest, které je spojují. Obě složky a spojení se může stát "blok" v oblasti povodí.

Příklad RBD bloky a odkazy

Postava výše představuje příklad RBD. Přerušovaná červená čára představuje jednoduchou misi 4 na 1. Poznámka: jak tam jsou jen dvě možné cesty k misi 4 na 1.

Vezměme si cestu 4: 3 na 0 na 1 a trasu 4 až 7 do 1. tečkovanou bloky 2, 5a 6 představují bloky, které nemají vliv na selhání / non-selhání mise 4 na 1. Jsou nebere v úvahu a jsou ignorovány. To je důležité, protože pro většinu mise bude velký počet redundantních bloky, které nebude mít vliv na úspěšnost konkrétního mise. To je více patrný ve větších sítích, přičemž počet redundantních bloků bude výsledky simulace nepřesné.

Pro urychlení simulační čas, a zajistí přesnější výsledky, je nezbytné abstraktní z celé povodí a použít pouze ty prvky, které mají vliv na úspěšnost dané mise.

Poznámka

Jediná cesta / cesta nemůže projít kteroukoli složku dvakrát.

V této fázi můžeme vytvořit odkaz matice a provádět simulace Monte Carlo.

Výpočet Architektura Dostupnost

Architektura dostupnost je pravděpodobnost, že všechny nepřímé připojení bude k dispozici v každém okamžiku. Dostupnost každé nepřímé spojení určuje při každém opakování simulace Monte Carlo, nicméně tyto nepřímé spojení (typicky) spoléhají na stejný soubor fyzických prvků. Proto, prostě agregaci tyto jednotlivé dostupnosti by "double-počet" těchto un-hotely jsou volné, což pesimistický celkovou architekturu dostupnost. Alternativně, celková architektura dostupnost se vypočítá při pohledu na každé iteraci a vidět, zda jsou k dispozici prvky, podílející se na nepřímé připojení zájmu. A pak součtem těchto výsledky na konci cvičení.

Spuštění spolehlivost simulátor

Pro simulaci vaší architektury z hlediska spolehlivosti

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Vybrat Analýza| Spolehlivost.

3. Vyberte ArchitekturaChcete-li zhodnotit z rozbalovacího menu.

Poznámka

Ve výchozím nastavení bude ABACUS automaticky vyberte první architekturu, pro které je z důvodu požaduje nové simulace na jakékoli dané nemovitosti či strukturálních změn.Toto zvýraznění je uvedeno v Červený na Panel nástrojů Simulace .

4. Vyberte Komponenty a PřipojeníChcete-li zhodnotit od okno pro výběr standardním prvkem pomocí "Zobrazit přímé spojení 'a' show procesy zapojení na radio-Button Filters v levé dolní části dialogového okna k pomoci s výběrem vás.

Další Checkboxk okno pro výběr standardním prvkem

· Save převáděl model bude uložit kopii RBD transformovaného verze projektu ve stejné složce jako aktuální projekt a přidat "_transformed" k názvu projektu.Tento transformovaný projekt lze využít k diagnostice podrobně simulaci spolehlivosti podnikané ABACUS.

Další Radio-Tlačítkak okno pro výběr standardním prvkem

· Ukázat přímé spojení automaticky nastaví bylo propojení filtru majetku za Typ nemovitosti = Chování, Name = Abstrakce a hodnota = přímá.Tato volba je vybrána ve výchozím nastavení a pomáhá výběr "přímé" spojení, jak je popsáno výše a níže.

· Zobrazit procesy Připojení automaticky nastaví bylo propojení filtru majetku za Typ nemovitosti = Chování, Name = Vztah a Hodnota = procesů.Tato možnost napomáhá výběr "přímé" spojení, jak je popsáno výše a níže.

5. Klepněte na tlačítko Další.

6. Vyber Misetj Připojení budete chtít zahrnout do simulace.

7. Nastavení Run Time Scale Factorslider.

Poznámka

Vyšší hodnoty přinese více statisticky konzistentní výsledky, ale trvat delší dobu pro výpočet.

Checkboxes

· Show Uzavřené Připojení bude automaticky filtrování dostupných připojení k obsahují pouze ty, které mají alespoň jednu úplnou fyzickou cestu ze zdrojové složky, která se v cílové složky dle výběru RBD popsané výše.

· Ukázat Nepřímé připojení automaticky nastaví bylo propojení filtru majetku za Typ nemovitosti = Chování, Name = Abstrakce a hodnota = nepřímé.Tato volba je vybrána ve výchozím nastavení a pomáhá výběr "nepřímé" nebo Mission připojení, jak je popsáno výše a níže.

Tlačítka

· Vševybere všechny Připojení.

· Obrátitzruší všechny aktuálně vybraná Připojení a vybere všechny ty, které nebyly vybrány.

· Žádnýzruší výběr všechny Připojení.

Další možnosti

· Run Time Scale Factor reguluje doba, simulace a přesnost s vyšším Hodnoty výnosIngvíce statisticky konzistentní výsledky, ale převzetí delší čas běh.

Poznámka

Při ABACUS vypočítává počet iterací simulovat to bude určovat nejspolehlivější prvek, který není dokonale spolehlivé a potom simulovat na Run Time Scale Factor časů 1 nad nedostupnosti tohoto prvku a 1 opakování. Nebo (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. To je, aby se ujistil, že tento prvek stále nedaří alespoň jednou v simulaci. Např. V případě, že nejspolehlivější prvek, který není dokonale spolehlivá má MTBF 10.000 hodin a MTTR 8 hodin, pak simulace bude trvat (10,000 + 8) / 8 = 1251 krát faktor Run časové měřítko + 1 iterací.

· Roky simulovat Ahead určuje počet let pro mise spolehlivost být vypočítána pro.

· Nžlutohnědý závitůdetermines počet zpracovatelských vláken použitých pro simulace Monte-Carlo.Tato volba bude výchozí odpovídal počtu dostupných CPU / jádra (včetně Hyper-Threading jádra), aby se minimalizovalo celkové simulační čas.

8. Klepněte na tlačítko Dokončita získáte Varování dialog.

9. Volitelně prozkoumat varování kliknutím Podrobnosti >>.

10. Klepněte na tlačítko Pokračovat.

Poznámka

V tomto okamžiku, ABACUS se provést Monte Carlosimulace architektury a po krátké době (s bary pokroku pro zpětnou vazbu), zobrazí se dialogové okno výpočet kompletní.

11. Klepněte na tlačítko Dobřeuznat simulaci.

Tip

Pro pořádání školení a další pomoc na spolehlivost Simulace najdete na Avolution Community .

Komponent a připojení vlastnosti

V následující tabulce jsou uvedeny komponenty a 'řídit'požadované vlastnosti připojení k hodnocení spolehlivosti. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou vstup nemovitost voliče řádku ( [image] ) S bublině "Spolehlivost Input". Změna na některou z těchto "vstup" vlastností a různých strukturálních změn úložiště bude mít za následek spolehlivosti simulátoru vyžadující re-simulace, jak je uvedeno v Červený na Panel nástrojů Simulace .

Typ | Jméno | Výchozí hodnota | Jednotka | Datový typ | Požadovaný | Popis
Spolehlivost | MTBF | ∞ | let, týdny, dny nebo hodiny | Desetinný | Pravda | Průměrná doba před výpadkem prvku. Poznámka: Hodnoty mohou být vyjádřeny v jednotkách let, týdnů, dní nebo hodin a jsou přeměněny na základě ve 24/7 'obsazenost koncepce takto; - 1 rok = 52 týdnů nebo 365 dní nebo 8760 hodin - 1 týden = 7 dní nebo 168 hodin - 1 den = 24 hodin
Spolehlivost | MTTR | 0 | let, týdny, dny nebo hodiny | Desetinný | Pravda | Průměrná doba do opravy prvku. Poznámka: Hodnoty mohou být vyjádřeny v jednotkách let, týdnů, dní nebo hodin a jsou přeměněny na základě ve 24/7 'obsazenost koncepce takto; - 1 rok = 52 týdnů nebo 365 dní nebo 8760 hodin - 1 týden = 7 dní nebo 168 hodin - 1 den = 24 hodin

V následující tabulce jsou uvedeny komponenty a 'řídit' Vlastnosti připojení na výstup spolehlivosti hodnotitelem. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Spolehlivost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a spolehlivost simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Spolehlivost | Spolehlivost - x let |  | Desetinný | Falešný | Pravděpodobnost, že element neselže v příštích x let. Toto je hodnota mezi 0 a 1.
Spolehlivost | Nespolehlivost - x let |  | Desetinný | Falešný | Pravděpodobnost, že prvek se nezdaří v následujících x let. Toto je hodnota mezi 0 a 1.
Spolehlivost | Dostupnost | % | Desetinný | Falešný | Vypočtená dostupnost složky nebo připojení. Toto je hodnota mezi 0% a 100%.
Spolehlivost | Nedostupnost | % | Desetinný | Falešný | Vypočtená nedostupnost složky nebo připojení. Toto je hodnota mezi 0% a 100%.

V následující tabulce jsou uvedeny 'nepřímý'Vlastnosti připojení na výstup spolehlivosti hodnotitelem. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Spolehlivost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a spolehlivost simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Spolehlivost | Mise Spolehlivost - x let |  | Desetinný | Falešný | Pravděpodobnost, že nepřímé spojení neselže v příštích x letech. Toto je hodnota mezi 0 a 1.
Spolehlivost | Mise Nespolehlivost - x let |  | Desetinný | Falešný | Pravděpodobnost, že nepřímé připojení se nezdaří v následujících x let. Toto je hodnota mezi 0 a 1.
Spolehlivost | Dostupnost | % | Desetinný | Falešný | Vypočtená dostupnost nepřímé připojení. Toto je hodnota mezi 0% a 100%.
Spolehlivost | Nedostupnost | % | Desetinný | Falešný | Vypočtená nedostupnost nepřímé připojení. Toto je hodnota mezi 0% a 100%.

Vlastnosti Architektura

V následující tabulce jsou uvedeny vlastnosti architektura výstupu o spolehlivosti hodnotitele. Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Spolehlivost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku dané nemovitosti či strukturální změny úložiště a spolehlivost simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Jednotka | Datový typ | Požadovaný | Popis
Spolehlivost | Dostupnost | % | Desetinný | Falešný | Dostupnost všech nepřímé připojení, které byly zahrnuty do hodnocení. To znamená, že pravděpodobnost, že všenepřímé připojení bude k dispozici v daném okamžiku. Toto je hodnota mezi 0% a 100%. Poznámka: Toto není násobení jednotlivých připojení dostupnosti protože by to bylo "dvojímu započítání" OSN dostupnosti příslušné složky.
Spolehlivost | Nedostupnost | % | Desetinný | Falešný | Nedostupnost nepřímých připojení, které byly zahrnuty do hodnocení. To znamená, že pravděpodobnost, že alespoň jedennepřímé spojení bude k dispozici v daném okamžiku. Toto je hodnota mezi 0% a 100%. Poznámka: Toto není násobení jednotlivých připojení unavailabilities protože by to bylo "dvojímu započítání" OSN dostupnosti příslušné složky.
Spolehlivost | Mise Spolehlivost - x let |  | Desetinný | Falešný | Pravděpodobnost, že všechny nepřímé připojení, které byly zahrnuty do hodnocení bude to selhání během příští xroky. Toto je hodnota mezi 0 a 1. Poznámka: Toto není násobení jednotlivých připojení spolehlivostí protože by to bylo "dvojímu započítání" OSN dostupnosti příslušné složky.
Spolehlivost | Mise Nespolehlivost - x let |  | Desetinný | Falešný | Pravděpodobnost, že alespoň jedna z nepřímé připojení, které byly zahrnuty do hodnocení se nezdaří během následujících xroky. Toto je hodnota mezi 0 a 1. Poznámka: Toto není násobení jednotlivých připojení unreliabilities protože by to bylo "dvojímu započítání" OSN dostupnosti příslušné složky.


Simulace Otevřenost

Navigace: Simulace vaší architektury> Simulátory>

Simulace Otevřenost

Odeslat připomínky na toto téma.

Otevřenost Simulátor určí, do jaké míry architektura, a jeho prvky jsou "otevřené", to znamená, že schopnost systému pro zpracování výměna dílů s minimálním dopadem.

Pro simulaci vaší architektury z hlediska otevřenosti

1. Ujistěte se, že máte Soubor ABACUS, Obsahující Váš obydlený architektura, otevřít.

2. Vybrat analýza | Otevřenost.

3. Vyber Architektura (y)Chcete-li zahrnout do hodnocení.

Poznámka

Ve výchozím nastavení bude ABACUS automaticky vyberte první architekturu, pro které je z důvodu požaduje nové simulace na jakékoli dané nemovitosti či strukturálních změn.Toto zvýraznění je uvedeno v Červený na Panel nástrojů Simulace .

4. Klepněte na tlačítko Dokončita získáte Varování dialog.

5. Volitelně prozkoumat varování kliknutím Podrobnosti >>.

6. Klepněte na tlačítko Pokračovat.

Poznámka

V tomto bodě, ABACUS bude provádět strukturální vyhodnocení architektury (ů) a po krátké době (s bary pokroku pro zpětnou vazbu), zobrazí se dialogové okno výpočet kompletní.

7. Klepněte na tlačítko Dobřeuznat simulaci.

Tip

Pro pořádání školení a další pomoc na otevřenosti ohodnocení najdete v části Avolution Community .

Komponent a připojení Standardní vlastnosti

V následující tabulce jsou uvedeny standardní vlastnosti komponenty a spojení požadované pro hodnocení otevřenost.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou vstup nemovitost voliče řádku ( [image] ) S bublině "Otevřenost Input". Změna na některou z těchto "vstup" vlastnosti v úložišti bude mít za následek otevřenosti simulátoru vyžadující re-simulace, jak je uvedeno v Červený na Panel nástrojů Simulace .

Typ | Jméno | Výchozí hodnota | Jednotka | Datový typ | Požadovaný | Popis
Otevřenost | Standardy-Standardní Splatnost-Organizace Level |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Úroveň odpovědné orgány v oblasti norem 0:Organizační / Proprietární 1:Konsorcium / defacto 2:Národní / Military 3: Mezinárodní
Otevřenost | Standardy-Standardní Splatnost-Status |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Dosažená úroveň Schválení s normalizačním orgánem 0:Pracovní / Výbor Návrh 1:Public Návrh / losuje 2:Prozatímní Návrh 3: Schválený
Otevřenost | Standardy-Standardní Splatnost-Stability |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Je standardní pravděpodobně změní? 0:Standardní zastaralý 1:Vysoce mohou změnit v další 1 až 2 roky 2:Známé změna / aktualizace stávajících funkcí 3:Vysoce stabilní (beze změny do 2 let)
Otevřenost | Standardy-Standardní Splatnost-Vendor Support |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Podpora prodejce 0:Žádné produkty nebo dodavatelé podporují standard 1:Jeden nebo více prodejců, které implementují část standardu 2:Více než jeden prodejce s produkty, které implementují všechny části normy 3:Mnohem více než jeden prodejce s produkty, které implementují všechny části normy
Otevřenost | Standardy-Standardní jednoznačnosti-Dokumentace |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Kvalita standardní dokumentaci 0: Chudí 1: Veletrh 2: Dobrý 3: Vynikající
Otevřenost | Standardy-Standardní jednoznačnost-Standardní šířka |  |  | Celé číslo | Falešný | Počet funkcí. Udává počet nejnižších standardní úroveň funkcí - Sf
Otevřenost | Standardy-Standardní jednoznačnosti-Sm |  | % | Desetinný | Falešný | Procentní podíl celkového počtu funkcí, které jsou povinné
Otevřenost | Standardy-Standardní jednoznačnosti-So |  | % | Desetinný | Falešný | Procentní podíl celkového počtu funkcí, které jsou volitelné
Otevřenost | Standardy-Standardní jednoznačnosti-Sc |  | % | Desetinný | Falešný | Procentní podíl celkového počtu funkcí, které jsou podmíněně definovány
Otevřenost | Profily-Profile-Documentation Dokumentace |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Kvalita standardní dokumentaci 0: Žádný 1: Chudí 2: Veletrh 3: Vynikající
Otevřenost | Profily-Profile Documentation-Přesnost |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Má dokumentace odrážet skutečnou návrhu systému? Jakou úroveň vlastností profilu se používají v systému? 0:Žádná funkce 1:Některé funkce 2:Většina funkcí 3:Všechny funkce
Otevřenost | Profily-Profile dokumentace splatnosti |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Je profil zralý a jsou k dispozici? 0:Ad-hoc 1:Založené Project 2:Organizační 3: Veřejnost
Otevřenost | Profily-Profile jednoznačnost-Explicit Šířka |  |  | Celé číslo | Falešný | Počet standardních funkcí uvedených jak je požadováno v profilu
Otevřenost | Profily-Profile jednoznačnosti-PM |  | % | Desetinný | Falešný | Procento povinných prvků v profilu
Otevřenost | Profily-Profile jednoznačnosti-Po |  | % | Desetinný | Falešný | Procento volitelných funkcí v profilu
Otevřenost | Profily-Profile jednoznačnosti-PC |  | % | Desetinný | Falešný | Procento podmíněně DEFINOVÁNO funkce v profilu
Otevřenost | Profily-Profile jednoznačnosti-Pokrytí |  | % | Desetinný | Falešný | Procento standardních funkcí konkrétně řešeny v profilu
Otevřenost | Profily-Profil Extensions Extension Šířka |  |  | Celé číslo | Falešný | Počet non-standardních funkcí určené profilem
Otevřenost | Profily-Profile-rozšíření pokrytí |  | % | Desetinný | Falešný | Procento prodloužení je podrobně uvedeno v profilu
Otevřenost | Dostupnost Výrobky produkt a Shoda Číslo zboží |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Počet produktů podporovat povinné funkce standardu 0:Žádné produkty podporují standard 1:Jednoho nebo více produktů realizovat část standardu 2:Více než jeden produkt provádí všechny části normy 3:Mnohem více než jeden produkt provádí všechny části normy
Otevřenost | Dostupnost Výrobky produkt a shody-přihláška Shoda |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Jakou úroveň shody se výrobky mají standardu? 0: Žádný 1:Prohlašoval 2:Prokázaná 3:Certifikované a demonstroval
Otevřenost | Dostupnost Výrobky produkt a shody, Shoda Quality |  | [0 | 1 | 2 | 3] | Vyhledávání / List | Falešný | Kvalita zkoušení shody 0: Žádný 1:In-house Testování produktu vývojářem 2:Nezávislé testování (např. NIST) 3:Prokázána v rámci příslušného výrobku

Součást, připojení a vlastnosti architektura

V následující tabulce jsou uvedeny součásti, připojení a vlastnosti architektura výstup otevřeností hodnotitele. Všechny z následujících vlastností vyhodnotit mezi nulou (0) a tři (3), nula (0) je nejméně žádoucí a tři (3) je nejvíce žádoucí.Tyto vlastnosti se zobrazí v okně Vlastnosti s ikonou výstupem nemovitost voliče řádku ( [image] ) S bublině "Otevřenost Output". Šipka na ikonu zdůrazní Červený ( [image] ), Pokud tyto vlastnosti jsou zastaralé v důsledku fundamentální změně vlastnictví k úložišti a otevřenosti simulátoru vyžaduje opětovné simulace v závislosti na Červený zvýraznění na Panel nástrojů Simulace .

Typ | Jméno | Datový typ | Požadovaný | Popis
Otevřenost | Otevřenost | Desetinný | Falešný | Celkové hodnocení otevřenosti položky.
Otevřenost | Standardy-Standardní Splatnost | Desetinný | Falešný | Současný stav standardu, což odráží zda nebo ne to bylo schváleno, jak dlouho to bylo v provozu a jak dobře přijat, je v rámci komunity vývojářů.
Otevřenost | Standardy-Standardní jednoznačnosti | Desetinný | Falešný | Jednoznačnost standardů, což odráží potenciální nejasnosti v následujících normách
Otevřenost | Profily-Profile dokumentace | Desetinný | Falešný | Rozsah, v němž profil interface dokumentace je vyvinut a zda je dokumentace profil vyjadřuje skutečnou návrh systému a / nebo zavedený systém
Otevřenost | Profily-Profile jednoznačnosti | Desetinný | Falešný | Míra podrobnosti poskytovány v profilu / specifikaci profil
Otevřenost | Profily-profilu Rozšíření | Desetinný | Falešný | Míra, do jaké profil odpovídá normě, na kterém je založen
Otevřenost | Produkty produkt Dostupnost a shody | Desetinný | Falešný | Zda nebo ne tam jsou otevřeny splňujícího standard produktů pro využití v rámci projektu


Standardní Zprávy

Navigace: Podávání zpráv o vaši architekturu>

Standardní Zprávy

Odeslat připomínky na toto téma.

POČITADLO' norma Zprávy vám umožní získat seznam prvků a spojů v jedné nebo více z vašich architektur. Tato zpráva obsahuje všechny informace týkající se součástí a spojů, včetně vybraných informací o komponentě nebo místa připojení v hierarchii typu, standardy, popis, vlastnosti a jejich příloh.

Poznámka

Obsah Zpráva jekonfigurovatelnýNíže prostřednictvím dialogovém okně Možnosti zpráva popsána, nicméně, to zjistit více informací o tom, jak vytvořit plně konfigurovatelný zakázku Zprávypoužití ABACUS vlastní sestavy, prosím odkazují na téma zde nebo Kontakt Podpora Avolution .

Chcete-li zobrazit norma zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura(s).

2. Vybrat Vložit| Standardní zprávanebo klikněte na Vytvořit standardní zprávu tlačítko na panelu nástrojů. Report Configurationse zobrazí okno.

Okno Configuration Report

3. Vyberte Architektury, Komponenty a Připojeníže chcete ve zprávě podaná Okno Configuration Report.Podívejte se prosím na výběr standardní součástí zde téma pro pomoc.

4. Nyní klikněte na tlačítko MožnostiTlačítko a Možnosti zprávaZobrazí se okno.

Okno Možnosti Report

5. Můžete si vybrat, k zobrazení Nová stránka pro každého prvkuSe Datum vytištění, Print Time, Čísla stráneka zda obsahovat název v záhlavízprávy zaškrtnutím / unticking příslušná zaškrtávací políčka. Můžete také přizpůsobit titul a autora editací Report Název a Autor textových polí. Můžete si také vybrat, jaký obsah se zobrazí na zprávě zaškrtnutím / unticking zaškrtávacích políček pod Zpráva Obsahčást okna. Po dokončení klikněte na Dobře.

6. Nyní klikněte na DokončitV okně Configuration Report.

Vykládat zobrazitelné zprávu

Příklad generované zprávy se krátce vysvětleny

Chcete-li procházet stránek zprávy, klepněte na ikony [image] umístěny na panelu nástrojů v levém horním rohu obrazovky.

Poznámka

Můžeš uložit hlášení do různých formátů kliknutím na tlačítko Vývozní Ikona zpráva [image] Nachází v panel nástrojů. Můžete si vybrat, pro export do těchto formátů: Vynikat, PDF a Slovo, Prosím, uložte sestavu v požadovaném místě pro pozdější použití. Pokud jsou provedeny změny v architektuře v pozdější fázi, bude nová zpráva musí být vytvořeny tak, aby odrážely změny.

Viz také

Analýza vaší architektury


Vlastní sestavy

Navigace: Podávání zpráv o vaši architekturu>

Vlastní sestavy

Odeslat připomínky na toto téma.

Uživatelské sestavy Abacus 'umožňují vytvářet plně konfigurovatelný vlastních sestav. Zprávy mohou obsahovat vlastní snímky a grafiku, stejně jako popisovat veškeré konstrukční díly, spoje nebo atributy z úložiště ABACUS, jakož i podrobných analytických výsledků z různých simulací (včetně TCO, výkonnost a spolehlivost). Kromě toho mohou zprávy obsahují diagramy, grafy, katalogy, matice / kontingenční tabulky, mapy, měřidla, Sparklines, datové bary a ukazatelů (např dopravně-světla).

Poznámka

Po dobu, kdy uživatel může otevřít již existující vlastní sestavy, to configure Zprávy licence uživatel potřebuje Report Configuration schopnost. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

Chcete-li zobrazit zvyk zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura(s).

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavyse zobrazí okno.

Vlastní sestavy okno

3. Vyberte existující Zprávaže chcete vystavit z Dostupné zprávy sekce.

4. Klepněte na tlačítko Run Report.Tato zpráva se otevře v aplikaci Microsoft Report Viewer a to Procházejte stránek zprávy, klepněte na ikony [image] umístěny na panelu nástrojů v levém horním rohu obrazovky.

Poznámka

Můžeš uložit hlášení do různých formátů kliknutím na tlačítko Vývozní Ikona zpráva [image] Nachází v panel nástrojů. Můžete si vybrat, pro export do těchto formátů: Vynikat, PDF a Slovo, Prosím, uložte sestavu v požadovaném místě pro pozdější použití. Pokud jsou provedeny změny v architektuře v pozdější fázi, bude nová zpráva musí být vytvořeny tak, aby odrážely změny.

Na upravit data úložiště, která je odeslána a zvyk zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura(s).

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavy okno (viz výše) Zobrazí.

Poznámka

Po dobu, kdy uživatel může otevřít již existující vlastní sestavy, to configure data, která je odeslána na vlastní zprávě licence uživatel potřebuje Report Configuration schopnost. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

3. Vyberte existující Zprávaže chcete vystavit z Dostupné zprávy sekce.

4. Klepněte na tlačítko Upravit Datové sady. Data Set Editorse zobrazí okno.Toto okno zobrazuje sbírku souborů dat, které jsou v současné době zasílány vlastní zprávě. V níže uvedeném příkladu jsou tři (3);

· soubor ApplicationProxy data, která udává všechny údaje pro všechny komponenty aplikací v "2015" Aktuální architektury (včetně vlastností o svých normách a jakýchkoli připojených komponent),

· sada TwoDViewProxy dat, která je zadáním jednoho nebo více schémat, kde název odpovídá "aplikačního prostředí (Austrálie)",

· TargetProxy sada dat, která udává všechny údaje pro všechny cílové spoje v roce 2015 "Skutečná" architektury (včetně připojených komponentů).

Data Set Editor okno

Poznámka

Name dotazu bude použit pro název sady dat v aplikaci Microsoft Report Builder (viz níže). Zahrnout pole určuje, zda datový soubor je buď jednoduché čidlo, kolekci prvků, všechny typy komponent, všechny typy připojení, jedno nebo více architektur, jedno nebo více schémat nebo jeden nebo více grafů. Pro "Kolekce prvků" datových sad tlačítko Filter je poskytován, který po kliknutí otevře filtru okně prvku, který vám umožní aplikovat více filtrů, která vrátí pouze prvky z určitých architektur, a / nebo některých druhů, a / nebo s určitými standardy , a / nebo připojené k určité složky, a / nebo s některými rodiči, a / nebo v určitých diagramů, a / nebo v určitých grafů a / nebo s danými hodnotami vlastnictví. U ostatních typů souboru dat název pole je k dispozici, a pomocí tlačítka Select si můžete vybrat objekt (y), které mají být součástí sady dat.

Poznámka

Datové soubory jsou uloženy vSady dat souboru (.xml)se stejným názvem souboru jako základna spojená Report Definition soubor (.RDL), Pokud tento soubor neexistuje sada dat editor automaticky naplnit s jakýmikoliv názvy dotazů, které existují v Report Definition soubor (.RDL)a nový Sady dat souboru (.xml)bude vytvořen, jakmile je definována aa platný seznam dotazů.

3. Chcete-li odstranit existující soubor dat pak vyberte Smazat dotaz tlačítko.

4. Chcete-li přidat novou sadu dat a pak klikněte na tlačítko Přidat nový Data SetTlačítko a konfigurovat soubor dat podle poznámce výše.

Na vytvořit nový vlastní zpráva(ze šablony)

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura.

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavy okno (viz výše) Zobrazí.

3. Klepněte na tlačítko Nový a vyberte buď A4 - Portrét, A4- Krajina, A3 - Portrét, A3 Krajina, US Letter - Portrét, US Letter - Krajina, US Tabloid - Portrét nebo US Tabloid - KrajinaV závislosti na orientaci zprávu a papíru velikosti, která je požadována.

4. Vyhledejte umístění pro uložení Report Definition soubor (.rdl / .rdlc) a odpovídající data Set (XML) a klepněte na tlačítko Uložit, To bude přidat novou vlastní zprávu k dispozici v části Reports okna vlastní zprávy, a to může otevřít nebo upravovat, jak je popsáno výše.

Na přidat existující vlastní zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura.

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavy okno (viz výše) Zobrazí.

3. Klepněte na tlačítko Přidat a přejděte do umístění souboru definice sestavy (.rdl / .rdlc) a klepněte na tlačítko Otevřít, To bude přidat novou vlastní zprávu k dispozici v části Reports okna vlastní zprávy, a to může otevřít nebo upravovat, jak je popsáno výše.

Poznámka

Předpokládá se, že soubor odpovídající Data Set (.xml) existuje ve stejném místě jako soubor Report Definition.

Na zkopírovat existující zvyk zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura.

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavy okno (viz výše) Zobrazí.

3. Vyberte existující Zprávaže chcete kopírovat z Dostupné zprávy sekce.

4. Klepněte na tlačítko Kopie a kopii zvoleného zprávy (s názvem "Kopie ..."), bude přidán do části Dostupné Reports okna vlastní zprávy, a to může otevřít nebo upravovat, jak je popsáno výše.

Poznámka

Tím bude vytvořit kopii této zprávy je Report Definition soubor (.rdl / .rdlc) stejně jako jeho odpovídající Data Set (XML)(pokud existuje).

Na odebrat stávající zvyk zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura.

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavy okno (viz výše) Zobrazí.

3. Vyberte existující Zprávaže chcete odebrat z Dostupné zprávyoddíl a klepněte na tlačítko Odstranit.

Poznámka

Při odebrání zprávu, bude na seznamu zpráv již nebudou zobrazovat. Nicméně, toto není smazat Zpráva uvádí zpráva definice soubor (.rdl / .rdlc) nebo Data Set soubor(.xml), Pokud je to nutné, odstranění těchto souborů může být dosaženo pomocí systému souborů.

Na přejmenovat existující zvyk zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura.

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavy okno (viz výše) Zobrazí.

3. Vyberte existující Zprávaže chcete přejmenovat na Dostupné zprávyoddíl a klepněte na tlačítko Přejmenovat.

4. Zadejte nový název pro sestavu.

Poznámka

Jak Report Definition soubor (.rdl / .rdlc) a odpovídající Data Set (XML), bude odpovídajícím způsobem přejmenována.

Na upravit navržení zvyk zpráva

1. Zkontrolujte, zda máte ABACUS otevřít soubor obsahující Váš obydlený architektura.

2. Vybrat Vložit| Vlastní zprávanebo klikněte na Vytvořit vlastní zprávu tlačítko na panelu nástrojů. Vlastní sestavy okno (viz výše) Zobrazí.

Poznámka

Po dobu, kdy uživatel může otevřít již existující vlastní sestavy, to configure navržení vlastních sestav licence uživatel potřebuje Report Configuration schopnost. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.Navíc, Microsoft Report Builder 3.0 je nutné navrhnout zprávy a lze jej stáhnout zdarma z zde .

3. Vyberte existující Zprávaže chcete vystavit z Dostupné zprávy sekce.

4. Klepněte na tlačítko Edit Report.Tato zpráva se otevře v aplikaci Microsoft Tvůrce sestav 3.0. Pro konkrétní pomoc a některé "tipy a triky" na některé z více běžných úkolů s navrhování zprávy naleznete na následujících sekcích. Pro obecnou pomoc na projektování zpráv naleznete na Microsoft Tvůrce sestav 3.0 stránkách nápovědy zde .

Přidání tabulky do sestavy

1. Ujistěte se, že máte počítadla uživatelských sestav Definition soubor (.rdl / .rdlc) otevřen v aplikaci Microsoft Tvůrce sestav 3.0.

2. Vybrat Vložit Karta v "stuhou" na vrcholu, pak klepněte na tlačítko Tabulka tlačítkov sekci regionů Data a vyberte Vložit tabulku.

3. Teď přetáhněte kurzordo polohy o zprávě plátně, kde chcete, aby levý horní roh tabulky umístěny. Klepněte na plátno, Ve výchozím nastavení je v tabulce bude přidán řádek záhlaví a pak podrobností skupiny (skupina je použita zorganizovat pohled na sestavy datové sady). Chcete-li odebrat skupinu, buď odstranit řádek nebo odstranění skupiny řádků na panelu nástrojů seskupení.

Tips

Vzorce / Výrazy v buňkách tabulky se editují výběrem buňky klepněte pravým tlačítkem myši na << Expr >> text a výběrem výraz .... Třídění řádků v tabulce se provádí výběrem tabulky a potom procházení dolů na straně druhé -> SortExpressions pole v panelu Vlastnosti a zadáním výraz. Pro celkové řádek na konci tabulky přidat řádek po (i mimo), seskupování a pak použijte následující výraz = Sum (Fields!Jméno.Hodnota)kde "Name" je pole je celkem. Chcete-li použít barvy na sloupce použít "IIF" prohlášení ve vlastnictví backgroundColor. Pro přidání měřidlo jako buňky v tabulce nejprve vložit měřidlo do buňky a pak padají datová pole potřebné pro rozchod. Při úpravě výšky & šířky řádky tabulky, ujistěte se, vyberte správný řádek, a pak najeďte kurzorem myši kolem šedé čáry, až se dostanete nahoru / dolů kurzor, a pak změnit velikost.

Přidání grafy do sestavy

1. Ujistěte se, že máte počítadla uživatelských sestav Definition soubor (.rdl / .rdlc) otevřen v aplikaci Microsoft Tvůrce sestav 3.0.

2. Vybrat Vložit Karta v "stuhou" na vrcholu, pak klepněte na tlačítko Schéma tlačítkov sekci regionů Data a vyberte Vložit Chart.

3. Teď přetáhněte kurzordo polohy o zprávě plátně, kde chcete, aby levý horní roh grafu umístit. Klepněte na plátno a pak Vyberte grafpožadujete z možností a klikněte na tlačítko Dobře.

Tips

Chcete-li zobrazit vlastnost jako anotaci na schémata, klikněte pravým tlačítkem myši na graf a vyberte volbu Zobrazit popisky dat, vyberte jednu z etiket, které byly přidány a nastavte Různé -> UseValueAsLabel na FALSE v panelu vlastností a přidejte výraz (např = Name.Value Fields) v Ostatní -!> Label. Speciálně pro bublina grafy; Bubble grafy jsou zobrazeny pod záhlavím bodový graf. Drop X vlastnost osy do polí řady (nebo přidat vlastnosti řady). Drop vlastnost osy Y do datových polí (nebo přidat vlastnosti řady). Chcete-li použít vlastnost definovat velikost bublin, pokles toto do datových polí (nebo přidat vlastnosti řady). Bubble grafy jsou schopny zobrazit, pokud je příliš mnoho dat (200 + položek), někdy to způsobí, že celý zprávu nezobrazí. Marker Type - Nastavte na kruhu. Ve výchozím nastavení, když klesá polí do datových polí, přidá jim s součet()formule, a tak odstranit to. Speciálně pro Skládaný grafy / Timeline / Ganttův diagram; Pro Ganttova diagramu používat rozsah grafu a přidat vlastnosti jako vysokých a nízkých hodnot v datových polí. Můžete mít více "tyčí" připočítáním více a více rozsahů, kde je nízká hodnota jednoho utkání vysokou hodnotu za jinou. Speciálně pro Koláčové grafy; U souhrnných koláčové grafy, přetažení dat do kategorie polí a datová pole, přidejte vzorec = CountRows (), Odfiltrovat Hodnoty 0 (např nákladů grafy), jinak etikety pro tyto budou nadále zobrazeny v grafu.

Použití příkazu IIF přidat barvy do tabulek a grafů

1. Ujistěte se, že máte počítadla uživatelských sestav Definition soubor (.rdl / .rdlc) otevřen v aplikaci Microsoft Tvůrce sestav 3.0.

2. Klepněte pravým tlačítkem myši na buňku v tabulce barvu a klikněte Vlastnosti Text Box.

3. Vybrat Vyplnit a klepněte na tlačítko fxTlačítko vpravo barvu výplně štítku av nastavit výraz pro backgroundColor pole zadejte výraz, např = IIF (Fields! InformationStatus.Value = "Zachovat", "zelená sv", IIF (Fields! InformationStatus.Value = "Redesign", "Yellow", IIF (Fields! InformationStatus.Value = "Refresh", "oranžová", " Losos"))), Tím se změní barvu pozadí na světle zelenou pro každou buňku, která obsahuje stav "Zachovat", žlutá pro každou buňku, která obsahuje stav "redesign", oranžová pro každou buňku, která obsahuje stav "Aktualizovat" a jakýkoli jiný status hodnota bude barevný v "Salmon".

Poznámka

Barvy mohou být přidány grafů výběrem série v grafu, a pak nastavení vzhledu -> vlastnost Color (nebo bublina mapuje Vzhled -> Marker -> Color vlastnictví) výrazu podobné výše uvedeného příkladu.

Věci mít na paměti při navrhování vlastních sestav

· Vzhledem k tomu všechny vlastnosti s výjimkou Integer jsou odesílány jako řetězec z ABACUS k divákovi zprávu, pokud chcete dělat žádné "výrazy" s nimi (jako propast jednu vlastnost jinou nebo druh), musíte je převést na desítkové nebo datum atd. Na pozadí , tento článek Je dobré reference. Např. = CDate (Fields LifecycleEndDate.Value!) Poznámka: Ujistěte se, že jazyk, zpráva je nastavena na hodnotu en-GB (jak je popsáno níže), přijmout dd / mm / rrrr, jak to očekává formát mm / dd / rrrr ve výchozím nastavení a podle 31/7/2011 selže konverze. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (CostTotalCosttoOwnnext5years.Value Fields!, 0)

· Pokud zjistíte, že jste snaží držet všechny tabulek a grafů na jednu stránku, Existuje několik hlavní způsoby správu dokumentů prostor:

· Konec stránky - Ujistěte se, že toto nastavení tabulka je vypnuto pro každou tabulku, kterou si přejete být na stejné stránce.

· Keep Together - Zajistit toto nastavení tabulka platí pro každou tabulku, kterou si přejete být na stejné stránce.

· Při pohybu věci kolem, je snazší pro oddálení pomocí ovladače na pravé dolní části stránky a potom multi výběr položek a táhnout

· Pro obrazový řádek v tabulce, ujistěte se, že "velikost" | "Třídění podle velikosti" je nastavena na "fit" jinak obrazu se mohou jevit jako příliš velké, nebo to bude špatně natažené.

· Na opakovat řádek záhlaví tabulky na každé stráncezprávy:

1. Otevřít Rozšířený režim v podokně seskupení. (Klikněte na šipku vpravo od skupiny sloupců a vyberte Rozšířený režim.)

2. V oblasti skupin řádků (ne Sloupec skupiny), klikněte na statické skupině, která zdůrazňuje odpovídající textové pole v tablix. Proklikejte každé statické skupiny, dokud se zdůrazňuje, že je úplně vlevo záhlaví sloupce. To je obvykle první Static skupině uvedeným.

3. V okně Vlastnosti nastavit vlastnost RepeatOnNewPage na hodnotu true.

4. Ujistěte se, že vlastnost KeepWithGroup je nastavena na hodnotu Po.

· Změna Nastavení jazykave vlastnostech Report, aby odpovídaly formáty dat, které potřebujete, například en-GB vyrábět UK formátu data (dd / mm / rrrr).

Viz také

Analýza vaší architektury


Publikovat na webu

Navigace: Podávání zpráv o vaši architekturu>

Publikovat na webu

Odeslat připomínky na toto téma.

ABACUS "Publikovat Web funkce umožňuje architektonické modely, které mají být viděn přes zabezpečené webové stránky. Architektury jsou exportovány do formátu HTML a jsou navrženy tak, aby odrážela vzhled a dojem z Exploreru v ABACUS. Pohledy (včetně katalogy, diagramy, 3D a grafy) jsou také exportovány do formátů zobrazovaných pomocí internetového prohlížeče.

Poznámka

V současné době, názory a Matice nejsou publikovány.

Chcete-li publikovat své architektonické modely, na web

1. Zkontrolujte, zda máte příslušné ABACUS souborotevřené, obsahující obydlený architekturakteré chcete publikovat na webu.

2. Vybrat Soubor| Publikovat....

3. Publikovat na webové konfiguraceZobrazí se okno.

Publikovat v síti WWW Konfigurace

4. Ve výchozím nastavení jsou vybrány všechny části modelu, včetně Stromový pohled, The Normy, Druhy, šablony a architektura (y). Zrušte zaškrtnutí jakékoli části, které nechcete publikovat na web, včetně všech jednotlivých názorů v rámci architektury (y).

Tip

Pokud chcete skrýt určité součásti, spoje a / nebo jejich vlastnosti se doporučuje, aby správce vytváří úlohu "veřejného" s použitím Přístup funkce na základě rolí Abacus ' a pak odstraní oprávnění ke čtení z těchto typů komponent, typů a / nebo vlastnosti připojení, které si nepřejí být zveřejněny. Pak by měl uživatel přihlásit pod tímto roli a publikovat na web, jako ABACUS zveřejní pouze na ty prvky, které mají oprávnění ke čtení nastavené pro roli. Kromě toho mohou uživatelé auto-publikovat z příkazového řádku, jak je popsáno zde .

Poznámka

Můžete si vybrat všechny části zobrazené kliknutím na tlačítko VšeTlačítko nebo invertovat vaši volbu kliknutím na tlačítko Obrátit tlačítko. Můžete také kliknout na tlačítko ŽádnýTlačítko pro vymazání volby.

Poznámka

Jestli ty zrušte zatržení u položky Tree Viewpak není strom rám (viz níže), budou zveřejněny. V souladu s tím, měli byste zvolit úvodní stránku podle kroku 6 nebo nižší Po publikování budete muset přizpůsobit buď nejvyšší úrovně; A) index.htmlsoubor změnou "rámu src =" mainPage.html "name =" "'element_details linky přímo odkaz na příslušné HTML stránky ve složce obsahu, nebo, b) mainPage.htmltím, že poskytuje hypertextový odkaz nebo přesměrovat na příslušné HTML stránky ve složce obsahu.

5. Klepněte na tlačítko Volba tlačítko a následující Možnosti Vydavateldialog se zobrazí.

PublikovatMožnosti er

6. Svolit 3D, Diagrama grafy formáty a zda se má zobrazovat název, popis nebo Vlastnosti Pro výhledem ven z dostupných možností (viz níže poznámku k připomínkám na různých formátech).

7. Pokud si přejete nastavit úvodní stránku publikovaného modelu do určitého pohledu pak zkontrolovat Použít Zobrazit jako úvodní stránkumožnost a přejděte do zobrazení pomocí tlačítka "...", který se aktivuje.

Poznámka

Pouze názory vybrané v části Oblasti podle kroku 4 výše, jsou k dispozici třeba nastavit jako výchozí stránku.

8. Pokud chcete získat zpětnou vazbu na konkrétní stránky v publikované modelu ujistěte se, že Email Zpětná vazbaje vybrána možnost, zadejte e-mailovou adresu v Emailová adresatextboxa upravit Těle e-mailuSekce případně, Pokud si nepřejete, aby zpětná vazba poslal následně zrušte zaškrtnutí Email Zpětná vazbaVolba a nechte textové pole prázdné.

9. Klikněte na Dobře tlačítko.

10. Klikněte na Procházet tlačítko.

11. Procházet pro složkyZobrazí se okno.

12. Vyberte umístění, které chcete uložit soubor HTML nejvyšší úrovně (a všechny automaticky generované soubory).

Poznámka

Je to dobrý nápad, vytvořit určitou složku (typicky volal "Vyšlo") s použitím Vytvořit novou složkutlačítko v dolní části dialogového okna pro uložení souboru na nejvyšší úrovni a všechny HTML automaticky generované soubory.

13. Klikněte na Dobře tlačítko.

14. Cesta složky se zobrazí v Adresářtextbox.

15. Klikněte na Dokončit tlačítko.

- nebo -

15. Zadejte cestu složku v Adresářtextové, kam chcete uložit soubor ve formátu HTML na nejvyšší úrovni (a případně automaticky generované soubory).

16. Klikněte na Dokončit tlačítko.

Poznámka

Export Diagramyvelmi zřídka selže, nejčastěji, když je počítač nedostatek paměti (normálně při použití velmi velkých souborů). Neúspěšný export bude opakován jednou. Tam bude jeden varování pro selhání první pokus, a druhý výstražný v případě, že re-pokus selže. Proto, pokud jsou pouze varování jsou "počáteční pokus selhal" ty, publikování byl úspěšný. V případě, že re-pokus selže, zkuste publikovat menší část vašeho souboru nebo uvolnit některé systémové paměti.

Uložený soubor (y) HTML může být nyní pohled z jeho umístění, nebo zkopírovat do zabezpečené webové stránky.

Publikovat na webu v aplikaci Internet Explorer10

Žádný hypertextové odkazy které byly vytvořeny v původním modelu bude přetrvával ve zveřejněném modelu a kliknutím na odkaz bude následovat odkaz na místo určení (je-li to bylo vydáváno). Kromě toho budou všechny prvky v publikovaných diagramy, které nejsou již hypertextové odkazy v původním modelu pomocí odkazem zpět na jejich odpovídající prvky v pohledu stromu (pokud to bylo vydáváno) a klepnutím na prvek ve zveřejněném diagramu důraz bude skočit zpět do příslušné místo ve stromu. Tato funkce je podobná "show v Explorer" klepněte pravým tlačítkem myši funkce v ABACUS.

Poznámka

Avolution důrazně doporučuje následující software a formáty souborů by měly být použity k plně využít Publikovat v síti WWW funkce v ABACUS:

1. Internet Explorer (80,0 a vyšší)zobrazit publikované zobrazení Průzkumník. Mozilla Firefox (30,0 nebo novější)Také se doporučuje, a plně podpořilNicméně, pokud používáte doporučený formátu SVG pro diagramy pak ve Firefoxu 9. můžete použít pouze na podporu prohlížeče nativní SVG, které bohužel neumožňuje přiblížení nebo rýžování.

2. Adobe SVG Viewer 3.0 zapojit (ke stažení od zde ) a SVGformát souboru pro publikován diagramy, Formát obrazu SVG pro diagramyDoporučuje se proto, že; SVG je formát obrazu založenou na vektorech, a proto je "ztráta-less 'a vypadá mnohem lépe, v daném úrovni přiblížení než kterákoli z jiných formátů, SVG lze importovat do MS Visio, SVG lze zvětšovat na jakékoliv úrovni nebo rozlišení , SVG má vazby zpět do zobrazení stromu pro připojení (ne jen komponenty), SVG vždy tiskne na lepší rozlišení, a SVG je asi poloviční velikost souboru z jiných formátů. PNG je další doporučení, nicméně, jak je to rasterised formát na některých úrovních přiblížení jasnost toho názoru, budou ztraceny a klepnutím na tlačítko připojení na diagramy nebude skočit zpět do příslušného umístění ve stromu. BMP je znechucený protože i když je formát "ztráty méně" velikost souboru je 100x, že z ostatních formátů a 20MB obrázky nejsou neobvyklé.

Trade-off s SVG je, že divák SVG bude muset být nainstalován a je třeba ujistěte se, že .svg image / svg + xml, který zní typy webového serveru MIME. Po instalaci prohlížeče SVG Microsoft Internet Explorer se vás zeptá, přijměte licenční smlouvu diváka, a pak by měl fungovat dobře. A zatímcoMozilla Firefox podporuje SVG soubory nativně, Adobe plugin je stále doporučujeaby bylo možné přiblížit diagramy, pokud používáte Firefox 8 nebo starší (pokud používáte Firefox 9 nelze zakázat nativní SVG diváka), Jakmile je instalace pro Adobe plugin byl spuštěn, tyto kroky jsou zapotřebí používat ve Firefoxu:

· Otevřete Firefox a zadejte "about: config" (bez uvozovek) do adresního řádku.

· Přejděte dolů a najít nemovitost svg.enabled(pokud používáte Firefox 9 pak nativní SVG prohlížení nemůže být zakázán, a tato vlastnost neexistuje), Dvojitým kliknutím na něj zakázat.

· Nyní zde adresář, kde je nainstalován SVG plugin (např C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Zkopírujte soubory NPSVG3dll a NPSVG3.zip a vložit je do adresáře pluginů Firefox (např C: \ Program Files \ Mozilla Firefox \ plugins)

· Ukončete všechny instance Firefoxu

3. ABACUS 3D Viewer Avolution je (3.1 a vyšší) a Avolution je .abacus3Dformát souboru pro publikované 3D zobrazení. Zatímco Cortona VRML Client plug-in (2.0 a vyšší)je k dispozici pro prohlížení VRML verze publikovaných názorů to není zdarma pro komerční využití a stále vyžaduje instalaci na straně klienta. 3D Viewer ABACUS je více rys-bohatý než jakýkoli prohlížeč VRML, a je volně k dispozici ke stažení zde , V obou případech se ujistěte, přidat .vrml x-svět / X-VRML a .abacus3d application / octet-stream na druhy webového serveru MIME.

4. PNGformát souboru pro publikované názory diagramu. Formát obrazu PNG pro zobrazení grafu je doporučeno, protože, když se jedná o rasterised formát a tam je "ztráta" trade-off mezi velikostí souboru a přehlednosti grafu je obvykle nejlepší. BMP je znechucený, jako když se jedná o "ztrátu méně" formátovat velikost souboru je 20x, že z dalších formátů a 2Mb grafy nejsou neobvyklé.

Chcete-li změnit vzhled a dojem z webových stránek, můžete upravit soubor výchozí stránku s názvem mainPage.html a soubor stylů s názvem abacus.css. Zde najdete tyto soubory ve stejné složce, kde jste se rozhodli uložit soubor HTML nejvyšší úrovně. Pro více informací o struktuře a šití publikované výstupu najdete v následující části.

Struktura ABACUS zveřejněn modelů

Počítadlo zveřejnila model je strukturován takto:

1. Složka nejvyšší úrovně obsahuje několik souborů a za předpokladu, všechny možnosti jsou zahrnuty v ABACUS Publikovat v síti WWW konfigurační dialog, že bude obsahovat index.htmlSoubor složený ze tří snímků; treeView.html, findNode.html a mainPage.html a pak shortcutError.html strana, TreeView.html je naplněn tree.js, tree_items.js a tree_tpl.js javascript soubory umístěné ve složce zahrnují (popsáno níže) a replikuje strom Exploreru z ABACUS. FindNode.html je poháněn find.js javascript soubor umístěn pod obsahovat složku (viz níže), a to bude hledat větve stromu nikoli pouze viditelné uzly. Ton mainPage.html je statická HTML stránky, které mohou být přizpůsobeny s firemní loga a podobněa zobrazí se, pokud není počáteční stranu je vybrán při publikování.A konečně, stránka shortcutError.html je vstupní stránka pro všechny rozbité zkratky ze stromu vzhledem k příslušné stránky nejsou publikovány.

Tip

Můžete přeskočit mainPage.html úplně podle výběru použít úvodní stránku při publikování nebo úpravě souboru index.html na bod přímo k dané zobrazení (řekněme) úpravou rámu src = "mainPage.html" řádku na bod přímo na první pohled v prvním architektury, typicky "rámec" diagramu.

2. Nejvyšší úrovně includesložky obsahujíIngrůzný JavaScript (JS) a kaskádových stylů (CSS) soubory používané .html soubory celém zveřejněného modelu.

3. Složka Content nejvyšší úrovně obsahuje, abecedně;

· A '3D Zobrazení' Složka sčíslovanýHTML stránky a soubor VRML nebo abacus3d pro každý z publikovaných 3D zobrazení, Viz poznámka níže pro informace o schématu číslování souborů.

· Architektury složka s číslované HTML stránky pro každou architekturu, která byla publikována. Viz poznámka níže pro informace o schématu číslování souborů.

· A Katalogy složka obsahující číslovaný HTML stránku, pro každý z publikovaných katalogů. Viz poznámka níže pro informace o schématu číslování souborů.

· A Grafy Složka sčíslovanýHTML stránky a PNG, JPG etc pro každý z publikovaných názorů diagramu, Viz poznámka níže pro informace o schématu číslování souborů.

· A Komponenty složku obsahujícíčíslovanýHTML stránky pro každou ze složek publikovaných, Viz poznámka níže pro informace o schématu číslování souborů.

· A Připojení složku obsahujícíčíslovanýHTML stránky pro každý z publikovaných přípojek, Viz poznámka níže pro informace o schématu číslování souborů.

· A Diagramy složku obsahujícíčíslovanýHTML stránky a PNG, SVG etc pro každou z zveřejnila diagramy. Viz poznámka níže pro informace o schématu číslování souborů.

· Ikony sub-Složka s různé obrazy používané v celém zveřejněného modelu.

· A Normy podsložku sčíslovanýHTML stránka pro všechny Normykteré byly publikovány. Viz poznámka níže pro informace o schématu číslování souborů.

· A Šablony sub-folder se sbírkou číslovaných dílčích složek pro každou šablonu zveřejněné z projektu. V rámci každé dílčí složky je Components a složku Připojení a uvnitř nich je číslované stránky HTML pro každou komponentu a připojení šablony. Viz poznámka níže ohledně informací o systému číslování složek / souborů.

· A Druhy sub-složka s komponentou aPřipojení sub-složky sčíslovanýHTML stránky pro všechny komponenty aTypy spojení, které byly publikoványa sbírka číslovaných dílčích složek pro každý typ zveřejněné z projektu, který obsahuje HTML stránku pro každý z omezení. Viz poznámka níže ohledně informací o systému číslování složek / souborů.

· A Pohledbods sub-složky ačíslovanýHTML stránka pro některý z pohledubods, které byly publikovány. Viz poznámka níže pro informace o schématu číslování souborů.

Poznámka

Číslování stránek HTML (a v některých případech obrazové soubory) odpovídá unikátní ID pro každý objekt, který byl úložiště nastaven, když bylo to vytvořilv ABACUS (označované jako EEIDs), Toto číslo se nemění tak jako diagramy, typy, komponenty atd jsou aktualizováno oni budejako předtím zachovat stejné ID. V každém případě se daný úložiště objektJméno může být nalezen poblíž začátku HTML stránky mezi ... HTML tagy.

Omezení přístupu na určité stránky / Zobrazení s IIS

Pokud používáte IIS jako webový server pro zveřejněného modelu, můžete být schopni omezit přístup na určité stránky / pohledy využívající metodu níže:

1. Vytvořit webové stránky v IIS (jiný v případě, že je stávající jedním nechcete zasahovat).

2. Změna Vlastnosti-> Directory Security-> anonymní přístup - odškrtněte anonymní přístup a využití ověřený přístup.

3. Pokud je to jen normální server s žádnými domény komplikací atd, pak byste měli použít volbu "Integrované ověřování systému Windows", která by pak použít server stroje místní uživatelé / loginy jako ověření, a jen přidat uživatele do místního počítače (být opatrný že jste si vědomi důsledků, bezpečnosti moudrý, přidávání nových uživatelů do zařízení, například v závislosti na tom, zda vzdálený přístup je nastaven pro stroj, atd.)

4. Přidat oprávnění na konkrétní soubory / složky podle potřeby. Klepněte pravým tlačítkem myši na jednotlivé soubory / složky -> Vlastnosti a upravte oprávnění zabezpečení tak, jak byste normálně souborů / složek.

To se může lišit v závislosti na verzi služby IIS a jaké konkrétní operační systém Windows je na serveru, a zda máte doménu nebo jiné odlišné nastavení.

Viz také

Naplnění vaší architektury | Analýza vaší architektury


Export vaši architekturu

Navigace: Podávání zpráv o vaši architekturu>

Export vaši architekturu

Odeslat připomínky na toto téma.

ABACUS umožňuje naexportovat architekturu MDB (Microsoft Access), MS SQL Server, .abacus (ABACUS soubor), a .xls formátu (Microsoft Excel). Můžete také exportovat diagrams až PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF a BMP a přehledech .html (HTML), .pdf (Adobe Acrobat), XLS (Microsoft Excel), .doc (Microsoft Word) a .rtf (Rich Text Format) formáty. To vám umožní analyzovat a zobrazit architekturu a jeho data jakýmkoli způsobem chcete.

Chcete-li exportovat svou architekturu MDB (Microsoft Access)

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Klikněte na Soubor menu.

3. Vybrat Vývozní, a pak Chcete-li MDB.

4. Vezměte na vědomí upozornění a klepněte na tlačítko Dobře.

5. Zadejte název souboru.

6. Klepněte na tlačítko Uložit Tlačítko.

Poznámka

Vývoz Formát databáze MDB je specifické pro ABACUS a jakékoli změny schématu bude mít za následek nemožnost zpětného dovozu. Prosím podívej se Naplnění s MS Access pro popis schématu MS Access.

Chcete-li exportovat architekturu MS SQL Server

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Klikněte na Soubor menu.

3. Vybrat Vývozní, a pak Pro MS SQL Serveru.

4. V dialogovém okně, které se objeví klikněte na tlačítko Export Blank MDB ...Tlačítko a importovat do vašeho databázového serveru MS SQL Server.

5. Vyplňte informace o databáze a řetězec připojení.

6. Klepněte na tlačítko Vývozní Tlačítko.

Poznámka

Vývoz formát MS SQL ServerDatabáze je specifické pro ABACUS a jakékoli změny schématu bude mít za následek nemožnost zpětného dovozu. Prosím podívej se Naplnění s MS Access pro popis schématu databáze.

Chcete-li exportovat svou architekturu .xls (soubor Excel)

1. Zkontrolujte, zda máte ABACUS otevřít soubor , Což Zobrazí explorer , A architektura přidané .

2. Zkontrolujte, zda máte Excel import / export konfigurace soubor definovány.

3. Klikněte pravým tlačítkem myšina architektuře ve vašem modelu nebo jakákoli část Komponentyuzel (v rámci dané architektury), který chcete exportovat do konfiguračním souboru Excel.

4. Vybrat Vývozní | Na Vynikat... z menu.

5. Vyberte Excel Import / Export Configuration soubor se má použítse zobrazí okno.

6. Vyberte příslušnou konfigurační soubor pro váš architektonický model a klikněte na tlačítko Otevřít tlačítko.

7. Pokud tomu tak není automaticky neučinili, mapa složky nejvyšší úrovně v aktuálním architektury široké Set Id(jak je definováno výše) a klikněte na Vývozní....

Mapování Příklad nejvyšší úrovně Component

8. Vyberte umístění a název souboru pro soubor aplikace Excel a klepněte na tlačítko Uložit tlačítko.

Chcete-li exportovat svou architekturu .abacus (ABACUS soubor)

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Klikněte pravým tlačítkem myšina uzlu Architecture, libovolné počítačové architektuře, ve vašem modelu nebo jakákoli část složek stromu.

3. Vybrat Export | Na Soubor...z menu.

4. Vyberte umístění a název souboru a klepněte na tlačítko Uložit tlačítko.

Poznámka

Můžete importovat soubor ABACUS zpět do ABACUS podle následujících kroků 1-2výše a výběrem Dovoz | Z Soubor..., Poté, co jste vybrali soubor, který chcete importovat, budete dotázáni, jak byste chtěli importovat standardy a typy. Můžete importovat standardy a typy jako nové nebo sloučených norem a typů. Výchozí nastavení je pro standardy a typy, které mají být sloučeny s stávajících standardů a typů, pokud již existují ve vašem projekt.

Chcete-li exportovat svou architekturu .xml

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Klikněte pravým tlačítkem myšina uzlu Architecture, libovolné počítačové architektuře, ve vašem modelu nebo jeho část z komponent stromu.

3. Vybrat Export | Na XML ...z menu. Případně můžete klepnout v nabídce Soubor| Vývozní| Na XML ...

4. Vyberte umístění a název souboru a klepněte na tlačítko Uložit tlačítko.

Poznámka

Můžete importovat soubor XML zpět do ABACUS podle následujících kroků 1-2výše a výběrem Dovoz | Z XML ..., Poté, co jste vybrali soubor XML, který chcete importovat, budete dotázáni, jak byste chtěli importovat standardy a typy. Můžete importovat standardy a typy jako nové nebo sloučených norem a typů. Výchozí nastavení je pro standardy a typy, které mají být sloučeny s stávajících standardů a typů, pokud již existují ve vašem projekt.

Chcete-li exportovat diagramu do PNG, JPG, SVG, TIFF, GIF nebo BMP

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Otevřete diagramchcete exportovat.

3. Klikněte na Export DiagramTlačítko na Diagram Panel nástrojů.

4. Export DiagramObjeví se okno.

5. Vyberte Procházettlačítko pro uložení vizualizaci na požadované místo.

6. Vyberte Uložit jako typpull-down menu vyberte typ souboru.

7. Klepněte na tlačítko Uložit tlačítko.

Chcete-li exportovat svou zprávu ve formátu pdf (Adobe Acrobat), XLS (Microsoft Excel) nebo.doc (Microsoft Word)

1. Zkontrolujte, zda máte ABACUS soubor otevřít.

2. Vytvořit zpráva chcete exportovat.

3. Klikněte na VývozníTlačítko na panelu nástrojů zpráv.

4. Vybrat Excel, PDF nebo Wordz rozevíracího seznamu.

5. Počkejte několik okamžiků, zatímco vývozy zprávy.

6. Vyberte umístění a název souboru a klepněte na tlačítko Uložit tlačítko.


Práce s Enterprise Server

Navigace: Správa>

Práce s Enterprise Server

Odeslat připomínky na toto téma.

ABACUS Enterprise Server je jak "non-blokovací" společný přístup, ale o "odpojena" jednou také. ABACUS je "non-zamykání" proto, že není vynutit soubor zamknout jedním uživatelem pro to, aby byl aktualizován. Každý uživatel má svou vlastní lokální kopii souboru, a když oni dělají změny a zachránit jejich soubor, tyto změny jsou zaznamenány a uloženy, když si uživatel přeje, aby je zavázat se k serveru.

ABACUS je "odpojena" v tom smyslu, že nemusíte být připojeni k serveru, potřebujete přístup k síti a zároveň pracovat na souboru. ABACUS vyžaduje pouze přístup k serveru při provádění operace, jako je vytvoření souboru, nebo provedení Checkout, spolu s operacemi na existující soubor - aktualizace, spáchat, nebo zobrazení protokolu o minulosti dopustí. Přístup k serveru není nutné pracovat na soubor a vaše změny nejsou okamžitě odeslána na server (to vám umožní snadno zrušit změny, pokud uděláte chybu). Při uložení souboru, jste "jen" šetří vaše kopie lokálně - to není až se zavázat, že vaše lokální změny (změny provedené od posledního potvrzení), jsou odesílány na server.

Vytvoření nového souboru Enterprise

Chcete-li vytvořit nový Enterprise soubor, vyberte Soubor| Nový ...a poté vyberte jednu z prvních dvou možností v části Enterprise Model Nový dialog Project (tj buď prázdný Enterprise soubor, nebo vytvořit jednu z existujícího ABACUS souboru). Třetí možností je "K pokladně" Enterprise soubor někdo jiný již vytvořil, bude to zahrnuty v další části.

Pokud se rozhodnete vytvořit nový soubor Enterprise, budete mít dialogové okno, které vám umožní procházet na místo, kde na serveru úložiště chcete uložit soubor. To bude mít také existující cestu k souboru a název vstoupila do vrcholu, pokud jste zvolili "Od Stávající model" v dialogovém okně Nový projekt a dodala soubor.

URL: Toto je URL k vašemu serveru úložiště, kde jsou uloženy soubory ABACUS Enterprise. Měli byste se zeptat na osobu, která spravuje server, co by mělo být toto URL.

Obrázek nahoře ukazuje úložiště s čtyři (4) stávajících projektů ABACUS podniku, po zadání adresy URL a stisknutím tlačítka Enter. Ty uvidíte po vytvoření nového Enterprise soubor, na dalším snímku pro "K pokladně", bude další složek a souborů v rámci tohoto úložiště.

Poznámka

Pokud používáte HTTPS (SSL) serveru, a server nemá platný certifikát SSL (společné pro intranetové či neveřejných serverů kvůli Náklady na certifikátu SSLs), Tam bude další krok, aby se. Ty budou muset trvale přijmout všechna připojení k tomuto serveru v dialogovém okně, které se objeví (bude to také ukázat trochu více informací na serveru). Chcete-li to provést, zadejte "p" (bez uvozovek) a stiskněte klávesu Enter. ABACUS se pop-up zprávu připomínat to před zobrazením dialogového okna.

Poznámka

Můžete být vyzváni k přihlášení k serveru, v tomto případě je osoba, která je Řídící servermůže poskytnout uživatelské jméno serveru a hesla. Také přihlašovací údaje pro všechny servery, které jste připojili k jsou uloženy, takže pokud z nějakého důvodu je třeba je vymazat to lze provést prostřednictvím Nástroje | Možnostia pak na Generál Karta kliknutím Obnovit Subversion uložené Přihlášenía výběrem serveru z rozbalovacího seznamu a klepnutím na tlačítko Clear Přihlášenía výběrem OK v dialogovém okně, které se objeví.

Poznámka

Na rozdíl od snímku je uvedeno výše, typicky jeden ABACUS projektu je obsažen v každém ABACUS úložišti, protože pokud je vytvořena více než 1 ABACUS projekt v jediném ABACUS úložiště, čísla změna protokolu Abacus jsou sdíleny všemi Abakus projektů, a to může zmást uživatele.

Preferovaný Název souboru: To ovlivní složku a název souboru, který bude použit (pokud již není zaujatý), při vytváření souboru na serveru úložiště. Všimněte si, že je vytvořena nová složka automaticky na serveru úložiště pro každý soubor (z výkonnostních důvodů, ABACUS Enterprise soubory jsou vytvořeny v jejich vlastní složky na základě umístění prohlíželi v dialogu).

Uchovávejte pracovní kopii v adresáři: Když je vytvořen soubor Enterprise na serveru úložiště, je třeba vytvořit na počítači místní pracovní soubory, takže můžete pracovat na souboru, aniž by byl připojen k síti. To je místo, které budete procházet, když chcete otevřít / re-otevřít soubor ABACUS Enterprise.

Pokladna existujícího Enterprise souboru

Pokud již někdo vytvořil nový Enterprise soubor, můžete "pokladna" tento soubor, který stahuje lokální kopii a nastaví potřebné soubory, takže ABACUS rozpozná toto jako soubor Enterprise vám. Dialog je podobný New Enterprise File Dialog. Zadejte adresu URL úložiště (podadresáře mohou být zahrnuty do adresy URL), vyberte požadovaný soubor a klepněte na tlačítko OK. S výhradou poznámky pod tže soubor bude otevřen.

Poznámka

Můžete být vyzváni k přihlášení k serveru, v tomto případě je osoba, která je Řídící servermůže poskytnout uživatelské jméno serveru a hesla. Také přihlašovací údaje pro všechny servery, které jste připojili k jsou uloženy, takže pokud z nějakého důvodu je třeba je vymazat to lze provést prostřednictvím Nástroje | Možnostia pak na Generál Karta kliknutím Obnovit Subversion uložené Přihlášenía výběrem serveru z rozbalovacího seznamu a klepnutím na tlačítko Clear Přihlášenía výběrem OK v dialogovém okně, které se objeví.

Enterprise souborů Rozdíly

Pokud jste vytvořili soubor Enterprise (buď nová, nebo prostřednictvím "pokladny" ze souboru vytvořeného někým jiným), složka bude vytvořena pro soubor, a to bude běžně obsahovat tyto 3 hlavní typy souborů:

· File '.abacus "- Jedná se o soubor ABACUS sám. Změny stránky jak lokálně nejsou okamžitě ukládány do tohoto souboru je napsáno pouze, když jste spáchat. Tento soubor je "normální" ABACUS soubor, to může být dána uživatelům non-EEjako projekt samostatný (bez souboru s příponou LOG), Nebo použity jako výchozí bod pro nový EE souboru.

· File '.changes "- Místní (nepotvrzené) změny provedené v souboru. Pokud tento soubor chybí, to znamená, že neexistují žádné lokální změny.

· '.log' Soubor- Tento soubor má pouze změny, které byly provedeny od posledního uživatele (obsah .changes uživatelského souboru, když oni spáchali).

Poznámka

Existují různé další soubory, které mohou být vytvořeny v průběhu aktualizace a zavázat procesů, a to; ‘.changesbefore' soubor- Tento soubor je kopie souboru .changes po aktualizace byla provedena a slouží k automatickému smířit ID konflikty mezi aktualizace a jakýkoli místní (nezávazné) změn před zavázat; ‘.zálohování' soubor- Tento soubor je kopie souboru .changes dříve, než uživatel ušetří více místní (nepotvrzené) změny v souboru .changes; a ‘.chyba' soubor- Tento soubor je kopie .changes souboru, pokud tam byl nějaký problém, který způsobil Abacus selhání otevřete soubor .abacus a uživatel se rozhodl vrátit jejich změny.Tyto soubory mohou být ignorovány.

Otevření souboru

Chcete-li otevřít soubor, stačí procházet na místo, kde jste se rozhodli pro uložení pracovní kopii, a otevřete soubor ABACUS, který je zde uložen. Když ABACUS vidí, že je .log soubor (a možná i .Změny souboru, pokud jste provedli změny), to bude považovat soubor jako soubor Enterprise.

Aktualizace souboru

Provedenín 'Aktualizovat' zkontroluje, zda novější verze souboru je umístěn na serveru. Pokud ano, bude to zavřete aktuální soubor, aktualizujte na novější soubor ze serveru, a stáhnout některé dočasné soubory, které mají číslo jako rozšíření - např 'Demo.125'. Tyto soubory jsou starší verze souboru s příponou LOG, a slouží k určení, jaké změny byly provedeny do souboru od posledního aktualizován. To je nutné odhalovat případné konflikty, ke kterým došlo, takže je můžete vyřešit.

Li Během procesu aktualizace jakýkoli konflikty byly nalezeny, Budete muset vyřešit dříve, než budete moci otevřít soubor znovu (můžete zrušit ale budete vyzváni k vyřešit konflikty znovupři příštím otevření souboru).

Uložení souboru

Při uložení souboru, to připojí všechny změny, které jste provedli v souboru .changes. To neníupravit soubor .abacus v této fázi - pouze tehdy, když je soubor zavázala k serveru, bude napsán přes (nebo když obdržíte aktualizace ze serveru).

Kde je 'Uložit jako'?

Neexistuje žádný koncept Uložit jako pro podnikové soubory. Přesto však můžete zkopírovat pracovní kopii .abacus souboru, přičemž má na paměti, že je zvyklý mít své lokální změny v něm.

Řešení konfliktů

Pokud ostatní uživatelé se dopustili změny v souboru v podobné části souboru pro vás, může tam být nějaké konflikty mezi jejich změn a Vy. Například jiný uživatel může odstranit součásti, které jste měli aktualizovat majetek na, Musíte buď vrátit zpět jejich změnu (pokud jste si jisti, že jejich byne se stalo), nebo zrušit vaši změnu (může se pak vrátit zpět do souboru a znovu vaši změnu).

Konkrétně existují 4 třídy konflikty, které mohou nastat;

1. Vymazat - Pokud jeden uživatel smaže objekt, že další změny uživatelů. Např. Uživatel A vypouští komponentu, ale uživatel B změnila název komponenty nebo k němu připojena, nebo přidán dětskou složku k němu atd.

2. Atribut - Když se dva uživatelé měnit oba přesně stejné "atribut" objektu. Např. Oba Uživatel A a uživatel B změnila název dané komponenty nebo jeho popis nebo hodnotu jednoho ze svých vlastností atd

3. Odkaz - Když se dva uživatelé změní přesně stejný "referenční" má objekt na jiný objekt. Např. Oba Uživatel A a uživatel B změnil typ některé komponenty nebo součást zdroj / dřez připojen k připojení nebo Google pohledu na diagram atd.

4. Sbírka - Když se dva uživatelé změnit "sběrem" pro objekt. Např. Oba Uživatel A a uživatel B přesunuty součást z jednoho rodiče na druhého, nebo re-objednal kolekci dětských komponent.

Poznámka

Různé bezvýznamné konflikty jsou vyřešeny automaticky ABACUS čímž se snižuje zatížení na uživatele.Například všechny konfliktní nastavení pan-zoom pro schémata se rozhodly zachovat poslední nastavení pan-zoom.

Spáchání změny

Pokud se rozhodnete, aby se zavázaly změn, soubor ABACUS ze serveru je otevřen, vaše místní jsou provedeny změny proti tomu, a pak Váš místní .abacus soubor přepsán s jedním, který má změny v něm. Změny souboru pak přepíše .log, a jak soubor .abacus a .log jsou odeslány na server.V případě, že se zavazují je úspěšný Zavázat se dialogové okno, jak je uvedeno níže je poskytována k zadání zprávu s commit.

Zobrazení záznam změn

Na zobrazit protokol změn na Podnik projekt, vybrat Soubor| View Log...

Maximální délka záznamu Záznamy: Tento bude výchozí posledních 10 záznamů ale další vstupy mohou být vyvolány změnou hodnoty a klepnutím na tlačítko Načíst tlačítko.

Revize: ThSloupec e Revize uvádí čísla revizí zavázaly k Enterprise serveru, ve výchozím nastavení, v obráceném chronologickém pořadí.

Poznámka

Čísla revizí nemusí být kontinuální, protože ABACUS dopouští bude uveden pouze při stejné Subversion úložiště může být používán pro jiné projekty Abacus a / nebo jiných kontrolních verze aplikací.

Datum: The Date sloupec obsahuje datum, že revize byl spáchán na Enterprise serveru.

Čas: The Time sloupec obsahuje čas dne (v 24hodinovém formátu), že revize byl spáchán na Enterprise serveru.

Autor: The Autor sloupec obsahuje název Microsoft Windows přihlašovací pro uživatele, která provedla commit následuje jejich ABACUS uživatelské jméno , Nebo "Anonymous" v případě, že uživatel není ověřen a anonymní uživatelé byli povolen přístup k Enterprise projektu v době commitu.

Log Zpráva: Thsloupec e Log Seznamy zpráv zprávy komitu, který byl dodán s revizí podle dialogovém okně je uvedeno výše.

Stáhněte revize XX jako samostatné ABACUS souboru: Pokud vyberete danou revizi v tabulce a potom klepněte na tlačítko Stáhnout budete moci extrahovat zvolené ABACUS revizi projektu ze serveru a uložit jej jako místní / samostatného projektu ABACUS.

Poznámka

Chcete-li se vrátit k předchozí revizi, prosím vidět Avolution článek komunity .

(Správce) Stáhněte soubor XML protokolu pro revizi XX: Uživatelé s možností Správce ABACUS si vybrat danou revizi v tabulce a potom klepněte na tlačítko Stáhnout extrahovat zvolený projekt ABACUS spáchat soubor protokolu ze serveru a uložit jej jako soubor XML.

Zobrazení revizní změn

Na zobrazit revizní změn jakéhokoli daného prvku (tj složky, připojení, pohled, děti atd) po dosažení Podnik projekt, klepněte pravým tlačítkem myši na prvek a vybrat Audit Trail..., Nastavte Od a rozsah revizí a klikněte na tlačítko Vyhledávání.

Poznámka

Jakmile je prvek odstraněn z projektu, již nejsou schopny přístup k informacím konkrétního audit stezka o tento prvek. Můžete však stále přístup "mateřskou" komponentu (například) a zobrazit informace audit stezka o vymazání (v tomto případě seznam ID prvku, který byl odstraněn).Kromě toho, komponentní / příloha Connection je "majetkem" přípojek takže změna připojený komponent z okna Průzkumník nebo na Diagramy se objeví na cestu pro audit připojení není díl a odstranění připojení a vytvoření nového připojení (jako se stane, když kliknete pravým tlačítkem myši 'Unattach' a pak 'Connect ... "v katalozích), bude mít za následek ztrátu informací audit trail pro původní složku - přílohu spojení úplně.

Poznámka

Ve výchozím nastavení je pro audit bude rekurzivně kontrolovat změny některého z dětí vybraného prvku. To může mít za následek dlouhou dobou odezvy a podle toho auditní stopa může být omezeno na samotný prvek odznačením Rekurzivní Možnost podle Možnosti AuditTlačítko "ozubené kolo" Panel nástrojů v dialogovém okně Audit Trail.

Od revize: Tento se standardně nastaví na první / nejstarší revize je k dispozici pro projekt na Enterprise Server.

Revizí: Tento se přepne na poslední / Aktuální verzi k dispozici pro projekt na Enterprise Server.

Poznámka

Po nastavení od a do revize rozsah klepněte na tlačítko Hledat načíst žádné konkrétní změny na vybraný prvek.

Revize: ThSloupec e Revize uvádí čísla revizí zavázaly k Enterprise serveru, ve výchozím nastavení, ve výhledovém chronologickém pořadí.

Poznámka

Čísla revize jsou nepravděpodobné být kontinuální, jak bude zobrazeno pouze revize relevantní pro vybraný prvek a jen ABACUS zavazuje bude uveden zatímco stejný Subversion úložiště může být používán pro jiné projekty Abacus a / nebo kontrolu verze aplikace.

Datum: The Date sloupec obsahuje datum, kdy byla provedena uživatel akce.

Poznámka

Datum uvedené je datum akce uživatele, ne datum revize byl spáchán na Enterprise serveru. V souladu s tím, může být den předcházet odpovídající revizi potvrzování den uvedený s Soubor | View Log ... příkaz.

Čas: The Time sloupec obsahuje čas dne (v 24hodinovém formátu), který byl použit při akce uživatele.

Poznámka

Čas zobrazený je čas akce uživatele, není čas revize došlo k Enterprise Server. V souladu s tím doba bude s největší pravděpodobností předcházet odpovídající revizi zavázat čas zobrazený s Soubor | View Log ... příkaz.

Autor: The Autor sloupec obsahuje uživatele, který provedl akci v Microsoft Windows přihlašovací jméno a následně jejich ABACUS uživatelské jméno , Nebo "Anonymous" v případě, že uživatel není ověřen a anonymní uživatelé byli povolen přístup k Enterprise projektu v době akce uživatele.

Poznámka

Autor uvedeny v Trail dialogu auditu nemusí nutně odpovídat Autor uvedené v dialogovém okně View Log nad za stejné revizi. Je to proto, že dialog seznamy View Log přihlášeného uživatele v okamžiku commitu, zatímco dialog seznamy Audit Trail přihlášeného uživatele v době akce uživatele, a to je možné mít jeden uživatel provádět změny a posílat své. změny souboru jinému uživateli zavázat - jako je tomu v případě, kdy externí uživatel (například Avolution) je pracovat na EE projektu.

Podrobnosti: The Podrobnosti sloupci jsou uvedeny přesné podrobnosti o zásahu uživatele jak jsou zaznamenány v Enterprise Server.

Tip

Je užitečné skupina podle sloupce Revize (jak je znázorněno v dialogu výše) a / nebo uživatel sloupce Akce na Snadno klasifikovat změny prvek zájmu.

Použití skriptování s Enterprise soubory

Pokud používáte skriptování s Enterprise soubory, měli byste si být vědomi toho, jak správně odstranit objekt z modelu. Obecně platí, že když odstraňujete objekt, budete volat metodu .Delete () na tom, spíše než jen vytahování z jeho rodiče.

Např. kdybyste COMP1 jako nadřazený comp2 a chcete vymazat comp2 ve skriptu, měli byste zavolat comp2.Delete (), spíše než comp1.Components.Remove (comp2).

Můžete použít odebrat, pokud máte v úmyslu přidat comp2 objekt na jiné místo v rámci architektury, ale to by neměl být použit v případě, že záměrem je odstranit objekt.

Tam je výjimka z tohoto, protože když chcete odebrat objekt, který "žije" na jiném místě v modelu. Pokud chcete odebrat standardní instanci z architektury / konstrukční části / připojení, pak byste to tím, že odstraní ji z instance standardním sbírka - arch1.Implementace.Uvolnit (IMP) - proto, že odstraněním by se odstranit ze všech instancí.

Správně pomocí Odstranit v skriptů je důležité, protože v případě, že objekt je odebrán z objectmodel a ne znovu přidá, pak to nebude moci být umístěn, ale vzhledem k tomu, že to není specificky vymazaného, ​​bude konfliktů Detekce a Resolution nikoli správně rozpoznat konflikt, pokud jiný uživatel měl pokoušet se používat tento objekt v některé z jejich změn, a konečný výsledek bude poškozený soubor změn pro daného uživatele.

Viz také

Jak se architektura zastoupena v ABACUS?


Práce s oprávněními

Navigace: Správa>

Práce s oprávněními

Odeslat připomínky na toto téma.

Projekty ABACUS mohou mít na základě rolíOprávnění nastavit pro každý prvek v rámci úložiště. Konkrétně, jemnozrnný Create-Read-Update-Delete (CRUD) Oprávnění lze nastavit na "objekt" (tj složka nebo připojení), zobrazení a atributu (tj úrovní vlastnictví).

Přehled

Při práci s ABACUS Enterprise Server , ABACUS nabízí jemnozrnné, založené na rolích CRUD oprávnění řídit přístup více uživatelů k úložišti.

Poznámka

Chcete-li konfigurovat oprávnění v projektu ABACUS licence uživatel potřebuje schopnost správce. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

Oprávnění lze nastavit pro architektury, komponent a připojení typy, vlastnosti (prostřednictvím jejich typů), šablony, názory a diagramy, katalogy, matice, grafy a 3Dpohledy, Pokud jsou oprávnění nastavena pro konstrukční části nebo typu připojení všechny instance tohoto typu v jakémkoli architekturách v tomto projektu "zdědí" ty oprávnění. Podobně, když je oprávnění nastavena pro vlastnost komponenty nebo typu připojení, v daném majetku na komponenty nebo připojení případech v jakémkoli architektur v tomto projektu "zdědí" ty oprávnění. V souladu s tím budou některá oprávnění aplikovat na názory, na nichž existují tyto prvky. Pokud jsou oprávnění nastaven na diagramu, zobrazení a / nebo obsahu pohledu samotného mít různá oprávnění aplikován na to.

Poznámka

Ve výchozím nastavení žádné oprávnění jsou stanoveny pro prvky v rámci projektu ABACUS. To je všechny prvky jsou vytvořitelný, čitelné, aktualizovatelný a Deleteable všichni uživatelé. Tímto způsobem oprávnění by měly být považovány pouze pro daný prvek v úložišti, když určité povolení má být omezenýpro určitou skupinu uživatelů. Například, pokud byly přidány oprávnění pro dané skupiny uživatelů k objektu (například typ komponenty), ale vlevo s všechna oprávnění povoleno, pak je funkčně stejné, jako v případě, že uživatel skupina nebyl přidán k objektu.

Oprávnění nemůženastavit pro specifické instance prvků architekturu je. Například, nemůžete jedna složka Aplikace aktualizovat ještě další ne. Chcete-li tyto "určité domény" oprávnění účinně dosáhnout však může správce nastavit konkrétní typy prvků pro dané domény, např typy komponent "aplikace - CRM domény" a "Aplikace - HR domény", a potom nastavit oprávnění pro každý typ způsobem. Můžete si vytvořit konkrétní typy seskupení pro každou doménu a potom odeberte aktualizaci oprávnění pro daný typ skupiny domény specifické a to omezí výtvory uvnitř a odstranění z toho seskupení, ale nelze aktualizovat z dětí. Samozřejmě, v případě, že seskupení doména specifická byl skryt odebráním povolení pro čtení pak děti budou skryta, a tím non-aktualizovatelný. Případně, pokud jsou použity pohledy (spíše než Exploreru) primárně řídit / zobrazit úložiště, by mohl být zaveden určitý pohled pro každou doménu, a pak správce mohl odpovídajícím způsobem nastavit oprávnění pro každého pohledu.

Správa uživatelů a skupin

Oprávnění jsou definovány na role nebo skupinaúroveň, na rozdíl od úrovni jednotlivých uživatelů, tak, že zatímco členů skupin se může měnit, oprávnění může zůstat pevná. Samozřejmě, pokud chcete, aby konkrétní uživatel oprávnění pak stačí, aby byly skupiny, nebo přesněji vytvořit skupinu s tímto uživatelem jako jediného společníka.

Je třeba uvést, že skupiny jsou atomový, Že se nemohou dědit oprávnění nebo uživatele od jednoho k druhému, a pokud uživatel patří do více skupin pak nejvíce oprávnění skupiny "pesimistický" bude mít přednost případ od případu pro každý jednotlivý oprávnění (tj Vytvořit -Read-Update Delete). Například v případě, že stejný uživatel je členem skupiny A a skupiny B a Skupina A právě Create-oprávnění čtení pro typy komponent Application zatímco skupina B byla právě čtení Aktualizace oprávnění pro typy komponent Application pak uživatel bude mít pouze oprávnění pro čtení instance komponenty Application.

Navíc tím, že ve výchozím nastavení, anonymní uživatelé(že je uživatelé, kteří nebyli definovány, nebo kteří nejsou přihlášeni) mají plný přístupk projektu. To má zajistit, že je k dispozici přístup v počáteční konfiguraci. Chcete-li blokovat přístup anonymní uživatelé jednoduše zrušte označení pole "Povolit anonymní uživatel plný přístup ke spisu" možnost v Správa uživatele / skupiny dialog uvedený níže. Pokud není nastaven anonymní uživatelé budou moci vidět část normami projektu.

A konečně, v případě, že "použití systému Windows Uživatelské jméno Vstup" je zaškrtnuta volba ověřování uživatelské jméno je prováděno proti Windows uživatelské jméno přihlášení na počítači každého uživatele proti uživatelské jméno je zadán dle níže. To je v případě, že systém Windows Uživatelské jméno Přihlášení k počítači daného uživatele to existuje jako platný uživatelské jméno a pak je vyžadováno žádné heslo a uživatel je automaticky ověřen. Poznámka: Toto účinně umožňuje použití Windows Active Directory (AD) ověřování.

Poznámka

Vzhledem k tomu, že oprávnění jsou definována pouze tehdy, když je třeba vzít pryč (omezený) od uživatelů, každý uživatel, který není členem skupiny, nebo jakákoli skupina, která nemá žádné oprávnění definované pro ni proti všem objektům, bude mít plný přístup k projekt.

Uživatelé a skupiny uživatelů

Chcete-li vytvořit nového uživatele

1. Vybrat Soubor| Správa uživatele / skupiny

Poznámka

Pokud nevidíte Spravovat uživatele / skupiny položky menu pak nemáte možnost správce. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

2. V dialogovém okně, které se objeví vyberte Přidat uživateletlačítko a zadejte uživatelské jméno a heslo v dialogovém okně Vytvořit nového uživatele. Poznámka: Uživatelská jména a hesla jsou velká a malá písmena.

Poznámka

Pokud je "užití Windows Uživatelské jméno Vstup" volba zaškrtnuta, jak je popsáno výše pak neúčinným heslo může být zadána jako ověření bude provedeno v souladu s operačním systémem Windows, kdy uživatel Uživatelské jméno jediného přihlášení.

2. Ve výchozím nastavení uvidíte, že Uživatelé mohou změnit své vlastní heslo. Pokud je to nutné, správce ABACUS může odstranit schopnost pro uživatele nastavit své vlastní heslo podle odškrtnutímzaškrtávacích políček.

Poznámka

Pokud mohou uživatelé změnit své vlastní heslo, které bude mít Soubor | Změnit heslo...položka menu, aby tak učinily.Také být vědomi, že pokud více lidí používá stejné uživatelské jméno pak jeden uživatel může změnit heslo tak, že žádné další osoby můžete přihlásit později. V souladu s tím, je doporučeno praxi mít single uživatelské jméno na fyzické osoby.

4. Volitelně, zadejte e-mailovou adresu, Umístění a telefonní číslo pro uživatele, pro pozdější použití.

5. Klikněte na Dobřetlačítko v dialogovém okně Vytvořit nového uživatele.

6. Klikněte na Dobře tlačítko.

Poznámka

Jakmile jste vytvořili svůj první uživatel, měli byste uvažovat o blokování přístupu anonymními uživateli zrušením zaškrtnutí "Povolit anonymní uživatel plný přístup ke spisu" možnost v dialogovém okně Správa uživatelů / skupin.Také, jakmile uživatel byl vytvořen (a je-li projekt Enterprise, změna zavázala k serveru), příště je projekt otevřen uživatelé budou vyzváni k Přihlášení pro ověřený přístuppodle dialogovém okně níže. V případě, že Přihlásit automaticky s těmito detailyje zaškrtnuta volba pak kombinace uživatelské jméno / heslo bude připomínán pro projekt a aplikovat pokaždé při otevření. Chcete-li vymazat uložené přihlašovací select Soubor | Smazat uložené Přihlášenípo otevření a budete vyzváni k přihlášení příště otevřete projekt.

Přihlásit se

Chcete-li odstranit stávající uživatele

1. Vybrat Soubor| Správa uživatele / skupiny

2. V dialogovém okně, které se objeví vyberte uživatelské jméno v panelu uživatelů, které chcete odstranit, a poté vyberte Smazat uživatele tlačítko.

3. Klikněte na Dobře tlačítko.

Chcete-li vytvořit novou skupinu

1. Vybrat Soubor| Správa uživatele / skupiny

2. V dialogovém okně, které se objeví vyberte Přidat skupinutlačítko a zadejte název skupiny v panelu Skupiny.

Poznámka

Názvy skupin musí být jedinečné.

3. Klikněte na Dobře tlačítko.

Na kopírovat stávající Skupina

1. Vybrat Soubor| Správa uživatele / skupiny

2. V dialogovém okně, které se objeví vyberte Kopie Skupina tlačítko.

Poznámka

Duplicitní skupina bude vytvořena s předponou "Kopie".Ve výchozím nastavení jsou všechny oprávnění z zkopírované skupiny budou duplikovány pro "Kopie" skupiny, včetně jakéhokoli přidělení uživatele.

3. Přejmenovat "kopie" skupiny, jako odpovídající použití Upravit skupinunebo pomalu poklepání.

Chcete-li odstranit existující skupiny

1. Vybrat Soubor| Správa uživatele / skupiny

2. V dialogovém okně, které se objeví vyberte jméno skupiny v panelu skupin, které chcete smazat, a poté vyberte Smazat skupinu tlačítko.

Poznámka

Každý uživatel, přiřazení ke skupině budou také odstraněny.

3. Klikněte na Dobře tlačítko.

Chcete-li přiřadit uživatele do skupiny

1. Vybrat Soubor| Správa uživatele / skupiny

2. V dialogovém okně, které se objeví vyberte uživatelské jméno v panelu uživatelů, které chcete přiřadit do skupiny a táhni a pusťto na název skupiny v panelu Skupiny, které chcete přiřadit k.

3. Klikněte na Dobře tlačítko.

Poznámka

Skupina (y), že uživatel je přiřazen jsou zobrazeny rozbalením Uživatelské jméno v panelu Uživateléa uživatelé, které jsou přiřazeny ke skupině, jsou zobrazeny tím, že rozšíří název skupiny v panelu Skupiny. Například, ve výše uvedeném snímku, uživatel "AS1-Aus" je přiřazen na tři (3) skupin, a to; "App Support Team 1", "Actual" a "Austrálie".

Chcete-li zrušit přiřazení uživatele ze skupiny

1. Vybrat Soubor| Správa uživatele / skupiny

2. V dialogovém okně, které se objeví rozbalte název skupiny, která obsahuje zadání uživatele, který chcete zrušit přiřazení a vyberte uživatelské jméno.

3. Klikněte na Zrušit přiřazení Uživatel tlačítko.

4. Klikněte na Dobře tlačítko.

Chcete-li importovat uživatele a / nebo skupiny (a žádné odpovídající oprávnění)

1. Vybrat Soubor| Správa uživatele / skupiny

2. Klikněte na Importovat tlačítko.

3. V dialogovém okně, které se objeví Procházetpro a otevřete projekt ABACUS obsahující uživatele a / nebo skupiny (a oprávnění), který chcete importovat do aktuálního projektu a klepněte na tlačítko Otevřít, Uživatele a skupiny, budou importovány a dialog Importovat Výsledky se zobrazí shrnující dovoz uživatelů a / nebo skupin. Klikněte na Dobře tlačítko.

Poznámka

V případě, že dovážené uživatelů nebo skupin existovala již v aktuálním projektu pak budou sloučena se stávajícími uživatele nebo skupiny.

4. Klikněte na Dobřetlačítko zpět v hlavním dialogového okna Správa uživatele / skupiny.

5. Pokud se vyskytnou nějaké typy vyhovující, vyhlídky, šablony nebo Architektury mezi aktuálním projektu a projekt ABACUS jste dovážející od, kompletní s oprávněními, které nejsou již existují v aktuálním projektu, oprávnění jsou dováženy a druhý dialog Importovat výsledky Zobrazí se shrnutí import. Klikněte na Dobře tlačítko.

Poznámka

Oprávnění jsou přidány pouze na existující typy (a jejich vlastnosti), pohledy, šablony nebo architektur pro skupiny, kde oprávnění nebylo již pro skupinu existují. Buď proto, že skupina je nová, nebo skupina existovala již v aktuálním projektu, ale žádná oprávnění bylo přiděleno pro tuto skupinu, aby danou položku. Neexistuje žádná "sloučení" oprávnění pro odpovídající položky, kde již existující oprávnění pro skupinu v aktuálním projektu.

Nastavení oprávnění

Oprávnění lze nastavit pro architektury, komponent a připojení typy, vlastnosti (prostřednictvím jejich typů), šablony, názory a diagramy, katalogy, matice, mapujed 3Dpohledy, Pokud jsou oprávnění nastavena pro konstrukční části nebo typu připojení všechny instance tohoto typu v jakémkoli architekturách v tomto projektu "zdědí" ty oprávnění. Podobně, když je oprávnění nastavena pro vlastnost komponenty nebo typu připojení, v daném majetku na komponenty nebo připojení případech v jakémkoli architektur v tomto projektu "zdědí" ty oprávnění. V souladu s tím budou některá oprávnění aplikovat na názory, na nichž existují tyto prvky. Pokud jsou oprávnění nastaven na diagramu, zobrazení a / nebo obsahu pohledu samotného mít různá oprávnění aplikován na to.

Oprávnění Správa

Chcete-li nastavit oprávnění pro komponentu (nebo připojení) Typ

1. Rozbalte Druhyvětev stromu.

2. Rozbalte Component (nebo připojení) Typyvětev stromu.

3. Rozšířit Skupinyv případě potřeby.

4. Klikněte pravým tlačítkem myši na Component (nebo připojení) TypChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

5. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

6. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

Poznámka

Vytvořte povolení upravuje i tehdy, když je možné kopírovat prvek. V souladu s tím, aby bylo možné kopírovat prvek vyžaduje vytvořit oprávnění pro všechny jeho děti (od zkopírovat prvek znamená kopírovat vše pod ním). Odebrání aktualizace povolení od prvku odstraňuje schopnost modifikovat samotný typ, a to iv případě, že uživatel má Návrhář doplněk a to také odstraňuje aktualizace povolení pro všechny své vlastnosti. Rodič prvek musí mít aktualizace povolení, aby mohli Vytvořte nějaké děti prvků nebo Smazat ITS existující dětské prvky. Odstranění povolení pro prvek také vyžaduje Delete povolení pro všechny jeho děti. Smazat povolení pro komponenty také vyžaduje aktualizace povolení všech připojených připojení.A konečně, odstranění Delete povolení od prvku odstraní schopnost odstranit samotný typ, a to iv případě, že uživatel má Návrhář add-on.

7. Klikněte na Dobře tlačítko.

Chcete-li nastavit oprávnění pro skupinu složky (nebo připojení) Druhy

1. Rozbalte Druhyvětev stromu.

2. Rozbalte Component (nebo připojení) Typyvětev stromu.

3. Klikněte pravým tlačítkem myši na Skupina, který obsahuje složka (nebo připojení) typy, které chcete nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

6. Klikněte na Dobře tlačítko.

7. V dialogovém okně, které se objeví klikněte na tlačítko Ano tlačítko.

Chcete-li nastavit oprávnění pro vlastnost

1. Rozbalte Druhyvětev stromu.

2. Rozbalte Component (nebo připojení) Typyvětev stromu.

3. Rozšířit Skupinyv případě potřeby.

4. Vyberte Component (nebo připojení), typ, který obsahuje vlastnost, kterou chcete nastavené oprávnění pro.

5. V okně Vlastnosti klikněte pravým tlačítkem myši na VlastnictvíChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

6. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

7. Ve výchozím nastavení uvidíte, že oprávnění Číst a aktualizace jsou k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

Poznámka

Vlastnosti, které měly povolení aktualizace odstraněny jsou uvedeny v kurzívaV okně Vlastnostia jejich hodnoty nemohou být aktualizovány tímto rolí, Dále, schopnost změnit údaje o nemovitosti (např jméno, jednotky atd) vyžaduje jak Update oprávnění na nemovitosti a Návrhář add-on.

8. Klikněte na Dobře tlačítko.

Chcete-li nastavit oprávnění pro šablony

1. Rozbalte Šablonyvětev stromu.

2. Vyhledejte Šablonaže máte zájem.

3. Klikněte pravým tlačítkem myši na ŠablonaChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení uvidíte, že oprávnění čtení je k dispozici. Odstraňte povolení podle odškrtnutímzaškrtávací políčko.

6. Klikněte na Dobře tlačítko.

Chcete-li nastavit oprávnění pro Viewpoint

1. Rozbalte Úhly pohleduvětev stromu.

2. Rozšířit Skupinyv případě potřeby.

3. Klikněte pravým tlačítkem myši na HlediskoChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

6. Klikněte na Dobře tlačítko.

Chcete-li nastavit oprávnění pro architekturu

1. Rozbalte Architekturyvětev stromu.

2. Rozbalte do Architekturaže máte zájem.

3. Klikněte pravým tlačítkem myši na ArchitekturaChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení uvidíte, že oprávnění čtení je k dispozici. Odstraňte povolení podle odškrtnutímzaškrtávací políčko.

6. Klikněte na Dobře tlačítko.

Chcete-li nastavit povolení pro Katalog

1. Rozbalte Katalogyobor architektury máte zájem.

2. Rozšířit Skupinyv případě potřeby.

3. Klikněte pravým tlačítkem myši na KatalogChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

6. Klikněte na Dobře tlačítko.

Chcete-li nastavit povolení pro Matice

1. Rozbalte Maticeobor architektury máte zájem.

2. Rozšířit Skupinyv případě potřeby.

3. Klikněte pravým tlačítkem myši na MaticeChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

6. Klikněte na Dobře tlačítko.

Chcete-li nastavit oprávnění pro diagram

1. Rozbalte Diagramyobor architektury máte zájem.

2. Rozšířit Skupinyv případě potřeby.

3. Klikněte pravým tlačítkem myši na DiagramChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

Poznámka

I když můžete nastavit oprávnění CRUD přímo diagramu, je třeba poznamenat, že oprávnění prvků na schématu může mít vliv na oprávnění pro zobrazení samotného. Například, pokud je třeba jen jedním prvkem v názoru, že má za sebou svou číst nebo aktualizovat oprávnění odstranit pak diagram bude mít odstraněny jeho aktualizace povolení. To je proto, že; a) prvky na názoru, že měli odebrány jejich oprávnění čtení, nebudou zobrazeny v pohledu opouštět "bílý prostor", kde byste jinak umístit některé nové prvky v případě, že výhled z hotelu byl aktualizovat, a b) prvky na názoru, že měli jejich svolení aktualizace odstraněna by pak mohl mít další prvky, klesl na ně, aby se stal děti, v případě, že výhled z hotelu byl aktualizovat. Také, vytvářet a aktualizovat oprávnění pro schéma vyžaduje, aby všechny prvky na zobrazení mají oprávnění ke čtení a složky mají povolení aktualizace (to je proto, přesunout složku do jiné složky, musíte být schopni jej aktualizovat, protože bude stát dítě).

6. Klikněte na Dobře tlačítko.

Chcete-li nastavit oprávnění pro zobrazení 3D

1. Rozbalte 3D Zobrazeníobor architektury máte zájem.

2. Rozšířit Skupinyv případě potřeby.

3. Klikněte pravým tlačítkem myši na 3D zobrazeníChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

6. Klikněte na Dobře tlačítko.

Chcete-li nastavit povolení pro Schéma

1. Rozbalte Grafyobor architektury máte zájem.

2. Rozšířit Skupinyv případě potřeby.

3. Klikněte pravým tlačítkem myši na SchémaChcete-li nastavit oprávnění pro a vyberte Upravit oprávnění.

4. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

5. Ve výchozím nastavení budete vidět, že crud oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

6. Klikněte na Dobře tlačítko.

Viz také

Jak se architektura zastoupena v ABACUS?


Práce s Dashboards

Navigace: Správa>

Práce s Dashboards

Odeslat připomínky na toto téma.

Projekty Abacus mohou mít jakoukoli konfiguraci názory (např diagramy, Grafy atd) uložené jako palubní deska a tyto uložené dashboardy mohou být nastavit jako výchozí spouštění "obrazovky" na otevření projektu a / nebo přiřadit k určitému skupina uživatelů a prezentovány na členy této skupiny uživatelů, když se přihlásí do projektu ABACUS.

Poznámka

Chcete-li nakonfigurovat panely dashboard v projektu ABACUS licence uživatel potřebuje schopnost správce. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

Prohlížení Dashboards

Příkladem aplikací Portfolio Management (APM) dashboard

Chcete-li zobrazit uložené Dashboard

1. Vybrat Pohled| Dashboards

2. Vyberte uloženou přístrojovou desku ze seznamu dostupných přístrojových desek.

Poznámka

Jakmile vybrané ABACUS bude stavět názory potřebné pro přístrojovou desku, a to může trvat několik sekund. Prosím, buďte trpěliví.

Správa Dashboards

Správa Dashboards

Chcete-li vytvořit nový Dashboard

1. Otevřete požadované názory a zařídit a dock okna, jak je požadováno pro přístrojovou desku.

2. Vybrat Pohled| Dashboards| Spravovat Dashboards ...

Poznámka

Pokud nevidíte Správa Dashboards položku pak nemáte možnost správce. Obraťte se na místního správce ABACUS nebo Podpora Avolution Pokud vyžadujete tuto funkci.

3. V dialogovém okně, které se objeví vyberte VytvořitTlačítko a zadejte název Dashboard v dialogovém okně Vytvořit nový ovládací panel.

4. Klikněte na Dobře tlačítko.

Chcete-li odstranit existující Dashboard

1. Vybrat Pohled| Dashboards| Spravovat Dashboards ...

2. V dialogovém okně, které se objeví vyberte Dashboard, kterou chcete odstranit ze seznamu a vyberte Vymazat tlačítko.

Poznámka

Odstranění řídicího panelu bude také odstranit všechny skupiny uživatelů přiřazení k tomuto palubní desky.

3. Klikněte na Dobře tlačítko.

Chcete-li nahradit existující Dashboard

1. Otevřete požadované názory a zařídit a dock okna, jak je požadováno za náhradní palubní desky.

2. Vybrat Pohled| Dashboards| Spravovat Dashboards ...

3. V dialogu, který se objeví vyberte Dashboard, který chcete nahradit ze seznamu a vyberte Nahradit tlačítko.

4. Klikněte na DobřeTlačítko pro potvrzení dialog Dashboard vyměnit.

Chcete-li přiřadit Dashboardjako výchozí úvodní obrazovce

1. Vybrat Pohled| Dashboards| Spravovat Dashboards ...

2. V dialogovém okně, které se objeví vyberte Dashboard ze seznamu, kterou chcete přiřadit jako výchozí úvodní "obrazovku"a vyberte Přiřadit... tlačítko.

3. V dialogovém okně, které se objeví vyberte vstup do uživatelské skupiny sloupců.

Poznámka

Pouze jeden dashboard lze přiřadit jako start "obrazovky", aby re-úkol bude odstranit Projekt zadání z předchozího palubní desky.Kromě toho, pokud se uživatel přihlásí jako člen skupiny uživatelů, která má přidělenou palubní desku, pak přiřazen přístrojová deska se otevře namísto výchozí projektu palubní desky.

4. Klikněte na Dobře tlačítko.

Chcete-li přiřadit uživatelské skupiny na Dashboard

1. Vybrat Pohled| Dashboards| Spravovat Dashboards ...

2. V dialogovém okně, které se objeví vyberte Dashboard ze seznamu, kterou chcete přiřadit skupinu uživatelů pro a vyberte Přiřadit... tlačítko.

3. V dialogovém okně, které se objeví vyberte User Group (nebo skupiny)Chcete-li přiřadit palubní desky jako na obrazovce pro "do začátku".

Poznámka

Je-li stejný User Group přiřazena více dashboardy pak bude použita jako první úkol v seznamu.

4. Klikněte na Dobře tlačítko.

Chcete-li zrušit přiřazení skupiny uživatelů z Dashboard

1. Vybrat Pohled| Dashboards| Spravovat Dashboards ...

2. V dialogovém okně, které se objeví rozbalte položku Dashboard ze seznamu, kterou chcete zrušit přiřazení skupiny uživatelů z.

3. Vyberte skupinu uživatele, kterou chcete zrušit přiřazení a vyberte Zrušit přiřazení tlačítko.

4. Klikněte na Dobře tlačítko.

Nastavení oprávnění

Oprávnění lze nastavit pro řídicí panely, aby bylo možné je přístrojová deska, aby byla viditelná, Aktualizovat a / nebo deleteablezadaných uživatelských skupin.

Oprávnění Správa

Chcete-li nastavit oprávnění pro Dashboard

1. Vybrat Pohled| Dashboards| Spravovat Dashboards ...

2. V dialogovém okně, které se objeví vyberte Dashboard ze seznamu, kterou chcete nastavit oprávnění pro a vyberte Oprávnění ... tlačítko.

3. V dialogovém okně, které se objeví klikněte na Přidat...tlačítko a vyberte SkupinaChcete-li přidat buď poklepáním nebo výběrem a klepnutím na tlačítko Dobře tlačítko.

4. Ve výchozím nastavení uvidíte, že čtení, aktualizaci a odstraňování oprávnění jsou všechny k dispozici. Odeberte oprávnění od odškrtnutímpříslušná zaškrtávací políčka.

5. Klikněte na Dobře tlačítko.

Viz také

Přizpůsobení rozhraní ABACUS | Práce s oprávněními


Registrace ABACUS

Navigace: Reference>

Registrace ABACUS

Odeslat připomínky na toto téma.

Při prvním spuštění počítadlo (nebo po dočasném licence vypršela), budete muset zaregistrovat aplikaci proti licenčním serveru Avolution Používá jedinečný licenční klíč poskytované na místní správce ABACUS nebo přímo z Avolution. Pokud nemáte licenční klíč, prosím kontaktujte svého místního správce ABACUS nebo Podpora Avolution .

Pro registraci s licenčním klíčem

1. Po instalaci, spustit počítadlobuď poklepáním na zástupce na ploše nebo v nabídce Start systému Windows.

2. V dialogovém okně Registrace, které se objeví zadejte 26 znak licenční klíčposkytnuté místního správce ABACUS nebo Podpora Avolution , Nebo klepněte na tlačítko Procházet...a vyberte podepsal .dlsc soubor vrátil z Podpora Avolution dle poznámce v kroku 4 níže. Používáte-li správně podepsaný .dlsc soubor ABACUS by měla začít podle kroku 5 níže.

Tip

Můžete vložit licenční klíč do dialogu zkopírováním do schránky Windows a výběrem na pozadí dialogu a stisknutím Ctrl + V.

Dialog Registrace

3. Klepněte na tlačítko Dobřea v případě, že licenční klíč je ABACUS platný licenční klíčABACUS se nyní pokusí kontaktovat licenční server Avolution k ověření licenční klíč.

Poznámka

Pokud dostanete Instalační kód je neplatnýRegistrace chyba je velmi pravděpodobné, že jste zadali nesprávně kód. Zkuste zkopírovat a vložit kód podle tip je uvedeno výše.

Kontaktování licenční server Avolution

4. Klepněte na tlačítko Dobřea po krátké době by měla ABACUS úspěšně registrovat.

Úspěšné Registrace

Poznámka

Pokud dostanete Nelze kontaktovat licenční serverRegistrace chyba je velmi pravděpodobné, že brána firewall (nebo jiná bezpečnostní opatření) ve vaší síti brání přístupu k licenčnímu serveru Avolution je. Klepněte na tlačítko DobřeUložte .dlsc soubor na lokální počítač a poté buď e-mail soubor .dlsc na Podpora Avolution a čekají na další instrukcenebo se snaží podepsat licenční soubor sami pomocí následující adresu - http://licensing.avolutionsoftware.com/LicenceSign/ .

Nelze kontaktovat licenční server

Otevřete License podpisu webové stránky

Manuální licence podepsání webové stránky

Případně, pokud se dostanete Tento kód instalace byl použit na více systémů, než povoluje licenceRegistrace chyba je pravděpodobné, že váš místní stroj byl přestavěn od posledního registrovaný Abacus, nebo se snažíte zaregistrovat licenční klíč jiného uživatele. Obraťte se na místního správce ABACUS nebo Podpora Avolution .

Již byl použit k instalaci kód

5. Klepněte na tlačítko Dobřea je-li zapsána úspěšně ABACUS by měla otevřít s Uvítací obrazovka .

Viz také

Podpora Avolution | Co ABACUS dělat?


ABACUS Instalace Předpoklady

Navigace: Reference>

ABACUS Instalace Předpoklady

Odeslat připomínky na toto téma.

Informace týkající se aplikace Visio Excel Import a Import / Export

ABACUS vyžaduje Microsoft Office být instalovány tak, aby k provádění operací Excel import / export a Visio Importovat. Ověřte prosím, že Microsoft Office 2003 nebo novějšíje správně nainstalován. Pokud narazíte na další problémy, kontakt Podpora Avolution .

Aby bylo možné provádět Visio Import a Excel import / export operace, ABACUS používá Microsoft Office primární sestavení InterOp (PIA je). ABACUS v současné době je dodáván s agregáty potřebné k provedení Excel Import / Export a Visio Import.

Informace týkající se SQL Server importem

ABACUS vyžaduje Microsoft SQL Server 2005, 2008, 2008 R2, 2012 nebo 2014je nainstalován, aby mohl začít nový projekt ze serveru SQL Server. Ověřte prosím, že Microsoft SQL Server 2005, 2008, 2008 R2, 2012 nebo 2014je správně nainstalován. Pokud narazíte na další problémy, kontakt Podpora Avolution .

Chyby Otevření 3D vizualizace

Pokud 3D prohlížeč ABACUS nefunguje pro vás, nesmí chybět v SlimDX DirectX Runtime (instalován jako součást plného ABACUS EXE instalace). To lze stáhnout zde , Pokud máte 64bit verzi systému Windows, budete možná muset nainstalovat tento .

Chyby Editace POČITADLO Zvyk Zprávy

Editace počítadlo "Custom Reports vyžaduje Report Builder 3.0, které mají být nainstalovány. ABACUS a Report Builder jsou postaveny na Microsoft .NET Framework 4.0, a zatímco oba nevyžadují Microsoft .NET Framework 3.5, Microsoft nesprávně nakonfiguroval Report Builder MSI pouze postupovat, pokud je nainstalován Microsoft .NET Framework 3.5.

V souladu s tím, Avolution má upravenou verzi instalačního Report Builder MSI souboru, který nevyžaduje Microsoft .NET Framework 3.5, může to být staženy zde .

Původní Microsoft Report Builder MSI si můžete stáhnout zde , Pokud ještě nemáte Microsoft .NET Framework 3.5, která bude vyžadovat, můžete si jej stáhnout zde , Poznámka: Pro více instalací, offline instalaci Microsoft .NET Framework 3.5 z zde může být vhodnější.


Možnosti příkazového řádku

Navigace: Reference>

Možnosti příkazového řádku

Odeslat připomínky na toto téma.

Můžete provádět různé operace Abacus přímo z příkazové řádky s nejčastější operace bytí otevřít konkrétní soubor projektu a publikovat na HTML.

Konkrétně se jedná o použití příkazového řádku ABACUS je následující;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "USER" / pass "PASS"]

Argument | Popis
ProjectFile | ProjectFile může být buď ABACUS Soubor projektu (.abacus), soubor knihovny (.abacuslib), soubor XML (.xml) nebo MS Access DB (MDB) a určený soubor bude buď otevřít (pokud .abacus nebo .abacuslib ), nebo vytvořen nový projekt (je-li XML nebo soubor MDB).
OptionalFile | OptionalFile může být buď skript ABACUS (.abacusscript, .vb nebo .cs), Makro (.abacusmac) nebo soubor knihovny (.abacuslib) a určený soubor bude buď spuštěn po otevření ProjectFile (pokud .abacusscript, .vb nebo .cs nebo .abacusmac), nebo jednoduše otevřít (pokud .abacuslib).
/ exitOnCompletion | Se ukončí Abakus a v případě potřeby uložit a zavázat všechny změny do otevřeného .abacus projektů na dokončení každé skriptu nebo makro. Poznámka: Tento parametr je malá a velká písmena, takže je nutné použít znak velkého písmene "o" a "C" v textu, jak je znázorněno.
/ dontShowDialogs | Zabrání ABACUS Enterprise Edition (EE) oznámení o aktualizaci dialogy zobrazovaly při otevření projektu. Poznámka: Tento parametr je malá a velká písmena a tak se určitě použít velká písmena "S" a "D" v textu, jak je znázorněno.
/ user "USER" / pass "PASS" | Uživatelské jméno uživatele a heslo PASS bude použit k přihlášení do projektu s, nahradí jakákoli uložená pověření uživatele. Poznámka: Uvozovky musí být umístěny kolem uživatele a PASS vlajky a dvě dvojité uvozovky mohou být použity k útěku uvozovek v jeden uživatel nebo PASS vlajky.

Např.;

ABACUS.exe "Data \ Example.abacus" "\ ScriptsPublishExample.vb"/ exitOnCompletion / dontShowDialogs / user "Public" / pass "123456"

kdy spustit z adresáře, kde ABACUS.exe dvojitý je Nachází bude otevřít Projekt Příklad a přihlaste se jako uživatel s heslem veřejné 123456 (jak je popsáno zde ), Zveřejní jej do HTML a pak zavřete projekt a to vše bez jakýchkoli zobrazení dialogová okna na cestě (např Aktualizovat úspěšné "nebo" k dispozici žádné aktualizace "pro podnikové projekty).

Např.;

ABACUS.exe "Data \ Example.abacus" "\ ScriptsKatalog Excel import.vb"/ exitOnCompletion / dontShowDialogs

kdy spustit z adresáře, kde ABACUS.exe dvojitý je Nachází bude otevřít Projekt Příklad a importovat "servery (2014 Actual) XLSX" MS Excel soubor do katalogu "serverů" na "2014" Aktuální architektuře projektu, aniž by vykazovaly jakékoli dialogová okna podél cesty, a pak uzavření projektu po dokončení. Pokud se operace provede změny v projektu, pak při uzavírání změny se uloží lokálně a je-li Enterprise projekt zavázala k Enterprise Server.

Poznámka

Ujistěte se, že používáte správný dvojité uvozovky jak tam je několik do standardní znakové sady ASCII a příkazového řádku systému Windows bude pracovat správně pouze se správným jedním. Správný dvojitý kód citát znak Desetinné 34 (hexadecimálně 22).To je to, co se používá ve výše uvedeném příkladu, takže neváhejte a kopírovat / vložit jej odtamtud.


Titulní strana

POČITADLO

Disclaimer

Avolution Pty Ltd neposkytuje žádné prohlášení ani záruky, pokud jde o tohoto manuálu a, v maximální míře povolené zákonem, výslovně omezuje svou odpovědnost za porušení jakékoliv záruky, které mohou být předpokládané k nahrazení této příručky s jiným. Dále, Avolution Pty Ltd si vyhrazuje právo revidovat tuto publikaci kdykoli, aniž by jí tím vznikl závazek upozorňovat jakoukoli osobu na revizi.

Copyright

Copyright 2001-2015Avolution Pty Ltd. Všechna práva vyhrazena.

Ochranné známky

Avolution Pty Ltd učinila veškeré úsilí dodávat informace o ochranných známkách o názvy společností, produktů a služeb uvedených v tomto návodu. Ochranné známky uvedené níže byly odvozeny z různých zdrojů.

Microsoft Windows, Access, Visio, Excel, SQL Server a Internet Explorerjsou ochranné známky společnosti Microsoft Corporation.

Obecná poznámka:

Některé názvy produktů použité v této příručce jsou použity pouze pro účely identifikace a mohou být ochrannými známkami příslušných vlastníků.

Prosinec do roku 2015Edition pro Avolution ABACUS verze 4.5.

Manuální revize 1.0

Generated, tištěný, a svázal v Austrálii.