Hvad gør ABACUS gøre?

Navigation: Introduktion til ABACUS>

Hvad gør ABACUS gøre?

Send kommentarer om dette emne.

For at få hjælp på andre sprog / oversættelser klik her .

ABACUS tager gætte arbejde ud af at håndtere løsninger, systemer, software, information, teknologi, forretningsprocesser og / eller hele virksomheder (samlet benævnt arkitekturer). Det kan hjælpe dig til at pragmatisk designe, overvåge, simulere, analysere og visualisere din arkitektur ved at modellere det, analysere det på intuitive måder (f.eks diagrammer, diagrammer og 3D), og derefter evaluere den mod din ikke-funktionelle krav.

Note

Ikke-funktionelle kraver de krav, som ikke relaterer sig direkte til, hvordan et produkt fungerer. I stedet, de er optaget af, hvor godt det fungerer. Ikke-funktionelle krav omfatter sådanne ting som ydeevne, åbenhed, udviklingsevne, kvalitet, skalerbarhed, modularitet, mv (i modsætning til funktionelle krav som, tænde dette lys, når denne knap er klikket). Traditionelt har ikke-funktionelle krav været vanskeligt - hvis ikke umuligt - at måle. Faktisk ABACUS er det eneste produkt, der objektivt og kvantificerbart kan måle de første tre - præstation, åbenhed, og udviklingsevne.

Kort sagt, du indtaster arkitektur og hvad du har brug for det at gøre. ABACUS så fortæller dig, hvis det vil gøre efter behov og påpeger eventuelle svagheder eller huller.

ABACUS trækker på over 20 år af systemer forskning og mange flere års etablerede systemteori. Det giver dig kvantificerbare, pålidelige, objektive svar, så du er ikke afhængig af subjektiv vurdering.

ABACUS står for Architecture-Based ANALYSE, CMEDDELELSE og Understanding af Systems. Det kan hjælpe dig med nogen storstilet arkitektur, men det er generelt bruges til fire (4) ting:

· Udviklingenen aktuel arkitektur. For eksempel, hvis din eksisterende arkitektur mangler ydeevne, vil ABACUS visualisere arkitektur for dig, at identificere de problemer (flaskehalse, etc.), så fortælle dig nøjagtighvordan man kan forbedre arkitekturen.

· Designen ny arkitektur. For eksempel, hvis du har brug for en helt ny arkitektur, og du designer det selv, vil ABACUS fortælle dig nøjagtighvilke komponenter du har brug for, og hvordan de skal tilsluttes.

· Indkøben ny arkitektur. For eksempel, hvis du har opfordret til bud på udformningen af ​​en ny arkitektur, og du vælger mellem tre designs, vil ABACUS fortælle dig nøjagtighvilken en der passer dine behov bedst.

· Kombinationnuværende eksisterende arkitekturer. For eksempel, hvis du har brug for at kombinere to eller flere separate arkitekturer, vil ABACUS guide dig.

Se også

Hvordan du gør det (Oversigt) | Hvad er arkitektur? | Hvordan er en arkitektur repræsenteret i ABACUS?

© 2001-2015 skønnede udvikling Pty Ltd Alle rettigheder forbeholdes.


Sådan bruger du ABACUS (Oversigt)

Navigation: Introduktion til ABACUS>

Sådan bruger du ABACUS (Oversigt)

Send kommentarer om dette emne.

Dette emne indeholder en grundlæggende overblik over de opgaver, der er forbundet med at bruge ABACUS.

Nedenstående diagram illustrerer arkitekturen-baserede analyse proces, som ABACUS foreskriver udvikler en aktuel arkitektur til en ny eller target arkitektur.

Den ABACUS Process

For at bruge ABACUS:

1. Revidere - Før du bruger ABACUS, skal du samle alle de oplysninger, du har om arkitektur og dens krav.

· Arkitektur - Identificere de potentielle komponenter i arkitektur og hvordan de interagerer. Der bør kun være nogle få komponenter på det øverste niveau. Disse kaldes "væsentlige komponenter". Selv de mest komplekse arkitekturer skal have mindre end 10 essentielle komponenter. f.eks. De væsentlige elementer i et forsikringsselskab arkitektur kan være politikker, kvitteringer, krav, og betalinger.

· Krav- Du er nødt til at vide, hvad der forventes af arkitekturen for at afgøre, om det er tilfredsstillende. f.eks. Antal transaktioner pr time.

· Hvor finder du det? - Denne information kan komme fra kravspecifikationer, design dokumenter, interviews med interessenter, den indsat kode osv Dybest set ethvert materiale, der er tilgængelig tilbyder ABACUS oplysninger om arkitekturen.

2. Befolke -Brug ABACUS at modellere din arkitektur og at præcisere de krav, vil blive målt arkitekturen imod.

· Arkitektur - I ABACUS du starter ud med en tom arkitektur - du skal befolke det. Det betyder indtaste alle arkitektur oplysninger, du indsamlede ovenfor. Du kan udfylde din arkitektur manuelt (ved hjælp af højreklik-menuen), eller du kan udfylde det automatisk (fra Microsoft Visio, Excel, Access osv). Typisk det øverste niveau (mere abstrakte) af arkitektur vil blive befolket manuelt, og de lavere (mere beton) vil blive befolket automatisk.

· Krav - Efterhånden som du tilføjer dine komponenter og forbindelser, du angiver deres egenskaber. I de fleste tilfælde vil disse egenskaber blive kravene i arkitekturen. For eksempel, hvis du vil have en 1.250 MIPS node / klynge, ville du tilføje node som en komponent, tilsæt derefter ydeevne ejendommen, og tildele en værdi på 1250 MIPS.

3. Analysere - Brug ABACUS til elegant analysere og visualisere den komplekse struktur af din arkitektur. Du kan analysere din arkitektur på en række måder eller fra en række synspunkter, herunder diagrammer, 3D og Explorer. Alternativt kan du ønsker at bruge nogle mere specifikke synspunkter som følger:

· Kortlægge din arkitektur - for at få ydeevne (responstid, båndbredde etc.), omkostninger (bar, pie, etc.) eller udviklingsevne (kapacitet plads, afvejning, etc.) synspunkter.

· Opret en rapport om din arkitektur.

4. Simulere - Brug ABACUS at simulere din arkitektur ydeevne, tilgængelighed, omkostninger, åbenhed osv

· For at gøre dette, skal du køre en af ​​simulatorer. ABACUS evaluerer din arkitektur mod dine kravved at udføre en simulering. Det læser og analyserer den aktuelle arkitektur, kører simuleringer, og beregner nogle nye egenskaber. Disse egenskaber bliver derefter gemt tilbage til arkitekturen. De nye egenskaber er de data, du forsøger at analysere, såsom udnyttelse, svartid, båndbredde,% tilgængelighed, TCO osv

5. Ingeniør- Brug ABACUS at besvare forskellige "hvad nu hvis" scenarier og styre udviklingen af ​​din arkitektur. Engineering er processen med at gentage Befolke - analysere - Simuler cyklus.

· På dette tidspunkt, duveformentlig udviklet en forståelse af den aktuelle arkitektur og fremhævet de områder, du har brug for at udvikle sig. Ganske ofte, dog skal du gentage befolke - Analysere - Simuler proces et antal gange. Dette vil sandsynligvis være, fordi det kan tage et par iterationer, før du finder Target Architecture. Også, hvis din arkitektur er meget kompleks, kan du gentage processen for hvert arkitektonisk "niveau".

6. Planfremtiden for din arkitektur ved hjælp af oplysninger fra ABACUS.

Note

Hvis du ikke prøver at udvikle en eksisterende arkitektur, skal du muligvis til at gentage nogle trin et antal gange, og i en anden rækkefølge. Det afhænger af, hvad du forsøger do. For eksempel, hvis du designer en ny arkitektur, vil du sandsynligvis kun udfylde din arkitektur én gang, og derefter bruge ABACUS over en lang periode af tid til at vejlede den fremtidige udvikling (e) af arkitekturen. På den anden side, hvis du køber en ny arkitektur og har flere alternativer at vælge imellem, skal du Oplev og fylde for hver af alternativerne, og derefter Analysere og simulere hver enkelt uafhængigt, før du udfører en endelig sammenligning på ende.

Se også

Hvad gør ABACUS gøre? | Hvad er arkitektur? | Hvordan er en arkitektur repræsenteret i ABACUS? | Befolker din arkitektur | Analyse din arkitektur | Simulering din arkitektur


Hvad er arkitektur?

Navigation: Introduktion til ABACUS>

Hvad er arkitektur?

Send kommentarer om dette emne.

Arkitektur er en abstrakt begreb- Ikke en fysisk ting. Det er en rig og omfattende beskrivelse eller forståelse af strukturen af ​​et system - opfange komponenterne og hvordan de er tilsluttet (interagere). Fordi begrebet arkitektur er så altomfattende, det er grundlæggende for omkostninger, tilgængelighed, udviklingsevne, åbenhed og systemets ydeevne. En sund arkitektur er en forudsætning for et lydsystem.

I ABACUS, du modellere din arkitektur. For enkelhedens skyld kalder vi denne arkitektoniske model en arkitektur.

Nedenstående diagram viser en typisk arkitektur 5komponenter (i et hierarki) forbundet med 2 forbindelser. Etiketterne angive navn på grund af de forskellige dele af arkitekturen i ABACUS.

En simpel arkitektur

ABACUS anser alle disse ting for at være en del af arkitekturen:

· Komponenterrepræsenterer enheder i din arkitektur som du kunne beskrive som "ting". For et forsikringsselskab, kan komponenterne blive systemerne til behandling af politikker, krav, betalinger og kvitteringer.

· Tilslutningerrepræsenterer forholdet mellem disse komponenter. For eksempel i et forsikringsselskab, der er kvitteringer genereret for gyldige politikker, det hævdes mod gyldige politikker, og gyldige krav resultere i betalinger. Når du tænker arkitektonisk - især når du bruger ABACUS - samlinger er lige så vigtige som komponenter, og de behandles i en næsten identisk måde.

· Alt i træet kan have Egenskaber. Egenskaber er ting som den måde, du har brug for dit system til at udføre, at antallet af linjer kode har det, hvor stor en procentdel af disse linjer, der er kommentarer, osv ABACUS anser alle disse ting for at være en del af arkitekturen.

· Ved hjælp af hierarkier(dvs. delkomponenter og sub-tilslutninger), Kan du skjule information og de-komponere din arkitektur. Abacus arkitektoniske model er yderst fleksibel. Enhver komponent på ethvert niveau kan relateres til nogen anden komponent på noget andet niveau ved nogen forbindelse på ethvert niveau.

· Attachmenter den proces, hvorved komponenter porte er bundet til tilslutningroller. Havne og Roller er grænsefladensmellem komponenter og forbindelser. De anvendes til at fastgøre forbindelser til komponenterne. Forbindelser har en kilde og en håndvask rolle(lette datastrømmen fra kilden komponent til vasken komponent)og konceptuelt, komponenter har porte. For enkelhed, men i ABACUS komponent porte er ikke vist og forbindelsen rollerne er direkte knyttet til de komponenter, selv.

· Komponenter og tilslutninger er af en vis Type. Dette er primært med henblik på klassificering. For eksempel politikker, krav, betalinger og kvitteringer er komponenter af typen 'System'. De gyldige politikker, gyldige krav, etc. er forbindelser af typen »transaktion«. Type tildelt til en komponent eller tilslutning giver en skabelon for ejendommene og normer, den har. For eksempel kan en Server-komponent type har 'Make & model' standardog en IP-adresse egenskab. I modsætning til andre stive værktøjer med en grundlæggende relationel database (RDB) back-end, i ABACUS kan du frit oprette dine egne nye typer og tildele dine egne kombinationer af egenskaber og standarder til dem.

· Standard biblioteker af ejendomme kan specificeres og tildeles til noget andet i arkitekturen. Disse biblioteker er kendt som Standarder. Ved hjælp af Standarder, Behøver du kun at samle specifikke systemer egenskaber - standard egenskaber er der allerede. For eksempel kan tildeles standard ydeevne Microsoft Windows 2000 til, hvad komponenter bruger Microsoft Windows 2000-operativsystemet.

Se også

Hvordan er en arkitektur repræsenteret i ABACUS? | Hvad gør ABACUS gøre? | Hvordan du gør det (Oversigt) | Oprettelse af en ny type


Den ABACUS interfacet

Navigation: Introduktion til ABACUS>

Den ABACUS interfacet

Send kommentarer om dette emne.

Når du starter ABACUS, vil du se hovedskærmen, som er tom bortset fra menuer og værktøjslinjen øverst, et tomt Explorer-vindue og titlen-bar. Denne skærm vil være centrum for din interaktion med ABACUS.

De vigtigste elementer er:

· hovedmenuerne

· værktøjslinjerne

· højrekliksmenuen

· de explorer og ejendom vinduer

· statuslinjen

Hovedmenuerne

Menuerne er arrangeret i en logisk rækkefølge.

Menuerne er beskrevet som følger;

· Menuen Filer- Menuen Filer kan du oprette, åbne, lukke, gemme, eksportere og udgive ABACUS filer. Det giver også mulighed for at oprette, åbne, lukke og gemme ABACUS Bibliotek filer.

· Menuen Rediger- Menuen Rediger kan du klippe, kopiere, indsætte, slette, omdøbe, finde og sortere elementerog fortryde / redo operationer.

· Menuen Vis- Menuen Vis giver dig mulighed for at åbne eller lukke de forskellige grænseflade Windows og statuslinjeNavigere frem og tilbage, gå til bestemte synspunkter og administrere dashboards.

· Menuen Indsæt- Indsæt menu giver dig mulighed for at tilføje nye standarder, Skabeloner, typer, elementer, visningpunkts, Kataloger, diagrammer, diagrammer, Rapporter og matricer.

· Analyse menuen- Analyse menu giver dig mulighed for at køre evalueringer mod en arkitektur, herunder; ydeevne, omkostninger, pålidelighed, modularitet og åbenhed.

· Menuen- Menuen Værktøjer giver dig mulighed for at køre scripting, opstillede mål for arkitekturenog udfører og arkitektur 'diff'. Du kan også ændre programmets indstillinger og tilpasse grænsefladen fra værktøjet menuen.

· Vindue menuen- Vindue menuen kan du docke, arrangere, vise og skjule de vinduer, du har åbne.

· Hjælp-menuen- Fra menuen Hjælp kan du få adgang til denne ABACUS hjælpefil. Du kan få adgang til webstedet, se din licens aftale og se generelle oplysninger om ABACUS, herunder den version af softwaren og ABACUS support og kontaktoplysninger. Du kan give feedback via spørgsmålet anmeldelsen siden. Hvis det er nødvendigt, kan du indtaste en registrering nøglen via menuen Hjælp.

Dette er den rækkefølge, du vil typisk følge, når du udfører dine opgaver;Når du har oprettet eller åbnet en filVil du normalt udfylde din arkitektur, så udsigtdet (i Stifinder, diagrammer, 3D, diagrammer, osv). På dette tidspunkt, vil du enten køre en evaluator, Eller du vil gentage processen med den samme arkitektur eller en anden arkitektur. (Se Sådan bruger du ABACUS (Oversigt) for yderligere oplysninger.)

Tag et kig gennem hovedmenuerne og prøv at forestille dig, hvordan du vil anvende dem til dit system.

Note

Du kan Tilpas dine menuer når som helst.

Værktøjslinjerne

Som standard er der følgende værktøjslinjer;

· Main værktøjslinje -

· de Simulation værktøjslinje -

· View værktøjslinjen -

· de Diagram værktøjbar (hvis en diagram er åben) -

· Makro Indspilning værktøjslinje -

Tag et kig gennem knapperne på hver værktøjslinje ved at svæve over dem for at se værktøjet-tip (genvej-tasten).

Note

Kun bestemte knapper vil være aktive, afhængigt af hvad du har valgt i Explorer-vindue, og du kan Tilpas dine værktøjslinjer når som helst.Derudover 'Godkend / Check Projekt Begrænsninger' knappen på hovedværktøjslinjen, og knapperne på Simulering værktøjslinjen vil fremhæve Rød når en ændring til den underliggende lageret kræver en re-validering af projektet eller en re-simulering af denne simulator hhv. Hold markøren over knappen for at se, hvilke arkitekturer er berørt.

Den højre-klik menuen

De vigtigste menuer og værktøjslinjer er ikkebruges til alt, selv om. Det er ofte mere bekvemt at bruge højreklik kontekstmenuen for forskellige operationer. (Også ikke alle de kommandoer tilgængelige via højreklik er tilgængelige via de vigtigste menuer, værktøjslinjer eller tastaturkommandoer.)

For eksempel, når du har oprettet en fil, og du har et træ diagram af din arkitektur, er det bedre at højreklikke på Arkitekturer i træet for at tilføje en ny arkitektur. Tilsvarende bør du højreklikker på komponenter for at tilføje en ny komponent. Højreklik på et par ting i træet for at se, hvad du kan gøre.

Tip

Generelt, vil du bruge hovedmenuerne til at udføre de mere højt niveau opgaver, ligesom evaluere din arkitektur. Opgaverne lavt niveau - ligesom at tilføje enkelte komponenter og forbindelser - er færdig med at bruge værktøjslinjerne og / eller højreklik-menuen.

EXPLORER og egenskaber vinduer

Når du åbner eller opretter en fil, vil et træ diagram vises i Stifinder-vinduet. Det er et vindue ind i din arkitektur. Og som du vælger elementer i Explorer-vindue tre andre vinduer; Generelle egenskaber, Referencerog Ejendomsstyrelsen vinduer vil opdatere til afspejle detaljerede oplysninger om dit valg.

Note

De almindelige Egenskaber, Referencerog Ejendomsstyrelsen vinduer er som standard skjult. Se Tilpasning af grænsefladen for hvor du får vist skjulte dem og potentielt efterlade dem permanent vises.

Mens du bygger din arkitektur, de Explorer og egenskaber vinduer er de mest nyttige repræsentation. Fordi de kan klappes sammen og udvides efter behov, og de ikke blevet for besværlig.

Explorer vindue har en træ (og status bar) og vinduerne egenskaber er 5sektioner:

· Type

· Standarder

· Beskrivelse

· Referencer

· Egenskaber

ABACUS anser alle disse ting for at være en del af arkitekturen.

Træ

Dette afsnit har et træ inddelt i 3 områder som følger:

1. Meta-model

· Standarder- Hvis mange komponenter har det samme sæt af egenskaber, kan du definere det sæt up-front, og så bare tildele den til komponenterne. Det samme gælder for forbindelser og nogen af ​​de andre elementer. Disse sæt af standard egenskaber lagres i Standardergren af ​​træet. I stedet for at definere hver ejendom for hver komponent og hver ejendom for hver tilslutning osv, bare tildele en standard. For eksempel faste karakteristika Unix-HP / UXkan gemmes som en Standard og tilskrives nogle komponenter, der bruger Unix-HP / UXoperativsystem som vist for OS01 server i screenshot over.

· Typer - Denne gren af ​​træet er et bibliotek med de typer af komponenter og forbindelser, du kan bruge. Typer bruges til at definere den meta-model til din arkitektur og til klassificering og filtrering, når du ser din arkitektur. De også fastlægge en skabelon for det standarder, Egenskaber og begrænsninger dine komponenter / tilslutninger kan have.

· Synspunkter- Udsigtpunkts kan oprettes fra eksisterende diagrammer og kan bruges til at skabe nye diagrammer.De er diagram stencils.

· Skabeloner - Skabeloner butik re-brugbar mønstre af komponenter og forbindelser sammen med den måde, som de er repræsenteret eller ses. De kan opfattes som "mini" arkitekturer eller løsninger, der kan placeres i eksisterende arkitekturer.

2. Arkitekturer -De arkitekturer filial af træet er, hvor du bygge arkitektur (r) i dit system. (Dette kaldes at befolke arkitekturen.) Du kan have et vilkårligt antal arkitekturer i en enkelt ABACUS fil.

3. Dashboards - Den Dashboards gren af ​​træet er, hvor du kan få adgang til alle gemte dashboards for projektet.

Note

Elementer i Explorer træ, der har haft deres Opdatering tilladelse fjernes (dvs. de er skrivebeskyttede) er vist i gråt.

Type

Dette afsnit angiver den specifikke komponent eller tilslutning type den aktuelt valgte element i træet.

Standarder

Dette afsnit indeholder en liste over de standarder for den aktuelt valgte element i træet.

Beskrivelse

Dette afsnit indeholder en kort beskrivelse af det valgte element i træet. Eventuelle relaterede hyperlinks kan også føjes til dette afsnit. Disse omfatter hjemmesider eller lokale absolutte stier peger på yderligere information om det givne element. Flere linjer er også tilladt. Gyldige hyperlinks nødt til at starte med en af ​​5 strenge; http: //, https: //, ftp: //, file: /// eller mailto :.

Tip

For hyperlinks med mellemrum, kan brugerne skrive i den URL eller sti, skal du vælge den ønskede tekst og Højreklik| Hyperlink. Dette vil ændre eventuelle mellemrum til 20%så hele URL eller sti vil fungere korrekt.

Skabt og Modified

Disse afsnitsgivebrugeren og dato / tid for at skabe, og sidste ændring, det aktuelt valgte element i træet.

Referencer

Dette afsnit indeholder en liste over de udgående og indgående komponenter for den aktuelt valgte element i træet.Det viser også de diagrammer, 3D og kortvisninger, at det aktuelt valgte element vises i. Hvis der vælges et diagram viser det Viewpoint hvis relevant for diagrammet og synspunkter i almindelighed det viser nogen Dashboards visningen vises i. Og når en standard er valgt i træet viser brugen af ​​den standard, typer, komponenter og forbindelser.

Egenskaber

Dette afsnit er, hvor du definere egenskaberne ved elementerne i din arkitektur, ligesom den måde, du har brug for det at udføre, at antallet af linjer kode har det, hvor stor en procentdel af disse linjer, der er kommentarer, etc.

De "input" og "output" egenskaber af den præ-bygget simulatorer vises i vinduet med en ejendom input rækken vælger ikon Properties ( [image] ) Og output ikon ( [image] ) Henholdsvis med et værktøjstip indikerer hvilke præ-bygget simulator ejendommen er relateret til, f.eks "Modularitet Output" eller "Ydeevne Input". Pilen på output ikoner vil fremhæve Rød ( [image] ), Når ejendommen er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet med simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Statuslinjen

Den venstre del af statuslinjen viser den fulde sti til den aktuelt i fokus repository element, enten valgt i Stifinder-vinduet eller på diagram lærred. Dette er så det nøjagtige sted i lageret hierarki for den givne element altid kan let bestemmes. Den højre del af statuslinjen viser forskellige operationelle meddelelser som 'Åbn ABACUS fil Vellykket "og" Cost Beregning Afsluttet ".

Se også

Hvordan du gør det (Oversigt) | Tilpasning af grænsefladen | Hvad er arkitektur? | Hvordan er en arkitektur repræsenteret i ABACUS? | Arbejde med ABACUS filer


Tilpasning af ABACUS grænsefladen

Navigation: Introduktion til ABACUS>

Tilpasning af ABACUS grænsefladen

Send kommentarer om dette emne.

Du kan ændre udseende og opførsel ABACUS interfacet på mange måder. ABACUS indeholder flere kombinationer foruddefinerede indstillinger, som du kan bruge til at anvende en gruppe af tilpasninger til grænsefladen. Derudover kan du foretage individuelle tilpasninger til elementer såsom vinduer, værktøjslinjer, genvejstaster og forskellige displays muligheder.

Arranger og Dock Windows

Du har mange muligheder for at arrangere vinduer i interface til ABACUS, herunder følgende:

· Tab-dock vinduer.

· Dock vinduer til kanten af ​​en ramme i interfacet.

· Minimer værktøj vinduer langs kanten af ​​grænsefladen.

· Nulstil vindue placering til standard layout.

Docking Vinduer

Når et vindue er dockable, kan det fastgøres til den ene side af en ramme inden grænsefladen eller det kan være anbragt på faner ruder i rammen. En guide diamant vises, når du trækker vinduer fra deres nuværende placering til en anden placering i interfacet. Guiden diamant kan du hurtigt re-dock et vindue på en af ​​de fire sider af rammen eller i midten som en tabbed rude. Når et vindue er dokket eller ej dockes, det flyder oven på de andre vinduer.

Til dock vinduer

1. Klik på det vindue, du vil forankre, for at give det fokus.

2. På den Vinduemenuen, klik Dockes.

3. Træk vinduet fra dets nuværende placering mod midten af ​​rammen, du ønsker at forankre det med.

En guide diamant vises. De fire pile diamant point mod fire kanter af rammen og midten repræsenterer ruden faneblade.

Tip

Hvis du vil flytte en dockes vindue uden snapper den på plads, skal du trykke på CTRL, mens du trækker den.

4. Når vinduet du trækker når den position, hvor du ønsker at forankre det, flytte markøren hen over den tilsvarende del af guiden diamant. En skitse af vinduet vises i det udpegede område.

5. For at dokke vinduet i angivne position, slip museknappen.

For eksempel, hvis Explorerer forankret på den venstre kant af grænsefladen og du ønsker at forankre det på den højre kant, vil du trækker Explorermod midten af ​​grænsefladen, flytte markøren over i højre side af guiden diamant, og derefter slippe museknappen.

Minimering Windows

Windows (uanset om de er Windows Værktøj - vises på Udsigtmenu eller Dokument Windows - optræder på Vinduemenu) støtte en funktion, der hedder Auto Hide. Auto Hide kan du se mere af din arkitektur på én gang ved at minimere vinduer langs kanterne af grænsefladen, når den ikke er i brug.

Hvis du vil slå Auto-Hide

1. Klik på det vindue, du ønsker at skjule at give det fokus.

2. På den Vinduemenuen, klik Auto Skjul.

- eller -

2. Klik på ikonet Kortnål på titellinjen i vinduet.

Auto Skjul Aktiveret

Når en auto-skjult vindue mister fokus, den automatisk glider tilbage til sin fane på kanten af ​​grænsefladen. Mens et vindue er auto-skjult, dens navn og ikon er synlige på en fane på kanten af ​​interfacet. For at vise en auto-skjult vindue, flytte markøren hen over fanen. Vinduet glider tilbage i udsigt og er klar til brug.

Note

Et vindue, der er auto-gemt, kan ikke forankret. For at dokke et vindue skal du slukke Auto Hide som beskrevet nedenfor.

Hvis du vil deaktivere Auto Skjul

1. Klik på det vindue, du vil beholde synlig for at give det fokus.

2. På den Vinduemenuen, klik Auto Skjulat fjerne markeringen.

- eller -

2. Klik på ikonet Kortnål på titellinjen i vinduet.

Auto Skjul Deaktiveret

Tip

Vinduer, der har Auto Hide aktiveret midlertidigt glide ind visning når vinduet har fokus. For at skjule vinduet igen, vælge et emne uden for det aktuelle vindue. Når vinduet mister fokus, den glider tilbage ud af betragtning.

Nulstilling Windows Layouts

Du kan vende tilbage grænsefladen til standard-vinduet layout ved hjælp af Nulstil Vindue Layout kommando. Når du kører denne kommando, opstår følgende handlinger:

· Alle vinduer er flyttet til deres standardindstillinger positioner.

· Vinduer, der er lukket i standard-vinduet layout er lukket af kommandoen.

· Vinduer, der er åbne i standard-vinduet layout åbnes af kommandoen.

· Vinduer, der er skjult / synlig i standard-vinduet layout er lavet skjulte / synlige ved kommandoen.

For at nulstille vindue placering til standard layout

1. På den Vinduermenuen, klik Nulstil Vindue Layout.

Tilpasning Menuer og værktøjslinjer

Du kan ændre layout, placering, og indholdet af menuer og værktøjslinjer i grænsefladen. Du kan også tilføje knapper til værktøjslinjer og ændre den tildelte ikon for enhver knap.

Opret nye værktøjslinjer

Hvis du vil oprette en ny værktøjslinje

1. På den Værktøjmenuen, vælg Tilpas.

2. I Tilpasdialogboksen, skal du vælge Værktøjslinjerfane.

3. Vælge Ny.

4. I Ny Værktøjslinjedialogboksen, skal du skrive et navn til værktøjslinjen.

5. Vælge Okay.

For at tilføje en kommandoknap til en menu eller værktøjslinje

1. På den Værktøjmenuen, vælg Tilpas.

2. I Tilpasdialogboksen, skal du vælge Kommandoerfane.

3. Vælg en kategori, og træk en kommando ud af dialogboksen til menuen eller værktøjslinjen.

4. Vælge Tæt.

Tip

Holde Alt-tasten kan du hurtigt tilpasse kommandoer, som om dialogen Tilpas var åben.

Se også

Den ABACUS interfacet


Arbejde med ABACUS filer

Navigation: Introduktion til ABACUS>

Arbejde med ABACUS filer

Send kommentarer om dette emne.

En abacus-fil er en beholder til en model af din arkitektur . Inden for en enkelt ABACUS fil, kan du modellere et vilkårligt antal arkitekturer vilkårligt antal gange.

Når du første gang åbner ABACUS, er der ingen filer åbne. At arbejde på din arkitektur, skal du enten oprette en ny fil eller åbne en eksisterende fil.

Når du åbner eller opretter en ny fil, vil et træ i explorer vinduet automatisk vise. Denne opdagelsesrejsende visning viser dig dit arkitektur til dato. Når du lukker filen, vil træet i explorer vinduet også forsvinde.

Hvis du vil oprette en ny ABACUS fil

1. Vælge Fil| Ny ...

2. I Nyt projekt dialogboks, der vises (som vist nedenfor) Vælgeenten oprette en tom, en model fra en standard ABACUS biblioteket , En model fra en brugerdefineret ABACUS bibliotek, en model fra XML, MS Access , MS Visio , MS Excel , MS SQL Server En Enterprise Server model eller en brugerdefineret ABACUS bibliotek (.abacuslib fil).

3. Klik på Okayknap og følge eventuelle dialogbokse, der kan vises.

Tip

Du vil ikke blive bedt om at navngive den fil, indtil du gemmer eller lukker den. Det er en god ide at gemme filen, så snart du opretter den. Så vil du ikke at bekymre dig om at navngive det senere i processen, når du koncentrerer sig om andre komplekse ting (som at udfylde din arkitektur).

Opret et nyt projekt

ABACUS Standard Biblioteker

ABACUS understøtter løbet 100 offentlige rammer og notationer hvoraf nogle er vist nedenfor. Når du vælger at oprette et nyt projekt fra en standard biblioteksbrugere have en hurtig start på modellering inden for en etablere rammer, drage fuld fordel af alle definerede elementtyper, attributter, notationer, synspunkter og skabeloner eller mønstre. Yderligere standard biblioteker er frit tilgængelige via skønnede udvikling Fællesskab her .

Nyt projekt fra Standard Library

Hvis du vil gemme en ny ABACUS fil

1. Vælge Fil| Gem som

Tip

Filnavne kan være hvilken som helst længde, og kan indeholde alle alfanumeriske tegn og mellemrum. De kan ikke indeholde tilde (~) karakter, røret (|) karakter, spørgsmålstegnet, eller de tegn, der normalt anvendes til sti beskrivelser såsom omvendt skråstreg (\) - undtagen som del af stien (?).

For at åbne en eksisterende ABACUS fil

1. Vælge Fil| Åben

Note

Hvis du åbner en fil fra en delt netværksplacering, der allerede er åben for en anden bruger, vil ABACUS give dig Læs Kun adgang. Ved brug af ABACUS med Læs Kun adgang, vil du ikke være i stand til at udføre skrive operationer, såsom befolke din arkitektur og kører evaluatorer. Du kan dog, se din arkitektur ved hjælp af explorer visning og 3D-visninger.

Se også

Hvordan er en arkitektur repræsenteret i ABACUS?


Hvordan er en arkitektur repræsenteret i ABACUS?

Navigation: Introduktion til ABACUS>

Hvordan er en arkitektur repræsenteret i ABACUS?

Send kommentarer om dette emne.

I ABACUS, du modellere din arkitektur. For enkelhedens skyld kalder vi denne arkitektoniske model en arkitektur.

Nedenstående diagram viser, hvordan en typisk arkitektur 5komponenter (i et hierarki) forbundet med 2 forbindelser ville blive repræsenteret i ABACUS.

Hvordan en simpel arkitektur er repræsenteret i ABACUS

Du kan have et vilkårligt antal arkitekturer i en enkelt ABACUS fil.

Den første arkitektur i træet

Typisk vil du oprette en ny arkitektur, når du ønsker at evaluere en ændring. For eksempel, ville du modellere din eksisterende arkitektur først - det ville være den første arkitektur i træet. Du kan kalde det "Current".

Sekundet

Når du ønsker at modellere og evaluere en ændring af din eksisterende arkitektur (f.eks øgede krav) du ville oprette en ny arkitektur. Den nemmeste måde at gøre dette ville være at skabe en kopi af 'Current "og omdøbe den" Evolution 1 Forsøg 1'. Dette ville være den anden arkitektur i træet. Hvis dine evalueringer af 'Evolution 1 Forsøg 1' har succes, kan du omdøbe den til blot 'Evolution 1'.

Den tredje

Hvis 'Evolution 1 Forsøg 1' ikke opfylder dine krav, kan du oprette en kopi af den, omdøbe den til 'Evolution 1 Forsøg 2', og prøv igen. Dette ville være den tredje arkitektur i træet.

Se også

Hvad gør ABACUS gøre? | Hvordan du gør det (Oversigt) | Hvad er arkitektur? | Arbejde med ABACUS filer | Oprettelse eller duplikere en arkitektur


Hjælp på andre sprog

Navigation: Introduktion til ABACUS>

Hjælp på andre sprog

Send kommentarer om dette emne.

ABACUS hjælp er tilgængelig i forskellige andre sprog / oversættelser og kan downloades fra nedenstående links.

Til erstatte den nuværende ABACUS hjælpefilenmed en oversat hjælpefil du følge disse trin:

1. Gem hjælpefilen fra den relevante link nedenfor.

2. Omdøb hjælpefilen til ABACUS.chm.

3. Åbn filen ved at dobbeltklikke på det, og hvis en "Åbn fil - Advarsel Sikkerhed 'dialogboks vises derefter fjerne markeringen i" Spørg altid, før du åbner filen "valgmulighed, og klik på Åbn.

4. Luk filen.

5. Udskift ABACUS.chm fil i mappen Programmer på ABACUS, typisk "C: \ Program Files \ skønnede udvikling \ ABACUS" eller "C: \ Program Files(x86)\ Skønnede udvikling \ ABACUS".

Note

Kontekstafhængig hjælp vil fortsætte med at arbejde med de oversatte hjælpefiler.

ABACUS hjælpefiler på andre sprog:

· Arabisk / العربية .

· Bulgarsk / български .

· Kinesisk (forenklet) / 中文 (简体) .

· Tjekkisk / Česká .

· Danske / Dansk .

· Estonian / Eesti .

· Finsk / Suomen .

· fransk / Français .

· tysk / Deutsch .

· Ungarsk / Magyar .

· Islandsk / Islandsk .

· Indonesisk / Indonesien .

· Italiensk / Italiano .

· Japansk / 日本 の .

· Lettisk / Latvijas .

· Malaysisk / Malaysia .

· Maltesisk / Malt i .

· Norsk / Norsk .

· Polere / Po lska .

· Portugisisk / Português .

· Russisk / русский .

· Slovakisk / Slovenski .

· Slovensk / Slovenski .

· Spansk / Españoles .

· Svensk / Svenska .

· Tyrkisk / Türk .

· Walisisk / Cymraeg .

Se også

Hvad gør ABACUS gøre?


Befolker din arkitektur

Navigation: Befolke din arkitektur>

Befolker din arkitektur

Send kommentarer om dette emne.

Færd med at opbygge en model af din arkitektur er kendt som befolker. Når du har opdaget din arkitektur og identificeret dine krav, er du klar til at modellere din arkitektur i ABACUS.

Under befolkning, vil du indtaste alle de oplysninger, du kender din arkitektur og hvad der kræves af det.

At udfylde din arkitektur

1. Sikre, at du har en ABACUS fil åben En viste opdagelsesrejsende Og en arkitektur tilføjet .

2. Manuelt befolker komponenter de højere niveau og tilslutninger af din arkitektur. Typisk vil dette være de mere abstrakte komponenter og forbindelser.

- eller -

2. Grafisk befolker komponenter og forbindelser, som du gerne vil se repræsenteret skematisk, ved hjælp af Tegneværktøj .

Du kan også vælge at

3. Befolke bruge Kataloger - Du kan få vist og komponenter, og forbindelser på en enkel måde. tabelform

4. Befolke bruge Matricer - Du kan få vist og redigere tilslutninger mellem komponenterne i en enkel tabelform måde.

5. Befolker fra Microsoft Access - Du kan importere en arkitektur fra og eksportere til Microsoft Access.

6. Befolker fra Microsoft Visio - Du kan importere en arkitektur fra og eksportere til Microsoft Visio.

7. Befolker fra Microsoft Excel - Du kan importere en arkitektur fra og eksportere til Microsoft Excel.

8. Befolker fra Microsoft SharePoint - Du kan importere en arkitektur fra og eksportere til Microsoft SQL Server.

9. Befolker fra Microsoft SQL Server - Du kan importere en arkitektur fra Microsoft SQL Server.

10. Importer fra XML - Du kan importere en arkitektur fra en ABACUS XML fragment eller en ArchiMate Interchange Sprog XML-fil.

Se også

Befolker din arkitektur manuelt | The Drawing Tool | Befolker din arkitektur fra Microsoft Access | Befolker din arkitektur fra Microsoft Visio | Befolker din arkitektur fra Microsoft Excel


Befolker din arkitektur manuelt

Navigation: Befolke din arkitektur> Befolke manuelt>

Befolker din arkitektur manuelt

Send kommentarer om dette emne.

De komponenter og tilslutninger af din arkitektur højere niveau vil sandsynligvis nødt til at være befolket manuelt. Typisk vil dette være de mere abstrakte komponenter og forbindelser.

Hvis du manuelt udfylde din arkitektur

1. Sikre, at du har en ABACUS filåben, en opdagelsesrejsendevises, og en arkitektur tilføjet .

2. Tilføj en komponent. At gøre dette, Højreklikpå det område af træet du ønsker at udfylde, og vælg Tilføj delkomponent ..., Eller klik på New Componentknappen på Vis værktøjslinje . Komponenter kan kun tilføjes under Komponenter gren af ​​træet. Du ønsker dit træ diagram for at være en nøjagtig gengivelse af din arkitektur. Når du opdagede din arkitektur, vil du have lært præcis, hvordan det hele passer sammen. Du skal bruge denne viden, når du tilføjer dine komponenter og forbindelser. Hvis du tilføjer dit første komponent, vil du tilføje den direkte til filialen Komponenter. Resten af ​​dine komponenter kan enten være på samme niveau i træet, eller de kan være sub-komponenter i den første.

3. Opdater værdierne afegenskaberneaf hver komponent, som du tilføje den. At gøre dette, klikpå komponenten, og redigere egenskaberne vises i Vinduet Egenskaber(typisk) til højre. Egenskaber er generelt ting som krav, forarbejdning kapacitet etc. Når ABACUS evaluerer din arkitektur, vil det beregne nogle nye egenskaber, og gemme dem tilbage til arkitekturen. De nye egenskaber er de data, du forsøger at analysere, såsom udnyttelse, svartid, båndbredde etc.

4. Tilføj dine forbindelser og opdateringderes egenskabersom du går - ligesom du gør for komponenter (men under Connections gren af ​​træet).

5. Vedhæftforbindelser og komponenter. For at gøre dette, skal du finde forbindelsen, skal du klikke på et af dets ender eller roller , Og træk det på en komponent. Du kan også klikke på en komponent, og træk den hen på en af ​​forbindelsen er roller (dvs. enten Source eller Sink). Eller du kan højreklikke og trække en komponent på en anden komponent, og vælg Opret forbindelse til. Eller bare højreklikke på en komponent, og vælg Forbinde.... Når du trækker en forbindelse rolle, Vil du bemærke en genvej symbol, når du peger på en komponent, kan du vedhæfte det til. Dette indikerer, at du ikke laver en kopi, du bare sætter det. Sørg for at du lægger det til den korrekte destination komponent. For eksempel, hvis det er en forbindelse kilde rolleTrække det gøre kildekomponenten (dvs. den komponent, der er kilden til datastrømmen).

Tip

Re-bestilling enheder inden din arkitektur (f.eks Komponenter, Forbindelser osv) i opdagelsesrejsendeer ganske let. ganske enkelt Klik| Holde| Trækden relevante enhed og sted, hvor det ønskes i din arkitektur. Den fornyede bestilling funktionalitet giver dig også mulighed for at placere enheder inden for forskellige hierarkier af din arkitektur.

Du kan også vælge at

6. Tilføj Standarder (præ-konfigurerede sæt egenskaber - forudindstillinger) til dine komponenter, tilslutninger eller typer

7. Ændre egenskaberne af en komponent, tilslutning eller type

8. Fortryd og Annuller Fortryd operationer

9. Ændre type af en komponent eller tilslutning

10. Opret en ny type eller type Group

11. Slet en komponent eller tilslutning

12. Opret, duplikere eller udvikle sig en arkitektur

13. Importer typer og standarder fra et bibliotek

14.. Importer fra et andet ABACUS fil, XML, Excel eller Visio

15. Kopiere og indsætte dele (eller alle) af din arkitektur

16. Søg og erstat varer i din arkitektur

17. Skjul / Vis nogle af eller alle knudepunkterne i træet

18. Flet emner

19. Definere og Godkend Begrænsninger at begrænse opbygningen af ​​din arkitektur

20. Udvikl din arkitektur at oprette flere arkitektoniske løsninger at sammenligne og baseline

Se også

Befolker din arkitektur - Oversigt | Oprettelse af en ny fil


Fortryd og Annuller Fortryd

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Fortryd og Annuller Fortryd

Send kommentarer om dette emne.

Ligesom mange moderne applikationer, ABACUS understøtter evnen til både fortryde og omgøre de seneste brugergrupper ændringer til et åbent projekt. For at fortryde den seneste ændring, aktiveres blot kommandoen Fortryd. Ændringer, der er fortrudt, kan fortrydes ved at aktivere redo kommando; ny anvender den senest ugjort ændring.

Advarsel

Undone ændringer er ikke i stand til at genanvendes, hvis yderligere der foretages ændringer i projektet siden blive fortrydes.

Note

Mens størstedelen af ​​ændringer støtter fortryde / redo i realtid, nogle diagram stencil ændringer, såsom at skabe en ny type-Shape / linje forening eller ændre en farve attribut forening, er ikke i stand til at fortrydes samme. I disse tilfælde skal det modificerede Diagram (angivet med en stjerne) være lukket, før disse ændringer kan fortrydes.

Fortryd og Annuller Fortryd kommando steder

Fortryd og Annuller Fortryd kommandoer kan tilgås fra tre forskellige steder:

· menuen Rediger

· værktøjslinjen Standard

· tastaturets genvejstaster CTRL + Z(fortryd), og CTRL + Y(redo)

Tip

Den fortryd og redo knapper på standardværktøjslinjen giver dropdown lister viser de seneste 10 ændringer, som kan fortrydes, og har været redone hhv. De er også en praktisk måde at fortryde / redo flere ændringer på én gang.


Ændring af en komponent / tilslutning s type

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Ændring af en komponent / tilslutning s type

Send kommentarer om dette emne.

Komponent og forbindelsestyper anvendes hovedsageligt ved tariferingen. Du kan bruge typer som filtre, når du ser din arkitektur. For eksempel, i stedet for at se det hele, kan du få vist bare Application komponenter.

For at ændre en komponent / tilslutning s type

1. Højreklikpå komponenten eller forbindelsen.

2. Vælge Skift type.

3. Vælg en anden type på listen.

Tip

Når du ændrer type, kan du få nogle nye standardereller egenskaber (hvad der er forbundet med type - se Typer gren af ​​træet). Din eksisterende standarder og egenskaber forbliver uændret. Du kan oprette dine egne nye typer og tildele dine egne kombinationer af standarder og egenskaber til dem.

Se også

Oprettelse af en ny type | Befolker din arkitektur - Oversigt | Analyse din arkitektur


Oprettelse af en ny komponent / tilslutning type eller type Group

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Oprettelse af en ny komponent / tilslutning type eller type Group

Send kommentarer om dette emne.

Komponent og forbindelsestyper anvendes hovedsageligt ved tariferingen. Du kan bruge typer som filtre, når du ser din arkitektur. For eksempel, i stedet for at se det hele, kan du få vist bare Application komponenter.

Hvis du vil oprette en ny komponent / tilslutning Type

Note

For at tilføje typer eller type grupper i et ABACUS projekt brugerlicens brug Designeren tilføjelse formåen. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

1. Udvid Typergren af ​​træet.

2. Højreklik på Komponenttyper (eller Forbindelsestyper).

3. Vælge Tilføj Komponent Type (eller Tilføj Stiktype) eller Opret gruppe.

Tip

Når du har oprettet en type, skal du ændre dens ikon (se nedenfor), og tilføj ejendomme og standarder til det for den komponent eller forbindelsesproblemer forekomster at "arve".

For at ændre ikon for en komponent / tilslutning Type

Note

For at ændre ikonerne for typer i et ABACUS projekt brugerlicens brug Designeren tilføjelse formåen. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

1. Højreklik på den Komponent Type (eller Forbindelsestype), Du ønsker at ændre ikonet for.

2. Vælge Skift ikon.

3. I Vælg ikon dialogen gennemse til et sted og vælge en billedfil og klik på Åbn.

Note

Du kan have en brugerdefineret ikon billede af enhver størrelse, men det vil altid blive skaleret til at passe til en 16x16 pixel billede i Stifinder vinduet. Så hvis din originale brugerdefinerede ikon billede er ikke af samme højde og bredde din Explorer vindue ikon vil blive strakt. Derfor bør tilpassede billeder være mindst 16x16 pixels, og hvis du ønsker at beholde den præcise udformning af den brugerdefinerede ikon sørge for din brugerdefinerede ikon billede er lig højden og bredden i pixels (16x16 eller større). Du bør også være forsigtig med ikke at have farvede 'pixels' gå hele vejen til grænsen af ​​den brugerdefinerede ikon billedet som det vil se fattige i Explorer-vindue med tilstødende ikoner 'blødning' ind i hinanden. Derfor bør du lade mindst 1 pixel hvid kant.

Tip

Du kan lave din brugerdefinerede ikon billedet et Ico, .bmp, .gif, .jpg eller .png format fil, men på grund af en begrænsning i Windows kun Ico format vil se et eksempel i dialogboksen ABACUS Vælg ikon, hvis du har udsigt Menupunkt indstillet til noget andet end miniaturebilleder.

Se også

Befolker din arkitektur - Oversigt | Analyse din arkitektur


Sletning af en komponent eller tilslutning

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Sletning af en komponent eller tilslutning

Send kommentarer om dette emne.

Hvis du vil slette en komponent eller tilslutning

1. Højreklikpå komponenten eller forbindelsen.

2. Vælge Slet.

Forsigtighed

ABACUS vil advare dig, hvilke synspunkter vil blive berørt af sletning og beder dig om at bekræfte sletningen. Dette skyldes, at elementer kan eksistere på mange diagrammer og det betaler sig at kontrollere, hvad den foreslåede sletning vil påvirke.

Tip

Hvis du sletter en komponent, alle dens delkomponenter vil også blive slettet. Du kan vælge at slette de interne og eksterne forbindelser til komponenten. Hvis du vælger ikke at slette dem, de forbindelser, det er vedhæftet til vil forblive, men de vil ikke længere være knyttet. Alle komponenter og forbindelser er af en bestemt Type . Sletning af komponent / forbindelsen har ingen indvirkning på den type (i Typer gren af ​​træet). Tilsvarende, hvis komponenten / forbindelsen er Standard tildelt, vil sletning ikke have nogen indvirkning på master i filialen standarder.

Se også

Befolker din arkitektur - Oversigt


Oprettelse eller duplikere en arkitektur

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Oprettelse eller duplikere en arkitektur

Send kommentarer om dette emne.

Du kan have et vilkårligt antal arkitekturer i en enkelt ABACUS fil. Typisk ville du oprette en ny arkitektur, hver gang du ønsker at modellere og evaluere en videreudvikling af systemet.

Hvis du vil oprette en ny arkitektur

1. Højreklik på den Arkitekturergren af ​​træet.

2. Vælge Ny arkitektur.

Hvis du vil oprette en kopi af en eksisterende arkitektur

1. Højreklikpå arkitekturen.

2. Vælge Kopi.

3. Højreklik på den Arkitekturergren af ​​træet.

4. Vælge Sæt ind.

5. Den nye arkitektur vil blive kaldt »Kopi af ...«.

At udvikle en eksisterende arkitektur

1. Højreklikpå arkitekturen.

2. Vælge Evolve.

3. Den nye arkitektur vil blive kaldt »... .1«.

Note

Der er en detaljeret beskrivelse på skiftende arkitekturer her .

Se også

Hvordan er en arkitektur repræsenteret i ABACUS | Evolving din arkitektur


Importere ind i din Arkitektur

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Importere ind i din Arkitektur

Send kommentarer om dette emne.

ABACUS giver dig at importere til din arkitektur fra en .abacus (ABACUS fil), .xml (en ABACUS XML fragment eller en ArchiMate Interchange Sprog XML-fil), .vsd (Microsoft Visio) format, og .xls (Microsoft Excel) format. Dette giver dig mulighed for at opbygge din arkitektur fra eksterne kilder hurtigt.

Til importere din arkitektur fra.abacus (Abacus fil)

1. Sikre, at du har en ABACUS fil åben.

2. Højreklikpå Arkitektur node, enhver arkitektur i din model eller en del af komponenterne træet.

3. Vælge Importere| Fra Fil...fra menuen.

4. Vælg en placering og den .abacus fil og klik på Åben knap.

Note

Når du har valgt den fil, du vil importere, bliver du spurgt, hvordan du ønsker at importere de standarder,, typerog synspunkter. Du kan importere standarder, typer og synspunkter som enten nye eller fusionerede standarder, typerog synspunkter. Standardindstillingen er for standarder, typer og synspunkter at blive fusioneret med eksisterende standarder, typer og synspunkter hvis de allerede findes (med samme nøjagtige navn) i dit projekt.

Til importeredin arkitektur fra.xml (en ABACUS XML fragment eller en ArchiMate Interchange Sprog XML-fil)

1. Sikre, at du har en ABACUS fil åben.

2. Højreklikpå en arkitektur node, enhver arkitektur i din model eller en del af komponenten træet.

3. Vælge Importere| Fra XML ...fra menuen.

4. Vælg en placering og den .xml fil, og klik på Åben knap.

Note

ABACUS vil kun importere en korrekt dannet ABACUS XML fragment eller en ArchiMate Interchange Sprog XML-fil. Når du har valgt den XML-fil, du vil importere, bliver du spurgt, hvordan du ønsker at importere de standarder,, typerog synspunkter. Du kan importere standarder, typer og synspunkter som enten nye eller fusionerede standarder, typerog synspunkter. Standardindstillingen er for standarder, typer og synspunkter at blive fusioneret med eksisterende standarder, typer og synspunkter hvis de allerede findes (med samme nøjagtige navn) i dit projekt.

Til importeredin arkitektur fra.VSD(Visio fil) se her .

Til importeredin arkitektur fra.xls (Excel-fil) se her .


Import af typer og standarder fra et bibliotek

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Import af typer og standarder fra et bibliotek

Send kommentarer om dette emne.

Du kan importere typer og standarder fra en ABACUS bibliotek fil. Du kan også eksportere typer og standarder fra din ABACUS fil til en ABACUS bibliotek fil.

For at importere typer og standarder fra et bibliotek til din arkitektur

1. Sikre, at du har en ABACUS filåben og Explorer-vinduevises.

2. Vælg Filer | Åbenat åbne en ABACUS biblioteksfil.

3. Abacus Bibliotek åbner i et andet tabbed ark i Explorer-vindue, og du bliver nødt til at frigøre denne tabbed ark at kunne trække og slip fra til den oprindelige ABACUS fil.

4. Træk og sliptyper og standarder fra biblioteket ind i din arkitektur.

- eller -

1. Vælg Filer | Ny ...

2. Opret en ny ABACUS filbaseret på en ABACUS biblioteksfil.

Sådan eksporterer typer og standarder fra din arkitektur ind i et bibliotek

1. Sikre, at du har en ABACUS filåben, Explorer-vinduevises, en ABACUS biblioteksfilåben og Bibliotek vinduevises.

2. Træk og sliptyper og standarder fra din arkitektur ind i biblioteket.

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt


Kopiering og indsættelse

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Kopiering og indsættelse

Send kommentarer om dette emne.

Du kan kopiere en del af eller hele din arkitektur og indsætte det et andet sted i træet.

Hvis du vil kopiere

1. Højreklikpå det emne, du gerne vil kopiere.

2. Vælge Kopi.

For at indsætte

1. Naviger træet for at finde det sted, du gerne vil indsætte elementet.

2. Højreklikpå grenen, du ønsker det skal vises i.

3. Vælge Sæt ind.

4. Punktet vil blive kopieret med det oprindelige navn (medmindre du kopiere den til den oprindelige gren - så vil det blive kaldt »Kopi af ...«).

Se også

Hvordan er en arkitektur repræsenteret i ABACUS


Finde og erstatte elementer i din arkitektur

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Finde og erstatte elementer i din arkitektur

Send kommentarer om dette emne.

Du kan finde og erstat en bestemt komponent, tilslutning, type, standard eller ejendom ved hjælp af ABACUS 'Find og erstat facilitet.

For at finde et emne

1. Klik på node i træet, du vil søge i.

2. Vælge Redigere| Findeller tryk på Ctrl + F.

3. Indtast tekst til elementetat finde i 'Find hvad felt.

4. Klik Find næste.

Til erstatte et element

1. Klik på node i træet, du vil søge i.

2. Vælge Redigere| Erstatteeller tryk på Ctrl + H.

3. Indtast tekst tilelementetat finde i 'Find hvad felt og teksten til at erstatte det med i "Erstat med" feltet (eller noget, hvis feltet er tomt).

4. Klik Find næsteat finde den første forekomst af 'Find hvad tekst og klik Erstatte at erstatte denne forekomst med 'Erstat med' tekst eller klik Erstat alleat erstatte alle forekomster.

Du har muligheder for at:

o Match sin sag,

o Match hele ordet,

o Søg fra begyndelsen af ​​projektet,

o Ignorer arkitekturer - det er arkitekturen noder selv. Eventuelle knuder beneath arkitektur knudepunkter såsom komponenter og forbindelser vil stadig søges,

o Ignorere komponenter - der er den komponent knudepunkter selv,

o Ignorer forbindelser - det er forbindelsen noder selv,

o Ignorer standarder - det er alle arkitektur, tilslutning komponent- og standard knuder vil blive ignoreret,

o Ignorer typer - det er den type noder selv. Eventuelle constraint noder beneath af typen knuder vil stadig blive søgt,

o Ignorer skabeloner og indhold - det er skabelonen noder selv samt enhver skabelon komponent og tilslutning noder under dem,

o Ignorer egenskaber - det er alle de ejendom typer, navne, værdier og enheder af alle modellens elementer vil blive ignoreret,

o Ignorer beskrivelser - det er beskrivelserne af alle modellens elementer vil blive ignoreret.

Se også

Hvordan er en arkitektur repræsenteret i ABACUS


Udvidelse og kollapse træet

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Udvidelse og kollapse træet

Send kommentarer om dette emne.

Når en node i træet indeholder delkomponenter og samlinger, vil det have en lille [image] eller [image] underskrive på sit venstre. Du kan klikke på [image] at udvide node og se dens delkomponenter og forbindelser. På samme måde kan du klikke på [image] at kollapse noden for at skjule delkomponenter og forbindelser (for at gøre mere plads eller gøre træet lettere at forstå).

Alternativt kan du udvide en hel knude, i hvilket tilfælde alle dens sub-noder også vil blive udvidet, og deres sub-knuder, og deres ... osv Ligeledes kan du kollapse en hel knude - lukke flere niveauer på en gang .

Derudover er der muligheder for at udvide kun arkitekturer, elementer (dvs. komponenter og forbindelser), komponenter eller forbindelser.

Hvis du vil udvide eller skjule en hel knude (og dens sub-noder, etc.)

1. Højreklikpå knuden.

2. Vælge Udvid | Alle eller Bryder sammen.

At udvide alle en arkitektur (r)

1. Højreklikpå arkitekturer eller en arkitektur.

2. Vælge Udvid | Alle.

At udvide elementer

1. Højreklikpå arkitekturer eller en arkitektur.

2. Vælge Udvid | Elementer.

At udvide komponenter

1. Højreklikom komponenter, en komponent eller en sub-komponent.

2. Vælge Udvid | Komponenter | Alle.

At udvide forbindelserne

1. Højreklikpå forbindelser, en forbindelse eller en sub-forbindelse.

2. Vælge Udvid | Tilslutninger | Alle.


Fletning emner

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Fletning emner

Send kommentarer om dette emne.

Hvornår vil du flette elementer?

Du ville fusionere elementer, når du har to (eller flere) objekter i din model, der er bedst repræsenteret ved en enkelt forekomst. Der er mange situationer, hvor du måske ønsker at gøre dette, herunder:

· Som et resultat af at importere et nyt sæt oplysninger i din model, som kan overlappe eller afløse eksisterende oplysninger. For eksempel hvis du importerer en opdateret version af et regneark i din model.

· Over tid dubletter af den "samme" komponent er blevet oprettet, og du ønsker at rydde op i disse dubletter.

· Hvis du udfører en hvad-nu-hvis scenariet og de emner, du er modellering faktisk fusionere i virkeligheden. For eksempel, hvis du er sammenlægning to afdelinger i din organisation, eller hvis du fusionere to servere.

Hvad kan flettes?

Følgende typer af elementer understøtter at blive slået sammen:

· Standarder

· Komponent og Forbindelsestyper

· Komponenter og tilslutninger

Sådan flette emner

For at starte en sammenfletning, at bruge højre museknap, skal du trække et element i explorer på en anden. Det emne du trækker er kilden, og det element, du trækker på, er destinationen. Ved at slippe højre museknap vil du blive præsenteret med en menu, hvorfra du kan vælge at samle de to elementer. Du bliver nødt til at vælge, om du vil bevare eller overskrive destinationen. Dette er yderligere forklaret nedenfor.

Sammenfletningen højre træk menuen

Hvad er forskellen på at bevare og overskrive destinationen?

Den bevare eller overskrive indstillingen dikterer, hvad der sker, hvis navn, beskrivelse eller Egenskaber mellem kilden og destination poster kamp.

Hvis Bevar Destination er valgt

· Destinationens navn og beskrivelse vil blive holdt.

· Eventuelle Egenskaber, der kun eksisterer i kilden tilsættes til destinationen.

Hvis Overskriv Destination er valgt:

· Destinationen navn vil blive overskrevet fra kilden.

· Destinationen beskrivelse vil blive overskrevet fra kilden, medmindre kilden beskrivelse er tomt.

· Eventuelle Egenskaber, der kun eksisterer i kilden tilsættes til destinationen.

· Værdien og Enheden for eventuelle Egenskaber, der findes i både kilde og destination vil blive overskrevet fra kilden, medmindre kildens værdi eller Enhed er tomt.

Særlige tilfælde

· Typer: Når fletning typer, er tilladelserne lagt sammen, i et 'pessimistisk' måde, således at hvis tilladelsen på kilden ikke eksisterede på destinationen, vil det blive tilføjet, og hvis det fandtes i destinationen, så hvis den enkelte tilladelse til en brugergruppe (Opret, Læs, Update eller Delete) svarer ikke (én givet, den ene benægtede), så er tilladelsen ville blive nægtet.

· Komponenter: Når fletning komponenter, er sub-komponenter i den kilde, udvandrede til destinationen, og er fusioneret med delkomponenter i destination, hvis deres navne er identiske, Uanset deres type.Desuden vil flere delkomponenter i kilden med det samme navn kombineres i en enkelt delkomponent i destinationen.

· Tilslutninger: De øverste niveau tilslutninger selv skal begge have de samme vedhæftede filer (eller mangel på samme) for at få lov til at blive lagt sammen. Når sammenlægning forbindelser, er sub-forbindelser af den kilde, udvandrede til destinationen, og er fusioneret med sub-forbindelser i destination, hvis deres navne er identiske OGderes vedhæftede filer er identiske. Hvis vedhæftede filer ikke er identiske, vil kilden sub-tilslutninger føjes til destinationen uden at fusionere med matchende forbindelser allerede er til stede. Dette er så, at der ikke vedhæftede filer tabt.


Udformning og godkendelse Begrænsninger

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Udformning og godkendelse Begrænsninger

Send kommentarer om dette emne.

Strukturen og egenskaberne af en arkitektur kan begrænses ved hjælp af begrænsninger. Begrænsninger kan anvendes til komponenttyper og forbindelsestyper at begrænse opbygningen af ​​en arkitektur på to måder. Den første måde er at begrænse hierarkived at definere "forælder bør / skal have barn" og "barn skal / skal have forældre" relationer. Den anden måde er at begrænse topologived at definere "komponent bør / skal vedlægges forbindelse" og "tilslutning bør / skal vedlægges komponent" relationer. Desuden kan begrænsninger skal anvendes på de egenskaber komponenttyper, forbindelsestyper, skabeloner, synsvinkler, arkitekturer, diagrammerog 3D-visninger for at begrænse arkitekturen (r) i yderligere to måder. Den første måde er at sætte datatypeaf ejendommen for at begrænse de gyldige værdier, at det kan have, nemlig; Tekst, Heltal, Decimal, dato / tid, boolesk eller liste. Den anden måde er at sætte krævesstatus af ejendommen at indikere, om en værdi skal indtastes for ejendommen (Bemærk: Krævede begrænsninger gælder kun for ejendomme for komponent og forbindelsestyper). Yderligere oplysninger om ejendomsret begrænsninger findes i Ændring af egenskaberne af en komponent, tilslutning eller type Hjælp emne. Når der er defineret begrænsninger, er det muligt at validere en arkitektur mod de begrænsninger. ABACUS vil advare om eventuelle begrænsninger, der er blevet overtrådt.

Nøglen til at afgøre, hvilken begrænsning (s) til at definere ligger i den præcise sprog, der anvendes til at beskrive den begrænsning. For hierarki begrænsninger, de er typisk af formen "substantiverkan / bør / skal opdeles i n substantiver" eller "substantiverkan / bør / skal sammenlægges med substantiver"Etc. For eksempel"Afdelingerskal opdeles i Hold" eller "Applikationerkan opdeles i Moduler". For topologi begrænsninger, de er typisk af formen"substantiverkan / bør / skal udsagnsord substantiver". For eksempel, "Processer måske opført af Hold" eller "Applikationerer hosted på Servere. "Nu kan du se, i hvert begrænsning er der forskellige kan / bør / skal" qualifiers ", og disse kan være af 3 typer;

· Valgfri- Disse vil typisk bruge ord / sætninger som; "kan", "kan", "kunne", "eventuelt" osv

· Anbefalede- Disse vil typisk bruge ord / sætninger som; "bør", "anbefalet", "rådgivet" osv

· Obligatorisk- Disse vil typisk bruge ord / sætninger som; "must", "er", "er", "har", "skal" osv

Afhængigt af typen af ​​tvang (hierarki eller topologi) og kvalifikatorer anvendes til at beskrive det, bør specifikke begrænsning (s) defineres (se nedenfor). For ovenstående hierarki eksempel på "Afdelingerskal opdeles i Hold"Man skal definere en" Forældre skal have barn "tvang og indstil håndhævelse, der skal fuldbyrdes. For ovenstående topologi eksempel på"Processer måske opført af Hold. "Man skal kun skabe to (2)" Forbindelse skal vedlægges Component "begrænsninger for hver ende af udføres af forbindelsestype Konkret er følgende begrænsninger anbefales skal defineres (se nedenfor) for de forskellige muligheder;

· Hierarki begrænsninger;

o Navneord A måskeopdeles i Navneord B, eller Navneord B måskeaggregeret af Navneord A eller Navneord B burde væreaggregeret af Navneord A- Definer en "Child skal have Parent" begrænsning med barnet type som Noun B, forælder type som Substantiv A og håndhævelse som advaret.

Note

Det betyder, at hvis et barn, bør den have en forælder af en bestemt type. Hvis ikke, vil du få en advarsel.

o Navneord A burde væreopdeles i Navneord B- Definer en "Forældre skal have barn" begrænsning med den forælder type som Noun A, barn type som Navneord B og håndhævelse som advaret.

Note

Det betyder, at hvis en forælder, bør den have børn af en bestemt type. Hvis ikke, vil du få en advarsel.

o Navneord A må væreopdeles i Navneord B- Definer en "Forældre skal have barn" begrænsning med den forælder type som Noun A, barn type som Navneord B og håndhævelse som håndhæves.

Note

Det betyder, at hvis en forælder eksisterer, skal det have børn af en bestemt type. Hvis ikke du vil få en fejl.

o Navneord A må væreaggregeret af Navneord B- Definer en "Child skal have Parent" begrænsning med barnet type som Noun A, forælder type som Navneord B og håndhævelse som håndhæves.

Note

Det betyder, at hvis et barn eksisterer, skal det have en forælder af en bestemt type. Hvis ikke, vil du få en fejl.

· Topologi begrænsninger;

o Navneord A måske udsagnsord Navneord B- Definer to (2) "Forbindelse skal vedlægges Component" begrænsninger. Den første er med Source slutningen af ​​forbindelsestype udsagnsordknyttet til navneord En komponent type og håndhævelse sat til tvungen. Den anden væsen med Sink slutningen af ​​forbindelsestype udsagnsordknyttet til Navneord B komponenttypegodkendelse og håndhævelse sat til tvungen.

Note

Det betyder, at hvis forbindelsen eksisterer, skal den tilsluttes komponenter af bestemte typer. Hvis ikke du vil få en fejl. Samlet dette sikrer, at disse komponenter stadig kan eksistere og ikke være forbundet til hinanden. Men hvis de er forbundet, skal forbindelser af den rigtige type anvendes.

o Navneord A burde være udsagnsord Navneord B- Definer to (2) "Component skal vedlægges Connection" begrænsninger. Den første er med Noun en komponenttype knyttet til kilden ende af udsagnsordforbindelsestype og håndhævelse indstillet til advaret. Den anden væsen med Noun B komponenttypegodkendelse knyttet til Sink slutningen af udsagnsordforbindelsestype og håndhævelse indstillet til advaret. Derudover definerer to (2) "Forbindelse skal vedlægges Component" begrænsninger. Den første er med Source slutningen af ​​forbindelsestype udsagnsordknyttet til navneord En komponent type og håndhævelse sat til tvungen. Den anden væsen med Sink slutningen af ​​forbindelsestype udsagnsordknyttet til Navneord B komponenttypegodkendelse og håndhævelse sat til tvungen.

Note

Dette betyder, at hvis komponenter af begge typer findes, skal de fastgøres til en tilslutning af en bestemt type. Hvis ikke du vil få en advarsel. Desuden betyder det, at hvis forbindelsen findes, skal det tilsluttes komponenter af den angivne type. Hvis ikke du vil få en fejl. Samlet dette sikrer at hvis komponenter af disse typer findes, vil du få advarsler, hvis de ikke er forbundet til hinanden.

o Navneord A må være udsagnsord Navneord B- Definer to (2) "Component skal vedlægges Connection" begrænsninger. Den første er med Noun en komponenttype knyttet til kilden ende af udsagnsordforbindelsestype og håndhævelse sat til tvungen. Den anden væsen med Noun B komponenttypegodkendelse knyttet til Sink slutningen af udsagnsordforbindelsestype og håndhævelse sat til tvungen. Derudover definerer to (2) "Forbindelse skal vedlægges Component" begrænsninger. Den første er med Source slutningen af ​​forbindelsestype udsagnsordknyttet til navneord En komponent type og håndhævelse sat til tvungen. Den anden væsen med Sink slutningen af ​​forbindelsestype udsagnsordknyttet til Navneord B komponenttypegodkendelse og håndhævelse sat til tvungen.

Note

Dette betyder, at hvis komponenter af begge typer findes, skal de fastgøres til en forbindelse af en bestemt type. Hvis ikke du vil få en fejl. Desuden betyder det, at hvis forbindelsen findes, skal det tilsluttes komponenter af den angivne type. Hvis ikke du vil få en fejl. Samlet dette sikrer at hvis komponenter af disse typer findes, vil du få fejl, hvis de ikke er forbundet til hinanden.

For at definere en begrænsning

1. Sikre, at du har en ABACUS filåben og Explorer-vinduevises.

2. I explorer træet udvide Typer | Komponenttypereller udvide Typer | Forbindelsestyper.

3. Højrekliken komponent type eller en forbindelsestype, og vælg Tilføj Constraint.

Tilføjelse af en begrænsning

For at definere et hierarki begrænsning, hvor en forælder skal have en bestemt barn

4. På den Tilføj Constraintvindue kryds i Opret Constraintafkrydsningsfelt under Forælder skal have barn Constraint areal.

5. Vælg komponenttypegodkendelsesmærkefra drop-down boks, som du vil angive som barn af den komponent, der er valgt i trin 3 type.

Note

Hvis der allerede er en aktiveret 'Forældre skal have barn' begrænsning defineret for moderselskabet komponent type og et andet barn komponenttypegodkendelse så er denne nye begrænsning vil blive behandlet som en "OG". Det er den type skal være en forælder til barn type A ogbarn type B, til uanset håndhævelse plan (f.eks Handikappede, advarede eller fuldbyrdes - se trin 7) er angivet for hver tvang.

6. Valgfrit kan du definere antallet af komponenter i type- specificerede, der skal være børn af type- højre klikkede i trin 3 minimum og maksimum.

7. Vælg, om du vil have den begrænsning at være Handicappet, Advaret eller Håndhæves.

Note

Handicappede begrænsninger vil blive ignoreret fra tvang validering, vil advaret begrænsninger producere en advarsel i Validering vinduet hvis de opdages og håndhæves begrænsninger vil producere en Fejl i Validering vinduet, hvis de opdages. Desuden skal alle fejl løses, før en Enterprise Server Projektet kan blive begået.

8. Klik Okay.

Note

Den begrænsning vil blive vist i den opdagelsesrejsende træet under den type- højre klikkede i trin 3. Pilen angiver retningen af ​​tvang og i dette tilfælde vil pege ned og højre. Hængelåsen er farvet efter, om den begrænsning er deaktiveret (grå), advaret (gul) eller fuldbyrdes (rød).

Forælder skal have barn advaret begrænsning

For at definere et hierarki begrænsning, hvor et barn skal have en bestemt forælder

4. På den Tilføj Constraintvindue kryds i Opret Constraintafkrydsningsfelt under Barn skal have Parent Constraint areal.

5. Vælg komponenttypegodkendelsesmærkefra drop-down boks, som du vil angive som den forælder af type- højre klikkede i trin 3.

Note

Hvis der allerede er en aktiveret 'Child skal have Parent' begrænsning defineret for den type barn komponent og en anden forælder komponenttypegodkendelse så er denne nye begrænsning vil blive behandlet som en "eller". Det er den type skal være et barn af forældre type A ellerforælder type B, og håndhævelsen plan (f.eks advaret eller fuldbyrdes - se næste trin) bør være den samme ellers håndhæves begrænsninger vil altid tilsidesætte advaret dem.

6. Vælg, om du vil have den begrænsning at være Handicappet, Advaret eller Håndhæves.

Note

Handicappede begrænsninger vil blive ignoreret fra tvang validering, vil advaret begrænsninger producere en advarsel i Validering vinduet hvis de opdages og håndhæves begrænsninger vil producere en Fejl i Validering vinduet, hvis de opdages. Desuden skal alle fejl løses, før en Enterprise Server Projektet kan blive begået.

7. Klik Okay.

Note

Den begrænsning vil blive vist i den opdagelsesrejsende visningen under type- valgt i trin 5. Pilen angiver retningen af ​​tvang og i dette tilfælde vil pege op og til venstre. Hængelåsen er farvet efter, om den begrænsning er deaktiveret (grå), advaret (gul) eller fuldbyrdes (rød).

Barnet skal have forældre advaret begrænsning

For at definere en topologi begrænsning, hvor en komponent skal være knyttet til en bestemt forbindelse

4. På den Tilføj Constraintvindue kryds i Opret Constraintafkrydsningsfelt under Komponent skal vedlægges Constraint areal.

5. Vælg forbindelsestypefra drop-down boks, som du vil angive som vedlagte forbindelse af type- højre klikkede i trin 3. (Eller vælg komponenttypegodkendelsesmærkefra drop-down boks, som du vil angive som den vedhæftede komponent, hvis i trin 3 du højreklikker klikkede en forbindelsestype.)

Note

Hvis der allerede er en aktiveret "Component vedlægges« begrænsning defineret for den type komponent og en anden forbindelsestype så er denne nye begrænsning vil blive behandlet som en "OG". Det er den type- skal vedlægges tilslutning type A ogtilslutning type B, til uanset håndhævelse plan (f.eks Handikappede, advarede eller fuldbyrdes - se trin 7) er angivet for hver tvang.

6. Valgfrit kan du vælge en forbindelse rolleat du ønsker at føje til tvang. Svælger den specifikke rolle (dvs. enten Source eller Sink) fra drop-down boks.

7. Vælg, om du vil have den begrænsning at være Handicappet, Advaret eller Håndhæves.

Note

Handicappede begrænsninger vil blive ignoreret fra tvang validering, vil advaret begrænsninger producere en advarsel i Validering vinduet hvis de opdages og håndhæves begrænsninger vil producere en Fejl i Validering vinduet, hvis de opdages. Desuden skal alle fejl løses, før en Enterprise Server Projektet kan blive begået.

8. Klik Okay.

For at definere en topologi begrænsning, hvor en forbindelse, skal være knyttet til en specifik komponent

4. På den Tilføj Constraintvindue kryds i Opret Constraintafkrydsningsfelt under Tilslutning skal vedlægges Constraint areal.

5. Vælg forbindelsestypefra drop-down boks, som du vil angive som vedlagte forbindelse af type- højre klikkede i trin 3. (Eller vælg komponenttypegodkendelsesmærkefra drop-down boks, som du vil angive som den vedhæftede komponent, hvis i trin 3 du højreklikker klikkede en forbindelsestype.)

Note

Hvis der allerede er en aktiveret "Forbindelse skal vedlægges« begrænsning defineret for forbindelsestypen og en anden komponenttypegodkendelse ved hjælp af den samme forbindelse rolle(dvs. enten Kilde eller Sink), så er denne nye begrænsning vil blive behandlet som en "eller". Det er forbindelsestypen skal vedlægges komponent type A ellertypen komponent B, og håndhævelsen plan (f.eks advaret eller fuldbyrdes - se trin 7) bør være den samme ellers håndhæves begrænsninger vil altid tilsidesætte advaret dem. Bemærk også, at hvis der er flere begrænsninger, som har forbindelsen rollespecificeret som »Enhver« (i modsætning til specifikt Kilde eller Sink) derefter hver ende af forbindelsen skal vedlægges en af ​​de komponenttyper specificeret i begrænsninger.

6. Valgfrit kan du vælge en forbindelse rolleat du ønsker at føje til tvang. Svælger den specifikke rolle (dvs. enten Kilde eller Håndvask) fra drop-down boks.

Note

Enten en kilde eller Sink rolle skal eksplicit udvalgt til Attachment kolonne for at være afgangstidspunkter skal vises i en komponent katalog .

7. Vælg, om du vil have den begrænsning at være Handicappet, Advaret eller Håndhæves.

Note

Handicappede begrænsninger vil blive ignoreret fra tvang validering, vil advaret begrænsninger producere en advarsel i Validering vinduet hvis de opdages og håndhæves begrænsninger vil producere en Fejl i Validering vinduet, hvis de opdages. Desuden skal alle fejl løses, før en Enterprise Server Projektet kan blive begået.

8. Klik Okay.

Realtid model kontrol og begrænsningvalidering

ABacus indeholder enrealtid Model Kontrol og Validering funktion til straks vise effekterne en given bruger operation vil have på advarsler og fejl med det aktuelle projekt, på grund af en hvilken som helst hierarki og topologi begrænsninger, der er blevet defineret. Det skal bemærkes, at alle fejl skal løses, før en Enterprise Server Projektet kan blive begået.

Den realtid validering begrænsning funktion er mest mærkbar, når befolker med diagrammer eller direkte i Stifinder-vinduet. Især i løbet af de følgende operationer, gives vejledning ved brug farve højdepunkter som om, operationen vil have på advarsler og fejl med det aktuelle projekt;

1. Når du trækker elementer på eller omkring et diagram farven på den forælder (eller fastgørelse) komponentens (hvis nogen) grænse vil være farvet i henhold til den ordning, der er beskrevet nedenfor.

2. Ved tilslutning komponenter ved hjælp af højreklik træk | Opret forbindelse til funktionen listen over tilgængelige Forbindelsestyper er farvet i henhold til den ordning, der er beskrevet nedenfor.

3. Ved tilslutning komponenter på diagrammer ved hjælp af Connector tilstand markøren skifter farver i henhold til ordningen, der er beskrevet nedenfor.

4. Når du tilføjer delkomponenter listen over tilgængelige komponenttyper er farvet i henhold til den ordning, der er beskrevet nedenfor.

Generelt anvendes følgende farver for at angive de effekter brugeren operation vil have for advarsler og fejl med det aktuelle projekt;

Sort : Ingen indvirkning på advarsler eller fejl.

Grøn : Operationen er udtrykkeligt i overensstemmelse meddefinerede hierarki og topologi begrænsninger for projektet.

Rød : Operationen er udtrykkeligt i strid medde definerede hierarki og topologi begrænsninger for projektet og vil resultere i advarsler og / eller fejl.

Baggrund model kontrol og begrænsningvalidering

ABACUS indeholder en Validering funktion til at vise alle advarsler og fejl med det aktuelle projekt, på grund af eventuelle begrænsninger, der er blevet defineret. Det skal bemærkes, at alle fejl skal løses, før en Enterprise Server Projektet kan blive begået.

Note

Validering skal manuelt køre via den "Valider / check Projekt Begrænsninger 'knappen på Hovedværktøjslinjen . Den Validering vinduet er skjult som standardmen vil blive vist, når knappen værktøjslinjen klikkes. Se Tilpasning af grænsefladen for hvor du får vist skjulte det og potentielt lade det permanent vises. Du kan også dobbeltklikke på en række i Validering vindue til "hoppe" til den relevante element i projektet.

Validering vindue

Standardindstillingerne kolonner i Validering vinduet beskrives som følger;

Advarsel eller Fejl: Denne kolonne viser et ikon for, om overtrædelsen er en advarsel (gul trekant med et udråbstegn) eller fejl (rød cirkel med et kryds).

Antal: Denne kolonne viser overtrædelsen nummer.

Note

Kun 200 overtrædelser vises ad gangen, og hvis der er mere end 200 overtrædelser i et projekt Start, Forrige, Næste Slut rækken navigatører i øverste højre hjørne af vinduet kan bruges til at gennemse de ekstra krænkelser.

Beskrivelse: Dette er en fuldstændig beskrivelse af overtrædelsen, herunder den pågældende enhed og Constraint.

Enhed: Denne kolonne viser den enhed af interesse for overtrædelsen.

Type: Denne kolonne viser det element type til virksomheden.

Arkitektur: Denne kolonne viser den arkitektur, inden for hvilken overtrædelsen har fundet sted.

Opdagede: Denne kolonne viser den tid, overtrædelsen blev opdaget.

Tip

Det er nyttigt at sortere faldende efter den Opdagede kolonne (som vist i ovenstående dialogboks) for at sikre de seneste krænkelser vises i 'top' på listen.

Der er flere brugergrupper muligheder for at ændre adfærd valideringen baggrunden model. For eksempel to ændre farver, der anvendes for overtrædelse tvang til noget andet end standard RødKlik på på Funktioner | Valgmuligheder ... derefter gå til de Valideringfane, og indstille farverne via Lave om knapper.

Validering optioner

Hvis du manuelt vil validere begrænsninger

1. Højreklik på den Arkitekturernode enhver arkitektur eller hvor som helst i enten Komponenter eller Tilslutningerdel af opdagelsesrejsende visningen og vælg Check Begrænsninger.

Godkend begrænsninger

2. Klik på Detaljerknappen på Advarslervinduet for at se, hvor arkitekturen krænker eventuelle begrænsninger, der er blevet defineret.

Note

Overtrædelser vises kun for de begrænsninger, der er blevet indstillet til Advarede eller fuldbyrdes. Desuden ordlyden af ​​advarslen vil omfatte "bør", hvis begrænsningen var bare en advarsel eller 'must', hvis det blev håndhævet.

3. Klik Okay.

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt


Evolving din arkitektur

Navigation: Befolke din arkitektur> Befolke manuelt> Ekstra indstillinger>

Evolving din arkitektur

Send kommentarer om dette emne.

Arkitekturer kan eksplicit udviklet sig og et hierarki af arkitekturer oprettet. Således ved udvikler din arkitektur i ABACUS, kan der skabes en række avancerede arkitektoniske løsninger, sammenlignes og baselined. Kan defineres mål (eller målinger) for et vilkårligt antal arkitektoniske egenskaber til eksisterende arkitekturer.

En enkel måde at overveje udviklingen af ​​en arkitektur er at relatere det til begrebet efterkommer arkitektur. Når en arkitektur er udviklet, et kopiaf moderselskabet arkitekturen er oprettet. Dette eksemplar kan også siges at være en direkte efterkommeraf den oprindelige forælder arkitektur.

Note

I denne online hjælp dokumentation og ABACUS værktøjssæt selve udtrykket udvikle siger mere almindeligt anvendt end udtrykket efterkommerBemærk, at både refererer til den samme funktionalitet.

At udvikle en eksisterende arkitektur

1. Sikre, at du har en ABACUS filåben og Explorer-vinduevises.

2. Vælg den relevante arkitektur, du ønsker at udvikle sig fra explorer træet.

3. Højreklikpå arkitektur og vælg Evolvefra menuen.

Udvikling af den valgte arkitektur

4. Den udviklede arkitektur vil blive vist under den valgte arkitektur.

Evolved Arkitektur

Note

Den udviklede arkitektur kan omdøbes ved at højreklikke på arkitekturen og vælge Omdøb.Desuden vil alle de diagrammer og kataloger i den udviklede arkitektur indstilles automatisk til 'diff' mod baseline arkitektur at det blev udviklet fra.

Sætte mål for din udviklet arkitektur

Sætte mål for din udviklet arkitektur gør det muligt at oprette et kriterium for at vurdere udviklingen i dine arkitekturer. Mål bestemmes af de ejendomstyper og navnene på de egenskaber, der findes i dit udviklet arkitektur. Mål kan også manuelt defineret og tilføjet til dig arkitektur. Følg nedenstående trin for at sætte mål.

Sætte mål fra eksisterende egenskaber for din udviklet arkitektur

1. Sikre, at du har en ABACUS filåben og Explorer-vinduevises.

2. Vælg Funktioner | Sætte målFra hovedmenuen bar.

3. De Goal InputVinduet vil vise.

Goal Input Vindue

4. Klik på Eksisterende knap.

5. De Vælg en ejendomVinduet vil vise.

6. Vælg en ejendom, du ønsker at indstille som et mål for din udviklet arkitektur og klik på Okay knap.

7. Det valgte mål vises nu i Goal Input vindue.

8. Vælg målet og klik på Redigere knap.

9. De Rediger GoalVinduet vil vise.

Note

Dette vindue kan du ændre ejendommen navn og type, at målet vil afspejle, samt de værste og bedste pris (eller minimum / maksimum værdier) for ejendommen. Disse værdier er fundet ved at sammenligne alle arkitekturer og finde den mindste og største værdi i hvert for den specifikke ejendom. Disse værdier kan også manuelt defineret. For eksempel, hvis du skulle sætte et mål for ejendommen navngivet Response (Ave)og af typen Opførsel, Kan din værste og bedste værdi afspejler transaktionen hastighed er nødvendig for optimal ydelse (bedste værdi) og transaktionen hastighed er nødvendig for kun vigtigste anvendelser, der skal behandles (værste værdi).

10. Når er blevet defineret de relevante værdier, skal du vælge Okay.

Sætte mål fra nye egenskaber til din udviklet arkitektur

1. Sikre, at du har en ABACUS filåben og Explorer-vinduevises.

2. Vælg Funktioner | Sætte målFra hovedmenuen bar.

3. De Goal InputVinduet vil vise.

4. Klik på Ny knap.

5. De Ny GoalVinduet vil vise.

Note

Dette vindue kan du definere ejendommen navn og type, at målet vil afspejle, såvel som den værste og bedste værdi (eller minimum / maksimum værdier) for ejendommen. For eksempel, hvis du skulle sætte et mål for ejendom med navnet Response (Ave)og af typen Opførsel, Kan din værste og bedste værdi afspejler transaktionen hastighed er nødvendig for optimal ydelse (bedste værdi) og transaktionen hastighed er nødvendig for kun vigtigste anvendelser, der skal behandles (værste værdi).

6. Når er blevet defineret de relevante værdier, skal du vælge Okay.

7. En dialog til Føj til alle arkitekturervil vises som nedenfor:

8. Klik på Jaat tilføje målet som en egenskab til alle relevante arkitekturer. Dette sikrer, at den nyligt definerede mål og dens egenskaber vil blive tilføjet til alle arkitekturer i filen. Hvis du ikke ønsker omfatter ejendommen i arkitekturer, kan du klikke på Ingen.

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Visning af en stjerne plot af dine udviklet arkitekturer | Visning af en scatter plot af dine udviklet arkitekturer


The Drawing Tool

Navigation: Befolke din arkitektur> Brug tegninger>

The Drawing Tool

Send kommentarer om dette emne.

The Drawing Tool tillader oprettelsen af ​​en bred vifte af arkitektoniske skemaer og diagrammer. Arkitekter traditionelt bruger en række forskellige tegninger til at registrere og formidle udformningen af ​​en arkitektur. Todimensionale (2D) diagrammer er den sædvanlige måde at dokumentere og kommunikere forskellige dele af et system. Typiske tegninger, der anvendes i virksomhedens systemer er:

· Forretningsprocesser modeller og diagrammer;

· Organisation diagrammer;

· Collaboration diagrammer;

· Entity-Relationship (ER) diagrammer;

· Data-rutediagrammer (DFD s);

· Klassediagrammer;

· IDEF (inkorporerer flere af ovenfor); og

· UML (som omfatter adskillige af de ovennævnte).

Der er virkelig ingen grænse for den slags diagrammer, der kan oprettes. ABACUS forsøger at balancere diagram fleksibilitet og samtidig bevare integriteten af ​​arkitektur og dens former for repræsentation.

Tegningen miljøet er en faneblade og dockes vindue inde i de vigtigste ABACUS ansøgning. Dette vindue indeholder et lærred, hvor tegningen finder sted, og når tegning vinduet er åbent en anden dockes vindue , Stencil vinduet, kan ses med et sæt af tegning stencils. Stencil rude har 4 faner: komponenter, tilslutninger, former og stik. Lærredet fremstår som en hvid baggrund med fine gitterlinjer (nyttige til layout).

Skal være repræsenteret af en række figurer, mens forbindelser er tegnet som instrueret linjer. Tilslutninger tillægger komponenter ved hjælp af roller (dvs. enten Source eller Sink) selv om disse ikke er vist af æstetiske grunde.

Tip

Mens diagrammerer meget nyttige for at vise forskellige dele af et system, de er begrænsede i deres skalerbarhed, hvilket er grunden til ABACUS bruger 3D til at visualisere komplekse systemer strukturer.

Du ønsker måske at

1. Åbn Diagrammer Værktøj

2. Opret en ny diagram af en del af en din arkitektur

3. Kopier et diagram inden for eller på tværs af arkitekturer

4. Tilføj komponenter til et diagram

5. Opret nye komponenter og forbindelser i din arkitektur (skematisk) ved hjælp af tegning værktøj

6. Slet komponenter fra et diagram

7. Vedhæft & manipulere tilslutninger

8. Skift display egenskaber af komponenter og forbindelser.

9. Brug af links i diagram

10. Håndhæve foreninger og synspunkter for at begrænse de typer af diagrammer, der kan drages.

Se også

Befolker din arkitektur | Befolker din arkitektur manuelt | Analyse din arkitektur


Åbning diagrammer

Navigation: Befolke din arkitektur> Brug tegninger>

Åbning diagrammer

Send kommentarer om dette emne.

De tegning stencil og lærred vinduer vises automatisk, når et diagram åbnes eller oprettes. Tilsvarende, når et diagram er lukket, det tilsvarende faner ark i lærredet vinduet forsvinder, og hvis der ikke yderligere træk er åbne derefter stencilen vinduet er lukket.

Til skabeen ny diagram

1. Sikre, at du har enABACUS fil åbenindeholder dit befolkede arkitektur.

2. Klik på Diagramikon i værktøjslinjen Vis.

- eller -

2. Vælge Indsæt| Diagram.

- eller -

2. Højreklik de Diagrammergren af ​​en given Arkitekturdel af træet, og vælg Skabe Diagram.

3. Vælg Arkitekturdu ønsker at fokusere på fra pull-down menuen. Bemærk: vil allerede være valgt arkitekturen for dig, hvis du brugte trin 3 ovenfor for at åbne nye diagram.

4. Vælg Udsigtspunkt du vil bruge, fra pull-down menuen. Bemærk: det valgte synspunkt vil filtrere komponenter og tilslutninger lister til kun dem, der findes på det synspunkt.

5. Vælg eventuelt en udsigt fra Filtrer efter Viewpull-down menuen for at forudindstille komponenter og forbindelser fra den valgte visning. Bemærk: det er effektivt ved hjælp af den valgte visning som en gemt forespørgsel.

6. Vælg Layout at være enten Radial eller Grid.

7. Vælg Komponenter og Tilslutningersom du ønsker i diagrammet fra Vinduet til valg standard element .

8. Klik Okay.

Note

Et nyt diagram vil blive føjet til Diagrammergren af ​​arkitekturen. Det vil have en standard navn, som du kan ændre senere ved at højreklikke på det.Desuden vil den sidste tilstand komponent- og udvælgelse forbindelse filtre gemmes med diagrammet effektivt redde "query" bruges til at oprette diagrammet.

For at åbne en eksisterende Diagram

1. I den specifikke befolkede arkitektur, udvide Diagrammergren af ​​træet.

2. Dobbeltklik diagrammet, du vil åbne.

Hvis du vil gemme et diagram

1. Sørg for, at du har en ny eller eksisterende diagram åbenog du har foretaget de nødvendige ændringer. Bemærk: en stjerne '*' vil blive vist, når det synspunkt navn i tabbed ark header, hvis der er ændringer, der skal gemmes.

2. I explorer Udsigt Klik på Spareknappen eller kom til Fil| Spareeller trykke Ctrl + Sat gemme alle ændringer i din arkitektur og skrive det til fil.

Hvis du vil gemme et diagram som en udsigtspunkt

1. Sørg for, at du har et eksisterende diagram i dit ABACUS fil.

2. Højreklikdiagrammet i Diagrammerdel af træet.

3. Vælge Gem som Diagram Viewpoint.

4. Indtast et navn til din nye diagram synspunktog klik Okay.

Se også

The Drawing Tool | Befolker din arkitektur | Analyse din arkitektur


Kopiering af diagrammer

Navigation: Befolke din arkitektur> Brug tegninger>

Kopiering af diagrammer

Send kommentarer om dette emne.

Der er 2 grundlæggende scenarier til at kopiere et eksisterende diagram; inden en arkitektur, eller på tværs af arkitekturer.

Til kopiet diagraminden en arkitektur

1. Sikre, at du har enABACUS fil åbenindeholder dit befolkede arkitekturmed mindst en diagram.

2. Udvide de Diagrammer filial (og eventuelle nødvendige Diagram grupper) af en given Arkitekturdel af træet.

3. Vælg diagrammet, du ønsker at kopiere, og tryk derefter på Ctrl + C eller Højreklikog vælg Kopi fra menuen.

Note

A kopi af diagram vil blive tilføjet til den Diagrammergren af samme arkitektur. Det vil have "Kopi af" føjet til begyndelsen af ​​navnet, Som du kan ændre senere ved trykke F2 eller højreklikke på detog vælge Omdøb.

Til kopiere et diagram tværs arkitekturer

1. Sikre, at du har enABACUS fil åbenindeholder dit befolkede arkitektursmed mindst en diagram.

2. Udvide de Diagrammer filial (og eventuelle nødvendige Diagram grupper) af de Arkitekturdel af træetfor arkitekturen, der indeholder diagrammet, du ønsker at kopiere.

3. Vælg diagrammet, du ønsker at kopiere og på den Generelle egenskabervindue note Udsigtspunkt at diagrammet er knyttet til (i feltet Type).

4. Nu, udvide de Diagrammer filial (og eventuelle nødvendige Diagram grupper) af de Arkitekturdel af træetfor det andet arkitektur, du ønsker at kopiere diagrammet ind.

5. Højreklik de Diagrammer knudepunkt (eller Diagram gruppe), Og vælg Opret Diagram .... I den dialogboks, der vises vælg Udsigtspunkt der blev bemærket i trin 3 ovenfor i drop-down øverst til højre. Lad alt andet som er, og klik Okay. I dialogboksen Diagram Name indtaste et navn på den (snart være) kopierede diagram. Bemærk: En tom diagram lærred ifølge den valgte synspunkt vil blive åbnet.

6. Vend tilbage til diagrammet, som du ønsker at kopiere og åbne, at ved højreklikkeknudepunktet og vælge Åben eller blot dobbeltklikke det.

7. Vælg baggrunden lærred af diagrammet, du ønsker at kopiere, og tryk på Ctrl + A. Dette vil markere alle elementerne på denne diagrammet. Tryk nu Ctrl + Cat kopiere indholdet til udklipsholderen.

8. Nu vender tilbage til den tomme diagram i arkitekturen, du ønsker at kopiere indholdet ind, vælge baggrundenlærred og enten Højreklikog vælg Sæt ind eller blot trykke Ctrl + Vat indsætte indhold. Efter en kort tid indholdet alle vil blive indsat i det nye tomme diagram.

Note

Elementer vil blive tilføjet til det øverste niveau af den nye arkitektur og bliver nødt til at være re-arrangeret eller fusioneret med eksisterende indhold i overensstemmelse hermed.

Se også

The Drawing Tool | Befolker din arkitektur | Analyse din arkitektur


Befolker diagrammer

Navigation: Befolke din arkitektur> Brug tegninger>

Befolker diagrammer

Send kommentarer om dette emne.

Tegninger i ABACUS er mere end blot tilfældige repræsentationer. De er tilpasset udsigt over arkitekturen, formateret og indrettet til at vise særlig betydning.

The Drawing Tool håndhæver den hierarkiske struktur af arkitekturen, således at komponenterne er visuelt indlejret i andre komponenter - reelt giver en "plan udsigt 'af elementerne. Når en komponent eller en forbindelse er blevet defineret i arkitekturen, kan det anvendes i et vilkårligt antal forskellige diagrammer. Vigtigt er tegneværktøjet tæt forbundet med den arkitektoniske model, således at ændringer udført i den ene altid er afspejlet i den anden.

Værktøjet fungerer ved at knytte former med særlig tilknytning og komponenttyper defineret i sektionen af ​​arkitekturen. Disse foreninger varierer afhængigt af typen af ​​diagrammet bliver trukket, og det er muligt, at en type komponent (eller forbindelse) kan have forskellige repræsentationer i de forskellige diagrammer, afhængigt af konteksten.

For at oprette en association mellem en figur og en komponent eller tilslutningstype

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Maksimér ABACUS ansøgningen, og konfigurere vinduet proportioner som du ønsker.

3. Vælg Fanen Formereller Fanen Stik i stencil vinduet.

4. I Typegren af ​​Stifinder den komponent eller tilslutningstype, du gerne vil forbinde med en form eller stik.

5. Vælg den valgte type element fra træet, skal du trække det over til fanen Former eller fane Stik, og slip den på formen eller stikdu gerne vil bruge.

Note

Du kan kontrollere en forening, du har oprettet ved at vælge komponenter eller fanen Forbindelser i Stencil vinduet, som viser de aktuelt tilknyttede elementer.

Hvis du vil tilføje nye figurer til din diagrammer / bibliotek

1. Opret en MS Visio diagram med de figurer, du vil føje til dit diagram og importere MS Visio diagram .

Tip

Det er vigtigt, hvilken størrelse du laver master formen i MS Visio, fordi ABACUS lærredet er dimensioneret i pixels og kun Millimeter enheder i MS Visio konvertere granularly til pixels på en 4 pixels til 1 millimeter forhold. Desuden standardindstillingerne ABACUS figurer er typisk 60 pixels højt, så oversætter til 15 millimeter i MS Visio. Betydning en tilrådeligt mester form størrelse i MS Visio er 25mm bred ved 15mm højda dette vil oversætte til 100 pixel i bredden og 60 pixels højt ABACUS.

Tip

Hvis du vil have en lille 'ikon' i øverste venstre hjørne af en figur, så kan du bare oprette den "ikonet" i master MS Visio form ved hjælp af MS Visio Tegning Tool palette (bemærk, at kun enkle linjer, cirkler og rektangler er understøttet og rasteriseret / bitmap figurer i særdeleshed er ikke understøttet). Desuden, hvis du vil have ikonet for at være fikseret i størrelse / skalai form i ABACUS så kan du gruppe den "ikonet" i master MS Visio form ved at vælge alle dens elementer, højreklikke et element, vælge Shape | Gruppe, derefter højreklikke på den grupperede form og vælge data | Shape data ..., vælge Ja i den dialogboks, der vises, og derefter tilføje en ejendom med Label indstillet til LockScale(bemærk det store "L" og "S"), den type er indstillet til Boolesk og værdien sat til at være RIGTIGT (bemærk det er alle i store bogstaver).

Tip

Hvis du ønsker at have en del af formen frosset fra skalering horisontalt eller vertikalt (som er typisk med en svømmebane "form) så kan du højreklikke på den del (e) af master MS Visio figur, du vil have frosne fra skalering og vælge Data | Shape data ..., vælge Ja i den dialogboks, der vises, og derefter tilføje en ejendom med Label indstillet til LockXScale eller LockYScale (bemærk det store "L" og "S"), den type er indstillet til Boolesk og værdien sat til at være RIGTIGT (bemærk det er alle i store bogstaver), for låst vandret eller lodret skalering hhv.

Tip

For at tillade farvning af formen i ABACUS efter import snarere end formen altid være en fast farve, er det tilrådeligt at gøre master MS Visio form udfyldning gennemsigtig og derefter bruge den indbyggede evne ABACUS til at farve en figur baggrund. Dette virker kun med rektangel eller næsten rektangel (f.eks afrundet rektangel) figurer som hele rektangulære baggrund vil blive farvet.

2. Åbne den tilsvarende diagram, og vælg Fanen Komponenteri stencil vinduet.

3. For hver ny figur, som du vil gøre tilgængelige for andre diagrammer Højreklikformen og vælge Føj til Former bibliotek. Dette vil gøre formen tilgængelige under fanen Former i stencil vinduet.

4. Tilknyt relevant komponent type med den nye figur fra Former Bibliotek ifølge de ovenfor beskrevne trin.

Note

Kun enkle og "vektor-baserede" figurer er understøttet i ABACUS i øjeblikket, er altså bitmaps understøttes ikke. Men værktøjer som Vector Magic ( www.vectormagic.com ) Er tilgængelige, som let vil konvertere bitmap-billeder til vektorbaserede former (dvs. SVG format), der kan åbnes i MS Visio og dermed udnyttes i ABACUS som pr ovenstående instruktioner.

TilføjelseKomponenter og tilslutninger

The Drawing Tool giver dig mulighed for at tilføje eksisterende komponenter og forbindelser fra lageret eller oprette nye komponenter og forbindelser, som du tegner et diagram. Som komponenter og forbindelser er skabt i diagrammer, er de samtidig tilsat til repository. Der er tre anbefalede måder at tilføje komponenter til et diagramog tre anbefalede måder at tilføje forbindelser til et diagram:

Hvis du vil oprette en helt ny komponent eller forbindelse på et diagramfra stencilen

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Vælg Komponenter eller Tilslutningerfane i stencil vinduet for at se de tilhørende figurer. Kun disse former kan anvendes til at skabe nye model elementer.

3. Klik og træken af ​​de tilgængelige tilknyttede figurer over på tegningen lærred. Det nye element vil blive vist på lærredet og i explorer træet.

4. Begynd at skriveet navn for det nye element i dialogen og eventuelle eksisterende elementer, der er matchet er foreslået, og kan vælges i stedet for at tilføje et nyt element til arkitekturen.

5. Klik Okay.

6. Hvis en figur blev droppet på en eksisterende komponent, så vil det enten blive til et barn af denne komponent (hvis formen kom fra Komponenterfane), eller vil blive knyttet til den pågældende komponent (hvis formen kom fra Tilslutningerfane).

Note

Det er nogle gange nødvendigt at justere den nye komponent eller tilslutning til et andet sted i den arkitektoniske hierarki ved hjælp af explorer.

For at placere en eksisterende komponent eller forbindelse fra repository på et diagram

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Vær sikker på at du har både Tegning Tool og Explorer vinduer kan ses.

3. I Stifinder, find den komponent eller forbindelse(element), du ønsker at tilføje til diagrammet.

4. Klik og trækdet valgte element på diagrammet. En form, der repræsenterer elementet vises på lærredet.

Note

Hvis typen af ​​den valgte element allerede er forbundet med en form, vil den tilsvarende form vist på lærredet. Men hvis der ikke er defineret forening for netop dette element, vil en standard form (rektangel) vises på lærredet, medmindre Håndhæve Diagram Synspunkter mulighed er den, i hvilket tilfælde formen vil ikke blive tilføjet til diagrammet.

Tip

Når en komponent er placeret på et diagram, som er forbundet til en anden komponent, der allerede på diagrammet, vil Drawing Tool forespørge, hvis du vil gerne vise forbindelsen (r) mellem dem. Også, hvis der er nogen børn af den komponent Tegning Tool vil forespørge, hvis du ønsker at inkludere børnene i en rekursiv måde.

Til oprette en forbindelse mellem 2 komponenter eller en tilsluttet komponent på et diagram ved hjælp af dynamisk stik

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Hover i løbet af en komponent på diagrammet, som du ønsker at tilslutte til en anden komponent, og du vil bemærke 2 ikoner vises uden øverst til højre på grænsen af ​​form som vist nedenfor. Bemærk: Den øverste ikon er for at skabe en forbindelse hvor svævede komponent er at være kilden, det nederste ikon for at skabe en forbindelse hvor svævede komponent skal være vasken.

3. Bevæge sig markøren over det ønskede ikon og klik og trækikonet til over enten over en anden komponent eller ledig plads på lærredet som vist nedenfor.

4. For at forbinde til en eksisterende komponent vælge Vedhæft til ...post i pop op-menuen, og hvis det er nødvendigt browse til sub-menu at vælge fra de tilgængelige forbindelsestyper.

- eller -

4. For at oprette en tilsluttet komponent valgte fra Ny...elementer i pop op-menuen, og hvis det er nødvendigt browse til sub-menu at vælge fra de tilgængelige forbindelsestyper, som vist nedenfor. Begynd at skriveet navn for det nye element i dialogen og eventuelle eksisterende elementer, der er matchet er foreslået, og kan vælges i stedet for at tilføje et nyt element til arkitekturen.

Note

Tilgængeligheden af ​​elementer i pop op-menuen og undermenuen er underlagt begrænsninger i meta-model.Det er kun den gyldig kilde eller synke komponenttyper, som bestemt ved tilslutning begrænsninger vil blive præsenteret som Vedhæft til ... og New ... menupunkter.

Til re-åbn dialogboksen til valg element den og placere eksisterende komponenter eller forbindelser fra lageret på et diagram

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Klik de Åbent Element Selectionknappen i Diagram værktøjslinjen. Bemærk: Dialogen valgelementet vil åbne med den sidste tilstand af eventuelle filtre gemt.

3. Vælg en ekstra indhold, som ønskes tilføjet til diagram og klik Okay. Bemærk: det nye indhold vil blive føjet til frirum på lærredet, og diagrammet kan efterfølgende lagt ud igen via Layout Diagramknappen i Diagram værktøjslinjen.

Brug gratisformFormer

Det er ofte ønskeligt at skabe visuelle elementer i et diagram til rent æstetiske årsager. Disse elementer kan bidrage til at forbedre layout og udseendet af et diagram, men de har ikke en streng arkitektoniske betydning. Tegneværktøjet tillader brugen af ​​Frihåndsfigurer at tilvejebringe tegning fleksibilitet.

For at tilføje en freeform form til et diagram

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Vælg Former eller Stikfane i stencil vinduet.

3. Klik og træken af ​​de tilgængelige former eller stik onto tegningen lærred. Det nye element vil blive vist på lærredet - men ikkei explorer træet.

Note

Freeform figurer er "ikke-associeret" former, som de har ingen tilknytning til nogen bestemt komponent eller tilslutning i den arkitektoniske model.

Til vise repository information freeform formsønet diagram

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Højreklikden freeform form og vælg Annotation | Vise.

3. Vælge at vise enten Diagram navn, Diagram Beskrivelse, Diagram Ejendom, Viewpoint Navn eller Arkitektur Navn.

Note

Teksten i freeform opdateres automatisk som de underliggende repository ændringer data.På denne måde kan der skabes et diagram 'titel blok "for, og derefter nemt kopieres på tværs, diagrammer.

Brug Flydende Former

Flydende former er i det væsentlige en anden måde at repræsentere komponenter i et diagram. Overvej en organisation med vigtige divisioner: CEO, marketing, salg og udvikling.

Trævisning

Disse inddelinger kan være visuelt repræsenteret i en lagdelt måde:

Layered View

Eller de kan være visuelt repræsenteret i et forskudt / Floating måde at vise hierarki:

Forskudt / Flydende Udsigt

Sidstnævnte repræsentation anvender begrebet flydende former.

For at konvertere en lagdelt komponent form i en flydende form

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Vælg komponenti diagrammet, du ønsker at repræsentere som en flydende form eller en tilknyttet form i Komponenterfanen stencil vindue, du vil alle forekomster som flydende former.

3. Højreklik på formen og vælg Float Component i genvejsmenuen, der vises. Bemærk diamant ledes tilslutningfra forældre bestanddel (e) til flydende bestanddel (e).

4. Klik og trækkomponenten til den ønskede placering. Når en flydendekomponent er valgt, vil have en blå omrids.

For at konvertere en flydende komponent form til en lagdelt form

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Vælg komponenti diagrammet, der i øjeblikket vises som en flydende form eller en tilknyttet form i Komponenterfanen stencil vindue, du vil alle forekomster som lagdelte former.

3. Klik og trækden flydende bestanddel (e) tilbage til den forælder (s) (i henhold til diamant ledes tilslutning). Bemærk: Hvis du ikke gør dette, så når du konverterer komponent (er) tilbage til at blive lagdelt hierarkiet af din model kan være påvirket.

4. Højreklik på formen og fravælge Float Component i genvejsmenuen, der vises. Bemærk, at diamant ledes tilslutningfra forældre bestanddel (e) til flydende bestanddel (e) forsvinder.

Replikaer

The Drawing Tool giver dig mulighed for at føje den samme komponent til et diagram flere gange med hver yderligere visuel forekomst af komponent på diagrammet benævnt en replika. Dette er især nyttigt for diagrammer, hvor en komponent har et stort antal knyttet til den forbindelser, og det er at foretrække at vise komponenten i flere lokationer tættere på oprindelsen af ​​hver af forbindelserne, eller til diagrammer, hvor en én-til-mange-relation af en komponent er at foretrække at vise ved hjælp af flydende funktionen (beskrevet ovenfor) med komponenten på flere steder på toppen af ​​de "mange" komponenter det er relateret til.

Note

Du kan vedhæfte / løsne forbindelser til / fra den oprindelige forekomst af komponenten i et diagram (som altid), men også ethvert af kopier, men når forbindelser tilføjes automatisk et diagram de er bundet til den første forekomst af komponenten på diagrammet som standard.

Note

Replikaer kan flettes med hinanden ved højre-klik og trækderefter vælge Flet ReplikaerMen fusionere en replika med en anden komponent vil resultere i andre replikaer forsvinder fra diagrammet.

Note

Der er ingen visuel forskel mellem den oprindelige instans af en komponent på et diagram og eventuelle kopier. Desuden højreklik menu til den oprindelige komponent på et diagram, og enhver replikaer er identisk, med for eksempel Vis i Stifindertager dig til den samme komponent i trævisningen af ​​lageret (alias modellen). Men højreklikke på komponenten i trævisningen af ​​lageret og vælge Gå tilog browsing til et diagram med reproduktioner vil altid tage dig til den "ældste" forekomst af komponenten på diagrammet. Dette vil typisk være original instans, der blev tilføjet til diagrammet men hvis det oprindelige instans efterfølgende blev slettet eller fusioneret med en replika så vil gå til hoppe til den ældste af de resterende kopier, der blev tilføjet.

Til tilføje en replika til en diagram

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Højreklik på en eksisterende komponent på diagrammet og vælg Opret replika.En kopi af den valgte komponent vil blive oprettet til højre for den oprindelige komponent.

- ELLER -

Vælg en eksisterende komponent på et diagram og tryk Ctrl + Celler højreklik på en eksisterende komponent på diagrammet og vælg Kopi. Nu skal du højreklikke på placering på diagrammet, som du ønsker replika og vælg Indsæt som Replica. Bemærk: Hvis du trykker Ctrl + V (eller højreklikke og vælge Sæt ind) vil skabe en kopi af den originale komponent ikke en replika.

- ELLER -

Klik og træken komponent fra trævisningen af ​​lageret (alias modellen) på et diagram, hvor komponenten allerede findes.

Konfiguration Connection Caps / Ends

The Drawing Tool giver dig mulighed for at sæt symbol anvendes i enderne af tilslutningsledningerne enten til en fast symbol eller et symbol afhængig af en ejendom på selve forbindelsen.Dette er særligt nyttigt til diagrammer, hvor retningen af ​​en forbindelse, som skal fremgå, eller for diagrammer, hvor Kardinalitet af forbindelse (eller retningen) er indeholdt i en ejendom på selve forbindelsen, f.eks "En-til-mange" vs "Mange-til-mange" (eller "Kilde for at Sink" vs "Sink Source").

Til konfigurere forbindelse hætter / ender på et diagram

1. Sørg for, at du har en ny eller eksisterende diagram åben.

2. Vælg Forbindeionerfane i stencil vinduet.

3. Højreklik cslikke en af ​​de forbundet forbindelsestyper og vælg Konfigurer Caps ....

4. For en fast forbindelse hætte / ende på enten kilden eller synke ende af forbindelsen sørg for relevante Fast alternativknap er valgt, og vælg derefter forbindelsen ende symbol fra pull down, f.eks "Pil hoved" eller "Diamond".

- ELLER -

For en ejendom-baserede forbindelse cap / ende på enten kilden eller synke ende af forbindelsen sørg for relevante Brug Ejendomalternativknap er valgt, og klik derefter på '...' knappen, og vælg den ønskede ejendom, og derefter ud for hver tilslutning ende symbol Indtast ejendom værdier, for hvilke den specifikke forbindelse symbolet der skal vises.

Note

Flere ejendomsværdier for en given forbindelse ende symbol kan indtastes adskilt af kommaer. F.eks. nedenstående dialog viser, at hvis "Data | Kardinalitet 'har en værdi på "en-til-mange" derefter kilden ende af forbindelsen vil have to line stryger gennem det og vasken ende af forbindelsen vil have en linie slag gennem det og derefter en fan-out to line slagtilfælde i slutningen.

Indstil Caps dialogen

Se også

The Drawing Tool | Befolker din arkitektur | Analyse din arkitektur


Manipulering diagrammer

Navigation: Befolke din arkitektur> Brug tegninger>

Manipulering diagrammer

Send kommentarer om dette emne.

Når et diagram er blevet oprettet, de elementer, der vises i det kan være re-arrangeret og re-størrelse som ønsket.

Hvis du vil flytte en komponent i et diagram

1. Sørg for, at du har en eksisterende diagram åben .

2. Klik-og-holdenhver komponent til at flytte det. Hvis den valgte komponent har en forælder, vil moderselskabet komponenten blive fremhævet.

3. Som elementetslæbt fra moderselskabet komponent, og over andre komponenter, 'potentielle' forældre vil blive fremhævet. Ordningen farve anvendte angiver effekten operationen vil have på de advarsler og fejl med det aktuelle projekt og er beskrevet i Udformning og godkendelse Begrænsninger . På denne måde kan du grafisk navigere hierarkiet fra en plantegning.

4. Frigøremuseknappen for at slippe elementet i sin nye placering.

Note

Du kan også bruge tastaturet til at re-position elementer på tegningen lærred. Du skal blot vælge den komponent eller fri form form du vil flytte, og bruge piletasterne placeret på tastaturet til at flytte formen til den ønskede plads.

Bemærk også, at når du trækker en komponent med musen over en anden komponent, er en »potentiel« forælder komponent fremhævet, når det øverste venstre hjørne af den komponent du trækker overlapper en anden komponent.

Tip

Freeform og Flydende former kan bestilles ved højreklikkeog vælge Placer forrest eller Send til Backfra menuen. Det er vigtigt at bemærke, at komponent former kan omdannes til Frihåndsfigurer af højreklikkepå specifikke komponent form og valg Konverter til freeform.

For at ændre størrelsen på en komponent i et diagram

1. Sørg for, at du har en eksisterende diagram åben .

2. Klik-hold-træken af ​​komponentens håndtag og ændre størrelsen på formen til den ønskede størrelse.

3. Alternativt at bevare figurens størrelsesforhold, trykkes Shift + Klik-hold-træk.

Hvis du vil flytte en forbindelse i et diagram

1. Sørg for, at du har en eksisterende diagram åben .

2. Klik-og-holdenhver forbindelse at flytte det.

3. Frigøremuseknappen for at slippe elementet i sin nye placering.

Note

Du kan kun flytte forbindelser, der ikke er knyttet til nogen komponenter. Hvis de er bundet, kan man kun bevæge den frie endes, eller re-route forbindelsen .

Sletning komponenter og forbindelser

Når du sletter en komponent eller forbindelse fra et diagram, har du mulighed for at slette den fra hele arkitektur. Enhver komponent, der er slettet fra arkitekturen vil automatisk blive fjernet fra alle andre diagrammer, hvor det vises. Da freeform tilfælde vises kun i ét diagram, slette dem påvirker ikke den arkitektoniske model eller hvilket som helst andet diagram.

Hvis du vil slette en komponent eller forbindelse fra et diagram

1. Sørg for, at du har en eksisterende diagram åben .

2. Klikpå eventuelle tilknyttede forbindelse eller komponent for at vælge den.

3. Tryk på Sletfor at slette det fra diagrammet, eller Shift + Deletefor at slette det fra hele modellen.

- eller -

2. Højreklik på alle tilknyttede element eller komponent. En genvejsmenu vises.

3. Vælge Slet fra View eller Slet fra Arkitekturfra genvejsmenuen.

Note

Hvis det element, du ønsker at slette fra det synspunkt har ingen børn og forekommer kun på denne opfattelse, vil ABACUS spørge, om du vil slette elementet fra lageret så godt.

Forsigtighed

Når du sletter en komponent fra den model, der har underordnede komponenter, børnene bliver også potentielt slettet efter dialogen advarslen.

Fusionerende Komponenter

Du ønsker måske at fusionere to komponenter eksisterende på samme diagram (og inden for arkitektur). Dette kan gøres af mange årsager, for eksempel, To servere eksisterer inden for en virksomheds infrastruktur-H01 og H02. Disse to servere er repræsenteret som to separate komponenter i en arkitektur. H01 er blevet anset for overflødig og derfor skal nedlægges. Alle eksisterende programmer, der kører på H01 er at blive flyttet til H02 (stadig i provision). Denne ændring kan derefter reflekteres af virkningen af ​​"fusionerende" de to komponenter H01 og H02 på diagrammet (og inden for arkitektur).

For en detaljeret diskussion om sammenlægning henvises til Fletning Elementer emne her .

At flette to eksisterende komponenter

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklik-holdpå den komponent, du vil flette og trækdet på den komponent, du vil flette det med. Sørg for, at omridset af destinationen komponent er markeret rødt for at indikere, at det er valgt.

3. Vælge Flet | Bevar destination eller Overskriv Destinationfra menuen.

Note

De Bevar destinationmulighed bevarer værdierne af destinationens komponentens egenskaber, hvis de findes på komponenten oprindelse så godt.

De Overskriv Destinationmulighed overskriver den destination komponent egenskaber med eventuelle fælles egenskaber fra komponenten oprindelse.

Ændring Connections

Vist i et diagram-forbindelser altidafspejler strukturen som defineret i selve arkitekturen. The Drawing Tool giver dig mulighed for at frigøre tilslutninger fra komponenter, flytte dem, kurve dem, re-route dem og re-vedhæfte dem til andre komponenter.

At frigøre / vedhæfte en forbindelse fra / til en komponent

1. Sørg for, at du har en eksisterende diagram åben .

2. Klik-og-holdpå en forbindelse.

3. Vælgeforbindelsen ende(dvs. Kilde eller Sink), Som du gerne vil frigøre / vedhæfte. Bemærk: Forbindelsen ender er angivet med små hvide cirkler og svæver over den hvide cirkel for en anden vil medføre et "værktøjstip" vises med den respektive rolle navn(dvs. enten Source eller Sink).

4. Trækforbindelsen ende til en ny placering (enten en ledig plads eller en komponent), og slip museknappen.

Note

Når forbindelsen ende er placeret over en gyldig komponent, er omridset af målbestanddelen fremhævet med en stiplet kontur. Ordningen farve anvendte angiver effekten operationen vil have på de advarsler og fejl med det aktuelle projekt og er beskrevet i Udformning og godkendelse Begrænsninger . Når frigivet den ende af the tilslutning og komponenten automatisk tilsluttes(eller vedlagt)Er og dette afspejles i den arkitektoniske model.

At re-route en forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Placer musemarkøren over en forbindelse.

3. Hold Flyttetasten nede og Klikmuseknappen for at placere en forbindelse ankerpunkt. Slip Flytte nøgle. Du kan fjerne ankerpunkt ved at gøre den samme operation.

4. Klik-og-trækanker punkt at omdirigere forbindelsen.

Tip

BrugAlt nøgle i stedet for den Flyttenøglen til at skabe ortogonale forbindelser.

Til kurve eller retteen forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Placer musemarkøren over en forbindelse.

3. Højreklikthan-forbindelse og i genvejsmenuen, der vises vælg Kurve, Orthogonal eller Lige.

Tip

Alle forbindelseraf en given type på diagrammet kan indstilles til Svejfet, Ortogonale eller Straight ved at højreklikke på den tilhørende linje for type på Fanen Forbindelser af Stencil vindueog vælge Curve, Ortogonale eller Straight.

Til anker på et bestemt punkt på kanten af ​​en figur

1. Sørg for, at du har en eksisterende diagram åben .

2. Vælg en forbindelse.

3. Placer musemarkøren over den "hvide prik 'i slutningen af en forbindelse.

4. HøjrekliktHan tilslutning ende og i genvejsmenuen, der vises vælg Anchor Endpoint til Shape.Flyt forbindelsen ende til ønsket placering på kanten af ​​formen.

ELLER

Hold Ctrltasten nede og cslikke-og-træk de indstiksende pege på ønsket placering på kanten af ​​formen.

Note

Forbindelser vil snap til den faktiske skæring deres tilsluttede form i stedet for afgrænsningsrammen af ​​denne form.

Se også

The Drawing Tool | Befolker din arkitektur | Analyse din arkitektur


Tegneværktøj Egenskaber

Navigation: Befolke din arkitektur> Brug tegninger>

Tegneværktøj Egenskaber

Send kommentarer om dette emne.

Tegneværktøjet understøtter en række tegnefunktionerne.

Zoome

Omfanget af diagrammet kan ændres ved hjælp af zoom-funktionen.

For at mindske omfanget af eller 'Zoom i'

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Trykke Ctrlog '= "tasten.

- eller -

2. Vælg Zoom indknappen på Diagramværktøjslinje.

- eller -

2. Trykke Ctrlog rul musehjulet forward. Bemærk: I denne tilstand lærredet vil zoome retning, hvor musen svæver over lærredet.

For at øge omfanget eller "zoome ud"

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Trykke Ctrlog '-' tasten.

- eller -

2. Vælg Zoome udknappen på Diagramværktøjslinje.

- eller -

2. Trykke Ctrlog rul musehjulet bagud. Bemærk: I denne tilstand lærredet vil zoome udad fra hvor musen svæver over lærredet.

Auto-layout

Layoutet af komponenterne i diagrammet kan ændres automatisk.

Til layout alle komponenter on et diagram

1. Cslikke de Layout Diagramknappen på Diagram værktøjslinjen.

2. Vælgeenten Radial Layout eller Grid Layout.

Note

Den Radial layout vil bruge det, der kaldes sådan, at tilsluttede komponenter trækkes sammen, mens usammenhængende komponenter er tvunget fra hinanden en "force-rettet" algoritme. The Grid layout vil bruge en fast bredde og højde afstand algoritme. Det første tillader brugeren at vælge den samlede diagram formatforhold (f.eks 16: 9, A4 (portræt), Letter (Liggende)) og derefter afstanden i siderne og mellem kolonner og rækker som vist nedenfor.Med Grid layout nogen tilslutninger mellem komponenterne ikke påvirker layout som det simpelthen arrangerer komponenterne alfabetisk (ved deres navn) fra øverste venstre hjørne til nederste højre hjørne af lærredet. Med begge algoritmer freeform figurer ikke flyttes.

Til layout børn komponenter i en enkelt forælder on et diagram

1. Højrekliket højt niveau komponent hvis børn, du ønsker at auto-layout.

2. Vælge Layout Børn.

Note

Som standard bruges kun Radial layout algoritme.

Ændring Element Æstetik synes godt om Farve, Gennemsigtighed, Shadows og rotation

Alle diagram elementer har æstetik, som kan manipuleres som ønsket. I tilfælde af tilknyttede figurer, kan disse aspekter indstilles hver typeog i de fleste tilfælde også pr eksempel. I tilfælde af Frihåndsfigurer, kan disse egenskaber indstilles pr eksempelpå lærredet.

Note

Enhver pr eksempel aspekter, som er blevet opstillet for tilknyttede figurer vil blive "overskrives", hvis det samme aspekt er ændret for den tilsvarende type.

Hvis du vil ændre farven på en tilknyttet form eller en freeform form

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller freeform form på lærredet.

3. Vælge Skift farve.

4. Vælg Fast Farvevalgknap (hvis relevant).

5. Vælg et Basic Farve eller definere en brugerdefineret farve i dialogboksen, og klik Okay.

- eller -

4. Vælg Gradientvalgknap (hvis relevant).

5. Vælg enten vandret, lodret, Frem Diagonal eller Bagud Diagonal for gradient retning i rullemenuen og klik Okay.

6. Vælg et Basic Farve eller definere en brugerdefineret farve i dialogboksen for Starte og Endeog klik Okay.

Note

ABACUS vil farve forgrunden af ​​en figur, hvis;
a) det er en "simpel" form med et enkelt underliggende grafisk element (f.eks cirkel, rektangel, polygon osv), eller
b) det er en "kompleks" form med flere underliggende subshapes, der alle er i samme farve / gradient som hinanden eller de subshapes har LockScale = TRUE sæt.
Hvis ovenstående betingelser ikke er opfyldt så baggrunden af ​​formen er farvet.

For at indstille farven på en tilknyttet form efter en ejendom

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vinduet(IKKE på tegningen lærred).

3. Vælge Skift farve.

4. Vælg Brug Ejendom Radio knap.

5. Vælg en egenskab ved at klikke på knappen '...' til højre for tekstfeltet.

6. Vælg Rækkevidde Radio knap.

7. Juster Min og Maxværdier som ønsket. Bemærk: enhver værdi under minimum værdi vil blive vist som min farve og enhver værdi over den maksimale, vil blive vist som Max farve. Også, når du bruger booleske, List eller dato / tid ejendomme værdierne konverteres til et indeks som følger; Boolean (False = 0, True = 1), List (et heltal vale på 1 til n for hver gyldig værdi i deres stigende rækkefølge angivet i feltet Enheder) og dato / klokkeslæt (antal dage siden 1 Januar 1900 - inklusive decimaler for timer, minutter, sekunder portioner - og hvis datoen er pre-1990 er et negativt tal).

8. Vælg et Basic Farve eller definere en brugerdefineret farve i dialogboksen for Min og Maxog klik Okay.

Tip

Hvis Grøn (RGB - 128,255,0) er valgt som min farve og Rød (RGB - 255,0,0) vælges som Max farve til en ejendom med værdi vifte af 1 til 4derefter en værdi på 1vil blive vist som GrønEn værdi på 2 i takt med Gul, 3 i takt med Orange og 4 i takt med Rød.

Alternativt, for en egenskab række 1 til 3en værdi på 1vil være så GrønEn værdi på 2 i takt med Rav og 3 i takt med Rødaka 'Traffic Lights «eller RAG status.

For en egenskab området fra 1 til 5, hvis Blå (RGB - 0,0,255) er valgt som min farve og Rød (RGB - 255,0,0) er valgt som Max farve en værdi på 1, vil være så BlåEn værdi på 2, som AquaEn værdi på 3 som GrønEn værdi på 4 som Gul og en værdi på 5, som Rød.

For en egenskab området fra 1 til 6, hvis Violet (RGB - 255,0,255) er valgt som min farve og Rød (RGB - 255,0,0) er valgt som Max farve en værdi på 1, vil være så VioletEn værdi på 2, som BlåEn værdi på 3 som AquaEn værdi på 4 som GrønEn værdi på 5, som Gul og en værdi på 6 som Rød.

Og endelig for en egenskab området fra 1 til 7 en værdi på 1 bliver så VioletEn værdi på 2, som MørkeblåEn værdi på 3 som LyseblåEn værdi på 4 som BlågrønEn værdi på 5, som GrønEn værdi på 6 som Rav og en værdi på 7 som Rød

Note

Se noten ovenfor på forgrunden versus baggrund farve.

- eller -

7. Vælg Specifik værdi Radio knap.

8. Klik på Rediger Farver knap.

9. Vælg hver værdi på skift, og klik Sæt farveat angive en bestemt farve for hver værdi.

Note

Rækken af ​​værdier for elementerne til stede på diagrammet vil blive præ-befolket.

10. Hvis du vil tilføje yderligere værdi farver til dem på forhånd befolkede (for eksempel efter ejendommen serien er omkonfigureres) klik Tilføj værdi.

Hvis du vil ændre farven gennemsigtighed en tilknyttet form eller en freeform form

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller freeform form på lærredet.

3. Vælge Skift farve.

4. I panelet Gennemsigtighed indstilles den øverste skyder til den ønskede gennemsigtighed for grundfarven.

5. Hvis Gradient eller ved hjælp af property muligheder bliver brugt, i panelet Gennemsigtighed indstille nederste skyderen til den ønskede gennemsigtighed for den anden farve.

6. Klik Okay.

At vise skygger for alle de forbundet figurer i et diagram

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenterfanen stencil vinduet.

3. Vælge Tilføje Skygger.

Til viser en skygge på en komponent form eller freeform form

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Højre-klikpå komponenten eller freeform form på lærredet.

3. Vælge Tilføje Skygger.

For at rotere komponent former og fri form figurer i diagrammer

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Vælg den komponent form eller en freeform form på lærredet, du vil rotere.

3. Højreklikom form og vælg Rotereog derefter vælge den relevante vinkel, du ønsker at rotere form ved.

Ændring Element annotationer og fritekst etiketter

Alle diagram elementer har anmærkninger der kan manipuleres som ønsket. I tilfælde af tilknyttede figurer, kan disse aspekter indstilles hver typeog i de fleste tilfælde også pr eksempel. I tilfælde af Frihåndsfigurerog stik, detekstetiketter kan indstilles pr eksempelpå lærredet.Otte (8) forskellige typer af annotationer kan vises til diagram elementer (dvs. navn, type, Ejendom værdi, Ejendom Marker, Attached Komponenter, Børn (kun komponenter), standarder og Timestamps (Oprettet, Ændret af etc)) i tyve fem (25) forskellige positioner (f.eks Centre - Uden Top, Inside venstre - center, uden for højre - Outside Bund).

Note

Enhver pr eksempel aspekter, som er blevet opstillet for tilknyttede figurer vil blive "overskrives", hvis det samme aspekt er ændret for den tilsvarende type.Desuden hvor 2 eller flere anmærkninger indtager den samme stilling kan kun bruges en enkelt skrifttype, typografi, skrifttype farve og størrelse og en separator (f.eks komma, plads, ny linje) skal være valgt.

At vise navnet eller typen for en tilknyttet komponent eller forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller stik på lærredet.

3. Vælge Anmærkninger.

Note

Ved en individuel associeret form eller stik på lærredet skal du vælge den Tilsidesæt Stencil anmærkningerafkrydsningsfeltet første gang.

4. Vælg Ny Annotation i værktøjslinjen og vælg Navn eller Type.

5. I den viste dialog vælge de Display indstillinger, der ønskes herunder beslag og skrifttype, typografi, skrifttype farve og størrelse. Også vælge de layoutindstillinger, der ønskes herunder horisontale og vertikale linjeføring (dvs. annotation position) og Angle (dvs. rotation). Vælge Okay.

For at vise en ejendom værdi for en tilknyttet komponent eller forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller stik på lærredet.

3. Vælge Anmærkninger.

Note

Ved en individuel associeret form eller stik på lærredet skal du vælge den Tilsidesæt Stencil anmærkningerafkrydsningsfeltet første gang.

4. Vælg Ny Annotation i værktøjslinjen og vælg Ejendom Værdi.

5. I den dialogboks, der vises vælg ejendommen ved at klikke på Ejendom: '...' knappen og vælge en ejendom i dialogboksen Vælg en ejendomog vælg Okay. Vælg de Display indstillinger, der ønskes herunder beslag og skrifttype, typografi, skrifttype farve og størrelse. Også vælge de layoutindstillinger, der ønskes herunder horisontale og vertikale linjeføring (dvs. annotation position) og Angle (dvs. rotation). Vælge Okay.

For at vise en ejendom markør for en tilknyttet komponent eller forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller stik på lærredet.

3. Vælge Anmærkninger.

Note

Ved en individuel associeret form eller stik på lærredet skal du vælge den Tilsidesæt Stencil anmærkningerafkrydsningsfeltet første gang.

4. Vælg Ny Annotation i værktøjslinjen og vælg Ejendom Marker.

5. I den dialogboks, der vises vælg ejendommen ved at klikke på Ejendom: '...' knappen og vælge en ejendom i dialogboksen Vælg en ejendomog vælg Okay. Indstil radius af markøren i pixel og farve metode til enten Farve på sortiment eller Colour By Ejendom og indstille farver opgaver. Også vælge de layoutindstillinger, der ønskes herunder horisontale og vertikale linjeføring (dvs. annotation position) og Angle (dvs. rotation). Vælge Okay.

At vise vedhæftede komponenter for en tilknyttet komponent eller forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller stik på lærredet.

3. Vælge Anmærkninger.

Note

Ved en individuel associeret form eller stik på lærredet skal du vælge den Tilsidesæt Stencil anmærkningerafkrydsningsfeltet første gang.

4. Vælg Ny Annotation i værktøjslinjen og vælg Vedhæftede Komponenter.

5. I den dialogboks, der vises, for forbundne komponenter vælge den vedhæftede type- ved at klikke på Vedhæftet: '...' knappen og vælge en komponent type i dialogen Set Component Typeog vælg Okay. Vælg den forbindelsestype fastgjort ved at klikke på tilsluttet via: '...' knappen og vælge en forbindelsestype i dialogboksen Set Forbindelsestypeog vælg Okay.For associerede tilslutninger vælge den forbindelse ende ved at vælge Kilde eller Sink fra Connection Slut: pull-down menuen. For både tilhørende komponenter og forbindelser vælge Vis indstillinger, der ønskes herunder beslag og skrifttype, typografi, skrifttype farve og størrelse. Også vælge de layoutindstillinger, der ønskes herunder horisontale og vertikale linjeføring (dvs. annotation position) og Angle (dvs. rotation). Vælge Okay.

At vise børnene for en tilknyttet komponent

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenterfanen stencil vindue eller en tilknyttet form på lærredet.

3. Vælge Anmærkninger.

Note

For en individuel tilknyttet form på lærredet skal du vælge den Tilsidesæt Stencil anmærkningerafkrydsningsfeltet første gang.

4. Vælg Ny Annotation i værktøjslinjen og vælg Børn.

5. I den viste dialog vælge de Display indstillinger, der ønskes herunder beslag og skrifttype, typografi, skrifttype farve og størrelse. Også vælge de layoutindstillinger, der ønskes herunder horisontale og vertikale linjeføring (dvs. annotation position) og Angle (dvs. rotation). Vælge Okay.

At vise standarderne for en tilknyttet komponent eller forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller stik på lærredet.

3. Vælge Anmærkninger.

Note

Ved en individuel associeret form eller stik på lærredet skal du vælge den Tilsidesæt Stencil anmærkningerafkrydsningsfeltet første gang.

4. Vælg Ny Annotation i værktøjslinjen og vælg Standarder.

5. I den viste dialog vælge de Display indstillinger, der ønskes herunder beslag og skrifttype, typografi, skrifttype farve og størrelse. Også vælge de layoutindstillinger, der ønskes herunder horisontale og vertikale linjeføring (dvs. annotation position) og Angle (dvs. rotation). Vælge Okay.

At vise de tidsstempler for en tilknyttet komponent eller forbindelse

1. Sørg for, at du har en eksisterende diagram åben .

2. Højreklikpå en tilknyttet form eller stik i Komponenter eller Tilslutningerfanen stencil vindue eller en tilknyttet form eller stik på lærredet.

3. Vælge Anmærkninger.

Note

Ved en individuel associeret form eller stik på lærredet skal du vælge den Tilsidesæt Stencil anmærkningerafkrydsningsfeltet første gang.

4. Vælg Ny Annotation i værktøjslinjen og vælg Oprettet, skabt af, skabte Marker, Modified, Ændret af eller Modified Marker.

5. I den dialogboks, der vises, hvis ikke en markør, vælg de Display indstillinger, der ønskes herunder beslag og skrifttype, typografi, skrifttype farve og størrelse. Hvis en markør, skal du indstille radius af markøren i pixel og farve metode til enten Farve på sortiment eller Colour By Ejendom og indstille farver opgaver. Også vælge de layoutindstillinger, der ønskes herunder horisontale og vertikale linjeføring (dvs. annotation position) og Angle (dvs. rotation). Vælge Okay.

Hvis du vil ændre skrifttypen stil med en freeform formeller stik

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Højreklikpå freeform form eller stik på lærredet. Bemærk: Hvis stik tekst etiket er ikke vise derefter at vise connecteller tekst label: Højreklikconnectellerog vælg Annotation | Vis Annotation.

3. Vælge Skift skrifttype.

4. Vælg en skrifttype, typografi og størrelse i dialogboksen, og vælg Okay.

Hvis du vil ændre skrifttypen farve af en freeform formeller stik

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Højreklikpå freeform form eller stik på lærredet. Bemærk: Hvis stik tekst etiket er ikke vise derefter at vise connecteller tekst label: Højreklikconnectellerog vælg Annotation | Vis Annotation.

3. Vælge Lave om Font farve.

4. Vælg en skrifttypeFarve (og for figurer Link Farve) ved at klikke på '...' knappen og vælge en farve i dialogen, og vælg Okay.

5. Vælg Gennemsigtighed i teksten etiketten ved at justere skyderen hvor 0 er fuldstændig gennemsigtig og 255 er helt uigennemsigtig.

At rotere teksten etiketten på en freeform formeller stik

1. Sørg for, at du har en ny eller eksisterende diagram åben .

2. Højreklikpå freeform form eller stik på lærredet. Bemærk: Hvis stik tekst etiket er ikke vise derefter at vise connecteller tekst label: Højreklikconnectellerog vælg Annotation | Vis Annotation.

3. Vælge Rotereog derefter vælge den relevante vinkel, du ønsker at rotere tekst label ved.

Se også

The Drawing Tool | Befolker din arkitektur | Analyse din arkitektur


Brug af links i diagrammer

Navigation: Befolke din arkitektur> Brug tegninger>

Brug af links i diagrammer

Send kommentarer om dette emne.

Former (fri form og komponenter) og stik (fri form eller forbindelser) inden diagrammer kan være knyttet til din eksisterende arkitektoniske repræsentationer i ABACUS, samt eksterne filer / mapper og webadresser. Disse links kan derefter styres (oprettet, ændret og slettet) via ABACUS værktøjssæt. Denne funktion kan bruges til at forbedre navigation og overordnet forståelse af din arkitektur skematisk.

For at tilføje links til dit diagram

1. Sørg for, at du har en eksisterende diagram åben .

2. Vælg den relevante form eller stik fra diagrammet.

3. Højreklikpå formeneller stik.

4. Vælge Åbne linksog en Linksvises.

5. Klik på Tilføjeikon og et New Linkvises.

6. Vælg den relevante Katalog | Matrix | Diagram| 3D-visning| Diagramradioknapper, og vælg derefter den relevante katalog, matrix, diagram, 3Deller diagram view i den aktuelle arkitektur fra Link Tildrop-down menuen.

- eller -

6. Vælg Internet sidevalgknap derefter indtaste den relevante URL (for eksempel http: //www.avolutionsoftware.com /)i feltet for at linke til en webside. Gyldige webadresser nødt til at starte med en af 5strygere; http: //, https: //, ftp: //, fil: eller \\. Mellemrum skal indtastes med en '% 20'.

- eller -

6. Vælg Absolut Filer | Relativ fil Radio knaps,klik derefter på '...'Knappen for at søge efter en ekstern fil til at linke til din diagrammet.

7. Klik Okayog den nye forbindelse vil blive vist i Links vinduet. Bemærk: Links Vinduet kan skaleres til at se det fulde navn, hvis det er nødvendigt.

8. Gentag trin 5-7at skabe flere links.

9. For at følge den oprettede linket, skal du vælge den relevante link, der vises i Linksvindue og klik Åbn link.

Note

Hvornår flere anmærkninger bliver vist for en form eller stik linket er vist på den første indføring i listen over anmærkninger i dialogboksen Rediger anmærkninger.

At følge links fra diagrammet

1. Sørg for, at du har en eksisterende diagram åben .

2. Vælg den relevante form eller stik fra diagrammet.

3. Klikpå det relevante hyperlink (blå understreget komponent navn) på en form, eller stik i diagrammet for at åbne og se det første link fra formeneller stik.Bemærk: Markøren skal skifte til en 'hånd', når linket er klar til at blive klikket på.

- eller -

3. Vælg den relevante form eller stik fra diagrammet.

4. Højreklikpå formeneller stik.

5. Vælge Åbne links og Linksvises.

6. Vælg den relevante link, som du gerne vil se.

7. Klik på Åbn linkknappen for at åbne og se relevante link.

For at slette links i din diagram

1. Sørg for, at du har en eksisterende diagram åben .

2. Vælg den relevante formeller stikfra diagrammet.

3. Højreklikpå formeneller stik.

4. Vælge Åbne links og Linksvises.

5. Vælg den relevante link, der skal slettes.

6. Klik på Slet knap. og forbindelsen fjernes fra Links vindue.

Organisering af links i din diagram

Du kan vælge, hvilke knyttet diagram, ekstern fil, eller web URL vises, når en figur mærke er Ctrl + klikkede i diagrammet.

1. Sørg for, at du har en eksisterende diagram åben .

2. Vælg den relevante form eller stik fra diagrammet.

3. Højreklikpå formeneller stik.

4. Vælge Åbne links og Linksvises.

5. For at ændre rækkefølgen af ​​de links du klikke på Flyt op | Flyt nedknapperne på højre side af Links vindue.

6. Det første link, der vises på venstre side af LinksVinduet er det link, der vises, når du Ctrl + Kliket hyperlink form eller stik navn.

Se også

Befolker din arkitektur | Befolker din arkitektur manuelt | Analyse din arkitektur


Diagram Synspunkter

Navigation: Befolke din arkitektur> Brug tegninger>

Diagram Synspunkter

Send kommentarer om dette emne.

The synspunkterfunktion sikrer, at komponenter og forbindelser, der tilsættes et diagram, skal have en type association tidligere defineret, før de kan sættes til et diagram. Denne funktion giver mulighed for begrænsning af de typer af diagrammer, der kan trækkes ved at begrænse de figurer og konnektorer, der er forbundet med komponenter og Tilslutningereksisterende i din arkitektur.

Aktivering eller deaktivering Håndhævelse diagram synspunkter

Evnen til at håndhæve diagram synspunkter automatisk aktiveret som standard. For at deaktivere / aktivere denne funktion, klik på Funktioner | Valgmuligheder ...| de Diagramfanen, og fravælge / vælge Håndhæve Diagram Synspunkterafkrydsningsfeltet i overensstemmelse hermed.

Note

Hvis du ikke kan se den "Gennemtving Diagram Synspunkter'Muligheden på fanen Diagram så du ikke har Designer tilføjelse, og indstillingen er som standard.

Oprettelse af en eksigibel diagram udsigtspunkt

1. Sikre, at du har en ABACUS fil åben med opdagelsesrejsendevisning vises.

2. I explorer opfattelse højreklikke på Udsigtpunktsog klik på Skabe Diagram Viewpoint

3. De Diagram ViewpointVinduet vil blive vist.

4. Tildel et relevant navn til diagram synspunktog bemærk, at udsigtspunkt gemmes under Synspunktersektion af opdagelsesrejsende.

5. De Diagram ViewpointVinduet vil blive vist.

6. Nu klikke og trække de relevante typer komponent og forbindelsestyper i dine arkitekturer på synspunkt figurer du vil have. Komponenttyperskal trækkes på en formi figurerfane, mens forbindelsestyperskal trækkes på en af ​​de 5 line stil figureri stikfane.

7. Hvis du vil gemme diagram synspunktdu har oprettet klik på [image] i øverste højre hjørne af din Diagram Viewpoint vindue.

Note

De diagram synspunktkan redigeres ved at højreklikke på den udsigtspunkt og vælge Åben eller dobbeltklikke de udsigtspunkt.

Synchonising en opdateret synspunkt med diagrammer

1. Sikre, at du har en ABACUS fil åben.

2. Enten skal du højreklikke på synspunkt i Explorer vindue under Meta-model | Synspunkterog vælg Synkroniser Diagram Mappings ...

- eller -

3. Tæt den åbne og opdateret synspunkt vindue og vælg Jai Synkroniser til Viewpointdialogboks, der vises.

4. De Viewpoint SynkroniseringDialogen vil blive vist som vist nedenfor.

Afkrydsningsfelter

· Tilføj Manglende tilknytninger- Enhver ny form (til typegodkendelse) eller stik (til tilslutning type) foreninger, der er blevet tilføjet til synspunktvil blive føjet til tilsvarende diagrams (dvs. deresstencils) at er knyttet til synspunkt.

· Opdatering EksisterendeKortlægninger- Eventuelle opdaterede aspekter af den eksisterende form (til typegodkendelse) eller stik (til tilslutningstype) foreninger for synspunktet(f.eks farve, skrifttyper) vil blive opdateret i tilsvarende diagrams (dvs. deresstencils) at er knyttet til synspunkt.

· Fjern EkstraKortlægninger- Eventuelle yderligere form (til typegodkendelse) eller stik (til tilslutning type) foreninger, der er blevet tilføjet til diagrammer (det vil sige deres stencils), men er ikke i udsigtspunktvil blive fjernet fra tilsvarende diagrams (dvs. deresstencils) at er knyttet til synspunkt.

· Overskriv Lokale indstillinger for tilføjet eller opdateret kortlægninger (Forskelle Only)- Eventuelle opdaterede aspekter af den eksisterende form (til typegodkendelse) eller stik (til tilslutningstype) foreninger for synspunktet(f.eks farve, skrifttyper) vil blive anvendt til de tilsvarende elementer på diagrammerne, der er knyttet til det synspunkt.Kun de opdaterede »forskelle« foretaget i synspunkt anvendes så eventuelle eksisterende lokale indstillinger i diagrammet, der ikke blev opdateret i det synspunkt vil forblive uændret.

· [image] Anmærkninger – Som ovenfor, men specielt til anmærkninger.

Se også

The Drawing Tool | Befolker din arkitektur | Analyse din arkitektur


Befolker hjælp Kataloger

Navigation: Befolke din arkitektur>

Befolker hjælp Kataloger

Send kommentarer om dette emne.

A katalog giver dig mulighed for at se og redigere komponenter eller forbindelser og deres egenskaber på en enkel måde tabelform.

Til oprette en ny katalog se i ABACUS

Note

Mens alle Arkitekt brugere kan oprette nye Kataloger, at gemme ændringer i en eksisterende Katalog indstillinger den bruger licens brug Designeren tilføjelse formåen. Dette er for at »beskytte« konfigurationen af ​​eksisterende Kataloger, der kan deles af mange brugere. Men Arkitekt bruger uden Designer add-on kan stadig vælge at 'Save As' eventuelle nye indstillinger til en ny katalog. Og selvfølgelig alle brugerlicenser kan vælge at "Kassér" eventuelle ændringer i et eksisterende katalog. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du har brug Designeren tilføjelse evne. Og husk, det er kun indstillingerne for kataloget, er alle redigeringer foretaget data i kataloget øjeblikkeligt anvendt til lageret, uanset.

1. Vælg Indsæt | Katalog.

2. I pull-down vælge den arkitektur, der indeholder de komponenter, ellerforbindelser, du ønsker at se.

3. I pull-down vælge komponenten eller tilslutningstype som du ønsker at have de tilfælde, opført som 'rækker' i kataloget.

4. De katalog vil blive befolket med etrække for hver forekomst af den valgte komponent eller tilslutningstype.

Note

Som standard venstre-mest Hierarki Pathsøjle (dvs. hierarkiet af forældre komponenter eller forbindelser over de valgte instanser) og 2. Navn søjle (dvs. listen over den valgte komponent eller tilslutning forekomster) er frosset til venstre for kataloget. For at ændre kolonne frysning trække kolonnen separator til højre for kolonnen Navn. Du kan Re-orderkolonner blot ved at trække og slippe deres kolonneoverskrifter. Celler af kolonner med en blå understregning er hyperlinks til andre elementer i projektet, og de hyperlinks kan følges ved at holde Ctrl nede og klikke på linkene. Kolonner kan være skjult ved at højreklikke på kolonneoverskriften og vælge Kolonne | Skjul kolonne. Skjulte kolonner kan vist til at klikke på knappen Konfigurer Kolonner værktøjslinjen og bruge Konfigurer Kolonner dialogboksen som vist nedenfor, eller ved at vælge pil ned del af knappen Konfigurer Kolonner værktøjslinjen og individuelt valg af skjulte kolonne (r) fra enten General, Egenskaber eller vedhæftede filer samlinger. Rækker kan være grupperet af deres kolonneværdier ved at trække kolonneoverskriften i den blå gruppering øverst af kataloget. På ethvert tidspunkt kan du dobbeltklikke på den katalog rækken vælgeren og springe tilden tilsvarende komponenteller tilslutningi Stifinder-vinduet.Ejendom celle værdier er fed skrift hvor de er anderledes til standardindstillingerne, og kursiv hvor de er skrivebeskyttede. Tidsstempel, Se og Attached Component kolonner kan være farvet i henhold til de celle værdier eller en vedhæftet komponent ejendom værdi ved at højreklikke på kolonneoverskriften og vælge Kolonne | Skift farve ... og derefter farve ved Tidsstempel eller Colour By Property mulighed, dog kun List, Integer, Decimal, boolesk eller dato / tid data type egenskaber vil farve. Ejendom værdier for Attached Component kolonner kan være vist ved at højreklikke på kolonneoverskriften og vælge Kolonne | Vis Ejendom ... og derefter Show Property mulighed. Og endelig, hvor der er Krævede begrænsninger sat for en ejendom kolonne disse kan vises med en snor (sammen med farvelægning i henhold til deres håndhævelse niveauer) ved at højreklikke på kolonneoverskriften og vælge Kolonne | Vis .

Katalog

Til tilføje / show kolonner til a Katalog visning i ABACUS

1. Sørg for, at du har en Katalog visning åben.

2. Skjulte kolonner kan individuelt vist til at klikke på pil til højre for knappen Konfigurer Kolonner værktøjslinjenog vælge den skjulte kolonne fra enten Generel, Egenskaber eller Vedhæftede filer samlinger.

Note

En flueben vises ved siden af ​​de aktuelt viste kolonner for kataloget.Derudover vil kun visse vedhæftede filer findes under vedhæftede ifølge begrænsninger der er defineret i dit projekt. Specielt til for en vedhæftet fil være klar til at blive vist i en komponent katalog den komponent type til kataloget skal angives som enten kilde eller synke (IKKE den »Enhver«) af et "tilslutning vedlægges" begrænsning for en forbindelse type, og der skal også være mindst én komponent type, specificeret som enten kilde eller synke (IKKE den »Enhver«) i den anden ende "af samme forbindelsestype.

- ELLER -

2. Flere kolonner kan vist til (eller bestilles eller fast) ved at klikke på Konfigurer knappen Kolonner værktøjslinjenog ved hjælp af de Konfigurer Kolonner viste dialog nedenfor.

Note

De aktuelt viste kolonner vises i panelet til højre med de tilgængelige kolonner der vises i panelet til venstre. De tilgængelige kolonner kan filtreres i overensstemmelse med Vælg Tilgængelige kolonner frapull-down, og de kan tilsættes ved at vælge dem i panelet til venstre og klikke på Tilføje knappen inbetween de to paneler.

Konfigurer dialogen Kolonner

Til fjerne / skjule kolonner fra en Katalog visning i ABACUS

1. Sørg for, at du har en Katalog visning åben.

2. Højreklik på kolonneoverskriften for den kolonne, du ønsker at fjerne / skjule og vælg Kolonne | Skjul kolonne.

- ELLER -

2. Flere kolonner kan skjules (eller bestilles eller fast) ved at klikke på Konfigurer knappen Kolonner værktøjslinjenog ved hjælp af de Konfigurer Kolonner viste dialog ovenfor.

Note

De aktuelt viste kolonner vises i panelet til højre med de tilgængelige kolonner der vises i panelet til venstre. De aktuelt viste kolonner kan være skjult ved at markere kolonnen i panelet til højre og klikke på Fjerne knappen inbetween de to paneler.

At udfylde ved hjælp af en Katalog visning i ABACUS

1. Til føje en komponent eller forbindelseaf den valgte type til de katalog (og projektet) klikke på Tilføj ny komponent / Tilføj knappen Ny forbindelse værktøjslinjen. Rækken bør vises og en komponent eller forbindelsen vil blive oprettet på øverste niveau i Komponenter eller Tilslutninger kollektion for den valgte arkitektur.

Note

Nye komponenter og tilslutninger er tilføjet som standard på det øverste niveau af komponenterne eller forbindelser samling af den valgte arkitektur. For at ændre den forælder af de nye komponenter eller forbindelser højreklikke Hierarkiet Sti celle til den nye komponent eller tilslutninger række og vælg Skift Parent ...og vælg den ønskede forælder (der noterer sig begrænsning fremhævning ).

Note

Nye rækker / elementer tilsættes direkte til et katalog via "Tilføj ny" -knappen, indsat i kataloget, eller skabes via import til kataloget fra MS Excel er fritaget for filtrering indtil kataloget er lukket. Dette er at give de nødvendige redigering af kolonneværdier som måske ikke opfylder de nuværende filtrering kriterierne i kataloget. Disse nye element rækker er markeret med et "+" symbol i rækken vælgeren cellen ved begyndelsen af ​​rækken, der er farvet grøn hvis elementet i øjeblikket opfylder de gemte filtrering kriterierne i kataloget (dvs. vil forblive på katalog, hvis genåbnede), og rød hvis det ikke.

2. Til fjerne en komponent eller forbindelseaf den valgte type fra de katalog (og projektet) vælge rækken og enten trykke Del nøgle eller højreklikke på rækken vælgeren, og vælg Slet fra Arkitektur. De række skulle forsvinde fra kataloget og det vil blive slettet fra projektet.

Til filter ved hjælp af en Katalog visning i ABACUS

1. Sørg for, at du har en Katalog visning åben.

2. Hvis filteret rækken ikke vises i toppen af ​​kataloget og klik derefter på Vis Filter Header Rowknap på værktøjslinjen.

3. I den kolonne, du ønsker at tilføje et filter, skal du dobbeltklikke på filteret rækken celle, hvor det viser "(Alle)«.

4. For Tidsstempel, Hierarki Path, Name eller Beskrivelsegenerelle kolonner eller Tekst, Heltal, Decimal, boolesk eller Dato / tidejendom kolonner klik på knappen ..., der vises i højre side af filteret rækken celle og ind i cellen værdier, der bør indgå i kataloget.

Note

Matching udføres, som om '*' jokertegn anvendes automatisk før og efter eventuelle strengværdier så en indgang af 'kat' (uden anførselstegn) ville omfatte rækker med 'bobkat','katkvinde "eller" ansøgkation 'osv Multiple / "eller" kan indtastes værdier på nye strækninger ved hjælp af Ctrl + Enter. For Integer og Decimal ejendom kolonner 'og' logik kan medtages ved hjælp '&"(Uden anførselstegn), og større end / kan mindre end osv logik inkluderes bruger '> =','>','<' og '<="(Uden anførselstegn), f.eks '> = 50000 & <90000'. Ikke-tomme værdsatte rækker kan inkluderes ved at indtaste '(Ikke-Blanks)"(Uden anførselstegn), og Blank værdsatte rækker kan inkluderes ved at indtaste '(Blanks)"(Uden anførselstegn).Og endelig, alle filtre er som standard tilfældet ufølsom, så 'kat' (uden anførselstegn) ville omfatte rækker med 'kat', 'Kat' eller 'kat' etc. For små bogstaver matching, indtaste '(Sag)"(Uden anførselstegn), før strengen f.eks «(Sag) Kat '(uden anførselstegn) kun ville omfatte rækker med' Kat 'i dem.

5. For Vedhæftede filersøjler, Standarder kolonner eller Liste ejendom kolonner ved at klikke på pil ned, der vises i højre side af filteret rækken celle og markere cellen værdier fra afkrydsningsfelterne, der bør indgå i kataloget.

Note

Den "(Select All)" afkrydsningsfeltet, vil gøre det muligt for alle de andre afkrydsningsfelter i realiteten, herunder alle de tilgængelige rækker. Den "(Ikke-Blanks)" afkrydsningsfeltet omfatter enhver ikke-tom værdsatte rækker. Den "(Blanks)" afkrydsningsfeltet vil omfatte eventuelle tomme værdsat rækker. Og endelig, fjerne markeringen specifikke værdsat afkrydsningsfelter vil automatisk fravælg den "(Vælg alle)" og "(Ikke-Blanks)» afkrydsningsfelterne for konsistens.

6. Klik Okay at anvende filteret.

Til deaktivere / aktivere filtrering på a Katalog visning i ABACUS

1. Sørg for, at du har en Katalog visning åben med en filter anvendt.

2. Klik på afkrydsningsfeltet til venstre for filteret række.

Til fjerne et filter fra a Katalog visning i ABACUS

1. Sørg for, at du har en Katalog visning åben med en filter anvendt.

2. Hvis du vil fjerne en individuel kolonne filter højreklikke på kolonneoverskriften og vælg Kolonne | Klar Filtrering.

3. For at fjerne alle filtre klikke på Optioner knap på værktøjslinjen, og vælg Ryd filter indstillinger.

At gemme / Gem som aKatalog visning

Note

Mens alle Arkitekt brugere kan oprette nye Kataloger, at gemme ændringer i en eksisterende Katalog indstillinger den bruger licens brug Designeren tilføjelse formåen. Dette er for at »beskytte« konfigurationen af ​​eksisterende Kataloger, der kan deles af mange brugere. Men Arkitekt bruger uden Designer add-on kan stadig vælge at 'Save As' eventuelle nye indstillinger til en ny katalog. Og selvfølgelig alle brugerlicenser kan vælge at "Kassér" eventuelle ændringer i et eksisterende katalog. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du har brug Designeren tilføjelse evne.Og husk, det er kun indstillingerne for kataloget, er alle redigeringer foretaget data i kataloget øjeblikkeligt anvendt til lageret, uanset.

1. Sørg for, at du har en ny eller eksisterende katalog Se åbenog du har foretaget de nødvendige ændringer.

2. I Katalog visningværktøjslinjen klik på Spareknappen for at gemme Katalog visning og eventuelle formatering ændringer.

Note

Hvis du ikke har en Gem-knappen i katalog Se værktøjslinjen så du ikke har Designer add-on, og du er kun i stand til Gem somnogen indstillinger skifter til et nyt katalog, når du går til at lukke eksisterende katalog.

3. Hvis de Katalog Navndialogboks vises (grund til at være et nyt katalog) indtaste et navn til katalog og tryk Okay.

Til eksport til MS Excel katalog

1. Sørg for, at du har en Katalog visning åben.

2. Klik på Eksport til Excel katalog regnearkknap på værktøjslinjen.

3. Vælg et filnavn for at gemme MS Excel katalog som. Klik Spare.

Note

Som standard den eksporterede MS Excel katalogets filnavn bliver kataloget navnet suffiks af Arkitektur navn i parentes, fx "Projekter (2014 Aktuel) .xlsx«. Du kan ændre noget af dette, herunder om filformatet er at være .xlsx eller .xls. Den arkitektur navn er optaget for at minde brugeren om, at hver enkelt katalog har specifikke indhold (dvs. id'er i kolonne A og række 1) for at lade det være rund-udløst tilbage i at bruge Importer fra MS Excel katalog som pr nedenfor.

Note

Som standard den skjulte Kolonne A inden den eksporterede MS Excel katalog indeholder det unikke id for hver af de elementer i ABACUS arkiv. Dette giver alle ændringer, der er lavet inden for MS Excel til at være "matchet op" til de eksisterende elementer i ABACUS ved indførsel (se nedenfor). Dog kan brugen af ​​denne unikke id til at "matche" rækker tilsidesættes med en Eksterne | IDejendom på elementet. Det vil sige, hvis elementet har en ekstern | ID-ejendom, og det er inkluderet i kataloget på eksport derefter værdierne af den eksterne | ID-kolonne skal bruges til at matche op rækkerne ved import (se nedenfor), og de unikke id-værdier i skjulte kolonne A vil blive ignoreret (og kan endda være tom). Den skjulte Kolonne A selv skal forblive, dog især værdien i celle A1. Desuden når du tilføjer eksterne ID'er til en eksisterende ABACUS element kollektion anbefaler vi at tilføje dem som en anden ejendom først, f.eks Eksterne | Temp og derefter omdøbe ejendommen til External | Id. Ellers duplikerede elementer vil blive tilføjet.

Katalog formateringeksporteres som standard, men for store kataloger dette kan resultere i eksporten bliver ganske langsomt. I overensstemmelse hermed, Tools | Valgmuligheder ...derefter de Katalogfane,du er i stand til at reducere mængden af ​​formatering, der eksporteres som vist på fanen Katalog nedenfor, og dermed fremskynde eksport.

Katalog eksport optioner

4. En Export Afsluttet dialogboks vises. Klik Okay.

Eksporteres til MS Excel katalog

Til import fra MS Excel katalog

Note

Som standard den skjulte Kolonne A inden den eksporterede MS Excel katalog (se ovenfor) indeholder det unikke id for hver af de elementer i ABACUS arkiv. Dette giver alle ændringer, der er lavet inden for MS Excel til at være "matchet op" til de eksisterende elementer i ABACUS ved indførsel. Dog kan brugen af ​​denne unikke id til at "matche" rækker tilsidesættes med en Eksterne | IDejendom på elementet. Det vil sige, hvis elementet har en ekstern | ID-ejendom, og det er inkluderet i kataloget på eksport (se ovenfor), så værdierne af den eksterne | ID-kolonne skal bruges til at matche op rækker på import og de unikke id-værdier i skjulte kolonne A vil blive ignoreret (og kan endda være tom). Den skjulte Kolonne A selv skal forblive, dog især værdien i celle A1. Desuden når du tilføjer eksterne ID'er til en eksisterende ABACUS element kollektion anbefaler vi at tilføje dem som en anden ejendom først, f.eks Eksterne | Temp og derefter omdøbe ejendommen til External | Id. Ellers duplikerede elementer vil blive tilføjet.

1. Sørg for, at du har en Katalog visning åben.

2. Klik på Importer fra Excel katalog regnearkknap på værktøjslinjen.

3. Vælg et filnavn til at importere MS Excel kataloget fra. Klik Åben.

4. Nye Fejl opdaget og / eller nye fejl / advarsler opdaget dialoger kan vises for enhver nyt indhold (dvs. rækker i MS Excel), der blev tilføjet. Vær opmærksom på de fejl / advarsler, og klik Okay.

5. En Import Afsluttet dialogboks vises, og det kan vise advarsler på grund af den import (se noter nedenfor). Klik Okay.

Note

For de tildelte standarder eller vedhæftede Component kolonner, skal nye poster via MS Excel katalog matcher præcis den navn af en eksisterende standard eller komponent af den korrekte type til opgaven eller tilslutning skal tilføjes. Den første navngivne Kampen vil blive brugt, og eventuelle umatchede indgange vil generere en advarsel som pr nedenfor. Endvidere mens advarsler er givet på genindførsel, elementer er ikke slettetfra ABACUS hvis de ikke er til stede i MS Excel katalog. Dette er fordi der er ingen måde, at ABACUS kan vide, om den tildelte standard eller vedhæftet komponent findes i ABACUS projektet, men findes ikke i MS Excel katalog fordi det er blevet slettet fra MS Excel katalog eller er blevet tilføjet til ABACUS projektet siden kataloget blev eksporteret. Derfor hvis brugerne ønsker at let "opdage", som tilslutninger er tilføjet under importen, de kan blot oprette en nødvendig egenskab på forbindelsen type og sætte det som standard til tomme, så de vil blive advaret om eventuelle nye forbindelser hver gang import er afsluttet.

Note

Når du importerer en MS Excel katalog forskellige advarsler kan vises. Det første, hvis en ny kolonne blev føjet til Excel, der ikke passer den "syntaks" for en ejendom eller fastgjort komponent kolonnen vil blive ignoreret. Dernæst vil line-by-line advarsler skal vises for nogen problemer med data på hver række i Excel-kataloget. Disse advarsler begynde med rækken nummer i skarpe parenteser og evt kolonnen etiketten (dvs. "[23, J] ...« for række 23, kolonne J), ​​og kan henvise til slettede elementer, uovertruffen standarder eller vedhæftede Component navne (som ignoreres som pr note ovenfor) eller en ugyldig eller blank ID om en ny række / element (som vil blive tilføjet). For en detaljeret artikel om befolke ABACUS hjælp Excel kataloger henvises til Skønnede udvikling Fællesskab eller Portfolio Manager kursus.

Note

Nye komponenter og tilslutninger er tilføjet som standard på det øverste niveau af komponenterne eller forbindelser samling af den valgte arkitektur. For at ændre den forælder af de nye komponenter eller forbindelser højreklikke Hierarkiet Sti celle til den nye komponent eller tilslutninger række og vælg Skift Parent ...og vælg den ønskede forælder (der noterer sig begrænsning fremhævning ).

Note

Elementer tilsættes direkte til et katalog via "Tilføj ny" -knappen, indsat i kataloget, eller skabes via import til kataloget fra MS Excel er fritaget for filtrering indtil kataloget er lukket. Dette er at give de nødvendige redigering af kolonneværdier som måske ikke opfylder de nuværende filtrering kriterierne i kataloget. Disse nye element rækker er markeret med et "+" symbol i rækken vælgeren cellen ved begyndelsen af ​​rækken, der er farvet grøn hvis elementet i øjeblikket opfylder de gemte filtrering kriterierne i kataloget (dvs. vil forblive på katalog, hvis genåbnede), og rød hvis det ikke.

Til sammenligne indholdet af et katalog med en anden arkitektur

1. Der henvises til emnet her .

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Befolker din arkitektur fra Visio | Befolker din arkitektur fra Excel


Befolker hjælp Matricer

Navigation: Befolke din arkitektur>

Befolker hjælp Matricer

Send kommentarer om dette emne.

En matrix kan du få vist og redigere 'direkte' tilslutninger mellem komponenterne i en enkel tabelform mådeog også se »indirekte vej« mellem komponenter i henhold til eventuelle mellemliggende komponenter (og forbindelser).

Til skabe en matrix visning i ABACUS

Note

Mens alle Arkitekt brugere kan oprette Matricer at redde dem og / eller deres indstillinger bruger licens brug Designeren tilføjelse formåen. Dette er for at "beskytte" konfigurationen af ​​eksisterende matricer, der kan deles af mange brugere. Men Arkitekt bruger uden Designer add-on kan stadig vælge at 'Save As' eventuelle nye indstillinger til en ny matrix. Og selvfølgelig alle brugerlicenser kan vælge at "Kassér" eventuelle ændringer i en eksisterende matrix. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

1. Vælg Indsæt | Matrix.

2. I rchitecture>pull-down vælge den arkitektur, der indeholder de komponenter og forbindelser, du ønsker at se.

3. I <KildeSkriv>pull-down vælge den komponent type, du ønsker at få de tilfælde, der er anført som 'rækker' ned af venstreaf matrixen.

4. I <HåndvaskSkriv>pull-down vælge den komponent type, du ønsker at få de tilfælde, der er anført som 'kolonner' øverstaf matrixen.

5. I træk ned Der er grundlæggende to "tilstande" af matrix du kan definere ...

"Direkte" tilslutninger matricer

6. Simpelthen svælge en (1) eller mere forbindelse typer på højre side af den menu, der vises, hvis du ønsker at se i "celler" af matricen, hvis enn eksplicitforbindelse eksisterer fra Lodret/ 'række"Del af matricen til Vandret/ 'kolonne"Del af matrixen.

Note

Kun forbindelser med kilden ende fastgjort til den Lodret/ 'række»Komponent og håndvask ende fastgjort til Vandret/ 'kolonne'Komponent vil blive vist. Skift Kilde og Håndvaskkomponenttypegodkendelse valg at se forbindelserne i den modsatte retning.

7. Matrixen vil blive befolket med et 'X' i cellerne (eller en ejendom værdi - se bemærkning nedenfor) hvis der er en forbindelse fra Lodret/ 'række'komponent i matricen til Vandret/ 'kolonne"Del af matrixen.

Note

For store matricer kun et maksimum på 100 rækker eller kolonner (herunder kollapsede rækker / kolonner) vil blive vist på et tidspunkt som det fremgår af "R" og "C" indikatorer i øverste venstre header celle hhv. For at se yderligere rækker bruge rullepanelerne. På ethvert tidspunkt kan du dobbeltklikke på den Lodret/ 'række' eller Horizontal / 'kolonne' komponent overskrifter og springe tilde tilsvarende komponenter i Explorer-vindue.Forældrene til den vertikale/ 'række' og Vandret/ 'kolonne' komponents er også eventuelt vist som overskrift rækker / kolonner med en grå overskrift titel. Når kollapsede (ved en enkelt klikke på overskriften celle), hvis børn vedhæftede filer eksisterede derefter et 'X' vil eventuelt blive vist, hvis alle børn blev fastgjort eller O vil eventuelt blive vist hvis kun nogle af børnene blev vedlagt. Cellerne kan være farvet ifølge en ejendomsværdi af forbindelserne ved at klikke på Indstillinger 'tandhjul' øverst til højre i matricen værktøjslinjen og vælge Farveindstillinger ... og derefter på knappen Rediger og vælge farve ved Tidsstempel eller Colour By Property indstilling og vælge en ejendom, MIN og MAX værdi rækkevidde og vælge farver, dog kun List, Integer, Decimal, boolesk eller dato / tid data type egenskaber vil farve. Hvis kollapsede cellen vil være farvet i henhold til den gennemsnitlige ejendomsværdi af forbindelserne. I stedet for et 'X', kan ejendomsværdier for cellerne være vist ved at klikke på Indstillinger 'tandhjul' øverst til højre i matricen værktøjslinjen og vælge Vis Værdi Indstillinger ... og derefter på knappen Rediger og vælge Vis ejendom indstillingen og vælge en ejendom.

Direkte forbindelser matrix viser Servere hvor Ansøgninger vært med farvelægning og en ejendom bliver vist i stedet for den generiske 'X'

- ELLER -

»Indirekte« tilslutninger matricer

6. Svælgeen sekvens af forbindelse typer og komponenttyperpå højre og venstre side af den menu, der vises, hvis du ønsker at se i "celler" af matricen, hvis enn indirekte vej tilsluttede komponentereksisterer fra Lodret/ 'række"Del af matricen til Vandret/ 'kolonne"Del af matrixen.

Note

Enhver gyldig sti, der indeholder de elementer, der er valgt i stien menuen wsyge blive vistuanset retningen af ​​de underliggende forbindelser, men ved valg af den vej, først og sidste elementer valgt skal være forbindelsestyper. Endvidere bestille De elementer, der er blevet valgt, er vist med en numerisk præfiksi kvadrat ('[]') konsoller og en given type kan medtages mutliple gangei stien (som angivet ved den numeriske præfiks). Fortløbende udvalg af typer komponent eller forbindelsestyper fortolkes som en 'ELLER'sti og hierarkiet af vedhæftede komponenter kan eventuelt medtages ved at kontrollere den "Søg også Attachment forældre / børn"Afkrydsningsfelt. Skift Kilde og Håndvaskkomponenttypegodkendelse markeringer for at se stier i den modsatte retning.

7. Matrixen vil blive befolket med etsti / samling af komponenteri cellerne, hvis der er en sti fra Lodret/ 'række'komponent i matricen til Vandret/ 'kolonne"Del af matrixen.

Note

For store matricer kun et maksimum på 100 rækker eller kolonner (herunder kollapsede rækker / kolonner) vil blive vist på et tidspunkt som det fremgår af "R" og "C" indikatorer i øverste venstre header celle hhv. For at se yderligere rækker bruge rullepanelerne. På ethvert tidspunkt kan du dobbeltklikke på den Lodret/ 'række' eller Horizontal / 'kolonne' komponent overskrifter og springe tilde tilsvarende komponenter i Explorer-vindue.Forældrene til den vertikale/ 'række' og Vandret/ 'kolonne' komponents er også eventuelt vist som overskrift rækker / kolonner med en grå overskrift titel. Når kollapsede (ved en enkelt klikke på overskriften celle), hvis nogen børn stier eksisterede derefter et 'X' vil eventuelt blive vist, hvis alle børn blev fastgjort eller O vil eventuelt blive vist hvis kun nogle af børnene havde stier. De indirekte kurvekomponenter kan være farvet ifølge en ejendomsværdi af komponenterne ved at klikke på Indstillinger 'tandhjul' øverst til højre i matricen værktøjslinjen og vælge Farveindstillinger ... og derefter på knappen Rediger og vælge farve ved Tidsstempel eller Colour By Property indstilling og vælge en ejendom, MIN og MAX værdi rækkevidde og vælge farver, dog kun List, Integer, Decimal, boolesk eller dato / tid data type egenskaber vil farve. Ejendom værdier for de indirekte kurvekomponenter kan være vist ved at klikke på Indstillinger 'tandhjul' øverst til højre i matricen værktøjslinjen og vælge Vis Værdi Indstillinger ... og derefter på knappen Rediger og vælge Vis ejendom indstillingen og vælge en ejendom.

Indirekte forbindelser matrix, som viser de programmer, der implementerer en given service af Institut

Til filteren matrix visning i ABACUS

1. Sørg for, at du har en ny Matrixafbildning åben.

2. Klik på Filter Axes 'tragt' øverst til højre i matricen værktøjslinjen.

3. På Source og / eller vasken fanerne tilføje Navn, Ejendom, Beskrivelse, Hierarkiet eller Standard filtre ved at klikke på knappen Tilføj, vælge en ejendom om nødvendigt og klikke Okay. Vælg de relevante indstillinger i panelet Nøgleord / Produkter ved hjælp af logik / syntaks, som beskrevet i nedenstående note. Eftersynet Panelet vil automatisk opdatere til viser resultaterne af aktuelle sæt filtre.

Note

For Tidsstempel, Hierarki Path, Name eller Beskrivelsefiltre eller Tekst, Heltal, Decimal, boolesk eller Dato / tidejendom filtre matching udføres, som om '*' jokertegn anvendes automatisk før og efter eventuelle strengværdier så en indgang af 'kat' (uden anførselstegn) ville omfatte rækker med 'bobkat','katkvinde "eller" ansøgkation 'osv Multiple / "eller" kan indtastes værdier på nye strækninger ved hjælp af Ctrl + Enter. For Heltal og Decimal ejendom filtre 'og' logik kan indgå hjælp '&"(Uden anførselstegn), og større end / kan mindre end osv logik inkluderes bruger '> =','>','<' og '<="(Uden anførselstegn), f.eks '> = 50000 & <90000'. Ikke-tomme værdsatte rækker kan inkluderes ved at indtaste '(Ikke-Blanks)"(Uden anførselstegn), og Blank værdsatte rækker kan inkluderes ved at indtaste '(Blanks)"(Uden anførselstegn). For Standarder eller Liste ejendom filtrerer Den "(Select All)" afkrydsningsfeltet, vil gøre det muligt for alle de andre afkrydsningsfelter i realiteten, herunder alle de tilgængelige elementer. Den "(Ikke-Blanks)" afkrydsningsfeltet vil omfatte alle ikke-blank ejendom værdiansættes elementer. Den "(Blanks)" afkrydsningsfeltet vil omfatte enhver tom ejendom værdsatte elementer. Og afmarkere nogen specifikke værdsat afkrydsningsfelter automatisk fravælge "(Vælg alle)« og »(Ikke-Blanks)» afkrydsningsfelterne for konsistens. Og endelig, alle filtre er som standard tilfældet ufølsom, så 'kat' (uden anførselstegn) ville omfatte elementer med 'kat', 'Kat' eller 'kat' etc. For små bogstaver matching, indtaste '(Sag)"(Uden anførselstegn), før strengen f.eks «(Sag) Kat '(uden anførselstegn), ville kun indeholde elementer med' Kat 'i dem.

At udfylde hjælp af en matrix visning i ABACUS

Note

Du kan kun tilføje / fjerne forbindelser, hvor en enkelt forbindelse typen er anvendt til Sti beskrevet ovenfor.

1. Til tilføje en forbindelseaf den valgte type mellem et Lodret/ 'række'Komponent og en Vandret/ 'kolonne"Komponent i matricen, hvor et 'X' ikke allerede findes(eller en vist ejendomsværdi - se note ovenfor)Dobbeltklik på cellen. Et 'X' skal vises (eller en ejendomsværdi - se note ovenfor) og en forbindelse vil blive oprettet på det øverste niveau i den Connections kollektion for den valgte arkitektur.

Note

Forbindelsens navn vil være det forbindelsestype navn som pr indstilling forbindelsestypen af ​​matricen, og hvis en ejendom værdi bliver vist i stedet for et 'X' standardværdien for ejendommen vil blive vist.

2. Til redigere en vist ejendomsværdipå sammenhængen mellem a Lodret/ 'række'Komponent og en Vandret/ 'kolonne"Del af matrixenDobbeltklik på cellen, eller højreklik på cellen og vælg Rediger Value ... og redigere værdien i dialogen Skift Value.

3. Til fjerne en forbindelse,af den valgte type mellem et Lodret/ 'række'Komponent og en Vandret/ 'kolonne"Komponent i matricen, hvor et 'X' findes allerede(eller en vist ejendomsværdi - se note ovenfor), højre-Klik på cellenog vælge Afbryd. X bør forsvinde, og forbindelsen vil blive slettet fra projektet.

At gemme / Gem som aMatrixafbildning

Note

Mens alle Arkitekt brugere kan oprette Matricer at redde dem og / eller deres indstillinger bruger licens brug Designeren tilføjelse formåen. Dette er for at "beskytte" konfigurationen af ​​eksisterende matricer, der kan deles af mange brugere. Men Arkitekt bruger uden Designer add-on kan stadig vælge at 'Save As' eventuelle nye indstillinger til en ny matrix. Og selvfølgelig alle brugerlicenser kan vælge at "Kassér" eventuelle ændringer i en eksisterende matrix. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du har brug Designeren tilføjelse evne.Og husk, det er kun indstillingerne for Matrix, alle redigeringer foretaget data i Matrix øjeblikkeligt anvendt på lageret, uanset.

1. Sørg for, at du har en ny Matrixafbildning åbenog du har foretaget de nødvendige ændringer.

2. I Matrixafbildningværktøjslinjen klik på længst til venstre Spare Matrixknappen for at gemme Matrixafbildning og eventuelle formatering ændringer.

Note

Hvis du ikke har en Gem-knappen i Matrixafbildning værktøjslinjen så du ikke har Designer add-on, og du er kun i stand til Gem somnogen indstillinger ændres til en ny matrix, når du går til at lukke eksisterende matrix.

3. Hvis de Matrix Navndialogboks, der vises (grund til at være en ny matrix) indtaste et navn til matrixog tryk Okay.

Til eksport til MS Excel-matrix

1. Sørg for, at du har en Matrixafbildning åben.

2. Klik på Eksport til Excelknap på værktøjslinjen.

3. Vælg et filnavn for at gemme MS Excel matrix som. Klik Spare.

Note

Som standard den eksporterede MS Excel matrix filnavn vil være Matrix navnet suffiks af Arkitektur navn i parentes, fx »Ansøgninger vært på servere (2014 Aktuel) .xlsx«. Du kan ændre noget af dette, herunder om filformatet er at være .xlsx eller .xls.

Formatering matrixeksporteres som standard, men for store matricer dette kan resultere i eksporten bliver ganske langsomt. I overensstemmelse hermed, Tools | Valgmuligheder ...derefter de Matrixfane,du er i stand til at reducere mængden af ​​formatering, der eksporteres som vist på fanen Matrix nedenfor, og dermed fremskynde eksport.

Matrix eksport optioner

4. En Export Afsluttet dialogboks vises. Klik Okay.

Eksporteres til MS Excel-matrix

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Befolker din arkitektur fra Visio | Befolker din arkitektur fra Excel


Befolker din arkitektur fra Microsoft Access

Navigation: Befolke din arkitektur> Befolke fra Microsoft-produkter>

Befolker din arkitektur fra Microsoft Access

Send kommentarer om dette emne.

Du kan eksportere din arkitektur til Microsoft Access til at udføre generelle formål beregninger, manipulationer eller rapporter på din arkitektur. Du kan derefter importere arkitekturen tilbage i ABACUS.

Note

Open fra Access / Eksportér til database funktion kræver, at Microsoft Access 2000eller nyere er installeret på computeren.

For at eksportere din arkitektur til Microsoft Access

1. Sikre, at du har en ABACUS filåben, Explorervises, og en arkitekturtilsat.

2. Vælg Filer | Eksportere | Til Database.

3. Vær opmærksom på dialogen advarslen som beskrevet ovenfor og klik på Ja for at fortsætte.

4. Vælg en placering og et filnavn for databasefilen.

For at importere den manipulerede arkitektur ind ABACUS

1. Sikre, at du har ABACUS åben.

2. Vælg Filer | Ny og vælg Fra Accessfra den dialogboks, der vises, og klik på OK.

3. Browse for databasen fil, du ønsker at importere.

ABACUS 'MS Access Database Schema

ABACUS har på sit hjerte enn ontologi / meta-meta-model, der består af komponenter, tilslutninger og begrænsninger. Denne "CCC" tilgang stammer fra forskellige standard tilgange, der er udviklet fra 1960'erne og fremefter kulminerede i international standard IEEE 1471, som skønnede udvikling grundlæggere har bidraget til. Følgende primitiver anvendelse

1. ABACUS indeholder Biblioteker af Standarder(eller standarder), Komponent og Forbindelsestyper, Begrænsninger, Synspunkter, Skabeloner (eller Mønstre) og mange Arkitekturer.

2. Standarder, Typer og Synspunkter majvære logisk Grupperetfor nemheds skyld.

3. Arkitekturer kan indeholdemange efterkommer Arkitekturer(eller Evolutions).

4. Hver Arkitektur indeholder mange Komponenter og Tilslutningerfor visse Typerog forskellige Visninger.

5. Komponenter og Tilslutninger måske nedbrydes til Delkomponenter og Sub-forbindelser.

6. Hver Komponent er fastgjort tilhvilket som helst antal Tilslutningermen hver Forbindelsekan kun være fastgjort tilhøjst to Komponenter.

7. Komponenter og Tilslutninger kan have Standarder med Egenskabersåsom information, ydeevne, pålidelighed Omkostninger mv

8. Arkitekturer, Komponenter og Tilslutninger kan have bestemt Egenskabersåsom information, ydeevne, pålidelighed Omkostninger mv

9. Begrænsninger kan eksisterer mellem Komponenter eller Tilslutninger eller mod Egenskaber.

10. Skabelonerer standard sammensætninger af Komponent og Forbindelsestyper.

11. Synspunkterer standard sammenslutninger af Komponent og Forbindelsestypertil anmærkninger.

12. Visningerer visuelle repræsentationer af Komponenter og Tilslutninger.

Følgende MS Access Entity Relationship Diagram (ERD) dokumenterer kerneArkitekturer, Evolutions, Komponent / Forbindelsestyper (og grupper), Komponenter / Forbindelser og Sub komponent / Connection begreber.

Core databaseskema

Note

Referentiel integritet er ikke blevet håndhævet på forholdet mellem komponenter bordet og Connections tabel (for "vedhæftet" mellem en given kilde eller Sink Component og en forbindelse). Dette skyldes, at en forbindelse kan eksistere uden komponent vedhæftede filer. Vi kunne have tilføjet en 'vedhæftet' tabel, men af ​​hensyn til enkelthed besluttede mod det. Det betyder naturligvis, at enhver redigering af Component Ids eller sletning af Component rækker alle sammen vil resultere i ukorrekte data. ABACUS vil håndtere enhver ukorrekthed på import ved at ignorere de forkerte data.

Følgende MS Access ERD dokumenterer Egenskaberkoncepter for arkitekturer, Komponent / Connection Typer og Komponenter / Forbindelser.

Egenskaber databaseskema

Følgende MS Access ERD dokumenterer Standarderkoncept for arkitekturer, Komponent / Connection Typer og Komponenter / Forbindelser.Bemærk: Tabellerne stadig bruge udtrykket »Gennemførelse« som pr tidligere versioner af ABACUS.

Standarder databaseskema

Følgende MS Access ERD dokumenterer Begrænsningerkoncept for Component / Forbindelsestyper.

Begrænsningerdatabaseskema

Følgende MS Access ERD dokumenterer Synspunkter koncept for Arkitekturer.Bemærk: Tabellerne stadig bruge udtrykket »TwoDTempl« som pr tidligere versioner af ABACUS.

Synspunkterdatabaseskema

Følgende MS Access ERD dokumenterer Katalogerkoncept for Arkitekturer.

Katalogerdatabaseskema

Følgende MS Access ERD dokumenterer Matricerkoncept for Arkitekturer.

Matricerdatabaseskema

Følgende MS Access ERD dokumenterer Diagrammerkoncept for Arkitekturer.Bemærk: Tabellerne stadig bruge udtrykket »TwoD« som pr tidligere versioner af ABACUS.

Note

Den Komponent / Forbindelsestype at Stencil form kortlægning og Freeform form dele af MS Access ERD er udeladt for klarhed.

Diagrammerdatabaseskema

Følgende MS Access ERD dokumenterer 3D-visningerkoncept for Arkitekturer.

3D-visningerdatabaseskema

Følgende MS Access ERD dokumenterer Diagrammerkoncept for Arkitekturer.

Diagrammerdatabaseskema

Følgende MS Access ERD dokumenterer Dashboards begreb.

Dashboardsdatabaseskema

ABACUS 'MS AccessForespørgsler

Inkluderet med MS Access Database er flere nyttige forespørgsler som følger;

· Comps ved Redskaber- Denne forespørgsel viser alle komponenterne i projektet (ved arkitektur og type) og indeholder alle de egenskaber som kolonner. Brug denne forespørgsel med filtre / kriterier på typen af ​​komponenter og / eller arkitektur til at producere 'typiske' tabeller for hver komponent type med deres egenskaber.

· Kønssygdomme ved Redskaber- Denne forespørgsel viser alle de standarder, der er i brug, antallet af forekomster af standard og indeholder alle de egenskaber som kolonner. Brug denne forespørgsel som en standard katalog.

· Redskaber fra Typer- Lister Denne forespørgsel alle dele egenskaber og deres% komplet med hver komponent type som kolonner. Brug denne forespørgsel for at bestemme, hvorvidt specifikke egenskaber opretholdes.

· Typer af Props- Denne forespørgsel viser alle de komponenttyper og omfatter% færdig af alle egenskaber som kolonner. Brug denne forespørgsel for at bestemme, hvorvidt specifikke egenskaber opretholdes.

· Type Count- Denne forespørgsel viser alle de komponenttyper og omfatter antallet af forekomster af hver type i faldende rækkefølge. Brug denne forespørgsel til at bestemme populariteten af ​​hver type i projektet.

Et notat om arbejdet med Memo felter i MS Access

De komponenter, tilslutninger og standarder Navn felter i tabellerne er defineret som memo felter for at give mulighed for et ubegrænset antal tegn, som pr ABACUS. For komponenter og forbindelser dette medfører par spørgsmål, fordi de også har et unikt id vilkår for henvisninger, men for Standarder dette medfører et par problemer, når de forsøger at slutte tabeller, fordi du ikke kan deltage memo felter i MS Access. Alternativt kan du indstille et WHERE-udtryk kriterier for at opnå den samme effekt, som vist i Visual Query Builder og tilsvarende SQL uddrag under denne liste ud hele nedarvede Standarder egenskaber til alle komponenter i den eksporterede ABACUS projektet.

Memo feltet 'slutter sig til "i Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

FRA Komponenter INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) og (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), implementeringer INNER JOIN ImplementationProperties PÅ Implementations.Id = ImplementationProperties.Implementation_Id

HVOR (((ComponentImplementationLinks.Name) = [implementeringer] [navn]).);

Memo feltet 'slutter sig til "i SQL

Et notat om automatisk genererer ABACUS id'er i MS Access

Forskellige ABACUS MS Access tabeller kræver en unik lang heltal ID så en enkel VB fremgangsmåde er tilvejebragt for at hjælpe i frembringelsen af ​​disse. To metoder ResetCounter () og GetNextCounter () er tilvejebragt inden ABACUS 'MS Access DB og deres anvendelse er som følger; ResetCounter () vil sætte tælleren tilbage til 0. GetNextCounter () vil vende tilbage næste tæller i sekvensen.

Metoderne udnytte en MS Access "særhed" at selv hvis du kalder ResetCounter () metode for hver række indsatsen (dvs. når du også køre GetNextCounter () funktion), fordi ResetCounter () funktion ikke har nogen parametre det bare kører det én gang og derfor ikke nulstille tælleren for hver række insert. Og også på grund af det samme 'særhed' du nødt til at passere eventuelle gamle kolonne variabel til GetNextCounter () til at narre den til at køre hver gang.

Der er også et trick for at være i stand til at køre ResetCounter () funktion i et indstik i SQL-sætning, fordi du ikke kan blot har det sidder der som en kolonne i sig selv, ligesom hvis det var en udvalgt forespørgsel. Det anbefales at gøre ResetCounter () kald del af en af ​​de andre områder, ved at sammenkæde det til ende, som det altid returnerer null alligevel.

Nedenfor er en typisk SQL brug af de metoder til at tilføje en liste over komponenttyper fra en tabel / forespørgsel kaldet "Component Type List '.

INSERT INTOComponentTypes (Id, Navn, Beskrivelse)

SELECT GetNextCounter ([Component Type List] .name)AS id, [Component Type List] .name som navn, [Component Type List] .description & ResetCounter ()AS Beskrivelse

FRA[Komponent Type List];

ABACUS ID / Tæller generation i SQL

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Befolker din arkitektur fra Visio | Befolker din arkitektur fra Excel


Befolker din arkitektur fra Microsoft Visio

Navigation: Befolke din arkitektur> Befolke fra Microsoft-produkter>

Befolker din arkitektur fra Microsoft Visio

Send kommentarer om dette emne.

Du kan importere din arkitektur fra Microsoft Visio. Figurer i din Visio tegning vil blive importeret som komponenter i ABACUS. Forbindelser i din Visio tegning vil blive importeret som forbindelser, og tegningen i sig selv vil blive importeret til ABACUS som et diagram. Desuden vil enhver brugerdefineret Ejendomme i din Visio tegning importeres som ejendomme med Sortér Key kortlagt til Property type, Label til Property Navn og værdi til ejendomsværdien.

Note

Importer fra Visio funktion kræver, at Microsoft Visio 2003eller nyere er installeret på computeren.

For at importere dine Visio-tegninger i ABACUS

1. Sikre, at du har ABACUS åben.

2. Vælg Filer | Ny og vælg Fra Visiofra den dialogboks, der vises, og klik på OK.

Note

Hvis du ønsker at importere til en eksisterende ABACUS projekt derefter enten højreklikke på Komponenter noden i en arkitektur, eller højreklik på en individuel komponent i en arkitektur, og vælg derefter Importer | Fra Visio.

3. Søge efter Visio fil, du ønsker at importere.

Note

Nedenfor er nogle enkle regler eller anbefalede praksis, når der opføres (eller ændrer) en MS Visio tegning til import i ABACUS.

1. Linjerne eller forbindelser skal være faktiske konnektorer, IKKE former.

· Ellers ABACUS vil bare importere dem som komponenter og derfor vil de ikke blive "knyttet" til noget.

· Hvis du har brug for at gøre nogle "smart" routing (andet end en lige linje ie) derefter bruge Dynamisk stik på Basic Former stencil vil ABACUS importere routing / ankerpunkter fint.

· Prøv at undgå at bruge "Ring netværk" og "Ethernet" figurer fra netværket og eksterne enheder stencil, der giver masser af komponenter, der skal "forbindes" til det. Mens vi importerer de vedhæftede filer fint som forbindelser den oprindelige form er stadig "udvidet" for at afspejle de vedhæftede filer. Brug adskille en separat "hub / bus" form (uden stik "ben") og derefter udtrykkeligt forbinde hver komponent til navet / bus med separate stik.

· Hvis en linje eller forbindelse opfører sig som en form, højreklik på den og gå til 'Formater | Behavior ... ", og sørg for, at Interaction stil er indstillet til Line (1-dimensionale).

2. Komponenterne skal være figurer IKKE stik.

· Ellers ABACUS vil bare importere dem som forbindelser, og derfor al information formen vil blive tabt.

· Hvis en komponent opfører sig som et stik, skal du højreklikke på den og gå til 'Formater | Adfærd ... ", og sørg for, at Interaction stil er indstillet til Box (2-dimensionelle).

3. Connector ender nødt til at være knyttet til former, ikke flyder rundt i baggrunden bag formen.

· Hvis du ikke tilslutter stikkene til formerne derefter ABACUS har ingen mulighed for at vide, at du har til formål at knytte den givne stik til formen / komponent og derfor det vil efterlade den ende af forbindelsen un-vedlagt.

4. Etiketter til figurer skal være (hvis muligt) den indbyggede tekst label til formen, ikke en separat tekstboks på tegningen.

· Separate tekstbokse vil blive importeret af ABACUS som komponenter i deres egen ret, og mens du kan flette "mærke" komponent med den virkelige komponent i ABACUS, eller bare konvertere "mærke" komponent til en freeform form (dvs. ikke en komponent i sig selv) er det bedst at undgå disse trin.

5. Brug det samme base form for hver forekomst af den samme type, vær ikke doven og bruge rektangel tider og box andre fra forskellige form stencils.

· ABACUS bruger basen form og sin base farve til entydigt at identificere de indgående og forbindelsestyper i tegningen, så en "rød firkant" og en "rød boks" vil blive importeret som to separate komponenttyper. Disse komponenttyper kan flettes i ABACUS, men det er bedst at undgå disse trin.

6. Fuldt ud indkapsle "børn" figurer indenfor deres "forældre", IKKE lade dem hænge ud over kanten.

· ABACUS vil opdage enhver form, der er helt indkapslet i en anden form som et barn af den forælder, så sørg for hele form, inklusive etiketten del, er vedlagt.

7. IKKE placere en form overlappende to andre figurer.

· Hvis en figur overlapper to andre former, det være sig en "gruppering" / baggrund rektangel eller på anden måde, vil det blive importeret af ABACUS som en komponent, der er et barn af hverken overlappede former, men så snart du vælger den komponent i ABACUS 'tegneværktøj på grund af den øverste venstre er komponenterne referencepunktet, vil det blive et barn af venstre overlappede form / komponent.

8. Prøv at minimere brugen af ​​tekst noter på tegningen, fordi disse vil blive importeret som komponenter i deres egen ret, og bliver nødt til at blive konverteret til freeform figurer i ABACUS. Tænk over, om de virkelig er navnet på en eksisterende komponent eller forbindelse.

9. Mens ABACUS understøtter rig / farvede / vektor-baserede former, forsøge at minimere brugen af ​​bitmaps, udenlandske former og Enhanced Metafiler til figurer som ABACUS gør i dagikkeunderstøtter disse typer. De vil blive importeret som enkle hvide rektangler.

10. Prøv at undgå linjeskift (shift-retur) i etiketter, som de er importeret og vises som en særlig "[]" tegn i ABACUS for komponenten navn.

11. Forsøge at minimere de forskellige farver, der anvendes til former af samme type. Som nævnt ovenfor, bundfarve og base form entydigt identificerer komponent og forbindelsestyper så jo mere variation er der den mere ophørende og konsolidering, der bliver nødt til at ske efter import i ABACUS.

12. Vær forsigtig med fyldte former, fordi hvis en figur er fyldt hele vejen til hjørnerne så farve det senere i ABACUS vil ikke have nogen effekt.

13. For komplekse line-baserede figurer skal du bruge en polygon, som er skabt ved at have linjer startende hvor den forrige slutter, og derefter i sidste ende gå tilbage til startpunktet. Hvis det ønskes, kan du bruge fyld og linjebredde at gøre polygon ligne en "pil" eller hvad form du ønsker.

14.. Sørg for, at figurerne id i MS Visio er meningsfuldt ikke bare Shape.xx. Dette kan redigeres ved hjælp af højre-klik "Vis ShapeSheet", som er tilgængelig i MS Visio developer mode (aktiveret gennem Funktioner | Indstillinger i MS Visio).

15. Ellipser og buerinden figurerer understøttet i ABACUS men NURBS og noter i øjeblikket ikke understøttet.

16. Sørg for, at hele formen er grupperet i MS Visio, eller det vil blive importeret som flere komponenter / typer.

17. Prøv at minimere brugen af ​​roterede figurer inden subshapes, da de nogle gange ikke vil blive importeret korrekt.

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Befolker din arkitektur fra Access | Befolker din arkitektur fra Excel


Befolker din arkitektur fra Microsoft Excel

Navigation: Befolke din arkitektur> Befolke fra Microsoft-produkter>

Befolker din arkitektur fra Microsoft Excel

Send kommentarer om dette emne.

Du kan importere din arkitektur fra et Excel-regneark (.xls eller .xlsx fil). Excel importør giver dig mulighed for at kortlægge lister over komponenter og forbindelser med typer, standarder, ejendomme og standard egenskaber ved at vælge kolonnerne i regnearket, der indeholder de relevante data.Det er dog en mere avanceret teknik end den anbefalede tilgangfor import fra MS Excel, som er via kataloger som beskrevet her .

Note

Import fra / eksport til Excel funktion kræver, at Microsoft Excel 2003eller nyere er installeret på computeren.

Den vigtigste funktion af Excel Importør er at give dig mulighed for at definere en konfigurationsfil (dvs. den hierarkiske struktur i din arkitektonisk model). Konfigurationsfilen gemmer en tidligere gemt kortlægning fra en Excel-fil til en ABACUS fil. Når defineret, er den gemte konfigurationsfil senere brugt til yderligere import af og eksport til .xls-filer.

Note

De viste i afsnittene nedenfor trin er specielt til brugere, der endnu ikke har definere og gemme en konfigurationsfil og importerer fra Excel for første gang. Du skal oprette og gemme en konfigurationsfil til at bruge eksport til excel funktion.

For at importere et Excel-regneark til ABACUS

1. Sikre, at du har ABACUS åben.

2. Vælg Filer | Ny og vælg mellem Excelfra den dialogboks, der vises, og klik på OK.

Note

Hvis du ønsker at importere til en eksisterende ABACUS projekt derefter enten højreklikke på Komponenter noden i en arkitektur, eller højreklik på en individuel komponent i en arkitektur, og vælg derefter Importer | Fra Excel.

3. De Import Excel regnearkVinduet vises

Import Excel regneark Vindue

4. Klik på Åbn Excel-filikon og gennemse til Excel-fil, du ønsker at importere.

5. Vælg Arbejdsarkdu ønsker at importere fra drop-down boks.

Note

Efter åbning din Excel-fil, kan du bruge Data Eksempelfane for at se kolonner og første 25 rækker af dit regneark. Herfra kan du få de kolonne numre er nødvendige for at udfylde Komponenter og Tilslutningerfane.

Du kan også vælge, om du vil have komponenter i et Excel-regneark, der skal importeres med tilfælde følsomhed. Du skal blot sætte kryds i Import med tilfælde følsomhedmulighed (som standard er dette altid afkrydset), og regnearket vil blive importeret i overensstemmelse hermed.

Prøve Excel-fil

Note

I dette eksempel vil vi importere en simpel infrastruktur og People arkitektur fra excel data vist i ovenstående skærmbillede. Forbindelser vil blive foretaget mellem "Mennesker ansvarlig" og "Servere", at de mennesker administrerer.

For at udfylde fanen Komponenter

Dette afsnit er for at definere de komponenttyper og den hierarkiske struktur for konfigurationsfilen.

1. Vælg Komponenterfane. Omdøbe Indstil IDved at tilsidesætte (nul) værdi

Note

Denne funktion gør det muligt at definere helt anderledes Indstillerfor funktionelt separate komponenter. Som det fremgår af skærmbilledet nedenfor, kan du ønsker at skelne din infrastruktur komponenter fra dine People komponenter. Hvis der er relationer (forbindelser) mellem disse separate sæt af komponenter, kan de defineres i henhold til den Tilslutningerfane. Senere i dette eksempel vil vi definere forbindelser af typen "administrerer" mellem Infrastruktur og People Indstiller.

Du kan også vælge, om du ønsker at tilføje en top-niveau Grupperingkomponent til alle elementer i sættet. Du skal blot sætte kryds i Gruppe Under Indstil IDoption (som standard dette ikke er markeret), og regnearket vil blive importeret i overensstemmelse hermed.

Tildeling Indstil ID

2. Når Indstillerer blevet defineret vælge Sætdu ønsker at udfylde og udbygge ved at klikke på [+] skilt.

3. Vælge Niveauer af komponenter i dette sætfra udvidet liste.

4. De Komponent hierarki Sets: Set IDvindue vises for at Sæt.

Komponent Hierarki og Tildeling af værdier (Indstil ID: Infrastruktur)

5. Omdøbe Niveau nummerkolonne i tvingende den (nul) værdi.

Note

De Niveau nummerkolonne giver dig mulighed for at tildele et hierarki til dine komponenter. Hvert niveau svarer til et lag inden din arkitektur, hvorved det første niveau er det øverste mest forælder niveau. For eksempel, niveau nummer "1" svarer til den øverste hierarkiske lag, Level nummer "2" er barn af niveau nummer "1" og så videre.

6. Vælg og tildele den relevante kolonne fra Excel-regneark til hver Niveau nummerved at indtaste den under Komponent Column kolonne.

Note

Du kan vælge at udelukke visse rækker, som du ikke ønsker at være repræsenteret i din arkitektur. Disse kan være kolonneoverskrifterne, tomme rækker, etc. For at udelukke rækker bruger Rækker til Udeluk:tekstfeltet nær øverste højre hjørne af vinduet. I dette eksempel har vi udelukket række 1, fordi det indeholder vores kolonneoverskrifterne.

7. Du kan vælge at tilføje beskrivelser til dine komponenter ved at overskrive den (nul)værdi i Beskrivelse kolonne.

Note

Denne beskrivelse er, hvad der vil blive vist i ABACUS under Generelle egenskabersektion | Beskrivelse felt.

8. Hvis en given regneark kolonne har mere end én komponent per celle (indtastes med Alt-Enter eller CHAR (10) kommando) derefter kryds i afkrydsningsfeltet nedenunder Behandl nye linjer som separate komponenter. Hver linje vil blive importeret som separate komponenter.

Tip

For at importere en »matrix« fra en samling af kolonner, hvor et »X« i en given »matrix« celle (cellerne B2: D2 sige) indebærer, at den komponent, angivet af rækken (i celle A2 sige) er forbundet til komponenten specificeret af kolonnen »overskrift« (i række 1 sige), kan en simpel formel anvendes. Indtast følgende formel for hver række i en kolonne uden for matrix-celler (kolonne F sige); = HVIS (B2 = "", "", B $ 1 & CHAR (10)) & HVIS (C2 = "", "", C $ 1 & CHAR (10)) & HVIS (D2 = "", "", D $ 1 & CHAR (10)). Derefter oprette en forbindelse indstillet som beskrevet nedenfor mellem komponenterne specificeret af rækken (i kolonne A sige), og dem, der er beskrevet af denne formel (i kolonne F sige). Vær sikker på at tjekke Behandl nye linjer som separate komponentermulighed, når komponenterne fra formlen er importeret. For mere avanceret matrix import, herunder overskrifter med flere lag af hierarkiet eller celler med forskellige værdier end blot en almindelig 'X', skal du kontakte Skønnede udvikling Support .

9. Udfylde resten af ​​kolonnerne efter behov.

Note

Du kan vælge at få den type fra søjlens rækker ved at markere afkrydsningsfeltet under Få type fra kolonnekolonne og indtaste den relevante kolonne fra Excel-regneark under Komponent Type Værdi eller kolonne kolonne. Dette vil importere alle komponenter i kolonnen og sæt dem til den type defineret i kolonnen. Alternativt og som med skærmen skudt over og under, du kan vælge at bruge en fast / prædefineret typen navn ved at indtaste navnet type under den Komponent Type Værdi eller kolonnekolonne og sikre afkrydsningsfeltet er un-kontrolleret.

Komponent Hierarki og Tildeling af værdier (Indstil ID: People)

Note

I dette eksempel ønsker vi at have vores netværk og mennesker grupperinger på niveau 1 i arkitektur. På niveau 2 ønsker vi at have vores servere og folk, der er ansvarlige for at administrere disse servere. De Komponenterklistermærket er udfyldt i overensstemmelse hermed, som vist i de to skærmbilleder ovenfor. I det første skærmbillede over vi har defineret niveau 1 (netværk grp) og niveau 2 (server) komponenter til infrastruktur Sæt. Og i screenshot umiddelbart over vi har defineret niveau 1 (folk gruppering) og niveau 2 (ansvarlige) komponenter til folket Sæt.

Alternativt, for MenneskerSet, snarere end at bruge kolonne C som en People gruppering, vi kunne have brugt Gruppe Under Indstil IDoption på den øverste fane niveau komponenter og så bare indtastes ét folk sub-niveau fra kolonne D. Dette er vist i skærmbilledet nedenfor.

Komponent Hierarki og Tildeling af værdier ved hjælp af gruppe under Set ID mulighed (Indstil ID: People)

10. Når komponenterne er blevet identificeret, skal du vælge den komponent niveau, du ønsker at udfylde egenskaber og / eller standarder for og udvide ved at klikke på [+] skilt.

11. Vælge Egenskaber af komponenter på dette niveaueller Component Standards på dette niveaufra udvidet liste og udfylde de relevante kolonner efter behov.

Befolker komponenter

Note

Egenskaber af komponenter på dette niveaugiver dig mulighed for at definere egenskaberne for komponenter på det valgte niveau. Component Standards på dette niveaugiver mulighed for at definere standarder og deres standard egenskaber for komponenter på det valgte niveau.

12. Gentag trin 2 - 11indtil alle dele niveauer er blevet befolket for alle definerede Indstiller. Brug pil tilbage nær det øverste højre hjørne af vinduet for at navigere tilbage til Indstillersom du har defineret tidligere.

For at udfylde fanen Forbindelser

Dette afsnit er for at definere de typer tilslutning og den hierarkiske struktur for konfigurationsfilen.

1. Vælg Tilslutningerfane. For hvert sæt af forbindelser, du nødt til at identificere den komponent Sætat du ønsker at være kilden komponenter og komponenten Sætdu ønsker at være destinationen komponenter.

2. Under Kilde Component Set IDindtaste Sætnavn, som svarer til den Sættidligere i den definerede Komponenterfane. Under Kilde komponentniveau nummerindtaste det nummer, der svarer til den komponent niveau, du ønsker at oprette forbindelse ved kilden ende af forbindelsen.

3. Nu vælge hvilken komponent gruppe vil være på destinationen ende af forbindelsen. Under Destination Component Set IDindtaste Sætnavn, som svarer til den Sætdefineret i Komponenterfane. Under Destination komponentniveau nummerindtaste det nummer, der svarer til den komponent niveau, du ønsker at oprette forbindelse til destinationen ende af forbindelsen.

Note

I dette eksempel ønsker vi at forbinde de ansvarlige for at administrere servere til de servere, som de administrerer. De ansvarlige blev defineret i Folkerepublikken Sætsom niveau 2 komponenter, mens serverne blev defineret i infrastrukturregistret Sætsom niveau 2 komponenter. De Tilslutningerklistermærket er udfyldt i overensstemmelse hermed, som vist i skærmbilledet nedenfor.

Tilslutninger Fanen Del 1 af 2

4. Hvis du rulle til højre, vil du finde ekstra muligheder for at importere dine forbindelser. Få type fra kolonne og Tilslutningstype Værdi eller kolonnefungerer på samme måde som for Komponenterfane.

5. Hvis Kilde Component Set ID og Kilde komponentniveau nummerer de samme som Destination Component Set ID og Destination komponentniveau nummer(for eksempel hvis du tilslutter den samme komponenttyper, såsom at skabe forbindelse fra servere til andre servere) så er du nødt til at have en anden kolonne i regnearket, der indeholder navnene på disse servere gentages. I denne situation ville du sætte det regneark kolonne i Destination gentaget i kolonne kolonne. Hvis i dette regneark kolonne du har indtastet mere end en tilsluttet komponent per celle derefter kryds i afkrydsningsfeltet nedenunder Behandl nye linjer som separate komponenter.

Tilslutninger Fanen Del 2 af 2

6. Når tilslutningerne er blevet identificeret vælge den forbindelse, du vil udfylde egenskaber og / eller standarder for og udvide ved at klikke på [+] skilt.

7. Vælge Ejendomme til disse forbindelser eller Standarder for disse forbindelserfra udvidet liste og udfylde de relevante kolonner efter behov.

Note

Ejendomme til disse forbindelsergiver dig mulighed for at definere egenskaberne for den valgte tilslutning gruppen. Standarder for disse forbindelsergiver mulighed for at definere standarder og deres standard egenskaber til den valgte tilslutning gruppen.

8. Gentag trin 2 - 7indtil der er defineret alle forbindelsesindstillingerne grupper.

9. Når du er færdig med at definere forbindelsesindstillingerne grupper, skal du klikke på Slutteknappen og din arkitektur vil blive oprettet fra den importerede Excel-fil. Ovenstående eksempel vil resultere i arkitekturen vist i skærmbilledet nedenfor.

Prøve Arkitektur Importeret fra Excel

10. Gem nu kortlagt konfiguration til en fil ved at klikke på Gem konfigurationikon. Din gemte konfiguration kan hentes senere ved at klikke på Åbn en konfigurationikon øverste venstre hjørne af vinduet.

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Befolker din arkitektur fra Access | Befolker din arkitektur fra Visio


Befolker din arkitektur fra Microsoft SharePoint

Navigation: Befolke din arkitektur> Befolke fra Microsoft-produkter>

Befolker din arkitektur fra Microsoft SharePoint

Send kommentarer om dette emne.

Du kan synkronisere din arkitektur medMicrosoft SharePoint-lister. Synkronisering indebærer enten skabe nye SharePoint-lister (og deres kolonner) fra ABACUS typer, deres egenskaber og vedhæftede filer, eller kortlægning af eksisterende SharePoint-lister (og deres kolonner) til ABACUS typer, deres egenskaber og vedhæftede filer, så enten sende indhold fra ABACUS til SharePoint eller SharePoint til ABACUS.

Note

De SharePoint Sync funktion kræver, at en Microsoft SharePoint 2010, 2013 eller SharePoint Online site er til rådighed til at oprette forbindelse til og synkronisere med.Mens funktionen SharePoint Sync kan oprette lister (med kolonner) på et SharePoint-websted fra enhver ABACUS projekt, kan skønnede udvikling også give forskellige SharePoint-websted skabeloner til støtte af standard rammer (f.eks TOGAF, ArchiMate, ITIL osv), så kontakt venligst Skønnede udvikling Support hvis du ønsker denne mulighed.

Til oprette en ny SharePoint-liste og kortlægge den til en ABACUS komponent eller tilslutningstype

1. Sikre, at du har ABACUS åben.

2. Vælge Tools | SharePoint Sync.

3. Klik på Ny kortlægningknap og en SharePoint Kortlægning dialogboks som vist nedenfor vises.

4. Indtast Site URL, brugernavn og adgangskode til SharePoint-webstedet, og klik Forbinde.

Note

En gyldig SharePoint "admin" eller "bidragyder" konto er påkrævet for at synkronisere fra og til SharePoint og en "læser" konto vil kun tillade synkronisering fra SharePoint.

5. Vælg ABACUS komponent eller tilslutningstype at kortlægge fra Vælg type træk ned.

6. Klik på Tilføj nyknappen og derefter for hver ABACUS komponent eller tilslutningstype aspekt, du ønsker at kortlægge en tilsvarende SharePoint felt liste vælge et emne i panelet til venstre og i højre panel indtaste det nye SharePoint-liste navn i New List kolonnen (kun første gang) , så kolonnen navn SharePoint i kolonnen Navn (eller brug standard), og klik Tildel hver gang.

Note

Som minimum at tillade synkronisering af ABACUS EEID, Arkitektur og navn aspekter vil automatisk blive kortlagt til et SharePoint-nummer og to (2) Enkelt tekstlinje (alias Text) kolonner hhv. Disse kan ikke være ikke tildelt. Endvidere kan kun visse ABACUS aspekter øjeblikket kortlægges til visse SharePoint kolonner og kolonnen Type pull-down indstilles automatisk til den ønskede SharePoint kolonnen typen.Nemlig;

· ABACUS 'hierarki Sti til SharePoint Flere tekstlinjer (aka Note) kolonner (Bemærk: SharePoint Enkelt tekstlinje (aka Tekst) kolonner kun støtte 255 tegn, så de ikke er foretrukket),

· ABACUS 'Vedhæftede Komponenter til SharePoint Opslag kolonner (Bemærk: En kortlægning skal allerede findes på en liste for de vedhæftede komponenter selv),

· ABACUS 'Tekst og beskrivelse egenskaber til at SharePoint Flere tekstlinjer (aka Note) kolonner (Bemærk: SharePoint Enkelt tekstlinje (aka Text) kolonner kun støtte 255 tegn, så de ikke er foretrukket),

· ABACUS 'Decimal eller Integer egenskaber til SharePoint Number søjler,

· ABACUS 'List egenskaber til SharePoint Choice kolonner (Note: SharePoint ikke håndhæve de valg værdier, så den liste datatype ikke behøver at blive håndhævet i ABACUS),

· ABACUS 'Dato / tid egenskaber til SharePoint Flere tekstlinjer (aka Note) kolonner (Bemærk: SharePoint dato og tid kolonner kan ikke bruges som endnu på grund af SharePoint s inkonsekvent støtte til tidszone / regionaliseringsbeslutninger indstillinger),

· ABACUS 'booleske egenskaber til SharePoint Ja / (alias Boolean) kolonner Nej.

En ABACUS elements tilhørende standarder ikke kan kortlægges til SharePoint liste kolonner som endnu.

7. Vælge Opret Kortlægning.

Til oprette en ny kortlægning mellem en ABACUS komponent eller tilslutning type og en eksisterende SharePoint-liste

1. Sikre, at du har ABACUS åben.

2. Vælge Tools | SharePoint Sync.

3. Klik på Ny kortlægningknap og en SharePoint Kortlægning dialogboks som vist nedenfor vises.

4. Indtast Site URL, brugernavn og adgangskode til SharePoint-webstedet, og klik Forbinde.

Note

En gyldig SharePoint "admin" eller "bidragyder" konto er påkrævet for at synkronisere fra og til SharePoint og en "læser" konto vil kun tillade synkronisering fra SharePoint.

5. Vælg ABACUS komponent eller tilslutningstype at kortlægge fra Vælg type træk ned.

6. Vælg SharePoint-webstedet listen for at kortlægge fra Vælg Liste træk ned.

7. For hver ABACUS komponent eller tilslutningstype aspekt, du ønsker at kortlægge til dets tilsvarende SharePoint liste kolonne vælge et emne i panelet til venstre og det højre panel henholdsvis, og klik Tildel.

Note

Som minimum at tillade synkronisering af ABACUS EEID, Arkitektur og navn aspekter skal mappes til et SharePoint-nummer og derefter for Arkitektur og Navn til enten Enkelt tekstlinje (alias Tekst) eller flere tekstlinjer (aka Note) kolonner hhv. Indtil dette sker på Mapping knappen Opret, vil ikke blive aktiveret. Endvidere kan kun visse ABACUS aspekter øjeblikket kortlægges til visse SharePoint kolonner.Nemlig;

· ABACUS 'Arkitektur aspekt til en SharePoint Enkelt tekstlinje (alias Tekst) eller flere tekstlinjer (aka Note) kolonner (dette er nødvendigt for indhold specifik kortlægning som beskrevet nedenfor),

· ABACUS 'hierarki Sti til SharePoint Enkelt tekstlinje (alias Tekst) eller flere tekstlinjer (aka Note) kolonner (Bemærk: SharePoint Enkelt tekstlinje (aka tekst) kolonner kun støtte 255 tegn, så eventuelle yderligere tegn vil blive afkortet, og derfor anbefales det at konvertere dem til flere tekstlinjer (aka Note) kolonner i SharePoint før kortlægning),

· ABACUS 'Vedhæftede Komponenter til SharePoint Opslag kolonner (Bemærk: En kortlægning skal allerede findes på en liste for de vedhæftede komponenter selv),

· ABACUS 'Tekst og beskrivelse egenskaber til at SharePoint Enkelt tekstlinje (alias Tekst) eller flere tekstlinjer (aka Note) kolonner (Bemærk: SharePoint Enkelt tekstlinje (aka tekst) kolonner kun støtte 255 tegn, så eventuelle yderligere tegn vil blive afkortet og derfor anbefales det at konvertere dem til flere tekstlinjer (aka Note) kolonner i SharePoint før kortlægning),

· ABACUS 'Decimal eller Integer egenskaber til SharePoint Antal kolonner (Bemærk:. SharePoint Beregnet kolonner kan bruges, men de vil kun være i stand til synkroniseret fra SharePoint til ABACUS Forsøger at synkronisere' til 'en beregnet kolonne, vil resultere i en advarsel, som pr nedenfor) ,

· ABACUS 'List egenskaber til SharePoint Choice søjler,

· ABACUS 'Dato / tid egenskaber til SharePoint Flere tekstlinjer (aka Note) kolonner (Bemærk: SharePoint dato og tid kolonner kan ikke anvendes på grund af SharePoint s inkonsekvent støtte til tidszone / regionaliseringsbeslutninger indstillinger),

· ABACUS 'booleske egenskaber til SharePoint Ja / (alias Boolean) kolonner Nej.

En ABACUS elements tilhørende standarder ikke kan kortlægges til SharePoint liste kolonner som endnu. Og SharePoint valuta, person eller gruppe, Hyperlink eller billede, Task Outcome, eksterne data og Managed Metadata kolonner kan ikke kortlægges i Abacus aspekter endnu.

8. Vælge Opret Kortlægning.

Til synkronisereMicrosoft SharePoint liste (r)ind ABACUS

1. Sikre, at du har ABACUS åben.

2. Vælge Tools | SharePoint Sync.

Note

Til synkronisere en SharePoint-liste med enABACUS projektet brugerlicens brug for SharePoint Synctilføjelse kapacitet. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

3. Vælg en eksisterende SharePoint-mapping (eller tilknytninger hjælp Ctrl-klikeller Vælg alleknap) fra SharePoint tilknytningerpanelsom vist i prøven skærmbillede over. Bemærk: Her viser vi netop den "Goal (eller krav)" ABACUS komponenttypegodkendelse kortlægning til et SharePoint liste kaldet Mål at blive valgt.

4. Vælg Arkitektur (r), som du vil synkronisere indhold med fra Synkroniser indhold fra arkitekturerpanelet vist i prøven screenshot over. Bemærk: Her viser vi netop den "2015 Aktuel 'arkitektur synkroniseres.

5. Vælg Synkronisere fra SP knap.

Note

Hvis SharePoint-webstedet legitimationsoplysninger er ikke 'All Saved "for kortlægning (er) valgt derefter en Login til dialog SharePoint vises beder om Webstedet URL, Brugernavn og / eller Adgangskode.Indtast venligst disse. Desuden vil synkroniseringen omfatte eventuelle andre kortlægninger, der kræves for vedhæftede komponenter / lookup kolonner. Eventuelle yderligere kortlægninger, der automatisk inkluderet, vil blive vist i dialogen som pr nedenfor.

6. Ved en vellykket synkronisering vises et SharePoint Sync dialog Resultater, som vist nedenfor en liste over de ændringer og eventuelle advarsler. Klik Okay.

Til synkronisere fra ABACUS til Microsoft SharePoint liste (r)

1. Sikre, at du har ABACUS åben.

2. Vælge Tools | SharePoint Sync.

Note

Til synkronisere en SharePoint-liste med enABACUS projektet brugerlicens brug for SharePoint Synctilføjelse kapacitet. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

3. Vælg en eksisterende SharePoint-mapping (eller tilknytninger hjælp Ctrl-klikeller Vælg alleknap) fra SharePoint tilknytningerpanelsom vist i prøven skærmbillede over. Bemærk: Her viser vi netop den "Goal (eller krav)" ABACUS komponenttypegodkendelse kortlægning til et SharePoint liste kaldet Mål at blive valgt.

4. Vælg Arkitektur (r), som du vil synkronisere indhold med fra Synkroniser indhold fra arkitekturerpanelet vist i prøven screenshot over. Bemærk: Her viser vi netop den "2015 Aktuel 'arkitektur synkroniseres.

5. Vælg Sync til SP knap.

Note

Hvis SharePoint-webstedet legitimationsoplysninger er ikke 'All Saved "for kortlægning (er) valgt derefter en Login til dialog SharePoint vises beder om Webstedet URL, Brugernavn og / eller Adgangskode.Indtast venligst disse. Desuden vil synkroniseringen omfatte eventuelle andre kortlægninger, der kræves for vedhæftede komponenter / lookup kolonner. Eventuelle yderligere kortlægninger, der automatisk inkluderet, vil blive vist i dialogen som pr nedenfor.

6. Ved en vellykket synkronisering vises et SharePoint Sync dialog Resultater, som vist nedenfor en liste over de ændringer og eventuelle advarsler. Klik Okay.

Note

ABACUS opdaterer SharePoint kolonner med tomme værdier, selvom 'Kræv, at denne kolonne indeholder oplysninger' er sat til Ja i SharePoint. Dette skyldes SharePoint ikke udsætter denne indstilling eksternt. Hvis dette skal forhindres, anbefales det, at en ABACUS Designer sætter Nødvendig begrænsning til True og håndhæves for den givne ejendom ved hjælp af ABACUS ' begrænsning funktion .

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Befolker din arkitektur fra Visio | Befolker din arkitektur fra Excel


Befolker din arkitektur fra Microsoft SQL Server

Navigation: Befolke din arkitektur> Befolke fra Microsoft-produkter>

Befolker din arkitektur fra Microsoft SQL Server

Send kommentarer om dette emne.

Du kan importere din arkitektur fra en Microsoft SQL Server-database. Du har valget mellem at bare importere tabeller og relationer effektivt importerer bare den generiske struktur af databasen eller bordene, Rækker og relationer, som vil importere ikke kun strukturen men data som godt.

Note

Fra SQL Server-funktion kræver, at Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014er installeret på computeren.

For at importere Microsoft SQL Server-database i ABACUS

1. Sikre, at du har ABACUS åben.

2. Vælg Filer | Ny og vælg Fra SQL Serverfra den dialogboks, der vises, og klik på OK.

3. I Importer SQL Server dialogboks, der vises indstille "MachineName« og »SQLINSTANCE 'værdier af Connection String variabel og den» DBNAME »værdien af ​​Database Name variabel til deres korrekte værdier som vist i prøven skærmbilledet nedenfor.

4. Indstil Database Name variabel til den samme værdi som Initial Catalog variablen er fastsat i ovenstående trin, som vist i prøven skærmbilledet nedenfor.

5. Tryk på Test forbindelse knappen og tabellerne importeres sektion i dialogen bør være befolket med de tilgængelige databasetabeller, som vist i prøven skærmbilledet nedenfor.

6. Vælg de tabeller, som du ønsker at importere fra enten individuelt at vælge dem eller bruge Alle, Ingen og Inverter knapperne til højre i dialogen.

Note

Kun Foreign Key relationer, der eksisterer mellem tabellerne, som du vælger, vil blive importeret.

7. Brug af radioen knappen Importer stil vælge, om du vil importere bare Borde og relationerne mellem dem eller tabellerne, deres Rækker og de specifikke relationer mellem rækkerne.

Note

Den første mulighed importerer tabellerne som komponenter af typen »Tabel" og forholdet mellem de to tabeller (fra fremmede nøgler) indføres som forbindelser af typen »Tabel Relation«. Dette er en klassisk "ERD 'stil udsigt over systemets tabeller. Den anden mulighed importerer tabelrækker som diskrete delkomponenter af typen "Tabel Row" med egenskaber svarende til hver af de kolonner / felter og med forholdet mellem de tabelrækker af typen »Tabel Relation«. Desuden, hvis der er en kolonne / felt kaldet 'Navn' så bruges til at navngive de enkelte tabelrække delkomponenter.

8. Vælg Importer ... knappen.

9. Efter en kort tid (med en statuslinje for feedback) et nyt ABACUS projektet vil blive oprettet med tabellerne, tabelrækker (hvis den anden mulighed blev valgt i ovenstående trin) og relationer fra Microsoft SQL Server-database.

Se også

Befolker din arkitektur - Oversigt | Befolker din arkitektur manuelt | Befolker din arkitektur fra Visio | Befolker din arkitektur fra Excel


Tilføjelse forudindstillede egenskaber til en komponent, tilslutning eller type

Navigation: Befolke din arkitektur> Egenskaber>

Tilføjelse forudindstillede egenskaber til en komponent, tilslutning eller type

Send kommentarer om dette emne.

Standard biblioteker af ejendomme kan specificeres og tildeles til noget andet i arkitekturen. Disse biblioteker er kendt som Standarder. Ved hjælp af Standarder, Behøver du kun at samle specifikke systemer egenskaber - standard egenskaber er der allerede.

For eksempel standard ydeevne Microsoft Windows 2000 kan gemmes som en Standardog tilskrives nogle komponenter (eller forbindelser, ikke at det ville være typisk) ved hjælp af Microsoft Windows 2000-operativsystemet.

Hvis du vil tilføje en standardtil en komponent, tilslutning eller type

1. Højreklikpå komponenten / tilslutning / type.

2. Vælge Tildel Standard.

3. Vælge en Standardfra listen.

Se også

Befolker din arkitektur - Oversigt | Ændring af egenskaberne af en komponent, tilslutning eller type | Aggregerede egenskaber


Ændring af egenskaberne af en komponent, tilslutning eller type

Navigation: Befolke din arkitektur> Egenskaber>

Ændring af egenskaberne af en komponent, tilslutning eller type

Send kommentarer om dette emne.

Egenskaber er typisk systemkravene, du definerer, eller resultaterne Abacus 'evalueringer. (Når ABACUS udfører sine evalueringer, det skriver ejendomme tilbage til filen.) Med andre ord, ejendomme er de ting, du ved om dit system, eller de ting, du bruger ABACUS at finde ud af.

For at ændre ejendomsværdien af ​​en komponent, tilslutning eller type

1. Klikpå komponenten / tilslutning / type (dens egenskaber vises i vinduet til højre Properties).

2. Klikat fremhæve den ejendom, du vil ændre.

3. Typeen ny værdi.

Vigtig

Desuden er mange egenskaber defineres ved brug Standarder . Ved at ændre en ejendom inden for en Standard, Du ikke kun ændre den aktuelle objekt, du også ændre mester Standard (under Standarder påtoppen af ​​træet). Før du gør dette, kontrollere, hvad andre komponenter, tilslutninger eller typer bruger Standard, Fordi ændringen ikke kan være relevante for dem- Du kan bruge Referencer vinduet for denne.

Tip

Du kan ændre en forbindelse egenskaber indefra Komponenter gren af ​​træet (og omvendt). Så, for eksempel, hvis du kigger på, hvilke forbindelser der er knyttet til en komponent, og du indser du er nødt til at ændre en, du kan.

Hvis du vil tilføje nye egenskaber til en komponent eller tilslutning (via type)

Note

Egenskaber kan kun tilføjes til typer og komponenter eller forbindelser af typen »arver« disse egenskaber.

1. Klikaf den type (dens egenskaber vises i vinduet til højre Properties).

2. Klikpå knappen Tilføj øverst Property vinduet for at tilføje en række i toppen af ​​ejendommen gitter for den nye ejendom.

3. Tilføj et Typefor den nye ejendom.

4. Tilføj et Navnfor den nye ejendom.

5. Tilføj et Standard værdifor den nye ejendom.

6. Tilføj et Enhedfor den nye ejendom.

7. Indstil Datatypefor den nye ejendom.

Note

Datatypen felt kan bruges til at begrænse de gyldige værdier, at en ejendom kan have. Det er; Tekst, Heltal, Decimal, dato / tid, boolesk eller liste.

o A TekstEjendommen er en, der har et ubegrænset antal tegn og i det væsentlige har ingen begrænsninger på værdien.Hvis ejendomsværdien er en korrekt formet hyperlink (dvs. URL'er nødt til at starte med en af 5strygere; http: //, https: //, ftp: //, fil:eller \\ og enhvermellemrum skal indtastes med en '% 20'), Så linket er klikbare (via ctrl + klik).

o En Heltalejendom skal være et helt tal enten positiv eller negativog kan indeholde en periode, rum, apostrof eller komma til cifret gruppering afhængigt af projektets Region indstillinger fra File | Projekt Indstillinger.Regionen indstillinger og den.Net Long.TryParse metode er anvendes til at bestemme gyldige Heltalværdier.

o A Decimalegenskab kan indeholde en periode eller komma for decimaltegnet symbol og kan indeholde en periode, rum, apostrof eller komma til cifret gruppering afhængigt af projektets Region indstillinger fra File | Projekt Indstillinger.Regionen indstillinger og den.Net Decimal.TryParse metode er anvendes til at bestemme gyldige Decimal værdier.

o A Dato / tidEjendommen giver enten en dato del eller en Time del eller begge dele. Regionenindstillingerog .Net DateTime.TryParse metode bruges primært til at bestemme gyldig dato og / eller tid værdier. Men den dato del, hvis relevant kræver mindst den Dag og Måned (året vil være antages at være det aktuelle år) eller måned og år dele at være gyldig. Dvs. Juni 3. kvartal 2010 eller bare 2010 er ugyldige. Selv om det vil variere med forskellige regionale indstillinger, typisk dag, måned og år dele kan adskilles med et mellemrum, komma, streg ("-") eller skråstreg ('/'). The Day del typisk er et heltal fra 1 til 31. måned del er typisk et heltal fra 1 til 12, et gyldigt 3 brev forkortelse for månederne (f.eks Jan, feb, mar) eller fuld måned navn (f.eks januar, februar , Marts). Året del er typisk en 4-cifret positivt tal, men 1, 2 og 3 cifrede år accepteres i henhold til indstillingerne i Kontrolpanel-> Regional og Sprog Indstillinger-> Regional Indstillinger-> Nærmere (knap) -> Dadel> Kalender. Typisk de fortolkes som følger; 0-29 fortolkes som 2000-2029, 30-99 som 1930-1999 og 100-999 som 100-999. Ugyldige datoer såsom 31 Juni 2010 og 31/9/2010 vil blive opdaget. Time del, hvis relevant kræver en Timer og Minutter del og eventuelt en Sekunder del. Timer, minutter og valgfri Sekunder dele er typisk adskilt med et kolon (":"), og den Sekunder del kan specificeres med et komma ("."). For yderligere information om de gyldige formater henvises til bemærkninger afsnittet om .Net DateTime.TryParse metode .

Tip

Det anbefales at anvende mindst 3 bogstaver måneders navn format (dvs. "juli" eller "Juli") for datoværdier snarere end numeriske formatering (dvs. "7" eller "07") som disse værdier vil validere på tværs af de fleste regioner, afhængigt på projektets Region indstillinger fra File | Projekt Indstillinger.Dvs. Det anbefales at anvende "15 jul 2010" snarere end "15/7/2010" eller "2010/07/15". Med dette eksempel, "15/7/2010" ville mislykkes validering for "English (United States)" og "2010/07/15" ville mislykkes for "English (United Kingdom)«, men "15 Jul 2010" ville passere for begge.

o A Booleskejendom kan være enten sande eller falske.Det er tilfældet ufølsom så SAND eller FALSK kan også bruges dog ja, nej, 1, 0 osv vil alle mislykkes nogen ejendom begrænsninger.

o A Listeegenskab tillader en samling af foruddefinerede værdier som lav | Mellem | Høj eller Bevar | Opdater | Redesign | På pension og den vifte af værdier kommer fra marken Enhed for ejendommen enten som komma eller rør '|' adskilte værdier. Ejendommen kan anses for at være ordinal (i modsætning til nominel, interval eller ratio), fordi når de anvendes på hitlisterne og at farve elementer på diagrams og 3ds værdierne behandles simpelthen i en stigende (eller faldende) rækkefølge. Det er værdier er plottet i stigende (eller faldende) rækkefølge på chart akser eller farveområder.

8. Datatype kan indstilles til at være Handicappet, Advaret eller Håndhævesved at højreklikke på Datatype feltet til andre formål end tekst, som giver alle tegn, så kan aldrig være forkert indstilling.

9. Indstil Nødvendigflaget for den nye ejendom.

Note

Den Obligatorisk felt kan bruges til at indikere, om en værdi skal indtastes for ejendommen. Det er, at det ikke kan være tom eller. falsker standard, og betyder, at ejendommen kan være tom eller tom, Rigtigtbetyder, at ejendommen skal have en værdi, og kan ikke være tom eller tom. Den nødvendige kan indstilles til at være Handicappet, Advaret eller Håndhævesved at højreklikke på det ønskede felt, hvis det er sat til True.

Se også

Befolker din arkitektur - Oversigt | Tilføjelse forudindstillede egenskaber til en komponent, tilslutning eller type | Aggregerede egenskaber


Ændring af et projekts Region indstillinger

Navigation: Befolke din arkitektur> Egenskaber>

Ændring af et projekts Region indstillinger

Send kommentarer om dette emne.

Ejendom værdier kræve visse formatering i forskellige regioner til at matche enhver Datatype begrænsninger for Integer, Decimal og dato / tid egenskaber. For eksempel i Australien decimaltegnet "123.456 punkt syv otte ni" er repræsenteret som "123,456.789", mens det i Tyskland ville det blive represnted som "123.456,789", og i Frankrig ville det være " 123 456789 ".Ligeledes i USA den "anden af ​​december 1970" er repræsenteret som en kort dato som "1970/12/02", men i Det Forenede Kongerige den er repræsenteret som "1970/02/12", og i Polen som "1970-1912 -02 ". Derfor for at arbejde med et ABACUS projekt på tværs af regionerne er behov for en global indstilling pr ABACUS projekt.

At skifte en ABACUS projektets Region indstillinger

1. Sikre, at du har en ABACUS fil åben.

2. Vælge File | Projektindstillinger ... og fra den viste dialog vælg Område og Klik på OK. Bemærk: Der henvises til afsnittet nedenfor for de regionale standardindstillinger.

Note

Hvis du ikke kan se Projektindstillinger ... menupunktså du ikke behøver Designeren og Administrator tilføjelses og du kan ikke ændre projektets region.Også, hvis der ikke Region er indstillet (dvs. regionen i Project Options er "Ingen (System Region)«), så hver brugerens MS Windows aktuelle kultur-indstillinger (dvs. Regional Settings)bruges til at validere egenskaber.

Region defaults

Nedenstående tabel viser den standardindstillinger for hver region som fastsat gennem File | Projektindstillinger ...menupunkt.Se venligst under tabellen for en liste over de anvendte symboler.

Område | Decimal Symbol | Digit gruppering | Minustegn | Kort tid | Lang tid | AM / PM-symbolet | Korte Dato | Lang Dato
Engelsk (Australien) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / åååå | dd MMMM yyyy
English (United Kingdom) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / åååå | dd MMMM yyyy
English (United States) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / åååå | dddd, MMMM dd, åååå
Fransk (Frankrig) | , | plads | - | HH: mm | HH: mm: ss | | | dd / mm / åååå | dddd d MMMM yyyy
Tysk (Tyskland) | , | . | - | HH: mm | HH: mm: ss | | | DD.MM.YYYY | dddd, d. MMMM yyyy
Italiensk (Italien) | , | . | - | HH: mm | HH: mm: ss | | | dd / mm / åååå | dddd d MMMM yyyy
Spansk (Spanien) | , | . | - | H: mm | H: mm: ss | | | dd / mm / åååå | dddd, dd 'de' MMMM 'de' yyyy
English (Canada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / mm / åååå | MMMM-dd-åå
Fransk (Canada) | , | plads | - | HH: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM yyyy
Arabisk (U.A.E.) | . | , | - | tt: mm tt | tt: mm: ss tt | ص | م | dd / mm / åååå | dd MMMM, åååå
Arabisk (Saudi-Arabien) | . | , | - | tt: mm tt | tt: mm: ss tt | ص | م | dd / mm / åå | dd / MMMM / åååå
English (Sydafrika) | , | plads | - | tt: mm tt | tt: mm: ss tt | AM | PM | yyyy / MM / dd | dd MMMM yyyy
Engelsk (New Zealand) | . | , | - | h: mm tt | h: mm: ss tt | morgenen | p.m. | d / mm / åååå | dddd, d MMMM yyyy
English (Indien) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd-MM-yyyy | dd MMMM yyyy
Tysk (Schweiz) | . | ' | - | HH: mm | HH: mm: ss | | | DD.MM.YYYY | dddd, d. MMMM yyyy
Fransk (Belgien) | , | . | - | HH: mm | HH: mm: ss | | | d / mm / åååå | dddd d MMMM yyyy
Hollandsk (Belgien) | , | . | - | H: mm | H: mm: ss | | | d / mm / åååå | dddd d MMMM yyyy
Tjekkiet (Tjekkiet) | , | plads | - | H: mm | H: mm: ss | DOP |. ODP. | d.M.yyyy | d. MMMM yyyy
Dansk (Danmark) | , | . | - | HH: mm | HH: mm: ss | | | dd-MM-yyyy | d. MMMM yyyy
Græsk (Grækenland) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / åååå | dddd, d MMMM yyyy
Finsk (Finland) | , | plads | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'yyyy
Hungarian (Ungarn) | , | plads | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | yyyy. MMMM d.
Hollandsk (Holland) | , | . | - | H: mm | H: mm: ss | | | d-M-yyyy | dddd d MMMM yyyy
Norsk, bokmål (Norge) | , | plads | - | HH: mm | HH: mm: ss | | | DD.MM.YYYY | d. MMMM yyyy
Polsk (Polen) | , | plads | - | HH: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM yyyy
Russisk (Rusland) | , | plads | - | H: mm | H: mm: ss | | | DD.MM.YYYY | d MMMM yyyy 'г.'
Svensk (Sverige) | , | plads | - | HH: mm | HH: mm: ss | | | yyyy-MM-dd | "hule" d MMMM yyyy
Korean (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | yyyy-MM-dd | yyyy '년' M '월' d '일' dddd
Hebraisk (Israel) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / åååå | dddd dd MMMM yyyy

De følgende symboler bruges til at angive, hvordan datoer og klokkeslæt vises:

Tid symboler |
h | Time (hh viser time med indledende nul)
m | Minut (mm viser minut med en indledende nul)
s | Andet (ss viser den anden med en indledende nul)
TT | ER. eller P.M.
H / H | 12 eller 24 timers display tid
Dato symboler |
d, dd | Dag
ddd, dddd | Dag i ugen
M | Måned
y | År

Se også

Befolker din arkitektur - Oversigt | Ændring af egenskaberne af en komponent, tilslutning eller type | Tilføjelse forudindstillede egenskaber til en komponent, tilslutning eller type


Aggregerede egenskaber

Navigation: Befolke din arkitektur> Egenskaber>

Aggregerede egenskaber

Send kommentarer om dette emne.

Operationen "Aggregate Egenskaber"Giver dig mulighed for at tilføje værdier for lignende egenskaber sammen og skriv (eller tilføje) resultatet i det valgte forælder element egenskaber. Det giver dig også til at definere omfanget af sammenlægning, og om at opdatere egenskaberne for alle de delelementer eller ej.

Til aggregerede egenskaber

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Højreklik på et element (en arkitektur, en komponent eller en forbindelse) til at gøre sammenlægning og vælg Aggregerede Egenskaber.

3. Vælg en af ​​de Aggregate Options (Traverse Alle Sub-niveauer eller Kun Direct Sub-Level). Hvis du har valgt Traverse Alle Sub-niveauer, Kan du også vælge den løsning, om at Opdatering Sub-Niveauer.

o Traverse Alle Sub-niveauerbetyder, at omfanget af sammenlægning vil omfatte elementerne i alle niveauer under din valgte element.

o Opdatering Sub-Niveauerkan kun ske, hvis du også har valgt indstillingen Traverse Alle Sub-niveauer. Det betyder, at mens du samle ejendomme op fra bunden, det samlede resultat på alle niveauer vil også blive opdateret i hver af de tilsvarende elementer.

o Kun Direct Sub-Levelbetyder, at kun egenskaberne for elementerne direkte under det valgte element vil lægges sammen.

o Vælge Omfatte StandardEgenskaberhvis du vil have de egenskaber, der er defineret i standarder skal medtages. Ellers vil kun de egenskaber unikke for hver komponenteksempel anvendes.

4. Vælg hvilke egenskaber, du ønsker at samle. De er grupperet i deres Typer.

5. Klik på Næste knap.

6. Vælg den mulighed, om at Overskriv Værdier eller Tilføj Værdieri det valgte element.

o Overskriv Værdiervil skrive resultaterne direkte ind i egenskaberne af den valgte element.

o Tilføj Værdiervil tilføje resultaterne til de eksisterende egenskaber af det valgte element.

Se også

Tilføjelse forudindstillede egenskaber til en komponent, tilslutning eller type | Ændring af egenskaberne af en komponent, tilslutning eller type | Evaluering din arkitektur


Analyse din arkitektur

Navigation: Analyse din arkitektur>

Analyse din arkitektur

Send kommentarer om dette emne.

Når du har befolket (og eventuelt simuleret) din arkitektur, er du klar til at bruge ABACUS til at analysere det. Ved at analysere det, kan du afgøre, om din arkitektur vil opfylde dine behov.

Du kan analysere din arkitektur på en række forskellige måder:

· Diagram

· 3D udsigt

· standard diagrammer (pie, line, kolonne, bar, osv)

· brugerdefinerede diagrammer ( responstid , kapacitet plads , stjerne plot , Scatterplot matrix og boble diagram )

· Arkitektur Diff

Note

Når du opretter et diagram, 3D udsigt, Rapport eller standardskema, den Vinduet til valg standard element bruges til at vælge elementer, du ønsker at se.

Se også

Befolker din arkitektur | Simulering din arkitektur | De Diagrammer Værktøj


Standard Element Selection

Navigation: Analyse din arkitektur>

Standard Element Selection

Send kommentarer om dette emne.

Når du opretter et diagram, 3D udsigt, rapport,standardskemaeller kører en simulering, Standard valgelementet vindue bruges til at vælge elementer, du ønsker at analysere / visning.

Vindue Standard Element Selection

Pulldowns

· Filtrer efter View vilje omfatte elementets fra en tidligere gemt visning (dvs. Diagram, figur, 3D). På denne måde kan du udføre komplekse 'slutte' forespørgsler ved at behandle en anden visning som en gemt "forespørgsel".

Afkrydsningsfelter

· Vis Niveauervilje gruppe elementet i henhold til niveauet, som de forekommer i træet. Niveau 1 er det øverste niveau.

· Vis Typervilje gruppe elementerne efter de typer, de er.

· Forældre til udvalgtevil omfatte forælder elementer af eventuelle udvalgte elementer. På denne måde kan du sikre, at kun hierarkiet over eventuelle børn vil blive medtaget i en "bottom-up" valg.

· Børn af udvalgtevil omfatte børnene elementer af eventuelle udvalgte elementer. På denne måde kan du sikre, at kun hierarkiet under eventuelle forældre vil blive inkluderet for en "top-down" valg.

· Navn Kampe Valuevil omfatte kun de elementer, der har et navn, der indeholder den angivne streng (Bemærk: Wildcards (dvs. og *) kan anvendes?). På denne måde kan du danne en "semantisk" forespørgsel.

· Har Ejendom Type / Navn / værdivil omfatte kun de elementer, der har en ejendom type, navn og værdi, som indeholder den angivne streng enten direkte på element eller på sine standarder (Bemærk:?.? Jokertegn (dvs. og *) kan anvendes F.eks * i feltet Værdi vil giver alle elementer, der har en ikke-tom værdi for den givne ejendom). På denne måde kan du danne en "semantisk" forespørgsel.

· Har Standardvil omfatte kun de elementer, der har en standard navn, hvori den angivne streng (Bemærk: Jokertegn (dvs. og *) kan anvendes F.eks HP * vil give alle elementer med mindst en Standard begynder med bogstaverne H og P?.). På denne måde kan du danne en "semantisk" forespørgsel.

· Komponenter / Forbindelser knyttet til udvalgtevil omfatte eventuelle vedhæftede elementer til dem, der er blevet udvalgt. På denne måde kan der vælges en "call-træ" eller "effekt-analyse".

Note

Hvis du har begge Vis Niveauer og Vis Typervalgt så kan du vælge at få træet viser niveauerne første eller typer først af den knap, der vises over de to afkrydsningsfelter.

Tip

Når et element er valgt i vinduet Standard Element Selection, vil det ikke være underlagt yderligere filterskift, indtil det er fravalgt. Da der ikke er indfødt måde at søge efter to forskellige sæt af elementer på én gang (f.eks Komponenter med Standard A eller Standard B), kan du søge først for et sæt, skal du vælge de ønskede komponenter, og derefter udføre en anden søgning efter det andet sæt .

Knapper

· Allevælger alle elementer.

· InverterFravælger alle de valgte elementer og vælger alle dem, der ikke blev valgt.

· Ingenfravælger alle elementer.

· Tilføj filtervælger den resulterende indholdet af de aktuelle filterindstillinger og tillader udvælgelse af yderligere indhold så effektivt en AND eller JOIN filteret.

Se også

Analyse din arkitektur


Visning af en 3D-diagram

Navigation: Analyse din arkitektur> 3D diagrammer>

Visning af en 3D-diagram

Send kommentarer om dette emne.

ABACUS kan du få vist din arkitektur som en 3D-visning, hvor komponent og tilslutning egenskaber er forbundet med farver, former og størrelser.

For at se en 3D-visning af din arkitektur

1. Sikre, at du har åbne ABACUS filenindeholder dit befolkede arkitektur.

2. Udvid Visningergren af ​​træet.

3. Udvid 3Dgren af ​​træet.

4. Dobbeltklik visualisering, du vil åbne.

- eller -

1. Sikre, at du har åbne ABACUS filenindeholder dit befolkede arkitektur.

2. Vælge Indsæt| 3Deller klik på knappen værktøjslinjen.

3. Åbn en eksisterendevisualisering (.abacus3d)

- eller -

1. Sikre, at du har åbne ABACUS filenindeholder dit befolkede arkitektur.

2. Vælge Indsæt| 3Deller klik på knappen værktøjslinjen.

3. Opret en ny visualisering:

· Vælg Arkitekturdu ønsker at se fra pull-down menuen.

· Vælg Komponenter og Tilslutningerdu ønsker at inkludere i diagrammet fra Vinduet til valg standard element .

· Associate farver, former og størrelser med Komponenttyper og Egenskaber.

· Associate farver og former med Forbindelsestyper og Egenskaber.

For at eksportere en 3D-visning

1. Sikre, at du har åbne en eksisterende 3D-visning.

2. I 3D-visningen er rullemenuer vælge File | Eksportere...og valgte placering og filtypen for visualisering fil (.abacus3d, .vrml eller .html).

3. Klik Spare.

Se også

Analyse din arkitektur | Navigation i 3D | Den Diagramming Værktøj


Navigation i et 3D Diagram

Navigation: Analyse din arkitektur> 3D diagrammer>

Navigation i et 3D Diagram

Send kommentarer om dette emne.

ABACUS giver dig mulighed for nemt at navigere gennem din arkitektur i 3D. Oplevelsen svarer til at flyve. Der er to former for navigation:

· Basis Control Mode (Standard); og

· Avanceret Control Mode - skift til denne tilstand ved at vælge Kontrollere| Advanced Control-tilstand.

Note

For at skifte mellem Basis Kontrol og Advanced Control Modes, kan du bruge F4tastaturgenvej funktionalitet.

Grundlæggende Control Mode

· Holde venstre knap og bevæge musen frem eller tilbage ændrer banen;

· Holde venstre knap og bevæge musen til venstre eller højre ændrer krøje;

· Holder den højre knap og flytte musen pander udsigten;

· Holder begge knapper nede og bevæge musen frem eller tilbage, zoomer ind og ud af arkitekturen; og

· Holder begge knapper nede og bevæge musen til venstre eller højre, ruller venstre og højre.

- eller -

· Ved at trykke på Venstre pilpå tastaturet eller numerisk tastatur vil dreje til venstre;

· Ved at trykke på Højre pilpå tastaturet eller numerisk tastatur vil dreje til højre;

· Ved at trykke på Pil oppå tastaturet eller numerisk tastatur vil zoome ind;

· Ved at trykke på Pil nedpå tastaturet eller numerisk tastatur vil zoome ud;

· Ved at trykke Side oppå tastaturet eller numerisk tastatur vil pitche op; og

· Ved at trykke Side nedpå tastaturet eller numerisk tastatur vil pitche ned.

Advanced Control-tilstand

· Flytningmusen frem og tilbage og op og ned, ændrer banen og giring (henholdsvis);

· Ved at trykke W eller Pil opzoomer ind (fremad) til arkitekturen;

· Ved at trykke S eller Pil nedzoomer ud (tilbage) fra arkitekturen;

· Ved at trykke A eller Venstre pilruller til venstre;

· Ved at trykke D eller Højre pilruller til højre;

· Ved at trykke Q eller Side nedhæver visningen (ved at sænke overslag); og

· Ved at trykke E eller Side opsænker visningen (ved at løfte perspektivet).

Interaktiv Control Mode

Trykke på og holde shift-tastenpå tastaturet tilsidesætter den aktuelle tilstand (Grundlæggende eller Avanceret) for at indtaste den interaktive styring. I denne tilstand er det muligt følgende:

· Rullemusemarkøren over en komponent eller forbindelse til se komponenten eller forbindelsen navn;

· Klikpå en komponent for at zoome ind på den pågældende komponent;

· Klik-og-trækpå en komponent for at rotere visningen omkring denne bestanddel; og

· Højrekliken komponent eller tilslutning, og vælg Vis i Stifinderat se, at komponent eller tilslutning beliggenhed i træet.

Fælles kontrol

· Brug ALT-ENTER / ESCat skifte fuld skærm;

· Brug F2at skifte visningstilstand. Dette kan også tilgås i Udsigt Menu.

· Brug musehjulet eller +/-at ændre hastigheden. Hastigheden angives med et tal i nederste venstre hjørne - vises kun, når det er under forandring. 1 er langsomst og 100 er hurtigst.


Visning af en standard diagram

Navigation: Analyse din arkitektur> Standard diagrammer>

Visning af en standard diagram

Send kommentarer om dette emne.

ABACUS 'standard diagrammer omfatter linje, bar, søjle, område, scatter, pie, kurve, Pareto, trin, overflade, radar, terninger, doughnut, pyramide, kontur og kurve område diagrammer. Når du har valgt den type diagram, du ønsker, at resten af ​​processen til visning hver af disse diagrammer er den samme.

For at se en standard diagram af din arkitektur

1. Sikre, at du har åbne ABACUS filenindeholder dit befolkede arkitektur, Og at du har evalueretdin arkitektur.

2. Vælge Indsæt| Diagrameller klik på knappen værktøjslinjen. De DiagrammerVinduet vil blive vist.

Diagrammer vindue

3. Vælg den type diagram, du ønsker, og indstille Chart Indstillinger, og klik derefter på Næste.

Chart Indstillinger

o Stackedvil vise forholdet mellem de enkelte elementer til helheden. Du kan bruge et stablet diagram, når du planlægger at have dataserier flere (dvs. flere ejendomme), og når du ønsker at fremhæve det samlede beløb.

o Stablet 100%vil sammenligne den procentdel hver værdi bidrager til en alt i hele kategorier. Du kan bruge en 100% stablet diagram, når du planlægger at have flere dataserier (dvs. flere egenskaber), og du ønsker at fremhæve bidragene til det hele, især hvis det samlede tal er det samme for hvert element.

o 3D Chartvil simpelthen vise datapunkter i 3-D format for æstetik. Hvis du ønsker at vise dataserier langs en 3. / z-aksen dimension derefter bruge Cluster Series indstillingen beskrevet nedenfor.

o Serie af Ejendomvil vise en dataserie for hver ejendom, der i sidste ende valgt. Hvis dette er afkrydset så egenskaberne bliver kategorierne og dataserier vil være for hvert element, der er valgt.

o Roter Chartvil roterer diagrammet 90 grader med uret ved at ombytte x- og y-akserne. Denne indstilling er kun tilgængelig for linjerne, Step og Cube diagrammerog er især nyttig til fremstilling af Milestone diagrammer som beskrevet i andet tip nedenfor. Bemærk: Kolonne og Søjlediagrammer er allerede "roteret" versioner af hinanden.

o Cluster-serievil vise flere serier af data langs en 3. / z-aksen dimension. Denne indstilling er kun tilgængelig for Column, Bar og Cube diagrammerog er især nyttig til fremstilling af Gantt stil diagrammer som beskrevet i første tip nedenfor.

Tip

Du kan oprette en Gantt kortmed vandrette bjælker, der viser tid / dato egenskaber til forskellige elementer ved at vælge et søjlediagram type og derefter vælge Cluster Series indstillingen.Desuden engang oprettet, kan den længst til venstre bar på diagrammet gøres "usynlig" ved at farve det hvide ved at højreklikke en af ​​søjlerne, vælge farve fra den menu, der vises, og vælge den øverste venstre farve fra paletten. Derudover grænsen for længst til venstre bar kan gøres "usynlig" ved at højreklikke på en af ​​søjlerne, vælge Egenskaber ... og på fanebladet Series i den viste dialog ændre Border Effect til Ingen og Colour til toppen -venstre farve fra paletten.

Tip

Du kan oprette en Milestone diagrammed små figurer, der viser tid / dato egenskaber til forskellige elementer ved at vælge en Cube diagramtype og derefter vælge Roter Chart og Cluster Series muligheder.Desuden engang oprettet, kuberne kan ændres til andre former ved at højreklikke på en af ​​kuber i en given dataserie og vælge Egenskaber ... og på fanebladet Series i den viste dialog ændre Bar til enten Cylinder eller Cone . Bemærk: spaltebredden værdi kan også bruges til at skrumpe '' symbolerne på diagrammet for at reducere overlapninger, jo højere tallet er, jo mindre overlapning vil der være.

4. I Arkitekturerafsnit, sætte kryds i arkitekturen / r du ønsker at kortlægge egenskaberne for arkitektur niveau for, og klik derefter på Næste.

Note

Valg af arkitektur niveau egenskaber er en helt valgfrit trin, og bør kun bruges, når du vil eksplicit kortlægge egenskaberne arkitekturniveauet selv.En arkitektur behøver ikke at blive udvalgt til da indeholde komponent eller forbindelsesegenskaber i det næste trin.

5. Vælg Komponenter og Tilslutningersom du ønsker i diagrammet fra Vinduet til valg standard element , Og klik derefter på Næste.

6. Vælg Egenskaberdu ønsker i diagrammet, og klik Slutte.

Chart Indstillinger

o Medtag Standard egenskaber vilje viser de nedarvede egenskaber fra standarderne til rådighed for udvælgelse.

o Aggregerede Egenskaber vilje tæller variansen mellem serie værdier, og kortlægge disse resultater i modsætning til de individuelle værdier selv.Denne indstilling er kun tilgængelig, hvis serien af ​​Property mulighed blev valgt i trin 3 ovenfor.

Tip

De ejendomme, der kortlægning afhænger af de elementer, du vælger.

Hvis du vil gemme et diagram

Note

Diagrammer kan kun gemmes, hvis de kun indeholder komponenter og forbindelser, som alle skal være fra en enkelt arkitektur i det aktuelle projekt.

1. Sørg for, at du har en ny eller eksisterende diagram åbenog du har foretaget de nødvendige ændringer.

2. I diagrammet værktøjslinjen klik på den venstre Gem Chartknappen for at gemme diagrammet og eventuelle formatering ændringer.

3. I Chart Navndialogboks, der vises indtaste et navn til diagrammet, og tryk på Okay.

Sådan eksporterer et diagram

1. Sikre, at du har en eksisterende diagram åben.

2. I diagrammet værktøjslinjen klik på 2. fra venstre Gem som BMPknappen og valgte placering for diagrammet.

3. Klik Spare.

Se også

Analyse din arkitektur | Visning af en responstid diagram | Visning af en kapacitet plads diagram


Visning af en kapacitet plads diagram

Navigation: Analyse din arkitektur> Tilpassede diagrammer>

Visning af en kapacitet plads diagram

Send kommentarer om dette emne.

En Capability Space diagram giver dig mulighed for at se, om din arkitektur opfylder krævede systemet kapacitet med hensyn til egenskaber, identificeret under systemet krav analyseprocessen.

For at se en evne plads diagram

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur, Og at du har evalueretdin arkitektur.

2. Vælge Indsæt| Diagram| Brugerdefinerede diagrammer| Capability Space. (De Capability Space Chart ConfigDialogen vil blive vist.)

3. I Arkitekturerafsnittet kryds i arkitekturer, du ønsker at diagrammet, og klik derefter på Næste.

4. I Egenskaberområde, kryds de arkitektoniske egenskaber, du gerne vil indgår som akserne i diagrammet.

5. I Evneområde, for hver ejendom omfattet fra det foregående trin, skal du vælge, om nogen Minimum eller kapacitet grænser Maksimum eksisterer, og værdierne af disse grænser. Standardværdierne er minimum og maksimum værdier evalueret for arkitekturer eller mål for ejendommen hvis den er blevet indstillet.

For at eksportere en evne plads diagram

1. Sikre, at du har en eksisterende kapacitet plads diagram åben.

2. I diagrammet værktøjslinjen klik på den venstre Gem som BMPknappen og valgte placering for diagrammet.

3. Klik Spare.

Se også

Analyse din arkitektur | Visning af en responstid diagram


Visning af en responstid diagram

Navigation: Analyse din arkitektur> Tilpassede diagrammer>

Visning af en responstid diagram

Send kommentarer om dette emne.

En svartid diagram giver dig mulighed for at se, om dine forbindelser bliver behandlet på den ønskede hastighed (dvs. inden deres deadline).

For at se en responstid diagram

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur, Og at du har evalueretdin arkitektur.

2. Vælge Indsæt| Diagram| Brugerdefinerede diagrammer| Responstid. (De Svartid Chart ConfigDialogen vil blive vist.)

3. Fra Arkitekturerdrop-down listen, skal du vælge arkitekturen, du ønsker at kortlægge.

4. I Tilslutningerområde, kryds de forbindelser, du gerne vil have medtaget i diagrammet.

5. De Skala Typeområde, skal du vælge Lineærhvis du vil have den lodrette akse (responstid), der skal vises som en lineær progression - hvert segment af tid tildeles en ligelig andel af aksen. Vælge LogaritmiskHvis du vil have det vist som en logaritmisk progression - hvert segment af aksen repræsenterer stadigt længere tid jo højere op aksen du går. (Hastigheden af ​​stigningen er bestemt af Grundlagdu vælger.)

Responstid diagram lodrette akse skala

At eksportere en responstid diagram

1. Sikre, at du har en eksisterende responstid diagram åben.

2. I diagrammet værktøjslinjen klik på den venstre Gem som BMPknappen og valgte placering for diagrammet.

3. Klik Spare.

Se også

Analyse din arkitektur | Visning af en kapacitet plads diagram


Visning af en stjerne plot af dine udviklet arkitekturer

Navigation: Analyse din arkitektur> Tilpassede diagrammer>

Visning af en stjerne plot af dine udviklet arkitekturer

Send kommentarer om dette emne.

Når en arkitektur er blevet udviklet, og de mål, der er defineret, kan det så visualiseres og sammenlignes med den oprindelige arkitektur hjælp stjerne plots. Dette afsnit beskriver, hvordan du opretter og manipulere en stjerne plot.

For at se en stjerne plot af dine udviklet arkitekturer

1. Sikre, at du har en ABACUS fil åben .

2. Sikre, at du har udviklet sig og sætte måltil din arkitektur som skitseret under Evolving din arkitektur

3. Vælge Indsæt| Diagram| de Brugerdefinerede diagrammerFanen | Stjerne Plot.

4. Klik på Slutte knap.

5. De Stjerne Plotmed de udviklede arkitekturer og sætte mål vil blive vist. Bemærk: Akserne af stjernen plottet kan flyttes ved at klikke og trække akserne til et andet område inden for grænserne af stjernen plottet kvalitet plads.

Note

Området på venstre side af stjernen plot viser indstillingerne for stjernen plot vises. Dette omfatter arkitektur, der er udviklet (i dette tilfælde "ABC Ltd As-Is 2010") Samt de mål, der er sat for denne arkitektur. Du vil bemærke, at de mål, der har en flueben ved siden af ​​dem er repræsenteret som akser stjernen plot (f.eks KPI- Omkostninger, KPI - kvalitet og KPI - Time). Du kan fjerne markeringen disse mål på ethvert tidspunkt at fjerne dem fra stjernen plot.

De røde og grønne "prikker", der vises på din stjerne plot repræsenterer en normaliseret værdi, som bestemt af de bedste og værste værdi (skitseret under Sætte mål for din udviklet arkitektur ) For den valgte topniveau arkitektur og eventuelle udviklinger af det. Disse værdier er repræsenteret i en Kvalitet Space.

Som det fremgår af ovenstående billede, er det tydeligt, at den oprindelige arkitektur (As-Is 2010) Har ringe Koste, Mens den første udviklet løsning (To-Be 2011 - Strategi A) Er flyttet inden for kvalitet plads til forbedring Koste, Kvalitet og tidmål. Alternativt andet udviklet option (To-Be 2011 - Strategi B), mens den også har forbedret Koste størrelsen af ​​forbedringen er mindre end Strategi A men både kvaliteten og Time mål er blevet forbedret mere end med Strategi A.I dette tilfælde en arkitekt maj vælge Strategi A over Strategi Bsom deres anbefalingog videre udvikle denne mulighed (til-være 2012 - Strategi A).

6. Fravælg Vis Evolutionsafkrydsningsfeltet for at skjule den linje (r), der repræsenterer udviklingen (r) mellem den oprindelige (f.eks As-Is 2010) Og udviklet (fx To-Be 2011 - StrategiA) arkitektur (r).

7. Vælg Vis Sticksafkrydsningsfeltet for at vise den relative størrelse af hver kvalitet attribut (de mål, der er blevet defineret på hver akser) for hver arkitektur.

8. Vælg Vis Arkitektur Navneafkrydsningsfelt, hvis du ønsker at navnene på originalen og udviklede arkitektur (r) til at blive vist på stjernen plot.

Se også

Analyse din arkitektur | Visning af en responstid diagram | Visning af en Scatterplot matrix af dine udviklet arkitekturer | Evolving din arkitektur


Visning af en scatter plot af dine udviklet arkitekturer

Navigation: Analyse din arkitektur> Tilpassede diagrammer>

Visning af en scatter plot af dine udviklet arkitekturer

Send kommentarer om dette emne.

Når en arkitektur er blevet udviklet, og de mål, der er defineret, kan det så visualiseres og sammenlignes med den oprindelige arkitektur hjælp Scatterplot matricer. Dette afsnit skitserer, hvordan du opretter og forstå de særlige kendetegn ved en scatterplot matrix.

For at se et scatterplot Matrix over dine udviklet arkitekturer

1. Sikre, at du har en ABACUS fil åben .

2. Sikre, at du har udviklet sig og sætte måltil din arkitektur som skitseret under Evolving din arkitektur

3. Vælge Indsæt| Diagram| de Brugerdefinerede diagrammerFanen | Scatterplot Matrix.

4. Klik på Slutte knap.

5. De Scatter Plotmed den definerede udvikling af arkitekturer og mål vil blive vist.

Note

Området på venstre side af scatterplot matricen viser indstillingerne for scatterplot matrix vises. Dette omfatter arkitektur, der er udviklet (i dette tilfælde "ABC Ltd As-Is 2010") Samt de mål, der er sat for denne arkitektur. Du vil bemærke, at de mål, der har en flueben ved siden af ​​dem er repræsenteret som X og Y akser scatterplot matrix (f.eks KPI- Omkostninger, KPI - kvalitet og KPI - Time). Du kan fjerne markeringen disse mål på ethvert tidspunkt at fjerne dem fra scatterplot matrix.

De blå prikker, der vises på din grund i matricen repræsenterer en normaliseret værdi, som bestemt af de bedste og værste værdi (skitseret under Sætte mål for din udviklet arkitektur ). Disse værdier er repræsenteret i en Kvalitet Space.

To definerede mål sammenlignes mod hinanden i et scatterplot matrix og processen gentages, indtil der er sammenlignet alle de mål (f.eks Første afbildning af matricen i ovennævnte diagram sammenligner KPI - OmkostningerMålet med KPI - Kvalitet mål. Den anden er Koste imod Tid og den sidste plot er Kvalitet imod Tid. De relevante mål etiketter er vist ved toppen og højre eller hver række af grunde.).

6. Vælg Arkitekturervalgknap, hvis du ønsker at få vist målinger for de enkelte arkitekturer.

7. Vælg Evolutionsradio-knappen, hvis du ønsker at vise de normaliserede ændringer fra den oprindelige arkitektur (f.eks As-Is 2010) Til den udviklede arkitektur (r) (fx To-Be 2011 - Strategi A og To-Be 2011 - Strategi B).

Se også

Analyse din arkitektur | Visning af en responstid diagram | Visning af en stjerne plot af dine udviklet arkitekturer | Evolving din arkitektur


Visning af en boble diagram

Navigation: Analyse din arkitektur> Tilpassede diagrammer>

Visning af en boble diagram

Send kommentarer om dette emne.

En boble diagram giver dig mulighed for at sammenligne op til 5 dimensioner (dvs. X, Y, boble størrelse / radius, boble farve og boble grænsen farve) i en visning.

For at se en boble diagram

1. Sikre, at du har en ABACUS fil åben .

2. Vælge Indsæt| Diagram| de Brugerdefinerede diagrammerFanen | Bubble Chart.

3. I Arkitekturerafsnittet kryds i arkitekturer (hvis nogen), du ønsker at kortlægge, og klik derefter på Næste.

4. Vælg Komponenter og Tilslutningersom du ønsker i diagrammet (hvis nogen) fra Vinduet til valg standard element , Og klik derefter på Næste.

5. Vælg X-aksenejendom, og klik derefter på Næste.

Note

Kun Heltal, Decimal, dato / tid, Boolean og List egenskaber kan anvendes til X-aksen. Desuden er Integer, decimal og dato / tid egenskaber plottet venstre mod højre langs aksen skaleres i henhold til værdien af ​​ejendommen, er imidlertid Boolean og List egenskaber simpelthen plottet venstre mod højre i nøjagtig rækkefølge (eller i omvendt rækkefølge, hvis muligheden for at bytte om på rækkefølgen er markeret) defineret for ejendommen, uanset deres værdier. F.eks. Lav | Mellem | Høj eller 1, 2, 4, 8, 16.

6. Vælg Y-aksenejendom, og klik derefter på Næste.

Note

Kun Heltal, Decimal, dato / tid, Boolean og List egenskaber kan anvendes til Y-aksen. Desuden er Integer, decimal og dato / tid egenskaber afbildes bund-til-top langs aksen skaleres efter værdien af ​​ejendommen, dog Boolean og List egenskaber er simpelthen afbildes bund-til-top i nøjagtig rækkefølge (eller i omvendt rækkefølge, hvis muligheden for at bytte om på rækkefølgen er markeret) defineret for ejendommen, uanset deres værdier. F.eks. Lav | Mellem | Høj eller 1, 2, 4, 8, 16.

7. Vælg boble størrelse / radiusejendom, og klik derefter på Næste.

Note

Kun Heltal, Decimal, Boolean og List egenskaber kan anvendes til boblestørrelsen / radius. Desuden Integer og Decimal egenskaber resulterer i en boble størrelse / radius skaleret efter værdien af ​​ejendommen, dog Boolean og List egenskaber resulterer i lige trin stigninger på boblen størrelse / radius i den nøjagtige rækkefølge (eller i omvendt rækkefølge, hvis mulighed for at bytte om på rækkefølgen er markeret) defineret for ejendommen, uanset deres værdier. F.eks. Lav | Mellem | Høj eller 1, 2, 4, 8, 16.

8. Vælg enten en fast boble farve eller knytte en ejendom med boblen farve, Og klik derefter på Næste.

Note

Kun Heltal, Decimal, Boolean og List egenskaber kan anvendes til boblen farve. Desuden Integer og Decimal egenskaber resulterer i en boble farve inden for det valgte interval skaleret efter værdien af ​​ejendommen, dog Boolean og List egenskaber resulterer i lige trin stigninger på boblen farve inden for det valgte interval i præcis den rækkefølge, der er defineret for ejendom uanset deres værdier. F.eks. Lav | Mellem | Høj eller 1, 2, 4, 8, 16.

9. Vælg enten ingen boble grænsen farve eller knytte en ejendom med boblen grænsen farve, Og klik derefter på Slutte.

Note

Kun Heltal, Decimal, Boolean og List egenskaber kan anvendes til boblen grænsen farve. Desuden Integer og Decimal egenskaber resulterer i en boble kant farve inden for det valgte interval skaleret efter værdien af ​​ejendommen, dog Boolean og List egenskaber resulterer i lige trin stigninger på boblen grænsen farve inden for det valgte interval i den nøjagtige rækkefølge, der er defineret for ejendommen, uanset deres værdier. F.eks. Lav | Mellem | Høj eller 1, 2, 4, 8, 16.

Bubble diagram

Hvis du vil gemme en boble diagram

Note

Bubble diagrammer kan kun gemmes, hvis de kun indeholder komponenter og forbindelser, som alle skal være fra en enkelt arkitektur i det aktuelle projekt.

1. Sørg for, at du har en ny eller eksisterende boble diagram åbenog du har foretaget de nødvendige ændringer.

2. I diagrammet værktøjslinjen klik på den venstre Gem Chartknappen for at gemme diagrammet og eventuelle formatering ændringer.

3. I Chart Navndialogboks, der vises indtaste et navn til boblen diagrammet, og tryk på Okay.

For at eksportere en boble diagram

1. Sikre, at du har åbne en eksisterende boble diagram.

2. I diagrammet værktøjslinjen klik på 2. fra venstre Gem som BMPknappen og valgte placering for diagrammet.

3. Klik Spare.

Se også

Analyse din arkitektur


Arkitektur Diff og Sync

Navigation: Analyse din arkitektur>

Arkitektur Diff og Sync

Send kommentarer om dette emne.

Når du har 2 eller flere arkitekturer, enten som evolutioner eller baseline arkitekturer, kan du visuelt 'diff' de to arkitekturer ved hjælp katalog eller diagram Sammenligning eller Arkitektur Diff funktion. Dette er især nyttigt for at opdage / re-opdage de præcise ændringer fra den ene arkitektur til en anden, som du udvikler arkitekturer og udvikle køreplaner i ABACUS.

Til vise 'diff' med en anden arkitektur via et diagram

1. Sikre, at du har en ABACUS fil åben .

2. Sikre, at du have mindst 2 arkitekturer i projektet.

3. Åbn diagrammet, du ønsker at sammenligne med en anden arkitektur.

4. Klik på "Sammenlign dette diagram til indholdet af en anden arkitektur" knappen på Diagram værktøjslinjen.

5. Vælg den anden arkitektur fra drop-down listen for at sammenligne med.

6. Du kan filtrere hvilke forskelle er vist ved at klikke på knappen 'Forskelle "på Diagram værktøjslinjen og fravælge muligheder, f.eks Ændret / Added / Ukendt og Ubestemt / Sync Anbefalet/ Hold Anbefalet.

Note

Komponenter og tilslutninger på diagrammet vil blive fremhævet i rød, grøn eller lilla hvor der er forskelle mellem det indhold, der er synlig på den aktuelle diagram og indholdet i den anden arkitektur. Rød anvendes, hvor det anbefales at synkronisere forskelle (se nedenfor), Grøn anvendes, hvor det ikke anbefales at synkronisere forskellene, der er at holde dem (se nedenfor) og Lilla anvendes hvor ABACUS ikke kan fremsætte en henstilling om synkronisering af de forskelle (se nedenfor). Kun det synlige indhold på diagrammet sammenlignes, så hvis en anmærkning viser et opbevaringssted ejendomsværdi, og at værdien ændres den givne komponent eller forbindelsen vil blive vist i svag rød, svag grøn eller svag lilla og en '*' symbol vises øverst til venstre for komponenter, men hvis nogle andre underliggende repository ejendomsværdi ændret, som ikke bliver vist i en anmærkning så ingen tegn vil blive givet. Indhold der forekommer på det nuværende diagram, men ingen match er fundet i sammenligningen arkitektur vil blive vist i stærk rød, stærk grøn eller stærk lillaog et '+' symbolet vises øverst til venstre for komponenter. Matching sker ved typegodkendelse og navn, således at hvis den type eller navnet på den komponent eller tilslutning har ændret sig i den anden arkitektur ingen match vil blive fundet. Da der ikke er nogen mulighed for pålideligt at bestemme, om det ville have været vist ekstra indhold fra den anden arkitektur på nuværende diagram (fx en ekstra interface mellem 2 komponenter som vist nedenfor i et diagram fra sammenligningen arkitektur til højre), er disse forskelle ikke vist for diagrammer (de er vist for kataloger som pr nedenfor). Svævende over hver ændrede punkt vil vise forskellen i tooltip. Svævende over den '*' symbol i øverste venstre af diagrammet giver en oversigt over de ændringer (eller ingen ændringer) mellem diagrammet indhold og indholdet af den anden arkitektur.

Farve Legend

· Grøn angiver elementer, at det ikke anbefales at synkronisere forskellene, det er at holde dem.

· Rød angiver emner, som det anbefales at synkronisere forskellene.

· Lilla angiver poster, hvor ABACUS ikke kan gøre en anbefaling om synkronisering forskellene.

Til synkronisere indhold ("sync") fra en arkitektur med hinanden via et diagram

1. Sikre, at du har en ABACUS fil åben .

2. Sikre, at du have mindst 2 arkitekturer i projektet.

3. Åbn diagrammet, du ønsker at sammenligne med en anden arkitektur.

4. Klik på "Sammenlign dette katalog til indholdet af en anden arkitektur" knappen på Diagram værktøjslinjen.

5. Vælg den anden arkitektur fra drop-down listen for at sammenligne med.

Note

Se ovenfor for den måde ABACUS viser "diff" mellem de 2 arkitekturer i kataloget. Især hvor Rød anvendes, hvor det eranbefales at Synkroniser forskellene, Grøn anvendes, hvor det er ikkeanbefales at synkronisere forskellene og Lilla anvendes hvor ABACUS ikke kan fremsætte en henstilling om synkronisering forskellene.

6. Højreklik på diagrammet elementet (eller elementer ved hjælp af Shift eller diagrammet lærred til Sync All), der viser en "diff" og vælg menupunktet Sync-menuen.

Note

Eventuelle synkronisering ændringer vil kun blive anvendt på den arkitektur, der i øjeblikket er i fokus kataloget tilhører. At anvende ændringerne til den anden arkitektur skal du bruge et katalog i den anden arkitektur. Desuden vil brugere være i stand til at anvende synkronisering ændringer, hvis de have tilladelse til det .

Note

Afhængigt af hvor du højreklikke menupunkt vil vise vejledning om, hvad der præcist vil blive synkroniseret. F.eks. Højreklik på en enkelt komponent i diagrammet vil kun synkronisere denne komponent. Hvorimod højreklikke på diagrammet lærred og vælge Sync All synkroniserer alle de aktuelt viste forskelle.

Til vise 'diff' med en anden arkitektur via et katalog

1. Sikre, at du har en ABACUS fil åben .

2. Sikre, at du have mindst 2 arkitekturer i projektet.

3. Åbn kataloget, du ønsker at sammenligne med en anden arkitektur.

4. Klik på "Sammenlign dette katalog til indholdet af en anden arkitektur" knappen på katalog værktøjslinjen.

5. Vælg den anden arkitektur fra drop-down listen for at sammenligne med.

6. Du kan filtrere hvilke forskelle er vist ved at klikke på knappen 'Forskelle "på Diagram værktøjslinjen og fravælge muligheder, f.eks Ændret / Added / Ukendt og Ubestemt / Sync Anbefalet/ Hold Anbefalet.

Note

Celler i kataloget vil blive fremhævet i rød, grøn eller lilla hvor der er forskelle mellem indholdet i det aktuelle katalog og den matchende indhold i den anden arkitektur. Rød anvendes, hvor det anbefales at synkronisere forskelle (se nedenfor), Grøn anvendes, hvor det ikke anbefales at synkronisere forskellene, der er at holde dem (se nedenfor) og Lilla anvendes hvor ABACUS ikke kan fremsætte en henstilling om synkronisering af de forskelle (se nedenfor). Kun de synlige rækker og kolonner i kataloget sammenlignes så hvis der er en forskel i træk ud over de aktuelt viste rækker eller en værdi i en kolonne, der ikke er vist har en forskel så ingen forskel vil fremgå. Hvis værdien i en individuel celle er anderledes med den matchende celle i sammenligning arkitekturen cellens grænse vil blive fremhævet. Kolonneoverskriften og række selector vil også blive nedtonet i svag lillaog vist med en "*" symbol. Disse '*' symboler kan klikkes for at springe til næste forskel i kolonne eller række hhv. Rækker, der opstår i det aktuelle katalog, men ingen match findes i sammenligningen arkitektur vil blive vist med et '+' symbol i rækken vælgeren til venstre og grænsen til hele rækken vil blive fremhævet. Rækker, der ville have fundet sted i sammenligningen arkitekturens udgave af kataloget (dvs. med de samme filtre osv), men ingen match findes i den aktuelle arkitektur vil blive vist med et '-' symbol i rækken vælgeren til venstre, grænsen til hele rækken vil blive fremhævet og hele rækker celler indhold vil blive vist i svag lillaog slog-igennem, f.eks 08:00 til 06:00. Matching sker ved typegodkendelse og navn, således at hvis den type eller navnet på den komponent eller tilslutning har ændret sig i den anden arkitektur ingen match vil blive fundet. Svævende over hver ændrede punkt vil vise forskellen i tooltip. Svævende over den '*' symbol i øverste venstre af diagrammet giver en oversigt over de ændringer (eller ingen ændringer) mellem diagrammet indhold og indholdet af den anden arkitektur.

Farve Legend

· Grøn angiver elementer, at det ikke anbefales at synkronisere forskellene, det er at holde dem.

· Rød angiver emner, som det anbefales at synkronisere forskellene.

· Lilla angiver poster, hvor ABACUS ikke kan gøre en anbefaling om synkronisering forskellene.

Til synkronisere indhold ("sync") fra en arkitektur med hinanden via et katalog

1. Sikre, at du har en ABACUS fil åben .

2. Sikre, at du have mindst 2 arkitekturer i projektet.

3. Åbn kataloget, du ønsker at sammenligne med en anden arkitektur.

4. Klik på "Sammenlign dette katalog til indholdet af en anden arkitektur" knappen på katalog værktøjslinjen.

5. Vælg den anden arkitektur fra drop-down listen for at sammenligne med.

Note

Se ovenfor for den måde ABACUS viser "diff" mellem de 2 arkitekturer i kataloget. Især hvor Rød anvendes, hvor det eranbefales at Synkroniser forskellene, Grøn anvendes, hvor det er ikkeanbefales at synkronisere forskellene og Lilla anvendes hvor ABACUS ikke kan fremsætte en henstilling om synkronisering forskellene.

6. Højreklik på cellen, kolonne eller række på vej (eller flere elementer ved hjælp af Shift eller Ctrl + A for alt), der viser en "diff" og vælg menupunktet Sync-menuen.

Note

Eventuelle synkronisering ændringer vil kun blive anvendt på den arkitektur, der i øjeblikket er i fokus kataloget tilhører. At anvende ændringerne til den anden arkitektur skal du bruge et katalog i den anden arkitektur. Desuden vil brugere være i stand til at anvende synkronisering ændringer, hvis de have tilladelse til det .

Note

Afhængigt af hvor du højreklikke (dvs. en celle, kolonne eller overskrift række) menupunktet vil vise vejledning om, hvad der præcist vil blive synkroniseret. F.eks. Højreklikke på en enkelt ejendom eller fastgjort komponent celle i kataloget vil kun synkronisere, at ejendommen eller vedhæftet komponent. Hvorimod at højreklikke på en række overskrift (eller overskrifter hjælp Shift) synkroniserer hele rækken (eller rækker). Højreklik på en kolonneoverskrift synkroniserer alle forskelle i den pågældende kolonne.

For at se et 'diff'2 hel arkitekturer

1. Sikre, at du har en ABACUS fil åben .

2. Sikre, at du have mindst 2 arkitekturer i projektet.

3. Vælge Værktøj| Arkitektur Diff ....

4. I den dialogboks, der vises vælg den første / Fra og sekund / Til arkitekturer at sammenligne.

5. Klik på Okay knap.

Arkitektur Diff

Farve Legend

· Grønangiver, at knuden blev tilsat i det andet / til arkitektur.

· Rødangiver, at knuden blev slettet i det andet / Til arkitektur.

· Blåangiver, at knuden har forskellige attributter (f.eks egenskaber eller standarder) i andet / til arkitektur.

· Gulangiver, at knuden har forskelle i sine børn i den anden / Til arkitektur, så knuden bør udvides.

Note

Du kan højreklikke og "Vis i Stifinder" på alle noder for at se detaljer og mere information gives på forskellene i Forskelle Resumé panelet, når en node er valgt.

Se også

Analyse din arkitektur | Visning af en responstid diagram | Visning af en Scatterplot matrix af dine udviklet arkitekturer | Evolving din arkitektur


Simulering din arkitektur

Navigation: Simulering din arkitektur>

Simulering din arkitektur

Send kommentarer om dette emne.

Når du har udfyldt og analyseret din arkitektur, er du klar til at bruge ABACUS at afgøre, om din arkitektur vil opfylde dine kvantitative behov. Dette kræver simulering. For at simulere din arkitektur skal du først beslutte, hvilken slags oplysninger, du vil opdage. Disse typer af information er ofte omtales som KPI'er, eller Key Performance Indicators. For eksempel, vil du analysere performance, udviklingsevne og åbenhed, eller ønsker du at samle parametre såsom samlede ejeromkostninger. Alle disse oplysninger kan blive afsløret på en eller anden måde. Når du har disse data, vil du være i stand til at analysere din arkitektur i en række forskellige grafiske formater (eller analysere de nye værdier direkte).

Der er tre muligheder for at simulere din arkitektur:

· Simple målinger ;

· Præ-bygget simulatorer ; eller

· Scripting .

Simple Metrics

Hver komponent i din arkitektur har egenskaber - hvoraf mange kan være tilpasset til din ansøgning af ABACUS. Disse egenskaber repræsenterer forskellige komponenternes karakteristika. I nogle tilfælde blot indsamle disse målinger (at bygge nøgletal) kan være nok til at fortælle dig vigtige oplysninger om din arkitektur. For eksempel, KLOCS eller Tusindvis af linjer kode, er ofte blevet brugt som et mål for kompleksitet. I andre tilfælde kan du eksportere data og analysere den ved hjælp et andet værktøj. Derudover kan du ønsker at indsamle egenskaber efter udførelse anden form for simulation.

Egenskaber kan indsamles gennem processen med sammenlægning . Aggregering tilføjer specificerede sub-egenskaber i alt, som afspejles i moder- komponent. Aggregering virker kun på komponenter, der indeholder delkomponenter.

Præ-bygget Simulatorer

Der er fem præ-bygget simulatorer, der kan anvendes med ABACUS. Disse er:

· Præstation;

· Modularitet;

· Total Cost of Ownership (TCO);

· Åbenhed; og

· Pålidelighed.

Note

ABACUS vil automatisk fremhæve, hvilke af disse simulatorer er nødt til at re-løber gennem Rød fremhæve på Simulation værktøjslinje .

Scripting

Scripting giver fleksibilitet til at simulere din arkitektur på brugerdefinerede måder. Ved skrive scripts du kan udføre simuleringer ud over den nuværende indbygget kapacitet på ABACUS. Hele ABACUS objekt model er til rådighed for scripting motor, så du er kun begrænset af din evne til at skrive scripts!

Visual Basic script er scriptsprog støttet af ABACUS, da det giver væsentlige programmering funktioner i et rimeligt enkelt format.

Se også

Eksport af din arkitektur | Aggregerede egenskaber | Skrivning scripts


Skrivning Scripts

Navigation: Simulering din arkitektur>

Skrivning Scripts

Send kommentarer om dette emne.

The Script Editor er en enkel og funktionel værktøj til at skrive og udføre VB eller C # script mod aktuelt åbnede ABACUS fil(Biblioteker understøttes ikke i scripting). Det har den sædvanlige Fil Åbn, Luk og gem kommandoer, så du kan gemme og hente scripts, du skriver. Det har også en grundlæggende køre og debug facilitet. The Script Manager kan du nemt udføre de forskellige scripts, som du har skrevet ved at placere en menu-post til dem direkte i menuen Funktioner.

At få adgang til Script Editor

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Vælge Værktøj | Script Editorog vinduet Script Editor åbnes. Så enten;

3. Åbne et eksisterende script via Fil | Åben i menuer drejebogsredaktør,

eller

3. Åbn en eksempel script via Eksempel element i menuer drejebogsredaktør,

eller

3. Indstille standardsproget til enten VB eller C # via Sprog element i menuer drejebogsredaktør,

eller

3. Åbent scripting specifik Hjælp via Hjælp element i menuer scripteditoren

Når du skriver scripts, skal du overholde enten VB eller C # syntakssom pr indstilling under Sprog post i menuer scripteditoren.

NOTE:

· Hvis du vil bruge standard VB funktioner som MsgBox ()du skal indeholde Import Microsoft.VisualBasicerklæring i begyndelsen af ​​dit script. Det var ikke nødvendigt, før version 3.0 af ABACUS.

· Denne hjælp omfatter ikke oplysninger om, hvordan man skriver VB script, heller ikke indeholde en VB reference. Du er velkommen til at skrive dine scripts i din foretrukne IDE eller redaktør, derefter kopiere og indsætte dem i Script Editor.

Når du først starter Script Editor, vil Script Editor være tom. Du kan få adgang til et skelet script gennem eksempler menuen. Første gang du starter din Script Editor, skal du køre skelet skabelonen til at se, at det virker. Derudover er der to eksempler scripts, som kan tilgås via Eksempler menuen.

For at skrive en nyttig script vil du nødt til at henvise til ABACUS ObjectModel. Det stilles til rådighed for dit script ved at inkludere Import ABACUS.ObjectModelerklæring i spidsen for dit script. En komplet reference til hele ABACUS objekt model er inkluderet i Script Editor. Du kan finde den ved at vælge Hjælp | Indholdfra vinduet Script Editor.

Scriptet editor indeholder mange nyttige funktioner til at skrive manuskripter, herunder Autofuldførelse som vist i skærmbilledet nedenfor. Men for en endnu rigere brugeroplevelse MS Visual Studio kan integreres med ABACUS og detaljerede instruktioner er tilgængelige her .

Script Editor med Autofuldførelse

Hvis du vil bruge Script manager

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Vælg Funktioner | Script manager.

3. Klik på Tilføjeikon og et Åbenvises.

4. Gå til den ABACUS Script (.abacusscript, .vb Eller .cs) Fil, du vil føje til menuen Funktioner.

5. Klik Okayog en henvisning til scriptet, vil blive vist i Script vinduet. Indtast navnet på scriptet som du ønsker det skal vises i menuen Værktøjer. Bemærk: The Script Manager-vinduet kan skaleres for at se den fulde sti hvis det er nødvendigt.

6. Gentag trin 3-5at oprette links til flere ABACUS scripts.

7. Klik Tætat lukke Script Manager og bemærk, at ABACUS script (s) vises nu under menuen Funktioner.

At køre et script

Enten;

1. Åbn, skrive i, eller kopiere og indsætte i scriptet, du vil køre, så det vises i hovedvinduet af Script Editor.

2. Klik på Løbe knap.

3. Hvis dit script indeholder fejl, vil Fejlbeskrivelse sektionen nederst scripteditoren liste detaljerne herunder linjenumre. NOTE: Hver enkelt fejl i Fejlbeskrivelse sektion kan være dobbelt-klikkede at tage dig til den tilsvarende linje i scriptet.

- eller -

1. Vælge Værktøjog derefter ABACUS Script navn menupunkt som oprettet med Script manager.

2. Hvis dit script indeholder fejl, vil Script Editor åbnes med indholdet af scriptet vist i hovedvinduet (fremhævet ved linje i første fejl) og Fejl Beskrivelse sektionen nederst scripteditoren vil liste de detaljer eller fejlen (e), herunder de linjenumre. NOTE: Hver enkelt fejl i Fejlbeskrivelse sektion kan være dobbelt-klikkede at tage dig til den tilsvarende linje i scriptet.

Scripting Compilation Fejl

Compilation fejl opstår, når syntaksen af ​​script-kode er ikke korrekt. Disse fejl vil dukke op i bunden af ​​vinduet i Error afsnittet med en beskrivelse af fejlen, og en linje nummer. Det er den linje nummer, der adskiller en samling fejl fra en Runtime fejl (se nedenfor), som ikke vil have en linje nummer. Compilation fejl kan dobbelt klikkes til at springe til og fremhæve den særlige linje pågældende.

Scripting Runtime fejl (Alvorlig)

Runtime fejl opstår, efter at script-kode er lykkedes kompileret uden fejl, men der opstår en fejl på runtime (se eksempler yderligere ned). Runtime fejl er vigtige, da de kan resultere i ødelagte modeller, når objekter skabt og refereret af andre objekter i modellen, ikke i sig selv en del af modellen (som regel fordi der er opstået en kørselsfejl før den kode, der ville have sat dem i modellen et eller andet sted, blev henrettet).

Hvis dit script opretter objekter, der skal føjes til modellen, kan du undgå korruption forårsaget af en runtime fejl ved at gemme dit script, lukning scripting, og udførelse af en fortryd af de ændringer, der blev skabt af scriptet (hvis script udførelse ikke fuldføre normalt ). Men der er også andre måder at undgå enhver korruption forekommende (se nedenfor). Note: Enhver scripts, der blot læser fra den model, og ikke skrive til det, er sikre og vil ikke forårsage nogen problemer, uanset om runtime fejl opstår under deres udførelse.

For at undgå korruption, når du skriver script kode, der skaber objekter, og tilføje dem til objektet model, foreslås det, at der tilsættes objekterne til modellen så hurtigt som muligt, hvis de er refereret af andre objekter.

For eksempel, hvis du opretter en ny forbindelse, og 2 nye komponenter, og derefter vedhæfte dem sammen, er det bedst at skabe den første komponent, føje det til model, så den anden og føje det, og derefter oprette forbindelsen og føje det, og så endelig oprette vedhæftede filer. Det betyder, at hvis der skulle være en runtime fejl, der afbryder scriptet udførelse, alle objekter, der er nødvendige for at være i objectmodel før en vedhæftet fil er oprettet, er i modellen. Korruption kan opstå, hvis for eksempel kun forbindelsen var blevet tilføjet, de vedhæftede filer lavet, og derefter en runtime fejl opstod før scriptet endelig tilføjede de nye komponenter til model.Corruption kan opstå, når et objekt, der refereres til af et andet objekt i den objectmodel, er i sig selv ikke i objectmodel.

Eksempel runtime fejl kan nævnes:

· Objekt henvisning ikke indstillet til en forekomst af et objekt - det sker, når et objekt variabel er en null reference og en metode eller ejendom på objektet bliver brugt. Null referencer kan kontrolleres ved »Hvis objectVariable er intet Derefter ...«

· Indeks var uden for rammerne af array - det sker, når et array der oprettes adgang med et indeks, der ligger uden for grænserne - fx mindre end 0 eller lig med eller større end længden / Optælling af arrayet. Array eller Collection længde kan kontrolleres af de .Length eller .Count egenskaber hhv.

· Ingen tilladelse undtagelse - Du har ikke tilladelse til at ... - denne ene opstår, hvis du ikke har tilladelse til at gøre given ændring

· Primær nøgle undtagelse - Duplicate / Missing Navn / ID - dette vil ske, hvis der foretages ændringer til en unik egenskab, der strider mod et andet objekt. F.eks. Arkitekturer skal være unikke ved navn, ligeledes med standarder.

· Referentiel integritet undtagelse - Indstilling af en henvisning felt til et objekt, der ikke er gyldig. F.eks. tilføjer "ingenting" eller null som barn til mange af de samlinger i objectmodel.

· Nul Længde undtagelse - det kan forekomme, hvis du prøver at indstille navnet på et objekt til en tom streng. De fleste objekter kræver deres navne at have mindst 1 karakter.

Import udsagn

Bemærk, at i starten af ​​skelettet scripts der er udsagn som Import ABACUS.ObjectModel. Disse udtalelser vil ikke omfatte en dll, der ikke allerede refereret af scriptet - deres formål er at give en "genvej" til at skulle angive hele navnet på en klasse.

For eksempel, til at erklære en variabel af typen CComponent (som repræsenterer en komponent i ABACUS), med Import ABACUS.ObjectModelerklæring mod toppen af ​​scriptet, vil kun kræve det, som skal deklareres dim comp som CComponent, Fordi compileren ved at kigge i ABACUS.ObjectModel namespace for CComponent klassen. Uden import erklæring, ville det have at blive erklæret som dim comp som ABACUS.ObjectModel.CComponent. En forsamling (såsom mscorlib.dll eller System.Windows.Forms.dll) kan indeholde mere end én namespace - importen erklæring er for disse navnerum, ikke for forsamlinger selv. Den ABACUS.ObjectModel.dll forsamling kun har én ABACUS.ObjectModel navnerum tilgængelige via Scripting.

Automatisk refereres forsamlinger

Følgende DLL'er refereres automatisk af Scripting:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (implicit refereres af compileren)

· ABACUS.ObjectModel.dll

For at gøre yderligere henvisninger til enten andre .NET forsamlinger, eller dine egne forsamlinger, se følgende afsnit om den #ImportDLL erklæring.

#ImportDLL Statement

Starter i ABACUS 3.1, kan du referere til yderligere forsamlinger, som du kan kræve for scripting med brug af den #ImportDLL erklæring. For eksempel, hvis du ønsker at få adgang til en brugerdefineret DLL af din og bruge alle funktionerne i det, ville du placere den i ABACUS mappe og indeholde følgende oplysning som den første linje (r) i dit script. Hvis det er en .NET dll, så normalt behøver du ikke at indtaste hele stien, bare DLL.

· #ImportDLL C: \ Program Files \ skønnede udvikling \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Nogle andre ting at bemærke:

1. Fordi DLL-filer skal findes på kompilere og runtime, dette begrænser custom (ikke .NET) DLL til at blive placeret i kun mappen ABACUS programmet.

2. #ImportDLL udsagn skal være den første linje (r) i et script - hvis du har 5 udsagn, så skal de være på de første 5 linjer af scriptet

3. En #ImportDLL redegørelse placeres overalt, men de første linjer af scriptet (fx hvis det blev placeret efter en kommentar eller en Import statement) vil ikke virke korrekt og / eller kan forårsage ubeslægtede compiler fejl.

#ImportDLL med Office forsamlinger

Hvis du har Microsoft Office installeret, og din script kræver Office Interop forsamlinger, er det muligt at referere dem blot ved at bruge #ImportDLL med samlingen navn (som anført nedenfor, f.eks. #ImportDLL Excel). Ved hjælp af denne metode har den fordel, at en absolut dll sti ikke behøver at blive brugt, så scriptet er mere bærbare (bør arbejde på både Office 2003 og 2007 uden at redigere scriptet).

Når du bruger denne funktion, er GAC (Global Assembly Cache) søges til Interop samling, og scriptet samler med stien til den opstilling, hvis fundet. Hvis det ikke er fundet, vil scripting tjekke ABACUS programmet biblioteket (som indeholder den Excel og Visio interops kun). Hvis den anmodede Interop ikke findes på dette tidspunkt, er der vist en advarsel.

De interops er typisk ikke installeret i GAC hvis du har installeret Microsoft Office, før du installerer .NET Framework (som er en del af den fulde ABACUS installation). Du kan installere dem ved at udføre Skift indstillingen til Microsoft Office fra Tilføj / fjern programmer, og vælg NET programmering muligheder. For mere info, se denne artiklen på MSDN.

De forsamlinger, for hvilke denne genvej understøttes er:

· Adgang

· Access.Dao

· Excel

· Kurve

· MSProject

· Outlook

· OutlookViewCtl

· Owc11

· PowerPoint

· Forlægger

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Ord

It er ikke helt klart, om alle de ovennævnte forsamlinger er nyttige, værelser havebeen inkluderet i denne funktion regardeless som nogle brugere feb har et behov for selv de obskure forsamlinger.

Se også

Simulering din arkitektur

© 2001-2015 skønnede udvikling Pty Ltd. Alle rettigheder forbeholdes.


Brug makroer

Navigation: Simulering din arkitektur>

Brug makroer

Send kommentarer om dette emne.

Hvis du udfører en opgave flere gange i ABACUS, kan du automatisere opgaven ved hjælp af en makro. Følgelig en abacus makro er en registreret række operationer, der kan afspilles på ethvert tidspunkt.

Optagelse af en makro

1. Vælg Funktioner | Indspil makroeller alternativt trykke Alt + F10.

2. Begynd at udføre operationer, som du ønsker at optage.

Advarsel

På dette tidspunkt er der nogle kendte problemer med makro optagelse. Venligst tage disse i betragtning, når du optager dine makroer:

· I øjeblikket makroer blot registrere dine Microsoft Windows-tastetryk, mus-bevægelser og museklik. Men på grund af begrænsninger med makrooptageren selv, er der nogle tastetryk som ikke altid er optaget. Heriblandt:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Starte]

· [F1] til [F12]

· Det anbefales derfor, at du kontrollerer, at en tastaturgenvej er registreret af makro optageren, før du optager en stor sekvens af hændelser, som kan afhænge af, at tastaturgenvej arbejde.

· I øjeblikket på grund af begrænsninger med makro-optager, er kontekstmenuer ikke håndteres korrekt af ABACUS, når de åbnes af en handling registreret af makro optageren. Når du åbner en genvejsmenu, skal du udføre en af ​​de funktioner, der er anført i genvejsmenuen via genvejsmenuen, ellers genvejsmenuen kan forblive åben under afspilning, hvilket kan føre til utilsigtede handlinger eller handlinger, som kan medføre fejl i ABACUS.

· Bemærk, at normale metoder til at lukke en genvejsmenu (f.eks at trykke på [Esc] på tastaturet, eller venstre klikke et andet sted på skærmen), kan faktisk ikke lukke genvejsmenuen under afspilning af en makro.

Tip

I dialoger, snarere end at bruge museklik, anbefales det at bruge tabulatortasten til at flytte gennem de tilgængelige kontroller og piletasterne til at vælge pull-down menupunkter eller radio knap optioner og mellemrumstasten for at vælge / de-vælg kontrol kasser.

Stop optagelse af en makro

1. Trykke Alt + F9eller alternativt vælge Værktøjer | Stop Makro.

2. I Gem makro som dialogen gennemse til et sted, og vælg en ABACUS makro (.abacusmac fil) filnavn og klik på Gem.

Note

Ved brug af Værktøj| Stop Makrovil omfatte denne operation i den indspillede makro. Det anbefales derfor, at brugerne bliver dygtige i at bruge de Alt + Funktionstastkombinationer muligheder for at arbejde med makroer for ikke at omfatte uønskede makro operationer i makroerne selv.

Tip

Da makroer øjeblikket ikke redigeres, anbefales det at optage lange opgaver som en række separate makroer ved hjælp af Alt + F10 / Alt + F9 "par".

For at afspille en optaget Macro

1. Vælg Funktioner | Afspilning Macroeller alternativt trykke Alt + F8.

2. I Open Makro dialogen gennemse til et sted, og vælg en ABACUS makro (.abacusmac fil) filnavn og klik på Åbn.

Advarsel

Når du åbner en ABACUS makro, hvis du dobbeltklikker på en makro-fil i dialogboksen Gennemse for at åbne den, kan den makro optageren hold venstre museknap i en venstre-klikket tilstand, indtil en optaget venstre-klik tilsidesætter denne stat.

Note

Afspilningshastigheden af ​​makroen kan indstilles under fanen Generelt under Værktøj| Optionersom enten Normal (standard), hurtig eller langsom. Både hurtig og langsom afspilning hastigheder er ikke anbefales, da de vil afspille de optagede makroer på cirka 100 gange og 1 / 100th realtid, hhv. Normal afspilningshastighed vil stadig afspille makroen ca. 30% hurtigere end den indspillede hastighed, så det anbefales under optagelse for at holde pause for en kort tid efter eventuelle langvarige forarbejdning opgaver for at sikre, at der på afspilning den næste operation er ikke udført, før opgaven behandlingen har afsluttet.

Stop afspilning af en optaget Macro

1. Trykke Alt + F9.


Simulering ydeevne

Navigation: Simulering din arkitektur> Simulatorer>

Simulering ydeevne

Send kommentarer om dette emne.

Baggrund

Den arkitektoniske evaluator for ydelse er en diskret begivenhed simulator, der virker ved at simulere strømmen af ​​meddelelser (eller tokens) hele en arkitektur. Teorien bag dette er afledt af forskning udført af University of Technology, Sydney, og er baseret på Layered kø Network Models(LQNM), Tidsindstillet og Farvede Petri-Net(TCPN) og Aktivitet Taktdiagrammer(ACD).

I ABACUS ydeevne simulation, er behandlingen på en komponent, drevet af meddelelser sendes til det fra en anden komponent. Principperne bag denne teknik kan forstås i fire hoveddele:

1. De besked-centreretkommunikation er modelleret i ABACUS hjælp logisk(eller indirekte) forbindelser. Logiske forbindelser definerer adfærd (frekvens og data) af de passerede mellem komponenterne beskeder. Et godt eksempel på logiske forbindelser ville være sekvensen strømme mellem to (2) forretningsprocesser eller de logiske grænseflader mellem to (2) applikationer.

2. Logiske beskeder transporteres til deres bestemmelsessted via hierarki(såsom ressource swimlanes) eller direkteforbindelser (såsom fysiske ledninger). For at gøre dette, de kan dirigeres op, på tværs af og bakke ned i hierarkiet (en lagdelt tilgang) for at følge den direkte vej.

3. Korrektheden af ​​modellen kan tilpasses. For eksempel kan en fremgangsmåde opdeles så langt ned, således at hver elementære proces og funktion har en separat processor fodaftryk. Alternativt kan det være nok at have bare en værdi for hele processen, hvilket afspejler den gennemsnitforarbejdning svar på en meddelelse.

4. Den faktiske forarbejdninger kun udføres af komponenter, der har (eller er) en processor. En processor er en generisk ting, og kunne være en CPU, en person, en organisatorisk enhed eller noget andet, der er i stand til at udføre arbejdet. For eksempel giver en forretningsproces ikke nogen egentlig behandling; dette gøres ved den første »forarbejdningsvirksomhed« det lokaliserer i enten dets moderselskab hierarki (hvis der anvendes en svømmebane notation) eller dens netværk for (hvis der anvendes et distribueret behandling notation).

Evalueringen udføres ved at simulere (specificeret) trafik i systemet, således at hver forbindelse er simuleret mindst én gang. Ankomsttider af meddelelser er tilfældigt genereret med hensyn til deres specificerede frekvens. Modellen simulerer behandling og påstand ressource og kø af meddelelser, indsamle statistik undervejs diverse output egenskaber.

Key Performance inputfaktorer

1. Frekvens- Den frekvens, ved hvilken forbindelsen sker.

2. Forarbejdning- Mængden af ​​gennemførelsestid til at fuldføre en proces. Dette kan være i timer, minutter, dage, operationer mv

3. Fart- Hastigheden af ​​processoren ressource. Det vil sige, hvor mange cykler / vejledning / foranstaltninger, som den kan udføre i en enhed af tid. Det er vigtigt at være i overensstemmelse med de enheder, der anvendes til forarbejdning.

4. Processorer- Antallet af processor ressourcer. Processorer kunne være folk, CPU'er, eksterne organisationer mv

Key Performance Output Faktorer

1. Gennemløb- Antallet af meddelelser per tidsenhed gennem forbindelse. Denne faktiske værdi kan sammenlignes med de forventede / teoretiske værdier (dvs. Frequency) at udlede mætning af systemet.

2. Beskedhastighed- Antallet af meddelelser per tidsenhed gennem komponent. Dette er summen af ​​alle de komponenter 'indkommende og udgående meddelelser.

3. Svar- Den mindste / gennemsnit / maksimum latenstid for denne forbindelse. Dette er summen af ​​alle de observerede latenser for forbindelse fra kilden til vasken og enhver kø og forarbejdning (og latens tilbage til kilden, hvis tovejs).

4. Udnyttelse- Udnyttelsen af komponent. Dette vil være 0%, hvis komponenten er ikke en enhed / processor (dvs. det har ikke de processorer og Speed ​​egenskaber defineret ovenfor).

Mens en diskret begivenhed simulation udføres for at beregne de forskellige output egenskaber, som beskrevet ovenfor, kan følgende formel anvendes som et groft verifikation af resultaterne (hvor anlægget ikke er mættet):

Udnyttelse = sum af frekvens for alle indgående forbindelser * Forarbejdning / (hastighed * Processorer)

Det overordnede koncept er måske bedst demonstreres ved at overveje følgende diagram, som viser to forskellige ydeevne meta-modeller. Den venstre hånd stil er den klassiske 'svømmebane' notation med forarbejdning opgaver baseret hierarkisk inden for deres processor ressourcer. Den højre hånd stil er et "distribueret" notation med forarbejdning opgaver forbundet via en processer forbindelse til deres processor ressource. Sidstnævnte notation tillader flere processor ressourcer til en given behandling opgave, i modsætning til den begrænsede svømmebane notation.

Note

Vises på hver meta-modellen er input egenskaber (i rødt) og output egenskaber (i blåt):

Præstationer meta-modeller: svømmebane versus Distributed notation

Kørsel Performance simulator

For at simulere din arkitektur med hensyn til ydeevne

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Vælge Analyse| Præstationeller klik på knappen værktøjslinjen.

3. Vælg Arkitekturdu ønsker at evaluere fra pull-down menuen.

Note

Som standard vil ABACUS automatisk vælge den første arkitektur for hvilke en re-simulering er nødvendig på grund af et underliggende ejendom eller strukturelle ændringer.Denne fremhævning er vist i Rød på den Simulation værktøjslinje .

4. Vælg Komponenter og Tilslutningerdu ønsker at evaluere, fra Vinduet til valg standard element .

5. Indstil Run Time Scale Factorskyderen.

Note

Højere værdier vil give mere statistisk konsistente resultater, men tager længere tid at beregne.

Ekstra Afkrydsningsfelt til Vinduet til valg standard element

· Save Transformeret Model vilje gemme en kopi af RBD forvandlet version af projektet i den samme mappe som det aktuelle projekt og tilføje "_transformed" til navnet projektet.Denne transformerede projekt kan anvendes til at diagnosticere detaljeret pålideligheden simulation foretaget af ABACUS.

Andre muligheder til Vinduet til valg standard element

· Run Time Scale Factor styrer simulation tid og nøjagtighed med højere værdier udbytteINGmere statistisk konsistente resultater, men tager længere tid til løbe.

Note

Når ABACUS beregner simuleringen tid, det vil afgøre den langsomste indirekte tilslutning Frekvens, der blev valgt til at blive simuleret og derefter 'warm-up for perioden (dvs. 1 over Frequency) i denne forbindelse (indlede periodiske besked generatorer til alle forbindelser tilfældigt i løbet af denne opvarmningstid, give dem alle en chance for at initiere) og derefter simulere for Run Time Scale Factor gange Periode af denne forbindelse. Eller (1 / frekvens) opvarmningstid + (1 / frekvens) * Run Time Scale Factor simulering tid. Dette er at sikre, at at alle tilslutninger er påbegyndt før statistikken indsamles og derefter den langsomste forbindelsen er stadig simuleret mindst én gang i simuleringen. F.eks. Hvis den langsomste indirekte forbindelse har en frekvens på 0,033 time-enheder (eller circa en gang om måneden, hvis de frister enheder er dage), så den varme-up tid vil være 30,3 time-enheder, og simuleringen tid vil være 30,3 time-enheder gange Kør tid Scale Factor.

6. Klik Slutteog du vil få en Advarseldialogen.

7. Eventuelt udforske advarslerne ved at klikke Detaljer >>.

8. Klik Blive ved.

Note

På dette tidspunkt vil ABACUS udføre en diskret-event simulering af arkitekturen og efter kort tid (med fremskridt barer for feedback) en beregning komplet dialogboks vises.

9. Klik Okayat anerkende simuleringen.

Tip

For kurser og yderligere hjælp på Ydelse Simulering henvises til Skønnede udvikling Fællesskab .

Egenskaber Komponent

Lister Nedenstående tabel de egenskaber, der kræves for at evaluere performance. Ejendomme er søgt efter først i komponenten tilfælde derefter Component Standards og hvis ikke fundet, standard bruges.Disse egenskaber vil blive vist i vinduet med en ejendom input rækken vælger ikon Properties ( [image] ) Med værktøjstip "Ydeevne Input". En ændring til nogen af ​​disse "input" egenskaber og forskellige strukturelle ændringer til arkivet vil resultere i Performance simulator kræver en re-simulation som angivet i Rød på den Simulation værktøjslinje .

Type | Navn | Standard værdi | Enhed | Datatype | Nødvendig | Beskrivelse
Opførsel | b_pack | 0,0 |  | Decimal | falsk | Den faste tjeneste tid til at pakke i sekunder. Denne ejendom er typisk angivet som en standard type og derefter bruges til flere komponenteksempler. For eksempel CORBA har b_pack = 0,23 ms.
Opførsel | m_pack | 0,0 |  | Decimal | falsk | Den variable tjeneste tid til at pakke i sekunder / byte. Denne ejendom er typisk angivet som en standard type og derefter bruges til flere komponenteksempler.
Opførsel | b_unpack | 0,0 |  | Decimal | falsk | Den faste tjeneste tid til at pakke ud i sekunder. Denne ejendom er typiskangivet som en standard type og derefter bruges til flere komponenteksempler.
Opførsel | m_unpack | 0,0 |  | Decimal | falsk | Den variable tjenesten tid at pakke i sekunder / byte. Denne ejendom er typiskangivet som en standard type og derefter bruges til flere komponenteksempler.
Opførsel | Forarbejdning | 0,0 |  | Decimal | Rigtigt | Mængden af ​​gennemførelsestid til at fuldføre en proces. Dette kan være i timer, minutter, dage, operationer mv
Opførsel | Processorer | 1 |  | Heltal | Rigtigt | Antallet af Processor ressourcer. Processorer kunne være folk, CPU'er, eksterne organisationer mv
Opførsel | Fart | 100 |  | Heltal | Rigtigt | Hastigheden af ​​processoren ressource. Det vil sige, hvor mange cykler / vejledning / foranstaltninger, som den kan udføre i en enhed af tid. Det er vigtigt at være i overensstemmelse med de enheder, der anvendes til forarbejdning.
Opførsel | k_bkgd | 0,0 |  | Decimal | falsk | Baggrund behandling på komponenten. Dette bruges til at justere de resultater, der matcher alle faste forskydninger for%. Dette kan sandsynligvis blive ignoreret.

Nedenstående tabel viser den komponent egenskaber output ved udførelsen evaluator. Et sæt af disse komponenter egenskaber genereres for hver komponent på hver forestilling løb.Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Ydeevne Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Performance simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Opførsel | Beskedhastighed |  | Decimal | falsk | Antallet af meddelelser per tidsenhed gennem komponenten. Dette er summen af ​​alle de komponenter 'indkommende og udgående meddelelser.
Opførsel | Båndbredde |  | Decimal | falsk | Samlet båndbredde gennem komponenten. Det skyldige beløb til både indgående og udgående meddelelser.
Opførsel | Udnyttelse | % | Decimal | falsk | Udnyttelsen af ​​komponenten. Dette vil være 0%, hvis komponenten er ikke en enhed / processor (dvs. Det behøver ikke Processorer og Speed ​​egenskaber defineret ovenfor)

Egenskaber Connection

Lister Nedenstående tabel de egenskaber, der kræves for at evaluere performance. Ejendomme er søgt efter først i forbindelsen tilfælde, er forbindelsen Standarder og hvis ikke fundet, er standard anvendes.Disse egenskaber vil blive vist i vinduet med en ejendom input rækken vælger ikon Properties ( [image] ) Med værktøjstip "Ydeevne Input" eller "Cost / Ydeevne Input". En ændring til nogen af ​​disse "input" egenskaber og forskellige strukturelle ændringer i arkivet vil resultere i Ydeevne simulator og / eller Omkostninger simulator kræver en re-simulation som angivet i Rød på den Simulation værktøjslinje .

Type

Navn

Standard værdi

Enhed

Datatype

Nødvendig

Beskrivelse

Opførsel

Slags

tovejs

[tovejs | envejs]

Opslag / liste

Rigtigt

Om forbindelsen er tovejs (tovejs) eller en-vejs (envejs).

De tilladte værdier for denne egenskab er "tovejs" eller "ensrettet".

Tovejs betyder synkrone anmodning / svarmeddelelser mens ensrettet måde en enkelt asynkron "begivenhed".

Opførsel

Abstraction

indirekte

[indirekte | direkte]

Opslag / liste

Rigtigt

Om forbindelsen er fysisk eller logisk. Direkte forbindelser er fysiske "rør" mellem to komponenter, som logiske forbindelser flyder sammen.

De tilladte værdier for denne egenskab er "direkte" eller "indirekte".

Hvis værdien er "direkte" så forbindelsen ikke behøver nogen anden egenskaber (med undtagelse af de egenskaber, Kind og abstraktion).

Data

L_app1

0

Heltal

falsk

Anmodning / begivenhed størrelse i bytes.

Hver forbindelse vil typisk have en specifik værdi for dette. I CORBA, begivenheder er faktisk tovejs og altid har en 12 byte erkende (L_app2). Hvis det er en sand ensrettet forbindelse derefter udelade ejendommen L_app2.

Data

L_app2

0

Heltal

falsk

Respons / anerkender størrelse i bytes.

Hver forbindelse vil typisk have en specifik værdi for dette. En envejs-forbindelse vil ikke have L_app2.

Opførsel

Frekvens

1

Decimal

Rigtigt

Den frekvens, ved hvilken forbindelsen sker.

Hver forbindelse vil typisk have en specifik værdi for dette. Hvis ejendommen frekvens er udeladt derefter standard anvendes.

Opførsel

Forholdet

processer

[processer | understøtter]

Opslag / liste

falsk

Forbindelser, der har den "processer" ejendom indikerer, at komponenten i begyndelsen af ​​forbindelsen vil blive omdannet til behandling på komponenten ved udgangen af ​​forbindelsen. I realiteten "kilden" komponent flyttes til at blive et barn af "synke" komponent (de vedhæftede forbindelser er også "trukket" med dette skridt).

Hvis en "processer" ejendom eksisterer derefter alle de andre forbindelsesegenskaber vil blive ignoreret, undtagen den valgfri "%" ejendom beskrevet nedenfor.

Opførsel

%

100,0

Decimal

falsk

Forbindelser, der har den "processer" ejendom (beskrevet ovenfor) kan eventuelt have en "%" egenskab at angive den del af bearbejdning, som tilskrives målbestanddelen. På denne måde kan en enkelt kilde komponent kan behandles af flere målbestanddele på forskellige% 's. De% værdier behøver ikke at tilføje op til 100%, og det er simpelthen bruges til at skalere "behandling" ejendom (se ovenfor) for kilden komponent, da den er omdannet til at blive et barn af destinationen komponent.

Lister Nedenstående tabel egenskaberne genereret af ydeevne evaluator. Et sæt af disse forbindelsesegenskaber genereres for hver forbindelse på hver forestilling løb.Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Ydeevne Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Performance simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Opførsel | Båndbredde |  | Decimal | falsk | Den samlede båndbredde til forbindelsen. Dette er kun beregnet for indirekte forbindelser, og er hovedsagelig (L_app1 + L_app2) * Throughput.
Opførsel | Båndbredde 1/2 |  | Decimal | falsk | Båndbredden specielt til udgående (1) og indgående (2) budskaber forbindelsen. Dette er kun beregnet for indirekte forbindelser, og er hovedsagelig L_app1 * Throughput og L_app2 * Throughput.
Opførsel | Gennemløb |  | Decimal | falsk | Antallet af beskeder per tidsenhed gennem forbindelsen. Denne faktiske værdi kan sammenlignes med de forventede / teoretiske værdier (dvs. Frequency) at udlede mætning af systemet.
Opførsel | Afsluttet | % | Decimal | falsk | Den procent af beskeder, der fuldføre behandling for forbindelsen. Dette er kun beregnet for indirekte forbindelser og er den Throughput / frekvens. Lejlighedsvis den Afsluttet værdi overstiger 100%, fordi tilfældighed af beskeden generation resulterer i en lidt højere besked generation frekvens end angivet.
Opførsel | Respons (Min / Ave / Max) |  | Decimal | falsk | Den mindste / gennemsnit / maksimum latenstid. Dette er kun beregnet for indirekte forbindelser, og er den observerede latenstid for forbindelsen fra kilde til vask og enhver kø og forarbejdning (og latens tilbage til kilden, hvis tovejs).

Arkitektur Egenskaber

Lister Nedenstående tabel systemet hele arkitektoniske egenskaber genereret af ydeevne evaluator. Et enkelt sæt egenskaber for arkitektur "samles" for hver forestilling løb.Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Ydeevne Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Performance simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Opførsel | Beskedhastighed |  | Decimal | falsk | Antallet af beskeder per tidsenhed gennem komponenterne i arkitekturen. Dette er summen af ​​alle de komponenter 'indkommende og udgående meddelelser.
Opførsel | Gennemløb |  | Decimal | falsk | Antallet af meddelelser per tidsenhed gennem forbindelser i arkitekturen. Dette er summen af ​​alle de indirekte forbindelser 'gennemløb, og denne aktuelle værdi kan sammenlignes med de forventede / teoretiske værdier (dvs. Frequency) for at udlede mætning af systemet.
Opførsel | Båndbredde |  | Decimal | falsk | Den samlede båndbredde. Summen af ​​arkitekturens forbindelse båndbredder.
Opførsel | Udnyttelse | % | Decimal | falsk | Udnyttelsen af ​​alle komponenter. Kan være større end 100%, da det er blot summen af ​​alle arkitekturens komponent ANVENDELSE.
Opførsel | Respons (Min / Ave / Max) |  | Decimal | falsk | Den mindste / gennemsnit / maksimum latenstid. Summen af ​​alle de observerede latenser for arkitekturens forbindelser fra kilde til at synke (og tilbage til kilden, hvis tovejs).


Simulering Modularitet

Navigation: Simulering din arkitektur> Simulatorer>

Simulering Modularitet

Send kommentarer om dette emne.

Den modularitet simulator beregner antallet af indgående og udgående forbindelser for hver komponent.

For at simulere din arkitektur i form af modularitet

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Vælge Analyse| Modularitet.

3. Vælg Arkitektur (r)du ønsker at inkludere i evalueringen.

Note

Som standard vil ABACUS automatisk vælge arkitekturen (er), for hvilke en re-simulering er nødvendig på grund af eventuelle underliggende strukturelle ændringer.Denne fremhævning er vist i Rød på den Simulation værktøjslinje .

4. Klik Næste.

5. Vælg Forbindelsestyper (s)du ønsker at inkludere i evalueringen.

6. Klik Næste.

7. Eventuelt tilpasse ejendommen navne til beregningsresultaterne.

8. Klik Slutte.

Note

På dette tidspunkt vil ABACUS udføre en strukturel evaluering af arkitekturen (r), og efter kort tid (med fremskridt barer for feedback) en beregning komplet dialogboks vises.

9. Klik Okayat anerkende evalueringen.

Tip

For kurser og yderligere hjælp på Modularitet Evaluering henvises til Skønnede udvikling Fællesskab .

Egenskaber Komponent

Lister Nedenstående tabel komponenten egenskaber, som er output af modularitet evaluator.Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Modularitet Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende strukturel ændring af arkivet og Modularitet simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Datatype | Nødvendig | Beskrivelse
Modularitet | Kobling-fan i (lokal) | Heltal | falsk | Antallet af forbindelser, der blæser ind i denne komponent.
Modularitet | Kobling-fan ud (lokal) | Heltal | falsk | Antal forbindelser, som blæser ud af denne komponent.
Modularitet | Kobling-fan i | Heltal | falsk | Antallet af forbindelser, der blæser ind i denne komponent, herunder forbindelser, ventilator i delkomponenter.
Modularitet | Kobling-fan ud | Heltal | falsk | Antal forbindelser, at fan ud af denne komponent, herunder forbindelser, ventilator i delkomponenter.


Simulering samlede ejeromkostninger (TCO)

Navigation: Simulering din arkitektur> Simulatorer>

Simulering samlede ejeromkostninger (TCO)

Send kommentarer om dette emne.

Baggrund

Total Cost of Ownership (TCO) er en finansiel skøn, der er designet til at måle de samlede afholdte levetidsomkostninger (fra anskaffelse til nedlukning / bortskaffelse) i forbindelse med ejede aktiver. TCO ikke kun afspejler omkostningerne ved køb, det omfatter også alle andre aspekter i den videre brug og vedligeholdelse af aktivet.

TCO bruges til at bestemme den indsats og budget koster nødvendigt at bruge på et system. En enkel måde at modellering i ABACUS til TCO er at bryde it-systemet ned i komponenter. Vi kan da finde ud af, hvor meget det i gennemsnit koster at køre en af ​​disse komponenter. Efter dette kunne vi derefter faktor i forskellige omkostninger afhængigt af, om IT-systemet er evolverbare eller åben etc. Hvis et system er allerede oppe at køre, den vigtigste faktor til at overveje, er udgifter til vedligeholdelse og måske omkostningerne til at nedlægge.

Et eksempel

Diagram for beregningseksempel

Komponenten under Organisation eller dens standard har disse egenskaber:

· FTE= 100 000 $ / år

· Support Indsats= 0.01 FTE + 0,001 FTE / år = 1000 $ + 100 $ / år

· Vedligeholdelsesomkostninger= 100 $ - 10 $ / år

· Kapitalomkostninger= 2000 $

· Installer Indsats= 2 FTE / dage = 0,01 årsværk / år = 1.000 $

Komponenten under Organisationen har disse egenskaber:

· Installer Horizon= -2 År (dvs. Systemet blev installeret 2 år før nu)

· Levetid= 3 år

Hvornår Installer Horizon + Levetid <= 0 Der er ikke mere vedligeholdelsesomkostninger.

Beregninger

Beregningerne er som følger:

Note

TC = omkostningerne pr. SE = Support Indsats. MC = vedligeholdelsesomkostningerne.

· Indledende omkostninger = kapitalomkostninger + Installer Indsats= 2000 + 1000 = 3000 $

· Ved t = -2 (under 1. år), TC = Initial omkostninger + SE + MC= 3000 + 1000 + 100 = 4100 $

· Ved t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1190 $

· Ved t = 0, TC = (1000 + 200) + (100 - 20) = 1280 $

· Ved t = 1 (sidste år), TC = (1000 + 300) + (100 - 30) = 1370 $

Graf for beregningseksempel

TCO er summen af ​​alle nuværende og fremtidige omkostninger, indtil systemet er blevet afmonteret.

· Ved t = -2 (under 1. år), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Ved t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Ved t = 0, TCO = 1280 + 1370 = 2650 $

· Ved t = 1 (sidste år), TCO = 1370 $

Vigtige omkostningsfaktorer

De vigtigste omkostningsfaktorer, der skal overvejes ved beregning af TCO af et aktiv i ABACUS er:

· Hardware Erhvervelse- Indledende omkostninger af udstyret (kapitalomkostningerne).

· Software Acquisition- Indledende udgifter til licensen til softwaren (kapitalomkostninger).

· Installation- Omkostninger i forbindelse med den første opsætning.

· Uddannelse- Omkostninger i forbindelse med ekstern leverandør uddannelse efter første opsætning.

· Støtte- Omkostninger i forbindelse med intern støtte.

· Opretholdelse- Omkostninger til at erstatte eller opgradere sælgers vedligeholdelseskontrakter, forsyninger og disaster recovery omkostninger.

· Infrastruktur- Omkostninger i forbindelse med støtte aktivet.

ABACUS Eksempel repræsentation Key omkostningsfaktorer

Kørsel af Cost simulator

For at simulere din arkitektur i form af omkostninger

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Vælge Analyse| Koste.

3. Vælg Arkitektur (r)du ønsker at inkludere i evalueringen.

Note

Som standard vil ABACUS automatisk vælge arkitekturen (er), for hvilke en re-simulering er nødvendig på grund af et underliggende ejendom eller strukturelle ændringer.Denne fremhævning er vist i Rød på den Simulation værktøjslinje .

4. Vælg Valutafra pull down.

5. Flyt År til at beregneskyderen til det antal år, der kræves.

Note

Som standard, hvis Years at beregne er mere end 1 år de omkostninger, automatisk vil blive beregnet for hvert enkelt år (og en samling af ejendomme tilføjet / opdateret) og derefter en kumulativ værdi for hele antal år også beregnet. Hvis kun den samlede værdi er påkrævet, fjerne markeringen i Beregn Per-År Omkostningerindstilling som beskrevet nedenfor for at spare på antallet af ejendomme i projektet.

6. Vælg, om at forlade Beregn Per-År Omkostningerkontrolleret eller fjerne markeringen af ​​det.

7. Klik Næste.

8. Eventuelt vælge Tilslutningerdu ønsker at tilskrive omkostningerne sammen som en del af evalueringen.

Note

Ved hjælp af en Omkostninger | Attributionejendom på tilslutninger omkostninger måske tilskrives fra komponenten fastgjort til vasken ende af forbindelsen til komponenten knyttet til kilden ende(dvs. Omkostninger | Attribution = "Sink at Source"), eller fra komponenten er fastgjort til kilde ende af forbindelsen til komponenten er fastgjort til håndvask ende(dvs. Omkostninger | Attribution = "Source til Sink"). Derudover ABACUS vil automatisk vælge de forbindelser med en Adfærd | Forholdet = "processer" eller "støtter"og retningen af ​​tildeling vil være "Sink man kilde '. Endvidere er omkostningerne fordeles ifølge ethvert Adfærd | % Eller Omkostninger | % Ejendomme på tilslutningerne, eller alternativt, hvor der er flere forbindelser fra en vask til mange kildereller kilde til mange drænIfølge et hvilket som Adfærd | Processing ejendomme på kilden komponentereller synke komponenter henholdsvis.

9. Klik Slutteog du vil få en Advarseldialogen.

10. Eventuelt udforske advarslerne ved at klikke Detaljer >>.

11. Klik Blive ved.

Note

På dette tidspunkt vil ABACUS udføre en aktivitetsbaseret omkostningsberegning evaluering af arkitekturen (r), og efter kort tid (med fremskridt barer for feedback) en beregning komplet dialogboks vises.

12. Klik Okayat anerkende evalueringen.

Tip

For kurser og yderligere hjælp på Cost Simulering henvises til Skønnede udvikling Fællesskab .

Komponent og / eller tilslutning Egenskaber

Nedenstående tabel viser den komponent og / eller tilslutning egenskaber der kræves for at vurdere omkostningerne.Disse egenskaber vil blive vist i vinduet med en ejendom input rækken vælger ikon Properties ( [image] ) Med værktøjstip "Cost Input". En ændring til nogen af ​​disse "input" egenskaber og forskellige strukturelle ændringer til arkivet vil resultere i Cost simulator kræver en re-simulation som angivet i Rød på den Simulation værktøjslinje .

Type

Navn

Standard værdi

Enhed

Datatype

Nødvendig

Beskrivelse

Koste

Installer Horizon

0

år

Heltal

Rigtigt

Angiver, når komponenten eller tilslutning har været eller vil blive installeret.

· En værdi på 0 (standard) viser, at komponenten eller tilslutning bliver installeret i indeværende år.

· En værdi under 0 angiver, at komponenten eller tilslutning er blevet installeret i fortiden.

· En værdi større end 0 indikerer, at komponenten eller tilslutning vil blive installeret i fremtiden.

Koste

Levetid

0

år

Heltal

Rigtigt

Angiver længden af ​​tid, hvori komponenten eller tilslutning vil forblive i drift, hvorefter den vil blive afmonteret.

Koste

FTE

100.000,00

$ / år

Decimal

falsk

De årlige omkostninger for hver fuldtidsansat.

Hvis denne egenskab ikke findes i komponentenselv eller i tilfælde af forbindelser komponenten er fastgjort til vasken ende af forbindelsen, Vil det blive søgt efter andre komponenter.

For det første, enhver 'vask' komponents ved udgangen af a forbindelse med en "støtter" forhold til komponenten bliver søgt, efterfulgt af at "synke" komponent forælders.

Hvis FTE ejendommen ikke bliver fundet, komponentens forælder-components vil derefter blive søgt. Hvis FTE stadig ikke fundet, er standardværdien anvendes.

Bemærk venligst: FTE er kun et gyldigt input ejendom på komponenter.

Koste

Vedligeholdelsesomkostninger (fast)

0.00

$ / år

Decimal

falsk

Den faste årlige udgifter til vedligeholdelse af komponenteneller tilslutning.

Koste

Vedligeholdelsesomkostninger (variabel)

0.00

$ / år

Decimal

falsk

Det beløb, hvormed de samlede udgifter til vedligeholdelse af komponenten eller tilslutning vil ændre hvert år.

For eksempel, er en værdi på $ -500 indikerer, at samlede vedligeholdelsesomkostninger reduceres med $ 500 hvert år, mens en værdi på $ 500 viser, at de samlede vedligeholdelsesomkostninger stiger med $ 500 hvert år.

Koste

Support Indsats (fast)

0.00

FTE / år

Decimal

falsk

Den årlige faste indsats for at støtte den komponenteller tilslutning, Der er angivet i form af personår.

Koste

Support Indsats (variabel)

0.00

FTE / år

Decimal

falsk

Det beløb, hvormed den samlede indsats for at støtte den komponent eller tilslutning vil ændre hvert år.

For eksempel en værdi på -0,01 viser, at den samlede støtte indsatsen falder med 0,01 årsværk hvert år, mens en værdi på 0,01 betyder, at den samlede støtte bestræbelserne stiger med 0,01 hvert år.

Koste

Kapitalomkostninger

0.00

$

Decimal

falsk

Den oprindelige udgifter til indkøb af komponenteneller tilslutning.

Koste

Installer Indsats

0.00

FTE

Decimal

falsk

Den indsats, der kræves, i personår, for at installere komponenteneller tilslutning.

Nedenstående tabel viser den komponent og / eller tilslutning egenskaber, der er output fra TCO evaluator. Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Cost Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Cost simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Note

Hvor output egenskaber fra TCO evaluator skal være "afrundes" den "Runde halvdel til endnu" tilgang (også benævnt »bankfolk" afrunding) anvendes.Denne teknik bruges til mere jævnt løse eventuelle 0,5 'tie-pauser' med det resultat, der rundes op eller ned til nærmeste endog Resultatet er, i stedet for altid afrunding og skævheder resultatet. Dvs. 2.5 rundes ned til 2, mens 3,5 rundes op til 4, i stedet for dem begge at blive enten rundet ned til 2 og 3 eller rundes op til 3 og 4.

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Koste | Total Cost til egen - næste x år. | $ | Heltal | falsk | De samlede omkostninger ved ejerskab over de næste xår, hvor x er længden af ​​tid, er angivet, når du kører evaluator. Dette omfatter udgifter til komponentens eller forbindelsen er standarder, delkomponentereller sub-tilslutninger(dvs. børn) og eventuelle tilskrives omkostninger.
Koste | Total Cost til egen (lokal) - næste x år. | $ | Heltal | falsk | Den "lokale" ejeromkostninger løbet af de næste xår, hvor xer længden af ​​tid, er angivet, når du kører evaluator. Det gør ikkeomfatter udgifter til komponentens delkomponenter eller tilslutning er sub-tilslutninger (dvs.børn) eller eventuelle tilskrives omkostninger.
Koste | Total Cost til egen (børn) - næste x år. | $ | Heltal | falsk | Den "børn" ejeromkostninger løbet af de næste xår, hvor x er længden af ​​tid, er angivet, når du kører evaluator. Denne kun omfatter udgifter til komponentens delkomponenter eller tilslutning er sub-tilslutninger (dvs. børn).
Koste | Total Cost til egen (tilskrevet) - næste x år. | $ | Heltal | falsk | Den "tilskrives" ejeromkostninger løbet af de næste xår, hvor x er længden af ​​tid, er angivet, når du kører evaluator. Denne kun omfatter enhver tilskrives omkostninger fra de vedlagte komponenter(som kan selvfølgelig omfatter henføres omkostninger fra eventuelle tilsluttede forbindelser).

Nedenstående tabel viser den komponent og / eller tilslutning egenskaber, der er output af TCO evaluatorhvis Beregn Per-År Omkostninger er valgt. Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Cost Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Cost simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Note

Se noten ovenfor om den mulige afrunding af output-egenskaber.

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Koste | Total Cost til egen - årx. | $ | Heltal | falsk | De samlede omkostninger ved ejerskab for år x, Hvor x er for hvert år specificeret, når du kører evaluator. Dette omfatter udgifter til komponentenseller forbindelsen er standarder, delkomponenter eller sub-tilslutninger (dvs. børn) og eventuelle tilskrives omkostninger.
Koste | Total Cost til egen (lokal) - årx. | $ | Heltal | falsk | Den "lokale" ejeromkostninger for år x, hvor x er for hvert år specificeret, når du kører evaluator. Det gør ikkeomfatter udgifter til komponentens delkomponenter eller tilslutning er sub-tilslutninger (dvs. børn) eller eventuelle tilskrives omkostninger.
Koste | Total Cost til egen (børn) - årx. | $ | Heltal | falsk | De "børn" ejeromkostninger for år x, Hvor x er for hvert år specificeret, når du kører evaluator. Denne kun omfatter udgifter til komponentens delkomponenter eller forbindelsen er sub-tilslutning (dvs. børn).
Koste | Total Cost til egen (tilskrevet) - årx. | $ | Heltal | falsk | Den "tilskrives" ejeromkostninger for år x, Hvor x er for hvert år specificeret, når du kører evaluator. Denne kun omfatter enhver tilskrives omkostninger fra de vedlagte komponenter(som kan selvfølgelig omfatter henføres omkostninger fra eventuelle tilsluttede forbindelser).

Ekstra Egenskaber Connection

Nedenstående tabel viser ekstra tilslutning egenskaber, der kræves af TCO evaluator. Disse egenskaber vil blive vist i vinduet med en ejendom input rækken vælger ikon Properties ( [image] ) Med værktøjstip "Cost / Ydeevne Input" eller bare "Cost Input". En ændring til nogen af ​​disse "input" egenskaber og forskellige strukturelle ændringer til arkivet vil resultere i omkostninger og / eller Ydeevne simulator kræver en re-simulation som angivet i Rød på den Simulation værktøjslinje .

Type | Navn | Standard værdi | Enhed | Datatype | Nødvendig | Beskrivelse
Koste | Attribution | Synke til Source | [Kilde for at Sink | Synke til Source] | Opslag / liste | Rigtigt | Hvis "Kilde til Sink", Denne forbindelse vilje have have kostestilskrives 'sammen' det fra kildekomponent til håndvask komponent. Alternativt, hvis "Synke til Source", Denne forbindelse vilje har omkostninger tilskrives 'sammen' det fra vasken komponent til kildeenheden.
Opførsel | Forholdet | understøtninger | [processer | understøtter] | Opslag / liste | falsk | Hvis "støtter", denne forbindelse angiver, at "kilde" komponent er støttet af "synke" komponent. Derudover deres omkostninger, hvis enten "støtter" eller "processer" så forbindelsen vil automatisk blive valgt i tilslutningerne til at have tilskrevet "langs" fra vasken komponent til kilden komponent.
Koste | % | 100,0 | % | Decimal | falsk | Angiver andelen af ​​vasken komponenter omkostninger, der vil blive tilskrives kilden komponent. De% værdier behøver ikke at tilføje op til 100%, og det er simpelthen bruges til at skalere "Total Cost at eje -. Næste x år" ejendom (se ovenfor) fra vasken, da det på tilskrives kildeenheden.

Arkitektur Egenskaber

Lister Nedenstående tabel arkitektur egenskaber, der er output fra TCO evaluator. Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Cost Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Cost simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Note

Se noten ovenfor om den mulige afrunding af output-egenskaber.

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Koste | Total Cost til egen - næste x år. | $ | Heltal | falsk | De samlede omkostninger ved ejerskab af hele arkitekturen i de næste x år.

Lister Nedenstående tabel arkitektur egenskaber, der er output fra TCO evaluatorhvis Beregn Per-År Omkostninger er valgt. Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Cost Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Cost simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Note

Se noten ovenfor om den mulige afrunding af output-egenskaber.

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Koste | Total Cost til egen - årx. | $ | Heltal | falsk | De samlede omkostninger ved ejerskab for hele arkitektur for år xi fremtiden.


Simulering Pålidelighed og tilgængelighed

Navigation: Simulering din arkitektur> Simulatorer>

Simulering Pålidelighed og tilgængelighed

Send kommentarer om dette emne.

Baggrund

Pålideligheden Evaluator beregner pålideligheden af ​​arkitekturen ved hjælp af input komponenter og forbindelser.

For komponenter og direkte forbindelser, er pålideligheden baseret på Mean Time Between Failure (MTBF). De eneste variable er nødvendige for at beregne pålideligheden af ​​arkitektoniske elementer er:

· De MTBFværdi (i år);

· De Mean tid til at reparere (MTTR)en fiasko (i år); og

· Den definerede periode af tid til at teste pålidelighed over.

Den formel, der anvendes i beregningen af ​​Pålideligheden er givet som:

Pålidelighed = -E (-y × alder)
Hvor y = 1 ÷ MTBF

Tilgængeligheden af ​​komponenter og forbindelser er baseret på MTBF og MTTR. Bemærk, at tilgængeligheden i modsætning til pålidelighed, er upåvirket af det tidsrum, som den bliver testet.

Tilgængelighed = MTBF / (MTBF + MTTR)

Mens metoder, der omdanner Reliability blokdiagrammer(ved hjælp af simple serie og parallelle konstruktioner) giver de mest nøjagtige resultater, disse metoder blive meget impraktisk, når vi forsøger at beregne pålideligheden for tjenesterejser inden enorme net af tusinder af elementer. Desuden er disse transformerende tilgange nedbryde for mange fælles strukturer, såsom netværk "masker".

De Monte Carlometode giver pålideligheden og tilgængeligheden af ​​et system til vilkårlig størrelse og kompleksitet, der skal beregnes. Monte Carlo-metoden simulerer mange scenarier og feller hvert scenarie en tilfældig tilstand, tilgængelig eller ikke tilgængelig, Der er tildelt hver fysiske element. Sandsynligheden for en given element er i en tilgængelig tilstand er baseret på pålideligheden / tilgængelighed af komponenten.

For eksempel kan en komponent med 90% tilgængelighed forventes at foreligge i ca. 90% af scenarierne. Den indirekte forbindelse pålidelighed og tilgængelighed kan derfor anslås som andelen af ​​tilfældige scenarios- for hvilken der findes en sti af elementerne i en tilgængelig opgørelse fra kilde til destination.

Note

Da beregningen af ​​lokale pålidelighed og tilgængelighed er baseret på forskellige parametre og forskellige formler (og dermed resulterer i forskellige værdier), er det nødvendigt at tildele hvert element tostater, en for tilgængelighed, og én for pålidelighed. Beregningen af ​​tilgængelighed bruger tilgængeligheden stat i hvert scenario, mens beregningen af ​​pålidelighed bruger pålideligheden stat i hvert scenario.

Pålideligheden evaluator anvender Monte Carlo simulation teknik til at arbejde ud pålideligheden af ​​en bestemt arkitektur. Arkitekturen er sat gennem tusinder af individuelle simuleringer, og resultaterne tabuleret at udlede en pålidelighed foranstaltning. Som nævnt ovenfor, Monte Carlo er den hurtigste metode til simulering større netværk og vil arbejde med en kompliceret (dvs. masket) struktur.

Evaluator udgange fire værdier:

1. Mission Pålidelighedover en årrække;

2. Tilgængelighed af arkitektur;

3. Pålidelighed af lokal komponentover en årrække; og

4. Tilgængelighed af lokal komponent.

Evaluator værker ud sandsynligheden for de komponent eller tilslutning arbejdsmiljø (dvs. ikke undlade), og den tid, det tager at reparere.

Hvordan standarder med MTBFs og / eller MTTRs behandles

Hvis et element (komponent eller forbindelse) har standarder med tildelte MTBF og / eller MTTR værdier, er disse værdier også anvendes til beregning af den lokale pålidelighed og tilgængelighed af et element som en serieforbindelse.

For eksempel, hvis en komponent A, Med tildelte standarder B, C, og Dhver har en MTBF og en MTTR værdi, Lokalt Pålidelighed = R(A)× R(B) × R(C) × R(D), hvor R = Beregnet pålidelighed (ved hjælp af formlen) af dets / standarder og Lokal Benytteevne = EN(A)× EN(B) × EN(C) × EN(D), hvor A = Beregnet nytteevne (ved hjælp af formlen) af dets / standarder. Det vil sige, hvis et element har tre standarder hver med MTBF og MTTR værdisOg også MTBF og MTTR værdisfor element egenskaber, den lokale pålidelighed og avilability gives som en række for hver af standarderne, og selve elementet.

Som et andet eksempel, hvis en komponent Ahar tildelt standarder B, C, og Dmen kun standard Bhar både en MTBF og en MTTR værdi, mens standard Char kun en MTBF værdi og standard Dkun har en MTTR værdi, Lokalt Pålidelighed = R (A)× R (B)× R (C), hvor R= Beregnet pålidelighed (ved hjælp af formlen) i komponent / standarder og lokale Tilgængelighed = A (A)× A (B)× A (C), hvor A= Beregnet tilgængelighed (ved hjælp af formlen) i komponent / standarder, men i beregningen af ​​A (C), fordi standarden kun har en MTBF værdi det 'søgninger'for den matchende MTTR værdi (er) og vil tilføje alle MTTR værdier den konstaterer, at don't selv har en matchende MTBF værdi, så i dette tilfælde ville bruge MTTR værdien af ​​standard D. Hvis der var en anden standard, siger E, Med blot en MTTR værdi samt derefter A (C)ville bruge MTBF af Cmed MTTR af D og Elægges sammen. Hvis en anden standard, siger FHavde bare en MTBF værdi, så A (F)ville også bruge MTTR af D og Elægges sammen.

Beregning Mission Pålidelighed

Mens beregning lokal pålidelighed er et spørgsmål om at bruge en simpel formel, beregning af indirekte forbindelser (mission) er ikke så let, især når vi har komplekse og store netværk af sammenflettede veje (forbindelser) og komponenter.

Tager hele netværket i betragtning

Da de indirekte forbindelser ikke repræsenterer en fysisk forbindelse, må vi finde ud af, hvordan kilden komponent kan komme til sit bestemmelsessted komponent. Og dette indebærer at se på hele netværket og alle de forskellige måder (og stier) vores kilde komponent kan tage for at nå destinationen komponent (vask).

Note

Så længe der er i det mindste en kompletvej fra kilde til destination, vil missionen lykkesog indirekte tilslutning omtales som en lukket forbindelse.

Forståelse Link Matrix

At vide, hvilke komponenter / direkte forbindelser er tilsluttet, hvad, vi har brug for en artefakt hurtigt tjekke, om to blokke er forbundet i en bestemt retning. Dette er funktionen af ​​forbindelsen matrix. Kort fortalt linket matrix er et todimensionalt array af booleske variabler, der angiver, om en bestemt komponent kan nå en anden komponent direkte. Dens størrelse er lig med kvadratet af det samlede antal komponenter i netværket.

A Simple Pålidelighed Block Diagram (RBD)

Relaterede Link Matrix for Pålidelighed Block Diagram (RBD)

Da ikke alle tilslutninger er tovejs (går begge veje), er det vigtigt, hvordan man kan læse på linket matrix korrekt. I pålideligheden evaluator, det første argument er kilden og det andet argument er den destination (sink).

Derfor, hvis link matrix (A, B) = True så betyder det, at A kan få til B direkte (envejs). B kan komme til A, hvis kun, hvis link matrix (B, A) = true. Hvis dette er sandt, medfører dette et tovejs forbindelse.

I det givne eksempel over:

· Kilde 1 kan nå destinationen 0 (Kilde 1 og Destination 0 giver et resultat af True); og

· Kilde 0 kan nå destinationen 1 (Kilde 0 og Destination 1 giver et resultat af True), da forbindelsen mellem 0 og 1 er tovejs.

· Kilde 2 kan ikke nå destinationen 1 (Kilde 2 og Destination 1 giver et resultat af Falsk), selv når kilden 1 kan nå destinationen 2 (Kilde 1 og Destination 2 giver et resultat af True). Det er betyder, at forbindelsen mellem 1 og 2 er ensrettet.

Forstå Pålidelighed Block Diagram

Pålideligheden blokdiagram (RBD) indkapsler strukturen af ​​hele objektet model i form af blokke og links. Hver blok repræsenterer et element, der har en mulighed for succes eller en fiasko i henhold til de links / stier, der forbinder dem. Begge komponenter og forbindelser kan blive en "blok" i RBD.

Eksempel RBD Blokke og links

Tallet ovenfor repræsenterer et RBD f.eks. Den stiplede røde linie repræsenterer en enkelt mission 4 til 1. Bemærk, hvordan der kun er to mulige veje for missionen 4 til 1.

Overvej ruten 4 til 3 til 0 til 1, og ruten 4 til 7 til 1. De stiplede blokke 2, 5og 6 repræsenterer blokke, som ikke påvirker den manglende / ikke-svigt af mission 4 til 1. De er ikke behandlet og ignoreres. Dette er vigtigt, da de fleste missioner vil der være et stort antal redundante blokke, der ikke vil påvirke en særlig opgave succes. Dette er mere tydeligt i større netværk, hvorved antallet af redundante blokke vil gøre simulation resultater unøjagtige.

For at fremskynde simulering tid, og sikre en mere præcise resultater, er det nødvendigt at abstrahere fra hele RBD og brug kun de elementer, der påvirker en mission succes.

Note

En enkelt rute / sti kan ikke gå gennem nogen komponent gange.

På dette stadium kan vi skabe et link matrix og udføre en Monte Carlo simulering.

Beregning Arkitektur Tilgængelighed

Arkitekturen tilgængelighed er sandsynligheden for, at alle de indirekte forbindelser vil være tilgængelig på ethvert tidspunkt. Tilgængeligheden af ​​en indirekte forbindelse bestemmes under hver iteration af Monte Carlo simulation, men disse indirekte forbindelser (typisk) påberåbe sig det samme sæt af fysiske elementer. Derfor simpelthen aggregere disse individuelle disponible ville "dobbelt-count" disse un-disponible, hvilket giver en pessimistisk overordnede arkitektur tilgængelighed. Alternativt er den overordnede arkitektur tilgængelighed beregnet ved at se på hver iteration og se, om de elementer, der indgår i de indirekte forbindelser af interesse er til rådighed. Og derefter at lægge disse resultater ved udgangen af ​​simuleringen.

Kørsel af Pålidelighed simulator

For at simulere din arkitektur med hensyn til pålidelighed

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Vælge Analyse| Pålidelighed.

3. Vælg Arkitekturdu ønsker at evaluere fra pull-down menuen.

Note

Som standard vil ABACUS automatisk vælge den første arkitektur for hvilke en re-simulering er nødvendig på grund af et underliggende ejendom eller strukturelle ændringer.Denne fremhævning er vist i Rød på den Simulation værktøjslinje .

4. Vælg Komponenter og Tilslutningerdu ønsker at evaluere fra Vinduet til valg standard element ved hjælp af 'Vis direkte forbindelser «og» Vis Processer Connections' radio-knap filtre i nederst til venstre i dialogboksen for at hjælpe med dig valg.

Ekstra Afkrydsningsfelt til Vinduet til valg standard element

· Save Transformeret Model vilje gemme en kopi af RBD forvandlet version af projektet i den samme mappe som det aktuelle projekt og tilføje "_transformed" til navnet projektet.Denne transformerede projekt kan anvendes til at diagnosticere detaljeret pålideligheden simulation foretaget af ABACUS.

Yderligere Radio-Knapper til Vinduet til valg standard element

· Vis direkte forbindelser indstiller automatisk en forbindelse er Ejendom filter til ejendom Type = Adfærd, Name = Abstraktion og værdi = direkte.Denne indstilling er valgt som standard, og hjælper udvælgelsen af ​​de 'direkte' forbindelser som beskrevet ovenfor og nedenfor.

· Vis Processer Tilslutninger vil automatisk sætte en forbindelse er Ejendom filter til ejendom Type = Adfærd, Name = Forholdet og værdi = processer.Denne indstilling hjælper udvælgelsen af ​​de 'direkte' forbindelser som beskrevet ovenfor og nedenfor.

5. Klik Næste.

6. Vælg Missionerdvs Connections du ønsker at inkludere i simuleringen.

7. Indstil Run Time Scale Factorskyderen.

Note

Højere værdier vil give mere statistisk konsistente resultater, men tager længere tid at beregne.

Afkrydsningsfelter

· At vise Lukkede Connections vilje automatisk filtrere tilgængelige forbindelser kun omfatter dem, der har mindst en fuldstændig fysisk vej fra kilden komponent til målbestanddelen som pr RBD valg beskrevet ovenfor.

· Vis Indirekte Connections indstiller automatisk en forbindelse er Ejendom filter til ejendom Type = Adfærd, Name = Abstraktion og værdi = indirekte.Denne indstilling er valgt som standard, og hjælper udvælgelsen af ​​de »indirekte« eller Mission-forbindelser som beskrevet ovenfor og nedenfor.

Knapper

· Allevælger alle de tilslutninger.

· InverterFravælger alle de aktuelt valgte tilslutninger og vælger alle dem, der ikke blev valgt.

· Ingenfravælger alle de tilslutninger.

Andre muligheder

· Run Time Scale Factor styrer simulation tid og nøjagtighed med højere værdier udbytteINGmere statistisk konsistente resultater, men tager længere tid til løbe.

Note

Når ABACUS beregner antallet af iterationer at simulere det vil bestemme den mest pålidelige element, der ikke er helt pålidelige og derefter simulere for Run Time Scale Factor gange 1 over Indisponible dette element plus 1 iteration. Eller (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Dette er at sikre, at dette element stadig ikke mindst én gang i simuleringen. F.eks. Hvis den mest pålidelige element, der ikke er helt pålidelig har en MTBF på 10.000 timer, og en MTTR på 8 timer derefter simuleringen vil tage (10.000 + 8) / 8 = 1.251 gange Kør tidsskala Factor + 1 iterationer.

· År at simulere Ahead bestemmer antallet af år for Mission Pålidelighed skal beregnes for.

· Nsortjord af Trådedetermines antallet af behandlinger tråde skal bruges til Monte Carlo simulation.Denne mulighed vil som standard til at matche antallet af tilgængelige CPU'er / kerner (herunder hyper-threading kerner) for at minimere den samlede simulering tid.

8. Klik Slutteog du vil få en Advarseldialogen.

9. Eventuelt udforske advarslerne ved at klikke Detaljer >>.

10. Klik Blive ved.

Note

På dette tidspunkt vil ABACUS udføre en Monte Carlosimulering af arkitektur og efter kort tid (med fremskridt barer for feedback) en beregning komplet dialogboks vises.

11. Klik Okayat anerkende simuleringen.

Tip

For kurser og yderligere hjælp på pålidelighed Simulation henvises til Skønnede udvikling Fællesskab .

Komponent og Connection Properties

Nedenstående tabel viser komponenten og 'direkte'forbindelsesegenskaber kræves for at evaluere pålidelighed. Disse egenskaber vil blive vist i vinduet med en ejendom input rækken vælger ikon Properties ( [image] ) Med værktøjstip "Pålidelighed Input". En ændring til nogen af ​​disse "input" egenskaber og forskellige strukturelle ændringer til arkivet vil resultere i Pålidelighed simulator kræver en re-simulation som angivet i Rød på den Simulation værktøjslinje .

Type | Navn | Standard værdi | Enhed | Datatype | Nødvendig | Beskrivelse
Pålidelighed | MTBF | ∞ | år, uger, dage eller timer | Decimal | Rigtigt | The Mean Tid før Svigt af elementet. Bemærk: Værdier kan udtrykkes i enheder af år, uger, dage eller timer, og konverteres efter en '24 / 7 'tilgængelighed koncept som følger; - 1 år = 52 uger eller 365 dage eller 8.760 timer - 1 uge = 7 dage eller 168 timer - 1 dag = 24 timer
Pålidelighed | MTTR | 0 | år, uger, dage eller timer | Decimal | Rigtigt | Den gennemsnitlige tid til Reparation af elementet. Bemærk: Værdier kan udtrykkes i enheder af år, uger, dage eller timer, og konverteres efter en '24 / 7 'tilgængelighed koncept som følger; - 1 år = 52 uger eller 365 dage eller 8.760 timer - 1 uge = 7 dage eller 168 timer - 1 dag = 24 timer

Nedenstående tabel viser komponenten og 'direkte' forbindelsesegenskaber output ved pålideligheden evaluator. Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Pålidelighed Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Pålidelighed simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Pålidelighed | Pålidelighed - x år |  | Decimal | falsk | Sandsynligheden for, at elementet ikke vil svigte inden for de næste x år. Dette er en værdi mellem 0 og 1.
Pålidelighed | Upålidelighed - x år |  | Decimal | falsk | Sandsynligheden for, at det element vil mislykkes inden for de næste x år. Dette er en værdi mellem 0 og 1.
Pålidelighed | Tilgængelighed | % | Decimal | falsk | Den beregnede tilgængelighed af komponenten eller forbindelsen. Dette er en værdi mellem 0% og 100%.
Pålidelighed | Indisponible | % | Decimal | falsk | Den beregnede utilgængelighed af komponenten eller forbindelsen. Dette er en værdi mellem 0% og 100%.

Nedenstående tabel viser den 'indirekte'forbindelsesegenskaber output ved pålideligheden evaluator. Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Pålidelighed Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Pålidelighed simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Pålidelighed | Mission Pålidelighed - x år |  | Decimal | falsk | Sandsynligheden for, at den indirekte forbindelse ikke vil svigte inden for de næste x år. Dette er en værdi mellem 0 og 1.
Pålidelighed | Mission Upålidelighed - x år |  | Decimal | falsk | Sandsynligheden for, at den indirekte forbindelse vil mislykkes inden for de næste x år. Dette er en værdi mellem 0 og 1.
Pålidelighed | Tilgængelighed | % | Decimal | falsk | Den beregnede tilgængeligheden af ​​indirekte tilslutning. Dette er en værdi mellem 0% og 100%.
Pålidelighed | Indisponible | % | Decimal | falsk | Den beregnede utilgængelighed af den indirekte forbindelse. Dette er en værdi mellem 0% og 100%.

Arkitektur Egenskaber

Nedenstående tabel viser den arkitektur egenskaber output ved pålideligheden evaluator. Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Pålidelighed Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom eller strukturel ændring af arkivet og Pålidelighed simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Enhed | Datatype | Nødvendig | Beskrivelse
Pålidelighed | Tilgængelighed | % | Decimal | falsk | Tilgængeligheden af ​​alle indirekte forbindelser, der er medtaget i evalueringen. Det vil sige, sandsynligheden for, at alleindirekte forbindelser vil være tilgængelige på et givet tidspunkt. Dette er en værdi mellem 0% og 100%. Bemærk: Dette er ikke en mangedobling af de individuelle tilslutning disponible da dette ville være "dobbelttælling" un-tilgængeligheden af ​​relevante komponenter.
Pålidelighed | Indisponible | % | Decimal | falsk | Den manglende adgang til de indirekte forbindelser, der er medtaget i evalueringen. Det vil sige, sandsynligheden for, at Idet mindste enindirekte forbindelsen vil være utilgængelige på et givet tidspunkt. Dette er en værdi mellem 0% og 100%. Bemærk: Dette er ikke en mangedobling af de individuelle tilslutning unavailabilities da dette ville være "dobbelttælling" un-tilgængeligheden af ​​relevante komponenter.
Pålidelighed | Mission Pålidelighed - x år |  | Decimal | falsk | Sandsynligheden for, at alle de indirekte forbindelser, der er medtaget i evalueringen vil blive ikke undlade inden for det næste xår. Dette er en værdi mellem 0 og 1. Bemærk: Dette er IKKE en mangedobling af de individuelle tilslutning pålidelighedsniveauerne da dette ville være "dobbelttælling" un-tilgængeligheden af ​​relevante komponenter.
Pålidelighed | Mission Upålidelighed - x år |  | Decimal | falsk | Sandsynligheden for, at mindst én af de indirekte forbindelser, der er blevet medtaget i evalueringen vil mislykkes inden for de næste xår. Dette er en værdi mellem 0 og 1. Bemærk: Dette er IKKE en mangedobling af de individuelle tilslutning unreliabilities da dette ville være "dobbelttælling" un-tilgængeligheden af ​​relevante komponenter.


Simulering Åbenhed

Navigation: Simulering din arkitektur> Simulatorer>

Simulering Åbenhed

Send kommentarer om dette emne.

Åbenheden simulator bestemmer i hvilken grad en arkitektur og dens elementer er "åbne", det vil sige, at systemet til at håndtere udskiftning af komponenter med minimal påvirkning.

For at simulere din arkitektur i form af åbenhed

1. Sikre, at du har den ABACUS filen, Indeholder dit befolkede arkitektur, åben.

2. Vælg Analyse | Åbenhed.

3. Vælg Arkitektur (r)du ønsker at inkludere i evalueringen.

Note

Som standard vil ABACUS automatisk vælge den første arkitektur for hvilke en re-simulering er nødvendig på grund af et underliggende ejendom eller strukturelle ændringer.Denne fremhævning er vist i Rød på den Simulation værktøjslinje .

4. Klik Slutteog du vil få en Advarseldialogen.

5. Eventuelt udforske advarslerne ved at klikke Detaljer >>.

6. Klik Blive ved.

Note

På dette tidspunkt vil ABACUS udføre en strukturel evaluering af arkitekturen (r), og efter kort tid (med fremskridt barer for feedback) en beregning komplet dialogboks vises.

7. Klik Okayat anerkende simuleringen.

Tip

For kurser og yderligere hjælp på Åbenhed Evaluering henvises til Skønnede udvikling Fællesskab .

Komponent og Connection Standard Egenskaber

Lister Nedenstående tabel standard egenskaber komponent og tilslutning kræves for at evaluere åbenhed.Disse egenskaber vil blive vist i vinduet med en ejendom input rækken vælger ikon Properties ( [image] ) Med værktøjstip "Åbenhed Input". En ændring til nogen af ​​disse "input" egenskaber i lageret vil resultere i åbenheden simulator kræver en re-simulation som angivet i Rød på den Simulation værktøjslinje .

Type | Navn | Standard værdi | Enhed | Datatype | Nødvendig | Beskrivelse
Åbenhed | Standarder-Standard Løbetid-Organisation Level |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Niveau af ansvarlige standarder Krop 0:Organisatorisk / Proprietary 1:Konsortium / defacto 2:National / Militær 3: International
Åbenhed | Standarder-Standard Løbetid-status |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Godkendelse niveau opnås med standardiseringsorgan 0:Working / Udvalg Udkast 1:Offentlig Udkast / balloted 2:Interim Udkast 3: Godkendt
Åbenhed | Standarder-Standard Løbetid-Stabilitet |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Vil sandsynligvis ændre standarden? 0:Standard forældede 1:Meget kan ændres i næste 1 til 2 år 2:Kendte ændring / opdateringer til eksisterende funktioner 3:Meget stabil (ingen ændring inden for 2 år)
Åbenhed | Standarder-Standard Løbetid-Vendor Support |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Vendor Support 0:Ingen produkter eller leverandører understøtter standarden 1:En eller flere leverandører, der implementerer en del af standarden 2:Mere end en leverandør med produkter, der gennemfører alle dele af standarden 3:Mange flere end én leverandør med produkter, der gennemfører alle dele af standarden
Åbenhed | Standarder-Standard tydelighed-Dokumentation |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Kvaliteten af ​​standard dokumentation 0: Dårlig 1: Retfærdig 2: God 3:Fremragende
Åbenhed | Standarder-Standard tydelighed-Standard Bredde |  |  | Heltal | falsk | Række funktioner. En optælling af de laveste niveau standard funktioner - Sf
Åbenhed | Standarder-Standard tydelighed-Sm |  | % | Decimal | falsk | Procentdel af det samlede antal funktioner, der er obligatoriske
Åbenhed | Standarder-Standard tydelighed-So |  | % | Decimal | falsk | Procentdel af det samlede antal funktioner, der er valgfri
Åbenhed | Standarder-Standard tydelighed-Sc |  | % | Decimal | falsk | Procentdel af det samlede antal funktioner, der er betinget defineret
Åbenhed | Profiler-profil Dokumentation-Dokumentation |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Kvaliteten af ​​standard dokumentation 0: Ingen 1: Dårlig 2: Retfærdig 3:Fremragende
Åbenhed | Profiler-profil Dokumentation-Nøjagtighed |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Er dokumentation afspejler selve systemet design? Hvilket niveau af profil funktioner bruges i systemet? 0:Ingen funktioner 1:Nogle funktioner 2:De fleste funktioner 3:Alle funktioner
Åbenhed | Profiler-profil Dokumentation-Løbetid |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Er profilen modne og tilgængelig? 0:Ad hoc 1:Projekt baseret 2:Organisatorisk 3: Offentlig
Åbenhed | Profiler-profil tydelighed-Eksplicit Bredde |  |  | Heltal | falsk | Antal standard funktioner er angivet som krævet i profilen
Åbenhed | Profiler-profil tydelighed-Pm |  | % | Decimal | falsk | Procentdel af obligatoriske funktioner i profil
Åbenhed | Profiler-profil tydelighed-Po |  | % | Decimal | falsk | Procentdel af ekstra funktioner i profil
Åbenhed | Profiler-profil tydelighed-Pc |  | % | Decimal | falsk | Procent med betinget defineret funktioner i profil
Åbenhed | Profiler-profil tydelighed-Dækning |  | % | Decimal | falsk | Procentdel af standard funktioner specifikt i profilen
Åbenhed | Profiler-Profil Extensions-Extension Bredde |  |  | Heltal | falsk | Antallet af ikke-standard funktioner angivet af profilen
Åbenhed | Profiler-Profil Extensions-Dækning |  | % | Decimal | falsk | Procentdel af udvidelser beskrevet i profilen
Åbenhed | Produkter-produkt Tilgængelighed og Overensstemmelse-antal produkter |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Antal produkter, understøtter de obligatoriske elementer i standarden 0:Ingen produkter understøtter standarden 1:Et eller flere produkter gennemføre en del af standarden 2:Mere end ét produkt gennemfører alle dele af standarden 3:Mange mere end ét produkt gennemfører alle dele af standarden
Åbenhed | Produkter-produkt Tilgængelighed og Overensstemmelse-Application Overensstemmelse |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Hvilket niveau af overensstemmelse gøre produkter har til standarden? 0: Ingen 1:Hævdede 2:Demonstreret 3:Certificeret og demonstreret
Åbenhed | Produkter-produkt Tilgængelighed og Overensstemmelse-Overensstemmelse Kvalitet |  | [0 | 1 | 2 | 3] | Opslag / liste | falsk | Kvaliteten af ​​overensstemmelsesprøvning 0: Ingen 1:In-house test af produktudvikler 2:Uafhængige test (f.eks NIST) 3:Påvist i forbindelse med relevante produkt

Komponent, Tilslutning og Arkitektur Egenskaber

Nedenstående tabel viser den komponent, tilslutning og arkitektur egenskaber output ved den åbenhed evaluator. Alle de følgende egenskaber evalueres til mellem nul (0) og tre (3), nul (0) er den mindst ønskelige og tre (3) er den mest ønskelige.Disse egenskaber vil blive vist i vinduet med en ejendom output rækken vælger ikon Properties ( [image] ) Med værktøjstip "Åbenhed Output". Pilen på ikonet vil fremhæve Rød ( [image] ), Når disse egenskaber er forældet på grund af en underliggende ejendom ændring af arkivet og Åbenhed simulatoren kræver re-simulering i henhold til den Rød fremhæve på Simulation værktøjslinje .

Type | Navn | Datatype | Nødvendig | Beskrivelse
Åbenhed | Åbenhed | Decimal | falsk | Samlet vurdering af elementets åbenhed.
Åbenhed | Standarder-Standard Løbetid | Decimal | falsk | Den nuværende situation for standarden, hvilket afspejler, hvorvidt det er blevet godkendt, hvor længe den har været i brug, og hvor godt accepteret det er inden for fællesskab af udviklere.
Åbenhed | Standarder-Standard tydelighed | Decimal | falsk | Den tydelighed af standarderne, hvilket afspejler den potentielle tvetydighed i efterfølgende standarder
Åbenhed | Profiler-profil Dokumentation | Decimal | falsk | I hvilket omfang grænseflade profil dokumentation er udviklet og hvorvidt profilen dokumentationen afspejler den faktiske system design og / eller implementeret systemet
Åbenhed | Profiler-profil tydelighed | Decimal | falsk | Detaljeringsgraden leveres i en profil / profil specifikation
Åbenhed | Profiler-Profil Extensions | Decimal | falsk | I hvor høj grad profilen i overensstemmelse med den standard, som den er baseret
Åbenhed | Produkter-produkt Tilgængelighed og Overensstemmelse | Decimal | falsk | Hvorvidt der er åbne standard kompatible produkter til rådighed til anvendelse i projektet


Standardrapporter

Navigation: Rapportering om din arkitektur>

Standardrapporter

Send kommentarer om dette emne.

ABACUS ' standard rapporter giver dig mulighed for at få en liste over de komponenter og tilslutninger i en eller flere af dine arkitekturer. Rapporten indeholder alle oplysninger om de komponenter og forbindelser udvalgte, herunder oplysninger om komponenten eller forbindelsen plads i hierarkiet, type, standarder, beskrivelse, egenskaber og dens vedhæftede filer.

Note

Indholdet rapport erkonfigurerbargennem dialogen Rapport Options beskrevet nedenfor, men to finde ud af mere information om, hvordan du opretter helt konfigurerbar skik rapporterhjælp ABACUS Tilpassede rapporter, be om henvises til emnet her eller kontakt Skønnede udvikling Support .

For at se et standard rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur(s).

2. Vælge Indsæt| Standard rapporteller klik på Opret Standard rapport knap på værktøjslinjen. De Rapport KonfigurationVinduet vil blive vist.

Rapport Configuration vinduet

3. Vælg Arkitekturer, Komponenter og Tilslutningersom du ønsker i rapporten fra Rapport Configuration Vinduet.Der henvises til standard Element Selection her emne for hjælp.

4. Klik nu på Optionerknappen og Rapport ValgmulighederVinduet vil vise.

Rapport Vinduet

5. Du kan vælge at vise et Ny side for hvert element, de Udskriv dato, Print Time, Sidetalog om der skal omfatter titlen i headerenaf rapporten ved at sætte / fjerne fluebenet de relevante afkrydsningsfelter. Du kan også ønsker at tilpasse titlen og forfatter ved at redigere Rapport Titel og Forfatter tekstbokse. Du kan også vælge, hvilket indhold der vises på rapporten fra sætte / fjerne fluebenet afkrydsningsfelterne under Anmeld indholddel af vinduet. Når du er færdig klik på Okay.

6. Klik nu på Sluttei rapporten Configuration vinduet.

At fortolke det synlige rapport

Eksempel genererede rapport med korte forklaringer

At navigere gennem rapportsider, skal du klikke på ikonerne [image] placeret på værktøjslinjen i øverste venstre hjørne af skærmen.

Note

Du kan spare rapporten til forskellige formater ved at klikke på Eksportere rapport ikon [image] placeret i værktøjslinjen. Du kan vælge at eksportere i følgende formater: Excel, PDF og Ord. Venligst gemme rapporten på det ønskede sted til senere brug. Hvis der foretages ændringer arkitekturen på et senere tidspunkt, vil en ny rapport skal oprettes for at afspejle ændringerne.

Se også

Analyse din arkitektur


Tilpassede rapporter

Navigation: Rapportering om din arkitektur>

Tilpassede rapporter

Send kommentarer om dette emne.

ABACUS 'brugerdefinerede rapporter giver dig mulighed for at skabe helt konfigurerbare brugerdefinerede rapporter. Rapporterne kan indeholde brugerdefinerede billedsprog og grafik samt detaljering nogen komponenter, tilslutninger eller attributter fra en ABACUS repository samt detaljerede analytiske resultater fra forskellige simuleringer (herunder TCO, ydeevne og pålidelighed). Derudover kan rapporter indeholde diagrammer, diagrammer, kataloger, matricer / pivottabeller, kort, gauges, minidiagrammer, data barer og indikatorer (f.eks trafik-lys).

Note

Mens enhver bruger kan åbne eksisterende brugerdefinerede rapporter, to configure rapporter brugerlicensen behov for Rapport Konfiguration evne. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

For at se et skik rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur(s).

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporterVinduet vil blive vist.

Tilpassede rapporter vindue

3. Vælgeksisterende Rapportsom du ønsker at vise fra Tilgængelige rapporter afsnit.

4. Klik Kør rapport.Rapporten åbnes i Microsoft Report Viewer og to Naviger gennem rapportsider, skal du klikke på ikonerne [image] placeret på værktøjslinjen i øverste venstre hjørne af skærmen.

Note

Du kan spare rapporten til forskellige formater ved at klikke på Eksportere rapport ikon [image] placeret i værktøjslinjen. Du kan vælge at eksportere i følgende formater: Excel, PDF og Ord. Venligst gemme rapporten på det ønskede sted til senere brug. Hvis der foretages ændringer arkitekturen på et senere tidspunkt, vil en ny rapport skal oprettes for at afspejle ændringerne.

Til redigere datalager, der sendes til a skik rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur(s).

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporter vindue (vist ovenfor) vil blive vist.

Note

Mens enhver bruger kan åbne eksisterende brugerdefinerede rapporter, to configure de data, der sendes til en brugerdefineret rapport brugerlicensen behov for Rapport Konfiguration evne. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

3. Vælgeksisterende Rapportsom du ønsker at vise fra Tilgængelige rapporter afsnit.

4. Klik Rediger data Sets. De Datasæt EditorVinduet vil blive vist.Dette vindue viser indsamlingen af ​​datasæt, der i øjeblikket sendes til en brugerdefineret rapport. I nedenstående eksempel er der tre (3);

· en ApplicationProxy datasæt, der specificerer alle detaljer for alle Application komponenter i "2015 Aktuel 'arkitektur (herunder egenskaber på deres standarder og eventuelle vedhæftede komponenter),

· et TwoDViewProxy datasæt, der specificerer et eller flere diagrammer hvor navnet matcher »Ansøgning Landskab (Australien)«,

· et TargetProxy datasæt, der specificerer alle detaljer for alle Target forbindelser i den "2015 faktiske" arkitektur (herunder de vedlagte komponenter).

Datasæt Editor vindue

Note

Den Query Navn vil blive anvendt til datasættet navn i Microsoft Report Builder (se nedenfor). Medtag felt angiver, om datasættet er enten et enkelt element, en samling af elementer, alle komponenttyper, Alle Typer, en eller flere arkitekturer, en eller flere diagrammer eller en eller flere diagrammer. For den "Indsamling af Elements 'datasæt en knap Filter leveres som når der klikkes åbner Element Filter vindue, som giver dig mulighed for at anvende flere filtre til at returnere kun elementer fra bestemte arkitekturer og / eller visse typer, og / eller med bestemte standarder og / eller er knyttet til bestemte komponenter, og / eller med bestemte forældre, og / eller i visse diagrammer, og / eller i bestemte diagrammer og / eller med givne Ejendom værdier. For de øvrige data sæt typer et navn felt er tilvejebragt og bruge knappen Vælg kan du vælge objektet (r), der skal indgå i datasættet.

Note

De datasæt lagres i enDatasæt fil (.xml)med den samme base filnavn som enforbundet Rapport Definition-fil (.rdl). Hvis denne fil ikke findes datasættet editoren vil automatisk udfylde med enhver forespørgsel navne, der findes i Rapport Definition-fil (.rdl)og en ny Datasæt fil (.xml)vil blive oprettet, når en en gyldig liste over forespørgsler er defineret.

3. Hvis du ønsker at slette en eksisterende datasæt derefter vælge Slet Query knap.

4. Hvis du ønsker at tilføje et nyt datasæt klik derefter på Tilføj ny Data Setknap og konfigurere datasættet som pr ovenstående Note.

Til oprette en ny brugerdefineret rapport(fra en skabelon)

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur.

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporter vindue (vist ovenfor) vil blive vist.

3. Klik Ny og vælg enten A4 - portræt, A4- Landskab, A3 - portræt, A3 Landskab, US Letter - portræt, US Letter - Landskab, US Tabloid - portræt eller US Tabloid - Landskabafhængigt af rapporten orientering og papirformat, der ønskes.

4. Gå til den placering for at gemme rapporten Definition fil (.rdl / .rdlc), og tilhørende data-fil (.xml), og klik Spare. Dette vil tilføje en ny brugerdefineret rapport til rådighed Rapporter afsnit af tilpassede rapporter vinduet og det kan åbnes eller redigeres som beskrevet ovenfor.

Til tilføje en eksisterende brugerdefineret rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur.

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporter vindue (vist ovenfor) vil blive vist.

3. Klik Tilføje og find den placering af rapporten Definition fil (.rdl / .rdlc), og klik Åben. Dette vil tilføje en ny brugerdefineret rapport til rådighed Rapporter afsnit af tilpassede rapporter vinduet og det kan åbnes eller redigeres som beskrevet ovenfor.

Note

Det antages, at en matchende Data Set-fil (.xml) findes i den samme placering som rapporten Definition fil.

Til kopiere en eksisterende brugerdefineret rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur.

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporter vindue (vist ovenfor) vil blive vist.

3. Vælgeksisterende Rapportsom du ønsker at kopiere fra Tilgængelige rapporter afsnit.

4. Klik Kopi og en kopi af den valgte rapport (navnet 'Kopi af ... ") vil blive tilføjet til den Tilgængelige rapporter afsnit af tilpassede rapporter vinduet og det kan åbnes eller redigeres som beskrevet ovenfor.

Note

Ved at gøre dette vil du oprette en kopi af rapportens Rapport Definition fil (.rdl / .rdlc) samt dens matchende Data Set-fil (.xml)(hvis det findes).

Til fjerne en eksisterende brugerdefineret rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur.

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporter vindue (vist ovenfor) vil blive vist.

3. Vælgeksisterende Rapportsom du ønsker at fjerne fra Tilgængelige rapportersektion og klik Fjerne.

Note

Når du fjerner en rapport, vil ikke længere blive vist på rapporten listen. Dette vil imidlertid ikke slette Rapporten beretning Definition fil (.rdl / .rdlc) eller Data Set fil(.xml). Hvis det er nødvendigt, kan slette disse filer opnås gennem filsystemet.

Til omdøbe en eksisterende brugerdefineret rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur.

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporter vindue (vist ovenfor) vil blive vist.

3. Vælgeksisterende Rapportsom du ønsker at omdøbe i de Tilgængelige rapportersektion og klik Omdøb.

4. Indtast et nyt navn for rapporten.

Note

Både rapporten Definition fil (.rdl / .rdlc), og tilhørende data-fil (.xml) vil blive omdøbt i overensstemmelse hermed.

Til redigere designet af et skik rapport

1. Sikre, at du har en ABACUS fil åben indeholder dit befolkede arkitektur.

2. Vælge Indsæt| Brugerdefineret rapporteller klik på Opret brugerdefinerede rapport knap på værktøjslinjen. De Tilpassede rapporter vindue (vist ovenfor) vil blive vist.

Note

Mens enhver bruger kan åbne eksisterende brugerdefinerede rapporter, to configure udformningen af ​​en tilpassede rapporter brugerlicensen behov for Rapport Konfiguration evne. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.Derudover er Microsoft Report Builder 3.0 kræves for at designe rapporter, og det kan downloades gratis fra her .

3. Vælgeksisterende Rapportsom du ønsker at vise fra Tilgængelige rapporter afsnit.

4. Klik Edit Report.Rapporten åbnes i Microsoft Report Builder 3.0. For specifikke hjælp og nogle tips & tricks 'på nogle af de mere almindelige opgaver med at designe rapporter henvises til afsnittene nedenfor. For generel hjælp til at designe rapporter henvises til Microsoft Report Builder 3.0 hjælpesider her .

Tilføjelse tabeller til din rapport

1. Sikre, at du har en ABACUS tilpasset rapport Definition fil (.rdl / .rdlc) åben i Microsoft Report Builder 3.0.

2. Vælge de Indsæt fane i "bånd" øverst, så Klik på Tabel knapi afsnittet data Regioner og vælg Indsæt tabel.

3. Nu trække markørentil positionen på rapportens lærredet, hvor du ønsker det øverste venstre hjørne af tabellen for at placeret. Klik på lærredet. Som standard bordet vil blive tilføjet med en kolonneoverskrift og derefter en detaljer gruppe (en gruppe bruges til at organisere en visning af en rapport datasæt). For at fjerne gruppen, enten slette rækken eller slette Row Group i gruppering værktøjslinjen.

Tips

Formler / Udtryk i tabelceller redigeres ved at markere cellen derefter højreklikke på << Udtr >> tekst og vælge Expression .... Sortering rækker i en tabel gøres ved at vælge tabellen og derefter browse ned til Andet -> SortExpressions felt i panelet Egenskaber og indtaste et udtryk. For en samlet række i slutningen af ​​et bord tilføjer en række efter (og udenfor) grupperingen og derefter bruge følgende udtryk = Sum (Fields!Navn.Værdi)hvor 'Navn' er det område, der i alt. For at anvende farve på søjler bruge en "IIf 'udtalelse i BackgroundColor ejendommen. Hvis du vil tilføje en måler som en celle i en tabel først indsætte måleren i en celle, og så drop datafelter, der kræves for måleren. Når du redigerer højden & bredder af tabelrækker, sikre, at du vælger den rigtige række, og derefter holder musen markøren rundt de grå linjer, indtil du får den Pil op / ned markør, og derefter ændre størrelsen.

Tilføjelse diagrammer til din rapport

1. Sikre, at du har en ABACUS tilpasset rapport Definition fil (.rdl / .rdlc) åben i Microsoft Report Builder 3.0.

2. Vælge de Indsæt fane i "bånd" øverst, så Klik på Diagram knapi afsnittet data Regioner og vælg Indsæt Chart.

3. Nu trække markørentil positionen på rapportens lærredet, hvor du ønsker det øverste venstre hjørne af diagrammet for at placeret. Klik på lærredet og så Vælg diagrammetdu har brug for fra valgmulighederne og klik Okay.

Tips

For at vise en ejendom som en anmærkning på søkort, skal du højreklikke på diagrammet og vælg Vis data Etiketter, vælg derefter en af ​​de etiketter, der er blevet tilføjet, og indstil Diverse -> UseValueAsLabel til False i panelet Egenskaber og tilføje et udtryk (f.eks = Name.Value) i diverse felter -!> Label. Specifikt for boble diagrammer; Boble diagrammer vises under overskriften Scatter diagrammet. Drop X-akse ejendom i serie felter (eller tilføje i serie Properties). Drop Y-akse ejendom i Datafelter (eller tilføje i serie Properties). For at bruge en ejendom til at definere boble størrelse, drop dette i Datafelter (eller tilføje i serie Properties). Boble diagrammer ikke er i stand til at vise, om der er for mange data (200+ varer), undertiden dette medfører hele rapporten for ikke at vise. Marker Type - Indstil til cirkel. Som standard, når slippe felter i Datafelter, det tilføjer dem med de sum()formel, så fjern dette. Specifikt for Stacked diagrammer / Tidslinje / Gantt diagrammer; For et Gantt-diagram bruge en række diagram og tilføje egenskaber som høje og lave værdier i datafelterne. Du kan have flere "søjler" ved at tilføje flere og flere områder, hvor den lave værdi for én matcher den høje værdi for en anden. Specifikt for Lagkagediagrammer; For aggregerede lagkagediagrammer, slip data i kategori felter og datafelter, tilføje formlen = CountRows (). Bortfiltrere eventuelle 0-værdier (fx på omkostnings- diagrammer), vil ellers etiketter til disse stadig vises på kortet.

Brug af en IIf erklæring tilføje farver til tabeller og diagrammer

1. Sikre, at du har en ABACUS tilpasset rapport Definition fil (.rdl / .rdlc) åben i Microsoft Report Builder 3.0.

2. Højreklik på cellen i tabellen til farve og klik Tekstboks Egenskaber.

3. Vælge Fylde og klik på FXknappen til højre for Fyld farve etiketten og i sættet et udtryk for BackgroundColor feltet indtaste et udtryk, fx = IIf (Fields! InformationStatus.Value = "Behold", "lysegrøn", IIf (Fields! InformationStatus.Value = "Redesign", "Yellow", IIf (Fields! InformationStatus.Value = "Refresh", "Orange", " Laks"))). Dette ændrer baggrundsfarven til lysegrøn for hver celle, der indeholder status 'Behold', gul for hver celle, der indeholder status 'Redesign «, Orange for hver celle, der indeholder status' Opdater 'og enhver anden status værdi vil være farvet i "Laks".

Note

Farver kan tilføjes for diagrammer ved at vælge serie på diagrammet og derefter indstille Udseende -> Farve ejendom (eller boble diagrammer Udseende -> Marker -> Farve ejendomsret) til et udtryk der ligner ovenstående eksempel.

Ting at huske på, når designe tilpassede rapporter

· Fordi alle ejendomme undtagen Integer sendes som en streng fra ABACUS til rapporten seeren, hvis du ønsker at gøre noget 'udtrykkene »med dem (ligesom dividere en egenskab med en anden eller sortere), du har brug for at konvertere dem til decimal eller Dato etc. For baggrunden , denne artikel er en god reference. F.eks. = CDate (Fields! LifecycleEndDate.Value) Note: Sørg for, at rapporten er indstillet til en-GB (som beskrevet nedenfor) for at acceptere dd / mm / åååå som det forventer mm / dd / åååå-format som standard, og derfor 31/7/2011 vil mislykkes konvertering. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Hvis du opdager, at du kæmper for at holde alle de tabeller og diagrammer på en side, Der er et par vigtigste måder at forvalte dit dokument plads:

· Sideskift - Sørg for, at denne tabel indstilling er slået fra for hver tabel, som du ønsker at være på samme side.

· Hold Together - Sikre denne borddækning er sandt for hver tabel, som du ønsker at være på samme side.

· Ved flytning tingene rundt, er det lettere at zoome ud ved hjælp af kontrol nederst til højre på siden og derefter multi vælge elementer og træk

· Til billedet række i en tabel, skal du sørge for, at 'Størrelse' | "Dimensionering" Ejendom er sat til 'Fit' ellers billedet muligvis for stor, eller det vil blive dårligt strakt.

· Til gentage en header række i en tabel på hver sideaf rapporten:

1. Åbn Avanceret tilstand i ruden grupperinger. (Klik på pilen til højre for kolonnen Grupper og vælg Avanceret tilstand.)

2. I rækken Grupper området (ikke Kolonne grupper), skal du klikke på en statisk gruppe, som fremhæver den tilsvarende tekstfeltet i tablix. Klik gennem hver Statisk gruppe, indtil den fremhæver det yderste venstre kolonneoverskriften. Dette er normalt den første statiske er noteret.

3. I vinduet Egenskaber, skal du indstille RepeatOnNewPage egenskaben til True.

4. Sørg for, at KeepWithGroup egenskaben er sat til Efter.

· Skift sprogindstillingeri Rapport egenskaber til at matche de dataformater, du har brug, f.eks da-DK til at producere UK dato format (dd / mm / åååå).

Se også

Analyse din arkitektur


Udgiv til web

Navigation: Rapportering om din arkitektur>

Udgiv til web

Send kommentarer om dette emne.

ABACUS 'Udgiv til web funktion giver arkitektoniske modeller, der skal ses via en sikker hjemmeside. Arkitekturer, der eksporteres til HTML-format og er designet til at afspejle udseendet og fornemmelsen af ​​Stifinder i ABACUS. Synspunkter (herunder Kataloger, diagrammer, 3D og diagrammer) også eksporteres til formater kan vises ved hjælp af en internet-browser.

Note

I øjeblikket er synspunkter og Matricer ikke offentliggjort.

At publicere dine arkitekturmodeller til internettet

1. Sørg for at du har den relevante ABACUS filåben, indeholdende befolkede arkitekturat du ønsker at udgive på internettet.

2. Vælge Fil| Offentliggøre....

3. De Udgiv til web-konfigurationVinduet vil vise.

Udgiv til web-konfiguration

4. Som standard alle de dele af modellen er valgt, herunder trævisningen den StandarderDe typer, Skabeloner og arkitektur (r). Fjern markeringen alle dele, du ikke ønsker at offentliggøre på internettet, herunder eventuelle individuelle synspunkter inden arkitekturen (r).

Tip

Hvis du ønsker at skjule bestemte komponenter, tilslutninger og / eller deres egenskaber anbefales det, at en administrator opretter en "offentlig" rolle hjælp ABACUS 'rollebaseret adgang funktionen og derefter fjerner Læs tilladelse fra disse komponenttyper, forbindelsestyper og / eller egenskaber, at de ikke ønsker at blive offentliggjort. Så skulle en bruger logger ind under denne rolle og udgive til internettet som ABACUS kun vil udgive elementer, der har læst tilladelse sat til rollen. Desuden kan brugerne automatisk publicere fra kommandolinjen som beskrevet her .

Note

Du må vælge alle de dele, der vises ved at klikke på Alleknappen eller invertere dit valg ved at klikke på Inverter knap. Du kan også klikke på Ingenknap for at slette dit valg.

Note

Hvis du fjerne markeringen trævisningen indstillingenså ingen trærammen (se nedenfor) vil blive offentliggjort. Derfor, du skal vælge en startsiden ifølge trin 6 nedenfor eller efter udgivelse, du bliver nødt til at tilpasse enten på øverste niveau; en) index.htmlfil ved at ændre den "ramme src =" mainPage.html "name =" element_details "'linje til direkte link til den relevante HTML-side under Content mappe eller, b) mainPage.htmlved at give et hyperlink eller omdirigere til den relevante HTML-side under Content mappe.

5. Klik på Valgmulighed knappen og følgende Udgiver ValgmulighederDialogen vil blive vist.

OffentliggøreER Valgmuligheder

6. Svælger 3D, Diagramog Charts formater og om at vise Titel, Beskrivelse eller Egenskaber for visningerne ud af de tilgængelige muligheder (se nedenfor note for kommentarer til de forskellige formater).

7. Hvis du ønsker at indstille startsiden af ​​den offentliggjorte model til en bestemt visning derefter kontrollere Brug Vis som startsidemulighed, og browse til visningen via knappen '...', der bliver aktiveret.

Note

Kun de valgte i afsnittet Områder som pr Trin 4 visninger ovenfor, er klar til at blive indstillet som startside.

8. Hvis du ønsker at modtage feedback på specifikke sider i den offentliggjorte model så sørg for E-mail Feedbacker valgt, indtaste en e-mailadresse i Email adresse tekstfeltog rediger E-mail Kropsnit som passende. Hvis du ikke ønsker at have feedback, sendte derefter fjerne markeringen i E-mail Feedbackindstilling og lade tekstfeltet tom.

9. Klik på Okay knap.

10. Klik på Gennemse knap.

11. De Browse for FolderVinduet vil vise.

12. Vælg den placering, du vil gemme på øverste niveau HTML-fil (og eventuelle automatisk genererede filer).

Note

Det er en god idé at oprette en bestemt mappe (typisk kaldet "Udgivet") ved hjælp af Lav ny mappeknappen nederst i dialogboksen for at gemme den øverste niveau HTML-fil og eventuelle automatisk genererede filer.

13. Klik på Okay knap.

14.. Mappen vej vil vise i Vejviser tekstfelt.

15. Klik på Slutte knap.

- eller -

15. Indtast mappesti i Vejvisertekstboks, hvor du vil gemme det øverste niveau HTML-fil (og eventuelle automatisk genererede filer).

16. Klik på Slutte knap.

Note

Eksport af Diagrammermeget lejlighedsvis mislykkes, oftest når computeren er ude af hukommelsen (normalt ved brug af meget store filer). En mislykket eksport vil blive forsøgt igen en gang. Der vil være en advarsel om et mislykket første forsøg, og en anden advarsel, hvis re-forsøg mislykkes. Derfor, hvis de eneste advarsler er "første forsøg mislykkedes" dem, det udgiver lykkedes. Hvis re-forsøg mislykkes forsøge at offentliggøre en mindre del af din fil eller gratis op nogle systemhukommelse.

Den gemte HTML-fil (er) kan nu være udsigt fra dens placering eller kopieres til et sikkert websted.

Udgiv til web i Internet Explorer10

Enhver hyperlinks der blev skabt i den oprindelige model vil blive fastholdt i den offentliggjorte model og klikke på linket vil følge linket til sit bestemmelsessted (hvis det blev offentliggjort). Desuden vil eventuelle elementer i publicerede diagrammer, der ikke allerede hyperlink i den oprindelige model af hyperlink tilbage til deres tilsvarende elementer i trævisningen (hvis det blev offentliggjort), og ved at klikke på elementet i den offentliggjorte diagrammet fokus vil hoppe tilbage til den relevante placering i træet. Denne funktion svarer til "Vis i Stifinder" højre-klik-funktionen i ABACUS.

Note

Skønnede udvikling anbefaler kraftigt følgende software og filformater bør anvendes til fuldt ud at udnytte Udgiv til web-funktionalitet i ABACUS:

1. Internet Explorer (80,0 og derover)for at se den offentliggjorte explorer visning. Mozilla Firefox (30,0 eller senere)anbefales også, og fuldt understøttetMen hvis du bruger det anbefalede SVG-format til diagrammer derefter i Firefox 9 du kan kun bruge den indfødte SVG viewer støtte, som desværre ikke tillader zoome eller panorering.

2. Adobe SVG Viewer 3.0 plug-in (download fra her ) og SVGfilformat til den offentliggjorte diagrammer. Den SVG-billede format for diagrammeranbefales fordi; SVG er en vektor-baserede billedformat og derfor er det "tabsfri" og ser langt bedre på ethvert givet zoomniveau end nogen af ​​de andre formater, kan SVG importeres til MS Visio, kan SVG zoomes til ethvert niveau eller opløsning , SVG har links tilbage til trævisningen for tilslutningerne (ikke kun komponenterne), SVG altid udskriver på en bedre opløsning, og SVG er omkring halvdelen filstørrelsen af ​​de andre formater. PNG er den næste anbefaling, men da det er en rastereseret format på bestemte zoomniveauer klarhed af den opfattelse, vil blive tabt, og klikke forbindelser på diagrammer vil ikke hoppe tilbage til det relevante sted i træet. BMP frarådes som mens det er en "tabsfri" formatere filstørrelsen er 100x de øvrige formater og 20MB billeder er ikke usædvanligt.

Trade-off med SVG er, at en SVG viewer bliver nødt til at blive installeret, og du skal sørge for, at der tilsættes .svg image / svg + xml web serverens MIME-typer. Efter installation af SVG viewer Microsoft Internet Explorer vil bede dig om at acceptere beskuerens licensaftale og så skulle virke fint. Og mensMozilla Firefox understøtter SVG-filer indbygget, Adobe plugin anbefales stadigat være i stand til at zoome diagrammerne, hvis du bruger Firefox 8 eller tidligere (hvis du bruger Firefox 9 kan du ikke deaktivere den indfødte SVG viewer). Når installationen for Adobe plugin er blevet kørt, de følgende trin er nødvendige bruge det i Firefox:

· Åbne op firefox og skriv "about: config" (uden citationstegn) i adresselinjen.

· Rul ned og find ejendommen svg.enabled(hvis du bruger Firefox 9 så den indfødte SVG visning kan ikke deaktiveres, og denne egenskab eksisterer ikke). Dobbeltklik på den for at deaktivere den.

· Nu finde den mappe, hvor SVG plugin er installeret (f.eks C: \ Programmer \ Fælles filer \ Adobe \ SVG Viewer 30,0 \)

· Kopiere filerne NPSVG3dll og de NPSVG3.zip og indsætte dem i firefox plugins mappe (f.eks C: \ Program Files \ Mozilla Firefox \ plugins)

· Lukke alle forekomster af firefox

3. Skønnede udvikling s ABACUS 3D Viewer (3,1 og derover) og Skønnede udvikling s .abacus3Dfilformat til de offentliggjorte 3D-visninger. Mens Cortona VRML Client plug-in (2,0 og derover)er til rådighed for at se VRML-versioner af de offentliggjorte synspunkter er det ikke gratis for kommerciel brug, og kræver stadig en klient-side installation. Abacus 3D Viewer er mere feature-rige end nogen VRML viewer og er frit tilgængelig for download fra her . I begge tilfælde skal du sørge for tilføje .vrml X-verden / x-VRML og .abacus3d application / octet-stream til internettet serverens MIME-typer.

4. PNGfilformat til de offentliggjorte Chart synspunkter. Den PNG-billede format til kortvisninger anbefales, fordi mens det er en rastereseret format, og der er "tab" trade-off mellem filstørrelse og diagram klarhed er typisk den bedste. BMP frarådes som mens det er en "tabsfri" formatere filstørrelsen er 20x, at de andre formater og 2 Mb diagrammer er ikke usædvanligt.

Hvis du ønsker at ændre udseendet og fornemmelsen af ​​de websider, kan du redigere startsiden fil med navnet mainPage.html og typografiark fil med navnet abacus.css. Du vil finde disse filer i samme mappe, hvor du har valgt at gemme øverste niveau HTML-fil. For mere information om strukturen og skræddersy den offentliggjorte output se næste afsnit.

Strukturen af ​​ABACUS offentliggjorte modeller

Den ABACUS offentliggjorte model er opbygget som følger:

1. Mappen øverste niveau indeholder flere filer og forudsat alle muligheder er inkluderet i ABACUS Udgiv til web-konfiguration dialogboksen det vil omfatte en indeks.htmlfil, der består af tre rammer; treeView.html, findNode.html og mainPage.html og så shortcutError.html side. Den treeView.html er befolket af tree.js, tree_items.js og tree_tpl.js javascript filer placeret under omfatte mappe (omtalt nedenfor) og kopierer Explorer træet fra ABACUS. Den findNode.html er drevet af de find.js javascript fil placeret under omfatte mappe (omtalt nedenfor), og det vil søge grene af træet snarere end blot de synlige noder. Than mainPage.html er en statisk HTML-side, der kan skræddersys med firmalogoer og lignendeog vil blive vist, medmindre en startsiden vælges, når der udgives.Og endelig, shortcutError.html side er en destinationsside for eventuelle ødelagte genveje fra træet på grund af de relevante sider ikke bliver offentliggjort.

Tip

Du kan springe mainPage.html helt ved vælger at bruge en start side, når der udgives eller modificere index.html fil til at pege direkte til en given visning (sige) ved at redigere rammen src = "mainPage.html" linje til at pege direkte til den første visning i første arkitektur, typisk den "rammer" diagram.

2. Det øverste niveau includemappe indeholderING forskellige javascript (.js) og Cascading Style Sheet (.css) filer der bruges af de .html filer hele den offentliggjorte model.

3. Mappen øverste niveau Indhold indeholder, Alfabetisk;

· EN '3D Visninger' mappe med etnummereredeHTML-side og en VRML eller abacus3d fil for hver af de offentliggjorte 3D-visninger. Se noten nedenfor for oplysninger om filen nummersystem.

· En Arkitekturer mappe med en nummereret HTML-side for hver arkitektur, der blev offentliggjort. Se noten nedenfor for oplysninger om filen nummersystem.

· A Kataloger mappe, der indeholder en nummereret HTML-side for hver af de offentliggjorte kataloger. Se noten nedenfor for oplysninger om filen nummersystem.

· A Diagrammer mappe med etnummereredeHTML-side og en PNG, JPG osv fil for hver af de offentliggjorte kortvisninger. Se noten nedenfor for oplysninger om filen nummersystem.

· A Komponenter mappe, der indeholder ennummereredeHTML-side for hver af de offentliggjorte komponenter. Se noten nedenfor for oplysninger om filen nummersystem.

· A Tilslutninger mappe, der indeholder ennummereredeHTML-side for hver af de offentliggjorte forbindelser. Se noten nedenfor for oplysninger om filen nummersystem.

· A Diagrammer mappe, der indeholder ennummereredeHTML-side og en PNG, SVG osv fil for hver af de offentliggjorte diagrammer. Se noten nedenfor for oplysninger om filen nummersystem.

· En ikoner sub-folder med forskellige billeder, der anvendes i hele den offentliggjorte model.

· A Standarder undermappe med ennummereredeHTML-side for en standarderder blev offentliggjort. Se noten nedenfor for oplysninger om filen nummersystem.

· A Skabeloner sub-folder med en samling af nummererede undermapper for hver skabelon offentliggjort fra projektet. Inden for hver undermappe er en Komponenter og en Connections mappe og inden disse er en nummereret HTML-side for hver komponent og tilslutning af skabelonen. Se noten nedenfor for oplysninger om den mappe / fil nummersystem.

· A Typer undermappe med komponent ogTilslutning undermapper med ennummereredeHTML-side for enhver komponent ogConnection Typer, der blev offentliggjortog en samling af nummererede undermapper for hver type offentliggjort fra projektet indeholder en HTML-side for hver af de begrænsninger. Se noten nedenfor for oplysninger om den mappe / fil nummersystem.

· A Udsigtpunkts undermappe og ennummereredeHTML-side for nogen af ​​Viewpunkts, der blev offentliggjort. Se noten nedenfor for oplysninger om filen nummersystem.

Note

Nummereringen af ​​HTML-sider (og i nogle tilfælde billedfiler) matcher enestående ID for hver repository objekt, der var indstillet, når det var oprettetinden ABACUS (benævnt EEIDs). Denne ID ændrer ikke så i takt med diagrammer, typer, komponenter etc er opdateret de viljebevarer samme ID som før. I hvert tilfælde skal den relevante repository objektnavn kan findes nær starten af ​​HTML-siden mellem ... HTML-tags.

Begrænsning af adgang til bestemte sider / ser med IIS

Hvis du bruger IIS som din webserver til den offentliggjorte model, kan du være i stand til at begrænse adgangen til visse sider / udsigt udnytte nedenstående metode:

1. Opret en hjemmeside i IIS (en anden, hvis der er et eksisterende, du ikke ønsker at blande sig i).

2. Skift Egenskaber-> Vejviser Security> Anonym adgang - fjerne markeringen anonym adgang og brug autentificeret adgang.

3. Hvis dette er bare en normal server uden domæne komplikationer osv, så skal du bruge 'integreret Windows-godkendelse' mulighed, som så ville bruge serveren maskiner lokale brugere / logins som autentifikation, og blot tilføje brugere til den lokale computer (være omhyggelig at du er klar over konsekvenserne, sikkerhed klogt, for at tilføje nye brugere til maskinen, fx afhængigt af, om fjernadgang er sat til maskinen, osv).

4. Tilføj tilladelser til de specifikke filer / mapper efter behov. Højreklik de enkelte filer / mapper -> Egenskaber, og juster tilladelser sikkerhedsstyrkerne, som du normalt ville for filer / mapper.

Dette kan variere afhængigt af, hvilken version af IIS og hvilke specifikke Windows operativsystem er på serveren, og om du har et domæne eller anden anderledes opsætning.

Se også

Befolker din arkitektur | Analyse din arkitektur


Eksport af din arkitektur

Navigation: Rapportering om din arkitektur>

Eksport af din arkitektur

Send kommentarer om dette emne.

ABACUS giver dig tileksportere din arkitektur til .mdb (Microsoft Access), MS SQL Server, .abacus (Abacus fil), og .xls- (Microsoft Excel) format. Du kan også eksportere din diagrams til PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF og BMP-format og dine rapporter til .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word), og .rtf (Rich Text Format) formater. Dette giver dig mulighed for at analysere og se arkitektur og sine data på nogen måde, du ønsker.

For at eksportere din arkitektur til .mdb (Microsoft Access)

1. Sikre, at du har en ABACUS fil åben.

2. Klik på Fil menu.

3. Vælge Eksportere, og så Til MDB.

4. Vær opmærksom på advarslen, og klik Okay.

5. Skriv et navn til filen.

6. Klik på Spare Knap.

Note

Eksport format .mdb database er specifikke for ABACUS og eventuelle skemaændringer vil resultere i manglende evne til at re-import. Se venligst Befolker med MS Access for en beskrivelse af MS Access-skemaet.

For at eksportere din arkitektur til MS SQL Server

1. Sikre, at du har en ABACUS fil åben.

2. Klik på Fil menu.

3. Vælge Eksportere, og så Til MS SQL Server.

4. I den dialogboks, der vises ved at klikke på Eksport Blank MDB ...knappen og importere dette i din MS SQL Server-database-server.

5. Udfyld oplysningerne i databasen og forbindelsen strengen.

6. Klik på Eksportere Knap.

Note

Eksport format MS SQL Serverdatabase er specifikke for ABACUS og eventuelle skemaændringer vil resultere i manglende evne til at re-import. Se venligst Befolker med MS Access for en beskrivelse af databasen skema.

For at eksportere din arkitektur til .xls (Excel-fil)

1. Sikre, at du har en ABACUS fil åben En viste opdagelsesrejsende Og en arkitektur tilføjet .

2. Sikre, at du har en Excel Import / Export konfigurationsfil defineret.

3. Højreklikpå en arkitektur i modellen eller en del af Komponenternode (inden for en given arkitektur), du ønsker at eksportere til Excel konfigurationsfil.

4. Vælge Eksportere | Til Excel ... fra menuen.

5. De Vælg Excel Import / Export konfigurationsfil til at brugeVinduet vil blive vist.

6. Vælg den relevante konfiguration fil til din arkitektonisk model, og klik på Åben knap.

7. Hvis ikke automatisk gjort det, kort de øverste niveau komponenter i din nuværende arkitektur til Set id(som tidligere defineret) og klik på Eksportere....

Eksempel Bedst Level Komponent Mapping

8. Vælg en placering og et filnavn til din Excel-fil, og klik på Spare knap.

For at eksportere din arkitektur til .abacus (ABACUS fil)

1. Sikre, at du har en ABACUS fil åben.

2. Højreklikpå Arkitektur node, enhver arkitektur i din model eller en del af komponenterne træet.

3. Vælge Eksport | Til Fil...fra menuen.

4. Vælg en placering og et filnavn, og klik på Spare knap.

Note

Du kan importere en ABACUS fil tilbage i ABACUS ved følgende trin 1-2ovenfor og derefter vælge Import | Fra Fil.... Når du har valgt den fil, du vil importere, bliver du spurgt, hvordan du ønsker at importere de standarder og typer. Du kan importere standarder og typer som enten nye eller fusionerede standarder og typer. Standardindstillingen er for normer og typer at blive fusioneret med eksisterende normer og typer, såfremt de allerede findes i din projekt.

For at eksportere din arkitektur til .xml

1. Sikre, at du har en ABACUS fil åben.

2. Højreklikpå en arkitektur node, enhver arkitektur i din model eller en del af komponenten træet.

3. Vælge Eksport | Til XML ...fra menuen. Alternativt kan du klikke på menuen Fil| Eksportere| Til XML ...

4. Vælg en placering og et filnavn, og klik på Spare knap.

Note

Du kan importere en XML-fil tilbage i ABACUS ved følgende trin 1-2ovenfor og derefter vælge Import | Fra XML .... Når du har valgt den XML-fil, du vil importere, bliver du spurgt, hvordan du ønsker at importere de standarder og typer. Du kan importere standarder og typer som enten nye eller fusionerede standarder og typer. Standardindstillingen er for normer og typer at blive fusioneret med eksisterende normer og typer, såfremt de allerede findes i din projekt.

For at eksportere diagrammet til PNG, JPG, SVG, TIFF, GIF eller BMP

1. Sikre, at du har en ABACUS fil åben.

2. Åbn diagramdu gerne vil eksportere.

3. Klik på Eksport Diagramknappen på Diagram værktøjslinje.

4. De Eksport Diagramvindue vises.

5. Vælg Gennemseknappen for at gemme visualisering i den ønskede placering.

6. Vælg Gem som typepull-down menuen til at vælge filtypen.

7. Klik på Spare knap.

Sådan eksporterer din rapport til .pdf (Adobe Acrobat), .xls (Microsoft Excel) eller.doc (Microsoft Word)

1. Sikre, at du har en ABACUS fil åben.

2. Opret en rapport du gerne vil eksportere.

3. Klik på Eksportereknappen på rapporterne værktøjslinjen.

4. Vælge Excel, PDF eller Wordfra drop-down boks.

5. Vent et øjeblik mens rapporten eksport.

6. Vælg en placering og et filnavn, og klik på Spare knap.


Arbejde med Enterprise Server

Navigation: Administration>

Arbejde med Enterprise Server

Send kommentarer om dette emne.

ABACUS Enterprise Server er både en »ikke-låsning 'samarbejdsorienteret tilgang, men en" afbrudt "en også. ABACUS er »ikke-låsning ', fordi det ikke tvinge fil, der skal låses fra en bruger for at blive opdateret. Hver bruger har sin egen lokale kopi af filen, og da de foretager ændringer og gemme deres filer, registreres og opbevares i, når brugeren ønsker at forpligte dem til serveren disse ændringer.

ABACUS er 'afbrudt' i den forstand, at du ikke behøver at være forbundet til serveren eller har brug for netadgang, mens de arbejder på en fil. ABACUS kræver kun adgang til serveren, når du udfører operationer ligesom at skabe en fil, eller udfører en kassen, sammen med operationer på en eksisterende fil - opdatering, begå, eller visning af log over fortiden begår. Adgang til serveren er ikke forpligtet til at arbejde på filen, og dine ændringer er ikke sendt til serveren med det samme (dette giver dig mulighed for nemt at kassere dine ændringer, hvis du laver en fejl). Når du gemmer din fil, er du 'bare' at gemme din kopi lokalt - det er ikke før du begår, at dine lokale ændringer (ændringer foretaget siden dit sidste begå), bliver sendt til serveren.

Oprettelse af en ny Enterprise fil

Hvis du vil oprette en ny Enterprise-fil, skal du vælge Fil| Ny ...og derefter vælge en af ​​de to første muligheder under Enterprise Model sektion af Ny dialog projekt (dvs. enten en tom Enterprise-fil, eller opret en fra en eksisterende ABACUS fil). Den tredje mulighed er at "bestilling" en Enterprise-fil en anden har allerede skabt, vil dette blive dækket i næste afsnit.

Når du vælger at oprette en ny Enterprise-fil, vil du få en dialog, der vil tillade dig at gå til, hvor på et lager server, du ønsker at gemme din fil. Det vil også have den eksisterende fil sti og navn indtastet op i toppen, hvis du vælger "Fra eksisterende model 'fra dialogen Nyt projekt og leveret en fil.

URL: Dette er webadressen til din repository server, hvor de ABACUS Enterprise filerne er gemt. Du bør spørge den person, der administrerer serveren, hvad denne webadresse skal være.

Billedet ovenfor viser et depot med fire (4) eksisterende ABACUS Enterprise-projekter, efter indtastning af URL og trykke på Enter. Du vil se, når du har oprettet en ny Enterprise-fil, på næste skærmbillede for "bestilling", vil der være en anden mappe og fil under denne lageret.

Note

Hvis du bruger en https (SSL) server, og serveren har ikke et gyldigt SSL-certifikat (fælles for intranet eller ikke-offentlige servere på grund af de udgifterne til SSL certifikats) Vil der være et ekstra skridt at tage. Du vil blive bedt om at permanent acceptere alle forbindelser til serveren i den dialogboks, der popper op (det vil også vise lidt mere information på serveren). For at gøre dette, skriv 'p' (uden anførselstegn) og tryk Enter. ABACUS vil poppe op en meddelelse, der minder dig om dette før viser dialogen.

Note

Du kan blive bedt om at logge ind på serveren, i hvilket tilfælde den person, der er styring af serverkan give serveren brugernavn og password. Også de login-oplysninger til nogen servere, som du har tilsluttet gemmes, så hvis en eller anden grund, de har brug for at blive ryddet dette kan gøres via Tools | Optionerog derefter på den Generel fane ved at klikke Nulstil Subversion Gemt Loginog vælge serveren fra drop-down listen og klikke Klar loginog vælge OK i dialogboksen, der vises.

Note

I modsætning til screenshot vist ovenfor, er typisk en enkelt ABACUS Project inkluderet i hver ABACUS Repository fordi hvis mere end 1 ABACUS Project er skabt i et enkelt ABACUS Repository, er Abacus ændre log numre deles på tværs af alle ABACUS Projekter og dette kan forvirre brugerne.

Foretrukne Filnavn: Dette påvirker både mappen og filnavnet, der vil blive anvendt (hvis det ikke allerede taget), når du opretter filen på lageret serveren. Bemærk, at en ny mappe oprettes automatisk på lageret server for hver fil (til ydeevnen, er ABACUS Enterprise filer oprettet i deres egen mappe under det sted gennemset i dialogen).

Opbevar arbejdskopi i Register: Når en Enterprise-fil oprettes på et lager-server, har brug for de lokale arbejdsforhold filer, der skal oprettes på din computer, så du kan arbejde på filen uden at være forbundet til netværket. Dette er det sted, du vil gå til, når du ønsker at åbne / genåbne en ABACUS Enterprise-fil.

Kassen en eksisterende Enterprise fil

Hvis nogen allerede har skabt en ny Enterprise fil, kan 'kassen' denne fil, der henter en lokal kopi og opretter de nødvendige filer så ABACUS anerkender dette som en Enterprise fil, du. Dialogen ligner Dialog Ny Enterprise fil. Indtast lageret URL (undermapper kan indgå i URL), vælge den ønskede fil, og klik på OK. Med forbehold for noten under than fil vil derefter blive åbnet.

Note

Du kan blive bedt om at logge ind på serveren, i hvilket tilfælde den person, der er styring af serverkan give serveren brugernavn og password. Også de login-oplysninger til nogen servere, som du har tilsluttet gemmes, så hvis en eller anden grund, de har brug for at blive ryddet dette kan gøres via Tools | Optionerog derefter på den Generel fane ved at klikke Nulstil Subversion Gemt Loginog vælge serveren fra drop-down listen og klikke Klar loginog vælge OK i dialogboksen, der vises.

Enterprise Fil Forskelle

Når du har oprettet en Enterprise-fil (enten en ny, eller via 'kassen' på en fil oprettet af en anden), vil der blive oprettet en mappe til filen, og det vil almindeligvis indeholder disse 3 hovedtyper af filer:

· '.abacus' Fil- Det er den ABACUS selve filen. Ændringer du laver lokalt er ikke straks gemmes i denne fil, er den kun skrives til, når du begår. Denne fil er en "normal" ABACUS fil, kan det gives til ikke-EE-brugeresom en enkeltstående projekt (uden .log fil)Eller anvendes som udgangspunkt for en ny EE fil.

· '.changes' Fil- De lokale (uudnyttede) ændringer i filen. Hvis der mangler denne fil, betyder, at der ikke er nogen lokale ændringer.

· '.log' Fil- Denne fil har kun de ændringer, der blev foretaget af den sidste bruger (indholdet af brugerens .changes fil, når de har begået).

Note

Der er forskellige andre filer, der kan oprettes under opdateringen og begår processer, nemlig; ‘.changesbefore' fil- Denne fil er en kopi af den .changes fil efter en opdatering er udført, og bruges til automatisk at afstemme eventuelle ID-konflikter mellem opdateringen og enhver lokal (uforpligtede) ændringer, før begå; ‘.backup' fil- Denne fil er en kopi af den .changes fil, før en bruger sparer mere lokale (uudnyttede) ændringer af .changes fil; og ‘.fejl' fil- Denne fil er en kopi af de .changes fil, hvis der var nogen spørgsmål, der forårsagede ABACUS at undlade at åbne .abacus filen og brugeren valgte at vende tilbage deres ændringer.Disse filer kan ignoreres.

Åbning af en fil

Vil åbne en fil, behøver du kun at gå til, hvor du har valgt at gemme arbejdskopien, og åbn ABACUS fil, der er gemt der. Når ABACUS ser, at der er en .logfil (og måske en .ændringer fil, hvis du har lavet ændringer), det vil behandle filen som en Enterprise-fil.

Opdatering af en fil

Udførelse af enn 'Opdater' vil kontrollere, om en nyere version af en fil er placeret på serveren. Hvis der er, vil det lukke din aktuelle fil, opdatere til den nyere fil fra serveren, og hente nogle midlertidige filer, som har et nummer som en forlængelse - fx »Demo.125«. Disse filer er de ældre versioner af .log fil, og bruges til at bestemme, hvilke ændringer der er foretaget til en fil, siden du sidst opdateret den. Dette er nødvendigt for at afsløre eventuelle konflikter, der kan være sket, så du kan løse dem.

Hvis under opdateringsprocessen enhver konflikterblev fundet, Skal du løse dem, før du kan åbne din fil igen (du kan annullere men vil du blive bedt om at løse konflikterne igennæste gang du åbner din fil).

Lagring af en fil

Når du gemmer en fil, dette tilføjer eventuelle ændringer, du har foretaget i .changes fil. Det gør ikkeændre .abacus filen på dette tidspunkt - kun når filen er forpligtet til serveren vil det blive skrevet i (eller når du modtager en opdatering fra serveren).

Hvor er "Gem som"?

Der er ingen begrebet Gem Som for Enterprise-filer. Du kan dog kopiere din arbejdskopi .abacus fil, holde sig for øje, at det ikke behøver dine lokale ændringer i det.

Løse konflikter

Hvis andre brugere har engagerede ændringer af filen i en lignende del af filen for dig, kan der være nogle konflikter mellem deres ændringer og dine. For eksempel kan en anden bruger sletter en komponent, at du havde opdatere en ejendom på. Du er nødt til enten fortryde deres ændring (hvis du er sikker på, at deres skalikke være sket), eller kassere din ændring (du kan så gå tilbage i filen og omgøre din ændring).

Konkret er der 4 klasser af konflikter, der kan opstå;

1. Slet - Når en bruger sletter et objekt, en anden bruger ændringer. F.eks. Bruger A slettet en komponent, men bruger B ændret komponentens navn eller tilsluttet det eller tilføjet et barn komponent til det osv

2. Attribut - Når to brugere både ændre nøjagtig samme "attribut" af et objekt. F.eks. Både Bruger A og Bruger B ændret en komponent navn eller dens beskrivelse eller værdien af ​​en af ​​sine ejendomme mv

3. Reference - Når to brugere ændrer nøjagtig samme 'henvisning' et objekt har til et andet objekt. F.eks. Både Bruger A og Bruger B ændret en komponents type eller kilden / vasken komponent knyttet til en forbindelse eller den linkede synspunkt for et diagram etc.

4. Samling - Når to brugere ændre en »indsamling« for et objekt. F.eks. Både Bruger A og Bruger B flyttet en komponent fra den ene forælder til den anden eller re-bestilt en samling af børns komponenter.

Note

Forskellige ligegyldige konflikter automatisk løses af ABACUS at minimere overhead på brugere.For eksempel eventuelle modstridende pan-zoom indstillinger for diagrammer er løst til at holde de nyeste pan-zoom-indstillinger.

Begå Ændringer

Når du vælger at begå dine ændringer, den ABACUS filen fra serveren åbnes, din lokal ændringer udføresimod det, og så din lokale .abacus fil overskrives med en, der har dine ændringer i det. Dine ændringer fil derefter overskriver den .log fil, og både .abacus filen og .log fil bliver sendt til serveren.Hvis begå lykkes en Commit dialog besked som vist nedenfor er tilvejebragt for at indtaste en besked med at begå.

Visning af en Log over ændringer

Til se en log over de ændringer af en Enterprise projekt, vælge Fil| Udsigt Log...

Maksimum Log Angivelser: Denne vil default til de sidste 10 poster, men yderligere poster kan hentes ved at ændre værdien og klikke på Hent knap.

Revision: The Revision kolonne viser tallene revision engageret i Enterprise-serveren, som standard, i omvendt kronologisk rækkefølge.

Note

Tallene revision må ikke være kontinuerlig, da det kun ABACUS begår vil blive opført mens den samme Subversion repository kan anvendes til andre ABACUS projekter og / eller andre udgave kontrol applikationer.

Dato: ThK Dato kolonne viser den dato, at revisionen var forpligtet til Enterprise-serveren.

Tid: The Time kolonne viser det tidspunkt på dagen (i 24-timers format), at revisionen var forpligtet til Enterprise-serveren.

Forfatter: The Forfatter kolonne viser Microsoft Windows-login-navn til den bruger, der udførte den commit efterfulgt af deres ABACUS brugernavn Eller 'Anonym', hvis brugeren ikke er godkendt, og anonyme brugere fik adgang til Enterprise-projektet på tidspunktet for den begå.

Log Message: The Log Message kolonne viser den begå budskab, der blev leveret med revisionen som pr dialogboksen vist ovenfor.

Hent revision XX som stand-alone ABACUS fil: Hvis du vælger en given revision i tabellen, og klik derefter på knappen Download vil du være i stand til at udtrække den valgte ABACUS projektet revision fra serveren og gemme det som en lokal / enkeltstående ABACUS projekt.

Note

At rulle tilbage til en tidligere revision se denne Skønnede udvikling samfund artiklen .

(Admin) Hent XML Log fil til revision XX: Brugere med ABACUS Administrator kapacitet kan vælge en given revision i tabellen, og klik derefter på knappen Hent for at udtrække den valgte ABACUS projektet begå logfil fra serveren og gemme det som en .xml-fil.

Visning af et revisionsspor af ændringer

Til se et revisionsspor af ændringer til en given element (dvs. komponent, tilslutning, visning, børn osv) af en Enterprise projekt, højreklikke på elementet og vælge Revisionsspor...Indstil Fra og Til Revision rækkevidde og klik Søge.

Note

Når et element slettes fra det projekt, du ikke længere kunne få adgang til specifikke revisionsspor oplysninger om dette element. Du kan dog stadig få adgang til 'forælder' komponent (for eksempel) og se revisionsspor oplysninger om sletningen (i dette tilfælde notering ID element, der blev slettet).Desuden Komponent / Connection vedhæftede fil er en "egenskab" af forbindelserne, så skiftende en vedhæftet komponent via Stifinder vindue eller på diagrammer vil vise i revisionssporet for en forbindelse ikke komponenten, og slette en forbindelse og skabe en ny forbindelse (som sker der, hvis du højreklikker på 'Unattach' og derefter 'Opret forbindelse ... «i kataloger) vil resultere i tab af revisionsspor oplysninger for den oprindelige komponent - tilknytning tilslutning helt.

Note

Som standard revisionssporet rekursivt vil kontrollere for ændringer i nogen af ​​de børn af den valgte element. Dette kan resultere i lange svartider og følgelig revisionssporet kan begrænses til selve elementet ved at fravælge Rekursiv indstilling under den Audit Valgmulighederknap på værktøjslinjen 'tandhjul' i dialogboksen Audit Trail.

Fra Revision: Denne vil default til den første / ældste revision til rådighed for projektet på Enterprise-serveren.

Til Revision: Denne vil som standard til det sidste / seneste revision til rådighed for projektet på Enterprise-serveren.

Note

Efter indstilling Fra og Til revision range klikke på knappen Søg for at hente nogen specifikke ændringer i den valgte element.

Revision: The Revision kolonne viser tallene revision engageret i Enterprise-serveren, som standard, i frem kronologisk rækkefølge.

Note

Er usandsynligt, at være kontinuerlig Numrene revision, da kun de ændringer der er relevante for det valgte element vises, og kun ABACUS begår vil blive opført mens den samme Subversion repository kan anvendes til andre ABACUS projekter og / eller versionen kontrol applikationer.

Dato: ThK Dato kolonne viser den dato, som brugeren handling blev foretaget.

Note

Den viste dato er brugerens handling dato, ikke den dato, hvor revisionen blev engageret i Enterprise-serveren. Derfor kan den dato forud for tilsvarende revision commit dato vist med den File | Se Log ... kommando.

Tid: The Time kolonne viser det tidspunkt på dagen (i 24-timers format), som brugeren handling blev foretaget.

Note

Klokkeslættet er brugerens handling tid, ikke det tidspunkt, hvor revisionen blev begået til Enterprise-serveren. Følgelig tiden vil sandsynligvis forud for de tilsvarende revision afsætte tid vist med File | Se Log ... kommando.

Forfatter: The Forfatter kolonne viser den bruger, der udførte handlingen Microsoft Windows-login-navn efterfulgt af deres ABACUS brugernavn Eller 'Anonym', hvis brugeren ikke er godkendt, og anonyme brugere fik adgang til Enterprise-projektet på tidspunktet for brugerens handling.

Note

Forfatteren er anført i Audit Trail dialogen ikke nødvendigvis matche forfatteren angivet i dialogboksen View Log ovenfor for den samme revision. Dette skyldes, at View Log dialogen lister den indloggede bruger på tidspunktet for den forpligte mens revisionssporet dialogen lister den indloggede bruger på tidspunktet for brugerens handling, og det er muligt at have én bruger foretage ændringer og sende deres. ændringer fil til en anden bruger til at begå - som det er tilfældet, når en ekstern bruger (f.eks skønnede udvikling) er at arbejde på en EE projekt.

Detaljer: The Detaljer kolonne viser de nøjagtige oplysninger om brugerens aktion som registreres på Enterprise-serveren.

Tip

Det er nyttigt at gruppe af revisionen kolonnen (som vist i dialogen ovenfor) og / eller kolonnen Bruger Handling til let klassificere ændringer i elementet af interesse.

Brug af scripting med Enterprise-filer

Hvis du bruger scripting med Enterprise-filer, skal du være opmærksom på, hvordan man korrekt slette et objekt fra modellen. Generelt, når du sletter et objekt, vil du kalde .Delete () metode på det, i stedet for kun at fjerne det fra dets moderselskab.

F.eks. hvis du havde COMP1 som moderselskab for Comp2 og du ønsker at slette Comp2 i dit script, skal du ringe comp2.Delete (), snarere end comp1.Components.Remove (Comp2).

Du må bruge fjerne, hvis du ønsker at tilføje Comp2 objekt til et andet sted inden for arkitektur, men det bør ikke anvendes, hvis det er hensigten at slette objektet.

Der er en undtagelse til denne, for når du ønsker at fjerne et objekt, "lever" andre steder i modellen. Når du ønsker at fjerne en standard eksempel fra en arkitektur / komponent / tilslutning, så ville du gøre det ved at fjerne det fra eksempelvis standard samling - arch1.Implementeringer.Remove (Imp) - fordi slette det ville fjerne det fra alle forekomster.

Korrekt brug af Slet i scripts er vigtigt, fordi hvis en genstand fjernes fra objectmodel og ikke re-added, så vil det ikke være i stand til at være placeret, men da det ikke var specifikt "slettet", Conflict Detection og Resolution vil ikke korrekt at detektere en konflikt, hvis en anden bruger var at forsøge at bruge dette objekt i nogen af ​​deres ændringer, og slutresultatet vil være en beskadiget sæt af ændringer for den pågældende bruger.

Se også

Hvordan er en arkitektur repræsenteret i ABACUS?


Arbejde med Tilladelser

Navigation: Administration>

Arbejde med Tilladelser

Send kommentarer om dette emne.

ABACUS projekter kan have rollebaserettilladelser sat for hvert element i lageret. Specifikt finkornet Create-Read-Update-DDELETE (CRUD) Tilladelser kan indstilles på "objekt" (dvs. komponent eller forbindelse), se og attribut (dvs. ejendomsret) niveauer.

Oversigt

Når man arbejder med det ABACUS Enterprise Server , ABACUS giver finkornet, CRUD tilladelser rollebaserede at kontrollere adgangen af ​​flere brugere til lageret.

Note

For at konfigurere tilladelserne i et ABACUS projekt brugerlicens brug Administrator kapacitet. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

Kan indstille tilladelser for arkitekturer, komponent- og forbindelsestyper, ejendomme (via deres typer), skabeloner, synspunkter og diagrammer, kataloger, matricer, diagrammer og 3Dvisninger. Når tilladelserne er sat for en komponent eller forbindelsestype alle forekomster af denne type i enhver arkitekturer i projektet "arve" disse tilladelser. Ligeledes når en tilladelse er sat for en egenskab af en komponent eller forbindelsestype, den givne ejendom på komponenten eller tilslutning forekomster i enhver arkitekturer i projektet "arve" disse tilladelser. Derfor vil visse tilladelser blive anvendt til de synspunkter, som eksisterer disse elementer. Når tilladelserne er sat til et diagram, udsigten og / eller indholdet af selve visningen har forskellige tilladelser anvendt på den.

Note

Som standard er sat ingen tilladelser for de elementer inden for en ABACUS projekt. Det er alle elementer er Createable, læsbare, Kan opdateres og Deleteable af alle brugere. På denne måde bør kun overvejes tilladelser for en given element i lageret, når en bestemt tilladelse er at være begrænsetfor en bestemt brugergruppe. For eksempel, hvis tilladelser for en given brugergruppe blev tilsat til et objekt (f.eks en komponent type), men venstre med alle tilladelser aktiveret, så er funktionelt det samme, som hvis brugergruppe ikke var tilføjet til objektet.

Tilladelser ikke kanindstilles til specifikke tilfælde af en arkitekturens elementer. For eksempel kan du ikke foretage opdateres én Ansøgning komponent endnu en ikke. For effektivt at nå disse "domæne specifikke" tilladelser kan dog administratoren oprette særlige elementtyper for de givne domæner, f.eks komponenttyper 'Ansøgning - CRM-domæne "og" Ansøgning - HR-domæne ", og derefter indstille tilladelserne for hver type i overensstemmelse hermed. Du kan lave specifikke Gruppering typer for hvert domæne og derefter fjerne opdateringen tilladelse for domænet-specifikke gruppe type og dette vil begrænse kreationer indenfor og sletninger fra Gruppering men ikke opdatere af børnene. Selvfølgelig, hvis det domæne-specifikke Gruppering var skjult ved at fjerne læsetilladelse så børnene ville være skjult og dermed ikke-opdateres. Alternativt, hvis synspunkter (i stedet for explorer) anvendes primært til at styre / se din repository, kunne etableres en given visning for hvert domæne, og så administratoren kan indstille tilladelser for hver visning i overensstemmelse hermed.

Administration af brugere og grupper

Tilladelser er defineret på rolle eller gruppeniveau, i modsætning til den individuelle brugerniveau, så mens medlemskab af grupperne kan ændre sig, tilladelser kan forblive fast. Selvfølgelig, hvis du ønsker en bestemt bruger tilladelse derefter blot gøre dem en gruppe, eller mere præcist oprette en gruppe med den pågældende bruger som det eneste medlem.

Det skal bemærkes, at grupper er atomar, Der er de ikke kan arve tilladelser eller brugere fra den ene til den anden, og hvis en bruger tilhører flere grupper så de mest 'pessimistiske' gruppe tilladelse forrang fra sag til sag for hver enkelt tilladelse (dvs. Opret -Læs-opdatering-Delete). For eksempel, hvis den samme bruger er medlem af gruppe A og gruppe B, og Gruppe A har netop Create-Læs tilladelse til Application komponenttyper, mens gruppe B har netop Læs-Opdatering tilladelse til Application komponenttyper så brugeren kun har læst tilladelse til Ansøgning komponenteksempler.

Desuden som standard, anonyme brugere(der er brugere, som ikke er blevet defineret, eller som ikke har logget ind) har fuld adgangtil projektet. Dette er for at sikre, at adgangen er tilgængelig i en indledende konfiguration. At blokere adgangen fra anonyme brugere simpelthen fjerne markeringen i "Tillad anonym bruger fuld adgang til fil 'i Administrer brugere / grupper viste dialog nedenfor. Når ukontrollerede anonyme brugere vil kun kunne se Standarder del af ethvert projekt.

Endelig er, om den "Brug Windows Brugernavn login 'er afkrydset brugernavn autentificering udføres mod Windows-brugernavn Logins på hver brugers maskine mod brugernavnet er angivet som pr nedenfor. Det er, hvis Windows Brugernavn Log ind for en given brugers maskine eksisterer som et gyldigt brugernavn så kræves ingen adgangskode, og brugeren bliver automatisk godkendt. Bemærk: dette effektivt tillader brugen af ​​Windows Active Directory (AD) godkendelse.

Note

Eftersom tilladelser er kun defineret, når de skal tages væk (begrænset) fra en bruger, enhver bruger, der ikke er medlem af en gruppe, eller en hvilken som helst gruppe, der ikke har nogen tilladelser defineret for den mod genstande, vil have fuld adgang til projektet.

Brugere og brugergrupper

For at oprette en ny bruger

1. Vælge Fil| Administrer brugere / grupper

Note

Hvis du ikke kan se Administrer brugere / grupper menupunkt, så du ikke har administrator kapacitet. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

2. I den dialogboks, der vises vælg Tilføj brugerknap og indtaste et brugernavn og en adgangskode i Opret ny dialogboksen User. Bemærk: Brugernavne og adgangskoder er store og små bogstaver.

Note

Hvis 'Brug Windows Brugernavn login' er afkrydset, som beskrevet ovenfor, så kan indtastes en dummy adgangskode som autentifikation vil blive udført i overensstemmelse med brugerens Window s Brugernavn eneste Login.

2. Som standard vil du se, at den Brugere kan ændre deres egen adgangskode. Hvis det er nødvendigt, kan ABACUS Administrator fjern de evne for brugerne at sætte deres egen adgangskode ved fjerne markeringenafkrydsningsfelterne.

Note

Hvis brugerne kan ændre deres egen adgangskode, de vil have en File | Skift kodeord...menupunkt til at gøre det.Vær også opmærksom på, at hvis flere mennesker bruger det samme brugernavn så en bruger kan ændre password, således at ingen andre mennesker kan logge ind bagefter. Følgelig anbefales det praksis at have en enkelt brugernavn per faktisk person.

4. Eventuelt indtaste e-mail-adresse, Beliggenhed og telefonnummer for brugerne til senere brug.

5. Klik på Okayknappen i Opret ny dialogboksen User.

6. Klik på Okay knap.

Note

Når du har oprettet din første bruger bør du overveje at blokere adgang anonyme brugere ved at fjerne markeringen af ​​"Tillad anonym bruger fuld adgang til fil" valgmulighed i Administrer Brugere / dialogen Grupper.Også, når en bruger er blevet oprettet (og hvis en Enterprise projekt, ændringen forpligtet til serveren), næste gang projektet åbnes brugere vil blive bedt om at Login for autentificeret adgangsom pr dialogboksen vist nedenfor. Hvis Log automatisk med disse oplysningerer afkrydset derefter / adgangskode kombination brugernavnet vil blive husket for projektet og anvendt hver gang på åbning. At rydde gemte login vælge File | Ryd gemte loginefter åbning, og vil du blive bedt om at logge ind igen, næste gang du åbner projektet.

Log på

For at slette en eksisterende bruger

1. Vælge Fil| Administrer brugere / grupper

2. I den dialogboks, der vises vælg User navn i panelet Brugere, som du ønsker at slette, og vælg derefter Slet bruger knap.

3. Klik på Okay knap.

Hvis du vil oprette en ny gruppe

1. Vælge Fil| Administrer brugere / grupper

2. I den dialogboks, der vises vælg Tilføj gruppeknappen og indtast et gruppenavn i panelet Grupper.

Note

Gruppe skal være entydige.

3. Klik på Okay knap.

Til kopiere en eksisterende Gruppe

1. Vælge Fil| Administrer brugere / grupper

2. I den dialogboks, der vises vælg Kopi Gruppe knap.

Note

En to eksemplarer gruppe vil blive oprettet med præfikset "Kopi af".Som standard alle tilladelser fra den kopierede gruppe vil blive kopieret til "Kopi af" gruppe, herunder enhver bruger opgave.

3. Omdøbe "Kopi af" gruppe efter behov ved hjælp af Rediger gruppeeller langsom dobbeltklik.

For at slette en eksisterende gruppe

1. Vælge Fil| Administrer brugere / grupper

2. I den dialogboks, der vises vælg koncernen navn i grupper panel, du ønsker at slette, og vælg derefter Slet gruppe knap.

Note

Enhver bruger opgaver for koncernen vil også blive fjernet.

3. Klik på Okay knap.

For at tildele en bruger til en gruppe

1. Vælge Fil| Administrer brugere / grupper

2. I den dialogboks, der vises vælg User navn i panelet Brugere, som du vil tildele en gruppe og Træk og slipdet på koncernens navn i grupper panel, du ønsker at tildele den til.

3. Klik på Okay knap.

Note

Den gruppe (r), som en bruger er tildelt, er vist ved at udvide Brugernavn i panelet Brugereog brugerne, der er tildelt en gruppe, vises ved at udvide gruppen i panelet Grupper. For eksempel i skærmaftrykket ovenfor, er "AS1-Aus" bruger tildelt tre (3) grupper, nemlig; "App Support Team 1", "Actual" og "Australia".

For at fjerne tilknytningen en bruger fra en gruppe

1. Vælge Fil| Administrer brugere / grupper

2. I den dialogboks, der vises udvide koncernens navn, der indeholder brugerens opgave, du ønsker at fjerne tilknytningen og vælg brugernavnet.

3. Klik på Unassign Bruger knap.

4. Klik på Okay knap.

For at importere brugere og / eller grupper (og eventuelle matchende Tilladelser)

1. Vælge Fil| Administrer brugere / grupper

2. Klik på Importere knap.

3. I den viste dialog Gennemsetil og åbn ABACUS projekt, der indeholder Brugere og / eller grupper (og tilladelser), du ønsker at importere til det aktuelle projekt, og klik Åben. Brugere og grupper vil blive importeret, og en dialogboks Import Resultater vises opsummerer import af brugere og / eller grupper. Klik på Okay knap.

Note

Hvis de importerede brugere eller grupper allerede eksisterede i det aktuelle projekt, så vil de blive lagt sammen med de eksisterende brugere eller grupper.

4. Klik på Okayknappen tilbage i de vigtigste Administrer brugere / dialogen Grupper.

5. Hvis der er nogen matchende Typer, Synspunkter, Skabeloner eller arkitekturer mellem det aktuelle projekt og ABACUS projekt du importerer fra, komplet med tilladelser, som ikke allerede findes i det aktuelle projekt, er tilladelserne importeres, og en anden dialogboks Import Results vises opsummerer importen. Klik på Okay knap.

Note

Tilladelser er kun tilføjes eksisterende typer (og deres egenskaber), Synspunkter, Skabeloner eller arkitekturer for grupper, hvor tilladelserne ikke allerede eksisterer for koncernen. Enten fordi koncernen er ny eller koncernen allerede eksisterede i det aktuelle projekt, men ingen tilladelser var blevet tildelt for denne gruppe til denne post. Der er ingen "sammensmeltning" af tilladelser til at matche poster, hvor tilladelser allerede eksisterede for koncernen i det aktuelle projekt.

Tilladelser indstilling

Kan indstille tilladelser for arkitekturer, komponent- og forbindelsestyper, ejendomme (via deres typer), skabeloner, synspunkter og diagrammer, kataloger, matricer, diagrammer etd 3Dvisninger. Når tilladelserne er sat for en komponent eller forbindelsestype alle forekomster af denne type i enhver arkitekturer i projektet "arve" disse tilladelser. Ligeledes når en tilladelse er sat for en egenskab af en komponent eller forbindelsestype, den givne ejendom på komponenten eller tilslutning forekomster i enhver arkitekturer i projektet "arve" disse tilladelser. Derfor vil visse tilladelser blive anvendt til de synspunkter, som eksisterer disse elementer. Når tilladelserne er sat til et diagram, udsigten og / eller indholdet af selve visningen har forskellige tilladelser anvendt på den.

Tilladelser Ledelse

Sådan indstiller tilladelse til en komponent (eller tilslutning) Type

1. Udvid Typergren af ​​træet.

2. Udvid Komponent (eller forbindelse) Typergren af ​​træet.

3. Udvide Grupperhvor det er nødvendigt.

4. Højreklik på den Komponent (eller tilslutning) Typedu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

5. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

6. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

Note

Opret tilladelse regulerer også, når du kan kopiere et element. Derfor at være i stand til at kopiere et element kræver Opret tilladelse for alle sine børn (siden at kopiere elementet betyder at kopiere alt under det). Fjernelse Opdater tilladelse fra et element fjerner evnen til at ændre typen selv, selvom brugeren har Designer tilføjelse, og det fjerner også Opdatering tilladelse til alle dets egenskaber. En forælder element skal have tilladelse til at opdater kunne Opret eventuelle børn elementer eller Slet sin eksisterende børn elementer. Slet tilladelse til et element kræver også Slet tilladelse for alle sine børn. Slet tilladelse til komponenter kræver også Opdatering tilladelse af alle de vedhæftede tilslutninger.Og endelig fjernelse Delete tilladelse fra et element fjerner muligheden for at slette typen selv, selvom brugeren har Designer tilføjelse.

7. Klik på Okay knap.

At der er en tilladelse til en gruppe af komponent (eller tilslutning) Typer

1. Udvid Typergren af ​​træet.

2. Udvid Komponent (eller forbindelse) Typergren af ​​træet.

3. Højreklik på den Gruppeder indeholder den komponent (eller forbindelse) Typer som du ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

6. Klik på Okay knap.

7. I den dialogboks, der vises ved at klikke på Ja knap.

Sådan indstiller tilladelse til en ejendom

1. Udvid Typergren af ​​træet.

2. Udvid Komponent (eller forbindelse) Typergren af ​​træet.

3. Udvide Grupperhvor det er nødvendigt.

4. Vælg den komponent (eller tilslutning) Indtast som indeholder den ejendom, du ønsker at de indstillede tilladelser for.

5. I vinduet Egenskaber Højreklik på den Ejendomdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

6. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

7. Som standard vil du se at tilladelserne Læs og Opdatering er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

Note

Egenskaber, der har haft Opdatering tilladelse fjernet, er vist i kursivi vinduet Egenskaberog deres værdier kan ikke opdateres af denne rolle. Også, evnen til at ændre oplysninger om en ejendom (f.eks navn, enheder osv) kræver både Update tilladelse på ejendommen og Designeren add-on.

8. Klik på Okay knap.

Sådan indstiller tilladelse til en skabelon

1. Udvid Skabelonergren af ​​træet.

2. Gå til den Skabelonat du er interesseret i.

3. Højreklik på den Skabelondu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Læs tilladelsen er til rådighed. Fjern tilladelse fra fjerne markeringenafkrydsningsfeltet.

6. Klik på Okay knap.

Sådan indstiller tilladelse til et Viewpoint

1. Udvid Synspunktergren af ​​træet.

2. Udvide Grupperhvor det er nødvendigt.

3. Højreklik på den Udsigtspunktdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

6. Klik på Okay knap.

For at indstille tilladelsen for et Arkitektur

1. Udvid Arkitekturergren af ​​træet.

2. Udvid til Arkitekturat du er interesseret i.

3. Højreklik på den Arkitekturdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Læs tilladelsen er til rådighed. Fjern tilladelse fra fjerne markeringenafkrydsningsfeltet.

6. Klik på Okay knap.

Sådan indstiller tilladelse til et Katalog

1. Udvid Katalogergren af ​​arkitekturen, du er interesseret i.

2. Udvide Grupperhvor det er nødvendigt.

3. Højreklik på den Katalogdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

6. Klik på Okay knap.

Sådan indstiller tilladelse til et Matrix

1. Udvid Matricergren af ​​arkitekturen, du er interesseret i.

2. Udvide Grupperhvor det er nødvendigt.

3. Højreklik på den Matrixdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

6. Klik på Okay knap.

Sådan indstiller tilladelse til et diagram

1. Udvid Diagrammergren af ​​arkitekturen, du er interesseret i.

2. Udvide Grupperhvor det er nødvendigt.

3. Højreklik på den Diagramdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

Note

Mens du kan angive tilladelser for CRUD direkte for et diagram, skal det bemærkes, at tilladelserne af elementerne på diagrammet kan påvirke tilladelserne for selve visningen. For eksempel, hvis der er bare ét element på den opfattelse, at har haft sin Læs eller opdatering tilladelse fjernes derefter diagrammet vil have sin Opdater tilladelse fjernet. Dette er fordi; a) elementerne på den opfattelse, at har haft deres Læs tilladelse fjernet, vil ikke blive vist på visningen forlader 'hvide rum', hvor du ellers placere nogle nye elementer, hvis udsigten var opdateres, og b) de elementer på den opfattelse, at har haft deres Opdatering tilladelse fjernet kunne så have andre elementer faldet på dem til at blive børn, hvis udsigten var opdateres. Også Opret og opdatering tilladelse til et diagram, kræver, at alle elementerne på visningen har Læs tilladelse og komponenterne har Update tilladelse (dette er fordi at flytte en komponent til en anden komponent, skal du være i stand til at opdatere det, da det vil blive til et barn).

6. Klik på Okay knap.

Sådan indstiller tilladelse til en 3D-visning

1. Udvid 3D Viewsgren af ​​arkitekturen, du er interesseret i.

2. Udvide Grupperhvor det er nødvendigt.

3. Højreklik på den 3D-visningdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

6. Klik på Okay knap.

Sådan indstiller tilladelse til et Diagram

1. Udvid Diagrammergren af ​​arkitekturen, du er interesseret i.

2. Udvide Grupperhvor det er nødvendigt.

3. Højreklik på den Diagramdu ønsker at indstille tilladelser for og vælg Rediger tilladelser.

4. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

5. Som standard vil du se, at Oprette, Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

6. Klik på Okay knap.

Se også

Hvordan er en arkitektur repræsenteret i ABACUS?


Arbejde med dashboards

Navigation: Administration>

Arbejde med dashboards

Send kommentarer om dette emne.

ABACUS projekter kan have en hvilken som helst konfiguration af synspunkter (f.eks diagrammer, Diagrammer osv) gemt som et dashboard, og disse gemte dashboards kan være indstillet som standard starter 'skærm' på at åbne et projekt og / eller tilknyttet en bestemt brugergruppe og præsenteret for medlemmerne af denne brugergruppe, når de logger ind på et ABACUS projekt.

Note

For at konfigurere dashboards i et ABACUS projekt brugerlicens brug Administrator kapacitet. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

Visning af dashboards

Et eksempel Application Portfolio Management (APM) instrumentbrættet

Sådan får du vist en gemt Dashboard

1. Vælge Udsigt| Dashboards

2. Vælg en gemt dashboard fra listen over tilgængelige dashboards.

Note

Når det er valgt ABACUS vil bygge de synspunkter, der er nødvendige for instrumentbrættet, og det kan tage et par sekunder. Vær tålmodig.

Håndtering af dashboards

Håndtering af dashboards

Hvis du vil oprette en ny Dashboard

1. Åbn de nødvendige synspunkter og arrangere og dock vinduer som påkrævet for instrumentbræt.

2. Vælge Udsigt| Dashboards| Administrer betjeningspaneler ...

Note

Hvis du ikke kan se Administrer Dashboards menupunktet så du ikke har administrator kapacitet. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support hvis du ønsker denne mulighed.

3. I den dialogboks, der vises vælg Skabeknappen og indtast Dashboard navn i dialogen Opret nyt Dashboard.

4. Klik på Okay knap.

For at slette en eksisterende Dashboard

1. Vælge Udsigt| Dashboards| Administrer betjeningspaneler ...

2. I den dialogboks, der vises vælg Dashboard du ønsker at slette fra listen, og vælg den Slet knap.

Note

Sletning af et instrumentbræt vil også slette bruger gruppe opgaver til denne instrumentbrættet.

3. Klik på Okay knap.

Hvis du vil erstatte et eksisterende Dashboard

1. Åbn de nødvendige synspunkter og arrangere og dock vinduer som påkrævet for udskiftning instrumentbræt.

2. Vælge Udsigt| Dashboards| Administrer betjeningspaneler ...

3. I den dialogboks, der vises vælg Dashboard, du ønsker at udskifte på listen, og vælg Erstatte knap.

4. Klik på Okayknappen for at anerkende Dashboard Erstattet dialogen.

Hvis du vil tildele en Dashboardsom standard Start-skærm

1. Vælge Udsigt| Dashboards| Administrer betjeningspaneler ...

2. I den dialogboks, der vises vælg Dashboard på listen, du ønsker at tildele som standard start 'skærm'og vælg Tildel ... knap.

3. I den dialogboks, der vises vælg post i User Groups kolonnen.

Note

Kun én dashboard kan tildele som starte "skærm", så re-opgave vil fjerne den opgave fra den tidligere instrumentbrættet.Desuden, hvis brugeren logger på som medlem af en brugergruppe, der har en tildelt dashboard så den tildelte instrumentbrættet vil blive åbnet i stedet for standard-projektet instrumentbræt.

4. Klik på Okay knap.

Hvis du vil tildele en brugergruppe til en Dashboard

1. Vælge Udsigt| Dashboards| Administrer betjeningspaneler ...

2. I den dialogboks, der vises vælg Dashboard på listen, du ønsker at tildele en brugergruppe til og vælg Tildel ... knap.

3. I den dialogboks, der vises vælg Bruger Gruppe (eller grupper)du vil tildele instrumentbrættet som "opstart" skærm for.

Note

Hvis den samme brugergruppe er tildelt flere dashboards så den første opgave på listen vil blive anvendt.

4. Klik på Okay knap.

For at fjerne tilknytningen en brugergruppe fra en Dashboard

1. Vælge Udsigt| Dashboards| Administrer betjeningspaneler ...

2. I den dialogboks, der vises udvide Dashboard element fra listen, du ønsker at fjerne tildelingen en brugergruppe fra.

3. Vælg User gruppe, du ønsker at fjerne tilknytningen og vælg Unassign knap.

4. Klik på Okay knap.

Tilladelser indstilling

Kan indstilles tilladelser til instrumentbrætter at give mulighed for instrumentbrættet at kunne ses, Opdaterbar og / eller deleteabletil givne brugergrupper.

Tilladelser Ledelse

Sådan indstiller tilladelse til en Dashboard

1. Vælge Udsigt| Dashboards| Administrer betjeningspaneler ...

2. I den dialogboks, der vises vælg Dashboard på listen, du ønsker at indstille tilladelser for, og vælg den Tilladelser ... knap.

3. I den viste dialog skal du klikke på Tilføje...knappen, og vælg Gruppedu ønsker at tilføje ved enten at dobbeltklikke på den eller vælge det og klikke på Okay knap.

4. Som standard vil du se, at Læs, opdatere og slette tilladelser er alle tilgængelige. Fjern tilladelserne af fjerne markeringende relevante afkrydsningsfelter.

5. Klik på Okay knap.

Se også

Tilpasning af ABACUS grænsefladen | Arbejde med Tilladelser


Registrering af ABACUS

Navigation: Reference>

Registrering af ABACUS

Send kommentarer om dette emne.

Når du først starter ABACUS (eller efter en midlertidig licens er udløbet), vil du nødt til at registrere ansøgningen mod skønnede udvikling licens server ved hjælp af en unik licensnøgle fra din lokale ABACUS administrator eller direkte fra skønnede udvikling. Hvis du ikke har en licens nøgle skal du kontakte din lokale ABACUS administrator eller Skønnede udvikling Support .

At registrere med en licensnøgle

1. Efter installationen, starte ABACUSved enten at dobbeltklikke på genvejen på skrivebordet eller fra menuen Start i Windows.

2. I registreringen dialogboks, der vises indtaste 26 tegn licensnøgleleveres af din lokale ABACUS administrator eller Skønnede udvikling support , Eller klik Gennemse ...og vælg den underskrevne .dlsc fil tilbage fra Skønnede udvikling Support som pr Bemærk ved trin 4 nedenfor. Hvis du bruger en korrekt underskrevet .dlsc fil ABACUS bør starte som pr trin 5 nedenfor.

Tip

Du kan indsætte licensnøglen i dialogen ved at kopiere den til Windows Udklipsholder og derefter vælge på baggrund af dialogen og trykke på Ctrl + V.

Dialogen Registrering

3. Klik Okayog hvis licensnøglen er en gyldigt ABACUS licensnøgleABACUS vil nu forsøge at kontakte skønnede udvikling licens-server til at godkende licensnøglen.

Note

Hvis du får en Installation Code er Ugyldigregistreringsfejl det er mest sandsynligt, at du har indtastet koden forkert. Prøv at kopiere og indsætte koden som pr Tip nævnt ovenfor.

Kontakt til skønnede udvikling License Server

4. Klik Okayog efter en kort periode ABACUS skal registrere med succes.

Vellykket Registrering

Note

Hvis du får en Kan ikke kontakte licens serverregistreringsfejl er det mest sandsynligt, at en firewall (eller andre sikkerhedsforanstaltninger) på dit netværk forhindrer adgang til skønnede udvikling licens server. Klik Okay, Gemme .dlsc filen på din lokale maskine og derefter enten e-mail til .dlsc filen til Skønnede udvikling Support og afvente yderligere instruktionereller prøv at underskrive licensfil dig selv ved hjælp af følgende webadresse - http://licensing.avolutionsoftware.com/LicenceSign/ .

Kan ikke kontakte licensserveren

Åbn Licens underskrivelsen webside

Manuel Licens underskrivelse webside

Alternativt, hvis du får Denne installation kode er brugt på flere systemer end tilladt af licensenregistreringsfejl er det sandsynligt, at din lokale maskine er blevet genopbygget, siden du sidst registrerede ABACUS, eller du forsøger at registrere med en anden brugers licens nøgle. Kontakt din lokale ABACUS administrator eller Skønnede udvikling Support .

Installation kode er allerede blevet brugt

5. Klik Okayog hvis det er registreret med succes ABACUS skal åbne med Velkomstskærm .

Se også

Skønnede udvikling Support | Hvad gør ABACUS gøre?


ABACUS Installation Forudsætninger

Navigation: Reference>

ABACUS Installation Forudsætninger

Send kommentarer om dette emne.

Oplysninger om Visio Import og Excel Import / Export

ABACUS kræver, at Microsoft Office installeres for at udføre Excel Import / Export og Visio Import operationer. Kontroller, at Microsoft Office 2003 eller nyereer installeret korrekt. Hvis du oplever yderligere problemer, kontakt Skønnede udvikling Support .

For at udføre Visio Import og Excel Import / Export operationer, ABACUS bruger Microsoft Office Primary Interop Assemblies (PIA s). ABACUS øjeblikket kommer pakket med de forsamlinger, der er nødvendige for at udføre Excel Import / Export og Visio Import.

Oplysninger om SQL Server Import

ABACUS kræver, at Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014er installeret for at starte et nyt projekt fra SQL Server. Kontroller, at Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014er installeret korrekt. Hvis du oplever yderligere problemer, kontakt Skønnede udvikling Support .

Fejl Åbning 3D Visualisering

Hvis ABACUS 3D Viewer ikke virker for dig, kan du gå glip af SlimDX DirectX Runtime (installeret som en del af den fulde ABACUS EXE installation). Dette kan downloades her . Hvis du har en 64bit version af Windows, kan du også nødt til at installere denne .

Fejl Redigering ABACUS Skik Rapporter

Redigering ABACUS 'Brugerdefineret rapporter kræver Rapportgenerator 3.0 skal installeres. ABACUS og Report Builder er bygget på Microsofts .NET Framework 4.0, og mens de begge ikke kræver Microsofts .NET Framework 3.5, har Microsoft forkert konfigureret Rapportgenerator MSI til kun fortsætte, hvis Microsofts .NET Framework 3.5 er installeret.

Derfor skønnede udvikling har en redigeret version af Rapportgenerator installation MSI-fil, som ikke kræver Microsofts .NET Framework 3.5, kan dette downloades her .

Den oprindelige Microsoft Report Builder MSI kan downloades her . Hvis du ikke allerede har Microsoft .NET Framework 3.5, som det vil kræve, kan du downloade det her . Bemærk: flere installationer, offline installation af Microsofts .NET Framework 3.5 fra her kan være mere passende.


Command Line muligheder

Navigation: Reference>

Command Line muligheder

Send kommentarer om dette emne.

Du kan udføre forskellige ABACUS operationer direkte fra kommandolinjen med den mest almindelige operation er at åbne et konkret projekt fil og udgive det til HTML.

Konkret kommandolinjen brugen Abacus er som følger;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ bruger "USER" / pass "PASS"]

Argument | Beskrivelse
ProjectFile | Den ProjectFile kan enten være et ABACUS projekt fil (.abacus), bibliotek fil (.abacuslib), XML-fil (.xml) eller MS Access DB (.mdb) og den angivne fil vil enten blive åbnet (hvis .abacus eller .abacuslib ), eller et nyt projekt oprettes (hvis .xml eller .mdb-fil).
OptionalFile | Det OptionalFile kan enten være et ABACUS script (.abacusscript, .vb eller .cs), makro (.abacusmac) eller biblioteket fil (.abacuslib), og den angivne fil vil enten blive kørt efter åbning af ProjectFile (hvis .abacusscript, .vb eller .cs eller .abacusmac) eller blot åbnet (hvis .abacuslib).
/ exitOnCompletion | Vil forlade ABACUS og om nødvendigt på Gem og begå eventuelle ændringer af de åbne .abacus projekter på færdiggørelsen af ​​enhver script eller makro. Bemærk: Dette flag er Case Sensitive så sørg for at bruge et stort O, og »C« i teksten som vist.
/ dontShowDialogs | Vil forhindre ABACUS Enterprise Edition (EE) opdatering anmeldelse dialoger fra at vise ved åbning et projekt. Bemærk: Dette flag er Case Sensitive så sørg for at bruge et stort "S" og "D" i teksten som vist.
/ bruger "USER" / pass "PASS" | Brugernavnet USER og adgangskode PASS vil blive brugt til at logge ind på projektet med, tilsidesættes alle gemte brugeroplysninger. Bemærk: Dobbelt citater skal placeres omkring brugeren og passerer flag og to dobbelte anførselstegn kan anvendes til at undslippe anførselstegn i enten brugeren eller PASS flag.

F.eks.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / bruger "Public" / pass "123456"

hvornår løbe fra den mappe, hvor de ABACUS.exe binær er placeret vilje åben Eksempel projektet og log på som bruger Offentligt med adgangskode 123456 (som beskrevet her ), Udgive det til HTML og derefter lukke projektet alle uden at vise nogen dialoger undervejs (f.eks 'Opdater Vellykket "eller" Ingen opdateringer til rådighed "for Enterprise-projekter).

F.eks.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalog Excel Import.vb"/ exitOnCompletion / dontShowDialogs

hvornår løbe fra den mappe, hvor de ABACUS.exe binær er placeret vilje åben Eksempel projektet og importere de "servere (2014 Aktuel) .xlsx" MS Excel-fil ind i "Servere" katalog af "2014 faktiske" arkitektur af projektet uden at vise nogen dialoger undervejs og derefter lukke projektet ved afslutningen. Hvis operationen gør ændringer af projektet så når du lukker ændringer gemmes lokalt, og hvis en Enterprise projekt forpligtet til Enterprise Server.

Note

Sørg for at bruge den korrekte dobbelte citat karakter som der er flere i standard ASCII tegnsæt og Windows Kommandoprompt fungerer kun korrekt med den rigtige. Den korrekte dobbelte citat tegn kode er Decimal 34 (hexadecimal 22).Dette er, hvad der bruges i eksemplet ovenfor, så er du velkommen til at copy / paste den derfra.


Titel side

ABACUS

Disclaimer

Skønnede udvikling Pty Ltd giver ingen erklæringer eller garantier med hensyn til denne vejledning, og i videst muligt omfang tilladt ved lov, udtrykkeligt begrænser sit ansvar for brud på enhver garanti, der måtte være underforstået til udskiftning af denne manual med en anden. Endvidere forbeholder skønnede udvikling Pty Ltd ret til at revidere denne publikation til enhver tid uden at pådrage sig en forpligtelse til at underrette nogen om revisionen.

Ophavsret

Copyright 2001-2015Skønnede udvikling Pty Ltd. Alle rettigheder forbeholdes.

Varemærker

Skønnede udvikling Pty Ltd har gjort alt for at levere varemærker information om firmanavne, produkter og tjenester, der nævnes i denne manual. Varemærker vist nedenfor blev afledt fra forskellige kilder.

Microsoft Windows, Access, Visio, Excel, SQL Server og Internet Explorerer varemærker tilhørende Microsoft Corporation.

Generel bemærkning:

Nogle produktnavne i denne vejledning bruges kun til identifikation og kan være varemærker tilhørende deres respektive virksomheder.

December 2015Edition til skønnede udvikling ABACUS Version 4,5.

Manuel Revision 1.0

Genereret, trykt og bundet i Australien.