Mida ABACUS teha?

Navigation: Sissejuhatus arvelaud>

Mida ABACUS teha?

Saada kommentaare selle teema.

Abiks teistes keeltes / tõlked kliki siin .

ABACUS võtab oletused välja tegelevad lahendusi, süsteemid, tarkvara, info, tehnoloogia, äri protsesside ja / või kogu ettevõtete (edaspidi ühiselt arhitektuur). See aitab teil pragmaatiliselt disaini, jälgida, simuleerimiseks, analüüsida ja visualiseerida arhitektuur modelleerides see, analüüsides seda intuitiivne viisil (nt graafikud, diagrammid ja 3D) ja seejärel hinnatakse seda vastu oma mitte-funktsionaalsed nõuded.

Märge

Mittefunktsionaalsed nõudedneed nõuded, mis ei puuduta otseselt kuidas toode toimib. Selle asemel, et nad on mures, kui hästi see töötab. Non-funktsionaalsed nõuded hõlmavad selliseid asju nagu jõudlus, avatus, evolvability, kvaliteet, mastaapsuse, moodulitest jms (mitte funktsionaalsete nõuete nagu lülitage selles valguses, kui seda nupule vajutamist). Traditsiooniliselt mitte-funktsionaalsed nõuded on raske - kui mitte võimatu - mõõta. Tegelikult ABACUS on ainus toode, mida saab objektiivselt ja koguseliselt mõõta esimese kolme - etendus, avatusJa evolvability.

Lihtsamalt öeldes, kui sisestate arhitektuuri ja mida on vaja seda teha. ABACUS siis ütleb teile, kui ta teeb vastavalt vajadusele ning märgib võimalikud puudused ja lüngad.

ABACUS tugineb üle 20 aastane süsteemid teadus- ja palju aastaid loodud süsteemide teooria. See annab sulle mõõdetavad, usaldusväärne, objektiivne vastuseid, nii et sa ei tuginedes subjektiivse hinnangu.

ABACUS tähistab Architecture-Based Analysis, Communication ja UMõistminekohta Systems. See võib aidata teil mõne suuremahulise arhitektuuri, kuid see on tavaliselt kasutatakse nelja (4) asjad:

· Arenevpraeguse arhitektuuri. Näiteks, kui teie olemasoleva arhitektuuri puudub tulemuslikkuse Abacus visualiseerida arhitektuuri teile, probleemide määratlemine (kitsaskohti, jne), siis ütlen teile täpseltkuidas parandada arhitektuuri.

· ProjekteerimineUue arhitektuuri. Näiteks, kui teil on vaja täiesti uut arhitektuuri ja sa projekteerimisel ise Abacus ütlen teile täpseltmillistest osadest, mida vajate ja kuidas neid ühendada.

· OstmineUue arhitektuuri. Näiteks, kui olete helistanud pakkumiste kohta disaini uue arhitektuuri, ja sa oled vahel valida kolme kujunduse Abacus ütlen teile täpseltmillest üks sobib teie vajadustele kõige paremini.

· ÜhendadesPraegused arhitektuuri. Näiteks, kui teil on vaja ühendada kaks või enam eraldi arhitektuur, ABACUS aitab sul.

Vaata ka

Kuidas sa seda (ülevaade) | Mis on arhitektuur? | Kuidas arhitektuuri esindatud ABACUS?

© 2001-2015 Avolution Inc Kõik õigused reserveeritud.


Kuidas kasutada ABACUS (ülevaade)

Navigation: Sissejuhatus arvelaud>

Kuidas kasutada ABACUS (ülevaade)

Saada kommentaare selle teema.

See teema pakub põhi ülevaate ülesanded koos kasutades ABACUS.

Järgnev skeem näitab arhitektuuril põhinevate analüüsi käigus, et ABACUS ette areneb praegune arhitektuuri uue või sihtmärgi arhitektuuri.

Arvelaud Process

Et kasutada ABACUS:

1. Audit - Enne kui kasutada ABACUS, peate koguda kõik andmed, mida on umbes arhitektuuri ning selle nõuded.

· Arhitektuur - Nimetage potentsiaali komponendid arhitektuuri ja kuidas nad suhtlevad. Seal peaks olema vaid mõni komponendid kõrgeimal tasandil. Neid nimetatakse "olulised koostisosad". Isegi kõige keerulisem arhitektuur peaks olema vähem kui 10 olulist komponenti. näiteks Olulisi komponente kindlustusselts arhitektuuri võib olla poliitika, kviitungid, nõuded ja maksed.

· Nõuded- Sa pead teadma, mida oodatakse arhitektuuri, et teha kindlaks, kas see on rahuldav. näiteks Tehingute arv tunnis.

· Kust seda leida? - See teave võib pärineda nõuete kirjeldused, disain dokumendid, intervjuud sidusrühmadega kasutusele kood jms Põhimõtteliselt materjali, mis on saadaval pakub ABACUS teavet arhitektuuri.

2. Rahvastama -Kasutage arvelaud modelleerida oma arhitektuuri ja täpsustada nõuded arhitektuuri saab mõõta.

· Arhitektuur - ABACUS hakkate läbi tühja arhitektuuri - sa pead asustamaseda. See tähendab sisenemist kõik arhitektuuri andmed, mida kogutakse üle. Võite asustada oma arhitektuuri käsitsi (kasutades paremklõpsake menüü), või saate asustada see automaatselt (Microsoft Visio, Excel, Access jne). Tavaliselt kõige ülemisele tasemele (rohkem abstraktne) arhitektuur on asustatud käsitsi ja madalam (konkreetsemad) on asustatud automaatselt.

· Nõuded - Kui lisate oma komponente ja ühendusi, saab määrata nende omadused. Enamikul juhtudel on need omadused on nõuetele arhitektuuri. Näiteks, kui sul on 1250 MIPS sõlme / klastri, siis lisaksin sõlme osana, siis lisa tulemuslikkuse vara, ja omistada väärtus 1250 MIPS.

3. Analüüsida - Kasutage arvelaud elegantselt analüüsida ja visualiseerida keeruline struktuur oma arhitektuuri.Sa saab analüüsida oma arhitektuuri mitmel viisil või mitmest seisukohti, sh diagrammid, 3D ja Explorer. Alternatiivina võite kasutada mõningaid täpsemaid seisukohti järgmiselt:

· Kaardistada oma arhitektuuri - saada tulemuslikkuse (reaktsiooniaeg, ribalaius, jne), kulud (baar, pirukas, jne) või evolvability (võime ruumi, kaubandus-off jne) seisukohti.

· Loo aruande oma arhitektuuri.

4. Simuleerima - Kasutage arvelaud simuleerida oma arhitektuuri jõudlust, kättesaadavuse, maksumuse, avatus jms

· Selleks, joosta üks simulaatorid. ABACUS hindab oma arhitektuuri vastu oma nõudedteostades simulatsiooni. See loeb ja analüüsib praegust arhitektuuri, jookseb simulatsioonide ja arvutab mõned uued omadused. Need omadused on siis salvestatud tagasi arhitektuuri. Uus omadused on andmeid üritad analüüsida, nagu kasutamise, reaktsiooniaeg, ribalaius,% kättesaadavust, TCO jms

5. Insener- Kasuta arvelaud vastata erinevatele "mis siis, kui" stsenaariumid ja kontrolli arengus oma arhitektuuri. Insenerid on protsess, korrates Asustada - Analüüsida - simuleeriminetsükli.

· Sel hetkel, siisolenilmselt arenenud arusaam Praegune Arhitektuur ja tõsteti esile valdkondi, mida vaja areneda. Üsna sageli, aga sa pead kordama asustada - Analüüsida - simuleerimine protsessi mitu korda. See on ilmselt, sest see võib võtta paar korduste enne leida Target arhitektuur. Samuti, kui teie arhitektuur on väga keeruline, võiksite korrata protsessi iga arhitektuurilise "tase".

6. Plantulevikus oma arhitektuuri abil teavet ABACUS.

Märge

Kui sa ei taha areneda olemasoleva arhitektuuri, siis võib vaja korrata mõned sammud mitu korda, ja teises järjekorras. See sõltub sellest, mida sa üritad do. Näiteks, kui sa mingit uut struktuuri, saad ilmselt ainult asustada oma arhitektuuri üks kord ja seejärel kasutada ABACUS üle pika aja suunata edasisele arengule (s) arhitektuuri. Teiselt poolt, kui sa osta uus struktuur ja mitmeid alternatiive valida, peate Avasta ja asustada iga alternatiive, ja seejärel analüüsimine ja simuleerimine igaüks iseseisvalt enne tulemusi lõpliku võrdluse juures lõpus.

Vaata ka

Mida ABACUS teha? | Mis on arhitektuur? | Kuidas arhitektuuri esindatud ABACUS? | Asustamine oma arhitektuuri | Analüüsides oma arhitektuuri | Simuleerimine oma arhitektuuri


Mis on arhitektuur?

Navigation: Sissejuhatus arvelaud>

Mis on arhitektuur?

Saada kommentaare selle teema.

Arhitektuur on abstraktne mõiste- Mitte füüsilisi asi. See on rikas ja põhjalik kirjeldus või struktuuri mõistmist süsteemi - hõivamiseks komponendid ja kuidas nad on seotud (suhelda). Kuna mõiste arhitektuur on nii kõikehõlmav, see on põhiline hind, kättesaadavus, evolvability, avatust ja süsteemi toimivust. Heli arhitektuur on eeltingimus on helisüsteem.

ABACUS, siis modelleerida oma arhitektuuri. Lihtsuse me nimetame seda arhitektuurse mudeli arhitektuuri.

Allolev diagramm näitab tüüpiline arhitektuur 5komponendid (hierarhia) ühendatud 2 ühendusi. Need sildid nimed antud erinevate osade arhitektuuri ABACUS.

Lihtne arhitektuuri

ABACUS leiab, et kõik need asjad olema osa arhitektuuri:

· Komponendidesindavad isikud oma arhitektuuri mis sa võiksid kirjeldada kui "asju". Kindlustusseltsile, komponendid võivad olla süsteemid töötlemiseks poliitika, väidab, maksed ja laekumised.

· Sidemedmoodustavad suhted nende komponentide vahel. Näiteks kindlustusselts, kviitungid genereeritakse kehtiv poliitika, väidetakse vastu kehtiva poliitika ja kehtivad nõuded välja maksmata. Kui mõelda arhitektuurselt - eriti kui kasutatakse ABACUS - ühendused on sama olulised kui osad, ja nad on käsitletud peaaegu identsed viisil.

· Kõik puu võib olla Omadused. Omadused on asjad nii, vajate oma süsteemi täita arv ridu koodi see on protsent need read, mis on kommentaarid jne ABACUS leiab, et kõik need asjad olema osa arhitektuuri.

· Kasutades hierarhiad(st alakomponentides ja sub-ühendused), Mida saab peita teavet ja de-kirjutada oma arhitektuuri. Arvelaud arhitektuurne mudel on äärmiselt paindlik. Iga osa igal tasandil võib olla seotud mõne muu komponendi mis tahes muul tasandil mingit seost igal tasandil.

· Attachmenton toiming, mille komponendid sadamad on kohustatud ühendustrollid. Ports ja Rollid on liidesskomponentide vahel ja ühendused. Neid kasutatakse kinnituda ühendused komponente. Ühendused on Source ja neel roll(soodustades andmevoog allikseadmega valamu osa)ja kontseptuaalselt, komponendid on sadamad. Lihtsuse siiski ABACUS komponendi pordid ei ole näidatud ja ühendus rollid on otseselt seotud selle osad ise.

· Komponendid ja ühendused on teatud Tüüp. See on peamiselt klassifitseerimise jaoks. Näiteks poliitika, väited, maksed ja laekumised on osade tüüp "süsteemi". Kehtiv poliitika kehtivad nõuded jne on ühendused tüüpi "Tehing". Tüüp määratud osa või ühendus pakub malli omadused ja normid on. Näiteks Server tüübikinnitusmärgi võib olla "Mark ja mudel" standardja IP aadressi vara. Erinevalt teistest jäik tööriistad põhi relatsiooniline andmebaasis (RDB) back-end, ABACUS saab vabalt luua oma uue liigid ja määrata oma kombinatsioonid omadused ja standardite neile.

· Standard raamatukogud omadusi saab täpsustada ja määrata midagi arhitektuuris. Need raamatukogud tuntakse Standardid. Kasutades StandardidTe ainult vaja koguda konkreetsete süsteemide omadusi - standard omadused on juba olemas. Näiteks standard toimivusomaduste Microsoft Windows 2000 saab määrata ükskõik komponendid kasutavad Microsoft Windows 2000 operatsioonisüsteemi.

Vaata ka

Kuidas arhitektuuri esindatud ABACUS? | Mida ABACUS teha? | Kuidas sa seda (ülevaade) | Uue Type


Arvelaud liides

Navigation: Sissejuhatus arvelaud>

Arvelaud liides

Saada kommentaare selle teema.

Kui hakkad ABACUS, näete peamine ekraan, mis on tühi, välja arvatud Menüüd ja tööriistariba ülaservas, tühja Exploreri aken ja pealkiri-baar. See ekraan on Rummu teie suhtlemist ABACUS.

Peamised elemendid on:

· põhimenüüdele

· tööriistaribad

· paremklõps menüüst

· maadeuurija ja kinnisvara aknad

· olekuribal

Põhimenüd

Menüüd on paigutatud loogilises järjekorras.

Menüüd on kirjeldatud järgmiselt;

· Faili menüü- Menüüs Fail võimaldab teil luua, avada, sulgeda, salvestada, ekspordi ja avaldavad ABACUS faile. Samuti võimaldab teil luua, avada, sulgeda ja säästa ABACUS raamatukogu faile.

· Edit menüü- Edit menüü võimaldab teil lõigata, kopeerida, kleepida, kustutada, ümber nimetada, leida ja sorteerida elemendidja undo / Redo operatsioone.

· Vaata menu- Menüüs Vaade võimaldab avada või sulgeda erinevaid aknaid ja olekuribaNavigeerida edasi ja tagasi, minge konkreetseid seisukohti ja hallata armatuurlauad.

· Sisestage menüü- Insert menüü võimaldab teil lisada uusi standardid, Mallid, tüübid, elemendid, vaadepunkts, Kataloogid, diagrammid, kaardidAruanded ja maatriksid.

· Analüüs menu- Analüüs menüü võimaldab käivitada hinnangute eest arhitektuur sealhulgas; tulemuslikkuse, hinna, töökindluse, moodulitest ja avatust.

· Tööriistad menüü- Tööriistad menüü võimaldab teil käivitada skriptimine, Eesmärkide püstitamine arhitektuurja täita ja arhitektuur "diff". Samuti võib muuta programmi võimalusi ja kohandada liidese abil menüü.

· Window menüü- Aken menüü võimaldab teil dokk, korraldada, näidata ja peita aknad teil on avatud.

· Abi menu- Menüüst Abi pääsete sellele ABACUS help file. Võite kasutada veebilehel, vaadata litsents leping ja näha üldist andmeid ABACUS sealhulgas tarkvara versiooni ja ABACUS toetust ja kontaktandmed. Võite anda tagasisidet kaudu küsimuses teate lehel. Kui vaja, saab sisestada registreerimise võti kaudu Help menu.

See on selleks, saate tavaliselt järgida, kui sa oled teostamiseks oma ülesandeid;Kui olete loonud või avatud fail, Saate tavaliselt asustada oma arhitektuuri, siis vaadesee (Explorer, diagrammid, 3D, Charts, jne). Sel hetkel, siis saad kas joosta HindajaVõi saate korrata protsessi sama arhitektuuri või teistsugust arhitektuuri. (Vt Kuidas kasutada ABACUS (ülevaade) Täiendavaid üksikasju.)

Have a look läbi põhimenüüdele ja proovige ette kujutada, kuidas sa neid oma süsteemis.

Märge

Sa saad Kohanda oma menüüd iga kell.

Tööriistaribad

Vaikimisi on järgmised tööriistaribad;

· Peamine tööriistariba -

· Simulatsioon tööriistariba -

· vaateriba -

· Skeem tööriistbar (kui skeem on avatud) -

· Macro Salvestamine tööriistariba -

Have a look läbi nuppe iga tööriistariba varjutavad neid näha Vihjemull (otsetee-klahvi).

Märge

Ainult teatud nupud on aktiivne sõltuvalt sellest, mida olete valinud Exploreri aken ja saad Kohanda oma tööriistaribad iga kell.Lisaks "Kinnita / Vaata Project piirangud" nuppu peamine tööriistariba ja nupud Simulatsioon tööriistariba esile Red kui muudatus alusvara hoidla nõuab uuesti kinnitamist projekti või re-simulatsioon, et simulaator võrra. Hover üle nuppu, et näha, mis arhitektuur on mõjutatud.

Paremklõpsake menüü

Põhimenüd ja menüüde eikasutada kõike, kuigi. Sageli on mugavam kasutada paremklõpsu kontekstimenüü erinevate tegevuste. (Ka mitte kõik käsud saadaval läbi paremklõpsu on kättesaadavad peamenüüde tööriistaribasid või klaviatuurkäskudega.)

Näiteks, kui olete loonud faili, ja teil on puudiagramm oma arhitektuuri, siis on parem paremklõpsake Architecture'i puu lisada uue arhitektuuri. Samamoodi peaks paremklõpsake Components lisada uue osa. Paremklõpsake mõned asjad puust näha, mida saate teha.

Ots

Üldiselt saad kasutada põhimenüüdele teostada rohkem kõrgetasemelisi ülesandeid, nagu hinnata oma arhitektuuri. Madala taseme ülesandeid - nagu lisades üksikuid komponente ja ühendusi - mida teha, kasutades tööriistaribasid ja / või paremklõpsake menüü.

Maadeuurija ja omadused aknad

Kui avate või luua faili, puu diagramm näitab Exploreri aknas. See on aken oma arhitektuuri. Ja kui valite elementi Explorer aknas kolm teised aknad; üldised omadused, Viitedja omadused aknad uuendab kajastada üksikasjalikku teavet oma valikut.

Märge

Üldised omadused, Viitedja omadused aknad on vaikimisi peidetud. Nägema Kohandamine liidese kuidas seda taas neile ja potentsiaalselt jäta neid pidevalt nähtav.

Kuigi sa oled hoone oma arhitektuuri, Explorer ja omadused aknad on kõige kasulikum esindatus. Kuna neid on võimalik kokku varisenud ja laiendatud vastavalt vajadusele, ja nad ei muutunud kohmakaks.

Explorer aknal Tree (ja Status bar) ja Properties aknad on 5sektsioonid:

· Tüüp

· Standardid

· Kirjeldamine

· Viited

· Omadused

ABACUS leiab, et kõik need asjad olema osa arhitektuuri.

Puu

See osa on puu jagada 3 aladel järgnevalt:

1. Meta-mudel

· Standardid- Kui palju komponente on samad omadused, mida saab kindlaks määrata soovitud up-front ja seejärel lihtsalt määrata selle komponendid. Sama kehtib ka ühendused ja mis tahes muu elemendi. Need komplekti Standardi omadused salvestatakse Standardidpuusse. Selle asemel, et määratleda iga vara iga osa, ja iga vara iga ühendus jne, lihtsalt määrata standard. Näiteks standard omadused Unix-HP / UXsaab salvestatakse Standard ja määrata igale komponentide abil Unix-HP / UXoperatsioonisüsteemi nagu näidatud jaoks OS01 server pildil üle.

· Tüübid - See puusse on raamatukogu tüüpi komponente ja seoseid, mida saab kasutada. Tüübid määratlemiseks kasutatakse meta-mudel oma arhitektuuri ja klassifitseerimise ja filtreerimine, kui vaatate oma arhitektuuri. Samuti määrata malli, mida standardid, Omadusi ja piiranguid oma osad / ühendused võivad olla.

· Seisukohad- Vaadepunkts on võimalik luua olemasolevate skeemide ning saab kasutada, et luua uusi diagrammid.Nad on diagramm šabloonid.

· Templates - Templates poest korduvkasutusega patterns Osade ja ühendused koos viisil, kus nad on esindatud või vaadata. Neid saab vaadelda kui "mini" arhitektuur või lahused, mida saab paigutada olemasolevatesse arhitektuurid.

2. Arhitektuur -Arhitektuurid filiaal Puu on koht, kus sa ehitada arhitektuur (s) oma süsteemi. (Seda nimetatakse asustamisega arhitektuuri.) Võite olla suvaline arv arhitektuuri ühe ABACUS faili.

3. Verbi - Armatuurlauad puusse on koht, kus saab tutvuda kõigi salvestatud armatuurlauad Projekti.

Märge

Kirjed Explorer puu, mis on olnud nende Värskenda luba eemaldada (st nad on ainult lugemiseks) on näidatud halli.

Tüüp

See osa tähistab konkreetset osa või ühenduse tüüp on valitud element puu.

Standardid

See osa annab nimekirja standardid Parajasti valitud element puu.

Kirjeldamine

See osa kirjeldab lühidalt valitud element puu. Iga seotud linke saab lisada ka selles osas. Nende hulka kuuluvad veebilehed või kohaliku absoluutne teed osutades Lisainfot antud element. Mitu rida on samuti lubatud. Kehtib hüperlingid on vaja alustada üks 5 stringe; http: // https: //, ftp: // file: /// või mailto :.

Ots

Hüperlinkidel koos tühikutega kasutajad saavad sisestada URL või tee, valige soovitud tekst ja Paremklõps| Hüperlink. See muudab mis tahes ruumid % 20nii et kogu URL või tee korralikult töötab.

Loodud ja modifitseeritud

Need osasandakasutaja ja kuupäeva / kellaaja loomiseks ning viimase modifikatsioon, valitud element puu.

Viited

See osa annab nimekirja väljuvaid ja saabuvaid komponendid Parajasti valitud element puu.See näitab ka diagrammid, 3D ja Chart seisukohti, et valitud element ilmub. Kui skeem on valitud see näitab Seisukoht vajadusel diagrammi ja seisukohti üldiselt näitab see igal Verbi seisukohal ilmub. Ja kui Standard on valitud puu näitab kasutamine standard liikide, osade ja ühendused.

Omadused

See lõik on koht, kus saab määrata omadused elemendid jooksul Sinu arhitektuuri, nagu kuidas sa seda vaja täita, kui palju ridu koodi see on protsent need read, mis on kommentaarid jne

Nn sisend "ja" toodangu "omadused varem ehitatud simulaatorid kuvatakse Properties aken vara sisendi real valija ikoon ( [image] ) Ja väljundi ikoon ( [image] ) Vastavalt koos tooltip näitab, mis varem ehitatud simulaator vara on seotud, nt "Modulaarsus Output" või "Performance sisend". Nool väljund ikoonid esile Red ( [image] ), Kui vara on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse simulaatorit nõudes uuesti simulatsiooni järgi Red esiletõstmise Simulatsioon tööriistariba .

Olekuriba

Vasakpoolne osa Olekuriba näitab täielik tee praegu fookuse hoidla element, kas valitud Explorer aken või skeemlõuend. See on nii, et täpne koht hoidla hierarhia antud element saab alati kergesti määratav. Parempoolne osa Olekuriba näitab erinevate tegevus- sõnumitest, nagu "Open ABACUS Faili Edukad" ja "kulude arvutamise Tehtud".

Vaata ka

Kuidas sa seda (ülevaade) | Kohandamine liidese | Mis on arhitektuur? | Kuidas arhitektuuri esindatud ABACUS? | Töö ABACUS faile


Kohandamine ABACUS liides

Navigation: Sissejuhatus arvelaud>

Kohandamine ABACUS liides

Saada kommentaare selle teema.

Te saate muuta välimust ja käitumist arvelaud liides mitmel viisil. ABACUS sisaldab mitmeid eelseadistatud kombinatsioone, mida saab kasutada, et rakendada rühma customisations liidesega. Lisaks saad teha üksikute customisations objektidega nagu aknaid, kiirklahvid, ja erinevate kuvab võimalusi.

Korraldada ja Dock Windows

Sul on palju võimalusi korraldada aknad jooksul liides ABACUS, sealhulgas järgmised:

· Tab-doki aknad.

· Dock aknad serva raami liides.

· Minimeerimine tool akende ääres liides.

· Taasta akna paigutus vaikepaigutusele.

Docking Windows

Kui aken on dokitav, seda saab kinnitada ühel küljel raami liidese sees või seda saab paigutada sakkidega panes raamis. Juhend teemant ilmub lohistada aknad oma praeguse kohast teise liides. Juhend teemant võimaldab kiiresti ümber dock aknas üks neljast küljest raami või keskel nagu kaartidega pane. Kui aken on lahtised või ei dokk, see hõljub peal teiste aknad.

Dokkimiseks aknad

1. Klõpsake aknas soovite dokk, et anda sellele keskenduda.

2. On Windowkäsku Dokitav.

3. Lohista akna selle praegusest asukohast poole kaadri keskele soovite dokk seda.

Juhend teemant tundub. Neli nooled teemant punkti suunas neli kaadri servad ja keskel tähistab kaartidega pane.

Ots

Teisaldamiseks dokk aknas ilma haaramine see paika, vajutage CTRL lohistades.

4. Kui aken sa lohistades jõuab asendisse, kus soovite dokk, liiguta kursor vastava osa juhend teemant. Ülevaade aken määratud ala.

5. Et dokkimiseks märgitud ametikohal, vabasta hiirenupp.

Näiteks, kui Uurijaon sadamas vasakul serval liides ja soovid dokk seda parem serv, siis oleks lohistada Uurijaäärele liides, kursoriga paremal pool juhend teemant, ja seejärel vabastage hiirenupp.

Minimeerimine Windows

Windows (kas nad on Tool Windows - ilmumise Vaademenüü või dokumendi Windows - ilmumise Windowmenüü) toetada funktsioon nimega Auto Hide. Auto Peida võimaldab teil näha rohkem oma arhitektuuri korraga minimeerides aknad servadel liides kui seda ei kasutata.

Sisselülitamiseks Auto Hide

1. Klõpsake aknas soovite peita, et anda sellele keskenduda.

2. On Windowkäsku Auto Hide.

- Või -

2. Klõpsake pushpin ikooni tiitliribal aknas.

Auto Peida lubatud

Kui auto peidetud akna kaotab fookuse automaatselt libiseb tagasi oma tab äärel liides. Kuigi aken on auto-peidetud, oma nimi ja ikoon on nähtav sakk servas liides. Et kuvada auto-peidetud akna liigutada kursori alt. Aken libiseb tagasi vaadata ja on kasutamiseks valmis.

Märge

Aken on auto-peidetud, ei saa sadamas. Dokkimiseks akna peate lülitage Auto Peida nagu allpool kirjeldatud.

Väljalülitamiseks Auto Hide

1. Klõpsake aknas soovid hoida nähtav, et anda sellele keskenduda.

2. On Windowkäsku Auto Hideselge märge.

- Või -

2. Klõpsake pushpin ikooni tiitliribal aknas.

Auto Peida puuetega

Ots

Windows, mis on Auto Peida võimaldas ajutiselt slaid silmas, kui aken on fookuses. Ning aken uuesti valida objekt väljaspool aktiivse akna. Kui aken kaotab fookuse, see libiseb tagasi välja vaadata.

Lähtestamine Windows Layouts

Võite tagastada liides vaikimisi aknapaigutus abil Taasta Akende paigutuskäsk. Kui ksku järgmisi tegevusi tekkida:

· Kõik aknad on kolinud oma default seisukohti.

· Windows, mis on suletud vaikimisi akna paigutus on suletud käsk.

· Windows, mis on avatud vaikimisi aknapaigutus avatakse käsk.

· Windows, mis on peidetud / nähtav vaikimisi akna paigutus on tehtud varjatud / nähtav käsuga.

Nullimiseks akna paigutus vaikepaigutusele

1. On Windowskäsku Taasta Akende paigutus.

Kohandamine Menüüd ja tööriistariba

Teil on võimalik muuta paigutus, positsiooni ja sisu menüüde ja tööriistaribade liides. Võite lisada ka nuppude tööriistaribasid ja muuta määratud ikooni tahes nuppu.

Loo uus tööriistaribad

Uue tööriistariba

1. On TöövahendidVali menüüst Kohanda.

2. Aasta Kohandadialoogiboks, valige Tööriistaribadtab.

3. Valima Uus.

4. Aasta Uus ToolbarTippige dialoogiboksi nimi tööriistaribal.

5. Valima Okei.

Lisada käsu nuppu menüü või tööriistariba

1. On TöövahendidVali menüüst Kohanda.

2. Aasta Kohandadialoogiboks, valige Käsudtab.

3. Valige kategooria ja lohista käsu välja dialoogiboksis menüüs või tööriistaribal.

4. Valima Lähedane.

Ots

Hoides all Alt-klahvi abil saate kiiresti kohandada käske, nagu oleks Kohanda dialoog oli avatud.

Vaata ka

Arvelaud liides


Töö ABACUS faile

Navigation: Sissejuhatus arvelaud>

Töö ABACUS faile

Saada kommentaare selle teema.

ABACUS fail on konteinerisse mudel oma arhitektuur . Ühes ABACUS faili, mida saab modelleerida suvalise arvu arhitektuuri suvaline arv kordi.

Kui te esimest korda avada ABACUS, ei ole faile avada. Töötada oma arhitektuuri, sa pead kas luua uus fail, või avage olemasolev fail.

Kui avate või luua uue faili, puu maadeavastaja aknas kuvatakse automaatselt. See explorer vaade näitab teile oma arhitektuuri kuupäeva. Kui sulgete faili, puu Explorer aknas kaovad ka.

Uue ABACUS faili

1. Valima Faili| New ...

2. Aastal dialoogi Uue projekti, mis näib (nagu allpool näidatud) Valimakas luua tühi mudel, mudel alates standard ABACUS raamatukogu Mudel, st kohandatud ABACUS raamatukogu, mudel XML, MS Access , MS Visio , MS Excel , MS SQL Server , Mis on Ettevõte Server mudel või kohandatud ABACUS raamatukogu (.abacuslib fail).

3. Vajuta Okeinuppu ja järgib kõiki dialoogid, mis võib tunduda.

Ots

Sa ei saa palutakse nimetada fail kuni teil säästa või sulgeda. See on hea mõte faili salvestada nii kiiresti kui sa luua. Siis sa ei pea muretsema nimetades seda hiljem protsess, kui sa oled keskendunud keerukaid asju (nagu asustamisega oma arhitektuuri).

Luua uus projekt

ABACUS Standard Raamatukogud

ABACUS toetab üle 100 avaliku raamistike ja märked millest mõned on toodud allpool. Valides uue projekti standard raamatukogu kasutajad on kiire algus modelleerimine jooksul luua raamistik täiel määral kasutada mistahes määratletud elemendi tüüpe, atribuudid, salakoodi, seisukohad ja malle või mustrid. Täiendav standard raamatukogud on vabalt saadaval Avolution ühenduse siin .

New Project Standard Library

Et salvestada uus ABACUS faili

1. Valima Faili| Salvesta kui

Ots

Failide nimed võivad olla mis tahes pikkusega, ning võib sisaldada tähti, numbreid ja ruumid. Nad ei tohi sisaldada tilde (~) iseloomu, toru (|) iseloomu, küsimärk (?), Või tegelased tavaliselt kasutatakse tee kirjelduse, nagu kurakriips (\) - välja arvatud osa tee.

Et avada olemasoleva ABACUS faili

1. Valima Faili| Avatud

Märge

Kui avate faili ühisvõrku asukohta, mis on juba avatud teisele kasutajale Abacus pakub Read Only juurdepääsu. Kui kasutate arvelaud Read Only juurdepääsu, siis ei ole võimalik täita kirjutada toiminguid, nagu asustamisega oma arhitektuuri ja töötab hindajad. Võite siiski vaadata oma arhitektuuri abil explorer vaadata ja 3D vaated.

Vaata ka

Kuidas arhitektuuri esindatud ABACUS?


Kuidas arhitektuuri esindatud ABACUS?

Navigation: Sissejuhatus arvelaud>

Kuidas arhitektuuri esindatud ABACUS?

Saada kommentaare selle teema.

ABACUS, siis modelleerida oma arhitektuuri. Lihtsuse me nimetame seda arhitektuurse mudeli arhitektuuri.

Alljärgnev diagramm näitab, kuidas tüüpiline arhitektuur 5komponendid (hierarhia) ühendatud 2 ühendused oleksid esindatud ABACUS.

Kuidas lihtne arhitektuur on esindatud ABACUS

Sul võib olla suvaline arv arhitektuuri ühe ABACUS faili.

Esimene arhitektuuri puu

Tavaliselt soovid luua uue arhitektuuri kui soovite, et hinnata muutusi. Näiteks võid modelleerida oma olemasoleva arhitektuuri esimene - see oleks esimene arhitektuuri puu. Sa võid seda nimetada "Praegune".

Teine

Kui soovite modelleerida ja hinnata muutusi oma olemasoleva arhitektuuri (nt suurenenud nõuded) soovite luua uue arhitektuuri. Lihtsaim viis seda teha oleks luua koopia "Praegune" ja selle ümber nimetada "Evolution 1 Katse 1". See oleks teine ​​arhitektuuri puu. Kui teie hinnanguid "Evolution 1 Katse 1" on edukas, siis võib selle ümber nimetada lihtsalt "Evolution 1".

Kolmas

Kui "Evolution 1 Katse 1" ei vasta teie nõuetele, saate luua koopia, ümber nimetada, et "Evolution 1 Katse 2", siis proovige uuesti. See oleks kolmas arhitektuuri puu.

Vaata ka

Mida ABACUS teha? | Kuidas sa seda (ülevaade) | Mis on arhitektuur? | Töö ABACUS faile | Loomine ja kopeerimisega arhitektuuri


Abi teistes keeltes

Navigation: Sissejuhatus arvelaud>

Abi teistes keeltes

Saada kommentaare selle teema.

ABACUS Abi on saadaval erinevates teistes keeltes / tõlked ja saab alla laadida linkidele.

Kuni asendada praegune ABACUS abifailkoos tõlgitud help file järgige neid samme:

1. Säästa abiga faili asjakohane link allpool.

2. Nimeta abi faili ABACUS.chm.

3. Avage fail topeltklõpsuga see ja kui "Open File - Security Warning" dialoog ilmub siis lülita "Küsi alati enne faili avamist" valik ja klõpsake Open.

4. Sulgege fail.

5. Vahetage ABACUS.chm faili ABACUS program files kausta, tavaliselt "C: \ Program Files \ Avolution \ ABACUS"Või"C: \ Program Files(x86)\ Avolution \ ABACUS".

Märge

Taust spikker jätkab tööd tõlgitud abi faile.

ABACUS abifailidele teistes keeltes:

· Araabia / العربية .

· Bulgaaria / български .

· Chinese (Simplified) / 中文 (简体) .

· Tšehhi / Česká .

· Taani / Dansk .

· Eesti / Eesti .

· Soome / Suomen .

· Prantsuse / Français .

· Saksa / Deutsch .

· Ungari / Magyar .

· Islandi / Islandi .

· Indoneesia / Indoneesia .

· Itaalia / Italiano .

· Jaapani / 日本 の .

· Läti / Latvijas .

· Malaisia / Malaisia .

· Malta / Linnased i .

· Norweigen / Norweigen .

· Poola / Po lska .

· Portugali / Português .

· Vene / русский .

· Slovaki / Slovenskí .

· Sloveeni / Slovenski .

· Hispaania / Españoles .

· Rootsi / Svenska .

· Türgi / Türk .

· Walesi / Cymraeg .

Vaata ka

Mida ABACUS teha?


Asustamine oma arhitektuuri

Navigation: asustamine oma arhitektuuri>

Asustamine oma arhitektuuri

Saada kommentaare selle teema.

Ülesehitamisel eeskujuks oma arhitektuuri tuntakse Populating. Kui olete avastanud oma arhitektuuri ja identifitseerida oma nõuded, olete valmis modelleerida oma arhitektuuri ABACUS.

Ajal elanikkonnast, siis saad sisestada kõik üksikasjad sa tead oma arhitektuuri ja milline on nõutav ta.

Asustada oma arhitektuuri

1. Veenduge, et teil on ABACUS fail avatud , Mis on explorer kuvatakse , Ja Arhitektuur lisatud .

2. Käsitsi asustada kõrgema taseme komponendid ja ühendused oma arhitektuuri. Tavaliselt see on rohkem abstraktne komponendid ja ühendused.

- Või -

2. Graafiliselt asustada komponente ja seoseid, mida soovite vt skemaatiliselt kujutatud joonisel, kasutades selleks Joonis Tool .

Võite ka, et

3. Asustada kasutades kataloogid - Saab vaadata ja komponendid ja ühendused lihtsa tabeli viis.

4. Asustada maatriksite abil - Saab vaadata ja muuta seoseid komponendid lihtsa tabeli viis.

5. Asustada Microsoft Access - Saab importida arhitektuuri ja eksportida Microsoft Access.

6. Asustada Microsoft Visio - Saab importida arhitektuuri ja eksportida Microsoft Visio.

7. Asustada Microsoft Excel - Saab importida arhitektuuri ja eksportida Microsoft Excel.

8. Asustada Microsoft SharePoint - Saab importida arhitektuuri ja eksportida Microsoft SQL Server.

9. Asustada Microsoft SQL Server - Saab importida arhitektuuri Microsoft SQL Server.

10. Impordi XML - Saab importida arhitektuuri alates ABACUS XML fragment või ArchiMate Interchange Keel XML-faili.

Vaata ka

Asustamine oma arhitektuuri käsitsi | Joonistus Tool | Asustamine oma arhitektuuri Microsoft Access | Asustamine oma arhitektuuri Microsoft Visio | Asustamine oma arhitektuuri Microsoft Excel


Asustamine oma arhitektuuri käsitsi

Navigation: asustamine oma arhitektuuri> asustamine käsitsi>

Asustamine oma arhitektuuri käsitsi

Saada kommentaare selle teema.

Kõrgema taseme komponendid ja ühendused oma arhitektuuri ilmselt tuleb asustatud käsitsi. Tavaliselt see on rohkem abstraktne komponendid ja ühendused.

Käsitsi asustada oma arhitektuuri

1. Veenduge, et teil on ABACUS failiAvatud, mis on uurijakuvatakse, ja Arhitektuur lisatud .

2. Lisa komponent. Selleks, Paremklõpsala puu soovite asustada, ja valige Lisa alamkomponendi ...Või klõpsake New Componentnuppu Vaata tööriistariba . Komponendid saab alla lisatakse komponendid puusse. Tahad oma puudiagramm olla täpne esitus oma arhitektuuri. Kui sa avastasid oma arhitektuuri, siis on õppinud, kuidas täpselt see kõik kokku klapib. Pead selle teadmisega, kui lisate oma komponente ja seoseid. Kui lisate oma esimest osa, siis saad lisada selle otse Components filiaal. Oma ülejäänud komponendid võivad olla samal tasemel puu või nad võivad olla alakomponentides esimese.

3. Uuenda väärtusedomadusteIga komponendi teil lisada. Selleks, klõpsosale, ja omadusi muuta kuvatakse Omadused aknas(tavaliselt) paremale. Omadused on üldiselt asjad nõuetele, töötlemise võimsus jms Kui ABACUS hindab oma arhitektuuri, siis arvutada mõned uued omadused ja neid päästa tagasi arhitektuuri. Uus omadused on andmeid üritad analüüsida, nagu kasutamise, reaktsiooniaeg, ribalaius jms

4. Lisa oma ühendusedja ajakohastamanende omadusedkui sa lähed - just nagu sa teha osad (kuid alla Ühendused puusse).

5. Kinnitageühendused ja komponendid. Selleks leidke ühendus, kliki ühe oma lõpeb või rollid Ja lohista see komponent. Teise kliki ühe komponendina ja lohista see üks-ühenduse rolle (st kas Allikas või Sink). Või saate paremklõps ja lohista komponent teisele komponent ja valige Ühenda. Või lihtsalt paremklõps osa ja valige Ühendage .... Tõmmates ühendust rollMärkad otsetee sümbol kui osutavad komponent võite lisada see. See näitab, et sa ei tee koopia, sa oled lihtsalt kinnitamata. Veenduge, et teil lisada see õige kohtades komponent. Näiteks, kui see on seotud allikas rollLiigutage seda teha allikas komponenti (st osa, mis on allikas andmevoo).

Ots

Re-tellimine üksused oma arhitektuuri (nt komponendid, ühendused jne) uurijaOn üsna lihtne. Lihtsalt Vajuta| Hoia| Dragasjaomane üksus ja koht, kus soovitakse oma arhitektuuri. Uuesti tellimine funktsionaalsus võimaldab panna üksuste erinevad hierarhiad oma arhitektuuri.

Võite ka, et

6. Lisa standardid (eelseadistatud komplekti omadusi - presets) oma osad, ühendused või liigid

7. Muuda omadused komponendi, ühendus või tüübi

8. Undo ja Redo toimingud

9. Muuda tüüp Osa või ühendus

10. Loo uus tüübi või rühma

11. Kustutama Osa või ühendus

12. Loo, kahe- või areneda arhitektuur

13. Import tüüpi ja standardid raamatukogust

14. Import teine ​​ABACUS faili, XML, Excel või Visio

15. Kopeeri ja kleebi osad (või kõik) oma arhitektuuri

16. Otsi ja asenda esemed oma arhitektuuri

17. Laienda / Sulge mõned või kõik sõlmed puu

18. Merge kirjed

19. Määrake ja Kinnita Piirangud piirata struktuuri oma arhitektuuri

20. Evolve teie arhitektuuri luua mitu arhitektuurilised lahendused võrrelda ja algtaseme

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Uue faili


Undo ja Redo

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Undo ja Redo

Saada kommentaare selle teema.

Nagu paljud kaasaegsed rakendused Abacus toetab võime nii tagasi võtta ja uuesti viimastel kasutaja tehtud muudatused avatud projekti. Undo viimaseid muutusi, lihtsalt aktiveerida Undo käsu. Muudatused, mis on likvideeritud saab leheküljed reformiti, aktiveerides redo käsk; uuesti kohaldada viimati tegemata muutus.

Hoiatus

Tegemata muutused ei ole võimalik tagasi panna kui täiendavaid muudatusi tehtud projekti, kuna on tegemata.

Märge

Kuigi enamik muudatusi toetavad undo / Redo reaalajas, mõned skeem stencil muutusi, näiteks luua uus Type-kuju / Line ühingu või muutuva ühing värvi atribuut, ei saa tagasi võtta kohe. Sellistel juhtudel modifitseeritud diagramm (tähistatud tärniga) peab suletakse enne neid muutusi saab tagasi võtta.

Undo ja Redo käsk kohad

Undo ja Redo käske võib tutvuda kolme eri kohtades:

· Edit menüüst

· Standard tööriistariba

· klaviatuuri kiirklahvid CTRL + Z(undo) ja CTRL + Y(Redo)

Ots

Undo ja Redo nupud tööriistaribal Standardne pakkuda rippmenüüst nimekirjad väljapanek 10. viimaseid muudatusi, mida saab tagasi võtta ning on leheküljed reformiti võrra. Nad on ka mugav viis undo / Redo korraga mitme muudatuse.


Muutuvad osa / ühendus on Type

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Muutuvad osa / ühendus on Type

Saada kommentaare selle teema.

Component ja ühenduse tüübid kasutatakse peamiselt liigitamiseks. Võite kasutada tüüpi filtrite kuvamisel oma arhitektuuri. Näiteks selle asemel, et vaadata kogu asi, mida võiks vaadata lihtsalt Application komponendid.

Selleks, et muuta osa / ühendus on Type

1. Paremklõpsosale või ühendus.

2. Valima Muuda tüüp.

3. Vali teine ​​tüüp nimekirja.

Ots

Kui muudad tüüp, võite saada mõned uued standardidvõi omadusi (kõik, mis on seotud Type - vaata tüübid puusse). Teie olemasolevad standardid ja omadused jäävad muutumatuks. Võite luua oma uut tüüpi ja määrata oma kombinatsioonid standardid ja omadusi neile.

Vaata ka

Uue Type | Asustamine oma arhitektuuri - ülevaade | Analüüsides Sinu arhitektuuri


Uue osa / ühendus tüübi või rühma

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Uue osa / ühendus tüübi või rühma

Saada kommentaare selle teema.

Component ja ühenduse tüübid kasutatakse peamiselt liigitamiseks. Võite kasutada tüüpi filtrite kuvamisel oma arhitektuuri. Näiteks selle asemel, et vaadata kogu asi, mida võiks vaadata lihtsalt Application komponendid.

Uue osa / Ühenduse tüüp

Märge

Lisada tüüpi või liiki rühmad ühes ABACUS projekti kasutaja litsents vajab Designer add-on võime. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

1. Laiendada Tüübidpuusse.

2. Paremklõpsedasi Component liigid(või Connection liigid).

3. Valima Lisa Component Type(või Lisa Connection Type) Või Loo Group.

Ots

Kui olete loonud tüüpi, siis peaksid muutma selle ikooni (vt allpool) ja lisada omadused ja standardid et see komponent või ühendus instantside "päranduseks".

Et muuta ikooni osa / Ühenduse tüüp

Märge

Et muuta ikoone tüüpi ühes ABACUS projekti kasutaja litsents vajab Designer add-on võime. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

1. Paremklõpskohta Component Type(või Connection Type), Mida soovite muuta ikooni.

2. Valima Muuda ikooni.

3. In dialoogi Ikooni valimine Sirvi asukoht ja valida pildifaili ja klõpsake Open.

Märge

Sul võib olla kohandatud ikooni pilti igas suuruses, kuid see on alati korrastatakse sobima 16x16 pikslit Exploreri aken. Seega, kui teie originaal custom ikooni pilt ei ole võrdse pikkuse ja laiusega oma Explorer aken ikoon venitatud. Seega, custom pilte peaks olema vähemalt 16x16 pikslit ja kui sa tahad, et säilitada täpne kuju custom ikooni veenduda oma custom ikooni pilt on võrdne kõrgus ja laius pikslites (16x16 või rohkem). Sa peaksid olema ettevaatlikud, millel ei ole värvitud "pikslit" läheb kõik viis piiril custom ikooni pilt näebki vaeste Explorer aken külgnevate ikoonid "verejooksu" üksteise sisse. Seega, siis tuleb jätta vähemalt 1 pixel valge ääris.

Ots

Võite teha oma custom ikooni Kujutle ICO, .bmp, .gif, .jpg või .png formaadis faili, kuid tänu piirangule ainult Windows ICO formaadis eelvaate ABACUS dialoogi Ikooni valimine, kui sul on Vaatemenüü võimalus seatud midagi muud kui pisipildid.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Analüüsides Sinu arhitektuuri


Kustutamine osa või ühendus

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Kustutamine osa või ühendus

Saada kommentaare selle teema.

Kustutada osa või ühendus

1. Paremklõpsosale või ühendus.

2. Valima Kustutama.

Ettevaatust

ABACUS hoiatab teid, mis vaated mõjutavad kustutamise ja küsida kustutamise kinnitamiseks. Seda seetõttu, et elemendid võivad eksisteerida mitmel diagrammid ja tasub vaadata, mida väljajätmine mõjutab.

Ots

Kui kustutad komponent, kõik alamkomponendi kustutatakse ka. Saate valida, kas kustutada sise- ja välisühenduste komponendile. Kui te ei soovi kustutada neid ühendusi on lisatud kuni jääb, kuid nad ei ole enam ühendatud. Kõik komponendid ja ühendused on konkreetse Tüüp . Kustutamine osa / ühendus ei mõju kirjutama (tüübid puusse). Samamoodi, kui osa / ühendus on Standard määratud, kustutamist ei ole mingit mõju meister Standards filiaal.

Vaata ka

Asustamine oma arhitektuuri - ülevaade


Loomine ja kopeerimisega arhitektuuri

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Loomine ja kopeerimisega arhitektuuri

Saada kommentaare selle teema.

Sul võib olla suvaline arv arhitektuuri ühe ABACUS faili. Tavaliselt soovite luua uue arhitektuuri iga kord, kui soovite modelleerida ja hinnata areng oma süsteemi.

Uue arhitektuuri

1. Paremklõpskohta Arhitektuuridpuusse.

2. Valima Uus arhitektuur.

Et luua koopia olemasoleva arhitektuuri

1. Paremklõpsarhitektuur.

2. Valima Koopia.

3. Paremklõpskohta Arhitektuuridpuusse.

4. Valima Pasta.

5. Uue arhitektuuri nimetatakse "Copy of ...".

Areneda olemasoleva arhitektuuri

1. Paremklõpsarhitektuur.

2. Valima Arenema.

3. Uue arhitektuuri saab nimeks "... .1".

Märge

Seal on üksikasjalik kirjeldus arenev arhitektuur siin .

Vaata ka

Kuidas arhitektuuri esindatud ABACUS | Areneb oma arhitektuuri


Import oma Architecture

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Import oma Architecture

Saada kommentaare selle teema.

ABACUS võimaldab importida Sinu arhitektuuri alates .abacus (ABACUS faili), xml (An ABACUS XML fragment või ArchiMate Interchange Keel XML-faili), .vsd (Microsoft Visio) formaadis, ja .xls (Microsoft Excel) formaadis. See võimaldab teil ehitada oma arhitektuuri välistest allikatest kiiresti.

Kuni import Sinu arhitektuuri pärit.abacus (ABACUS fail)

1. Veenduge, et teil on ABACUS failiavatud.

2. Paremklõpsarhitektuur sõlme, mis tahes arhitektuuri oma mudel või osa Components puu.

3. Valima Import| Pärit Fail ...menüüst.

4. Vali asukoht ja .abacus fail ja klõpsa Avatudnuppu.

Märge

Kui olete valinud faili, mida soovite importida, siis tuleb küsida, kuidas soovite importida standardeid, liigidja seisukohti. Saate importida standardid, liigid ja seisukohti kas uusi või ühendatakse standardid, liigidja seisukohti. Vaikimisi on standardite, liigid ja seisukohti tuleb ühendada olemasolevad standardid, liigid ja seisukohti kui need on juba olemas (sama täpne nimi) oma projekt.

Kuni importSinu arhitektuuri päritxml (An ABACUS XML fragment või ArchiMate Interchange Keel XML-faili)

1. Veenduge, et teil on ABACUS failiavatud.

2. Paremklõpskohta Arhitektuur sõlme, mis tahes arhitektuuri oma mudel või osa Component puu.

3. Valima Import| Pärit XML ...menüüst.

4. Vali asukoht ja XML- faili ja klõpsake Avatudnuppu.

Märge

ABACUS ainult importida korrektselt moodustatud ABACUS XML fragment või ArchiMate Interchange Keel XML-faili. Kui olete valinud XML-faili, mida soovite importida, siis tuleb küsida, kuidas soovite importida standardeid, liigidja seisukohti. Saate importida standardid, liigid ja seisukohti kas uusi või ühendatakse standardid, liigidja seisukohti. Vaikimisi on standardite, liigid ja seisukohti tuleb ühendada olemasolevad standardid, liigid ja seisukohti kui need on juba olemas (sama täpne nimi) oma projekt.

Kuni importSinu arhitektuuri pärit.vsd(Visiofile)nägema siin .

Kuni importSinu arhitektuuri pärit.xls (Exceli fail)nägema siin .


Import tüüpi ja standardid raamatukogu

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Import tüüpi ja standardid raamatukogu

Saada kommentaare selle teema.

Saate importida tüüpi ja standardite alates ABACUS teegi faili. Võimalik on ka eksportida tüüpi ja standardid oma ABACUS faili kaasa ABACUS teegi faili.

Importida tüüpi ja standardid raamatukogu oma arhitektuuri

1. Veenduge, et teil on ABACUS failiavatud ja Explorer akenkuvatakse.

2. Vali Fail | Avatudavada ABACUS teegifail.

3. Arvelaud Raamatukogu avab teise sakkidega lehel Exploreri aken ja pead lahti haakida see sakkidega lehel saaks drag-and-drop alates selle esialgse ABACUS faili.

4. Tõmba ja lase lahtitüüpi ja standardite raamatukogu oma arhitektuuri.

- Või -

1. Vali Fail | New ...

2. Loo uus ABACUS failipõhineb ABACUS teegifail.

Eksportida tüüpi ja standardid oma arhitektuuri arvesse raamatukogu

1. Veenduge, et teil on ABACUS failiAvatud on Explorer akenkuvatakse, mis on ABACUS teegifailavatud ja Raamatukogu Windowkuvatakse.

2. Tõmba ja lase lahtitüüpi ja standardid oma arhitektuuri raamatukokku.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi


Kopeerimine ja kleepimine

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Kopeerimine ja kleepimine

Saada kommentaare selle teema.

Võite kopeerida kogu või osa oma arhitektuuri ja kleepige see teises kohas puu.

Kopeerimiseks

1. Paremklõpsobjekt, mida soovite kopeerida.

2. Valima Koopia.

Kleepimiseks

1. Liigu puu leida koht, kuhu soovite kleepida kirje.

2. Paremklõpsfiliaali kohta soovite seda kuvada jooksul.

3. Valima Pasta.

4. Elementi kopeerida algse nime (kui teil kopeerida originaal filiaal - siis saab nimeks "Copy of ...").

Vaata ka

Kuidas arhitektuuri esindatud ABACUS


Otsimine ja asendamine esemed oma arhitektuuri

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Otsimine ja asendamine esemed oma arhitektuuri

Saada kommentaare selle teema.

Leiate ja vahetage konkreetset komponenti, ühendus, tüüp standard või vara kasutades ABACUS "Leia ja vahetage rajatis.

Et leida objekti

1. Klõpsake sõlme puu soovite otsida jooksul.

2. Valima Edit| Leidmavõi vajutage Ctrl + F.

3. Sisesta teksti kirjeleida ka "Leia mida väljale.

4. Vajuta Leia Next.

Kuni asendama Elemendi

1. Klõpsake sõlme puu soovite otsida jooksul.

2. Valima Edit| Vahetagevõi vajutage Ctrl + H.

3. Sisesta tekstikirjeleida ka "leida, mida väljale ja tekst asendada see on" Asenda "väljale (või midagi kui väli tühjaks).

4. Vajuta Leia Nextleida esimese astme "Leia mida" teksti ja kliki Vahetage asendada see näiteks koos "Asenda" teksti või kliki Asenda kõikasendada kõiki juhtumeid.

Teil on võimalik:

o Match oma seisukohti,

o Match terve sõna,

o Otsi alates projekti algusest,

o Ignoreeri arhitektuur - mis on arhitektuur sõlmed ise. Kõik sõlmed all arhitektuuri tippude nagu osad ja ühendused ikka otsida,

o Ignoreeri komponendid - see on osa sõlmed ise,

o Ignoreeri ühendused - mis on seotud sõlmed ise,

o Ignoreeri standardid - see on kõik, arhitektuuri, komponentide ja seotud standard sõlmede ignoreeritakse,

o Ignoreeri tüübid - mis on tüüpi sõlmed ise. Iga piirang sõlmede all tüüpi sõlmed ikka otsida,

o Ignoreeri malle ja sisu - see on malli sõlmed ise samuti malli osa ja seotud sõlmed all neid,

o Ignoreeri omadused - see on kogu vara, nimi, väärtused ja mõõtühikud on kõik mudeli elemente ignoreeritakse,

o Ignoreeri kirjelduse - mis on kirjeldatud kõik mudeli elemente ignoreeritakse.

Vaata ka

Kuidas arhitektuuri esindatud ABACUS


Laiendamine ja kokkuvajumine puu

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Laiendamine ja kokkuvajumine puu

Saada kommentaare selle teema.

Kui sõlme puu sisaldab alakomponentides ja kogud, siis on väike [image] või [image] kirjutama oma vasakule. Te võite klõpsata [image] laiendada sõlme ja vaata alamkomponendi ja ühendused. Samuti võite klõpsata [image] kokkuvarisemise sõlme varjata alakomponendina ja ühendused (et teha rohkem ruumi või tüve lihtsam aru saada).

Võite laiendada kogu sõlm, mille puhul kõik tema sub-keskused on võimalik laiendada, ja nende sub-sõlmed ja nemad ... jne Samamoodi saab kollaps kogu sõlm - sulgeda mitmel tasandil korraga .

Lisaks on võimalusi laiendada ainult arhitektuuri elemendid (st komponendid ja ühendused), osad või ühendused.

Laiendada või ahendada kogu sõlme (ja selle sub-sõlmed, jne)

1. Paremklõpssõlme.

2. Valima Laienda | Kõik võiKokkuvarisemine.

Laiendada kogu arhitektuuri (s)

1. Paremklõpskohta arhitektuurid või arhitektuuri.

2. Valima Laienda | Kõik.

Laiendada elemendid

1. Paremklõpskohta arhitektuurid või arhitektuuri.

2. Valima Laienda | Elements.

Laiendada komponendid

1. Paremklõpskoostisosade, osa või sub-komponent.

2. Valima Laienda | Komponendid | Kõik.

Laiendada ühendused

1. Paremklõpsühenduste kohta, ühendus või sub-ühendus.

2. Valima Laienda | Ühendused | Kõik.


Ühinevad esemed

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Ühinevad esemed

Saada kommentaare selle teema.

Kui sa ühendada esemeid?

Sa oleks ühendada punkte, kui teil on kaks (või rohkem) objektide oma mudel, mis on paremini esindatud ühe astme. On palju olukordi, kui sa tahad seda teha, sealhulgas:

· Selle tulemusena impordib uued andmed oma mudel, mis võivad dubleerida või asendada olemasoleva informatsiooni. Näiteks kui teil importida uuendatud versioon tabelisse oma mudel.

· Aja jooksul duplikaadid "sama komponent on loodud ja soovid puhastada neid duplikaadid.

· Kui Teil ei ole juhul-kui-stsenaariumi ja objekte, mida modelleerimine tegelikult ühinevad tegelikkus. Näiteks, kui sa ühinevad kaks osakonda oma organisatsiooni, või kui ühinevad kaks servereid.

Mis saab ühendada?

Järgmised tüüpi objekte toetavad ühendamist:

· Standardid

· Component ja ühenduse tüübid

· Komponendid ja ühendused

Kuidas ühendada esemeid

Algatada ühendamise, kasutades hiire paremat nuppu, tõmmake üks punkt explorer teisele. Objekt, mida tõmmates on allikas ja objekt, lohistada peale on valitud alal. Pärast vabastamist hiire parema nupuga siis esitatakse koos menüü, kust saab valida ühendada kaks toodet. Sa pead valima, kas soovite säilitada või üle kirjutada alal. Seda on selgitatud allpool.

Ühendamine aga parem drag menu

Mis vahe on säilitada ja kirjutades alal?

Säilita või ülekirjutamise seadeid dikteerib, mis juhtub, kui nimi, kirjeldus või omaduste vahel allikas ja sihtpunkt punkte mängu.

Kui Säilita Sihtkoht on valitud

· Sihtkohaks nimi ja kirjeldus hoitakse.

· Iga omadused, mis eksisteerivad üksnes allika lisatakse kohtades.

Kui ülekirjutamine Sihtkoht on valitud:

· Sihtkohaks nimi kirjutatakse allikast.

· Sihtkohaks kirjeldus kirjutatakse allikast, kui allika kirjeldus on tühi.

· Iga omadused, mis eksisteerivad üksnes allika lisatakse kohtades.

· Väärtus ja Unit egi, et on olemas nii allikas ja sihtpunkt kirjutatakse allikast, kui allikas väärtuspäev või üksus on tühi.

Erijuhud

· Tüübid: Kui ühinevad tüübid, õigused ühendatakse, on "pessimistlik" viisil, nii et kui luba käsitleb allikas ei eksisteeri kohtades oleks lisada, ja kui see ei eksisteeri kohtades, siis kui üksikute loa kasutaja rühm (Loo, Loe, ajakohastada või kustutada) ei sobi (üks antakse üks eitas), siis luba ei antaks.

· Komponendid: Kui ühinevad komponendid, alakomponendina allikas on rännanud kohtades ja on ühinenud alakomponentides sihtkoha, kui nende nimed on identsedSõltumata nende liigist.Lisaks mitu alakomponentides allika sama nime saab kombineerida ühte alamkomponendi sihtkoha.

· Sidemed: Ülemine tase ühendused ise peavad mõlemad on sama manuseid (või selle puudumist), et lubataks ühendada. Kui ühinevad ühendused, sub-ühendused allikas on rännanud kohtades ja on ühinenud sub-ühendused kohtades, kui nende nimed on identsed JAnende kinnitused on identsed. Kui manuseid ei ole identsed, allikas sub-ühendused lisatakse sihtkohta ilma ühinevad sobitamise ühendused juba olemas. See on nii, et manused on kadunud.


Määratlemine ja heakskiitmine piirangud

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Määratlemine ja heakskiitmine piirangud

Saada kommentaare selle teema.

Struktuur ja omadused arhitektuuri võib piirata kasutades piiranguid. Piirangud saab rakendada komponendi tüübid ja ühenduste tüübid piirata struktuuri arhitektuuri kahel viisil. Esimene võimalus on piirata hierarhiamääratledes "lapsevanem peaks / peab olema laps" ja "laps peaks / peab olema vanema" suhteid. Teine võimalus on piirata topoloogiamääratledes "osa peaks / peab olema lisatud ühendus" ja "ühendus peaks / peab olema lisatud osa" suhteid. Lisaks piiranguid võib kohaldada omadusi osa liike, ühenduse tüübid, mallid, seisukohti, arhitektuur, diagrammidja 3D vaated piirata arhitektuuri (s) kahes lisaviise. Esimene võimalus on seada andmetüüpvara piirata kehtivad väärtused, et see võib olla, nimelt; Tekst, Integer, Decimal, Date / Time, Boole'i ​​või loetelu. Teine võimalus on, et määrata nõutavvara staatust näitavad, kas väärtus tuleb sisestada vara (Märkus: Vajalikud piirangud kehtivad ainult omadused komponent ja ühenduse tüübid). Lisateave vara piirangud on sätestatud Muutuvad omadused komponent, ühendus või tüübi abiteema. Kui piiranguid ei ole määratud, siis on võimalik kinnitada arhitektuuri vastu piiranguid. ABACUS hoiatab mis tahes piirangud, mis on rikutud.

Oluline kindlaks teha, millised piirang (s) määratleda peitub täpset keelt kasutatakse, et kirjeldada piirang. Sest hierarhia piiranguid need on tavaliselt vormist "nimisõnadvõib / peab / peavad jaotada n nimisõnad"Või"nimisõnadvõib / peab / peavad olema summeeritud nimisõnad"Jne Näiteks"Osakonnadtuleb jaotada Võistkonnad"Või"Rakendusedvõib jaotada kaheks: Moodulid". Suhe topoloogiast piiranguid tavaliselt on need vormist"nimisõnadsaab / peaks / peab verb nimisõnad". Näiteks, "Protsessid võib olla sooritavad Võistkonnad"Või"Rakendusedon majutatud Serverid". Nüüd näed iga piirang on erinevaid saa / tohiks / must" täpsustus "ja neid võib olla 3 tüüpi;

· Vabatahtlik- Need on tavaliselt kasutada sõnu / lauseid nagu; "võib", "ei", "ei", "valikuliselt" jms

· Soovitatav- Need on tavaliselt kasutada sõnu / lauseid nagu; "peaks", "soovitas", "soovitas" jms

· Kohustuslik- Need on tavaliselt kasutada sõnu / lauseid nagu; "must", "on", "ei", "ei", "tuleb" jms

Sõltuvalt piiranguliigi (hierarhia või topoloogiast) ja Määrajate kasutatakse kirjeldades seda, konkreetsed kitsendus (s) peaks olema määratletud (vt allpool). Eespool hierarhia näide "Osakonnadtuleb jaotada Võistkonnad"Tuleks määratleda" Parent peab olema Child "piirang ja seatud täitmise täitmisele. Eespool topoloogia näide"Protsessid võib olla sooritavad Võistkonnad"Üks peaks ainult luua kaks (2)" Connection peab olema lisatud Component "piiranguid ükskõik kummast otsast teostatud ühenduse tüüp. Täpsemalt järgmised piirangud soovitatakse määratleda (vt allpool) jaoks erinevaid võimalusi;

· Hierarhia piiranguid;

o Nimisõnad võib ollajaotada Nimisõnad BVõi Nimisõnad B võib ollasummeeritud Nimisõnadvõi Nimisõnad B peaks olemasummeeritud Nimisõnad- Define "Laps peab olema Parent" piirang lapsega tüübiga Nimisõna B, vanem tüüp, nagu ümar ja jõustamise hoiatatud.

Märge

See tähendab, et kui laps on olemas, peaks olema vanem teatud tüüpi. Kui ei ole, siis saad hoiatuse.

o Nimisõnad peaks olemajaotada Nimisõnad B- Define "Parent peab olema Child" piirang koos vanema tüübiga ümar, laps tüübiga Nimisõna B ja jõustamise hoiatatud.

Märge

See tähendab, et kui vanem on olemas, see peaks olema lastele teatud tüüpi. Kui ei ole, siis saad hoiatuse.

o Nimisõnad peab olemajaotada Nimisõnad B- Define "Parent peab olema Child" piirang koos vanema tüübiga ümar, laps tüübiga Nimisõna B ja jõustamiseks jõustamist.

Märge

See tähendab, et kui vanem on olemas, peavad olema lapsed, et teatavat tüüpi. Kui ei ole siis saan veateate.

o Nimisõnad peab olemasummeeritud Nimisõnad B- Define "Laps peab olema Parent" piirang lapsega tüüp, nagu ümar, vanem tüüp, nagu Nimisõna B ja jõustamiseks jõustamist.

Märge

See tähendab, et kui laps on olemas, peab olema vanema teatud tüüpi. Kui ei ole, siis saab viga.

· Topoloogia piiranguid;

o Nimisõnad võib olla verb Nimisõnad B- Define kaks (2) "Connection tuleb lisada Component" piirangud. Neist esimene on koos Allikas lõpuks ühenduse tüüp verblisatud ümar osa tüüpi ja täitmine seatud jõustada. Teine, kel on Sink lõpuks ühenduse tüüp verblisatud Nimisõna B osa tüüpi ja täitmine seatud jõustada.

Märge

See tähendab, et kui ühendus on olemas, siis tuleb ühendada komponendid teatavat liiki. Kui ei ole siis saan veateate. Üldine see tagab, et need komponendid, siiski võimalik ja ei tohi omavahel ühendatud. Kuid kui nad on ühendatud, ühendused õige tuleb kasutada.

o Nimisõnad peaks olema verb Nimisõnad B- Define kaks (2) "Component tuleb lisada Connection" piirangud. Esimene on koos ümar osa tüüpi kinnitatud Allikas lõpuni verbühenduse tüüp ja täitmine seatud hoiatatud. Teine, kel Nimisõna B osa tüüpi kinnitatud Sink lõpuni verbühenduse tüüp ja täitmine seatud hoiatatud. Lisaks määratleb kaks (2) "Connection tuleb lisada Component" piirangud. Neist esimene on koos Allikas lõpuks ühenduse tüüp verblisatud ümar osa tüüpi ja täitmine seatud jõustada. Teine, kel on Sink lõpuks ühenduse tüüp verblisatud Nimisõna B osa tüüpi ja täitmine seatud jõustada.

Märge

See tähendab, et kui osad mõlemat tüüpi olemas, tuleks neid külge ühendada teatud tüüpi. Kui ei ole sa saad hoiatuse. Lisaks tähendab see, et kui ühendus on olemas, peab olema ühendatud komponentide määratud tüüpi. Kui ei ole siis saan veateate. Üldine see tagab, et kui osad nendest liike, saad hoiatusi kui nad ei ole omavahel ühendatud.

o Nimisõnad peab olema verb Nimisõnad B- Define kaks (2) "Component tuleb lisada Connection" piirangud. Esimene on koos ümar osa tüüpi kinnitatud Allikas lõpuni verbühenduse tüüp ja täitmine seatud jõustada. Teine, kel Nimisõna B osa tüüpi kinnitatud Sink lõpuni verbühenduse tüüp ja täitmine seatud jõustada. Lisaks määratleb kaks (2) "Connection tuleb lisada Component" piirangud. Neist esimene on koos Allikas lõpuks ühenduse tüüp verblisatud ümar osa tüüpi ja täitmine seatud jõustada. Teine, kel on Sink lõpuks ühenduse tüüp verblisatud Nimisõna B osa tüüpi ja täitmine seatud jõustada.

Märge

See tähendab, et kui osad mõlemat tüüpi olemas, nad tuleb ühendada, et ühendus teatud tüüpi. Kui ei ole siis saan veateate. Lisaks tähendab see, et kui ühendus on olemas, peab olema ühendatud komponentide määratud tüüpi. Kui ei ole siis saan veateate. Üldine see tagab, et kui osad nendest liike, saad vead kui neid ei ole omavahel ühendatud.

Et määrata piirangu

1. Veenduge, et teil on ABACUS failiavatud ja Explorer akenkuvatakse.

2. Exploreri puu laiendada Tüübid | Component liigidvõi laiendada Tüübid | Connection liigid.

3. Paremklõpsosa tüübi või ühenduse tüübiks valige Lisa kitsendus.

Lisades piirang

Et määrata hierarhia piirang, kus lapsevanem peab olema konkreetne laps

4. On Lisa kitsendusakna märgistada Loo piirangkast all Parent Peab olema lapse piirangpiirkond.

5. Valige tüübikinnitusmärgialates rippmenüüst et soovite määrata, kui laps on osa tüüpi valisid punktis 3.

Märge

Kui on juba aktiveeritud "Parent Peab olema Child" piirang määratletud vanema osa tüüpi ja teine ​​laps tüübikinnitusmärgi siis see uus piirang ei tohiks käsitleda kui "JA". See on tüüp peab olema vanema lapse A- jalapse B tüüpi, mis iganes täitmise taset (nt puuetega hoiatas ega täitma - vaata punkt 7) on määratud iga piirang.

6. Soovi korral saab määrata minimaalse ja maksimaalse arvu komponente osa nimetatud tüüpi, mis peavad olema lapsed tüübikinnitusmärgi paremklõpsu 3. etapis.

7. Vali, kas soovid piirang olla Invaliidistunud, Hoiatasvõi Sunniviisiline.

Märge

Keelatud piirangud ignoreeritakse alates piirang valideerimise hoiatas piiranguid hakkab tootma Hoiatus Kontroll aken, kui nad avastatakse ja täidetakse piiranguid hakkab tootma viga valideerimisaknas kui avastada. Veelgi enam, kõik vead tuleb lahendada enne Ettevõte Server Projekti saab teoks.

8. Vajuta Okei.

Märge

Piirang kuvatakse explorer puu all tüübikinnitusmärgi paremklõpsu 3. etapp nool tähistab suunas piirang ja sel juhul märkida alla ja paremale. Tabalukk on värvitud vastavalt sellele, kas piirang on keelatud (hall), hoiatatakse (kollane) või sunniviisilise (punane).

Parent peab olema lapse hoiatas piirang

Et määrata hierarhia piirang, kus laps peab olema konkreetne lapsevanem

4. On Lisa kitsendusakna märgistada Loo piirangkast all Laps peab olema Parent piirangpiirkond.

5. Valige tüübikinnitusmärgialates rippmenüüst et soovite määrata, kui vanem osa tüüpi paremklõpsu 3. etapis.

Märge

Kui on juba aktiveeritud "Laps peab olema Parent" piirang määratletud lapse tüübikinnitusmärgi ja teise vanema osa tüübikinnituse siis see uus piirang ei tohiks käsitleda kui "VÕI". See on tüüp peab olema laps vanema A-tüüpi võivanema B tüüpi ja jõustamise tase (nt hoiatatakse või sunniviisiliselt - vt järgmine samm) peaks olema sama teisiti täitmisele piiranguid alati alistada hoiatas ones.

6. Vali, kas soovid piirang olla Invaliidistunud, Hoiatasvõi Sunniviisiline.

Märge

Keelatud piirangud ignoreeritakse alates piirang valideerimise hoiatas piiranguid hakkab tootma Hoiatus Kontroll aken, kui nad avastatakse ja täidetakse piiranguid hakkab tootma viga valideerimisaknas kui avastada. Veelgi enam, kõik vead tuleb lahendada enne Ettevõte Server Projekti saab teoks.

7. Vajuta Okei.

Märge

Piirang kuvatakse Explorer View all tüübikinnitusmärgi valitud samm 5. nool tähistab suunas piirang ja sel juhul märkida üles ja vasakule. Tabalukk on värvitud vastavalt sellele, kas piirang on keelatud (hall), hoiatatakse (kollane) või sunniviisilise (punane).

Laps peab olema vanema hoiatas piirang

Et määratleda topoloogia piirang, kus osa peab olema kinnitatud kindla ühenduse

4. On Lisa kitsendusakna märgistada Loo piirangkast all Component tuleb lisada kitsenduspiirkond.

5. Valige ühenduse tüüpalates rippmenüüst et soovite täpsustada, kuna lisatud ühendamine tüübikinnitusmärgi paremklõpsu 3. etapp (või valige tüübikinnitusmärgialates rippmenüüst et soovite täpsustada, kuna lisatud osa, kui sammus 3 sa paremklõpsu ühenduse tüübiks.)

Märge

Kui on juba aktiveeritud "Component tuleb lisada" piirang määratletud osa tüübikinnituse ja muu ühenduse tüüp, siis see uus piirang ei tohiks käsitleda kui "JA". See on osa tüübikinnituse peab olema lisatud ühendus A- jaühenduse tüüp B, mis iganes täitmise taset (nt puuetega hoiatas ega täitma - vaata punkt 7) on määratud iga piirang.

6. Soovi korral saab valida ühendusviis rollmis sa tahad lisada piirang. Svalib konkreetse roll (st kas Allikas või Sink) alates rippmenüüst.

7. Vali, kas soovid piirang olla Invaliidistunud, Hoiatasvõi Sunniviisiline.

Märge

Keelatud piirangud ignoreeritakse alates piirang valideerimise hoiatas piiranguid hakkab tootma Hoiatus Kontroll aken, kui nad avastatakse ja täidetakse piiranguid hakkab tootma viga valideerimisaknas kui avastada. Veelgi enam, kõik vead tuleb lahendada enne Ettevõte Server Projekti saab teoks.

8. Vajuta Okei.

Et määratleda topoloogia piirang, kus ühendus peab olema lisatud konkreetset komponenti

4. On Lisa kitsendusakna märgistada Loo piirangkast all Ühendus peab olema lisatud piirangpiirkond.

5. Valige ühenduse tüüpalates rippmenüüst et soovite täpsustada, kuna lisatud ühendamine tüübikinnitusmärgi paremklõpsu 3. etapp (või valige tüübikinnitusmärgialates rippmenüüst et soovite täpsustada, kuna lisatud osa, kui sammus 3 sa paremklõpsu ühenduse tüübiks.)

Märge

Kui on juba aktiveeritud "Connection tuleb lisada" piirang määratletud ühenduse tüüp ja teine ​​osa tüüpi kasutavad sama ühendust roll(st kas Allikas või Sink), siis see uus piirang ei tohiks käsitleda kui "VÕI". See on ühenduse tüüp peab olema lisatud komponent A-tüüpi võiosa B tüüpi ja jõustamise tase (nt hoiatatakse või sunniviisiliselt - vaata punkt 7) peaks olema sama teisiti täitmisele piiranguid alati alistada hoiatas ones. Pange tähele, et kui on mitu piiranguid, mis on seotud rolltäpsustatud kui "mis tahes" (vastandina konkreetselt Source või Sink), siis peab iga otsas ühendus peab olema lisatud üks komponent tüüpi täpsustatud piiranguid.

6. Soovi korral saab valida ühendusviis rollmis sa tahad lisada piirang. Svalib konkreetse roll (st kas Allikas või Valamu) alates rippmenüüst.

Märge

Kas Allikas või Sink rolli tuleb selgelt valitud välja Attachment kolonn olema olevaist tuleb näidata osa kataloog .

7. Vali, kas soovid piirang olla Invaliidistunud, Hoiatasvõi Sunniviisiline.

Märge

Keelatud piirangud ignoreeritakse alates piirang valideerimise hoiatas piiranguid hakkab tootma Hoiatus Kontroll aken, kui nad avastatakse ja täidetakse piiranguid hakkab tootma viga valideerimisaknas kui avastada. Veelgi enam, kõik vead tuleb lahendada enne Ettevõte Server Projekti saab teoks.

8. Vajuta Okei.

Real-time mudeli kontrollimiseks ja piirangkinnitamine

ABACUS sisaldabreaalajas mudeli kontrollimiseks ja Valideerimine funktsiooni kohe ekraan mõju antud kasutaja operatsioon avaldada hoiatusi ja vigu praeguse projekti, mis tuleneb mistahes hierarhia ja topoloogia piiranguid, mis on kindlaks määratud. Tuleb märkida, et kõik vead tuleb lahendada enne Ettevõte Server Projekti saab teoks.

Reaalajas piirang valideerimise funktsioon on kõige märgatavam, kui asustamisega diagrammid või otse Explorer aknas. Eelkõige järgmiste toimingute ajal, juhised on antud kasutades Värikorostukset selle mõju toimimise avaldavad hoiatusi ja vigu praeguse projekti;

1. Kui lohistada elemente peale või ümber diagrammi värvi vanema (või kinnitamiseks) komponendi (kui üldse) piiri on värvitud vastavalt skeemile allpool kirjeldatud.

2. Kui ühendate komponentide kasutades paremklõpsu drag | Ühenda funktsioon loendist ühenduse tüübid on värvitud vastavalt skeemile allpool kirjeldatud.

3. Kui ühendate komponentide diagrammid abil Connector režiim muutub hiirekursori värve vastavalt skeemile allpool kirjeldatud.

4. Kui lisate alakomponentides saadaolevate Component tüübid on värvitud vastavalt skeemile allpool kirjeldatud.

Üldiselt järgmised värvid osutamiseks kasutatakse mõjude kasutaja operatsioon on kõigi hoiatuste ja vigade praeguse projekti;

Black : No mõju hoiatusi või vigu.

Green : Operatsioon on selgesõnaliselt kooskõlasmääratletud hierarhia ja topoloogia piiranguid projekti.

Red : Operatsioon on selgesõnaliselt rikkudesmääratletud hierarhia ja topoloogia piiranguid projekti ning selle tulemusena hoiatused ja / või vigu.

Taust mudeli kontrollimiseks ja piirangkinnitamine

ABACUS sisaldab Valideerimine funktsioon, et kuvada kõik hoiatused ja vead praeguse projekti, kuna mingeid piiranguid, mis on kindlaks määratud. Tuleb märkida, et kõik vead tuleb lahendada enne Ettevõte Server Projekti saab teoks.

Märge

Valideerimine tuleb käsitsi käivitada kaudu "Kinnita / Vaata Project piirangud" nuppu Peamine tööriistariba . Valideerimisaknas on vaikimisi peidetudaga ilmub tööriistariba nupule vajutamist. Nägema Kohandamine liidese kuidas seda taas näha ja potentsiaalselt jätke see püsivalt välja. Samuti saate topeltklõpsu rida Kontroll akna "hüpata" asjaomastele osa projektist.

Valideerimine aknas

Vaikimisi veergude valideerimisaknas kirjeldatakse järgmiselt;

Hoiatus või viga: See veerg näitab ikoon, kas rikkumine on hoiatus (kollane kolmnurk hüüumärgiga) või viga (punane ring ristiga).

Hulk: See veerg kuvab rikkumise number.

Märge

Ainult 200 rikkumist näidatakse korraga ja kui seal on rohkem kui 200 rikkumised projekti Start, Eelmine, Järgmine ja Lõpprida navigaatorite ülaosas paremal aknas saab sirvida täiendavaid rikkumisi.

Kirjeldamine: See on täielik kirjeldus rikkumise sealhulgas Entity ja kitsenduste kohta.

Entity: See veerg kuvab Entity muret rikkumisega.

Tüüp: See veerg näitab elemendi tüübi jaoks Entity.

Arhitektuur: See veerg kuvab Arhitektuur mille jooksul rikkumine on aset leidnud.

Avastatud: See veerg näitab aega, et rikkumist ei tuvastatud.

Ots

See on kasulik kahanevalt poolt avastatud veerus (nagu näidatud dialoog eespool), et tagada viimaste rikkumiste ilmuvad "top" nimekirja.

On mitmeid kasutajana käitumise muutmiseks tausta mudeli valideerimise. Näiteks to muuta värve kasutada piiranguteta rikkumiste midagi muud kui vaikimisi RedKlõpsake Tools | Options ... seejärel minna Valideeriminetab, ja määrata värvid kaudu Muuda nupud.

Valideerimine valikud

Käsitsi kinnitada piiranguid

1. Paremklõpskohta Arhitektuuridsõlm, mis tahes arhitektuuri või kuskil kas Komponendidvõi Sidemedosa Explorer View ja valige Saate piirangud.

Kinnita piiranguid

2. Klõpsake Detailidnuppu Hoiatusedaknast näha, kui arhitektuuri rikub mingeid piiranguid, mis on kindlaks määratud.

Märge

Rikkumised näidatakse vaid neid piiranguid, mis on seatud hoiatatakse või jõustada. Lisaks sõnastust hoiatus hõlmavad "peaks", kui piirang oli lihtsalt hoiatuse või 'must', kui see hakkas kehtima.

3. Vajuta Okei.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi


Areneb oma arhitektuuri

Navigation: asustamine oma arhitektuuri> asustamine käsitsi> Extra Valikud>

Areneb oma arhitektuuri

Saada kommentaare selle teema.

Arhitektuurid saab selgelt välja arenenud ja hierarhia arhitektuur loodud. Nii areneb oma arhitektuuri ABACUS, mitmeid täiustatud arhitektuursed lahendused on võimalik luua, võrrelda ja baasjoonitud. Eesmärgid (või mõõdikud) võib määratleda iga number arhitektuuri omadused olemasolevate struktuuride.

Lihtne viis kaaluda areng arhitektuur on seotud selle mõiste järeltulija arhitektuuri. Kui arhitektuur on arenenud, et koopiavanema arhitektuuri loomisel. Seda eksemplari võib öelda, et otsene järglanealgse lapsevanemarhitektuuri.

Märge

Selles online aidata dokumentatsiooni ja ABACUS töövahenditega ise sõna arenemaon sagedamini kasutatud kui mõiste järglanePalun pange tähele, et mõlemad viitavad sama funktsionaalsust.

Areneda olemasoleva arhitektuuri

1. Veenduge, et teil on ABACUS failiavatud ja Explorer akenkuvatakse.

2. Valige asjakohane arhitektuuri soovite arenema explorer puu.

3. Paremklõpsarhitektuur ja valige Arenemamenüüst.

Arenev valinud Arhitektuur

4. Tekkiv arhitektuuri alla ilmub valitud arhitektuuri.

Evolved Arhitektuur

Märge

Tekkiv arhitektuur saab ümber paremklõpsuga arhitektuuri ja valimine Nimeta.Lisaks on kõik skeemid ja katalooge arenenud arhitektuur saab automaatselt "diff" vastu algtaseme arhitektuuri et ta arenenud.

Eesmärkide seadmine oma arenenud arhitektuur

Eesmärkide seadmine oma arenenud arhitektuur võimaldab teil luua kriteeriumid, et hinnata arengut oma arhitektuuri. Eesmärgid on määratud omandi liike ja nende nimed, omadused olemasolevate oma arenenud arhitektuuri. Eesmärgid võib ka käsitsi määratletud ja lisas, et sa arhitektuuri. Järgige allpool toodud samme seada eesmärgid.

Eesmärkide seadmine on olemasolevate omadused oma arenenud arhitektuur

1. Veenduge, et teil on ABACUS failiavatud ja Explorer akenkuvatakse.

2. Valige Vahendid | Set GoalsPeamenüüst baar.

3. Goal sisendaken kuvab.

Goal sisestamise aken

4. Vajuta Olemasolevadnuppu.

5. Vali Propertyaken kuvab.

6. Vali kinnisvara soovid eesmärgiks seadnud oma arenenud arhitektuuri ja klõpsa Okeinuppu.

7. Valitud eesmärk nüüd ilmuvad Goal sisendaknas.

8. Valige eesmärk ja kliki Editnuppu.

9. Edit Goalaken kuvab.

Märge

See aken võimaldab muuta vara nimetus ja liik, et eesmärk on kajastada, samuti kõige suurema ja kõige väärtus (või minimaalne / maksimaalne väärtus) kõnealuse kinnisvara. Need väärtused on leitud, võrreldes kõigi arhitektuuri ja leida väikseima ja suurima väärtuse iga selle konkreetse vara. Neid väärtusi saab ka käsitsi määratletud. Näiteks, kui sa olid seadnud eesmärgiks, et vara nimega Vastus (Ave)ja tüüp KäitumineTeie halvim ja parim väärtus võib peegeldada tehingu kiirus vajalik optimaalse töö (parim hinna) ja tehingu kiirus vaja ainult peamine taotluste läbivaatamist (halvim väärtus).

10. Kui asjaomased väärtused on määratletud valige Okei.

Eesmärkide seadmine on uued omadused oma arenenud arhitektuur

1. Veenduge, et teil on ABACUS failiavatud ja Explorer akenkuvatakse.

2. Valige Vahendid | Set GoalsPeamenüüst baar.

3. Goal sisendaken kuvab.

4. Vajuta Uusnuppu.

5. New Goalaken kuvab.

Märge

See aken võimaldab määrata vara nimetus ja liik, et eesmärk on kajastada, samuti kõige suurema ja kõige väärtus (või minimaalne / maksimaalne väärtus) kõnealuse kinnisvara. Näiteks, kui sa olid seadnud eesmärgiks vara nimega Vastus (Ave)ja tüüp KäitumineTeie halvim ja parim väärtus võib peegeldada tehingu kiirus vajalik optimaalse töö (parim hinna) ja tehingu kiirus vaja ainult peamine taotluste läbivaatamist (halvim väärtus).

6. Kui asjaomased väärtused on määratletud valige Okei.

7. Dialoogi Lisa kõik arhitektuurikuvatakse allpool:

8. Vajuta Jahlisada eesmärk kui vara kõigi asjakohaste arhitektuuri. See tagab, et uuesti määratletud eesmärk ja selle omadusi lisatakse kõik arhitektuurid failis. Kui te ei soovi sisaldama vara arhitektuur, saate klõpsata Ei ole.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Kasutaja staar krunt oma arenenud arhitektuur | Kasutaja hajuvusgraafik oma arenenud arhitektuur


Joonistus Tool

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Joonistus Tool

Saada kommentaare selle teema.

Joonistus Tool võimaldab luua erinevaid arhitektuurilisi skeemid ja diagrammid. Arhitektid traditsiooniliselt kasutatakse erinevaid joonised salvestada ja edastada disaini arhitektuuri. Kahemõõtmeline (2D) diagrammid on tavapärane viis dokumenteerimise ja edastamise erinevate süsteemi osade. Tüüpjoonistele tüüpi kasutatakse ettevõtte süsteeme on:

· Business protsessi mudeleid ja skeeme;

· Organisatsiooni skeem;

· Koostööskeemid;

· Entity-Relationship (ER) diagrammid;

· Andmevoo diagrammid (DFD on);

· Klassiskeemid;

· IDEF (sisaldab mitme eespool); ja

· UML (sisaldab mitme eespool).

Seal tõesti ei ole piiratud liiki skeeme, et on võimalik luua. ABACUS üritab tasakaalu diagramm paindlikkust säilitades terviklikkuse arhitektuuri ja selle vormid esindatus.

Loosimine keskkond on sakkidega ja dokk aknas sees peamine ABACUS taotluse. See aken sisaldab lõuend kus joonestamine ja kui joonistus aken on avatud teist dokitav aknas , Šabloon aknas on nähtav komplekt joonistus šabloonid. Šabloonsõel pane on 4 kaarti: Komponendid, ühendused, kuju ja ühendused. Lõuend ilmub valgel taustal ruudustik (kasulik paigutus).

Komponendid on esindatud erinevaid kujundeid, samal ajal kui ühendused on koostatud vastavalt juhendile jooned. Ühendused lisada komponente kasutades rollid (st kas Allikas või Sink) kuigi need ei ole näidatud esteetilistel põhjustel.

Ots

Kuigi diagrammidon väga kasulikud näidates erinevaid süsteemi osade, nad on piiratud nende mastaapsuse, mistõttu ABACUS kasutab 3D visualiseerida keeruline süsteem struktuure.

Te võiksite

1. Avage Diagramming Tool

2. Loo uus skeem ja osa oma arhitektuuri

3. Kopeeri skeem ühes või mitmes arhitektuur

4. Lisa komponendid to skeem

5. Loo uus komponendid ja ühendused oma arhitektuuri (diagrammi) abil tööriist

6. Kustuta komponendid skeemilt

7. Kaasa manipuleerida ühendused

8. Muuda Display Properties komponentide ja ühendused.

9. Kasutades lingid skeem

10. Rakendada tüüpi kindlustusseltside ja seisukohti nii, et piirata skeemitüüpe mida saab välja.

Vaata ka

Asustamine oma arhitektuuri | Asustamine oma arhitektuuri käsitsi | Analüüsides Sinu arhitektuuri


Avamine skeemid

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Avamine skeemid

Saada kommentaare selle teema.

Joonistus stencil ja lõuend aknad ilmub automaatselt, kui skeem on avada ega luua. Ka siis, kui skeem on suletud, vastava sakkidega lehel lõuendile akna kaob ja kui enam joonised on avatud siis stencil akna sulgeda.

Kuni loomauus skeem

1. Veenduge, et teil onABACUS fail avatudsisaldab teie asustatud arhitektuuri.

2. Vajuta Diagramikooni tööriistaribal.

- Või -

2. Valima Sisesta| Diagram.

- Või -

2. Paremklõps Skeemidefiliaali antud Arhitektuurosa puu ja valige Loo Skeem.

3. Valige Arhitektuursoovite keskenduda alates rippmenüüst. Märkus: arhitektuur on juba valitud, kui sa kasutada ülal punktis 3 avab uue skeemi.

4. Valige Seisukoht soovite kasutada alates rippmenüüst. Märkus: valitud vaatenurgast filtreerib komponendid ja ühendused nimekirjad on vaid need saadaval seisukohalt.

5. Soovi valida vaade Filtreeri Vaatarippmenüüst eelvalimiseks komponendid ja ühendused valitud vaade. Märkus: see on tegelikult kasutades valitud vaates salvestatud päringu.

6. Valige Layout olema kas Radial või Võre.

7. Valige Komponendidja Sidemedmida soovite diagrammil alates standard element valiku aken .

8. Vajuta Okei.

Märge

Uus diagramm lisatakse Skeemidefiliaali arhitektuuri. See on vaikimisi antud nime, kus saab muuta hiljem parema nupu klõpsuga.Lisaks viimase riigi komponendi ja ühendus valikut filtrid salvestatakse joonisega tõhusalt säästa "päringu" kasutatakse, et luua diagrammi.

Avada olemasolevale skeemile

1. Konkreetsel asustatud arhitektuur, laiendada Skeemidepuusse.

2. Topeltklõps diagrammi, mida soovite avada.

Et säästa skeem

1. Veenduge, et teil on uus või olemasolev skeem avatudja olete teinud vajalikud muudatused. Märkus: tärniga "*" kuvatakse pärast vaade nimi kaartidega lehel päise kaudu, kui on muutusi salvestada.

2. Explorer vaade klõpsa Salvestanuppu või sain Faili| Salvestavõi vajutada Ctrl + SMuudatuste salvestamiseks oma arhitektuuri ja kirjutada see esitada.

Et säästa skeem nagu vaatepunkt

1. Veenduge, et teil on olemasoleva diagrammi oma ABACUS faili.

2. Paremklõpsjoonisel on Skeemideosa puu.

3. Valima Salvesta kui Skeem Seisukoht.

4. Sisestage nimi oma uue skeemi seisukohaltja klõpsa Okei.

Vaata ka

Joonistus Tool | Asustamine oma arhitektuuri | Analüüsides Sinu arhitektuuri


Kopeerimine diagrammid

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Kopeerimine diagrammid

Saada kommentaare selle teema.

Seal on 2 põhistsenaariumi kopeerimine olemasolevale skeemile; jooksul arhitektuuri või üle arhitektuur.

Kuni koopiaskeemjooksul arhitektuur

1. Veenduge, et teil onABACUS fail avatudsisaldab teie asustatud arhitektuurivähemalt ühe skeem.

2. Laienema Skeemidefiliaal (ja mis tahes nõutavatele Skeem rühmad) teatava Arhitektuurosa puu.

3. Valige diagramm, mida soovite kopeerida ja seejärel vajutage Ctrl + Cvõi paremklõpsja valige Koopia menüüst.

Märge

A koopia Skeem lisatakse Skeemidefiliaali sama arhitektuuri. See on "Koopia" lisatud algust nimi, Kus saab muuta hiljem vajutades F2 või paremkliki seeja valides Rename.

Kuni kopeerida skeem üle arhitektuur

1. Veenduge, et teil onABACUS fail avatudsisaldab teie asustatud arhitektuurisvähemalt ühe skeem.

2. Laienema Skeemidefiliaal (ja mis tahes nõutavatele Skeem rühmad) kohta Arhitektuurosa puujaoks arhitektuuri, mis sisaldab skeem, mida soovite kopeerida.

3. Valige diagramm, mida soovite kopeerida ning General omadusedakna Märkus Seisukoht et skeem on seotud (in väljale Tüüp).

4. Nüüd, laienema Skeemidefiliaal (ja mis tahes nõutavatele Skeem rühmad) kohta Arhitektuurosa puuTeiste arhitektuuri, mida soovite kopeerida skeem arvesse.

5. Paremklõps Skeemide sõlm (või Skeem grupp) Ja valige Loo diagramm .... Dialoogis ilmub valida Seisukoht mis oli märgitud ülaltoodud punktis 3 in rippmenüüst ülaosas paremal. Jäta kõike muud kui on ja klõpsa Okei. Skeem Nimi dialoogis sisestage nimi (varsti) kopeerida diagramm. Märkus: tühi skeem lõuendile vastavalt valitud vaatenurgast avatakse.

6. Tagasi diagramm, mida soovite kopeerida ja avatud, et paremklõpsusõlme ja valimine Avatud või lihtsalt topeltklõpsugaseda.

7. Vali taust lõuendil diagrammi, mida soovite kopeerida ja vajutage Ctrl + A. See valib kõik tõendid, et skeem. Nüüd vajutage Ctrl + Ckopeerida sisu lõikelauale.

8. Nüüd, tagasi tühi skeem arhitektuuris soovite kopeerida sisult, vali taustalõuend ja kas paremklõpsja valige Pasta või lihtsalt vajutage Ctrl + Vkleepida sisu. Pärast lühikest aega sisu on kõik võimalik kleepida uus tühi skeem.

Märge

Elemendid lisatakse tipptaseme uue arhitektuuri ja tuleb ümber korraldada või liideti olemasolevate sisu vastavalt.

Vaata ka

Joonistus Tool | Asustamine oma arhitektuuri | Analüüsides Sinu arhitektuuri


Populating skeemid

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Populating skeemid

Saada kommentaare selle teema.

Joonised ABACUS on midagi enamat kui lihtsalt suvalise esindused. Nad on kohandatud vaateid arhitektuur, vormindatud ja korraldatud näidata erilist tähendust.

Joonistus Tool jõustab hierarhiline struktuur arhitektuuri, nii et osad on visuaalselt pesastatud muud komponendid - tegelikult annab "pealtvaates" elemente. Kord osa või on ühendus määratletud arhitektuur, seda saab kasutada mistahes mitmeid erinevaid diagrammid. Oluline on, et tööriist on tihedalt seotud arhitektuurse mudeli, et tehtud muudatused kas üks on alati kajastub muu.

Tööriist töötab sidudes kujundeid eriline side ja osade liikide määratletud tüübid osa arhitektuuri. Need ühendused varieeruda sõltuvalt tüüpi skeemil tõmbamist ja on võimalik, et üht tüüpi komponent (või ühendamiseks) võivad olla erinevad esindustes erinevatele skeemidele, sõltuvalt kontekstist.

Et luua seos kuju ja osa või ühenduse tüüp

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Võimalikult ABACUS taotluse ja konfigureerida akna mõõtmed kui sa soovid.

3. Valige Kujundid tabvõi Pistikud tab šabloon aknas.

4. Aasta Tüüpfiliaali Explorer, leida komponent või ühenduse tüüp, mida soovite seostada kuju või pistik.

5. Vali valinud tüüpi element puu, lohista see üle Kujundid tab või Pistikud tab, ja pistad kuju või pesasoovid kasutada.

Märge

Võite kontrollida ühingu olete loonud valides komponendid või vahekaarti Ühendused šabloon akna, mis näitavad praegu seotud elemente.

Et lisada uusi kujundeid oma diagrammid / raamatukogu

1. Loo MS Visio skeem kujundid, mida soovite lisada oma skeemi ja importida MS Visio diagrammi .

Ots

On oluline, millise suurusega teete kapten kuju MS Visio sest ABACUS lõuend mõõtmed pikslites ja ainult millimeetrites üksuste MS Visio teisendada granularly et pikslit 4 pikslit 1 millimeeter suhe. Lisaks vaikimisi ABACUS kuju on tavaliselt 60 pikslit kõrged, nii et tõlgib 15 millimeetrit MS Visio. Mis tähendab soovitatav kapten kuju suurus MS Visioon 25mm laiune 15mm kõrgekui see tõlgib 100 pikslit lai 60 pikslit kõrged ABACUS.

Ots

Kui sa tahad olla natuke "ikoon" ülemises vasakus nurgas kuju, siis saate lihtsalt luua "ikoon" master MS Visio kuju, kasutades MS Visio Drawing Tool palett (pange tähele, et ainult lihtsad jooned, ringid ja ristkülikud on toetatud ja rasterdada / bitmap kuju eriti ei toetata). Pealegi, kui soovite, et ikoon on fikseeritud suurus / ulatusjooksul kuju ABACUS siis saate grupi "ikoon" master MS Visio kuju valides kõiki selle elemente, paremklõpsu üks element, valides Kuju | Nimel, siis paremklõpsake rühmitatud kuju ja valides andmed | Kuju andmed ..., valides Yes dialoogis ilmub ja siis lisades maa-Label seatud LockScale(märkida suur- "L" ja "S"), Type seatud Loogiline ja väärtus määratud olema TRUE (pange tähele, see on kõik suure algustähega).

Ots

Kui sa tahad olla osa kuju jääs tagi horisontaalselt või vertikaalselt (see on tüüpiline nn swimlane "kuju), siis saate paremklõpsake osa (de) kapten MS Visio kuju, et soovite külmutatud alates tagi ja valige Andmed | Kuju andmed ..., valides Yes dialoogis ilmub ja siis lisades maa-Label seatud LockXScalevõi LockYScale (märkida suur- "L" ja "S"), Type seatud Loogiline ja väärtus määratud olema TRUE (pange tähele, see on kõik suure algustähega), et lukustada horisontaalne või vertikaalne tagi võrra.

Ots

Et võimaldada värvus kuju ABACUS pärast importimist, mitte kuju alati on fikseeritud värvi on soovitav teha kapten MS Visio kuju kyllikseen läbipaistev ja siis kasuta sisseehitatud võime arvelaud värvi kuju tausta. See töötab ainult ristküliku või peaaegu ristkülik (nt ümardatud ristküliku) kujuga, kuna kogu ristkülikukujuline taust on värvitud.

2. Avage vastav diagramm ja valige Komponendid tabšabloon aknas.

3. Iga uue kuju, et soovite teha kättesaadavaks muu skeem Paremklõpskuju ja valige Lisa Kujundid Raamatukogu. See muudab kuju kättesaadavad Kujundid tab šabloon aknas.

4. Seostamine vastava elemendiga tüüpi uue kuju erinevusega kujundeid vastavat raamatukogu ülalkirjeldatud etappe.

Märge

Ainult lihtsa ja "vektor põhinev" kuju on toetatud ABACUS hetkel, st bitmaps ei toeta. Kuid vahendeid nagu Vector Magic ( www.vectormagic.com ) On saadaval, mis kergesti teisendada bitmap pilte vektor põhinev kuju (st SVG formaadis), mida saab avada MS Visio ja seega kasutada ABACUS kohta eespool juhiseid.

LisadesKomponendid ja ühendused

Joonistus Tool võimaldab teil lisada olemasolevate komponentide ja ühendused hoidlast või luua uusi komponente ja seoseid kui on joonistus skeem. Kuna komponendid ja ühendused on loodud diagrammid, nad on samaaegselt lisatud sisse hoidla. Seal on kolm soovitatav viise, lisades komponente skeemja kolm soovitatud viise, lisades ühendused skeem:

Et luua täiesti uue komponendi või ühendus skeemtrafarettide

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Valige Komponendidvõi Sidemedtab šabloon aknast näha seonduvaid kujundeid. Ainult need kujud saab kasutada uue mudeli elemente.

3. Klõpsa ja lohistaüks olemasolevatest seotud kujundeid peale tõmbamine lõuend. Uus element ilmub lõuendile ja explorer puu.

4. Alusta kirjutamistnimi uus element Dialoogi ja olemasolevate elementide sobitatakse on soovitanud ja saab valida lisamise asemel uue elemendi arhitektuuri.

5. Vajuta Okei.

6. Kui kuju tilgutati olemasoleva komponendi, siis kas saab laps selle osa (kui kuju tuli Komponendidtab) või pööratakse sellele koostisosale (kui kuju tuli Sidemedtab).

Märge

Mõnikord on vaja kohandada uute osade või ühendus mõnda teise koha arhitektuurne hierarhia abil explorer.

Et koht olemasoleva komponendi või ühendus alates hoidla peale skeem

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Ole kindel, et sul on nii tööriist ja Exploreri aknad vaadatav.

3. Kui Explorer, leidke osavõi ühendus(element) soovid lisada diagramm.

4. Klõpsa ja lohistavalitud element peale diagramm. Kuju esindav element ilmub lõuendile.

Märge

Kui tüüp valitud element on juba seostatud kuju, vastava kuju ilmub lõuendile. Kui aga ei ole määratletud ühistu selle konkreetse elemendi vaikimisi kuju (ristkülik) ilmub lõuendile kui Rakendada skeem Seisukohad võti on sisse lülitatud mispuhul kuju ei lisata skeemile.

Ots

Kui komponent on asetatud skeemi, mis on ühendatud teise osa juba diagramm, Joonistus Tool päringu, kui soovite, et näidata seost (s) vahel. Samuti, kui on lapsed sellest osa Joonistus Tool päringu, kui soovid lisada lapsi, on rekursiivne viisil.

Kuni luua seoseid 2 komponentide või ühendatud osa diagrammi kasutades dünaamilise ühenduspesa

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Hõljuma üle komponendi skeemi, mida soovite ühendada teise osa ja märkad 2 ikoonid ilmuvad väljaspool ülemises paremas piiri kuju, nagu allpool näidatud. Märkus: top ikoon on luua ühendus, kus kohal viibib kursor komponent on olla allikas, põhja ikoon on luua ühendus, kus kohal viibib kursor komponent on olla valamu.

3. Move kursor soovitud ikoon ja kliki ja lohistaikooni kas üle teisele osale või vaba ruumi lõuendile nagu allpool näidatud.

4. Et ühendada olemasoleva komponendi valida Lisada ...kirje pop-up menüü ja vajadusel Sirvi alammenüü valida olemasolevate ühenduse tüübid.

- Või -

4. Et luua sidus komponent valis alates New ...kirjed pop-up menüü ja vajadusel Sirvi alammenüü valida olemasolevate ühenduse tüübid nagu allpool näidatud. Alusta kirjutamistnimi uus element Dialoogi ja olemasolevate elementide sobitatakse on soovitanud ja saab valida lisamise asemel uue elemendi arhitektuuri.

Märge

Kättesaadavus punkte pop-up menüü ja alammenüü reguleerib piirangud meta-mudel.See on ainus kehtiv allikas või valamu osa liike, mis määratakse kindlaks ühenduse piirangute esitletakse kui Kinnitage, et ... ja New ... menüüvalikud.

Kuni taasavada element valimise dialoogi ja panna olemasolevad komponendid või ühendused hoidlast peale skeem

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Vajuta Avatud Element Selectionnuppu Diagramm tööriistariba. Märkus: element valiku dialoog avab viimase seisu filtrid salvestatud.

3. Vali täiendavat sisu, mis on vajalik, et lisada diagramm ja klõpsa Okei. Märkus: uus sisu lisatakse selge ruumi lõuendile ja diagramm saab hiljem sätestatud kord kaudu Layout skeemnuppu Diagramm tööriistariba.

Kasutades tasutavormKujundid

Sageli on soovitav luua visuaalseid elemente diagramm puhtalt esteetilistel põhjustel. Neid elemente võib aidata parandada esitus ja skeem, kuid nad ei ole range arhitektuurilise tähenduse. Joonistus Tool võimaldab kasutada vormiga kujundid pakkuda joonistus paindlikkust.

Lisada vormiga kuju skeem

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Valige Kujundidvõi Pistikudtab šabloon aknas.

3. Klõpsa ja lohistaüks kuju vahel või pistikutega peale tõmbamine lõuend. Uus element ilmub lõuendile - kuid eiExploreri puu.

Märge

Vabakäeline kujundid "mitteliitunud" kuju, sest neil ei ole seost ühegi konkreetse komponendi või ühendus arhitektuurse mudeli.

Kuni kuvada hoidla info vormiga kujuSskeem

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. ParemklõpsVabakuju kuju ja valige Annotatsioon | Display.

3. Vali kuvada kas Skeem nimi, Joonis Kirjeldus, Skeem Property, Seisukoht Nimivõi Arhitektuur nimi.

Märge

Teksti vormiga automaatselt, kui selle aluseks olev hoidla andmete muudatused.Sel viisil skeem "tiitliplokk" saab luua ja siis lihtsalt kopeeritakse, diagrammid.

Kasutades Floating Kujundid

Ujuvad kujud on sisuliselt üks võimalus esindada komponendid skeem. Mõtle organisatsiooni võti osakonda: tegevjuht, turundus, müük ja arengu.

Tree View

Need vaheseinad võivad olla visuaalselt esindatud erinevaid tasandeid:

Kihiline Vaata

Või nad võivad olla visuaalselt esindatud ajatatud / Ujuva viisil, et näidata hierarhia:

Vahelduvad / Floating Vaade

Viimane esindus kasutab mõistet ujuvad kujundeid.

Et teisendada kihiline osa kuju ujuv kuju

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Valige osaTeie skeem soovite esindavad ujuva kuju või assotsieerunud kuju Komponendidtab šabloon aknas soovite kõigil juhtudel, kui ujuvad kujundeid.

3. Paremklõpsake kuju ja valige Float Component kontekstimenüüst, mis ilmub. Märkus teemant juhib ühendustvanemalt komponent (s) to the ujuva komponent (s).

4. Klõpsa ja lohistakomponendi soovitud kohta. Kui ujuvkomponent on valitud see on sinine kontuur.

Et teisendada muutuva komponendi kuju ümber kihiline kuju

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Valige osaTeie diagramm, mis on praegu näidatakse ujuvad kuju või assotsieerunud kuju Komponendidtab šabloon aknas soovite kõigil juhtudel, kui kihiline kujundeid.

3. Klõpsa ja lohistaujuva osa (de) tagasi vanema (te) (vastavalt teemant juhib ühendust). Märkus: Kui te seda ei tee, siis kui sa teisendada osa (de) tagasi on kihiline hierarhias oma mudel võib olla mõjutatud.

4. Paremklõpsake kuju ja tühista valik Float Component kontekstimenüüst, mis ilmub. Pange tähele, et teemant juhib ühendustvanemalt komponent (s) to the ujuva komponent (s) kaob.

Kopeerivad

Joonistus Tool võimaldab teil lisada sama komponent diagramm mitu korda iga täiendava visuaalse näiteks sellest osast diagrammil nimetatakse replica. See on eriti kasulik diagrammid, kui komponenti on suur arv ühendusi külge pandud ja on eelistatav, et näidata komponendi eri kohtades lähemale päritolu iga ühendused või diagrammide kui üks-mitmele seos komponendi on eelistatav, et näidata, kasutades ujuva turvaelement (ülalkirjeldatud) komponendiga eri kohtades peal "paljudel" komponendid on see seotud.

Märge

Saad kinnitada / lahti ühendused / algsest näiteks sellest osast diagrammil (nagu alati), vaid ka ükskõik millise kopeerivad, aga kui ühendused lisatakse automaatselt diagramm nad on seotud esimese astme komponendi diagrammil vaikimisi.

Märge

Kopeerivad liita omavahel paremklõpsu ja dragvalides seejärel Merge kopeerivadSiiski ühineva replica erineva komponendi tulemuseks muul kopeerivad kaovad diagramm.

Märge

Ei ole visuaalset erinevust originaal näiteks komponendi kohta skeem ja kõik koopiad. Lisaks paremklõpsake menüü esialgse komponendi skeem ja kõik koopiad on identsed, näiteks Show Explorervõttes teil sama komponent Tree View hoidla (aka mudel). Kuid paremklõpsu komponent Tree View hoidla ja valides Minemaja sirvimist skeem koos kopeerivad alati teid vanim "Näiteks komponendi skeemil. Tavaliselt see on originaal näiteks, et lisati diagramm, kuid kui see originaal näiteks hiljem kustutada või ühendatakse replica siis minge hüppab vanim ülejäänud kopeerivad et lisati.

Kuni lisada replica kuni skeem

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Paremklõpsake olemasoleva komponendi diagrammil ja vali Loo Replica.Replica valitud komponendi luuakse paremal algse komponenti.

- VÕI -

Vali olemasoleva komponendi skeem ja vajutage Ctrl + Cvõi paremklõpsake olemasoleva komponendi diagrammil ja vali Koopia. Nüüd paremklõps asukohaga diagramm, mida soovite replica ja valige Kleebi Replica. Märkus: Vajutades Ctrl + V (või paremklõpsu ja valides Paste) loob originaali koopia komponent EI replica.

- VÕI -

Klõpsa ja lohistakomponendist Puuvaates hoidla (aka mudel) peale diagramm, kus osa on juba olemas.

Ühenduse konfigureerimine Mütsid / Ends

Joonistus Tool võimaldab teil sümboli määramiseks kasutatakse otstes ühendustorustikus kas fikseeritud sümbol või sümbol sõltub vara taga ühenduse.See on eriti kasulik diagrammid kus suunas ühendus on vajalik tuleb näidata või diagrammide kus cardinality seosest (või suunas) sisaldub vara ühendus iseenesest nt "Üks-mitmele" vs "Paljud-mitmele" (või "Allikas Sink" vs "Sink Allikas").

Kuni seadistada ühendus mütsid / lõpeb skeem

1. Veenduge, et teil on uus või olemasolev skeem avatud.

2. Valige Ühendageioonetab šabloon aknas.

3. Right-cnilpsamaüks seotud ühenduse tüübid ja valige Seadista Caps ....

4. Sest püsiühenduse kork / lõpus kas allikas või valamu otsas ühendus veenduge asjakohaste Fikseeritud raadionupp ja seejärel ühendust lõpus sümbol lahtikäiv, nt "Arrow Head" ja "Diamond".

- VÕI -

Sest vara põhinev ühendus kork / lõpus kas allikas või valamu otsas ühendus veenduge asjakohaste Kasutades Propertyraadionupp, klõpsake "..." nuppu ja vali vajalik vara ja siis kõrvuti ühendus lõpus sümbol siseneda vara väärtust, mille jaoks konkreetne seos sümbol on näha.

Märge

Mitu vara väärtust antud ühendus lõpus sümbol võib kanda eraldatud komadega.Näiteks Dialoogi näitab, et kui "Andmed | Kardinaalsusega vara väärtus on "Üks-mitmele" siis allikas otsas ühendus on kaks rida lööki läbi ja valamu otsas ühendus on üks rida insuldi läbi ja siis fan-out kahe line lööki lõpus.

Seadista Caps dialoog

Vaata ka

Joonistus Tool | Asustamine oma arhitektuuri | Analüüsides Sinu arhitektuuri


Manipuleerides skeemid

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Manipuleerides skeemid

Saada kommentaare selle teema.

Kui skeem on loodud elemendid, mis tunduvad võib ümber korraldada ja nende suurust vastavalt soovile.

Et liikuda ühe komponendina skeem

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Vajuta-ja-hoiamis tahes osa liigutada. Kui valitud komponendil on vanem, vanem osa on esile tõstetud.

3. Kuna element ontirisid emaettevõtte osa ja üle muud komponendid, "potentsiaal" vanemad saavad esile. Värvilahendus selgub mõju operatsiooni on kõigi hoiatuste ja vigade praeguse projekti ja kirjeldatakse Määratlemine ja heakskiitmine piirangud . Sel moel saab graafiliselt navigeerida hierarhia alates "pealtvaates.

4. Vabastaminehiirenuppu tilk element oma uude asukohta.

Märge

Võite kasutada ka klaviatuuri ümber paigutada elemente joonisel lõuend. Lihtsalt vali komponent või vabas vormis kuju, mida soovite teisaldada ja kasutada nooleklahve asub klaviatuuril liikuda kuju soovitud kohta.

Pange tähele, et kui tõmbad osa hiirega üle teise osa, "võimalikku" vanem osa on esile tõstetud kui ülemises vasakus nurgas komponent olete tõmmates kattub teise osa.

Ots

Vabakäeline ja Ujuvad kuju võimalik tellida paremklõpsuja valides Too ettevõi Saada tagaplaanilemenüüst. On oluline märkida, et komponendi kuju saab muundada vabavormilise kujudest selle paremklõpsukonkreetsete komponentide kuju ja valimine Teisenda FreeForm.

Muuta ühe komponendina skeem

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Kliki hold-dragüks komponent käepidemete ja suurust kuju soovitud suurus.

3. Teise säilitada kuju kuvasuhte, vajutage Shift + klõps-hold-drag.

Teisaldamiseks ühendus skeem

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Vajuta-ja-hoiamingit seost liigutada.

3. Vabastaminehiirenuppu tilk element oma uude asukohta.

Märge

Liigutada saab ainult ühendused, mis ei ole seotud ühegi komponendid. Kui nad on seotud, saate liikuda ainult vaba otsasVõi marsruuti ühendust .

Kustutamine osadega ja ühendused

Kui kustutamata osa või ühendus skeem, teil on võimalus kustutada kogu arhitektuuri. Iga komponent, mis kustutatakse arhitektuuri automaatselt eemaldatakse muid skeeme, kus ta ilmub. Kuna vormiga juhtudel esinevad ainult ühe skeemi, nende kustutamist ei mõjuta arhitektuurne mudel või mõne muu skeemi.

Kustutada osa või ühendus skeem

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Vajutamis tahes seotud ühenduse või selle osa, et see valida.

3. Vajutage Kustutamavõti kustutada diagrammi, või Shift + Deletekustutada selle kogu mudelit.

- Või -

2. Paremklõpsake iga seotud element või. Kontekstimenüüst ilmub.

3. Valima Kustuta Vaatavõi Kustuta Arhitektuurkontekstimenüüst.

Märge

Kui element, mida soovite kustutada arvates ei ole lapsi ja esineb ainult seda seisukohta, ABACUS küsib, kas soovite kustutada element hoidlast samuti.

Ettevaatust

Kustutades komponendi mudel, mis on lapse komponendid, lapsed ka potentsiaalselt kustutatakse vastavalt hoiatus dialoog.

Ühinevad komponendid

Soovi korral saab ühendada kaks komponenti olemasolevate Sama skeemi (ja sees arhitektuur). Seda võib teha mitmel põhjusel, näiteks, Kaks serverid eksisteerib ettevõtte infrastruktuuri- H01 ja H02. Need kaks serverid on esindatud kahe eraldi komponentide arhitektuuri. H01 on peetud tarbetu ja seega tuleb kasutusest kõrvaldada. Kõik olemasolevad rakendused töötavad H01 on nihkunud H02 (veel komisjonitasu). See muutus võib siis kajastub toimel "ühinevad" kaks komponenti H01 ja H02 diagrammil (ja jooksul arhitektuur).

Täpsema ülevaate ühinevate palun vaadake Ühinevad Kirjed teema siin .

Et ühendada kaks olemasolevat komponendid

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsake-hoidkeosale soovite ühendada ja dragsee peale komponent soovite ühendada see. Veenduge ülevaade kohtades komponent on esile tõstetud punane mis näitab, et see on valitud.

3. Valima Merge | Säilita Destinationvõi Ülekirjutamine Destinationmenüüst.

Märge

Säilita Destinationvalik säilitab väärtused kohtades komponendi omadused, kui need on olemas on pärit osa samuti.

Ülekirjutamine Destinationvõimalus kirjutab kohtades komponendi omaduste ühiseid omadusi kaugusel pärit komponent.

Muutuvad ühendused

Näidatud ühendused diagramm alatikajastada struktuuri määratletud arhitektuur ise. Joonistus Tool võimaldab teil eemaldada ühendused komponendid, neid liigutada, kõver neid, marsruuti neid ja uuesti lisada need muud komponendid.

Eemaldamiseks / külge saab ühendada alates / kuni osa

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Vajuta-ja-hoiakuidagi seotud.

3. Valimaühendus lõpp(st Allikas või Sink), Et soovid eemaldada / lisada. Märkus: ühenduse otsas on tähistatud väikese valge ringid ja varjutavad valge ring teise paneb 'tooltip "ilmuma vastava rollnimi(st kas Allikas või Sink).

4. Dragühendusotsa uude asukohta (kas tühi koht või komponent) ja vabasta hiirenupp.

Märge

Kui ühendus lõpuks asetatakse kehtiv komponent, kontuuri kohtades komponent on esile tõstetud katkendlik ülevaade. Värvilahendus selgub mõju operatsiooni on kõigi hoiatuste ja vigade praeguse projekti ja kirjeldatakse Määratlemine ja heakskiitmine piirangud . Kui vabastatud Selleks the Seoses ja komponendi automaatselt ühendatud(või juurde)Ja see kajastub arhitektuurse mudeli.

Marsruuti ühendust

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Aseta hiir üle ühendust.

3. Hoia Niheklahvi ja Vajutahiirenuppu panna ühendus ankur punkti. Vabastage Nihe võti. Saate eemaldada ankur punkti samaga operatsioon.

4. Vajuta-ja lohistageankurdamispunkti marsruuti ühendus.

Ots

KasutaAlt võtme asemel Nihevõti luua ortogonaalsed ühendused.

Kuni kõver või sirutadaühendus

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Aseta hiir üle ühendust.

3. ParemklõpstTa ühendus ja ilmuvast kontekstimenüüst valida Kõverjoon, Ortogonaalne või Sirge.

Ots

Kõik ühendusedantud tüüpi diagrammil saab seada Kumer, ristuva või Hetero paremklõpsu seotud line tüübi kohta Ühendused tab selle Šabloon aknasja valides Curve, ristuva või Sirge.

Kuni kinnistada ühele kindlale punktile serva kuju

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Vali ühendust.

3. Aseta hiir üle "Valge dot" lõpus ühendus.

4. Paremklõpstta ühendust lõpus ja ilmuvast kontekstimenüüst valida Ankru Endpoint Kujundiks.Liiguta ühendus lõpu soov asukohaga serva kuju.

VÕI

Hoia Ctrlklahvi ja clakkuda-ja-lohista Seoses lõpuni osutama soov asukohaga serva kuju.

Märge

Ühendused asetuks tegelik lõikepunkti nendega seotud kuju asemel piirdekasti et kuju.

Vaata ka

Joonistus Tool | Asustamine oma arhitektuuri | Analüüsides Sinu arhitektuuri


Joonis Tool omadused

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Joonis Tool omadused

Saada kommentaare selle teema.

Joonistus Tool toetab mitmeid joonistus funktsioone.

Suurendus

Skaalal diagrammil saab muuta kasutades zoom funktsioon.

Et vähendada skaala või "zoom in"

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Press Ctrlja "=" võti.

- Või -

2. Valige Suurendanuppu Diagramtööriistariba.

- Või -

2. Press Ctrlja rulli hiire ratast edasi. Märkus: Selles režiimis lõuendile suumib suunas, kus hiirekursor viibib lõuendile.

Et suurendada ulatuse või "välja suumida"

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Press Ctrlja "-" klahvi.

- Või -

2. Valige Vähendanuppu Diagramtööriistariba.

- Või -

2. Press Ctrlja rulli hiire ratast tagasi. Märkus: Selles režiimis lõuendile suumib väljapoole, kui hiirekursor viibib lõuendile.

Auto-layout

Paigutus komponendid diagrammil saab muuta automaatselt.

Et skeem kõik komponendid on skeem

1. Cnilpsama Layout skeemnuppu Diagramm tööriistariba.

2. Valimakumbki Radial paigutus või Võrgu skeem.

Märge

Radiaalne kujundus kasutab nn "jõu suunatud" algoritmi nii, et ühendatud osad on koostatud koos samas ei ole seotud komponendid on sunnitud peale. Grid kujundus kasutab fikseeritud laiuse ja kõrguse vahekaugus algoritm. See esiteks võimaldab kasutajal valida üldine skeem Kuvasuhe (nt 16: 9, A4 (Portrait), kiri (Landscape)) ja siis vahe külgedel ja vahel veerge ja ridu nagu allpool näidatud.Mis Grid paigutus vahel seost komponendid ei mõjuta layout, sest see lihtsalt korraldab komponendid tähestikuliselt (nime järgi) ülevalt-vasakult alt paremale lõuend. Mõlemad algoritmid vormiga kujundid ei liikunud.

Et skeem lapsed komponendid aastal üksikvanemaga on skeem

1. Paremklõpskõrgetasemelise komponent, kelle lapsed soovid automaatselt paigutuse.

2. Valima Layout Lapsed.

Märge

Vaikimisi ainult Radial Esitusalgoritm kasutatakse.

Muutuv Element Esteetika nagu Värv, Läbipaistvus, Shadows ja pööramine

Kõik diagramm elementidel on esteetika mida võib manipuleerida nagu soovitud. Juhul sarnased kujundid, neid aspekte saab seadistada kaupaja enamikel juhtudel ka Ühe astme. Juhul vabavormilise kujundeid, neid omadusi saab määrata Ühe astmelõuendile.

Märge

Iga ühe astme aspekte, mis on seatud seotud kujundeid saab "kirjutatakse" kui sama aspekt on muutunud vastava tüübi.

Et muuta värvi sellega seotud kuju või vormiga kuju

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või vormiga kuju lõuendile.

3. Valima Muuda värve.

4. Valige Fikseeritud Värvnupp (kui on olemas).

5. Vali Põhivärvinimed või Define Custom Colour dialoogis ja klõpsa Okei.

- Või -

4. Valige Gradientnupp (kui on olemas).

5. Vali kas horisontaalselt, vertikaalselt, Forward Diagonaal või tahapoole Diagonaal gradiendi suunas rippmenüüst ja klõpsa Okei.

6. Vali Põhivärvinimed või Define Custom Colour dialoogis eest Startja Otsja klõpsa Okei.

Märge

ABACUS värvitakse esiplaanil kuju, kui;
a) see on "lihtne" kuju ühe aluseks oleva graafilise elemendi (nt ring, ristkülik, hulknurk jne), või
b) see on "keeruline" kuju mitme alusvara subshapes, mis on kõik sama värvi / gradient nagu iga teine ​​või subshapes on LockScale = TRUE komplekti.
Kui ülaltoodud tingimused ei ole täidetud, siis tausta kuju on värviline.

Et valida värvi sellega seotud kuju vastavalt vara

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon aknas(EI joonisel lõuend).

3. Valima Muuda värve.

4. Valige Kasutades Property Raadio nupp.

5. Vali kinnisvara klõpsates "..." nuppu paremal tekstikasti.

6. Valige Range Raadio nupp.

7. Reguleerige Minja Maxväärtusi nagu soovitud. Märkus: kui tahes palju väiksem minimaalne väärtus on näidatud Min värvi ja mis tahes väärtus ületab maksimaalset ilmub nagu Max värvi. Ka siis, kui kasutate Loogiline, loetelu või Date / Time omadused väärtused konverteeritakse indeks järgmiselt; Loogiline (False = 0, True = 1), loetelu (täisarv vale 1 kuni n iga kehtiv väärtus nende kasvavas järjekorras täpsustatud Units valdkonnas) ja kuupäev / aeg (päevade arv alates 1. jaanuar 1900 - sealhulgas kümnendkohtade jaoks tunnid, minutid, sekundid osad - ja kui kuupäev on enne 1990. see on negatiivne arv).

8. Vali Põhivärvinimed või Define Custom Colour dialoogis eest Minja Maxja klõpsa Okei.

Ots

Kui Green (RGB - 128,255,0) valitakse Min värvi ja Red (RGB - 255,0,0) on valitud Max värvi jaoks vara väärtuse vahemikus 1kuni 4siis väärtus 1kuvatakse Green, Mille väärtus 2kui Kollane, 3kui Apelsinja 4kui Red.

Alternatiivina kinnisvara valikut 1kuni 3väärtus 1oleks sama Green, Mille väärtus 2kui Merevaikja 3kui Redaka "valgusfoori" või RAG staatus.

Sest vara vahemikus 1 kuni 5, kui Blue (RGB - 0,0,255) valitakse Min värvi ja Red (RGB - 255,0,0) valitakse Max värvida väärtus 1 on sama Blue, Mille väärtus on 2, kuna Vesi, Mille väärtus on 3, nagu Green, Mille väärtus on 4, kuna Kollane ja väärtus 5 kui Red.

Sest vara vahemikus 1 kuni 6, kui Violett (RGB - 255,0,255) valitakse Min värvi ja Red (RGB - 255,0,0) valitakse Max värvida väärtus 1 on sama Violett, Mille väärtus on 2, kuna Blue, Mille väärtus on 3, nagu Vesi, Mille väärtus on 4, kuna Green, Mille väärtus on 5, kuna Kollane ja väärtuse 6, kuna Red.

Ja lõpuks, et vara vahemikus 1 kuni 7 a väärtus 1 on nagu Violett, Mille väärtus on 2, kuna Tumesinine, Mille väärtus on 3, nagu Helesinine, Mille väärtus on 4, kuna Sinine Roheline, Mille väärtus on 5, kuna Green, Mille väärtus on 6 nagu Merevaik ja väärtus 7, kui Red

Märge

Vaata märkus eespool esiplaanil võrreldes tausta värvi.

- Või -

7. Valige Eriline väärtus Raadio nupp.

8. Klõpsake Edit Värvidnuppu.

9. Valige iga hinna ning kliki nuppu Määra värvusmäärata kindlat värvi iga väärtuse.

Märge

Vahemikus väärtused elementide diagrammil saab eeltäidetud.

10. Et lisada lisaväärtust värvid neile eeltäidetud (näiteks pärast vara hulk on ümberseadistamise) click Lisa Value.

Selleks, et muuta värvi läbipaistvust sellega seotud kuju või vormiga kuju

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või vormiga kuju lõuendile.

3. Valima Muuda värve.

4. Transparency paneel top liugur soovitud läbipaistvuse baasi värvi.

5. Kui Gradient või Kasutades Property võimalusi ei kasutata, Transparency paneel põhja liugur soovitud läbipaistvuse teist värvi.

6. Vajuta Okei.

Näidata varjudjaoks kõik seotud kujundeid skeem

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidtab šabloon aknas.

3. Valima Lisama Shadows.

Kuni näidata varju osa kuju või vormiga kuju

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Õigusnupugaosale või vormiga kuju lõuendile.

3. Valima Lisama Shadows.

Pööramiseks osa kuju ja vabas vormis kujundeid diagrammid

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Vali komponent kuju või vormiga kuju lõuendile soovite pöörata.

3. Paremklõpskohta kuju ja valige Pööraja siis valige asjakohane nurga soovite kujundi pööramiseks poolt.

Muutuvad Element annotatsioonid ja Vabakäeline Tekstipealdised

Kõik skeemi elemendid on annotatsioone mida võib manipuleerida nagu soovitud. Juhul sarnased kujundid, neid aspekte saab seadistada kaupaja enamikel juhtudel ka Ühe astme. Juhul vormiga kujundidja pistikudOntekstipealdisi saab seada Ühe astmelõuendile.Kaheksa (8) erinevat tüüpi marginaale võidakse kuvatakse skeemi elemente (nt nimi, tüüp, Property Value, Kinnisvara Marker, lisatud komponendid, lapsed (komponentide puhul), standardid ja ajatemplite (luua, muuta By jne)) on kahekümne viis (25) erinevatel ametikohtadel (nt Keskus - Väljaspool Top, sees vasakule - keskus, Õues Õigus - Väljaspool Bottom).

Märge

Iga ühe astme aspekte, mis on seatud seotud kujundeid saab "kirjutatakse" kui sama aspekt on muutunud vastava tüübi.Veelgi enam, kui 2 või rohkem märkusi samale positsiooni ainult ühe Font, Fondi stiil, Fondi värv ja suurus mida saab kasutada ja eraldaja (nt koma, tühik, uue rea) tuleb valida.

Näidata nimetuse või tüübi jaoks seotud koostisosa või ühendus

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või pesa lõuendile.

3. Valima Annotatsioonid.

Märge

Üksikisiku seotud kuju või pesa lõuendile pead valima Alistamine šabloon annotatsioonidMärkekastiga esimest korda.

4. Valige Uus Kommentaar tööriistaribal ja valige Nimi või Tüüp.

5. Dialoogis ilmub vali Näita, et on soovitav kaasa sulgudes ja font, stiil, Fondi värv ja suurus. Ka valida paigutuse valikuid, mis on vajalik sealhulgas horisontaalne ja vertikaalne viimine (nt märke asendisse) ja nurk (st pööramine). Valima Okei.

Et näidata vara väärtus jaoks seotud koostisosa või ühendus

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või pesa lõuendile.

3. Valima Annotatsioonid.

Märge

Üksikisiku seotud kuju või pesa lõuendile pead valima Alistamine šabloon annotatsioonidMärkekastiga esimest korda.

4. Valige Uus Kommentaar tööriistaribal ja valige Property Value.

5. Dialoogis ilmub valida omadus, klõpsates Kinnisvara: "..." nuppu ja valides vara Vali Property dialoogja valige Okei. Vali Kuvavalikud et soovitakse sealhulgas sulgudes ja font, stiil, Fondi värv ja suurus. Ka valida paigutuse valikuid, mis on vajalik sealhulgas horisontaalne ja vertikaalne viimine (nt märke asendisse) ja nurk (st pööramine). Valima Okei.

Et näidata vara marker jaoks seotud koostisosa või ühendus

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või pesa lõuendile.

3. Valima Annotatsioonid.

Märge

Üksikisiku seotud kuju või pesa lõuendile pead valima Alistamine šabloon annotatsioonidMärkekastiga esimest korda.

4. Valige Uus Kommentaar tööriistaribal ja valige Kinnisvara Marker.

5. Dialoogis ilmub valida omadus, klõpsates Kinnisvara: "..." nuppu ja valides vara Vali Property dialoogja valige Okei. Määra raadiuses SM pikslit ja värvimine meetod kas Colour Autor Range või Colour By Property ning määrata värve ülesandeid. Ka valida paigutuse valikuid, mis on vajalik sealhulgas horisontaalne ja vertikaalne viimine (nt märke asendisse) ja nurk (st pööramine). Valima Okei.

Näidata lisatud komponendid jaoks seotud koostisosa või ühendus

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või pesa lõuendile.

3. Valima Annotatsioonid.

Märge

Üksikisiku seotud kuju või pesa lõuendile pead valima Alistamine šabloon annotatsioonidMärkekastiga esimest korda.

4. Valige Uus Kommentaar tööriistaribal ja valige Lisatud komponendid.

5. Dialoogis ilmub, seotud komponente valida juurde tüübikinnitusmärgi klõpsates lisatud: "..." nuppu ja valides komponent kirjuta Set Component Type dialoogja valige Okei. Vali lisatud ühenduse tüüp klõpsates ühendatud: "..." nuppu ja valides ühenduse tüübiks Set Connection Type dialoogja valige Okei.Sest seotud ühendused valige ühendus lõpuks valides Allikas või Sink alates Connection Lõpp: rippmenüüsse. Nii nendega seotud komponente ja seoseid vali Näita, et on soovitav kaasa sulgudes ja font, stiil, Fondi värv ja suurus. Ka valida paigutuse valikuid, mis on vajalik sealhulgas horisontaalne ja vertikaalne viimine (nt märke asendisse) ja nurk (st pööramine). Valima Okei.

Näidata lapsed for seotud koostisosa

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidtab šabloon akna või assotsieerunud kuju lõuendile.

3. Valima Annotatsioonid.

Märge

Üksikisiku seotud kuju lõuendile pead valima Alistamine šabloon annotatsioonidMärkekastiga esimest korda.

4. Valige Uus Kommentaar tööriistaribal ja valige Lapsed.

5. Dialoogis ilmub vali Näita, et on soovitav kaasa sulgudes ja font, stiil, Fondi värv ja suurus. Ka valida paigutuse valikuid, mis on vajalik sealhulgas horisontaalne ja vertikaalne viimine (nt märke asendisse) ja nurk (st pööramine). Valima Okei.

Näidata standardeid jaoks seotud koostisosa või ühendus

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või pesa lõuendile.

3. Valima Annotatsioonid.

Märge

Üksikisiku seotud kuju või pesa lõuendile pead valima Alistamine šabloon annotatsioonidMärkekastiga esimest korda.

4. Valige Uus Kommentaar tööriistaribal ja valige Standardid.

5. Dialoogis ilmub vali Näita, et on soovitav kaasa sulgudes ja font, stiil, Fondi värv ja suurus. Ka valida paigutuse valikuid, mis on vajalik sealhulgas horisontaalne ja vertikaalne viimine (nt märke asendisse) ja nurk (st pööramine). Valima Okei.

Näidata ajamarkerite jaoks seotud koostisosa või ühendus

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Paremklõpsmis on seotud organisatsiooni kuju või konnektor Komponendidvõi Sidemedtab šabloon akna või assotsieerunud kuju või pesa lõuendile.

3. Valima Annotatsioonid.

Märge

Üksikisiku seotud kuju või pesa lõuendile pead valima Alistamine šabloon annotatsioonidMärkekastiga esimest korda.

4. Valige Uus Kommentaar tööriistaribal ja valige Loodud loodud, loodud Marker, modifitseeritud, mida on muudetud või modifitseeritud Marker.

5. Dialoogis ilmub, kui mitte marker, vali Näita, et on soovitav kaasa sulgudes ja font, stiil, Fondi värv ja suurus. Kui marker, määrata raadius SM pikslit ja värvimine meetod kas Colour Autor Range või Colour By Property ning määrata värve ülesandeid. Ka valida paigutuse valikuid, mis on vajalik sealhulgas horisontaalne ja vertikaalne viimine (nt märke asendisse) ja nurk (st pööramine). Valima Okei.

Fondi muutmiseks stiilis vormiga kujuvõi pesa

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Paremklõpskohta vormiga kuju või pesa lõuendile. Märkus: Kui ühenduspesa tekstipealdise ei näidata siis näidata connectvõi pealdis: ParemklõpsConnectvõija valige Annotatsioon | Näita tähistamine.

3. Valima Muuda Font.

4. Vali font, stiil ja suurus dialoogis ja valige Okei.

Fondi muutmiseks värv on vormiga kujuvõi pesa

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Paremklõpskohta vormiga kuju või pesa lõuendile. Märkus: Kui ühenduspesa tekstipealdise ei näidata siis näidata connectvõi pealdis: ParemklõpsConnectvõija valige Annotatsioon | Näita tähistamine.

3. Valima Muuda Font Värv.

4. Vali FontVärv (ja kujundab lingi värv) klõpsates "..." nuppu ja valides värvi Dialoogi ja valige Okei.

5. Vali Transparency tekstipealdise reguleerides liugur kus 0 on täiesti läbipaistev ja 255 on täiesti läbipaistmatu.

Teksti pööramiseks etiketil vormiga kujuvõi pesa

1. Veenduge, et teil on uus või olemasolev skeem avatud .

2. Paremklõpskohta vormiga kuju või pesa lõuendile. Märkus: Kui ühenduspesa tekstipealdise ei näidata siis näidata connectvõi pealdis: ParemklõpsConnectvõija valige Annotatsioon | Näita tähistamine.

3. Valima Pööraja siis valige asjakohane nurga soovite pöörata pealdis poolt.

Vaata ka

Joonistus Tool | Asustamine oma arhitektuuri | Analüüsides Sinu arhitektuuri


Kasutades lingid skeemid

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Kasutades lingid skeemid

Saada kommentaare selle teema.

Kujundid (vabas vormis ja komponendid) ja pistikud (vabas vormis või ühendused) jooksul diagrammid võib olla seotud olemasoleva arhitektuurse esindused ABACUS, kui ka väliseid faile / kaustu ja URL. Need seosed saab siis õnnestus (tekib, muutub ja kustutatud) kaudu ABACUS töövahenditega. Seda funktsiooni saab kasutada, et suurendada navigatsiooni ja üldine arusaam oma arhitektuuri skeemina.

Lisada linke teie diagramm

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Valige asjakohane kuju või pesa Teie skeem.

3. Paremklõpskujuvõi pesa.

4. Valima Avatud lingidja Lingidaken.

5. Vajuta Lisamaikoon ja New Linkaken.

6. Valige asjakohane Kataloog | Matrix | Skeem| 3D View| Chartnööpe, siis valige asjakohane andmebaas, maatriks, skeem, 3Dvõi skeem Arvestades praeguse arhitektuuri alates Linkrippmenüüst.

- Või -

6. Valige Kodulehtnupp siis sisestage asjaomane internetiaadress (nt http: //www.avolutiontarkvara.ee /)valdkonnas link veebilehele. Kehtib URL on vaja alustada üks 5stringe; http: // https: //, ftp: //,file:või \\. Kõik ruumid tuleb sisestada koos "% 20".

- Või -

6. Valige Absoluutne Faili | Suhteline Fail Raadio nupps,Seejärel klõpsa "..."Nuppu, et sirvida välise faili linki diagramm.

7. Vajuta Okeija uus link näidatakse lingid aknas. Märkus: Links akna suurust saab muuta, et näha täisnime, kui vaja.

8. Korrake samme 5-7luua rohkem sidemeid.

9. Et järgida loodud link, valige asjakohane link kuvatakse Lingidakna ja klõpsa Ava link.

Märge

Millal Mitme annotatsioone näidatakse jaoks kuju või pesa link kuvatakse esmalt annotatsioonile nimekirja kannete Muuda annotatsioonid dialoog.

Et jälgige oma skeem

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Valige asjakohane kuju või pesa Teie skeem.

3. Vajutaasjakohaste hüperlink (sinine allajoonitud osa nime) kuju või pesa joonisel avada ja vaadata esimest linki kujuvõi pesa.Märkus: Kursor tuleb muuta, et "käsi", kui link on valmis klõpsatud.

- Või -

3. Valige asjakohane kuju või pesa Teie diagramm.

4. Paremklõpskujuvõi pesa.

5. Valima Avatud lingid ja Lingidaken.

6. Valige asjakohane link, et soovid näha.

7. Vajuta Ava linknuppu, et avada ja vaadata asjakohaste link.

Kustutada lingid skeem

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Valige asjakohane kujuvõi pesaTeie diagramm.

3. Paremklõpskujuvõi pesa.

4. Valima Avatud lingid ja Lingidaken.

5. Valige asjakohane link, mis tuleb kustutada.

6. Vajuta Kustutamanuppu. ja link on eemaldatud Lingid aknas.

Näituse lingid skeem

Võite valida, mis on seotud diagramm, väline fail või web URL kuvatakse kuju silt on Ctrl + klõpsatud diagramm.

1. Veenduge, et teil on olemasoleva skeem avatud .

2. Valige asjakohane kuju või pesa Teie diagramm.

3. Paremklõpskujuvõi pesa.

4. Valima Avatud lingid ja Lingidaken.

5. Muutmiseks, et lingid klõpsa Liiguta üles | Liiguta allanupud paremal küljel Lingidaknas.

6. Esimene link, mis ilmub vasakul servas Lingidaken on link, mis kuvab kui Ctrl + klõpslingitud kuju või pesa nimi.

Vaata ka

Asustamine oma arhitektuuri | Asustamine oma arhitektuuri käsitsi | Analüüsides Sinu arhitektuuri


Skeem Seisukohad

Navigation: asustamine oma arhitektuuri> Kasutades Joonised>

Skeem Seisukohad

Saada kommentaare selle teema.

The seisukohtifunktsioon tagab, et komponente ja ühendusi, mida lisatakse diagramm peab olema tüüpi assotsiatsiooni eelnevalt defineeritud, enne kui nad on võimalik lisada diagramm. See funktsioon võimaldab piirata tüüpi diagrammid, mida võib teha, piirates kuju ja ühendused, mis on seotud komponendid ja Sidemedolemasolevate jooksul oma arhitektuuri.

Lubamine või keelamine täitmisele skeem seisukohti

Võime rakendada skeem seisukohti automaatselt vaikimisi lubatud. Et keelata / lubada seda funktsiooni kliki Tools | Options ...| Skeemtab, ja eemalda / valida Rakendada skeem Seisukohadkast vastavalt.

Märge

Kui te ei näe "Rakendada skeem Seisukohad"Variant diagrammil tab siis ei ole Designer add-on ja valik on vaikimisi.

Loomine täitmisele skeem vaatepunkt

1. Veenduge, et teil on ABACUS faili Avatud koos uurijaArvestades kuvatakse.

2. Explorer vaade paremklõps Vaadepunktsja vajuta Loo Skeem Seisukoht

3. Skeem Seisukohtaken kuvatakse.

4. Määra vastava nime skeemi seisukohaltja pange tähele, et vaatepunkt salvestatakse all Seisukohadosa explorer.

5. Skeem Seisukohtaken kuvatakse.

6. Nüüd klõpsa ja lohista asjakohaste komponentide tüüpide ja ühenduse tüübid oma arhitektuuri peale seisukohalt kuju sa soovid. Component tüüpituleb tirisid pealekujuaasta kujutab, samas ühenduse tüübidtuleb lohistada üks 5 line stiilis kujuaasta Pistikudtab.

7. Et päästa skeemi seisukohaltolete loonud klõpsa [image] ülemises paremas nurgas oma Skeem Seisukohtaknas.

Märge

skeemi seisukohaltvõib toimetanud parema nupu klõpsuga vaatepunkt ja valides Avatudvõi topeltklõpsuga vaatepunkt.

Synchonising uuendatud seisukohalt diagrammid

1. Veenduge, et teil on ABACUS faili avatud.

2. Kas paremklõps seisukohalt on Uurija akna all Meta-mudel | Seisukohadja valige Sync diagramm Kirjeldused ...

- Või -

3. Lähedane avatud ja uuendatud seisukohalt akna ja valige Jahaasta Sünkroniseeri et Seisukohtdialoog, mis kuvatakse.

4. Seisukoht SünkroniseerimineKuvatakse nagu allpool näidatud.

Linnukesed

· Lisa puuduv Kirjeldused- Iga uus kuju (komponendi tüüpi) või liides (ühenduse tüüp) liidud, mis on lisatud to seisukohaltsiis lisatakse vastav skeems (st nendešabloons)et on seotud seisukohalt.

· Ajakohastada olemasolevaidKirjeldused- Kõik ajakohastatud aspekte olemasoleva kuju (komponendi tüüpi) või liides (ühenduse tüüp) ühendused seisukohalt(nt värv, fondilaadide) on värskendatud vastav skeems (st nendešabloons)et on seotud seisukohalt.

· Eemalda ExtraKirjeldused- Kõik täiendavad kuju (komponendi tüüpi) või liides (ühenduse tüüp) liidud, mis on lisatud Euroopa diagrammid (st nende šabloonid), kuid ei asu vaatepunkttuleb eemaldada vastav skeems (st nendešabloons)et on seotud seisukohalt.

· Kirjutan üle Local Settings for lisatud või uuendatud Kirjeldused (Erinevused Only)- Kõik ajakohastatud aspekte olemasoleva kuju (komponendi tüüpi) või liides (ühenduse tüüp) ühendused seisukohalt(nt värv, fondilaadide) rakendatakse vastava elemendid diagrammid, mis on seotud seisukohalt.Ainult ajakohastatud "erinevused" tehtud seisukohalt on rakendatud nii et kõik olemasolevad kohalikud seaded diagramm, mis ei ole ajakohastatud seisukohalt jääb samaks.

· [image] Annotatsioonid – Nagu eespool vaid spetsiaalselt annotatsioonid.

Vaata ka

Joonistus Tool | Asustamine oma arhitektuuri | Analüüsides Sinu arhitektuuri


Asustamine kasutades kataloogid

Navigation: asustamine oma arhitektuuri>

Asustamine kasutades kataloogid

Saada kommentaare selle teema.

A kataloog võimaldab vaadata ja muuta komponentide või ühendused ja nende omadused lihtsas tabeli viisil.

Kuni luua uus kataloog Vaata ka ABACUS

Märge

Kuigi kõik Arhitekt kasutajad saavad luua uusi kataloogid, muudatused salvestada olemasoleva Kataloog on seaded kasutaja litsents vajab Designer add-on võime. See on "kaitsmaks" konfiguratsiooni olemasolevate kataloogid, mida võib jagavad paljud kasutajad. Kuid Arhitekt kasutab ilma Designer add-on siiski valida "Save As" uuele seadeid uue kataloogi. Ja muidugi kõik kasutaja litsentse saab valida "Loobu" mingeid muudatusi olemasoleva Kataloog. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja Designer add- võimekust. Ja pidage meeles, see on lihtsalt seadete kataloog, kõik tehtud muudatusi andmeid Kataloogis on koheselt rakendada hoidla, sõltumata.

1. Valige Insert | Kataloog.

2. Aasta pull-down valida Arhitektuur, mis sisaldab komponente võiühendused, mida soovite vaadata.

3. Aasta pull-down valida osa või ühenduse tüüp et soovid on toodud juhtudel kui "rida' Kataloogis.

4. kataloog hakatakse asustatirida iga astme valitud komponendi või ühenduse tüüp.

Märge

Vaikimisi vasemmanpuolimmaista Hierarhia Pathveerg (st hierarhia vanem komponendid või ühendused üle valitud juhtudel) ja 2. Nimi kolonni (st nimekiri valitud komponendi või ühendamiseks eksemplare) külmutatakse vasakul kataloogis. Et muuta kolonni külmutamine lohistada kolonnis eraldaja paremal Nimi kolonni. Sa saad ümber korraldadaveerud lihtsalt lohistades oma Veerupealkirjadel. Rakke veergude sinine allajoonitud on hüperlinke teiste elementidega projekti ja linke saab jälgida hoides Ctrl ja klõpsates linke. Postid võivad olla peidetud paremklõpsu veeru pealkirjale ja valige veerg | Peida veerg. Varjatud sambad saab varjamatu nupul Konfigureeri veerud tööriistariba nuppu ja kasutades seadistamine veerud dialoogi, nagu allpool näidatud, või valides noolt osa seadistamine veerud tööriistariba nuppu ja individuaalselt valides peidetud veeru (d) kas General Properties või failid kogudest. Read võivad olla rühmitatud nende veeru väärtused lohistades sarakeotsikko siniste rühmituse ülaosas kataloogi. Igal ajal saab topeltklõps Kataloog rida valijaja hüpatavastav osavõi ühendusExploreri aknas.Kinnisvara raku väärtused rasvases kirjas kui need on erinevad algoleku ja kaldkirja kus nad on ainult lugemiseks. Ajatempel, Kinnisvara ja lisatud Component kolonnid võivad olla värviline Vastavalt rakkude väärtused või kinnitatud osa vara väärtusest paremklõpsu veeru pealkirjale ja valige veerg | Muuda värve ... ja siis Värv poolt Timestamp või Colour By Property võimalus, aga ainult Nimekiri, Integer, Decimal, Boole'i ​​või Date / Time andmete tüübi omadused värvitakse. Kinnisvara väärtused Lisatud Component kolonnid võivad olla näidanud paremklõpsu veeru pealkirjale ja valige veerg | Näita Property ... ja siis Näita Property võimalus. Ja lõpuks, kus on Vajalik piiranguid seatud vara veerus võib neid näidatakse string (koos värvainega vastavalt nende jõustamise tase) paremklõpsu veeru pealkirjale ja valige veerg | Näita .

Kataloog

Kuni lisada / Näita veerge a Kataloog Arvestades ABACUS

1. Veenduge, et teil on Kataloog vaade avatud.

2. Varjatud sambad on võimalik eraldi varjamatu klõpsates nool paremale ja seadistamine veerud tööriistaribalja valides peidetud veeru kas Üldine, Omadused või Manused kogudest.

Märge

Linnukese kuvatakse kõrval näidatakse parajasti veerud kataloogi.Lisaks ainult teatud manuseid valmib all failid paragrahvi järgi piirangud mis on määratletud projekti. Eeskätt lisatuks kättesaadav näidata osa Kataloog komponent tüüpi kataloogi tuleb märkida kas allikas või valamu (mitte "Kõik") on "ühendus peab olema kinnitatud" piirang ühendust tüüp ja seal peab olema ka vähemalt üks osa nimetatud tüüpi kas allikas või valamu (mitte "Kõik") teiselt "lõpuks" sama ühenduse tüüp.

- VÕI -

2. Mitu sambad saab varjamatu (või tellida või fikseeritud) klõpsates Seadista veerud tööriistaribalja kasutades seadistamine veerud Dialog toodud allpool.

Märge

Praegu näidatakse veergudes näidatakse paneeli paremal olemasolevatele veerud kuvatakse paneeli vasakul. Olemasolevad sambad võib filtreeritud vastavalt Vali Saadaval veerudpull-down ja neid võib lisada, valides neid paneeli vasakul klõpsates Lisama nuppu inbetween kaks paneeli.

Seadista veerud dialoog

Kuni kustutada / peita veergu Kataloog Arvestades ABACUS

1. Veenduge, et teil on Kataloog vaade avatud.

2. Paremklõpsake veeru pealkirja veerus soovite eemaldada / peida ja valige Veerg | Peida veerg.

- VÕI -

2. Mitu veergude peitmise (või tellida või fikseeritud) klõpsates Seadista veerud tööriistaribalja kasutades seadistamine veerud Dialog eespool näidatud.

Märge

Praegu näidatakse veergudes näidatakse paneeli paremal olemasolevatele veerud kuvatakse paneeli vasakul. Praegu näidatakse veergudes võib peita valides veeru parempoolset paneeli ja klõpsates Eemalda nuppu inbetween kaks paneeli.

Asustada kasutades Kataloog Arvestades ABACUS

1. Kuni lisada komponent või ühendusValitud tüüpi kuni Kataloog (ja projekti) käsku Add New Component / Lisa uus Connection tööriistaribal. Rida peaks ilmuvad ja komponent või Seoses luuakse tipus tase Komponendid ja Ühendused kollektsiooni valitud Arhitektuur.

Märge

New komponendid ja ühendused lisatakse vaikimisi tipptasemel komponente või ühendused kogumise valitud Arhitektuur. Muutmiseks vanem uute osade või ühendused paremklõpsake hierarhia Path raku uue komponendi või ühendused rida ja valige Muuda Parent ...ja vali soovitud vanema (võttes arvesse piirang esiletõstmine ).

Märge

Uus rida / elemente lisada otse kataloogi kaudu "Add New" nuppu, kleepida kataloogi või loodud kaudu importivad kataloogi MS Excel on vabastatud filtreerimine kuni Kataloog on suletud. See on võimalik vajalikke toimetamine veeru väärtused, mis ei vasta praegune filtreerimiskriteeriumid kataloogi. Need uued element rida on tähistatud "+" sümbolile reas valijat raku alguses reas, mis on värvitud roheline kui element praegu vastab salvestatud filtreerimiskriteeriumid kataloogi (st jääb Kataloog kui taasavatud), ja punane kui seda ei juhtu.

2. Kuni eemaldada komponent või ühendusValitud tüüpi pärit Kataloog (ja projekti) valige rida ja kas ajakirjanduses Del klahvi või paremklõps real valija ja valige Kustuta Arhitektuur. rida peaks kaduma kataloogist ja see kustutatakse projekti.

Kuni filter kasutades Kataloog Arvestades ABACUS

1. Veenduge, et teil on Kataloog vaade avatud.

2. Kui filter rida ei näita ülaosas kataloogi siis klõpsa Näita Filter päisereastööriistariba nuppu.

3. Veerus soovid lisada filter, topeltklõpsake filter rida lahter, kuhu see näitab "(Kõik)".

4. Eest Ajatempel, hierarhia Path, nimivõi Kirjeldamineüldiselt sambad või Tekst, Integer, Decimal, Booleanvõi Kuupäev / aegvara veerud nuppu ... nuppu, mis ilmub paremal filter rea rakkude ja sisestada lahtrisse väärtused, mis tuleks lisada kataloogi.

Märge

Matching toimub justkui "*" metamärke rakendatakse automaatselt enne ja pärast iga string väärtused nii, et märge "kass" (ilma jutumärkideta) hõlmaks read "bobkass','kassnaine "või" taotkassioon "vms Mitu /" või "väärtused võivad olla kantud uued read Ctrl + Enter. Sest Integer ja Decimal vara veerud "ja" loogika võib lisada kasutades "&"(Ilma jutumärkideta) ja suurem kui / alla jne loogika võib kanda kasutades"> =','>','<"Ja"<="(Ilma jutumärkideta) nt "> = 50000 & <90000". Non-blank hinnatud ridu võib lisada sisestades "(Non-toorikud)"(Ilma jutumärkideta) ja Blank hinnatud ridu võib lisada sisestades"(Tühjad)"(Ilma jutumärkideta).Ja lõpuks, kõik filtrid on vaikimisi tõstutundetu nii kass "(ilma jutumärkideta) hõlmaks read" kass "," Kass "või" CAT "jne tõstutundlikult, sisestage"(Case)"(Ilma jutumärkideta) enne string nt (Case) Kass "(ilma jutumärkideta) sisaldaks üksnes read" Kass "neid.

5. Eest Manusedveerud Standardid veerud või Nimekiri vara sambad klõpsake noolt nuppu, mis ilmub paremal filter rea rakkude ja valige lahter väärtused ruudud, et tuleks lisada kataloogi.

Märge

The '(Vali kõik) märkeruut võimaldab kõigi teiste ruudud, tegelikult ka kogu olemasolevat rida. The '(Non-toorikud) ruut hulka kõik mitte-tühjad hinnatud rida. The '(Tühjad) ruut hulka tühje hinnatud rida. Ja lõpuks, lülitades välja konkreetse hinnatud ruudud automaatselt Puhasta (Vali kõik) "ja" (Non-toorikud) "ruudud järjepidevuse.

6. Vajuta Okei kohaldada filter.

Kuni lubada / keelata filtreerimine a Kataloog Arvestades ABACUS

1. Veenduge, et teil on Kataloog vaade avatud koos filter rakendusuuringute.

2. Vajuta ruut vasakul filter järjest.

Kuni filtri eemaldamiseks a Kataloog Arvestades ABACUS

1. Veenduge, et teil on Kataloog vaade avatud koos filter rakendusuuringute.

2. Et eemaldada individuaalne veerus filter paremklõps veerupäisel ja valige Veerg | Clear filtreerimine.

3. Et kustutada kõik filtrid klõpsake Valikud tööriistariba nuppu ja valige Clear Filter Seaded.

Päästma / Salvesta kui aKataloog vaade

Märge

Kuigi kõik Arhitekt kasutajad saavad luua uusi kataloogid, muudatused salvestada olemasoleva Kataloog on seaded kasutaja litsents vajab Designer add-on võime. See on "kaitsmaks" konfiguratsiooni olemasolevate kataloogid, mida võib jagavad paljud kasutajad. Kuid Arhitekt kasutab ilma Designer add-on siiski valida "Save As" uuele seadeid uue kataloogi. Ja muidugi kõik kasutaja litsentse saab valida "Loobu" mingeid muudatusi olemasoleva Kataloog. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja Designer add- võimekust.Ja pidage meeles, see on lihtsalt seadete kataloog, kõik tehtud muudatusi andmeid Kataloogis on koheselt rakendada hoidla, sõltumata.

1. Veenduge, et teil on uus või olemasoleva Kataloog vaade avatudja olete teinud vajalikud muudatused.

2. Aasta Kataloog vaadetööriistariba klõpsa Salvestanuppu, et salvestada Kataloog vaade ja formaati muutusi.

Märge

Kui te ei ole nuppu Salvesta Kataloogis Vaateribal siis ei ole Designer add-on ja sa oled ainus võimalik Salvesta kuimingeid seadeid, muutub uue kataloogi, kui lähete sulgeda olemasolev andmebaas.

3. Kui KataloogNimiIlmub dialoog (tänu sellele, et uus kataloog) sisestage nimi kataloog ja vajutage Okei.

Kuni ekspordiks MS Excel Kataloog

1. Veenduge, et teil on Kataloog vaade avatud.

2. Klõpsake Ekspordi Excelisse Kataloog tabelissetööriistariba nuppu.

3. Vali failinime päästa MS Excel kataloogi. Vajuta Salvesta.

Märge

Vaikimisi eksporditud MS Excel Kataloogi failinimi kataloogi nimi lõppmärgistega Arhitektuur nimi sulgudes, nt "Projektid (2014 Tegelik) Xlsx". Sa saad muuta kõik see, sealhulgas kas failiformaat on olla Xlsx või .xls. Arhitektuur nimi on kantud meelde kasutaja, et iga Kataloog on konkreetne sisu (st ID veerus ja reas 1) et ta saaks olla ümar otsa tagasi kasutades Import MS Excel Kataloog kohta allpool.

Märge

Vaikimisi peidetud veerg jooksul eksportinud MS Excel kataloog sisaldab unikaalset ID iga elemendid ABACUS hoidla. See võimaldab kõikidest muudatustest, mis on tehtud sees MS Excel tuleb "sobitada up", et olemasolevaid elemente ABACUS impordi (vt allpool). Kuid kasutada seda ainulaadset ID-"sobib kuni" rida võib kaalu koos Välised | IDvara element. See tähendab, et kui element omab Välised | ID vara ja see kuulub alates ekspordiks, siis on väärtuste External | ID veerus kasutatakse sobivad kuni rida import (vt allpool) ja unikaalne ID väärtusi peidetud veerg ignoreeritakse (ja võib isegi olla tühi). Varjatud veerg ise peab jääma siiski eelkõige väärtuse lahtrisse A1. Lisaks lisamisel väline ID olemasolevale ABACUS element kogumise soovitame need lisada erinevat vara esimene, nt Välised | Temp ja siis ümbernimetamine vara External | ID. Vastasel eksemplaris elemendid lisatakse.

Kataloog vormingueksporditakse vaikimisi siiski suurte kataloogide see võib põhjustada ekspordi on üsna aeglane. Seega Tööriistad | Options ...siis Kataloogtab,Sul on võimalik vähendada vormingu, mida eksporditakse näidatud kataloogi tab alla, kiirendades seega eksport.

Kataloog ekspordi valikud

4. Eksport Valminud kuvatakse dialoog. Vajuta Okei.

Eksporditakse MS Excel Kataloog

Kuni importimist MS Excel Kataloog

Märge

Vaikimisi peidetud veerg jooksul eksportinud MS Excel kataloog (vt eespool) sisaldab unikaalset ID iga elemendid ABACUS hoidla. See võimaldab kõikidest muudatustest, mis on tehtud sees MS Excel tuleb "sobitada up", et olemasolevaid elemente ABACUS impordi. Kuid kasutada seda ainulaadset ID-"sobib kuni" rida võib kaalu koos Välised | IDvara element. See tähendab, et kui element omab Välised | ID vara ja see kuulub alates eksport (vt eespool), siis väärtused External | ID veerus kasutatakse sobivad kuni rida import ja unikaalne ID väärtused peidetud veerg ignoreeritakse (ja võib isegi olla tühi). Varjatud veerg ise peab jääma siiski eelkõige väärtuse lahtrisse A1. Lisaks lisamisel väline ID olemasolevale ABACUS element kogumise soovitame need lisada erinevat vara esimene, nt Välised | Temp ja siis ümbernimetamine vara External | ID. Vastasel eksemplaris elemendid lisatakse.

1. Veenduge, et teil on Kataloog vaade avatud.

2. Klõpsake Import Exceli Kataloog tabelissetööriistariba nuppu.

3. Vali failinime importida MS Excel kataloogi. Vajuta Avatud.

4. New avastatud vigu ja / või New vead / Hoiatused Avastati dialoogid võivad ilmuda iga uue sisu (st rida MS Excel), mis lisati. Võtke teadmiseks vead / hoiatusi ja klõpsa Okei.

5. Import Valminud kuvatakse dialoog ja see võib näidata hoiatusi tõttu import (vt alltoodud märkusi). Vajuta Okei.

Märge

Sest määratud standardid või kinnitatud Component sambad, uued kanded kaudu MS Excel Kataloog peab vastama täpselt nimi Olemasoleva Standard või Component õiget tüüpi loovutamiseks või ühendus, mis lisatakse. Esimene nimega match kasutatakse ja mis tahes tasakaalustamata kanded toob hoiatuse kohta allpool. Veelgi enam, kui antakse hoiatused kohta taassissevedu, elemendid ei kustutataalates ABACUS kui nad ei ole olemas MS Excel kataloogi. Seda seetõttu, et ei ole nii, et ABACUS ei tea, kas määratud Standard või kinnitatud Component olemas ABACUS projekti, kuid ei ole olemas MS Excel Kataloog sest see on kustutatud MS Excel kataloogi või on lisatud ABACUS Projekti kuna kataloogi eksporditi. Seega, kui kasutajad tahavad lihtsalt "avastada", mis ühendused on lisatud importimise ajal nad lihtsalt luua vajalik vara ühenduse tüüp ja määrake see vaikimisi tühi, nii et nad oleksid teadlikud kõigi uute ühenduste iga kord, kui import on lõpetatud.

Märge

Kui importiva MS Excel Kataloog erinevate hoiatusi võib kuvada. Esiteks, kui uus veerg lisati Excel, mis ei vasta "süntaks" eest vara või kinnitatud osa veerus ignoreeritakse. Järgmine rida-realt hoiatused kuvatakse mingeid küsimusi andmed iga rida Exceli kataloogi. Need hoiatused algab rea number nurksulgudes ja vajadusel veerus etikett (st "[23, J] ..." reas 23, veerg J) ja võib viidata kustutatud üksusi, tasakaalustamata standardid või kinnitatud Component nimed (mis ignoreeritakse kohta märkus eespool) või vale või tühi ID seotud uue rea / element (mis lisatakse). Detailse artikli kohta asustamisega ABACUS Excel kataloogid palun vaadake Avolution ühenduse või portfellihaldur kursuse.

Märge

New komponendid ja ühendused lisatakse vaikimisi tipptasemel komponente või ühendused kogumise valitud Arhitektuur. Muutmiseks vanem uute osade või ühendused paremklõpsake hierarhia Path raku uue komponendi või ühendused rida ja valige Muuda Parent ...ja vali soovitud vanema (võttes arvesse piirang esiletõstmine ).

Märge

Elements lisada otse kataloogi kaudu "Add New" nuppu, kleepida kataloogi või loodud kaudu importivad kataloogi MS Excel on vabastatud filtreerimine kuni Kataloog on suletud. See on võimalik vajalikke toimetamine veeru väärtused, mis ei vasta praegune filtreerimiskriteeriumid kataloogi. Need uued element rida on tähistatud "+" sümbolile reas valijat raku alguses reas, mis on värvitud roheline kui element praegu vastab salvestatud filtreerimiskriteeriumid kataloogi (st jääb Kataloog kui taasavatud), ja punane kui seda ei juhtu.

Kuni võrrelda sisu kataloogi teise arhitektuur

1. Palun vaadake teemat siin .

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Asustamine oma arhitektuuri Visio | Asustamine oma arhitektuuri Excel


Asustamine maatriksite abil

Navigation: asustamine oma arhitektuuri>

Asustamine maatriksite abil

Saada kommentaare selle teema.

Maatriks saate vaadata ja muuta "otsene" seosed komponentide lihtsa tabeli viisja vaadata ka kaudne tee "komponentide vahel vastavalt vahe komponendid (ja ühendused).

Kuni looma maatriks vaade ABACUS

Märge

Kuigi kõik Arhitekt kasutajad saavad luua Matriitsid, et neid päästa ja / või nende seadistused kasutaja litsents vajab Designer add-on võime. See on "kaitsmaks" konfiguratsiooni olemasolevate Maatriksid mida võib jagavad paljud kasutajad. Kuid Arhitekt kasutab ilma Designer add-on siiski valida "Save As" uuele seadeid uue Matrix. Ja muidugi kõik kasutaja litsentse saab valida "Loobu" mingeid muudatusi olemasoleva Matrix. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

1. Valige Insert | Matrix.

2. Aasta rchitecture>pull-down valida Arhitektuur, mis sisaldab komponente ja seoseid, mida soovite vaadata.

3. Aasta <AllikasTüüp>pull-down valida tüübikinnitusmärgi, mis soovid on toodud juhtudel kui "rida' vasakult ääreltMaatriksi.

4. Aasta <ValamuTüüp>pull-down valida tüübikinnitusmärgi, mis soovid on toodud juhtudel kui "sambad' üla-Maatriksi.

5. Aasta lammutama on olemuselt kaks "režiimi" maatriksi saab määrata ...

"Direct" ühendused maatriksid

6. Lihtsalt svalituid üks (1) või rohkem ühendus liigid Paremal servas avanevast menüüst, kui soovite näha "rakud" maatriksi kuin selgesõnalineSeoses olemas alates Vertical/ "ridaKomponendi ning maatriksi Horisontaalne/ "veergKomponendi ning maatriksi.

Märge

Ainult sidemed allikas ots kinnitatud Vertical/ "rida"Komponent ja valamu lõppu lisatud Horisontaalne/ "veerg"Komponent näidatakse. Lülitage Allikasja Valamutüübikinnitusmärgi valikud, et vaadata ühendused vastupidises suunas.

7. Maatriks hakatakse asustati "X" rakkudes (või vara väärtuse - vaata märkust) kui on olemas seos alates Vertical/ "rida "komponent maatriksi Horisontaalne/ "veergKomponendi ning maatriksi.

Märge

Suurte maatriksid ainult maksimaalselt 100 ridade või veergude (sh varises read / veerud), kuvatakse korraga nagu näitab "R" ja "C" näitajad ülemises vasakus päise lahtri võrra. Et vaadata ridu kasutada kerimisribad. Igal ajal saab topeltklõps Vertical/ "rida"Või Horizontal / "veerg"Komponenti rubriikide ja hüpatavastava komponentide Explorer aknas.Vanemad on vertikaalne/ "rida' ja Horisontaalne/ "veerg"Komponentis on ka soovi korral näidata rubriigis read / veerud halli pealkirja pealkiri. Kui varisenud (ühekordse klõpsuga pealkirja cell), kui lapsed manuseid olemas siis "X" on valikuliselt näidanud, kui kõik lapsed olid kinnitatud või "O" on soovi korral näidata kui ainult mõned lapsed olid kinnitatud. Rakud võivad olla värviline vastavalt vara väärtus ühendused klõpsates Options "hammasratas" ülaosas paremal maatriks tööriistariba ja valides värve Settings ... ja siis Edit nuppu ja valides värve poolt Timestamp või Colour By Property valik ja valides vara, Min ja Max väärtus vahemikus ja valides värve, aga ainult Nimekiri, Integer, Decimal, Boole'i ​​või Date / Time andmete tüübi omadused värvitakse. Kui varisenud raku on värvitud vastavalt keskmisele vara väärtus ühendused. Selle asemel, et "X", vara väärtused võivad rakud olla näidanud klõpsates Options "hammasratas" ülaosas paremal maatriks tööriistariba ja valides Show Väärtus Settings ... ja siis Edit nuppu ja valides Show vara võimalust ja valides vara.

Otsene ühendused maatriks näitab Serverid, kui taotlus on majutatud värvimine ja vara näidatakse asemel üldnimetuseks "X"

- VÕI -

"Kaudne" ühendused maatriksid

6. Svalituidjada ühendus liigid ja komponent tüüpiparemal ja vasakul pool menüü, mis ilmub, kui soovite näha "rakud" maatriksi kuin kaudset teed ühendatud komponendidolemas alates Vertical/ "ridaKomponendi ning maatriksi Horisontaalne/ "veergKomponendi ning maatriksi.

Märge

Iga kehtiv tee, mis sisaldab elemente valitud tee menu whaige olema näidatudsõltumata suunast aluseks ühendused siiski valides teekonnale esimeneja viimase elemendid valitud peab olema ühenduse tüübid. Lisaks järjekord elemente, mis on valitud näidatakse koos numbriline eesliideruut ("[]") sulgudes ja antud tüüpi võib lisada mutliple kordateele (tähistatud numbriline koodiga). Järjestikused valik komponent tüüpi või ühenduse tüübid on tõlgendada "OR"path ja hierarhiat kinnitunud komponente võib valikuliselt lisada kontrollides "Samuti otsida Attachment vanemad / lapsed"Ruut. Lülitage Allikasja Valamutüübikinnitusmärgi valikud, et vaadata rajad vastupidises suunas.

7. Maatriks hakatakse asustatitee / kogumise komponendidrakkudes kui on olemas tee alates Vertical/ "rida "komponent maatriksi Horisontaalne/ "veergKomponendi ning maatriksi.

Märge

Suurte maatriksid ainult maksimaalselt 100 ridade või veergude (sh varises read / veerud), kuvatakse korraga nagu näitab "R" ja "C" näitajad ülemises vasakus päise lahtri võrra. Et vaadata ridu kasutada kerimisribad. Igal ajal saab topeltklõps Vertical/ "rida"Või Horizontal / "veerg"Komponenti rubriikide ja hüpatavastava komponentide Explorer aknas.Vanemad on vertikaalne/ "rida' ja Horisontaalne/ "veerg"Komponentis on ka soovi korral näidata rubriigis read / veerud halli pealkirja pealkiri. Kui varisenud (ühekordse klõpsuga pealkirja cell), kui lapsi teed olemas siis "X" on valikuliselt näidanud, kui kõik lapsed olid kinnitatud või "O" on soovi korral näidata kui ainult mõned lapsed olid teed. Kaudne tee komponendid võivad olla värviline vastavalt vara väärtuse komponendid, klõpsates Options "hammasratas" ülaosas paremal maatriks tööriistariba ja valides värve Settings ... ja siis Edit nuppu ja valides värve poolt Timestamp või Colour By Property valik ja valides vara, Min ja Max väärtus vahemikus ja valides värve, aga ainult Nimekiri, Integer, Decimal, Boole'i ​​või Date / Time andmete tüübi omadused värvitakse. Omandi väärtused kaudse path komponendid võivad olla näidanud klõpsates Options "hammasratas" ülaosas paremal maatriks tööriistariba ja valides Show Väärtus Settings ... ja siis Edit nuppu ja valides Show vara võimalust ja valides vara.

Kaudne ühendused maatriks näitab Rakendused et rakendada antud Service Department

Kuni filtermaatriks vaade ABACUS

1. Veenduge, et teil on uus Matrix vaade avatud.

2. Klõpsake Filter Kirved "lehter" ülaosas paremal maatriks tööriistariba.

3. On allikas ja / või Sink kaarte lisada nimi, Kinnisvara, kirjeldus, hierarhia või Standard filtrid klõpsates nupule Lisa, valides Property vajadusel ja klõps Okei. Valige asjakohane valikuid Märksõnad / Esemed paneeli kasutades loogika / süntaks kirjeldatud tekstis edaspidi. Eelvaate paneel automaatselt näitama tulemusi praegused filtrid.

Märge

Eest Ajatempel, hierarhia Path, nimivõi Kirjeldaminefiltrite või Tekst, Integer, Decimal, Booleanvõi Kuupäev / aegvara filtrid sobivad toimub justkui "*" metamärke rakendatakse automaatselt enne ja pärast iga string väärtused nii, et märge "kass" (ilma jutumärkideta) hõlmaks read "bobkass','kassnaine "või" taotkassioon "vms Mitu /" või "väärtused võivad olla kantud uued read Ctrl + Enter. Eest Täisarv ja Decimal vara filtrid "ja" loogika võib lisada kasutades "&"(Ilma jutumärkideta) ja suurem kui / alla jne loogika võib kanda kasutades"> =','>','<"Ja"<="(Ilma jutumärkideta) nt "> = 50000 & <90000". Non-blank hinnatud ridu võib lisada sisestades "(Non-toorikud)"(Ilma jutumärkideta) ja Blank hinnatud ridu võib lisada sisestades"(Tühjad)"(Ilma jutumärkideta).Eest Standardid või Nimekiri vara filtrid "(Vali kõik) märkeruut võimaldab kõigi teiste ruudud, tegelikult ka kõik olemasolevad elemendid. The '(Non-toorikud) ruut hulka kõik mitte-tühjad vara väärtuseks elemendid. The '(Tühjad) ruut hulka tühje vara väärtuseks elemendid. Ja eemaldades märke mingeid konkreetseid hinnatud ruudud automaatselt Puhasta (Vali kõik) "ja" (Non-toorikud) "ruudud järjepidevus. Ja lõpuks, kõik filtrid on vaikimisi tõstutundetu nii kass "(ilma jutumärkideta) hõlmaks elemente" kass "," Kass "või" CAT "jne tõstutundlikult, sisestage"(Case)"(Ilma jutumärkideta) enne string nt (Case) Kass "(ilma jutumärkideta) sisaldaks üksnes elemente" Kass "neid.

Asustada kasutades Matrix vaade ABACUS

Märge

Võite ainult lisada / eemaldada ühendused, kus ühe ühenduse tüüp on kasutatud Path eespool kirjeldatud.

1. Kuni lisada ühendustValitud tüüpi vahel Vertical/ "rida"Komponenti ja Horisontaalne/ "veerg"Komponent maatriks, kus" X "ei ole olemas(või näidatud vara väärtus - vt märkus eespool)Topeltklõps raku. "X" peaks ilmuma (või vara väärtuse - vt märkus eespool) ja ühendus luuakse tipus tase Ühendused kollektsiooni valitud Arhitektuur.

Märge

Ühendus nimi saab olema ühenduse tüüp nime kohta ühenduse tüüp seade maatriksi ja kui vara väärtus on näidatud asemel "X" vaikimisi väärtust vara kuvatakse.

2. Kuni muuta näidanud vara väärtusevaheliste seoste kohta a Vertical/ "rida"Komponenti ja Horisontaalne/ "veerg"Komponent maatriksTopeltklõps raku või paremklõpsake rakkude ja valige Edit Value ... ja muutke väärtus Muutus Väärtuse dialoog.

3. Kuni kustutada ühendustValitud tüüpi vahel Vertical/ "rida"Komponenti ja Horisontaalne/ "veergKomponendi ning maatriksi, kus "X" on juba olemas(või näidatud vara väärtus - vt märkus eespool), right-kliki rakuja valige Lõpeta. X kaovad ja ühendus kustutatakse projekti.

Päästma / Salvesta kui aMatrix vaade

Märge

Kuigi kõik Arhitekt kasutajad saavad luua Matriitsid, et neid päästa ja / või nende seadistused kasutaja litsents vajab Designer add-on võime. See on "kaitsmaks" konfiguratsiooni olemasolevate Maatriksid mida võib jagavad paljud kasutajad. Kuid Arhitekt kasutab ilma Designer add-on siiski valida "Save As" uuele seadeid uue Matrix. Ja muidugi kõik kasutaja litsentse saab valida "Loobu" mingeid muudatusi olemasoleva Matrix. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja Designer add- võimekust.Ja pidage meeles, see on lihtsalt seadeid Matrix, kõik tehtud muudatusi andmeid Matrix on koheselt rakendada hoidla, sõltumata.

1. Veenduge, et teil on uus Matrix vaade avatudja olete teinud vajalikud muudatused.

2. Aasta Matrix vaadetööriistariba kliki vasakpoolsem Salvesta Matrixnuppu, et salvestada Matrix vaade ja formaati muutusi.

Märge

Kui te ei ole Salvesta nuppu Matrix Vaateribal siis ei ole Designer add-on ja sa oled ainus võimalik Salvesta kuimingeid seadeid muutub uue maatriksi kui lähete sulgeda olemasolevaid maatriks.

3. Kui MatrixNimiilmuvasse dialoogi (tänu sellele, et uus maatriks) sisestage nimi maatriksja vajutage Okei.

Kuni ekspordiks MS Excel maatriks

1. Veenduge, et teil on Matrix vaade avatud.

2. Klõpsake Ekspordi Excelissetööriistariba nuppu.

3. Vali failinime päästa MS Excel maatriksist. Vajuta Salvesta.

Märge

Vaikimisi eksporditud MS Excel maatriksi failinimi Matrix nimi lõppmärgistega Arhitektuur nimi sulgudes, nt "Taotlused võõrustajaks Serverid (2014 Tegelik) Xlsx". Sa saad muuta kõik see, sealhulgas kas failiformaat on olla Xlsx või .xls.

Matrix vormingueksporditakse vaikimisi siiski suurte maatriksid see võib põhjustada ekspordi on üsna aeglane. Seega Tööriistad | Options ...siis Matrixtab,Sul on võimalik vähendada vormingu, mida eksporditakse näidatud Matrix tab alla, kiirendades seega eksport.

Matrix ekspordi valikud

4. Eksport Valminud kuvatakse dialoog. Vajuta Okei.

Eksporditakse MS Excel maatriks

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Asustamine oma arhitektuuri Visio | Asustamine oma arhitektuuri Excel


Asustamine oma arhitektuuri Microsoft Access

Navigation: asustamine oma arhitektuuri> asustamine Microsofti tooted>

Asustamine oma arhitektuuri Microsoft Access

Saada kommentaare selle teema.

Saate eksportida oma arhitektuuri Microsoft Access täita üldotstarbelised arvutused, manipulatsioonid ja aruandeid oma arhitektuuri. Seejärel saate importida arhitektuur tagasi ABACUS.

Märge

Avatud alates Access / Eksport Database funktsioon nõuab, et Microsoft Access 2000või uuem on arvutisse installitud.

Ekspordi arhitektuuri Microsoft Access

1. Veenduge, et teil on ABACUS failiAvatud on Uurijakuvatakse, ja arhitektuurlisatud.

2. Vali Fail | Eksport | Et Database.

3. Võtke teadmiseks hoiatus dialoog, nagu eespool kirjeldatud ja klõpsake jätkamiseks Jah.

4. Valige asukoht ja failinimi andmebaasi faili.

Importida manipuleerida arhitektuuri arvesse ABACUS

1. Veenduge, et teil on ABACUS avatud.

2. Vali Fail | Uus ja valige Siit Accessalates ilmuvasse dialoogi ja klõpsake OK.

3. Sirvi andmebaasi faili, mida soovid importida.

ABACUS "MS Access andmebaasi skeemi

ABACUS on tema südamessen ontoloogia / meta-meta-mudel koosneb komponendid, ühendused ja piiranguid. See "CCC" lähenemine oli saadud erinevate standard lähenemisviiside 1960 aastast kulmineerus rahvusvaheline standard IEEE 1471, mis Avolution asutajad aidanud. Järgmised primitiivid kohaldata;

1. ABACUS sisaldab Raamatukogudkohta Standardid(või Standards), Componentja Connection liigid, Piirangud, Seisukohad, Templates (või Mustrid) Ja palju Arhitektuurid.

2. Standardid, Tüübidja Seisukohad võibloogiliselt Rühmitatudmugavamaks.

3. Arhitektuurid võivad sisaldadapaljud järeltulija Arhitektuurid(või arenguid).

4. Iga Arhitektuur sisaldabpalju Komponendidja Sidemedteatud Tüübidja erinevate Views.

5. Komponendidja Sidemed võib olla lagunenudsisse Sub-komponendidja Sub-ühendused.

6. Iga Componenton lisatudmis tahes arv Sidemedkuid iga Ühendussaab olla ainult lisatudmaksimaalselt kaks Komponendid.

7. Komponendidja Sidemedsaab olema Standardidkoos Omadusednagu Teave, tulemuslikkuse, usaldusväärsuse, maksumus jne

8. Arhitektuurid, Komponendidja Sidemedsaab olemaspetsiifiline Omadusednagu Teave, tulemuslikkuse, usaldusväärsuse, maksumus jne

9. Piirangudsaab vahel Komponendidvõi Sidemedvõi vastu Omadused.

10. Templateson standardse koostisega Componentja Connection liigid.

11. Seisukohadon standard ühendused Componentja Connection liigidnotatsioonile.

12. Viewson visuaalne esindused Komponendidja Sidemed.

Järgmised MS Access Entity Relationship diagramm (ERD) dokumenteerib tuumArhitektuur, Arenguid, Component / Connection liigid (ja grupid), Components / Ühendused ja Sub Component / Connection mõisted.

Core andmebaasi skeemi

Märge

Referential terviklikkus ei ole jõustatud vahelise suhte komponendid laua ja ühendused tabelis (jaoks "manus" vahel allika või Sink Component ja Ühendus). Seda seetõttu, et ühendus ei saa eksisteerida ilma komponent manuseid. Võiksime lisanud seotust "tabelist kuid lihtsuse huvides otsustas vastu. Loomulikult tähendab see, et toimetamine Component IDd või kustutamine Component rida kõik koos tulemuseks valeandmeid. ABACUS tegelen ebatäpsust impordi eirates valeandmeid.

Järgmised MS Access ERD dokumenteerib Omadusedkontseptsioonide arhitektuur, Component / Connection liigid ja komponendid / Connections.

Omadused andmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Standardidkontseptsiooni arhitektuur, Component / Connection liigid ja komponendid / Connections.Märkus: tabelid siiski kasutada mõistet "rakendamine" kohta eelmiste versioonide ABACUS.

Standardid andmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Piirangudkontseptsiooni Component / Connection tüübid.

Piirangudandmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Seisukohad kontseptsioon Arhitektuurid.Märkus: lauad veel kasutada terminit "TwoDTempl" kohta eelmiste versioonide ABACUS.

Seisukohadandmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Kataloogidkontseptsioon Arhitektuurid.

Kataloogidandmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Matriitsidkontseptsioon Arhitektuurid.

Matriitsidandmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Skeemidekontseptsioon Arhitektuurid.Märkus: lauad veel kasutada terminit "TwoD" kohta eelmiste versioonide ABACUS.

Märge

Osale / Connection Type šabloon kuju kaardistamise ja Vabakäeline kuju osad MS Access ERD on selguse huvides välja jäetud.

Skeemideandmebaasi skeemi

Järgmised MS Access ERD dokumenteerib 3D Viewskontseptsioon Arhitektuurid.

3D Viewsandmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Äritegevuskontseptsioon Arhitektuurid.

Äritegevusandmebaasi skeemi

Järgmised MS Access ERD dokumenteerib Verbimõiste.

Verbiandmebaasi skeemi

ABACUS "MS AccessPäringud

Kaasas MS Access Database on mitmeid kasulikke päringud järgmiselt;

· Comps poolt Props- Selle päringu loetletud kõik komponendid projekti (arhitektuur ja liik) ja sisaldab kõiki omadusi nagu sambad. Kasutage seda päringut filtrid / kriteeriumite abil tüübikinnitusmärgi ja / või arhitektuuri toota "tüüpiline" tabelid iga osa tüübikinnituse nende omadused.

· Stds poolt Props- Selle päringu loetletud kõik standardid, mis on kasutusel, esinemiste arv on standard ja sisaldab kõiki omadusi nagu sambad. Kasutage seda päringut standarditel kataloogi.

· Abivahendid liikide- Selle päringu loetletud kõik komponent omadused ja nende% valmis iga osa tüüpi sambad. Kasutage seda päringut teha kindlaks, kas konkreetse omadused säiliksid.

· Tüübid poolt Props- Selle päringu loetletud kõik komponent tüüpi ja kuuluvad% valmis kõik omadused nagu sambad. Kasutage seda päringut teha kindlaks, kas konkreetse omadused säiliksid.

· Tüüp Krahv- Selle päringu loetletud kõik komponent tüüpi ja sisaldab mitmeid esinemisi iga kahanevas järjekorras. Kasutage seda päringut teha kindlaks populaarsus iga projektis.

Märkus töötamise kohta Memo väljad MS Access

Komponentide ühendused ja standardid Nimi väljad on tabelites määratletud memo väljad lubada piiramatu arvu märke, nagu iga ABACUS. Komponentide ja ühendused See tekitab mõned küsimused, sest neil on ka unikaalne ID väli viitamise, kuid Standards see põhjustab palju probleeme, kui soovitakse liituda tabelid, sest sa ei saa liituda memo väljad MS Access. Võite määrata Kus punkti kriteeriumid, et saavutada sama efekti nagu näidatud Visual Query Builder ja vastavate SQL pikad allpool seda nimekirja läbi kõik päritud standardid omadused kõik komponendid on eksporditud ABACUS projekti.

Memo valdkonnas "liitub" Visual päringukoostur

Vali Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Komponentidest INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) JA (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), implementation INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

KUS (((ComponentImplementationLinks.Name) = [implementation]. [Nimi]));

Memo valdkonnas "liitub" SQL

Märkus automaatselt tekitama ABACUS sümbolid MS Access

Erinevad ABACUS MS Access laudades unikaalne pikk täisarv ID nii lihtne VB pakutud meetod abi põlvkonna neid. Kaks meetodeid ResetCounter () ja GetNextCounter () raames on esitatud ABACUS "MS Access DB ja nende kasutamine on järgmised; ResetCounter () loob leti taga 0. GetNextCounter () tagastab järgmise leti järjekorras.

Meetodid kasutada MS Access "veidrus", et isegi siis, kui te helistate ResetCounter () meetod iga rea ​​sisestada (st kui ka joosta GetNextCounter () funktsiooni), sest ResetCounter () funktsioon ei ole mingit parameetrit see lihtsalt jookseb seda üks kord ja seepärast ei loenduri nullimiseks iga rida lisada. Ja ka sellepärast, et sama "veidrus" sa pead läbima kõik vanad veerus muutuja GetNextCounter () funktsiooni, et panna see töötab iga kord.

Samuti on trikk, et on võimalik käivitada ResetCounter () funktsiooni siseelemendiga arvesse SQL sest sa ei saa lihtsalt lasta seda istub seal kolonni omal, nagu siis, kui ta oli valige päring. Soovitav on teha ResetCounter () kõne osa üks teistes valdkondades, liitmisel seda lõpuni, sest see naaseb alati null niikuinii.

Allpool on tüüpiline SQL meetodite kasutamise lisada nimekirja Component tüübid tabelist / päringu nn Component Type loetelu ".

INSERT INTOComponentTypes (Id nimi, kirjeldus)

VALI GetNextCounter ([Component Type List] .name)AS Id, [Component Type List] .name AS Nimi, [Component Type List] .description & ResetCounter ()AS Kirjeldus

Alates[Component Type List];

ABACUS ID / Counter põlvkonna SQL

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Asustamine oma arhitektuuri Visio | Asustamine oma arhitektuuri Excel


Asustamine oma arhitektuuri Microsoft Visio

Navigation: asustamine oma arhitektuuri> asustamine Microsofti tooted>

Asustamine oma arhitektuuri Microsoft Visio

Saada kommentaare selle teema.

Saate importida oma arhitektuuri Microsoft Visio. Kujundid oma Visio Loosimine imporditud komponendid ABACUS. Ühendused oma Visio joonise imporditakse ühendusi ja joonistus ise imporditakse ABACUS kui skeem. Lisaks sellele tuleb iga Custom Properties oma Visio Loosimine imporditud omadused koos Sorteeri Key kaardistatakse Kinnisvara tüüp, etiketti Property nimi ja väärtus on vara väärtusest.

Märge

Import alates Visio funktsioon nõuab, et Microsoft Visio 2003või uuem on arvutisse installitud.

Importida oma Visio joonistustest ABACUS

1. Veenduge, et teil on ABACUS avatud.

2. Vali Fail | Uus ja valige Siit Visioalates ilmuvasse dialoogi ja klõpsake OK.

Märge

Kui soovite importida olemasoleva ABACUS projekti, siis kas paremklõpsake Components sõlm sees arhitektuur, või paremklõpsake individuaalne komponent sees Arhitektuur ja seejärel Import | Siit Visio.

3. Sirvi jaoks Visio faili, mida soovid importida.

Märge

Allpool on mõned lihtsad reeglid või soovituslike tavade ehitamisel (või muutes) MS Visio joonistuse importida ABACUS.

1. Sirged või ühendused peavad olema tegelikud ühendused, mitte kuju.

· Vastasel ABACUS lihtsalt importida neid komponente ja seetõttu neid ei lisatud "" midagi.

· Kui teil on vaja teha mõned "targad" marsruudi kohta (välja arvatud sirge), siis kasuta Dynamic pistikusse Basic Shapes stencil Abacus impordib suunamises / Ankurpunktid trahvi.

· Püüa vältida kasutades "Ring võrk" ja "Ethernet" kujundeid Network ja välisseadmed šabloon, mis võimaldab palju komponente tuleb "ühendada" ta. Kuigi me importida manuseid trahvi ühendused originaal kuju on ikka "laiendatud" kajastada manuseid. Kasutada eraldi eraldi "hub / bus" kuju (ilma pesa "jalad") ja siis otseselt ühendada iga osa rummu / bus eraldi ühendused.

· Kui rida või ühendus käitub nagu kuju, paremklõps ja minna "Format | Käitumine ... "ja veenduge, et koostoime stiilis on seatud Line (1-dimensional).

2. Komponendid peavad olema kujundeid EI ühendused.

· Vastasel ABACUS lihtsalt importida neid ühendusi ja seetõttu kõik kuju kaduma ei läheks.

· Kui komponent käitub nagu pesa, paremklõps ja minna "Format | Käitumine ... "ja veenduge, et koostoime stiilis on seatud Box (2-mõõtmeline).

3. Connector otsad tuleb kinnitada kujundeid, ei ujuvad ringi tausta kuju.

· Kui te ei ühenda pistikud kuju siis ABACUS on kuidagi võimalik teada, et te kinnitamiseks ettenähtud antud pistiku kuju / komponent ja seega jätan selle otsas ühendus un-külge.

4. Etiketid kuju peaks olema (kui võimalik) sisseehitatud teksti märgistuse kuju, mitte eraldi teksti kasti joonistamine.

· Eraldi teksti kasti saavad imporditud ABACUS osadena omaette ja samas saab ühendada "label" komponendi tegelik komponent ABACUS või lihtsalt teisendada "label" komponent Vabakuju kuju (st ei ole komponent ise) see on parem vältida neid samme.

5. Kasutage sama baasi kuju iga Näiteks sama tüüpi, ei ole laisk ja kasutada ristkülikut mõnikord ja kast teisi erineva kuju šabloonid.

· ABACUS kasutab baasi kuju ja selle põhivärv identifitseerimiseks komponent ja ühenduse tüübid joonisel nii "punane ristkülik" ja "punane kast" saavad imporditakse kahe eraldi komponendina tüüpi. Need komponent tüüpi liita ABACUS kuid see on parem vältida neid samme.

6. Täielikult kapseldada "lapsed" kujundeid oma "vanemad", ärge jätke neid rippus üle ääre.

· ABACUS tuvastab mis tahes kujuga, mis on täielikult kapseldatud teise kuju kui laps vanema veenduge, et kogu kuju, sealhulgas etiketi osa, on suletud.

7. ÄRGE asetage kuju kattuvad kaks kuju.

· Kui kuju kattub kaks kuju, olgu see siis "rühmituse" / tausta ristkülik või teisiti, siis imporditud ABACUS osana, mis on lapsele ei kattunud kuju, kuid niipea, kui valite komponent ABACUS "tööriist tõttu ülemisest vasakust olles komponendid viide punkti, muutub laps vasakul kattusid kuju / komponent.

8. Püüa kasutamise minimeerimiseks teksti lisades joonis sest need saavad imporditud komponente omaette ja tuleb ümber vormiga kujundeid ABACUS. Mõtle, kas nad on tõesti nime olemasoleva komponendi või ühendus.

9. Kuigi ABACUS toetab rikas / värvitud / vektor põhinev kujundeid, proovige vähendada kasutamist bitmaps, välismaa kuju ja täiustatud metafailid kujundeid nagu ABACUS praegu eieirahastataks seda tüüpi. Nad on imporditud nii lihtne valge ristkülikud.

10. Püüa vältida reavahetusmärgid (vahetustega tagasipöördumine) märgistusel kui nad on imporditud ja näidatakse erimärk "[]" ABACUS komponendile nimi.

11. Proovi minimeerida erinevat värvi, mida kasutatakse kuju sama tüüpi. Nagu eespool mainitud, põhivärv ja baasi kuju üheselt identifitseerib osa ja ühenduse tüübid seda rohkem variatsioon on rohkem ühineva ja konsolideerimine, et tuleb teha post-import ABACUS.

12. Olge täis kujundeid, sest kui kuju on täidetud kõik viis nurka siis värvimine hiljem ABACUS ei mõjuta.

13. Keeruliste line-põhine kuju peate kasutama polügooni mis on loodud võttes read, mis algavad, kui eelmine lõpeb ja siis lõpuks läheb tagasi alguspunkti. Soovi korral saate täita ja joonelaiuseks teha polügooni nägema "nool" või mis iganes kujuga soovid.

14. Veenduge, et kuju ID MS Visio on sisukas mitte ainult Shape.xx. See on muudetav kasutades paremklõpsu "Show kujundileht", mis on saadaval MS Visio Arendaja režiim (võimaldas läbi Tööriistad | valikud MS Visio).

15. Ellipsid ja kaaredjooksul kujundeidtoetatakse ABACUS kuid NURBS ja nuuti praegu ei toetata.

16. Veenduge, et kogu kuju on pandud MS Visio või siis saada imporditakse mitmest komponendist / tüübid.

17. Püüa kasutamise minimeerimiseks pööratud kujundeid jooksul subshapes kui nad mõnikord ei saa importida korrektselt.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Asustamine oma arhitektuuri Access | Asustamine oma arhitektuuri Excel


Asustamine oma arhitektuuri Microsoft Excel

Navigation: asustamine oma arhitektuuri> asustamine Microsofti tooted>

Asustamine oma arhitektuuri Microsoft Excel

Saada kommentaare selle teema.

Saate importida oma arhitektuuri Exceli tabelit (.xls või Xlsx file). Excel importija saab kaardistada nimekirjad osa ja sidemed tüübid, standardid, omadused ja standard omadused valides sambad taulukkolaskentaohjelmassasi mis sisaldavad asjakohaseid andmeid.Siiski on rohkem arenenud tehnikat kui soovitatud lähenemisviisimportiva MS Excel, mis on läbi kataloogid nagu on kirjeldatud siin .

Märge

Importimiseks / Export Exceli funktsioon nõuab, et Microsoft Excel 2003või uuem on arvutisse installitud.

Põhiülesanne Exceli importija on võimaldada teil määratleda konfiguratsioonifaili (st hierarhiline struktuur oma arhitektuurilise mudel). Konfiguratsioonifaili kauplustes varem salvestatud kaardistamine alates Exceli faili kaasa ABACUS faili. Kui tehakse salvestatakse konfiguratsioonifaili hiljem kasutada edasiseks importivate ja eksportivate .xls faile.

Märge

Sammud on näidatud allpool on spetsiaalselt kasutajad, kes ei ole veel kindlaks määrata ja salvestada konfiguratsioonifaili ning importis excel esmakordselt. Peate looma ja säästa konfiguratsioonifaili kasutada eksport Exceli funktsiooni.

Importida Exceli tabelit arvesse ABACUS

1. Veenduge, et teil on ABACUS avatud.

2. Vali Fail | Uus ja valige Excelalates ilmuvasse dialoogi ja klõpsake OK.

Märge

Kui soovite importida olemasoleva ABACUS projekti, siis kas paremklõpsake Components sõlm sees arhitektuur, või paremklõpsake individuaalne komponent sees Arhitektuur ja seejärel Import | Excel.

3. Import Exceli töövihikkuvatakse aken

Import Exceli töövihik Window

4. Klõpsake Avatud Excel failikoon ja sirvida Excel fail, mida soovid importida.

5. Vali Töölehtsoovid importida rippmenüü.

Märge

Pärast avamist Excel fail, mida saab kasutada Andmed eelvaadetab, et vaadata sambad ja esimesed 25 rida tööleht. Siit võid saada veeru numbrid vaja täita Komponendidja Sidemedtab.

Võite valida, kas soovite komponente Exceli tabelisse tuleb imporditud tõstutundlikkuse. Lihtsalt märgistada Import koos tõstutundlikkusevalik (vaikimisi on see alati rist) ja tabelisse on imporditud vastavalt.

Proovi Excel fail

Märge

Selles näites me importida lihtne infrastruktuuri ja Inimesed Arhitektuur Exceli andmete näidatud ülaltoodud pildil. Ühendused tehakse vahel "Inimesed Vastutustundlik" ja "serverid", et need inimesed valitsema.

Asustada Components tab

See osa on mõeldud määratlemisel osa liike ja hierarhiline struktuur konfiguratsioonifaili.

1. Valige Komponendidtab. Nimetage Set IDülekaaluka (null)väärtus

Märge

See funktsioon võimaldab määrata täiesti erinevad Komplektidfunktsionaalselt eraldi komponente. Nagu näha pildil võiksite eristada oma infrastruktuuri komponente oma Inimesed komponendid. Kui on suhted (ühendused) nendes eraldi komplekti komponendid, neid saab alusel määratletud Sidemedtab. Hiljem see näiteks siis me defineerime ühendused tüüpi "haldab" vahel Infrastruktuur ja Inimesed Komplektid.

Võite valida, kas soovite lisada tipptasemel Rühmituskomponent kõigi elementide kogum. Lihtsalt märgistada Group Under Set IDvalik (vaikimisi on see märkimata) ja tabelisse on imporditud vastavalt.

Omistamine Set ID

2. Kui Komplektidon määratletud valige Seadkesoovite asustada ja laiendada klikates [+]kirjutama.

3. Valima Komponentide tasemete selles Setalates laiendatud nimekirja.

4. Komponentide hierarhia Lavakujundus: Set IDaken eest, et Seadke.

Komponentide hierarhia ja Väärtuste (Set ID: Infrastructure)

5. Nimetage Tase arvveerus ülekaaluka (null)väärtus.

Märge

Tase arvveerus saab määrata hierarhia oma komponente. Iga tase vastab kiht jooksul oma arhitektuuri, mille esimene tase on top kõige lapsevanemtasemel. Näiteks Tase arv "1" vastab tähtsaim hierarhiline kiht, Level Number "2" on lapse taseme numbri "1" ja nii edasi.

6. Vali ja määrata asjaomase veeru alates Exceli tabeli igale Tase arvsisestades see alla Component veergkolonni.

Märge

Saate valida, kas jätta teatud read, et sa ei taha olla esindatud oma arhitektuuri. Need võivad olla Veerupäistega, tühi rida, jne välista rida kasutada Ridu Välista:teksti kasti ülaosas paremas nurgas akna. Antud näites on välistatud rida 1, kuna see sisaldab meie Veerupäistega.

7. Saate valida, kas lisada kirjeldusi oma komponentide kirjutades (null)väärtus Kirjeldus veerg.

Märge

See kirjeldus on see, mis ilmub ABACUS all General omadusedosa | Kirjeldaminevaldkonnas.

8. Kui antud tabelisse veeru on rohkem kui üks komponent elemendi kohta (sisestatud kasutades Alt-Enter või CHAR (10) käsk), siis märkige ruut all Ravida New Lines eraldi komponentidena. Iga rida imporditakse eraldi komponentidena.

Ots

Importida "maatriks" on kogumik sambad, kus "X" teatud "maatriks" raku (rakkude B2: D2 öelda) viitab sellele, et osa määratud rida (raku A2 öelda) on ühendatud osa määratud veerus "rubriiki" (in real 1 ütleme), lihtne valem saab kasutada. Sisesta järgmise valemi iga rea ​​veerus kaugemale maatriksi rakud (veerg F öelda); = IF (B2 = "", "", B $ 1 & CHAR (10)) & IF (C2 = "", "", C $ 1 & CHAR (10)) & IF (D2 = "", "", D $ 1 & CHAR (10)). Siis luua ühendus, nagu on kirjeldatud allpool komponentide vahel määratud rida (A veerus öelda) ja mida on kirjeldanud seda valemit (veerus F öelda). Ole kindlasti vaadata Ravida New Lines eraldi komponentidenavariant, kui kõik detailid valem on imporditud. Täpsemaks maatriks import, sh järgmised rubriigid mitmekihilist hierarhia või rakkude erinevad väärtused kui lihtsalt tavaline "X", võtke Avolution Support .

9. Täida ülejäänud veerud nii nagu vaja.

Märge

Võite valida, et saada tüübist kolonnist rida märgistades vastava ruudu all Võta tüüp veerustveerus ja käsitsi vastava veeru Exceli tabeli all Component Tüüp Value või veergkolonni. See importida kõik komponendid, st kolonni ja lasta neil määratletud tüüpi kolonni. Teise ja nagu Ekraanipilt üleval ja all, võite kasutada fikseeritud / ettemääratud tüübi nime sisestades tüüp nime all Component Tüüp Value või veergveerus ja hoolitsedes ruut on un-kontrollida.

Komponentide hierarhia ja Väärtuste (Set ID: Inimesed)

Märge

Selles näites soovime meie võrkude ja inimesed rühmitused tasemel 1 Arhitektuur. Tasemel 2 tahame meie serverid ja inimesed haldav need serverid. Komponendidminekuks on täidetud järelikult nagu on näidatud kahe ülaltoodud piltidele. Esimesel pildil oleme määratlenud tase 1 (võrgu grupis) ja 2. taseme (server) komponendid infrastruktuuri Seadke. Ja pildil kohe üle oleme määratlenud tase 1 (inimesed, rühmitades) ja tase 2 (vastutavad inimesed) komponentide Inimesed Seadke.

Alternatiivselt jaoks InimesedSet, selle asemel et kasutada veerg C rahvana rühmitus, oleksime kasutanud Group Under Set IDvalik tipptasemel komponendid sakk ja siis lihtsalt sisenenud Inimesed alajaotuseks veerg D. Seda on näidatud allpool oleval pildil.

Komponentide hierarhia ja Väärtuste kasutades Group Under Set ID valik (Set ID: Inimesed)

10. Kui komponendid on kindlaks tehtud, valige komponent, mille soovite asustada omadused ja / või standardite ja laiendada klikates [+]kirjutama.

11. Valima Omadused Components sellel tasandilvõi Component Standards sellel tasandilalates laiendatud nimekiri ja asustada vastavates veergudes, kui vaja.

Asustamine komponendid

Märge

Omadused Components sellel tasandilvõimaldab määrata omadused komponendid valitud tasemega. Component Standards sellel tasandilvõimaldab määrata standarditega ja nende standard omadused komponendid valitud tasemega.

12. Korrake samme 2-11kuni kogu komponendi tasemed on asustatud kõikide määratletud Komplektid. Kasutage tagasinoolel ülaosas paremas nurgas akna navigeerida tagasi Komplektidmis sa eelnevalt defineeritud.

Asustada vahekaarti Ühendused

See osa on määratleda ühenduse tüübid ja hierarhiline struktuur konfiguratsioonifaili.

1. Valige Sidemedtab. Iga komplekt ühendused teil tuvastada komponent Seadkeet sa tahad olla allikas komponendid ja komponendi Seadkesa tahad olla kohtades komponendid.

2. All Allikas Component Set IDsisestage Seadkenime, mis vastab Seadkeeelnevalt defineeritud Komponendidtab. All Allikas Component Tase arvsisestage number, mis vastab komponendi tasandil, mida soovite ühendada otse tekkekohas otsas ühendus.

3. Nüüd, millist komponenti grupp on sihtpunktis otsas ühendus. All Sihtkoht Component Set IDsisestage Seadkenime, mis vastab Seadkemääratletud Komponendidtab. All Sihtkoht Component Tase arvsisestage number, mis vastab komponendi tasandil, mida soovite ühendada sihtkohta otsas ühendus.

Märge

Selles näites soovime, et ühendada inimesi haldav serverid Serverid, et nad haldavad. Vastutavad inimesed olid määratletud Inimesed Seadkekui tase 2 komponenti samas serverid määratletud infrastruktuuri Seadkekui tase 2 komponente. Sidemedtab on täidetud vastavalt, nagu on näha allpool oleval pildil.

Ühendused Tab 1. osa 2

4. Kui liigute õiges leiad lisavõimalusi impordib oma ühendusi. Võta tüüp veerustja Connection Type Value või veergtöötavad samal viisil nagu tekstid Komponendidtab.

5. Kui Allikas Component Set ID ja Allikas Component Tase arvon sama Sihtkoht Component Set ID ja Sihtkoht Component Tase arv(näiteks kui te ühendate sama komponent tüüpi, milleks on näiteks ühendused serverid teistele serveritele), siis peate teise veeru taulukkolaskentaohjelmassasi, mis sisaldab isikute nimed serverid korrata. Sellises olukorras sa paneks, et tabelisse veeru Sihtkoht veerus korratudkolonni. Kui selles tabelisse veeru olete sisestanud rohkem kui ühe ühendatud komponent elemendi kohta, siis märkige ruut all Ravida New Lines eraldi komponentidena.

Ühendused Tab 2. osa 2

6. Kui ühendused on kindlaks valige ühendus soovite asustada omadused ja / või standardite ja laiendada klikates [+]kirjutama.

7. Valima Omadused Need ühendusedvõi Standardid nende ühendusedalates laiendatud nimekiri ja asustada vastavates veergudes, kui vaja.

Märge

Omadused Need ühendusedvõimaldab määrata omadused valitud ühenduslülina. Normid Need ühendusedvõimaldab määrata standarditega ja nende standard omadused valitud ühenduslülina.

8. Korrake samme 2-7kuni kõik seoses järgi on määratud.

9. Kui olete lõpetanud määratlemisel ühenduslülid, klõpsa Finišnuppu ja oma arhitektuuris on loodud imporditud Excel fail. Ülaltoodud näide toob kaasa arhitektuur näidatud allpool oleval pildil.

Proovi Arhitektuur Sissetoodud Excel

10. Nüüd päästa kaardistatud konfiguratsiooni faili klikates Salvesta konfiguratsioonikooni. Teie salvestatud konfiguratsiooni saab hiljem taastada klikates Avage Configurationikooni ülaosas vasakul nurgas aken.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Asustamine oma arhitektuuri Access | Asustamine oma arhitektuuri Visio


Asustamine oma arhitektuuri Microsoft SharePoint

Navigation: asustamine oma arhitektuuri> asustamine Microsofti tooted>

Asustamine oma arhitektuuri Microsoft SharePoint

Saada kommentaare selle teema.

Sa saad sünkroniseerima Sinu arhitektuuri koosMicrosoft SharePoint nimekirjad. Sünkroniseerimine tähendab kas uute SharePoint nimekirjad (ja nende veerud) alates ABACUS tüübid, nende omadused ja manuste või kaardistada olemasolevad SharePoint nimekirjad (ja nende veerud) arvelaud tüübid, nende omadused ja manuseid, siis kas saates sisu arvelaud SharePoint või SharePoint arvelaud.

Märge

SharePoint Sync funktsioon nõuab, et Microsoft SharePoint 2010, 2013või SharePoint Online Sait on saadaval ühendada ja sünkroonida.Kuigi SharePoint Sync funktsioon võib luua nimekirju (sammastega) SharePointi saidil igast ABACUS projekti, Avolution võib pakkuda ka erinevaid SharePoint saidimallide toetuseks standard raamistikud (näiteks TOGAF, ArchiMate, ITIL jne) nii et palun võtke Avolution Support kui teil on vaja see võimalus.

Kuni luua uus SharePointi loendi ja kaardistada selle mõnele ABACUS komponent või ühenduse tüüp

1. Veenduge, et teil on ABACUS avatud.

2. Valima Tööriistad | SharePoint Sync.

3. Klõpsake New kaardistaminenuppu ja SharePoint Mapping dialoog, nagu allpool näidatud ilmub.

4. Sisestage Site URL, kasutajanime ja parooli SharePointi sait ja klõpsake Ühendage.

Märge

Kehtiv SharePoint "admin" või "toetaja" konto on kohustatud sünkroonida ja SharePoint ja "lugeja" kontole võimaldab üksnes sünkroonis SharePoint.

5. Vali ABACUS komponent või ühenduse tüüp kaardistada alates Vali tüüp lammutama.

6. Klõpsake Lisa uusnuppu ja seejärel iga ABACUS komponent või ühenduse tüüp aspekt, mida soovite kaarti, et vastava SharePointi loendi valdkonnas elemendi valimiseks vasakul paneelil ja paremal pool sisestada uue SharePointi loendi nime New loetelu veerus (ainult esimene kord) , siis SharePoint veerus nime veerg nimi (või kasutage vaikimisi) ja klõpsake Määra iga kord.

Märge

Minimaalselt lubada sünkroniseerimine ABACUS EEID, arhitektuur ja nimi aspekte automaatselt kaardistatakse SharePoint arv ja kahe (2) üherealised (aka Text) veerud vastavalt. Neid ei saa määramata. Lisaks ainult teatud ABACUS aspekte võib praegu kaardistatakse teatud SharePoint sambad ja Kolonni tüüp rippmenüüst saab automaatselt vajaliku SharePoint veerus tüübist.Nimelt;

· ABACUS "hierarhia Tee SharePoint mitu rida teksti (aka märkus) kolonnid (Märkus: SharePoint üherealised (aka Text) sambad toetavad ainult 255 tähemärki et nad ei ole eelistatud),

· ABACUS "Lisatud Components SharePointi Otsing sambad (Märkus: kaardistamine peab juba olemas nimekiri jaoks lisatud komponente ise),

· ABACUS "Tekst ja kirjeldus omadused SharePointi mitu rida teksti (aka märkus) kolonnid (Märkus: SharePoint üherealised (aka Text) sambad toetavad ainult 255 tähemärki et nad ei ole eelistatud),

· ABACUS "Decimal või Integer omadused SharePoint arv veerge,

· ABACUS "Nimekiri omadused SharePoint Choice sambad (Märkus: SharePoint ei sunni valikut väärtused nii Nimekiri andmete tüüp ei vaja jõustada ABACUS)

· ABACUS "Date / Time omadused SharePoint mitu rida teksti (aka märkus) kolonnid (Märkus: SharePoint Kuupäev ja aeg sambad ei saa kasutada veel saabunud SharePoint ebaühtlasele toetust ajatsooni / piirkondadeks seaded),

· ABACUS "Loogiline omadused SharePoint jah / ei (aka Boole'i) veerud.

ABACUS elemendi Associated Standards ei saa kaardistada SharePointi loendi veerud veel.

7. Valima Loo kaardistamine.

Kuni luua uus kaardistamistarkvaraga vahel ABACUS komponent või ühenduse tüüp ja olemasoleva SharePoint nimekirja

1. Veenduge, et teil on ABACUS avatud.

2. Valima Tööriistad | SharePoint Sync.

3. Klõpsake New kaardistaminenuppu ja SharePoint Mapping dialoog, nagu allpool näidatud ilmub.

4. Sisestage Site URL, kasutajanime ja parooli SharePointi sait ja klõpsake Ühendage.

Märge

Kehtiv SharePoint "admin" või "toetaja" konto on kohustatud sünkroonida ja SharePoint ja "lugeja" kontole võimaldab üksnes sünkroonis SharePoint.

5. Vali ABACUS komponent või ühenduse tüüp kaardistada alates Vali tüüp lammutama.

6. Vali SharePointi sait nimekirja kaardistada alates Vali Nimekiri lammutama.

7. Iga ABACUS komponent või ühenduse tüüp aspekt, mida soovite kaarti oma vastava SharePointi loendi veerg elemendi valimiseks vasakul paneelil ja paremal pool vastavalt ja klõpsa Määra.

Märge

Minimaalselt lubada sünkroniseerimine ABACUS EEID, arhitektuur ja nimi aspekte tuleb kaardistatakse SharePoint arv ja siis Arhitektuur ja nimi kas üherealised (aka Text) või mitu rida teksti (aka märkus) veerud vastavalt. Kuni seda tehakse Loo kaardistamine nuppu ei võimaldanud. Lisaks ainult teatud ABACUS aspekte võib praegu kaardistatakse teatud SharePoint sambad.Nimelt;

· ABACUS "Arhitektuur aspekt SharePointi üherealised (aka Text) või mitu rida teksti (aka märkus) kolonnid (see on vajalik sisu konkreetse kaardistamine kirjeldatud allpool),

· ABACUS "hierarhia Tee SharePoint üherealised (aka Text) või mitu rida teksti (aka märkus) kolonnid (Märkus: SharePoint üherealised (aka Text) sambad toetavad ainult 255 tähemärki nii täiendavaid tähemärki kärbitakse ja seetõttu on soovitatav muuta neid mitu rida teksti (aka märkus) veergude SharePoint enne kaardistamine),

· ABACUS "Lisatud Components SharePointi Otsing sambad (Märkus: kaardistamine peab juba olemas nimekiri jaoks lisatud komponente ise),

· ABACUS "Tekst ja kirjeldus omadused SharePointi üherealised (aka Text) või mitu rida teksti (aka märkus) kolonnid (Märkus: SharePoint üherealised (aka Text) sambad toetavad ainult 255 tähemärki nii täiendavaid tähemärki kärbitakse ja seetõttu on soovitatav muuta neid mitu rida teksti (aka märkus) veergude SharePoint enne kaardistamine),

· ABACUS "Decimal või Integer omadused SharePoint arv veergudes (Märkus: SharePoint Arvestuslik sambad saab kasutada aga nad saavad ainult sünkroniseeritud SharePoint arvelaud. Proovite sünkroonida" kuni "arvutatud veerg toob kaasa hoiatuse kohta allpool) ,

· ABACUS "Nimekiri omadused SharePoint Choice sambad,

· ABACUS "Date / Time omadused SharePoint mitu rida teksti (aka märkus) kolonnid (Märkus: SharePoint Kuupäev ja aeg sambad ei saa kasutada, kuna SharePoint ebaühtlasele toetust ajatsooni / piirkondadeks seaded),

· ABACUS "Loogiline omadused SharePoint jah / ei (aka Boole'i) veerud.

ABACUS elemendi Associated Standards ei saa kaardistada SharePointi loendi veerud veel. Ja SharePoint valuutariski, isik või grupp, Hüperlink või pilt, tulemuses, Välised andmed ja Haldaja Metaandmed sambad ei saa paigutada arvelaud aspektid veel.

8. Valima Loo kaardistamine.

Kuni sünkroniseerimaMicrosoft SharePointi loendi (te)arvesse ABACUS

1. Veenduge, et teil on ABACUS avatud.

2. Valima Tööriistad | SharePoint Sync.

Märge

Kuni sünkroniseerida SharePoint nimekirja koosABACUS projekti kasutaja litsents vajab SharePoint Syncadd-on võime. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

3. Valige olemasolev SharePoint kaardistamine (või kaardistamisel kasutades Ctrl-klikkvõi Vali kõiknuppu) alates SharePoint Kirjeldusedpaneelnagu näidatud proov screenshot eespool. Märkus: siin näitame ainult "Goal (või nõue) ABACUS tüübikinnitusmärgi kaardistamine SharePointi loendi nimega Eesmärgid on valitud.

4. Valige Arhitektuur (s), mida soovite sünkroonida sisu alates Sync Sisu alates arhitektuuridtoimkonnale näidatud proov screenshot eespool. Märkus: siin näitame ainult "2015 Tegelik" arhitektuuri on sünkroniseerida.

5. Valige Sync SPnupp.

Märge

Kui SharePointi saidil volikirja ei ole "kõik salvestatud" kaardistamise (s) valitud siis sisse SharePoint ilmub dialoog jaoks Saidi URL, Kasutajanimi ja / või Salasõna.Palun sisestage need. Lisaks sünkroniseerimine hõlmab muu kaardistamisel, mis on vajalikud lisatud komponentide / lookup sambad. Kõik täiendavad kaardistamisel, mis on automaatselt näidatakse dialoogi kohta allpool.

6. Edukalt sünkroniseerimine SharePointi Sync tulemused, ilmub dialoog, nagu allpool loetletud muudatuste ja hoiatusi. Vajuta Okei.

Kuni sünkroonimiseks arvelaud Microsoft SharePointi loendi (te)

1. Veenduge, et teil on ABACUS avatud.

2. Valima Tööriistad | SharePoint Sync.

Märge

Kuni sünkroniseerida SharePoint nimekirja koosABACUS projekti kasutaja litsents vajab SharePoint Syncadd-on võime. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

3. Valige olemasolev SharePoint kaardistamine (või kaardistamisel kasutades Ctrl-klikkvõi Vali kõiknuppu) alates SharePoint Kirjeldusedpaneelnagu näidatud proov screenshot eespool. Märkus: siin näitame ainult "Goal (või nõue) ABACUS tüübikinnitusmärgi kaardistamine SharePointi loendi nimega Eesmärgid on valitud.

4. Valige Arhitektuur (s), mida soovite sünkroonida sisu alates Sync Sisu alates arhitektuuridtoimkonnale näidatud proov screenshot eespool. Märkus: siin näitame ainult "2015 Tegelik" arhitektuuri on sünkroniseerida.

5. Valige Sync To SPnupp.

Märge

Kui SharePointi saidil volikirja ei ole "kõik salvestatud" kaardistamise (s) valitud siis sisse SharePoint ilmub dialoog jaoks Saidi URL, Kasutajanimi ja / või Salasõna.Palun sisestage need. Lisaks sünkroniseerimine hõlmab muu kaardistamisel, mis on vajalikud lisatud komponentide / lookup sambad. Kõik täiendavad kaardistamisel, mis on automaatselt näidatakse dialoogi kohta allpool.

6. Edukalt sünkroniseerimine SharePointi Sync tulemused, ilmub dialoog, nagu allpool loetletud muudatuste ja hoiatusi. Vajuta Okei.

Märge

ABACUS uuendab SharePoint sambad nullproovidega isegi kui Nõua, et see veerg sisaldab andmeid "on seatud Jah SharePoint. Seda seetõttu, et SharePoint ei jäta seda seadistust väliselt. Kui see on võimalik vältida, on soovitatav, et ABACUS Designer seab sobiv takistus True ja jõustanud antud vara kasutades ABACUS " piirang tunnusjoon .

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Asustamine oma arhitektuuri Visio | Asustamine oma arhitektuuri Excel


Asustamine oma arhitektuuri Microsoft SQL Server

Navigation: asustamine oma arhitektuuri> asustamine Microsofti tooted>

Asustamine oma arhitektuuri Microsoft SQL Server

Saada kommentaare selle teema.

Saate importida oma arhitektuuri Microsoft SQL Server andmebaasi. Teil on valida lihtsalt importida Lauad ja suhted tõhusalt importiva lihtsalt üldise andmebaasi struktuuri või tabelid, Ridade ja suhted, mis impordib mitte ainult struktuuri kuid andmed samuti.

Märge

Kellelt SQL Server funktsiooni kasutamiseks on vaja, et Microsoft SQL Server 20052008, 2008 R2, 2012 või 2014on arvutisse installitud.

Importida Microsoft SQL Server andmebaasi ABACUS

1. Veenduge, et teil on ABACUS avatud.

2. Vali Fail | Uus ja valige SQL Serveralates ilmuvasse dialoogi ja klõpsake OK.

3. Impordi SQL Server ilmuvas dialoogiaknas määrata "MachineName" ja "SQLINSTANCE" väärtused seoses string muutuja ja "dbname" väärtus Database Name muutuva nende õige väärtusi nagu näidatud proovi pilt allpool.

4. Määra Database Name muutuja sama väärtusega kui Initial Catalog muutuja seatud samm eespool, nagu näidatud proovi pilt allpool.

5. Vajuta Test Connection nuppu ja tabelid Import Dialoogi tuleks asustatud olemasolevate andmebaasi tabeleid, nagu näidatud proovi pilt allpool.

6. Vali tabelid, mida soovite importida kas individuaalselt, valides neid või kasutavad kõik, Puudub tagurpidi nuppe Dialoogi parempoolses osas.

Märge

Ainult Foreign Key suhteid, mis vahel on tabelid, et valida saavad imporditud.

7. Kasutades Import Style nupp valida, kas soovid importida ainult Lauad ja nendevahelised suhted või tabelid, oma rida ja konkreetsed seosed read.

Märge

Esimene võimalus impordib Lauad osadena tüüp "Tabel" ja seosed tahes kaks tabelit (alates välismaa võtmed) on imporditud ühendused tüüpi "Tabel suhe". See on klassikaline "ERD" stiilis Arvestades süsteemi tabelid. Teine variant impordib tabeli read eraldiseisvate alakomponentides tüüpi "Tabel Row", mille omadused vastavad igasse veergu / valdkondades ja suhetes tabeli read tüüpi "Tabel suhe". Pealegi, kui on olemas kolonn / väli nimega "nimi", siis kasutatakse seda nimetada üksikute Tabel Row alakomponentides.

8. Vali Import ... nuppu.

9. Pärast lühikest aega (koos edistymispalkki tagasisidet) uue ABACUS projekt loodud, laudade read (kui teine ​​variant oli valitud samm eespool) ja suhted Microsofti SQL Server andmebaasi.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Asustamine oma arhitektuuri käsitsi | Asustamine oma arhitektuuri Visio | Asustamine oma arhitektuuri Excel


Lisades eelseadistatud omadused komponent, ühendus või tüübi

Navigation: asustamine oma arhitektuuri> Properties>

Lisades eelseadistatud omadused komponent, ühendus või tüübi

Saada kommentaare selle teema.

Standard raamatukogud omadusi saab täpsustada ja määrata midagi arhitektuuris. Need raamatukogud tuntakse Standardid. Kasutades StandardidTe ainult vaja koguda konkreetsete süsteemide omadusi - standard omadused on juba olemas.

Näiteks standard toimivusomaduste Microsoft Windows 2000 võib salvestatakseStandardja määrata igale komponendid (või ühendused, mitte et see oleks tüüpiline) kasutades Microsoft Windows 2000 operatsioonisüsteemi.

Lisadastandardkomponendiga, ühendus või tüübi

1. Paremklõpsosale / ühendus / tüübist.

2. Valima Määra Standard.

3. ValimaStandardnimekirjast.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Muutuvad omadused komponent, ühendus või tüübi | Täitematerjalide


Muutuvad omadused komponent, ühendus või tüübi

Navigation: asustamine oma arhitektuuri> Properties>

Muutuvad omadused komponent, ühendus või tüübi

Saada kommentaare selle teema.

Omadused on tavaliselt süsteemi nõuded, et teil määratleda, või tulemused ABACUS hinnangutest. (Kui ABACUS täidab oma hinnanguid, siis kirjutab omadused tagasi faili.) Teisisõnu omadused on asju, mida sa tead oma süsteemi, või asjad, mida sa kasutad arvelaud teada.

Et muuta vara väärtuse osa, ühendus või tüübi

1. Vajutaosale / ühendus / tüüp (selle omadusi kuvatakse Properties akna paremal).

2. Vajutarõhutada vara, mida soovite muuta.

3. Tüüpuus väärtus.

Oluline

Ka paljud omadused on määratud, kasutades Standardid . Muutes vara jooksulStandardSa mitte ainult ei muuda praegust objekti, siis muutuvad ka kapten Standard (all Standarditetop puud). Enne seda teed, vaadata, mida teised komponendid, ühendused või liigid kasutavad Standard, Sest muutus ei pruugi olla neile oluline- Saate Viited akna selle.

Ots

Teil on võimalik muuta ühenduse omadusi seest Components puusse (ja vastupidi). Nii näiteks, kui te vaatate, mis seos on lisatud osa, ja sa mõistad, sa pead muutma ühe, saate.

Et lisada uusi omadusi osa või ühendus (via tüübist)

Märge

Omadused saab lisada liigid ja komponendid või ühendused tüüpi "pärida" need omadused.

1. Vajutatüübist (selle omadusi kuvatakse Properties akna paremal).

2. Vajutanupule Lisa ülaosas Property aknas lisada rida ülaosas vara grid uue vara.

3. Lisa TüüpUue vara.

4. Lisa NimiUue vara.

5. Lisa VaikeväärtusUue vara.

6. Lisa ÜhikUue vara.

7. Seadke Data TypeUue vara.

Märge

Andmetüüp valdkonnas saab piirata kehtivad väärtused, et vara võib olla. See on; Tekst, Integer, Decimal, Date / Time, Boole'i ​​või loetelu.

o A Tekstkinnisvara on üks, mis on piiramatu arvu märke ja sisuliselt ei ole piiranguid väärtus.Kui vara väärtus on õigesti kirjutatud hüperlink (st URL vaja alustuseks üks 5stringe; http: // https: //, ftp: //,file:või \\ tahesruumid tuleb sisestada koos "% 20") Siis link on klikitav (via ctrl + click).

o Täisarvvara peab olema täisarv kas positiivne või negatiivneja võib sisaldada jooksul, ruumi, ülakoma või koma ette kohaline grupis sõltuvalt Projekti Piirkond seaded pärit Faili | Projekti valikud.Regiooni seadistusi ja.Võrk Long.TryParse meetod on kasutatakse, et määrata kehtiv Täisarvväärtused.

o A Decimalvara võib sisaldada perioodi või koma ette koma sümbol, mis võivad sisaldada perioodil, ruumi, ülakoma või koma ette kohaline grupis sõltuvalt Projekti Piirkond seaded pärit Faili | Projekti valikud.Regiooni seadistusi ja.Võrk Decimal.TryParse meetod on kasutatakse, et määrata kehtiv Decimal väärtused.

o A Kuupäev / aegvara võimaldab kas Date osa või Time osa või nii. Regioonseadedja .Net DateTime.TryParse meetod kasutatakse eelkõige kindlaks kehtiv kuupäev ja / või Time väärtusi. Kuid Date osa vajaduse korral nõuab vähemalt päeva ja kuud (aasta tuleb eeldatavalt käesoleva aasta) või kuu ja aasta osad kehtivuse. St Juunis Q3 2010 või isegi ainult 2010 on kehtetud. Kuigi see on erinev erinevate piirkondlike oludega, tavaliselt päev, kuu ja aasta osi on võimalik eristada tühik, koma kriips (-) või kaldkriips (/). The Day osa tavaliselt on täisarv vahemikus 1 kuni 31. Kuu osa on tavaliselt täisarv 1 kuni 12, kehtiv 3 kirja lühend kuud (nt Jan, veebr) või Kuu täielik nimi (nt jaanuar, veebruar märtsil). Aasta osa on tavaliselt 4-kohaline positiivne arv, kuid 1, 2 ja 3 kohaline aastat aktsepteeritakse vastavalt seaded Control Panel> Regional and Language Options> Regional Options> Kohanda (nupp) -> kuupäev:> Kalender. Tavaliselt neid tõlgendatakse järgmiselt; 0-29 tõlgendatakse 2000-2029, 30-99 kui 1930-1999 ja 100-999 nii 100-999. Vale kuupäev nagu 31. juuni 2010 ja 31/9/2010 tuvastatakse. Aeg osa vajaduse korral nõuab Tundide ja Minutite osa ja vajadusel Seconds osa. Tunnid, minutid ja vabatahtlik Seconds osad on tavaliselt eraldatud kooloniga (':') ja Seconds osa saab tellida koma ("."). Täiendavat teavet kehtiv formaate palun vaadake Märkused jagu NET DateTime.TryParse meetod .

Ots

Soovitatav on kasutada vähemalt 3 kirja kuu nimi formaadis (st "juuli" või "juuli") kuupäeva väärtuste asemel numbrilisi vormingu (nt "7" või "07"), kuna need väärtused kinnitama üle kõige piirkondades sõltuvalt aru projekti Piirkond seaded pärit Faili | Projekti valikud.St on soovitatav kasutada "15. juuli 2010", mitte "15/7/2010" või "2010/07/15". Selle näiteks "15/7/2010" ei aita valideerimist "English (United States) ja" 2010/07/15 "jääb täitmata" English (United Kingdom) ", aga" 15. juuli 2010 "oleks liigu mõlemat.

o A Loogilinevara võib olla kas tõene või väär.See on tõstutundetu tõsi või FALSE saab kasutada ka aga jah, ei, 1, 0 jne kõik suuda kõiki omandi piirangud.

o A Nimekirivara võimaldab kollektsiooni eeldefineeritud väärtusi nagu Madal | Medium | Kõrge või Valida | Värskenda | Plaani | Pensionile ja väärtuste vahemik pärineb Unit valdkonnas vara kas koma või toru "|" eraldatud väärtusi. Vara võib pidada järgarvud (erinevalt nominaalne, intervalli või suhte), sest kui kasutada graafikuid ja värvi elemendid skeems ja 3DS väärtusi käsitleda lihtsalt kasvavas (või kahanevalt) järjekorras. See on graafikule kasvavalt (või kahanevalt) Et diagrammil telgedega või värvus.

8. Andmete tüüp saab seada olla Invaliidistunud, Hoiatasvõi Sunniviisilineparemklõpsu Data Type valdkonnas mis tahes muu kui tekst, mis võimaldab ühtegi märki, et ei saa kunagi olla vale.

9. Seadke Nõutavlipu uus vara.

Märge

Nõutud väli saab näidata, et väärtus tuleb sisestada vara. See on, et see ei saa olla tühi või tühjad. FalseVaikimisi on ja tähendab vara võib olla tühi või tühi, Tõsitähendab, et vara väärtus peab olema ja ei tohi olla tühi või tühi. Nõutav saab seada olla Invaliidistunud, Hoiatasvõi Sunniviisilineparemklõpsu sobiv valdkonnas, kui see on seatud True.

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Lisades eelseadistatud omadused komponent, ühendus või tüübi | Täitematerjalide


Muutuv Projekti piirkonna seaded

Navigation: asustamine oma arhitektuuri> Properties>

Muutuv Projekti piirkonna seaded

Saada kommentaare selle teema.

Kinnisvara väärtused nõuda teatud vormingu eri piirkondades suvalise Data Type piiranguid Integer, Decimal ja kuupäev / aeg omadused. Näiteks Austraalias koma "123456 punkti seitse kaheksa üheksa" on esindatud "123,456.789", samas kui Saksamaa oleks represnted nagu "123.456,789" ja Prantsusmaal oleks " 123 456789 ".Ka USA-"teine ​​detsember 1970" on esindatud lühikese kuupäev "1970/12/02" kuid Ühendkuningriigis on esindatud "1970/02/12" ja Poolas "1970-1912 -02 ". Seega töötada koos ABACUS projekti eri piirkondade kui kogu maailmas kohta ABACUS projekti on vaja.

Muutma ABACUS projekti piirkonna seaded

1. Veenduge, et teil on ABACUS failiavatud.

2. Valima Faili | Projekti valikud ... ja ilmuvas dialoogiaknas vali Piirkondja kliki OK. Märkus: Palun vaadake allpool piirkondliku vaikimisi.

Märge

Kui te ei näe Projekti valikud ... menüüvalikusiis ei ole Designer ja Administrator Lisasja sa ei saa muuta projekti piirkonnas.Samuti, kui ei ole Piirkond on seatud (st piirkonna Projekti valikud on "Puudub (System Region)"), siis iga kasutaja MS Windows praeguse kultuuri seaded (st Regional Settings)kasutatakse kinnitamiseks omadused.

Piirkond vaikimisi

Järgnev tabel loetleb vaikimisi iga piirkonna määratud läbi Faili | Projekti valikud ...menüüvaliku.Palun vaata allpool tabelis nimekirja sümboleid kasutatakse.

Piirkond | Decimal Symbol | Digit rühmitus | Negatiivne märk | Lühike aeg | Kaua aega | AM / PM sümbolit | Lühike kuupäev | Pikk kuupäev
Inglise (Austraalia) | . | , | - | HH: mm | HH: mm: ss | AM | PM | pp / kk / aaaa | dd MMMM yyyy
English (United Kingdom) | . | , | - | HH: mm | HH: mm: ss | AM | PM | pp / kk / aaaa | dd MMMM yyyy
English (United States) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / aaaa | dddd, MMMM dd, aaaa
Prantsuse (Prantsusmaa) | , | ruum | - | HH: mm | HH: mm: ss | | | pp / kk / aaaa | dddd d MMMM yyyy
Saksa (Saksamaa) | , | . | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM yyyy
Itaalia (Itaalia) | , | . | - | HH: mm | HH: mm: ss | | | pp / kk / aaaa | dddd d MMMM yyyy
Hispaania (Hispaania) | , | . | - | H: mm | H: mm: ss | | | pp / kk / aaaa | dddd, dd "de" MMMM "de" yyyy
Inglise (Kanada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | pp / kk / aaaa | MMMM-pp-aaaa
Prantsuse (Kanada) | , | ruum | - | HH: mm | HH: mm: ss | | | aaaa-kk-pp | d MMMM yyyy
Araabia (AÜE) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | pp / kk / aaaa | dd MMMM yyyy
Araabia (Saudi Araabia) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | pp / kk / aaaa | dd / MMMM / aaaa
Inglise (Lõuna-Aafrika) | , | ruum | - | hh: mm tt | hh: mm: ss tt | AM | PM | aaaa / kk / pp | dd MMMM yyyy
Inglise (Uus-Meremaa) | . | , | - | h: mm tt | h: mm: ss tt | a.m. | Pärastlõunal. | d / MM / YYYY | dddd, päeva MMMM yyyy
Inglise (India) | . | , | - | HH: mm | HH: mm: ss | AM | PM | PP-KK-AAAA | dd MMMM yyyy
Saksa (Šveits) | . | ' | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM yyyy
Prantsuse (Belgia) | , | . | - | HH: mm | HH: mm: ss | | | d / MM / YYYY | dddd d MMMM yyyy
Hollandi (Belgia) | , | . | - | H: mm | H: mm: ss | | | d / MM / YYYY | dddd d MMMM yyyy
Tšehhi (Tšehhi) | , | ruum | - | H: mm | H: mm: ss | DOP. | odp. | d.M.yyyy | d. MMMM yyyy
Taani (Taani) | , | . | - | HH: mm | HH: mm: ss | | | PP-KK-AAAA | d. MMMM yyyy
Kreeka (Kreeka) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / aaaa | dddd, päeva MMMM yyyy
Soome (Soome) | , | ruum | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta "yyyy
Ungari (Ungari) | , | ruum | - | H: mm | H: mm: ss | de. | du. | yyyy.MM.dd. | aaaa. MMMM d.
Hollandi (Holland) | , | . | - | H: mm | H: mm: ss | | | d-M-aaaa | dddd d MMMM yyyy
Norra, eesti (Norra) | , | ruum | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | d. MMMM yyyy
Poola (Poola) | , | ruum | - | HH: mm | HH: mm: ss | | | aaaa-kk-pp | d MMMM yyyy
Vene (Venemaa) | , | ruum | - | H: mm | H: mm: ss | | | dd.MM.yyyy | d MMMM yyyy "г."
Rootsi (Rootsi) | , | ruum | - | HH: mm | HH: mm: ss | | | aaaa-kk-pp | "den 'd MMMM yyyy
Korea (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | aaaa-kk-pp | aaaa "년" M "월" d "일" dddd
Heebrea (Iisrael) | . | , | - | HH: mm | HH: mm: ss | AM | PM | pp / kk / aaaa | dddd dd MMMM yyyy

Järgmised sümboleid kasutatakse täpsustama kuupäevad ja kellaajad kuvatakse:

Aeg sümbolid |
h | Tund (hh kuvab tund nulliga)
m | Hetke (mm kuvab minut nulliga)
s | Teiseks (ss kuvab teine ​​nulliga)
tt | Ennelõunasest või pärast keskpäeva
h / H | 12 või 24 tunni möödudes ekraan
Kuupäev sümbolid |
d, dd | Päev
ddd, dddd | Nädalapäev
M | Kuu
y | Aasta

Vaata ka

Asustamine oma arhitektuuri - ülevaade | Muutuvad omadused komponent, ühendus või tüübi | Lisades eelseadistatud omadused komponent, ühendus või tüübi


Täitematerjalide

Navigation: asustamine oma arhitektuuri> Properties>

Täitematerjalide

Saada kommentaare selle teema.

Operatsioon "agregaat Omadused"Võimaldab teil lisada väärtust sarnased omadused kokku ja kirjutada (või lisada) tulemus arvesse valitud vanem elemendi omadused. Samuti saate piiritleda koondamise ja kas uuendada omadused kõik sub-elemente või mitte.

Et täitematerjalide

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Paremklõpsake elementi (arhitektuur, osa või ühendus) mis teha liitmise ja valige Täitematerjalide.

3. Vali üks agregaat Options (Traverse Kõik alamtasemetevõi Ainult Direct Alamtase). Kui olete valinud Traverse Kõik alamtasemete, Siis võib valida ka variant, kas Värskenda alamtasemete.

o Traverse Kõik alamtasemetetähendab, et reguleerimisala liitmist sisaldab elemente kõik tasemed all valitud element.

o Värskenda alamtasemetesaab teha ainult siis, kui olete ka valinud variandi Traverse Kõik alamtasemete. See tähendab, et kui sa täitematerjalide alt üles, on koondtulemus igal tasandil ajakohastatakse ka igasse vastava elemente.

o Ainult Direct Alamtasetähendab, et ainult omadusi elemendid otse alla valitud element summeeritakse.

o Valima Sisaldama StandardOmadusedKui soovite, et omadused on määratletud standardid kuuluda. Vastasel korral ainult omadused unikaalne iga komponendi Näiteks hakatakse kasutama.

4. Vali milliste omaduste soovite summeerida. Nad on grupeeritud nende Tüübid.

5. Klõpsake Järgminenuppu.

6. Vali variant, kas Ülekirjutamine väärtusedvõi Lisa väärtusedarvesse valitud element.

o Ülekirjutamine väärtusedkirjutab tulemused otse omadusi valitud element.

o Lisa väärtusedlisab tekstile olemasolevale omadusi valitud element.

Vaata ka

Lisades eelseadistatud omadused komponent, ühendus või tüübi | Muutuvad omadused komponent, ühendus või tüübi | Hindamine oma arhitektuuri


Analüüsides oma arhitektuuri

Navigation: Analüüsides oma arhitektuuri>

Analüüsides oma arhitektuuri

Saada kommentaare selle teema.

Kui oled asustatud (ja vajadusel simuleeritud) oma arhitektuuri, oled valmis kasutama arvelaud analüüsida. Analüüsides seda, saate määrata, kas teie arhitektuuri rahuldada oma vajadusi.

Saate analüüsida oma arhitektuuri erinevaid võimalusi:

· Skeem

· 3D vaade

· standard kaardid (pirukas, rida, veerg, baar, jne)

· custom kaardid ( reaktsiooniaeg , võime ruumi , star plot , hajuvusgraafik maatriks ja mulligraafiku )

· Arhitektuur Diff

Märge

Luues diagramm, 3D vaade, Aruande või standard skeem, standard element valiku aken kasutatakse, et valida elemente, mida soovite vaadata.

Vaata ka

Asustamine oma arhitektuuri | Simuleerimine oma arhitektuuri | Diagramming Tool


Standard Element Selection

Navigation: Analüüsides oma arhitektuuri>

Standard Element Selection

Saada kommentaare selle teema.

Luues diagramm, 3D vaade, aruanne,standard skeemvõi töötab simulatsioon, Standard element valiku aken kasutatakse, et valida elemente soovite analüüsida / vaade.

Standard Element Selection Window

Pulldowns

· Filtreeri Vaatatahe sisaldama elements on varem salvestatud vaade (st diagramm, joonis, 3d). Sel moel saab täita keerukaid "liituda" päringut töödelda teistsugune kui salvestatud "päringu".

Linnukesed

· Show Levelskoondataks element vastavalt tasemele, kus nad esinevad puu. Tase 1 on top Kõige tasandil.

· Näita liigidtahe rühma elemendid vastavalt tüüpi, et nad on.

· Vanemad valitudsisaldab vanema elemendid tahes valitud elemendid. Sel moel saab tagada üksnes hierarhia kõrgemal lapsi kaasatakse jaoks "alt-üles" valikut.

· Lapsed valitudhõlmavad laste elemendid tahes elementidele. Sel moel saab tagada üksnes hierarhia allpool ükskõik milliseid vanemad on lisatud "ülevalt-alla" valikut.

· Klapib Valuehõlmab ainult neid elemente, mis on nime sisaldava määratud stringi (Pange tähele: metamärkidest (st? ja *) võib kasutada). Sel moel saab moodustada "semantiline" päringut.

· Kas Kinnisvara tüüp / nimi / väärtushõlmab ainult neid elemente, mis on Property liik, nimetus ja väärtus, mis sisaldab määratud stringi kas otse element või selle standardid (Pange tähele: metamärkidest (st? ja *) võib kasutada. Nt? * Value väli anda kõik elemendid, mis on mitte-tühi Väärtus antud Property). Sel moel saab moodustada "semantiline" päringut.

· Omab Standardhõlmab ainult neid elemente, mis on Standard nimes sisaldub määratud stringi (Pange tähele: metamärkidest (st? ja *) võib kasutada. Nt HP * annab kõik elemendid vähemalt ühe Standard algab tähtedega H ja P). Sel moel saab moodustada "semantiline" päringut.

· Komponendid / Connections lisatud valitudsisaldab kõikide lisatud elemente nendega, mis on välja valitud. Sel viisil "kõne-tree" või "mõjude analüüsi" saab valida.

Märge

Kui teil on nii Show Levelsja Näita liigidvalitud, siis saate valida, kas puu näidata taset esimesel või tüüpi esmalt nuppu, mis ilmub üle kahe ruudud.

Ots

Kui objekt on valitud Standard Element Selection Window, siis ei ole vaja täiendavat filter muutusi, kuni see tühistatakse. Kuna ei ole native võimalus otsida kahte erinevat elementi korraga (nt koostisained Standard või Standard B), saate otsida kõigepealt ühe komplekti, vali soovitud komponente, ja seejärel täita teist otsida teine ​​komplekt .

Nupud

· Kõikvalib kõik elemendid.

· Teistpiditühistab kõik valitud elemendid ja valib kõik need, kes ei valitud.

· Mitte ükskitühistab kõik elemendid.

· Lisa Filtervalib tulemuseks sisu praegune filter seaded ja võimaldab valida täiendava sisu tõhusalt JA-või liituda filter.

Vaata ka

Analüüsides oma arhitektuuri


Kasutaja 3D skeem

Navigation: Analüüsides oma arhitektuuri> 3D diagrammid>

Kasutaja 3D skeem

Saada kommentaare selle teema.

ABACUS võimaldab teil vaadata oma arhitektuuri 3D vaade, kus osa ja seotud omadused on seotud värvi, kuju ja suurusega.

Et vaadata 3D vaade oma arhitektuuri

1. Veenduge, et teil on avada ABACUS failisisaldab teie asustatud arhitektuuri.

2. Laiendada Viewspuusse.

3. Laiendada 3Dpuusse.

4. Topeltklõps visualiseerimine, mida soovite avada.

- Või -

1. Veenduge, et teil on avada ABACUS failisisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| 3Dvõi klõpsake tööriistaribal nuppu.

3. Avage olemasolevvisualiseerimine (.abacus3d)

- Või -

1. Veenduge, et teil on avada ABACUS failisisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| 3Dvõi klõpsake tööriistaribal nuppu.

3. Loo uus visualiseerimine:

· Valige Arhitektuurmida soovite vaadata alates rippmenüüst.

· Valige Komponendidja Sidemedsoovid lisada diagramm alates standard element valiku aken .

· Associate värvi, kuju ja suurusega koos Component liigidja Omadused.

· Associate värve ja kujundeid Connection liigidja Omadused.

Eksportida 3D vaade

1. Veenduge, et teil on avada olemasoleva 3D vaade.

2. 3D vaate rippmenüüd valida Faili | Ekspordi ...ja valis asukoha ja failitüüp visualiseerimine faili (.abacus3d, .vrml või .html).

3. Vajuta Salvesta.

Vaata ka

Analüüsides oma arhitektuuri | Navigation 3D | Skeemide ülesmärkimise Tool


Navigation 3D skeem

Navigation: Analüüsides oma arhitektuuri> 3D diagrammid>

Navigation 3D skeem

Saada kommentaare selle teema.

ABACUS võimaldab hõlpsasti liikuda oma arhitektuuri 3D. Kogemus on sarnane sõidab. On kaks viisi navigeerimine:

· Basic (vaikimisi); ja

· Täpsem Reguleerimisrežiim - muutus see režiim, valides Reguleerimine| Täpsem Reguleerimisrežiim.

Märge

Et vahetada Basic ja Advanced juhtrezhiimid saate F4kiirklahvi funktsionaalsust.

Basic režiim

· Hoia vasakut nuppu ja hiirt liigutades edasi või tagasi muutub pigi;

· Hoia vasakut nuppu ja liigutades hiirt vasakule või paremale muudab yaw;

· Hoides paremat nuppu ja hiirt liigutades pannid seisukohta;

· Hoides mõlemat nuppu all ja hiirt liigutades edasi või tagasi, suurendatakse ja vähendatakse arhitektuuri; ja

· Hoides mõlemat nuppu all ja liigutada hiirt vasakule või paremale, rullides vasakule ja paremale.

- Või -

· Vajutades Nool vasakuleklaviatuuri või numbriklahvistiku omakorda vasakule;

· Vajutades Nool paremaleklaviatuuri või numbriklahvistiku omakorda õigus;

· Vajutades Nool ülesklaviatuuri või numbriklahvistiku suumib;

· Vajutades Noolklaviatuuri või numbriklahvistiku suumib;

· Vajutades Page Upklaviatuuri või numbriklahvistiku on pigi üles; ja

· Vajutades Page Downklaviatuuri või numbriklahvistiku on pigi maha.

Täpsem Reguleerimisrežiim

· LiikumineHiire edasi ja tagasi, üles ja alla, muutub pigi ja yaw (vastavalt);

· Vajutades Wvõi Nool ülessuumib (edasi), et arhitektuur;

· Vajutades Svõi Noolzoom out (tagasi) alates arhitektuurist;

· Vajutades Avõi Nool vasakulerullides vasakule;

· Vajutades Dvõi Nool paremaleveereb paremale;

· Vajutades Qvõi Page Downtõstab vaade (alandades perspektiiv); ja

· Vajutades Evõi Page Uplangetab vaade (tõstes seisukohast).

Interaktiivne Reguleerimisrežiim

Vajutades ja hoides shiftklaviatuuril alistab praeguse režiimi (Basic või Advanced) siseneda interaktiivne juhtimisrežiim. Selles režiimis järgmine on võimalik:

· Rollhiirekursori osa või ühendus näha komponent või ühenduse nimi;

· Vajutaon komponendil suumimiseks, et osa;

· Vajuta-ja lohistageon komponendil vaate pööramiseks ümber, et osa; ja

· ParemklõpsOsa või ühendus ja valige Näita In Explorernäha, et osa või ühendus asukohta puus.

Ühine kontroll

· Kasuta ALT-Enter / ESClülitab täisekraanil;

· Kasuta F2kuva muutmiseks režiimis. See võib olla ka võimalik tutvuda VaadeMenu.

· Kasuta hiirerattavõi +/-muuta kiirust. Kiirus on näidatud mitmetes alumises vasakus nurgas - kuvatakse ainult siis, kui see on muutumas. 1 on kõige aeglasem ja 100 on kõige kiiremini.


Kasutaja standard skeem

Navigation: Analüüsides oma arhitektuuri> Standard kaardid>

Kasutaja standard skeem

Saada kommentaare selle teema.

ABACUS "standard graafikuid hulka line, baar, kolonn, piirkond, hajumine, pirukas, kõver, Pareto, samm, pind, radar, kuup, sõõrik, püramiid, kontuur ja kõver ala graafikuid. Kui olete valinud tüüpi diagrammi soovite, ülejäänud protsessi vaatamise kõik need kaardid on sama.

Et vaadata standard graafiku oma arhitektuuri

1. Veenduge, et teil on avada ABACUS failisisaldab teie asustatud arhitektuuri, Ja et teil on hinnataSinu arhitektuuri.

2. Valima Sisesta| Chartvõi klõpsake tööriistaribal nuppu. Äritegevusaken kuvatakse.

Äritegevus aknas

3. Vali tüüp skeem soovid ja määrata Chart Options, seejärel klõpsake Järgmine.

Chart Options

o Laotudnäitab, kuidas üksikud esemed kogu. Võid kasutada laotud skeem, kui teil on kavas on mitu andmesarja (st mitu omadused) ja kui sa tahad, et rõhutada kokku.

o Laotud 100%võrdleme protsent iga hinna aitab kokku erinevate kategooriate. Võid kasutada 100% laotud skeem, kui teil on kavas on mitu andmesarja (st mitu omadused) ja soovid rõhutada sissemakseid tervikuna, eriti kui kogusumma on sama iga element.

o 3D joonislihtsalt kuvada andmepunktidega 3-D formaadis esteetika. Kui soovite kuvada andmeid seeria mööda 3. / z-telje mõõdet, siis kasuta Cluster Series valik allpool kirjeldatud.

o Series by Propertykuvab andmed sarja iga vara, mis on lõppkokkuvõttes valitud. Kui see on märkimata, siis omadused muutuvad kategooriad ja andmete rida on iga element, mis on valitud.

o Pööra Chartpöörab skeem 90 kraadi päripäeva, vahetades x ja y telge. See valik on saadaval ainult Lines, Step ja Cube kaardidning on eriti kasulik teha Milestone graafikuid kirjeldatud teise otsa alla. Märkus: Veerg ja Bar graafikuid juba "pöörata" versioonid üksteist.

o Cluster Serieskuvab mitme rea andmeid mööda 3. / z-telje mõõtme. See valik on saadaval ainult kolonni Bar ja Cube kaardidning on eriti kasulik teha Gantt style graafikuid kirjeldatud esimeses Tip allpool.

Ots

Saate luua Gantti diagrammhorisontaalsete baarid näitab aeg / kuupäev omadused eri osade valides Bar diagrammi tüüp ja seejärel valides Cluster Series võimalus.Lisaks, kui on loodud, kõige vasakpoolsem baar diagrammi saab "nähtamatu" värvimine see valge paremklõpsu üks baarid, valides värve menüüst, mis ilmub ja valides ülevalt vasakult värvi palett. Lisaks piiri jaoks kõige vasakpoolsem bar saab "nähtamatu" paremklõpsu üks baarid, tuleb valida Omadused ... ning Series saki ilmuvasse dialoogi muutes ületavat mõju Puudub ja Colour üles -left värvi palett.

Ots

Saate luua Milestone skeemväikeste kuju näitab aeg / kuupäev omadused eri osade valides Cube diagrammi tüüp ja seejärel valides Pööra Chart ja Cluster Series võimalusi.Lisaks, kui on loodud, kuubikud saab muuta teiste kujundite paremklõpsu üks kuubikud antud andmete sarja ja valida Omadused ... ning Series saki ilmuvasse dialoogi muutes Bar kas Silindri või Cone . Märkus: Gap laius väärtus võib kasutada ka "kahaneb" sümbolid skeem vähendada kattuvaid, seda suurem number, seda vähem kattuvad seal.

4. Aasta Arhitektuuridparagrahvi märgistada arhitektuur / s soovid kaardistada arhitektuuri tasandil omadusi, siis klõpsa Järgmine.

Märge

Valides arhitektuuri tasandil omadused on täiesti vabatahtlik samm ja tuleks kasutada ainult siis, kui soovite selgelt kaardistada arhitektuuri tasandil omadused ise.Arhitektuuri ei pea olema valitud nii, et juhul sisaldab osa või seoses omadused järgmises etapis.

5. Valige Komponendidja Sidemedmida soovite diagrammil alates standard element valiku aken , Siis klõpsa Järgmine.

6. Valige Omadusedsoovite diagrammi ja klõpsa Finiš.

Chart Options

o Kaasa Standard omadusedtahe näita päritud omadused alates Standards võimalik valida.

o Täitematerjalidetahe loota lahknevus seeriate väärtuste ja kaardistada neid tulemusi erinevalt individuaalsed väärtused ise.See valik on saadaval ainult siis, kui Series by Property võimalus valiti punktis 3 toodud.

Ots

Omadused olemas kaardistamisega sõltuvad elemendid valite.

Et säästa skeem

Märge

Äritegevus saab salvestada üksnes juhul, kui nad sisaldavad ainult komponendid ja ühendused, mis kõik peavad olema ühest arhitektuuri praeguses projektis.

1. Veenduge, et teil on uus või olemasolev skeem avatudja olete teinud vajalikud muudatused.

2. Diagrammi tööriistaribal klõpsata vasakpoolsem Salvesta Chartnuppu, et salvestada diagrammi ja formaati muutusi.

3. Aasta Joonis nimiVali ilmuvas dialoogis sisesta nimi diagrammi ja vajutage Okei.

Eksportida skeem

1. Veenduge, et teil on olemasolev skeemavatud.

2. Diagrammi tööriistariba kliki 2. vasakult Säästa Kuna BMPnuppu ja valisin asukoha diagrammi.

3. Vajuta Salvesta.

Vaata ka

Analüüsides oma arhitektuuri | Kasutaja reaktsiooniaeg skeem | Kasutaja võime ruumi skeem


Kasutaja võime ruumi skeem

Navigation: Analüüsides oma arhitektuuri> Custom kaardid>

Kasutaja võime ruumi skeem

Saada kommentaare selle teema.

Võime Space skeem võimaldab vaadata, kas teie arhitektuuri vastab nõutud süsteemi võime suhtes omadused käigus süsteemi nõuete analüüsi käigus.

Et vaadata võime ruumi skeem

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri, Ja et teil on hinnataSinu arhitektuuri.

2. Valima Sisesta| Chart| Custom Charts| Capability Space. (Selle Capability Space Chart Configdialoog, mis näitab.)

3. Aasta Arhitektuuridparagrahvi märgistada arhitektuuri soovite diagrammi, siis kliki Järgmine.

4. Aasta Omadusedala, märgistada arhitektuurne omadused soovid lisada nii teljed diagrammi.

5. Aasta Võimepiirkonnas, iga vara hulka alates eelmisest etapist, valida, kas minimaalne või maksimaalne võime piirid olemas ja väärtused need piirid. Vaikimisi väärtused on minimaalsed ja maksimaalsed väärtused hinnati arhitektuuri või eesmärgiks vara kui see on määratud.

Eksportida võime ruumi skeem

1. Veenduge, et teil on olemasolev võime ruumi skeemavatud.

2. Diagrammi tööriistaribal klõpsata vasakpoolsem Säästa Kuna BMPnuppu ja valisin asukoha diagrammi.

3. Vajuta Salvesta.

Vaata ka

Analüüsides oma arhitektuuri | Kasutaja reaktsiooniaeg skeem


Kasutaja reaktsiooniaeg skeem

Navigation: Analüüsides oma arhitektuuri> Custom kaardid>

Kasutaja reaktsiooniaeg skeem

Saada kommentaare selle teema.

Kosteaeg skeem võimaldab vaadata, kas teie ühendused töödeldakse vajalikul määra (st nende tähtaeg).

Et vaadata reaktsiooniaeg skeem

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri, Ja et teil on hinnataSinu arhitektuuri.

2. Valima Sisesta| Chart| Custom Charts| Reaktsiooniaeg. (Selle Response Time Chart Configdialoog, mis näitab.)

3. Alates ArhitektuuridRippmenüüst valige arhitektuuri soovite kaardistada.

4. Aasta Sidemedala, märgistada ühendused soovid lisada diagrammi.

5. Scale TypeValige alas LinearKui soovite vertikaalteljel (reaktsiooniaeg), et näidata kui sirgjoonelise - iga segment aega eraldatud võrdse osa telge. Valima Logarithmickui sa tahad seda kuvatakse logaritmiline progressiooni - iga segment telje moodustab üha enam aega kõrgemal telje minna. (Kiirus kasv määrab Alusvalid.)

Vastus ajagraafiku vertikaalteljel skaala

Eksportida reaktsiooniaeg skeem

1. Veenduge, et teil on olemasolev reaktsiooniaeg skeemavatud.

2. Diagrammi tööriistaribal klõpsata vasakpoolsem Säästa Kuna BMPnuppu ja valisin asukoha diagrammi.

3. Vajuta Salvesta.

Vaata ka

Analüüsides oma arhitektuuri | Kasutaja võime ruumi skeem


Kasutaja staar krunt oma arenenud arhitektuur

Navigation: Analüüsides oma arhitektuuri> Custom kaardid>

Kasutaja staar krunt oma arenenud arhitektuur

Saada kommentaare selle teema.

Kui arhitektuur on arenenud ja eesmärgid on määratletud, saab siis visualiseerida ja võrrelda algse arhitektuuri kasutades star krundid. See osa kirjeldab, kuidas luua ja töödelda staar plot.

Et vaadata star krunt oma arenenud arhitektuur

1. Veenduge, et teil on ABACUS fail avatud .

2. Veenduge, et teil on arenenudja seatud eesmärkeTeie arhitektuuri kirjeldatud all Areneb oma arhitektuuri

3. Valima Sisesta| Chart| Custom Chartstab | Star Krundi.

4. Vajuta Finišnuppu.

5. Star Krundikoos arenenud arhitektuur ja seada eesmärke kuvatakse. Märkus: telgede star krundi võib positsioneerida klõpsates ja lohistades telgede teise ala piires staar krundi kvaliteediga ruumi.

Märge

Ala vasakul pool star krundi näitab seadeid star krundi kuvatakse. See hõlmab arhitektuuri, mis on kujunenud (antud juhul "ABC Ltd As-is 2010") Samuti eesmärgid, mis on seatud, et arhitektuur. Sa tähele, et eesmärgid, mis on linnukese nende kõrval on esindatud teljed star plot (nt KPI- Kulud, KPI - kvaliteet ja KPI - Aeg). Võite untick nende eesmärkide igal ajahetkel neid eemaldada staar plot.

Punane ja roheline "dots", mis ilmuvad teie star krundi esindavad normaliseeritud väärtus, mille määrab kindlaks parim ja halvim väärtus (kogumi alusel Eesmärkide seadmine oma arenenud arhitektuur ) Valitud tipptasemel arhitektuuriga ja kõik arengud seda. Need väärtused on esindatud Kvaliteet Space.

Nagu eespool ülaloleval pildil on selgelt näha, et algse arhitektuuri (As-is 2010) On kehv CostKuigi esimest arenenud variant (To-be 2011 - strateegia) On liikunud jooksul kvaliteediga ruumi parandamiseks Cost, Kvaliteet ja aegeesmärgid. Alternatiivselt teise arenenud variant (To-be 2011 - strateegia B) kui see on ka paranenud Cost suurusjärku paranemist ei omast väiksem Strateegia A kuid nii Kvaliteet ja aeg eesmärke on paranenud rohkem kui strateegia A.Sel juhul arhitekt võib valima Strateegiaüle Strateegia Bnende soovitusja edasi areneda, et võimalus (To Be 2012 - strateegia).

6. Tühista Näita arenguidruut peita line (ed) areng (s) vahel originaal (nt As-is 2010) Ja arenenud (nt To-be 2011 - strateegiaA) arhitektuur (s).

7. Valige Näita pulgadruut kuvamiseks suhteline suurus iga kvaliteedinäitaja (eesmärgid, mis on kindlaks määratud iga telge) iga arhitektuuri.

8. Valige Näita Arhitektuur nimedKontrollige ruut, kui soovite nimed originaal ja arenenud arhitektuur (s) ilmuma star plot.

Vaata ka

Analüüsides oma arhitektuuri | Kasutaja reaktsiooniaeg skeem | Kasutaja punktdiagramm maatriks oma arenenud arhitektuur | Areneb oma arhitektuuri


Kasutaja hajuvusgraafik oma arenenud arhitektuur

Navigation: Analüüsides oma arhitektuuri> Custom kaardid>

Kasutaja hajuvusgraafik oma arenenud arhitektuur

Saada kommentaare selle teema.

Kui arhitektuur on arenenud ja eesmärgid on määratletud, saab siis visualiseerida ja võrrelda algse arhitektuuri abil hajuvusgraafik maatriksid. See osa kirjeldab, kuidas luua ja mõista omadused punktdiagramm maatriks.

Et vaadata punktdiagramm Matrix oma arenenud arhitektuur

1. Veenduge, et teil on ABACUS fail avatud .

2. Veenduge, et teil on arenenudja seatud eesmärkeTeie arhitektuuri kirjeldatud all Areneb oma arhitektuuri

3. Valima Sisesta| Chart| Custom Chartstab | ScatterPlot'ile Matrix.

4. Vajuta Finišnuppu.

5. Hajuvusdiagrammilekoos määratletud areng arhitektuur ja eesmärgid kuvatakse.

Märge

Ala vasakul servas hajuvusgraafik maatriks näitab seadete hajuvusgraafik maatriks kuvatakse. See hõlmab arhitektuuri, mis on kujunenud (antud juhul "ABC Ltd As-is 2010") Samuti eesmärgid, mis on seatud, et arhitektuur. Sa tähele, et eesmärgid, mis on linnukese nende kõrval on esindatud X ja Y telgedega hajuvusgraafik ainest (nt KPI- Kulud, KPI - kvaliteet ja KPI - Aeg). Võite untick nende eesmärkide igal ajahetkel neid eemaldada hajuvusgraafik maatriks.

Sinine punkte, mis ilmuvad teie krundile maatriksi esindavad normaliseeritud väärtus, mille määrab kindlaks parim ja halvim väärtus (kogumi alusel Eesmärkide seadmine oma arenenud arhitektuur ). Need väärtused on esindatud Kvaliteet Space.

Kaks määratletud eesmärke võrreldakse üksteise vastu punktdiagramm maatriks ja protsessi korratakse, kuni kõik eesmärgid on võrreldud (nt Esimene plot maatriksi siinsel pildil võrdleb KPI - Costeesmärgi poole KPI - kvaliteet eesmärk. Teine on Costvastu Aeg ja viimase Krunt on Kvaliteet vastu Aeg. Vastav eesmärk siltide näidatakse ülaosas paremal või iga rea ​​krundid.).

6. Valige Arhitektuuridnupp, kui soovite kuvada meetrika üksikute arhitektuuri.

7. Valige Arenguidnupp, kui soovite kuvada normaliseeritud muudatused esialgse arhitektuuri (nt As-is 2010), Et tekkiv arhitektuur (s) (nt To-be 2011 - strateegia ja To Be 2011 - strateegia B).

Vaata ka

Analüüsides oma arhitektuuri | Kasutaja reaktsiooniaeg skeem | Kasutaja staar krunt oma arenenud arhitektuur | Areneb oma arhitektuuri


Vaatad mulligraafiku

Navigation: Analüüsides oma arhitektuuri> Custom kaardid>

Vaatad mulligraafiku

Saada kommentaare selle teema.

Mull skeem võimaldab võrrelda kuni 5 mõõtmed (st X, Y, mull suurus / raadius, mull värvi ja mull äärisvärv) ühes vaates.

Et vaadata mulligraafiku

1. Veenduge, et teil on ABACUS fail avatud .

2. Valima Sisesta| Chart| Custom Chartstab | Mulligraafiku.

3. Aasta Arhitektuuridparagrahvi märgistada arhitektuur (kui üldse), mida soovite kaardistada, siis klõpsa Järgmine.

4. Valige Komponendidja Sidemedmida soovite diagrammil (kui üldse) alates standard element valiku aken , Siis klõpsa Järgmine.

5. Valige X-telgvara, siis klõpsa Järgmine.

Märge

Ainult Integer, Decimal, Date / Time, Loogiline ja loetelu omadused saab kasutada X-teljel. Lisaks Integer, Koma Date / Time omadused joonistatakse vasakule-paremale piki telge korrastatakse vastavalt vara väärtusest, aga Loogiline ja loetelu omadused on lihtsalt joonistatud vasakule-paremale täpselt, et (või vastupidises järjekorras, kui võimalus vastupidises järjekorras kontrollitakse) defineeritud vara sõltumata nende väärtused. Näiteks Madal | Medium | Kõrge või 1, 2, 4, 8, 16.

6. Valige Y-telgvara, siis klõpsa Järgmine.

Märge

Ainult Integer, Decimal, Date / Time, Loogiline ja loetelu omadused saab kasutada Y-teljel. Lisaks Integer, Koma Date / Time omadused joonistatakse alt-üles-top teljel korrastatakse vastavalt vara väärtusest, aga Loogiline ja loetelu omadused on lihtsalt joonistatakse alt-üles-top täpselt, et (või vastupidises järjekorras, kui võimalus vastupidises järjekorras kontrollitakse) defineeritud vara sõltumata nende väärtused. Näiteks Madal | Medium | Kõrge või 1, 2, 4, 8, 16.

7. Valige mull suurus / raadiusvara, siis klõpsa Järgmine.

Märge

Ainult Integer, Decimal, Loogiline ja loetelu omadused saab kasutada mulli suuruse / raadiusega. Lisaks Integer ja Decimal omadused põhjustada mull suurus / raadius korrastatakse vastavalt vara väärtusest, aga Loogiline ja loetelu omadused kaasa võrdne samm suureneb mulli suuruse / kodarluu täpses järjekorras (või vastupidises järjekorras, kui võimalus vastupidises järjekorras kontrollitakse) defineeritud vara sõltumata nende väärtused. Näiteks Madal | Medium | Kõrge või 1, 2, 4, 8, 16.

8. Valige kas Fikseeritud mull värvivõi siduda kinnisvara mulli värvi, Siis klõpsa Järgmine.

Märge

Ainult Integer, Decimal, Loogiline ja loetelu omadused saab kasutada mulli värvi. Lisaks Integer ja Decimal omadused põhjustada mull värvi kohta valitud vahemik korrastatakse vastavalt vara väärtusest, aga Loogiline ja loetelu omadused kaasa võrdne samm suureneb mulli värvi kohta valitud vahemik täpselt, et määratleda vara, sõltumata nende väärtused. Näiteks Madal | Medium | Kõrge või 1, 2, 4, 8, 16.

9. Valige kas no mull äärisvärvvõi siduda kinnisvara mulli äärisvärv, Siis klõpsa Finiš.

Märge

Ainult Integer, Decimal, Loogiline ja loetelu omadused saab kasutada mulli äärisvärv. Lisaks Integer ja Decimal omadused põhjustada mull äärisvärv jooksul valitud vahemik korrastatakse vastavalt vara väärtusest, aga Loogiline ja loetelu omadused kaasa võrdne samm suureneb mulli äärisvärv jooksul valitud vahemik täpselt, et määratleda vara eest, sõltumata nende väärtused. Näiteks Madal | Medium | Kõrge või 1, 2, 4, 8, 16.

Mulligraafiku

Et säästa mulligraafiku

Märge

Bubble graafikuid saab salvestada üksnes juhul, kui nad sisaldavad ainult komponendid ja ühendused, mis kõik peavad olema ühest arhitektuuri praeguses projektis.

1. Veenduge, et teil on uus või olemasolev mulligraafiku avatudja olete teinud vajalikud muudatused.

2. Diagrammi tööriistaribal klõpsata vasakpoolsem Salvesta Chartnuppu, et salvestada diagrammi ja formaati muutusi.

3. Aasta Joonis nimiVali ilmuvas dialoogis sisesta nimi mulligraafiku ja vajutage Okei.

Eksportida mulligraafiku

1. Veenduge, et teil on avage olemasolev mulligraafiku.

2. Diagrammi tööriistariba kliki 2. vasakult Säästa Kuna BMPnuppu ja valisin asukoha diagrammi.

3. Vajuta Salvesta.

Vaata ka

Analüüsides oma arhitektuuri


Arhitektuur Diff ja Sync

Navigation: Analüüsides oma arhitektuuri>

Arhitektuur Diff ja Sync

Saada kommentaare selle teema.

Kui teil on 2 või rohkem arhitektuur, kas arenguid või algtaseme arhitektuur, saate visuaalselt "diff" kaks arhitektuuri abil Kataloog või diagramm võrdlus või Arhitektuur Diff funktsioon. See on eriti kasulik avastamas / re-avastamas täpne muudatusi tehtud ühest arhitektuuri teise kui te areneb arhitektuuri ja arendada tegevuskavad ABACUS.

Kuni näita "diff" teise arhitektuuri kaudu skeem

1. Veenduge, et teil on ABACUS fail avatud .

2. Veenduge, et teil olema vähemalt 2 arhitektuuri projektis.

3. Avage diagramm, mida soovite võrrelda teise arhitektuuri.

4. Vajuta "Võrdle seda skeemi sisu teise arhitektuur" nuppu Diagramm tööriistariba.

5. Vali teine ​​arhitektuuri alates rippmenüüst võrrelda.

6. Võite filtreerida millised erinevused on näidanud, klõpsates "Erinevused" nuppu Diagramm tööriistariba ja valimata võimalusi, nt Muutunud / Lisatud / Unknown ja Määratlemata / Sync Soovitatavad/ Hoia Soovitatavad.

Märge

Komponendid ja ühendused skeem esile tõstetud punane, roheline või purpurne kus on erinevusi sisu, mis on nähtav praegune skeem ja sisu teistes arhitektuuri. Red kasutatakse millede puhul on soovitav sünkroniseerida erinevusi (vt allpool), Green kasutatakse juhul, kui see ei ole soovitatav sünkroonida erinevusi, mis on hoida neid (vt allpool) ja Purpurne kasutatakse juhul ABACUS ei saa anda soovitusi sünkroonimise kohta erinevused (vt allpool). Ainult nähtav sisu skeem on võrreldes nii et kui märke näitab hoidla vara väärtus ja see väärtus muutunud antud komponendi või ühendus kuvatakse nõrga punane, nõrga rohelinevõi nõrga lilla ja tähisega * kuvatakse ülaosas lahkus komponendid, aga kui mõned teised aluseks hoidla vara väärtuse muutus, mida ei ole näidatud annotatsioon siis ei viita antakse. Sisu, mis tekib praeguse skeemi, kuid ei sobi leitakse võrdluses arhitektuuri kuvatakse tugev punane, tugev rohelinevõi tugev lillaja "+" sümbol kuvatakse ülaosas vasakul komponendid. Matching tehakse komponent liik ja nimi, nii et kui liigi või nime osa või ühendus on muutunud teiste arhitektuuri ei sobi leitakse. Kuna puudub viis usaldusväärselt kindlaks määrata, kas täiendava sisu teistest arhitektuuri oleks näidatud aktiivse diagrammiga (nt täiendav liides 2 komponenti nagu on näidatud allolevas diagramm võrdlemisest arhitektuuri paremal), ei ole neid erinevusi näidatud diagrammide (need on näidatud kataloogide kohta allpool). Uusehitise üle iga muutunud kirje näitab erinevust tooltip. Uusehitise üle tähisega * ülemises vasakus diagramm esitab kokkuvõtte muutusi (või ei muudeta) vahel skeem sisu ja sisu teiste arhitektuuri.

Värv Legend

· Green näitab objekte, mis ei ole soovitatav sünkroonida erinevusi, mis on hoida neid.

· Red näitab objekte, mis on soovitatav sünkroonida erinevused.

· Purpurne näitab kirjed, kus ABACUS ei saa anda soovitusi sünkroonimise kohta erinevused.

Kuni sünkroonida ("sync") sisu ühest arhitektuuri teise kaudu skeem

1. Veenduge, et teil on ABACUS fail avatud .

2. Veenduge, et teil olema vähemalt 2 arhitektuuri projektis.

3. Avage diagramm, mida soovite võrrelda teise arhitektuur.

4. Vajuta "Võrdle seda kataloogi sisu teise arhitektuur" nuppu Diagramm tööriistariba.

5. Vali teine ​​arhitektuuri alates rippmenüüst võrrelda.

Märge

Vaata eespool, kuidas ABACUS näitab "diff" vahel 2 arhitektuuri kataloogi. Eelkõige kuidas Red kasutatakse siis, kui see onSoovitatav Sync erinevusi, Green kasutatakse siis, kui on eiSoovitatav sünkroonida erinevusi ja Purpurne kasutatakse juhul ABACUS ei saa anda soovitusi sünkroonimise kohta erinevused.

6. Paremklõpsake skeem element (või elementide abil Shift või diagramm lõuendile Sync Kõik) näitab "diff" ja valige Sync menüüst.

Märge

Iga sünkroniseerimine muudatused rakendada ainult arhitektuuri, et praegu keskendutakse Kataloog kuulub. Kohaldada muudatusi teiste arhitektuuri peate kasutama kataloogi teistes arhitektuuri. Lisaks kasutajaid on ainult võimalik taotleda sünkroniseerimine muudatusi, kui need on selleks luba .

Märge

Sõltuvalt sellest, kus sa paremklõps menüüst kuvatakse juhised selle kohta, mida täpselt saab olema sünkroniseeritud.Näiteks Paremklõpsu ühe osa joonisel ainult sünkroniseerida, et osa. Arvestades paremklõpsu skeem lõuend ja valides Sync Kõik sünkroniseerib kõik praegu näidanud erinevusi.

Kuni näita "diff" teise arhitektuuri kataloogi kaudu

1. Veenduge, et teil on ABACUS fail avatud .

2. Veenduge, et teil olema vähemalt 2 arhitektuuri projektis.

3. Avage andmebaas, mida soovite võrrelda teise arhitektuuri.

4. Vajuta "Võrdle seda kataloogi sisu teise arhitektuur" nuppu Kataloog tööriistariba.

5. Vali teine ​​arhitektuuri alates rippmenüüst võrrelda.

6. Võite filtreerida millised erinevused on näidanud, klõpsates "Erinevused" nuppu Diagramm tööriistariba ja Valiku tühistamine võimalusi, nt Muutunud / Lisatud / Unknown ja Määratlemata / Sync Soovitatavad/ Hoia Soovitatavad.

Märge

Rakke kataloogis on esile tõstetud punane, roheline või purpurne kus on erinevusi sisu aktiivse kataloogiga ja sobitamine sisu teistes arhitektuuri. Red kasutatakse millede puhul on soovitav sünkroniseerida erinevusi (vt allpool), Green kasutatakse juhul, kui see ei ole soovitatav sünkroonida erinevusi, mis on hoida neid (vt allpool) ja Purpurne kasutatakse juhul ABACUS ei saa anda soovitusi sünkroonimise kohta erinevused (vt allpool). Ainult nähtavaid ridu ja veerge kataloogis võrreldakse nii et kui on olemas erinevus järjest kaugemale praegu näidatakse ridade või väärtus veerus, mida ei ole näidatud on erinev, siis pole vahet, siis näidatakse. Kui väärtus indiviidi raku teistsugune sobiva raku võrdlus arhitektuuri raku piiri tõstetakse esile. Veerupäisel ja järjest valija ka varjutatud nõrga lillaja näidatakse koos tähisega *. Need "*" sümboleid võib klõpsata hüpata järgmisele erinevus veeru või rea võrra. Read, mis toimub aktiivse kataloogiga kuid ei sobi leitakse võrdluses arhitektuuri näidatakse koos "+" sümbol reas valija vasakul piiril kogu järjest tõuseb esile. Read, mis on toimunud võrreldes arhitektuuri versioon kataloogi (st sama filtrid jne), kuid ei sobi leitakse praeguse arhitektuuri näidatakse koos "-" sümboliga rea ​​valija vasakul piiril Kogu järjest tõstetakse esile ning kogu rida rakke sisu kuvatakse nõrga lillaja läbikriipsutused, nt 08:00-06:00. Matching tehakse komponent liik ja nimi, nii et kui liigi või nime osa või ühendus on muutunud teiste arhitektuuri ei sobi leitakse. Uusehitise üle iga muutunud kirje näitab erinevust tooltip. Uusehitise üle tähisega * ülemises vasakus diagramm esitab kokkuvõte muudatustest (või ei muudeta) vahel skeem sisu ja sisu teiste arhitektuuri.

Värv Legend

· Green näitab objekte, mis ei ole soovitatav sünkroonida erinevusi, mis on hoida neid.

· Red näitab objekte, mis on soovitatav sünkroonida erinevused.

· Purpurne näitab kirjed, kus ABACUS ei saa anda soovitusi sünkroonimise kohta erinevused.

Kuni sünkroonida ("sync") sisu ühest arhitektuuri teise kataloogi kaudu

1. Veenduge, et teil on ABACUS fail avatud .

2. Veenduge, et teil olema vähemalt 2 arhitektuuri projektis.

3. Avage andmebaas, mida soovite võrrelda teise arhitektuur.

4. Vajuta "Võrdle seda kataloogi sisu teise arhitektuur" nuppu Kataloog tööriistariba.

5. Vali teine ​​arhitektuuri alates rippmenüüst võrrelda.

Märge

Vaata eespool, kuidas ABACUS näitab "diff" vahel 2 arhitektuuri kataloogi. Eelkõige kuidas Red kasutatakse siis, kui see onSoovitatav Sync erinevusi, Green kasutatakse siis, kui on eiSoovitatav sünkroonida erinevusi ja Purpurne kasutatakse juhul ABACUS ei saa anda soovitusi sünkroonimise kohta erinevused.

6. Paremklõpsake raku, veeru või rea pealkiri (või mitu elementi kasutades Shift või Ctrl + A kõike) näitab "diff" ja valige Sync menüüst.

Märge

Iga sünkroniseerimine muudatused rakendada ainult arhitektuuri, et praegu keskendutakse Kataloog kuulub. Kohaldada muudatusi teiste arhitektuuri peate kasutama kataloogi teistes arhitektuuri. Lisaks kasutajaid on ainult võimalik taotleda sünkroniseerimine muudatusi, kui need on selleks luba .

Märge

Sõltuvalt sellest, kus sa paremklõpsu (st rakk, veeru või rea pealkiri) menüüvaliku kuvatakse juhised selle kohta, mida täpselt saab olema sünkroniseeritud.Näiteks Paremklõpsu ühe vara või kinnitatud osa raku kataloogis ainult sünkroniseerida, et vara või lisatud komponent. Arvestades paremklõpsu rea pealkiri (või rubriikide kasutades Shift) sünkroniseerib kogu rea (või ridade). Paremklõpsu veerupäisele sünkroniseerib kõik erinevused selles veerus.

Et vaadata 'Diff'2 kogu arhitektuur

1. Veenduge, et teil on ABACUS fail avatud .

2. Veenduge, et teil olema vähemalt 2 arhitektuuri projektis.

3. Valima Töövahendid| Arhitektuur Diff ....

4. Dialoogis ilmub valida esimene / From ja teine ​​/ To arhitektuuri võrrelda.

5. Vajuta Okeinuppu.

Arhitektuur Diff

Värv Legend

· Greennäitab, et sõlm lisati teine ​​/ arhitektuuri.

· Rednäitab, et sõlm jäeti teine ​​/ arhitektuuri.

· Bluenäitab, et sõlm on erinevad tunnused (nt omadused või standarditele) teise / arhitektuuri.

· Kollanenäitab, et sõlm on erinevusi oma lapsed teises / arhitektuur nii sõlme tuleks laiendada.

Märge

Võite paremklõps ja "Show in Explorer" kõik tipud vaata üksikasju ja rohkem teavet antakse erinevused Erinevused kokkuvõte paneel, kui sõlm on valitud.

Vaata ka

Analüüsides oma arhitektuuri | Kasutaja reaktsiooniaeg skeem | Kasutaja punktdiagramm maatriks oma arenenud arhitektuur | Areneb oma arhitektuuri


Simuleerimine oma arhitektuuri

Navigation: simuleerimine oma arhitektuuri>

Simuleerimine oma arhitektuuri

Saada kommentaare selle teema.

Kui oled asustatud ja analüüsida oma arhitektuuri, oled valmis kasutama arvelaud, kas teie arhitektuuri kohtub oma kvantitatiivse vajadustele. See nõuab simuleerimine. Et simuleerida oma arhitektuuri peate esmalt otsustada, millist teavet soovite leida. Seda tüüpi informatsiooni on sageli viidatud kui KPI või Key Performance Indicators. Näiteks, kas sa tahad analüüsivad, evolvability ja avatust, või sa tahad, et koguda meetrika nagu kogukuludega. Kogu see teave ei tehta mingil moel. Kui teil on selle andmed, mida saab analüüsida oma arhitektuuri erinevaid graafilisi formaate (või analüüsida uute väärtuste otse).

On kolm võimalust jäljendades oma arhitektuuri:

· Lihtne mõõdikud ;

· Pre-ehitatud simulaatorid ; või

· Scripting .

Lihtne Metrics

Iga osa oma arhitektuuri on omadused - millest paljud võivad olla kohandatud teie taotlusele Abacuse. Neid omadusi esindavad erinevaid omadusi komponente. Mõnel juhul lihtsalt koguda neid parameetreid (ehitada KPI) võib olla piisav, et öelda teile olulist informatsiooni oma arhitektuuri. Näiteks KLOCS või Tuhanded rida koodi, on laialt kasutatav meede keerukust. Muudel juhtudel, võite eksportida andmeid ja seda analüüsida, kasutades muud vahendit. Lisaks võid koguda omadused pärast täidab teist tüüpi simulatsioon.

Omadused saab koguda läbi protsessi agregatsiooni . Liitmine lisab alltoimikusse omadused kokku, mis kajastub vanem osa. Liitmine töötab ainult komponendid, mis sisaldavad alakomponentides.

Pre-ehitatud simulaatorid

On olemas viis valmismallide simulaatoreid, mida võib kasutada koos ABACUS. Need on:

· Performance;

· Modulaarsus;

· Kogukuludega (TCO);

· Avatus; ja

· Usaldusväärsus.

Märge

ABACUS automaatselt välja, millised on need simulaatorid tuleb uuesti läbida Red rõhutades kohta Simulatsioon tööriistariba .

Scripting

Scripting annab paindlikkuse simuleerida oma arhitektuuri custom viisil. Poolt kirjalikult skripte saate teha simulatsioone kaugemale praegusest hoonestatud võimsus ABACUS. Kogu ABACUS objekti mudel on saadaval skriptimismootori, nii et teil on piiratud ainult teie võime kirjutada skripte!

Visual Basic script on skriptimiskeel toetab ABACUS, sest see annab olulise programmeerimine funktsioonid mõistlikult lihtsa vormi.

Vaata ka

Eksport oma arhitektuuri | Täitematerjalide | Kirjutamine skripte


Kirjutamine skripte

Navigation: simuleerimine oma arhitektuuri>

Kirjutamine skripte

Saada kommentaare selle teema.

Script Editor on lihtne ja funktsionaalne kasuliku kirjutamiseks ja täidesaatva VB või C # script vastu Praegu avatud ABACUS faili(Raamatukogud ei toeta skriptimine). See on tavaline fail avada, sulgeda ja Save käsud, nii et saate salvestada ja laadida skripte kirjutada. Samuti on põhilised perspektiivis ja siluda rajatis. Skriptihalduris võimaldab hõlpsasti täita erinevaid skripte, mis olete kirjutanud pannes menüü-üksuse jaoks neid otse menüü Tööriistad.

Et pääseda Script Editor

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Valima Töövahendid | Script Editorja Script Editor aken. Siis kas;

3. Avab olemasoleva skripti kaudu Faili | Avatud skriptiredaktoris menüüd,

või

3. Ava Näide skripti kaudu Näide elemendi Script Editor menüüd,

või

3. Määra vaikimisi keel kas VB või C # kaudu Keel elemendi Script Editor menüüd,

või

3. Avatud skriptimine konkreetset abi kaudu Aitama elemendi Script Editor menüüd

Kui kirjutad skriptid, peate järgima kas VB või C # süntaksnagu iga seadistuse all Keel elemendi Script Editor menüüd.

MÄRGE:

· Et kasutada standard VB funktsioone nagu MsgBox ()Teile peab sisaldama Import Microsoft.VisualBasicavalduses alguses oma script. See ei ole vaja enne versiooni 3.0 Abacuse.

· See abi ei tohi sisaldada teavet selle kohta, kuidas kirjutada VB skripti ega sisalda VB viide. Julgelt kirjutada oma skripte oma lemmik IDE või toimetaja, seejärel kopeerige ja kleepige Script Editor.

Kui te esimest korda alustada Script Editor, Skriptiredaktori tühi. Võite kasutada skelett script läbi Näiteid menüüst. Esimene kord, kui hakkate oma Script Editor, tuleks lasta Mall skelett näha, et see toimib. Lisaks on kaks näiteks skripte, mis pääseb näidete menüü.

Kirjutada kasulik script peate viitama ABACUS ObjectModel. See on tehtud kättesaadavaks oma script sealhulgas Import ABACUS.ObjectModelavalduses eesotsas oma script. Täielik viide kogu ABACUS objekti mudeli on kaasas Script Editor. Võite leida, valides Aidake | Sisukordalates Script Editor aken.

Skriptiredaktoris sisaldab palju kasulikke funktsioone kirjalikult skripte, sealhulgas AutoComplete nagu näidatud allpool oleval pildil. Kuid veelgi rikkamaks kasutaja kogemus MS Visual Studio on võimalik integreerida ABACUS ja üksikasjalikud juhised on kättesaadavad siin .

Script Editor koos AutoComplete

Et kasutada skriptihalduris

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Valige Vahendid | Skriptihalduris.

3. Vajuta Lisamaikoon ja Avatudaken.

4. Sirvi ABACUS Script (.abacusscript, .vb Või .cs) Fail, mida soovite lisada Tools menüüst.

5. Vajuta Okeija viide script kuvatakse skriptihalduris aknas. Sisestage skripti nimi, nagu soovite seda kuvada menüü Tööriistad. Märkus: skriptihalduris akna suurust saab muuta, et näha kogu tee, kui vaja.

6. Korrake samme 3-5luua sidemeid rohkem ABACUS skripte.

7. Vajuta Lähedanesulgeda skriptihalduris ja pange tähele, et ABACUS script (s) nüüd ilmub menüü Tööriistad.

Et käivitada skripti

Mõlemal;

1. Open, kirjuta või kopeeri ja kleebi skripti, mida soovite käivitada, nii et see kuvatakse peaaknas ning Script Editor.

2. Klõpsake Jooksnuppu.

3. Kui teie skript on viga, viga Kirjeldus osa allosas Skriptiredaktori loetleb andmed, sealhulgas liini numbrid. MÄRGE: Iga inimene viga Viga Kirjeldus osa võib olla topeltklikkis teid vastava rida skripti.

- Või -

1. Valima Töövahendidja seejärel ABACUS Script nimi menüüst nagu loodud Skriptihalduris.

2. Kui teie script sisaldab vigu, Skriptiredaktori avatakse sisu script näidatud peaaknas (rõhutati line esimese viga) ja Error Kirjeldus osa allosas Skriptiredaktori loetleb andmed või viga (de) rida numbreid. MÄRGE: Iga inimene viga Viga Kirjeldus osa võib olla topeltklikkis teid vastava rida skripti.

Scripting koostamine vead

Koostamine vigu tekkida, kui süntaks skripti kood ei ole õige. Need vead ilmuvad allosas akna Error osa, kus on vea kirjeldus ja liini number. See on rea number, mis eristab kogumik vea käitustõrge (vt allpool), mis ei ole liini number. Koostamine vigu saab topelt klõpsatud hüpata ja esile konkreetseid line küsimus.

Scripting Runtime vead (NB)

Runtime vigu tekkida pärast skripti koodi on edukalt koostanud ilma vigu, kuid tekib viga käivitamisel (vt näiteid täpsema). Runtime vead on olulised, sest nad võivad põhjustada rikutud mudelid, kui loodud objektide ja objektidega teiste objektide mudel, ei ole ise mudeli osa (tavaliselt sellepärast käitustõrge on toimunud enne koodi, mis oleks neile mudeli kuskil hukati).

Kui teie skript loob objekte lisada mudeli, mida saab vältida korruptsiooni põhjustatud käitustõrge säästa oma script, sulgedes skriptid, ja täidab Undo muutused, mis olid loodud script (kui skripti täitmise ei lõpetanud tavaliselt ). Siiski on ka teisi viise, et vältida korruptsiooni esinev (vt allpool). Märge: Iga skriptid, et lihtsalt lugeda mudeli ja ei kirjuta seda, on ohutu ning ei tekita probleeme, sõltumata sellest, kas Runtime vigu tekkida nende täitmist.

Et vältida korruptsiooni, kui kirjalikult script kood, mis loob esemete ja lisades need objekti mudeli, see on soovitatav, et objektid on lisatud mudeli võimalikult kiiresti, kui neid osutatakse muid esemeid.

Näiteks kui loote uus ühendus ja 2 uued osad, siis lisades neid koos, see on parim, et luua esimene osa, lisage see mudel, siis teine ​​ja lisab ta, ja siis luua ühendus ja lisada, ja siis lõpuks luua manuseid. See tähendab, et kui oleks olemas olla käitustõrge mis katkestab skripti täitmise, kõik objektid, mis peavad olema objectmodel enne manus on loodud, on mudeli. Korruptsioon võib tekkida, kui näiteks ainult ühendus oli lisatud, siis manuseid tehtud, ja siis käitustõrge toimus enne skripti lõpuks lisada uusi komponente model.Corruption võib tekkida siis, kui objekt, millele viidatakse teise objekti objectmodel, ise mitte objectmodel.

Näide Runtime vead on järgmised:

· Objekti viide ole seatud astme objekti - see juhtub siis, kui objekt muutuja on null viide, ja meetod või vara objekti kasutatakse. Null viited saab kontrollida "Kui objectVariable midagi siis ..."

· Indeks oli väljaspool piire massiivi - see juhtub siis, kui massiiv on pöördunud koos indeks, mis on väljaspool piire - näiteks väiksem kui 0 või võrdne või suurem kui pikkus / Count massiivi. Array või kollektsiooni pikkus võib kontrollib LENGTH või .Count omadused võrra.

· Ei Luba Erand - Sa ei pea luba ... - see juhtub siis, kui sul ei ole luba teha antud muudatus

· Esmane Key Erand - Duplicate / Kadunud nimi / ID - see toimub juhul, kui muudatus on tehtud unikaalne omadus, mis on vastuolus teise objekti. Näiteks Arhitektuur peab olema unikaalne nimi, samuti Standards.

· Referential Integrity Erand - seadistamine viide valdkonnas objektile, mis ei kehti. Näiteks Lisades "midagi" või null, kui laps paljudele kogud objectmodel.

· Zero Length Erand - see võib juhtuda, kui sa püüad määrata objekti nimi tühja stringi. Enamik objekte nõuavad nende nimed olema vähemalt 1 iseloomuga.

Import avaldused

Pange tähele, et alguses skelett skriptid on avaldused, nagu Import ABACUS.ObjectModel. Need avaldused ei sisalda DLL, mis ei ole juba viidatud skripti - nende eesmärk on pakkuda "otsetee", millel täpsustada kogu nimi klass.

Näiteks kuulutada tüüpi muutuja CComponent (esindab osa ABACUS), mille Import ABACUS.ObjectModelavalduses poole peal kirjas, oleks vaid seda nõuavad tuleb deklareerida päevasõidutulede comp kui CComponent, Sest koostaja teab, et vaatan ABACUS.ObjectModel nimeruumi jaoks CComponent klassi. Ilma impordi avaldus see tuleks deklareerida päevasõidutulede comp kui ABACUS.ObjectModel.CComponent. Koost (nt mscorlib.dll või System.Windows.Forms.dll) võib olla rohkem kui üks nimeruumi - import avaldus on nende nimeruumid, mitte sõlmed ise. ABACUS.ObjectModel.dll kokkupanek on ainult ühe ABACUS.ObjectModel nimeruumi kättesaadavad Scripting.

Automaatselt viidatud komplektid

Järgmised DLL on viidatud automaatselt Scripting:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (kaudselt osutatakse koostaja)

· ABACUS.ObjectModel.dll

Et täiendavaid viiteid kas teised NET sõlmed, või oma sõlmed, lugege järgmist jaotist #ImportDLL avalduse.

#ImportDLL Statement

Alates ABACUS 3.1, saate viidata veel sõlmed, mida võib nõuda jaoks skripte kasutada #ImportDLL avalduse. Näiteks kui sa tahad pääseda kohandatud DLL sinu ja kasutada funktsionaalsust seda, siis oleks asetage see ABACUS kataloog ja sisaldavad märkust nagu esimene rida (id) oma script. Kui see on .NET dll, siis tavaliselt sa ei pea sisestama kogu tee, vaid DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL system.Xml.dll

Mõned muid asju tähele:

1. Kuna DLL tuleb leida kompileerimise ja runtime piirab see custom (mitte NET) DLL panemist ABACUS programmi kausta ainult.

2. #ImportDLL avaldused peavad olema esimene rida (s) scripti - kui teil on 5 avaldusi, siis peaksid nad olema esimese 5 rida skripti

3. #ImportDLL avalduses paigutada kõikjale, kuid esimesed read skript (nt juhul, kui see pandi pärast Kommentaari või import avaldust) ei tööta õigesti ja / või võib põhjustada mitteseotud tõlkija vead.

#ImportDLL Office Assemblies

Kui teil on Microsoft Office installitud, ja oma script nõuab Office Interop sõlmed, siis on võimalik neile viitavad lihtsalt abil #ImportDLL koost nimi (mis on loetletud allpool, näiteks #ImportDLL Excel). Seda meetodit kasutades on see eelis, et absoluutne dll tee ei ole kasutatav, nii et script on rohkem kaasaskantavaid (peaks töötama nii Office 2003 ja 2007. ilma redigeerimise script).

Kui kasutate seda funktsiooni, üldasjade (Global Assembly Cache) on otsinud interop montaaž ja skript koostab koos teele, et seadeldis on leitud. Kui see ei ole leitud, skriptid kontrollib ABACUS programmi kataloogis (mis sisaldab Excel ja Visio interops ainult). Kui taotluse interop ei leitud selleks ajaks, hoiatus kuvatakse.

Interops tavaliselt ei paigaldatud üldasjade kui olete installinud Microsoft Office enne paigaldamist .NET Framework (mis on osa kogu ABACUS paigaldamine). Võite installida neid teostades Change variant Microsoft Office'i Add / Remove Programs ja valida NET programmeeritavad võimalused. Täpsema info saamiseks vaata artikkel MSDN.

Kokkupanemine, mille kiirklahvi toetab, on järgmised:

· Juurdepääs

· Access.Dao

· Excel

· Graafik

· MSProject

· Väljavaade

· OutlookViewCtl

· Owc11

· PowerPoint

· Kirjastaja

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Sõna

It ei ole päris selge, kas kõik eespool sõlmed on kasulik, toad havebeen sisaldub see funktsioon regardeless nagu mõned kasutajad veebruar on vaja isegi varjata sõlmed.

Vaata ka

Simuleerimine oma arhitektuuri

© 2001-2015 Avolution Pty Ltd Kõik õigused kaitstud.


Makrodega

Navigation: simuleerimine oma arhitektuuri>

Makrodega

Saada kommentaare selle teema.

Kui telefonil ülesandeid korduvalt ABACUS, saate automatiseerida ülesanne kasutades makro. Seetõttu otsustab ABACUS makro on salvestatud operatsioonide jada, mida saab taasesitada igal ajal.

Salvestamine Macro

1. Valige Vahendid | Record Macrovõi teise võimalusena vajutage Alt + F10.

2. Alusta operatsioone, mida soovite salvestada.

Hoiatus

Sel ajal on mõned tuntud küsimusi makro salvestamise. Palun võta neid arvesse, kui salvestate oma makrosid:

· Praegu makrosid lihtsalt salvestada Microsoft Windows klahvivajutusi, hiire liikumise ja hiireklõpsuga. Kuid piirangute tõttu koos makro salvestaja ise, on mõned klahvivajutused, mis ei ole alati registreerida. Nende hulka kuuluvad:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] kuni [F12]

· Seetõttu on soovitatav, et te veenduge, et kiirklahvi salvestatakse makro salvestaja enne salvestamist suur sündmuste jada, mis võib sõltuda et kiirklahvi töö.

· Praegu piirangute tõttu koos makro salvestaja, kontekstimenüüsid ei käidelda korralikult ABACUS kui nad avasid hagi salvestatud makro salvestaja. Kui kontekstimenüü avamiseks peate täitma ühe loetletud ülesannete kontekstimenüüst kontekstimenüü abil, vastasel kontekstimenüüst jääda avatuks taasesituse ajal, mis võib tekitada soovimatuid toiminguid või tegevusi, mis võib põhjustada vigu ABACUS.

· Pange tähele, et tavaline meetodeid sulgemise kontekstimenüü (nt vajutades [Esc] klaviatuuril, või Vasakklõps kusagil mujal ekraanil) ei pruugi tegelikult sulgeda kontekstimenüü taasesituse ajal makro.

Ots

Dialoogides, selle asemel et kasutada hiireklõpsuga, on soovitatav kasutada TAB klahvi, et liikuda saadaval kontrolli ja nooleklahve, et valida rippmenüüst teemad või raadionupp võimalusi ja tühiku valida / de-valige kontrolli kastid.

Salvestamise lõpetamiseks Macro

1. Press Alt + F9või alternatiivselt valige Tools | Peatus Macro.

2. Save Macro dialoog avage kaust ja valige ABACUS makro (.abacusmac faili) faili nimi ja klõpsake nuppu Salvesta.

Märge

Kasutades Töövahendid| Peatus Macrosisaldab see operatsioon salvestatud makro. Seetõttu on soovitatav, et kasutajatel saada valda kasutamise Alt + Function võti võimalusi töötamiseks makrosid, et mitte lisada soovimatu makro tegevust makrosid ise.

Ots

Kuna makrosid ei ole praegu muudetavaid on soovitatav salvestada pikki ülesandeid paljudes eraldi makrosid kasutades Alt + F10 / Alt + F9 "paari".

Taasesitamiseks salvestatud Macro

1. Valige Vahendid | Playback Macrovõi teise võimalusena vajutage Alt + F8.

2. Ava Macro dialoog avage kaust ja valige ABACUS makro (.abacusmac faili) faili nimi ja klõpsake Open.

Hoiatus

Avamisel ABACUS makro, kui te topeltklõps makro faili Sirvi dialoogi avada, makro salvestaja võib hoida hiire vasaku nupu vasakusse klõpsanud riigi kuni registreerida vasak-kliki alistab see riik.

Märge

Taasesituse kiirus makro saab seada sakk alla Töövahendid| Valikudkas Normal (default), kiire või aeglane. Nii kiire kui aeglase taasesituse kiirust ei soovitata, sest nad on kordus salvestatud makrosid umbes 100 korda ja 1 / 100th reaalajas võrra. Taasesituse ikkagi kordus makro umbes 30% kiiremini kui salvestatud kiirus seega on soovitatav salvestamise ajal pausi lühikest aega pärast mis tahes pikk töötlemise ülesandeid on tagada, et esituse järgmine toiming ei käivitata enne töötlemise ülesanne on lõpetatud.

Peatus mängib salvestatud Macro

1. Press Alt + F9.


Simuleerimine Performance

Navigation: simuleerimine oma arhitektuuri> Simulaatorid>

Simuleerimine Performance

Saada kommentaare selle teema.

Taust

Arhitektuuri hindaja täitmiseks on eraldiseisev sündmus simulaator, mis töötab simuleerides voolu lugemiseks (või märgid) kogu arhitektuuri. Teooria see on saadud uurimust, mille Tehnikaülikool, Sydney ja põhineb Kihiline Järjekorras Network mudelid(LQNM) Timed ja värvilised Petri-Nets(TCPN) ja Aktiivsus Cycle skeemid(ACD).

Kui ABACUS tulemuslikkuse simulatsioon, töötlemise kohta üks komponent on põhjustanud peamiselt edastatav ta teise osa. Põhimõtted taga seda tehnikat saab aru neljast osast:

1. sõnum-kesksemaksside modelleeritakse ABACUS kasutades loogiline(või kaudse) ühendused. Loogilisi seoseid määratleda käitumine (sagedus ja andmed) edastatavad komponentide vahel. Hea näide loogilisi seoseid oleks järjekord liigub kahe (2) äriprotsesse või loogiline liidesed kahe (2) rakendusi.

2. Loogiline lugemiseks transporditakse sihtkohta kaudu hierarhia(näiteks ressursside swimlanes) või otseneühendusi (näiteks füüsilise juhtmed). Selleks võivad nad suunata üles, üle ja tagasi hierarhias allapoole (mitmetasandilist lähenemisviisi) järgida ei tee.

3. Vastavuse täpsust mudeli saab reguleerida, et see sobiks. Näiteks protsessi võib jagada sätestatakse niivõrd selline, et iga elementaarne protsessi ja funktsiooni on eraldi töötlemiseks jalajälge. Teise võimalusena võib see olla piisav, et on ainult üks raha kogu protsessi, peegeldades keskminetöötlemise vastuseks sõnumi.

4. Tegelik töötleminetoimub ainult komponendid, mis on (või on) protsessor. Protsessor on üldine asi, ja võib olla CPU, inimene, organisatsioonilise üksuse või midagi muud, mis on võimeline teostama tööd. Näiteks äriprotsesside ei tee mingit tegelikku töötlemine; see on tehtud esimene "volitatud töötleja" see paikneb kas selle vanema hierarhia (kui swimlane märke kasutatakse) või selle töötlemise võrgu (kui jagatud töötlemise märke kasutatakse).

Hindamine toimub simuleerides (täpsustada) liiklus süsteemi, nii et iga ühendus on simuleeritud vähemalt üks kord. Saabumise ajad sõnumeid on juhuslikult genereeritud seoses nende kindlaksmääratud sagedusega. Mudeli simuleerib ressurss töötlemise ja vaidlusküsimusi ja järjekordi sõnumeid, kogudes statistika mööda teed erinevate atribuudid.

Key Performance sisendtegurite

1. Frequency- Sagedus, mille juures seoses tekib.

2. Töötlemine- Kogus tegemise aeg lõpetada ühe protsessi. See võib olla tundi, minutit, päeva, operatsioonid jms

3. Speed- Kiirus protsessori ressurss. See tähendab, et kui palju tsükleid / juhised / tegevused on võimalik teha ühe ajaühiku. On oluline, et see oleks kooskõlas ühikud töötlemiseks.

4. Töötlejad- Arv protsessor ressursse. Töötlejad võivad olla inimesed, protsessori, välised organisatsioonid jms

Key Performance väljundtegurite

1. Läbilaskvus- Sõnumite arvu ajaühikus läbi ühendus. See tegelik väärtus võib võrreldes eeldatava / teoreetilised väärtused (st Frequency) tuletada küllastumine süsteemi.

2. Sõnum Rate- Sõnumite arvu ajaühikus läbi osa. See on summa kõikide komponentide sissetulevad ja väljaminevad kirjad.

3. Vastus- Minimaalne / keskmine / max latency selle ühendus. See on summa kõikide vaadeldud latentsused ühendus allikas valamu ja mis tahes järjekordi ja töötlemine (ja latentsus tagasi allikas kui kahesuunaline).

4. Utiliseerimine- Ärakasutamisest osa. Sellest saab 0%, kui osa ei ole seadme / töötleja (st see ei ole protsessorid ja Speed ​​omadused on määratletud ülalpool).

Kuigi eraldiseisev sündmus simulatsiooni teostatakse arvutada erinevate atribuudid, nagu eespool kirjeldatud, järgmise valemi võib kasutada ligikaudseks tulemuste kinnitamisest (kus süsteem ei ole veel täiel):

Kasutamine: = Sum of Frequency kõik sissetulevad ühendused * töötlemine / (Speed ​​* protsessorid)

Üldine kontseptsioon on ehk kõige paremini näitab arvestades järgmist skeemi, mis näitab kahe erineva jõudlusega meta-mudelid. Vasakpoolne stiil on klassikaline "swimlane" märkuse töötlemise ülesandeid põhineb hierarhiliselt oma protsessori ressursse. Parempoolne stiil on hajutatud märke töötlemise ülesandeid kaudu ühendatud protsesside seost nende protsessori ressurss. See viimane märkus võimaldab mitu protsessorit ressursid antud töötlemise ülesanne, erinevalt piiratud swimlane märke.

Märge

Näidatakse iga meta-mudel on sisend omadused (punane) ja atribuudid (sinine):

Performance meta-mudelid: Swimlane versus Distributed märke

Running Performance simulaator

Et simuleerida oma arhitektuuri poolest tulemuslikkuse

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Valima Analüüs| Performancevõi klõpsake tööriistaribal nuppu.

3. Valige Arhitektuursoovite hinnata alates rippmenüüst.

Märge

Vaikimisi ABACUS valib automaatselt esimene arhitektuuri, mille re-simulatsioon tõttu on vajalik nende all oleva vara või struktuurimuutusi.See esiletõstmine on näidatud Red kohta Simulatsioon tööriistariba .

4. Valige Komponendidja Sidemedsoovite, et hinnata, alates standard element valiku aken .

5. Seadke Filmi pikkus Scale Factorliugur.

Märge

Kõrgemad väärtused toovad rohkem statistiliselt ühtseid tulemusi, kuid võtab kauem aega, et arvutada.

Täiendav CheckboxEuroopa standard element valiku aken

· Save Muundatud Mudeltahe salvestada koopia RBD ümber versiooni projekti samasse kausta praeguse projekti ja lisab "_transformed" projekti nimi.See muutnud projekti saab diagnoosida üksikasjalikult usaldusväärsust simulatsiooni võetud ABACUS.

Muud võimalused on standard element valiku aken

· Filmi pikkus Scale Factor kontrollib ajahetkele ja täpsuse suuremal väärtused saakserohkem statistiliselt ühtseid tulemusi, kuid võtmine kauem aega jooks.

Märge

Kui ABACUS arvutab simulatsiooni ajal määrab aeglaseim kaudne seos sagedusega, mis valiti simuleeritakse ja siis "soojenduseks" Perioodi (st 1 üle sagedust) antud kontekstis (algatamisel perioodiline teade generaatorid kõik ühendused juhuslikult sel soojenduseks ajal, andes neile kõigile võimaluse algatada) ning seejärel simuleerida Run Time Scale Factor korda periood, et ühendus. Või (1 / Frequency) soojenemisaeg + (1 / sagedus) * Run Time Scale Factor ajahetkele. See on veenduda, et kõik ühendused on algatatud enne statistikat koguda ja siis kõige aeglasem ühendus on ikka simuleeritud vähemalt üks kord simulatsioon. Näiteks Kui aeglaseim kaudne seos on sagedus 0,033 aeg-ühikut (või ca kord kuus, kui aeg-ühikud on päeva), siis soojenduseks aega on 30,3 aeg-üksused ja simulatsiooni aeg on 30,3 aeg-üksused korda Run aeg Scale Factor.

6. Vajuta Finišja saad Hoiatusdialoogi.

7. Soovi uurida hoiatusi klikates Detailid >>.

8. Vajuta Jätkama.

Märge

Sel hetkel, ABACUS on diskreetse-event simulatsiooni arhitektuuri ja mõne aja pärast (koos edenemisribad tagasisidet) arvutus täielik ilmub dialoog.

9. Vajuta Okeitunnustada simulatsioon.

Ots

Koolituste ja täiendavat abi Performance Simulatsioon palun vaadake Avolution ühenduse .

Component omadused

Järgnev tabel loetleb omadusi tulemuslikkuse hindamiseks vajalikud. Omadused otsitakse esimene komponentide eksemplare, siis Component Standardid ja kui ei leita, siis vaikimisi kasutatakse.Need omadused on näidatud Properties aken vara sisendi real valija ikoon ( [image] ) Koos tooltip "Performance sisend". Muutus kõik need "input" omadused ja erinevad struktuurimuutused hoidla toob kaasa Performance simulaator nõudes uuesti simulatsiooni märgitud Red kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Vaikimisi väärtus | Ühik | Data Type | Nõutav | Kirjeldamine
Käitumine | b_pack | 0,0 |  | Decimal | False | Fikseeritud teeninduse aeg pakkida sekundit. See majutusasutus on tüüpiliselt märgitud kui standard tüübi ja siis kasutatakse mitut komponentide eksemplare. Näiteks CORBA on b_pack = 0,23 ms.
Käitumine | m_pack | 0,0 |  | Decimal | False | Muutuva teeninduse aeg pakkida sekundit / bait. See majutusasutus on tüüpiliselt märgitud kui standard tüübi ja siis kasutatakse mitut komponentide eksemplare.
Käitumine | b_unpack | 0,0 |  | Decimal | False | Fikseeritud teeninduse aeg lahti sekundiga. See majutusasutus on tüüpiliseltmärgitud kui standard tüübi ja siis kasutatakse mitut komponentide eksemplare.
Käitumine | m_unpack | 0,0 |  | Decimal | False | Muutuva teeninduse aeg lahti sekunditega / bait. See majutusasutus on tüüpiliseltmärgitud kui standard tüübi ja siis kasutatakse mitut komponentide eksemplare.
Käitumine | Töötlemine | 0,0 |  | Decimal | Tõsi | Summa tegemise aeg lõpetada ühe protsessi. See võib olla tundi, minutit, päeva, operatsioonid jms
Käitumine | Töötlejad | 1 |  | Täisarv | Tõsi | Arv Protsessor ressursse. Töötlejad võivad olla inimesed, protsessori, välised organisatsioonid jms
Käitumine | Speed | 100 |  | Täisarv | Tõsi | Kiirus protsessori ressurss. See tähendab, et kui palju tsükleid / juhised / tegevused on võimalik teha ühe ajaühiku. On oluline, et see oleks kooskõlas ühikud töötlemiseks.
Käitumine | k_bkgd | 0,0 |  | Decimal | False | Taust töötlemise osale. Seda kasutatakse, et reguleerida tulemusi suvalise fikseeritud nihke%. See saab ilmselt ignoreerida.

Järgnevas tabelis on toodud komponendi omadused toodangut tulemuslikkuse hindaja. Komplekt nende komponentide omadused on loodud iga osa iga tulemuslikkuse perspektiivis.Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Performance Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja Performance simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Käitumine | Sõnum Rate |  | Decimal | False | Sõnumite arvu ajaühikus läbi komponent. See on summa kõikide komponentide sissetulevad ja väljaminevad kirjad.
Käitumine | Bandwidth |  | Decimal | False | Üldiselt ribalaius läbi komponent. Summa tingitud nii sissetulevate ja väljaminevate sõnumite.
Käitumine | Utiliseerimine | % | Decimal | False | Kasutamise komponent. See on 0%, kui osa ei ole seade / töötleja (st see ei ole protsessorid ja Speed ​​omadused määratletud eespool)

Connection Properties

Järgnev tabel loetleb omadusi tulemuslikkuse hindamiseks vajalikud. Omadused otsitakse esimene Connection juhtumeid, siis ühendus Standardid ja kui ei leita, siis vaikimisi kasutatakse.Need omadused on näidatud Properties aken vara sisendi real valija ikoon ( [image] ) Koos tooltip "Performance sisend" või "Cost / Performance sisend". Muutus kõik need "input" omadused ja erinevad struktuurimuutused hoidla toob kaasa Performance simulaator ja / või Kulude simulaator nõuab uuesti simulatsiooni märgitud Red kohta Simulatsioon tööriistariba .

Tüüp

Nimi

Vaikimisi väärtus

Ühik

Data Type

Nõutav

Kirjeldamine

Käitumine

Lahke

kahesuunaline

[kahesuunaline | ühesuunaline]

Otsing / Nimekiri

Tõsi

Kas ühendus on kahesuunaline (kahesuunaline) või ühesuunalise (ühesuunaline).

Lubatud väärtused selle kinnisvara on "kahesuunaline" või "ühesuunaline".

Kahesuunaline tähendab sünkroonne taotluse / vastuse lugemiseks samas ühesuunaline vahendeid ühe asünkroonne "sündmus".

Käitumine

Abstraction

kaudne

[kaudse | otsene]

Otsing / Nimekiri

Tõsi

Kas ühendus on füüsiline või loogiline. Otsene ühendused füüsilised "torud" kahe komponente, mis loogilisi seoseid voolata.

Lubatud väärtused selle kinnisvara on "otsene" või "kaudne".

Kui väärtus on "otsene" siis ühendus ei vaja muud omadused (välja arvatud omadused Kind ja abstraktsioon).

Andmed

L_app1

0

Täisarv

False

Päring / sündmuse suurus baitides.

Iga ühendus on tavaliselt kindlat väärtust. CORBA, sündmused on tegelikult kahesuunaline ja alati on 12 baiti tunnistama (L_app2). Kui see on tõsi ühesuunaline ühendust, siis jätke vara L_app2.

Andmed

L_app2

0

Täisarv

False

Response / tunnistama suurus baitides.

Iga ühendus on tavaliselt kindlat väärtust. Ühesuunaline ühendus ei pea L_app2.

Käitumine

Frequency

1

Decimal

Tõsi

Sagedus, mille juures ühendus toimub.

Iga ühendus on tavaliselt kindlat väärtust. Kui vara sagedus jääb välja, siis vaikimisi kasutatakse.

Käitumine

Suhe

protsessid

[protsesse | toetab]

Otsing / Nimekiri

False

Ühendused, mis on "protsessid" vara näitavad, et komponendi alguses ühendus saab ümber töödelda ajal komponendi lõpus ühendus. In tagajärjeks "allikas" osa liigutatakse saada laps "valamu" komponent (lisatud ühendused ka "lohistada" Selle sammuga).

Kui "protsessid" vara on olemas, siis kõik teised ühenduse omadusi ei arvestata, välja arvatud vabatahtlik "%" vara allpool kirjeldatud.

Käitumine

%

100,0

Decimal

False

Ühendused, mis on "protsessid" vara (ülalkirjeldatud) võib valikuliselt olla "%" vara näitamiseks osakaal töötlemisega, mida omistatakse sihtkohale komponenti. Sel viisil ühe allikseadmel saab töödelda mitme sihtkoha komponente erinevates% 's. Olema% väärtustest ei ole vaja lisada kuni 100% ja seda kasutatakse vaid skaala "töötlemine" vara (vt eespool) for allikseadmel sest see on transformeeritud saada laps sihtkoha komponenti.

Järgnev tabel loetleb omadusi loodud tulemuslikkuse hindaja. Komplekt need seotud omadused on loodud iga ühenduse iga tulemuslikkuse perspektiivis.Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Performance Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja Performance simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Käitumine | Bandwidth |  | Decimal | False | Üldise ribalaius ühendamiseks. See on vaid arvutatakse kaudse ühendused ja on sisuliselt (L_app1 + L_app2) * jõudlus.
Käitumine | Bandwidth 1/2 |  | Decimal | False | Ribalaius konkreetselt väljuvate (1) ja sissetulevate (2) sõnumite seosest. See on vaid arvutatakse kaudse ühendused ja on sisuliselt L_app1 * Tootlikkus ja L_app2 * jõudlus.
Käitumine | Läbilaskvus |  | Decimal | False | Sõnumite arvu ajaühikus läbi ühenduse. See tegelik väärtus võib võrreldes eeldatava / teoreetilised väärtused (st Frequency) tuletada küllastumine süsteemi.
Käitumine | Valminud | % | Decimal | False | Protsent sõnumeid edukalt töötlemise ühendamiseks. See on vaid arvutatakse kaudse ühendused ja tootlikkusega / sagedus. Vahel Lõpetatud väärtus ületab 100%, sest juhuslikkust sõnum põlvkonna tulemused veidi suurem sõnum põlvkonna sagedusega kui määratud.
Käitumine | Vastus (Min / Ave / Max) |  | Decimal | False | Minimaalne / keskmine / max latency. See on vaid arvutatakse kaudse ühendused ja on täheldatud peiteaeg ühendus allikas vajuma ja kõik järjekordi ja töötlemine (ja latentsus tagasi allikas kui kahesuunaline).

Arhitektuur omadused

Järgnev tabel loetleb kogu süsteemi arhitektuurne omadused loodud tulemuslikkuse hindaja. Ühtsed omadused arhitektuur on "koondatud" iga tulemuslikkuse perspektiivis.Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Performance Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja Performance simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Käitumine | Sõnum Rate |  | Decimal | False | Sõnumite arvu ajaühikus läbi komponentide arhitektuuri. See on summa kõikide komponentide sissetulevad ja väljaminevad kirjad.
Käitumine | Läbilaskvus |  | Decimal | False | Sõnumite arvu ajaühikus läbi ühendused arhitektuuri. See on summa kõikide kaudse ühendused 'throughputs ja see tegelik väärtus võib võrreldes eeldatava / teoreetilised väärtused (st Frequency) tuletada küllastumine süsteemi.
Käitumine | Bandwidth |  | Decimal | False | Üldine ribalaiust. Summa arhitektuuri ühendus andmemahud.
Käitumine | Utiliseerimine | % | Decimal | False | Kasutamise kõiki komponente. Võib olla suurem kui 100%, sest see on lihtsalt summa, arhitektuur koosseisu kasutuskordadel.
Käitumine | Vastus (Min / Ave / Max) |  | Decimal | False | Minimaalne / keskmine / max latency. Summa kõigi vaadeldud latentsused arhitektuuri seotusest allikast vajuma (ja tagasi allikas kui kahesuunaline).


Simuleerimine Modulaarsus

Navigation: simuleerimine oma arhitektuuri> Simulaatorid>

Simuleerimine Modulaarsus

Saada kommentaare selle teema.

Moodulpõhimõtet simulaator arvutab arvu sissetulevad ja väljaminevad ühendused iga komponent.

Et simuleerida oma arhitektuuri poolest moodulitest

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Valima Analüüs| Modulaarsus.

3. Vali Arhitektuur (s)soovite kaasata hindamisse.

Märge

Vaikimisi ABACUS valib automaatselt arhitektuur (s), mille re-simulatsioon on vajalik, kuna puuduvad tegelikud struktuurimuutusi.See esiletõstmine on näidatud Red kohta Simulatsioon tööriistariba .

4. Vajuta Järgmine.

5. Vali Connection tüübid (s)soovite kaasata hindamisse.

6. Vajuta Järgmine.

7. Soovi kohandada omaduste nimed arvutamise tulemusi.

8. Vajuta Finiš.

Märge

Sel hetkel, ABACUS täidab struktuurseid hindamine arhitektuur (s) ja mõne aja pärast (koos edenemisribad tagasisidet) arvutus täielik ilmub dialoog.

9. Vajuta Okeitunnustada hindamist.

Ots

Koolituste ja täiendavat abi Modulaarsus Hindamine palun vaadake Avolution ühenduse .

Component omadused

Järgnevas tabelis on toodud komponendi omadused, mis on väljund poolt moodulitest hindaja.Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Modulaarsus Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud, kuna alusvara struktuurimuutuse hoidlasse ja Modulaarsus simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Data Type | Nõutav | Kirjeldamine
Modulaarsus | Liitmikud-fänn (kohaliku) | Täisarv | False | Arv ühendusi, et fänn sellesse komponent.
Modulaarsus | Liitmikud-fan out (kohaliku) | Täisarv | False | Arv ühendusi, et fänn sellest osa.
Modulaarsus | Liitmikud-fänn | Täisarv | False | Arv ühendusi, et fänn sellesse komponenti, sealhulgas ühendused, mis fänn osadeks komponendid.
Modulaarsus | Liitmikud-fan out | Täisarv | False | Arv ühendusi, et ventilaatori välja selle osa, sealhulgas ühendused, mis fänn osadeks komponendid.


Simuleerimine kogukuludega (TCO)

Navigation: simuleerimine oma arhitektuuri> Simulaatorid>

Simuleerimine kogukuludega (TCO)

Saada kommentaare selle teema.

Taust

Kogukuludega (TCO) on rahaline hinnang, mille eesmärk on mõõta kogu tekkinud olelusringi kulude (st omandamise lõpetamise / kõrvaldamine) seotud kuuluv vara. TCO mitte ainult peegeldab ostu-, see hõlmab ka kõiki teisi aspekte nende edasise kasutamise ja hooldamise vara.

TCO kasutatakse, et määrata pingutust ja eelarve kulusid vaja kulutada süsteemi. Lihtne viis modelleerimine ABACUS eest TCO on murda IT süsteemi alla komponentideks. Seejärel saame teada, kui palju keskmiselt maksab joosta üks neist komponentidest. Pärast seda võiksime tegur erinevaid kulusid sõltuvalt sellest, kas IT süsteem on evolvable või avatud jne Kui süsteem on juba käimas, peamine tegur kaaluda on hooldus- ja võibolla kulu tegevuse lõpetamise.

Näiteks

Skeem Näide arvutamine

Komponendi organisatsioon või selle standard on need omadused:

· Täistööajale taandatud= 100 000 $ / aastas

· Toetus Effort= 0,01 Täistööajale taandatud + 0,001 Täistööajale taandatud / aastas = 1000 $ + 100 $ / aastas

· Hoolduskulud= 100 $ - 10 $ / aastas

· Kapitalikulu= 2000 $

· Paigaldage Effort= 2 Täistööajale taandatud / päeva = 0.01 Täistööajale taandatud / aastas = 1000 $

Komponendi Organisatsioon on need omadused:

· Paigaldage Horizon= -2 Aastat (st süsteem paigaldati 2 aastat enne olemas)

· Eluaeg= 3 aastat

Millal Paigaldage Horizon + Eluiga <= 0 Ei ole enam hoolduskulud.

Arvutused

Arvutused on järgmised:

Märge

TC = kulu aastas. SE = Support pingutust. MC = hoolduskulud.

· Algne soetusmaksumus = kapitalikulud + Installi Effort= 2000 + 1000 = 3000 $

· At t = -2 (käigus 1. aasta), TC = Algne soetusmaksumus + SE + MC= 3000 + 1000 + 100 = 4100 $

· At t = -1, TC = SE + MC= (1000 + 100) + (100-10) = 1190 $

· At t = 0, TC = (1000 + 200) + (100-20) = 1280 $

· T = 1 (viimane aasta), TC = (1000 + 300) + (100-30) = 1370 $

Graafik Näide arvutamine

TCO on summa kõikide praeguste ja tulevaste kulude, kuni süsteem on tegevuse lõpetanud.

· T = -2 (ajal 1. aasta), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· T = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· T = 0, TCO = 1280 + 1370 = 2650 $

· T = 1 (viimane aasta), TCO = 1370 $

Key kulufaktorid

Oluline kulude tegurid, mida tuleb arvestada, kui arvutatakse TCO vara ABACUS on:

· Riistvara soetamine- Esialgne maksumus seadmed (kapitalikulu).

· Tarkvara soetamine- Esialgne maksumus litsentsi tarkvara (kapitalikulu).

· Paigaldamine- Kulud, mis on seotud esmase häälestamise.

· Koolitus- Hind, mis on seotud väliste müüja koolituse pärast esialgset seadistust.

· Support- Seotud kulusid sisemine toetus.

· Hooldus- Kulud asendada või uuendada müüja hoolduslepingud tarned ja katastroofiabi kulud.

· Infrastruktuur- Kulud, mis on seotud toetada vara.

ABACUS Näide esinduses Key kulufaktorid

Running Cost simulaator

Et simuleerida oma arhitektuuri poolest kulu

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Valima Analüüs| Cost.

3. Vali Arhitektuur (s)soovite kaasata hindamisse.

Märge

Vaikimisi ABACUS valib automaatselt arhitektuur (s), mille re-simulatsioon tõttu on vajalik nende all oleva vara või struktuurimuutusi.See esiletõstmine on näidatud Red kohta Simulatsioon tööriistariba .

4. Valige Valuutaalates lahtikäiv.

5. Liigutage Aastaid arvutadaliugur mitu aastat vaja.

Märge

Vaikimisi, kui Years arvutada on rohkem kui 1 aasta kulud arvutatakse automaatselt iga üksiku aastal (ja kogumise omadused lisatud / uuendatud) ja siis kumulatiivne väärtus kogu aastate arvu arvutatakse samuti. Kui ainult kumulatiivne väärtus ei vaja, siis lülita Arvuta Per-aasta kuludvariant, nagu allpool kirjeldatud säästa kinnistute arv projektis.

6. Vali, kas jätta Arvuta Per-aasta kuludkontrollida või eemaldage see.

7. Vajuta Järgmine.

8. Soovi valida Sidemedsoovid omistada kulud koos osana hindamine.

Märge

Kasutades Kulude | Omistaminevara ühendused kulud võib olla omistatud komponendist lisatud kraanikaussi otsas ühendus komponendile lisatud allika lõppu(st maksumus | Attribution = "Sink Allikas"), või komponendist lisatud allikas lõpuks ühendust osa külge valamu lõpp(st maksumus | Attribution = "Allikas Sink"). Lisaks ABACUS automaatselt valida need ühendused koos Behaviour | Suhted = "protsessid" või "toetab"ja suunas omistamine on "Sink Allikas". Lisaks kulutused on jaotatakse vastavalt ükskõik Behaviour | % Või kulu | % Omadusi ühendustel, või alternatiivselt, kus on mitu ühendused valamu paljud allikadvõi allikas paljudele valamudVastavalt suvalisele Behaviour | Töötlemine omadused allikast komponendidvõi valamu komponendid vastavalt.

9. Vajuta Finišja saad Hoiatusdialoogi.

10. Soovi uurida hoiatusi klikates Detailid >>.

11. Vajuta Jätkama.

Märge

Sel hetkel, ABACUS täidab tegevuspõhise kuluarvestuse hindamine arhitektuur (s) ja mõne aja pärast (koos edenemisribad tagasisidet) arvutus täielik ilmub dialoog.

12. Vajuta Okeitunnustada hindamist.

Ots

Koolituste ja täiendavat abi kulu Simulatsioon palun vaadake Avolution ühenduse .

Component ja / või Connection Omadused

Järgnev tabel loetleb osa ja / või ühendust omadused peavad hindama kulusid.Need omadused on näidatud Properties aken vara sisendi real valija ikoon ( [image] ) Koos tooltip "Cost sisend". Muutus kõik need "input" omadused ja erinevad struktuurimuutused hoidla toob kaasa kulude simulaator nõudes uuesti simulatsiooni märgitud Red kohta Simulatsioon tööriistariba .

Tüüp

Nimi

Vaikimisi väärtus

Ühik

Data Type

Nõutav

Kirjeldamine

Cost

Paigaldage Horizon

0

aastat

Täisarv

Tõsi

Määrab, kui osa või ühendus on olnud või on paigaldatud.

· Väärtus 0 (default) näitab, et osa või ühendus on paigaldatud käesoleval aastal.

· Väärtus on väiksem kui 0 näitab, et osa või ühendus on paigaldatud ka varem.

· See on suurem 0 näitab, et osa või ühendus paigaldatakse tulevikus.

Cost

Eluaeg

0

aastat

Täisarv

Tõsi

Määrab aja, mil osa või ühendus jääb operatsioon, mille järel see demonteeritakse.

Cost

Täistööajale taandatud

100,000.00

$ / aastas

Decimal

False

Aastane maksumus iga täistööajaga töötaja.

Kui see vara ei ole tuvastatud komponentise või puhul ühendused komponendi külge kraanikaussi otsas ühendus, Siis otsitakse muid komponente.

Esiteks, mis tahes "valamu" osas lõpus a seoses "toetab" suhe komponendile otsitakse, millele järgnes et "valamu" osa vanems.

Kui Täistööajale taandatud vara ei ole leitud, komponendi lapsevanem-components siis otsitakse. Kui Täistööajale taandatud ikka ei leidnud, vaikimisi väärtus on kasutatud.

Märkus: Täistööajale taandatud ainult kehtiva sisend vara komponente.

Cost

Hoolduskulud (fikseeritud)

0.00

$ / aastas

Decimal

False

Iga-aastane püsikulu säilitades osavõi ühendus.

Cost

Hoolduskulud (muutuva)

0.00

$ / aastas

Decimal

False

Summa, mille kogumaksumus säilitades osa või ühendus muutub igal aastal.

Näiteks väärtus $ -500 näitab, et kõigi hoolduskulude väheneb $ 500 võrra aastas, ning väärtus $ 500 näitab, et kõigi hoolduskulude suureneb $ 500 aastas.

Cost

Toetus pingutust (fikseeritud)

0.00

Täistööajale taandatud / aastas

Decimal

False

Iga-aastane fikseeritud jõupingutusi toetada komponentvõi ühendus, Mis määratletakse inimaasta.

Cost

Toetus pingutust (muutuva)

0.00

Täistööajale taandatud / aastas

Decimal

False

Summa, mille püügikoormus toetada komponent või ühendus muutub igal aastal.

Näiteks väärtus -0,01 näitab, et kogu toest pingutust väheneb 0,01 isiku aastat igal aastal, samas väärtusega 0,01 näitab, et kogu toest pingutust tõuseb 0,01 igal aastal.

Cost

Kapitalikulu

0.00

$

Decimal

False

Esialgne ostmise kulud komponentvõi ühendus.

Cost

Paigaldage Effort

0.00

Täistööajale taandatud

Decimal

False

Nõutavad jõupingutused, isiklikult-aastane, paigaldada komponentivõi ühendus.

Järgnev tabel loetleb osa ja / või ühendust omadused, mis on väljund poolt TCO hindaja. Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Cost Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja kulude simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Märge

Kui atribuudid alates TCO hindaja peab olema "ümardatud edaspidi" Round pool isegi "lähenemine (nimetatakse ka" pankurid "ümardamisest) kasutatakse.Seda tehnikat kasutatakse ühtlasemalt lahendada .5 "tie puruneb", mille tulemusena on ümardada üles- või allapoole lähima isegi tulemus, mitte alati ümardamisest ja viltused tulemus. St 2.5 ümardatakse 2, samal ajal 3,5 ümardatakse 4, mitte neid mõlemaid on kas ümardatakse 2 ja 3 või ümardatakse 3 ja 4.

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Cost | Total Cost omada - järgmine x aastat. | $ | Täisarv | False | Projekti kogumaksumuseks omandiõiguse üle järgmise xaastat, kus x on aeg kindlaks määratud sõites hindaja. See hõlmab kulusid komponendi või ühendus on standardid, alakomponentidesvõi sub-ühendused(st lapsed) ja kõik tingitud kulud.
Cost | Total Cost omada (kohalik) - kõrval x aastat. | $ | Täisarv | False | Nn kohaliku "ülalpidamiskulud üle järgmise xaastat, kus xon aeg kindlaks määratud sõites hindaja. See teeb eisisaldada kulusid komponendi alakomponentides või ühendus on sub-ühendused (stlapsed) või tingitud kulud.
Cost | Total Cost omada (lapsed) - kõrval x aastat. | $ | Täisarv | False | Nn laste ülalpidamiskulud üle järgmise xaastat, kus x on aeg kindlaks määratud sõites hindaja. See ainult sisaldab maksumuse komponendi alakomponentides või ühendus on sub-ühendused (st lapsed).
Cost | Total Cost omada (omistatud) - kõrval x aastat. | $ | Täisarv | False | Nn omistatud "ülalpidamiskulud üle järgmise xaastat, kus x on aeg kindlaks määratud sõites hindaja. See ainult hõlmab kõiki tingitud kulud lisatud komponendid(mis võib muidugi hulka tingitud kulud igast kinnitatud ühendused).

Järgnev tabel loetleb osa ja / või ühendust omadused, mis on väljund poolt TCO hindajakui Arvuta Per-Year Kulud valik on. Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Cost Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja kulude simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Märge

Vaata märkus eespool võimaliku ümardamise atribuudid.

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Cost | Total Cost omada - aastax. | $ | Täisarv | False | Projekti kogumaksumuseks omandisse jaoks aasta x, Kus x on iga aasta määratud sõites hindaja. See hõlmab kulusid komponendivõi ühendus on standardid, alakomponentides või sub-ühendused (st lapsed) ja kõik tingitud kulud.
Cost | Total Cost omada (kohalik) - aastax. | $ | Täisarv | False | Nn kohaliku "ülalpidamiskulud aastaks xVajaduse xon iga aasta määratud sõites hindaja. See teeb eisisaldada kulusid komponendi alakomponentides või ühendus on sub-ühendused (st lapsed) või tingitud kulud.
Cost | Total Cost omada (lapsed) - aastax. | $ | Täisarv | False | Nn laste ülalpidamiskulud aastaks x, Kus x on iga aasta määratud sõites hindaja. See ainult sisaldab maksumuse komponendi alakomponentides või ühendus on sub-ühendus (st lapsed).
Cost | Total Cost omada (omistatud) - aastax. | $ | Täisarv | False | Nn omistatud "ülalpidamiskulud aastaks x, Kus x on iga aasta määratud sõites hindaja. See ainult hõlmab kõiki tingitud kulud lisatud komponendid(mis võib muidugi hulka tingitud kulud igast kinnitatud ühendused).

Täiendav Connection Properties

Järgmises tabelis on loetletud lisa- Seoses omadused, mis on vajalikud TKO hindaja. Need omadused on näidatud Properties aken vara sisendi real valija ikoon ( [image] ) Koos tooltip "Cost / Performance sisend" või lihtsalt "Cost sisend". Muutus kõik need "input" omadused ja erinevad struktuurimuutused hoidla toob kaasa kulusid ja / või Performance simulaator nõuab uuesti simulatsiooni märgitud Red kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Vaikimisi väärtus | Ühik | Data Type | Nõutav | Kirjeldamine
Cost | Omistamine | Valamu Allikas | [Allikas Sink | Valamu Source] | Otsing / Nimekiri | Tõsi | Kui "Allikas kereühendusega", Sellega seoses tahe olema olema maksumussomistatud "koos" see alates allikaskomponendi valamu osa. Alternatiivselt, kui "Valamu Allikas", Sellega seoses tahe on kuludes "koos" see valamu komponent allikseadmega.
Käitumine | Suhe | toetab | [protsesse | toetab] | Otsing / Nimekiri | False | Kui "toetab", sellega seoses näitab, et "allikas" komponendile toetab "valamu" komponendile. Lisaks, kui kas "toetab" või "protsessid" siis ühendus automaatselt valitud ühendused on oma kuludes "mööda" valamu komponent allikseadmega.
Cost | % | 100,0 | % | Decimal | False | Näitab osa valamu komponendid kulud, mis on tingitud allikseadmega. Olema% väärtusi ei ole vaja lisada kuni 100% ja see on lihtsalt kasutatav skaala "Total Cost omada - järgmine x aastat." käsutada (vt eespool) äravoolusifoonist komponendi sest see on omistatud allikseadmel.

Arhitektuur omadused

Järgnev tabel loetleb arhitektuuri omadused, mis on väljund poolt TCO hindaja. Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Cost Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja kulude simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Märge

Vaata märkus eespool võimaliku ümardamise atribuudid.

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Cost | Total Cost omada - järgmine x aastat. | $ | Täisarv | False | Projekti kogumaksumuseks omandiõiguse kogu arhitektuuri üle järgmise x aasta jooksul.

Järgnev tabel loetleb arhitektuuri omadused, mis on väljund poolt TCO hindajakui Arvuta Per-Year Kulud valik on. Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Cost Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja kulude simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Märge

Vaata märkus eespool võimaliku ümardamise atribuudid.

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Cost | Total Cost omada - aastax. | $ | Täisarv | False | Projekti kogumaksumuseks omandisse jaoks kogu arhitektuuri aastaks xtulevikku.


Simuleerimine Töökindlus ja käideldavus

Navigation: simuleerimine oma arhitektuuri> Simulaatorid>

Simuleerimine Töökindlus ja käideldavus

Saada kommentaare selle teema.

Taust

Töökindlus Hindaja arvutab usaldusväärsust arhitektuuri abil sisend komponendid ja ühendused.

Osade ja otseühendus, usaldusväärsuse põhineb Mean Time Between jätmine (MTBF). Ainsad tegurid arvutamiseks vajalik usaldusväärsus arhitektuursed elemendid on:

· MTBFväärtus (aastates);

· Vahepeal remont (MTTR)ebaõnnestumine (aastates); ja

· Määratletud aega katsetada Usaldusväärsus üle.

Seda valemit kasutatakse arvutamisel Usaldusväärsus on antud:

Usaldusväärsus = -e (y × vanus)
Kus y = 1 ÷ MTBF

Kättesaadavus komponendid ja ühendused põhineb MTBF ja MTTR. Pange tähele, et kättesaadavus, erinevalt usaldusväärsust, on mõjutanud aja eest, mis ta on testitud.

Saadavus = MTBF / (MTBF + MTTR)

Kuigi meetodeid, mis muudavad Usaldusväärsus plokkskeeme(kasutades lihtsaid jada- ja konstruktsioone) anda kõige täpse tulemuse need meetodid muutunud väga impraktiline kui püüame arvutada usaldusväärsuse esindused tohutu võrgustike tuhandeid elemente. Lisaks nendele transformational lähenemisviise murda palju ühiseid struktuure, nagu võrgu "silma".

Monte CarloMeetod võimaldab usaldusväärsuse ja kättesaadavuse süsteemi suvalise suuruse ja keerukusega tuleb arvestada. Monte Carlo meetod simuleerib palju stsenaariume ja fvõi iga stsenaarium juhuslik riik saadaval või saadaval, On määratud igale füüsilise element. Tõenäosus, et antud element on võimalikus riik on rajatud usaldusväärsus / kättesaadavus komponent.

Näiteks osa 90% kättesaadavust saab eeldatavasti saab umbes 90% stsenaariume. Kaudne seos usaldusväärsus ja kättesaadavus Seepärast võib hinnata kui osa juhuslikult scenarios-, mille teele elemendid olemas võimalikus RKT allikast alal.

Märge

Kuna arvutamise kohaliku töökindluse ja käideldavuse põhineb erinevate parameetrite ja erinevate valemite (ja seega tulemuseks erinevaid väärtusi), on vaja määrata iga elemendi kaksriigid, Üks Saadavuse, ja üks töökindluse. Arvutus kättesaadavuse kasutab kättesaadavust riik iga stsenaariumi arvestamine usaldusväärsust kasutab usaldusväärsust riigi iga stsenaariumi.

Usaldusväärsuse hindaja kasutab Monte Carlo simulatsiooni meetod töötada välja usaldusväärsust konkreetse arhitektuuri. Arhitektuur läbib tuhandeid üksikute simulatsioone ja tulemused tabelis tuletada usaldusväärsust meede. Nagu eespool mainitud, Monte Carlo on kõige kiiremini tehnikat simuleerimiseks suuremat võrkude ja töötab koos iga kompleks (st silmadega) struktuuri.

Hindaja väljastab neli väärtust:

1. Missioon Usaldusväärsusüle mitme aasta jooksul;

2. Kättesaadavus selle arhitektuur;

3. Usaldusväärsus selle kohaliku komponentüle mitme aasta jooksul; ja

4. Kättesaadavus selle kohaliku komponent.

Hindaja töötab välja tõenäosus komponendi või ühendus töö (st ei suuda) ja aeg, mis kulub remont.

Kuidas standardite MTBFs ja / või MTTRs koheldakse

Kui element (komponent või ühendus) on standardite määratud MTBF ja / või MTTR väärtusi, nende väärtuste kasutatakse ka arvutamist kohaliku usaldusväärsust ja kättesaadavus Elemendi jadana ühendus.

Näiteks, kui komponent AKoos määratud standardite B, CJa Diga on MTBF ja MTTR väärtus, Local Usaldusväärsus = R(A)× R(B) × R(C) × R(D)Vajaduse R = Arvutatakse usaldusväärsust (kasutades valemit) komponendi / standardidja Kohalik Kasuvõime = A (A)× A (B) × A (C) × A (D)Vajaduse A = Arvutada kasuvõime (kasutades valemit) komponendi / standardid. Seda juhul, kui element on kolm standardid iga koos MTBF ja MTTR väärtussJa ka MTBF ja MTTR väärtusselemendi omadused, kohaliku usaldusväärsust ja avilability antakse jadana väärtus iga standardite ja element ise.

Teise näitena, kui komponent Aon määratud standardite B, CJa Dkuid ainult standard Bon nii MTBF ja MTTR väärtust, samas kui standard Con ainult MTBF väärtus ja standard Don ainult MTTR väärtus, Local Usaldusväärsus = R (A)× R (B)× R (C)Vajaduse R= Arvutatakse usaldusväärsust (kasutades valemit) komponendi / standardite ja kohaliku Kättesaadavus = A (A)× A (B)× A (C)Vajaduse A= Arvutatakse kättesaadavus (kasutades valemit) komponendi / standardite kuid arvutamisel A (C), sest standard vaid on MTBF väärtus on 'otsingud'jaoks sobiva MTTR väärtus (ed) ja lisab kogu MTTR väärtustab ta leiab, et don't ise on sobitamise MTBF väärtus, nii et sel juhul oleks kasutada MTTR väärtus standard D. Kui seal oli veel standardse öelda EKoos lihtsalt MTTR väärtus samuti siis A (C)kasutaks MTBF Ckoos MTTR kohta Dja Eliita. Kui teine ​​standard, ütlevad FOli lihtsalt MTBF väärtusest A (F)oleks kasutada ka MTTR of Dja Eliita.

Arvuta missioon Usaldusväärsus

Kuigi arvutamisel kohaliku usaldusväärsus on küsimus abil lihtne valem, arvutamine kaudse ühendused (missioon) ei ole nii lihtne, eriti kui meil on keeruline ja suurte võrkude põimitud teed (ühendused) ja komponente.

Võttes kogu võrgu arvesse

Kuna kaudsed ühendused ei esinda füüsilise ühenduse, peame teada, kuidas allikseadmega saad oma sihtkohta komponent. Ja see tähendab, et käsitleda kogu võrgu ja kõik erineval moel (ja teed) meie allikseadmega saab võtta, et jõuda sihtkohta komponent (valamu).

Märge

Niikaua kui on olemas vähemalt üks täieliktee allikast sihtkoht missioon on edukasja kaudse ühendus on viidatud kui sulgesühenduse.

Mõistmise Link Matrix

Et teada, millised osad / otseühendus on seotud sellega, mida me vajame artefakti kiiresti kontrollida, kas kaks plokki on seotud teatud suunas. See on funktsioon seose maatriksis. Lühidalt link maatriks on kahemõõtmeline massiiv Boole'i ​​muutujad, mis ütleb, kas konkreetne komponent võib ulatuda teise osa otse. Selle suurus on võrdne ruudu koguarvust komponendid võrku.

Lihtne Usaldusväärsus Plokkskeemid (RBD)

Seotud Link Matrix töökindluse Plokkskeemid (RBD)

Kuna kõik ühendused on kahesuunaline (läheb mõlemas suunas), siis on oluline teada, kuidas lugeda link maatriks õigesti. Usaldusväärsuse hindaja esimene argument on allikas ja teine ​​argument on valitud alal (valamu).

Seega, kui link maatriks (A, B) = true, siis tähendab see, et saan B otse (ühesuunaliste). B saab A, kui ainult siis, kui link maatriks (B, A) = true. Kui see on tõsi, see tähendab, kahesuunalise ühenduse.

Antud näites üle:

· Allikas 1 jõuavad kohtades 0 (Allikas 1 ja Sihtkoht 0 annab tulemuseks True); ja

· Allikas 0 jõuavad kohtades 1 (Allikas 0 ja Destination 1 annab tulemuseks True), kui link 0 ja 1 vahel on kahesuunaline.

· Allikas 2 ei jõua kohtades 1 (Allikas 2 ja Destination 1 annab tulemusena False) isegi siis, kui allikas 1 jõuavad alal 2 (Allikas 1 ja Destination 2 annab tulemuseks True). See on tähendab, et seos 1 ja 2 on ühesuunalised.

Mõistmise Usaldusväärsus Plokkskeemid

Usaldusväärsuse plokkskeem (RBD) isoleerib struktuuri kogu objekti mudeli poolest plokid ja lingid. Iga plokk on element, mis on võimalik rike või edu vastavalt lingid / teed, et ühendada neid. Mõlemad komponendid ja ühendused võivad saada "plokk" on RBD.

Näide RBD plokid ja lingid

Joonisel Ülaltoodud esindab RBD näiteks. Katkendjoon punane joon tähistab ühe missioon 4 1. Vaadake, kuidas seal on ainult kaks võimalikku teed, et missioon 4: 1.

Vaatleme liinil 4-3 kuni 0-1, ja marsruudi 4-7 kuni 1. punktiirjoon plokid 2, 5ja 6 moodustavad plokid, mis ei mõjuta rike / non-rike missioon 4 1. Nad ei peeta ja ignoreeritakse. See on oluline, kuna enamiku missioonide tekib suur hulk koondatud plokid, mis ei mõjuta konkreetse missiooni edu. See on märgatavam suuremate võrkude, mille arv koondatud plokid teeb simulatsiooni tulemused ebatäpsed.

Et kiirendada ajahetkele, ja tagada Täpsema tuleb abstraheeruda kogu RBD ja kasutada ainult neid elemente, mis mõjutavad missiooni edu.

Märge

Üks tee / tee ei lähe läbi ühtegi osa kaks korda.

Praeguses etapis me saame luua lingi maatriks ja sooritada Monte Carlo simulatsiooni.

Arvuta Arhitektuur saadavust

Arhitektuur kättesaadavus on tõenäosus, et kõik kaudsed ühendused on saadaval igal ajahetkel. Kättesaadavus iga kaudne seos on määratud ajal iga iteratsiooni Monte Carlo simulatsiooni, aga need kaudsed ühendused (tavaliselt) tugineda samad füüsilised elemendid. Seega, lihtsalt koondamisel individuaalsete kättesaadavust oleks "double-count" need un-kättesaadavust, andes pessimistlik Üldstruktuur kättesaadavust. Teise kogu arhitektuur kättesaadavus arvutatakse vaadates iga iteratsiooni ja nähes, kas asjaolud kaudses ühendused huvi on olemas. Ja seejärel liidetakse need tulemused lõpus simulatsiooni.

Running Usaldusväärsus simulaator

Et simuleerida oma arhitektuuri poolest usaldusväärsust

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Valima Analüüs| Usaldusväärsus.

3. Valige Arhitektuursoovite hinnata alates rippmenüüst.

Märge

Vaikimisi ABACUS valib automaatselt esimene arhitektuuri, mille re-simulatsioon tõttu on vajalik nende all oleva vara või struktuurimuutusi.See esiletõstmine on näidatud Red kohta Simulatsioon tööriistariba .

4. Valige Komponendidja Sidemedsoovite hinnata alates standard element valiku aken kasutades "Näita Direct Ühendused" ja "Show Protsessid Ühendused" raadio-nuppu filtrid põhjas dialoogi vasakpoolses osas abi teiega valikut.

Täiendav CheckboxEuroopa standard element valiku aken

· Save Muundatud Mudeltahe salvestada koopia RBD ümber versiooni projekti samasse kausta praeguse projekti ja lisab "_transformed" projekti nimi.See muutnud projekti saab diagnoosida üksikasjalikult usaldusväärsust simulatsiooni võetud ABACUS.

Täiendav Radio-NupudEuroopa standard element valiku aken

· Näita Direct ühendused automaatselt niipea ühendus on Atribuudifilter vara Type = Käitumine, Name = Abstraction ja Value = otsese.See valik on vaikimisi valitud ja abivahendid valik otsesele ühendused nagu eespool kirjeldatud ja allpool.

· Näita Protsessid Ühendused automaatselt niipea ühendus on Atribuudifilter vara Type = Käitumine, Name = Suhted ja Value = protsessid.See võimalus aitab valiku otsesele ühendused nagu eespool kirjeldatud ja allpool.

5. Vajuta Järgmine.

6. Vali Missioonidst Ühendused soovite lisada simulatsioon.

7. Seadke Filmi pikkus Scale Factorliugur.

Märge

Kõrgemad väärtused toovad rohkem statistiliselt ühtseid tulemusi, kuid võtab kauem aega, et arvutada.

Linnukesed

· Show Suletud ühendusedtahe automaatselt filtreerida saadaolevaid ühendusi vaid hõlmavad neid, millel on vähemalt üks täielik füüsilise tee allikseadmel sihtkohale komponendi seisuga RBD valiku ülal kirjeldatud.

· Näita Kaudne ühendused automaatselt niipea ühendus on Atribuudifilter vara Type = Käitumine, Name = Abstraction ja Value = kaudne.See valik on vaikimisi valitud ja AIDS valiku kaudsed või missioon ühendused nagu eespool kirjeldatud ja allpool.

Nupud

· KõikValib kogu sidemed.

· Teistpiditühistab kõigi valitud sidemed ja valib kõik need, mis ei valitud.

· Mitte ükskitühistab kõik sidemed.

Muud valikud

· Filmi pikkus Scale Factor kontrollib ajahetkele ja täpsuse suuremal väärtused saakserohkem statistiliselt ühtseid tulemusi, kuid võtmine kauem aega jooks.

Märge

Kui ABACUS arvutab korduste arvu simuleerida see määrab kõige usaldusväärsem element, mis ei ole täiesti usaldusväärsed ja siis simuleerida Run Time Scale Factor korda 1 üle kättesaamatuse et element pluss 1 korduse. Või (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. See on veenduda, et see element ei toimu vähemalt üks kord simulatsioon. Näiteks Kui kõige usaldusväärsem element, mis ei ole täiesti usaldusväärsed on MTBF 10000 tundi ja MTTR 8 tundi, seejärel simulatsiooni võtab (10000 + 8) / 8 = 1251 korda Run aeg Scale Factor + 1 korduste.

· Aastaid simuleerida Ahead määrab, mitu aastat, enne kui missioon Kas tuleb arvutada.

· Numbra teemaddetermines arvu töötlemise teemasid kasutada Monte-Carlo simulatsioon.See valik vaikimisi sobitada arvu saadaval protsessoriga / südamikud (sh hüperlõimede südamikud), et minimeerida ajahetkele.

8. Vajuta Finišja saad Hoiatusdialoogi.

9. Soovi uurida hoiatusi klikates Detailid >>.

10. Vajuta Jätkama.

Märge

Sel hetkel, ABACUS täidab Monte-Carlosimulatsiooni arhitektuuri ja mõne aja pärast (koos edenemisribad tagasisidet) arvutus täielik ilmub dialoog.

11. Vajuta Okeitunnustada simulatsioon.

Ots

Koolituste ja täiendavat abi Usaldusväärsus Simulatsioon palun vaadake Avolution ühenduse .

Component ja Connection Properties

Järgnevas tabelis on toodud komponendi ja"otsene"Seoses omadused peavad hindama usaldusväärsust. Need omadused on näidatud Properties aken vara sisendi real valija ikoon ( [image] ) Koos tooltip "Usaldusväärsus sisend". Muutus kõik need "input" omadused ja erinevad struktuurimuutused hoidla toob kaasa Usaldusväärsus simulaator nõudes uuesti simulatsiooni märgitud Red kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Vaikimisi väärtus | Ühik | Data Type | Nõutav | Kirjeldamine
Usaldusväärsus | MTBF | ∞ | aastat, nädala, päeva või tundi | Decimal | Tõsi | Vahepeal Enne Häired element. Märkus: väärtusi saab väljendada ühikutes aastat, nädala, päeva või tundi ja konverteeritakse pärast '24 / 7 "kättesaadavus mõiste järgmiselt; - 1 aasta = 52 nädalat või 365 päeva või 8760 tundi - 1 nädal = 7 päeva või 168 tunni - 1 päev = 24 tundi
Usaldusväärsus | MTTR | 0 | aastat, nädala, päeva või tundi | Decimal | Tõsi | Vahepeal remont elemendi. Märkus: väärtusi saab väljendada ühikutes aastat, nädala, päeva või tundi ja konverteeritakse pärast '24 / 7 "kättesaadavus mõiste järgmiselt; - 1 aasta = 52 nädalat või 365 päeva või 8760 tundi - 1 nädal = 7 päeva või 168 tunni - 1 päev = 24 tundi

Järgnevas tabelis on toodud komponendi ja"otsene" Seoses omadused toodangut usaldusväärsust hindaja. Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Kas Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja Usaldusväärsus simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Usaldusväärsus | Usaldusväärsus - x aastat |  | Decimal | False | Tõenäosus, et element ei suuda lähema x aastat. See on väärtus 0 ja 1 vahel.
Usaldusväärsus | Ebausaldusväärsuse - x aastat |  | Decimal | False | Tõenäosus, et element nurjub lähema x aastat. See on väärtus 0 ja 1 vahel.
Usaldusväärsus | Kättesaadavus | % | Decimal | False | Arvestatud kättesaadavus komponendi või ühendus. See on väärtus vahemikus 0% kuni 100%.
Usaldusväärsus | Kättesaamatuse | % | Decimal | False | Arvestatud puudumise komponendi või ühendus. See on väärtus vahemikus 0% kuni 100%.

Järgnev tabel loetleb 'kaudne'Seoses omadused toodangut usaldusväärsust hindaja. Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Kas Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja Usaldusväärsus simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Usaldusväärsus | Missioon Usaldusväärsus - x aastat |  | Decimal | False | Tõenäosus, et kaudne seos ei suuda lähema x aastat. See on väärtus 0 ja 1 vahel.
Usaldusväärsus | Missioon Ebausaldusväärsuse - x aastat |  | Decimal | False | Tõenäosus, et kaudsete ühendus ei toimi lähema x aastat. See on väärtus 0 ja 1 vahel.
Usaldusväärsus | Kättesaadavus | % | Decimal | False | Arvestatud kättesaadavus kaudne seos. See on väärtus vahemikus 0% kuni 100%.
Usaldusväärsus | Kättesaamatuse | % | Decimal | False | Arvestatud ei ole kättesaadav kaudne seos. See on väärtus vahemikus 0% kuni 100%.

Arhitektuur omadused

Järgnev tabel loetleb arhitektuuri omadused toodangut usaldusväärsust hindaja. Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Kas Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu tagatiseks oleva kinnisvara või struktuurimuutuse hoidlasse ja Usaldusväärsus simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Ühik | Data Type | Nõutav | Kirjeldamine
Usaldusväärsus | Kättesaadavus | % | Decimal | False | Kättesaadavus kõigile kaudsed ühendused, mis on kantud hindamine. See tähendab, et tõenäosus, et kõikkaudsed ühendused on kättesaadavad antud ajahetkel. See on väärtus vahemikus 0% kuni 100%. Märkus: see ei ole paljunemise individuaalse ühenduse kättesaadavust, sest see oleks "kahekordset arvestamist" un-kättesaadavus asjakohaste komponentidega.
Usaldusväärsus | Kättesaamatuse | % | Decimal | False | Kättesaamatus kaudse ühendused, mis on kantud hindamine. See tähendab, et tõenäosus, et vähemalt ükskaudne seos on saadaval aadressil antud ajahetkel. See on väärtus vahemikus 0% kuni 100%. Märkus: see ei ole paljunemise üksikliitumiste unavailabilities nagu oleks see "topelt-loendus" un-kättesaadavus asjakohaste komponentidega.
Usaldusväärsus | Missioon Usaldusväärsus - x aastat |  | Decimal | False | Tõenäosus, et kõik kaudse ühendusi, mis on kantud Hindamist suuda lähema xaastat. See on väärtus 0 ja 1 vahel Märkus: See ei ole paljunemist üksikliitumiste reliabilities nagu oleks see "topelt-loendus" un-kättesaadavus asjakohaste komponentidega.
Usaldusväärsus | Missioon Ebausaldusväärsuse - x aastat |  | Decimal | False | Tõenäosus, et vähemalt üks kaudse ühendused, mis on kantud hindamise nurjub lähema xaastat. See on väärtus 0 ja 1 vahel Märkus: See ei ole paljunemist üksikliitumiste unreliabilities nagu oleks see "topelt-loendus" un-kättesaadavus asjakohaste komponentidega.


Simuleerimine Avatus

Navigation: simuleerimine oma arhitektuuri> Simulaatorid>

Simuleerimine Avatus

Saada kommentaare selle teema.

Avatus simulaator määrab tase, mis näitab arhitektuuri ja selle elemendid on "avatud", st võime süsteemi käsitseda komponentide vahetamist minimaalse mõjuga.

Et simuleerida oma arhitektuuri poolest avatus

1. Veenduge, et teil on ABACUS faili, Mis sisaldab teie asustatud arhitektuuri, avatud.

2. Vali analüüs | Avatus.

3. Vali Arhitektuur (s)soovite kaasata hindamisse.

Märge

Vaikimisi ABACUS valib automaatselt esimene arhitektuuri, mille re-simulatsioon tõttu on vajalik nende all oleva vara või struktuurimuutusi.See esiletõstmine on näidatud Red kohta Simulatsioon tööriistariba .

4. Vajuta Finišja saad Hoiatusdialoogi.

5. Soovi uurida hoiatusi klikates Detailid >>.

6. Vajuta Jätkama.

Märge

Sel hetkel, ABACUS täidab struktuurseid hindamine arhitektuur (s) ja mõne aja pärast (koos edenemisribad tagasisidet) arvutus täielik ilmub dialoog.

7. Vajuta Okeitunnustada simulatsioon.

Ots

Koolituste ja täiendavat abi Avatus Hindamine palun vaadake Avolution ühenduse .

Component ja Connection Standard omadused

Järgnev tabel loetleb osa ja ühendus standard omadused peavad hindama avatust.Need omadused on näidatud Properties aken vara sisendi real valija ikoon ( [image] ) Koos tooltip "Avatus sisend". Muutus kõik need "input" omadused hoidla toob kaasa Avatus simulaator nõudes uuesti simulatsiooni märgitud Red kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Vaikimisi väärtus | Ühik | Data Type | Nõutav | Kirjeldamine
Avatus | Standardid-Standard Tähtajapõhine Organisatsiooni Level |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Tase vastutustundliku Standardikeskus 0:Organisatsiooni / varaline 1:Consortium / DEFACTO 2:National / Military 3:Rahvusvaheline
Avatus | Standardid-Standard küpsus-staatus |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Kinnitamine saavutatud standarditele keha 0:Töö / komitee eelnõu 1:Avalik eelnõu / Balloted 2:Ajutine eelnõu 3:Kinnitatud
Avatus | Standardid-Standard Tähtajapõhine Stabiilsus |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Kas standard tõenäoliselt muutub? 0:Standard vananenud 1:Väga muutuda järgmise 1-2 aastat 2:Tuntud muutus / uuendused olemasolevatele omadused 3:Väga stabiilne (ei muutu 2 aasta jooksul)
Avatus | Standardid-Standard Tähtajapõhine Vendor Support |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Vendor Support 0:Ei ole tooteid või müüjad toetada standard 1:Üks või mitu müüjad, et rakendada osa standard 2:Rohkem kui üks müüja tooteid, mis rakendavad kõik osad standard 3:Paljud on rohkem kui üks müüja tooteid, mis rakendavad kõik osad standard
Avatus | Standardid-Standard selgus-Dokumentatsiooni |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Kvaliteet standard dokumentatsioon 0:Vaene 1:Fair 2:Hea 3:Suurepärane
Avatus | Standardid-Standard selgus-Standard Width |  |  | Täisarv | False | Mitmeid funktsioone. Count madalaima taseme standard funktsioone - Sf
Avatus | Standardid-Standard selgus-Sm |  | % | Decimal | False | Osakaal mitmeid funktsioone, mis on kohustuslikud
Avatus | Standardid-Standard selgus, So |  | % | Decimal | False | Osakaal mitmeid funktsioone, mis on vabatahtlik
Avatus | Standardid-Standard selgus-SC |  | % | Decimal | False | Osakaal mitmeid funktsioone, mis on tinglikult määratleda
Avatus | Profiilid Profile Dokumentatsiooni-Dokumentatsiooni |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Kvaliteet standard dokumentatsioon 0:Mitte ükski 1:Vaene 2:Fair 3:Suurepärane
Avatus | Profiilid Profile Dokumentatsiooni täpsus |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Kas dokumentatsioon ei kajasta tegelikku süsteemi projekteerimise? Mis tasemel profiili funktsioone kasutatakse süsteemi? 0:No omadused 1:Mõned funktsioonid 2:Enamik funktsioone 3:Kõik funktsioonid
Avatus | Profiilid Profile Dokumentatsiooni-Lõpptähtaeg |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Kas profiili küps ja kättesaadav? 0:Ad-hoc 1:Projektipõhine 2:Organisatsiooni 3:Avalik
Avatus | Profiilid Profile selgus fakultatiivsetest Laius |  |  | Täisarv | False | Arv standard eripäraga nõutud profiili
Avatus | Profiilid Profile selgus-Pm |  | % | Decimal | False | Protsent KOHUSTUSLIK funktsioonid profiili
Avatus | Profiilid Profile selgus-Po |  | % | Decimal | False | Protsent lisavarustusele profiilis
Avatus | Profiilid Profile selgus-PC |  | % | Decimal | False | Osakaal tingimisi määratletud funktsioonid profiili
Avatus | Profiilid Profile selgus-Coverage |  | % | Decimal | False | Protsent standard funktsioone käsitletakse eraldi profiili
Avatus | Profiilid Profile Extensions-Extension Laius |  |  | Täisarv | False | Arv ei ole kindlad omadused määrab profiili
Avatus | Profiilid Profile Extensions-Coverage |  | % | Decimal | False | Protsent laiendused üksikasjalikult profiili
Avatus | Tooted-toote kättesaadavust ning vastavust-arv tooted |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Toodete arv toetamine kohustuslikud funktsioonid standard 0:Tooteid pole toetab standard 1:Üks või rohkem tooteid rakendada osa standard 2:Rohkem kui ühe toote rakendab kõiki osi standard 3:Paljud on rohkem kui üks toode täidab kõiki osi standard
Avatus | Tooted-toote kättesaadavust ning vastavust-Application Vastavus |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Mis tasemel vastavust ei toodetega on standard? 0:Mitte ükski 1:Väitis 2:Tõestatud 3:Sertifitseeritud ja näitas
Avatus | Tooted-toote kättesaadavust ning vastavust-Vastavus kvaliteet |  | [0 | 1 | 2 | 3] | Otsing / Nimekiri | False | Kvaliteet vastavuse kontrollimine 0:Mitte ükski 1:In-house katsetamine tootearendaja 2:Sõltumatud testid (nt NIST) 3:Demonstreeriti kontekstis asjaomase toote

Component, Connection ja arhitektuuri Omadused

Järgnev tabel loetleb komponent, ühendus ja arhitektuuri omadused toodangut avatus hindaja. Kõik järgmised omadused hinnatakse, nulli (0) ja kolm (3), null (0) peetakse kõige vähem soovitav ja kolm (3) olles kõige soovitavam.Need omadused on näidatud Properties aken vara väljundi rida valija ikoon ( [image] ) Koos tooltip "Avatus Output". Nool ikoon esile Red ( [image] ), Kui need omadused on aegunud tõttu alusvara muutus hoidlasse ja avatus simulaator nõuab uuesti simulatsiooni järgi Red rõhutades kohta Simulatsioon tööriistariba .

Tüüp | Nimi | Data Type | Nõutav | Kirjeldamine
Avatus | Avatus | Decimal | False | Üldhinnangu elemendi avatust.
Avatus | Standardid-Standard Tähtaeg | Decimal | False | Praegune olukord standard, mis peegeldab kas see on heaks kiidetud, kui kaua see on olnud kasutusel ja kui hästi vastu on ühenduses arendajad.
Avatus | Standardid-Standard selgus | Decimal | False | Selgusest standardite, peegeldab potentsiaali ebaselgust järgnenud standardid
Avatus | Profiilid Profile Dokumentatsiooni | Decimal | False | See, mil määral liides profiili dokumentatsioon on arenenud ja kas profiili dokumendid peavad kajastama tegelikku süsteemi projekteerimise ja / või rakendatud süsteemi
Avatus | Profiilid Profile selgus | Decimal | False | Tase detailsus profiili / profiili spetsifikatsioon
Avatus | Profiilid Profile Extensions | Decimal | False | Mil määral profiili vastab standardile, mis on aluseks
Avatus | Tooted-toote kättesaadavust ning vastavust | Decimal | False | Kas on või ei ole avatud standard conformant tooted saadaval kasutamine projektis


Standard aruanded

Navigation: aruanne oma arhitektuuri>

Standard aruanded

Saada kommentaare selle teema.

ABACUS " standard aruanded võimaldavad saada osade loetelu ja ühendused ühes või mitmes oma struktuur. Aruanne sisaldab kogu teavet, mis on seotud komponendid ja ühendused valitud, sealhulgas teave selle komponendi või ühendus koht hierarhias, tüüp, standardid, kirjeldus, omadused ja selle lisadega.

Märge

Aruanne sisu onseadistatavläbi aruanne Options dialoogiaknas kirjeldatakse allpool, aga to saada rohkem informatsiooni selle kohta, kuidas luua täielikult seadistatav custom aruandedkasutades ABACUS Custom ReportsPalun vaadake teemat siin või kokkupuude Avolution Support .

Et vaadata standard aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri(s).

2. Valima Sisesta| Standard aruannevõi klõpsake Loo Standard aruanne tööriistariba nuppu. Aruanne Configurationaken kuvatakse.

Aruanne Configuration aknas

3. Valige Arhitektuurid, Komponendidja Sidemedmis sa tahad aruande Aruanne seadistustedialoog.Palun vaadake Standard Element Selection siin teema aidata.

4. Nüüd klõpsa Valikudnuppu ja Aruanne valikudaken kuvab.

Aruanne Options aken

5. Saate valida, kas kuvada Uus leht iga ElementOn Prindi kuupäev, Prindi aeg, Page Numbersja kas lisada pealkiri päisesAruande märgistades / unticking asjakohaste ruudud. Võite kohandada pealkiri ja autor redigeerides Raport Pealkirija Kirjanik teksti kasti. Võite ka valida, millist sisu kuvatakse aruande, märkides / unticking ruudud all Aruande sisumääratud akna osa. Kui olete lõpetanud, klõpsake Okei.

6. Nüüd klõpsa Finišaruandes Configuration aknas.

Tõlgendada vaadatav aruande

Näide Loodud aruanne koos lühikesed selgitused

Liikuda aruande lehekülgedel, kliki ikooni [image] asub tööriistariba peal vasakus nurgas ekraani.

Märge

Sa saad päästma Aruande erinevates formaatides klõpsates Eksport Aruandes ikooni [image] asub sisse tööriistaribal. Võite valida ekspordiks järgmistes formaatides: Excel, PDFja Sõna. Palun aruande salvestada soovitud asukoha hilisemaks kasutamiseks. Kui on tehtud muudatusi arhitektuuris hiljem, uus aruanne tuleb luua, et kajastada muudatusi.

Vaata ka

Analüüsides oma arhitektuuri


Custom Reports

Navigation: aruanne oma arhitektuuri>

Custom Reports

Saada kommentaare selle teema.

ABACUS "custom aruanded võimaldavad teil luua täielikult seadistatav kohandatud aruandeid. Aruanded võivad olla kohandatud kujundlikkus ja graafika, samuti üksikasjalikult tahes komponente, ühendused või atribuudid alates ABACUS hoidla samuti üksikasjalikku analüütilist tulemusi erinevate simulatsioonide (sh TCO ja töökindluse). Lisaks aruanded võivad sisaldada jooniseid, diagramme, kataloogid, maatriksid / pivot tabeleid, kaarte, gabariidid, minigraafika, andmete baarid ja näitajate (nt liiklus-tuled).

Märge

Kuigi iga kasutaja saab avada olemasolevaid kohandatud aruandeid, to configure aruanded kasutaja litsents vajab Aruanne Configuration võimekust. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

Et vaadata tava aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri(s).

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken kuvatakse.

Custom Reportsaken

3. Valigeolemasolev Aruannemis sa tahad kuvada alates Saadaval aruandedosa.

4. Vajuta Run aruanne.Aruanne avaneb Microsoft Report Viewer ja to Liikuda aruande lehekülgedel, kliki ikooni [image] asub tööriistariba peal vasakus nurgas ekraani.

Märge

Sa saad päästma Aruande erinevates formaatides klõpsates Eksport Aruandes ikooni [image] asub sisse tööriistaribal. Võite valida ekspordiks järgmistes formaatides: Excel, PDFja Sõna. Palun aruande salvestada soovitud asukoha hilisemaks kasutamiseks. Kui on tehtud muudatusi arhitektuuris hiljem, uus aruanne tuleb luua, et kajastada muudatusi.

Kuni muuta hoidla andmed, mis saadetakse a tava aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri(s).

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken (eespool näidatud) kuvatakse.

Märge

Kuigi iga kasutaja saab avada olemasolevaid kohandatud aruandeid, to configure andmed, mis saadetakse kohandatud aruande kasutaja litsents vajab Aruanne Configuration võimekust. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

3. Valigeolemasolev Aruannemis sa tahad kuvada alates Saadaval aruandedosa.

4. Vajuta Muuda andmeid Komplektid. Andmed Set Editoraken kuvatakse.See aken näitab andmete kogumise komplekti, mida praegu saadetakse kohandatud aruande. Allpool toodud näites on kolm (3);

· ApplicationProxy andmekogum mis täpsustab kõik üksikasjad kõigi taotlemine komponentide "2015 Tegelik arhitektuur (sealhulgas omadused nende Standardid ja kõikide lisatud komponendid),

· TwoDViewProxy andmekogum mis täpsustatakse üht või mitut skeemid, kus klapib "Application Landscape (Austraalia),

· TargetProxy andmekogum mis täpsustab kõik üksikasjad kõigi Target ühendused "2015 Tegelik arhitektuur (sealhulgas lisatud komponendid).

Andmed Set Editoraken

Märge

Päringu nimi kasutatakse andmestiku nime Microsoft Report Builder (vt allpool). Kaasa väli määrab, kas andmekogumi on kas ühe Element, kogumise Elements Kõik Component tüübid, Kõik ühenduse tüübid, ühe või mitme arhitektuur, ühe või mitme skeemid või ühe või mitme Charts. Sest "Collection of Elements" andmekogumid Filter nupp on mis, kui klõpsad avab Element Filter akna, mis võimaldab teil rakendada mitu filtrit naasta alles elemente teatud arhitektuurid ja / või teatud liiki ja / või teatud standardid ja / või lisatud teatud komponente, ja / või koos teatud Vanemad ja / või teatud skeemid, ja / või teatud skeemid ja / või etteantud väärtustele. Teiste andmete kogum tüübid Nimi väli on ja kasutavad Vali nupuga saab valida objekti (de) lisamiseks andmetega komplekti.

Märge

Andmekogumite hoitakseAndmekogud faili (.xml)Sama baasi failinime seotud Aruanne Definition faili (.rdl). Kui seda faili ei ole olemas andmekogumi redaktor automaatselt asustada päringu nimed, mis on olemas Aruanne Definition faili (.rdl)ja uus Andmekogud faili (.xml)luuakse kord aa kehtiv nimekiri päringuid on määratletud.

3. Kui soovite kustutada olemasoleva andmekogumi seejärel Kustuta Querynuppu.

4. Kui soovid lisada uusi andmeid seatud klõpsake Lisada uusi andmeid Setnuppu ja seadistada andmekogumi kohta märkuse eespool.

Kuni Uue kohandatud aruanne(mallist)

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken (eespool näidatud) kuvatakse.

3. Vajuta Uus ja valige kas A4 - Portrait, A4 Maastik, A3 - Portrait, A3 Maastik, US Letter - Portrait, US Letter - Landscape, USA Tabloid - Portraitvõi USA Tabloid - LandscapeSõltuvalt aruande orientatsiooni ja paberi formaat, mis on vajalik.

4. Sirvi asukohta salvestada aruanne Definition faili (.rdl / .rdlc) ja sobitamine andmed Määra faili (xml) ja klõpsake Salvesta. See lisab uue custom aruande Aruannete osa Custom Reports akna ja seda võib avada ja redigeerida, nagu eespool kirjeldatud.

Kuni lisada olemasolevat kohandatud aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken (eespool näidatud) kuvatakse.

3. Vajuta Lisama ja sirvi asukoha aruanne Definition faili (.rdl / .rdlc) ja klõpsake Avatud. See lisab uue custom aruande Aruannete osa Custom Reports akna ja seda võib avada ja redigeerida, nagu eespool kirjeldatud.

Märge

Võib oletada, et sobitamine andmed Määra faili (xml) esineb samas kohas aruande definitsiooni fail.

Kuni kopeerida olemasolevat kohandatud aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken (eespool näidatud) kuvatakse.

3. Valigeolemasolev Aruannemis sa tahad kopeerida alates Saadaval aruandedosa.

4. Vajuta Koopia ja koopia valitud aruanne (nimega "Copy of ...") on lisatud Aruannete osa Custom Reports akna ja seda võib avada ja redigeerida, nagu eespool kirjeldatud.

Märge

Sel moel loob koopia aruande Aruanne Definition fail (.rdl / .rdlc) samuti selle sobitamine andmed Määra faili (xml)(kui see on olemas).

Kuni eemaldada olemasolevat kohandatud aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken (eespool näidatud) kuvatakse.

3. Valigeolemasolev Aruannemis sa tahad eemaldada alates Saadaval aruandedja klõpsa Eemalda.

Märge

Kui eemaldate aruande ta ei ilmu enam aruande nimekirja. Kuid see ei kustuta Aruande raportidefinitsioonide fail (.rdl / .rdlc) või Andmed Set fail(xml). Kui vaja, kustutades neid faile on võimalik saavutada failisüsteemi.

Kuni muuta olemasoleva custom aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken (eespool näidatud) kuvatakse.

3. Valigeolemasolev Aruannemis sa tahad ümber in Saadaval aruandedja klõpsa Nimeta.

4. Sisestage uus nimi aruanne.

Märge

Nii aruanne Definition faili (.rdl / .rdlc) ja sobitamine andmed Määra faili (xml) nimetatakse ümber vastavalt.

Kuni muuta disain tava aruanne

1. Veenduge, et teil on ABACUS fail avatud sisaldab teie asustatud arhitektuuri.

2. Valima Sisesta| Custom Reportvõi klõpsake Loo Custom Report tööriistariba nuppu. Custom Reportsaken (eespool näidatud) kuvatakse.

Märge

Kuigi iga kasutaja saab avada olemasolevaid kohandatud aruandeid, to configure disain kohandatud aruanded kasutaja litsents vajab Aruanne Configuration võimekust. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.Lisaks Microsoft Report Builder 3.0 on vaja kujundada aruanded ja seda saab tasuta alla laadida siin .

3. Valigeolemasolev Aruannemis sa tahad kuvada alates Saadaval aruandedosa.

4. Vajuta Muuda Raport.Aruanne avaneb Microsoft Report Builder 3.0. Konkreetse abi ja mõned nõuandeid ja nippe "mõned levinumad ülesandeid projekteerimisel aruanded palun vaadake allpool. Üldiseks abi projekteerimisel aruanded palun vaadake Microsoft Report Builder 3.0 abilehekülgi siin .

Tabelite lisamine oma aruande

1. Veenduge, et teil on ABACUS Custom Report Definition faili (.rdl / .rdlc) avatud Microsoft Report Builder 3.0.

2. Valima Sisesta vahekaardil lint "ülaosas, siis kliki Tabel nuppData Regioonide osa ja valige Lisa tabel.

3. Nüüd lohistage kursorasendisse aruande lõuend, kuhu soovite ülemises vasakus nurgas laua panna. Vajuta lõuendile. Vaikimisi tabelis lisatakse pealöögiga reas ja siis üksikasjad rühm (rühm kasutatakse korraldada eesmärgiga aruande andmekogumi). Eemaldamiseks grupist, kas Rea kustutamiseks või kustutada Row fraktsiooni rühmitus tööriistariba.

Otss

Valemid / Expressions tabelis rakud toimetanud vali lahter siis paremklõpsake << Expr >> teksti ja valida Expression .... Sorteerimine rida tabelis on teinud, valides laua ja siis vaatab allapoole Muud -> SortExpressions valdkonnas Properties paneelil ja sisestamise väljendus. Kokku reas lõpus tabeli lisada rida pärast (ja väljaspool) rühmituse ja siis kasuta järgmise valemi = Sum (Fields!Nimi.Value)kus "nimi" on põld kokku. Kandideerimiseks värvimine postide kasutada "Ilf" avalduse BackgroundColor vara. Lisada mõõtur raku tabelis esimene sisestada mõõtur rakku ja siis tilk andmeväljad vajalik hinnata. Kui muudate kõrgus ja laiusega tabeli read, et teil valida õige rida ja siis viid hiirekursori ümber halli read kuni saad Nool üles / alla kursor, siis suurust.

Lisades Charts oma aruande

1. Veenduge, et teil on ABACUS Custom Report Definition faili (.rdl / .rdlc) avatud Microsoft Report Builder 3.0.

2. Valima Sisesta vahekaardil lint "ülaosas, siis kliki Chart nuppData Regioonide osa ja valige Sisesta Chart.

3. Nüüd lohistage kursorasendisse aruande lõuend, kuhu soovite ülemises vasakus nurgas diagrammi paigutada. Vajuta lõuendile ja siis valida diagrammivajate valikute ja klõpsa Okei.

Otss

Et näidata vara annotatsioon kaartidel, paremklõps diagrammi ja valida Show Andmed etiketid, seejärel valige üks sildid, mis on lisatud ja määrata Misc -> UseValueAsLabel False Properties paneelil ja lisada väljend (nt = Fields! Name.Value) in Misc -> Label. Spetsiaalselt mull kaardid; Bubble graafikud kuvatakse all punktdiagramm rubriiki. Drop X telje kinnisasja Series väljad (või lisada Series omadused). Drop Y teljel kinnisasja andmeväljad (või lisada Series omadused). Et kasutada vara määratleda mulli suurus, tilk seda arvesse andmeväljad (või lisada Series omadused). Bubble graafikuid ei suuda näidata, kui on liiga palju andmeid (200 + esemed), mõnikord see põhjustab kogu aruande ei näidata. Marker tüüp - valige ringi. Vaikimisi on kukutades väljad andmeväljad, see lisab neile summa ()valemis nii eemalda see. Spetsiaalselt Laotud kaardid / Timeline / Gantti diagrammid; Sest Gantti diagramm kasutada erinevaid skeem ja lisada omadused nagu kõrge ja madal väärtused andmeväljad. Sul võib olla mitu "baari", lisades üha rohkem valikuid, kus Väikese väärtusega üks sobib kõrge hinna teise. Spetsiaalselt Pie diagramme; Agregaatide pie diagramme, tilk andmed Kategooria valdkondades ja andmeväljad, lisage valem = CountRows (). Filter ühtegi 0 väärtusi (nt kulude graafikud), muidu siltide need ilmuvad siiski diagrammi.

Kasutades Kkui avalduse värvuse tabelid ja diagrammid

1. Veenduge, et teil on ABACUS Custom Report Definition faili (.rdl / .rdlc) avatud Microsoft Report Builder 3.0.

2. Paremklõpsake lahter tabelis värvi ja klõpsa Text Box omadused.

3. Valima Täitma ja klõpsa fxnuppu paremal täitevärve märgistusel ja Set avaldis BackgroundColor valdkonnas sisestage väljendus, nt = IIF (Fields! InformationStatus.Value = "Valida", "heleroheline", IIF (Fields! InformationStatus.Value = "Plaani", "Kollane", IIF (Fields! InformationStatus.Value = "Värskenda", "Orange", " Salmon "))). See muudab taustavärvi heleroheline iga rakk, mis sisaldab staatus "jääb", kollane iga rakk, mis sisaldab staatus "Plaani", Orange iga rakk, mis sisaldab staatus "Värskenda" ja muust seisundist väärtus on värvitud in "Lõhe".

Märge

Värvid saab lisada diagramme valides seeria diagrammi ja seejärel seades Välimus -> Color vara (või mull kaardistab Välimus -> Kivi -> Color vara) väljendusele sarnaselt ülaltoodud näites.

Asjad meeles pidada, kui projekteerimisel kohandatud aruandeid

· Kuna kõik omadused, välja arvatud Integer saadetakse stringi arvelaud aruande vaataja kui sa tahad teha mis tahes "väljendeid" nendega (nagu lõhe üks vara teise või omamoodi) teil on vaja teisendada need koma või kuupäev jne taust , see artikkel on hea viide. Näiteks = CDate (Fields! LifecycleEndDate.Value) Märge: Palun veenduge, et aruanne keeleks on en-GB (kirjeldatud allpool) vastu dd / mm / yyyy, sest see eeldab pp / kk / aaaa vormi vaikimisi ja seega 31/7/2011 ei suuda vahetamisega. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Kui leiate, et olete hädas hoida kõik tabelid ja diagrammid ühel lehel, Seal on mõned peamised juhtimise viisid oma dokumendi ruumi:

· Page Break - Tagada, et see tabel, milles on välja Iga laua soovid olla samal lehel.

· Hoia Koos - Tagada see tabel, milles on True Iga laua soovid olla samal lehel.

· Liikudes asju ümber, siis on lihtsam välja suumida abil kontrolli all paremas nurgas lehel ja seejärel mitme elemendi valimiseks ja drag

· Sest pilt tabeli rida, siis veenduge, et "suurus" | "Suurus" Kinnisvara on seatud "Fit" muidu võib pilt liiga suur, või siis on see halvasti venitatud.

· Kuni korrata päises tabelis igal leheküljelAruande:

1. Avatud Täpsem Mode rühmitused pane. (Klõpsake noolt veeru Groups ja valige Advanced Mode).

2. Reas Grupid ala (mitte veerg Groups), klõpsa Static rühm, mis toob esile vastava tekstikasti on tablix. Vajuta läbi iga Static rühm, kuni see toob esile vasakpoolsema veeru päisel. See on tavaliselt esimene Static grupp loetletud.

3. Properties akna määrata RepeatOnNewPage vara True.

4. Veenduge, et KeepWithGroup omadus on märgitud Pärast.

· Muuda keele seadedAruandes omadused sobitada andmevormingutest vajate, nt en-GB toota UK kuupäeva formaadis (pp / kk / aaaa).

Vaata ka

Analüüsides oma arhitektuuri


Avalda Web

Navigation: aruanne oma arhitektuuri>

Avalda Web

Saada kommentaare selle teema.

ABACUS "Publish to Web funktsioon võimaldab arhitektuuriliste mudeleid vaadata turvalise veebilehel. Arhitektuurid eksporditakse HTML formaati ja on mõeldud kajastama välimuse Exploreri ABACUS. Views (sealhulgas kataloogid, skeemid, 3D ja Charts) Samuti eksporditakse formaate vaadatav kasutades interneti brauseri.

Märge

Praegu Seisukohti ja Matriitsid ei avaldata.

Avaldada oma arhitektuurilise mudelid veebis

1. Veenduge, et on asjakohane ABACUS failiavatud, mis sisaldab asustatud arhitektuuriet soovite avaldada veebis.

2. Valima Faili| Avalda ....

3. Avalda Web Configurationaken kuvab.

Avalda Web Configuration

4. Vaikimisi kõiki osi mudel on valitud sealhulgas Tree View on StandardidLiigid, mallid ja Arhitektuur (s). Puhasta portsjonit te ei soovi avaldada veebis, sealhulgas üksikisiku arvamusi arhitektuur (s).

Ots

Kui soovite peita erikomponentide, ühendused ja / või nende omadused on soovitatav, et administraator loob "Avalik" rolli kasutades ABACUS "rolli põhineva juurdepääsu funktsioon ja siis kaob lugemisõigus nendest osa liike, ühenduse tüübid ja / või omadused, et nad ei soovi avaldada. Siis peaks kasutaja sisse kõnealuse rolli ja avaldada veebis ABACUS ainult avaldada elemente, mis on loetav seatud rolli. Lisaks saavad kasutajad auto avaldada käsurealt kirjeldatud siin .

Märge

Sa võid valida kõik portsjonid kuvatakse klikates Kõiknuppu või pöörake oma valik klikates Teistpidinuppu. Võite klõpsata ka Mitte ükskinuppu, et kustutada oma valikut.

Märge

Kui sa lülita Tree View võimalussiis ei ole puu raam (vt allpool) avaldatakse. Seega tuleb valida avaleheks vastavalt etapile 6 alla või pärast avaldades peate kohandada kas tipptasemel; a) index.htmlfaili muutes "raami src =" mainPage.html "name =" element_details "" line ühendab otse asjaomasele html lehele all Sisu kausta, või, b) mainPage.htmlandes hüperlingi või suunata vastavale html lehele all Sisu kausta.

5. Klõpsake Valik nuppu ja järgmised Kirjastaja valikuddialoog, mis näitab.

Avaldaer valikud

6. Svalib 3D, Skeemja Charts formaadis ja kas näidata Pealkiri, kirjeldus või omadused vaadete välja võimalikud valikud (vt märkus allpool kommentaarid erinevates formaatides).

7. Kui soovite määrata avaleheks avaldatud mudel konkreetse eesmärgiga siis kontrollige Kasutage Kuva Start Pagevalik ja sirvi seisukohal kaudu "..." nuppu, et muutub lubatud.

Märge

Ainult seisukohti valitud valdkonnad osa kohta eespool etapist 4 on saadaval seada ka avaleht.

8. Kui soovite saada tagasisidet teatud lehekülgede avaldatud mudel siis veenduge, Email tagasisidevalik on, sisestage e-posti aadress E-posti aadresstekstikastija muuta Email Bodyosa vastavalt vajadusele. Kui te ei soovi on saadetud tagasiside eemalda märge Email tagasisideja jätta tekstikasti tühi.

9. Vajuta Okeinuppu.

10. Vajuta Sirvinuppu.

11. Kausta otsimineaken kuvab.

12. Valige kaust, kuhu soovite salvestada tipptasemel HTML fail (ja automaatselt genereeritud failid).

Märge

See on hea mõte luua eraldi kausta (tavaliselt "Avaldatud"), kasutades Tee uus kaustallosas dialoogi salvestada tipptasemel HTML fail ja kõik automaatselt genereeritud faile.

13. Vajuta Okeinuppu.

14. Kaustatee ilmuvad Kataloogtekstikasti.

15. Vajuta Finišnuppu.

- Või -

15. Sisestage kausta tee ka Kataloogtekstikasti, kuhu soovite salvestada tipptasemel HTML fail (ja automaatselt genereeritud failid).

16. Vajuta Finišnuppu.

Märge

Eksportivate Skeemideväga harva ei õnnestu, enamasti siis, kui arvuti on välja mälu (tavaliselt siis, kui kasutatakse väga suuri faile). Ebaõnnestunud ekspordi proovitakse uuesti kord. Seal on üks hoiatus läbikukkunud katse ja teise hoiatuse, kui uuesti katse ebaõnnestub. Seega, kui ainult hoiatused "Esimene katse ebaõnnestus", kinnitab avaldada oli edukas. Kui uuesti ebaõnnestub proovida avaldades väiksema osa oma faili või tasuta kuni muutmälu.

Salvestatud HTML fail (id) saab nüüd silmas tema asukoht või kopeerida turvaline veebileht.

Avalda Web Internet Explorer10

Kõik hüperlinke mis loodi esialgne mudel on kestnud avaldatud mudel ja lingi jälgib link oma sihtkohta (kui see ilmus). Lisaks sellele tuleb iga elementi avaldatud diagrammid, mis ei ole juba lingitud esialgne mudel tahte lingitud tagasi nende vastavate elementide puuvaates (kui see ilmus) ja klõpsates element avaldatud skeemi keskmes hüpata tagasi asjakohaste asukoht Tree. See funktsioon on sarnane "Näita Explorer" paremklõpsu funktsiooni ABACUS.

Märge

Avolution soovitab järgmist tarkvara ja failivormingud tuleks kasutada täielikult ära Avalda Web funktsionaalsuse ABACUS:

1. Internet Explorer (80,0 ja üle selle)vaatamiseks avaldatud explorer arvates. Mozilla Firefox (3.0 Või hiljem)Samuti on soovitatav ja täielikult toetatudAga kui kasutatakse soovitatud SVG formaadis jooniseid siis Firefox 9 saab kasutada ainult emakeelena SVG toetus, mis kahjuks ei võimalda suum või panoraamimistoimingute.

2. Adobe SVG Viewer 3.0 sisse panema (allalaadimiseks siin ) ja SVGfailiformaat avaldatud diagrammid. SVG-vormingus pilt eest diagrammidon soovitatav, sest; SVG on vektor põhinev pildi formaat ja seetõttu on kadu-vähem "ja tundub palju parem igal zoom tasemel kui mõne formaate, SVG võib importida MS Visio, SVG võib suurendada mis tahes tasandil või resolutsiooni SVG on lingid puuvaates eest ühendused (mitte ainult komponendid), SVG alati prindib parema resolutsiooniga ning SVG on umbes pool faili suurus teisi formaate. PNG on järgmine soovitus, aga kui see on rasterised formaadis teatud suumitasemega selgus vaade kaob ja klõpsates ühendused diagrammid ei hüpata vastavatele asukoht puu. BMP on julge nagu samas on see "kaotus-vähem formaadis faili suurus on 100x suurem kui teistes vormingutes ja 20Mb pilte ei ole ebatavaline.

Kompromiss on SVG on, et SVG tuleb paigaldada ja sa pead veenduge, et svg image / svg + xml lisatakse veebiserveri MIME tüübid. Pärast paigaldamist SVG Microsoft Internet Explorer küsib nõus vaataja litsentsilepingu ja siis peaks tegema trahvi. Ja kuigiMozilla Firefox toetab SVG-faile algupäraselt, Adobe plugin on siiski soovitatavet oleks võimalik suurendada diagrammid, kui te kasutate Firefox 8 või varem (kui te kasutate Firefox 9 te ei saa keelata native SVG). Kui installeerimine Adobe plugin on sõidetud, järgmisi samme on vaja kasutada seda Firefox:

· Ava firefox ja sisestage "about: config" (ilma jutumärkideta) arvesse aadressiribale.

· Kerige ja leida vara svg.enabled(kui te kasutate Firefox 9 siis native SVG vaatamise saa olla puudega ja seda vara ei ole olemas). Topeltklõps seda keelata.

· Nüüd uuri kataloog, kus SVG plugin paigaldatud (nt C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 3.0 \)

· Kopeeri failid NPSVG3Dll ja NPSVG3Zip ja kleepige firefox plugins kataloogi (nt C: \ Program Files \ Mozilla Firefox \ plugins)

· Sulgege kõik juhtumid firefox

3. Avolution on ABACUS 3D Viewer (3.1 ja rohkem)ja Avolution on .abacus3Dfailiformaat avaldatud 3D vaated. Kuigi Cortona VRML Client plug-in (2.0 ja rohkem)on saadaval vaatamiseks VRML versioonid avaldatud seisukohti see ei ole tasuta kasutamiseks ärilisel eesmärgil ja nõuab veel kliendipoolse paigaldus. Arvelaud 3D Viewer on rikkalikumaid kui ükski VRML vaataja ja on vabalt allalaadimiseks saadaval siin . Mõlemal juhul veenduge lisada .vrml x-maailm / x-VRML ja .abacus3d application / oktett-stream veebiserverisse MIME tüübid.

4. PNGfailiformaat avaldatud Chart seisukohti. PNG-vormingus pilt diagrammi vaated on soovitatav, sest kuigi see on rasterised vormi ja seal on "kahjum" kompromiss vahel faili suurus ja diagramm selgus on tavaliselt parim. BMP on julge nagu samas on see "kaotus-vähem formaadis faili suurus on 20x suurem kui teistes vormingutes ja 2MB graafikuid ei ole ebatavaline.

Kui soovite muuta ilme ja veebilehti, saate muuta avalehel faili nimega mainPage.html ja laadilehte faili nimega abacus.css. Leiad need failid samasse kausta, kus sa otsustasid päästa tipptasemel HTML faili. Lisateavet struktuuri ja õmblemine avaldatud väljund näha järgmises osas.

Struktuur ABACUS avaldatud mudelid

Arvelaud avaldatud mudel on üles ehitatud järgmiselt:

1. Tipptasemel kaust sisaldab palju faile ja eeldusel, et kõik võimalused on kantud ABACUS Avalda Web seadistustedialoogi see sisaldab indeks.htmlfile koosneb kolmest raamid; treeView.html, findNode.html ja mainPage.html ja siis shortcutError.htmllehekülg. TreeView.html on asustatud tree.js, tree_items.jsja tree_tpl.js javascript failid asuvad all hulka kaust (allpool) ja dubleerivate Explorer puud ABACUS. FindNode.html on powered by find.js javascript faili all asuvad hulka kaust (allpool) ja see ei otsi okstele, mitte ainult nähtav sõlmed. TTa mainPage.html on staatiline HTML lehele, mida saab kohandada koos ettevõtte logode jmsja näidatakse, kui start lehel on valitud avaldamisel.Ja lõpuks, shortcutError.html lehel on kodulehe purunenud otseteed puu tõttu sobivad lehekülge ei avaldata.

Ots

Sa ei jäta mainPage.html kokku poolt Valides kasutada avaleheks avaldamisel või muutmise index.html fail juhtida otse antud seisukohta (ütleme) muutes raami src = "mainPage.html" line juhtida otse esimest silmas esimeses arhitektuur, tavaliselt "raames" skeem.

2. Tipptasemel includekausta sisaldavadseerinevate javascript (Js) ja CSS-stiil (CSS), mida kasutab .html faile kogu avaldatud mudel.

3. Tipptasemel Sisu kaustas, Tähestikuliselt;

· A '3D Views' kaustakohmetuHTML lehele ja VRML või abacus3d faili iga avaldatud 3D vaade. Vaata allpool märkust teavet faili numereerimissüsteem.

· Arhitektuurid kausta nummerdatud HTML lehele iga arhitektuur, mis avaldati. Vaata allpool märkust teavet faili numereerimissüsteem.

· A Kataloogid kaust nummerdatud HTML lehele iga avaldas katalooge. Vaata allpool märkust teavet faili numereerimissüsteem.

· A Äritegevus kaustakohmetuHTML lehele ja PNG, JPG jne faili iga avaldatud Chart vaated. Vaata allpool märkust teavet faili numereerimissüsteem.

· A Komponendid kaustkohmetuHTML leht iga avaldatud komponendid. Vaata allpool märkust teavet faili numereerimissüsteem.

· A Sidemed kaustkohmetuHTML leht iga avaldatud ühendused. Vaata allpool märkust teavet faili numereerimissüsteem.

· A Skeemide kaustkohmetuHTML lehele ja PNG, SVG jne faili iga avaldatud diagrammid. Vaata allpool märkust teavet faili numereerimissüsteem.

· ikoonid sub-kausta koos erinevate pilte kasutada kogu avaldatud mudel.

· A Standardid sub-kaustakohmetuHTML lehele tahes standardidmis avaldati. Vaata allpool märkust teavet faili numereerimissüsteem.

· A Templates sub-folder mille kogumiseks nummerdatud alamkaustadesse iga malli avaldatud projekti. Igas alamkatalooge on Komponendid ja ühendused kausta ja neis on nummerdatud HTML lehele on iga osa ja ühendada malli. Vaata allpool märkust teavet kausta / faili numereerimissüsteem.

· A Tüübid alamkatalooge komponentvideo jaConnection alamkaustadesse kooskohmetuHTML leht mõne komponendi jaConnection liigid, mis avaldatija kogumise nummerdatud alamkaustadesse iga avaldas projekti, mis sisaldab HTML lehele iga piiranguid. Vaata allpool märkust teavet kausta / faili numereerimissüsteem.

· A Vaadepunkts alamkatalooge jakohmetuHTML leht ühegi Viewpunkts, mis avaldati. Vaata allpool märkust teavet faili numereerimissüsteem.

Märge

Numeratsioon HTML lehekülgede (ja mõningatel juhtudel pildifaile) vastab unikaalne ID iga hoidla objekt, mis oli määrata, kui see oli loodudjooksul ABACUS (edaspidi EEIDs). See ID ei muutu nii kui diagrammid, tüüpi, komponendid etc on ajakohastatud nad tahesäilitada sama ID nagu enne. Igal juhul on asjakohane hoidla objektinimi võib leida lähedal algust HTML lehe vahel ... HTML teeke.

Juurdepääsu piiramiseks teatud lehekülgedel / Views IIS

Kui kasutate IIS oma veebiserveri avaldatud mudel, siis võib olla võimalik piirata juurdepääsu teatavatele lehekülgedele / vaatamist meetodit kasutades allpool:

1. Loo kodulehel IIS (teine ​​kui on olemasoleva sa ei taha segada).

2. Muuda Properties-> Kataloog Julgeoleku> Anonüümsed ühendus - Puhasta, anonüümne juurdepääs ja kasutamine autenditud juurdepääs.

3. Kui see on lihtsalt tavaline server ilma domeeni tüsistusi jne, siis peaks kasutama integreeritud Windowsi autentimist "variant, mida siis kasutada serveri masinaid kohalike kasutajate / sisselogimise sest autentimise ja lihtsalt lisada kasutajaid kohaliku arvuti (olles ettevaatlik et olete teadlik tagajärgedest, turvalisuse tark, lisades uusi kasutajaid masin, nt sõltuvalt sellest, kas kaugjuurdepääsu on setup masin, jne).

4. Lisa õigused konkreetseid faile / kaustu vaja. Parem klõps üksikuid faile / kaustu -> Properties ja reguleerida kaitse load nagu tavaliselt failide / kaustade.

See võib erineda sõltuvalt sellest, milline versioon IIS ja milliseid konkreetseid Windows OS on serveris, ja kas teil on domeeni või muid erinevaid setup.

Vaata ka

Asustamine oma arhitektuuri | Analüüsides oma arhitektuuri


Eksport teie Arhitektuur

Navigation: aruanne oma arhitektuuri>

Eksport teie Arhitektuur

Saada kommentaare selle teema.

ABACUS võimaldab kunieksportida oma arhitektuuri MDB (Microsoft Access), MS SQL Server, .abacus (ABACUS fail), ja .xls (Microsoft Excel) formaadis. Võimalik on ka eksportida oma skeems PNG, JPG, SVG (skaalautuvia vektorgraafika), TIFF, GIF ja BMP formaadis ja oma aruandeid .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), Doc (Microsoft Word) ja .rtf (Rich Text Format) formaadis. See võimaldab teil analüüsida ja vaadata arhitektuuri ja selle andmed kuidagi soovite.

Ekspordi arhitektuuri MDB (Microsoft Access)

1. Veenduge, et teil on ABACUS failiavatud.

2. Vajuta Failimenüü.

3. Valima Eksport, ja siis Et MDB.

4. Võtke teadmiseks hoiatus ja klõpsa Okei.

5. Sisestage faili nimi.

6. Klõpsake SalvestaButton.

Märge

Ekspordi vormi MDB andmebaasi konkreetse arvelaud ja mis tahes skeemi muudatused toovad kaasa võimetus uuesti import. Palun vaata Asustamine MS Access kirjeldust MS Access skeem.

Ekspordi arhitektuuri MS SQL Server

1. Veenduge, et teil on ABACUS failiavatud.

2. Vajuta Failimenüü.

3. Valima Eksport, ja siis MS SQL Server.

4. Dialoogis ilmub klõpsa Ekspordi Blank MDB ...nuppu ja importida seda oma MS SQL Server andmebaasi server.

5. Täida andmebaasis info ja seoses string.

6. Klõpsake EksportButton.

Märge

Ekspordi vormi MS SQL ServerAndmebaas on konkreetse arvelaud ja mis tahes skeemi muudatused toovad kaasa võimetus uuesti import. Palun vaata Asustamine MS Access võtta vastu kirjeldus andmebaasi skeemi.

Ekspordi arhitektuuri .xls (Exceli fail)

1. Veenduge, et teil on ABACUS fail avatud , Mis on explorer kuvatakse , Ja Arhitektuur lisatud .

2. Veenduge, et teil on Excel Import / Export Seadistusfaili määratletud.

3. Paremklõpskohta arhitektuuri oma mudel või osa Komponendidsõlm (etteantud arhitektuur), mida soovite eksportida Exceli Seadistusfaili.

4. Valima Eksport | Kuni Excel ... menüüst.

5. Vali Excel Import / Export konfiguratsioonifaili kasutageaken kuvatakse.

6. Valige asjakohane konfiguratsioonifaili oma arhitektuurilise mudel ja klõpsa Avatudnuppu.

7. Kui ei ole automaatselt teinud, kaart tipptasemel komponendid on oma praeguse arhitektuuri Määra Id(eelnevalt defineeritud) ja vajuta Ekspordi ....

Näide Top-Level Component kaardistamine

8. Vali asukoht ja failinimi oma Exceli fail ja vajuta Salvestanuppu.

Ekspordi arhitektuuri .abacus (ABACUS fail)

1. Veenduge, et teil on ABACUS failiavatud.

2. Paremklõpsarhitektuur sõlme, mis tahes arhitektuuri oma mudel või osa Components puu.

3. Valima Ekspordi | Kuni Fail ...menüüst.

4. Vali asukoht ja failinimi ja vajutage Salvestanuppu.

Märge

Võite importida ABACUS faili tagasi ABACUS poolt järgmised sammud 1-2eespool ja valides seejärel Import | Pärit Fail .... Kui olete valinud faili, mida soovite importida, siis tuleb küsida, kuidas soovite importida standardid ja liigid. Saate importida standardite ja tüüpide kas uusi või ühendatakse standardid ja liigid. Vaikimisi on standardite ja tüüpide tuleb ühendada olemasolevad standardid ja tüüpidesse, kui need on juba olemas oma projekt.

Ekspordi arhitektuuri xml

1. Veenduge, et teil on ABACUS failiavatud.

2. Paremklõpskohta Arhitektuur sõlme, mis tahes arhitektuuri oma mudel või osa Component puu.

3. Valima Ekspordi | Kuni XML ...menüüst. Võite klõpsata menüü Faili| Eksport| Kuni XML ...

4. Vali asukoht ja failinimi ja vajutage Salvestanuppu.

Märge

Saate importida XML-faili tagasi ABACUS poolt järgmised sammud 1-2eespool ja valides seejärel Import | Pärit XML .... Kui olete valinud XML-faili, mida soovite importida, siis tuleb küsida, kuidas soovite importida standardid ja liigid. Saate importida standardite ja tüüpide kas uusi või ühendatakse standardid ja liigid. Vaikimisi on standardite ja tüüpide tuleb ühendada olemasolevad standardid ja tüüpidesse, kui need on juba olemas oma projekt.

Ekspordi skeem PNG, JPG, SVG, TIFF, GIF või BMP

1. Veenduge, et teil on ABACUS failiavatud.

2. Avage skeemsoovid eksportida.

3. Vajuta Ekspordi Diagramnuppu Skeem tööriistariba.

4. Ekspordi skeemaken.

5. Valige Sirvinuppu, et salvestada visualiseerimise soovitud asukohta.

6. Valige Save as typerippmenüüst valida failitüübi.

7. Klõpsake Salvestanuppu.

Ekspordi aruande .pdf (Adobe Acrobat), .xls (Microsoft Excel)võidoc (Microsoft Word)

1. Veenduge, et teil on ABACUS failiavatud.

2. Loo aruanne soovid eksportida.

3. Vajuta Eksportnuppu aruanded tööriistariba.

4. Valima Excel, PDF või Wordalates rippmenüüst.

5. Oota hetk, kui aruande eksport.

6. Vali asukoht ja failinimi ja vajutage Salvestanuppu.


Töö Enterprise Server

Navigation: Administration>

Töö Enterprise Server

Saada kommentaare selle teema.

ABACUS Enterprise Server on nii "mitte-lukustamist" koostööl põhinev lähenemine, kuid "lahti" üks ka. ABACUS on "non-kesklukustus", sest see ei sundida faili lukustada üks kasutaja, et seda ajakohastatakse. Igal kasutajal on oma kohalik koopiaks, ja kui nad teevad sellesse muudatusi ja salvestada oma faili, need muutused registreeritakse ja neid säilitatakse, kui kasutaja soovib kohustada neid serverisse.

ABACUS on "lahti" selles mõttes, et sa ei pea olema ühendatud server või vajad juurdepääs võrgule töötamise ajal faili. ABACUS vajab ainult juurdepääs serverile, kui operatsioone nagu luua fail, või mis täidab kassa koos operatsioone olemasoleva faili - uuendus, panevad toime või logi vaatamise minevikus toime. Juurdepääs server ei pea töötama fail ja muudatused ei ole saadetakse serverisse kohe (see võimaldab hõlpsasti muudatustest loobuda, kui teete vea). Kui faili salvestada, siis on "lihtsalt" salvestamiseks koopia kohapeal - see on alles sa endale, et oma kohaliku muudatused (muudatused tehtud pärast viimast toime), saadetakse serverisse.

Uue Enterprise Fail

Uue Enterprise faili, vali Faili| New ...ja seejärel valige üks kahest esimesest võimalusest all Enterprise Mudel osa Dialoogi Uue projekti (st kas tühja Enterprise faili, või luua olemasolevast ABACUS fail). Kolmas võimalus on "Minu tellimused" Enterprise faili keegi teine ​​on juba loodud, see kaetakse järgmises osas.

Kui soovite luua uue Enterprise faili, siis antakse dialoogi, mis võimaldab teil sirvida kus hoidlas server soovid salvestada faili. Samuti on olemasoleva faili tee ja nimi kantakse kuni ülemise kui valisite "olemasolevate Mudel" alates dialoogi Uue projekti ja tarnitud faili.

URL: See on URL hoidla server kus ABACUS Enterprise failid on salvestatud. Sa peaksid küsima isik, kes haldab server, mida see URL peaks olema.

Järgneval pildil hoidla koos nelja (4) olemasolevate ABACUS Enterprise projektid, pärast sisenemist URL ja vajutage Enter.Sa näete, kui olete uue Enterprise faili, järgmisel screenshot "Minu tellimused", seal on veel üks kaust ja fail alla selle hoidla.

Märge

Kui te kasutate https (SSL) server ja server ei ole kehtivat SSL sertifikaat (ühise sisevõrgu või mitteavalik serverid tõttu Maksumus SSL sertifikaats) Tekib lisatööd teha. Sul on vaja püsivalt vastu kõik ühendused, et server dialoogis hüppab (see näitab ka natuke rohkem infot server). Selleks, tüüp "p" (ilma jutumärkideta) ja vajuta Enter. ABACUS ilmub sõnum teile meelde seda enne näitab dialoogi.

Märge

Teil võidakse paluda login server mille puhul isik, kes on haldamise servervõib pakkuda serveri kasutajanime ja parooliga. Samuti sisselogimismandaadi tahes serverites, et olete ühendatud salvestatakse nii et kui mingil põhjusel tuleb need kustutatakse seda saab teha läbi Tööriistad | Valikudja siis Üldine tab klikates Taasta Subversionist Salvestatud Logi sisseja valides serveri rippmenüüst ja klõpsates Clear Logi sisseja valides OK ilmuvasse dialoogi.

Märge

Erinevalt pildil näidatud eespool, tavaliselt ühe ABACUS Projekti on kaasatud iga ABACUS hoidlast, sest rohkem kui 1 ABACUS Project on loodud ühe ABACUS hoidlast, ABACUS muutus log numbrid on jagatud kõigi ABACUS Projektid ja see võib segadusse kasutajad.

Eelistatud Faili: See mõjutab nii kausta ja faili nimi, mida kasutatakse (kui ei ole juba tehtud), kui luua faili hoidlasse server. Pange tähele, et uus kaust luuakse automaatselt hoidla server iga faili (jõudluse huvides Abacus Enterprise failid on loodud oma kausta asukoha sirvida, et dialoogis).

Hoidke töötava geeni kataloogide: Kui ettevõte fail on loodud hoidlas server, kohalik töö failid tuleb luua oma arvutis, nii et saate töötada faili ilma võrku ühendatud. See on koht, et te sirvida, kui soovite avada / taasavada ABACUS Enterprise faili.

Kassasse olemasoleva ettevõtte Fail

Kui keegi on juba loonud uue Enterprise faili, saate "kassasse" seda pilti, mis laeb kohaliku koopia ja nähakse ette vajalikud failid nii ABACUS tunnistab seda kui Enterprise faili. Dialoog on sarnane New Enterprise Failidialoog. Kirjuta hoidla URL (alamkatalooge saab lisada URL), valige soovitud fail ja vajuta OK. Vastavalt märkus allpool tta esitada siis avatakse.

Märge

Teil võidakse paluda login server mille puhul isik, kes on haldamise servervõib pakkuda serveri kasutajanime ja parooliga. Samuti sisselogimismandaadi tahes serverites, et olete ühendatud salvestatakse nii et kui mingil põhjusel tuleb need kustutatakse seda saab teha läbi Tööriistad | Valikudja siis Üldine tab klikates Taasta Subversionist Salvestatud Logi sisseja valides serveri rippmenüüst ja klõpsates Clear Logi sisseja valides OK ilmuvasse dialoogi.

Enterprise Faili erinevused

Kui olete loonud Enterprise faili (kas uus või läbi "kassasse" faili loodud kellegi teise poolt), kausta luuakse fail, ja see sisaldab tavaliselt need 3 peamist tüüpi faile:

· ".abacus" Faili- See on ABACUS fail ise. Muutused, mida teete kohapeal ei ole kohe salvestada faili, see on ainult kirjutatud, kui sa endale. See fail on "normaalne" ABACUS faili, see võib anda mitte-EE kasutajadkui eraldiseisva projekti (ilma .log fail)Või kasutatakse lähtepunktina uuele EE faili.

· ".changes" Faili- Kohaliku (sidumata) tehtud muudatused faili. Kui see fail on puudu, see tähendab, et puuduvad kohalikud muutused.

· ".log" Faili- Selle faili on ainult muudatused, mis tegid viimase kasutaja (sisu kasutaja .changes faili, kui nad on toime).

Märge

On mitmeid muid faile, mis võivad tekkida uuendamise ajal ja pühenduda protsesse, nimelt; ‘.changesbefore"Faili- See fail on koopia .changes faili pärast värskendamist ja kasutatakse automaatselt sobitada mis tahes ID konflikte update ja kõik kohalikud (sidumata) muudatused enne toime; ‘.backup"Faili- See fail on koopia .changes faili enne kasutaja säästab rohkem kohalikke (sidumata) muudatused .changes faili; ja ‘.error"Faili- See fail on koopia .changes esitada, kui seal oli küsimus, mis põhjustas arvelaud suuda avada .abacus faili ja kasutaja valis pöörduda oma muudatused.Need failid võivad ignoreerida.

Faili avamine

Faili avamiseks, pead vaid sirvida, kus valisid salvestada tööversiooni ja avada ABACUS fail, mis salvestatakse seal. Kui ABACUS näeb, et on olemas .logifaile (ja võib-olla .muudatusi esitada kui olete teinud muudatusi), see ravib fail Enterprise faili.

Uuendamine faili

Performingn "Uuenda" kontrollib, kas uuem versioon fail asub serveris. Kui on, siis sulgege oma praeguse faili uuendada uuema faili serverist ja alla laadida mõned ajutised failid, et on mitmeid jätkuna - nt "Demo.125". Need failid on vanemad versioonid .log faili, ja mida kasutatakse, et teha kindlaks, milliseid muudatusi on tehtud faili pärast sinu viimast värskendamist ta. See on vajalik, et avastada võimalikud konfliktid, mis võib olla tekkinud nii et saate neid lahendada.

Kui Uuendamise protsessi ajal mis tahes konfliktidleitiPeate neid lahendada enne saate avada oma faili uuesti (võite tühistada kuid siis küsitakse lahendada konflikte uuestiJärgmine kord, kui avate oma faili).

Faili salvestamise

Kui salvestate faili, see lisab tahes muudatused tehtud .changes faili. See ei olemuuta .abacus fail selles etapis - ainult siis, kui fail on pühendunud server seda üle kirjutada (või kui te saate update server).

Kus on "Save As"?

Ei ole mõiste Save As for Enterprise faile. Võite aga kopeerida töökoopia .abacus faili, pidades silmas, et see harjumus on kohaliku muudatusi.

Konfliktide lahendamine

Kui teised kasutajad on pühendunud faili muutmist sarnaselt osa toimikust, et teil võib esineda mõningaid konflikte nende muudatused ja sinu. Näiteks teise kasutaja võib kustutada osa, et teil oli uuendada vara. Sa pead kas undo oma muutus (kui olete kindel, et nemad peaksidei on juhtunud), või unustada oma muutus (te siis tagasi minna fail ja tehke muutus).

Täpsemalt on 4 liiki konflikte, mis võivad tekkida;

1. Kustutama - Kui üks kasutaja kustutab objekti, mis teisele kasutajale muutusi. Näiteks Kasutaja Kustutatud osa, kuid kasutaja B muutunud komponendi nime või sellega ühendatud või lisatakse laps komponent on vms

2. Atribuut - Kui kaks kasutajat nii muuta täpselt sama "atribuut" objekt. Näiteks Mõlemad Kasutaja A ja kasutaja B muutunud osa nimi või kirjeldus või väärtuse üks tema omadused jms

3. Viide - Kui kaks kasutajat muuta täpselt sama "viide" objekt on teise objekti. Näiteks Mõlemad Kasutaja A ja kasutaja B muutunud osa tüübi või allikas / valamu osa külge seotud või seotud vaatenurga skeem jms

4. Kollektsioon - Kui kaks kasutajat muuta "kogumikust" objektile. Näiteks Mõlemad Kasutaja A ja kasutaja B kolis osa ühelt vanemalt teisele või re-tellis kogumine laste komponendid.

Märge

Erinevad tagajärgedeta konfliktid automaatselt lahendada arvelaud vähendada üldkulusid kasutajate.Näiteks vastuolud pan-suumisätted diagrammid on otsustanud hoida viimaste pan-zoom seaded.

Pühendumine muudatused

Kui valite endale oma muudatused, ABACUS faili serverist on avatud, oma kohalik muudatusi ei tehtaselle vastu, ja siis kohaliku .abacus faili üle kirjutada üks, mis on teie muudatusi. Muudatused esitada siis kirjutab .log faili, ja nii .abacus faili ja .log fail saadetakse serverisse.Kui toime on edukas sissekandmisteadet dialoog nagu allpool on sätestatud, et sisestada teadet koos toime.

Vaatad Logi muutuste

Kuni Vaata logi tehtavate muudatustega Ettevõte projektValige Faili| Vaata logi...

Maksimaalne Logi kanded: See vaikeasendis viimase 10 kirjed, kuid täiendavaid kirjeid võib saada muutes väärtust ja klõpsates Too nuppu.

Läbi: The Revisjoni veerus läbivaatamise numbrid pühendunud Enterprise server vaikimisi vastupidises järjekorras.

Märge

Läbivaatamine numbrid ei pruugi olla pidev sest ainult ABACUS kohustab on loetletud samas sama Subversionist hoidla võib seda kasutada teiste ABACUS projektide ja / või muu versiooni kontrolli rakendused.

Kuupäev: The Date veerus kuupäev, et läbivaatamine oli pühendunud Enterprise server.

Aeg: The aeg veerus kellaajast (24 tunni formaadis), et läbivaatamine oli pühendunud Enterprise server.

Kirjanik: The Autor veerus Microsoft Windows login nime kasutaja, sooritas Sissekandmisega millele järgneb nende ABACUS kasutajanime Või "Anonymous", kui kasutaja ei ole kinnitatud ja anonüümsed kasutajad ei pääse Enterprise projekti ajal ning pühenduda.

Logi Message: The Logiteade veerus loetletud sissekandmisteadet, mis oli varustatud muutmise kohta Dialoogis eespool näidatud.

Lae läbivaatamise XX nagu stand-alone ABACUS faili: Kui valite antud täiendusi tabelist ja vajuta nuppu Laadi siis suutma valitud ABACUS projekti läbivaatamine serverist ja salvestage see kohalik / iseseisev ABACUS projekti.

Märge

Rulli tagasi eelmise läbivaatamise vaadake seda Avolution kogukond article .

(Admin) Lae XML logifaili muutmise XX: Kasutajad koos ABACUS Administrator võime valida teatud täiendusi tabelist ja vajuta nuppu Laadi alla, et eraldada valitud ABACUS projekti toime log faili server ja salvestage see xml faili.

Kasutaja kontrolljäljena muutuste

Kuni Vaata kontrolljäljena tehtavate muudatuste tahes element (st osa, ühendus, arvates lapsed jne) kohta Ettevõte projekt, paremklõpsake element ja valima Audit Trail...Seadke From ja To Läbi valikut ja klõpsa Otsing.

Märge

Kui element on kustutatud projekti te ei ole enam võimalik tutvuda konkreetse kontrolljälje informatsiooni, et element. Võite siiski veel pääseda "vanema" komponent (näiteks) ja vaata kontrolljälje info kustutamist (antud juhul loetletakse ID elemendi, mis kustutati).Lisaks Component / Connection kinnitus on "vara" on ühendused nii muutuvad lisatud komponent läbi Explorer akna või skeemid näitavad kontrolljälje jaoks ühendus ei osale, ja kustutamine ühendus ja luua uus ühendus (nagu juhtub, kui klõpsate "Unattach" ja siis "Ühendage ..." kataloogides) toob kaasa kaotuse kontrolljälje andmeid originaal osa - ühendus manusena kokku.

Märge

Vaikimisi kontrolljäljest on rekursiivselt kontrollida muutusi ükskõik lapsi valitud element. See võib kaasa tuua pika reageerimisajaga ning seega kontrolljälje piiratud element ise valimata Rekursiivne valikuvõimalus Audit valikud"hammasratas" tööriistaribal nuppu Audit Trail dialoog.

Siit Revisjoni: See vaikimisi esimese / vanimaid muutmise projekti jaoks eraldatud kohta Enterprise server.

Et läbivaatamine: See vaikimisi viimasele / viimase muutmise projekti jaoks eraldatud kohta Enterprise server.

Märge

Pärast seda, milles From ja To muutmise vahemik klõpsake nuppu Otsi laadida mingeid konkreetseid muudatusi valitud element.

Läbi: The Revisjoni veerus läbivaatamise numbrid pühendunud Enterprise server vaikimisi tulevikutehingute kronoloogilises järjekorras.

Märge

Läbivaatamine numbrid on tõenäoliselt toimuma pidevalt, sest ainult parandusi seotud valitud element kuvatakse ainult ABACUS kohustub on loetletud samas sama Subversionist hoidla võib seda kasutada teiste ABACUS projektide ja / või versiooni kontrolli rakendused.

Kuupäev: The Date veerus kuupäev, et kasutaja tegevus toimus.

Märge

Kuupäeva näidanud on kasutaja tegevuse kuupäeva, mitte kuupäeval läbivaatamise oli pühendunud Enterprise server. Seega kuupäeva võib eelneda vastava läbivaatamise Sissekandmisega kuupäeva, mis on näidatud Faili | Vaata logi ...käsk.

Aeg: The aeg veerus kellaajast (24 tunni formaadis), et kasutaja tegevus toimus.

Märge

Kell näidanud on kasutaja tegevuse ajal ei ole aega läbivaatamise oli pühendunud Enterprise server. Seega, aeg on tõenäoliselt eelnema vastava läbivaatamise endale aega, mis on näidatud Faili | Vaata logi ...käsk.

Kirjanik: The Autor veerus kasutaja, et läbi meetme Microsoft Windows login nimi järgneb nende ABACUS kasutajanime Või "Anonymous", kui kasutaja ei ole kinnitatud ja anonüümsed kasutajad ei pääse Enterprise projekti ajal kasutaja tegevuse.

Märge

Autor loetletud Audit Trail dialoog ei pruugi olla sama autor loetletud Vaata logi dialoog eespool sama läbivaatamist. Seda seetõttu, et View Logi dialoog nimekirjad sisseloginud kasutaja on aeg pühenduda samas kontrolljäljest dialoog nimekirjad sisseloginud kasutaja ajal kasutaja tegevuse, ja see on võimalik, et üks kasutaja muuta ja saata oma. muudatusi esitada teisele kasutajale toime - nagu käesoleval juhul, kui välise kasutaja (nagu Avolution) on tööd selle nimel, EE projekti.

Detailid: The Detailid Veerus täpne üksikasjad kasutaja meetmeid arvele Enterprise server.

Ots

On kasulik grupi poolt Läbi kolonni (nagu näidatud dialoog eespool) ja / või Kasutaja Action veerus kuni lihtsalt liigitada muudatusi element huvi.

Kasuta Scripting Ettevõtluse faile

Kui kasutad skripte Enterprise faile, peate olema teadlik, kuidas õigesti kustutad objekti mudeli. Üldiselt, kui kustutad objekti, siis nimetame .Delete () meetodi peal, mitte ainult eemaldab selle lapsevanem.

Näiteks kui sa oleksid comp1 kui vanem comp2 ja soovid kustutada comp2 oma script, siis tuleb helistada comp2.Delete (), mitte comp1.Components.Remove (comp2).

Võid kasutada eemaldada, kui te kavatsete lisada comp2 objektilt teisele aset arhitektuuri, kuid see ei tohi kasutada, kui on kavatsus kustutada objekti.

On arvatud, et see, kui soovite eemaldada objekti, mis "elab" mujal mudel. Kui soovite eemaldada standard Näiteks alates arhitektuur / osale / ühendus, siis oleks seda teha, eemaldades selle näiteks on standard kogumise - arch1.Rakendused.Võtke (Imp) - sest kustutades oleks eemaldage see kõik juhtumid.

Õigesti kasutades Kustuta skriptide on oluline, sest kui objekt on eemaldatud objectmodel ja mitte uuesti lisada, siis ei saa asuda, kuid kuna see ei olnud just "kustutatud", ohtude avastamise ja mitte õigesti tuvastada konflikti, kui teine ​​kasutaja oli püüda kasutada seda objekti kõigi nende muutuste ning lõpptulemus on rikutud rida muudatusi, et kasutaja.

Vaata ka

Kuidas arhitektuuri esindatud ABACUS?


Töö reeglid

Navigation: Administration>

Töö reeglid

Saada kommentaare selle teema.

ABACUS projektid võivad olla rollipõhistõiguste kogum iga element hoidla. Täpsemalt peeneteraline Create-Read-Update-Delete (Kõnts) Õigusi võib seada object (st osa või ühendus), vaadata ja atribuut (st vara) taset.

Ülevaade

Töötades ABACUS Enterprise Server Abacus pakub peeneteraline rollipõhist kõnts õigused kontrollida juurdepääsu mitme kasutaja hoidlasse.

Märge

Et seadistada õigused ühes ABACUS projekti kasutaja litsents vajab administraatori võimekust. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

Õigusi võib määrata, et arhitektuuri, komponentide ja ühenduse tüübid, omadused (via nende tüübid), malle, seisukohti ja diagrammid, kataloogid, maatriksid, diagramme ja 3Dvaated. Kui load on seatud komponent või ühenduse tüüp kõigil juhtudel seda tüüpi igal arhitektuuri, et projekti "pärida" need õigused. Samuti, kui luba on seatud vara osa või ühenduse tüüp, antud vara osale või ühendus juhtudel igal arhitektuuri, et projekti "pärida" need õigused. Seega, teatud õigusi rakendatakse seisukohad, mille alusel need elemendid olemas. Kui load on seatud diagramm, vaade ja / või sisu vaadake ise on erinevad load rakendamise järel.

Märge

Vaikimisi ei load on seatud elemendid sees ABACUS projekti. See on kõik elemendid on Createable, loetav, uuendatav ja Deleteable kõik kasutajad. Sel viisil õigused tuleks kaaluda ainult antud element hoidla, kui teatud luba on olla piiratudteatud grupid. Näiteks, kui load antud grupp lisati objekti (nt osa tüüpi), kuid jättis kõik õigused lubatud, siis see on funktsionaalselt sama nagu siis, kui see grupp polnud lisatakse objekti.

Permissions ei saaseada konkreetseid juhtumeid arhitektuuri elemente. Näiteks, sa ei saa muuta ühe taotluse osa uuendatav järjekordne ole. Selleks, et tõhusalt saavutada nende "Domeeni" permissions aga administraator saab luua konkreetse elemendi tüüpide antud domeenid, nt komponent tüüpi "Application - CRM domeeni" ja "Application - HR valdkonnas", ja seejärel määrata õigusi iga vastavalt. Võite teha konkreetse rühmituse tüüpi iga domeeni ja seejärel eemaldada uuendus luba valdkonnapõhised grupi tüübist ja see piirab loomingut jooksul ja deletsioonid see rühmitus kuid ei uuenda laste. Muidugi, kui valdkonnapõhised rühmitus oli peidetud eemaldades loetav siis lapsi oleks varjatud ja seega mitte-uuendatav. Alternatiivselt, kui seisukohti (mitte explorer) kasutatakse peamiselt juhtida / vaadata hoidla, antud arvates iga domeeni võiks luua, ja seejärel administraator võiks määrata õigusi igal vaatel vastavalt.

Tegevjuht Kasutajad ja grupid

Õigused on määratletud juures rollvõi grupptasandil, mitte üksikute kasutaja tasandil, nii et kui liikmete rühmad võivad muutuda, õigused võib püsivad. Muidugi, kui soovite konkreetse kasutaja loata, siis lihtsalt teha neid rühma, või täpsemalt öeldes luua rühma, mis kasutaja ainuosanik.

Tuleb märkida, et rühmad on aatomi-, Mis on ei saa nad pärida õigusi või kasutajate ühest teise, ja kui kasutaja kuulub mitu rühmade siis kõige "pessimistlik rühma luba ülimuslikud iga juhtumi puhul eraldi iga üksiku luba (st Looge -Read uuendus-Delete). Näiteks, kui sama kasutaja kuulub rühma ja rühma B ja A-rühma on just Loo-lugemisõigus taotlemine komponent tüüpi ajal Group B on lihtsalt Loe uuendus loa taotlemine komponent tüüpi siis kasutaja on ainult Loe luba Application komponentide eksemplare.

Lisaks vaikimisi anonüümsed kasutajad(mis on kasutajad, kes ei ole määratud või kes ei ole sisse loginud) on täielik juurdepääsProjekti. Selle eesmärk on tagada, et ühendus on saadaval algse konfiguratsiooni. Blokeerida juurdepääsu anonüümsed kasutajad tühjendage Luba ja anonüümne kasutaja täielik juurdepääs toimikutele variant hallata kasutajate / Dialog toodud allpool. Kui märkimata anonüümsed kasutajad saavad ainult näha Standards osa iga projekti.

Lõpuks, kui "Use Windows Kasutajanimi sisse" Märkimise kasutajanimi autentimine toimub peale Windows Kasutajanimi kirjautumistunnukset iga kasutaja masina vastu kasutajanimi on sisestatud kohta allpool. See on siis, kui Windows Kasutajanimi sisse antud kasutaja masin olemas kehtiv kasutajanimi siis parooli ei ja kasutaja automaatselt kinnitatud. Märkus: see tõhusalt võimaldab kasutamine Windows Active Directory (AD) autentimist.

Märge

Arvestades, et load on määratud ainult siis, kui neil on vaja ära võtta (piiratud) kasutajalt, iga kasutaja, kes ei ole grupi liikmeks, või rühm, mis ei ole õigusi määratleda see mis tahes esemeid, mis on täielik juurdepääs Projekti.

Kasutajate ja kasutajatunnuste Groups

Uue kasutaja

1. Valima Faili| Kasutajate haldamine / Grupid

Märge

Kui te ei näe Kasutajate haldamine / Grupid menüükirjet sul ei ole administraator võimekust. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

2. Dialoogis ilmub valida Lisa kasutajanuppu ja sisesta kasutajanimi ja parool Loo uus kasutaja dialoogi. Märkus: kasutajanimed ja paroolid on tõstutundlikud.

Märge

Kui "Use Windows Kasutajanimi sisse" valik on sisse lülitatud, nagu eespool kirjeldatud, siis näiv parooli saab sisestada nii autentimist tehakse vastavalt kasutaja akna Kasutajanimi sisse ainult.

2. Vaikimisi näed, et Kasutajad saavad muuta oma parooli. Vajadusel ABACUS Administraator võib eemaldada võime kasutajad kehtestada oma parooli poolt eemaldades märkeruudud.

Märge

Kui kasutajad saavad muuta oma salasõna on neil Faili | Muuda salasõna...menüüst teha.Samuti pidage meeles, et kui mitu inimest kasutavad sama kasutajanime, siis üks kasutaja võib muuta parooli nii, et ükski teine ​​rahvas saab sisse hiljem. Seega on soovitav praktikas omada ühes kasutajanimi per tegelik inimene.

4. Soovi korral sisesta e-posti aadress, Asukoht ja telefoninumber kasutajate jaoks alles.

5. Vajuta Okeinuppu Loo uus kasutaja dialoogi.

6. Vajuta Okeinuppu.

Märge

Kui olete loonud oma esimese kasutaja siis peaks kaaluma blokeerides juurdepääsu anonüümsed kasutajad linnukese 'Luba anonüümne kasutaja täielik juurdepääs toimikutele variant Kasutajate haldamine / Grupid dialoog.Samuti, kui kasutaja on loonud (ja kui ettevõte projekti muudatust pühendunud server), järgmine kord projekti avatakse kasutajad palutakse Sisene autoriseeritud juurdepääsuühe dialoogi toodud allpool. Kui Automaatne sisselogimine nende detaileMärkimise siis kasutaja nime / parooli kombinatsiooni mäletatakse projekti ja kohaldamine iga avamisel. Selge salvestatud login valige Faili | Clear Saved Logi sissepärast avamist ja siis küsitakse uuesti sisse järgmisel avamisel projekti.

Logi sisse

Kustutada olemasoleva Kasutaja

1. Valima Faili| Kasutajate haldamine / Grupid

2. Dialoogis ilmub vali kasutaja nimi Kasutajad paneel, mida soovite kustutada ja seejärel Kasutaja kustutaminenuppu.

3. Vajuta Okeinuppu.

Uue Group

1. Valima Faili| Kasutajate haldamine / Grupid

2. Dialoogis ilmub valida Lisa Groupnuppu ja sisestage grupi nime Grupid paneeli.

Märge

Grupi nimed peavad olema unikaalsed.

3. Vajuta Okeinuppu.

Kuni kopeerida olemasolevaGroup

1. Valima Faili| Kasutajate haldamine / Grupid

2. Dialoogis ilmub valida KoopiaGroupnuppu.

Märge

Duplikaadi rühm luuakse eesliide "koopia".Vaikimisi kõik õigused on kopeeritud rühm on dubleeritud "Copy of", kuhu kuuluvad iga kasutaja ülesanne.

3. Nimeta "Koopia" rühm vajadusel kasutades Edit Groupvõi aeglane topeltklõps.

Kustutada olemasoleva Group

1. Valima Faili| Kasutajate haldamine / Grupid

2. Dialoogis ilmub valida Group nimi Grupid paneel, mida soovite kustutada ja seejärel Kustuta Groupnuppu.

Märge

Iga kasutaja ülesannetega Group eemaldatakse ka.

3. Vajuta Okeinuppu.

Määramiseks Kasutaja klubisse

1. Valima Faili| Kasutajate haldamine / Grupid

2. Dialoogis ilmub vali kasutaja nimi Kasutajad paneeli, et soovite loovutada Group ja tõmba ja lase lahtisee peale Group nimi Grupid paneel, mida soovite määrata selle.

3. Vajuta Okeinuppu.

Märge

Rühm (s), et kasutaja on määratud näidatakse laiendades Kasutaja nimi Kasutajad paneelja kasutajad, mis on määratud rühm on näidanud, laiendades Group nimi Grupid paneeli. Näiteks Ülaltoodud on "AS1-Aus" kasutaja määratud kolme (3) grupid, nimelt; "App Support Team 1", "tegelik" ja "Austraalia".

Et tühistage määrang Kasutaja alates Group

1. Valima Faili| Kasutajate haldamine / Grupid

2. Dialoogis ilmub laiendada Grupi nimi, mis sisaldab kasutaja ülesande, mida soovite tühistage määrang ja valige Hüüdnimi.

3. Vajuta Tühistage määrang Kasutajanuppu.

4. Vajuta Okeinuppu.

Importida kasutajad ja / või grupid (ja kõik sobitamise reeglid)

1. Valima Faili| Kasutajate haldamine / Grupid

2. Vajuta Importnuppu.

3. Dialoogis ilmub Sirvija avada ABACUS projekti, mis sisaldab kasutajate ja / või grupid (ja reeglid), mida soovite importida praeguse projekti ja klõpsa Avatud. Kasutajad ja grupid suletakse imporditud ja Import tulemused, ilmub dialoog, mis võtab kokku import kasutajate ja / või rühmad. Vajuta Okeinuppu.

Märge

Kui imporditud Kasutajad või Rühmad olid olemas juba praeguse projekti, siis nad tuleb ühendada olemasoleva Kasutajad või Rühmad.

4. Vajuta Okeinupp tagasi põhiteema Kasutajate haldamine / Grupid dialoog.

5. Kui on mingeid vastavustüüpide Seisukohti, mallid või arhitektuurid senise projekti ja ABACUS projekti sa importis koos õigused, mis ei ole juba olemas praegune projekt on õigused imporditud ja teine ​​Import tulemused dialoog tundub kokkuvõtlik import. Vajuta Okeinuppu.

Märge

Õigused on ainult lisada olemasolevale liigid (ja nende omadused), Seisukohad, mallid või arhitektuurid gruppidele, kus lube ei ole juba olemas grupp. Kas sellepärast, et grupp on uus või grupp on juba olemas praeguse projekti, kuid mitte õigused olid määratud, et Group sellele objektile. Ei ole "ühendamine" on õigused megafossil kus load olemas juba Grupi praeguse projekti.

Milles lubasid

Õigusi võib määrata, et arhitektuuri, komponentide ja ühenduse tüübid, omadused (via nende tüübid), malle, seisukohti ja diagrammid, kataloogid, maatriksid, graafikuidd 3Dvaated. Kui load on seatud komponent või ühenduse tüüp kõigil juhtudel seda tüüpi igal arhitektuuri, et projekti "pärida" need õigused. Samuti, kui luba on seatud vara osa või ühenduse tüüp, antud vara osale või ühendus juhtudel igal arhitektuuri, et projekti "pärida" need õigused. Seega, teatud õigusi rakendatakse seisukohad, mille alusel need elemendid olemas. Kui load on seatud diagramm, vaade ja / või sisu vaadake ise on erinevad load rakendamise järel.

Õigused juhtimine

Kui soovite, et loa osa (või Connection) Tüüp

1. Laiendada Tüübidpuusse.

2. Laiendada Component (või Connection) liigidpuusse.

3. Laienema Grupidvajaduse korral.

4. Paremklõpskohta Component (või Connection) Tüüpsoovite määrata õigusi ja valiks Edit reeglid.

5. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

6. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

Märge

Loo luba reguleerib ka siis, kui saate kopeerida element. Seega oleks võimalik kopeerida element vajab Loo luba kõik oma lapsed (alates kopeerida element tähendab kopeerida kõike selle alla). Eemaldamine värskendus loata element kaob võimalus muuta tüüpi iseenesest isegi kui kasutaja on Designer add-ja see Samuti eemaldab uuendus luba kõik oma omadused. Vanem element peab olema värskendus luba, et oleks võimalik Loo lapsi elemente või Kustuta oma olemasolev laste elemente. Kustuta luba element nõuab ka Kustuta luba kõigile oma lastele. Kustuta luba komponendid nõuab ka Uuenda loata kõik lisatud ühendused.Ja lõpuks, eemaldades Delete luba alates element kaob võimalus kustutada tüüpi iseenesest isegi kui kasutaja on Designer add-.

7. Vajuta Okeinuppu.

Kui soovite, et luba rühmale Component (või Connection) liigid

1. Laiendada Tüübidpuusse.

2. Laiendada Component (või Connection) liigidpuusse.

3. Paremklõpskohta Groupmis sisaldab Component (või Connection) tüübid, mida soovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

6. Vajuta Okeinuppu.

7. Dialoogis ilmub klõpsa Jahnuppu.

Kui soovite, et loa Property

1. Laiendada Tüübidpuusse.

2. Laiendada Component (või Connection) liigidpuusse.

3. Laienema Grupidvajaduse korral.

4. Vali komponent (või Connection) Tüüp mis sisaldab vara soovite seatud õigused.

5. Properties aknas paremklõpskohta Varasoovite määrata õigusi ja valiks Edit reeglid.

6. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

7. Vaikimisi näed, et Read ja värskendamine õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

Märge

Omadused, mis on olnud Update luba välja on toodud kaldkirjasAtribuutide aknasning nende väärtusi ei ole võimalik ajakohastada, et osa. Samuti võime muuta andmed vara (nt nimi, üksused jne) nõuab nii värskendus luba varale ja Designer add-on.

8. Vajuta Okeinuppu.

Kui soovite, et loa Mall

1. Laiendada Templatespuusse.

2. Otsi üles Šabloonet olete huvitatud.

3. Paremklõpskohta Šabloonsoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et on loetav saadaval. Eemalda loata eemaldades märkeruut.

6. Vajuta Okeinuppu.

Kui soovite, et loa Seisukoht

1. Laiendada Seisukohadpuusse.

2. Laienema Grupidvajaduse korral.

3. Paremklõpskohta Seisukohtsoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

6. Vajuta Okeinuppu.

Kui soovite, et loa suhtes, arhitektuur

1. Laiendada Arhitektuuridpuusse.

2. Laieneda Arhitektuuret olete huvitatud.

3. Paremklõpskohta Arhitektuursoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et on loetav saadaval. Eemalda loata eemaldades märkeruut.

6. Vajuta Okeinuppu.

Kui soovite, et loa jaoks Kataloog

1. Laiendada Kataloogidfiliaali arhitektuuri olete huvitatud.

2. Laienema Grupidvajaduse korral.

3. Paremklõpskohta Kataloogsoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

6. Vajuta Okeinuppu.

Kui soovite, et loa jaoks Matrix

1. Laiendada Matriitsidfiliaali arhitektuuri olete huvitatud.

2. Laienema Grupidvajaduse korral.

3. Paremklõpskohta Matrixsoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

6. Vajuta Okeinuppu.

Kui soovite, et loa skeemilt

1. Laiendada Skeemidefiliaali arhitektuuri olete huvitatud.

2. Laienema Grupidvajaduse korral.

3. Paremklõpskohta Skeemsoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

Märge

Kuigi saate määrata kõnts õigused otse skeem, siis tuleb märkida, et load elementide diagrammil võib mõjutada õigused seisukohal ise. Näiteks kui on kasvõi üks element on seisukohal, et on olnud oma Read või värskendamine luba eemaldada siis skeem on selle värskenduse luba eemaldada. Selle põhjuseks on asjaolu; a) elemente, et on olnud oma lugemisõigus eemaldada ei näidata vaatest jättes "tühja ruumi", kus sa muidu panna mõningaid uusi elemente kui vaade oli uuendatav, ja b) elementide kohta, et on olnud nende värskendamine luba eemaldada oleks saanud siis muud elemendid langes nende peale saada lapsi, kui oli vaade uuendatav. Samuti luua ja uuendada luba skeem nõuab, et kõik elemendid arvates on loetav ja komponendid on Värskenda luba (seda sellepärast, et liikuda komponent teisele komponent, siis peab olema võimalik seda uuendada, kuna see saada laps).

6. Vajuta Okeinuppu.

Kui soovite, et loa 3D View

1. Laiendada 3D Viewsfiliaali arhitektuuri olete huvitatud.

2. Laienema Grupidvajaduse korral.

3. Paremklõpskohta 3D Viewsoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

6. Vajuta Okeinuppu.

Kui soovite, et loa jaoks Chart

1. Laiendada Äritegevusfiliaali arhitektuuri olete huvitatud.

2. Laienema Grupidvajaduse korral.

3. Paremklõpskohta Chartsoovite määrata õigusi ja valiks Edit reeglid.

4. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

5. Vaikimisi näed, et luua, lugeda Uuenda ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

6. Vajuta Okeinuppu.

Vaata ka

Kuidas arhitektuuri esindatud ABACUS?


Töö Verbi

Navigation: Administration>

Töö Verbi

Saada kommentaare selle teema.

ABACUS projektid võivad olla mis tahes konfiguratsiooni vaated (nt diagrammid, Kaardid jne) salvestatakse armatuurlaud ja need salvestatakse armatuurlauad saab vaikimisi algab "ekraan" avamise projekti ja / või eraldada konkreetseks grupid ja esitatakse liikmetele, et grupid, kui nad sisse logida kaasa ABACUS projekti.

Märge

Et seadistada armatuurlauad ühes ABACUS projekti kasutaja litsents vajab administraatori võimekust. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

Kasutaja Verbi

Näiteks taotlemine Portfolio Management (APM) armatuurlaual

Salvestatud Armatuurlaud

1. Valima Vaade| Verbi

2. Vali salvestatud armatuurlauale nimekirjast saadaval armatuurlauad.

Märge

Kui valitud ABACUS ehitab seisukohti vaja armatuurlaual ja see võib võtta mõne sekundi. Palun ole kannatlik.

Tegevjuht Verbi

Tegevjuht Verbi

Uue Armatuurlaud

1. Avage vajalik seisukohti ja korraldada ja dokki aknad vaja armatuurlaual.

2. Valima Vaade| Verbi| Manage Views ...

Märge

Kui te ei näe Manage Views menüükirjet sul ei ole administraator võimekust. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support kui teil on vaja see võimalus.

3. Dialoogis ilmub valida Loonuppu ja sisestage Armatuurlaud nime Loo uus Armatuurlaud dialoog.

4. Vajuta Okeinuppu.

Kustutada olemasoleva Armatuurlaud

1. Valima Vaade| Verbi| Manage Views ...

2. Dialoogis ilmub valida Armatuurlaud soovite kustutada loendist ja valige Kustutamanuppu.

Märge

Kustutamine armatuurlaual kustuvad ka iga kasutaja grupi ülesanded sellele armatuurlauale.

3. Vajuta Okeinuppu.

Asendama olemasolevaid Armatuurlaud

1. Avage vajalik seisukohti ja korraldada ja dokki aknad asendamiseks vajalikest armatuurlauale.

2. Valima Vaade| Verbi| Manage Views ...

3. Dialoogis ilmub valida Armatuurlaud soovite asendada nimekirjast ja valige Vahetagenuppu.

4. Vajuta Okeikinnitamiseks nuppu Armatuurlaud Vahetatud dialoog.

Et määrata Armatuurlaudvaikimisi Start Screen

1. Valima Vaade| Verbi| Manage Views ...

2. Dialoogis ilmub valida Armatuurlaud nimekirjast soovid määrata vaikimisi start "ekraan"ja valige Määra ...nuppu.

3. Dialoogis ilmub valida kirje Kasutaja Grupid veerus.

Märge

Ainult üks armatuurlauale saab määrata, kui start "ekraan" nii suunamine eemaldab loovutamise eelmisest armatuurlaual.Pealegi, kui kasutaja logib liikmena kasutaja rühm, mis on määratud armatuurlauale siis antud armatuurlauale avatakse asemel vaikimisi projekti armatuurlauale.

4. Vajuta Okeinuppu.

Et määrata User Group armatuurlaua

1. Valima Vaade| Verbi| Manage Views ...

2. Dialoogis ilmub valida Armatuurlaud nimekirjast soovite määrata grupid ja valige Määra ...nuppu.

3. Dialoogis ilmub valida User Group (või grupid)soovite määrata armatuurlaual kui tegevust alustavatesse ekraani.

Märge

Kui sama User Group on määratud mitu armatuurlauad siis esimene ülesanne nimekirjas kasutada.

4. Vajuta Okeinuppu.

Et tühistage määrang Kasutaja Group alates Armatuurlaud

1. Valima Vaade| Verbi| Manage Views ...

2. Dialoogis ilmub laiendada Armatuurlaud loendist soovite tühistage määrang kasutaja grupp.

3. Valige Kasutaja grupp soovite tühistage määrang ja valige Tühistage määrangnuppu.

4. Vajuta Okeinuppu.

Milles lubasid

Õigusi võib määrata armatuurlauad võimaldada armatuurlaual olema vaadatav, Uuendatav ja / või deleteableet antud kasutaja rühmad.

Õigused juhtimine

Kui soovite, et loa armatuurlaua

1. Valima Vaade| Verbi| Manage Views ...

2. Dialoogis ilmub valida Armatuurlaud nimekirjast soovite Õiguste määramine ja valige Permissions ...nuppu.

3. Dialoogis ilmub klõpsa Lisa ...nuppu ja valige Groupsoovite lisada kas sellel topeltklõpsu tehes või valides ja klõpsates Okeinuppu.

4. Vaikimisi näed, et Loe, värskendamine ja Kustuta õigused on kõik olemas. Eemaldage õigused poolt eemaldades märkeasjakohaste ruudud.

5. Vajuta Okeinuppu.

Vaata ka

Kohandamine ABACUS liides | Töö reeglid


Registreerimine ABACUS

Navigation: Reference>

Registreerimine ABACUS

Saada kommentaare selle teema.

Kui te esimest korda alustada ABACUS (või pärast ajutist kehtivusaeg on lõppenud) pead registreerib taotluse vastu Avolution litsentsi server kasutades unikaalset võti, mida teie kohalik ABACUS Administraator või otse Avolution. Kui te ei ole võti võtke ühendust kohaliku ABACUS Administraator või Avolution Support .

Registreeruda litsentsi võti

1. Pärast paigaldamist, alustada ABACUSkas topeltklõpsuga otsetee töölaual või Windowsi Start menüüst.

2. Registreerimise ilmuvasse dialoogi siseneda 26 märk võtimida teie kohalik ABACUS Administraator või Avolution toetust Või kliki Sirvi ...ja valige allkirjastatud .dlsc faili naasnud Avolution Support kohta Märkuse Samm 4 alla. Kui kasutate õigesti allkirjastatud .dlsc faili ABACUS tuleks alustada ühe Samm 5 allpool.

Ots

Võite kleepida litsentsi võti dialoogi, kopeerides selle Windows lõikelauale ja siis valides taust dialoogi ja vajutades Ctrl + V.

Registreerimine dialoog

3. Vajuta Okeija kui võti on kehtib ABACUS võtiABACUS nüüd proovida võtta ühendust Avolution litsentsi server autentimiseks võti.

Märge

Kui sa saad Paigaldamine kood on viganeregistreerimise viga see on kõige tõenäolisem, et teil on trükitud koodi valesti. Proovige kopeerige kood seisuga Vihje eespool.

Kontakteerumine Avolution litsentsi Server

4. Vajuta Okeija pärast lühikest aega ABACUS peaks registreerima edukalt.

Edukas Registreeri

Märge

Kui teil tekib Ei saa ühendust litsentsi serverregistreerimise viga see on kõige tõenäolisem, et tulemüür (või muid turvameetmeid) teie võrgus on takistada juurdepääsu Avolution litsentsi server. Vajuta OkeiSalvesta .dlsc faili kohalikus arvutis ja seejärel kumbki saata .dlsc faili Avolution Support ja ootama edasisi juhiseidvõi proovida kirjutada litsentsi esitada ise, kasutades järgmist URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Ei saa ühendust litsentsiserverit

Avage litsentsi allkirjastamise veebileht

Käsitsi litsentsi allkirjastamise veebileht

Alternatiivselt, kui sul saada See paigaldus kood on kasutatud mitme süsteemi kui litsentsiga lubatudregistreerimise viga on tõenäoline, et sinu masin on ümber ehitatud pärast viimast registreeritud ABACUS või püüate registreerida teise kasutaja võti. Palun võtke ühendust kohaliku ABACUS Administraator või Avolution Support .

Paigaldamine koodi on juba kasutatud

5. Vajuta Okeija kui nad on registreeritud edukalt ABACUS peaks avama koos Tere Screen .

Vaata ka

Avolution Support | Mida ABACUS teha?


ABACUS paigaldamine eeldused

Navigation: Reference>

ABACUS paigaldamine eeldused

Saada kommentaare selle teema.

Informatsioon Visio Import ja Excel Import / Export

ABACUS nõuab, et Microsoft Office paigaldada täitmiseks Excel Import / Export ja Visio Import operatsioone. Palun veenduge, et Microsoft Office 2003 või uuemon õigesti paigaldatud. Kui teil tekib täiendavaid probleeme, võtke ühendust Avolution Support .

Selleks, et täita Visio Import ja Excel Import / Export tegevust Abacus kasutab Microsoft Office Esmane Interop Assemblies (PIA on). ABACUS praegu tuleb pakendada koos sõlmed vaja teha Excel Import / Export ja Visio Import.

Informatsioon SQL Server Import

ABACUS nõuab, et Microsoft SQL Server 20052008, 2008 R2, 2012 või 2014on paigaldatud, et alustada uut projekti SQL Server. Palun veenduge, et Microsoft SQL Server 20052008, 2008 R2, 2012 või 2014on õigesti paigaldatud. Kui teil tekib täiendavaid probleeme, võtke ühendust Avolution Support .

Vead avamine 3D Visualiseerimised

Kui ABACUS 3D Viewer ei tööta, siis võib kadunud SlimDX DirectX Runtime (paigaldatud osana kogu ABACUS EXE paigaldada). Selle saab alla laadida siin . Kui teil on 64bit versioon Windows, siis võib ka vaja paigaldada see .

Vead Toimetajad ABACUS Tava Aruanded

Toimetajad ABACUS "Custom Reports nõuab Report Builder 3.0 paigaldada. ABACUS ja aruanne Builder on üles ehitatud Microsoft .NET Framework 4.0, ja kui nad nii ei nõua Microsofti .NET Framework 3.5, Microsoft on valesti konfigureeritud aruande Builder MSI ainult edasi, kui Microsoft .NET Framework 3.5 on installitud.

Seega Avolution on redigeeritud versioon Report Builder paigaldus MSI fail, mis ei nõua Microsofti .NET Framework 3.5, seda saab alla laadida siin .

Algne Microsoft Report Builder MSI saab alla laadida siin . Kui sul ei ole veel Microsoft .NET Framework 3.5, mis on selleks vaja, saad selle alla laadida siin . Märkus: Mitme rajatised, offline paigaldada Microsofti .NET Framework 3.5 alates siin võib olla asjakohasem.


Käsureavõtmetega

Navigation: Reference>

Käsureavõtmetega

Saada kommentaare selle teema.

Võite sooritada erinevaid ABACUS operatsioonide otse käsurealt kõige enam levinud on avatud konkreetse projekti esitamist ja avaldamist see HTML.

Täpsemalt käsurea kasutamist ABACUS on järgmine;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "USER" / pass "PASS"]

Argument | Kirjeldamine
ProjectFile | ProjectFile võib olla kas ABACUS projekti faili (.abacus), raamatukogu faili (.abacuslib), XML faili (xml) või MS Access DB (MDB) ja määratud fail kas avada (kui .abacus või .abacuslib ) või uue projekti loodud (kui xml või MDB fail).
OptionalFile | OptionalFile võib olla kas ABACUS script (.abacusscript, .vb või .cs), makro (.abacusmac) või teegi faili (.abacuslib) ja määratud fail kas käivitada pärast avamist ProjectFile (kui .abacusscript, .vb või .cs või .abacusmac) või lihtsalt avada (kui .abacuslib).
/ exitOnCompletion | Väljub ABACUS ja vajadusel salvestada ja pühenduda mingeid muudatusi avatud .abacus projektide lõpetamist skripti või makro. Märkus: See lipp on tõstutundlik, nii et kasuta suurtähtede "O" ja "C" teksti, nagu näidatud.
/ dontShowDialogs | Kas vältida ABACUS Enterprise Edition (EE) värskendusteatis dialooge näitab avamisel projekti. Märkus: See lipp on tõstutundlik, nii et kasuta suurtähtede "S" ja "D" teksti, nagu näidatud.
/ kasutaja "kasutaja" / pass "PASS" | Kasutajanime kasutajanimi ja parool PASS kasutatakse logida projekti, jättes arvestamata kõik salvestatud kasutaja andmed. Märkus: jutumärkide tuleb panna ümber kasutaja ja PASS lipud ja kaks jutumärkide võib kasutada põgeneda topeltjutumärgi kas kasutaja või PASS lipud.

Näiteks;

ABACUS.exe "Data \ Example.abacus" "skriptid \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / user "Avalik" / pass "123456"

millal kulgema kataloog, kus ABACUS.exe binaarne on asub tahe avatud Näites projekti ja sisse logima kasutaja Public parooliga 123456 (nagu on kirjeldatud siin ), Avaldab see HTML ja sulgege projekti kõik omamata dialoogid teel (nt "Uuenda edukas" või "No uuendused saadaval" Ettevõtluse projektid).

Näiteks;

ABACUS.exe "Data \ Example.abacus" "skriptid \Kataloog Excel Import.vb"/ exitOnCompletion / dontShowDialogs

millal kulgema kataloog, kus ABACUS.exe binaarne on asub tahe avatud Näites projekti ja import "Serverid (2014 Tegelik) Xlsx" MS Excel fail üles "Serverid" kataloogi "2014 Tegelik" projekti ülesehitus, omamata dialoogid mööda teed ja siis sulgemise projekti lõpetamist. Kui operatsioon muudab projekti siis sulgemisel muutused kohapeal salvestatud ja kui ettevõte projekti pühendunud Enterprise Server.

Märge

Kasutage kindlasti õiget jutumärke iseloomu, sest mitmed on standard ASCII kooditabel ja Windows Command Prompt ainult korralikult töötada õige. Õige jutumärke koodiga on Decimal 34 (Hexadecimal 22).See on see, mida kasutatakse ülaltoodud näite nii vabalt copy / paste sealt.


Tiitellehel

ABACUS

Tingimused

Avolution Pty Ltd tee mingeid kinnitusi ega anna garantiisid selle kasutusjuhendi ja nii suures ulatuses seadusega lubatud sõnaselgelt piiratud vastutust rikkumise eest mingit vastutust, mis võib tuleneda selle asendamist käesoleva käsiraamatu teise. Lisaks Avolution Pty Ltd jätab endale õiguse muuta käesoleva väljaande igal ajal, ilma et tekiks kohustus teavitada kedagi läbivaatamist.

Copyright

Copyright 2001-2015Avolution Inc Kõik õigused reserveeritud.

Kaubamärgid

Avolution Pty Ltd on teinud kõik endast oleneva, et pakkuda kaubamärk informatsiooni firma nime, toodete ja teenuste juhendis mainitud. Kaubamärgid Allpool on saadud erinevatest allikatest.

Microsoft Windows, Access, Visio, Excel, SQL Server ja Internet Exploreron Microsoft Corporationi kaubamärgid.

Üldine märkus:

Mõned tootenimed kasutatakse selles juhendis kasutatakse ainult tuvastamise eesmärgil ning need võivad olla kaubamärgid nende firmad.

Detsember 2015Edition Avolution ABACUS versioon 4.5.

Käsitsi Läbi 1,0

Loodud, trükitud ja köidetud Austraalia.