Mitä ABACUS tehdä?

Navigation: Johdatus ABACUS>

Mitä ABACUS tehdä?

Lähetä kommentit tästä aiheesta.

Apua muilla kielillä / käännökset klikkaa tässä .

ABACUS vie arvaus-treenata käsitellä ratkaisuja, järjestelmiä, ohjelmistot, tiedot, teknologia, liiketoimintaprosessit ja / tai koko yrityksille (jäljempänä yhteisesti arkkitehtuurit). Se voi auttaa sinua pragmaattisesti suunnitella, seurata, simuloida, analysoida, ja visualisoi arkkitehtuuri mallintamalla se, analysoida se luonnonmukaisia ​​tapoja (esim kaavioita, kaaviot ja 3D) ja sitten vertaamalla sitä teidän ei-toiminnalliset vaatimukset.

Huomautus

Ei-toiminnalliset vaatimuksetovat ne vaatimukset, jotka eivät liity suoraan siihen, miten tuote toimii. Sen sijaan, ne ovat huolissaan siitä, miten hyvin se toimii. Ei-toiminnalliset vaatimukset ovat sellaisia ​​asioita kuten suorituskyky, avoimuus, evolvability, laatu, skaalautuvuus, modulaarisuus, jne. (Toisin kuin toiminnalliset vaatimukset, kuten, kytke tämä valoa, kun tätä painiketta napsautetaan). Perinteisesti ei-toiminnallisia vaatimuksia on ollut vaikea - ellei mahdoton - mitata. Itse asiassa, ABACUS on ainoa tuote, joka voi objektiivisesti ja määrien mitata kolme ensimmäistä - suorituskyky, avoimuus, ja evolvability.

Yksinkertaisesti sanottuna, annat arkkitehtuuria ja mitä tarvitset sitä tehdä. ABACUS sitten kertoo, jos se tekee tarvittaessa ja huomauttaa heikkouksia tai puutteita.

ABACUS pohjautuu yli 20 vuoden järjestelmien tutkimus ja monta vuotta perustettu systeemiteorian. Se antaa sinulle mitattavissa, luotettavaa, objektiivista vastauksia, joten et ole vedoten subjektiivisesta arvioinnista.

ABACUS sanoista Architecture-Bhinnoitteluun Analysis, Communication ja Understandingof Systems. Se voi auttaa sinua kaikissa laajamittaista arkkitehtuuri, mutta se on yleensä käytetään neljä (4) asiaa:

· Kehittyvänykyinen arkkitehtuuri. Esimerkiksi, jos nykyiset arkkitehtuuri puuttuu suorituskyky, Abacus visualisoida arkkitehtuuri sinulle, tunnistaa ongelmat (pullonkaulat, jne), niin kerro sinulle täsmälleenmiten parantaa arkkitehtuuriin.

· Suunnitteluuusi arkkitehtuuri. Esimerkiksi, jos tarvitset kokonaan uusi arkkitehtuuri, ja olet suunnittelussa itse, ABACUS kertoo täsmälleenmitä osia tarvitset ja miten ne tulee kytkeä.

· Osto-uusi arkkitehtuuri. Esimerkiksi, jos olet pyysi tarjouksia suunnitteluun uutta arkkitehtuuria, ja olet valinnut kolmesta grafiikat ABACUS kertoo täsmälleenkumpi sopii tarpeisiisi parhaiten.

· Yhdistäminenolemassa oleva arkkitehtuurit. Esimerkiksi, jos haluat yhdistää kaksi tai useampia erillisiä arkkitehtuurit, ABACUS opastaa.

Katso myös

Miten teet sen (yleiskatsaus) | Mikä on arkkitehtuuri? | Miten arkkitehtuuri edustettuna ABACUS?

© 2001-2015 Avolution Inc. Kaikki oikeudet pidätetään.


Kuinka käyttää ABACUS (yleiskatsaus)

Navigation: Johdatus ABACUS>

Kuinka käyttää ABACUS (yleiskatsaus)

Lähetä kommentit tästä aiheesta.

Tämä aihe antaa perustiedot yleiskuvan tehtävien mukana käyttäen ABACUS.

Seuraava kuva arkkitehtuuri perustuva analyysi prosessi, joka ABACUS säädetään kehittyvä nykyinen arkkitehtuuri uuteen tai kohde arkkitehtuuri.

ABACUS Process

Voit käyttää ABACUS:

1. Tarkastaa - Ennen kuin käytät ABACUS, sinun täytyy kerätä kaikki tiedot sinulla on noin arkkitehtuuri, ja sen vaatimukset.

· Arkkitehtuuri - Tunnista mahdolliset komponenttien arkkitehtuurin ja miten ne vaikuttavat toisiinsa. Siellä pitäisi olla vain muutamia osia ylimmällä tasolla. Näitä kutsutaan "olennaisia ​​osia". Monimutkaisetkin arkkitehtuurit tulisi olla alle 10 olennaisia ​​osia. esim. Keskeisiä tekijöitä vakuutusyhtiön arkkitehtuuri voi olla politiikkaa, kuitit, saamiset, ja maksut.

· Vaatimukset- Sinun täytyy tietää, mitä on odotettavissa arkkitehtuurin, jotta voidaan määrittää, jos se on tyydyttävä. esim. Kauppojen lukumäärä tunnissa.

· Mistä löysit sen? - Tämä tieto voi tulla vaatimuskuvaukset, suunnittelu asiakirjoja, haastatteluja sidosryhmien käyttöön koodi, jne. Periaatteessa mikä tahansa materiaali, joka on saatavilla tarjoaa ABACUS tietoa arkkitehtuurista.

2. Asuttaa -Käytä ABACUS mallin arkkitehtuurista ja täsmennettävä vaatimukset rakennetta mitataan vastaan.

· Arkkitehtuuri - Abacus aloitat tyhjällä arkkitehtuuri - joudut asuttaa se. Tämä tarkoittaa syöttänyt kaikki arkkitehtuuri tiedot kerännyt edellä. Voit kertyisi arkkitehtuuri manuaalisesti (käyttämällä oikealla hiirennapilla), tai voit asuttaa sen automaattisesti (Microsoft Visio, Excel, Access jne). Tyypillisesti top-eniten tasoja (tiivistelmä) arkkitehtuurin on asuttu käsin, ja alemmilla tasoilla (konkreettisempia) tullaan asuttu automaattisesti.

· Vaatimukset - Kun lisäät laitteiden ja yhteyksien, voit määrittää niiden ominaisuuksia. Useimmissa tapauksissa nämä ominaisuudet ovat vaatimukset arkkitehtuuria. Esimerkiksi, jos sinulla on 1250 MIPS solmu / cluster, lisäät solmun osana, lisää sitten suorituskykyä omaisuutta, ja antaa arvoa 1250 MIPS.

3. Analysoida - Käytä Abacus tyylikkäästi analysoida ja visualisoida monimutkainen rakenne arkkitehtuurista. Sinä voi analysoida arkkitehtuurin monin tavoin tai useista näkökulmista, mukaan lukien kaaviot, 3D ja Explorer. Vaihtoehtoisesti voit halutessasi käyttää joitakin tarkempia näkemyksiä seuraavasti:

· Kartoittakaa arkkitehtuuri - saada suorituskyvyn (vasteaika, kaistanleveys, jne.), Kustannukset (baari, piirakka, jne.) Tai evolvability (valmius tila, kauppa-off, jne.) Näkemyksiä.

· Luo raportti laitealustan.

4. Simuloida - Käytä ABACUS simuloida arkkitehtuurista suorituskykyä, saatavuus, hinta, avoimuus, jne.

· Voit tehdä tämän suorittamalla yksi simulaattoreita. ABACUS arvioi teidän arkkitehtuuri vasten vaatimuksetsuorittamalla simulointi. Se lukee ja analysoidaan nykyistä arkkitehtuuri, kulkee simulaatioita, ja laskee joitakin uusia ominaisuuksia. Nämä ominaisuudet ovat sitten tallennetaan takaisin arkkitehtuuriin. Uudet ominaisuudet ovat tiedot yrität analysoida, kuten käyttöaste, vasteaika, kaistanleveys,% saatavuus, TCO jne

5. Insinööri- Käytä ABACUS vastata eri "entä jos" skenaarioita ja hillittävä väestön arkkitehtuurista. Engineering on prosessi toistetaan Lisääntynyt - Analyse - Simuloisykli.

· Tässä vaiheessa, olet'Veluultavasti kehitetty ymmärrystä Nykyinen Arkkitehtuuri ja korosti alueet sinun täytyy kehittyä. Usein kuitenkin, sinun täytyy toistaa Kansoittavat - Analyse - Simuloi prosessi useita kertoja. Tämä on luultavasti koska se voi kestää pari toistojen ennen kuin löydät Target Arkkitehtuuri. Myös, jos arkkitehtuuri on hyvin monimutkainen, voit toistaa prosessin kunkin arkkitehtuurin "tasolla".

6. Suunnitelmatulevaisuus teidän arkkitehtuurin avulla toimittamien tietojen ABACUS.

Huomautus

Jos et ole yrittänyt kehittää nykyisiä arkkitehtuuri, voit joutua toistamaan joitakin vaiheita monta kertaa, ja eri järjestyksessä. Se riippuu siitä, mitä yrität tehdä. Esimerkiksi, jos olet suunnittelussa uusi arkkitehtuuri, luultavasti vain kertyisi arkkitehtuuri kerran, ja sitten käyttää ABACUS pitkän aikaa ohjata tulevan kehityksen (t) arkkitehtuuri. Toisaalta, jos olet ostamassa uutta arkkitehtuuria ja on useita vaihtoehtoja, joista valita, sinun täytyy löytää ja Kansoittavat kunkin vaihtoehtojen, ja sitten analysoida ja simuloida jokainen itsenäisesti ennen suorittamista lopullisen vertailun end.

Katso myös

Mitä ABACUS tehdä? | Mikä on arkkitehtuuri? | Miten arkkitehtuuri edustettuna ABACUS? | Populating arkkitehtuurista | Analysointi arkkitehtuurista | Simulointi arkkitehtuurista


Mikä on arkkitehtuuri?

Navigation: Johdatus ABACUS>

Mikä on arkkitehtuuri?

Lähetä kommentit tästä aiheesta.

Arkkitehtuuri on abstrakti käsite- Ei ole fyysinen asia. Se on rikas ja kattava kuvaus tai käsitys järjestelmän rakennetta - syömällä komponentit ja miten ne on liitetty (vuorovaikutuksessa). Koska käsite arkkitehtuuri on niin kaikenkattava, se on olennaista kustannukset, saatavuus, evolvability, avoimuus, ja järjestelmän suorituskyvyn. Ääni arkkitehtuuri on ennakkoehtona äänijärjestelmä.

Abacus, voit mallintaa arkkitehtuuria. Yksinkertaisuuden, me kutsumme tätä arkkitehtuurin malli arkkitehtuuri.

Kaaviossa on kuvattu tyypillinen arkkitehtuuri 5komponentit (Hierarkiassa) yhdistetty 2 liitäntää. Tarrat nimet annetaan eri osien arkkitehtuurin Abacus.

Yksinkertainen arkkitehtuuri

ABACUS pitää kaikki nämä asiat olla osa arkkitehtuuria:

· Komponentitedustavat yksiköt laitealustan joka voisi kuvata kuin "asioita". Saat vakuutusyhtiö, osat voidaan järjestelmiä käsittely politiikan, väittää, maksut ja tulot.

· Liitännätedustavat suhteet näiden komponenttien. Esimerkiksi vakuutusyhtiö, kuitit generoidaan voimassa politiikkoja, väitteitä on esitetty vastaan ​​voimassa politiikkaa, ja hyväksyttävä hakemus johtaa maksujen. Kun ajattelu arkkitehtonisesti - varsinkin kun käytetään Abacus - liitokset ovat yhtä tärkeitä kuin komponentteja, ja ne käsitellään lähes samalla tavalla.

· Kaikki puu voi olla Ominaisuudet. Ominaisuudet ovat asioita, kuten miten haluat järjestelmän suorittamaan, määrä riviä koodia se on, prosenttiosuus näistä linjat, jotka ovat kommentteja, jne ABACUS pitää kaikki nämä asiat olla osa arkkitehtuuria.

· Käyttämällä hierarkiat(Ts alikomponentit ja sub-yhteydet), Voit piilottaa tietoa ja de-säveltää arkkitehtuurista. ABACUS arkkitehtoninen malli on erittäin joustava. Jonkin osan millään tasolla voi liittyä mihinkään muuhun komponenttiin milloin tahansa tasolla mitään yhteyttä millään tasolla.

· Liiteon toimenpide, jolla komponentit satamat on pakko yhteysroolit. Aikataulut ja Roolit ovat liitäntäslaitteiden välillä ja yhteyksiä. Niitä käytetään liittää yhteydet komponentteja. Liitokset on Lähde ja Sink rooli(Helpottamalla datavuon lähdelaite pesuallas komponentti)ja käsitteellisesti, komponentit on satamia. Yksinkertaisuuden vuoksi, kuitenkin, Abacus komponentin portteja ei ole esitetty, ja yhteyden roolit ovat suoraan kiinnitetty itse osat.

· Komponentit ja yhteydet ovat tietyn Tyyppi. Tämä on lähinnä luokittelua varten. Esimerkiksi politiikkoja, väittää, maksut ja tulot ovat komponentteja tyyppiä "System". Voimassa politiikkojen voimassa väittää, jne. Ovat yhteyksien tyyppiä "Transaction". Kirjoita valittu komponentti tai liitäntä tarjoaa mallin ominaisuuksia ja vaatimuksia se on. Esimerkiksi Server osan saattaa olla "Merkki & Malli" standardija IP-osoite omaisuutta. Toisin kuin muut jäykkä työkaluja perustiedot relaatio-emäs (RDB) back-end, Abacus voit vapaasti luoda omia uudenlaisia ​​ja määrittää itse ominaisuuksien yhdistelmiä ja standardien niitä.

· Standardikirjastot ominaisuuksia voidaan määrittää ja osoitetaan mitään muuta arkkitehtuuria. Näiden kirjastojen kutsutaan Standardit. Käyttämällä Standardit, Sinun tarvitsee vain kerätä tiettyihin järjestelmiin ominaisuudet - standardin ominaisuudet ovat jo olemassa. Esimerkiksi standardin suoritusarvot Microsoft Windows 2000 voidaan määrittää mitä osia käytät Microsoft Windows 2000 -käyttöjärjestelmään.

Katso myös

Miten arkkitehtuuri edustettuna ABACUS? | Mitä ABACUS tehdä? | Miten teet sen (yleiskatsaus) | Luodaan uusi tyyppi


ABACUS käyttöliittymä

Navigation: Johdatus ABACUS>

ABACUS käyttöliittymä

Lähetä kommentit tästä aiheesta.

Kun aloitat ABACUS, näet päänäyttö, joka on tyhjä, lukuun ottamatta valikot ja työkalupalkki huipulla, tyhjä Explorer-ikkuna ja otsikko-baari. Tämä näyttö on napa teidän vuorovaikutusta ABACUS.

Pääkohdat ovat:

· päävalikot

· Työkalurivit

· aivan click menu

· tutkimusmatkailija ja omaisuus ikkunat

· tilarivillä

Päävalikot

Valikot on järjestetty loogisessa järjestyksessä.

Valikot ovat seuraavat;

· Tiedosto-valikko- Tiedosto-valikon avulla voit luoda, avata, sulkea, tallentaa, viedä ja julkaista ABACUS tiedostoja. Sen avulla voit luoda, avata, sulkea ja tallentaa ABACUS kirjastotiedostot.

· Muokkaa-valikosta- Muokkaa-valikon avulla voit leikata, kopioida, liittää, poistaa, nimetä uudelleen, etsiä ja lajitella elementitja kumoa / tee uudelleen toimintoja.

· Näytä valikko- Näytä-valikon avulla voit avata tai sulkea eri käyttöliittymä Windows ja tilarivi, Navigoida eteen- ja taaksepäin, siirtyä haluamaasi näkemyksiä ja hallita raporttinäkymät.

· Lisää-valikon- Lisää-valikosta voit lisätä uusia standardit, Malleja, tyyppejä, elementit, näkymäkohtas, Luetteloita, kaavioita, kaavioita, Raportteja ja matriisit.

· Analyysi valikko- Analyysi valikon avulla voit suorittaa arviointeja vastaan ​​arkkitehtuuri mukaan lukien; suorituskyky, hinta, luotettavuus, modulaarisuus ja avoimuus.

· Työkalut-valikko- Työkalut-valikosta voit suorittaa scripting, asettaa tavoitteet arkkitehtuurija suorittaa ja arkkitehtuurin diff ". Voit myös muuttaa ohjelman vaihtoehtoja ja muokata käyttöliittymän työkalun valikosta.

· Ikkuna valikko- Ikkuna-valikosta voit telakka, järjestää, näyttää ja piilottaa ikkunat sinulla on auki.

· Ohje-valikosta- Ohje-valikosta voit käyttää tätä ABACUS ohjetiedoston. Voit käyttää sivustoa, tarkastella lisenssi sopimus ja tarkastella yleisiä tietoja ABACUS lukien ohjelmistoversio ja ABACUS tuki ja yhteystiedot. Voit antaa palautetta kautta kysymys ilmoituksen sivu. Tarvittaessa voit kirjoittaa rekisteröinnin avain Ohje-valikon kautta.

Tämä on järjestyksessä käytät tavallisesti seurata kun olet suorittaessaan tehtävät;Kun olet luonut tai avata tiedosto, Voit normaalisti kertyisi arkkitehtuuri, sitten näkymäse (Explorer, kaaviot, 3D, kaaviot, jne). Tässä vaiheessa voit joko ajaa arvioija, Tai voit toistaa prosessin kanssa samaa arkkitehtuuria tai eri arkkitehtuuri. (Katso Kuinka käyttää ABACUS (yleiskatsaus) lisätietoja.)

Tutustu läpi tärkeimmät valikot ja yrittää kuvitella, miten voit soveltaa niitä omaan järjestelmään.

Huomautus

Sinä pystyt Mukauta valikot milloin vain.

Työkalurivit

Oletuksena on seuraavat työkalurivien;

· Päätyökalurivillä -

· Simulointi työkalurivi -

· Näytä työkalurivi -

· Kaavio työkalubar (jos kaavio on avoin) -

· Makro Äänitys työkalurivi -

Tutustu läpi painikkeita kunkin työkalupalkin leijuu heitä näkemään työkaluvihjeen (pikakuvake-näppäin).

Huomautus

Vain tietyt painikkeet ovat aktiivisia riippuen siitä, mitä olet valinnut Explorer-ikkunan ja voit Mukauta työkalurivit milloin vain.Lisäksi "Vahvista / Check Project rajoitukset -painiketta Päätyökalurivin ja painikkeet Simulaatio työkalupalkin korostetaan Punainen kun muutos taustalla arkistoon vaatii uudelleen validointi hankkeen tai uudelleen simulointi että simulaattori vastaavasti. Vie hiiri painiketta mitkä arkkitehtuurit ovat vaikuttaneet.

Oikealla hiirennapilla

Tärkeimmät valikot ja työkalurivit ovat eirahoittaa kaikkea, vaikka. Usein on mukavampi käyttää hiiren kakkospainikkeella pikavalikko eri toimintoihin. (Myös ei kaikki komennot kautta hiiren kakkospainikkeella ovat saatavilla päävalikot, työkalurivit, tai näppäimistön komentoja.)

Esimerkiksi, kun olet luonut tiedoston, ja sinulla on puu kaavio arkkitehtuurista, se on parempi hiiren kakkospainikkeella arkkitehtuurit puussa lisätä uuden arkkitehtuurin. Vastaavasti et hiiren kakkospainikkeella Komponentit lisättävä komponentti. Klikkaa hiiren oikealla muutamia asioita puussa nähdä mitä voit tehdä.

Kärki

Yleensä voit käyttää päävalikkoon suorittamaan enemmän korkean tason tehtäviä, kuten arviointiin laitealustan. Matalan tason tehtävät - kuten lisäämällä yksittäiset osat ja liitännät - tehdään käyttäen työkalurivit ja / tai oikealla hiirennapilla.

Tutkimusmatkailija ja ominaisuudet ikkunat

Kun avaat tai luoda tiedoston, puu kaavio näyttää Explorer-ikkunassa. Se on ikkuna arkkitehtuurista. Ja kun valitset elementit Explorer -ikkuna kolme muut ikkunat; Yleiset ominaisuudet, Viitteetja ominaisuudet ikkunat päivittyvät yksityiskohtaista tietoa valintasi.

Huomautus

Yleiset ominaisuudet, Viitteetja ominaisuudet ikkunat on piilotettu oletusarvoisesti. Nähdä Mukauttaminen käyttöliittymä kuinka piilotiedostojen niitä ja mahdollisesti jättää ne pysyvästi näkyviin.

Kun olet rakentaa oma arkkitehtuuri, Explorer ja ominaisuudet ikkunat ovat eniten hyötyä edustus. Koska ne voidaan romahti ja laajennetaan tarpeen mukaan ja ne eivät tullut raskas.

Explorer-ikkuna on puu (ja Status bar) ja ominaisuudet ikkunat ovat 5kohdat:

· Tyyppi

· Standardit

· Kuvaus

· Viitteet

· Ominaisuudet

ABACUS pitää kaikki nämä asiat olla osa arkkitehtuuria.

Puu

Tässä osassa on puu ryhmitelty 3 alueille seuraavasti:

1. Meta-malli

· Standardit- Jos useat komponentit on samoja ominaisuuksia, voit määritellä ne etupainotteisesti, ja sitten vain antaa sen komponentteja. Sama koskee liikenteeseen ja muuta ainetta. Näiden sarjaa standardin ominaisuuksia on tallennettu Standardithaara puu. Määrittelyn sijaan jokaisen kiinteistön jokaisen komponentin, ja jokaisen kiinteistön jokaisen yhteyden jne, vain antaa standardi. Esimerkiksi standardin ominaisuudet Unix-HP / UXvoidaan tallentaa Standardi ja sisällyttää mihinkään komponentteja Unix-HP / UXkäyttöjärjestelmä kuten on esitetty OS01 palvelin kuvakaappaus edellä.

· Tyypit - Tämä haara puu on kirjaston eri komponenttien ja yhteyksiä voit käyttää. Tyypit käytetään määrittelemään meta-malli arkkitehtuurista ja luokittelun ja suodatuksen, kun katselet arkkitehtuurista. Ne määräävät myös mallina mitä standardit, Ominaisuudet ja rajoitteet laitteiden / yhteyksiä voi olla.

· Näkökulmia- Näkymäkohtat voidaan luoda olemassa olevista kaavioiden ja voidaan käyttää luomaan uusia kaavioita.Ne ovat kaavio stensiilit.

· Mallit - Mallit myymälä uudelleenkäytettävät malleja komponenttien ja liitännät sekä miten ne ovat edustettuna tai katsella. Ne voidaan ajatella "mini" arkkitehtuureja tai liuoksia, jotka voidaan sijoittaa olemassa oleviin arkkitehtuurit.

2. Arkkitehtuurit -Arkkitehtuurit haara puun on, jossa rakentaa arkkitehtuuri (T) järjestelmään. (Tätä kutsutaan asuttavat arkkitehtuuri.) Voit olla mitään muutamille laitealustoille yhdessä ABACUS tiedosto.

3. Kojelauta - Kojelauta haara puu on, jos voit käyttää mitä tahansa tallennettuja mittaristot projektin.

Huomautus

Tuotteita Explorer puu, joka on ollut heidän Päivitys lupaa poistettu (eli ne ovat vain luettavissa) ne on merkitty harmaalla.

Tyyppi

Tämä osio tarkoittaa tietyn osan tai yhteystyyppi valitun elementin puussa.

Standardit

Tässä osassa on luettelo standardit sillä hetkellä valittu elementti puussa.

Kuvaus

Tässä osassa on lyhyt kuvaus valittu elementti puussa. Siihen liittyvät linkit voidaan myös lisätä tähän osioon. Näitä ovat sivustoja tai paikallisten absoluuttinen polkuja osoittaa lisätietoja tietyn alkuaineen. Useita rivejä ovat sallittuja. Voimassa hyperlinkkejä täytyy aloittaa jollakin 5 jouset; http: //, https: //, ftp: //, file: /// tai mailto :.

Kärki

Hyperlinkkien välilyönteineen, käyttäjät voivat kirjoittaa URL tai polku, valitse haluamasi teksti ja Oikea Valitse| Hyperlinkki. Tämä muuttaa välilyöntejä % 20joten koko URL tai polku toimii oikein.

Luotu ja Modified

Nämä jaksossäätääkäyttäjä ja päivämäärä / aika luomisen, ja viime muutos, valitun elementin puussa.

Viitteet

Tässä osassa on luettelo lähtevien ja saapuvien komponenttien sillä hetkellä valittu elementti puussa.Se osoittaa myös kaaviot, 3D ja karttanäkymien että tällä hetkellä valittu elementti näkyy. Jos kaavio on valittu se näyttää näkökulmasta tarvittaessa varten kaavio ja näkemyksiä yleensä se osoittaa mitään Kojelauta mieltä näkyy. Ja kun Standard valitaan puussa se osoittaa käyttö standardin tyypit, komponentteja ja yhteyksiä.

Ominaisuudet

Tämä osio on, jos ominaisuuksien määrittämiseen elementit arkkitehtuurista, kuten tapa tarvitset sitä tehdä, määrä riviä koodia se on, prosenttiosuus näistä linjat, jotka ovat kommentteja, jne.

"Tulo" ja "tuotos" ominaisuudet valmiiksi rakennettu simulaattorit näytetään Properties ikkunan ominaisuus panos rivi valitsimen kuvaketta ( [image] ) Ja ulostulo kuvake ( [image] ) Vastaavasti työkaluvihje ilmaisee joka valmiiksi rakennettu simulaattori omaisuus liittyy, esimerkiksi "Modulaarisuus Output" tai "Performance Input". Nuoli lähtöikonit korostetaan Punainen ( [image] ), Kun omaisuus on vanhentunut vuoksi olevan kiinteistön tai rakennemuutos arkiston simulaattori vaativat uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tilapalkki

Vasen osa Tilapalkki näyttää koko polun hetkellä tarkennuksen arkistossa elementti, joko valittu Explorer-ikkunassa tai kaavio kangas. Tämä on niin, että tarkka paikka arkistoon hierarkian annetulle elementti voidaan aina helposti määrittää. Oikeanpuoleinen osa Tilapalkki näyttää eri toimintojen viestejä, kuten "Avaa ABACUS Tiedoston Onnistunut" ja "kustannuslaskennan Valmis".

Katso myös

Miten teet sen (yleiskatsaus) | Mukauttaminen käyttöliittymä | Mikä on arkkitehtuuri? | Miten arkkitehtuuri edustettuna ABACUS? | Työskentely ABACUS tiedostoja


Mukauttaminen ABACUS liitäntä

Navigation: Johdatus ABACUS>

Mukauttaminen ABACUS liitäntä

Lähetä kommentit tästä aiheesta.

Voit muuttaa ulkoasua ja käyttäytymistä ABACUS käyttöliittymän monin tavoin. ABACUS sisältää useita valmiita asetuksia yhdistelmiä, joita voit käyttää hakea ryhmä mukauttamistöistä rajapintaan. Lisäksi voit tehdä yksittäisiä mukauttamistöistä kohteille, kuten ikkunoiden, työkalurivien pikanäppäimiä, ja eri näyttöjä vaihtoehtoja.

Järjestä ja Dock Windows

Sinulla on monia vaihtoehtoja järjestämiseksi ikkunoiden sisällä käyttöliittymä ABACUS, mukaan lukien seuraavat:

· Tab-telakka ikkunat.

· Telakka ikkunat reunaan kehyksen käyttöliittymän.

· Minimoida työkalu ikkunat reunaa pitkin rajapinnan.

· Palauta ikkunoiden sijaintiin oletusasetteluun.

Docking Windows

Kun ikkuna on telakointiasema, se voidaan kiinnittää toiselle puolelle kehyksen sisällä liitäntä, tai se voidaan järjestää välilehtien lasien kehyksen sisällä. Opas timantti tulee näkyviin, kun vedät ikkunat niiden nykyisestä sijainnista toiseen paikkaan käyttöliittymä. Opas timantti avulla voit nopeasti uudelleen telakoida ikkunan yksi neljästä puolin rungon tai keskus välilehtiä ruudussa. Kun ikkuna on irralliset tai telakointiasema, se kelluu päälle muut ikkunat.

Telakka ikkunat

1. Napsauta ikkunaa, jota haluat laituriin, antaa sille keskittyä.

2. Käytössä Ikkunavalikosta Telakoitavat.

3. Vedä ikkuna sen nykyisestä sijainnista kohti kehyksen keskelle haluat telakka sitä.

Opas timantti ilmestyy. Neljä nuolet timantti pisteen kohti neljän kehyksen reunoja ja keskelle edustaa välilehtiä ruudussa.

Kärki

Jos haluat siirtää telakointiasema ikkunan napsauttamalla se paikalleen, paina CTRL vetäessäsi sitä.

4. Kun ikkuna vedät saavuttaa asennon, jossa haluat telakoida sen, siirrä osoitinta vastaavan osan oppaan timantti. Ääriviivat ikkunan näkyy osoitetulla alueella.

5. Telakoida ikkunan paikka esitetään, vapauta hiiren painike.

Esimerkiksi, jos Tutkimusmatkailijatelakoitu vasenta reunaa käyttöliittymä ja haluat telakoida sen oikeassa reunassa, voit vetää Tutkimusmatkailijakohti keskellä käyttöliittymä, siirrä osoitinta oikealle puolelle oppaan timantti, ja vapauta sitten hiiren painike.

Minimointi Windows

Windows (ovatko ne Tool Windows - näkymisen Näkymävalikosta, tai asiakirjan Windows - näkymisen Ikkunavalikko) tukea ominaisuus nimeltä Auto Hide. Auto Hide voit nähdä enemmän arkkitehtuuria kerralla minimoimalla ikkunat reunoja pitkin rajapinnan kun sitä ei käytetä.

Voit ottaa Auto Hide

1. Napsauta ikkunan haluat piilottaa antaa sille keskittyä.

2. Käytössä Ikkunavalikosta Auto Hide.

- tai -

2. Napsauta nastaa kuvaketta otsikkorivillä ikkunan.

Auto Hide Käytössä

Kun automaattinen piilotettu ikkuna menettää keskittyä, se liukuu automaattisesti takaisin sen välilehti reunalla käyttöliittymä. Kun ikkuna on automaattisesti piilossa, sen nimi ja kuvake näkyvät välilehden reunalla käyttöliittymä. Näyttää automaattisen piilotettu ikkuna, siirrä osoitinta välilehti. Ikkuna liukuu takaisin katsella ja on käyttövalmis.

Huomautus

Ikkuna, joka on automaattinen piilotettu ei voida viedä. Voit kiinnittää ikkuna sinun tulee sammuttaa Auto Hide alla kuvatulla tavalla.

Sammuttaa Auto Hide

1. Napsauta ikkunan haluat pitää näkyvissä antaa sille keskittyä.

2. Käytössä Ikkunavalikosta Auto Hidepoista valintamerkki.

- tai -

2. Napsauta nastaa kuvaketta otsikkorivillä ikkunan.

Auto Piilota Vammaiset

Kärki

Ikkunat ovat Auto Hide sallittuna väliaikaisesti liukua näkyviin, kun ikkuna on keskittyä. Piilota ikkuna uudelleen, valitse kohde ulkopuolella nykyisen ikkunan. Kun ikkuna menettää keskittyä, se liukuu takaisin pois näkyvistä.

Nollaaminen Windows Ulkoasut

Voit palata käyttöliittymän oletus asettelu käyttäen Palauta ikkuna Layout komento. Kun olet suorittanut tämän komennon, seuraavat toiminnot tapahtuvat:

· Kaikki ikkunat siirretään niiden oletuksena kantoja.

· Ikkunat ovat kiinni oletuksena asettelu suljetaan komennolla.

· Ikkunat ovat avoinna oletus asettelu avataan komennolla.

· Ikkunat ovat piilossa / näkyvissä oletuksena asettelu tehdään piilossa / näkyväksi komennon.

Voit palauttaa ikkunoiden sijaintiin oletusasetteluun

1. Käytössä Windowsvalikosta Palauta ikkuna Layout.

Kustomointi Valikot ja työkalurivit

Voit vaihtaa asettelun asema, ja sisältö valikot ja työkalurivit käyttöliittymän. Voit myös lisätä painikkeita työkalurivit ja muuttaa osoitettu kuvaketta tahansa painiketta.

Luo uusi työkalurivejä

Luoda uuden työkalupalkin

1. Käytössä Työkalutvalikosta Muokkaa.

2. Vuonna Muokkaavalintaikkunassa Työkalurivitvälilehti.

3. Valita Uusi.

4. Vuonna Uusi Toolbar-valintaikkunassa nimi työkalupalkin.

5. Valita Kunnossa.

Lisätä komennon painiketta valikon tai työkalurivin

1. Käytössä Työkalutvalikosta Muokkaa.

2. Vuonna Muokkaavalintaikkunassa Komennotvälilehti.

3. Valitse luokka ja vedä komento ulos valintaikkunan valikosta tai työkaluriviltä.

4. Valita Lähellä.

Kärki

Pitämällä Alt-näppäimen avulla voit nopeasti muokata komentoja ikään Muokkaa dialogi oli auki.

Katso myös

ABACUS käyttöliittymä


Työskentely ABACUS tiedostoja

Navigation: Johdatus ABACUS>

Työskentely ABACUS tiedostoja

Lähetä kommentit tästä aiheesta.

ABACUS tiedosto on säiliö malli teidän arkkitehtuuri . Sisällä yhden ABACUS tiedosto, voit mallintaa minkä tahansa määrän arkkitehtuurit monta kertaa tahansa.

Kun avaat ABACUS, ei ole tiedostoja auki. Työskennellä teidän arkkitehtuuri, sinun täytyy joko luoda uuden tiedoston, tai avaa olemassa olevan tiedoston.

Kun avaat tai luoda uuden tiedoston, puu Explorer-ikkuna näyttää automaattisesti. Tämä Explorerissa Näytä näyttää sinulle arkkitehtuuri tasalla. Kun suljet tiedoston, puu Explorer-ikkuna katoavat myös.

Luoda uuden ABACUS tiedosto

1. Valita Tiedosto| Uusi ...

2. Uusi projekti -valintataulussa näyttöön (kuten alla) Valitajoko luoda tyhjän malli, malli standardi ABACUS kirjasto , Malli mukautetun ABACUS kirjasto, malli XML, MS Access , MS Visio , MS Excel , MS SQL Server , Yritys Palvelin malli tai mukautetun ABACUS kirjasto (.abacuslib tiedosto).

3. Klikkaa Kunnossapainiketta ja noudata ohjeita valintaikkunat voivat näkyä.

Kärki

Et pyydetään nimeä tiedosto kunnes tallennat tai suljet sen. Se on hyvä idea tallentaa tiedoston heti luoda sitä. Niin sinun ei tarvitse huolehtia nimeämällä se myöhemmin prosessissa kun olet keskittyä muihin monimutkaisia ​​asioita (kuten asuttavat arkkitehtuurista).

Luo uusi projekti

ABACUS Standard Kirjastot

ABACUS tukee yli 100 julkinen puitteet ja merkinnät joista muutamia alla. Kun valitset luoda uusi projekti standardin kirjasto käyttäjillä on nopea alku mallinnus sisällä luoda puitteet täysimääräinen erikseen määriteltyä elementin, ominaisuudet, merkinnät, näkökulmia ja malleja tai malleja. Muita standardi kirjastot ovat vapaasti saatavilla Avolution yhteisön tässä .

Uusi projekti Standard Library

Voit tallentaa uuden ABACUS tiedosto

1. Valita Tiedosto| Tallenna nimellä

Kärki

Tiedostonimet voi olla mikä tahansa pituus, ja voivat sisältää mitä tahansa aakkosnumeerisia merkkejä ja välilyöntejä. He eivät voi sisältää tilde (~) merkki, putki (|) merkki, kysymysmerkki (?), Tai merkkejä tavallisesti käytetään polku kuvaukset, kuten kenoviiva (\) - muutoin kuin osana polku.

Voit avata olemassa olevan ABACUS tiedosto

1. Valita Tiedosto| Avata

Huomautus

Jos avaat tiedoston jaetun verkon paikkaan, joka on jo avoinna toiselle käyttäjälle, ABACUS saat vain luku pääsy. Käytettäessä ABACUS vain luku pääsy, et voi suorittaa kirjoitustoimintoja, kuten asuttavat arkkitehtuurista ja käynnissä arvioijat. Voit kuitenkin tarkastella arkkitehtuuri käyttäen Explorerissa Näytä ja 3D-näkymät.

Katso myös

Miten arkkitehtuuri edustettuna ABACUS?


Miten arkkitehtuuri edustettuna ABACUS?

Navigation: Johdatus ABACUS>

Miten arkkitehtuuri edustettuna ABACUS?

Lähetä kommentit tästä aiheesta.

Abacus, voit mallintaa arkkitehtuuria. Yksinkertaisuuden, me kutsumme tätä arkkitehtuurin malli arkkitehtuuri.

Kaaviossa on kuvattu, miten tyypillinen arkkitehtuuri 5komponentit (Hierarkiassa) yhdistetty 2 yhteydet olisivat edustettuina ABACUS.

Miten yksinkertainen arkkitehtuuri on edustettuna ABACUS

Voit olla mitään muutamille laitealustoille yhdessä ABACUS tiedosto.

Ensimmäinen arkkitehtuuri puussa

Yleensä voit luoda uuden arkkitehtuurin kun haluat arvioida muutoksen. Esimerkiksi, haluat malli nykyisen arkkitehtuurin ensimmäinen - tämä olisi ensimmäinen arkkitehtuuri puussa. Sitä voisi kutsua "Nykyinen".

Toinen

Kun haluat mallintaa ja arvioida muutos nykyiseen arkkitehtuuriin (esim lisääntynyt vaatimukset) haluat luoda uuden arkkitehtuurin. Helpoin tapa tehdä tämä olisi luoda kopio "Nykyinen" ja nimeä se "Evolution 1 Yritä 1 '. Tämä olisi toinen arkkitehtuuri puussa. Jos arviointeja "Evolution 1 Yritä 1 'ovat onnistuneita, voit nimetä sen yksinkertaisesti" Evolution 1 ".

Kolmas

Jos "Evolution 1 Yritä 1 'ei täytä tarpeitasi, voit luoda siitä kopion, nimeä se uudelleen" Evolution 1 Yritä 2', ja yritä uudelleen. Tämä olisi kolmas arkkitehtuuri puussa.

Katso myös

Mitä ABACUS tehdä? | Miten teet sen (yleiskatsaus) | Mikä on arkkitehtuuri? | Työskentely ABACUS tiedostoja | Luominen tai toistamatta arkkitehtuuri


Ohje muilla kielillä

Navigation: Johdatus ABACUS>

Ohje muilla kielillä

Lähetä kommentit tästä aiheesta.

ABACUS apua on saatavilla eri muita kieliä / käännökset ja voi ladata alla olevista linkeistä.

Jotta korvaa nykyisen ABACUS ohjetiedostonjossa käännetty ohjetiedoston toimi seuraavasti:

1. Tallenna ohjetiedoston asianomaisesta linkistä.

2. Nimeä apua tiedosto ABACUS.chm.

3. Avaa tiedosto kaksoisnapsauttamalla sitä ja jos "Avaa tiedosto - Suojausvaroitus -valintaikkuna tulee näyttöön ja poista" Kysy aina ennen kuin avaat tiedosto "vaihtoehto ja valitse Avaa.

4. Sulje tiedosto.

5. Korvaa ABACUS.chm tiedoston ABACUS Program Files -kansioon, tyypillisesti "C: \ Program Files \ Avolution \ ABACUS" tai "C: \ Program Files(X86)\ Avolution \ ABACUS".

Huomautus

Tilannekohtainen ohje jatkaa kanssa käännetty ohjetiedostoissa.

ABACUS ohjetiedostot muilla kielillä:

· Arabialainen / العربية .

· Bulgarialainen / български .

· Kiina (yksinkertaistettu) / 中文 (简体) .

· Tšekin / Česká .

· Tanskan kieli / Dansk .

· Virolainen / Eesti .

· Suomi / Suomen .

· Ranska / Français .

· Saksan kieli / Deutsch .

· Unkarin kieli / Magyar .

· Islantilainen / Islantilainen .

· Indonesialainen / Indonesia .

· Italialainen / Italiano .

· Japani / 日本 の .

· Latvialainen / Latvijas .

· Malesian / Malesia .

· Maltalainen / Maltaat i .

· Norweigen / Norweigen .

· Kiillottaa / Po lska .

· Portugali / Português .

· Venäjän kieli / русский .

· Slovakian / Slovenski .

· Slovenian / Slovenski .

· Espanja / Españoles .

· Ruotsi / Svenska .

· Turkki / Türk .

· Walesin / Cymraeg .

Katso myös

Mitä ABACUS tehdä?


Populating arkkitehtuurista

Navigation: Asuttavat arkkitehtuurista>

Populating arkkitehtuurista

Lähetä kommentit tästä aiheesta.

Rakentamassa mallin laitealustan tunnetaan jäsenöittäminen. Kun olet löytänyt oman arkkitehtuuri ja tunnistanut vaatimuksia, olet valmis mallintaa arkkitehtuurin ABACUS.

Aikana väestö, annat kaikki yksityiskohdat tiedät arkkitehtuuri ja mitä tarvitaan sen.

Kertyisi arkkitehtuuri

1. Varmista, että käytössä ABACUS tiedosto auki , tutkimusmatkailija näytetään , Ja arkkitehtuuri lisätty .

2. Manuaalisesti asuttaa ylemmän tason komponentteja ja yhteyksiä oman arkkitehtuurin. Tyypillisesti tämä on enemmän abstrakteja komponentteja ja yhteyksiä.

- tai -

2. Graafisesti asuttaa komponentteja ja yhteyksiä, jotka haluaisit katso edustaa kaavamaisesti, käyttäen Piirtotyökalu .

Voit myös haluta

3. Asuttaa käyttämällä Luettelot - Voit katsella ja komponentit ja yhteyksien yksinkertaisella taulukkomuodossa tavalla.

4. Asuttaa käyttäen Matriisit - Voit tarkastella ja muokata yhteydet laitteiden välillä yksinkertaisesti taulukkomuodossa tavalla.

5. Asuttaa Microsoft Access - Voit tuoda arkkitehtuuria ja vienti Microsoft Access.

6. Asuttaa Microsoft Visio - Voit tuoda arkkitehtuuria ja vienti Microsoft Visio.

7. Asuttaa Microsoft Excel - Voit tuoda arkkitehtuuria ja vienti Microsoft Excel.

8. Asuttaa Microsoft SharePoint - Voit tuoda arkkitehtuuria ja vienti Microsoft SQL Server.

9. Asuttaa Microsoft SQL Server - Voit tuoda arkkitehtuuri Microsoft SQL Server.

10. Tuo XML - Voit tuoda arkkitehtuurin ABACUS XML-fragmentti tai ArchiMaten Interchange Kieli XML-tiedoston.

Katso myös

Asuttavat arkkitehtuurista manuaalisesti | Piirtotyökalu | Asuttavat arkkitehtuurista Microsoft Access | Asuttavat arkkitehtuurista Microsoft Visio | Asuttavat arkkitehtuurista Microsoft Excel


Asuttavat arkkitehtuurista manuaalisesti

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti>

Asuttavat arkkitehtuurista manuaalisesti

Lähetä kommentit tästä aiheesta.

Ylemmän tason komponentteja ja yhteyksiä oman arkkitehtuurin täytyy todennäköisesti asuttu käsin. Tyypillisesti tämä on enemmän abstrakteja komponentteja ja yhteyksiä.

Manuaalisesti kertyisi arkkitehtuuri

1. Varmista, että käytössä ABACUS tiedostoavoin, tutkimusmatkailijanäyttöön, ja arkkitehtuuri lisätty .

2. Lisää osa. Tehdä tämä, Hiiren kakkospainikkeellasen alueen puu haluat asuttamaan, ja valitse Lisää Alakomponentti ...Tai napsauta Uusi komponenttipainiketta Näytä työkalupalkki . Komponentit voidaan lisätä vain alle osat haara puu. Haluat puu kaavio on tarkka esitys arkkitehtuurista. Kun olet löytänyt oman arkkitehtuuri, olette oppineet, miten kaikki sopii yhteen. Tarvitset tätä tietoa, kun lisäät laitteiden ja yhteyksien. Jos lisäät ensimmäinen komponentti, voit lisätä sen suoraan Components haara. Loput komponentit voivat olla joko samalla tasolla puussa, tai ne voivat olla alakomponenttien ensin.

3. Päivittää arvotominaisuudetKunkin komponentin lisäät sen. Tehdä tämä, napsahduskomponentin, ja muokata ominaisuuksia näytetään Ominaisuudet ikkuna(Tyypillisesti) oikealle. Ominaisuudet ovat yleensä asioita, kuten vaatimuksia, jalostuskapasiteettia, jne. Kun ABACUS arvioi arkkitehtuurista, se laskee joitakin uusia ominaisuuksia, ja tallentaa ne takaisin arkkitehtuuriin. Uudet ominaisuudet ovat tiedot yrität analysoida, kuten käyttöaste, vasteaika, kaistanleveys, jne.

4. Lisää yhteyksiä ja päivittääniiden ominaisuudetkuten mennä - aivan kuten teet komponenttien (mutta alle yhteydet haara puu).

5. Liittääliitännät ja komponentit. Voit tehdä tämän, etsi yhteys, napsauta yhtä sen päättyy tai roolit , Ja vedä se komponentti. Voit myös napsauttaa komponentti ja vedä se yksi liittymän roolit (eli joko lähde tai upota). Tai voit hiiren kakkospainikkeella ja vedä komponentti toiselle komponentti ja valitse Yhdistää. Tai yksinkertaisesti hiiren kakkospainikkeella komponenttia ja valitse Yhdistä .... Kun vedät yhteys rooli, Huomaat pikakuvakkeen symboli, kun osoitat komponentti voit liittää sen. Tämä tarkoittaa, että et ole tehdä kopio, olet juuri kytkenyt sen. Varmista, että kiinnitä se oikeaan kohteeseen komponentti. Esimerkiksi, jos se on liittymän Source rooli, Vedä se tehdä lähdelaite (eli komponentti, joka on lähde tietovirta).

Kärki

Re-tilaus yksiköiden omassa arkkitehtuuri (esim komponentit, yhteydet jne.) Vuonna tutkimusmatkailijaon melko helppoa. Yksinkertaisesti Klikkaa| Pitää| Vetääasiaankuuluvien tahojen kanssa ja missä halutaan arkkitehtuurista. Uudelleenjärjestämisen toimintoja myös voit sijoittaa yhteisöjä eri hierarkioita arkkitehtuurista.

Voit myös haluta

6. Lisää Standardit (Valmiiksi konfiguroitu sarjaa ominaisuudet - esiasetukset) laitteeseen ja, liitoksia tai tyypit

7. Muuttaa ominaisuuksia komponentin, yhteyden tai tyyppi

8. Kumoa ja Tee uudelleen toiminnot

9. Muuta tyyppi komponentin tai yhteys

10. Luo uusi tyyppi tai tyhmä

11. Poistaa komponentti tai liitäntä

12. Luo, kopioida tai kehittyä arkkitehtuuri

13. Tuo tyypit ja standardit kirjastosta

14. Tuo toisesta ABACUS tiedoston, XML, Excel tai Visio

15. Kopioi ja liitä osat (tai kaikki) laitealustan

16. Etsi ja korvaa kohteita arkkitehtuuri

17. Laajenna / Pienennä jotkin tai kaikki solmut puussa

18. Yhdistää kohdetta

19. Määritellä ja Vahvistaa Rajoitteet rajoittaa rakenteen ja arkkitehtuuri

20. Kehitä arkkitehtuuri luoda useita arkkitehtonisia ratkaisuja vertailla ja perustason

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Luodaan uusi tiedosto


Kumoa ja Tee uudelleen

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Kumoa ja Tee uudelleen

Lähetä kommentit tästä aiheesta.

Kuten monet nykyajan sovelluksia, ABACUS tukee kyky sekä kumota ja tehdä uudelleen viime käyttäjä tehdyt muutokset Avaa projekti. Jos haluat kumota viimeisimmän muutos, yksinkertaisesti aktivoida kumoa komento. Muutokset, jotka on kumota voidaan redone aktivoimalla redo komento; uudelleen soveltamalla viimeksi tekemättä muutoksia.

Varoitus

Tekemättä muutoksia eivät voi kiinnittää uudelleen, jos uusia muutoksia tehdään hankkeeseen, koska on perua.

Huomautus

Vaikka valtaosa muutokset tukevat kumoa / tee uudelleen reaaliajassa, jotkut kaavio sapluuna muutoksia, kuten luoda uusi tyyppi-Shape / Line yhdistys tai muuttamalla yhdistys värimääritteessä, eivät voi voi kumota välittömästi. Näissä tapauksissa, modifioitu kaavio (merkitty tähdellä) on oltava kiinni ennen kuin nämä muutokset voidaan kumota.

Kumoa ja Tee uudelleen komento sijainnit

Kumoa ja Tee uudelleen komentoja voidaan pääsee kolmella eri paikkakunnalla:

· Muokkaa-valikosta

· vakiotyökalurivin

· näppäimistön pikanäppäimet CTRL + Z(Kumoa) ja CTRL + Y(Toista)

Kärki

Kumoa ja Tee uudelleen painikkeita vakiotyökalurivillä tarjoavat avattavasta luettelot näytetään 10 viimeisintä muutoksia, jotka voidaan kumota ja on redone vastaavasti. Ne ovat myös kätevä tapa kumoa / tee uudelleen useita muutoksia kerralla.


Muuttaminen komponentti / yhteyden tyyppi

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Muuttaminen komponentti / yhteyden tyyppi

Lähetä kommentit tästä aiheesta.

Komponentti ja yhteystyypit käytetään pääasiassa luokittelua varten. Voit käyttää erilaisia ​​suodattimia, kun katselet arkkitehtuurista. Esimerkiksi sen sijaan katsella koko asia, voit katsella vain sovelluskomponenttien.

Muuttaa osan / yhteyden tyyppi

1. Hiiren kakkospainikkeellakomponentin tai yhteyden.

2. Valita Muuta tyyppi.

3. Valitse erityyppinen listasta.

Kärki

Kun muutat tyyppi, voit saada uusia standardittai ominaisuudet (mikä liittyy Tyyppi - katso tyypit haara puu). Olemassa olevat standardit ja ominaisuudet säilyvät ennallaan. Voit luoda omia uudenlaisia ​​ja määrittää itse yhdistelmät standardit ja ominaisuuksia niitä.

Katso myös

Luodaan uusi tyyppi | Asuttavat arkkitehtuurista - Yleistä | Analysointi arkkitehtuurista


Luodaan uusi komponentti / yhteyden tyypin tai tyhmä

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Luodaan uusi komponentti / yhteyden tyypin tai tyhmä

Lähetä kommentit tästä aiheesta.

Komponentti ja yhteystyypit käytetään pääasiassa luokittelua varten. Voit käyttää erilaisia ​​suodattimia, kun katselet arkkitehtuurista. Esimerkiksi sen sijaan katsella koko asia, voit katsella vain sovelluskomponenttien.

Luoda uuden osan / liitäntä Tyyppi

Huomautus

Voit lisätä tyypit tai tyypin ryhmien ABACUS projektissa käyttäjän lisenssi tarvitsee Designer lisäosa ominaisuus. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

1. Laajenna Tyypithaara puu.

2. Hiiren kakkospainikkeellapäällä Komponentti Tyypit (tai Liitäntä tyypit).

3. Valita Lisää Komponentti Tyyppi (tai Lisää Yhteyden tyyppi) tai Luo ryhmä.

Kärki

Kun olet luonut tyyppi, vaihda sen kuvake (katso alla) ja lisää ominaisuudet ja standardit sille osan tai yhteyden ilmentymät "perivät".

Muuttaa kuvaketta osan / yhteyden tyyppi

Huomautus

Muuttaa kuvakkeet tyyppien ABACUS projektissa käyttäjän lisenssi tarvitsee Designer lisäosa ominaisuus. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

1. Hiiren kakkospainikkeellakoskevat Komponentti Tyyppi (tai Yhteyden tyyppi) Haluat muuttaa kuvaketta.

2. Valita Vaihda kuvake.

3. Valitse Valitse kuvake valintaikkunan Selaa sijainti ja valitse kuvatiedosto ja napsauta Avaa.

Huomautus

Voit olla mukautettua kuvaketta kuvan kaikenkokoisille mutta se aina sovitetaan ja 16x16 pikselin kuva Explorer -ikkunan. Joten jos alkuperäinen custom kuvake kuva ei ole yhtä korkeus ja leveys teidän Explorer -ikkunan kuvake venytetään. Näin ollen, custom kuvat tulisi olla vähintään 16x16 pikseliä ja jos haluat säilyttää tarkka muoto mukautetun kuvakkeen varmista, että mukautetun kuvakkeen kuva on sama korkeus ja leveys pikseleinä (16x16 tai uudempi). Sinun pitäisi myös olla varovainen, joilla ei ole värjätty "pikseliä" menee aina rajalle mukautetun kuvakkeen kuvan se näyttää köyhiä Explorer -ikkunan, jonka vieressä kuvakkeet "verenvuotoa" toisiinsa. Näin ollen, sinun pitäisi odottaa ainakin 1 pikselin valkoinen reuna.

Kärki

Voit tehdä muokatun kuvakkeen kuva Ico, .bmp, .gif, .jpg tai .png-muotoisen tiedoston, mutta koska rajoitus vain Windows ICO muodossa esikatsella vuonna ABACUS Valitse Icon dialogi jos sinulla View Menu-vaihtoehto asetettu mitään muuta kuin Miniatyyrit.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Analysointi arkkitehtuurista


Poistaminen komponentti tai liitäntä

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Poistaminen komponentti tai liitäntä

Lähetä kommentit tästä aiheesta.

Voit poistaa osan tai yhteys

1. Hiiren kakkospainikkeellakomponentin tai yhteyden.

2. Valita Poistaa.

Varovaisuus

ABACUS varoittaa sinua joka näkymät vaikuttavat poistetaan ja pyytää sinua vahvistamaan poisto. Tämä johtuu siitä, että elementit voivat olla monissa kaavioiden ja se kannattaa tarkistaa, mitä ehdotettu poistaminen vaikuttaa.

Kärki

Jos poistat komponentin, kaikki sen osa-komponentteja poistetaan myös. Voit poistaa sisäiset ja ulkoiset yhteydet komponentti. Jos et halua poistaa ne, yhteydet se on liitteenä ja pysyy, mutta ne eivät enää liitetään. Kaikki komponentit ja liitännät ovat tietyn Tyyppi . Poistaminen komponentti / liitäntä ei ole vaikutusta Kirjoita (tyypit haara puu). Vastaavasti, jos osa / yhteys on Standardi osoitettu, poistaminen ei ole vaikutusta mestari standardien haara.

Katso myös

Asuttavat arkkitehtuurista - Yleistä


Luominen tai toistamatta arkkitehtuuri

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Luominen tai toistamatta arkkitehtuuri

Lähetä kommentit tästä aiheesta.

Voit olla mitään muutamille laitealustoille yhdessä ABACUS tiedosto. Yleensä haluat luoda uuden arkkitehtuurin joka kerta kun haluat mallintaa ja arvioida kehitystä järjestelmään.

Luoda uuden arkkitehtuuri

1. Hiiren kakkospainikkeellakoskevat Arkkitehtuurithaara puu.

2. Valita Uusi arkkitehtuuri.

Voit luoda kopion olemassa olevan arkkitehtuuri

1. Hiiren kakkospainikkeellaarkkitehtuurista.

2. Valita Kopioida.

3. Hiiren kakkospainikkeellakoskevat Arkkitehtuurithaara puu.

4. Valita Tahna.

5. Uutta rakennetta kutsutaan "kopio ...".

Kehittyä nykyisiä arkkitehtuuri

1. Hiiren kakkospainikkeellaarkkitehtuurista.

2. Valita Kehittää.

3. Uutta rakennetta kutsutaan "... 0,1".

Huomautus

On yksityiskohtainen kuvaus kehittyvään arkkitehtuureille tässä .

Katso myös

Miten arkkitehtuuri edustettuna ABACUS | Kehittyvä arkkitehtuurista


Tuominen osaksi Arkkitehtuuri

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Tuominen osaksi Arkkitehtuuri

Lähetä kommentit tästä aiheesta.

ABACUS voit tuontia arkkitehtuurista alkaen .abacus (ABACUS tiedosto), .xml (ABACUS XML-fragmentti tai ArchiMaten Interchange kieli XML-tiedosto), .vsd (Microsoft Visio) -muodossa, ja .xls (Microsoft Excel) -muodossa. Näin voit rakentaa arkkitehtuuri ulkoisista lähteistä nopeasti.

Jotta tuoda maahan arkkitehtuurista alkaen.abacus (ABACUS tiedosto)

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Hiiren kakkospainikkeellaon Arkkitehtuuri solmu, kaikki arkkitehtuuri teidän mallia tai mitään osaa Components puu.

3. Valita Tuoda maahan| Alkaen Tiedoston ...valikosta.

4. Valitse sijainti ja .abacus tiedosto ja valitse Avatapainiketta.

Huomautus

Kun olet valinnut tiedoston, jonka haluat tuoda, sinulta kysytään, miten haluat tuoda standardien, tyypitja näkökulmia. Voit tuoda standardit, tyypit ja näkökulmia joko uusien tai yhdistää standardeja, tyypitja näkökulmia. Oletusasetus on standardeja, tyypit ja näkökulmia yhdistetään nykyisten standardien, tyypit ja näkökulmia jos ne ovat jo olemassa (Sama tarkka nimi) teidän hanke.

Jotta tuoda maahanarkkitehtuurista alkaen.xml (ABACUS XML-fragmentti tai ArchiMaten Interchange kieli XML-tiedosto)

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Hiiren kakkospainikkeellaon Arkkitehtuuri solmu, kaikki arkkitehtuuri teidän mallia tai mitään osaa Component puu.

3. Valita Tuoda maahan| Alkaen XML ...valikosta.

4. Valitse sijainti ja .xml tiedosto ja valitse Avatapainiketta.

Huomautus

ABACUS vain tuoda oikein muodostettu ABACUS XML-fragmentti tai ArchiMaten Interchange Kieli XML-tiedoston. Kun olet valinnut XML-tiedosto, jonka haluat tuoda, sinulta kysytään, miten haluat tuoda standardien, tyypitja näkökulmia. Voit tuoda standardit, tyypit ja näkökulmia joko uusien tai yhdistää standardeja, tyypitja näkökulmia. Oletusasetus on standardeja, tyypit ja näkökulmia yhdistetään nykyisten standardien, tyypit ja näkökulmia jos ne ovat jo olemassa (Sama tarkka nimi) teidän hanke.

Jotta tuoda maahanarkkitehtuurista alkaen.VSD(Visiotiedosto)nähdä tässä .

Jotta tuoda maahanarkkitehtuurista alkaen.xls (Excel-tiedosto)nähdä tässä .


Tuominen tyypit ja standardit kirjastosta

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Tuominen tyypit ja standardit kirjastosta

Lähetä kommentit tästä aiheesta.

Voit tuoda erilaisia ​​ja standardeja ABACUS kirjastotiedosto. Voit myös viedä tyypit ja standardit teidän ABACUS tiedoston ABACUS kirjastotiedosto.

Voit tuoda tyypit ja standardit kirjastosta omalle arkkitehtuuri

1. Varmista, että käytössä ABACUS tiedostoavoin ja Explorer-ikkunanäyttöön.

2. Valitse File | Avataavata ABACUS kirjastotiedosto.

3. ABACUS Kirjasto avataan toinen välilehtiä arkki Explorer-ikkuna ja joudut irrota tämä välilehtiä arkki pystyä vetää-ja-pudota se alkuperäiseen ABACUS tiedosto.

4. Raahaa ja pudotatyypit ja standardit kokoelmasta omaan arkkitehtuuriin.

- tai -

1. Valitse File | Uusi ...

2. Luo uusi ABACUS tiedostoperustuvat ABACUS kirjastotiedosto.

Voit viedä tyypit ja standardit teidän arkkitehtuuria kirjasto

1. Varmista, että käytössä ABACUS tiedostoauki, Explorer-ikkunanäkyvissä, ABACUS kirjastotiedostoavoin ja Kirjasto ikkunanäyttöön.

2. Raahaa ja pudotatyypit ja standardit teidän arkkitehtuuri kirjastoon.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti


Kopiointi ja liittäminen

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Kopiointi ja liittäminen

Lähetä kommentit tästä aiheesta.

Voit kopioida osan tai kaikki arkkitehtuurin ja liitä se toiseen paikkaan puussa.

Kopioida

1. Hiiren kakkospainikkeellasiinä kohdassa, jonka haluat kopioida.

2. Valita Kopioida.

Liittää

1. Navigoi puu löytää paikka haluat liittää kohteen.

2. Hiiren kakkospainikkeellaoksalla haluat sen näkyvän sisällä.

3. Valita Tahna.

4. Tuote kopioidaan alkuperäisen nimen (ellet kopioida sen alkuperäiseen haara - se kutsutaan "kopio ...").

Katso myös

Miten arkkitehtuuri edustettuna ABACUS


Etsiminen ja korvaaminen tuotteita arkkitehtuuri

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Etsiminen ja korvaaminen tuotteita arkkitehtuuri

Lähetä kommentit tästä aiheesta.

Voit löytää ja korvaa erityinen osa, yhteys, tyyppi, standardi tai omaisuuden käyttämällä ABACUS "Etsi ja korvaa laitos.

Löytää kohteen

1. Napsauta solmu puun haluat hakuja.

2. Valita Muokata| Löytäätai paina Ctrl + F.

3. Syötä teksti Tuotelöytää "Etsittävä-kenttään.

4. Klikkaa Etsi seuraava.

Jotta korvata esine

1. Napsauta solmu puun haluat hakuja.

2. Valita Muokata| Korvatatai paina Ctrl + H.

3. Syötä tekstiTuotelöytää "Etsittävä-kenttään ja teksti korvata se on" Korvaa-kenttään (Tai mitään, jos kenttä jätetään tyhjäksi).

4. Klikkaa Etsi seuraavalöytää ensimmäisen oikeusasteen "Etsi mitä" teksti ja napsauta Korvata korvata tässä tapauksessa kanssa "Korvaa" teksti tai napsauta Korvaa kaikkikorvata kaikki tapaukset.

Sinulla on vaihtoehtoja:

o Match asiaansa,

o Match koko sanan,

o Etsi alusta hankkeen,

o Ohita arkkitehtuurit - että on arkkitehtuuri solmut itse. Mikä tahansa solmujen alapuolella arkkitehtuuri solmut kuten komponentit ja yhteydet edelleen etsitään,

o Ohita komponentit - että on komponentti solmut itse,

o Ohita liitännät - että on yhteys solmut itse,

o Ohita standardit - eli kaikki arkkitehtuuri, komponentti ja liitäntä standardi solmut ohitetaan,

o Ohita tyyppejä - se on tyyppi solmut itse. Mikä tahansa rajoitus solmut alla tyypin solmut edelleen etsitään,

o Ohita malleja ja sisältö - että on malli solmut itsensä sekä kaikki mallin komponentti ja liitäntä solmut niiden alla,

o Ohita ominaisuudet - että on kaikki omaisuus tyypit, nimet, arvot ja yksiköt kaikkien mallin elementit ohitetaan,

o Ohita kuvauksia - että on kuvaukset kaikista mallin elementit ohitetaan.

Katso myös

Miten arkkitehtuuri edustettuna ABACUS


Laajentaminen ja romahtamassa puu

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Laajentaminen ja romahtamassa puu

Lähetä kommentit tästä aiheesta.

Kun solmun puussa alaerien ja kokoelmia, sillä on pieni [image] tai [image] merkki on sen vasemmalla. Voit napsauttamalla [image] laajentaa solmu ja nähdä sen alaerien ja yhteyksiä. Samoin voit napsauttaa [image] romahtaa solmu piilottaa osa-komponentteja ja yhteyksiä (jotta enemmän tilaa tai tehkää puu helpompi ymmärtää).

Vaihtoehtoisesti voit laajentaa koko solmu, jolloin kaikki sen osa-solmut laajennetaan myös, ja niiden osa-solmujen ja heidän ... jne. Samoin voit romahtaa koko solmu - sulkeminen useita tasoja kerralla .

Lisäksi on vaihtoehtoja laajentaa vain arkkitehtuurit, elementit (eli komponentit ja liitännät), osia tai liittimiä.

Laajentaa tai tiivistää koko solmu (ja sen osa-solmut, jne)

1. Hiiren kakkospainikkeellasolmua.

2. Valita Laajenna | Kaikki tai Romahdus.

Jos haluat laajentaa kaikki architecture (s)

1. Hiiren kakkospainikkeellakoskevat arkkitehtuurit tai arkkitehtuuri.

2. Valita Laajenna | Kaikki.

Laajentaa elementit

1. Hiiren kakkospainikkeellakoskevat arkkitehtuurit tai arkkitehtuuri.

2. Valita Laajenna | Elements.

Laajentaa komponentit

1. Hiiren kakkospainikkeellaosista, komponentti tai osa-komponentti.

2. Valita Laajenna | Komponentit | Kaikki.

Laajentaa yhteyksiä

1. Hiiren kakkospainikkeellayhteyksistä, yhteys tai osa-yhteys.

2. Valita Laajenna | Liitännät | Kaikki.


Sulautuvien kohdetta

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Sulautuvien kohdetta

Lähetä kommentit tästä aiheesta.

Koska yhdistät kohdetta?

Sinun olisi yhdistää kohteita, kun sinulla on kaksi (tai enemmän) esineitä teidän malli parhaiten edustaa kertaalleen. On monia tilanteita, jolloin saatat haluta tehdä tämän, mukaan lukien:

· Seurauksena tuoda uudet tiedot mallisi joka voi päällekkäisiä tai korvata olemassa olevaa tietoa. Esimerkiksi jos tuot päivitetyn version taulukkosi mallisi.

· Ajan kaksoiskappaleet "saman" komponentti on luotu ja haluat siivota nämä kaksoiskappaleet.

· Jos suoritat mitä jos skenaario ja kohteita olet mallinnus todella sulautuvat todellisuudessa. Esimerkiksi, jos olet yhdistämällä kaksi osastojen organisaation, tai jos sulautuvat kaksi palvelinta.

Mitä voidaan yhdistää?

Seuraavanlaisia ​​kohdat tukevat yhdistämisen:

· Standardit

· Komponentti ja Yhteystyypit

· Komponentit ja liitännät

Miten yhdistää kohdetta

Aloittaa yhdistämisen, hiiren oikealla painikkeella, vedä yksi kohde explorer toiselle. Tuote vedät on lähde, ja kohde, joka vedät päälle on määränpää. Vapautettaessa hiiren oikealla painikkeella saat esitetään valikon, josta voit valita yhdistää kaksi tuotetta. Sinun täytyy valita, haluatko säilyttää tai korvata kohde. Tämä on edelleen selitetään.

Yhdistämisen oikea-raahaa -valikko

Mitä eroa on säilyttämisen ja korvaa kohde?

Säilyttää tai korvata vaihtoehto sanelee mitä tapahtuu, jos nimi, kuvaus tai Ominaisuudet välillä lähde ja kohde kohteita ottelussa.

Jos Säilytä Kohde valitaan

· Vastaanottajan nimi ja kuvaus pidetään.

· Ole kiinteistöjä, olemassa vain lähde lisätään määränpäähän.

Jos Korvaa Kohde valitaan:

· Vastaanottajan nimi korvataan lähteestä.

· Vastaanottajan Kuvaus korvataan lähteestä, ellei lähteen Kuvaus on tyhjä.

· Ole kiinteistöjä, olemassa vain lähde lisätään määränpäähän.

· Arvo ja yksikkö ole kiinteistöjä, joita esiintyy sekä lähde ja kohde korvataan lähteestä, ellei lähteen Arvo tai yksikkö on tyhjä.

ERITYISTAPAUKSET

· Tyypit: Kun yhdistämällä tyyppejä, oikeudet yhdistetään, on "pessimistinen" tavalla, niin että jos lupaa lähteestä ei ollut olemassa kohde, se lisätään, ja jos se oli olemassa kohteessa, sitten jos yksittäiset lupaa käyttäjäryhmän (luoda, lukea, päivittää tai poistaa) eivät vastanneet (yksi myönnetään, yksi estetty), niin että lupa evättäisiin.

· Komponentit: Kun yhdistämällä komponentteja, alakomponenttien lähde siirtyvät määränpäähän, ja ne yhdistettiin alaerien kohteessa jos niiden nimet ovat samat, Riippumatta niiden tyypistä.Lisäksi useita alakomponenttien lähde samanniminen yhdistetään yhdeksi osa-komponentti kohteessa.

· Liitännät: Huipputason kytkentöjä itse on molemmilla on sama liitteitä (tai sen puute) on voitava yhdistää. Kun yhdistämällä yhteydet, osa-liitännät lähteen siirtyvät määränpäähän, ja yhdistetään Saharan yhteyksiä määräpaikkaan, jos niiden nimet ovat samat JAniiden liitetiedostot ovat samat. Jos liitteet eivät ole identtisiä, lähde sub-yhteyksiä lisätään määränpäähän ilman sulautuu vastaavia yhteyksiä jo. Tämä on niin, että ei liitteitä menetetään.


Määritteleminen ja hyväksyminen rajoitteet

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Määritteleminen ja hyväksyminen rajoitteet

Lähetä kommentit tästä aiheesta.

Rakennetta ja ominaisuuksia arkkitehtuuria voidaan rajoittaa käyttämällä rajoitteita. Rajoitteet voidaan soveltaa komponenttityypit ja yhteys tyypit rajoittaa rakenteen arkkitehtuuri kahdella tavalla. Ensimmäinen tapa on rajoittaa hierarkiamäärittelemällä "vanhemman tulisi / täytyy olla lapsi" ja "lapsi olisi / on oltava emo" suhteita. Toinen tapa on rajoittaa topologiamäärittelemällä "komponentti olisi / on liitettävä yhteys" ja "yhteys olisi / on liitettävä komponentti" suhteita. Lisäksi rajoitukset voidaan soveltaa ominaisuuksia komponenttityypit, yhteys tyypit, malleja, näkökulmia, arkkitehtuurit, kaaviotja 3D-näkymät rajoittaa arkkitehtuuri (t) kaksi tapaa. Ensimmäinen tapa on asettaa tietotyyppiomaisuuden rajoittaa voimassa arvoja, että se voi olla, nimittäin; Teksti, Integer, Desimaali, Päivämäärä / Aika, Boolen tai Luettelo. Toinen tapa on asettaa vaaditaantila kiinteistön ilmoittamaan, arvoa on kirjattu omaisuus (Huom: Vaadittava rajoitukset koskevat vain ominaisuuksia komponentti ja liitäntä tyypit). Lisätietoja omaisuuden rajoitteet annetaan Ominaisuuksia muuttamalla komponentin, yhteyden tai tyyppi ohjeaihe. Kun rajoitteet on määritelty, on mahdollista vahvistaa arkkitehtuurin vastaan ​​rajoitteet. ABACUS varoittaa mitään rajoituksia, jotka on loukattu.

Avain mitkä rajoitus (t) määritellä piilee juuri kielellä käytetään kuvaamaan rajoitus. Sillä hierarkia rajoitteet ne ovat yleensä muotoa "sanatvoi / olisi / on hajotetaan n sanat" tai "sanatvoi / olisi / on yhdisteltynä sanat"Jne. Esimerkiksi,"Osastoton hajotetaan Joukkueet" tai "Sovelluksetvoidaan jakaa Moduulit". Sillä topologia rajoitteet ne ovat yleensä muotoa"sanatvoi / pitäisi / must verbi sanat". Esimerkiksi, "Prosessit voi olla esittäjä Joukkueet" tai "Sovelluksetolemme isännöi Palvelimet". Nyt voit nähdä jokaisessa rajoitus on olemassa erilaisia ​​voi / pitäisi / must" Qualifiers "ja ne voivat olla 3 tyyppiä;

· Valinnainen- Nämä tyypillisesti käyttää sanoja / lauseita, kuten; "Saattaa", "voi", "voi", "mahdollisesti" jne.

· Suositeltava- Nämä tyypillisesti käyttää sanoja / lauseita, kuten; "Tulee", "suositellaan", "neuvoi" jne.

· Pakollinen- Nämä tyypillisesti käyttää sanoja / lauseita, kuten; "Must", "on", "ovat", "on", "on" jne.

Riippuen turvataan (hierarkian tai topologia) ja karsinnoissa käytetään kuvaamaan sitä, erityinen rajoitus (t) olisi määriteltävä (katso alla). Edellä hierarkiassa esimerkki "Osastoton hajotetaan Joukkueet"Pitäisi määritellä" vanhemman on oltava lapsen "rajoitus ja asettaa täytäntöönpanon määrä panna täytäntöön. Edellä topologia esimerkki"Prosessit voi olla esittäjä Joukkueet"Pitäisi luoda vain kaksi (2)" Connection on kiinnitettävä komponentti "rajoituksia kumpaankin päähän suorittamien yhteystyyppi. Erityisesti seuraavat rajoitteet suositellaan määriteltävä (katso alla) eri vaihtoehdoista;

· Hierarkia rajoitteet;

o Substantiivit voi ollahajotetaan Substantiivit B, tai Substantiivit B voi ollayhdisteltynä Substantiivit tai Substantiivit B pitäisi ollayhdisteltynä Substantiivit- Määritä "Lapsi on oltava emo" rajoitus lapsen kanssa tyypin kuin Noun B, vanhempi tyyppi kuten Noun ja täytäntöönpano kuin varoitettu.

Huomautus

Tämä tarkoittaa, että jos lapsi on, sen tulisi olla vanhempi tietyntyyppisiä. Jos ei, saat varoituksen.

o Substantiivit pitäisi ollahajotetaan Substantiivit B- Määritä "vanhemman on oltava lapsen" rajoite vanhemman tyypin kuin Noun, lapsi tyypiksi Noun B ja täytäntöönpanoa kuin varoitettu.

Huomautus

Tämä tarkoittaa, että jos vanhempi on, sen tulisi olla lapsia tietyntyyppisiä. Jos ei, saat varoituksen.

o Substantiivit pakko ollahajotetaan Substantiivit B- Määritä "vanhemman on oltava lapsen" rajoite vanhemman tyypin kuin Noun, lapsi tyypiksi Noun B ja täytäntöönpanoa kuin pakotetulta.

Huomautus

Tämä tarkoittaa, että jos vanhempi on olemassa, sillä on oltava lapsia tietyntyyppisiä. Jos ei saat virheen.

o Substantiivit pakko ollayhdisteltynä Substantiivit B- Määritä "Lapsi on oltava emo" rajoitus lapsen kanssa tyypin kuin Noun, vanhempi tyyppi kuten Noun B ja täytäntöönpanoa kuin pakotetulta.

Huomautus

Tämä tarkoittaa, että jos lapsi on olemassa, sillä on oltava vanhempi tietyntyyppisiä. Jos ei, saat virheilmoituksen.

· Topologia rajoitteet;

o Substantiivit voi olla verbi Substantiivit B- Määrittele kaksi (2) "Connection on kiinnitettävä Component" rajoitukset. Ensimmäinen olento kanssa Lähde loppuun yhteyden tyyppi verbiliitteenä noun osan ja täytäntöönpanosta asetettu pakotetulta. Toinen on kanssa Sink loppuun yhteyden tyyppi verbiliitteenä Noun B osan ja täytäntöönpanosta asetettu pakotetulta.

Huomautus

Tämä tarkoittaa, että jos yhteys on olemassa, se täytyy liittää komponentteja tietyntyyppisten. Jos ei saat virhe. Kaiken kaikkiaan tämä takaa sen, että nämä komponentit voivat edelleen olemassa, ja ei saa kytkeä toisiinsa. Mutta jos ne on kytketty, liitännät oikeanlaista on käytettävä.

o Substantiivit pitäisi olla verbi Substantiivit B- Määrittele kaksi (2) "Komponentti on kiinnitettävä Connection" rajoitukset. Ensimmäinen on kanssa Noun osan kiinnitetty Lähde loppuun verbiyhteyden tyyppi ja täytäntöönpano asetettu varoitettu. Toinen on kanssa Noun B osan kiinnitetty Sink loppuun verbiyhteyden tyyppi ja täytäntöönpano asetettu varoitettu. Lisäksi määritellä kaksi (2) "Connection on kiinnitettävä Component" rajoitukset. Ensimmäinen olento kanssa Lähde loppuun yhteyden tyyppi verbiliitteenä noun osan ja täytäntöönpanosta asetettu pakotetulta. Toinen on kanssa Sink loppuun yhteyden tyyppi verbiliitteenä Noun B osan ja täytäntöönpanosta asetettu pakotetulta.

Huomautus

Tämä tarkoittaa, että jos komponentit joko tyyppiä, niitä olisi liitettävä yhteyden tietyn tyyppinen. Jos ei saat varoituksen. Lisäksi tämä tarkoittaa, että jos yhteys on olemassa, se on kytkettynä komponentteja määritellyn tyyppistä. Jos ei saat virheen. Kaiken kaikkiaan tämä takaa sen, että jos osat tämäntyyppisten olemassa, saat varoituksia, jos ne eivät liity toisiinsa.

o Substantiivit pakko olla verbi Substantiivit B- Määrittele kaksi (2) "Komponentti on kiinnitettävä Connection" rajoitukset. Ensimmäinen on kanssa Noun osan kiinnitetty Lähde loppuun verbiyhteyden tyyppi ja täytäntöönpano asetetaan pakotetulta. Toinen on kanssa Noun B osan kiinnitetty Sink loppuun verbiyhteyden tyyppi ja täytäntöönpano asetetaan pakotetulta. Lisäksi määritellä kaksi (2) "Connection on kiinnitettävä Component" rajoitukset. Ensimmäinen olento kanssa Lähde loppuun yhteyden tyyppi verbiliitteenä noun osan ja täytäntöönpanosta asetettu pakotetulta. Toinen on kanssa Sink loppuun yhteyden tyyppi verbiliitteenä Noun B osan ja täytäntöönpanosta asetettu pakotetulta.

Huomautus

Tämä tarkoittaa, että jos komponentit joko tyyppiä on olemassa, ne on kiinnitetty yhteyden tietyn tyyppinen. Jos ei saat virheen. Lisäksi tämä tarkoittaa, että jos yhteys on olemassa, se on kytkettynä komponentteja määritellyn tyyppistä. Jos ei saat virheen. Kaiken kaikkiaan tämä takaa sen, että jos osat tämäntyyppisten olemassa, saat virheitä, jos ne eivät liity toisiinsa.

Määritellä rajoitus

1. Varmista, että käytössä ABACUS tiedostoavoin ja Explorer-ikkunanäyttöön.

2. Vuonna tutkimusmatkailija puu laajentaa Tyypit | Komponentti Tyypittai laajentaa Tyypit | Liitäntä tyypit.

3. Hiiren kakkospainikkeellaosan tai yhteyden tyyppi ja valitse Lisää reunaehto.

Lisääminen rajoitus

Määritellä hierarkia rajoite, kun emoyhtiö on oltava erityinen lapsi

4. Käytössä Lisää reunaehtoikkuna rasti Luo Rajoitusvalintaruutu alla Parent Must Have Child reunaehtoalueella.

5. Valitse osanalkaen avattavasta että haluat määrittää lapsena osan valittu vaiheessa 3.

Huomautus

Jos on jo käytössä "Parent Must Have Lapsen rajoite määritelty vanhemman osan ja toisen lapsen osan tämä uusi rajoitus kohdellaan" ja ". Tämä on tyyppi on vanhempi lapsi tyyppi jalapsi tyyppi B, mihin tahansa täytäntöönpanon tasolla (esim liikuntarajoitteisille, varoitettu tai panna täytäntöön - katso vaihe 7) on määritelty jokaiselle rajoitus.

6. Vaihtoehtoisesti voit määrittää minimi- ja maksimimäärä komponenttien tyyppihyväksynnän täsmentänyt, että on lapsia osan oikealla klikataan vaiheessa 3.

7. Valitse, haluatko rajoitus olla Vammaiset, Varoitti tai Pakollinen.

Huomautus

Vammaiset rajoitukset ohitetaan rajoitus validointi, varoitetaan rajoitukset tuottaa varoitus Validation ikkunassa, jos ne havaitaan ja pannaan täytäntöön rajoitukset tuottaa Virhe Validation ikkunassa, jos ne havaitaan. Lisäksi kaikki virheet on ratkaistava ennen Yritys Palvelin hanke voidaan sitoutua.

8. Klikkaa Kunnossa.

Huomautus

Rajoitus näkyy tutkimusmatkailija puu alla osan oikealla klikataan vaiheessa 3. Nuoli osoittaa suunnan rajoitus ja tässä tapauksessa tulee kohta alas ja oikealle. Riippulukko on väritetty mukaan, onko rajoitus on käytössä (harmaa), varoitettu (keltainen) tai täytäntöönpanosta (punainen).

Vanhemman on oltava lapsen varoitti rajoitus

Määritellä hierarkia rajoite, jossa lapsi on oltava erityinen vanhempi

4. Käytössä Lisää reunaehtoikkuna rasti Luo Rajoitusvalintaruutu alla Lapsi Must Have Parent reunaehtoalueella.

5. Valitse osanalkaen avattavasta että haluat määrittää kuin vanhempi osan oikealla klikataan vaiheessa 3.

Huomautus

Jos on jo käytössä "lapsella on oltava emo" rajoite määritelty lapsen osan ja toisen vanhemman osan tämä uusi rajoitus kohdellaan "TAI". Tämä on tyyppi on lapsi vanhemman tyypin taivanhempi tyyppi B, ja täytäntöönpano taso (esim varoitettu tai panna täytäntöön - katso seuraava vaihe) olisi oltava sama muuten täytäntöön rajoitukset aina ohittaa varoitti niistä.

6. Valitse, haluatko rajoitus olla Vammaiset, Varoitti tai Pakollinen.

Huomautus

Vammaiset rajoitukset ohitetaan rajoitus validointi, varoitetaan rajoitukset tuottaa varoitus Validation ikkunassa, jos ne havaitaan ja pannaan täytäntöön rajoitukset tuottaa Virhe Validation ikkunassa, jos ne havaitaan. Lisäksi kaikki virheet on ratkaistava ennen Yritys Palvelin hanke voidaan sitoutua.

7. Klikkaa Kunnossa.

Huomautus

Rajoitus näytetään Explorerissa Näytä nojalla osan valittu vaiheessa 5. nuoli osoittaa suunnan rajoitus ja tässä tapauksessa tulee kohta ylös ja vasemmalle. Riippulukko on väritetty mukaan, onko rajoitus on käytössä (harmaa), varoitettu (keltainen) tai täytäntöönpanosta (punainen).

Lapsella on oltava vanhempi varoitti rajoitus

Määritellä topologia rajoite, jossa komponentti on liitettävä erityinen yhteys

4. Käytössä Lisää reunaehtoikkuna rasti Luo Rajoitusvalintaruutu alla Komponentti on kiinnitettävä reunaehtoalueella.

5. Valitse yhteyden tyyppialkaen avattavasta että haluat määrittää kuin liitteenä yhteyden osan oikealla klikataan vaiheessa 3 (Tai valitse osanalkaen avattavasta että haluat määrittää kuin liitteenä osaa, jos vaiheessa 3 napsautit hiiren oikealla painikkeella yhteystyyppi.)

Huomautus

Jos on jo käytössä "Component on liitettävä pakottavia määritelty osan ja toinen yhteystyyppi sitten tämä uusi rajoitus kohdellaan" ja ". Että on osan on liitettävä yhteystyypin jayhteyden tyyppi B, mihin tahansa täytäntöönpanon tasolla (esim liikuntarajoitteisille, varoitettu tai panna täytäntöön - katso vaihe 7) on määritelty jokaiselle rajoitus.

6. Vaihtoehtoisesti voit valita yhteyden rooliettä haluat lisätä rajoitus. Svalitsee erityiset rooli (Eli joko lähde tai upota) alkaen pudotusvalikosta.

7. Valitse, haluatko rajoitus olla Vammaiset, Varoitti tai Pakollinen.

Huomautus

Vammaiset rajoitukset ohitetaan rajoitus validointi, varoitetaan rajoitukset tuottaa varoitus Validation ikkunassa, jos ne havaitaan ja pannaan täytäntöön rajoitukset tuottaa Virhe Validation ikkunassa, jos ne havaitaan. Lisäksi kaikki virheet on ratkaistava ennen Yritys Palvelin hanke voidaan sitoutua.

8. Klikkaa Kunnossa.

Määritellä topologia rajoite, jossa yhteys on liitettävä erityinen osa

4. Käytössä Lisää reunaehtoikkuna rasti Luo Rajoitusvalintaruutu alla Yhteys on kiinnitettävä reunaehtoalueella.

5. Valitse yhteyden tyyppialkaen avattavasta että haluat määrittää kuin liitteenä yhteyden osan oikealla klikataan vaiheessa 3 (Tai valitse osanalkaen avattavasta että haluat määrittää kuin liitteenä osaa, jos vaiheessa 3 napsautit hiiren oikealla painikkeella yhteystyyppi.)

Huomautus

Jos on jo käytössä "Yhteys on liitettävä pakottavia määritelty yhteyden tyyppi ja toinen komponentti tyyppi Samaa yhteyttä käyttävien rooli(eli joko Lähde tai Sink), niin tämä uusi rajoitus kohdellaan "TAI". Että on liitäntätapa on liitettävä osan tyyppihyväksyntähakemukseen taiosan B ja täytäntöönpano taso (esim varoitettu tai panna täytäntöön - katso vaihe 7) olisi oltava sama muuten täytäntöön rajoitukset aina ohittaa varoitti niistä. Huomaa myös, että jos on useita rajoitteita, joilla yhteys roolimääritelty "väliä" (vastakohtana erityisesti lähde tai Sink) ja sitten kumpaankin päähän yhteyden on kiinnitetty yhteen komponentin tyyppejä määritelty rajoitteet.

6. Vaihtoehtoisesti voit valita yhteyden rooliettä haluat lisätä rajoitus. Svalitsee erityiset rooli (Ts joko Lähde tai Pesuallas) alkaen pudotusvalikosta.

Huomautus

Joko Lähde tai Sink rooli on nimenomaisesti valittu Liite sarake on tilata erikseen näytettäväksi komponentti luettelo .

7. Valitse, haluatko rajoitus olla Vammaiset, Varoitti tai Pakollinen.

Huomautus

Vammaiset rajoitukset ohitetaan rajoitus validointi, varoitetaan rajoitukset tuottaa varoitus Validation ikkunassa, jos ne havaitaan ja pannaan täytäntöön rajoitukset tuottaa Virhe Validation ikkunassa, jos ne havaitaan. Lisäksi kaikki virheet on ratkaistava ennen Yritys Palvelin hanke voidaan sitoutua.

8. Klikkaa Kunnossa.

Reaaliaika malli tarkkailun ja rajoitusvalidointi

ABacus sisältääreaaliaikainen Malli tarkistaminen ja Validation ominaisuus heti näyttö vaikutukset tietyn käyttäjän toiminta tulee olemaan varoitukset ja virheet nykyisen projektin, jotka johtuvat hierarkia ja topologia rajoituksia, jotka on määritelty. On huomattava, että kaikki virheet on ratkaistava ennen Yritys Palvelin hanke voidaan sitoutua.

Reaaliaikainen rajoitus tarkistusominaisuuden on selvimmin asuttavat kaavioiden tai suoraan Explorer-ikkunassa. Erityisesti seuraavien toimenpiteiden aikana, annetaan ohjeita värien korostuu siten toimenpide olla varoitukset ja virheet nykyisen projektin;

1. Kun vetämällä elementtejä päälle tai ympärille kaavio väri vanhemman (tai liittämällä) komponentin (jos on) raja on värillinen mukaan järjestelmän alla.

2. Kun liität komponentteja hiiren kakkospainikkeella vetää | Yhdistä on luettelo käytettävissä olevista Yhteystyypit värjäytyy mukaan järjestelmän alla.

3. Kun liitoskomponenttien kaavioiden avulla Connector tilassa kohdistin vaihtaa väriä mukaan järjestelmän alla.

4. Kun lisäät alaerien luettelon käytettävissä komponenttityypit värjäytyy mukaan järjestelmän alla.

Yleensä seuraavat värejä käytetään osoittamaan vaikutuksia käyttäjän toiminta tulee olemaan varoitukset ja virheet nykyinen projekti;

Musta : Ei vaikutusta varoituksia tai virheitä.

Vihreä : Toiminta on nimenomaisesti mukaisestimääriteltyä hierarkiaa ja topologia rajoituksia projektin.

Punainen : Toiminta on nimenomaisesti vastaisestimääriteltyä hierarkiaa ja topologia rajoituksia projektin ja johtaa varoitukset ja / tai virheitä.

Tausta malli tarkkailun ja rajoitusvalidointi

Abacus sisältää Tarkistusominaisuuden näyttää kaikki varoitukset ja virheet nykyisen projektin, koska mitään rajoituksia, jotka on määritelty. On huomattava, että kaikki virheet on ratkaistava ennen Yritys Palvelin hanke voidaan sitoutua.

Huomautus

Validointi on käsin ajaa kautta "Vahvista / Check Project rajoitukset -painiketta Päätyökalurivin . Validation ikkuna on piilotettu oletusarvoisestimutta tulee näkyviin, kun työkalupalkin painiketta napsautetaan. Nähdä Mukauttaminen käyttöliittymä kuinka piilotiedostojen se ja mahdollisesti jätä se pysyvästi näkyviin. Voit myös kaksoisnapsauttamalla riviä Validation ikkunan "hypätä" asianomaisille osa hanketta.

Validation ikkuna

Oletuksena sarakkeet Validation ikkunassa ovat seuraavat;

Varoitus tai virhe: Tämä sarake näyttää kuvake onko rikkomus on Varoitus (keltainen kolmio huutomerkki) tai Virhe (punainen ympyrä rastilla).

Määrä: Tämä sarake näyttää rikkomisesta numero.

Huomautus

Vain 200 rikkomukset näkyvät aikaa ja jos on enemmän kuin 200 loukkauksista hankkeessa Käynnistä, Edellinen, Seuraava ja Lopeta rivi navigaattorit yläreunassa-ikkunan oikeassa voidaan käyttää selaamaan lisää rikkomuksia.

Kuvaus: Tämä on täydellinen kuvaus rikkomisesta, mukaan lukien yrityksen ja Constraint osalta.

Entity: Tämä sarake näyttää Entity huolestuttavat rikkomisesta.

Tyyppi: Tämä sarake näyttää elementin tyyppi Entity.

Arkkitehtuuri: Tämä sarake näyttää arkkitehtuuri, jossa rikkominen on tapahtunut.

Detected: Tämä sarake näyttää ajan, että rikkominen havaittiin.

Kärki

On hyödyllistä laskeva mukaan Detected sarakkeen (kuten on esitetty valintaikkuna yllä) varmistaa viimeisimmän loukkauksista näkyvät top luettelon.

On olemassa useita käyttäjä vaihtoehtoja muuttaa käyttäytymistä taustalla mallin validointi. Esimerkiksi To muuttaa väriä käytetään rajoitus rikkomukset jotain muuta kuin oletuksena PunainenNapsauta Työkalut | Asetukset ... siirry Validationvälilehti, ja asettaa värit kautta Muuttaa painikkeet.

Validation vaihtoehdot

Manuaalisesti vahvistaa rajoitukset

1. Hiiren kakkospainikkeellakoskevat Arkkitehtuuritsolmu, kaikki arkkitehtuuri tai missä tahansa joko Komponentit tai Liitännätosa Explorerissa Näytä ja valitse Tarkista Rajoitukset.

Validoi rajoitteet

2. Napsauta Tarkemmat tiedotpainiketta Varoituksetikkuna nähdä missä arkkitehtuuri rikkoo rajoituksia, jotka on määritelty.

Huomautus

Rikkomukset näytetään vain niille rajoituksia, jotka on asetettu varoitettu tai täytäntöönpanosta. Lisäksi sanamuoto varoitus kuuluu "pitäisi", jos rajoitus oli vain varoitus tai "must", jos se pantiin täytäntöön.

3. Klikkaa Kunnossa.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti


Kehittyvä arkkitehtuurista

Navigation: Asuttavat laitealustan> Asuttavat manuaalisesti> Extra valinnat>

Kehittyvä arkkitehtuurista

Lähetä kommentit tästä aiheesta.

Arkkitehtuurit voidaan selkeästi kehittynyt ja hierarkia arkkitehtuurit luotu. Näin kehittyvät arkkitehtuurista Abacus, useita kehittyneitä arkkitehtonisia ratkaisuja voidaan luoda verrattuna ja baselined. Tavoitteet (tai käyttötiedot) voidaan määritellä minkä tahansa määrän arkkitehtonisia ominaisuuksia nykyisten arkkitehtuureille.

Yksinkertainen tapa harkita kehitys arkkitehtuuri on suhteuttaa sen käsite jälkeläinen arkkitehtuuri. Kun arkkitehtuuri on kehittynyt, kopioidaEmoyhtiön arkkitehtuuri on luotu. Tämä kappale voidaan sanoa olevan suora jälkeläinenAlkuperäisen vanhempi arkkitehtuuri.

Huomautus

Tässä online-apua asiakirjat ja ABACUS työkalut itse, termi kehittääon yleisesti käytetty kuin termi jälkeläinen, Huomaa, että molemmat viittaavat samaan toiminnallisuutta.

Kehittyä nykyisiä arkkitehtuuri

1. Varmista, että käytössä ABACUS tiedostoavoin ja Explorer-ikkunanäyttöön.

2. Valitse kyseinen arkkitehtuuri haluat kehittyä tutkimusmatkailija puu.

3. Oikealla painikkeellaarkkitehtuurista ja valitse Kehittäävalikosta.

Kehittyvä Valittu Arkkitehtuuri

4. Kehittynyt arkkitehtuuri alle ilmestyy valitun arkkitehtuurin.

Evolved Arkkitehtuuri

Huomautus

Kehittynyt arkkitehtuuri voidaan nimetä uudelleen oikealla klikkaamalla arkkitehtuuri ja valitsemalla Nimetä uudelleen.Lisäksi kaikki kaaviot ja luetteloissa kehittynyt arkkitehtuuri on automaattisesti "Diff" vastaan ​​perustason arkkitehtuuri että se oli kehittynyt.

Tavoitteiden asettaminen sinun kehittynyt arkkitehtuuri

Tavoitteiden asettaminen sinun kehittynyt arkkitehtuurin avulla voit luoda perusteet arvioida kehitystä oman arkkitehtuurit. Tavoitteet määräytyvät omaisuuden tyypit ja nimet ominaisuuksia olemassa sinun kehittynyt arkkitehtuuri. Tavoitteet voidaan myös manuaalisesti määritelty ja lisätään teille arkkitehtuuria. Seuraa ohjeita asettaa tavoitteita.

Tavoitteiden asettaminen alkaen nykyisiä ominaisuuksia sinun kehittynyt arkkitehtuuri

1. Varmista, että käytössä ABACUS tiedostoavoin ja Explorer-ikkunanäyttöön.

2. Valitse Työkalut | Asettaa tavoitteitaPäävalikosta baari.

3. Maali Inputtulee näkyviin.

Maali Syöttöikkuna

4. Klikkaa Nykyinenpainiketta.

5. Valitse Kiinteistövälitystulee näkyviin.

6. Valitse ominaisuus, jonka haluat asettaa tavoite teidän kehittynyt arkkitehtuuri ja klikkaa Kunnossapainiketta.

7. Valittu tavoite näkyy nyt Maali Input ikkuna.

8. Valitse tavoite ja klikkaa Muokatapainiketta.

9. Muokkaa Maalitulee näkyviin.

Huomautus

Tämä ikkuna avulla voit muuttaa kiinteistön nimi ja tyyppi, että tavoite heijastaa sekä pahin ja paras arvo (tai minimi / maksimiarvot) kyseistä ominaisuutta. Nämä arvot löytyvät vertaamalla kaikki arkkitehtuurit ja löytää pienimmän ja suurimman arvon kukin kyseisen omaisuuden. Nämä arvot voidaan myös manuaalisesti määritelty. Esimerkiksi, jos olit asettanut tavoitteeksi omaisuutta nimetty Response (Ave)ja tyypin Käyttäytyminen, Pahin ja paras arvo voisi kuvasta tapahtumaa nopeus tarvitaan optimaalisen suorituskyvyn (paras arvo) ja kauppa nopeutta tarvitaan vain tärkeimmät hakemusten käsittelyä (huonoin arvo).

10. Kun asiaankuuluvat arvot on määritelty, valitse Kunnossa.

Tavoitteiden asettaminen uusien kiinteistöjen oman kehittynyt arkkitehtuuri

1. Varmista, että käytössä ABACUS tiedostoavoin ja Explorer-ikkunanäyttöön.

2. Valitse Työkalut | Asettaa tavoitteitaPäävalikosta baari.

3. Maali Inputtulee näkyviin.

4. Klikkaa Uusipainiketta.

5. Uusi tavoitetulee näkyviin.

Huomautus

Tämä ikkuna avulla voit määrittää kiinteistön nimi ja tyyppi, että tavoite heijastaa sekä pahin ja paras arvo (tai minimi / maksimiarvot) kyseistä ominaisuutta. Esimerkiksi, jos olit asettanut tavoitteeksi kiinteistöjen nimeltään Response (Ave)ja tyypin Käyttäytyminen, Pahin ja paras arvo voisi kuvasta tapahtumaa nopeus tarvitaan optimaalisen suorituskyvyn (paras arvo) ja kauppa nopeutta tarvitaan vain tärkeimmät hakemusten käsittelyä (huonoin arvo).

6. Kun asiaankuuluvat arvot on määritelty, valitse Kunnossa.

7. Valintaikkuna Lisää kaikki arkkitehtuuritnäyttää kuten alla:

8. Klikkaa Kyllälisätä tavoite kuin kohde kaikki asiaankuuluvat arkkitehtuurit. Näin varmistetaan, että äskettäin määritelty tavoite ja sen ominaisuudet lisätään kaikki arkkitehtuurit tiedoston. Jos et halua sisällyttää kiinteistön arkkitehtuurit, voit klikata Ei.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Katsoo tähti tontti teidän kehittynyt arkkitehtuureille | Katsoo Sirontakuvaajan teidän kehittynyt arkkitehtuureille


Piirtotyökalu

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Piirtotyökalu

Lähetä kommentit tästä aiheesta.

Piirtotyökalu voidaan luoda erilaisia ​​arkkitehtonisia kaavioita ja kaavioita. Arkkitehdit perinteisesti käyttää erilaisia ​​piirustuksia tallentaa ja välittää suunnittelu arkkitehtuuri. Kaksiulotteinen (2D) kaaviot ovat tavallinen tapa dokumentoida ja kommunikoida eri osien järjestelmän. Tyypillisiä piirustuksia tyyppejä käytetään yritysjärjestelmien ovat:

· Liiketoimintaprosessien mallit ja kaaviot;

· Organisaatiokaaviot;

· Collaboration kaaviot;

· Entity-Relationship (ER) kaaviot;

· Data-Vuokaaviot (DFD n);

· Luokkamalleista;

· IDEF (sisältää useita edellä); ja

· UML (sisältää useita edellä).

Ei todellakaan ole mitään rajaa erilaisia ​​kaavioita, joka voidaan luoda. ABACUS yritetään tasapainottaa kaavio joustavuutta säilyttäen eheyden arkkitehtuurin ja sen edustusta.

Piirtäminen ympäristö on välilehtiä ja telakoitavat ikkuna sisällä tärkein ABACUS sovelluksen. Tässä ikkunassa on kangas, jossa piirustus tapahtuu ja kun piirtoikkunan on auki toinen telakoitavat ikkuna , Kaavain ikkunan, on nähtävissä joukko piirustus stensiilit. Sapluuna ruudussa on 4 välilehteä: Komponentit, liitännät, muodot ja liittimet. Kangas näkyy valkoisella taustalla hieno ruudukko (hyödyllisiä layout).

Edustajia on erilaisia ​​muotoja, kun taas liitännät piirretään suunnattu linjat. Liitännät liittää komponentteja roolit (Eli joko lähde tai upota) vaikka näitä ei ole esitetty esteettisistä syistä.

Kärki

Sillä aikaa kaaviotovat erittäin hyödyllisiä näyttää erilaisia ​​osia järjestelmä, ne ovat rajallisia niiden laajennettavuus, minkä vuoksi ABACUS käyttää 3D visualisoida monimutkainen järjestelmä rakenteita.

Haluat ehkä

1. Avaa Kaavio Työkalu

2. Luo uusi kaavio osa arkkitehtuurista

3. Kopioi kaavio sisällä tai niiden välillä arkkitehtuureille

4. Yhdistä komponentit on kaavio

5. Luo uusia komponentteja ja yhteyksiä teidän arkkitehtuuri (kaavamaisesti) käyttäen piirtotyökaluksi

6. Poista osat alkaen kaavio

7. Kiinnitä & manipuloida yhteydet

8. Muuta näytön ominaisuudet komponenttien ja yhteyksiä.

9. Käyttämällä linkkejä kaavio

10. Valvoa yhdistyksiä ja näkökulmia jotta voidaan rajoittaa tyyppisiä kaavioita, jotka voidaan tehdä.

Katso myös

Populating arkkitehtuurista | Asuttavat arkkitehtuurista manuaalisesti | Analysointi arkkitehtuurista


Avaaminen kaaviot

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Avaaminen kaaviot

Lähetä kommentit tästä aiheesta.

Piirtäminen sapluuna ja kangas ikkunat näkyviin automaattisesti, kun kaavio avataan tai luodaan. Vastaavasti, kun kaavio on suljettu, vastaava välilehdillä arkki kangas ikkuna katoaa ja jos enää piirustukset ovat auki sitten kaavain ikkuna suljetaan.

Jotta luodauusi kaavio

1. Varmista, että käytössäABACUS tiedosto aukijoissa näkyvät asutuilla arkkitehtuuri.

2. Klikkaa Diagramkuvaketta View työkaluriviltä.

- tai -

2. Valita Aseta| Diagram.

- tai -

2. Hiiren kakkospainikkeella Kaaviothaara tietyn Arkkitehtuuriosa puun ja valitse Luoda Kaavio.

3. Valitse Arkkitehtuurihaluat keskittyä alkaen alasvetovalikosta. Huomautus: arkkitehtuuri on jo valittu sinulle, jos käytit vaiheessa 3 Avaa uusi kaavio.

4. Valitse Näkökulma haluat käyttää mistä pudotusvalikosta. Huomaa: valittu näkökulma suodattaa komponentit ja yhteydet luettelot vain ne käytettävissä näkökulmasta.

5. Vaihtoehtoisesti valitse näkymä Lajittele Näytäalasvetovalikosta esivalintana komponentit ja yhteydet valittu näkymä. Huomautus: tämä on tehokkaasti käyttämällä valitun näkymän tallennettu kysely.

6. Valitse Layout olla joko Säteittäinen tai Ruudukko.

7. Valitse Komponentit ja Liitännätettä haluat kaaviota standardi elementti valinta ikkuna .

8. Klikkaa Kunnossa.

Huomautus

Uusi kaavio lisätään Kaaviothaara arkkitehtuurin. Se on oletuksena nimi, jonka voit muuttaa myöhemmin oikealla klikkaamalla sitä.Lisäksi viimeiset komponenttien ja yhteyden valinta suodattimet tallennetaan kaavion tehokkaasti säästää "kyselyn" käytetään luoda kaavion.

Jos haluat avata kaavion

1. Erityisissä asutuilla arkkitehtuuri, laajentaa Kaaviothaara puu.

2. Tuplaklikkaus kaavio haluat avata.

Voit tallentaa kaavio

1. Varmista, että sinulla on uusi tai olemassa kaavio avataja olet tehnyt tarvittavat muutokset. Huomautus: Tähdellä "*" näkyy sen jälkeen näkymä nimen välilehtiä levyn otsikko, onko muutoksia tallennetaan.

2. Vuonna tutkimusmatkailija Näkymä Klikkaa Tallentaapainiketta tai sai Tiedosto| Tallentaatai paina Ctrl + Stallentaa kaikki muutokset arkkitehtuurista ja kirjoittaa se tiedostoon.

Jos haluat tallentaa kaavio kuin näkökulma

1. Varmista, että sinulla on olemassa kaavio sinun ABACUS tiedoston.

2. Hiiren kakkospainikkeellakaavio Kaaviotosa puusta.

3. Valita Tallenna nimellä Kaavio Näkökulma.

4. Anna nimi uudelle kaavio näkökulmaja valitse Kunnossa.

Katso myös

Piirtotyökalu | Populating arkkitehtuurista | Analysointi arkkitehtuurista


Kopiointi kaaviot

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Kopiointi kaaviot

Lähetä kommentit tästä aiheesta.

On 2 perusskenaarioita kopiointi olemassa oleva kaavio; sisällä arkkitehtuuri, tai poikki arkkitehtuurit.

Jotta kopioidakaaviosisällä arkkitehtuuri

1. Varmista, että käytössäABACUS tiedosto aukijoissa näkyvät asutuilla arkkitehtuurijossa on ainakin yksi kaavio.

2. Laajentaa Kaaviothaara (Ja tarvittavat Kaavio ryhmät) Tietyn Arkkitehtuuriosa puun.

3. Valitse kaavio haluat kopioida ja paina Ctrl + C tai hiiren kakkospainikkeellaja valitse Kopioida valikosta.

Huomautus

A kopio kaavio lisätään Kaaviothaara sama arkkitehtuuri. Se on "Kopio" liitteenä alkua nimi, Jonka voit muuttaa myöhemmin painamalla F2 tai oikea-klikkaamalla sitäja valitsemalla Nimeä uudelleen.

Jotta kopioida kaavio poikki arkkitehtuureille

1. Varmista, että käytössäABACUS tiedosto aukijoissa näkyvät asutuilla arkkitehtuurisjossa on ainakin yksi kaavio.

2. Laajentaa Kaaviothaara (Ja tarvittavat Kaavio ryhmät) of Arkkitehtuuriosa puunvarten arkkitehtuuri, joka sisältää kaavion haluat kopioida.

3. Valitse kaavio haluat kopioida ja Yleiset ominaisuudetikkuna huomautus Näkökulma että kaavio liittyy (Tyyppi alalla).

4. Nyt, laajentaa Kaaviothaara (Ja tarvittavat Kaavio ryhmät) of Arkkitehtuuriosa puunmuiden arkkitehtuuria, joka haluat kopioida kaavion osaksi.

5. Hiiren kakkospainikkeella Kaaviot solmu (tai Kaavio ryhmä) Ja valitse Luo Kaavio .... Vuonna avautuvassa Valitse Näkökulma että on todettu vaiheessa 3 edellä avattavasta oikeassa yläreunassa. Jätä kaikki muu kuin on ja napsauta Kunnossa. Kaaviossa nimi -valintaikkuna Syötä nimi (pian) kopioitu kaavio. Huom: tyhjä kaavio kangas mukaan valitun näkökulmasta avataan.

6. Paluu kaavio, jonka haluat kopioida ja avata että hiiren kakkospainikkeellasolmu ja valitsemalla Avata tai yksinkertaisesti tuplaklikkaamalla se.

7. Valitse tausta kangas kaavion haluat kopioida ja paina Ctrl +. Tämä valitsee kaikki elementit että kaavio. Paina nyt Ctrl + Ckopioida sisällön leikepöydälle.

8. Nyt palaa tyhjä kaavio arkkitehtuurista haluat kopioida sisältöä, Valitse taustakangas ja joko hiiren kakkospainikkeellaja valitse Tahna tai paina Ctrl + Vliittää sisältöä. Kun lyhyt aika sisältö kaikki liitetään uuteen tyhjä kaavio.

Huomautus

Elementit lisätään huipputason uuden arkkitehtuurin ja täytyy järjestää uudelleen tai sulautui nykyisten sisältöä vastaavasti.

Katso myös

Piirtotyökalu | Populating arkkitehtuurista | Analysointi arkkitehtuurista


Populating kaaviot

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Populating kaaviot

Lähetä kommentit tästä aiheesta.

Piirustukset Abacus ovat enemmän kuin vain mielivaltainen esityksiä. Ne räätälöidään näkymät arkkitehtuurin, muotoiltu ja järjestetty osoittamaan erityistä merkitystä.

Piirtotyökalu valvoo hierarkkinen rakenne arkkitehtuuri, niin että komponentit ovat visuaalisesti sisäkkäin muut - tehokkaasti antaa "pohjapiirros" elementtejä. Kun komponentti tai yhteys on määritelty arkkitehtuuria, sitä voidaan käyttää missä tahansa useissa eri kaavioiden. Tärkeää on, piirtotyökalua liittyy läheisesti arkkitehtoninen malli, niin että muutokset tehdään joko yksi on aina heijastuu muihin.

Työkalu toimii liittämällä muotoja erityisesti yhteys ja komponentti määritettyihin Tyypit osassa arkkitehtuurin. Näiden yhdistysten vaihtelevat riippuen kaavion siirretään, ja on mahdollista, että yksi tyyppi komponentin (tai yhteys) voi olla eri esityksiä eri kaavioissa, kontekstista riippuen.

Perustaa yhdistyksen välillä muoto ja osan tai yhteystyyppi

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Maksimoi ABACUS sovellus, ja määritä ikkunan mittasuhteet kuin haluat.

3. Valitse Muodot välilehti tai Liittimet välilehti in sapluuna ikkunassa.

4. Vuonna Tyyppihaara Explorer, etsi komponentti tai yhteyden tyyppi haluat yhdistää muodon tai liitin.

5. Valitse valittu tyyppi elementti puusta, vedä se Muodot välilehti tai Liittimet välilehti, ja pudota se muoto tai liitinhaluat käyttää.

Huomautus

Voit tarkistaa yhdistys olet luonut valitsemalla komponentit tai yhteys välilehti kaavain ikkunan, joka näyttää tällä hetkellä liittyviä elementtejä.

Voit lisätä uusia muotoja omaan kaaviot / kirjasto

1. Luo MS Visio kaavio muotoja, jotka haluat lisätä kaavion ja tuoda MS Visio kaavio .

Kärki

On tärkeää, mikä kokosi tehdä master-muoto MS Visio koska ABACUS kangas on mitoitettu pikseliä ja vain Millimetrit yksiköiden MS Visio muuntaa granularly on pikseleitä 4 pikseliä 1 mm suhde. Lisäksi oletuksena ABACUS muodot ovat tyypillisesti 60 pikseliä korkea, jotta kääntää 15 mm MS Visio. Merkitys suositeltavaa Master muoto koko MS Visioon 25mm leveä 15mm korkeakoska se kääntää 100 pikseliä leveä ja 60 pikseliä korkea Abacus.

Kärki

Jos haluat olla hieman "ikoni" sivun vasemmassa yläkulmassa muoto sitten voit yksinkertaisesti luoda "kuvaketta" master MS Visio muoto käyttämällä MS Visio Drawing Työkalupaletti (huomaa, että vain yksinkertaiset linjat, ympyrät ja suorakulmioita tuetaan ja rasteroituja / bittikartta muotoja erityisesti ei tueta). Lisäksi, jos haluat kuvakkeen olla vahvistetaan koko / mittakaavassasisällä muoto Abacus voit ryhmä "kuvaketta" master MS Visio muoto valitsemalla kaikki sen elementit, oikea-klikkaamalla yksi elementti, valitsemalla muoto | Ryhmä, sitten hiiren kakkospainikkeella ryhmitelty muoto ja valitsemalla Data | Muodon tiedot ... valitsemalla Kyllä avautuvassa valintataulussa ja sitten lisäämällä omaisuuden Label asetettu LockScale(Huomaa isot "L" ja "S"), tyyppi asetettu Boolean ja Value asetettu TOTTA (Huom se on kaikki isoilla).

Kärki

Jos haluat olla osa muoto jäädytetty skaalaamisen vaaka- tai pystysuoraan (kuten on tyypillistä "kaista" muoto), voit hiiren kakkospainikkeella osa (t) master MS Visio muoto että haluat jäädytetty skaalaamisen ja valitse Data | Muodon tiedot ... valitsemalla Kyllä avautuvassa valintataulussa ja sitten lisäämällä omaisuuden Label asetettu LockXScale tai LockYScale (Huomaa isot "L" ja "S"), tyyppi asetettu Boolean ja Value asetettu TOTTA (Huom se on kaikki isoilla), ja lukittu vaakasuoraan tai pystysuoraan skaalaus vastaavasti.

Kärki

Jotta väritys muodon Abacus tuonnin jälkeen pikemminkin kuin muoto aina on kiinteä väri on suositeltavaa tehdä master-MS Visio muoto kyllikseen läpinäkyvä ja sitten käyttää sisäänrakennettu kyky Abacus väri muoto tausta. Tämä toimii vain suorakaiteen tai lähes suorakaiteen (esim pyöristetyn suorakulmion) muotoja koko suorakulmainen tausta on värillinen.

2. Avaa vastaava kaavio ja valitse Komponentit-välilehtiin sapluuna ikkunassa.

3. Kunkin uuden muodon, jonka haluat saataville muut kaaviot Hiiren kakkospainikkeellamuoto ja valitse Lisää Muodot Library. Tämä tekee muoto saataville muodot välilehden sapluuna ikkunassa.

4. Liitä asiaa osan uuden muodon muodot kirjastosta mukaan edellä kuvatut.

Huomautus

Vain yksinkertainen ja "vektori-pohjainen" muodot ovat tuettuja Abacus tällä hetkellä, eli bittikarttoja ei tueta. Kuitenkin, työkaluja, kuten Vector Magic-( www.vectormagic.com ) Ovat käytettävissä, jotka helposti muuntaa bittikarttakuvien osaksi vektori-muotoja (eli SVG-muodossa), joka voidaan avata MS Visio ja siten hyödyntää ABACUS kohti edellä ohjeiden.

LisääminenKomponentit ja liitännät

Drawing työkalun avulla voit lisätä olemassa olevia komponentteja ja yhteyksiä arkistosta tai luoda uusia komponentteja ja yhteyksiä kuin vedät kaavio. Osina ja yhteydet luodaan kaavioita, ne ovat samanaikaisesti lisätään varasto. On kolme suositeltava tapoja komponenttien lisääminen kaavioja kolme suositeltava tapa lisätä yhteyksiä kaavio:

Voit luoda täysin uuden osan tai yhteyden kaavioalkaen sapluuna

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Valitse Komponentit tai Liitännätvälilehti sapluuna ikkunasta nähdä liittyvien muotoja. Vain näitä muotoja voidaan käyttää luomaan uusi malli elementtejä.

3. Klikkaa ja vedäyksi käytettävissä liittyvän muotoja päälle piirustus kankaalle. Uusi elementti ilmestyy kankaalle ja tutkimusmatkailija puu.

4. Alkaa kirjoittaanimi uudelle elementin valintaikkunassa ja olemassa olevat elementit, jotka kohdistetaan ovat ehdottaneet ja voidaan valita mieluummin kuin lisäämällä uusi elementti arkkitehtuuri.

5. Klikkaa Kunnossa.

6. Jos muoto tiputettiin tietyn komponentin, niin se joko tulee lapsen kyseisen osan (jos muoto tuli Komponentitvälilehti), tai liitetään että komponentti (jos muoto tuli Liitännätvälilehti).

Huomautus

Joskus on tarpeen mukauttaa uuden osan tai yhteys jaetaan eri paikka arkkitehtuurin hierarkian avulla tutkimusmatkailija.

Paikka olemassa olevan osan tai yhteys varasto päälle kaavio

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Varmista, että olet molemmat piirtotyökalua ja Explorer -ikkunat katsottavissa.

3. Explorer, etsi komponentti tai yhteys(Elementti) haluat lisätä kaavion.

4. Klikkaa ja vedävalitun elementin päälle kaavio. Muoto edustaa elementti ilmestyy kankaalle.

Huomautus

Jos tyyppi valitun elementin on jo liitetty muoto, vastaava muoto ilmestyy kankaalle. Jos kuitenkin ole määritelty yhdistys kyseisen elementti, oletus muoto (suorakaide) ilmestyy kankaalle ellei Pakota Kaavio Näkökulmia vaihtoehto on, jolloin muoto ei lisätä kaavion.

Kärki

Kun komponentti on sijoitettu kaavion joka on kytketty toiseen laitteeseen jo kaavio, piirtotyökalua kyselyn jos haluat näyttää yhteyden (t) välillä. Lisäksi, jos on lapsia komponentin piirtotyökalua kyselyn jos haluat sisällyttää lasten, vuonna rekursiivinen tavalla.

Jotta luoda yhteys 2 osien tai liitetyn komponentin kaavio dynaamisen liitin

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Häilyä yli komponentti kaavio, jonka haluat liittää toiseen komponenttiin ja huomaat 2 ilmestyvät ulkopuolella oikeassa yläkulmassa rajan muodon alla. Huomautus: top kuvake on luoda yhteys, jossa leijui komponentti on olla lähde, pohja kuvake on luoda yhteys, jossa leijui komponentti on olla pesuallas.

3. Liikkua kohdistin halutun kuvakkeen ja klikkaa ja vedäkuvaketta liikaa joko toisessa komponentin tai vapaata tilaa kankaalle kuten alla.

4. Voit muodostaa yhteyden tietyn komponentin valita Liitä ...kohde ponnahdusvalikosta ja tarvittaessa Selaa alivalikon valita käytettävissä yhteystyypit.

- tai -

4. Voit luoda kytketty komponentti valitsi Uusi...kohteet ponnahdusvalikosta ja tarvittaessa Selaa alivalikon valita saatavilla yhteystyypit kuten alla. Alkaa kirjoittaanimi uudelle elementin valintaikkunassa ja olemassa olevat elementit, jotka kohdistetaan ovat ehdottaneet ja voidaan valita mieluummin kuin lisäämällä uusi elementti arkkitehtuuri.

Huomautus

Saatavuus erien ponnahdusvalikosta ja alivalikko säännellään rajoitteet meta-malli.Se on vain pätevä lähde tai upota komponentti tyyppejä määritetty yhteys rajoitusten tullaan esittämään Liitä ... ja New ... valikkokohdat.

Jotta uudelleen avaa elementti valintaikkuna ja aseta olemassa olevia komponentteja tai yhteyksiä arkistosta päälle kaavio

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Klikkaa Avoin Element Selectionpainiketta Kuva työkalupalkin. Huomautus: elementti valintaikkuna avautuu viimeiset suodattimia tallennettu.

3. Valitse muita sisältöä, joka halutaan lisätä kaavion ja napsauta Kunnossa. Huomautus: uutta sisältöä lisätään vapaata tilaa kankaalle ja kaavio voi olla myöhemmin säädettyihin uudelleen kautta Layout Kaaviopainiketta Kuva työkalupalkin.

Käyttämällä FreemuotoMuodot

On usein toivottavaa luoda visuaalisia elementtejä kaavio puhtaasti esteettisistä syistä. Nämä elementit voivat parantaa ulkoasua ja ulkonäkö kaavio, mutta heillä ei ole tiukka arkkitehtoninen merkitys. Piirtotyökalu sallitaan vapaamuotoinen muotoja antaa piirustus joustavuutta.

Voit lisätä vapaamuotoinen muoto kaavio

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Valitse Muodot tai Liittimetvälilehti sapluuna ikkunassa.

3. Klikkaa ja vedäyksi käytettävissä muotoja tai liittimiä piirustus kankaalle. Uusi elementti ilmestyy kankaalle - mutta eiExplorer puu.

Huomautus

Vapaamuotoiset muodot ovat "ei-liittyvä" muotoja, koska niillä ei ole yhdessä mitään tiettyä komponenttia tai yhteyden arkkitehtuurimalli.

Jotta Näytä arkiston tiedot Vapaamuotoiset muotopoikakaavio

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Hiiren kakkospainikkeellavapaamuotoinen muoto ja valitse Lisäykset | Näyttö.

3. Valita näytettäväksi joko Kaavio Nimi, Kaavio Kuvaus, Kaavio Kiinteistövälitys, Näkökulma Nimi tai Arkkitehtuuri Nimi.

Huomautus

Teksti vapaamuotoinen päivittää automaattisesti kun taustalla arkiston tietojen muutokset.Näin kaavio "otsikko lohko" voidaan luoda, ja sitten helposti kopioida koko, kaaviot.

Kelluvien Muodot

Kelluvat muodot ovat olennaisesti toinen tapa edustaa komponenttien kaavio. Harkitse organisaatio keskeisten osastojen: toimitusjohtaja, markkinointi, myynti ja kehittäminen.

Puunäkymä

Nämä rajapinnat voidaan visuaalisesti edustettuna kerroksellinen tavalla:

Layered Näytä

Tai ne voidaan visuaalisesti edustaa vaiheittain / kelluva tavalla näyttää hierarkia:

Porrastettu / Kelluva Näkymä

Jälkimmäinen edustus käyttää käsitettä kelluva muotoja.

Voit muuntaa kerroksellinen komponentti muoto osaksi kelluva muoto

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Valitse komponenttiteidän kaavio haluat edustaa kelluvana muoto tai liittyvän muoto Komponentitvälilehden sapluuna ikkunan haluat kaikki esiintymät kuin kelluva muotoja.

3. Napsauta hiiren kakkospainikkeella muotoa ja valitse Float Komponentti pikavalikosta näyttöön. Huomaa timantti otsikkona yhteysvanhemman komponentti (t) kelluva komponentti (a).

4. Klikkaa ja vedäkomponentti haluttuun paikkaan. Kun kelluvakomponentti valitaan sillä on sininen ääriviivat.

Voit muuntaa kelluva osa muoto osaksi kerroksellinen muoto

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Valitse komponenttiteidän kaavio että parhaillaan esitetty kelluva muoto tai liittyvän muoto Komponentitvälilehden sapluuna ikkunan haluat kaikki esiintymät kuin kerroksittain muotoja.

3. Klikkaa ja vedäkelluva komponentti (t) takaisin vanhemman (t) (mukaan timantti otsikkona yhteys). Huomautus: Jos et tee tätä sitten kun muuntaa komponentti (t) takaisin on kerrostettu hierarkia malli voisi vaikuttaa.

4. Napsauta hiiren kakkospainikkeella muotoa ja unselect Float Komponentti pikavalikosta näyttöön. Huomaa, että timantti otsikkona yhteysvanhemman komponentti (t) kelluva komponentti (t) katoaa.

Replikat

Drawing työkalun avulla voit lisätä saman komponentin kaavio useita kertoja jokaista visuaalinen esimerkiksi komponentin kaavion kutsutaan kopio. Tämä on erityisen hyödyllistä kaavioita, joissa komponentti on suuri määrä yhteyksiä kiinnitetty siihen, ja se on edullista osoittaa komponentin eri paikoissa lähempänä alkuperää kunkin yhteyksiä, tai kaavioita, joissa yksi-moneen komponentin on parempi näyttää käyttäen kelluvan ominaisuuden (edellä on kuvattu) komponentin eri paikoissa päälle "monien" osia se liittyy.

Huomautus

Voit liittää / irrottaa yhteydet / alkuperäisestä esiintymä komponentin kaavio (kuten aina), mutta myös johonkin jäljennöksiä, mutta kun yhteydet lisätään automaattisesti kaavio ne kiinnitetään ensisijaisesti komponentin kaaviossa oletuksena.

Huomautus

Jäljennöksiä voidaan yhdistää toisiinsa hiiren kakkospainikkeella ja vedävalitsemalla Yhdistä ReplikatKuitenkin sulautuvat kopio eri osa johtaa muita jäljennöksiä katoamassa kaaviosta.

Huomautus

Ei ole visuaalinen ero alkuperäisen esiintymä komponentin kaavio ja kaikki jäljennöksiä. Lisäksi hiiren kakkospainiketta alkuperäiseen komponentti kaavio ja kaikki jäljennöksiä on sama, jossa esimerkiksi Näytä Explorerissakun sinut samaan osa puunäkymä arkiston (alias malli). Kuitenkin hiiren kakkospainikkeella komponentti puunäkymään loppusijoitustilan ja valitsemalla Meneja selaamista kaavion jäljennöksiä aina vie vanhin "esiintymä komponentin kaavio. Tyypillisesti tämä on alkuperäinen esimerkiksi, että lisättiin kaavion mutta jos alkuperäinen esimerkiksi sittemmin poistettu tai sulautui kopio siirry siirtyy vanhin jäljellä jäljennöksiä, jotka lisättiin.

Jotta lisää replica kaavio

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Hiiren kakkospainikkeella olemassa olevan komponentin kaavio ja valitse Luo Replica.Kopio valitun komponentin luodaan oikealle alkuperäisen komponentin.

- TAI -

Valitse olemassa oleva komponentti kaavio ja paina Ctrl + Ctai napsauta hiiren kakkospainikkeella olemassa olevan komponentin kaavio ja valitse Kopioida. Nyt klikkaa hiiren oikealla paikalla kaavio, jonka haluat replica ja valitse Liitä kuten Replica. Huomautus: Painamalla Ctrl + V (tai klikkaamalla hiiren oikeaa painiketta ja valitsemalla Liitä) luo kopion alkuperäisestä komponenttia kopio.

- TAI -

Klikkaa ja vedäkomponentti puunäkymä arkiston (alias malli) päälle kaavio, jossa komponentti on jo olemassa.

Määrittäminen liitinsuojukset / Loppuu

Drawing työkalun avulla voit aseta symboli käytetään päissä yhdysletkut joko kiinteä symboli tai symboli riippuu kiinteistön yhteyden itse.Tämä on erityisen hyödyllistä kaavioita, joissa suunta yhteys tarvitaan näytetään, tai kaavioita, joissa mahtavuus yhteyden (tai suunta) sisältyy kiinteistön yhteyden itse, esimerkiksi "One-to-Monet" vs. "monta-Monet" (tai "Source Sink 'vs" Sink lähdekoodin ").

Jotta määritä liitäntä caps / päättyy kaavio

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin.

2. Valitse Kytkeäionejavälilehti sapluuna ikkunassa.

3. Oikea-Cnuolla yksi liittyvä yhteys tyypit ja valitse Määritä Caps ....

4. Jos kiinteä yhteys cap / päättyy joko lähde tai upota pää yhteyden varmistaa asiaa Kiinteä valintanappi on valittuna ja valitse yhteys pää symboli vetää alas, esimerkiksi "Arrow Head" tai "Diamond".

- TAI -

Saat kiinteistö-pohjainen yhteys cap / päättyy joko lähde tai upota pää yhteyden varmistaa asiaa Propertyvalintanappi on valittuna, valitse "..." -painiketta ja valitse haluamasi omaisuutta ja sitten vierekkäin yhteyden päähän symboli syöttää omaisuutta arvot, joiden erityinen yhteys symboli ovat näkyvän.

Huomautus

Useita ominaisuuksien arvot tietyn yhteyden pää symboli voidaan syöttää pilkulla erotettuna. Esim. dialogi käy ilmi, että jos "Data | Kardinaliteetti omaisuuden arvo on "One-to-Monet" sitten lähde loppuun yhteys on kaksi linja aivohalvauksia läpi ja pesuallas loppuun yhteys on yksi rivi isku läpi ja sitten fan-out kahden linja aivohalvauksia lopussa.

Määritä Caps dialogi

Katso myös

Piirtotyökalu | Populating arkkitehtuurista | Analysointi arkkitehtuurista


Manipuloimalla kaaviot

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Manipuloimalla kaaviot

Lähetä kommentit tästä aiheesta.

Kun kaavio on luotu, elementtejä, jotka näkyvät se voidaan uudelleen järjestää ja uudelleen kokoinen halutulla tavalla.

Jos haluat siirtää komponentin kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Klikkaa-ja-pidäjonkin komponentin siirtää sitä. Jos valittu komponentti on vanhempi, vanhempi komponentti on korostettu.

3. Koska elementti onvetää sen emoyhtiön komponentti, ja yli muiden komponenttien, "mahdollinen" vanhemmat tulee korostettuna. Värimaailma käytetty osoittaa vaikutus toimintaan tulee olemaan varoitukset ja virheet nykyisen projektin ja kuvataan Määritteleminen ja hyväksyminen rajoitteet . Näin voit graafisesti navigoida hierarkian "pohjapiirros".

4. Julkaisuhiiren painiketta pudottaa elementti uuteen paikkaan.

Huomautus

Voit myös käyttää näppäimistöä uudelleen asetteluelementit piirustus kankaalle. Valitse vain osan tai vapaamuotoinen muoto, jonka haluat siirtää ja nuolinäppäimillä sijaitsee näppäimistöä muotoon haluttuun paikkaan.

Huomaa myös, että kun vedät komponentti hiiri toiseen komponenttiin, "potentiaalinen" vanhempi osa on korostettuna kun vasen yläkulma komponentin vedät limittyy toinen komponentti.

Kärki

Vapaa muoto ja Kelluva muodot voi tilata hiiren kakkospainikkeellaja valitsemalla Tuo eteen tai Vie taaksevalikosta. On tärkeää huomata, että komponentti muotoja voidaan muuntaa vapaamuotoinen muotoja hiiren kakkospainikkeellaerityisistä komponentti muoto ja valitsemalla Muunna Freeform.

Kokoa komponentin kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Click-hold-vedäyksi komponentin kahvat ja kokoa muoto haluttuun kokoon.

3. Vaihtoehtoisesti säilyttää kuvion kuvasuhde, masentaa Shift + Click-hold-vedä.

Liikkua yhteyden kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Klikkaa-ja-pidämitään yhteyttä siirtää sitä.

3. Julkaisuhiiren painiketta pudottaa elementti uuteen paikkaan.

Huomautus

Voit siirtää vain yhteyksiä, joita ei ole liitetty mitään osia. Jos ne ovat kiinnittyneet, voit vain siirtää vapaa pääs, tai uutta reittiä yhteys .

Poistaminen komponentit ja kytkennät

Kun poistat osan tai yhteyden kaavio, sinulla on mahdollisuus poistaa sen koko arkkitehtuuria. Mikä tahansa komponentti, joka poistetaan arkkitehtuuri poistetaan automaattisesti muista kaavioita, joissa se esiintyy. Koska vapaamuotoinen tapauksissa näkyvät vain yhdessä kaaviossa, niiden poistaminen ei vaikuta arkkitehtoninen mallia tai muuta kaavio.

Voit poistaa osan tai yhteyden kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Klikkaatahansa liittyvän yhteyden tai osan valitse se.

3. Paina PoistaaAvain poistaa sen kaavio, tai Shift + Deletepoistaa sen koko malli.

- tai -

2. Napsauta hiiren kakkospainikkeella mitään liittyvät elementtinä tai komponenttina. Pikavalikko tulee näkyviin.

3. Valita Poista näkyvistä tai Poista Arkkitehtuuripikavalikosta.

Huomautus

Jos elementti, jonka haluat poistaa näkymä ei ole lapsia ja ilmenee vain, että näkymä, ABACUS kysyy, haluatko poistaa elementin arkistosta samoin.

Varovaisuus

Kun poistat komponentin malli, joka on lapsi komponentteja, lapset myös mahdollisesti poistetaan mukaan varoitus dialogi.

Sulautuvien Komponentit

Voit halutessasi yhdistää kaksi olevat osat samalla kaavio (ja sisällä arkkitehtuuri). Tämä voidaan tehdä useista syistä, esimerkiksi, Kaksi palvelinta vallitsee yrityksen infrastruktuuri- H01 ja H02. Nämä kaksi palvelimet ovat edustettuina kahdesta erillisestä osasta sisällä arkkitehtuuri. H01 on katsottu tarpeettomaksi ja siten on poistettava käytöstä. Kaikki nykyiset sovellukset käynnissä H01 on tarkoitus siirtää H-02 (vielä provisio). Tämä muutos voidaan sitten heijastuu toiminta "yhdistämällä" kaksi komponenttia H01 ja H02 kaavion (ja sisällä arkkitehtuuri).

Yksityiskohtainen keskustelu sulautuvat katso yhdistäminen Items aihe tässä .

Yhdistää kaksi olemassa olevia komponentteja

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Napsauta hiiren kakkospainikkeella-pitääkomponentin haluat yhdistää ja vetääse kiinni komponentin haluat yhdistää sen kanssa. Varmista ääriviivat kohde komponentti korostuu punaisena ilmaisten, että se on valittu.

3. Valita Yhdistä | Säilytä Kohde tai Korvaa Kohdevalikosta.

Huomautus

Säilytä Kohdevaihtoehto säilyttää arvot kohde komponentin ominaisuudet, jos ne toimivat peräisin komponentti samoin.

Korvaa Kohdevaihtoehto korvaa kohde komponentin ominaisuuksia mitään yhteistä ominaisuuksia peräisin komponentti.

Muutat liitäntöjä

Liitännät esitetty kaavio ainaheijastavat rakenne määritelty arkkitehtuurin itse. Drawing työkalun avulla voit irrottaa yhteydet komponenteista, siirtää niitä, käyrä heitä, uusi reitti niitä ja uudelleen liittää ne muut.

Irrottaa / liittää yhteyden / komponenttiin

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Klikkaa-ja-pidätahansa yhteyden.

3. Valitayhteys pää(Ts Lähde tai Sink) Että haluat irrottaa / liittää. Huomautus: yhteyden päät merkitty pieni valkoinen piireissä ja leijuu valkoinen ympyrä toiseen aiheuttaa "tooltip" näkyvän vastaaviin rooli nimi(Eli joko lähde tai upota).

4. Vetääyhteys end uuteen paikkaan (joko vapautunut paikka tai komponentti) ja vapauta hiiren painike.

Huomautus

Kun yhteys pää on sijoitettu yli voimassa komponentti, ääriviivat kohde komponentin on korostettu katkoviivalla. Värimaailma käytetty osoittaa vaikutus toimintaan tulee olemaan varoitukset ja virheet nykyisen projektin ja kuvataan Määritteleminen ja hyväksyminen rajoitteet . Kun vapautetaan että pää the yhteys ja komponentti kytketään automaattisesti(Tai liitteenä), Ja tämä heijastuu arkkitehtuurimalli.

Uudelleen reitin yhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Sijoita hiiren osoitin yhteyden.

3. Pidä Siirtääpainettuna ja Klikkaahiiren painiketta asettaa yhteyden ankkuripisteen. Vapauta Siirtää avain. Voit poistaa tukipisteen tekemällä saman operaation.

4. Klikkaa-ja-vedätukipistettä uudelleen reitin yhteys.

Kärki

KäytäAlt avain sijasta Siirtääavain luoda ortogonaalisia yhteyksiä.

Jotta käyrä tai suoristaayhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Sijoita hiiren osoitin yhteyden.

3. Hiiren kakkospainikkeellaThän yhteys ja yhteydessä avautuvasta valikosta valitse Käyrä, Ortogonaaliset tai Suoraan.

Kärki

Kaikki liitännättietyntyyppisiä kaaviossa voidaan asettaa Kaarevat, Orthogonal tai Suora napsauttamalla hiiren kakkospainikkeella liittyvä linja tyypin Yhteydet-välilehtija Stencil ikkunaja valitsemalla Curve, Orthogonal tai Suora.

Jotta ankkuri päälle tiettyyn pisteeseen reunalla muoto

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Valitse yhteys.

3. Sijoita hiiren osoitin "valkoinen piste" lopussa yhteys.

4. Hiiren kakkospainikkeellaThän liitospäällä ja yhteydessä avautuvasta valikosta valitse Anchor Endpoint Shape.Siirrä yhteys pää halu paikalla reunalla muodon.

TAI

Pidä Ctrlpainettuna ja click-ja-vedä liitospäällä osoittaa halu sijainti reunalla muodon.

Huomautus

Yhteydet napsahtaa todellinen siepata niihin sidossuhteessa muodon sijasta muokkausalueen tuon muodon.

Katso myös

Piirtotyökalu | Populating arkkitehtuurista | Analysointi arkkitehtuurista


Piirtotyökalu Ominaisuudet

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Piirtotyökalu Ominaisuudet

Lähetä kommentit tästä aiheesta.

Piirtotyökalu tukee useita piirustus ominaisuuksia.

Zoomaus

Laajuus kaavion voidaan muuttaa zoomaus.

Voit vähentää laajuuden tai "zoom"

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Lehdistö Ctrlja "=" -näppäintä.

- tai -

2. Valitse Lähennäpainiketta Diagramtyökalurivi.

- tai -

2. Lehdistö Ctrlja pyöritä hiiren rullaa eteenpäin. Huomautus: Tässä tilassa kangas zoomaa kohti missä hiiri on leijuu kankaalle.

Lisätä laajuuden tai "loitontaa"

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Lehdistö Ctrlja "-" -näppäintä.

- tai -

2. Valitse Loitontaapainiketta Diagramtyökalurivi.

- tai -

2. Lehdistö Ctrlja pyöritä hiiren rullaa taaksepäin. Huomautus: Tässä tilassa kangas zoomaa ulospäin missä hiiri on leijuu kankaalle.

Auto-layout

Ulkoasu komponenttien kaaviossa voidaan muuttaa automaattisesti.

Layout kaikki komponentit on kaavio

1. Cnuolla Layout Kaaviopainiketta Kaavio työkalupalkin.

2. Valitajompikumpi Radial Layout tai Kantaverkkoon.

Huomautus

Radial layout käyttää mitä kutsutaan "voima-suunnattu" algoritmia siten, että liitettyjen laitteiden vedetään yhteen kun kytkemättä komponentit joutuvat erilleen. Grid layout käyttää kiinteää leveys ja korkeus väli algoritmi. Se ensinnäkin avulla käyttäjä voi valita yleistä kaavio Kuvasuhde (esim 16: 9, A4 (Muotokuva), Letter (Maisema)), ja sitten etäisyys sivuilla ja välillä sarakkeita ja rivejä alla.Kanssa Grid layout mitään osien välillä eivät vaikuta asettelu kuin se vain järjestää komponenttien aakkosjärjestykseen (niiden nimi) ylävasemmalta oikeassa alareunassa kankaalle. Kun molemmat algoritmit vapaamuotoinen muotoja ei siirretä.

Layout lapset komponentit yksinhuoltaja On kaavio

1. Hiiren kakkospainikkeellakorkean tason komponentti joiden lapset haluat auto-layout.

2. Valita Layout Lapset.

Huomautus

Oletuksena vain Radial asettelua algoritmia käytetään.

Muuttaminen Element Estetiikka pitää Väri, Avoimuus, Shadows ja Rotation

Kaikki kaavio elementeillä on estetiikka joka voidaan manipuloida halutulla tavalla. Tapauksessa liittyvien muotoja, nämä näkökohdat voidaan asettaa per tyyppija useimmissa tapauksissa myös per esimerkiksi. Kun kyseessä on vapaamuotoinen muotoja, nämä ominaisuudet voidaan asettaa per esimerkiksikankaalle.

Huomautus

Mikä tahansa kohti esimerkiksi näkökohtia, jotka on asetettu liittyvien muotoja tulee "korvataan" jos sama näkökulma on muuttunut vastaavan tyypin.

Voit vaihtaa väriä liittyvän muoto tai vapaamuotoinen muoto

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai vapaamuotoinen muoto kankaalle.

3. Valita Vaihda väriä.

4. Valitse Kiinteä Värivalintanappi (tarvittaessa).

5. Valitse Basic Väri tai Määritä Custom Väri valintaikkunassa ja valitse Kunnossa.

- tai -

4. Valitse Kaltevuusvalintanappi (tarvittaessa).

5. Valitse joko Vaaka, Pysty, Eteenpäin Diagonal tai taaksepäin Diagonal varten kaltevuus suuntaan pulldown ja napsauta Kunnossa.

6. Valitse Basic Väri tai Määritä Custom Väri käyttää dialogissa Alku ja Loppuja valitse Kunnossa.

Huomautus

Abacus väri etualalla muoto, jos;
a) se on "yksinkertainen" muotoon yhdellä taustalla graafinen elementti (esim ympyrä, suorakulmio, monikulmio jne), tai
b) se on "monimutkainen" muotoon useita taustalla subshapes jotka ovat kaikki samaa väriä / kaltevuus kuin toisiaan tai subshapes on LockScale = TOSI asetettu.
Jos edellä mainitut ehdot eivät täyty taustalla muoto on värillinen.

Asettaa väri liittyy muodon mukaan kiinteistön

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkuna(EI piirustus kankaalle).

3. Valita Vaihda väriä.

4. Valitse Property radiopainike.

5. Valitse ominaisuus klikkaamalla "..." -painiketta oikealla oppikirja.

6. Valitse Alue radiopainike.

7. Säädä Min ja Maxarvot halutulla tavalla. Huomautus: mikä tahansa arvo alle minimiarvon näkyy niin Min värisävy ja arvon yläpuolella suurimman näkyy niin Max väri. Myös, kun käytetään Boolen, Lista tai Date / Time ominaisuudet arvot muunnetaan indeksiin seuraavasti; Boolean (False = 0, True = 1), List (kokonaisluku Vale of 1 n jokaiselle kelvollinen arvo niiden nousevassa järjestyksessä määritelty yksiköiden alalla) ja Date / Time (päivien jälkeen 01 tammikuu 1900 - myös desimaaleja varten tuntia, minuuttia, sekuntia osia - ja jos päivämäärä on ennen vuotta 1990 se on negatiivinen luku).

8. Valitse Basic Väri tai Määritä Custom Väri käyttää dialogissa Min ja Maxja valitse Kunnossa.

Kärki

Jos Vihreä (RGB - 128,255,0) valitaan Min väri ja Punainen (RGB - 255,0,0) valitaan Max väri omaisuuden arvo valikoima 1että 4Sitten arvo 1näytetään Vihreä, Arvo 2kuten Keltainen, 3kuten Oranssi ja 4kuten Punainen.

Vaihtoehtoisesti ominaisuus valikoima 1että 3arvo 1on yhtä Vihreä, Arvo 2kuten Keltainen ja 3kuten Punainenaka "Liikennevalot" tai rätillä tila.

Saat ominaisuus valikoima 1-5 jos Sininen (RGB - 0,0,255) valitaan Min väri ja Punainen (RGB - 255,0,0) valitaan Max väri arvo 1 on yhtä Sininen, Arvo 2 as Aqua, Arvo 3: Vihreä, Arvo 4 kuin Keltainen ja arvo 5 kuin Punainen.

Saat ominaisuus valikoima 1-6 jos Violetti (RGB - 255,0,255) valitaan Min väri ja Punainen (RGB - 255,0,0) valitaan Max väri arvo 1 on yhtä Violetti, Arvo 2 as Sininen, Arvo 3: Aqua, Arvo 4 kuin Vihreä, Arvo 5 kuin Keltainen ja arvo 6 kuin Punainen.

Ja lopuksi, sillä kiinteistön eri 1-7 arvo 1 on yhtä Violetti, Arvo 2 as Tummansininen, Arvo 3: Vaaleansininen, Arvo 4 kuin Sinivihreä, Arvo 5 kuin Vihreä, Arvo 6 kuin Keltainen ja arvo 7 kuin Punainen

Huomautus

Katso huomautus edellä etualalla vastaan ​​taustalla väritys.

- tai -

7. Valitse Erityiset Arvo radiopainike.

8. Napsauta Muokkaa Väritpainiketta.

9. Valitse kukin arvo vuorollaan ja valitse Aseta Värimäärittää tietyn värin kullekin arvolle.

Huomautus

Vaihteluvälin alkuaineet kaaviossa on valmiiksi asuttuja.

10. Lisätä mitään lisäarvoa värejä kuin esitäytetty (esimerkiksi kun kiinteistö alue on jäsennetään) klikkauksella Add Value.

Voit vaihtaa väriä läpinäkyvyyttä liittyvän muoto tai vapaamuotoinen muoto

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai vapaamuotoinen muoto kankaalle.

3. Valita Vaihda väriä.

4. Avoimuutta Elimellä ylempää liukusäädintä haluamaasi avoimuutta pohjaväri.

5. Jos Liukuväri tai käyttäminen Kiinteistön vaihtoehtoja käytetään, vuonna Läpinäkyvyys Elimellä pohjaan liukusäädintä haluttuun avoimuutta toisen värin.

6. Klikkaa Kunnossa.

Näyttää varjojavarten kaikki liittyvä muotoja kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentitvälilehden sapluuna ikkunan.

3. Valita Lisätä Shadows.

Jotta näyttää varjo komponentti muoto tai vapaamuotoinen muoto

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Oikea-Klikkaakomponentin tai vapaamuotoinen muoto kankaalle.

3. Valita Lisätä Shadows.

Voit kiertää komponentti muotoja ja vapaamuotoinen muotoja kaaviot

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Valitse komponentti muoto tai vapaamuotoinen muoto kankaalle haluat kiertää.

3. Hiiren kakkospainikkeellaon muoto ja valitse Kiertääja sitten valitaan haluttu kulma haluat kiertää muotoon.

Muuttaminen Element Merkinnät ja Vapaamuotoiset teksteineen

Kaikki kaavio elementeillä on merkinnät joka voidaan manipuloida halutulla tavalla. Tapauksessa liittyvien muotoja, nämä näkökohdat voidaan asettaa per tyyppija useimmissa tapauksissa myös per esimerkiksi. Kun kyseessä on vapaamuotoinen muotojaja liittimet,teksteineen voidaan asettaa per esimerkiksikankaalle.Kahdeksan (8) eri tyyppisiä merkintöjä voidaan näytetään kaavio elementtejä (eli nimi, tyyppi, Ominaisuus, Kiinteistövälitys Marker, Attached komponentit, Lapset (komponenttien vain), standardit ja Aikaleimat (Kirjoittaja Muutettu jne)) vuonna kaksikymmentä (25) eri asennoissa (esim Centre - Ulkopuolella Top Inside vasen - keskus, Outside Oikea - Outside Bottom).

Huomautus

Mikä tahansa kohti esimerkiksi näkökohtia, jotka on asetettu liittyvien muotoja tulee "korvataan" jos sama näkökulma on muuttunut vastaavan tyypin.Lisäksi jos 2 tai enemmän huomautuksia miehittää samassa asemassa vain yhden Font, fontin tyyliä ja väriä ja kokoa voidaan käyttää ja erotin (esim pilkku, avaruus, uusi rivi) on valittava.

Näyttää nimi tai tyyppi varten liittyvän osan tai yhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai liitäntään kankaalle.

3. Valita Merkinnät.

Huomautus

Yksittäisen liittyy muoto tai liittimeen kankaalle sinun tulee valita Ohita Stencil Huomautukset-valintaruudun ensimmäistä kertaa.

4. Valitse Uusi Lisäykset työkalupalkissa ja valitse Nimi tai Tyyppi.

5. Vuonna avautuvassa Valitse Näytön asetukset, jotka halutaan mukaan lukien kannattimet ja Font, fontin tyyliä ja väriä ja kokoa. Myös valitse asetteluvaihtoehdot että halutaan myös vaaka- ja pystysuunnasta (eli huomautus asento) ja kulma (eli kierto). Valita Kunnossa.

Näyttää ominaisuus arvo varten liittyvän osan tai yhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai liitäntään kankaalle.

3. Valita Merkinnät.

Huomautus

Yksittäisen liittyy muoto tai liittimeen kankaalle sinun tulee valita Ohita Stencil Huomautukset-valintaruudun ensimmäistä kertaa.

4. Valitse Uusi Lisäykset työkalupalkissa ja valitse Ominaisuus Arvo.

5. Vuonna avautuvassa valitse omaisuutta klikkaamalla Property: "..." -painiketta ja valitsemalla kiinteistön Select Property valintaikkunaja valitse Kunnossa. Valitse Näytön asetukset, jotka halutaan mukaan lukien kannattimet ja Font, fontin tyyliä ja väriä ja kokoa. Myös valitse asetteluvaihtoehdot että halutaan myös vaaka- ja pystysuunnasta (eli huomautus asento) ja kulma (eli kierto). Valita Kunnossa.

Näyttää ominaisuus merkki varten liittyvän osan tai yhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai liitäntään kankaalle.

3. Valita Merkinnät.

Huomautus

Yksittäisen liittyy muoto tai liittimeen kankaalle sinun tulee valita Ohita Stencil Huomautukset-valintaruudun ensimmäistä kertaa.

4. Valitse Uusi Lisäykset työkalupalkissa ja valitse Kiinteistövälitys Marker.

5. Vuonna avautuvassa valitse omaisuutta klikkaamalla Property: "..." -painiketta ja valitsemalla kiinteistön Select Property valintaikkunaja valitse Kunnossa. Aseta säde merkki pikseleinä ja väritys tapa joko Väri ALUE tai Colour Kiinteistöpalveluiden ja asettaa värit tehtäviä. Myös valitse asetteluvaihtoehdot että halutaan myös vaaka- ja pystysuunnasta (eli huomautus asento) ja kulma (eli kierto). Valita Kunnossa.

Näyttää liitteenä komponentit varten liittyvän osan tai yhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai liitäntään kankaalle.

3. Valita Merkinnät.

Huomautus

Yksittäisen liittyy muoto tai liittimeen kankaalle sinun tulee valita Ohita Stencil Huomautukset-valintaruudun ensimmäistä kertaa.

4. Valitse Uusi Lisäykset työkalupalkissa ja valitse Liitteenä Komponentit.

5. Vuonna avautuvassa sillä niihin liittyvät komponentit valita kiinnitetty osan napsauttamalla Attached: "..." -painiketta ja valitsemalla osan Set Komponentti tyyppi dialogija valitse Kunnossa. Valitse liitteenä yhteystyyppi napsauttamalla kytketty: "..." -painiketta ja valitsemalla yhteystyyppi Set Yhteyden tyyppi -valintaikkunaja valitse Kunnossa.Saat liittyvät yhteydet valitsemalla yhteyden loppuun valitsemalla Lähde tai uppoaa liitospäällä: -pudotusvalikosta. Sekä niihin liittyvät komponentit ja liitännät valitse Näytön asetukset, jotka halutaan mukaan lukien kannattimet ja Font, fontin tyyliä ja väriä ja kokoa. Myös valitse asetteluvaihtoehdot että halutaan myös vaaka- ja pystysuunnasta (eli huomautus asento) ja kulma (eli kierto). Valita Kunnossa.

Näyttää lapset varten liittyvä komponentti

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentitvälilehden sapluuna ikkunan tai liittyvän muoto kankaalle.

3. Valita Merkinnät.

Huomautus

Yksittäiselle liittyvä muoto kankaalle sinun tulee valita Ohita Stencil Huomautukset-valintaruudun ensimmäistä kertaa.

4. Valitse Uusi Lisäykset työkalupalkissa ja valitse Lapset.

5. Vuonna avautuvassa Valitse Näytön asetukset, jotka halutaan mukaan lukien kannattimet ja Font, fontin tyyliä ja väriä ja kokoa. Myös valitse asetteluvaihtoehdot että halutaan myös vaaka- ja pystysuunnasta (eli huomautus asento) ja kulma (eli kierto). Valita Kunnossa.

Näyttää standardit varten liittyvän osan tai yhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai liitäntään kankaalle.

3. Valita Merkinnät.

Huomautus

Yksittäisen liittyy muoto tai liittimeen kankaalle sinun tulee valita Ohita Stencil Huomautukset-valintaruudun ensimmäistä kertaa.

4. Valitse Uusi Lisäykset työkalupalkissa ja valitse Standardit.

5. Vuonna avautuvassa Valitse Näytön asetukset, jotka halutaan mukaan lukien kannattimet ja Font, fontin tyyliä ja väriä ja kokoa. Myös valitse asetteluvaihtoehdot että halutaan myös vaaka- ja pystysuunnasta (eli huomautus asento) ja kulma (eli kierto). Valita Kunnossa.

Näyttää aikaleimat varten liittyvän osan tai yhteys

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Hiiren kakkospainikkeellasiihen liittyvällä muoto tai liitin Komponentit tai Liitännätvälilehden sapluuna ikkunan tai liittyy muoto tai liitäntään kankaalle.

3. Valita Merkinnät.

Huomautus

Yksittäisen liittyy muoto tai liittimeen kankaalle sinun tulee valita Ohita Stencil Huomautukset-valintaruudun ensimmäistä kertaa.

4. Valitse Uusi Lisäykset työkalupalkissa ja valitse Kirjoittaja, Kirjoittaja, Kirjoittaja Marker, Modified Muutettu tai Modified Marker.

5. Vuonna avautuvassa jos ei merkki, valitse Näytön asetukset, jotka halutaan mukaan lukien kannattimet ja Font, fontin tyyliä ja väriä ja kokoa. Jos merkki, aseta säde merkki pikseleinä ja väritys tapa joko Väri ALUE tai Colour Kiinteistöpalveluiden ja asettaa värit tehtäviä. Myös valitse asetteluvaihtoehdot että halutaan myös vaaka- ja pystysuunnasta (eli huomautus asento) ja kulma (eli kierto). Valita Kunnossa.

Muuttaa fontin tyyliä vapaamuotoinen muototai liitin

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Hiiren kakkospainikkeellaon vapaamuotoinen muoto tai liitin kankaalle. Huomautus: Jos liitin tekstistä ei näytä sitten näyttää Connecttai tekstinimiön: Hiiren kakkospainikkeellaconnecttaija valitse Lisäykset | Näytä Annotation.

3. Valita Vaihda Font.

4. Valitse kirjasin, tyyli ja koko valintaikkunassa ja valitse Kunnossa.

Muuttaa fontin väri of vapaamuotoinen muototai liitin

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Hiiren kakkospainikkeellaon vapaamuotoinen muoto tai liitin kankaalle. Huomautus: Jos liitin tekstistä ei näytä sitten näyttää Connecttai tekstinimiön: Hiiren kakkospainikkeellaconnecttaija valitse Lisäykset | Näytä Annotation.

3. Valita Muuttaa Font Väri.

4. Valitse FontVäri (ja muodot linkin väri) klikkaamalla "..." -painiketta ja valitsemalla väri -valintaikkunassa ja valitse Kunnossa.

5. Valitse avoimuus tekstistä säätämällä liukusäädintä jossa 0 on täysin avoin ja 255 on täysin läpinäkymätön.

Jos haluat kiertää tekstiä etiketissä vapaamuotoinen muototai liitin

1. Varmista, että sinulla on uusi tai olemassa kaavio avoin .

2. Hiiren kakkospainikkeellaon vapaamuotoinen muoto tai liitin kankaalle. Huomautus: Jos liitin tekstistä ei näytä sitten näyttää Connecttai tekstinimiön: Hiiren kakkospainikkeellaconnecttaija valitse Lisäykset | Näytä Annotation.

3. Valita Kiertääja sitten valitaan haluttu kulma haluat kiertää tekstinimiön mukaan.

Katso myös

Piirtotyökalu | Populating arkkitehtuurista | Analysointi arkkitehtuurista


Käyttämällä linkkejä kaaviot

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Käyttämällä linkkejä kaaviot

Lähetä kommentit tästä aiheesta.

Muodot (vapaamuotoinen ja komponentit) ja liittimet (vapaassa muodossa tai yhteyksiä) sisällä kaavioita voidaan yhdistää olemassa olevaan arkkitehtuurin edustustojen ABACUS, sekä ulkoiset tiedostot / kansiot ja URL. Nämä linkit voidaan sitten hallita (luoda, muuttaa ja poistaa) kautta ABACUS työkalut. Tätä ominaisuutta voidaan käyttää parantamaan navigointi ja kokonaisvaltaista ymmärtämistä arkkitehtuurista kaavamaisesti.

Voit lisätä linkkejä kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Valitse oikea muoto tai liitin teidän kaavio.

3. Hiiren kakkospainikkeellamuodontai liitin.

4. Valita Avaa linkitja Linkitikkuna avautuu.

5. Klikkaa Lisätäkuvake ja Uusi linkkiikkuna avautuu.

6. Valitse haluamasi Katalogi | Matrix | Kaavio| 3D-näkymä| Kartoittaaradio Valitse sitten asiaa luettelo, matriisi, kaavio, 3Dtai kaavio näkymä nykyisen arkkitehtuurin Linkki pudotusvalikosta.

- tai -

6. Valitse Verkkosivustovalintanappi sitten, syötä tarvittavat URL (Esim. Http: //www.avolutionohjelmisto.com /)alalla linkki web-sivulle. Voimassa URL täytyy aloittaa jollakin 5jouset; http: //, https: //, ftp: //,tiedosto: tai \\. Välilyöntejä tulee syöttää "% 20".

- tai -

6. Valitse Absoluuttinen File | Suhteellinen File radiopainikes,napsauta "..."-painiketta Selaamaan ulkoisen tiedoston linkittää kaavio.

7. Klikkaa Kunnossaja uusi linkki näkyy Linkit ikkunassa. Huomautus: Linkkejä ikkuna kokoa voi muuttaa nähdä koko nimeä tarvittaessa.

8. Toista vaiheet 5-7luoda enemmän yhteyksiä.

9. Voit seurata luotu linkkiä, valitse asiaankuuluva yhteys näkyy Linkitikkuna ja klikkaa Avaa linkki.

Huomautus

Milloin useita huomautuksia ovat esitetty muoto tai liitin linkki näkyy ensimmäinen merkintä luettelossa Huomautusten Muokkaa Huomautukset dialogi.

Seurata linkkejä kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Valitse oikea muoto tai liitin teidän kaavio.

3. Klikkaaasianomaisilla hyperlinkin (sininen alleviivattu osa nimen) muoto tai liitin Kaavion avata ja nähdä ensimmäisen linkin muototai liitin.Huomautus: Osoitin tulisi muuttua "käsi", kun linkki on valmis napsautetaan.

- tai -

3. Valitse oikea muoto tai liitin teidän kaavio.

4. Hiiren kakkospainikkeellamuodontai liitin.

5. Valita Avaa linkit ja Linkitikkuna avautuu.

6. Valitse kyseinen linkki, joka haluat nähdä.

7. Klikkaa Avaa linkkipainiketta avata ja katsella asiaankuuluva yhteys.

Voit poistaa linkkien kaavio

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Valitse oikea muototai liitinteidän kaavio.

3. Hiiren kakkospainikkeellamuodontai liitin.

4. Valita Avaa linkit ja Linkitikkuna avautuu.

5. Valitse kyseinen linkki, on poistettava.

6. Klikkaa Poistaapainiketta. ja linkki poistetaan Linkit ikkuna.

Järjestelytoimikunnan linkkien kaavio

Voit valita joka liittyy kaavio, ulkoisen tiedoston tai web URL näkyy, kun muoto etiketti on Ctrl + napsautetaan kaaviossa.

1. Varmista, että sinulla on olemassa kaavio avoin .

2. Valitse oikea muoto tai liitin teidän kaavio.

3. Hiiren kakkospainikkeellamuodontai liitin.

4. Valita Avaa linkit ja Linkitikkuna avautuu.

5. Muuttaa järjestystä linkit klikkaa Siirrä ylös | Siirrä alaspainikkeita oikealla puolella Linkit ikkuna.

6. Ensimmäinen linkki, joka näkyy vasemmalla puolella Linkitikkuna on linkki, joka näyttää, kun Ctrl + Clickhyperlinkitetty muoto tai liitin nimi.

Katso myös

Populating arkkitehtuurista | Asuttavat arkkitehtuurista manuaalisesti | Analysointi arkkitehtuurista


Kaavio Näkökulmia

Navigation: Asuttavat laitealustan käyttäminen> Piirustukset>

Kaavio Näkökulmia

Lähetä kommentit tästä aiheesta.

The näkökulmiaominaisuus varmistaa, että osat ja liitännät, joita lisätään kaavio on oltava yhdistyksen edellä on määritelty, ennen kuin ne voidaan lisätä kaavio. Tämä ominaisuus mahdollistaa rajoittamisesta tyyppisiä kaavioita, jotka voidaan tehdä rajoittamalla muotoja ja liittimet, jotka liittyvät komponentit ja Liitännätolemassa olevista arkkitehtuurista.

Käyttöönotto tai poistaminen käytöstä täytäntöönpano kaavio näkökulmia

Kykyä valvoa kaavio näkökulmia automaattisesti oletusarvoisesti käytössä. Voit poistaa / ottaa tämän ominaisuuden klikkaa Työkalut | Asetukset ...| Kaaviovälilehti ja poista / valitse Pakota Kaavio Näkökulmia-valintaruutu vastaavasti.

Huomautus

Jos et näe "Pakota Kaavio Näkökulmia"Vaihtoehto kaavio-välilehden sitten sinulla ei ole Designer lisäosan ja vaihtoehto on oletusarvoisesti käytössä.

Luominen täytäntöönpanokelpoinen kaavio näkökulma

1. Varmista, että käytössä ABACUS tiedosto auki tutkimusmatkailijaon näkyvissä.

2. Vuonna Explorerissa Näytä klikkaa hiiren oikealla Näkymäkohtasja klikkaa Luoda Kaavio Näkökulma

3. Kaavio NäkökulmaNäyttöön tulee.

4. Määritä asiaankuuluva nimi kaavio näkökulmaja huomaa, että näkökulma on tallennettu Näkökulmiaosa tutkimusmatkailija.

5. Kaavio NäkökulmaNäyttöön tulee.

6. Nyt klikkaa ja vedä kyseisen komponentin tyypit ja yhteystyypit teidän arkkitehtuurit päälle näkökulma muodot haluat. Komponenttityypiton vetää päälle muotovuonna muodotvälilehti, kun taas yhteystyypiton vetää päälle yksi 5 viivatyylin muodotvuonna liittimetvälilehti.

7. Voit tallentaa kaavio näkökulmaolet luonut klikkaa [image] oikeassa yläkulmassa alakulmassa Kaavio Näkökulma ikkuna.

Huomautus

kaavio näkökulmavoi muokata oikealla klikkaamalla näkökulma ja valitsemalla Avata tai tuplaklikkaamalla näkökulma.

Synchonising päivitetty näkökulmasta kaavioiden

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Joko hiiren kakkospainikkeella näkökulma Tutkimusmatkailija ikkuna alla Meta-malli | Näkökulmiaja valitse Sync Kaavio Kuvaukset ...

- tai -

3. Lähellä avoin ja päivitetty näkökulma ikkuna ja valitse Kyllävuonna Synkronoi Näkökulmadialogi, joka näkyy.

4. Näkökulma SynkronointiNäyttöön tulee alla olevan kuvan.

Valintaruudut

· Lisättävä puuttuvat Kuvaukset- Jokainen uusi muoto (tyyppihyväksyttävä) tai-liitin (yhteystyyppi) järjestöt, jotka on lisätty jotta näkökulmastalisätään vastaava kaaviot (eli niiden sapluunat) että liittyvät näkökulmasta.

· Päivittää olemassa oleviaKuvaukset- Päivitetyt näkökohtia nykyisen muodon (tyyppihyväksyttävä) tai-liitin (yhteystyyppi) yhdistykset näkökulma(Esim väri, fontteja) päivitetään vastaava kaaviot (eli niiden sapluunat) että liittyvät näkökulmasta.

· Poista ExtraKuvaukset- Ylimääräiset muoto (tyyppihyväksyttävä) tai-liitin (yhteystyyppi) järjestöt, jotka on lisätty ja kaaviot (eli niiden stensiilit), mutta eivät ole näkökulmapoistetaan vastaava kaaviot (eli niiden sapluunat) että liittyvät näkökulmasta.

· Korvaa Paikalliset asetukset lisätty tai päivitetty Kartoitukset (Erot vain)- Päivitetyt näkökohtia nykyisen muodon (tyyppihyväksyttävä) tai-liitin (yhteystyyppi) yhdistykset näkökulma(Esim väri, fontteja) sovelletaan vastaavaan elementtejä kaaviot, jotka liittyvät näkökulmasta.Vain päivitetyn "eroja" tehty näkökulmasta sovelletaan niin kaikki nykyiset paikalliset asetukset kaaviossa, joita ei ole päivitetty näkökulma pysyy ennallaan.

· [image] Merkinnät – Kuten edellä mutta erityisesti merkintöjä.

Katso myös

Piirtotyökalu | Populating arkkitehtuurista | Analysointi arkkitehtuurista


Populating käyttämällä Luettelot

Navigation: Asuttavat arkkitehtuurista>

Populating käyttämällä Luettelot

Lähetä kommentit tästä aiheesta.

A luettelo voit tarkastella ja muokata komponentit tai yhteydet ja niiden ominaisuudet yksinkertaisella taulukkomuodossa tavalla.

Jotta Luo uusi katalogi katseltaviksi ABACUS

Huomautus

Vaikka kaikki Arkkitehti käyttäjät voivat luoda uusia Luettelot, tallentaa muutokset olemassa olevaan katalogi asetukset käyttäjän lisenssi tarvitsee Designer lisäosa ominaisuus. Tämä on "suojella" asetukset nykyisten Luettelot jotka voidaan jakaa useille käyttäjille. Kuitenkin arkkitehti käyttää ilman Designer lisäosa voi silti valita "Tallenna nimellä" kaikki uudet asetukset uuteen Catalogue. Ja tietysti kaikki käyttäjän lisenssit voi valita "hävittämään" muutoksia olemassa olevaan Catalogue. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset Suunnittelija lisäosa valmiudet. Ja muistakaa, tämä on vain asetukset Catalogue, kaikki muutokset tietoihin tehdyt yhteisön luettelossa ovat välittömästi levitetään arkistoon riippumatta.

1. Valitse Insert | Luettelo.

2. Vuonna avattavista valita Architecture joka sisältää komponentit taiyhteyksiä haluat tarkastella.

3. Vuonna avattavista valitse komponentti tai yhteyden tyyppi että haluat olla tapauksia listattu "rivit' luettelossa.

4. luettelo on asuttujarivin jokaista esimerkiksi valitun osan tai yhteystyypin.

Huomautus

Oletuksena vasen eniten Hierarkia Polkusarake (eli hierarkia vanhemman komponenttien tai tiedonsiirtonopeus on yli valitun tapauksissa) ja toinen Nimi sarake (eli luettelo valitun komponentin tai yhteyden tapauksissa) jäädytetään vasemmalla luettelo. Jos haluat muuttaa sarakkeen jäätymispiste vedä sarakkeen erotin oikealle Nimi-sarakkeen. Sinä pystyt re-ordersarakkeet vetämällä ja pudottamalla niiden sarakeotsikot. Solut palstoja sininen alleviivaus ovat hyperlinkkejä muihin elementteihin hankkeeseen ja hyperlinkkejä voi seurata pitämällä Ctrl ja klikkaamalla linkkejä. Sarakkeet voi olla kätketty oikealla klikkaamalla sarakkeen otsikkoa ja valitsemalla solu | Piilota sarake. Piilotetut sarakkeet voidaan unhidden napsauttamalla Määritä sarakkeet työkalurivin painiketta ja käyttämällä Määritä sarakkeet -valintaikkuna kuten alla, tai valitsemalla alanuolta osa Määritä sarakkeet työkalurivin painiketta ja erikseen valitsemalla piilotettu sarake (t) joko General, Kiinteistöt tai -laitteet kokoelmista. Rivit voi olla ryhmitelty niiden sarakkeen arvot vetämällä sarakkeen otsikon siniseen ryhmittymän yläreunassa kuvaston. Milloin tahansa voit kaksoisnapsauttaa luettelo rivi valitsin ja hypätävastaava komponenttitai yhteysExplorer-ikkunassa.Kiinteistövälitys solujen arvot ovat lihavoitu jos ne poikkeavat oletukset, ja kursivoitua jossa ne vain lukea. Aikaleiman, Kiinteistövälitys ja Attached Component sarakkeita voi olla värillinen mukaan solujen arvot tai liitetty osa omaisuuden arvoa hiiren kakkospainikkeella sarakkeen otsikkoa ja valitsemalla solu | Vaihda väriä ... ja sitten Colour mukaan Aikaleima tai Colour kiinteistöverot vaihtoehto kuitenkin vain Luettelo, Integer, Desimaali, Boolen tai Päivämäärä / aika tietotyyppi ominaisuudet väri. Kiinteistövälitys arvot Attached Komponentti sarakkeita voi olla näytetään oikealla klikkaamalla sarakkeen otsikkoa ja valitsemalla solu | Näytä Kiinteistövälitys ... ja sitten Näytä Property vaihtoehto. Ja lopuksi, jossa on Vaadittu rajoitteet asetettu ominaisuus sarakkeen nämä saatetaan näyttää merkkijono (yhdessä väritys mukaan niiden täytäntöönpano tasot) hiiren kakkospainikkeella sarakkeen otsikkoa ja valitsemalla solu | Näytä .

Luettelo

Jotta Lisää / näytä sarakkeet a Luettelo näkymä Abacus

1. Varmista, että sinulla on Catalogue näkymä avata.

2. Piilotetut sarakkeet voidaan erikseen unhidden klikkaamalla nuoli oikealle Configure kolumnit työkalurivin painikettaja valitsemalla piilotettu sarake joko Yleinen, Ominaisuudet tai Liitteet kokoelmia.

Huomautus

Valintamerkki näkyy vieressä näytössä oleva sarakkeet luettelo.Lisäksi vain tietyt liitteet on saatavilla Liitteet § mukaan rajoitteet jotka on määritelty projektin. Erityisesti varten kiinnitys käytettävissä esitetään komponentin luettelo komponentin tyyppi luettelo on määritettävä joko lähde tai upota (EI "Kaikki") of "yhteys on liitettävä" rajoite yhteys tyyppi, ja siellä on myös oltava vähintään yksi komponentti tyyppiä määritelty joko lähde tai upota (EI "Kaikki") toisen "pää" saman yhteyden tyyppi.

- TAI -

2. Useita sarakkeita voidaan unhidden (tai tilata tai kiinteä) napsauttamalla Määritä sarakkeet työkalurivin painikeja käyttämällä Määritä sarakkeet valintaikkuna alla.

Huomautus

Näkyvissä olevan sarakkeet näkyvät paneelissa Oikealla käytettävissä sarakkeet näkyy paneelin vasemmalla. Käytettävissä sarakkeita voidaan suodattaa mukaan Valitse Käytettävissä Kolumnitavattavan ja ne voidaan lisätä valitsemalla ne paneelissa vasemmalla ja klikkaamalla Lisätä painike inbetween kaksi paneelia.

Määritä sarakkeet dialogi

Jotta poistaa / piilottaa sarakkeita Luettelo näkymä Abacus

1. Varmista, että sinulla on Catalogue näkymä avata.

2. Napsauta hiiren kakkospainikkeella sarakkeen otsikkoa sarakkeen haluat poistaa / piilottaa ja valitse Sarake | Piilota sarake.

- TAI -

2. Useita sarakkeita voidaan piilottaa (tai tilata tai kiinteä) napsauttamalla Määritä sarakkeet työkalurivin painikeja käyttämällä Määritä sarakkeet Dialog yllä.

Huomautus

Näkyvissä olevan sarakkeet näkyvät paneelissa Oikealla käytettävissä sarakkeet näkyy paneelin vasemmalla. Näkyvissä olevan sarakkeet voidaan piilottaa valitsemalla sarake paneelissa oikealla ja napsauttamalla Poistaa painike inbetween kaksi paneelia.

Asuttamaan käyttämällä Luettelo näkymä Abacus

1. Jotta Lisää komponentti tai yhteysvalitun tyyppi että luettelo (ja hanke) napsauttamalla Lisää uusi Komponentti / Lisää uusi yhteys työkalurivin painiketta. Riviä näkyvät ja komponentti tai yhteys luodaan yläosassa tasolla Osat tai Liitännät kokoelma valitun arkkitehtuurin.

Huomautus

Uudet komponentit ja yhteydet lisätään oletuksena ylimmällä tasolla komponenttien tai yhteydet kokoelma valitun arkkitehtuurin. Muuttaa vanhempi uusien osien ja yhteyksiä hiiren kakkospainikkeella Hierarkia polku solun uuden osan tai yhteyksiä rivi ja valitse Muuta Parent ...ja valitse haluttu vanhemman (ottaen huomioon rajoitus korostus ).

Huomautus

Uudet rivit / elementtejä lisätään suoraan luettelo kautta "Lisää uusi" -painiketta, liitetään luettelo, tai luotu kautta tuontia luetteloon MS Excel on vapautettu suodatus kunnes luettelo on kiinni. Tämä mahdollistaa tarvittavien muokkaaminen sarakkeen arvoja, jotka eivät ehkä täytä nykyisiä suodatus kriteerit luettelo. Näiden uusi elementti rivejä on merkitty "+" symboli rivinvalitsimen solun alussa rivi, joka on värillinen vihreä jos elementti kokoontuu nykyisin tallennettu suodatus kriteerit luettelo (eli jää luettelona, ​​jos uudelleen avattu), ja punainen jos se ei.

2. Jotta Poista komponentti tai yhteysvalitun tyyppi alkaen luettelo (ja hanke) valitse rivi ja joko painamalla Del-näppäintä tai napsauta hiiren kakkospainikkeella rivin valitsin ja valitse Poista Arkkitehtuuri. rivi pitäisi kadota kuvastosta ja se poistetaan hanke.

Jotta suodattaa käyttämällä Luettelo näkymä Abacus

1. Varmista, että sinulla on Catalogue näkymä avata.

2. Jos suodatin rivi ei näy yläreunassa luettelo napsauta Näytä suodatin otsikkorivityökalurivin painiketta.

3. Sarakkeessa haluat lisätä suodatin, kaksoisnapsauta suodatin rivin soluun, jossa se esittää "(kaikki)".

4. Varten Aikaleima, Hierarkia Path, Nimi tai Kuvausyleinen sarakkeita tai Teksti, Integer, Desimaali, Boolen tai Treffiaikaomaisuus sarakkeita napsauttamalla ... -painiketta, joka näkyy oikealla puolella suodattimen rivin solu ja kirjoita solun arvot, jotka olisi sisällytettävä luetteloon.

Huomautus

Sovitus suoritetaan ikään kuin "*" jokerimerkit sovelletaan automaattisesti ennen ja jälkeen mikä tahansa merkkijono arvot niin, että merkintä "kissa" (ilman lainausmerkkejä) kuuluisi riveihin "Bobkissa','kissanainen "tai" sokissaion 'jne. Useita / "tai" arvoja voidaan merkitä uusia ratoihin Ctrl + Enter. Kokonaisluku ja Decimal omaisuutta sarakkeita "ja" logiikka voidaan sisällyttää käyttäen "&"(Ilman lainausmerkkejä) ja suurempi kuin / pienempi kuin jne logiikka voidaan sisällyttää käyttäen"> =','>','<' ja '<="(Ilman lainausmerkkejä) esim. '> = 50000 & <90000 ". Ei-tyhjä arvo riviä voidaan sisällyttää syöttämällä "(Non-aihiot)"(Ilman lainausmerkkejä) ja Tyhjä arvostettu riviä voidaan sisällyttää syöttämällä"(Aihiot)"(Ilman lainausmerkkejä).Ja lopuksi, kaikki suodattimet ovat oletuksena kirjainkoko niin "kissa" (ilman lainausmerkkejä) kuuluisi riveihin "kissa", "Kissa" tai "CAT" jne kirjainkoko matching, kirjoita "(Asia)"(Ilman lainausmerkkejä) ennen merkkijonon esim. "(Asia) Cat" (ilman lainausmerkkejä) sisältyvät vain riveihin "Kissa" niihin.

5. Varten Liitteetsarakkeet, Standardit sarakkeita tai Lista omaisuus sarakkeet napsauttamalla alanuolipainiketta, joka näkyy oikealla puolella suodattimen rivin solu ja valitse solu arvot valintaruudut olisi sisällytettävä luetteloon.

Huomautus

"(Valitse kaikki)" valintaruutu mahdollistaa kaikki muut valintaruudut, itse asiassa mukaan lukien kaikki käytettävissä rivit. "(Non-aihiot)" valintaruutu sisältää ei-tyhjä arvostettu rivejä. "(Aihiot)" valintaruutu sisältää tyhjiä arvostettu rivejä. Ja lopuksi, poistamalla erityisiä arvostettu valintaruudut automaattisesti Poista valinnat "(Valitse kaikki)" ja "(Non-aihiot)" valintaruudut johdonmukaisuus.

6. Klikkaa Kunnossa soveltaa suodatinta.

Jotta poista / enable suodatusta a Luettelo näkymä Abacus

1. Varmista, että sinulla on Catalogue näkymä avata kanssa suodattaa sovellettu.

2. Napsauta valintaruutu vasemmalla suodatin rivin.

Jotta poista suodatin a Luettelo näkymä Abacus

1. Varmista, että sinulla on Catalogue näkymä avata kanssa suodattaa sovellettu.

2. Voit poistaa yksittäisen sarake suodatin hiiren kakkospainikkeella sarakeotsikkoa ja valitse Sarake | Kirkas suodatus.

3. Voit poistaa kaikki suodattimet napsauttamalla Vaihtoehdot työkalurivin painike ja valitse Poista suodatin Asetukset.

Pelastaa / Tallenna nimellä aCatalogue näkymä

Huomautus

Vaikka kaikki Arkkitehti käyttäjät voivat luoda uusia Luettelot, tallentaa muutokset olemassa olevaan katalogi asetukset käyttäjän lisenssi tarvitsee Designer lisäosa ominaisuus. Tämä on "suojella" asetukset nykyisten Luettelot jotka voidaan jakaa useille käyttäjille. Kuitenkin arkkitehti käyttää ilman Designer lisäosa voi silti valita "Tallenna nimellä" kaikki uudet asetukset uuteen Catalogue. Ja tietysti kaikki käyttäjän lisenssit voi valita "hävittämään" muutoksia olemassa olevaan Catalogue. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset Suunnittelija lisäosa valmiudet.Ja muistakaa, tämä on vain asetukset Catalogue, kaikki muutokset tietoihin tehdyt yhteisön luettelossa ovat välittömästi levitetään arkistoon riippumatta.

1. Varmista, että sinulla on uusi tai olemassa Catalogue näkymä avataja olet tehnyt tarvittavat muutokset.

2. Vuonna Catalogue näkymätyökalurivi klikkaa Tallentaapainiketta tallentaaksesi Catalogue näkymä ja kaikki muotoilumuutokset.

Huomautus

Jos sinulla ei ole Tallenna-painiketta Luettelon mielestä työkalurivin niin sinulla ei ole Designer lisäosan ja olet vain voi Tallenna nimelläasetuksia muuttuu uuden tuoteluettelon kun menet sulkea nykyisiä luettelo.

3. Jos Luettelo Nimivalintaikkuna tulee esiin (Koska on uusi luettelo) anna nimi luettelo ja paina Kunnossa.

Jotta vienti MS Excel luettelo

1. Varmista, että sinulla on Catalogue näkymä avata.

2. Napsauta Vie Exceliin katalogi taulukkolaskentatyökalurivin painiketta.

3. Valitse tiedostonimi pelastaa MS Excel luettelo. Klikkaa Tallentaa.

Huomautus

Oletuksena viedä MS Excel luettelo tiedostonimi on Catalogue nimi loppuliitteenä Architecture nimi suluissa, esim "Hankkeet (2014 Todellinen) Xlsx". Voit muuttaa tämän, myös se, onko tiedostomuoto on olla Xlsx tai .xls. Arkkitehtuuri nimi sisältyy muistuttaa käyttäjää, että kukin luettelo on konkreettinen sisältö (eli tunnukset sarakkeessa ja rivi 1), jotta se voi olla pyöreä-lauennut takaisin käyttäen Tuo MS Excel luettelo kohti alla.

Huomautus

Oletuksena piilotettu sarake sisällä viedä MS Excel luettelo sisältää yksilöllinen tunnus kullekin elementtien ABACUS arkistoon. Tämä mahdollistaa muutoksia että tehdään MS Excel on "Hyväksytty" nykyiseen elementit ABACUS tuonnissa (katso alla). Kuitenkin käyttää tätä yksilöllinen tunnus on "sovittaa" riviä voidaan ohittaa kanssa Ulkoinen | IDomaisuutta elementti. Eli jos elementti on ulkoinen | ID omaisuus ja se sisältyy luetteloon viennin sitten arvot ulkoinen | ID sarake käytetään sovittaa rivit tuonnissa (katso alla) ja yksilöllinen tunnus arvoja piilotettu sarakkeessa ohitetaan (ja voi jopa olla tyhjä). Piilotettu sarake itsensä on kuitenkin edelleen erityisesti solun A1 arvo. Lisäksi kun lisätään ulkoinen tunnus: n olemassa olevaan ABACUS elementti kokoelma suosittelemme lisäämään niitä eri kiinteistö ensimmäinen, esimerkiksi Ulkoinen | Temp ja sitten nimeämällä omaisuuden Ulkoinen | ID. Muuten kahtena elementit lisätään.

Catalogue muotoiluviedään oletuksena kuitenkin suuria luetteloita tämä voi johtaa vienti on melko hidasta. Näin ollen Työkalut | Asetukset ...sitten Luettelovälilehti,voit vähentää muotoilut viedään osoittamalla katalogi välilehden alla, mikä nopeuttaa vienti.

Luettelo vienti vaihtoehdot

4. Vie Valmiit valintaikkuna. Klikkaa Kunnossa.

Viedään MS Excel luettelo

Jotta tuonti MS Excel luettelo

Huomautus

Oletuksena piilotettu sarake sisällä viedä MS Excel luettelo (katso edellä) sisältää yksilöllinen tunnus kullekin elementtien ABACUS arkistoon. Tämä mahdollistaa muutoksia että tehdään MS Excel on "Hyväksytty" nykyiseen elementit ABACUS tuonnin. Kuitenkin käyttää tätä yksilöllinen tunnus on "sovittaa" riviä voidaan ohittaa kanssa Ulkoinen | IDomaisuutta elementti. Eli jos elementti on ulkoinen | ID omaisuus ja se sisältyy luetteloon vienti (katso edellä) sitten arvot ulkoinen | ID sarake käytetään sovittaa rivit tuonnissa ja yksilöllinen tunnus arvoja piilotettu sarakkeessa ohitetaan (ja voi jopa olla tyhjä). Piilotettu sarake itsensä on kuitenkin edelleen erityisesti solun A1 arvo. Lisäksi kun lisätään ulkoinen tunnus: n olemassa olevaan ABACUS elementti kokoelma suosittelemme lisäämään niitä eri kiinteistö ensimmäinen, esimerkiksi Ulkoinen | Temp ja sitten nimeämällä omaisuuden Ulkoinen | ID. Muuten kahtena elementit lisätään.

1. Varmista, että sinulla on Catalogue näkymä avata.

2. Napsauta Tuo Excel Catalogue taulukkolaskentatyökalurivin painiketta.

3. Valitse tiedostonimi tuoda MS Excel katalogin. Klikkaa Avata.

4. Uusi Havaittu virheitä ja / tai uusia virheitä / Varoitukset Detected valintaikkunat voivat näkyä, jos uusi sisältö (eli rivit MS Excel), että lisättiin. Huomioitava virheiden / varoitusten ja valitse Kunnossa.

5. Tuo Valmiit valintaruutu näkyy ja se voi näyttää varoituksia koska tuonti (katso tiedot alla). Klikkaa Kunnossa.

Huomautus

Sillä annetaan standardeja tai liittää Component sarakkeita, uudet merkinnät kautta MS Excel luettelo on täsmälleen nimi olemassa olevan standardin tai Component oikean tyypin luovuttamista tai yhteys lisätään. Ensimmäinen nimeltä ottelu käytetään ja kaikki verraton merkinnät tuottaa varoitus kohti alla. Lisäksi vaikka varoituksia annetaan jälleentuonti, elementit ovat ei poistetaalkaen ABACUS jos ne eivät ole läsnä MS Excel luettelo. Tämä johtuu siitä, että ei ole mitään keinoa, että ABACUS voi tietää onko osoitettu Standard tai liittää Component olemassa ABACUS hankkeeseen, mutta ei ole olemassa MS Excel luettelo, koska se on poistettu MS Excel luetteloon tai on lisätty ABACUS hankkeelle, koska luettelo on viety. Vastaavasti, jos käyttäjät haluavat helposti "havaita", mitä yhteyksiä on lisätty tuonnin aikana he voivat yksinkertaisesti luoda vaaditaan kiinteistön yhteyden tyyppi ja aseta se on oletuksena tyhjä niin, että ne varoitetaan kaikista uusia yhteyksiä aina tuonti on valmis.

Huomautus

Kun tuot MS Excel luettelo eri varoituksia voidaan näyttää. Ensinnäkin, jos uusi sarake lisättiin Excel, joka ei vastaa "syntaksin" varten kiinteistön tai kiinnitetty komponentti sarake ohitetaan. Seuraavaksi linja-riviltä varoitukset näkyy mitään ongelmia tiedot kunkin rivin Excel luettelo. Nämä varoitukset alkavat rivin numero hakasulkeissa ja tarvittaessa sarakkeeseen etiketti (eli "[23, J] ..." varten rivi 23, sarake J) ja voivat viitata poistetut kohteet, verraton standardit tai liitetty Komponentti nimet (joka ohitetaan kohti huomautus edellä) tai virheellinen tai tyhjä tunnus liittyvät uusi rivi / elementti (joka lisätään). Yksityiskohtainen artikkeli asuttavat ABACUS Excel luettelot katso Avolution Yhteisön tai salkunhoitaja kurssin.

Huomautus

Uudet komponentit ja yhteydet lisätään oletuksena ylimmällä tasolla komponenttien tai yhteydet kokoelma valitun arkkitehtuurin. Muuttaa vanhempi uusien osien ja yhteyksiä hiiren kakkospainikkeella Hierarkia polku solun uuden osan tai yhteyksiä rivi ja valitse Muuta Parent ...ja valitse haluttu vanhemman (ottaen huomioon rajoitus korostus ).

Huomautus

Elementtejä lisätään suoraan luettelo kautta "Lisää uusi" -painiketta, liitetään luettelo, tai luotu kautta tuontia luetteloon MS Excel on vapautettu suodatus kunnes luettelo on kiinni. Tämä mahdollistaa tarvittavien muokkaaminen sarakkeen arvoja, jotka eivät ehkä täytä nykyisiä suodatus kriteerit luettelo. Näiden uusi elementti rivejä on merkitty "+" symboli rivinvalitsimen solun alussa rivi, joka on värillinen vihreä jos elementti kokoontuu nykyisin tallennettu suodatus kriteerit luettelo (eli jää luettelona, ​​jos uudelleen avattu), ja punainen jos se ei.

Jotta vertailla sisällön luettelo toisen arkkitehtuuri

1. Katso aiheeseen tässä .

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Asuttavat arkkitehtuurista Visio | Asuttavat arkkitehtuurista Excel


Populating käyttäen Matriisit

Navigation: Asuttavat arkkitehtuurista>

Populating käyttäen Matriisit

Lähetä kommentit tästä aiheesta.

Matriisi voit tarkastella ja muokata 'suoraan' yhteydet laitteiden välillä yksinkertaisella taulukkomuodossa tavallaja myös katsella "epäsuora polku laitteiden välillä minkä tahansa välikomponentit (ja liitännät).

Jotta luoda Matrix näkymä Abacus

Huomautus

Vaikka kaikki Arkkitehti käyttäjät voivat luoda matriisit pelastaa heidät ja / tai niiden asetuksia käyttäjän lisenssi tarvitsee Designer lisäosa ominaisuus. Tämä on "suojella" asetukset nykyisten Matriisit jotka voidaan jakaa useille käyttäjille. Kuitenkin arkkitehti käyttää ilman Designer lisäosa voi silti valita "Tallenna nimellä" kaikki uudet asetukset uuteen Matrix. Ja tietysti kaikki käyttäjän lisenssit voi valita "hävittämään" muutoksia olemassa olevaan Matrix. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

1. Valitse Insert | Matrix.

2. Vuonna <rchitecture>avattavista valita Architecture joka sisältää komponentit ja liitännät haluat katsella.

3. Vuonna <LähdeTyyppi>avattavista valita osan, joka haluat olla tapauksia listattu "rivit' Vasemmallamatriisin.

4. Vuonna <PesuallasTyyppi>avattavista valita osan, joka haluat olla tapauksia listattu "sarakkeet' yläosassamatriisin.

5. Vuonna vedä alas on lähinnä kaksi "tilaa" matriisin voit määrittää ...

"Suora" yhteydet matriisit

6. Yksinkertaisesti svalita yksi (1) tai enemmän yhteys tyypit oikealla puolella avautuvasta valikosta jos haluat nähdä "solujen matriisin josn nimenomaistayhteys on olemassa siitä Pystysuora/ "rivi"Komponentti matriisi Vaakasuora/ "sarake"Osa matriisin.

Huomautus

Vain yhteydet lähteen pää on kiinnitetty Pystysuora/ "rivi"Komponentti ja pesuallas pää on kiinnitetty Vaakasuora/ "sarake"Komponentti tulee näkyviin. Kytkin Lähde ja Pesuallasosan valintoja katsella yhteydet vastakkaiseen suuntaan.

7. Matriisi on asuttuja 'X' soluissa (tai kiinteistön arvo - katso alla oleva huomautus) jos on yhteys Pystysuora/ "rivi'komponentti matriisi Vaakasuora/ "sarake"Osa matriisin.

Huomautus

Suurissa matriisit vain enintään 100 riviä tai saraketta (myös romahti riviä / saraketta) näytetään kerrallaan mikä näkyy "R" ja "C" indikaattoreita vasemmassa yläkulmassa otsikkosoluun vastaavasti. Voit tarkastella rivejä käyttää vierityspalkkeja. Milloin tahansa voit kaksoisnapsauttaa Pystysuora/ "rivi' tai Horizontal / "sarake"Komponentti otsikot ja hypätävastaava komponentit Explorer-ikkunassa.Vanhemmat Pysty/ "rivi' ja Vaakasuora/ "sarake"Komponenttis myös mahdollisesti esitetty nimikkeeseen rivejä / sarakkeita harmaa otsikko otsikko. Kun romahti (yksittäisinä klikkaamalla otsikon solu) jos lapset liitetiedostoja olemassa sitten 'X' mahdollisesti näytetään, jos kaikki lapset olivat kiinni tai "O" tulee mahdollisesti olla näkyvissä, jos vain osa lapsista oli liitetty. Solut voivat olla värillinen mukaan omaisuuden arvo on yhteyksien napsauttamalla Asetukset "hammaspyörän yläreunassa oikeassa matriisin työkalupalkin ja valitsemalla Väriasetukset ... ja sitten Muokkaa-painiketta ja valitsemalla Colour mukaan Aikaleima tai Colour Kiinteistöpalveluiden vaihtoehto ja valitsemalla ominaisuus, Min ja Max arvoalueella ja värien kuitenkin vain Luettelo, Integer, Desimaali, Boolen tai Päivämäärä / aika tietotyyppi ominaisuudet väri. Jos romahti solu väritetään mukaan keskimäärin omaisuuden arvo on yhteyksiä. Sen sijaan, että "X", omaisuuden arvot solut voivat olla näytetään napsauttamalla Asetukset "hammaspyörän yläreunassa oikeassa matriisin työkalupalkin ja valitsemalla Näytä Arvo Asetukset ... ja sitten Muokkaa-painiketta ja valitsemalla Näytä omaisuutta vaihtoehto ja valitsemalla omaisuutta.

Suorat yhteydet taulukko, jossa palvelimet Jos hakemukset isännöi väritys ja omaisuus on esitetty sijaan yleinen "X"

- TAI -

"Välillinen" yhteydet matriisit

6. Svalitasekvenssi yhteys tyypit ja komponenttityypitoikealla ja vasemmalla puolella avautuvasta valikosta jos haluat nähdä "solujen matriisin josn epäsuora polku liitettyjen laitteidenolemassa alkaen Pystysuora/ "rivi"Komponentti matriisi Vaakasuora/ "sarake"Osa matriisin.

Huomautus

Mikä tahansa kelvollinen polku, joka sisältää elementtejä valittu polku valikossa wsairas näytetäänsuunnasta riippumatta taustalla olevien yhteyksien, kuitenkin, kun valitsemalla polku ensimmäinen ja viime elementtejä valittu on yhteystyypit. Lisäksi, tilata elementtejä, jotka on valittu näytetään numeerinen etuliiteneliön ("[]") kiinnikkeet ja tietylle voidaan sisällyttää mutliple kertaapolku (merkitty numeerinen etuliite). Peräkkäisen valinta komponenttityypit tai yhteystyypit tulkitaan 'TAI'polku ja hierarkia liitteenä komponentteja voidaan vaihtoehtoisesti sisällyttää tarkistamalla "Myös selata Liite vanhemmat / lapset"Valintaruutu. Kytkin Lähde ja Pesuallasosan valintoja nähdäksesi polut vastakkaiseen suuntaan.

7. Matriisi on asuttujapolku / kokoelma komponenttejasoluissa, jos on olemassa polku alkaen Pystysuora/ "rivi'komponentti matriisi Vaakasuora/ "sarake"Osa matriisin.

Huomautus

Suurissa matriisit vain enintään 100 riviä tai saraketta (myös romahti riviä / saraketta) näytetään kerrallaan mikä näkyy "R" ja "C" indikaattoreita vasemmassa yläkulmassa otsikkosoluun vastaavasti. Voit tarkastella rivejä käyttää vierityspalkkeja. Milloin tahansa voit kaksoisnapsauttaa Pystysuora/ "rivi' tai Horizontal / "sarake"Komponentti otsikot ja hypätävastaava komponentit Explorer-ikkunassa.Vanhemmat Pysty/ "rivi' ja Vaakasuora/ "sarake"Komponenttis myös mahdollisesti esitetty nimikkeeseen rivejä / sarakkeita harmaa otsikko otsikko. Kun romahti (yksittäisinä klikkaamalla otsikon solu) jos lapsia polut olemassa sitten 'X' mahdollisesti näytetään, jos kaikki lapset olivat kiinni tai "O" tulee mahdollisesti olla näkyvissä, jos vain osa lapsista oli polkuja. Epäsuora polku komponentit voivat olla värillinen mukaan omaisuuden arvo komponenttien napsauttamalla Asetukset "hammaspyörän yläreunassa oikeassa matriisin työkalupalkin ja valitsemalla Väriasetukset ... ja sitten Muokkaa-painiketta ja valitsemalla Colour mukaan Aikaleima tai Colour Kiinteistöpalveluiden vaihtoehto ja valitsemalla ominaisuus, Min ja Max arvoalueella ja värien kuitenkin vain Luettelo, Integer, Desimaali, Boolen tai Päivämäärä / aika tietotyyppi ominaisuudet väri. Kiinteistövälitys arvot epäsuora polku komponentit voivat olla näytetään napsauttamalla Asetukset "hammaspyörän yläreunassa oikeassa matriisin työkalupalkin ja valitsemalla Näytä Arvo Asetukset ... ja sitten Muokkaa-painiketta ja valitsemalla Näytä omaisuutta vaihtoehto ja valitsemalla omaisuutta.

Epäsuorat yhteydet matriisi, joka osoittaa sovelluksia, jotka toteuttavat tietyn palvelun mukaan laitos

Jotta suodattaaMatrix näkymä Abacus

1. Varmista, että sinulla on uusi Matrix näkymä avata.

2. Napsauta Suodatin akseleiden suppilo yläreunassa oikeassa matriisin työkalupalkin.

3. Lähteestä ja / tai Sink välilehtiä lisätä nimen, Kiinteistövälitys, kuvaus, hierarkia tai Standard suodattimia napsauttamalla Lisää-painiketta, valitsemalla Kiinteistövälitys tarvittaessa ja valitsemalla Kunnossa. Valitse haluamasi vaihtoehdot Avainsanat / kohteet paneeliin käytetään logiikkaa / syntaksin kuvatulla huomautus alla. Esikatselu paneeli päivittää automaattisesti näyttämään tulokset nykyinen sarja suodattimia.

Huomautus

Varten Aikaleima, Hierarkia Path, Nimi tai Kuvaussuodattimet tai Teksti, Integer, Desimaali, Boolen tai Treffiaikakiinteistö suodattimet sovitus suoritetaan ikään kuin "*" jokerimerkit sovelletaan automaattisesti ennen ja jälkeen mikä tahansa merkkijono arvot niin, että merkintä "kissa" (ilman lainausmerkkejä) kuuluisi riveihin "Bobkissa','kissanainen "tai" sokissaion 'jne. Useita / "tai" arvoja voidaan merkitä uusia ratoihin Ctrl + Enter. Varten Kokonaisluku ja Desimaali omaisuus suodattimia "ja" logiikka voidaan sisällyttää käyttäen "&"(Ilman lainausmerkkejä) ja suurempi kuin / pienempi kuin jne logiikka voidaan sisällyttää käyttäen"> =','>','<' ja '<="(Ilman lainausmerkkejä) esim. '> = 50000 & <90000 ". Ei-tyhjä arvo riviä voidaan sisällyttää syöttämällä "(Non-aihiot)"(Ilman lainausmerkkejä) ja Tyhjä arvostettu riviä voidaan sisällyttää syöttämällä"(Aihiot)"(Ilman lainausmerkkejä).Varten Standardit tai Lista omaisuus suodattimet "(Valitse kaikki)" valintaruutu mahdollistaa kaikki muut valintaruudut, itse asiassa mukaan lukien kaikki käytettävissä elementtejä. "(Non-aihiot)" valintaruutu sisältää ei-tyhjä omaisuutta arvostettu elementtejä. "(Aihiot)" valintaruutu sisältää tyhjiä omaisuutta arvostettu elementtejä. Ja poistamalla erityisiä arvostettu valintaruudut automaattisesti Poista valinnat "(Valitse kaikki)" ja "(Non-aihiot) -valintaruudut johdonmukaisuuden. Ja lopuksi, kaikki suodattimet ovat oletuksena kirjainkoko niin "kissa" (ilman lainausmerkkejä) sisältäisi elementtejä "kissa", "Kissa" tai "CAT" jne kirjainkoko matching, kirjoita "(Asia)"(Ilman lainausmerkkejä) ennen merkkijonon esim. "(Asia) Cat" (ilman lainausmerkkejä) sisältyvät vain elementtejä "Kissa" niihin.

Asuttamaan käyttäen Matrix näkymä Abacus

Huomautus

Voit vain lisätä / poistaa yhteydet, joissa yhden yhteyden tyyppi on käytetty Path kuvatulla tavalla.

1. Jotta Lisää yhteysvalitun tyypin välillä Pystysuora/ "rivi"Komponentti ja Vaakasuora/ "sarake"Komponentti matriisi, jossa" X "ei vielä ole(Tai esitetty kiinteistön arvo - katso huomautus yllä)Kaksoisnapsauta solua. "X" tulisi näkyä (Tai kiinteistön arvo - katso huomautus yllä) ja yhteys luodaan ylimmällä tasolla yhteyksien kokoelma valitun arkkitehtuurin.

Huomautus

Yhteyden nimi on yhteystyyppi nimi kohti yhteys-asetus matriisin ja jos omaisuuden arvo on esitetty sijasta "X" oletusarvo kiinteistön näkyy.

2. Jotta muokata esitetty kiinteistön arvovälisestä yhteydestä a Pystysuora/ "rivi"Komponentti ja Vaakasuora/ "sarake"Komponentti matriisinKaksoisnapsauta solua, tai napsauta hiiren kakkospainikkeella solua ja valitse Muokkaa arvoa ..., ja muokkaa arvoa Muuta arvoa -valintaikkunan.

3. Jotta poista yhteysvalitun tyypin välillä Pystysuora/ "rivi"Komponentti ja Vaakasuora/ "sarake"Komponentti matriisi, jossa" X "on jo olemassa(Tai esitetty kiinteistön arvo - katso huomautus yllä), oikea-Napsauta soluaja valitsemalla Katkaise. X pitäisi kadota ja yhteys poistetaan hanke.

Pelastaa / Tallenna nimellä aMatrix näkymä

Huomautus

Vaikka kaikki Arkkitehti käyttäjät voivat luoda matriisit pelastaa heidät ja / tai niiden asetuksia käyttäjän lisenssi tarvitsee Designer lisäosa ominaisuus. Tämä on "suojella" asetukset nykyisten Matriisit jotka voidaan jakaa useille käyttäjille. Kuitenkin arkkitehti käyttää ilman Designer lisäosa voi silti valita "Tallenna nimellä" kaikki uudet asetukset uuteen Matrix. Ja tietysti kaikki käyttäjän lisenssit voi valita "hävittämään" muutoksia olemassa olevaan Matrix. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset Suunnittelija lisäosa valmiudet.Ja muistakaa, tämä on vain asetukset Matrix, kaikki muutokset tietoihin tehdyt Matrix ovat välittömästi levitetään arkistoon riippumatta.

1. Varmista, että sinulla on uusi Matrix näkymä avataja olet tehnyt tarvittavat muutokset.

2. Vuonna Matrix näkymätyökalurivi klikkaa vasemmanpuoleisin Tallentaa Matriisipainiketta tallentaaksesi Matrix näkymä ja kaikki muotoilumuutokset.

Huomautus

Jos sinulla ei ole Tallenna-painiketta Matrix näkymä työkalupalkin niin sinulla ei ole Designer lisäosan ja olet vain voi Tallenna nimelläasetuksia muuttuu uuden matriisin kun menet sulkea olemassa olevan matriisin.

3. Jos Matriisi Nimiavautuvassa (Koska on uusi matriisi) anna nimi matriisija paina Kunnossa.

Jotta vienti MS Excel matriisiin

1. Varmista, että sinulla on Matrix näkymä avata.

2. Napsauta Vie Exceliintyökalurivin painiketta.

3. Valitse tiedostonimi pelastaa MS Excel matriisi. Klikkaa Tallentaa.

Huomautus

Oletuksena viedä MS Excel matriisi tiedostonimi on Matrix nimi loppuliitteenä Architecture nimi suluissa, esim "Sovellukset isännöi Palvelimet (2014 Todellinen) Xlsx". Voit muuttaa tämän, myös se, onko tiedostomuoto on olla Xlsx tai .xls.

Matrix muotoiluviedään oletuksena kuitenkin suuria matriiseja tämä voi johtaa vienti on melko hidasta. Näin ollen Työkalut | Asetukset ...sitten Matriisivälilehti,voit vähentää muotoilut viedään osoittamalla Matrix-välilehden alla, mikä nopeuttaa vienti.

Matrix vienti vaihtoehdot

4. Vie Valmiit valintaikkuna. Klikkaa Kunnossa.

Viedään MS Excel matriisiin

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Asuttavat arkkitehtuurista Visio | Asuttavat arkkitehtuurista Excel


Asuttavat arkkitehtuurista Microsoft Access

Navigation: Asuttavat laitealustan> Asuttavat Microsoftilta tuotteet>

Asuttavat arkkitehtuurista Microsoft Access

Lähetä kommentit tästä aiheesta.

Voit viedä arkkitehtuuri Microsoft Access suorittaa yleiskäyttöön laskelmia, manipulointia tai raportteja arkkitehtuuri. Voit sitten tuoda arkkitehtuuri takaisin ABACUS.

Huomautus

Open Access / Vie tietokanta ominaisuus edellyttää, että Microsoft Access 2000tai uudempi on asennettu tietokoneeseen.

Viedä arkkitehtuuri Microsoft Access

1. Varmista, että käytössä ABACUS tiedostoauki, Tutkimusmatkailijanäyttöön, ja arkkitehtuurilisättiin.

2. Valitse File | Viedä | Database.

3. Huomioi varoitus dialogi edellä kuvatulla tavalla ja valitse Kyllä jatkaaksesi.

4. Valitse sijainti ja tiedostonimi tietokantatiedosto.

Voit tuoda manipuloitu arkkitehtuuria ABACUS

1. Jotta sinulla on ABACUS auki.

2. Valitse File | Uudet ja valitse Accessalkaen avautuvassa ja valitse OK.

3. Selaa tietokanta tiedosto, jonka haluat tuoda.

ABACUS "MS Access-tietokanta Schema

ABACUS on sen sydänn ontologia / meta-meta-malli koostuu komponentit, yhteydet ja rajoitteet. Tämä "CCC" lähestymistapa oli peräisin eri standardi lähestymistapoja kehitetty 1960-luvulta lähtien huipentui kansainvälisen standardin IEEE 1471, joka Avolution perustajat osaltaan. Seuraavat primitives sovelletaan;

1. ABACUS sisältää Kirjastotof Standardit(Tai Standards), Komponentti ja Liitäntä tyypit, Rajoitteet, Näkökulmia, Mallit (tai Kuviot) ja monet Arkkitehtuurit.

2. Standardit, Tyypit ja Näkökulmia Toukokuuolla loogisesti Ryhmiteltymukavuussyistä.

3. Arkkitehtuurit voivat sisältäämonet jälkeläinen Arkkitehtuurit(Tai Evolutions).

4. Kukin Arkkitehtuuri sisältäämonet Komponentit ja LiitännätTiettyjen Tyypitja eri Näkymät.

5. Komponentit ja Liitännät voi olla hajoaaosaksi Sub-Components ja Sub-yhteydet.

6. Kukin Komponenttion liitteenärajoittamattoman määrän Liitännätmutta jokainen Yhteysvoi olla vain liitteenäenintään kaksi Komponentit.

7. Komponentit ja Liitännätvoida olla Standardit kanssa Ominaisuudetkuten tieto-, suorituskyky, luotettavuus, kustannukset jne.

8. Arkkitehtuurit, Komponentit ja Liitännätvoida ollaerityinen Ominaisuudetkuten tieto-, suorituskyky, luotettavuus, kustannukset jne.

9. Rajoitteetvoida välillä Komponentit tai Liitännät tai vastaan Ominaisuudet.

10. Mallitovat vakiona koostumuksia Komponentti ja Liitäntä tyypit.

11. Näkökulmiaovat vakiona yhdistykset Komponentti ja Liitäntä tyypitja muistiinpanoja.

12. Näkymätovat visuaalisia esityksiä Komponentit ja Liitännät.

Seuraavat MS Access Entity suhdekaavio (ERD) Asiakirjat ydinArkkitehtuurit, Evolutions, Komponentti / Yhteystyypit (ja ryhmille), Komponentit / Connections ja Sub Komponentti / yhteydenotto käsitteitä.

Core tietokantakaavaa

Huomautus

Viite-eheyden ei ole täytäntöön suhdetta Komponentit pöytä ja liitännät taulukossa (varten "kiinnitys" välillä lähteisiin tai Sink Komponentti ja Connection). Tämä johtuu siitä, että yhteys voi olla olemassa ilman komponentti liitteitä. Voisimme lisänneet "liite" taulusta yksinkertaisuuden hylännyt että. Tietenkin tämä tarkoittaa, että muokkaus Component tunnukset tai poistamisen Component rivien kaikki yhdessä johtaa virheellisiä tietoja. ABACUS hoitaa kaikki virheellisyys tuonnin sivuuttamalla virheelliset tiedot.

Seuraavat MS Access ERD dokumentoi Ominaisuudetkonsepteja arkkitehtuurit, Komponentti / Yhteystyypit ja komponentit / Liitännät.

Ominaisuudet tietokantakaavaa

Seuraavat MS Access ERD dokumentoi Standarditkäsite arkkitehtuurit, Komponentti / Yhteystyypit ja komponentit / Liitännät.Huomautus: taulukot silti käyttää termiä "täytäntöönpano" kohti aiemmat versiot Abacus.

Standardit tietokantakaavaa

Seuraavat MS Access ERD dokumentoi Rajoitteetkäsite Komponentti / Yhteystyypit.

Rajoitteettietokantakaavaa

Seuraavat MS Access ERD dokumentoi Näkökulmia käsite Arkkitehtuurit.Huomautus: taulukot silti käyttää termiä "TwoDTempl" kohti aiemmat versiot Abacus.

Näkökulmiatietokantakaavaa

Seuraavat MS Access ERD dokumentoi Luettelotkäsite Arkkitehtuurit.

Luettelottietokantakaavaa

Seuraavat MS Access ERD dokumentoi Matriisitkäsite Arkkitehtuurit.

Matriisittietokantakaavaa

Seuraavat MS Access ERD dokumentoi Kaaviotkäsite Arkkitehtuurit.Huomautus: taulukot silti käyttää termiä "TwoD" kohti aiemmat versiot Abacus.

Huomautus

Komponentti / Yhteyden tyyppi kaavaimen muoto kartoitus ja vapaamuotoinen muoto osia MS Access ERD on jätetty pois selvyyden vuoksi.

Kaaviottietokantakaavaa

Seuraavat MS Access ERD dokumentoi 3D-näkymätkäsite Arkkitehtuurit.

3D-näkymättietokantakaavaa

Seuraavat MS Access ERD dokumentoi Kaavioitakäsite Arkkitehtuurit.

Kaavioitatietokantakaavaa

Seuraavat MS Access ERD dokumentoi Kojelauta käsite.

Kojelautatietokantakaavaa

ABACUS "MS AccessKyselyt

Mukana MS Access-tietokanta on useita hyödyllisiä kyselyitä seuraavasti;

· Comps mukaan Rekvisiitta- Tämä kysely listaa kaikki komponentit hankkeen (jonka arkkitehtuuri ja tyyppi) ja sisältää kaikki ominaisuudet sarakkeita. Käytä tätä kysely suodattimet / kriteerit sen osan ja / tai arkkitehtuuri tuottaa "tyypillinen" pöydät kunkin osan niiden ominaisuuksia.

· Sukupuolitaudit mukaan Rekvisiitta- Tämä kysely listaa kaikki standardit, jotka ovat käytössä, tapahtumien määrä standardin ja sisältää kaikki ominaisuudet sarakkeita. Käytä tätä kysely standardien luettelo.

· Rekvisiitta Tyypit- Tämä kysely listaa kaikki osa kiinteistöistä ja niiden% täydellinen kunkin tyyppihyväksynnän sarakkeina. Tämän kyselyn onko erityisiä ominaisuuksia pidetään kunnossa.

· Tyypit by Rekvisiitta- Tämä kysely listaa kaikki komponenttityypit ja sisältää% valmis kaikista kiinteistöistä sarakkeita. Tämän kyselyn onko erityisiä ominaisuuksia pidetään kunnossa.

· Tyyppi Kreivi- Tämä kysely listaa kaikki komponenttityypit ja sisältää esiintymien lkm kunkin laskevassa järjestyksessä. Tämän kyselyn määrittää suosio kunkin hankkeeseen.

Huomautus työskentelee Memo kentät MS Access

Komponentit, liitännät ja standardit Nimi kentät taulukoissa määritellään muistio kentät mahdollistaa rajoittamattoman määrän merkkejä, kohti ABACUS. Komponenttien ja kytkennät tämä aiheuttaa muutamia asioita, koska niillä on myös yksilöllinen tunnus kenttä viitataan, mutta standardien tämä aiheuttaa joitakin ongelmia, kun yrittää liittyä taulukoita, koska et voi liittyä muistio kentät MS Access. Vaihtoehtoisesti voit asettaa Mistä lauseke kriteerit saavuttaa sama vaikutus kuin esitetty Visual Kyselyn muodostin ja vastaavat SQL katkelmia alle lista kaikki perinyt Standardit ominaisuudet kaikki osat viedyssä ABACUS hanke.

Memo "liittyy" Visual Kyselyn muodostin

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Komponenteista sisäliitos ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) JA (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), toteutukset sisäliitos ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

MISSÄ (((ComponentImplementationLinks.Name) = [toteutukset]. [Nimi]));

Memo "liittyy" SQL

Muistio automaattisesti tuottavan ABACUS tunnuksia MS Access

Eri ABACUS MS Access taulukoita vaativat ainutlaatuisen pitkä kokonaisluku tunnus niin yksinkertainen VB menetelmä annetaan tukea sukupolven näiden. Kaksi menetelmää ResetCounter () ja GetNextCounter () ovat sisällä ABACUS "MS Access DB ja niiden käyttö on seuraava; ResetCounter () asettaa laskurin takaisin 0 GetNextCounter () palaa ensi laskuri järjestyksessä.

Menetelmiä hyödyntää MS Access "oikku" että vaikka soitat ResetCounter () menetelmä jokaista rivi Lisää (eli kun olet myös suorittaa GetNextCounter () funktio), koska ResetCounter () toiminto ei ole parametreja se vain toimii se kerran ja siksi ei nollaa laskurin rivi Lisää. Ja myös siksi, että sama "omituisuus" sinun on läpäistävä kaikki vanhat sarakkeen muuttuja GetNextCounter () funktio huijata sen käynnissä joka kerta.

Myös temppu mahdollisuutta toimittaa ResetCounter () toimintoa insertin SQL koska et voi vain on se istuu siellä sarakkeen omasta, kuin jos se oli hakukysely. On suositeltavaa tehdä ResetCounter () kutsu osa yksi muilla aloilla, ketjuttamalla sen loppuun, koska se aina palauttaa null muutenkin.

Alla on tyypillinen SQL käytön menetelmiä lisätä luetteloon komponenttityypit taulukosta / kysely kutsutun osan tyyppi List ".

INSERT INTOComponentTypes (tunnus, nimi, kuvaus)

VALINTA GetNextCounter ([Component Type List] .name)AS Id, [Component Type List] .name AS nimi, [Component Type List] .description & ResetCounter ()AS Kuvaus

FROM[Component Type List];

ABACUS ID / laskuri sukupolven SQL

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Asuttavat arkkitehtuurista Visio | Asuttavat arkkitehtuurista Excel


Asuttavat arkkitehtuurista Microsoft Visio

Navigation: Asuttavat laitealustan> Asuttavat Microsoftilta tuotteet>

Asuttavat arkkitehtuurista Microsoft Visio

Lähetä kommentit tästä aiheesta.

Voit tuoda arkkitehtuurin Microsoft Visio. Muotoja Visio piirustus tuodaan osina osaksi ABACUS. Yhteydet Visio piirustus tuodaan kuten yhteyksiä ja piirustus itse tuodaan ABACUS kuin kaavio. Lisäksi mukautettuja Kiinteistöjä Visio piirustus tuodaan koska ominaisuuksia lajitteluavaimena kartoitettu Kiinteistön tyyppi, Label Kohteen nimi ja Arvo omaisuuden arvo.

Huomautus

Tuo Visio ominaisuus edellyttää, että Microsoft Visio 2003tai uudempi on asennettu tietokoneeseen.

Tuoda Visio piirustukset ABACUS

1. Jotta sinulla on ABACUS auki.

2. Valitse File | Uudet ja valitse Visioalkaen avautuvassa ja valitse OK.

Huomautus

Jos haluat tuoda olemassa olevan ABACUS hanke sitten joko hiiren kakkospainikkeella Components solmu arkkitehtuuri, tai napsauta hiiren kakkospainikkeella yksittäisen komponentin sisällä Arkkitehtuuri ja valitse Tuo | Visio.

3. Selaa Visio-tiedoston haluat tuoda.

Huomautus

Alla on muutamia yksinkertaisia ​​sääntöjä tai suositellut käytännöt rakennettaessa (tai muuttamalla) MS Visio piirustus tuotavaksi ABACUS.

1. Linjat tai yhteydet on oltava todellinen liittimiä, EI muotoja.

· Muuten ABACUS vain tuoda ne komponentit ja näin ne eivät "kiinnitetty" mitään.

· Jos haluat tehdä joitakin "älykkäitä" reititys (eli muiden kuin suora viiva) ja käytä sitten Dynamic liittimeen Perusmuodot sapluuna, Abacus tuoda reititys / tukipisteitä hieno.

· Pyrkikää välttämään "Ring verkko" ja "ethernet" muotoja verkko- ja oheislaitteet sapluuna, jonka avulla paljon komponenttien "liittää" siihen. Kun tuomme liitteitä sakon yhteyksiä alkuperäinen muoto on edelleen "laajennettu" vastaamaan liitteitä. Käytä erillinen erillinen "hub / bussi" muoto (ilman liitintä "jalat") ja sitten nimenomaisesti liittää jokaisen komponentin napa / bussi erillinen liittimet.

· Jos linja tai yhteys käyttäytyy kuten muoto, oikealla klikkaa sitä ja mennä "Format | Käyttäytyminen ... "ja varmista, että vuorovaikutus tyyli on asetettu Line (1-ulotteinen).

2. Komponentit oltava muotoja EI liittimiä.

· Muuten ABACUS vain tuoda ne yhteydet ja vastaavasti kaikki muoto tiedot häviävät.

· Jos komponentti käyttäytyy kuten liitin, oikealla klikkaa sitä ja mennä "Format | Käyttäytyminen ... "ja varmista, että vuorovaikutus tyyli on asetettu Box (2-ulotteinen).

3. Liittimet on kiinnitetty muotoja, EI kelluva ympäri taustan muoto.

· Jos et liitä liittimet muotoja sitten ABACUS ei voi mitenkään tietää, että olet tarkoitus liittää annettu liitin muoto / komponentti ja vastaavasti se jättää että pää yhteyden YK-liitteenä.

4. Etiketit muodot olisi (jos mahdollista) sisäänrakennettu teksti etiketti muoto, ei ole erillinen tekstikenttään piirustus.

· Erillinen tekstiruutuja saa maahantuomien ABACUS komponentteina itsenäisesti ja vaikka voit yhdistää "label" komponentti todellinen komponentti ABACUS, tai vain muuntaa "label" komponentin vapaamuotoinen muoto (eli ei itse komponentista) se on parasta välttää näitä ohjeita.

5. Käytä samaa pohjan muoto kussakin tapauksessa samantyyppisiä, älä laiska ja käyttää suorakulmio joskus ja laatikko muut eri muoto stensiilit.

· ABACUS käyttää pohja muoto ja sen pohjaväri yksilöimään komponentti ja yhteystyypit piirustuksessa niin "punainen suorakulmio" ja "punainen laatikko" saavat tuodaan kahtena erillisenä komponentti tyyppiä. Nämä komponentti tyyppejä voidaan yhdistää Abacus mutta se on parasta välttää näitä ohjeita.

6. Kokonaan kiteyttää "lapset" muodot niiden "vanhemmat", älä jätä niitä reunan yli.

· ABACUS havaitsee tahansa muotoon, joka on kokonaan kapseloitu toinen muoto kuin lapsi vanhemman joten varmista koko muoto, mukaan lukien etiketti osa, on suljettu.

7. Älä sijoita muoto päällekkäisiä kaksi muita muotoja.

· Jos muoto ulottumaan kahden muita muotoja, olla se "ryhmittymä" / tausta suorakulmion tai muuten, se voidaan tuoda ABACUS komponenttina, joka on lapsi ole päällekkäisen muotoja mutta heti kun valitset komponentin Abacus "piirtotyökalu , koska vasemmassa yläkulmassa on komponenttien viite piste, siitä tulee lapselle vasemman päällekkäin muoto / komponentti.

8. Yritä minimoida muistiinpanoja piirustus koska nämä saavat tuodaan osina itsenäisesti ja täytyy muuntaa vapaamuotoinen muotoja ABACUS. Mieti, ovatko ne todella nimi tietyn komponentin tai yhteys.

9. Vaikka ABACUS tukee rikas / värilliset / vektori-pohjainen muotoja, yrittää minimoida käytön bittikarttoja, ulkomaisten muodot ja Enhanced Metafile varten muotoja ABACUS hetkellä eieitukevat näitä tyyppejä. Ne tuodaan niin yksinkertaista valkoista nelikulmiota.

10. Yritä välttää rivinvaihtoja (shift-paluu) etiketeissä niiden tuonnista ja esitetään erityinen luonne "[]" Abacus komponentin nimi.

11. Yrittää minimoida eri värejä, joita käytetään muotojen samaa tyyppiä. Kuten edellä mainittiin, pohjaväri ja pohja muoto yksilöi komponentti ja liitäntä tyypit niin enemmän vaihtelua on enemmän yhdistäminen ja konsolidointi, jotka on tehtävä tuonnin jälkeisiä Abacus.

12. Varo täytetty muotoja sillä jos muoto on täynnä aina kulmat sitten väritys se myöhemmin Abacus ei ole vaikutusta.

13. Monimutkaisten linja-pohjainen muotoja on käytettävä monikulmio joka on luotu ottaa linjat alkavat jossa edellinen päättyy ja sitten lopulta menee takaisin lähtöpisteessä. Jos haluat, voit käyttää täyttö- ja viivan leveys tehdä monikulmio näyttää "nuoli" tai mitä muoto haluat.

14. Varmista muodot ID MS Visio on mielekästä ole vain Shape.xx. Tämä on muokattavissa käyttäen hiiren kakkospainikkeella "Näytä muotolomake", joka on saatavilla MS Visio kehittäjätilassa (käytössä kautta Tools | Options MS Visio).

15. Ellipses ja kaaretsisällä muodottuetaan Abacus mutta NURBS ja urat ei tueta tällä hetkellä.

16. Varmista koko muoto on ryhmitelty MS Visio tai se saa tuotu useita komponentteja / tyyppejä.

17. Yritä minimoida Käännetyn muotoja sisällä subshapes koska ne joskus ei tuoda oikein.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Asuttavat arkkitehtuurista Access | Asuttavat arkkitehtuurista Excel


Asuttavat arkkitehtuurista Microsoft Excel

Navigation: Asuttavat laitealustan> Asuttavat Microsoftilta tuotteet>

Asuttavat arkkitehtuurista Microsoft Excel

Lähetä kommentit tästä aiheesta.

Voit tuoda arkkitehtuurin Excel (.xls tai Xlsx tiedosto). Excel maahantuoja voit kartta luettelot komponentin ja yhteyksiä tyyppejä, standardit, ominaisuudet ja standardi ominaisuuksia valitsemalla sarakkeita laskentataulukon, jotka sisältävät tarvittavat tiedot.Se on kuitenkin enemmän kehittynyt tekniikka kuin suositeltava lähestymistapatuontia MS Excel, joka on kautta luettelot kuten kuvattu tässä .

Huomautus

Tuo / Vie Exceliin ominaisuus edellyttää, että Microsoft Excel 2003tai uudempi on asennettu tietokoneeseen.

Päätehtävä Excel maahantuoja avulla voit määrittää konfiguraatiotiedosto (eli hierarkkinen rakenne teidän arkkitehtuurin malli). Asetustiedosto tallentaa aiemmin tallennetun kartoitus Excel-tiedoston ABACUS tiedostoon. Kun määritellään, tallennettu asetustiedosto käytetään myöhemmin edelleen tuontia ja vientiä .xls.

Huomautus

Vaiheet esitetään jäljempänä olevissa kohdissa ovat erityisesti käyttäjille, jotka eivät ole vielä määrittää ja tallentaa konfigurointitiedoston ja tuotavan excel ensimmäistä kertaa. Sinun täytyy luoda ja tallentaa konfigurointitiedoston käyttää Vie Exceliin toiminto.

Voit tuoda Excel osaksi ABACUS

1. Jotta sinulla on ABACUS auki.

2. Valitse File | Uusi ja valitse Kunnostautuaalkaen avautuvassa ja valitse OK.

Huomautus

Jos haluat tuoda olemassa olevan ABACUS hanke sitten joko hiiren kakkospainikkeella Components solmu arkkitehtuuri, tai napsauta hiiren kakkospainikkeella yksittäisen komponentin sisällä Arkkitehtuuri ja valitse Tuo | Excelistä.

3. Tuo Excel-taulukonNäyttöön tulee

Tuo Excel-taulukon -ikkuna

4. Napsauta Avaa Excel-tiedostokuvake ja selaa Excel-tiedoston haluat tuoda.

5. Valitse Työlistahaluat tuoda pudotusvalikosta.

Huomautus

Avaamisen jälkeen Excel-tiedoston, voit käyttää Tiedot esikatseluvälilehti tarkastella sarakkeita ja ensimmäiset 25 riviä laskentataulukon. Täältä voit saada sarakkeen numerot, joita tarvitaan täyttämään Komponentit ja Liitännätvälilehti.

Voit myös valita, haluatko osia Excel-taulukon tuoda kanssa kirjainerottelutiedon. Yksinkertaisesti rasti Tuo kanssa kirjainerottelutiedonvaihtoehto (oletuksena tämä on aina valittuna) ja taulukkolaskenta tuodaan vastaavasti.

Näyte Excel-tiedosto

Huomautus

Tässä esimerkissä aiomme tuoda yksinkertainen perusrakenteet Ihmiset Arkkitehtuuri päässä ExCeL esitetyistä tiedoista edellä kuvakaappaus. Liitännät tehdään välillä "Ihmiset Vastuullinen" ja "palvelimet", että ne ihmiset hallinnoida.

Asuttamaan Komponentit-välilehti

Tämä osio on määriteltäessä komponenttityypit ja hierarkkisen asetustiedostoa.

1. Valitse Komponentitvälilehti. Nimeä Set IDpakottavilla (tyhjä) arvo

Huomautus

Tämän ominaisuuden avulla voit määrittää täysin eri SarjatToiminnallisesti erillisiä komponentteja. Kuten on esitetty kuvakaappaus alla, voit erottaa oman Infrastruktuurin osat irti People komponenteista. Jos on suhteet (yhteydet) näiden erillistä komponenttien, ne voidaan määritellä alla Liitännätvälilehti. Myöhemmin tässä esimerkissä me määrittää yhteyksiä tyyppiä "Järjestelmänvalvojat" välillä Infrastructure ja Ihmiset Sarjat.

Voit myös valita, haluatko lisätä huipputason Ryhmittymäkomponentti kaikki elementit asetettu. Yksinkertaisesti rasti Ryhmässä Set IDvaihtoehto (oletuksena tämä merkintä poistetaan) ja taulukkolaskenta tuodaan vastaavasti.

Määrittäminen Set ID

2. Kun Sarjaton määritelty valitse Sarjahaluat asuttaa ja laajentaa klikkaamalla [+] merkki.

3. Valita Tasot Components tässä Setalkaen laajennetun luettelon.

4. Komponentti Hierarkia: Aseta tunnusikkuna ilmestyy kyseisen Sarja.

Komponentti Hierarkia ja Arvojen (Set ID: Infrastructure)

5. Nimeä Taso Numerosarake pakottavilla (tyhjä) arvo.

Huomautus

Taso Numerosarake voit määrittää hierarkian laitteiden. Jokainen taso vastaa kerros omassa arkkitehtuuri jolloin ensimmäinen taso on alkuun kaikkein vanhempi taso. Esimerkiksi, Taso määrä "1" vastaa ylimmän hierarkiakerroksen, Taso määrä "2" on lapsi tason määrä "1" ja niin edelleen.

6. Valitse ja antaa asiaa sarakkeen Excel kuhunkin Taso Numerokirjoittamalla sen alla Komponentti sarakesarake.

Huomautus

Voit valita jättää tietyt rivit, et halua olla edustettuina arkkitehtuurista. Nämä voivat olla sarakeotsikoita, tyhjiä rivejä jne haluat jättää rivit käyttää Rivien Exclude:tekstikenttään yläreunassa oikeassa yläkulmassa ikkunan. Tässä esimerkissä olemme ulkopuolelle rivi 1, koska se sisältää meidän sarakeotsikot.

7. Voit halutessasi lisätä kuvauksia laitteeseen ja korvaamalla (tyhjä)arvo Kuvaus sarake.

Huomautus

Tämä kuvaus on mitä näkyy ABACUS alle Yleiset ominaisuudetjakso | Kuvaus ala.

8. Jos tietyn taulukon sarakkeen on useampi kuin yksi komponentti solua kohti (syöttää käyttämällä Alt-Enter tai CHAR (10) komento) rasti valintaruutu alla Kohtele New Lines erillisinä komponentteina. Jokainen rivi tuodaan erillisinä komponentteina.

Kärki

Voit tuoda "matriisi" kokoelmasta sarakkeita, jossa "X" tietyllä "matriisi" cell (solut B2: D2 sanoa) tarkoittaa, että komponentti määritelty rivin (soluun A2 sanoa) on liitetty komponentti määritelty sarakkeessa "otsikon" (rivillä 1 vaikkapa), yksinkertaista kaavaa voidaan käyttää. Kirjoita seuraava kaava kunkin rivin sarakkeen jälkeen matriisin solut (sarake F sanoa); = JOS (B2 = "", "", B $ 1 & CHAR (10)) ja IF (C2 = "", "", C $ 1 & CHAR (10)) ja IF (D2 = "", "", D $ 1 & CHAR (10)). Sitten perustaa yhteyden asetettu alla kuvatulla komponenttien välillä määritelty rivin (sarakkeen sanoa) ja ne kuvataan tässä kaavan (sarakkeessa F sanoa). Muista tarkistaa Kohtele New Lines erillisinä komponentteinavaihtoehto, kun komponentteja kaava tuodaan. Kokeneemmille matriisi tuonti, budjettinimikkeet useita kerroksia hierarkian tai solujen eri arvoja kuin vain tavallinen "X", ota yhteyttä Avolution tuki .

9. Täytä loput sarakkeita tarpeen mukaan.

Huomautus

Voit saada tyyppi sarakkeesta rivit rastittamalla valintaruutu alla Get tyyppi sarakkeestasarake ja tulla merkityksellisille sarakkeen Excel alla Komponentti Tyyppi Arvo tai sarakesarake. Tämä tuo kaikki komponentit, jotka pylvääseen ja asettaa ne määriteltyä tyyppiä sarakkeessa. Vaihtoehtoisesti, ja kuten kuvakaappaus yllä ja alla, voit käyttää kiinteää / ennalta määritellyn tyypin nimi kirjoittamalla tyypin nimi, Komponentti Tyyppi Arvo tai sarakesarake ja varmista valintaruutu on YK-tarkastettu.

Komponentti Hierarkia ja Arvojen (Set ID: People)

Huomautus

Tässä esimerkissä haluamme on meidän verkkoihin ja ihmiset ryhmien tasolla 1 arkkitehtuurin. Tasolla 2 haluamme olla meidän palvelimille ja ihmiset hallinnoinnista vastaava kyseisille palvelimille. Komponentitvälilehti on täytetty vastaavasti, kuten on esitetty kahdessa kuvakaappauksia edellä. Ensimmäisessä kuvakaappaus edellä olemme määritelleet taso 1 (verkko ryhmittely) ja tason 2 (palvelin) komponentit Infrastruktuuri Sarja. Ja kuvakaappaus välittömästi edellä olemme määritelleet taso 1 (ihmiset ryhmittely) ja tason 2 (vastaavien henkilöiden) komponentit Ihmiset Sarja.

Vaihtoehtoisesti IhmisetSet, sen sijaan että käyttäisivät sarake C Ihmiset ryhmittymä, olisimme voineet käyttää Ryhmässä Set IDvaihtoehto huipputason komponentit välilehti ja sitten vain tullut yksi Ihmiset alatason päässä sarakkeessa D. Tämä on esitetty kuva alla.

Komponentti Hierarkia ja Arvojen käyttäen ryhmässä Set ID vaihtoehto (Set ID: People)

10. Kun komponentit on tunnistettu, valitse komponentti taso haluat kansoittavat ominaisuuksia ja / tai standardien ja laajentaa klikkaamalla [+] merkki.

11. Valita Ominaisuudet Komponentit tällä tasolla tai Komponentti Standardit tällä tasollaalkaen laajennetun luettelon ja kansoittavat asiaa sarakkeita tarpeen mukaan.

Populating Komponentit

Huomautus

Ominaisuudet Komponentit tällä tasollavoit määritellä ominaisuudet komponenttien haluttu taso. Komponentti Standardit tällä tasollavoit määritellä standardit ja niiden standardi ominaisuuksia komponenttien haluttu taso.

12. Toista vaiheet 2-11kunnes kaikki komponentti tasot on asuttu Kaikkien määritettyjen Sarjat. Käytä taakse-nuolta lähellä sivun oikeassa yläkulmassa ikkunan siirtyä takaisin Sarjatjoka olet määritellyt aiemmin.

Asuttamaan Yhteydet-välilehti

Tämä osio on määriteltäessä liitäntätyypit ja hierarkkisen asetustiedostoa.

1. Valitse Liitännätvälilehti. Kunkin sarjan yhteyksiä on tunnistettava komponentti Sarjaettä haluat olla lähdekomponenttien ja komponentti Sarjahaluat olla määränpäähän komponentteja.

2. Alla Lähdelaite Set ID syötä Sarjanimen, joka vastaa Sarjamääritellään aiemmin Komponentitvälilehti. Alla Lähde komponenttitasolla lukumääräSyötä numero, joka vastaa komponenttitasolla haluat yhdistää lähde lopussa yhteyden.

3. Nyt valita mikä komponentti ryhmä oltava perillä lopussa yhteyden. Alla Kohde Osan Set ID syötä Sarjanimen, joka vastaa Sarjamääritelty Komponentitvälilehti. Alla Kohde Komponentti Taso lukumääräSyötä numero, joka vastaa komponenttitasolla haluat yhdistää määränpäässä lopussa yhteyden.

Huomautus

Tässä esimerkissä haluamme yhdistää ihmiset hallinnoinnista vastaava palvelimia palvelimia että se hallinnoi. Ihmiset vastaavat määriteltiin Ihmiset Sarjatason 2 osien kun palvelimet infrastruktuurirekisterissä Sarjatason 2 komponentteja. Liitännätvälilehti on täytetty vastaavasti, kuten on esitetty kuva alla.

Yhteydet-välilehti Osa 1 2

4. Jos vierität oikealle, löydät ylimääräistä vaihtoehtoja tuomalla yhteyksiä. Get tyyppi sarakkeesta ja Yhteyden tyyppi Arvo tai saraketoimivat samalla tavalla kuin Komponentitvälilehti.

5. Jos Lähdelaite Set ID ja Lähde komponenttitasolla lukumääräovat samat kuin Kohde Osan Set ID ja Kohde Komponentti Taso lukumäärä(Esimerkiksi jos liität samaa komponenttia tyyppejä, kuten siihen liittämistä palvelimista muihin palvelimiin) sitten sinun täytyy olla toinen sarakkeeseen laskentataulukon, joka sisältää nimet palvelimia toistetaan. Tässä tilanteessa voit laittaa että taulukkolaskentaohjelma sarake Kohde toisteta sarakkeessasarake. Jos että taulukon sarakkeen olet antanut enemmän kuin yksi kytketyn laitteen solua kohti rasti valintaruutu alla Kohtele New Lines erillisinä komponentteina.

Yhteydet-välilehti Osa 2 2

6. Kun liitännät on tunnistettu valita yhteyden haluat kansoittavat ominaisuuksia ja / tai standardien ja laajentaa klikkaamalla [+] merkki.

7. Valita Ominaisuudet Nämä yhteydet tai Standardeja näille Liitännätalkaen laajennetun luettelon ja kansoittavat asiaa sarakkeita tarpeen mukaan.

Huomautus

Ominaisuudet Nämä yhteydetvoit määritellä ominaisuuksia valitun täntäryhmä. Standardit Nämä yhteydetvoit määritellä standardit ja niiden standardi ominaisuuksia valitun täntäryhmä.

8. Toista vaiheet 2-7kunnes kaikki yhteyden ryhmät on määritelty.

9. Kun olet lopettanut määritellään kytkentäryhmiä, klikkaa Saada valmiiksinappia ja arkkitehtuuri luodaan tuodusta Excel-tiedoston. Esimerkissä johtaa arkkitehtuurin esitetty kuva alla.

Näyte Arkkitehtuuri Tuotu Excel

10. Nyt tallentaa kartoitettu asetukset tiedostoon napsauttamalla Tallenna kokoonpanonkuvaketta. Tallennetut asetukset voidaan hakea myöhemmin napsauttamalla Avaa Configurationkuvaketta yläreunassa vasemmassa alakulmassa ikkunan.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Asuttavat arkkitehtuurista Access | Asuttavat arkkitehtuurista Visio


Asuttavat arkkitehtuurista Microsoft SharePoint

Navigation: Asuttavat laitealustan> Asuttavat Microsoftilta tuotteet>

Asuttavat arkkitehtuurista Microsoft SharePoint

Lähetä kommentit tästä aiheesta.

Sinä pystyt synkronoida arkkitehtuurista kanssaMicrosoft SharePoint-luetteloista. Synkronointi edellyttää joko uusia SharePoint-luetteloista (ja niiden sarakkeet) peräisin ABACUS tyypit, niiden ominaisuudet ja liitetiedostoja, tai kartoitetaan SharePoint-luetteloista (ja niiden sarakkeet) Abacus tyypit, niiden ominaisuudet ja liitetiedostoja, sitten joko lähettää sisältöä ABACUS SharePoint tai SharePoint- Abacus.

Huomautus

SharePoint Sync ominaisuus edellyttää, että Microsoft SharePoint 2010, 2013 tai SharePoint Online Sivusto on saatavilla yhteyden ja synkronoida.Vaikka SharePoint Sync ominaisuus voi luoda luetteloita (pylväineen) SharePoint-sivuston mistä tahansa ABACUS hanke, Avolution voi myös tarjota erilaisia ​​SharePoint-sivuston malleja, jotka tukevat standardin puitteiden (esim TOGAF ArchiMate®, ITIL jne) niin ota yhteyttä Avolution tuki jos tarvitset tätä ominaisuutta.

Jotta luoda uuden SharePoint-luettelo ja kartta sen ABACUS osan tai yhteyden tyyppi

1. Jotta sinulla on ABACUS auki.

2. Valita Työkalut | SharePoint Sync.

3. Napsauta Uusi kartoituspainiketta ja SharePoint Mapping valintaikkuna kuten alla näkyy.

4. Anna sivuston URL-osoite, käyttäjätunnus ja salasana SharePoint-sivuston ja klikkaa Kytkeä.

Huomautus

Voimassa SharePoint "admin" tai "avustaja" tilille vaaditaan synkronoitavia ja SharePoint ja "lukija" tili sallii vain synkronoida SharePoint.

5. Valitse ABACUS osan tai yhteyden tyyppi karttaan alkaen Valitse tyyppi vedä alas.

6. Napsauta Lisää uusi-painiketta ja sitten kunkin ABACUS osan tai yhteyden tyyppi näkökulma haluat karttaa vastaava SharePoint luettelokenttään valitse kohde vasemmassa paneelissa ja oikeassa paneelissa Kirjoita uusi SharePoint-luettelon nimi Uusi List sarakkeeseen (vain ensimmäisellä kerralla) , sitten SharePoint sarakkeen nimi sarakkeen nimi (tai käytä oletusnimeä) ja napsauta Luovuttaa joka kerta.

Huomautus

Vähimmäisvaatimuksena jotta synkronointi ABACUS EEID, arkkitehtuuri ja nimi näkökohdat automaattisesti kartoitettu SharePoint lukumäärä ja kaksi (2) Yhden tekstirivin (alias teksti) sarakkeita vastaavasti. Nämä voivat olla vapaana. Lisäksi vain tietyt ABACUS näkökohtia voidaan tällä hetkellä kuvata tiettyjä SharePoint sarakkeet ja pylväs tyyppi avattavasta asetetaan automaattisesti vaadittuun SharePoint sarake tyyppi. Nimittäin;

· ABACUS "Hierarkia Polku SharePoint useita riviä tekstiä (alias huomautus) sarakkeet (Huomautus: SharePoint Yksi rivi tekstiä (alias teksti) pylväät tukevat vain 255 merkkiä, joten ne eivät ole edullisia),

· ABACUS "Attached Komponentit SharePoint Lookup sarakkeita (Huom: kartoitus on jo olemassa luettelo liitteenä komponentit itse),

· ABACUS "Teksti ja kuvaus ominaisuudet SharePoint useita riviä tekstiä (alias huomautus) sarakkeet (Huomautus: SharePoint Yksi rivi tekstiä (alias teksti) pylväät tukevat vain 255 merkkiä, joten ne eivät ole edullisia),

· ABACUS "Desimaali tai Kokonaisluku ominaisuuksia SharePoint määrä sarakkeita,

· ABACUS "Luettelo ominaisuuksia SharePoint Choice sarakkeet (Huom: SharePoint ei pakota valintaa arvot niin Luettelo tietotyyppi ei tarvitse panna täytäntöön Abacus),

· ABACUS "Päivämäärä / aika ominaisuuksia SharePoint useita riviä tekstiä (alias huomautus) sarakkeet (Huomautus: SharePoint Päivämäärä ja aika sarakkeita ei voi käyttää vielä johtuen SharePointin epäjohdonmukainen tuki aikavyöhyke / alueellistamisen asetukset),

· ABACUS "Boolean ominaisuuksia SharePoint Kyllä / Ei (alias Boolean) sarakkeita.

ABACUS elementin liittyvät standardit ei voida sijoittaa SharePoint luetteloon sarakkeita vielä.

7. Valita Luo kartoitus.

Jotta Luo uusi kartoitus ABACUS osan tai yhteyden tyyppi ja olemassa oleva SharePoint lista

1. Jotta sinulla on ABACUS auki.

2. Valita Työkalut | SharePoint Sync.

3. Napsauta Uusi kartoituspainiketta ja SharePoint Mapping valintaikkuna kuten alla näkyy.

4. Anna sivuston URL-osoite, käyttäjätunnus ja salasana SharePoint-sivuston ja klikkaa Kytkeä.

Huomautus

Voimassa SharePoint "admin" tai "avustaja" tilille vaaditaan synkronoitavia ja SharePoint ja "lukija" tili sallii vain synkronoida SharePoint.

5. Valitse ABACUS osan tai yhteyden tyyppi karttaan alkaen Valitse tyyppi vedä alas.

6. Valitse SharePoint-sivuston luettelossa karttaa Valitse Luettelo vedä alas.

7. Kunkin ABACUS osan tai yhteyden tyyppi näkökulma haluat karttaa sitä vastaavaan SharePoint lista sarakkeen valitse kohde vasemmassa paneelissa ja oikea paneeli vastaavasti ja valitse Luovuttaa.

Huomautus

Vähimmäisvaatimuksena jotta synkronointi ABACUS EEID, arkkitehtuuri ja nimi näkökohtia on kartoitettu SharePoint lukumäärä ja sitten Arkkitehtuuri ja nimi joko Single rivi tekstiä (alias teksti) tai useita riviä tekstiä (alias Huomautus) sarakkeita vastaavasti. Kunnes tämä on tehty Luo Mapping painike ei ole käytössä. Lisäksi vain tietyt ABACUS näkökohtia voidaan tällä hetkellä kuvata tietyt SharePoint sarakkeet. Nimittäin;

· ABACUS "Arkkitehtuuri näkökohta SharePoint riviäkään teksti (alias teksti) tai useita riviä tekstiä (alias huomautus) sarakkeet (tämä tarvitaan sisällön Kartoituspalveluihin kuten alla on kuvattu),

· ABACUS "Hierarkia Polku SharePoint riviäkään teksti (alias teksti) tai useita riviä tekstiä (alias huomautus) sarakkeet (Huomautus: SharePoint Yksi rivi tekstiä (alias teksti) pylväät tukevat vain 255 merkkiä, joten muita merkkejä, katkaistaan ​​ja siksi on suositeltavaa muuntaa ne Useita riviä tekstiä (alias huomautus) sarakkeita SharePoint ennen kartoitus),

· ABACUS "Attached Komponentit SharePoint Lookup sarakkeita (Huom: kartoitus on jo olemassa luettelo liitteenä komponentit itse),

· ABACUS "Teksti ja kuvaus ominaisuudet SharePoint riviäkään teksti (alias teksti) tai useita riviä tekstiä (alias huomautus) sarakkeet (Huomautus: SharePoint Yksi rivi tekstiä (alias teksti) pylväät tukevat vain 255 merkkiä, joten muita merkkejä lyhennetään ja siksi on suositeltavaa muuntaa ne Useita riviä tekstiä (alias huomautus) sarakkeita SharePoint ennen kartoitus),

· ABACUS "Desimaali tai Kokonaisluku ominaisuuksia SharePoint määrä sarakkeisiin (Huomautus: SharePoint Laskettu sarakkeita voidaan käyttää kuitenkin he vain voi synkronoida SharePoint ABACUS. Yritetään synkronoida" muotoon "laskettu sarake johtaa varoitus kohti alla) ,

· ABACUS "Luettelo ominaisuuksia SharePoint Choice sarakkeita,

· ABACUS "Päivämäärä / aika ominaisuuksia SharePoint useita riviä tekstiä (alias huomautus) sarakkeet (Huomautus: SharePoint Päivämäärä ja aika sarakkeita ei voi käyttää, koska SharePoint epäjohdonmukaista tuki aikavyöhyke / alueellistamisen asetukset),

· ABACUS "Boolean ominaisuuksia SharePoint Kyllä / Ei (alias Boolean) sarakkeita.

ABACUS elementin liittyvät standardit ei voida sijoittaa SharePoint luetteloon sarakkeita vielä. Ja SharePointin Valuutta, henkilön tai ryhmän, hyperlinkki tai kuva, Tehtävä tulos, ulkoiset tiedot ja Managed Metadata sarakkeita ei voi kuvata ABACUS näkökohtia vielä.

8. Valita Luo kartoitus.

Jotta synkronoidaMicrosoft SharePoint-luettelo (t)osaksi ABACUS

1. Jotta sinulla on ABACUS auki.

2. Valita Työkalut | SharePoint Sync.

Huomautus

Jotta synkronoida SharePoint listaABACUS hanke käyttäjän lisenssi tarvitsee SharePoint Syncadd-on ominaisuus. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

3. Valitse olemassa oleva SharePoint kartoitus (tai kuvaukset käyttämällä Ctrl-click tai Valitse kaikkipainike) alkaen SharePoint Kuvauksetpaneelikuten on esitetty näytteen varjostin edellä. Huomautus: tässä näytämme vain "Maali (tai vaatimus)" ABACUS tyyppihyväksynnän kartoitus SharePoint lista nimeltään Tavoitteet on valittu.

4. Valitse Arkkitehtuuri (t), jotka haluat synkronoida sisältöä alkaen Sync Sisältö alkaen arkkitehtuuritpaneeli esitetty näytteen kuvakaappaus edellä. Huomautus: tässä näytämme vain "2015 Todellinen arkkitehtuuria synkronoidaan.

5. Valitse Synkronoida SPnappi.

Huomautus

Jos SharePoint-sivuston käyttäjätiedot eivät ole "Kaikki suosikki" varten kartoitus (t) valitaan sitten Kirjaudu SharePoint ilmestyy valintaikkuna, jossa pyydetään Sivuston URL-osoite, Käyttäjätunnus ja / tai Salasana.Anna nämä. Lisäksi synkronointi sisältää muita kuvaukset, joita tarvitaan liitteenä komponenttien / Lookup sarakkeita. Ylimääräiset kuvaukset, jotka sisällytetään automaattisesti näkyy dialogi kohti alla.

6. Onnistuneita synkronointi SharePoint Sync Results ikkuna ilmestyy näyttöön alla luetellaan muutokset ja varoituksia. Klikkaa Kunnossa.

Jotta synkronoinnista Abacus Microsoft SharePoint-luettelo (t)

1. Jotta sinulla on ABACUS auki.

2. Valita Työkalut | SharePoint Sync.

Huomautus

Jotta synkronoida SharePoint listaABACUS hanke käyttäjän lisenssi tarvitsee SharePoint Syncadd-on ominaisuus. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

3. Valitse olemassa oleva SharePoint kartoitus (tai kuvaukset käyttämällä Ctrl-click tai Valitse kaikkipainike) alkaen SharePoint Kuvauksetpaneelikuten on esitetty näytteen varjostin edellä. Huomautus: tässä näytämme vain "Maali (tai vaatimus)" ABACUS tyyppihyväksynnän kartoitus SharePoint lista nimeltään Tavoitteet on valittu.

4. Valitse Arkkitehtuuri (t), jotka haluat synkronoida sisältöä alkaen Sync Sisältö alkaen arkkitehtuuritpaneeli esitetty näytteen kuvakaappaus edellä. Huomautus: tässä näytämme vain "2015 Todellinen arkkitehtuuria synkronoidaan.

5. Valitse Sync SPnappi.

Huomautus

Jos SharePoint-sivuston käyttäjätiedot eivät ole "Kaikki suosikki" varten kartoitus (t) valitaan sitten Kirjaudu SharePoint ilmestyy valintaikkuna, jossa pyydetään Sivuston URL-osoite, Käyttäjätunnus ja / tai Salasana.Anna nämä. Lisäksi synkronointi sisältää muita kuvaukset, joita tarvitaan liitteenä komponenttien / Lookup sarakkeita. Ylimääräiset kuvaukset, jotka sisällytetään automaattisesti näkyy dialogi kohti alla.

6. Onnistuneita synkronointi SharePoint Sync Results ikkuna ilmestyy näyttöön alla luetellaan muutokset ja varoituksia. Klikkaa Kunnossa.

Huomautus

ABACUS päivittää SharePoint sarakkeet nollanäytteistä vaikka "vaatia, että tämä sarake sisältää tiedon" on asetettu Kyllä SharePoint. Tämä johtuu siitä, SharePoint ei altista tätä asetusta ulkoisesti. Jos tämä on estettävä suositellaan ABACUS Designer asettaa haluttu rajoitus True ja noudatettu annettuja majoituspaikkaan ABACUS " rajoitus ominaisuus .

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Asuttavat arkkitehtuurista Visio | Asuttavat arkkitehtuurista Excel


Asuttavat arkkitehtuurista Microsoft SQL Server

Navigation: Asuttavat laitealustan> Asuttavat Microsoftilta tuotteet>

Asuttavat arkkitehtuurista Microsoft SQL Server

Lähetä kommentit tästä aiheesta.

Voit tuoda arkkitehtuuria Microsoft SQL Server-tietokanta. Voit valita vain tuoda taulukot ja suhteet tehokkaasti tuoda vain yleinen tietokannan rakennetta tai taulukot, Rivit ja suhteet, jotka tuovat paitsi rakenne, mutta tiedot samoin.

Huomautus

SQL Server ominaisuus edellyttää, että Microsoft SQL Server 20052008, 2008 R2, 2012 tai 2014on asennettu tietokoneeseen.

Voit tuoda Microsoft SQL Server tietokannan ABACUS

1. Jotta sinulla on ABACUS auki.

2. Valitse File | Uudet ja valitse SQL Serveralkaen avautuvassa ja valitse OK.

3. Vuonna Tuo SQL Server avautuvassa asettaa "tietokoneen_nimi" ja "SQLINSTANCE" arvoja Connection merkkijono muuttujan ja "dbname" arvo Tietokannan nimi muuttuja oikeisiin arvoihin, kuten on esitetty näytteen kuvakaappaus alla.

4. Aseta Tietokannan nimi muuttuja samaan arvoon kuin Initial Catalog muuttuja asetettu vaiheessa edellä, kuten on esitetty näytteen kuvakaappaus alla.

5. Paina Testaa yhteys -painiketta ja taulukot Tuo osan dialogi olisi asuttuja käytettävissä taulujen, kuten on esitetty näytteen kuvakaappaus alla.

6. Valitse taulukoiden haluat tuoda joko yksittäin valitsemalla ne tai käyttämällä kaikki, ei mitään ja Käänteinen painikkeita oikealla puolella dialogi.

Huomautus

Vain viiteavain suhteet välisistä Taulukot että valitset saa tuodaan.

7. Käyttäminen Tuo tyyli valintanappia valita, haluatko tuoda vain Pöydät ja niiden väliset suhteet tai taulukot, niiden rivit ja erityinen väliset suhteet Rivit.

Huomautus

Ensimmäinen vaihtoehto tuo Taulukot osina tyyppi "taulukossa" ja suhteet tahansa kahden taulukot (vieraasta avaimet) tuodaan yhteydet tyyppi "taulukossa suhde". Tämä on klassinen "ERD" tyyli näkymä järjestelmän taulukoissa. Toinen vaihtoehto tuo Taulukon rivien erillisinä alakomponenttien tyyppi "taulukon rivi", jonka ominaisuudet vastaavat kutakin sarakkeet / kentät ja suhteiden Taulukon rivien tyyppiä "Taulukko suhde". Lisäksi jos on sarake / kenttä nimeltä "Name" tämä käytetään nimetä yksittäisiä taulukon rivi alaerien.

8. Valitse Tuo ... -painiketta.

9. Kun lyhyessä ajassa (edistymispalkki palautetta) uusi ABACUS hanke luotu taulukoita, taulukon rivit (jos toinen vaihtoehto valittiin vaiheessa yllä) ja suhteet Microsoft SQL Server-tietokanta.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Asuttavat arkkitehtuurista manuaalisesti | Asuttavat arkkitehtuurista Visio | Asuttavat arkkitehtuurista Excel


Lisäämällä valmiiksi ominaisuuksia komponentti, liitäntä tai tyyppi

Navigation: Asuttavat laitealustan> Ominaisuudet>

Lisäämällä valmiiksi ominaisuuksia komponentti, liitäntä tai tyyppi

Lähetä kommentit tästä aiheesta.

Standardikirjastot ominaisuuksia voidaan määrittää ja osoitetaan mitään muuta arkkitehtuuria. Näiden kirjastojen kutsutaan Standardit. Käyttämällä Standardit, Sinun tarvitsee vain kerätä tiettyihin järjestelmiin ominaisuudet - standardin ominaisuudet ovat jo olemassa.

Esimerkiksi standardin suoritusarvot Microsoft Windows 2000 voidaan tallentaaStandardija määrätty mitään osia (Tai yhteyksiä, ei että se olisi tyypillinen) käyttäen Microsoft Windows 2000 -käyttöjärjestelmään.

Lisätästandardikomponenttiin, yhteys tai tyyppi

1. Hiiren kakkospainikkeellaosaan / yhteys / tyyppi.

2. Valita Luovuttaa Standardi.

3. ValitaStandardilistasta.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Ominaisuuksia muuttamalla komponentin, yhteyden tai tyyppi | Aggregate ominaisuudet


Ominaisuuksia muuttamalla komponentin, yhteyden tai tyyppi

Navigation: Asuttavat laitealustan> Ominaisuudet>

Ominaisuuksia muuttamalla komponentin, yhteyden tai tyyppi

Lähetä kommentit tästä aiheesta.

Ominaisuudet ovat tyypillisesti järjestelmävaatimukset että määrittelet, tai tulokset ABACUS arviointien. (Kun ABACUS suorittaa arvioinnit, se kirjoittaa ominaisuuksia takaisin tiedosto.) Toisin sanoen, ominaisuudet ovat asioita tiedät järjestelmän, tai mitä käytät ABACUS selvittää.

Muuttaa omaisuuden arvo komponentin, yhteyden tai tyyppi

1. Klikkaaosaan / yhteys / tyyppi (sen ominaisuudet näkyvät Ominaisuudet-ikkunassa oikealla).

2. KlikkaaKorosta ominaisuus, jota haluat muuttaa.

3. Tyyppiuusi arvo.

Tärkeä

Lisäksi, monet ominaisuudet on määritetty käyttäen Standardit . Muuttamalla kiinteistötStandardi, Et vain muuttaa nykyisen objektin, voit myös vaihtaa mestari Standardi (Alle Standarditpuun latvaan). Ennen tätä, tarkistaa, mitä muut, liitoksia tai tyypit käyttävät Standardi, Koska muutos voi olla merkitystä heille- Voit käyttää Viittaukset ikkuna tälle.

Kärki

Voit muuttaa yhteyden ominaisuuksia sisällä osat haara puun (ja päinvastoin). Niinpä esimerkiksi, jos etsit mitä yhteyksiä on kiinnitetty komponentti, ja huomaat, että olet vaihtaa yksi, voit.

Voit lisätä uusia ominaisuuksia komponentti tai liitäntä (via tyyppi)

Huomautus

Ominaisuudet voidaan lisätä tyyppejä ja komponentteja tai yhteyksiä tyyppiä "perivät" nämä ominaisuudet.

1. Klikkaatyypistä (sen ominaisuudet näkyvät Ominaisuudet-ikkunassa oikealla).

2. KlikkaaLisää-painiketta yläreunassa Property ikkunan lisätä rivin yläosassa kiinteistön verkkoon uusi ominaisuus.

3. Lisää TyyppiUuden omaisuutta.

4. Lisää NimiUuden omaisuutta.

5. Lisää OletusarvoUuden omaisuutta.

6. Lisää YksikköUuden omaisuutta.

7. Aseta TietotyyppiUuden omaisuutta.

Huomautus

Data Tyyppi-kentän voidaan käyttää rajoittamaan voimassa arvot omaisuus voi olla. Tuo on; Teksti, Integer, Desimaali, Päivämäärä / Aika, Boolen tai Luettelo.

o A Tekstiomaisuus on yksi, joka on rajaton määrä merkkejä ja olennaisesti ei ole rajoituksia arvoon.Jos omaisuuden arvo on oikein muodostettu hyperlinkin (eli URL täytyy aloittaa jollakin 5jouset; http: //, https: //, ftp: //,tiedosto:tai \\ ja kaikkitilat olisi syöttää "% 20") Niin linkki on napsautettava (kautta ctrl + click).

o Kokonaislukuomaisuus on kokonaisluku joko positiivisia tai negatiivisiaja voivat sisältää ajan, tila, heittomerkki tai pilkku numero ryhmittymän riippuen projektin Alueasetukset alkaen File | Vaihtoehdot hankkeelle.Alueen asetukset ja.Netto Long.TryParse menetelmä on käytetään määrittämään voimassa Kokonaislukuarvot.

o A Desimaaliomaisuus voi sisältää piste tai pilkku varten desimaalin symboli ja voi sisältää ajan, tila, heittomerkki tai pilkku numero ryhmittymän riippuen projektin Alueasetukset alkaen File | Vaihtoehdot hankkeelle.Alueen asetukset ja.Netto Decimal.TryParse menetelmä on käytetään määrittämään voimassa Desimaali arvot.

o A Treffiaikaominaisuuden avulla joko Date osan tai aikainen Osa tai molempia. Alueasetuksetja Net DateTime.TryParse menetelmä käytetään pääasiassa määrittämään kelvollinen päivämäärä ja / tai aika-arvot. Kuitenkin Päivämäärä osa tarvittaessa edellyttää vähintään päivän ja kuukauden (vuosi oletetaan olevan kuluva vuosi) tai kuukausi ja vuosi, osat voimassa. Toisin sanoen Kesäkuussa Q3 2010 tai jopa vain 2010 ovat pätemättömiä. Vaikka se vaihtelee eri alueellisten asetuksia, tyypillisesti päivä, kuukausi ja vuosi, osat voidaan erottaa välilyönnillä, pilkulla, viiva ("-") tai kauttaviivaa ('/'). Päivä osa on tyypillisesti kokonaisluku 1 31. Kuukausi osa on tyypillisesti kokonaisluku 1-12, voimassa 3 lyhenteen kuukauden (esim tammi, helmi, maalis) tai koko kuukauden nimi (esim tammi-, helmi- , maaliskuu). Vuosi osa on tyypillisesti 4-numeroinen positiivinen mutta 1, 2 ja 3 numeroinen vuotta hyväksytään mukaan asetukset Ohjauspaneeli-> Alue- ja kielikohtaiset Options-> Alueellinen Options-> Muokkaa (painike) -> Date> Kalenteri. Tyypillisesti ne tulkitaan seuraavasti; 0-29 tulkitaan 2000-2029, 30-99 kuin 1930-1999 ja 100-999 kuin 100-999. Virheellinen päivämäärät kuten 31 kesäkuu 2010 ja 31/9/2010 havaitaan. Time osa tarvittaessa edellyttää Tunnit ja Minuutit osan ja mahdollisesti Seconds osa. Tunnit, Minuutit ja valinnaiset Seconds osat on tyypillisesti erotetaan kaksoispisteellä (":") ja sekunnit osa voidaan varustaa desimaalipilkkua ('.'). Lisätietoja voimassa formaatteja katso Huomautuksia osio Net DateTime.TryParse menetelmä .

Kärki

On suositeltavaa käyttää vähintään 3 kirjain kuukauden nimi muodossa (eli "Jul" tai "heinäkuun") päivämäärän arvot pikemmin kuin numeerinen muotoilu (eli "7" tai "07"), koska nämä arvot vahvistaa koko useimmilla alueilla riippuen Project: n Alueasetukset alkaen File | Vaihtoehdot hankkeelle.Toisin sanoen on suositeltavaa käyttää "15 heinäkuu 2010" eikä "15/7/2010" tai "07.15.2010". Tämän Esimerkiksi "15/7/2010" epäonnistuu validointi "Englanti (Yhdysvallat) 'ja' 2010-07-15" epäonnistuu varten "Englanti (Yhdistynyt kuningaskunta)", mutta "15 heinäkuu 2010" kulkisi varten molemmat.

o A Booleanomaisuus voi olla joko Oikein vai väärin.On kirjainkoko niin TOSI tai EPÄTOSI voidaan käyttää myös kuitenkin Kyllä, Ei, 1, 0 jne kaikki epäonnistuu omaisuutta rajoitteet.

o A Listaominaisuuden avulla kokoelma ennalta määriteltyjä arvoja, kuten matala | Medium | Korkea tai pitää | Päivitä | Uudelleensuunnittelu | Eläkkeelle ja arvojen tulee Yksikkö-kentästä omaisuutta joko pilkulla tai putken "|" erotetut arvot. Omaisuus voidaan pitää järjestysluku (Toisin kuin nimellinen, alue tai suhde), koska kun käytetään kaavioita ja väri elementtejä kaavios ja 3ds arvoja käsitellään yksinkertaisesti nouseva (tai laskeva) järjestys. Tämä on arvot piirretään nousevaan (tai laskeva) järjestys Kaavion akselien tai väri vaihtelee.

8. Tietotyyppi voidaan asettaa olla Vammaiset, Varoitti tai Pakollinennapsauttamalla hiiren kakkospainikkeella Data Type kentän jokin muu asetus kuin teksti, joka mahdollistaa minkä tahansa merkkejä niin ei voi koskaan olla virheellisiä.

9. Aseta Pakollinenlippu uusi ominaisuus.

Huomautus

Pakollinen kenttä voidaan käyttää osoittamaan, onko arvo on syötettävä omaisuutta. Se on, että se ei voi olla tyhjä tai tyhjä. Vääräon oletuksena ja merkitsee omaisuus voi olla tyhjä tai tyhjä, Tottatarkoittaa, että omaisuus pitäisi olla arvo ja ei voi olla tyhjä tai tyhjä. Pakollinen voidaan asettaa olla Vammaiset, Varoitti tai Pakollinennapsauttamalla hiiren kakkospainikkeella Pakollinen kenttä, jos se on asetettu True.

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Lisäämällä valmiiksi ominaisuuksia komponentti, liitäntä tai tyyppi | Aggregate ominaisuudet


Muuttaminen Projektin alueasetukset

Navigation: Asuttavat laitealustan> Ominaisuudet>

Muuttaminen Projektin alueasetukset

Lähetä kommentit tästä aiheesta.

Kiinteistöjen arvot edellyttää tiettyjä muotoiluja eri alueilla vastaamaan tahansa Tiedot Tyyppi rajoituksia Integer, Decimal ja päivämäärä / aika ominaisuudet. Esimerkiksi Australiassa desimaalin "satakaksikymmentäkolmetuhattaneljäsataaviisikymmentäkuusi kohta seitsemän kahdeksan yhdeksän" on edustettuina "123,456.789", kun taas Saksassa se olisi represnted kuin "123.456,789" ja Ranskassa se olisi " 123 456789 ".Vastaavasti Yhdysvalloissa "toinen joulukuu 1970" on edustettuina lyhyt päivämäärä "12.2.1970", mutta Yhdistyneessä kuningaskunnassa se on edustettuina "12.2.1970" ja Puolassa "1970-12 -02 ". Näin ollen työskennellä ABACUS hanke eri alueilla yleinen asetus kohti ABACUS hanketta tarvitaan.

Muuttua ABACUS hankkeen alueasetukset

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Valita File | Projekti Asetukset ... ja avautuvassa Valitse Alue ja OK. Huom: Katso seuraavassa osassa alueellisen oletusarvot.

Huomautus

Jos et näe Projekti Asetukset ... valikkokohtaniin sinulla ei ole Designer ja Administrator lisäosas ja et voi muuttaa projektin alueella.Lisäksi, jos ei alue on asetettu (eli alue Project Valinnat on "Ei mitään (System alue) ') sitten kunkin käyttäjän MS Windows nykyinen kulttuuri ympäristöissä (Regional Settings)käytetään vahvistamaan ominaisuuksia.

Alue oletusarvot

Seuraavassa taulukossa oletusasetukset kunkin alueen vahvistetun kautta File | Projekti Asetukset ...valikkokohta.Katso taulukon alla on luettelo käytetyistä symboleista.

Alue | Desimaalimerkki | Digit ryhmittely | Negatiivinen | Lyhyt aika | Pitkä aika | AM / PM-symboli | Lyhyt Päivämäärä | Long Päivämäärä
Englanti (Australia) | . | , | - | HH: mm | HH: mm: ss | AM | Pääministeri | pp / kk / vvvv | dd MMMM yyyy
Englanti (Iso-Britannia) | . | , | - | HH: mm | HH: mm: ss | AM | PM | pp / kk / vvvv | dd MMMM yyyy
Englanti (Yhdysvallat) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / vvvv | DDDD, MMMM dd, vvvv
Ranska (Ranska) | , | tila | - | HH: mm | HH: mm: ss | | | pp / kk / vvvv | DDDD d MMMM yyyy
Saksa (Saksa) | , | . | - | HH: mm | HH: mm: ss | | | pp.kk.vvvv | DDDD, d. MMMM yyyy
Italia (Italia) | , | . | - | HH: mm | HH: mm: ss | | | pp / kk / vvvv | DDDD d MMMM yyyy
Espanja (Espanja) | , | . | - | H: mm | H: mm: ss | | | pp / kk / vvvv | DDDD, dd "de 'MMMM' de 'yyyy
Englanti (Kanada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | pp / kk / vvvv | MMMM-pp-vv
Ranskan (Kanada) | , | tila | - | HH: mm | HH: mm: ss | | | vvvv-kk-pp | d MMMM yyyy
Arabia (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | pp / kk / vvvv | dd MMMM yyyy
Arabia (Saudi-Arabia) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | pp / kk / vv | pp / MMMM / vvvv
Englanti (Etelä-Afrikka) | , | tila | - | hh: mm tt | hh: mm: ss tt | AM | PM | vvvv / kk / pp | dd MMMM yyyy
Englanti (Uusi-Seelanti) | . | , | - | h: mm tt | h: mm: ss tt | aamupäivällä | p.m. | d / kk / vvvv | DDDD, d MMMM yyyy
Englanti (Intia) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd-MM-YYYY | dd MMMM yyyy
Saksa (Sveitsi) | . | ' | - | HH: mm | HH: mm: ss | | | pp.kk.vvvv | DDDD, d. MMMM yyyy
Ranska (Belgia) | , | . | - | HH: mm | HH: mm: ss | | | d / kk / vvvv | DDDD d MMMM yyyy
Hollanti (Belgia) | , | . | - | H: mm | H: mm: ss | | | d / kk / vvvv | DDDD d MMMM yyyy
Tšekin (Tšekki) | , | tila | - | H: mm | H: mm: ss | DOP. | ODP. | d.M.yyyy | d. MMMM yyyy
Tanskan (Tanska) | , | . | - | HH: mm | HH: mm: ss | | | dd-MM-YYYY | d. MMMM yyyy
Kreikka (Kreikka) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / vvvv | DDDD, d MMMM yyyy
Suomi (Suomi) | , | tila | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'yyyy
Unkarin (Unkari) | , | tila | - | H: mm | H: mm: ss | de. | du. | yyyy.MM.dd. | vvvv. MMMM d.
Hollanti (Alankomaat) | , | . | - | H: mm | H: mm: ss | | | d-M-vvvv | DDDD d MMMM yyyy
Norja, suomi (Norja) | , | tila | - | HH: mm | HH: mm: ss | | | pp.kk.vvvv | d. MMMM yyyy
Puola (Puola) | , | tila | - | HH: mm | HH: mm: ss | | | vvvv-kk-pp | d MMMM yyyy
Russian (Venäjä) | , | tila | - | H: mm | H: mm: ss | | | pp.kk.vvvv | d MMMM yyyy 'г. "
Ruotsi (Ruotsi) | , | tila | - | HH: mm | HH: mm: ss | | | vvvv-kk-pp | "Den" d MMMM yyyy
Korean (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | vvvv-kk-pp | vvvv "년" M "월 'd' 일 'DDDD
Heprea (Israel) | . | , | - | HH: mm | HH: mm: ss | AM | PM | pp / kk / vvvv | DDDD pp MMMM yyyy

Seuraavilla symboleilla täsmentää, miten päivämäärät ja kellonajat näytetään:

Aika symbolit |
h | Tunti (hh näyttää tunti nollaa)
m | Minuutti (mm näyttää minuutit nollaa)
s | Toinen (ss näyttää toisen nollan kanssa)
tt | A.M. tai P.M.
h / H | 12 tai 24 tunnin ajan näytön
Päivämäärä symbolit |
d, dd | Päivä
ddd, DDDD | Viikonpäivä
M | Kuukausi
y | Vuosi

Katso myös

Asuttavat arkkitehtuurista - Yleistä | Ominaisuuksia muuttamalla komponentin, yhteyden tai tyyppi | Lisäämällä valmiiksi ominaisuuksia komponentti, liitäntä tai tyyppi


Aggregate ominaisuudet

Navigation: Asuttavat laitealustan> Ominaisuudet>

Aggregate ominaisuudet

Lähetä kommentit tästä aiheesta.

Operaatio "Aggregate Ominaisuudet"Voit lisätä arvoja samanlaiset ominaisuudet yhteen ja kirjoittaa (tai lisätä) tulos valitulle emoelementin ominaisuuksia. Sen avulla voit määrittää soveltamisalan yhdistäminen ja onko päivittää ominaisuudet kaikkien osa-elementtejä vai ei.

Voit yhteenlaskettu ominaisuudet

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Napsauta hiiren kakkospainikkeella elementin (arkkitehtuuri, komponentti tai yhteys), jossa tehdä yhdistäminen ja valitse Aggregate Ominaisuudet.

3. Valitse yksi Aggregate Options (Traverse Kaikki Sub-tasot tai Vain suora alitaso). Jos olet valinnut Traverse Kaikki Sub-tasot, Voit myös valita vaihtoehto, haluatko Päivitä Sub-tasot.

o Traverse Kaikki Sub-tasottarkoittaa, että soveltamisalaan yhdistäminen sisältää elementtejä kaikilla tasoilla alla valitsemasi elementti.

o Päivitä Sub-tasotvoidaan tehdä vain, jos olet myös valinneet vaihtoehto Traverse Kaikki Sub-tasot. Tämä tarkoittaa, että kun yhdistää ominaisuuksia alhaalta ylöspäin, yhteenlaskettu tulos kaikilla tasoilla myös päivitetään kuhunkin vastaavien elementtien.

o Vain suora alitasotarkoittaa, että vain ominaisuudet elementtien alapuolella valitun elementin lasketaan yhteen.

o Valita Sisältää StandardiOminaisuudetjos haluat määritellyt ominaisuudet standardit sisällytettävä. Muuten, vain ominaisuudet ainutlaatuinen kunkin komponentin tapauksessa käytetään.

4. Valitse, mitkä ominaisuudet haluat yhdistää. Ne on ryhmitelty niiden Tyypit.

5. Napsauta Seuraavapainiketta.

6. Valitse vaihtoehto, haluatko Korvaa Arvot tai Lisää Arvotosaksi valitun elementin.

o Korvaa Arvotkirjoittaa tulokset suoraan ominaisuuksia valitun elementin.

o Lisää Arvotlisää tuloksia olemassa olevien ominaisuuksien valitun elementin.

Katso myös

Lisäämällä valmiiksi ominaisuuksia komponentti, liitäntä tai tyyppi | Ominaisuuksia muuttamalla komponentin, yhteyden tai tyyppi | Arvioimalla arkkitehtuuri


Analysointi arkkitehtuurista

Navigation: analysointi arkkitehtuurista>

Analysointi arkkitehtuurista

Lähetä kommentit tästä aiheesta.

Kun olet asutuilla (ja mahdollisesti simuloitu) arkkitehtuurista, olet valmis käyttämään ABACUS analysoida sitä. Analysoimalla sitä, voit määrittää, jos arkkitehtuuri täyttää tarpeesi.

Voit analysoida arkkitehtuurin eri tavoin:

· Kaavio

· 3D näkymä

· standardi kaavioita (Piirakka, viiva, pylväs, baari, jne.)

· Custom kartat ( vasteaika , valmiudet tilaa , tähti tontti , scatterplot matriisi ja kuplakaavio )

· Arkkitehtuuri JM

Huomautus

Kun luot kaavio, 3D näkymä, Raportti tai standardin kaavio, standardi elementti valinta ikkuna valitaan elementtejä haluat katsella.

Katso myös

Populating arkkitehtuurista | Simulointi arkkitehtuurista | Kaavio Työkalu


Standardi Element Selection

Navigation: analysointi arkkitehtuurista>

Standardi Element Selection

Lähetä kommentit tästä aiheesta.

Kun luot kaavio, 3D näkymä, Raportti,vakiotaulukollatai käynnissä simulointi, Standardi elementti valintaikkuna valitaan elementtejä haluat analysoida / katsella.

Standardi Element valintaikkuna

Pulldowns

· Lajittele Näytä tahtoa sisältää elementtis aiemmin tallennetun näkymä (eli kaavio, kaavio, 3D). Näin voit suorittaa monimutkaisia ​​"liittyä" kyselyihin käsittelemällä toista mieltä kuin tallennettu "kyselyn".

Valintaruudut

· Näytä tasottahtoa ryhmä mukainen tasolle, jolla ne esiintyvät puussa. Taso 1 on alkuun kaikkein tasolla.

· Näytä Tyypittahtoa ryhmä elementit tyyppien mukaan, että ne ovat.

· Vanhemmat valittujensisältyy emoyhtiön elementtejä tahansa valitun elementtejä. Näin voit varmistaa, että vain hierarkia edellä lapsia sisällytetään varten "alhaalta ylös" valinta.

· Lapset valittujensisältyy lapsia elementtejä tahansa valitun elementtejä. Näin voit varmistaa, että vain hierarkian alla kaikki vanhemmat sisällytetään varten "ylhäältä alas" valinta.

· Nimi ottelut Arvosisältää ainoastaan ​​ne elementit, jotka on nimi, joka sisältää merkkijonoa (Huomaa: Jokerimerkit (eli? ja *) voidaan käyttää). Näin voit muodostaa "semanttinen" kyselyn.

· Onko Kiinteistön tyyppi / Nimi / arvosisältää ainoastaan ​​ne elementit, jotka on asuntotyyppi, nimi ja arvo, jotka sisältävät määritelty merkkijono joko suoraan elementtiin tai sen Standards (Huomaa: Jokerimerkit (eli? ja *) voi käyttää. Esim? * Arvo-kenttään tulee antaa kaikkia seikkoja, jotka on ei-tyhjä arvo annetulle Property). Näin voit muodostaa "semanttinen" kyselyn.

· On Standardsisältää ainoastaan ​​ne elementit, jotka ovat standardin nimi, joka sisältää merkkijonoa (Huomaa: Jokerimerkit (eli? ja *) voi käyttää. Esim HP * antaa kaikki elementit ainakin yksi Standard alkaa kirjaimilla H ja P). Näin voit muodostaa "semanttinen" kyselyn.

· Komponentit / Liitännät kiinnitetty valittusisältyvät kaikki kiinnitetty elementit, jotka on valittu. Tällä tavalla "call-puu" tai "vaikutusten-analyysi" voidaan valita.

Huomautus

Jos sinulla on sekä Näytä tasot ja Näytä Tyypitvalittuna niin voit olla puun pitoisuuksia ensimmäisen tai tyyppejä ensin painiketta, joka näkyy yläpuolella rasti ruutuun.

Kärki

Kun kohde on valittu Standard Element valintaikkuna, se ei aseteta muita suodatin muutokset, kunnes se on valittu. Koska ei ole syntyperäinen tapa etsiä kahta erilaista elementtien kerralla (esim Komponentit standardin tai Standard B), voit etsiä ensin yhdet, valitse halutut komponentit, ja tee sitten toinen etsi toista sarja .

Painikkeet

· Kaikkivalitsee kaikki elementit.

· Käänteinenpoistaa valinnan kaikki valitun elementtejä ja valitsee kaikki ne, joita ei valittu.

· Ei mitäänpoistaa valinnan kaikki elementit.

· Lisää suodatinvalitsee tuloksena sisältö suodattimien ja mahdollistaa valinnan lisäsisältöä yhtä tehokkaasti JA tai liittyä suodatin.

Katso myös

Analysointi arkkitehtuurista


Katseleminen 3D kaavio

Navigation: analysointi laitealustan> 3D kaaviot>

Katseleminen 3D kaavio

Lähetä kommentit tästä aiheesta.

ABACUS voit katsella arkkitehtuurin 3D näkymä, jossa komponentti ja liitäntä ominaisuudet liittyvät värit, muodot ja koot.

Katsella 3D näkymän arkkitehtuuri

1. Jotta sinulla on avaa ABACUS tiedostojoissa näkyvät asutuilla arkkitehtuuri.

2. Laajenna Näkymäthaara puu.

3. Laajenna 3Dhaara puu.

4. Tuplaklikkaus visualisoinnin haluat avata.

- tai -

1. Jotta sinulla on avaa ABACUS tiedostojoissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| 3Dtai napsauta työkalurivin painiketta.

3. Avaa nykyinenvisualisointi (.abacus3d)

- tai -

1. Jotta sinulla on avaa ABACUS tiedostojoissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| 3Dtai napsauta työkalurivin painiketta.

3. Luo uusi visualisointi:

· Valitse Arkkitehtuurihaluat näkymä alasvetovalikosta.

· Valitse Komponentit ja Liitännäthaluat sisällyttää kaaviota standardi elementti valinta ikkuna .

· Associate värit, muodot ja koot kanssa Komponentti Tyypit ja Ominaisuudet.

· Associate värejä ja muotoja Liitäntä tyypit ja Ominaisuudet.

Viedä 3D näkymä

1. Jotta sinulla on Avaa aiemmin 3D näkymä.

2. 3D-näkymän alasvetovalikoista valita File | Viedä...ja valitsi sijainti ja tiedostotyypin visualisointi tiedosto (.abacus3d, .vrml tai .html).

3. Klikkaa Tallentaa.

Katso myös

Analysointi arkkitehtuurista | Navigointi 3D | Kaavio Tool


Navigointi 3D Kaavio

Navigation: analysointi laitealustan> 3D kaaviot>

Navigointi 3D Kaavio

Lähetä kommentit tästä aiheesta.

ABACUS avulla voit helposti selata arkkitehtuuri 3D. Kokemus on samanlainen purjehtii. On kaksi tilaa navigointi:

· Basic-ohjauspaneeli (oletus); ja

· Advanced Control Mode - muutos tähän tilaan valitsemalla Ohjaus| Lisäsäädöt tila.

Huomautus

Voit vaihtaa Perus ohjaus ja Advanced Ohjaustilat, voit käyttää F4pikanäppäin toiminnallisuutta.

Basic Ohjaustapa

· Pitämällä vasenta painiketta ja liikuttamalla hiirtä eteen- tai taaksepäin muuttaa kentällä;

· Pitämällä vasenta painiketta ja liikuttamalla hiirtä vasemmalle tai oikealle muuttaa viipottaa;

· Holding oikeaa painiketta ja liikuttamalla hiirtä pannut näkymä;

· Pitämällä molempia painikkeita alas ja liikuttamalla hiirtä eteen- tai taaksepäin, zoomaa sisään ja ulos arkkitehtuurin; ja

· Pitämällä molempia painikkeita alas ja liikuttamalla hiirtä vasemmalle tai oikealle, rullaa vasemmalle ja oikealle.

- tai -

· Painamalla Nuoli vasemmallenäppäimistön tai numeronäppäimistön kääntyy vasemmalle;

· Painamalla Nuoli oikeallenäppäimistön tai numeronäppäimistön kääntyy oikealle;

· Painamalla Nuoli ylösnäppäimistön tai numeronäppäimistön zoomaa;

· Painamalla Nuoli alasnäppäimistön tai numeronäppäimistön zoomaa;

· Painamalla Sivu ylösnäppäimistön tai numeronäppäimistö piki ylös; ja

· Painamalla Sivu alasnäppäimistön tai numeronäppäimistön piki alas.

Lisäsäädöt tila

· Liikkuvahiiri eteenpäin ja taaksepäin, ja ylös ja alas, muuttuu kentällä ja viipottaa (vastaavasti);

· Painamalla W tai Nuoli ylöszoomaa (eteenpäin) arkkitehtuuriin;

· Painamalla S tai Nuoli alasloitontaa (taaksepäin) pois arkkitehtuuri;

· Painamalla A tai Nuoli vasemmallerullina vasemmalle;

· Painamalla D tai Nuoli oikeallerullaa oikealle;

· Painamalla Q tai Sivu alasnostaa näkymä (alentamalla näkökulmasta); ja

· Painamalla E tai Sivu ylösalentaa näkymä (nostamalla näkökulmasta).

Vuorovaikutteinen Ohjaustapa

Pitämällä vaihtonäppäinnäppäimistöllä ohittaa nykyisen tilan (Basic tai Advanced) siirtyä vuorovaikutteiseen ohjaustapa. Tässä tilassa mahdollista on seuraava:

· Rullahiiren osoitin komponentin tai yhteyden nähdä komponentin tai yhteyden nimi;

· Klikkaaon komponentti zoomata että komponentti;

· Klikkaa-ja-vedäon komponentti kiertää näkymää noin että komponentti; ja

· Hiiren kakkospainikkeellakomponentti tai yhteys ja valitse Näytä Explorerissanähdä, että osa tai liittymän sijainnin puussa.

Yhteinen valvonta

· Käyttää ALT-ENTER / ESCVoit vaihtaa koko näytön tilaan;

· Käyttää F2vaihtaa näytön tilassa. Tämä pääsee myös sisään NäkymäValikko.

· Käytä hiiren rullaa tai +/-muuttaa nopeutta. Nopeus osoitetaan numero vasemmassa alakulmassa - näkyy vain silloin, kun se on muuttumassa. 1 on hitain ja 100 on nopein.


Katsoo vakiotaulukolla

Navigation: analysointi laitealustan> Standard kaavioita>

Katsoo vakiotaulukolla

Lähetä kommentit tästä aiheesta.

ABACUS "standardi kaavioita kuuluvat linja, baari, sarake, alue, scatter, piirakka, kaarre, Pareto, vaihe, pinnan, tutka, kuutio, donitsi, pyramidi, ääriviivat ja käyrä aluekaavioita. Kun olet valinnut kartan tyyppi haluat, loput prosessi katseluun jokainen näistä kaavioita on sama.

Voit tarkastella vakiotaulukolla arkkitehtuurimäärittelyn

1. Jotta sinulla on avaa ABACUS tiedostojoissa näkyvät asutuilla arkkitehtuuri, Ja että sinulla on arvioituarkkitehtuurista.

2. Valita Aseta| Kartoittaatai napsauta työkalurivin painiketta. KaavioitaNäyttöön tulee.

Kaavioita ikkuna

3. Valitse tyyppi kaavio haluat ja asettaa Chart Options, napsauta Seuraava.

Kaavio Valinnat

o Pinottunäyttää suhdetta yksittäisten kappaleiden koko. Voit käyttää pinota kaavion kun aiot olla useita tietosarjoja (eli useita ominaisuuksia), ja kun haluat korostaa koko.

o Peräkkäisen 100%vertaa prosenttiosuus kunkin arvon edistää yhteensä yli luokkia. Voit käyttää 100% pinottu kaavio kun aiot olla useita tietosarjoja (eli useita ominaisuuksia) ja haluat korostaa osuus koko, varsinkin jos koko on sama jokaisen elementin.

o 3D-karttayksinkertaisesti näyttää datapisteet 3-D muodossa estetiikkaa. Jos haluat näyttää tiedot sarja pitkin 3rd / z-akselin ulottuvuus sitten käyttää Cluster sarjan optio kuvattu alla.

o Sarjan Kiinteistövälitysnäyttää tiedot sarjaa kunkin kiinteistön, joka on lopulta valittu. Jos tämä on valittu niin ominaisuudet tulee luokat ja tiedot sarja on jokaisen elementin, joka on valittu.

o Kierrä Chartpyörii kaavio 90 astetta myötäpäivään vaihtamalla x- ja y-akselit. Tämä vaihtoehto on käytettävissä vain Lines, vaihe ja Cube kaavioitaja on erityisen hyödyllistä tehdä Milestone kaavioita kuvatulla toisessa kärjen alla. Huomautus: pylväskuviot jo "kierretään" versioita toisistaan.

o Cluster Seriesnäyttää useita sarjan datan pitkin 3rd / z-akselin ulottuvuus. Tämä vaihtoehto on käytettävissä vain sarake, Baari ja Cube kaavioitaja on erityisen hyödyllistä tehdä Gantt tyyliä kaavioita kuvatun Ensimmäinen vihje alla.

Kärki

Voit luoda Gantt-kaaviovaakasuora baareja osoittaa aika / päivämäärä ominaisuuksia eri elementtien valitsemalla Palkkikuvaaja tyyppi ja valitsemalla Cluster sarjan optio.Lisäksi kerran luotu, äärimmäisenä vasemmalla baari kaaviossa voidaan tehdä "näkymätön" värjäämällä se valkoinen hiiren kakkospainikkeella yksi palkeista, valitsemalla Väri alkaen avautuvasta valikosta ja valitsemalla sivun vasemmassa väri paletista. Lisäksi rajalla äärimmäisenä vasemmalla baari voidaan tehdä "näkymätön" hiiren kakkospainikkeella yksi palkeista, valitsemalla Ominaisuudet ... ja Series -välilehteä että näyttää muuttamalla ylittäviä vaikutuksia vailla ja Colour alkuun -left väri paletista.

Kärki

Voit luoda Milestone kaaviopieniä muotoja osoittaa aika / päivämäärä ominaisuuksia eri elementtien valitsemalla Cube kaaviotyyppi ja valitsemalla Kierrä Chart ja Cluster-sarjan optiot.Lisäksi kerran luotu, kuutiot voidaan muuttaa muita muotoja napsauttamalla hiiren kakkospainikkeella yksi kuutiot tietyllä tietosarjojen ja valitsemalla Ominaisuudet ... ja Series -välilehteä että näyttää muuttamalla Bar joko Sylinteri tai Cone . Huomautus: Gap leveys arvo voidaan myös käyttää "kutistua" symbolit kaavion vähentää päällekkäisyyksiä, suurempi numero vähemmän päällekkäisten tulee olemaan.

4. Vuonna Arkkitehtuuritjakso, rasti arkkitehtuuri / s haluat kartoittaa arkkitehtuurin taso ominaisuuksia, valitse Seuraava.

Huomautus

Valinta arkkitehtuuri taso ominaisuuksia on täysin vapaaehtoista askel ja tulisi käyttää vain silloin, kun haluat nimenomaan kartoittaa arkkitehtuurin taso ominaisuuksia itse.Arkkitehtuuri ei tarvitse valitaan sitten sisällyttää osan tai yhteyden ominaisuuksia seuraavassa vaiheessa.

5. Valitse Komponentit ja Liitännätettä haluat kaavion standardi elementti valinta ikkuna , Sitten valitse Seuraava.

6. Valitse Ominaisuudethaluamasi kaavion ja napsauta Saada valmiiksi.

Kaavio Valinnat

o Sisällytä Peruskohteet tahtoa osoittavat perinyt ominaisuuksia Standards valittavissa.

o Aggregate Ominaisuudet tahtoa laskea vaihtelut sarjan arvojen ja kartoittaa näitä tuloksia eikä yksittäisiä arvoja itse.Tämä vaihtoehto on käytettävissä vain, jos sarjan Property vaihtoehto valittiin vaiheessa 3 edellä.

Kärki

Ominaisuudet käytettävissä kartoitus riippuvat elementtejä valitset.

Voit tallentaa kaavion

Huomautus

Kaavioita voi tallentaa vain, jos ne sisältävät vain osia ja yhteyksiä, jotka kaikki on yhdestä arkkitehtuuri nykyisen projektin.

1. Varmista, että sinulla on uusi tai olemassa kaavio avataja olet tehnyt tarvittavat muutokset.

2. Kaaviossa työkalurivin klikkaa vasemmanpuoleisin Tallenna Chartpainiketta tallentaaksesi kaavio ja kaikki muotoilumuutokset.

3. Vuonna Kaavio Nimiavautuvassa kirjoita nimi kaavio ja paina Kunnossa.

Viedä kaavio

1. Varmista sinulla on olemassa kartoittaa avata.

2. Kaaviossa työkalurivin klikkaa 2nd vasemmalta Tallenna nimellä BMPpainiketta ja valitsi paikka kartalla.

3. Klikkaa Tallentaa.

Katso myös

Analysointi arkkitehtuurista | Katsoo vasteaika kaavio | Katselu kyky tila kaavio


Katselu kyky tila kaavio

Navigation: analysointi laitealustan> Custom kaaviot>

Katselu kyky tila kaavio

Lähetä kommentit tästä aiheesta.

Capability Space kaavion avulla voit katsella onko arkkitehtuuri täyttää vaaditut järjestelmän kyky suhteen ominaisuuksiin havaittujen järjestelmän vaatimus analysointi prosessi.

Voit tarkastella valmiudet tila kaavio

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri, Ja että sinulla on arvioituarkkitehtuurista.

2. Valita Aseta| Kartoittaa| Custom kaaviot| Capability Space. ( Capability Space Chart Confignäyttöön tulee valintaikkuna.)

3. Vuonna Arkkitehtuuritjakso, rasti arkkitehtuurit haluat kaavion, valitse sitten Seuraava.

4. Vuonna Ominaisuudetalue, rasti arkkitehtoninen ominaisuuksia haluaisit sisällytetty akselit kaavion.

5. Vuonna Capabilityalue, jokaisen kiinteistön mukana edellisestä vaiheesta, valitse onko Minimi tai suurimman suorituskyvyn rajoja olemassa ja arvot näiden rajojen. Oletusarvot ovat minimi- ja maksimiarvot arvioitiin arkkitehtuureille tai tavoite omaisuutta jos se on asetettu.

Voit viedä kyky tila kaavio

1. Varmista sinulla on olemassa valmiudet tilaa kaavio avata.

2. Kaaviossa työkalurivin klikkaa vasemmanpuoleisin Tallenna nimellä BMPpainiketta ja valitsi paikka kartalla.

3. Klikkaa Tallentaa.

Katso myös

Analysointi arkkitehtuurista | Katsoo vasteaika kaavio


Katsoo vasteaika kaavio

Navigation: analysointi laitealustan> Custom kaaviot>

Katsoo vasteaika kaavio

Lähetä kommentit tästä aiheesta.

Vasteaika kaavion avulla voit katsella onko yhteyksiä käsitellään vaaditulla nopeudella (ts niiden määräaika).

Nähdäksesi vasteaika kaavio

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri, Ja että sinulla on arvioituarkkitehtuurista.

2. Valita Aseta| Kartoittaa| Custom kaaviot| Vasteaika. ( Vasteaika Chart Confignäyttöön tulee valintaikkuna.)

3. Alkaen Arkkitehtuuritavattavasta luettelosta arkkitehtuuri haluat kartoittaa.

4. Vuonna Liitännätalue, rasti yhteydet haluaisit sisältyvät kaavioon.

5. Scale Tyyppialue, valitse Lineaarinenjos haluat pystysuora akseli (vasteaika) näytetään lineaarisena eteneminen - kukin segmentti kohdalle myönnetään yhtä suuren osan akselin. Valita Logaritminenjos haluat näyttää logaritminen eteneminen - kukin segmentti akseli esittää yhä pidempiä aikoja ylempänä akseli mennä. (Korotuksen määräytyy Pohjavalitset.)

Vasteaika kaavio pystyakselin asteikko

Voit viedä vasteaika kaavio

1. Varmista sinulla on olemassa vasteaika kaavio avata.

2. Kaaviossa työkalurivin klikkaa vasemmanpuoleisin Tallenna nimellä BMPpainiketta ja valitsi paikka kartalla.

3. Klikkaa Tallentaa.

Katso myös

Analysointi arkkitehtuurista | Katselu kyky tila kaavio


Katsoo tähti tontti teidän kehittynyt arkkitehtuureille

Navigation: analysointi laitealustan> Custom kaaviot>

Katsoo tähti tontti teidän kehittynyt arkkitehtuureille

Lähetä kommentit tästä aiheesta.

Kun arkkitehtuuri on kehittynyt ja tavoitteet määritellään, se voidaan sitten visualisoida ja verrata alkuperäisen arkkitehtuurin käyttämällä tähti tontteja. Tässä osassa kerrotaan, kuinka luoda ja manipuloida tähti juoni.

Katsella tähti tontti teidän kehittynyt arkkitehtuureille

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Jotta sinulla on kehittynyt ja asettaa tavoitteitasinun arkkitehtuuri kuvatulla alle Kehittyvä arkkitehtuurista

3. Valita Aseta| Kartoittaa| Custom kaaviotvälilehti | Star Tontti.

4. Klikkaa Saada valmiiksipainiketta.

5. Star Tonttikanssa kehittynyt arkkitehtuurit ja asettaa tavoitteita näytetään. Huomautus: akselit tähti tontti voidaan sijoittaa uudelleen napsauttamalla ja vetämällä akselit toiselle alueelle rajoissa tähti tontin laadun tilaa.

Huomautus

Alue vasemmalla puolella tähti tontti näyttää asetukset tähti juoni näyttöön. Tämä sisältää arkkitehtuuria, joka on kehittynyt (tässä tapauksessa "ABC Oy kuin on 2010") Sekä tavoitteet, jotka on asetettu, että arkkitehtuuri. Huomaatte, että tavoitteet, jotka on valintamerkki niiden vieressä ovat edustettuina akselit tähti tontin (esim KPI- Kustannukset, KPI - Laatu ja KPI - Aika). Voit rasti näiden tavoitteiden missään vaiheessa aikaa poistaa ne tähti juoni.

Punainen ja vihreä "pisteitä" jotka näkyvät tähti tontti edustavat normalisoitu arvo, määritetty paras ja huonoin arvo (esitetty alla Tavoitteiden asettaminen sinun kehittynyt arkkitehtuuri ) Valitun huipputason arkkitehtuuri ja kaikki kehitys sen. Nämä arvot ovat edustettuina Laatu Space.

Kuten yllä olevassa kuvassa, se on selvästi nähtävissä, että alkuperäistä arkkitehtuuria (Sellaisenaan 2010) On huono Maksaa, Kun ensimmäinen kehittynyt vaihtoehto (To-Be 2011 - Strategia) On liikkunut laadun tilaa parantaa Maksaa, Laatu ja aikatavoitteita. Vaihtoehtoisesti toinen kehittynyt vaihtoehto (To-Be 2011 - Strategia B), kun taas se on myös parantunut Maksaa suuruus parannus on pienempi kuin Strategia A mutta sekä laatu ja aika tavoitteet on parannettu enemmän kuin strategian A.Tässä tapauksessa arkkitehti Toukokuu valita Strategia yli Strategia Bkuten niiden suositusja kehittyä edelleen, että vaihtoehto (To-Be 2012 - strategia).

6. Poista Näytä Evolutionsvalintaruutu piilottaa rivi (t) edustaa kehitys (t) välillä alkuperäisen (esim Sellaisenaan 2010) Ja kehittynyt (esim. To-Be 2011 - Strategia) Arkkitehtuurin (s).

7. Valitse Näytä Sticksvalintaruutu näyttämään suhteellinen suuruus kunkin laatumääre (tavoitteet, jotka on määritelty kunkin akselin osalta) kullekin arkkitehtuuri.

8. Valitse Näytä Arkkitehtuuri nimetvalintaruutu jos haluat nimet alkuperäisen ja kehittynyt arkkitehtuuri (t) näkyvän tähti tontti.

Katso myös

Analysointi arkkitehtuurista | Katsoo vasteaika kaavio | Katsoo scatterplot matriisi teidän kehittynyt arkkitehtuureille | Kehittyvä arkkitehtuurista


Katsoo Sirontakuvaajan teidän kehittynyt arkkitehtuureille

Navigation: analysointi laitealustan> Custom kaaviot>

Katsoo Sirontakuvaajan teidän kehittynyt arkkitehtuureille

Lähetä kommentit tästä aiheesta.

Kun arkkitehtuuri on kehittynyt ja tavoitteet määritellään, se voidaan sitten visualisoida ja verrata alkuperäisen arkkitehtuurin avulla scatterplot matriiseja. Tässä osassa kerrotaan, kuinka luoda ja ymmärtää ominaisuudet scatterplot matriisin.

Voit tarkastella scatterplot Matrix teidän kehittynyt arkkitehtuureille

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Jotta sinulla on kehittynyt ja asettaa tavoitteitasinun arkkitehtuuri kuvatulla alle Kehittyvä arkkitehtuurista

3. Valita Aseta| Kartoittaa| Custom kaaviotvälilehti | Scatterplot Matrix.

4. Klikkaa Saada valmiiksipainiketta.

5. Pistekaavionkanssa määritellyt kehitystä arkkitehtuurit ja tavoitteet näytetään.

Huomautus

Alue vasemmalla puolella scatterplot matriisin näyttää asetukset scatterplot matriisin näyttöön. Tämä sisältää arkkitehtuuria, joka on kehittynyt (tässä tapauksessa "ABC Oy kuin on 2010") Sekä tavoitteet, jotka on asetettu, että arkkitehtuuri. Huomaatte, että tavoitteet, jotka on valintamerkki niiden vieressä ovat edustettuina X ja Y akselit scatterplot matriisi (esim KPI- Kustannukset, KPI - Laatu ja KPI - Aika). Voit rasti näiden tavoitteiden missään vaiheessa aikaa poistaa ne scatterplot matriisi.

Siniset pisteet jotka näkyvät tontin matriisissa edustavat normalisoitu arvo, määritetty paras ja huonoin arvo (esitetty alla Tavoitteiden asettaminen sinun kehittynyt arkkitehtuuri ). Nämä arvot ovat edustettuina Laatu Space.

Kaksi määritellyt tavoitteet verrataan toisiinsa scatterplot matriisi ja prosessi toistetaan, kunnes kaikki tavoitteet on verrattu (esim ensimmäisen tontin matriisin edellä kaaviossa vertaa KPI - Kustannuksetmaalinsa KPI - Laatu tavoite. Toinen on Maksaa vastaan Aika ja viimeinen tontti on Laatu vastaan Aika. Asiaa Tavoitteena nimet näkyvät yläosassa ja oikeassa tai kukin rivi tontteja.).

6. Valitse Arkkitehtuuritvalintanappi, jos haluat näyttää mittarit yksittäisten arkkitehtuureille.

7. Valitse Evolutionsvalintanappi, jos haluat näyttää normalisoitu muutokset alkuperäiseen arkkitehtuuriin (esim Sellaisenaan 2010) Ja kehittynyt architecture (s) (esim. To-Be 2011 - Strategia ja To-Be 2011 - strategian B).

Katso myös

Analysointi arkkitehtuurista | Katsoo vasteaika kaavio | Katsoo tähti tontti teidän kehittynyt arkkitehtuureille | Kehittyvä arkkitehtuurista


Katsoo kuplakaavio

Navigation: analysointi laitealustan> Custom kaaviot>

Katsoo kuplakaavio

Lähetä kommentit tästä aiheesta.

Kuplakaavio voit vertailla jopa 5 ulottuvuuksia (eli X, Y, kuplakoko / säde, kupla väri ja kupla raja väri) yhdessä näkymässä.

Voit tarkastella kuplakaavio

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Valita Aseta| Kartoittaa| Custom kaaviotvälilehti | Kuplakaavio.

3. Vuonna Arkkitehtuuritjakso, rasti arkkitehtuurit (mahdollisesti) haluat kartoittaa, napsauta Seuraava.

4. Valitse Komponentit ja Liitännätettä haluat kaavion (jos on) standardi elementti valinta ikkuna , Sitten valitse Seuraava.

5. Valitse X-akseliomaisuus, valitse Seuraava.

Huomautus

Vain Kokonaisluku, Desimaali, Päivämäärä / Aika, Boolen ja List ominaisuudet voidaan käyttää X-akselin. Lisäksi Integer, desimaali ja Date / Time ominaisuudet on piirretty vasemmalle-to-oikeus akselilla skaalattu mukaan omaisuuden arvo kuitenkin Boolen ja List ominaisuudet ovat yksinkertaisesti piirretään vasen-to-aivan tarkkaa järjestystä (tai päinvastaisessa järjestyksessä, jos mahdollisuus kääntää tilaus tarkastetaan) määritellään omaisuutta riippumatta niiden arvot. Esim. Alhainen | Medium | Korkea tai 1, 2, 4, 8, 16.

6. Valitse Y-akseliomaisuus, valitse Seuraava.

Huomautus

Vain Kokonaisluku, Desimaali, Päivämäärä / Aika, Boolen ja List ominaisuudet voidaan käyttää Y-akselin. Lisäksi Integer, desimaali ja Date / Time ominaisuudet on piirretty alhaalta-to-top akselilla skaalattu mukaan omaisuuden arvo kuitenkin Boolen ja List ominaisuudet yksinkertaisesti piirretään alhaalta-to-top täsmälleen samassa järjestyksessä (tai päinvastaisessa järjestyksessä, jos mahdollisuus kääntää tilaus tarkastetaan) määritellään omaisuutta riippumatta niiden arvot. Esim. Alhainen | Medium | Korkea tai 1, 2, 4, 8, 16.

7. Valitse kupla koko / sädeomaisuus, valitse Seuraava.

Huomautus

Vain Kokonaisluku, Desimaali, Boolen ja List ominaisuudet voidaan käyttää kuplakoon / säde. Lisäksi Integer ja Decimal ominaisuudet johtaa kuplakoon / säde skaalattu mukaan omaisuuden arvo kuitenkin Boolen ja List ominaisuudet ovat yhtä vaiheessa lisäyksiä kuplakoon / säde tarkkaa järjestystä (tai päinvastaisessa järjestyksessä, jos mahdollisuus kääntää tilaus tarkastetaan) määritellään omaisuutta riippumatta niiden arvot. Esim. Alhainen | Medium | Korkea tai 1, 2, 4, 8, 16.

8. Valitse joko kiinteä kupla väri tai liittää kiinteistö kupla väri, Sitten valitse Seuraava.

Huomautus

Vain Kokonaisluku, Desimaali, Boolen ja List ominaisuudet voidaan käyttää kupla väri. Lisäksi Integer ja Decimal ominaisuudet johtaa kupla väri valitulla alueella skaalattu mukaan omaisuuden arvo kuitenkin Boolen ja List ominaisuudet ovat yhtä vaiheessa kasvaa kupla väri valitulla alueella täsmälleen varten määritellyssä järjestyksessä omaisuutta riippumatta niiden arvot. Esim. Alhainen | Medium | Korkea tai 1, 2, 4, 8, 16.

9. Valitse joko ei kupla reunuksen väri tai liittää kiinteistö kupla reunuksen väri, Sitten valitse Saada valmiiksi.

Huomautus

Vain Kokonaisluku, Desimaali, Boolen ja List ominaisuudet voidaan käyttää kupla reunuksen väri. Lisäksi Integer ja Decimal ominaisuudet johtaa kupla raja väri valitulla alueella skaalattu mukaan omaisuuden arvo kuitenkin Boolen ja List ominaisuudet ovat yhtä vaiheessa kasvaa kupla rajan väri valitulla alueella täsmälleen samassa järjestyksessä määritelty omaisuutta riippumatta niiden arvot. Esim. Alhainen | Medium | Korkea tai 1, 2, 4, 8, 16.

Kuplakaavio

Voit tallentaa kuplakaavio

Huomautus

Kupla kaavioita voi tallentaa vain, jos ne sisältävät vain osia ja yhteyksiä, jotka kaikki on yhdestä arkkitehtuuri nykyisen projektin.

1. Varmista, että sinulla on uusi tai olemassa kuplakaavio avataja olet tehnyt tarvittavat muutokset.

2. Kaaviossa työkalurivin klikkaa vasemmanpuoleisin Tallenna Chartpainiketta tallentaaksesi kaavio ja kaikki muotoilumuutokset.

3. Vuonna Kaavio Nimiavautuvassa kirjoita nimi kuplakaavio ja paina Kunnossa.

Viedä kuplakaavio

1. Jotta sinulla on Avaa aiemmin kuplakaavio.

2. Kaaviossa työkalurivin klikkaa 2nd vasemmalta Tallenna nimellä BMPpainiketta ja valitsi paikka kartalla.

3. Klikkaa Tallentaa.

Katso myös

Analysointi arkkitehtuurista


Arkkitehtuuri Diff ja synkronointi

Navigation: analysointi arkkitehtuurista>

Arkkitehtuuri Diff ja synkronointi

Lähetä kommentit tästä aiheesta.

Kun sinulla on 2 tai enemmän arkkitehtuurit, joko kehitys tai lähtötilanteessa arkkitehtuurit, voit visuaalisesti "diff" kaksi arkkitehtuurit avulla luettelo tai kaavio Vertailu tai Arkkitehtuuri JM ominaisuus. Tämä on erityisen hyödyllistä löytämässä / uudelleen löytää tarkka tehdyt muutokset yhdestä arkkitehtuuri toiseen kun kehittyvät rakenteita ja kehittää etenemissuunnitelmia Abacus.

Jotta osoittavat "diff" toisella arkkitehtuuri kautta kaavio

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Varmista, että olet olla vähintään 2 arkkitehtuurit hankkeeseen.

3. Avaa kaavio haluat vertailla toiseen arkkitehtuuriin.

4. Napsauta "Vertaa tätä kaavio sisällön toisen arkkitehtuuri -painiketta kaavio työkalupalkin.

5. Valitse muut arkkitehtuurin pudotusvalikosta verrata.

6. Voit suodattaa mitä erot näkyvät napsauttamalla "Erot -painiketta Kaavio työkalupalkin ja poistamalla vaihtoehtoja, esimerkiksi Muuttunut / Lisätty / Tuntematon ja Määrittelemätön / Sync Suositeltava/ Pidä Suositeltava.

Huomautus

Komponentit ja yhteydet kaavio on korostettu punainen, vihreä tai violetti jossa on eroja sisältöä, joka näkyy nykyisen kaavion ja sisällön toiseen arkkitehtuuri. Punainen käytetään silloin, on suositeltavaa synkronoida eroja (katso jäljempänä), Vihreä käytetään silloin, se ei ole suositeltavaa synkronoida eroja, että on pitää ne (katso alla) ja Violetti käytetään tarvittaessa ABACUS voi tehdä suosituksen siitä synkronointi eroja (katso alla). Vain näkyvä sisältö kaaviossa verrataan joten jos merkintä näyttää arkiston omaisuuden arvo ja että arvo muuttuu annetaan osan tai yhteys näkyy heikko punainen, heikko vihreä tai heikko violetti ja "*" symboli näkyy vasemmassa yläkulmassa komponenteille, mutta jos jokin muu taustalla arkiston omaisuuden arvo muuttui, joka ei ole esitetty merkintä niin mitään merkkejä annetaan. Sisältöä, joka tapahtuu nykyisen kaaviossa mutta ei ottelu löytyy vertailussa arkkitehtuuri näkyy vahva punainen, vahva vihreä tai vahva violettija "+" symboli esitetään ylimpänä vasemmassa komponenteille. Matching tehdään osan ja nimi siten, että jos tyyppi tai ainesosan nimi tai yhteys on muuttunut muut arkkitehtuuri ei ottelu löytyy. Koska ei ole mitään keinoa luotettavasti onko lisäsisältöä muista arkkitehtuuri olisi kuin nykyisellä kaavio (esim ylimääräinen rajapinta 2 komponenttien kuten alla kaaviossa vertailukaudesta arkkitehtuuri oikealla), nämä erot eivät ole esitetty kaaviot (ne näkyvät luettelot kohti alla). Leijuu kukin muuttuneen kohde näkyy ero tooltip. Leijuu "*" symboli vasemmassa yläkulmassa kaavion esitetään yhteenveto muutoksista (tai ei muutoksia) välillä kaavion sisältö ja sisältö muiden arkkitehtuurin.

Väri Legend

· Vihreä ilmaisee esineitä, se ei ole suositeltavaa synkronoida eroja, että on pitää ne.

· Punainen ilmaisee kohteita, jotka on suositeltavaa synkronoida eroja.

· Violetti ilmaisee kohdetta jossa ABACUS voi tehdä suosituksen siitä synkronointi eroista.

Jotta synkronoida (synkronointi) ohjelmaa yhdestä arkkitehtuuri toiseen kautta kaavio

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Varmista, että olet olla vähintään 2 arkkitehtuurit hankkeeseen.

3. Avaa kaavio haluat vertailla toiseen arkkitehtuuri.

4. Napsauta "Vertaa tätä katalogi sisältöä toisen arkkitehtuuri -painiketta kaavio työkalupalkin.

5. Valitse muut arkkitehtuurin pudotusvalikosta verrata.

Huomautus

Katso yllä tavasta ABACUS näyttää "JM" välillä 2 arkkitehtuurit luettelossa. Erityisesti miten Punainen käytetään siellä, missä se onsuositeltavaa Synkronoi erot, Vihreä käytetään kun se on eisuositeltavaa synkronoida eroja ja Violetti käytetään tarvittaessa ABACUS voi tehdä suosituksen siitä synkronointi eroista.

6. Hiiren kakkospainikkeella kaavion elementti (tai elementit käyttäen Shift tai kaavio kangas Sync Kaikki) osoittaa "diff" ja valitse Sync valikkokohta.

Huomautus

Mitään synkronointi muutokset voidaan soveltaa vain arkkitehtuuri, joka nykyisin keskittyy luettelo kuuluu. Ota muutokset muihin arkkitehtuurin sinun on käytettävä luettelo muissa arkkitehtuuri. Lisäksi käyttäjät vain voi hakea synkronoinnin muutokset, jos ne on lupa tehdä niin .

Huomautus

Riippuen siitä, missä hiiren kakkospainikkeella valikon kohta näkyy ohjeita siitä, mitä tarkalleen on menossa synkronoidaan. Esim. Hiiren kakkospainikkeella yksittäinen komponentti kaaviossa vain synkronoida että komponentti. Kun taas hiiren kakkospainikkeella kaavion kankaalle ja valitsemalla Sync Kaikki synkronoi kaikki tällä hetkellä esitetty eroja.

Jotta osoittavat "diff" toisella arkkitehtuuri kautta luettelo

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Varmista, että olet olla vähintään 2 arkkitehtuurit hankkeeseen.

3. Avaa luettelo haluat vertailla toiseen arkkitehtuuriin.

4. Napsauta "Vertaa tätä katalogi sisältöä toisen arkkitehtuuri -painiketta Catalogue työkalupalkin.

5. Valitse muut arkkitehtuurin pudotusvalikosta verrata.

6. Voit suodattaa mitä erot näkyvät napsauttamalla "Erot -painiketta Kaavio työkalupalkin ja valinnan poistaminen vaihtoehtoja, kuten Muuttunut / Lisätty / Tuntematon ja Määrittelemätön / Sync Suositeltava/ Pidä Suositeltava.

Huomautus

Solut luettelo on korostettu punainen, vihreä tai violetti jossa on eroja sisällön nykyisessä luettelossa ja vastaavat sisällön toiseen arkkitehtuuri. Punainen käytetään silloin, on suositeltavaa synkronoida eroja (katso jäljempänä), Vihreä käytetään silloin, se ei ole suositeltavaa synkronoida eroja, että on pitää ne (katso alla) ja Violetti käytetään tarvittaessa ABACUS voi tehdä suosituksen siitä synkronointi eroja (katso alla). Vain näkyvä rivit ja sarakkeet luetteloon verrataan joten jos on ero peräkkäin kuin tällä hetkellä on esitetty rivejä tai arvon sarake ei näytetä on ero sitten mitään eroa ilmoitetaan. Jos arvo yksittäinen solu on erilainen matching solun vertailussa arkkitehtuurin solu raja on korostettu. Sarakkeen otsikkoa ja rivin valitsin myös varjostettu heikko violettija näytetään "*" symboli. Nämä "*" symbolia voidaan napsauttaa siirtyä seuraavaan eroa sarakkeen tai rivin vastaavasti. Rivit esiintyy nykyisessä luettelossa, mutta ei ottelu löytyy vertailussa arkkitehtuuri näkyy kanssa "+" symboli rivillä valitsin vasemmalla ja rajan koko rivi on korostettu. Rivit, joka olisi tapahtunut verrattuna arkkitehtuurin versio luettelo (eli sama suodattimet jne), mutta ei ottelu löytyy nykyisen arkkitehtuurin näkyy kanssa "-" symboli rivillä valitsin vasemmalla, rajalla koko rivi korostetaan ja koko rivit solut sisältö näkyy heikko violettija iski-kautta, esim. 8am to kahdeksantoista. Matching tehdään osan ja nimi siten, että jos tyyppi tai ainesosan nimi tai yhteys on muuttunut muut arkkitehtuuri ei ottelu löytyy. Leijuu kukin muuttuneen kohde näkyy ero tooltip. Leijuu "*" symboli vasemmassa yläkulmassa kaavion esitetään yhteenveto muutoksista (tai ei muutoksia) välillä kaavion sisältö ja sisältö muiden arkkitehtuuri.

Väri Legend

· Vihreä ilmaisee esineitä, se ei ole suositeltavaa synkronoida eroja, että on pitää ne.

· Punainen ilmaisee kohteita, jotka on suositeltavaa synkronoida eroja.

· Violetti ilmaisee kohdetta jossa ABACUS voi tehdä suosituksen siitä synkronointi eroista.

Jotta synkronoida (synkronointi) ohjelmaa yhdestä arkkitehtuuri toiseen kautta luettelo

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Varmista, että olet olla vähintään 2 arkkitehtuurit hankkeeseen.

3. Avaa luettelo haluat vertailla toiseen arkkitehtuuri.

4. Napsauta "Vertaa tätä katalogi sisältöä toisen arkkitehtuuri -painiketta katalogi työkalupalkin.

5. Valitse muut arkkitehtuurin pudotusvalikosta verrata.

Huomautus

Katso yllä tavasta ABACUS näyttää "JM" välillä 2 arkkitehtuurit luettelossa. Erityisesti miten Punainen käytetään siellä, missä se onsuositeltavaa Synkronoi erot, Vihreä käytetään kun se on eisuositeltavaa synkronoida eroja ja Violetti käytetään tarvittaessa ABACUS voi tehdä suosituksen siitä synkronointi eroista.

6. Napsauta hiiren kakkospainikkeella solua, sarakkeen tai rivin otsikkoa (tai useita kohteita käyttäen Shift tai Ctrl + kaikesta) osoittaa "diff" ja valitse Sync valikkokohta.

Huomautus

Mitään synkronointi muutokset voidaan soveltaa vain arkkitehtuuri, joka nykyisin keskittyy luettelo kuuluu. Ota muutokset muihin arkkitehtuurin sinun on käytettävä luettelo muissa arkkitehtuuri. Lisäksi käyttäjät vain voi hakea synkronoinnin muutokset, jos ne on lupa tehdä niin .

Huomautus

Riippuen siitä, missä hiiren kakkospainikkeella (eli solu, sarakkeen tai rivin otsikkoa) valikkokohta näkyy ohjeita siitä, mitä tarkalleen on menossa synkronoidaan. Esim. Hiiren kakkospainikkeella yksittäinen kiinteistö tai kiinnitetty osan solu luettelo vain synkronoi että omaisuus tai liitetty komponentti. Kun taas hiiren kakkospainikkeella rivin otsikkoa (tai otsikot käyttäen Shift) synkronoi koko rivin (tai rivien). Hiiren kakkospainikkeella sarakkeen otsikkoa synkronoi kaikki erot sarakkeen.

Nähdäksesi 'JM'2 koko arkkitehtuurit

1. Varmista, että käytössä ABACUS tiedosto auki .

2. Varmista, että olet olla vähintään 2 arkkitehtuurit hankkeeseen.

3. Valita Työkalut| Arkkitehtuuri JM ....

4. Vuonna avautuvassa valitse ensimmäinen / alkaen ja toinen / To arkkitehtuurit vertailla.

5. Klikkaa Kunnossapainiketta.

Arkkitehtuuri Diff

Väri Legend

· Vihreäilmaisee, että solmu lisättiin toiseen / arkkitehtuuriin.

· Punainenilmaisee, että solmu poistettiin toisessa / arkkitehtuuriin.

· Sininenilmaisee, että solmu on määritelty eri tavoin (esim ominaisuuksia tai normeja) toisessa / arkkitehtuuriin.

· Keltainenilmaisee, että solmu on eroja sen lapsilla toisessa / arkkitehtuuriin niin solmu olisi laajennettava.

Huomautus

Voit hiiren kakkospainikkeella ja "Näytä Explorer" kaikki solmut nähdä yksityiskohtia ja lisätietoa annetaan erot erot Yhteenveto paneeli kun solmu on valittuna.

Katso myös

Analysointi arkkitehtuurista | Katsoo vasteaika kaavio | Katsoo scatterplot matriisi teidän kehittynyt arkkitehtuureille | Kehittyvä arkkitehtuurista


Simulointi arkkitehtuurista

Navigation: simulointi arkkitehtuurista>

Simulointi arkkitehtuurista

Lähetä kommentit tästä aiheesta.

Kun olet asutuilla ja analysoinut arkkitehtuuri, olet valmis käyttämään ABACUS onko sinun arkkitehtuuri vastaa käyttäjän määrällisiä tarpeita. Tämä edellyttää simulointi. Simuloida arkkitehtuurista sinun on ensin päätettävä, millaisia ​​tietoja haluat löytää. Tämäntyyppiset tiedot ovat usein kutsutaan KPI tai Key Performance Indicators. Esimerkiksi, haluat analysoida suorituskyky, evolvability, ja avoimuus, vai haluatko kerätä mittareita kuten kokonaiskustannuksia. Kaikki tämä tieto voi paljastaa jollakin tavalla. Kun sinulla on nämä tiedot, voit analysoida arkkitehtuurin eri graafisia formaatteja (tai analysoida uusia arvoja suoraan).

On olemassa kolme vaihtoehtoa simuloida laitealustan:

· Yksinkertainen mittarit ;

· Valmiiksi rakennettu simulaattorit ; tai

· Scripting .

Yksinkertainen Metrics

Jokainen osa arkkitehtuurista on ominaisuuksia - joista monet saattavat olla mukautettuja hakemukseen Abacus. Nämä ominaisuudet ovat eri ainesosien ominaisuuksien. Joissakin tapauksissa yksinkertaisesti kerätä nämä mittarit (rakentaa KPI) voi riittää kertoa tärkeitä tietoja arkkitehtuurista. Esimerkiksi, KLOCS, tai tuhansia rivejä koodia, on käytetty laajalti mittana monimutkaisuus. Muissa tapauksissa voit viedä tietoja ja analysoida sen käyttämällä toisen työkalun. Lisäksi voit kerätä ominaisuuksia suorittamisen jälkeen muunlaista simulointi.

Ominaisuudet voidaan kerätä läpi prosessin aggregaatti . Aggregaatiota lisää määritellyillä osa-ominaisuudet koko, joka heijastuu vanhemman komponentti. Aggregaatiota toimii vain komponentteja, jotka sisältävät osa-komponentteja.

Valmiiksi rakennettu Simulaattorit

On viisi valmiiksi rakennettu simulaattoreita, joita voidaan käyttää Abacus. Nämä ovat:

· Suorituskyky;

· Modulaarisuus;

· Kokonaiskustannukset (TCO);

· Avoimuus; ja

· Luotettavuus.

Huomautus

ABACUS automaattisesti esiin, mikä näistä simulaattoreita on uudelleen läpi Punainen korostus Simulointi työkalurivi .

Scripting

Scripting tarjoaa joustavuutta simuloida arkkitehtuurin mukautetun tavalla. Mukaan kirjoittaminen skriptit voit suorittaa simulaatioita yli nykyisen rakennetun kapasiteetin Abacus. Koko ABACUS oliomalli on käytettävissä komentosarjamoduuli, joten olet vain rajoitettu kykyäsi kirjoittaa skriptejä!

Visual Basic käsikirjoitus on skriptikieli tukee ABACUS, koska se tarjoaa olennaista ohjelmointi ominaisuuksia suhteellisen yksinkertaiset muodossa.

Katso myös

Vieminen arkkitehtuuri | Aggregate ominaisuudet | Kirjoittaminen skriptejä


Kirjoittaminen Scripts

Navigation: simulointi arkkitehtuurista>

Kirjoittaminen Scripts

Lähetä kommentit tästä aiheesta.

Script Editor on yksinkertainen ja toimiva apuohjelma kirjoittamista ja täytäntöönpanosta VB tai C # script vastaan parhaillaan auki ABACUS tiedosto(Kirjastot eivät tue scripting). Se on tavallista File Open, Sulje ja tallenna komentoja, joten voit tallentaa ja hakea skriptejä kirjoitat. Se on myös perus ajaa ja debug laitokseen. Script Managerin avulla voit helposti toteuttaa eri skriptejä, jotka olet kirjoittanut asettamalla valikon vaihtoehdon niille suoraan Työkalut-valikosta.

Pääset Skriptieditori

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Valita Työkalut | Script Editorja Script Editor ikkuna avautuu. Sitten joko;

3. Avaa olemassa käsikirjoituksen kautta Tiedosto | Avata vuonna Skriptieditori valikot,

tai

3. Avaa Esimerkki script kautta Esimerkki tuote Skriptieditori valikot,

tai

3. Aseta oletus kieli joko VB tai C # kautta Kieli tuote Skriptieditori valikot,

tai

3. Open Scripting erityistä tukea kautta Auttaa tuote Skriptieditori valikot

Kun kirjoitat skriptejä, sinun on noudatettava joko VB tai C # syntaksikohti asetus alla Kieli kohteen Skriptieditori valikot.

HUOMAUTUS:

· Käyttää standardi VB toimintoja kuten MsgBox ()sinun on oltava Tuonti Microsoft.VisualBasicjulkilausuma alussa oman käsikirjoituksen. Tämä ei ollut tarpeen ennen versiota 3.0 Abacus.

· Tämä ohje ei sisällä tietoa siitä, miten kirjoittaa VB käsikirjoituksen, eikä se sisällä VB viittaus. Voit vapaasti kirjoittaa skriptejä suosikki IDE tai toimittaja, kopioi ja liitä Script Editor.

Kun aloitat Skriptieditori, Skriptieditori on tyhjä. Voit käyttää luuranko käsikirjoituksen kautta Esimerkkejä valikko. Kun ensimmäisen kerran käynnistät Script Editor, sinun pitäisi ajaa Malli luuranko nähdä, että se toimii. Lisäksi on kaksi komentotiedostoja joka pääsee läpi Esimerkkejä valikko.

Voit kirjoittaa hyödyllinen käsikirjoituksen sinun tulee viitata ABACUS ObjectModel. Se on saatavilla käsikirjoitus sisällyttämällä Tuonti ABACUS.ObjectModellausunto kärjessä oman käsikirjoituksen. Täydellinen viittaus koko ABACUS oliomallia mukana Script Editor. Löydät sen valitsemalla Apua | Sisällysalkaen Skriptieditori ikkuna.

Script editor sisältää monia hyödyllisiä ominaisuuksia kirjoittamiseen skriptejä, mukaan lukien automaattinen täydennys kuten on esitetty kuva alla. Kuitenkin entistä monipuolisemman käyttökokemuksen MS Visual Studio voidaan integroida ABACUS ja yksityiskohtaiset ohjeet ovat saatavilla tässä .

Script editor kanssa Automaattinen täydennys

Käyttää Script Manager

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Valitse Työkalut | Script Manager.

3. Klikkaa Lisätäkuvake ja Avataikkuna avautuu.

4. Selaa Abacus Script (.abacusscript, .vb Tai .cs) Tiedosto haluat lisätä Työkalut-valikkoon.

5. Klikkaa Kunnossaja viittaus kirjoitus näkyy Script Manager -ikkunassa. Anna nimi script kuin haluat sen näkyvän Työkalut-valikosta. Huomautus: Script Manager -ikkunan kokoa voi muuttaa nähdä koko polku tarvittaessa.

6. Toista vaiheet 3-5luoda linkkejä enemmän ABACUS skriptejä.

7. Klikkaa LähelläSulje Script Manager ja huomaa, että ABACUS skriptin (t) nyt ilmestyy Työkalut-valikosta.

Komentosarjan suorittamisen

Joko;

1. Auki, kirjoita tai kopioi ja liitä käsikirjoituksen haluat ajaa, joten se näkyy pääikkunassa Script Editor.

2. Napsauta Ajaapainiketta.

3. Jos käsikirjoitus sisältää virheitä, virheen kuvaus osiossa alareunassa Skriptieditori listaa yksityiskohdista, kuten linja numerot. HUOMAUTUS: Jokainen yksittäinen virhe Virhe Kuvaus osa voi olla kaksinkertainen napsautetaan vie sinut vastaavaan rivin kirjoitus.

- tai -

1. Valita Työkalutja sitten ABACUS Script nimi valikkokohta kuin luotu Script Manager.

2. Jos käsikirjoitus sisältää virheitä, Skriptieditori avataan sisällön kirjoitus näkyy pääikkunassa (korostettiin rivi Ensimmäinen virhe) ja virheen kuvaus osiossa alareunassa Skriptieditori listaa tiedot tai virhe (t) mukaan lukien rivinumerot. HUOMAUTUS: Jokainen yksittäinen virhe Virhe Kuvaus osa voi olla kaksinkertainen napsautetaan vie sinut vastaavaan rivin kirjoitus.

Scripting Kokoelma virheet

Kokoomateos virheitä esiintyy, kun syntaksi komentosarjakoodin ei ole oikea. Nämä virheet näkyvät alareunassa ikkunan Error osassa, jossa kuvaus virheestä, ja rivinumero. Se on linja numero joka erottaa kokoelma virheen runtime error (katso jäljempänä), joka ei ole rivinumero. Kokoomateos virheet voidaan kaksinkertainen napsautetaan hyppäämään ja korostaa erityinen linja kyseessä.

Scripting Runtime virheet (Tärkeä)

Runtime virheitä esiintyy, kun käsikirjoitus koodi on menestyksekkäästi käännetty ilman virheitä, mutta virhe tapahtuu runtime (katso esimerkit alas edelleen). Kesto virheet ovat tärkeitä, koska ne voivat aiheuttaa vioittunut malleissa, kun objekteja luotu ja viitataan muiden esineiden malli, eivät itse kuulu mallin (yleensä koska runtime error on tapahtunut ennen kuin koodi, joka olisi asettanut ne mallissa jonnekin, teloitettiin).

Jos skripti luo esineet lisätä malliin, voit välttää korruption aiheuttama runtime error tallentamalla oman käsikirjoituksen, sulkemalla scripting, ja suoritetaan Kumoa muutoksia, jotka on luotu käsikirjoitus (jos käsikirjoitus suorittamisen ei ole täydellinen yleensä ). On kuitenkin olemassa myös muita tapoja välttää korruptiota esiintyy (katso alla). Huomautus: Kaikki skriptejä, jotka vain lukea malli ja eivät kirjoita sitä, ovat turvallisia ja eivät aiheuta ongelmia, riippumatta siitä, runtime virheitä aikana niiden toteuttamista.

Korruption välttämiseksi, kun kirjoitat käsikirjoitus koodi, joka luo esineitä ja lisäämällä ne objekti malli, ehdotetaan, että esineet lisätään malliin niin pian kuin mahdollista, jos ne viittaa muita esineitä.

Esimerkiksi, jos luot uuden yhteyden, ja 2 uusia komponentteja, ja sitten liittämällä ne yhteen, on parasta luoda ensimmäinen komponentti, lisää se malli, sitten toinen ja lisätä sen, ja sitten luoda yhteys ja lisätä sen, ja sitten lopulta luoda liitetiedostoja. Tämä tarkoittaa, että jos olisi olemassa olevan runtime error joka keskeyttää skriptin suorituksen, kaikki esineet, joita tarvitaan olla objectmodel ennen liitetiedoston luodaan, ovat mallissa. Korruptio voi ilmetä, jos esimerkiksi vain yhteys oli lisätty, liitteet tehty, ja sitten runtime virhe ennen käsikirjoitus lopulta lisäsi uuden komponenttien model.Corruption voi esiintyä aina objekti, johon viitataan toisen esineen objectmodel, ei itse ole objectmodel.

Esimerkki runtime virheitä:

· Referenssin ei asetettu instanssi kohteen - Tämä tapahtuu, kun kohde muuttuja on nolla viittaus, ja menetelmä tai omaisuuden joka esinettä käytetään. Null viittaukset voidaan tarkistaa "Jos objectVariable ole mitään Sitten ..."

· Indeksi oli rajojen ulkopuolella array - Tämä tapahtuu, kun matriisi on käytössä kanssa indeksi, joka on rajojen ulkopuolella - esimerkiksi pienempi kuin 0 tai suurempi tai yhtä suuri kuin pituus / Kreivi jono. Array tai Kokoelma pituutta voidaan tarkistaa .Length tai .Count ominaisuuksia vastaavasti.

· Ei lupaa Poikkeus - Sinulla ei ole lupaa ... - tämä tapahtuu, jos sinulla ei ole lupaa tehdä tietyn muutoksen

· Ensisijainen Key Poikkeus - Monista / Missing nimi / tunnus - tämä tapahtuu, jos muutos tehdään ainutlaatuinen ominaisuus, joka on ristiriidassa toisen objektin. Esim. Arkkitehtuurit on oltava yksilöllinen nimityksen, samoin Standards.

· Viite-eheyden Poikkeus - asetus viittaus kentän esineeseen, joka ei kelpaa. Esim. lisäämällä "ei mitään" tai null lapsena moniin kokoelmien objectmodel.

· Nollapituutta Poikkeus - tämä saattaa ilmetä, jos yrität määrittää nimen objektin tyhjä merkkijono. Useimmat kohteet edellyttävät nimensä olla vähintään 1 merkki.

Tuonti lausunnot

Huomaa, että alussa luuranko skriptit on lausuntoja, kuten Tuonti ABACUS.ObjectModel. Nämä lausumat eivät sisällä dll joka ei ole jo viittaa kirjoitus - niiden tarkoitus on tarjota "oikotie" ottaa määrittää koko nimi luokan.

Esimerkiksi, julistaa muuttuja tyyppiä CComponent (edustavat komponentti Abacus), kanssa Tuonti ABACUS.ObjectModellausunto yläosaa kohti käsikirjoituksen, vain vaatia sitä tarvitse ilmoittaa hämärä Comp kuten CComponent, Koska kääntäjä tietää katsoa ABACUS.ObjectModel nimiavaruutta CComponent luokan. Ilman tuonti julkilausuman, se olisi ilmoitettu dim Comp kuten ABACUS.ObjectModel.CComponent. Kokoonpano (kuten mscorlib.dll, tai system.Windows.Forms.dll) voi sisältää useamman kuin yhden nimiavaruus - tuonti lausunto Näistä nimitilat, ei kokoonpanot itse. ABACUS.ObjectModel.dll kokoonpano on vain yksi ABACUS.ObjectModel nimiavaruuden pääsee Scripting.

Automaattisesti viitataan kokoonpanot

Seuraavat DLL viitataan automaattisesti Scripting:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (epäsuorasti viittaa kääntäjä)

· ABACUS.ObjectModel.dll

Jos haluat tehdä lisää viittauksia joko muita NET kokoonpanot, tai oma kokoonpanot, katso seuraava osio #ImportDLL lausunto.

#ImportDLL lausuma

Vuodesta ABACUS 3.1, voit viittaus muita kokoonpanot mitä voi vaatia komentosarjakäyttöä käytön #ImportDLL lausunto. Esimerkiksi, jos halusi käyttää mukautetun DLL sinun ja hyödyntää toiminnallisuutta, sitä asettaisi sen ABACUS hakemistoon ja sisältävät ilmoitus ensimmäinen rivi (t) käsikirjoitus. Jos se on NET DLL, niin yleensä sinun ei tarvitse syöttää koko polku, vain DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.xml.dll

Joitakin muita asioita:

1. Koska DLL on löydettävä käännöksessä ja runtime, mikä rajoittaa mukautetun (ei NET) DLL on sijoitettu ABACUS -ohjelmakansiosta vain.

2. #ImportDLL lausunnot on ensimmäinen rivi (t) kirjoitus - jos sinulla on 5 lausuntoja, niin ne pitäisi olla ensimmäisellä 5 riviä kirjoitus

3. #ImportDLL lausunto sijoittaa mihin tahansa, mutta ensimmäinen riviä kirjoitus (esim jos se pantiin jälkeen kommenttia tai Tuonti lausunto) ei toimi oikein ja / tai saattavat aiheuttaa liity kääntäjä virheitä.

#ImportDLL Office kokoonpanot

Jos sinulla on Microsoft Office asennettuna, ja käsikirjoitus vaatii viraston Interop kokoonpanot, on mahdollista viittaus niitä yksinkertaisesti käyttämällä #ImportDLL kanssa kokoonpanon nimi (kuten alla, esim. #ImportDLL Excel). Tällä menetelmällä on se etu, että absoluuttinen dll polkua ei tarvitse käyttää, joten käsikirjoitus on kannettava (pitäisi toimia molemmilla Office 2003 ja 2007 ilman, että muokkaat käsikirjoituksen).

Kun käytät tätä toimintoa, GAC (Global Assembly Cache) etsitään Interop kokoonpano, ja käsikirjoitus kokoaa polku että kokoonpano jos löytyy. Jos se ei ole löytynyt, scripting tarkistaa ABACUS ohjelmahakemistossa (joka sisältää Excelin ja Visio interops vain). Jos pyydettyä INTEROP ei löytynyt tällä kertaa, näkyy varoitus.

Interops tyypillisesti ole asennettu GAC jos olet asentanut Microsoft Office ennen kuin asennat .NET Framework (joka on osa koko ABACUS asennus). Voit asentaa ne suorittamalla Muuta vaihtoehtoa Microsoft Office -ohjelman Lisää / poista sovellus, ja valitse .NET Ohjelmoitavuus vaihtoehtoja. Saat lisätietoja, katso tämä artikla MSDN.

Kokoonpanot, joille tämä pikakuvake tuettuja ovat:

· Pääsy

· Access.Dao

· Kunnostautua

· Kaavio

· MSProject

· Näkymät

· OutlookViewCtl

· OWC11

· PowerPoint

· Kustantaja

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Sana

It ei ole täysin selvää, onko kaikki edellä kokoonpanot ovat työkaluja, huoneita havebeen sisällytetty tätä ominaisuutta regardeless kuin jotkut käyttäjät helmikuu tarvitsevat jopa hämärtää kokoonpanot.

Katso myös

Simulointi arkkitehtuurista

© 2001-2015 Avolution Pty Ltd: Kaikki oikeudet pidätetään.


Makroilla

Navigation: simulointi arkkitehtuurista>

Makroilla

Lähetä kommentit tästä aiheesta.

Jos suoritat tehtävän toistuvasti Abacus, voit automatisoida tehtävän käyttämällä makro. Näin ollen, Abacus makro on tallennettu sarja toimintoja, jotka voidaan toistaa milloin tahansa.

Tallennus Makro

1. Valitse Työkalut | Record makrotai vaihtoehtoisesti paina Alt + F10.

2. Aloittavat toimintansa, jonka haluat tallentaa.

Varoitus

Tällä hetkellä on olemassa joitakin tunnettuja ongelmia makro tallennus. Ota nämä huomioon, kun tallennuksen makroja:

· Tällä hetkellä makrot vain tallentaa Microsoft Windows näppäimistön, hiiren liikkeet ja hiiren napsautuksella. Kuitenkin johtuen rajoituksista kanssa makro-tallennin itse, on joitakin näppäimistön, joita ei aina kirjata. Nämä sisältävät:

· [Tab]

· [Ctrl]

· [Alt]

· [Poistu]

· [Käynnistä]

· [F1] on [F12]

· Siksi on suositeltavaa, että olet varmistanut, että pikanäppäin on tallennettu makro-tallennin ennen tallennuksen suuri tapahtumasarjasta, joka voi luottaa, että pikanäppäin työ.

· Tällä hetkellä johtuu rajoituksia makro-tallennin, pikavalikot ei käsitellä asianmukaisesti ABACUS kun ne avataan nostamalla kirjannut makro-tallennin. Kun avaat pikavalikon, sinun täytyy suorittaa yksi toiminnoista lueteltujen pikavalikosta kautta pikavalikon, muuten kontekstivalikko saattaa jäädä auki toiston aikana, mikä voi johtaa tahattomiin toimia tai toimia, jotka voisivat aiheuttaa virheitä ABACUS.

· Huomaa, että normaali menetelmiä sulkemisen pikavalikon (esim painamalla [Esc] näppäimistöllä, tai vasemmalle napsauttamalla muualla ruudulla) ei oikeastaan ​​sulje kontekstivalikkoon toiston aikana makro.

Kärki

Valintaikkunoissa, käyttävät mieluummin hiirellä, on suositeltavaa käyttää sarkainnäppäintä liikkua saatavilla valvontaa ja nuolinäppäimillä valita pudotusvalikosta kohteita tai valintanappi vaihtoehtoja ja välilyöntiä valita / de-valitse Tarkista laatikot.

Tallennuksen lopettaminen Makro

1. Lehdistö Alt + F9tai vaihtoehtoisesti valitse Työkalut | Lopeta Macro.

2. Valitse Tallenna makro -valintaikkunan Selaa sijainti ja valitse ABACUS makro (.abacusmac tiedosto) tiedoston nimi ja valitse Tallenna.

Huomautus

Käyttäminen Työkalut| Lopeta Macrosisällyttää tämän toiminnan tallennettu makro. Siksi on suositeltavaa, että käyttäjät tulla taitavia käyttämällä Alt + Toimintonäppäin vaihtoehtoja työskennellä Makroja jottei sisällyttää toivottuja makro toimintaa makrot itse.

Kärki

Koska makrot eivät ole tällä hetkellä muokattavissa on suositeltavaa kirjata pitkiä tehtäviä sarjana erillisiä makroja käyttäen Alt + F10 / Alt + F9 "paria".

Toistaa tallennetun Makro

1. Valitse Työkalut | Toisto Macrotai vaihtoehtoisesti paina Alt + F8.

2. Avaa makro -valintaikkunan Selaa sijainti ja valitse ABACUS makro (.abacusmac tiedosto) tiedostonimi ja valitse Avaa.

Varoitus

Kun avaat ABACUS makro, jos tuplaklikkaa makro tiedoston selausikkunaan avata, makro-tallennin voi pitää vasemman hiiren painiketta vasemmalla napsauttanut tilassa kunnes tallennettu vasemmalla napsauttamalla ohituksia tässä tilassa.

Huomautus

Toistonopeutta makro voidaan asettaa Yleiset-välilehden Työkalut| Vaihtoehdotjoko Normaali (oletus), nopeasti tai hitaasti. Sekä nopea ja hidas toisto nopeus ei suositella, koska ne toistaa tallennettu makrojen noin 100 kertaa ja 1/100 reaaliaikaista, vastaavasti. Normaali toisto nopeus vielä toistaa makro noin 30% nopeammin kuin nauhoitusnopeuden joten on suositeltavaa tallennuksen aikana pysähtyä vähän aikaa sen jälkeen kaikki pitkät käsittelyajat tehtävänä on varmistaa, että toiston seuraava toimenpide ei suoriteta ennen käsittelyä tehtävä on valmistunut.

Stop pelaa tallennetun Makro

1. Lehdistö Alt + F9.


Simulointi Suorituskyky

Navigation: simulointi laitealustan> Simulators>

Simulointi Suorituskyky

Lähetä kommentit tästä aiheesta.

Tausta

Arkkitehtoninen arvioijan suorituskyky on diskreetti tapahtuma simulaattori että toimii simuloimalla virtaus viestien (tai rahakkeita) koko arkkitehtuuri. Teoria takana on johdettu tekemän tutkimuksen University of Technology, Sydney, ja se perustuu Layered jonoverkkona mallit(LQNM), Ajastettu ja Värilliset Petri-verkot(TCPN) ja Aktiviteetti Cycle kaaviot(ACD).

Vuonna ABACUS suorituskyky simulaatio, käsittely yksi ainesosa on johtuu suurelta osin viestit välitetään se toisesta komponentti. Periaatteet tätä tekniikkaa voidaan ymmärtää neljästä pääosasta:

1. viesti-keskeinenviestintä on mallinnettu Abacus käyttäen looginen(Tai epäsuora) yhteyksiä. Loogiset yhteydet määritellä käyttäytymistä (yleisyys ja tiedot) viestien välillä kului komponentteja. Hyvä esimerkki loogisia yhteyksiä olisi sekvenssi virtaa kahden (2) liiketoimintaprosessien tai looginen rajapintoja kahden (2) sovellukset.

2. Looginen viestit kuljetetaan määränpäähänsä kautta hierarkia(Kuten luonnonvarojen swimlanes) tai suoraanliitännät (kuten fyysinen johdot). Voit tehdä tämän ne voidaan reitittää ylös, esille takaisin alas hierarkiassa (Monitasoista lähestymistapaa) seurata suoraa polkua.

3. Uskollisuus mallia voidaan säätää sopivaksi. Esimerkiksi, voidaan jakaa alas niin pitkälle siten, että jokainen peruskoulun prosessi ja toiminta on erillinen käsittely jalanjälki. Vaihtoehtoisesti se voi olla tarpeeksi on vain yksi arvo koko prosessin, mikä keskimäärinkäsittely vastauksena viestin.

4. Varsinainen jalostussuoritetaan vain osia, jotka ovat (tai ovat) suoritin. Prosessori on yleinen asia, ja se voisi olla CPU, henkilö, organisaation yksikkö tai jotain muuta, joka pystyy suorittamaan työn. Esimerkiksi, liiketoimintaprosessien ei tee mitään varsinaista käsittelyä; tämä tapahtuu ensin "jalostaja" se etsii joko sen emoyhtiön hierarkian (jos kaista merkintätapa on käytössä) tai sen käsittely verkkoon (jos hajautettuun merkintätapa on käytössä).

Arviointi tehdään simuloimalla (määritelty) liikennettä järjestelmässä, siten, että jokainen yhteys on simuloidaan ainakin kerran. Saapumisajat viestit satunnaisesti osalta niiden tietyin välein. Malli simuloi resurssi käsittely ja riitaa ja jonotusta viestien, kerätä tilastoja matkan varrella erilaiset tuotanto ominaisuuksia.

Key Performance oletuksin

1. Taajuus- Taajuus, jolla yhteys tapahtuu.

2. Jalostus- Määrä suoritusaika loppuun yksi prosessi. Tämä voi olla tunnit, minuutit, päivää, toiminta jne.

3. Nopeus- Prosessorin nopeutta resurssi. Eli kuinka monta kierrosta / ohjeet / toimiin se voi suorittaa yhdessä aikayksikössä. On tärkeää olla johdonmukainen yksiköitä käytetään käsittely.

4. Prosessorit- Määrä prosessorin resursseja. Prosessorit voi olla ihmisiä, CPU, ulkopuolisten organisaatioiden jne.

Key Performance tuotostekijöihin

1. Suoritusteho- Viestien määrä aikayksikössä kautta yhteys. Tämä todellinen arvo voidaan verrata odotettavissa / teoreettiset arvot (eli Frequency) päätellä kylläisyyttä järjestelmän.

2. Viesti Luokitus- Viestien määrä aikayksikössä kautta komponentti. Tämä on summa kaikkien osien "saapuvat ja lähtevät viestit.

3. Vastaus- Vähimmäis- / keskimääräinen / maksimilatenssi tästä yhteys. Tämä on summa havaittu latenssit yhteyden lähteeltä pesuallas ja kaikki jonotuksen ja käsittely (ja latenssi takaisin lähteeseen jos kaksisuuntainen).

4. Käyttö- Hyödyntäminen komponentti. Tämä on 0% jos osa ei ole laite / jalostaja (eli se ei ole prosessorit ja nopeus ominaisuudet edellä on määritelty).

Kun taas erillinen tapahtuma simulaatio suoritetaan laskea eri näyttö- ominaisuudet, kuten edellä on kuvattu, seuraavaa kaavaa voidaan käyttää karkea tarkastuksen tulosten (jossa järjestelmä ei ole tyydyttynyt):

Hyödyntäminen = summa taajuuden kaikki saapuvat yhteydet * Processing / (Nopeus * prosessorit)

Kokonaiskonsepti on ehkä parhaiten osoittaa huomioon seuraavassa kaaviossa, jossa esitetään kaksi erilaista suorituskykyä meta-malleja. Vasen käsi tyyli on klassinen "kaista" merkintätavalla käsittely tehtäviä perustuu hierarkkisesti niiden suoritinresursseja. Oikea käsi tyyli on hajautettuja merkintätapa jalostukseen liittyvät tehtävät kautta prosesseja yhteyden niiden suoritinresurssi. Tämä jälkimmäinen merkintätapa mahdollistaa useiden suoritinresursseja tiettyä käsittelyä tehtävä, toisin kuin rajallinen kaista merkintää.

Huomautus

Näkyvissä jokaisessa meta-malli ovat panos ominaisuuksia (punaisella) ja tulos-ominaisuuksista (sininen):

Suorituskyky meta-mallit: kaista vastaan ​​Distributed merkintätapa

Running Performance simulaattori

Simuloida arkkitehtuurista suorituskyvyn

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Valita Analyysi| Suorituskykytai napsauta työkalurivin painiketta.

3. Valitse Arkkitehtuurihaluat arvioida mistä pudotusvalikosta.

Huomautus

Oletuksena ABACUS automaattisesti valitse ensimmäinen arkkitehtuuri joka uudelleen simulointi vuoksi tarvitaan mitään olevan kiinteistön tai rakenteellisia muutoksia.Tämä korostus näkyy Punainen koskevat Simulointi työkalurivi .

4. Valitse Komponentit ja Liitännäthaluatte arvioida, mistä standardi elementti valinta ikkuna .

5. Aseta Akun kesto Scale Factorliukusäädintä.

Huomautus

Korkeammat arvot tuottaa enemmän tilastollisesti johdonmukaisia ​​tuloksia mutta kestää kauemmin aikaa laskea.

Lisä- Valintaruutuja standardi elementti valinta ikkuna

· Save Muuttunut Malli tahtoa tallentaa kopion RBD muuttunut versio hankkeen samaan kansioon kuin nykyisen projektin ja liittää "_transformed" hankkeen nimi.Tämä muuttunut hanke voidaan diagnosoida yksityiskohtaisesti luotettavuus simulointi toteuttamia ABACUS.

Muita vaihtoehtoja standardi elementti valinta ikkuna

· Akun kesto Scale Factor ohjaa simulointi aikaa ja tarkkuutta suurempi arvot tuottoIngtilastollisesti yhdenmukaisia ​​tuloksia, mutta ottaen pidempään ajaa.

Huomautus

Kun ABACUS laskee simulointi aikaa se määrää hitain epäsuora yhteys Taajuus joka valittiin simuloida ja sitten "warm-up" varten aikaa (1 yli taajuus) tämän yhteyden (käynnistävät määräajoin viesti generaattorit kaikki liitännät satunnaisesti tänä lämpenemisaika, antaa heille kaikki mahdollisuudet aloittaa) ja sitten simuloida varten Run Aika-asteikko Factor kertaa Toimenpiteen yhteydessä. Tai (1 / Taajuus) lämpenemisaika + (1 / taajuus) * Akun kesto Scale Factor simulointi aikaa. Tämä on varmistaa, että kaikki kytkennät on aloitettu ennen tilastotiedot kerätään ja sitten hitain yhteys on edelleen simuloidaan ainakin kerran simulointi. Esim. Jos hitain epäsuora yhteys on Taajuus 0,033 ajan yksikköä (tai noin kerran kuukaudessa, jos aika-yksiköt ovat päivää) sitten lämpenemisaika on 30,3 ajan yksiköiden ja simulointi aika on 30,3 ajan yksikköä kertaa Ajoaika Scale Factor.

6. Klikkaa Saada valmiiksija saat Varoitusdialogi.

7. Vaihtoehtoisesti tutkia varoitukset klikkaamalla Yksityiskohdat >>.

8. Klikkaa Jatkaa.

Huomautus

Tässä vaiheessa ABACUS suorittaa diskreetti-tapahtuma simulointi arkkitehtuurin ja hetken kuluttua (ja edistystä baareja palaute) laskelma täydellinen valintaikkuna tulee näkyviin.

9. Klikkaa Kunnossatunnustaa simulointi.

Kärki

Koulutusten ja edelleen apua Performance Simulaatio katso Avolution Yhteisön .

Komponentti Ominaisuudet

Seuraavassa taulukossa vaadittavat ominaisuudet tehokkuuden arvioimiseksi. Ominaisuudet etsitään ensin Component tapauksissa, sitten Component Standardit ja jos ei löydy, oletuksena on käytetty.Nämä ominaisuudet näkyvät Ominaisuudet-ikkunassa, jossa kiinteistö panos rivi valitsimen kuvaketta ( [image] ) Kanssa tooltip Performance Input ". Muutos johonkin näistä "panos" ominaisuuksia ja erilaisia ​​rakenteellisia muutoksia arkistoon johtaa Performance simulaattori vaativat uudelleen simulointi esitettyjä Punainen koskevat Simulointi työkalurivi .

Tyyppi | Nimi | Oletusarvo | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Käyttäytyminen | b_pack | 0,0 |  | Desimaali | Väärä | Kiinteän liikenteen aika pakata sekunneissa. Tämä ominaisuus on tyypillisesti määritelty standardi tyyppi ja sitten käytetään useita komponenttiesiintymää. Esimerkiksi, CORBA on b_pack = 0,23 ms.
Käyttäytyminen | m_pack | 0,0 |  | Desimaali | Väärä | Muuttuja palvelu aika pakata sekunneissa / tavu. Tämä ominaisuus on tyypillisesti määritelty standardi tyyppi ja sitten käytetään useita komponenttiesiintymää.
Käyttäytyminen | b_unpack | 0,0 |  | Desimaali | Väärä | Kiinteän liikenteen aika purkaa sekunneissa. Tämä ominaisuus on tyypillisestimääritelty standardi tyyppi ja sitten käytetään useita komponenttiesiintymää.
Käyttäytyminen | m_unpack | 0,0 |  | Desimaali | Väärä | Muuttuja palveluaika purkaa sekunneissa / tavu. Tämä ominaisuus on tyypillisestimääritelty standardi tyyppi ja sitten käytetään useita komponenttiesiintymää.
Käyttäytyminen | Jalostus | 0,0 |  | Desimaali | Totta | Määrä suoritusaika loppuun yksi prosessi. Tämä voi olla tunnit, minuutit, päivää, toiminta jne.
Käyttäytyminen | Prosessorit | 1 |  | Kokonaisluku | Totta | Määrä Processor resursseja. Prosessorit voi olla ihmisiä, CPU, ulkopuolisten organisaatioiden jne.
Käyttäytyminen | Nopeus | 100 |  | Kokonaisluku | Totta | Prosessorin nopeutta resurssi. Eli kuinka monta kierrosta / ohjeet / toimiin se voi suorittaa yhdessä aikayksikössä. On tärkeää olla johdonmukainen yksiköitä käytetään käsittely.
Käyttäytyminen | k_bkgd | 0,0 |  | Desimaali | Väärä | Tausta käsittely komponentti. Tätä käytetään säätämään tulokset vastaamaan mihinkään kiinteään offsetteja%. Tämä voidaan todennäköisesti jättää huomiotta.

Seuraavassa taulukossa komponentin ominaisuuksia tuotos suorituskyvyn arvioijan. Joukko näiden komponentin ominaisuuksia syntyy kunkin osan jokaisesta suorituskyky ajaa.Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "Performance Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja suorituskyky simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Käyttäytyminen | Viesti Luokitus |  | Desimaali | Väärä | Viestien määrä aikayksikköä kohti kautta komponentti. Tämä on summa kaikkien osien "saapuvat ja lähtevät viestit.
Käyttäytyminen | Kaistanleveys |  | Desimaali | Väärä | Kaiken kaistanleveys kautta komponentti. Summa johtuu sekä saapuvat että lähtevät viestit.
Käyttäytyminen | Käyttö | % | Desimaali | Väärä | Hyödyntäminen komponentin. Tämä on 0% jos osa ei ole laite / jalostaja (eli se ei ole prosessorit ja nopeus ominaisuudet on määritelty edellä)

Yhteyden ominaisuudet

Seuraavassa taulukossa vaadittavat ominaisuudet tehokkuuden arvioimiseksi. Ominaisuudet etsitään ensin yhteyden tapauksissa, yhteys Standardit ja jos ei löydy, oletuksena on käytetty.Nämä ominaisuudet näkyvät Ominaisuudet-ikkunassa, jossa kiinteistö panos rivi valitsimen kuvaketta ( [image] ) Kanssa tooltip Performance Input tai Kulut / esiintyjä Input ". Muutos johonkin näistä "panos" ominaisuuksia ja erilaisia ​​rakenteellisia muutoksia arkistoon johtaa Performance simulaattori ja / tai Kustannukset simulaattori edellyttää uudelleen simulointi esitettyjä Punainen koskevat Simulointi työkalurivi .

Tyyppi

Nimi

Oletusarvo

Yksikkö

Tietotyyppi

Pakollinen

Kuvaus

Käyttäytyminen

Ystävällinen

kaksisuuntainen

[Kaksisuuntainen | yksisuuntainen]

Haku / List

Totta

Onko yhteys on kaksisuuntainen (kaksisuuntainen) tai yksisuuntainen (yksisuuntainen).

Sallitut arvot tämän ominaisuuden ovat "kaksisuuntainen" tai "yksisuuntaista".

Kaksisuuntainen tarkoittaa synkroninen pyyntö / vastaus viestit taas yksisuuntainen avulla yksittäinen asynkroninen "tapahtuma".

Käyttäytyminen

Abstraktio

epäsuora

[Välillinen | suoraan]

Haku / List

Totta

Onko yhteys on fyysinen tai looginen. Suorat yhteydet ovat fyysisiä "putkia" kahden komponenttien loogisia yhteyksiä virtaamaan pitkin.

Sallitut arvot tämän ominaisuuden ovat "suoraan" tai "välillinen".

Jos arvo on "suora" sitten yhteys ei tarvitse mitään muita ominaisuuksia (lukuun ottamatta kiinteistöjen Kind ja abstraktio).

Tiedot

L_app1

0

Kokonaisluku

Väärä

Pyyntö / tapahtuma koko tavuina.

Jokainen yhteys on tyypillisesti tietty arvo tälle. CORBA, tapahtumat ovat todella kaksisuuntaista ja aina 12 tavun tunnustaa (L_app2). Jos se on totta yksisuuntainen yhteys sitten jättää pois omaisuutta L_app2.

Tiedot

L_app2

0

Kokonaisluku

Väärä

Response / tunnustaa koko tavuina.

Jokainen yhteys on tyypillisesti tietty arvo tälle. Yksisuuntainen yhteys ei ole L_app2.

Käyttäytyminen

Taajuus

1

Desimaali

Totta

Taajuus, jolla yhteys tapahtuu.

Jokainen yhteys on tyypillisesti tietty arvo tälle. Jos kiinteistö taajuus jätetään pois silloin oletuksena on käytetty.

Käyttäytyminen

Yhteys

prosessit

[Prosessit | tukee]

Haku / List

Väärä

Yhteydet, jotka ovat "prosessit" omaisuus osoittavat, että komponentti alussa yhteys muunnetaan tulisi käsiteltyä komponentti lopussa yhteyden. Itse asiassa "lähde" ​​komponentti siirretään tulla lapseksi "upota" komponentti (liitteenä yhteydet myös "vetää" tämän liikkua).

Jos "prosessit" omaisuus on olemassa niin kaikki muut Yhteysominaisuuksien ohitetaan, paitsi vapaaehtoinen "%" omaisuus alla.

Käyttäytyminen

%

100,0

Desimaali

Väärä

Yhteydet, jotka ovat "prosessit" omaisuus (kuvattu edellä) voi mahdollisesti olla "%" omaisuus osoittamaan osuus käsittely, joka on kohdistettava määränpäähän komponentti. Tällä tavalla yhdestä lähteestä komponentti voidaan käsitellä useita määränpäitä komponentit eri%: n. % Arvoista ei tarvitse lisätä jopa 100% ja se on yksinkertaisesti käytetään mittakaavassa "käsittely" omaisuus (katso edellä) varten lähdelaite kuin se muuttuu tulla lapsi kohde komponentin.

Seuraavassa taulukossa ominaisuuksia syntyy suorituskyvyn arvioijan. Joukko näiden yhteyden ominaisuuksia syntyy jokaisen yhteyden kunkin suorituskykyä aikavälillä.Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "Performance Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja suorituskyky simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Käyttäytyminen | Kaistanleveys |  | Desimaali | Väärä | Yleinen kaistanleveys yhteyttä varten. Tämä on vain lasketaan epäsuorat yhteydet ja on olennaisesti (L_app1 + L_app2) * Siirtonopeus.
Käyttäytyminen | Kaistanleveys 1/2 |  | Desimaali | Väärä | Kaistanleveys erityisesti lähtevän (1) ja tulevan (2) viestien yhteyden. Tämä on vain lasketaan epäsuorat yhteydet ja on olennaisesti L_app1 * läpäisyä ja L_app2 * Throughput.
Käyttäytyminen | Suoritusteho |  | Desimaali | Väärä | Viestien määrä aikayksikköä kohti kautta yhteyden. Tämä todellinen arvo voidaan verrata odotettavissa / teoreettiset arvot (eli Frequency) päätellä kylläisyyttä järjestelmän.
Käyttäytyminen | Valmistunut | % | Desimaali | Väärä | Prosenttia viestejä läpäistyään käsittely yhteyden. Tämä on vain lasketaan epäsuorat yhteydet ja on Suoritusteho / Taajuus. Satunnaisesti Valmiit arvo ylittää 100%, koska satunnaisuuden viestin sukupolven johtaa hieman suurempi viesti sukupolven taajuus kuin määritelty.
Käyttäytyminen | Response (min / Ave / Max) |  | Desimaali | Väärä | Minimi / keskiarvo / suurin latenssi. Tämä on vain lasketaan epäsuorat yhteydet ja on havaittu latenssi yhteyden lähteestä pesuallas ja kaikki jonotuksen ja käsittely (ja latenssi takaisin lähteeseen jos kaksisuuntainen).

Arkkitehtuuri Ominaisuudet

Seuraavassa taulukossa koko järjestelmän arkkitehtuurin ominaisuuksia syntyy suorituskyvyn arvioijan. Yksi joukko ominaisuuksia arkkitehtuurin "yhteen" jokaiselle suorituskykyä aikavälillä.Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "Performance Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja suorituskyky simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Käyttäytyminen | Viesti Luokitus |  | Desimaali | Väärä | Viestien määrä aikayksikköä kohti kautta komponenttien arkkitehtuurin. Tämä on summa kaikkien osien "saapuvat ja lähtevät viestit.
Käyttäytyminen | Suoritusteho |  | Desimaali | Väärä | Viestien määrä aikayksikköä kohti kautta yhteydet arkkitehtuurin. Tämä on summa kaikkien epäsuorat yhteydet "myyntiä eikä tämä todellinen arvo voidaan verrata odotettavissa / teoreettiset arvot (eli Frequency) päätellä kylläisyyttä järjestelmän.
Käyttäytyminen | Kaistanleveys |  | Desimaali | Väärä | Yleinen kaistanleveys. Summa arkkitehtuurin yhteys kaistanleveyksillä.
Käyttäytyminen | Käyttö | % | Desimaali | Väärä | Hyödyntäminen kaikki komponentit. Voi olla suurempi kuin 100%, koska se on vain summa arkkitehtuurin komponentti käyttötarkoituksiin.
Käyttäytyminen | Response (min / Ave / Max) |  | Desimaali | Väärä | Minimi / keskiarvo / suurin latenssi. Summa havaittu latenssit arkkitehtuurin yhteydet lähteestä pesuallas (ja takaisin lähteeseen jos kaksisuuntainen).


Simulointi Modulaarisuus

Navigation: simulointi laitealustan> Simulators>

Simulointi Modulaarisuus

Lähetä kommentit tästä aiheesta.

Modulaarisuus simulaattori laskee useita saapuvia ja lähteviä yhteyksiä kunkin osan.

Simuloida arkkitehtuurista kannalta modulaarisuus

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Valita Analyysi| Modulaarisuus.

3. Valitse Arkkitehtuuri (t)haluat sisällyttää arvioinnissa.

Huomautus

Oletuksena ABACUS valitsee automaattisesti arkkitehtuuri (t) ja uudelleen simulointi vuoksi tarvitaan taustalla olevat rakenteelliset muutokset.Tämä korostus näkyy Punainen koskevat Simulointi työkalurivi .

4. Klikkaa Seuraava.

5. Valitse Liitäntä tyypit (t)haluat sisällyttää arvioinnissa.

6. Klikkaa Seuraava.

7. Valinnaisesti muokata ominaisuus nimet laskentatulosten.

8. Klikkaa Saada valmiiksi.

Huomautus

Tässä vaiheessa ABACUS suorittaa rakenteellinen arviointi arkkitehtuuri (t) ja lyhyen ajan kuluttua (ja edistystä baareja palaute) laskelma täydellinen valintaikkuna tulee näkyviin.

9. Klikkaa Kunnossatunnustaa arviointiin.

Kärki

Koulutusten ja edelleen apua modulaarisuus Arviointi katso Avolution Yhteisön .

Komponentti Ominaisuudet

Seuraavassa taulukossa komponentti ominaisuuksia, jotka ovat lähtönä modulaarisuus arvioijan.Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "modulaarisuus Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita, koska taustalla rakennemuutoksen arkistoon ja modulaarisuus simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Tietotyyppi | Pakollinen | Kuvaus
Modulaarisuus | Kytkimen-tuuletin (paikallinen) | Kokonaisluku | Väärä | Yhteyksien määrä että tuuletin tähän komponentti.
Modulaarisuus | Kytkentä-levittäytyä (paikallinen) | Kokonaisluku | Väärä | Yhteyksien määrä että fani pois tätä osaa.
Modulaarisuus | Kytkimen-tuuletin | Kokonaisluku | Väärä | Yhteyksien määrä että tuuletin tähän komponentti, mukaan luettuina yhteydet että tuuletin osa-komponentteja.
Modulaarisuus | Kytkentä-levittäytyä | Kokonaisluku | Väärä | Yhteyksien määrä että levittäytyä tämän komponentin, mukaan lukien yhteyksien tuuletin osa-komponentteja.


Simulointi kokonaiskustannukset (TCO)

Navigation: simulointi laitealustan> Simulators>

Simulointi kokonaiskustannukset (TCO)

Lähetä kommentit tästä aiheesta.

Tausta

Kokonaiskustannukset (TCO) on taloudellinen arvio, suunniteltu mittaamaan koko aiheutuvat elinkaarikustannukset (hankinnasta aina käytöstä poistamiseen / jätehuolto) liittyvät omaisuuden. TCO ei vain heijastaa osto-, se sisältää myös kaikki muut seikat edelleen käyttöä ja huoltoa omaisuuserän.

TCO käytetään määrittämään vaivaa ja talousarvio maksaa tarpeen käyttää järjestelmään. Yksinkertainen tapa mallinnus Abacus TCO on rikkoa tietotekninen järjestelmä alas komponentteja. Voimme sitten selvittää, kuinka paljon keskimäärin se maksaa ajaa yksi näistä komponenteista. Tämän jälkeen voisi sitten tekijä eri kustannuksia riippuen siitä, onko IT-järjestelmä on evolvable tai auki jne. Jos järjestelmä on jo käynnissä, tärkein tekijä on ylläpitokustannuksista ja ehkä kustannuksia poistaa käytöstä.

Esimerkki

Kaavio Esimerkki laskeminen

Komponentin Organisaatio tai sen standardi on nämä ominaisuudet:

· FTE= 100 000 $ / vuosi

· Tuki Ponnistus= 0.01 FTE + 0,001 FTE / v = 1000 $ + 100 $ / vuosi

· Ylläpitokustannukset= 100 $ - 10 $ / vuosi

· Pääomakustannukset= 2000 $

· Asenna Ponnistus= 2 kokoaikaista / vrk = 0,01 FTE / v = 1000 $

Komponentin Organisaatio on nämä ominaisuudet:

· Asenna Horizon= -2 Vuotta (eli asennettiin 2 vuotta ennen nykyisen)

· Elinikä= 3 vuotta

Milloin Asenna Horizon + Elinikä <= 0 , Ei ole enää ylläpitokustannukset.

Laskelmat

Laskelmat ovat seuraavat:

Huomautus

TC = kustannukset vuodessa. SE = Tuki vaivaa. MC = ylläpitokustannukset.

· Alkukustannukset = pääomakustannukset + Asenna Ponnistus= 2000 + 1000 = 3000 $

· T = -2 (aikana 1. vuosi), TC = Alkuperäinen hinta + SE + MC= 3000 + 1000 + 100 = 4100 $

· T = -1, TC = SE + MC= (1000 + 100) + (100-10) = 1190 $

· T = 0, TC = (1000 + 200) + (100-20) = 1280 $

· T = 1 (viimeinen vuosi), TC = (1000 + 300) + (100-30) = 1370 $

Kuvaaja Esimerkki laskeminen

TCO on summa kaikki nykyiset ja tulevat kustannukset, kunnes järjestelmä on poistettu käytöstä.

· T = -2 (aikana 1. vuosi), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· T = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· T = 0, TCO = 1280 + 1370 = 2650 $

· T = 1 (viimeinen vuosi), TCO = 1370 $

Avain kustannustekijät

Avain kustannustekijät on otettava huomioon laskettaessa TCO omaisuuserän Abacus ovat:

· Laitteisto hankinta- Ensimmäinen laitteiden hinta (pääomakustannukset).

· Ohjelmistot Hankinta- Ensimmäinen kustannukset lisenssin ohjelmiston (pääomakustannukset).

· Asennus- Liittyvät kustannukset alkuasetukset.

· Koulutus- Kustannukset, jotka liittyvät ulkoisiin myyjä koulutukseen käyttöönoton jälkeen.

· Tuki- Kustannukset, jotka liittyvät sisäistä tukea.

· Huolto- Kustannukset korvata tai päivittää myyjän huoltosopimuksia tarvikkeet ja katastrofi perintäkulut.

· Infrastruktuuri- Liittyvät kustannukset tukevat voimavara.

ABACUS Esimerkki edustusto Key kustannustekijöiden

Running Kustannukset simulaattori

Simuloida arkkitehtuurista kustannuksiltaan

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Valita Analyysi| Maksaa.

3. Valitse Arkkitehtuuri (t)haluat sisällyttää arvioinnissa.

Huomautus

Oletuksena ABACUS valitsee automaattisesti arkkitehtuuri (t) ja uudelleen simulointi vuoksi tarvitaan mitään olevan kiinteistön tai rakenteellisia muutoksia.Tämä korostus näkyy Punainen koskevat Simulointi työkalurivi .

4. Valitse Valuuttaavattavasta.

5. Siirrä Vuotta laskealiukusäädintä monta vuotta tarvitaan.

Huomautus

Oletuksena, jos Years laskea on yli 1 vuoden kustannukset automaattisesti lasketaan kunkin vuoden (ja kokoelma ominaisuuksia lisätty / päivitetty) ja sitten kumulatiivinen arvo koko useita vuosia myös laskettu. Jos vain kumulatiivinen arvo vaaditaan sitten poista Laske Per-Vuosi Kustannuksetkuvatun vaihtoehdon alla säästää useita kiinteistöjä hankkeeseen.

6. Valitse, jättää Laske Per-Vuosi Kustannuksettarkastetaan tai poista se.

7. Klikkaa Seuraava.

8. Vaihtoehtoisesti valitse Liitännäthaluat katsoa kustannuksia pitkin osana arviointia.

Huomautus

Käyttäminen Kustannukset | Nimeäomaisuutta yhteyksien kustannukset voi olla johtuvan komponentista kiinnitetty altaan päähän yhteyden komponenttiin kiinnitetty lähteessä(Eli kustannukset | Nimeä = "Sink lähdekoodin"), tai komponentista kiinni lähde yhteyden päättymiseen komponenttiin kiinnitetty pesuallas pää(Ts Kustannukset | Nimeä = "Lähde upota"). Lisäksi, ABACUS valitsee automaattisesti niitä yhteyksiä käyttäytyminen | Suhde = "prosesseja" tai "tukee"ja suunta syyksi on "vajoavat source". Lisäksi kustannukset ovat jaetaan Minkä tahansa käyttäytyminen | % Kulut | % Ominaisuuksia yhteyksiä, tai vaihtoehtoisesti jossa on useita yhteyksiä pesuallas monien lähteidentai lähde monille nielujaMukaan tahansa käyttäytyminen | Käsittely ominaisuuksia lähdekomponenttientai upota osia vastaavasti.

9. Klikkaa Saada valmiiksija saat Varoitusdialogi.

10. Vaihtoehtoisesti tutkia varoitukset klikkaamalla Yksityiskohdat >>.

11. Klikkaa Jatkaa.

Huomautus

Tässä vaiheessa ABACUS suorittaa toimintolaskenta arviointiin arkkitehtuuri (t) ja lyhyen ajan kuluttua (ja edistystä baareja palaute) laskelma täydellinen valintaikkuna tulee näkyviin.

12. Klikkaa Kunnossatunnustaa arviointiin.

Kärki

Koulutusten ja edelleen apua Kustannukset Simulaatio katso Avolution Yhteisön .

Komponentti ja / tai Connection Ominaisuudet

Seuraavassa taulukossa komponentti ja / tai yhteyden vaadittavat ominaisuudet arvioida kustannuksia.Nämä ominaisuudet näkyvät Ominaisuudet-ikkunassa, jossa kiinteistö panos rivi valitsimen kuvaketta ( [image] ) Kanssa tooltip Kulut Input ". Muutos johonkin näistä "panos" ominaisuuksia ja erilaisia ​​rakenteellisia muutoksia arkistoon johtaa Kustannukset simulaattori vaativat uudelleen simulointi esitettyjä Punainen koskevat Simulointi työkalurivi .

Tyyppi

Nimi

Oletusarvo

Yksikkö

Tietotyyppi

Pakollinen

Kuvaus

Maksaa

Asenna Horizon

0

vuotta

Kokonaisluku

Totta

Määrittää kun komponentti tai yhteys on ollut, tai asennetaan.

· Arvo 0 (oletus) osoittaa, että komponentti tai yhteys asennetaan kuluvana vuonna.

· Arvo on alle 0 tarkoittaa, että komponentti tai yhteys on asennettu aiemmin.

· Arvo on suurempi kuin 0 tarkoittaa, että komponentti tai yhteys asennetaan tulevaisuudessa.

Maksaa

Elinikä

0

vuotta

Kokonaisluku

Totta

Määrittää aika, jonka komponentti tai yhteys pysyy toiminnassa, minkä jälkeen se poistetaan käytöstä.

Maksaa

FTE

100.000,00

$ / Vuosi

Desimaali

Väärä

Vuotuiset kustannukset kunkin Kokoaikainen Vakituinen.

Jos tämä ominaisuus ei löydy komponentinitse tai tapauksessa yhteydet komponentin kiinnitetty altaan yhteyden päättymiseen, Se etsitään muiden komponenttien.

Ensinnäkin, kaikki "sink" komponenttis lopussa a yhteydessä "tukee" suhde komponenttiin etsitään, seuraa että "sink" komponentin vanhempis.

Jos FTE kiinteistö ei löydy, komponentin vanhempi-komponentit jälkeen etsitään. Jos FTE ei vieläkään löydy, oletusarvoa käytetään.

Huomaa: FTE on vain voimassa tulo kiinteistön osia.

Maksaa

Ylläpitokustannukset (kiinteä)

0.00

$ / Vuosi

Desimaali

Väärä

Vuosittaiset kiinteät kustannukset, komponentintai yhteys.

Maksaa

Ylläpitokustannukset (muuttuja)

0.00

$ / Vuosi

Desimaali

Väärä

Määrä, jolla kokonaiskustannukset säilyttää komponentin tai yhteys muuttuvat vuosittain.

Esimerkiksi arvo $ -500 osoittaa, että huollon kokonaiskustannuksista pienenee, $ 500. vuosittain, kun taas arvo $ 500 osoittaa, että huollon kokonaiskustannuksista kasvaa, $ 500. vuosittain.

Maksaa

Tuki vaivaa (kiinteä)

0.00

FTE / vuosi

Desimaali

Väärä

Vuosittaiset kiinteät vaivaa tukea komponentintai yhteys, Ne määritelty henkilötyövuotta.

Maksaa

Tuki vaivaa (muuttuja)

0.00

FTE / vuosi

Desimaali

Väärä

Määrä, jolla kokonaisponnisteluista tukea komponentin tai yhteys muuttuvat vuosittain.

Esimerkiksi arvo -0,01 osoittaa, että koko tuki vaivaa laskee 0,01 henkilötyövuotta vuosittain, kun taas arvo 0,01 tarkoittaa, että koko tuki vaivaa kasvaa 0,01 vuosittain.

Maksaa

Pääomakustannukset

0.00

$

Desimaali

Väärä

Alkuperäinen hankintakustannukset komponentintai yhteys.

Maksaa

Asenna Ponnistus

0.00

FTE

Desimaali

Väärä

Ponnistus, vuonna henkilötyövuotta, asentaa komponenttitai yhteys.

Seuraavassa taulukossa komponentti ja / tai yhteyden ominaisuuksia, jotka ovat lähtönä TCO arvioijan. Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip Kulut Output ". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja kustannukset simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Huomautus

Kun tuotos ominaisuuksia TCO arvioijan on oltava "pyöristetty" "Round puoli jopa" lähestymistapa (myös nimitystä "pankkiirien" pyöristys) käytetään.Tätä tekniikkaa käytetään tasaisemmin ratkaisemaan 0,5 "tie-tauot" kanssa tulos pyöristetään ylöspäin tai alaspäin lähimpään jopa tulos, eikä aina pyöristäminen ylös- tai alaspäin ja vinouttaa tulos. Toisin sanoen 2.5 pyöristetään alaspäin 2, kun taas 3,5 pyöristetään ylöspäin 4, pikemminkin kuin ne molemmat ovat joko pyöristetään 2 ja 3 tai pyöristettynä 3 ja 4.

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Maksaa | Kokonaiskustannukset omistaa - seuraavaksi x vuotta. | $ | Kokonaisluku | Väärä | Kokonaiskustannukset seuraavien xvuotta, jossa x on aika määritellyn ajettaessa arvioija. Tämä sisältää kustannukset komponentin tai yhteys on standardit, osa-komponentittai osa-yhteydet(toisin sanoen lapset) ja kaikki johtuu kustannukset.
Maksaa | Kokonaiskustannukset omistavat (paikallinen) - seuraavaksi x vuotta. | $ | Kokonaisluku | Väärä | "Paikallinen" elinkaarikustannukset seuraavien xvuotta, jos xon aika määritellyn ajettaessa arvioija. Tämä ei eisisältävät kustannukset komponentin osa-komponentit tai liitäntä n osa-yhteydet (toisin sanoenlapset) tai katsoa kustannuksia.
Maksaa | Kokonaiskustannukset omistavat (lasten) - seuraava X vuotta. | $ | Kokonaisluku | Väärä | "Lapset" elinkaarikustannukset seuraavien xvuotta, jossa x on aika määritellyn ajettaessa arvioija. Tämä vain sisältää kustannukset komponentin osa-komponentit tai liitäntä n osa-yhteydet (toisin sanoen lapset).
Maksaa | Kokonaiskustannukset omistavat (johtuvan) - seuraavaksi x vuotta. | $ | Kokonaisluku | Väärä | "Syyksi" elinkaarikustannukset seuraavien xvuotta, jossa x on aika määritellyn ajettaessa arvioija. Tämä vain sisältää kaikki johtuu kustannukset oheiskomponenttien(Joka voi tietysti ovat johtuvan kustannukset tahansa liitteenä yhteydet).

Seuraavassa taulukossa komponentti ja / tai yhteyden ominaisuuksia, jotka ovat lähtönä TCO arvioijanjos Laske Per-Year Oikeudenkäyntikulut vaihtoehto on valittu. Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip Kulut Output ". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja kustannukset simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Huomautus

Katso huomautus edellä mahdollisesta pyöristämisestä tuotoksen ominaisuuksia.

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Maksaa | Kokonaiskustannukset omistaa - vuosiX. | $ | Kokonaisluku | Väärä | Kokonaiskustannukset varten vuosi x, Jossa x on vuosittain määritetty ajettaessa arvioija. Tämä sisältää kustannukset komponentintai yhteys on standardit, osa-komponentit tai osa-yhteydet (toisin sanoen lapset) ja kaikki johtuu kustannukset.
Maksaa | Kokonaiskustannukset omistavat (paikallinen) - vuosiX. | $ | Kokonaisluku | Väärä | "Paikallinen" kokonaiskustannukset Vuodeksi x, missä xon vuosittain määritetty ajettaessa arvioija. Tämä ei eisisältävät kustannukset komponentin osa-komponentit tai liitäntä n osa-yhteydet (toisin sanoen lapset) tai katsoa kustannuksia.
Maksaa | Kokonaiskustannukset omistavat (lasten) - vuosiX. | $ | Kokonaisluku | Väärä | "Lapset" kokonaiskustannukset Vuodeksi x, Jossa x on vuosittain määritetty ajettaessa arvioija. Tämä vain sisältää kustannukset komponentin osa-komponentit tai liitäntä n osa-yhteys (toisin sanoen lapset).
Maksaa | Kokonaiskustannukset omistavat (johtuvan) - vuosiX. | $ | Kokonaisluku | Väärä | "Syyksi" kokonaiskustannukset Vuodeksi x, Jossa x on vuosittain määritetty ajettaessa arvioija. Tämä vain sisältää kaikki johtuu kustannukset oheiskomponenttien(Joka voi tietysti ovat johtuvan kustannukset tahansa liitteenä yhteydet).

Lisä- Yhteyden ominaisuudet

Seuraavassa taulukossa lisä- Yhteysominaisuuksien vaatimat TCO arvioijan. Nämä ominaisuudet näkyvät Ominaisuudet-ikkunassa, jossa kiinteistö panos rivi valitsimen kuvaketta ( [image] ) Kanssa tooltip Kulut / esiintyjä Input "tai vain" Cost Input ". Muutos johonkin näistä "panos" ominaisuuksia ja erilaisia ​​rakenteellisia muutoksia arkistoon johtaa Kustannukset ja / tai Suorituskyky simulaattori edellyttää uudelleen simulointi esitettyjä Punainen koskevat Simulointi työkalurivi .

Tyyppi | Nimi | Oletusarvo | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Maksaa | Nimeä | Vajoavat Source | [Lähde Sink | Vajoavat Lähde] | Haku / List | Totta | Jos "Lähde Sink", Tässä yhteydessä tahtoa olla olla maksaasjohtuu "pitkin" se alkaen lähdekomponentti pesuallas komponentti. Vaihtoehtoisesti, jos "Vajoavat Source", Tässä yhteydessä tahtoa ovat kustannukset johtuu "pitkin" se alkaen pesuallas komponentin lähdelaite.
Käyttäytyminen | Yhteys | tukee | [Prosessit | tukee] | Haku / List | Väärä | Jos "tukee", tässä yhteydessä tarkoittaa, että "lähde" ​​komponentti on tuettu "uppoaa" komponentti. Lisäksi, jos joko "tukee" tai "käsittely" sitten yhteys automaattisesti valitaan yhteydet ovat niiden kustannukset johtuu "pitkin" päässä pesuallas komponentin lähdelaite.
Maksaa | % | 100,0 | % | Desimaali | Väärä | Osoittaa osuus altaan komponenttien kustannuksia, jotka on kohdistettava lähdelaite. % Arvoista ei tarvitse lisätä jopa 100% ja se on yksinkertaisesti käytetään mittakaavassa "kokonaiskustannukset omistaa - seuraavaksi x vuotta." omaisuus (katso edellä) peräisin pesuallas komponentti se johtuu lähdelaite.

Arkkitehtuuri Ominaisuudet

Seuraavassa taulukossa arkkitehtuurin ominaisuuksia, jotka ovat lähtönä TCO arvioijan. Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip Kulut Output ". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja kustannukset simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Huomautus

Katso huomautus edellä mahdollisesta pyöristämisestä tuotoksen ominaisuuksia.

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Maksaa | Kokonaiskustannukset omistaa - seuraavaksi x vuotta. | $ | Kokonaisluku | Väärä | Kokonaiskustannukset koko arkkitehtuurin seuraavien X vuotta.

Seuraavassa taulukossa arkkitehtuurin ominaisuuksia, jotka ovat lähtönä TCO arvioijanjos Laske Per-Year Oikeudenkäyntikulut vaihtoehto on valittu. Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip Kulut Output ". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja kustannukset simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Huomautus

Katso huomautus edellä mahdollisesta pyöristämisestä tuotoksen ominaisuuksia.

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Maksaa | Kokonaiskustannukset omistaa - vuosiX. | $ | Kokonaisluku | Väärä | Kokonaiskustannukset varten koko arkkitehtuuri Vuodeksi xtulevaisuuteen.


Simuloidaan Luotettavuus ja käytettävyys

Navigation: simulointi laitealustan> Simulators>

Simuloidaan Luotettavuus ja käytettävyys

Lähetä kommentit tästä aiheesta.

Tausta

Luotettava Arvioija laskee luotettavuutta arkkitehtuurin käyttämällä ottokomponenttien ja yhteyksiä.

Komponenttien ja suorat yhteydet, luotettavuus perustuu Mean Time Between Failure (MTBF). Vain muuttujia laskemiseksi tarvitaan luotettavuutta arkkitehtonisia elementtejä ovat:

· MTBFarvo (vuosina);

· Mean Time To Repair (MTTR)epäonnistuminen (vuosina); ja

· Määrätyn ajan testata Luotettavuus yli.

Kaava laskennassa Luotettavuus annetaan:

Luotettavuus = -e (-y × ikä)
Jossa y = 1 ÷ MTBF

Komponenttien saatavuus ja yhteyksien perustuu MTBF ja MTTR. Huomaa, että saatavuus, toisin kuin luotettavuus, ei vaikuta ajanjakso, jonka se testataan.

Saatavuus = MTBF / (MTBF + MTTR)

Vaikka menetelmiä, jotka muuntavat Luotettavuus Lohkokaaviot(Käyttäen yksinkertaisia ​​sarja ja rinnan konstruktioita) antavat eniten tarkkoja tuloksia, nämä menetelmät tulevat erittäin Olenkäytännöllisiä kun yritämme laskea luotettavuus virkamatkoja sisällä valtava tuhansien elementtejä. Lisäksi nämä muutosjohtaminen lähestymistapoja murtaa monia yhteisiä rakenteita, kuten verkko "silmää".

Monte Carlomenetelmä mahdollistaa luotettavuus ja saatavuus järjestelmän mielivaltainen koko ja monimutkaisuus laskea. Monte Carlo -menetelmä simuloi monia skenaarioita ja ftai kukin skenaario satunnainen valtio, saatavissa tai poissa, On kullekin fyysinen elementti. Todennäköisyys tietyn elementin ollessa käytettävissä tilassa perustuu luotettavuuteen / saatavuus komponentin.

Esimerkiksi komponentti 90% saatavuus voidaan odottaa olevan käytettävissä noin 90% skenaarioita. Epäsuora yhteys luotettavuus ja saatavuus voidaan siten arvioida suhteessa satunnainen scenarios- joille polku elementtejä olemassa käytettävissä lau- lähteestä kohteeseen.

Huomautus

Koska laskeminen paikallisten luotettavuus ja saatavuus perustuu eri parametreja ja eri kaavojen (ja siten johtaa eri arvoja), on tarpeen määrittää jokaisen elementin kaksivaltiot, Yksi saatavuus, ja yksi luotettavuudelle. Laskenta saatavuus käytetään saatavuus valtio kussakin skenaariossa, kun taas laskettaessa luotettavuuden käyttää luotettavuus valtio kussakin tilanteessa.

Luotettavuus arvioija käyttää Monte Carlo tekniikka selvittää luotettavuutta tietyn arkkitehtuurin. Arkkitehtuuri käy läpi tuhansia yksittäisiä simulaatioita ja tulokset taulukoitu johtamiseksi luotettavuus toimenpide. Kuten edellä mainittiin, Monte Carlo on nopein tekniikka simuloida suuria verkkoja ja toimii monimutkaisia ​​(eli silmukkaverkkoja) rakenne.

Arvioija lähdöt neljä arvoa:

1. Mission Luotettavuusyli useita vuosia;

2. Saatavuusja arkkitehtuuri;

3. Luotettavuusja paikallinen komponenttiyli useita vuosia; ja

4. Saatavuusja paikallinen komponentti.

Arvioija toimii todennäköisyys komponentti tai liitäntä työ (toisin sanoen ei puuttuessa) ja aika korjata.

Miten standardit MTBFs ja / tai MTTRs kohdellaan

Jos elementti (komponentti tai yhteys) on standardien osoitettu MTBF ja / tai MTTR arvot, nämä arvot ovat myös käytetään laskettaessa paikallisen luotettavuuden ja saatavuus ja elementin sarjakytkennän.

Esimerkiksi, jos osa A, Joille on määrätty standardien B, C, ja Dkullakin MTBF ja MTTR arvo, Paikallinen Luotettavuus = R(A)× R(B) × R(C) × R(D), missä R = Laskettu luotettavuus (kaavalla) komponentin / standardit ja Paikallinen Hyödyttääkyky = (A)× (B) × (C) × (D), missä A = Laskettu hyödyttääkyky (kaavalla) komponentin / standardeja. Eli jos elementti on kolme standardeja kukin kanssa MTBF ja MTTR arvos, Ja myös MTBF ja MTTR arvoselementille ominaisuudet, paikallinen luotettavuus ja avilability annetaan sarjana arvo kunkin standardien ja elementin itsensä.

Toisena esimerkkinä, jos komponentti Aon määritetty standardit B, C, ja Dmutta vain standardi Bon sekä MTBF ja MTTR arvo, kun taas standardi Con vain MTBF arvo ja standardi Don vain MTTR arvo, Paikallinen Luotettavuus = R ()× R (B)× R (C), missä R= Laskettu luotettavuus (kaavalla) komponentin / standardit ja paikallinen Saatavuus = ()× (B)× (C), missä A= Laskettu saatavuus (kaavalla) komponentin / standardeja mutta laskettaessa (C), koska tavallinen vain MTBF arvo se 'haut'matching MTTR arvo (t) ja lisää kaikki MTTR arvostaa se toteaa, että Don't itsellään on vastaavia MTBF arvo, joten tässä tapauksessa se käyttäisi MTTR arvoa standardin D. Jos oli toinen standardi, sanovat E, Vain MTTR arvo sekä sitten (C)käyttäisi MTBF Ckanssa MTTR on D ja Elasketaan yhteen. Jos toinen standardi, sanovat F, Oli vain MTBF arvo sitten (F)myös käyttää MTTR on D ja Elasketaan yhteen.

Laskeminen Mission Luotettavuus

Vaikka laskettaessa paikallinen luotettavuus on kysymys käyttämällä yksinkertaista kaavaa, laskemisesta epäsuorat yhteydet (operaatio) ei ole niin helppoa, varsinkin kun meillä on monimutkainen ja laaja verkostoja lomitettu polkuja (yhteydet) ja komponentteja.

Kun koko verkon huomioon

Koska epäsuorat yhteydet eivät edusta fyysistä yhteyttä, meidän täytyy selvittää, miten lähdelaite pääsee määränpäähänsä komponentti. Ja tämä tarkoittaa tarkastellaan koko verkko ja kaikki eri tavoin (ja polkuja) meidän lähdelaite voi lentämiseen komponentti (pesuallas).

Huomautus

Niin kauan kuin on olemassa ainakin yksi täydellinenpolku lähteestä kohteeseen, operaatio onnistuuja epäsuora yhteys kutsutaan Suljettu yhteys.

Ymmärtäminen Link Matrix

Jos haluat tietää, mitkä osat / suorat yhteydet ovat yhteydessä mitä tarvitsemme artefakti nopeasti tarkistaa, onko kahden korttelin liitetään tiettyyn suuntaan. Tämä on funktio linkin matriisin. Lyhyesti, linkki matriisi on kaksiulotteinen joukko Boolen muuttujia, todetaan, onko tietty osa voi saavuttaa toisen komponentin suoraan. Sen koko on yhtä suuri kuin neliön kokonaismäärästä komponenttien verkossa.

Yksinkertainen Luotettavuus Lohkokaaviot (RBD)

Liittyvä linkki Matrix luotettavuudelle Lohkokaaviot (RBD)

Koska kaikki yhteydet ovat kaksisuuntaisia ​​(takana molempiin suuntiin), on tärkeää osata lukea linkin matriisi oikein. Luotettavuuteen arvioijan, ensimmäinen argumentti on lähde ja toinen argumentti on määränpää (pesuallas).

Siksi jos linkki matriisi (A, B) = true se tarkoittaa, että voi saada B suoraan (yksisuuntainen). B voi saada, jos vain, jos linkki matriisi (B, A) = true. Jos tämä on totta, tämä merkitsee sitä, kaksisuuntainen yhteys.

Annetussa esimerkissä edellä:

· Lähde 1 voi saavuttaa määränpäähän 0 (Lähde 1 ja kohde 0 tulos on True); ja

· Lähde 0 pääsee määränpäähän 1 (Lähde 0 ja kohde 1 tulos on True), koska yhteys 0 ja 1 on kaksisuuntaista.

· Lähde 2 ei pääse määränpää 1 (Lähde 2 ja Destination 1. antaa tuloksen epätosi), vaikka lähde 1 pääsee määränpäähän 2 (Lähde 1 ja kohde 2 tulos on True). Tämä on merkitsee sitä, että yhteys 1 ja 2 on yksisuuntaista.

Ymmärtäminen Luotettavuus lohkokaavio

Luotettavuus lohkokaavio (RBD) kiteyttää rakenteen koko kohde mallin kannalta lohkojen ja linkkejä. Jokainen lohko edustaa elementti, joka on epäonnistumisen mahdollisuus tai menestyksen mukaan linkkejä / polkuja, jotka yhdistävät heitä. Molemmat komponentit ja yhteydet voivat tulla "block" in RBD.

Esimerkki RBD Blocks ja linkit

Kuva edellä edustaa RBD esimerkki. Punaisena katkoviivana edustaa yhtä tehtävä 4 1. Huomautus miten on vain kaksi mahdollista polkuja operaation 4-1.

Harkitse reitti 4-3 arvoksi 0 1 ja reitti 4-7 1. pilkullinen lohkot 2, 5ja 6 edustavat lohkot eivät vaikuta vika / ei-epäonnistuminen tehtävän 4 1. Niitä ei pidetä ja ohitetaan. Tämä on tärkeää, koska useimmille tehtäviä tulee olemaan suuri määrä tarpeeton lohkot ei vaikuta tietyn operaation menestys. Tämä on selvempää suurissa verkoissa jolloin määrä tarpeeton lohkojen tekee simuloinnin tulokset epätarkkoja.

Nopeuttaa simulointi aikaa, ja varmistaa tarkempia tuloksia, on tarpeen abstrahoitua koko RBD ja käyttää vain osia, jotka vaikuttavat operaation menestys.

Huomautus

Yhdellä reitillä / polkua voi mennä läpi mitään osaa kahdesti.

Tässä vaiheessa voimme luoda linkin matriisi ja suorittaa Monte Carlo simulointi.

Laskeminen Arkkitehtuuri Saatavuus

Arkkitehtuuri saatavuus on todennäköisyys, että kaikki välilliset yhteydet ovat käytettävissä milloin tahansa ajankohtana. Saatavuus epäsuoran yhteyden määritetään aikana jokaisen iteraation Monte Carlo simulointi, mutta nämä epäsuorat yhteydet (tyypillisesti) tukeutuvat samoihin joukko fyysisiä elementtejä. Siksi yksinkertaisesti yhdistämällä nämä yksittäiset saatavuus olisi "tupla-count" nämä un-saatavuutta, jolloin pessimistinen kokonaisarkkitehtuurin saatavuus. Vaihtoehtoisesti yleinen arkkitehtuuri saatavuus lasketaan katsomalla jokaisen iteraation ja nähdä onko osatekijät epäsuorat yhteydet kohteita ovat käytettävissä. Ja sitten yhdistämällä nämä tulokset lopussa simulointi.

Running Luotettavuus simulaattori

Simuloida teidän arkkitehtuurin luotettavuuden

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Valita Analyysi| Luotettavuus.

3. Valitse Arkkitehtuurihaluat arvioida mistä pudotusvalikosta.

Huomautus

Oletuksena ABACUS automaattisesti valitse ensimmäinen arkkitehtuuri joka uudelleen simulointi vuoksi tarvitaan mitään olevan kiinteistön tai rakenteellisia muutoksia.Tämä korostus näkyy Punainen koskevat Simulointi työkalurivi .

4. Valitse Komponentit ja Liitännäthaluat arvioida alkaen standardi elementti valinta ikkuna käyttämällä "Näytä suorat yhteydet" ja "Näytä prosessit yhteydet 'radio-painiketta suodattimia vasemmassa alareunassa valintaikkuna, jonka avulla kanssasi valintaa.

Lisä- Valintaruutuja standardi elementti valinta ikkuna

· Save Muuttunut Malli tahtoa tallentaa kopion RBD muuttunut versio hankkeen samaan kansioon kuin nykyisen projektin ja liittää "_transformed" hankkeen nimi.Tämä muuttunut hanke voidaan diagnosoida yksityiskohtaisesti luotettavuus simulointi toteuttamia ABACUS.

Muita Radio-Painikkeetja standardi elementti valinta ikkuna

· Näytä Suorat yhteydet asettaa automaattisesti yhteyden on omaisuus- suodatin asuntotyyppi = Behaviour, Name = abstraktio ja arvo = suora.Tämä vaihtoehto on valittu oletuksena ja aids valinta "suora" yhteydet edellä kuvatulla tavalla ja alla.

· Näytä Prosessit yhteydet asettaa automaattisesti yhteyden on omaisuus- suodatin asuntotyyppi = Behaviour, Name = Suhde ja arvo = prosessit.Tämä vaihtoehto auttaa valinta "suora" yhteydet kuten edellä kuvattiin ja alla.

5. Klikkaa Seuraava.

6. Valitse Missionseli yhteydet haluat sisällyttää simuloinnissa.

7. Aseta Akun kesto Scale Factorliukusäädintä.

Huomautus

Korkeammat arvot tuottaa enemmän tilastollisesti johdonmukaisia ​​tuloksia mutta kestää kauemmin aikaa laskea.

Valintaruudut

· Show Suljettu Liitännät tahtoa suodattaa automaattisesti käytettävissä yhteydet vain ne, joilla on vähintään yksi kokonainen fyysinen polku lähdelaite määränpäähän komponentti kohti RBD valinta edellä kuvatulla tavalla.

· Näytä epäsuorat yhteydet asettaa automaattisesti yhteyden on omaisuus- suodatin asuntotyyppi = Behaviour, Name = abstraktio ja arvo = epäsuora.Tämä vaihtoehto on valittu oletuksena ja aids valinta "välillinen" tai Mission yhteydet edellä kuvatulla tavalla ja alla.

Painikkeet

· Kaikkivalitsee kaikki yhteydet.

· Käänteinenpoistaa valinnan kaikki valitun yhteydet ja valitsee kaikki ne, joita ei ole valittu.

· Ei mitäänpoistaa valinnan kaikki yhteydet.

Muut valinnat

· Akun kesto Scale Factor ohjaa simulointi aikaa ja tarkkuutta suurempi arvot tuottoIngtilastollisesti yhdenmukaisia ​​tuloksia, mutta ottaen pidempään ajaa.

Huomautus

Kun ABACUS laskee toistojen simuloida se määrää luotettavin elementti, joka ei ole täysin luotettava ja sitten simuloida varten Run Aika-asteikko Factor kertaa 1 yli epäkäytettävyys että elementti plus 1 iteraation. Tai (MTBF + MTTR) / MTTR * Akun kesto Scale Factor + 1. Tämä on varmistaa, että tämä osa ei vieläkään vähintään kerran simulointi. Esim. Jos luotettavin elementti, joka ei ole täysin luotettava on MTBF 10000 tuntia ja MTTR 8 tuntia sitten simulointi kestää (10000 + 8) / 8 = 1251 kertaa Run aika Scale Factor + 1 toistojen.

· Vuotta Simuloi Ahead määrittää, montako vuotta operaation luotettavuus lasketaan.

· Numbra Langatdetermines määrä suoritinsäiettä käyttää Monte Carlo simulointi.Tämä vaihtoehto on oletusarvoisesti vastaamaan käytettävissä olevien suorittimia / ytimet (mukaan lukien Hyper-Threading ydintä) minimoimiseksi koko simulointi aikaa.

8. Klikkaa Saada valmiiksija saat Varoitusdialogi.

9. Vaihtoehtoisesti tutkia varoitukset klikkaamalla Yksityiskohdat >>.

10. Klikkaa Jatkaa.

Huomautus

Tässä vaiheessa ABACUS suorittaa Monte-Carlosimulointi arkkitehtuurin ja hetken kuluttua (ja edistystä baareja palaute) laskelma täydellinen valintaikkuna tulee näkyviin.

11. Klikkaa Kunnossatunnustaa simulointi.

Kärki

Koulutusten ja edelleen apua Luotettavuus Simulaatio katso Avolution Yhteisön .

Komponentti ja Yhteyden ominaisuudet

Seuraavassa taulukossa komponentti ja 'suoraan'Yhteysominaisuuksien arvioimiseen tarvittavia luotettavuutta. Nämä ominaisuudet näkyvät Ominaisuudet-ikkunassa, jossa kiinteistö panos rivi valitsimen kuvaketta ( [image] ) Kanssa tooltip "Luotettavuus Input". Muutos johonkin näistä "panos" ominaisuuksia ja erilaisia ​​rakenteellisia muutoksia arkistoon johtaa Luotettavuus simulaattori vaativat uudelleen simulointi esitettyjä Punainen koskevat Simulointi työkalurivi .

Tyyppi | Nimi | Oletusarvo | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Luotettavuus | MTBF | ∞ | vuotta, viikkoja, päiviä tai tuntia | Desimaali | Totta | Mean Time Ennen Epäonnistuminen elementin. Huomautus: Arvot voidaan ilmaista yksikköinä vuotta, viikkoja, päiviä tai tunteja ja muunnetaan seuraavat '24 / 7 'saatavuus käsite seuraavasti; - 1 vuosi = 52 viikkoa tai 365 tai 8760 tuntia - 1 viikko = 7 päivää tai 168 tuntia - 1 päivä = 24 tuntia
Luotettavuus | MTTR | 0 | vuotta, viikkoja, päiviä tai tuntia | Desimaali | Totta | Mean aikaa korjata elementin. Huomautus: Arvot voidaan ilmaista yksikköinä vuotta, viikkoja, päiviä tai tunteja ja muunnetaan seuraavat '24 / 7 'saatavuus käsite seuraavasti; - 1 vuosi = 52 viikkoa tai 365 tai 8760 tuntia - 1 viikko = 7 päivää tai 168 tuntia - 1 päivä = 24 tuntia

Seuraavassa taulukossa komponentti ja 'suoraan' Yhteysominaisuuksien tuotos luotettavuutta arvioijan. Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "Luotettavuus Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja luotettavuus simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Luotettavuus | Luotettavuus - X vuotta |  | Desimaali | Väärä | Todennäköisyys, että elementti ei onnistu seuraavan X vuotta. Tämä on arvo välillä 0 ja 1.
Luotettavuus | Epäluotettavuus - X vuotta |  | Desimaali | Väärä | Todennäköisyys, että elementti epäonnistuu seuraavan x vuoden aikana. Tämä on arvo välillä 0 ja 1.
Luotettavuus | Saatavuus | % | Desimaali | Väärä | Laskettu saatavuus komponentin tai yhteyden. Tämä on arvo välillä 0% ja 100%.
Luotettavuus | Epäkäytettävyys | % | Desimaali | Väärä | Laskettu epäkäytettävyys komponentin tai yhteyden. Tämä on arvo välillä 0% ja 100%.

Seuraavassa taulukossa 'epäsuora'Yhteysominaisuuksien tuotos luotettavuutta arvioijan. Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "Luotettavuus Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja luotettavuus simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Luotettavuus | Mission Luotettavuus - x vuotta |  | Desimaali | Väärä | Todennäköisyys, että välillinen yhteys ei onnistu seuraavan X vuotta. Tämä on arvo välillä 0 ja 1.
Luotettavuus | Mission Epäluotettavuus - x vuotta |  | Desimaali | Väärä | Todennäköisyys, että välillinen yhteys epäonnistuu seuraavan X vuotta. Tämä on arvo välillä 0 ja 1.
Luotettavuus | Saatavuus | % | Desimaali | Väärä | Laskettu saatavuus epäsuora yhteys. Tämä on arvo välillä 0% ja 100%.
Luotettavuus | Epäkäytettävyys | % | Desimaali | Väärä | Laskettu epäkäytettävyys epäsuora yhteys. Tämä on arvo välillä 0% ja 100%.

Arkkitehtuuri Ominaisuudet

Seuraavassa taulukossa arkkitehtuurin ominaisuuksia tuotos luotettavuutta arvioijan. Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "Luotettavuus Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön tai rakennemuutosta arkistoon ja luotettavuus simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Luotettavuus | Saatavuus | % | Desimaali | Väärä | Kaikki käytettävissä olevat epäsuorat yhteydet, jotka on sisällytetty arviointiin. Että on, todennäköisyys, että kaikkiepäsuorat yhteydet ovat saatavilla tiettynä ajankohtana. Tämä on arvo välillä 0% ja 100%. Huomautus: Tämä ei ole kertomalla yksittäisten yhteyden saatavuus koska tämä olisi "kaksinkertainen laskenta" YK-saatavuus merkityksellisiä osia.
Luotettavuus | Epäkäytettävyys | % | Desimaali | Väärä | Epäkäytettävyys epäsuorat yhteydet, jotka on sisällytetty arviointiin. Että on, todennäköisyys, että ainakin yksivälillinen yhteys ei ole käytettävissä tietyllä ajankohtana. Tämä on arvo välillä 0% ja 100%. Huomautus: Tämä ei ole kertomalla yksilöllisestä yhteydestä unavailabilities koska tämä olisi "kaksinkertainen laskenta" YK-saatavuus merkityksellisiä osia.
Luotettavuus | Mission Luotettavuus - x vuotta |  | Desimaali | Väärä | Todennäköisyys, että kaikki välilliset yhteydet, jotka on sisällytetty Arviointia ei onnistu seuraavien xvuotta. Tämä on arvo välillä 0 ja 1. Huomautus: Tämä ei ole kertomalla yksilöllisestä yhteydestä luotettavuudet koska tämä olisi "kaksinkertainen laskenta" YK-saatavuus merkityksellisiä osia.
Luotettavuus | Mission Epäluotettavuus - x vuotta |  | Desimaali | Väärä | Todennäköisyys, että ainakin yksi epäsuoria yhteyksiä, jotka on sisällytetty arvioinnissa epäonnistuu seuraavan xvuotta. Tämä on arvo välillä 0 ja 1. Huomautus: Tämä ei ole kertomalla yksilöllisestä yhteydestä unreliabilities koska tämä olisi "kaksinkertainen laskenta" YK-saatavuus merkityksellisiä osia.


Simulointi Avoimuus

Navigation: simulointi laitealustan> Simulators>

Simulointi Avoimuus

Lähetä kommentit tästä aiheesta.

Avoimuus simulaattori määrittää, missä määrin arkkitehtuuri ja sen elementit ovat "auki", eli kyky järjestelmän käsitellä osien vaihto minimaaliset vaikutukset.

Simuloida arkkitehtuurista suhteen avoimuuden

1. Jotta sinulla on ABACUS tiedosto, Joissa näkyvät asutuilla arkkitehtuuri, avata.

2. Valitse analyysi | Avoimuus.

3. Valitse Arkkitehtuuri (t)haluat sisällyttää arvioinnissa.

Huomautus

Oletuksena ABACUS automaattisesti valitse ensimmäinen arkkitehtuuri joka uudelleen simulointi vuoksi tarvitaan mitään olevan kiinteistön tai rakenteellisia muutoksia.Tämä korostus näkyy Punainen koskevat Simulointi työkalurivi .

4. Klikkaa Saada valmiiksija saat Varoitusdialogi.

5. Vaihtoehtoisesti tutkia varoitukset klikkaamalla Yksityiskohdat >>.

6. Klikkaa Jatkaa.

Huomautus

Tässä vaiheessa ABACUS suorittaa rakenteellinen arviointi arkkitehtuuri (t) ja lyhyen ajan kuluttua (ja edistystä baareja palaute) laskelma täydellinen valintaikkuna tulee näkyviin.

7. Klikkaa Kunnossatunnustaa simulointi.

Kärki

Koulutusten ja edelleen apua julkisuudesta Arviointi katso Avolution Yhteisön .

Komponentti ja liitäntä Peruskohteet

Seuraavassa taulukossa komponentti ja liitäntä standardi ominaisuuksia arvioimiseen tarvittavia avoimuutta.Nämä ominaisuudet näkyvät Ominaisuudet-ikkunassa, jossa kiinteistö panos rivi valitsimen kuvaketta ( [image] ) Kanssa tooltip "Avoimuus Input". Muutos johonkin näistä "panos" ominaisuuksia loppusijoituslaitoksen johtaa Avoimuus simulaattori vaativat uudelleen simulointi esitettyjä Punainen koskevat Simulointi työkalurivi .

Tyyppi | Nimi | Oletusarvo | Yksikkö | Tietotyyppi | Pakollinen | Kuvaus
Avoimuus | Standardeihin Standardi Maturiteetti-järjestön taso |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Taso vastaa standardointielimen 0:Organisaation / Proprietary 1:Consortium / defacto 2:Kansallinen / Military 3:Kansainvälinen
Avoimuus | Standardeihin Standardi Maturiteetti tila |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Hyväksyntätaso saavutetaan standardointielin 0:Working / komitea Luonnos 1:Julkinen Luonnos / Balloted 2:Väliaikainen Luonnos 3:Hyväksytty
Avoimuus | Standardeihin Standardi Maturiteettipohjainen vakaus |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | On standardi todennäköisesti muuttuu? 0:Standardi vanhentunut 1:Erittäin muuttua ensi 1-2 vuotta 2:Tunnetut muutos / päivitykset olemassa olevia ominaisuuksia 3:Erittäin vakaa (ei muutosta 2 vuotta)
Avoimuus | Standardeihin Standardi Maturiteettipohjainen Myyjä Tuki |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Myyjä Tuki 0:Ei tuotteita tai myyjät tukevat standardia 1:Yksi tai enemmän myyjiä, jotka toteuttavat osan standardin 2:Enemmän kuin yksi myyjä tuotteiden kanssa, jotka panevat täytäntöön kaikki osat vakio 3:Paljon enemmän kuin yksi myyjä tuotteiden kanssa, jotka panevat täytäntöön kaikki osat vakio
Avoimuus | Standardeihin Standardi eksplisiittisyyden-dokumentaatio |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Laatu standardin asiakirjat 0: Huono 1:Oikeudenmukainen 2: Hyvä 3: Erinomainen
Avoimuus | Standardeihin Standardi eksplisiittisyyden-Standard Leveys |  |  | Kokonaisluku | Väärä | Useita ominaisuuksia. Kreivi alimmalla tasolla vakio-ominaisuuksia - Sf
Avoimuus | Standardeihin Standardi eksplisiittisyyden-Sm |  | % | Desimaali | Väärä | Prosenttiosuus kaikista useita ominaisuuksia, jotka ovat pakollisia
Avoimuus | Standardeihin Standardi eksplisiittisyyden-So |  | % | Desimaali | Väärä | Prosenttiosuus kaikista useita ominaisuuksia, jotka ovat valinnaisia
Avoimuus | Standardeihin Standardi eksplisiittisyyden-Sc |  | % | Desimaali | Väärä | Prosenttiosuus kokonaismäärästä ominaisuuksia, joita ehdollisena määritelty
Avoimuus | Profiilit-Profile dokumentaatio-dokumentaatio |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Laatu standardin asiakirjat 0: Ei mitään 1: Huono 2:Oikeudenmukainen 3: Erinomainen
Avoimuus | Profiilit-Profile dokumentaatio-tarkkuus |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Onko asiakirjat heijastavat todellista järjestelmän suunnittelu? Mikä taso profiilin ominaisuuksia käytetään järjestelmässä? 0:Ei ominaisuudet 1:Jotkin ominaisuudet 2:Useimmat ominaisuudet 3:Kaikki ominaisuudet
Avoimuus | Profiilit-Profile Documentation Eräpäivään |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Onko profiilin kypsä ja käytettävissä? 0:Ad-hoc 1:Hanke perustuu 2:Organisaation 3:Julkinen
Avoimuus | Profiilit-Profile eksplisiittisyyden-Explicit Leveys |  |  | Kokonaisluku | Väärä | Määrä vakio-ominaisuuksia määriteltyjen vaatimusten mukaisesti profiilia
Avoimuus | Profiilit-Profile eksplisiittisyyden-Pm |  | % | Desimaali | Väärä | Prosenttiosuus pakollisia ominaisuuksia profiili
Avoimuus | Profiilit-Profile eksplisiittisyyden-Po |  | % | Desimaali | Väärä | Prosenttiosuus valinnaisia ​​ominaisuuksia profiili
Avoimuus | Profiilit-Profile eksplisiittisyyden-Pc |  | % | Desimaali | Väärä | Prosenttiosuus EHDOLLISESTI MÄÄRITELLYT ominaisuuksia profiili
Avoimuus | Profiilit-Profile eksplisiittisyyden-kattavuus |  | % | Desimaali | Väärä | Prosenttiosuus vakio-ominaisuuksia erityisesti käsiteltävä profiilia
Avoimuus | Profiilit-Profile Extensions-laajennus Leveys |  |  | Kokonaisluku | Väärä | Joukko ei-vakio-ominaisuuksia määrittelemä profiilia
Avoimuus | Profiilit-Profile Extensions-kattavuus |  | % | Desimaali | Väärä | Prosenttiosuus laajennuksia yksityiskohtaisesti profiilia
Avoimuus | Tuotteet-tuote Saatavuus ja Conformance-määrä Tuotteet |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Tuotteiden tukemiseen pakollinen ominaisuudet standardin 0:Ei tuotteet tukevat standardia 1:Yksi tai useampi tuote toteuttaa osan standardin 2:Useamman kuin yhden tuotteen toteuttaa kaikki osat standardin 3:Paljon enemmän kuin yhden tuotteen toteuttaa kaikki osat standardin
Avoimuus | Tuotteet-tuote Saatavuus ja Conformance-Application Yhteensopivuus |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Mikä taso vaatimustenmukaisuuden eivät tuotteet on standardi? 0: Ei mitään 1:Väitti 2:Osoittanut 3:Sertifioitu ja Näyttöä
Avoimuus | Tuotteet-tuote Saatavuus ja Conformance poikkeamien Laatu |  | [0 | 1 | 2 | 3] | Haku / List | Väärä | Laadun vaatimustenmukaisuuden testauksesta 0: Ei mitään 1:In-house testaus tuotekehittäjä 2:Riippumaton testaus (esim. NIST) 3:Osoitettu yhteydessä merkityksellisistä tuote-

Komponentti, Yhteys ja arkkitehtuuri Ominaisuudet

Seuraavassa taulukossa komponentti, yhteys ja arkkitehtuuri ominaisuudet tuotoksen avoimuus arvioijan. Kaikki seuraavat ominaisuudet arvioida, välillä nolla (0) ja kolme (3), nolla (0) on vähiten toivottava ja kolme (3) on halutuin.Nämä ominaisuudet näkyvät Properties ikkunan ominaisuus lähtö rivinvalitsimen kuvake ( [image] ) Kanssa tooltip "Avoimuus Output". Nuoli kuvake korostetaan Punainen ( [image] ), Kun nämä ominaisuudet ovat vanhentuneita vuoksi olevan kiinteistön muutos arkistoon ja Avoimuus simulaattori vaatii uudelleen simulointi mukaan Punainen korostus Simulointi työkalurivi .

Tyyppi | Nimi | Tietotyyppi | Pakollinen | Kuvaus
Avoimuus | Avoimuus | Desimaali | Väärä | Kokonaisarvioinnin alkion avoimuus.
Avoimuus | Standardit-Standard maturiteetti | Desimaali | Väärä | Nykytilaa standardin, heijastava onko se on hyväksytty, kuinka kauan se on ollut käytössä ja miten hyvin vastaan ​​se on yhteisössä kehittäjille.
Avoimuus | Standardit-Standard eksplisiittisyyden | Desimaali | Väärä | Eksplisiittisyyden standardien, mikä potentiaali epäselvyyttä seurannut standardien
Avoimuus | Profiilit-Profile dokumentaatio | Desimaali | Väärä | Missä määrin rajapinta profiili asiakirjat on kehitetty ja onko profiili asiakirjat vastaavat varsinaisen järjestelmän suunnittelu ja / tai toteutettu järjestelmä
Avoimuus | Profiilit-Profile eksplisiittisyyden | Desimaali | Väärä | Taso Erittelyjen profiili / profile erittely
Avoimuus | Profiilit-Profile laajennukset | Desimaali | Väärä | Määrin profiilin mukainen standardi, johon se perustuu
Avoimuus | Tuotteet-tuote Saatavuus ja yhdenmukaisuus | Desimaali | Väärä | Vai ei on avoin standardi vaatimustenmukaisten tuotteiden käytettävissä käyttöaste hankkeessa


Vakioraportteja

Navigointi: raportointi laitealustan>

Vakioraportteja

Lähetä kommentit tästä aiheesta.

ABACUS " standardi raportit voit saada luettelo osista ja yhteydet yksi tai useampi arkkitehtuurit. Raportti sisältää kaikki tiedot, jotka liittyvät komponentit ja liitännät valittu, mukaan lukien tiedot komponentin tai yhteyden paikka hierarkiassa, tyyppi, standardit, kuvaus, ominaisuudet ja sen liitteistä.

Huomautus

Raportin sisällön onkonfiguroitavissakautta Raportti Valinnat valintaikkuna alla, kuitenkin, tO löytää lisää tietoa siitä, miten luoda täysin konfiguroitavissa custom raportitkäyttämällä ABACUS Custom raportit, Ole hyvä katso aihe tässä tai yhteyshenkilö Avolution tuki .

Nähdäksesi standardi kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri(T).

2. Valita Aseta| Standardi Raporttitai klikkaa Luo Standard raportti työkalurivin painiketta. Kertomus ConfigurationNäyttöön tulee.

Raportti-ikkunassa

3. Valitse Arkkitehtuurit, Komponentit ja Liitännätettä haluamasi raportti Raportti-ikkunassa.Katso Standard Element Selection tässä Uutta apua.

4. Nyt klikkaa Vaihtoehdot-painiketta ja Raportti Valinnattulee näkyviin.

Raportti Valinnat ikkuna

5. Voit valita näytettäväksi Uusi sivu kullekin Element, Tulosta Päivämäärä, Tulosta Aika, Sivunumerotja onko ovat otsikko otsikossaRaportin rastittamalla / dasta asiaa valintaruudut. Voit halutessasi myös muokata otsikko ja kirjoittaja muokkaamalla Raportin otsikko ja Kirjailija ruutuihin. Voit myös valita, mitä sisältöä näytetään mietintö rastittamalla / dasta valintaruutujen Ilmoita sisältöosan ikkunasta. Kun olet valmis, klikkaa Kunnossa.

6. Nyt klikkaa Saada valmiiksiReport-ikkunassa.

Tulkita katseltavissa raportti

Esimerkki Luotu Mietintö lyhyet selitykset

Selata raportti sivuja, klikkaa kuvakkeita [image] sijaitsevat työkalurivin ylhäällä vasemmassa yläkulmassa.

Huomautus

Sinä pystyt tallentaa kertomus eri muodoissa klikkaamalla Viedä kertomus kuvake [image] sijaitsevat sisään työkalupalkin. Voit viedä seuraavissa muodoissa: Kunnostautua, PDF ja Sana. Ole hyvä tallentaa raportin haluttuun paikkaan myöhempää käyttöä varten. Jos muutoksia tehdään arkkitehtuurin myöhemmässä vaiheessa, uusi raportti on luotu vastaamaan muutoksia.

Katso myös

Analysointi arkkitehtuurista


Mukautettuja raportteja

Navigointi: raportointi laitealustan>

Mukautettuja raportteja

Lähetä kommentit tästä aiheesta.

ABACUS "mukautettuja raportteja voit luoda täysin konfiguroitavissa mukautettuja raportteja. Raportit voivat sisältää mukautetun kuvia ja grafiikkaa sekä yksityiskohtaisesti sellaiset osat, liitoksia tai määritteitä ABACUS arkistosta sekä yksityiskohtaiset analyyttiset tulokset eri simulaatiot (mukaan lukien TCO, suorituskyky ja luotettavuus). Lisäksi raportit voivat sisältää kaavioita, kaavioita, luetteloita, matriiseja / pivot-taulukot, kartat, mittareita, Sparklinet, tiedot baareja ja indikaattoreita (esimerkiksi liikenne-valot).

Huomautus

Vaikka kuka tahansa käyttäjä voi avata olemassa olevia mukautettuja raportteja, tO configure raportit käyttäjän lisenssi tarvitsee Kertomus Configuration valmiudet. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

Nähdäksesi asiakassuhde kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri(T).

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raporttejaNäyttöön tulee.

Mukautettuja raportteja ikkuna

3. Valitsenykyinen Kertomusettä haluat näyttää alkaen Käytettävissä raportitosiosta.

4. Klikkaa Suorita raportti.Raportti avautuu Microsoft Report Viewer ja tO Liiku raportin sivuja, klikkaa kuvakkeita [image] sijaitsevat työkalurivin ylhäällä vasemmassa yläkulmassa.

Huomautus

Sinä pystyt tallentaa kertomus eri muodoissa klikkaamalla Viedä kertomus kuvake [image] sijaitsevat sisään työkalupalkin. Voit viedä seuraavissa muodoissa: Kunnostautua, PDF ja Sana. Ole hyvä tallentaa raportin haluttuun paikkaan myöhempää käyttöä varten. Jos muutoksia tehdään arkkitehtuurin myöhemmässä vaiheessa, uusi raportti on luotu vastaamaan muutoksia.

Jotta muokata arkiston tiedot, joka lähetetään a asiakassuhde kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri(T).

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raportteja ikkuna (Kuva yllä) näytetään.

Huomautus

Vaikka kuka tahansa käyttäjä voi avata olemassa olevia mukautettuja raportteja, tO configure data, joka lähetetään mukautetun raportin käyttäjän lisenssi tarvitsee Kertomus Configuration valmiudet. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

3. Valitsenykyinen Kertomusettä haluat näyttää alkaen Käytettävissä raportitosiosta.

4. Klikkaa Muokkaa aineistoja. Data Set EditorNäyttöön tulee.Tämä ikkuna näyttää keräämistä tiedoista, joita parhaillaan lähetetään mukautetun raportin. Alla olevassa esimerkissä on kolme (3);

· ApplicationProxy tietoaineistoa, joka on täsmennetään kaikki tiedot kaikkien Application komponentit "2015 Todellinen" arkkitehtuuri (mukaan lukien ominaisuudet niiden standardien ja kaikki liitteenä komponentit),

· TwoDViewProxy tietoaineistoa, joka on yhden tai useampia kaavioita jossa nimi vastaa "Application Maisema (Australia),

· TargetProxy tietoaineistoa, joka on täsmennetään kaikki tiedot kaikki tavoite yhteydet "2015 Todellinen" arkkitehtuuri (mukaan lukien liitteenä komponentit).

Data Set Editor ikkuna

Huomautus

Kyselyn nimi käytetään Tietoaineiston nimi Microsoft Report Builder (katso alla). Sisällytä kenttä määrittää, onko aineisto on joko yksittäisenä tekijänä, Kokoelma elementtejä, kaikki sarjaan tyypit, kaikki yhteystyypit, yksi tai useampi arkkitehtuurit, yksi tai useampi kaaviot tai yhden tai useamman kaaviot. Sillä "kerääminen Elements" tietosarjat suodin -painiketta tarjotaan joka napsauttaminen avaa Element Filter ikkunan, jonka avulla voit hakea useita suodattimia palata vain osia tietyiltä arkkitehtuurit, ja / tai tietyntyyppisten, ja / tai tiettyjen standardien , ja / tai kiinnitetty tiettyihin osiin, ja / tai tiettyjen Vanhemmat, ja / tai tietyissä kaaviot, ja / tai tietyissä kaaviot ja / tai tietyn Kiinteistöjen arvoihin. Muiden datajoukon tyyppejä nimi kenttä on säädetty ja käyttämällä valintapainiketta voit valita kohteen (t) mukana keräämiseen.

Huomautus

Aineistoja tallennetaanTietokokonaisuuksia tiedosto (.xml)jolla on sama nimi kuin liittyvä Ilmoita Määritelmä tiedosto (.RDL). Jos tätä tiedostoa ei ole olemassa datajoukon editorin automaattisesti kansoittavat kaikenlaisissa kysymyksissä nimiä, joita esiintyy Ilmoita Määritelmä tiedosto (.RDL)ja uusi Tietokokonaisuuksia tiedosto (.xml)luodaan kerran aa voimassa luettelo kyselyitä on määritelty.

3. Jos haluat poistaa olemassa olevan datajoukon valitse Poista Kyselypainiketta.

4. Jos haluat lisätä uuden datajoukon napsauta Lisätä uusia tietoja Setpainiketta ja määrittele tietojen asetettu kohti Huom edellä.

Jotta luoda uuden mukautetun kertomus(Mallista)

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raportteja ikkuna (Kuva yllä) näytetään.

3. Klikkaa Uusi ja valitse joko A4 - Portrait, A4- Maisema, A3 - Portrait, A3- Maisema, US Letter - Portrait, US Letter - Landscape, Yhdysvaltain Tabloid - Portrait tai Yhdysvaltain Tabloid - Landscaperiippuen mietinnön suunta ja paperikoko halutaan.

4. Selaa tallennuspaikka Report Definition tiedosto (.rdl / .rdlc) ja vastaavat Data Set (.xml) ja napsauta Tallentaa. Tämä lisää uuden mukautetun raportin Saatavilla Raportit osa Custom raportit ikkuna ja se voi avata tai muokata edellä kuvatulla tavalla.

Jotta lisätä olemassa olevaa mukautettua kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raportteja ikkuna (Kuva yllä) näytetään.

3. Klikkaa Lisätä ja selaa sijainnin Raportti Määritelmä tiedosto (.rdl / .rdlc) ja klikkaa Avata. Tämä lisää uuden mukautetun raportin Saatavilla Raportit osa Custom raportit ikkuna ja se voi avata tai muokata edellä kuvatulla tavalla.

Huomautus

Oletetaan, että sopiva tietue (.xml) on samassa paikassa kuin Ilmoita Määritelmä tiedosto.

Jotta kopioida olemassa olevaa mukautettua kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raportteja ikkuna (Kuva yllä) näytetään.

3. Valitsenykyinen Kertomusettä haluat kopioida alkaen Käytettävissä raportitosiosta.

4. Klikkaa Kopioida ja jäljennös valitun raportin (nimeltään "kopio ...") lisätään Saatavilla Raportit osa Custom raportit ikkuna ja se voi avata tai muokata edellä kuvatulla tavalla.

Huomautus

Tekemällä tämän voit luoda kopion mietinnön Raportti Määritelmä tiedosto (.rdl / .rdlc) sekä sen Matching Data Set (.xml)(Jos se on olemassa).

Jotta poistaa olemassa olevaa mukautettua kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raportteja ikkuna (Kuva yllä) näytetään.

3. Valitsenykyinen Kertomusettä haluat poistaa alkaen Käytettävissä raportitkohta ja napsauta Poistaa.

Huomautus

Kun poistat raportti se ei enää näy raportissa luetteloon. Kuitenkin, tämä ei poista kertomus Mietintö Määritelmä tiedosto (.rdl / .rdlc) tai Data Set tiedosto(.xml). Tarvittaessa poistamalla nämä tiedostot voidaan saavuttaa tiedostojärjestelmä.

Jotta nimetä olemassa olevaa mukautettua kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raportteja ikkuna (Kuva yllä) näytetään.

3. Valitsenykyinen Kertomusettä haluat nimetä vuonna Käytettävissä raportitkohta ja napsauta Nimetä uudelleen.

4. Anna uusi nimi mietinnön.

Huomautus

Sekä raportti Määritelmä tiedosto (.rdl / .rdlc) ja vastaavat Data Set (.xml) nimeksi tulee vastaavasti.

Jotta muokata suunnittelu asiakassuhde kertomus

1. Varmista, että käytössä ABACUS tiedosto auki joissa näkyvät asutuilla arkkitehtuuri.

2. Valita Aseta| Muokattu raporttitai klikkaa Luo muokattu raportti työkalurivin painiketta. Mukautettuja raportteja ikkuna (Kuva yllä) näytetään.

Huomautus

Vaikka kuka tahansa käyttäjä voi avata olemassa olevia mukautettuja raportteja, tO configure suunnittelu mukautettuja raportteja käyttäjän lisenssi tarvitsee Kertomus Configuration valmiudet. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.Lisäksi Microsoft Report Builder 3.0 tarvitaan suunnitella raportteja ja sen voi ladata ilmaiseksi osoitteesta tässä .

3. Valitsenykyinen Kertomusettä haluat näyttää alkaen Käytettävissä raportitosiosta.

4. Klikkaa Muokkaa Ilmoita.Raportti avautuu Microsoft Report Builder 3.0. Tiettyjä apua ja joitakin "Vinkit" joitakin yleisempiä tehtäviä suunnittelussa raporttien katso kohdat alla. Yleisiä ohjeita suunnitteluun raportit katso Microsoft Report Builder 3.0 ohjesivuja tässä .

Lisääminen taulukot raportin

1. Jotta sinulla on ABACUS muokattu raportti Määritelmä tiedosto (.rdl / .rdlc) auki Microsoft Report Builder 3.0.

2. Valita Aseta -välilehti nauha yläreunassa, sitten klikkaa Taulukko nappiData alueiden jakso ja valitse Lisää taulukko.

3. Nyt vedä kursoriasentoon mietinnöstä kankaalle, johon haluat sivun vasemmassa yläkulmassa taulukon sijoitettu. Klikkaa kangas. Oletuksena taulukko lisätään puskea rivi ja sitten yksityiskohtia ryhmä (ryhmä käytetään järjestää näkymä raportin aineisto). Voit poistaa ryhmän, joko poistaa rivin tai poistaa Row ryhmän ryhmittely työkalupalkin.

Kärkis

Kaavat / Expressions taulukon soluissa muokataan valitsemalla solu sitten hiiren kakkospainikkeella << Expr >> tekstiä ja valitsemalla Expression .... Lajittelu taulukon rivit tehdään valitsemalla taulukossa ja sitten lukemassa alas Muut -> SortExpressions kentän ominaisuudet -paneeli ja syöttämällä ilme. Yhteensä rivin lopussa taulukon lisätä rivin jälkeen (ja ulkopuolella) ryhmittely ja sitten käyttää seuraavan lausekkeen = Summa (Fields!Nimi.Arvo)jossa "Name" on kentän ollessa yhteensä. Soveltaa väritys sarakkeisiin käyttää "IIF" toteamus BackgroundColor omaisuutta. Voit lisätä mittari kuin solu taulukon ensimmäisessä aseta mittari soluun ja sitten pudota tietokenttiä tarvitaan mittari. Kun muokkaat korkeus ja leveydet taulukkorivit, muista valita oikea rivi, ja sitten viet hiiren osoittimen ympärillä harmaa linjat kunnes saat Nuoli ylös / alas kursori, sitten muuttaa.

Lisääminen Charts raportin

1. Jotta sinulla on ABACUS muokattu raportti Määritelmä tiedosto (.rdl / .rdlc) auki Microsoft Report Builder 3.0.

2. Valita Aseta -välilehti nauha yläreunassa, sitten klikkaa Kartoittaa nappiData alueiden jakso ja valitse Aseta Kaavio.

3. Nyt vedä kursoriasentoon mietinnöstä kankaalle, johon haluat sivun vasemmassa yläkulmassa kaavion sijoitettu. Klikkaa kangas ja sitten valitse karttate vaativat vaihtoehdoista ja napsauta Kunnossa.

Kärkis

Näyttämään omaisuuden huomautus kaavioissa, klikkaa hiiren oikealla kaavion ja valitse Näytä tiedot Tarrat, valitse yksi tarroja, on lisätty ja aseta Muut -> UseValueAsLabel False ominaisuusnäytössä ja lisää ilmaisun (esim = Fields! Name.Value) in Muut -> Label. Erityisesti kupla kaavioita; Kupla kartat näkyvät alla pistekaaviolle otsikko. Drop X-akseli kiinteistön sarjan kenttiä (tai lisätä Sarja Properties). Pudota Y-akseli kiinteistön Tietokentät (tai lisätä Sarja Properties). Käyttää kohde määrittää kuplan koko, pudota tämän huomioon Tietokentät (tai lisätä Sarja Properties). Kupla kartat ovat pysty näyttämään jos on liikaa tietoja (200 + eriä), joskus tämä saa koko kertomuksen näy. Marker Tyyppi - Aseta ympyrä. Oletuksena, kun pudottamalla kenttiä Tietokentät, se lisää ne summa()kaava, niin poista tämä. Erityisesti Pinottu kaavioita / Aikajana / Gantt kaavioita; Saat janakaaviota käyttää erilaisia ​​kaavio ja lisätä ominaisuuksia kuten korkean ja matalan arvot tietokentät. Sinulla voi olla useita "baarit" lisäämällä yhä enemmän alueita, jossa pieni arvo yksi vastaa korkea arvo toiseen. Erityisesti Piirakkakuvioita; Aggregaattia piirakkakuvioita, pudota tiedot kategorian kenttiin ja Data aloilla, lisätä kaava = CountRows (). Suodattaa pois kaikki 0-arvot (esim kustannusten kaavioita), muuten etiketit nämä näkyvät edelleen kartassa.

Käyttämällä IIF selvitys lisätä värejä taulukoita ja kaavioita

1. Jotta sinulla on ABACUS muokattu raportti Määritelmä tiedosto (.rdl / .rdlc) auki Microsoft Report Builder 3.0.

2. Hiiren kakkospainikkeella taulukon solua väri ja napsauta Kirjoita Ominaisuudet.

3. Valita Täyttää ja valitse FXpainiketta oikealla täyttöväri merkinnöissä ja Set lauseke BackgroundColor kenttään syöttää lausekkeen, esimerkiksi = IIF (Fields! InformationStatus.Value = "Säilytä", "Vaaleanvihreä", IIF (Fields! InformationStatus.Value = "Uudelleensuunnittelu", "keltainen", IIF (Fields! InformationStatus.Value = "Päivitä", "oranssi", " Lohi"))). Tämä muuttaa taustaväri vaaleanvihreä kunkin sisältävän solun status "Säilytä", keltainen kunkin sisältävän solun status "Uudelleensuunnittelu", Orange kullekin solulle, joka sisältää asema Päivitä ja minkä tahansa muun tilan arvo on värillinen in 'Salmon ".

Huomautus

Värit voidaan lisätä kaavioita valitsemalla sarja kartalla ja asettamalla sitten Ulkoasu -> Color omaisuuden (tai kupla kaavioita Ulkoasu -> Marker -> Color omaisuus) lauseke samanlainen kuin edellä esimerkin.

Asiat pitää mielessä suunniteltaessa mukautettuja raportteja

· Koska kaikki ominaisuudet lukuun ottamatta Integer lähetetään merkkijonon Abacus raportti katsojan jos haluat tehdä mitään "ilmaisuja" niiden kanssa (kuten jakaa yksi ominaisuus toisella tai lajitella) sinun täytyy muuntaa ne desimaaleja tai Date jne tausta , Tämä artikkeli on hyvä referenssi. Esim. = CDATE (Fields! LifecycleEndDate.Value) Huomautus: Varmista, että mietintö kieli on asetettu fi-FI (jäljempänä esitetyllä tavalla) hyväksyä pp / kk / vvvv koska se odottaa kk / pp / vvvv oletuksena ja vastaavasti 31.7.2011 epäonnistuu muuntaminen. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Jos huomaat, että olet kamppailee pitää kaikki taulukoita ja kaavioita yhdellä sivulla, On olemassa muutamia tärkeimmät tapoja hallita dokumentin tilaa:

· Page Break - Varmista, että tämä kattaus on pois jokaisen taulukon, jonka haluat olla samalla sivulla.

· Pidä yhdessä - Varmista tämä kattaus pätee kaikkiin taulukon, jonka haluat olla samalla sivulla.

· Kun liikkuvat asiat ympärillä, on helpompi loitontaa käyttämällä ohjaus oikeassa alareunassa sivun ja sitten monen valita kohteita ja vetää

· Kuvalle taulukon rivin, varmista, että "Koko" | "Mitoitus" ominaisuus asetetaan "Fit" muuten kuva voi olla liian suuri, tai se on huonosti venytetään.

· Jotta Toistan otsikkorivi taulukon jokaisella sivullaRaportin:

1. Avaa Advanced Mode yhtymien ruudussa. (Klikkaa nuolta Column Ryhmät ja valitse Edistynyt tila.)

2. Vuonna riviryhmien alue (ei sarake ryhmät), klikkaa staattinen ryhmä, jossa korostetaan vastaava oppikirja vuonna tablix. Klikkaa läpi kunkin Staattinen ryhmä kunnes se korostaa vasemmanpuoleisimman sarakkeen otsikkoa. Tämä on yleensä ensimmäinen pysyvä ryhmä listattu.

3. Ominaisuudet-ikkunassa, aseta RepeatOnNewPage omaisuutta True.

4. Varmista, että KeepWithGroup omaisuus on asetettu jälkeen.

· Muuta kieliasetuksetRaportti ominaisuuksia vastaamaan tiedostomuotoja tarvitset, esimerkiksi fi-FI tuottaa UK päiväyksen muoto (pp / kk / vvvv).

Katso myös

Analysointi arkkitehtuurista


Julkaise Web

Navigointi: raportointi laitealustan>

Julkaise Web

Lähetä kommentit tästä aiheesta.

ABACUS "Julkaise Web -toiminnon avulla arkkitehtonisia malleja katsottavaksi suojatun verkkosivuston. Arkkitehtuurit viedään HTML-muodossa ja on suunniteltu vastaamaan ulkoasua Explorer ABACUS. Näkymät (mukaan lukien Luettelot, kaaviot, 3D ja kaaviot) Myös viedään muodoissa jota voidaan tarkastella Internet-selaimella.

Huomautus

Tällä hetkellä Näkökulmia ja matriisit ei julkisteta.

Julkaista arkkitehtuurin malleja Web

1. Varmista sinulla on asiaa ABACUS tiedostoauki, sisältävät asutuilla arkkitehtuuriettä haluat julkaista Web.

2. Valita Tiedosto| Julkaista....

3. Julkaise Web Configurationtulee näkyviin.

Julkaise Web Configuration

4. Oletuksena kaikki osat malli valitaan myös Puunäkymä, Standardit, Tyypit, mallit ja arkkitehtuuri (s). Poista kaikki osat et halua julkaista verkossa, mukaan lukien yksittäiset näkemykset architecture (s).

Kärki

Jos haluat piilottaa yksittäisiä komponentteja, yhteydet ja / tai niiden ominaisuudet on suositeltavaa pääkäyttäjä luo "julkinen rooli käyttäen ABACUS rooli-pohjainen käyttöliittymä ominaisuus ja sitten poistaa Lue lupaa näiden komponenttien tyyppejä, yhteystyypit ja / tai ominaisuuksia, jotka he eivät halua julkaista. Sitten käyttäjä, kirjaudu sisään kyseisen roolin ja julkaista web koska Abacus julkaista vain osia, jotka on Lue luvan asetettu rooli. Lisäksi käyttäjät voivat automaattisesti julkaista komentoriviltä kuvatulla tässä .

Huomautus

Voit valita kaikki osat näkyvät klikkaamalla Kaikkipainike tai kääntää valintasi klikkaamalla Käänteinenpainiketta. Voit myös klikata Ei mitäänpainike tyhjentää valintasi.

Huomautus

Jos sinä poista Puunäkymä vaihtoehtoniin ei puu runko (katso alla) julkaistaan. Vastaavasti, sinun pitäisi valita aloitussivu mukaan vaihe 6 alle tai julkaistuaan sinun täytyy muokata joko huipputason; ) index.htmltiedosto muuttamalla "runko src =" mainPage.html "name =" element_details "" rivi suoraan linkittää asiaa html-sivun sisällön kansio tai, b) mainPage.htmltarjoamalla hyperlinkin tai ohjata asiaa html-sivun sisältö kansioon.

5. Napsauta Vaihtoehto -painiketta ja seuraavat Kustantaja Vaihtoehdotvalintaikkuna tulee näkyviin.

Julkaistaer Valinnat

6. Svalitsee 3D, Kaavioja kaaviot muodoissa ja näkyykö osaston Kuvaus tai Ominaisuudet sillä maisemat käytettävissä olevista vaihtoehdoista (katso alla oleva huomautus kommentteja eri muodoissa).

7. Jos haluat asettaa aloitussivuksi julkaistun mallin tiettyyn näkymä tarkista Käytä Näytä aloitussivuvaihtoehto ja selaa näkymä kautta "..." -painiketta joka tulee käytössä.

Huomautus

Vain näkemykset valittu Alueet § kohti Vaihe 4 edellä ovat käytettävissä sopia aloitussivu.

8. Jos haluat saada palautetta tietyillä sivuilla julkaistussa mallissa varmista Sähköposti Palautevaihtoehto on valittu, Syötä sähköpostiosoite Sähköpostiosoite tekstilaatikkoja muokata Sähköposti Bodyjakso tarvittaessa. Jos et halua antaa palautetta ja poista Sähköposti Palautevaihtoehto ja jätä oppikirja tyhjä.

9. Klikkaa Kunnossapainiketta.

10. Klikkaa Selaillapainiketta.

11. Selaa tiedostojatulee näkyviin.

12. Valitse sijainti haluat tallentaa huipputason HTML-tiedosto (ja kaikki automaattisesti tiedostoja).

Huomautus

Se on hyvä idea luoda tiettyyn kansioon (tyypillisesti nimeltään "Julkaistu") käyttäen Luo uusi kansioalareunassa valintaikkunan tallentaa huipputason HTML-tiedosto ja kaikki automaattisesti tiedostoja.

13. Klikkaa Kunnossapainiketta.

14. Kansion polku näkyy vuonna Hakemisto tekstilaatikko.

15. Klikkaa Saada valmiiksipainiketta.

- tai -

15. Kirjoita kansion polku Hakemistooppikirja, johon haluat tallentaa huipputason HTML-tiedosto (ja kaikki automaattisesti tiedostoja).

16. Klikkaa Saada valmiiksipainiketta.

Huomautus

Vientiä Kaaviothyvin satunnaisesti epäonnistuu, useimmiten kun tietokone on muisti (normaalisti käytettäessä erittäin suuria tiedostoja). Epäonnistui vienti tulee yritetään kerran. Tulee yksi varoituksen epäonnistunut ensimmäinen yritys, ja toinen varoitus, jos uudelleen yritys epäonnistuu. Siksi, jos vain varoitukset ovat "ensimmäinen yritys epäonnistui" niitä, julkaista oli onnistunut. Jos uudelleen epäonnistuu yrittää julkaista pienempi osa tiedoston tai vapauttaa joitakin järjestelmän muistia.

Tallennetaan HTML-tiedoston (t) voi nyt olla näkymät sen sijainti tai kopioida suojattua kotisivuilta.

Julkaise Web Internet Explorer10

Kaikki hyperlinkkejä luotuja alkuperäinen malli on itsepintaisesti julkaisi mallin ja klikkaamalla linkkiä seuraa linkkiä määränpäähänsä (jos se on julkaistu). Lisäksi kaikki elementit julkaistu kaavioita, joita ei jo linkitetty alkuperäisen mallin tahtoa linkitetään takaisin vastaavien elementtien Puunäkymä (jos se on julkaistu) ja klikkaamalla osa julkaistaan ​​kaavion painopiste siirtyy takaisin asiaankuuluvat sijainti Tree. Tämä ominaisuus on samanlainen "Näytä Resurssienhallinnassa" hiiren kakkospainikkeella ominaisuus ABACUS.

Huomautus

Avolution voimakkaasti suosittelee seuraavia ohjelmistoja ja tiedostomuotoja olisi käytettävä täysimääräisesti hyödyntää Julkaise Web toiminnot Abacus:

1. Internet Explorer (80,0 ja yli)nähdäkseen julkaistun Explorerissa Näytä. Mozilla Firefox (30,0 tai uudempi)on myös suositeltavaa ja täysin tuettuKuitenkin, jos käytät suositeltua SVG-muodossa kaaviot sitten Firefox 9 voit käyttää vain natiivi SVG Viewer tukea, joka valitettavasti ei salli zoomausta tai panoroinnin.

2. Adobe SVG Viewer 3.0 kytkeä (Ladattavissa tässä ) ja SVGtiedostomuoto julkaistu kaaviot. SVG-tiedosto muoto kaavioton suositeltavaa, koska; SVG on vektori-pohjainen kuvan muodossa, ja siksi se on "tappio-vähemmän" ja näyttää paljon paremmin tiettynä zoomaustasolla kuin minkään muun formaatteja, SVG voidaan tuoda MS Visio, SVG voidaan zoomata tahansa tasolla tai päätöslauselma , SVG on linkit takaisin puu näkymä yhteydet (ei vain komponentit), SVG aina tulostaa paremmalla päätöslauselman, ja, SVG on noin puolet tiedostokoko muissa muodoissa. PNG on seuraava suositus, mutta koska se on rasterised muoto tietyillä zoomaustasoilla selkeyttä mielestä katoaa ja klikkaamalla yhteydet kaavioiden ei hyppää takaisin asiaan sijainti puussa. BMP on lannistunut, kun se on "häviötöntä" alustaa tiedostokoko on 100x kuin muut formaatit ja 20MB kuvat eivät ole epätavallisia.

Kompromissi SVG on, että SVG katsoja täytyy asentaa ja sinun täytyy varmista, että .svg kuva / SVG + xml lisätään www-palvelimen MIME-tyypit. Asennuksen jälkeen SVG Viewer Microsoft Internet Explorer pyytää sinua hyväksymään katsojan lisenssisopimus ja sitten se pitäisi toimia hyvin. Ja vaikkaMozilla Firefox tukee SVG-tiedostoja natiivisti, Adobe plugin on silti suositeltavaapystyä zoomata kaaviot jos käytät Firefoxia 8 tai aikaisemmin (jos käytät Firefoxia 9 et voi poistaa syntyperäinen SVG katsoja). Kun asennus Adobe plugin on ajettu, seuraava vaihetta tarvitaan käyttää sitä Firefoxissa:

· Avata firefox ja kirjoita "about: config" (ilman lainausmerkkejä) osaksi osoitepalkkiin.

· Selaa alaspäin ja löytää omaisuus svg.enabled(Jos käytät Firefox 9 sitten natiivi SVG katselu voi olla pois käytöstä, ja tämä ominaisuus ei ole olemassa). Tuplaklikkaa sitä poistaa sen.

· Nyt löytää hakemisto jossa SVG laajennuksen on asennettu (esim C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Kopioi tiedostot NPSVG3.dll ja NPSVG3zip ja liittää ne firefox plugins hakemistoon (esim C: \ Program Files \ Mozilla Firefox \ plugins)

· Sulkea kaikki esiintymät firefox

3. Avolution n ABACUS 3D Viewer (3.1 tai uudempi) ja Avolution n .abacus3Dtiedostomuoto julkaistaan ​​3D-näkymät. Samalla kun Cortona VRML Client plug-in (2.0 tai uudempi)on saatavilla tarkastella VRML versiot julkaistaan ​​näkemykset se ei ole ilmainen kaupalliseen käyttöön ja vaatii vielä client-side asennus. ABACUS 3D Viewer on monipuolinen kuin mikään VRML katsojan ja on vapaasti ladattavissa tässä . Kummassakin tapauksessa varmista lisätä .vrml X-maailma / X-VRML ja .abacus3d application / oktetti-stream web-palvelimen MIME-tyypit.

4. PNGtiedostomuoto julkaistu Chart näkemyksiä. PNG kuvaformaatti varten karttanäkymät on suositeltavaa, koska kun se on rasterised muoto ja siellä on "tappio" kompromissi tiedostokoon ja kaavio selkeys on tyypillisesti paras. BMP on lannistunut, kun se on "häviötöntä" alustaa tiedoston koko on 20x kuin muut formaatit ja 2Mb kaavioita eivät ole epätavallisia.

Jos haluat vaihtaa ulkoasua web-sivuja, voit muokata aloitussivun tiedosto nimeltä mainPage.html ja tyylisivut nimeltä abacus.css. Löydät nämä tiedostot samaan kansioon, johon valitsit tallentaa ylätason HTML-tiedosto. Lisätietoja rakenteesta ja räätälöinti julkaistu lähdön katso seuraavaa osaa.

Rakenne Abacus julkaistu malleja

ABACUS julkaistu malli rakenne on seuraava:

1. Ylimmän tason kansio sisältää useita tiedostoja ja olettaen, että kaikki vaihtoehdot ovat mukana ABACUS Julkaise Web Mallit dialogi se sisältää indeksi.htmltiedosto koostuu kolmesta kuvaa; treeView.html, findNode.html ja mainPage.html ja sitten shortcutError.html sivu. TreeView.html on asuttu tree.js, tree_items.js ja tree_tpl.js JavaScript-tiedostot alla ovat kansio (käsitellään jäljempänä) ja jäljittelee Explorer puu ABACUS. FindNode.html on powered by find.js JavaScript-tiedosto alla ovat kansio (käsitellään jäljempänä) ja se etsii puun oksat eikä vain näkyvä solmut. Thän mainPage.html on staattinen HTML-sivu, joka voidaan räätälöidä yritysten logoja ja vastaaviaja näytetään ellei aloitussivu valitaan julkaistessaan.Ja lopuksi, shortcutError.html sivu on aloitussivun särkyneiden pikakuvakkeet puusta takia sopiva sivuja ei julkaista.

Kärki

Voit ohittaa mainPage.html kokonaan vuoteen valitsevat käyttää aloitussivulle julkaistessaan tai muuttamalla index.html tiedoston osoittamaan suoraan tietyn näkymän (esimerkiksi) muokkaamalla runko src = "mainPage.html" linja osoittamaan suoraan ensimmäinen näkymä ensimmäisessä arkkitehtuuri, tyypillisesti "puitteet" kaavio.

2. Huipputason includekansio sisältääIng eri javascript (.js) ja CSS-tyylisivun (.css) käyttämät tiedostot Html tiedostot koko julkaistu malli.

3. Ylimmän tason sisältö kansiossa, aakkosjärjestyksessä;

· '3D Näkymät' kansionumeroituHTML-sivun ja VRML tai abacus3d tiedoston jokaiselle julkaistu 3D näkemyksiä. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· Arkkitehtuurit kansio numeroidun HTML sivulla kunkin arkkitehtuuria, joka julkaistiin. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· A Luettelot kansio, jossa numeroitu HTML-sivun jokaisen ilmestyvät luettelot. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· A Kaavioita kansionumeroituHTML-sivun ja PNG, JPG jne tiedosto kunkin julkaistu Chart näkemyksiä. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· A Komponentit sisältävän kansionnumeroituHTML-sivu kunkin julkaistu komponenttien. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· A Liitännät sisältävän kansionnumeroituHTML-sivu kunkin julkaistu yhteyksien. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· A Kaaviot sisältävän kansionnumeroituHTML-sivun ja PNG, SVG jne tiedosto kunkin julkaistu kaaviot. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· kuvakkeet sub-kansio kanssa erilaisia ​​kuvia käytetään koko julkaistu malli.

· A Standardit sub-kansionumeroituHTML-sivun mitään standarditettä julkaistiin. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

· A Mallit sub-kansio kokoelma numeroitu alikansioita kunkin mallin julkaissut hankkeesta. Kunkin osa-kansio on Komponentit ja-kansio ja näissä on numeroitu HTML-sivun kunkin osan ja yhteyden mallin. Katso huomautus alla tietoja kansio / tiedosto numerointi.

· A Tyypit sub-kansio Component jaLiitäntä osa-kansioitanumeroituHTML-sivun mistään Komponentti jaYhteys Tyypit, jotka julkistettiinja kokoelma numeroitu alikansioita kunkin julkaisi hankkeesta, joka sisältää HTML-sivun jokaisen rajoitukset. Katso huomautus alla tietoja kansio / tiedosto numerointi.

· A Näkymäkohtas sub-kansio janumeroituHTML-sivun mille tahansa Viewkohtas, jotka julkistettiin. Katso huomautus alla tietoja kuvanumerointi järjestelmän.

Huomautus

Numerointi HTML-sivujen (ja joissakin tapauksissa kuvatiedostot) vastaa ainutlaatuinen ID kullekin loppusijoituslaitoksen esine, joka oli määrittää, kun se oli luotusisällä ABACUS (kutsutaan EEIDs). Tämä tunnus ei muuta niin kuten kaaviot, tyypit, komponentit jne olemme päivitetty ne tahtoasäilyttävät saman ID kuin ennen. Joka tapauksessa, asiaa arkistosta esinenimi voi löytyä lähellä alkua HTML-sivun välillä ... HTML-tunnisteita.

Rajoittamalla pääsyä tietyille Sivut / Views IIS

Jos käytät IIS Web-palvelin julkaistun mallin, saatat pystyä rajoittamaan tiettyjen sivujen / näkemyksiä hyödyntäen menetelmä alla:

1. Luo verkkosivuilla IIS (toinen jos on olemassa yksi et halua häiritä).

2. Muuta Properties> Directory Security-> Anonyymi - poista anonyymi pääsy, ja käyttö todennettu pääsy.

3. Jos tämä on vain normaali palvelin ilman verkkotunnuksen komplikaatioita jne, sinun kannattaa käyttää "integroitu Windows-todennus" vaihtoehto, joka sitten käyttää palvelimen koneita paikalliset käyttäjät / kirjautumiset kuten autentikointi, ja vain lisätä käyttäjiä paikalliseen tietokoneeseen (varo että olet tietoinen seurauksista, turvallisuus viisas, lisätä uusia käyttäjiä laitteen, esimerkiksi sen mukaan, onko etäkäyttö on asennusohjelma kone, jne).

4. Lisää käyttöoikeudet tiettyjä tiedostoja / kansioita tarpeen mukaan. Napsauta hiiren kakkospainikkeella yksittäisiä tiedostoja / kansioita -> Ominaisuudet ja säädä suojausoikeudet normaaliin tapaan tiedostoja / kansioita.

Tämä voi vaihdella mikä versio IIS ja mitä erityisiä Windows-käyttöjärjestelmä on palvelimella, ja onko sinulla verkkotunnuksen tai muu eri asetukset.

Katso myös

Populating arkkitehtuurista | Analysointi arkkitehtuurista


Vieminen Arkkitehtuuri

Navigointi: raportointi laitealustan>

Vieminen Arkkitehtuuri

Lähetä kommentit tästä aiheesta.

ABACUS voit ettäviedä arkkitehtuurin Mdb (Microsoft Access), MS SQL Server, .abacus (ABACUS tiedosto), ja .xls (Microsoft Excel) -muodossa. Voit myös viedä kaavios PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF ja BMP-muodossa ja raportit .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) ja .rtf (Rich Text Format) muodossa. Näin voit analysoida ja tarkastella arkkitehtuuri ja sen tiedot haluamallasi tavalla.

Viedä arkkitehtuuria Mdb (Microsoft Access)

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Klikkaa Tiedostovalikko.

3. Valita Viedä, ja sitten MDB.

4. Huomioi varoitus- ja valitse Kunnossa.

5. Kirjoita tiedoston nimi.

6. Napsauta TallentaaPainiketta.

Huomautus

Vienti muoto Mdb tietokanta on erityisiä ABACUS ja kaikki rakenteen muutokset johtavat kyvyttömyys uudelleen tuonti. Ole hyvä ja katso Asuttavat MS Access on kuvaus MS Access skeema.

Viedä arkkitehtuuria MS SQL Server

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Klikkaa Tiedostovalikko.

3. Valita Viedä, ja sitten MS SQL Server.

4. Vuonna avautuvassa valitse Vie Tyhjä MDB ...painiketta ja tuoda tämä osaksi MS SQL Server-tietokanta palvelimeen.

5. Täytä tietokannan tiedot ja yhteysmerkkijono.

6. Napsauta ViedäPainiketta.

Huomautus

Vienti muoto MS SQL Servertietokanta on erityisiä ABACUS ja kaikki rakenteen muutokset johtavat kyvyttömyys uudelleen tuonti. Ole hyvä ja katso Asuttavat MS Access on kuvaus tietokantakaavan.

Viedä arkkitehtuuria .xls (Excel-tiedosto)

1. Varmista, että käytössä ABACUS tiedosto auki , tutkimusmatkailija näytetään , Ja arkkitehtuuri lisätty .

2. Varmista, että käytössä Excel Tuo / Vie määritystiedosto on määritelty.

3. Hiiren kakkospainikkeellaon arkkitehtuurin mallisi tai mitään osaa Komponentitsolmu (tietyssä arkkitehtuuri) haluat viedä Excel määritystiedosto.

4. Valita Viedä | Jotta Excel ... valikosta.

5. Valitse Excel Tuo / Vie määritystiedosto käyttääNäyttöön tulee.

6. Valitse kyseinen kokoonpano tiedosto arkkitehtuurin malli ja napsauta Avatapainiketta.

7. Jos ei automaattisesti tehnyt niin, kartta huipputason komponenttien nykyisen arkkitehtuurin Set ID(Kuten edellä on määritelty) ja klikkaa Viedä....

Esimerkki Ylätason Component kartoitus

8. Valitse sijainti ja tiedostonimi oman Excel-tiedoston ja valitse Tallentaapainiketta.

Viedä arkkitehtuuria .abacus (ABACUS tiedosto)

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Hiiren kakkospainikkeellaon Arkkitehtuuri solmu, kaikki arkkitehtuuri teidän mallia tai mitään osaa Components puu.

3. Valita Vienti | Jotta Tiedoston ...valikosta.

4. Valitse sijainti ja tiedostonimi ja napsauta Tallentaapainiketta.

Huomautus

Voit tuoda ABACUS tiedosto takaisin ABACUS suorittamalla vaiheet 1-2edellä ja valitsemalla Tuonti | Alkaen Tiedoston .... Kun olet valinnut tiedoston, jonka haluat tuoda, sinulta kysytään, miten haluat tuoda standardit ja tyypit. Voit tuoda standardeja ja tyyppejä kuin joko uusia tai yhdistää standardeja ja tyypit. Oletusasetus on normeja ja tyypit yhdistetään nykyisiä standardeja ja tyyppeihin, jos ne ovat jo olemassa teidän hanke.

Viedä arkkitehtuurin .xml

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Hiiren kakkospainikkeellaon Arkkitehtuuri solmu, kaikki arkkitehtuuri teidän mallia tai mitään osaa Component puu.

3. Valita Vienti | Jotta XML ...valikosta. Vaihtoehtoisesti voit klikata valikosta Tiedosto| Viedä| Jotta XML ...

4. Valitse sijainti ja tiedostonimi ja napsauta Tallentaapainiketta.

Huomautus

Voit tuoda XML-tiedoston takaisin ABACUS suorittamalla vaiheet 1-2edellä ja valitsemalla Tuonti | Alkaen XML .... Kun olet valinnut XML-tiedosto, jonka haluat tuoda, sinulta kysytään, miten haluat tuoda standardit ja tyypit. Voit tuoda standardeja ja tyyppejä kuin joko uusia tai yhdistää standardeja ja tyypit. Oletusasetus on normeja ja tyypit yhdistetään nykyisiä standardeja ja tyyppeihin, jos ne ovat jo olemassa teidän hanke.

Viedä kaavio PNG, JPG, SVG, TIFF, GIF tai BMP

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Avaa kaaviohaluat viedä.

3. Klikkaa Vie Diagrampainiketta Kaavio työkalurivi.

4. Vie Kaavioikkuna avautuu.

5. Valitse Selaillapainiketta tallentaaksesi visualisointi haluttuun paikkaan.

6. Valitse Save as typealasvetovalikosta valita tiedostotyypin.

7. Napsauta Tallentaapainiketta.

Viedä raportin .pdf (Adobe Acrobat), .xls (Microsoft Excel) tai.doc (Microsoft Word)

1. Varmista, että käytössä ABACUS tiedosto avata.

2. Luo kertomus haluat viedä.

3. Klikkaa Viedä-painiketta raportit työkalupalkin.

4. Valita Excel, PDF- tai Wordalkaen pudotusvalikosta.

5. Odota hetki, kun raportti vienti.

6. Valitse sijainti ja tiedostonimi ja napsauta Tallentaapainiketta.


Työskentely Enterprise Server

Navigointi: Hallinto>

Työskentely Enterprise Server

Lähetä kommentit tästä aiheesta.

ABACUS Laitos Palvelin on sekä "ei-lukitus" yhteistyöhön perustuvan lähestymistavan, mutta "irti" yksi myös. ABACUS on "ei-lukitus", koska se ei pakottaa tiedosto lukita yksi käyttäjä se päivitetään. Jokaisella käyttäjällä on oma paikallinen kopio tiedostosta, ja koska ne tehdä muutoksia ja tallentaa tiedoston, nämä muutokset kirjataan ja tallennetaan, kun käyttäjä haluaa sitoutua ne palvelimelle.

ABACUS on "katkaistu" siinä mielessä, että sinun ei tarvitse olla yhteydessä palvelimeen tai tarvitset verkkoon pääsy työskennellessään tiedosto. ABACUS vain vaatii pääsyä palvelimelle suoritettaessa toimintoja, kuten luoda tiedoston, tai suorittaa kassalle, yhdessä toimintansa luodun tiedoston - päivitys, toteuttavat tai katselu loki menneisyyden sitoutuu. Palvelimelle ei tarvitse työskennellä tiedosto, ja muutokset eivät ole lähetetään palvelimelle heti (tämän avulla voit helposti hylätä muutokset, jos teet virheen). Kun tallennat tiedoston, olet "vain" tallentamatta kopioida paikallisesti - se on vasta sitoudut että paikallinen muutokset (muutokset edellisestä sitoutua), lähetetään palvelimelle.

Uuden Enterprise tiedosto

Voit luoda uuden Enterprise tiedoston, valitse Tiedosto| Uusi ...ja valitse yksi ensimmäisistä kahdesta vaihtoehdosta alla Enterprise Malli osa Uusi projekti -valintataulussa (Eli joko tyhjä Laitos tiedoston, tai luoda yksi olemassa ABACUS tiedosto). Kolmas vaihtoehto on "kassalle" Enterprise tiedosto joku muu on jo luonut, tämä katetaan seuraavassa osassa.

Kun haluat luoda uuden Enterprise tiedoston, sinulle annetaan dialogi, jonka avulla voit selata missä arkistopalvelimelle haluat tallentaa tiedoston. Se on myös nykyisen tiedoston polku ja nimi tuli ylös alkuun jos valitsit "alkaen nykyistä mallia" maasta Uusi projekti -valintataulussa ja mukana tiedosto.

URL: Tämä on URL-osoite arkistopalvelimelle jossa ABACUS Enterprise tiedostot tallennetaan. Sinun pitäisi kysyä henkilö, joka hallitsee palvelimen mitä tämän URL-osoitteen pitäisi olla.

Yllä oleva kuva näyttää arkiston neljä (4) nykyisten ABACUS Laitos hankkeita tultuaan URL ja painamalla enter. Sinä näkevät kun luot uuden Enterprise tiedoston, seuraavalla kuvakaappausta "kassalle", tulee uusi kansio ja tiedosto tähän arkistoon.

Huomautus

Jos käytät HTTPS (SSL) palvelin, ja palvelin ei ole voimassa oleva SSL-sertifikaatti (yhteinen intranet tai muut kuin julkiset palvelimet vuoksi kustannukset SSL-varmenteens) Tulee olemaan ylimääräinen askel ottaa. Sinun on pysyvästi hyväksyä kaikki yhteydet, että palvelin dialogi, joka avautuu (se myös osoittaa hieman enemmän tietoa palvelimelle). Voit tehdä tämän kirjoittamalla "s" (ilman lainausmerkkejä) ja paina Enter. ABACUS ponnahtaa viesti, jossa muistutetaan tämän ennen osoittaa dialogi.

Huomautus

Sinua saatetaan pyytää kirjautumaan palvelimelle jolloin henkilö on hallinnassa palvelinvoi tarjota palvelimen käyttäjätunnus ja salasana. Myös kirjautumistietoja tahansa palvelimia, jotka olet yhteydessä tallennetaan joten jos jostain syystä ne on syytä selvittää tämä voi tapahtua Työkalut | Vaihtoehdotja sitten Yleinen välilehdelle napsauttamalla Nollaa Subversion Tallennetut Kirjauduja valitsemalla palvelimen pudotusvalikosta ja napsauttamalla Tyhjennä Kirjaudu sisäänja valitsemalla OK avautuvassa.

Huomautus

Toisin kuvakaappaus edellä on esitetty, tyypillisesti yksi ABACUS hanke sisällytetään kunkin ABACUS Repository koska jos yli 1 ABACUS projekti on luotu yhdessä ABACUS Repository, ABACUS Kanavan numerot jaetaan kaikkien ABACUS Projektit ja tämä saattaa sekoittaa käyttäjiä.

Preferred Tiedostonimi: Tämä vaikuttaa sekä kansio ja tiedostonimi, jota käytetään (jos ei jo otettu) luotaessa tiedosto arkistopalvelimelle. Huomaa, että uusi kansio luodaan automaattisesti arkistopalvelimelle jokaisen tiedoston (suorituskyvyn vuoksi, ABACUS Enterprise tiedostot luodaan omia kansiossa sijainnin selailla olevassa dialogi).

Säilytä työkopion Directory: Kun yritys tiedosto on luotu arkistopalvelimelle, paikalliset työ tiedostot on luotu tietokoneella, joten voit työskennellä tiedostoa ilman yhteyttä verkkoon. Tämä on paikka, että voit selata kun haluat avata / uudelleen auki ABACUS Enterprise tiedosto.

Kassalle Olemassa Enterprise tiedosto

Jos joku on jo luonut uuden Enterprise tiedoston, voit "kassalle" tiedosto, joka lataa paikallinen kopio ja asettaa tarvittavat tiedostot niin ABACUS tunnistaa tämän Enterprise tiedosto. Dialogi on samanlainen Uusi Enterprise File Dialog. Anna arkiston paikannin (alihakemistot voidaan sisällyttää URL), valitse haluamasi tiedosto ja valitse OK. Jollei alla oleva huomautus thän tiedosto sen jälkeen avata.

Huomautus

Sinua saatetaan pyytää kirjautumaan palvelimelle jolloin henkilö on hallinnassa palvelinvoi tarjota palvelimen käyttäjätunnus ja salasana. Myös kirjautumistietoja tahansa palvelimia, jotka olet yhteydessä tallennetaan joten jos jostain syystä ne on syytä selvittää tämä voi tapahtua Työkalut | Vaihtoehdotja sitten Yleinen välilehdelle napsauttamalla Nollaa Subversion Tallennetut Kirjauduja valitsemalla palvelimen pudotusvalikosta ja napsauttamalla Tyhjennä Kirjaudu sisäänja valitsemalla OK avautuvassa.

Laitos Tiedostojen erot

Kun olet luonut Enterprise tiedosto (joko uuteen tai kautta "kassalle" tiedoston luonut joku muu), kansio luodaan tiedosto, ja se yleensä sisältää nämä 3 tärkein tiedostotyypit:

· ".abacus" Tiedosto- Tämä on ABACUS tiedosto itse. Muutokset teet paikallisesti eivät ole heti tallennetaan tähän tiedostoon, se on vain kirjoitettu kun sitoutua. Tämä tiedosto on "normaali" ABACUS tiedosto, se voidaan antaa ei-EE käyttäjätkuin stand-alone hanke (ilman .log tiedosto), Tai käyttää lähtökohtana uuden EE tiedosto.

· ".changes" Tiedosto- Paikallinen (sitomattomat) tehdyt muutokset tiedostoon. Jos tämä tiedosto puuttuu, tämä tarkoittaa, ei ole paikallisia muutoksia.

· '.lokitiedosto- Tämä tiedosto on vain muutokset tehtiin viimeinen käyttäjä (sisällön käyttäjän .changes tiedoston, kun he ovat tehneet).

Huomautus

On olemassa useita muita tiedostoja, jotka voidaan luoda päivityksen aikana ja sitoutua prosessien, nimittäin; ‘.changesbefore"Tiedosto- Tämä tiedosto on kopio .changes tiedoston jälkeen päivitys on tehty ja sitä käytetään automaattisesti sovittaa yhteen kaikki ID ristiriidat päivitys ja kaikki paikalliset (sitova) muuttuu ennen sitoutua; ‘.backup"Tiedosto- Tämä tiedosto on kopio .changes tiedoston ennen käyttäjä säästää enemmän paikallisia (ei-sitova) muutokset .changes tiedosto; ja ‘.virhe"Tiedosto- Tämä tiedosto on kopio .changes tiedosto, jos löytyisi ongelman, jonka vuoksi ABACUS epäonnistua avata .abacus tiedoston ja käyttäjä päätti palauttaa niiden muutokset.Nämä tiedostot voidaan jättää huomiotta.

Avaaminen Tiedoston

Voit avata tiedoston, sinun tarvitsee vain selata missä valitsit tallentaa työkopioosi, ja avaa ABACUS tiedosto, joka on tallennettu siellä. Kun Abacus näkee, että on olemassa .lokitiedosto (ja ehkä .muutokset tiedosto, jos olet tehnyt muutoksia), se käsittelee tiedoston Enterprise tiedosto.

Päivittäminen tiedosto

Esittävätn "Update" tarkistaa, onko uudempaa versiota tiedosto sijaitsee palvelimessa. Jos on, se sulkee nykyisen tiedoston, päivittää uudempaan tiedoston palvelimelta, ja ladata joitakin väliaikaiset tiedostot, joiden määrä jatkeeksi - esimerkiksi "Demo.125". Nämä tiedostot ovat vanhempia versioita .log tiedoston, ja käytetään määrittämään, mitä muutoksia on tehty tiedosto kun viimeksi päivitetty sen. Tämä on tarpeen havaita ristiriidat, joita on tapahtunut niin, että voit ratkaista ne.

Jos päivityksen aikana mitään konfliktithavaittiin, Sinun täytyy ratkaista ne ennen kuin voit avata tiedoston uudelleen (voit peruuttaa mutta sinua pyydetään ratkaisemaan konflikteja uudelleenseuraavan kerran avaat tiedoston).

Tallentaminen Tiedoston

Kun tallennat tiedoston, tämä liittää muutokset olet tehnyt .changes tiedosto. Se eimuokata .abacus tiedosto tässä vaiheessa - vain, kun tiedosto on sitoutunut palvelin sitä kirjoittaa niiden päälle (tai kun saat päivityksen palvelimelta).

Missä on 'Tallenna nimellä'?

Ei ole käsitettä Tallenna nimellä Enterprise tiedostoja. Voit kuitenkin kopioida työkopiosi .abacus tiedosto, pitäen mielessä, että se tapa on paikallinen muutoksia.

Konfliktien ratkaisemiseen

Jos muut käyttäjät ovat sitoutuneet muutoksia tiedoston samanlainen osa tiedosto sinulle, voi olla joitakin ristiriidat niiden muutoksiin ja sinun. Esimerkiksi, toinen käyttäjä voi poistaa komponentti, joka sinulla oli päivittää omaisuuden. Sinun täytyy joko kumota niiden muutos (jos olet varma, että heidän pitäisiei on tapahtunut), tai hylätä muutoksen (voit sitten mennä takaisin tiedosto ja redo muutos).

Erityisesti on 4 luokkaa konflikteja voi tapahtua;

1. Poistaa - Kun yksi käyttäjä poistaa objektin toisen käyttäjän muutokset. Esim. Käyttäjän Poistetaan komponentti mutta käyttäjä B muutti osan nimi tai kytketty siihen tai lisätä lapsen komponentti se jne.

2. Ominaisuus - Kun kaksi käyttäjää sekä muuttaa täsmälleen sama "ominaisuus" esineen. Esim. Sekä Käyttäjän ja Käyttäjä B muutti osan nimi tai sen kuvaus tai arvo yksi sen ominaisuuksista jne.

3. Viite - Kun kaksi käyttäjää vaihtaa täsmälleen sama viittaus "esine on toiseen kohteeseen. Esim. Sekä Käyttäjän ja Käyttäjä B muutti komponentin tyyppi tai lähde / pesuallas komponentti kiinnitetty yhteyden tai liittyy näkökulman kaavio jne.

4. Kokoelma - Kun kaksi käyttäjää vaihtaa "kokoelma" varten esine. Esim. Sekä Käyttäjän ja Käyttäjä B muutti komponentin vanhemmalta toiselle tai uudelleen tilata kokoelma lasten komponentteja.

Huomautus

Erilaiset merkityksetön ristiriidat automaattisesti ratkaista ABACUS minimoida yläpuolella käyttäjiin.Esimerkiksi ristiriidat yleiseurooppalaista zoom asetuksia kaaviot päättäneet pitää uusimman yleiseurooppalaista zoom-asetuksilla.

Sitoutuminen Muutokset

Kun päätät sitoutua muutokset, ABACUS tiedosto palvelimelta avataan, paikallinen muutokset tehdäänsitä vastaan, ja sitten paikallinen .abacus tiedosto korvataan yhdellä, jossa on sinun muutoksia. Muutokset tiedosto sitten korvaa .log tiedosto, ja molemmat .abacus tiedosto ja .log tiedosto lähetetään palvelimelle.Jos sitoutua onnistuu arkistoon valintaikkuna kuten alla annetaan syöttää viestin sitoutua.

Katselu loki Muutokset

Jotta tarkastella lokia muutokset Yritys hankeValitse Tiedosto| View Log...

Suurin lokitiedot: Tämä oletusarvoisesti viimeisen 10 merkinnät mutta lisämerkintöjä voidaan hakea muuttamalla arvon ja napsauttamalla Hakea painiketta.

Tarkistus: The Versio sarakkeessa luetellaan versionumerot sitoutunut yrityksen palvelimelle, oletusarvoisesti, käänteisessä kronologisessa järjestyksessä.

Huomautus

Versionumerot eivät välttämättä ole jatkuvaa, sillä vain ABACUS sitoutuu listataan kun sama Subversion-arkiston voidaan voidaan käyttää muihin ABACUS hankkeisiin ja / tai muu versio valvonnan sovelluksia.

Päivämäärä: ThU Päivämäärä sarakkeessa luetellaan päivämäärä että tarkistus oli sitoutunut Enterprise palvelimelle.

Aika: The Aika sarakkeessa luetellaan kellonaika (24 tunnin muodossa), että tarkistus oli sitoutunut Enterprise palvelimelle.

Kirjailija: The Tekijä sarakkeessa luetellaan Microsoft Windows kirjautuminen nimi käyttäjälle, joka suorittaa toimitusta seuraa niiden ABACUS käyttäjätunnus Tai "Nimetön", jos käyttäjä ei ole todennettu ja anonyymien käyttäjien annettiin pääsy Enterprise hankkeen aikaan sitoutua.

Lokiviestin: The Lokiviestin sarakkeessa luetellaan arkistoon, joka oli varustettu tarkistamisen kohti valintaikkuna yllä.

Lataa tarkistus XX itsenäisinä ABACUS tiedosto: Jos valitset tietyn tarkistus taulukossa ja napsauta Lataa-painiketta voit poimia valitun ABACUS hanke versiota palvelimelta ja tallentaa sen paikallinen / stand-alone ABACUS projekti.

Huomautus

Roll takaisin edellisen version katso tämä Avolution yhteisö artikkeli .

(Admin) Lataa XML lokitiedosto tarkistamista XX: Käyttäjät, joilla ABACUS Administrator kyky valita tietty tarkistus taulukossa ja napsauta Lataa-painiketta poimia valitun ABACUS hankkeen sitoutua lokitiedosto palvelimelta ja tallentaa sen .xml-tiedoston.

Katsoo Audit Trail of Changes

Jotta katsella kirjausketju muutoksia tahansa elementtiin (eli komponentti, liitäntä, katsella, lapset jne) ja Yritys hanke, hiiren kakkospainikkeella elementti ja valita Audit Trail..., Aseta Mistä ja Mihin: Versio alue ja napsauta Haku.

Huomautus

Kun elementti poistetaan projektin et enää pysty käyttämään tiettyjä kirjausketjun tietoja että elementti. Voit kuitenkin edelleen käyttää "vanhempi" komponentti (esimerkiksi) ja nähdä kirjausketju tietoja poisto (tässä tapauksessa luetellaan ID elementti poistettu).Lisäksi Komponentti / Yhteys kiinnitys on "ominaisuus" yhteyksien niin muuttuvassa liitetty komponentti kautta Explorer-ikkunassa tai kaaviot näy kirjausketju yhteys EI komponentti ja poistaa yhteyden ja luo uusi yhteys (kuten tapahtuu, jos hiiren kakkospainikkeella "Unattach" ja sitten "Yhdistä ..." luetteloissa) johtaa menetykseen jäljitysketjun tietoja alkuperäisen osan - yhteys kiinnitys kokonaan.

Huomautus

Oletuksena jäljitysketju rekursiivisesti tarkista muutokset johonkin lasten valittu elementti. Tämä voi johtaa pitkiin vasteajat ja vastaavasti kirjausketju voidaan rajoittaa elementtiin itse poistamalla valinnan Rekursiivinen mukainen vaihtoehto Audit Valinnat"Hammaspyörä 'työkalurivin painiketta Audit Trail dialogi.

Mistä: Versio: Tämä oletusarvoisesti ensimmäinen / vanhimman version käytettävissä hankkeen Enterprise palvelimelle.

Versiohistoriaan: Tämä oletusarvoisesti viimeksi / tarkistettu viimeksi käytettävissä hankkeen Enterprise palvelimelle.

Huomautus

Asettamisen jälkeen alkaen ja versioväli klikkaa haku-painiketta hakea konkreettisia muutoksia valitun elementin.

Tarkistus: The Versio sarakkeessa luetellaan versionumerot sitoutunut yrityksen palvelimelle, oletusarvoisesti, eteenpäin aikajärjestyksessä.

Huomautus

Versionumeroita ovat todennäköisesti ole jatkuvaa, sillä ainoastaan ​​tarkistukset liittyvät valitun elementin näytetään vain ABACUS sitoutuu listataan kun sama Subversion-arkiston voidaan voidaan käyttää muihin ABACUS hankkeisiin ja / tai versio ohjaus sovelluksia.

Päivämäärä: ThU Päivämäärä sarakkeessa luetellaan päivämäärä että käyttäjän toimia tehtiin.

Huomautus

Päivämäärä esitetty on käyttäjän toimia päivämäärä, ei päivämäärää tarkistus on sitoutunut Enterprise palvelimelle. Näin ollen voi olla aikaisintaan vastaava tarkistus sitoutua päivämäärä näytetään File | View Log ... komento.

Aika: The Aika sarakkeessa luetellaan kellonaika (24 tunnin muodossa), että käyttäjän toimia tehtiin.

Huomautus

Näkyvä aika on käyttäjän toimia aikaa, ei aikaa tarkistus oli sitoutunut Enterprise palvelimelle. Näin ollen aika todennäköisesti edeltää vastaava tarkistus sitoutua aika näytetään File | View Log ... komento.

Kirjailija: The Tekijä sarakkeessa luetellaan käyttäjä suorittaneen toimen Microsoft Windows kirjautuminen nimen perässä niiden ABACUS käyttäjätunnus Tai "Nimetön", jos käyttäjä ei ole todennettu ja anonyymien käyttäjien annettiin pääsy Enterprise hankkeen aikaan käyttäjän toimia.

Huomautus

Tekijä luetellut Audit Trail dialogi ei välttämättä vastaa Tekijä luetellut View loki edellä saman version. Tämä johtuu Näytä loki luettelot kirjautuneen käyttäjän aikaan sitoutua samalla Audit Trail -valintaikkunassa näkyvät kirjautuneen käyttäjän aikaan käyttäjän toimia, ja se on mahdollista saada yksi käyttäjä tehdä muutoksia ja lähettää. muuttaa tiedoston toiselle käyttäjälle sitoutua - kuten silloin, kun ulkoinen käyttäjä (kuten Avolution) on työskennellä EE hanke.

Tarkemmat tiedot: The Tiedot sarakkeessa luetellaan tarkat tiedot käyttäjän kanteen kirjattu Enterprise -palvelimen.

Kärki

On hyödyllistä ryhmän Versio sarake (Kuten on esitetty dialogi edellä) ja / tai käyttäjän toimia sarake että helposti luokitella muutokset kiinnostava elementti.

Käyttö Scripting Enterprise tiedostoja

Jos käytät scripting Enterprise tiedostoja, sinun pitäisi olla tietoinen siitä, miten oikein poistaa objektin mallista. Yleensä, kun olet poistamassa objekti, voit soittaa .Delete () -menetelmää sitä, pikemminkin kuin vain poistamalla sen emoyhtiön.

Esim. jos olisit COMP1 kuin vanhempi COMP2 ja haluat poistaa COMP2 oman käsikirjoituksen, sinun pitäisi soittaa comp2.Delete (), pikemminkin kuin comp1.Components.Remove (COMP2).

Voit käyttää poistaa, jos aiot lisätä COMP2 kohde toiseen paikkaan sisällä arkkitehtuurin, mutta sitä ei pitäisi käyttää, jos on tarkoitus poistaa kohteen.

On Poikkeuksena tähän, kun haluat poistaa objektin "elää" muualla malli. Kun haluat poistaa standardin oikeusasteen Arkkitehtuuri / komponentti / liitäntä, niin voisitte tehdä niin poistamalla sen oikeusasteen standardi kokoelma - arch1.Toteutukset.Irrota (IMP) - koska poistamalla se poistaisi sen kaikissa tapauksissa.

Oikein käyttäen Poista skriptit on tärkeää, sillä jos kohde poistetaan objectmodel eikä lisätään uudelleen, niin se ei voi olla paikalla, mutta koska se ei ollut nimenomaan "poistettu", Conflict Detection ja Resolution eivät tunnista ristiriita, jos toinen käyttäjä oli yrittää käyttää saman kohteen tahansa niiden muutoksia, ja lopputulos on vioittunut joukko muutoksia kyseiselle käyttäjälle.

Katso myös

Miten arkkitehtuuri edustettuna ABACUS?


Työskentely Oikeudet

Navigointi: Hallinto>

Työskentely Oikeudet

Lähetä kommentit tästä aiheesta.

ABACUS hankkeilla voi olla roolipohjainenkäyttöoikeudet asettaa jokainen elementti arkistossa. Erityisesti, pienijyväinen Create-Read-Update-Doista (LIKA) Käyttöoikeudet voidaan asettaa "esine" (eli komponentti tai liitäntä), katsella ja määrite (eli omaisuus) tasoilla.

Yleiskatsaus

Työskenneltäessä ABACUS Laitos Palvelin Abacus tarjoaa hienorakeista, rooli-pohjainen lika oikeudet valvoa pääsyä useiden käyttäjien arkistoon.

Huomautus

Määrittää käyttöoikeudet ABACUS projektissa käyttäjän lisenssi tarvitsee järjestelmänvalvojan valmiudet. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

Oikeudet voidaan asettaa arkkitehtuurit, komponentti ja liitäntä tyypit, ominaisuudet (kautta tyypit), malleja, näkökulmia ja kaaviot, luettelot, matriisit, kaavioita ja 3D-näkymät. Kun oikeudet asetetaan osan tai yhteystyyppi kaikista tapauksista kyseisen tyypin missään arkkitehtuureja, että hanke "perivät" nämä oikeudet. Samoin, kun lupa on asetettu omaisuutta osan tai yhteystyyppi, kun otetaan kiinteistön osan tai yhteyden tapauksissa missään arkkitehtuureja, että hanke "perivät" nämä oikeudet. Näin ollen tiettyjä oikeuksia aletaan soveltaa näkemyksiä siitä, mitä niistä olemassa. Kun käyttöoikeudet on asetettu kaavio, katsella ja / tai sisällön mieltä itse on erilaisia ​​lupia soveltaa.

Huomautus

Oletusarvoisesti ei käyttöoikeudet asetetaan elementit ABACUS hanke. Se on kaikki elementit ovat Createable, luettavissa, Päivitettävissä ja Deleteable kaikille käyttäjille. Tällä tavoin oikeudet tulee harkita vain tietylle osa arkistossa kun tietty lupa on olla rajoitettutietylle käyttäjäryhmälle. Esimerkiksi, jos käyttöoikeudet tietylle käyttäjäryhmälle lisättiin esine (esim osan), mutta jää kaikkien oikeudet käytössä, niin tämä on toiminnallisesti sama kuin jos käyttäjäryhmä ei ollut lisätään objekti.

Oikeudet ei pystymäärätä tiettyjä esimerkkejä arkkitehtuurin elementtejä. Esimerkiksi, et voi tehdä yksi hakemus komponentti päivitettävissä vielä toinen ei. Tehokkaasti saavuttamiseksi "verkkoaluekohtaisen" käyttöoikeudet kuitenkin, Ylläpitäjä voi perustaa erityinen osa tyypit annettu aloilla, esimerkiksi komponenttityypit Application - CRM domain "ja" Application - HR domain ", ja aseta käyttöoikeudet kullekin vastaavasti. Voit tehdä erityisiä ryhmittely tyypit kunkin toimialueen ja poista päivitys lupaa Verkkoaluekohtaiset ryhmä tyyppi ja tämä rajoittaa luomuksia sisällä ja poistot yhtymää mutta ei päivitä lapsia. Tietenkin jos Verkkoaluekohtaiset ryhmittely oli piilotettu poistamalla lukuoikeus sitten lapset olisi piilossa ja siten ei-päivitettävissä. Vaihtoehtoisesti, jos näkymät (pikemminkin kuin Explorer) käytetään ensisijaisesti hallita / katsella arkiston, tietyn näkymän jokaiselle verkkotunnuksen voitu määrittää, ja sitten Administrator voisi asettaa käyttöoikeudet jokaiselle näkymä vastaavasti.

Toimitusjohtaja Käyttäjät ja ryhmät

Oikeudet on määritelty rooli tai ryhmätasolla, toisin kuin yksittäisen käyttäjän tasolle, niin että vaikka jäsenyys ryhmät voivat muuttua, käyttöoikeuksia voi pysyvät kiinteinä. Tietenkin jos haluat tietyn käyttäjän lupaa sitten yksinkertaisesti tehdä niistä ryhmä, tai tarkemmin luoda ryhmän, joka käyttäjän ainoaksi jäseneksi.

On huomattava, että ryhmät ovat atomi-, Eli ne eivät voi periä käyttöoikeuksia tai käyttäjiä toisesta toiseen, ja jos käyttäjä kuuluu useita ryhmiä sitten kaikkein "pessimistinen" ryhmä lupaa etusijalla tapauskohtaisesti tapauskohtaisesti kunkin lupaa (eli luominen -Lue-päivitys-Delete). Esimerkiksi jos sama käyttäjä on jäsenenä konsernin ja ryhmä B ja ryhmä A on juuri Luo-Lue lupa Application komponenttityypit kun ryhmä B on vain Lue-päivitys lupaa Application komponenttityypit niin käyttäjä vain lukenut luvan sovelluskomponentin tapauksissa.

Lisäksi oletuksena, anonyymit käyttäjät(Eli käyttäjät, jotka eivät ole määritelty tai jotka eivät ole kirjautunut) on täysi pääsyhankkeeseen. Näin varmistetaan, että yhteys on käytettävissä alkukokoonpano. Estää pääsyn Anonyymit käyttäjät yksinkertaisesti poista "Salli anonyymi käyttäjä täysi pääsy tiedostoon" vaihtoehto hallinta Käyttäjät / ryhmät Dialog alla. Kun valittuna anonyymit käyttäjät vain voi nähdä Standards osa hankkeita.

Lopuksi, jos "Käytä Windows Käyttäjätunnus Tulo" vaihtoehto on valittu käyttäjätunnus todennus tehdään vasten Windows Käyttäjätunnus Logins kunkin käyttäjän kone pääse käyttäjätunnus n kirjattu kohti alla. Eli jos Windows Käyttäjänimi Tulo tietyn käyttäjän kone olemassa kelvollinen käyttäjätunnus sitten salasanaa ei tarvita, ja käyttäjä on automaattisesti todennettu. Huomautus: tämä tehokkaasti mahdollistaa käytön Windows Active Directory (AD) autentikointi.

Huomautus

Koska luvat ainoastaan ​​määritellään niiden on otettava pois (rajoitettu) käyttäjältä, kuka tahansa käyttäjä, joka ei ole ryhmän jäsen, tai mikä tahansa ryhmä, jolla ei ole oikeuksia määritelty sitä vastaan ​​mitään esineitä, on täysi pääsy projekti.

Käyttäjät ja käyttäjäryhmät

Luoda uuden Käyttäjä

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

Huomautus

Jos et näe Käyttäjien hallinta / ryhmät valikkokohde niin sinulla ei ole järjestelmänvalvojan valmiudet. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

2. Vuonna avautuvassa Valitse Lisää käyttäjä-painiketta ja anna käyttäjätunnus ja salasana Luo uusi käyttäjä dialogi. Huomautus: Käyttäjätunnukset ja salasanat ovat isot ja pienet kirjaimet.

Huomautus

Jos "Käytä Windowsin Käyttäjätunnus Tulo" vaihtoehto on valittu edellä kuvatulla sitten nuken salasana voidaan syöttää todennus suoritetaan mukaan käyttäjän Windowsin Käyttäjätunnus Kirjaudu vain.

2. Oletuksena näet, että Käyttäjät voivat muuttaa omaa salasanaa. Tarvittaessa ABACUS Ylläpitäjä voi poistaa kyky käyttäjät voivat asettaa omat salasanan mukaan poistamalla valinnanvalintaruudut.

Huomautus

Jos käyttäjät voivat vaihtaa oman salasanan heillä File | Vaihda salasana...valikkokohta tehdä niin.Muista myös, että jos useat ihmiset käyttävät samaa käyttäjätunnusta sitten yksi käyttäjä voi vaihtaa salasanan niin, että mikään muu ihmiset voivat kirjautua jälkikäteen. Vastaavasti, on suositeltavaa käytäntönä yksi käyttäjätunnus per todellinen henkilö.

4. Voit halutessasi kirjoittaa sähköpostiosoite, Sijainti ja Puhelinnumero käyttäjille tulevaa käyttöä varten.

5. Klikkaa Kunnossapainiketta Luo uusi käyttäjä dialogi.

6. Klikkaa Kunnossapainiketta.

Huomautus

Kun olet luonut ensimmäinen käyttäjä sinun pitäisi harkita estää pääsyn Anonyymit käyttäjät poistamalla valinnan "Salli anonyymi käyttäjä täysi pääsy tiedostoon" vaihtoehto hallinta Käyttäjät / ryhmät dialogi.Myös, kun käyttäjä on luonut (ja jos Enterprise hanke, muutos sitoutunut palvelin), seuraavan kerran projekti avataan käyttäjille kehotetaan Kirjaudu tunnistettujen yhteyskohti valintaikkuna alla. Jos Kirjaudu automaattisesti nämä tiedotvaihtoehto on valittu, käyttäjätunnus / salasana-yhdistelmää muistetaan hankkeen ja sovellettava joka kerran avattaessa. Tyhjentää tallennetut kirjautuminen valitse File | Poista tallennetut Kirjauduavaamisen jälkeen ja sinua pyydetään kirjautua uudelleen seuraavan kerran avaat projektin.

Kirjaudu sisään

Voit poistaa olemassa olevan Käyttäjän

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

2. Vuonna avautuvassa Valitse käyttäjänimi käyttäjät paneeli, jonka haluat poistaa ja valitse sitten Poista käyttäjäpainiketta.

3. Klikkaa Kunnossapainiketta.

Voit luoda uuden ryhmän

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

2. Vuonna avautuvassa Valitse Lisää ryhmä-painiketta ja kirjoita ryhmän nimi ryhmät paneelissa.

Huomautus

Ryhmä nimien on oltava yksilöllisiä.

3. Klikkaa Kunnossapainiketta.

Jotta kopioida olemassaRyhmä

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

2. Vuonna avautuvassa Valitse KopioidaRyhmäpainiketta.

Huomautus

Kaksoiskappale ryhmä luodaan etuliite "kopio".Oletuksena kaikki luvat kopioida ryhmä monistetaan varten "kopio" ryhmä myös käyttäjän tehtävän.

3. Nimeä "kopio" ryhmän tarvittaessa käyttämällä Muokkaa ryhmäätai hidas kaksoisnapsauta.

Voit poistaa olemassa olevan ryhmän

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

2. Vuonna avautuvassa valitse ryhmän nimi Ryhmät paneeli, jonka haluat poistaa ja valitse sitten Poista ryhmäpainiketta.

Huomautus

Jokainen käyttäjän tehtäviä konsernin poistetaan myös.

3. Klikkaa Kunnossapainiketta.

Määrittää käyttäjän ryhmään

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

2. Vuonna avautuvassa Valitse käyttäjänimi Käyttäjät-paneelissa, jonka haluat määrittää ryhmän ja raahaa ja pudotase päälle Ryhmän nimi Ryhmät-paneeli, jonka haluat määrittää sen.

3. Klikkaa Kunnossapainiketta.

Huomautus

Ryhmä (t), jotka käyttäjä on liitetty on esitetty laajentamalla Käyttäjänimi Käyttäjät-paneelissaja käyttäjät, jotka on määritetty ryhmään näkyvät laajentamalla Ryhmän nimi Ryhmät-paneelissa. Esimerkiksi, edellä kuvakaappaus, "AS1-Aus" käyttäjä on liitetty kolme (3) ryhmää, nimittäin; "App Support Team 1", "Todellinen" ja "Australia".

Voit Unassign käyttäjän ryhmästä

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

2. Vuonna avautuvassa laajentaa Ryhmän nimi, joka sisältää User tehtävän, jonka haluat Unassign ja valitse Lempinimi.

3. Klikkaa Unassign Käyttäjäpainiketta.

4. Klikkaa Kunnossapainiketta.

Voit tuoda käyttäjät ja / tai ryhmät (ja kaikki vastaavat käyttöoikeudet)

1. Valita Tiedosto| Hallitse käyttäjiä / ryhmät

2. Klikkaa Tuoda maahanpainiketta.

3. Vuonna avautuvassa Selaillaja avaa ABACUS projekti, joka sisältää käyttäjät ja / tai ryhmät (ja käyttöoikeudet) haluat tuoda nykyisen projektin ja valitse Avata. Käyttäjät ja ryhmät tuodaan ja Tuo tulokset valintaikkuna ilmestyy yhteenveto tuonti Käyttäjät ja / tai Ryhmät. Klikkaa Kunnossapainiketta.

Huomautus

Jos tuodut käyttäjät tai ryhmät jo olemassa nykyisen projektin sitten ne yhdistetään nykyiset käyttäjät tai ryhmät.

4. Klikkaa Kunnossapainike takaisin tärkein Käyttäjien hallinta / ryhmät dialogi.

5. Jos on hakutyyppien Näkökulmia, Mallit tai arkkitehtuureja välillä nykyisen projektin ja ABACUS projekti tuot päässä, jossa on käyttöoikeudet, jotka eivät jo nykyisen projektin, käyttöoikeudet tuodaan ja toinen Tuo tulokset -valintaikkunan näkyy yhteenveto tuonti. Klikkaa Kunnossapainiketta.

Huomautus

Oikeudet ovat vain lisätään nykyistä tyyppiä (ja niiden ominaisuudet), Näkökulmia, Mallit tai arkkitehtuureja varten ryhmissä, joissa oikeuksia ei ole vielä olemassa konsernille. Joko koska konserni on uusi tai konsernin jo olemassa nykyisen projektin mutta ei käyttöoikeuksia ollut osoitettu, että konsernin kyseiseen erään. Ei ole "yhdistäminen" on oikeuksia vastaavia kohteita, joissa käyttöoikeudet jo olemassa konsernin nykyisen projektin.

Käyttöoikeuksien

Oikeudet voidaan asettaa arkkitehtuurit, komponentti ja liitäntä tyypit, ominaisuudet (kautta tyypit), malleja, näkökulmia ja kaaviot, luettelot, matriisit, kaavioitad 3Dnäkymät. Kun oikeudet asetetaan osan tai yhteystyyppi kaikista tapauksista kyseisen tyypin missään arkkitehtuureja, että hanke "perivät" nämä oikeudet. Samoin, kun lupa on asetettu omaisuutta osan tai yhteystyyppi, kun otetaan kiinteistön osan tai yhteyden tapauksissa missään arkkitehtuureja, että hanke "perivät" nämä oikeudet. Näin ollen tiettyjä oikeuksia aletaan soveltaa näkemyksiä siitä, mitä niistä olemassa. Kun käyttöoikeudet on asetettu kaavio, katsella ja / tai sisällön mieltä itse on erilaisia ​​lupia soveltaa.

Oikeudet Management

Asettaa luvan komponentti (tai Connection) Tyyppi

1. Laajenna Tyypithaara puu.

2. Laajenna Komponentti (tai Connection) Tyypithaara puu.

3. Laajentaa Ryhmättarvittaessa.

4. Hiiren kakkospainikkeellakoskevat Komponentti (tai Connection) Tyyppihaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

5. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

6. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

Huomautus

Luo lupa koskee myös, kun voit kopioida elementti. Näin ollen, jotta voi kopioida elementti edellyttää Luo lupaa kaikille lapsille (koska kopioida osien selitykset kopioiminen alapuolella). Poistaminen Päivitys lupaa elementti poistaa kyky muokata tyyppi itse, vaikka käyttäjä on Designer add-on ja se poistaa myös Päivitä lupaa kaikille ominaisuuksia. Emoelementin oltava Päivitä lupa pystyä Luo lapsia osia tai Poista sen nykyinen lapset elementtejä. Poista lupaa elementin edellyttää myös Poista lupaa kaikille lapsille. Poista lupaa komponenttien edellyttää myös päivitys lupaa kaikki liitteenä liitännät.Ja lopuksi, poistamalla Poista lupaa elementistä poistaa mahdollisuus poistaa tyyppi itse, vaikka käyttäjä on Designer lisäosalla.

7. Klikkaa Kunnossapainiketta.

Asettaa luvan ryhmän komponentin (tai Connection) Tyypit

1. Laajenna Tyypithaara puu.

2. Laajenna Komponentti (tai Connection) Tyypithaara puu.

3. Hiiren kakkospainikkeellakoskevat Ryhmäjoka sisältää komponentin (tai yhteys) tyypit, jotka haluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

6. Klikkaa Kunnossapainiketta.

7. Vuonna avautuvassa valitse Kylläpainiketta.

Asettaa luvan Kiinteistövälitys

1. Laajenna Tyypithaara puu.

2. Laajenna Komponentti (tai Connection) Tyypithaara puu.

3. Laajentaa Ryhmättarvittaessa.

4. Valitse Component (tai Connection) tyyppiä, joka sisältää kiinteistön haluat käyttöoikeuksien määrittäminen.

5. Ominaisuudet-ikkunassa hiiren kakkospainikkeellakoskevat Omaisuushaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

6. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

7. Oletuksena näet, että Lue ja päivitä käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

Huomautus

Ominaisuuksia, joilla on ollut Update lupa poistettu esitetään kursivointiOminaisuudet-ikkunassaja niiden arvoja ei voida ylläpitää niitä rooli. Myös, kyky muokata yksityiskohtia omaisuuden (esim nimi, yksiköt jne) edellyttää sekä Update lupaa omaisuutta ja Suunnittelija lisäosalla.

8. Klikkaa Kunnossapainiketta.

Asettaa luvan malli

1. Laajenna Mallithaara puu.

2. Selaa Sapluunaettä olet kiinnostunut.

3. Hiiren kakkospainikkeellakoskevat Sapluunahaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että Lue lupaa on käytettävissä. Poista luvalla poistamalla valinnanvalintaruutu.

6. Klikkaa Kunnossapainiketta.

Asettaa luvan näkökulma

1. Laajenna Näkökulmiahaara puu.

2. Laajentaa Ryhmättarvittaessa.

3. Hiiren kakkospainikkeellakoskevat Näkökulmahaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

6. Klikkaa Kunnossapainiketta.

Asettaa luvan Arkkitehtuuri

1. Laajenna Arkkitehtuurithaara puu.

2. Laajenee Arkkitehtuuriettä olet kiinnostunut.

3. Hiiren kakkospainikkeellakoskevat Arkkitehtuurihaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että Lue lupaa on käytettävissä. Poista luvalla poistamalla valinnanvalintaruutu.

6. Klikkaa Kunnossapainiketta.

Asettaa luvan Luettelo

1. Laajenna Luettelothaara arkkitehtuurin olet kiinnostunut.

2. Laajentaa Ryhmättarvittaessa.

3. Hiiren kakkospainikkeellakoskevat Luettelohaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

6. Klikkaa Kunnossapainiketta.

Asettaa luvan Matriisi

1. Laajenna Matriisithaara arkkitehtuurin olet kiinnostunut.

2. Laajentaa Ryhmättarvittaessa.

3. Hiiren kakkospainikkeellakoskevat Matriisihaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

6. Klikkaa Kunnossapainiketta.

Asettaa luvan Kaavio

1. Laajenna Kaaviothaara arkkitehtuurin olet kiinnostunut.

2. Laajentaa Ryhmättarvittaessa.

3. Hiiren kakkospainikkeellakoskevat Kaaviohaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

Huomautus

Vaikka voit asettaa lika käyttöoikeudet suoraan kaavio, on huomattava, että luvat elementtien kaavio saattaa vaikuttaa oikeudet mieltä itse. Esimerkiksi, jos on jopa vain yksi elementti, että on ollut sen Lue tai päivitys lupaa poistaa sitten kaavio on sen päivitys lupaa poistettu. Tämä johtuu siitä, että; ) elementtejä että ovat saaneet Lue lupaa poistaa ei näytetä näkymä jättäen "white space", jossa voit muuten laittaa joitain uusia osia, jos näkymä oli päivitettävissä, ja b) seikat, että on ollut niiden päivitys lupa poistettu voisi sitten olla muita elementtejä pudotetaan heitä lapsia jos näkymä oli päivitettävissä. Myös, luoda ja päivittää luvan kaavio edellyttää, että kaikki elementit näkymä on Lue luvalla ja komponentit on päivitys lupaa (tämä johtuu siirtää osan päälle toisen laitteen, sinun on voitava päivittää sen, koska se tullut lapsi).

6. Klikkaa Kunnossapainiketta.

Asettaa luvan 3D-näkymä

1. Laajenna 3D Näkymäthaara arkkitehtuurin olet kiinnostunut.

2. Laajentaa Ryhmättarvittaessa.

3. Hiiren kakkospainikkeellakoskevat 3D-näkymähaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

6. Klikkaa Kunnossapainiketta.

Asettaa luvan Kartoittaa

1. Laajenna Kaavioitahaara arkkitehtuurin olet kiinnostunut.

2. Laajentaa Ryhmättarvittaessa.

3. Hiiren kakkospainikkeellakoskevat Kartoittaahaluat asettaa käyttöoikeudet ja valitse Muuta Oikeuksia.

4. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

5. Oletuksena näet, että luoda, lukea, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

6. Klikkaa Kunnossapainiketta.

Katso myös

Miten arkkitehtuuri edustettuna ABACUS?


Työskentely Kojelauta

Navigointi: Hallinto>

Työskentely Kojelauta

Lähetä kommentit tästä aiheesta.

ABACUS hankkeilla voi olla mitään asetuksia näkemyksiä (esim kaaviot, Kaavioita ym) tallennettu kojelauta ja nämä tallennetut raporttinäkymät voi olla oletuskansiona alkaa "näyttö" avaamisesta hankkeen ja / tai osoitettu tiettyyn käyttäjäryhmä ja esitteli jäsenille että käyttäjäryhmän kun he kirjautuvat sisään ABACUS hankkeeseen.

Huomautus

Määrittää mittaristot vuonna ABACUS projektissa käyttäjän lisenssi tarvitsee järjestelmänvalvojan valmiudet. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

Katsoo Kojelauta

Esimerkiksi Application Portfolio Management (APM) kojelauta

Jos haluat tarkastella tallennettuja Dashboard

1. Valita Näkymä| Kojelauta

2. Valitse tallennettu kojelauta luettelosta käytettävissä mittaristot.

Huomautus

Kun valittu ABACUS rakentaa näkemyksiä tarvitaan kojelautaan ja tämä voi kestää muutaman sekunnin. Ole kärsivällinen.

Toimitusjohtaja Kojelauta

Toimitusjohtaja Kojelauta

Luoda uuden Dashboard

1. Avaa tarpeelliset näkemyksiä ja järjestää ja telakka ikkunat edellyttämällä kojelautaan.

2. Valita Näkymä| Kojelauta| Hallitse Kojelauta ...

Huomautus

Jos et näe Manage Kojelauta valikkokohta niin sinulla ei ole järjestelmänvalvojan valmiudet. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki jos tarvitset tätä ominaisuutta.

3. Vuonna avautuvassa Valitse Luoda-painiketta ja kirjoita Dashboard nimi Luo uusi Dashboard dialogi.

4. Klikkaa Kunnossapainiketta.

Jos haluat poistaa Dashboard

1. Valita Näkymä| Kojelauta| Hallitse Kojelauta ...

2. Vuonna avautuvassa Valitse Dashboard haluat poistaa luettelosta ja valitse Poistaapainiketta.

Huomautus

Poistaminen kojelauta myös poistaa käyttäjäryhmä toimeksiantoja että kojelauta.

3. Klikkaa Kunnossapainiketta.

Korvata nykyiset Dashboard

1. Avaa tarpeelliset näkemyksiä ja järjestää ja telakka ikkunat edellytetään uusittaessa kojelautaan.

2. Valita Näkymä| Kojelauta| Hallitse Kojelauta ...

3. Vuonna avautuvassa Valitse Dashboard haluat korvata luettelosta ja valitse Korvatapainiketta.

4. Klikkaa Kunnossapainiketta tunnustaa Dashboard Korvattu dialogi.

Määrittää Dashboardoletukseksi aloitusnäyttö

1. Valita Näkymä| Kojelauta| Hallitse Kojelauta ...

2. Vuonna avautuvassa Valitse Dashboard listasta haluat määrittää oletuksena start "näyttö"ja valitse Määritä ...painiketta.

3. Vuonna avautuvassa Valitse merkintä käyttäjäryhmät sarake.

Huomautus

Vain yksi kojelauta voidaan antaa kuin aloittaa 'näyttö' niin siirtämällä poistaa toimeksianto edellisestä kojelauta.Lisäksi, jos käyttäjä kirjautuu sisään jäsenenä käyttäjäryhmä, joka on määritetty kojelauta sitten annetaan kojelauta avataan sijasta oletuksena hankkeen kojelautaan.

4. Klikkaa Kunnossapainiketta.

Määrittää käyttäjäryhmän Dashboard

1. Valita Näkymä| Kojelauta| Hallitse Kojelauta ...

2. Vuonna avautuvassa Valitse Dashboard listasta haluat määrittää käyttäjän ryhmä ja valitse Määritä ...painiketta.

3. Vuonna avautuvassa Valitse User Group (tai ryhmät)haluat määrittää kojelaudan kuin starttirahoitusta näytön.

Huomautus

Jos sama User Group on osoitettu useita mittaristot sitten ensimmäinen tehtävä luettelossa käytetään.

4. Klikkaa Kunnossapainiketta.

Voit Unassign User Group Dashboard

1. Valita Näkymä| Kojelauta| Hallitse Kojelauta ...

2. Vuonna avautuvassa laajentaa Dashboard kohde luettelosta haluat Unassign käyttäjän ryhmä.

3. Valitse Käyttäjäryhmä haluat Unassign ja valitse Unassignpainiketta.

4. Klikkaa Kunnossapainiketta.

Käyttöoikeuksien

Oikeudet voidaan asettaa mittaristot, jotta kojelautaan mil, Päivitettävissä ja / tai deleteableannettujen käyttäjäryhmille.

Oikeudet Management

Asettaa luvan Dashboard

1. Valita Näkymä| Kojelauta| Hallitse Kojelauta ...

2. Vuonna avautuvassa Valitse Dashboard listasta haluat asettaa käyttöoikeudet ja valitse Käyttöoikeudet ...painiketta.

3. Vuonna avautuvassa klikkaa Lisätä...painiketta ja valitse Ryhmähaluat lisätä joko kaksoisnapsauttamalla sitä tai valitsemalla se ja napsauttamalla Kunnossapainiketta.

4. Oletuksena näet, että Read, päivittää ja poistaa käyttöoikeudet ovat kaikkien saatavilla. Poista käyttöoikeuksia poistamalla valinnanasiaankuuluvat valintaruudut.

5. Klikkaa Kunnossapainiketta.

Katso myös

Mukauttaminen ABACUS liitäntä | Työskentely Oikeudet


Rekisteröityminen ABACUS

Navigointi: Reference>

Rekisteröityminen ABACUS

Lähetä kommentit tästä aiheesta.

Kun aloitat ABACUS (tai sen jälkeen väliaikaisen luvan on päättynyt) sinun täytyy rekisteröidä hakemus vastaan ​​Avolution lisenssi palvelimeen käyttämällä ainutlaatuista lisenssiavain mukaan paikallisviranomaisilta ABACUS järjestelmänvalvojan tai suoraan Avolution. Jos sinulla ei ole lisenssiavainta ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki .

Rekisteröityä lisenssiavain

1. Asennuksen jälkeen, aloittaa ABACUSjoko kaksoisnapsauttamalla työpöydän pikakuvaketta tai Windowsin Käynnistä-valikosta.

2. Vuonna Rekisteröinti avautuvassa kirjoita 26 merkki lisenssiavainmukaan paikallisviranomaisilta ABACUS Administrator tai Avolution tuki Tai napsauta Selaa ...ja valitse allekirjoitettu .dlsc tiedosto palannut Avolution tuki kohti Huomautus vaiheessa 4 alla. Jos käytät oikein allekirjoitettu .dlsc tiedosto ABACUS pitäisi aloittaa kohti Vaihe 5 alla.

Kärki

Voit liittää lisenssiavaimen osaksi dialogi kopioimalla se Windowsin leikepöydälle ja valitsemalla taustalla dialogi ja painamalla Ctrl + V.

Rekisteröinti dialogi

3. Klikkaa Kunnossaja jos lisenssin avain on voimassa ABACUS lisenssiavainABACUS yrittää nyt ottaa yhteyttä Avolution lisenssin palvelin todentaa lisenssiavaimen.

Huomautus

Jos saat Asennus on virheellinenrekisteröinti virhe on erittäin todennäköistä, että olet kirjoittanut koodin väärin. Kokeile kopioida ja liittää koodin kohti Vinkki edellä.

Yhteydenotto Avolution License Server

4. Klikkaa Kunnossaja sen jälkeen lyhyen aikaa ABACUS pitäisi rekisteröityä onnistuneesti.

Onnistunut Rekisteröinti

Huomautus

Jos saat Ei saa yhteyttä käyttöoikeuspalvelintarekisteröinti virhe on erittäin todennäköistä, että palomuuri (tai muita turvatoimia) verkossa estävät pääsyn Avolution lisenssi palvelimelle. Klikkaa Kunnossa, Tallenna .dlsc tiedosto paikalliseen koneeseen ja sitten jompikumpi email .dlsc tiedosto Avolution tuki ja odottaa lisäohjeitatai yritä kirjautua lisenssitiedoston itse käyttämällä seuraava URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Ei saa yhteyttä käyttöoikeuspalvelinta

Avaa License allekirjoittamisesta verkkosivun

Manuaalinen Lisenssi allekirjoittamisesta verkkosivu

Vaihtoehtoisesti, jos saat Tämä asennus koodia on käytetty useampia kuin sallii lisenssirekisteröinti virhe on todennäköistä, että paikallinen kone on rakennettu uudelleen, koska olet viimeksi rekisteröitynyt ABACUS tai yrität rekisteröityä toisen käyttäjän lisenssiavain. Ota yhteyttä paikalliseen ABACUS Administrator tai Avolution tuki .

Asennus koodi on jo käytetty

5. Klikkaa Kunnossaja jos ne on rekisteröity onnistuneesti ABACUS pitäisi avata kanssa Tervetuloa-näyttö .

Katso myös

Avolution tuki | Mitä ABACUS tehdä?


ABACUS Asennus Ennakkoedellytyksiä

Navigointi: Reference>

ABACUS Asennus Ennakkoedellytyksiä

Lähetä kommentit tästä aiheesta.

Tiedot Visio Tuonti ja Excel Import / Export

ABACUS edellyttää, että Microsoft Office asennetaan voidakseen suorittaa Excel Import / Export ja Visio Import toimintaa. Varmista, että Microsoft Office 2003 tai uudempion asennettu oikein. Jos sinulla edelleen ongelmia, yhteyshenkilö Avolution tuki .

Voidakseen täyttää Visio Tuo ja Excel Import / Export toiminnan ABACUS käyttää Microsoft Office Primary Interop Assembly (PIA: n). ABACUS tällä hetkellä mukana tulee kokoonpanot tarpeen tehdä Excel Import / Export ja Visio Tuo.

Tiedot SQL Server Tuonti

ABACUS edellyttää, että Microsoft SQL Server 20052008, 2008 R2, 2012 tai 2014asennetaan, jotta voidaan aloittaa uuden projektin SQL Server. Varmista, että Microsoft SQL Server 20052008, 2008 R2, 2012 tai 2014on asennettu oikein. Jos sinulla edelleen ongelmia, yhteyshenkilö Avolution tuki .

Virheet avaaminen 3D visualisaatioita

Jos ABACUS 3D Viewer ei toimi, saatat olla puuttuu SlimDX DirectX Runtime (asennettu osana koko ABACUS EXE asentaa). Tämä voi ladata tässä . Jos sinulla on 64bit Windows, saatat joutua asentamaan tämä .

Virheet Muokkaaminen ABACUS Asiakassuhde Raportit

Muokkaaminen ABACUS "Custom raportit vaatii Report Builder 3.0 on asennettu. ABACUS ja Report Builder on rakennettu Microsoftin .NET Framework 4.0, ja vaikka he molemmat eivät vaadi Microsoftin .NET Framework 3.5, Microsoft on määritetty virheellisesti Report Builder MSI vain edetä jos Microsoft .NET Framework 3.5 on asennettuna.

Niinpä Avolution on muokattu versio Report Builder asennus MSI-tiedosto, joka ei vaadi Microsoftin .NET Framework 3.5, tämä voi ladata tässä .

Alkuperäinen Microsoft Report Builder MSI voi ladata tässä . Jos sinulla ei vielä ole Microsoft .NET Framework 3.5 jossa se vaatii, voit ladata sen tässä . Huomautus: useita laitoksia, offline asentaa Microsoftin .NET Framework 3.5 alkaen tässä voi olla sopivampi.


Komentorivin

Navigointi: Reference>

Komentorivin

Lähetä kommentit tästä aiheesta.

Voit suorittaa erilaisia ​​ABACUS toimintoja suoraan komentoriviltä yleisin toimenpide on avata tiettyyn hankkeeseen tiedosto ja julkaista sen HTML.

Erityisesti komentoriviltä käyttö Abacus on seuraava;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ käyttäjä "USER" / pass "pass"]

Perustelu | Kuvaus
ProjectFile | ProjectFile voi olla joko ABACUS hankkeen tiedosto (.abacus), kirjasto tiedosto (.abacuslib), XML (.xml) tai MS Access DB (.mdb) ja määritetyn tiedoston joko avataan (jos .abacus tai .abacuslib ) tai uusi projekti on luotu (jos .xml tai .mdb-tiedoston).
OptionalFile | OptionalFile voi olla joko ABACUS käsikirjoitus (.abacusscript, .vb tai .cs), makro (.abacusmac) tai kirjastotiedosto (.abacuslib) ja määritetyn tiedoston joko ajaa avaamisen jälkeen ProjectFile (jos .abacusscript, .vb tai .cs tai .abacusmac) tai yksinkertaisesti avataan (jos .abacuslib).
/ ExitOnCompletion | Poistuu ABACUS ja tarvittaessa säästöä ja toimittaa muutoksia avoimeen .abacus hankkeiden loppuun mitään käsikirjoituksen tai makro. Huom: Tämä lippu on Case Sensitive joten muista käyttää isoja "O" ja "C" tekstissä esitetyllä.
/ DontShowDialogs | Estää ABACUS Enterprise Edition (EE) päivitysilmoituksen dialogit näyttämästä avattaessa projekti. Huom: Tämä lippu on Case Sensitive joten muista käyttää isoja "S" ja "D" tekstissä esitetyllä.
/ Käyttäjä "Käyttäjä" / pass "pass" | Käyttäjätunnus USER ja salasana pass käytetään kirjautua hankkeeseen, pakottavista kaikki tallennetut käyttäjätiedot. Huom: Double lainauksia on sijoitettu ympäri käyttäjä ja PASS liput ja kaksi lainausmerkkeihin voidaan käyttää paeta lainausmerkkeihin joko käyttäjän tai PASS lippuja.

Esim.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ ExitOnCompletion / dontShowDialogs / käyttäjä "Julkinen" / pass "123456"

milloin alkaa hakemistosta, johon ABACUS.exe binaarinen on sijaitsevat tahtoa avata Esimerkki hanke ja kirjaudu sisään käyttäjätunnuksella yleisölle salasana 123456 (kuvattu tässä ), Julkaista sen HTML ja sulje hankkeen kaikki ilman näkyviä valintaikkunat varrella (esimerkiksi "päivitys onnistui" tai "Ei päivityksiä saatavilla" Enterprise hankkeet).

Esim.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Luettelo Excel tuoda.vb"/ ExitOnCompletion / dontShowDialogs

milloin alkaa hakemistosta, johon ABACUS.exe binaarinen on sijaitsevat tahtoa avata Esimerkki hanke ja tuoda "Palvelimet (2014 todellinen) .xlsx" MS Excel-tiedoston "Palvelimet" luettelo "2014 Todellinen" arkkitehtuuri hankkeen ilman näkyviä valintaikkunat matkan varrella ja sitten sulkemalla hankkeen päätyttyä. Jos toiminta tekee muutoksia hankkeen sitten kun suljet muutokset tallennetaan paikallisesti ja jos Enterprise hanke sitoutunut Enterprise Server.

Huomautus

Muista käyttää oikeita lainausmerkki merkki koska on olemassa useita standardissa ASCII-merkistöä ja Windows komentorivi toimii vain oikein oikea. Oikea lainausmerkki merkki koodi on Desimaali 34 (Heksadesimaali 22).Tämä on mitä käytetään esimerkiksi yllä niin voit kopioida / liitä se sieltä.


Etusivu

ABACUS

Disclaimer

Avolution Pty Ltd tekee mitään takuita suhteessa tähän käsikirja ja sen sallimissa rajoissa lain, nimenomaisesti rajoittaa sen vastuuta rikkomisesta takuun jotka voidaan hiljaista korvaamiseen tämän oppaan toisella. Lisäksi Avolution Pty Ltd pidättää oikeuden muuttaa tämän julkaisun milloin tahansa joutumatta velvollisuutta ilmoittaa kenellekään henkilölle tarkistuksen.

Tekijänoikeus

Copyright 2001-2015Avolution Pty Ltd. Kaikki oikeudet pidätetään.

Tavaramerkit

Avolution Pty Ltd on tehnyt kaikkensa toimittamaan tavaramerkki tietoja yritysten nimet, tuotteet ja palvelut Tässä oppaassa mainitut. Tavaramerkkejä alla olivat peräisin eri lähteistä.

Microsoft Windows, Access, Visio, Excel, SQL Server ja Internet Explorerovat Microsoft Corporationin tavaramerkkejä.

Yleinen huomautus:

Jotkut käytetyt tuotenimet tässä käsikirjassa käytetään vain tunnistamistarkoituksessa ja saattavat olla omistajiensa tavaramerkkejä yrityksiä.

Joulukuu 2015Edition Avolution ABACUS Versio 4.5.

Manuaalinen Versio 1.0

Generated, painettu, ja sidottu Australiassa.