Was bedeutet ABACUS tun?

Navigation: Einführung in die ABACUS>

Was bedeutet ABACUS tun?

Senden Sie Kommentare Zu diesem Thema.

Für Hilfe in anderen Sprachen / Übersetzungen klicken Sie bitte auf Hier .

ABACUS nimmt die Vermutung-Arbeit aus, die sich mit Lösungen, Systeme, Software, Information, Technologie, Geschäftsprozesse und / oder ganze Unternehmen (gemeinsam als Architekturen bezeichnet). Es kann Ihnen helfen, sich pragmatisch zu entwerfen, zu überwachen, zu simulieren, analysieren und visualisieren Sie Ihre Architektur durch Modellierung ist es, die Analyse in intuitive Weise (zB Grafiken, Diagramme und 3D) und dann die Bewertung es gegen Ihre nicht-funktionalen Anforderungen.

Notiz

Nicht-funktionalen Anforderungensind die Anforderungen, die nicht direkten Bezug zu, wie ein Produkt funktioniert. Stattdessen sind sie besorgt, wie gut es funktioniert. Nicht-funktionalen Anforderungen sind unter anderem die Leistung, Offenheit, Evolvierbarkeit, Qualität, Skalierbarkeit, Modularität, usw. (im Gegensatz zu funktionalen Anforderungen wie, schalten Sie dieses Licht, wenn diese Schaltfläche klicken). Traditionell, nicht-funktionale Anforderungen waren schwierig - wenn nicht unmöglich - zu messen. In der Tat ist ABACUS das einzige Produkt, objektiv und quantifizierbar messen, können die ersten drei - Performance, Offenheit, und Evolvierbarkeit.

Einfach gesagt, Sie die Architektur und das, was Sie es benötigen zu tun geben. ABACUS sagt Ihnen dann, wenn sie werde tun, was erforderlich ist, und weist darauf hin, Schwachstellen oder Lücken.

ABACUS stützt sich auf mehr als 20 Jahre Systemforschung und viele weitere Jahre der etablierten Systemtheorie. Es gibt Ihnen quantifizierbar, zuverlässige, objektive Antworten, so dass Sie nicht auf die subjektive Einschätzung angewiesen sind.

ABACUS steht für Architecture-Based Analyse, Communikation und UERSTÄNDIGUNG von Systems. Es kann Ihnen bei allen großen Maßstab Architektur helfen, aber es ist in der Regel für vier (4) Dinge verwendet:

· Evolvingein aktueller Architektur. Zum Beispiel, wenn Sie Ihre bestehende Architektur fehlt Leistung, ABACUS wird die Architektur für Sie sichtbar zu machen, die Probleme zu identifizieren (Engpässe, etc.), dann sagen Sie, genauhow, um die Architektur zu verbessern.

· Entwerfeneine neue Architektur. Zum Beispiel, wenn Sie eine völlig neue Architektur benötigen, und Sie sind der Gestaltung selbst, ABACUS wird Ihnen sagen, genauwelche Komponenten Sie benötigen und wie sie miteinander verbunden werden sollen.

· Einkaufeine neue Architektur. Zum Beispiel, wenn Sie zur Angebotsabgabe auf die Gestaltung einer neuen Architektur genannt haben, und Sie können zwischen drei Entwürfe der Wahl sind, ABACUS wird Ihnen sagen, genauwelcher davon am besten Ihren Anforderungen entspricht.

· Die KombinationStrom bestehende Architekturen. Zum Beispiel, wenn Sie zwei oder mehr separate Architekturen kombinieren müssen, ABACUS wird euch führen.

Sehe auch

Wie Sie es tun (Übersicht) | Was ist Architektur? | Wie wird eine Architektur in ABACUS vertreten?

© 2001-2015 Avolution Pty Ltd. Alle Rechte vorbehalten.


Wie ABACUS (Übersicht) verwenden

Navigation: Einführung in die ABACUS>

Wie ABACUS (Übersicht) verwenden

Senden Sie Kommentare Zu diesem Thema.

Dieses Thema bietet einen grundlegenden Überblick über die mit der Verwendung von ABACUS verbundenen Aufgaben.

Das folgende Diagramm zeigt die Architektur-basierte Analyse-Prozess, die ABACUS sieht sich entwickelnden eine aktuelle Architektur in eine neue oder Zielarchitektur.

Die ABACUS Prozess

Um ABACUS verwenden:

1. Prüfung - Bevor Sie ABACUS verwenden, müssen Sie alle Informationen über die Architektur zu haben, und seine Anforderungen zu sammeln.

· Architektur - Identifizieren Sie die möglichen Komponenten der Architektur und wie sie interagieren. Es sollten nur wenige Bauteile auf der obersten Ebene sein. Diese werden als "wesentliche Bestandteile". Selbst komplexe Architekturen sollte weniger als 10 wesentliche Bestandteile. z.B. Die wesentlichen Komponenten der Architektur eines Versicherungsunternehmens können Politik, Quittungen, Ansprüche und Zahlungen.

· Bedarf- Sie müssen wissen, was von der Architektur, um festzustellen, ob es ausreichend ist, erwartet. z.B. Anzahl der Transaktionen pro Stunde.

· Wo finden Sie es? - Diese Informationen können von Anforderungsspezifikationen, Konstruktionsunterlagen, Interviews mit den Beteiligten, die zum Einsatz Code usw. kommen grundsätzlich jedes Material, das verfügbar ist ABACUS bietet Informationen über die Architektur.

2. Bevölkern -Verwenden Sie ABACUS auf Ihre Architektur-Modell und die Anforderungen der Architektur wird gegen gemessen werden soll.

· Architektur - In ABACUS Sie beginnen mit einem leeren Architektur - Sie haben bevölkern es. Das bedeutet, das die Architektur der Eingabe aller Informationen, die Sie oben gesammelt. Sie können Ihre Architektur manuell ausfüllen (mit dem Kontextmenü), oder Sie können es automatisch aufgefüllt (von Microsoft Visio, Excel, Access usw.). Typischerweise werden die obersten Ebenen (abstraktere) der Architektur wird manuell aufgefüllt werden, und die unteren Ebenen (konkreter) automatisch aufgefüllt werden.

· Bedarf - Wie Sie Ihre Komponenten und Verbindungen hinzufügen, können Sie deren Eigenschaften festlegen. In den meisten Fällen werden diese Eigenschaften die Anforderungen der Architektur. Zum Beispiel, wenn Sie eine 1250 MIPS Knoten / cluster haben, würden Sie den Knoten als eine Komponente hinzuzufügen, fügen Sie dann die Performance-Eigenschaft und einen Wert von 1250 MIPS zuweisen.

3. Analysieren - Verwenden Sie ABACUS elegant Analyse und Visualisierung der komplexen Struktur der Architektur. Sie Ihre Architektur in einer Reihe von Möglichkeiten, oder aus einer Reihe von Gesichtspunkten, einschließlich Diagramme, 3D und Explorer analysieren. Alternativ möchten Sie vielleicht einige spezifischere Ansichten wie folgt zu verwenden:

· Zeichnen Sie Ihre Architektur -, um die Leistung (Reaktionszeit, Bandbreite, etc.), Kosten (Balken-, Kreis-, etc.) oder Evolvierbarkeit (Fähigkeit Raum, Trade-off, etc.) Ansichten zu erhalten.

· Erstellen Sie einen Bericht auf Ihrer Architektur.

4. Simulieren - Verwenden Sie ABACUS auf Ihrer Architektur Performance, Verfügbarkeit, Kosten, Offenheit usw. zu simulieren

· Um dies zu tun, führen Sie eine der Simulatoren. ABACUS wertet Ihre Architektur gegen Ihre Anforderungendurch Durchführen einer Simulation. Es liest und analysiert die aktuelle Architektur, läuft Simulationen und berechnet einige neue Eigenschaften. Diese Eigenschaften werden dann zurück zu der Architektur gespeichert. Die neuen Eigenschaften sind die Daten, die Sie versuchen, zu analysieren sind, wie zB Auslastung, Antwortzeit, Bandbreite, Verfügbarkeit%, TCO usw.

5. Ingenieur- Verwenden Sie ABACUS an verschiedene "Was wäre wenn" -Szenarien zu beantworten und die Kontrolle der Entwicklung Ihrer Architektur. Engineering ist der Prozess des Wiederholens der Bevölkern - Analyse - Simulation Zyklus.

· An dieser Stelle können Siehabewahrscheinlich entwickelt ein Verständnis für die aktuelle Architektur und markiert die Bereiche, die Sie weiterentwickeln müssen. Sehr oft jedoch müssen Sie die Populate wiederholen - Analyse - Simulation Prozess mehrmals. Dies wird wahrscheinlich sein, weil es kann ein paar Iterationen, bevor Sie die Zielarchitektur. Auch, wenn Ihre Architektur ist sehr komplex, können Sie den Prozess für jede architektonische "level" zu wiederholen.

6. Planendie Zukunft Ihrer Architektur unter Verwendung der Informationen, die von ABACUS zur Verfügung gestellt.

Notiz

Wenn Sie nicht versuchen, eine bestehende Architektur zu entwickeln sind, müssen Sie möglicherweise einige Schritte wiederholen mehrmals, und in einer anderen Reihenfolge. Es hängt davon ab, was Sie versuchen, do. Zum Beispiel, wenn Sie mit dem Entwurf einer neuen Architektur sind, werden Sie wahrscheinlich nur Ihre Architektur bevöl einmal, und dann verwenden ABACUS über einen langen Zeitraum, um die zukünftige Entwicklung (en) der Architektur führen. Auf der anderen Seite, wenn Sie den Kauf einer neuen Architektur und haben mehrere Alternativen zur Auswahl, müssen Sie entdecken, und füllen Sie für jede der Alternativen und dann Analysieren und Simulieren jedes unabhängig voneinander, bevor eine endgültige Vergleich von der Ende.

Sehe auch

Was bedeutet ABACUS tun? | Was ist Architektur? | Wie wird eine Architektur in ABACUS vertreten? | Auffüllen der Architektur | Analyse Ihrer Architektur | Simulation von Ihrer Architektur


Was ist Architektur?

Navigation: Einführung in die ABACUS>

Was ist Architektur?

Senden Sie Kommentare Zu diesem Thema.

Architektur ist eine abstrakte Konzept- Keine physikalische Ding. Es ist eine reiche und umfassende Beschreibung oder Verständnis der Struktur eines Systems - Erfassung der Komponenten und wie sie verbunden sind (interagieren). Weil die Vorstellung der Architektur ist so allumfassend, ist es grundlegend, die Kosten, die Verfügbarkeit, evolvability, Offenheit und die Leistung des Systems. Ein Sound-Architektur ist eine Voraussetzung für ein Soundsystem.

In ABACUS, modellieren Sie Ihre Architektur. Der Einfachheit halber nennen wir diese Architekturmodell eine Architektur.

Das folgende Diagramm zeigt eine typische Architektur 5Komponenten (in einer Hierarchie) um 2 Verbindungen verbunden sind. Die Etiketten zeigen die Namen angesichts der verschiedenen Teile der Architektur in ABACUS.

Eine einfache Architektur

ABACUS ist der Auffassung, all diese Dinge, um Teil der Architektur werden:

· Componentsstellen die Einheiten Ihrer Architektur die Sie als "Dinge" beschreiben könnte. Für eine Versicherungsgesellschaft, könnten die Komponenten der Systeme für die Verarbeitung Politik, Forderungen, Zahlungen und Einnahmen sein.

· Anschlüsserepräsentieren die Beziehungen zwischen diesen Komponenten. Zum Beispiel in einem Versicherungsunternehmen, Quittungen sind für gültige Richtlinien erzeugt werden, sind Ansprüche gegen die gültigen Grundsätze sowie berechtigte Ansprüche führen zu Zahlungen. Wenn das Denken architektonisch - insbesondere bei Verwendung von ABACUS - Anschlüsse sind ebenso wichtig wie die Komponenten, und sie sind mit in nahezu identischer Weise behandelt.

· Alles, was in der Baumstruktur haben kann, Immobilien. Objekte sind Dinge wie die Art und Weise Sie Ihr System benötigen, um durchzuführen, die Anzahl der Zeilen Code hat der prozentuale Anteil dieser Zeilen, die Kommentare sind usw. ABACUS hält all diese Dinge, um ein Teil der Architektur.

· Durch die Nutzung Hierarchien(d.h. Subkomponenten und Teilverbindungen), Können Sie Informationen zu verstecken und de-komponieren Sie Ihre Architektur. Die ABACUS Architekturmodell ist äußerst flexibel. Jede Komponente auf jeder Ebene kann auf jede andere Komponente in jeder anderen Ebene durch jede Verbindung auf jeder Ebene stehen.

· Befestigungist die Operation, durch die Komponenten Anschlüsse werden, um die Verbindung gebundenRollen. Ports und Rollen sind die Schnittstelleszwischen den Komponenten und Verbindungen. Sie werden verwendet, um Verbindungen zu den Komponenten zu befestigen. Anschlüsse haben eine Quelle und einer Senke Rolle(Vereinfachung des Datenflusses von der Quellkomponente auf das Senkenkomponente)und konzeptionell, haben Komponenten-Ports. Der Einfachheit halber wird jedoch in ABACUS Komponente Anschlüsse sind nicht gezeigt und die Verbindungsrollen sind direkt mit den Komponenten selbst verbunden.

· Komponenten und Anschlüsse sind von einem bestimmten Art. Dies ist vor allem zum Zwecke der Einstufung. Zum Beispiel die Politik, Forderungen, Zahlungen und Einnahmen sind Komponenten des Typs "System". Die gültigen Richtlinien, berechtigte Ansprüche, etc. sind Verbindungen des Typs 'Transaktion'. Der Typ an eine Komponente oder Verbindung zugeordnet bietet eine Vorlage für die Eigenschaften und Standards hat. Zum Beispiel könnte ein Server-Komponente Art haben "Make & Model ' Standardund eine IP-Adresse Eigentum. Im Gegensatz zu anderen Hartwerkzeuge mit einer grundlegenden relationalen Datenbasis (RDB) Back-End, in ABACUS können Sie frei Ihre eigenen neuen Typen und ordnen Sie Ihre eigenen Kombinationen von Eigenschaften und Normen zu ihnen.

· Standardbibliotheken von Eigenschaften können festgelegt und, etwas anderes in der Architektur zugeordnet werden. Diese Bibliotheken sind bekannt als Standards. Durch die Nutzung Standards, Müssen Sie nur auf bestimmte Systeme Eigenschaften zu sammeln - die Standard-Eigenschaften sind schon da. Zum Beispiel die Standard-Leistungsmerkmale von Microsoft Windows 2000 können in jede beliebige Komponenten werden unter dem Betriebssystem Microsoft Windows 2000 zugeordnet werden.

Sehe auch

Wie wird eine Architektur in ABACUS vertreten? | Was bedeutet ABACUS tun? | Wie Sie es tun (Übersicht) | Erstellen einer neuen Art


Die ABACUS-Schnittstelle

Navigation: Einführung in die ABACUS>

Die ABACUS-Schnittstelle

Senden Sie Kommentare Zu diesem Thema.

Wenn Sie ABACUS starten, werden Sie den Hauptbildschirm, der leer bis auf die Menüs und Werkzeugleiste oben, ein leeres Fenster Explorer und dem Titel-Bar ist zu sehen. Dieser Bildschirm wird das Zentrum der Interaktion mit ABACUS sein.

Die wichtigsten Elemente sind:

· Die Hauptmenüs

· die Symbolleisten

· das Rechtsklick-Menü

· die Forscher und Eigenschaftsfenster

· in der Statusleiste

Die Hauptmenüs

Die Menüs sind in einer logischen Reihenfolge angeordnet.

Die Menüs werden wie folgt beschrieben;

· Menü Datei- Das Menü Datei können Sie erstellen, öffnen, schließen, speichern, exportieren und ABACUS-Dateien zu veröffentlichen. Es erlaubt Ihnen auch, um zu erstellen, öffnen, schließen und speichern ABACUS Bibliotheksdateien.

· Menü Bearbeiten- Das Menü Bearbeiten können Sie schneiden, kopieren, einfügen, löschen, umbenennen, suchen und sortieren Elementeund Undo / Redo-Operationen.

· Menü Ansicht- Das Menü Ansicht ermöglicht es Ihnen, Öffnen oder Schließen der verschiedenen Schnittstellen Fenster und StatusleisteNavigieren Sie vorwärts und rückwärts, gehen Sie zu bestimmten Ansichten und Dashboards verwalten.

· Menü Einfügen- Das Menü Einfügen können Sie neue hinzufügen, Standards, Vorlagen, Arten, Elemente, AnsichtPunkts, Kataloge, Abbildungen, Charts, Berichte und Matrizen.

· Menü Analyse- Die Analyse-Menü können Sie Auswertungen gegen eine Architektur einschließlich laufen; Leistung, Kosten, Zuverlässigkeit, Modularität und Offenheit.

· Menü Extras- Das Menü Extras können Sie die Skript laufen, gesetzten Ziele für die Architekturund durchzuführen, und Architektur 'diff'. Sie können auch Optionen des Programms zu modifizieren und die Benutzeroberfläche von dem Werkzeug-Menü.

· Menü Fenster- Das Menü Fenster erlaubt Ihnen, anzudocken, zu arrangieren, Show und die Fenster, die Sie geöffnet haben verstecken.

· Hilfe-Menü- Aus dem Menü Hilfe Sie diese ABACUS Hilfedatei zugreifen können. Sie können die Website zugreifen, sehen Sie Ihre Lizenz Vereinbarung und allgemeine Informationen über ABACUS darunter die Version der Software und ABACUS Unterstützung und Kontaktdetails anzuzeigen. Sie können uns über das Problem zu Benachrichtigungsseite bereitzustellen. Falls erforderlich, können Sie einen Registrierungsschlüssel über das Hilfe-Menü zu gelangen.

Das ist die Reihenfolge Sie in der Regel zu folgen, wenn Sie die Durchführung sind Ihre Aufgaben;Sobald Sie erstellt oder geöffnet haben, ein Datei, Werden Sie in der Regel zu füllen Ihre Architektur, dann Aussichtes (in Explorer, Grafiken, 3D, Charts, etc.). An dieser Stelle werden Sie entweder ein Gutachter, Oder Sie werden den Prozess mit der gleichen Architektur oder einer anderen Architektur zu wiederholen. (Sehen Wie ABACUS (Übersicht) verwenden für weitere Details.)

Werfen Sie einen Blick über die Hauptmenüs und versuchen Sie sich vorzustellen, wie Sie sie für Ihr System zutreffen.

Notiz

Sie können Passen Sie Ihre Menüs jederzeit.

Die Symbolleisten

Standardmäßig gibt es die folgenden Symbolleisten;

· der Hauptsymbolleiste -

· das Simulation Symbolleiste -

· Werkzeugkasten Ansicht -

· das Diagramm-Toolsbar (wenn ein Diagramm ist offen) -

· das Makro Aufnahme Symbolleiste -

Werfen Sie einen Blick über die Tasten auf jeder Symbolleiste schwebt über ihnen, um das Werkzeug-Spitze (Shortcut-Taste) zu sehen.

Notiz

Nur bestimmte Tasten aktiv sein, je nachdem, was Sie im Explorer-Fenster ausgewählt haben, und Sie können Fertigen Sie Ihre Symbolleisten jederzeit.Zusätzlich wird die Schaltfläche "Validate / Projekt Constraints Prüfen" auf der Hauptsymbolleiste und die Schaltflächen auf der Symbolleiste Simulation wird aufzeigen, Rot wenn eine Änderung der zugrunde liegenden Repository erfordert eine erneute Validierung des Projekts oder einer Re-Simulation von diesem Simulator auf. Zeigen Sie auf die Schaltfläche, um zu sehen, welche Architekturen betroffen sind.

Die Rechtsklick-Menü

Die wichtigsten Menüs und Symbolleisten sind nichtfür alles verwendet, though. Oft ist es bequemer, die Rechtsklick-Kontextmenü für verschiedene Operationen verwenden. (Auch nicht alle durch Rechtsklick zur Verfügung stehenden Befehle sind über die Hauptmenüs, Symbolleisten oder Tastaturbefehle zur Verfügung.)

Zum Beispiel, wenn Sie eine Datei erstellt haben, und Sie haben ein Baumdiagramm von Ihrer Architektur, ist es besser, einen Rechtsklick auf Architekturen in der Baumstruktur, um eine neue Architektur. Ebenso sollten Sie einen Rechtsklick auf Komponenten, um eine neue Komponente hinzufügen. Rechts-Klick auf ein paar Dinge in der Baumstruktur zu sehen, was Sie tun können.

Spitze

Im Allgemeinen werden Sie die Hauptmenüs verwenden, um die weitere High-Level-Aufgaben wie die Bewertung Ihrer Architektur durchzuführen,. Die Low-Level-Aufgaben - wie das Hinzufügen von einzelnen Komponenten und Anschlüsse - werden mit den Symbolleisten und / oder Rechtsklick-Menü erfolgen.

Die Explorer und Eigenschaften-Fenster

Wenn Sie öffnen oder erstellen Sie eine Datei, wird ein Baumdiagramm im Explorer-Fenster angezeigt werden soll. Es ist ein Fenster in die Architektur. Und wie Sie Elemente innerhalb des Explorer-Fensters wählen drei anderen Fenstern; Die allgemeinen Eigenschaften, Referenzenund Eigenschaften-Fenster wird aktualisiert, um detaillierte Informationen über Ihre Auswahl zu reflektieren.

Notiz

Die allgemeinen Eigenschaften, Referenzenund Properties Fenster sind standardmäßig ausgeblendet. Sehen Anpassen der Schnittstelle für die, wie man sie sichtbar machen und möglicherweise lassen sie permanent angezeigt.

Während Sie den Aufbau Ihrer Architektur bist, sind die Explorer und Eigenschaften-Fenster der nützlichste Darstellung. Weil sie brach zusammen und erweitert werden, wie erforderlich ist, und sie müssen nicht umständlich geworden.

Das Explorer-Fenster hat einen Baum (und Statusleiste) und die Eigenschaften-Fenster haben 5Sektionen:

· Art

· Standards

· Beschreibung

· Referenzen

· Immobilien

ABACUS ist der Auffassung, all diese Dinge, um ein Teil der Architektur.

Baum

Dieser Abschnitt weist eine Baum in 3 Bereiche eingeteilt wie folgt:

1. Metamodell

· Standards- Wenn zahlreiche Komponenten haben den gleichen Satz von Eigenschaften, können Sie das Set up-front zu definieren, und dann einfach ordnen Sie diese Komponenten. Das gleiche gilt für Verbindungen, und jedes der anderen Elemente. Diese Sätze von Standard-Eigenschaften sind in die gespeicherte StandardsZweig des Baumes. Stattdessen definieren jede Eigenschaft für jede Komponente und jede Eigenschaft für jede Verbindung etc, nur zuordnen Standard. Zum Beispiel die Standard-Merkmale von Unix-HP / UXkann als gerettet werden Standard und auf alle Komponenten unter Verwendung der zugewiesene Unix-HP / UXBetriebssystem wie für das gezeigte OS01 Server im Screenshot über.

· Typen - Dieser Zweig des Baumes ist eine Bibliothek für die Arten von Komponenten und Verbindungen Sie verwenden können. Typen werden verwendet, um die Meta-Modell für Ihre Architektur und für die Klassifizierung und Filterung bei der Anzeige Ihrer Architektur zu definieren. Sie eine Vorlage für bestimmen auch, was Standards, Eigenschaften und Einschränkungen Ihrer Komponenten / Anschlüsse können.

· Aussichtspunkte- AussichtPunkts kann aus bestehenden Diagramme erstellt werden und können verwendet werden, um neue Diagramme zu erzeugen.Sie sind Diagramm Schablonen.

· Vorlagen - Vorlagen Shop wiederverwendbare Mustern der Komponenten und Verbindungen zusammen mit der Art, in der sie dargestellt sind oder angezeigt. Sie können als "mini" Architekturen oder Lösungen, die in die bestehenden Architekturen angeordnet werden kann gedacht werden,.

2. Architekturen -Die Architekturen Zweig des Baumes ist, wo Sie bauen die Architektur (n) Ihres Systems. (Dies wird als Auffüllen der Architektur). Sie können eine beliebige Anzahl von Architekturen in einem einzigen ABACUS-Datei haben.

3. Dashboards - Die Dashboards Zweig des Baumes ist, wo Sie Zugriff auf alle gespeicherten Dashboards für das Projekt.

Notiz

Angebote im Explorer-Baum wurden, deren Berechtigung aktualisieren entfernt (dh sie schreibgeschützt sind) sind grau dargestellt.

Art

Dieser Abschnitt zeigt die spezifische Komponente oder Verbindungstyp des aktuell ausgewählten Element im Baum.

Standards

Dieser Abschnitt enthält eine Liste der Standards für das aktuell ausgewählte Element im Baum.

Beschreibung

Dieser Abschnitt enthält eine kurze Beschreibung des ausgewählten Elements in der Baumstruktur. Alle damit verbundenen Hyperlinks können auch zu diesem Abschnitt hinzugefügt werden. Dazu gehören Websites oder lokalen absolute Pfade, die auf Informationen über die gegebenen Element weiter. Mehrere Zeilen sind ebenfalls erlaubt. Gültig Hyperlinks brauchen, um mit einem der 5-Strings beginnen; http: //, https: //, ftp: //, file: /// oder mailto :.

Spitze

Für Hyperlinks mit Leerzeichen können Benutzer in der URL oder Pfad eingeben, wählen Sie den gewünschten Text ein und Rechtsklick| Hyperlink. Dadurch werden alle Räume ändern % 20so dass die ganze URL oder Pfad wird korrekt funktionieren.

Erstellt und geändert

Diese Abschnitts liefernder Benutzer und Datum / Uhrzeit für die Erstellung und letzten Änderung, die aktuell ausgewählte Element im Baum.

Referenzen

Dieser Abschnitt enthält eine Liste der ausgehenden und eingehenden Komponenten für das aktuell ausgewählte Element im Baum.Es zeigt auch die Diagramme, 3D und Tabelle Aussicht, dass die aktuell ausgewählte Element in angezeigt wird. Wenn ein Diagramm ausgewählt wird, zeigt es die Viewpoint ggf. für das Diagramm und für Ansichten im Allgemeinen ist es keine Dashboards der Blick erscheint zeigt. Und wenn ein Standard- wird in der Baumstruktur ausgewählt ist zeigt die Verwendung des Standards durch Typen, Komponenten und Verbindungen.

Immobilien

Dieser Abschnitt ist in dem Sie die Merkmale definieren Die Elemente innerhalb Ihre Architektur, wie die Art, die Anzahl der Codezeilen, die Sie benötigen, um es durchzuführen hat, der Anteil dieser Linien, Kommentare, etc. sind

Die "Input" und "Output" Eigenschaften der vorgefertigten Simulatoren wird in dem Eigenschaftsfenster mit einer Eigenschaft Eingabezeile Icon zur Auswahl angezeigt ( [image] ) Und Ausgabe-Symbol ( [image] ), Die jeweils mit einem Tooltipp anzeigen, welche vorgefertigte Simulator Eigentum ist verwandt, zB "Modularität Output" oder "Performance-Input '. Der Pfeil auf der Ausgangs Symbole markieren Rot ( [image] ), Wenn die Eigenschaft ist veraltet aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository mit dem Simulator erfordert re-Simulation gemäß der Rot Hervorhebung Simulation Symbolleiste .

In der Statusleiste

Der linke Teil der Statusleiste zeigt den vollständigen Pfad zu der derzeit im Fokus befindlichen Depotelement entweder im Explorer-Fenster oder auf die ausgewählte Diagramm Leinwand. Dies ist so, daß die genaue Stelle im Repository Hierarchie für das betreffende Element immer leicht bestimmt werden. Der rechte Teil der Statusleiste zeigt verschiedene Betriebsmeldungen wie 'Open ABACUS Datei Erfolgreich "und" Cost Calculation Completed ".

Sehe auch

Wie Sie es tun (Übersicht) | Anpassen der Schnittstelle | Was ist Architektur? | Wie wird eine Architektur in ABACUS vertreten? | Arbeiten mit ABACUS Dateien


Individuelle Anpassung des ABACUS-Schnittstelle

Navigation: Einführung in die ABACUS>

Individuelle Anpassung des ABACUS-Schnittstelle

Senden Sie Kommentare Zu diesem Thema.

Sie können das Aussehen und das Verhalten der ABACUS-Schnittstelle in vielerlei Hinsicht ändern. ABACUS enthält mehrere vordefinierte Einstellungen Kombinationen, die Sie verwenden, um eine Gruppe von Anpassungen auf die Oberfläche anzuwenden. Außerdem können Sie individuelle Anpassungen, um Elemente wie Fenster, Symbolleisten, Tastenkombinationen und verschiedene Displays Optionen machen.

Ordnen und Dock Windows-

Sie haben viele Möglichkeiten zum Anordnen von Fenstern innerhalb der Schnittstelle für ABACUS, einschließlich der folgenden:

· Tab-Dock-Fenster.

· Dockfenster an den Rand eines Rahmens in der Schnittstelle.

· Minimieren Sie Tool-Fenster entlang der Kante der Schnittstelle.

· Zurücksetzen Fenster Platzierung auf den Standard-Layout.

Docking-Windows-

Wenn ein Fenster andockbar ist, kann sie auf einer Seite eines Rahmens in der Schnittstelle befestigt werden oder es kann auf Registerscheiben in dem Rahmen angeordnet sein. Ein Leitfaden Diamanten angezeigt, wenn Sie Fenster an eine andere Position in der Schnittstelle ziehen von ihrem aktuellen Speicherort. Die Führungs Diamanten können Sie schnell wieder andocken ein Fenster auf eine der vier Seiten des Rahmens oder in der Mitte als Registerteilfenster. Wenn ein Fenster nicht angedockt ist oder nicht angedockt, schwimmt es auf der anderen Fenster.

Um Fenster andocken

1. Klicken Sie auf das Fenster, das Sie andocken wollen, um ihn zu aktivieren.

2. Auf dem FensterKlicken Sie im Menü Dockable.

3. Ziehen Sie das Fenster von seiner aktuellen Position in Richtung der Mitte des Rahmens Sie es mit andocken soll.

Ein Leitfaden Diamanten angezeigt. Die vier Pfeile der Diamantspitze in Richtung der vier Kanten des Rahmens und der Mitte stellt die Registerteilfenster.

Spitze

Um eine andockbare Fenster, ohne ihn einrasten lassen, drücken Sie STRG gedrückt, während Sie es verschieben.

4. Wenn das Fenster Sie ziehen die Position, an der Sie es andocken möchten erreicht, bewegen Sie den Mauszeiger über den entsprechenden Abschnitt der Führungs Diamant. Ein Überblick über das Fenster, in dem bezeichneten Gebiet.

5. Um das Fenster in der angegebenen Position zu verankern, die Maustaste loslassen.

Wenn beispielsweise Forscherist am linken Rand der Schnittstelle angedockt ist und Sie ihn auf der rechten Kante andocken möchten, ziehen würden Forscherin Richtung der Mitte der Schnittstelle, bewegen Sie den Mauszeiger auf der rechten Seite der Führungs Diamant, und lassen Sie die Maustaste los.

Minimierung von Windows

Fenster (ob es sich um Windows-Tool - auf das Erscheinen AussichtMenü oder Dokumentfenster - auf das Erscheinen FensterMenü) unterstützen eine Funktion namens Auto Hide. Auto Hide können Sie mehr aus Ihrer Architektur zu einer Zeit durch Minimierung der Fenster an den Rändern der Schnittstelle bei Nichtgebrauch zu sehen.

Auf Auto Hide schalten

1. Klicken Sie auf das Fenster, das Sie sich zu verstecken, um sie zu aktivieren möchten.

2. Auf dem FensterKlicken Sie im Menü Auto Hide.

- oder -

2. Klicken Sie auf das Symbol Reißzwecke auf die Titelleiste des Fensters.

Aktiviert Auto Hide

Wenn ein automatisch ausgeblendet Fenster den Fokus verliert, es gleitet automatisch wieder zurück zu seiner Registerkarte auf den Rand der Schnittstelle. Während ein Fenster automatisch ausgeblendet werden, sind ihre Namen und das Symbol an einer Lasche an der Kante der Oberfläche sichtbar. Um ein automatisch ausgeblendet Fenster anzuzeigen, bewegen Sie den Mauszeiger über die Registerkarte. Das Fenster gleitet zurück in Sicht und ist einsatzbereit.

Notiz

Ein Fenster, das automatisch ausgeblendet ist, kann nicht angedockt werden. Um ein Fenster anzudocken, müssen Sie deaktivieren Auto Hide wie unten beschrieben.

So schalten Sie Auto Hide

1. Klicken Sie auf das Fenster, das Sie sichtbar um sie zu aktivieren behalten möchten.

2. Auf dem FensterKlicken Sie im Menü Auto Hideum das Häkchen zu entfernen.

- oder -

2. Klicken Sie auf das Symbol Reißzwecke auf die Titelleiste des Fensters.

Auto Hide Für die Behinderte

Spitze

Windows, das Auto Hide aktivierter zeitweise in den Blick zu gleiten, wenn das Fenster den Fokus hat haben. Um das Fenster wieder auszublenden, wählen Sie ein Element außerhalb des aktuellen Fensters. Sobald das Fenster den Fokus verliert, gleitet es wieder aus dem Blickfeld.

Zurücksetzen von Windows-Layouts

Sie können die Schnittstelle zur Standard-Fensterlayout mit Hilfe der Rück Fensterlayout zurücksetzen Befehl. Wenn Sie diesen Befehl ausführen, werden die folgenden Aktionen:

· Alle Fenster sind auf ihre Standardpositionen bewegt.

· Fenster, die in der Standard-Fensterlayout geschlossen werden durch den Befehl geschlossen.

· Fenster, die in der Standard-Fenster-Layout geöffnet werden mit dem Befehl geöffnet.

· Fenster, die versteckt sind / in der Standard-Fenster-Layout sichtbar werden durch den Befehl versteckt / sichtbar gemacht.

Um Fenster Platzierung auf den Standard-Layout zurücksetzen

1. Auf dem Windows-Klicken Sie im Menü Fensterlayout zurücksetzen.

Anpassen von Menüs und Symbolleisten

Sie können das Layout, die Position und Inhalt der Menüs und Symbolleisten in der Oberfläche ändern. Sie können auch Tasten, um Symbolleisten hinzufügen und ändern Sie den zugewiesenen Symbol für jede Taste.

Erstellen Sie neue Symbolleisten

Um eine neue Symbolleiste zu erstellen

1. Auf dem ToolsWählen Sie im Menü Anpassen.

2. im AnpassenDialogfeld, wählen Sie die Symbolleisten Tab.

3. Wählen Neu.

4. im Neu ToolbarDialogfeld, geben Sie einen Namen für die Symbolleiste.

5. Wählen OK.

Um eine Befehlsschaltfläche, um ein Menü oder eine Symbolleiste hinzufügen

1. Auf dem ToolsWählen Sie im Menü Anpassen.

2. im AnpassenDialogfeld, wählen Sie die Befehle Tab.

3. Wählen Sie eine Kategorie und ziehen Sie einen Befehl aus dem Dialogfeld, um das Menü oder Symbolleiste.

4. Wählen Nah dran.

Spitze

Halten Sie die Alt-Taste können Sie schnell anpassen Befehle, als ob das Dialogfeld Anpassen geöffnet war.

Sehe auch

Die ABACUS-Schnittstelle


Arbeiten mit ABACUS Dateien

Navigation: Einführung in die ABACUS>

Arbeiten mit ABACUS Dateien

Senden Sie Kommentare Zu diesem Thema.

Ein ABACUS-Datei ist ein Container für ein Modell Ihres Architektur . Innerhalb eines einzelnen ABACUS-Datei können Sie eine beliebige Anzahl von Architekturen Modellierung beliebig oft.

Beim ersten Öffnen ABACUS, es gibt keine Dateien zu öffnen. Um von Ihrer Architektur zu arbeiten, müssen Sie entweder eine neue Datei, oder öffnen Sie eine vorhandene Datei.

Wenn Sie öffnen oder erstellen Sie eine neue Datei, wird ein Baum im Explorer-Fenster automatisch angezeigt. Das Explorer-Ansicht zeigt Ihnen Ihre Architektur auf dem Laufenden. Wenn Sie die Datei schließen, wird der Baum im Explorer-Fenster auch verschwinden.

Um eine neue Datei zu erstellen ABACUS

1. Auswählen Datei| Neu ...

2. In dem Dialogfeld Neues Projekt, das angezeigt wird (siehe unten) Wählenentweder erstellen Sie ein leeres Modell, ein Modell aus einer Standard-ABACUS-Bibliothek , Ein Modell aus einer benutzerdefinierten ABACUS Bibliothek, ein Modell aus XML, MS Access , MS Visio , MS Excel , MS SQL Server , ein Unternehmen Server Modell oder eine benutzerdefinierte ABACUS-Bibliothek (.abacuslib Datei).

3. Klicken Sie auf OKTaste und befolgen Sie alle Dialogfelder, die angezeigt werden können.

Spitze

Sie werden nicht aufgefordert, die Datei zu benennen, bis Sie speichern oder schließen Sie es werden. Es ist eine gute Idee, um Ihre Dateien, sobald Sie sie erstellen zu speichern. Dann werden Sie sich keine Gedanken über die Namensgebung später im Prozess, wenn Sie auf andere komplexe Dinge konzentriert sind (wie das Auffüllen Ihrer Architektur) zu kümmern.

Erstellen eines neuen Projekts

ABACUS Standard Libraries

ABACUS unterstützt über 100 öffentlichen Frameworks und Notationen von denen einige unten. Bei der Wahl, um ein neues Projekt zu erstellen aus einer Standardbibliothek Benutzer einen schnellen Einstieg in die Modellierung in einem Rahmen zu etablieren die volle Nutzung aller definierten Elementtypen, Attribute, Notationen, Aussichtspunkte und Vorlagen oder Mustern. Weitere Standard-Bibliotheken sind durch die Avolution Gemeinschaft frei verfügbar Hier .

Neues Projekt Standard Library

Um eine neue Datei zu speichern ABACUS

1. Auswählen Datei| Speichern als

Spitze

Dateinamen können beliebig lang sein, und kann keine alphanumerische Zeichen und Leerzeichen enthalten. (?) | () Sie können nicht die Tilde (~) Zeichen, das Rohr enthalten Zeichen, das Fragezeichen oder die Zeichen in der Regel für die Pfadbeschreibung wie der Backslash (\) - nur als Bestandteil des Pfades.

Um eine bestehende ABACUS-Datei zu öffnen

1. Auswählen Datei| Öffnen

Notiz

Wenn Sie von einer Netzwerkfreigabe, die bereits an einen anderen Benutzer geöffnet Öffnen einer Datei wird ABACUS mit Nur-Lese-Zugriff zu ermöglichen. Bei der Verwendung von ABACUS mit Nur-Lese-Zugriff, werden Sie nicht in der Lage, Schreib-Operationen durchzuführen, wie beispielsweise Auffüllen der Architektur und läuft Gutachter sein. Sie können aber sehen Sie Ihre Architektur mit der Explorer-Ansicht und 3D-Ansichten.

Sehe auch

Wie wird eine Architektur in ABACUS vertreten?


Wie wird eine Architektur in ABACUS vertreten?

Navigation: Einführung in die ABACUS>

Wie wird eine Architektur in ABACUS vertreten?

Senden Sie Kommentare Zu diesem Thema.

In ABACUS, modellieren Sie Ihre Architektur. Der Einfachheit halber nennen wir diese Architekturmodell eine Architektur.

Das folgende Diagramm zeigt, wie eine typische Architektur 5Komponenten (in einer Hierarchie) von 2 Anschlüssen verbunden wäre in ABACUS vertreten sein.

Wie eine einfache Architektur ist in ABACUS vertreten

Sie können eine beliebige Anzahl von Architekturen in einem einzigen ABACUS-Datei haben.

Die erste Architektur im Baum

In der Regel können Sie eine neue Architektur schaffen würde, wann immer Sie eine Änderung auswerten möchten. Zum Beispiel können Sie Ihre bestehende Architektur erste Modell würde - das wäre die erste Architektur im Baum. Sie konnten es nennen 'Aktuell'.

Der Zweite

Wenn Sie zu modellieren und eine Änderung an Ihrer bestehenden Architektur auswerten möchten (zB erhöhte Anforderungen) würden Sie eine neue Architektur zu schaffen. Der einfachste Weg, dies zu tun wäre, um eine Kopie der 'Aktuell' zu erstellen und benennen Sie sie "Evolution 1 Versuch 1 '. Dies wäre die zweite Architektur im Baum sein. Wenn Ihr Auswertungen der 'Evolution 1 Versuch 1' erfolgreich sind, können Sie sie umbenennen, um einfach "Evolution 1 '.

Der dritte

Wenn 'Evolution 1 Versuch 1' nicht Ihren Anforderungen gerecht zu werden, können Sie eine Kopie davon zu erstellen, benennen Sie sie in "Evolution 1 Versuch 2", und versuchen Sie es erneut. Dies würde die dritte Architektur in dem Baum ist.

Sehe auch

Was bedeutet ABACUS tun? | Wie Sie es tun (Übersicht) | Was ist Architektur? | Arbeiten mit ABACUS Dateien | Erstellen oder Duplizieren einer Architektur


Hilfe in anderen Sprachen

Navigation: Einführung in die ABACUS>

Hilfe in anderen Sprachen

Senden Sie Kommentare Zu diesem Thema.

ABAKUS Hilfe ist in verschiedenen anderen Sprachen / Übersetzungen und können von den folgenden Links heruntergeladen werden.

Zu ersetzen Sie den aktuellen ABACUS-Hilfedateimit einem übersetzten Hilfedatei bitte wie folgt vor:

1. Speichern Sie die Hilfedatei aus dem entsprechenden Link unten.

2. Benennen Sie die Hilfedatei zu ABACUS.chm.

3. Öffnen Sie die Datei mit einem Doppelklick auf, und wenn eine "Open File - Warnung Sicherheit" Dialog erscheint, dann deaktivieren Sie die Option "Immer vor dem Öffnen der Datei fragen" und klicken Sie auf Öffnen.

4. Schließen Sie die Datei.

5. Ersetzen Sie die ABACUS.chm Datei in dem Ordner ABACUS Programmdateien, in der Regel "C: \ Program Files \ Avolution \ ABACUS" oder "C: \ Program Files(x86)\ Avolution \ ABACUS".

Notiz

Kontextsensitive Hilfe wird auch weiterhin mit den übersetzten Hilfedateien zu arbeiten.

ABACUS-Hilfe-Dateien in anderen Sprachen:

· Arabisch / العربية .

· bulgarisch / български .

· Vereinfachtes Chinesisch) / 中文 (简体) .

· tschechisch / Česká .

· dänisch / Dansk .

· estnisch / Eesti .

· finnisch / Suomen .

· Französisch / Français .

· Deutsche / Deutsch .

· ungarisch / Magyar .

· isländisch / isländisch .

· Indonesier / Indonesien .

· Italienisch / Italiano .

· japanisch / 日本 の .

· lettisch / Latvijas .

· malaysisch / Malaysia .

· maltesisch / Malz i .

· Norweigen / Norweigen .

· Polieren / Po lskĂ .

· Portugiesisch / Português .

· Russisch / русский .

· slowakisch / Slovenski .

· Slowenisch / Slovenski .

· Spanisch / Españoles .

· Schwedisch / Svenska .

· Türkisch / Türke .

· Walisisch / Cymraeg .

Sehe auch

Was bedeutet ABACUS tun?


Auffüllen der Architektur

Navigation: Füllen Sie Ihre Architektur>

Auffüllen der Architektur

Senden Sie Kommentare Zu diesem Thema.

Der Prozess des Aufbaus einer Modell Ihrer Architektur ist bekannt als Bestückung. Sobald Sie Ihre Architektur entdeckt und identifiziert Ihren Anforderungen haben, sind Sie bereit, Ihre Architektur in ABACUS modellieren.

Während der Bevölkerung, werden Sie alle Details, die Sie zu Ihrer Architektur und was davon benötigt wissen eingeben.

Ihre Architektur zu füllen

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet , ein Explorer angezeigt , und ein Architektur hinzugefügt .

2. Manuell ausfüllen die übergeordneten Komponenten und Verbindungen Ihrer Architektur. Typischerweise werden die abstrakteren Komponenten und Verbindungen sein.

- oder -

2. Grafisch bevöl die Komponenten und Verbindungen, die Sie möchten, schematisch dargestellte, mit dem Stuhl Zeichenwerkzeug .

Vielleicht möchten Sie auch auf

3. Füllen Sie mit Kataloge - Können Sie anzeigen und Komponenten und Verbindungen auf einfache tabellarische Weise.

4. Füllen Sie mit Hilfe von Matrizen - Können Sie anzeigen und die Verbindungen zwischen den Komponenten zu bearbeiten auf einfache tabellarische Art und Weise.

5. Füllen Sie aus Microsoft Access - Sie können eine Architektur aus importieren und exportieren Microsoft Access.

6. Füllen Sie aus Microsoft Visio - Sie können eine Architektur aus importieren und exportieren Microsoft Visio.

7. Füllen Sie aus Microsoft Excel - Sie können eine Architektur aus importieren und exportieren Microsoft Excel.

8. Füllen Sie aus Microsoft Sharepoint - Sie können eine Architektur aus importieren und exportieren Microsoft SQL Server.

9. Füllen Sie aus Microsoft SQL Server - Sie können eine Architektur von Microsoft SQL Server zu importieren.

10. Import von XML- - Sie können eine Architektur von einem ABACUS XML-Fragment oder eine Archimate Interchange Sprache XML-Datei zu importieren.

Sehe auch

Auffüllen der Architektur Hand | Das Zeichenwerkzeug | Auffüllen der Architektur von Microsoft Access | Auffüllen der Architektur von Microsoft Visio | Auffüllen der Architektur aus Microsoft Excel


Auffüllen der Architektur Hand

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen>

Auffüllen der Architektur Hand

Senden Sie Kommentare Zu diesem Thema.

Die übergeordneten Komponenten und Verbindungen Ihrer Architektur müssen wahrscheinlich manuell bestückt werden. Typischerweise werden die abstrakteren Komponenten und Verbindungen sein.

Ihre Architektur manuell ausfüllen

1. Stellen Sie sicher, Sie haben ein ABACUS-Dateioffen, ein Forscherangezeigt wird, und ein Architektur hinzugefügt .

2. Eine Komponente hinzufügen. Um dies zu tun, Rechtsklickauf dem Gelände des Baumes Sie auffüllen möchten, und wählen Sie Hinzufügen Sub-Komponente ..., Oder klicken Sie auf die Neue KomponenteTaste auf der Symbolleiste anzeigen . Komponenten können nur im Rahmen der Komponenten Zweig des Baumes hinzugefügt werden. Sie möchten Ihre Baumdiagramm, um eine genaue Darstellung Ihrer Architektur. Wenn Sie Ihre Architektur entdeckt, werden Sie gelernt haben, wie genau es passt alles zusammen. Du wirst dieses Wissen müssen, wenn Sie Ihre Komponenten und Verbindungen hinzuzufügen. Wenn Sie das Hinzufügen Ihrer ersten Komponente sind, werden Sie es direkt an die Komponenten Zweig hinzuzufügen. Der Rest des Komponenten können entweder in der gleichen Ebene in der Struktur sein, oder sie können Teilkomponenten des ersten sein.

3. Aktualisieren Sie die Werte vonEigenschaftenjeder Komponente, wie Sie es hinzufügen. Um dies zu tun, klickenauf die Komponente, und bearbeiten Sie die in der angezeigten Eigenschaften Eigenschaftenfenster(typischerweise) nach rechts. Eigenschaften sind in der Regel Dinge wie Anforderungen, die Verarbeitungskapazitäten, etc. Wenn ABACUS wertet Ihre Architektur, wird es ein paar neue Eigenschaften zu berechnen, und speichern Sie sie zurück in die Architektur. Die neuen Eigenschaften sind die Daten, die Sie versuchen, zu analysieren sind, wie zB Auslastung, Antwortzeiten, Bandbreite usw.

4. Fügen Sie Ihre Verbindungen und aktualisierenderen Eigenschaftenwie Sie gehen - genau wie Sie für Komponenten (aber unter der Anschlüsse Zweig des Baumes).

5. AnfügenVerbindungen und Komponenten. Um dies zu tun, suchen Sie die Verbindung, klicken Sie auf eines seiner endet oder Rollen , Und ziehen Sie sie auf eine Komponente. Alternativ klicken Sie auf eine Komponente, und ziehen Sie es auf einer der Verbindung der Rollen (das heißt entweder Source oder Sink). Oder Sie können der rechten Maustaste und ziehen Sie eine Komponente auf eine andere Komponente, und wählen Sie Verbunden mit. Oder einfach mit der rechten Maustaste auf eine Komponente, und wählen Sie Verbinden.... Wenn Sie eine Verbindung ziehen Rolle, Werden Sie eine Verknüpfung Symbol bemerken, wenn Sie an einer Komponente können Sie es zu befestigen zeigen. Dies zeigt an, dass Sie nicht eine Kopie anfertigen, Sie sind nur anbringen. Stellen Sie sicher, dass Sie es an die richtige Zielkomponente zu befestigen. Zum Beispiel, wenn es ist Quelle einer Verbindung Rolle, Ziehen Sie es tun, die Quellkomponente (dh die Komponente, die die Quelle des Datenflusses ist).

Spitze

Nachbestellung Einheiten innerhalb Ihrer Architektur (zB Komponenten, Anschluß etc.) in das Forscherist recht einfach. Einfach Klicken| Halten| Ziehendie entsprechende Einheit und Ort, wo in Ihrer Architektur gewünscht. Die Neuordnung Funktionalität ermöglicht es Ihnen auch Einheiten innerhalb verschiedener Hierarchien von Ihrer Architektur zu platzieren.

Vielleicht möchten Sie auch auf

6. In Normen (vorkonfigurierten Sets von Eigenschaften - Voreinstellungen), um Ihre Komponenten, Verbindungen oder Arten

7. Ändern Sie die Eigenschaften einer Komponente, Verbindung oder Typ

8. Undo und Redo Geschäftstätigkeit

9. Ändern Sie den Typ einer Komponente oder Verbindung

10. Erstellen Sie eine neue Art oder Artengruppe

11. Löschen eine Komponente oder Verbindung

12. Erstellen, vervielfältigen oder weiterentwickeln eine Architektur

13. Import-Typen und Standards aus einer Bibliothek

14. Importieren aus anderen ABACUS-Datei, XML, Excel oder Visio

15. Kopieren und Einfügen Teile (oder alle) Ihrer Architektur

16. Suchen und Ersetzen Artikel im Architektur

17. Expandieren kollabieren einige oder alle der Knoten in der Baumstruktur

18. Verschmelzen Artikel

19. Definieren und Bestätigen Beschränkungen um die Struktur Ihrer Architektur zu beschränken

20. Entwickeln Sie Ihre Architektur mehrere architektonische Lösungen zu vergleichen und Baseline erstellen

Sehe auch

Auffüllen der Architektur - Übersicht | Erstellen einer neuen Datei


Undo und Redo

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Undo und Redo

Senden Sie Kommentare Zu diesem Thema.

Wie viele moderne Anwendungen, unterstützt ABACUS die Fähigkeit, sowohl Undo und Redo letzten Änderungen Benutzer zu einem offenen Projekt vorgenommen. Um die letzte Änderung rückgängig zu machen, aktivieren Sie einfach den Befehl Rückgängig. Änderungen, die rückgängig gemacht haben, können durch die Aktivierung des Befehls Redo erneuert werden; Re-Anwendung die zuletzt rückgängig Veränderung.

Warnung

Undone Änderungen sind nicht in der Lage, erneut angewendet werden, wenn weitere Änderungen an dem Projekt seit der rückgängig gemacht.

Notiz

Während die überwiegende Mehrheit der Änderungen zu unterstützen Undo / Redo in Echtzeit, einige Diagramm Schablonen Veränderungen, wie die Schaffung einer neuen Art-Shape / Line Verband oder Ändern eines Vereins Farbattribut, sind nicht in der Lage, sofort rückgängig gemacht werden. In diesen Fällen muss das modifizierte Diagram (durch * gekennzeichnet) geschlossen wird, bevor diese Änderungen rückgängig gemacht werden kann.

Undo und Redo-Befehl Standorten

Die Befehle Rückgängig und Wiederherstellen können aus drei verschiedenen Orten zugegriffen werden:

· das Menü Bearbeiten

· der Standard-Werkzeugleiste

· die Tastenkombinationen STRG + Z(Undo) und STRG + Y(Redo)

Spitze

Die Undo und Redo-Tasten auf der Standard-Symbolleiste bieten Dropdown-Listen Anzeigen der 10 neuesten Änderungen, die rückgängig gemacht werden können, und haben jeweils erneuert worden. Sie sind auch eine praktische Möglichkeit, Undo / Redo mehrere Änderungen auf einmal.


Ändern einer Komponente / Verbindung des Typ

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Ändern einer Komponente / Verbindung des Typ

Senden Sie Kommentare Zu diesem Thema.

Komponenten und Verbindungstypen werden hauptsächlich zum Zwecke der Einstufung verwendet. Sie können Arten als Filter zu verwenden, wenn Sie Ihre Architektur. Beispielsweise kann anstelle der Betrachtung der ganzen Sache, Sie könnten nur Anwendungskomponenten anzuzeigen.

Um eine Komponente / Verbindung des Typ ändern

1. Rechtsklickauf der Komponente oder einer Verbindung.

2. Auswählen Typ ändern.

3. Wählen Sie eine andere Art aus der Liste.

Spitze

Wenn Sie die Art ändern, erhalten Sie möglicherweise einige neue Standardsoder Eigenschaften (was auch immer mit dem Typ zugeordnet ist - siehe die Typen Zweig des Baumes). Ihre bestehende Standards und die Eigenschaften bleiben unverändert. Sie können Ihre eigene neue Typen erstellen und Ihre eigenen Kombinationen Standards und Eigenschaften, um sie.

Sehe auch

Erstellen einer neuen Art | Auffüllen der Architektur - Übersicht | Analysieren Ihre Architektur


Erstellen einer neuen Komponente / Verbindungstyp oder Typengruppe

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Erstellen einer neuen Komponente / Verbindungstyp oder Typengruppe

Senden Sie Kommentare Zu diesem Thema.

Komponenten und Verbindungstypen werden hauptsächlich zum Zwecke der Einstufung verwendet. Sie können Arten als Filter zu verwenden, wenn Sie Ihre Architektur. Beispielsweise kann anstelle der Betrachtung der ganzen Sache, Sie könnten nur Anwendungskomponenten anzuzeigen.

Um eine neue Komponente / Verbindungstyp erstellen

Notiz

Um Arten oder Artengruppen in einer ABACUS Projekt der Benutzer-Lizenz muss der Designer-Add-on-Fähigkeit hinzuzufügen. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

1. Erweitern Sie den TypenZweig des Baumes.

2. Rechtsklick am Komponententypen (oder Verbindungstypen).

3. Auswählen In Komponente Typ (oder In-Anschlusstyp) oder Gruppe erstellen.

Spitze

Sobald Sie eine Typ erstellt haben, sollten Sie das entsprechende Symbol (siehe unten) zu ändern und Eigenschaften und Standards um sie für die Komponente bzw. Verbindung Instanzen "erben".

Um das Symbol für ein Bauteil / Anschlusstyp verändern

Notiz

Um die Symbole für Typen in einer ABACUS Projekt der Benutzer-Lizenz muss der Designer-Add-on-Fähigkeit zu ändern. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

1. Rechtsklick auf dem Komponente Typ (oder Verbindungstyp), Die Sie auf das Symbol für ändern möchten.

2. Auswählen Icon ändern.

3. Im Dialog browse Select Icon an einen Ort und wählen Sie eine Bilddatei und klicken Sie auf Öffnen.

Notiz

Sie können ein benutzerdefiniertes Symbol Bild jeder Größe haben, aber es wird immer skaliert, um zu einem 16x16 Pixel Bild im Explorer-Fenster zu passen. Also, wenn Ihr Originalbild benutzerdefinierte Symbol ist nicht von gleicher Höhe und Breite werden Ihre Explorer-Fenster-Symbol gestreckt werden. Dementsprechend sollten benutzerdefinierte Bilder mindestens 16x16 Pixel sein, und wenn Sie die genaue Form des benutzerdefinierten Symbols beibehalten möchten sicherstellen, dass Ihre benutzerdefinierte Symbolbild entspricht in Höhe und Breite in Pixel (16x16 oder größer). Sie sollten auch vorsichtig sein, über nicht mit farbigen 'Pixel' gehen den ganzen Weg bis zur Grenze des benutzerdefinierten Symbolbild als es Armen in der Explorer-Fenster mit benachbarten Symbolen 'Blutung' ineinander zu suchen. Dementsprechend sollten Sie zumindest ein 1 Pixel weißen Rand zu verlassen.

Spitze

Sie können Ihre benutzerdefinierten Symbolbild eine .ico, .bmp, .gif, .jpg oder .png-Format-Datei zu machen, aber aufgrund einer Beschränkung in Windows nur ICO-Format wird in der ABACUS Select Icon Dialogfeld eine Vorschau, wenn Sie die Ansicht Menüpunkt haben auf etwas anderes als Thumbnails eingestellt.

Sehe auch

Auffüllen der Architektur - Übersicht | Analysieren Ihre Architektur


Löschen einer Komponente oder Verbindung

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Löschen einer Komponente oder Verbindung

Senden Sie Kommentare Zu diesem Thema.

Um eine Komponente oder Verbindung löschen

1. Rechtsklickauf der Komponente oder einer Verbindung.

2. Auswählen Löschen.

Vorsicht

ABACUS wird Sie warnen, welche Ansichten werden von der Löschung nicht berührt und fordert Sie auf, den Löschvorgang zu bestätigen. Dies liegt daran, Elemente können auf viele Diagramme vorhanden sind und es sich lohnt, zu überprüfen, was die vorgeschlagene Streichung beeinflussen.

Spitze

Wenn Sie eine Komponente löschen, werden alle seine Unterkomponenten ebenfalls gelöscht. Sie können wählen, um die internen und externen Verbindungen zu der Komponente zu löschen. Wenn Sie nicht wählen, um sie zu löschen, die Verbindungen ist es angebracht zu bleiben, aber sie werden nicht mehr angehängt werden. Alle Komponenten und Anschlüsse sind von einem bestimmten Art . Das Löschen der Komponente / Verbindung hat keine Auswirkungen auf den Typ (in der Arten Zweig des Baumes). Und falls das Bauteil / Verbindung hat einen Standard zugeordnet ist, wird gelöscht haben keine Auswirkungen auf den Master in der Standards Branche.

Sehe auch

Auffüllen der Architektur - Übersicht


Erstellen oder Duplizieren einer Architektur

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Erstellen oder Duplizieren einer Architektur

Senden Sie Kommentare Zu diesem Thema.

Sie können eine beliebige Anzahl von Architekturen in einem einzigen ABACUS-Datei haben. Normalerweise würde man eine neue Architektur jedes Mal zu modellieren und zu bewerten, eine Entwicklung des Systems möchten.

Um eine neue Architektur zu schaffen

1. Rechtsklick auf dem ArchitekturenZweig des Baumes.

2. Auswählen Neue Architektur.

Um eine Kopie einer bestehenden Architektur zu schaffen

1. Rechtsklickauf die Architektur.

2. Auswählen Kopie.

3. Rechtsklick auf dem ArchitekturenZweig des Baumes.

4. Auswählen Paste.

5. Die neue Architektur wird den Namen "Kopie von ...".

Um eine bestehende Architektur zu entwickeln

1. Rechtsklickauf die Architektur.

2. Auswählen Entwickeln.

3. Die neue Architektur wird den Namen '... .1'.

Notiz

Es gibt eine ausführliche Beschreibung über sich entwickelnde Architekturen Hier .

Sehe auch

Wie wird eine Architektur in ABACUS vertreten | Evolving Ihre Architektur


Importieren in Ihre Architektur

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Importieren in Ihre Architektur

Senden Sie Kommentare Zu diesem Thema.

ABACUS können Sie zu importieren Ihre Architektur von einer .abacus (ABACUS-Datei), .xml (ein Abakus XML-Fragment oder Archimate Interchange Sprache XML-Datei), VSD (Microsoft Visio) Format und XLS (Microsoft Excel) Format. Dies ermöglicht Ihnen, bauen Sie Ihre Architektur aus anderen Quellen schnell.

Zu Import Ihre Architektur von.abacus (ABACUS-Datei)

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Rechtsklickauf der Architektur-Knoten auf jeder Architektur im Modell oder ein Teil der Komponenten Baum.

3. Auswählen Import| Von Datei...aus dem Menü.

4. Wählen Sie einen Ort und die .abacus Datei und klicken Sie auf die Öffnen Taste.

Notiz

Nachdem Sie die Datei, die Sie importieren möchten, ausgewählt haben, werden Sie gefragt, wie Sie möchten, um die Standards zu importieren, Typenund Standpunkte. Sie können Standards importieren, Typen und Standpunkte entweder neue oder fusionierte Standards, Typenund Standpunkte. Die Standardeinstellung ist für Standards, Typen und Standpunkte mit bestehenden Standards zusammengeführt werden, Typen und Standpunkte Wenn sie bereits existieren (mit der gleichen genauen Namen) in deinem Projekt.

Zu ImportIhre Architektur von.xml (ein Abakus XML-Fragment oder Archimate Interchange Sprache XML-Datei)

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Rechtsklickauf einer Architektur-Knoten auf jeder Architektur im Modell oder ein Teil der Komponentenbaum.

3. Auswählen Import| Von XML ...aus dem Menü.

4. Wählen Sie einen Ort und die XML- Datei und klicken Sie auf die Öffnen Taste.

Notiz

ABACUS wird nur einwandfrei gebildet ABACUS XML-Fragment oder eine Archimate Interchange Sprache XML-Datei zu importieren. Nachdem Sie die XML-Datei, die Sie importieren möchten, ausgewählt haben, werden Sie gefragt, wie Sie möchten, um die Standards zu importieren, Typenund Standpunkte. Sie können Standards importieren, Typen und Standpunkte entweder neue oder fusionierte Standards, Typenund Standpunkte. Die Standardeinstellung ist für Standards, Typen und Standpunkte mit bestehenden Standards zusammengeführt werden, Typen und Standpunkte Wenn sie bereits existieren (mit der gleichen genauen Namen) in deinem Projekt.

Zu ImportIhre Architektur von.vsd(Visio Datei) sehen Hier .

Zu ImportIhre Architektur von.xls (Excel-Datei) sehen Hier .


Importieren von Typen und Standards aus einer Bibliothek

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Importieren von Typen und Standards aus einer Bibliothek

Senden Sie Kommentare Zu diesem Thema.

Sie können Arten und Standards von einem ABACUS Bibliotheksdatei importieren. Sie können auch Typen und Standards exportieren aus Ihrem ABACUS-Datei in eine ABACUS Bibliotheksdatei.

Um Typen und Standards aus einer Bibliothek zu importieren in Ihre Architektur

1. Stellen Sie sicher, Sie haben ein ABACUS-Dateioffen, und der Explorer-Fensterangezeigt.

2. Wählen Sie Datei | Öffnenzu einem offenen ABACUS Bibliotheksdatei.

3. Die ABACUS-Bibliothek wird in einem zweiten Registerblatt in der Explorer-Fenster zu öffnen, und Sie werden zu müssen Abdocken dieses Tabbed Blatt unterstützt, um von it-and-Drop verschieben, um den ursprünglichen ABACUS-Datei sein.

4. Drag-and-DropTypen und Standards aus der Bibliothek in Ihre Architektur.

- oder -

1. Wählen Sie Datei | Neu ...

2. Erstelle eine neue ABACUS-Dateibezogen auf eine ABACUS Bibliotheksdatei.

Um Typen und Standards von Ihrer Architektur in eine Bibliothek exportieren

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffne das Explorer-Fensterangezeigt wird, ein ABACUS Bibliotheksdateioffen, und der Bibliotheksfensterangezeigt.

2. Drag-and-DropTypen und Standards von Ihrer Architektur in die Bibliothek.

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand


Kopieren und Einfügen

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Kopieren und Einfügen

Senden Sie Kommentare Zu diesem Thema.

Sie können einen Teil oder alle Ihre Architektur zu kopieren und an einer anderen Stelle im Baum.

Kopieren

1. Rechtsklickauf dem Element, das Sie kopieren möchten.

2. Auswählen Kopie.

Einfügen

1. Navigieren Sie den Baum, um den Ort, den Sie möchten, dass der Artikel einfügen zu finden.

2. Rechtsklickauf dem Zweig Sie wollen, dass es innerhalb von angezeigt.

3. Auswählen Paste.

4. Das Einzelteil wird mit dem ursprünglichen Namen kopiert werden (sofern Sie es nicht auf die ursprüngliche Niederlassung kopieren - dann wird es genannt werden "Kopie von ...").

Sehe auch

Wie wird eine Architektur in ABACUS vertreten


Suchen und Ersetzen von Artikel im Architektur

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Suchen und Ersetzen von Artikel im Architektur

Senden Sie Kommentare Zu diesem Thema.

Sie können finden, und Ersetzen eine spezifische Komponente, Anschluss, Typ, Standard- oder Eigenschaft mithilfe ABACUS 'Finden und Ersetzen Einrichtung.

Um einen Artikel zu finden

1. Klicken Sie auf den Knoten des Baums Sie möchten, dass in zu suchen.

2. Auswählen Bearbeiten| Findenoder drücken Strg + F.

3. Geben Sie die Text für der Gegenstandin das Feld "Suchen nach" zu finden.

4. Klicken Nächstes finden.

Zu ersetzen ein Gegenstand

1. Klicken Sie auf den Knoten des Baums Sie möchten, dass in zu suchen.

2. Auswählen Bearbeiten| Ersetzenoder drücken Strg + H.

3. Geben Sie die Text für der Gegenstandin finden Sie auf Suchen, was 'Feld und den Text, um ihn mit in die zu ersetzen "Ersetzen durch" Feld (oder nichts, wenn das Feld leer ist).

4. Klicken Nächstes findenum die erste Instanz des 'Suchen nach' Text und klicken Sie auf Suche Ersetzen um dieses Beispiel mit dem "Ersetzen durch" Text oder klicken Sie auf Ersetzen Alles ersetzenum alle Instanzen zu ersetzen.

Sie haben die Optionen, um:

o Wer passt zu seinem Fall,

o Wer passt das ganze Wort,

o Suchen von Anfang des Projekts,

o Ignorieren Architekturen - das ist die Architektur Knoten selbst. Beliebigen Knoten unter den Knoten-Architektur, wie die Komponenten und Verbindungen werden immer noch gesucht werden,

o Ignorieren Komponenten - das ist die Komponente Knoten selbst,

o Ignorieren Verbindungen - das ist die Verbindungsknoten selbst,

o Ignorieren Standards - also alle Architektur, Komponenten und Verbindungsstandard Knoten werden ignoriert,

o Ignorieren Typen - das ist die Art Knoten selbst. Etwaige Beschränkungsknoten unter der Typknoten werden immer noch gesucht werden,

o Ignorieren Vorlagen und Inhalte -, dass die Vorlage Knoten selbst sowie jede Vorlage Komponente und Verbindungsknoten ist unter ihnen,

o Ignorieren Eigenschaften -, die alle Immobilienarten, Namen, Werte und Einheiten aller der Modellelemente werden ignoriert,

o Ignorieren Beschreibungen - das ist die Beschreibung aller der Modellelemente werden ignoriert.

Sehe auch

Wie wird eine Architektur in ABACUS vertreten


Auf- und Zuklappen der Baum

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Auf- und Zuklappen der Baum

Senden Sie Kommentare Zu diesem Thema.

Wenn ein Knoten in dem Baum enthält Subkomponenten und Sammlungen, wird es einen kleinen haben [image] oder [image] melden Sie an ihrer linken. Sie können das klicken [image] um den Knoten zu erweitern und seine Unterkomponenten und Verbindungen. Ebenso können Sie die klicken [image] um den Knoten zu kollabieren, um die Sub-Komponenten und Anschlüsse (um mehr Platz zu schaffen zu machen oder der Baum leichter zu verstehen) zu verstecken.

Alternativ können Sie einen ganzen Knotens, wobei alle seine Unterknoten werden auch erweitert werden, und deren Unterknoten erweitern, und ihnen ... etc. In ähnlicher Weise können Sie eine ganze Knoten zusammenbrechen - Schließen mehrere Ebenen auf einmal .

Darüber hinaus gibt es die Möglichkeiten, dass nur die Architekturen Elemente (dh Komponenten und Verbindungen), Komponenten oder Verbindungen zu erweitern.

So erweitern oder reduzieren einen vollständigen Knoten (und seine Unterknoten, etc.)

1. Rechtsklickauf dem Knoten.

2. Auswählen Erweitern | Alle oder Zusammenbruch.

Um mit einer Architektur zu erweitern (en)

1. Rechtsklickauf Architekturen oder einer Architektur.

2. Auswählen Erweitern | Alle.

So erweitern Elemente

1. Rechtsklickauf Architekturen oder einer Architektur.

2. Auswählen Erweitern | Elemente.

Um Komponenten zu erweitern

1. Rechtsklickauf Komponenten, ein Bauteil oder eine Teilkomponente.

2. Auswählen Erweitern | Components | Alle.

Um Verbindungen zu erweitern

1. Rechtsklickauf Verbindungen, eine Verbindung oder ein Sub-Anschluss.

2. Auswählen Erweitern | Connections | Alle.


Zusammenführen von Artikel

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Zusammenführen von Artikel

Senden Sie Kommentare Zu diesem Thema.

Wann würden Sie Einzelteile zusammenführen?

Sie würden Artikel zusammenführen, wenn Sie zwei (oder mehr) Objekte in Ihrem Modell, das am besten mit einer einzigen Instanz vertreten habe. Es gibt viele Situationen, wenn Sie möchten, dies zu tun, unter anderem:

· Als Ergebnis des Imports einen neuen Satz von Informationen in Ihr Modell, das duplizieren oder ersetzen vorhandene Information kann. Zum Beispiel wenn Sie eine aktualisierte Version von einer Tabellenkalkulation in Ihr Modell importieren.

· Im Laufe der Zeit Duplikate der 'gleichen' Komponente erstellt wurden und Sie bereinigen diese Duplikate möchten.

· Wenn Sie ausführen ein Was-wäre-wenn-Szenario und die Elemente, die Sie modellieren tatsächlich verschmelzen in der Realität. Zum Beispiel, wenn Sie Zusammenführen von zwei Abteilungen in Ihrem Unternehmen, oder wenn Sie Zusammenführen von zwei Servern.

Was kann zusammengelegt werden?

Die folgenden Arten von Gegenständen unterstützen zusammengeführt:

· Standards

· Komponenten und Verbindungstypen

· Bauteile und Verbindungen

Wie Sie Artikel zusammenführen

Um ein Zusammenführen zu starten, mit der rechten Maustaste, ziehen Sie ein Element im Explorer auf ein anderes. Das Element, das Sie verschieben werden ist die Quelle und das Element, das Sie auf ziehen ist das Ziel. Beim Loslassen der rechten Maustaste werden Sie mit einem Menü, in dem Sie wählen können, um die beiden Elemente zusammenführen präsentiert. Sie müssen entscheiden, ob Sie zu erhalten oder überschreiben Sie die Ziel möchten. Dies wird weiter unten erläutert.

Das Zusammenführen der rechten Drag-Menü

Was ist der Unterschied zwischen der Erhaltung und Überschreiben Sie das Ziel?

Die Option zu erhalten oder überschreiben diktiert, was passiert, wenn die Namen, die Beschreibung oder Eigenschaften zwischen der Quell- und Ziel-Artikel Spiel.

Wenn Preserve Destination gewählt wird

· Der Destination Name und Beschreibung bleiben erhalten.

· Alle Eigenschaften, die nur in der Quelle vorhanden sind, werden zu dem Ziel aufgenommen.

Wenn Overwrite Destination gewählt wird:

· Die Ziel-Name wird von der Quelle überschrieben.

· Der Destination Beschreibung wird von der Quelle überschrieben werden, es sei denn, der Quelle Beschreibung leer.

· Alle Eigenschaften, die nur in der Quelle vorhanden sind, werden zu dem Ziel aufgenommen.

· Der Wert und die Einheit von Eigenschaften, die sowohl in der Quell- und Ziel existieren wird von der Quelle überschrieben werden, es sei denn, der Quellwert oder Einheit leer ist.

Sonderfälle

· Typen: Beim Zusammenführen Typen werden die Berechtigungen zusammengeführt, in einem "pessimistisch" Art und Weise, so dass, wenn die Berechtigung für Quelle nicht auf dem Ziel vorhanden ist, hinzugefügt werden würde, und wenn es in der Ziel existierte, dann, wenn die einzelnen Erlaubnis für eine Benutzergruppe (Create, Read, Update oder Delete) stimmen nicht überein (ein gewährt, einem verweigert), dann würde die Erlaubnis verweigert.

· Components: Beim Verbinden von Bauteilen werden die Teilkomponenten der Quelle zum Ziel migriert und sind mit Sub-Komponenten in der Ziel verschmolzen, wenn die Namen identisch sind, Unabhängig von ihrem Typ.Weiterhin werden mehrere Teilkomponenten der Quelle mit dem gleichen Namen in einem einzigen Teilkomponente in dem Ziel kombiniert werden.

· Anschlüsse: Die Top-Level-Verbindungen selbst müssen beide haben die gleichen Anhänge (oder deren Fehlen) zu dürfen, zusammengeführt werden. Beim Zusammenführen von Verbindungen werden die Teilverbindungen der Quelle zum Ziel migriert und sind mit Teilverbindungen im Ziel verschmolzen, wenn die Namen identisch sind UNDderen Anhänge sind identisch. Wenn Anhänge nicht identisch sind, werden die Quellteilverbindungen zum Ziel, ohne die Fusion mit passenden Verbindungen bereits vorhandenen hinzugefügt werden. Dies ist, so dass keine Anhänge verloren.


Festlegung und Validierung von Constraints

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Festlegung und Validierung von Constraints

Senden Sie Kommentare Zu diesem Thema.

Die Struktur und die Eigenschaften einer Architektur kann mit Beschränkungen begrenzt werden. Einschränkungen können Komponententypen und Verbindungstypen angewendet werden, um die Struktur einer Architektur auf zwei Arten beschränken. Die erste Möglichkeit besteht darin, die Filterung Hierarchiedurch die Definition von "Eltern sollten / müssen Kind haben" und Beziehungen »Kind sollte / muss Elternteil". Die zweite Möglichkeit besteht darin, die Filterung Topologiedurch die Definition von "Komponente sollte / muss, um eine Verbindung angebracht werden" und Beziehungen "Verbindung soll / muss die Komponente angebracht werden". Darüber hinaus können Einschränkungen auf die Eigenschaften der Komponententypen, Verbindungstypen, Vorlagen, Aussichtspunkte, Architekturen angewendet werden, Diagrammeund 3D-Ansichten, die Architektur (en) in zwei weitere Möglichkeiten zu beschränken. Der erste Weg ist, um die eingestellte Dateitypdes Grundstücks an die gültigen Werte, die es haben kann, nämlich zu beschränken; Text, Integer, Dezimal, Datum / Zeit, Boolean oder Liste. Der zweite Weg ist, um das Set erforderlichStatus der Eigenschaft, um anzugeben, ob ein Wert für die Eigenschaft eingegeben werden muss (Hinweis: Notwendige Einschränkungen nur, um Eigenschaften für Komponenten und Verbindungstypen Aufpreis). Weitere Angaben zu den Immobilien Einschränkungen in der vorgesehenen Ändern der Eigenschaften einer Komponente, Verbindung oder Typ Hilfethema. Einmal Einschränkungen definiert sind, ist es möglich, eine Architektur gegen die Zwänge zu validieren. ABACUS wird über alle Einschränkungen, die verstoßen wurde, zu warnen.

Der Schlüssel zu bestimmen, welche Randbedingung (en), liegt an der genauen Sprache verwendet, um die Einschränkung zu beschreiben definieren. Für Hierarchie Beschränkungen sie in der Regel in der Form "Substantivekann / soll / muss in n zerlegt werden Substantive" oder "Substantivekann / soll / muss von aggregiert werden Substantive"Etc. Zum Beispiel"Abteilungenmuss in die zerlegt werden Teams" oder "Anwendungenkann in zerlegt werden Module". Für Topologie Zwänge sie in der Regel in der Form"Substantivekann / soll / muss Verb Substantive". Beispielsweise, "Prozesse kann sein durchgeführt von Teams" oder "Anwendungen gibt gehostet auf Server". Jetzt können Sie in jedem Constraint sehen können, gibt es verschiedene kann / soll / muss" Qualifier "und diese können von 3 Typen sein;

· Optional- Diese werden in der Regel verwenden Wörter / Phrasen wie; "könnte", "kann", "könnte", "gegebenenfalls", usw.

· Empfohlen- Diese werden in der Regel verwenden Wörter / Phrasen wie; "sollte", "empfohlen", "empfohlen", usw.

· Verpflichtend- Diese werden in der Regel verwenden Wörter / Phrasen wie; "Muss", "wird", "werden", "besitzt", "sollen", usw.

Je nach Art von Zwang (Hierarchie oder Topologie) und den darin beschreiben, verwendet Qualifikanten sollten spezifische Einschränkung (en) definiert werden (siehe unten). Für das obige Beispiel der Hierarchie "Abteilungenmuss in die zerlegt werden TeamsEltern müssen Kinder haben "Zwang und den Durchsetzungsgesetzt werden kann. Für das obige Beispiel-Topologie von" "sollte man einen zu definieren"Prozesse kann sein durchgeführt von Teams. ", Man sollte nur erstellen Sie zwei (2)" Anschluss muss auf Component "Einschränkungen für die beiden Enden durch Verbindungstyp die geführt befestigt werden Insbesondere werden die folgenden Einschränkungen empfohlen, definiert werden (siehe unten) für die verschiedenen Optionen;

· Hierarchie Einschränkungen;

o Substantive A kann seinin zerlegt Substantive B, oder Substantive B kann seinvon aggregiert Substantive A oder Substantive B solltevon aggregiert Substantive A- Definieren Sie einen "Child muss Eltern haben" Constraint mit dem Kind Typ wie Noun B, Muttertyp wie Nomen A und Durchsetzung als gewarnt.

Notiz

Das bedeutet, wenn ein Kind vorhanden ist, sollte es ein Elternteil eines bestimmten Typs. Wenn nicht, werden Sie eine Warnung.

o Substantive A solltein zerlegt Substantive B- Definieren Sie eine "Parent müssen Child haben" Constraint mit der Muttertyp wie Nomen A, Kind Typ wie Noun B und Durchsetzung als gewarnt.

Notiz

Das heißt, wenn ein Elternteil vorhanden ist, sollte es Kindern eines bestimmten Typs. Wenn nicht, werden Sie eine Warnung.

o Substantive A muss seinin zerlegt Substantive B- Definieren Sie eine Einschränkung mit der Muttertyp wie Nomen A, Kind Typ wie Noun B und Durchsetzung als Erzwungen "Parent müssen Child haben".

Notiz

Das heißt, wenn ein Elternteil vorhanden ist, müssen die Kinder eines bestimmten Typs. Wenn nicht, werden Sie eine Fehlermeldung.

o Substantive A muss seinvon aggregiert Substantive B- Definieren Sie einen "Child muss Eltern haben" Constraint mit dem Kind Typ wie Nomen A, Muttertyp wie Noun B und Durchsetzung, wie durchgesetzt werden.

Notiz

Das bedeutet, wenn ein Kind vorhanden ist, muss es ein Elternteil eines bestimmten Typs. Wenn nicht, wird eine Fehlermeldung angezeigt.

· Topologie Zwänge;

o Substantive A kann sein Verb Substantive B- Legen Sie zwei (2) Beschränkungen "Anschluss muss auf Component angebracht werden". Die erste ist mit der Source-Ende-Verbindungstyp Verbangebracht, um eine Komponententyp und Durchsetzung auf Erzwungen gesetzt Substantivs. Die zweite mit dem Sink Ende der Verbindungstyp Verbum Noun B Bauart und Durchsetzung auf Erzwungen gesetzt angebracht.

Notiz

Das bedeutet, wenn die Verbindung besteht, muss Komponenten bestimmter Arten verbinden. Wenn nicht, werden Sie eine Fehlermeldung. Insgesamt ist dies gewährleistet, dass diese Komponenten noch bestehen und nicht miteinander verbunden sein. Jedoch, wenn sie verbunden sind, sind die Anschlüsse des rechten Typs verwendet werden.

o Substantive A sollte Verb Substantive B- Legen Sie zwei (2) Beschränkungen "Component muss Anschluss angebracht werden". Die erste ist mit Noun Ein Komponententyp zur Quelle Ende der angeschlossene VerbVerbindungstyp und Durchsetzung Satz gewarnt. Die zweite mit Noun B Bauart zum Waschbecken Ende der angeschlossene VerbVerbindungstyp und Durchsetzung Satz gewarnt. Zusätzlich definieren Sie zwei (2) Beschränkungen "Anschluss muss auf Component angebracht werden". Die erste ist mit der Source-Ende-Verbindungstyp Verbangebracht, um eine Komponententyp und Durchsetzung auf Erzwungen gesetzt Substantivs. Die zweite mit dem Sink Ende der Verbindungstyp Verbum Noun B Bauart und Durchsetzung auf Erzwungen gesetzt angebracht.

Notiz

Dies bedeutet, dass, wenn die Komponenten jedes Typs existieren können, sollten sie eine Verbindung einer bestimmten Art befestigt werden. Wenn nicht, werden Sie eine Warnung. Darüber hinaus bedeutet dies, dass, wenn die Verbindung besteht, muß es, um Komponenten des genannten Typs verbunden werden. Wenn nicht, werden Sie eine Fehlermeldung. Insgesamt ist dies gewährleistet, dass, wenn die Komponenten dieser Art existiert, wird nach Warnungen erhalten, wenn sie nicht miteinander verbunden sind.

o Substantive A muss sein Verb Substantive B- Legen Sie zwei (2) Beschränkungen "Component muss Anschluss angebracht werden". Die erste ist mit Noun Ein Komponententyp zur Quelle Ende der angeschlossene VerbVerbindungstyp und Durchsetzung auf Erzwungen festlegen. Die zweite mit Noun B Bauart zum Waschbecken Ende der angeschlossene VerbVerbindungstyp und Durchsetzung auf Erzwungen festlegen. Zusätzlich definieren Sie zwei (2) Beschränkungen "Anschluss muss auf Component angebracht werden". Die erste ist mit der Source-Ende-Verbindungstyp Verbangebracht, um eine Komponententyp und Durchsetzung auf Erzwungen gesetzt Substantivs. Die zweite mit dem Sink Ende der Verbindungstyp Verbum Noun B Bauart und Durchsetzung auf Erzwungen gesetzt angebracht.

Notiz

Dies bedeutet, dass, wenn die Komponenten jedes Typs existieren, müssen sie auf eine Verbindung einer bestimmten Art befestigt werden. Wenn nicht, werden Sie eine Fehlermeldung. Darüber hinaus bedeutet dies, dass, wenn die Verbindung besteht, muß es, um Komponenten des genannten Typs verbunden werden. Wenn nicht, werden Sie eine Fehlermeldung. Insgesamt ist dies gewährleistet, dass, wenn die Komponenten dieser Art existiert, wird nach Fehlern, wenn sie nicht miteinander verbunden sind.

Um einen Constraint zu definieren

1. Stellen Sie sicher, Sie haben ein ABACUS-Dateioffen, und der Explorer-Fensterangezeigt.

2. In der Explorer-Struktur zu erweitern Typen | Komponententypenoder erweitern Typen | Verbindungstypen.

3. Rechtsklickein Komponententyp oder ein Verbindungstyp, und wählen Sie Bedingungen hinzufügen.

Hinzufügen einer Einschränkung

Um eine Hierarchie Einschränkung, wo ein Elternteil muss einen bestimmten Kind haben zu definieren

4. Auf dem Bedingungen hinzufügenFenster markieren Sie das Erstellen ConstraintKontrollkästchen unter der Mutter Must Have Kinder Constraint Bereich.

5. Wähle aus Bauartaus der Dropdown-Liste, die Sie als das Kind des Komponententyps in Schritt 3 ausgewählten angeben möchten.

Notiz

Wenn es bereits einen fähigen "Eltern Must Have Child 'Einschränkung für das übergeordnete Komponententyp und ein weiteres Kind Bauart dann diese neue Einschränkung wird als ein" UND "behandelt werden, definiert. Das ist der Typ muss ein Elternteil des Kindes Typ A sein undKinder Typ B, um was auch immer Durchsetzungsebene (zB Behinderte, gewarnt oder vollstreckt - siehe Schritt 7) wird für jede Einschränkung angegeben.

6. Optional können Sie die minimale und maximale Anzahl von Komponenten der Komponententyp festgelegt, dass die Kinder der Bauartrechtsklick in Schritt 3 sein muss, zu definieren.

7. Wählen Sie, ob die Einschränkung sein wollen, Behindert, Gewarnt oder Gesetzt.

Notiz

Disabled Einschränkungen werden aus Beschränkungsvalidierungs ignoriert werden, werden gewarnt Einschränkungen eine Warnung in der Validierungsfenster zu produzieren, wenn sie erkannt werden und durchgesetzt Einschränkungen wird ein Fehler bei der Validierung Fenster zu produzieren, wenn sie erkannt werden. Weiterhin müssen alle Fehler, bevor eine gelöst werden Unternehmen Server Projekt kann begangen werden.

8. Klicken OK.

Notiz

Die Einschränkung wird im Explorer-Baum unter dem Bauartrechtsklick in Schritt 3 Der Pfeil zeigt die Richtung der Einschränkung und in diesem Fall wird nach unten zeigen und rechts angezeigt werden. Das Vorhängeschloss wird entsprechend gefärbt, ob die Einschränkung ist deaktiviert (grau), warnte (gelb) oder erzwungen (rot).

Elternteil muss Kind gewarnt Einschränkung haben

Um eine Hierarchie Einschränkung, wo ein Kind muss einen bestimmten Elternteil zu definieren

4. Auf dem Bedingungen hinzufügenFenster markieren Sie das Erstellen ConstraintKontrollkästchen unter der Kinder Must Have Elternteil Constraint Bereich.

5. Wähle aus Bauartaus dem Dropdown-Feld, das Sie als der Mutter der Komponententyp angeben wollen in Schritt 3 rechten Maustaste geklickt.

Notiz

Wenn es bereits einen fähigen "Child Must Have Parent 'Einschränkung für das Kind Komponententyp und ein anderes Mutterbauart dann diese neue Einschränkung wird als ein" ODER "behandelt werden, definiert. Das ist der Typ muss ein Kind der Muttertyp A sein oderMutter Typ B, und die Vollstreckung Ebene (zB gewarnt oder vollstreckt - siehe nächsten Schritt) sollten die gleichen Einschränkungen anderweitig erzwungen werden immer überschreiben, warnte diejenigen sein.

6. Wählen Sie, ob die Einschränkung sein wollen, Behindert, Gewarnt oder Gesetzt.

Notiz

Disabled Einschränkungen werden aus Beschränkungsvalidierungs ignoriert werden, werden gewarnt Einschränkungen eine Warnung in der Validierungsfenster zu produzieren, wenn sie erkannt werden und durchgesetzt Einschränkungen wird ein Fehler bei der Validierung Fenster zu produzieren, wenn sie erkannt werden. Weiterhin müssen alle Fehler, bevor eine gelöst werden Unternehmen Server Projekt kann begangen werden.

7. Klicken OK.

Notiz

Die Einschränkung wird in der Explorer-Ansicht unter dem Komponententyp in Schritt 5 gewählten angezeigt werden Der Pfeil zeigt die Richtung der Einschränkung und in diesem Fall wird darauf auf und ging. Das Vorhängeschloss wird entsprechend gefärbt, ob die Einschränkung ist deaktiviert (grau), warnte (gelb) oder erzwungen (rot).

Kind muss Eltern gewarnt Einschränkung haben

Eine Topologie-Einschränkung, wobei eine Komponente muss auf eine bestimmte Verbindung gebunden werden soll

4. Auf dem Bedingungen hinzufügenFenster markieren Sie das Erstellen ConstraintKontrollkästchen unter der Component beizufügen Constraint Be Bereich.

5. Wähle aus Verbindungstypaus dem Dropdown-Feld, das Sie als der angehängten Anschluss des Komponententyp angeben wollen Rechtsklick in Schritt 3 (oder wählen Sie den Bauartaus dem Dropdown-Feld, das Sie als der angeschlossenen Komponente angeben, wenn Sie in Schritt 3 Sie Rechtsklick einen Verbindungstyp soll.)

Notiz

Wenn es bereits einen fähigen "Component beizufügen" Einschränkung für den Komponententyp und einer anderen Verbindung definiert geben Sie dann die neue Einschränkung wird als ein "UND" behandelt werden. Das ist die Komponenten-Typ muss auf Verbindungstyp A befestigt werden undVerbindungstyp B, um was auch immer Durchsetzungsebene (zB Behinderte, gewarnt oder vollstreckt - siehe Schritt 7) wird für jede Einschränkung angegeben.

6. Optional können Sie eine Verbindung auswählen Rolledass Sie auf die Einschränkung hinzufügen möchten. Swählt den spezifischen Rolle (das heißt entweder Source oder Sink) aus dem Dropdown-Feld.

7. Wählen Sie, ob die Einschränkung sein wollen, Behindert, Gewarnt oder Gesetzt.

Notiz

Disabled Einschränkungen werden aus Beschränkungsvalidierungs ignoriert werden, werden gewarnt Einschränkungen eine Warnung in der Validierungsfenster zu produzieren, wenn sie erkannt werden und durchgesetzt Einschränkungen wird ein Fehler bei der Validierung Fenster zu produzieren, wenn sie erkannt werden. Weiterhin müssen alle Fehler, bevor eine gelöst werden Unternehmen Server Projekt kann begangen werden.

8. Klicken OK.

Eine Topologie-Einschränkung, wo eine Verbindung muss einer bestimmten Komponente verbunden werden soll

4. Auf dem Bedingungen hinzufügenFenster markieren Sie das Erstellen ConstraintKontrollkästchen unter der Verbindung beizufügen Constraint Bereich.

5. Wähle aus Verbindungstypaus dem Dropdown-Feld, das Sie als der angehängten Anschluss des Komponententyp angeben wollen Rechtsklick in Schritt 3 (oder wählen Sie den Bauartaus dem Dropdown-Feld, das Sie als der angeschlossenen Komponente angeben, wenn Sie in Schritt 3 Sie Rechtsklick einen Verbindungstyp soll.)

Notiz

Wenn es bereits einen fähigen "Verbindung beizufügen" Einschränkung für den Verbindungstyp und eine andere Komponente Typ definiert unter Verwendung der gleichen Verbindung Rolle(das heißt entweder Source oder Sink), dann ist diese neue Einschränkung wird als ein "ODER" behandelt werden. Das ist der Verbindungstyp muss auf Komponententyp A befestigt werden oderKomponenten-Typ B, und die Vollstreckung Ebene (zB gewarnt oder vollstreckt - siehe Schritt 7) sollten die gleichen Einschränkungen anderweitig erzwungen werden immer überschreiben, warnte diejenigen sein. Man beachte auch, dass, wenn es mehrere Beschränkungen, die die Verbindung den Rollewie angegeben 'Alle' (im Gegensatz zu speziell Source oder Sink), dann jedes Ende der Verbindung muss auf einem der in den Zwängen angegebenen Komponententypen angebracht werden.

6. Optional können Sie eine Verbindung auswählen Rolledass Sie auf die Einschränkung hinzufügen möchten. Swählt den spezifischen Rolle (d.h. entweder Quelle oder Sinken) aus dem Dropdown-Feld.

Notiz

Um eine explizit ausgewählt werden, entweder eine Source oder Sink Rolle braucht Befestigung Spalte fügt, in einer Komponente angezeigt werden Katalog .

7. Wählen Sie, ob die Einschränkung sein wollen, Behindert, Gewarnt oder Gesetzt.

Notiz

Disabled Einschränkungen werden aus Beschränkungsvalidierungs ignoriert werden, werden gewarnt Einschränkungen eine Warnung in der Validierungsfenster zu produzieren, wenn sie erkannt werden und durchgesetzt Einschränkungen wird ein Fehler bei der Validierung Fenster zu produzieren, wenn sie erkannt werden. Weiterhin müssen alle Fehler, bevor eine gelöst werden Unternehmen Server Projekt kann begangen werden.

8. Klicken OK.

Echtzeit Modellüberprüfung und ZwangGültigkeitserklärung

ABACUS weist einEchtzeit-Model Checking und Überprüfungsfunktion zu sofort anzeigen die Auswirkungen ein bestimmter Benutzer den Betrieb auf haben die Warnungen und Fehler mit dem aktuellen Projekt, auf Grund einer Hierarchie und Topologie Einschränkungen, die definiert wurden. Es sei darauf hingewiesen, dass alle Fehler müssen, bevor ein beigelegt, Unternehmen Server Projekt kann begangen werden.

Die Echtzeit-Beschränkungsvalidierungs Merkmal ist am deutlichsten, wenn das Auffüllen mit Diagrammen oder direkt im Explorer-Fenster. Insbesondere während der folgenden Operationen, Führung mit Farbakzenten in Bezug auf die Auswirkungen der Betrieb wird auf gegeben haben die Warnungen und Fehler mit dem aktuellen Projekt;

1. Beim Ziehen von Elementen auf oder um ein Diagramm der Farbe des Mutterunternehmens (oder Anbringen) Komponente (falls vorhanden) Grenze wird nach dem unten beschriebenen Schema gefärbt sein.

2. Beim Anschluss von Komponenten mit der rechten Maustaste auf Drag | Schließen Um die Liste der verfügbaren Verbindungstypen wird nach dem unten beschriebenen Schema farbig kennzeichnen.

3. Beim Anschluss von Komponenten in Diagrammen mit dem Anschluss-Modus wird der Cursor Farben entsprechend der unten beschriebenen Schema zu ändern.

4. Beim Hinzufügen von Unterkomponenten die Liste der verfügbaren Komponententypen wird nach dem unten beschriebenen Schema gefärbt.

Im Allgemeinen werden die folgenden Farben verwendet werden, um die Auswirkungen der Benutzer den Betrieb wird auf die Warnungen und Fehler mit dem aktuellen Projekt anzuzeigen;

Schwarz : Keine Auswirkungen auf Warnungen oder Fehler.

Grün : Die Bedienung ist explizit in Übereinstimmung mitHierarchie und Topologie Zwänge für das Projekt.

Rot : Die Bedienung ist explizit unter Verstoß gegendie Hierarchie und Topologie Zwänge für das Projekt und wird in Warnungen und / oder Fehlern führen.

Hintergrund Modellüberprüfung und ZwangGültigkeitserklärung

ABACUS umfasst ein Überprüfungsfunktion, um alle Warnungen und Fehler mit dem aktuellen Projekt, aufgrund irgendwelcher Zwänge, die definiert wurden angezeigt. Es sei darauf hingewiesen, dass alle Fehler müssen, bevor ein beigelegt, Unternehmen Server Projekt kann begangen werden.

Notiz

Die Validierung muss manuell über die Schaltfläche Ausführen 'Validate / Projekt Constraints Prüfen "auf die werden Hauptsymbolleiste . Das Fenster Validierung ist standardmäßig ausgeblendetsondern wird angezeigt, wenn die Schaltfläche in der Symbolleiste angeklickt wird. Sehen Anpassen der Schnittstelle für die, wie man sie sichtbar machen und möglicherweise lassen Sie es permanent angezeigt. Außerdem können Sie doppelklicken Sie auf eine beliebige Zeile in der Validierungsfenster zu "springen", um das entsprechende Element in dem Projekt.

Validierungsfenster

Die Standard-Spalten in der Validierungsfenster werden wie folgt beschrieben;

Warnung oder Fehlermeldung: Diese Spalte zeigt ein Symbol für, ob die Verletzung ist eine Warnung (gelbes Dreieck mit einem Ausrufezeichen) oder Fehler (roter Kreis mit einem Kreuz).

Anzahl: In dieser Spalte wird die Verletzung Nummer.

Notiz

Nur 200 Verstöße zu einem Zeitpunkt gezeigt, und wenn es mehr als 200 Verstöße in einem Projekt der Start, Zurück, Weiter und End Reihe Navigatoren in der oberen rechten Ecke des Fensters kann verwendet werden, um die zusätzlichen Verletzungen zu durchsuchen werden.

Beschreibung: Dies ist eine vollständige Beschreibung der Verletzung einschließlich der Entity und Constraint betrifft.

Entity: In dieser Spalte wird die Entity von Belang für die Verletzung.

Art: Diese Spalte zeigt die Elementtyp für die Entity.

Architektur: Diese Spalte zeigt die Architektur, in dem der Verstoß stattgefunden hat.

Erkannt: Diese Spalte zeigt die Zeit, die der Verstoß festgestellt wurde.

Spitze

Es ist nützlich, absteigend durch den erfassten Säule (wie im Dialog oben abgebildet), um sicherzustellen, die jüngsten Verletzungen an der "top" in der Liste angezeigt.

Es gibt mehrere Benutzeroptionen, um das Verhalten des Hintermodellvalidierung zu ändern. Beispielsweise to ändern Sie die für die Einschränkungsverletzungen verwendeten Farben, etwas anderes als das Standard Rot, klicken auf Tools | Options ... dann gehen das GültigkeitserklärungRegisterkarte, und Stellen Sie die Farben über die Veränderung Tasten.

Gültigkeitserklärung Optionen

Um Einschränkungen manuell zu validieren

1. Rechtsklick auf dem ArchitekturenKnoten auf jeder Architektur oder überall in entweder der Components oder AnschlüsseTeil der Explorer-Ansicht und wählen Sie CHECK-Einschränkungen.

Validieren Einschränkungen

2. Drücke den EinzelheitenTaste auf der WarnungenFenster, um zu sehen, wo die Architektur gegen irgendwelche Einschränkungen, die definiert wurden.

Notiz

Verstöße werden nur für die Zwänge, die gesetzt wurden, um gewarnt oder vollstreckt gezeigt. Außerdem der Wortlaut der Warnung schließen "sollte", wenn die Einschränkung war nur eine Warnung oder ein "Muss", wenn es erzwungen wurde.

3. Klicken OK.

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand


Evolving Ihre Architektur

Navigation: Füllen Sie Ihre Architektur> manuell Auffüllen> Zusatzoptionen>

Evolving Ihre Architektur

Senden Sie Kommentare Zu diesem Thema.

Architekturen können explizit entwickelt werden, und eine Hierarchie von Architekturen erstellt. So, indem sie sich Ihre Architektur in ABACUS kann eine Reihe von erweiterten architektonischen Lösungen erstellt werden, verglichen und als Baseline. Ziele (oder Metriken) kann für eine beliebige Anzahl von architektonischen Eigenschaften für vorhandene Architekturen definiert werden.

Ein einfacher Weg, um die Entwicklung einer Architektur prüfen, ist es, um das Konzept der Beziehung Nachfahre Architektur. Wenn eine Architektur entwickelt wird, ein Kopieder Mutter Architektur entsteht. Diese Kopie kann gesagt werden, eine direkte sein Nachkommedes ursprünglichen Elternteil Architektur.

Notiz

In dieser Online-Hilfe und die ABACUS-Toolset selbst, die Laufzeit entwickelnwird häufiger als der Begriff, NachkommeBitte beachten Sie, dass beide auf der gleichen Funktionalität.

Um eine bestehende Architektur zu entwickeln

1. Stellen Sie sicher, Sie haben ein ABACUS-Dateioffen, und der Explorer-Fensterangezeigt.

2. Wählen Sie die entsprechende Architektur, die Sie aus dem Explorer-Baum entwickeln möchten.

3. Rechtsklickauf die Architektur und Auswahl Entwickelnaus dem Menü.

Evolving der gewählten Architektur

4. Die entwickelte Architektur wird unter der gewählten Architektur erscheinen.

Evolved Architektur

Notiz

Die entwickelte Architektur kann durch Rechtsklick auf die Architektur und die Auswahl umbenannt werden Umbenennen.Darüber hinaus werden alle Diagramme und Kataloge in den entwickelten Architektur automatisch eingestellt werden 'diff' gegenüber dem Baseline-Architektur dass es aus entwickelt.

Ziele zu setzen für Ihre Architektur entwickelt

Ziele zu setzen für Ihre entwickelt Architektur ermöglicht es Ihnen, ein Kriterium, um die Entwicklung Ihres Architekturen beurteilen zu erstellen. Ziele werden von den Immobilienarten und die Namen der Objekte in Ihrer Architektur entwickelt bestehenden bestimmt. Ziele können auch manuell definiert werden, und fügte hinzu, um Sie Architektur. Gehen Sie folgendermaßen vor, um Ziele zu setzen.

Ziele setzen auf den bestehenden Liegenschaften für Ihren entwickelte Architektur

1. Stellen Sie sicher, Sie haben ein ABACUS-Dateioffen, und der Explorer-Fensterangezeigt.

2. Wählen Sie Extras | Ziele setzenVon der Hauptmenüleiste.

3. das Goal EingangsFenster wird angezeigt.

Goal Eingabefenster

4. Klicken Sie auf Bestehende Taste.

5. das Wählen Sie eine EigenschaftFenster wird angezeigt.

6. Wählen Sie eine Eigenschaft, die Sie als Ziel festlegen möchten für Ihren entwickelte Architektur und klicken Sie auf die OK Taste.

7. Das ausgewählte Ziel wird nun die erscheinen Goal Eingangs Fenster.

8. Wählen Sie das Ziel und klicken Sie auf die Bearbeiten Taste.

9. das Ziel ändernFenster wird angezeigt.

Notiz

In diesem Fenster können Sie die Eigenschaft Name und Typ, dass das Ziel zu reflektieren, sowie die schlimmsten und besten Wert (oder Minimum / Maximum-Werte) für diese Eigenschaft zu ändern. Diese Werte werden durch Vergleich aller Architekturen und der Suche nach der kleinsten und größten Wert in jeder für die jeweilige Immobilie gefunden. Diese Werte können auch manuell definiert werden. Zum Beispiel, wenn Sie waren, um ein Ziel für die Eigenschaft mit dem Namen gesetzt Response (Ave)und des Typs Verhalten, Könnte Ihr schlechteste und beste Wert der Transaktionsgeschwindigkeit für optimale Leistung (bester Wert) und die Transaktionsgeschwindigkeit nur für Hauptanwendungen benötigt wird, um verarbeitet werden (schlechtester Wert) benötigt reflektieren.

10. Sobald die relevanten Werte definiert wurden, wählen Sie OK.

Festlegung von Zielen aus Neue Angebote entwickelt Architektur

1. Stellen Sie sicher, Sie haben ein ABACUS-Dateioffen, und der Explorer-Fensterangezeigt.

2. Wählen Sie Extras | Ziele setzenVon der Hauptmenüleiste.

3. das Goal EingangsFenster wird angezeigt.

4. Klicken Sie auf Neu Taste.

5. das Neues ZielFenster wird angezeigt.

Notiz

In diesem Fenster können Sie die Eigenschaft Name und Typ, dass das Ziel zu reflektieren, sowie die schlimmsten und besten Wert (oder Minimum / Maximum-Werte) für diese Eigenschaft definieren. Zum Beispiel, wenn Sie waren, um ein Ziel für die Eigenschaft mit dem Namen gesetzt Response (Ave)und des Typs Verhalten, Könnte Ihr schlechteste und beste Wert der Transaktionsgeschwindigkeit für optimale Leistung (bester Wert) und die Transaktionsgeschwindigkeit nur für Hauptanwendungen benötigt wird, um verarbeitet werden (schlechtester Wert) benötigt reflektieren.

6. Sobald die relevanten Werte definiert wurden, wählen Sie OK.

7. Ein Dialog zur In allen Architekturenwird wie folgt angezeigt:

8. Klicke auf Jaum das Ziel als eine Eigenschaft auf alle relevanten Architekturen hinzuzufügen. Dies stellt sicher, daß der neu definierte Ziel und seine Eigenschaften werden zu allen Architekturen in der Datei hinzugefügt werden. Wenn Sie nicht möchten, sind das Eigentum in den Architekturen, können Sie klicken Sie auf Nein.

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Anzeigen einer star Grundstück Ihrer entwickelten Architekturen | Anzeigen einer Streudiagramm Ihrer entwickelten Architekturen


Das Zeichenwerkzeug

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Das Zeichenwerkzeug

Senden Sie Kommentare Zu diesem Thema.

Das Zeichenwerkzeug ermöglicht die Erstellung einer Vielzahl von architektonischen Schaltpläne und Diagramme. Architekten verwenden traditionell eine Reihe von verschiedenen Zeichnungen zu erfassen und übermitteln den Entwurf einer Architektur. Zweidimensionale (2D-) Darstellungen sind die übliche Art zu belegen und den verschiedenen Teilen des Systems. Typische Zeichnungen Typen in Unternehmenssystemen verwendet werden, sind:

· Geschäftsprozessmodelle und Diagramme;

· Organigramme;

· Collaboration-Diagramme;

· Entity-Relationship (ER) Diagramme;

· Datenflussdiagramme (DFD);

· Klassendiagramme;

· IDEF (die mehrere der oben); und

· UML (die mehrere der oben).

Es gibt wirklich keine Begrenzung für die Art der Diagramme, die erstellt werden können. ABACUS versucht Diagramm Flexibilität auszugleichen und gleichzeitig die Integrität der Architektur und ihre Darstellungsformen.

Die Zeichnung ist ein Umfeld Registerkarten und andockbare Fenster innerhalb des Haupt ABACUS-Anwendung. Dieses Fenster enthält eine Leinwand in dem die Zeichnung stattfindet und wenn die Zeichenfenster geöffnet ist eine zweite andockbaren Fenster Das Schablonenfenster ist sichtbar mit einer Reihe von Zeichenschablonen. Der Schablonenbereich verfügt über 4 Registerkarten: Komponenten, Anschluß Formen und Verbindungen. Die Leinwand scheint, als einem weißen Hintergrund mit feinen Gitterlinien (hilfreich für das Layout).

Komponenten werden durch eine Reihe von Formen dargestellt, während Verbindungen als gerichtete Linien gezeichnet. Anschlüsse zu befestigen, um Komponenten mit Rollen (das heißt entweder Source oder Sink) obwohl diese aus ästhetischen Gründen nicht gezeigt.

Spitze

Während Diagrammesind sehr nützlich für die verschiedene Teile eines Systems, sie sind in ihrem begrenzten Skalierbarkeit, weshalb ABACUS setzt 3D bis hin zu komplexen Systemstrukturen zu visualisieren.

Sie können zu wollen,

1. Öffne das Diagrammerstellung Werkzeug

2. Erstellen Sie ein neues Diagramm der Teil einer Ihrer Architektur

3. Kopieren Sie ein Diagramm innerhalb oder zwischen Architekturen

4. In Komponenten einem Diagramm

5. Erstellen Sie neue Komponenten und Verbindungen in Ihrer Architektur (schematisch) mit dem Zeichenwerkzeug

6. Komponenten löschen aus einem Diagramm

7. Bringen & Verbindungen zu manipulieren

8. Ändere das Anzeigeeigenschaften der Komponenten und Verbindungen.

9. Die Nutzung von Links in Diagramm

10. Erzwingen Typzuordnungen und Aussichtspunkte um so die Arten von Diagrammen, die gezogen werden kann, zu beschränken.

Sehe auch

Auffüllen der Architektur | Auffüllen der Architektur Hand | Analysieren Ihre Architektur


Öffnungspläne

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Öffnungspläne

Senden Sie Kommentare Zu diesem Thema.

Die Zeichenschablone und Leinwand-Fenster erscheint automatisch, wenn ein Diagramm geöffnet oder erstellt. Ebenso, wenn ein Diagramm ist geschlossen, Tabbed das entsprechende Blatt in der Leinwand-Fenster verschwindet, und wenn keine weiteren Zeichnungen geöffnet sind, dann wird die Schablone Fenster geschlossen.

Zu erstellenein neues Diagramm

1. Stellen Sie sicher, Sie haben einABACUS-Datei geöffnetmit Ihrer besiedelte Architektur.

2. Klicken Sie auf DiagramSymbol in der Symbolleiste anzeigen.

- oder -

2. Auswählen Einfügen| Diagram.

- oder -

2. Rechtsklick das DiagramsZweig der eine gegebene ArchitekturAbschnitt des Baums, und wählen Sie Erstellen Diagramm.

3. Wähle aus ArchitekturSie aus dem Pull-Down-Menü scharfstellen möchten. Hinweis: Die Architektur wird bereits für Sie ausgewählt werden, wenn Sie verwendet Schritt 3 oben, um das neue Diagramm zu öffnen.

4. Wähle aus Standpunkt die Sie aus dem Pull-Down Menü verwenden möchten. Hinweis: die gewählte Gesichtspunkt werden die Komponenten und Verbindungen Listen nur diejenigen der Sicht zur Verfügung zu filtern.

5. Optional Ein Blick von der wählen Filtern nach AnsichtPulldown-Menü, um die Komponenten und Verbindungen von der gewählten Ansicht vorzuwählen. Hinweis: Dies ist wirksam mit der gewählten Ansicht, wie eine gespeicherte Abfrage.

6. Wähle aus Gestaltung um entweder Radial oder Gitter.

7. Wähle aus Components und Anschlüssedass Sie in der Abbildung aus der willst Standard-Element-Auswahlfenster .

8. Klicken OK.

Notiz

Ein neues Diagramm wird auf die hinzugefügt werden, DiagramsGebiet der Architektur. Es wird ein Standardname, den Sie mit der rechten Maustaste auf sie später ändern können.Außerdem wird der letzte Zustand der Komponenten und Verbindungsauswahlfilter mit dem Diagramm effektiv Speichern des "Abfrage" verwendet, um das Diagramm zu erstellen, gespeichert werden.

Um ein vorhandenes Schema zu öffnen

1. In dem speziellen besiedelten Architektur, erweitern Sie die DiagramsZweig des Baumes.

2. Doppelklick das Diagramm, das Sie öffnen möchten.

Um ein Diagramm zu speichern

1. Stellen Sie sicher, dass Sie eine neue oder bereits vorhandene Schaltbild öffnenund Sie die notwendigen Änderungen vorgenommen haben. Hinweis: ein Sternchen "*" wird nach der View-Namen im Registerblatt-Header angezeigt werden, wenn Änderungen gespeichert werden sollen.

2. In der Explorer-Ansicht klicken Sie auf die sparenButton oder muss Datei| sparenoder drücken Strg + S, um alle Änderungen in Ihrer Architektur zu sparen und schreiben Sie es in eine Datei.

Um ein Diagramm als Abwehr Standpunkt

1. Stellen Sie sicher, dass Sie ein vorhandenes Diagramm in Ihrem ABACUS-Datei haben.

2. RechtsklickDas Schema in der DiagramsTeil des Baumes.

3. Auswählen Speichern als Diagramm Viewpoint.

4. Geben Sie einen Namen für die neue Diagramm Sichtund klicken Sie auf OK.

Sehe auch

Das Zeichenwerkzeug | Auffüllen der Architektur | Analysieren Ihre Architektur


Kopieren Pläne

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Kopieren Pläne

Senden Sie Kommentare Zu diesem Thema.

Es gibt 2 grundlegende Szenarien Kopieren eines vorhandenen Diagramm; innerhalb einer Architektur oder über Architekturen.

Zu Kopieein Diagramminnerhalb einer Architektur

1. Stellen Sie sicher, Sie haben einABACUS-Datei geöffnetmit Ihrer besiedelte Architekturmit mindestens einem Diagramm.

2. Erweitern das Diagrams Zweig (und, falls erforderlich Diagramm Gruppen) eines gegebenen ArchitekturAbschnitt des Baums.

3. Wählen Sie das Diagramm, das Sie kopieren möchten, und drücken Sie Strg + C oder Rechtsklickund wählen Sie Kopie aus dem Menü.

Notiz

A Kopie der Diagramm wird auf die hinzugefügt werden, DiagramsZweig der gleich Architektur. Es wird haben "Kopie" in den Anfang des Namens hängten, Die Sie später ändern können Drücken von F2 oder Rechtsklick auf sieund Umbenennen auswählen.

Zu Kopieren Sie ein Diagramm über Architekturen

1. Stellen Sie sicher, Sie haben einABACUS-Datei geöffnetmit Ihrer besiedelte Architektursmit mindestens einem Diagramm.

2. Erweitern das Diagrams Zweig (und, falls erforderlich Diagramm Gruppen) von das ArchitekturAbschnitt des Baumsfür die Architektur, die das Diagramm die Sie kopieren möchten enthält.

3. Wählen Sie das Diagramm, das Sie kopieren möchten und auf die Allgemeine EigenschaftenFenster der Notiz Standpunkt dass das Diagramm auf (in dem Feld Art) verbunden.

4. Jetzt, erweitern das Diagrams Zweig (und, falls erforderlich Diagramm Gruppen) von das ArchitekturAbschnitt des Baumsfür die andere Architektur, die Sie das Diagramm in kopieren möchten.

5. Rechtsklick das Diagrams Knoten (oder die Diagramm-Gruppe) Und wählen Sie Diagramm erstellen .... In dem Dialog, der erscheint, wählen Sie Standpunkt das wurde in Schritt 3 oben in der Dropdown-rechts oben angemerkt. Lassen Sie alles andere, wie es und klicken Sie auf OK. Im Dialogdiagrammnamen geben Sie einen Namen für die (bald) kopiert Diagramm. Anmerkung: Eine leere Diagramm Leinwand entsprechend dem gewählten Gesichtspunkt wird geöffnet.

6. Zurück zu dem Diagramm, die Sie kopieren und öffnen möchten, dass Rechtsklickder Knoten und Auswählen Öffnen oder einfach Doppelklick es.

7. Wählen Sie den Hintergrund Leinwand des Diagramms die Sie kopieren möchten, und drücken Sie Strg + A. Dadurch werden alle Elemente auf diesem Diagramm wählen. Drücken Sie jetzt Strg + Cum den Inhalt in die Zwischenablage kopieren.

8. Nun kehren Sie zum leeren Diagramm in der Architektur, die Sie den Inhalt in kopieren möchten, Wählen Sie das HintergrundLeinwand und entweder Rechtsklickund wählen Sie Paste oder drücken Sie einfach Strg + Vum den Inhalt einzufügen. Nach einer kurzen Zeit wird der Inhalt aller in die neue leere Diagramm eingefügt werden.

Notiz

Elemente werden in die oberste Ebene der neuen Architektur hinzugefügt werden und werden neu angeordnet werden müssen oder zusammengeführt mit bestehenden Inhalten entsprechend.

Sehe auch

Das Zeichenwerkzeug | Auffüllen der Architektur | Analysieren Ihre Architektur


Bestückungspläne

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Bestückungspläne

Senden Sie Kommentare Zu diesem Thema.

Zeichnungen in ABACUS sind mehr als nur beliebige Darstellungen. Sie werden besonders angefertigt Blick auf die Architektur, formatiert und angeordnet ist, besondere Bedeutung zu zeigen.

Das Zeichenwerkzeug erzwingt die hierarchische Struktur der Architektur, so dass Komponenten werden visuell in andere Komponenten verschachtelt - effektiv geben ein "Draufsicht" der Elemente. Sobald ein Bauteil oder eine Verbindung in die Architektur definiert wurde, kann sie in einer beliebigen Anzahl verschiedener Diagramme verwendet werden. Wichtig ist, dass das Zeichenwerkzeug eng mit dem Architekturmodell verknüpft ist, so dass Änderungen entweder in einem getan werden immer in der anderen wieder.

Das Tool arbeitet durch Zuordnung Formen besonders im Bereich der Architektur Typen definierte Verbindung und Komponententypen. Diese Verbände variieren abhängig von der Art des Diagramms gezeichnet, und es ist möglich, dass eine Art der Komponente (oder eine Verbindung) können verschiedene Darstellungen in den verschiedenen Diagrammen haben, abhängig von dem Kontext.

So richten Sie eine Zuordnung zwischen einer Form und einer Komponente oder Verbindungstyp

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Maximieren Sie die ABACUS-Anwendung und konfigurieren Sie die Fensterproportionen wie Sie wünschen.

3. Wähle aus Formen Registerkarte oder der Steckverbinder Registerkarte im Schablonenfenster.

4. im ArtZweig der Explorer die Komponente oder Verbindungstyp Sie möchten, um mit einer Form oder Stecker zu verbinden.

5. Wählen Sie den gewählten Typ Element aus dem Baum, ziehen Sie sie in das Register Shapes oder Connectors Registerkarte, und legen Sie es auf die Form oder SteckerSie möchten, um zu verwenden.

Notiz

Sie können eine Zuordnung Sie indem Sie die Komponenten oder Registerkarte Verbindungen im Schablonenfenster, das die aktuell zugeordnete Elemente zeigen erstellt haben zu überprüfen.

Um neue Formen, um Ihre Diagramme / Bibliothek hinzufügen

1. Erstellen Sie eine MS Visio-Diagramm mit den Formen, die Sie zu Ihrem Diagramm hinzufügen wollen und importieren Sie die MS Visio-Diagramm .

Spitze

Es ist wichtig, welche Größe Sie das Master-Form in MS Visio zu machen, weil die ABACUS Leinwand wird in Pixel bemessen und nur Millimeter-Einheiten in MS Visio konvertiert granular, um Pixel auf einem 4 Pixel bis 1 Millimeter-Verhältnis. Darüber hinaus sind die Standard ABACUS Formen typischerweise 60 Pixel hoch, so dass übersetzt in 15 Millimeter in MS Visio. Bedeutung eines sinn Master-Formgröße in MS Visioist 25mm breit und 15mm hochda dies zu 100 Pixel breit und 60 Pixel hoch in ABACUS übersetzen.

Spitze

Wenn Sie ein wenig "Symbol" in der oberen linken Ecke eines Form dann können Sie einfach die "Ikone" in der Master-MS Visio-Shape unter Verwendung des MS Visio Drawing Tool-Palette haben wollen (beachten Sie, dass nur einfache Linien, Kreise und Rechtecke werden unterstützt und gerastert / Bitmap-Formen, insbesondere werden nicht unterstützt). Außerdem, wenn Sie wollen, das Symbol zu sein Größe / Skala fixiertinnerhalb der Form im ABACUS, dann können Sie die Gruppe "Ikone" in der Master-MS Visio Form, indem Sie alle Elemente, Rechtsklick auf ein Element, die Auswahl Form | Group, dann mit der rechten Maustaste auf das gruppierte Form und die Auswahl Daten | Formdaten ... die Auswahl Ja in dem Dialogfeld, das angezeigt wird, und dann eine Eigenschaft mit dem Etikett zu setzen LockScale(beachten Sie die Großbuchstaben "L" und "S"), die Art zu setzen Boolean und der Wert eingestellt sein WAHR (beachten Sie, alles in Großbuchstaben ist).

Spitze

Wenn Sie einen Teil der Form von horizontal oder vertikal (wie es typisch mit einem 'Schwimmbahn "-Form) Skalierung eingefroren haben wollen, dann können Sie right-click die Bereich (e) des Master-MS Visio Form, die Sie gefrorene vom Skalierungs möchten und wählen Sie Daten | Formdaten ... die Auswahl Ja in dem Dialogfeld, das angezeigt wird, und dann eine Eigenschaft mit dem Etikett zu setzen LockXScale oder LockYScale (beachten Sie die Großbuchstaben "L" und "S"), die Art zu setzen Boolean und der Wert eingestellt sein WAHR (beachten Sie, alles in Großbuchstaben ist), für gesperrte horizontale oder vertikale Skalierung auf.

Spitze

Um die Färbung der Form im ABACUS nach dem Import nicht die Form stets eine feste Farbe ist es ratsam, füllen Sie den Master-MS Visio Form machen lassen transparent und verwenden Sie die eingebaute Fähigkeit, in ABACUS zu einer Form Hintergrundfarbe. Dies funktioniert nur bei Rechteck oder in der Nähe von-Rechteck (zB Rechteck mit abgerundeten Ecken) Formen, wie die gesamte rechteckigen Hintergrund wird eingefärbt werden.

2. Öffnen Sie das entsprechende Diagramm und wählen Sie die Registerkarte Komponentenim Schablonenfenster.

3. Für jede neue Form, die Sie für andere Diagramme machen wollen Rechtsklickdie Form und wählen Sie In den Formen-Bibliothek. Dadurch wird die Form auf der Registerkarte Formen im Schablonenfenster zur Verfügung.

4. Ordnen Sie den entsprechenden Komponenten-Typ mit der neuen Form der Formen-Bibliothek nach den oben beschriebenen Schritten.

Notiz

Nur einfache und "Vektor-basierte" Formen in ABACUS im Moment unterstützt, sind also Bitmaps nicht unterstützt. Jedoch Tools wie Vector Magic ( www.vectormagic.com ) Zur Verfügung, die leicht zu konvertieren werden Bitmap-Bilder in vektorbasierte Formen (dh SVG-Format), die in MS Visio geöffnet werden kann und somit in ABACUS gemäß den obigen Anweisungen verwendet.

HinzufügenBauteile und Verbindungen

Das Zeichenwerkzeug ermöglicht es Ihnen, fügen bestehenden Komponenten und Verbindungen aus dem Repository oder neue Komponenten und Verbindungen, wie Sie sind, zeichnen ein Diagramm. Als Komponenten und Verbindungen werden in Diagrammen erstellt, werden sie gleichzeitig in der Mehr Quelle. Es gibt drei empfohlen Möglichkeiten zum Hinzufügen von Komponenten zu einem Diagrammund drei empfohlenen Wege der Zugabe von Verbindungen zu einem Diagramm:

Eine völlig neue Komponente oder Verbindung in einem Diagramm erstellenvon der Schablonen

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Wähle aus Components oder AnschlüsseRegisterkarte im Schablonenfenster, um die zugehörigen Formen zu sehen. Nur diese Formen verwendet werden, um neue Modellelemente zu schaffen.

3. Klicken und Zieheneine der verfügbaren zugehörigen Formen auf das Zeichen Leinwand. Das neue Element wird auf der Leinwand und im Explorer-Baum erscheinen.

4. Beginnen Sie,einen Namen für das neue Element im Dialog und eventuell vorhandene Elemente, die angepasst sind vorgeschlagen und kann eher als das Hinzufügen eines neuen Elements auf die Architektur gewählt werden.

5. Klicken OK.

6. Eine Form, wurde auf eine vorhandene Komponente sank, dann wird entweder ein Kind dieser Komponente werden (wenn die Form aus dem kam Componentstab), oder wird auf diese Komponente befestigt werden (wenn die Form aus dem kam Anschlüsse Tab).

Notiz

Es ist manchmal notwendig, um die neue Komponente oder Verbindung in einem anderen Ort in der architektonischen Hierarchie mit dem Explorer anpassen.

Um eine vorhandene Komponente oder Verbindung von dem Ort, Quelle auf ein Diagramm,

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Seien Sie sicher, dass Sie sowohl das Zeichenwerkzeug und Explorer-Fenster sichtbar sind.

3. In der Explorer den Komponente oder Verbindung(element) Sie möchten, um zum Diagramm hinzufügen.

4. Klicken und Ziehendas ausgewählte Element auf dem Diagramm. Eine Form, die das Element wird auf der Leinwand angezeigt.

Notiz

Wenn der Typ des gewählten Element bereits mit einer Form zugeordnet ist, wird die entsprechende Form auf der Leinwand erscheinen. Wenn jedoch gibt es keine definierte Assoziation für das jeweilige Element, wird ein Standardform (Rechteck) auf der Leinwand erscheinen, es sei denn, die Erzwingen Diagramm Aussichtspunkte Option ist in diesem Fall die Form nicht auf dem Diagramm hinzugefügt werden.

Spitze

Wenn eine Komponente in einem Diagramm, die zu einer anderen Komponente bereits auf dem Diagramm verbunden ist platziert, wird das Zeichenwerkzeug abfragen, wenn Sie möchten, um die Verbindung (en) zwischen ihnen zu zeigen. Auch, wenn es irgendwelche Kinder der Komponente der Zeichnung Tool wird abgefragt, wenn Sie möchten, um die Kinder sind, in einer rekursiven Weise.

Zu eine Verbindung zwischen 2 Komponenten oder einer angeschlossenen Komponente auf ein Diagramm mit Hilfe von dynamisch-Anschluss

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Schweben über eine Komponente auf das Diagramm, das Sie zu einer anderen Komponente anschließen wollen, und Sie werden feststellen, 2 Symbole werden außerhalb der oben rechts auf der Grenze der Form, wie unten dargestellt. Hinweis: Das obere Symbol ist für die Schaffung einer Verbindung, bei der die hovered- Komponente ist mit der Quelle ist, ist die untere Symbol für die Schaffung einer Verbindung, bei der die hovered- Komponente zur Senke sein.

3. Bewegung Den Cursor auf den gewünschten Symbol und Klicken und Ziehendas Symbol, um entweder über eine andere Komponente oder freien Raum auf der Leinwand über wie unten dargestellt.

4. Um zu einer vorhandenen Komponente zu verbinden wählen das Anhängen an...Element im Popup-Menü und bei Bedarf wechseln Sie zu dem Untermenü, um aus den verfügbaren Verbindungstypen auswählen.

- oder -

4. So erstellen Sie eine angeschlossene Komponente aus der wählten Neu...Elemente im Popup-Menü und bei Bedarf wechseln Sie zu dem Untermenü, um aus den verfügbaren Verbindungsarten wählen, wie unten dargestellt. Beginnen Sie,einen Namen für das neue Element im Dialog und eventuell vorhandene Elemente, die angepasst sind vorgeschlagen und kann eher als das Hinzufügen eines neuen Elements auf die Architektur gewählt werden.

Notiz

Die Verfügbarkeit der Elemente im Popup-Menü und Untermenü wird durch die Regierten Beschränkungen im Metamodell.Das ist nur die gültige Quelle oder Senke Komponententypen wie von Verbindungseinschränkungen festgelegt werden, wie der anbringen und ... und ... Neue Menüpunkte vorgestellt.

Zu Wiedereröffnung der Elementauswahl-Dialog und stellen Sie vorhandene Komponenten oder Verbindungen aus dem Repository auf ein Diagramm,

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Klicken das Offene ElementauswahlSchaltfläche in der Symbolleiste Diagramm. Anmerkung: der Auswahldialog Element wird mit dem letzten Stand der alle Filter gespeichert wurden.

3. Wählen Sie alle zusätzlichen Inhalte, die gewünscht wird, auf das Diagramm, und klicken Sie hinzugefügt werden OK. Hinweis: der neue Inhalt wird auf der Leinwand, um Freiraum hinzugefügt werden und das Diagramm kann anschließend wieder gelegt über das Layout-DiagrammSchaltfläche in der Symbolleiste Diagramm.

Mit FreeFormShapes

Es ist oft wünschenswert, optische Elemente in einem Diagramm aus rein ästhetischen Gründen zu schaffen. Diese Elemente können dazu beitragen, das Layout und das Erscheinungsbild eines Diagramms, aber sie haben nicht eine strenge architektonische Bedeutung. Das Zeichenwerkzeug ermöglicht die Verwendung von Freiformflächen zu zeichnen Flexibilität bieten.

Um einen Freiform zu einem Diagramm hinzufügen

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Wähle aus Shapes oder SteckverbinderRegisterkarte im Schablonenfenster.

3. Klicken und Zieheneine der verfügbaren Formen oder Anschlüsse auf die Zeichenfläche. Das neue Element wird auf der Leinwand erscheinen - aber nichtim Explorer-Baum.

Notiz

Freiformen sind "nicht-assoziierten" Formen, wie sie keine Verbindung mit einer bestimmten Komponente oder Verbindung in der Architekturmodell haben.

Zu Anzeigen Repository-Informationen in Freiform-FormSohnein Diagramm

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Rechtsklickdie Freiform, und wählen Sie Annotation | Anzeigen.

3. Wählen Sie entweder das Display Diagramm-Name, Diagram Beschreibung, Diagramm der Immobilie, Viewpoint-Name oder Architektur Namens.

Notiz

Der Text in der Freiform wird automatisch als die zugrunde liegenden Daten-Repository Änderungen zu aktualisieren.Auf diese Weise kann für ein Diagramm "Plankopf" erstellt werden und dann leicht über, kopiert Diagramme.

Mithilfe der schwebenden Formen

Floating-Formen sind im wesentlichen ein weiterer Weg, um Komponenten in einem Diagramm dar. Betrachten wir eine Organisation mit den wichtigsten Geschäftsbereiche: CEO, Marketing, Vertrieb und Entwicklung.

Baumsicht

Diese Bereiche können visuell in einer geschichteten Art und Weise dargestellt werden:

Layered anzeigen

Oder sie können visuell in einer gestaffelten dargestellt werden / Schwimm Weise Hierarchie zeigen:

Gestaffelt / Schwimmende Aussicht

Letztere Darstellung verwendet das Konzept des schwimmenden Formen.

Um eine geschichtete Komponente Form in eine schwimmende Form zu konvertieren

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Wähle aus Komponenteim Diagramm, die Sie als schwimmende Form oder einer zugeordneten Form in das darstellen wollen ComponentsRegisterkarte des Schablonenfenster Sie alle Instanzen als schwimmende Formen möchten.

3. Rechtsklicken Sie auf die Form und wählen Sie Float Component aus dem Kontextmenü, das angezeigt wird. Beachten Sie die Diamant-Leitung Verbindungvon der Mutterkomponente (n) mit dem schwimmenden Komponente (n).

4. Klicken und Ziehendas Bauteil an den gewünschten Ort. Wenn ein schwimmendeKomponente wird gewählt, wird er eine blaue Kontur haben.

, Eine schwimmende Komponentenform in einer geschichteten Form umzuwandeln

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Wähle aus Komponentein Ihrem Diagramm, das derzeit als schwimmende Form oder einer zugeordneten Form in der gezeigten ComponentsRegisterkarte des Schablonenfenster Sie alle Instanzen als geschichtet Formen möchten.

3. Klicken und Ziehendie schwimmende Komponente (n) zurück in die übergeordnete (n) (nach der Diamant-Leitung Verbindung). Hinweis: Wenn Sie dies nicht tun, dann, wenn Sie die Komponente (n) zu konvertieren zurück zu sein überlagert die Hierarchie des Modells betroffen sein könnten.

4. Rechtsklicken Sie auf die Form und die unselect Float Component aus dem Kontextmenü, das angezeigt wird. Beachten Sie, dass die Diamant-Leitung Verbindungvon der Mutterkomponente (n) mit dem schwimmenden Komponente (n) verschwinden.

Replicas

Das Zeichenwerkzeug ermöglicht es Ihnen, fügen die gleiche Komponente eines Diagramms mehrmals mit jedem zusätzlichen visuellen Instanz der Komponente in dem Diagramm als ein Replikat bezeichnet. Dies ist insbesondere nützlich für die Diagramme in dem eine Komponente eine große Anzahl von Verbindungen mit ihm verbunden, und es ist bevorzugt, die Komponente in mehreren Orten näher zu dem Ursprung der jede der Verbindungen zu zeigen oder für Diagramme wobei eine Eins-zu-viele-Beziehung einer Komponente ist bevorzugt, um die Verwendung des schwebenden Merkmal (oben beschrieben) mit dem Bestandteil an mehreren Stellen auf der Oberseite der "viele" Komponenten an sich mit.

Notiz

Sie können ein Anbringen / Lösen Verbindungen von / aus der ursprünglichen Instanz der Komponente in einem Diagramm (wie immer), sondern auch eine der Repliken jedoch, wenn Verbindungen werden automatisch in das Diagramm eingetragen werden sie der ersten Instanz der Komponente gebunden sind, auf das Diagramm standardmäßig.

Notiz

Replicas können miteinander verschmolzen werden rechte Maustaste und ziehendann Auswählen Merge ReplicasJedoch Verschmelzung eine Replik mit einer anderen Komponente in allen anderen Repliken verschwinden aus dem Diagramm zur Folge haben.

Notiz

Es gibt keinen visuellen Unterschied zwischen dem ursprünglichen Instanz einer Komponente in einem Diagramm und alle Repliken. Darüber hinaus ist das Rechtsklick-Menü für die ursprüngliche Komponente auf ein Diagramm und jede Repliken identisch, zum Beispiel Im Explorer anzeigendie Sie zu derselben Komponente in der Strukturansicht des Repositorys (aka Modell). , Der rechten Maustaste jedoch die Komponente in der Strukturansicht des Repository und Auswahl Gehe zuund das Surfen auf ein Diagramm mit Repliken gelangen Sie immer an die "älteste" Instanz der Komponente auf das Diagramm. In der Regel wird dies ursprünglichen Instanz, die an das Diagramm hinzugefügt wurde, aber wenn das ursprüngliche Instanz wurde anschließend gelöscht oder verschmolzen mit einer Replik dann Gehe zu wird zu den ältesten der verbleibenden Kopien, die hinzugefügt wurden springen.

Zu fügen Sie eine Replik auf eine Diagramm

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Rechtsklicken Sie auf eine vorhandene Komponente auf das Diagramm, und wählen Sie Replik erstellen.Eine Replik des ausgewählten Komponente auf der rechten Seite der ursprünglichen Komponente erzeugt werden.

- ODER -

Wählen Sie eine vorhandene Komponente auf einem Diagramm, und drücken Sie Strg + Coder rechten Maustaste auf eine vorhandene Komponente auf das Diagramm, und wählen Sie Kopie. Jetzt rechten Maustaste auf die Stelle auf dem Diagramm, dass Sie die Replik möchten, und wählen Sie Einfügen als Replica. Hinweis: Durch Drücken Sie Strg + V (oder mit der rechten Maustaste und wählen Einfügen) eine Kopie der ursprünglichen Komponente nicht eine Replik erstellen.

- ODER -

Klicken und Zieheneine Komponente aus der Baumansicht des Repository (auch bekannt als das Modell) auf ein Diagramm, in dem die Komponente bereits vorhanden ist.

Konfigurieren der Verbindungs ​​Caps / Ends

Das Zeichenwerkzeug ermöglicht es Ihnen, stellen Sie die an den Enden der Verbindungsleitungen entweder zu einem festen Symbol oder ein Symbol abhängig von einer Eigenschaft auf der Verbindung selbst verwendete Symbol.Dies ist besonders nützlich für Diagramme, wo die Richtung einer Verbindung erforderlich ist, angezeigt werden können, oder für Diagramme wobei die Kardinalität der Verbindung (oder die Richtung) in einer Eigenschaft auf die Verbindung selbst, zB enthaltenen "One-to-Many" vs "Many-to-Many" (oder "Quelle zur Senke" vs "Sink zur Quelle").

Zu konfigurieren Sie die Verbindungskappen / endet am ein Diagramm

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet.

2. Wähle aus VerbindenIonenRegisterkarte im Schablonenfenster.

3. Rechts clecken einer der zugeordneten Verbindungstypen und wählen Sie Konfigurieren Caps ....

4. Für eine feste Anschlusshaube / Ende entweder an der Quelle oder Senke Ende der Verbindung sicherzustellen, dass die einschlägigen Fester Radio-Button ausgewählt ist, und wählen Sie dann das Anschlussende Symbol aus dem Pull-Down, zB "Pfeilspitze" oder "Diamond '.

- ODER -

Für eine eigenschaftsbasierte Anschlusshaube / Ende entweder an der Quelle oder Senke Ende der Verbindung sicherzustellen, dass die einschlägigen Mit Hilfe der ImmobilieOptionsfeld gewählt ist, klicken Sie auf die Schaltfläche "..." und wählen Sie die erforderliche Eigenschaft und dann neben jedem Verbindungsende Symbol geben die Eigenschaftswerte, für die gezeigt werden, die spezifische Verbindungssymbol sind.

Notiz

Mehrere Eigenschaftswerte für eine bestimmte Verbindung Endesymbol können durch Komma getrennt werden eingegeben. Z.B. die folgenden Dialog zeigt, dass, wenn der 'Data | Kardinalität Eigentum hat einen Wert von "One-to-Many", dann die Quelle Ende der Verbindung werden zwei Linienstriche durch sie und das Waschbecken Ende der Verbindung wird durch sie haben eines Linienstrich und dann ein Fan-out von zwei Linie Schlaganfälle am Ende.

Konfigurieren Caps Dialog

Sehe auch

Das Zeichenwerkzeug | Auffüllen der Architektur | Analysieren Ihre Architektur


Bearbeiten von Diagrammen

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Bearbeiten von Diagrammen

Senden Sie Kommentare Zu diesem Thema.

Sobald ein Diagramm erstellt worden ist, können die Elemente, die darin erscheinen neu arrangiert werden, und re-sized, wie gewünscht.

Um eine Komponente in einem Diagramm zu bewegen

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Klicken und Haltenjede Komponente, um sie zu bewegen. Wenn die ausgewählte Komponente eine übergeordnete, wird die übergeordnete Komponente hervorgehoben.

3. Als das Elementgeschleppt von der übergeordneten Komponente, und über weitere Komponenten, 'potenziell' Eltern wird hervorgehoben. Das Farbschema verwendet wird, zeigt die Wirkung der Betrieb wird auf die Warnungen und Fehler mit dem aktuellen Projekt zu haben und ist in Festlegung und Validierung von Constraints . Auf diese Weise können Sie grafisch die Hierarchie navigieren von einem "Draufsicht".

4. Freisetzungdie Maustaste los, um das Element in seiner neuen Position abzulegen.

Notiz

Sie können auch die Tastatur verwenden, um Elemente auf der Zeichenfläche neu positionieren. Wählen Sie einfach das Bauteil oder freier Form Form, die Sie sich zu bewegen und mit den Pfeiltasten auf der Tastatur, um die Form an die gewünschte Stelle zu verschieben.

Beachten Sie auch, dass, wenn das Ziehen einer Komponente mit der Maus über eine andere Komponente ist ein "Potenzial" übergeordnete Komponente markiert, wenn der linken oberen Ecke der Komponente Sie ziehen eine andere Komponente überschneidet.

Spitze

Freiform- und Schwimmende Formen kann bestellt werden Rechtsklickund Auswählen Nach vorne bringen oder In den Hintergrundaus dem Menü. Es ist wichtig zu beachten, dass Bauteilformen kann auf Freiformen überführt werden Rechtsklickauf bestimmte Bauteilform und Auswahl Umwandlung in Freiform-.

Um eine Komponente in einem Diagramm die Größe

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Klicken-hold-Drageiner der Handgriffe der Komponente und die Größe der Form auf die gewünschte Größe.

3. Alternativ zum Seitenverhältnis des Form beizubehalten, drücken Sie Shift + Klick-hold-Drag.

Um eine Verbindung in einem Diagramm zu bewegen

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Klicken und Halteneine Verbindung, um es zu bewegen.

3. Freisetzungdie Maustaste los, um das Element in seiner neuen Position abzulegen.

Notiz

Sie können nur Verbindungen, die nicht auf alle Komponenten befestigt sind, zu bewegen. Wenn sie gebunden sind, können Sie nur das freie Ende zu bewegens, oder Neuberechnung der Route die Verbindung .

Löschen von Komponenten und Anschlüsse

Beim Löschen einer Komponente oder Verbindung von einem Diagramm, haben Sie die Möglichkeit, um es von der gesamten Architektur löschen. Jede Komponente, die von der Architektur gelöscht wird automatisch von allen anderen Diagrammen stellt sich heraus, entfernt werden. Da Freiform-Instanzen in einem Diagramm werden nur angezeigt, sie zu löschen keinen Einfluss auf die Architekturmodell oder ein anderes Schaltbild.

Um eine Komponente oder eine Verbindung aus einem Diagramm löschen

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Klickenauf jedem zugehörigen Verbindung oder eine Komponente, um sie auszuwählen.

3. Drücken Sie die LöschenSchlüssel, um es aus dem Diagramm zu löschen, oder Umschalt + Entfum sie aus dem gesamten Modells löschen.

- oder -

2. Rechts-Klick auf eine damit verbundene Element oder Bauteil. Ein Kontextmenü erscheint.

3. Auswählen Löschen anzeigen oder Löschen Architekturaus dem Kontextmenü.

Notiz

Wenn das Element, das Sie aus der Ansicht löschen möchten, hat keine Kinder und tritt nur auf dieser Ansicht wird ABACUS gefragt, ob Sie das Element aus dem Repository als auch löschen möchten.

Vorsicht

Beim Löschen einer Komponente aus dem Modell, das Kind-Komponenten hat, die Kinder werden möglicherweise auch nach der Warnmeldung gelöscht.

Zusammenführen von Komponenten

Sie können fusionieren zwei Komponenten bestehenden auf demselben Diagramm (und innerhalb der Architektur). Dies kann aus verschiedenen Gründen durchgeführt werden, beispielsweise, Zwei Server innerhalb von Infrastruktur- H eines Unternehmens vorhanden ist01 und H02. Diese beiden Server sind als zwei getrennte Komponenten in einer Architektur dargestellt. H01 wurde die Auffassung nicht notwendig und ist es außer Betrieb genommen werden damit. Alle bestehenden Anwendungen auf H läuft01 sind an H verschoben werden02 (noch in der Kommission). Diese Veränderung kann dann durch die Wirkung der "merging" der beiden Komponenten H widerspiegeln01 und H02 im Diagramm (und innerhalb der Architektur).

Für eine ausführliche Diskussion über die Zusammenführung entnehmen Sie bitte dem Zusammenführen von Artikel Thema beziehen Hier .

Um zwei vorhandenen Komponenten zusammenführen

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechts-Klick-Haltenauf der Komponente, die Sie zusammenführen möchten, und ziehenes auf die Komponente, die Sie sie mit zusammenführen möchten. Sicherzustellen, dass der Umriss des Zielkomponente wird rot markiert, um anzuzeigen, dass es ausgewählt ist.

3. Auswählen Zusammenführen | Preserve Destination oder Überschreiben Destinationaus dem Menü.

Notiz

das Preserve DestinationOption bewahrt die Werte der Eigenschaften der Zielkomponente, wenn sie auf den Ursprung-Komponente gibt es ebenfalls.

das Überschreiben DestinationOption überschreibt die Eigenschaften der Zielkomponente mit beliebigen gemeinsame Eigenschaften von dem Ursprungskomponente.

Ändern Anschlüsse

Die im Diagramm dargestellten Verbindungen immergeben die Struktur wie in der Architektur selbst definiert. Das Zeichenwerkzeug können Sie Verbindungen von Komponenten zu lösen, verschieben Sie sie, Kurve ihnen Neuberechnung der Route ihnen und wieder bringen Sie sie an andere Komponenten.

Anbringen / Abnehmen eine Verbindung von / zu einer Komponente

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Klicken und Haltenauf jedem Anschluss.

3. Auswählen die Verbindung Ende(d.h. Source oder Sink), Die Sie gerne Anbringen / Abnehmen. Hinweis: die Verbindungsenden mit kleinen weißen Kreise angezeigt und schwebt über dem weißen Kreis für eine Sekunde ein "Tooltip", um mit dem jeweiligen erscheinen lassen Rolle Name(das heißt entweder Source oder Sink).

4. Ziehendie Verbindung zu beenden, um eine neue Position (entweder einen freien Platz oder eine Komponente) und lassen Sie die Maustaste los.

Notiz

Wenn ein Verbindungsende über einer gültigen Komponente platziert wird, wird der Umriß der Zielkomponente mit einer gestrichelten Umriss hervorgehoben. Das Farbschema verwendet wird, zeigt die Wirkung der Betrieb wird auf die Warnungen und Fehler mit dem aktuellen Projekt zu haben und ist in Festlegung und Validierung von Constraints . Einmal freigesetzt dass Ende the Verbindung und die Komponente werden automatisch verbunden(oder im Anhang)Und dies wird in der Architekturmodell wider.

Um eine neue Route eine Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Positionieren Sie den Mauszeiger über eine Verbindung.

3. Halten Sie die VerschiebenTaste gedrückt und Klickendie Maustaste, um eine Verbindung Ankerpunkt zu platzieren. Befreit das Verschieben Taste. Sie können den Ankerpunkt, indem Sie die gleiche Operation zu entfernen.

4. Klicken und Ziehender Ankerpunkt, um eine neue Route die Verbindung.

Spitze

Verwenden Sie dieAlt Anstelle des Tasters VerschiebenSchlüssel zum orthogonalen Verbindungen erstellen.

Zu Kurve oder gerade eine Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Positionieren Sie den Mauszeiger über eine Verbindung.

3. Rechtsklickter Anschluss und im Kontextmenü, das erscheint, wählen Sie Kurve, Senkrecht oder Gerade.

Spitze

Alle VerbindungenKlick rechts die zugehörige Linie für die Art auf die eines bestimmten Typs auf dem Diagramm kann auf Curved, Orthogonal oder Gerade durch eingestellt werden Registerkarte Verbindungen des Schablonenfensterund Auswählen Curve, Orthogonal oder Hetero.

Zu Anker auf einen bestimmten Punkt auf dem Rand einer Form

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Wählen Sie eine Verbindung.

3. Positionieren Sie den Mauszeiger über die "weißen Punkt" am Ende eine Verbindung.

4. Rechtsklickter Verbindung zu beenden und im Kontextmenü, das erscheint, wählen Sie Verankern Endpoint Shape.Bewegen die Verbindungsende zu dem Wunsch Lage am Rand der Form.

ODER

Halten Sie die CtrlTaste gedrückt und clecken und ziehen das Anschlussende zeigen auf der Wunsch Lage am Rand der Form.

Notiz

Verbindungen werden auf die tatsächliche Schnittpunkt ihrer verbundenen Form anstelle des Begrenzungsrahmens dieser Form einrasten.

Sehe auch

Das Zeichenwerkzeug | Auffüllen der Architektur | Analysieren Ihre Architektur


Zeichenwerkzeug Merkmale

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Zeichenwerkzeug Merkmale

Senden Sie Kommentare Zu diesem Thema.

Das Zeichenwerkzeug unterstützt eine Reihe von Zeichenfunktionen.

Zoomen

Die Skala des Diagramms kann mit Hilfe der Zoom-Funktion geändert werden.

Um den Maßstab oder "Zoom in" zu verringern

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Drücken Sie Ctrlund die '=' Taste.

- oder -

2. Wähle aus HineinzoomenTaste auf der DiagramSymbolleiste.

- oder -

2. Drücken Sie Ctrlund drehen Sie das Mausrad Vorwärts-. Hinweis: In diesem Modus wird die Leinwand in Richtung, wo die Maus über die Leinwand schweben zu vergrößern.

Um den Maßstab zu erhöhen oder "verkleinern"

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Drücken Sie Ctrlund '-' Taste.

- oder -

2. Wähle aus RauszoomenTaste auf der DiagramSymbolleiste.

- oder -

2. Drücken Sie Ctrlund drehen Sie das Mausrad rückwärts. Hinweis: In diesem Modus wird die Leinwand wird nach außen, von wo aus die Maus über die Leinwand schweben zu vergrößern.

Auto-Layout

Die Anordnung der Komponenten in dem Diagramm können automatisch geändert werden.

Um das Layout alle Komponenten on ein Diagramm

1. Clecken das Layout-DiagrammTaste auf der Diagrammsymbolleiste.

2. Auswählen entweder Radial-Layout oder Gitterstruktur.

Notiz

Radialer Anordnung verwenden, was man eine "Kraft-gerichtete" -Algorithmus, daß verbundene Komponenten zusammengezogen werden, während nicht verbundenen Komponenten auseinandergedrückt werden. Die Grid-Layout verwenden eine feste Breite und Höhe Abstandsalgorithmus. Es ermöglicht zum einen der Benutzer, um die Gesamtbild-Seitenverhältnis zu wählen (zB 16: 9, A4 (Hochformat), Buchstabe (Landschaft)) und dann der Abstand an den Seiten und zwischen den Spalten und Zeilen wie unten gezeigt.Mit Grid-Layout irgendwelche Verbindungen zwischen den Komponenten haben keine Auswirkungen auf das Layout, wie es einfach ordnet die Komponenten alphabetisch (nach ihrem Namen) von oben links nach unten rechts von der Leinwand. Mit beiden Algorithmen Freiformflächen werden nicht verschoben.

Um das Layout Kinder Komponenten in einem einzigen übergeordneten on ein Diagramm

1. Rechtsklickein High-Level-Komponente, deren Kinder Sie Auto-Layout möchten.

2. Auswählen Layout Kinder.

Notiz

Standardmäßig werden nur die Radial-Layout-Algorithmus verwendet.

Ändern Element Ästhetik mögen Farbe, Transparenz, Schatten und Rotation

Alle Diagrammelemente müssen Ästhetik, die beliebig manipuliert werden kann. Im Fall der zugehörigen Formen, können diese Aspekte festgelegt werden pro Typund in den meisten Fällen auch pro Instanz. Im Fall von Freiformen können diese Eigenschaften festgelegt werden pro Instanzauf der Leinwand.

Notiz

Jede pro Instanz Aspekte, die für die damit verbundenen Formen festgelegt wurden, wird "überschrieben" werden, wenn die gleichen Aspekt ist für den entsprechenden Typ geändert.

Um die Farbe eines zugeordneten Form oder eine Freiform-Form zu ändern

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Freiform-Form auf der Leinwand.

3. Auswählen Farbe ändern.

4. Wähle aus Feste FarbeOptionsfeld (falls zutreffend).

5. Wählen Sie eine Grundfarbe oder Definieren Sie eine kundenspezifische Farbe im Dialog und klicken Sie auf OK.

- oder -

4. Wähle aus GradientOptionsfeld (falls zutreffend).

5. Wählen Sie entweder Horizontal, Vertikal, Vorwärts oder Rückwärts Diagonal Diagonal zur Gradientenrichtung im Pulldown und klicken Sie auf OK.

6. Wählen Sie eine Grundfarbe oder Definieren Sie eine kundenspezifische Farbe im Dialog für Anfang und Endeund klicken Sie auf OK.

Notiz

ABACUS wird den Vordergrund einer Form, wenn Farbe;
a) es sich um eine "einfache" Form mit einem einzigen zugrunde liegenden Grafikelement (zB Kreis, Rechteck, Polygon, etc.), oder
b) es sich um eine "komplexe" Form mit mehreren zugrunde liegenden subshapes, die alle die gleiche Farbe / Farbverlauf als voneinander sind oder die subshapes haben LockScale = TRUE gesetzt.
Wenn die oben genannten Bedingungen nicht erfüllt sind, wird der Hintergrund des Form ist farbig.

Um die Farbe eines zugehörigen Formsatz nach einer Immobilie

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster(NICHT auf der Zeichenfläche).

3. Auswählen Farbe ändern.

4. Wähle aus Mit Hilfe der Immobilie Radio knopf.

5. Wählen Sie eine Eigenschaft durch Klicken auf die Schaltfläche "..." rechts neben dem Textfeld.

6. Wähle aus Angebot Radio knopf.

7. Stellen Sie die Min und MaxWerte wie gewünscht. Hinweis: Jeder Wert unter den Minimalwert wird als Min Farbe angezeigt und jeder Wert über dem maximalen wird als Max Farbe dargestellt werden. Auch bei der Verwendung von Boolean, List oder Datum / Zeit Eigenschaften werden die Werte auf einen Index wie folgt umgerechnet; Boolean (False = 0, True = 1), List (eine ganze Zahl vale von 1 bis n für jeden gültigen Wert in ihren aufsteigender Reihenfolge im Feld Einheiten angegeben) und Datum / Zeit (Anzahl der Tage seit dem 1. Januar 1900 - einschließlich der Dezimalstellen für Stunden, Minuten, Sekunden Portionen - und wenn das Datum vor 1990 ist es eine negative Zahl).

8. Wählen Sie eine Grundfarbe oder Definieren Sie eine kundenspezifische Farbe im Dialog für Min und Maxund klicken Sie auf OK.

Spitze

Ob Grün (RGB - 128,255,0) wird als Min Farbe ausgewählt und Rot (RGB - 255,0,0) als Max-Farbe für ein Objekt mit Wertebereich gewählt 1 zu 4dann ein Wert von 1wird angezeigt als GrünEin Wert von 2 als Gelb, 3 als Orange und 4 als Rot.

Alternativ können für eine Reihe von Immobilien 1 zu 3ein Wert von 1als sein GrünEin Wert von 2 als Gelb und 3 als RotAuch bekannt als: "Traffic Lights" oder RAG-Status.

Eine Immobilie Bereich von 1 bis 5, falls Blau (RGB - 0,0,255) wird als Min Farbe ausgewählt und Rot (RGB - 255,0,0) gewählt, wie das Max-Farbe ein Wert von 1 wird als sein BlauEin Wert von 2, wie WasserEin Wert von 3, wie GrünEin Wert von 4 als Gelb und ein Wert von 5 als Rot.

Eine Immobilie Bereich von 1 bis 6, falls Violett (RGB - 255,0,255) wird als Min Farbe ausgewählt und Rot (RGB - 255,0,0) gewählt, wie das Max-Farbe ein Wert von 1 wird als sein ViolettEin Wert von 2, wie BlauEin Wert von 3, wie WasserEin Wert von 4 als GrünEin Wert von 5 als Gelb und ein Wert von 6, wie Rot.

Und schließlich für eine Eigenschaft Bereich von 1 bis 7 einen Wert von 1 wird als sein ViolettEin Wert von 2, wie DunkelblauEin Wert von 3, wie HellblauEin Wert von 4 als Blau GrünEin Wert von 5 als GrünEin Wert von 6, wie Gelb und ein Wert von 7 als Rot

Notiz

Lesen Sie den Hinweis oben auf den Vordergrund gegenüber Hintergrundfarbe.

- oder -

7. Wähle aus Bestimmten Wert Radio knopf.

8. Drücke den Ändern Farben Taste.

9. Wählen Sie jeden Wert wiederum ein und klicken Sie Set Farbeum eine bestimmte Farbe für jeden Wert zu setzen.

Notiz

Der Wertebereich für den in der Abbildung vorhandenen Elemente werden bereits ausgefüllt.

10. Um zusätzliche Wert Farben zu jenen vorausgefüllt (zum Beispiel nach dem Immobilienbereich neu konfiguriert wurde) Klick hinzufügen Mehrwert.

Um die Farbe zu Transparenz eines zugeordneten Form oder eine Freiform-Form zu ändern

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Freiform-Form auf der Leinwand.

3. Auswählen Farbe ändern.

4. Im Transparenzbedienfeld stellen Sie den oberen Schieberegler auf die gewünschte Transparenz für die Grundfarbe.

5. Wenn der Gradient oder Verwenden von Eigenschaftsoptionen verwendet werden, in der Transparenz-Panel stellen Sie den unteren Schieberegler auf die gewünschte Transparenz für die zweite Farbe.

6. Klicken OK.

Zeigen Schatten für alle der damit verbundenen Formen in einem Diagramm

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der ComponentsRegisterkarte des Schablonenfenster.

3. Auswählen Hinzufügen Schatten.

Zu zeigen einen Schatten auf Bestandteil Form oder Freiform

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Recht-klickenauf der Komponente oder Freiform-Form auf der Leinwand.

3. Auswählen Hinzufügen Schatten.

Zu Komponente Formen und Freiform Formen in Diagrammen zu drehen

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Wählen Sie die Komponente Form oder eine Freiform-Form auf der Leinwand das Sie drehen möchten.

3. Rechtsklickauf Form und wählen Sie Drehenund wählen Sie den entsprechenden Winkel Sie die Form durch drehen möchten.

Ändern Element Anmerkungen und Freiform-Text Labels

Alle Bildelemente haben Anmerkungen die beliebig manipuliert werden kann. Im Fall der zugehörigen Formen, können diese Aspekte festgelegt werden pro Typund in den meisten Fällen auch pro Instanz. Im Fall von Freiformflächenund Stecker, dasBeschriftungen kann eingestellt werden pro Instanzauf der Leinwand.Acht (8) unterschiedliche Arten von Annotationen für Diagrammelemente angezeigt werden (dh Name, Typ, Objekt Wert, Property Marker, Anbauteile, Kinder (nur für Komponenten), Standards und Zeitstempel (Erstellt, Geändert von, etc.)) in zwanzig fünf (25) verschiedenen Positionen (zB Zentrum - Außen Top, links Inside - Center, rechts außen - Außenseitenende).

Notiz

Jede pro Instanz Aspekte, die für die damit verbundenen Formen festgelegt wurden, wird "überschrieben" werden, wenn die gleichen Aspekt ist für den entsprechenden Typ geändert.Wenn mit 2 oder mehr Anmerkungen besetzen die gleiche Position nur eine einzige Schriftart, Schriftstil, Schriftfarbe und Größe verwendet werden kann und einen Separator (zB Komma, Leerzeichen, Zeilen) muss ausgewählt werden.

Zeigen der Name oder Typ für eine zugehörige Komponente bzw. Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Anschluss auf der Leinwand.

3. Auswählen Anmerkungen.

Notiz

Für einen einzelnen assoziierten Form oder Anschluss auf der Leinwand, müssen Sie die Auswahl Überschreiben Sie Stencil AnmerkungenKontrollkästchen die erste Zeit.

4. Wählen Sie New Annotation in der Werkzeugleiste und wählen Sie Name oder Art.

5. In dem Dialog, wählen Sie die Display-Optionen, die gewünscht werden, einschließlich Halterungen und der Schriftart, Schriftstil, Schriftfarbe und Größe angezeigt. Wählen Sie außerdem die Layout-Optionen, die gewünscht werden, einschließlich der horizontale und vertikale Ausrichtung (dh Annotation Position) und der Winkel (dh Rotation). Auswählen OK.

Um eine Eigenschaft zu zeigen, Wert für eine zugehörige Komponente bzw. Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Anschluss auf der Leinwand.

3. Auswählen Anmerkungen.

Notiz

Für einen einzelnen assoziierten Form oder Anschluss auf der Leinwand, müssen Sie die Auswahl Überschreiben Sie Stencil AnmerkungenKontrollkästchen die erste Zeit.

4. Wählen Sie New Annotation in der Werkzeugleiste und wählen Sie Eigentumswert.

5. In dem Dialog, wählen Sie die Eigenschaft durch Klicken auf die Immobilie angezeigt: Schaltfläche "..." und wählen Sie eine Eigenschaft im Dialog Wählen Sie eine Eigenschaftund wählen Sie OK. Wählen Sie die Anzeigeoptionen, die gewünscht werden, einschließlich Halterungen und der Schriftart, Schriftstil, Schriftfarbe und Größe. Wählen Sie außerdem die Layout-Optionen, die gewünscht werden, einschließlich der horizontale und vertikale Ausrichtung (dh Annotation Position) und der Winkel (dh Rotation). Auswählen OK.

Um eine Eigenschaft zu zeigen, Marker für eine zugehörige Komponente bzw. Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Anschluss auf der Leinwand.

3. Auswählen Anmerkungen.

Notiz

Für einen einzelnen assoziierten Form oder Anschluss auf der Leinwand, müssen Sie die Auswahl Überschreiben Sie Stencil AnmerkungenKontrollkästchen die erste Zeit.

4. Wählen Sie New Annotation in der Werkzeugleiste und wählen Sie Property Marker.

5. In dem Dialog, wählen Sie die Eigenschaft durch Klicken auf die Immobilie angezeigt: Schaltfläche "..." und wählen Sie eine Eigenschaft im Dialog Wählen Sie eine Eigenschaftund wählen Sie OK. Stellen Sie den Radius der Markierung in Pixel und der Farbmethode entweder Farbe nach Produktgruppen oder Farbe von der Immobilie und stellen Sie die Farben Zuordnungen. Wählen Sie außerdem die Layout-Optionen, die gewünscht werden, einschließlich der horizontale und vertikale Ausrichtung (dh Annotation Position) und der Winkel (dh Rotation). Auswählen OK.

Zeigen Anbauteile für eine zugehörige Komponente bzw. Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Anschluss auf der Leinwand.

3. Auswählen Anmerkungen.

Notiz

Für einen einzelnen assoziierten Form oder Anschluss auf der Leinwand, müssen Sie die Auswahl Überschreiben Sie Stencil AnmerkungenKontrollkästchen die erste Zeit.

4. Wählen Sie New Annotation in der Werkzeugleiste und wählen Sie Anbauteile.

5. In dem erscheinenden Dialog zum zugehörigen Komponenten wählen Sie den angeschlossenen Komponenten-Typ, indem Sie das beigefügte: "..." Button und der Auswahl eines Komponententyp im Dialog Set Component Typeund wählen Sie OK. Wählen Sie das beigefügte Verbindungstyp, indem Sie auf das Verbunden Via: "..." Knopf und Wählen Sie einen Verbindungstyp im Dialogfeld Set Verbindungstypund wählen Sie OK.Für zugehörigen Verbindungen wählen Sie das Anschlussende durch Auswahl Quelle oder Senke aus der Verbindung Ende: Pulldown-Menü. Für beide zugehörigen Komponenten und Anschlüsse Wählen Sie die Anzeigeoptionen, die gewünscht werden, einschließlich Halterungen und der Schriftart, Schriftstil, Schriftfarbe und Größe. Wählen Sie außerdem die Layout-Optionen, die gewünscht werden, einschließlich der horizontale und vertikale Ausrichtung (dh Annotation Position) und der Winkel (dh Rotation). Auswählen OK.

Zeigen die Kinder für eine zugeordnete Komponente

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der ComponentsRegisterkarte des Schablonenfenster oder eine zugehörige Form auf der Leinwand.

3. Auswählen Anmerkungen.

Notiz

Für einen einzelnen assoziierten Form auf der Leinwand, müssen Sie die Auswahl Überschreiben Sie Stencil AnmerkungenKontrollkästchen die erste Zeit.

4. Wählen Sie New Annotation in der Werkzeugleiste und wählen Sie Kinder.

5. In dem Dialog, wählen Sie die Display-Optionen, die gewünscht werden, einschließlich Halterungen und der Schriftart, Schriftstil, Schriftfarbe und Größe angezeigt. Wählen Sie außerdem die Layout-Optionen, die gewünscht werden, einschließlich der horizontale und vertikale Ausrichtung (dh Annotation Position) und der Winkel (dh Rotation). Auswählen OK.

Zeigen die Standards für eine zugehörige Komponente bzw. Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Anschluss auf der Leinwand.

3. Auswählen Anmerkungen.

Notiz

Für einen einzelnen assoziierten Form oder Anschluss auf der Leinwand, müssen Sie die Auswahl Überschreiben Sie Stencil AnmerkungenKontrollkästchen die erste Zeit.

4. Wählen Sie New Annotation in der Werkzeugleiste und wählen Sie Standards.

5. In dem Dialog, wählen Sie die Display-Optionen, die gewünscht werden, einschließlich Halterungen und der Schriftart, Schriftstil, Schriftfarbe und Größe angezeigt. Wählen Sie außerdem die Layout-Optionen, die gewünscht werden, einschließlich der horizontale und vertikale Ausrichtung (dh Annotation Position) und der Winkel (dh Rotation). Auswählen OK.

Zeigen die Zeitstempel für eine zugehörige Komponente bzw. Verbindung

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Rechtsklickauf einer zugeordneten Form oder Verbinder in der Components oder AnschlüsseRegisterkarte des Schablonenfenster oder eine zugeordnete Form oder Anschluss auf der Leinwand.

3. Auswählen Anmerkungen.

Notiz

Für einen einzelnen assoziierten Form oder Anschluss auf der Leinwand, müssen Sie die Auswahl Überschreiben Sie Stencil AnmerkungenKontrollkästchen die erste Zeit.

4. Wählen Sie New Annotation in der Werkzeugleiste und wählen Sie Erstellt, von, Erstellt Marker erstellt, geändert oder Geändert von Geändert Marker.

5. In dem erscheinenden Dialog, wenn nicht ein Marker, wählen Sie die Display-Optionen, die gewünscht werden, einschließlich Halterungen und der Schriftart, Schriftstil, Schriftfarbe und Größe. Wenn ein Marker, stellen Sie den Radius der Markierung in Pixel und der Farbmethode entweder Farbe nach Produktgruppen oder Farbe von der Immobilie und stellen Sie die Farben Zuordnungen. Wählen Sie außerdem die Layout-Optionen, die gewünscht werden, einschließlich der horizontale und vertikale Ausrichtung (dh Annotation Position) und der Winkel (dh Rotation). Auswählen OK.

Um den Schriftstil eines Freiform-Form zu ändernoder Stecker

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Rechtsklickauf der Freiform oder Stecker auf der Leinwand. Hinweis: Wenn die Steckverbinder Text-Label ist nicht dann zeigen, um den Verbindungs ​​zeigenoder Beschriftung: Rechtsklickdie Verbindungsoderund wählen Sie Annotation | Show Annotation.

3. Auswählen Schriftart ändern.

4. Wählen Sie eine Schriftart, Schriftstil und Größe im Dialog und wählen Sie OK.

Um die Schriftart zu ändern Farbe einer Freiform-Formoder Stecker

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Rechtsklickauf der Freiform oder Stecker auf der Leinwand. Hinweis: Wenn die Steckverbinder Text-Label ist nicht dann zeigen, um den Verbindungs ​​zeigenoder Beschriftung: Rechtsklickdie Verbindungsoderund wählen Sie Annotation | Show Annotation.

3. Auswählen Veränderung Schriftfarbe.

4. Wählen Sie eine SchriftartFarbe (und für die Formen der Link-Farbe), indem Sie auf die Schaltfläche "..." und wählen Sie eine Farbe im Dialog, und wählen Sie OK.

5. Wählen Sie die Transparenz des Text-Label mit dem Schieberegler, wobei 0 vollständig transparent und 255 als undurchsichtig.

Um den Text zu Etikett eines Freiform zu drehenoder Stecker

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene haben Diagramm geöffnet .

2. Rechtsklickauf der Freiform oder Stecker auf der Leinwand. Hinweis: Wenn die Steckverbinder Text-Label ist nicht dann zeigen, um den Verbindungs ​​zeigenoder Beschriftung: Rechtsklickdie Verbindungsoderund wählen Sie Annotation | Show Annotation.

3. Auswählen Drehenund wählen Sie den entsprechenden Winkel Sie das gedreht werden soll Beschriftung durch.

Sehe auch

Das Zeichenwerkzeug | Auffüllen der Architektur | Analysieren Ihre Architektur


Die Nutzung von Links in Diagrammen

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Die Nutzung von Links in Diagrammen

Senden Sie Kommentare Zu diesem Thema.

Formen (freie Form und Komponenten) und Anschlüsse (freier Form oder Verbindungen) innerhalb Diagramme können Ihre bestehende architektonische Darstellungen in ABACUS, als auch externe Dateien / Ordner und URLs verknüpft werden. Diese Links können dann über die ABACUS-Toolset verwaltet werden (erstellt, geändert und gelöscht werden). Diese Funktion kann verwendet werden, um die Navigation und die allgemeine Verständnis für Ihre Architektur schematisch zu verbessern.

Links zu Ihrem Diagramm hinzufügen

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Wählen Sie die entsprechende Form oder Stecker von Ihrem Diagramm.

3. Rechtsklickvon der Formoder Stecker.

4. Auswählen Öffnen Linksund LinksFenster erscheint.

5. Klicken Sie auf HinzufügenSymbol und eine Neuer LinkFenster erscheint.

6. Wählen Sie die entsprechende Katalog | Matrix | Diagramm| 3D-Ansicht| DiagrammRadio-Buttons, dann wählen Sie die entsprechende Katalog, matrix, Diagramm, 3D-oder Diagramm Ansicht in der aktuellen Architektur aus dem Link zu Dropdown-Menü.

- oder -

6. Wähle aus WebseiteRadio-Button, dann geben Sie die entsprechende URL (z.B. http: //www.avolutionSoftware.com /)auf dem Gebiet, um zu einer Webseite verlinken. Gültige URLs müssen mit einem der zu starten 5Zeichenfolgen; http: //, https: //, ftp: //, Datei: oder \\. Keine Leerzeichen sollte mit einem '% 20' eingegeben werden.

- oder -

6. Wähle aus Absolute Datei | Relative Datei Radio knopfs,klicken Sie auf den '...", Um für eine externe Datei zu suchen, um das Diagramm zu verknüpfen.

7. Klicken OKund der neue Link wird in der Links-Fenster angezeigt. Hinweis: Das Fenster Verbindungen können in der Größe verändert werden, um den vollständigen Namen ggf. zu sehen.

8. Wiederholen Sie die Schritte 5-7mehr Links zu erstellen.

9. Um den erstellten Link zu folgen, wählen Sie den entsprechenden Link in der angezeigte LinksFenster und klicken Sie auf Verbindung öffnen.

Notiz

Wenn mehrere Anmerkungen werden für a gezeigt Form oder Steckverbinder der Link ist auf der ersten Annotation in Liste der Anmerkungen im Edit Anmerkungen Dialog angezeigt.

Links von Ihrem Diagramm folgen

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Wählen Sie die entsprechende Form oder Stecker von Ihrem Diagramm.

3. Klickenauf der entsprechenden Hyperlinks (blau unterstrichen Komponentenname) auf einem Form oder Stecker in dem Diagramm zu öffnen und die erste Verbindung von der Formoder Stecker.Hinweis: Der Cursor sollte auf eine "Hand", wenn die Verbindung bereit ist, angeklickt werden, zu ändern.

- oder -

3. Wählen Sie die entsprechende Form oder Stecker von Ihrem Diagramm.

4. Rechtsklickvon der Formoder Stecker.

5. Auswählen Öffnen Linksund LinksFenster erscheint.

6. Wählen Sie den entsprechenden Link, den Sie sehen möchten.

7. Klicken Sie auf Verbindung öffnenTaste, um zu öffnen und den entsprechenden Link.

Um Links in Ihrem Diagramm zu löschen

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Wählen Sie die entsprechende Formoder Steckervon Ihrem Diagramm.

3. Rechtsklickvon der Formoder Stecker.

4. Auswählen Öffnen Linksund LinksFenster erscheint.

5. Wählen Sie den entsprechenden Link, der gelöscht werden muss.

6. Klicken Sie auf Löschen Taste. und die Verbindung wird von dem entfernt Links Fenster.

Organisations Links in Ihrem Diagramm

Sie können wählen, welche Diagramm, externen Datei verknüpft, oder Web-URL wird angezeigt, wenn eine Form Markierung Strg + Anklicken im Diagramm.

1. Stellen Sie sicher, dass Sie eine vorhandene Diagramm geöffnet .

2. Wählen Sie die entsprechende Form oder Stecker von Ihrem Diagramm.

3. Rechtsklickvon der Formoder Stecker.

4. Auswählen Öffnen Linksund LinksFenster erscheint.

5. Um die Reihenfolge der Verbindungen Klicken Sie auf ändern Nach oben | Sich abwärts bewegenTasten auf der rechten Seite der Links Fenster.

6. Das erste Verbindungsglied, das auf der linken Seite die erscheint LinksFenster ist der Link, wenn Sie zeigt Strg + Klickenein Hyperlink Form oder Stecker Name.

Sehe auch

Auffüllen der Architektur | Auffüllen der Architektur Hand | Analysieren Ihre Architektur


Diagramm Viewpoints

Navigation: Füllen Sie Ihre Architektur> Verwenden von Zeichnungen>

Diagramm Viewpoints

Senden Sie Kommentare Zu diesem Thema.

The StandpunkteMerkmal stellt sicher, dass die Komponenten und Verbindungen, die zu einem Diagramm hinzugefügt werden, müssen eine Art Verband zuvor definiert, bevor sie in einem Diagramm hinzugefügt. Mit dieser Funktion können für die Einschränkung der Arten von Diagrammen, die durch die Beschränkung der Formen und Steckverbinder, die mit Komponenten und zugeordneten gezogen werden kann, Anschlüssebestehenden innerhalb Ihrer Architektur.

Aktivieren oder Deaktivieren der Durchsetzung Bild Aussichtspunkte

Die Fähigkeit zur Durchsetzung Diagramm Standpunkte wird automatisch standardmäßig aktiviert. So aktivieren / deaktivieren Sie diese Funktion, klicken Sie auf Extras | Options ...| das DiagrammRegisterkarte, und deaktivieren / aktivieren Sie das Erzwingen Diagramm AussichtspunkteKontrollkästchen entsprechend.

Notiz

Wenn Sie nicht sehen, das "Erzwingen Diagramm Aussichtspunkte'Option auf der Registerkarte Diagramm, dann müssen Sie nicht die Designer Add-on und die Option ist standardmäßig aktiviert.

Erstellen eines vollstreckbaren Bild Standpunkt

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei mit der offenen ForscherAnsicht angezeigt.

2. In der Explorer-Ansicht klicken Sie rechts auf AussichtPunktsund klicken Sie auf Erstellen Diagramm Viewpoint

3. das Diagramm ViewpointFenster wird angezeigt.

4. Vergeben Sie einen aussagekräftigen Namen, um die Diagramm Sichtund beachten Sie, dass die Standpunkt wird unter die gespeicherte AussichtspunkteAbschnitt der Explorer.

5. das Diagramm ViewpointFenster wird angezeigt.

6. Jetzt klicken und ziehen Sie die entsprechenden Komponententypen und Anschlussarten in Ihrem Architekturen auf die Sicht Formen du willst. Komponententypenmuss auf einen gezogen werden Form im FormenRegisterkarte, während Verbindungstypenmuss auf gezogen werden einer der 5 Linienstil Formen im Steckverbinder Tab.

7. Um das zu retten Diagramm SichtSie klicken auf das geschaffen haben [image] in der oberen rechten Ecke des Diagramm Viewpoint Fenster.

Notiz

das Diagramm Sichtkann durch Rechtsklick auf die bearbeitet werden Standpunkt und Auswählen Öffnen oder Doppelklick das Standpunkt.

Synchonising eine aktualisierte Sicht mit Diagrammen

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Entweder mit der rechten Maustaste auf die Sicht in die Forscher Fenster unter Meta-Modell | Aussichtspunkteund wählen Sie Sync Diagramm Mappings ...

- oder -

3. Nah dran die offene und aktuelle Sicht Fenster und wählen Ja im Synchronisieren Sie den Blickwinkel der AufnahmeDialogfeld, das angezeigt wird.

4. das Viewpoint SynchronisationDialog wird wie unten dargestellt angezeigt.

Checkboxen

· Fehlende Zuordnungen- Jede neue Form (zum Komponententyp) oder Stecker (zum Verbindungstyp) Vereinigungen, die hinzugefügt wurden zum Aussichtspunktwird auf die hinzugefügt werden, entsprechendes Diagramms (d.h. ihre Schablones) dass sind unter dem Gesichtspunkt verbunden.

· Update des bestehendenZuordnungen- Jegliche Änderung der Aspekte der bestehenden Form (zum Komponententyp) oder Stecker (zum Verbindungstyp) Verbände der Blickpunkt(zB Farbe, Schriftschnitte) wird in die aktualisiert werden entsprechendes Diagramms (d.h. ihre Schablones) dass sind unter dem Gesichtspunkt verbunden.

· Entfernen Extra-Zuordnungen- Jede weitere Form (zum Komponententyp) oder Stecker (zum Verbindungstyp) Vereinigungen, die hinzugefügt wurden zum Diagramme (d.h. ihre Schablonen), sind aber nicht in der Standpunktwerden aus der entfernt werden entsprechendes Diagramms (d.h. ihre Schablones) dass sind unter dem Gesichtspunkt verbunden.

· Überschreiben Sie Lokale Einstellungen für hinzugefügt oder aktualisiert Mappings (Unterschiede Only)- Jegliche Änderung der Aspekte der bestehenden Form (zum Komponententyp) oder Stecker (zum Verbindungstyp) Verbände der Blickpunkt(zB Farbe, Schriftarten) wird zu den entsprechenden Elementen in den Diagrammen, die unter dem Gesichtspunkt verknüpft sind anzuwenden.Nur des aktualisierten Unterschiede dürfen nicht zu dem Gesichtspunkt vorgenommen werden so aufgebracht, eventuell vorhandene lokale Einstellungen in dem Diagramm, die nicht im Blickpunkt aktualisiert wurden, bleiben unverändert.

· [image] Anmerkungen – Wie oben, aber speziell für die Anmerkungen.

Sehe auch

Das Zeichenwerkzeug | Auffüllen der Architektur | Analysieren Ihre Architektur


Auffüllen mit Kataloge

Navigation: Füllen Sie Ihre Architektur>

Auffüllen mit Kataloge

Senden Sie Kommentare Zu diesem Thema.

A Katalog ermöglicht es Ihnen, zu bearbeiten und Komponenten anzeigen oder Verbindungen und deren Eigenschaften auf einfache tabellarische Art und Weise.

Zu erstellen Sie einen neuen Katalog sehen in ABAKUS

Notiz

Während alle Architect-Benutzer können neue Kataloge zu erstellen, um Änderungen an den Einstellungen eines vorhandenen Katalog zu retten das User-Lizenz braucht den Designer-Add-on-Fähigkeit. Dies ist zu "schützen" die Konfiguration der vorhandenen Kataloge, die von vielen Benutzern gemeinsam genutzt werden kann. Allerdings verwendet Architect ohne die Designer Add-on kann noch 'Speichern unter' alle neuen Einstellungen auf einen neuen Katalog zu wählen. Und natürlich alle Benutzerlizenzen können "entledigen" Änderungen an einem vorhandenen Katalog zu wählen. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie verlangen, die Designer-Add-on Fähigkeit. Und denken Sie daran, dies ist nur die Einstellungen der Katalog werden alle Änderungen an den Daten im Katalog machte sofort in das Repository angewendet, unabhängig.

1. Wählen Sie Einfügen | Katalog.

2. im Pull-Down wählen Sie die Architektur, die die Komponenten enthält, oderVerbindungen, die Sie anzeigen möchten.

3. im Pull-Down wählen Sie die Komponente oder Verbindungstyp , dass Sie haben die Instanzen als 'möchtenZeilen' im Katalog.

4. das Katalog wird mit einem aufgefüllt werdenZeile für jede Instanz des ausgewählten Komponente oder Verbindungsart.

Notiz

Standardmäßig ist die am weitesten links HierarchiepfadSpalte (dh der Hierarchie übergeordneten Komponenten oder Verbindungen über den ausgewählten Instanzen) und dem 2. Name Säule (dh die Liste der ausgewählten Komponente oder Verbindungsinstanzen) auf der linken Seite der Katalog froren. Um die Spalte zu ändern Einfrieren ziehen Sie die Spaltentrennzeichen rechts neben der Spalte Name. Sie können NachbestellungSpalten einfach per Drag & Drop die Spaltenüberschriften. Zellen der Spalten mit einem blauen Unterstreichung sind Hyperlinks auf andere Elemente in das Projekt und die Hypertext-Links können mit gedrückter Strg-Taste und Klick auf die Links folgen. Spalten können versteckt durch Rechtsklick auf die Spaltenüberschrift und wählen Sie Säule | Ausblenden Spalte. Ausgeblendete Spalten können durch Klicken auf die Spalten Symbolleiste auf die Schaltfläche Konfiguration und Verwendung der Spalten konfigurieren Dialog, wie unten dargestellt, oder indem Sie den Pfeil nach unten Teil der Spalten Symbolleiste auf die Schaltfläche Configure und individuell der Auswahl des versteckten Spalte (n) entweder von der General Properties eingeblendet werden Zusatzausrüstungen Sammlungen. Zeilen kann gruppiert durch ihre Spaltenwerte, indem Sie die Spaltenüberschrift in den blauen Gruppierungsleiste am oberen Rand des Katalogs. Zu jeder Zeit können Sie einen Doppelklick auf das Katalog Zeilenselektor und springen zudie entsprechende Komponenteoder die Verbindungim Explorer-Fenster.Property Zellenwerte sind fett gedruckt wo sie anders als die Standardwerte sind, und kursiv wo sie schreibgeschützt sind. Zeitstempel, Eigentum und angebaute Component Spalten kann farbig nach den Zellenwerte oder Eigenschaftswert einer angehängten Komponente durch Rechtsklick auf die Spaltenüberschrift und wählen Sie Säule | Farbwechsel ... und dann die Farbe von Zeitpunkt oder Colour By Property Option jedoch nur Liste, Integer, Dezimal, Boolean oder Datum / Zeit Datentyp-Eigenschaften werden zu färben. Eigenschaftswerte für angebaute Component Spalten kann gezeigt durch Rechtsklick auf die Spaltenüberschrift und wählen Sie Säule | Show ... und dann die Option Show. Und schließlich, wo es Notwendige Einschränkungen Eine Immobilie Spalte können diese mit einem angezeigt werden string (zusammen mit Färbemitteln nach ihrer Durchsetzung Ebenen) durch Rechtsklick auf die Spaltenüberschrift und wählen Sie Säule | Zeigen .

Katalog

Zu Hinzufügen / show Spalten a Katalog Blick in ABACUS

1. Stellen Sie sicher, dass Sie eine Katalogansicht öffnen.

2. Ausgeblendete Spalten können einzeln durch Klicken auf die eingeblendet werden Pfeil auf der rechten Seite der Symbolleiste auf die Schaltfläche Configure Columnsund die Auswahl der versteckten Spalte aus entweder der General, Immobilien oder Dateianhänge Sammlungen.

Notiz

Ein Häkchen wird angezeigt neben dem aktuell angezeigten Spalten für den Katalog werden.Darüber hinaus werden nur bestimmte Anlagen unter den Anbau sein Schnitt gemäß der Beschränkungen die in Ihrem Projekt definiert sind. Insbesondere für eine Anlage zur Verfügung stehen, um in einem Bauteilkatalog angezeigt werden die Komponententyp für den Katalog muss entweder als Quelle angegeben oder Senke (NICHT "Alle") einer "Verbindung angeschlossen sein müssen," Einschränkung für eine Verbindung werden Typ, und es muss auch mindestens ein Komponententyp entweder als Quelle oder Senke angegeben sein (NICHT "Alle") des anderen "Ende" aus dem gleichen Verbindungstyp.

- ODER -

2. Mehrere Spalten können durch Klicken auf die eingeblendet werden (oder bestellt oder fest) Spalten konfigurieren Symbolleiste auf die Schaltflächeund unter Verwendung der Spalten konfigurieren Dialog unten.

Notiz

Die aktuell angezeigten Spalten werden im Panel auf der rechten mit den verfügbaren Spalten in der auf der linken gezeigt. Die verfügbaren Spalten können entsprechend den filtrierenden Wählen Sie Verfügbare Spalten VonPull-down und sie können, indem Sie sie in der auf der linken und auf die Schaltfläche hinzugefügt werden Hinzufügen Taste zwischen die beiden Platten.

Dialog Spalten konfigurieren

Zu entfernen / Spalten aus einer ausblenden Katalog Blick in ABACUS

1. Stellen Sie sicher, dass Sie eine Katalogansicht öffnen.

2. Rechtsklicken Sie auf die Spaltenüberschrift für die Spalte, die Sie entfernen / verbergen möchten und wählen Sie Column | Spaltennamen.

- ODER -

2. Mehrere Spalten können ausgeblendet werden (oder bestellt oder fest), indem Sie die Spalten konfigurieren Symbolleiste auf die Schaltflächeund unter Verwendung der Spalten konfigurieren Dialog oben gezeigt.

Notiz

Die aktuell angezeigten Spalten werden im Panel auf der rechten mit den verfügbaren Spalten in der auf der linken gezeigt. Die aktuell angezeigten Spalten können indem Sie die Spalte im Feld auf der rechten und auf die Schaltfläche ausgeblendet werden Entfernen Taste zwischen die beiden Platten.

So füllen Sie mit a Katalog Blick in ABACUS

1. Zu füge hinzu ein Komponente oder Verbindungdes ausgewählten Typs zu das Katalog (und Projekt) Klicken Sie Hinzufügen Komponente / Neue Verbindung hinzufügen Schaltfläche in der Symbolleiste. Die Zeile sollte erscheinen und eine Komponente oder Verbindung wird auf der obersten Ebene der erstellt werden Komponenten oder Connections-Auflistung für die gewählte Architektur.

Notiz

Neue Komponenten und Anschlüsse sind standardmäßig auf der obersten Ebene der Bauteile oder Anschlüsse Sammlung von der gewählten Architektur aufgenommen. Um das übergeordnete Element der neuen Komponenten oder Anschlüsse ändern rechten Maustaste auf den Hierarchiepfad Zelle für die neue Komponente oder Verbindungen Zeile und wählen Ändern Eltern ...und wählen Sie die gewünschte Mutter (Kenntnisnahme der Constraint-Hervorhebung ).

Notiz

Neue Zeilen / Elemente direkt hinzugefügt, um einen Katalog über die 'Neue' Knopf, in den Katalog eingefügt oder erstellt über den Import in den Katalog aus MS Excel sind von Filtern, bis der Katalog geschlossen befreit. Dies ist, um die notwendigen Bearbeitung von Spaltenwerte, die nicht den aktuellen Filterkriterien des Katalogs erfüllen können zulassen. Diese neuen Elementreihen durch ein Symbol "+" in der Zeilenauswahl Zelle am Anfang der Reihe, die farbig angezeigt wird grün wenn das Element derzeit erfüllt die gespeicherten Filterkriterien des Katalogs (dh auf Katalog bleiben, wenn wieder eröffnet) und rot wenn es dies nicht tut.

2. Zu entfernen Sie ein Komponente oder Verbindungdes ausgewählten Typs von das Katalog (und Projekt) wählen Sie die Zeile, und entweder drücken Sie Entf-Taste oder mit der rechten klicken Sie auf die Zeilenauswahl und wählen Sie Löschen von Architektur. das Reihe sollte verschwinden aus dem Katalog und es wird aus dem Projekt gelöscht werden.

Zu Filter Verwendung einer Katalog Blick in ABACUS

1. Stellen Sie sicher, dass Sie eine Katalogansicht öffnen.

2. Wenn die Filterzeile wird nicht an der Spitze der Katalog zeigt dann klicken Sie auf die Filter anzeigen KopfzeileSchaltfläche in der Symbolleiste.

3. In der Spalte, die Sie möchten, um einen Filter hinzuzufügen, doppelklicken Sie auf die Zelle, in der Filterzeile zeigt "(Alle)".

4. Für Zeitstempel, Hierarchiepfad, Namens oder Beschreibungallgemeine Spalten oder Text, Integer, Dezimal, Boolean oder TerminzeitImmobilien Spalten klicken Sie auf die Schaltfläche ..., die in der rechten Seite der Filterzeile Zelle angezeigt und geben Sie die Zellenwerte, die im Katalog enthalten sein sollten.

Notiz

Matching ist, als wenn "*" Platzhalter werden automatisch vor und nach beliebigen String-Werte durchgeführt, so dass ein Eintrag von "Katze" (ohne die Anführungszeichen) würde Zeilen mit "bob schließenKatze','KatzeFrau "oder" AnwenKatzeion 'usw. Mehrere / "oder" Werte können auf neue Linien mit eingegeben werden Strg + Enter. Für Integer und Decimal Eigenschaft Spalten "und" Logik kann mit einbezogen werden "&"(Ohne die Anführungszeichen), und mehr als / weniger als etc Logik kann mit einbezogen werden"> =','>','<' und '<="(Ohne die Anführungszeichen) z > = 50000 & <90000. Nicht leeren Wert Reihen kann durch Eingabe von 'enthalten sein(Non-Blanks)"(Ohne die Anführungszeichen) und Blank geschätzten Zeilen kann durch Eingabe enthalten sein '(Blanks)' (ohne die Anführungszeichen).Und schließlich, sind alle Filter standardmäßig Kleinschreibung so "Katze" (ohne die Anführungszeichen) würde Zeilen mit "Katze", "Katze" oder "CAT" usw. Für Groß- und Kleinschreibung Anpassung beinhalten, geben Sie '(Fall)"(Ohne die Anführungszeichen), bevor der String beispiels "(Urteil) Cat" (ohne die Anführungszeichen) nur enthalten Zeilen mit "Katze" in ihnen.

5. Für DateianhängeSäulen, Standards Spalten oder Liste Immobilien Spalten klicken Sie auf den Pfeil nach unten-Taste, die in der rechten Seite der Filterzeile Zelle angezeigt wird, und wählen Sie die Zellenwerte aus dem Kontrollkästchen, die in dem Katalog enthalten sein sollten.

Notiz

Die "(Alle auswählen)" Kontrollkästchen ermöglicht alle anderen Kontrollkästchen in der Tat mit allen zur Verfügung stehenden Zeilen. Der '(Non-Blanks) "Kontrollkästchen wird jede nicht-leere Zeilen sind geschätzt. Der '(Leerzeichen) "Kontrollkästchen wird auch keine leeren Reihen geschätzt. Und schließlich, deaktivieren keine spezifischen geschätzt Kontrollkästchen wird automatisch deaktivieren Sie die "(Alle auswählen)" und "(Non-Blanks)" Kontrollkästchen für Konsistenz.

6. Klicken OK um den Filter anzuwenden.

Zu deaktivieren / aktivieren Filterung auf a Katalog Blick in ABACUS

1. Stellen Sie sicher, dass Sie eine Katalogansicht öffnen mit einem Filter angewandten.

2. Klicken Sie auf das Kontrollkästchen links neben der Filterzeile.

Zu entfernen Sie einen Filter aus a Katalog Blick in ABACUS

1. Stellen Sie sicher, dass Sie eine Katalogansicht öffnen mit einem Filter angewandten.

2. Um eine einzelne Spalte Filter entfernen rechten Maustaste auf die Spaltenüberschrift, und wählen Sie Column | Klar Filtering.

3. So entfernen Sie alle Filter klicken Sie auf die Optionen Schaltfläche in der Symbolleiste und wählen Sie Clear Filter-Einstellungen.

Speichern / speichern als aKatalogansicht

Notiz

Während alle Architect-Benutzer können neue Kataloge zu erstellen, um Änderungen an den Einstellungen eines vorhandenen Katalog zu retten das User-Lizenz braucht den Designer-Add-on-Fähigkeit. Dies ist zu "schützen" die Konfiguration der vorhandenen Kataloge, die von vielen Benutzern gemeinsam genutzt werden kann. Allerdings verwendet Architect ohne die Designer Add-on kann noch 'Speichern unter' alle neuen Einstellungen auf einen neuen Katalog zu wählen. Und natürlich alle Benutzerlizenzen können "entledigen" Änderungen an einem vorhandenen Katalog zu wählen. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie verlangen, die Designer-Add-on Fähigkeit.Und denken Sie daran, dies ist nur die Einstellungen der Katalog werden alle Änderungen an den Daten im Katalog machte sofort in das Repository angewendet, unabhängig.

1. Stellen Sie sicher, dass Sie eine neue haben oder bestehende Katalogansicht öffnenund Sie die notwendigen Änderungen vorgenommen haben.

2. im KatalogansichtSymbolleiste, klicken Sie auf die sparenTaste, um die zu retten Katalogansicht und alle Formatierungsänderungen.

Notiz

Wenn Sie nicht über eine Schaltfläche Speichern in der Katalogansicht Symbolleiste dann müssen Sie nicht die Designer-Add-on, und Sie müssen nur in der Lage Speichern alsAlle Einstellungen, verwandelt sich in einen neuen Katalog, wenn Sie die vorhandenen Katalog zu schließen gehen.

3. Ob das Katalog NameDialog erscheint (da auf sie ein neuer Katalog) Geben Sie einen Namen für die Katalog und drücken Sie OK.

Zu Export nach MS Excel-Katalog

1. Stellen Sie sicher, dass Sie eine Katalogansicht öffnen.

2. Drücke den Export nach Excel Tabellenkalkulation KatalogSchaltfläche in der Symbolleiste.

3. Wählen Sie einen Dateinamen, um die MS Excel-Katalog als zu speichern. Klicken sparen.

Notiz

Standardmäßig ist der exportierten Excel-Katalog Dateinamen wird der Katalogname durch die Architektur Namen in Klammern angehängt sein, zB "Projekte (2014 Actual) .xlsx". Sie können alle dies zu ändern, einschließlich, ob das Dateiformat, um .xlsx oder .xls sein. Die Architektur Name ist enthalten, um den Benutzer, dass jeder Katalog hat spezifische Inhalte (dh IDs in der Spalte A und Zeile 1), damit sie rund um ausgelöst zu sein wieder mit Import aus MS Excel-Katalog nach unten zu erinnern.

Notiz

Standardmäßig ist die verborgene Spalte A in der exportierten Excel-Katalog enthält die eindeutige ID für jedes der Elemente in der ABACUS-Repository. Auf diese Weise können alle Änderungen, die in MS Excel gemacht werden, um sein 'abgestimmt up "an die vorhandenen Elemente innerhalb ABACUS beim Import (siehe unten). Jedoch kann die Verwendung dieses einzigartigen ID zu "übereinstimmen" Zeilen mit einem übersteuert werden Externe | ICH WÜRDEEigenschaft auf dem Element. Das heißt, wenn das Element eine Außen | ID-Eigenschaft, und es ist im Katalog auf den Export dann die Werte der extern | ID-Spalte wird verwendet, um über die Einfuhr richten Sie die Zeilen (siehe unten) und die eindeutige ID-Werte in der verborgenen Spalte A werden ignoriert (und kann sogar leer sein). Die verborgene Spalte A selbst muss bleiben jedoch insbesondere der Wert in Zelle A1. Darüber hinaus beim Hinzufügen von externen IDs zu einer bestehenden ABACUS Element Kollektion, empfehlen wir als eine andere Eigenschaft Erster ihnen, zB Externe | Temp und dann die Umbenennung der Eigenschaft Externe | ICH WÜRDE. Ansonsten doppelte Elemente hinzugefügt werden.

Katalog-Formatierungist standardmäßig exportiert, aber für große Kataloge dies kann in der Export als ziemlich langsam führen. Dementsprechend wird in Tools | Options ...dann auf das Katalog Tab,Sie sind in der Lage, die Menge der Formatierung, die exportiert wird, wie auf der Registerkarte Katalog unten zu reduzieren, wodurch die Beschleunigung des Export.

Katalog Export Optionen

4. Ein Export abgeschlossen Dialog wird angezeigt. Klicken OK.

Nach MS Excel exportiert Katalog

Zu Import aus MS Excel-Katalog

Notiz

Standardmäßig ist die verborgene Spalte A in der exportierten Excel-Katalog (siehe oben) enthält die eindeutige ID für jedes der Elemente in der ABACUS-Repository. Auf diese Weise können alle Änderungen, die in MS Excel gemacht werden, um sein 'abgestimmt up "an die vorhandenen Elemente innerhalb ABACUS auf Import. Jedoch kann die Verwendung dieses einzigartigen ID zu "übereinstimmen" Zeilen mit einem übersteuert werden Externe | ICH WÜRDEEigenschaft auf dem Element. Das heißt, wenn das Element eine Außen | ID-Eigenschaft, und es ist im Katalog auf den Export enthalten (siehe oben), dann die Werte des Außen | ID-Spalte verwendet werden, um bis die Zeilen auf Import und die eindeutige ID-Werte in der Spalte A ausgeblendet wird ignoriert (und kann sogar leer sein). Die verborgene Spalte A selbst muss bleiben jedoch insbesondere der Wert in Zelle A1. Darüber hinaus beim Hinzufügen von externen IDs zu einer bestehenden ABACUS Element Kollektion, empfehlen wir als eine andere Eigenschaft Erster ihnen, zB Externe | Temp und dann die Umbenennung der Eigenschaft Externe | ICH WÜRDE. Ansonsten doppelte Elemente hinzugefügt werden.

1. Stellen Sie sicher, dass Sie eine Katalogansicht öffnen.

2. Drücke den Import von Excel-Tabellenkalkulation KatalogSchaltfläche in der Symbolleiste.

3. Wählen Sie einen Dateinamen, um die MS Excel-Katalog importieren. Klicken Öffnen.

4. Neuer Fehler erkannt und / oder neue Fehler / Warnungen erkannt Dialoge für jede neue Inhalte angezeigt werden (dh Zeilen in der MS Excel), die hinzugefügt wurde. Beachten Sie die Fehler / Warnungen, und klicken Sie OK.

5. Ein Import-Dialog abgeschlossen wird angezeigt, und es kann Warnungen auf den Import durch (siehe Hinweise unten) zeigen. Klicken OK.

Notiz

Für die zugeordneten Standards oder befestigt Component Spalten müssen neue Einträge über die MS Excel-Katalog genau übereinstimmen Name einer bestehenden Standard oder Komponenten des richtigen Typs für die Zuordnung oder den Anschluss an hinzugefügt werden. Das erste Spiel mit dem Namen verwendet und alle unübertroffene Einträge eine Warnung nach unten zu erzeugen. Hinzu kommt, dass Warnhinweise auf Re-Import gegeben, sind Elemente, nicht gelöschtvon ABACUS, wenn sie nicht in der MS Excel Katalog. Dies liegt daran, dass es keine Möglichkeit gibt, dass ABACUS wissen können, ob die zugewiesene Standard oder Anbauteil in der ABACUS Projekt vorhanden ist, aber nicht in der MS-Excel Katalog existieren, weil es von der MS Excel Katalog gelöscht wurde oder auf die ABACUS hinzugefügt Projekt seit dem Katalog wurde exportiert. Dementsprechend, wenn die Nutzer wollen einfach "zu erkennen", die Anschlüsse während des Importvorgangs hinzugefügt wurden, können sie einfach eine erforderliche Eigenschaft von dem Verbindungstyp und stellen Sie es standardmäßig auf leer, so dass sie keine neuen Verbindungen jedes Mal der Import gewarnt werden ist fertig.

Notiz

Beim Import einer MS Excel-Katalog verschiedene Warnungen angezeigt werden. Erstens, wenn eine neue Spalte zu der Excel, die nicht die "Syntax" für eine Eigenschaft oder befestigt Komponente die Säule wird ignoriert einstimmt aufgenommen. Als nächstes wird Zeile für Zeile Warnungen für alle Probleme mit den Daten auf jeder Zeile der Excel-Katalog angezeigt werden. Diese Warnungen beginnen mit der Zeilennummer in eckigen Klammern und ggf. der Spaltenbeschriftung (dh '[23, J] ...' für die Zeile 23, Spalte J) und kann gelöschte Elemente, unerreichte Standards oder befestigt Component Namen beziehen (die werden als pro Note oben ignoriert) oder eine ungültige oder leere ID im Zusammenhang mit einer neuen Zeile / Element (das wird hinzugefügt werden). Für eine ausführliche Artikel über bevöl ABACUS mit Excel Katalogen finden Sie im Handbuch Avolution Gemeinschaft oder der Portfolio Manager Ausbildung.

Notiz

Neue Komponenten und Anschlüsse sind standardmäßig auf der obersten Ebene der Bauteile oder Anschlüsse Sammlung von der gewählten Architektur aufgenommen. Um das übergeordnete Element der neuen Komponenten oder Anschlüsse ändern rechten Maustaste auf den Hierarchiepfad Zelle für die neue Komponente oder Verbindungen Zeile und wählen Ändern Eltern ...und wählen Sie die gewünschte Mutter (Kenntnisnahme der Constraint-Hervorhebung ).

Notiz

Elemente direkt hinzugefügt, um einen Katalog über die 'Neue' Knopf, in den Katalog eingefügt oder erstellt über den Import in den Katalog aus MS Excel sind von Filtern, bis der Katalog geschlossen befreit. Dies ist, um die notwendigen Bearbeitung von Spaltenwerte, die nicht den aktuellen Filterkriterien des Katalogs erfüllen können zulassen. Diese neuen Elementreihen durch ein Symbol "+" in der Zeilenauswahl Zelle am Anfang der Reihe, die farbig angezeigt wird grün wenn das Element derzeit erfüllt die gespeicherten Filterkriterien des Katalogs (dh auf Katalog bleiben, wenn wieder eröffnet) und rot wenn es dies nicht tut.

Zu Vergleichen Sie den Inhalt eines Katalogs mit einer anderen Architektur

1. Bitte auf das Thema beziehen Hier .

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Auffüllen der Architektur aus Visio | Auffüllen der Architektur aus Excel


Auffüllen mit Matrizen

Navigation: Füllen Sie Ihre Architektur>

Auffüllen mit Matrizen

Senden Sie Kommentare Zu diesem Thema.

Eine Matrix ermöglicht es Ihnen, anzuzeigen und zu bearbeiten 'direkt' Verbindungen zwischen den Komponenten auf einfache Weise tafelund auch die "indirekte Weg 'zwischen den Komponenten anzuzeigen nach beliebigen Zwischenkomponenten (und Verbindungen).

Zu erstellen eine Matrix-Ansicht in ABACUS

Notiz

Während alle Architect Benutzer können Matrizen zu erstellen, um sie und / oder ihre Einstellungen zu speichern, die User-Lizenz braucht den Designer-Add-on-Fähigkeit. Dies ist zu "schützen" die Konfiguration der vorhandenen Matrizen, die von vielen Benutzern gemeinsam genutzt werden kann. Allerdings verwendet Architect ohne die Designer Add-on kann immer noch auf "Speichern unter" die neuen Einstellungen auf eine neue Matrix zu wählen. Und natürlich alle Benutzerlizenzen können "entledigen" Änderungen an einer bestehenden Matrix zu wählen. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

1. Wählen Sie Einfügen | Matrix.

2. im rchitecture>Pull-Down wählen Sie die Architektur, die die Komponenten und Verbindungen, die Sie anzeigen möchten, enthält.

3. im <QuelleTyp>Pull-Down wählen Sie den Komponententyp, mit dem Sie die als 'Instanzen haben möchtenZeilen' auf der linkender Matrix.

4. im <SinkenTyp>Pull-Down wählen Sie den Komponententyp, mit dem Sie die als 'Instanzen haben möchtenSpalten' über die Oberseiteder Matrix.

5. im herunterziehen gibt es im Wesentlichen zwei "Modi" der Matrix können Sie festlegen, ...

'Direkt' Verbindungen Matrizen

6. Einfach swählen eine (1) oder mehr Verbindung Typen auf der rechten Seite des Menüs, das angezeigt wird, wenn Sie in den "Zellen" der Matrix, wenn ein sehen wollenn expliziteVerbindung von der vorhanden ist Vertikal/ 'Reihe"Komponente der Matrix, um das Horizontal/ 'Spalte"Bestandteil der Matrix.

Notiz

Nur Verbindungen mit der Quelle, um die befestigten Ende Vertikal/ 'Reihe"Komponente und Waschbecken Ende auf die beigefügten Horizontal/ 'Spalte"Komponente wird angezeigt. Schalten Sie die Quelle und SinkenKomponenten-Typ Auswahl, um die Verbindungen in die entgegengesetzte Richtung zu sehen.

7. Die Matrix wird mit einem "X" gefüllt werden in den Zellen (oder einem Eigenschaftswert - siehe Hinweis unten) wenn es eine Verbindung von dem Vertikal/ 'Reihe'Bestandteil der Matrix, um das Horizontal/ 'Spalte"Bestandteil der Matrix.

Notiz

Bei großen Matrizen nur maximal 100 Zeilen oder Spalten (einschließlich brach Zeilen / Spalten) wird zu einem Zeitpunkt, wie durch den "R" und "C" Indikatoren im oberen linken Kopfzelle gezeigt angezeigt. So zeigen Sie zusätzliche Zeilen verwenden Sie die Bildlaufleisten. Zu jeder Zeit können Sie einen Doppelklick auf das Vertikal/ 'Reihe' oder HorizontAl / 'Spalte' Komponente Überschriften und springen zudie entsprechenden Komponenten in der Explorer-Fenster.Die Eltern des Vertikal/ 'Reihe' und Horizontal/ 'Spalte' Komponentes sind ebenfalls wahlweise als Überschrift-Zeilen / Spalten mit einem grauen Überschrift Titel angezeigt. Wenn (durch Einzelklick die Überschrift-Zelle), wenn Kinder Anhänge existiert dann ein "X" eingestürzt wird wahlweise angezeigt, wenn alle Kinder angebracht werden oder eine "O" wird wahlweise angezeigt, wenn nur ein Teil der Kinder angebracht wurden werden. Die Zellen können farbig entsprechend einem Wert der Eigenschaft der Verbindungen, indem Sie die Optionen 'Zahnrad' in der oberen rechten Ecke der Matrix Werkzeugleiste und wählen Sie Farbeinstellungen ... und dann auf die Schaltfläche Bearbeiten und wählen Sie die Farbe von Zeitpunkt oder Colour By Property Option und Auswahl eine Eigenschaft, die Min- und Max-Wert-Bereich und der Auswahl der Farben, aber nur Liste, Integer, Dezimal, Boolean oder Datum / Zeit Datentyp-Eigenschaften werden zu färben. Wenn brach die Zelle nach dem durchschnittlichen Wert der Eigenschaft der Verbindungen eingefärbt werden. Anstelle eines "X", kann die Eigenschaftswerte für die Zellen sein gezeigt indem Sie die Optionen 'Zahnrad' in der oberen rechten Ecke der Matrix Werkzeugleiste und wählen Sie Wert Einstellungen anzeigen ... und dann auf die Schaltfläche Bearbeiten und wählen Sie die Option Eigenschaft anzeigen und die Auswahl der Unterkunft.

Direkte Verbindungen Matrix, die die Server, auf denen Anwendungen mit Farbgebung und einer Eigenschaft gehostet wobei anstelle gezeigte generische 'X'

- ODER -

"Indirekten" Verbindungen Matrizen

6. Swähleneine Sequenz von Verbindung Typen und Komponententypenauf der rechten und linken Seite des Menüs, das angezeigt wird, wenn Sie in den "Zellen" der Matrix, wenn ein sehen wollenn indirekten Weg der angeschlossenen Komponentenbestehen aus der Vertikal/ 'Reihe"Komponente der Matrix, um das Horizontal/ 'Spalte"Bestandteil der Matrix.

Notiz

Jeder gültige Pfad, der in der Bahn-Menü w ausgewählten Elemente enthältill angezeigtungeachtet der Richtung der zugrundeliegenden Anschlüsse sind jedoch bei der Auswahl des Weges der erste und letzten Elemente ausgewählt sind Verbindungstypen werden. Ferner das Auftrag der Elemente, die ausgewählt wurden, ist mit einem gezeigten numerischen Präfixin quadratischen ('[]') Klammern und eine gegebene Art enthalten sein können mutliple Zeitenin dem Weg (wie durch die numerische Präfix angegeben ist). In Folge Auswahl der Komponententypen oder Verbindungstypen als eine interpretierte 'ODER'Pfad und die Hierarchie der angeschlossenen Komponenten kann gegebenenfalls durch die Überprüfung einbezogen werden die 'Auch nach Anhang Eltern / Kinder"Kontrollkästchen. Schalten Sie die Quelle und SinkenKomponenten-Typ Auswahl, um die Ansicht Wege in der Gegenrichtung.

7. Die Matrix wird mit einem aufgefüllt werdenPfad / Sammlung von Komponentenin den Zellen, wenn es ein Pfad von dem Vertikal/ 'Reihe'Bestandteil der Matrix, um das Horizontal/ 'Spalte"Bestandteil der Matrix.

Notiz

Bei großen Matrizen nur maximal 100 Zeilen oder Spalten (einschließlich brach Zeilen / Spalten) wird zu einem Zeitpunkt, wie durch den "R" und "C" Indikatoren im oberen linken Kopfzelle gezeigt angezeigt. So zeigen Sie zusätzliche Zeilen verwenden Sie die Bildlaufleisten. Zu jeder Zeit können Sie einen Doppelklick auf das Vertikal/ 'Reihe' oder HorizontAl / 'Spalte' Komponente Überschriften und springen zudie entsprechenden Komponenten in der Explorer-Fenster.Die Eltern des Vertikal/ 'Reihe' und Horizontal/ 'Spalte' Komponentes sind ebenfalls wahlweise als Überschrift-Zeilen / Spalten mit einem grauen Überschrift Titel angezeigt. Wenn (durch Einzelklick die Überschrift-Zelle), ob irgendwelche Kinder Wegen existiert dann ein "X" eingestürzt wird wahlweise angezeigt, wenn alle Kinder angebracht werden oder eine "O" wird wahlweise angezeigt, wenn nur ein Teil der Kinder hatte Pfade werden. Die indirekten Weg Komponenten können farbig nach einem Eigenschaftswert der Komponenten, indem Sie die Optionen 'Zahnrad' in der oberen rechten Ecke der Matrix Werkzeugleiste und wählen Sie Farbeinstellungen ... und dann auf die Schaltfläche Bearbeiten und wählen Sie die Farbe von Zeitpunkt oder Colour By Property Option und Auswahl eine Eigenschaft, die Min- und Max-Wert-Bereich und der Auswahl der Farben, aber nur Liste, Integer, Dezimal, Boolean oder Datum / Zeit Datentyp-Eigenschaften werden zu färben. Eigenschaftswerte für den indirekten Weg Komponenten können gezeigt indem Sie die Optionen 'Zahnrad' in der oberen rechten Ecke der Matrix Werkzeugleiste und wählen Sie Wert Einstellungen anzeigen ... und dann auf die Schaltfläche Bearbeiten und wählen Sie die Option Eigenschaft anzeigen und die Auswahl der Unterkunft.

Indirekte Verbindungen Matrix, die die Anwendungen, die einen bestimmten Service von Abteilung zu implementieren

Zu Filtereine Matrix-Ansicht in ABACUS

1. Stellen Sie sicher, dass Sie eine neue haben Matrix-Ansicht öffnen.

2. Klicken Sie auf den Filter Axes "Trichter" in der oberen rechten Ecke der Matrix-Symbolleiste.

3. Auf der Quelle und / oder der Spüle Registerkarten hinzufügen, Namen, Eigenschaft, Beschreibung, Hierarchie oder Standard-Filter, indem Sie auf die Schaltfläche Hinzufügen, die Auswahl einer Immobilie bei Bedarf und klicken OK. Wählen Sie die entsprechenden Optionen in der Keywords / Artikel-Panel mit der Logik / Syntax wie in der Anmerkung unten beschrieben. Das Vorschaufenster wird automatisch aktualisiert, um die Ergebnisse der aktuellen Reihe von Filtern zu zeigen.

Notiz

Für Zeitstempel, Hierarchiepfad, Namens oder BeschreibungFiltern oder Text, Integer, Dezimal, Boolean oder TerminzeitImmobilien Filter Anpassung, als ob '*' Wildcards werden automatisch vor und nach beliebigen String-Werte durchgeführt, so dass ein Eintrag von "Katze" (ohne die Anführungszeichen) würde Zeilen mit "bob schließenKatze','KatzeFrau "oder" AnwenKatzeion 'usw. Mehrere / "oder" Werte können auf neue Linien mit eingegeben werden Strg + Enter. Für Ganze Zahl und Dezimal Immobilien Filter "und" Logik kann mit "aufgenommen werden&"(Ohne die Anführungszeichen), und mehr als / weniger als etc Logik kann mit einbezogen werden"> =','>','<' und '<="(Ohne die Anführungszeichen) z > = 50000 & <90000. Nicht leeren Wert Reihen kann durch Eingabe von 'enthalten sein(Non-Blanks)"(Ohne die Anführungszeichen) und Blank geschätzten Zeilen kann durch Eingabe enthalten sein '(Blanks)' (ohne die Anführungszeichen). Für Standards oder Liste Immobilienfilter Die "(Alle auswählen)" Kontrollkästchen Sie alle anderen Kontrollkästchen in der Tat mit allen zur Verfügung stehenden Elemente zu ermöglichen. Der '(Non-Blanks) "Kontrollkästchen werden alle nicht leeren Eigenschaft geschätzt Elemente enthalten. Der '(Leerzeichen) "Kontrollkästchen wird auch eine beliebige leere Eigenschaft geschätzt Elemente. Und deaktivieren alle spezifischen geschätzt Kontrollkästchen automatisch deaktivieren Sie den "(Alle auswählen)" und "(Non-Blanks)" Kontrollkästchen für Konsistenz. Und schließlich, sind alle Filter standardmäßig Kleinschreibung so "Katze" (ohne die Anführungszeichen) würde auch Elemente mit "Katze", "Katze" oder "CAT" usw. Für Groß- und Kleinschreibung passenden, geben Sie '(Fall)"(Ohne die Anführungszeichen), bevor der String beispiels "(Urteil) Cat" (ohne die Anführungszeichen) nur Elemente enthalten, mit "Katze" in ihnen.

So füllen Sie mit einem Matrix-Ansicht in ABACUS

Notiz

Sie können nur hinzufügen, / Verbindungen, wo eine einzige Verbindungstyp ist für die oben beschriebene Weg benutzt worden zu entfernen.

1. Zu fügen Sie eine Verbindungdes ausgewählten Typs zwischen einer Vertikal/ 'Reihe"Komponente und eine Horizontal/ 'Spalte"Komponente der Matrix, wobei ein" X "nicht vorhanden(oder eine gezeigten Eigenschaftswert - siehe Hinweis oben)Doppelklicken Sie auf die Zelle. Ein "X" sollte angezeigt werden (oder ein Eigenschaftswert - siehe Hinweis oben) und eine Verbindung wird auf der obersten Ebene der Connections-Auflistung für die gewählte Architektur erstellt werden.

Notiz

Der Verbindungsname wird die Verbindungstyp Name nach Verbindungstyp Einstellung der Matrix und wenn ein Eigenschaftswert wird anstelle eines 'X' den Standardwert für die Eigenschaft gezeigt wird gezeigt,.

2. Zu eine gezeigten Eigenschaftswert bearbeitenauf der Verbindung zwischen a Vertikal/ 'Reihe"Komponente und eine Horizontal/ 'Spalte"Komponente der MatrixDoppelklicken Sie auf die Zelle, oder rechts auf die Zelle und wählen Sie Wert bearbeiten ..., und bearbeiten Sie den Wert in der Change Value Dialog.

3. Zu entfernen Sie eine Verbindungdes ausgewählten Typs zwischen einer Vertikal/ 'Reihe"Komponente und eine Horizontal/ 'Spalte"Komponente der Matrix, wobei ein" bereits X 'vorhanden ist(oder eine gezeigten Eigenschaftswert - siehe Hinweis oben), Recht-klicken Sie auf die Zelleund wählen Sie Trennen. Der X sollte verschwinden, und die Verbindung wird aus dem Projekt gelöscht werden.

Speichern / speichern als aMatrix-Ansicht

Notiz

Während alle Architect Benutzer können Matrizen zu erstellen, um sie und / oder ihre Einstellungen zu speichern, die User-Lizenz braucht den Designer-Add-on-Fähigkeit. Dies ist zu "schützen" die Konfiguration der vorhandenen Matrizen, die von vielen Benutzern gemeinsam genutzt werden kann. Allerdings verwendet Architect ohne die Designer Add-on kann immer noch auf "Speichern unter" die neuen Einstellungen auf eine neue Matrix zu wählen. Und natürlich alle Benutzerlizenzen können "entledigen" Änderungen an einer bestehenden Matrix zu wählen. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie verlangen, die Designer-Add-on Fähigkeit.Und denken Sie daran, dies ist nur die Einstellungen der Matrix, alle Änderungen an den Daten in der Matrix gebildet werden sofort in das Repository angewendet, unabhängig.

1. Stellen Sie sicher, dass Sie eine neue haben Matrix-Ansicht öffnenund Sie die notwendigen Änderungen vorgenommen haben.

2. im Matrix-AnsichtWerkzeugleiste klicken Sie auf den ganz links sparen MatrixTaste, um die zu retten Matrix-Ansicht und alle Formatierungsänderungen.

Notiz

Wenn Sie nicht über eine Schaltfläche Speichern in der Matrix-Ansicht Symbolleiste dann müssen Sie nicht die Designer-Add-on, und Sie müssen nur in der Lage Speichern alsalle Einstellungen ändert, um eine neue Matrix, wenn Sie die vorhandene Matrix schließen gehen.

3. Ob das Matrix Nameangezeigten Dialogfenster (da auf eine neue Matrix) Geben Sie einen Namen für die Matrixund drücken Sie OK.

Zu Export nach MS Excel-Matrix

1. Stellen Sie sicher, dass Sie eine Matrix-Ansicht öffnen.

2. Drücke den Export nach ExcelSchaltfläche in der Symbolleiste.

3. Wählen Sie einen Dateinamen, um die MS Excel-Matrix als zu speichern. Klicken sparen.

Notiz

Standardmäßig ist der exportierten Excel-Matrix Dateinamen wird die Matrix Namen von der Architektur Namen in Klammern angehängt sein, zB "Anträge auf Servers (2014 Actual) gehostet .xlsx". Sie können alle dies zu ändern, einschließlich, ob das Dateiformat, um .xlsx oder .xls sein.

Matrix-Formatierungist standardmäßig exportiert, aber für große Matrizen kann dies in der Export als ziemlich langsam führen. Dementsprechend wird in Tools | Options ...dann auf das Matrix Tab,Sie sind in der Lage, die Menge der Formatierung, die exportiert wird, wie auf der Registerkarte Matrix unten zu reduzieren, wodurch die Beschleunigung des Export.

Matrix Export Optionen

4. Ein Export abgeschlossen Dialog wird angezeigt. Klicken OK.

Nach MS Excel exportiert Matrix

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Auffüllen der Architektur aus Visio | Auffüllen der Architektur aus Excel


Auffüllen der Architektur von Microsoft Access

Navigation: Füllen Sie Ihre Architektur> Auffüllen von Microsoft-Produkten>

Auffüllen der Architektur von Microsoft Access

Senden Sie Kommentare Zu diesem Thema.

Sie können Ihre Architektur zu Microsoft Access exportieren, um Allzweckberechnungen, Manipulationen oder Berichte von Ihrer Architektur durchzuführen. Anschließend können Sie die Architektur wieder in ABACUS.

Notiz

Das Öffnen von Access / den Datenbank-Export Funktion erfordert, dass Microsoft Access 2000auf dem Computer oder neuer installiert ist.

Ihre Architektur zu Microsoft Access exportieren

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffne das Forscherangezeigt wird, und ein Architektur hinzugefügt.

2. Wählen Sie Datei | Export | Um Datenbank.

3. Beachten Sie die Warnmeldung, wie oben beschrieben, und klicken Sie auf Ja, um fortzufahren.

4. Wählen Sie einen Speicherort und Dateinamen für die Datenbankdatei.

Um die Stell Architektur in ABACUS importieren

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Wählen Sie Datei | Neu und wählen Sie Von Zugangaus dem angezeigten Dialogfeld und klicken Sie auf OK.

3. Suchen Sie nach der Datenbankdatei, die Sie importieren möchten.

MS Access-Datenbank-Schema ABACUS '

ABACUS hat an seinem Herzen einn Ontologie / Meta-Meta-Modell aus Komponenten, Anschluß und Einschränkungen gemacht. Dieses "CCC" Konzept wurde von verschiedenen Standard-Ansätze aus den 1960er Jahren ab ihren Höhepunkt in den internationalen Standard IEEE 1471, die Avolution Gründer dazu beigetragen, entwickelt abgeleitet. Die folgenden Grundelementen anzuwenden;

1. ABAKUS enthält Bibliotheken von Standards(oder Standards), Komponente und Verbindungstypen, Beschränkungen, Aussichtspunkte, Vorlagen (oder Patterns) und viele Architekturen.

2. Standards, Typen und Aussichtspunkte kannlogisch Gruppiert Bequemlichkeit.

3. Architekturen kann enthaltenviele Nachkommen Architekturen(oder Evolutions).

4. Jede einzelne Architektur enthält viele Components und Anschlüssebestimmter Typenund verschiedene Ansichten.

5. Components und Anschlüsse kann sein zerlegt in Sub-Komponenten und Sub-Anschlüsse.

6. Jede einzelne Komponenteist angeheftetEine beliebige Anzahl von Anschlüsseaber jedes Verbindungkann nur sein, angeheftetmaximal zwei Components.

7. Components und Anschlüsse kann haben Standards mit Immobilienwie zB Informationen, Performance, Zuverlässigkeit, Kosten usw.

8. Architekturen, Components und Anschlüsse kann habenspezifische Immobilienwie zB Informationen, Performance, Zuverlässigkeit, Kosten usw.

9. Beschränkungen kann bestehen zwischen Components oder Anschlüsse oder gegen Immobilien.

10. Vorlagensind Standardzusammensetzungen Komponente und Verbindungstypen.

11. Aussichtspunktesind Standardverbände Komponente und VerbindungstypenIn den Notationen.

12. Ansichtensind visuelle Darstellungen von Components und Anschlüsse.

Die folgende MS Access Entity Relationship Diagram (ERD) dokumentiert der AderArchitekturen, Evolutions, Component / Verbindungstypen (und Gruppen), Komponenten / Anschlüsse und Sub-Komponente / Anschlusskonzepte.

Das Datenbankschema Kern

Notiz

Referentielle Integrität nicht auf die Beziehung zwischen den Komponenten-Tabelle und der Connections-Tabelle (für die "Anlage" zwischen einem gegebenen Source oder Sink-Komponente und eine Connection) durchgesetzt. Dies liegt daran, dass eine Verbindung ohne die Komponente Anlagen existieren. Wir könnten eine "Anlage" Tabelle hinzugefügt haben, aber im Interesse der Einfachheit entschieden dagegen. Natürlich bedeutet dies, dass jede Bearbeitung von Komponenten-IDs oder Löschen von Komponenten Zeilen alles zusammen führt zu falschen Daten führen. ABACUS wird keine Unrichtigkeit bei der Einfuhr durch Ignorieren Sie die falschen Daten zu verarbeiten.

Die folgende MS Access ERD dokumentiert der ImmobilienKonzepte für Architekturen, Component / Anschlussarten und Komponenten / Anschlüsse.

Eigenschaften Datenbankschema

Die folgende MS Access ERD dokumentiert der StandardsKonzept für Architekturen, Component / Anschlussarten und Komponenten / Anschlüsse.Hinweis: Die Tabellen noch den Begriff "Durchführung" nach früheren Versionen von ABACUS.

Standards des Datenbankschemas

Die folgende MS Access ERD dokumentiert der BeschränkungenKonzept für Component / Verbindungstypen.

BeschränkungenDatenbankschema

Die folgende MS Access ERD dokumentiert der Aussichtspunkte Konzept Architekturen.Hinweis: Die Tabellen noch den Begriff "TwoDTempl 'nach früheren Versionen von ABACUS.

AussichtspunkteDatenbankschema

Die folgende MS Access ERD dokumentiert der KatalogeKonzept Architekturen.

KatalogeDatenbankschema

Die folgende MS Access ERD dokumentiert der MatrizenKonzept Architekturen.

MatrizenDatenbankschema

Die folgende MS Access ERD dokumentiert der DiagramsKonzept Architekturen.Hinweis: Die Tabellen noch den Begriff "twod 'nach früheren Versionen von ABACUS.

Notiz

Die Komponente / Verbindungstyp auf Form-Mapping und Freiform Teile der MS Access ERD Stencil wurden der Übersichtlichkeit halber weggelassen.

DiagramsDatenbankschema

Die folgende MS Access ERD dokumentiert der 3D-AnsichtenKonzept Architekturen.

3D-AnsichtenDatenbankschema

Die folgende MS Access ERD dokumentiert der ChartsKonzept Architekturen.

ChartsDatenbankschema

Die folgende MS Access ERD dokumentiert der Dashboards Konzept.

DashboardsDatenbankschema

ABACUS 'MS AccessAnfragen

Mit der MS Access-Datenbank enthalten sind mehrere nützliche Anfragen wie folgt;

· Comps von Props- Diese Abfrage listet alle Komponenten in das Projekt (von der Architektur und Typ) und beinhaltet alle Eigenschaften als Spalten. Verwenden Sie diese Abfrage mit Filtern / Kriterien über die Bauteil und / oder Architektur zu "typischen" Tabellen für die einzelnen Komponenten-Typ mit ihren Eigenschaften zu produzieren.

· Stds von Props- Diese Abfrage listet alle Standards, die verwendet werden, die Anzahl der Vorkommen des Standards und umfasst alle Eigenschaften als Spalten. Verwenden Sie diese Abfrage als Standards Katalog ein.

· Props von Typen- Diese Abfrage listet alle Komponenteneigenschaften und deren% vollständig von jedem Komponententyp als Spalten. Verwenden Sie diese Abfrage, um festzustellen, ob bestimmte Eigenschaften eingehalten werden.

· Typen von Props- Diese Abfrage listet alle Komponententypen und beinhaltet die komplette% aller Eigenschaften als Spalten. Verwenden Sie diese Abfrage, um festzustellen, ob bestimmte Eigenschaften eingehalten werden.

· Typ Count- Diese Abfrage listet alle Komponententypen und enthält die Anzahl der Vorkommen der einzelnen Arten in absteigender Reihenfolge. Verwenden Sie diese Abfrage, um die Popularität der einzelnen Arten in das Projekt zu bestimmen.

Ein Hinweis auf die Arbeit mit Memo-Felder in MS Access

Die Komponenten, Anschluß und Standards Namensfelder in den Tabellen sind als Memo-Felder definiert, um für eine unbegrenzte Anzahl von Zeichen zu ermöglichen, wie pro ABACUS. Für die Bauteile und Verbindungen verursacht dies einige Probleme, weil sie auch eine einzigartige ID-Feld für die Referenzierung, aber für die Standards das verursacht einige Probleme, wenn sie versuchen, um Tabellen zu verknüpfen, weil Sie nicht Memo-Felder in MS Access anzuschließen. Alternativ können Sie eine WHERE-Klausel Kriterien festgelegt, wie in der Visual Query Builder und gezeigt entsprechenden SQL-Schnipsel unterhalb dieser Liste aus, um den gleichen Effekt zu erzielen alle geerbt Standards Eigenschaften für alle Komponenten in der exportierten ABACUS-Projekt.

Memo-Feld 'Verknüpfungen' in Visual Query Builder

WÄHLEN Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Von den Komponenten INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) und (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Implementierungen INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

WHERE (((ComponentImplementationLinks.Name) = [Implementierungen] [Name]).);

Memo-Feld 'Verknüpfungen' in SQL

Ein Hinweis zum automatischen Erzeugen von ABACUS IDs in MS Access

Verschiedene ABACUS MS Access-Tabellen benötigen eine einzigartige lange Ganzzahl-ID, so eine einfache VB-Verfahren vorgesehen ist, um bei der Erzeugung von diesen zu unterstützen. Zwei Methoden Resetcounter () und GetNextCounter () innerhalb ABACUS 'MS Access DB vorgesehen, und ihre Verwendung ist wie folgt; Resetcounter () wird der Zähler wieder auf 0 GetNextCounter () gesetzt wird der nächste Zähler in der Sequenz zurück.

Die Methoden nutzen eine MS Access "Marotte", dass selbst wenn Sie die Resetcounter () -Methode für jede Zeile einfügen (dh, wenn Sie die GetNextCounter () -Funktion führen auch), weil die Resetcounter () Funktion keine Parameter es gerade läuft haben es einmal und bietet deshalb nicht die Zähler für jede Zeile Einsatz nicht zurückgesetzt. Und auch wegen der gleichen 'Unikat' muss man alle alten Spaltengröße an die GetNextCounter () Funktion zu übergeben, um sie in laufen jedes Mal zu täuschen.

Es gibt auch einen Trick, um in der Lage, den Resetcounter () in einem Einsatz in die SQL-Anweisung ausgeführt werden, weil man kann nicht nur haben sie dort sitzen als Spalte auf seine eigene, wie wenn es eine Auswahlabfrage. Es wird empfohlen, um den Resetcounter () Aufruf Teil eines der anderen Felder zu machen, durch die Verkettung es bis zum Ende, wie es immer null zurück sowieso.

Im Folgenden ist eine typische SQL Verwendung der Verfahren, um eine Liste der Komponententypen aus einer Tabelle / Abfrage namens "Component Type List 'hinzuzufügen.

EINFÜGEN INComponentTypes (ID, Name, Beschreibung)

SELECT GetNextCounter ([Component Type List] .name)AS Id [Component Type List] .name Name, [Component Type List] .beschreibung & Resetcounter ()AS Beschreibung

VON[Component Type List];

ABACUS ID / Zähler-Generation in SQL

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Auffüllen der Architektur aus Visio | Auffüllen der Architektur aus Excel


Auffüllen der Architektur von Microsoft Visio

Navigation: Füllen Sie Ihre Architektur> Auffüllen von Microsoft-Produkten>

Auffüllen der Architektur von Microsoft Visio

Senden Sie Kommentare Zu diesem Thema.

Sie können Ihre Architektur aus Microsoft Visio importieren. Shapes in der Visio-Zeichnung als Komponenten in ABACUS importiert werden. Verbindungen in Visio-Zeichnung als Verbindungen importiert werden und die Zeichnung selbst wird in ABACUS als Diagramm importiert werden. Darüber hinaus werden alle benutzerdefinierten Eigenschaften in der Visio-Zeichnung als Eigenschaften mit dem Key Sortieren auf die Art der Immobilie abgebildet, Etikett, um eine Immobilie und den Wert an die Eigenschaft Wert importiert werden.

Notiz

Der Import von Visio Funktion erfordert, dass Microsoft Visio 2003auf dem Computer oder neuer installiert ist.

Um Ihre Visio-Zeichnungen in ABACUS importieren

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Wählen Sie Datei | Neu und wählen Sie Von Visioaus dem angezeigten Dialogfeld und klicken Sie auf OK.

Notiz

Wenn Sie in eine bestehende ABACUS Projekt importieren möchten, dann entweder mit der rechten Maustaste auf den Knoten Komponenten innerhalb einer Architektur, oder rechtsklicken Sie eine einzelne Komponente innerhalb einer Architektur und wählen Sie Import | Von Visio.

3. Suchen Sie nach der Visio-Datei, die Sie importieren möchten.

Notiz

Im Folgenden sind einige einfache Regeln oder empfohlene Praktiken bei der Konstruktion (oder Änderung) eine MS Visio-Zeichnung für den Import in ABACUS.

1. Die Leitungen oder Anschlüsse müssen tatsächlichen Anschlüsse, NICHT Formen sein.

· Ansonsten ABACUS wird genauso Komponenten importieren und entsprechend werden sie nicht "angehängt" werden, um irgendetwas.

· Wenn Sie einige "intelligente" Routing (dh andere als eine gerade Linie) zu tun, dann nutzen Sie die dynamische Anschluss auf der Basis Shapes-Schablone benötigen, ABACUS importieren die Routing / Ankerpunkte in Ordnung.

· Versuchen Sie zu vermeiden, mit dem "Ring-Netzwerk" und "Ethernet" Formen aus dem Netzwerk und Peripheriegeräte Schablone, die viele Komponenten an, um es zu "verbunden" werden kann. Während wir importieren die Anlagen in Ordnung, Verbindungen die ursprüngliche Form ist immer noch "erweitert", um die Anlagen zu reflektieren. Verwenden Sie trennen einen separaten "Hub / Bus" Form (ohne den Verbinder "Beine") und dann explizit eine Verbindung der einzelnen Komponenten an der Nabe / Bus mit separaten Anschlüssen.

· Wenn eine Linie oder Verbindung verhält sich wie eine Form, rechten Maustaste darauf und gehen Sie zu "Format | Verhalten ... "und stellen Sie sicher, dass Interaction Design an Line (1-dimensional) gesetzt.

2. Die Komponenten müssen Formen NICHT Anschlüsse sein.

· Ansonsten ABACUS wird genauso Verbindungen importieren und entsprechend alle Forminformationen gehen verloren.

· Wenn eine Komponente verhält sich wie ein Verbindungsstück, rechts klicken Sie und gehen Sie zu "Format | Verhalten ... "und stellen Sie sicher, dass Interaction Design an Box (2-dimensional) festgelegt ist.

3. Anschlussenden müssen den Formen befestigt werden, nicht im Umlauf in den Hintergrund hinter der Form.

· Wenn Sie die Anschlüsse nicht mit den Formen zu verbinden weiß dann ABACUS hat keine Möglichkeit zu wissen, dass Sie beabsichtigt, die angesichts Stecker an die Form / Komponente zu befestigen und somit wird es, dass Ende der Verbindung un-gebunden zu verlassen.

4. Etiketten für Formen sollte (wenn möglich) die eingebaute Textbezeichnung für die Form, keine separate Textfeld auf der Zeichnung zu sein.

· Separate Textfelder werden von ABACUS als Komponenten in ihrem eigenen Recht importiert werden, und während Sie das "label" Komponente mit der realen Komponente in ABACUS fusionieren, oder einfach nur das "label" Komponente konvertieren, um einen Freiform-Form (dh keine Komponente selbst) ist es am besten, um diese Schritte zu vermeiden.

5. Verwenden Sie die gleiche Grundform für jede Instanz des gleichen Typs, sei nicht faul und benutzen manchmal Rechteck und Feld andere von unterschiedlicher Form Schablonen.

· ABACUS verwendet die Grundform und seine Grundfarbe, um die Komponente und Verbindungstypen in der Zeichnung, so ein "rotes Rechteck" und ein "red box" werden als zwei separate Komponententypen importiert werden eindeutig zu identifizieren. Diese Komponententypen können in ABACUS zusammengeführt werden, aber es ist am besten, um diese Schritte zu vermeiden.

6. Wholly kapseln "Kinder" Formen innerhalb ihrer "Eltern", lassen Sie sie nicht hängen über den Rand.

· ABACUS wird eine beliebige Form, die vollständig innerhalb einer anderen Form als Kind des Eltern eingekapselt ist, so stellen Sie sicher, die ganze Form, einschließlich der Etikettteil, eingeschlossen zu erkennen.

7. NICHT positionieren eine Form überlappenden zwei andere Formen.

· Wenn eine Form überlappt beiden anderen Formen, sei es eine "Gruppierung" / Hintergrundrechteck oder auf andere Weise, wird es von ABACUS als eine Komponente, die ein Kind nicht überlappenden Formen ist aber importiert werden, sobald Sie die Komponente in ABACUS "Zeichenwerkzeug auswählen Aufgrund der oben links wobei die Komponenten Referenzpunkt, wird er ein Kind des linken geworden überlappt Form / Komponente.

8. Versuchen Sie, die Verwendung von Text-Notizen auf der Zeichnung zu minimieren, da diese werden als Komponenten in ihrem eigenen Recht importiert werden und müssen, um Freiformflächen in ABACUS umgewandelt werden. Denken Sie darüber nach, ob sie wirklich der Name einer vorhandenen Komponente oder Verbindung.

9. Während ABACUS unterstützt reiche / farbig / vektorbasierte Formen, versuchen, die Verwendung von Bitmaps, fremde Formen und Enhanced Metafiles für Formen zu minimieren, wie ABACUS derzeit tutnichtunterstützen diese Arten. Sie werden als einfache weiße Rechtecke importiert werden.

10. Versuchen Sie, Wagenrücklauf (Shift-Return) in Etiketten zu vermeiden, wie sie eingeführt werden und als Sonderzeichen "[]" in ABACUS für die Komponentenname angezeigt.

11. Versuchen, die verschiedenen Farben, die zum Formen des gleichen Typs verwendet werden, zu minimieren. Wie oben erwähnt, Grundfarbe und Grundform eindeutig identifiziert Komponente und Verbindungstypen, so dass die mehr Abwechslung gibt es die weitere Zusammenführung und Konsolidierung, die Notwendigkeit, nach der Einfuhr in ABACUS durchgeführt werden.

12. Seien Sie vorsichtig mit gefüllten Formen, weil eine Form, die den ganzen Weg zu den Ecken gefüllt später Färbung in ABACUS keine Wirkung.

13. Für komplexe zeilenbasierte Formen müssen Sie ein Polygon, das durch mit Linien ab, wo der vorherige beendet und dann letztendlich geht zurück auf den Startpunkt erstellt wird, zu verwenden. Falls gewünscht, können Sie Füll- und Linienbreite zu verwenden, um das Polygon zu sehen wie ein "Pfeil" oder was auch immer gewünschte Form zu machen.

14. Sicherstellen, dass die Formen ID in MS Visio ist sinnvoll nicht nur Shape.xx. Dies ist editierbare mit der rechten Maustaste "Shapesheet anzeigen", die in MS Visio Entwicklermodus ist (| Optionen in MS Visio durch Werkzeuge aktiviert).

15. Ellipsen und Bögenin Formensind in ABACUS unterstützt, aber nurbs und Splines werden derzeit nicht unterstützt.

16. Stellen Sie sicher, die gesamte Form wird in MS Visio gruppiert oder wird es als mehrere Komponenten / Typen importiert werden.

17. Versuchen, die Verwendung von gedrehten Formen innerhalb subshapes zu minimieren, da sie in manchen Fällen nicht korrekt eingelesen werden.

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Auffüllen der Architektur aus Zugang | Auffüllen der Architektur aus Excel


Auffüllen der Architektur aus Microsoft Excel

Navigation: Füllen Sie Ihre Architektur> Auffüllen von Microsoft-Produkten>

Auffüllen der Architektur aus Microsoft Excel

Senden Sie Kommentare Zu diesem Thema.

Sie können Ihre Architektur aus einer Excel-Tabelle importieren (.xls oder .xlsx Datei). Die Excel-Importprogramm können Sie Listen von Komponenten und Verbindungen mit Typen, Normen, Eigenschaften und Standard Eigenschaften zuordnen, indem Sie die Spalten in Ihrer Tabelle, die die relevanten Daten enthalten.Es ist jedoch eine weitere fortgeschrittene Technik als das empfohlene Vorgehensweisefür den Import aus MS Excel, die über ist Katalogen wie beschrieben Hier .

Notiz

Der Import von / Excel-Export-Funktion erfordert, dass Microsoft Excel 2003auf dem Computer oder neuer installiert ist.

Die Hauptfunktion des Excel Importer ist, damit Sie eine Konfigurationsdatei (dh der hierarchischen Struktur des Architekturmodell) zu definieren. Die Konfigurationsdatei speichert eine zuvor gespeicherte Mapping aus einer Excel-Datei in einem ABACUS-Datei. Einmal definiert, wird die gespeicherte Konfigurationsdatei später zur weiteren Import von gebrauchten und Export nach XLS-Dateien.

Notiz

Die in den folgenden Abschnitten dargestellten Schritte sind speziell für Anwender, die noch zu definieren und zu speichern eine Konfigurationsdatei und den Import aus Excel zum ersten Mal. Sie müssen erstellen und speichern Sie eine Konfigurationsdatei, um den Export zu verwenden, um Funktion zu übertreffen.

So importieren Sie eine Excel-Tabelle in ABACUS

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Wählen Sie Datei | Neu und wählen Sie aus Übertreffenaus dem angezeigten Dialogfeld und klicken Sie auf OK.

Notiz

Wenn Sie in eine bestehende ABACUS Projekt importieren möchten, dann entweder mit der rechten Maustaste auf den Knoten Komponenten innerhalb einer Architektur, oder rechtsklicken Sie eine einzelne Komponente innerhalb einer Architektur und wählen Sie Import | Von Excel.

3. das Import Excel-TabelleFenster wird angezeigt

Import Excel-Tabelle Fenster

4. Drücke den Öffnen Sie Excel DateiSymbol und suchen Sie nach der Excel-Datei, die Sie importieren möchten.

5. Wählen Sie das ArbeitsblattSie importieren aus dem Dropdown-Feld wollen.

Notiz

Nach dem Öffnen Ihrer Excel-Datei, können Sie die Verwendung DatenvorschauRegisterkarte, um die Säulen und ersten 25 Zeilen Ihrer Tabelle anzuzeigen. Von hier aus können Sie die Spaltennummern benötigt, um füllen Sie erhalten die Components und Anschlüsse Tab.

Sie können auch auswählen, ob Sie Komponenten in eine Excel-Tabelle mit Groß- und Kleinschreibung importiert werden soll. Einfach ankreuzen die Import mit Groß- und KleinschreibungOption (standardmäßig immer angekreuzt) und die Tabellenkalkulation entsprechend importiert werden.

Beispiel Excel Datei

Notiz

In diesem Beispiel werden wir eine einfache Infrastruktur und Architektur von den Menschen in der obigen Screenshot gezeigt Excel-Daten importieren. Verbindungen werden zwischen "Verantwortliche" und "Server", dass diese Menschen zu verwalten werden.

Um die Registerkarte Komponenten bevöl

Dieser Bereich ist für die Festlegung der Komponententypen und die hierarchische Struktur der Konfigurationsdatei.

1. Wähle aus Components Tab. Benennen Sie die Set IDdurch Überschreiben der (Null) Wert

Notiz

Diese Funktion ermöglicht es Ihnen, völlig anders definieren Setsfür funktional getrennten Komponenten. Wie in der Abbildung unten gezeigt, können Sie Ihre Infrastruktur-Komponenten von Ihrem Menschen Komponenten unterscheiden. Wenn es Beziehungen (Verbindungen) zwischen diesen getrennte Sätze von Komponenten, können sie unter dem festgelegt werden Anschlüsse Tab. Später in diesem Beispiel werden wir Verbindungen vom Typ "Verwaltet" zwischen der Infrastruktur und Menschen zu definieren Sets.

Sie können auch auswählen, ob Sie eine Top-Level hinzugefügt werden soll GruppierungKomponente für alle Elemente des Satzes. Einfach ankreuzen die Gruppe unter Set IDOption (standardmäßig nicht markiert) und der Tabellenkalkulation werden entsprechend importiert werden.

Zuweisen Set ID

2. Sobald das Setsdefiniert wurden wählen das SetSie bevölkern und zu erweitern, indem Sie auf das wollen [+] Schild.

3. Auswählen Ebenen der Komponenten in diesem Setaus der erweiterten Liste.

4. das Komponentenhierarchie Sets: Set IDFenster für das erscheinen Set.

Komponentenhierarchie und Zuordnung von Werten (Set ID: Infrastructure)

5. Benennen Sie die Stufe ZahlSäule durch Überschreiben der (Null) Wert.

Notiz

das Stufe ZahlSpalte können Sie eine Hierarchie, um Ihre Komponenten zuweisen. Jede Stufe entspricht einer Schicht innerhalb Ihrer Architektur, wobei die erste Ebene ist die oberste Elternteil Ebene. B. Stufe Zahl "1" entspricht der obersten Hierarchieebene, Ebene Nummer "2" ist das Kind der Stufe "1" und so weiter.

6. Wählen Sie und vergeben Sie die entsprechende Spalte aus der Excel-Tabelle zu jedem Stufe Zahlvon unter der Eingabe Component Spalte Spalte.

Notiz

Sie können wählen, um bestimmte Zeilen, die Sie wollen nicht in Ihre Architektur dargestellt werden ausgeschlossen. Diese können Spaltenüberschriften, leere Zeilen usw. werden, um auszuschließen, verwenden Sie die Zeilen Zeilen ausschließen:Textfeld in der Nähe der oberen rechten Ecke des Fensters. In diesem Beispiel haben wir die Zeile 1 ausgeschlossen, weil es unser Spaltenüberschriften enthält.

7. Sie können wählen, um Beschreibungen zu Ihren Komponenten durch Überschreiben der hinzufügen (Null)Wert in der Beschreibung Spalte.

Notiz

Diese Beschreibung ist, was in ABACUS unter die erscheinen Allgemeine EigenschaftenAbschnitt | Beschreibung Bereich.

8. Wenn eine gegebene Tabellenkalkulation Spalte hat mehr als eine Komponente pro Zelle (angegeben mit Alt-Eingabe oder CHAR (10) Befehl) kreuzen Sie das Kontrollkästchen unter Gönnen New Linien als separate Komponenten. Jede Zeile wird als separate Komponenten importiert werden.

Spitze

Um eine "Matrix" aus einer Sammlung von Spalten, in denen ein "X" in einem bestimmten "Matrix" Zelle (Zellen B2: D2 sagen) importieren impliziert, dass die durch die Zeilen angegebenen Komponente (in Zelle A2 sagen) mit dem Bauteil verbunden von der Spalte "Überschrift" (in Zeile 1 Wort) angegeben ist, kann eine einfache Formel verwendet werden. Geben Sie die folgende Formel für jede Zeile in einer Spalte über die Matrixzellen (Spalte F sagen); = IF (B2 = "", "", B $ 1 CHAR (10)) und IF (C2 = "", "", C $ 1 & CHAR (10)) und IF (D2 = "", "", D $ 1 & CHAR (10)). Dann eine Verbindung hergestellt, wie unten zwischen den durch die Zeilen angegebenen Komponenten beschrieben (in Spalte A sagen) und die von dieser Formel (in Spalte F sagen) eingestellt. Achten Sie darauf, das zu überprüfen Gönnen New Linien als separate KomponentenOption, wenn die Komponenten aus der Formel importiert werden. Für fortgeschrittene Matrix Import, mit Bezeichnung mit mehreren Schichten von Hierarchie oder Zellen mit unterschiedlichen Werten als nur eine reine 'X', kontaktieren Sie bitte Avolution Unterstützung .

9. Füllen Sie den Rest der Spalten nach Bedarf.

Notiz

Sie können wählen, um die Art von den Säulenreihen, indem Sie das Kontrollkästchen unter der get Holen Sie Type aus der KolonneSäule und Eingabe der entsprechenden Spalte in der Excel-Tabelle unter der Komponente Art Wert oder Spalte Spalte. Dadurch werden alle Komponenten in dieser Spalte zu importieren und stellte sie auf den Typ in der Spalte festgelegt. Alternativ und wie mit dem Screenshot oben und unten, können Sie wählen, um eine feste / vordefinierten Typnamen durch Eingabe der Typnamen unter der Verwendung Komponente Art Wert oder SpalteSpalte und sicherstellen, dass das Kontrollkästchen ist nicht markiert.

Komponentenhierarchie und Zuordnung von Werten (Set ID: People)

Notiz

In diesem Beispiel wollen wir unsere Netze und Menschen Gruppierungen auf der Ebene 1 der Architektur haben. Auf Ebene 2 möchten wir unseren Servern und Personen für die Verwaltung dieser Server befasst sind. das ComponentsTab wurde entsprechend ausgefüllt, wie in den beiden Bildschirm oben gezeigt. In der ersten Abbildung oben haben wir die Stufe 1 (Netzwerk-Gruppierung) und Stufe 2 (Server) Komponenten für die Infrastruktur festgelegt Set. Und im Screenshot unmittelbar über haben wir die Stufe 1 (Personen Gruppierung) und Stufe 2 (Verantwortlichen) Komponenten für die Menschen definiert Set.

Alternativ kann zur MenschenSet, anstatt Spalte C als Menschen Gruppierung, die wir verwendet haben, könnte die Gruppe unter Set IDOption auf der Level-Komponenten Registerkarte oben und dann nur einen Menschen Unterebene von Column D. Dies ist in der Abbildung unten eingetragen.

Komponentenhierarchie und Zuordnung von Werten mithilfe von Gruppen unter Set ID-Option (Set ID: People)

10. Sobald die Komponenten identifiziert worden sind, wählen Sie die Komponentenebene Sie die Eigenschaften und / oder Standards zu bevölkern und zu erweitern, indem Sie auf das wollen [+] Schild.

11. Auswählen Eigenschaften von Komponenten auf dieser Ebene oder der Component Standards auf diesem Niveauaus der erweiterten Liste und füllen Sie die entsprechenden Spalten nach Bedarf.

Füllen Components

Notiz

Eigenschaften von Komponenten auf dieser Ebenekönnen Sie Eigenschaften für Komponenten bei der gewählten Ebene zu definieren. Component Standards auf diesem Niveaukönnen Sie die Standards und deren Standardeigenschaften für Komponenten bei der gewählten Ebene zu definieren.

12. Wiederholen Sie die Schritte 2-11bis alle Komponenten Ebenen haben für alle definierten besiedelt Sets. Verwenden Sie den Zurück-Pfeil in der Nähe der oberen rechten Ecke des Fensters, um zum Navigieren Setsdie Sie zuvor definiert.

Um die Registerkarte Verbindungen bevöl

Dieser Abschnitt ist für die Definition der Verbindungstypen und die hierarchische Struktur für die Konfigurationsdatei.

1. Wähle aus Anschlüsse Tab. Für jede Gruppe von Verbindungen, die Sie haben, um die Komponente zu identifizieren Setdass Sie mit dem Source-Komponenten und die Komponente sein wollen SetSie möchten, dass die Ziel-Komponenten sein.

2. Unter dem Source Component Set IDgeben Sie die SetName, der dem entspricht, Setfrüher in die definierte Components Tab. Unter dem Quelle Komponentenebene Anzahlgeben Sie die Anzahl entsprechend der Komponentenebene, die Sie an der Quelle Ende der Verbindung verbinden möchten.

3. Nun der gewünschte Komponentengruppe am Zielort der Verbindung sein wird. Unter dem Destination Component Set IDgeben Sie die SetName, der dem entspricht, Setin die definierte Components Tab. Unter dem Destination Komponentenebene Anzahlgeben Sie die Anzahl entsprechend der Komponentenebene, die Sie am Zielort Ende der Verbindung verbinden möchten.

Notiz

In diesem Beispiel wollen wir die Menschen für die Verwaltung von Servern auf den Servern, die sie verwalten verantwortlich zu verbinden. Die Verantwortlichen wurden in den Menschen definiert Setals Level 2-Komponenten, während die Server wurden in der Infrastruktur festgelegt Setals Level 2-Komponenten. das AnschlüsseRegisterkarte wurde entsprechend ausgefüllt, wie in der Abbildung unten gezeigt.

Verbindungen Tab Teil 1 von 2

4. Wenn Sie nach rechts scrollen, werden Sie zusätzliche Optionen für den Import Ihrer Verbindungen finden. Holen Sie Type aus der Kolonne und Verbindungstyp Wert oder Spalteauf die gleiche Weise wie für die Components Tab.

5. Wenn das Source Component Set IDund Quelle Komponentenebene Anzahlsind die gleichen wie die Destination Component Set IDund Destination Komponentenebene Anzahl(zum Beispiel, wenn Sie verbinden die gleichen Komponententypen, wie Herstellen von Verbindungen von Servern auf andere Server), dann müssen Sie eine andere Spalte in Ihrer Tabelle, die die Namen der Server wiederholt enthält. In dieser Situation würden Sie diese Spalte in der Tabellenkalkulation setzen Destination in Spalte Wiederholte Spalte. Wenn in dieser Tabellenkalkulation Säulen Sie mehr als eine angeschlossene Komponente pro Zelle eingegeben haben, dann kreuzen Sie das Kontrollkästchen unter Gönnen New Linien als separate Komponenten.

Verbindungen Tab Teil 2 von 2

6. Sobald die Verbindungen wurden identifiziert wählen Sie die Verbindung, die Sie, um die Eigenschaften und / oder Standards zu bevölkern und zu erweitern, indem Sie auf das wollen [+] Schild.

7. Auswählen Eigenschaften für diese Verbindungen oder Standards für diese Verbindungenaus der erweiterten Liste und füllen Sie die entsprechenden Spalten nach Bedarf.

Notiz

Eigenschaften für diese Verbindungenkönnen Sie Eigenschaften für den gewählten Verbindungsgruppe zu definieren. Standards für diese Verbindungenermöglicht es Ihnen, die Standards und ihre Standard-Eigenschaften für den gewählten Verbindungsgruppe zu definieren.

8. Wiederholen Sie die Schritte 2-7bis alle Anschlußgruppen festgelegt sind.

9. Wenn Sie die Definition der Verbindungsgruppen fertig sind, klicken Sie auf die FertigSchaltfläche und Ihre Architektur wird aus der importierten Excel-Datei erstellt werden. Das obige Beispiel wird in der in der Abbildung unten gezeigten Architektur führen.

Beispiel Architektur von Excel importiert

10. Speichern Sie nun das zugeordnete Konfiguration in einer Datei, indem Sie auf die Save Configuration Symbol. Ihre gespeicherte Konfiguration kann später durch Klicken auf die abgerufen werden Öffnen Sie eine KonfigurationsSymbol in der Nähe der oberen linken Ecke des Fensters.

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Auffüllen der Architektur aus Zugang | Auffüllen der Architektur aus Visio


Auffüllen der Architektur von Microsoft Sharepoint

Navigation: Füllen Sie Ihre Architektur> Auffüllen von Microsoft-Produkten>

Auffüllen der Architektur von Microsoft Sharepoint

Senden Sie Kommentare Zu diesem Thema.

Sie können synchronisieren Ihre Architektur mit Microsoft Sharepoint-Listen. Synchronisation beinhaltet entweder die Schaffung neuer Sharepoint-Listen (und deren Spalten) von ABACUS Typen, deren Eigenschaften und Anlagen oder die Zuordnung der vorhandenen Sharepoint-Listen (und deren Spalten), um ABACUS Typen, deren Eigenschaften und Anhänge, dann entweder Senden von Inhalten von ABACUS auf Sharepoint oder Sharepoint- ABACUS.

Notiz

das Sharepoint-Sync Funktion erfordert, dass ein Microsoft Sharepoint 2010, 2013 oder Sharepoint Online Website verfügbar ist, um zu verbinden und zu synchronisieren.Während die Sharepoint-Sync-Funktion können Listen (mit Spalten) auf einer Sharepoint-Site von jedem ABACUS-Projekt erstellen, können Avolution auch verschiedene Sharepoint-Website-Vorlagen zur Unterstützung der Standard-Frameworks (zB TOGAF, Archimate, ITIL usw.) so kontaktieren Avolution Unterstützung Wenn Sie diese Funktion benötigen.

Zu erstellen Sie eine neue Sharepoint-Liste und ordnen Sie es einem Abakus Komponente oder Verbindungstyp

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Auswählen Tools | Sharepoint-Sync.

3. Drücke den New MappingTaste und eine Sharepoint-Mapping-Dialog wie unten gezeigt erscheint.

4. Geben Sie die URL der Website, Benutzername und Passwort für die Sharepoint-Website und klicken Sie Verbinden.

Notiz

Ein gültiger Sharepoint 'admin' oder 'Beitrag' Konto erforderlich ist, um von und zu Sharepoint und ein "Leser" Konto synchronisieren nur Sync ermöglichen von Sharepoint.

5. Wählen Sie das ABACUS Typ Komponente oder Verbindung mit von der Landkarte Wählen Sie Art herunterziehen.

6. Drücke den Neue hinzufügenTaste und anschließend für jede ABACUS Komponente oder Verbindungstyp Aspekt, auf die sie einen entsprechenden Sharepoint-Listenfeld Karte Wählen Sie ein Element in der linken Seite und auf der rechten Seite geben die neue Sharepoint-Liste Namen in der Spalte Neue Liste (nur beim ersten Mal) möchten , dann ist die Sharepoint-Spaltennamen in der Spalte Name (oder verwenden Sie die Standardeinstellung) und klicken Sie auf Zuordnen jedes Mal.

Notiz

Als Mindestanforderung, damit die Synchronisation der ABACUS EEID, Architektur und Namens Aspekte werden automatisch auf einer Sharepoint-Nummer und zwei (2) Eine Textzeile (auch bekannt als Text) Spalten bzw. abgebildet werden. Diese können nicht aufgehoben werden. Darüber hinaus können nur bestimmte Aspekte ABACUS derzeit auf bestimmte Sharepoint-Spalten abgebildet werden und die Spalte Typ Pull-down wird automatisch auf den gewünschten Sharepoint-Spaltentyp festgelegt werden. Nämlich;

· ABACUS 'Hierarchiepfad auf Sharepoint Mehrere Textzeilen (auch bekannt als Hinweis) Säulen (Hinweis: Sharepoint Eine Textzeile (auch bekannt als Text) Spalten unterstützen nur 255 Zeichen, so dass sie bevorzugt nicht),

· ABACUS "angeschlossenen Komponenten auf Sharepoint Lookup Spalten (Hinweis: Ein Mapping muss bereits vorhanden sein, um eine Liste für die angeschlossenen Komponenten selbst),

· ABACUS 'Text und Beschreibung Eigenschaften Mehrere Textzeilen (auch bekannt als Hinweis) Spalten Sharepoint (Hinweis: Sharepoint Eine Textzeile (auch bekannt als Text) Spalten unterstützen nur 255 Zeichen, so dass sie bevorzugt nicht),

· ABACUS "Dezimal oder Integer Objekte zum Sharepoint Anzahl Spalten

· ABACUS "Listeneigenschaften auf Sharepoint Wahl Säulen (Hinweis: Sharepoint nicht die Wahl Werte durchzusetzen, so dass die Liste Datentyp muss nicht in ABACUS durchgesetzt werden),

· ABACUS "Date / Time Properties auf Sharepoint Mehrere Textzeilen (auch bekannt als Hinweis) Säulen (Hinweis: Sharepoint-Spalten Datum und Uhrzeit kann noch nicht durch Sharepoint inkonsistente Unterstützung für Zeitzone / Regionaleinstellungen verwendet werden),

· ABACUS "Boolean Eigenschaften von Sharepoint Ja / Nein (aka Boolean) Spalten.

Eines ABACUS Element zugeordnet Standards können nicht auf Sharepoint-Liste Spalten noch abgebildet werden.

7. Auswählen Erstellen Mapping.

Zu erstellen Sie eine neue Zuordnung zwischen einem Abakus Komponente oder Verbindungstyp und einer vorhandenen Sharepoint-Liste

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Auswählen Tools | Sharepoint-Sync.

3. Drücke den New MappingTaste und eine Sharepoint-Mapping-Dialog wie unten gezeigt erscheint.

4. Geben Sie die URL der Website, Benutzername und Passwort für die Sharepoint-Website und klicken Sie Verbinden.

Notiz

Ein gültiger Sharepoint 'admin' oder 'Beitrag' Konto erforderlich ist, um von und zu Sharepoint und ein "Leser" Konto synchronisieren nur Sync ermöglichen von Sharepoint.

5. Wählen Sie das ABACUS Typ Komponente oder Verbindung mit von der Landkarte Wählen Sie Art herunterziehen.

6. Wählen Sie die Sharepoint-Site-Liste, um aus der Karte Select-Liste herunterziehen.

7. Für jede ABACUS Komponente oder Verbindungstyp Aspekt, auf die sie ihre entsprechende Sharepoint-Liste Spalten Karte Wählen Sie ein Element in der linken Seite und der rechten Platte jeweils möchten und klicken Sie Zuordnen.

Notiz

Als Mindestanforderung, damit die Synchronisation der ABACUS EEID, Architektur und Namens Aspekte zu einer Sharepoint-Nummer und dann für Architektur und Namen zugeordnet werden, um entweder Eine Textzeile (auch bekannt als Text) oder Mehrere Textzeilen (auch bekannt als Hinweis) Spalten auf. Bis dies geschehen ist das anlegen Mapping-Taste wird nicht aktiviert. Darüber hinaus können nur bestimmte Aspekte ABACUS derzeit auf bestimmte Sharepoint-Spalten abgebildet werden. Nämlich;

· ABACUS 'Architektur Aspekt in einer Sharepoint Eine Textzeile (auch bekannt als Text) oder Mehrere Textzeilen (auch bekannt als Hinweis) Säulen (dies ist für den Inhalt spezifischen Mapping, wie unten beschrieben erforderlich),

· ABACUS 'Hierarchiepfad zu Textzeile (auch bekannt als Text) oder Mehrere Textzeilen (auch bekannt als Hinweis) Säulen (Hinweis Sharepoint: Sharepoint Eine Textzeile (auch bekannt als Text) Spalten unterstützen nur 255 Zeichen, damit alle zusätzlichen Zeichen werden abgeschnitten und damit es wird empfohlen, sie auf mehrere Zeilen Text (auch bekannt als Hinweis) Spalten in Sharepoint, bevor Mapping) umzuwandeln,

· ABACUS "angeschlossenen Komponenten auf Sharepoint Lookup Spalten (Hinweis: Ein Mapping muss bereits vorhanden sein, um eine Liste für die angeschlossenen Komponenten selbst),

· ABACUS 'Text und Beschreibung Eigenschaften Eine Textzeile (auch bekannt als Text) oder Mehrere Textzeilen (auch bekannt als Hinweis) Säulen (Hinweis Sharepoint: Sharepoint Eine Textzeile (auch bekannt als Text) Spalten unterstützen nur 255 Zeichen, damit alle zusätzlichen Zeichen werden abgeschnitten und daher ist es empfehlenswert, sie in mehrere Textzeilen (aka Hinweis) Spalten in Point vor mapping) umzuwandeln,

· ABACUS "Dezimal oder Integer Objekte zum Sharepoint Anzahl Spalten. (Anmerkung: Sharepoint Berechnete Spalten können verwendet werden, aber sie werden nur in der Lage sein, von Sharepoint zu ABACUS synchronisiert Der Versuch, zu synchronisieren" auf "einer berechneten Spalte wird mit einer Warnung nach unten zur Folge haben) .

· ABACUS "Listeneigenschaften auf Sharepoint Wahl Säulen,

· ABACUS "Date / Time Properties auf Sharepoint Mehrere Textzeilen (auch bekannt als Hinweis) Säulen (Hinweis: Sharepoint-Spalten Datum und Uhrzeit kann aufgrund von Sharepoint inkonsistente Unterstützung für Zeitzone / Regionaleinstellungen verwendet werden),

· ABACUS "Boolean Eigenschaften von Sharepoint Ja / Nein (aka Boolean) Spalten.

Eines ABACUS Element zugeordnet Standards können nicht auf Sharepoint-Liste Spalten noch abgebildet werden. Und Sharepoint Geld, Person oder Gruppe, Hyperlink oder Bild, Task-Ergebnis, externe Daten und verwalteten Metadatenspalten können nicht auf ABACUS Aspekte noch abgebildet werden.

8. Auswählen Erstellen Mapping.

Zu synchronisierenIhre Microsoft Sharepoint-Liste (n)in ABACUS

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Auswählen Tools | Sharepoint-Sync.

Notiz

Zu ein Sharepoint-Liste mit einem synchronisierenABACUS-Projekt der Benutzer-Lizenz muss der Sharepoint-SyncAdd-on-Fähigkeit. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

3. Wählen Sie eine vorhandene Sharepoint-Mapping (oder Zuordnungen mit Ctrl-Klick oder der Alle auswählenSchaltfläche) aus dem Sharepoint-MappingsTafelwie in der Probe Screenshot gezeigt über. Hinweis: Hier zeigen wir nur das 'Tor (oder Anforderung) "ABACUS Bauart Zuordnung zu einer Sharepoint-Liste genannten Ziele ausgewählt.

4. Wählen Sie die Architektur (en), die Sie synchronisieren Inhalte mit der wollen Sync Inhalt von ArchitekturenPlatte nach in der Probe Screenshot gezeigt über. Hinweis: Hier zeigen wir nur die "2015 Actual" Architektur wird synchronisiert.

5. Wähle aus Sync Von SP Taste.

Notiz

Wenn die Sharepoint-Website Anmeldeinformationen sind nicht "All Saved" für die Abbildung (en) dann gewählt, ein Login-Dialog erscheint, die von Sharepoint für die Seiten-URL, Benutzername und / oder Passwort.Bitte geben Sie diese. Darüber hinaus wird die Synchronisation sind alle anderen Zuordnungen, die für die angeschlossenen Komponenten / Nachschlagespalten erforderlich sind. Alle zusätzlichen Zuordnungen, die automatisch enthalten sind, werden im Dialog nach unten gezeigt werden.

6. Nach erfolgreicher Synchronisation einer Sharepoint-Sync-Dialog Die Ergebnisse werden wie unten die Auflistung der Änderungen und alle Warnungen angezeigt. Klicken OK.

Zu Synchronisieren von ABACUS auf Ihre Microsoft Sharepoint-Liste (n)

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Auswählen Tools | Sharepoint-Sync.

Notiz

Zu ein Sharepoint-Liste mit einem synchronisierenABACUS-Projekt der Benutzer-Lizenz muss der Sharepoint-SyncAdd-on-Fähigkeit. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

3. Wählen Sie eine vorhandene Sharepoint-Mapping (oder Zuordnungen mit Ctrl-Klick oder der Alle auswählenSchaltfläche) aus dem Sharepoint-MappingsTafelwie in der Probe Screenshot gezeigt über. Hinweis: Hier zeigen wir nur das 'Tor (oder Anforderung) "ABACUS Bauart Zuordnung zu einer Sharepoint-Liste genannten Ziele ausgewählt.

4. Wählen Sie die Architektur (en), die Sie synchronisieren Inhalte mit der wollen Sync Inhalt von ArchitekturenPlatte nach in der Probe Screenshot gezeigt über. Hinweis: Hier zeigen wir nur die "2015 Actual" Architektur wird synchronisiert.

5. Wähle aus Sync Um SP Taste.

Notiz

Wenn die Sharepoint-Website Anmeldeinformationen sind nicht "All Saved" für die Abbildung (en) dann gewählt, ein Login-Dialog erscheint, die von Sharepoint für die Seiten-URL, Benutzername und / oder Passwort.Bitte geben Sie diese. Darüber hinaus wird die Synchronisation sind alle anderen Zuordnungen, die für die angeschlossenen Komponenten / Nachschlagespalten erforderlich sind. Alle zusätzlichen Zuordnungen, die automatisch enthalten sind, werden im Dialog nach unten gezeigt werden.

6. Nach erfolgreicher Synchronisation einer Sharepoint-Sync-Dialog Die Ergebnisse werden wie unten die Auflistung der Änderungen und alle Warnungen angezeigt. Klicken OK.

Notiz

ABACUS wird Sharepoint-Spalten mit leeren Werten zu aktualisieren, selbst wenn 'erfordern, dass diese Spalte enthält Informationen' auf Ja in Sharepoint gesetzt. Das ist, weil Sharepoint nicht diese Einstellung von außen aussetzen. Wenn dies verhindert werden soll ist es empfehlenswert, eine ABACUS Designer setzt die Pflichtbeschränkung auf True und durchgesetzt werden für die gegebene Eigenschaft mit ABACUS ' Zwang Feature .

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Auffüllen der Architektur aus Visio | Auffüllen der Architektur aus Excel


Auffüllen der Architektur von Microsoft SQL Server

Navigation: Füllen Sie Ihre Architektur> Auffüllen von Microsoft-Produkten>

Auffüllen der Architektur von Microsoft SQL Server

Senden Sie Kommentare Zu diesem Thema.

Sie können Ihre Architektur aus einer Microsoft SQL Server-Datenbank zu importieren. Sie haben die Wahl, um nur die Tabellen und Beziehungen effektiv zu importieren nur die generische Struktur der Datenbank oder der Tabellen, Zeilen und Beziehungen, die nicht nur die Struktur, sondern die Daten als auch importieren wird importieren.

Notiz

Die Von SQL Server Funktion erfordert, dass Microsoft SQL Server 20052008, 2008 R2, 2012 oder 2014ist auf dem Computer installiert ist.

In ABACUS importieren Sie Ihre Microsoft SQL Server Datenbank

1. Stellen Sie sicher, Sie ABACUS geöffnet haben.

2. Wählen Sie Datei | Neu und wählen Sie Von SQL Serveraus dem angezeigten Dialogfeld und klicken Sie auf OK.

3. In der SQL Server-Import-Dialog, der die "MACHINE 'und' SQLINSTANCE 'Werte der Verbindungszeichengröße und der' DBNAME 'Wert der Datenbankname variable ihre richtigen Werte eingestellt wird als in der Probe Screenshot unten gezeigt.

4. Stellen Sie die Datenbank-Name-Variable auf den gleichen Wert wie die Initial Catalog Variable im Schritt oben ausgeführt, wie in dem Beispiel-Screenshot unten gezeigt.

5. Drücken Sie auf die Schaltfläche Verbindung testen und die Tische für den Import des Dialog sollte mit den verfügbaren Datenbanktabellen gefüllt werden, wie im Beispiel-Screenshot unten gezeigt.

6. Wählen Sie die Tabellen, die Sie importieren möchten, indem Sie sie auswählen entweder einzeln oder mit dem All, None und Invert-Tasten auf der rechten Seite des Dialogs.

Notiz

Nur die Fremdschlüsselbeziehungen zwischen den Tabellen, die Sie auswählen, wird importiert werden existieren.

7. Verwenden Sie das Optionsfeld Import-Art auswählen, ob Sie nur die Tabellen und die Beziehungen zwischen ihnen und den Tabellen, deren Zeilen und die besonderen Beziehungen zwischen den Zeilen importieren möchten.

Notiz

Die erste Option importiert die Tabellen als Komponenten des Typs "Tabelle" und die Beziehungen zwischen zwei Tabellen (aus den Fremdschlüsseln) werden als Verbindungen des Typs "Tabelle von Beziehungen 'importiert. Dies ist ein klassisches "ERD" Stil Blick auf die Systemtabellen. Die zweite Option importiert die Tabellenzeilen als diskrete Teilkomponenten des Typs 'Table Row "mit Eigenschaften entsprechend jeder der Spalten / Feldern und mit den Beziehungen zwischen den Tabellenzeilen vom Typ' Tabelle von Beziehungen '. Wenn darüber hinaus gibt es eine Spalte / Feld mit dem Namen 'Name' wird diese verwendet, um die einzelnen Tabellenzeile Teilkomponenten zu nennen.

8. Wählen Sie die Schaltfläche Importieren ....

9. Nach einer kurzen Zeitdauer (mit einem Fortschrittsbalken für die Rückführung) eine neue ABACUS Projekt wird mit den Tabellen erstellt werden, Tabellenzeilen (wenn die zweite Option wurde im obigen Schritt gewählt) und Beziehungen von der Microsoft SQL Server-Datenbank.

Sehe auch

Auffüllen der Architektur - Übersicht | Auffüllen der Architektur Hand | Auffüllen der Architektur aus Visio | Auffüllen der Architektur aus Excel


Hinzufügen voreingestellten Eigenschaften einer Komponente, Verbindung oder Typ

Navigation: Füllen Sie Ihre Architektur> Eigenschaften>

Hinzufügen voreingestellten Eigenschaften einer Komponente, Verbindung oder Typ

Senden Sie Kommentare Zu diesem Thema.

Standardbibliotheken von Eigenschaften können festgelegt und, etwas anderes in der Architektur zugeordnet werden. Diese Bibliotheken sind bekannt als Standards. Durch die Nutzung Standards, Müssen Sie nur auf bestimmte Systeme Eigenschaften zu sammeln - die Standard-Eigenschaften sind schon da.

Zum Beispiel die Standard-Leistungsmerkmale von Microsoft Windows 2000 kann als gerettet werden Standardund auf alle Komponenten zugeordnet (oder Verbindungen, nicht, dass das wäre typisch) mit dem Betriebssystem Microsoft Windows 2000.

Um eine hinzuzufügen Standardauf eine Komponente, Verbindung oder Typ

1. Rechtsklickauf dem Bauteil / Verbindung / Aktivität.

2. Auswählen Zuordnen Standard.

3. Auswählen ein Standardaus der Liste.

Sehe auch

Auffüllen der Architektur - Übersicht | Ändern der Eigenschaften einer Komponente, Verbindung oder Typ | Aggregate Eigenschaften


Ändern der Eigenschaften einer Komponente, Verbindung oder Typ

Navigation: Füllen Sie Ihre Architektur> Eigenschaften>

Ändern der Eigenschaften einer Komponente, Verbindung oder Typ

Senden Sie Kommentare Zu diesem Thema.

Eigenschaften sind in der Regel die Systemanforderungen, die Sie definieren, oder die Ergebnisse der ABACUS "Auswertungen. (Wenn ABACUS führt seine Auswertungen, schreibt es Eigenschaften zurück in die Datei.) Mit anderen Worten: Objekte sind die Dinge, die Sie über Ihr System, oder die Dinge, die Sie mit ABACUS, um herauszufinden.

Um den Wert der Eigenschaft einer Komponente, Anschluss oder Typ verändern

1. Klickenauf dem Bauteil / Verbindung / Aktivität (seine Eigenschaften werden im Eigenschaftenfenster auf der rechten Seite angezeigt werden).

2. Klickenum die Eigenschaft, die Sie ändern möchten.

3. Artein neuer Wert.

Wichtig

Auch sind viele Eigenschaften mit Hilfe definiert Standards . Durch die Änderung einer Eigenschaft in eine StandardSie nicht nur das aktuelle Objekt zu ändern, können Sie auch den Master ändern Standard (unter Standards beidie Spitze des Baumes). Bevor Sie dies tun, zu überprüfen, was andere Komponenten, Verbindungen oder Typen werden mit Hilfe der Standard, Da die Änderung möglicherweise nicht für sie relevant sein- Sie können die Referenzen-Fenster für diesen Einsatz.

Spitze

Sie können die Eigenschaften einer Verbindung von innerhalb der Components Zweig des Baumes (und umgekehrt) zu ändern. So, zum Beispiel, wenn man sich, welche Anschlüsse an einem Bauteil angebracht werden suchen, und Sie erkennen, müssen Sie eine zu ändern, Sie können.

Um neue Eigenschaften (über den Typ) zu einer Komponente oder Verbindung hinzufügen

Notiz

Objekte können nur auf Typen und Komponenten oder Verbindungen des Typs hinzugefügt werden 'erben' diese Eigenschaften.

1. Klickenvon der Art (seine Eigenschaften werden im Eigenschaftenfenster auf der rechten Seite angezeigt werden).

2. Klickenauf die Schaltfläche Hinzufügen am oberen Rand des Eigenschaftenfenster, um eine Zeile am Anfang des Eigenschaftenraster für die neue Eigenschaft hinzuzufügen.

3. Füge hinzu ein Artfür die neue Eigenschaft.

4. Füge hinzu ein Namefür die neue Eigenschaft.

5. Füge hinzu ein Standardwertfür die neue Eigenschaft.

6. Füge hinzu ein Einheitfür die neue Eigenschaft.

7. Stellen Sie die Dateitypfür die neue Eigenschaft.

Notiz

Das Feld Datentyp kann verwendet werden, um die gültigen Werte, die eine Eigenschaft haben kann, zu beschränken. Das ist; Text, Integer, Dezimal, Datum / Zeit, Boolean oder Liste.

o A TextEigentum ist eine, die eine unbegrenzte Anzahl von Zeichen hat und im Wesentlichen keine Beschränkungen für den Wert.Wenn der Wert der Eigenschaft ist ein ordnungsgemäß gebildet Hyperlink (dh URLs müssen mit einem der zu starten 5Zeichenfolgen; http: //, https: //, ftp: //, Datei:oder \\ und jedeRäume sollten mit einem "% 20" eingegeben werden), Dann ist der Link anklickbar (via Strg + Klick).

o Ein Ganze ZahlEigenschaft muss eine ganze Zahl sein entweder positiv oder negativund kann einen Punkt, Leerzeichen, Apostroph oder Komma für Zifferngruppierung in Abhängigkeit von der Project enthalten Region-Einstellungen von Datei | Projektoptionen.Die Region und die Einstellungen.Netz Long.TryParse Verfahren ist zur Bestimmung gültiger Ganze Zahl Werte.

o A DezimalImmobilie kann eine enthalten Punkt oder Komma für das Dezimal-Symbol und können einen Punkt, Leerzeichen, Apostroph oder Komma für Zifferngruppierung in Abhängigkeit von der Project enthalten Region-Einstellungen von Datei | Projektoptionen.Die Region und die Einstellungen.Netz Decimal.TryParse Verfahren ist zur Bestimmung gültiger Dezimal Werte.

o A TerminzeitEigenschaft ermöglicht es entweder einen Datumsteil oder ein Zeitteil oder beides. Die RegionEinstellungenund das .Net DateTime.TryParse Verfahren werden in erster Linie verwendet, um gültige Datum und / oder Zeitwerte zu bestimmen. Doch die seit Teil ggf. erfordert zumindest der Tag und Monat (das Jahr wird angenommen, um das aktuelle Jahr sein) oder Monat und Jahr Teile gültig zu sein. D.h. Juni Q3 2010 oder auch nur 2010 sind ungültig. Oder Schrägstrich ('/') - Während es mit verschiedenen regionalen Einstellungen unterschiedlich, in der Regel können Sie den Tag, Monat und Jahr Teile mit einem Leerzeichen, Komma, Strich ('') getrennt werden. Der Tag Teil in der Regel eine ganze Zahl von 1 bis 31. Der Monat Teil ist in der Regel eine ganze Zahl von 1 bis 12, ein gültiges 3 Buchstaben bestehende Abkürzung für die Monate (zB Jan, Feb, Mar) oder der volle Name des Monats (zB Januar, Februar , März). Das Jahr Teil ist in der Regel eine 4-stellige positive Zahl, aber 1, 2 und 3-stellige Jahre sind nach den Einstellungen im Systemsteuerung-> Regions- und Sprach Optionen-> Regionale Optionen-> Individuell anpassen (Taste) angenommen -> Date-> Kalender. In der Regel werden sie wie folgt zu interpretieren; 0-29 als 2000 bis 2029 um 99, wie von 1930 bis 1999 und von 100 bis 999, wie 100 bis 999 interpretiert, 30. Ungültige Daten wie 31. Juni 2010 und 31/9/2010 werden erkannt. Der Zeitteil falls erfordert eine Stunden und Minuten Teil und gegebenenfalls einen Teil Sekunden. Die Stunden, Minuten und Sekunden optional Teile werden in der Regel mit einem Doppelpunkt getrennt (':') und die Sekunden Teil kann mit einer Dezimalstelle angegeben werden ('.'). Für weitere Informationen über die gültigen Formate finden Sie im Abschnitt Bemerkungen zur .Net beziehen DateTime.TryParse Verfahren .

Spitze

Es wird empfohlen, mindestens die 3 Buchstaben Monatsname-Format für Datumswerte und nicht numerische Formatierungen (dh "7" oder "07"), wie diese Werte werden über die meisten Regionen je Validierung nutzen (dh "Juli" oder "Juli") auf der Project Region-Einstellungen von Datei | Projektoptionen.D.h. Es wird empfohlen, "15. Juli 2010" statt "15/7/2010" oder "2010.07.15" zu verwenden. Mit diesem Beispiel "15/7/2010" würde Validierung für fail "Englisch (USA)" und "2010.07.15" würde für 'English (United Kingdom) "allerdings" 15. Juli 2010 "scheitern würde passieren beide.

o A BooleanEigenschaft kann entweder wahr oder falsch sein.Es ist Groß- und Kleinschreibung, so WAHR oder FALSCH kann aber auch verwendet werden, ja, nein, 1, 0 usw. werden alle scheitern keine Eigenschaft Constraints werden.

o A ListeEigenschaft ermöglicht eine Sammlung von vordefinierten Werten wie Low | Medium | Hohe oder Bewahren | Aktualisieren | Redesign | Zurückziehen und der Wertebereich stammt aus dem Feld Einheit für die Eigenschaft entweder als Komma oder Rohr '|' getrennte Werte. Die Eigenschaft kann Gilt als Ordinal- (im Gegensatz zu nominal, Intervall oder Verhältnis), weil, wenn auf Karten verwendet und Elemente auf Farbe Diagramms und 3ds die Werte nur in aufsteigender (oder absteigender) Reihenfolge behandelt. Das ist Werte werden in aufsteigender (oder absteigender) Reihenfolge auf den Diagrammachsen oder Farbbereiche aufgetragen.

8. Der Datentyp kann so eingestellt werden kann Behindert, Gewarnt oder Gesetztdurch Rechtsklick auf die Datentyp-Feld zu einem anderen als Text, der alle Zeichen so kann nicht immer falsch sein, ermöglicht die Einstellung.

9. Stellen Sie die ErforderlichFlag für die neue Eigenschaft.

Notiz

Das Pflichtfeld kann verwendet werden, um anzuzeigen, ob ein Wert für die Eigenschaft eingegeben werden muss werden. Das heißt, daß sie nicht leer ist oder leer sein. Falschist die Standardeinstellung und bedeutet die Eigenschaft kann leer oder leer sein, Wahrbedeutet, dass die Eigenschaft sollte einen Wert haben und darf nicht leer oder leer sein. Die benötigte kann so eingestellt werden kann Behindert, Gewarnt oder Gesetztdurch Rechtsklick auf das Feld Erforderliche, wenn es auf True gesetzt ist.

Sehe auch

Auffüllen der Architektur - Übersicht | Hinzufügen voreingestellten Eigenschaften einer Komponente, Verbindung oder Typ | Aggregate Eigenschaften


Ändern Region Einstellungen eines Projekts

Navigation: Füllen Sie Ihre Architektur> Eigenschaften>

Ändern Region Einstellungen eines Projekts

Senden Sie Kommentare Zu diesem Thema.

Eigenschaftenwerte erfordern bestimmte Formatierungen in verschiedenen Regionen zu einem passen Datentyp Einschränkungen für Integer, Dezimal und Datum / Uhrzeit Eigenschaften. Zum Beispiel in Australien die Dezimalzahl "123.456 Punkt sieben acht neun" als "123,456.789" dargestellt, während in Deutschland würde es als "123.456,789" represnted und in Frankreich, es wäre " 123 456789 ".Auch in den USA die "zweite von Dezember 1970" als Kurzreisedatum nach "1970.12.02", aber in Großbritannien wird es als "1970.02.12" und in Polen als "1970-1912 vertreten -02 ". Dementsprechend ist, um mit einer Rechenmaschine Projekt in den Regionen eine globale Einstellung pro ABACUS Projekts erforderlich zu arbeiten.

Wechseln Region Einstellungen eines ABACUS Projekt

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Auswählen Datei | Projekt Optionen ... und aus dem angezeigten Dialogfenster wähle aus Region und klicken Sie auf OK. Hinweis: Bitte beachten Sie die unten für die regionalen Standardeinstellungen Abschnitt.

Notiz

Wenn Sie nicht sehen, das Projekt Optionen ... Menüpunktdann müssen Sie nicht den Designer und Administrator Erweiterungs und Sie Region des Projekts nicht ändern.Auch, wenn keine Region eingestellt ist (dh die Region im Projekt Optionen ist "None (System Region) ') dann jeweils MS Windows aktuellen Kultureinstellungen des Benutzers (dh Ländereinstellungen)werden verwendet, um die Eigenschaften zu validieren.

Region Standardwerte

Die folgende Tabelle listet die Standardwerte für die einzelnen Regionen, wie durch den Satz Datei | Projekt Optionen ...Menüpunkt.Bitte siehe unten für eine Liste der verwendeten Symbole.

Region | Dezimalzeichen | Zifferngruppierung | Negatives Vorzeichen | Kurze Zeit | Lange Zeit | AM / PM-Symbol | Short Date | Langes Datum
Englisch (Australien) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / JJJJ | dd MMMM yyyy
Englisches Vereinigtes Königreich) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / JJJJ | dd MMMM yyyy
Englisch Vereinigte Staaten) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / yyyy | dddd, MMMM dd, yyyy
Französisch (Frankreich) | , | Raum | - | HH: mm | HH: mm: ss | | | dd / MM / JJJJ | dddd d MMMM yyyy
Deutsch (Deutschland) | , | . | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM yyyy
Italian (Italy) | , | . | - | HH: mm | HH: mm: ss | | | dd / MM / JJJJ | dddd d MMMM yyyy
Spanisch (Spanien) | , | . | - | H: mm | H: mm: ss | | | dd / MM / JJJJ | dddd, dd 'de' MMMM 'de' yyyy
Englisch (Kanada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / MM / JJJJ | MMMM-dd-yy
Französisch (Canada) | , | Raum | - | HH: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM yyyy
Arabisch (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | Õ | م | dd / MM / JJJJ | dd MMMM yyyy
Arabisch (Saudi-Arabien) | . | , | - | hh: mm tt | hh: mm: ss tt | Õ | م | dd / MM / yy | dd / MMMM / JJJJ
Englisch (Südafrika) | , | Raum | - | hh: mm tt | hh: mm: ss tt | AM | PM | yyyy / / TT MM | dd MMMM yyyy
Englisch (Neuseeland) | . | , | - | h: mm tt | h: mm: ss tt | a.m. | p.m. | d / MM / JJJJ | dddd, d MMMM yyyy
Englisch (Indien) | . | , | - | HH: mm | HH: mm: ss | AM | PM | TT-MM-JJJJ | dd MMMM yyyy
Deutsch (Schweiz) | . | ' | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM yyyy
Französisch (Belgien) | , | . | - | HH: mm | HH: mm: ss | | | d / MM / JJJJ | dddd d MMMM yyyy
Niederländisch (Belgien) | , | . | - | H: mm | H: mm: ss | | | d / MM / JJJJ | dddd d MMMM yyyy
Tschechisch (Tschechische Republik) | , | Raum | - | H: mm | H: mm: ss | dop |. odp. | d.M.yyyy | d. MMMM yyyy
Dänisch (Dänemark) | , | . | - | HH: mm | HH: mm: ss | | | TT-MM-JJJJ | d. MMMM yyyy
Griechisch (Griechenland) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / JJJJ | dddd, d MMMM yyyy
Finnisch (Finnland) | , | Raum | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'yyyy
Ungarisch (Ungarn) | , | Raum | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | yyyy. MMMM d.
Niederländisch (Niederlande) | , | . | - | H: mm | H: mm: ss | | | d-M-yyyy | dddd d MMMM yyyy
Norwegisch, Bokmål (Norwegen) | , | Raum | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | d. MMMM yyyy
Polish (Poland) | , | Raum | - | HH: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM yyyy
Russisch (Russland) | , | Raum | - | H: mm | H: mm: ss | | | dd.MM.yyyy | d MMMM yyyy "г. '
Schwedisch (Schweden) | , | Raum | - | HH: mm | HH: mm: ss | | | yyyy-MM-dd | Grube 'D MMMM yyyy
Koreanisch (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | yyyy-MM-dd | yyyy '년' M '월' d '일' dddd
Hebräisch (Israel) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / JJJJ | dddd dd MMMM yyyy

Folgende Symbole werden verwendet, um anzugeben, wie Datums- und Zeitangaben werden angezeigt:

Zeit Ticker |
h | Stunde (hh Zeigt die Stunde mit führender Null)
m | Minute (mm Zeigt die Minute mit führender Null)
s | Sekunde (ss zeigt die Sekunde mit führender Null)
tt | A. M. oder P. M.
h / H | 12 oder 24 Stunden-Zeitanzeige
Datum Symbole |
d, dd | Tag
ddd, dddd | Tag der Woche
M | Monat
y | Jahr

Sehe auch

Auffüllen der Architektur - Übersicht | Ändern der Eigenschaften einer Komponente, Verbindung oder Typ | Hinzufügen voreingestellten Eigenschaften einer Komponente, Verbindung oder Typ


Aggregate Eigenschaften

Navigation: Füllen Sie Ihre Architektur> Eigenschaften>

Aggregate Eigenschaften

Senden Sie Kommentare Zu diesem Thema.

Die Operation "Aggregat Immobilien"Ermöglicht es Ihnen, Werte für ähnliche Objekte zusammen das Ergebnis in den Eigenschaften des ausgewählten übergeordneten Element hinzuzufügen und zu schreiben (oder hinzufügen). Es erlaubt Ihnen auch, den Umfang der Aggregation zu definieren und ob die Eigenschaften aller Unterelemente oder nicht aktualisieren.

Um Aggregateigenschaften

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Rechts-Klick auf ein Element (eine Architektur, eine Komponente oder eine Verbindung), in der die Aggregation zu tun, und wählen Sie Aggregate Immobilien.

3. Wählen Sie eines der Aggregate-Optionen (Traverse alle Unterebenen oder Nur Direct Sub-Level-). Wenn Sie gewählt haben, Traverse alle UnterebenenSie können auch wählen Sie die Option, ob Update Unterebenen.

o Traverse alle Unterebenenbedeutet, dass der Umfang der Aggregation der Elemente in allen Ebenen unter dem gewünschten Element enthalten.

o Update Unterebenenist nur möglich, wenn Sie haben auch die Möglichkeit gewählt werden Traverse alle Unterebenen. Dies bedeutet, dass, während Sie von unten nach oben zu aggregieren Eigenschaften, die aggregierte Ergebnis auf allen Ebenen wird auch in jede der entsprechenden Elemente aktualisiert werden.

o Nur Direct Sub-Level-bedeutet, daß nur die Eigenschaften der Elemente, die direkt unterhalb der gewählten Element aggregiert werden.

o Auswählen Einschließen StandardImmobilienwenn man die in den definierten Eigenschaften möchten Standards einzubeziehen. Ansonsten wird nur die Eigenschaften eindeutig für jede Komponenteninstanz verwendet werden.

4. Wählen Sie, welche Eigenschaften Sie aggregieren möchten. Sie sind gruppiert nach ihrer Typen.

5. Drücke den Nächster Taste.

6. Wählen Sie die Option, ob Überschreiben Werte oder Fügen Sie Wertein das ausgewählte Element.

o Überschreiben Wertewerden die Ergebnisse direkt in den Eigenschaften des gewählten Elements zu schreiben.

o Fügen Sie Wertewird die Ergebnisse zu den bestehenden Eigenschaften des gewählten Elements hinzuzufügen.

Sehe auch

Hinzufügen voreingestellten Eigenschaften einer Komponente, Verbindung oder Typ | Ändern der Eigenschaften einer Komponente, Verbindung oder Typ | Bewertung Ihrer Architektur


Analyse Ihrer Architektur

Navigation: Analysieren Sie Ihre Architektur>

Analyse Ihrer Architektur

Senden Sie Kommentare Zu diesem Thema.

Sobald Sie bevölkert haben (und wahlweise simuliert) Ihre Architektur, sind Sie bereit, ABACUS verwenden, um sie zu analysieren. Durch die Analyse ist, können Sie feststellen, ob Ihre Architektur wird Ihren Bedürfnissen entsprechen.

Sie können Ihre Architektur in einer Vielzahl von verschiedenen Möglichkeiten zu analysieren:

· Diagramm

· 3D- Aussicht

· Standard-Charts (Kreis-, Linien-, Säulen-, Balken-, etc.)

· benutzerdefinierte Diagramme ( Reaktionszeit , Fähigkeit Raum , star Grundstück , Streudiagramm-Matrix und Blasendiagramm )

· Architektur Diff

Notiz

Beim Erstellen eines Diagramms 3D Aussicht, Bericht oder eine Standardkarte, die Standard-Element-Auswahlfenster wird verwendet, um Elemente, die Sie anzeigen möchten.

Sehe auch

Auffüllen der Architektur | Simulation von Ihrer Architektur | das Diagrammerstellung Werkzeug


Standard-Elementauswahl

Navigation: Analysieren Sie Ihre Architektur>

Standard-Elementauswahl

Senden Sie Kommentare Zu diesem Thema.

Beim Erstellen eines Diagramms 3D Aussicht, Bericht,Standardgrafikoder eine Simulation, Die Standard-Elementauswahl-Fenster wird verwendet, um Elemente, die Sie / view analysieren möchten.

Standard-Elementauswahl Fenster

Pulldowns

· Filter nach Ansicht werden einschließen das Elements aus einem zuvor gespeicherten Ansichts (dh Diagram, Schaubild, 3D). Auf diese Weise durchführen können komplexe "nachziehen" Abfragen durch die Behandlung eine andere Ansicht als gerettet 'query'.

Checkboxen

· Zeige Levelsdie Gruppe das Element nach der Höhe, mit denen sie in der Struktur auftritt. Stufe 1 ist die oberste Ebene.

· Typen anzeigengruppiert die Elemente entsprechend den Typen, die sie sind.

· Eltern von ausgewähltenwerden die übergeordneten Elemente jeder ausgewählten Elemente enthalten. Auf diese Weise können Sie sicherstellen, dass nur die Hierarchie über allen Kindern wird für einen "bottom-up" Auswahl aufgenommen werden.

· Kinder von ausgewähltengehören die Kinder Elemente jeder ausgewählten Elemente. Auf diese Weise können Sie sicherstellen, dass nur die Hierarchie unter allen Eltern für einen "top-down" Selektion aufgenommen werden.

· Namen Spiele Wertwerden nur die Elemente, die einen Namen mit dem angegebenen String haben, gehören (Bitte beachten Sie: Wildcards (dh und *) können verwendet werden?). Auf diese Weise können Sie eine "semantische" Abfrage zu bilden.

· Hat Immobilientyp / Name / Wertwerden nur die Elemente, die eine Art der Immobilie, Name und Wert mit dem angegebenen String entweder direkt auf dem Element oder auf seiner Standards haben, gehören (Bitte beachten Sie:?.? im Feld Wert Wildcards (dh und *) können verwendet werden, zB * werden geben Sie alle Elemente, die einen nicht leeren Wert für die gegebene Eigenschaft haben). Auf diese Weise können Sie eine "semantische" Abfrage zu bilden.

· Verfügt über Standard-werden nur die Elemente, die einen Standard-Namen mit dem angegebenen String haben, gehören (Bitte beachten Sie: Wildcards (dh und *) können verwendet werden, zB HP * werden alle Elemente mit mindestens einer Norm mit den Buchstaben H und P geben?.). Auf diese Weise können Sie eine "semantische" Abfrage zu bilden.

· Komponenten / Verbindungen zu ausgewählten befestigtwerden alle angeschlossenen Elemente wie diejenigen, die ausgewählt wurden, umfassen. Auf diese Weise wird eine "Call-Baum" oder "Einfluss-Analyse" kann ausgewählt werden.

Notiz

Wenn Sie beide haben Zeige Levels und Typen anzeigengewählt, dann können Sie wählen, um die Baum Show Ebenen ersten oder Typen zuerst von der Taste, die über die beiden Kontrollkästchen angezeigt wird.

Spitze

Sobald ein Element in der Standard-Elementauswahl Fenster ausgewählt ist, wird es nicht vorbehaltlich weiterer Filterwechsel, bis es deaktiviert wird. Da gibt es keine native Möglichkeit, für zwei verschiedene Gruppen von Elementen auf einmal zu suchen (zB Komponenten mit Standard A OR Standard B), können Sie zunächst für einen Satz zu suchen, wählen Sie die gewünschten Komponenten, und führen Sie dann eine zweite Suche nach dem zweiten Satz .

Buttons

· Allewählt alle Elemente.

· Umkehrendeselektiert alle aktuell ausgewählten Elemente und wählt alle diejenigen, die nicht ausgewählt wurden.

· Keinedeselektiert alle Elemente.

· Filter hinzufügenwählt den resultierenden Inhalt der aktuellen Filtereinstellungen und ermöglicht die Auswahl von zusätzlichen Inhalten wie effektiv eine UND oder Verknüpfungsfilter.

Sehe auch

Analyse Ihrer Architektur


Anzeigen eines 3D-Diagramm

Navigation: Analysieren Sie Ihre Architektur> 3D-Diagramme>

Anzeigen eines 3D-Diagramm

Senden Sie Kommentare Zu diesem Thema.

ABACUS ermöglicht Ihnen, Ihre Architektur als 3D-Ansicht in dem Bauteil und Verbindungseigenschaften sind mit Farben, Formen und Größen verknüpft sind.

Um eine 3D-Ansicht Ihrer Architektur zu sehen

1. Vergewissern Sie sich, öffnen Sie die ABACUS-Dateimit Ihrer besiedelte Architektur.

2. Erweitern Sie den AnsichtenZweig des Baumes.

3. Erweitern Sie den 3D-Zweig des Baumes.

4. Doppelklick die Visualisierung Sie öffnen möchten.

- oder -

1. Vergewissern Sie sich, öffnen Sie die ABACUS-Dateimit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| 3D-oder klicken Sie auf die Schaltfläche in der Symbolleiste.

3. Öffnen Sie ein bestehendenVisualisierung (.abacus3d)

- oder -

1. Vergewissern Sie sich, öffnen Sie die ABACUS-Dateimit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| 3D-oder klicken Sie auf die Schaltfläche in der Symbolleiste.

3. Erstellen Sie eine neue Visualisierung:

· Wähle aus ArchitekturSie aus dem Pull-Down-Menü angezeigt werden sollen.

· Wähle aus Components und AnschlüsseSie im Diagramm von der aufgenommen werden sollen Standard-Element-Auswahlfenster .

· Associate Farben, Formen und Größen mit Komponententypen und Immobilien.

· Associate Farben und Formen mit Verbindungstypen und Immobilien.

Um eine 3D-Ansicht exportieren

1. Vergewissern Sie sich, öffnen Sie eine vorhandene 3D-Ansicht.

2. Im Pulldown-Menüs der 3D-Ansicht zu wählen Datei | Export...und wählte den Standort und den Dateityp für die Visualisierungsdatei (.abacus3d, .vrml oder .html).

3. Klicken sparen.

Sehe auch

Analyse Ihrer Architektur | Navigation in 3D | Die Diagramming Tool


Navigation in einer 3D-Diagramm

Navigation: Analysieren Sie Ihre Architektur> 3D-Diagramme>

Navigation in einer 3D-Diagramm

Senden Sie Kommentare Zu diesem Thema.

ABACUS können Sie ganz einfach durch Ihre Architektur in 3D zu navigieren. Die Erfahrung ist ähnlich zu fliegen. Es gibt zwei Modi der Navigation:

· Basic Control Modus (Standard); und

· Advanced Control Modus - Wechsel in diesen Modus, indem Sie Steuern| Erweiterte Control Mode.

Notiz

Um zwischen Basic Control und Advanced Control Modi wechseln, können Sie die Verwendung F4Tastenkombination Funktionalität.

Basic-Control Mode

· Halten Sie die linke Taste gedrückt und bewegen Sie die Maus verändert die Tonhöhe nach vorne oder hinten;

· Halten Sie die linke Taste gedrückt und bewegen Sie die Maus nach links oder rechts verändert die Gier;

· Halten Sie die rechte Maustaste und Bewegen der Maus Pfannen den Blick;

· Halten Sie beide Tasten gedrückt und bewegen Sie die Maus nach vorne oder hinten, zoomt in die und aus der Architektur; und

· Halten Sie beide Tasten gedrückt und bewegen Sie die Maus nach links oder rechts, rollt links und rechts.

- oder -

· Durch Drücken der Taste Linker Pfeilauf der Tastatur oder Zehnertastatur wird links abbiegen;

· Durch Drücken der Taste Rechter Pfeilauf der Tastatur oder Zehnertastatur wird rechts abbiegen;

· Durch Drücken der Taste Aufwärtspfeilauf der Tastatur oder Zehnertastatur vergrößern;

· Durch Drücken der Taste Untere Pfeiltasteauf der Tastatur oder Ziffernblock verkleinert;

· Drücken Page Upauf der Tastatur oder Zehnertastatur wird pitch up; und

· Drücken Page Downauf der Tastatur oder Zehnertastatur wird die Tonhöhe nach unten.

Erweiterte Control Mode

· In Bewegungdie Maus vor und zurück und nach oben und unten, ändert die Nick- und Gier (jeweils);

· Drücken W oder Aufwärtspfeilzoomt (vorwärts) in die Architektur;

· Drücken S oder Untere Pfeiltastezoomt (rückwärts) von der Architektur;

· Drücken A oder Linker PfeilWalzen nach links;

· Drücken D oder Rechter Pfeilrollt nach rechts;

· Drücken Q oder Page Downhebt die Ansicht (durch eine Senkung der Perspektive); und

· Drücken E oder Page Upsenkt die Ansicht (durch Erhöhung der Vorausschau).

Interactive Control Mode

Durch Drücken und Halten der shift Tasteauf der Tastatur überschreibt den aktuellen Modus (Standard oder Erweitert) um die interaktive Steuermodus zu gelangen. In diesem Modus ist die folgende möglich:

· Rollender Mauszeiger über einer Komponente oder Verbindung, um die Komponente oder Name Zusammenhang sehen;

· Klickenauf eine Komponente auf, daß die Komponente vergrößern;

· Klicken und Ziehenauf eine Komponente, um die Ansicht um diese Komponente zu drehen; und

· Rechtsklickeine Komponente oder Verbindung und wählen Sie Im Explorer anzeigen, dass die Komponente oder Standort-Verbindung in der Baumstruktur angezeigt.

Gemeinsame Kontrollen

· Benutzen ALT-ENTER / ESCIn den Vollbildmodus umschalten;

· Benutzen F2um den Anzeigemodus zu ändern. Dies kann auch in die zugegriffen werden Aussicht Menü.

· Verwenden Sie die Mausrad oder +/-um die Geschwindigkeit zu ändern. Die Geschwindigkeit wird durch eine Zahl in der unteren linken Ecke angezeigt - nur angezeigt, wenn es sich verändert. 1 am langsamsten und 100 ist am schnellsten.


Anzeigen einer Standardgrafik

Navigation: Analyse Ihrer Architektur> Standard-Charts>

Anzeigen einer Standardgrafik

Senden Sie Kommentare Zu diesem Thema.

ABACUS "Standard Diagramme enthalten Linie, Balken-, Säulen-, Gegend, Streuung, pie, Kurve, Pareto, Schritt, Oberfläche, Radar, Würfel, Donut, Pyramide, Kontur und Kurvenflächendiagramme. Sobald Sie den Diagrammtyp Sie ausgewählt haben, ist der Rest des Prozesses für die Anzeige von jedem dieser Diagramme die gleiche.

Um eine Standardgrafik Ihrer Architektur zu sehen

1. Vergewissern Sie sich, öffnen Sie die ABACUS-Dateimit Ihrer besiedelte Architektur, Und dass Sie bewertetIhre Architektur.

2. Auswählen Einfügen| Diagrammoder klicken Sie auf die Schaltfläche in der Symbolleiste. das ChartsFenster wird angezeigt.

Charts-Fenster

3. Wählen Sie den Typ der Tabelle können Sie wollen, und legen Sie die Diagrammoptionen, klicken Sie dann auf Nächster.

Diagrammoptionen

o Gestapeltewird die Beziehung der einzelnen Positionen, um die ganze Show. Sie können eine Stapeldiagramm verwenden, wenn Sie planen, um mehrere Datenreihen (dh mehrere Eigenschaften) und haben, wenn Sie die Gesamt betonen wollen.

o Gestapelt 100%den Prozentsatz jeder Wert trägt zu einer Summe über Kategorien zu vergleichen. Sie können eine 100% gestapelten Diagramm verwenden, wenn Sie planen, um mehrere Datenreihen (dh mehrere Eigenschaften), und Sie, die Beiträge auf die gesamte zu unterstreichen, vor allem, wenn die Gesamt ist das gleiche für jedes Element möchten.

o 3D-Diagrammwird einfach die Datenpunkte in 3-D-Format anzeigen für Ästhetik. Wenn Sie die Datenreihe entlang einer dritten / z-Achsen-Dimension anzeigen möchten, dann verwenden Sie die Option Cluster Series unten beschrieben.

o Serie von Immobilienwird eine Datenreihe für jede Eigenschaft, die letztlich ausgewählt wird angezeigt. Wenn dieser nicht aktiviert ist, dann werden die Eigenschaften der Kategorien zu werden und die Datenreihe für jedes Element, das ausgewählt wird.

o Drehen Tabellewird das Diagramm um 90 Grad drehen durch Vertauschen der x und y-Achse im Uhrzeigersinn. Diese Option ist nur für die Linien, Schritt und Cube-Charts verfügbarund ist besonders nützlich für die Herstellung Milestone Diagramme wie in der zweiten Spitze unterhalb beschrieben. Hinweis: Spalte und Balkendiagramme sind bereits 'gedreht' Versionen von einander.

o Cluster Serieswerden mehrere Reihendaten entlang einer dritten / z-Achsen-Dimension angezeigt. Diese Option für die Spalte ist nur verfügbar, Bar und Cube-Chartsund ist besonders nützlich für die Herstellung von Gantt-Diagramme Stil wie in der ersten Tipp unten beschrieben.

Spitze

Sie können eine zu erstellen Gantt-Chartmit horizontalen Balken, die Zeit / Datum-Eigenschaften für verschiedene Elemente, indem Sie eine Bar Diagrammtyp auswählen und dann die Option Cluster Series.Darüber hinaus einmal erstellt, kann das am weitesten links stehende Balken im Diagramm "unsichtbar" durch Einfärben es weiß durch Rechtsklick auf einer der Bars, die Auswahl Farbe aus dem Menü, das angezeigt wird und die Wahl der oberen linken Farbe aus der Palette vorgenommen werden. Zusätzlich wird die Grenze für den am weitesten links Leiste kann "unsichtbar" gemacht werden durch Rechtsklick auf eine der Bars, wählen Sie Eigenschaften ... und auf der Registerkarte Reihe im angezeigten Dialogfeld die Änderung der Grenzeffekt auf None und Farbe an die Spitze -links Farbe aus der Palette.

Spitze

Sie können eine zu erstellen Milestone-Chartmit kleinen Formen, die Zeit / Datum-Eigenschaften für verschiedene Elemente, indem Sie einen Cube Diagrammtyp und dann den Drehen-Diagramm und Optionen Cluster Series.Darüber hinaus einmal erstellt, die Würfel können in andere Formen, die durch einen Rechtsklick auf einen der Würfel in einer bestimmten Datenreihen und wählen Sie Eigenschaften ... und auf der Registerkarte Reihe im angezeigten Dialogfenster Ändern der Bar entweder Zylinder oder Kegel geändert werden . Hinweis: Die Spaltweite Wert kann auch zu "schrumpfen" die Symbole auf dem Diagramm verwendeten überlappenden, um zu reduzieren, je höher die Zahl, desto weniger überlappe wird es geben.

4. im ArchitekturenAbschnitt, aktivieren Sie die Architektur / s Sie die Architekturebene Eigenschaften Diagramm als, klicken Sie dann auf möchten Nächster.

Notiz

Auswählen Architekturebene Eigenschaften ist eine völlig optionaler Schritt und sollte nur verwendet werden, wenn Sie die Eigenschaften selbst Architekturebene explizit Diagramm erstellen möchten.Eine Architektur muss nicht ausgewählt werden, dann gehören Komponenten oder Verbindungseigenschaften im nächsten Schritt.

5. Wähle aus Components und Anschlüssedass Sie in der Tabelle aus der willst Standard-Element-Auswahlfenster , Klicken Sie dann auf Nächster.

6. Wähle aus ImmobilienSie in der Tabelle und klicken Sie auf Fertig.

Diagrammoptionen

o Gehören Standard-Eigenschaften werden zeigen die vererbten Eigenschaften von den zur Auswahl stehenden Standards.

o Aggregate Immobilien werden zählen die Varianz zwischen den Reihenwerten und Diagramm diese Ergebnisse im Gegensatz zu den Einzelwerten selbst.Diese Option ist nur verfügbar, wenn die Serie von Immobilien-Option wurde in Schritt 3 ausgewählt.

Spitze

Die für Charting verfügbaren Eigenschaften hängen von den Elementen, die Sie auswählen.

Um ein Diagramm zu speichern

Notiz

Charts können nur gespeichert werden, wenn sie Komponenten und Verbindungen, von denen alle müssen aus einer einzigen Architektur im aktuellen Projekt enthalten nur.

1. Stellen Sie sicher, dass Sie ein neues oder vorhandenes Diagramm haben öffnenund Sie die notwendigen Änderungen vorgenommen haben.

2. In der Karten-Werkzeugleiste klicken Sie auf die am weitesten links Save-DiagrammTaste, um das Diagramm und alle Formatierungsänderungen zu speichern.

3. im DiagrammnameDialogfeld, geben Sie einen Namen für das Diagramm und drücken erscheint OK.

Um ein Diagramm zu exportieren

1. Stellen Sie sicher, Sie haben ein vorhandenes Diagramm öffnen.

2. In der Symbolleiste auf Diagramm auf der 2. von links Speichern als BMPTaste und wählen Sie den Speicherort für das Diagramm.

3. Klicken sparen.

Sehe auch

Analyse Ihrer Architektur | Anzeigen einer Antwortzeitdiagramm | Anzeigen einer Fähigkeit Raum Chart


Anzeigen einer Fähigkeit Raum Chart

Navigation: Analysieren Sie Ihre Architektur> Benutzerdefinierte Diagramme>

Anzeigen einer Fähigkeit Raum Chart

Senden Sie Kommentare Zu diesem Thema.

Eine Capability Raum Chart ermöglicht es Ihnen, zu sehen, ob Ihre Architektur erfüllt die erforderlichen Systemfähigkeit in Bezug auf Eigenschaften während des Systemanforderungsanalyse Prozess identifiziert.

Um eine Fähigkeit Raum anzusehen

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur, Und dass Sie bewertetIhre Architektur.

2. Auswählen Einfügen| Diagramm| Individuelle Charts| Capability Raum. (Das Capability Raumtabelle KonfigDialog wird angezeigt.)

3. im ArchitekturenAbschnitt Zutreffendes Architekturen Sie Diagramm möchten, klicken Sie dann auf Nächster.

4. im ImmobilienBereich, kreuzen Sie die architektonischen Eigenschaften, die Sie würde als die Achsen des Diagramms enthalten mag.

5. im FähigkeitBereich, für jede Eigenschaft aus dem vorherigen Schritt enthalten ist, wählen Sie, ob ein Minimum oder Maximum-Fähigkeit Grenzen existieren und die Werte dieser Grenzen. Die Standardwerte sind die für die Architekturen oder ausgewertet Minimal- und Maximalwerte Ziel für die Eigenschaft wenn festgestellt wurde eingestellt.

Um eine Fähigkeit Raumdiagramm exportieren

1. Stellen Sie sicher, Sie haben ein vorhandenes Fähigkeit Raum Chart öffnen.

2. In der Karten-Werkzeugleiste klicken Sie auf die am weitesten links Speichern als BMPTaste und wählen Sie den Speicherort für das Diagramm.

3. Klicken sparen.

Sehe auch

Analyse Ihrer Architektur | Anzeigen einer Antwortzeitdiagramm


Anzeigen einer Antwortzeitdiagramm

Navigation: Analysieren Sie Ihre Architektur> Benutzerdefinierte Diagramme>

Anzeigen einer Antwortzeitdiagramm

Senden Sie Kommentare Zu diesem Thema.

Eine Reaktionszeit Chart ermöglicht es Ihnen, zu sehen, ob Ihre Verbindungen werden mit der erforderlichen Rate (dh innerhalb ihrer Frist) verarbeitet.

Um eine Reaktionszeit anzusehen

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur, Und dass Sie bewertetIhre Architektur.

2. Auswählen Einfügen| Diagramm| Individuelle Charts| Reaktionszeit. (Das Reaktionszeit Tabelle KonfigDialog wird angezeigt.)

3. Von dem ArchitekturenDropdown-Liste, wählen Sie die Architektur Sie ein Diagramm erstellen möchten.

4. im AnschlüsseBereich, kreuzen Sie die Verbindungen, die Sie würde in der Tabelle enthalten mag.

5. das SkalentypWählen Sie im Bereich Linearwenn Sie die vertikale Achse (Reaktionszeit) als lineare Progression angezeigt werden soll - jedes Segment der Zeit zugeordnet wird zu gleichen Teilen von der Achse. Auswählen Logarithmischwenn Sie wollen, dass es angezeigt wird als eine logarithmische Progression - jedes Segment der Achse stellt zunehmend längere Zeiträume je höher der Achse Sie gehen. (Die Geschwindigkeit der Erhöhung wird durch die fest BaseSie auswählen.)

Antwortzeitdiagramm Vertikalachsenskala

Um eine Antwort Zeitdiagramm exportieren

1. Stellen Sie sicher, Sie haben ein vorhandenes Antwortzeitdiagramm öffnen.

2. In der Karten-Werkzeugleiste klicken Sie auf die am weitesten links Speichern als BMPTaste und wählen Sie den Speicherort für das Diagramm.

3. Klicken sparen.

Sehe auch

Analyse Ihrer Architektur | Anzeigen einer Fähigkeit Raum Chart


Anzeigen einer star Grundstück Ihrer entwickelten Architekturen

Navigation: Analysieren Sie Ihre Architektur> Benutzerdefinierte Diagramme>

Anzeigen einer star Grundstück Ihrer entwickelten Architekturen

Senden Sie Kommentare Zu diesem Thema.

Sobald eine Architektur wurde entwickelt und die Ziele definiert sind, kann es dann visualisiert und verglichen mit der ursprünglichen Architektur mit Sterne-Plots werden. Dieser Abschnitt beschreibt, wie Sie erstellen und bearbeiten einen Stern Plot.

Um einen Stern Grundstück Ihrer entwickelten Architekturen betrachten

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Vergewissern Sie sich, entwickelt und Ziele setzenfür Ihre Architektur, wie unter beschrieben Evolving Ihre Architektur

3. Auswählen Einfügen| Diagramm| das Individuelle ChartsRegister | Star Grundstück.

4. Klicken Sie auf Fertig Taste.

5. das Star Grundstückmit den entwickelten Architekturen und Ziele wird angezeigt. Hinweis: Die Achsen der star Grundstück kann durch Klicken und Ziehen Sie die Achsen in einen anderen Bereich innerhalb der Grenzen des Stern Plotqualität Raum positioniert werden.

Notiz

Der Bereich auf der linken Seite des Sterns Plot zeigt die Einstellungen des star Grundstück angezeigt. Dies schließt die Architektur, die sich entwickelt hat (in diesem Fall "ABC Ltd Ist-2010") Sowie die Ziele, die für die Architektur festgelegt wurden. Sie werden feststellen, dass die Ziele, die ein Häkchen haben neben ihnen werden als Achsen des star Grundstück vertreten (zB KPI- Kosten, KPI - Qualität und KPI - Zeit). Sie können diese Ziele an jedem Punkt der Zeit deaktivieren, um sie von dem Stern Grundstück zu entfernen.

Die roten und grünen "Punkte", die auf Ihrem Grundstück star erscheinen stellen einen normalisierten Wert, wie von der besten und schlechtesten Wert ermittelt (unter umrissen Ziele zu setzen für Ihre Architektur entwickelt ) Für die ausgewählte Top-Level-Architektur und etwaige Entwicklungen davon. Diese Werte werden in ein vertreten Qualität Raum.

Wie in der obigen Bild aufgeführt sind, ist deutlich sichtbar, dass die ursprüngliche Architektur (Ist-2010) Hat eine schlechte Kosten, Während der erste entwickelt Option (To-Be 2011 - Strategie A) Hat im Rahmen des Qualitäts Raum bewegt, um das zu verbessern Kosten, Qualität und ZeitZiele. Alternativ kann die zweite Option entwickelt (To-Be 2011 - Strategie B), während es auch die verbesserte Kosten das Ausmaß der Verbesserung geringer als die ist Strategie A aber sowohl die Qualität und Zeit Ziele wurden mehr als mit Strategie A. verbessertIn diesem Fall wird ein Architekt kann wählen Strategie A zu Ende Strategie Bwie ihre Empfehlungund weiter zu entwickeln, dass die Option (To-Be 2012 - Strategie A).

6. Deaktivieren Sie das Zeige EvolutionsKontrollkästchen, um die Zeile (n), die die Evolution (n) zwischen dem Original zu verstecken (zB Ist-2010) Und entwickelte (z.B. To-Be 2011 - StrategieA) Architektur (en).

7. Wähle aus Zeige SticksKontrollkästchen, um die relative Größe jedes Qualitätsmerkmal (die Ziele, die auf jeder Achse definiert worden sind) für jede Architektur anzuzeigen.

8. Wähle aus Zeige Architektur NamesKontrollkästchen, wenn Sie wollen, um den Namen des Originals und entwickelten Architektur (en), um auf den Stern Plot angezeigt.

Sehe auch

Analyse Ihrer Architektur | Anzeigen einer Antwortzeitdiagramm | Anzeigen einer Streudiagramm-Matrix Ihres entwickelten Architekturen | Evolving Ihre Architektur


Anzeigen einer Streudiagramm Ihrer entwickelten Architekturen

Navigation: Analysieren Sie Ihre Architektur> Benutzerdefinierte Diagramme>

Anzeigen einer Streudiagramm Ihrer entwickelten Architekturen

Senden Sie Kommentare Zu diesem Thema.

Sobald eine Architektur wurde entwickelt und die Ziele definiert sind, kann es dann visualisiert und verglichen mit der ursprünglichen Architektur mit Streudiagramm-Matrizen werden. In diesem Abschnitt wird das Erstellen und zu verstehen, die Eigenschaften einer Streudiagramm-Matrix.

Um ein Streudiagramm-Matrix Ihres entwickelten Architekturen betrachten

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Vergewissern Sie sich, entwickelt und Ziele setzenfür Ihre Architektur, wie unter beschrieben Evolving Ihre Architektur

3. Auswählen Einfügen| Diagramm| das Individuelle ChartsRegister | Streudiagramm-Matrix.

4. Klicken Sie auf Fertig Taste.

5. das Streudiagrammmit der definierten Entwicklung von Architekturen und Ziele angezeigt.

Notiz

Der Bereich auf der linken Seite des Streudiagramm-Matrix zeigt die Einstellungen des Streudiagramm-Matrix angezeigt. Dies schließt die Architektur, die sich entwickelt hat (in diesem Fall "ABC Ltd Ist-2010") Sowie die Ziele, die für die Architektur festgelegt wurden. Sie werden feststellen, dass die Ziele, die ein Häkchen haben neben ihnen werden als X- und Y-Achsen des Streudiagramm-Matrix dargestellt (zB KPI- Kosten, KPI - Qualität und KPI - Zeit). Sie können diese Ziele an jedem Punkt der Zeit deaktivieren, um sie vor dem Streudiagramm-Matrix zu entfernen.

Die blauen Punkte, die auf Ihrem Grundstück in der Matrix stellen einen normalisierten Wert, wie von der besten und schlechtesten Wert ermittelt (unter umrissen Ziele zu setzen für Ihre Architektur entwickelt ). Diese Werte werden in ein vertreten Qualität Raum.

Zwei definierte Ziele gegeneinander in einer Streudiagramm-Matrix verglichen und der Prozess wird wiederholt, bis alle Ziele wurden im Vergleich (zB Die erste Handlung der Matrix im obigen Diagramm vergleicht KPI - KostenZiel mit der KPI - Qualität Tor. Das zweite ist, Kosten gegen Zeit und die letzte Handlung ist Qualität gegen Zeit. Die relevanten Ziel-Etiketten sind an der oberen und rechten oder jeder Reihe von Plots dargestellt.).

6. Wähle aus ArchitekturenRadio-Button, wenn Sie die Messdaten für die einzelnen Architekturen angezeigt werden sollen.

7. Wähle aus EvolutionsRadio-Button, wenn Sie die normalisierten Änderungen von der ursprünglichen Architektur darstellen möchten (zB Ist-2010) Mit der weiterentwickelten Architektur (en) (z.B. To-Be 2011 - Strategie A und To-Be 2011 - Strategie B).

Sehe auch

Analyse Ihrer Architektur | Anzeigen einer Antwortzeitdiagramm | Anzeigen einer star Grundstück Ihrer entwickelten Architekturen | Evolving Ihre Architektur


Anzeigen einer Blasendiagramm

Navigation: Analysieren Sie Ihre Architektur> Benutzerdefinierte Diagramme>

Anzeigen einer Blasendiagramm

Senden Sie Kommentare Zu diesem Thema.

Ein Blasendiagramm können Sie bis zu 5 Dimensionen (dh X, Y, Blasengröße / Radius, Farbe und Blase Blase Grenze Farbe) in einer Ansicht einen direkten Vergleich.

Um eine Blase anzusehen

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Auswählen Einfügen| Diagramm| das Individuelle ChartsRegister | Blasendiagramm.

3. im ArchitekturenAbschnitt Zutreffendes Architekturen (falls vorhanden) Sie ein Diagramm erstellen möchten, klicken Sie dann auf Nächster.

4. Wähle aus Components und Anschlüssedass Sie in der Tabelle aus der willst (falls vorhanden) Standard-Element-Auswahlfenster , Klicken Sie dann auf Nächster.

5. Wähle aus X-AchseEigentum, klicken Sie dann auf Nächster.

Notiz

Nur Integer, Dezimal, Datum / Zeit, Boolean und Listeneigenschaften kann für die X-Achse verwendet werden. Außerdem Integer, Dezimal und Datum / Zeit Eigenschaften aufgetragen sind von links nach rechts entlang der nach dem Wert der Immobilie skalierten Achse sind jedoch Boolean und Listeneigenschaften einfach aufgetragen links nach rechts in der exakten Reihenfolge (oder in die umgekehrte Reihenfolge, wenn die Option, um die Reihenfolge umzukehren aktiviert ist) für die Eigenschaft, unabhängig von ihrer Werte definiert. Z.B. Low | Medium | Hoch oder 1, 2, 4, 8, 16.

6. Wähle aus Y-AchseEigentum, klicken Sie dann auf Nächster.

Notiz

Nur Integer, Dezimal, Datum / Zeit, Boolean und Listeneigenschaften kann für die Y-Achse verwendet werden. Darüber hinaus sind Integer, Dezimal und Datum / Zeit Eigenschaften von unten nach oben entlang der nach dem Wert der Immobilie skalierten Achse aufgetragen, aber Boolean und Listeneigenschaften werden einfach aufgetragen unten nach oben in der exakten Reihenfolge (oder in die umgekehrte Reihenfolge, wenn die Option, um die Reihenfolge umzukehren aktiviert ist) für die Eigenschaft, unabhängig von ihrer Werte definiert. Z.B. Low | Medium | Hoch oder 1, 2, 4, 8, 16.

7. Wähle aus Blasengröße / RadiusEigentum, klicken Sie dann auf Nächster.

Notiz

Nur Integer, Dezimal, Boolean und Listeneigenschaften kann für die Blasengröße / Radius verwendet werden. Außerdem Integer und Decimal Eigenschaften führen zu einer Blasengröße / Radius nach dem Wert der Immobilie skaliert, jedoch dazu führen, Boolean und Listeneigenschaften in gleichem Schritt erhöht sich der Blasengröße / Radius in der exakten Reihenfolge (oder in umgekehrter Reihenfolge, wenn die Möglichkeit, die Reihenfolge umzukehren wird überprüft) für die Eigenschaft, unabhängig von ihrer Werte definiert. Z.B. Low | Medium | Hoch oder 1, 2, 4, 8, 16.

8. Wählen Sie entweder ein festen Blase Farbe oder assoziieren eine Eigenschaft mit dem Blasen Farbe, Klicken Sie dann auf Nächster.

Notiz

Nur Integer, Dezimal, Boolean und Listeneigenschaften kann für die Blase Farbe verwendet werden. Außerdem Integer und Decimal Eigenschaften führen zu einer Blase Farbe innerhalb des gewählten Bereich nach dem Wert der Immobilie skaliert, jedoch dazu führen, Boolean und Listeneigenschaften in gleichem Schritt steigt der Blase Farbe innerhalb des gewählten Bereichs in der exakten Reihenfolge für die definierte Eigenschaft unabhängig von ihren Werten. Z.B. Low | Medium | Hoch oder 1, 2, 4, 8, 16.

9. Wählen Sie entweder keine Blase Rahmenfarbe oder assoziieren eine Eigenschaft mit dem Blasenrahmenfarbe, Klicken Sie dann auf Fertig.

Notiz

Nur Integer, Dezimal, Boolean und Listeneigenschaften kann zur Blasengrenzfarbe verwendet werden. Außerdem Integer und Decimal Eigenschaften führen zu einer Blase Grenze Farbe innerhalb des gewählten Bereichs nach dem Wert der Immobilie skaliert, jedoch dazu führen, Boolean und Listeneigenschaften in gleichem Schritt steigt der Blase Grenze Farbe innerhalb des gewählten Bereichs in der exakten Reihenfolge definiert für die Eigenschaft, unabhängig von ihrer Werte. Z.B. Low | Medium | Hoch oder 1, 2, 4, 8, 16.

Blasendiagramm

Um ein Blasendiagramm sparen

Notiz

Blasendiagramme können nur gespeichert werden, wenn sie Komponenten und Verbindungen, von denen alle müssen aus einer einzigen Architektur im aktuellen Projekt enthalten nur.

1. Stellen Sie sicher, dass Sie eine neue oder vorhandene Blasendiagramm haben öffnenund Sie die notwendigen Änderungen vorgenommen haben.

2. In der Karten-Werkzeugleiste klicken Sie auf die am weitesten links Save-DiagrammTaste, um das Diagramm und alle Formatierungsänderungen zu speichern.

3. im DiagrammnameDialogfeld, geben Sie einen Namen für das Blasendiagramm und drücken erscheint OK.

Um ein Blasendiagramm exportieren

1. Vergewissern Sie sich, öffnen Sie eine vorhandene Blasendiagramm.

2. In der Symbolleiste auf Diagramm auf der 2. von links Speichern als BMPTaste und wählen Sie den Speicherort für das Diagramm.

3. Klicken sparen.

Sehe auch

Analyse Ihrer Architektur


Architektur Diff und Sync

Navigation: Analysieren Sie Ihre Architektur>

Architektur Diff und Sync

Senden Sie Kommentare Zu diesem Thema.

Wenn Sie entweder als Evolutionen oder Baseline-Architekturen, können Sie visuell 'diff' die beiden Architekturen mit 2 oder mehr Architekturen Katalog oder Diagramm-Vergleich oder Architektur Diff-Funktion. Dies ist für die Entdeckung / neu zu entdecken, die genauen Änderungen von einer Architektur zur anderen gemacht, wie Sie Architekturen zu entwickeln und zu entwickeln, Roadmaps in ABACUS besonders nützlich.

Zu zeigen die 'diff' mit einer anderen Architektur über ein Diagramm,

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Stellen Sie sicher, haben mindestens 2-Architekturen im Projekt.

3. Öffnen Sie das Diagramm, das Sie auf einen anderen Architektur vergleichen möchten.

4. Klicken Sie auf den "Vergleichen Sie diese Darstellung, um den Inhalt einer anderen Architektur 'Taste auf der Diagramm-Symbolleiste.

5. Wählen Sie die anderen Architektur aus der Dropdown-Liste, um zu vergleichen.

6. Sie können durch Klicken auf die Schaltfläche "Unterschiede" auf der Diagrammsymbolleiste und deaktivieren Optionen, zB Filter, welche Unterschiede gezeigt werden Geändert / hinzugefügt / Unknown, und Unbestimmt / Sync Empfohlen/ Halten empfohlen.

Notiz

Komponenten und Verbindungen auf dem Diagramm wird hervorgehoben rot, grün oder lila wo gibt es Unterschiede zwischen den Inhalten, die auf dem aktuellen Diagramm und den Inhalt in die jeweils andere Architektur zu sehen ist. Rot wird verwendet, wenn es wird empfohlen, um die Unterschiede Sync (siehe unten), Grün wird verwendet, wenn es nicht empfohlen wird, um die Unterschiede zu synchronisieren, also halten sie (siehe unten) und Lila wird verwendet, wenn ABACUS kann eine Empfehlung zum Synchronisieren der Unterschiede (siehe unten) nicht zu machen. Nur die sichtbaren Inhalte auf dem Diagramm ist im Vergleich so dass, wenn eine Anmerkung ein Repository-Eigenschaftenwert zeigt, und dieser Wert wird die gegebene Komponente verändert oder die Verbindung wird angezeigt schwachen roten, schwaches grün oder schwache lila und eine an gezeigt "*" Symbol oben links für Komponenten, jedoch, wenn eine andere zugrunde liegenden Repository-Eigenschaftswert geändert, dass wird nicht in einer Anmerkung dann kein Hinweis gegeben werden angezeigt. Inhalte, die auf das aktuelle Diagramm auftritt, aber keine Übereinstimmung in der Vergleichs Architektur gefunden wird angezeigt starke rote, starke grüne oder starke lilaund einem "+" Symbol oben links für die Komponenten dargestellt. Matching wird durch Komponententyp und Namen, so dass, wenn die Art oder den Namen der Komponente oder Verbindung in der anderen Architektur verändert keine Übereinstimmung gefunden wird getan. So gibt es keine Möglichkeit, zuverlässig zu bestimmen, ob zusätzliche Inhalte von dem anderen Architektur würde das aktuelle Diagramm gezeigt worden sind (zB durch eine zusätzliche Schnittstelle zwischen 2 Komponenten, wie unten im Diagramm aus dem Vergleich Architektur auf der rechten Seite), sind diese Unterschiede nicht für Diagrammen dargestellt (sie werden für Kataloge nach unten). Schwebt über jedem geänderten Artikel werden den Unterschied in der Quickinfo angezeigt. Bewegen der Maus über das Symbol "*" in der oberen linken Seite des Diagramms stellt eine Zusammenfassung der Änderungen (oder ohne Änderungen) zwischen Inhalt des Diagramms und die Inhalte der anderen Architektur.

Farbe Legend

· Grün zeigt an, Elemente, die es nicht empfohlen wird, um die Unterschiede zu synchronisieren, ist, dass sie zu halten.

· Rot zeigt an, Elemente, ist es empfehlenswert, um die Unterschiede zu synchronisieren.

· Lila zeigt an, Posten, bei denen ABACUS kann eine Empfehlung zum Synchronisieren die Unterschiede nicht zu machen.

Zu ("sync") Inhalte von einer Architektur mit einem anderen über ein Diagramm synchronisieren

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Stellen Sie sicher, haben mindestens 2-Architekturen im Projekt.

3. Öffnen Sie das Diagramm, das Sie auf einen anderen Architektur vergleichen möchten.

4. Klicken Sie auf den "Vergleichen Sie diesen Katalog mit dem Inhalt eines anderen Architektur 'Taste auf der Diagramm-Symbolleiste.

5. Wählen Sie die anderen Architektur aus der Dropdown-Liste, um zu vergleichen.

Notiz

Siehe oben für die Art, ABACUS zeigt die "diff" zwischen den 2-Architekturen im Katalog. Insbesondere, wie Rot verwendet wird, wo es istempfohlen, um die Unterschiede zu synchronisieren, Grün verwendet wird, wo es nichtempfohlen, um die Unterschiede zu synchronisieren und Lila wird verwendet, wenn ABACUS kann eine Empfehlung zum Synchronisieren die Unterschiede nicht zu machen.

6. Rechtsklick auf das Diagramm-Element (oder Elemente mit Shift oder das Diagramm Leinwand, um Sync All), die eine 'diff' und wählen Sie den Menüpunkt Sync.

Notiz

Etwaige Synchronisierungs Änderungen nur für die Architektur, die sich momentan im Fokus Katalog gehört angewendet werden. Um Änderungen an den anderen Architektur müssen Sie einen Katalog in die jeweils andere Architektur zu verwenden anzuwenden. Darüber hinaus werden die Nutzer nur in der Lage, die Synchronisation ändert sich, wenn sie anzuwenden haben die Erlaubnis, dies zu tun .

Notiz

Je nachdem, wo Sie mit der rechten Maustaste auf den Menüpunkt wird Anleitung, was genau vor sich geht, die synchronisiert werden angezeigt. Z.B. Ein Rechtsklick auf eine einzelne Komponente in der Abbildung wird nur zu synchronisieren, dass die Komponente. In der Erwägung, Rechtsklick auf das Diagramm, Leinwand und wählen Sync All werden alle aktuell angezeigten Unterschiede zu synchronisieren.

Zu zeigen die 'diff' mit einer anderen Architektur über einen Katalog

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Stellen Sie sicher, haben mindestens 2-Architekturen im Projekt.

3. Öffnen Sie den Katalog, den Sie an eine andere Architektur vergleichen möchten.

4. Klicken Sie auf den "Vergleichen Sie diesen Katalog mit dem Inhalt eines anderen Architektur 'Taste auf der Katalog-Symbolleiste.

5. Wählen Sie die anderen Architektur aus der Dropdown-Liste, um zu vergleichen.

6. Sie können durch Klicken auf die Schaltfläche "Unterschiede" auf der Diagrammsymbolleiste und Abwählen Optionen, zB Filter, welche Unterschiede gezeigt werden Geändert / hinzugefügt / Unknown, und Unbestimmt / Sync Empfohlen/ Halten empfohlen.

Notiz

Zellen im Katalog wird in hervorgehoben werden rot, grün oder lila wo gibt es Unterschiede zwischen den Inhalten im aktuellen Katalog und dem passenden Inhalt in die jeweils andere Architektur. Rot wird verwendet, wenn es wird empfohlen, um die Unterschiede Sync (siehe unten), Grün wird verwendet, wenn es nicht empfohlen wird, um die Unterschiede zu synchronisieren, also halten sie (siehe unten) und Lila wird verwendet, wenn ABACUS kann eine Empfehlung zum Synchronisieren der Unterschiede (siehe unten) nicht zu machen. Nur die sichtbaren Zeilen und Spalten im Katalog werden verglichen, um, wenn es einen Unterschied in einer Reihe über die aktuell angezeigten Zeilen oder einen Wert in eine Spalte, die nicht dargestellt ist, hat eine Differenz dann kein Unterschied wird angezeigt. Wobei der Wert in einer einzelnen Zelle ist anders mit der passenden Zelle im Vergleich Architektur die Zellgrenze wird hervorgehoben. Die Spaltenüberschrift und Zeilenauswahl wird auch in schattiert schwache lilaund mit einem '*' Symbol angezeigt. Diese "*" Symbole können angeklickt werden, um zum nächsten Unterschied in der Spalte oder Zeile bzw. springen. Zeilen, die im aktuellen Katalog auftritt, aber keine Übereinstimmung in der Vergleichs Architektur gefunden wird mit einem '+' Symbol in der Zeilenauswahl auf der linken und der Grenze der gesamte Zeile wird markiert angezeigt. "-" Symbol in der Zeilenauswahl auf der linken Seite, der Grenze der Zeilen, die in der Vergleichs Architektur Version des Katalogs (dh mit den gleichen Filter, etc.) stattgefunden hätte, aber keine Übereinstimmung in der Architektur gefunden werden mit einem angezeigt werden die gesamte Zeile wird markiert und die ganze Zeilen Zellen Inhalte werden in gezeigt werden, schwache lilaund schlug Durch, z.B. Von 08.00 Uhr bis 18.00 Uhr. Matching wird durch Komponententyp und Namen, so dass, wenn die Art oder den Namen der Komponente oder Verbindung in der anderen Architektur verändert keine Übereinstimmung gefunden wird getan. Schwebt über jedem geänderten Artikel werden den Unterschied in der Quickinfo angezeigt. Bewegen der Maus über das Symbol "*" in der oberen linken Seite des Diagramms enthält eine Zusammenfassung der Änderungen (oder ohne Änderungen) zwischen Inhalt des Diagramms und der Inhalt der anderen Architektur.

Farbe Legend

· Grün zeigt an, Elemente, die es nicht empfohlen wird, um die Unterschiede zu synchronisieren, ist, dass sie zu halten.

· Rot zeigt an, Elemente, ist es empfehlenswert, um die Unterschiede zu synchronisieren.

· Lila zeigt an, Posten, bei denen ABACUS kann eine Empfehlung zum Synchronisieren die Unterschiede nicht zu machen.

Zu ("sync") Inhalte von einer Architektur mit einem anderen über einen Katalog zu synchronisieren

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Stellen Sie sicher, haben mindestens 2-Architekturen im Projekt.

3. Öffnen Sie den Katalog, den Sie an eine andere Architektur vergleichen möchten.

4. Klicken Sie auf den "Vergleichen Sie diesen Katalog mit dem Inhalt eines anderen Architektur 'Taste auf der Katalog-Symbolleiste.

5. Wählen Sie die anderen Architektur aus der Dropdown-Liste, um zu vergleichen.

Notiz

Siehe oben für die Art, ABACUS zeigt die "diff" zwischen den 2-Architekturen im Katalog. Insbesondere, wie Rot verwendet wird, wo es istempfohlen, um die Unterschiede zu synchronisieren, Grün verwendet wird, wo es nichtempfohlen, um die Unterschiede zu synchronisieren und Lila wird verwendet, wenn ABACUS kann eine Empfehlung zum Synchronisieren die Unterschiede nicht zu machen.

6. Rechtsklicken Sie auf die Zelle, Spalte oder Zeile Überschrift (oder mehrere Artikel mit Shift oder Strg + A für alles), die eine 'diff' und wählen Sie den Menüpunkt Sync.

Notiz

Etwaige Synchronisierungs Änderungen nur für die Architektur, die sich momentan im Fokus Katalog gehört angewendet werden. Um Änderungen an den anderen Architektur müssen Sie einen Katalog in die jeweils andere Architektur zu verwenden anzuwenden. Darüber hinaus werden die Nutzer nur in der Lage, die Synchronisation ändert sich, wenn sie anzuwenden haben die Erlaubnis, dies zu tun .

Notiz

Je nachdem, wo Sie mit der rechten Maustaste (dh eine Zelle, Spalte oder Zeile Überschrift) der Menüpunkt wird Anleitung, was genau los ist angezeigt, die synchronisiert werden. Z.B. Ein Rechtsklick auf eine einzelne Eigenschaft oder Anbauteil Zellen im Katalog nur zu synchronisieren, dass die Eigenschaft oder Komponente befestigt. Wohingegen rechten Maustaste auf eine Zeile Überschrift (oder Überschriften mit Shift) wird die gesamte Zeile (oder Zeilen) zu synchronisieren. Ein Rechtsklick auf einen Spaltenkopf werden alle Unterschiede in dieser Spalte zu synchronisieren.

Um eine Ansicht 'diff'2 ganze Architekturen

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet .

2. Stellen Sie sicher, haben mindestens 2-Architekturen im Projekt.

3. Auswählen Tools| Architektur Diff ....

4. In dem Dialog, wählen Sie als Erste / Aus und zweiten / To-Architekturen zu vergleichen, wird angezeigt.

5. Klicken Sie auf OK Taste.

Architektur Diff

Farbe Legend

· Grünzeigt an, dass der Knoten in der zweiten / Architektur aufgenommen.

· Rotzeigt an, dass der Knoten in der zweiten gelöscht / zur Architektur.

· Blauzeigt an, dass der Knoten über verschiedene Attribute (zB Eigenschaften oder Standards) in der zweiten / Architektur.

· Gelbzeigt an, dass der Knoten Unterschiede in ihren Kindern in der zweiten / Architektur so dass der Knoten erweitert werden sollte.

Notiz

Sie können mit der rechten Maustaste anklicken und "Im Explorer anzeigen" auf allen Knoten zu sehen, Details und weitere Informationen wird auf die Unterschiede in der Unterschiede Zusammenfassung Tafel gegeben, wenn ein Knoten ausgewählt ist.

Sehe auch

Analyse Ihrer Architektur | Anzeigen einer Antwortzeitdiagramm | Anzeigen einer Streudiagramm-Matrix Ihres entwickelten Architekturen | Evolving Ihre Architektur


Simulation von Ihrer Architektur

Navigation: Simulieren Sie Ihre Architektur>

Simulation von Ihrer Architektur

Senden Sie Kommentare Zu diesem Thema.

Sobald Sie besiedelt haben und analysiert Ihre Architektur, sind Sie bereit, ABACUS verwenden, um festzustellen, ob Ihre Architektur wird Ihre quantitative Anforderungen zu erfüllen. Dies erfordert, Simulation. Ihre Architektur zu simulieren, müssen Sie zunächst entscheiden, von der Art der Informationen, die Sie entdecken wollen. Diese Arten von Informationen werden oft als KPIs oder Key Performance Indicators bezeichnet. Zum Beispiel, haben Sie, um die Leistung, Entwicklungsfähigkeit und Offenheit analysieren wollen, oder wollen Sie Kennzahlen wie Gesamtbetriebskosten zu sammeln möchten. All diese Informationen können in irgendeiner Weise offenbart werden. Sobald Sie diese Daten haben, werden Sie in der Lage, Ihre Architektur in einer Vielzahl von grafischen Formaten zu analysieren (oder die neuen Werte direkt zu analysieren).

Es gibt drei Optionen für die Simulation von Ihrer Architektur:

· Einfache Kennzahlen ;

· Vorgefertigte Simulatoren ; oder

· Scripting .

Einfache Metrics

Jede Komponente in der Architektur Eigenschaften hat - von denen viele benutzerdefinierte auf Ihre Anwendung von ABACUS ist. Diese Eigenschaften stellen verschiedene Merkmale der Komponenten. In einigen Fällen einfach Erhebung dieser Kennzahlen (KPIs zu bauen) kann genug, um Ihnen wichtige Informationen über Ihre Architektur zu erzählen. B. KLOCS oder Tausende von Codezeilen wurden in großem Umfang als Maß für die Komplexität verwendet. In anderen Fällen kann es zu wollen, exportieren Sie die Daten und zu analysieren mit einem anderen Werkzeug. Darüber hinaus können Sie Objekte nach der Durchführung eine andere Art von Simulation zu sammeln.

Eigenschaften können durch den Prozess der gesammelt werden Anhäufung . Aggregation fügt angegebene Teileigenschaften auf insgesamt, die in der übergeordneten Komponente widerspiegelt. Aggregation funktioniert nur auf Komponenten, die Sub-Komponenten enthalten.

Vorgefertigte Simulatoren

Es gibt fünf vordefinierte Simulatoren, die mit ABACUS verwendet werden kann. Diese sind:

· Performance;

· Modularität;

· Total Cost of Ownership (TCO);

· Offenheit; und

· Zuverlässigkeit.

Notiz

ABACUS wird automatisch zu markieren, welche dieser Simulatoren werden durch erneut ausführen müssen Rot Hervorhebung auf die Simulation Symbolleiste .

Scripting

Scripting bietet die Flexibilität, Ihre Architektur in individuelle Weise zu simulieren. Durch Schreiben von Skripts Sie Simulationen über die aktuelle eingebaute Kapazität von ABACUS durchführen können. Die gesamte ABACUS-Objektmodell ist für das Scripting-Engine, so dass Sie nur durch Ihre Fähigkeit, Skripte zu schreiben beschränkt!

Visual Basic-Skript ist die Skriptsprache von ABACUS unterstützt, da sie wesentliche Programmfunktionen in einer recht einfachen Format.

Sehe auch

Exportieren Sie Ihre Architektur | Aggregate Eigenschaften | Schreiben von Skripts


Schreiben von Skripts

Navigation: Simulieren Sie Ihre Architektur>

Schreiben von Skripts

Senden Sie Kommentare Zu diesem Thema.

Der Skript-Editor ist eine einfache und funktionalen Nutzen für das Schreiben und Ausführen von VB oder C # Skript für die aktuell geöffneten ABACUS-Datei(Bibliotheken sind nicht scripting unterstützt). Es verfügt über die üblichen Datei-Öffnen, Schließen und Speichern-Befehle, so können Sie speichern und Skripte, die Sie schreiben, abzurufen. Es hat auch einen grundlegenden Ausführungs- und Debugmöglichkeiten. Das Script Manager können Sie ganz einfach durchführen, die verschiedenen Skripte, die Sie, indem Sie einen Menüpunkt für sie direkt im Menü Extras geschrieben haben.

Um die Skript-Editor zugreifen

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Auswählen Tools | Script Editorund die Skript-Editor-Fenster öffnet sich. Dann entweder;

3. Öffnen Sie ein vorhandenes Skript über Datei | Öffnen in den Skript-Editor-Menüs,

oder

3. Öffnen Sie ein Beispiel-Skript über die Beispiel Artikel in den Skript-Editor-Menüs,

oder

3. Legen Sie die Standardsprache, entweder VB oder C # über das Sprache Artikel in den Skript-Editor-Menüs,

oder

3. Öffnen Sie Scripting spezifische Hilfe im Hilfe Artikel in den Skript-Editor-Menüs

Beim Schreiben von Skripts, müssen Sie sich an entweder VB oder C # Syntaxnach der Einstellung unter der Option Sprache im Skript-Editor-Menüs.

HINWEIS:

· Zur Standard-VB-Funktionen wie verwenden MsgBox ()Sie müssen den Importe Microsoft.VisualBasicAnweisung am Anfang des Skripts. Dies war vorher nicht Version 3.0 von ABACUS notwendig.

· Diese Hilfe enthält keine Informationen über die VB-Skript zu schreiben, noch ein VB-Hinweis enthalten. Fühlen Sie sich frei, um Ihre Skripte in Ihrer bevorzugten IDE oder Editor schreiben, dann kopieren und fügen Sie sie in das Skript-Editor.

Beim ersten Start den Skript-Editor, wird die Skript-Editor leer sein. Sie können ein Skelett-Skript durch das Menü Beispiele zuzugreifen. Das erste Mal, wenn Sie Ihre Script-Editor zu starten, sollten Sie die Vorlage Skelett laufen, um zu sehen, dass es funktioniert. Darüber hinaus gibt es zwei Beispiel-Skripte, die durch den Menü Beispiele zugegriffen werden kann.

Um eine sinnvolle Skript zu schreiben, müssen Sie das ABACUS Object verweisen. Es wird zur Verfügung, um das Skript, indem das gemacht Importe ABACUS.ObjectModelStatement an der Spitze des Skripts. Eine vollständige Referenz für die gesamte ABACUS-Objektmodell wird mit dem Script Editor enthalten. Sie können es, indem Sie zu finden Hilfe | Inhaltaus dem Skript-Editor-Fenster.

Der Script-Editor enthält viele nützliche Funktionen für das Schreiben von Skripts, einschließlich Autovervollständigen wie in der Abbildung unten gezeigt. Jedoch für eine noch höhere Benutzerfreundlichkeit MS Visual Studio mit ABACUS integriert werden und detaillierte Anweisungen zur Verfügung Hier .

Skript-Editor mit Autovervollständigen

Um den Skript-Manager verwenden

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Wählen Sie Extras | Script Manager.

3. Klicken Sie auf HinzufügenSymbol und ein ÖffnenFenster erscheint.

4. Navigieren Sie zu dem ABACUS Script (.abacusscript, VB oder CS-) Datei, die Sie auf das Menü Extras hinzufügen möchten.

5. Klicken OKund ein Verweis auf das Skript im Script Manager-Fenster angezeigt. Geben Sie den Namen für das Skript, wie Sie es in dem Menü Extras erscheinen soll. Hinweis: Die Manager-Fenster Skript kann geändert werden, um den vollständigen Pfad ggf. zu sehen.

6. Wiederholen Sie die Schritte 3-5um Verbindungen zu mehr ABACUS-Skripte erstellen.

7. Klicken Nah dranum den Skript-Manager zu schließen, und beachten Sie, dass die ABACUS-Skript (n) nun unter dem Menü Extras angezeigt.

Um ein Skript ausführen

Entweder;

1. Open, eintippen oder kopieren und fügen Sie im Skript die Sie ausführen möchten, so ist es im Hauptfenster von der angezeigte Script Editor.

2. Drücke den Lauf Taste.

3. Wenn Ihr Skript Fehler enthält, wird die Fehlerbeschreibung Abschnitt am unteren Rand des Skript-Editor die Details einschließlich der Zeilennummern aufzulisten. HINWEIS: Jeder einzelne Fehler in der Fehlerbeschreibung Schnitt doppelgeklickt, um Sie auf die entsprechende Zeile im Skript zu nehmen.

- oder -

1. Auswählen Toolsund dann das ABACUS Script Name Menüpunkt wie bei der erstellt Script Manager.

2. Wenn Ihr Skript Fehler enthält, wird die Skript-Editor mit dem Inhalt des Skripts im Hauptfenster (an der Linie des ersten Fehler hervorgehoben) dargestellt und die Fehlerbeschreibung Abschnitt am unteren Rand des Skript-Editor wird die Details aufzulisten oder geöffnet werden der Fehler (e) mit den Zeilennummern. HINWEIS: Jeder einzelne Fehler in der Fehlerbeschreibung Schnitt doppelgeklickt, um Sie auf die entsprechende Zeile im Skript zu nehmen.

Scripting Kompilierung-Fehler

Übersetzen Fehler auf, wenn die Syntax der Script-Code ist nicht korrekt. Diese Fehler werden am unteren Rand des Fensters im Abschnitt Fehler auftauchen, mit einer Beschreibung des Fehlers und einer Zeilennummer. Es ist die Zeilennummer, die einen Übersetzungsfehler aus einer Laufzeitfehler (siehe unten), die nicht über eine Zeilennummer unterscheidet. Compilation Fehler können doppelgeklickt werden, um zu springen, und markieren Sie die betreffende Zeile in Frage.

Scripting Runtime Errors (Wichtig)

Laufzeitfehler auftreten, nachdem der Skriptcode wurde erfolgreich ohne Fehler kompiliert, aber während der Laufzeit ein Fehler auf (siehe Beispiele weiter nach unten). Laufzeitfehler sind wichtig, da sie in beschädigten Modellen führen, wenn Objekte erstellt und von anderen Objekten im Modell verwiesen wird, sind nicht selbst Teil des Modells (in der Regel, weil ein Laufzeitfehler hat vor dem Code, der sie in das Modell gelegt haben würde aufgetreten irgendwo, wurde hingerichtet).

Wenn Ihr Skript erstellt Objekte, um zum Modell hinzugefügt werden, können Sie die Korruption von einem Laufzeitfehler verursacht, indem Sie Ihr Skript, Schließen Scripting, und Durchführen einer Undo der Änderungen, die durch das Skript erstellt wurden (wenn die Ausführung des Skripts nicht normal abgeschlossen vermeiden ). Es gibt jedoch auch andere Möglichkeiten, um jede Beschädigung auftritt (siehe unten) zu vermeiden. Notiz: Alle Skripte, die lediglich aus dem Modell zu lesen und nicht zu schreiben, sicher sind und keine Probleme verursachen, unabhängig davon, ob während ihrer Ausführung Laufzeitfehler auftreten.

Um Korruption zu vermeiden, beim Schreiben von Script-Code, dass die Schaffung Objekte und die Aufnahme in das Objektmodell, wird vorgeschlagen, dass die Objekte dem Modell hinzugefügt so bald wie möglich, wenn sie von anderen Objekten referenziert werden.

Zum Beispiel, wenn Sie erstellen eine neue Verbindung, und 2 neue Komponenten, und dann miteinander Befestigen sie, ist es am besten, um die erste Komponente zu erstellen, ist es zum Modell hinzufügen, dann die zweite, und fügen Sie es, und erstellen Sie die Verbindung und fügen Sie es, und dann schließlich die Anhänge zu erstellen. Dies bedeutet, dass, wenn es zu einem Laufzeitfehler, die die Skriptausführung unterbricht sein, alle Objekte, die erforderlich sind, um in der Object sein, bevor eine Anlage erstellt wird, sind in dem Modell. Beschädigung kann auftreten, wenn beispielsweise nur die Verbindung zugegeben worden war, haben die Anlagen hinzu, und ein Laufzeitfehler aufgetreten ist, bevor das Skript die neuen Komponenten schließlich zur model.Corruption hinzugefügt werden können auftreten, wenn ein Objekt, das durch ein anderes Objekt verwiesen wird, in die Object, ist selbst nicht in der Object.

Beispiel Laufzeitfehlern gehören:

· Der Objektverweis wurde nicht auf eine Instanz eines Objekts festgelegt - in diesem Fall, wenn ein Objekt Variable ist ein NULL-Verweis, und eine Methode oder Eigenschaft für das Objekt verwendet wird. Null-Referenzen können überprüft werden: "Wenn objectVariable Is Nothing Then ... '

· Index war außerhalb der Begrenzungen des Arrays - Dies geschieht, wenn ein Array mit einem Index, der außerhalb der Grenzen ist zugänglich - zB kleiner als 0 oder gleich oder größer als die Länge / Anzahl des Arrays. Anordnung oder Sammlung Länge kann durch den .Length oder .Count Eigenschaften bzw. überprüft werden.

· No Permission Ausnahme - Sie haben keine Berechtigung, um ... - dieses tritt auf, wenn Sie nicht über die Berechtigung, um die gegebene Änderung vornehmen

· Primary Key Exception - Duplizieren / Fehlende Name / ID - diese wird auftreten, wenn eine Änderung an einem einzigartigen Attribut, das mit einem anderen Objekt kollidiert gemacht. Z.B. Architekturen muss nach Name eindeutig sein, ebenfalls mit Standards.

· Referentielle Integrität Ausnahme - Setzen eines Referenzfeld auf ein Objekt, das nicht gültig ist. Z.B. Hinzufügen von "nichts" oder null, wie ein Kind, um viele der Sammlungen in der Object.

· Zero Length Ausnahme - dies kann auftreten, wenn Sie versuchen, den Namen eines Objekts auf einen leeren String gesetzt. Die meisten Objekte erfordern ihre Namen, um mindestens 1 Charakter haben.

Imports-Anweisungen

Man beachte, dass zu Beginn des Skeletts Skripte sind Aussagen wie Importe ABACUS.ObjectModel. Diese Aussagen werden nicht gehören eine DLL, die nicht bereits durch das Skript verwiesen wird - ihr Ziel ist es, eine "Abkürzung" zu haben, um den gesamten Namen einer Klasse angeben, bereitzustellen.

Zum Beispiel, um eine Variable vom Typ CComponent (die eine Komponente in ABACUS) zu erklären, mit der Importe ABACUS.ObjectModelAnweisung zur Oberseite des Skripts, wäre nur erforderlich, sie enthalten, als dim comp als CComponent, Weil der Compiler weiß, in der ABACUS.ObjectModel Namespace für das CComponent Klasse freuen. Ohne die Anweisung Imports, müsste sie als deklariert werden dim comp als ABACUS.ObjectModel.CComponent. Eine Anordnung (wie mscorlib.dll oder System.Windows.Forms.dll) können mehr als einen Namespace enthalten - die Imports-Anweisung für diesen Namensräumen, nicht für die Baugruppen selbst. Die ABACUS.ObjectModel.dll Montage hat nur den einzigen ABACUS.ObjectModel Space via Scripting zugänglich.

Automatisch referenzierten Assemblys

Folgende DLLs werden automatisch durch Scripting verwiesen:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (implizit durch den Compiler verwiesen wird)

· ABACUS.ObjectModel.dll

Weitere Referenzen entweder anderen .NET-Assemblies, oder Ihren eigenen Baugruppen zu machen, finden Sie im Abschnitt über die #ImportDLL Aussage.

#ImportDLL Erklärung

Ab ABACUS 3.1 können Sie zusätzliche Baugruppen, die Sie für die Skripterstellung mit der Nutzung der kann verlangen Referenz #ImportDLL Aussage. Zum Beispiel, wenn Sie eine benutzerdefinierte DLL von Ihnen zugreifen und diese nutzen, die Funktionalität in ihr wollte, würden Sie es in der ABACUS-Verzeichnis platzieren und schließen Sie die Anweisung als erste Zeile (n) in Ihrem Skript. Wenn es sich um eine .NET-DLL, dann in der Regel müssen Sie nicht den gesamten Pfad, nur das DLL eingeben.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Einige andere Dinge zu beachten:

1. Da die DLLs benötigen, um bei der Kompilierung und zur Laufzeit gefunden werden, schränkt dieser Brauch (nicht .NET) DLLs, um in nur Programmordner ABACUS platziert.

2. #ImportDLL Aussagen muss die erste Zeile (n) aus einem Skript sein - wenn Sie 5-Anweisungen, dann sollten sie auf den ersten 5 Zeilen des Skripts sein

3. Ein #ImportDLL Aussage überall aufgestellt, aber die ersten Zeilen des Skripts (zB wenn es nach einem Kommentar oder eine Imports-Anweisung platziert wurde) wird nicht korrekt funktionieren und / oder kann ohne Bezug Compiler-Fehler verursachen.

#ImportDLL mit Office-Assemblies

Wenn Sie Microsoft Office installiert, und Ihr Script benötigt die Office-Interop Assemblies, ist es möglich, sie einfach mit Referenz #ImportDLL mit der Montage-Namen (wie nachstehend aufgeführt, z.B. #ImportDLL Excel). Mit dieser Methode hat den Vorteil, dass eine absolute dll-Pfad muss nicht verwendet werden, so dass das Skript ist mehr tragbar (sollte sowohl auf Office 2003 und 2007, ohne Bearbeitung des Skripts zu arbeiten).

Wenn Sie diese Funktion verwenden, wird die GAC (Global Assembly Cache) für die Interop-Assembly gesucht, und das Skript kompiliert durch den Pfad zu dieser Versammlung, wenn gefunden. Wenn es nicht gefunden wird, wird Skript das Programmverzeichnis ABACUS überprüfen (die die Excel enthält, und Visio Interops only). Wenn der angeforderte Interop ist nicht bis zu diesem Zeitpunkt festgestellt, wird eine Warnung angezeigt.

Die Interops werden in der Regel nicht im GAC installiert, wenn Sie Microsoft Office vor der Installation des .NET Framework (die Teil der Voll ABACUS-Installation) installiert haben. Sie können sie, indem Sie die Option Change for Microsoft Office aus zu installieren Add / Remove Programs, und wählen Sie .NET-Programmieroptionen. Für mehr Informationen, sehen dies Artikel auf MSDN.

Die Baugruppen für die diese Verknüpfung wird unterstützt:

· Zugriff

· Access.Dao

· Übertreffen

· Graph

· MSProject

· Ausblick

· OutlookViewCtl

· OWC11

· Power Point

· Herausgeber

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Word-

It ist nicht ganz klar, ob alle oben genannten Baugruppen sind nützlich, Zimmer wurden alle in dieser Funktion regardeless enthalten, da einige Nutzer Februar haben das Bedürfnis, selbst für die obskuren Baugruppen.

Siehe auch

Simulation von Ihrer Architektur


Verwenden von Makros

Navigation: Simulieren Sie Ihre Architektur>

Verwenden von Makros

Senden Sie Kommentare Zu diesem Thema.

Wenn Sie eine Aufgabe wiederholt in ABACUS durchführen, können Sie die Aufgabe mithilfe eines Makros zu automatisieren. Dementsprechend ist es eine ABACUS Makro eine aufgezeichnete Folge von Operationen, die jederzeit wiedergegeben werden können.

Aufzeichnung eines Makros

1. Wählen Sie Extras | Makro aufzeichnenoder drücken Sie Alt + F10.

2. Starten Durchführung von Operationen, die Sie aufnehmen möchten.

Warnung

Zu diesem Zeitpunkt gibt es einige bekannte Probleme mit Makro-Aufnahme. Bitte nehmen Sie diese in Betracht, wenn die Aufzeichnung Ihrer Makros:

· Derzeit Makros einfach nehmen Sie Ihre Microsoft Windows-Tastatureingaben, Mausbewegungen und Mausklicks. Jedoch aufgrund der Beschränkungen der Makroaufzeichnung selbst, gibt es einige Tasteneingaben, die nicht immer aufgezeichnet werden. Diese beinhalten:

· [Tab]

· [Strg]

· [Alt]

· [Esc]

· [Anfang]

· [F1] bis [F12]

· Es wird daher empfohlen, dass Sie überprüfen, ob eine Tastenkombination wird durch den Makro-Rekorder vor der Aufnahme eine große Folge von Ereignissen, die auf dieser Tastenkombination Arbeits abhängen können aufgezeichnet.

· Derzeit wegen der Beschränkungen mit dem Makro-Rekorder, Kontextmenüs nicht richtig von ABACUS behandelt, wenn sie durch eine Aktion von der Makro-Recorder aufgezeichnet werden geöffnet. Wenn Sie ein Kontextmenü zu öffnen, müssen Sie einen der im Kontextmenü über das Kontextmenü aufgeführten Funktionen durchführen, sonst können Sie das Kontextmenü während der Wiedergabe geöffnet bleiben, was zu unbeabsichtigten Handlungen oder Handlungen, die Fehler bei der ABACUS führen können führen kann.

· Beachten Sie, dass normale Methoden zum Schließen eines Kontextmenü (zB Drücken von [Esc] auf der Tastatur, oder linke Maustaste irgendwo anders auf dem Bildschirm), kann eigentlich nicht das Kontextmenü während der Wiedergabe eines Makros zu schließen.

Spitze

In Dialogen, anstatt Mausklicks, ist es empfehlenswert, die Tab-Taste verwenden, um durch die verfügbaren Kontrollen und die Cursor-Tasten zu bewegen, um Pull-Down-Menüpunkte oder Optionsfelder und die Leertaste auswählen / de-select Check wählen Boxen.

Um die Aufzeichnung eines Makros stoppen

1. Drücken Sie Alt + F9oder alternativ wählen Sie Extras | Stoppen Macro.

2. Im Makro Dialogfeld Speichern unter auf Durchsuchen, um einen Ort und wählen Sie eine ABACUS Makro (.abacusmac Datei) Dateinamen und klicken Sie auf Speichern.

Notiz

Verwendung Tools| Stoppen Macrowird diese Operation in dem aufgezeichneten Makro enthalten. Es wird daher empfohlen, dass Benutzer beherrschen mit Hilfe der Alt + Funktionstaste Optionen für das Arbeiten mit Makros, um nicht unerwünschte Makrooperationen in den Makros selbst gehören zu werden.

Spitze

Da die Makros sind zur Zeit nicht bearbeitet werden, wird empfohlen, langwierige Aufgaben als eine Reihe von separaten Makros mit Alt + F10 / Alt + F9 "Paare" aufzeichnen.

Um ein aufgezeichnetes Makro Playback

1. Wählen Sie Extras | Wiedergabe Macrooder drücken Sie Alt + F8.

2. Im Makro-Dialog Durchsuchen, um einen Speicherort Öffnen und wählen Sie eine ABACUS Makro (.abacusmac Datei) Dateinamen und klicken Sie auf Öffnen.

Warnung

Beim Öffnen eines ABACUS Makro, wenn Sie einen Doppelklick auf einer Makro-Datei aus dem Browse-Dialogfeld, um es zu öffnen, die Makroaufzeichnung können Sie die linke Maustaste in einem linksklickt Zustand, bis eine aufgezeichnete Linksklick Schreibungen dieser Zustand zu halten.

Notiz

Die Wiedergabegeschwindigkeit des Makros können auf der Registerkarte Allgemein unter eingestellt werden Tools| Optionenentweder als Normal (Standard), schnell oder langsam. Schnelle und langsame Wiedergabegeschwindigkeiten sind nicht zu empfehlen, da sie die aufgezeichneten Makros bei etwa 100-mal und 1/100 in Echtzeit wiederzugeben sind. Normale Wiedergabegeschwindigkeit wird immer noch wiederholen Sie den Makro ca. 30% schneller als die aufgezeichnete Geschwindigkeit, so empfiehlt es sich, während der Aufnahme, um für eine kurze Zeit nach jeder längeren Verarbeitungsaufgaben innehalten, dass bei der Wiedergabe die nächste Operation nicht ausgeführt wird, bevor die Verarbeitungsaufgabe hat sicherzustellen, abgeschlossen.

Zum Stoppen der Wiedergabe einer aufgezeichneten Makro

1. Drücken Sie Alt + F9.


Simulieren Leistungs

Navigation: Simulieren Sie Ihre Architektur> Simulatoren>

Simulieren Leistungs

Senden Sie Kommentare Zu diesem Thema.

Hintergrund

Die architektonische Auswerter für die Leistung ist ein diskretes Ereignis-Simulator, der durch die Simulation der Strömung von Nachrichten (oder Token) im ganzen eine Architektur funktioniert. Die Theorie dahinter ist, von der Forschung von der University of Technology, Sydney getan abgeleitet und basiert auf Layered Queuing Netzwerk Models(LQNM) Timed und Coloured Petri-Nets(TCPN) und Aktivitätszyklus Diagrams(ACD).

Im ABACUS Leistungssimulation, wird die Verarbeitung an einem Bauteil weitgehend von Nachrichten, um sie von einer anderen Komponente übergeben angetrieben. Die Prinzipien hinter diesem Verfahren kann in vier Hauptteile zu verstehen:

1. das Nachricht-centricKommunikation ist in ABACUS Verwendung modelliert logisch(oder indirekt) Verbindungen. Logische Verbindungen definieren das Verhalten (Frequenz und Daten) der Nachrichten zwischen den Komponenten geleitet. Ein gutes Beispiel für logische Verbindungen wäre die Folge fließt zwischen zwei (2) Geschäftsprozesse oder die logischen Schnittstellen zwischen zwei (2) Anwendungen.

2. Logische Nachrichten werden an ihren Bestimmungsort transportiert über Hierarchie(wie Ressourcen Swimlanes) oder direktVerbindungen (wie beispielsweise physikalische Leitungen). Um dies können sie auf, verlegt werden über zu tun und wieder nach unten in der Hierarchie (a mehrschichtigen Ansatz), um den direkten Weg zu folgen.

3. Die Wiedergabetreue des Modells eingestellt werden, um zu passen. Zum Beispiel kann ein Prozess so weit nach unten, so dass jede Elementarprozeß und die Funktion hat einen separaten Verarbeitungs Fußabdruck teilen. Alternativ kann es genug, nur einen Wert für den gesamten Prozess zu haben, was die durchschnittlichVerarbeitungs Antwort auf eine Nachricht.

4. Die tatsächliche Verarbeitungwird nur von Komponenten, die einen Prozessor (oder werden) durchgeführt. Ein Prozessor ist eine generische Sache, und könnte eine CPU, eine Person, eine Organisationseinheit oder irgendetwas anderes, das in der Lage ist, die Arbeiten ist sein. Zum Beispiel ist ein Geschäftsprozess keine eigentliche Verarbeitung zu tun; dies wird durch die erste "Prozessor" lokalisiert es entweder in der übergeordneten Hierarchie (wenn ein swimlane Notation verwendet) oder dessen Verarbeitungsnetzwerk (wenn eine verteilte Verarbeitung Notation verwendet) durchgeführt.

Die Auswertung erfolgt durch die Simulation der (angegebenen) Verkehr in dem System, so daß jede Verbindung mindestens einmal simuliert geführt. Ankunftszeiten der Nachrichten werden nach dem Zufallsprinzip in Bezug auf ihre spezifizierten Frequenz erzeugt. Das Modell simuliert Ressourcenverarbeitung und Streit und die Warteschlangen von Nachrichten, das Sammeln von Statistiken auf dem Weg verschiedene Ausgabeeigenschaften.

Key Performance Inputfaktoren

1. Frequenz- Die Frequenz, bei der die Verbindung stattfindet.

2. Verarbeitung- Die Höhe der Ausführungszeit zu einem Vorgang abzuschließen. Dies kann in Stunden, Minuten, Tage, Operationen usw. sein

3. Geschwindigkeit- Die Geschwindigkeit der Prozessorressourcen. Das heißt, wie viele Zyklen / Anleitungen / Aktionen in einer Zeiteinheit durchführen. Es ist wichtig, im Einklang mit den für die Verarbeitung verwendeten Einheiten zu sein.

4. Processors- Die Anzahl der Prozessorressourcen. Prozessoren könnten Menschen, CPUs, externen Organisationen usw. sein

Key Performance Outputfaktoren

1. Durchsatz- Die Anzahl der Nachrichten pro Zeiteinheit durch die Verbindung. Dieser Istwert kann die zu erwartende / theoretische Werte (dh Frequenz) verglichen werden, um eine Sättigung des Systems abzuleiten.

2. Nachricht Bewertung- Die Anzahl der Nachrichten pro Zeiteinheit durch die Komponente. Dies ist die Summe der ein- und ausgehenden Nachrichten aller Komponenten ".

3. Antwort- Die minimale / durchschnittliche / maximale Latenz für diese Verbindung. Dies ist die Summe aller beobachteten Verzögerungen für die Verbindung von der Quelle zur Senke und jeder Warteschlangen und Verarbeitung (und Latenz zur Quelle zurück, wenn bidirektional).

4. Verwendung- Die Ausnutzung der Komponente. Dies wird 0%, wenn die Komponente nicht eine Vorrichtung / Prozessor (dh es muss nicht die Prozessoren und Geschwindigkeitseigenschaften oben definiert).

Während einer diskreten Ereignissimulation durchgeführt, um die verschiedenen Leistungseigenschaften zu berechnen, wie oben beschrieben, kann die folgende Formel als eine grobe Überprüfung der Ergebnisse (in dem das System nicht gesättigt ist) verwendet werden:

Nutzung = Summe der Frequenz für alle eingehenden Verbindungen * Verarbeitung / (Speed ​​* Processors)

Das Gesamtkonzept ist vielleicht am besten durch Betrachtung der folgenden Abbildung, die zwei verschiedene Leistungs Metamodelle zeigt demonstriert. Die linke Hand-Stil ist der Klassiker "Swimlane" Notation mit Verarbeitungsaufgaben hierarchisch innerhalb ihrer Prozessor-Ressourcen basiert. Die rechte Hand Stil ist eine "verteilt" Notation mit den Verarbeitungsaufgaben über eine Verbindung zu ihren Prozessen Prozessorressourcen verbunden. Diese letztere Schreibweise können mehrere Prozessorressourcen für eine bestimmte Verarbeitungsaufgabe, im Gegensatz zu der begrenzten Swimlane-Notation.

Notiz

Dargestellt auf jedes Metamodell sind die Eingabeeigenschaften (in rot) und Ausgangseigenschaften (in blau):

Performance-Meta-Modelle: Swimlane gegen Distributed-Notation

Das Ausführen des Performance-Simulator

Ihre Architektur in Bezug auf Leistung zu simulieren

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Auswählen Analyse| Performanceoder klicken Sie auf die Schaltfläche in der Symbolleiste.

3. Wähle aus ArchitekturSie aus dem Pull-Down-Menü bewerten möchten.

Notiz

Standardmäßig wird ABACUS automatisch die erste Architektur, für die eine erneute Simulation wird aufgrund einer zugrunde liegenden Immobilie oder strukturelle Änderungen erforderlich wählen.Diese Hervorhebung wird in gezeigt, Rot auf dem Simulation Symbolleiste .

4. Wähle aus Components und AnschlüsseSie auswerten möchten, aus der Standard-Element-Auswahlfenster .

5. Stellen Sie die Run Time Scale Factor Schieberegler.

Notiz

Höhere Werte statistisch konsistente Ergebnisse liefern, aber nehmen mehr Zeit, um zu berechnen.

Weitere Checkbox zum Standard-Element-Auswahlfenster

· Save transformierten Modell werden speichern Sie eine Kopie des RBD transformierte Version des Projekts im gleichen Ordner wie das aktuelle Projekt und fügen Sie "_transformiert" auf den Projektnamen.Diese verwandelt Projekt kann verwendet werden, um im Detail zu diagnostizieren die Zuverlässigkeit Simulation von ABACUS vorgenommen werden.

Andere Optionen, um die Standard-Element-Auswahlfenster

· Run Time Scale Factor steuert die Simulationszeit und Genauigkeit bei höherer Werte Ertragingmehr statistisch konsistente Ergebnisse, aber Einnahme längere Zeit, um Lauf.

Notiz

Wenn ABACUS berechnet die Simulationszeit wird es die langsamste indirekte Verbindung Frequenz, die ausgewählt wurde, um simuliert werden "Warm-up" für den Zeitraum (dh 1 über die Frequenz) dieser Verbindung zu bestimmen und dann (Einleitung periodische Nachricht Generatoren für alle Verbindungen nach dem Zufallsprinzip während dieser Aufwärmzeit, indem sie ihnen allen eine Chance zu initiieren) und Simulation für die Laufzeit-Skalierungsfaktor-fache der Periode dieser Verbindung dann. Oder (1 / Frequenz) Aufwärmzeit + (1 / Frequenz) * Laufzeit-Skalierungsfaktor Simulationszeit. Dies ist, um sicherzustellen, dass, dass alle Verbindungen initiiert, bevor Statistiken werden gesammelt und dann die langsamste Verbindung noch mindestens einmal in der Simulation nachgebildet. Z.B. Wenn der langsamste indirekte Verbindung hat eine Frequenz von 0,033 Zeiteinheiten (oder ca. einmal im Monat, wenn die Zeiteinheiten sind Tage) wird die Aufwärmzeit werden 30,3 Zeiteinheiten und die Simulationszeit werden 30,3 Zeiteinheiten Zeiten Die Laufzeit-Skalierungsfaktor.

6. Klicken Fertigund Sie erhalten eine Warnung Dialog.

7. Die Warnungen wahlweise zu erkunden, indem Sie Details >>.

8. Klicken Fortsetzen.

Notiz

An diesem Punkt wird ABACUS einen diskreten Ereignissimulation der Architektur durchzuführen und nach kurzer Zeit (mit Fortschrittsbalken für die Rückführung) eine Berechnung abgeschlossen Dialog erscheint.

9. Klicken OKum die Simulation zu quittieren.

Spitze

Für Schulungen und weitere Hilfe bei den Performance-Simulation finden Sie im Handbuch Avolution Gemeinschaft .

Komponenteneigenschaften

Die folgende Tabelle listet die erforderlich ist, um Leistung zu bewerten Eigenschaften. Die Eigenschaften sind für die erste in der Komponenteninstanzen gesucht, dann die Komponente Standards und wenn nicht gefunden, wird der Standardwert verwendet.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Eingabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Performance-Input '. Eine Änderung einer dieser 'input' Eigenschaften und verschiedene strukturelle Änderungen in das Repository wird in der Performance-Simulator eine erneute Simulation erfordern führen, wie in angedeutet Rot auf dem Simulation Symbolleiste .

Art | Name | Standardwert | Einheit | Dateityp | Erforderlich | Beschreibung
Verhalten | b_pack | 0.0 |  | Dezimal | Falsch | Die feste Service-Zeit in Sekunden zu packen. Diese Immobilie typischerweise als Standard-Typ festgelegt und dann für mehrere Komponenteninstanzen eingesetzt. Zum Beispiel hat CORBA b_pack = 0,23 ms.
Verhalten | m_pack | 0.0 |  | Dezimal | Falsch | Die variable Dienstzeit in Sekunden / Byte zu packen. Diese Immobilie typischerweise als Standard-Typ festgelegt und dann für mehrere Komponenteninstanzen eingesetzt.
Verhalten | b_unpack | 0.0 |  | Dezimal | Falsch | Die feste Servicezeit in Sekunden auszupacken. Diese Immobilie typischerweiseals Standard-Typ festgelegt und dann für mehrere Komponenteninstanzen eingesetzt.
Verhalten | m_unpack | 0.0 |  | Dezimal | Falsch | Die variable Dienstzeit in Sekunden / Byte entpacken. Diese Immobilie typischerweiseals Standard-Typ festgelegt und dann für mehrere Komponenteninstanzen eingesetzt.
Verhalten | Verarbeitung | 0.0 |  | Dezimal | Wahr | Die Höhe der Bearbeitungszeit zu einem Vorgang abzuschließen. Dies kann in Stunden, Minuten, Tage, Operationen usw. sein
Verhalten | Processors | 1 |  | Ganze Zahl | Wahr | Der Anzahl der Prozessorressourcen. Prozessoren könnten Menschen, CPUs, externen Organisationen usw. sein
Verhalten | Geschwindigkeit | 100 |  | Ganze Zahl | Wahr | Die Geschwindigkeit der Prozessorressourcen. Das heißt, wie viele Zyklen / Anleitungen / Aktionen in einer Zeiteinheit durchführen. Es ist wichtig, im Einklang mit den für die Verarbeitung verwendeten Einheiten zu sein.
Verhalten | k_bkgd | 0.0 |  | Dezimal | Falsch | Hintergrundverarbeitung auf dem Bauteil. Dies wird verwendet, um die Ergebnisse anpassen, um keine festen Offsets für% entsprechen. Dies kann wohl ignoriert.

Die folgende Tabelle listet die Komponenteneigenschaften, ausgegeben durch den Leistungsbewertungs. Für jede Komponente auf jedem Leistungslauf sind eine Reihe von diesen Komponenteneigenschaften erzeugt.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Performance-Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und der Performance-Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Verhalten | Nachricht Bewertung |  | Dezimal | Falsch | Die Anzahl der Nachrichten pro Zeiteinheit durch das Bauteil. Dies ist die Summe der ein- und ausgehenden Nachrichten aller Komponenten ".
Verhalten | Bandwidth |  | Dezimal | Falsch | Gesamtbandbreite durch das Bauteil. Die Summe aufgrund von eingehenden und ausgehenden Nachrichten.
Verhalten | Verwendung | % | Dezimal | Falsch | Die Nutzung der Komponente. Dies wird 0%, wenn die Komponente nicht ein Gerät / Prozessor (dh es muss nicht Processors und oben definierten Geschwindigkeit Objekte)

Verbindungseigenschaften

Die folgende Tabelle listet die erforderlich ist, um Leistung zu bewerten Eigenschaften. Immobilien suchen zunächst in den Anschluss Fällen, wird die Verbindung Normen und, wenn nicht gefunden, wird der Standard verwendet gesucht.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Eingabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Performance-Eingang" oder "Preis- / Leistungs Input '. Eine Änderung einer dieser 'input' Eigenschaften und verschiedene strukturelle Änderungen in das Repository wird in der Performance-Simulator führen und / oder Kostensimulator erfordert eine erneute Simulation, wie in angegeben Rot auf dem Simulation Symbolleiste .

Art

Name

Standardwert

Einheit

Dateityp

Erforderlich

Beschreibung

Verhalten

Art

bidirektionale

[Bidirektionale | unidirektionale]

Lookup / Liste

Wahr

Ob die Verbindung bidirektional ist (bidirektional) oder Einweg (unidirektional).

Die zulässigen Werte für diese Eigenschaft sind "bidirektional" oder "einseitig".

Bidirektionale bedeutet synchronen Request / Response-Nachrichten in der Erwägung, einseitig gerichteten Mitteln eine einzelne asynchrone "Ereignis".

Verhalten

Abstraktion

indirekt

[indirekten | direkt]

Lookup / Liste

Wahr

Ob die Verbindung physischer oder logischer. Direkte Verbindungen sind physische "Rohre" zwischen zwei Komponenten, die logische Verbindungen entlang.

Die zulässigen Werte für diese Eigenschaft sind "direkte" oder "indirekte".

Ist der Wert "direkt" wird die Verbindung benötigt keine anderen Eigenschaften (mit Ausnahme der Immobilien Bild Art und Abstraktion).

Daten

L_app1

0

Ganze Zahl

Falsch

Request / Ereignisgröße in Byte.

Jede Verbindung weist typischerweise einen spezifischen Wert für diese. In CORBA, sind Ereignisse tatsächlich bidirektional und haben einen 12 Byte zu bestätigen (L_app2) immer. Wenn es eine wahre unidirektionale Verbindung, dann lassen Sie die Eigenschaft L_app2.

Daten

L_app2

0

Ganze Zahl

Falsch

Response / anerkennen Größe in Byte.

Jede Verbindung weist typischerweise einen spezifischen Wert für diese. Eine unidirektionale Verbindung nicht haben L_app2.

Verhalten

Frequenz

1

Dezimal

Wahr

Die Frequenz, bei der die Verbindung stattfindet.

Jede Verbindung weist typischerweise einen spezifischen Wert für diese. Wenn die Eigenschaft Frequency wird dann links der Standardwert verwendet.

Verhalten

Beziehung

Prozesse

[Prozesse | unterstützt]

Lookup / Liste

Falsch

Verbindungen, die "Prozesse" Eigenschaft aufweisen anzuzeigen, dass die Komponente an dem Anfang der Verbindung werden umgewandelt, um die Komponente an dem Ende der Verbindung verarbeitet werden. In der Tat die "Quelle" Komponente bewegt wird, um ein Kind der "sink" Komponente (die angebrachten Verbindungen werden auch "gezogen" Mit diesem Schritt) zu werden.

Wenn ein "Prozesse" Eigenschaft vorhanden ist, dann alle anderen Verbindungseigenschaften werden ignoriert, mit Ausnahme der unten beschriebenen optionalen "%" Eigentum.

Verhalten

%

100,0

Dezimal

Falsch

Verbindungen, die "Prozesse" -Eigenschaft (oben beschrieben) aufweisen kann optional eine "%" Eigenschaft, um den Anteil der Verarbeitung, die die Zielkomponente übertragen werden oder anzuzeigen. Auf diese Weise kann eine einzelne Quellkomponente von mehreren Zielkomponenten an verschiedenen% 's verarbeitet werden. Die% -Werte müssen nicht bis zu 100% zu addieren und es wird einfach verwendet, um die Signalquelle zu skalieren die "Verarbeitung" Eigenschaft (siehe oben), wie sie transformiert, um ein Kind der Zielkomponente zu werden.

In der folgenden Tabelle sind die von der Leistungsbewertungs erzeugten Objekte. Für jede Verbindung auf jedem Leistungslauf sind eine Reihe von diesen Verbindungseigenschaften erzeugt.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Performance-Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und der Performance-Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Verhalten | Bandwidth |  | Dezimal | Falsch | Die Gesamtbandbreite für die Verbindung. Dies wird nur für indirekte Verbindungen berechnet und ist im Wesentlichen (L_app1 + L_app2) * Durchsatz.
Verhalten | Bandbreite 1/2 |  | Dezimal | Falsch | Die Bandbreite speziell für ausgehende (1) und ankommende (2) Nachrichten der Verbindung. Dies wird nur für indirekte Verbindungen berechnet und ist im Wesentlichen L_app1 * Durchsatz und L_app2 * Durchsatz.
Verhalten | Durchsatz |  | Dezimal | Falsch | Die Anzahl der Nachrichten pro Zeiteinheit durch die Verbindung. Dieser Istwert kann die zu erwartende / theoretische Werte (dh Frequenz) verglichen werden, um eine Sättigung des Systems abzuleiten.
Verhalten | Fertiggestellt | % | Dezimal | Falsch | Der prozentuale Anteil der Nachrichten, die erfolgreich Komplettbearbeitung für die Verbindung. Dies wird nur für indirekte Verbindungen berechnet und ist die Durchsatzleistung / Frequenz. Gelegentlich wird die Completed Wert übersteigt 100%, weil die Zufälligkeit der Nachrichtenerzeugung führt zu einer etwas höheren Nachrichtenerzeugungsfrequenz als angegeben.
Verhalten | Response (Min / Ave / Max) |  | Dezimal | Falsch | Die minimale / durchschnittliche / maximale Latenz. Dies wird nur für indirekte Verbindungen berechnet und ist die beobachtete Latenz für die Verbindung von der Quelle zur Senke und jedem Queueing und Verarbeitung (und Latenz zurück an die Quelle, wenn bidirektional).

Architektur Immobilien

Die folgende Tabelle listet die systemweiten Architektureigenschaften von der Performance Evaluator erzeugt. Ein einzelner Satz von Eigenschaften für die Architektur werden für jede Performance-run "aggregiert".Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Performance-Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und der Performance-Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Verhalten | Nachricht Bewertung |  | Dezimal | Falsch | Die Anzahl der Nachrichten pro Zeiteinheit durch die Komponenten in der Architektur. Dies ist die Summe der ein- und ausgehenden Nachrichten aller Komponenten ".
Verhalten | Durchsatz |  | Dezimal | Falsch | Die Anzahl der Nachrichten pro Zeiteinheit durch die Verbindungen in der Architektur. Dies ist die Summe aller indirekte Verbindungen "Durchsätze und dieser Istwert kann der voraussichtlichen / theoretische Werte (zB Frequenz) verglichen werden, um eine Sättigung des Systems abzuleiten.
Verhalten | Bandwidth |  | Dezimal | Falsch | Die Gesamtbandbreite. Summe der Verbindungsbandbreiten der Architektur.
Verhalten | Verwendung | % | Dezimal | Falsch | Die Nutzung aller Komponenten. Kann größer als 100% sein, da es nur die Summe aller Komponenten Nutzungen der Architektur.
Verhalten | Response (Min / Ave / Max) |  | Dezimal | Falsch | Die minimale / durchschnittliche / maximale Latenz. Summe aller beobachteten Latenzen für Verbindungen der Architektur von der Quelle zur Senke (und zurück zu Quelle, wenn bidirektional).


Simulieren Modularität

Navigation: Simulieren Sie Ihre Architektur> Simulatoren>

Simulieren Modularität

Senden Sie Kommentare Zu diesem Thema.

Die Modularität Simulator berechnet die Anzahl der eingehenden und ausgehenden Verbindungen für jede Komponente.

Ihre Architektur in Bezug auf Modularität simulieren

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Auswählen Analyse| Modularität.

3. Wählen Sie das Architektur (en)Sie wollen in der Bewertung enthalten.

Notiz

Standardmäßig wird ABACUS automatisch die Architektur (en), für die eine erneute Simulation aufgrund irgend zugrunde liegenden strukturellen Änderungen erforderlich wählen.Diese Hervorhebung wird in gezeigt, Rot auf dem Simulation Symbolleiste .

4. Klicken Nächster.

5. Wählen Sie das Verbindungstypen (n)Sie wollen in der Bewertung enthalten.

6. Klicken Nächster.

7. Optional passen Sie die Eigenschaftennamen für die Berechnungsergebnisse.

8. Klicken Fertig.

Notiz

An diesem Punkt wird ABACUS eine strukturelle Bewertung der Architektur (en) durchzuführen und nach kurzer Zeit (mit Fortschrittsbalken für die Rückführung) eine Berechnung abgeschlossen Dialog erscheint.

9. Klicken OKum die Auswertung zu bestätigen.

Spitze

Für Schulungen und weitere Hilfe auf Modularität Auswertung finden Sie im Handbuch Avolution Gemeinschaft .

Komponenteneigenschaften

Die folgende Tabelle listet die Komponenteneigenschaften, die durch die Modularität Evaluator ausgegeben werden.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Modularität Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Strukturwandel in das Repository und die Modularität Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Dateityp | Erforderlich | Beschreibung
Modularität | Kupplung-fan in (lokalen) | Ganze Zahl | Falsch | Anzahl der Verbindungen, Ventilator in dieser Komponente.
Modularität | Kupplung-Lüfter aus (lokal) | Ganze Zahl | Falsch | Anzahl der Verbindungen, Lüfter aus dieser Komponente.
Modularität | Kupplung-fan in | Ganze Zahl | Falsch | Anzahl der Verbindungen, Ventilator in dieser Komponente, einschließlich Verbindungen, die Lüfter in Unterkomponenten.
Modularität | Einkopplung auffächern | Ganze Zahl | Falsch | Anzahl der Verbindungen, Lüfter aus dieser Komponente, einschließlich Verbindungen, die Lüfter in Unterkomponenten.


Simulation von Total Cost of Ownership (TCO)

Navigation: Simulieren Sie Ihre Architektur> Simulatoren>

Simulation von Total Cost of Ownership (TCO)

Senden Sie Kommentare Zu diesem Thema.

Hintergrund

Total Cost of Ownership (TCO) ist ein Finanzschätzung, entworfen, um die gesamten anfallenden Lebenszykluskosten (von der Akquisition bis zur Stilllegung / Entsorgung) mit über Vermögenswerte zu bemessen. TCO spiegelt nicht nur die Anschaffungskosten, es enthält auch alle anderen Aspekte bei der weiteren Nutzung und Wartung des Vermögenswertes.

TCO wird verwendet, um den Aufwand zu bestimmen und Budgetkosten erforderlich sind, um auf einem System zu verbringen. Eine einfache Möglichkeit der Modellierung in ABACUS für TCO ist es, die IT-System in Komponenten brechen. Wir können dann herauszufinden, wie viel im Durchschnitt es um eine dieser Komponenten laufen Kosten. Danach konnten wir dann Faktor bei unterschiedlichen Kosten je nachdem, ob das IT-System ist evolvable oder öffnen usw. Wenn ein System bereits in Betrieb, ist der wichtigste Faktor zu berücksichtigen, die Kosten für die Wartung und vielleicht die Kosten, um außer Betrieb nehmen.

Ein Beispiel

Diagramm der Musterberechnung

Die Komponente unter Organisation oder seine Standard hat folgende Eigenschaften:

· FTE= $ 100 000 / Jahr

· Support Effort= 0,01 + 0,001 FTE FTE / Jahr = 1000 $ + 100 $ / Jahr

· Unterhaltskosten= 100 $ - 10 $ / Jahr

· Kapitalkosten= 2000 $

· Installieren Effort= 2 FTE / Tag = 0,01 FTE / Jahr = 1000 $

Die Komponente unter Organisation hat folgende Eigenschaften:

· Installieren Horizon= -2 Jahre (dh Das System wurde 2 Jahre vor dem aktuellen installiert)

· Lebensdauer= 3 Jahre

Wenn Installieren Horizon + Lebensdauer <= 0 Gibt es keine weitere Wartungskosten.

Berechnungen

Die Berechnungen sind wie folgt:

Notiz

TC = die Kosten pro Jahr. SE = Unterstützung Effort. MC = Wartungskosten.

· Erste Kosten = Kapitalkosten + Installieren Effort= 2000 + 1000 = 3000 $

· Bei t = -2 (während der 1. Jahr) TC = Anfangskosten + SE + MC= 3000 + 1000 + 100 = 4100 $

· Bei t = -1, TC = SE + MC= (1000 + 100) + (100-10) = 1190 $

· Bei t = 0, TC = (1000 + 200) + (100-20) = 1280 $

· Bei t = 1 (Abschlussjahr), TC = (1000 + 300) + (100-30) = 1370 $

Graph für Beispiel Berechnung

TCO ist die Summe aller gegenwärtigen und künftigen Kosten, bis das System außer Betrieb genommen wurde.

· Bei t = -2 (während der 1. Jahr), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Bei t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Bei t = 0, TCO = 1280 + 1370 = 2650 $

· Bei t = 1 (Abschlussjahr), TCO = 1.370 $

Key Kostenfaktoren

Die wichtigsten Kostenfaktoren, um bei der Berechnung der Gesamtbetriebskosten eines Vermögenswertes in ABACUS sind zu berücksichtigen:

· Hardware Acquisition- Initial Kosten der Ausrüstung (Kapitalkosten).

· Software Acquisition- Anfängliche Kosten für die Lizenz für die Software (Kapitalkosten).

· Installation- Kosten im Zusammenhang mit der Ersteinrichtung verbunden.

· Ausbildung- Kosten für externe Anbieter Training nach der Ersteinrichtung verbunden.

· Unterstützen- Kosten mit interner Unterstützung verbunden.

· Instandhaltung- Kosten zu ersetzen oder Upgrade der Anbieter Wartungsverträgen, Lieferungen und Disaster-Recovery-Kosten.

· Infrastructure- Kosten im Zusammenhang mit Unterstützung des Asset.

ABACUS Beispiel Darstellung der Key Kostenfaktoren

Das Ausführen des Kostensimulator

Ihre Architektur in Bezug auf die Kosten simulieren

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Auswählen Analyse| Kosten.

3. Wählen Sie das Architektur (en)Sie wollen in der Bewertung enthalten.

Notiz

Standardmäßig wird ABACUS automatisch die Architektur (en), für die eine erneute Simulation wird aufgrund einer zugrunde liegenden Immobilie oder strukturelle Änderungen erforderlich wählen.Diese Hervorhebung wird in gezeigt, Rot auf dem Simulation Symbolleiste .

4. Wähle aus Währungaus dem Pull-Down.

5. Beweg das Jahre zu berechnen,Schieberegler, um die Anzahl der Jahre erforderlich.

Notiz

Standardmäßig ist, wenn die Jahre zu berechnen, mehr als 1 Jahr Die Kosten werden automatisch für jedes einzelne Jahr berechnet werden (und eine Sammlung von Eigenschaften hinzugefügt / aktualisiert) und dann eine kumulative Wert für die gesamte Anzahl von Jahren berechnet. Wenn nur der kumulative Wert wird benötigt, dann deaktivieren Sie das Kontroll Berechnen Per-Jahr KostenOption, wie unten beschrieben, auf die Anzahl der Objekte im Projekt zu speichern.

6. Wählen Sie, ob zu verlassen Berechnen Per-Jahr Kostenprüft oder deaktivieren Sie es.

7. Klicken Nächster.

8. Wahlweise wählen, die AnschlüsseSie Kosten zusammen als Teil der Auswertung Attribut wollen.

Notiz

Verwendung einer Cost | ZuschreibungEigentum an den Anschlüssen Kosten kann sein zugeschrieben von der Komponente an den Senken Ende der Verbindung mit dem Bauteil zu dem Quellenende befestigt(dh Kosten | Attribution = "Sink zur Source") oder von der Komponente auf die beigefügten Quelle Ende der Verbindung mit dem Bauteil auf die beigefügten sinken Ende(das heißt Cost | Attribution = "Quelle zur Senke"). Hinzu kommt noch, ABACUS wird automatisch diese Verbindungen wählen Sie mit einem Behaviour | Relationship = "Prozesse" oder "Träger"und die Richtung der Zuschreibung wird "Sink um Quellenangabe". Darüber hinaus sind die Kosten aufgeteilt nach Behaviour | % Oder Cost | % Eigenschaften auf die Verbindungen, oder alternativ, wenn es mehrere Verbindungen von einem Senken vielen Quellenoder die Quelle zu vielen Waschbecken, Nach Behaviour | Verarbeitungseigenschaften auf die Source-Komponentenoder sinken Komponenten jeweils.

9. Klicken Fertigund Sie erhalten eine Warnung Dialog.

10. Die Warnungen wahlweise zu erkunden, indem Sie Details >>.

11. Klicken Fortsetzen.

Notiz

An diesem Punkt wird ABACUS eine Prozesskostenrechnung Auswertung der Architektur (en) durchzuführen und nach kurzer Zeit (mit Fortschrittsbalken für die Rückführung) eine Berechnung abgeschlossen Dialog erscheint.

12. Klicken OKum die Auswertung zu bestätigen.

Spitze

Für Schulungen und weitere Hilfe auf Kosten Simulation finden Sie im Handbuch Avolution Gemeinschaft .

Komponente und / oder Anschluss Immobilien

Die folgende Tabelle listet die Komponente und / oder die Verbindung Eigenschaften erforderlich, um Kosten zu bewerten.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Eingabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Kosten Input '. Eine Änderung einer dieser 'input' Eigenschaften und verschiedene strukturelle Änderungen in das Repository werden in der Kostensimulator eine erneute Simulation erfordern führen, wie in angedeutet Rot auf dem Simulation Symbolleiste .

Art

Name

Standardwert

Einheit

Dateityp

Erforderlich

Beschreibung

Kosten

Installieren Horizon

0

Jahre

Ganze Zahl

Wahr

Gibt an, wann die Komponente oder die Verbindung worden ist oder installiert werden soll.

· Der Wert 0 (Standardwert) zeigt an, dass die Komponente oder die Verbindung wird im laufenden Jahr installiert.

· Ein Wert kleiner als 0 gibt an, dass die Komponente oder die Verbindung wurde in der Vergangenheit installiert.

· Ein Wert größer als 0 gibt an, dass die Komponente oder die Verbindung wird in der Zukunft installiert werden.

Kosten

Lebensdauer

0

Jahre

Ganze Zahl

Wahr

Gibt die Länge der Zeit, in der die Komponente oder die Verbindung wird in Betrieb bleiben, nach dem es außer Betrieb genommen werden.

Kosten

FTE

100.000,00

$ / Jahr

Dezimal

Falsch

Die jährlichen Kosten der jeweiligen Vollzeit Festanstellung.

Wenn diese Eigenschaft nicht in der Komponente gefundenselbst oder im Falle der Verbindungen der Komponente und dem Senken Ende der Verbindung angeschlossen, Wird es für die in anderen Komponenten durchsucht werden.

Erstens, any 'sink' Komponentes am Ende von a Verbindung mit einem "Träger" -Beziehung auf die Komponente gesucht wird, gefolgt von dass "sink" Eltern-Komponentes.

Wenn der FTE-Eigenschaft nicht gefunden wird, die die Komponente Elternteil-Komponenten werden dann durchsucht werden. Wenn FTE ist immer noch nicht gefunden wird, wird der Standardwert verwendet.

Bitte beachten Sie: FTE ist nur eine gültige Eingabe Immobilie auf Komponenten.

Kosten

Wartungskosten (fest)

0.00

$ / Jahr

Dezimal

Falsch

Die jährliche feste Kosten für die Instandhaltung der Komponenteoder die Verbindung.

Kosten

Wartungskosten (variabel)

0.00

$ / Jahr

Dezimal

Falsch

Der Betrag, um die Gesamtkosten für die Aufrechterhaltung der Komponenten oder die Verbindung wird jedes Jahr ändern.

Zum Beispiel wird ein Wert von $ -500 zeigt an, dass die Gesamtwartungskosten von 500 $ pro Jahr ab, während ein Wert von $ 500 an, dass die Gesamtwartungskosten erhöht sich um 500 $ pro Jahr.

Kosten

Support Effort (fest)

0.00

FTE / Jahr

Dezimal

Falsch

Die jährliche feste Anstrengungen zur Unterstützung der Komponenteoder die Verbindung, In Bezug auf die Personen-Jahre festgelegt.

Kosten

Support Effort (variabel)

0.00

FTE / Jahr

Dezimal

Falsch

Der Betrag, um den Gesamtaufwand der Unterstützung der Komponente oder die Verbindung wird jedes Jahr ändern.

Zum Beispiel wird ein Wert von -0,01 zeigt an, dass die Gesamtbetreuungsaufwand von 0,01 Personenjahre pro Jahr ab, während ein Wert von 0,01 zeigt, dass die Gesamtbetreuungsaufwand erhöht sich um 0,01 pro Jahr.

Kosten

Kapitalkosten

0.00

$

Dezimal

Falsch

Die Kosten für den Kauf der Komponenteoder die Verbindung.

Kosten

Installieren Effort

0.00

FTE

Dezimal

Falsch

Der Aufwand in Personenjahren, um die Komponente zu installierenoder die Verbindung.

Die folgende Tabelle listet die Komponente und / oder die Verbindung Eigenschaften, die von der TCO Auswerter ausgegeben werden. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Cost Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und die Kosten Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Notiz

Wo die Leistungseigenschaften von der TCO Evaluator sein müssen, "gerundet" die "Round Halb sogar" Ansatz (auch als "Banker Rundungs ​​genannt) wird verwendet,.Diese Technik wird verwendet, um jede 0,5 gleichmäßiger zu beheben "Tie-Breaks" wobei das Ergebnis nach oben oder unten auf die nächste abgerundet sogar Ergebnis, anstatt immer Rundung und Neigen Sie das Ergebnis. D.h. 2.5 ist auf 2 abgerundet, während 3,5 bis auf 4 abgerundet, anstatt sie beide entweder abgerundet auf 2 und 3 oder bis zu 3 und 4 abgerundet ist.

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Kosten | Gesamtkosten zu arbeiten - neben x Jahren. | $ | Ganze Zahl | Falsch | Die Gesamtbetriebskosten in den nächsten xJahre, wobei x die Länge der Zeit festgelegt bei der Ausführung des Evaluators. Dies schließt die Kosten der Komponente oder eine Verbindung von Standards Subkomponentenoder Teilverbindungen(d.h. Kinder) und alle zugeschrieben Kosten.
Kosten | Gesamtkosten zu arbeiten (lokal) - nächsten x Jahren. | $ | Ganze Zahl | Falsch | Der "lokale" Cost of Ownership in den nächsten xJahre, in denen xist die Länge der angegebenen Zeit bei der Ausführung des Evaluators. Dies tut nichtund die Kosten für Teilkomponenten der Komponente oder Sub-Anschlüsse-Verbindung (d.h.Kinder) oder irgendwelche zurückzuführen Kosten.
Kosten | Gesamtkosten zu arbeiten (Kinder) - nächsten x Jahren. | $ | Ganze Zahl | Falsch | Die "Kinder" Cost of Ownership in den nächsten xJahre, wobei x die Länge der Zeit festgelegt bei der Ausführung des Evaluators. Dies nur auch die Kosten für Teilkomponenten der Komponente oder Sub-Anschlüsse-Verbindung (d.h. Kinder).
Kosten | Gesamtkosten zu arbeiten (zugeschrieben) - nächsten x Jahren. | $ | Ganze Zahl | Falsch | Die "zugeschrieben" Cost of Ownership in den nächsten xJahre, wobei x die Länge der Zeit festgelegt bei der Ausführung des Evaluators. Dies nur enthält keine zugerechnet Kosten von den angeschlossenen Komponenten(die natürlich gehören zurückzuführen möglicherweise Kosten alle angeschlossenen Verbindungen).

Die folgende Tabelle listet die Komponente und / oder die Verbindung Eigenschaften, die von der TCO Auswerter ausgegeben werden,wenn das berechnen Per-Jahr Kosten Option ausgewählt ist. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Cost Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und die Kosten Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Notiz

Lesen Sie den Hinweis über die mögliche Rundung der Ausgabeeigenschaften.

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Kosten | Gesamtkosten zu arbeiten - Jahrx. | $ | Ganze Zahl | Falsch | Die Total Cost of Ownership für Jahr x, Wobei x für jedes Jahr angegeben bei der Ausführung des Evaluators. Dies schließt die Kosten der Komponenteoder eine Verbindung von Standards Subkomponenten oder Teilverbindungen (d.h. Kinder) und alle zugeschrieben Kosten.
Kosten | Gesamtkosten zu arbeiten (lokal) - Jahrx. | $ | Ganze Zahl | Falsch | Der "lokale" Cost of Ownership für Jahr x, woher xist für jedes Jahr angegeben bei der Ausführung des Evaluators. Dies tut nichtund die Kosten für Teilkomponenten der Komponente oder Sub-Anschlüsse-Verbindung (d.h. Kinder) oder irgendwelche zurückzuführen Kosten.
Kosten | Gesamtkosten zu arbeiten (Kinder) - Jahrx. | $ | Ganze Zahl | Falsch | Die "Kinder" Cost of Ownership für Jahr x, Wobei x für jedes Jahr angegeben bei der Ausführung des Evaluators. Dies nur auch die Kosten für Teilkomponenten der Komponente oder Sub-Anschluss-Verbindung (d.h. Kinder).
Kosten | Gesamtkosten zu arbeiten (zugeschrieben) - Jahrx. | $ | Ganze Zahl | Falsch | Die "zugeschrieben" Cost of Ownership für Jahr x, Wobei x für jedes Jahr angegeben bei der Ausführung des Evaluators. Dies nur enthält keine zugerechnet Kosten von den angeschlossenen Komponenten(die natürlich gehören zurückzuführen möglicherweise Kosten alle angeschlossenen Verbindungen).

Weitere Verbindungseigenschaften

In der folgenden Tabelle zusätzlich Verbindungseigenschaften, die durch die TCO Evaluator benötigt werden. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Eingabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Preis- / Leistungs Input 'oder' Kosten Input '. Eine Änderung einer dieser 'input' Eigenschaften und verschiedene strukturelle Änderungen in das Repository wird in der Kosten führen und / oder Performance-Simulator erfordert eine erneute Simulation, wie in angegeben Rot auf dem Simulation Symbolleiste .

Art

Name

Standardwert

Einheit

Dateityp

Erforderlich

Beschreibung

Kosten

Zuschreibung

Sinken auf Quelle

[Quelle zur Senke | Sinken auf Source]

Lookup / Liste

Wahr

Ob "Quelle zur Senke"Diese Verbindung werden haben haben Kostenszugeschrieben 'zusammen' es von dem QuelleKomponente zum sinken Komponente. Alternativ, wenn "Sinken auf Quelle"Diese Verbindung werden haben Kosten "zusammen" zugeschrieben es vom Senkenkomponente der Quellkomponente.

Verhalten

Beziehung

Halterungen

[Prozesse | unterstützt]

Lookup / Liste

Falsch

Wenn "Träger" ist, zeigt diese Verbindung, dass "Quelle" Komponente durch die "Senke" Komponente unterstützt.

Außerdem, wenn Sie entweder "Träger" oder "Prozesse", dann wird die Verbindung automatisch in den Verbindungen ausgewählt werden, um ihre Kosten für zugeschrieben 'zusammen' aus dem Waschbecken-Komponente auf die Signalquelle.

Kosten

%

100,0

%

Dezimal

Falsch

Zeigt den Anteil eines Senkenkomponentenkosten, die mit der Source-Komponente zurückzuführen ist. Die% -Werte müssen nicht bis zu 100% zu addieren und es wird einfach verwendet werden, um die Skala "Total Cost zu arbeiten -. X nächsten Jahre" Eigenschaft (siehe oben) von der Senkenkomponente, wie sie mit der Source-Komponente zurückzuführen.

Architektur Immobilien

In der folgenden Tabelle sind die Eigenschaften, die Architektur von der TCO Evaluator ausgegeben werden. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Cost Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und die Kosten Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Notiz

Lesen Sie den Hinweis über die mögliche Rundung der Ausgabeeigenschaften.

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Kosten | Gesamtkosten zu arbeiten - neben x Jahren. | $ | Ganze Zahl | Falsch | Die Gesamtbetriebskosten der gesamten Architektur in den nächsten x Jahren.

Die folgende Tabelle zeigt die Architektur Eigenschaften, die durch die TCO Evaluator ausgegeben werden Listenwenn das berechnen Per-Jahr Kosten Option ausgewählt ist. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Cost Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und die Kosten Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Notiz

Lesen Sie den Hinweis über die mögliche Rundung der Ausgabeeigenschaften.

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Kosten | Gesamtkosten zu arbeiten - Jahrx. | $ | Ganze Zahl | Falsch | Die Total Cost of Ownership für die gesamte Architektur für Jahr x in die Zukunft.


Simulation von Zuverlässigkeit und Verfügbarkeit

Navigation: Simulieren Sie Ihre Architektur> Simulatoren>

Simulation von Zuverlässigkeit und Verfügbarkeit

Senden Sie Kommentare Zu diesem Thema.

Hintergrund

Die Zuverlässigkeit Evaluator berechnet die Zuverlässigkeit der Architektur mit Hilfe der Input-Komponenten und Verbindungen.

Für Komponenten und direkte Verbindungen wird die Zuverlässigkeit bei der Mean Time Between Failure (MTBF) basiert. Die einzigen Variablen erforderlich, um die Zuverlässigkeit der architektonischen Elemente zu berechnen sind:

· das MTBFWert (in Jahren);

· das Mittlere Reparaturzeit (MTTR)ein Fehler (in Jahren); und

· Die definierten Zeitraum, um Zuverlässigkeit zu testen über.

Die bei der Berechnung der Zuverlässigkeit verwendet Formel gegeben ist als:

Zuverlässigkeit = -e (-y x Alter)
Wobei y = 1 ÷ MTBF

Die Verfügbarkeit von Komponenten und Verbindungen liegt die MTBF und MTTR basiert. Beachten Sie, dass die Verfügbarkeit Gegensatz Zuverlässigkeit, ist unabhängig von der Zeitdauer, für die sie getestet wird.

Verfügbarkeit = MTBF / (MTBF + MTTR)

Während Methoden, die zu transformieren Zuverlässigkeits-Blockdiagramme(mit einfachen Reihen- und Parallelkonstrukte) geben die genauesten Ergebnisse, werden diese Verfahren hoch impraktisch, wenn wir versuchen, die Zuverlässigkeit für die Missionen in großen Netzwerke aus Tausenden von Elementen zu berechnen. Darüber hinaus sind diese transformative Ansätze brechen für viele gemeinsame Strukturen, wie zum Beispiel Netzwerk "Maschen".

das Monte CarloVerfahren ermöglicht die Zuverlässigkeit und Verfügbarkeit eines Systems von beliebiger Größe und Komplexität zu berechnen. Die Monte-Carlo-Methode simuliert viele Szenarien und foder jeder Szenario eine zufällige Zustand verfügbar oder nicht verfügbarWird jedem physikalischen Element zugeordnet. Die Wahrscheinlichkeit, in einem verfügbaren Zustand eines bestimmten Elements ist von der Zuverlässigkeit / Verfügbarkeit der Komponente.

Beispielsweise kann ein Bauteil mit 90% Verfügbarkeit voraussichtlich in etwa 90% der verfügbaren Szenarien werden. Zuverlässigkeit und Verfügbarkeit Die indirekte Verbindung ist somit als das Verhältnis der zufälligen scenarios-, für die in einem verfügbaren Rechnung von der Quelle zum Ziel ein Pfad von Elementen besteht geschätzt werden.

Notiz

Da die Berechnung der lokalen Zuverlässigkeit und Verfügbarkeit basiert auf verschiedenen Parametern und verschiedenen Formeln (und somit ergeben sich unterschiedliche Werte) basiert, ist es notwendig, jedes Element zuzuweisen zweiZustände, Eine freie und eine für Zuverlässigkeit. Die Berechnung der Verfügbarkeit verwendet die Verfügbarkeitszustand in jedem Szenario, während die Berechnung der Zuverlässigkeit verwendet die Zuverlässigkeit Zustand in jedem Szenario.

Die Zuverlässigkeit Evaluator verwendet die Monte-Carlo-Simulationstechnik zu erarbeiten, die Zuverlässigkeit einer besonderen Architektur. Die Architektur wird durch Tausende von Einzelsimulationen setzen und die Ergebnisse tabellarisch dargestellt, um eine Zuverlässigkeit Maßnahme abzuleiten. Wie oben erwähnt, ist Monte Carlo die schnellste Methode für die Simulation von großen Netzwerken und wird mit jeder komplexen (dh vernetzt) ​​Struktur zu arbeiten.

Der Bewerter gibt vier Werte:

1. Mission Zuverlässigkeitüber mehrere Jahre;

2. Verfügbarkeit des Architektur;

3. Zuverlässigkeit des lokale Komponenteüber mehrere Jahre; und

4. Verfügbarkeit des lokale Komponente.

Der Evaluator arbeitet die Wahrscheinlichkeit, das Komponente oder Verbindung Arbeits (d.h. keine Fehler) und die Zeit, zu reparieren.

Wie Standards mit MTBF und / oder MTTRs werden behandelt

Wenn ein Element (Komponente oder Verbindung) hat Standards zugeordnet MTBF und / oder MTTR Werte, werden diese Werte in die Berechnung der lokalen Zuverlässigkeit verwendet und Verfügbarkeiten eines Elements als Reihenschaltung.

Wenn beispielsweise eine Komponente A, Mit zugeordneten Normen B, C, und Djeweils eine MTBF und eine MTTR Wert, Local Zuverlässigkeit = R(A)× R(B) × R(C) × R(D), woher R = Berechnete Zuverlässigkeit (nach der Formel) der Komponente / Standards und Lokale NützenFähigkeit = EIN(A)× EIN(B) × EIN(C) × EIN(D), woher A = Berechnet NutzenFähigkeit (mit Hilfe der Formel) der Komponente / Standards. Das heißt, wenn ein Element hat drei Standards jede einzelne mit MTBF und MTTR WertsSowie MTBF und MTTR Wertsfür die Eigenschaften des Elements, das lokale Zuverlässigkeit und avilability als Reihenwert von jedem der Standards und das Element selbst gegeben.

Als weiteres Beispiel kann, wenn eine Komponente Ahat zugeordneten Normen B, C, und Dsondern nur Standard- Bhat sowohl eine MTBF und MTTR-Wert ein, während Standard- Chat nur einen MTBF-Wert und Standard Dhat nur einen MTTR-Wert, Local Zuverlässigkeit = R (A)× R (B)× R (C), woher R= Berechnete Zuverlässigkeit (nach der Formel) der Komponente / Standards und Local Verfügbarkeit = A (A)× A (B)× A (C), woher A= Berechnete Verfügbarkeit (nach der Formel) der Komponente / Standards, aber bei der Berechnung einer (C), da der Standard hat nur einen MTBF-Wert ist 'Suchanfragen'nach dem passenden MTTR-Wert (e) und fügen Sie alle MTTR-Werte sie feststellt, dass don't sich eine passende MTBF-Wert haben, so dass es in diesem Fall den MTTR-Wert-Standard verwenden würden D. Wenn es einen anderen Standard, sagen, E, Mit nur einer MTTR-Wert als auch dann A (C)würde die MTBF von verwenden Cmit der MTTR von D und Eaddiert. Wenn einem anderen Standard, sagen, FHatte gerade einen MTBF-Wert dann A (F)würde auch die MTTR von verwenden D und Eaddiert.

Berechnung Mission Zuverlässigkeit

Bei der Berechnung lokaler Sicherheit ist eine Frage der Verwendung einer einfachen Formel, ist die Berechnung der indirekten Verbindungen (Mission) nicht so einfach, vor allem, wenn wir komplexe und große Netzwerke von Interlaced-Wege (Verbindungen) und Komponenten.

Unter das gesamte Netzwerk in Betracht

Da die indirekten Verbindungen nicht über eine physische Verbindung zu vertreten, müssen wir herausfinden, wie die Quellkomponente kann an seinen Bestimmungsort Komponente zu erhalten. Und dies impliziert Blick auf das gesamte Netzwerk und alle die verschiedenen Möglichkeiten (und Pfade) unserer Quellenkomponente können, um die Zielkomponente (Senke) zu erreichen.

Notiz

Solange es mindestens ein komplettWeg von der Quelle zum Ziel wird die Mission erfolgreich sein,und die indirekte Verbindung wird als eine geschlossene Verbindung bezeichnet.

Das Verständnis der Link-Matrix

Um zu wissen, welche Komponenten / direkte Anbindung an das, was wir brauchen, ein Artefakt, schnell zu prüfen, ob zwei Blöcke werden in eine bestimmte Richtung verbunden sind. Dies ist die Funktion der Verbindungsmatrix. Kurz gesagt, ist der Link-Matrix eine zweidimensionale Anordnung von Booleschen Variablen, ob eine bestimmte Komponente kann eine andere Komponente direkt erreichen Staaten. Seine Größe ist gleich der Quadratwurzel der Gesamtzahl von Komponenten in dem Netzwerk.

A Simple Zuverlässigkeits-Blockdiagramm (RBD)

Related Link-Matrix für die Zuverlässigkeits-Blockdiagramm (RBD)

Da nicht alle Verbindungen sind bidirektional (in beide Richtungen), ist es wichtig, wie man den Link Matrix richtig gelesen. In die Zuverlässigkeit Evaluator, ist das erste Argument der Quelle und das zweite Argument ist das Ziel (Senke).

Deshalb, wenn Link-Matrix (A, B) = True dann bedeutet es, dass A bekommen kann, um direkt B (unidirektional). B kann zu einem, wenn nur, wenn Link-Matrix (B, A) = True. Wenn dies wahr ist, bedeutet dies eine bidirektionale Verbindung.

In dem gegebenen Beispiel über:

· Quelle 1 kann Destination 0 erreichen (Quelle 1 und Destination 0 zu einem Resultat von True); und

· Quelle 0 kann Ziel 1 erreicht (Quelle 0 und Ziel 1 zu einem Resultat von True), wie die Verbindung zwischen 0 und 1 ist bidirektional.

· Quelle 2 kann nicht Ziel 1 zu erreichen (Quelle 2 und Ziel 1 gibt ein Ergebnis von False), auch wenn Quelle 1 Ziel 2 zu erreichen (Quelle 1 und Ziel 2 zu einem Resultat von True). Dies bedeutet, dass die Verbindung zwischen 1 und 2 ist unidirektional.

Das Verständnis der Zuverlässigkeits-Blockdiagramm

Die Zuverlässigkeit Blockschaltbild (RBD) kapselt die Struktur des gesamten Objektmodells in Bezug auf die Blöcke und Links. Jeder Block stellt ein Element, das eine Möglichkeit der Erfolg oder Misserfolg nach den Links / Pfade, die sie verbinden hat. Beide Komponenten und Verbindungen kann ein "Block" in der RBD geworden.

Beispiel RBD Blöcke und Verbindungen

Die Figur oben stellt eine RBD Beispiel. Die gestrichelte rote Linie stellt eine einzelne Mission 4 auf 1. Hinweis, wie es nur zwei mögliche Wege für die Mission 4-1.

Betrachten die Strecke 4-3 bis 0-1, und die Strecke 4-7 zu 1. Die gepunktete Blöcke 2, 5und 6 für Blöcke, die keine Auswirkungen auf den Ausfall / Nicht-Ausfall-Mission 4 zu 1. Sie sind nicht berücksichtigt und werden ignoriert. Dies ist wichtig, wie für die meisten Missionen wird es eine große Anzahl von redundanten Blöcke, die den Erfolg eines bestimmten Mission nicht beeinträchtigen wird. Dies ist deutlicher in größeren Netzwerken, wobei die Anzahl der redundanten Blöcke werden die Simulationsergebnisse ungenau machen.

Zur Beschleunigung der Simulationszeit und sorgen für genauere Ergebnisse, ist es notwendig, Auszug aus dem gesamten RBD und verwenden Sie nur die Elemente, die den Erfolg einer Mission beeinträchtigen.

Notiz

Eine einzige Weg / Pfad kann nicht durch irgendeine Komponente zweimal zu gehen.

Zu diesem Zeitpunkt können wir einen Link-Matrix zu erstellen und durchzuführen, eine Monte-Carlo-Simulation.

Berechnung Architecture Verfügbarkeit

Die Verfügbarkeitsarchitektur ist die Wahrscheinlichkeit, dass alle indirekten Verbindungen werden zu jedem Zeitpunkt zur Verfügung stehen. Die Verfügbarkeit der einzelnen indirekten Verbindung während jeder Iteration der Monte-Carlo-Simulation ermittelt, jedoch sind diese indirekten Verbindungen (in der Regel) auf dem gleichen Satz von physikalischen Elementen verlassen. Daher einfach aggregieren diese einzelnen Verfügbarkeiten würde "Doppelzählung" diese un-Verfügbarkeiten, was eine pessimistische Gesamtverfügbarkeit Architektur. Alternativ wird die Gesamtverfügbarkeit Architektur suchen Sie in jeder Iteration und zu sehen, ob die Elemente in den indirekten Verbindungen von Interesse beteiligt sind, berechnet. Und dann die Aggregation dieser Ergebnisse am Ende der Simulation.

Das Ausführen des Reliability-Simulator

Ihre Architektur in Bezug auf Zuverlässigkeit simulieren

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Auswählen Analyse| Zuverlässigkeit.

3. Wähle aus ArchitekturSie aus dem Pull-Down-Menü bewerten möchten.

Notiz

Standardmäßig wird ABACUS automatisch die erste Architektur, für die eine erneute Simulation wird aufgrund einer zugrunde liegenden Immobilie oder strukturelle Änderungen erforderlich wählen.Diese Hervorhebung wird in gezeigt, Rot auf dem Simulation Symbolleiste .

4. Wähle aus Components und Anschlüssedie Sie aus der evaluieren möchten Standard-Element-Auswahlfenster Verwendung der 'Show direkter Verbindungen "und" Zeige Prozesse Connections' Radio-Button-Filter in der linken unteren Ecke des Dialogs, um mit Ihnen zu Auswahl zu unterstützen.

Weitere Checkbox zum Standard-Element-Auswahlfenster

· Save transformierten Modell werden speichern Sie eine Kopie des RBD transformierte Version des Projekts im gleichen Ordner wie das aktuelle Projekt und fügen Sie "_transformiert" auf den Projektnamen.Diese verwandelt Projekt kann verwendet werden, um im Detail zu diagnostizieren die Zuverlässigkeit Simulation von ABACUS vorgenommen werden.

Zusätzliche Radio-Buttons zum Standard-Element-Auswahlfenster

· Zeigen Direktverbindungen wird automatisch eine Verbindung aufgebaut hat Property Filter für Immobilientyp = Behaviour, Name = Abstraktion und Wert = Direkt.Diese Option ist standardmäßig aktiviert und unterstützt die Auswahl der "direkten" Verbindungen, wie oben und unten beschrieben.

· Zeige Prozesse Anschlüsse wird automatisch eine Verbindung aufgebaut hat Property Filter für Immobilientyp = Behaviour, Name = Beziehung und Wert = Prozesse.Diese Option hilft bei der Auswahl der "direkten" Verbindungen, wie oben und unten beschrieben.

5. Klicken Nächster.

6. Wählen Sie das Missionendh Verbindungen, die Sie wollen in der Simulation enthalten.

7. Stellen Sie die Run Time Scale Factor Schieberegler.

Notiz

Höhere Werte statistisch konsistente Ergebnisse liefern, aber die längere Zeit zu berechnen,.

Checkboxen

· Show Geschlossene Anschlüsse werden die verfügbaren Verbindungen automatisch zu filtern, um nur gehören jene, die mindestens einen vollständigen physischen Pfad vom Quellkomponente an die Zielkomponente nach dem oben beschriebenen RBD Auswahl haben.

· Indirekte Verbindungen anzeigen wird automatisch eine Verbindung aufgebaut hat Property Filter für Immobilientyp = Behaviour, Name = Abstraktion und Wert = indirekte.Diese Option ist standardmäßig aktiviert und unterstützt die Auswahl der "indirekten" oder Mission-Verbindungen wie oben und unten beschrieben.

Buttons

· Allewählt alle Anschlüsse.

· UmkehrenAuswahl aller aktuell ausgewählten Anschlüsse und wählt alle diejenigen, die nicht ausgewählt wurden.

· Keinedeselektiert alle Anschlüsse.

Andere Optionen

· Run Time Scale Factor steuert die Simulationszeit und Genauigkeit bei höherer Werte Ertragingmehr statistisch konsistente Ergebnisse, aber Einnahme längere Zeit, um Lauf.

Notiz

Wenn ABACUS berechnet die Anzahl der Iterationen zu simulieren, werden es die zuverlässigste Element, das nicht absolut zuverlässig zu bestimmen und dann zur Laufzeit-Skalierungsfaktor mal 1 simulieren über die Nichtverfügbarkeit des Elements plus 1 Iteration. Oder (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Dies ist um sicherzustellen, dass dieses Element noch mindestens einmal in der Simulation fehlschlägt. Z.B. Wenn das zuverlässigste Element, das nicht vollkommen zuverlässig einen MTBF von 10.000 Stunden und eine MTTR von 8 Stunden gerührt, dann wird die Simulation (10.000 + 8) / 8 = 1,251-fache der Laufzeit-Skalierungsfaktor + 1 Iterationen dauern.

· Jahre Ahead Simulieren bestimmt die Anzahl der Jahre für die Mission Zuverlässigkeit für berechnet werden.

· NUmbra von Themendetermines die Anzahl von Threads für die Monte-Carlo-Simulation zu verwenden.Diese Option wird standardmäßig auf die Anzahl der verfügbaren CPUs / Cores (einschließlich Hyper-Threading-Kerne) entsprechen, um die Gesamtsimulationszeit zu minimieren.

8. Klicken Fertigund Sie erhalten eine Warnung Dialog.

9. Die Warnungen wahlweise zu erkunden, indem Sie Details >>.

10. Klicken Fortsetzen.

Notiz

An dieser Stelle wird ein ABACUS durchführen Monte CarloSimulation der Architektur und nach kurzer Zeit (mit Fortschrittsbalken für die Rückführung) eine Berechnung abgeschlossen Dialog erscheint.

11. Klicken OKum die Simulation zu quittieren.

Spitze

Für Schulungen und weitere Hilfe an Zuverlässigkeit Simulation finden Sie im Handbuch Avolution Gemeinschaft .

Komponenten und Verbindungseigenschaften

Die folgende Tabelle listet die Komponente und 'direkt'Verbindungseigenschaften erforderlich sind, um die Zuverlässigkeit zu bewerten. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Eingabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Zuverlässigkeit Input '. Eine Änderung einer dieser 'input' Eigenschaften und verschiedene strukturelle Änderungen in das Repository wird in der Zuverlässigkeit Simulator eine erneute Simulation erfordern führen, wie in angedeutet Rot auf dem Simulation Symbolleiste .

Art | Name | Standardwert | Einheit | Dateityp | Erforderlich | Beschreibung
Zuverlässigkeit | MTBF | ∞ | Jahren, Wochen, Tage oder Stunden | Dezimal | Wahr | Das Mittlerer Ausfall des Elements. Hinweis: Die Werte können in Einheiten von Jahren, Wochen, Tage oder Stunden angegeben werden und werden nach einer '24 / 7 'Verfügbarkeitskonzept wie folgt umgerechnet; - 1 Jahr = 52 Wochen oder 365 Tage oder 8760 Stunden - 1 Woche = 7 Tage oder 168 Stunden - 1 Tag = 24 Stunden
Zuverlässigkeit | MTTR | 0 | Jahren, Wochen, Tage oder Stunden | Dezimal | Wahr | Die mittlere Zeit bis des Elements zu reparieren. Hinweis: Die Werte können in Einheiten von Jahren, Wochen, Tage oder Stunden angegeben werden und werden nach einer '24 / 7 'Verfügbarkeitskonzept wie folgt umgerechnet; - 1 Jahr = 52 Wochen oder 365 Tage oder 8760 Stunden - 1 Woche = 7 Tage oder 168 Stunden - 1 Tag = 24 Stunden

Die folgende Tabelle listet die Komponente und 'direkt' Verbindungseigenschaften Ausgabe durch die Zuverlässigkeit Evaluator. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Zuverlässigkeit Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und die Zuverlässigkeit Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Zuverlässigkeit | Zuverlässigkeit - x Jahre |  | Dezimal | Falsch | Die Wahrscheinlichkeit, dass das Element nicht in den nächsten x Jahren scheitern. Dies ist ein Wert zwischen 0 und 1.
Zuverlässigkeit | Unzuverlässigkeit - x Jahre |  | Dezimal | Falsch | Die Wahrscheinlichkeit, dass das Element in den nächsten x Jahren scheitern. Dies ist ein Wert zwischen 0 und 1.
Zuverlässigkeit | Verfügbarkeit | % | Dezimal | Falsch | Die berechnete Belegungs der Komponente oder einer Verbindung. Dies ist ein Wert zwischen 0% und 100%.
Zuverlässigkeit | Nichtverfügbarkeit | % | Dezimal | Falsch | Die berechnete Nichtverfügbarkeit des Bauteils oder der Verbindung. Dies ist ein Wert zwischen 0% und 100%.

Die folgende Tabelle listet die 'indirekt'Verbindungseigenschaften Ausgabe durch die Zuverlässigkeit Evaluator. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Zuverlässigkeit Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und die Zuverlässigkeit Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Zuverlässigkeit | Mission Zuverlässigkeit - x Jahre |  | Dezimal | Falsch | Die Wahrscheinlichkeit, dass die indirekte Verbindung wird nicht in den nächsten x Jahren scheitern. Dies ist ein Wert zwischen 0 und 1.
Zuverlässigkeit | Mission Unzuverlässigkeit - x Jahre |  | Dezimal | Falsch | Die Wahrscheinlichkeit, dass die indirekte Verbindung werden in den nächsten x Jahren scheitern. Dies ist ein Wert zwischen 0 und 1.
Zuverlässigkeit | Verfügbarkeit | % | Dezimal | Falsch | Die berechnete Verfügbarkeit der indirekte Verbindung. Dies ist ein Wert zwischen 0% und 100%.
Zuverlässigkeit | Nichtverfügbarkeit | % | Dezimal | Falsch | Die berechnete Nichtverfügbarkeit der indirekte Verbindung. Dies ist ein Wert zwischen 0% und 100%.

Architektur Immobilien

Die folgende Tabelle listet die Architektur Eigenschaften Ausgabe durch die Zuverlässigkeit Evaluator. Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Zuverlässigkeit Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie oder Strukturwandel in das Repository und die Zuverlässigkeit Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Einheit | Dateityp | Erforderlich | Beschreibung
Zuverlässigkeit | Verfügbarkeit | % | Dezimal | Falsch | Die Verfügbarkeit aller indirekten Verbindungen, die in die Auswertung einbezogen wurden. Das heißt, die Wahrscheinlichkeit, dass alleindirekte Verbindungen werden zu einem bestimmten Zeitpunkt zur Verfügung stehen. Dies ist ein Wert zwischen 0% und 100%. Hinweis: Dies ist nicht die Vermehrung der einzelnen Anschluss Verfügbarkeiten wie dieser wäre "Doppelzählung" Die UN-Verfügbarkeit der relevanten Komponenten.
Zuverlässigkeit | Nichtverfügbarkeit | % | Dezimal | Falsch | Die Nichtverfügbarkeit der indirekten Verbindungen, die in die Auswertung einbezogen wurden. Das heißt, die Wahrscheinlichkeit, dass mindestens einindirekte Verbindung wird zu einem gegebenen Zeitpunkt nicht verfügbar sein. Dies ist ein Wert zwischen 0% und 100%. Hinweis: Dies ist nicht die Vermehrung der einzelnen Anschlussnichtverfügbarkeiten, wie dieser wäre "Doppelzählung" Die UN-Verfügbarkeit der relevanten Komponenten.
Zuverlässigkeit | Mission Zuverlässigkeit - x Jahre |  | Dezimal | Falsch | Die Wahrscheinlichkeit, dass alle der indirekten Verbindungen, die in die Auswertung mit einbezogen wurden, werden nicht mit dem nächsten versagen xJahren. Dies ist ein Wert zwischen 0 und 1. Hinweis: Dies ist nicht die Vermehrung der einzelnen Anschluss Reliabilitäten als dieser wäre "Doppelzählung" Die UN-Verfügbarkeit der relevanten Komponenten.
Zuverlässigkeit | Mission Unzuverlässigkeit - x Jahre |  | Dezimal | Falsch | Die Wahrscheinlichkeit, dass mindestens eine der indirekten Verbindungen, die in die Auswertung mit einbezogen wurden, werden mit dem nächsten fehler xJahren. Dies ist ein Wert zwischen 0 und 1. Hinweis: Dies ist nicht die Vermehrung der einzelnen Anschluss unreliabilities wie dieser wäre "Doppelzählung" Die UN-Verfügbarkeit der relevanten Komponenten.


Simulation von Offenheit

Navigation: Simulieren Sie Ihre Architektur> Simulatoren>

Simulation von Offenheit

Senden Sie Kommentare Zu diesem Thema.

Die Offenheit Simulator bestimmt den Grad, in dem eine Architektur und seiner Elemente sind "offen", das heißt, die Fähigkeit des Systems zum Austausch von Komponenten mit minimalen Auswirkungen behandeln.

Ihre Architektur in Bezug auf Offenheit zu simulieren

1. Vergewissern Sie sich, die ABACUS-Datei, Mit Ihren besiedelte Architektur, öffnen.

2. Wählen Sie Analyse | Offenheit.

3. Wählen Sie das Architektur (en)Sie wollen in der Bewertung enthalten.

Notiz

Standardmäßig wird ABACUS automatisch die erste Architektur, für die eine erneute Simulation wird aufgrund einer zugrunde liegenden Immobilie oder strukturelle Änderungen erforderlich wählen.Diese Hervorhebung wird in gezeigt, Rot auf dem Simulation Symbolleiste .

4. Klicken Fertigund Sie erhalten eine Warnung Dialog.

5. Die Warnungen wahlweise zu erkunden, indem Sie Details >>.

6. Klicken Fortsetzen.

Notiz

An diesem Punkt wird ABACUS eine strukturelle Bewertung der Architektur (en) durchzuführen und nach kurzer Zeit (mit Fortschrittsbalken für die Rückführung) eine Berechnung abgeschlossen Dialog erscheint.

7. Klicken OKum die Simulation zu quittieren.

Spitze

Für Schulungen und weitere Hilfe auf Offenheit Auswertung finden Sie im Handbuch Avolution Gemeinschaft .

Komponenten und Anschluss Standardeigenschaften

In der folgenden Tabelle sind die Komponenten und Verbindungsstandardeigenschaften erforderlich ist, um Offenheit zu bewerten.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Eingabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Offenheit Input '. Eine Änderung einer dieser 'input' Eigenschaften im Repository wird in der Offenheit Simulator eine erneute Simulation erfordern führen, wie in angedeutet Rot auf dem Simulation Symbolleiste .

Art | Name | Standardwert | Einheit | Dateityp | Erforderlich | Beschreibung
Offenheit | Standards-Standard-Maturity-Organisation Ebene |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Ebene der zuständigen Normungsorganisation 0:Organisatorische / Proprietary 1:Consortium / Defacto 2:Nationale / Militär 3:Internationale
Offenheit | Standards-Standard-Laufzeit-Status- |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Genehmigungsstufe mit der Normungsorganisation erreicht 0:Arbeiten / Committee Draft 1:Öffentliche Draft / balloted 2:Zwischen Draft 3: Genehmigt
Offenheit | Standards-Standard-Laufzeit-Stabilität |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Ist der Standard voraussichtlich ändern? 0:Standard überholt 1:Hoch unterliegen im nächsten 1 bis 2 Jahren ändern 2:Bekannte Änderung / Aktuelles zu vorhandenen Features 3:Hochstabil (keine Änderung innerhalb von 2 Jahren)
Offenheit | Standards-Standard-Maturity-Vendor-Support |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Vendor-Support 0:Keine Produkte oder Anbieter unterstützen die Standard- 1:Ein oder mehrere Anbieter, die einen Teil der Norm anwenden 2:Mehr als ein Anbieter mit Produkten, die alle Teile der Norm anwenden 3:Viel mehr als einem Anbieter mit Produkten, die alle Teile der Norm anwenden
Offenheit | Standards-Standard-Explizit-Dokumentation |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Qualität der Standard-Dokumentation 0: Arm 1: Messe 2: Gut 3: Ausgezeichnet
Offenheit | Standards-Standard-Explizit-Standard Breite |  |  | Ganze Zahl | Falsch | Anzahl der Funktionen. Eine Zählung der untersten Ebene Standard-Funktionen - Sf
Offenheit | Standards-Standard-Explizit-Sm |  | % | Dezimal | Falsch | Prozentsatz der Gesamtzahl der Features, die obligatorisch sind
Offenheit | Standards-Standard-Explizit-So |  | % | Dezimal | Falsch | Prozentsatz der Gesamtzahl der Features, die optional sind
Offenheit | Standards-Standard-Explizit-Sc |  | % | Dezimal | Falsch | Prozentsatz der Gesamtzahl der Features, die bedingt definiert sind
Offenheit | Profile-Profil-Dokumentation Dokumentation |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Qualität der Standard-Dokumentation 0: Keine 1: Arm 2: Messe 3: Ausgezeichnet
Offenheit | Profile-Profil Documenta-Genauigkeit |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Enthält Dokumentationen spiegeln die tatsächlichen System-Design? Welches Maß an Profil Merkmale sind in dem System verwendet werden? 0:Keine Funktionen 1:Einige Features 2:Die meisten Funktionen 3:Alle Funktionen
Offenheit | Profile-Profil-Dokumentation Maturity |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Ist das Profil ausgereift und verfügbar ist? 0: Ad hoc 1: Projektbasiert 2:Organisations 3: Öffentlichkeit
Offenheit | Profile-Profil Explizit-explizite Breite |  |  | Ganze Zahl | Falsch | Anzahl der festgelegten Standard-Features wie im Profil erforderlich
Offenheit | Profile-Profil Explizit-PM |  | % | Dezimal | Falsch | Prozentsatz der obligatorischen Funktionen im Profil
Offenheit | Profile-Profil Explizit-Po |  | % | Dezimal | Falsch | Prozentualer Anteil der optionalen Funktionen im Profil
Offenheit | Profile-Profil Explizit-Pc |  | % | Dezimal | Falsch | Prozentsatz der bedingt definiert wird Funktionen im Profil
Offenheit | Profile-Profil Explizit-Coverage |  | % | Dezimal | Falsch | Prozentsatz der Standard-Funktionen, die speziell im Profil angesprochen
Offenheit | Profile-Profil Extensions-Extension Breite |  |  | Ganze Zahl | Falsch | Anzahl von Nicht-Standard-Funktionen durch das Profil festgelegt
Offenheit | Profile-Profil Extensions-Coverage |  | % | Dezimal | Falsch | Prozentualer Anteil der Erweiterungen im Profil beschrieben
Offenheit | Artikel-Verfügbarkeit des Produktes und Conformance-Anzahl der Produkte |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Anzahl der Produkte unterstützen die obligatorischen Features der Standard- 0:Keine Produkte unterstützen die Standard- 1:Ein oder mehrere Produkte zu implementieren einen Teil des Standard- 2:Mehr als ein Produkt implementiert alle Teile der Norm 3:Viele mehr als ein Produkt implementiert alle Teile der Norm
Offenheit | Artikel-Verfügbarkeit des Produktes und Conformance-Anwendung Conformance |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Welches Maß an Übereinstimmung keine Produkte zum Standard? 0: Keine 1:Beansprucht 2: Gezeigt 3:Zertifiziert und Nachgewiesene
Offenheit | Artikel-Verfügbarkeit des Produktes und Conformance-Conformance-Qualität |  | [0 | 1 | 2 | 3] | Lookup / Liste | Falsch | Qualität der Konformitätsprüfung 0: Keine 1:In-house-Tests von Produktentwickler 2:Unabhängige Tests (z NIST) 3:Im Rahmen der relevanten Produkt gezeigt

Komponenten, Anschluss und Architektur Immobilien

Die folgende Tabelle enthält die Komponente, Verbindung und Architektur Objekte ausgegeben von der Offenheit Evaluator. Alle der folgenden Eigenschaften zu bewerten, um zwischen Null (0) und drei (3), Null (0) als die am wenigsten wünschenswerte und drei (3) die am meisten erwünscht.Diese Eigenschaften werden im Eigenschaftenfenster mit einer Eigenschaft Ausgabezeile Icon zur Auswahl angezeigt ( [image] ) Mit dem Tooltip "Offenheit Output '. Der Pfeil auf dem Symbol markieren Rot ( [image] ), Wenn diese Eigenschaften nicht mehr aktuell sind aufgrund eines zugrunde liegenden Immobilie Änderung an das Repository und die Offenheit Simulator erfordert re-Simulation gemäß der Rot Hervorhebung auf die Simulation Symbolleiste .

Art | Name | Dateityp | Erforderlich | Beschreibung
Offenheit | Offenheit | Dezimal | Falsch | Gesamtbewertung der Offenheit des Einzelteils.
Offenheit | Standards-Standard-Laufzeit | Dezimal | Falsch | Der aktuelle Stand des Standards, was, ob sie genehmigt worden ist, wie lange es schon im Einsatz und wie gut akzeptierte es innerhalb der Gemeinschaft von Entwicklern ist gewesen.
Offenheit | Standards-Standard-Explizit | Dezimal | Falsch | Die Deutlichkeit der Standards, was die potenzielle Mehrdeutigkeit in folgenden Standards
Offenheit | Profile-Profil-Dokumentation | Dezimal | Falsch | Das Ausmaß, in dem Schnittstellenprofil Dokumentation entwickelt und ob das Profil Dokumentation entspricht dem aktuellen System-Design und / oder das implementierte System
Offenheit | Profile-Profil Explizit | Dezimal | Falsch | Der Detailgrad in einem Profil / profile-Spezifikation zur Verfügung gestellt
Offenheit | Profile-Profil-Erweiterung | Dezimal | Falsch | Das Ausmaß, in dem das Profil der Norm entspricht, auf dem es basiert
Offenheit | Artikel-Verfügbarkeit des Produktes und Conformance | Dezimal | Falsch | Unabhängig davon, ob es offene Standard-konforme Produkte für den Einsatz in dem Projekt


Standardberichte

Navigation: Die Berichterstattung über Ihre Architektur>

Standardberichte

Senden Sie Kommentare Zu diesem Thema.

ABAKUS' Standard Berichte können Sie eine Liste der Komponenten und Verbindungen in einem oder mehreren Ihrer Architekturen zu erhalten. Der Bericht enthält alle Informationen zu den Komponenten und Verbindungen ausgewählt, einschließlich Informationen über die Komponente oder Ort Verbindung in der Hierarchie, Typ, Normen, Beschreibung, Eigenschaften und seiner Anlagen zusammen.

Notiz

Der Inhalt des Berichts istkonfigurierbarüber das Dialogberichtoptionen unten beschrieben, aber to Für weitere Informationen über das Erstellen vollständig konfigurierbar benutzerdefinierte Berichtemit ABACUS Benutzerdefinierte Berichte, Bitte siehe Thema Hier oder Kontakt Avolution Unterstützung .

Um eine Ansicht Standard Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur(e).

2. Auswählen Einfügen| Standardberichtoder klicken Sie auf die Erstellen Sie Standard-Report Schaltfläche in der Symbolleiste. das KonfigurationsberichtFenster wird angezeigt.

Bericht Konfigurationsfenster

3. Wähle aus Architekturen, Components und Anschlüssedass Sie in dem Bericht der will Bericht Konfigurationsfenster.Bitte beachten Sie die Standard-Elementauswahl beziehen Hier Thema um Hilfe.

4. Klicken Sie nun auf die OptionenTaste und die BerichtsoptionenFenster wird angezeigt.

Fenster Auswertungsoptionen

5. Sie können wählen, um eine Anzeige Neue Seite für jedes Element, das Datum des Drucks, Druckzeit, Seitenzahlenund ob den Titel in der Kopfzeiledes Berichts durch Ankreuzen / Haken bei der entsprechenden Kontrollkästchen. Vielleicht möchten Sie auch, um den Titel und Autor, indem Sie besonders anfertigen Titel des Berichts und Autor Textfelder ein. Sie können auch wählen, welche Inhalte im Bericht angezeigt wird durch Ankreuzen / Haken bei der Kontrollkästchen unter der BerichtsinhaltTeil des Fensters. Wenn Sie fertig sind klicken Sie auf OK.

6. Klicken Sie nun auf Fertigim Bericht Konfigurationsfenster.

Um den sichtbaren Bericht interpretieren

Beispiel generierter Berichte mit kurzen Erklärungen

Um durch die Berichtsseiten zu navigieren, klicken Sie auf die Symbole [image] in der Werkzeugleiste auf der linken oberen Ecke des Bildschirms befindet.

Notiz

Sie können sparen Bericht in verschiedene Formate indem Sie auf die Export Bericht icon [image] gelegen im die Symbolleiste. Sie können wählen, um in den folgenden Formaten exportieren: Übertreffen, PDF und Wort. Bitte speichern Sie den Bericht in die gewünschte Position für die spätere Verwendung. Wenn Änderungen an der Architektur zu einem späteren Zeitpunkt erfolgt, wird ein neuer Bericht erstellt haben, um die Änderungen zu berücksichtigen.

Sehe auch

Analyse Ihrer Architektur


Benutzerdefinierte Berichte

Navigation: Die Berichterstattung über Ihre Architektur>

Benutzerdefinierte Berichte

Senden Sie Kommentare Zu diesem Thema.

ABACUS "benutzerdefinierte Berichte erlauben Ihnen, vollständig konfigurierbar benutzerdefinierte Berichte erstellen. Die Berichte können kundenspezifische Bilder und Grafiken sowie Detaillierung alle Komponenten, Verbindungen oder Attribute aus einem Abakus-Repository sowie detaillierte analytische Ergebnisse aus verschiedenen Simulationen (einschließlich TCO, Leistung und Zuverlässigkeit) enthalten. Darüber hinaus können Berichte Diagramme, Schaubilder, Kataloge, Matrizen / Pivot-Tabellen, Karten, Lehren, Sparklines, Datenbalken und Indikatoren (zB Ampel enthalten).

Notiz

Während jeder Benutzer kann bestehende benutzerdefinierte Berichte zu öffnen, to configure Berichte der Benutzer-Lizenz muss der Konfigurationsbericht Fähigkeit. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

Um eine Ansicht Brauch Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur(e).

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte BerichteFenster wird angezeigt.

Benutzerdefinierte Berichte Fenster

3. Wähle ausbestehenden Bericht das du willst angezeigt von dem Berichte Abschnitt.

4. Klicken Bericht ausführen.Der Bericht wird in Microsoft Report Viewer und t öffneno durch die Berichtsseiten zu navigieren, klicken Sie auf die Symbole [image] in der Werkzeugleiste auf der linken oberen Ecke des Bildschirms befindet.

Notiz

Sie können sparen Bericht in verschiedene Formate indem Sie auf die Export Bericht icon [image] gelegen im die Symbolleiste. Sie können wählen, um in den folgenden Formaten exportieren: Übertreffen, PDF und Wort. Bitte speichern Sie den Bericht in die gewünschte Position für die spätere Verwendung. Wenn Änderungen an der Architektur zu einem späteren Zeitpunkt erfolgt, wird ein neuer Bericht erstellt haben, um die Änderungen zu berücksichtigen.

Zu die Repository-Daten, die gesendet wird, zu bearbeiten a Brauch Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur(e).

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte Berichte Fenster (oben gezeigt) wird Angezeigt werden.

Notiz

Während jeder Benutzer kann bestehende benutzerdefinierte Berichte zu öffnen, to configure die Daten, die zu einem benutzerdefinierten Bericht gesendet wird der Benutzer-Lizenz muss der Konfigurationsbericht Fähigkeit. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

3. Wähle ausbestehenden Bericht das du willst angezeigt von dem Berichte Abschnitt.

4. Klicken Edit Data Sets. das Data Set EditorFenster wird angezeigt.Dieses Fenster zeigt die Sammlung von Datensätzen, die derzeit zu einem benutzerdefinierten Bericht gesendet werden. Im folgenden Beispiel gibt es drei (3);

· ein ApplicationProxy Datensatz, der die Angabe wird alle Details für alle Anwendungskomponenten in der '2015 Actual' Architektur (einschließlich der Eigenschaften auf ihre Standards und alle angeschlossenen Komponenten),

· a TwoDViewProxy Datensatz, der die Angabe einer oder mehrerer Diagramme ist, wo der Name mit "Application Landscape (Australien) ',

· a TargetProxy Datensatz, der die Angabe wird der Informationen für alle Zielverbindungen in der "2015 Actual 'Architektur (einschließlich der angeschlossenen Komponenten).

Data Set Editor Fenster

Notiz

Die Abfragename wird für den Dataset-Namen in Microsoft Report Builder (siehe unten) verwendet werden. Die Include Feld gibt, ob die Datenmenge ist entweder ein Einzelelement, Eine Sammlung von Elementen, alle Komponententypen, alle Verbindungstypen, eine oder mehrere Architekturen, ein oder mehrere Diagramme oder eine oder mehrere Charts. Für die "Sammlung von Elementen, 'Datensätze eine Schaltfläche Filter versehen ist, die, wenn sie angeklickt öffnet das Element Filterfenster können Sie mehrere Filter anwenden, um nur Elemente aus bestimmten Architekturen zurückkehren können, und / oder für bestimmte Arten und / oder mit bestimmten Standards und / oder bestimmte Komponenten angebracht sind, und / oder mit bestimmten Eltern und / oder in bestimmten Diagrammen und / oder in bestimmten Charts und / oder mit bestimmten Objektwerten. Bei den anderen Datensatztypen ein Namensfeld ist vorgesehen und mit der Select-Taste können Sie das Objekt (e), um mit der Datensatz enthalten sein soll.

Notiz

Die Datensätze werden in eine gespeicherteDatensätze Datei (.xml)mit dem gleichen Basisdateinamen als ein damit verbundenen Report Definition-Datei (.RDL). Wenn diese Datei nicht existiert, wird der Datensatz-Editor wird automatisch mit allen Query-Namen, die in die existieren bevöl Report Definition-Datei (.RDL)und ein neuer Datensätze Datei (.xml)wird erstellt, sobald aa gültige Liste der Abfragen definiert werden.

3. Wenn Sie einen vorhandenen Datensatz löschen möchten, wählen Sie die Abfrage löschen Taste.

4. Wenn Sie einen neuen Datensatz hinzufügen wollen, klicken Sie auf die In New Data Setund konfigurieren Sie die Daten nach dem Hinweis oben dargelegt.

Zu erstellen Sie eine neue benutzerdefinierte Bericht(aus einer Vorlage)

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte Berichte Fenster (oben gezeigt) wird Angezeigt werden.

3. Klicken Neu und wählen Sie entweder A4 - Portrait, A4- Landschaft, A3 - Portrait, A3- Landschaft, US Letter - Portrait, US Letter - Landschaft, US Tabloid - Portrait oder US Tabloid - Landschaftje nach dem Bericht Orientierung und Papierformat, das gewünscht wird.

4. Suchen Sie den Speicherort, um die Berichtsdefinitionsdatei (RDL / RDLC) und den passenden Datensatz Datei (.xml) zu speichern und klicken Sie auf sparen. Dies wird eine neue benutzerdefinierte Bericht an die Berichte Abschnitt der Custom Reports Fenster hinzufügen und es geöffnet oder bearbeitet, wie oben beschrieben.

Zu fügen Sie eine vorhandene benutzerdefinierte Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte Berichte Fenster (oben gezeigt) wird Angezeigt werden.

3. Klicken Hinzufügen und an die Stelle der Definition Datei Bericht durchsuchen (RDL / RDLC) und klicken Sie auf Öffnen. Dies wird eine neue benutzerdefinierte Bericht an die Berichte Abschnitt der Custom Reports Fenster hinzufügen und es geöffnet oder bearbeitet, wie oben beschrieben.

Notiz

Es wird angenommen, dass ein passender Datensatz Datei (.xml) in der gleichen Position wie der Report Definition-Datei vorhanden ist.

Zu Kopieren Sie eine vorhandene benutzerdefinierte Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte Berichte Fenster (oben gezeigt) wird Angezeigt werden.

3. Wähle ausbestehenden Bericht das du willst Kopieren von dem Berichte Abschnitt.

4. Klicken Kopie und eine Kopie des ausgewählten Berichts (mit dem Namen "Kopie von ...") wird auf die Berichte Abschnitt der Custom Reports-Fenster hinzugefügt werden, und es kann geöffnet oder bearbeitet werden, wie oben beschrieben.

Notiz

Auf diese Weise erhalten Sie eine Kopie des Berichts zu erstellen Report Definition Datei (RDL / RDLC) sowie ihre passenden Datensatzdatei (.xml)(falls vorhanden).

Zu entfernen Sie eine vorhandene benutzerdefinierte Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte Berichte Fenster (oben gezeigt) wird Angezeigt werden.

3. Wähle ausbestehenden Bericht das du willst zu entfernen von dem BerichteAbschnitt und klicken Sie auf Entfernen.

Notiz

Wenn Sie einen Bericht zu entfernen wird es nicht mehr auf der Berichtsliste angezeigt. Dies wird jedoch nicht gelöscht werden die Bericht Report Definition Datei (RDL / RDLC) oder der Data Set Datei(.xml). Bei Bedarf kann das Löschen dieser Dateien über das Dateisystem erreicht werden.

Zu eine vorhandene benutzerdefinierte umbenennen Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte Berichte Fenster (oben gezeigt) wird Angezeigt werden.

3. Wähle ausbestehenden Bericht das du willst umbenennen in das BerichteAbschnitt und klicken Sie auf Umbenennen.

4. Geben Sie einen neuen Namen für den Bericht.

Notiz

Sowohl die Berichtsdefinitionsdatei (RDL / RDLC) und der passenden Datensatzdatei (.xml) wird entsprechend umbenannt.

Zu Bearbeiten Sie die Gestaltung einer Brauch Bericht

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet mit Ihrer besiedelte Architektur.

2. Auswählen Einfügen| Custom Reportoder klicken Sie auf die Erstellen von benutzerdefinierten Bericht Schaltfläche in der Symbolleiste. das Benutzerdefinierte Berichte Fenster (oben gezeigt) wird Angezeigt werden.

Notiz

Während jeder Benutzer kann bestehende benutzerdefinierte Berichte zu öffnen, to configure Das Design einer benutzerdefinierten Berichten der Benutzer-Lizenz muss der Konfigurationsbericht Fähigkeit. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.Zusätzlich Microsoft Report Builder 3.0 ist erforderlich, um Berichte zu entwerfen und es kann kostenlos heruntergeladen werden Hier .

3. Wähle ausbestehenden Bericht das du willst angezeigt von dem Berichte Abschnitt.

4. Klicken Bericht bearbeiten.Der Bericht wird in Microsoft Report Builder 3.0 zu öffnen. Für spezifische Hilfe und einige "Tipps & Tricks" für einige der häufigsten Aufgaben, die mit der Erstellung von Berichten finden Sie in den folgenden Abschnitten beziehen. Für allgemeine Hilfe bei der Gestaltung Berichte siehe zu den Microsoft Report Builder 3.0 Hilfe-Seiten Hier .

Hinzufügen von Tabellen, um Ihren Bericht

1. Vergewissern Sie sich, Ein Abakus Custom Report Definitionsdatei (RDL / RDLC) in Microsoft Report Builder 3.0 geöffnet.

2. Auswählen das Einfügen Registerkarte im "Farbband" an der Spitze, dann drücke den Tabelle Tastein der Datenbereichen Abschnitt, und wählen Sie Tabelle einfügen.

3. Jetzt ziehen Sie den Cursoran die Position auf den Bericht Leinwand, wo Sie wollen, dass die obere linke Ecke der Tabelle platziert. Klicken Sie auf die Leinwand. Standardmäßig wird die Tabelle mit einer Kopfzeile und dann eine Detailgruppe (eine Gruppe wird verwendet, um einen Blick auf eine Berichtsdataset organisieren) hinzugefügt werden. Um die Gruppe zu entfernen, entweder die Zeile zu löschen oder löschen Sie den Zeilengruppe in der Gruppierung Symbolleiste.

Spitzes

Formeln / Expressions in Tabellenzellen werden durch die Auswahl der Zelle dann mit der rechten Maustaste auf das << Expr >> Text und Auswahl Expression bearbeitet .... > SortExpressions Feld im Eigenschaftenfenster und geben Sie einen Ausdruck - Sortieren Zeilen in einer Tabelle wird durch Auswahl der Tabelle und dann gerade nach unten auf die andere getan. Für insgesamt Zeile am Ende einer Tabelle hinzufügen, eine Zeile nach (und außerhalb) die Gruppierung und verwenden Sie dann den folgenden Ausdruck = Sum (Fields!Name.Wert)wobei 'Name' ist das Feld, das summiert. Zur Färbung gelten für Spalten verwenden Sie ein "IIF" Anweisung in der Backgroundcolor-Eigenschaft. Um einen Spur als eine Zelle in einer Tabelle hinzufügen, zuerst die Manometer in eine Zelle einfügen und löschen Sie dann Datenfelder für die Spurweite erforderlich. Bei der Bearbeitung der Höhe und Breite der Tabellenzeilen, dass Sie die richtige Zeile auszuwählen, und bewegen Sie dann den Mauszeiger um die grauen Linien, bis Sie den Pfeil zu up / down Cursor, dann die Größe.

Hinzufügen Charts, um Ihren Bericht

1. Vergewissern Sie sich, Ein Abakus Custom Report Definitionsdatei (RDL / RDLC) in Microsoft Report Builder 3.0 offen.

2. Auswählen das Einfügen Registerkarte im "Farbband" an der Spitze, dann drücke den Diagramm Tastein der Datenbereichen Abschnitt, und wählen Sie Diagramm einfügen.

3. Jetzt ziehen Sie den Cursoran die Position auf den Bericht Leinwand, wo Sie wollen, dass die obere linke Ecke des Diagramms platziert. Klicken Sie auf die Leinwand und dann Wählen Sie das DiagrammSie aus den Optionen und klicken Sie benötigen OK.

Spitzes

Um eine Eigenschaft als Anmerkung in Diagrammen angezeigt werden, klicken Sie rechts auf das Diagramm und wählen Sie Datenbezeichnungen anzeigen, dann wählen Sie eine der Etiketten, die hinzugefügt wurde, und stellen Sie den Misc -> UseValueAsLabel auf False im Eigenschaftenfenster, und fügen Sie einen Ausdruck (zB = Felder Name.Value) im Misc -> Etikette. Speziell für Bubble-Charts; Blasendiagramme sind unter dem Punktdiagramm Überschrift angezeigt. Drop X-Achse Immobilie in Felder-Serie (oder fügen Sie im Eigenschaften-Serie). Drop Y-Achse Immobilie in Datenfelder (oder fügen Sie im Eigenschaften-Serie). Um eine Eigenschaft zu verwenden, um Blasengröße zu definieren, fallen diese in die Datenfelder (oder fügen Sie im Eigenschaften-Serie). Blasendiagramme können nicht angezeigt werden, wenn es zu viele Daten (200 + Artikel), manchmal bewirkt, dass der gesamte Bericht nicht angezeigt. Markertyp - zum Kreis ein. Standardmäßig wird beim Fallenfelder in Datenfelder, sie mit der hinzufügt Summe()Formel, so entfernen Sie diese. Speziell für Gestapelte Diagramme / Timeline / Gantt-Diagramme; Für ein Gantt-Diagramm mit einem Sortimentsübersicht und Eigenschaften wie hohe und niedrige Werte in den Datenfelder hinzuzufügen. Sie können mehrere 'Bars', indem mehr und mehr Bereiche, in denen der niedrige Wert für eine den hohen Wert für einen anderen übereinstimmt. Speziell für Kreisdiagramme; Für Aggregatkreisdiagramme, fallen die Daten in Kategorie Feldern und in Datenfelder, fügen Sie die Formel = CountRows (). Filtern Sie alle 0-Werte (zB auf den Kosten Charts), sonst werden die Beschriftungen für diese immer noch auf der Karte angezeigt.

Mit Hilfe eines Anweisung von IIF, um Farben in Tabellen und Diagramme hinzufügen

1. Vergewissern Sie sich, Ein Abakus Custom Report Definitionsdatei (RDL / RDLC) in Microsoft Report Builder 3.0 offen.

2. Rechtsklicken Sie auf die Zelle in der Tabelle, um die Farbe und den Klick Textfeldeigenschaften.

3. Auswählen Füllen und klicken Sie auf die fxSchaltfläche rechts der Füllfarbe Etikett und im Set einen Ausdruck für die Backgroundfeld geben Sie einen Ausdruck, zB = IIF (Fields! InformationStatus.Value = "Retain", "Lightgreen", iif (Fields! InformationStatus.Value = "Redesign", "Yellow", iif (Fields! InformationStatus.Value = "Refresh", "orange", " Lachs"))). Dadurch ändert sich die Hintergrundfarbe auf hellgrün für jede Zelle, die den Status "Retain", gelb für jede Zelle, die den Status "Redesign" enthält enthält, Orange für jede Zelle, die den Status "Aktualisieren" und andere Statuswert enthält, wird eingefärbt werden in 'Salmon'.

Notiz

Farben können für Diagramme durch Auswahl der Serie auf der Karte und dann die Einstellung der Darstellung hinzugefügt werden -> Color-Eigenschaft (oder für Blasendiagramme der Darstellung -> Marker -> Color-Eigenschaft) auf einen Ausdruck ähnlich dem obigen Beispiel.

Dinge zu beachten bei der Gestaltung von benutzerdefinierten Berichten

· Da alle Eigenschaften mit Ausnahme Integer werden als String von ABACUS auf den Report Viewer geschickt, wenn Sie keine "Wendungen" mit ihnen (wie Division durch ein anderes oder Art eine Eigenschaft) machen wollen, müssen Sie sie konvertieren dezimal oder Datum etc. Für Hintergrund . Dieser Artikel ist eine gute Referenz. Z.B. = CDate (Fields! LifecycleEndDate.Value) Hinweis: Bitte stellen Sie sicher, dass der Bericht die Sprache aus, um en-GB eingestellt ist (wie unten beschrieben), um TT / MM / JJJJ akzeptieren, wie es mm / tt / Format standardmäßig erwartet und entsprechend 31/7/2011 wird die Umwandlung fehl. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = Formatcurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Wenn Sie feststellen, dass Sie zu kämpfen haben halten alle Tabellen und Diagramme auf einer Seite anzeigen, Gibt es ein paar wichtigsten Möglichkeiten für die Verwaltung Ihres Dokuments Raum:

· Seitenumbruch - Stellen Sie sicher, dass diese Tabelle Einstellung deaktiviert ist für jede Tabelle, die Sie auf der gleichen Seite sein wollen.

· Halten Sie Together - Achten Sie darauf, diese Tabelle Einstellung gilt für jede Tabelle, die Sie auf der gleichen Seite sein wollen.

· Wenn bewegliche Sachen herum, ist es einfacher zu verkleinern mit Hilfe der Steuer am unteren rechten Rand der Seite und dann mehr Elemente auswählen und ziehen

· Für das Bild Zeile in einer Tabelle, stellen Sie sicher, dass die 'Größe' | 'Sizing' Eigenschaft auf 'Fit' sonst das Bild gesetzt ist möglicherweise zu groß erscheinen, oder es wird schlecht gestreckt werden.

· Zu wiederholen Sie eine Kopfzeile einer Tabelle auf jeder Seitedes Berichts:

1. Öffnen Sie Advanced Mode im Gruppierungen Bereich. (Klicken Sie auf den Pfeil rechts neben der Spaltengruppen und wählen Sie Erweiterter Modus.)

2. In der Zeilengruppen Bereich (nicht Spaltengruppen), klicken Sie auf eine statische Gruppe, die das entsprechende Textfeld in der Tablix hervorhebt. Klicken Sie durch die einzelnen statischen Gruppe, bis er unterstreicht die ganz linke Spaltenüberschrift. Dieser ist in der Regel die erste statische Gruppe aufgeführt.

3. Im Fenster Eigenschaften die RepeatOnNewPage Eigenschaft auf True.

4. Stellen Sie sicher, dass die Keepwithgroup-Eigenschaft auf Nach eingestellt.

· Ändere das Spracheinstellungenim Berichtseigenschaften, um die Datenformate Sie benötigen, beispielsweise entsprechen en-GB Großbritannien Datumsformat (dd / mm / yyyy) zu produzieren.

Sehe auch

Analyse Ihrer Architektur


Im Web veröffentlichen

Navigation: Die Berichterstattung über Ihre Architektur>

Im Web veröffentlichen

Senden Sie Kommentare Zu diesem Thema.

ABACUS "Im Web veröffentlichen-Funktion ermöglicht Architekturmodelle, um über eine sichere Website eingesehen werden. Architekturen werden in HTML-Format exportiert und sind entworfen, um das Aussehen zu reflektieren und das Gefühl der Explorer in ABACUS. Ansichten (einschließlich Kataloge, Abbildungen, 3D- und Charts) werden auch in Formate sichtbar über einen Internetbrowser exportiert.

Notiz

Derzeit sind Aussichtspunkte und Matrizen nicht veröffentlicht.

Um Ihr Architekturmodelle im Web veröffentlichen

1. Stellen Sie sicher, Sie haben die entsprechende ABACUS-Dateioffen, enthält die besiedelte Architekturdass Sie auf der Web veröffentlicht werden soll.

2. Auswählen Datei| Veröffentlichen....

3. das Im Web veröffentlichen ConfigurationFenster wird angezeigt.

Im Web veröffentlichen Configuration

4. Standardmäßig sind alle Teile des Modells sind so gewählt, einschließlich der Strukturansicht, die StandardsDie Typen, Templates und Architektur (en). Deaktivieren Sie alle Teile die Sie nicht wollen, um im Web zu veröffentlichen, einschließlich der einzelnen Ansichten in der Architektur (en).

Spitze

Wenn Sie bestimmte Komponenten, Verbindungen und / oder ihre Eigenschaften ausblenden möchten, wird empfohlen, dass ein Administrator mit Rolle eines "öffentlichen" Rollenbasierte Zugriffsfunktion ABACUS ' und entfernt dann die Leseberechtigung von diesen Komponententypen, Verbindungstypen und / oder Eigenschaften, die sie nicht wollen, veröffentlicht. Dann sollte ein Benutzer unter dieser Rolle melden Sie sich an und tragen zum Netz wie ABACUS nur Elemente, die die Erlaubnis für die Rolle gesetzt Lesen Sie zu veröffentlichen. Darüber hinaus können Benutzer automatisch veröffentlichen, von der Kommandozeile, wie beschrieben, Hier .

Notiz

Sie können alle durch einen Klick auf das angezeigte Teile wählen AlleTaste oder Invertzucker Ihre Auswahl, indem Sie auf die Umkehren Taste. Sie können auch auf das klicken KeineTaste um die Auswahl zu löschen.

Notiz

wenn du deaktivieren Sie die Option Baumansichtdann kein Baum-Rahmen (siehe unten) werden veröffentlicht. Entsprechend, sollten Sie eine Startseite gemäß Schritt 6 unten oder wählen Sie nach der Veröffentlichung müssen Sie entweder die Top-Level anpassen; ein) index.htmlDatei, indem Sie die 'Frame src = "mainPage.html" name = "element_details"' Zeile in eine direkte Verknüpfung zu der entsprechenden HTML-Seite unter dem Inhaltsordner, oder, b) mainPage.htmldurch einen Hyperlink oder eine Weiterleitung an die entsprechenden HTML-Seite unter dem Inhaltsordner.

5. Drücke den Option Taste und die folgenden Publisher-OptionenDialog wird angezeigt.

Veröffentlichenäh Optionen

6. Swählt den 3D, Diagrammund Charts Formate und ob der Titel, Beschreibung und Eigenschaften zeigen, für die Aussicht aus den verfügbaren Optionen (siehe Hinweis unten für Kommentare zu den verschiedenen Formaten).

7. Wenn Sie die Startseite der veröffentlichten Modell zu einer bestimmten Ansicht verwenden möchten, dann überprüfen Sie die Verwenden anzeigen Als Startseite festlegenOption und suchen Sie die Ansicht über die Schaltfläche "...", die aktiviert wird.

Notiz

Nur die in den Bereichen Teilstück nach Schritt 4 ausgewählten Ansichten oben stehen als Startseite festgelegt werden.

8. Wenn Sie Feedback zu bestimmten Seiten in der veröffentlichten Modells erhalten dann sicherstellen, dass die E-Mail FeedbackOption ausgewählt ist, Geben Sie eine E-Mail-Adresse in das E-Mail-Addresse Textfeldund bearbeiten Sie die Email KörperAbschnitt gegebenenfalls. Wenn Sie nicht wünschen, haben Rückmeldungen gesendet und deaktivieren Sie die E-Mail FeedbackOption und lassen Sie das Textfeld leer.

9. Klicken Sie auf OK Taste.

10. Klicken Sie auf Durchsuchen Taste.

11. das Ordner suchenFenster wird angezeigt.

12. Wählen Sie den Speicherort Sie die Top-Level-HTML-Datei (und alle automatisch generierten Dateien) gespeichert werden soll.

Notiz

Es ist eine gute Idee, einen bestimmten Ordner (in der Regel als "Veröffentlicht") mit dem Knopf Neuen Ordner erstellenSchaltfläche am unteren Rand des Dialog die Top-Level-HTML-Datei und keine automatisch generierten Dateien zu speichern.

13. Klicken Sie auf OK Taste.

14. Der Ordnerpfad wird im Display Verzeichnis Textfeld.

15. Klicken Sie auf Fertig Taste.

- oder -

15. Geben Sie den Pfad des Ordners in das VerzeichnisTextfeld, wo Sie die Top-Level-HTML-Datei (und alle automatisch generierten Dateien) gespeichert werden soll.

16. Klicken Sie auf Fertig Taste.

Notiz

Exportieren Diagramssehr selten ausfällt, am häufigsten, wenn der Computer aus dem Speicher (in der Regel bei der Verwendung von sehr großen Dateien). Eine nicht bestandene Ausfuhr wird einmal wiederholt. Es wird eine Warnung für einen fehlgeschlagenen ersten Versuch, und eine zweite Warnung, wenn die Wiederversuch fehlschlägt. Deshalb, wenn die einzigen Warnungen sind "erste Versuch fehlgeschlagen" diejenigen, die zu veröffentlichen war erfolgreich. Wenn der Wiederversuch fehlschlägt versuchen, die Veröffentlichung einer kleineren Teil Ihrer Datei oder kostenlos bis einige Systemspeicher.

Die gespeicherten HTML-Datei (en) können jetzt von ihrem Standort oder auf eine sichere Website kopiert werden.

Im Web veröffentlichen in Internet Explorer10

Irgendein Hyperlinks die in der ursprünglichen Modells erstellt wurden, werden in der veröffentlichten Modell beibehalten werden, und klicken Sie auf den Link gelangen Sie den Link zu seinem Ziel zu folgen (wenn es veröffentlicht wurde). Darüber hinaus werden alle Elemente in der veröffentlichten Diagramme, die nicht bereits in der ursprünglichen Modells mittels Hyperlink verwiesen wird zurück in ihre entsprechenden Elemente in der Strukturansicht (wenn es veröffentlicht wurde) und durch Klicken auf das Element in der veröffentlichten Plan wird der Schwerpunkt um zurückzuspringen Hyperlink von die entsprechende Stelle in dem Baum. Diese Funktion ist ähnlich wie die "Im Explorer anzeigen" Rechtsklick-Funktion in ABACUS.

Notiz

Avolution empfiehlt dringend, die folgende Software und Dateiformate zu verwenden, um in vollem Umfang nutzen das Web veröffentlichen Funktionalität in ABACUS werden:

1. Internet Explorer (80,0 und darüber)um die veröffentlichte Explorer-Ansicht anzuzeigen. Mozilla Firefox (30,0 oder höher)wird auch empfohlen und vollständig unterstützteJedoch, wenn mit der empfohlenen SVG-Format für Diagramme dann in Firefox 9 können Sie nur die native SVG Viewer unterstützen die leider nicht erlaubt Zoomen oder Panning.

2. Adobe SVG Viewer 3.0 Steck (Download Hier ) und SVGDateiformat für die veröffentlichte Diagramme. Die SVG-Datei-Format für den Diagrammewird, weil empfohlen; SVG ist ein vektorbasiertes Bildformat und daher ist es "verlustfrei" und sieht viel besser zu einem bestimmten Zoomstufe als alle anderen Formaten SVG lassen sich in MS Visio importiert werden können SVG auf jede Ebene oder die Auflösung vergrößert werden hat SVG Verbindungen zurück zu der Baumansicht für die Anschlüsse (nicht nur die Komponenten), SVG druckt immer an einer besseren Auflösung und, SVG ist etwa die Hälfte der Dateigröße der anderen Formate. PNG ist die nächste Empfehlung, aber da es ein gerasterten Format zu bestimmten Zoomstufen die Klarheit der Blick verloren und klicken Verbindungen in Diagrammen werden nicht zurück zu der betreffenden Stelle im Baum zu springen. BMP ist als während es ein "verlustfrei" zu formatieren die Dateigröße ist 100x, dass der andere Formate und 20Mb Bilder werden nicht ungewöhnlich abgeraten.

Die Trade-off mit SVG ist, dass ein SVG-Viewer muss installiert sein und Sie brauchen stellen Sie sicher, dass SVG-Bild / svg + xml wird MIME-Typen des Web-Servers hinzugefügt. Nach der Installation des SVG-Viewer Microsoft Internet Explorer fordert Sie auf Lizenzvereinbarung des Betrachters anzunehmen und dann sollte es okay sein. Und währendMozilla Firefox unterstützt SVG-Dateien nativ, das Adobe-Plugin wird weiterhin empfohlenin der Lage sein, um zu vergrößern die Diagramme, wenn Sie Firefox 8 oder früher sein (wenn Sie Firefox 9 können Sie die native SVG-Viewer nicht deaktivieren). Sobald die Installation für die Adobe-Plugin ausgeführt wurde, werden die folgenden Schritte sind erforderlich, verwenden Sie es in Firefox:

· Öffnen Sie Firefox und geben Sie "about: config" (ohne die Anführungszeichen) in die URL-Leiste.

· Blättern Sie nach unten und finden Sie die Unterkunft svg.enabled(wenn Sie mit Firefox 9 werden dann die native SVG Betrachtung kann nicht deaktiviert werden und diese Eigenschaft nicht vorhanden ist). Doppelklicken Sie darauf, um es zu deaktivieren.

· Jetzt finden das Verzeichnis, in das SVG-Plugin installiert ist (zB C: \ Programme \ Gemeinsame Dateien \ Adobe \ SVG Viewer 30,0 \)

· Kopieren Sie die Dateien NPSVG3DLL und das NPSVG3.zip und fügen Sie sie in das Plugin-Verzeichnis firefox (zB C: \ Programme \ Mozilla Firefox \ plugins)

· Schließen Sie alle Instanzen von Firefox

3. Avolution der ABACUS 3D Viewer (3.1 und höher) und Avolution die .abacus3DDateiformat für die veröffentlichten 3D-Ansichten. Während Cortona VRML Client-Plug-in (2.0 und höher)ist für VRML-Versionen der veröffentlichten Ansichten es ist nicht frei für die kommerzielle Nutzung und immer noch zu sehen erfordert eine clientseitige Installation. Die ABACUS 3D Viewer ist mehr feature-rich als jede VRML-Viewer und steht zum Download zur freien Verfügung Hier . In jedem Fall stellen Sie sicher, fügen .vrml x-world / x-VRML und .abacus3d application / octet-stream, um MIME-Typen des Webservers.

4. PNGDateiformat für die veröffentlichten Diagramm Blick. Das PNG-Bildformat für das Diagramm Blick ist da zu empfehlen, während es ein gerasterten Format, und es gibt "Verlust" der Kompromiss zwischen Dateigröße und Chart Klarheit ist in der Regel die besten. BMP ist als während es entmutigt ein "verlustfrei" zu formatieren die Dateigröße ist 20-fach, dass der andere Formate und 2Mb Charts sind nicht ungewöhnlich.

Wenn Sie das Aussehen der Fan der Internetseiten möchten, können Sie die Startseite Datei namens mainPage.html und die Stylesheet-Datei mit dem Namen abacus.css bearbeiten. Sie finden diese Dateien im selben Ordner finden, in dem Sie die Top-Level-HTML-Datei gespeichert haben. Für weitere Informationen über den Aufbau und die Anpassung der veröffentlichten Ausgabe finden Sie im nächsten Abschnitt.

Die Struktur der ABACUS veröffentlichten Modellen

Die ABACUS veröffentlichten Modell ist wie folgt aufgebaut:

1. Der Ordner der obersten Ebene enthält mehrere Dateien und unter der Annahme, alle Optionen sind in der ABACUS enthalten Web veröffentlichen Konfigurationsdialog wird eine include Index.htmlDatei aus drei Rahmen; treeView.html, findNode.html und mainPage.html und dann shortcutError.html Seite. Die treeView.html wird durch die bevölkerten Tree.js, tree_items.js und tree_tpl.js Javascript-Dateien unter dem Ordner enthalten (siehe unten) und repliziert die Explorer-Baum von ABACUS. Die findNode.html der Firma das find.js Javascript-Datei unter dem Ordner enthalten (siehe unten) und es werden die Zweige des Baumes nicht nur die sichtbaren Knoten zu suchen. Ter mainPage.html ist eine statische HTML-Seite, die mit Firmenlogos und dergleichen zugeschnitten werden könnenund wird angezeigt, sofern ein Startseite wird gewählt, wenn die Veröffentlichung werden.Und schließlich die shortcutError.html Seite ist eine Zielseite für defekte Verknüpfungen von dem Baum durch die entsprechenden Seiten nicht veröffentlicht.

Spitze

Sie können die mainPage.html ganz überspringen, indem Wahl eine Startseite zu verwenden, wenn die Veröffentlichung oder Modifizieren Sie die Datei index.html, um direkt zu einer bestimmten Ansicht (beispielsweise), indem Sie den Rahmen src = "mainPage.html" Linie direkt an die erste Ansicht in der ersten Architektur zeigen, in der Regel die "Rahmen" Diagramm zeigen.

2. Die Top-Level-includeOrdner enthaltening verschiedene Javascript (JS) und Cascading Stylesheet (CSS-Dateien) durch die HTML-Dateien im gesamten veröffentlichten Modell verwendet.

3. Der Inhalt Ordner der obersten Ebene enthält, alphabetisch;

· EIN '3D- Ansichten' Ordner mit einemnummerierteHTML-Seite und eine VRML oder abacus3d-Datei für jede der veröffentlichten 3D-Ansichten. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· Ein Architekturen Ordner mit einem nummerierten HTML-Seite für jede Architektur, die veröffentlicht wurde. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· A Kataloge Ordner mit einer nummerierten HTML-Seite für jeden der veröffentlichten Kataloge. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· A Charts Ordner mit einemnummerierteHTML-Seite und eine PNG, JPG etc Datei für jede der veröffentlichten Diagramm Ansichten. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· A Components Ordner mit einnummerierteHTML-Seite für jeden der veröffentlichten Komponenten. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· A Anschlüsse Ordner mit einnummerierteHTML-Seite für jeden der freigegebenen Verbindungen. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· A Diagrams Ordner mit einnummerierteHTML-Seite und eine PNG, SVG usw. Datei für jedes der Veröffentlichung Diagramme. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· Ein icons UnterMappe mit verschiedene Bilder in der gesamten veröffentlichten Modell verwendet.

· A Standards Unterordner mit einnummerierteHTML-Seite für alle Standardsdaß veröffentlicht. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

· A Vorlagen Unter-Mappe mit einer Sammlung von nummerierten Unterordner für jedes aus dem Projekt veröffentlicht Vorlage. Innerhalb jedes Unterordners ist ein Komponenten und einen Ordner Connections und innerhalb dieser ist eine nummerierte HTML-Seite für jede Komponente und dem Anschluss der Vorlage. Siehe Hinweis unten für Informationen über die Ordner- / Dateinummerierungsschema.

· A Typen Unterordner mit Component undAnschluss Unterordner mit einnummerierteHTML-Seite für jede Komponente undVerbindungstypen, die veröffentlicht wurden,und eine Sammlung von nummerierten Unterordner für jeden Typ aus dem Projekt veröffentlicht, das eine HTML-Seite für jede der Einschränkungen. Siehe Hinweis unten für Informationen über die Ordner- / Dateinummerierungsschema.

· A AussichtPunkts Unterordner und einenummerierteHTML-Seite für einen der AnsichtPunkts, die veröffentlicht wurden. Siehe Hinweis unten für Informationen über die Dateinummerierungsschema.

Notiz

Die Nummerierung der HTML-Seiten (und in einigen Fällen das Bilddateien) bringt die einzigartig ICH WÜRDE für jedes Repository-Objekt, das war gesetzt, wenn es war erstelltinnerhalb ABACUS (als EEIDs bezeichnet). Diese ID ist nicht so ändern als Diagramme, Typen, Komponenten etc gibt aktualisiert sie werdenbehalten die gleiche ID wie zuvor. In jedem Fall ist die relevante Repository-ObjektName kann in der Nähe der Start der HTML-Seite zwischen den

... HTML-Tags finden.

Beschränken des Zugriffs auf bestimmte Seiten / Ansichten mit IIS

Bei Verwendung von IIS als Web-Server für die veröffentlichte Modell, können Sie in der Lage, den Zugriff auf bestimmte Seiten / Ansichten unter Verwendung des Verfahrens unter beschränken:

1. Erstellen Sie eine Website in IIS (ein anderes, wenn es eine vorhandene Sie wollen nicht zu stören).

2. Ändern Sie den Eigenschaften-> Verzeichnis Security-> Anonymer Zugriff - deaktivieren Sie den anonymen Zugriff und die Nutzung authentifizierten Zugriff.

3. Ist dies nur ein normaler Server ohne Domain-Komplikationen etc, dann sollten Sie die Option "Integrierte Windows-Authentifizierung", die dann würden die Server-Maschinen lokale Benutzer / Anmeldungen wie die Authentifizierung verwenden, und nur Benutzer auf dem lokalen Computer hinzuzufügen (wobei Sie darauf achten dass Sie wissen um die Konsequenzen, Sicherheits weise, der das Hinzufügen neuer Benutzer an der Maschine, zB je nachdem, ob RAS-Setup für die Maschine, etc).

4. Hinzufügen von Berechtigungen auf die speziellen Dateien / Ordner nach Bedarf. Rechtsklicken Sie auf die einzelnen Dateien / Ordner -> Eigenschaften, und stellen Sie die Sicherheitsberechtigungen, wie Sie in der Regel für Dateien / Ordner würden.

Dies kann je nachdem, welche Version von IIS und welche spezifischen Windows-Betriebssystem auf dem Server, und ob Sie eine Domäne oder andere unterschiedliche Setup haben abweichen.

Sehe auch

Auffüllen der Architektur | Analyse Ihrer Architektur


Exportieren Sie Ihre Architektur

Navigation: Die Berichterstattung über Ihre Architektur>

Exportieren Sie Ihre Architektur

Senden Sie Kommentare Zu diesem Thema.

ABACUS können Sie zuexportieren Sie Ihre Architektur zur .mdb (Microsoft Access), MS SQL Server, .abacus (ABACUS-Datei) und .xls (Microsoft Excel) Format. Sie können auch exportieren Sie Ihre Diagramms, um PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF und BMP-Format und Ihre Berichte an .html (HTML), PDF (Adobe Acrobat), .xls (Microsoft Excel), DOC (Microsoft Word) und Formate RTF (Rich Text Format). Dies ermöglicht Ihnen, zu analysieren und sehen Sie die Architektur und die Daten in irgendeiner Weise Sie wollen.

Ihre Architektur zu exportieren .mdb (Microsoft Access)

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Klicken Sie auf Datei Menü.

3. Auswählen Export, und dann Um MDB.

4. Beachten Sie die Warnung und klicken Sie auf OK.

5. Geben Sie einen Namen für die Datei.

6. Drücke den sparen Taste.

Notiz

Das Exportformat des MDB-Datenbank spezifisch für ABACUS und alle Schemaänderungen werden in die Unfähigkeit, wieder importieren führen. Bitte lesen Auffüllen mit MS Access Eine Beschreibung der MS Access-Schema.

Ihre Architektur exportieren MS SQL Server

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Klicken Sie auf Datei Menü.

3. Auswählen Export, und dann Um MS SQL Server.

4. In dem Dialog, der erscheint, klicken Sie auf Export Leere MDB ...Taste und importieren Sie diese in Ihre MS SQL Server-Datenbankserver.

5. Füllen Sie die Datenbankinformationen und der Verbindungszeichenfolge.

6. Drücke den Export Taste.

Notiz

Das Exportformat des MS SQL ServerDatenbank spezifisch für ABACUS und alle Schemaänderungen werden in die Unfähigkeit, wieder importieren führen. Bitte lesen Auffüllen mit MS Access für eine Beschreibung des Datenbankschemas.

Ihre Architektur zu .xls exportieren (Excel-Datei)

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei geöffnet , ein Explorer angezeigt , und ein Architektur hinzugefügt .

2. Stellen Sie sicher, Sie haben ein Excel Import / Export-Konfigurationsdatei definiert.

3. Rechtsklickauf einer Architektur, in Ihrem Modell oder jeder Teil der ComponentsKnoten (innerhalb einer bestimmten Architektur), die Sie in der Excel-Konfigurationsdatei exportieren möchten.

4. Auswählen Export | Zu Excel ... aus dem Menü.

5. das Wählen Sie Excel-Import / Export-Konfigurationsdatei zu verwendenFenster wird angezeigt.

6. Wählen Sie die entsprechende Konfigurationsdatei für Ihre Architekturmodell und klicken Sie auf Öffnen Taste.

7. Falls nicht automatisch geschehen, Karte die Top-Level-Komponenten in Ihre aktuelle Architektur, um die Set ID(wie vorstehend definiert) und klicken Sie auf Export....

Beispiel Top-Level-Komponenten-Mapping

8. Wählen Sie einen Speicherort und Dateinamen für Ihre Excel-Datei und klicken Sie auf die sparen Taste.

Ihre Architektur zu .abacus exportieren (ABACUS-Datei)

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Rechtsklickauf der Architektur-Knoten auf jeder Architektur im Modell oder ein Teil der Komponenten Baum.

3. Auswählen Export | Zu Datei...aus dem Menü.

4. Wählen Sie einen Speicherort und einen Dateinamen und klicken Sie auf die sparen Taste.

Notiz

Sie können eine Datei wieder in ABACUS ABACUS importieren, indem Sie folgende Schritte durch 1-2oben und anschließende Auswahl Import | Von Datei.... Nachdem Sie die Datei, die Sie importieren möchten, ausgewählt haben, werden Sie gefragt, wie Sie möchten, um die Standards und Typen zu importieren. Sie können Normen und Typen, wie neue oder fusionierte Normen und Typen zu importieren. Die Standardeinstellung ist für die Normen und Typen, um mit bestehenden Normen und Typen zusammengeführt werden, wenn sie bereits in Ihrer vorhanden Projekt.

Ihre Architektur exportieren .xml

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Rechtsklickauf einer Architektur-Knoten auf jeder Architektur im Modell oder ein Teil der Komponentenbaum.

3. Auswählen Export | Zu XML ...aus dem Menü. Alternativ können Sie auf das Menü klicken Datei| Export| Zu XML ...

4. Wählen Sie einen Speicherort und einen Dateinamen und klicken Sie auf die sparen Taste.

Notiz

Sie können eine XML-Datei zurück in ABACUS importieren, indem Sie folgende Schritte durch 1-2oben und anschließende Auswahl Import | Von XML .... Nachdem Sie die XML-Datei, die Sie importieren möchten ausgewählt haben, werden Sie gefragt, wie Sie möchten, um die Standards und Typen zu importieren. Sie können Normen und Typen, wie neue oder fusionierte Normen und Typen zu importieren. Die Standardeinstellung ist für die Normen und Typen, um mit bestehenden Normen und Typen zusammengeführt werden, wenn sie bereits in Ihrer vorhanden Projekt.

Um PNG, JPG, SVG, TIFF, GIF oder BMP exportieren Diagramm

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Öffne das DiagrammSie möchten, um zu exportieren.

3. Klicken Sie auf Export DiagramTaste auf der Diagramm Symbolleiste.

4. das Export-DiagrammFenster erscheint.

5. Wähle aus DurchsuchenTaste, um die Visualisierung in der gewünschten Position zu speichern.

6. Wähle aus DateitypPulldown-Menü, um den Dateityp zu wählen.

7. Drücke den sparen Taste.

Um Ihren Bericht zu .pdf (Adobe Acrobat) zu exportieren, XLS (Microsoft Excel) oderDOC (Microsoft Word)

1. Stellen Sie sicher, Sie haben ein ABACUS-Datei öffnen.

2. Ein ... kreieren Bericht Sie möchten, um zu exportieren.

3. Klicken Sie auf ExportSchaltfläche auf der Werkzeugleiste Berichte.

4. Auswählen Excel, PDF oder Word-aus dem Dropdown-Feld.

5. Warten Sie einen Moment, während die Exporte Bericht.

6. Wählen Sie einen Speicherort und einen Dateinamen und klicken Sie auf die sparen Taste.


Arbeiten mit Enterprise Server

Navigation: Administration>

Arbeiten mit Enterprise Server

Senden Sie Kommentare Zu diesem Thema.

ABACUS Enterprise- Server ist sowohl ein "Non-Locking" kooperativen Ansatz, sondern eine 'getrennt' man auch. ABACUS ist "Nicht-Verriegelung", weil es nicht zwingen die Datei durch einen Benutzer gesperrt ist, damit es aktualisiert werden kann. Jeder Benutzer hat seine eigene lokale Kopie der Datei, und da sie Änderungen vornehmen und speichern Sie die Datei, werden diese Änderungen aufgezeichnet und, wenn der Benutzer, um sie an den Server zu begehen will gespeichert.

ABACUS ist "getrennt" im Sinne, die Sie nicht brauchen, um mit dem Server verbunden oder müssen den Netzwerkzugriff während der Arbeit an einer Datei werden. ABACUS benötigt nur Zugriff auf den Server bei der Durchführung von Operationen wie das Erstellen einer Datei oder der Durchführung einer Kasse, zusammen mit Operationen an eine bestehende Datei - Update, zu begehen, oder sehen Sie das Protokoll der letzten begeht. Zugriff auf den Server ist nicht erforderlich, auf die Datei zu arbeiten, und die Änderungen sind nicht sofort an den Server gesendet (dies können Sie ganz einfach Ihre Änderungen verwerfen, wenn Sie einen Fehler machen). Wenn Sie Ihre Datei speichern, Sie sind "nur" Speichern Ihrer Kopie lokal - es ist nicht, bis Sie sagen zu, dass Ihre lokalen Änderungen werden an den Server gesendet (Änderungen seit dem letzten Commit gemacht).

Erstellen einer neuen Enterprise File

Um eine neue Enterprise-Datei zu erstellen, wählen Sie Datei| Neu ...und wählen Sie eine der ersten beiden Optionen unter dem Abschnitt der Unternehmensmodell Dialog Neues Projekt (dh entweder eine leere Enterprise-Datei oder erstellen Sie eine aus einer bestehenden ABACUS-Datei). Die dritte Möglichkeit ist die "Kasse" ein Enterprise-Datei jemand anderes bereits erstellt hat, wird dies im nächsten Abschnitt behandelt werden.

Wenn Sie wählen, um eine neue Enterprise-Datei zu erstellen, werden Sie einen Dialog, mit dem Sie, wo auf einem Repository-Server Sie möchten, um Ihre Datei zu speichern blättern gegeben. Es wird auch die vorhandene Datei Pfad und Name eingetragen bis die Spitze, wenn Sie wählten "Aus bestehender Model 'aus dem Dialogfeld Neues Projekt und eine Datei geliefert.

URL: Dies ist die URL zu Ihrer Repository-Server, wo die ABACUS Enterprise-Dateien gespeichert sind. Sie sollten die Person, die die Verwaltung des Servers, was diese URL sollte, ist zu fragen.

Das obige Bild zeigt ein Repository mit vier (4) bestehende ABACUS Enterprise-Projekte, nach der Eingabe der URL und die Eingabetaste drücken. Sie werden sehen, nachdem Sie eine neue Enterprise-Datei zu erstellen, auf dem nächsten Screenshot "Zur Kasse", gibt es eine weitere Ordner und Dateien im Rahmen dieses Repository.

Notiz

Wenn Sie eine HTTPS (SSL) Server, und der Server nicht über ein gültiges SSL-Zertifikat (gemeinsam für Intranet oder nicht-öffentlichen Servern aufgrund von das Kosten für die SSL-Zertifikats) Wird es einen zusätzlichen Schritt zu nehmen. Sie werden benötigt, um alle Verbindungen zu diesem Server im Dialogfeld, das erscheint, dauerhaft zu akzeptieren (auch alle ein bisschen mehr Informationen auf dem Server). Um dies zu tun, geben Sie "p" (ohne die Anführungszeichen) und drücken Sie Enter. ABACUS öffnet sich eine Nachricht erinnert Sie dies vor, die den Dialog.

Notiz

Sie können aufgefordert werden, um den Server in diesem Fall die Person, die anmelden werden die Verwaltung des Serverskönnen die Server-Benutzernamen und ein Kennwort angeben. Auch die Anmeldeinformationen für alle Server, die Sie angeschlossen haben, um gerettet zu werden, so wenn aus irgendeinem Grund müssen sie klären kann dies über durchgeführt werden werden Tools | Optionenund dann auf den General Registerkarte durch Klicken auf Zurücksetzen Subversion Gespeichert Anmeldenund die Auswahl der Server aus der Dropdown-Liste aus und klicken Klar Anmeldenund Auswählen von OK in dem erscheinenden Dialog.

Notiz

Im Gegensatz zu dem oben gezeigten Screenshot wird in der Regel eine einzige ABACUS-Projekt in jedem ABACUS Repository enthalten, weil, wenn mehr als 1 ABACUS-Projekt wird in einer einzigen ABACUS Repository angelegt werden die ABACUS Änderungsprotokoll Zahlen über alle ABACUS Projekte geteilt und dies kann den Benutzer verwirren.

Bevorzugte Dateiname: Dies betrifft sowohl den Ordner und den Dateinamen, der verwendet werden wird (falls nicht schon gemacht) beim Erstellen der Datei auf dem Repository-Server. Beachten Sie, dass ein neuer Ordner wird automatisch auf dem Repository-Server für jede Datei erstellt (aus Leistungsgründen, ABACUS Enterprise-Dateien werden in einem eigenen Ordner unter dem Ort im Dialogsucht erstellt).

Bewahren Arbeitskopie im Verzeichnis: Wenn eine Enterprise-Datei auf einem Repository-Server erstellt haben, müssen lokale Arbeitsdateien auf dem Computer erstellt werden, so dass Sie auf die Datei, ohne mit dem Netzwerk verbunden zu arbeiten. Dies ist der Ort, den Sie, wenn Sie zu öffnen / wieder öffnen eine ABACUS Enterprise-Datei möchten.

Kasse einer vorhandenen Enterprise File

Sollte jemand bereits eine neue Enterprise-Datei erstellt, kann 'Kasse' Diese Datei, die eine lokale Kopie herunter und legt die erforderlichen Dateien, so ABACUS erkennt dies als Enterprise-Datei. Der Dialog ist ähnlich dem New Enterprise File Dialog. Geben Sie die Repository-URL (Unterverzeichnisse können in der URL enthalten sein), wählen Sie die gewünschte Datei aus und klicken Sie auf OK. Vorbehaltlich der Anmerkung unten tEr Datei wird dann geöffnet werden.

Notiz

Sie können aufgefordert werden, um den Server in diesem Fall die Person, die anmelden werden die Verwaltung des Serverskönnen die Server-Benutzernamen und ein Kennwort angeben. Auch die Anmeldeinformationen für alle Server, die Sie angeschlossen haben, um gerettet zu werden, so wenn aus irgendeinem Grund müssen sie klären kann dies über durchgeführt werden werden Tools | Optionenund dann auf den General Registerkarte durch Klicken auf Zurücksetzen Subversion Gespeichert Anmeldenund die Auswahl der Server aus der Dropdown-Liste aus und klicken Klar Anmeldenund Auswählen von OK in dem erscheinenden Dialog.

Enterprise File Unterschiede

Wenn Sie eine Enterprise-Datei erstellt haben (entweder neu, oder über "Kasse" einer Datei, die von jemand anderem), einen Ordner für die Datei erstellt werden, und es wird häufig enthalten diese 3 wichtigsten Arten von Dateien:

· Datei '.abacus'- Das ist die ABACUS-Datei selbst. Änderungen, die Sie vor Ort zu machen sind nicht sofort in diese Datei gespeichert wird, wird es nur, wenn Sie verpflichten geschrieben. Diese Datei ist eine "normale" ABACUS-Datei, kann es zu nicht-EE-Benutzer gegeben werdenals Stand-alone-Projekt (ohne die log-Datei)Oder als Ausgangspunkt für eine neue EE-Datei verwendet.

· Datei '.changes'- Die lokalen (nicht festgeschriebenen) Änderungen an der Datei vorgenommen. Wenn diese Datei fehlt, bedeutet dies, gibt es keine lokalen Änderungen.

· '.Logdatei- Diese Datei hat nur die Änderungen, die durch den letzten Benutzer (die Inhalte .changes-Datei des Benutzers, wenn sie begangen) vorgenommen wurden.

Notiz

Es gibt verschiedene andere Dateien, die während der Aktualisierung erstellt und verpflichten Prozesse, nämlich sein kann; ‘.changesbefore' Datei- Diese Datei ist eine Kopie des .changes Datei nach ein Update durchgeführt wurde und wird benutzt, um ID-Konflikte zwischen dem Update und einem lokalen (nicht festgeschriebenen) automatisch zu versöhnen Änderungen, bevor begehen; ‘.backup' Datei- Diese Datei ist eine Kopie des .changes Datei, bevor ein Benutzer spart mehr lokale (nicht festgeschriebenen) Änderungen an der .changes Datei; und ‘.Fehler' Datei- Diese Datei ist eine Kopie der .changes Datei, ob es eine Frage, die ABACUS verursacht zu scheitern, um die Datei zu öffnen .abacus und der Benutzer wählen, um ihre Änderungen rückgängig machen.Diese Dateien können ignoriert werden.

Öffnen einer Datei

Um eine Datei zu öffnen, müssen Sie nur auf dem Sie die Arbeitskopie zu speichern, und öffnen Sie die ABACUS-Datei, die dort gespeichert sind, wählte zu durchsuchen. Wenn ABACUS sieht, dass es eine .Log-Datei (und vielleicht ein .Änderungen einzureichen, wenn Sie Änderungen vorgenommen haben), wird die Datei als Enterprise-Datei zu behandeln.

Aktualisieren einer Datei

Durchführen einern "Aktualisieren" wird überprüft, ob eine neuere Version einer Datei auf dem Server befindet. Wenn ja, wird sie Ihre aktuelle Datei zu schließen, zu aktualisieren, um die neuere Datei vom Server, und downloaden Sie einige temporäre Dateien, die eine Zahl als Erweiterung haben - zB 'Demo.125'. Diese Dateien sind die älteren Versionen der log-Datei, und werden verwendet, um festzustellen, welche Änderungen an einer Datei vorgenommen wurden, seit Sie zuletzt aktualisiert es. Dies ist notwendig, um Konflikte, die aufgetreten kann, so dass Sie sie zu lösen haben, zu erkennen.

Ob während der Aktualisierung jeder Konflikte wurden gefunden, Sie benötigen, um sie zu lösen, bevor Sie Ihre Datei erneut zu öffnen (Sie kündigen können aber werden Sie aufgefordert, die Konflikte wieder zu lösendas nächste Mal, wenn Sie Ihre Datei zu öffnen).

Speichern einer Datei

Wenn Sie eine Datei zu speichern, hängt dies alle Änderungen an der .changes Datei gemacht haben. Es nichtÄndern Sie die .abacus Datei zu diesem Zeitpunkt - nur, wenn die Datei auf den Server wird sie überschrieben werden (oder wenn Sie ein Update vom Server zu empfangen) verpflichtet.

Wo ist 'Speichern unter'?

Es gibt kein Konzept von Speichern für Enterprise-Dateien. Sie können jedoch Ihre Arbeitskopie kopieren .abacus Datei, wenn man bedenkt, dass sie gewohnt haben, Ihre lokalen Änderungen darin.

Lösen von Konflikten

Wenn andere Benutzer haben engagierte Änderungen an der Datei in einem ähnlichen Teil der Datei, Sie, kann es einige Konflikte zwischen ihren Änderungen und Ihnen. Zum Beispiel kann ein anderer Benutzer eine Komponente, die man hatte löschen Aktualisieren einer Immobilie auf. Sie müssen entweder rückgängig zu machen ihrer Änderung (wenn Sie sicher sind, dass ihnen solltennicht passiert), oder verwerfen Sie die Änderung (Sie können anschließend wieder in der Datei gehen und wiederholen Sie Ihre ändern).

Genauer gesagt gibt es 4 Klassen von Konflikten, die auftreten können;

1. Löschen - Wenn ein Benutzer ein Objekt, dass ein anderer Benutzer Änderungen löscht. Z.B. Benutzername Ein gelöschtes eine Komponente, aber Benutzer B änderte den Namen der Komponente oder mit ihm verbunden oder hinzugefügt eine untergeordnete Komponente, es usw.

2. Attribut - Wenn zwei Benutzer beide verändern die exakt gleiche 'Attribut' eines Objekts. Z.B. Sowohl Benutzer A und Benutzer B den Namen einer Komponente oder seine Beschreibung oder den Wert der eine seiner Eigenschaften usw. geändert

3. Referenz - Wenn zwei Benutzer genau die gleiche "Referenz" zu ändern ein Objekt auf ein anderes Objekt. Z.B. Sowohl Benutzer A und Benutzer B verändert Typ einer Komponente oder der Quelle / Senke-Komponente zu einem Anschluss oder der gelinkten Sicht für ein Diagramm usw. befestigt

4. Sammlung - Wenn zwei Benutzer ändern eine "Sammlung" für ein Objekt. Z.B. Sowohl Benutzer A und Benutzer B bewegt eine Komponente von einem Elternteil in ein anderes oder nachbestellt eine Sammlung von Kinder-Komponenten.

Notiz

Verschiedene inkonsequent Konflikte werden automatisch von ABACUS beschlossen, den Overhead auf die Benutzer zu minimieren.Zum Beispiel entgegenstehende pan-Zoom-Einstellungen für Diagramme sind entschlossen, die neuesten pan-Zoom-Einstellungen zu halten.

Begehen Änderungen

Wenn Sie wählen, um Ihre Änderungen zu übernehmen, die ABACUS-Datei vom Server Öffnen Sie Ihre lokal Änderungen werden durchgeführt, dagegen, und dann Ihren lokalen .abacus Datei wird mit einem, der die Änderungen in sie überschrieben. Ihre Änderungen Datei überschreibt dann die log-Datei, und sowohl die .abacus-Datei und die log-Datei an den Server gesendet.Wenn der Commit erfolgreich ein Dialog Nachricht Commit, wie unten gezeigt ist vorgesehen, um eine Nachricht mit dem Commit in Kraft.

Anzeigen ein Protokoll der Änderungen

Zu ein Protokoll der Änderungen ein Unternehmen Projekt, auswählen Datei| Ansicht Protokoll...

Maximale Protokolleinträge: Dies wird auf die letzten 10 Einträge standardmäßig aber zusätzliche Einträge können indem Sie den Wert, und klicken Sie die abgerufen werden Abrufen Taste.

Revision: The Revision Spalte listet die Revisionsnummern in die Enterprise-Server begangen, die standardmäßig in umgekehrt chronologischer Reihenfolge.

Notiz

Die Revisionsnummern kann nicht kontinuierlich sein, wie nur der ABACUS Commits werden aufgelistet, während die gleiche Subversion-Repository kann für andere ABACUS Projekte und / oder andere Versionskontrollanwendungen verwendet werden.

Datum: The Datum Spalte werden das Datum, das die Revision wurde dem Enterprise-Server ermöglichen.

Zeit: The Zeit Spalte wird der Tageszeit (im 24-Stunden-Format), dass die Revision wurde dem Enterprise-Server ermöglichen.

Autor: The Autor Spalte listet die Microsoft Windows-Anmeldename für den Benutzer, dass das Commit durchgeführt, gefolgt von ihrer ABACUS Benutzernamen Oder "Anonym", wenn der Benutzer nicht authentifiziert und anonymen Benutzern der Zugriff auf den Enterprise-Projekt zum Zeitpunkt der den Commit erlaubt.

Log-Meldung: ThSpalte E Log-Meldung listet die Commit-Nachricht, die mit der Revision nach dem oben gezeigten Dialog Verfügung gestellt wurde.

Revision herunterladen XX als Stand-alone ABACUS-Datei: Wenn Sie eine bestimmte Revision in der Tabelle auswählen und dann auf die Schaltfläche Download, Sie in der Lage, um die gewählte ABACUS Projekt Revision vom Server zu extrahieren und speichern Sie sie als lokale / Stand-alone-ABACUS-Projekt.

Notiz

Um zu einer früheren Revision rückgängig sehen Sie bitte dieses Avolution Gemeinschaft Artikel .

(Admin) Laden Sie XML-Protokolldatei für die Revision XX: Benutzer mit der ABACUS Administrator-Fähigkeit kann eine bestimmte Revision in der Tabelle auswählen und dann auf die Schaltfläche Download, um zu extrahieren die gewählte ABACUS Projekt verpflichten Log-Datei vom Server und speichern Sie es als XML-Datei.

Anzeigen eines Audit Trail der Änderungen

Zu sehen einen Audit Trail der Änderungen an einem bestimmten Element (dh Komponente, Verbindung, Blick, Kinder usw.) von einer Unternehmen Projekt, rechten Maustaste auf das Element und auswählen Buchungskontrolle...Setzte die Von und Bis Revision Bereich und klicken Sie auf Suche.

Notiz

Sobald ein Element aus dem Projekt gelöscht Sie nicht mehr in der Lage, bestimmte Audit-Trail-Informationen zu diesem Element zu gelangen. Sie können jedoch nach wie vor die "Eltern" Komponente (zum Beispiel) zugreifen und sehen, Audit-Trail Informationen über das Löschen (in diesem Fall die Auflistung der ID des Elements, das gelöscht wurde).Darüber hinaus ist Component / Anschlussbefestigungs ein "Eigentum" der Verbindungen so Änderung eines angeschlossenen Komponente über die Explorer-Fenster oder auf Diagramme werden im Audit-Trail für eine Verbindung NICHT der Komponente und dem Löschen einer Verbindung und eine neue Verbindung zu zeigen (wie passiert, wenn Sie mit der rechten Maustaste auf "löse" und dann "Verbinden ..." in Katalogen) führt zum Verlust der Audit-Trail-Informationen für die ursprüngliche Komponente führen - Anschlussbefestigungs insgesamt.

Notiz

Standardmäßig wird der Audit-Trail wird rekursiv auf Veränderungen zu überprüfen, um eines der Kinder des ausgewählten Elements. Dies kann zu langen Antwortzeiten führen und dementsprechend kann der Audit-Trail, um das Element selbst durch Abwahl der beschränken Rekursive Option unter der Überprüfungsoptionen'Zahnrad' Schaltfläche in der Symbolleiste in der Audit-Trail-Dialog.

Von Revision: Dies wird auf die erste / älteste Revision für das Projekt auf dem Enterprise-Server vorhanden Standard.

Zur Revision: Dies wird bis zum letzten / neueste Version für das Projekt auf dem Enterprise-Server vorhanden Standard.

Notiz

Nach der Einstellung der von und bis Revisionsbereich auf die Schaltfläche Suchen, spezifische Änderungen an der gewählten Element abrufen.

Revision: The Revision Spalte listet die Revisionsnummern in die Enterprise-Server begangen, die standardmäßig in chronologischer Reihenfolge nach vorne.

Notiz

Die Revisionsnummern unwahrscheinlich kontinuierlich zu sein als nur die, die für die gewählte Element Revisionen angezeigt und nur die ABACUS verpflichtet werden aufgelistet, während die gleiche Subversion-Repository kann für andere ABACUS Projekte und / oder Versionskontrollanwendungen verwendet werden.

Datum: The Datum Spalte werden das Datum, das die Benutzeraktion gemacht wurde.

Notiz

Das angegebene Datum ist die Aktion des Benutzers Datum, nicht das Datum die Revision wurde dem Enterprise-Server ermöglichen. Dementsprechend kann das Datum Commit Datum mit dem gezeigten die entsprechende Revision voraus Datei | Ansicht Protokoll... Befehl.

Zeit: The Zeit Spalte wird der Tageszeit (im 24-Stunden-Format), die der Benutzer Aktion gemacht wurde.

Notiz

Die Zeit gezeigt, ist der Benutzer Aktion Zeit, nicht die Zeit, die Revision wurde dem Enterprise-Server ermöglichen. Dementsprechend ist die Zeit wird sehr wahrscheinlich die entsprechende Revision voraus begehen mit der gezeigten Zeit Datei | Ansicht Protokoll... Befehl.

Autor: The Autor Spalte enthält den Benutzer, dass der Aktion Microsoft Windows Login-Namen, gefolgt von ihren durchgeführt ABACUS Benutzernamen Oder "Anonym", wenn der Benutzer nicht authentifiziert und anonymen Benutzern der Zugriff auf den Enterprise-Projekt zum Zeitpunkt der Aktion des Benutzers erlaubt.

Notiz

Die im Audit Trail Dialog aufgelistet Autor nicht unbedingt entsprechen den Autor in der Ansicht Log-Dialog oben für die gleiche Version aufgeführt. Dies ist da die Dialoglisten View Log der angemeldete Benutzer bei der das Commit während die Dialoglisten Audit Trail der angemeldete Benutzer zum Zeitpunkt der Benutzeraktion, und es ist möglich, dass ein Benutzer Änderungen vornehmen und schicken ihre. changes-Datei an einen anderen Benutzer zu begehen - wie es der Fall, wenn ein externer Benutzer (wie Avolution) ist es, auf einem EE-Projekt zu arbeiten.

Einzelheiten: The-Details Spalte sind die genauen Einzelheiten der Aktion des Benutzers als auf der Enterprise-Server aufgezeichnet.

Spitze

Es ist nützlich, Gruppe durch die Revision Spalte (wie oben im Dialogfeld angezeigt) und / oder die Benutzeraktion Spalte zu leicht klassifizieren die Änderungen des Elements von Interesse.

Die Verwendung von Skripten mit Enterprise-Dateien

Wenn Sie mit Enterprise-Skriptdateien verwenden, sollten Sie sich bewusst sein, wie ein Objekt aus dem Modell richtig zu löschen. Im Allgemeinen, wenn Sie ein Objekt löschen, werden Sie die .Delete () -Methode auf sie, als es nur bei den Mutter Entfernen rufen, statt.

Z.B. wenn Sie als übergeordnetes Element comp2 comp1 hatte und Sie comp2 in Ihrem Skript löschen möchten, sollten Sie comp2.Delete (), anstatt comp1.Components.Remove (comp2) nennen.

Sie verwenden entfernen, wenn Sie beabsichtigen, die comp2 Objekt zu einem anderen Ort innerhalb der Architektur, aber es sollte nicht verwendet werden, wenn die Absicht besteht, das Objekt zu löschen.

Es gibt eine Ausnahme, denn wenn Sie ein Objekt, dass 'lebt' an anderer Stelle in dem Modell entfernen möchten. Arch1 - wenn Sie eine Standard-Instanz von einer Architektur / component / Verbindung entfernen möchten, dann würden Sie so von ihm aus der Instanz Standardsammlung zu entfernen zu tun.Implementierungen.Remove (IMP) - weil es zu löschen wäre es von allen Instanzen zu entfernen.

Ordnungsgemäßen Verwendung in Skripten löschen ist wichtig, weil, wenn ein Objekt aus der Object entfernt und nicht wieder aufgenommen, dann wird es nicht in der Lage, entfernt werden, aber da war es nicht speziell 'gelöscht', Konflikterkennung und -lösung wird nicht einen Konflikt richtig zu erkennen, wenn ein anderer Benutzer war, um zu versuchen, um das Objekt in jeder ihrer Änderungen zu verwenden, und das Endergebnis wird eine beschädigte Satz von Änderungen für den Benutzer sein.

Sehe auch

Wie wird eine Architektur in ABACUS vertreten?


Arbeiten mit Berechtigungen

Navigation: Administration>

Arbeiten mit Berechtigungen

Senden Sie Kommentare Zu diesem Thema.

ABACUS Projekte können rollenbasierteBerechtigungen für jedes Element im Repository. Speziell, feinkörnig Create-Read-Update-Delete (CRUD) Berechtigungen können an der "Gegenstand" (dh Komponente oder Verbindung), ansehen und Attribut (dh Eigenschaft) Stufen eingestellt werden.

Überblick

Bei der Arbeit mit der ABACUS Enterprise- Server Bietet ABACUS feinkörnigen, rollenbasierte CRUD Berechtigungen, um den Zugriff von mehreren Benutzern auf das Repository zu steuern.

Notiz

Um die Berechtigungen in einem ABACUS Projekt der Benutzer-Lizenz muss der Administrator-Fähigkeit zu konfigurieren. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

Berechtigungen können für die Architekturen, Komponenten und Verbindungstypen, Eigenschaften (über deren Typen) eingestellt werden, Vorlagen, Sichtweisen und Pläne, Kataloge, Matrizen, Diagramme und 3D-Ansichten. Wenn Berechtigungen für eine Komponente oder Verbindungstyp alle Instanzen dieses Typs in allen Architekturen in diesem Projekt setzen "erben" diese Berechtigungen. Ebenso, wenn eine Genehmigung für eine Eigenschaft einer Komponente oder Verbindungstyp, der angegebenen Eigenschaft für die Komponente oder Verbindung Instanzen in allen Architekturen in diesem Projekt setzen "erben" diese Berechtigungen. Dementsprechend werden bestimmte Berechtigungen, um die Ansichten, auf denen diese Elemente vorhanden sind anzuwenden. Wenn die Berechtigungen für ein Diagramm, der Ansicht und / oder den Inhalt der Ansicht selbst gesetzt haben verschiedene Berechtigungen angewendet.

Notiz

In der Standardeinstellung keine Berechtigungen für die Elemente innerhalb eines ABACUS Projekt eingestellt. Das ist alle Elemente erstellbar, lesbar, aktualisierbar und löschbar von allen Benutzern sind. Auf diese Weise sollten nur die Berechtigungen für ein gegebenes Element in dem Repository berücksichtigt werden, wenn eine gewisse Berechtigung zu sein beschränktfür eine bestimmte Benutzergruppe. Zum Beispiel, wenn die Berechtigungen für eine bestimmte Benutzergruppe wurden (zB ein Komponententyp) auf ein Objekt hinzugefügt, ließ aber mit alle Berechtigungen aktiviert ist, dann ist das funktionell gleich als ob das Benutzergruppe nicht zu dem Objekt hinzugefügt.

Berechtigungen kann nichtfür bestimmte Instanzen von Elementen eines Architektur festgelegt werden. Beispielsweise können Sie nicht machen eine Anwendungskomponente aktualisierbar noch eine andere nicht. Um diese "Domain Specific 'Berechtigungen effektiv jedoch zu erreichen, kann der Administrator spezifische Elementtypen für die angegebenen Domänen, zB eingestellt Komponententypen "Application - CRM-Domäne" und "Anwendung - HR-Domäne", und setzen Sie die Berechtigungen für jeden Typ entsprechend. Sie können bestimmte Gruppierung Typen für jede Domäne zu machen und dann zu entfernen Aktualisierungserlaubnis für die domänenspezifische Gruppentyp und dies wird Schöpfungen innerhalb und Streichungen aus dieser Gruppierung zu beschränken, sondern der Kinder nicht aktualisieren. Natürlich, wenn die domänenspezifische Gruppierung wurde durch Entfernen Leseberechtigung dann würden die Kinder versteckt werden und dadurch nicht aktualisierbar versteckt. Alternativ, wenn Aussicht (statt explorer) werden in erster Linie verwendet, um zu verwalten / anzuzeigen Ihr Repository könnte eine bestimmte Ansicht für jede Domain eingerichtet werden, und dann wird der Administrator kann die Berechtigungen für jede Ansicht entsprechend eingestellt.

Verwalten von Benutzern und Gruppen

Berechtigungen werden auf das definierte Rolle oder GruppeEbene, im Gegensatz zu den einzelnen Benutzer-Ebene, so dass, während die Mitgliedschaft der Gruppen kann sich ändern, die Berechtigungen können fixiert bleiben. Natürlich, wenn Sie wollen, eine bestimmte Benutzerberechtigung dann einfach machen sie eine Gruppe oder eine Gruppe genauer zu schaffen mit diesem Benutzer als einziges Mitglied.

Es sei darauf hingewiesen, dass die Gruppen werden Atom-, Ist, dass sie Berechtigungen oder Benutzer nicht erben kann von einem zum anderen, und wenn ein Benutzer gehört zu mehreren Gruppen dann die "pessimistisch" Gruppenberechtigung Vorrang auf einer Fall-zu-Fall-Basis für jede einzelne Berechtigung zu nehmen (dh erstellen -Lesen-aktualisieren-Delete). Zum Beispiel, wenn derselbe Benutzer ist Mitglied der Gruppe A und Gruppe B und Gruppe A hat gerade erstellen-Leseberechtigung für Anwendungskomponententypen, während Gruppe B hat gerade Read-Update-Berechtigung für Anwendungskomponententypen wird der Benutzer nur die Erlaubnis zum Lesen Anwendungskomponenteninstanzen.

Darüber hinaus standardmäßig, Anonyme Benutzer(dh Benutzer, die nicht festgelegt worden sind, oder die nicht angemeldet sind) haben Voller Zugangum das Projekt. Dies soll sicherstellen, dass der Zugriff in einer Ausgangskonfiguration vor. Um den Zugriff durch anonyme Benutzer sperren deaktivieren Sie einfach die "Anonyme Benutzer vollständigen Zugriff auf Datei 'in den verwalten Benutzer / Gruppen Optionsdialog unten. Wenn nicht markiert anonyme Benutzer nur in der Lage, um die Standards Teil eines Projekts zu sehen.

Schließlich, wenn die "Use Windows Benutzername Login 'Option aktiviert Benutzername Authentifizierung gegenüber den Windows-Benutzername Logins auf dem Computer jedes Benutzers gegen den Benutzernamen des nach unten eingetragen durchgeführt. Das heißt, wenn der Windows-Benutzername Login für Maschine eines bestimmten Benutzers vorhanden ist, wie einem gültigen Benutzernamen dann kein Kennwort erforderlich ist, und der Benutzer automatisch authentifiziert wird. Hinweis: dies effektiv ermöglicht Verwendung von Windows Active Directory (AD) Authentifizierung.

Notiz

Da die Berechtigungen werden nur definiert, wenn sie benötigen, um (eingeschränkt) von einem Benutzer, alle Benutzer, die nicht Mitglied in einer Gruppe oder eine Gruppe, die keine Berechtigungen für sie festgelegt gegen irgendwelche Gegenstände hat, vollen Zugang zu haben, weggenommen werden Projekt.

Benutzer und Benutzergruppen

Um einen neuen Benutzer zu erstellen

1. Auswählen Datei| Verwalten Benutzer / Gruppen

Notiz

Wenn Sie nicht sehen, die Benutzer verwalten / Groups Menüpunkt, dann müssen Sie nicht den Administrator-Fähigkeit. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

2. In dem Dialog, der erscheint, wählen Sie Benutzer hinzufügenund geben Sie einen Benutzernamen und das Passwort im Dialogfeld Create New Benutzer. Hinweis: Benutzernamen und Passwörter sind case sensitive.

Notiz

Wenn die "Use Windows Benutzername Login 'Option wird überprüft, wie oben, dann kann ein Dummy-Passwort zur Authentifizierung eingegeben werden beschrieben werden entsprechend nur das Fenster der Benutzer-Anmeldung Benutzername durchgeführt werden.

2. Standardmäßig werden Sie sehen, dass die Benutzer können ihre eigenen Passwort zu ändern. Bei Bedarf kann der Administrator ABACUS entfernen das Möglichkeit für Benutzer, um ihre eigenen Passwort gesetzt durch Durch Entfernen des Häkchensdie Kontrollkästchen.

Notiz

Wenn Benutzer ihre eigenen Passwort zu ändern sie eine haben Datei | Kennwort ändern...Menüpunkt, dies zu tun.Beachten Sie außerdem, dass, wenn mehrere Personen den gleichen Benutzernamen, dann einen Benutzer kann das Passwort, so dass keine anderen Personen können danach einloggen ändern. Dementsprechend empfiehlt es Praxis, einen haben Einzelbenutzernamen per tatsächliche Person.

4. Optional können Sie die E-Mail-Adresse, Ort und Telefonnummer für die Benutzer für die Zukunft.

5. Klicken Sie auf OKButton in der Create New Dialog Benutzer.

6. Klicken Sie auf OK Taste.

Notiz

Sobald Sie Ihre erste Nutzer erstellt haben, sollten Sie prüfen, blockiert den Zugriff durch anonyme Benutzer durch Deaktivieren der "Anonyme Benutzer vollständigen Zugriff auf Datei 'in der Benutzer verwalten / Dialoggruppen-Option.Auch, wenn ein Benutzer erstellt wurde (und wenn ein Enterprise-Projekt, die Änderung an den Server übermittelt), das nächste Mal, das Projekt geöffnet wird Benutzer aufgefordert werden Melde dich für den authentifizierten Zugriffnach der unten dargestellten Dialog. Wenn das Melde dich an, automatisch mit diesen AngabenOption wird dann überprüft der Benutzername / Passwort-Kombination für das Projekt erinnert und angewandt jedes Mal beim Öffnen werden. Um die gespeicherten Login wählen Sie Clear Datei | Klar Gespeichert Anmeldennach dem Öffnen und werden Sie aufgefordert, melden Sie sich erneut nächste Mal, wenn Sie das Projekt geöffnet sein.

Anmeldung

Um einen bestehenden Benutzer zu löschen

1. Auswählen Datei| Verwalten Benutzer / Gruppen

2. In dem Dialog, wählen Sie den Benutzernamen in das Panel-Benutzer, den Sie löschen möchten, und wählen Sie dann erscheint das Benutzer löschen Taste.

3. Klicken Sie auf OK Taste.

Um eine neue Gruppe zu erstellen

1. Auswählen Datei| Verwalten Benutzer / Gruppen

2. In dem Dialog, der erscheint, wählen Sie Gruppe hinzufügenund geben Sie einen Gruppennamen in das Gruppen-Panel.

Notiz

Gruppennamen müssen eindeutig sein.

3. Klicken Sie auf OK Taste.

Zu Kopieren Sie eine vorhandene Gruppe

1. Auswählen Datei| Verwalten Benutzer / Gruppen

2. In dem Dialog, der erscheint, wählen Sie Kopie Gruppe Taste.

Notiz

Ein Duplikat-Gruppe erstellt werden, mit dem Präfix "Kopie von".Standardmäßig sind alle Berechtigungen aus der kopierten Gruppe wird für die "Kopie von" Gruppe einschließlich der Benutzerzuordnung dupliziert werden.

3. Benennen Sie die "Kopie von" Gruppe gegebenenfalls mit Edit Groupoder langsam Doppelklick.

Um eine vorhandene Gruppe zu löschen

1. Auswählen Datei| Verwalten Benutzer / Gruppen

2. In dem Dialog, wählen Sie den Namen der Gruppe im Gruppen-Panel, die Sie löschen möchten, und wählen Sie dann erscheint das Gruppe löschen Taste.

Notiz

Jeder Anwender Aufträge an den Konzern werden ebenfalls entfernt.

3. Klicken Sie auf OK Taste.

Um einen Benutzer einer Gruppe zuweisen

1. Auswählen Datei| Verwalten Benutzer / Gruppen

2. In dem Dialog, wählen Sie den Benutzernamen in das Panel-Benutzer, die Sie einer Gruppe zuweisen möchten, und scheint Drag-and-Drop-es auf den Namen Gruppe in der Gruppen-Panel, mit dem Sie es zuordnen möchten.

3. Klicken Sie auf OK Taste.

Notiz

Die Gruppe (n), dass ein Benutzer, um sich durch den Ausbau der gezeigte zugeordnet Benutzernamen in das Panel Benutzerund die Benutzer, die einer Gruppe zugeordnet sind, werden durch die Erweiterung der Gruppennamen in der Gruppen-Panel angezeigt. Zum Beispiel wird in dem Bildschirm der Benutzer "AS1-Aus" auf drei (3) Gruppen, nämlich zugeordnet; "App-Support-Team 1", "Actual" und "Australien".

Um einen Benutzer aus einer Gruppe aufheben

1. Auswählen Datei| Verwalten Benutzer / Gruppen

2. In dem Dialog, erweitern Sie den Namen der Gruppe, die die Benutzerzuordnung, die Sie aufheben, und wählen Sie den Benutzernamen enthält, möchten angezeigt wird.

3. Klicken Sie auf Unassign Benutzer Taste.

4. Klicken Sie auf OK Taste.

So importieren Sie Benutzer und / oder Gruppen (und alle passenden Berechtigungen)

1. Auswählen Datei| Verwalten Benutzer / Gruppen

2. Klicken Sie auf Import Taste.

3. In dem erscheinenden Dialog Durchsuchenum und öffnen Sie das ABACUS Projekt, das die Benutzer enthält, und / oder Gruppen (und Berechtigungen), die Sie in das aktuelle Projekt importieren möchten und klicken Sie Öffnen. Die Benutzer und Gruppen werden importiert und eine Import Ergebnisse Dialog erscheint mit einer Zusammenfassung der Import der Benutzer und / oder Gruppen. Klicken Sie auf OK Taste.

Notiz

Wenn die importierten Benutzer oder Gruppen bereits im aktuellen Projekt existiert dann werden sie mit den vorhandenen Benutzer oder Gruppen zusammengeführt werden.

4. Klicken Sie auf OKSchaltfläche Benutzer / Gruppen-Dialog wieder im Haupt verwalten.

5. Wenn es irgendwelche passenden Typen, Aussichtspunkte, Templates oder Architekturen zwischen dem aktuellen Projekt und die ABACUS Projekt, das Sie aus importierten, komplett mit Berechtigungen, die nicht bereits im aktuellen Projekt vorhanden sind, werden die Berechtigungen importiert und ein zweites Dialog Import Ergebnisse erscheint eine Zusammenfassung der Import. Klicken Sie auf OK Taste.

Notiz

Berechtigungen werden nur für bestehende Typen (und ihre Produkte), Aussichtspunkte, Templates oder Architekturen für die Gruppen, in denen die Berechtigungen nicht bereits für den Konzern bestehen aufgenommen. Entweder, weil der Konzern neu ist oder der Konzern bereits im aktuellen Projekt existiert, aber keine Berechtigungen hatte für diese Gruppe zu diesem Element zugeordnet. Es gibt keine "Verschmelzung" von Berechtigungen für passenden Artikel in denen die Berechtigungen bereits für den Konzern im aktuellen Projekt existiert.

Festlegen von Berechtigungen

Berechtigungen können für die Architekturen, Komponenten und Verbindungstypen, Eigenschaften (über deren Typen) eingestellt werden, Vorlagen, Sichtweisen und Pläne, Kataloge, Matrizen, Diagramme eind 3DAnsichten. Wenn Berechtigungen für eine Komponente oder Verbindungstyp alle Instanzen dieses Typs in allen Architekturen in diesem Projekt setzen "erben" diese Berechtigungen. Ebenso, wenn eine Genehmigung für eine Eigenschaft einer Komponente oder Verbindungstyp, der angegebenen Eigenschaft für die Komponente oder Verbindung Instanzen in allen Architekturen in diesem Projekt setzen "erben" diese Berechtigungen. Dementsprechend werden bestimmte Berechtigungen, um die Ansichten, auf denen diese Elemente vorhanden sind anzuwenden. Wenn die Berechtigungen für ein Diagramm, der Ansicht und / oder den Inhalt der Ansicht selbst gesetzt haben verschiedene Berechtigungen angewendet.

Berechtigungsverwaltung

Um die Genehmigung für eine Komponente (oder Anschluss) eingestellt Typ

1. Erweitern Sie den TypenZweig des Baumes.

2. Erweitern Sie den Die Komponente (oder Anschluss) TypenZweig des Baumes.

3. Erweitern Gruppen wo nötig.

4. Rechtsklick auf dem Die Komponente (oder Anschluss) TypSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

5. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

6. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

Notiz

Berechtigung Erstellen regelt auch, wenn Sie ein Element kopieren. Entsprechend der Lage sein, ein Element zu kopieren erfordert die Berechtigung Erstellen für alle seine Kinder (da, um das Element zu kopieren bedeutet, kopieren alles, was darunter). Entfernen Erlaubnis Update von einem Element beseitigt die Fähigkeit, die Aktivität sich zu ändern, selbst wenn der Benutzer die Designer Add-on und entfernt auch die Erlaubnis Update für alle seine Eigenschaften. Ein übergeordnetes Element muss die Berechtigung aktualisieren, um in der Lage sein müssen Erstellen Sie Kinder Elemente oder Löschen ihrer bestehenden Kinder-Elemente. Berechtigung Löschen für ein Element erfordert auch die Berechtigung Löschen für alle seine Kinder. Berechtigung für Komponenten zu löschen erfordert auch die Erlaubnis aller angeschlossenen Verbindungen aktualisieren.Und schließlich, das Entfernen Berechtigung Löschen aus einem Element beseitigt die Fähigkeit, die Aktivität selbst zu löschen, auch wenn der Benutzer über die Designer Add-on.

7. Klicken Sie auf OK Taste.

Um die Berechtigung für eine Gruppe von Komponenten (oder Anschluss) eingestellt Typen

1. Erweitern Sie den TypenZweig des Baumes.

2. Erweitern Sie den Die Komponente (oder Anschluss) TypenZweig des Baumes.

3. Rechtsklick auf dem Gruppe, dass die Komponente (oder Anschluss) Typen, die Sie, um die Berechtigungen zu definieren und klicken möchten enthält Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

6. Klicken Sie auf OK Taste.

7. In dem Dialog, der erscheint, klicken Sie auf Ja Taste.

Um die Zustimmung des Immobilienobjektes eingestellt

1. Erweitern Sie den TypenZweig des Baumes.

2. Erweitern Sie den Die Komponente (oder Anschluss) TypenZweig des Baumes.

3. Erweitern Gruppen wo nötig.

4. Wählen Sie die Komponente (oder Verbindung) Typ, der die Eigenschaft, die Sie zu den Berechtigungen für wünsche enthält.

5. Im Fenster Eigenschaften Rechtsklick auf dem EigentumSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

6. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

7. Standardmäßig werden Sie sehen, dass die Berechtigungen Lesen und aktualisieren sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

Notiz

Eigenschaften, die die Update-Berechtigung entfernt wurden sind in gezeigt Kursivschriftim Eigenschaftenfensterund ihre Werte können von dieser Rolle aktualisiert. Auch die Fähigkeit, die Details einer Eigenschaft zu ändern (zB den Namen, Einheiten usw.) erfordert sowohl die Update-Berechtigung auf dem Grundstück und die Designer-Add-on.

8. Klicken Sie auf OK Taste.

Um die Genehmigung für eine Vorlage festgelegt

1. Erweitern Sie den VorlagenZweig des Baumes.

2. Navigieren Sie zu dem Vorlagedass Sie interessiert sind.

3. Rechtsklick auf dem VorlageSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass die Leseberechtigung verfügbar ist. Entfernen Sie die Genehmigung Durch Entfernen des Häkchensdas Kontrollkästchen.

6. Klicken Sie auf OK Taste.

Um die Genehmigung für eine Sicht setzen

1. Erweitern Sie den AussichtspunkteZweig des Baumes.

2. Erweitern Gruppen wo nötig.

3. Rechtsklick auf dem StandpunktSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

6. Klicken Sie auf OK Taste.

Um die Genehmigung für eine Architektur festgelegt

1. Erweitern Sie den ArchitekturenZweig des Baumes.

2. Zu erweitern, um die Architekturdass Sie interessiert sind.

3. Rechtsklick auf dem ArchitekturSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass die Leseberechtigung verfügbar ist. Entfernen Sie die Genehmigung Durch Entfernen des Häkchensdas Kontrollkästchen.

6. Klicken Sie auf OK Taste.

Um die Genehmigung für einen Satz Katalog

1. Erweitern Sie den KatalogeGebiet der Architektur sind Sie interessiert.

2. Erweitern Gruppen wo nötig.

3. Rechtsklick auf dem KatalogSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

6. Klicken Sie auf OK Taste.

Um die Genehmigung für einen Satz Matrix

1. Erweitern Sie den MatrizenGebiet der Architektur sind Sie interessiert.

2. Erweitern Gruppen wo nötig.

3. Rechtsklick auf dem MatrixSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

6. Klicken Sie auf OK Taste.

Um die Genehmigung für ein Diagramm eingestellt

1. Erweitern Sie den DiagramsGebiet der Architektur sind Sie interessiert.

2. Erweitern Gruppen wo nötig.

3. Rechtsklick auf dem DiagrammSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

Notiz

Sie können zwar die CRUD-Berechtigungen direkt für ein Diagramm gesetzt ist darauf hinzuweisen, dass die Berechtigungen der Elemente auf dem Diagramm können Sie die Berechtigungen für die Ansicht selbst zu beeinflussen. Zum Beispiel, wenn es auch nur ein Element auf der Ansicht, dass seine lesen oder aktualisieren Erlaubnis entfernt dann das Diagramm wird seine Update-Berechtigung entfernt wurde. Das ist weil; a) die Elemente auf der Ansicht wurden, deren Leseberechtigung entfernt erscheint nicht auf dem Ansicht verlassen "weißen Raum", wo Sie sonst könnten, einige neue Elemente, wenn die Aussicht war aktualisierbar angezeigt werden, und b) die Elemente, auf die Auffassung, dass haben ihre Berechtigung aktualisieren entfernt könnte dann andere Elemente fiel auf sie, um Kinder zu werden, wenn die Aussicht war aktualisierbar. Außerdem erstellen und die Erlaubnis-Update für ein Diagramm erfordert, dass alle Elemente auf der Ansicht, die Leseberechtigung und die Komponenten die UPDATE-Berechtigung (dieses ist, weil, um eine Komponente auf eine andere Komponente zu verschieben, müssen Sie in der Lage, es zu, da es zu aktualisieren werde ein Kind).

6. Klicken Sie auf OK Taste.

Um die Genehmigung für eine 3D-Ansicht eingestellt

1. Erweitern Sie den 3D AnsichtenGebiet der Architektur sind Sie interessiert.

2. Erweitern Gruppen wo nötig.

3. Rechtsklick auf dem 3D-AnsichtSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

6. Klicken Sie auf OK Taste.

Um die Genehmigung für einen Satz Diagramm

1. Erweitern Sie den ChartsGebiet der Architektur sind Sie interessiert.

2. Erweitern Gruppen wo nötig.

3. Rechtsklick auf dem DiagrammSie die Berechtigungen zu definieren und klicken möchten Berechtigungen bearbeiten.

4. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

5. Standardmäßig werden Sie sehen, dass das crud Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

6. Klicken Sie auf OK Taste.

Sehe auch

Wie wird eine Architektur in ABACUS vertreten?


Arbeiten mit Dashboards

Navigation: Administration>

Arbeiten mit Dashboards

Senden Sie Kommentare Zu diesem Thema.

ABACUS-Projekte können eine beliebige Konfiguration von Ansichten (zB Diagramme, Diagramme usw.) als Dashboard gespeichert und diese gespeicherten Dashboards können als die Standardstart 'screen' beim Öffnen eines Projekts und / oder eingestellt zu einem bestimmten zugewiesenen Benutzergruppe und Mitglieder dieser Benutzergruppe, wenn sie sich auf eine ABACUS Projekt vorgestellt.

Notiz

Dashboards in einem ABACUS Projekt der Benutzer-Lizenz muss der Administrator-Fähigkeit zu konfigurieren. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

Anzeigen von Dashboards

Ein Beispiel Application Portfolio Management (APM) Dashboard

Um eine gespeicherte Dashboard einsehen

1. Auswählen Aussicht| Dashboards

2. Wählen Sie eine gespeicherte Dashboard aus der Liste der verfügbaren Dashboards.

Notiz

Einmal ausgewählt ABACUS werden die Ansichten für das Dashboard erforderlich zu bauen und dies kann einige Sekunden dauern. Bitte haben Sie Geduld.

Verwalten von Dashboards

Verwalten von Dashboards

Um ein neues Armaturenbrett erstellen

1. Öffnen Sie die erforderlichen Ansichten und arrangieren und Dock Fenster wie für die Instrumententafel erforderlich.

2. Auswählen Aussicht| Dashboards| Dashboards verwalten ...

Notiz

Wenn Sie den Menüpunkt verwalten Dashboards nicht sehen, dann müssen Sie nicht den Administrator-Fähigkeit. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung wenn Sie benötigen diese Fähigkeit.

3. In dem Dialog, der erscheint, wählen Sie Erstellenund geben Sie die Dashboard-Namen in das Dialogfeld Create New Dashboard.

4. Klicken Sie auf OK Taste.

Um eine bestehende Armaturenbrett löschen

1. Auswählen Aussicht| Dashboards| Dashboards verwalten ...

2. In dem Dialog wählen Sie das Dashboard Sie aus der Liste löschen möchten, und wählen Sie das erscheint Löschen Taste.

Notiz

Löschen eines Dashboard werden auch alle Benutzergruppenzuweisungen zu diesem Dashboard zu löschen.

3. Klicken Sie auf OK Taste.

Um einen vorhandenen Dashboards ersetzen

1. Öffnen Sie die erforderlichen Ansichten und arrangieren und Dock Fenster als für den Ersatz Armaturenbretts erforderlich.

2. Auswählen Aussicht| Dashboards| Dashboards verwalten ...

3. In dem Dialog wählen Sie das Dashboard Sie möchten, erscheint in der Liste zu ersetzen und wählen Sie die Ersetzen Taste.

4. Klicken Sie auf OKTaste, um das Dashboard Ersetzte Dialog anzuerkennen.

Um einen Dashboard-zuweisenals Standard-Startbildschirm

1. Auswählen Aussicht| Dashboards| Dashboards verwalten ...

2. In dem Dialog wählen Sie das Dashboard in der Liste aus, die Sie zuweisen möchten, erscheint als die Standardstart 'screen'und wählen Sie die Zuordnen... Taste.

3. In dem Dialog, der erscheint, wählen Sie Eintrag in der User Groups Spalte.

Notiz

Nur ein Dashboard kann als abzutreten starten 'screen', so re-Zuordnung wird die entfernen Zuweisung aus dem vorherigen Dashboard.Außerdem, wenn der Benutzer als Mitglied einer Benutzergruppe, die eine zugewiesene Dashboard dann die zugewiesene Dashboard wird anstelle des Standard-Projekt-Dashboard geöffnet werden muss.

4. Klicken Sie auf OK Taste.

Um eine Benutzergruppe zu einer Dashboard-zuweisen

1. Auswählen Aussicht| Dashboards| Dashboards verwalten ...

2. In dem Dialog wählen Sie das Dashboard in der Liste erscheint, die Sie einer Benutzergruppe zuweisen möchten, und wählen Sie die Zuordnen... Taste.

3. In dem Dialog, der erscheint, wählen Sie User Group (oder Gruppen)Sie, um das Dashboard als "Start-up" Bildschirm zuweisen möchten.

Notiz

Wenn die gleiche Benutzergruppe ist, um mehrere Dashboards dann zugeordnet die erste Aufgabe in der Liste verwendet.

4. Klicken Sie auf OK Taste.

Um eine Benutzergruppe von einem Armaturenbrett aufheben

1. Auswählen Aussicht| Dashboards| Dashboards verwalten ...

2. In dem Dialog, erweitern Sie den Dashboard-Element aus der Liste erscheint, die Sie eine Benutzergruppe aus aufheben möchten.

3. Wählen Sie die Benutzergruppe, die Sie aufheben möchten, und wählen Sie die Zuweisung aufheben Taste.

4. Klicken Sie auf OK Taste.

Festlegen von Berechtigungen

Berechtigungen können für Armaturenbretter gesetzt werden, damit die für das Armaturenbrett, um sichtbar zu sein, Updatefähig und / oder löschbarIn den angegebenen Benutzergruppen.

Berechtigungsverwaltung

Um die Genehmigung für eine Dashboard-Set

1. Auswählen Aussicht| Dashboards| Dashboards verwalten ...

2. In dem Dialog wählen Sie das Dashboard in der Liste für die Sie Berechtigungen festlegen möchten, und wählen Sie das erscheint Berechtigungen ... Taste.

3. In dem Dialog, klicken Sie auf die erscheint Hinzufügen...Taste und wählen Sie die GruppeSie entweder durch einen Doppelklick oder auswählen und auf das zu legen OK Taste.

4. Standardmäßig werden Sie sehen, dass der Read, Update und Delete-Berechtigungen sind alle vorhanden. Entfernen Sie die Berechtigungen Durch Entfernen des Häkchensdie entsprechenden Kontrollkästchen.

5. Klicken Sie auf OK Taste.

Sehe auch

Individuelle Anpassung des ABACUS-Schnittstelle | Arbeiten mit Berechtigungen


Registrieren von ABACUS

Navigation: Nachschlagen>

Registrieren von ABACUS

Senden Sie Kommentare Zu diesem Thema.

Beim ersten Start von ABACUS (oder nach einer vorübergehenden Lizenz abgelaufen ist), müssen Sie die Anwendung gegen Avolution der Lizenz-Server mit einem eindeutigen Lizenzschlüssel von Ihrem lokalen ABACUS Administrator oder direkt von Avolution vorgesehen registrieren. Wenn Sie nicht über einen Lizenzschlüssel haben, bitte kontaktieren Sie Ihren lokalen ABACUS Administrator oder Avolution Unterstützung .

Um mit einem Lizenzschlüssel registrieren

1. Nach der Installation ABACUS startenentweder durch einen Doppelklick auf die Verknüpfung auf dem Desktop oder über das Windows-Startmenü.

2. Im Registrierungsdialog, der erscheint, geben Sie die 26 stelligen Lizenzschlüsselvon Ihrem lokalen ABACUS Administrator zur Verfügung gestellt oder Avolution Unterstützung , Oder klicken Sie auf Durchsuchen ...und wählen Sie die signierte Datei von .dlsc zurück Avolution Unterstützung gemäß dem Hinweis in Schritt 4 unten. Bei Verwendung eines korrekt signiert .dlsc Datei ABACUS sollte nach Schritt 5 unten starten.

Spitze

Sie können den Lizenzschlüssel in das Dialogfeld, indem Sie sie in die Zwischenablage und wählen Sie den Hintergrund des Dialogs und Drücken von Strg + V einfügen

Dialog Registrierung

3. Klicken OKund wenn der Lizenzschlüssel ist ein ABACUS gültigen LizenzschlüsselABACUS wird nun versuchen, Avolution der Lizenz-Server zu kontaktieren, um den Lizenzschlüssel zu authentifizieren.

Notiz

Wenn Sie erhalten eine Installationscode ist ungültigRegistrierungsfehler ist es sehr wahrscheinlich, dass Sie den Code korrekt eingegeben haben. Versuchen Sie, das Kopieren und Einfügen den Code gemäß der oben genannten Tipp.

Kontaktieren des Avolution License Server

4. Klicken OKund nach einer kurzen Zeit ABACUS sollte erfolgreich registrieren.

Erfolgreiche Anmeldung

Notiz

Wenn Sie eine Nicht kontaktieren kann LizenzserverRegistrierungsfehler ist es sehr wahrscheinlich, dass eine Firewall (oder eine andere Sicherheitsmaßnahmen) in Ihrem Netzwerk der Zugriff auf Avolution der Lizenz-Server zu verhindern. Klicken OKSpeichern Sie die Datei .dlsc auf Ihrem lokalen Rechner und dann entweder Die e-mail .dlsc Datei an Avolution Unterstützung und warten auf weitere Anweisungenoder versuchen, melden Sie die Lizenzdatei Sie sich mit dem folgenden URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Kann keine Verbindung zum Lizenzserver

Öffnen Sie den Lizenz Unterzeichnung Homepage

Manuelle Lizenz Unterzeichnung Homepage

Alternativ, wenn Sie die Dieser Installationscode ist auf mehr Systemen verwendet worden, als durch die Lizenz gestattetRegistrierungsfehler es wahrscheinlich, dass Ihre lokale Maschine wurde wieder aufgebaut, seit Sie zuletzt registrierten ABACUS oder Sie versuchen, mit Lizenzschlüssel eines anderen Benutzers zu registrieren sind. Bitte kontaktieren Sie Ihren Administrator oder ABACUS Avolution Unterstützung .

Installations-Code bereits verwendet wurde

5. Klicken OKund wenn erfolgreich registriert sollten ABACUS mit der offenen Begrüßungsbildschirm .

Sehe auch

Avolution Unterstützung | Was bedeutet ABACUS tun?


ABACUS Installations Vorraussetzungen

Navigation: Nachschlagen>

ABACUS Installations Vorraussetzungen

Senden Sie Kommentare Zu diesem Thema.

Informationen zu Visio Import und Excel-Import / Export

ABACUS setzt voraus, dass Microsoft Office, um Excel-Import / Export und Visio Import Operationen installiert werden. Bitte überprüfen Sie, ob Microsoft Office 2003 oder neuerrichtig installiert ist. Falls Sie weitere Probleme auftreten, wenden Sie sich Avolution Unterstützung .

Um Visio Import und Excel-Import / Export-Operationen durchführen, verwendet ABACUS das Microsoft Office Primary Interop Assemblies (PIA). ABACUS derzeit kommt mit den notwendigen Excel Import / Export und Visio Import durchführen Baugruppen verpackt.

Informationen zu SQL Server-Import

ABACUS setzt voraus, dass Microsoft SQL Server 20052008, 2008 R2, 2012 oder 2014ist erforderlich, um ein neues Projekt von SQL Server starten installiert. Bitte überprüfen Sie, ob Microsoft SQL Server 20052008, 2008 R2, 2012 oder 2014richtig installiert ist. Falls Sie weitere Probleme auftreten, wenden Sie sich Avolution Unterstützung .

Fehler beim Öffnen 3D-Visualisierungen

Wenn die ABACUS 3D-Viewer nicht für Sie arbeiten, können Sie fehlen die SlimDX DirectX Runtime (als Teil der Voll ABACUS EXE installiert ist). Dies kann heruntergeladen werden Hier . Wenn Sie ein 64-Bit-Version von Windows, können Sie auch brauchen, um zu installieren Dies .

Fehler Bearbeitung ABAKUS Benutzerdefinierte Berichte

Bearbeiten von ABACUS "Benutzerdefinierte Berichte erfordert Report Builder 3.0 installiert werden. ABACUS und der Report Builder basieren auf Microsoft .NET Framework 4.0 gebaut, und während sie sowohl von Microsoft .NET Framework 3.5 nicht benötigen, ist Microsoft nicht korrekt konfiguriert wird die Report Builder MSI nur fort, wenn Microsoft .NET Framework 3.5 installiert ist.

Dementsprechend hat Avolution eine bearbeitete Version des Report Builder-Installation MSI-Datei, die Microsoft .NET Framework 3.5 nicht erforderlich ist, kann diese heruntergeladen werden Hier .

Die ursprüngliche Microsoft Report Builder MSI heruntergeladen werden kann Hier . Wenn Sie nicht bereits über Microsoft .NET Framework 3.5, die es benötigen, können Sie es downloaden Hier . Hinweis: Für mehrere Installationen, die Offline-Installation des Microsoft .NET Framework 3.5 aus Hier besser geeignet sein.


Befehlszeilenoptionen

Navigation: Nachschlagen>

Befehlszeilenoptionen

Senden Sie Kommentare Zu diesem Thema.

Sie können verschiedene ABACUS Operationen direkt von der Befehlszeile ausführen mit die häufigste Operation auf eine bestimmte Projektdatei zu öffnen und es in HTML.

Genauer gesagt, wird wie folgt vorgeKommandoZeilenNutzung von ABACUS;

ABACUS.exe Project [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "USER" / pass "PASS"]

Argument | Beschreibung
Project | Die Project kann entweder eine ABACUS-Projektdatei (.abacus), Bibliotheksdatei (.abacuslib), XML-Datei (.xml) oder MS Access DB (.mdb) und die angegebene Datei entweder geöffnet werden (wenn .abacus oder .abacuslib ) oder ein neues Projekt angelegt (wenn .xml oder MDB-Datei).
OptionalFile | Die OptionalFile kann entweder eine ABACUS-Skript (.abacusscript, VB oder CS), Makro (.abacusmac) bzw. Library-Datei (.abacuslib) und die angegebene Datei entweder nach dem Öffnen der Project (wenn .abacusscript, VB ausgeführt werden können oder CS oder .abacusmac) oder einfach geöffnet (wenn .abacuslib).
/ exitOnCompletion | Wird verlassen ABACUS und wenn erforderlich, speichern und begehen keine Änderungen an den offenen .abacus Projekte auf die Beendigung von Skript oder Makro. Hinweis: Diese Flagge ist Case Sensitive so sicher sein, um einen Groß 'O' und 'C' im Text zu verwenden, wie dargestellt.
/ dontShowDialogs | Wird ABACUS Enterprise Edition (EE) Update-Benachrichtigung Dialoge aus, die beim Öffnen eines Projekts zu vermeiden. Hinweis: Diese Flagge ist Case Sensitive so sicher sein, um einen Groß 'S' und 'D' im Text zu verwenden, wie dargestellt.
/ user "USER" / pass "PASS" | Der Benutzername und das Passwort USER PASS verwendet werden, um sich in dem Projekt mit und überschreibt alle gespeicherten Benutzerdaten. Hinweis: Doppelte Anführungszeichen müssen rund um die USER und PASS Flags platziert werden und zwei doppelte Anführungszeichen verwendet werden, um doppelte Anführungszeichen in entweder der Benutzer oder die PASS-Flags zu entkommen werden.

Z.B.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / user "Public" / pass "123456"

wenn aus dem Verzeichnis, in dem ausgeführt das ABACUS.exe binär ist gelegen werden öffnen Das Beispielprojekt und melden Sie sich als Benutzer mit Passwort öffentlichen 123456 (wie beschrieben Hier ), Veröffentliche es in HTML und schließen Sie das Projekt ohne irgendwelche Dialoge auf dem Weg (zB »Update Successful" bzw. "Keine Updates verfügbar" für Enterprise-Projekte).

Z.B.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalog Excel importieren.vb"/ exitOnCompletion / dontShowDialogs

wenn aus dem Verzeichnis, in dem ausgeführt das ABACUS.exe binär ist gelegen werden öffnen Das Beispielprojekt und die "Servers (2014 Actual) .xlsx" MS Excel-Datei in das "Server" Katalog des "2014 Actual 'Architektur des Projekts zu importieren, ohne irgendwelche Dialoge auf dem Weg, und dann schließen Sie das Projekt nach Abschluss. Wenn der Vorgang Änderungen an dem Projekt dann beim Schließen der Änderungen werden lokal gespeichert und wenn ein Enterprise-Projekt auf den Enterprise Server begangen.

Notiz

Seien Sie sicher, die korrekte doppelte Anführungszeichen verwenden, da es mehrere in der Standard-ASCII-Zeichensatz und die Windows-Eingabeaufforderung wird nur korrekt mit der richtigen Arbeit. Die korrekte Anführungszeichen Zeichencode ist Dezimal 34 (hexadezimal 22).Dies ist, was in dem Beispiel verwendeten oben, so zögern Sie copy / paste es von dort.


Titelblatt

ABAKUS

Haftungsausschluss

Avolution Pty Ltd übernimmt keine Gewährleistung oder Haftung in Bezug auf dieses Handbuch und auf den maximalen gesetzlich zulässigen Umfang begrenzt ausdrücklich jegliche Haftung für Verstöße jeglicher Gewährleistung, die auf den Ersatz dieses Handbuchs mit einem anderen implizit enthaltenen. Des Weiteren behält sich Avolution Pty Ltd das Recht vor, diese Veröffentlichung jederzeit ohne die Verpflichtung entstehen, jede Person der Revision benachrichtigt zu überarbeiten.

Copyright

Copyright 2001-2015Avolution Pty Ltd. Alle Rechte vorbehalten.

Markenzeichen

Avolution Pty Ltd hat alle Anstrengungen unternommen, um Information über die Firma Namen, Produkte und Dienstleistungen in diesem Handbuch erwähnt liefern gemacht. Warenzeichen unten wurden aus verschiedenen Quellen stammen.

Microsoft Windows, Access, Visio, Excel, SQL Server und Internet Explorersind Marken der Microsoft Corporation.

Allgemeiner Hinweis:

Einige Produktnamen in diesem Handbuch verwendet werden nur zu Identifikationszwecken verwendet und sind möglicherweise Marken ihrer jeweiligen Unternehmen sein.

Dezember 2015Edition für Avolution ABACUS Version 4.5.

Handbuch Revision 1.0

Generiert, gedruckt und in Australien gebunden.