Hozzátéve, előre beállított tulajdonságok egy alkatrész, csatlakozás vagy típus

Navigáció: Népszerű az architektúrának> Ingatlan>

Hozzátéve, előre beállított tulajdonságok egy alkatrész, csatlakozás vagy típus

Küldje el észrevételeit ebben a témában.

Normál könyvtárak tulajdonságok adhatók meg és rendelt mást az építészet. Ezek a könyvtárak ismert Szabványok. Használva Szabványok, Már csak be kell gyűjteni egyedi rendszerek tulajdonságait - a standard tulajdonságok már ott.

Például a standard teljesítmény-jellemzőinek Microsoft Windows 2000 lehet megtakarítani, mint a Standardés rendelt olyan alkatrészek (vagy a csatlakozások, nem mintha ez lenne jellemző) a Microsoft Windows 2000 operációs rendszert.

Hozzáadni standardegy alkatrész, csatlakozás vagy típus

1. Jobb klikkaz alkatrészen / kapcsolat / típus.

2. Válassza ki Rendeljen Standard.

3. Válassza kiegy Standarda listából.

Lásd még

Benépesítő az architektúrának - Áttekintés | A tulajdonságok módosításával egy komponens, kapcsolat vagy típus | Összesített tulajdonságok

© 2001-2015 Avolution Pty Ltd. Minden jog fenntartva.


Összesített tulajdonságok

Navigáció: Népszerű az architektúrának> Ingatlan>

Összesített tulajdonságok

Küldje el észrevételeit ebben a témában.

A művelet "Komplett Tulajdonságok"Lehetővé teszi hozzá értékeit hasonló tulajdonságokkal együtt, és levelet (vagy felvételét) az eredményt a kiválasztott szülő elem tulajdonságait. Azt is lehetővé teszi, hogy meghatározza a hatálya összesítés és arról, hogy frissítse a tulajdonságok az összes al-elemek, vagy sem.

Az aggregált tulajdonságok

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Kattintson a jobb gombbal egy elemre (az építészet, alkatrész vagy kapcsolat), amely alatt ezt az összevonás és válassza Összesített Ingatlan.

3. Válasszon az aggregált Options (Traverse Minden alszintjük vagy Csak Direct Sub-Level). Ha úgy döntött, Traverse Minden alszintjük, Akkor is választhat a lehetőséget, hogy a Frissítés alszintjük.

o Traverse Minden alszintjükazt jelenti, hogy a hatálya összesítés tartalmazza az elemeket minden szinten az Ön által kiválasztott elemet.

o Frissítés alszintjükcsak akkor valósítható meg, ha azt is vállasztotta Traverse Minden alszintjük. Ez azt jelenti, hogy amíg összesítik tulajdonságok alulról felfelé, összesített eredménye minden szinten is frissülnek mindegyikébe a megfelelő elemeket.

o Csak Direct Sub-Levelazt jelenti, hogy csak a tulajdonságait az elemek közvetlenül alatta a választott elem összeadódik.

o Válassza ki Tartalmazzák StandardTulajdonságokHa szeretné, hogy a tulajdonságok meghatározott szabványok felveendő. Ellenkező esetben, csak a tulajdonságok egyedi minden komponens például fogják használni.

4. Válassza ki, melyik tulajdonságát összesíteni. Ők vannak csoportosítva a Típusok.

5. Kattintson a Következő gomb.

6. Válassza ki a lehetőséget, hogy a Felülírása értékek vagy Add értékeka választott elem.

o Felülírása értékekfogja írni az eredményeket közvetlenül a tulajdonságait a kiválasztott elem.

o Add értékeknöveli az eredményeket a meglévő ingatlanok a kiválasztott elem.

Lásd még

Hozzátéve, előre beállított tulajdonságok egy alkatrész, csatlakozás vagy típus | A tulajdonságok módosításával egy komponens, kapcsolat vagy típus | Értékeli a építészet


Építészet diff és szinkronizálás

Navigáció: elemezve az architektúrának>

Építészet diff és szinkronizálás

Küldje el észrevételeit ebben a témában.

Ha 2 vagy több architektúrák, akár fejleményeket és a kiindulási architektúrák, akkor vizuálisan "diff" a két architektúra segítségével katalógus vagy diagram összehasonlítása, illetve a Építészet diff jellemző. Ez különösen hasznos felfedezésére / újra felfedezni a pontos változtatások egyik építészet egy másik, ahogy fejlődnek architektúrák és útiterv kidolgozása az ABACUS.

Hogy mutatják a "diff" másik építészet keresztül rajz

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Győződjön meg róla, van legalább 2 architektúrák a projektben.

3. Nyissa meg a rajzot szeretné összehasonlítani más architektúra.

4. Kattintson a "Hasonlítsuk össze ezt Diagram tartalmát más architektúra" gombot a Diagram eszköztár.

5. Válassza ki a többi architektúra a legördülő listából összehasonlítani.

6. Szűrheti milyen eltérések láthatók, kattintson a "különbségek" gombot a Diagram eszköztár és üresen hagyásával opciók, pl Megváltozott / Added / Ismeretlen és Határozatlan / Sync Ajánlott/ Tartsa Ajánlott.

hangjegy

Valamint csatlakoztatása az ábrán lesznek kiemelve piros, zöld vagy lila ahol különbség van a látható tartalom az aktuális rajz és a tartalom a másik építészet. Piros használják ahol ajánlott Sync a különbségeket (lásd alább), Zöld használják, ahol nem ajánlott szinkronizálni a különbség, hogy az tartsa őket (lásd alább) és Lila használják, ahol ABACUS nem tud ajánlást arról szinkronizál a különbségeket (lásd alább). Csak a látható tartalom a diagramot összehasonlítva, így ha egy kommentárt mutat adattár ingatlanok értékét, és ez az érték megváltozik az adott alkatrész vagy kapcsolat lesz látható halványvörös, halványzöld vagy Halvány lila és a "*" szimbólummal jelenik meg a bal felső komponensek, azonban ha valamilyen más mögöttes adattár ingatlan értéke megváltozott, hogy nem jelenik meg egy jegyzet, akkor nem utal kap. Tartalom fordul elő, hogy az aktuális rajz, de nincs találat az összehasonlítás architektúra lesz látható erős piros, erős zöld vagy erős lilaés a "+" jel látható a bal felső komponensek. Megfelelő végzi alkatrész és neve olyan, hogy ha a típus megnevezése vagy az alkatrész vagy kapcsolat változott a többi architektúra nem egyezik meg fogja találni. Mivel nincs mód a megbízható meghatározására, hogy a kiegészítő tartalom a többi architektúra volna látható az aktuális rajz (pl egy másik felületen között 2 alkatrészek amint az az alábbi diagram az összehasonlítás architektúra a jobb oldalon), ezek a különbségek nem Látható diagramok (ők láthatók a katalógusok, mint egy alább). Lebeg minden megváltozott tétel megmutatja a különbséget a tooltipben. Lebeg a "*" szimbólum a bal felső a diagram összefoglalja a változásokat (vagy nem változott) a rajz tartalmát, és a tartalmát más architektúrára.

Szín Legend

· Zöld azt jelzi, elem, hogy ez nem ajánlott szinkronizálni a különbség, hogy az, hogy tartsa őket.

· Piros azt jelzi, tárgyakat, javasoljuk, hogy szinkronizálni a különbségeket.

· Lila azt jelzi, tételeket, ahol ABACUS nem tud ajánlást arról szinkronizál a különbségeket.

Hogy szinkronizálni ("szinkron") tartalmakat egy építészeti másik keresztül rajz

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Győződjön meg róla, van legalább 2 architektúrák a projektben.

3. Nyissa meg a rajzot szeretné összehasonlítani egy másik építészet.

4. Kattintson a "Hasonlítsuk össze ezt katalógus tartalmának más architektúra" gombot a Diagram eszköztár.

5. Válassza ki a többi architektúra a legördülő listából összehasonlítani.

hangjegy

Lásd fent az utat ABACUS mutatja a 'diff' között 2 architektúrák a katalógusban. Különösen, hogy hogyan Piros alkalmazunk, ahol vanJavasoljuk, hogy szinkronizálása a különbségeket, Zöld használunk, ha az nemJavasoljuk, hogy szinkronizálja a különbségeket, és Lila használják, ahol ABACUS nem tud ajánlást arról szinkronizál a különbségeket.

6. Kattintson jobb gombbal a rajz elem (vagy elemek használatával Shift vagy a rajz vászonra szinkronizálni mind) mutatja a "diff", és válassza ki a szinkronizálás menüpontot.

hangjegy

Bármilyen szinkronizálás változások csak akkor alkalmazzuk, hogy az architektúra, hogy a jelenleg a fókuszban katalógusban tartozik. A módosítások alkalmazásához a többi architektúra kell használni egy katalógust a másik építészet. Továbbá, a felhasználók csak akkor lesz képes alkalmazni a szinkronizálás változásokat, ha azok Van erre engedélyt .

hangjegy

Attól függően, hogy hol a jobb gombbal a menüpont jelenik útmutatást, hogy pontosan mit fog szinkronizálni. Ilyen például. Jobb gombbal a egykomponensű az ábrán csak szinkronizálni, hogy komponense. Mivel jobb egérgombbal a rajz vászon és kiválasztja szinkronizálja szinkronizálja az összes aktuálisan látható különbségek.

Hogy mutatják a "diff" másik építészet keresztül katalógusa

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Győződjön meg róla, van legalább 2 architektúrák a projektben.

3. Nyissa meg a katalógust szeretné összehasonlítani más architektúra.

4. Kattintson a "Hasonlítsuk össze ezt katalógus tartalmának más architektúra" gombot a katalógus eszköztár.

5. Válassza ki a többi architektúra a legördülő listából összehasonlítani.

6. Szűrheti milyen eltérések láthatók, kattintson a "különbségek" gombot a Diagram eszköztár és kijelölt volta törlésével opciók, pl Megváltozott / Added / Ismeretlen és Határozatlan / Sync Ajánlott/ Tartsa Ajánlott.

hangjegy

A sejteket a katalógusban lesznek kiemelve piros, zöld vagy lila ahol vannak különbségek a tartalmát az aktuális katalógusban, és a megfelelő tartalmat a másik építészet. Piros használják ahol ajánlott Sync a különbségeket (lásd alább), Zöld használják, ahol nem ajánlott szinkronizálni a különbség, hogy az tartsa őket (lásd alább) és Lila használják, ahol ABACUS nem tud ajánlást arról szinkronizál a különbségeket (lásd alább). Csak a látható sorok és oszlopok a katalógusban képest, így ha van különbség egy sorban túl a jelenleg látható sorok vagy egy értéket egy oszlopot, amely nem jelenik meg egy különbség, akkor nincs különbség lesz feltüntetve. Ha az érték az egyéni cellába eltér a megfelelő cellába az összehasonlítás építészet a cellahatár ki kell emelni. Az oszlop fejlécére, és sorban választó is árnyalt Halvány lilaés látható egy "*" szimbólum. Ezek a "*" szimbólum lehet kattintott ugrani a következő különbség a sor vagy oszlop volt. Sorok fordul elő, hogy az aktuális katalógusban, de nincs találat az összehasonlítás architektúra lesz látható a "+" jel a sorban választó a bal oldalon, és a határ a teljes sort ki kell emelni. Sorok hogy bekövetkezett volna az összehasonlítás építészet változata a katalógusban (azaz azonos szűrők stb), de nincs találat a jelenlegi architektúra lesz látható a "-" jelet a sorban választó a bal oldalon, a határ az egész sort világítani fog, és a teljes sorok sejtek tartalma jelenik meg Halvány lilaés áthúzza, például 08:00-06:00. Megfelelő végzi alkatrész és neve olyan, hogy ha a típus megnevezése vagy az alkatrész vagy kapcsolat változott a többi architektúra nem egyezik meg fogja találni. Lebeg minden megváltozott tétel megmutatja a különbséget a tooltipben. Lebeg a "*" szimbólum a bal felső a diagram összefoglalja a változásokat (vagy nem változott) a rajz tartalmát, és a tartalmát más architektúrára.

Szín Legend

· Zöld azt jelzi, elem, hogy ez nem ajánlott szinkronizálni a különbség, hogy az, hogy tartsa őket.

· Piros azt jelzi, tárgyakat, javasoljuk, hogy szinkronizálni a különbségeket.

· Lila azt jelzi, tételeket, ahol ABACUS nem tud ajánlást arról szinkronizál a különbségeket.

Hogy szinkronizálni ("szinkron") tartalmakat egy építészeti másik keresztül katalógusa

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Győződjön meg róla, van legalább 2 architektúrák a projektben.

3. Nyissa meg a katalógust szeretné összehasonlítani egy másik építészet.

4. Kattintson a "Hasonlítsuk össze ezt katalógus tartalmának más architektúra" gombot a katalógus eszköztár.

5. Válassza ki a többi architektúra a legördülő listából összehasonlítani.

hangjegy

Lásd fent az utat ABACUS mutatja a 'diff' között 2 architektúrák a katalógusban. Különösen, hogy hogyan Piros alkalmazunk, ahol vanJavasoljuk, hogy szinkronizálása a különbségeket, Zöld használunk, ha az nemJavasoljuk, hogy szinkronizálja a különbségeket, és Lila használják, ahol ABACUS nem tud ajánlást arról szinkronizál a különbségeket.

6. Kattintson jobb gombbal a cella, oszlop vagy sor címében (vagy több elemet használ a Shift vagy Ctrl + A mindent) mutatja a "diff", és válassza ki a szinkronizálás menüpontot.

hangjegy

Bármilyen szinkronizálás változások csak akkor alkalmazzuk, hogy az architektúra, hogy a jelenleg a fókuszban katalógusban tartozik. A módosítások alkalmazásához a többi architektúra kell használni egy katalógust a másik építészet. Továbbá, a felhasználók csak akkor lesz képes alkalmazni a szinkronizálás változásokat, ha azok Van erre engedélyt .

hangjegy

Attól függően, hogy hol a jobb egérgombbal (azaz egy sejt, oszlop vagy sor címében) menüpont jelenik útmutatást, hogy pontosan mit fog szinkronizálni. Ilyen például. Jobb egérgombbal kattintva egy ingatlan vagy az ahhoz csatlakozó alkatrész sejt a katalógusban csak szinkronizálni, hogy a tulajdon vagy csatolt elem. Mivel jobb gombbal a fejlécben (vagy fejezetek használatával Shift) szinkronizálja az egész sort (vagy sorok). Ehhez kattintson jobb gombbal az oszlop fejlécére szinkronizálja az összes különbséget az oszlopban.

Megtekintéséhez 'diff'2 egész architektúrák

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Győződjön meg róla, van legalább 2 architektúrák a projektben.

3. Válassza ki Eszközök| Építészet diff ....

4. A megjelenő párbeszédablakban válassza ki az első / A és a második / A architektúrák összehasonlítani.

5. Kattints a oké gomb.

Építészet diff

Szín Legend

· Zöldjelzi, hogy a csomópont adunk a második / TO építészet.

· Pirosazt jelzi, hogy a csomópont törlésre került, a második / építészet.

· Kékazt jelzi, hogy a csomópont különböző jellemzőkkel bír (pl tulajdonságait vagy szabványok) a második / építészet.

· Sárgaazt jelzi, hogy a csomópont különbség a gyerekek a második / A architektúra, így a csomópont bővíteni kell.

hangjegy

Akkor kattintson jobb gombbal és a "Show Explorer" minden csomópont a részletek és több információt kapunk a különbség a különbségek Összegzés panelen, ha egy csomópont van kiválasztva.

Lásd még

Elemezve az architektúrának | Megtekintése válaszidő chart | Profil szórásgörbe mátrix a kialakult architektúrák | Fejlődik az architektúrának


A tulajdonságok módosításával egy komponens, kapcsolat vagy típus

Navigáció: Népszerű az architektúrának> Ingatlan>

A tulajdonságok módosításával egy komponens, kapcsolat vagy típus

Küldje el észrevételeit ebben a témában.

Tulajdonságok jellemzően a rendszer követelményeinek, amit meg, vagy az eredmények ABACUS "értékelések. (Ha ABACUS végzi értékelések, azt írja tulajdonságok vissza a fájlt.) Más szóval, tulajdonságok azok a dolgok tudsz a rendszer, vagy a dolog, amit használ ABACUS hogy megtudja.

Változtatni az ingatlan értékének egy komponens, kapcsolat vagy típus

1. Kattintsonaz alkatrészen / kapcsolat / típusa (annak tulajdonságait jeleníti meg a Properties ablakban a jobb oldalon).

2. Kattintsonjelölje ki a kívánt tulajdonság változtatni.

3. típusegy új értéket.

Fontos

Emellett számos olyan tulajdonsága van definiálva Szabványok . Megváltoztatásával egy ingatlant belül Standard, Akkor nem csak megváltoztatni az aktuális objektum, akkor is változtatni a mester Standard (alatt SzabványokA fa tetején). Mielőtt ezt megtenné, ellenőrizze, milyen egyéb alkatrészek, csatlakozások vagy típusokat használ Standard, Mert a változtatás nem vonatkoznak rájuk- Akkor a hivatkozások ablakban erre.

Tipp

Meg lehet változtatni a kapcsolat tulajdonságait belül az összetevők ágon szintén (és fordítva). Így például, ha keres, hogy milyen kapcsolat van csatolva egy összetevő, és rájössz, hogy meg kell változtatni az egyik, akkor.

Új tulajdonságokat, hogy az alkatrész vagy kapcsolat (via típus)

hangjegy

Tulajdonságok csak ki kell típusok és az alkatrészek vagy a csatlakozások a típus "örökli" ezeket a tulajdonságokat.

1. KattintsonA típus (a tulajdonságait jeleníti meg a Properties ablakban a jobb oldalon).

2. Kattintsonaz Add gombra a tetején a Property ablakot, hogy adjunk egy felső sorában az ingatlan rács az új ingatlan.

3. Hozzáadása típusAz új ingatlan.

4. Hozzáadása NévAz új ingatlan.

5. Hozzáadása Alapértelmezett értékAz új ingatlan.

6. Hozzáadása EgységAz új ingatlan.

7. Állítsa be a AdattípusAz új ingatlan.

hangjegy

A adattípusmezőt lehet használni, hogy korlátozza az érvényes értékeket, amelyek egy ingatlan lehet. Azaz; Szöveg, Egész, tízes dátum / idő, logikai vagy List.

o A Szövegtulajdonság az egyik, hogy korlátlan számú karakter, és lényegében nincs korlátozás értékét.Ha az ingatlan értéke egy megfelelően kialakított hivatkozást (azaz URL kell kezdeni az egyik 5húrok; http: //, https: //, ftp: //,fájl:vagy \\ és bármelyterek kell beírni a "% 20"), Akkor a link kattintható (via ctrl + klikk).

o Egy Egész számtulajdonság kell egy egész szám pozitív vagy negatívés tartalmazhatnak időszakban, tér, aposztróf vagy vesszővel digit egyesülés függően a Projekt Régió beállítások ból ből Fájl | Project Options.A régió beállítások és a.Nettó Long.TryParse módszer van meghatározásához használt érvényes Egész számértékek.

o A Decimálistulajdonság tartalmazhat időszak, vagy vessző a tizedes jel, és tartalmazhatnak időszakban, tér, aposztróf vagy vesszővel digit egyesülés függően a Projekt Régió beállítások ból ből Fájl | Project Options.A régió beállítások és a.Nettó Decimal.TryParse módszer van meghatározásához használt érvényes Decimális értékek.

o A Dátum időtulajdonság lehetővé teszi akár egy dátum részben vagy a Time részben vagy mindkettő. A régióbeállításokés a .Net DateTime.TryParse módszer elsősorban annak megállapítására érvényes dátum és / vagy idő értékeket. Ugyanakkor a dátum része adott esetben előfeltétele legalább az Nap és Hónap (az év lesz feltételezzük, hogy a folyó évben), vagy hónap és év részek érvényes legyen. Azaz. Június, Q3 2010, vagy akár csak 2010 érvénytelenek. Bár eltérőek a különböző területi beállítások, jellemzően a nap, hónap és év részek szóközzel elválasztva, vessző, kötőjel ('-') vagy perjel ('/'). A Nap része jellemzően egy egész szám 1-től 31. A Hónap része jellemzően egész szám 1-12, érvényes 3 betűs rövidítés a hónapban (pl Jan, Feb, Mar), vagy a hónap teljes neve (pl január, február , Március). Az Év része tipikusan egy 4 jegyű pozitív szám, de az 1, 2 és 3 számjegyű év elfogadta a beállítások szerint a Vezérlőpult> Területi és nyelvi Options-> Regionális Options-> testreszabása (gomb) -> Datum> Naptár. Ezek általában a következőképpen kell értelmezni; 0-29 értelmezi 2000-2029, 30-99, mint 1930-1999 és 100-999 a 100-999. Érvénytelen kilenc óra, mint 31 június 2010 és 31/9/2010 lesz kimutatható. Az idő egy részét adott esetben szükség van egy óra és perc részből és esetleg Seconds része. Az órákat, perceket és opcionális Seconds részek rendszerint elválasztjuk a kettőspont (":"), és a másodperc része lehet megadni egy tizedes pont ('.'). További információk a használható formátumok kérjük, olvassa el a Megjegyzések részben a .Net DateTime.TryParse módszer .

Tipp

Javasoljuk, hogy legalább a 3 betű hónap nevét formában (azaz "július" vagy "Július") az időpont értékek helyett numerikus formázás (azaz "7" vagy "07"), mint ezek az értékek érvényesítésére az egész legtöbb régióban függően a projekt Régió beállítások ból ből Fájl | Project Options. Azaz. ajánlatos használni "15 július 2010" helyett "15/7/2010" vagy "2010/07/15". Ezzel a példával, "15/7/2010" megbukik érvényesítését az "English (United States)" és a "2010/07/15" sértené a "English (United Kingdom)", ugyanakkor "15 július 2010" haladna a mind a kettő.

o A Logikaitulajdonság lehet igaz vagy hamis.Ez a kis- és nagybetűket, így igaz vagy hamis is használható azonban igen, nem, 1, 0 stb mind sikertelen vagyon korlátok.

o A Listatulajdonság lehetővé teszi a gyűjtemény előre meghatározott értékek, mint a Low | Közepes | Magas vagy megtartása | Frissítés | Újratervezés | Nyugdíjba, és értéktartományáról származik az Egység mezőben az ingatlan akár vessző vagy a cső "|" tagolt. A tulajdonság lehet tekinteni, hogy sorrendi (szemben a névleges, intervallum vagy arány), mert ha használt térképeken és a színes elemek diagrams és 3DS az értékek kezelni, egy növekvő (vagy csökkenő) sorrendben. Ez az értékeket fel kell rajzolni növekvő (vagy csökkenő) sorrendben a chart tengelyek vagy színe.

8. Az adatok típusa lehet állítani, hogy legyen Tiltva, Figyelmeztetett vagy ÉrvényesíteniEhhez kattintson jobb gombbal a adattípusmező bármilyen más beállítást mint szöveg, amely lehetővé teszi bármilyen karakter, így soha nem lehet hibás.

9. Állítsa be a Kívántzászló az új ingatlanok.

hangjegy

A mező kitöltése kötelező lehet használni annak jelzésére, hogy egy érték kell beírni a tulajdon. Azaz, hogy nem lehet üres vagy üres. Hamisaz alapértelmezett, és azt a tulajdonság lehet üres vagy üres, Igazazt jelenti, hogy az ingatlan értéke lehet, és nem lehet üres vagy üres. A Szükséges lehet állítani, hogy legyen Tiltva, Figyelmeztetett vagy ÉrvényesíteniEhhez kattintson jobb gombbal a kívánt mezőt, ha azt a True.

Lásd még

Benépesítő az architektúrának - Áttekintés | Hozzátéve, előre beállított tulajdonságok egy alkatrész, csatlakozás vagy típus | Összesített tulajdonságok


Megváltoztatása alkatrész / csatlakozás típusának

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Megváltoztatása alkatrész / csatlakozás típusának

Küldje el észrevételeit ebben a témában.

Komponens és csatlakozó típusok elsősorban a besorolás szempontjából. Használhatja típusok, szűrők, amikor megtekinti az építészet. Például, ahelyett, hogy megtekinti az egészet, akkor is megtekinthették csak alkalmazás-összetevők.

Megváltoztatni egy alkatrész / csatlakozás típusának

1. Jobb klikkAz összetevőtől vagy kapcsolatot.

2. Válassza ki Típus módosítása.

3. Válasszon egy másik típust a listából.

Tipp

Ha megváltoztatjuk a típus, akkor kap néhány új szabványokvagy tulajdonságokat (bármi társul a típus - lásd a típusok ágon szintén). A meglévő szabványok és tulajdonságai változatlanok maradnak. Ön is létrehozhat saját új típusú, és hozzá a saját kombinációi szabványok és tulajdonságait nekik.

Lásd még

Létrehozva egy új típusa | Benépesítő az architektúrának - Áttekintés | Elemző Ön építészet


Módosítása Projekt régióbeállítást

Navigáció: Népszerű az architektúrának> Ingatlan>

Módosítása Projekt régióbeállítást

Küldje el észrevételeit ebben a témában.

Ingatlan értékének szükségük van bizonyos formázási a különböző régiókban, hogy megfeleljen a Adatok korlátai Egész, tízes és dátum / idő tulajdonságok. Például Ausztráliában a tizedes "123.456 pont hét nyolc kilenc" jelentése "123,456.789", míg Németországban lenne represnted mint "123.456,789" és Franciaországban lenne " 123 456789 ".Hasonlóképpen, az USA-ban a "második decemberi" 1970 képviselteti magát, mint egy rövid dátumát "1970/12/02", de az Egyesült Királyságban pedig a "1970/02/12" és Lengyelországban "1970-1912 -02 ". Ennek megfelelően, hogy együtt dolgozik egy ABACUS projekt egyes régiók között világviszonylatban per ABACUS projekt van szükség.

Változtatni Egy ABACUS projekt régióbeállítást

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Válassza ki Fájl | Project Options ... és a megjelenő párbeszédablakban válassza ki a Régió és kattintson az OK gombra. Megjegyzés: Kérjük, olvassa el az alábbi részben a regionális alapértékeket.

hangjegy

Ha nem látja a Project Options ... menüpontotakkor nem kell a tervező és adminisztrátor Hozzáads és nem tudja megváltoztatni a projekt régióban.Továbbá, ha nincs Régió beállítása (azaz a régió Project Options none (Rendszer Régió) "), akkor mindegyik felhasználó MS Windows jelenlegi kultúra beállítások (azaz Területi beállítások)arra használják, hogy érvényesítse a tulajdonságokat.

Régió defaults

Az alábbi táblázat a defaults Minden régió amint a Fájl | Project Options ...menüpontot.Kérjük, lásd a táblázat, amely felsorolja a használt szimbólumok.

Régió | Tizedesjelként | Digit egyesülés | Negatív előjellel | Rövid idő | Hosszú idő | AM / PM szimbólum | Rövid dátum | Hosszú napja
Angol (ausztrál) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / hónap / év | dd MMMM nn
English (United Kingdom) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / hónap / év | dd MMMM nn
Angol (Egyesült Államok) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / nn | dddd, MMMM nn, éééé
Francia (Franciaország) | , | hely | - | HH: mm | HH: mm: ss | | | dd / hónap / év | dddd d MMMM nn
Német (Németország) | , | . | - | HH: mm | HH: mm: ss | | | DD.MM.YYYY | dddd, d. MMMM nn
Olasz (Olaszország) | , | . | - | HH: mm | HH: mm: ss | | | dd / hónap / év | dddd d MMMM nn
Spanyol (Spanyolország) | , | . | - | H: mm | H: mm: ss | | | dd / hónap / év | dddd, dd "de" MMMM 'de' nn
Angol (Kanada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / hónap / év | MMMM-dd-yy
Francia (kanadai) | , | hely | - | HH: mm | HH: mm: ss | | | nn-hh-nn | d MMMM nn
Arab (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / hónap / év | dd MMMM, éééé
Arab (Szaúd-Arábia) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | év / hó / éé | dd / MMMM / nn
Angol (Dél-Afrika) | , | hely | - | hh: mm tt | hh: mm: ss tt | AM | PM | év / hó / dd | dd MMMM nn
Angol (Új-Zéland) | . | , | - | h: mm tt | h: mm: ss tt | órakor | p.m. | d / hónap / év | dddd, nap MMMM nn
Angol (India) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd-HH-NN | dd MMMM nn
Német (Svájc) | . | ' | - | HH: mm | HH: mm: ss | | | DD.MM.YYYY | dddd, d. MMMM nn
Francia (belga) | , | . | - | HH: mm | HH: mm: ss | | | d / hónap / év | dddd d MMMM nn
Holland (Belgium) | , | . | - | H: mm | H: mm: ss | | | d / hónap / év | dddd d MMMM nn
Cseh (Cseh Köztársaság) | , | hely | - | H: mm | H: mm: ss | DOP. | ODP. | d.M.yyyy | d. MMMM nn
Dán (Dánia) | , | . | - | HH: mm | HH: mm: ss | | | dd-HH-NN | d. MMMM nn
Görög (Görögország) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / nn | dddd, nap MMMM nn
Finn (Finnország) | , | hely | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta "yyyy
Magyar (Magyarország) | , | hely | - | H: mm | H: mm: ss | de. | du. | yyyy.MM.dd. | nn. MMMM d.
Holland (Hollandia) | , | . | - | H: mm | H: mm: ss | | | d-M-nn | dddd d MMMM nn
Norvég, bokmal (Norvégia) | , | hely | - | HH: mm | HH: mm: ss | | | DD.MM.YYYY | d. MMMM nn
Lengyel (Lengyelország) | , | hely | - | HH: mm | HH: mm: ss | | | nn-hh-nn | d MMMM nn
Orosz (Oroszország) | , | hely | - | H: mm | H: mm: ss | | | DD.MM.YYYY | d MMMM yyyy "г."
Svéd (Svédország) | , | hely | - | HH: mm | HH: mm: ss | | | nn-hh-nn | "den 'D MMMM nn
Koreai (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | nn-hh-nn | nn "년" M "월" d "일 'dddd
Héber (Izrael) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / hónap / év | dddd dd MMMM nn

Az alábbi szimbólumokat használjuk adni, hogy milyen napokon és időpontokban jelennek meg:

Időszimbólum |
h | Órát (HH megjeleníti az óra, egy vezető nullával)
m | Perc (mm megjeleníti a perc, egy vezető nullával)
s | Második (ss megjeleníti a második, egy vezető nullával)
tt | A.M. vagy P.M.
h / H | 12 vagy 24 órás idő kijelzés
Dátum szimbólumok |
d, dd | Nap
ddd, dddd | A hét napja
M | Hó
y | Év

Lásd még

Benépesítő az architektúrának - Áttekintés | A tulajdonságok módosításával egy komponens, kapcsolat vagy típus | Hozzátéve, előre beállított tulajdonságok egy alkatrész, csatlakozás vagy típus


Parancssori opciók

Navigáció: Referencia>

Parancssori opciók

Küldje el észrevételeit ebben a témában.

Akkor végre különböző műveleteket ABACUS közvetlenül a parancssorban a leggyakoribb művelet megnyitni egy adott projekt fájlt, és azt közzéteszi HTML.

Pontosabban, a parancssor használatát ABACUS a következő;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "USER" / pass "PASS"]

Érv | Leírás
ProjectFile | A ProjectFile lehet egy ABACUS projekt fájl (.abacus), könyvtár fájl (.abacuslib), XML fájl (.xml) vagy MS Access DB (mdb) és a fájl akkor sem kell nyitni (ha .abacus vagy .abacuslib ), vagy egy új projekt létre (ha .xml vagy Mdb fájl).
OptionalFile | A OptionalFile lehet egy ABACUS script (.abacusscript, .vb vagy .cs), makró (.abacusmac) vagy a könyvtár fájl (.abacuslib) és a fájl akkor sem lehet futtatni kinyitása után ProjectFile (ha .abacusscript, .vb vagy .cs vagy .abacusmac), vagy egyszerűen nyitható (ha .abacuslib).
/ exitOnCompletion | Kilép ABACUS és ha szükséges megtakarítás és kötelezzék el semmilyen változtatást a nyílt .abacus projektek befejezését a script, vagy makró. Megjegyzés: Ez a zászló a kis- és nagybetűket, így biztos, hogy használjon nagybetűs "O" és "C" a szövegben látható.
/ dontShowDialogs | Megakadályozza ABACUS Enterprise Edition (EE) frissítési értesítést dialógusok megjelenjenek nyitásakor a projekt. Megjegyzés: Ez a zászló a kis- és nagybetűket, így biztos, hogy használjon nagybetűs "S" és "D" a szövegben látható.
/ user "USER" / pass "PASS" | A felhasználónév és a jelszó PASS USER fogják használni, hogy jelentkezzen be a projektet, felülbírálva a mentett felhasználói hitelesítő adatokat. Megjegyzés: Dupla idézetek kell elhelyezni a felhasználó köré, és adja át zászlók és két kettős idézőjelek lehet használni, hogy elkerülje a kettős idézőjelek közé sem a felhasználó vagy PASS zászlók.

Ilyen például.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.Vb"/ exitOnCompletion / dontShowDialogs / user "Nyilvános" / pass "123456"

amikor futtassa a könyvtárban, ahol a ABACUS.exe kétkomponensű van található akarat nyisd ki A példa projekt és felhasználóként Nyilvános jelszóval 123456 (leírtak itt ), Közzéteszi a HTML és zárja be a projekt összes anélkül, hogy bármilyen dialógusok az út mentén (pl 'Frissítés sikeres "vagy" Nincs elérhető frissítés "Vállalkozásfejlesztési projektek).

Ilyen például.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalógus Excel Import.Vb"/ exitOnCompletion / dontShowDialogs

amikor futtassa a könyvtárban, ahol a ABACUS.exe kétkomponensű van található akarat nyisd ki A példa projekt és importálja a "Servers (2014 Actual) .xlsx" MS Excel fájlt a "Szerverek" katalógusát "2014 Actual" architektúra a projekt nem jelentkezik semmilyen dialógusok az út mentén, majd bezárja a projekt befejezését. Ha a művelet módosítja a projektet, majd amikor becsukja a változásokat menti helyi és ha egy vállalkozás projekt elkötelezett az Enterprise Server.

hangjegy

Ügyeljen arra, hogy a megfelelő idézőjelig mivel több a szabványos ASCII karakterkészlet és a Windows parancssorban csak akkor működik megfelelően, ha a helyes. A helyes idézőjelig kód Tizedes 34 (hexadecimális 22).Ez az, amit használnak a fenti példában így bátran copy / paste onnan.


Másolás és beillesztés

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Másolás és beillesztés

Küldje el észrevételeit ebben a témában.

Tudja másolni egy részét vagy egészét az architektúrának és illessze be egy másik helyen, a fa.

Másolni

1. Jobb klikkA tételt szeretne másolni.

2. Válassza ki Másolat.

BeillesztÒse

1. Mozgás a fa, hogy megtalálják a helyet szeretne illessze be az elemet.

2. Jobb klikkaz ág azt szeretné, hogy megjelenhessenek.

3. Válassza ki Paszta.

4. Az elem lehet másolni az eredeti névvel (ha nem másoljuk az eredeti ág -, akkor ez lesz az úgynevezett "Copy of ...").

Lásd még

Hogyan épül fel egy építészeti képviselt ABACUS


Másolás diagramok

Navigáció: Népszerű az architektúrának használata> Rajzok>

Másolás diagramok

Küldje el észrevételeit ebben a témában.

Van 2 alapvető forgatókönyv a másolás egy meglévő rajzot; architektúrán belül, vagy az egész architektúrák.

Hogy másolatdiagramarchitektúrán belül

1. Győződjön meg arról, hogy van egyABACUS fájlmegnyitásitartalmazza a lakott építészetlegalább egy diagram.

2. Kibontása a Diagramok ág (és az esetleg szükséges Diagram csoportok) egy adott Építészetrészben a fa.

3. Válassza ki a rajz a másolni kívánt, majd nyomja meg Ctrl + C vagy Jobb klikkés válassza Másolat a menüből.

hangjegy

A példányát a ábra hozzáadásra kerül a Diagramokága a azonos építészet. Ez lesz "Másolata" hozzáadódik a név elejét, Amely megváltoztathatja később F2 vagy jobb kattintássalés kiválasztja átnevezése.

Hogy másolni egy rajz keresztül architektúrák

1. Győződjön meg arról, hogy van egyABACUS fájlmegnyitásitartalmazza a lakott építészetslegalább egy diagram.

2. Kibontása a Diagramok ág (és az esetleg szükséges Diagram csoportok) A a Építészetrészben a faAz architektúra, amely tartalmazza a rajz a másolni kívánt.

3. Válassza ki a rajz a másolni kívánt és a Általános tulajdonságokablak veszi a Nézőpont A diagram kapcsolódik (a Típus mezőben).

4. Most, bővítse a Diagramok ág (és az esetleg szükséges Diagram csoportok) A a Építészetrészben a famás architektúrára, hogy másolni kívánt diagram a.

5. Jobb klikk a Diagramok csomópont (vagy a Diagram-csoport), És válassza Hozzon létre Diagram .... A megjelenő párbeszédablakban válassza ki a Nézőpont hogy jegyezte a fenti 3 lépésben a legördülő jobb felső. Hagyja minden mást is, és kattintson oké. A diagram címe párbeszédablakban adjon meg egy nevet a (hamarosan) másolt rajz. Megjegyzés: Az üres rajz vászon a választott nézőpont nyílik.

6. Térjen vissza a rajzot, hogy a másolni kívánt és nyitott, hogy a jobb gombbal kattintvaA csomópont és kiválasztó Nyisd ki vagy egyszerűen duplán kattintva azt.

7. Válassza ki a háttérben vászon, a rajz másolni kívánt, majd nyomja meg Ctrl + A. Ez kijelöli valamennyi elemét, hogy rajz. Most nyomja Ctrl + CA tartalom másolására a vágólapra.

8. Térjünk vissza az üres diagram az építészet másolni kívánt a tartalmat, válassza ki a háttérbenvászon és vagy Jobb klikkés válassza Paszta vagy egyszerűen nyomjuk meg Ctrl + Vhogy illessze be a tartalmat. Miután egy rövid ideig a tartalom minden illeszti be az új üres rajzot.

hangjegy

Elemeket hozzá kell adni a legfelső szintű az új architektúra és kell majd átrendezték, vagy egyesült a meglévő tartalmat ennek megfelelően.

Lásd még

A rajz eszköz | Benépesítő az architektúrának | Elemző Ön építészet


Létrehozva egy új alkatrész / csatlakozás típusa vagy típuscsoportja

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Létrehozva egy új alkatrész / csatlakozás típusa vagy típuscsoportja

Küldje el észrevételeit ebben a témában.

Komponens és csatlakozó típusok elsősorban a besorolás szempontjából. Használhatja típusok, szűrők, amikor megtekinti az építészet. Például, ahelyett, hogy megtekinti az egészet, akkor is megtekinthették csak alkalmazás-összetevők.

Ahhoz, hogy hozzon létre egy új alkatrész / csatlakozás típusa

hangjegy

Hozzáadni típusú vagy jellegű csoport egy ABACUS projekt a felhasználói licenc szüksége a tervező add-on képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

1. Bővíteni a Típusokága a fa.

2. Jobb klikk on Komponens típusok (vagy Csatlakozási típusok).

3. Válassza ki Add összetevő típusa (vagy Add csatlakozás típusa) vagy Csoport létrehozása.

Tipp

Miután létrehozott egy típus, akkor változtatni kell az ikonja (lásd alább), és adjunk hozzá tulajdonságok és szabványok hogy ez az összetevő vagy kapcsolat esetben a "örökli".

Megváltoztatni ikont alkatrész / csatlakozás típusa

hangjegy

Ahhoz, hogy változtatni az ikonok a típusok egy ABACUS projekt a felhasználói licenc szüksége a tervező add-on képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

1. Jobb klikka Komponens típusa (vagy Csatlakozás típusa) Meg akarja változtatni az ikont.

2. Válassza ki Ikon módosítása.

3. A Select Icon párbeszédpanelen keresse meg a helyét, és válassza ki egy képfájlt és a Megnyitás gombra.

hangjegy

Tudod van egy egyéni ikont kép tetszőleges méretű, de mindig lesz méretezve, hogy egy 16x16 pixeles képet az Explorer ablakban. Tehát, ha az eredeti egyéni ikon képe nem egyenlő magassága és szélessége az Intéző ablak ikon nyújtva. Ennek megfelelően az egyéni képeket kell legalább 16x16 pixel, és ha azt szeretné, hogy megtartja a pontos alakjának egyéni ikon győződjön meg róla, egyéni ikont a kép azonos magasságú és szélessége pixelben (16x16 vagy nagyobb). Akkor is meg kell óvatosnak nem rendelkező színes "pixel" megy egészen a határ az egyéni ikon kép úgy fog kinézni rossz az Explorer ablakban a szomszédos ikonok "vérzés" egymásba. Ennek megfelelően, meg kell hagyni legalább egy 1 pixel fehér szegéllyel.

Tipp

Tudod, hogy az egyéni ikonképet egy Ico, .bmp, .gif, .jpg vagy .png formátumú fájlt, de korlátai miatt a Windows csak Ico formátumú előnézeti az ABACUS Ikonválasztás dialógus, ha a Nézet menü opciót állítva semmi más, mint Miniatűrök.

Lásd még

Benépesítő az architektúrának - Áttekintés | Elemző Ön építészet


Létrehozása vagy párhuzamosan egy olyan építészet

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Létrehozása vagy párhuzamosan egy olyan építészet

Küldje el észrevételeit ebben a témában.

Tetszőleges számú architektúrák egyetlen ABACUS fájlt. Általában azt hozzon létre egy új architektúra minden alkalommal a modellezni kívánt és értékelik a fejlődés a rendszer.

Ahhoz, hogy hozzon létre egy új architektúra

1. Jobb klikka Architektúrákága a fa.

2. Válassza ki Új Építészet.

Hogy hozzon létre egy másolatot a meglévő architektúra

1. Jobb klikkA architektúra.

2. Válassza ki Másolat.

3. Jobb klikka Architektúrákága a fa.

4. Válassza ki Paszta.

5. Az új architektúra fogják hívni "másolata ...".

Fejlődni egy meglévő architektúra

1. Jobb klikkA architektúra.

2. Válassza ki Fejlődik.

3. Az új architektúra fogják hívni "... 0,1".

hangjegy

Van egy részletes leírást a fejlődő architektúrák itt .

Lásd még

Hogyan épül fel egy építészeti képviselt ABACUS | Fejlődik az architektúrának


Egyéni jelentések

Navigáció: Jelentés az adott architektúrán>

Egyéni jelentések

Küldje el észrevételeit ebben a témában.

ABACUS "egyéni jelentések lehetővé teszik, hogy teljesen konfigurálható egyéni jelentések. A jelentések tartalmazhatnak egyedi képekkel és grafika, valamint részletezi az olyan alkatrészek, csatlakozások vagy tulajdonságok egy ABACUS adattár valamint részletes analitikai eredményeket a különböző szimulációk (beleértve a TCO, teljesítmény és megbízhatóság). Továbbá, a jelentések tartalmazzák grafikonok, táblázatok, katalógusok, matricák / pivot táblák, térképek, szelvények, értékgörbék, adatok bárok és mutatók (pl közlekedési lámpák).

hangjegy

Ugyan minden felhasználó meg tudja nyitni a meglévő egyéni jelentések, to configure jelentések A felhasználói licenc szüksége Jelentés konfiguráció képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

Megtekintéséhez szokás jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet(k).

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentésekablak jelenik meg.

Egyéni jelentések ablak

3. Válassza ki a létező Jelentéskívánt megjeleníteni tól Elérhető jelentések szakasz.

4. Kattintson Jelentés futtatása.A jelentés nyílik meg a Microsoft Report Viewer és to navigálhat a jelentés oldalakon, kattintson az ikonokra [image] az eszköztáron találhatók a bal felső sarokban.

hangjegy

tudsz mentés a jelentés a különböző formátumok kattintson a Export az ikon [image] található ban Az eszköztár. Választhat, hogy az export a következő formátumokban: Excel, PDF és Szó. Kérjük menteni a jelentést a kívánt helyre későbbi felhasználásra. Ha módosításokat hajt végre, hogy az architektúra egy későbbi időpontban, egy új jelentést kell majd létre, hogy tükrözze a változásokat.

Hogy tárolót szerkeszteni küldött adatokat a a szokás jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet(k).

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentések ablak (fent látható) jelenik.

hangjegy

Ugyan minden felhasználó meg tudja nyitni a meglévő egyéni jelentések, to configure A küldött adatokat az egyéni jelentést A felhasználói licenc szüksége Jelentés konfiguráció képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

3. Válassza ki a létező Jelentéskívánt megjeleníteni tól Elérhető jelentések szakasz.

4. Kattintson Szerkesztés adathalmazok. A Data Set Szerkesztőablak jelenik meg.Ez az ablak mutatja az adatgyűjtést határozza meg, hogy éppen küldött, hogy az egyéni jelentést. Az alábbi példában három (3);

· Egy ApplicationProxy adathalmaz, amely meghatározza az összes részletet az összes alkalmazás-összetevő a "2015 Actual" építészet (beleértve a tulajdonságokat a szabványok és a csatlakoztatott komponensek),

· Egy TwoDViewProxy adathalmaz, amely meghatározza egy vagy több diagram, ahol a név megegyezik "Application Tájkép (Ausztrália)",

· Egy TargetProxy adathalmaz, amely meghatározza minden részletet a célt kapcsolatot a "2015 Actual" építészet (beleértve a mellékelt komponensek).

Data Set Szerkesztő ablak

Hangjegy

A lekérdezés nevét fogják használni az adathalmaz név közé Microsoft Report Builder (lásd alább). Az include mező határozza meg, hogy az adatbázisba vagy egy egyszerű elem, a gyűjtemény elemei, alkotó valamennyi típusú, minden kapcsolat típusok, egy vagy több architektúrák, egy vagy több diagram, illetve egy vagy több Charts. A kollekció az Elements 'adatok állít Szűrő gomb áll rendelkezésre, amelyre kattintva megnyílik az Element szűrő ablak, amely lehetővé teszi, hogy alkalmazza a többszörös szűrők segítségével csak olyan elemeket bizonyos architektúrák, és / vagy bizonyos típusú, és / vagy az egyes előírásoknak , és / vagy a csatolt egyes alkatrészek, és / vagy bizonyos szülők, és / vagy bizonyos diagramok, és / vagy bizonyos Táblázatok és / vagy adott tulajdonság értékeket. A többi adatsor típusok a Név mező és a Kijelölés gombra kiválaszthatja a tárgy (ak) fel kell venni a rendelkezésre álló adatok alapján.

Hangjegy

Az adathalmazok tárolása egyAdathalmazok fájl (.xml)az azonos alap fájlnevet, mint egy társult Report fájl (.RDL). Ha ez a fájl nem létezik az adathalmaz szerkesztő automatikusan feltölti bármilyen kérdéssel neveket, hogy létezik a Report fájl (.RDL)és egy új Adathalmazok fájl (.xml)akkor jön létre, amikor aa érvényes listája lekérdezések meghatározása.

3. Ha törölni szeretne egy meglévő adathalmaz majd válassza ki a Törlés Kérdés gomb.

4. Ha szeretné, hogy egy új adatsor majd a Add New Data Setgombra, és adja az adathalmaz, mint egy a fenti megjegyzést.

Hogy hozzon létre egy új egyéni jelentés(sablonból)

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet.

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentések ablak (fent látható) jelenik.

3. Kattintson Új és válassza ki vagy A4 - Portré, A4 Fekvő, A3 - Portré, A3 Fekvő, US Letter - Portré, US Letter - Tájkép, USA Bulvár - Portré vagy USA Bulvár - Tájképattól függően, hogy a jelentés tájolásának és a papír méretét, hogy kívánatos.

4. Keresse meg a helyet, hogy mentse a jelentés fájl (.rdl / .rdlc) és az ennek megfelelő Data Set fájl (.xml), majd kattintson Mentés. Ez hozzáad egy új egyéni jelentést az Elérhető jelentések részben az egyéni jelentések ablakot, és azt is kinyitotta vagy szerkesztett fent leírtak szerint.

Hogy add egy meglévő egyéni jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet.

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentések ablak (fent látható) jelenik.

3. Kattintson Add és keresse meg a helyét a jelentés fájl (.rdl / .rdlc), majd kattintson Nyisd ki. Ez hozzáad egy új egyéni jelentést az Elérhető jelentések részben az egyéni jelentések ablakot, és azt is kinyitotta vagy szerkesztett fent leírtak szerint.

Hangjegy

Azt feltételezik, hogy a megfelelő Data Set fájl (.xml) létezik ugyanazon a helyen, mint a jelentés definíciós fájlt.

Hogy másolni egy meglévő egyéni jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet.

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentések ablak (fent látható) jelenik.

3. Válassza ki a létező Jelentéskívánt másolni tól Elérhető jelentések szakasz.

4. Kattintson Másolat és annak egy példányát a kiválasztott jelentés (a neve 'másolata ... ") hozzá kell adni az Elérhető jelentések részben az egyéni jelentések ablakot, és azt is kinyitotta vagy szerkesztett fent leírtak szerint.

Hangjegy

Ezzel akkor létrehoz egy példányt a jelentés Report Definition akta (.rdl / .rdlc) valamint a illő Data Set fájl (.xml)(ha létezik).

Hogy távolítsa el a meglévő egyéni jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet.

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentések ablak (fent látható) jelenik.

3. Válassza ki a létező Jelentéskívánt eltávolítani tól Elérhető jelentésekrészt, majd kattintson Távolítsuk.

Hangjegy

Ha eltávolít egy jelentést, hogy többé nem jelenik meg a jelentésben listát. Azonban ez nem törli a jelentés Jelentés Definition akta (.rdl / .rdlc) vagy a Data Set akta(.xml). Ha szükséges, fájlok törlése révén lehet elérni a fájlrendszer.

Hogy átnevezni egy meglévő egyéni jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet.

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentések ablak (fent látható) jelenik.

3. Válassza ki a létező Jelentéskívánt átnevezni a a Elérhető jelentésekrészt, majd kattintson Átnevezése.

4. Adjon meg egy új nevet a jelentést.

Hangjegy

Mind a jelentés fájl (.rdl / .rdlc) és az ennek megfelelő Data Set fájl (.xml) átnevezésre kerül ennek megfelelően.

Hogy szerkeszteni a tervezés egy szokás jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet.

2. Válassza ki Helyezze| Egyedi jelentésvagy kattintson a Egyéni jelentés létrehozása eszköztár gombra. A Egyéni jelentések ablak (fent látható) jelenik.

hangjegy

Ugyan minden felhasználó meg tudja nyitni a meglévő egyéni jelentések, to configure A tervezés egy egyéni jelentések A felhasználói licenc szüksége Jelentés konfiguráció képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.Ezenfelül a Microsoft Report Builder 3.0 szükséges tervezni jelentések és lehet ingyenesen letölthető itt .

3. Válassza ki a létező Jelentéskívánt megjeleníteni tól Elérhető jelentések szakasz.

4. Kattintson Jelentés szerkesztése.A jelentés nyílik meg a Microsoft Report Builder 3.0. Konkrét segítséget és néhány "tippek és trükkök" néhány a leggyakoribb feladatok tervezése jelentések kérjük, olvassa el az alábbi pontokban. Általános segítség tervezése jelentések kérem hivatkozzon A Microsoft Report Builder 3.0 súgóoldalain itt .

Hozzátéve, táblázatok a jelentés

1. Győződjön meg arról, hogy van Egy ABACUS Egyedi jelentés fájl (.rdl / .rdlc) nyitott a Microsoft Report Builder 3.0.

2. Válassza ki a Helyezze fülön a "szalag" a tetején, majd kattintson az Táblázat gombA Data Régiók oldalunkon, és válassza Táblázat beszúrása.

3. Most húzza a kurzortAz elhelyezkedés a jelentés vásznon, ahová a bal felső sarokban az asztal helyezett. Kattintson a vásznon. Alapértelmezésben a táblázat lesz hozzá egy fejléc, majd a részleteket csoport (csoport szervezésére használjuk néző jelentést adatbázisba). Ahhoz, hogy távolítsa el a csoportot, vagy törölje a sort, vagy törölje a Row Csoport a Csoportosulás eszköztár.

Tipps

Formulák / kifejezések táblázatban sejtek által szerkesztett kiválasztja a sejt majd a jobb egérgombbal a << >> Expr szöveget és kiválasztja Expression .... Válogató sorok egy táblázatot Ehhez válasszuk ki az asztalra, majd böngészni le a másik -> SortExpressions mezőt a Tulajdonságok panel és a belépő egy kifejezés. A teljes sor végén egy asztal hozzá sorban után (és kívül) az egyesülés, majd a következő kifejezés = Sum (Fields!Név.Érték)ahol "Név" az a terület, hogy összesítik. Alkalmazni színező oszlopokhoz használni "IIF nyilatkozata a BackgroundColor ingatlan. Hogy adjunk egy nyomtávú, mint egy cellát egy táblát helyezze be a szelvény egy cellába, majd vidd adat mely szükséges a szelvény. Szerkesztésekor a magasságot és szélességet a táblázat sorait, győződjön meg róla válassza ki a megfelelő sort, majd vigye az egér mutatóját az egész szürke vonalak, amíg nem kap a nyíl fel / le kurzor, majd átméretezni.

Hozzátéve, grafikonok a jelentés

1. Győződjön meg arról, hogy van Egy ABACUS Egyedi jelentés fájl (.rdl / .rdlc) nyitott a Microsoft Report Builder 3.0.

2. Válassza ki a Helyezze fülön a "szalag" a tetején, majd kattintson az Diagram gombA Data Régiók oldalunkon, és válassza Helyezze kör.

3. Most húzza a kurzortAz elhelyezkedés a jelentés vásznon, ahová a bal felső sarokban a diagram helyezni. Kattintson a vásznon és akkor jelölje ki a diagramvan szüksége, a lehetőségek és kattintson oké.

Tipps

Hogy megjelenjen a tulajdonság, mint egy jegyzet térképeken, jobb klikk a charton, és válassza annak adatcímkéket, majd válassza ki a címkéket bővült, és állítsa be a Egyéb -> UseValueAsLabel False a Properties panelen, és adjunk hozzá egy kifejezés (pl = Fields! Name.Value) a Egyéb -> címke. Kifejezetten buborék grafikonok; Buborék grafikonok jelennek alatt Pontdiagram cím. Dobd X tengely tulajdonának sorozat mezőket (vagy hozzá Series Properties). Dobd Y tengely tulajdonának adatok mezők (vagy hozzá Series Properties). Hogy egy ingatlan meghatározni buborék méretét, vidd ezt figyelembe adatok mezők (vagy hozzá Series Properties). Bubble diagramok nem tudja megjeleníteni, ha túl sok az adat (200 + elem), néha ez okozza a teljes jelentést nem jelenik meg. Marker Type - Állítsd kör. Alapértelmezésben, amikor csökken a mezőket adatok mezők, teszi hozzá őket a összeg()képlet, így távolítsa el ezt. Kifejezetten Halmozott grafikonok / Timeline / Gantt-diagramok; Egy Gantt-diagram a számos ábra és add tulajdonságokkal magas és alacsony értékek az adatbeviteli mezőket. Egyszerre több a "rácsok" hozzáadásával több és több tartományt, ahol az alacsony érték az egyik megfelel a magas érték a másik. Kifejezetten Kördiagramok; Összesített tortadiagramokból dobja az adatokat Kategória mezőket és adatok mezők, adjuk hozzá a formula = CountRows (). Kiszűrni a 0 értékeket (pl költség táblázatok), különben a címkék ezek továbbra is megjelennek a térképen.

Segítségével IIF nyilatkozatot színesebb lesz, táblázatok és grafikonok

1. Győződjön meg arról, hogy van Egy ABACUS Egyedi jelentés fájl (.rdl / .rdlc) nyitott a Microsoft Report Builder 3.0.

2. Kattintson jobb gombbal a cella a táblázatban szín és a kattintás Text Box Properties.

3. Válassza ki Tölt és kattintson a fxgombra a jobb oldalon a kitöltés színe címkén és a Set egy kifejezés BackgroundColor mezőbe írja be egy kifejezést, pl = IIF (Fields! InformationStatus.Value = "megtartani", "Világos zöld", IIF (Fields! InformationStatus.Value = "Újratervezés", "Sárga", IIF (Fields! InformationStatus.Value = "Frissítés", "Orange", " Lazac"))). Ez megváltoztatja a háttér színe zöld fény minden egyes sejt, amely tartalmazza a Status "megtartani", sárga minden sejt, amely tartalmazza a Status "újratervezése", Orange minden sejt, amely tartalmazza az állapotot "Frissítés" és minden egyéb helyzet szerinti értéke színezve lesz a "Lazac".

hangjegy

Színek lehet adni grafikonok adja meg a sorozatot a diagramon, majd beállítani a Megjelenés -> Color tulajdonság (vagy buborék grafikonok a Megjelenés -> Marker -> Color tulajdon) kifejezés a fentiekhez hasonló példa.

Dolog, hogy tartsa szem előtt a tervezés során egyéni jelentések

· Mivel minden ingatlan kivételével Egész kerülnek elküldésre stringet ABACUS a jelentés néző, ha akarok semmilyen megnyilvánulását velük (mint megosztottság egyik tulajdonság a másik, vagy sort) kell átalakítani, hogy a decimális vagy dátum stb háttérben , ez a cikk egy jó referencia. Ilyen például. = CDate (Fields! LifecycleEndDate.Value) Megjegyzés: Kérjük, hogy a jelentés nyelv az en-GB (lásd az alábbiakban), hogy elfogadja dd / mm / yyyy ahogy elvárja mm / nap / év formátumban alapértelmezés szerint, és ennek megfelelően 31/7/2011 sikertelen lesz konverzió. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Ha úgy találja, hogy te küzd, hogy tartani az összes táblázatok és grafikonok egy oldalon, Van néhány fő kezelésének módjait a dokumentum helyet:

· Oldal Break - Biztosítani kell, hogy ez a táblázat beállítás ki van kapcsolva minden asztalra, hogy azt szeretné, hogy ugyanazon az oldalon.

· Maradjunk együtt - biztosítsák ezt a táblázatot beállítás Igaz-egy tábla, hogy azt szeretné, hogy ugyanazon az oldalon.

· Amikor a mozgó dolgokat, akkor könnyebb kicsinyíteni a control alján az oldal jobb majd több tétel kiválasztásához és húzza

· A kép egy táblában lévő sor, győződjön meg arról, hogy a "Méret" | "Kalibrálás" tulajdonság értéke "Fit" különben a kép megjelenhet túl nagy, vagy akkor rosszul nyúlt.

· Hogy ismételje meg a fejlécsora táblázat minden oldalonA jelentés:

1. Nyílt Speciális mód a csoportosulások ablaktábla. (Kattintson a nyílra az oszlop csoportok és válassza ki a Speciális mód.)

2. A sorcsoportba terület (nem Column csoportjai), kattintson a Static-csoport, amely kiemeli a megfelelő szövegdobozba a TABLIX. Kattintson keresztül minden Statikus csoport amíg kiemeli a bal szélső oszlop fejlécére. Ez általában az első statikus csoport szerepel.

3. A Tulajdonságok ablakban állítsa be az RepeatOnNewPage tulajdonságot True.

4. Győződjön meg arról, hogy a KeepWithGroup tulajdonság beállítása után.

· Megváltoztatni a nyelvi beállításokA jelentés tulajdonságok egyezteti az adatokat formátumokat van szüksége, pl hu-HU elő UK formátumban (nap / hó / év).

Lásd még

Elemezve az architektúrának


Testreszabása ABACUS interfész

Navigáció: Bevezetés a ABACUS>

Testreszabása ABACUS interfész

Küldje el észrevételeit ebben a témában.

Meg lehet változtatni a megjelenését és viselkedését a ABACUS interfész sok. ABACUS tartalmaz néhány előre definiált beállítás-kombinációk, amelyek segítségével alkalmazni egy csoport hozása a felületet. Ezen felül, akkor lehet, hogy az egyéni testreszabást a tételek, mint például az ablakok, eszköztárak, gyorsbillentyűk, és különböző kijelzők lehetőségeket.

Rendezzük és Dock Windows-

Van sok lehetőség, hogy intézkedjen ablakokat belül interfész ABACUS, beleértve a következőket:

· Tab-dokkoló ablakok.

· Dock ablakok szélén egy keretet a felületen.

· Csökkentse minimálisra eszköz ablak széle mentén a felület.

· Visszaállítása ablakok elhelyezésével, hogy az alapértelmezett elrendezés.

Dokkoló a Windows

Amikor egy ablak dokkolható, lehet rögzítve az egyik oldalán egy keret belül a felület vagy lehet elrendezve füles üvegtáblák a kereten belül. A kalauz gyémánt jelenik meg húzza ablakok a jelenlegi helyen, hogy egy másik helyen, a felületen. Az útmutató gyémánt lehetővé teszi, hogy gyorsan újra dokkolni egy ablak a négy oldalán a keret, vagy a közepén, mint egy füles panelen. Amikor egy ablak nem rögzített, vagy nem dokkolható, úszik a tetején a többi ablak.

Dokkolni ablakok

1. Kattintson a kívánt ablakot dokkolni, hogy ez a hangsúly.

2. A Ablakmenü Dokkolható.

3. Húzza az ablakot a jelenlegi helyéről közepe felé a keret szeretné dokkolni azt.

A kalauz gyémánt jelenik meg. A négy nyíl a gyémánt pont felé négy keret széleit és a központ jelenti a füles panelen.

Tipp

Mozgatni egy dokkolható ablak nélkül harapós a helyére, nyomjuk meg a CTRL húzás közben is.

4. Amikor az ablak húz eléri azt a pozíciót, ahová a rögzítéshez, mozgassa az egérmutatót a megfelelő része a vezető gyémánt. Az ablak körvonala megjelenik a kijelölt területen.

5. Rögzíti az ablakot a megjelölt helyen, engedje fel az egérgombot.

Például, ha Felfedeződokkolt a bal szélén a felületet, és szeretné rögzítheti a jobb szélén, akkor húzza Felfedezőközepe felé a felület, mozgassa az egérmutatót a jobb oldalon a vezető gyémánt, majd engedje fel az egérgombot.

Minimalizálása a Windows

A Windows (függetlenül attól, hogy eszköz a Windows - megjelent a Kilátásmenüben, vagy dokumentum a Windows - megjelent a Ablakmenü) támogatja a funkció úgynevezett automatikus elrejtés. Auto Hide lehetővé teszi, hogy többet látni az architektúrának egyszerre minimalizálásával ablakok szélei mentén a felület, ha nem használja.

Ahhoz, hogy kapcsolja be az Auto Hide

1. Kattintson az ablak elrejteni kívánt adni neki koncentrálni.

2. A Ablakmenü Auto Hide.

- vagy -

2. Kattintson a rajzszög ikonra a címsorban az ablakon.

Auto Hide Enabled

Amikor egy automatikus elrejtés ablak elveszti a fókuszt, akkor automatikusan visszacsúszik a lap szélén a felület. Míg egy ablak automatikus elrejtés, a neve és ikonja látható a lap szélén a felület. Hogy megjelenítsen egy automatikus elrejtés ablakban vigye az egérmutatót a fül. Az ablak visszacsúszik a képbe, és készen áll a használatra.

hangjegy

Egy ablak, amely automatikus elrejtés nem rögzíthető. Dokkolni egy ablak akkor ki kell kapcsolnia automatikus elrejtés az alábbiak szerint.

Hogy kikapcsolja az Automatikus elrejtés

1. Kattintson az ablak meg szeretné tartani látható, hogy ez a hangsúly.

2. A Ablakmenü Auto Hidetörölje a pipát.

- vagy -

2. Kattintson a rajzszög ikonra a címsorban az ablakon.

Auto Hide mozgássérültek

Tipp

Ablak automatikus elrejtés engedélyezése átmenetileg csúszik a képbe, amikor az ablak van fókuszban. Az ablak elrejtéséhez ismét, válasszon egy tételt kívül az aktuális ablakot. Miután az ablak elveszti a fókuszt, hogy visszacsúszik ki álláspontját.

Az újraindítással a Windows-elrendezések

Akkor vissza a felületet, hogy az alapértelmezett ablakelrendezésben segítségével Visszaállítása ablakelrendezést parancs. Amikor futtatja ezt a parancsot, a következő beavatkozások történnek:

· Minden ablakon át az alapértelmezett pozíciót.

· Ablak zárva az alapértelmezett ablakelrendezésben le vannak zárva a parancsot.

· Ablakok nyitva vannak az alapértelmezett ablak elrendezése is nyit a parancsot.

· A Windows vannak elrejtve / látható alapértelmezett ablakelrendezésben készült rejtett / látható a parancsot.

Visszaállításához ablakelhelyezéssel az alapértelmezett elrendezés

1. A ablakokmenü Visszaállítása ablakelrendezést.

Testre menük és eszköztárak

Meg lehet változtatni az elrendezés, a munkakört és tartalma menük és eszköztárak a felületen. Azt is hozzá gombokkal eszköztárak és megváltoztassa a megadott ikonra bármelyik gombot.

Új eszköztárak

Ahhoz, hogy hozzon létre egy új eszköztár

1. A Eszközökmenüből válassza ki Testreszabása.

2. A Testreszabásapárbeszédablakban válassza ki a Eszköztárakfület.

3. Válaszd ki Új.

4. A Új Eszköztárpárbeszédablakban adjon nevet az eszköztár.

5. Válaszd ki oké.

Parancs hozzáadása gombbal egy menü vagy eszköztár

1. A Eszközökmenüből válassza ki Testreszabása.

2. A Testreszabásapárbeszédablakban válassza ki a Parancsokfület.

3. Válasszon egy kategóriát, majd húzza a parancsot ki a párbeszédablakban a menü vagy eszköztár.

4. Válaszd ki Közeli.

Tipp

Lenyomva tartja az Alt-kulcs lehetővé teszi, hogy gyorsan testre parancsokat, mintha a Customize dialógus nyitva volt.

Lásd még

Az ABACUS interfész


Meghatározása és érvényesítése Megszorítások

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Meghatározása és érvényesítése Megszorítások

Küldje el észrevételeit ebben a témában.

A szerkezete és tulajdonságai egy architektúra lehet korlátozni segítségével korlátok. A kényszerek lehet alkalmazni, hogy komponens típusok és a kapcsolat típusok, hogy korlátozza a szerkezet egy olyan építészet két módon. Az első módszer az, hogy korlátozza a hierarchiameghatározásával "szülő / kell rendelkeznie gyermek" és a "gyermek / szülő kell" kapcsolatokat. A második módszer az, hogy korlátozza a topológiameghatározásával "összetevő / csatolni kell kapcsolatot" és "kapcsolat kell / kell csatolni alkatrész" kapcsolatokat. Továbbá korlátokat lehet alkalmazni a tulajdonságait komponens típusok, csatlakozó típusok, sablonok, kilátók, architektúrák, diagramokés 3D nézetben, hogy korlátozza az architektúra (ek) ben két további módon. Az első lehetőség, hogy állítsa be a adattípusAz ingatlan korlátozni az érvényes értékeket, hogy lehet, nevezetesen; Szöveg, Egész, tízes dátum / idő, logikai vagy List. A második lehetőség, hogy állítsa be a kívántaz ingatlan állapotát, jelezve, hogy egy érték kell beírni a tulajdonság (Megjegyzés: A kötelező korlátok csak az ingatlan alkatrész és csatlakozó típusok). További információk a tulajdon megszorítások biztosított a A tulajdonságok módosításával egy komponens, kapcsolat vagy típus súgótémakörre. Miután megszorítások vannak definiálva, lehetőség van, hogy érvényesítse egy olyan építészet ellen, a korlátok. ABACUS figyelmeztetni fog semmilyen korlátozás, hogy megsértették.

A legfontosabb, hogy melyik korlát (ok) meghatározása rejlik pontosan ezzel a kifejezéssel, hogy leírja a korlátozást. Mert hierarchia megszorítások ezek jellemzően a forma "főneveklehet / kell / kell bontani n főnevek" vagy "főneveklehet / kell / kell összesíteni főnevek"Stb Például,"Részlegekkell bontani Csapatok" vagy "Alkalmazásokbontható Modulok". A topológia korlátokat ezek jellemzően a forma"főneveklehet / kell / kell ige főnevek". Például, "Folyamatok lehet előadja Csapatok" vagy "Alkalmazások vannak házigazdája Szerverek". Most láthatjuk az egyes kényszer vannak különböző lehet / kell / kell" selejtező "és ez lehet a 3 fajta;

· Választható- Ezek jellemzően szavak / kifejezések, mint például; "lehet", "lehet", "úgy", "adott esetben", stb

· Ajánlott- Ezek jellemzően szavak / kifejezések, mint például; "kell", "ajánlott", "tanácsolta", stb

· Feltétlenül szükséges- Ezek jellemzően szavak / kifejezések, mint például; "must", "van", "a", "van", "kell" stb

Attól függően, hogy milyen típusú kényszer (hierarchia vagy topológia) és a selejtező leírására használt IT, specifikus kényszer (ek) meg kell határozni (lásd alább). A fenti hierarchia példa a "Részlegekkell bontani Csapatok"Egy meg kell határoznia a" Szülő kell Child "kényszer és állítsa be a végrehajtás érvényesíteni kell. A fenti topológia példája"Folyamatok lehet előadja Csapatok"Egy kell csak létrehozni két (2)" Kapcsolat csatolni kell Component "korlátai mindkét végén végzett a kapcsolat típusa szerint. Konkrétan a következő megszorítások ajánlott meg kell határozni (lásd alább) a különböző lehetőségeket;

· Hierarchia korlátok;

o A főnevek lehetbontani Főnevek B, vagy Főnevek B lehetösszesítve A főnevek vagy Főnevek B kelleneösszesítve A főnevek- Adjuk meg a "gyermeknek kell Szülő" kényszer a gyermekkel típusú Noun B, szülő típusú Noun A és végrehajtási figyelmeztetett.

hangjegy

Ez azt jelenti, hogy ha egy gyerek van, akkor a szülő egy bizonyos típusú. Ha nem, akkor kap egy figyelmeztetést.

o A főnevek kellenebontani Főnevek B- Adjuk meg a "Szülő kell Child" kényszer a szülő típusú Noun A, gyermek típusú Noun B és végrehajtási figyelmeztetett.

hangjegy

Ez azt jelenti, hogy ha a szülő van, akkor a gyerekek egy bizonyos típusú. Ha nem, akkor kap egy figyelmeztetést.

o A főnevek kell, hogy legyenbontani Főnevek B- Adjuk meg a "Szülő kell Child" kényszer a szülő típusú Noun A, gyermek típusú Noun B és végrehajtási erőszakos.

hangjegy

Ez azt jelenti, hogy ha a szülő létezik, rendelkeznie kell a gyermekek egy bizonyos típusú. Ha nem, akkor kap egy hiba.

o A főnevek kell, hogy legyenösszesítve Főnevek B- Adjuk meg a "gyermeknek kell Szülő" kényszer a gyermekkel típusú Noun A szülő típusú Noun B és végrehajtási erőszakos.

hangjegy

Ez azt jelenti, hogy ha egy gyerek van, akkor kell egy szülő egy bizonyos típusú. Ha nem, akkor kap egy hiba.

· Topológia korlátokat;

o A főnevek lehet ige Főnevek B- Adjon meg két (2) "Kapcsolat csatolni kell Component" korlátok. Az első az a forrása végén összeköthető igecsatolt Noun kelléket és végrehajtás az erőszakos. A második pedig a mosogató végén összeköthető igecsatolt Noun B-alkatrész és végrehajtás az erőszakos.

hangjegy

Ez azt jelenti, hogy ha a kapcsolat létezik, meg kell csatlakoztatni összetevői bizonyos típusú. Ha nem, akkor kap egy hiba. Összességében ez biztosítja, hogy ezek a komponensek is létezik, és nem csatlakoztatható egymáshoz. Azonban ha csatlakoztatva, kapcsolatokat a megfelelő típusú kell használni.

o A főnevek kellene ige Főnevek B- Adjon meg két (2) "komponens csatolni kell Connection" korlátok. Az első, hogy az Noun Egy alkatrész csatolt Forrás vége igekapcsolat típusát és a végrehajtás beállítva, hogy figyelmeztetett. A második lény Noun B alkatrész csatlakozik a mosogató végén igekapcsolat típusát és a végrehajtás beállítva, hogy figyelmeztetett. Emellett meghatározzák a két (2) "Kapcsolat csatolni kell Component" korlátok. Az első az a forrása végén összeköthető igecsatolt Noun kelléket és végrehajtás az erőszakos. A második pedig a mosogató végén összeköthető igecsatolt Noun B-alkatrész és végrehajtás az erőszakos.

hangjegy

Ez azt jelenti, hogy ha az összetevők vagy a másik fajta létezik, akkor csatolni kell a kapcsolatot egy bizonyos típusú. Ha nem kapsz egy figyelmeztetést. Ezen túlmenően, ez azt jelenti, hogy ha a kapcsolat létezik, akkor kell csatlakoztatni komponenseket a megadott típusú. Ha nem, akkor kap egy hiba. Összességében ez biztosítja, hogy ha komponensek ilyen típus létezik, akkor kap figyelmeztetést, ha azok nem kapcsolódnak egymáshoz.

o A főnevek kell, hogy legyen ige Főnevek B- Adjon meg két (2) "komponens csatolni kell Connection" korlátok. Az első, hogy az Noun Egy alkatrész csatolt Forrás vége igekapcsolat típusát és a végrehajtás állítva erőszakos. A második lény Noun B alkatrész csatlakozik a mosogató végén igekapcsolat típusát és a végrehajtás állítva erőszakos. Emellett meghatározzák a két (2) "Kapcsolat csatolni kell Component" korlátok. Az első az a forrása végén összeköthető igecsatolt Noun kelléket és végrehajtás az erőszakos. A második pedig a mosogató végén összeköthető igecsatolt Noun B-alkatrész és végrehajtás az erőszakos.

hangjegy

Ez azt jelenti, hogy ha a komponensek bármelyik típusú léteznek, azokat úgy kell felerősíteni, hogy a kapcsolat egy bizonyos típusú. Ha nem, akkor kap egy hiba. Ezen túlmenően, ez azt jelenti, hogy ha a kapcsolat létezik, akkor kell csatlakoztatni komponenseket a megadott típusú. Ha nem, akkor kap egy hiba. Összességében ez biztosítja, hogy ha komponensek ilyen típus létezik, akkor kap a hibákat, ha azok nem kapcsolódnak egymáshoz.

Meghatározni egy korlátot

1. Győződjön meg arról, hogy van egy ABACUS fájlnyílt és a Explorer ablak Megjelenik.

2. A felfedező fa bővíteni Típusok | Komponens típusokvagy bővítse Típusok | Csatlakozási típusok.

3. Jobb klikkEgy alkatrész vagy a kapcsolat típusát és válasszuk Add Megszorítás.

Hozzátéve, a megszorítás

Hierarchia meghatározásához kényszer, ahol a szülő kell egy adott gyermek

4. A Add Megszorításablakban jelölje be a Hozzon létre Megszorításjelölőnégyzetet alatt Szülő Must Have Gyermek Megkötés terület.

5. Válassza ki a alkatrészA legördülő menüből, hogy meg akarja határozni a gyermek az alkatrész 3. lépésben kiválasztott.

hangjegy

Ha már van egy engedélyezett "Szülő Must Have Gyermek megszorítás definiálva a szülő alkatrész és egy másik gyerek alkatrész, akkor ez újabb kényszert úgy kezelik, mint egy" és ". Ez a típus legyen a szülő a gyermek típusú ésgyermek, B típusú, bármely végrehajtási szinten (például fogyatékkal figyelmeztetett, vagy végrehajtani - lásd 7. lépés) van megadva minden megszorítás.

6. Opcionálisan megadhatjuk a minimális és maximális számát komponensei alkatrész határozni, hogy legyen gyermekei alkatrész jobb kattintott a 3. lépésben.

7. Adjuk meg, hogy a kényszer, hogy legyen Tiltva, Figyelmeztetett vagy Érvényesíteni.

hangjegy

Fogyatékkal korlátok figyelmen kívül fogja hagyni származó kényszer érvényesítése, figyelmeztetve megszorítások fog egy figyelmeztetés a validációs ablakban ha azokat felismerik és végre megszorításokat fog egy hiba a validációs ablakban ha azokat felismerik. Továbbá minden hibákat meg kell oldani, mielőtt egy Vállalkozás Szerver projekt lehet lekötni.

8. Kattintson oké.

hangjegy

A kényszer jelenik meg az Intézőben fa alá alkatrész jobb kattintott a 3. lépésben a nyíl jelzi az irányt a kényszer és ebben az esetben lefelé kell mutatnia és jobbra. A lakat színes aszerint, hogy a kényszer van tiltva (szürke), figyelmeztetve (sárga), vagy erőszakos (piros).

Szülő kell gyermeke figyelmeztette megszorítás

Hierarchia meghatározásához megszorítás, ha egy gyermeknek kell egy bizonyos fölérendelt

4. A Add Megszorításablakban jelölje be a Hozzon létre Megszorításjelölőnégyzetet alatt Gyermeknek kell Szülő Megkötés terület.

5. Válassza ki a alkatrészA legördülő menüből, hogy meg akarja határozni, mint a szülő a alkatrész jobb kattintott a 3. lépésben.

hangjegy

Ha már van egy engedélyezett "gyermeknek kell anyavállalat korlát meghatározása a gyermek alkatrész és a másik szülő alkatrész, akkor ez újabb kényszert úgy kezelik, mint egy" vagy ". Ez a típus legyen a gyermek szülő típusú vagyszülő B típusú, illetve a végrehajtó szintet (pl figyelmeztetni vagy végrehajtani - lásd a következő lépést) azonosnak kell lennie különben érvényesíteni megszorítások mindig felülírja figyelmeztette is.

6. Adjuk meg, hogy a kényszer, hogy legyen Tiltva, Figyelmeztetett vagy Érvényesíteni.

hangjegy

Fogyatékkal korlátok figyelmen kívül fogja hagyni származó kényszer érvényesítése, figyelmeztetve megszorítások fog egy figyelmeztetés a validációs ablakban ha azokat felismerik és végre megszorításokat fog egy hiba a validációs ablakban ha azokat felismerik. Továbbá minden hibákat meg kell oldani, mielőtt egy Vállalkozás Szerver projekt lehet lekötni.

7. Kattintson oké.

hangjegy

A kényszer jelenik meg az Intézőben nézet szerint alkatrész lépésben kiválasztott 5. A nyíl iránya a korlátozás, és ebben az esetben is pont felfelé és balra. A lakat színes aszerint, hogy a kényszer van tiltva (szürke), figyelmeztetve (sárga), vagy erőszakos (piros).

Gyermeknek kell szülő figyelmeztette megszorítás

Meghatározni a topológia megszorítás, ha egy komponens csatolni kell egy adott kapcsolaton

4. A Add Megszorításablakban jelölje be a Hozzon létre Megszorításjelölőnégyzetet alatt Component csatolni kell Megkötés terület.

5. Válassza ki a összeköthetőA legördülő menüből, hogy meg akarja határozni, mint a mellékelt kapcsolatot az alkatrész jobb kattintott a 3. lépésben (vagy válassza a alkatrészA legördülő menüből, hogy meg akarja határozni, mint a mellékelt komponens, ha a 3. lépésben a jobb kattintott a kapcsolat típusát.)

hangjegy

Ha már van egy engedélyezett "komponens csatolni kell megszorítás definiálva az alkatrész és más típusú kapcsolatot akkor ez az új korlát úgy kezelik, mint egy" és ". Ez az alkatrész csatolni kell kapcsolatot típusú éscsatlakozás B típusú, bármely végrehajtási szinten (például fogyatékkal figyelmeztetett, vagy végrehajtani - lásd 7. lépés) van megadva minden megszorítás.

6. Opcionálisan válassza ki a kapcsolat szerephogy a felvenni kívánt a megszorítással. Smegválasztja a konkrét szerep (azaz forrás vagy nyelő) A legördülő menüből.

7. Adjuk meg, hogy a kényszer, hogy legyen Tiltva, Figyelmeztetett vagy Érvényesíteni.

hangjegy

Fogyatékkal korlátok figyelmen kívül fogja hagyni származó kényszer érvényesítése, figyelmeztetve megszorítások fog egy figyelmeztetés a validációs ablakban ha azokat felismerik és végre megszorításokat fog egy hiba a validációs ablakban ha azokat felismerik. Továbbá minden hibákat meg kell oldani, mielőtt egy Vállalkozás Szerver projekt lehet lekötni.

8. Kattintson oké.

Meghatározni a topológia megszorítás, ha egy kapcsolat csatolni kell egy bizonyos alkatrész

4. A Add Megszorításablakban jelölje be a Hozzon létre Megszorításjelölőnégyzetet alatt Csatlakozás csatolni kell Megkötés terület.

5. Válassza ki a összeköthetőA legördülő menüből, hogy meg akarja határozni, mint a mellékelt kapcsolatot az alkatrész jobb kattintott a 3. lépésben (vagy válassza a alkatrészA legördülő menüből, hogy meg akarja határozni, mint a mellékelt komponens, ha a 3. lépésben a jobb kattintott a kapcsolat típusát.)

hangjegy

Ha már van egy engedélyezett "Connection csatolni kell megszorítás meghatározni a kapcsolat típusát, és a másik alkatrész kapcsolatot használó szerep(azaz vagy Forrás vagy Cél), akkor ez az új korlát úgy kezelik, mint egy "vagy". Ez a kapcsolat típusát kell csatolni alkatrész A vagyalkatrész B, illetve a végrehajtó szintet (pl figyelmeztetni vagy végrehajtani - lásd 7. lépés) azonosnak kell lennie különben érvényesíteni megszorítások mindig felülírja figyelmeztette is. Figyelemreméltó az is, hogy ha több korlátok, amelyek a kapcsolat szerepmegadva, mint "bármely" (szemben a kifejezetten Source vagy Sink), majd mindkét végén a kapcsolatot csatolni kell az egyik komponens megadott típusok korlátai.

6. Opcionálisan válassza ki a kapcsolat szerephogy a felvenni kívánt a megszorítással. Smegválasztja a konkrét szerep (azaz akár Forrás vagy Mosogató) A legördülő menüből.

hangjegy

Vagy egy Source vagy Sink szerepet kell kifejezetten kiválasztottak Attachment oszlop legyen avilable bemutatásra kerülő alkatrész katalógus .

7. Adjuk meg, hogy a kényszer, hogy legyen Tiltva, Figyelmeztetett vagy Érvényesíteni.

hangjegy

Fogyatékkal korlátok figyelmen kívül fogja hagyni származó kényszer érvényesítése, figyelmeztetve megszorítások fog egy figyelmeztetés a validációs ablakban ha azokat felismerik és végre megszorításokat fog egy hiba a validációs ablakban ha azokat felismerik. Továbbá minden hibákat meg kell oldani, mielőtt egy Vállalkozás Szerver projekt lehet lekötni.

8. Kattintson oké.

Valós idő modell ellenőrzése, kényszer érvényesítés

ABacus tartalmaz egyvalós idejű modell ellenőrzése és Érvényesítési funkció azonnal kijelző A hatások egy adott felhasználói működtetés lesz a A figyelmeztetések és hibák a jelenlegi projekt során bármilyen hierarchia és topológia korlátok amely a már megadott. Meg kell jegyezni, hogy az összes hibákat meg kell oldani, mielőtt egy Vállalkozás Szerver projekt lehet lekötni.

A valós idejű megszorítás érvényesítési szolgáltatását vehető észre, hogy benépesítése ábrákkal, vagy közvetlenül az Explorer ablakban. Különösen a következő műveletek végrehajtásakor, útmutatást adnak a színes kiemeli, hogy a hatás a művelet lesz a A figyelmeztetések és hibák a jelenlegi projekt;

1. Amikor húzza elemek ra vagy környékén egy ábrát a színe a szülő (vagy kapcsolódó) komponens (ha van ilyen) határon szerint színezett az alábbi vázlat szerint.

2. Amikor összekötő elemek segítségével a jobb egérgombbal húzza | Csatlakozás az jellemző az elérhető kapcsolatok támogatása színű séma szerint az alábbiak szerint.

3. Amikor összekötő elemek diagramok segítségével a csatlakozó mód a kurzor fog változni színek szerint a rendszer az alábbiak szerint.

4. Ha hozzá alkomponenseket a rendelkezésre álló komponens típusok színű séma szerint az alábbiak szerint.

Általában a következő színek jelölik a hatások a felhasználói működtetés lesz a figyelmeztetések és hibák a jelenlegi projekt;

Fekete : Nincs hatással a figyelmeztetések és hibák.

Zöld : A művelet kifejezetten összhangbanmeghatározott hierarchia és a topológia korlátokat a projekt.

Piros : A művelet kifejezetten megsértveA meghatározott hierarchia és topológia korlátokat a projekt és azt eredményezi, figyelmeztetések és / vagy hibák.

Háttér modell ellenőrzése, kényszer érvényesítés

ABACUS tartalmaz Érvényesítési szolgáltatását, hogy megjelenítse az összes figyelmeztetést és hibák a jelenlegi projekt miatt semmilyen korlátozás amely a már megadott. Meg kell jegyezni, hogy az összes hibákat meg kell oldani, mielőtt egy Vállalkozás Szerver projekt lehet lekötni.

hangjegy

Validation manuálisan kell futtatni a 'érvényesítése / Check Project Megszorítások "gombot a Fő eszköztár . Az érvényesítés ablak alapértelmezésben rejtettde meg fognak jelenni, ha az eszköztár gombra kattintva. Lásd Egyéni interfész hogyan kell megzavar, és potenciálisan hagyja állandóan látható. Is, akkor kattintson duplán bármelyik sorában a validációs ablak "ugrani" a megfelelő elemet a projektben.

Érvényesítési ablak

Az alapértelmezett oszlopok a validációs ablak a következőképpen írja le;

Figyelmeztetés vagy hiba: Ebben az oszlopban egy ikont, hogy a jogsértés egy figyelmeztetés (sárga háromszög felkiáltójellel) vagy Error (piros kör egy kereszt).

Szám: Ebben az oszlopban a jogsértés száma.

hangjegy

Csak 200 megsértése jelennek meg egy időben, és ha több mint 200 megsértése projekt az Első, Előző, Következő és End sorban navigátorok felső-ablak jobb lehet böngészni a további jogsértések.

Leírás: Ez egy teljes leírást a megsértése, beleértve a gazdálkodó és kényszer érintett.

Entity: Ebben az oszlopban az Entity foglalkoztatják a megsértése.

típus: Ebben az oszlopban az elemtípusra az Entity.

Építészet: Ebben az oszlopban az építészet, amelyen belül a jogsértés helyére.

Észlelt: Ez az oszlop mutatja az időt, hogy a jogsértés nem volt kimutatható.

Tipp

Érdemes csökkenő sorrend a észlelve oszlop (amint az a dialógus fent) a legutóbbi jogsértések jelenik meg a "top" a lista.

Számos felhasználó lehetőség változtatni a viselkedését a háttérben modellérvényesítés. Például To változtatni a színeket használt megszorítás megsértése valami más, mint az alapértelmezett PirosKattintson az Eszközök | Beállítások ... akkor megy a Érvényesítésfülre, állítsa be a színeket keresztül Visszajáró pénz gombok.

Érvényesítés opciók

Ha kézzel érvényesítéséhez megszorítások

1. Jobb klikka Architektúrákcsomópont, minden építészeti vagy bárhol akár a Alkatrészek vagy Kapcsolatokrésze a felfedező nézetet, és válasszuk Ellenőrizze Megszorítások.

Érvényesítse megszorítások

2. Kattintson a Részletekgombot a Figyelmeztetésekablakot, hogy ahol az építészet sérti semmilyen korlátozás amely a már megadott.

hangjegy

Megsértése csak akkor jelennek meg azok számára, korlátok, hogy vannak, hogy figyelmeztetni vagy végrehajtani. Továbbá a szövege a figyelmeztető tartalmazni fog "kell", ha a korlát csak egy figyelmeztetést, vagy "kell", ha azt végrehajtani.

3. Kattintson oké.

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel


Törlése alkatrész vagy kapcsolat

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Törlése alkatrész vagy kapcsolat

Küldje el észrevételeit ebben a témában.

Törölni egy alkatrész vagy kapcsolat

1. Jobb klikkAz összetevőtől vagy kapcsolatot.

2. Válassza ki Töröl.

Vigyázat

ABACUS figyelmezteti Önt melyik nézőpont hatással lesz a törlés és kérjük, hogy erősítse meg a törlést. Ez azért van, mert elemeknek létezik számos diagramok és megéri ellenőrizni, amit a javasolt törlést hatással lesz.

Tipp

Ha töröl egy komponense, annak minden alkomponenseket is törlésre kerül. Választhat, hogy törölje a belső és külső kapcsolatok az alkatrészt. Ha úgy dönt, hogy nem törli őket, a csatlakozások ez csatolt hogy marad, de akkor már nem kell csatolni. Minden alkatrész és a csatlakozókhoz egy adott típus . Törlése a komponens / kapcsolatnak nincs hatással a típus (a típusok ágon szintén). Hasonlóképpen, ha az alkatrész / csatlakozás van Standard rendelt, törlés nem lesz hatással a mester a szabványok ága.

Lásd még

Benépesítő az architektúrának - Áttekintés


Diagram Nézőpontok

Navigáció: Népszerű az architektúrának használata> Rajzok>

Diagram Nézőpontok

Küldje el észrevételeit ebben a témában.

The szempontokfunkció biztosítja, hogy az alkatrészek és a kapcsolók a hozzá diagramot kell egy ilyen jellegű egyesületek korábban megadott előtt hozzá lehet adni egy rajzot. Ez a funkció lehetővé teszi, hogy a korlátozás a típusú diagramok lehet levonni korlátozásával a formák és csatlakozók, amelyek kapcsolatban vannak Alkatrészek és Kapcsolatokbelül létező Ön építészet.

Engedélyezése vagy tiltása érvényesítése rajz nézőpontok

Az a képesség, hogy érvényre rajz nézőpontok automatikusan alapértelmezés szerint engedélyezett. Letiltani / engedélyezni ezt a funkciót kattintson az Eszközök | Beállítások ...| a Diagramfülre, és törölje / válassza ki a Végre kell hajtani a Diagram Nézőpontokjelölőnégyzetet kell.

hangjegy

Ha nem látja a "Végre kell hajtani a Diagram Nézőpontok"Opciót a Diagram lapon, akkor nem kell a tervező add-on, és az opció alapértelmezés szerint.

Létrehozása végrehajtható rajz nézőpont

1. Győződjön meg arról, hogy van egy ABACUS fájl nyitott a felfedezőnézet jelenik meg.

2. A Tallózó nézet jobb klikk Kilátáspontsés kattintson Teremt Diagram Nézőpont

3. A Diagram Nézőpontablak jelenik meg.

4. Rendeljen egy adott nevet a rajz szempontjábólés vegye figyelembe, hogy a nézőpont menti alatt Nézőpontokrészben a felfedező.

5. A Diagram Nézőpontablak jelenik meg.

6. Most kattintson és húzza a megfelelő alkatrész-típusok és csatlakozó típusok a architektúrák rá a nézőpont formák akarsz. Komponens típusokkell húzni rá egy alaka alakzatoklapon, míg a csatlakozási típusokkell húzni rá egy az 5 vonal stílusát formáka csatlakozókfület.

7. Hogy mentse a rajz szempontjábóllétrehozta kattintson a [image] A jobb felső sarokban a Diagram Nézőpont ablak.

hangjegy

A rajz szempontjábóllehet szerkesztette jobb gombbal a nézőpont és kiválasztja Nyisd ki vagy duplán kattintva a nézőpont.

Synchonising frissített szempontból diagramok

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Vagy kattintson jobb gombbal a szempontból az Felfedező ablak alatt Meta-modell | Nézőpontokés válassza Sync Diagram Mappings ...

- vagy -

3. Közeli A nyílt és frissített szempontból ablakban, és válassza Igena Szinkronizálása a Nézőpontpárbeszédablak jelenik meg.

4. A Nézőpont Szinkronizáláspárbeszédablak jelenik meg az alábbiak szerint.

Jelölőnégyzetei

· Add Hiányzó Mappings- Minden új formája (típusjóváhagyás), illetve csatlakozó (a kapcsolat típusa) szövetségeket, hogy adtak hozzá A nézőponthozzáadásra kerül a megfelelő rajzs (azaz a stencils) hogy kapcsolódnak a szempontból.

· Frissíti a meglévőMappings- A frissített szempontból a jelenlegi formája (az alkatrész) vagy csatlakozó (a kapcsolat típusát) egyesületek számára szemszögéből(pl szín, betűtípus stílus) frissítésre kerül a megfelelő rajzs (azaz a stencils) hogy kapcsolódnak a szempontból.

· Távolítsuk ExtraMappings- Bármilyen további alakja (típusjóváhagyás), illetve csatlakozó (a kapcsolat típusa) szövetségeket, hogy adtak hozzá hoz diagramok (azaz a stencil), de nem a nézőponteltávolításra kerül a megfelelő rajzs (azaz a stencils) hogy kapcsolódnak a szempontból.

· Felülírása Local Settings növelt vagy Frissítve Mappings (Különbségek Only)- A frissített szempontból a jelenlegi formája (az alkatrész) vagy csatlakozó (a kapcsolat típusát) egyesületek számára szemszögéből(pl szín, betűtípus stílus) kell alkalmazni, hogy a megfelelő elemeket a rajzok, amelyek kapcsolódnak a szempontból.Csak a frissített "különbségek" tette a szempontból alkalmaznak, így a meglévő helyi beállításokat az ábrát, amely nem frissítette a szempontból változatlan marad.

· [image] Magyarázatok – Mint fent, de kifejezetten a kommentárokat.

Lásd még

A rajz eszköz | Benépesítő az architektúrának | Elemző Ön építészet


Rajzeszköz jellemzők

Navigáció: Népszerű az architektúrának használata> Rajzok>

Rajzeszköz jellemzők

Küldje el észrevételeit ebben a témában.

A rajz eszköz segítségével számos rajz jellemzői.

Nagyítás

A skála a diagram segítségével lehet módosítani a zoom funkció.

Ha csökkenteni szeretné a skála vagy a "nagyítás"

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Sajtó Ctrlés a "=" gombot.

- vagy -

2. Válassza ki a Közelíts rágombot a Diagrameszköztár.

- vagy -

2. Sajtó Ctrland roll a egér kerék előre. Megjegyzés: Ebben a módban a vásznon nagyítani fogja felé, ahol az egér lebeg a vásznon.

Hogy növelje a skála vagy a "kicsinyítés"

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Sajtó Ctrlés a "-" gombot.

- vagy -

2. Válassza ki a Kicsinyítésgombot a Diagrameszköztár.

- vagy -

2. Sajtó Ctrland roll a egér kerék hátrafelé. Megjegyzés: Ebben a módban a vásznon nagyítani fogja kifelé, ahol az egér lebeg a vásznon.

Auto-elrendezés

Az elrendezés a komponenseket a diagram lehet módosítani automatikusan.

Elrendezési minden alkatrészek on diagram

1. Cnyalás a Layout Diagramgombot a Diagram eszköztár.

2. Válassza ki bármelyik Radial Layout vagy Rácsos elrendezés.

hangjegy

A Radial elrendezést használja majd az úgynevezett "erő által irányított" algoritmus, hogy a csatlakoztatott komponensek össze vannak húzva, miközben független komponensek kénytelenek egymástól. A Grid layout használja majd a rögzített szélességű és magasságú térköz algoritmus. Ez egyrészt lehetővé teszi, hogy a felhasználó választhat a teljes diagram Képarány (pl 16: 9, A4 (portré), Letter (fekvő)), majd a távolság az oldalán és a sorok és oszlopok az alábbiakban bemutatott.A Grid layout semmilyen elemei közötti kapcsolatok nem befolyásolják az elrendezés, mert egyszerűen csak intézkedik a komponensek betűrendben (név szerint) a bal felső a jobb alsó a vásznon. Mindkét algoritmus szabadkézi alakzatok nem mozdul el.

Elrendezési gyermekek alkatrészek Egy egyedülálló szülő on diagram

1. Jobb klikkmagas szintű alkatrész, akiknek a gyermekei szeretné automatikus elrendezési.

2. Válassza ki Layout Gyermekek.

hangjegy

Alapértelmezésben csak az Radial elrendezés algoritmust használnak.

Változó elem Esztétika mint Szín, Átláthatóság, Shadows és elforgatás

Minden rajz elemek esztétika, amely lehet manipulálni, mint kívánatos. Abban az esetben, kapcsolódó formák, ezeket a szempontokat lehet állítani fajtánkéntés a legtöbb esetben szintén példányonként. Abban az esetben, szabadkézi formák, ezeket a tulajdonságokat be lehet állítani példányonkénta vásznon.

hangjegy

Bármilyen példányonként szempontokat, amelyek tűztek kapcsolódó formák lesznek "írja felül", ha ugyanazt a szempontot változott a megfelelő típus.

Ahhoz, hogy változtatni a színét a társult alakú vagy szabálytalan alakú, formájú

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy szabálytalan alakú formát a vásznon.

3. Válassza ki Változás Szín.

4. Válassza ki a Fix Színrádió gomb (ha van ilyen).

5. Válasszon egy Basic Szín, illetve jelölje meg az Egyéni szín a párbeszédablakban, és kattintson oké.

- vagy -

4. Válassza ki a Gradiensrádió gomb (ha van ilyen).

5. Válasszon akár vízszintes, függőleges Előre diagonális vagy hátra Átlós a színátmenet irányát a legördülő és kattintson oké.

6. Válasszon egy Basic Szín, illetve jelölje meg az Egyéni szín lehetőséget a párbeszédablak Indul és Végés kattintson oké.

hangjegy

ABACUS fogják színesíteni az előtérben egy formája, ha;
a) ez egy "egyszerű" alakú, egy mögöttes grafikai elem (pl kör, négyszög, sokszög stb), vagy
b) ez egy "összetett" alakú, több mögöttes subshapes, hogy az összes azonos színű / lejtőn egymással, illetve a subshapes van LockScale = true.
Ha a fenti feltételek nem teljesülnek, akkor a háttérben a formát színű.

Színének beállításához társult alakja szerint egy ingatlan

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatoklapján a sablon ablakban(NEM a rajzon vászon).

3. Válassza ki Változás Szín.

4. Válassza ki a Segítségével Ingatlan Rádiógomb.

5. Válasszon egy ingatlan kattintson a "..." gomb jobbra az ábrán.

6. Válassza ki a Hatótávolság Rádiógomb.

7. Állítsa be a Min és Maxértékek a kívánt módon. Megjegyzés: bármilyen érték minimális érték alá jelenik meg, mint a Min szín és bármilyen érték a maximum felett lesz látható, mint a Max színét. Így, amikor a logikai, lista vagy dátum / idő tulajdonságok értékeit alakítja az index az alábbiak szerint; Logikai (False = 0, True = 1), List (egész szám vale 1-től n minden érvényes értéküknél növekvő sorrendben meghatározott egységek terén) és a dátum / idő (napok száma, mivel január 1, 1900 - beleértve tizedesjegyek óra, perc, másodperc részek - és ha a dátum 1990 előtti ez egy negatív szám).

8. Válasszon egy Basic Szín, illetve jelölje meg az Egyéni szín lehetőséget a párbeszédablak Min és Maxés kattintson oké.

Tipp

Ha Zöld (RGB - 128,255,0) választanánk Min szín és Piros (RGB - 255,0,0) választanánk Max szín egy telken értékhatára 1 hogy 4majd egy értéke 1jelennek meg Zöld, Értéke 2 mint Sárga, 3 mint narancs és 4 mint Piros.

Alternatívaként, egy ingatlan választéka 1 hogy 3értéke 1lesz, mint Zöld, Értéke 2 mint Borostyán és 3 mint Pirosaka "közlekedési lámpa" vagy RAG állapotát.

Ahhoz, hogy egy tulajdonság tartományban 1-5, ha Kék (RGB - 0,0,255) választanánk Min szín és Piros (RGB - 255,0,0) választanánk Max szín értéke 1 lesz, mint Kék, Értéke 2, mint Aqua, Értéke 3, mint Zöld, Értéke 4, mint Sárga és egy értéket 5-ös Piros.

Ahhoz, hogy egy tulajdonság tartományban 1-6, ha Ibolya (RGB - 255,0,255) választanánk Min szín és Piros (RGB - 255,0,0) választanánk Max szín értéke 1 lesz, mint Ibolya, Értéke 2, mint Kék, Értéke 3, mint Aqua, Értéke 4, mint Zöld, Értéke 5, mint Sárga és értéke 6, mint Piros.

És végül, egy tulajdonság tartományban 1-7 értéke 1 lesz, mint Ibolya, Értéke 2, mint Sötétkék, Értéke 3, mint Világoskék, Értéke 4, mint Kék zöld, Értéke 5, mint Zöld, Értéke 6, mint Borostyán és értéke 7, mint Piros

hangjegy

Lásd a fenti megjegyzést előtér versus háttér színezés.

- vagy -

7. Válassza ki a Fajlagos értéke Rádiógomb.

8. Kattintson a Szerkesztés Színek gomb.

9. Válassza ki egymás után az értékeket, majd kattintson Színállítani egy adott színt minden értéket.

hangjegy

Az értékek az elemek jelen a rajz lesz előre lakott.

10. Ahhoz, hogy hozzá semmilyen hozzáadott értéket színek azoknak előre kitöltött (például miután a vagyon körét már átalakították) klikk Hozzáadott érték.

Változtatni a színét átláthatóságát társult alakú vagy szabálytalan alakú, formájú

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy szabálytalan alakú formát a vásznon.

3. Válassza ki Változás Szín.

4. A Transparency panel adja meg a felső csúszkát a kívánt átláthatóságot az alapszín.

5. Ha a színátmenet vagy a property lehetőségek is felhasználásra kerül, a Transparency panel beállítani az alsó csúszkát a kívánt átláthatóság a második szín.

6. Kattintson oké.

Megmutatni árnyékokmert minden társult alakzat rajz

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészeklapján a sablon ablakon.

3. Válassza ki Add Árnyak.

Hogy mutatnak árnyék Egy alkatrész formájában vagy szabadkézi alakzat

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Jobbra-ClickAz összetevőtől vagy szabadkézi alakja a vásznon.

3. Válassza ki Add Árnyak.

Forgatni alkatrész formák és szabad formában formák rajzok

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Válassza ki az alkatrészt alakú vagy szabálytalan alakú formát a vásznon szeretné forgatni.

3. Jobb klikkA forma és válasszuk Forogmajd válassza ki a megfelelő szögben szeretné forgatni a forma által.

Megváltoztatása Element Feljegyzések és Freeform szöveg címkék

Minden rajz elemek megjegyzések amely lehet manipulálni, mint kívánatos. Abban az esetben, kapcsolódó formák, ezeket a szempontokat lehet állítani fajtánkéntés a legtöbb esetben szintén példányonként. Abban az esetben, szabadkézi alakzatokés csatlakozók, aszövegcímkék be lehet állítani példányonkénta vásznon.Nyolc (8) különböző kommentárokat látható lehet rajz elemek (azaz név, típus, ingatlan értékét, ingatlan Marker, rögzített alkatrészeket, Gyermek (az alkatrészek esetében), szabványok és Időbélyegzők (Alkotó módosított, stb)) a huszonöt Öt (25) különböző pozíciókban (pl Központ - Külső Top, belső bal - Központ, Külső Jobb - külső felületén).

hangjegy

Bármilyen példányonként szempontokat, amelyek tűztek kapcsolódó formák lesznek "írja felül", ha ugyanazt a szempontot változott a megfelelő típus.Továbbá, amennyiben 2 vagy több kommentárokat foglalják el ugyanabban a helyzetben csak egy betűtípus, stílus, betűtípus szín és méret lehet használni, és a szeparátor (pl vessző, szóköz, új sor) ki kell választani.

Megmutatni A nevét vagy típusát A társult alkatrész vagy kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy csatlakozó a vásznon.

3. Válassza ki Magyarázatok.

hangjegy

Az egyéni összefüggő alakú vagy csatlakozó a vásznon, akkor ki kell választania a Felülbírálása stencil Magyarázatokjelölőnégyzetet az első alkalommal.

4. Válassza az Új Jegyzet az eszköztáron, és válassza Név vagy típus.

5. A megjelenő párbeszédablakban válassza ki a kijelző opciókat kívánt beleértve konzolok és a betűtípus, stílus, betűtípus szín és méret. Továbbá, adja meg az elrendezéssel opciókat kívánt beleértve a vízszintes és függőleges helyzettől (azaz feliratozást pozíció) és a szög (azaz forgatás). Válassza ki oké.

Mutatni egy ingatlan érték A társult alkatrész vagy kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy csatlakozó a vásznon.

3. Válassza ki Magyarázatok.

hangjegy

Az egyéni összefüggő alakú vagy csatlakozó a vásznon, akkor ki kell választania a Felülbírálása stencil Magyarázatokjelölőnégyzetet az első alkalommal.

4. Válassza az Új Jegyzet az eszköztáron, és válassza Ingatlan értékét.

5. A megjelenő párbeszédablakban válassza ki az ingatlant, kattintson a Tulajdonságok: "..." gombra, és válassza a tulajdonság a Select a Tulajdonságok párbeszédablakés válassza oké. Válassza ki a Display lehetőséget, hogy kívánatosak, beleértve konzolok és a betűtípus, stílus, betűtípus szín és méret. Továbbá, adja meg az elrendezéssel opciókat kívánt beleértve a vízszintes és függőleges helyzettől (azaz feliratozást pozíció) és a szög (azaz forgatás). Válassza ki oké.

Mutatni egy ingatlan jelző A társult alkatrész vagy kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy csatlakozó a vásznon.

3. Válassza ki Magyarázatok.

hangjegy

Az egyéni összefüggő alakú vagy csatlakozó a vásznon, akkor ki kell választania a Felülbírálása stencil Magyarázatokjelölőnégyzetet az első alkalommal.

4. Válassza az Új Jegyzet az eszköztáron, és válassza Az ingatlan Marker.

5. A megjelenő párbeszédablakban válassza ki az ingatlant, kattintson a Tulajdonságok: "..." gombra, és válassza a tulajdonság a Select a Tulajdonságok párbeszédablakés válassza oké. A sugár a marker képpont, és a színező módszerrel akár színes paletta vagy Colour megfelelő szállást és állítsa be a színeket feladatokat. Továbbá, adja meg az elrendezéssel opciókat kívánt beleértve a vízszintes és függőleges helyzettől (azaz feliratozást pozíció) és a szög (azaz forgatás). Válassza ki oké.

Megmutatni mellékelt komponensek A társult alkatrész vagy kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy csatlakozó a vásznon.

3. Válassza ki Magyarázatok.

hangjegy

Az egyéni összefüggő alakú vagy csatlakozó a vásznon, akkor ki kell választania a Felülbírálása stencil Magyarázatokjelölőnégyzetet az első alkalommal.

4. Válassza az Új Jegyzet az eszköztáron, és válassza Csatolt Components.

5. A megjelenő párbeszédablakban a kapcsolódó alkatrészek válassza ki a mellékelt alkatrész kattintson a Csatolt: "..." gombra, és válasszon egy alkatrész a Set összetevő típusa ablakbanés válassza oké. Válassza ki a mellékelt kapcsolat típusát kattintva keresztül csatlakozik: "..." gombra, és válassza ki a kapcsolat típusát a Set csatlakozás típusa párbeszédablakés válassza oké.Mert kapcsolódó kapcsolatokat szeretnénk a kapcsolatot végén kiválasztja Source vagy Sink a kapcsolat vége: legördülő menüben. Mindkét kapcsolódó alkatrészek és csatlakozások válassza ki a kijelző opciókat kívánt beleértve konzolok és a betűtípus, stílus, betűtípus szín és méret. Továbbá, adja meg az elrendezéssel opciókat kívánt beleértve a vízszintes és függőleges helyzettől (azaz feliratozást pozíció) és a szög (azaz forgatás). Válassza ki oké.

Megmutatni a gyerekek Egy kapcsolódó elem

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészekfülön a stencil ablak vagy társult alakja a vásznon.

3. Válassza ki Magyarázatok.

hangjegy

Az egyéni összefüggő alakja a vásznon, akkor ki kell választania a Felülbírálása stencil Magyarázatokjelölőnégyzetet az első alkalommal.

4. Válassza az Új Jegyzet az eszköztáron, és válassza Gyermekek.

5. A megjelenő párbeszédablakban válassza ki a kijelző opciókat kívánt beleértve konzolok és a betűtípus, stílus, betűtípus szín és méret. Továbbá, adja meg az elrendezéssel opciókat kívánt beleértve a vízszintes és függőleges helyzettől (azaz feliratozást pozíció) és a szög (azaz forgatás). Válassza ki oké.

Megmutatni A szabványok A társult alkatrész vagy kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy csatlakozó a vásznon.

3. Válassza ki Magyarázatok.

hangjegy

Az egyéni összefüggő alakú vagy csatlakozó a vásznon, akkor ki kell választania a Felülbírálása stencil Magyarázatokjelölőnégyzetet az első alkalommal.

4. Válassza az Új Jegyzet az eszköztáron, és válassza Szabványok.

5. A megjelenő párbeszédablakban válassza ki a kijelző opciókat kívánt beleértve konzolok és a betűtípus, stílus, betűtípus szín és méret. Továbbá, adja meg az elrendezéssel opciókat kívánt beleértve a vízszintes és függőleges helyzettől (azaz feliratozást pozíció) és a szög (azaz forgatás). Válassza ki oké.

Megmutatni időbélyegzőknek A társult alkatrész vagy kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Jobb klikkA társult alakú vagy csatlakozó a Alkatrészek vagy Kapcsolatokfülön a stencil ablak vagy egy társult alakú vagy csatlakozó a vásznon.

3. Válassza ki Magyarázatok.

hangjegy

Az egyéni összefüggő alakú vagy csatlakozó a vásznon, akkor ki kell választania a Felülbírálása stencil Magyarázatokjelölőnégyzetet az első alkalommal.

4. Válassza az Új Jegyzet az eszköztáron, és válassza Alkotó által létrehozott, teremtett Marker, Modified Modified By vagy módosított Marker.

5. A megjelenő párbeszédablakban, ha nem egy marker, válassza ki a kijelző opciókat kívánt beleértve konzolok és a betűtípus, stílus, betűtípus szín és méret. Ha a marker, meg a sugara a marker képpont, és a színező módszerrel akár színes paletta vagy Colour By Ingatlan és állítsa be a színeket feladatokat. Továbbá, adja meg az elrendezéssel opciókat kívánt beleértve a vízszintes és függőleges helyzettől (azaz feliratozást pozíció) és a szög (azaz forgatás). Válassza ki oké.

Változtatni a betűtípust a szabadkézi alakzatvagy csatlakozó

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Jobb klikka szabadkézi alakzat vagy csatlakozó a vásznon. Megjegyzés: Ha a csatlakozó szöveges címke nem mutatják majd, hogy bemutassák a connectvagy szöveges címkét: Jobb klikka connectvagyés válassza Feliratozáslépték | Mutass Jegyzet.

3. Válassza ki Változás betűtípus.

4. Válassza ki a betűtípust, a stílus és a méret a párbeszédablakban, és válassza oké.

A betűtípus módosítása szín A szabálytalan alakú, formájúvagy csatlakozó

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Jobb klikka szabadkézi alakzat vagy csatlakozó a vásznon. Megjegyzés: Ha a csatlakozó szöveges címke nem mutatják majd, hogy bemutassák a connectvagy szöveges címkét: Jobb klikka connectvagyés válassza Feliratozáslépték | Mutass Jegyzet.

3. Válassza ki Visszajáró pénz Font Szín.

4. Válasszon egy betűtípusSzín (és a formák a link színe), kattintson a "..." gombra, és adja meg a színét a párbeszéd és válasszuk oké.

5. Válassza ki a Transparency a szöveg címke beállításával a csúszkát a 0 teljes mértékben átlátható és 255 teljes mértékben átláthatatlan.

Forgatni a szöveges címkét a szabadkézi alakzatvagy csatlakozó

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Jobb klikka szabadkézi alakzat vagy csatlakozó a vásznon. Megjegyzés: Ha a csatlakozó szöveges címke nem mutatják majd, hogy bemutassák a connectvagy szöveges címkét: Jobb klikka connectvagyés válassza Feliratozáslépték | Mutass Jegyzet.

3. Válassza ki Forogmajd válassza ki a megfelelő szögben szeretné forgatni a szöveges címkét által.

Lásd még

A rajz eszköz | Benépesítő az architektúrának | Elemző Ön építészet


Szimuláló teljes birtoklási költség (TCO)

Navigáció: szimulálása az architektúrának> Szimulátorok>

Szimuláló teljes birtoklási költség (TCO)

Küldje el észrevételeit ebben a témában.

Háttér

Teljes birtoklási költség (TCO) pénzügyi becslés, amelynek célja, hogy az intézkedés a teljes felmerült életciklus-költségek (a beszerzéstől a leszerelési / ártalmatlanítás) kapcsolatos tulajdonban lévő eszközök. TCO nem csak tükrözi a beszerzési költségek, ez magában foglalja az összes egyéb szempontok a további használatát és karbantartását az eszköz.

TCO meghatározására használják az erőfeszítés és a költségvetés szükséges költségeket költeni a rendszer. Egy egyszerű módja a modellezés ABACUS TCO hogy megtörjük az informatikai rendszer elemekre. Tudjuk majd megtudja, mennyit átlagban kerül fut ezen összetevők valamelyike. Miután ez sikerült, akkor faktor a különböző költségeket attól függően, hogy az informatikai rendszer evolvable vagy nyitott stb Ha egy rendszer már működő, a fő tényező, hogy fontolja meg az a költség, karbantartási és talán a költség leszerelésére.

Egy példa

Rajza példa számítása

Az összetevő mellett Szervezet és a szabványos rendelkezik ezekkel a tulajdonságokkal:

· FTE= 100 000 $ / év

· Támogatás Effort= 0,01 FTE + 0.001 FTE / év = 1000 $ + 100 $ / év

· Fenntartási költség= 100 $ - 10 $ / év

· Tőkeköltség= 2000 $

· Telepítse Effort= 2 FTE / nap = 0.01 FTE / év = 1000 $

A komponens keretében Szervezet ezeket a tulajdonságokat:

· Telepítse Horizon= -2 Év (azaz a rendszer telepítése előtt 2 évvel a jelen)

· Élettartam= 3 év

Amikor Telepítse Horizon + Élettartam <= 0 , Nincs több karbantartási költség.

Számítások

A számítások a következők:

hangjegy

TC = a költség évente. SE = Támogatás igyekezet. MC = karbantartási költségek.

· Kezdeti költség = tőkeköltség + Install Effort= 2000 + 1000 = 3000 $

· A t = -2 (közben 1. év), TC = Kezdeti költség + SE + MC= 3000 + 1000 + 100 = 4100 $

· A t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1190 $

· A t = 0, a TC = (1000 + 200) + (100 - 20) = 1280 $

· T = 1 (utolsó év), TC = (1000 + 300) + (100-30) = 1370 $

Graph példa számítása

TCO összege minden jelenlegi és jövőbeli költségeket, amíg a rendszer már hatástalanított.

· A t = -2 (közben 1. év), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· T = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· A t = 0, TCO = 1280 + 1370 = 2650 $

· T = 1 (utolsó év), TCO = 1370 $

Key költségtényezők

A legfontosabb költségtényezők az kiszámításához figyelembe vett TCO, az eszköz ABACUS a következők:

· Hardverek beszerzése- Kezdeti költségek a berendezések (tőkeköltség).

· Szoftverek beszerzése- Kezdeti költségek a licenc szoftver (tőkeköltség).

· Telepítés- Kapcsolatos költségek a kezdeti beállításokat.

· Edzés- Költség kapcsolódó külső szállító képzés kezdeti beállítás után.

· Támogatás- Költség kapcsolódó belső támogatás.

· Karbantartás- A költségek cserélni vagy bővíteni forgalmazó karbantartási szerződések, a beszerzések és a katasztrófa utáni helyreállítás költségeit.

· Infrastruktúra- Együtt járó költségek támogatása eszköz.

ABACUS példa képviselete Key költségtényezők

Futás a költség-szimulátor

Szimulálni az architektúrának a költségek szempontjából

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Válassza ki Elemzés| Költség.

3. Válaszd a Építészet (ek)szeretné felvenni az értékelést.

hangjegy

Alapértelmezésben ABACUS automatikusan kiválasztja az architektúra (ek), melyek ismételt szimuláció miatt szükséges bármely alapul szolgáló ingatlan vagy strukturális változások.Ez a kiemelés látható Piros a Szimuláció eszköztár .

4. Válassza ki a ValutaA legördülő menüből.

5. Mozgassa a Év kiszámításáhozcsúszkát évek számát szükséges.

hangjegy

Alapértelmezésben, ha a következő években számítani több mint 1 éve a költségeket automatikusan kalkulálja minden egyes évben (és a gyűjtemény a hozzáadott tulajdonságok / frissítve), majd a kumulált értéke az egész években is számítani. Ha csak a kumulált értéke van szükség, akkor szüntesse meg a Számolja Per-év Költségekopció az alábbiakban leírt menteni a tulajdonságok száma a projektben.

6. Válassza ki, hogy elhagyják Számolja Per-év Költségekellenőrizni, vagy törölje azt.

7. Kattintson Következő.

8. Opcionálisan válassza ki Kapcsolatokkíván tulajdonítani költségek mellett részeként az értékelést.

hangjegy

Egy Költség | Tulajdonításingatlan a kapcsolatot költségek lehet tulajdonított a komponens csatolt a mosogató végén a kapcsolat a komponens csatolt a forrás vége(azaz Költség | Nevezd = "Sink a forrás"), vagy a komponens csatolt forrás végén a kapcsolat a komponens csatolt mosogató vég(azaz Költség | Nevezd = "Source Sink"). Továbbá, ABACUS automatikusan kiválasztja azokat a kapcsolatokat a viselkedése | Relationship = "folyamatok" vagy "támogatások"és az irányt a jóváírás lesz "elsüllyed forrás". Továbbá, a költségek felosztani bármelyike ​​szerinti Behaviour | % Vagy költség | % Ingatlanokat a kapcsolatot, vagy pedig ahol több kapcsolatok egy mosogató számos forrásravagy a forrással, számos mosogató, Bármelyike ​​szerinti Behaviour | Feldolgozási tulajdonságok a forrás alkatrészekvagy mosogató alkatrészek, illetve.

9. Kattintson befejezésés akkor kap egy Figyelmeztetés párbeszéd.

10. Adott esetben vizsgálja meg a figyelmeztetéseket kattintva Részletek >>.

11. Kattintson Folytatás.

hangjegy

Ezen a ponton ABACUS végez, tevékenység alapú költségszámítás értékelése architektúra (ek) és rövid idő múlva (a folyamatjelzőm visszajelzést) számítással teljes párbeszédablak jelenik meg.

12. Kattintson okéelismerni az értékelést.

Tipp

A képzések és a további segítséget Költség szimuláció kérjük, olvassa el a Avolution közösségi .

Összetevő és / vagy a Kapcsolat Tulajdonságok

Az alábbi táblázat az alkatrész és / vagy a kapcsolat ingatlan kell értékelnie az ár.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan beviteli sorban választó ikon ( [image] ) A tooltip "Költség Input". A változás, hogy minden ilyen "input" tulajdonságok és a különböző strukturális változások az adattárba fogja eredményezni a költség-szimulátor igénylő újra szimulációs megjelölt Piros a Szimuláció eszköztár .

típus

Név

Alapértelmezett érték

Egység

Adattípus

Kívánt

Leírás

Költség

Telepítse Horizon

0

év

Egész szám

Igaz

Megadja az összetevő vagy a kapcsolat volt, vagy lesz telepítve.

· A 0 érték (alapértelmezett) azt jelzi, hogy az alkatrész vagy a kapcsolat folyamatban van telepítve a tárgyévben.

· A kisebb érték a 0 azt jelenti, hogy az alkatrész vagy a kapcsolat lett telepítve a múltban.

· Egy érték nagyobb, mint 0 azt jelzi, hogy az összetevő vagy a kapcsolat telepítésre kerül a jövőben.

Költség

Élettartam

0

év

Egész szám

Igaz

Meghatározza az időtartamot, amelyben a komponens vagy a kapcsolat marad üzemben, ami után leszerelték.

Költség

FTE

100.000,00

$ / év

Decimális

Hamis

Az éves költségek minden egyes Teljes munkaidős Alkalmazott.

Ha ez a tulajdonság nem található a komponensmaga, vagy abban az esetben, csatlakozások a komponens csatolt a mosogató végén a kapcsolat, Akkor lehet keresni más alkatrészeket.

Először, minden "nyelő" összetevős végén a a összefüggésben olyan "támogatja" kapcsolat a komponens között lehet keresni, majd hogy "nyelő" komponens szülős.

Ha a FTE ingatlan nem található, az összetevő szülő-alkatrészek majd keresni. Ha FTE még mindig nem találtak, az alapértelmezett érték kerül felhasználásra.

Figyelem: FTE csak érvényes bemeneti ingatlan alkatrészeket.

Költség

Karbantartási költség (fix)

0.00

$ / év

Decimális

Hamis

Az éves költséggel és alkatrészvagy a kapcsolat.

Költség

Karbantartási költség (változó)

0.00

$ / év

Decimális

Hamis

Az összeg, amellyel a teljes fenntartási költségeit az alkatrész vagy a kapcsolat minden évben változni fognak.

Például egy értéke $ -500 jelzi, hogy a teljes karbantartási költségek csökken 500 $ minden évben, míg az érték 500 $ azt jelzi, hogy a teljes karbantartási költségek növekszik 500 $ évente.

Költség

Támogatás Effort (fix)

0.00

FTE / év

Decimális

Hamis

Az éves fix erőfeszítés támogatása az alkatrészvagy a kapcsolat, Kifejezése a személy-év.

Költség

Támogatás Effort (változó)

0.00

FTE / év

Decimális

Hamis

Az összeg, amellyel a teljes halászati ​​tevékenység támogatása az alkatrész vagy a kapcsolat minden évben változni fognak.

Például egy értéke -0,01 azt jelzi, hogy a teljes támogatást erőkifejtés lecsökken 0,01 személy években minden évben, míg az érték 0,01 azt jelzi, hogy az összes támogatás erőfeszítés növekszik 0,01 minden évben.

Költség

Tőkeköltség

0.00

$

Decimális

Hamis

A kezdeti beszerzési költsége az alkatrészvagy a kapcsolat.

Költség

Telepítse Effort

0.00

FTE

Decimális

Hamis

Az erőfeszítés szükséges, a személy-év, az alkatrész telepítésérevagy a kapcsolat.

Az alábbi táblázat az alkatrész és / vagy a kapcsolat tulajdonságok, amelyek által a kimeneten TCO értékelő. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Költség Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a költség-szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

hangjegy

Ha a kimeneti tulajdonságokat a TCO értékelő kell "kerekíteni" a "Round felében még" megközelítés (más néven "bankárok" kerekítés) használják.Ezt a technikát használják, hogy egyenletesebben megoldja a 0,5 "tie break tánc" és az eredmény felfelé vagy lefelé kerekíteni a legközelebbi még eredmény, hanem mindig felfelé vagy lefelé kerekítése és a ferde az eredmény. Azaz. 2.5 lekerekítjük 2, míg 3,5 felkerekítik 4, ahelyett, mindkettőjüket, hogy akár lefelé kerekítve 2 és 3 vagy felfelé kerekítve 3 és 4.

típus | Név | Egység | Adattípus | Kívánt | Leírás
Költség | Teljes költsége saját célra - következő x évben. | $ | Egész szám | Hamis | A teljes birtoklási költséget az elkövetkező xév, ahol x a megadott időtartamon belül, amikor fut az értékelő. Ez magában foglalja a költség a komponens vagy a kapcsolat a szabványok, alkomponenseketvagy al-csatlakozások(azaz gyermek), illetve bármely tulajdonítható költségeket.
Költség | Teljes költsége a Own (helyi) - következő X év. | $ | Egész szám | Hamis | A "helyi" birtoklási költséget az elkövetkező xév, ahol xa megadott időtartamon belül, amikor fut az értékelő. Ez nem nemtartalmazza a költség az alkatrész alkomponenseket vagy a kapcsolat a sub-csatlakozások (azazgyermekek), vagy bármely tulajdonítható költségeket.
Költség | Teljes költsége a Own (gyermek) - következő x évben. | $ | Egész szám | Hamis | A "gyermekek" birtoklási költséget az elkövetkező xév, ahol x a megadott időtartamon belül, amikor fut az értékelő. Ez csak magában foglalja a költségek az összetevő alkomponenseket vagy a kapcsolat a sub-csatlakozások (azaz gyermekek).
Költség | Teljes költsége a Own (tulajdonítható) - következő X év. | $ | Egész szám | Hamis | A "tulajdonított" birtoklási költséget az elkövetkező xév, ahol x a megadott időtartamon belül, amikor fut az értékelő. Ez csak magában foglal minden tulajdonított költségeket a csatolt alkatrészek(ami természetesen vonatkozik tulajdonítható költségeket bármely csatolt kapcsolatok).

Az alábbi táblázat az alkatrész és / vagy a kapcsolat tulajdonságok, amelyek által a kimeneten TCO értékelőha a Számolja Per-év költségekről opciót választja. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Költség Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a költség-szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

hangjegy

Lásd a fenti megjegyzést az esetleges kerekítés a kimeneti tulajdonságok.

típus | Név | Egység | Adattípus | Kívánt | Leírás
Költség | Teljes költsége saját célra - évx. | $ | Egész szám | Hamis | A birtoklási összköltség mert év x, Ahol x Minden évben megadott, amikor fut az értékelő. Ez magában foglalja a költség a komponensvagy a kapcsolat a szabványok, alkomponenseket vagy al-csatlakozások (azaz gyermek), illetve bármely tulajdonítható költségeket.
Költség | Teljes költsége a Own (helyi) - évx. | $ | Egész szám | Hamis | A "helyi" fenntartási költségek évre x, ahol xvan Minden évben megadott, amikor fut az értékelő. Ez nem nemtartalmazza a költség az alkatrész alkomponenseket vagy a kapcsolat a sub-csatlakozások (azaz gyermekek), vagy bármely tulajdonítható költségeket.
Költség | Teljes költsége a Own (gyermek) - évx. | $ | Egész szám | Hamis | A "gyermekek" fenntartási költségek évre x, Ahol x Minden évben megadott, amikor fut az értékelő. Ez csak magában foglalja a költségek az összetevő alkomponenseket vagy a kapcsolat a sub-csatlakozás (azaz gyermekek).
Költség | Teljes költsége a Own (tulajdonított) - évx. | $ | Egész szám | Hamis | A "tulajdonított" fenntartási költségek évre x, Ahol x Minden évben megadott, amikor fut az értékelő. Ez csak magában foglal minden tulajdonított költségeket a csatolt alkatrészek(ami természetesen vonatkozik tulajdonítható költségeket bármely csatolt kapcsolatok).

További Kapcsolat tulajdonságai

Az alábbi táblázat a további csatlakozási tulajdonságokat, amelyek szükségesek a TCO értékelő. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan beviteli sorban választó ikon ( [image] ) A tooltip "ár / teljesítmény Input" vagy csak "Költség Input". A változás, hogy minden ilyen "input" tulajdonságok és a különböző strukturális változások az adattárba fogja eredményezni Költség és / vagy Teljesítmény szimulátor igénylő újra szimulációs megjelölt Piros a Szimuláció eszköztár .

típus

Név

Alapértelmezett érték

Egység

Adattípus

Kívánt

Leírás

Költség

Tulajdonítás

Süllyednek Forrás

[Forrás a Cél | Süllyednek Forrás]

Keresése / Lista

Igaz

Ha "Forrás a Cél", Ez a kapcsolat akarat van van költségstulajdonított "mentén" azt tól forráskomponens a mosogató összetevő. Alternatív módon, ha "Süllyednek Forrás", Ez a kapcsolat akarat lett költségek tulajdonított "mentén" azt A mosogató komponens a forrás alkatrész.

Viselkedés

Kapcsolat

támaszok

[folyamatok | támogatja]

Keresése / Lista

Hamis

Ha a "hordozók", ez a csatlakozás azt jelzi, hogy "forrás" komponens által támogatott "mosogató" komponens.

Továbbá, ha bármelyik "támogatja" vagy "folyamatok", akkor a kapcsolat automatikusan kiválasztja a kapcsolatot, hogy a költségeiket tulajdonított "mentén" a mosogató komponens a forrás komponens.

Költség

%

100,0

%

Decimális

Hamis

Jelzi az aránya a mosogató alkatrészek költségeket fognak részesülni, a forrás komponens. A% értékeket nem kell hozzá akár 100% és egyszerűen használható skála a "teljes költsége a Saját - következő x évben." tulajdonság (lásd fent) a mosogató komponens, mivel annak tulajdonítják, hogy a forrás komponens.

Építészet Ingatlan

Az alábbi táblázat az építészeti tulajdonságok, amelyek által a kimeneten TCO értékelő. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Költség Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a költség-szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

hangjegy

Lásd a fenti megjegyzést az esetleges kerekítés a kimeneti tulajdonságok.

típus | Név | Egység | Adattípus | Kívánt | Leírás
Költség | Teljes költsége saját célra - következő x évben. | $ | Egész szám | Hamis | A teljes birtoklási költség az egész architektúra az elkövetkező x évben.

Az alábbi táblázat az építészeti tulajdonságok, amelyek által a kimeneten TCO értékelőha a Számolja Per-év költségekről opciót választja. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Költség Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a költség-szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

hangjegy

Lásd a fenti megjegyzést az esetleges kerekítés a kimeneti tulajdonságok.

típus | Név | Egység | Adattípus | Kívánt | Leírás
Költség | Teljes költsége saját célra - évx. | $ | Egész szám | Hamis | A birtoklási összköltség mert a teljes architektúra évre xa jövőben.


Szimuláló modularitás

Navigáció: szimulálása az architektúrának> Szimulátorok>

Szimuláló modularitás

Küldje el észrevételeit ebben a témában.

A modularitás szimulátor kiszámolja a bejövő és kimenő kapcsolatok minden komponens.

Szimulálni az architektúrának szempontjából modularitás

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Válassza ki Elemzés| A modularitás.

3. Válaszd a Építészet (ek)szeretné felvenni az értékelést.

hangjegy

Alapértelmezésben ABACUS automatikusan kiválasztja az architektúra (ek), melyek ismételt szimuláció miatt szükséges semmilyen mögöttes szerkezeti változások.Ez a kiemelés látható Piros a Szimuláció eszköztár .

4. Kattintson Következő.

5. Válaszd a Csatlakozási típusok (ek)szeretné felvenni az értékelést.

6. Kattintson Következő.

7. Opcionálisan szabni a tulajdonság nevét a számítási eredményeket.

8. Kattintson befejezés.

hangjegy

Ezen a ponton ABACUS elvégzi a szerkezeti értékelését az architektúra (ek) és rövid idő múlva (a folyamatjelzőm visszajelzést) számítással teljes párbeszédablak jelenik meg.

9. Kattintson okéelismerni az értékelést.

Tipp

A képzések és a további segítséget modularitás értékelése kérjük, olvassa el a Avolution közösségi .

Komponens tulajdonságait

Az alábbi táblázat a komponens tulajdonságait, hogy kiad a modularitás értékelő.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "A modularitás Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt egy mögöttes szerkezeti változás, hogy a tároló és a modularitás szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Adattípus | Kívánt | Leírás
A modularitás | Tengelykapcsoló-fan (helyi) | Egész szám | Hamis | A kapcsolatok száma, a ventilátort ezt az összetevőt.
A modularitás | Kuplung-fan out (helyi) | Egész szám | Hamis | A kapcsolatok száma, a ventilátor ki ezt az összetevőt.
A modularitás | Tengelykapcsoló-rajongó | Egész szám | Hamis | A kapcsolatok száma, a ventilátort ez a komponens, beleértve a kapcsolatokat, hogy a ventilátort alkomponenseket.
A modularitás | Kuplung-szétterülnek | Egész szám | Hamis | A kapcsolatok száma, a ventilátor ki ezt az összetevőt, beleértve a kapcsolatokat, hogy a ventilátort alkomponenseket.


Szimuláló nyitottság

Navigáció: szimulálása az architektúrának> Szimulátorok>

Szimuláló nyitottság

Küldje el észrevételeit ebben a témában.

A nyitottság szimulátor határozza meg, hogy milyen mértékben az építészet és annak elemei: a "nyílt", azaz képes-e a rendszer kezelésére alkatrészek cseréjét minimális hatása.

Szimulálni az architektúrának nyitottságát tekintve

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Válassza Elemzés | Nyitottság.

3. Válaszd a Építészet (ek)szeretné felvenni az értékelést.

hangjegy

Alapértelmezésben ABACUS automatikusan kiválasztja az első architektúra, amely újbóli szimuláció miatt szükséges bármely alapul szolgáló ingatlan vagy strukturális változások.Ez a kiemelés látható Piros a Szimuláció eszköztár .

4. Kattintson befejezésés akkor kap egy Figyelmeztetés párbeszéd.

5. Adott esetben vizsgálja meg a figyelmeztetéseket kattintva Részletek >>.

6. Kattintson Folytatás.

hangjegy

Ezen a ponton ABACUS elvégzi a szerkezeti értékelését az architektúra (ek) és rövid idő múlva (a folyamatjelzőm visszajelzést) számítással teljes párbeszédablak jelenik meg.

7. Kattintson okéelismerni a szimuláció.

Tipp

A képzések és a további segítséget nyitottság értékelése kérjük, olvassa el a Avolution közösségi .

Komponens és csatlakozás Standard Tulajdonságok

Az alábbi táblázat az alkatrész és csatlakozó szabvánnyal ingatlan kell értékelnie az nyitottságot.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan beviteli sorban választó ikon ( [image] ) A tooltip "Nyitottság Input". A változás, hogy minden ilyen "input" tulajdonságok az adattárban eredményeként a nyitottság szimulátor igénylő újra szimulációs megjelölt Piros a Szimuláció eszköztár .

típus | Név | Alapértelmezett érték | Egység | Adattípus | Kívánt | Leírás
Nyitottság | Szabványok-szabvány Lejárat-Organisation szint |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Szintjének felel Szabványügyi Testület 0:Szervezeti / Tulajdonosi 1:Konzorcium / DEFACTO 2:Nemzeti / Katonai 3: Nemzetközi
Nyitottság | Szabványok-szabvány Lejárat-állapot |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Jóváhagyási szint érhető el a szabványügyi testület 0:Üzemi / Bizottság tervezete 1:Nyilvános Tervezet / Balloted 2:Időközi tervezete 3: Jóváhagyott
Nyitottság | Szabványok-szabvány Lejárat-Stabilitási |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | A szabvány valószínűleg változtatni? 0:Normál elavult 1:Erősen változhatnak a következő 1-2 év 2:Ismert változás / frissítések meglévő funkciókat 3:Nagyon stabil (nincs változás 2 éven belül)
Nyitottság | Szabványok-szabvány Lejárat-gyártó támogatja |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Szállító Támogatás 0:Nincs termék vagy gyártók támogatják a standard 1:Egy vagy több gyártók, hogy végrehajtja egy részét a standard 2:Több, mint egy vendor termékeket használnak, amelyek minden részét szabvány 3:Sokkal több, mint egy vendor termékeket használnak, amelyek minden részét szabvány
Nyitottság | Szabványok-szabvány explicitségnek-dokumentáció |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Minőségi szabvány dokumentáció 0: Szegény 1: Becsületes 2: Jó 3: Kiváló
Nyitottság | Szabványok-szabvány explicitség-szabvány szélesség |  |  | Egész szám | Hamis | Számos funkció. A gróf a legalacsonyabb szintű alapfelszereltség - Sf
Nyitottság | Szabványok-szabvány explicitségnek-SM |  | % | Decimális | Hamis | Százalékos aránya az összes számos funkció, hogy kötelező
Nyitottság | Szabványok-szabvány explicitségnek-So |  | % | Decimális | Hamis | Százalékos aránya az összes számos funkció, hogy a kötelező
Nyitottság | Szabványok-szabvány explicitségnek-Sc |  | % | Decimális | Hamis | Százalékos aránya az összes számát funkciók, amelyek feltételesen meghatározott
Nyitottság | Profiles-Profil Dokumentáció-dokumentáció |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Minőségi szabvány dokumentáció 0: Egyik sem 1: Szegény 2: Becsületes 3: Kiváló
Nyitottság | Profiles-Profil Dokumentáció-pontosság |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Vajon dokumentáció tükrözik a tényleges rendszer tervezése? Milyen szintű profil funkciókat használják a rendszert? 0:Nem jellemzői 1:Egyes funkciók 2:A legtöbb jellemzői 3:Minden funkció
Nyitottság | Profiles-Profil Dokumentációs lejáratig |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | A profil érett és rendelkezésre? 0: Ad hoc 1:Projekt alapú 2: Szervezeti 3: Nyilvános
Nyitottság | Profiles-Profil explicitség-Explicit szélesség |  |  | Egész szám | Hamis | Számú szabványos funkciók megadott, ahogyan azt az adatlapról
Nyitottság | Profiles-Profil explicitségnek-PM |  | % | Decimális | Hamis | Százalékában KÖTELEZŐ funkciók profil
Nyitottság | Profiles-Profil explicitségnek-Po |  | % | Decimális | Hamis | Százalékában opcionális funkciók a profil
Nyitottság | Profiles-Profil explicitségnek-PC |  | % | Decimális | Hamis | Százalékában feltételesen van definiálva funkciók profil
Nyitottság | Profiles-Profil explicitségnek-lefedettség |  | % | Decimális | Hamis | Százalékában alapfelszereltség külön foglalkoztak a profil
Nyitottság | Profiles-Profil Extensions-hosszabbító szélessége |  |  | Egész szám | Hamis | Száma nem szabványos funkciók által meghatározott profil
Nyitottság | Profiles-Profil Extensions-lefedettség |  | % | Decimális | Hamis | Százalékát kiterjesztéseket részletezett profil
Nyitottság | Termékek terméket Elérhetőség és megfelelésfüggő termékek száma |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Termékek száma támogató kötelező a szabvány jellemzőit 0:Nincsenek termékek támogatják a szabványos 1:Egy vagy több termék végrehajtja egy részét a standard 2:Több, mint egy termék végrehajtja minden része a szabványos 3:Sok egynél több termék végrehajtja minden része a szabványos
Nyitottság | Termékek terméket Elérhetőség és megfelelésfüggő Application Megegyezés |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Milyen szintű megfelelés ne termékek a szabvány? 0: Egyik sem 1:Azt állította, 2:Bizonyított 3:Tanúsított, és bizonyította
Nyitottság | Termékek terméket Elérhetőség és megfelelésfüggő Megegyezés Minőség |  | [0 | 1 | 2. | 3] | Keresése / Lista | Hamis | Minőségi megfelelőségvizsgáló 0: Egyik sem 1:Beltéri vizsgálatok szerint a termék fejlesztője 2:Független vizsgálat (például NIST) 3:Igazolták összefüggésben érintett termékpiac

Komponens, Connection és építészet Ingatlan

Az alábbi táblázat a komponens, a kapcsolat és az építészet tulajdonságok kimenet nyitottsága értékelő. Az összes alábbi tulajdonságokat értékelik közötti nulla (0) és három (3), nulla (0) volt a legkevésbé kívánatos és három (3), hogy a legkívánatosabb.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Nyitottság Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan változás, hogy a tároló és a nyitottság szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Adattípus | Kívánt | Leírás
Nyitottság | Nyitottság | Decimális | Hamis | Átfogó értékelés a tételt nyitottságát.
Nyitottság | Szabványok-szabvány Lejárat | Decimális | Hamis | A jelenlegi állapot a standard, tükrözve, hogy vagy nem hagyták jóvá, hogy mennyi ideig volt használatban, és milyen jól fogadták, hogy a közösségen belül a fejlesztők.
Nyitottság | Szabványok-szabvány explicitségnek | Decimális | Hamis | Explicitségéhez az előírásoknak, ami a potenciális veszélyforrás az ezt követő szabványok
Nyitottság | Profiles-Profil Dokumentáció | Decimális | Hamis | Az, hogy milyen mértékben interfész profil dokumentáció fejlett és hogy a profil dokumentációja tükrözi az aktuális rendszer kialakítása és / vagy a megvalósított rendszer
Nyitottság | Profiles-Profil explicitségnek | Decimális | Hamis | A részletesség szintje biztosított a Profil / profile specifikáció
Nyitottság | Profiles-Profil Extensions | Decimális | Hamis | Az, hogy milyen mértékben a profil megfelel a szabványnak, amelyre épül
Nyitottság | Termékek terméket Elérhetőség és Megegyezés | Decimális | Hamis | Függetlenül attól, hogy vannak olyan nyílt szabvány konform termékek hasznosítható, a projektben


Szimuláló teljesítmény

Navigáció: szimulálása az architektúrának> Szimulátorok>

Szimuláló teljesítmény

Küldje el észrevételeit ebben a témában.

Háttér

Az építészeti értékelő teljesítmény egy diszkrét esemény szimulátor, amely úgy működik, hogy szimulálják az üzenetek áramlását (vagy tokenek) az egész egy olyan építészet. Az elmélet mögött ez származik kutatást végzett a University of Technology, Sydney, és alapjául Rakott Sorba Hálózati modellek(LQNM), Időzített és színes Petri-hálók(TCPN) és Tevékenység Ütemdiagramok(ACD).

Az ABACUS teljesítményt szimuláció, feldolgozás egyik alkotóelem nagyrészt az üzeneteket átadni neki egy másik alkatrész. Az elvek mögött ez a technika is lehet értelmezni, négy fő részből áll:

1. A Üzenet-centrikuskommunikációs modellezi ABACUS segítségével logikus(vagy közvetett) kapcsolatok. Logikai kapcsolatok határozzák meg a viselkedést (gyakorisága és adatok) az üzenetek között eltelt alkatrészeket. Egy jó példa a logikai kapcsolatok lenne a sorrend között folyik, két (2) üzleti folyamatok, illetve a logikai interfészek két (2) alkalmazásokat.

2. Logikai üzenetek szállítják a rendeltetési helyükre keresztül hierarchia(mint például az erőforrás swimlanes), vagy közvetlencsatlakozások (például fizikai vezetékek). Ehhez azt lehet vezetni, akár, az egész, és vissza le a hierarchia (réteges megközelítés), hogy kövesse a közvetlen út.

3. A hűség a modell lehet beállítani, hogy megfeleljen. Például, egy folyamat lehet osztani le eddig, hogy minden egyes elemi folyamat és a funkció egy külön feldolgozási lábnyom. Alternatív módon, lehet, elég, ha csak az egyik érték a teljes folyamat, ami a átlagosfeldolgozási válaszul egy üzenetet.

4. Az aktuális feldolgozásvégzik csak a komponensek, hogy van (vagy vannak) egy processzor. A processzor egy általános dolog, és lehet egy CPU, egy személy, egy szervezeti egység, vagy bármi más, ami képes a munkát végző. Például egy üzleti folyamat nem végez tényleges feldolgozást; ez történik az első "feldolgozó" Ez elhelyezi vagy anyavállalatának hierarchia (ha sáv jelölés használható) vagy adatfeldolgozó hálózatot (ha az elosztott feldolgozás jelölés használható).

Az értékelést úgy végezzük, hogy szimulálja a (meghatározott) forgalom a rendszer, úgy, hogy minden egyes kapcsolat szimulált legalább egyszer. Érkezési idők üzenetek véletlenszerűen generált, tekintettel a megadott frekvencián. A modell szimulálja feidoigozó és versengés és a besorolási üzenetek, összegyűjtése statisztikák az út mentén különböző kimeneti tulajdonságokkal.

Key Performance inputtényezők

1. Frekvencia- Az a frekvencia, ahol a kapcsolat lép fel.

2. Feldolgozás- Az összeg a kivitelezés ideje befejezni egy folyamatot. Ez lehet az óra, perc, nap, műveletek, stb

3. Sebesség- A sebesség a processzor-erőforrást. Ez azt jelenti, hogy hány ciklus / utasítások / akciók végrehajtására is egy egységnyi idő alatt. Fontos, hogy összhangban legyen a használt egységek feldolgozása.

4. Processzorok- A több processzor erőforrásait. Processzorok lehet az emberek, CPU, külső szervezeteket stb

Key Performance kimeneti tényezők

1. Áteresztőképesség- Az üzenetek száma egységnyi idő alatt a kapcsolat. Ez a tényleges érték lehet hasonlítani a várható / elméleti értékeket (azaz frekvencia) levezetni telítettségét a rendszer.

2. Üzenet Értékelés- Az üzenetek száma egységnyi idő alatt a összetevő. Ez az összeg az összes komponens "kimenő és bejövő üzeneteket.

3. Válasz- A minimális / átlagos / maximális várakozási idő erre kapcsolat. Ez az összeg az összes megfigyelt latencia a kapcsolatot létesít a forrás és a mosogató és a sorban állás és feldolgozása (és a késleltetés vissza a forráshoz, ha kétirányú).

4. Hasznosítás- Az hasznosítása összetevő. Ez lesz 0%, ha az alkatrész nem egy eszköz / processzor (azaz nem rendelkeznek a processzorok és a Speed ​​tulajdonságok fentiekben meghatározott).

Míg egy diszkrét esemény szimuláció végezzük kiszámításához különféle kimeneti tulajdonságok, a fent leírtak szerint, a következő képlet lehet használni, mint egy durva eredmények hitelességének (ahol a rendszer nem telített):

Hasznosítása = Sum of Frekvencia bejövő kapcsolatokat * Processing / (Speed ​​* processzorok)

A teljes koncepció talán legjobban bizonyítja, figyelembe véve a következő ábra, amely azt mutatja, két különböző teljesítményű meta-modell. A bal oldali stílusa a klasszikus "sáv" jelölést a feldolgozási feladatok alapján hierarchikusan belül processzor erőforrásait. A jobb oldali stílus egy "elosztott" jelölést a feldolgozási feladatokat keresztül csatlakozik folyamatok kapcsolatot a processzor-erőforrást. Ez utóbbi jelölés lehetővé teszi több erőforrást egy adott feldolgozási feladatot, ellentétben a korlátozott sáv jelölést.

hangjegy

Látható az egyes meta-modell a bemeneti tulajdonságok (piros) és kimeneti tulajdonságok (kék):

Teljesítmény meta-modell: sáv versus Elosztott jelölés

Futás a teljesítmény szimulátor

Szimulálni az architektúrának a teljesítmény

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Válassza ki Elemzés| Teljesítményvagy kattints a gombra.

3. Válassza ki a Építészetértékelni szeretné a legördülő menüből.

hangjegy

Alapértelmezésben ABACUS automatikusan kiválasztja az első architektúra, amely újbóli szimuláció miatt szükséges bármely alapul szolgáló ingatlan vagy strukturális változások.Ez a kiemelés látható Piros a Szimuláció eszköztár .

4. Válassza ki a Alkatrészek és Kapcsolatokértékelni szeretné, a szabvány elemkijelölési ablakban .

5. Állítsa be a Run Time Scale Factorcsúszkát.

hangjegy

A magasabb értékek hozam több statisztikailag konzisztens eredményeket, de tovább tart a kiszámításához.

További Checkbox hoz szabvány elemkijelölési ablakban

· Save Átalakult Modell akarat menteni egy másolatot az RBD átalakított változata a projekt ugyanabban a könyvtárban, mint a jelenlegi projekt és hozzáfűzni "_transformed", hogy a projekt nevét.Ez az átalakult projekt lehet diagnosztizálni részletesen a megbízhatóság szimuláció által vállalt ABACUS.

További lehetőségek a szabvány elemkijelölési ablakban

· Run Time Scale Factor vezérli a szimulációs idő és a pontosság magasabb értékek hozamINGTöbb statisztikailag konzisztens eredményeket, de figyelembe hosszabb időt fut.

hangjegy

Amikor ABACUS kiszámítja a szimulációs idő ez fogja meghatározni a leglassabb közvetett kapcsolatot gyakorisága, amit kiválasztott szimulálható, majd a "bemelegítő" Az időszak (azaz 1 feletti frekvencia) ezt a kapcsolatot (kezdeményező periodikus üzenet generátorok az összes kapcsolat véletlenszerűen ez alatt az bemelegedési idő, kaptak egy esélyt, hogy kezdeményezi), majd szimulálni a Run Time Scale Factor alkalommal, amíg ez a kapcsolat. Vagy (1 / frekvencia) bemelegedési idő + (1 / frekvencia) * Run Time Scale Factor szimulációs időt. Ennek célja, hogy győződjön meg arról, hogy, hogy az összes kapcsolat előtt indított statisztikákat gyűjtenek majd a leglassabb kapcsolat még mindig szimulált legalább egyszer a szimuláció. Ilyen például. Ha a leglassabb közvetett kapcsolat van egy gyakorisága 0,033 time-egység (vagy körül havonta egyszer, ha az idő-egységek nappal), akkor a bemelegedési idő lesz 30,3 time-egységek és a szimulációs idő lesz 30,3 time-egységek alkalommal A működési idő Skálatényező.

6. Kattintson befejezésés akkor kap egy Figyelmeztetés párbeszéd.

7. Adott esetben vizsgálja meg a figyelmeztetéseket kattintva Részletek >>.

8. Kattintson Folytatás.

hangjegy

Ezen a ponton ABACUS elvégzi a diszkrét-esemény szimuláció az architektúra és rövid idő múlva (a folyamatjelzőm visszajelzést) számítással teljes párbeszédablak jelenik meg.

9. Kattintson okéelismerni a szimuláció.

Tipp

A képzések és a további segítséget Performance Szimuláció kérjük, olvassa el a Avolution közösségi .

Komponens tulajdonságait

Az alábbi táblázat a szükséges tulajdonságokat, hogy értékelje teljesítményét. Tulajdonságok keresi először a Component esetekben, akkor a komponens szabványok és ha nem talált, az alapértelmezés lesz használatban.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan beviteli sorban választó ikon ( [image] ) A tooltip "Performance Input". A változás, hogy minden ilyen "input" tulajdonságok és a különböző strukturális változások az adattárba fogja eredményezni Performance szimulátor igénylő újra szimulációs megjelölt Piros a Szimuláció eszköztár .

típus | Név | Alapértelmezett érték | Egység | Adattípus | Kívánt | Leírás
Viselkedés | b_pack | 0.0 |  | Decimális | Hamis | A fix szolgáltatási ideje összepakolni másodpercben. Ez a tulajdonság tipikusan meghatározott, mint egy szabványos típusú, majd használni több komponens példányok. Például, CORBA van b_pack = 0,23 ms.
Viselkedés | m_pack | 0.0 |  | Decimális | Hamis | A változó szolgáltatás ideje összepakolni másodpercben / bájt. Ez a tulajdonság tipikusan meghatározott, mint egy szabványos típusú, majd használni több komponens példányok.
Viselkedés | b_unpack | 0.0 |  | Decimális | Hamis | A rögzített szolgálati idő kicsomagolni másodpercben. Ez a tulajdonság tipikusanmeghatározott, mint egy szabványos típusú, majd használni több komponens példányok.
Viselkedés | m_unpack | 0.0 |  | Decimális | Hamis | A változó szolgálati idő kicsomagolni másodpercben / bájt. Ez a tulajdonság tipikusanmeghatározott, mint egy szabványos típusú, majd használni több komponens példányok.
Viselkedés | Feldolgozás | 0.0 |  | Decimális | Igaz | Az összeg a kivitelezés ideje befejezni egy folyamatot. Ez lehet az óra, perc, nap, műveletek, stb
Viselkedés | Processzorok | 1 |  | Egész szám | Igaz | A több processzor erőforrásait. Processzorok lehet az emberek, CPU, külső szervezeteket stb
Viselkedés | Sebesség | 100 |  | Egész szám | Igaz | A processzor sebessége erőforrás. Ez azt jelenti, hogy hány ciklus / utasítások / akciók végrehajtására is egy egységnyi idő alatt. Fontos, hogy összhangban legyen a használt egységek feldolgozása.
Viselkedés | k_bkgd | 0.0 |  | Decimális | Hamis | Háttér feldolgozás az alkatrészen. Ez állíthatja az eredményeket, hogy megfeleljen minden állandó korrekciót%. Ez valószínűleg meg lehet figyelmen kívül hagyni.

Az alábbi táblázat a komponens tulajdonságait kimeneti teljesítménye révén értékelő. Egy sor ilyen komponens tulajdonságait létrejönnek minden komponens minden előadás távon.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "kimeneti teljesítmény". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a teljesítmény-szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Egység | Adattípus | Kívánt | Leírás
Viselkedés | Üzenet Értékelés |  | Decimális | Hamis | Az üzenetek száma egységnyi idő alatt a komponens. Ez az összeg az összes komponens "kimenő és bejövő üzeneteket.
Viselkedés | Sávszélesség |  | Decimális | Hamis | Teljes sávszélesség révén az alkatrész. Az összegnek a bejövő és kimenő üzenetek.
Viselkedés | Hasznosítás | % | Decimális | Hamis | A kihasználtság az alkatrész. Ez lesz 0%, ha az alkatrész nem egy eszköz / processzor (azaz nem rendelkezik processzorok és Speed ​​tulajdonságok megadott)

Kapcsolat tulajdonságai

Az alábbi táblázat a szükséges tulajdonságokat, hogy értékelje teljesítményét. Tulajdonságok keresi először a Connection esetekben, akkor a kapcsolat Szabványok és ha nem találja, akkor az alapértelmezett használják.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan beviteli sorban választó ikon ( [image] ) A tooltip "Performance Input" vagy a "költség / teljesítmény bemenet". A változás, hogy minden ilyen "input" tulajdonságok és a különböző strukturális változások az adattárba fogja eredményezni Performance szimulátoros és / vagy Költség szimulátor igénylő újra szimulációs megjelölt Piros a Szimuláció eszköztár .

típus

Név

Alapértelmezett érték

Egység

Adattípus

Kívánt

Leírás

Viselkedés

Fajta

kétirányú

[kétirányú | egyirányú]

Keresése / Lista

Igaz

Hogy a kapcsolat kétirányú (kétirányú) vagy egyirányú (egyirányú).

A megengedett értékeit az ingatlan a "kétirányú" vagy "egyirányú".

Kétirányú jelenti szinkron kérés / válasz üzeneteket mivel egyirányú úton egy aszinkron "esemény".

Viselkedés

Absztrakció

közvetett

[közvetett | közvetlen]

Keresése / Lista

Igaz

Hogy a kapcsolat fizikai vagy logikai. Közvetlen kapcsolat fizikai "csövek" két eleme között, hogy a logikai kapcsolatok mentén folyjon.

A megengedett értékeit az ingatlan van a "közvetlen" és "közvetett".

Ha az érték "közvetlen", akkor a kapcsolat nem kell semmilyen egyéb tulajdonságok (kivéve a tulajdonságok Fajta és az absztrakció).

Adat

L_app1

0

Egész szám

Hamis

Kérdés / eseményt mérete byte-ban.

Minden kapcsolat tipikusan egy meghatározott érték ezen. CORBA, események valójában kétirányú, és mindig van egy 12 byte elismerik (L_app2). Ha ez egy igazi egyirányú kapcsolat, akkor hagyja ki az ingatlan L_app2.

Adat

L_app2

0

Egész szám

Hamis

Válasz / elismerik mérete byte-ban.

Minden kapcsolat tipikusan egy meghatározott érték ezen. Az egyirányú kapcsolat nem lesz L_app2.

Viselkedés

Frekvencia

1

Decimális

Igaz

A frekvenciát, amelynél a kapcsolat lép fel.

Minden kapcsolat tipikusan egy meghatározott érték ezen. Ha az ingatlan gyakorisága kimarad, akkor az alapértelmezett használják.

Viselkedés

Kapcsolat

folyamatok

[folyamatok | támogatja]

Keresése / Lista

Hamis

Kapcsolatokat, amelyeken a "eljárások" tulajdonság azt jelzi, hogy az alkatrész elején a kapcsolat kell átalakítani, hogy lehet feldolgozni, az alkatrész végén a kapcsolatot. Valójában a "forrás" komponens költözött gyermeke lett a "mosogató" komponens (a mellékelt kapcsolatokat is "húzta" Ezzel a lépéssel).

Ha a "folyamatok" tulajdonság létezik, akkor az összes többi csatlakozási tulajdonságok figyelmen kívül fogja hagyni, kivéve az opcionális "%" ingatlan az alábbiak szerint.

Viselkedés

%

100,0

Decimális

Hamis

Kapcsolatokat, amelyeken a "eljárások" tulajdonság (fent leírt) opcionálisan van egy "%" tulajdonság, hogy jelezze az aránya a feldolgozás, amely annak tulajdonítható, hogy a rendeltetési hely komponens. Ezen a módon egy forrásból komponens lehet feldolgozni több rendeltetési komponensek különböző% 's. A% értékeket nem kell hozzá akár 100% és egyszerűen használható skála a "feldolgozás" tulajdonság (lásd fent) a forrás összetevőből áll, mivel átalakul gyermeke lett a cél komponens.

Az alábbi táblázat az ingatlan által generált teljesítményt értékelő. Egy sor a kapcsolat tulajdonságainak létrejönnek minden kapcsolatot az egyes teljesítmény távon.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "kimeneti teljesítmény". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a teljesítmény-szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Egység | Adattípus | Kívánt | Leírás
Viselkedés | Sávszélesség |  | Decimális | Hamis | A teljes sávszélesség a kapcsolatot. Ez csak akkor kerül kiszámításra a közvetett kapcsolatok és lényegében (L_app1 + L_app2) * Teljesítmény.
Viselkedés | Sávszélesség 1/2 |  | Decimális | Hamis | A sávszélesség kifejezetten a kimenő (1) és a bejövő (2) üzenetek a kapcsolatot. Ez csak akkor kerül kiszámításra a közvetett kapcsolatok és lényegében L_app1 * Átviteli sebesség és L_app2 * Teljesítmény.
Viselkedés | Áteresztőképesség |  | Decimális | Hamis | Az üzenetek száma időegységenként segítségével a kapcsolatot. Ez a tényleges érték lehet hasonlítani a várható / elméleti értékeket (azaz frekvencia) levezetni telítettségét a rendszer.
Viselkedés | Befejezett | % | Decimális | Hamis | A százaléka üzenetek sikeresen teljes feldolgozása a kapcsolatot. Ez csak akkor kerül kiszámításra a közvetett kapcsolatok és az áteresztőképesség / frekvencia. Esetenként a Befejezett értéke meghaladja a 100% -ot, mivel a véletlenszerűséget üzenet generálás eredménye egy valamivel magasabb üzenetet generációs infó a megadottnál.
Viselkedés | Response (Min / Ave / Max) |  | Decimális | Hamis | A minimális / átlagos / maximális várakozási idő. Ez csak akkor kerül kiszámításra a közvetett kapcsolatok és a megfigyelt várakozási idejét a kapcsolat a forrástól a mosogató és a sorban állás és feldolgozása (és a késleltetés vissza a forráshoz, ha kétirányú).

Építészet Ingatlan

Az alábbi táblázat a rendszer-szintű építészeti tulajdonságai által generált teljesítményt értékelő. Egy sor tulajdonsága az építészet "aggregált" minden teljesítmény távon.Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "kimeneti teljesítmény". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a teljesítmény-szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Egység | Adattípus | Kívánt | Leírás
Viselkedés | Üzenet Értékelés |  | Decimális | Hamis | Az üzenetek száma időegységenként keresztül a komponenseket a építészet. Ez az összeg az összes komponens "kimenő és bejövő üzeneteket.
Viselkedés | Áteresztőképesség |  | Decimális | Hamis | Az üzenetek száma egységnyi idő alatt a kapcsolat az építészet. Ez az összeg az összes közvetett kapcsolat "teljesítmények és ez tényleges érték lehet hasonlítani a várható / elméleti értékeket (azaz frekvencia) levezetni telítettségét a rendszer.
Viselkedés | Sávszélesség |  | Decimális | Hamis | A teljes sávszélesség. Összege építészet kapcsolata sávszélességek.
Viselkedés | Hasznosítás | % | Decimális | Hamis | A hasznosítása összes komponens. Nagyobb lehet, mint 100%, mivel ez csak az összeg az összes architektúra alkotó ALKALMAZÁSOK.
Viselkedés | Response (Min / Ave / Max) |  | Decimális | Hamis | A minimális / átlagos / maximális várakozási idő. Összessége megfigyelt latencia az építészet kapcsolatai a forrástól a mosogató (és vissza forrás, ha kétirányú).


Szimuláló Megbízhatóság és rendelkezésre állás

Navigáció: szimulálása az architektúrának> Szimulátorok>

Szimuláló Megbízhatóság és rendelkezésre állás

Küldje el észrevételeit ebben a témában.

Háttér

A megbízhatóság értékelő kiszámítja a megbízhatóság az architektúra segítségével a bemeneti elemek és kapcsolatok.

Az alkatrészekkel és közvetlen kapcsolatot, a megbízhatóság alapul Mean Time Between Failure (MTBF). Az egyetlen változók számításához szükséges megbízhatóságának építészeti elemei a következők:

· A Meghibásodások közötti átlagidőértéket (években);

· A Mean Time To Repair (MTTR)hiba (években); és

· A meghatározott időre tesztelni Megbízhatóság fölött.

Az alkalmazott képlet kiszámítása során Megbízhatóság adják meg:

Megbízhatóság = -e (-y × kor)
Ahol y = 1 ÷ MTBF

Az összetevők elérhetősége és csatlakozások alapul MTBF és MTTR. Ne feledje, hogy a rendelkezésre álló, ellentétben a megbízhatóság, nem befolyásolja azt az időszakot, amelyre a tesztelt.

Szabad szobák = MTBF / (MTBF + MTTR)

Míg módszereket, amelyekkel a Megbízhatóság blokkdiagrammok(egyszerű soros és párhuzamos konstrukciók) ad a legpontosabb eredményeket, ezek a módszerek váltak rendkívül impraktikus, ha megpróbáljuk kiszámítani a megbízhatóság küldetések belül hatalmas hálózatok százezer elemeket. Továbbá, ezek a transzformációs megközelítések lebontják sok közös struktúrák, mint például a hálózati "hálószemek".

A Monte Carlomódszer lehetővé teszi a megbízhatóság és rendelkezésre állás rendszer tetszőleges méretű és komplexitású kell számítani. A Monte Carlo módszer szimulálja sok forgatókönyv és fvagy minden egyes forgatókönyv véletlenszerű állapotban, elérhető vagy nem érhető el, Az egyes fizikai elem. Annak a valószínűsége, hogy egy adott elem lévén, hozzáférhető állapotban alapul megbízhatóság / elérhetőség a komponens.

Például, egy komponens, 90% -os a rendelkezésre álló lehet várhatóan rendelkezésre álló mintegy 90% -át a forgatókönyvek. A közvetett kapcsolatot a megbízhatóság és rendelkezésre állás lehet becsülni, mint az aránya a véletlenszerű scenarios- amelyekre útját elemek létezik egy elérhető állami forrástól a célállomás.

hangjegy

Mivel a számítást a helyi megbízhatósága és rendelkezésre állása alapul különböző paramétereket, és a különböző formulák (és így eredményez különböző értékeket), szükséges rendelni minden egyes eleme kettőÁllamokban, az egyik a rendelkezésre állás, és az egyik a megbízhatóság. A számítás a rendelkezésre állás használja a rendelkezésre álló állam egyes forgatókönyvek, mivel a számítási megbízhatóságot használja megbízhatóságát állam minden forgatókönyvben.

A megbízhatóság értékelő használja a Monte Carlo szimulációs technika, hogy dolgozzanak ki megbízhatóságának adott architektúra. Az architektúra kerül a több ezer egyedi szimulációk és az eredmények táblázatba, hogy ebből a megbízhatóság intézkedés. Mint már említettük, a Monte Carlo a leggyorsabb technika szimuláló nagyobb hálózatok és együtt fog működni minden komplex (azaz szemű) szerkezetét.

Az értékelő kimenetek négy érték:

1. Mission Megbízhatóságmely több éven át;

2. ElérhetőségA építészet;

3. MegbízhatóságA helyi alkatrészmely több éven át; és

4. ElérhetőségA helyi alkatrész.

A bíráló ki annak a valószínűsége, a alkatrész vagy csatlakozás Üzemi (azaz Nem elmulasztása) és a szükséges időre megjavítani.

Hogyan szabványok MTBFs és / vagy MTTRs kezelik

Ha egy elem (alkatrész vagy kapcsolat esetén) szabványok rendelt MTBF és / vagy MTTR értékek, ezek az értékek is használják a számítás a helyi megbízhatóság és a rendelkezésre állás Egy elem, mint egy sor kapcsolat.

Például, ha egy összetevő A, A hozzárendelt szabványok B, C, és Dmindegyike rendelkezik MTBF és MTTR érték, Helyi Megbízhatóság = R(A)× R(B) × R(C) × R(D), ahol R = Kiszámítani megbízhatósága (az alábbi képlet segítségével) a komponens / szabványok és Helyi Igénybeképesség = A (A)× A (B) × A (C) × A (D), ahol A = Kiszámítani eredménytelenülképessége (a következő képlet segítségével) a komponens / szabványokat. Azaz, ha egy elem három szabványok minden egyes A MTBF és MTTR értéks, És szintén MTBF és MTTR értéksAz elem tulajdonságainak, a helyi megbízhatóság és avilability adják egy sor értéke az egyes standardok és az elem maga.

Egy másik példa, ha egy összetevő Avan rendelve szabványok B, C, és Dde csak a szokásos Begyaránt egy MTBF és MTTR értéket, míg a standard Ccsak egy MTBF értéke és szabványos Dcsak egy MTTR értéket, Helyi Megbízhatóság = R (A)× R (B)× R (C), ahol R= Kiszámítani megbízhatósága (az alábbi képlet segítségével) a komponens / szabványok és Helyi Elérhetőség = A (a)× A (B)× A (C), ahol A= Kiszámítani állás (képlet) a komponens / előírásokat, de számításba egy (C), mert a szabvány csak egy MTBF értéket 'keresések'A megfelelő MTTR érték (ek) és a hozzá minden MTTR értékeket úgy találja, hogy Don't maguk is megfelelő MTBF értéket, így ebben az esetben nem lenne használni az MTTR értéke normál D. Ha volt egy másik szabvány, mondjuk E, Csak egy MTTR értéket is, majd A (C)használná MTBF CA MTTR a D és Eössze kell adni. Ha egy másik szabvány, mondjuk F, Éppen egy MTBF értéke, majd A (F)azt is használja a MTTR a D és Eössze kell adni.

Kiszámításakor Mission Megbízhatóság

Kiszámításakor a helyi megbízhatóság kérdése egy egyszerű képlet, a számítást a közvetett kapcsolatok (küldetés) nem is olyan könnyű, különösen, ha már összetett és nagy hálózatok összefűzött utak (kapcsolatok) és alkatrészek.

Figyelembe az egész hálózat figyelembe

Mivel a közvetett kapcsolat nem jelentenek fizikai kapcsolat, meg kell találni, hogyan forrás komponens lehet eljutni a célállomásra összetevője. És Ez megköveteli a teljes hálózatot, és a különböző módon (és utak) a forrásunk komponens lehet venni, hogy elérjük a célt komponens (mosogató).

hangjegy

Mindaddig, amíg van legalább egy teljesútját a forrástól a célállomás, a küldetés sikeres leszés a közvetett kapcsolat említett, mint egy zárt kapcsolat.

Megérteni a link Matrix

Tudni, hogy melyik komponens / közvetlen kapcsolatot kapcsolódik ahhoz, amit, szükségünk van egy ereklye, hogy gyorsan ellenőrizni, hogy két blokk kapcsolódik egy adott irányba. Ez a funkció a linket mátrix. Röviden, a link mátrix egy két dimenziós tömb logikai változó, amely kimondja, hogy egy adott alkatrész elérheti másik összetevője közvetlenül. A mérete egyenlő a tér a teljes komponensek száma a hálózatban.

Egy egyszerű Megbízhatóság blokk diagram (RBD)

Kapcsolódó link Matrix a megbízhatóság blokk diagram (RBD)

Mivel nem minden kapcsolat kétirányú (folyamatosan mindkét irányban), fontos tudni, hogyan kell olvasni a linket mátrix helyesen. A megbízhatóság értékelő, az első érv a forrás és a második érv a cél (mosogató).

Ezért, ha a link mátrix (A, B) = igaz, akkor ez azt jelenti, hogy egy kaphatnak B közvetlenül (egyirányú). B kaphat kap, ha csak a linket mátrix (B, A) = True. Ha ez igaz, ez azt jelenti, egy kétirányú kapcsolat.

Az adott példa felett:

· Forrás 1 elérheti úti cél 0 (Forrás 1 és Destination 0 olyan eredményt ad a True); és

· Forrás 0 elérheti úti cél 1 (Forrás 0 és Destination 1 olyan eredményt ad a True), a kapcsolódási 0 és 1 közötti kétirányú.

· Forrás 2 nem éri el rendeltetési 1 (Forrás 2 és Destination 1 olyan eredményt ad, az hamis) akkor is, ha forrás 1 elérheti úti cél 2 (Forrás 1 és Destination 2 olyan eredményt ad a True). Ez azt jelenti, hogy a kapcsolat 1 és 2 között van egyirányúak.

Megérteni a megbízhatóság Blokkdiagram

A megbízhatóság blokk diagram (RBD) magában foglalja a szerkezet a teljes objektum modell szempontjából blokkok és linkek. Minden blokk egyik eleme, hogy lehetősége van a hiba, vagy a siker szerint a linkeket / utak, amelyek összekötik őket. A komponenseket és kapcsolatokat válhat "blokk" a RBD.

Például RBD tömbök és linkek

Az alak feletti jelent RBD példa. A piros szaggatott vonal egyes küldetés 4. 1 Figyeljük meg, hogy csak két lehetséges út a misszió 4-1.

Tekintsük az útvonal 4-3 az 0-1, és az útvonal 4-7 a 1 pontozott blokkok 2, 5és 6 képviselik blokkok, amelyek nem érintik a hiba / nem kudarca misszió 4. 1 Ezek nem figyelembe venni, és nem veszi figyelembe. Ez azért fontos, mert a legtöbb misszió nem lesz sok felesleges blokkok ez nem befolyásolja egy adott küldetés sikeréhez. Ez még nyilvánvalóbb nagyobb hálózatok, amellyel a több felesleges blokkok teszi a szimulációs eredmények pontatlanok.

Hogy gyorsítsák fel szimulációs idő, és biztosítja pontosabb eredményt, meg kell elvonatkoztatni a teljes RBD és csak az elemeket, amelyek befolyásolják a küldetés sikeréhez.

hangjegy

Egyetlen útvonal / útvonal nem megy át semmilyen összetevő kétszer.

Ebben a szakaszban tudunk létrehozni egy linket mátrix, és végre egy Monte Carlo szimuláció.

Kiszámításakor Építészet Elérhetőség

Az architektúra a rendelkezésre álló annak a valószínűsége, hogy az összes közvetett kapcsolat lesz elérhető bármely időpontban. A rendelkezésre álló egyes közvetett kapcsolat során határozzák meg az egyes iterációs a Monte Carlo szimuláció azonban ezeket a közvetett kapcsolatok (jellemzően) támaszkodnak ugyanazokat a fizikai elemek. Ezért egyszerűen összesítése ezeknek az egyéni elérhetőségek lenne "dupla száma" ezeket az ENSZ-elérhetőséget, így egy pesszimista átfogó architektúra rendelkezésre állását. Alternatív megoldásként a teljes felépítése a rendelkezésre álló kiszámítani, hogy néz mindegyik ismétlésnél, és látta, hogy a elemek vesznek részt a közvetett kapcsolatban érdekes állnak rendelkezésre. És aztán aggregáló ezeket az eredményeket a végén a szimuláció.

Futás a megbízhatóság szimulátor

Szimulálni az architektúrának a megbízhatóság szempontjából

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Válassza ki Elemzés| Megbízhatóság.

3. Válassza ki a Építészetértékelni szeretné a legördülő menüből.

hangjegy

Alapértelmezésben ABACUS automatikusan kiválasztja az első architektúra, amely újbóli szimuláció miatt szükséges bármely alapul szolgáló ingatlan vagy strukturális változások.Ez a kiemelés látható Piros a Szimuláció eszköztár .

4. Válassza ki a Alkatrészek és Kapcsolatokértékelni szeretné a szabvány elemkijelölési ablakban az 'Show közvetlen összeköttetésben' és 'show folyamatok Connections "rádió-gomb szűrőket a bal alsó sarokban a párbeszéd elősegítése céljából lehet kiválasztani.

További Checkbox hoz szabvány elemkijelölési ablakban

· Save Átalakult Modell akarat menteni egy másolatot az RBD átalakított változata a projekt ugyanabban a könyvtárban, mint a jelenlegi projekt és hozzáfűzni "_transformed", hogy a projekt nevét.Ez az átalakult projekt lehet diagnosztizálni részletesen a megbízhatóság szimuláció által vállalt ABACUS.

További Radio-Gombok hoz szabvány elemkijelölési ablakban

· Mutasd a közvetlen kapcsolatot automatikusan beállítja a kapcsolat ingatlan szűrő ingatlan típusa = viselkedése, Name = absztrakció és érték = közvetlen.Ez az opció az alapértelmezett, és segíti a kiválasztásban a "közvetlen" kapcsolat a fenti és lenti.

· Mutass folyamatok kapcsolatok automatikusan beállítja a kapcsolat ingatlan szűrő ingatlan típusa = viselkedése, Name = kapcsolat és érték = folyamatok.Ez a lehetőség segíti a kiválasztás a "közvetlen" csatlakozások, mint a fent leírt és az alábbiakban.

5. Kattintson Következő.

6. Válaszd a Missziókazaz kapcsolatok szeretne venni a szimulációban.

7. Állítsa be a Run Time Scale Factorcsúszkát.

hangjegy

A magasabb értékek hozam több statisztikailag konzisztens eredményeket, de tovább tart a kiszámítása.

Jelölőnégyzetei

· Előadás Zárt kapcsolatok akarat automatikusan szűrni az elérhető csatlakozások csak közé tartoznak azok, amelyek legalább egy teljes fizikai útvonal a forrástól komponens a rendeltetési komponens, mint egy a RBD kiválasztási fentebb leírtuk.

· Mutasd közvetett kapcsolatban automatikusan beállítja a kapcsolat ingatlan szűrő ingatlan típusa = viselkedése, Name = absztrakció és érték = közvetett.Ez az opció az alapértelmezett, és segíti a kiválasztásban a "közvetett" vagy misszió kapcsolatok a fenti és az alábbi.

Gombok

· Mindenkiválasztja az összes kapcsolatok.

· InvertMegszünteti az összes aktuálisan kiválasztott kapcsolatok és kiválasztja azokat, amelyek nem voltak kiválasztva.

· Egyik semkikapcsolja az összes kapcsolatok.

További lehetőségek

· Run Time Scale Factor vezérli a szimulációs idő és a pontosság magasabb értékek hozamINGTöbb statisztikailag konzisztens eredményeket, de figyelembe hosszabb időt fut.

hangjegy

Amikor ABACUS kiszámítja a iterációszám szimulálni ez fogja meghatározni a legmegbízhatóbb eleme, hogy nem tökéletesen megbízható, majd szimulálni a Run Time Scale Factor alkalommal 1 fölött nem hozzáférhető az elem plusz 1 ismétlés. Vagy (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Ez a célja annak biztosítása, hogy ez az elem sem sikerül legalább egyszer a szimuláció. Ilyen például. Ha a legmegbízhatóbb eleme, hogy nem tökéletesen megbízható egy MTBF 10.000 óra, és egy átlagos javítási idô 8 óra, akkor a szimuláció kerül (10.000 + 8) / 8 = 1,251 alkalommal a Run alkalommal Skálatényező + 1 ismétléseket.

· Év szimuláltra Ahead meghatározza, hogy hány éves a misszió Megbízhatóság adatok alapján kell kiszámítani.

· Numbra szálakdeidőpontokról száma processzorszál használni a Monte-Carlo szimuláció.Ez az opció alapértelmezésben hogy megfeleljen a rendelkezésre álló CPU-k / magok (beleértve a Hyper-Threading magok), hogy minimálisra csökkentsék szimulációs idő.

8. Kattintson befejezésés akkor kap egy Figyelmeztetés párbeszéd.

9. Adott esetben vizsgálja meg a figyelmeztetéseket kattintva Részletek >>.

10. Kattintson Folytatás.

hangjegy

Ezen a ponton, ABACUS elvégzi a Monte Carloszimuláció az architektúra és rövid idő múlva (a folyamatjelzőm visszajelzést) számítással teljes párbeszédablak jelenik meg.

11. Kattintson okéelismerni a szimuláció.

Tipp

A képzések és a további segítséget Megbízhatóság Szimuláció kérjük, olvassa el a Avolution közösségi .

Komponens és kapcsolat tulajdonságai

Az alábbi táblázat a komponens és 'közvetlen'csatlakozási tulajdonságokat kell értékelnie az megbízhatóság. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan beviteli sorban választó ikon ( [image] ) A tooltip "Megbízhatóság Input". A változás, hogy minden ilyen "input" tulajdonságok és a különböző strukturális változások az adattárba fogja eredményezni Megbízhatóság szimulátor igénylő újra szimulációs megjelölt Piros a Szimuláció eszköztár .

típus | Név | Alapértelmezett érték | Egység | Adattípus | Kívánt | Leírás
Megbízhatóság | Meghibásodások közötti átlagidő | ∞ | év, hét, nap, óra | Decimális | Igaz | A Mean Time előtt tartása az elem. Megjegyzés: Az értékek egységeiben kifejezett év, hét, nap, óra és alakítja követően '24 / 7 "hozzáférés fogalma az alábbiak szerint; - 1 év = 52 hét vagy 365 napig vagy 8760 óra - 1 hét = 7 nap, vagy 168 óra - 1 nap = 24 óra
Megbízhatóság | MTTR | 0 | év, hét, nap, óra | Decimális | Igaz | A Mean Time To Repair az elem. Megjegyzés: Az értékek egységeiben kifejezett év, hét, nap, óra és alakítja követően '24 / 7 "hozzáférés fogalma az alábbiak szerint; - 1 év = 52 hét vagy 365 napig vagy 8760 óra - 1 hét = 7 nap, vagy 168 óra - 1 nap = 24 óra

Az alábbi táblázat a komponens és 'közvetlen' kapcsolat tulajdonságai által kiadott megbízhatósági értékelő. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Megbízhatóság Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a megbízhatóság szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Egység | Adattípus | Kívánt | Leírás
Megbízhatóság | Megbízhatóság - x év |  | Decimális | Hamis | Annak a valószínűsége, hogy az elem nem fogja elmulasztani a következő x évben. Ez az érték 0 és 1 közötti.
Megbízhatóság | Megbízhatatlansága - x év |  | Decimális | Hamis | Annak a valószínűsége, hogy az elem nem fogja az elkövetkező években x. Ez az érték 0 és 1 közötti.
Megbízhatóság | Elérhetőség | % | Decimális | Hamis | A számított elérhetősége az alkatrész vagy a kapcsolat. Ez az érték 0% és 100%.
Megbízhatóság | Elérhetetlensége | % | Decimális | Hamis | A számított hiánya az alkatrész vagy a kapcsolat. Ez az érték 0% és 100%.

Az alábbi táblázat a 'közvetett'kapcsolat tulajdonságai által kiadott megbízhatósági értékelő. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Megbízhatóság Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a megbízhatóság szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Egység | Adattípus | Kívánt | Leírás
Megbízhatóság | Mission Megbízhatóság - x év |  | Decimális | Hamis | Annak a valószínűsége, hogy a közvetett kapcsolat nem fogja elmulasztani a következő x évben. Ez az érték 0 és 1 közötti.
Megbízhatóság | Mission Megbízhatatlan - x év |  | Decimális | Hamis | Annak a valószínűsége, hogy a közvetett kapcsolat nem fog működni a következő x évben. Ez az érték 0 és 1 közötti.
Megbízhatóság | Elérhetőség | % | Decimális | Hamis | A számított hozzáférhetősége közvetett kapcsolatot. Ez az érték 0% és 100%.
Megbízhatóság | Elérhetetlensége | % | Decimális | Hamis | A számított hiánya a közvetett kapcsolat. Ez az érték 0% és 100%.

Építészet Ingatlan

Az alábbi táblázat az építészeti tulajdonságai által kiadott megbízhatósági értékelő. Ezek a tulajdonságok jelennek meg a Properties ablakban egy ingatlan kimeneti sorban választó ikon ( [image] ) A tooltip "Megbízhatóság Output". A nyíl az ikonra kiemeli Piros ( [image] ), Ha ezek a tulajdonságok elavultak miatt szolgáló ingatlan vagy szerkezeti változás, hogy a tároló és a megbízhatóság szimulátor, újra fel kell szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

típus | Név | Egység | Adattípus | Kívánt | Leírás
Megbízhatóság | Elérhetőség | % | Decimális | Hamis | A rendelkezésre álló valamennyi közvetett kapcsolatban, hogy bekerültek az értékelésbe. Azaz, a valószínűsége, hogy mindenközvetett kapcsolatban áll majd rendelkezésre egy adott időpontban. Ez az érték 0% és 100%. Megjegyzés: Ez NEM a szorzást az egyéni csatlakozással elérhetőségeken, mert ez lenne a "kettős elszámolás" az ENSZ-elérhetőségét az érintett alkatrészeket.
Megbízhatóság | Elérhetetlensége | % | Decimális | Hamis | A elérhetetlensége közvetett kapcsolatokat, amelyeken szerepel az értékelést. Azaz, a valószínűsége, hogy legalább egyközvetett kapcsolat nem lesz elérhető, egy adott időpontban. Ez az érték 0% és 100%. Megjegyzés: Ez NEM a szorzást az egyéni csatlakozással unavailabilities mivel ez lenne a "kettős elszámolás" az ENSZ-elérhetőségét az érintett alkatrészeket.
Megbízhatóság | Mission Megbízhatóság - x év |  | Decimális | Hamis | Annak a valószínűsége, hogy az összes közvetett kapcsolatban, hogy bekerültek az értékelés nem lesz sikertelen a következő xév. Ez az érték 0 és 1 között Megjegyzés: Ez NEM a szorzás az egyes kapcsolat megbízhatósága, mivel ez lenne a "kettős elszámolás" az ENSZ-elérhetőségét az érintett alkatrészeket.
Megbízhatóság | Mission Megbízhatatlan - x év |  | Decimális | Hamis | Annak a valószínűsége, hogy legalább az egyik a közvetett kapcsolat, hogy már tartalmazza az értékelés sikertelen lesz a következő xév. Ez az érték 0 és 1 között Megjegyzés: Ez NEM a szorzást az egyéni csatlakozással unreliabilities mivel ez lenne a "kettős elszámolás" az ENSZ-elérhetőségét az érintett alkatrészeket.


Szimuláló az építészet

Navigáció: szimulálása az architektúrának>

Szimuláló az építészet

Küldje el észrevételeit ebben a témában.

Ha már lakott, és elemezte az architektúrának, akkor készen áll a használatra ABACUS állapítható meg, hogy az építészet találkozik a mennyiségi igényeket. Ez megköveteli tettetés. Szimulálni az architektúrának először el kell döntenie, hogy milyen információkat szeretne felfedezni. Az ilyen típusú információk gyakran nevezik KPI, vagy Key Performance Indicators. Például, nem akarsz teljesítményének elemzése, evolvability, és a nyitottság, vagy szeretné összegyűjteni mutatók, mint a teljes birtoklási költséget. Mindez információhoz is juthatunk valamilyen módon. Miután ezt adatokat, akkor képes lesz arra, hogy elemezze az architektúrának a különböző grafikus formátumban (vagy elemezni az új értékeket közvetlenül).

Három lehetőség van, hogy szimulálják az architektúrának:

· Egyszerű mérőszámok ;

· Előre elkészített szimulátorok ; vagy

· Scripting .

Egyszerű Metrics

Minden alkatrészt az Ön építészet tulajdonságai - amelyek közül sok lehet szokás, hogy az alkalmazás az ABACUS. Ezek a tulajdonságok jelentik különböző jellemzőit a komponenseket. Egyes esetekben egyszerűen gyűjtése ezeket a mérőszámokat (építeni KPI) lehet ahhoz, hogy elmondjam fontos információt a építészet. Például KLOCS, vagy több ezer sornyi kódot, már széles körben használják az intézkedés a komplexitás. Más esetekben érdemes lehet Az adatok exportálásához és elemezze egy másik eszközt. Továbbá, érdemes gyűjteni ingatlan elvégzése után egy másik fajta szimuláció.

Tulajdonságok lehet gyűjteni a folyamat összesítés . Aggregációs hozzáteszi megadott al-ingatlanok összesen, ami tükröződik a szülő elem. Aggregációs csak akkor működik alkatrészeket tartalmazó al-alkatrészeket.

Előre elkészített szimulátorok

Jelenleg öt előre beépített szimulátorok hogy lehet használni az ABACUS. Ezek:

· Teljesítmény;

· A modularitás;

· Teljes birtoklási költség (TCO);

· Nyitottság; és

· Megbízhatóság.

hangjegy

ABACUS automatikusan kiemelni, hogy ezek közül szimulátorok kell újra végigmenni Piros kiemelve a Szimuláció eszköztár .

Scripting

Scripting biztosítja a rugalmasságot, hogy szimulálják az architektúrának egyéni módon. Által írásban szkriptek akkor végre szimulációk túl a jelenlegi beépített kapacitása ABACUS. Az egész ABACUS objektum modell áll rendelkezésre a scripting motor, így csak korlátozott a képességét, hogy írni szkripteket!

Visual Basic szkript a programozási nyelv által támogatott ABACUS, hiszen ez biztosítja alapvető programozási funkciók egy viszonylag egyszerű formában.

Lásd még

Exportálása építészet | Összesített tulajdonságok | Írás szkriptek


Fejlődik az architektúrának

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Fejlődik az architektúrának

Küldje el észrevételeit ebben a témában.

Architektúrák lehet kifejezetten fejlődött, és a hierarchia architektúrák létre. Így fejlődik a építészet ABACUS, számos fejlett építészeti megoldásokat lehet létrehozni, összehasonlítva és baselined. Célok (vagy mérőszámok) meg lehet határozni tetszőleges számú építészeti tulajdonságait meglévő architektúrák.

Egy egyszerű módja annak, hogy fontolja meg a fejlődése egy olyan építészet, hogy kapcsolódik, hogy a koncepció leszármazottja építészet. Amikor egy architektúra fejlődik, a másolatAz anyavállalat építészeti jön létre. Ezt a példányt lehet mondani, hogy a közvetlen leszármazottaz eredeti szülő építészet.

hangjegy

Ebben az online súgó dokumentáció és a ABACUS eszközkészlet maga a kifejezés fejlődikgyakrabban használják, mint a kifejezés leszármazottKérjük, vegye figyelembe, hogy mind ugyanarra a funkcionalitást.

Fejlődni egy meglévő architektúra

1. Győződjön meg arról, hogy van egy ABACUS fájlnyílt és a Explorer ablak Megjelenik.

2. Válassza ki a megfelelő architektúra szeretne fejlődni a felfedező fa.

3. Jobb klikkaz építészeti és válasszuk Fejlődika menüből.

Formálódó a Kiválasztott Építészet

4. A kialakult építészeti alatt jelenik meg a kiválasztott építészet.

Evolved Építészet

hangjegy

A kialakult építészeti lehet átnevezni a jobb kattintással az architektúra és a kiválasztás Átnevezése.Továbbá, minden diagramok és katalógusok a kialakult építészeti automatikusan beállítva "diff" ellen az alapvonal építészet hogy azt alakult ki.

Célok kitűzése a kialakult építészeti

Célok kitűzése a kialakult építészeti lehetővé teszi, hogy hozzon létre egy kritériumok, amelyek alapján az alakulását a architektúrák. Gólok határozza meg az ingatlan típusok és azoknak a nevét, tulajdonságait meglévő a kialakult építészet. Gólok manuálisan is meghatározott, és hozzátette, hogy te építészet. Kövesse az alábbi lépéseket a kitűzött célokat.

Beállítás gólokat meglévő tulajdonságait a kialakult építészeti

1. Győződjön meg arról, hogy van egy ABACUS fájlnyílt és a Explorer ablak Megjelenik.

2. Válasszuk az Eszközök | A meghatározott célokA fő menüsor.

3. A Gól bemenetablak.

Gól beviteli ablak

4. Kattints a Létező gomb.

5. A Válasszon egy ingatlanablak.

6. Válassza ki a kívánt tulajdonság beállítani a cél a kialakult építészeti és kattintson a oké gomb.

7. A kiválasztott cél most már megjelenik a Gól bemenet ablak.

8. Válassza ki a célt, és kattintson a Szerkesztés gomb.

9. A Szerkesztés gólablak.

hangjegy

Ez az ablak lehetővé teszi, hogy módosítsa a tulajdonság nevét és típusát, hogy a cél tükrözi, valamint a legjobb és a legrosszabb értéket (vagy minimum / maximum értékek) azt a tulajdonságot. Ezek az értékek találhatók összehasonlításával minden architektúrán és találd meg a legkisebb és a legnagyobb érték minden erre a konkrét ingatlan. Ezek az értékek manuálisan is határozni. Például, ha úgy döntesz, hogy célt az ingatlan elemzi Response (AVE)és a típus Viselkedés, A legrosszabb és a legjobb ár-érték tükrözheti a tranzakció sebessége szükséges az optimális teljesítmény (legjobb érték) és a tranzakciós sebesség szükséges csak a fő alkalmazási kell feldolgozni (legrosszabb érték).

10. Miután a megfelelő értékek kerültek meghatározásra, válassza ki oké.

A célok kitűzése az új tulajdonságokat a kialakult építészeti

1. Győződjön meg arról, hogy van egy ABACUS fájlnyílt és a Explorer ablak Megjelenik.

2. Válasszuk az Eszközök | A meghatározott célokA fő menüsor.

3. A Gól bemenetablak.

4. Kattints a Új gomb.

5. A Új célablak.

hangjegy

Ez az ablak lehetővé teszi, hogy meghatározza az ingatlan nevét és típusát, hogy a cél tükrözi, valamint a legjobb és a legrosszabb értéket (vagy minimum / maximum értékek) azt a tulajdonságot. Például, ha úgy döntesz, hogy célt adjanak ingatlan elemzi Response (AVE)és a típus Viselkedés, A legrosszabb és a legjobb ár-érték tükrözheti a tranzakció sebessége szükséges az optimális teljesítmény (legjobb érték) és a tranzakciós sebesség szükséges csak a fő alkalmazási kell feldolgozni (legrosszabb érték).

6. Miután a megfelelő értékek kerültek meghatározásra, válassza ki oké.

7. Egy párbeszédablak Hozzáadás minden architektúránMegjelenik az alábbi:

8. Kattintson Igenhozzáadni a cél, mint a tulajdon valamennyi releváns architektúrák. Ez biztosítja, hogy az újonnan meghatározott cél és annak tulajdonságait hozzáadásra kerül minden architektúrák a fájlban. Ha nem szeretné, többek között az ingatlan a architektúrák, akkor kattintson Nem.

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Megtekintése egy csillag telken a kialakult architektúrák | Megtekintése szórásdiagramon a kialakult architektúrák


Bővülő és összeomlik a fa

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Bővülő és összeomlik a fa

Küldje el észrevételeit ebben a témában.

Amikor egy csomópont a növényben található al-alkatrészek és gyűjtemények, akkor van egy kis [image] vagy [image] aláírni a bal oldalon. Akkor kattintson a [image] bővíteni a csomópont és látni al-alkatrészek és csatlakozások. Hasonlóképpen, akkor kattintson a [image] összeomlani a csomópont elrejteni az al-alkatrészek és csatlakozások (annak érdekében, hogy több hely, illetve, hogy a fa könnyebb megérteni).

Másik lehetőség, hogy bővítse az egész csomópontot, amely esetben az összes al-csomópont szintén bővíteni fogja, és azok al-csomópontok, és az övék ... stb Hasonlóképpen, akkor összeomlik az egész csomópont - záró több szinten egyszerre .

Ezen kívül van a lehetőség, hogy bővítse csak a architektúrák, elemek (azaz alkatrészek és csatlakozások), alkatrészek vagy csatlakozások.

Kibontásához vagy egy egész csomópontot (és annak al-csomópontok, stb)

1. Jobb klikka csomópontra.

2. Válassza ki Kibontása | Minden vagy Összeomlás.

Bővíteni minden olyan építészet (ek)

1. Jobb klikkA architektúrák vagy építészet.

2. Válassza ki Kibontása | Minden.

Bővíteni elemek

1. Jobb klikkA architektúrák vagy építészet.

2. Válassza ki Kibontása | Elemek.

Bővíteni alkatrészek

1. Jobb klikkaz összetevőkről, alkatrész vagy rész-összetevő.

2. Válassza ki Kibontása | Components | Minden.

Bővíteni kapcsolatok

1. Jobb klikkA Connections egy kapcsolat vagy egy al-csatlakozás.

2. Válassza ki Kibontása | Kapcsolatok | Minden.


Exportálásával Építészet

Navigáció: Jelentés az adott architektúrán>

Exportálásával Építészet

Küldje el észrevételeit ebben a témában.

ABACUS lehetővé teszi, hogyexportálja a architektúrát MDB (Microsoft Access), MS SQL Server, .abacus (ABACUS fájl), és .xls (Microsoft Excel) formátumban. Azt is exportálja a diagrams hogy PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF és BMP formátumban, és a jelentései .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) és .rtf (Rich Text Format) formátumot. Ez lehetővé teszi, hogy elemezze, és tekintse meg az építészet és az adatokat a kívánt módon.

Exportálni az architektúra Mdb (Microsoft Access)

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Kattints a Fájl menü.

3. Válassza ki Export, és akkor A MDB.

4. Tudomásul veszi a figyelmeztetést, és kattintson oké.

5. Írja be a fájl nevét.

6. Kattintson a Mentés Gomb.

hangjegy

Az export formátum az mdb adatbázis specifikus ABACUS és minden séma változások eredményeként képtelen újra importálni. Kérlek nézz Benépesítő az MS Access A leírás a MS Access séma.

Exportálni az architektúra MS SQL Server

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Kattints a Fájl menü.

3. Válassza ki Export, és akkor MS SQL Server.

4. A megjelenő párbeszédablakban kattintson a Export Üres MDB ...gombot, és importálja be ezt a MS SQL Server adatbázis szerver.

5. Töltse ki az adatbázis információkat, és a kapcsolat string.

6. Kattintson a Export Gomb.

hangjegy

Az export formátuma MS SQL Serveradatbázis specifikus ABACUS és minden séma változások eredményeként képtelen újra importálni. Kérlek nézz Benépesítő az MS Access leírását az adatbázis séma.

Exportálni az architektúra .xls (Excel fájl)

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási , Egy explorer megjelenített És egy építészet hozzáadott .

2. Győződjön meg arról, hogy van egy Excel Import / Export konfigurációs fájl definiált.

3. Jobb klikkegy architektúra a modell vagy bármely részét a Alkatrészekcsomópont (egy adott architektúra) exportálni kívánja, hogy az Excel konfigurációs fájl.

4. Válassza ki Export | Hogy Excel ... a menüből.

5. A Válassza Excel Import / Export konfigurációs fájl használataablak jelenik meg.

6. Válassza ki a megfelelő konfigurációs fájl az építészeti modell és kattintson a Nyisd ki gomb.

7. Ha automatikusan nem tette meg, térkép A legfelső szinten alkatrészeket a jelenlegi szerkezet a Set Id(a korábban megadott), és kattints Export....

Például felső szintű komponens Mapping

8. Válasszon egy helyet és fájlnevet a Excel fájlt, és kattintson a Mentés gomb.

Exportálni az architektúra .abacus (ABACUS fájl)

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Jobb klikkA Építészet csomópont, minden építészet a modell vagy bármely részét a komponensek fa.

3. Válassza ki Export | Hogy Fájl ...a menüből.

4. Válassza ki a helyét és nevét, majd kattintson a Mentés gomb.

hangjegy

Importálhat ABACUS fájlt vissza ABACUS lépéseivel 1-2a fenti, majd adja meg Import | Ból ből Fájl .... Miután kiválasztotta a kívánt fájlt importálni, kérni fogja, hogyan szeretné importálni a szabványok és típusok. Akkor lehet importálni szabványok és típusok, mint új vagy összevonták szabványok és típusok. Az alapértelmezett beállítás a szabványok és típusok kell fésülni a meglévő szabványok és típusok, ha már létezik a program.

Exportálni az architektúra .xml

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Jobb klikkegy Építészet csomópont, minden építészet a modell vagy bármely részét a komponens fa.

3. Válassza ki Export | Hogy XML ...a menüből. Másik lehetőség, hogy kattintson a menüben Fájl| Export| Hogy XML ...

4. Válassza ki a helyét és nevét, majd kattintson a Mentés gomb.

hangjegy

Akkor lehet importálni egy XML fájlt vissza ABACUS lépéseivel 1-2a fenti, majd adja meg Import | Ból ből XML .... Miután kiválasztotta az XML fájlt importálni kívánt, kérni fogja, hogyan szeretné importálni a szabványok és típusok. Akkor lehet importálni szabványok és típusok, mint új vagy összevonták szabványok és típusok. Az alapértelmezett beállítás a szabványok és típusok kell fésülni a meglévő szabványok és típusok, ha már létezik a program.

Hogy exportálja a diagramot PNG, JPG, SVG, TIFF, GIF, BMP

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Nyissa meg a diagramszeretne exportálni.

3. Kattints a Export Diagramgombot a Diagram eszköztár.

4. A Export Diagramablak jelenik meg.

5. Válassza ki a Böngésszengombra a vizualizációs a kívánt helyre.

6. Válassza ki a Fájl típusalegördülő menüből válassza ki a fájltípust.

7. Kattintson a Mentés gomb.

Hogy exportálja a jelentést .pdf (Adobe Acrobat), .xls (Microsoft Excel) vagy.doc (Microsoft Word)

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Alkot egy jelentés szeretne exportálni.

3. Kattints a Exportgombot a jelentések eszköztár.

4. Válassza ki Excel, PDF vagy WordA legördülő menüből.

5. Várjon néhány másodpercet, míg a jelentés export.

6. Válassza ki a helyét és nevét, majd kattintson a Mentés gomb.


Keresése és cseréje elem a építészet

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Keresése és cseréje elem a építészet

Küldje el észrevételeit ebben a témában.

Megtalálhatod és csere külön rész, kapcsolat, típus, normál vagy ingatlan használatával ABACUS "Find és csere létesítmény.

Találni egy elemet

1. Kattintson a csomópont a fa szeretne keresni belül.

2. Válassza ki Szerkesztés| Leletvagy nyomja meg a Ctrl + F.

3. Írd be a szöveg A tételtalálni a "Mit keres" mezőben.

4. Kattintson Következő keresése.

Hogy cserélje egy tárgy

1. Kattintson a csomópont a fa szeretne keresni belül.

2. Válassza ki Szerkesztés| Cseréljevagy nyomja meg a Ctrl + H.

3. Írd be a szövegA tételtalálni a "Mit keres 'mező és a szöveget cserélje ki a" Csere "mezőbe (vagy semmit, ha a mező üres).

4. Kattintson Következő keresésehogy megtalálja az első fokon a "Mit keres" szöveget, majd kattintson Cserélje cserélni ebben az esetben a "Csere" szöveget, vagy kattintson Az összes cseréjecserélni a példányokat.

Megvan a lehetőség, hogy:

o Egyezik a helyzet,

o Egyezik az egész szót,

o Keresés a kezdetektől a projekt,

o Figyelmen kívül hagyja architektúrák -, hogy az építészet csomópontok magukat. Bármilyen csomópontok alatt architektúra csomópontok, mint a komponensek és a kapcsolatok továbbra is lehet keresni,

o Figyelmen kívül hagyja alkatrészek -, hogy az a komponense csomópontok magukat,

o Figyelmen kívül hagyja kapcsolatok - ez a kapcsolat csomópontok magukat,

o Figyelmen kívül hagyja szabványok - ez minden, építészet, alkatrész és csatlakozó szabvánnyal csomópont figyelmen kívül fogja hagyni,

o Figyelmen kívül hagyja típusok -, hogy az a típusú csomópontok magukat. Minden kötöttség csomópontok alatt a típusú csomópontok továbbra is keresett,

o Figyelmen kívül hagyja sablonok és tartalmát - azaz a sablon csomópontok magukat, valamint minden olyan sablont alkatrész és csatlakozó csomópontok alattuk,

o Figyelmen kívül hagyja ingatlanok - vagyis az összes ingatlan típusok, neveket, értékek és mértékegységek összes modell elemeit figyelmen kívül fogja hagyni,

o Figyelmen kívül hagyja leírások - ez a leírások minden a modell elemeit figyelmen kívül hagyja.

Lásd még

Hogyan épül fel egy építészeti képviselt ABACUS


Segítség más nyelveken

Navigáció: Bevezetés a ABACUS>

Segítség más nyelveken

Küldje el észrevételeit ebben a témában.

GOLYÓS SZÁMOLÓGÉP segítséget kaphat a különböző nyelveken / fordítások és letölthető az alábbi linkekre.

Hogy felváltani a jelenlegi ABACUS súgó fájltegy lefordított súgó fájlt kövesse a következő lépéseket:

1. Mentse el a súgó fájlt a megfelelő linkre.

2. Nevezze át a súgó fájlt ABACUS.chm.

3. Nyisd meg a fájlt dupla kattintással, és ha a "Fájl megnyitása - biztonsági figyelmeztetés" párbeszédablak jelenik meg, majd törölje a "Mindig kérdezd a fájl megnyitása előtt" opciót, majd kattintson a Megnyitás.

4. Zárja le a fájlt.

5. Cserélje ki a ABACUS.chm fájlt a ABACUS Program Files könyvtárban, általában "C: \ Program Files \ Avolution \ ABACUS" vagy "C: \ Program Files(x86)\ Avolution \ ABACUS".

hangjegy

Kontextus súgó továbbra is működni fog a lefordított súgó fájlt.

ABACUS segítségével fájlokat más nyelveken:

· arab / العربية .

· bolgár / български .

· Kínai (egyszerűsített) / 中文 (简体) .

· cseh / Česká .

· dán / Dansk .

· észt / Eesti .

· finn / Suomen .

· francia / Français .

· német / Deutsch .

· Magyar / magyar .

· izlandi / izlandi .

· indonéz / Indonézia .

· olasz / Olasz .

· japán / 日本 の .

· lett / Latvijas .

· Malajziai / Malaysia .

· máltai / Maláta i .

· Norweigen / Norweigen .

· lengyel / Po lska .

· Portugál / Português .

· orosz / русский .

· szlovák / Slovenskí .

· szlovén / Slovenski .

· spanyol / Ñoles .

· svéd / Svenska .

· török / Török .

· walesi / Cymraeg .

Lásd még

Mit jelent ABACUS csinálni?


Hogyan épül fel egy építészeti képviselt ABACUS?

Navigáció: Bevezetés a ABACUS>

Hogyan épül fel egy építészeti képviselt ABACUS?

Küldje el észrevételeit ebben a témában.

Ebben ABACUS, akkor modellezni az architektúrának. Az egyszerűség kedvéért nevezzük ezt építészeti modell egy olyan építészet.

Az alábbi ábra egy tipikus építészeti 5 alkatrészek (hierarchiájában) köti össze a 2. csatlakozások lennének képviselve ABACUS.

Hogyan egyszerű építészet képviselteti magát ABACUS

Tetszőleges számú architektúrák egyetlen ABACUS fájlt.

Az első építészet a fán

Jellemzően akkor hozzon létre egy új architektúra, amikor csak akarja, hogy értékelje a változás. Például azt modellezi a meglévő architektúra első - ez lenne az első építészet a fán. Lehet, hogy ezt "Aktuális".

A második

Ha azt szeretnénk, hogy modellezni és értékeli a változást a meglévő architektúra (pl megnövekedett követelmények) azt hozzon létre egy új architektúra. A legegyszerűbb módja ennek az lenne, hogy hozzon létre egy példányt a "Jelenlegi", és nevezze át "Evolution 1 Kísérlet 1". Ez lenne a második architektúra a fán. Ha értékelését "Evolution 1 Kísérlet 1" sikeres, akkor nevezd át egyszerűen "Evolution 1".

A harmadik

Ha "Evolution 1 Kísérlet 1" nem felel meg a követelményeknek, akkor létrehozhat egy példányt belőle, nevezd át "Evolution 1 Kísérlet 2", és próbálja újra. Ez lenne a harmadik építészet a fán.

Lásd még

Mit jelent ABACUS csinálni? | Hogyan csinálod (áttekintés) | Mi az építészet? | Munka ABACUS fájlok | Létrehozása vagy párhuzamosan egy olyan építészet


Hogyan kell használni ABACUS (áttekintés)

Navigáció: Bevezetés a ABACUS>

Hogyan kell használni ABACUS (áttekintés)

Küldje el észrevételeit ebben a témában.

Ez a témakör alapvető áttekintést a feladatokat használatával ABACUS.

Az alábbi ábra szemlélteti a architektúrára épülő elemzési folyamat, hogy ABACUS rendelkezik fejlődik a jelenlegi szerkezet egy új vagy célarchitektúra.

Az ABACUS folyamat

Ahhoz, hogy használni ABACUS:

1. Könyvvizsgálat - Mielőtt használni ABACUS, meg kell gyűjteni az összes információt, amit az építészetről, és annak követelményeit.

· Építészet - Meghatározza az esetleges komponensei építészet és hogyan hatnak egymásra. Csak akkor kell néhány összetevő, a legfelső szinten. Ezek az úgynevezett "alapvető összetevői". Még a legösszetettebb architektúrák kevesebb mint 10 lényeges elemeket. ilyen például. Az alapvető összetevői a biztosító társaság architektúra lehet politikák, nyugták, követelések, és a kifizetések.

· Követelmények- Tudnunk kell, hogy mi várható az architektúra meghatározása érdekében, ha ez kielégítő. ilyen például. Tranzakciók száma óránként.

· Hol találja meg? - Ez az információ származhat követelmények leírások, tervezési dokumentumok, interjúk az érdekeltekkel, a telepített kódot, stb Alapvetően olyan anyagot, amely elérhető kínál ABACUS információkat az architektúra.

2. Benépesít -Használja ABACUS modellezni a építészet és a követelmények meghatározása az építészet vonatkozásában mérik.

· Építészet - Ebben ABACUS ha elindul egy üres építészet - meg kell benépesít azt. Ez azt jelenti, belépő minden architektúra összegyűjtött adatokat feletti. Tudod feltölteni építészet manuálisan (a jobb egérgombbal a menü), vagy tudod feltölteni azt automatikusan (a Microsoft Visio, Excel, Access, stb). Jellemzően a legfelső szinten (elvontabb) az architektúra fognak megjelenni kézzel, és az alsó szinten (konkrétabb) fognak megjelenni automatikusan.

· Követelmények - Ahogy hozzá az összetevők és a kapcsolatok, akkor adja meg a tulajdonságaikat. A legtöbb esetben ezek a tulajdonságok lesz a követelményeknek az építészet. Például, ha lesz egy 1250 MIPS node / cluster, akkor hozzáadja a csomópont összetevőjeként, majd hozzáadjuk a teljesítményt ingatlan, és hozzá egy értéket 1250 MIPS.

3. Elemezze - Használja ABACUS elegánsan elemezni és megjeleníteni a komplex szerkezete a építészet. Te elemzi a építészet számos módon, vagy a több nézőpontból, beleértve a diagramok, 3D és Explorer. Másik lehetőség, hogy használni szeretnénk néhány specifikus nézetek a következők:

· Chart építészet -, hogy a teljesítmény (válaszidő, sávszélesség, stb), költsége (bár, pite, stb), vagy evolvability (képesség tér, trade-off, stb) nézeteit.

· Hozzon létre egy jelentést az adott architektúrán.

4. Szimulálni - Használja ABACUS szimulálni az architektúrának teljesítményét, a rendelkezésre álló, a költségek, a nyitottság, stb

· Ehhez futtassa az egyik szimulátorok. ABACUS értékeli a építészet ellen a követelményeknekelvégzésével szimuláció. Olvassa és elemzi a jelenlegi architektúra, fut szimulációk, és kiszámítja néhány új tulajdonságokkal. Ezeket a tulajdonságokat, majd vissza is menthetők az architektúra. Az új tulajdonságok az adatokat próbál elemezni, mint a hasznosítás, válaszidő, sávszélesség,% rendelkezésre állás, TCO stb

5. Mérnök- A ABACUS válaszolni a különböző "mi lenne ha" forgatókönyvek és ellenőrzik az alakulását a építészet. Engineering az a folyamat, megismételve a Népességnövekedés - Elemezze - szimulálása ciklus.

· Ezen a ponton, akkor"veValószínűleg fejlődött, hogy értik a jelenlegi szerkezet és kiemelte azokat a területeket meg kell fejlődni. Elég gyakran, de akkor meg kell ismételni a betelepítés - Elemezze - szimulálása folyamat során számos alkalommal. Ez valószínűleg azért, mert lehet, hogy csak pár ismétléseket, mielőtt megtalálja a célarchitektúra. Továbbá, ha a architektúra nagyon bonyolult, érdemes megismételni a műveletet minden egyes építészeti "szinten".

6. TervA jövőben az építészet segítségével által szolgáltatott információk ABACUS.

hangjegy

Ha nem próbál fejlődni egy meglévő architektúra, lehet, hogy meg kell ismételnie néhány lépést többször, és más sorrendben. Ez attól függ, mit akarsz csinálni. Például, ha tervezése egy új architektúra, akkor valószínűleg csak feltölteni építészet egyszer, majd ABACUS hosszú ideig, hogy irányítsák a jövőbeni alakulása (ek) az architektúra. Másrészt, ha vásárolnak egy új építészeti és több alternatíva közül lehet választani, akkor kell felfedezni, és feltölteni az egyes alternatívák, majd elemzése és szimulálása mindegyik önállóan, mielőtt végrehajtaná a végső összehasonlítás végén.

Lásd még

Mit jelent ABACUS csinálni? | Mi az építészet? | Hogyan épül fel egy építészeti képviselt ABACUS? | Benépesítő az architektúrának | Elemezve az architektúrának | Szimuláló az építészet


Importáltak a Építészet

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Importáltak a Építészet

Küldje el észrevételeit ebben a témában.

ABACUS lehetővé teszi, importálni Ön építészet egy .abacus (ABACUS fájl), .xml (az ABACUS XML fragmentum vagy ArchiMate Interchange Nyelv XML fájl), .VSD (Microsoft Visio) formátumban, valamint .xls (Microsoft Excel) formátumban. Ez lehetővé teszi, hogy készítsd el építészet külső forrásból gyorsan.

Hogy behozatali Ön építészet ból ből.abacus (ABACUS fájl)

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Jobb klikkA Építészet csomópont, minden építészet a modell vagy bármely részét a komponensek fa.

3. Válassza ki Import| Ból ből Fájl ...a menüből.

4. Válasszon egy helyet, és A .abacus akta és kattintson a Nyisd ki gomb.

hangjegy

Miután kiválasztotta a kívánt fájlt importálni, kérni fogja, hogyan szeretné importálni a szabványok, típusokés nézőpontok. Akkor lehet importálni szabványok, típusok és nézőpontok például új vagy összevonták szabványok, típusokés nézőpontok. Az alapértelmezett beállítás a szabványok, típusok és nézőpontok hogy összevonják a meglévő szabványokkal, típusok és nézőpontok ha már léteznek (ugyanazzal a pontos neve) Ön program.

Hogy behozataliÖn építészet ból ből.xml (egy ABACUS XML fragmentum vagy ArchiMate Interchange Nyelv XML fájl)

1. Győződjön meg arról, hogy van egy ABACUS fájl nyisd ki.

2. Jobb klikkegy Építészet csomópont, minden építészet a modell vagy bármely részét a komponens fa.

3. Válassza ki Import| Ból ből XML ...a menüből.

4. Válasszon egy helyet, és Az .xml fájlt, és kattintson a Nyisd ki gomb.

hangjegy

ABACUS csak importálni egy megfelelően kialakított ABACUS XML töredék vagy ArchiMate Interchange Nyelv XML fájl. Miután kiválasztotta az XML fájlt importálni kívánt, kérni fogja, hogyan szeretné importálni a szabványok, típusokés nézőpontok. Akkor lehet importálni szabványok, típusok és nézőpontok például új vagy összevonták szabványok, típusokés nézőpontok. Az alapértelmezett beállítás a szabványok, típusok és nézőpontok hogy összevonják a meglévő szabványokkal, típusok és nézőpontok ha már léteznek (ugyanazzal a pontos neve) Ön program.

Hogy behozataliÖn építészet ból ből.VSD(Visiofájl)lát itt .

Hogy behozataliÖn építészet ból ből.xls (Excel fájl)lát itt .


Importáló típusok és szabványok egy könyvtárból

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Importáló típusok és szabványok egy könyvtárból

Küldje el észrevételeit ebben a témában.

Akkor lehet importálni típusok és szabványok egy ABACUS könyvtár fájl. Azt is export típusok és szabványok az Ön ABACUS fájlt egy ABACUS könyvtár fájl.

Importálni típusok és szabványok a könyvtár az Ön építészet

1. Győződjön meg arról, hogy van egy ABACUS fájlnyílt és a Explorer ablak Megjelenik.

2. Válassza a Fájl | Nyisd kinyitni ABACUS könyvtár fájl.

3. Az ABACUS Könyvtár megnyílik egy második fülében az Explorer ablakban, és akkor meg kell dokkolásoldásához ezt a fülében hogy képes legyen drag-and-drop belőle, hogy az eredeti ABACUS fájlt.

4. Drag-and-droptípusok és szabványok a könyvtárat az architektúrának.

- vagy -

1. Válassza a Fájl | Új ...

2. Hozzon létre egy új ABACUS fájlalapul ABACUS könyvtár fájl.

Exportálni típusok és szabványok az Ön építészetet könyvtár

1. Győződjön meg arról, hogy van egy ABACUS fájlnyitott, a Explorer ablakMegjelenik egy ABACUS könyvtár fájlnyílt és a Könyvtár Ablak Megjelenik.

2. Drag-and-droptípusok és szabványok az Ön építészet be a könyvtárba.

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel


Az ABACUS interfész

Navigáció: Bevezetés a ABACUS>

Az ABACUS interfész

Küldje el észrevételeit ebben a témában.

Amikor elkezdi ABACUS, látni fogja a fő képernyőn, ami üres, kivéve a menük és eszköztár tetején, egy üres Explorer ablakot, és a cím-bár. Ez a képernyő lesz a központja a kölcsönhatás ABACUS.

A fő elemei a következők:

· A fő menü

· Az eszköztárak

· a jobb klikk menü

· A felfedező és ingatlan ablakok

· Az állapotsorban

A fő menü

A menük elrendezése logikus sorrendben.

A menük a következőképpen írja le;

· Fájl menü- A Fájl menü lehetővé teszi, hogy, nyitott, szoros, kivéve, export és kihirdetik ABACUS fájlokat. Azt is lehetővé teszi, hogy hozzon létre, nyitott, szoros, és mentse ABACUS Könyvtár fájlok.

· Szerkesztés menü- A Szerkesztés menü segítségével kivágás, másolás, beillesztés, törlés, átnevezés, megtalálni és rendezni elemekés Undo / Redo műveleteket.

· Nézet menü- A Nézet menü segítségével nyissa vagy zárja a különböző interfész Windows és a status barNavigáljon előre és hátra, menj a specifikus nézetek és kezelése műszerfal.

· Beszúrás menü- A Beszúrás menü lehetővé teszi, hogy új szabványok, Sablonok, típusok, elemek, kilátásponts, Katalógusok, ábrák, táblázatok, Jelentések és mátrixok.

· Elemzés menüben- Az elemzés menü segítségével futtatni értékelések ellen építészet, beleértve; teljesítmény, a költségek, a megbízhatóság, a modularitás és a nyitottság.

· Eszközök menü- Az Eszközök menü lehetővé teszi, hogy futtatni scripting, A meghatározott célok az építészetés végezze el és az építészet "diff". Akkor is módosíthatja a program lehetőséget és a kezelőfelületet a Eszköz menüből.

· Ablak menü- Az Ablak menü segítségével dokkol, elrendezése, megjelenítése és elrejtése ablak van nyitva.

· Súgó menü- A Súgó menüből elérheti ezt a ABACUS súgó fájlt. Elérheti a honlap, tekintse meg engedély megállapodást, és tekintse meg az általános részleteket ABACUS beleértve a verzió a szoftver és ABACUS támogatást és elérhetőségeit. Tudod visszajelzést adnak át a kérdést értesítést oldalon. Ha szükséges, akkor adjon meg egy regisztrációs kulcsot keresztül a Súgó menü.

Ez a sorrend akkor általában követik, ha éppen elvégzése a feladatok;Miután létrehozott vagy megnyitott egy akta, Akkor általában feltölteni építészet, majd Kilátásez (az Intézőben, diagramok, 3D, grafikonok, stb). Ezen a ponton, akkor sem futtathatja értékelő, Vagy akkor ismételje meg az eljárást az azonos architektúra, vagy más architektúrát. (Lásd Hogyan kell használni ABACUS (áttekintés) a további részleteket.)

Tekintse meg a főmenüt próbálja meg elképzelni, hogyan fog alkalmazza őket a rendszer.

hangjegy

tudsz Testreszabása menük bármikor.

Az eszköztárak

Alapértelmezésben vannak a következő eszköztárak;

· A Fő eszköztár -

· a Szimulációs eszköztár -

· A Nézet eszköztár -

· a Diagram eszközbár (ha diagram nyitva) -

· A Makró Felvétel eszköztár -

Tekintse meg a gombokat minden egyes eszköztár lebeg felettük, hogy a szerszám csúcsa (shortcut-key).

hangjegy

Csak bizonyos gombok aktív lesz attól függően, hogy mit választott ki az Explorer ablakban, és akkor Testreszabása eszköztárak bármikor.Emellett a "érvényesítése / Check Project Megszorítások" gombra a Fő eszköztár és a gombokat a szimulációs eszköztár kiemeli Piros amikor a változás, hogy a mögöttes adattár igényel ismételt ellenőrzése, a projekt vagy ismételt szimulációja, hogy szimulátor volt. Az egérmutatót a gomb, hogy melyik architektúrát érint.

A jobb egérgombbal a menü

A fő menük és eszköztárak nemhasználják mindent, mégis. Gyakran sokkal kényelmesebb használni a jobb klikk menüből különféle műveleteket. (Továbbá, nem minden rendelkezésre álló parancsok segítségével a jobb gombbal elérhetőek a fő menüket, eszköztárakat, vagy a billentyűzet parancsokkal.)

Például, ha egyszer már létrehozott egy fájlt, és van egy faszerkezetű diagram az architektúrának, akkor jobb, ha a jobb gombbal a architektúrák a fán, hogy egy új architektúra. Hasonlóképpen, akkor kattintson jobb gombbal az összetevőkről, hogy az új alkatrész. Kattintson a jobb gombbal egy pár dolgot a fát, hogy mit lehet csinálni.

Tipp

Általában akkor használja a fő menük végre a több magas szintű feladatok, mint értékeli a architektúrát. Az alacsony szintű feladatok - mint a hozzá egyes összetevők és összeköttetések - kész az eszköztárak és / vagy a jobb egérgombbal a menü.

A felfedező és ingatlan ablakok

Amikor megnyit vagy hozzon létre egy fájlt, egy fa diagram jelenik meg az Explorer ablakban. Ez egy ablak a architektúrát. És ahogy kiválasztja az elemeket a Explorer ablakot három Más ablakok; Általános tulajdonságok, Irodalomés a Tulajdonságok ablak frissítésre kerül részletes információkat a választás.

hangjegy

Az Általános tulajdonságok, Irodalomés a Tulajdonságok ablak alapértelmezés szerint rejtettek. Lásd Egyéni interfész hogyan kell elrejtésére és potenciálisan hagyja őket állandóan látható.

Míg építünk az architektúrának, az Explorer és a Tulajdonságok ablak a leghasznosabb képviseletét. Mert lehet összecsukott és kibontott szükség, és nem nehézkessé válhat.

Az Explorer ablak van egy fa (és a Status bar), és a Tulajdonságok ablakok 5szakaszok:

· típus

· Szabványok

· Leírás

· Referenciák

· Tulajdonságok

ABACUS úgy véli, mindezek a dolgok, hogy része legyen az építészet.

Fa

Ez a szakasz egy fa csoportosítva 3-nak alábbiak szerint:

1. Meta-modell

· Szabványok- Ha több komponensek ugyanazokat a tulajdonságokat, akkor definiáljuk az induló, és aztán csak rendelje hozzá az alkatrészeket. Ugyanez vonatkozik a kapcsolatok és bármely más elemek. Ezek a készletek a szabványos tulajdonságok vannak tárolva a Szabványokága a fa. Meghatározása helyett minden ingatlan minden alkatrész, és minden ingatlan minden kapcsolat stb, csak rendelni egy standard. Például a standard jellemzőit Unix-HP / UXlehet megtakarítani, mint a Standard és rendelt olyan alkatrészek felhasználásával Unix-HP / UXoperációs rendszer látható a OS01 szerver a screenshot felett.

· Típusok - Ez ágon szintén egy könyvtár a fajta alkatrészek és csatlakozások használhatja. A típusok meghatározására használt meta-modell és az architektúrának és az osztályozás és szűrést, ha megtekinti az építészet. Azt is meghatározza egy sablont, amit szabványok, Tulajdonságok és korlátok az összetevők / kapcsolat esetén sem lehet.

· Nézőpontok- Kilátásponts hozhatók létre a meglévő rajzok és fel lehet használni, hogy új diagramok.Ezek rajz sablonok.

· Sablonok - Sablonok áruház újra használható minták alkatrészek és csatlakozások mellett a módját képviselik vagy megtekinthető. Ők is gondolt, mint "mini" architektúrák és megoldások, hogy lehet helyezni a meglévő architektúrák.

2. Architektúrák -A architektúrák ág A fa, ahol építeni a építészet (k) a rendszer. (Ezt nevezik benépesítő építészet.) Tetszőleges számú architektúrák egyetlen ABACUS fájlt.

3. Dashboards - A Dashboards ága a fa, ahol elérheti mentett műszerfalak a projekt.

hangjegy

Tételek az Intézőben fa, de nem saját Frissítés engedélye távolítani (azaz csak olvasható) szürkén jelennek meg.

típus

Ez a szakasz jelöli az adott alkatrész vagy összeköthető az aktuálisan kiválasztott elem a fa.

Szabványok

Ez a szakasz egy listát a szabványok az aktuálisan kiválasztott elem a fa.

Leírás

Ez a rész egy rövid leírást a kijelölt elemet a fa. Bármely kapcsolódó linkeket is bővül ez a szakasz. Ezek közé tartozik a weboldalak vagy a helyi abszolút útvonalakat mutat, hogy további információkat az adott elem. Több vonal is megengedettek. Érvényes hivatkozásokat kell kezdeni egy 5 húrok; http: //, https: //, ftp: //, file: /// vagy mailto :.

Tipp

A linkeket a terek, a felhasználók írja be az URL-t vagy elérési utat, válassza ki a kívánt szöveget, és Jobb klikk| Hiperlink. Ez meg fog változni minden szünetet % 20így az egész URL-t vagy elérési út helyesen fog működni.

Létrehozhatók és módosíthatók

Ezek szakaszs ada felhasználó és a dátum / idő létrehozására, és az utolsó módosítását, Az aktuálisan kiválasztott elem a fa.

Referenciák

Ez a szakasz egy listát a kimenő és bejövő alkatrészek az aktuálisan kiválasztott elem a fa.Ez is mutatja, a rajzok, 3D és kör véleményét, hogy az aktuálisan kiválasztott elem megjelenik. Ha egy rajz van kiválasztva azt mutatja, a Nézőpont adott esetben a rajz és a nézetek általában ez minden Dashboards a nézet jelenik meg. És amikor egy standard van kijelölve a fán azt mutatja, a használata a standard típusok szerint, valamint csatlakoztatása.

Tulajdonságok

Ez a rész az, ahol jellemzőinek meghatározására az elemek belül Ön építészet, mint ahogy szükség van rá, hogy végre, a sorok száma a kódot azt az aránya, ezek a vonalak, amelyek kommentek, stb

A "bemeneti" és "kimeneti" tulajdonságait előre elkészített szimulátorok jelenik meg a Tulajdonságok ablakot egy ingatlan beviteli sorban választó ikon ( [image] ) És kimeneti ikon ( [image] ), Illetve egy tooltip jelzi, mely előre beépített szimulátor az ingatlan kapcsolódik, pl "A modularitás Output" vagy "Performance Input". A nyíl a kimeneti ikonok kiemeli Piros ( [image] ), Ha az ingatlan elavult miatt szolgáló ingatlan vagy szerkezeti változás, hogy az adattár a szimulátorral igénylő újra szimuláció szerint Piros kiemelve a Szimuláció eszköztár .

Az állapotsor

A bal oldali részét állapotsor mutatja a teljes elérési utat a jelenleg fókuszban adattár elem, vagy kiválasztott Explorer ablak, illetve a diagram vászon. Ez azért van így, hogy a pontos helyet a tároló hierarchiában az adott elem mindig határozhatók meg könnyen. A jobb oldali részén a csík mutatja, különböző működési üzenetek, mint például a "nyílt ABACUS Fájl sikeres" és "ára Befejezett '.

Lásd még

Hogyan csinálod (áttekintés) | Egyéni interfész | Mi az építészet? | Hogyan épül fel egy építészeti képviselt ABACUS? | Munka ABACUS fájlok


Mit jelent ABACUS csinálni?

Navigáció: Bevezetés a ABACUS>

Mit jelent ABACUS csinálni?

Küldje el észrevételeit ebben a témában.

Ha segítségre más nyelveken / fordítások kattintson itt .

ABACUS úgy találgatás ki foglalkozó megoldások, rendszerek, szoftverek, információk, technológia, üzleti folyamatok és / vagy az egész vállalkozás (a továbbiakban együtt architektúrák). Ez segíthet, hogy pragmatikusan tervezni, figyelemmel kíséri, szimulálják, elemzése és megjelenítése építészet modellezési meg, elemezve azt intuitív módon (pl táblázatok, diagramok és 3D) és értékelésére, ez ellen nem funkcionális követelményeknek.

hangjegy

Nem funkcionális követelményekazok a követelmények, amelyek nem kapcsolódnak közvetlenül az, hogy egy termék működik. Ehelyett arról van szó, hogy milyen jól működik. Nem funkcionális követelmények közé olyan dolgok, mint a teljesítmény, a nyitottság, evolvability, minőség, skálázhatóság, modularitás, stb (szemben a funkcionális követelmények, mint, kapcsolja be ezt a fényt, ha erre a gombra kattint). Hagyományosan, nem funkcionális követelmények lett volna nehéz - ha nem lehetetlen - mérni. Tény, hogy ABACUS az egyetlen olyan termék, amely objektíven és mennyiségileg mérni az első három - teljesítmény, nyitottság, és evolvability.

Egyszerűen fogalmazva, ha be az architektúra és mit szükséges a használata. ABACUS majd megmondja, ha ez is megteszi a szükséges eszközökkel és rámutat az esetleges hiányosságok, vagy hiányos.

ABACUS merít több mint 20 éves rendszerek kutatása és még sok éven keresztül létrehozott rendszerek elmélete. Ez adja számszerűsíthető, megbízható, objektív választ, így már nem épül a szubjektív értékelést.

ABACUS jelentése Architecture-Based Analysis, Cjáratú és UnderstandingA Systems. Ez segíthet bármilyen nagyszabású építészeti, de ez általában négy (4) dolgot:

· FormálódóA jelenlegi szerkezet. Például, ha a meglévő épületek nem a teljesítmény, ABACUS fogja megjeleníteni az architektúra az Ön számára, a problémák feltárására (szűk, stb), majd megmondja pontosanhogyan lehetne javítani az architektúra.

· Tervezésegy új architektúra. Például, ha szüksége van egy teljesen új architektúra, és te tervezése magad, ABACUS fogja mondani, pontosanmilyen összetevők van szüksége, és hogyan kell csatlakoztatni.

· Beszerzésiegy új architektúra. Például, ha közbeszerzési pályázatot írt ki a design egy új architektúra, és te közötti választás három tervez, ABACUS fogja mondani, pontosanmelyik illik az Ön igényei legjobb.

· Ötvözijelenleg meglévő architektúrák. Például, ha kell össze két vagy több különálló architektúrák, ABACUS végigvezeti Önt.

Lásd még

Hogyan csinálod (áttekintés) | Mi az építészet? | Hogyan épül fel egy építészeti képviselt ABACUS?


Kapcsolatok segítségével a diagramok

Navigáció: Népszerű az architektúrának használata> Rajzok>

Kapcsolatok segítségével a diagramok

Küldje el észrevételeit ebben a témában.

Alakzatok (szabad formában és alkatrészek) és csatlakozók (szabad formában vagy kapcsolatok) belül diagramok köthető a meglévő építészeti képviseletek ABACUS, valamint a külső fájlok / mappák és URL-eket. Ezek a kapcsolatok aztán sikerült (létrehozni, módosítani és törölni) keresztül ABACUS eszközkészlet. Ez a funkció használható, hogy fokozza a hajózás és teljes megértése az architektúrának vázlatosan.

A linkeket a rajz

1. Meg arról, hogy egy létező rajz nyitott .

2. Válassza ki a megfelelő alakú vagy csatlakozó az Ön rajz.

3. Jobb klikkaz alakvagy csatlakozó.

4. Válassza ki Nyílt linkekés egy Linkekablak.

5. Kattints a Addikon és egy Új linkablak.

6. Válassza ki a megfelelő Katalógus | Matrix | Diagram| 3D nézet| Diagramrádió gombot, majd válassza ki a megfelelő katalógus, mátrix, diagram, 3Dvagy diagram Tekintettel a jelenlegi szerkezet a Link To legördülő menü.

- vagy -

6. Válassza ki a Weboldalrádió gombot, majd adja meg a megfelelő URL- (például http: //www.avolutionszoftver.com /)területén link egy weboldalra. Érvényes URL kell kezdeni az egyik 5húrok; http: //, https: //, ftp: //,fájl: vagy \\. Szóközt kell beírni a "% 20".

- vagy -

6. Válassza ki a Abszolút File | Relatív Fájl Rádiógombs,majd kattintson a "..."Gombbal, a külső fájlt a linket a diagram.

7. Kattintson okéés az új link jelenik meg a linkek ablakban. Megjegyzés: A hivatkozások ablakban lehet átméretezni, hogy a teljes nevét, ha szükséges.

8. Ismételje 5-7hogy több kapcsolatot.

9. Követni a teremtett kapcsolatot, válassza ki a megfelelő linkre jelenik meg a Linkekablakot, és kattintson Link megnyitása.

hangjegy

Amikor több kommentárok is látható egy alakja, vagy csatlakozó a link jelenik meg az első feljegyzés listáját feljegyzéseit a Szerkesztés Jegyzetek párbeszédablakban.

Ha követni linkeket a rajz

1. Meg arról, hogy egy létező rajz nyitott .

2. Válassza ki a megfelelő alakú vagy csatlakozó az Ön rajz.

3. Kattintsonaz érintett hivatkozást (kék aláhúzott összetevő neve) egy alak vagy csatlakozó A rajz megnyitásához és megtekintéséhez az első link alakjátólvagy csatlakozó.Megjegyzés: A kurzor átvált egy "kéz", amikor a kapcsolat készen kell kattintani.

- vagy -

3. Válassza ki a megfelelő alakú vagy csatlakozó az Ön rajz.

4. Jobb klikkaz alakvagy csatlakozó.

5. Válassza ki Nyílt linkek és a Linkekablak.

6. Válassza ki a megfelelő linkre, hogy szeretne megtekinteni.

7. Kattints a Link megnyitásagombot, hogy megnyissa és tekintse meg a megfelelő linkre.

Ha törölni linkek a rajz

1. Meg arról, hogy egy létező rajz nyitott .

2. Válassza ki a megfelelő alakúvagy csatlakozóaz Ön rajz.

3. Jobb klikkaz alakvagy csatlakozó.

4. Válassza ki Nyílt linkek és a Linkekablak.

5. Válassza ki a megfelelő linkre, hogy törölni kell.

6. Kattints a Töröl gomb. és a kapcsolat eltávolítjuk a Linkek ablak.

Szervező linkek a rajz

Kiválaszthatja, hogy melyik kapcsolódik rajz, külső fájl vagy weboldal URL jelenik meg, amikor egy alak címke Ctrl + kattintás az ábra.

1. Meg arról, hogy egy létező rajz nyitott .

2. Válassza ki a megfelelő alakú vagy csatlakozó az Ön rajz.

3. Jobb klikkaz alakvagy csatlakozó.

4. Válassza ki Nyílt linkek és a Linkekablak.

5. Módosítani a sorrendben a linkek kattintson A Feljebb | Move Downgombok a jobb oldali a Linkek ablak.

6. Az első link, hogy megjelenik a bal oldali Linkekablak a linket, amely megjeleníti, ha Ctrl + kattintáshiperlink alakja vagy csatlakozó név.

Lásd még

Benépesítő az architektúrának | Benépesítő az architektúrának kézzel | Elemző Ön építészet


Manipuláló diagramok

Navigáció: Népszerű az architektúrának használata> Rajzok>

Manipuláló diagramok

Küldje el észrevételeit ebben a témában.

Egyszer egy rajz jött létre, az elemek jelennek meg lehet átrendezték, és újra méretű, mint kívánatos.

Mozgatni egy komponens diagram

1. Meg arról, hogy egy létező rajz nyitott .

2. Kattintson és tartsa lenyomvaBármely alkatrész mozgatni. Ha a kiválasztott komponens szülő, a szülővel komponens lesz kiemelve.

3. Ahogy az elemvonszolta a szülő alkatrész, és több mint más alkatrészek, "potenciális" szülők jelölődni. Színsémájának jelzi a hatását a művelet lesz a figyelmeztetések és hibák a jelenlegi projekt, és ismerteti Meghatározása és érvényesítése Megszorítások . Ily módon, grafikusan navigálni a hierarchia egy "felülnézetben".

4. KiadásAz egér gombját, hogy ejtse az elem az új helyen.

hangjegy

Ön is használja a billentyűzetet, hogy újra helyzetbe elemek a rajzon vásznon. Egyszerűen válassza ki az alkatrészt vagy szabad formában alakját szeretné mozgatni, és használja a nyilakat található a billentyűzeten mozgatni az alakzatot a kívánt helyre.

Szintén fontos megjegyezni, hogy ha húzva egy alkatrész a képre az egeret egy másik összetevő, a "potenciális" szülő alkatrész ki van jelölve, amikor a bal felső sarokban a komponens húz átfedésben egy másik összetevő.

Tipp

Mentes és Lebegő formák Megrendelhető jobb gombbal kattintvaés kiválasztja Előre hoz vagy Hátraküldésa menüből. Fontos megjegyezni, hogy a komponens alakzatok lehet alakítani szabadkézi alakzatokat jobb gombbal kattintvaspeciális alkatrész formájában, és kiválasztja Átalakítás Freeform.

Átméretezése komponens diagram

1. Meg arról, hogy egy létező rajz nyitott .

2. Click-hold-dragaz egyik komponens kezeli, és átméretezni a forma a kívánt méretet.

3. Alternatív fenntartani a forma képarány, nyomja Shift + kattintás-hold húzás.

Mozgatni a kapcsolatot egy rajz

1. Meg arról, hogy egy létező rajz nyitott .

2. Kattintson és tartsa lenyomvaminden kapcsolatot mozgatni.

3. KiadásAz egér gombját, hogy ejtse az elem az új helyen.

hangjegy

Egyszerre csak mozgatni kapcsolatok, melyek nem kötődnek az alkatrészeket. Ha azok kapcsolódnak, csak akkor tudjuk mozgatni a szabad végs, vagy toron a kapcsolatot .

Törlése valamint csatlakoztatása

Amikor töröl egy alkatrész vagy kapcsolatot egy diagramot, akkor azt a lehetőséget, hogy eltávolítja a teljes architektúra. Bármely komponens, amely törli az architektúra automatikusan törlődik minden más diagramok, ha úgy tűnik. Mivel szabadkézi esetekben csak akkor jelennek meg egy diagramon, törlése őket nem befolyásolja az építészeti modell, vagy bármely más diagram.

Törölni egy alkatrészt vagy kapcsolatot egy rajz

1. Meg arról, hogy egy létező rajz nyitott .

2. Kattintsonbármely kapcsolódó kapcsolat vagy alkatrész válassza ki.

3. Nyomja meg a Törölgombot, hogy törölje azt a rajzot, vagy Shift + Deletehogy eltávolítja a teljes modell.

- vagy -

2. Kattintson a jobb gombbal bármelyik kapcsolódó elem vagy komponens. A helyi menü jelenik meg.

3. Válassza ki Törlés a Nézet vagy Törlés a Építészeta helyi menüből.

hangjegy

Ha az elem, amely a törölni kívánt szemszögéből nincs gyermeke, és csak jelentkezik a nézetet, ABACUS megkérdezi, hogy törölni szeretné az elem a tárolóból is.

Vigyázat

Ha törli egy komponenst a modell, amely a gyermek elemek, a gyerekek is potenciálisan törölni szerint a figyelmeztető ablakot.

Egyesülő Components

Érdemes lehet egyesíteni a két komponens meglévő ugyanazon a diagramon (és ezen belül az architektúra). Ez elvégezhető számos okból, például, Két szerver létezik egy cég, infrastruktúra-H01 és a H02. Ez a két szerver képviseletében a két külön részből architektúrán belül. H01 már szükségtelennek és így leszerelték. Minden meglévő futó alkalmazások H01 kell eltolódott a H02 (még jutalék). Ez a változás ezután tükröződik a keresetet a "egyesülő" a két komponens H01 és a H02 Az ábrán (és az építészet).

A részletes vitát egyesülő kérjük, olvassa el az egyesülő elemek téma itt .

Ahhoz, hogy összevonja a két meglévő alkatrészek

1. Meg arról, hogy egy létező rajz nyitott .

2. Kattintson a jobb gombbal nyomva tartásA komponens egyesíteni kívánt és ellenállásrá a kívánt összetevő beolvad a. Ellenőrizze, hogy a vázlatot a rendeltetési alkatrész van jelölve piros, jelezve, hogy be van jelölve.

3. Válassza ki Merge | Őrizze Destination vagy Felülírása Destinationa menüből.

hangjegy

A Őrizze Destinationbeállítás megőrzi az értékeket a rendeltetési összetevő tulajdonságait, ha létezik az eredeti komponenst is.

A Felülírása Destinationopció felülírja a cél komponens tulajdonságait minden közös tulajdonságokkal eredeti alkatrész.

Változó kapcsolatok

A bemutatott csatlakoztatási diagram mindigtükrözik a struktúra meghatározott építészet maga. A rajz eszköz lehetővé teszi, hogy leválassza kapcsolatok alkatrészek, mozgatni őket, görbe őket, toron őket és újra azokat csatolja egyéb alkatrészek.

Ha le akarja / csatolja a kapcsolatot / a komponens

1. Meg arról, hogy egy létező rajz nyitott .

2. Kattintson és tartsa lenyomvaminden kapcsolatot.

3. Válassza ki a kapcsolat vég (azaz. Source vagy Sink), Hogy szeretne leválasztani / tulajdonítanak. Megjegyzés: A kapcsolat végét jelzi, apró fehér körök és lebeg a fehér kör a második fog okozni "tooltip" jelenik meg a megfelelő szerep név(azaz forrás vagy nyelő).

4. DragA kapcsolat véget egy új helyre (akár egy üres helyre, vagy egy komponens) és engedje el az egérgombot.

hangjegy

Amikor egy kapcsolat vége fölé helyezzük egy érvényes összetevője, a vázlatot a rendeltetési alkatrész ki van jelölve egy szaggatott körvonalait. Színsémájának jelzi a hatását a művelet lesz a figyelmeztetések és hibák a jelenlegi projekt, és ismerteti Meghatározása és érvényesítése Megszorítások . Miután megjelent E célból a The csatlakozás és az alkatrész automatikusan csatlakozik(vagy csatolva), És ez tükröződik az építészeti modell.

Ahhoz, hogy újra útvonal kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Helyezze az egérmutatót a kapcsolatot.

3. Tartsa a Váltásgombot lenyomva és Kattintsonaz egérgombot, hogy tegyen egy kapcsolatot csomópontot. Engedje el a Váltás kulcsfontosságú. Akkor távolítsa el a csomópontot tesszük ugyanezt működését.

4. Kattintson és húzásA kikötési pont az útvonal a kapcsolatot.

Tipp

Használja aAlt kulcs helyett Váltáskulcsot létrehozni ortogonális kapcsolatokat.

Hogy görbe, vagy kiegyenesítenia kapcsolat

1. Meg arról, hogy egy létező rajz nyitott .

2. Helyezze az egérmutatót a kapcsolatot.

3. Jobb klikktő kapcsolatot, és a megjelenő helyi menüben válasszuk a Görbe, Ortogonális vagy Egyenes.

Tipp

Minden kapcsolatAz adott típusú, az ábrán állítható ívelt, ortogonális vagy egyenes jobb gombbal kattintva a hozzá tartozó sor a típus a Kapcsolatok fülreA Stencil ablakbanés kiválasztja a görbe, vagy egyenes ortogonális.

Hogy horgonyt rá egy adott ponton szélén egy forma

1. Meg arról, hogy egy létező rajz nyitott .

2. Válassza ki a kapcsolatot.

3. Helyezze az egérmutatót a "fehér dot 'végén az a kapcsolat.

4. Jobb klikktő kapcsolat végét, és a megjelenő helyi menüben válasszuk a Anchor Endpoint Alakzattá.Mozgasd a kapcsolat végét a vágy helyen szélén a forma.

VAGY

Tartsa a Ctrlgombot lenyomva és cnyalja és húzás a kapcsolat vége mutat A vágy helyen szélén a forma.

hangjegy

Összeköttetések dobott a tényleges lehallgatott a csatlakoztatott alakja helyett a befoglaló négyzetet, hogy alakja.

Lásd még

A rajz eszköz | Benépesítő az architektúrának | Elemző Ön építészet


Egyesülő elemek

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Egyesülő elemek

Küldje el észrevételeit ebben a témában.

Ha azt akarod egyesíteni elemeket?

Azt egyesíteni tételek, ha két (vagy több) objektumokat a modell, amely a legjobban képviseli egyetlen példány. Sok olyan helyzet, amikor érdemes ezt, többek között:

· Ennek eredményeként az importáló egy sor új információt a modellbe, amely megismételni vagy szorítani a meglévő információkat. Például, ha a behozatali frissített verzióját egy táblázatot a modellbe.

· Idővel másolatát az "azonos" komponens hoztak létre, és szeretné, hogy tisztítsák meg a másolatok.

· Ha végeznek a mi lenne, ha a forgatókönyv és a tételeket meg modellezzük ténylegesen összevonása a valóságban. Például, ha egyesülő két osztály a szervezet, vagy ha egyesülő két szerver.

Mit lehet egyesíteni?

Az alábbi típusú elemek támogatják egyesítették:

· Szabványok

· Komponens és csatlakozótípusok

· Alkatrészek és csatlakozások

Hogyan lehet egyesíteni tételek

Kezdeményezni egyesítés, használja a jobb egérgombot, húzza az egyik elem az Intézőben egy másikra. A tétel húz a forrása, és az elem, hogy húzza rá a cél. Ha elengedi a jobb egérgombbal, akkor megjelenik egy menü, ahol kiválaszthatja, hogy összevonja a két elem. Meg kell választani, hogy szeretné megőrizni, vagy felülírja a cél. Ezt az alábbiakban részletesen tárgyaljuk.

Az egyesítés jobb húzás menü

Mi a különbség a megőrzése és átírás a cél?

Az megőrizni, vagy felülírja az opció szabja meg, mi történik, ha a Név, Leírás, vagy a Tulajdonságok között a forrás és a cél tételek mérkőzést.

Ha Őrizze Destination választunk

· A célállomás nevét és leírását fogják tartani.

· Valamennyi tulajdonság, ami csak létezik a forrás hozzá a cél.

Ha felülírás Destination választjuk:

· A hely neve felülíródik a forrás.

· A célállomás Leírás felülíródik a forrás, hacsak a forrás leírása üres.

· Valamennyi tulajdonság, ami csak létezik a forrás hozzá a cél.

· Az érték és mértékegység tulajdonságaira hogy létezik mind a forrás és a cél felülíródik a forrás, hacsak a forrás értékét vagy egység üres.

Speciális esetek

· TípusokAmikor beolvadó típusok, a jogosultságok vannak vonva, a "pesszimista" módon, például ha a Engedély forrás nem létezik a cél, akkor kell hozzá, és ha létezett is a cél, akkor, ha az egyén engedélyt egy felhasználói csoport (Create, Read, Update vagy Delete) nem illik (egy sor, egy tiltott), akkor az engedélyt akkor lehet megtagadni.

· AlkatrészekAmikor egyesülő alkatrészek, az al-elemek a forrás költözteti a cél, és összemosódik alkomponenseket a cél, ha nevük azonos, Függetlenül azok típusától.Továbbá a többes alkomponensei a forrás az azonos nevű fogják össze egyetlen alkomponens a cél.

· Kapcsolatok: A felső szintű kapcsolatok maguknak kell mindkettőnek ugyanaz a mellékleteket (vagy annak hiánya) lehetővé kell tenni, hogy összevonják. Egyesítésekor kapcsolatok, az al-kapcsolat a forrás költözteti a cél, és összemosódik al-csatlakozás a cél, ha nevük azonos ÉSazok mellékleteit azonosak. Ha mellékletek nem azonosak, a forrás al-csatlakozás hozzá kell adni a cél nélkül egyesült megfelelő kapcsolatok már jelen van. Ez azért van így, hogy a mellékletek nem vesznek el.


Navigáció 3D rajz

Navigáció: elemezve az architektúrának> 3D rajzok>

Navigáció 3D rajz

Küldje el észrevételeit ebben a témában.

ABACUS segítségével könnyedén navigálhat az architektúrának 3D-ben. A tapasztalat hasonló repülő. Két mód navigáció:

· Alapvető vezérlési mód (alapértelmezett); és

· Advanced Control Mode - változás ebben az üzemmódban kiválasztja Ellenőrzés| Részletes vezérlési mód.

hangjegy

Ha váltani Basic vezérlése és fejlett vezérlési módok, akkor a F4gyorsbillentyű funkció.

Alapvető vezérlési mód

· Gazdaságban a bal gombot lenyomva tartva mozgassa az egeret előre vagy hátra megváltoztatja a pályán;

· Gazdaságban a bal gombot lenyomva tartva mozgassa az egeret balra vagy jobbra megváltoztatja az elfordulási;

· Tartja a jobb gomb és az egér mozgatásával serpenyők véli,;

· Tartod Mindkét gombot lenyomva és az egeret mozgatva előre vagy hátra, zoomol, és ki az architektúra; és

· Tartod Mindkét gombot lenyomva és az egér mozgatásával balra vagy jobbra, tekercsek, balra és jobbra.

- vagy -

· Nyomja meg a Bal nyílA vagy a numerikus billentyűzetet fog fordulni balra;

· Nyomja meg a Jobb nyílA vagy a numerikus billentyűzetet fog jobbra fordulni;

· Nyomja meg a Felfelé nyílA billentyűzeten vagy a numerikus billentyűzet nagyítás;

· Nyomja meg a Lefele nyílA vagy a numerikus billentyűzetet fog kicsinyítés;

· Megnyomásával Oldal felA vagy a numerikus billentyűzetet fog szurok fel; és

· Megnyomásával Lapozás lefeléA billentyűzeten vagy a numerikus billentyűzet pályán lefelé.

Részletes vezérlési mód

· MozgóAz egér előre-hátra, fel és le, megváltoztatja a pályán és a perdület (rendre);

· Megnyomásával W vagy Felfelé nyílráközelít (előre), hogy az architektúra;

· Megnyomásával S vagy Lefele nyíllekicsinyíti a (vissza) az architektúra;

· Megnyomásával A vagy Bal nyíltekercs balra;

· Megnyomásával D vagy Jobb nyíltekercs jobbra;

· Megnyomásával Q vagy Lapozás lefeléemeli a nézetet (csökkentve a szempontból); és

· Megnyomásával E vagy Oldal felcsökkenti a nézetet (megemelésével szempontjából).

Interaktív vezérlési mód

Lenyomva tartja a Shift gombotA billentyűzeten felülírja az aktuális mód (Basic vagy Advanced), hogy lépjen be az interaktív vezérlési mód. Ebben az üzemmódban a következő lehetséges:

· TekercsAz egérkurzort az alkatrész vagy kapcsolatot, hogy az alkatrész vagy a kapcsolat nevét;

· KattintsonEgy komponens hogy a nagyítás, hogy komponens;

· Kattintson és húzásEgy komponens forgatni a nézetet körül, hogy komponens; és

· Jobb klikkEgy összetevő vagy kapcsolat és válassza Megjelenítés az Intézőbenlátni, hogy az alkatrész vagy kapcsolat helyét a fán.

Közös ellenőrzések

· Használat ALT-ENTER / ESCváltás teljes képernyős módban;

· Használat F2hogy módosítsa a megjelenítési módot. Ez is elérhető a Kilátás Menü.

· Használja a egérgörgő vagy +/-a sebesség megváltoztatásához. A sebesség szám jelzi a bal alsó sarokban - csak akkor jelenik meg, ha ez változik. 1. a leglassabb és 100 leggyorsabb.


Nyitva diagramok

Navigáció: Népszerű az architektúrának használata> Rajzok>

Nyitva diagramok

Küldje el észrevételeit ebben a témában.

A rajz sablon és vászon ablakokat automatikusan megjelenik, amikor egy rajz megnyitásakor vagy létre. Hasonlóképpen, amikor egy diagram zárva van, a megfelelő fülében a vásznon ablak eltűnik, és ha további rajzok nyitottak, majd a sablon ablak zárva.

Hogy teremtÚj rajz

1. Győződjön meg arról, hogy van egyABACUS fájlmegnyitásitartalmazza a lakott építészet.

2. Kattints a Diagramikonra a Nézet eszköztáron.

- vagy -

2. Válassza ki Helyezze| Diagram.

- vagy -

2. Jobb klikk a Diagramokág egy adott Építészetrészben a fát, és válasszuk Teremt Diagram.

3. Válassza ki a Építészetszeretne összpontosítani a legördülő menüből. Megjegyzés: Az építészet már ki lesz jelölve, ha Ön alkalmazott fenti 3. lépés, hogy nyissa meg az új rajz.

4. Válassza ki a Nézőpont a használni kívánt a legördülő menüből. Megjegyzés: a választott nézőpont szűri a komponensek és a kapcsolatok listákat csak azok lehetnek elérhetők a szempontból.

5. Opcionálisan válassza a kilátás az Szűrés megtekintéselegördülő menüben előválasztó valamint csatlakoztatása a választott nézetben. Megjegyzés: ez hatékonyan használja a kiválasztott néző, mint egy mentett lekérdezés.

6. Válassza ki a Elrendezés hogy vagy Sugárirányú vagy Rács.

7. Válassza ki a Alkatrészek és Kapcsolatokkívánt az ábrán a szabvány elemkijelölési ablakban .

8. Kattintson oké.

hangjegy

Egy új diagram kerül adunk a Diagramokága az architektúra. Ez lesz az alapértelmezett nevet, ami megváltoztathatja később a jobb egérgombbal rajta.Továbbá, az utolsó állam, az alkatrész és a kapcsolat a kiválasztási szűrők mentésre kerül a rajz hatékonyan megtakarítás a "query" létrehozásához használt rajz.

Megnyitni egy létező rajz

1. A konkrét lakott építészet, bővítse a Diagramokága a fa.

2. Dupla kattintás A rajz a megnyitni kívánt.

Menteni a rajzot

1. Meg arról, hogy egy új vagy már meglévő rajz nyisd kiés elvégezte a szükséges módosításokat. Megjegyzés: A csillaggal '*' jelenik meg, miután a nézet nevére a fülében fejlécet, ha vannak olyan változások menti.

2. A felfedező nézetet, kattintson a Mentésgombot, vagy van, hogy Fájl| Mentésvagy nyomja le Ctrl + Smenteni a változtatásokat a építészet és írd fájlba.

Menteni a rajzot, mint egy nézőpont

1. Meg arról, hogy egy meglévő rajzot a ABACUS fájlt.

2. Jobb klikkAz ábrán a Diagramokrésze a fa.

3. Válassza ki Mentés másként Diagram Nézőpont.

4. Adjon meg egy nevet az új rajz szempontjábólés kattintson oké.

Lásd még

A rajz eszköz | Benépesítő az architektúrának | Elemző Ön építészet


Benépesítő segítségével katalógusok

Navigáció: Népszerű az architektúrának>

Benépesítő segítségével katalógusok

Küldje el észrevételeit ebben a témában.

A katalógus lehetővé teszi, hogy megtekintheti és szerkesztheti alkatrészek vagy a csatlakozások és tulajdonságaik egyszerű táblázatos módon.

Hogy hozzon létre egy új katalógus megtekintheti a GOLYÓS SZÁMOLÓGÉP

hangjegy

Bár minden Építész felhasználók hozhatnak létre új katalógusok, hogy mentse a változtatásokat, hogy egy meglévő Katalógus beállításait a felhasználói engedély szüksége a tervező add-on képesség. Ez a "védelem" a konfigurációs meglévő katalógusok, hogy meg lehet osztani a sok felhasználó. Azonban építész használja anélkül, hogy a tervező add-on is választhat a "Mentés másként" bármely új beállításokat egy új katalógus. És természetesen az összes felhasználói engedélyek választhat, hogy "megválni" bármilyen változás egy meglévő katalógus. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége A tervező add-on képesség. És ne feledd, hogy ez csak a beállításokat a katalógus, minden módosítást tett az adatokat a katalógus azonnal alkalmazni a tárolóból, függetlenül.

1. Válassza ki a Beszúrás | Katalógus.

2. A <Építészet>legördülő válassza ki az Architecture, amely tartalmazza a komponenseket vagykapcsolatokat a megtekinteni kívánt.

3. A legördülő válassza ki az alkatrészt vagy a kapcsolat típusa hogy azt szeretné, hogy a felsorolt ​​problémákat, mint "sorok' A katalógusban.

4. A katalógus fognak megjelenni asorban minden egyes példánya a kiválasztott alkatrész vagy kapcsolat típusát.

hangjegy

Alapértelmezésben a legbaloldalibb Hierarchia Pathoszlop (azaz a hierarchia a szülő alkatrészek vagy csatlakozások felett a kiválasztott példányok) és a 2. Név oszlop (azaz a listát a kiválasztott készülék vagy a kapcsolat esetben) befagyasztották balra a katalógusban. Megváltoztatni az oszlop fagyasztó húzza az oszlop elválasztó a jogot a Név oszlopban. Tudsz Re-Orderoszlopok egyszerűen áthúzza a oszlop fejlécére. Sejtek oszlopok a kék aláhúzással vannak hivatkozásokat más elemek a projekt és a linkeket lehet majd a Ctrl billentyű és hivatkozásokra kattintva. Oszlopok rejtett Ehhez kattintson jobb gombbal a kívánt oszlop fejlécére, és kiválasztja oszlop | Oszlop elrejtése. Rejtett oszlopok titkolt kattintson a Beállítás oszlopok eszköztár gombot és konfigurálása oszlopok párbeszédablak az alábbi módon, vagy adja meg a lefelé mutató nyílra része oszlopok konfigurálásával eszköztár gombra, és külön-külön adja meg a rejtett oszlop (ok) akár az általános, Ingatlan vagy Mellékletek gyűjtemények. Sort lehet csoportosítva által oszlop értékeit húzza az oszlop fejlécében a kék csoportosulás sáv tetején a katalógusban. Bármikor kétszer kattintson a katalógus sorban választó és ugrásA megfelelő alkatrészvagy a kapcsolataz Explorer ablakban.Az ingatlan cella értékek félkövér Ha különbözőek az alapértelmezett, és dőlt ahol csak olvashatók. Időbélyeg, Ingatlan és Attached komponens oszlopok lehetnek színezett szerint a sejt értékek vagy a csatlakoztatott komponens az ingatlan értékének jobb gombbal kattintva az oszlop fejlécében, és kiválasztja oszlop | Változás Szín ... és akkor a Szín időbélyeg vagy a Colour By Property lehetőség azonban csak Lista, Integer, tízes logikai vagy dátum / idő adattípus tulajdonságok fogják színesíteni. Az ingatlan értékét Attached komponens oszlopok lehetnek Látható Ehhez kattintson jobb gombbal a kívánt oszlop fejlécére, és kiválasztja oszlop | Mutasd Property ... majd a Show Property opciót. És végül, ahol Kötelező megszorítások beállítva egy tulajdonság oszlop ezeket el kell kerülni a string (együtt színezés szerint a végrehajtási szint) jobb gombbal kattintva az oszlop fejlécében, és kiválasztja oszlop | Mutasd .

Katalógus

Hogy add / megjelenítése oszlopokat a Katalógus kilátás ABACUS

1. Győződjön meg arról, hogy van egy Katalógus nézet nyisd ki.

2. Rejtett oszlopok egyenként titkolt kattintva nyíl a jobb oldalon a Beállítás oszlopok eszköztár gombés kiválasztja a rejtett oszlop sem a Tábornok, Tulajdonságok vagy Mellékletek gyűjtemények.

hangjegy

Egy pipa jelenik meg mellette a jelenleg látható oszlopok a katalógusban.Emellett csak bizonyos mellékletek alatt lesz elérhető a csatolmányok részhez szerint korlátok hogy határozza meg a projekt. Különösen mellékleteként lesz elérhető, hogy megjelenik a elemkatalógus az alkatrész a katalógusban kell meghatározni a forrás- vagy elsüllyed (NEM a "Bármely") a "kapcsolatot kell csatolni" kényszer egy kapcsolathoz típusú, és ott is kell lennie legalább egy alkatrész megadott forrás- vagy a mosogató (NEM a "Bármely") a másik "végén" azonos kapcsolat típusát.

- VAGY -

2. Több oszlop is titkolt (megrendelés vagy fix) való kattintással Az oszlopok konfigurálásával eszköztár gombés konfigurálása oszlopok látható párbeszédablak alább.

hangjegy

Az aktuálisan megjelenített oszlopok jelennek meg a panel jobb oldalán a rendelkezésre álló oszlopok látható a panel a bal oldalon. A rendelkezésre álló oszlopok lehet szűrni szerint Válassza Elérhető oszlopokathúzza lefelé és ki lehet egészíteni kiválasztja azokat a panel a bal oldalon, és kattintson a Add gombot inbetween a két panel.

Az oszlopok konfigurálásával ablakban

Hogy távolítsa / elrejtése oszlopok egy Katalógus kilátás ABACUS

1. Győződjön meg arról, hogy van egy Katalógus nézet nyisd ki.

2. Kattintson jobb gombbal a fejlécére az oszlop az eltávolítani kívánt / elrejtése, és válassza Oszlop | Oszlop elrejtése.

- VAGY -

2. Több oszlop lehet rejtett (vagy megrendelhető vagy rögzített), kattintson a Az oszlopok konfigurálásával eszköztár gombés konfigurálása oszlopok látható párbeszédablak felett.

hangjegy

Az aktuálisan megjelenített oszlopok jelennek meg a panel jobb oldalán a rendelkezésre álló oszlopok látható a panel a bal oldalon. Az aktuálisan megjelenített oszlopok lehet rejteni kiválasztásával az oszlopra, a panel a jobb és kattintson a Távolítsuk gombot inbetween a két panel.

Benépesítésére segítségével Katalógus kilátás ABACUS

1. Hogy adjunk hozzá egy alkatrész vagy kapcsolatA kiválasztott típus hogy a katalógus (és projekt) kattintson az Új komponens / Új kapcsolat hozzáadása eszköztár gombra. Tehát a sor jelennek meg, és a alkatrész vagy kapcsolat jön létre a legfelső szinten a Alkatrészek vagy Kapcsolatok gyűjtemény a kiválasztott Építészet.

hangjegy

Új alkatrészek és új kapcsolatot alapértelmezés szerint a legfelső szinten az Alkatrész vagy Connections gyűjteménye a választott Építészet. Megváltoztatni a szülő az új alkatrészek vagy csatlakozások kattintson jobb gombbal a hierarchia Path sejt az új alkatrész vagy kapcsolat sorban, és válassza Változás Szülő ...és válassza ki a kívánt szülő (figyelembe veszi a korlát kiemelés ).

hangjegy

Új sorok / elemekkel egészül ki közvetlenül a katalógusból az "Új" gombra, beillesztve a katalógusban, vagy létre keresztül importáltak a katalógust MS Excel mentesülnek a szűrés, amíg a katalógusban zárva. Ennek célja, hogy lehetővé teszik a szükséges szerkesztési oszlop értékek, amelyek nem felelnek meg a jelenlegi szűrési feltételeket a katalógusban. Ezek az új elemek sora jelzi a "+" jel a sorban választó cella elején a sort, amely olyan színű, zöld ha az elem jelenleg megfelel az elmentett szűrési feltételeket a katalógus (azaz marad katalógusa ha újra megnyitott), és piros ha nem.

2. Hogy eltávolítása alkatrész vagy kapcsolatA kiválasztott típus ból ből a katalógus (és projekt) jelölje ki a sort, és vagy nyomja Del billentyűt, vagy kattintson jobb gombbal a sorban választó és válassza Törlés a Építészet. A sor el kell tűnnie A katalógusból és az törlésre kerül a projekt.

Hogy szűrő használva Katalógus kilátás ABACUS

1. Győződjön meg arról, hogy van egy Katalógus nézet nyisd ki.

2. Ha a szűrő sorban nem jelenik meg a tetején a katalógusban, majd kattintson a Mutass Filter Fejléc soreszköztár gombra.

3. Az oszlopot szeretne hozzáadni egy szűrőt, kattintson duplán a szűrő sorcellában ahol azt mutatja "(All)".

4. A Időbélyeg, hierarchia helye, neve vagy Leírásáltalános oszlopok vagy Szöveg, Egész, tízes logikai vagy Dátum időingatlan oszlopok kattintson a ... gombra, hogy megjelenik a jobb a szűrő sorcellában, és adja meg a cella értékeket, fel kell venni a katalógusban.

hangjegy

Megfelelő módon végezzük el, ha "* 'maszk automatikusan alkalmazza előtt és után minden szöveges adatok, így egy bejegyzést a" macska "(idézőjelek nélkül) magában sorok" Bobmacska','macskanő "vagy" irántimacskaion "stb Többszörös /" vagy "értékek felvehető új vonalak segítségével Ctrl + Enter. Mert egész és tizedes ingatlan oszlopok "és a" logika lehet benne használatával "&"(Idézőjelek nélkül), és nagyobb, mint / kevesebb mint etc logika lehet benne az '> =','>','<' és '<="(Idézőjelek nélkül), például "> = 50000 & <90000". Nem üres sorok értékes lehet venni megadásával "(Nem Üresek)"(Idézőjelek nélkül), és üres sorok értékes lehet venni megadásával"(Üresek)"(Idézőjelek nélkül).És végül, valamennyi szűrő alapértelmezés szerint a kis- és nagybetűk, így a "macska" (idézőjelek nélkül) magában sorban a "macska", "Macska" vagy "CAT" stb kis- és nagybetűk megfelelő, írja be a '(Ügy)"(Idézőjelek nélkül), mielőtt a húr, például "(A) Macska" (idézőjelek nélkül), akkor csak azokat a sorokat 'Cat' bennük.

5. A Mellékletekoszlopok, Szabványok oszlopok vagy Lista ingatlan oszlopok kattintson a lefelé mutató nyílra, hogy megjelenik a jobb a szűrő sorcellában, és válassza ki a cella értékeket a négyzeteket, hogy fel kell venni a katalógusban.

hangjegy

A "(Select All)" jelölőnégyzetet lehetővé teszi az összes többi jelölőnégyzetet, a hatás, beleértve az összes rendelkezésre álló sorok. A "(Nem Üresek) 'négyzetet fog bármely, nem üres értékes sorokban. A '(Üres) "jelölőnégyzetet nem tartalmaz olyan üres értékes sorokat. És végül, vedd ki a pipát konkrét értékes négyzeteket automatikusan törölje a "(Select All)" és "(Nem Üresek)" jelölőnégyzetet összhang.

6. Kattintson oké a szűrőt alkalmazni.

Hogy disable / enable szűrésre a Katalógus kilátás ABACUS

1. Győződjön meg arról, hogy van egy Katalógus nézet nyisd ki val,-vel szűrő alkalmazott.

2. Kattintson a jelölőnégyzetet a bal oldalán a szűrő sorban.

Hogy távolítsa el a szűrőt a Katalógus kilátás ABACUS

1. Győződjön meg arról, hogy van egy Katalógus nézet nyisd ki val,-vel szűrő alkalmazott.

2. Eltávolítani egyéni oszlopot szűrő kattintson jobb gombbal a fejlécre, és válassza Oszlop | Tiszta szűrése.

3. Ahhoz, hogy távolítsa el az összes szűrőt kattintson a Beállítások eszköztár gombot, és válasszuk Clear Filter Settings.

Menteni / mentés másként aKatalógus nézet

hangjegy

Bár minden Építész felhasználók hozhatnak létre új katalógusok, hogy mentse a változtatásokat, hogy egy meglévő Katalógus beállításait a felhasználói engedély szüksége a tervező add-on képesség. Ez a "védelem" a konfigurációs meglévő katalógusok, hogy meg lehet osztani a sok felhasználó. Azonban építész használja anélkül, hogy a tervező add-on is választhat a "Mentés másként" bármely új beállításokat egy új katalógus. És természetesen az összes felhasználói engedélyek választhat, hogy "megválni" bármilyen változás egy meglévő katalógus. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége A tervező add-on képesség.És ne feledd, hogy ez csak a beállításokat a katalógus, minden módosítást tett az adatokat a katalógus azonnal alkalmazni a tárolóból, függetlenül.

1. Meg arról, hogy egy új vagy a meglévő Katalógus nézet nyisd kiés elvégezte a szükséges módosításokat.

2. A Katalógus nézeteszköztár, kattintson a Mentésgombra a Katalógus nézet és bármely formázási módosításokat.

hangjegy

Ha nincs Mentés gombot Katalógus nézet eszköztár akkor nincs Tervező add-on, és meg tudják csak Mentés máskéntbeállításokon változtatni egy új katalógust, ha megy, hogy lezárja a már létező katalógus.

3. Ha a Katalógus Névablak jelenik meg (a következménye, hogy az új katalógus) adjon meg egy nevet a katalógus és nyomja meg a oké.

Hogy kiviteli MS Excel katalógusa

1. Győződjön meg arról, hogy van egy Katalógus nézet nyisd ki.

2. Kattintson a Exportálás Excel táblázatkezelő katalóguseszköztár gombra.

3. Válassza ki a fájl nevét, hogy megmentse a MS Excel katalógust. Kattintson Mentés.

hangjegy

Alapértelmezésben az exportált MS Excel katalógus fájlnév lesz a katalógus nevet toldalékolt az Építészet nevét zárójelek között, például "A projektek (2014 Actual) .xlsx". Meg lehet változtatni sem ezt, beleértve azt, hogy a fájlformátum, hogy .xlsx vagy .xls. Az Építészet neve szerepel, hogy emlékeztesse a felhasználót, hogy minden katalógusa sajátos tartalommal (azaz azonosítók A oszlop és sor 1) lehetővé teszik, hogy oda-vissza megbotlott használatával Import MS Excel katalógust per alább.

hangjegy

Alapértelmezésben a rejtett oszlop az exportált MS Excel katalógus tartalmazza az egyedi azonosító az egyes elemek a ABACUS tárolóból. Ez lehetővé teszi, hogy bármilyen változás, hogy készülnek az MS Excel, hogy "kiegyenlített fel" a meglévő elemei ABACUS import (lásd alább). Azonban az ezzel egyedi azonosítóval "egyeznek meg" sorok felülbírálhatja egy Külső | IDingatlan a elemet. Azaz, ha az elemnek van egy külső | Tulajdonság és ez szerepel a katalógusban az export, akkor az értékeket a külső | ID oszlopot kell használni, hogy megfeleljen a sorok import (lásd alább) és az egyedi azonosító értékeket a rejtett oszlopban figyelmen kívül fogja hagyni (és nem is lehet üres). A rejtett oszlop maga kell, hogy maradjon, de különösen az értéket A1 cellában. Továbbá, ha hozzá külső azonosítót egy meglévő ABACUS elem kollekció akkor ajánlott felvenni őket egy másik ingatlan első, pl Külső | Ideiglenes majd átnevezi az ingatlan külső | ID. Ellenkező esetben ismétlődő elemeket lesz hozzá.

Katalógus formázásexportálják alapértelmezés szerint azonban a nagy katalógusok ez vezethet az export pedig meglehetősen lassú. Ennek megfelelően, Eszközök | Beállítások ...majd a Katalóguslaponmeg tudja-e csökkenteni a formázás exportáljuk, ahogy a katalógus lap alább, ami felgyorsítja az export.

Katalógus export opciók

4. Egy Export Befejezve ablak jelenik meg. Kattintson oké.

Exportált MS Excel katalógusa

Hogy import MS Excel katalógusa

hangjegy

Alapértelmezésben a rejtett oszlop az exportált MS Excel katalógus (lásd fent) tartalmazza egyedi azonosító az egyes elemek a ABACUS tárolóból. Ez lehetővé teszi, hogy bármilyen változás, hogy készülnek az MS Excel, hogy "kiegyenlített fel" a meglévő elemei ABACUS import. Azonban az ezzel egyedi azonosítóval "egyeznek meg" sorok felülbírálhatja egy Külső | IDingatlan a elemet. Azaz, ha az elemnek van egy külső | Tulajdonság és ez szerepel a katalógusban export (lásd fent), akkor az értékeket a külső | ID oszlopot kell használni, hogy egyeznek meg a sorok és behozatali az egyedi azonosító értékeket a rejtett oszlopban figyelmen kívül fogja hagyni (és nem is lehet üres). A rejtett oszlop maga kell, hogy maradjon, de különösen az értéket A1 cellában. Továbbá, ha hozzá külső azonosítót egy meglévő ABACUS elem kollekció akkor ajánlott felvenni őket egy másik ingatlan első, pl Külső | Ideiglenes majd átnevezi az ingatlan külső | ID. Ellenkező esetben ismétlődő elemeket lesz hozzá.

1. Győződjön meg arról, hogy van egy Katalógus nézet nyisd ki.

2. Kattintson a Import Excel táblázatkezelő katalóguseszköztár gombra.

3. Válassza ki a fájl nevét importálni az MS Excel katalógust. Kattintson Nyisd ki.

4. Új Feltárt hibák és / vagy az új hibák / figyelmeztetések észlelve dialógusok is megjelenhetnek bármilyen új tartalmat (azaz sorok a MS Excel), hogy adunk. Tudomásul veszi a hibák / figyelmeztetések és kattintson oké.

5. Egy Import befejeződött ablakot a kijelzőn, és mutathat figyelmeztetések miatt az import (lásd az alábbi megjegyzéseket). Kattintson oké.

hangjegy

A hozzárendelt szabványok vagy a csatlakoztatott komponens oszlopok, új bejegyzések keresztül MS Excel katalógusa pontosan meg kell egyeznie a név A létező szabvány vagy komponens a megfelelő típusú átruházására vagy kapcsolat kell hozzá. Az első elemzi mérkőzés fogják használni, és minden páratlan bejegyzéseket figyelmeztetést generál, mint egy alább. Továbbá, míg a figyelmeztetéseket újraimportálás, elemek nem törlődnekre ABACUS ha azok nincsenek jelen a MS Excel katalógusban. Ez azért van, mert nincs módja, hogy ABACUS lehet tudni, hogy a kijelölt szabvány vagy a csatlakoztatott komponens létezik az ABACUS projekt, de nem létezik a MS Excel katalógusa mert törölték az MS Excel katalógusban vagy került fel az ABACUS projekt, mivel a katalógusban exportálták. Ennek megfelelően, ha a felhasználók szeretnék egyszerűen "érzékeli", amely kapcsolatot bővült az importálás során akkor egyszerűen hozzon létre egy szükséges tulajdonság a kapcsolat típusától és állítsa ez alapértelmezés szerint üres, hogy azok fogják figyelmeztetni az esetleges új kapcsolatok minden egyes alkalommal az import befejeződött.

hangjegy

Importálásakor MS Excel katalógusa különböző figyelmeztetések jelenhetnek meg. Először is, ha egy új oszlopot adtunk az Excel, hogy nem felel meg a "szintaktikai" egy ingatlan vagy az ahhoz csatlakozó komponens az oszlop figyelmen kívül hagyja. Ezután line-by-line figyelmeztetések jelennek meg az olyan kérdések az adatokat minden egyes sora az Excel katalógusban. Ezeket a figyelmeztetéseket kezdődik a sor számát zárójelben és adott esetben az oszlop címkéjére (vagyis "[23, J] ..." A 23. sor a J oszlopban), és utalhat a törölt elemeket, páratlan szabványok vagy csatolt részekből (amely figyelmen kívül hagyja, mint egy jegyzetet fent), vagy érvénytelen vagy üres ID kapcsolatos új sort / elem (amely hozzáadódik). A részletes cikket a feltöltésért ABACUS Excel katalógusok kérjük, olvassa el a Avolution közösségi vagy a Portfolio Manager tanfolyamot.

hangjegy

Új alkatrészek és új kapcsolatot alapértelmezés szerint a legfelső szinten az Alkatrész vagy Connections gyűjteménye a választott Építészet. Megváltoztatni a szülő az új alkatrészek vagy csatlakozások kattintson jobb gombbal a hierarchia Path sejt az új alkatrész vagy kapcsolat sorban, és válassza Változás Szülő ...és válassza ki a kívánt szülő (figyelembe veszi a korlát kiemelés ).

hangjegy

Elemekkel egészül ki közvetlenül a katalógusból az "Új" gombra, beillesztve a katalógusban, vagy létre keresztül importáltak a katalógust MS Excel mentesülnek a szűrés, amíg a katalógusban zárva. Ennek célja, hogy lehetővé teszik a szükséges szerkesztési oszlop értékek, amelyek nem felelnek meg a jelenlegi szűrési feltételeket a katalógusban. Ezek az új elemek sora jelzi a "+" jel a sorban választó cella elején a sort, amely olyan színű, zöld ha az elem jelenleg megfelel az elmentett szűrési feltételeket a katalógus (azaz marad katalógusa ha újra megnyitott), és piros ha nem.

Hogy összehasonlítani a tartalmat egy katalógust másik építészet

1. Kérjük, olvassa el a témában itt .

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Benépesítő az architektúrának Visio | Benépesítő az architektúrának Excel


Benépesítő segítségével mátrixok

Navigáció: Népszerű az architektúrának>

Benépesítő segítségével mátrixok

Küldje el észrevételeit ebben a témában.

A mátrix lehetővé teszi, hogy megtekintheti és szerkesztheti a 'közvetlen' közötti csatlakozások komponenseket egy egyszerű táblázatos módonés megtekintheti a "közvetett utat" az összetevők között bármelyike ​​szerinti köztes elemek (és kapcsolatok).

Hogy teremt Mátrix nézetet ABACUS

hangjegy

Bár minden Építész felhasználók létrehozhatják Matricák, hogy megmentse őket, és / vagy azok beállításait a felhasználói engedély szüksége a tervező add-on képesség. Ez a "védelem" a konfigurációs meglévő mátrixok lehet osztani a sok felhasználó. Azonban építész használja anélkül, hogy a tervező add-on is választhat a "Mentés másként" bármely új beállításokat egy új Matrix. És természetesen az összes felhasználói engedélyek választhat, hogy "megválni" bármilyen változás egy meglévő Matrix. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

1. Válassza ki a Beszúrás | Mátrix.

2. A rchitecture>legördülő válassza ki az Architecture, amely tartalmazza a komponenseket, és kapcsolatot a megtekinteni kívánt.

3. A <ForrásÍrja>legördülő válassza ki az alkatrész, hogy azt szeretné, hogy a felsorolt ​​problémákat, mint "sorok' lenyomva a bala mátrix.

4. A <MosogatóÍrja>legördülő válassza ki az alkatrész, hogy azt szeretné, hogy a felsorolt ​​problémákat, mint "oszlopok' az egész tetejéna mátrix.

5. A húzd le alapvetően két "üzemmódban" mátrix megadhatjuk ...

"Közvetlen" kapcsolat mátrixok

6. Egyszerűen sválaszt egy (1) vagy több kapcsolat típusok a jobb oldali a megjelenő menüben, ha szeretné látni a "sejtek" a mátrix, ha an explicitkapcsolat áll fenn a Függőleges/ "sor"Komponens a mátrix a Vízszintes/ "oszlop"Komponens a mátrix.

hangjegy

Csak kapcsolatokat a forrás végével csatlakozik a Függőleges/ "sor"Komponens és mosdó végén csatlakozik a Vízszintes/ "oszlop"Komponens jelenik meg. Kapcsolja ki a Forrás és Mosogatóalkatrész választás, hogy megtekinthesse a kapcsolat az ellenkező irányba.

7. A mátrix fognak megjelenni a "X" A sejtek (vagy az ingatlan értékének - lásd alább a megjegyzést) Ha van kapcsolat a Függőleges/ "sor'komponens a mátrix a Vízszintes/ "oszlop"Komponens a mátrix.

hangjegy

Nagyméretű problémákra csak maximum 100 sorok vagy oszlopok (beleértve összeomlott sorok / oszlopok) lesz látható egy időben, amint azt az "R" és "C" mutatók a bal felső fejcellára volt. Ha további sorokat használja a görgetősáv. Bármikor kétszer kattintson a Függőleges/ "sor' vagy HorizontAL / 'oszlop' összetevő fejezetek és ugrása megfelelő összetevőket a Explorer ablakot.A szülők a függőleges/ "sor' és Vízszintes/ "oszlop' összetevős szintén opcionálisan látható fejeltávolítás sorok / oszlopok, szürke tétel címe. Amikor összeomlott (Egyetlen kattintással cím cella), ha a gyermekek mellékletek létezett, akkor az 'X' fog esetben jelenik meg, ha az összes gyerek tapadt vagy "O" fog esetben jelenik meg, ha csak néhány gyermek mellékeltek. A sejtek lehetnek színezett állítja egy ingatlan értékét a kapcsolatot, kattintson a Beállítások "fogaskerék" a jobb felső mátrix eszköztár és kiválasztja Szín Beállítások ..., majd a Szerkesztés gombra, és adja meg a Colour időbélyeg vagy a Colour By Property opciót, és válassza egy ingatlant, a min és max érték tartomány és választott színek azonban csak Lista, Integer, tízes logikai vagy dátum / idő adattípus tulajdonságok fogják színesíteni. Ha összeomlott a cella szerint színezett átlagos ingatlan értékét a kapcsolatot. Ahelyett, hogy egy "X", tulajdonságértékeit sejtek lehetnek Látható kattintson a Beállítások "fogaskerék" a jobb felső mátrix eszköztár és kiválasztja ábrázolni Érték Beállítások ..., majd a Szerkesztés gombot, és válassza a Show ingatlan opciót, és válasszon egy ingatlan.

Közvetlen kapcsolat mátrix mutatja a szerverek, ahol az alkalmazások házigazdája színező és egy ingatlan is látható, hanem a generikus "X"

- VAGY -

"Közvetett" kapcsolatot mátrixok

6. Sválasztsorozata kapcsolat típusok és komponens típusoka jobb és bal oldalán megjelenő menüben, ha szeretné látni a "sejtek" a mátrix, ha an közvetett útját csatlakoztatott komponensekléteznek a Függőleges/ "sor"Komponens a mátrix a Vízszintes/ "oszlop"Komponens a mátrix.

hangjegy

Az érvényes elérési útját, amely a választott elemet az utat menüben wbeteg jelenik megfüggetlenül attól, hogy az irányt a mélyebb összefüggések azonban, amikor kiválasztja az utat a első és Utolsó elemeket kell a kiválasztott csatlakozási típusok. Továbbá, a rendelés az elemek, amelyeket a kiválasztott látható egy numerikus előtagA szögletes ('[]') zárójelek és egy adott típusú lehet venni magukban foglalhatnak alkalommalaz útvonal (amint azt a számszerű előtag). Egymást követő válogatott komponens típusok vagy csatlakozási típusok is felfoghatjuk, mint a 'VAGY'út, és a hierarchia mellékelt komponens adott esetben tartalmazza ellenőrzi a 'Szintén keresni Attachment szülők / gyerekek"Jelölőnégyzetet. Kapcsolja ki a Forrás és Mosogatóalkatrész választás, hogy megtekinthesse a utak az ellenkező irányba.

7. A mátrix fognak megjelenni apath / gyűjtemény alkatrészeka sejtekben, ha van egy pálya tól Függőleges/ "sor'komponens a mátrix a Vízszintes/ "oszlop"Komponens a mátrix.

hangjegy

Nagyméretű problémákra csak maximum 100 sorok vagy oszlopok (beleértve összeomlott sorok / oszlopok) lesz látható egy időben, amint azt az "R" és "C" mutatók a bal felső fejcellára volt. Ha további sorokat használja a görgetősáv. Bármikor kétszer kattintson a Függőleges/ "sor' vagy HorizontAL / 'oszlop' összetevő fejezetek és ugrása megfelelő összetevőket a Explorer ablakot.A szülők a függőleges/ "sor' és Vízszintes/ "oszlop' összetevős szintén opcionálisan látható fejeltávolítás sorok / oszlopok, szürke tétel címe. Amikor összeomlott (Egyetlen kattintással cím cella), ha olyan gyerek utak létezett, akkor az 'X' fog esetben jelenik meg, ha az összes gyerek tapadt vagy "O" fog esetben jelenik meg, ha csak néhány, a gyerekek utak. A közvetett utat az összetevők lehetnek színezett állítja egy ingatlan értékét a komponensek kattintson a Beállítások "fogaskerék" a jobb felső mátrix eszköztár és kiválasztja Szín Beállítások ..., majd a Szerkesztés gombra, és adja meg a Colour időbélyeg vagy a Colour By Property opciót, és válassza egy ingatlant, a min és max érték tartomány és választott színek azonban csak Lista, Integer, tízes logikai vagy dátum / idő adattípus tulajdonságok fogják színesíteni. Tulajdonság értékeket a közvetett utat komponensek lehetnek Látható kattintson a Beállítások "fogaskerék" a jobb felső mátrix eszköztár és kiválasztja ábrázolni Érték Beállítások ..., majd a Szerkesztés gombot, és válassza a Show ingatlan opciót, és válasszon egy ingatlan.

Közvetett kapcsolat mátrix, amely bemutatja a pályázatokat, amelyek megfelelnek egy adott szolgáltatás által Tanszék

Hogy szűrőMátrix nézetet ABACUS

1. Meg arról, hogy egy új Matrix nézet nyisd ki.

2. Kattintson a Szűrő tengelyek "tölcsér" a jobb felső mátrix eszköztár.

3. A Forrás és / vagy a mosogató fülek Új név, ingatlan, Leírás, hierarchia vagy Standard szűrők kattintson a Hozzáadás gombra, adja meg a tulajdon, ha szükséges, és kattintással oké. Válassza ki a megfelelő beállításokat a kulcsszavak / db panel segítségével a logikai / szintaxist, ahogy az a lenti megjegyzést. Az előnézeti panel automatikusan frissíti, hogy bemutassa az eredményeket az aktuális sorozat szűrőt.

hangjegy

A Időbélyeg, hierarchia helye, neve vagy Leírásszűrők vagy Szöveg, Egész, tízes logikai vagy Dátum időingatlan szűrők megfelelő végzünk, mintha '*' maszk automatikusan alkalmazza előtt és után minden szöveges adatok, így egy bejegyzést a "macska" (idézőjelek nélkül) magában sorok "Bobmacska','macskanő "vagy" irántimacskaion "stb Többszörös /" vagy "értékek felvehető új vonalak segítségével Ctrl + Enter. A Egész szám és Decimális ingatlan szűrők "és a" logika lehet benne használatával "&"(Idézőjelek nélkül), és nagyobb, mint / kevesebb mint etc logika lehet benne az '> =','>','<' és '<="(Idézőjelek nélkül), például "> = 50000 & <90000". Nem üres sorok értékes lehet venni megadásával "(Nem Üresek)"(Idézőjelek nélkül), és üres sorok értékes lehet venni megadásával"(Üresek)"(Idézőjelek nélkül).A Szabványok vagy Lista ingatlan szűrők A "(Select All)" jelölőnégyzetet lehetővé teszi az összes többi jelölőnégyzetet, a hatás, beleértve az összes rendelkezésre álló elemeket. A "(Nem Üresek)" jelölőnégyzetet magában foglal minden olyan, nem üres ingatlan értékes elemeket. A '(Üres) "jelölőnégyzetet nem tartalmaz olyan üres ingatlan értékes elemeket. És akadálytalan konkrét értékes négyzeteket automatikusan törölje a "(Select All)" és "(Nem Üresek)" jelölőnégyzetet a következetesség. És végül, valamennyi szűrő alapértelmezés szerint a kis- és nagybetűk, így a "macska" (idézőjelek nélkül) elemeket is tartalmazna a "macska", "Macska" vagy "CAT" stb kis- és nagybetűk megfelelő, írja be a '(Ügy)"(Idézőjelek nélkül), mielőtt a húr, például "(A) Macska" (idézőjelek nélkül), akkor csak olyan elemek "Macska" bennük.

Feltölteni egy mátrix nézet ABACUS

hangjegy

Csak akkor hozzáadása / eltávolítása kapcsolatokat, ahol egyetlen kapcsolat típusa óta használják a Path fent leírt.

1. Hogy adjunk hozzá egy kapcsolatA kiválasztott típus között Függőleges/ "sor"Komponenst és Vízszintes/ "oszlop"Eleme a mátrix, ahol egy" X "nem létezik(vagy látható ingatlan értéke - lásd a fenti)Kattintson duplán a cellába. "X" meg kell jelennie (vagy az ingatlan értékének - lásd a fenti) és egy kapcsolat jön létre a legfelső szinten a bekötések gyűjtemény a kiválasztott Építészet.

hangjegy

A kapcsolat neve lesz a összeköthető név mint egy a kapcsolatot típus beállítása a mátrix, és ha egy ingatlan értéke is megjelenik helyett egy "X" az alapértelmezett érték az ingatlan jelenik meg.

2. Hogy szerkesztése látható ingatlan értékétközötti kapcsolatot a Függőleges/ "sor"Komponenst és Vízszintes/ "oszlop"Komponens a mátrixKattintson duplán a cellába, vagy kattintson jobb gombbal a cellára, és válassza a Szerkesztés Érték ..., és szerkessze az értéket az érték módosítása párbeszédablakban.

3. Hogy távolítsa el a kapcsolatotA kiválasztott típus között Függőleges/ "sor"Komponenst és Vízszintes/ "oszlop"Eleme a mátrix, ahol egy" X "már létezik(vagy látható ingatlan értéke - lásd a fenti), jobbra-kattintson a sejtés válasszuk a Bont. Az X el kell tűnnie, és a kapcsolat törlődik a projektből.

Menteni / mentés másként aMatrix nézet

hangjegy

Bár minden Építész felhasználók létrehozhatják Matricák, hogy megmentse őket, és / vagy azok beállításait a felhasználói engedély szüksége a tervező add-on képesség. Ez a "védelem" a konfigurációs meglévő mátrixok lehet osztani a sok felhasználó. Azonban építész használja anélkül, hogy a tervező add-on is választhat a "Mentés másként" bármely új beállításokat egy új Matrix. És természetesen az összes felhasználói engedélyek választhat, hogy "megválni" bármilyen változás egy meglévő Matrix. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége A tervező add-on képesség.És ne feledd, hogy ez csak a beállításokat a Mátrix, minden módosítást tett az adatokat a Matrix azonnal alkalmazni a tárolóból, függetlenül.

1. Meg arról, hogy egy új Matrix nézet nyisd kiés elvégezte a szükséges módosításokat.

2. A Matrix nézeteszköztár Kattintson a bal szélső Mentés Mátrixgombra a Matrix nézet és bármely formázási módosításokat.

hangjegy

Ha nincs Mentés gombra a Matrix nézet eszköztár akkor nincs Tervező add-on, és meg tudják csak Mentés máskéntbeállításokon változtatni egy új mátrixot, ha megy, hogy lezárja a meglévő mátrix.

3. Ha a Mátrix NévA megjelenő párbeszédablakban (a következménye, hogy egy új mátrix) adjon meg egy nevet a mátrixés nyomja meg a oké.

Hogy kiviteli MS Excel mátrix

1. Győződjön meg arról, hogy van egy Matrix nézet nyisd ki.

2. Kattintson a Exportálás Exceleszköztár gombra.

3. Válassza ki a fájl nevét, hogy megmentse a MS Excel mátrixban. Kattintson Mentés.

hangjegy

Alapértelmezésben az exportált MS Excel mátrix fájlneve lesz a Mátrix nevet toldalékolt az Építészet nevét zárójelek között, például "Alkalmazások otthont Servers (2014 Actual) .xlsx". Meg lehet változtatni sem ezt, beleértve azt, hogy a fájlformátum, hogy .xlsx vagy .xls.

Mátrix formázásexportálják alapértelmezés szerint azonban a nagy mátrixok ez vezethet az export pedig meglehetősen lassú. Ennek megfelelően, Eszközök | Beállítások ...majd a Mátrixlaponmeg tudja-e csökkenteni a formázás exportáljuk, ahogy a Mátrix lap alább, ami felgyorsítja az export.

Mátrix export opciók

4. Egy Export Befejezve ablak jelenik meg. Kattintson oké.

Exportált MS Excel mátrix

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Benépesítő az architektúrának Visio | Benépesítő az architektúrának Excel


Benépesítő diagramok

Navigáció: Népszerű az architektúrának használata> Rajzok>

Benépesítő diagramok

Küldje el észrevételeit ebben a témában.

Rajzok ABACUS több, mint csupán önkényes ábrázolások. Ezek egyéni nézetek az architektúra, formázott és elhelyezni, hogy mutassanak különleges jelentéssel bír.

A rajz eszköz érvényesíti a hierarchikus szerkezete építészet, hogy az alkatrészek vizuálisan ágyazott egyéb alkatrészek - így lényegében egy "felülnézetben" az elemek. Ha egy komponens vagy a kapcsolat már meghatározták az építészet, akkor lehet használni, tetszőleges számú különböző ábrákat. Fontos, hogy a rajz eszköz szorosan kapcsolódik az építészeti modell, úgy, hogy változások végzett akár egy mindig tükröződik a többi.

Az eszköz működik társítanak formák különös kapcsolatot, és komponens típusok meghatározott típusai részben a építészet. Ezek az összefüggések függően változhat, hogy milyen típusú diagram készülő, és lehetséges, hogy az egyik típusú alkatrész (vagy kapcsolat) lehet különböző reprezentációk a különböző diagramok, a szövegkörnyezettől függően.

Hogy hozzanak létre egy szövetség között a forma és az alkatrész vagy kapcsolat típusát

1. Meg arról, hogy egy új vagy meglévő rajz nyitott .

2. Hozza ki a ABACUS alkalmazás, és beállítani az ablak arányok mint amire vágysz.

3. Válassza ki a Shapes lap vagy a Csatlakozók lap A stencil ablakban.

4. A típusága a Intézőben keresse meg az alkatrészt vagy kapcsolat típusát szeretne társítani egy alak vagy csatlakozó.

5. Válassza ki a választott típusú elemet a fáról, húzza át a Shapes fület vagy Csatlakozók fülre, áthúzzuk az alak vagy csatlakozószeretné használni.

hangjegy

Tudod ellenőrizni társulás létrehozta kiválasztásával alkatrészeket vagy Connections fülre a stencil ablakban, amelyek bemutatják az aktuálisan kapcsolódó elemeket.

Ha új formák a diagramok / könyvtár

1. Hozzon létre egy MS Visio rajz a formák, hogy szeretne felvenni a rajz és importálja a MS Visio rajz .

Tipp

Fontos, hogy milyen méretű csinál a mester alakja MS Visio, mert az ABACUS vászon van méretezve pixel, és csak milliméter egységek MS Visio átalakítani granulárisan a pixelek 4 pixel és 1 milliméter arányt. Továbbá, az alapértelmezett ABACUS formák jellemzően 60 pixel magas, így fordítja 15 milliméter MS Visio. Jelentés egy tanácsos mester alakja mérete MS Visiovan 25mm széles és 15mm magasmivel ez lefordítja 100 pixel széles és 60 pixel magas ABACUS.

Tipp

Ha azt szeretnénk, hogy egy kis "ikon" a bal felső sarkában egy alakzatot, akkor egyszerűen létre a "ikont" a mester MS Visio alakja az MS Visio rajzban Eszközpalettáról (megjegyezzük, hogy csak egyszerű vonalak, körök és téglalapok támogatott és raszteres / bitmap formák különösen nem támogatott). Továbbá, ha azt szeretnénk, az ikon, hogy fix méretű / léptékűaz alakzaton belül a ABACUS akkor csoportja a "ikont" a mester MS Visio alakja kiválasztásával annak valamennyi elemét, jobb egérgombbal kattintva egy elem kiválasztása Alak | Csoport, majd kattintson jobb gombbal a csoportosított alakja és kiválasztja adatok | Alak adat ..., Yes kiválasztása a megjelenő párbeszédablakban, majd hozzá egy telken a címke beállítása LockScale(vegye figyelembe a nagybetűs "L" és "S"), a Type beállítása Logikai és a beállított érték legyen IGAZ (vegye figyelembe, hogy minden nagybetűs).

Tipp

Ha azt szeretnénk, hogy egy részét a forma fagyott méretezés vízszintesen vagy függőlegesen (ami általában egy "sáv" alakú), akkor a jobb gombbal a rész (ek) a mester MS Visio alakja kívánt fagyott a méretezéstől és válassza a Data | Alak adat ..., Yes kiválasztása a megjelenő párbeszédablakban, majd hozzá egy telken a címke beállítása LockXScale vagy LockYScale (vegye figyelembe a nagybetűs "L" és "S"), a Type beállítása Logikai és a beállított érték legyen IGAZ (vegye figyelembe, hogy minden nagybetűs), a lezárt vízszintes vagy függőleges méretezést volt.

Tipp

Ahhoz, hogy a színező a formát ABACUS importálás után, nem pedig a forma hogy mindig egy fix szín célszerű, hogy a mester MS Visio alakja kitöltésének átlátszó majd a beépített képesség ABACUS színezni az alakzat háttér. Ez csak akkor működik, téglalap vagy közel négyszög (pl lekerekített téglalap) alakú, mint az egész téglalap alakú háttér színezve lesz.

2. Nyissuk meg a megfelelő diagramot, és válassza ki a Komponensek lapA stencil ablakban.

3. Minden egyes új forma, hogy azt szeretné, hogy elérhetőek legyenek a többi diagramok Jobb klikkA forma és válasszuk Add hozzá a Shapes Könyvtár. Ez lehetővé teszi majd a forma elérhető az alakzatok fülön a stencil ablakban.

4. Társulnak a megfelelő alkatrész az új forma a formák szerinti könyvtár a fenti lépéseket.

hangjegy

Csak az egyszerű és "vektor-alapú" alakú támogatottak ABACUS abban a pillanatban, azaz bitmap nem támogatottak. Ugyanakkor eszközök, mint a Vector Magic ( www.vectormagic.com ) Állnak, amelyek könnyen konvertálni bitmap képeket vektoros formák (pl SVG formátumban), hogy ki lehet nyitni az MS Visio, és így hasznosítani ABACUS mint egy a fenti utasításokat.

Hozzátéve,Alkatrészek és csatlakozások

A rajz eszköz lehetővé teszi, hogy add meglévő elemek és kapcsolatok a tárolóból, vagy új alkatrészek és csatlakozások, ahogy a rajz egy rajz. Ahogy alkatrészek és csatlakozások jönnek létre diagramok, azok egyidejűleg hozzáadjuk az raktár. Vannak Három ajánlott módjait hozzátéve komponensek egy diagramés három ajánlott módja, hozzátéve kapcsolatok egy diagram:

Hogy egy teljesen új alkatrész vagy kapcsolat diagramonA stencil

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Válassza ki a Alkatrészek vagy Kapcsolatokfülön a stencil ablakot, hogy a kapcsolódó formák. Csak ezek a formák is használható új modell elemeit.

3. Kattintson és húzzaaz egyik elérhető kapcsolódó alakzatok rá a rajz vásznon. Az új elem jelenik meg a vásznon, és a felfedező fa.

4. Kezdje el beírniegy nevet az új elemnek a párbeszéd és a meglévő elemeket, amelyek mind a javasolt, és lehet választani, nem pedig, hogy egy új elem, hogy az architektúra.

5. Kattintson oké.

6. Ha egy alak volt, esett rá egy meglévő komponenst, akkor sem gyermeke lett ez az összetevő (ha a forma a Alkatrészeklapon), vagy csatolva lesz ez az összetevő (ha a forma a Kapcsolatoklap).

hangjegy

Néha ki kell igazítani az új alkatrész vagy kapcsolat egy másik helyre az építészeti hierarchia segítségével a felfedező.

Elhelyezni meglévő alkatrész vagy a kapcsolat a raktár rá egy rajz

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Ellenőrizzük, hogy mind a rajz eszköz és Explorer ablakot megtekinthető.

3. Az Intézőben keresse összetevő vagy kapcsolat(elem) szeretne felvenni a rajz.

4. Kattintson és húzzaa választott elem rá a diagramot. Egy alak képviselő elem jelenik meg a vásznon.

hangjegy

Ha a típus a kiválasztott elem már hozzá van rendelve egy alakzat, a megfelelő alakú jelenik meg a vásznon. Ha azonban nincs megszabott szövetség az adott elem, egy alapértelmezett formája (téglalap) jelenik meg a vásznon, kivéve, ha a Végre kell hajtani a Diagram Nézőpontok opció be van kapcsolva, amely esetben az alakja nem lesz hozzá, hogy a diagram.

Tipp

Amikor egy alkatrészt elhelyezzük egy diagram, amely össze van kötve egy másik összetevő már a rajz, a rajz eszköz fogja kérdezni, ha szeretné megmutatni a kapcsolat (ok) között. Továbbá, ha vannak olyan gyerekek az alkatrész a Drawing eszköz fogja kérdezni, ha szeretné felvenni a gyerekeket, rekurzív módon.

Hogy létrehozza a kapcsolatot 2 alkatrészek vagy a csatlakoztatott berendezést egy rajz dinamikus csatlakozó

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Lebeg több mint egy alkatrész az ábrán, hogy szeretne csatlakozni egy másik összetevője, és érezni fogja 2 ikonok jelennek kívül a jobb felső határának a forma az alábbiak szerint. Megjegyzés: A felső ikon a kapcsolat létrehozásához, ahol a körözött komponens, hogy a forrás, az alsó ikon a kapcsolat létrehozásához, ahol a körözött összetevő az, hogy a mosogató.

3. Mozog a kurzort a kívánt ikonra, és kattintson és húzzaAz ikonra fölött vagy alatt egy másik összetevő vagy üres helyet a vásznon az alábbiak szerint.

4. A csatlakozáshoz egy meglévő alkatrész kiválasztani a Csatolja a ...menüpontot a felbukkanó menüből, és ha szükséges, keresse meg az almenüt, hogy válasszon a rendelkezésre álló csatlakozási típusok.

- vagy -

4. Hogy hozzon létre egy összefüggő komponens döntött, a Új...elem a felugró menüben, és ha szükséges, keresse meg az almenüt, hogy válasszon a rendelkezésre álló csatlakozási típusok az alábbiak szerint. Kezdje el beírniegy nevet az új elemnek a párbeszéd és a meglévő elemeket, amelyek mind a javasolt, és lehet választani, nem pedig, hogy egy új elem, hogy az architektúra.

hangjegy

A rendelkezésre álló elemeket a felbukkanó menüben és almenüben az irányadók korlátok a meta-modell.Ez csak az érvényes forrás vagy elsüllyed komponens típusok által meghatározott kapcsolatban megszorítások kerülnek bemutatásra, mint a Csatolás ... és Új ... menüpontot.

Hogy újra el kell indítani az elem kiválasztása párbeszédablakban, és tegyük a meglévő alkatrészeket vagy csatlakozásokat az adattár-ra egy diagram

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Kattintson a Nyílt elemkijelölésigombra a Diagram eszköztár. Megjegyzés: a elem kiválasztása párbeszédablakban Megnyílik az utolsó állam bármely szűrők mentett.

3. Válasszon további tartalom, amely kívánatos, hozzá kell adni a rajz és kattintson oké. Megjegyzés: az új tartalom kerül majd üres hely van a vásznon, és a rajz lehet utólag lefektetett újra keresztül Layout Diagramgombra a Diagram eszköztár.

Használata ingyenesformaShapes

Gyakran kívánatos, hogy hozzon létre vizuális elemek egy diagramot tisztán esztétikai okokból. Ezek az elemek segíthet javítani az elrendezés és megjelenése a rajz, mégis nem egy szigorú építészeti jelentősége. A rajz eszköz lehetővé teszi a használatát szabadkézi alakzatokat, hogy rajz rugalmasságot.

Hozzáadni egy szabadkézi alakzat egy diagram

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Válassza ki a Shapes vagy Csatlakozókfülön a stencil ablakban.

3. Kattintson és húzzaaz egyik rendelkezésre álló formák és csatlakozókat a rajzon vászonra. Az új elem jelenik meg a vásznon -, hanem nemA felfedező fa.

hangjegy

Szabadkézi alakzatok "nem jár" alakú, mivel azok nincsenek kapcsolatban semmilyen komponens vagy kapcsolat az építészeti modell.

Hogy megjelenítéséhez adattár információk szabadkézi alakzatfiamdiagram

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Jobb klikkA szabadkézi forma és válasszuk Feliratozáslépték | Kijelző.

3. Válassza ki a megjeleníteni vagy a Diagram neve, Diagram Leírás, Diagram Ingatlan, Nézőpont neve vagy Építészet neve.

hangjegy

A szöveg a szabadkézi automatikusan frissülnek a mögöttes adattár adatváltozások.Ily módon egy diagram "címpecsétet" hozható létre, majd könnyen másolható át, diagramok.

Lebegő formák

Lebegő formák lényegében egy másik módja, hogy képviselje alkatrészek diagramon. Fontolja meg egy szervezet kulcsfontosságú részlege van: vezérigazgatója, marketing, értékesítési és fejlesztés.

Fa nézet

Ez az osztás lehet vizuálisan képviselt réteges módon:

Rakott megtekintése

Vagy lehetnek vizuálisan képviseli egy lépcsőzetes / úszó módon megmutatni hierarchia:

Megtántorodott / Úszó Kilátás

Az utóbbi ábrázolás fogalmát alkalmazza lebegő formák.

Átalakítani a réteges komponens alak egy lebegő alakja

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Válassza ki a összetevőa diagram azt szeretnénk, hogy képviselje, mint egy úszó alakja, vagy társult alakja a Alkatrészeklapján a sablon ablakban szeretné, hogy minden esetben a lebegő formák.

3. Kattintson jobb gombbal a forma és válassza Float komponens A megjelenő helyi menüt. Megjegyzés: a gyémánt élén kapcsolata szülő komponens (ek), hogy az úszó komponens (ek).

4. Kattintson és húzzaa komponens a kívánt helyre. Amikor a úszókomponenst a akkor azt a kék vonallal.

Átalakítani egy lebegő alkatrész formájában egy réteges alakja

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Válassza ki a összetevőa rajz, hogy jelenleg látható, mint egy úszó alakja, vagy társult alakja a Alkatrészeklapján a sablon ablakban szeretné, hogy minden esetben a rakott formák.

3. Kattintson és húzzaa lebegő komponens (ek) vissza a szülő (k) (az a gyémánt élén kapcsolat). Megjegyzés: Ha ezt nem tesszük meg, akkor, amikor konvertálni az alkatrész (ek) vissza is rakott a hierarchia a modell hatással lehet.

4. Kattintson a jobb gombbal a forma majd töröljük Float komponens A megjelenő helyi menüt. Megjegyezzük, hogy a gyémánt élén kapcsolata szülő komponens (ek), hogy az úszó komponens (ek) el fog tűnni.

Replikák

A rajz eszköz lehetővé teszi, hogy add ugyanazon komponens egy diagram többször minden további vizuális például a komponens az ábrán nevezik replika. Ez különösen hasznos a diagramok, ahol egy komponens egy nagy kapcsolatok száma csatolva, és kívánatos, hogy bemutassák a komponens több helyen közelebb az eredetét egyes csatlakozások, vagy diagramok, ahol egy-az-sok kapcsolat Egy komponens előnyösebb megjeleníthető segítségével a lebegő funkció (fent leírt) a komponens több helyen a tetején a "számos" komponensek ez kapcsolódik.

hangjegy

Akkor csatolni / leválnak kapcsolatok / az eredeti példány a komponens egy diagram (mint mindig), hanem bármely, a replikák, azonban ha a kapcsolatok automatikusan hozzáadódik egy ábrát ezek a jogok az első fokon az alkatrész A rajz alapértelmezés szerint.

hangjegy

Replikák is összeolvadt egymással jobb kattintás és húzásmajd kiválasztja Merge replikákAzonban, összevonása egy másolata egy másik komponens eredményez bármely más replika eltűnnek a rajz.

hangjegy

Nincs vizuális különbséget az eredeti példányának összetevő egy rajzot és minden replikák. Továbbá, a jobb egérgombbal a menü az eredetileg beszerelt egy rajzot és minden replikák azonos, ami például Megjelenítés az Intézőbenfigyelembe, hogy ugyanazt a komponenst a fa nézetben az adattár (aka modell). Azonban jobb egérgombbal az összetevő a fa nézetben a tároló és kiválasztja Menjés böngészés egy diagrammot replikák mindig elviszi a "legidősebb" például az alkatrész az ábrán. Általában ez lesz az eredeti példányt adtunk a rajz, de ha ez az eredeti példány utóbb törölte vagy összeolvadt egy replika majd a Go To ugrik a legrégebbi megmaradt replikák, hogy adtak hozzá.

Hogy replika felvételéhez egy diagram

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Kattintson a jobb gombbal meglévő alkatrész az ábrán, és válassza Hozzon létre Replica.A replika a kiválasztott komponens jön létre a jogot az eredeti alkatrész.

- VAGY -

Válasszon ki egy meglévő komponens egy diagramot, és nyomjuk meg Ctrl + Cvagy kattintson jobb gombbal meglévő alkatrész az ábrán, és válassza Másolat. Most kattintson jobb gombbal a helyét az ábrán, hogy szeretné, hogy a replika, és válassza Beillesztés Replica. Megjegyzés: A Ctrl + V (vagy jobb egérgombbal, és válassza a Paste) létrehoz egy másolatot az eredeti alkatrész nem egy replika.

- VAGY -

Kattintson és húzzaegy komponenst a Fa nézet a tároló (aka modell) rá egy rajz, ahol az alkatrész már létezik.

Konfigurálása Connection Caps / Ends

A rajz eszköz lehetővé teszi, hogy állítsa be a szimbólum használt végein a csatlakozó vezetékek, hogy vagy egy rögzített szimbólum vagy egy szimbólum függ tulajdonság a kapcsolat maga.Ez különösen hasznos a diagramok, ahol az irányba, egy kapcsolat szükséges kimutatható, vagy diagramok, ahol a számossága a kapcsolat (vagy az irány) tartalmazza egy tulajdonság a kapcsolat maga, pl "Egy-sokaknak" vs "sok-sok" (vagy "Source Sink" vs "Sink a forrás").

Hogy beállíthatja a kapcsolat sapkák / ér véget diagram

1. Meg arról, hogy egy új vagy meglévő rajz nyitott.

2. Válassza ki a Kösseionokfülön a stencil ablakban.

3. Jobb cnyalás az egyik kapcsolódó csatlakozási típusok és válassza Konfigurálása Caps ....

4. A fix kapcsolat sapka / vége a forrás- vagy a mosogató végén a kapcsolatot ellenőrizze, hogy a megfelelő Rögzített rádió gomb van kijelölve, majd válasszuk ki a kapcsolat vége jel A legördülő menüből, pl "Arrow Head" vagy "Diamond".

- VAGY -

Egy ingatlan-alapú kapcsolatot sapka / vége a forrás- vagy a mosogató végén a kapcsolatot ellenőrizze, hogy a megfelelő Segítségével Ingatlanrádió gomb van kiválasztva, majd kattintson a "..." gombra, és válassza ki a kívánt ingatlan, majd egymás mellé kapcsolat vége jel adja az ingatlant értékeket, amelyek az adott kapcsolat szimbóluma kell feltüntetni.

hangjegy

Többszörös ingatlan értékének egy adott kapcsolat vége jel lehet beírni vesszővel elválasztva. Ilyen például. A dialógus mutatja, hogy ha a "Adat | Számosságú tulajdonság értéke "Egy-sokaknak", akkor a forrás végén a kapcsolat lesz két vonalaknak rajta, és a mosogató végén a kapcsolat lesz egy sort a stroke át rajta, majd egy rajongó a kettőből vonalaknak végén.

Configure Caps ablakban

Lásd még

A rajz eszköz | Benépesítő az architektúrának | Elemző Ön építészet


Benépesítő az architektúrának

Navigáció: Népszerű az architektúrának>

Benépesítő az architektúrának

Küldje el észrevételeit ebben a témában.

A folyamat az épület egy modell a felépítést nevezik benépesítés. Miután felfedezték a építészet és azonosították a követelményeknek, akkor készen áll a modell a építészet ABACUS.

Során a népesség, akkor adjuk meg a részleteket tudsz az építészet és mi szükséges belőle.

Feltölteni a építészet

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási , Egy explorer megjelenített És egy építészet hozzáadott .

2. Kézzel népességnövekedés A magasabb szintű komponenseket és csatlakozásait építészet. Általában ez lesz az elvontabb alkatrészek és csatlakozások.

- vagy -

2. Grafikailag népességnövekedés Az alkatrészek és csatlakozások, amit szeretne látni képviselt vázlatosan, az Rajzeszköz .

Ön is szeretné

3. Benépesítik a katalógusok - Megtekintheti és alkatrészek és kapcsolatok egyszerű táblázatos módon.

4. Benépesítik a mátrixok - Megtekintheti és szerkesztheti a összeköttetéseket egyszerű táblázatos módon.

5. Népességnövekedés a Microsoft Access - Akkor importálni egy építészeti és exportálni A Microsoft Access.

6. Népességnövekedés a Microsoft Visio - Akkor importálni egy építészeti és exportálni Microsoft Visio.

7. Népességnövekedés a Microsoft Excel - Akkor importálni egy építészeti és exportálni Microsoft Excel.

8. Népességnövekedés a Microsoft SharePoint - Akkor importálni egy építészeti és exportálni A Microsoft SQL Server.

9. Népességnövekedés a Microsoft SQL Server - Akkor importálni egy építészeti Microsoft SQL Server.

10. Import XML - Akkor importálni egy építészeti egy ABACUS XML fragmentum vagy ArchiMate Interchange Nyelv XML fájl.

Lásd még

Benépesítő az architektúrának kézzel | A rajz eszköz | Benépesítő az architektúrának a Microsoft Access | Benépesítő az architektúrának a Microsoft Visio | Benépesítő az architektúrának a Microsoft Excel


Benépesítő az architektúrának a Microsoft Access

Navigáció: Népszerű az architektúrának> Népszerű a Microsoft termékek>

Benépesítő az architektúrának a Microsoft Access

Küldje el észrevételeit ebben a témában.

A kivitel a architektúra a Microsoft Access hogy végre általános célú számítások, manipulációk vagy jelentések az adott architektúrán. Akkor majd importálja az építészet vissza ABACUS.

hangjegy

Az Open Access / Export Adatbázis funkció megköveteli, hogy A Microsoft Access 2000vagy újabb telepítve van a számítógépre.

Exportálni az építészet a Microsoft Access

1. Győződjön meg arról, hogy van egy ABACUS fájlnyitott, a Felfedezőjelenik meg, és egy építészetadunk hozzá.

2. Válassza a Fájl | Export | Adatbázis-.

3. Vegye figyelembe a figyelmeztető ablak a fentiek szerint, majd kattintson az Igen folytatni.

4. Válassza ki a helyét és nevét az adatbázis fájlt.

Importálni a manipulált építészetet ABACUS

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza a Fájl | Új és válasszuk AccessA megjelenő párbeszédablakban kattintson az OK gombra.

3. Böngésszen az adatbázis fájlt szeretne importálni.

ABACUS "MS Access adatbázis-séma

ABACUS van a szívében egyn ontológia / meta-meta-modell alkotja alkatrész, csatlakozások és korlátok. Ez a "CCC" megközelítés származik különböző standard megközelítések fejlődött az 1960-es évektől kezdve záruló nemzetközi szabvány IEEE 1471, amely Avolution alapítói hozzájárult. A következő primitívek alkalmazni;

1. GOLYÓS SZÁMOLÓGÉP tartalmazza KönyvtárakA Szabványok(vagy Standards), Összetevő és Csatlakozási típusok, Megszorítások, Nézőpontok, Sablonok (vagy Minták) és sok Architektúrák.

2. Szabványok, Típusok és Nézőpontok májuslogikusan Csoportosítvakedvéért.

3. Architektúrák tartalmazhatnakSok leszármazottja Architektúrák(vagy Evolutions).

4. Minden egyes Építészet tartalmazza sok Alkatrészek és KapcsolatokBizonyos Típusokés a különböző Nézetek.

5. Alkatrészek és Kapcsolatok lehet lebomlott ba Alkomponenseket és Sub-csatlakozások.

6. Minden egyes Összetevővan csatoltbármennyi Kapcsolatokde minden Kapcsolatcsak akkor lehet csatoltlegfeljebb két Alkatrészek.

7. Alkatrészek és Kapcsolatok tud van Szabványok val vel Tulajdonságokpéldául az információs, teljesítmény, megbízhatóság, költség stb

8. Architektúrák, Alkatrészek és Kapcsolatok tud van különleges Tulajdonságokpéldául az információs, teljesítmény, megbízhatóság, költség stb

9. Megszorítások tud között fennálló Alkatrészek vagy Kapcsolatok vagy ellen Tulajdonságok.

10. Sablonokszabványos készítmények Összetevő és Csatlakozási típusok.

11. Nézőpontokszabványos társulásai Összetevő és Csatlakozási típusoka jelöléseket.

12. Nézetekvizuális ábrázolásai Alkatrészek és Kapcsolatok.

A következő MS Access Entitásviszony- Diagram (ERD) dokumentálja magArchitektúrák, Fejleményeket, Komponens / Csatlakozási típusok (és csoportok), alkatrészek / Connections és Sub alkatrész / csatlakozás fogalmak.

A Core adatbázissémát

hangjegy

Referenciális integritás nem érvényesíthetők összetevői közötti kapcsolat asztal és a Connections asztalra (a "kötődés" között egy adott Source vagy Sink komponens és a kapcsolat). Ez azért van, mert a kapcsolat létezhet anélkül, alkatrész mellékleteket. Mi volna hozzá egy "csatolt" táblát, de az egyszerűség kedvéért így döntöttünk. Természetesen ez azt jelenti, hogy minden szerkesztését összetevő-azonosítója vagy törlése komponens sorok együtt azt eredményezi, hogy a helytelen adatokat. ABACUS kezelik az inkorrekt import figyelmen kívül hagyva a helytelen adatokat.

A következő MS Access ERD dokumentálja Tulajdonságokkoncepciók architektúrák, komponens / Csatlakozási típusok és alkatrészek / Connections.

Tulajdonságok adatbázissémát

A következő MS Access ERD dokumentálja Szabványokkoncepció architektúrák, komponens / Csatlakozási típusok és alkatrészek / Connections.Megjegyzés: A táblák továbbra is használhatja a "Végrehajtás", ahogy az előző verziók ABACUS.

Szabványok adatbázissémát

A következő MS Access ERD dokumentálja Megszorításokkoncepció komponens / csatlakoztatási módokat.

Megszorításokadatbázissémát

A következő MS Access ERD dokumentálja Nézőpontok koncepció Architektúrák.Megjegyzés: A táblák továbbra is használhatja a "TwoDTempl", ahogy az előző verziók ABACUS.

Nézőpontokadatbázissémát

A következő MS Access ERD dokumentálja Katalógusokkoncepció Architektúrák.

Katalógusokadatbázissémát

A következő MS Access ERD dokumentálja Mátrixokkoncepció Architektúrák.

Mátrixokadatbázissémát

A következő MS Access ERD dokumentálja Diagramokkoncepció Architektúrák.Megjegyzés: A táblák továbbra is használhatja a "TwoD", ahogy az előző verziók ABACUS.

hangjegy

A komponens / kapcsolat típusát Stencil alakja feltérképezése és szabadkézi alakzat része a MS Access ERD már elhagyásával.

Diagramokadatbázissémát

A következő MS Access ERD dokumentálja 3D nézetekkoncepció Architektúrák.

3D nézetekadatbázissémát

A következő MS Access ERD dokumentálja Táblázatokkoncepció Architektúrák.

Táblázatokadatbázissémát

A következő MS Access ERD dokumentálja Dashboards koncepció.

Dashboardsadatbázissémát

ABACUS "MS AccessLekérdezések

Tartalmazza a MS Access adatbázis számos hasznos lekérdezések az alábbiak szerint:

· Tömörít a Kellékek- Ez a lekérdezés felsorolja az összes elemet a projektben (az építészet és típus) és magában foglalja mindazokat a tulajdonságokat, mint oszlopok. Használja ezt a lekérdezést, hogy a szűrők / kritériumot a alkatrész és / vagy építészeti termelni "tipikus" táblákat minden alkatrész típusának tulajdonságait.

· STD-k által Kellékek- Ez a lekérdezés felsorolja az összes normák, amelyek használatban vannak, az előfordulások számát a szabvány, és magában foglalja mindazokat a tulajdonságokat, mint oszlopok. Használja ezt a lekérdezést szabványok katalógusban.

· Kellékeket típusai- Ez a lekérdezés felsorolja az összes komponens tulajdonságait és% -ban teljes minden alkatrész oszlopok. Használja ezt a lekérdezést annak megállapítására, hogy jellemző tulajdonságokat tartanak fenn.

· Típusok Kellékek- Ez a lekérdezés felsorolja az összes komponens típusok, és magában foglalja a% kész az összes tulajdonságait, oszlopok. Használja ezt a lekérdezést annak megállapítására, hogy jellemző tulajdonságokat tartanak fenn.

· Típus szám- Ez a lekérdezés felsorolja az összes komponens típusok, és magában foglalja az előfordulások számát minden típus szerint csökkenő sorrendben. Használja ezt a lekérdezést, hogy meghatározza a népszerűsége minden típus a projektben.

Egy megjegyzés a dolgozó Memo mezők MS Access

Az alkatrész, csatlakozások és szabványok Név mezőket a táblák meghatározása a memo mezők, hogy korlátlan számú karakter, mint egy ABACUS. Az összetevők és csatlakozások ez okozza néhány olyan kérdés, mert nekik is van egy egyedi azonosító mező referálásra, de a Standard ez okozza néhány probléma, amikor megpróbálja a táblákat, mert nem tudsz csatlakozni memo mezők MS Access. Másik lehetőség, hogy állítsa WHERE kritériumok elérni ugyanazt a hatást, amint az a Visual Query Builder és a megfelelő SQL töredék alatti listából ki az összes örökölte Szabványok tulajdonságait, a komponensek az exportált ABACUS projekt.

Memo mező "csatlakozik" a Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Összetevıitıl inner join ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) ÉS (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), implementációk inner join ImplementationProperties BE Implementations.Id = ImplementationProperties.Implementation_Id

WHERE (((ComponentImplementationLinks.Name) = [implementációk]. [Név]));

Memo mező "csatlakozik" az SQL

Egy megjegyzés az automatikusan generál ABACUS azonosítók MS Access

Különböző ABACUS MS Access táblákat igényelnek egy egyedi hosszú egész szám ID így egy egyszerű VB eljárást biztosítunk, hogy segítse a generációs ezeket. Két módszer ResetCounter () és GetNextCounter () van, ami ABACUS "MS Access DB és azok használatáról a következő; ResetCounter () lesz a számlálót vissza 0. GetNextCounter () visszatér a következő számláló a sorrendben.

A módszerek kihasználni egy MS Access "trükkje", hogy még ha hívja a ResetCounter () metódus minden sorban betét (azaz, ha annak is a GetNextCounter () függvény), mert a ResetCounter () függvény nem lehet paramétere csak fut egyszer, és ezért nem nullázza a számlálót minden sorban betét. És azért is, mert az azonos "trükkje" akkor át kell adni a régi oszlop változót a GetNextCounter () függvény a bolond is figyelembe fut minden alkalommal.

Van is egy trükk, hogy képesek legyenek a ResetCounter () függvény inzertként SQL mert vidám csak azt, hogy ott ül, mint egy oszlop a saját, mint ha azt egy SELECT lekérdezés. Javasoljuk, hogy a ResetCounter () hívás részét egy másik területen, a összefűző, hogy a végén, mint mindig visszatér null egyébként.

Az alábbiakban egy tipikus SQL módszerek alkalmazásához, hogy adjunk egy listát a komponens típusok egy tábla / lekérdezés úgynevezett "összetevő típusa listája".

INSERT INTOComponentTypes (Id nevét, leírását)

SELECT GetNextCounter ([Component Type List] .name)AS Id, [Component Type List] .name például név, [Component Type List] .description & ResetCounter ()AS Leírás

BÓL BŐL[Component Type List];

ABACUS ID / Counter generációs SQL

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Benépesítő az architektúrának Visio | Benépesítő az architektúrának Excel


Benépesítő az architektúrának a Microsoft Excel

Navigáció: Népszerű az architektúrának> Népszerű a Microsoft termékek>

Benépesítő az architektúrának a Microsoft Excel

Küldje el észrevételeit ebben a témában.

A behozatal a építészetnek az Excel táblázatkezelő (.xls vagy .xlsx fájl). Az Excel importőr lehetővé teszi, hogy feltérképezze listákat az alkatrész- és kapcsolatokat típusú, szabványok, ingatlanok és szabványos tulajdonságok kiválasztásával az oszlopok a táblázat, amely tartalmazza a releváns adatokat.Ez azonban egy fejlettebb technika, mint a megközelítéssel,importáló MS Excel amely révén katalógusok a leírás alapján itt .

hangjegy

Az Importálás / Exportálás Excel funkció megköveteli, hogy A Microsoft Excel 2003vagy újabb telepítve van a számítógépre.

A fő funkciója az Excel importőr hogy lehetővé teszi, hogy meghatározza a konfigurációs fájl (azaz a hierarchikus építészeti modelljét). A konfigurációs fájl tárolja a korábban elmentett leképezés egy Excel fájlt egy ABACUS fájlt. Miután megadtad, a mentett konfigurációs fájlt később felhasználható a további importálása és exportálása a .xls fájlok.

hangjegy

A bemutatott lépések az alábbiakban leírt kifejezetten azok számára, akik még nem határozza meg, és egy konfigurációs fájlt, és importál excel először. Létre kell hoznia, és egy konfigurációs fájlt használja az export excel funkció.

Importálni egy Excel táblázatot ABACUS

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza a Fájl | Új és válasszunk a ExcelA megjelenő párbeszédablakban kattintson az OK gombra.

hangjegy

Ha szeretné importálni meglévő ABACUS projekt akkor vagy kattintson jobb gombbal a komponensek csomópont architektúrán belül, vagy kattintson jobb gombbal az egyes komponensek architektúrán belül, majd válassza Import | Excel.

3. A Import Excel munkalapablak

Import Excel táblázatkezelő ablak

4. Kattintson a Nyílt Excel fájlIkon és böngésszen az Excel-fájlt szeretne importálni.

5. Válaszd a Munkalapimportálni kívánja a legördülő menüből.

hangjegy

Megnyitása után a Excel fájlt, akkor a Adatok megtekintéselapon megtekintheti az oszlopokat, és az első 25 sorban a táblázat. Innen lehet szerezni az oszlop szám szükséges kitölteni a Alkatrészek és Kapcsolatokfület.

Azt is megadhatjuk, hogy vagy nem akarnak alkatrészek az Excel táblázatkezelő importálni kell a kis- és nagybetűk. Egyszerűen jelölje be a Import a kis- és nagybetűkopciót (alapértelmezés szerint ez mindig rovatot) és a munkafüzet lesz behozni kell.

Minta Excel fájl

hangjegy

Ebben a példában most importálni egy egyszerű infrastruktúra és Emberek Építészet az excel mutatott adatok a fenti képen. Kapcsolatok fog tenni a "nép felelős", és a "Servers", hogy azok az emberek, adminisztrálni.

Feltölthető a komponensek lap

Ez a szakasz a meghatározó komponens típusok hierarchikus struktúráját a konfigurációs fájl.

1. Válassza ki a Alkatrészekfület. Nevezze át a Készülék azonosítónyomós a (nulla) érték

hangjegy

Ez a funkció lehetővé teszi, hogy meghatározza teljesen más KészletekA funkcionálisan elkülönülő elemek. Amint az az alábbi képen, akkor érdemes megkülönböztetni az infrastrukturális alkatrészeket a People alkatrészeket. Ha vannak összefüggések (kapcsolatok) közötti külön meghatározza az alkatrészek, akkor lehet meghatározni alatt Kapcsolatokfület. Később ebben a példában definiálunk kapcsolatok típusú "Adminisztrálja" között az infrastruktúra és az emberek Készletek.

Azt is megadhatjuk, hogy vagy nem szeretne adni egy felső szintű Csoportosításkomponens az összes halmaz elemeit. Egyszerűen jelölje be a Csoport alatt Set IDopciót (alapértelmezés szerint ez nincs bejelölve), és a munkafüzet lesz behozni kell.

Hozzárendelése Set ID

2. Egyszer a Készletekmeghatározásra kerültek ki a Készletszeretne venni és bővíteni, kattintson a [+] jel.

3. Válassza ki Szintek komponensek a készletbenA kibővített listája.

4. A Komponens hierarchia megállapítja: Set IDablak jelenik meg, az adott Készlet.

Részegység hierarchiája és értékeket (Set ID: Infrastruktúra)

5. Nevezze át a Szint számaoszlop nyomós a (nulla) érték.

hangjegy

A Szint számaoszlop lehetővé teszi, hogy rendelni egy hierarchia az összetevők. Minden szint megfelel egy réteg belül az architektúrának, amelyben az első szint a legfelső szülő szint. Például szint "1" szám megfelel a legfelső réteg hierarchikus, Level száma "2" a gyermek a szint száma "1" és így tovább.

6. Válassza ki és jelölje ki a megfelelő oszlopot a Excel táblázatkezelő az egyes Szint számabeírással alatt Komponens oszlop oszlop.

hangjegy

Kiválaszthatja, hogy bizonyos sorok nem szeretné, hogy képviseltesse magát az architektúrának. Ezek lehetnek oszlop fejlécét, üres sorok, stb zárja sort használja a Sorok kizárni:szövegmezőbe, közel a jobb felső sarokban az ablak. Ebben a példában a kizárt 1. sor, mert tartalmazza a oszlop fejlécét.

7. Választhat, hogy hozzá leírásokat, hogy az összetevők felülírásával a (nulla)értéket a Leírás oszlop.

hangjegy

A leírás, amit meg fog jelenni ABACUS alatt Általános tulajdonságokszakaszban | Leírás mező.

8. Ha egy adott táblázatkezelő oszlop egynél több komponens cellánként (belépett az Alt + Enter vagy a CHAR (10) parancsot), akkor jelölje be a jelölőnégyzetet alatta Kényeztesse New Lines külön komponensként. Minden sor kerül importált külön komponensként.

Tipp

Importálni "mátrix" gyűjteményéből oszlopok, ahol "X" egy adott "mátrix" cell (sejt B2: D2 mondják) azt jelenti, hogy az alkatrész által meghatározott sorban (A2 cellában mondani) csatlakozik az alkatrész által meghatározott "oszlop" cím (1. sorának mondjuk), egy egyszerű képlet alkalmazható. Adja meg a következő képlet minden sorban egy oszlopban túl a mátrix sejtek (F oszlop mondják); = HA (B2 = "", "", B $ 1 & CHAR (10)) és HA (C2 = "", "", C $ 1 & CHAR (10)) és HA (D2 = "", "", D $ 1 & CHAR (10)). Aztán hozott létre kapcsolatot pontban leírtak alábbiakban a komponensek között által megadott sor (az A oszlopban mondják), és azok által leírt ez a képlet (az F oszlop mondani). Ügyeljünk arra, hogy a Kényeztesse New Lines külön komponenskéntopciót, ha a komponensek a képletből importálják. A fejlettebb mátrix import, beleértve a következő megnevezéseket több réteg hierarchia vagy sejtek eltérő értékek, mint csak egy sima "X", kérjük, forduljon Avolution Támogatás .

9. Töltsük ki a többi oszlop szükséges.

hangjegy

Kiválaszthatja, hogy milyen típusú az oszlopról sorok checkbox bejelölésével alatt Get Type A-oszloposzlop, és beírja a megfelelő oszlop Excel táblázatkezelő alatt Alkatrész Típus Érték vagy oszlop oszlop. Ez fogja importálni az összes alkatrészt az adott oszlopban, és állítsa őket, hogy meghatározott típusú oszlop. Alternatív és mint a képernyő lövés felett és alatt, akkor választhat, hogy egy fix / előre meghatározott típus név megadásával a típus neve alatt Alkatrész Típus Érték vagy oszloposzlop és ügyelve a négyzet nincs un-ellenőrizték.

Részegység hierarchiája és értékeket (Set ID: Emberek)

hangjegy

Ebben a példában azt kívánjuk, hogy a hálózatok és az emberek csoportosulások 1. szinten az építészetnek. A 2. szinten is szeretnénk ha a szerverek és az emberek igazgatásáért felelős e szerverek. A Alkatrészekfül már kitöltve ennek megfelelően, amint az a két screenshotok fenti. Az első képen fent meghatároztuk a szint 1 (hálózati csoportosítás) és 2. szint (szerver) alkatrészek az infrastruktúra- Készlet. És a screenshot közvetlenül felette meghatároztuk a szint 1 (emberek csoportosítás) és 2. szint (felelős személyek) alkatrészek az emberek Készlet.

Alternatív módon, a EmberekSet használata helyett a C oszlop, mint az emberek csoportosulása, mi lehetett volna használni a Csoport alatt Set IDopciót a legfelső szintű komponenseket fülre, majd csak belépett egy nép alsóbb szintű oszlopból D. Ezt mutatja a lenti képen.

Részegység hierarchiája és értékeket használó csoport alatt Set ID opciót (Set ID: Emberek)

10. Miután az alkatrészeket azonosítottak, válassza ki a komponens szinten kíván feltölteni a tulajdonságok és / vagy normák és bővítése, kattintson a [+] jel.

11. Válassza ki Az alkatrészek tulajdonságainak ezen a szinten vagy a Komponens szabványok ezen a szintenA kibővített listája és feltölti a megfelelő oszlopában szükséges.

Benépesítő Components

hangjegy

Az alkatrészek tulajdonságainak ezen a szintenmegadható, hogy a tulajdonságai elemek a kiválasztott szint. Komponens szabványok ezen a szintenlehetővé teszi, hogy meghatározza a szabványokat és szabvány tulajdonságait alkatrészeket a kiválasztott szint.

12. Ismételje 2-11amíg az összes komponens szinten benépesítették az összes definiált Készletek. A hátsó melletti nyílra a jobb felső sarokban az ablak lépjen vissza a Készletekamit korábban megadott.

Feltölthető a Kapcsolatok fülre

Ez a szakasz a meghatározó a kapcsolat típusát és a hierarchikus felépítés a konfigurációs fájl.

1. Válassza ki a Kapcsolatokfület. Minden kapcsolatrendszer van, hogy azonosítsuk azt a komponenst Készlethogy azt szeretné, hogy a forrás alkatrészek és alkatrész Készletazt szeretné, hogy a cél alkatrészeket.

2. Alatta a Forrás komponens szett ID írd be a Készletnév, amely megfelel a Készletdefiniált korábban a Alkatrészekfület. Alatta a Forrás komponens szinten számaadja meg a számot alkotóelemének megfelelő szintet szeretne csatlakozni a forrás végén a kapcsolatot.

3. Most melyik komponens csoport lesz a cél végén a kapcsolatot. Alatta a Destination komponens szett ID írd be a Készletnév, amely megfelel a Készletmeghatározása a Alkatrészekfület. Alatta a Destination komponens szinten számaadja meg a számot alkotóelemének megfelelő szintet szeretne csatlakozni a célállomáson végén a kapcsolatot.

hangjegy

Ebben a példában szeretnénk csatlakozni az emberek kezeléséért felelős szerverek a szerverek az általuk felügyelt. Az emberek felelősek definiálva a People KészletMint a 2. szint komponenseket, míg a szerverek meghatározták az infrastruktúra- KészletMint a 2. szint alkatrészeket. A Kapcsolatoklapon már megfelelően kitölteni, amint az a lenti képen.

Kapcsolatok fül Part 1 of 2

4. Ha lapozzunk jobbra, meg fogja találni az extra opciókat importálja a kapcsolatokat. Get Type A-oszlop és Csatlakozás típusa Érték vagy oszlopugyanúgy működnek, mint a Alkatrészekfület.

5. Ha a Forrás komponens szett ID és a Forrás komponens szinten számaugyanazok, mint a Destination komponens szett ID és a Destination komponens szinten száma(például, ha csatlakozik az azonos komponens típusok vannak, így a kapcsolatok szerverek a más szerverek), akkor meg kell, hogy egy másik oszlopot a táblázat, amely azoknak a nevét, szerverek ismételni. Ebben a helyzetben meg kellene tenni, hogy a táblázatkezelő oszlopot a Úti cél oszlop ismételten oszlop. Ha ebben a táblázatkezelő oszlopban beírt több mint egy csatlakoztatott készülék cellánként majd jelölje be a jelölőnégyzetet alatta Kényeztesse New Lines külön komponensként.

Kapcsolatok fül 2. rész 2

6. Amint a kapcsolat azonosítottak válasszuk ki a kapcsolatot szeretne venni a tulajdonságok és / vagy normák és bővítése, kattintson a [+] jel.

7. Válassza ki Tulajdonságok ezek a kapcsolatok vagy Szabványok ezek a kapcsolatokA kibővített listája és feltölti a megfelelő oszlopában szükséges.

hangjegy

Tulajdonságok ezek a kapcsolatokmegadható, hogy a tulajdonságokat a kiválasztott kapcsolódási csoportot. Szabványok ezek a kapcsolatoklehetővé teszi, hogy meghatározza a szabványokat és szabvány tulajdonságait a kiválasztott kapcsolódási csoportot.

8. Ismételje 2-7amíg az összes kapcsolat csoportok már definiált.

9. Ha befejezte meghatározó kapcsolat csoportok, kattintson a befejezésgombra, és az építészet jön létre az importált Excel fájlt. A fenti példa azt eredményezi, hogy az építészet látható a lenti képen.

Minta Építészet importált Excel

10. Most mentse el a leképezett konfigurációs fájlba, kattintson a A beállítások mentése ikon. Az elmentett konfigurációt lehet letölteni kattintva később a Nyiss egy konfigurációsikon mellett a bal felső sarokban az ablak.

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Benépesítő az architektúrának Access | Benépesítő az architektúrának Visio


Benépesítő az architektúrának a Microsoft SharePoint

Navigáció: Népszerű az architektúrának> Népszerű a Microsoft termékek>

Benépesítő az architektúrának a Microsoft SharePoint

Küldje el észrevételeit ebben a témában.

tudsz szinkronizálni Ön építészet val velMicrosoft SharePoint-listák. A szinkronizálás során akár új SharePoint-listák (és oszlopok) ad ABACUS típusú, azok tulajdonságait és a mellékleteket, illetve feltérképezése meglévő SharePoint-listák (és oszlopok) ABACUS típusú, azok tulajdonságait és a mellékleteket, akkor vagy küldő tartalmat ABACUS a SharePoint vagy a SharePoint hogy ABACUS.

hangjegy

A SharePoint szinkron funkció megköveteli, hogyegy Microsoft SharePoint 2010, 2013, vagy SharePoint Online helyén áll a csatlakozásra, és szinkronizálni.Míg a SharePoint Sync funkció is felsorolja (oszlopok) a SharePoint webhely bármely ABACUS projekt, Avolution is nyújthat különböző SharePoint webhelysablonként támogató egységes keretek (pl TOGAF, ArchiMate, ITIL stb) kérem forduljon Avolution Támogatás Ha szüksége van erre lehetősége.

Hogy hozzon létre egy új SharePoint-lista és térkép azt egy ABACUS alkatrész vagy összeköthető

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza ki Eszközök | SharePoint szinkron.

3. Kattintson a Új Mappinggombra, és a SharePoint Mapping párbeszédablakban az alábbi módon jelenik meg.

4. Írja be a webhely URL-címe, felhasználónév és a jelszó a SharePoint oldalon, és kattintson Kösse.

hangjegy

Érvényes SharePoint "admin" vagy "közreműködő" fiók szükséges szinkronizálni és a SharePoint és a "olvasó" számla csak akkor engedi szinkronizálás SharePoint.

5. Válassza ki a ABACUS alkatrész vagy összeköthető, hogy feltérképezze a Válasszon típust húzd le.

6. Kattintson a Új hozzáadásagombot, majd az egyes ABACUS alkatrész vagy összeköthető szempont szeretné hozzárendelni a megfelelő SharePoint-lista mezőben válasszon ki egy elemet a bal oldali panelen, és a jobb oldali panelen adja meg az új SharePoint-lista nevét az Új lista oszlopában (csak az első alkalommal) , akkor a SharePoint oszlop neve az oszlop nevét (vagy használja az alapértelmezett), majd kattintson Rendeljen minden alkalommal.

hangjegy

A minimum, hogy a szinkronizálás a ABACUS EEID, Építészet és címe szempontokat automatikusan leképezve a SharePoint száma, és két (2) Egy sor szöveg (aka szöveg) oszlopok rendre. Ezeket nem lehet hozzárendelve. Emellett csak bizonyos ABACUS szempontok jelenleg térképezni, hogy bizonyos SharePoint oszlopok és a Column legördülő automatikusan beállítja a kívánt SharePoint oszlop típusa. Ugyanis;

· ABACUS "hierarchiája Út a SharePoint többsoros szöveg (aka Megjegyzés) oszlopok (Megjegyzés: A SharePoint egyetlen sornyi szöveget (aka szöveg) oszlopok csak támogatni 255 karakter, így nem előnyös),

· ABACUS "rögzített alkatrészeket a SharePoint keresése oszlopok (Megjegyzés: A térképészeti már léteznie kell egy listát a mellékelt komponensek magukat),

· ABACUS "szöveg és leírás ingatlan a SharePoint többsoros szöveg (aka Megjegyzés) oszlopok (Megjegyzés: A SharePoint egyetlen sornyi szöveget (aka szöveg) oszlopok csak támogatni 255 karakter, így nem előnyös),

· ABACUS "Tizedes vagy integer tulajdonságokat SharePoint száma oszlopok,

· ABACUS "Lista tulajdonságok a SharePoint Choice oszlopok (Megjegyzés: A SharePoint nem kényszeríti a választás értékek, így a lista adattípus nem kell érvényesíteni ABACUS),

· ABACUS "Dátum / idő tulajdonságokat SharePoint többsoros szöveg (aka Megjegyzés) oszlopok (Megjegyzés: A SharePoint Dátum és idő oszlopok nem használhatók miatt még SharePoint következetlen támogatása időzóna / regionalizáció beállítások),

· Abacus logikai tulajdonságokat SharePoint Igen / Nem (aka logikai) oszlopok.

Az ABACUS elem a kapcsolódó szabványokkal nem lehet térképezni, hogy a SharePoint oszlopai még.

7. Válassza ki Hozzon létre Mapping.

Hogy hozzon létre egy új leképezés közötti ABACUS alkatrész vagy kapcsolat típusát és a meglévő SharePoint-lista

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza ki Eszközök | SharePoint szinkron.

3. Kattintson a Új Mappinggombra, és a SharePoint Mapping párbeszédablakban az alábbi módon jelenik meg.

4. Írja be a webhely URL-címe, felhasználónév és a jelszó a SharePoint oldalon, és kattintson Kösse.

hangjegy

Érvényes SharePoint "admin" vagy "közreműködő" fiók szükséges szinkronizálni és a SharePoint és a "olvasó" számla csak akkor engedi szinkronizálás SharePoint.

5. Válassza ki a ABACUS alkatrész vagy összeköthető, hogy feltérképezze a Válasszon típust húzd le.

6. Válassza ki a SharePoint webhely listát, hogy feltérképezzék a Válassza ki a lista húzd le.

7. Minden ABACUS alkatrész vagy összeköthető szempont szeretné hozzárendelni a megfelelő SharePoint-lista oszlopában válasszon ki egy elemet a bal oldali panelen, és a jobb oldali panelen rendre és kattintson Rendeljen.

hangjegy

A minimum, hogy a szinkronizálás a ABACUS EEID, Építészet és címe szempontokat kell térképezni, hogy a SharePoint száma, majd az Építészet és neve, hogy akár egy sornyi szöveg (aka szöveg) vagy több sornyi szöveget (aka Megjegyzés) oszlopok rendre. Amíg ez nem történt, a Create Mapping gomb nem lesz engedélyezve. Emellett csak bizonyos ABACUS szempontok jelenleg térképezni, hogy bizonyos SharePoint oszlopok. Ugyanis;

· ABACUS "Építészet szempont, hogy a SharePoint egyetlen sornyi szöveget (aka szöveg) vagy több sornyi szöveget (aka Megjegyzés) oszlopok (ez szükséges a megfelelő tartalmat feltérképezése az alábbiakban megadott),

· ABACUS "hierarchiája Út a SharePoint egyetlen sornyi szöveget (aka szöveg) vagy több sornyi szöveget (aka Megjegyzés) oszlopok (Megjegyzés: A SharePoint egyetlen sornyi szöveget (aka szöveg) oszlopok csak támogatni 255 karakter, így minden további karakter lesz csonka és ezért ajánlott átalakítani őket, hogy több sornyi szöveget (aka Megjegyzés) oszlopok SharePoint előtt mapping),

· ABACUS "rögzített alkatrészeket a SharePoint keresése oszlopok (Megjegyzés: A térképészeti már léteznie kell egy listát a mellékelt komponensek magukat),

· ABACUS "szöveg és leírás ingatlan a SharePoint egyetlen sornyi szöveget (aka szöveg) vagy több sornyi szöveget (aka Megjegyzés) oszlopok (Megjegyzés: A SharePoint egyetlen sornyi szöveget (aka szöveg) oszlopok csak támogatni 255 karakter, így minden további karakter lesz csonka és ezért érdemes átalakítani őket, hogy több sornyi szöveget (aka Megjegyzés) oszlopok SharePoint előtt mapping),

· ABACUS "Tizedes vagy integer ingatlan a SharePoint száma oszlopok (Megjegyzés: A SharePoint Számított oszlopok is használhatók azonban ezek csak akkor lesz képes szinkronizálni a SharePoint ABACUS. Próbál szinkronizálni", hogy "egy számított oszlopot, amelynek eredményeképpen a figyelmeztetést, mint egy alább) ,

· ABACUS "Lista tulajdonságok SharePoint Choice oszlopok,

· ABACUS "Dátum / idő tulajdonságokat SharePoint többsoros szöveg (aka Megjegyzés) oszlopok (Megjegyzés: A SharePoint Dátum és idő oszlopok nem használhatók miatt SharePoint következetlen támogatása időzóna / regionalizáció beállítások),

· Abacus logikai tulajdonságokat SharePoint Igen / Nem (aka logikai) oszlopok.

Az ABACUS elem a kapcsolódó szabványokkal nem lehet térképezni, hogy a SharePoint oszlopai még. És a SharePoint valuta, személy vagy csoport, hivatkozás vagy kép, feladat eredménye, Külső adatok és menedzselt metaadatok oszlopok nem leképezve ABACUS szempontokat még.

8. Válassza ki Hozzon létre Mapping.

Hogy szinkronizálniA Microsoft SharePoint-lista (ek)a ABACUS

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza ki Eszközök | SharePoint szinkron.

hangjegy

Hogy szinkronizálja a SharePoint-lista egyABACUS projekt a felhasználói licencet szüksége SharePoint szinkronadd-on képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

3. Válasszon ki egy meglévő SharePoint térképezés (vagy leképezések segítségével Ctrl + kattintás vagy a Mindet kiválasztgombot) a SharePoint Mappingspanelamint az a minta képernyőkép felett. Megjegyzés: itt mutatunk, csak a "Cél (vagy szükséglet)" ABACUS alkatrész leképeződik egy SharePoint-lista nevű célok kiválasztásakor.

4. Válassza ki a Architecture (k), hogy szeretne szinkronizálni tartalom a Sync tartalomjegyzék architektúrákpanel bemutatott minta screenshot felett. Megjegyzés: itt mutatunk, csak a "2015 Actual" építészet szinkronizálva lesznek.

5. Válassza ki a Sync SP gomb.

hangjegy

Ha a SharePoint webhely hitelesítő nem "Minden mentve" a térképezés (ek) választja, akkor a Belépés SharePoint ablak jelenik meg, kérve a Honlap URL, Felhasználói név és / vagy Jelszó.Írja be a képen. Továbbá, a szinkronizálás tartalmazni fog bármilyen más leképezések, amelyek szükségesek a csatolt komponensek / lookup oszlopokat. Bármilyen további leképezés, hogy automatikusan tartalmazza jelenik meg a dialógus, mint egy alább.

6. Sikeres szinkronizálás a SharePoint szinkronizálás eredményei ablak jelenik meg az alábbiak szerint felsorolja a változásokat, és minden figyelmeztetés. Kattintson oké.

Hogy szinkronizálni ABACUS hogy A Microsoft SharePoint-lista (ek)

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza ki Eszközök | SharePoint szinkron.

hangjegy

Hogy szinkronizálja a SharePoint-lista egyABACUS projekt a felhasználói licencet szüksége SharePoint szinkronadd-on képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

3. Válasszon ki egy meglévő SharePoint térképezés (vagy leképezések segítségével Ctrl + kattintás vagy a Mindet kiválasztgombot) a SharePoint Mappingspanelamint az a minta képernyőkép felett. Megjegyzés: itt mutatunk, csak a "Cél (vagy szükséglet)" ABACUS alkatrész leképeződik egy SharePoint-lista nevű célok kiválasztásakor.

4. Válassza ki a Architecture (k), hogy szeretne szinkronizálni tartalom a Sync tartalomjegyzék architektúrákpanel bemutatott minta screenshot felett. Megjegyzés: itt mutatunk, csak a "2015 Actual" építészet szinkronizálva lesznek.

5. Válassza ki a Sync segítségével SP gomb.

hangjegy

Ha a SharePoint webhely hitelesítő nem "Minden mentve" a térképezés (ek) választja, akkor a Belépés SharePoint ablak jelenik meg, kérve a Honlap URL, Felhasználói név és / vagy Jelszó.Írja be a képen. Továbbá, a szinkronizálás tartalmazni fog bármilyen más leképezések, amelyek szükségesek a csatolt komponensek / lookup oszlopokat. Bármilyen további leképezés, hogy automatikusan tartalmazza jelenik meg a dialógus, mint egy alább.

6. Sikeres szinkronizálás a SharePoint szinkronizálás eredményei ablak jelenik meg az alábbiak szerint felsorolja a változásokat, és minden figyelmeztetés. Kattintson oké.

hangjegy

ABACUS frissíti a SharePoint oszlopok üres értéket akkor is, ha "megkövetelése, hogy ez az oszlop tartalmazza információ" pontban az Igen SharePoint. Ez azért van, mert a SharePoint nem teszi ki ezt a beállítást külsőleg. Ha ez kell akadályozni azt ajánlják, hogy az ABACUS Tervező beállítja a szükséges kényszert Igaz és végrehajtja az adott ingatlan használata ABACUS " kényszer funkció .

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Benépesítő az architektúrának Visio | Benépesítő az architektúrának Excel


Benépesítő az architektúrának a Microsoft SQL Server

Navigáció: Népszerű az architektúrának> Népszerű a Microsoft termékek>

Benépesítő az architektúrának a Microsoft SQL Server

Küldje el észrevételeit ebben a témában.

A behozatal a architektúra egy Microsoft SQL Server adatbázisba. Akkor a választás, hogy csak importálni az asztalok és kapcsolatok hatékonyan importáló csak az általános szerkezetet az adatbázisban, vagy a táblázatok, sorok és kapcsolatok, amelyek importálni nem csak a szerkezet, de az adatok is.

hangjegy

Az SQL Server funkció megköveteli, hogy A Microsoft SQL Server 20052008, 2008 R2, 2012-ben vagy 2014telepítve van a számítógépre.

Importálni a Microsoft SQL Server adatbázist ABACUS

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza a Fájl | Új és válasszuk SQL ServerA megjelenő párbeszédablakban kattintson az OK gombra.

3. Az Import SQL Server megjelenő párbeszédablakban állítsa be az "SZÁMÍTÓGÉPNÉV" és "SQLINSTANCE" értékeit a kapcsolat string változó és a "DBNAME" értékét az adatbázis neve változó, hogy a helyes értékeket, amint az a minta lenti képen.

4. Állítsa Az adatbázis neve változó értéke megegyezik az eredetileg Katalógus változó meg a fenti lépést, amint az a minta lenti képen.

5. Nyomja meg a Kapcsolat tesztelése gombra, és a táblázatok importálása részben a dialógus kell kitöltenie a rendelkezésre álló adatbázis táblákat, amint az a minta lenti képen.

6. Válassza ki a táblákat, hogy az importálni kívánt akár egyénileg kiválasztja azokat, vagy a Minden, Nincs és megfordítása a jobb oldali gombokkal a párbeszéd.

hangjegy

Csak a Foreign Key kapcsolatok között fennálló Asztalok, hogy válassza kap importált.

7. Az Importálás Stílus bejelölésével válassza ki, hogy az importálni kívánt csak a táblázatok és a közöttük lévő kapcsolatok, vagy a táblázatok, a sorok és a konkrét kapcsolatok a sorok között.

hangjegy

Az első lehetőség importálja a táblázatok elemeiként típusú "Táblázat", és a kapcsolatok bármely két asztalok (az idegen kulcsok) hoznak összeköttetést a típus "táblázat kapcsolat". Ez egy klasszikus "ERD" stílusban véve a rendszer táblák. A második lehetőség importálja a Táblázat sorok diszkrét alkomponensei típusú "Táblázat sor" megfelelő tulajdonságokkal rendelkező egyes oszlopok / mezők és kapcsolatok a táblázat sorai a típus "táblázat kapcsolat". Továbbá, ha van egy oszlop / területen úgynevezett "Név", akkor ez az elnevezés az egyes Táblázat sor alkomponenseket.

8. Válassza ki az Import ... gombra.

9. Egy rövid ideig (egy progress bar visszajelzést) új ABACUS projekt jön létre az asztalok, táblázatsorokat (ha a második lehetőséget választotta az előző lépésben) és kapcsolatok a Microsoft SQL Server adatbázis.

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Benépesítő az architektúrának Visio | Benépesítő az architektúrának Excel


Benépesítő az architektúrának a Microsoft Visio

Navigáció: Népszerű az architektúrának> Népszerű a Microsoft termékek>

Benépesítő az architektúrának a Microsoft Visio

Küldje el észrevételeit ebben a témában.

A behozatal a építészetének Microsoft Visio. Alakzatok a Visio rajz kerül importálásra komponenseket ABACUS. Kapcsolatok a Visio rajz kerül importálásra kapcsolatok és a rajz maga lesz behozni ABACUS mint egy rajz. Továbbá, egyéni tulajdonságot a Visio rajz kerül importálásra ingatlan a Rendezés gombot leképezve az ingatlan típusa, címke, hogy a tulajdonság nevét és értékét az ingatlan értékét.

hangjegy

Az Importálás Visio funkció megköveteli, hogy A Microsoft Visio 2003vagy újabb telepítve van a számítógépre.

Importálni a Visio rajzok ABACUS

1. Győződjön meg arról, hogy van ABACUS nyitva.

2. Válassza a Fájl | Új és válasszuk A VisioA megjelenő párbeszédablakban kattintson az OK gombra.

hangjegy

Ha szeretné importálni meglévő ABACUS projekt akkor vagy kattintson jobb gombbal a komponensek csomópont architektúrán belül, vagy kattintson jobb gombbal az egyes komponensek architektúrán belül, majd válassza Import | A Visio.

3. Keressük meg a Visio fájlt szeretne importálni.

hangjegy

Az alábbiakban néhány egyszerű szabályt, vagy ajánlott gyakorlatokat építésekor (vagy módosítása) egy MS Visio rajz behozni ABACUS.

1. A vonalak vagy kapcsolatokat kell tényleges csatlakozók, NEM formák.

· Ellenkező ABACUS majd csak importálni őket alkatrészek és ennek megfelelően nem lesznek "csatolt" semmihez.

· Ha meg kell csinálni néhány "okos" routing (azaz más, mint egy egyenes vonal) majd a Dynamic csatlakozó az Egyszerű alakzatok stencil, ABACUS importálja a routing / kikötési pontok finom.

· Próbálja meg elkerülni a "Ring hálózat" és "Ethernet" formákat a Hálózat és perifériák stencil, amely lehetővé teszi sok komponensek "csatlakozik" rá. Míg mi a behozatali mellékletek bírság kapcsolatokat az eredeti formát is "habosított", hogy tükrözze a mellékleteket. Használjon külön külön "hub / busz" alakú (anélkül, hogy a csatlakozó "láb"), majd kifejezetten csatlakozni minden komponenst, hogy az agy / busz külön csatlakozókkal.

· Ha egy sor vagy a kapcsolat úgy viselkedik, mint egy forma, jobb klikk, és megy a "Formátum | Viselkedés ... ", és győződjön meg arról, hogy Interaction stílusa van állítva vonal (1 dimenziós).

2. A komponenseket kell alakzatok NEM csatlakozók.

· Ellenkező ABACUS majd csak importálni őket kapcsolatok és ennek megfelelően minden formája információ elvész.

· Ha egy alkatrész úgy viselkedik, mint egy csatlakozó, jobb klikk, és megy a "Formátum | Viselkedés ... ", és győződjön meg arról, hogy Interaction stílusa van állítva Box (2 dimenziós).

3. Csatlakozó végek kell csatolni formák, NEM lebeg a hátteret az alakzatot.

· Ha nem csatlakoztatja a csatlakozókat, hogy a formák akkor ABACUS már nem lehet tudni, hogy célja, hogy rögzítse a megadott csatlakozót a forma / komponens, és ennek megfelelően fogja hagyni, hogy vége a kapcsolatot az ENSZ-csatolták.

4. Címkék formák legyen (ahol lehetséges) a beépített szöveges címkét az alakja, nem külön mezőbe a rajzon.

· Külön mezőkbe kap által behozott ABACUS mint alkatrészek saját jogon, és amíg lehet összevonni a "címke" komponens az igazi eleme ABACUS, vagy csak átalakítani a "címke" komponens egy szabálytalan alakú formát (azaz nem a komponens maga) a legjobb, hogy elkerüljék ezeket a lépéseket.

5. Használja ugyanazt a bázis alakja minden esetben azonos típusú, ne legyen lusta, és használja téglalapot, és néha doboz mások különböző alakú stencil.

· ABACUS használja a bázis forma és a alapszínt egyedileg azonosítani az alkatrész és csatlakozó típusok a rajz, így a "vörös négyszög" és a "piros doboz" kap behozott két külön komponens típusok. Ezek a komponens típusok össze lehet vonni a ABACUS de a legjobb, hogy elkerüljék ezeket a lépéseket.

6. Teljes egészében felölelik "gyerekek" alakzatok belül "szülők", ne hagyjuk őket lóg szélére.

· ABACUS érzékeli minden formája, hogy teljes mértékben látnak el egy másik formája, mint a gyermek, a szülő úgyhogy győződjön meg róla az egész alakja, beleértve a címke részét, zárt.

7. Ne helyezze a forma átfedő két másik alak.

· Ha egy alak átfedésben van két másik formában, legyen az egy "csoportban" / háttér téglalap vagy más módon, akkor importálható ABACUS alkotórészeként, hogy gyermeke nem átlapolt formák, de amint kiválasztja a komponens ABACUS "rajzeszköz , mivel a bal felső, hogy a komponensek referencia pont, ez lesz a gyermek a bal átfedésben alakja / komponens.

8. Megpróbálja minimalizálni a használatát szöveges megjegyzéseket a rajzon, mert ezek kap behozni alkatrészeket saját jogon, és át kell alakítani a szabadkézi alakzatokat ABACUS. Gondolj, hogy azok valóban a nevét egy meglévő alkatrész vagy kapcsolatot.

9. Míg ABACUS támogatja a gazdag / színes / vektor-alapú formák, próbálja meg minimalizálni a használatát bitmap, külföldi formák és továbbfejlesztett Metafájlok a formák, mint ABACUS jelenleginélnemtámogassa ezeket a típusokat. Ők lesznek behozni egyszerű fehér téglalap.

10. Próbálja meg elkerülni a kocsi vissza (shift-vissza) a címkéket, ahogy azok az importált és látható, mint egy különleges karakter "[]" az ABACUS az összetevő neve.

11. Megpróbálja minimalizálni a különböző színek, hogy a használt formák az azonos típusú. Mint már említettük, az alapszín és az alap alakja egyedileg azonosítja alkatrész és csatlakozó típusok, így a több variáció is van annál beolvadó és konszolidáció, amely meg kell tenni utáni import ABACUS.

12. Legyen óvatos, mert tele formák ha egy forma tele van egészen a sarkokat, majd színezés később a ABACUS nem lesz hatása.

13. Az összetett sor-alapú formák akkor kell használni egy sokszög ami által létrehozott, amelynek kezdődő sorok, ahol az előzőt befejezte, majd végül megy vissza a kiindulási pont. Ha szükséges, akkor a kitöltés és vonalvastagság, hogy a sokszög néz ki, mint egy "nyíl", vagy bármi kívánt alakzat.

14. Ellenőrizze, hogy a formák ID MS Visio értelmes nem csak Shape.xx. Ez szerkeszthető segítségével jobb gombbal a 'Show ShapeSheet ", amely elérhető az MS Visio fejlesztői módban (révén lehetővé Tools | Options MS Visio).

15. És az ellipszis ívekbelüli formáktámogatottak ABACUS de NURBS és spline jelenleg nem támogatottak.

16. Győződjön meg róla, az egész alakja van csoportosítva MS Visio, vagy ez lesz behozni több összetevőből / típusait.

17. Megpróbálja minimalizálni a használatát elforgatott alakzatok belül subshapes mivel azok néha nem importálható helyesen.

Lásd még

Benépesítő az architektúrának - Áttekintés | Benépesítő az architektúrának kézzel | Benépesítő az architektúrának Access | Benépesítő az architektúrának Excel


Benépesítő az architektúrának kézzel

Navigáció: Népszerű az architektúrának> feltöltése manuálisan>

Benépesítő az architektúrának kézzel

Küldje el észrevételeit ebben a témában.

A magasabb szintű komponenseket és csatlakozásait építészet valószínűleg kell lakott kézzel. Általában ez lesz az elvontabb alkatrészek és csatlakozások.

Ha manuálisan feltölteni építészet

1. Győződjön meg arról, hogy van egy ABACUS fájlnyitott, egy felfedezőjelenik meg, és egy építészet hozzáadott .

2. Add alkatrész. Ezt csináld meg, Jobb klikkA területen a fa szeretne venni, és válassza Add alkomponens ..., Vagy kattintson a Új komponensgombot a Nézet eszköztár . Alkatrészeket csak ki az alkatrészeket ága a fa. Azt szeretné, hogy fadiagram hogy pontos ábrázolása az architektúrának. Amikor felfedezték az architektúrának, akkor megtanultam, hogy pontosan hogyan használható mindez együtt. Szükséged lesz ez a tudás, amikor hozzáadja az alkatrészek és csatlakozások. Ha hozzá az első komponenst, akkor add meg közvetlenül az összetevők ága. A többi a komponensek lehetnek ugyanazon a szinten a fában, vagy lehetnek al-komponensek az első.

3. Frissítse az értékeketa tulajdonságokValamennyi komponens felvételekor. Ezt csináld meg, kettyenésa komponens, és szerkesztheti a tulajdonságok jelennek meg a Tulajdonságok ablakban(jellemzően) jobbra. Tulajdonságok általában a dolgok, mint a követelmények, feldolgozó kapacitás, stb Ha ABACUS értékeli az architektúrának, majd kiszámítja néhány új tulajdonságokkal, és mentse őket vissza az architektúra. Az új tulajdonságok az adatokat próbál elemezni, mint a hasznosítás, válaszidő, sávszélesség, stb

4. Add hozzá a kapcsolatok és frissítéstulajdonságaikkirovó - csak úgy, mintha alkatrészek (de az Connections ágon szintén).

5. Erősítsecsatlakozások és alkatrészek. Ehhez keresse meg a kapcsolatot, kattintson valamelyik vége vagy szerepek , És húzza valamelyik összetevője. Vagy: kattintson a komponens, és húzza az egyik kapcsolat a szerepek (azaz forrás vagy nyelő). Vagy akkor kattintson a jobb gombbal, és húzza a komponenst a másikba összetevőre, majd válassza Kapcsolodni. Vagy egyszerűen kattintson jobb gombbal a komponens, és válassza Kapcsolatba .... Ha húzza a kapcsolat szerep, Észre fogod venni egy parancsikont jelképe ha pont egy komponens segítségével csatolja. Ez azt jelzi, hogy te nem készít másolatot, csak most teszi fel. Győződjön meg róla, csatolja a megfelelő helyre komponens. Például, ha ez a kapcsolat a Forrás szerepHúzza azt csinálni a forrás (azaz a komponens, amely a forrása az adatáramlás).

Tipp

Utánrendelésére egységei az architektúrának (pl alkatrész, csatlakozások stb) a felfedezőnagyon könnyű. Egyszerűen Kattintson| Tart| Dragaz érintett személy és hely, ahol kívánatos az architektúrának. A utánrendelésére funkciókat is lehetővé teszi, hogy helyezze egységei különböző hierarchiák Az architektúra.

Ön is szeretné

6. Add Szabványok (előre konfigurált Tulajdonságkészletek - beállítások), hogy az összetevők, csatlakozások vagy típusok

7. Tulajdonságainak módosítása Egy komponens, kapcsolat vagy típus

8. Undo és Redo művelet

9. Változtassuk meg a típus az alkatrész vagy kapcsolat

10. Hozzon létre egy új típusú, vagy típuscsoportja

11. Töröl Egy összetevő vagy kapcsolat

12. Hozzon létre, sokszorosítása illetve fejlődni egy olyan építészet

13. Import típusok és szabványok egy könyvtárból

14. Importálás más ABACUS fájlt, XML, Excel vagy Visio

15. Másolás és beillesztés rész (vagy az összes) Az architektúra

16. Keresés és csere elemek a építészet

17. Expand / néhány vagy az összes csomópontot a fában

18. Összeolvad tételek

19. Határozza és Érvényesít Megszorítások korlátozni a szerkezete a építészet

20. Fejlődik a építészet létrehozásához számos építészeti megoldások összehasonlítására és az alapvonal

Lásd még

Benépesítő az architektúrának - Áttekintés | Az új fájl létrehozása


Közzététel a weben

Navigáció: Jelentés az adott architektúrán>

Közzététel a weben

Küldje el észrevételeit ebben a témában.

ABACUS "Közzététel a weben funkció lehetővé teszi, építészeti modellek is megtekinthetők egy biztonságos weboldal. Architektúrák exportálják HTML formátumban, és célja, hogy tükrözze a kinézetét a Explorer ABACUS. Nézettség (beleértve a katalógusok, diagramok, 3D és grafikonok) szintén exportálhatók formátumok megtekinthető egy internet böngésző segítségével.

hangjegy

Jelenleg Nézőpontok és mátrixok nem tették közzé.

Közzétenni a építészeti modellek az interneten

1. Biztos van hozzá megfelelő ABACUS fájlnyitott, amely tartalmazza a lakott építészethogy szeretné közzétenni az interneten.

2. Válassza ki Fájl| Adja ....

3. A Közzététel a weben konfigurációablak.

Adja a webes konfigurációs

4. Alapértelmezésben minden része a modell kiválasztott beleértve a fa nézetben, a SzabványokA típusok, sablonok és építészet (ek). Törölje bármelyik része nem szeretné, hogy tegye közzé az interneten, az esetleges egyéni nézetek belül architektúra (ek).

Tipp

Ha azt szeretnénk, hogy elrejtse egyedi alkatrész, csatlakozások és / vagy azok tulajdonságait ajánlott, hogy egy adminisztrátor létrehoz egy "nyilvános" szerepkör ABACUS "szerep alapú hozzáférés funkció majd eltávolítja az Olvasás engedélyt azoktól komponens típusok, kapcsolat-típusok és / vagy tulajdonság, hogy nem kívánnak közzé. Ezután a felhasználó be kellene jelentkeznie alatt ezt a szerepet, és közzéteszi a weben, mint ABACUS csak közzé elemeket olvasási jogunk állítva a szerepet. Továbbá, a felhasználók automatikus közzé a parancssorból leírtak itt .

hangjegy

Kiválaszthatja a részek kattintva jeleníthető meg a Mindengombot vagy fordítsa a kiválasztást az a Invert gomb. Akkor is, kattintson a Egyik semgombot, hogy törölje a kiválasztást.

hangjegy

Ha törölje a Fa nézet opciótakkor se fa keretben (lásd alább) teszik közzé. Ennek megfelelően, akkor válassza ki a kezdő oldal szerint az alábbi 6. lépéssel, vagy közzététele után meg kell szabni akár a felső szintű; a) index.htmlfájl megváltoztatásával a "rokon src =" mainPage.html "name =" element_details "" sort, hogy közvetlenül hivatkoznak a vonatkozó html oldalon a Tartalom mappa, vagy, b) mainPage.htmlazáltal, hogy egy hivatkozást vagy átirányítani a megfelelő html oldalon a Tartalom mappa.

5. Kattintson a Opció gombot, és a következő Kiadó opciókpárbeszédablak jelenik meg.

Adjaer opciók

6. Smegválasztja a 3D, Diagramés grafikonok formátumok és hogy megjelenjen-e a cím, leírás, illetve ingatlanok a kilátást a rendelkezésre álló lehetőségek (lásd az alábbi megjegyzést észrevételeit a különböző formátumok).

7. Ha szeretné, hogy állítsa be a kezdő oldalon a publikált modell adott nézetben majd ellenőrizze a Használja Nézet kezdő oldalopciót, és keresse meg a néző a '...' gombra, hogy engedélyezett lesz.

hangjegy

Csak a nézetek kiválasztott területek szakaszban, mint egy lépés a fenti 4-ről kell állítani mint a kezdő oldalon.

8. Ha szeretné, hogy visszajelzéseket kapjanak a konkrét oldalakat a publikált modell, akkor ellenőrizze, hogy a E-mail Visszajelzésopciót választja, Adjon meg egy email címet a Email cím szövegdobozés szerkesztheti a E-mail Bodyfejezetben értelemszerűen. Ha nem szeretné, hogy visszajelzést küldeni, akkor törölje a E-mail Visszajelzésopciót, és hagyja üresen a szövegdobozt.

9. Kattints a oké gomb.

10. Kattints a Böngésszen gomb.

11. A Tallózás a mappákablak.

12. Válassza ki a kívánt helyet tárolni a felső szintű HTML fájlt (és minden automatikusan generált fájlok).

hangjegy

Ez egy jó ötlet, hogy hozzon létre egy külön mappába (általában az úgynevezett "publikált") segítségével Új mappagombra a dialógus ablak alján tárolni a felső szintű HTML fájlt, és a automatikusan generált fájlokat.

13. Kattints a oké gomb.

14. A mappa elérési útja jelenik meg a Directory szövegdoboz.

15. Kattints a befejezés gomb.

- vagy -

15. Írja be a mappa elérési útját a Directoryszövegdoboz, ahol tárolni szeretné a felső szintű HTML fájlt (és minden automatikusan generált fájlok).

16. Kattints a befejezés gomb.

hangjegy

Exportáló Diagramoknagyon ritkán sikerül, leggyakrabban, amikor a számítógép memóriája meg (általában használata esetén nagyon nagy fájlok). A sikertelen export újra megpróbáljuk egyszer. Lesz egy figyelmeztetés a sikertelen első kísérlet, és a második figyelmeztetést, ha az újbóli próbálkozás sikertelen. Ezért, ha csak a figyelmeztetések "első kísérlet sikertelen" is, a közzétételi sikeres volt. Ha az ismételt kísérlet meghiúsul próbáld közzé egy kisebb részét a fájl vagy szabadítson fel rendszermemória.

Az elmentett HTML fájl (ok) most kilátás a helyét vagy másolt egy biztonságos weboldal.

Közzététel a weben az Internet Explorer10

Bármilyen hivatkozásokat jött létre, hogy az eredeti modell lesz kitartott a publikált modell és linkre kattintva követi a linket a címzetthez (ha azt közzé). Ezen túlmenően minden eleme megjelent rajzok, amelyeket még nem linkelve az eredeti modell által linkelve vissza hozzájuk tartozó elemek a fa nézetben (ha megjelent), és kattintson az elem a közzétett rajz a hangsúly ugrik vissza az érintett helyen, a fa. Ez hasonló a "Show In Explorer" jobb-klikk funkciót ABACUS.

hangjegy

Avolution nyomatékosan ajánlja a következő szoftverek és fájlformátumok kell használni, hogy teljes mértékben kihasználni a Közzététel a weben funkcionalitás ABACUS:

1. Internet böngésző (80,0 felett)a megtekintéséhez a közzétett Explorer kilátás. Mozilla Firefox (30,0 vagy újabb)Ugyancsak ajánlott és teljes mértékben támogatottAzonban, ha az ajánlott SVG formátumban diagramok majd a Firefox 9 csak akkor tudjuk használni a natív SVG Viewer támogatás, amely sajnos nem teszi lehetővé zoomolás vagy eltolás.

2. Adobe SVG Viewer 3.0 csatlakoztat (letölthető itt ) és SVGfájlformátum a közzétett diagramok. Az SVG képformátumát diagramokajánlott, mivel; SVG egy vektor-alapú képformátum, ezért "veszteségmentes", és úgy néz ki, sokkal jobb, bármely adott nagyítási szinten, mint bármely más formátumok, SVG lehet behozni MS Visio, SVG lehet nagyított bármilyen szinten vagy a felbontás , SVG vannak kapcsolatai vissza a fa nézet a kapcsolat (nem csak a komponensek), SVG mindig elkészül egy jobb felbontású, és az SVG körülbelül a fele a fájl mérete más formátum. PNG a következő ajánlást, de mivel ez egy rasterised formátumban bizonyos nagyítási szinteken a világosság a néző elvész, és kattintással kapcsolatok diagramok nem ugrik vissza a megfelelő helyen, a fa. BMP elriasztani a bár ez egy "veszteségmentes" formázza a fájl mérete 100x, hogy a más formátumok és 20Mb képeket nem szokatlan.

A kompromisszum az SVG, hogy az SVG Viewer kell majd telepíteni, és meg kell győződjön meg arról, hogy .svg image / svg + xml adunk a webszerver MIME típusok. A telepítés után a SVG Viewer Microsoft Internet Explorer kérni fogja, hogy elfogadja a néző licencszerződést, és akkor kell működnie. És miközbenMozilla Firefox támogatja SVG-fájlok natívan, az Adobe plugin, még mindig ajánlotthogy képes nagyítani a rajzokat, ha használja a Firefox 8 vagy korábbi (ha használja a Firefox 9 nem tudja letiltani a natív SVG Viewer). Miután a telepítés az Adobe bővítmény már fut, a következő lépéseket kell használni a Firefox:

· Nyisd ki a Firefox és be az "about: config" (idézőjelek nélkül) a címsorba.

· Lapozzunk lefelé, és megtalálni az ingatlant svg.enabled(ha használja a Firefox 9, majd a natív SVG-nézés nem lehet kikapcsolni, és az ingatlan nem létezik). Kattintson duplán, tiltsa le azt.

· Most találni A könyvtár, ahol az SVG plugin telepítve (pl: C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Másolja a fájlokat NPSVG3.dll és a NPSVG3.zip, és illessze be őket a firefox plugins könyvtárba (pl C: \ Program Files \ Mozilla Firefox \ plugins)

· Zárja le az összes előforduló firefox

3. Avolution a ABACUS 3D Viewer (3.1 és újabb) és Avolution a .abacus3Dfájlformátum a közzétett 3D nézetek. Amíg a Cortona VRML Client plug-in (2.0 és újabb)elérhető, hogy megtekinthesse VRML változatai a közzétett nézetek nem ingyenes a kereskedelmi használatra, és mindig szükség van egy kliens oldali telepítést. Az ABACUS 3D Viewer több funkciókban gazdag, mint bármely VRML megjelenítő és szabadon letölthető itt . Mindkét esetben győződjön meg róla, add .vrml x-world / x-vrml és .abacus3d application / octet-stream a webszerver MIME típusok.

4. PNGfájlformátum a közzétett kör nézeteit. A PNG formátumot a kör nézetek ajánlott, mivel míg ez egy rasterised formátumban, és van "veszteség" trade-off a fájlméret és chart egyértelműség általában a legjobb. BMP elriasztani a bár ez egy "veszteségmentes" formázza a fájl mérete 20x, hogy a más formátumok és 2 MB diagramok nem szokatlan.

Ha meg szeretné változtatni a kinézetét a weboldalakat, akkor szerkesztheti a kezdőlapra nevű fájlt mainPage.html és a stíluslap nevű fájlt abacus.css. Meg fogja találni ezeket a fájlokat a mappába, ahol úgy döntöttek, hogy mentse a felső szintű HTML fájlt. További információk a struktúra és a szabás, a megjelent kimeneti lásd a következő szakaszt.

A szerkezet ABACUS megjelent modellek

Az ABACUS publikált modell felépítése a következő:

1. A felső szintű mappa tartalmazza több fájlt, és feltételezve, hogy minden lehetőség benne van az ABACUS Közzététel a weben konfigurációs párbeszédablak ez tartalmazni fog egy index.htmlfájl is három képkocka; treeView.html, findNode.html és mainPage.html és akkor shortcutError.htmloldal. A treeView.html által lakott az tree.js, tree_items.js és tree_tpl.js javascript fájlokat alatt található többek között mappába (lásd alább) és megismétli a Explorer fa ABACUS. A findNode.html hajtja a find.js javascript fájl alatt található többek között mappába (lásd alább), és megkeresi az ágak a fa helyett csak a látható csomópontok. Tő mainPage.html egy statikus HTML oldal szabható vállalati logók és hasonlókés jelenik meg, kivéve, ha egy kezdő oldal választották közzétételekor.És végül, a shortcutError.html oldal egy nyitóoldal bármilyen törött hivatkozások a fáról miatt a megfelelő oldalakon nem tették közzé.

Tipp

Azt, hogy kihagyja a mainPage.html összességében dönt, hogy használja a kezdőlapot a kiadói vagy módosításával az index.html fájlt, hogy pont közvetlenül egy adott nézetben (mondjuk) szerkesztésével a keret src = "mainPage.html" sort, hogy pont közvetlenül az első nézetet az első architektúra, jellemzően a "keretet" diagram.

2. A felső szintű includemappa tartalmazzaING különféle javascript (Js) és CSS (.css) által használt fájlokat a .html egész publikált modell.

3. A felső szintű tartalom mappa tartalmazza, betűrendben;

· A '3D Nézetek' mappa, számozottHTML oldal és a VRML vagy abacus3d fájl minden a közzétett 3D nézetek. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· Egy Architektúrák mappa, számozott HTML oldal minden architektúra, amely megjelent. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· A Katalógusok tartalmazó mappát számozott HTML oldal minden egyes közzétett katalógusok. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· A Táblázatok mappa, számozottHTML oldal és a PNG, JPG, stb aktát a közzétett Könyv nézetek. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· A Alkatrészek tartalmazó mappa számozottHTML oldal minden egyes közzétett komponenseket. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· A Kapcsolatok tartalmazó mappa számozottHTML oldal minden egyes közzétett csatlakozások. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· A Diagramok tartalmazó mappa számozottHTML oldal és a PNG, SVG, stb aktát a közzétett diagramok. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· Egy ikonok alattimappa val vel Különféle képeket, szerte a publikált modell.

· A Szabványok al-mappa, számozottHTML oldal bármilyen szabványoktettek közzé. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

· A Sablonok alatti-folder gyűjteménye a számozott alkönyvtárak minden közzétett formanyomtatvány a projektből. Az egyes al-mappa egy komponensek és kapcsolatok mappát és ezen belül a számozott HTML oldal minden komponens és kapcsolatot a sablon. Lásd az alábbi megjegyzést információt a mappa / fájl számozási sémát.

· A Típusok al-mappa komponens ésCsatlakozás al-mappákat egy számozottHTML oldal minden komponens ésCsatlakozási típusok, amelyeket közzéés a gyűjtemény a számozott alkönyvtárak mindegyik típus megjelent a projekt tartalmaz egy HTML oldal minden a megszorítások. Lásd az alábbi megjegyzést információt a mappa / fájl számozási sémát.

· A Kilátásponts al-mappát, és a számozottHTML oldal minden a Nézetponts tettek közzé. Lásd az alábbi megjegyzést információt a fájl számozási sémát.

hangjegy

A számozás az oldal HTML (és egyes esetekben a képfájlok) megegyezik a egyedi ID Minden adattár objektum volt be, amikor ez volt létrehozottbelül ABACUS (a továbbiakban EEIDs). Ez az azonosító nem változik, így mint ábrák, típusok, alkatrészek stb. vannak frissítve ők akaratmegtartja ugyanazt az azonosítót, mint korábban. Minden esetben, a vonatkozó tároló objektumnév is található, közel a kezdete a HTML oldala ... HTML.

Korlátozása a hozzáférést bizonyos oldalak / Views IIS

Ha az IIS, mint a webszerver a publikált modell, akkor lehet, hogy korlátozza a hozzáférést bizonyos oldalak / kilátás módszerét alkalmazva az alábbi:

1. Hozzon létre egy honlapot az IIS (egy másik, ha már van egy, akit nem akarnak beavatkozni).

2. Változtassuk meg a Tulajdonságok-> Directory Security-> Névtelen hozzáférés - törölje a Névtelen hozzáférés és azok használatának hitelesített hozzáférést.

3. Ha ez csak egy normális szerver nincs domain szövődmények stb, akkor kell használni az "integrált Windows-hitelesítés" lehetőség, amely majd a szerver gép helyi felhasználók / bejelentkezések, mint a hitelesítés, és add hozzá a felhasználók számára a helyi számítógépen (ügyelve hogy tisztában vannak a következményekkel, biztonsági bölcs, az új felhasználókat, hogy a gép, pl attól függően, hogy távoli hozzáférés beállítása a gép, stb).

4. Add engedélyeket a bizonyos fájlok / mappák szükség. Jobb klikk az egyes fájlokat / mappákat -> Tulajdonságok, és állítsa be a biztonsági engedélyeket a szokásos módon a fájlokat / mappákat.

Ez eltérhet attól függően, hogy milyen verziójú IIS és milyen konkrét Windows operációs rendszer van a szerveren, és hogy van egy tartomány vagy egyéb más összeállítást.

Lásd még

Benépesítő az architektúrának | Elemezve az architektúrának


Regisztráció ABACUS

Navigáció: Referencia>

Regisztráció ABACUS

Küldje el észrevételeit ebben a témában.

Amikor először kezdi ABACUS (vagy azt követően az ideiglenes működési engedély lejárt), akkor regisztrálnia kell a kérelem elleni Avolution engedély szerver segítségével egyedi engedéllyel által megadott kulcsot a helyi ABACUS rendszergazda vagy közvetlenül Avolution. Ha nem rendelkezik licenckulccsal forduljon a helyi ABACUS rendszergazda vagy Avolution Támogatás .

A regisztrációhoz egy engedély kulcs

1. A telepítés után, kezdeni ABACUSakár duplán kattintva a parancsikont az asztalon vagy a Windows Start menüben.

2. A Regisztrációs megjelenő párbeszédablakban adja meg a 26 karakter engedély kulcsáltal biztosított helyi ABACUS rendszergazda vagy Avolution támogatás , Vagy kattintson Böngésszen ...és válassza ki az aláírt .dlsc fájlt vissza Avolution Támogatás mint egy a megjegyzés a 4. lépés alább. Ha egy helyesen írt alá .dlsc fájl ABACUS kell kezdeni, mint egy 5. lépés alább.

Tipp

Akkor be az engedély kulcsot a dialógus átmásolással a Windows vágólapra, majd kiválasztja a háttérben a párbeszéd és a Ctrl + V

Regisztráció dialógus

3. Kattintson okéés ha az engedély kulcs egy Érvényes ABACUS licenc kulcsABACUS most megpróbál kapcsolatba lépni Avolution engedély szerver hitelesítéséhez a licenc kulcsot.

hangjegy

Ha kap egy Telepítés kód érvénytelenregisztrációs hiba akkor legvalószínűbb, hogy nem írta a kódot helytelenül. Próbálja másolás és beillesztés a kódot, mint egy a Tip fent említett.

Kapcsolatfelvétel az Avolution licenckiszolgálójára

4. Kattintson okéés egy rövid ideig ABACUS kell regisztrálni sikeresen.

Sikeres regisztráció

hangjegy

Ha kapsz egy Nem lehet kapcsolatba lépni licenckiszolgálórólregisztrációs hiba akkor a legvalószínűbb, hogy a tűzfal (vagy egyéb biztonsági intézkedések) az Ön hálózatán való hozzáférést megakadályozó Avolution engedély szerver. Kattintson okéMentse a .dlsc fájlt a helyi gépen, majd bármelyik feladni az .dlsc fájlt Avolution Támogatás és várják a további utasításokatvagy megpróbál bejelentkezni a licenc fájlt készítünk a következő URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Nem lehet kapcsolatba lépni a licenckiszolgálóhoz

Nyissa meg a licenc aláírása weboldal

Kézi Licenc aláírása weboldal

Esetleg, ha kap a Ez a telepítési kódot használták több rendszerek, mint által megengedett engedélyregisztrációs hiba valószínű, hogy a helyi gépen már átépítették, mióta utoljára regisztrált ABACUS vagy próbál regisztrálni egy másik felhasználó licence kulcsot. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás .

Telepítési kódot már használták

5. Kattintson okéés ha sikeresen regisztrálni ABACUS kell nyitni a Üdvözlő képernyő .

Lásd még

Avolution Támogatás | Mit jelent ABACUS csinálni?


Normál elemkijelölési

Navigáció: elemezve az architektúrának>

Normál elemkijelölési

Küldje el észrevételeit ebben a témában.

Amikor létrehoz egy rajzot, 3D Kilátás, jelentés,standard regisztrálóvagy lefuttat egy szimulációtAz állandó elemek kiválasztása ablakban lehet kiválasztani elemeket az elemezni kívánt / kilátás.

Normál Elem kiválasztása ablak

Lehúzás

· Szűrés megtekintése akarat tartalmazza az elems egy korábban elmentett nézet (azaz rajz, diagram, 3D). Ily módon akkor végre komplex "csatlakozni" lekérdezések kezelésére egy másik nézet, mint egy mentett "query".

Jelölőnégyzetei

· Szintek megjelenítésecsoportosítva eleme szerint a szintet, amelyben előfordulnak a fában. Az 1. szint a legfelső szinten.

· Mutass típusaiakarat csoport az elemek típusainak megfelelően, hogy azok.

· A szülők a kiválasztotttartalmazni fogja a szülő eleme minden egyes elemeken. Ily módon lehet biztosítani, hogy csak a hierarchia fölött minden gyereknek lesz benne egy "bottom-up" kiválasztása.

· Gyermekek válogatotttartalmazni fogja a gyermekek fontosságúak minden egyes elemeken. Ily módon lehet biztosítani, hogy csak a hierarchia alábbi semmilyen szülők szerepelni fog egy "felülről lefelé" gombot.

· Név mérkőzések ÉrtékEz csak azokat az elemeket, amelyek neve tartalmazza a megadott string (Megjegyzés: Ezek a helyettesítő (azaz? és *) is használhatók). Ily módon alkothat "szemantikai" lekérdezés.

· Van Ingatlan típusa / Név / ÉrtékEz csak azokat az elemeket, amelyek Ingatlan típusa, neve és értéke, amelyek a megadott karakterláncot akár közvetlenül az elem vagy a szabványok (Figyelem: a helyettesítő karakterek (azaz? és *) is használhatók. Pl? * az Érték mező hogy minden elem, hogy van egy nem üres érték az adott ingatlan). Ily módon alkothat "szemantikai" lekérdezés.

· Van szabványEz csak azokat az elemeket, amelyek egy szabvány nevet tartalmazó megadott string (Megjegyzés: Ezek a helyettesítő (azaz? és *) is használhatók. Pl HP * ad minden olyan elem, legalább egy szabvány betűkkel kezdődő H és P). Ily módon alkothat "szemantikai" lekérdezés.

· Alkatrészek / összeköttetéssel kiválasztottnem tartalmaz olyan elemeket csatolt azon, hogy nem került. Ily módon a "call-fa" vagy "hatás-elemzés" lehet választani.

hangjegy

Ha mind Szintek megjelenítése és Mutass típusaiKiválasztott akkor választhat, hogy a fa show-szint az első vagy a típus először a gombot, hogy megjelenik a fenti két dobozt.

Tipp

Ha egy tétel ki van jelölve a standard elem kiválasztása ablakban nem lesz köthető további szűrőcserék, amíg nincs kijelölve. Mivel nincs natív módon keres két különböző elemeket egyszerre (pl összetevők Standard A VAGY B szabvány), kereshet az első egy csoportját, válassza ki a kívánt komponenseket, majd végezze el a második keresés a második szett .

Gombok

· Mindenkiválasztja az összes elemet.

· InvertMegszünteti az összes aktuálisan kiválasztott elemet, és kiválasztja azokat, amelyek nem voltak kiválasztva.

· Egyik semkikapcsolja az összes elemet.

· Add Filterkiválasztja a kapott tartalmát az aktuális szűrési beállítások és lehetővé válik a kiegészítő tartalom olyan hatékonyan, az ÉS vagy csatlakozzon szűrőt.

Lásd még

Elemezve az architektúrának


A rajz eszköz

Navigáció: Népszerű az architektúrának használata> Rajzok>

A rajz eszköz

Küldje el észrevételeit ebben a témában.

A rajz eszköz létrehozását teszi lehetővé a legkülönbözőbb építészeti rajzok és diagramok. Építészek hagyományosan a számos különböző rajzok rögzítésére és közvetíteni a tervezés egy olyan építészet. Kétdimenziós (2D) rajzok állnak a szokásos módon dokumentálásának és a kommunikáció különböző részein a rendszer. Tipikus rajzok típusú használt vállalati rendszerek:

· Üzleti folyamat modellek és diagramok;

· A szervezeti felépítést;

· Együttműködési diagramokat;

· Egyed-kapcsolat (ER) diagramok;

· Adatok-diagramok (DFD-k);

· Osztály diagramok;

· IDEF (amely magában foglalja több, a fentiekben); és

· UML (amely magában foglalja több, fent említett).

Tényleg nincs határa a fajta diagramok hogy létre lehet hozni. ABACUS megpróbálja ellensúlyozni rajz rugalmasságot, miközben integritásának megőrzése az architektúra és a formák ábrázolása.

A rajz környezet füles és rögzíthető ablakot belül a fő ABACUS alkalmazás. Ez az ablak tartalmazza a vásznon, ahol a rajz kerül sor, és amikor a rajz ablak nyitva van, a második dokkolható ablak A stencil ablakban megtekinthető egy sor rajz sablonok. A stencil ablaktábla 4 fül: alkatrész, csatlakozások, alakzatok és csatlakozók. A vászon jelenik meg egy fehér háttér finom rács vonalak (hasznos elrendezés).

Komponensek által képviselt számos formák, míg a csatlakozások vannak rajzolva irányított vonalak. Kapcsolatok tulajdonítanak alkatrészek felhasználásával szerepek (azaz forrás vagy nyelő) bár ezek nem láthatók esztétikai okokból.

Tipp

Míg diagramokNagyon hasznos a használata különböző részein a rendszer, ők csak a saját skálázhatóság, ezért ABACUS használ 3D elképzelni komplex rendszer struktúrák.

Érdemes lehet

1. Nyissa meg a Ábrakészítő Eszköz

2. Hozzon létre egy új rajzot egy részének az architektúrának

3. Másolása rajz belüli vagy több architektúrák

4. Add alkatrészek egy rajz

5. Új alkatrészek és csatlakozások Ön architektúra (vázlatosan) a rajzeszköz

6. Törlés alkatrészek Egy rajz

7. Erősítse & manipulálni kapcsolatok

8. Megváltoztatni a megjelenítési tulajdonságok Az alkatrészek és csatlakozások.

9. Segítségével linkek diagram

10. Érvényesíteni típusú egyesületek és nézőpontok annak érdekében, hogy korlátozzák a fajta diagramok lehet levonni.

Lásd még

Benépesítő az architektúrának | Benépesítő az architektúrának kézzel | Elemző Ön építészet


Címlap

GOLYÓS SZÁMOLÓGÉP

Jogi nyilatkozat

Avolution Pty Ltd nem vállal felelősséget vagy garanciát, hogy a kézikönyv, és a lehető legnagyobb mértékben a törvény által megengedett, kifejezetten korlátozza annak megsértésével kapcsolatos felelősségét a garanciát, amely lehet hallgatólagos, hogy a csere a kézikönyv egy másik. Továbbá Avolution Pty Ltd fenntartja a jogot a jelen kiadvány bármikor anélkül, kötelesek erről bármely személy a felülvizsgálatot.

szerzői jog

Minden jog fenntartva 2001-2015Avolution Pty Ltd. Minden jog fenntartva.

A védjegyek

Avolution Pty Ltd mindent megtett, hogy a kínálat védjegye információkat cégnevek, termékek és szolgáltatások szerepelnek a kézikönyvben. A védjegyek alább látható volt különböző forrásokból származnak.

Microsoft Windows, Access, Visio, Excel, SQL Server és az Internet Explorera Microsoft Corporation védjegye.

Általános megjegyzés:

Néhány termék nevek ebben a kézikönyvben csak azonosítás céljából és védjegyei lehetnek az adott vállalat.

December 2015Edition Avolution ABACUS verzió 4.5.

Kézi Felülvizsgálat 1.0

Kivált, nyomtatott és kötött Ausztráliában.


ABACUS Telepítési előfeltételek

Navigáció: Referencia>

ABACUS Telepítési előfeltételek

Küldje el észrevételeit ebben a témában.

Vonatkozó információkat Visio Import és Excel Import / Export

ABACUS megköveteli, hogy a Microsoft Office telepíteni annak érdekében, hogy végre Excel Import / Export és Import Visio műveleteket. Kérjük, ellenőrizze, hogy Microsoft Office 2003 vagy újabbvan telepítve. Ha azt tapasztalja, további problémák, kapcsolati Avolution Támogatás .

Annak érdekében, hogy végre Visio Import és Excel Import / Export műveletek ABACUS használja a Microsoft Office elsődleges együttműködési szerelvények (PIA). ABACUS jelenleg tartozékai a szerelvények elvégzéséhez szükséges Excel Import / Export és Import Visio.

Vonatkozó információkat az SQL Server Import

ABACUS megköveteli, hogy a Microsoft SQL Server 20052008, 2008 R2, 2012-ben vagy 2014telepítve van ahhoz, hogy egy új projektet az SQL Server. Kérjük, ellenőrizze, hogy A Microsoft SQL Server 20052008, 2008 R2, 2012-ben vagy 2014van telepítve. Ha azt tapasztalja, további problémák, kapcsolati Avolution Támogatás .

Hibák Nyitva 3D látványtervek

Ha a ABACUS 3D Viewer nem működik az Ön számára, lehet, hogy hiányzik a SlimDX DirectX Runtime (részeként telepített teljes ABACUS EXE telepíteni). Ez lehet letölteni itt . Ha van egy 64 bites Windows-verziót, akkor is kell telepíteni ez .

Hibák Szerkesztés GOLYÓS SZÁMOLÓGÉP Szokás Jelentések

Szerkesztése ABACUS "Egyéni jelentések igényel Report Builder 3.0 kell telepíteni. ABACUS és a Report Builder épülnek a Microsoft .NET Framework 4.0, és bár mindketten nincs szükség a Microsoft .NET Framework 3.5, Microsoft helytelenül konfigurált a Report Builder MSI hogy csak akkor folytathatja, ha a Microsoft .NET Framework 3.5 telepítve van.

Ennek megfelelően Avolution egy szerkesztett változatát Report Builder telepítése MSI-fájl, amely nem igényel a Microsoft .NET Framework 3.5, ez lehet letölteni itt .

Az eredeti Microsoft Report Builder MSI lehet letölteni itt . Ha még nem rendelkezik Microsoft .NET Framework 3.5, amely akkor lesz szükség, akkor töltse le itt . Megjegyzés: több telepített, az offline telepíteni a Microsoft .NET-keretrendszer 3.5-re itt megfelelőbb lehet.


Undo és Redo

Navigáció: Népszerű az architektúrának> feltöltése manuálisan> Extra beállítások>

Undo és Redo

Küldje el észrevételeit ebben a témában.

Mint sok korszerű alkalmazások, ABACUS támogatja a képesség, hogy mind visszavonására és újra elmúlt felhasználó változtatások nyílt projekt. Hogy visszavonja a legutóbbi csere, egyszerűen aktiválja a Visszavonás parancsot. Változásokat, amelyek megszüntették lehet visszaállítani aktiválásával a redo parancsot; újra alkalmazza a legutóbb visszavonni változást.

Figyelmeztetés

Visszavonva változások nem képesek újra alkalmazni, ha további változások történtek a projekt, mivel éppen visszavonni.

hangjegy

Míg a legtöbb változást támogatják Undo / Redo valós időben, néhány diagram stencil változások, mint például létre egy új típusú Alak / vonal egyesület vagy változó társulás színes attribútum, nem tudja visszavonni azonnal. Ezekben az esetekben a módosított rajz (csillaggal jelöltük) előtt le kell zárni ezeket a változtatásokat lehet visszavonni.

Undo és Redo parancs helyszínek

A visszavonás és mégis parancsokat lehet hozzáférni három különböző helyszínen:

· A Szerkesztés menü

· A Szokásos eszköztár

· billentyűparancsait CTRL + Z(visszavonás) és CTRL + Y(redo)

Tipp

Az Undo és Redo gombbal a szokásos eszköztáron nyújt legördülő listák megjelenítésére 10 legutóbbi változások vonható vissza, és felújították ill. Ők is jól jön, Undo / Redo több változtatást egyszerre.


Makrók segítségével

Navigáció: szimulálása az architektúrának>

Makrók segítségével

Küldje el észrevételeit ebben a témában.

Ha valamilyen feladat elvégzésére ismételten ABACUS, akkor automatizálja a feladatot makró használata. Ennek megfelelően az ABACUS makró egy rögzített műveletek sorozata, amelyet vissza lehet játszani bármikor.

Makrórögzítésnél

1. Válasszuk az Eszközök | Rekord Macrovagy nyomja meg az Alt + F10.

2. Kezdje műveletek végrehajtása, hogy a rögzíteni kívánt.

Figyelmeztetés

Ebben az időben, van néhány ismert problémákat makrórögzítést. Kérjük, hogy ezeket figyelembe, amikor a felvétel a makrók:

· Jelenleg makrók csak rögzíti a Microsoft Windows billentyűk, egér mozgását, és egérkattintással. Azonban, mivel a korlátozások a makrórögzítővel magát, van néhány karakternél, amelyek nem mindig rögzítik. Ezek tartalmazzák:

· [Tab]

· [Ctrl]

· [Alt]

· [Kilépés]

· [Indul]

· [F1] [F12]

· Ezért javasoljuk, hogy ellenőrizze, hogy a gyorsbillentyű által bejegyzett makrórögzítővel felvétel előtt egy nagy események sorozata, amely függhet gyorsbillentyű munkavégzés.

· Jelenleg korlátai miatt a makrórögzítővel, a helyi menük nem kezelik megfelelően a ABACUS amikor megnyitott egy cselekvési által rögzített makrórögzítővel. Amikor egy helyi menüt, akkor hajtsa végre a felsorolt ​​funkciók a helyi menü segítségével a helyi menüben, különben a helyi menü maradjon nyitva lejátszás közben, így előfordulhat, hogy nem szándékos intézkedések vagy ami okozhat hibákat ABACUS.

· Ne feledje, hogy a normális módszerek zárás a helyi menü (pl megnyomása [Esc] billentyűt, vagy a bal egérgombbal kattintva valahol a képernyőn) valójában nem zárja be a helyi menü lejátszás közben a makró.

Tipp

Az ablakokban, ahelyett egérkattintással, javasoljuk, hogy használja a Tab billentyűvel mozoghat a rendelkezésre álló ellenőrzések és a kurzor billentyűkkel válassza ki a legördülő menüpontok vagy rádiós gomb opciót, és a szóköz válassza / de bejelölnek dobozok.

A felvétel leállítása Makró

1. Sajtó Alt + F9vagy pedig válasszuk az Eszközök | Állj Macro.

2. A Mentés Makró másként párbeszédpanelen keresse meg a helyét, és válassza ki a ABACUS makró (.abacusmac fájl) fájl nevét, és kattintson a Mentés gombra.

hangjegy

Használata Eszközök| Állj Macrotartalmazni fogja ezt a műveletet a rögzített makró. Ezért azt javasoljuk, hogy a felhasználók lesz ismerik az Alt + funkció billentyű lehetőségek dolgozó makrók, hogy ne tartalmazza a nem kívánt makró műveletek a makrók magukat.

Tipp

Mivel a makrók jelenleg nem szerkeszthető ajánlott felvenni hosszadalmas feladat, mint egy sor különböző makrók az Alt + F10 / Alt + F9 "párok".

Lejátszani, rögzített makró

1. Válasszuk az Eszközök | Lejátszás Macrovagy nyomja meg az Alt + F8.

2. A Megnyitás Makró párbeszédpanelen keresse meg a helyét, és válassza ki a ABACUS makró (.abacusmac fájl) fájl nevét, és kattintson a Megnyitás.

Figyelmeztetés

Amikor megnyit egy ABACUS makró, ha duplán kattint egy makró fájlt a Tallózás párbeszédablak megnyitásához, a makrórögzítővel tarthat a bal egérgombbal a bal kattintott állapotban marad, amíg a felvett bal gombbal felülbírálja ezt állapotban.

hangjegy

A lejátszási sebesség a makró beállítható a General fülön alatt Eszközök| Beállításokmint a Normál (alapértelmezett), gyors vagy lassú. Mindkét Gyors és lassú lejátszás sebességet nem ajánlott, mivel azok visszajátszani a rögzített makrókat körülbelül 100-szor és 1/100-valós idejű, ill. Normál lejátszás sebessége is visszajátszani a makró mintegy 30% -kal gyorsabb, mint a rögzített sebesség, ezért ajánlott felvétel közben megszakad egy rövid idő után minden hosszas feldolgozási feladatokat annak érdekében, hogy a lejátszás a következő művelet nem kerül végrehajtásra, mielőtt a feldolgozási feladat van befejeződött.

Ahhoz, hogy hagyjuk abba a játékot a rögzített makrót

1. Sajtó Alt + F9.


Megtekintése 3D rajz

Navigáció: elemezve az architektúrának> 3D rajzok>

Megtekintése 3D rajz

Küldje el észrevételeit ebben a témában.

ABACUS lehetővé teszi, hogy a felépítés 3D nézet, ahol komponens és csatlakozási tulajdonságok társított színek, formák, és méretben.

Megtekintéséhez 3D-s nézete az architektúrának

1. Győződjön meg arról, hogy van nyissa ki az ABACUS fájltartalmazza a lakott építészet.

2. Bővíteni a Nézetekága a fa.

3. Bővíteni a 3Dága a fa.

4. Dupla kattintás A vizualizáció megnyitni kívánt.

- vagy -

1. Győződjön meg arról, hogy van nyissa ki az ABACUS fájltartalmazza a lakott építészet.

2. Válassza ki Helyezze| 3Dvagy kattints a gombra.

3. Nyisson létezővizualizáció (.abacus3d)

- vagy -

1. Győződjön meg arról, hogy van nyissa ki az ABACUS fájltartalmazza a lakott építészet.

2. Válassza ki Helyezze| 3Dvagy kattints a gombra.

3. Hozzon létre egy új vizualizációs:

· Válassza ki a Építészetmegtekinteni kívánt a legördülő menüből.

· Válassza ki a Alkatrészek és Kapcsolatokfelvenni kívánt az ábrán a szabvány elemkijelölési ablakban .

· Associate színben, formában és méretben Komponens típusok és Tulajdonságok.

· Associate színek és formák Csatlakozási típusok és Tulajdonságok.

Exportálni 3D nézetben

1. Győződjön meg arról, hogy van megnyit egy meglévő 3D nézet.

2. A 3D-s nézet a legördülő menük kiválasztásához Fájl | Export...és úgy döntött, a helyszín és fájltípust a vizualizáció fájl (.abacus3d, .vrml vagy .html).

3. Kattintson Mentés.

Lásd még

Elemezve az architektúrának | Navigáció 3D-ben | A diagramm eszköz


Megtekintése buborékdiagram

Navigáció: elemezve az architektúrának> Egyéni diagramok>

Megtekintése buborékdiagram

Küldje el észrevételeit ebben a témában.

A buborékdiagram segítségével összehasonlíthatjuk akár 5 méretei (azaz X, Y, buborék méretét / sugár, buborék színét és buborék keret színe) egy nézetben.

Megtekintéséhez buborékdiagram

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Válassza ki Helyezze| Diagram| a Egyedi Chartslap | Buborékdiagram.

3. A Architektúrákrész, jelölje meg a architektúrák (ha van ilyen) szeretné feltérképezni, majd kattintson Következő.

4. Válassza ki a Alkatrészek és Kapcsolatokkívánt a diagram (ha van ilyen) a szabvány elemkijelölési ablakban , Majd kattintson Következő.

5. Válassza ki a X-tengelyingatlan, akkor kattintson Következő.

hangjegy

Csak Integer, tízes dátum / idő, logikai és Lista tulajdonságok lehet használni az X-tengely. Továbbá Egész, tízes és dátum / idő tulajdonságai ábrázoljuk balról-jobbra a tengely mentén arányosítva a az ingatlan értéke azonban logikai és Lista tulajdonságai egyszerűen ábrázolni balról-jobbra a pontos sorrendben (vagy fordított sorrendben, ha a lehetőség, hogy fordított sorrendben van jelölve) határozza meg az ingatlan, függetlenül azok értékeit. Ilyen például. Alacsony | Közepes | Magas vagy 1, 2, 4, 8, 16.

6. Válassza ki a Y-tengelyingatlan, akkor kattintson Következő.

hangjegy

Csak Integer, tízes dátum / idő, logikai és Lista tulajdonságok lehet használni az Y-tengely. Továbbá Egész, tízes és dátum / idő tulajdonságai ábrázoljuk lentről felső tengely mentén arányosítva a az ingatlan értéke azonban logikai és Lista tulajdonságai egyszerűen ábrázolni lentről top pontosan abban a sorrendben (vagy fordított sorrendben, ha a lehetőség, hogy fordított sorrendben van jelölve) határozza meg az ingatlan, függetlenül azok értékeit. Ilyen például. Alacsony | Közepes | Magas vagy 1, 2, 4, 8, 16.

7. Válassza ki a buborékmérettől / sugáringatlan, akkor kattintson Következő.

hangjegy

Csak Egész, Tizedes, logikai és Lista tulajdonságok lehet használni a buborék mérete / sugara. Továbbá, egész és tizedes tulajdonságok eredményeznek buborékmérettől / sugár arányosítva a az ingatlan értéke azonban logikai és Lista tulajdonságok eredményeznek egyenlő fokozatos növelése a buborék mérete / sugár pontosan abban a sorrendben (vagy fordított sorrendben, ha a lehetőséget, hogy fordított sorrendben van jelölve) határozza meg az ingatlan, függetlenül azok értékeit. Ilyen például. Alacsony | Közepes | Magas vagy 1, 2, 4, 8, 16.

8. Válassza vagy a fix buborék színe vagy társult egy telken a buborék színét, Majd kattintson Következő.

hangjegy

Csak Egész, Tizedes, logikai és Lista tulajdonságok lehet használni a buborék színét. Továbbá, egész és tizedes tulajdonságok eredményeznek egy buborék színét a választott tartományban méretezhető szerint az ingatlan értéke azonban logikai és Lista tulajdonságok eredményeznek egyenlő fokozatos növelése a buborék színét a választott tartományban pontosan abban a sorrendben írjuk be az ingatlan, függetlenül azok értékeit. Ilyen például. Alacsony | Közepes | Magas vagy 1, 2, 4, 8, 16.

9. Válassza ki, nincs buborék keret színe vagy társult egy telken a buborék keret színe, Majd kattintson befejezés.

hangjegy

Csak Egész, Tizedes, logikai és Lista tulajdonságok lehet használni a buborék határ színe. Továbbá, egész és tizedes tulajdonságok eredményeznek egy buborék keret színe a kiválasztott tartományban méretezhető szerint az ingatlan értéke azonban logikai és Lista tulajdonságok eredményeznek egyenlő fokozatos növelése a buborék keret színe a kiválasztott tartományban a pontos sorrendben megadott Az ingatlan függetlenül azok értékeit. Ilyen például. Alacsony | Közepes | Magas vagy 1, 2, 4, 8, 16.

Buborékdiagram

Menteni egy buborékdiagram

hangjegy

Bubble grafikonok csak akkor lehet megmenteni, ha azok csak olyan alkatrészek és csatlakozások, amelyek mindegyike kell egy egységes architektúra az aktuális projekt.

1. Meg arról, hogy egy új vagy már meglévő buborékdiagram nyisd kiés elvégezte a szükséges módosításokat.

2. A grafikonon eszköztáron kattintson a bal szélső Mentés körgombot, hogy mentse a táblázatot, és bármilyen formázási módosításokat.

3. A Könyv címeA megjelenő párbeszédablakban adja meg a nevet a buborékdiagram, majd nyomja meg oké.

Exportálása buborékdiagram

1. Győződjön meg arról, hogy van megnyit egy meglévő buborékdiagram.

2. A grafikonon eszköztáron kattintson a 2. balról Mentés másként BMPgombot, és úgy döntött, a helyszín a chart.

3. Kattintson Mentés.

Lásd még

Elemezve az architektúrának


Profil képesség térben chart

Navigáció: elemezve az architektúrának> Egyéni diagramok>

Profil képesség térben chart

Küldje el észrevételeit ebben a témában.

Képesek Tér chart segítségével megtekintheti, hogy az Ön építészet teljesíti a szükséges rendszer képességeinek tulajdonságaival kapcsolatos feltárt rendszer követelmény elemzési folyamat.

Ha meg szeretné tekinteni a képesség térben chart

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet, És hogy van értékeltékAz architektúrának.

2. Válassza ki Helyezze| Diagram| Egyedi Charts| Képesség Tér. (A Képesség tér kör konfigpárbeszédablak jelenik meg.)

3. A Architektúrákrészben jelölje be a architektúrák kívánt diagramot, majd kattintson Következő.

4. A Tulajdonságokterületen, jelölje be az építészeti tulajdonságai ki szeretne benne a két tengely a diagram.

5. A Képességterület, az egyes ingatlanok szerepelnek az előző lépésben, válassza ki, hogy bármilyen minimális vagy maximális kapacitás korlátozások vannak érvényben, és az értékeket az ezen korlátok. Az alapértelmezett értékek azok a minimális és maximális értékek értékelték a architektúrák vagy célja az ingatlan ha be van állítva.

Exportálása képesség térben chart

1. Győződjön meg arról, hogy van egy meglévő képesség helyet chart nyisd ki.

2. A grafikonon eszköztáron kattintson a bal szélső Mentés másként BMPgombot, és úgy döntött, a helyszín a chart.

3. Kattintson Mentés.

Lásd még

Elemezve az architektúrának | Megtekintése válaszidő chart


Szabványos jelentések

Navigáció: Jelentés az adott architektúrán>

Szabványos jelentések

Küldje el észrevételeit ebben a témában.

GOLYÓS SZÁMOLÓGÉP' standard jelentések lehetővé teszi, hogy egy listát a komponensek és a kapcsolatok egy vagy több architektúrák. A jelentés tartalmazza az összes információt, hogy a komponensek és a kapcsolatok kiválasztott, beleértve az érintett összetevő vagy kapcsolat helyét a hierarchiában, típus, szabványok, leírás, tulajdonságok és az ahhoz csatolt.

hangjegy

A jelentés tartalmának vankonfigurálhatókeresztül a jelentés opciók párbeszédablak alábbiakban ismertetett, azonban, to tudjon meg többet arról, hogyan kell létrehozni Teljesen konfigurálható egyéni jelentéseksegítségével ABACUS Egyéni jelentések, Kérlek olvassa el a témában itt vagy kapcsolatba lép Avolution Támogatás .

Megtekintéséhez standard jelentés

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet(k).

2. Válassza ki Helyezze| Normál jelentésvagy kattintson a Szokásos jelentésének létrehozása eszköztár gombra. A Jelentés konfigurációablak jelenik meg.

Jelentés konfiguráció ablakban

3. Válassza ki a Architektúrák, Alkatrészek és Kapcsolatokkívánt a jelentésben a Jelentés Configuration ablak.Kérjük, nézze meg a standard elemkijelölési itt Téma segítségért.

4. Most kattintsunk a Beállításokgombot, és a Jelentés opciókablak.

Jelentés lehetőségek ablakban

5. Kiválaszthatja, hogy megjelenjen a Új oldal minden egyes elem, a Nyomtatás dátuma, Nyomtatás idő, Lapszámokés arról, hogy tartalmazza a címet a fejlécbenA jelentés bejelölésével / vegye le a jelölést megfelelő négyzeteket. Ön is szeretné szabni a cím és a szerző szerkesztésével Felajánlás címe és Szerző mezőbe. Azt is megadhatja, hogy milyen tartalom jelenik meg a jelentésben bejelölésével / vegye le a jelölést négyzeteket alatt Jelentés tartalmarészében az ablakot. Miután befejeztük kattintson oké.

6. Most kattintson befejezésA jelentés konfiguráció ablak.

Értelmezni a jelentés megtekinthető

Példa létrehozott jelentés rövid magyarázattal

Eligazodni a jelentés oldalakon, kattintson az ikonokra [image] az eszköztáron találhatók a bal felső sarokban.

hangjegy

tudsz mentés a jelentés a különböző formátumok kattintson a Export az ikon [image] található ban Az eszköztár. Választhat, hogy az export a következő formátumokban: Excel, PDF és Szó. Kérjük menteni a jelentést a kívánt helyre későbbi felhasználásra. Ha módosításokat hajt végre, hogy az architektúra egy későbbi időpontban, egy új jelentést kell majd létre, hogy tükrözze a változásokat.

Lásd még

Elemezve az architektúrának


Megtekintése válaszidő chart

Navigáció: elemezve az architektúrának> Egyéni diagramok>

Megtekintése válaszidő chart

Küldje el észrevételeit ebben a témában.

A válaszidő chart segítségével megtekintheti, hogy a kapcsolatok feldolgozása folyamatban van a kívánt ütemben (azaz saját határidő).

Ha meg szeretné tekinteni a válaszidő chart

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási tartalmazza a lakott építészet, És hogy van értékeltékAz architektúrának.

2. Válassza ki Helyezze| Diagram| Egyedi Charts| Válaszidő. (A Válasz idő Könyv konfigpárbeszédablak jelenik meg.)

3. Tól Architektúráklegördülő listából válassza ki az architektúra szeretné feltérképezni.

4. A Kapcsolatokterületen, jelölje be a csatlakozásokat ki szeretne szerepelnek a táblázatban.

5. A Scale típusaterületen válassza LineárisHa szeretné, hogy a függőleges tengely (reakcióidő), hogy megjelenik, mint egy lineáris progresszió - minden szegmensében osztják el egyenlő arányban a tengely. Válassza ki LogaritmikusHa azt szeretnénk, hogy megjelenik a logaritmikus progresszió - minden egyes szegmense a tengely az egyre hosszabb ideig a feljebb a tengely megy. (Az arány a növekedés határozza meg a Báziskiválaszt.)

Válaszidő chart függőleges tengely skála

Exportálása válaszidő chart

1. Győződjön meg arról, hogy van egy meglévő válaszidő chart nyisd ki.

2. A grafikonon eszköztáron kattintson a bal szélső Mentés másként BMPgombot, és úgy döntött, a helyszín a chart.

3. Kattintson Mentés.

Lásd még

Elemezve az architektúrának | Profil képesség térben chart


Megtekintése szórásdiagramon a kialakult architektúrák

Navigáció: elemezve az architektúrának> Egyéni diagramok>

Megtekintése szórásdiagramon a kialakult architektúrák

Küldje el észrevételeit ebben a témában.

Miután egy architektúra már kialakult, és a célok vannak, azokat azután láthatóvá és összehasonlítottuk az eredeti architektúra segítségével szórásgörbe mátrixok. Ez a rész bemutatja, hogyan lehet létrehozni és megérteni a jellemzőit szórásgörbe mátrix.

Ha meg szeretné tekinteni szórásgörbe Matrix a kialakult architektúrák

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Győződjön meg arról, hogy van fejlődött és A meghatározott célokaz architektúrának vázolt alatt Fejlődik az architektúrának

3. Válassza ki Helyezze| Diagram| a Egyedi Chartslap | Szórásgörbe Matrix.

4. Kattints a befejezés gomb.

5. A SzórásdiagramonA meghatározott alakulását architektúrák és célok jelennek meg.

hangjegy

A terület a bal oldali a szórásgörbe mátrix mutatja a beállításokat a szórásgörbe mátrix jelenik meg. Ez magában foglalja az architektúra, hogy már kialakult (ebben az esetben "ABC Kft ahogy van 2010"), Valamint a cél, amelyet a beállított, hogy az építészet. Akkor vegye figyelembe, hogy a célokat, amelyek egy pipa mellett jelzés képviselteti magát, mint az X és Y tengelyen a szórásgörbe mátrixot (pl KPI- Költség, KPI - Minőség és KPI - Idő). Lehet untick e célok bármely pontján idő, hogy távolítsa el őket a szórásgörbe mátrix.

A kék pontok, amelyek megjelennek a telek a mátrix képviselnek normalizált érték, ahogy azt a legjobb és a legrosszabb értéket (körvonalazott Célok kitűzése a kialakult építészeti ). Ezeket az értékeket képviseli egy Minőségi Tér.

Két meghatározott célok képest egymás ellen szórásgörbe mátrix és a folyamat addig ismétlődik, amíg az összes célokat már képest (pl Az első telek a mátrix a fenti ábra összehasonlítja az KPI - Költségcélja a KPI - Minőség cél. A második Költség ellen Idő és az utolsó telek Minőség ellen Idő. A vonatkozó cél címkék jelennek meg a felső és jobb, vagy minden egyes sora telkek.).

6. Válassza ki a Architektúrákrádió gombot, ha meg kívánja jeleníteni a mérőszámok az egyes architektúrák.

7. Válassza ki a Evolutionsrádió gombot, ha meg kívánja jeleníteni a normalizált változások az eredeti építészeti (pl Ahogy van 2010), Hogy a kialakult architektúra (ok) (például To-Be 2011 - Stratégia az A és To-Be 2011 - B stratégia).

Lásd még

Elemezve az architektúrának | Megtekintése válaszidő chart | Megtekintése egy csillag telken a kialakult architektúrák | Fejlődik az architektúrának


Profil szabványos chart

Navigáció: elemezve az architektúrának> Normál táblázat>

Profil szabványos chart

Küldje el észrevételeit ebben a témában.

ABACUS "szabvány grafikonok include sor, bár, oszlop, terület, szórás, pite, görbe, Pareto, lépés, felszíni, radar, kocka, fánk, piramis, kontúr és görbe alatti terület listákon. Miután kiválasztotta a típusú diagram azt szeretné, a többi a folyamat megtekintésére mindegyik grafikonok ugyanaz.

Ha meg szeretné tekinteni egy szabványos térképet az Ön építészet

1. Győződjön meg arról, hogy van nyissa ki az ABACUS fájltartalmazza a lakott építészet, És hogy van értékeltékAz architektúrának.

2. Válassza ki Helyezze| Diagramvagy kattints a gombra. A Táblázatokablak jelenik meg.

Táblázatok ablakban

3. Válassza ki a típusú diagram akar, és állítsa be a kör beállításokat, majd kattintson Következő.

Könyv opciók

o Halmozottmegmutatja az összefüggést az egyes elemek az egész. Használhatja a halmozott diagramok, ha azt tervezi, hogy több adat (azaz több tulajdonság), és ha azt szeretné, hogy hangsúlyozzák a teljes.

o Halmozott 100%lesz összehasonlítani a százalékos értéket az egyes hozzájárul összesen több kategóriában. Használhatja a 100% halmozott diagramok, ha azt tervezi, hogy több adat (azaz több tulajdonság), és azt szeretné, hogy hangsúlyozzák a hozzájárulás az egész, különösen, ha a végösszeg azonos az egyes elemekhez.

o 3D diagramegyszerűen megjelenítjük az adatpontok 3-D formátumban esztétika. Ha szeretné, hogy az adatok megjelenítésére sorozat mentén 3. / z-tengely dimenziót majd a Cluster Series alább leírt.

o Series by Propertymegjelenik egy adatsort az egyes ingatlanokra, amelyek végül kiválasztott. Ha ez nincs bejelölve, akkor a tulajdonságok lesz a kategóriák és az adatok sorozat lesz minden eleme, hogy ki van választva.

o Forgatás körforog a diagram 90 fokkal jobbra felcserélésével az x és y tengelyt. Ez a lehetőség csak akkor érhető el a vonalak, Step és Cube grafikonokés különösen hasznos a mérföldkő diagramok leírt második csúcsa alatti. Megjegyzés: oszlop és sávdiagramoknak már "forgatni" változatai egymást.

o Klaszter sorozatmegjeleníti több sorozat adatok mellett a 3. / z-tengely dimenzió. Ez a lehetőség csak akkor érhető el az oszlop, bár és Cube grafikonokés különösen hasznos készítésére Gantt stílus diagramok leírt első Tip alább.

Tipp

Tudod teremt egy Gantt-diagramvízszintes sávok mutatja idő / dátum tulajdonságokkal különböző elemek kiválasztásával bár diagram típusát, majd kiválasztja a Cluster Series lehetőség.Továbbá, ha létre, a bal szélső sáv a chart lehet "láthatatlan" színezik meg a fehér jobb gombbal kattintva egy sáv kiválasztása Szín a megjelenő menüben, és kiválasztja a bal felső szín a palettáról. Emellett a határ a bal szélső oszlop lehet "láthatatlan" jobb gombbal kattintva egy sáv, válassza a Properties ... és a sorozat lapján megjelenő párbeszédablakban megváltoztatása átnyúló hatása, hogy nincs-re, Szín tetejére -left színt a palettáról.

Tipp

Tudod teremt egy Mérföldkő chartkis formák mutatja idő / dátum tulajdonságokkal különböző elemek kiválasztásával Cube diagram típusát, majd kiválasztja a Forgatás kör és a Cluster sorozat opciók.Továbbá, ha létre, a kockákat lehet változtatni, hogy más formák jobb gombbal kattintva egy kockát egy adott adatsor és válassza a Tulajdonságok ... és a sorozat lapján megjelenő párbeszédablakban megváltoztatása Bár a Cilinder vagy Cone . Megjegyzés: A Résszélesség értéket is fel lehet használni, hogy "csökken" a szimbólumokat a kör csökkentése átfedés, annál nagyobb a szám, annál kevesebb átfedés lesz.

4. A Architektúrákszakaszban jelölje az architektúra / s szeretné feltérképezni az architektúra szintű tulajdonságait, majd kattintson Következő.

hangjegy

Kiválasztása architektúra szintű tulajdonságok egy teljesen opcionális lépés, és csak akkor kell használni, ha azt szeretnénk, hogy kifejezetten feltérképezni az architektúra szintű tulajdonságok önmagukban.Egy architektúra nem kell kiválasztani, hogy akkor tartalmaznia alkatrész vagy csatlakozási tulajdonságokat a következő lépésben.

5. Válassza ki a Alkatrészek és Kapcsolatokhogy szeretne a táblázatot a szabvány elemkijelölési ablakban , Majd kattintson Következő.

6. Válassza ki a Tulajdonságokszeretné a diagram és kattintson befejezés.

Könyv opciók

o Közé tartoznak a standard tulajdonságok akarat mutatják az öröklött tulajdonságok a szabványok választható.

o Összesített Ingatlan akarat számolja közti eltérés a sorozat értékei, és számba azokat az eredményeket, szemben az egyedi értékek magukat.Ez a lehetőség csak akkor érhető el, ha a Series by Property opció került kiválasztásra a 3. lépést.

Tipp

Az ingatlan áll ábrázolási függenek az elemek kiválasztásakor.

Hogy mentse a diagram

hangjegy

Táblázatok csak menteni, ha csak olyan alkatrészek és csatlakozások, amelyek mindegyike kell egy egységes architektúra az aktuális projekt.

1. Meg arról, hogy egy új vagy már meglévő chart nyisd kiés elvégezte a szükséges módosításokat.

2. A grafikonon eszköztáron kattintson a bal szélső Mentés körgombot, hogy mentse a táblázatot, és bármilyen formázási módosításokat.

3. A Könyv címeA megjelenő párbeszédablakban adja meg a nevét a diagram, majd nyomja meg oké.

Exportálása chart

1. Győződjön meg arról, hogy van egy meglévő diagram nyisd ki.

2. A grafikonon eszköztáron kattintson a 2. balról Mentés másként BMPgombot, és úgy döntött, a helyszín a chart.

3. Kattintson Mentés.

Lásd még

Elemezve az architektúrának | Megtekintése válaszidő chart | Profil képesség térben chart


Megtekintése egy csillag telken a kialakult architektúrák

Navigáció: elemezve az architektúrának> Egyéni diagramok>

Megtekintése egy csillag telken a kialakult architektúrák

Küldje el észrevételeit ebben a témában.

Egyszer egy architektúra már kialakult, és a célok meghatározása, hogy aztán láthatóvá és összehasonlítják az eredeti architektúra csillagos telkek. Ez a rész bemutatja, hogyan lehet létrehozni és manipulálni egy csillag telek.

Ha meg szeretné tekinteni egy csillag telken a kialakult architektúrák

1. Győződjön meg arról, hogy van egy ABACUS fájlmegnyitási .

2. Győződjön meg arról, hogy van fejlődött és A meghatározott célokaz architektúrának vázolt alatt Fejlődik az architektúrának

3. Válassza ki Helyezze| Diagram| a Egyedi Chartslap | Csillagok Telek.

4. Kattints a befejezés gomb.

5. A Csillagok TelekA kialakult architektúrák és a kitűzött célokat fog megjelenni. Megjegyzés: A tengelyek a csillag telek lehet helyezni kattintással és húzással a tengelyeket másik terület határain belül a csillag telek minőségi tér.

hangjegy

A terület a bal oldali a csillagos telek mutatja a beállításokat a csillag telek jelenik meg. Ez magában foglalja az architektúra, hogy már kialakult (ebben az esetben "ABC Kft ahogy van 2010"), Valamint a cél, amelyet a beállított, hogy az építészet. Akkor vegye figyelembe, hogy a célokat, amelyek egy pipa mellett jelzés képviseli a tengely a csillag területen (pl KPI- Költség, KPI - Minőség és KPI - Idő). Lehet untick e célok bármely pontján idő, hogy távolítsa el őket a csillag telek.

A piros és a zöld "pontok", amelyek megjelennek a csillagos telken képviselnek normalizált érték, ahogy azt a legjobb és a legrosszabb értéket (körvonalazott Célok kitűzése a kialakult építészeti ) A kiválasztott legfelső szintű építészeti és minden fejleményei azt. Ezeket az értékeket képviseli egy Minőségi Tér.

Ahogy az a fenti képen, akkor jól látható, hogy az eredeti architektúra (Ahogy van 2010) Gyenge Költség, Míg az első fejlődött opció (To-Be 2011 - Stratégia A) Költözött a minőségi tér javítására Költség, Minőség és időcélokat. Alternatív módon, a második kialakult opció (To-Be 2011 - Stratégia B) Noha Javította a Költség a nagysága a javulás kisebb, mint a Stratégia A de mind a minőség és az idő céljait is nagyobb mértékben javult, mint a stratégia A.Ebben az esetben egy építész május válaszd ki A stratégia felett B stratégiaazok ajánlásaés tovább fejlődni, hogy lehetőség (To-Be 2012 - Stratégia A).

6. Szüntessük meg a Mutass Evolutionsjelölőnégyzetet, hogy elrejtse a sor (s) képviselő evolúció (ek) az eredeti (pl Ahogy van 2010) És a kialakult (például To-Be 2011 - StratégiaA) architektúra (S).

7. Válassza ki a Mutass Sticksjelölőnégyzetet, hogy megjelenjen a relatív nagysága az egyes minőségi attribútum (a cél, amelyet meghatározott az egyes tengelyek) az egyes építészet.

8. Válassza ki a Mutass Építészet nevekjelölőnégyzetet, ha azt szeretné, hogy a nevét az eredeti és a kialakult építészeti (ok) megjelennek a csillag telek.

Lásd még

Elemezve az architektúrának | Megtekintése válaszidő chart | Profil szórásgörbe mátrix a kialakult architektúrák | Fejlődik az architektúrának


Elemezve az architektúrának

Navigáció: elemezve az architektúrának>

Elemezve az architektúrának

Küldje el észrevételeit ebben a témában.

Miután lakott (és adott esetben a szimulált) az architektúrának, akkor készen áll a használatra ABACUS elemezni. Elemezve, akkor lehet meghatározni, ha a szerkezet megfelel az Ön igényeinek.

Segítségével elemzi a építészet számos különböző módon:

· Diagram

· 3D Kilátás

· szabvány grafikonok (pite, vonal, oszlop, stb)

· Egyedi térképek ( válaszidő , képesség térben , csillagos telek , szórásgörbe mátrix és buborékdiagram )

· Építészet Diff

hangjegy

Amikor létrehoz egy rajzot, 3D Kilátás, Jelentés vagy standard regisztráló, a szabvány elemkijelölési ablakban kiválasztására használható elemeket szeretné megtekinteni.

Lásd még

Benépesítő az architektúrának | Szimuláló az építészet | A Ábrakészítő Eszköz


Mi az építészet?

Navigáció: Bevezetés a ABACUS>

Mi az építészet?

Küldje el észrevételeit ebben a témában.

Az építészet absztrakt koncepció- Nem fizikai dolog. Ez egy gazdag és átfogó leírása, vagy megértése a szerkezet egy rendszer - készítse el a komponenseket és hogyan kapcsolódik (kölcsönhatásba). Mivel a fogalom építészet olyan mindent magába foglaló, alapvető fontosságú, hogy a költségek, az elérhetőség, evolvability, a nyitottság, és a rendszer teljesítményét. A hang építészet előfeltétele, hogy a hangrendszer.

Ebben ABACUS, akkor modellezni az architektúrának. Az egyszerűség kedvéért nevezzük ezt építészeti modell egy olyan építészet.

Az alábbi ábra egy tipikus építészeti 5 alkatrészek (hierarchiájában) összekötött 2 kapcsolatokat. A címkék jelzik a nevét adni a különböző részein a építészet ABACUS.

Egy egyszerű építészet

ABACUS úgy véli, mindezek a dolgok, hogy része legyen az architektúra:

· Alkatrészekképviseli a jogalanyok Az architektúra amit lehetett leírni, mint "a dolgok". Egy biztosító társaság, az összetevők lehetnek a rendszerek feldolgozásra politikák, követelések, a kifizetések, és a bevételeket.

· Kapcsolatokképviseli a kapcsolatok között ezeket. Például egy biztosító társaság, bevételeket generál az érvényes politikák, állítások ellen érvényes politikák, és a jogos követeléseket kifizetést eredményez. Amikor a gondolkodás építészetileg - különösen amikor ABACUS - kapcsolatok ugyanolyan fontosak, mint összetevők, és ők kezelik a szinte azonos módon.

· Minden, ami a fa lehet Tulajdonságok. Tulajdonságok olyan dolgok, mint ahogy megkövetelik a rendszer elvégzésére, a sorok száma a kódot azt az aránya, ezek a vonalak, amelyek kommentek, stb ABACUS úgy véli, mindezek a dolgok, hogy része legyen az építészet.

· Használva hierarchiák (azaz. alkomponenseket és al-csatlakozások), Elrejtheti az információs és de-komponáljon építészet. Az ABACUS építészeti modell rendkívül rugalmas. Bármely alkatrész bármilyen szinten kapcsolatba hozható be más más szinten semmilyen kapcsolatban bármilyen szinten.

· Attachmentaz a művelet, amellyel alkatrészek portok kötelesek kapcsolatotszerepek. Portok és Szerepek az interfészsa berendezések kapcsolatokat. Hozzá vannak szokva, hogy csatolja kapcsolatot alkatrészeket. Csatlakozók van egy forrás és egy mosdó szerep(megkönnyítve adatáramlás a forrás komponens a mosogató komponens)és fogalmilag, alkatrészek portokat. Az egyszerűség kedvéért azonban, ABACUS komponens port nem látható, és a kapcsolat szerepek közvetlenül kapcsolódik a komponensek maguk.

· Alkatrészek és csatlakozások egy bizonyos típus. Ez főleg a besorolás szempontjából. Például a politika, azt állítja, a kifizetések, és a számlák ennek elemei a típusú "System". Az érvényes politikák, a jogos követeléseket, stb kapcsolatok típusú "ügylet". A Type rendelt alkatrész vagy csatlakozás biztosítja a sablont az ingatlanok és a szabványok azt. Például egy szerver alkatrész volna "Tedd & Modell" standardés IP-címet tulajdon. Eltérően más merev eszközöket alap relációs adatbázis (RDB) back-end, a ABACUS akkor szabadon létrehozhatja saját új típusú és rendelje el azon a tulajdonságok és szabványok nekik.

· Normál könyvtárak tulajdonságok adhatók meg és rendelt mást az építészet. Ezek a könyvtárak ismert Szabványok. Használva Szabványok, Már csak be kell gyűjteni egyedi rendszerek tulajdonságait - a standard tulajdonságok már ott. Például a standard teljesítmény-jellemzőinek Microsoft Windows 2000 lehet rendelni bármit alkatrészeket használ Microsoft Windows 2000 operációs rendszert.

Lásd még

Hogyan épül fel egy építészeti képviselt ABACUS? | Mit jelent ABACUS csinálni? | Hogyan csinálod (áttekintés) | Létrehozva egy új típusa


Munka Enterprise Server

Navigáció: Adminisztráció>

Munka Enterprise Server

Küldje el észrevételeit ebben a témában.

ABACUS Enterprise Szerver egyszerre "nem zár" együttműködésen alapuló megközelítés, de a "le" egy is. ABACUS "nem zár", mert nem kényszeríteni a fájlt be kell zárni az egyik felhasználó érte frissíteni kell. Minden felhasználó saját helyi másolatot a fájl, és olyan változtatásokat, és megmentsék a fájlt, ezek a módosítások rögzítik és tárolják, ha a felhasználó nem akar elkövetni, hogy a kiszolgálóra.

Abacus "le" abban az értelemben, hogy nem kell a szerverhez kapcsolódó, vagy szükség van hálózati hozzáférés mellett dolgozik egy fájlt. ABACUS csak azt írja elő a hozzáférést a szerverhez, amikor műveletek végrehajtása, mint ami egy fájlt, vagy végez pénztár, valamint a műveletek egy meglévő fájlt - frissítés, elkövetni, vagy megtekinti a naplót a múlt követ el. Hozzáférés a szerver nem kell dolgozni a fájlt, és a módosítások nem küldeni a szerver azonnal (ebben segítségével könnyedén megtartani a módosításokat, ha hibázik). Ha menti a fájlt, akkor "csak" mentés másolat helyben - nem, amíg meg elkövetni, hogy a helyi változások (óta végrehajtott módosítások az utolsó commit), elküldik a szerver.

Létrehozva egy új Enterprise fájl

Ahhoz, hogy hozzon létre egy új vállalati fájlt, válassza ki Fájl| Új ...majd válassza ki az egyik első két lehetőség mellett a vállalati modell részben a Új projekt párbeszédpanel (azaz vagy egy üres Enterprise fájlt, vagy hozzon létre egy egy meglévő ABACUS fájl). A harmadik lehetőség az, hogy "Pénztár" Enterprise fájlt valaki már létrehozott, ez fedezi a következő részben.

Ha úgy dönt, hogy hozzon létre egy új Enterprise fájlt, akkor meg kell adni egy párbeszédablak, amely lehetővé teszi, hogy keresse meg, ahol a tárolóhoz szeretné tárolni a fájl. Ez is lesz a meglévő fájl elérési útját és nevét lépett fel a felső ha úgy döntött, "Meglévő Model" a New Project párbeszédablak és szállított egy fájlt.

URL: Ez az URL-t a tárolóhoz, ahol a ABACUS Enterprise tárolja. Meg kell kérni a személy, aki irányítja a szerver, hogy ez mit URL legyen.

A fenti képen látható egy adattár négy (4) meglévő ABACUS Enterprise projektek, miután belépett a URL-t és nyomjunk Entert. Te számára, miután létrehoz egy új Enterprise fájl, a következő képen a "Pénztár", lesz egy másik mappa és fájl e tárolóból.

hangjegy

Ha ön használ egy HTTPS (SSL) szerver, és a kiszolgáló nem rendelkezik érvényes SSL-tanúsítvánnyal (közös intranetes vagy nem nyilvános kiszolgálókon miatt a költsége SSL tanúsítványs) Lesz egy extra lépés. Meg kell majd véglegesen elfogadni minden kapcsolatot a kiszolgáló a dialógus felugró (ez is egy kicsit több információt a szerver). Ehhez típus "p" (idézőjelek nélkül), és nyomja meg az Entert. ABACUS felbukkan egy üzenetet, emlékeztetve, ennek megjelenése előtt az ablakot.

hangjegy

Akkor lehet kérni, hogy jelentkezzen be, hogy a szerver ebben az esetben az a személy, aki kezelése a szervernyújthat a szerver felhasználónevét és jelszavát. Emellett a bejelentkezési adatait, bármilyen szerverek, hogy már csatlakoztatva vannak mentve, így ha bármilyen oknál fogva tisztázni kell ezt lehet tenni keresztül Eszközök | Beállításokmajd az Tábornok lapon létrehozott Visszaállítása Subversion Mentett Bejelentkezésés kiválasztja a szervert a legördülő listából, és kattintson a Tiszta Belépésés kiválasztja az OK gombra a megjelenő párbeszédablakban.

hangjegy

Ellentétben a screenshot a fentiekből kiderül, jellemzően egyetlen ABACUS projekt szerepel minden ABACUS Adattár, mert ha több, mint 1 ABACUS projekt létrehozása, egyetlen ABACUS Adattár, az ABACUS változtatási napló szám megosztják az összes ABACUS projektek és ez megzavarhatja a felhasználókat.

Előnyben Fájlnév: Ez egyaránt érinti a mappát, és fájlnév, amelyeket használni fognak (ha még nem történt), ha megteremti a fájlt a tárolóhoz. Ne feledje, hogy egy új mappát hoz létre automatikusan a tároló szerver minden fájl (a teljesítmény miatt, ABACUS Enterprise fájlok jönnek létre saját mappát a helyét böngészhető a párbeszédablakban).

Tárolja munkapéldány a könyvtár: Ha egy vállalat fájlt hoz létre a tárolóhoz, a helyi üzemi fájlokat kell létrehozni a számítógépen, így a munka a fájlt anélkül, hogy csatlakozik a hálózathoz. Ez az a hely, hogy akkor keresse meg, ha meg szeretné nyitni / újra megnyitja az ABACUS Enterprise fájlt.

Checkout már meglévő vállalat Fájl

Ha valaki már létrehozott egy új Enterprise fájlt, akkor "pénztár" ezt a fájlt, amely letölti a helyi gépen beállítja a szükséges fájlokat, így ABACUS elismeri, hogy ez egy Enterprise fájlt. A párbeszédablak hasonló új vállalati fájlt Dialog. Írja be az URL-t (alkönyvtárakat is szerepel az URL), válassza ki a kívánt fájlt, majd kattintson az OK gombra. Figyelemmel az alábbi megjegyzést tő fájl ezt követően megnyitotta.

hangjegy

Akkor lehet kérni, hogy jelentkezzen be, hogy a szerver ebben az esetben az a személy, aki kezelése a szervernyújthat a szerver felhasználónevét és jelszavát. Emellett a bejelentkezési adatait, bármilyen szerverek, hogy már csatlakoztatva vannak mentve, így ha bármilyen oknál fogva tisztázni kell ezt lehet tenni keresztül Eszközök | Beállításokmajd az Tábornok lapon létrehozott Visszaállítása Subversion Mentett Bejelentkezésés kiválasztja a szervert a legördülő listából, és kattintson a Tiszta Belépésés kiválasztja az OK gombra a megjelenő párbeszédablakban.

Enterprise Fájl különbségek

Ha létrehozta Enterprise fájlt (akár egy újat, vagy azon keresztül "pénztár" egy fájl mások által létrehozott), egy mappát hoz létre a fájlt, és ez általában tartalmaznak ezek a 3 fő típusú fájlokat:

· ".abacus" Fájl- Ez a ABACUS fájlt magát. Változtatásokat, hogy a helyben nem Azonnal menteni a fájlba, az csak írott amikor elkövetni. Ez a fájl egy "normális" ABACUS fájlt, akkor lehet adni, nem EE felhasználókmint egy önálló projekt (anélkül, hogy a .log), Illetve használják a kiindulópontja egy új EE fájlt.

· ".changes" Fájl- A helyi (nem kötött) változás történt a fájl. Ha ez a fájl hiányzik, ez azt jelenti, nincsenek helyi változások.

· '.log fájl- Ez a fájl csak a változások történtek az elmúlt felhasználó (a tartalmát a felhasználó .changes fájlt, amikor az általuk elkövetett).

hangjegy

Vannak egyéb fájlok jöhetnek létre a frissítés során, és kötelezzék folyamatok, nevezetesen; ‘.changesbefore"Fájl- Ez a fájl egy példányát a .changes fájl egy frissítés után végeztek, és segítségével automatikusan összeegyeztetni esetleges ID közötti konfliktusok a frissítést, és minden helyi (nem kötött) változások előtt követ el; ‘.biztonsági mentés"Fájl- Ez a fájl egy példányát a .changes fájlt, mielőtt a felhasználó elment inkább helyi (nem kötött) változások a .changes fájlt; és ‘.hiba"Fájl- Ez a fájl egy példányát a .changes fájl, van-e probléma, amely miatt ABACUS hogy nem nyílnak a .abacus fájlt, és a felhasználó úgy döntött, hogy visszatér a változások.Ezek a fájlok figyelmen kívül lehet hagyni.

Fájl megnyitása

Egy fájl megnyitásához, csak akkor kell böngészni, ahol úgy döntöttek, hogy tárolja a munkapéldány, és nyissa meg a ABACUS fájlt tárolják ott. Amikor ABACUS látja, hogy van egy .log fájl (és talán egy .változások fájlt, ha olyan változtatásokat), akkor kezelje a fájlt, mint egy vállalkozás fájlt.

Egy fájl frissítése

Végrehajtásan 'Frissítés' lesz e újabb verziója egy fájl található a szerveren. Ha van, akkor csukd be a jelenlegi fájl, frissítse az újabb fájlt a szerverről, és töltse le néhány ideiglenes fájlokat, melyek számos kiterjesztéseként - pl "Demo.125". Ezek a fájlok a régebbi változatai a .log, és arra használják, hogy meghatározzák, milyen változások történtek egy fájlt, mióta utoljára frissítve azt. Erre azért van szükség, hogy feltárják a konfliktusok, amelyek előfordulhattak, így azok megoldására.

Ha a frissítési folyamat során minden konfliktusok megtalált, Akkor kell megoldani őket, mielőtt meg tudja nyitni újra a fájl (akkor törölheti de kérni fogja megoldani a konfliktusokat újraA következő alkalommal, amikor megnyitja a fájlt).

Fájl mentése

Amikor elment egy fájlt, ez hozzáfűzi bármely Ön által végzett módosításokat a .changes fájlt. Azt nemmódosítsa a .abacus fájl ebben a szakaszban - csak akkor, ha a fájl elkötelezett amellett, hogy a szerver lesz felülírni (vagy ha kap egy frissítést a szerver).

Hol van a 'Mentés másként'?

Nincs koncepció a Mentés másként Vállalkozásfejlesztési fájlokat. Akkor azonban másolja a munkapéldány .abacus fájlt, szem előtt tartva, hogy ez szokás a helyi változásokat is.

Konfliktusok megoldására

Ha más felhasználók elkötelezett módosítást a file hasonló része a fájlt Önnek, előfordulhat, hogy néhány közötti összeütközéseket változások és a tiéd. Például, egy másik felhasználó töröl egy összetevő, hogy volt frissíti ingatlan. Meg kell, hogy vagy vonja vissza a változás (ha biztos benne, hogy az övék kellnem történt), vagy elveti a változás (lehet, majd térjen vissza a fájlt, és újra a változás).

Különösen van 4 osztályok a konfliktusok, amelyek előfordulhatnak;

1. Töröl - Amikor egy felhasználó töröl egy objektumot, hogy egy másik felhasználó változásokat. Ilyen például. Felhasználó A törölt egy komponens, de B felhasználó megváltoztatta az összetevő nevét vagy a hozzá csatlakoztatott vagy hozzáadott, a gyermekekkel, hogy ez stb

2. Tulajdonság - Amikor két felhasználó is módosíthatja a pontosan ugyanolyan "attribútum" egy tárgy. Ilyen például. Mindkét felhasználó az A és B felhasználó megváltozott alkatrész nevét vagy annak leírását, illetve az értékét annak egyik ingatlan stb

3. Referencia - Amikor két felhasználó megváltoztathatja a pontosan ugyanolyan "referencia" egy objektum egy másik objektumot. Ilyen például. Mindkét felhasználó az A és B felhasználó megváltoztatta a részegység típusának vagy a forrás / mosogató szerelt alkatrész kapcsolat, vagy a csatolt szempontból egy rajz stb

4. Gyűjtemény - Amikor két felhasználó megváltoztathatja a "gyűjtés" egy objektum. Ilyen például. Mindkét felhasználó az A és B felhasználó költözött ki az alkatrészt a másik szülőre, vagy újra elrendelte gyűjteménye gyermekek alkatrészeket.

hangjegy

Különböző lényegtelen konfliktusokat automatikusan megoldani ABACUS hogy minimálisra csökkentsék a rezsi felhasználók.Például minden ezzel ellentétes pán-zoombeállításnál diagramok úgy döntöttek, hogy tartsa a legújabb pán-zoom beállítás.

Elkövetése Változások

Ha úgy dönt, a saját módosításokat, a ABACUS fájl a szerver nyílik, a helyi változások végzik ellene, és akkor a helyi .abacus fájl felülírja az egyik, hogy a változások azt. A változtatások a fájlt, majd felülírja a .log, és mind a .abacus fájlt, és a .log küldeni a szerverre.Ha a véglegesítés sikeres tartozó üzenetben párbeszédablak az alábbi módon biztosítja, hogy adjon meg egy üzenetet a elkövetni.

Megtekintése Bejelentkezés Változások

Hogy megjelenítheti a naplót a változások egy Vállalkozás programVálassza Fájl| Napló megtekintése...

Maximális Napló bejegyzések: Ez alapértelmezésként az utolsó 10 bejegyzés, de további bejegyzések lehet letölteni változó értékét és kattintással Visszahoz gomb.

Felülvizsgálat: The Felülvizsgálat oszlopban az változatszámúak elkötelezett az Enterprise szerver alapértelmezés szerint fordított időrendi sorrendben.

hangjegy

A felülvizsgálati számok nem folyamatos, mivel csak a ABACUS kötelezettséget vállal fog szerepelni míg ugyanez a Subversion tároló is használják más ABACUS projektek és / vagy egyéb verziókövető alkalmazások.

Dátum: The dátum oszlop felsorolja a dátumot, hogy a felülvizsgálat elkötelezett volt az Enterprise Server.

Idő: ThE Idő oszlop felsorolja a pontos idő (24 órás formátumban), hogy a felülvizsgálat elkötelezett volt az Enterprise Server.

Szerző: The Szerző oszlop felsorolja a Microsoft Windows bejelentkezési nevét a felhasználó számára, hogy végre a véglegesítés után következik ABACUS felhasználónevet Vagy "Anonymous", ha a felhasználó nincs hitelesítve, és anonim felhasználókat arra hozzáférhetnek a vállalati projekt idején a elkövetni.

Napló üzenet: The Napló üzenet oszlopban az a elkövetni üzenetet, hogy megkapta a felülvizsgálat, mint egy a dialógus fent látható.

Változat letöltés XX mint önálló ABACUS fájl: Ha kiválaszt egy adott változatról a táblázatban, majd kattintson a Letöltés gombra akkor képes lesz arra, hogy bontsa a választott ABACUS projekt felülvizsgálatát a szerverről, és mentse el egy helyi / önálló ABACUS projekt.

hangjegy

Visszatérhet az előző felülvizsgálat olvassa ezt a Avolution közösség cikk .

(Admin) letöltése XML Log file felülvizsgálatára XX: A felhasználók az ABACUS Administrator képesség kiválaszthatja egy adott felülvizsgálatát a táblázatban, majd kattintson a Letöltés gombra kivonat a választott ABACUS projekt elkövetni log fájlt a szerver, és mentse el egy .xml fájlt.

Profil Audit Trail of Changes

Hogy megtekintheti az ellenőrzési nyomvonal a változások minden adott elemet (azaz alkatrész, csatlakozás, kilátás, gyermek, stb) egy Vállalkozás program, kattintson jobb gombbal az elem és válasszon Audit Trail...Állítsa a kezdeti és felülvizsgálata tartomány és kattintással Keresés.

hangjegy

Ha egy elem törlődik a projekt akkor már nem tud hozzáférni adott naplózási információkat adott elem. Akkor azonban még mindig elérheti a "szülő" komponens (például), és látni naplózási információkat a törlés (ebben az esetben felsorolja az azonosító az elem a törölt).Továbbá, komponens / Connection melléklet egy "tulajdon" a kapcsolat, így a változó egy csatolt komponens révén Explorer ablak, illetve a diagramok megmutatja az eseménynaplóban a kapcsolatra nem az azt alkotó, törlése kapcsolatot, és hozzon létre egy új kapcsolatot (például történik, ha a jobb gombbal "Unattach", majd a "Csatlakozás ..." katalógusokban) elvesztését eredményezi a naplózási információkat az eredetileg beszerelt - kapcsolat mellékletet összesen.

hangjegy

Alapértelmezésben az ellenőrzési nyomvonalat fog rekurzív-e változás, hogy minden gyerek a kiválasztott elem. Ez azt eredményezheti, hosszú reakcióidőt és ennek megfelelően az ellenőrzési nyomvonalat lehet korlátozni az elem maga által kikapcsolná az Rekurzív lehetőség szerint Audit opciók"fogaskerék" gombot az eszköztáron az eseménynaplóban párbeszédablak.

Honnan Felülvizsgálat: Ez alapértelmezésként az első / legrégebbi felülvizsgálata áll a projekt Enterprise szerver.

Felülvizsgálat: Ez alapértelmezésként az utolsó / legutóbbi felülvizsgálata áll a projekt Enterprise szerver.

hangjegy

Miután beállította a kezdeti és felülvizsgálata tartomány kattintson a Keresés gombra letölteni semmilyen konkrét változtatásokat a választott elem.

Felülvizsgálat: The Felülvizsgálat oszlopban az változatszámúak elkötelezett az Enterprise szerver alapértelmezés szerint előre időrendi sorrendben.

hangjegy

A felülvizsgálat számok nem valószínű, hogy a folyamatos, mivel csak a revíziók releváns a választott elem lesz látható, és csak a ABACUS követ el fog szerepelni míg ugyanez a Subversion tároló is használják más ABACUS projektek és / vagy verzió vezérlő alkalmazások.

Dátum: The dátum oszlop felsorolja a dátumot, hogy a felhasználói beavatkozásra került sor.

hangjegy

A feltüntetett időpont a felhasználói beavatkozás dátumát, nem a dátum a felülvizsgálat elkötelezett volt az Enterprise Server. Ennek megfelelően, a dátum megelőzheti a megfelelő felülvizsgálata véglegesítés jelzett időpontig a Fájl | Napló megtekintése... parancs.

Idő: ThE Idő oszlop felsorolja a pontos idő (24 órás formátumban), hogy a felhasználói beavatkozásra került sor.

hangjegy

A jelzett idő a felhasználói beavatkozás időt, nem az idő a felülvizsgálat elkötelezett volt az Enterprise Server. Ennek megfelelően, az idő nagy valószínűséggel megelőzi a megfelelő felülvizsgálata elkövetni időben mutatja a Fájl | Napló megtekintése... parancs.

Szerző: The Szerző oszlop felsorolja a felhasználót, hogy végre a cselekvés által Microsoft Windows bejelentkezési nevet, majd a ABACUS felhasználónevet Vagy "Anonymous", ha a felhasználó nincs hitelesítve, és anonim felhasználókat arra hozzáférhetnek a vállalati projekt idején a felhasználói beavatkozásra.

hangjegy

A Szerző felsorolt ​​Audit Trail dialógus nem feltétlenül egyezik meg a Szerző szerepel a Napló megtekintése párbeszédablakban felett ugyanazon felülvizsgálatát. Ez azért van, mert a Napló megtekintése párbeszédablakban megjelenik a bejelentkezett felhasználó idején a elkövetnek, míg az Audit Trail párbeszédablakban megjelenik a bejelentkezett felhasználó idején a felhasználói beavatkozás, és az is lehetséges, hogy egy felhasználó módosíthassa, és küldjék el. Megváltoztatja a fájl egy másik felhasználónak, hogy kötelezzék el - mint a jelen esetben, ha egy külső felhasználó (mint például Avolution), hogy dolgozzon ki egy EE projekt.

Részletek: The Részletek oszlop felsorolja a pontos részleteket a felhasználó cselekvés elszámolni Enterprise szerver.

Tipp

Célszerű csoport által Felülvizsgálat oszlop (amint az a dialógus fent) és / vagy a Felhasználó Művelet oszlop hogy egyszerűen osztályozza a változások az elem a kamat.

Használata Scripting az Enterprise fájlok

Ha használja scripting Enterprise fájlokat, akkor tudnia kell, hogyan kell helyesen törölni egy objektumot a modellt. Általában, ha törlünk egy objektumot, akkor hívja a .Delete () metódus rajta, és nem csak eltávolítja a szülő.

Ilyen például. ha már KOMP1, mint a szülő a KOMP2 és törölni kívánt KOMP2 a script, akkor hívja comp2.Delete () helyett comp1.Components.Remove (KOMP2).

Ön használhatja eltávolítani, ha szeretné hozzáadni a KOMP2 objektumot egy másik helyre az építészet, de nem szabad használni, ha a szándék az, hogy törli az objektumot.

Van egy kivétel e, ha szeretné távolítani egy objektumot, hogy "él" máshol a modellt. Ha szeretne eltávolítani egy normál esetben egy építészeti / alkatrész / kapcsolat, akkor azt megteheti kiveszi a példány standard gyűjteménye - arch1.Implementációk.A (IMP) -, mert a törlés megszüntetné azt minden esetben.

Helyesen használja a Törlés szkriptek azért fontos, mert ha egy tárgy eltávolítjuk a objectmodel és nem újra hozzá, akkor nem lesz képes elhelyezni, de mivel ez nem volt kifejezetten "törölve", konfliktusérzékelő és a felbontás nem helyesen felismerni a konfliktus, ha egy másik felhasználó az volt, hogy megpróbálja használni azt a tárgyat azok bármilyen változást, és a végeredmény lesz sérült meg a változásokat az adott felhasználó számára.

Lásd még

Hogyan épül fel egy építészeti képviselt ABACUS?


Munka ABACUS fájlok

Navigáció: Bevezetés a ABACUS>

Munka ABACUS fájlok

Küldje el észrevételeit ebben a témában.

Egy abakusz fájl egy konténert egy modell a építészet . Egyetlen ABACUS fájlt, akkor modellezni tetszőleges számú architektúrák tetszőleges számú alkalommal.

Amikor először nyitja meg ABACUS, nincs olyan fájl nyitva. Hogy működik a szerkezet, akkor sem hozzon létre egy új fájlt, vagy nyisson meg egy meglévő fájlt.

Amikor megnyit vagy hozzon létre egy új fájlt, egy fa a felfedező ablakban automatikusan megjelenik. Ez explorer nézet megmutatja az építészet a mai napig. Amikor bezárja a fájlt, a fa az Explorer ablak is eltűnik.

Ahhoz, hogy hozzon létre egy új fájlt ABACUS

1. Válassza ki Fájl| Új ...

2. Az Új projekt megjelenő párbeszédablakban (lásd alább), Válaszd kihogy vagy hozzon létre egy üres modell, egy modellt egy szabvány ABACUS könyvtár , A modell egy egyedi ABACUS könyvtár, a modell XML, MS Access , MS Visio , MS Excel , MS SQL Server , Egy Vállalkozás Szerver modell vagy egy egyéni ABACUS könyvtár (.abacuslib fájl).

3. Kattints a okégombra, és kövesse a dialógusok, amely megjelenhet.

Tipp

Ön nem kérni, hogy nevezze el a fájlt, amíg ment vagy zárja be. Ez egy jó ötlet, hogy mentse a fájlt, amint létrehozza. Akkor nem kell aggódnia megnevezné később a folyamat, ha éppen koncentrál egyéb összetett dolgok (mint megtölteni az architektúrának).

Új projekt létrehozása

ABACUS standard könyvtárak

ABACUS támogatja a több mint 100 állami keretek és jelölések, amelyek közül néhány alább látható. Amikor eldöntöd, hogy hozzon létre egy új projektet egy szabványos könyvtárat használók egy gyors bevezetést modellezés belül létre keretet teljes mértékben kihasználva olyan meghatározott elem típusok, tulajdonságok, jelölések, nézőpontok és sablonok vagy minták. További szabványos könyvtárak szabadon elérhető az Avolution közösségi itt .

Új projekt Standard Library

Menteni egy új fájlt ABACUS

1. Válassza ki Fájl| Mentés másként

Tipp

Fájlneveket lehet bármilyen hosszúságú lehet, és tartalmazhat alfanumerikus karakter szóközökkel együtt. Ők nem tartalmazhatja a hullámvonal (~) karakter, a cső (|) karaktert, a kérdőjel (?), Vagy a karakterek általában használt útvonal leírását, például a fordított perjel (\) - kivéve részeként az út.

Megnyitni egy létező ABACUS fájl

1. Válassza ki Fájl| Nyisd ki

hangjegy

Ha megnyit egy fájlt egy megosztott hálózati helyről, már meg van nyitva egy másik felhasználó, ABACUS nyújt Önnek csak olvasáshoz. Amikor ABACUS a Csak olvasható hozzáférést, akkor nem lesz képes elvégezni írási műveletek, mint például megtölteni az architektúrának és fut értékelők. Akkor azonban, tekintse meg az építészet segítségével a felfedező és 3D nézetek.

Lásd még

Hogyan épül fel egy építészeti képviselt ABACUS?


Munka Dashboards

Navigáció: Adminisztráció>

Munka Dashboards

Küldje el észrevételeit ebben a témában.

ABACUS projektek tetszőleges konfigurációs nézetek (pl diagramok, Grafikonok stb) mentette meg a műszerfalon, és megmentette a vezérlőpultot beállítva alapértelmezett kezdő "képernyő" projektek megnyitásának és / vagy rendelve egy specifikus felhasználói csoport és bemutatott tagjai a felhasználói csoport, ha bejelentkeznek egy ABACUS projekt.

hangjegy

Konfigurálása műszerfalakat egy ABACUS projekt a felhasználói licenc szüksége a Rendszergazda képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

Profil Dashboards

Egy példa Portfolio Management (APM) műszerfal

Mentett Portál

1. Válassza ki Kilátás| Dashboards

2. Válassza ki a mentett irányítópult a rendelkezésre álló műszerfal.

hangjegy

Miután kiválasztott ABACUS épít a nézetek szükséges a műszerfal és ez eltarthat néhány másodpercig. Kérjük várjon.

Ügyvezető Dashboards

Ügyvezető Dashboards

Ahhoz, hogy hozzon létre egy új Dashboard

1. Nyissa meg a szükséges nézetek és intézkedik és dock ablakok szükség a műszerfalon.

2. Válassza ki Kilátás| Dashboards| Kezelése Dashboards ...

hangjegy

Ha nem látja a Manage Dashboards menüpont akkor nincs Administrator képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

3. A megjelenő párbeszédablakban válassza ki a Teremtgombot, és adja meg a Dashboard nevét az Új Dashboard párbeszéd.

4. Kattints a oké gomb.

Ha törölni egy meglévő Portál

1. Válassza ki Kilátás| Dashboards| Kezelése Dashboards ...

2. A megjelenő párbeszédablakban válassza ki a Dashboard törölni kívánt a listából, és válassza ki a Töröl gomb.

hangjegy

Törlése műszerfal is törlődnek a felhasználó csoportos feladatok az, hogy a műszerfal.

3. Kattints a oké gomb.

Hogy egy meglévő Portál

1. Nyissa meg a szükséges nézetek és intézkedik és dock ablakok szükség a csere műszerfalon.

2. Válassza ki Kilátás| Dashboards| Kezelése Dashboards ...

3. A megjelenő párbeszédablakban válassza ki a Dashboard le kívánja cserélni a listából, és válassza ki a Cserélje gomb.

4. Kattints a okégomb megnyomásával nyugtázza a Dashboard Helyébe párbeszéd.

Rendelni Portálaz alapértelmezett Start képernyő

1. Válassza ki Kilátás| Dashboards| Kezelése Dashboards ...

2. A megjelenő párbeszédablakban válassza ki a Dashboard a listából szeretne rendelni az alapértelmezett Start "képernyő"és válassza ki a Rendeljen ... gomb.

3. A megjelenő párbeszédablakban válassza ki a bejegyzés a felhasználói csoportok oszlop.

hangjegy

Csak egy műszerfal lehet rendelni, mint a kezdeni "képernyő", így újra hozzárendelés eltávolítja a megbízásából az előző műszerfal.Továbbá, ha a felhasználó bejelentkezik tagjaként egy felhasználói csoportot, hogy egy hozzárendelt műszerfalon, majd a hozzárendelt műszerfal nyílik helyett az alapértelmezett projekt műszerfal.

4. Kattints a oké gomb.

A Felhasználó csoport egy Dashboard

1. Válassza ki Kilátás| Dashboards| Kezelése Dashboards ...

2. A megjelenő párbeszédablakban válassza ki a Dashboard a listából szeretne rendelni a felhasználói csoportot, és válassza ki a Rendeljen ... gomb.

3. A megjelenő párbeszédablakban válassza ki a User Group (vagy csoportok)akarsz rendelni a műszerfal, mint a "start up" képernyő.

hangjegy

Ha ugyanazt a felhasználói csoport rendelni több műszerfalak ezután az első feladat a listán fogják használni.

4. Kattints a oké gomb.

Hozzárendelés megszüntetése felhasználói csoport egy Dashboard

1. Válassza ki Kilátás| Dashboards| Kezelése Dashboards ...

2. A megjelenő párbeszédablakban bővíteni a Dashboard elemet a listából szeretne hozzárendelés megszüntetése felhasználói csoportot.

3. Válassza ki a felhasználó szeretné hozzárendelés megszüntetése, és válassza ki a Unassign gomb.

4. Kattints a oké gomb.

A jogosultságok beállítása

Engedélyeket be tudja állítani a műszerfal, hogy lehetővé váljon a műszerfal megtekinthető legyen, Frissíthető és / vagy deleteablehogy adott felhasználói csoportok.

Engedélyek kezelése

Állítsa be az engedélyt a Dashboard

1. Válassza ki Kilátás| Dashboards| Kezelése Dashboards ...

2. A megjelenő párbeszédablakban válassza ki a Dashboard a listából a beállítani kívánt engedélyeket, és válassza ki a Engedélyek ... gomb.

3. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

4. Alapértelmezésben látni fogja, hogy az Olvasás, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

5. Kattints a oké gomb.

Lásd még

Testreszabása ABACUS interfész | Munka Engedélyek


Munka Engedélyek

Navigáció: Adminisztráció>

Munka Engedélyek

Küldje el észrevételeit ebben a témában.

ABACUS projektek lehet szerep alapúengedélyeket készlet minden eleme a tárolóból. Pontosabban, finomszemcsés Create-Read-Update-Délete (Szifilisz) Engedélyeket be tudja állítani a "tárgy" (azaz alkatrész vagy kapcsolat), megtekintheti és attribútum (vagyis tulajdon) szintet.

Áttekintés

A munka során ABACUS Enterprise Szerver Abacus nyújt finomszemcsés, szerep-alapú szifilisz jogosultságokkal szabályozza a hozzáférést több felhasználó az adattárban.

hangjegy

Konfigurálása engedélyeket egy ABACUS projekt a felhasználói licenc szüksége a Rendszergazda képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

Engedélyeket be tudja állítani a architektúrák, alkatrész és csatlakozó típusok, tulajdonságok (via azok típusát), sablonok, nézőpontok és ábrák, katalógusok, mátrixok, diagramok és 3Dnézetek. Amikor jogosultságok megadásához az alkatrész vagy összeköthető minden esetben az adott típus minden architektúrák, hogy a projekt "örökli" azokat a jogosultságokat. Hasonlóképpen, ha engedélyt nem állítják egy tulajdonság az alkatrész vagy kapcsolat típusát, az adott tulajdonság az alkatrész vagy kapcsolat esetben bármely architektúrák, hogy a projekt "örökli" azokat a jogosultságokat. Ennek megfelelően bizonyos engedélyekre kell alkalmazni, hogy a nézetek, amelyek ezen elemek léteznek. Ha a jogosultságok vannak beállítva a rajz, a látvány és / vagy a tartalmát a néző maga is különböző engedélyeket alkalmazni rá.

hangjegy

Alapértelmezésben nincs jogosultságok megadásához az elemek belül ABACUS projekt. Azaz minden elem Createable, olvasható, frissíthető és Deleteable minden felhasználó. Ily módon engedélyeket csak akkor minősül egy adott elem az adattár, ha egy bizonyos engedélyt az, hogy korlátozottegy bizonyos felhasználói csoport. Ha például jogosultságokat egy adott felhasználói csoport adunk egy tárgyat (például egy alkatrész), de maradt minden engedélyt engedélyezve van, akkor ez funkcionálisan ugyanaz, mintha a felhasználó csoport nem volt adunk az objektumot.

Engedélyek nem tudbeállítható bizonyos esetekben egy olyan építészet elemeit. Például, nem tudja, hogy egy alkalmazás-összetevő frissíthető újabb nem. Ahhoz, hogy hatékonyan elérni ezeket "domain-specifikus" engedélyeket azonban a rendszergazda beállíthatja az egyedi elem típusok az adott területeken, például komponens típusok "Application - CRM tartomány" és a "Kérelem - HR területen", majd a jogosultságokat az egyes kell. Tudod, hogy konkrét csoportosítás típusok egyes erdőkben, majd távolítsa frissítés engedélyt a terület-specifikus csoport típusát és ez korlátozza alkotásait belüli és törléseiről hogy csoportosítása, de nem frissíti a gyerekek. Természetesen, ha a domain-specifikus csoportosulás volt rejtve eltávolításával olvasási engedélyt, akkor a gyerekek rejtett és ezáltal nem frissíthető. Vagy ha nézetek (ahelyett Explorer) használnak elsősorban kezelni / megtekintheti adattár, egy adott nézetben az egyes erdőkben lehetett megállapítani, majd az adminisztrátor beállítod a jogosultságokat az egyes nézetekben kell.

Felhasználók és csoportok kezelése

Engedélyek határozza meg a szerep vagy csoportszinten, szemben az egyéni felhasználói szinten, hogy míg tagságát a csoportok változhat, a jogosultságokat maradhat rögzítve. Természetesen, ha azt szeretnénk, egy adott felhasználó engedélye, akkor egyszerűen csak teszi őket egy csoportba, pontosabban hozzon létre egy csoportot, hogy a felhasználó, hogy egyetlen tagja.

Meg kell jegyezni, hogy a csoportok atom, Ami akkor nem örökölhetik jogosítványait vagy a felhasználók egyik a másikra, és ha a felhasználó tartozik, több csoport, akkor a legtöbb "pesszimista" csoport engedélyével elsőbbséget élveznek egy eseti elbírálás alapján, minden egyes engedélyt (azaz létrehozása OLVASD-update-Delete). Például, ha ugyanaz a felhasználó tagja a csoport és B csoport és csoport nemrég Create-olvasás jogosultság Application komponens típusok, míg a B csoport nemrég olvasható frissítése engedélye Application komponens típusok, akkor a felhasználó csak olvasási engedélyt Alkalmazás alkatrész példányok.

Továbbá alapértelmezetten, anonim felhasználó(azaz a felhasználók, akik nem kapták meg, vagy akik nem vagy bejelentkezve) van teljes hozzáférésta projekthez. Ez annak biztosítására, hogy rendelkezésre áll egy kezdeti konfiguráció. Hogy blokkolja a hozzáférést a névtelen egyszerűen törölje a "Névtelen felhasználó teljes hozzáféréssel rendelkeztek az 'opciót a Felhasználók kezelése / csoport ablakban alább látható. Ha nincs bejelölve anonim felhasználók csak akkor lesz képes látni a szabványok részét olyan projektet.

Végül, ha a "A Windows Felhasználónév Login" opció be van jelölve felhasználónév hitelesítés a szemben a Windows Felhasználónév Bejelentkezések minden felhasználó gépén ellen felhasználónevét által bevitt mint egy alább. Azaz, ha a Windows felhasználóneve Login egy adott felhasználó gépére létezik egy érvényes felhasználónevet, akkor nincs szükség jelszóra, és a felhasználó automatikusan hitelesíti. Megjegyzés: Ez ténylegesen lehetővé teszi használat a Windows Active Directory (AD) hitelesítést.

hangjegy

Tekintettel arra, hogy engedélyeket csak meghatározott mikor kell elvenni (korlátozott) a felhasználó, minden felhasználót, hogy nem egy olyan csoport tagja, vagy bármely csoport, amelynek nincs meghatározott engedélyek ellen semmilyen tárgyat, majd teljes hozzáférésük van A projekt.

A felhasználók és a felhasználói csoportok

Ahhoz, hogy hozzon létre egy új felhasználói

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

hangjegy

Ha nem látja a Felhasználók kezelése / Csoportok menüpontot, akkor nincs meg a rendszergazdai képesség. Kérjük, lépjen kapcsolatba a helyi ABACUS rendszergazda vagy Avolution Támogatás Ha szüksége van erre lehetősége.

2. A megjelenő párbeszédablakban válassza ki a Felhasználó hozzáadásagombot, és írja be a felhasználói nevet és a jelszót a Create New User párbeszéd. Megjegyzés: A felhasználói nevek és jelszavak kis- és nagybetűket.

hangjegy

Ha a "A Windows Felhasználónév Login" opció be van jelölve a fent leírt módon, majd egy dummy jelszót lehet megadni hitelesítés megfelelően kell végezni a felhasználó Window Felhasználó Bejelentkezés csak.

2. Alapértelmezésben látni fogja, hogy a A felhasználók a saját jelszavát. Ha szükséges, a ABACUS ügyvezető igazgató eltávolíthatja a képessége a felhasználók számára, hogy saját maguk határozzák meg a jelszót által akadálytalanA négyzeteket.

hangjegy

Ha a felhasználók módosíthatják saját jelszót akkor van egy Fájl | Változtass jelszót...menüpont erre.Továbbá, ne feledje, hogy ha több ember használja ugyanazt a felhasználónevet, akkor az egyik felhasználó megváltoztathatja a jelszavát úgy, hogy más emberek jelentkezned utána. Ennek megfelelően, akkor ajánlott gyakorlatban van egy Egyetlen felhasználónév per valós személy.

4. Adott esetben adja meg az email címét, Elhelyezkedés és Telefon A felhasználók a jövőben is.

5. Kattints a okégombra a Create New User párbeszéd.

6. Kattints a oké gomb.

hangjegy

Miután létrehozta az első felhasználó akkor érdemes hozzáférés blokkolását névtelen törölje a jelet a "Névtelen felhasználó teljes hozzáféréssel rendelkeztek az 'opciót a Felhasználók kezelése / Csoportok párbeszédablak.Továbbá, ha egy felhasználó hoztak létre (és ha egy vállalkozás a projekt, a változás a szerverre), a következő alkalommal a projekt megnyílik a felhasználók fogják kérni Jelentkezz be, hogy hitelesített hozzáféréstmint egy a dialógus alább látható. Ha a Automatikus bejelentkezés ezekkel részletekopció be van jelölve, akkor a felhasználói név / jelszó párost fognak emlékezni a projekt és alkalmazott minden egyes alkalommal a nyitáskor. Törölje az elmentett bejelentkezési válasszuk Fájl | Mentett Bejelentkezésmegnyitása után, és kérni fogja, hogy jelentkezzen be újra a következő alkalommal megnyitja a projektet.

Bejelentkezés

Ha törölni létező Felhasználó

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

2. A megjelenő párbeszédablakban válassza ki a felhasználó nevét a felhasználók panel törölni kívánt, majd válassza ki a Felhasználó törlése gomb.

3. Kattints a oké gomb.

Ahhoz, hogy hozzon létre egy új csoport

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

2. A megjelenő párbeszédablakban válassza ki a Csoport hozzáadásagombra, és adja meg a csoport nevét a Csoportok panel.

hangjegy

Csoport nevének egyedinek kell lennie.

3. Kattints a oké gomb.

Hogy másolni egy már meglévő Csoport

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

2. A megjelenő párbeszédablakban válassza ki a Másolat Csoport gomb.

hangjegy

A kettőzött csoportok jönnek létre előtaggal "másolata".Alapértelmezésben összes engedélyt a másolt csoport fogják másolni a "másolat" csoport, beleértve bármely felhasználó megbízást.

3. Nevezze át a "másolat" csoport megfelelő használata Csoport szerkesztésevagy lassú dupla kattintással.

Ha törölni egy meglévő csoport

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

2. A megjelenő párbeszédablakban válassza ki a csoport nevét a Csoportok panel törölni kívánt, majd válassza ki a Csoport törlése gomb.

hangjegy

Bármilyen Felhasználó feladatokat a csoport is el kell távolítani.

3. Kattints a oké gomb.

A Felhasználó a csoport

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

2. A megjelenő párbeszédablakban válassza ki a felhasználó nevét a felhasználók panel, melyet szeretne rendelni a csoport és drag-and-droprá a csoport nevét a Csoportok panel kívánt rendelje hozzá.

3. Kattints a oké gomb.

hangjegy

A csoport (ok), hogy a felhasználó tagja jelennek bővítésével Felhasználó nevét a felhasználók panelés a felhasználók, amelyek egy csoporthoz jelennek bővül a csoport nevét a Csoportok panel. Például, a fenti képernyőkép, a "AS1-AUS" felhasználó van hozzárendelve három (3) csoport, nevezetesen; "App Support Team 1", "tényleges" és "Ausztrália".

Hozzárendelés megszüntetése Felhasználó a csoportból

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

2. A megjelenő párbeszédablakban bontsa ki a csoport nevét, amely a felhasználói feladat, hogy szeretne hozzárendelés megszüntetése, és válassza ki a felhasználónevet.

3. Kattints a Unassign Felhasználó gomb.

4. Kattints a oké gomb.

Importálni felhasználók és / vagy csoportok (és bármely megfelelő engedélyekkel)

1. Válassza ki Fájl| Felhasználók kezelése / Csoportok

2. Kattints a Import gomb.

3. A megjelenő párbeszédablakban Böngésszenés nyissa meg a ABACUS tartalmazó projektet felhasználók és / vagy csoportok (és engedélyek) szeretne importálni a jelenlegi projektet, és kattintson Nyisd ki. A felhasználók és csoportok importálása, egy Import eredmények ablak jelenik meg, amely összefoglalja az import a felhasználók és / vagy csoportok. Kattints a oké gomb.

hangjegy

Ha az importált felhasználók vagy csoportok már létezett a jelenlegi projekt akkor lesznek vonva a meglévő felhasználók vagy csoportok.

4. Kattints a okégombbal vissza a fő felhasználók / csoportok párbeszédpanel.

5. Ha van-e megfelelő típusok, kilátók, sablonok, vagy architektúrák között a jelenlegi projekt és az ABACUS projekt maga importáló, komplett engedélyeket még nem létezik a jelenlegi projekt az engedélyek a behozott és egy második Import eredmények ablak Megjelenik összefoglalja az import. Kattints a oké gomb.

hangjegy

Engedélyek csak fokozta, hogy a meglévő típusok (és azok tulajdonságai), kilátók, sablonok, vagy architektúrák a csoportok, ahol az engedélyeket még nem léteztek a Csoport számára. Vagy azért, mert a csoport új, vagy a csoport már létezett az aktuális projektben, de semmilyen jogosultsággal nem osztották volna ki az adott csoport arra a tételre. Nincs "összevonása" az engedélyeket illő tárgyakat, ahol engedélyeket már létezett a Csoport az aktuális projektben.

A jogosultságok beállítása

Engedélyeket be tudja állítani a architektúrák, alkatrész és csatlakozó típusok, tulajdonságok (via azok típusát), sablonok, nézőpontok és ábrák, katalógusok, mátrixok, diagramok egyd 3Dnézetek. Amikor jogosultságok megadásához az alkatrész vagy összeköthető minden esetben az adott típus minden architektúrák, hogy a projekt "örökli" azokat a jogosultságokat. Hasonlóképpen, ha engedélyt nem állítják egy tulajdonság az alkatrész vagy kapcsolat típusát, az adott tulajdonság az alkatrész vagy kapcsolat esetben bármely architektúrák, hogy a projekt "örökli" azokat a jogosultságokat. Ennek megfelelően bizonyos engedélyekre kell alkalmazni, hogy a nézetek, amelyek ezen elemek léteznek. Ha a jogosultságok vannak beállítva a rajz, a látvány és / vagy a tartalmát a néző maga is különböző engedélyeket alkalmazni rá.

Engedélyek kezelése

Állítsa be az engedélyt egy komponens (vagy kapcsolat) Típus

1. Bővíteni a Típusokága a fa.

2. Bővíteni a Komponens (vagy kapcsolat) típusaiága a fa.

3. Kibontása Csoportok ahol szükséges.

4. Jobb klikka Komponens (vagy kapcsolat) Típuskívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

5. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

6. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

hangjegy

Hozzon létre engedélye szabályozza azt is, ha lehet másolni egy elemet. Ennek megfelelően, hogy lehet másolni egy elemet igényel létrehozása engedélyt minden gyermek (mivel másolni az elem azt jelenti, másolásával, alatta). Eltávolítása frissítése engedélye eleme eltávolítja a képesség, hogy módosítsa a típus is, akkor is, ha a felhasználó rendelkezik a tervező add-on, és ez eltávolítja frissítése jogosult az összes tulajdonságait. A szülő elem kell frissítése engedélyt, hogy képes legyen Készítsen gyermeke elemek vagy Törölje a létező gyermekek elemeket. Törlés engedélyt egy elem is szükség törlése engedélyt minden gyermek. Törlés engedélyt komponensek szintén frissítést igényel engedélyével a mellékelt kapcsolatokat.És végül, megszüntetve Törlés engedély egy elemet eltávolítja a képességét, hogy törölje a típus is, akkor is, ha a felhasználó rendelkezik a tervező add-on.

7. Kattints a oké gomb.

Állítsa be az engedélyt egy csoportja komponens (vagy kapcsolat) típusai

1. Bővíteni a Típusokága a fa.

2. Bővíteni a Komponens (vagy kapcsolat) típusaiága a fa.

3. Jobb klikka Csoportamely tartalmazza a komponens (vagy kapcsolatban), hogy milyen típusú szeretné állítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

6. Kattints a oké gomb.

7. A megjelenő párbeszédablakban kattintson a Igen gomb.

Állítsa be az engedélyt egy ingatlan

1. Bővíteni a Típusokága a fa.

2. Bővíteni a Komponens (vagy kapcsolat) típusaiága a fa.

3. Kibontása Csoportok ahol szükséges.

4. Válassza ki a Component (vagy kapcsolat) Típus amely tartalmazza az ingatlan szeretné a beállított engedélyeket.

5. A Tulajdonságok ablakban Jobb klikka Ingatlankívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

6. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

7. Alapértelmezésben látni fogja, hogy az Olvasás és frissítése engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

hangjegy

Tulajdonságok, amelyek már az Update engedélyével eltávolították láthatók dőlt betűka Properties ablakbanés ezek az értékek nem frissítette ezt a szerepet. Továbbá, a képesség, hogy módosíthatja az adatokat egy tulajdonság (például a név, egységek, stb) van szükség mind az Update engedélyt az ingatlan és A tervező add-on.

8. Kattints a oké gomb.

Állítsa be az engedélyt egy sablon

1. Bővíteni a Sablonokága a fa.

2. Böngésszen a Sablonhogy érdekli.

3. Jobb klikka Sablonkívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy az olvasás jogosultság elérhető. Távolítsuk el a jogosultsággal akadálytalanA jelölőnégyzetet.

6. Kattints a oké gomb.

Állítsa be az engedélyt a Nézőpont

1. Bővíteni a Nézőpontokága a fa.

2. Kibontása Csoportok ahol szükséges.

3. Jobb klikka Nézőpontkívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

6. Kattints a oké gomb.

Állítsa be az engedélyt egy építészeti

1. Bővíteni a Architektúrákága a fa.

2. Bővíteni a Építészethogy érdekli.

3. Jobb klikka Építészetkívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy az olvasás jogosultság elérhető. Távolítsuk el a jogosultsággal akadálytalanA jelölőnégyzetet.

6. Kattints a oké gomb.

Állítsa be az engedélyt egy Katalógus

1. Bővíteni a Katalógusokága az architektúra érdekli.

2. Kibontása Csoportok ahol szükséges.

3. Jobb klikka Katalóguskívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

6. Kattints a oké gomb.

Állítsa be az engedélyt egy Mátrix

1. Bővíteni a Mátrixokága az architektúra érdekli.

2. Kibontása Csoportok ahol szükséges.

3. Jobb klikka Mátrixkívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

6. Kattints a oké gomb.

Állítsa be az engedélyt egy diagram

1. Bővíteni a Diagramokága az architektúra érdekli.

2. Kibontása Csoportok ahol szükséges.

3. Jobb klikka Diagramkívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

hangjegy

Amíg lehet beállítani a szifilisz engedélyeket közvetlenül egy diagramot, meg kell jegyezni, hogy az engedélyeket az elemek az ábrán hatással lehet a jogosultságokat a nézet is. Például, ha van még csak egy eleme az a nézet, amely már a Read vagy Frissítés engedélyével eltávolították, majd a rajz lesz a frissítés engedélyével eltávolították. Ez azért van, mert; a) az elemeket az állásponton van, hogy voltak azok az olvasás jogosultság eltávolításra nem jelenik meg a néző elhagyja "white space", ahol egyébként helyezzen néhány új elemet, ha a véleményen volt, frissíthető, és b) az elemek a véleményen van, hogy voltak azok frissítése engedélyével eltávolították aztán más elemek esett rá őket, hogy gyermekei legyenek, ha a véleményen volt, frissíthető. Továbbá, létrehozása és frissítése engedélyt egy rajz megköveteli, hogy minden elemét a nézet, hogy az Olvasás engedélyt, és az alkatrészek a frissítés engedélye (ez azért van, mert mozogni egy komponenst a másik összetevő, akkor képesnek kell lennie arra, hogy frissítse, mivel ez lesz gyermeke lett).

6. Kattints a oké gomb.

Állítsa be az engedélyt egy 3D nézet

1. Bővíteni a 3D Viewsága az architektúra érdekli.

2. Kibontása Csoportok ahol szükséges.

3. Jobb klikka 3D nézetkívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

6. Kattints a oké gomb.

Állítsa be az engedélyt egy Diagram

1. Bővíteni a Táblázatokága az architektúra érdekli.

2. Kibontása Csoportok ahol szükséges.

3. Jobb klikka Diagramkívánja beállítani a jogosultságokat, és válassza Engedélyek szerkesztése.

4. A megjelenő párbeszédablakban kattintson a Add ...gombra, és válassza ki a Csoportszeretne hozzáadni akár duplán kattintva, vagy kijelöli, és rákattint a oké gomb.

5. Alapértelmezésben látni fogja, hogy a Create, Read, Update és Delete engedélyeket minden elérhető. Távolítsuk el a jogosítványokat akadálytalana vonatkozó négyzeteket.

6. Kattints a oké gomb.

Lásd még

Hogyan épül fel egy építészeti képviselt ABACUS?


Írás Scripts

Navigáció: szimulálása az architektúrának>

Írás Scripts

Küldje el észrevételeit ebben a témában.

A Script Editor egy egyszerű és funkcionális segédprogram írásban és a végrehajtó VB vagy C # script ellen aktuálisan megnyitott fájl ABACUS(A könyvtárak nem támogatottak scripting). Ez a szokásos Fájl megnyitása, bezárása és mentése parancsot, hogy el lehessen menteni, és letölteni a szkriptek írsz. Ez is egy alapvető futás és hibakereső eszköz. A Script Manager lehetővé teszi, hogy könnyen végre a különböző szkriptek, hogy megírtuk azáltal, hogy a menü-tétel közvetlenül az Eszközök menüben.

Hogy elérje a Script Editor

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Válassza ki Eszközök | Script Editorés a Script Editor ablak. Akkor sem,

3. Nyisson meg egy létező script segítségével Fájl | Nyisd ki A Script Editor menük,

vagy

3. Nyiss egy példa script segítségével az Példa elemet a Script Editor menük,

vagy

3. Állítsa be az alapértelmezett nyelvet sem VB vagy C # keresztül Nyelv elemet a Script Editor menük,

vagy

3. Nyílt scripting Súgójuk keresztül Segítség elemet a Script Editor menük

Írásakor scriptek, akkor be kell tartania vagy a VB vagy C # szintaxismint egy a beállítás alatt Nyelv elemet a Script Editor menük.

MEGJEGYZÉS:

· Hogy szabványos VB funkciók, mint a MsgBox ()meg kell adni a Import Microsoft.VisualBasicnyilatkozatot elején a forgatókönyvet. Ez nem volt szükség, mielőtt Version 3.0 ABACUS.

· Ez a segítség nem tartalmaz információt, hogyan kell írni VB script, és nem tartalmaz a VB hivatkozást. Nyugodtan írja meg scripteket kedvenc IDE vagy szerkesztő, majd másolja őket a Script Editor.

Amikor először kezdi el a Script Editor, a Script Editor üres lesz. Elérheti a csontvázat script a példák menüt. Az első alkalommal indítja el a Script Editor, akkor nem kell aggódnod a sablon csontváz látni, hogy működik. Ezen kívül van két példa szkriptet amely keresztül érhető el a példákban menüben.

Olyan hasznos szkriptet akkor kell hivatkozni a ABACUS ObjectModel. Rendelkezésére bocsátják a forgatókönyvbe, beleértve a Import ABACUS.ObjectModelnyilatkozatot élén a forgatókönyvet. A teljes hivatkozva a teljes ABACUS objektum modell tartalmazza a Script Editor. Megtalálható kiválasztásával Súgó | TartalomA Script Editor ablakban.

A script editor tartalmaz számos hasznos funkciót írásához scriptek, beleértve az automatikus kiegészítés, amint az a lenti képen. Ahhoz azonban, hogy még gazdagabb felhasználói élmény MS Visual Studio integrálható ABACUS és részletes utasítások állnak rendelkezésre itt .

Script szerkesztő automatikus kiegészítés

Ahhoz, hogy a Szkriptkezelő

1. Győződjön meg arról, hogy van Az ABACUS fájl, Amely a lakott építészet, nyisd ki.

2. Válasszuk az Eszközök | Szkriptkezelő.

3. Kattints a Addikon és egy Nyisd kiablak.

4. Böngésszen a ABACUS Script (.abacusscript, .vb Vagy .cs) Fájlt szeretne hozzáadni az Eszközök menübe.

5. Kattintson okéés egy hivatkozást a script jelenik meg a Script ablakot. Írja be a nevét a script, amit szeretnék, hogy megjelenjen az Eszközök menü. Megjegyzés: A Script Manager ablakban lehet átméretezni, hogy a teljes elérési utat, ha szükséges.

6. Ismételje 3-5hogy kapcsolatot teremtsen a több ABACUS szkripteket.

7. Kattintson Közelihogy lezárja a Script Manager és a figyelmét, hogy a ABACUS script (ek) is megjelennek az Eszközök menüben.

Futtatni egy szkriptet

Bármelyik;

1. Nyitott, írja be vagy másolja be a script futtatni kívánt, így az megjelenik a fő ablakban a Script Editor.

2. Kattintson a Fut gomb.

3. Ha a script hibákat tartalmaz, a hiba leírása részben alján a Script Editor kiírja a részleteket, beleértve a sorszámok. MEGJEGYZÉS: Minden egyes hiba a hiba leírása részben lehet duplán kattintunk, hogy ha a megfelelő sort a forgatókönyvben.

- vagy -

1. Válassza ki Eszközökmajd a ABACUS Script név menüpont jöhetnek létre a Szkriptkezelő.

2. Ha a script hibákat tartalmaz, a Script Editor nyílik meg a tartalmát a szkript látható a fő ablakban (kiemelve a sorban az első hiba), és a hiba leírása részben alján a Script Editor kiírja a részleteket, vagy A hiba (k), beleértve a sorszámok. MEGJEGYZÉS: Minden egyes hiba a hiba leírása részben lehet duplán kattintunk, hogy ha a megfelelő sort a forgatókönyvben.

Scripting fordítási hibák

Fordítási hibák fordulnak elő, amikor a szintaxis a script kód nem megfelelő. Ezek a hibák bukkannak fel a az ablak alján a hiba részén, egy leírást a hiba, és a sor száma. Ez a vonal számát, ami megkülönbözteti a fordítási hibát egy Runtime error (lásd alább), amely nem egy sorszámot is. Fordítási hibák is duplán kattintva ugorhat, és kiemeli azokat a konkrét kérdéses sor.

Scripting Runtime hibák (Fontos)

Futásidejű hibák fordulnak elő, miután a script kódot sikeresen össze hiba nélkül, de hiba történik futásidőben (lásd a példákat tovább részletezve). Futásidejű hibák azért fontosak, mert azt eredményezheti, hogy a sérült modell, amikor létrehozott objektumok és a hivatkozott egyéb tárgyak a modell, maguk nem része a modell (általában azért, mert a futásidejű hiba történt, mielőtt a kódot, amely elhelyezte őket a modell Valahol, kivégezték).

Ha a script létrehoz objektumok hozzáadását a modell, akkor elkerülhető a korrupció által okozott futásidejű hiba a megtakarítás a forgatókönyvet, záró script, és végez egy visszavonás a változások jöttek létre a script (ha a szkript futása nem fejezte be rendesen ). Vannak azonban más módjai is, hogy elkerülhető legyen a korrupció előforduló (lásd alább). hangjegy: Olyan szkriptek, amelyek pusztán olvasni a modell, és ne írjon rá, biztonságban vannak, és nem okoz semmilyen problémát, függetlenül attól, hogy futásidejű hibák lépnek fel azok végrehajtását.

Annak elkerülése érdekében, a korrupció, ha írásban script kód, amely objektumokat és hozzátéve, hogy az objektum modellt, azt javasolják, hogy a tárgyak adnak a modell a lehető leghamarabb, ha azok által hivatkozott egyéb tárgyak.

Például, ha létre egy új kapcsolatot, és 2 új komponensek, majd rögzíti őket, a legjobb, hogy hozzon létre az első komponens, add hozzá a modell, majd a második, és add meg, majd hozza létre a kapcsolatot, és add meg, majd végül létrehozza a mellékleteket. Ez azt jelenti, hogy ha nem is lenne futásidejű hiba, hogy megszakítja a parancsfájl végrehajtása, minden olyat, amelyek szükségesek, hogy a objectmodel előtt egy mellékletet jön létre, amelyek a modellben. A sérülés akkor fordulhat elő, ha például csak a kapcsolat már hozzá, a mellékletek készül, majd a futásidejű hiba történt, mielőtt a forgatókönyvet végül hozzá az új alkatrészeket a model.Corruption is előfordulhat, ha egy tárgy, amelyre hivatkoznak egy másik tárgy A objectmodel, önmagában sem a objectmodel.

Például futásidejű hibák közé tartozik:

· Az objektum nincs beállítva egy példányát egy tárgy - ez akkor történik, ha egy tárgy változó egy null referenciát és metódusok és tulajdonságok az objektumon van használatban. Null referenciák lehet ellenőrizni "Ha objectVariable semmi Aztán ..."

· Index határain kívül a tömb - ez akkor történik, amikor egy tömb használatban van egy index, amely határain kívül - pl kisebb, mint 0, vagy egyenlő vagy nagyobb, mint a hosszúság / Count a tömb. Array vagy Gyűjtemény hossza lehet ellenőrizni a .Length vagy .Count ingatlan volt.

· Nincs engedély Kivétel - Nem kell engedélyt ... - ez bekövetkezik, ha nincs engedélye, hogy az adott változás

· Elsődleges kulcs Kivétel - Ismétlődő / Hiányzó Név / ID - ez akkor történik, ha változás történik a különleges tulajdonság, amely ütközik egy másik objektumot. Ilyen például. Architektúrák egyedinek kell lennie megnevezés, hasonlóképpen a szabványoknak.

· Hivatkozási integritás Kivétel - beállítása egy hivatkozást mező olyan tárgy, amely nem érvényes. Ilyen például. hozzátéve, "semmi", vagy null, mint egy gyerek, hogy sok a gyűjtemények a objectmodel.

· Hossza nulla Kivétel - ez akkor fordulhat elő, ha megpróbálja beállítani a nevét egy objektumot egy üres string. A legtöbb objektumok igényelnek a nevüket, hogy legalább 1 karaktert.

Import nyilatkozatok

Ne feledje, hogy az elején a csontváz scriptek vannak olyan nyilatkozatok, mint Import ABACUS.ObjectModel. Ezek a kijelentések nem tartalmazza a dll, hogy még nem hivatkozik a forgatókönyvet - céljuk az, hogy egy "helyi", hogy kell meghatároznia a teljes nevét egy osztály.

Például arra, hogy egy változó típusú CKomponens (képviselő összetevő ABACUS), a Import ABACUS.ObjectModelnyilatkozatot teteje felé a forgatókönyvet, csak arra lenne szükség, hogy lehessen nyilvánítani, homályos comp mint CKomponensMert a fordító tudja, hogy néz ki a ABACUS.ObjectModel névtér a CKomponens osztályban. Anélkül, hogy a behozatal nyilatkozatot, azt kellene nyilvánítani homályos comp mint ABACUS.ObjectModel.CComponent. Egy szerelvény (mint például Mscorlib.dll, vagy System.Windows.Forms.dll) tartalmazhat több névtér - a behozatal állítás ezekre névterek, nem a szerelvények magukat. A ABACUS.ObjectModel.dll szerelvény csak az egységes ABACUS.ObjectModel névtér elérhető Scripting.

Automatikusan hivatkozott szerelvények

A következő DLL hivatkozott automatikusan Scripting:

· Mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (implicite hivatkozott a fordítóprogram)

· ABACUS.ObjectModel.dll

Ahhoz, hogy további hivatkozások sem más .NET assembly, vagy a saját szerelvények, a következő részben a #ImportDLL nyilatkozatot.

#ImportDLL nyilatkozat

Kezdve az ABACUS 3.1, akkor hivatkozni további szerelvényeket, hogy esetleg szükség a scriptek használatával a #ImportDLL nyilatkozatot. Például, ha akarta elérni egy egyéni DLL a tiéd, és használja a funkcionalitást, akkor azt tegyük a ABACUS könyvtárba, és tartalmazza a következő nyilatkozatot, mint az első sorban (ek) a forgatókönyvet. Ha ez egy .NET dll, akkor általában nem kell, hogy adja meg a teljes elérési utat, csak a DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Néhány más fontos megjegyzés:

1. Mivel a DLL kell fordításkor és futtatási, ez korlátozza az egyéni (nem NET) DLL-eket forgalomba az ABACUS program mappát csak.

2. #ImportDLL nyilatkozatokat kell lennie az első sor (ok) egy script - ha 5 kimutatások, akkor legyen az első 5 sor a forgatókönyvet

3. Egy #ImportDLL nyilatkozatot bárhol elhelyezhető, de az első sorok a forgatókönyvet (például, ha az anyagot, miután egy megjegyzést vagy import kimutatás) nem fog megfelelően működni és / vagy okozhat független fordító hibákat.

#ImportDLL Office összeállítások

Ha a Microsoft Office telepítve, és a script igényli a Hivatal együttműködése a szerelvények, lehetséges, hivatkozni rájuk egyszerűen használ #ImportDLL az összeszerelést a nevet (alább felsorolt, ilyen például. #ImportDLL Excel). Ezzel a módszerrel az az előnye, hogy az abszolút dll útvonal nem kell alkalmazni, így a szkript könnyebben hordozható (működnie kell az Office 2003 és 2007 szerkesztése nélkül a script).

Amikor ezt a funkciót használja, a GAC ​​(Global Assembly Cache) lesz keresve a interoperabilitási összeszerelés, és a szkript állítja össze az elérési útját, hogy az összeszerelést, ha találtak. Ha ez nem találtak, script ellenőrzi a ABACUS program könyvtárba (amely tartalmazza az Excel és a Visio interops esetén). Ha a kért interoperabilitási nem található meg ebben az időben, egy figyelmeztetés jelenik meg.

A interops jellemzően nincs telepítve a GAC, ha telepített Microsoft Office telepítése előtt a .NET-keretrendszer (amely része a teljes ABACUS telepítés). Tudod telepíteni őket, hogy elvégezzük a Change lehetőséget a Microsoft Office Programok hozzáadása / eltávolítása, és válassza a .NET programozhatóság lehetőségeket. További információk, lásd ezt cikk az MSDN-en.

A szerelvények, amelyek ezt a rövidítést támogatottak:

· Hozzáférés

· Access.Dao

· Excel

· Grafikon

· Az MS Project

· Outlook

· OutlookViewCtl

· Owc11

· PowerPoint

· Kiadó

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Szó

It nem teljesen világos, hogy a fenti szerelvények Hasznos, szobák havebeen tartalmazza ezt a funkciót regardeless, mint néhány felhasználó február van szükség még a homályos szerelvények.

Lásd még

Szimuláló az építészet