Bæti forstillt eiginleika til hluti, tengingu eða tegund

Navigation: Populating vélina þína> Properties>

Bæti forstillt eiginleika til hluti, tengingu eða tegund

Senda athugasemdir um þetta efni.

Standard bókasöfn eignir getur verið skilgreindur og úthlutað til nokkuð annað í arkitektúr. Þessi bókasöfn eru þekkt sem Standards. Með því að nota Standards, Þú þarft aðeins að safna tilteknum kerfum eignir - venjulegt eignir eru þar nú þegar.

Til dæmis staðlaða eiginleika árangur af Microsoft Windows 2000 er hægt að vista semStandardog úthlutað til hvers konar hluti (eða tengingum, ekki að það væri dæmigert) nota Microsoft Windows 2000 stýrikerfi.

Til að bæta viðstaðalltil hluti, tengingu eða tegund

1. Hægrismellaá hluti / tengingu / tegund.

2. Veldu Úthluta Standard.

3. VelduaStandardaf listanum.

Sjá einnig

Populating vélina þína - Yfirlit | Breyta eiginleikum íhluta, tengingu eða tegund | Samanlagðar eignir

© 2001-2015 Avolution Pty Ltd. Öll réttindi áskilin.


Samanlagðar eignir

Navigation: Populating vélina þína> Properties>

Samanlagðar eignir

Senda athugasemdir um þetta efni.

Rekstur "Aggregate Properties"Gerir þér kleift að bæta við gildi svipaða eiginleika saman og skrifa (eða bæta við) niðurstöðuna í eignir sem valinn móðurfélagsins þáttur er. Það leyfir þér einnig að skilgreina gildissvið samansafn og hvort að uppfæra eiginleika allra undir-þætti eða ekki.

Að leggja saman eignir

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Hægri-smelltu á frumefni (arkitektúr, íhlutur eða tengingu) til þess að gera fyrir samsöfnun og veldu Samanlagðar Properties.

3. Veldu einn af samanlagðri stillingar (Traverse Allar undirvísitölur Levelseða Aðeins Direct Sub-Level). Ef þú hefur valið Traverse Allar undirvísitölur LevelsÞú getur einnig valið möguleika hvort að Update Sub-Levels.

o Traverse Allar undirvísitölur Levelsþýðir að umfang samloðun mun fela þætti í öllum stigum undir valið þáttur þinn.

o Update Sub-LevelsAðeins er hægt að gera ef þú hefur einnig valið möguleika Traverse Allar undirvísitölur Levels. Þetta þýðir að á meðan þú samanlagt eignir frá grunni, samanlagt niðurstaðan á hverju stigi verður einnig uppfærður í hvert samsvarandi einingar.

o Aðeins Direct Sub-Levelþýðir að aðeins eignir þætti beint undir valið þáttur verður lögð saman.

o Veldu Eru StandardPropertiesef þú vilt eiginleika skilgreind í staðlar að vera með. Annars, aðeins eiginleika einstök fyrir hvern hluti dæmis verður notað.

4. Veldu hvaða eiginleikar þú vilt að samanlagt. Þeir eru flokkaðar í þeirra Tegundir.

5. Smelltu á Næstahnappinn.

6. Veldu möguleika hvort að Yfirskriftar Valueseða Bæta Valuesí valið frumefni.

o Yfirskriftar Valuesmun skrifa niðurstöðurnar beint í eiginleika valið frumefni.

o Bæta Valuesmun bæta niðurstöður við núverandi eiginleika valið frumefni.

Sjá einnig

Bæti forstillt eiginleika til hluti, tengingu eða tegund | Breyta eiginleikum íhluta, tengingu eða tegund | Mat vélina þína


Arkitektúr Diff og Sync

Navigation: Greina vélina þína>

Arkitektúr Diff og Sync

Senda athugasemdir um þetta efni.

Þegar þú hefur 2 eða fleiri arkitektúr, annaðhvort sem þróunar eða grunngildi arkitektúr, þú getur sjónrænt "Diff 'tveir örgjörvar með Vöruflokkar eða skýringarmynd Samanburður eða Arkitektúr Diff lögun. Þetta er sérstaklega gagnlegt fyrir að uppgötva / re-uppgötva nákvæmlega breytingar frá einum arkitektúr til annars eins og þú þróast arkitektúr og þróa roadmaps í Abacus.

Til Sýna 'breyting' með öðru arkitektúr gegnum skýringarmynd

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Tryggja þér hafa að minnsta kosti 2 arkitektúr í verkefninu.

3. Opnaðu skýringarmynd sem þú vilt að bera saman við aðra arkitektúr.

4. Smelltu á 'bera saman þessa mynd hér til innihald annars arkitektúr' hnappinn á myndinni stikunni.

5. Veldu annað arkitektúr frá the falla-dúnn listi til að bera saman við.

6. Þú getur síað hvaða munur er sýndur með því að smella á hnappinn 'Mismunur' á myndinni stikunni og afvelja valkosti, td Breytt / bætt / Unknown og Óákveðins / Sync Mælt/ Halda Mælt.

Note

Hluti og tengingar á fletinum verður lögð áhersla á rauður, grænt eða fjólublátt þar sem það eru mismunandi milli efni sem er sýnilegt á núverandi skýringarmynd og efni í öðrum arkitektúr. Red er notað þar sem það er mælt með að Sync muninn (sjá hér að neðan), Grænn er notað þar sem það er ekki mælt með að samstilla muninn, sem er að halda þeim (sjá hér að neðan) og Purple er notað þar ABACUS getur ekki gera tillögu um syncing muninn (sjá hér að neðan). Aðeins sýnilegt efni á myndinni er miðað svo ef umsögnina er að sýna eignarskattur geymsla og gildi er breytt viðkomandi hluti eða tenging verður sýnd í dauft rautt, dauft grænteða dauft fjólublátt og a '*' tákn sést efst til vinstri fyrir hluti, hins vegar, ef einhver annar undirliggjandi gildi geymsla eign breyst sem ekki er verið sýnd í umsögnina þá ekki vísbending verður gefið. Efni sem á sér stað á núverandi mynstri en engin samsvörun finnst í samanburði arkitektúr verður sýnd í Sterk rauður, sterkt grænteða sterkt fjólubláttog a '+' tákn birtist efst í vinstra fyrir hluti. Lokað er gert með íhluta og nafn svo að ef gerð eða nafn íhluta eða tengingu hefur breyst í hinu arkitektúr ekki passa verður að finna. Eins og það er engin leið að áreiðanlegum ákvarða hvort fleiri efni úr hinu arkitektúr hefði verið sýnt fram á núverandi mynstri (td til viðbótar tengi milli 2 þætti eins og sýnt er hér fyrir neðan á skýringarmynd frá samanburði arkitektúr til hægri), eru þessi munur ekki sýnd skýringarmyndir (þeir eru sýnd bæklingum sem greinir hér að neðan). Sveima yfir hvern breytta lið mun sýna muninn á ábending. Sveima yfir '*' táknið efst til vinstri á myndinni er yfirlit yfir breytingar (eða engar breytingar) milli innihald mynstri og innihald hins arkitektúr.

Colour Legend

· Grænn sýnir atriði sem það er ekki mælt með því að samstilla muninn, sem er að halda þeim.

· Red sýnir atriði sem það er mælt með því að samstilla muninn.

· Purple sýnir atriði þar ABACUS getur ekki gera tillögu um syncing muninn.

Til samstilla efni ('sync') frá einum arkitektúr við annan gegnum skýringarmynd

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Tryggja þér hafa að minnsta kosti 2 arkitektúr í verkefninu.

3. Opnaðu skýringarmynd sem þú vilt að bera saman við aðra arkitektúr.

4. Smelltu á 'bera þetta Catalogue til innihald annars arkitektúr' hnappinn á Skýringarmynd stikunni.

5. Veldu annað arkitektúr frá the falla-dúnn listi til að bera saman.

Note

Sjá hér að ofan fyrir því ABACUS sýnir 'breyting' á milli 2 arkitektúr í verslun. Einkum hvernig Red er notað þar sem það ermælt með því að Sync muninn, Grænn er notað þar sem það er ekkimælt með því að samstilla mismun og Purple er notað þar ABACUS getur ekki gera tillögu um syncing muninn.

6. Hægri-smelltu á skýringarmynd þáttur (eða þætti með Shift eða skýringarmynd striga til að samræma allt) sýnir a 'diff' og veldu Sync matseðill atriði.

Note

Allar samstillingu breytingar verður aðeins beitt að arkitektúr sem nú eru í fókus verslun tilheyrir. Til að sækja um breytingar til hins arkitektúr verður þú að nota verslun í hinu arkitektúr. Ennfremur, notandi vilja aðeins vera fær um að beita breytingar samstillingu ef þeir leyfi til að gera það .

Note

Það fer eftir því hvar þú hægri-smelltu á valmyndina birtir leiðbeiningar um hvað nákvæmlega er að fara að vera samstillt.T.d. Hægri-smella á einn þáttur í myndinni mun aðeins samstilla þessi hluti. En hægrismella á skýringarmynd striga og velja Sync Allir vilja samstilla allar nú sýnt muninn.

Til Sýna 'breyting' með öðru arkitektúr gegnum vörulista

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Tryggja þér hafa að minnsta kosti 2 arkitektúr í verkefninu.

3. Opnaðu verslun sem þú vilt að bera saman við aðra arkitektúr.

4. Smelltu á 'bera þetta Catalogue til innihald annars arkitektúr' hnappinn á Catalogue stikunni.

5. Veldu annað arkitektúr frá the falla-dúnn listi til að bera saman við.

6. Þú getur síað hvaða munur er sýndur með því að smella á hnappinn 'Mismunur' á myndinni stikunni og afvelja valkosti, td Breytt / bætt / Unknown og Óákveðins / Sync Mælt/ Halda Mælt.

Note

Frumur í verslun verður lögð áhersla á rauður, grænt eða fjólublátt þar sem það eru mismunandi milli efni í núverandi verslun og samsvarandi efni í hinum arkitektúr. Red er notað þar sem það er mælt með að Sync muninn (sjá hér að neðan), Grænn er notað þar sem það er ekki mælt með að samstilla muninn, sem er að halda þeim (sjá hér að neðan) og Purple er notað þar ABACUS getur ekki gera tillögu um syncing muninn (sjá hér að neðan). Aðeins sýnileg raðir og dálka í verslun eru bornar saman þannig að ef það er munur á röð handan nú sýndar raðir eða gildi í dálki sem birtist ekki hefur mismunur þá enginn munur verður gefið til kynna. Þar sem gildi í einstökum klefi er öðruvísi með samsvarandi klefi í samanburði arkitektúr klefi rammi hápunktur. Súlan haus og röð val mun einnig vera skyggða í dauft fjólubláttog sýnt með '*' tákn. Þessar '*' tákn má smella til að hoppa til næsta munur á dálks eða raðar í sömu röð. Raðir sem á sér stað í núverandi verslun en ekki passa er að finna í samanburði arkitektúr verður sýnt með '+' tákn í röð val á vinstri og meðfram öllu röð verður hápunktur. Raðir sem hefði átt sér stað í útgáfu Samanburðurinn arkitektúr er á verslun (þ.e. með sömu síur osfrv) en ekki passa er að finna í núverandi arkitektúr verður sýnt með '-' tákn í röð val á vinstri, á landamærum allt röð verður lögð áhersla og öllu röðum frumur innihald verður sýnd í dauft fjólubláttog sló í gegnum, t.d. 08:00 til 6pm. Lokað er gert með íhluta og nafn svo að ef gerð eða nafn íhluta eða tengingu hefur breyst í hinu arkitektúr ekki passa verður að finna. Sveima yfir hvern breytta lið mun sýna muninn á ábending. Sveima yfir '*' táknið efst til vinstri á myndinni er yfirlit yfir breytingar (eða engar breytingar) milli innihald skýringarmynd og innihald hins arkitektúr.

Colour Legend

· Grænn sýnir atriði sem það er ekki mælt með því að samstilla muninn, sem er að halda þeim.

· Red sýnir atriði sem það er mælt með því að samstilla muninn.

· Purple sýnir atriði þar ABACUS getur ekki gera tillögu um syncing muninn.

Til samstilla efni ('sync') frá einum arkitektúr við annan í gegnum vörulista

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Tryggja þér hafa að minnsta kosti 2 arkitektúr í verkefninu.

3. Opnaðu verslun sem þú vilt að bera saman við aðra arkitektúr.

4. Smelltu á 'bera þetta Catalogue til innihald annars arkitektúr' hnappinn á Catalogue stikunni.

5. Veldu annað arkitektúr frá the falla-dúnn listi til að bera saman.

Note

Sjá hér að ofan fyrir því ABACUS sýnir 'breyting' á milli 2 arkitektúr í verslun. Einkum hvernig Red er notað þar sem það ermælt með því að Sync muninn, Grænn er notað þar sem það er ekkimælt með því að samstilla mismun og Purple er notað þar ABACUS getur ekki gera tillögu um syncing muninn.

6. Hægri-smelltu á klefi, dálki eða röð stefnir (eða fleiri atriði með Shift eða Ctrl + A fyrir allt) sýna "breyting" og velja Sync matseðill atriði.

Note

Allar samstillingu breytingar verður aðeins beitt að arkitektúr sem nú eru í fókus verslun tilheyrir. Til að sækja um breytingar til hins arkitektúr verður þú að nota verslun í hinu arkitektúr. Ennfremur, notandi vilja aðeins vera fær um að beita breytingar samstillingu ef þeir leyfi til að gera það .

Note

Það fer eftir því hvar þú hægri-smella (þ.e. klefi, dálki eða röð fyrirsögn) vallistaatriðið birtir leiðbeiningar um hvað nákvæmlega er að fara að vera samstillt.T.d. Hægri-smella á einn eign eða meðfylgjandi hluti fruma í verslun mun aðeins samstilla þessi eign eða meðfylgjandi hluti. En hægrismella röð stefnir (eða fyrirsagnir með Shift) mun samstilla allt (eða raðir). Hægrismella dálk haus mun samstilla öll munur á þeim dálki.

Til að skoða 'breyting'af 2 heild arkitektúr

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Tryggja þér hafa að minnsta kosti 2 arkitektúr í verkefninu.

3. Veldu Verkfæri| Arkitektúr Diff ....

4. Í glugganum sem birtist skaltu velja fyrsta / Frá og annað / Til arkitektúr til að bera saman.

5. Smelltu á OKhnappinn.

Arkitektúr Diff

Colour Legend

· Grænngefur til kynna að hnúturinn var bætt í seinni / í arkitektúr.

· Redgefur til kynna að hnúturinn var eytt í öðru / To arkitektúr.

· Bluegefur til kynna að hnúturinn á mismunandi vegu (td eiginleika eða staðla) Í annarri / arkitektúr.

· Yellowgefur til kynna að hnúturinn hefur mismunandi börnum sínum í annað / Til arkitektúr svo hnúturinn skal stækkað.

Note

Þú getur hægri smellt og "Sýna í Explorer" á alla hnúta að sjá upplýsingar og nánari upplýsingar er að finna á muninn á Mismunur Yfirlit spjaldið þegar hnúturinn er valið.

Sjá einnig

Greina vélina þína | Skoða svar tími töfluna | Skoða á öðrum ásnum matrix þróast arkitektúr þínum | Þróun vélina þína


Breyta eiginleikum íhluta, tengingu eða tegund

Navigation: Populating vélina þína> Properties>

Breyta eiginleikum íhluta, tengingu eða tegund

Senda athugasemdir um þetta efni.

Eignir eru venjulega kerfið kröfur sem þú tilgreinir, eða niðurstöður mats Abacus '. (Þegar ABACUS framkvæma mat sínum, skrifar það eiginleika aftur á skránni.) Með öðrum orðum, eiginleikar eru það sem þú veist um kerfið, eða það sem þú ert að nota Abacus að finna út.

Til að breyta eignarskattur af hluti, tengingu eða tegund

1. Smelltuá hluti / tengingar / tegund (eiginleikar hennar birtist í Properties glugganum til hægri).

2. Smelltuað varpa ljósi á eign sem þú vilt breyta.

3. Gerðný gildi.

Mikilvægt

Einnig eru margir eiginleikar skilgreind Standards . Með því að breyta eign innanStandard, Þú ekki aðeins að breyta núverandi hlut, þú breytir einnig skipstjóra Standard (undir Standards áefst á trénu). Áður en að gera þetta, athuga hvað aðrir efnisþættir, tengingar eða gerðir eru að nota Standard, Vegna þess að breyting getur ekki að eiga við þá- Þú getur notað tilvísanir gluggi fyrir þetta.

Ábending

Þú getur breytt eiginleikum á tengingu frá innan Hluti útibú tré (og öfugt). Svo, til dæmis, ef þú ert að leita á hvaða tengingar eru fest við hluti, og þú gerir þér grein að breyta einum, þú getur.

Til að bæta við nýjum eiginleikum við íhluti eða tengingu (með gerð)

Note

Properties er aðeins hægt að bæta við gerðum og íhluta eða tengingar af gerðinni 'erfa "þá eiginleika.

1. Smelltueftir tegund (eiginleikar hennar birtist í Properties glugganum til hægri).

2. Smelltuá Bæta við hnappinn efst Property glugga til að bæta upp röð á the toppur af the eign rist fyrir nýja eign.

3. Bæta við Gerðfyrir nýja eign.

4. Bæta við Namefyrir nýja eign.

5. Bæta við Sjálfgefið gildifyrir nýja eign.

6. Bæta við Unitfyrir nýja eign.

7. Stilltu Gögn Tegundfyrir nýja eign.

Note

The Data Type reit er hægt að nota til að takmarka gild gildi sem eign getur haft. Það er; Text, Integer, Decimal, Date / Time, Boolean eða List.

o A TextiStaðurinn er einn sem hefur ótakmarkaðan fjölda stafa og í raun hefur engar hömlur á verðmæti.Ef eign gildi er rétt mynduð tengil (þ.e. Slóðir þarft til að byrja með einn af 5strengir; http: //, https: //, ftp: //,file:eða \\ og allirrými skal gert með '% 20') Þá er tengill smella (með ctrl + smell).

o An IntegerEign verður að vera heil tala annaðhvort jákvæð eða neikvæðog getur innihaldið tímabil, rúm, úrfellingarmerki eða komma fyrir stafa flokkun eftir því verkefnisins Region stillingar frá Skrá | Project Options.The Region stillingar og.Net Long.TryParse aðferð er notað til að ákvarða gildi Integergildi.

o A Decimaleign getur innihaldið a tímabil eða komma fyrir Tugabrotatákn geta innihaldið tímabil, rúm, úrfellingarmerki eða komma fyrir stafa flokkun eftir því verkefnisins Region stillingar frá Skrá | Project Options.The Region stillingar og.Net Decimal.TryParse aðferð er notað til að ákvarða gildi Decimal gildi.

o A Date / Timeleyfilegt annaðhvort Dagsetning hluta eða Time hluta eða bæði. The RegionStillingarog Nettó DateTime.TryParse aðferð eru fyrst og fremst notuð til að ákvarða gilda dagsetningu og / eða tíma gildi. Hins vegar Date hluti ef við þarf að minnsta kosti dag og mánuð (Ár verður ráð fyrir að vera núverandi ári) eða mánuður og ár hlutar úr gildi. Þ.e. Júní, Q3 2010 eða jafnvel bara 2010 eru ógild. En það mun vera mismunandi með mismunandi svæðisbundnum stillingum, yfirleitt daginn, mánuðinn og Ár hluta er hægt að skilja með rúm, komma, strik ('-') eða skástrik ('/'). The Day hluti er yfirleitt heiltala frá 1 til 31. næsta mánaðar hluti er yfirleitt heiltala frá 1 til 12, gilt 3 bréf skammstöfun fyrir mánuði (td Jan, Feb, Mar) eða fullt nafn mánaðar (td janúar, febrúar mars). The Year hluti er yfirleitt 4 stafa jákvæð tala en 1, 2 og 3 stafa ár eru samþykkt í samræmi við stillingar í Control Panel-> Regional and Language Valkostir-> Regional Valkostir-> Stilla (hnappur) -> Date-> Dagbók. Venjulega þeir eru túlkuð sem hér segir; 0-29 er túlkað sem 2000-2029, 30 til 99 eins og 1930-1999 og 100-999 sem 100-999. Ógildir dagsetningar ss 31 júní 2010 og 31/9/2010 verður að uppgötva. The Time hluti ef við krefst klukkustundum og mínútum þátt og mögulega Seconds hluti. The Hours, Minutes og valfrjálst Seconds hlutar eru yfirleitt aðskilin með tvípunkti (':') og sekúndur hluti er hægt að tilgreina með kommu ('.'). Nánari upplýsingar um gildandi snið vinsamlegast vísa til athugasemdareit hluta á .Net DateTime.TryParse aðferð .

Ábending

Það er mælt með því að nota að minnsta kosti 3 bréf nafn mánaðar snið (þ.e. "Júlí" eða "Júlí") fyrir dagsetningu gildum fremur en tölulegar formatting (þ.e. "7" eða "07") sem þessum gildum verður sannreyna yfir flestum svæðum eftir á Project er Region stillingar frá Skrá | Project Options.Þ.e. það er mælt með að nota "15 Jul 2010" frekar en "15/7/2010" eða "7/15/2010". Með þessu dæmi, "15/7/2010" myndi mistakast löggilding fyrir '(United States) "og" 2010/07/15 "myndi mistakast að' English (United Kingdom)", þó "15 júl 2010" myndi fara fyrir bæði.

o A Booleaneign getur verið annaðhvort True eða False.Það er málið særandi svo satt eða FALSE má einnig nota hins Já, Nei, 1, 0 etc mun þverra hvaða eign þvingun.

o A Listleyfilegt safn af fyrirfram skilgreindum gildum eins og Low | Medium | Hátt eða haldið | Endurnýja | Endurhönnun | Störfum og bil kemur frá Eining reitnum fyrir eign annaðhvort sem kommu eða pípu '|' aðskilin gildi. Eign getur talist vera ordinal (eins og öfugt við vægu, bil eða hlutfall) því þegar það er notað á kortum og að lita þætti á skýringarmynds og 3DS gildin eru meðhöndlaðir einfaldlega í hækkandi (eða lækkandi) röð. Það er gildi eru teiknuð í hækkandi (eða lækkandi) röð á töfluna ása eða lit svið.

8. The Data Type er hægt að stilla til að vera Disabled, Aðvöruneða Framfylgtmeð því að hægri-smella á tegund gagna sviði fyrir hvaða stillingu annað en texta, sem gerir allar stafir svo má ekki alltaf vera rangt.

9. Stilltu Áskiliðmerkja fyrir nýja eign.

Note

Nauðsynlegur reitur er hægt að nota til að gefa til kynna hvort gildi þarf að færa fyrir eign. Það er að það má ekki vera autt eða tóm. Falseer sjálfgefið og þýðir eign getur verið tómur eða auður, Trueþýðir að eign ætti að hafa gildi og getur ekki verið tómt eða auður. The Required er hægt að stilla til að vera Disabled, Aðvöruneða Framfylgtmeð því að hægri-smella á Krafist sviði ef það hefur verið stillt á True.

Sjá einnig

Populating vélina þína - Yfirlit | Bæti forstillt eiginleika til hluti, tengingu eða tegund | Samanlagðar eignir


Breyting á hluti / tegund tengingu er

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Breyting á hluti / tegund tengingu er

Senda athugasemdir um þetta efni.

Hluti og tengingu tegundir eru aðallega notaðar fyrir flokkun. Þú getur notað gerðir sem síur þegar skoðuð vélina þína. Til dæmis, í stað þess að skoða allt hlutur, getur þú skoðað bara hluti Umsókn.

Til að breyta íhlut / tegund tengingu er

1. Hægrismellaá hluti eða tengingu.

2. Veldu Breyta Type.

3. Velja aðra tegund af listanum.

Ábending

Þegar þú breytir tegund, þú getur fengið nokkrar nýjar staðlareða eiginleika (hvað er í tengslum við gerð - sjá ferðalaga útibú tré). Núverandi þinn staðlar og eignir verði óbreytt. Þú getur búið til eigin nýja þínum gerðir og tengja eigin samsetningar þína á staðlar og eignir til þeirra.

Sjá einnig

Að búa til nýja tegund | Populating vélina þína - Yfirlit | Greining arkitektúr þinn


Breyting Svæði stillingar verkefnis er

Navigation: Populating vélina þína> Properties>

Breyting Svæði stillingar verkefnis er

Senda athugasemdir um þetta efni.

Property gildi þurfa víst formatting á mismunandi svæðum til að passa allir Gögn Tegund þvingun fyrir Integer, aukastaf og dagsetningu / tíma eiginleika. Til dæmis í Ástralíu aukastaf "123.456 punkta sjö átta níu" er táknuð sem "123,456.789", en í Þýskalandi og það væri represnted sem "123.456,789" og í Frakklandi að það væri " 123 456789 ".Á sama hátt, í Bandaríkjunum er "annað desember 1970" er táknuð sem stutta dagsetningu og "12/2/1970" en í Bretlandi er táknuð sem "2/12/1970" og í Póllandi sem "1970-1912 -02 ". Samkvæmt því, að vinna með Abacus verkefni milli svæða alþjóðlegt stilling fyrir Abacus verkefnisins er krafist.

Breyta Svæði stillingar AN Abacus verkefnisins

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Veldu Skrá | Project Options ... og frá glugganum sem birtist velja Regionog smelltu á OK. Ath: Sjá neðar í svæðisbundnum vanskila.

Note

Ef þú sérð ekki Project Options ... valmyndinniþá þú þarft ekki Designer og Administrator viðbótsog þú getur ekki breytt svæði verkefnisins.Einnig, ef ekki Region er sett (þ.e. svæðið í verkefni valkosti er 'None (System Region)') þá hver MS Windows núverandi menningu stillingar notandans (þ.e. Regional Settings)eru notuð til að sannprófa eiginleika.

Svæði vanskil

Eftirfarandi tafla sýnir að vanskil fyrir hvert svæði sem sett gegnum Skrá | Project Options ...valmyndinni.Vinsamlega sjá hér borðið til að fá lista af táknum sem notuð eru.

Region | Tugabrotatákn | Stafa hópar | Neikvætt formerki | Short Time | Langur tími | AM / PM tákn | Short Date | Long Date
English (Australia) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / ÁÁÁÁ | dd MMMM áááá
English (United Kingdom) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / ÁÁÁÁ | dd MMMM áááá
English (United States) | . | , | - | HH: mm TT | HH: mm: ss TT | AM | PM | M / D / áááá | DDDD, MMMM dd, áááá
Franska (France) | , | rúm | - | HH: mm | HH: mm: ss | | | dd / MM / ÁÁÁÁ | DDDD D MMMM áááá
Þýska (Þýskaland) | , | . | - | HH: mm | HH: mm: ss | | | dd.mm.aaaa | DDDD, d. MMMM áááá
Ítalska (Italy) | , | . | - | HH: mm | HH: mm: ss | | | dd / MM / ÁÁÁÁ | DDDD D MMMM áááá
Spænska (Spain) | , | . | - | H: mm | H: mm: ss | | | dd / MM / ÁÁÁÁ | DDDD, dd 'de' mmmm 'de' áááá
English (Canada) | . | , | - | HH: mm TT | HH: mm: ss TT | AM | PM | dd / MM / ÁÁÁÁ | MMMM-dd-áá
Franska (Canada) | , | rúm | - | HH: mm | HH: mm: ss | | | YYYY-MM-dd | D MMMM áááá
Arabic (U.A.E.) | . | , | - | kk: mm TT | kk: mm: ss TT | ص | م | dd / MM / ÁÁÁÁ | dd MMMM, áááá
Arabic (Saudi Arabia) | . | , | - | kk: mm TT | kk: mm: ss TT | ص | م | dd / MM / YY | dd / MMMM / áááá
English (South Africa) | , | rúm | - | kk: mm TT | kk: mm: ss TT | AM | PM | áááá / MM / dd | dd MMMM áááá
English (New Zealand) | . | , | - | HH: mm TT | HH: mm: ss TT | fyrir hádegi | p.m. | D / MM / ÁÁÁÁ | DDDD, d MMMM áááá
English (India) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd-mm-áááá | dd MMMM áááá
Þýska (Switzerland) | . | ' | - | HH: mm | HH: mm: ss | | | dd.mm.aaaa | DDDD, d. MMMM áááá
Franska (Belgium) | , | . | - | HH: mm | HH: mm: ss | | | D / MM / ÁÁÁÁ | DDDD D MMMM áááá
Dutch (Belgium) | , | . | - | H: mm | H: mm: ss | | | D / MM / ÁÁÁÁ | DDDD D MMMM áááá
Czech (Czech Republic) | , | rúm | - | H: mm | H: mm: ss | dop |. ODP. | d.M.yyyy | d. MMMM áááá
Danska (Danmörk) | , | . | - | HH: mm | HH: mm: ss | | | dd-mm-áááá | d. MMMM áááá
Gríska (Greece) | , | . | - | HH: mm TT | HH: mm: ss TT | πμ | μμ | D / M / áááá | DDDD, d MMMM áááá
Finnish (Finland) | , | rúm | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'áááá
Hungarian (Hungary) | , | rúm | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | d. MMMM d.
Dutch (Netherlands) | , | . | - | H: mm | H: mm: ss | | | D-M-áááá | DDDD D MMMM áááá
Norska, bókmál (Norway) | , | rúm | - | HH: mm | HH: mm: ss | | | dd.mm.aaaa | d. MMMM áááá
Pólska (Pólland) | , | rúm | - | HH: mm | HH: mm: ss | | | YYYY-MM-dd | D MMMM áááá
Russian (Russia) | , | rúm | - | H: mm | H: mm: ss | | | dd.mm.aaaa | D MMMM áááá 'г.'
Sænska (Svíþjóð) | , | rúm | - | HH: mm | HH: mm: ss | | | YYYY-MM-dd | "Den" d MMMM áááá
Korean (Korea) | . | , | - | TT HH: mm | TT klst: mm: ss | 오전 | 오후 | YYYY-MM-dd | YYYY '년' M '월' d '일' DDDD
Hebrew (Israel) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / ÁÁÁÁ | DDDD dd MMMM áááá

Eftirfarandi tákn eru notuð til að tilgreina hvernig dag- og tímasetningar eru birtar:

Tími tákn |
h | Klukkustund (HH sýnir klukkutíma með leiðandi núll)
m | Minute (mm sýnir mínútu með leiðandi núll)
s | Second (ss sýnir annað með leiðandi núll)
TT | Fyrir hádegi eða P.M.
H / H | 12 eða 24 klst tími sýna
Dagsetning tákn |
d, dd | Day
ddd, DDDD | Dagur vikunnar
M | Mánuður
y | Ár

Sjá einnig

Populating vélina þína - Yfirlit | Breyta eiginleikum íhluta, tengingu eða tegund | Bæti forstillt eiginleika til hluti, tengingu eða tegund


Command Line valkostir

Navigation: Tilvísun>

Command Line valkostir

Senda athugasemdir um þetta efni.

Þú getur gert ýmsar Abacus aðgerðir beint frá the stjórn lína með algengustu aðgerðirnar vera til að opna sérstaka verkefni skrá og birta það til HTML.

Sérstaklega, stjórn lína notkun Abacus er sem hér segir;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ notandi "notandi" / framhjá "PASS"]

Rök | Lýsing
ProjectFile | The ProjectFile getur verið annaðhvort ABACUS verkefnið skrá (.abacus), bókasafn skrá (.abacuslib), XML skrá (.xml) eða MS Access DB (MDB) og Skráin verður annaðhvort að opna (ef .abacus eða .abacuslib ) eða nýtt verkefni búin (ef .xml eða MDB skrá).
OptionalFile | The OptionalFile getur verið annaðhvort ABACUS handrit (.abacusscript, .vb eða .cs), þjóðhagsleg (.abacusmac) eða bókasafn skrá (.abacuslib) og Skráin verður annað hvort að keyra eftir opnun ProjectFile (ef .abacusscript, .vb eða .cs eða .abacusmac) eða einfaldlega opna (ef .abacuslib).
/ exitOnCompletion | Mun hætta Abacus og ef þarf að bjarga og fremja neinar breytingar á opnum .abacus verkefni á að ljúka einhverju handriti eða fjölvi. Ath: Þessi biti er Case Sensitive svo vertu viss um að nota hástafi 'O' og 'C' í textanum eins og sýnt er.
/ dontShowDialogs | Kemur í veg fyrir ABACUS Enterprise Edition (EE) Tilkynning uppfærslu glugga birtist við opnun verkefni. Ath: Þessi biti er Case Sensitive svo vertu viss um að nota hástafi 'S' og 'd' í textanum eins og sýnt er.
/ notandi "notandi" / framhjá "PASS" | Notandanafnið USER og lykilorð PASS verður notað til að skrá þig inn á verkefninu með, vega þyngra vistað nein notandi persónuskilríki. Ath: gæsalappa verður að vera sett í kringum notanda og PASS fánar og tveir gæsalappa má nota til að flýja gæsalappa í annaðhvort notandinn eða fara fánar.

T.d.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.VB"/ exitOnCompletion / dontShowDialogs / notandi "Public" / framhjá "123456"

hvenær hlaupa frá möppuna þar að ABACUS.exe tvöfaldur er staðsett mun opinn Dæmið verkefnið og skrá þig inn sem notandi Almenn með lykilorði 123456 (eins og lýst er hér ), Birta það til HTML og svo loka verkefnið allt án þess að sýna nein glugga á leiðinni (td 'Uppfæra Árangursrík' eða 'Engar uppfærslur í boði "fyrir Enterprise verkefni).

T.d.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Vörulisti Excel Import.VB"/ exitOnCompletion / dontShowDialogs

hvenær hlaupa frá möppuna þar að ABACUS.exe tvöfaldur er staðsett mun opinn Dæmið verkefnið og flytja "Servers (2014 Actual) .xlsx" MS Excel skrá í verslun 'netþjóna á "2014 Raunveruleg" arkitektúr verkefnisins án þess að sýna nein glugga á leiðinni og þá loka verkefnið er lokið. Ef aðgerðin gerir breytingar á verkefninu þá við lokun breytingar eru vistaðar á staðnum og ef Enterprise verkefni skuldbundið sig til að Enterprise Server.

Note

Vertu viss um að nota rétta tvöfalda vitna staf þar sem það eru nokkrir í venjulegu ASCII stafasett og Windows Stjórn Hvetja mun aðeins vinna rétt með the réttur einn. Rétt tvöfaldur vitna stafkóði er Decimal 34 (Sextánskt 22).Þetta er það sem er notað í dæminu hér að ofan svo ekki hika við að afrita / líma það þaðan.


Afrita og líma

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Afrita og líma

Senda athugasemdir um þetta efni.

Hægt er að afrita hluta eða öllu arkitektúr og líma það á öðrum stað í trénu.

Til að afrita

1. Hægrismellaá hlutnum sem þú vilt afrita.

2. Veldu Afrita.

Að líma

1. Sigla tré til að finna stað sem þú vilt líma hlutinn.

2. Hægrismellaá grein sem þú vilt það til að birtast innan.

3. Veldu Líma.

4. Atriðið verður að afrita með upprunalegu nafni (nema þú afritað það á upprunalega grein - þá verður það kallað "Afrit af ...").

Sjá einnig

Hvernig er arkitektúr fulltrúa í Abacus


Afritun skýringarmyndir

Navigation: Populating vélina þína> Using Teikningar>

Afritun skýringarmyndir

Senda athugasemdir um þetta efni.

Það eru 2 helstu atburðarás til að afrita núverandi skýringarmynd; innan arkitektúr, eða yfir arkitektúr.

Til Afritaskýringarmyndinnan arkitektúr

1. Tryggja þú hafa óákveðinn greinir í enskuABACUS skrá er opininniheldur þínum byggð arkitektúrmeð að minnsta kosti einum skýringarmynd.

2. Stækkaað Skýringarmyndirútibú (og allir sem krafist Skýringarmynd hópar) af tilteknum Arkitektúrhluti af trénu.

3. Veldu skýringarmynd sem þú vilt afrita og síðan er stutt á Ctrl + Ceða hægrismellaog veldu Afrita úr valmyndinni.

Note

A afrit af myndinni ekki bætt við Skýringarmyndirútibú í Sama arkitektúr. Það mun hafa "Afrit af" bætt við upphaf nafni, Sem þú getur breytt síðar ýta F2 eða hægrismella á þaðog velja Rename.

Til afrita skýringarmynd yfir arkitektúr

1. Tryggja þú hafa óákveðinn greinir í enskuABACUS skrá er opininniheldur þínum byggð arkitektúrsmeð að minnsta kosti einum skýringarmynd.

2. Stækkaað Skýringarmyndirútibú (og allir sem krafist Skýringarmynd hópar) af að Arkitektúrhluti af trénufyrir arkitektúr sem inniheldur skýringarmynd sem þú vilt afrita.

3. Veldu skýringarmynd þú vilt afrita og á Almennir eiginleikarglugga athugið að Sjónarmið að skýringarmynd tengist (í reitnum Gerð).

4. Nú, aukaað Skýringarmyndirútibú (og allir sem krafist Skýringarmynd hópar) af að Arkitektúrhluti af trénufyrir hinn arkitektúr sem þú vilt afrita skýringarmynd í.

5. Hægrismellaað Skýringarmyndir hnút (eða Skýringarmynd hópur) Og veldu Búa Skýringarmynd .... Í glugganum sem birtist velja Sjónarmið sem kom fram í skrefi 3 hér að framan í fellilistanum efst til hægri. Láta allt annað sem er og smella OK. Á myndinni Nafn valmynd slá inn heiti fyrir (bráðum að vera) afrita myndinni. Ath: A auður skýringarmynd striga í samræmi við valið sjónarhorni verður opnuð.

6. Fara aftur á myndinni sem þú vilt afrita og opna það með því að hægrismellahnúturinn og val Open eða einfaldlega tvísmelltþað.

7. Veldu bakgrunn striga af myndinni sem þú vilt afrita og stutt á Ctrl + A. Þetta mun velja alla þætti á þessi skýringarmynd. Nú ýta Ctrl + Cað afrita efni til klemmuspjald.

8. Nú, aftur á auðu skýringarmynd í arkitektúr þú vilt afrita efni í, velja bakgrunnstriga og annaðhvort hægrismellaog veldu Líma eða einfaldlega ýta Ctrl + Vað líma efni. Eftir stuttan tíma efni verður allt límt inn nýja auða myndinni.

Note

Elements verður bætt við efstu á nýju arkitektúr og verður að vera með tilvísun til-raða eða sameinuð við núverandi efni í samræmi við.

Sjá einnig

The Teikning Tól | Populating vélina þína | Greining arkitektúr þinn


Búa til nýja hluti / tegund tengingar eða Type Group

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Búa til nýja hluti / tegund tengingar eða Type Group

Senda athugasemdir um þetta efni.

Hluti og tengingu tegundir eru aðallega notaðar fyrir flokkun. Þú getur notað gerðir sem síur þegar skoðuð vélina þína. Til dæmis, í stað þess að skoða allt hlutur, getur þú skoðað bara hluti Umsókn.

Til að búa til nýja hluti / tegund tengingar

Note

Til að bæta tegundir eða tegund hópa í Abacus verkefni notandinn leyfi þarf hönnuður bæta við-á hæfileiki. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

1. Stækkaðu Tegundirútibú tré.

2. Hægrismellaá Component ferðalaga(eða Tengingu ferðalaga).

3. Veldu Bæta íhluta(eða Bæta gerð tengingar) Eða Búa til hóp.

Ábending

Þegar þú hefur búið til ferðar, þá ættir þú að breyta táknmynd þess (sjá hér að neðan) og bæta eiginleikar og staðlar til þess, að íhluturinn eða tengingu tilvikum að 'Inherit'.

Til að breyta tákni fyrir íhluta / tegund tengingar

Note

Til að breyta táknum fyrir tegundir í Abacus verkefni notandinn leyfi þarf hönnuður bæta við-á hæfileiki. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

1. Hægrismella á Component Type(eða Gerð tengingar) Þú vilt breyta táknið fyrir.

2. Veldu Breyta Icon.

3. Í velja táknmyndir valmynd fletta að stað og velja mynd skrá og smellt á Open.

Note

Hægt er að hafa Custom Icon mynd af hvaða stærð en það mun alltaf verða minnkaðar til að passa við 16x16 pixla mynd í Explorer glugga. Svo ef upprunalega Custom Icon myndin er ekki jafn hæð og breidd þinn Explorer glugga icon verður strekkt. Samkvæmt því, sérsniðna myndir ættu að vera að minnsta kosti 16x16 pixlar og ef þú vilt halda nákvæma lögun Custom Icon tryggja Custom Icon mynd er jafn hæð og breidd í dílum (16x16 eða meira). Þú ættir einnig að vera varkár um að hafa ekki litað 'díla' fara alla leið til landamæra Custom Icon mynd eins og það mun líta léleg í Explorer glugga með aðliggjandi táknum 'blæðingum' inn í hvert annað. Samkvæmt því, ættir þú að fara að minnsta kosti 1 pixla hvítt landamæri.

Ábending

Þú getur gert Custom Icon myndin er ICO, BMP, .gif, .jpg eða .png formi skrá en vegna takmörkunar á Windows aðeins ICO snið mun forsýning í ABACUS velja táknmyndir glugga ef þú hefur View matseðill valkostur stillt á neitt annað en Smámyndir.

Sjá einnig

Populating vélina þína - Yfirlit | Greining arkitektúr þinn


Búa til eða endurtekning arkitektúr

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Búa til eða endurtekning arkitektúr

Senda athugasemdir um þetta efni.

Þú getur haft hvaða fjölda arkitektúr í einni Abacus skrá. Venjulega, þú vilt búa til nýjan architecture hvert skipti sem þú vilt að fyrirmynd og meta þróun kerfisins.

Til að búa til nýjan arkitektúr

1. Hægrismella á Arkitektúrútibú tré.

2. Veldu New Architecture.

Til að búa til afrit af núverandi arkitektúr

1. Hægrismellaá arkitektúr.

2. Veldu Afrita.

3. Hægrismella á Arkitektúrútibú tré.

4. Veldu Líma.

5. Hin nýja arkitektúr verður kallað "Afrit af ...".

Að þróast núverandi arkitektúr

1. Hægrismellaá arkitektúr.

2. Veldu Þróast.

3. Hin nýja arkitektúr verður kallað "... 0,1".

Note

Það er nákvæm lýsing á vaxandi arkitektúr hér .

Sjá einnig

Hvernig er arkitektúr fulltrúa í Abacus | Þróun vélina þína


Sérsniðnar skýrslur

Navigation: Skýrslur um arkitektúr þinn>

Sérsniðnar skýrslur

Senda athugasemdir um þetta efni.

Abacus 'sérsniðnar skýrslur leyfa þér að búa til alveg stillanlegt sérsniðnar skýrslur. Skýrslurnar geta verið sérsniðin myndmál og grafík auk útlista hvaða þættir, tengingar eða eiginleika frá Abacus geymsla sem og nánari upplýsingar greinandi niðurstöður úr mismunandi uppgerð (þ.mt TCO, frammistöðu og áreiðanleika). Auk, skýrslur geta innihaldið skýringarmyndir, töflur, bæklingum, fylkjum / pivot töflur, kort, gauges, sparklines, gögn barir og vísa (td umferð-ljós).

Note

Þó allir notandi geta opnað núverandi sérsniðnar skýrslur, teða stilla skýrslur notandinn leyfi þarf í Skýrsla Configuration hæfileiki. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

Til að skoða sérsniðin Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr(s).

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi verður birt.

Sérsniðnar skýrslurgluggi

3. Veldunúverandi Skýrslasem þú vilt til að sýna frá Laus Skýrslurkafla.

4. Smelltu Run Report.Skýrslan mun opna í Microsoft Report Viewer og to Finnið skýrslu síður, smellur á the helgimynd [image] staðsett á stikunni á efst í vinstra horninu á skjánum.

Note

Þú getur vista í skýrslunni að ýmsum sniðum með því að smella á Export Skýrslan icon [image] staðsett í stikunni. Þú getur valið að flytja í eftirfarandi snið: Excel, PDFog Bæta. Vistaðu skýrslu í viðkomandi stað til síðari nota. Ef breytingar eru gerðar á arkitektúr síðar, í nýrri skýrslu verður að vera búin að endurspegla breytingarnar.

Til breyta geymsla gagna sem eru send til a sérsniðin Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr(s).

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi (sýnd fyrir ofan) verður birt.

Note

Þó allir notandi geta opnað núverandi sérsniðnar skýrslur, teða stilla gögn sem eru send til sérsniðna skýrslu notandinn leyfi þarf í Skýrsla Configuration hæfileiki. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

3. Veldunúverandi Skýrslasem þú vilt til að sýna frá Laus Skýrslurkafla.

4. Smelltu Breytt gögnum Leikmynd. The Gögn Set Editorgluggi verður birt.Þessi gluggi sýnir safn af gagnagrunnum sem nú eru send til sérsniðna skýrslu. Í dæminu hér að neðan eru þrjú (3);

· An ApplicationProxy gögnum sem tilgreina allar upplýsingar fyrir alla umsókn hluti í '2015 Raunverulegur' arkitektúr (þ.mt eignir á merkjum sínum og hvers konar fylgir hluti),

· a TwoDViewProxy gögnum sem tilgreina einn eða fleiri skýringarmyndir þar sem nafn passar "Umsókn Landscape (Australia) ',

· a TargetProxy gögnum sem tilgreina allar upplýsingar fyrir alla miða tengingar í "2015 Raunverulegur 'arkitektúr (þ.mt meðfylgjandi hluti).

Gögn Set Editorgluggi

Note

The Fyrirspurn Name verður notað fyrir gagnapakka nafni í Microsoft Report Builder (sjá hér að neðan). The Hafa svið skilgreinir hvort gagnapakka er annaðhvort Single Element, safn af þætti, allt Component ferðalaga, All Connection Tegundir, einn eða fleiri arkitektúr, einn eða fleiri teikningar eða einn eða fleiri töflur. Fyrir 'Safn Elements gagnagrunna síunarregla hnappur er veitt sem þegar smellt opnar Element Sía glugga sem leyfir þér að sækja margar síur til að skila aðeins þætti úr tilteknum arkitektúr og / eða tiltekinna tegunda og / eða með tiltekna og / eða fylgir ákveðnum þáttum, og / eða með ákveðnum foreldra, og / eða í ákveðnum skýringarmynd, og / eða í tilteknum myndum og / eða með gefið eign gildi. Fyrir aðrar tegundir gagna stilla nafn reitur er veitt og með Veldu hnappinn sem þú getur valið hlut (s) til að fylgja með gögnum.

Note

Sem í gagnasettinu eru geymdar íGögn Leikmynd skrá (.XML)með sama grunn skrá nafn sem Antengd Skýrsla Definition skrá (.RDL). Ef þessi skrá er ekki til að gögnum ritstjóri sjálfkrafa byggja með hvaða fyrirspurn nöfn sem eru fyrir hendi í Skýrsla Definition skrá (.RDL)og ný Gögn Leikmynd skrá (.XML)verður búin þegar AA gildur listi af fyrirspurnum er skilgreint.

3. Ef þú vilt eyða núverandi gögn sett þá velja Eyða Fyrirspurnhnappinn.

4. Ef þú vilt bæta við nýjum gögnum sett smelltu þá Bæta við nýjum gögnum Setjahnappinn og stilla gögn sem sett eru samkvæmt skýringu hér að ofan.

Til búa til nýja sérsniðna Skýrsla(með sniðmáti)

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr.

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi (sýnd fyrir ofan) verður birt.

3. Smelltu New og veldu annaðhvort A4 - Portrait, A4- Landscape, A3 - Portrait, A3- Landscape, US Letter - Portrait, US Letter - Landscape, US Tabloid - Portraiteða US Tabloid - Landscapeeftir skýrslu stefnumörkun og pappír stærð sem óskað er.

4. Beit til the staðsetning til að vista Report Definition skrá (.rdl / .rdlc) og passa Data Set skrá (xml) og smelltu Vista. Þetta mun bæta við nýjum sérsniðna skýrslu Laus Skýrslur hluta Custom Skýrslur glugga og það getur opnað eða breytt eins og lýst er hér að ofan.

Til bæta núverandi siðvenju Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr.

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi (sýnd fyrir ofan) verður birt.

3. Smelltu Bæta og beit til the staðsetning af the Report Definition skrá (.rdl / .rdlc) og smelltu Open. Þetta mun bæta við nýjum sérsniðna skýrslu Laus Skýrslur hluta Custom Skýrslur glugga og það getur opnað eða breytt eins og lýst er hér að ofan.

Note

Gert er ráð fyrir að samsvarandi gögn Set skrá (.xml) er í sama stað sem Report Definition skrá.

Til að afrita sérsniðna Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr.

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi (sýnd fyrir ofan) verður birt.

3. Veldunúverandi Skýrslasem þú vilt að afrita frá Laus Skýrslurkafla.

4. Smelltu Afrita og afrit af völdu skýrslu (sem heitir 'Afrit af ... ") verður bætt við fyrirliggjandi skýrslur hluta Custom Skýrslur glugga og það getur opnað eða breytt eins og lýst er hér að ofan.

Note

Með því að gera þetta þú verður að búa til afrit af skýrslunni er Skýrsla Definition skrá (.rdl / .rdlc) sem og þess passa Data Set skrá (.xml)(ef það er til staðar).

Til fjarlægja núverandi siðvenju Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr.

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi (sýnd fyrir ofan) verður birt.

3. Veldunúverandi Skýrslasem þú vilt að fjarlægja frá Laus Skýrslurkafla og smellur Fjarlægja.

Note

Þegar þú fjarlægir skýrslu verður ekki lengur birtast á skýrslunni listanum. Hins vegar mun þetta ekki eyða Skýrsla Definition skýrslunnar skrá (.rdl / .rdlc) eða Gögn Set skrá(.xml). Ef þörf er á, að eyða þessum skrám er hægt að ná í gegnum the skrá kerfi.

Til endurnefnt siðvenja Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr.

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi (sýnd fyrir ofan) verður birt.

3. Veldunúverandi Skýrslasem þú vilt að endurnefna í að Laus Skýrslurkafla og smellur Endurnefna.

4. Sláðu inn nýtt heiti fyrir skýrsluna.

Note

Bæði Report Definition skrá (.rdl / .rdlc) og passa Data Set skrá (.xml) verður gefið annað heiti.

Til breyta hönnun a sérsniðin Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr.

2. Veldu Insert| Custom Reporteða smelltu á Búa sérsniðna skýrslu tækjastikuhnappur. The Sérsniðnar skýrslurgluggi (sýnd fyrir ofan) verður birt.

Note

Þó allir notandi geta opnað núverandi sérsniðnar skýrslur, teða stilla hönnun á sérsniðnar skýrslur notandinn leyfi þarf í Skýrsla Configuration hæfileiki. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.Auk þess Microsoft Report Builder 3.0 er nauðsynlegt að hanna skýrslur og það er hægt að sækja ókeypis frá hér .

3. Veldunúverandi Skýrslasem þú vilt til að sýna frá Laus Skýrslurkafla.

4. Smelltu Breyta Report.Skýrslan mun opna í Microsoft Report Builder 3.0. Fyrir sérstaka aðstoð og sumir "ábendingar og bragðarefur 'á sumir af the fleiri sameiginlegur verkefni með hanna skýrslur vinsamlegast vísa til hér að aftan. Fyrir almenna aðstoð við hönnun skýrslur vinsamlegast vísa til Microsoft Report Builder 3.0 hjálparsíður hér .

Bæti Töflur til skýrslunni

1. Tryggja þú hafa An ABACUS Custom Report Definition skrá (.rdl / .rdlc) opið í Microsoft Report Builder 3.0.

2. Velduað Insert flipann í "borði" efst, þá smelltu á Tafla hnappurí gögnum Svæði kafla og velja Insert Table.

3. Nú dragðu bendilinntil stöðu á skýrslu striga þar sem þú vilt efst í vinstra horninu á borðinu til sett. Smelltu á striga. Sjálfgefið borðið verður bætt með hausnum og síðar details hóp (hópur er notað til að skipuleggja sýn á CCD skýrslu). Til að fjarlægja hópinn, annað hvort eyða röð eða eyða Row Group í Flokkun tækjastikunni.

Ábendings

Formúlur / orðasambönd í töflunnar eru ritstýrður með því að velja klefi þá hægri-smella á << Expr >> texta og velja Expression .... Flokkun raðir í töflunni er gert með því að velja borð og þá beit niður til annarra -> SortExpressions sviði í Properties spjaldið og eru þá teknir tjáningu. Samtals röð í lok borð bæta umferð eftir (og utan) á flokkun og þá nota eftirfarandi segð = Sum (Fields!Name.Value)þar sem "Name" er svæðið sem nam. Til að sækja um litarefni til dálka nota 'llf' yfirlýsingu í BackgroundColor hótelinu. Til að bæta við mál sem klefi í töflu fyrst setja mál í klefa og þá falla gögn sviðum sem þarf til að mál. Þegar breyta á hæð & breidd af töflunni raðir, að tryggja að þú velur rétta röð, og þá músarbendilinn um gráa línur þar til þú færð ör upp / niður bendilinn, þá búa.

Bæti Charts að skýrslunni

1. Tryggja þú hafa An ABACUS Custom Report Definition skrá (.rdl / .rdlc) opið í Microsoft Report Builder 3.0.

2. Velduað Insert flipann í "borði" efst, þá smelltu á Mynd hnappurí gögnum Svæði kafla og velja Setja inn mynd.

3. Nú dragðu bendilinntil stöðu á skýrslu striga þar sem þú vilt efst í vinstra horninu á myndinni til sett. Smelltu á striga og svo velja töflunaþú þarft einhvern af valkostunum og smelltu OK.

Ábendings

Til að birta eign sem umsögnina á töflur, hægri smelltu á töfluna og veldu Show gögn Merki, þá velja einn af the merki sem hefur verið bætt og sett Ýmislegt -> UseValueAsLabel til False í Properties spjaldið og bæta tjáningu (td = Fields Name.Value) í Misc -> Label. Sérstaklega fyrir kúla töflur; Kúla töflur eru birtar undir punktarit fyrirsögninni. Falla X ás eign í Series sviðum (eða bæta við í röð Properties). Falla Y ás eign í gögnum sviðum (eða bæta við í röð Properties). Til að nota eign til að skilgreina stærð kúla, falla þetta í Data sviðum (eða bæta við í röð Properties). Kúla töflur eru ekki að sýna ef það er of mikið af gögnum (200+ hlutir), stundum veldur þetta allt skýrslu ekki birta. Marker Type - Set til hring. Sjálfgefið er að sleppa sviðum í gögn sviðum, bætir það þá með SUM ()uppskrift, svo fjarlægja þetta. Sérstaklega fyrir Staflað töflur / Tímalína / Gantt töflur; Fyrir Gantt kortsins nota svið töfluna og bæta eiginleika eins hátt og lágt gildi í gögn sviðum. Hægt er að hafa marga "bars" með því að bæta fleiri og fleiri svið, þar sem lágt gildi fyrir einn passar mikið gildi fyrir aðra. Sérstaklega fyrir Kökurit; Fyrir samanlagt baka töflur, falla gögn í flokk sviðum og í gögnum sviðum, bæta formúluna = CountRows (). Sía út einhverjar 0 gildi (td á kostnað töflur), annars merki fyrir þessum mun enn birtast á myndinni.

Notkun IIF yfirlýsingu að bæta litum við borðum og töflur

1. Tryggja þú hafa An ABACUS Custom Report Definition skrá (.rdl / .rdlc) opið í Microsoft Report Builder 3.0.

2. Hægri-smelltu á reitinn í töflunni að lit og smelltu Texti Box Properties.

3. Veldu Fylltu og smelltu á FXhnappinn hægra megin við fylla lit merki og í Setja tjáningu fyrir BackgroundColor sviði inn tjáningu, td = IIF (Fields! InformationStatus.Value = "Halda", "Ljósgrænncolor", IIF (Fields! InformationStatus.Value = "Endurhönnun", "Yellow", IIF (Fields! InformationStatus.Value = "Refresh", "Orange", " Salmon "))). Þetta breytir bakgrunnslit til ljósgrænt fyrir hverja einingu sem inniheldur stöðu 'halda', gult fyrir hverja einingu sem inniheldur réttarstöðu "endurhanna", Orange fyrir hverja einingu sem inniheldur stöðu 'Refresh' og annarra aðstæðna gildi verður lituð í 'salmon'.

Note

Colours má bæta fyrir töflur með því að velja röð á töfluna og þá setja útlit -> Color eign (eða kúla töflur útliti -> Marker -> Color eign) til tjáningar svipað dæminu hér að ofan.

Things að hafa í huga þegar þú hannar sérsniðnar skýrslur

· Vegna þess að öll eignir nema Integer eru send sem streng frá Abacus í skýrslu áhorfandi ef þú vilt gera allir 'orðasambönd' með þeim (eins og skipta einu eign með öðru eða tegund) sem þú þarft að breyta þeim í fjölda eða Dagsetning o.fl. Til bakgrunni , Þessi grein er góð viðmiðun. T.d. = CDate (Fields! LifecycleEndDate.Value) Ath: Vinsamlegast tryggja að skýrslan tungumál er stillt á en-GB (eins og lýst er hér að neðan) til að taka dd / mm / áááá eins og það gerir ráð mm / dd / YYYY sniði sjálfgefið og í samræmi 31/7/2011 mun mistakast viðskipti. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Ef þú sérð að þú ert í erfiðleikum með að halda öllum töflum og myndum á einni síðu, Það eru nokkrar helstu leiðir við stjórnun skjal rúm:

· Page Break - að tryggja að þetta borð stilling er á fyrir hverja töflu sem þú vilt vera á sömu síðu.

· Halda Together - Tryggja þetta borð stilling er True fyrir hverja töflu sem þú vilt vera á sömu síðu.

· Þegar flytja hlutina í kring, það er auðveldara að þysja út með stjórn á the botn réttur af the blaðsíða og þá multi velja atriði og draga

· Fyrir myndina röð í töflunni, ganga úr skugga um að 'stærð' | Property 'límvatn' sett 'passa' annan myndinni birst of stór, eða það verður illa strekkt.

· Til endurtaka hausnum borð á hverri síðuskýrslunnar:

1. Open Advanced Mode í hópa glugganum. (Smelltu á örina til hægri dálkinum Hópar og veldu Advanced Mode.)

2. Í Row Hópar svæði (ekki Dálkur hópa), smella á Static hóp, sem varpar ljósi á samsvarandi kennslubók í tablix. Smelltu í gegnum hvert Static ráðstefnu fyrr en hún er lögð áhersla á dálknum lengst til vinstri haus. Þetta er yfirleitt fyrsta Static hópur talinn.

3. Í Properties glugganum, setja RepeatOnNewPage eign til True.

4. Gakktu úr skugga um að KeepWithGroup eign er stillt á eftir.

· Breyta Stillingar tungumálsÍ skýrslu eignir til að passa gögn snið sem þú þarfnast, td en-GB til að framleiða UK Dagsetningarsniðið (dd / mm / áááá).

Sjá einnig

Greina vélina þína


Aðlagaðu abacus tengi

Navigation: Inngangur að Abacus>

Aðlagaðu abacus tengi

Senda athugasemdir um þetta efni.

Þú getur breytt útliti og hegðun Abacus tengi á margan hátt. ABACUS nær nokkrum fyrirfram ákveðnum stillingum samsetningar sem þú getur notað til að beita hóp customisations að tengi. Að auki er hægt að gera einstaka customisations fyrir atriði, svo sem gluggum, tækjastika, lykla flýtilykla og ýmsir sýna valkosti.

Raða og Dock Windows

Þú hefur marga möguleika til að skipuleggja glugga innan tengi fyrir abacus, þar á meðal eftirfarandi:

· Tab-bryggju gluggum.

· Dock gluggar að brún ramma í tengi.

· Smækka tól glugga meðfram brún tengi.

· Endurstilla glugga vistun í sjálfgefna skipulag.

Skipakví Windows

Þegar gluggi er dockable, það er hægt að fest til hliðar við ramma innan tengi eða það er hægt að raða á grábröndóttur köttur gluggarúða innan ramma. A leiðarvísir demantur birtist þegar þú draga glugga frá núverandi staðsetningu þeirra á annan stað í tengi. Bókin demantur leyfa þú til fljótt aftur að bryggju glugga á einn af fjórum hliðum ramma eða í miðju sem flipanum megin. Þegar gluggi er Sítt eða ekki dockable, flýtur það ofan á öðrum gluggum.

Að bryggju glugga

1. Smelltu á gluggann sem þú vilt að bryggju, að gefa það áherslu.

2. Á Windowvalmyndinni skaltu smella Dockable.

3. Draga glugga frá núverandi staðsetningu hennar í átt að miðju rammans sem þú vilt að bryggju það með.

A leiðarvísir demantur birtist. Fjögur örvar demantur benda til fjórum brúnum ramma og miðju táknar flipanum glugganum.

Ábending

Til að færa dockable glugga án glefsinn henni á sinn stað, ýttu á Ctrl meðan þú dregur hana.

4. Þegar gluggi sem þú ert að draga nær þeirri stöðu þar sem þú vilt að bryggju það skaltu færa bendilinn yfir samsvarandi hluta fylgja demantur. Yfirlit af the gluggi birtist á afmörkuðu svæði.

5. Að bryggju glugga í stöðu til kynna, gefa út the mús hnappur.

Til dæmis, ef Explorerer hafnarverkamaður á vinstri brún af the tengi og þú vilt að bryggju það á hægri brún, myndir þú draga Explorerí átt að miðju tengi skaltu færa bendilinn yfir hægra megin á handbók demantur, og þá gefa út the mús hnappur.

Að lágmarka Windows

Windows (hvort sem þeir eru Tool Windows - birtist á Viewmenu, eða Document Windows - birtist á Windowmenu) styðja lögun gestur Auto Fela. Auto Fela gerir þér kleift að sjá meira af vélina þína í einu með því að lágmarka glugga meðfram jöðrum tengi þegar ekki í notkun.

Til að kveikja á sjálfvirkri Hide

1. Smelltu á gluggann sem þú vilt að fela að gefa það áherslu.

2. Á Windowvalmyndinni skaltu smella Auto Fela.

- Eða -

2. Smelltu á pushpin táknið á titilslá glugga.

Auto Fela virkt

Þegar sjálfvirkt falinn glugga missir fókus renna sjálfkrafa aftur til tab á brún af the tengi. En gluggi er sjálfvirk falin, nafn og icon eru sýnilegar á flipa á brún af the tengi. Til að birta sjálfvirkt falin glugga, færa bendilinn yfir flipanum. Glugginn renna aftur inn í að skoða og er tilbúinn til notkunar.

Note

A gluggi sem er sjálfvirkt falinn er ekki hægt að bryggju. Að bryggju á gluggann sem þú þarft að slökkva Auto Fela eins og lýst er hér að neðan.

Til að slökkva á sjálfvirkri Fela

1. Smelltu á gluggann sem þú vilt halda sýnilegt að gefa það áherslu.

2. Á Windowvalmyndinni skaltu smella Auto Felaað hreinsa merkið.

- Eða -

2. Smelltu á pushpin táknið á titilslá glugga.

Auto Fela Disabled

Ábending

Windows sem hafa Auto Fela virkt tímabundið renna inn í að skoða þegar gluggi er fókus. Að fela gluggann aftur, velja atriði utan glugga. Þegar gluggi missir fókus renna henni aftur út úr augum.

Að endurstilla Windows Layouts

Þú getur skilað tengi við sjálfgefna glugga skipulag nota Endurstilla Window Layoutstjórn. Þegar þú keyrir þessa skipun, eftirfarandi aðgerðir eiga sér stað:

· Allir gluggar eru flutt í sjálfgefin stöðu þeirra.

· Windows sem eru lokaðir í sjálfgefna glugga skipulag lokað eftir skipun.

· Windows sem eru opin í sjálfgefna glugga skipulag eru opnaðar með stjórn.

· Windows sem eru falin / sýnileg í sjálfgefna glugga skipulag eru gerðar falinn / sýnileg og stjórn.

Til að endurstilla glugga vistun í sjálfgefna skipulag

1. Á Windowsvalmyndinni skaltu smella Endurstilla Window Layout.

Aðlagaðu Matseðlar og Toolbars

Þú getur breytt skipulag, stöðu og efni valmyndir og tækjastika í tengi. Þú getur einnig bætt við hnappa til að tækjastika og breyta því táknið fyrir hvaða hnappur.

Búa til nýjar tækjastika

Til að búa til nýja tækjastika

1. Á Verkfærimatseðill, velja Sérsníða.

2. Í Sérsníðavalmynd, velja Toolbarsflipann.

3. Veldu New.

4. Í New Toolbarvalmynd, slá inn heiti fyrir tækjastikunni.

5. Veldu OK.

Til að bæta stjórn á hnappinn til að fá valmynd eða tólastiku

1. Á Verkfærimatseðill, velja Sérsníða.

2. Í Sérsníðavalmynd, velja Skipanirflipann.

3. Veldu flokk og draga skipun úr valmynd í valmynd eða tólastiku.

4. Veldu Loka.

Ábending

Halda niðri Alt-takkann gerir þér kleift að fljótur-aðlaga skipanir sem þó Customize valmynd var opið.

Sjá einnig

Abacus tengi


Skilgreina og staðfesta þvingun

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Skilgreina og staðfesta þvingun

Senda athugasemdir um þetta efni.

Uppbygging og eiginleikar af arkitektúr er hægt að takmarka með því að nota þvingun. Þvingun er hægt að beita til að hluti gerðum og gerðum tengingu til að takmarka uppbyggingu arkitektúr á tvo vegu. Fyrsta leiðin er að takmarka stigveldimeð því að skilgreina "foreldri ætti / að hafa barn" og "barn ætti / að hafa foreldri" sambönd. Hin leiðin er að takmarka grannfræðimeð því að skilgreina "hluti ætti / að vera fest við tengingu" og "tengingu ætti / að vera fest við hluti" sambönd. Ennfremur, þvingun er hægt að beita til eiginleika íhlutanna gerðum, tegunda tenginga, sniðmát, sjónarmið, arkitektúr, skýringarmyndirog 3D lítur að takmarka arkitektúr (s) í tveimur öðrum hætti. Fyrsta leiðin er að setja á gögn tegundeignarinnar að takmarka gild gildi sem það getur haft, þ.e.; Text, Integer, Decimal, Date / Time, Boolean eða List. Hin leiðin er að setja á krafistStaða á eignum til að gefa til kynna hvort gildi þarf að færa fyrir eign (Athugið: Nauðsynlegar þvingun aðeins um eignir fyrir hluti og tengingu gerðum). Nánari upplýsingar um eign þvingun er veitt í Breyta eiginleikum íhluta, tengingu eða tegund hjálp umræðuefni. Þegar þvingun hefur verið skilgreind, það er hægt að sannreyna arkitektúr gegn þvingun. ABACUS mun vara um hvaða takmarkanir sem hafa verið brotið.

Lykillinn að því að ákvarða hvaða þvingun (s) til að skilgreina lygi í nákvæmlega tungumál er notað til að lýsa því aðhaldi. Fyrir stigveldi þvingun þeir eru yfirleitt á formi "Nafnorðgetur / ættir / verður niðurbrot í n Nafnorð"Eða"Nafnorðgetur / ættir / verður safnað saman með Nafnorð"O.fl. Til dæmis,"Lagðarverður að niðurbrot í Teams"Eða"Umsóknirhægt að niðurbrot í Einingar". Fyrir grannfræði þvingun þeir eru yfirleitt á formi"Nafnorðgetur / ættir / verður sögn Nafnorð". Til dæmis, "Processes getur verið flutt af Teams"Eða"Umsóknireru hýst á Servers. "Nú, þú getur séð í hvert þvingun eru ýmsar getur / ættu / verður 'undankeppni' og þær geta verið af 3 gerðum;

· Valfrjálst- Þetta mun nota venjulega orð / setningar eins og; "mega", "getur", "gæti", "mögulega" osfrv

· Mælt- Þetta mun nota venjulega orð / setningar eins og; "ætti", "mælt", "ráðlagt" osfrv

· Nauðsynlegur- Þetta mun nota venjulega orð / setningar eins og; "verður", "er", "eru", "hefur", "skulu" osfrv

Það fer eftir tegund af þvingun (stigveldi eða grannfræði) og undankeppni notuð er til að lýsa því, sérstaklega þvingun (s) ætti að vera skilgreint (sjá hér að neðan). Fyrir ofan stigveldi dæmi um "Lagðarverður að niðurbrot í Teams"Maður á að skilgreina" Parent að hafa barn "þvingun og setja framkvæmd skal fara fram. Fyrir ofan grannfræði dæmi um"Processes getur verið flutt af Teams. "Ætti aðeins að búa tvö (2)" Connection verður að fylgja Component "þvingun til hvorum enda flutt af tegund tengingar Nánar tiltekið eru eftirfarandi þvingun mælt að skilgreina (sjá að neðan) á mismunandi valkosti;

· Stigveldi þvingun;

o Nafnorð A getur veriðniðurbrot í Nafnorð B, Eða Nafnorð B getur veriðlagðar saman af Nafnorð Aeða Nafnorð B ætti að veralagðar saman af Nafnorð A- Veldu "Child verður að hafa foreldri" þvingun með barnið gerðar og Noun B, foreldri gerð og Noun A og framkvæmd sem varað.

Note

Þetta þýðir að ef barn er til, það ætti að hafa foreldri af ákveðinni tegund. Ef ekki, verður þú að fá viðvörun.

o Nafnorð A ætti að veraniðurbrot í Nafnorð B- Veldu "Parent verður að hafa barn" þvingun með foreldri gerð og Noun A, barn tegundar og Noun B og framkvæmd sem varað.

Note

Þetta þýðir að ef foreldri er til, það ætti að hafa börn af ákveðinni tegund. Ef ekki, verður þú að fá viðvörun.

o Nafnorð A hlýtur að veraniðurbrot í Nafnorð B- Skilgreina a "Parent að hafa barn" þvingun með foreldri gerð og Noun A, barn tegundar og Noun B og framkvæmd sem framfylgt.

Note

Þetta þýðir að ef foreldri er til, það verður að hafa börn af ákveðinni tegund. Ef þú vilja fá villu.

o Nafnorð A hlýtur að veralagðar saman af Nafnorð B- Veldu "Child verður að hafa foreldri" þvingun með barnið gerðar og Noun A, foreldri gerð og Noun B og framkvæmd sem framfylgt.

Note

Þetta þýðir að ef barn er til, það verður að hafa foreldri af ákveðinni tegund. Ef ekki, verður þú að fá villu.

· Grannfræði þvingun;

o Nafnorð A getur verið sögn Nafnorð B- Skilgreina tvö (2) "Connection verður að fylgja til Component" þvingun. Fyrsta vera með Source lok tegund tengingar sögnfylgir nafnorð A íhluta og fullnustu sett til framfylgt. Annað sem við vaskinn lok tegund tengingar sögnfest Noun B íhluta og fullnustu stillt á framfylgt.

Note

Þetta þýðir að ef tengingin er til, það verður að tengja hluti af ákveðnum tegundum. Ef þú vilja fá villu. Heild tryggir þetta að þessir þættir geta enn til staðar og ekki hægt að tengja við hvert annað. Hins vegar ef þeir eru tengdir, tengingar á rétta tegund verður að nota.

o Nafnorð A ætti að vera sögn Nafnorð B- Skilgreina tvö (2) "Component skal fylgja Connection" þvingun. Fyrst að vera með Noun A íhluta fest við uppspretta lok sögntegund tengingu og fullnustu sett til Athugið. Annað sem við Noun B íhluta fest í vaskinn enda er sögntegund tengingu og fullnustu sett til Athugið. Auk þess að skilgreina tvö (2) "Connection verður að fylgja til Component" þvingun. Fyrsta vera með Source lok tegund tengingar sögnfylgir nafnorð A íhluta og fullnustu sett til framfylgt. Annað sem við vaskinn lok tegund tengingar sögnfest Noun B íhluta og fullnustu stillt á framfylgt.

Note

Þetta þýðir að ef hluti af hvorri tegund til, þeir ættu að vera fest við tengingu af ákveðinni gerð. Ef þú vilja fá viðvörun. Að auki, þetta þýðir að ef tengingin er til staðar, það verður að vera tengdur hluti af tiltekinni gerð. Ef þú vilja fá villu. Heild þetta tryggir að ef hluti af þessum tegundum til, þú munt fá viðvaranir ef þeir eru ekki tengd við hvert annað.

o Nafnorð A hlýtur að vera sögn Nafnorð B- Skilgreina tvö (2) "Component skal fylgja Connection" þvingun. Fyrst að vera með Noun A íhluta fest við uppspretta lok sögntegund tengingu og fullnustu stillt á framfylgt. Annað sem við Noun B íhluta fest í vaskinn enda er sögntegund tengingu og fullnustu stillt á framfylgt. Auk þess að skilgreina tvö (2) "Connection verður að fylgja til Component" þvingun. Fyrsta vera með Source lok tegund tengingar sögnfylgir nafnorð A íhluta og fullnustu sett til framfylgt. Annað sem við vaskinn lok tegund tengingar sögnfest Noun B íhluta og fullnustu stillt á framfylgt.

Note

Þetta þýðir að ef hluti af hvorri tegund til, þeir verða að vera tengdur við tengingu af ákveðinni gerð. Ef þú vilja fá villu. Að auki, þetta þýðir að ef tengingin er til staðar, það verður að vera tengdur hluti af tiltekinni gerð. Ef þú vilja fá villu. Heild þetta tryggir að ef hluti af þessum tegundum til, þú munt fá villur ef þeir eru ekki tengd við hvert annað.

Að skilgreina þvingun

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopna og Explorer gluggabirtist.

2. Í landkönnuður tré auka Tegundir | Component ferðalagaeða auka Tegundir | Tengingu ferðalaga.

3. Hægrismellaa íhluta eða gerð tengingar og veldu Bæta þvingun.

Bæti þvingun

Til að skilgreina stigveldi þvingun, þar sem foreldri þarf að hafa ákveðna barn

4. Á Bæta þvingunglugga merkið á Búa þvingungátreitinn undir Parent Verður að hafa börn þvingunsvæði.

5. Veldu íhlutafrá fellilistanum sem þú vilt að tilgreina eftir því sem barnið á íhluta valinn í skrefi 3.

Note

Ef það er nú þegar virkt 'Parent Verður Hafa Child' þvingun skilgreint fyrir foreldra íhluta og annað barn íhluta þá er þetta nýja þvingun verður að meðhöndla sem 'og'. Það er tegund verður að vera foreldri barn gerð A ogbarn tegund B, að hvað sem framkvæmd stigi (td fatlaða, Athugið eða framfylgt - sjá skref 7) er tilgreind fyrir hverja þvingun.

6. Valfrjáls getur þú skilgreint lágmarks og hámarks fjölda þátta íhluta er tilgreint að verður að vera börn íhluta hægri-smellt er í skrefi 3.

7. Veldu hvort þú vilt að þvingun til að vera Disabled, Aðvöruneða Framfylgt.

Note

Fatlaðir þvingun verður hunsað frá þvingun fullgildingu, varaði þvingun mun framleiða Viðvörun á Löggilding glugga ef þeir eru greind og framfylgt þvingun mun framleiða villu í Löggilding glugga ef þeir eru greind. Ennfremur allar villur verður að leysa áður en Enterprise Server Verkefnið er hægt að framið.

8. Smelltu OK.

Note

Þvingun birtist í Explorer tré undir íhluta hægri-smellt er í lið 3. Örin táknar stefnu þvingun og í þessu tilfelli mun benda niður og til hægri. The hengilás er lituð í samræmi við hvort þvingun er óvirk (grár), varaði (gult) eða framfylgt (rautt).

Foreldri þarf að hafa barn varað þvingun

Til að skilgreina stigveldi þvingun, þar sem barn verður að fá ákveðin foreldri

4. Á Bæta þvingunglugga merkið á Búa þvingungátreitinn undir Barnið verður að hafa Parent þvingunsvæði.

5. Veldu íhlutafrá fellilistanum sem þú vilt að tilgreina eins foreldri íhluta hægri-smellt er í skrefi 3.

Note

Ef það er nú þegar virkt 'Child Verður Hafa foreldri sé þvingun skilgreind fyrir barnið íhluta og annað foreldri íhluta þá er þetta nýja þvingun verður að meðhöndla sem "OR". Það er tegund verður að vera barn af gerðinni foreldri A eðaforeldri gerð B, og fullnustu stig (td Athugið eða framfylgt - sjá næstu skref) ætti að vera sömu annars framfylgt þvingun mun alltaf hnekkja varað sjálfur.

6. Veldu hvort þú vilt að þvingun til að vera Disabled, Aðvöruneða Framfylgt.

Note

Fatlaðir þvingun verður hunsað frá þvingun fullgildingu, varaði þvingun mun framleiða Viðvörun á Löggilding glugga ef þeir eru greind og framfylgt þvingun mun framleiða villu í Löggilding glugga ef þeir eru greind. Ennfremur allar villur verður að leysa áður en Enterprise Server Verkefnið er hægt að framið.

7. Smelltu OK.

Note

Þvingun birtist í Explorer mati undir íhluta valið í þrepi 5. Örin táknar stefnu þvingun og í þessu tilfelli mun benda upp og fór. The hengilás er lituð í samræmi við hvort þvingun er óvirk (grár), varaði (gult) eða framfylgt (rautt).

Barnið verður að hafa foreldri varað þvingun

Til að skilgreina grannfræði þvingun, þar sem hluti skal fest við ákveðna tengingu

4. Á Bæta þvingunglugga merkið á Búa þvingungátreitinn undir Component skal fest þvingunsvæði.

5. Veldu gerð tengingarfrá fellilistanum sem þú vilt að tilgreina sem fylgir tengslum við íhluta hægri-smellt er í lið 3. (eða velja íhlutafrá fellilistanum sem þú vilt að tilgreina eins meðfylgjandi hluti ef í skrefi 3 þú hægri-smellir á gerð tengingar.)

Note

Ef það er nú þegar virkt 'Component verður að fylgja "þvingun skilgreint fyrir íhluta og annars gerð tengingar þá er þetta nýja þvingun verði meðhöndluð sem' og '. Það er íhluta skal fest við tengingu tegund A ogtenging gerð B, að hvað sem framkvæmd stigi (td fatlaða, Athugið eða framfylgt - sjá skref 7) er tilgreind fyrir hverja þvingun.

6. Valfrjáls þú getur valið tengingu Hlutverksem þú vilt bæta við þvingun. Skjósa sérstakar Hlutverk (þ.e. annað hvort Source eða sökkva) frá fellilistanum.

7. Veldu hvort þú vilt að þvingun til að vera Disabled, Aðvöruneða Framfylgt.

Note

Fatlaðir þvingun verður hunsað frá þvingun fullgildingu, varaði þvingun mun framleiða Viðvörun á Löggilding glugga ef þeir eru greind og framfylgt þvingun mun framleiða villu í Löggilding glugga ef þeir eru greind. Ennfremur allar villur verður að leysa áður en Enterprise Server Verkefnið er hægt að framið.

8. Smelltu OK.

Til að skilgreina grannfræði þvingun, þar sem tenging verður fest við ákveðna hluti

4. Á Bæta þvingunglugga merkið á Búa þvingungátreitinn undir Tenging skal fest Þvingunsvæði.

5. Veldu gerð tengingarfrá fellilistanum sem þú vilt að tilgreina sem fylgir tengslum við íhluta hægri-smellt er í lið 3. (eða velja íhlutafrá fellilistanum sem þú vilt að tilgreina eins meðfylgjandi hluti ef í skrefi 3 þú hægri-smellir á gerð tengingar.)

Note

Ef það er nú þegar virkt 'Connection verður að fylgja "þvingun skilgreint fyrir tegund tengingar og annað íhluta nota sömu tengingu Hlutverk(þ.e.a.s. annaðhvort Source eða sökkva), þá er þetta nýja þvingun verði meðhöndluð sem 'OR'. Það er gerð tengingar verður að fylgja íhluta A eðaíhluta B, og fullnustu stig (td Athugið eða framfylgt - sjá skref 7) ætti að vera sömu annars framfylgt þvingun mun alltaf hnekkja varað sjálfur. Athugaðu einnig, að ef það eru margar takmarkanir sem hafa tengingu Hlutverktilgreint sem "Allir" (eins og öfugt við sérstaklega Source eða sökkva) þá hver endi tengingu verður að fylgja einum af hluti tegundir sem tilgreindar eru í þvingun.

6. Valfrjáls þú getur valið tengingu Hlutverksem þú vilt bæta við þvingun. Skjósa sérstakar Hlutverk (þ.e. annað hvort Source eða Sink) frá fellilistanum.

Note

Annaðhvort Source eða sökkva hlutverk þarf að vera skýrt valin til að Viðhengi dálkur að vera avilable að vera sýnt í þætti verslun .

7. Veldu hvort þú vilt að þvingun til að vera Disabled, Aðvöruneða Framfylgt.

Note

Fatlaðir þvingun verður hunsað frá þvingun fullgildingu, varaði þvingun mun framleiða Viðvörun á Löggilding glugga ef þeir eru greind og framfylgt þvingun mun framleiða villu í Löggilding glugga ef þeir eru greind. Ennfremur allar villur verður að leysa áður en Enterprise Server Verkefnið er hægt að framið.

8. Smelltu OK.

Alvöru tími líkan stöðva og þvingunlöggilding

ABACUS inniheldurrauntíma Model Checking og Löggilding lögun til strax sýna áhrif tiltekins notanda aðgerð mun hafa á viðvaranir og villur með núverandi verkefni, vegna hvaða stigveldi og grannfræði þvingun sem hafa verið tilgreindar. Það skal tekið fram að allar villur verður að leysa áður en Enterprise Server Verkefnið er hægt að framið.

The raunverulegur-tími þvingun löggilding eiginleiki er mest áberandi þegar populating með skýringarmynd eða beint í Explorer glugga. Einkum á eftirfarandi aðgerðir, leiðbeiningar eru veittar með lit hápunktur á áhrifum rekstur mun hafa á viðvaranir og villur með núverandi verkefni;

1. Þegar draga þætti á eða í kringum skýringarmynd lit foreldris (eða setja) hluti (ef einhver) landamæri verður lituð samkvæmt kerfinu lýst hér að neðan.

2. Þegar tengja hluti með the réttur-smellur draga | Tengdu til lögun lista yfir fáanlega Connection Tegundir er lituð samkvæmt kerfinu lýst hér að neðan.

3. Þegar tengja hluti á skýringarmyndum með tengingarstjóranum Mode bendillinn breytist litum samkvæmt kerfinu lýst hér að neðan.

4. Þegar þú bætir undirþætti listi yfir tiltækar Component Tegundir er lituð samkvæmt kerfinu lýst hér að neðan.

Almennt eftirfarandi litir eru notaðir til að tilgreina hvaða áhrif notandi aðgerð mun hafa á viðvaranir og villur með núverandi verkefni;

Black : Engin áhrif á áminningu eða villur.

Grænn : Aðgerðin er beinlínis í samræmi viðskilgreint stigveldi og grannfræði þvingun til verkefnisins.

Red : Aðgerðin er beinlínis í bága viðsem skilgreint stigveldi og grannfræði þvingun fyrir verkefnið og mun leiða í aðvaranir og / eða villur.

Bakgrunnur líkan stöðva og þvingunlöggilding

ABACUS inniheldur Löggilding eiginleiki að sýna allar viðvaranir og villur með núverandi verkefni, vegna hvers konar takmarkana sem hafa verið tilgreindar. Það skal tekið fram að allar villur verður að leysa áður en Enterprise Server Verkefnið er hægt að framið.

Note

Löggilding þarf að vera með höndunum að keyra í gegnum "Staðfesta / Athugaðu Project þvingun 'hnappinn á Main tækjastika . The Validation glugginn er falinn sjálfgefiðen mun birtast þegar tækjastika hnappur er smellt. Sjá Aðlagaðu tengi fyrir hvernig á að Birta það og hugsanlega láta það varanlega birtist. Einnig, þú geta tvöfaldur-smellur hvaða röð í Löggilding glugga að "hoppa" á viðkomandi þáttur í verkefninu.

Löggilding glugga

Sjálfgefnu dálkum Löggilding glugga er lýst sem hér segir;

Viðvörun eða Villa: Þessi dálkur sýnir tákn fyrir hvort brotið er Warning (gulur þríhyrningur með upphrópunarmerki) eða Villa (rauður hringur með krossi).

Fjöldi: Þessi dálkur sýnir Brot númer.

Note

Aðeins 200 brot eru sýndar í einu og ef það eru fleiri en 200 brot í verkefninu Start, Prev, Next og End róður sæfarar efst til hægri í glugganum er hægt að nota til að skoða frekari brot.

Lýsing: This er a fullur lýsing á broti, þ.mt Fyrirtæki og þvingun að ræða.

Entity: Þessi dálkur sýnir Entity sem varða brotið.

Gerð: Þessi dálkur sýnir þátturinn gerð fyrir aðila.

Arkitektúr: Þessi dálkur sýnir Architecture þar sem brotið hefur átt sér stað.

Fundin: Þessi dálkur sýnir þann tíma sem brotið varð vart.

Ábending

Það er gagnlegt að raða niður eftir fundin dálk (eins og sýnt er í glugganum hér að ofan) að tryggja nýjustu brot birtast á 'efst' á listanum.

Það eru nokkrir möguleikar notandi til að breyta hegðun bakgrunnur líkan löggilding. Til dæmis to breyta litum sem notuð eru til þvingun brot á eitthvað annað en sjálfgefið Red, Smelltu á Tools | Valkostir ... þá fara að að Löggildingflipann og setja liti í gegnum Breyta hnappa.

Löggilding möguleikar

Til höndunum staðfesta þvingun

1. Hægrismella á Arkitektúrhnút, allir arkitektúr eða hvar sem er í annaðhvort Hlutieða Tengingarhluti af landkönnuður að skoða og velja Athugaðu þvingun.

Sannprófa þvingun

2. Smelltu á Upplýsingarhnappinn á Viðvaranirglugga til að sjá hvar arkitektúr brýtur einhverjar skorður sem hafa verið skilgreindar.

Note

Brot eru aðeins sýnd fyrir þá þvingun sem hafa verið sett til að Aðvörun eða framfylgt. Ennfremur orðalag viðvörun mun fela 'ætti' ef þvingun var bara viðvörun eða 'verður' ef það var framfylgt.

3. Smelltu OK.

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt


Eyði hluti eða tengingu

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Eyði hluti eða tengingu

Senda athugasemdir um þetta efni.

Til að eyða íhlutur eða tengingu

1. Hægrismellaá hluti eða tengingu.

2. Veldu Eyða.

Varúð

ABACUS mun vara þig sem skoðanir verða fyrir áhrifum af eyðingu og biðja þig um að staðfesta eyðingu. Þetta er vegna þess að þættir kunna að vera til á mörgum skýringarmyndum og það borgar sig að athuga hvað fyrirhuguð niðurfelling mun hafa áhrif.

Ábending

Ef þú eyðir hluti, öll hennar undirþætti verður einnig eytt. Þú getur valið að eyða innri og ytri tengingar við hluti. Ef þú velur ekki að eyða þeim, tengingar það er fest að verði áfram, en þeir vilja ekki lengur vera tengdur. Allir íhlutir og tengingar eru tiltekin Gerð . Eyði hluti / tengingu hefur engin áhrif á gerð (í þeim gerðum útibú tré). Á sama hátt, ef hluti / tengingu er a Standard úthlutað, eyða mun ekki hafa áhrif á skipstjóra á Standards útibú.

Sjá einnig

Populating vélina þína - Yfirlit


Skýringarmynd Sjónarmið

Navigation: Populating vélina þína> Using Teikningar>

Skýringarmynd Sjónarmið

Senda athugasemdir um þetta efni.

The sjónarmiðmöguleiki tryggir að þættir og tengsl sem er bætt við skýringarmynd verður að hafa tegund félag áður skilgreint áður en þeir geta bætt við skýringarmynd. Þessi eiginleiki gerir ráð fyrir um takmarkanir á þeim tegundum skýringarmyndir sem draga má með því að takmarka form & tengin sem eru tengd með Hluti og Tengingarlýði innan vélina þína.

Virkjun eða Gera óvinnufæran framfylgja skýringarmynd sjónarmið

Getu til að framfylgja skýringarmynd sjónarmið er sjálfkrafa virkt sjálfkrafa. Að slökkva / kveikja þennan möguleika smelltu á Tools | Valkostir ...| að Skýringarmyndflipann og afvelja / velja Framfylgja Skýringarmynd Sjónarmiðkassann samræmi við það.

Note

Ef þú sérð ekki "Framfylgja Skýringarmynd Sjónarmið"Valkostur á myndinni flipann þá þú þarft ekki Designer bæta við-á og kostur er á við vanræksla.

Búa til aðfararhæfa skýringarmynd sjónarmið

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá opna með landkönnuðurútsýni birtist.

2. Í landkönnuður mati hægri smelltu á Viewbendasog smelltu á Búa Skýringarmynd Sjónarmið

3. The Skýringarmynd Sjónarmiðgluggi verður birt.

4. Úthluta viðeigandi nafn til að skýringarmynd sjónarmiðog athugið að sjónarmið er vistuð undir Sjónarmiðkafla landkönnuður.

5. The Skýringarmynd Sjónarmiðgluggi verður birt.

6. Nú Smelltu og dragðu viðeigandi tegundir eininga og tegunda tenginga í arkitektúr þínum inn á sjónarmið form þú vilt. Component tegundirverður að draga inn alögun í formflipi, meðan tegundir tenginguverður að draga inn einn af 5 línu stíl stærðum í tengiflipann.

7. Að vista skýringarmynd sjónarmiðþú hefur búið til smellur á the [image] efst í hægra horninu á þinn Skýringarmynd Sjónarmiðglugga.

Note

The skýringarmynd sjónarmiðmá breyta með því að hægri smella á sjónarmið og val Openeða tvísmelltað sjónarmið.

Synchonising uppfærða sjónarmið með skýringarmyndum

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá opinn.

2. Annaðhvort er hægrismellt á sjónarmið í því Explorer Gluggi undir Meta-líkan | Sjónarmiðog veldu Sync Skýringarmynd kortlagning ...

- Eða -

3. Loka opinn og uppfærð sjónarmið glugga og veldu Já í Samstilla við Sjónarmiðvalmynd sem birtist.

4. The Sjónarmið Samstillingvalmynd birtist eins og sýnt er hér fyrir neðan.

Gátreit

· Bæta Missing kortlagning- Sérhver nýr lögun (til íhluta) eða tengi (að gerð tengingarinnar) samtök sem hefur verið bætt til sjónarhorniverður bætt við Samsvarandi skýringarmynds (þ.e. þeirrastencils)að eru tengd við sjónarhóli.

· Update NúverandiKortlagning- Öll uppfærð þætti núverandi formi (til íhluta) eða tengi (að gerð tengingarinnar) samtök fyrir sjónarmið(til dæmis lit, letur stíll) verður uppfærð í Samsvarandi skýringarmynds (þ.e. þeirrastencils)að eru tengd við sjónarhóli.

· Fjarlægja ExtraKortlagning- Allir viðbótar lögun (til íhluta) eða tengi (að gerð tengingarinnar) samtök sem hefur verið bætt til skýringarmyndir (Ã¾.e stenslar þeirra) en eru ekki í sjónarmiðverður fjarlægt úr Samsvarandi skýringarmynds (þ.e. þeirrastencils)að eru tengd við sjónarhóli.

· Skrifa yfir Local Stillingar added Uppfært kortlagning (Mismunur Only)- Öll uppfærð þætti núverandi formi (til íhluta) eða tengi (að gerð tengingarinnar) samtök fyrir sjónarmið(til dæmis lit, letur stíll) verður beitt á viðeigandi þáttum á skýringarmyndum sem tengjast sjónarhóli.Aðeins uppfært "munur" gerðar á sjónarhorni er beitt svo allir núverandi sveitarfélaga stillingar í myndinni sem voru ekki uppfærð í sjónarhóli verði óbreytt.

· [image] Textaskýringar – Og að ofan en sérstaklega fyrir umsagnir.

Sjá einnig

The Teikning Tól | Populating vélina þína | Greining arkitektúr þinn


Teikning tól lögun

Navigation: Populating vélina þína> Using Teikningar>

Teikning tól lögun

Senda athugasemdir um þetta efni.

The Teikning Tool styður fjölda teikna lögun.

Zooming

Umfang myndinni er hægt að breyta með því að nota aðdrátt.

Til að minnka umfang eða 'zoom í'

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Press Ctrlog '=' takkann.

- Eða -

2. Veldu Zoom Inhnappinn á Diagramtækjastiku.

- Eða -

2. Press Ctrlog rúlla músina hjól áfram. Ath: Í þessum ham striga mun stækka til þar sem músin er sveima yfir striga.

Til að auka umfang eða "þysja út"

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Press Ctrlog '-' takkann.

- Eða -

2. Veldu Minnka aðdrátthnappinn á Diagramtækjastiku.

- Eða -

2. Press Ctrlog rúlla músina hjól afturábak. Ath: Í þessum ham striga mun stækka út frá þar sem músin er sveima yfir striga.

Auto-skipulag

Útlitið þáttanna í myndinni er hægt að breyta sjálfkrafa.

Til skipulag allt hluti oN A skýringarmynd

1. Csleikja að Skipulag Skýringarmyndhnappinn á Skýringarmynd stikunni.

2. Velduannaðhvort Radial Layout eða Grid Layout.

Note

The Radial skipulag mun nota það sem er kallað "afl-beint 'reiknirit þannig að tengd þættir eru dregin saman á meðan ótengdan þættir eru neydd í sundur. The Grid skipulag mun nota fasta breidd og hæð línubil reiknirit. Það gerir í fyrsta lagi notandinn að velja heild skýringarmynd hlutföllum (td 16: 9, A4 (Portrait), Letter (Landscape)) og þá bil á hliðum og á milli dálka og raðir sem sést hér að neðan.Með rist skipulag einhver tengsl milli efnisþátta hafa ekki áhrif á skipulag og það raðar einfaldlega hluti stafrófsröð (með nafni) frá efst til vinstri til neðst til hægri á striga. Með báðum reiknirit Freeform form eru ekki flutt.

Til skipulag börn hluti í einni foreldri oN A skýringarmynd

1. Hægrismellaa hár-láréttur flötur hluti sem börn þú vilt sjálfvirkt farartæki-skipulag.

2. Veldu Layout Börn.

Note

Sjálfgefið aðeins Radial skipulag algrím er notað.

Breyting Element Fagurfræði eins Litur, Gagnsæi, Shadows og snúningur

Öll skýringarmynd þættir hafa fagurfræði sem má handleika eins og þú vilt. Þegar um er að ræða fram tengd form, þessi atriði er hægt að stilla á gerðog í flestum tilvikum einnig á dæmi. Þegar um er að ræða Freeform form, Þessa eiginleika er hægt að stilla á dæmiá striga.

Note

Allir á td þætti sem sett hafa verið fram tilheyrandi form verður 'plága' ef sama þáttur er breytt á sama tegund.

Til að breyta lit á tengdum lögun eða freeform lögun

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða Freeform lögun á striga.

3. Veldu Breyta Colour.

4. Veldu Fast Colourvalhringinn (ef við á).

5. Veldu Basic Litur eða skilgreina sérsniðna Litur í valmynd og smelltu OK.

- Eða -

4. Veldu Stigullvalhringinn (ef við á).

5. Veldu annaðhvort lárétt, lóðrétt, Forward Diagonal eða Afturábak Diagonal fyrir halli átt í pulldown og smella OK.

6. Veldu Basic Litur eða skilgreina sérsniðna Litur í glugganum fyrir Startog Endog smelltu OK.

Note

ABACUS mun lita forgrunni á lögun ef;
a) það er "einfalt" form með einum undirliggjandi grafísku þáttur (td hringur, rétthyrningur, marghyrning etc), eða
b) það er "flókin" form með mörgum undirliggjandi subshapes sem eru öll í sama lit / halli sem hvert annað eða subshapes hafa LockScale = true sett.
Ef ofangreind skilyrði eru ekki uppfyllt þá bakgrunnur lögun er lituð.

Til að stilla lit fylgir lögun samkvæmt eign

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga(EKKI á teikniborðinu striga).

3. Veldu Breyta Colour.

4. Veldu Using Propertyútvarp hnappur.

5. Veldu eign með því að smella á '...' hnappinn til hægri á kennslubók.

6. Veldu Range útvarp hnappur.

7. Stilla Minog Maxgildi sem óskað er. Ath: öll gildi undir lágmarks gildi verður sýnt sem Min lit og öll gildi yfir hámarki verður sýnt sem Max litinn. Einnig, þegar Boolean, listi eða Dagsetning / Tími eignir gildin eru umreiknaðar í vísitölu sem hér segir; Boolean (False = 0, True = 1), List (heiltala Vale of 1 til n fyrir hvern gild gildi í hækkandi röð þeirra sem tilgreind eru í einingum sviði) og dagsetning / tími (fjöldi daga frá 1. janúar 1900 - þ.mt brotum fyrir klukkustundir, mínútur, sekúndur hluta - og ef dagsetning er pre-1990 það er neikvæð tala).

8. Veldu Basic Litur eða skilgreina sérsniðna Litur í glugganum fyrir Minog Maxog smelltu OK.

Ábending

Ef Grænn (RGB - 128,255,0) er valið sem Min lit og Red (RGB - 255,0,0) er valið sem Max lit fyrir eign með gildi á bilinu 1að 4þá gildið 1verður birt eins Grænn, Gildið 2eins Yellow, 3eins Orangeog 4eins Red.

Að öðrum kosti, fyrir eign svið af 1að 3gildið 1verður eins Grænn, Gildið 2eins Amberog 3eins Redaka 'umferðarljós "eða RAG staða.

Fyrir a eign á bilinu 1 til 5 Ef Blue (RGB - 0,0,255) er valið sem Min lit og Red (RGB - 255,0,0) er valið sem Max lita a gildið 1 verður eins Blue, Td gildið 2 eins og Aqua, Er gildi af 3 eins og Grænn, Er gildi af 4 sem Yellow og gildi af 5 sem Red.

Fyrir a eign á bilinu 1 til 6 ef Violet (RGB - 255,0,255) er valið sem Min lit og Red (RGB - 255,0,0) er valið sem Max lita a gildið 1 verður eins Violet, Td gildið 2 eins og Blue, Er gildi af 3 eins og Aqua, Er gildi af 4 sem Grænn, Er gildi af 5 eins og Yellow og gildi af 6 eins og Red.

Og að lokum, að eign bilinu 1 til 7 er gildið 1 verður eins og Violet, Td gildið 2 eins og Dökkblátt, Er gildi af 3 eins og Ljósblár, Er gildi af 4 sem Blue Green, Er gildi af 5 eins og Grænn, Er gildi 6 sem Amber og gildi af 7 eins og Red

Note

Sjá athugasemd hér að ofan á forgrunni móti bakgrunn litarefni.

- Eða -

7. Veldu Specific Valueútvarp hnappur.

8. Smelltu á Edit Colourshnappinn.

9. Veldu hvert gildi í aftur og smella Setja Liturað setja ákveðna lit fyrir hvern gildi.

Note

Umfang gildanna fyrir frumefna á myndinni verður fyrirfram byggð.

10. Til að bæta við fleiri litum gildi að þeim fylltar (td eftir eign svið hefur verið endurstilla) smell Bæta við Gildi.

Til að breyta lit gagnsæi fylgir laginu eða freeform lögun

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða Freeform lögun á striga.

3. Veldu Breyta Colour.

4. Í Transparency spjaldið sett á topp renna til viðkomandi gagnsæi fyrir grunn lit.

5. Ef Stigull eða Using Property valkostir eru notuð í Transparency spjaldið stilla botn renna til viðkomandi gagnsæi í annað litinn.

6. Smelltu OK.

Til að sýna skuggarfyrir allt í tengd form í myndinni

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutiflipanum stencil glugga.

3. Veldu Bæta Shadows.

Til sýna skugga á hluti lögun eða Freeform lögun

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Hægri-clická hluti eða Freeform form á striga.

3. Veldu Bæta Shadows.

Til að snúa hluti form og óbundnu formi form í teikningum

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Veldu hluti lögun eða freeform form á striga þú vilt að snúa.

3. Hægrismellaá lögun og veldu Snúaog þá velja the viðeigandi horn þú vilt að snúa lögun með.

Breyting Element textaskýringar og Freeform textamerkingum

Öll skýringarmynd þættir hafa textaskýringar sem má handleika eins og þú vilt. Þegar um er að ræða fram tengd form, þessi atriði er hægt að stilla á gerðog í flestum tilvikum einnig á dæmi. Þegar um er að ræða Freeform stærðumog tengiErMerkingar er hægt að setja á dæmiá striga.Átta (8) mismunandi gerðir af textaskýringar birst skýringarmynd þætti (þ.e. nafn, tegund, Property Value, Property Marker, Attached Components, börn (fyrir hluti aðeins), staðla og Tímastimplunar (Búið, breytt því osfrv)) í tuttugustu fimm (25) mismunandi stöðum (td Centre - Utan Top, Inside vinstri - Centre, Utan Hægri - Utan Botn).

Note

Allir á td þætti sem sett hafa verið fram tilheyrandi form verður 'plága' ef sama þáttur er breytt á sama tegund.Ennfremur, þar sem 2 eða fleiri textaskýringar hernema sömu stöðu aðeins einn Font, Font stíl, Font lit og stærð má nota og Separator (td komma, rúm, ný lína) verður að velja.

Til að sýna nafn eða tegund fyrir tengslum hluti eða tengingu

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða tengið á striga.

3. Veldu Textaskýringar.

Note

Fyrir einstakan tengd lögun eða tengið á striga sem þú þarft að velja Hnekkja Stencil textaskýringargátreit í fyrsta skipti.

4. Veldu Nýtt Umsögnina í stikunni og veldu Name eða Gerð.

5. Í glugganum sem birtist velja Sýna valkosti sem eru viðeigandi á meðal sviga og Font, stíll osfrv lit og stærð. Einnig velja án valkosti sem eru viðeigandi á meðal lárétt og lóðrétt lega (þ.e. umsögnina stöðu) og hornið (þ.e. snúningur). Veldu OK.

Til að sýna eign gildi fyrir tengslum hluti eða tengingu

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða tengið á striga.

3. Veldu Textaskýringar.

Note

Fyrir einstakan tengd lögun eða tengið á striga sem þú þarft að velja Hnekkja Stencil textaskýringargátreit í fyrsta skipti.

4. Veldu Nýtt Umsögnina í stikunni og veldu Property Value.

5. Í glugganum sem birtist skaltu velja eign með því að smella á eign: "..." hnappinn og velja eign í Select A Property valmyndog veldu OK. Veldu skjánum valkosti sem eru viðeigandi á meðal sviga og Font, stíll osfrv lit og stærð. Einnig velja án valkosti sem eru viðeigandi á meðal lárétt og lóðrétt lega (þ.e. umsögnina stöðu) og hornið (þ.e. snúningur). Veldu OK.

Til að sýna eign merki fyrir tengslum hluti eða tengingu

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða tengið á striga.

3. Veldu Textaskýringar.

Note

Fyrir einstakan tengd lögun eða tengið á striga sem þú þarft að velja Hnekkja Stencil textaskýringargátreit í fyrsta skipti.

4. Veldu Nýtt Umsögnina í stikunni og veldu Property Marker.

5. Í glugganum sem birtist skaltu velja eign með því að smella á eign: "..." hnappinn og velja eign í Select A Property valmyndog veldu OK. Setja radíus prjónamerki dílar og litarefni aðferð til annaðhvort Colour By Range eða Colour By Property og setja liti verkefni. Einnig velja án valkosti sem eru viðeigandi á meðal lárétt og lóðrétt lega (þ.e. umsögnina stöðu) og hornið (þ.e. snúningur). Veldu OK.

Til að sýna fylgir hluti fyrir tengslum hluti eða tengingu

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða tengið á striga.

3. Veldu Textaskýringar.

Note

Fyrir einstakan tengd lögun eða tengið á striga sem þú þarft að velja Hnekkja Stencil textaskýringargátreit í fyrsta skipti.

4. Veldu Nýtt Umsögnina í stikunni og veldu Meðfylgjandi Hluti.

5. Í glugganum sem birtist fyrir tengda þætti velja meðfylgjandi íhluta með því að smella á viðhengi: "..." hnappinn og velja íhluta í Set íhluta valmyndog veldu OK. Veldu meðfylgjandi tengingu með því að smella á tengd með: "..." hnappinn og velja gerð tengingar í Set Connection Type valmyndog veldu OK.Fyrir tengslum tengingar velja tenginguna enda með því að velja Source eða Vaskur frá tengiendanum: fellilistanum. Fyrir bæði tengda þætti og tengsl velja Sýna valkosti sem eru viðeigandi á meðal sviga og Font, stíll osfrv lit og stærð. Einnig velja án valkosti sem eru viðeigandi á meðal lárétt og lóðrétt lega (þ.e. umsögnina stöðu) og hornið (þ.e. snúningur). Veldu OK.

Til að sýna börnin fyrir tengslum hluti

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutiflipanum stencil glugga eða tengd lögun á striga.

3. Veldu Textaskýringar.

Note

Fyrir einstakan tengist form á striga sem þú þarft að velja Hnekkja Stencil textaskýringargátreit í fyrsta skipti.

4. Veldu Nýtt Umsögnina í stikunni og veldu Börn.

5. Í glugganum sem birtist velja Sýna valkosti sem eru viðeigandi á meðal sviga og Font, stíll osfrv lit og stærð. Einnig velja án valkosti sem eru viðeigandi á meðal lárétt og lóðrétt lega (þ.e. umsögnina stöðu) og hornið (þ.e. snúningur). Veldu OK.

Til að sýna staðlar fyrir tengslum hluti eða tengingu

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða tengið á striga.

3. Veldu Textaskýringar.

Note

Fyrir einstakan tengd lögun eða tengið á striga sem þú þarft að velja Hnekkja Stencil textaskýringargátreit í fyrsta skipti.

4. Veldu Nýtt Umsögnina í stikunni og veldu Standards.

5. Í glugganum sem birtist velja Sýna valkosti sem eru viðeigandi á meðal sviga og Font, stíll osfrv lit og stærð. Einnig velja án valkosti sem eru viðeigandi á meðal lárétt og lóðrétt lega (þ.e. umsögnina stöðu) og hornið (þ.e. snúningur). Veldu OK.

Til að sýna tímastimplana fyrir tengslum hluti eða tengingu

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægrismellaá tengslum formi eða tengið í það Hlutieða Tengingarflipanum stencil glugga eða tengd lögun eða tengið á striga.

3. Veldu Textaskýringar.

Note

Fyrir einstakan tengd lögun eða tengið á striga sem þú þarft að velja Hnekkja Stencil textaskýringargátreit í fyrsta skipti.

4. Veldu Nýtt Umsögnina í stikunni og veldu Búin, búin By, Created Marker, breytt, breytt því eða breytt Marker.

5. Í glugganum sem birtist, ef ekki merki, velja Sýna valkosti sem eru viðeigandi á meðal sviga og Font, stíll osfrv lit og stærð. Ef merki, setja radíus prjónamerki dílar og litarefni aðferð til annaðhvort Colour By Range eða Colour By Property og setja liti verkefni. Einnig velja án valkosti sem eru viðeigandi á meðal lárétt og lóðrétt lega (þ.e. umsögnina stöðu) og hornið (þ.e. snúningur). Veldu OK.

Til að breyta leturgerð stíl af Freeform löguneða tengi

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Hægrismellaá Freeform lögun eða tengi á striga. Athugið: Ef tengi texti merki er ekki að sýna þá að sýna tengjaeða texti merki: Hægrismellaað tengjaeðaog veldu Umsögnina | Sýna umsögnina.

3. Veldu Breyta Font.

4. Veldu Font, leturgerð stíl og stærð í glugganum og veldu OK.

Að breyta leturgerð lit á Freeform löguneða tengi

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Hægrismellaá Freeform lögun eða tengi á striga. Athugið: Ef tengi texti merki er ekki að sýna þá að sýna tengjaeða texti merki: Hægrismellaað tengjaeðaog veldu Umsögnina | Sýna umsögnina.

3. Veldu Breyta Font Colour.

4. Veldu leturColour (og mótar Link Colour) með því að smella á '...' hnappinn og velja lit í valmynd og velja OK.

5. Veldu gagnsæi texta merkimiða með því að stilla renna með 0 er fullkomlega gagnsæ og 255 í fullu ógagnsæ.

Til að snúa texta merkimiða Freeform löguneða tengi

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Hægrismellaá Freeform lögun eða tengi á striga. Athugið: Ef tengi texti merki er ekki að sýna þá að sýna tengjaeða texti merki: Hægrismellaað tengjaeðaog veldu Umsögnina | Sýna umsögnina.

3. Veldu Snúaog þá velja the viðeigandi horn þú vilt að snúa texti merki með.

Sjá einnig

The Teikning Tól | Populating vélina þína | Greining arkitektúr þinn


Líkja Total eignarréttar (TCO)

Navigation: Líkja vélina þína> Herma>

Líkja Total eignarréttar (TCO)

Senda athugasemdir um þetta efni.

Bakgrunnur

Heildarkostnaður eignarréttar (TCO) er fjármálafyrirtæki mat, sem ætlað er að mæla heildar sem stofnað líf-hringrás kostnaður (frá kaupum á lokun / förgun) í tengslum við eignir með fullum eignarrétti. TCO ekki aðeins endurspeglar kostnað af kaupum, það tekur einnig til allra annarra þátta í frekari notkun og viðhald eignarinnar.

TCO er notað til að ákvarða fyrirhöfn og fjárhagsáætlun kostnaður nauðsynlegt að eyða á kerfi. Einföld leið til að sitja í Abacus fyrir TCO er að brjóta það kerfi niður í undirþætti. Við getum þá finna út hversu mikið að meðaltali það kostar að keyra einn af þessum hlutum. Eftir þetta sem við gætum þá þáttur í mismunandi kostnaði eftir því hvort það kerfi er evolvable eða opinn osfrv Ef kerfið er nú þegar upp og keyra, helstu þáttur til íhuga er kostnaður við viðhald og kannski kostnaði til úr notkun.

Dæmi

Teikning fyrir dæmi Útreikningur

The hluti undir stofnunin eða staðall þess hefur þessa eiginleika:

· FTE= 100 000 $ / ári

· Stuðningur áreynsla= 0,01 FTE + 0,001 FTE / ári = 1000 $ + 100 $ / ári

· Viðhald Kostnaður= 100 $ - 10 $ / ári

· Capital Kostnaður= 2000 $

· Setja áreynsla= 2 FTE / daga = 0,01 FTE / ári = 1000 $

The hluti undir stofnunarinnar hefur þessa eiginleika:

· Setja Horizon= -2 Ár (þ.e. Kerfið var sett 2 árum fyrir stundu)

· Lífskeið= 3 ár

Hvenær Setja Horizon + Lifespan <= 0 , Það er ekkert meira viðhald kostnaður.

Útreikningar

Útreikningarnir eru sem hér segir:

Note

TC = kostnað á ári. SE = Stuðningur áreynsla. MC = viðhald kostnaður.

· Upphafleg kostnaður = Capital Kostnaður + Setja áreynsla= 2000 + 1000 = 3000 $

· Á t = -2 (á 1. ári), TC = Stofnkostnaður + SE + MC= 3000 + 1000 + 100 = 4100 $

· Við t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1190 $

· Við T = 0, TC = (1000 + 200) + (100 - 20) = 1280 $

· Við t = 1 (síðasta ári), TC = (1000 + 300) + (100-30) = 1370 $

Línurit fyrir dæmi Útreikningur

TCO er summa allra núlifandi og komandi kostnaði fyrr en kerfið hefur verið tekinn úr notkun.

· Á t = -2 (á 1. ári), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Við t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Við t = 0, TCO = 1280 + 1370 = 2650 $

· Við t = 1 (síðasta ár), TCO = 1370 $

Helstu þættir Kostnaður

The lykilatriði kostnaður að huga þegar reikna TCO eignar í Abacus eru:

· Vélbúnaður Acquisition- Stofnkostnaður á búnaði (kostnaði fjármagns).

· Hugbúnaður Acquisition- Stofnkostnaður skírteinisins fyrir hugbúnað (fjármagnskostnaðar).

· Uppsetning- Kostnaður við fyrstu uppsetningu.

· Þjálfun- Kostnaður í tengslum við utanaðkomandi seljanda þjálfun eftir fyrstu uppsetningu.

· Stuðningur- Kostnaður í tengslum við innri stuðning.

· Viðhald- Kostnaður við að skipta eða uppfæra seljanda viðhald samninga, vistir og hörmung bati kostnað.

· Infrastructure- Kostnaður við að styðja við eign.

ABACUS Dæmi Fulltrúar Lykill Þáttur Kostnaður

Running Kostnaður hermir

Að líkja vélina þína í skilmálar af kostnaði

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Veldu Greining| Kostnaður.

3. Velja Architecture (s)þú vilt að fela í mat.

Note

Sjálfgefið ABACUS velur sjálfkrafa arkitektúr (s) sem er aftur uppgerð þarf vegna hvaða undirliggjandi eignum eða skipulagsbreytinga.Þetta auðkenning er sýnt á Red á Simulation tækjastika .

4. Veldu Gjaldmiðillfrá rífa niður.

5. Færðu Ár að reiknarenna til fjölda ára sem þarf.

Note

Sjálfgefið ef Years að reikna er meira en 1 ár kostnaðurinn sjálfkrafa reiknuð út fyrir hvern ári (og safn af eignir bætt / updated) og síðan uppsöfnuð gildi fyrir alla fjölda ára reiknað einnig. Ef aðeins uppsöfnuð gildi þarf þá óhindraður the Reikna Per ára Kostnaðurvalkostur eins og lýst er hér að neðan til að spara á fjölda eiginleika í verkefninu.

6. Velja hvort að fara Reikna Per ára Kostnaðurmerkt eða hakið það.

7. Smelltu Næsta.

8. Mögulega velja Tengingarþú vilt tengja kostnað eftir sem hluti af mati.

Note

Using a Kostnaður | Attributioneign á tengingum kostnaði getur verið rekja frá hluti fylgir vaskinn enda tengingu við hluti sem fylgir upptökum enda(þ.e. Kostnaður | Attribution = "Sink Heimild"), eða frá hluti fest við uppspretta enda tengingu við hluti fest við vaskur enda(þ.e. Kostnaður | Attribution = "Heimild til að Vaskur"). Til viðbótar, ABACUS velur sjálfkrafa þessi tengsl með Hegðun | Sambandið = "ferli" eða "styður"og átt úthlutun verður 'Vaskur Heimild'. Enn fremur, kostnaður skipt í samræmi við hverja sem er Hegðun | % Eða Kostnaður | % Eignir á tengingum, eða að öðrum kosti þar sem það eru margar tengingar frá vaski í mörgum heimildumeða fengið til margra sekkur, Í samræmi við hverja Hegðun | Vinnslu eignir á heimildar hlutieða sökkva hluti um sig.

9. Smelltu Finishog þú munt fá a Warningvalmynd.

10. Mögulega kanna viðvaranir með því að smella Nánar >>.

11. Smelltu Halda áfram.

Note

Á þessum tímapunkti, ABACUS framkvæmir starfsemi sem byggir kosta mat á arkitektúr (s) og eftir stuttan tíma (með framvindu börum um álit) útreikninga heill valmynd vilja birtast.

12. Smelltu OKað viðurkenna mat.

Ábending

Fyrir námskeiðum og frekari hjálp um Kostnaður Simulation vinsamlegast vísa til Avolution Community .

Component og / eða Tenging Properties

Eftirfarandi tafla sýnir hluti og / eða tengingu eiginleikar sem þarf til að meta kostnað.Þessir eiginleikar verður sýnd í Properties glugganum með eign inntak röð selector táknið ( [image] ) Með ábending 'Kostnaður Input ". Breyting einhverju af þessum 'input' eignir og ýmsar skipulagsbreytingar við geymsla mun leiða í kostnaði hermir þarfnast aftur uppgerð eins og fram kemur í Red á Simulation tækjastika .

Gerð

Name

Sjálfgefna gildið

Unit

Gögn Tegund

Áskilið

Lýsing

Kostnaður

Setja Horizon

0

ár

Integer

True

Tilgreinir þegar þátturinn eða tenging hefur verið, eða verður sett.

· Gildið 0 (sjálfgefið) gefur til kynna að hluti eða tenging Verið er að setja á yfirstandandi ári.

· A gildi minna en 0 gefur til kynna að hluti eða tenging hefur verið sett upp í fortíðinni.

· Gildi sem er hærra en 0 gefur til kynna að hluti eða tenging verður sett upp í framtíðinni.

Kostnaður

Lífskeið

0

ár

Integer

True

Skilgreinir hversu lengi sem hlutinn eða tenging verður áfram í rekstri, en eftir það verður tekinn úr notkun.

Kostnaður

FTE

100,000.00

$ / ári

Decimal

False

Árlegur kostnaður við hverja Full Time starfsmanns.

Ef þessi eign er ekki í hlutisjálft eða um er að ræða virkar er hluti fest við vaskinn enda tenginguVerður það að leita að í öðrum hlutum.

Í fyrsta lagi, allir "vaskur" hlutisí lok a tengingu með "styður" sambandi við efnisþáttinn verður leitað, fylgt eftir með sem 'vaskur' foreldri íhluturinn ers.

Ef FTE eign er ekki, þá hluti er foreldri-components verður þá að leita. Ef FTE er enn ekki fundið, sjálfgefið gildi er notað.

Vinsamlegast athugið: FTE er aðeins gild inntak eign á hluti.

Kostnaður

Viðhald Kostnaður (fast)

0.00

$ / ári

Decimal

False

Árlegur fastur kostnaður við að viðhalda hlutieða tenging.

Kostnaður

Viðhald Kostnaður (breyta)

0.00

$ / ári

Decimal

False

Sú fjárhæð sem heildarkostnaður viðhalda hluti eða tenging mun breytast á hverju ári.

Til dæmis, a gildi $ -500 sýnir að alls viðhald kostnaður lækkar um $ 500 hvor ári, á meðan gildið $ 500 sýnir að alls viðhald kostnaður hækkar um 500 $ á ári hverju.

Kostnaður

Stuðningur viðleitni (fast)

0.00

FTE / ári

Decimal

False

Hin árlega fasta átak um að styðja hlutieða tenging, Tilgreint í skilmálum ársverkum.

Kostnaður

Stuðningur viðleitni (breyta)

0.00

FTE / ári

Decimal

False

Sú fjárhæð sem alls átak styðja hluti eða tenging mun breytast á hverju ári.

Til dæmis, a gildi -0.01 sýnir að alls stuðningur áreynsla minnkar með 0,01 mannár á ári, á meðan gildið 0,01 bendir til þess að samanlagðar stuðningur áreynsla hækkar um 0,01 á hverju ári.

Kostnaður

Capital Kostnaður

0.00

$

Decimal

False

Upphafleg kostnaður af að kaupa hlutieða tenging.

Kostnaður

Setja áreynsla

0.00

FTE

Decimal

False

The átak í ársverkum, að setja hlutieða tenging.

Eftirfarandi tafla sýnir hluti og / eða tengingu eignir sem eru framleiðsla af TCO evaluator. Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Kostnaður Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og kostnaður hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Note

Þar sem framleiðsla eignir frá TCO evaluator Nauðsynlegt er að námundað "á" Round hálft jafnvel "nálgun (einnig nefnd" bankastjóri "námundun) er notað.Þessi aðferð er notuð til að jafnari leysa öll .5 'jafntefli hlé' með þeim afleiðingum að námundað upp eða niður til næsta jafnvel Niðurstaðan, en alltaf dregið upp eða niður og skekkja niðurstöðuna. Þ.e. 2,5 er námundað niður í 2, en 3,5 er námundað upp í 4, frekar en þá bæði að vera annaðhvort námundað niður í 2 og 3 eða námundað í 3 og 4.

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Kostnaður | Heildarkostnaður að eiga - næstu x árum. | $ | Integer | False | Heildarkostnaður eignarréttar á næstu xár, þar sem x er lengd tíma tilgreint þegar í gangi evaluator. Þetta felur í sér kostnað af hluti er eða tenging er stöðlum, undirþættieða undir-tengingar(þ.e. börn) og allir rekja kostnað.
Kostnaður | Heildarkostnaður við eiga (staðbundið) - næsta x ára. | $ | Integer | False | The 'sveitarfélaga "eignarréttar á næstu xár, þar xer lengd tíma tilgreint þegar í gangi evaluator. Þetta er ekkifela í sér kostnað undirþætti íhlutinn er eða undir-tengingar tengingu er (þ.e.börn) eða einhver sem rekja kostnað.
Kostnaður | Heildarkostnaður eigin (börn) - næsta x árum. | $ | Integer | False | Kostnaður 'börn' eignarhalds á næstu xár, þar sem x er lengd tíma tilgreint þegar í gangi evaluator. Þetta aðeins felur í sér kostnað af undirþætti íhlutinn er eða undir-tengingar tengingu er (þ.e. börn).
Kostnaður | Heildarkostnaður við eiga (rekja) - næsta x ára. | $ | Integer | False | The 'rekja' eignarhald á næstu xár, þar sem x er lengd tíma tilgreint þegar í gangi evaluator. Þetta aðeins gildir einnig rekja kostnað frá meðfylgjandi hluti(sem getur auðvitað eru rekja kostnað frá öllum meðfylgjandi tengingar).

Eftirfarandi tafla sýnir hluti og / eða tengingu eignir sem eru framleiðsla af TCO evaluatoref Reikna Per-Year Kostnaður er valið. Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Kostnaður Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og kostnaður hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Note

Sjá athugasemd hér að ofan um hugsanlega námundun á framleiðsla eiginleika.

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Kostnaður | Heildarkostnaður að eiga - árix. | $ | Integer | False | Heildarkostnaður eignarréttar fyrir ári x, Þar sem x er fyrir hvert ár tilgreint þegar í gangi evaluator. Þetta felur í sér kostnað af hluti ereða tenging er stöðlum, undirþætti eða undir-tengingar (þ.e. börn) og allir rekja kostnað.
Kostnaður | Heildarkostnaður við eiga (staðbundið) - árix. | $ | Integer | False | The 'sveitarfélaga "kostnaður af eignarréttur fyrir árið x, Þar sem xer fyrir hvert ár tilgreint þegar í gangi evaluator. Þetta er ekkifela í sér kostnað undirþætti íhlutinn er eða undir-tengingar tengingu er (þ.e. börn) eða einhver sem rekja kostnað.
Kostnaður | Heildarkostnaður að eiga (börn) - árix. | $ | Integer | False | Kostnaður 'Börn' eignarhalds fyrir árið x, Þar sem x er fyrir hvert ár tilgreint þegar í gangi evaluator. Þetta aðeins felur í sér kostnað af undirþætti íhlutinn er eða undir-tenging tengingu er (þ.e. börn).
Kostnaður | Heildarkostnaður við eiga (rekja) - árix. | $ | Integer | False | The 'rekja' eignarhald fyrir árið x, Þar sem x er fyrir hvert ár tilgreint þegar í gangi evaluator. Þetta aðeins gildir einnig rekja kostnað frá meðfylgjandi hluti(sem getur auðvitað eru rekja kostnað frá öllum meðfylgjandi tengingar).

Viðbótarupplýsingar Tengingu Properties

Eftirfarandi tafla sýnir viðbótar eignir tengingu sem þarf af TCO evaluator. Þessir eiginleikar verður sýnd í Properties glugganum með eign inntak röð selector táknið ( [image] ) Með ábending 'Kostnaður / Performance Input "eða bara" Kostnaður Input ". Breyting einhverju af þessum 'input' eignir og ýmsar skipulagsbreytingar við geymsla mun leiða í kostnaði og / eða Performance hermir krefjast aftur uppgerð eins og fram kemur í Red á Simulation tækjastika .

Gerð | Name | Sjálfgefna gildið | Unit | Gögn Tegund | Áskilið | Lýsing
Kostnaður | Attribution | Sökkva til Heimild | [Heimild til Vaskur | Sökkva til Heimild] | Lookup / List | True | Ef "Source sökkva"Þetta tengingu mun hafa hafa kostnaðursrekja 'og' það frá uppsprettahluti til vaskur hluti. Að öðrum kosti, ef "Sökkva til Heimild"Þetta tengingu mun hefur kostnaður rekja 'og' það frá vaskinum hluti til the uppspretta hluti.
Hegðun | Sambandið | styður | [ferli | styður] | Lookup / List | False | Ef "styður", þessi tenging gefur til kynna að "uppspretta" hluti er styrkt af "sökkva" hluti. Að auki, ef annaðhvort "styður" eða "ferli" þá tengingin sjálfkrafa valin í tengingum að hafa kostnað þeirra rekja 'meðfram' úr vaskinum hluti til the uppspretta hluti.
Kostnaður | % | 100.0 | % | Decimal | False | Sýnir hlutfall vaskinn íhlutir kostnað sem verður að rekja til uppspretta hluti. The% gildi þurfa ekki að bæta við allt að 100% og það er einfaldlega notað til að skala "Heildarkostnaður við eiga -. Næsta x ár" eign (sjá hér að ofan) frá vaskinum hluti eins og það má rekja til uppspretta hluti.

Arkitektúr Properties

Eftirfarandi tafla með arkitektúr eiginleika sem eru framleiðsla af TCO evaluator. Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Kostnaður Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og kostnaður hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Note

Sjá athugasemd hér að ofan um hugsanlega námundun á framleiðsla eiginleika.

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Kostnaður | Heildarkostnaður að eiga - næstu x árum. | $ | Integer | False | Heildarkostnaður við eignarhald á öllu arkitektúr næstu x árin.

Eftirfarandi tafla með arkitektúr eiginleika sem eru framleiðsla af TCO evaluatoref Reikna Per-Year Kostnaður er valið. Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Kostnaður Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og kostnaður hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Note

Sjá athugasemd hér að ofan um hugsanlega námundun á framleiðsla eiginleika.

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Kostnaður | Heildarkostnaður að eiga - árix. | $ | Integer | False | Heildarkostnaður eignarréttar fyrir allt arkitektúr fyrir árið xinn í framtíðina.


Líkja Modularity

Navigation: Líkja vélina þína> Herma>

Líkja Modularity

Senda athugasemdir um þetta efni.

The modularity hermir reiknar fjölda komandi og á útleið tengsl fyrir hvern íhlut.

Að líkja vélina þína í skilmálar af modularity

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Veldu Greining| Modularity.

3. Velja Architecture (s)þú vilt að fela í mat.

Note

Sjálfgefið ABACUS velur sjálfkrafa arkitektúr (s) sem er aftur uppgerð þarf af einhverjum undirliggjandi skipulagsbreytinga.Þetta auðkenning er sýnt á Red á Simulation tækjastika .

4. Smelltu Næsta.

5. Velja Tenging ferðalaga (s)þú vilt að fela í mat.

6. Smelltu Næsta.

7. Mögulega aðlaga eign nöfn útreikningurinn.

8. Smelltu Finish.

Note

Á þessum tímapunkti, ABACUS mun framkvæma skipulagsbreytingar mat á arkitektúr (s) og eftir stuttan tíma (með framvindu börum um álit) útreikninga heill valmynd vilja birtast.

9. Smelltu OKað viðurkenna mat.

Ábending

Fyrir námskeiðum og frekari hjálp um Modularity Mat vinsamlegast vísa til Avolution Community .

Component Properties

Eftirfarandi tafla með hluti eiginleika sem eru framleiðsla af Modularity evaluator.Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Modularity Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi uppbyggingu breytingu geymsla og Modularity hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Gögn Tegund | Áskilið | Lýsing
Modularity | Tenging-fan í (staðbundið) | Integer | False | Fjöldi tenginga sem aðdáandi í þessa hluti.
Modularity | Coupling-fan út (staðbundið) | Integer | False | Fjöldi tenginga sem aðdáandi út þessa hluti.
Modularity | Tenging-fan í | Integer | False | Fjöldi tenginga sem aðdáandi í þessum þætti, þar á meðal tengingar sem aðdáandi í undirþætti.
Modularity | Coupling-fan út | Integer | False | Fjöldi tenginga sem aðdáandi af þessum þætti, þar á meðal tengingar sem aðdáandi í undirþætti.


Líkja Hreinskilni

Navigation: Líkja vélina þína> Herma>

Líkja Hreinskilni

Senda athugasemdir um þetta efni.

Hreinskilni hermir ákvarðar stig sem arkitektúr og þættir hennar eru 'opið', það er, getu kerfisins til að takast skipta út íhlutum með sem minnstum áhrifum.

Að líkja vélina þína í skilmálar af hreinskilni

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Veldu Greining | Hreinskilni.

3. Velja Architecture (s)þú vilt að fela í mat.

Note

Sjálfgefið ABACUS velur sjálfkrafa fyrsta arkitektúr sem aftur-uppgerð þarf vegna hvaða undirliggjandi eignum eða skipulagsbreytinga.Þetta auðkenning er sýnt á Red á Simulation tækjastika .

4. Smelltu Finishog þú munt fá a Warningvalmynd.

5. Mögulega kanna viðvaranir með því að smella Nánar >>.

6. Smelltu Halda áfram.

Note

Á þessum tímapunkti, ABACUS mun framkvæma skipulagsbreytingar mat á arkitektúr (s) og eftir stuttan tíma (með framvindu börum um álit) útreikninga heill valmynd vilja birtast.

7. Smelltu OKað viðurkenna uppgerð.

Ábending

Fyrir námskeiðum og frekari aðstoð á hreinskilni mat vinsamlegast vísa til Avolution Community .

Hluti og Tenging Standard Properties

Eftirfarandi tafla með hluti og tengingu staðlaðar eiginleika sem þarf til að meta hreinskilni.Þessir eiginleikar verður sýnd í Properties glugganum með eign inntak röð selector táknið ( [image] ) Með ábending 'Hreinskilni Input ". Breyting einhverju af þessum 'input' eignir í geymsla mun leiða í hreinskilni hermir þarfnast aftur uppgerð eins og fram kemur í Red á Simulation tækjastika .

Gerð | Name | Sjálfgefna gildið | Unit | Gögn Tegund | Áskilið | Lýsing
Hreinskilni | Standards-Standard maturity Organisation Level |  | [0 | 1 | 2 | 3] | Lookup / List | False | Stig ábyrgur staðlastofnun 0:Skipulagsbreytingar / Eigin 1:Consortium / defacto 2:National / Military 3:International
Hreinskilni | Standards-Standard maturity Status |  | [0 | 1 | 2 | 3] | Lookup / List | False | Samþykki stigi náð með staðlastofnun 0:Vinna / Nefnd Draft 1:Public Draft / Balloted 2:Tímabundna Drög 3:Samþykkt
Hreinskilni | Standards-Standard maturity Stability |  | [0 | 1 | 2 | 3] | Lookup / List | False | Er staðall líklegt til að breyta? 0:Standard úreltur 1:Mjög geta breyst í næstu 1 til 2 ár 2:Þekkt breyting / uppfærslur á núverandi aðgerðir 3:Mjög stöðugt (engin breyting innan 2 ára)
Hreinskilni | Standards-Standard maturity Vendor Support |  | [0 | 1 | 2 | 3] | Lookup / List | False | Vendor Stuðningur 0:Engar vörur eða seljendur styðja staðalinn 1:Ein eða fleiri framleiðendur sem innleiða hluta af staðlinum 2:Meira en einn söluaðili með vörur sem styðjast allir hlutar staðalsins 3:Margir fleiri en einn söluaðili með vörur sem styðjast allir hlutar staðalsins
Hreinskilni | Standards-Standard Explicitness-Documentation |  | [0 | 1 | 2 | 3] | Lookup / List | False | Gæði venjulegu gögnum 0:Poor 1:Fair 2:Good 3:Excellent
Hreinskilni | Standards-Standard Explicitness-Standard Breidd |  |  | Integer | False | Tala af lögun. A telja lægstu stig staðall lögun - Sf
Hreinskilni | Standards-Standard Explicitness-Sm |  | % | Decimal | False | Hlutfall af heildarfjölda eiginleika sem eru nauðsynlegur
Hreinskilni | Standards-Standard Explicitness-So |  | % | Decimal | False | Hlutfall af heildarfjölda eiginleika sem eru valfrjáls
Hreinskilni | Standards-Standard Explicitness-Sc |  | % | Decimal | False | Hlutfall af heildarfjölda eiginleika sem eru skilyrt skilgreind
Hreinskilni | Snið-Profile Documentation-Documentation |  | [0 | 1 | 2 | 3] | Lookup / List | False | Gæði venjulegu gögnum 0:Ekkert 1:Poor 2:Fair 3:Excellent
Hreinskilni | Snið-Profile Documentation-Accuracy |  | [0 | 1 | 2 | 3] | Lookup / List | False | Er skjöl endurspegla raunverulegt kerfi hönnun? Á hvaða stigi prófílinn aðgerðir eru notaðar í kerfinu? 0:Engar aðgerðir 1:Sumar aðgerðir 2:Flestir eiginleikar 3:Allar aðgerðir
Hreinskilni | Snið-Profile Documentation gjalddaga |  | [0 | 1 | 2 | 3] | Lookup / List | False | Er sniðið þroskaður og í boði? 0:Ad-hoc 1:Project byggt 2:Skipulagsbreytingar 3:Public
Hreinskilni | Snið-Profile Explicitness-Explicit Breidd |  |  | Integer | False | Fjöldi staðall lögun sem tilgreind sem krafist er í sniðinu
Hreinskilni | Snið-Profile Explicitness-Pm |  | % | Decimal | False | Hlutfall SKYLDUBUNDNA aðgerðir í prófílnum
Hreinskilni | Snið-Profile Explicitness-Po |  | % | Decimal | False | Hlutfall sérbúnaði í uppsetningu
Hreinskilni | Snið-Profile Explicitness-Pc |  | % | Decimal | False | Hlutfall af skilyrðum skilgreindar aðgerðir í prófíl
Hreinskilni | Snið-Profile Explicitness-Umfjöllun |  | % | Decimal | False | Hlutfall staðall lögun sérstaklega fjallað í uppsetningu
Hreinskilni | Snið-prófíl Extensions-Extension Breidd |  |  | Integer | False | Fjöldi non-staðall lögun tilgreinir upplýsingar
Hreinskilni | Snið-prófíl Extensions-Umfjöllun |  | % | Decimal | False | Hlutfall eftirnafn nákvæmur í sniðinu
Hreinskilni | Vara-vara framboð og samræmi, fjölda af vörum |  | [0 | 1 | 2 | 3] | Lookup / List | False | Fjöldi vara styðja lögboðin lögun staðalsins 0:Engar vörur styðja staðalinn 1:Ein eða fleiri vörur innleiða hluta af venjulegu 2:Fleiri en eina vöru útfærir alla hluta staðalsins 3:Margir fleiri en eina vöru útfærir alla hluta staðalsins
Hreinskilni | Vara-vara framboð og samræmi, Umsókn samræmi |  | [0 | 1 | 2 | 3] | Lookup / List | False | Á hvaða stigi samræmi gera vörur að staðall? 0:Ekkert 1:Krafa 2:Sýnt 3:Staðfest og Sýnt
Hreinskilni | Vara-vara framboð og samræmi, samræmi Quality |  | [0 | 1 | 2 | 3] | Lookup / List | False | Gæði samræmi próf 0:Ekkert 1:Í húsinu prófuð af vöruþróun 2:Independent prófanir (t.d. NIST) 3:Sýnt í tengslum við viðeigandi vöru

Component, Connection og arkitektúr Properties

Eftirfarandi tafla sýnir hluti, tengingu og arkitektúr eignir framleiðsla af hreinskilni evaluator. Allar eftirfarandi eiginleika meta að milli núll (0) og þrjú (3), núll (0) er að minnsta kosti æskilegt og þrír (3) að vera sem mest æskilegt.Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Hreinskilni Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eign breytingar á geymsla og hreinskilni hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Gögn Tegund | Áskilið | Lýsing
Hreinskilni | Hreinskilni | Decimal | False | Heildarmat á hreinskilni atriðisins.
Hreinskilni | Standards-Standard Lánstími | Decimal | False | Núverandi ástand af the staðall, sem endurspeglar hvort það hefur verið samþykkt, hversu lengi það hefur verið í notkun og hversu vel tekið er það innan samfélagsins verktaki.
Hreinskilni | Standards-Standard Explicitness | Decimal | False | The explicitness staðlanna, sem endurspeglar hugsanlega tvíræðni í ensuing staðla
Hreinskilni | Snið-Profile Documentation | Decimal | False | Að hve miklu leyti tengi prófíll gögn er þróað og hvort sniðið skjölin raunverulegt kerfi hönnun og / eða framkvæmd kerfi
Hreinskilni | Snið-Profile Explicitness | Decimal | False | The láréttur flötur af smáatriði veitt í profile / upplýsingar forskrift
Hreinskilni | Snið-prófíl Extensions | Decimal | False | Hversu sem sniðið í samræmi við staðalinn sem hún er byggð
Hreinskilni | Vara-vara framboð og samræmi | Decimal | False | Hvort það eru opnir staðlaðar af samræmi vörur í boði til notkunar í verkefninu


Líkja Performance

Navigation: Líkja vélina þína> Herma>

Líkja Performance

Senda athugasemdir um þetta efni.

Bakgrunnur

The byggingarlistar evaluator fyrir frammistöðu er stakur atburður hermir sem virkar með því að líkja flæði skilaboð (eða tákn) í gegn um arkitektúr. Kenningin á bak við þetta er dregið frá rannsókn sem unnin af University of Technology, Sydney, og er byggt á Lagskipt biðröð Net Models(LQNM), Tímastillt og Coloured Petri-Nets(TCPN) og Virkni Cycle Skýringarmyndir(ACD).

Í abacus árangur uppgerð, vinnsla á einn þátt er ekið að miklu leyti af skilaboðum framhjá til það frá öðru hluti. Meginreglurnar bak þessari tækni er hægt að skilja í fjórum hlutum:

1. The Skilaboðin-miðlægursamskipti eru byggð í Abacus með rökrétt(eða óbeint) tengingar. Rökfræðileg tengingar skilgreina hegðun (tíðni og gögn) af skilaboðum sem send eru milli efnisþátta. Gott dæmi um rökrétt tengsl væri röð rennur milli tveggja (2) viðskipti aðferð eða rökrétt tengsl milli tveggja (2) forrit.

2. Rökfræðileg skilaboð eru flutt á áfangastað með stigveldi(svo sem úrræði swimlanes) eða beintengingar (eins og líkamlega vír). Til að gera þetta að þeir geta flutt upp, yfir og aftur niður í stigveldi (A lagskiptu nálgun) að fylgja bein slóð.

3. Tryggð líkaninu er hægt að breyta til föt. Til dæmis, a ferli má skipta niður svo langt þannig að hver grunn ferli og virkni hefur sérstakan vinnslu fótspor. Einnig getur það verið nóg að hafa bara eitt gildi fyrir allt ferlið, sem endurspeglar meðaltalvinnslu svar skilaboðum.

4. Raunveruleg vinnsluer flutt aðeins af hlutum sem hafa (eða eru) örgjörva. A örgjörva er almenn hlutur, og gæti verið CPU, maður, skipulagi eining eða eitthvað annað sem er fær um að framkvæma verkið. Til dæmis, a viðskipti aðferð hjartarskinn ekki gera allir raunverulegur vinnslu; þetta er gert með því að fyrsta 'örgjörva' það staðsetur í annað foreldrið stigveldi þess (ef sundbraut merki er notað) eða vinnslu net (ef dreift vinnslu merki er notuð).

Matið er framkvæmt með því að líkja (ótilgreint) umferð í kerfinu, þannig að sérhver tengsl er herma að minnsta kosti einu sinni. Komutími skilaboða eru af handahófi mynda með tilliti til tilgreinda tíðni þeirra. Líkanið líkir vefsíðuna vinnslu og deilum og biðröð af skilaboðum, safna tölfræði leiðinni sem ýmsa eiginleika framleiðsla.

Helstu Performance Inntak Þættir

1. Tíðni- Tíðni þar sem tengingin kemur.

2. Vinnsla- Fjárhæð keyrslutíma að klára eitt ferli. Þetta kann að vera í klukkustundum, mínútum, dögum, rekstur o.fl.

3. Hraði- Hraði örgjörva auðlind. Það er, hversu margir umferðir / leiðbeiningar / aðgerðir er hægt að framkvæma í einni einingu af tíma. Það er mikilvægt að vera í samræmi við einingar sem notaðar til vinnslu.

4. Örgjörvum- Fjöldi örgjörva auðlinda. Örgjörvum gæti verið fólk, CPU, utanaðkomandi stofnanir o.fl.

Helstu Performance Output Þættir

1. Afköst- Fjöldi skilaboða á tímaeiningu gegnum það tenging. Þetta raunverulegt gildi má bera saman við væntanlegan / fræðilegu gildi (þ.e. tíðni) að álykta mettun kerfisins.

2. Skilaboð Rate- Fjöldi skilaboða á tímaeiningu gegnum það hluti. Þetta er summan af komandi og á útleið skilaboð allir þættir.

3. Svar- Lágmarks / meðaltal / hámark leynd fyrir þetta tenging. Þetta er summan af öllum mældum leynd fyrir tengingu frá upptökum að vaskinum og hvaða biðröð og vinnslu (og leynd aftur til the uppspretta ef tvíátta).

4. Nýting- Nýting á hluti. Þetta verður 0% ef hluti er ekki tæki / örgjörva (þ.e. það hefur ekki örgjörvar og Hraði eiginleika skilgreind að ofan).

En stakur atburður uppgerð er flutt til að reikna ýmsa eiginleika framleiðsla, eins og lýst er hér að framan, samkvæmt eftirfarandi formúlu má nota sem gróft sannprófun niðurstöðum (þar sem kerfið er ekki mettuð):

Nýting = samanlagðir Tíðni allra komandi tengingar * Processing / (hraða * Processors)

Í heild Hugmyndin er kannski best fram með því að íhuga eftirfarandi skýringarmynd sem sýnir tvær mismunandi árangur meta-módel. Vinstri hönd stíl er klassískt "sundbraut 'merki með vinnslu verkefna byggist hierarchically innan örgjörva auðlindir þeirra. Hægra stíll er a 'dreift' merki með vinnslu verkefna tengd með ferli tengingu við örgjörva vefsíðuna þeirra. Þetta síðastnefnda ritháttur gerir margar auðlindir örgjörva fyrir tiltekið vinnslu verkefni, ólíkt takmarkaðan sundbraut tákn.

Note

Sýnt á hverju meta-líkan eru inntak eiginleika (í rauðu) og framleiðsla eiginleika (í bláu):

Flutningur meta-módel: sundbraut móti Úthluta merki

Keyra árangur hermir

Að líkja vélina þína í skilmálar af flutningur

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Veldu Greining| Performanceeða smelltu á stikunni hnappinn.

3. Veldu Arkitektúrþú vilt að meta frá fellilistanum.

Note

Sjálfgefið ABACUS velur sjálfkrafa fyrsta arkitektúr sem aftur-uppgerð þarf vegna hvaða undirliggjandi eignum eða skipulagsbreytinga.Þetta auðkenning er sýnt á Red á Simulation tækjastika .

4. Veldu Hlutiog Tengingarþú vilt að meta, frá staðall þáttur val gluggi .

5. Stilltu Run Time Scale Factorrenna.

Note

Hærri gildi muni meira tölfræðilega samræmi niðurstöður en taka lengri tíma að reikna.

Viðbótarupplýsingar Gátreitinn til staðall þáttur val gluggi

· Save umbreytt Modelmun vista afrit af RBD breytta útgáfu verkefnisins í sömu möppu og núverandi verkefni og bæta "_transformed" að nafninu verkefni.Þetta umbreytt verkefni er hægt að nota til að greina í smáatriðum áreiðanleika uppgerð ráðist af Abacus.

Aðrir valkostir til að staðall þáttur val gluggi

· Run Time Scale Factor stýrir uppgerð tíma og nákvæmni með hærri gildi ávöxtunIngmeira tölfræðilega samræmi Niðurstöður en taka lengri tími hlaupa.

Note

Þegar ABACUS reiknar líkanið tíma það mun ákvarða hægur óbeina tengingu tíðni sem var valinn til að líkja og síðan 'upphitun' tímabilsins (þ.e. 1 yfir tíðni) af þessu sambandi (hafin reglubundin rafala skilaboð fyrir alla tengingar handahófi á þessu hita upp tíma, gefa þeim öllum tækifæri til að hefja) og þá líkja eftir Run Time Scale Factor sinnum Gildistími því sambandi. Eða (1 / Frequency) hita upp tími + (1 / Frequency) * Run Time Scale Factor uppgerð tíma. Þetta er að ganga úr skugga um að að allar tengingar eru hafin áður en tölfræði er safnað og síðan hægur tengsl er enn herma að minnsta kosti einu sinni í uppgerð. T.d. Ef hægur óbeina tengingu hefur Tíðni 0.033 tíma-einingar (eða circa einu sinni í mánuði ef tími-einingar eru dagar) þá hita upp tíma verður 30.3 tíma-einingar og uppgerð tíma verður 30.3 tíma-einingar sinnum Run tími Scale Factor.

6. Smelltu Finishog þú munt fá a Warningvalmynd.

7. Mögulega kanna viðvaranir með því að smella Nánar >>.

8. Smelltu Halda áfram.

Note

Á þessum tímapunkti, ABACUS mun framkvæma stakur-atburður uppgerð á arkitektúr og eftir stuttan tíma (með framvindustikur um álit) útreikninga heill valmynd vilja birtast.

9. Smelltu OKað viðurkenna uppgerð.

Ábending

Fyrir námskeiðum og frekari hjálp um árangur Simulation vinsamlegast vísa til Avolution Community .

Component Properties

Eftirfarandi tafla sýnir eiginleika sem þarf til að meta árangur. Eignir eru að leita að fyrst í Component tilvikum, þá Component Standards og ef stofna ekki, sjálfgefið er notað.Þessir eiginleikar verður sýnd í Properties glugganum með eign inntak röð selector táknið ( [image] ) Með ábending 'Performance Input ". Breyting einhverju af þessum 'input' eignir og ýmsar skipulagsbreytingar við geymsla mun leiða í Performance hermir þarfnast aftur uppgerð eins og fram kemur í Red á Simulation tækjastika .

Gerð | Name | Sjálfgefna gildið | Unit | Gögn Tegund | Áskilið | Lýsing
Hegðun | b_pack | 0,0 |  | Decimal | False | Fast þjónusta tími til að pakka í sekúndum. Þessi eign er yfirleitt skilgreind sem venjulegu gerð og síðan notað til mörgum tilvikum hluti. Til dæmis, CORBA hefur b_pack = 0,23 ms.
Hegðun | m_pack | 0,0 |  | Decimal | False | Breytan þjónusta tími til að pakka í sekúndum / bæti. Þessi eign er yfirleitt skilgreind sem venjulegu gerð og síðan notað til mörgum tilvikum hluti.
Hegðun | b_unpack | 0,0 |  | Decimal | False | Fast þjónusta tími til að taka upp á nokkrum sekúndum. Þessi eign er yfirleittskilgreind sem venjulegu gerð og síðan notað til mörgum tilvikum hluti.
Hegðun | m_unpack | 0,0 |  | Decimal | False | Breytan þjónusta tími til að taka upp í sekúndur / bæti. Þessi eign er yfirleittskilgreind sem venjulegu gerð og síðan notað til mörgum tilvikum hluti.
Hegðun | Vinnsla | 0,0 |  | Decimal | True | Fjárhæð keyrslutíma að klára eitt ferli. Þetta kann að vera í klukkustundum, mínútum, dögum, rekstur o.fl.
Hegðun | Örgjörvum | 1 |  | Integer | True | Fjölda örgjörvi auðlinda. Örgjörvum gæti verið fólk, CPU, utanaðkomandi stofnanir o.fl.
Hegðun | Hraði | 100 |  | Integer | True | Hraða örgjörva auðlind. Það er, hversu margir umferðir / leiðbeiningar / aðgerðir er hægt að framkvæma í einni einingu af tíma. Það er mikilvægt að vera í samræmi við einingar sem notaðar til vinnslu.
Hegðun | k_bkgd | 0,0 |  | Decimal | False | Bakgrunnur vinnslu á hluti. Þetta er notað til að leiðrétta niðurstöður eftir því hvaða fasta móti fyrir%. Þetta má líklega að hunsa.

Eftirfarandi tafla sýnir hluti eignir framleiðsla af frammistöðu evaluator. A setja af þessum hluti eignanna er mynda fyrir hverja hluti á hverri sýningu hlaupa.Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Performance Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og árangur hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Hegðun | Skilaboð Rate |  | Decimal | False | Fjöldi skilaboða á tímaeiningu gegnum hluti. Þetta er summan af komandi og á útleið skilaboð allir þættir.
Hegðun | Bandwidth |  | Decimal | False | Heild bandbreidd gegnum hluti. Summa vegna bæði komandi og á útleið skilaboð.
Hegðun | Nýting | % | Decimal | False | Nýting hluti. Þetta verður 0% ef hluti er ekki tæki / örgjörva (þ.e. það þarf ekki örgjörvar og Speed ​​eiginleikar skilgreint er hér að ofan)

Tengingu Properties

Eftirfarandi tafla sýnir eiginleika sem þarf til að meta árangur. Eignir eru að leita að í fyrsta sinn í Connection tilvikum þá tengingin Standards og ef stofna ekki, sjálfgefið er notað.Þessir eiginleikar verður sýnd í Properties glugganum með eign inntak röð selector táknið ( [image] ) Með ábending 'Performance Input "eða" Kostnaður / Performance Input ". Breyting einhverju af þessum 'input' eignir og ýmsar skipulagsbreytingar við geymsla mun leiða í Performance hermir og / eða Kostnaður hermir krefjast aftur uppgerð eins og fram kemur í Red á Simulation tækjastika .

Gerð

Name

Sjálfgefna gildið

Unit

Gögn Tegund

Áskilið

Lýsing

Hegðun

Kind

tvíátta

[tvíátta | einátta]

Lookup / List

True

Hvort tenging sé tvíátta (tvíátta) eða einn-vegur (einátta).

Leyfilegar gildi fyrir þennan gististað eru "tvíátta" eða "einátta".

Tvíátta þýðir samstilltur beiðni / svar skilaboð EÐ einstefnu hætti einn ósamstilltur "atburður".

Hegðun

Abstrakt

óbeinn

[óbein | bein]

Lookup / List

True

Hvort tenging sé líkamlega eða rökrétt. Beinar tengingar eru líkamleg "rör" á milli tveggja þátta sem rökrétt tengsl streymi.

Leyfilegar gildi fyrir þennan gististað eru "bein" eða "óbein".

Ef gildið er "bein" þá tengingin þarf ekki aðra eiginleika (nema fyrir eignir Tegund og abstrakt).

Gögn

L_app1

0

Integer

False

Beiðni / atburður stærð í bætum.

Sérhver tengsl munu yfirleitt hafa sérstakt gildi fyrir þetta. Í CORBA, eru atburðir raun tvíátta og alltaf hafa a 12 bæti viðurkenna (L_app2). Ef það er satt einátta tengingu þá fara út eign L_app2.

Gögn

L_app2

0

Integer

False

Svar / viðurkenna stærð í bætum.

Sérhver tengsl munu yfirleitt hafa sérstakt gildi fyrir þetta. A einátta tengingu mun ekki hafa L_app2.

Hegðun

Tíðni

1

Decimal

True

Tíðni á tengingu á sér stað.

Sérhver tengsl munu yfirleitt hafa sérstakt gildi fyrir þetta. Ef eign Tíðni er eftir út þá er sjálfgefið notuð.

Hegðun

Sambandið

ferli

[ferli | styður]

Lookup / List

False

Tengingar sem hafa "ferli" eign til kynna að hluti í upphafi tengingu verður að breyta til að vinna á hluti í lok tengingu. Í raun er "uppspretta" hluti er flutt að verða barn í "sökkva" hluti (meðfylgjandi tengingar eru einnig "draga" með það skref).

Ef "ferli" eign til staðar er allt aðra eiginleika tengingu verður hunsað, nema valfrjálst "%" eign sem lýst er hér að neðan.

Hegðun

%

100.0

Decimal

False

Tengingar sem hafa "ferli" eign (sem lýst er hér að ofan) getur mögulega verið "%" eign til kynna hlutfall vinnslu sem er að rekja til áfangastað hluti. Á þennan hátt er einn fengið hluti er hægt að vinna með marga hluti áfangastað á ýmsum% 's. The% gildi þurfa ekki að bæta við allt að 100% og það er einfaldlega notað til að skala "vinnslu" eign (sjá hér að framan) fyrir the uppspretta hluti eins og það er umbreytt til að verða barn á áfangastað hluti.

Eftirfarandi tafla sýnir eiginleika mynda af frammistöðu evaluator. A setja af þessum tengingu eignir eru búnir fyrir hverja tengingu á hverri árangur hlaupa.Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Performance Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og árangur hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Hegðun | Bandwidth |  | Decimal | False | Í heild bandbreidd fyrir tenginguna. Þetta er aðeins reiknað fyrir óbeinum tengingar og er í meginatriðum (L_app1 + L_app2) * Afköst.
Hegðun | Bandwidth 1/2 |  | Decimal | False | Bandbreidd sérstaklega fyrir sendan (1) og komandi (2) skilaboð á tengingu. Þetta er aðeins reiknað fyrir óbeinum tengingar og er í meginatriðum L_app1 * Afköst og L_app2 * Afköst.
Hegðun | Afköst |  | Decimal | False | Fjöldi skilaboða á tímaeiningu gegnum tengingu. Þetta raunverulegt gildi má bera saman við væntanlegan / fræðilegu gildi (þ.e. tíðni) að álykta mettun kerfisins.
Hegðun | Lokið | % | Decimal | False | The prósent skilaboð sem tókst að ljúka vinnslu fyrir tenginguna. Þetta er aðeins reiknað fyrir óbeinum tengingar og er Afköst / Frequency. Stundum Lokið gildi yfir 100% vegna þess að randomness af skilaboð kynslóð leiðir örlítið hærra skilaboð kynslóð tíðni en tilgreint.
Hegðun | Svar (Min / Ave / Max) |  | Decimal | False | Lágmarks / meðaltal / hámark leynd. Þetta er aðeins reiknað fyrir óbeinum tengingar og er vart leynd fyrir tengingu frá upptökum að sökkva og allir biðröð og vinnslu (og leynd aftur til the uppspretta ef tvíátta).

Arkitektúr Properties

Eftirfarandi tafla með kerfi-breiður byggingarlistar eignir mynda af frammistöðu evaluator. A eitt safn af eignum til arkitektúr eru "samanlagður" fyrir hvern árangur hlaupa.Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Performance Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og árangur hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Hegðun | Skilaboð Rate |  | Decimal | False | Fjöldi skilaboða á tímaeiningu gegnum hluti í arkitektúr. Þetta er summan af komandi og á útleið skilaboð allir þættir.
Hegðun | Afköst |  | Decimal | False | Fjöldi skilaboða á tímaeiningu gegnum tengingar í arkitektúr. Þetta er summan af gegnumstreymi Öll óbeinum tengingar 'og þetta raunverulegt gildi má bera saman við væntanlegan / fræðilegu gildi (þ.e. tíðni) að álykta mettun kerfisins.
Hegðun | Bandwidth |  | Decimal | False | Í heild bandbreidd. Summa tengingu bandbreiddir arkitektúr er.
Hegðun | Nýting | % | Decimal | False | Nýting allra þátta. Getur verið meiri en 100% eins og það er bara summa allra hluti utilisations arkitektúr er.
Hegðun | Svar (Min / Ave / Max) |  | Decimal | False | Lágmarks / meðaltal / hámark leynd. Summa allra fram leynd fyrir tengingar arkitektúr er frá upptökum að sökkva (og aftur til uppruna ef tvíátta).


Líkja áreiðanleika og framboð

Navigation: Líkja vélina þína> Herma>

Líkja áreiðanleika og framboð

Senda athugasemdir um þetta efni.

Bakgrunnur

The Áreiðanleiki Evaluator reiknar áreiðanleika arkitektúr með því að nota inntak hluti og tengingar.

Fyrir hluti og beinna tenginga, áreiðanleiki byggist á Mean Time Milli Bilun (MTBF). Eina breytur þarf til að reikna áreiðanleika byggingarlistar þætti eru:

· The MTBFgildi (í árum);

· The Mean Time Til Gera (MTTR)bilun (í árum); og

· The afmarkað tímabil til að prófa áreiðanleika yfir.

Formúlan sem er notuð við útreikning á Áreiðanleiki er gefið sem:

Áreiðanleiki = -e (-y × aldur)
Þar sem y = 1 ÷ MTBF

Framboð á íhlutum og tengingar byggist á MTBF og MTTR. Athugaðu að framboð, ólíkt áreiðanleika, er ekki fyrir áhrifum af tíma sem það er verið að prófa.

Framboð = MTBF / (MTBF + MTTR)

Þó aðferðir sem breyta Áreiðanleika block diagrams(með einföldum röð og samhliða býr) gefa mest nákvæma niðurstöður, verða þessar aðferðir mjög imhagnýt þegar við reynum að reikna áreiðanleika fyrir verkefni innan gríðarstór net þúsunda þætti. Enn fremur, þessir umbreytingu aðferðir brjóta niður margra algengra mannvirki, svo sem net "möskva".

The Monte CarloAðferðin gerir áreiðanleika og framboð af kerfi handahófskennt stærð og flókið að reikna. The Monte Carlo aðferð líkir mörgum tilfellum og feða hver atburðarás a handahófi ríki, í boði eða ófáanlegurEr úthlutað til hvers líkamlega frumefni. Líkur á tilteknu frumefni vera í boði ríkis byggist á áreiðanleika / framboð hluti.

Til dæmis, a hluti með 90% framboð má ráð fyrir að vera í boði í um það bil 90% af tilfellum. Áreiðanleiki The óbeinum tengslum og framboð er því hægt að áætla tíðni út sem hlutfall af handahófi scenarios- sem leið þætti ríkir í boði ástand- frá upptökum að áfangastað.

Note

Þar sem útreikningur á staðbundnum tryggt og aðgangur byggist á því að mismunandi færibreytum og mismunandi formúlur (og þar sem mismunandi gildi), það er nauðsynlegt að tiltaka hverja frumefni tveirríki, eitt fyrir framboði og einn fyrir áreiðanleika. Útreikningur á framboði notar framboð ríki í hverri sviðsmynd, en við útreikning á áreiðanleika notar áreiðanleika ríki í hvert atburðarás.

Áreiðanleika evaluator notar Monte Carlo uppgerð tækni til að vinna út áreiðanleika tilteknu arkitektúr. The arkitektúr er sett í gegnum þúsundir einstakra uppgerð og niðurstöður settar í að reikna áreiðanleika mál. Eins og getið er hér að framan, Monte Carlo er the festa tækni til að líkja stærri net og mun vinna með hvaða flóknu (þ.e. meshed) byggingu.

The evaluator framleiðsla fjögur gildi:

1. Mission Áreiðanleikiá nokkrum árum;

2. Framboð af arkitektúr;

3. Áreiðanleiki af sveitarfélaga hlutiá nokkrum árum; og

4. Framboð af sveitarfélaga hluti.

The evaluator gengur líkur á að hluti eða tengingu vinna (þ.e. ekki galli) og tíminn sem á að gera.

Hvernig staðla með MTBFs og / eða MTTRs eru meðhöndlaðir

Ef þáttur (hluti eða tenging) hefur staðla úthlutað MTBF og / eða MTTR gildi er þessi gildi einnig notuð við útreikning á staðnum áreiðanleika og framboð stak í röð tengingu.

Til dæmis, ef hluti A, Með úthlutað staðla B, COg Dhver með MTBF og MTTR gildi, Local Áreiðanleiki = R(A)× R(B) × R(C) × R(D), Þar sem R = Reiknaður áreiðanleiki (með formúlunni) af hluti / staðlaog Local Gagngetu = A (A)× A (B) × A (C) × A (D), Þar sem A = Reiknaður gagngetu (með formúlunni) af hluti / staðla. Það er, ef stak hefur þrjú viðmið hver með MTBF og MTTR gildisOg einnig MTBF og MTTR gildisfyrir eignir frumefni, the heimamaður áreiðanleika og avilability er gefið með röð verðmæti hvert staðla og frumefni sjálfs.

Sem annað dæmi, Ef íhlutur Ahefur úthlutað staðla B, COg Den aðeins staðall Bhefur bæði MTBF og MTTR gildi, en staðall Chefur aðeins að MTBF gildi og staðall Dhefur aðeins að MTTR gildi, Local Áreiðanleiki = R (A)× R (B)× R (C), Þar sem R= Reiknaður áreiðanleiki (með formúlunni) af hluti / staðla og Local Framboð = A (A)× A (B)× A (C), Þar sem A= Reiknaður framboð (með formúlunni) af hluti / staðla en við útreikning (C) vegna þess að staðallinn hefur eingöngu að MTBF gildi það 'leit'fyrir samsvörun MTTR gildi (s) og mun bæta alla MTTR gildi það kemst að Don't sjálfir hafa samsvarandi MTBF gildi, þannig að í þessu tilfelli væri það notað MTTR gildi staðall D. Ef það var annar staðall, segja E, Með bara MTTR gildi eins og þá A (C)myndi nota MTBF af Cmeð MTTR af Dog Elögð saman. Ef annar staðall, segja F, Hafði bara MTBF gildi þá A (F)myndi einnig nota MTTR af Dog Elögð saman.

Reikna Mission Áreiðanleiki

Þó reikna sveitarfélaga áreiðanleika er spurning um að nota einfalda formúlu, útreikning óbeinna tengingar (verkefni) er ekki svo auðvelt, sérstaklega þegar við höfum flókin og stór net af flétta leiðum (tenging) og hluti.

Taka allt net mið

Eins og óbeinum tengingar eru ekki kynning í líkamlegu sambandi verðum við að finna út hvernig uppspretta hluti er hægt að fá að hluti áfangastað. Og í þessu felst að horfa á allt netið og öllum mismunandi vegu (og stígum) uppspretta hluti okkar getur tekið til að ná áfangastað hluti (vaskur).

Note

Svo lengi sem það er að minnsta kosti einn heillleiðin frá upptökum að áfangastað, verður verkefni að ná árangriog óbein tengsl er vísað til sem lokaði tengingunni.

Skilningur á Link Matrix

Til að vita hvaða þættir / bein tengsl eru tengd við það, sem við þurfum að Artefact að fljótt að athuga hvort tvær blokkir eru tengdir í ákveðna átt. Þetta er fall á tengilinn fylki. Í stuttu máli, the hlekkur fylki er tvívítt fylki af Boolean breytur sem segir hvort viðkomandi íhlutur getur náð Annar hluti beint. Stærð hennar er jöfn veldi af heildarfjölda hluti í netið.

A Simple Áreiðanleiki Block Skýringarmynd (RBD)

Tengdar Link Matrix fyrir áreiðanleika blokk skýringarmynd (RBD)

Sem ekki allar tengingar eru bi-stefnuvirkt (fara á báða vegu), það er mikilvægt veist hvernig á að lesa á tengilinn fylki rétt. Í áreiðanleika evaluator, fyrsta rifrildi er uppspretta og annað rifrildi er áfangastaður (vaskur).

Því ef tengilinn fylki (A, B) = True þá þýðir það að A er hægt að fá í B beint (Uni-stefnuvirkt). B getur fengið að ef aðeins ef tengilinn fylki (B, A) = True. Ef þetta er satt, þetta felur í sér báðar áttir tengingu.

Í gefið dæmi ofan:

· Source 1 getur náð áfangastað 0 (Heimild 1 og Áfangastaður 0 gefur niðurstöðu satt); og

· Source 0 getur náð áfangastað 1 (Heimild 0 og Áfangastaður 1 gefur niðurstöðu satt), sem tengslin milli 0 og 1 er tvíátta.

· Source 2 getur ekki náð áfangastað 1 (Source 2 og Áfangastaður 1 gefur niðurstöðu False), jafnvel þegar uppspretta 1 nærð áfangastað 2 (Source 1 og Áfangastaður 2 gefur niðurstöðu satt). Þetta er felur í sér að tengsl milli 1. og 2. Uni-stefnuvirkt.

Skilningur á Áreiðanleiki blokk skýringarmynd

Áreiðanleika blokk skýringarmynd (RBD) ævisaga uppbyggingu öllu mótmæla líkan í skilmálar af blokkum og tengla. Sérhver blokk táknar stak sem hefur möguleika á bilun eða velgengni samkvæmt The hlekkur / brautir sem tengja þá. Bæði efnin og tengingar geta orðið "blokk" í RBD.

Dæmi RBD Blokkir og tenglar

Myndin ofan táknar RBD dæmi. The hljóp rauða línan táknar eitt verkefni 4 til 1. athugasemdar hvernig það eru aðeins tvær mögulegar leiðir fyrir verkefni 4 til 1.

Íhuga leiðina 4 til 3 í 0 til 1, og leið 4 til 7 1. dotted blokkir 2, 5og 6 tákna blokkir sem hafa ekki áhrif á bilun / ekki bilun verkefni 4 til 1. Þeir eru ekki talin og eru hunsuð. Þetta er mikilvægt þar sem í flestum verkefnum verður fjölda óþarfi blokkir sem mun ekki hafa áhrif á árangur tiltekna sendinefndarinnar. Þetta er meira áberandi í stærri netum þar sem fjöldi óþarfi blokkir mun gera uppgerð niðurstöður ónákvæm.

Til að flýta uppgerð tíma, og tryggja nákvæmari niðurstöður, það er nauðsynlegt til að ágrip af öllu RBD og nota aðeins þá þætti sem hafa áhrif velgengni sendinefndarinnar.

Note

Ein leið / slóð getur ekki farið í gegnum hvaða hluti tvisvar.

Á þessu stigi getum við búið til tengil fylki og framkvæma Monte Carlo hermun.

Reikna Architecture Framboð

The arkitektúr framboð eru líkurnar á að allir óbeinir tengingar verða í boði á hverjum tíma. Framboð á hvers óbeinum tengslum er ákvarðað á hverjum endurtekning á Monte Carlo hermun, þó þessi óbeinu tengsl (oftast) að treysta á sama mengi af líkamlegum þáttum. Því, einfaldlega að leggja saman þessi einstaklingur availabilities myndi "tvöfaldur-telja" þessar Un-availabilities, gefa svartsýnn heild arkitektúr framboð. Einnig, í heild arkitektúr framboð er reiknað með því að horfa á hverja ítrun og sjá hvort þættir sem taka þátt í óbeinum tengingar staðir eru í boði. Og þá samtals þessar niðurstöður í lok uppgerð.

Running áreiðanleika hermir

Að líkja vélina þína í skilmálar af áreiðanleika

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Veldu Greining| Áreiðanleiki.

3. Veldu Arkitektúrþú vilt að meta frá fellilistanum.

Note

Sjálfgefið ABACUS velur sjálfkrafa fyrsta arkitektúr sem aftur-uppgerð þarf vegna hvaða undirliggjandi eignum eða skipulagsbreytinga.Þetta auðkenning er sýnt á Red á Simulation tækjastika .

4. Veldu Hlutiog Tengingarþú vilt að meta frá staðall þáttur val gluggi nota 'Sýna bein tengsl' og 'Sýna Processes tengingar' útvarp-hnappinn síur neðst til vinstri í glugganum til að aðstoða við þig vali.

Viðbótarupplýsingar Gátreitinn til staðall þáttur val gluggi

· Save umbreytt Modelmun vista afrit af RBD breytta útgáfu verkefnisins í sömu möppu og núverandi verkefni og bæta "_transformed" að nafninu verkefni.Þetta umbreytt verkefni er hægt að nota til að greina í smáatriðum áreiðanleika uppgerð ráðist af Abacus.

Viðbótarupplýsingar FjarskiptakerfiButtons til staðall þáttur val gluggi

· Sýna bein tengsl sjálfkrafa sett tenging hefur Property síu fyrir Property Type = Hegðun, nafn = abstrakt og gildi = bein.Þessi valkostur er valinn sjálfkrafa og hjálpartæki úrval af 'beinum "tengingar sem lýst er hér að ofan og neðan.

· Sýna Ferli Tengingar sjálfkrafa sett tenging hefur Property síu fyrir Property Type = Hegðun, nafn = Relationship og Value = ferli.Þessi valkostur hjálpartæki við val á "beinum" tenginga eins og lýst er hér að ofan og neðan.

5. Smelltu Næsta.

6. Velja Missionsþ.e. Tengingar þú vilt hafa með í uppgerð.

7. Stilltu Run Time Scale Factorrenna.

Note

Hærri gildi muni meira tölfræðilega samræmi niðurstöður en taka lengri tíma að reikna.

Gátreit

· Sýna Lokaðar tengingarmun sjálfkrafa síað í boði tengingar aðeins eru þeir sem hafa að minnsta kosti einn heill líkamlega leið frá upptökum hluti til áfangastaðar hluti eins og á RBD val lýst er hér að ofan.

· Sýna Óbein Connections sjálfkrafa sett tenging hefur Property síu fyrir Property Type = Hegðun, nafn = abstrakt og gildi = óbein.Þessi valkostur er valinn sjálfkrafa og hjálpartæki úrval af 'óbeinna' eða Mission tengingar eins og lýst er hér að ofan og neðan.

Buttons

· Alltvelur alla tengingar.

· InvertAfvelur allt valinn tengingar og velur alla þá sem voru ekki valdir.

· EkkertAfvelur allt tengingar.

Aðrir valkostir

· Run Time Scale Factor stýrir uppgerð tíma og nákvæmni með hærri gildi ávöxtunIngmeira tölfræðilega samræmi Niðurstöður en taka lengri tími hlaupa.

Note

Þegar ABACUS reiknar fjölda endurtekninga til að líkja það mun ákvarða áreiðanlegustu þáttur sem er ekki fullkomlega áreiðanleg og þá líkja eftir Run Time mælikvarða þáttur sinnum 1 yfir unavailability frumefni auk 1 endurtekning. Eða (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Þetta er til að tryggja að þessi þáttur ekki enn að minnsta kosti einu sinni í uppgerð. T.d. Ef áreiðanlegur þáttur sem er ekki fullkomlega áreiðanlegt hefur MTBF 10.000 tímum og MTTR 8 stundir þá uppgerð mun taka (10.000 + 8) / 8 = 1251 sinnum Run tími Scale Factor + 1 endurtekningar.

· Ár að Líkja Ahead ákvarðar fjölda ára fyrir Mission Áreiðanleiki að reikna fyrir.

· Number þræðidetermines fjöldi vinnslu þræði að nota fyrir Monte-Carlo hermun.Þessi möguleiki mun sjálfgefið að passa fjölda tiltækra Örgjörva / kjörnum (þ.mt Há þráður algerlega) til að draga úr heildar uppgerð tíma.

8. Smelltu Finishog þú munt fá a Warningvalmynd.

9. Mögulega kanna viðvaranir með því að smella Nánar >>.

10. Smelltu Halda áfram.

Note

Á þessum tímapunkti, ABACUS mun framkvæma Monte-Carloeftirlíkingu af arkitektúr og eftir stuttan tíma (með framvindu börum um álit) útreikninga heill valmynd vilja birtast.

11. Smelltu OKað viðurkenna uppgerð.

Ábending

Fyrir námskeiðum og frekari hjálp um áreiðanleika Simulation vinsamlegast vísa til Avolution Community .

Hluti og Tenging Properties

Eftirfarandi tafla sýnir hluti og"bein"tengingu eignir þarf að meta áreiðanleika. Þessir eiginleikar verður sýnd í Properties glugganum með eign inntak röð selector táknið ( [image] ) Með ábending 'Áreiðanleiki Input ". Breyting einhverju af þessum 'input' eignir og ýmsar skipulagsbreytingar við geymsla mun leiða í áreiðanleika hermir þarfnast aftur uppgerð eins og fram kemur í Red á Simulation tækjastika .

Gerð | Name | Sjálfgefna gildið | Unit | Gögn Tegund | Áskilið | Lýsing
Áreiðanleiki | MTBF | ∞ | ár, vikur, daga eða klukkustundir | Decimal | True | The Mean Time Áður Bilun í frumefni. Ath: Gildi hægt að gefa upp í einingum ára, vikur, daga eða klukkustundir og eru umreiknuð í kjölfar '24 / 7 'framboð hugtak sem hér segir; - 1 ár = 52 vikur eða 365 daga eða 8,760 klst - 1 viku = 7 daga eða 168 klukkustundir - 1 dag = 24 klst
Áreiðanleiki | MTTR | 0 | ár, vikur, daga eða klukkustundir | Decimal | True | The Mean Time Til Gera frumefnisins. Ath: Gildi hægt að gefa upp í einingum ára, vikur, daga eða klukkustundir og eru umreiknuð í kjölfar '24 / 7 'framboð hugtak sem hér segir; - 1 ár = 52 vikur eða 365 daga eða 8,760 klst - 1 viku = 7 daga eða 168 klukkustundir - 1 dag = 24 klst

Eftirfarandi tafla sýnir hluti og"bein" tengingu eignir framleiðsla af áreiðanleika evaluator. Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Áreiðanleiki Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og Áreiðanleiki hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Áreiðanleiki | Áreiðanleiki - x árum |  | Decimal | False | Líkurnar á því að þátturinn verður ekki mistakast í næstu x árin. Þetta er á milli 0 og 1.
Áreiðanleiki | Óáreiðanleika - x árum |  | Decimal | False | Líkurnar á því að þátturinn muni mistakast næstu x árin. Þetta er á milli 0 og 1.
Áreiðanleiki | Framboð | % | Decimal | False | Reiknað framboð af hluti eða tengingu. Þetta er gildi milli 0% og 100%.
Áreiðanleiki | Unavailability | % | Decimal | False | Reiknað unavailability á íhlutum eða tengingu. Þetta er gildi milli 0% og 100%.

Eftirfarandi tafla sýnir að 'óbeinn'tengingu eignir framleiðsla af áreiðanleika evaluator. Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Áreiðanleiki Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og Áreiðanleiki hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Áreiðanleiki | Mission Áreiðanleiki - x árum |  | Decimal | False | Líkurnar á því að óbeina tengingu mun ekki mistakast næstu x árin. Þetta er á milli 0 og 1.
Áreiðanleiki | Mission óáreiðanleika - x árum |  | Decimal | False | Líkurnar á því að óbeina tengingu mun mistakast næstu x árin. Þetta er á milli 0 og 1.
Áreiðanleiki | Framboð | % | Decimal | False | Reiknað framboð af óbeinum tengingu. Þetta er gildi milli 0% og 100%.
Áreiðanleiki | Unavailability | % | Decimal | False | Reiknað unavailability óbeinum tengingu. Þetta er gildi milli 0% og 100%.

Arkitektúr Properties

Eftirfarandi tafla sýnir arkitektúr eignir framleiðsla af áreiðanleika evaluator. Þessir eiginleikar verður sýnd í Properties glugganum með eign framleiðsla röð selector táknið ( [image] ) Með ábending 'Áreiðanleiki Output ". Örin á táknið mun varpa ljósi Red ( [image] ) Þegar þessar eignir eru úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla og Áreiðanleiki hermir krefst aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Gerð | Name | Unit | Gögn Tegund | Áskilið | Lýsing
Áreiðanleiki | Framboð | % | Decimal | False | Framboð af öllum óbeinum tengingar sem hafa verið með í matinu. Það er, líkurnar á því að alltóbeinum tengingar verða í boði á ákveðnum stað í tíma. Þetta er gildi milli 0% og 100%. Athugið: Þetta er EKKI margföldun einstökum availabilities tengingu eins og þetta væri "tvítalningu" SÞ-framboð af viðkomandi hlutum.
Áreiðanleiki | Unavailability | % | Decimal | False | Unavailability óbeinum tengingar sem hafa verið með í matinu. Það er, líkurnar á því að Að minnsta kosti einnóbeinn tengsl munu vera ófáanlegur á ákveðnum stað í tíma. Þetta er gildi milli 0% og 100%. Athugið: Þetta er EKKI margföldun einstökum unavailabilities tengingu eins og þetta væri "tvítalningu" SÞ-framboð af viðkomandi hlutum.
Áreiðanleiki | Mission Áreiðanleiki - x árum |  | Decimal | False | Líkurnar á því að allar óbeinna tengingar sem hafa verið með í mat verður ekki mistakast í næsta xár. Þetta er gildi milli 0 og 1. Til athugunar: Þetta er EKKI margföldun einstökum áreiðanleikastuðlarnir tengingu eins og þetta væri "tvítalningu" SÞ-framboð af viðkomandi hlutum.
Áreiðanleiki | Mission óáreiðanleika - x árum |  | Decimal | False | Líkurnar á að minnsta kosti einn af óbeinum tengingar sem hafa verið með í mati mun mistakast í næsta xár. Þetta er gildi milli 0 og 1. Til athugunar: Þetta er EKKI margföldun einstökum unreliabilities tengingu eins og þetta væri "tvítalningu" SÞ-framboð af viðkomandi hlutum.


Líkja vélina þína

Navigation: Líkja vélina þína>

Líkja vélina þína

Senda athugasemdir um þetta efni.

Þegar þú hefur fjölmennasta og greind vélina þína, þú ert tilbúinn til að nota Abacus til að ákvarða hvort arkitektúr mun mæta megindlegar þörfum þínum. Þetta krefst uppgerð. Að líkja vélina þína verður þú fyrst að ákveða hvers konar upplýsingar sem þú vilt að uppgötva. Þessar tegundir af upplýsingum er oft vísað til sem KPI er, eða helstu vísbendingar um árangur. Til dæmis, viltu greina árangur, evolvability og hreinskilni, eða viltu að safna tölfræði eins og heildarkostnaði eignarhaldi. Allar þessar upplýsingar er hægt að ljós á einhvern hátt. Þegar þú hefur þessar upplýsingar, verður þú að vera fær um að greina vélina þína í ýmsum grafísku formi (eða greina ný gildi beint).

Það eru þrír möguleikar fyrir að líkja vélina þína:

· Einföld tölfræði ;

· Pre-innbyggður herma ; eða

· Scripting .

Einföld Bragfræði

Sérhver þáttur í vélina þína hefur eiginleika - margir sem geta verið sérsniðin til umsókn þína á Abacus. Þessir eiginleikar tákna ýmsa eiginleika hluti. Í sumum tilfellum, einfaldlega safna þessar mælieiningar (til að byggja KPI er) er nóg til að segja þér mikilvægar upplýsingar um vélina þína. Til dæmis, KLOCS eða Þúsundir af línum af kóða, hafa verið mikið notuð sem mælikvarði á flókið. Í öðrum tilvikum, getur þú vilt að flytja gögn og greina hana með annað tól. Auk þess, getur þú vilt að safna eignir eftir sig annars konar uppgerð.

Eiginleika er hægt að safna í gegnum ferlið við samansafn . Samansafn bætir tilgreind undir-eiginleika samtals sem endurspeglast í foreldri hluti. Samansafn virkar aðeins á hluti sem innihalda undirþætti.

Pre-innbyggður Herma

Það eru fimm pre-innbyggður herma sem nota má við Abacus. Þessir eru:

· Árangur;

· Modularity;

· Heildarkostnaður eignarréttar (TCO);

· Hreinskilni; og

· Áreiðanleika.

Note

ABACUS sjálfkrafa varpa hver þessara herma þarf að vera aftur að keyra í gegnum Red áherslu á Simulation tækjastika .

Scripting

Scripting veitir sveigjanleika til að líkja arkitektúr í sérsniðna hátt. By skrifa handrit þú getur gert eftirlíkingar utan núverandi í byggð getu abacus. Öllu ABACUS mótmæla líkan er í boði á forskriftarþarfir vél, þannig að þú ert aðeins takmörkuð af getu þína til að skrifa handritin!

Visual Basic handrit er forskriftarþarfir tungumál studd af Abacus, þar sem það inniheldur lífsnauðsynlegar forritun lögun í tiltölulega einföldu sniði.

Sjá einnig

Útflutning vélina þína | Samanlagðar eignir | Skrifa handrit


Þróun vélina þína

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Þróun vélina þína

Senda athugasemdir um þetta efni.

Arkitektúr má skýrt þróast og stigveldi arkitektúr búin. Þannig með því að þróa vélina þína í abacus, a tala af háþróaður byggingarlistar lausnir er hægt að skapa, samanborið og baselined. Markmið (eða mælieiningar) er hægt að skilgreina fyrir hvaða fjölda byggingarlistar eignir fyrir núverandi arkitektúr.

Einföld leið til að fjalla um þróun arkitektúr er að tengja það hugtakinu afkomandi arkitektúr. Þegar arkitektúr er þróast, a Afritamóðurfélags arkitektúr er búin. Þetta eintak er hægt að segja að vera bein afkomandiaf upprunalegu foreldriarkitektúr.

Note

Í þessu á netinu hjálp gagna og abacus verkfæraskúr sjálft, hugtakið þróaster oftast notað en hugtakið afkomandiVinsamlegast athugið að bæði vísa til sömu virkni.

Að þróast núverandi arkitektúr

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopna og Explorer gluggabirtist.

2. Veldu viðeigandi arkitektúr þú vilt að þróast frá landkönnuður tré.

3. Hægrismellaum uppbyggingu og veldu Þróastúr valmyndinni.

Þróun The Chosen Architecture

4. The þróast arkitektúr mun birtast undir völdu arkitektúr.

Þróast Architecture

Note

The þróast arkitektúr má endurnefna með því að hægri smella á arkitektúr og val Endurnefna.Einnig hafa allir skýringarmyndir og bæklingum í þróaðist arkitektúr sjálfkrafa stillt á "breyting" gegn grunnspánni arkitektúr að það var þróast frá.

Setja markmið fyrir þróast vélina þína

Setja markmið fyrir þróast arkitektúr þitt leyfir þér að búa til viðmiðanir til að meta þróun arkitektúr þínum. Markmið eru ákvörðuð af hótelinu tegundir og nöfn þeirra eiginleika sem í þróaðist vélina þína. Markmið getur einnig verið handvirkt skilgreind og bætt við þér arkitektúr. Fylgdu skrefunum hér fyrir neðan til að setja sér markmið.

Setja mörk núverandi eignir fyrir þróast vélina þína

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopna og Explorer gluggabirtist.

2. Veldu Tools | Setja markmiðFrá aðalvalmynd bar.

3. The Markmið Inntakgluggi birtist.

Markmið Inntak Window

4. Smelltu á Núverandihnappinn.

5. The Veldu eigngluggi birtist.

6. Veldu eign sem þú vilt nota sem markmið fyrir þróast vélina þína og smelltu á OKhnappinn.

7. Völdu Markmiðið munu nú birtast í Markmið Inntakglugga.

8. Veldu mark og smella á Breytahnappinn.

9. The Edit Goalgluggi birtist.

Note

Þetta gluggi gerir þér kleift að breyta eign heiti og tegund að markmiðið mun endurspegla, eins og heilbrigður eins og the versta og besta gildi (eða umsamið hámarks- / lágmarksverð gildi) fyrir eigninni. Þessi gildi eru að finna með því að bera alla arkitektúr og finna minnstu og stærsta gildið í hvert fyrir að tiltekin eign. Þessi gildi er einnig hægt að handvirkt skilgreind. Til dæmis, ef þú varst að setja sér markmið fyrir eign heitir Svörun (Ave)og tegund Hegðun, Versta og besta gildi þitt gæti endurspegla viðskipti hraða sem þarf til að ná hámarksafköstum (besta gildi) og viðskipti hraða þarf fyrir aðeins helstu forrit sem á að verka (versta gildi).

10. Þegar viðeigandi gildi hafa verið skilgreind, velja OK.

Setja mörk nýjar eignir fyrir þróast vélina þína

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopna og Explorer gluggabirtist.

2. Veldu Tools | Setja markmiðFrá aðalvalmynd bar.

3. The Markmið Inntakgluggi birtist.

4. Smelltu á Newhnappinn.

5. The New Goalgluggi birtist.

Note

Þetta gluggi gerir þér kleift að skilgreina eign heiti og tegund að markmiðið mun endurspegla, eins og heilbrigður eins og versta og bestu gildi (eða lágmarks / hámarks gildi) fyrir eigninni. Til dæmis, ef þú varst að setja sér markmið fyrir eign sem heitir Svörun (Ave)og tegund Hegðun, Versta og besta gildi þitt gæti endurspegla viðskipti hraða sem þarf til að ná hámarksafköstum (besta gildi) og viðskipti hraða þarf fyrir aðeins helstu forrit sem á að verka (versta gildi).

6. Þegar viðeigandi gildi hafa verið skilgreind, velja OK.

7. A valmynd til Bæta öllum arkitektúrmun birta hér fyrir neðan:

8. Smelltu á Jáað bæta við marki sem eign til allra viðeigandi arkitektúr. Þetta tryggir að nýlega skilgreint markmið og eiginleikar þess verður bætt við öllum arkitektúr í skrá. Ef þú vilt ekki fela í sér eign í arkitektúr, getur þú smellt á No.

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Skoða stjarna söguþræði þróast arkitektúr þínum | Skoðar scatter söguþræði þróast arkitektúr þínum


Aukin og hrynja tré

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Aukin og hrynja tré

Senda athugasemdir um þetta efni.

Þegar hnút í trénu inniheldur undirþætti og söfn, það verður lítið [image] eða [image] skilti á vinstri hennar. Þú getur smellt á [image] að auka hnút og sjá til þess undirþætti og tengingar. Á sama hátt, þú getur smellt á [image] að hrynja hnút til að fela undir-hluti og tengingar (í því skyni að gera meira pláss eða gera tré auðveldara að skilja).

Einnig er hægt að auka heilt hnút, en þá öllum undir-hnúta verður einnig stækkað og undir þeirra hnúður, og þeirra ... etc Á sama hátt, þú getur hrunið heilt hnút - lokun mörgum stigum í einu .

Auk þess eru möguleikar til að auka aðeins arkitektúr, þætti (þ.e. hluti og tengingar), hluti eða tengingar.

Til að auka eða draga heilt hnút (og undirvísitölur hennar hnúður, osfrv)

1. Hægrismellaá hnút.

2. Veldu Stækka | Allt eðaCollapse.

Til að auka öllum arkitektúr (s)

1. Hægrismellaá arkitektúr eða arkitektúr.

2. Veldu Stækka | Allt.

Til að auka þætti

1. Hægrismellaá arkitektúr eða arkitektúr.

2. Veldu Stækka | Elements.

Til að auka hluti

1. Hægrismellaá hlutum, íhluti eða undir-hluti.

2. Veldu Stækka | Hluti | Allt.

Til að auka tengsl

1. Hægrismellaá Tengsl, tengingu eða undir-tengingu.

2. Veldu Stækka | Tengingar | Allt.


Útflutning Architecture þitt

Navigation: Skýrslur um arkitektúr þinn>

Útflutning Architecture þitt

Senda athugasemdir um þetta efni.

ABACUS gerir þér aðflytja vélina þína til að MDB (Microsoft Access), MS SQL Server, .abacus (ABACUS skrá), og .xls (Microsoft Excel) sniði. Þú getur einnig flutt þinn skýringarmynds til PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF og BMP snið og skýrslum til .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) og Rtf (Rich Text Format) snið. Þetta gerir þér kleift að greina og skoða arkitektúr og gögn á nokkurn hátt sem þú vilt.

Að flytja vélina þína til að MDB (Microsoft Access)

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Smelltu á Filemenu.

3. Veldu Export, og svo Til MDB.

4. Taka mið af viðvörun og smelltu OK.

5. Sláðu inn heiti fyrir skrá.

6. Smelltu á VistaButton.

Note

Útflutningur snið af MDB gagnasafn er sérstaklega við Abacus og hvaða stefið breytingar munu leiða til vanhæfni til að tilvísun til-innflutningur. Vinsamlega sjá Populating með MS Access fyrir lýsingu á MS Access stefið.

Að flytja vélina þína til að MS SQL Server

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Smelltu á Filemenu.

3. Veldu Export, og svo Til MS SQL Server.

4. Í glugganum sem birtist smella á Export Blank MDB ...hnappinn og flytja þetta inn í þinn MS SQL Server gagnagrunn miðlara.

5. Fylla í gagnagrunni upplýsingar og tengingu band.

6. Smelltu á ExportButton.

Note

Útflutningur snið af MS SQL Servergagnagrunnur er sérstaklega við Abacus og hvaða stefið breytingar munu leiða til vanhæfni til að tilvísun til-innflutningur. Vinsamlega sjá Populating með MS Access fyrir lýsingu á stefið gagnagrunninum.

Að flytja vélina þína til að .xls (Excel skjal)

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin , An landkönnuður birtist , Og An arkitektúr bætt .

2. Tryggja þú hafa óákveðinn greinir í ensku Excel Import / Export Configuration File skilgreint.

3. Hægrismellaá arkitektúr í líkan eða hluta af Hlutihnút (innan ákveðins arkitektúr) þú vilt flytja til Excel stillingaskránni.

4. Veldu Export | Til Excel ... úr valmyndinni.

5. The Veldu Excel Import / Export stillingaskrá til að notagluggi verður birt.

6. Veldu viðeigandi stillingar skrá fyrir byggingar fyrirmynd og smelltu á Openhnappinn.

7. Ef ekki sjálfkrafa gert, Kort efsta stigi hluti í núverandi arkitektúr þín til Set Id(eins og skilgreint er) og smelltu á Export ....

Dæmi Top-Level Component Kortlagning

8. Veldu staðsetningu og skráarnafn fyrir Excel skrá og smelltu á Vistahnappinn.

Að flytja vélina þína til að .abacus (ABACUS skrá)

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Hægrismellaá Architecture hnút, allir arkitektúr í líkaninu eða einhver hluti Hluti tré.

3. Veldu Export | Til Skrá ...úr valmyndinni.

4. Veldu staðsetningu og skráarnafn og smelltu á Vistahnappinn.

Note

Þú getur flutt inn Abacus skrá aftur inn Abacus með eftirfarandi skrefum 1-2ofan og velja síðan Innflutningur | Frá Skrá .... Eftir að þú hefur valið skrána sem þú vilt flytja inn, verður þú beðin hvernig þú vildi eins og til að flytja staðla og gerðum. Þú getur flutt staðla og gerðir sem annað hvort ný eða sameinuð staðla og gerðum. Sjálfgefin stilling er að staðla og gerðir til að vera sameinuð gildandi stöðlum og gerðum ef þær eru til nú þegar í þinn Verkefnið.

Að flytja vélina þína til XML

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Hægrismellaá Architecture hnút, allir arkitektúr í líkaninu eða einhver hluti af Component tré.

3. Veldu Export | Til XML ...úr valmyndinni. Einnig er hægt að smella á valmyndina File| Export| Til XML ...

4. Veldu staðsetningu og skráarnafn og smelltu á Vistahnappinn.

Note

Þú getur flutt XML skrá aftur inn Abacus með eftirfarandi skrefum 1-2ofan og velja síðan Innflutningur | Frá XML .... Eftir að þú hefur valið XML skrá sem þú vilt flytja inn, verður þú beðin hvernig þú vildi eins og til að flytja staðla og gerðum. Þú getur flutt staðla og gerðir sem annað hvort ný eða sameinuð staðla og gerðum. Sjálfgefin stilling er að staðla og gerðir til að vera sameinuð gildandi stöðlum og gerðum ef þær eru til nú þegar í þinn Verkefnið.

Að flytja skýringarmynd til PNG, JPG, SVG, TIFF, GIF eða BMP

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Opna skýringarmyndþú vildi eins og til að flytja.

3. Smelltu á Export Diagramhnappinn á Skýringarmynd tækjastiku.

4. The Export Skýringarmyndgluggi vilja birtast.

5. Veldu Flokkahnappinn til að vista visualization í viðkomandi stað.

6. Veldu Vista sem tegunddraga-dúnn matseðill til að velja the skrá tegund.

7. Smelltu á Vistahnappinn.

Að flytja skýrsluna til .pdf (Adobe Acrobat), .xls (Microsoft Excel)eða.doc (Microsoft Word)

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Búa til Skýrsla þú vildi eins og til að flytja.

3. Smelltu á Exporthnappinn á skýrslur stikunni.

4. Veldu Excel, PDF eða Wordfrá fellilistanum.

5. Bíddu í smá stund á meðan skýrslu útflutningi.

6. Veldu staðsetningu og skráarnafn og smelltu á Vistahnappinn.


Finna og skipta liði í vélina þína

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Finna og skipta liði í vélina þína

Senda athugasemdir um þetta efni.

Þú finnur og Skipta sérstakur hluti, tengingu, tegund, staðall eða eign með því að nota Abacus 'Finna og Skipta leikni.

Til að finna hlut

1. Smelltu á hnút af trénu sem þú vilt að leita innan.

2. Veldu Breyta| Finnaeða ýttu Ctrl + F.

3. Sláðu inn texti fyrir hluturinnað finna í 'finna það sem "sviði.

4. Smelltu Finna næsta.

Til skipta hlut

1. Smelltu á hnút af trénu sem þú vilt að leita innan.

2. Veldu Breyta| Skiptaeða ýttu Ctrl + H.

3. Sláðu inn texti fyrirhluturinnað finna í "Finna hvað reitur og texta til að skipta um það með í" Skipta með 'sviði (eða ekkert ef sviði er skilinn eftir auður).

4. Smelltu Finna næstaað finna fyrstu eintak af "Finna hvað texta og smella Skipta að skipta út þessu dæmi með "Skipta með texta eða smella Skipta öllumað skipta öllum tilvikum.

Þú hefur valkosti til:

o Passa mál sitt,

o Finna allt orðið,

o Leita í upphafi verkefnisins,

o Hunsa arkitektúr - sem er arkitektúr hnúður sig. Allar hnútar undir arkitektúr hnúður eins og hluti og tengingar mun enn vera leitað,

o Hunsa hluti - það er hluti hnúður sig,

o Hunsa tengingar - það er tenging hnúður sig,

o Hunsa staðla - sem er allt arkitektúr, hluti og tengingu staðall hnúður verður hunsað,

o Hunsa tegundir - sem er gerð hnúður sig. Þvingun hnútar neðan af gerðinni hnúta mun enn vera leitað,

o Hunsa sniðmát og innihald - það er sniðmát hnúður sig eins vel og allir sniðmát hluti og tenging hnúður undir þeim,

o Hunsa eiginleika - sem er allt tegundir gististaða, nöfn, gildi og einingar allra þátta líkansins verður hunsað,

o Hunsa lýsingar - það er lýsingar á öllum þáttum líkansins verður hunsað.

Sjá einnig

Hvernig er arkitektúr fulltrúa í Abacus


Hjálp á öðrum tungumálum

Navigation: Inngangur að Abacus>

Hjálp á öðrum tungumálum

Senda athugasemdir um þetta efni.

ABACUS hjálp er í boði á ýmsum öðrum tungumálum / þýðingar og má nálgast tenglana hér fyrir neðan.

Til í stað núverandi Abacus hjálpa skrámeð þýddu hjálpa skrá skaltu fylgja þessum skrefum:

1. Vistaðu hjálpa skrá frá viðkomandi tengilinn hér að neðan.

2. Endurnefna hjálpa skrá til ABACUS.chm.

3. Opna skrána með því að tvísmella á það og ef 'Open File - Security Viðvörun' valmynd birtist þá óhindraður the "alltaf spyrja áður en þú opnar skrá" valmöguleikann og smellt á Open.

4. Loka skrá.

5. Settu ABACUS.chm skrá í Abacus Program Files möppunni, oftast "C: \ Program Files \ Avolution \ ABACUS"Eða"C: \ Program Files(x86)\ Avolution \ ABACUS".

Note

Samhengi næmur hjálpa mun halda áfram að vinna með þýddum hjálparskrár.

Abacus hjálparskrár á öðrum tungumálum:

· Arabic / العربية .

· Bulgarian / български .

· Chinese (Simplified) / 中文 (简体) .

· Czech / Česká .

· Danska / Dansk .

· eistneska, eisti, eistneskur / Eesti .

· Finnish / Suomen .

· French / Français .

· þýska, Þjóðverji, þýskur / Deutsch .

· ungverska, Ungverji, ungverskt / Magyar .

· Íslenska / Íslenska .

· Indonesian / Indonesia .

· Italian / Italiano .

· Japanese / 日本 の .

· Latvian / Latvijas .

· Malaysian / Malaysia .

· Maltese / Malt i .

· Norweigen / Norweigen .

· Pólska / Po lska .

· Portúgalska / Português .

· rússneska, Rússi, rússneskur / русский .

· Slovak / Slovenčina .

· Slovenian / Slovenčina .

· spænska, Spánverji, spænskur / Españoles .

· Swedish / Svenska .

· Turkish / Türk .

· Welsh / Cymraeg .

Sjá einnig

Hvað þýðir ABACUS gera?


Hvernig er arkitektúr fulltrúa í Abacus?

Navigation: Inngangur að Abacus>

Hvernig er arkitektúr fulltrúa í Abacus?

Senda athugasemdir um þetta efni.

Í abacus, þú fyrirmynd vélina þína. Fyrir einfaldleiki, við köllum þetta byggingarlistar líkan arkitektúr.

Myndin hér að neðan sýnir hvernig dæmigerður arkitektúr 5hluti (í stigveldi) tengdur með 2 tengi væru gerð abacus.

Hvernig einföld arkitektúr er táknuð í Abacus

Þú getur haft hvaða fjölda arkitektúr í einni Abacus skrá.

Fyrsti arkitektúr í trénu

Venjulega, viltu búa til nýja arkitektúr þegar þú vilt að meta breytingar. Til dæmis, þú vilt fyrirmynd núverandi arkitektúr fyrst - þetta væri fyrsta arkitektúr í trénu. Þú gætir kalla það 'Núverandi'.

Sekúndan

Þegar þú vilt að fyrirmynd og meta breytingu á núverandi vélina þína (td ef þau verða kröfur) sem þú vilt búa til nýjan arkitektúr. Auðveldasta leiðin til að gera þetta væri að búa til afrit af 'Núverandi' og endurnefna það "Evolution 1 Tilraun 1 '. Þetta væri annað arkitektúr í trénu. Ef mat á því "Evolution 1. Tilraun 1 'eru vel hægt að endurnefna það til einfaldlega" Evolution 1'.

Þriðja

Ef 'Evolution 1 Tilraun 1' er ekki að fullnægja þörfum þínum, getur þú búið til afrit af því, endurnefna það til "Evolution 1 Tilraun 2 ', og reyndu aftur. Þetta myndi vera þriðji arkitektúr í trénu.

Sjá einnig

Hvað þýðir ABACUS gera? | Hvernig þú gerir það (Yfirlit) | Hvað er arkitektúr? | Vinna með Abacus skrár | Búa til eða endurtekning arkitektúr


Hvernig á að nota Abacus (yfirlit)

Navigation: Inngangur að Abacus>

Hvernig á að nota Abacus (yfirlit)

Senda athugasemdir um þetta efni.

Þetta viðfangsefni gefur undirstöðu yfirlit yfir helstu verkefni sem taka þátt með því að nota abacus.

Eftirfarandi skýringarmynd sýnir arkitektúr byggir greiningu ferli sem ABACUS kveður á um þróun núverandi arkitektúr í nýja eða miða arkitektúr.

Abacus Process

Til að nota Abacus:

1. Endurskoðun - Áður en þú notar abacus, verður þú að safna öllum upplýsingum sem þú þarft um arkitektúr og kröfur sínar.

· Arkitektúr - Geti gert hluti af arkitektúr og hvernig þeir hafa samskipti. Það ætti aðeins að vera nokkur hluti á efsta stigi. Þetta eru kallaðir "ómissandi hluti". Jafnvel flóknustu arkitektúr ættu að hafa minna en 10 helstu íhluti. t.d. The Essential Hluti af arkitektúr vátryggingafélags getur verið stefnu, kvittanir, kröfur og greiðslur.

· Kröfur- Þú þarft að vita hvað er ætlast af arkitektúr í því skyni að ákvarða hvort það er fullnægjandi. t.d. Fjöldi viðskipta á klukkustund.

· Hvar þú finnur það? - Þessar upplýsingar geta komið frá kröfur upplýsingar, skjöl hönnun, viðtöl við hagsmunaaðila á vettvangi kóða o.fl. grundvallaratriðum eitthvað efni sem er í boði býður Abacus upplýsingar um arkitektúr.

2. Byggja -Notaðu Abacus til líkan arkitektúr og að tilgreina kröfur arkitektúr verður mæld á móti.

· Arkitektúr - Í Abacus þú byrjar út með tóman arkitektúr - þú þarft að byggjaþað. Þetta þýðir að slá öll arkitektúr upplýsingum safnað ofan. Þú getur byggja vélina þína handvirkt (með the réttur-smellur matseðill), eða þú getur byggja það sjálfkrafa (frá Microsoft Visio, Excel, Access etc). Venjulega efstu mest stigum (meira abstrakt) af arkitektúr verður byggð höndunum og lægri stigum (meira steypu) verður byggð sjálfkrafa.

· Kröfur - Eins og þú bætir hluti þinn og tengingar, þú tilgreinir eiginleika þeirra. Í flestum tilvikum hafa þessar eignir verða kröfur arkitektúr. Til dæmis, ef þú vilja hafa a 1250 MIPS hnút / þyrping, myndir þú bæta hnút sem hluti, þá bæta árangur eign, og úthluta gildi 1250 MIPS.

3. Greina - Notaðu Abacus að glæsilegur greina og sjón flókin uppbyggingu vélina þína.Þú er hægt að greina vélina þína í nokkra vegu eða frá fjölda sjónarmiða, þar á meðal skýringarmyndir, 3D og Explorer. Einnig getur þú vilt nota við fleiri hafa skoðanir sem hér segir:

· Mynd vélina þína - að fá árangur (viðbragðstíma, bandbreidd, o.fl.), kostnaður (bar, baka, osfrv) eða evolvability (getu rúm, málamiðlun, osfrv) skoðanir.

· Búa til skýrslu um vélina þína.

4. Líkja - Notaðu Abacus að líkja arkitektúr þíns árangur, framboð, kostnað, hreinskilni, osfrv

· Til að gera þetta, hlaupa einn af simulators. ABACUS metur þitt arkitektúr gegn þörfum þínummeð því að framkvæma eftirlíkingu. Það les og greinir núverandi arkitektúr, keyrir uppgerð, og reiknar sér nýja eiginleika. Þessir eiginleikar eru síðan vistaðar til baka arkitektúr. Nýju eignir eru gögn sem þú ert að reyna að greina, svo sem nýtingu, svar tími, bandbreidd,% framboð, TCO osfrv

5. Verkfræðingur- Nota ABACUS að svara ýmsum "hvað ef" aðstæður og stjórna þróun vélina þína. Engineering er ferli endurtaka Byggja - Greina - Líkjahringrás.

· Á þessum tímapunkti, þúheflíklega þróað með sér skilning á núverandi Arkitektúr og lögð áhersla á svæði sem þú þarft til að þróast. Oft þó, þú þarft að endurtaka byggja - Greina - Líkir ferlið nokkrum sinnum. Þetta mun líklega vera vegna þess að það getur tekið nokkrar endurtekningar áður en þú finnur Target Architecture. Einnig, ef arkitektúr er mjög flókið, getur þú vilt að endurtaka ferlið fyrir hvert byggingarlist "stigi".

6. Planframtíð arkitektúr með því að nota upplýsingar frá Abacus.

Note

Ef þú ert ekki að reyna að þróast núverandi arkitektúr, getur þú þurft að endurtaka nokkrum skrefum nokkrum sinnum, og í annarri röð. Það fer eftir því hvað þú ert að reyna að gera. Til dæmis, ef þú ert að hanna nýja arkitektúr, þú munt sennilega bara byggja vélina þína einu sinni, og þá nota Abacus yfir langan tíma til að leiða frekari þróun (s) af arkitektúr. Á hinn bóginn, ef þú ætlar að kaupa nýja arkitektúr og hafa nokkra möguleika til að velja úr, þú þarft að finna og Byggja fyrir hvert val, og þá Greina og Líkja hver óháð áður framkvæma endanlega samanburð á the endir.

Sjá einnig

Hvað þýðir ABACUS gera? | Hvað er arkitektúr? | Hvernig er arkitektúr fulltrúa í Abacus? | Populating vélina þína | Greina vélina þína | Líkja vélina þína


Flyt inn Arkitektúr þitt

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Flyt inn Arkitektúr þitt

Senda athugasemdir um þetta efni.

ABACUS gerir þér að flytja inn arkitektúr þinn úr rannsókn .abacus (ABACUS skrá), .xml (sem ABACUS XML brot eða ArchiMate Interchange Language XML skrá), .vsd (Microsoft Visio) snið, og .xls (Microsoft Excel) sniði. Þetta gerir þér kleift að byggja vélina þína frá utanaðkomandi aðilum fljótt.

Til innflutningur arkitektúr þinn frá.abacus (ABACUS skrá)

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Hægrismellaá Architecture hnút, allir arkitektúr í líkaninu eða einhver hluti Hluti tré.

3. Veldu Innflutningur| Frá Skrá ...úr valmyndinni.

4. Veldu staðsetningu og sem .abacus skrá og smelltu á Openhnappinn.

Note

Eftir að þú hefur valið skrána sem þú vilt flytja inn, verður þú beðin hvernig þú vildi eins og til að flytja staðla, tegundirog sjónarmið. Þú getur flutt staðla, tegundir og sjónarmið sem annaðhvort nýtt eða sameinuðu staðla, tegundirog sjónarmið. Sjálfgefin stilling er fyrir staðla, tegundir og sjónarmið að sameinast gildandi stöðlum, tegundir og sjónarmið ef þeir eru fyrir hendi þegar (með sama nákvæmlega nafn) í þinn Verkefnið.

Til innflutningurarkitektúr þinn frá.xml (sem ABACUS XML brot eða ArchiMate Interchange Language XML skrá)

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn.

2. Hægrismellaá Architecture hnút, allir arkitektúr í líkaninu eða einhver hluti af Component tré.

3. Veldu Innflutningur| Frá XML ...úr valmyndinni.

4. Veldu staðsetningu og sem .xml skrá og smelltu á Openhnappinn.

Note

ABACUS mun aðeins flytja inn rétt mynduð Abacus XML brot eða ArchiMate Interchange Tungumál XML skrá. Eftir að þú hefur valið XML skrá sem þú vilt flytja inn, verður þú beðin hvernig þú vildi eins og til að flytja staðla, tegundirog sjónarmið. Þú getur flutt staðla, tegundir og sjónarmið sem annaðhvort nýtt eða sameinuðu staðla, tegundirog sjónarmið. Sjálfgefin stilling er fyrir staðla, tegundir og sjónarmið að sameinast gildandi stöðlum, tegundir og sjónarmið ef þeir eru fyrir hendi þegar (með sama nákvæmlega nafn) í þinn Verkefnið.

Til innflutningurarkitektúr þinn frá.VSD(Visioskrá)sjá hér .

Til innflutningurarkitektúr þinn frá.xls (Excel skjal)sjá hér .


Flyt gerðir og staðla frá bókasafni

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Flyt gerðir og staðla frá bókasafni

Senda athugasemdir um þetta efni.

Þú getur flutt gerðir og staðla frá Abacus bókasafn skrá. Þú getur einnig flutt gerðir og staðla frá Abacus skrá til Abacus bókasafn skrá.

Til að flytja tegundir og staðla frá bókasafni í vélina þína

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopna og Explorer gluggabirtist.

2. Veldu File | OpenTil að opna ABACUS bókasafn skrá.

3. Abacus Library opnast í öðrum flipanum lak í Explorer glugga og þú verður að undock þessa flipanum blaði að vera fær um að draga-og-sleppa frá því að upprunalega Abacus skrá.

4. Draga og sleppagerðir og staðlar frá bókasafninu í vélina þína.

- Eða -

1. Veldu File | New ...

2. Búa til nýjan ABACUS skrábyggt á ABACUS bókasafn skrá.

Að flytja tegundir og staðla frá vélina þína í bókasafn

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopin, þá Explorer gluggabirtist, sem ABACUS bókasafn skráopna og Bókasafn Windowbirtist.

2. Draga og sleppagerðir og staðla frá vélina þína í safninu.

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt


Abacus tengi

Navigation: Inngangur að Abacus>

Abacus tengi

Senda athugasemdir um þetta efni.

Þegar þú byrjar abacus, munt þú sjá helstu skjár, sem er tóm, nema fyrir valmyndir og tækjastika efst, tómt Explorer glugga og titlinum-bar. Þessi skjár verður miðstöð samskiptum þínum við Abacus.

Helstu þættirnir eru:

· helstu valmyndir

· the tækjastika

· the réttur smellur matseðill

· The Explorer og eign glugga

· stöðustikuna

Helstu valmyndir

The valmyndir eru raðað í rétta röð.

The valmyndir eru sem hér segir;

· File menu- The File valmynd leyfir þér að búa til, opna, loka, vista, útflutningur og birta Abacus skrár. Það leyfir þér einnig að búa til, opna, loka og vista ABACUS skrám safnsins.

· Valmyndin Breyta- The Edit valmynd leyfir þér að skera, afrita, líma, eyða, endurnefna, finna og raða þættiog losa / endurtaka aðgerðir.

· View menu- The View valmynd leyfir þér að opna eða loka ýmsum tengi Windows og stöðuslá, Sigla fram og til baka, fara í sérstakar skoðanir og stjórna mælaborð.

· Insert menu- The Setja valmynd leyfir þér að bæta við nýjum staðlar, Sniðmát, tegundir, þættir, skoðabendas, Bæklingum, skýringarmyndir, töflur, Skýrslur og fylkjum.

· Greining menu- The Analysis valmynd leyfir þér að keyra mat gegn arkitektúr, meðal annars; flutningur, kostnaður, áreiðanleiki, sveigjanleiki og víðsýni.

· Tools valmyndina- The Tools valmynd leyfir þér að keyra forskriftarþarfir, setja markmið fyrir arkitektúrog framkvæma og arkitektúr "breyting". Þú getur líka breytt valkosti áætlunarinnar og sérsniðið viðmót frá tól valmyndinni.

· Window valmyndinni- The Window valmynd leyfir þér að bryggju, raða, sýna og fela gluggakista þú hefur opinn.

· Hjálp valmyndinni- Í valmyndinni Hjálp þú getur fengið aðgang að Abacus hjálpa skrá. Þú getur fengið aðgang að vefsíðu, skoða þinn leyfi samkomulag og skoða almennar upplýsingar um Abacus þ.mt útgáfa af the hugbúnaður og abacus aðstoð og upplýsingar um tengiliði. Þú getur veitt endurgjöf í gegnum málið tilkynningu síðunni. Ef þörf er á, getur þú slærð inn skráning lykill gegnum Hjálp valmyndinni.

Þetta er til þess að þú munt yfirleitt fylgja þegar þú ert vopnaður út verkefni;Þegar þú hefur búið til eða opnað skrá, Þú munt yfirleitt byggja vélina þína, þá útsýniþað (í Explorer, skýringarmyndir, 3D, Charts, etc). Á þessum tímapunkti, þú munt annað hvort keyra evaluator, Eða þú munt endurtaka ferlið með sama arkitektúr eða mismunandi arkitektúr. (Sjá Hvernig á að nota Abacus (yfirlit) fyrir frekari upplýsingar.)

Líttu í gegnum aðalvalmynd og reyna að ímynda sér hvernig þú munt eiga þau að vélinni þinni.

Note

Þú getur Sérsníða valmyndir hvenær sem er.

Tólastikurnar

Sjálfgefið eru eftirfarandi tækjastika;

· Main tækjastika -

· að Simulation Toolbar -

· á View tækjastika -

· að Skýringarmynd tólBar (ef skýringarmynd er opið) -

· efnahagslegu Recording Toolbar -

Líttu í gegnum hnappa á hverju tækjastikunni því að sveima yfir þeim til þess að sjá Tool-þjórfé (flýtileið-lykil).

Note

Einungis tilteknum hnappar verða virkir eftir því hvað þú hefur valið í Explorer glugga og þú getur Sérsníða Tólastikurnar hvenær sem er.Auk, 'Staðfesta / Athugaðu Project þvingun' hnappinn á Main stikunni og hnappar á Simulation stikunni mun varpa ljósi Red þegar breyting á undirliggjandi geymsla krefst aftur staðfestingu á verkefni eða aftur eftirlíkingu af því hermir hins vegar. Sveima yfir hnappinn til að sjá hvaða arkitektúr eru í húfi.

Hægri-smelltu á valmyndina

Helstu valmyndir og tækjastika eru ekkinota fyrir allt, þó. Það er oft þægilegra að nota the réttur-smellur samhengi matseðill fyrir ýmsum aðgerðum. (Einnig, ekki allir skipanir í gegnum hægri smell eru í boði í gegnum helstu valmyndir, tækjastika, eða lyklaborð skipanir.)

Til dæmis, þegar þú hefur búið til skrá, og þú hafa a tré skýringarmynd af vélina þína, það er betra að hægri-smella á arkitektúr í tré til að bæta við nýrri arkitektúr. Á sama hátt, ættir þú hægri-smellir á hlutum til að bæta við nýrri hluti. Hægri-smelltu á nokkur atriði í tré til að sjá hvað þú getur gert.

Ábending

Almennt, þú munt nota helstu valmyndir til að framkvæma fleiri háttsettum verkefni, eins og mat vélina þína. The lágmark-láréttur flötur verkefni - eins og að bæta einstaka þætti og tengsl - er gert með því að nota tækjastika og / eða hægri-smelltu á valmyndina.

The Explorer og eignir Windows

Þegar þú opnar eða búa til skrá, tré skýringarmynd birtist í Explorer glugga. Það er gluggi inn í vélina þína. Og eins og þú velur þætti innan Explorer glugga þrír aðrar rúður; hinum almennu PropertiesTilvísanirog eignir Windows mun uppfæra til að endurspegla ítarlegum upplýsingum um val þitt.

Note

Almennar PropertiesTilvísanirog Properties gluggar eru falin sjálfgefið. Sjá Aðlagaðu tengi fyrir hvernig að Birta þá og hugsanlega láta þá varanlega birtist.

Á meðan þú ert að byggja vélina þína, the Explorer og Properties gluggar eru mest að gagni framsetning. Vegna þess að þeir geta vera hrundi og stækkað eftir þörfum, og þeir verða ekki fyrirferðarmikill.

The Explorer glugga hefur tré (og stöðu bar) og Properties gluggar hafa 5kafla:

· Gerð

· Standards

· Lýsing

· Tilvísanir

· Properties

ABACUS telur alla þessa hluti til að vera hluti af arkitektúr.

Tree

Þessi hluti hefur tré flokkuð í 3 svæði eins og hér segir:

1. Meta-líkan

· Standards- Ef fjölmargir þættir hafa sama mengi eiginleika, er hægt að skilgreina sett upp fyrir framan, og þá bara tengja það að hlutunum. Hið sama gildir um tengingar og eitthvað af öðrum þáttum. Þetta setur af stöðluðum eiginleikum eru geymdar í Standardsútibú tré. Í stað þess að skilgreina hvert eign fyrir hvern efnisþátt og hvert eign fyrir hvern tengingu etc, bara úthluta staðall. Til dæmis staðlaða eiginleika Unix-HP / UXhægt að vista sem a Standard og úthlutað til hvers konar hluti sem nota á Unix-HP / UXstýrikerfi eins og sýnt fyrir OS01 Miðlarinn í screenshot ofan.

· Tegundir - Þessi grein af trénu er bókasafn af the tegund af íhlutum og tengingar sem þú getur notað. Séu notaðar til að skilgreina meta-líkan fyrir vélina þína og fyrir flokkun og síun þegar skoðuð vélina þína. Þeir ákveða einnig sniðmát fyrir hvað staðlar, Eiginleika og takmarkanir Hluti Þinn / tengingar geta haft.

· Sjónarmið- Viewbendas er hægt að búa til úr núverandi skýringarmyndir og hægt er að nota til að búa til nýja skýringarmynd.Þeir eru skýringarmynd stencils.

· Sniðmát - Sniðmát geyma aftur nothæfur mynstur af íhlutum og tengingar ásamt því sem þeir eiga fulltrúa eða skoðað. Þeir geta vera hugsun af eins og "lítill" arkitektúr eða lausnir sem hægt er að setja inn í núverandi arkitektúr.

2. Arkitektúr -The arkitektúr útibú af trénu er þar sem þú byggja arkitektúr (s) á vélinni þinni. (Þetta er kallað populating arkitektúr.) Þú getur haft hvaða fjölda arkitektúr í einni Abacus skrá.

3. Mælaborð - The Mælaborð útibú tré er þar sem þú getur fengið aðgang að hvaða vistuð mælaborð fyrir verkefnið.

Note

Atriði í Explorer tré sem hafa haft þeirra Update leyfi fjarlægt (þ.e. þeir eru að lesa-eini) eru sýndar í gráu.

Gerð

Þessi hluti táknar ákveðna hluti eða tegund tengingar á valinn þáttur í trénu.

Standards

Í þessum kafla er listi af staðlar fyrir valinn þáttur í trénu.

Lýsing

Í þessum kafla gefur stutta lýsingu á völdum þáttur í trénu. Tengdar, tengla er einnig hægt að bæta við þennan kafla. Þetta eru vefsíður eða sveitarfélaga alger leiðir sem vísa á frekari upplýsingum um tiltekið frumefni. Margar línur eru einnig leyft. Gilda tengla þarft til að byrja með einn af 5 strengi; http: //, https: //, ftp: //, file: /// eða mailto :.

Ábending

Fyrir tengla með bilum, notandi getur slegið inn vefslóð eða slóð, velja þarf texta og Hægrismella| Tengil. Þetta mun breyta einhverju rými til % 20þannig að allt URL eða slóð mun virka rétt.

Búið og breytt

Þetta kaflasveitanotandi og dagsetning / tími fyrir stofnun, og síðast breytingar á, sem valin þáttur í trénu.

Tilvísanir

Í þessum kafla er listi af komandi og á útleið hluti fyrir valinn þáttur í trénu.Það sýnir einnig skýringarmynd, 3D og mynd skoðanir sem valinn þáttur birtist í. Ef skýringarmynd er valið það sýnir Sjónarmið ef við á skýringarmyndinni og útsýni almennt það sýnir einhver mælaborð Sú skoðun virðist í. Og þegar Standard er valið í trénu það sýnir notkun staðalsins eftir tegundum, íhluti og tengingar.

Properties

Þessi hluti er þar sem þú skilgreina eiginleika þættir innan arkitektúr þinn, eins og the vegur þú þarfnast það til að framkvæma, fjölda lína af kóða það hefur, sem hlutfall af þessum línum sem eru athugasemdum o.fl.

The 'input' og 'framleiðsla "eiginleika the pre-innbyggður herma verður sýnd í Properties glugganum með eign inntak röð selector táknið ( [image] ) Og framleiðsla icon ( [image] ) Sig með ábending gefur til kynna sem pre-innbyggður hermir eign er tengjast, td 'Modularity Output "eða" Performance Skrá'. Örin á framleiðsla táknum mun varpa ljósi Red ( [image] ) Þegar eign er úrelt vegna undirliggjandi eignum eða skipulagsbreytingar til geymsla með hermir þarfnast aftur uppgerð samkvæmt Red áherslu á Simulation tækjastika .

Stöðustikuna

Vinstri hluti stöðustikunni sýnir fulla slóð að nú í fókus geymsla frumefni, annaðhvort valið í Explorer glugga eða á skýringarmyndstriga. Þetta er svo að nákvæmlega staðurinn í geymsla stigveldi fyrir tiltekið frumefni er alltaf hægt að auðveldlega ákvarðað. Hægri hönd hluti stöðustikunni sýnir ýmsum aðgerðum skilaboð eins og "Open Abacus File Árangursrík 'og' kostnaður útreikning Lokið '.

Sjá einnig

Hvernig þú gerir það (Yfirlit) | Aðlagaðu tengi | Hvað er arkitektúr? | Hvernig er arkitektúr fulltrúa í Abacus? | Vinna með Abacus skrár


Hvað þýðir ABACUS gera?

Navigation: Inngangur að Abacus>

Hvað þýðir ABACUS gera?

Senda athugasemdir um þetta efni.

Um hjálp á öðrum tungumálum / þýðingar vinsamlegast smelltu hér .

ABACUS tekur giska-vinnu út af að takast á við lausnir, kerfi, hugbúnaður, upplýsingar, tækni, viðskipti aðferð og / eða öllu fyrirtækja (sameiginlega nefnt arkitektúr). Það getur hjálpað þér að pragmatically hanna, fylgjast með, líkja, greina, og sjón þín arkitektúr með því að sitja það, greina það í leiðandi hátt (td töflur, skýringarmyndir og 3D) og síðan meta það gegn virka ekki kröfur þínar.

Note

Non-hagnýtur kröfureru þessar kröfur sem varða ekki beint að HVERNIG vara starfar. Þess í stað eru þeir áhyggjur með hversu vel það starfar. Non-hagnýtur kröfur eru slíkt sem árangur, hreinskilni, evolvability, gæði, sveigjanleika, sveigjanleiki, osfrv (öfugt við hagnýtur kröfur eins, kveikja á þessu ljósi þegar þessi hnappur er smellt). Hefð hefur sem virka ekki kröfur verið erfitt - ef ekki ómögulegt - að mæla. Í raun, ABACUS er eina varan sem getur hlutlægt og quantifiably mæla fyrstu þrjú - flutningur, hreinskilniOg evolvability.

Einfaldlega setja, þú slærð inn arkitektúr og hvað sem þú þarfnast hennar að gera. ABACUS segir þér þá ef það mun gera eftir þörfum og bendir allir veikleika eða eyður.

ABACUS byggir á yfir 20 ára kerfi rannsókna og margir fleiri ára komið Systems Theory. Það gefur þér mælanleg, áreiðanleg, hlutlægum svör, svo þú ert ekki að treysta á huglægt mat.

ABACUS stendur fyrir Architecture-Based Analysis, Communication og Understandingaf Systems. Það getur hjálpað þér með hvaða stórum stíl arkitektúr, en það er almennt notað fyrir fjórum (4) hlutum:

· Þróunnúverandi arkitektúr. Til dæmis, ef núverandi arkitektúr skortir árangur, ABACUS mun sjón arkitektúr fyrir þig, greina vandamál (flöskuhálsum, osfrv), þá segja þér nákvæmlegahvernig á að bæta arkitektúr.

· Hönnunný arkitektúr. Til dæmis, ef þú þarft alveg nýja arkitektúr, og þú ert að hanna það sjálfur, ABACUS mun segja þér nákvæmlegahvaða þættir sem þú þarft og hvernig þeir ættu að vera tengdur.

· Innkaupastjóriný arkitektúr. Til dæmis, ef þú hafa kallað eftir tilboðum um hönnun nýs arkitektúr, og þú ert að velja á milli þriggja hönnun, ABACUS mun segja þér nákvæmlegasem einn hentar þörfum þínum bestu.

· Sameinarnúverandi núverandi arkitektúr. Til dæmis, ef þú þarft að sameina tvö eða fleiri aðskilin arkitektúr, ABACUS mun leiða þig.

Sjá einnig

Hvernig þú gerir það (Yfirlit) | Hvað er arkitektúr? | Hvernig er arkitektúr fulltrúa í Abacus?


Using tengla í Skýringarmyndir

Navigation: Populating vélina þína> Using Teikningar>

Using tengla í Skýringarmyndir

Senda athugasemdir um þetta efni.

Form (ókeypis form og hluti) og tengi (ókeypis formi eða tengingar) innan skýringarmyndir Hægt er að tengja við núverandi byggingar þínum fulltrúa í Abacus, auk ytri skrár / möppur og vefslóðir. Þessir tenglar geta þá verið stjórnað (búin, breytt og eytt) um Abacus verkfæraskúr. Þessi eiginleiki er hægt að nota til að auka siglingar og almennt skilning á vélina þína með skýringarmynd.

Að bæta við tenglum teikningu þína

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Veldu viðeigandi lögun eða tengi frá myndinni þinni.

3. Hægrismellaá löguneða tengi.

4. Veldu Opna tenglaog a Tenglargluggi.

5. Smelltu á Bætaicon og New Linkgluggi.

6. Veldu viðeigandi Bæklingur | Matrix | Skýringarmynd| 3D View| MyndHnapparnir, þá velja viðeigandi verslun, fylki, skýringarmynd, 3Deða graf Skoða í núverandi arkitektúr frá Link Tofellivalmynd.

- Eða -

6. Veldu Websiteútvarp hnappur þá inn viðeigandi vefslóð (t.d. http: //www.avolutionhugbúnaður.com /)á sviði til að tengja við vefsíðu. Gildar vefslóðir þarft til að byrja með einn af 5strengir; http: //, https: //, ftp: //,file:eða \\. Allar rými skal gert með '% 20'.

- Eða -

6. Veldu Absolute File | Hlutfallsleg Fileútvarp hnappurs,smelltu þá á '...'Hnappinn til að fletta í ytri skrár til að tengja á myndinni þinni.

7. Smelltu OKog nýr hlekkur verður sýnd í Tenglar glugga. Ath: The Links glugga er hægt að búa til að sjá fullt nafn ef þörf krefur.

8. Endurtaktu skref 5-7til að búa til fleiri tengla.

9. Að fylgja búið tengilinn, veldu viðeigandi tengil birtist í Tenglarglugga og smella Open Link.

Note

Hvenær margar textaskýringar eru birt fyrir lögun eða tengi tengillinn birtist á fyrstu umsögnina í listanum yfir skýringa í Edit Textaskýringar valmynd.

Til að fylgja tengla frá myndinni þinni

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Veldu viðeigandi lögun eða tengi frá myndinni þinni.

3. Smelltuá viðkomandi tengil (blátt undirstrikað hluti nafn) á lögun eða tengi í myndinni til að opna og skoða í fyrsta tengil laginueða tengi.Ath: Bendillinn ætti að breyta til "hönd" þegar tengill er tilbúinn til að smella.

- Eða -

3. Veldu viðeigandi lögun eða tengi frá myndinni þinni.

4. Hægrismellaá löguneða tengi.

5. Veldu Opna tengla og Tenglargluggi.

6. Veldu viðeigandi tengil sem þú vilt skoða.

7. Smelltu á Open Linkhnappinn til að opna og skoða viðeigandi tengil.

Til að eyða tengla í myndinni þinni

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Veldu viðeigandi löguneða tengifrá myndinni þinni.

3. Hægrismellaá löguneða tengi.

4. Veldu Opna tengla og Tenglargluggi.

5. Veldu viðeigandi tengil sem þarf að vera eytt.

6. Smelltu á Eyðahnappinn. og the hlekkur er fjarlægt úr Tenglar glugga.

Skipulagsnefndum tengla í myndinni þinni

Þú getur valið hvaða tengd skýringarmynd, ytri skrá, eða vefur URL birtist þegar lögun merki er Ctrl + smellt á myndinni.

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Veldu viðeigandi lögun eða tengi frá myndinni þinni.

3. Hægrismellaá löguneða tengi.

4. Veldu Opna tengla og Tenglargluggi.

5. Til að breyta röð af tenglum smelltu á Færa upp | Færa niðurTakkarnir til hægri hönd hlið af the Tenglarglugga.

6. Fyrsti tengillinn sem birtist á vinstri hönd hlið af the Tenglargluggi er tengill sem sýnir þegar þér Ctrl + Smelltua vefslóðartengdar lögun eða tengi nafn.

Sjá einnig

Populating vélina þína | Populating arkitektúr handvirkt | Greining arkitektúr þinn


Notfæra Skýringarmyndir

Navigation: Populating vélina þína> Using Teikningar>

Notfæra Skýringarmyndir

Senda athugasemdir um þetta efni.

Þegar skýringarmynd hefur verið búin til, þá þætti sem birtast í henni er hægt að endurnýta raða og aftur stór eins og þú vilt.

Til að færa hluti á skýringarmynd

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Click-og-haldaeinhver hluti til að færa það. Ef valið hluti hefur foreldri, foreldri hluti verður hápunktur.

3. Sem þátturinn erdraga frá hluti móðurfélag þess, og yfir aðra hluti, "hugsanlega" foreldrar vilja verða hápunktur. Litastef sýnir áhrif rekstur mun hafa á viðvaranir og villur með núverandi verkefni og er lýst í Skilgreina og staðfesta þvingun . Á þennan hátt getur þú myndrænt vafra stigveldi frá "grunnmynd".

4. Releasemús hnappur til að falla þáttur í nýjan stað.

Note

Þú gætir líka nota lyklaborðið til að tilvísun til-staða þætti á teikniborðinu striga. Einfaldlega veldu hluti eða ókeypis mynd lögun sem þú vilt færa og nota arrow takkana staðsett á lyklaborðinu til að færa form á viðeigandi stað.

Hafðu einnig í huga að þegar að draga hluti með músinni yfir annan efnisþátt, a 'hugsanlega' parent hluti er auðkenndur þegar efst í vinstra horninu á íhlutum sem þú ert að draga skarast Annar hluti.

Ábending

Freeform og Fljótandi form Hægt er að panta með því hægrismellaog val Koma til Fronteða Setja aftastúr valmyndinni. Það er mikilvægt að hafa í huga að hluti form er hægt að breyta Freeform form af hægrismellaá tiltekna hluti lögun og val Umbreyta til Freeform.

Til að breyta stærð hluti í myndinni

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Smelltu-halda-dragaeinn af handföng íhlutarins og búa lögun til viðkomandi stærð.

3. Einnig að halda hlutföllum lögun er, valda Shift + Click seinagangur draga.

Til að færa tengingu í myndinni

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Click-og-haldaeinhver tengsl til að færa það.

3. Releasemús hnappur til að falla þáttur í nýjan stað.

Note

Þú getur aðeins fært tengingar sem ekki eru tengdir ákv hluti. Ef þeir eru tengdir, getur þú aðeins færa lausa endanums, Eða Re-beina tengingu .

Eyði Hluti og tengingar

Þegar þú eyðir íhlutur eða tengingu milli skýringarmynd, hefur þú möguleika á að eyða henni af öllu arkitektúr. Hvaða hluti sem er eytt úr arkitektúr, verður eytt sjálfkrafa úr öðrum skýringarmyndum sem það birtist. Þar Freeform tilvik birtast aðeins á einum mynstri, eyða þeim hefur ekki áhrif á byggingar líkan eða önnur skýringarmynd.

Til að eyða íhlutur eða tengingu frá skýringarmynd

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Smelltuá hvaða tengd tengingu eða íhluta til að velja það.

3. Ýttu á Eyðatakkann til að eyða það frá myndinni, eða Shift + Deleteað eyða því af öllu fyrirmynd.

- Eða -

2. Hægri-smelltu á tengdan frumefni eða hluti. A samhengi valmynd vilja birtast.

3. Veldu Eyða úr Vieweða Eyða úr Arkitektúrúr samhengi matseðill.

Note

Ef þáttur sem þú vilt eyða úr augum hefur engin börn og aðeins gerist á þeirri skoðun, ABACUS verður spurt hvort þú viljir eyða þáttur frá geymsla eins og heilbrigður.

Varúð

Þegar þú eyðir a hluti af líkaninu sem hefur barn hluti, börnin munu einnig vera hugsanlega eytt í samræmi við viðvörun valmynd.

Samrunafélaganna Hluti

Þú vilt kannski að sameina tveir þættir núverandi á sama mynstri (og innan arkitektúr). Þetta má gera fyrir mörgum ástæðum, til dæmis, Tveir framreiðslumaður er innan infrastructure- H fyrirtækisins01 og H02. Þessir tveir miðlarar eru fulltrúa sem tvö aðskilin grunnefnum arkitektúr. H01 hefur verið talið óþarft og því er að tekinn úr notkun. Allir núverandi forrit í gangi á H01 eru að færst til H02 (enn í þóknun). Þessi breyting er síðan hægt að endurspeglast í virkni "samrunafélaganna" tveimur hlutum H01 og H02 á myndinni (og innan arkitektúr).

Ítarlega umfjöllun um sameiningu vinsamlegast vísa í sameiningu Items efni hér .

Að sameina tvö núverandi hluti

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Hægri-smelltu-haldaá hluti sem þú vilt að sameina og dragaþað inn á hluti sem þú vilt að sameina það með. Gakktu úr skugga um útlínur áfangastað hluti er auðkenndur rautt til að sýna að það er valið.

3. Veldu Sameina | Varðveita Áfangastaðureða Skrifa yfir Áfangastaðurúr valmyndinni.

Note

The Varðveita Áfangastaðurvalkostur varðveitir gildi eignir Ákvörðunarstaður efnisþáttarins ef þeir eru á upptök hluti eins og heilbrigður.

The Skrifa yfir Áfangastaðurvalkostur birtist eignir áfangastað Component er með einhver sameiginleg frá upprunnar hluti.

Breyting Connections

Tengingar sýnt á skýringarmynd alltafendurspegla uppbyggingu sem skilgreind er í arkitektúr sig. The Teikning tól leyfir þér að losa tengingar frá hlutum, færa þá, bugða þá, með tilvísun til-leið þá og aftur hengja þá til aðra hluti.

Til að losa / festa á tengingu frá / til hluti

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Click-og-haldaá hvaða tengingu.

3. Veldutengingin enda(þ.e. Source eða sökkva) Sem þú vilt losa / festa. Ath: tengingin rofnar eru auðkennd með litlum hvítum hringjum og sveima yfir hvíta hringnum í annað mun valda "Tooltip 'að birtast með tilheyrandi HlutverkNafnið(þ.e. annað hvort Source eða sökkva).

4. Dragtengingin enda á nýjan stað (annaðhvort laust sæti eða hluta) og sleppir músarhnappnum.

Note

Þegar tenging enda er sett yfir gild hluti, útlínur áfangastað hluti er auðkenndur með þjóta útlínur. Litastef sýnir áhrif rekstur mun hafa á viðvaranir og villur með núverandi verkefni og er lýst í Skilgreina og staðfesta þvingun . Þegar út að lok þe tengingu og hluti eru sjálfkrafa tengdur(eða fylgja), Og þetta endurspeglast í byggingarlist fyrirmynd.

Til re-routing tengingu

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Staðsettu músarbendilinn yfir tengingu.

3. Halda Shiftlykill niður og Smelltumús hnappur til að setja upp tengingu akkeri benda. Losa Shift lykill. Þú getur fjarlægt akkeri benda með því að gera sömu aðgerð.

4. Click-og-dragaakkeri benda til að tilvísun til-leið tenginguna.

Ábending

NotaAlt lykill í stað ShiftLykillinn að búa hornréttar tengingar.

Til bugða eða réttatenging

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Staðsettu músarbendilinn yfir tengingu.

3. HægrismellaTHann tengingu og í samhengi matseðill sem birtist velja Curve, Þverstæðum eða Straight.

Ábending

Allar tengingartiltekinnar tegundar á myndinni er hægt að stilla til að Boginn, þverstæðum eða Straight með því að hægri-smella á tilheyrandi línu fyrir tegund hins Tengingar flipann af Stencil gluggaog val Curve, þverstæðum eða Straight.

Til akkeri á tilteknum punkti á brún að vegna lögunar

1. Tryggja að þú ert með núverandi skýringarmynd opinn .

2. Velja tengingu.

3. Staðsettu músarbendilinn yfir Hvíti punktur 'í lok tenging.

4. HægrismellaTHann tengingu endir og í samhengi matseðill sem birtist velja Akkeri endapunktur í form.Færa tengingu enda á löngun stað á brún lögun.

OR

Halda Ctrllykill niður og csleikja-og-dragaað endir tengsl benda á löngun staðsetningu á brún lögun.

Note

Tengingar og þá tekið til raunverulegra hlera tengdra lögun þeirra í stað hljóp kassi þess lögun.

Sjá einnig

The Teikning Tól | Populating vélina þína | Greining arkitektúr þinn


Sameina atriði

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Sameina atriði

Senda athugasemdir um þetta efni.

Hvenær vilt þú sameina atriði?

Þú myndi sameinast atriði þegar þú ert með tvær (eða fleiri) hluti í líkan sem best er lýst með einu lagi. There ert margir aðstæður þegar þú might vilja til að gera þetta, þar á meðal:

· Sem afleiðing af að flytja inn nýtt sett af upplýsingum inn líkan sem getur afritað eða hólmi fyrirliggjandi upplýsingar. Til dæmis ef þú flytja uppfærða útgáfu af töflu í líkan þínum.

· Með tímanum afrit af "sama" hluti hafa verið búin til og sem þú vilt að hreinsa upp þessi afrit.

· Ef þú ert að framkvæma a hvað-ef atburðarás og þá hluti sem þú ert að sitja ert í raun að sameina í raun og veru. Til dæmis, ef þú ert að sameina tvær deildir í stofnun, eða ef þú ert að sameina tvo netþjóna.

Hvað er hægt að sameinast?

Eftirfarandi gerðir af hlutum styðja að sameiningu:

· Standards

· Hluti og Tenging ferðalaga

· Hluti og Tengingar

Hvernig á að sameina atriði

Að hefja sameiningu, með því að nota hægri músarhnappi, draga einn hlut í Explorer yfir í annað. Hluturinn sem þú ert að draga er uppspretta, og hluturinn sem þú dregur inn er áfangastaður. Við gefa út á hægri músarhnappi þú vilja vera nútíminn með valmynd sem þú getur valið um að sameina tvo hluti. Þú verður að velja hvort þú vilt halda eða skrifa áfangastað. Þetta er nánar útskýrt hér að neðan.

The sameinast hægri-draga menu

Hver er munurinn á milli varðveita og skrifa of mikið áfangastað?

Varðveita eða skrifa valkostur ræður hvað gerist ef nafn, lýsingu eða Properties milli uppspretta og áfangastað atriði leiksins.

Ef Varðveita Áfangastaður er valið

· Nafn áfangastað og lýsing verður haldið.

· Allar eignir sem aðeins eru í upptökum er bætt á áfangastað.

Ef Skrifa yfir Áfangastaður er valinn:

· Nafn áfangastað verður skrifað yfir frá upptökum.

· Lýsing á áfangastað verður skrifað yfir frá upptökum, nema uppspretta lýsing er auður.

· Allar eignir sem aðeins eru í upptökum er bætt á áfangastað.

· The Value og Unit hvaða Properties sem ríkir bæði í upptökum og ákvörðunarstaður verður skrifað frá upptökum, nema Value uppspretta eða Unit er auður.

Sérstökum tilvikum

· Tegundir: Þegar sameina tegundir eru heimildir sameinuð, í "svartsýnn" hátt, þannig að ef leyfi á uppruna ekki vera til á áfangastað, það vildi vera bætt, og ef það var fyrir hendi í áfangastað, þá ef einstaklingurinn leyfi fyrir notendahóp (búa til, lesa, uppfæra eða eyða) ekki passa (einn hlut, einn neitað), þá leyfi yrði hafnað.

· Hluti: Þegar sameina hluti, undir-hluti af upptökum eru flutt á áfangastað, og eru sameinuð með undirþætti á áfangastað ef nöfn þeirra eru eins, Óháð gerð þeirra.Ennfremur, margar undir-hluti af upptökum með sama nafni verður sameinuð í eitt undir-hluti í áfangastað.

· Tengingar: Efsta stigi tengingar sjálfir verða báðir hafa sömu viðhengi (eða skortur þar) til að fá að vera sameinuð. Þegar sameina tengingar eru undir-tengingar á upptökum flytja á áfangastað, og eru sameinuð með undir-tengingar í áfangastað ef nöfn þeirra eru eins OGviðhengi þeirra eru eins. Ef viðhengi eru ekki eins, fengið undir- tengingar verður bætt á áfangastað án þess að sameinast passa tengingar þegar eru til staðar. Þetta er svo að engin viðhengi eru glötuð.


Navigation í 3D skýringarmynd

Navigation: Greina vélina þína> 3D skýringarmyndir>

Navigation í 3D skýringarmynd

Senda athugasemdir um þetta efni.

ABACUS leyfa þú til auðveldlega fletta í gegnum vélina þína í 3D. Reynslan er svipað að fljúga. Það eru tvær stillingar á flakk:

· Basic Control Mode (Default); og

· Advanced Control Mode - breyting þessum ham með því að velja Control| Advanced Control Mode.

Note

Til að skipta á milli Basic Stjórna og Advanced Control ham, getur þú notað F4flýtilykill virkni.

Basic Control Mode

· Halda vinstri hnappinn og færa músina áfram eða til baka breytingar á vellinum;

· Halda vinstri hnappinn og færa músina til vinstri eða hægri breytir yaw;

· Halda hægri hnappinn og færa músina pönnur útsýni;

· Halda báða hnappana niður og færa músina fram eða aftur, dregur það inn og út úr arkitektúr, og

· Halda báða hnappana niður og færa músina til vinstri eða hægri, rúlla vinstri og hægri.

- Eða -

· Ýta á Left Arrowá lyklaborðinu eða talnaskiki mun snúa vinstri;

· Ýta á Right Arrowá lyklaborðinu eða talnaskiki mun snúa rétt,

· Ýta á Up Arrowá lyklaborðinu eða talnaskiki stækkar;

· Ýta á Niður örá lyklaborðinu eða talnaskiki mun þysja út;

· Ýta Page Upá lyklaborðinu eða talnaskiki mun kasta upp; og

· Ýta Page Downá lyklaborðinu eða talnaskiki mun kasta niður.

Advanced Control Mode

· Færamús fram og til baka, og upp og niður, breytir völlinn og yaw (í sömu röð);

· Ýta Weða Up Arrowdregur í (áfram) að arkitektúr,

· Ýta Seða Niður ördregur út (aftur) frá arkitektúr;

· Ýta Aeða Left Arrowrúlla vinstra;

· Ýta Deða Right Arrowrúlla til hægri;

· Ýta Qeða Page Downlyfta útsýni (með því að lækka sjónarhorni); og

· Ýta Eeða Page Uplækkar útsýni (með því að upphefja sjónarhorninu).

Interactive Control Mode

Því að halda að Shiftá lyklaborðinu hunsar núverandi háttur (Basic eða Advanced) til að slá gagnvirka stjórna háttur. Í þessum ham Eftirfarandi er mögulegt:

· Rollmúsarbendillinn yfir íhlut eða tengingu til að sjá hluti eða heiti tengingu er;

· Smelltuá hluti til að súmma inn á þessi hluti;

· Click-og-dragaá hluti til að snúa mynd í kringum þessi hluti; og

· Hægrismellaíhlutur eða tengingu og veldu Sýna í Explorerað sjá að hluti eða staðsetningu tengslum er í trénu.

Algengar stýringar

· Nota ALT-ENTER / ESCað skipta fullur skjár háttur,

· Nota F2breyta sýna stillingu. Þetta er einnig hægt að nálgast í ViewValmynd.

· Nota mús hjóleða +/-til að breyta hraða. Hraðinn er auðkenndur með númeri í the lægri vinstri horninu - sést aðeins þegar það er að breytast. 1 er hægur og 100 er festa.


Opnun Skýringarmyndir

Navigation: Populating vélina þína> Using Teikningar>

Opnun Skýringarmyndir

Senda athugasemdir um þetta efni.

Stencil og striga teikna glugga birtist sjálfkrafa þegar skýringarmynd er opnuð eða búin. Á sama hátt, þegar skýringarmynd er lokað, samsvarandi flipanum lak í striga glugga hverfur og ef engin frekari teikningar eru opnir þá stencil gluggi er lokað.

Til búaný skýringarmynd

1. Tryggja þú hafa óákveðinn greinir í enskuABACUS skrá er opininniheldur þínum byggð arkitektúr.

2. Smelltu á Diagramtáknið í Sýn og tækjaslá.

- Eða -

2. Veldu Insert| Diagram.

- Eða -

2. Hægrismellaað Skýringarmyndirútibú gefið Arkitektúrhluti af trénu og veldu Búa Skýringarmynd.

3. Veldu Arkitektúrþú vilt leggja áherslu á frá fellilistanum. Athugið: arkitektúr muni vera valið fyrir þig ef þú notaðir Skref 3 hér að ofan til að opna nýja skýringarmynd.

4. Veldu Sjónarmið þú vilt nota úr fellilistanum. Ath: valið sjónarmið síar hluti og tengingar listana aðeins vera þær birtar á sjónarmið.

5. Gætuð velja útsýni frá Sía eftir Viewfellilistanum til Forveldu hluti og tengingar frá valið útsýni. Ath: þetta er í raun að nota valið mynd sem vistuð fyrirspurn.

6. Veldu Skipulag að vera annaðhvort Radial eða Grid.

7. Veldu Hlutiog Tengingarsem þú vilt í myndinni frá því staðall þáttur val gluggi .

8. Smelltu OK.

Note

Ný myndinni ekki bætt við Skýringarmyndirútibú arkitektúr. Það mun hafa sjálfgefið heiti, sem þú getur breytt seinna með því að hægrismella á það.Ennfremur, the síðastur ástand af the hluti og val tengingu filters mun hólpinn með skýringarmynd raun sparnaður 'fyrirspurn' notað til að búa til skýringarmynd.

Til að opna Skýringarmynd

1. Í sérstökum fjölmennasta arkitektúr opnarðu Skýringarmyndirútibú tré.

2. Tvísmella Myndin sem þú vilt opna.

Til að vista skýringarmynd

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinnog þú hefur gert nauðsynlegar breytingar. Ath: stjörnu "*" verður sýnd á eftir skoða nafni í flipanum blaði haus ef það eru breytingar sem frelsa má.

2. Í landkönnuður mati smelltu á Vistahnappinn eða fékk að File| Vistaeða valda Ctrl + Stil að vista allar breytingar á vélina þína og skrifa það til að skrá.

Til að vista skýringarmynd sem a sjónarmið

1. Tryggja að þú ert með núverandi skýringarmynd í Abacus skrá.

2. HægrismellaSkýringarmyndin í Skýringarmyndirhluti af trénu.

3. Veldu Vista sem Skýringarmynd Sjónarmið.

4. Sláðu inn nafn fyrir nýja þinn skýringarmynd sjónarmiðog smelltu OK.

Sjá einnig

The Teikning Tól | Populating vélina þína | Greining arkitektúr þinn


Populating með Vörulistar

Navigation: Populating vélina þína>

Populating með Vörulistar

Senda athugasemdir um þetta efni.

A verslun gerir þér kleift að skoða og breyta hlutum eða tengingar og eiginleika þeirra á einfaldan tabular hátt.

Til búa til nýja Catalogue skoða í ABACUS

Note

Þó allt Architect notendur geta búið til nýjar Vörulistar, að vista breytingar á stillingum núverandi Vörulisti fékk notandi leyfisveitandi þarf Hönnuður bæta við-á hæfileiki. Þetta er til að "vernda" stillingar núverandi Vörulistar sem er heimilt að deila með mörgum notendum. Hins vegar Architect notar án Designer bæta við-á getur samt valið að "Save As" allar nýjar stillingar á nýju skránni. Og auðvitað allt notandaleyfi getur valið að "Fleygja 'allar breytingar á núverandi kennsluskrá. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarft hönnuður bæta við-á hæfileiki. Og muna, þetta er bara stillingar á skránni, eru allar breytingar sem gerðar eru til gögn í skránni í stað beitt geymsla, óháð.

1. Veldu Insert | Catalogue.

2. Í draga niður velja Architecture sem inniheldur hluti eðatengingar sem þú vilt skoða.

3. Í draga niður að velja hluti eða gerð tengingar sem þú vilt hafa þau tilvik sem 'raðir' í verslun.

4. The verslun verður byggð meðróa fyrir hvert tilvik af völdum íhluta eða tegund tengingar.

Note

Sjálfgefið vinstri-mest Stigveldi Pathdálki (þ.e. stigveldi foreldri íhluta eða tengingar ofan valinn tilvikum) og 2. Name dálki (þ.e. lista yfir vali á einingu eða tengingu tilvikum) eru frystar vinstra megin við verslun. Til að breyta dálk frystingu draga dálk skilju til hægri Nafn dálki. Þú getur aftur tildálkum einfaldlega með því að draga og sleppa Dálkurinn fyrirsagnir þeirra. Reiti með bláum undirstrikun eru tengla að öðrum þáttum í verkefninu og tengla má fylgja eftir með því að halda niðri Ctrl og smella á tenglana. Dálkar getur verið falinn með því að hægri-smella á dálkafyrirsögn og velja Column | Fela dálki. Falinn dálkum má úr felum með því að smella Stilla Columns tækjastikuhnappinn og nota Stilla dálka valmynd eins og sýnt er hér að neðan, eða með því að velja örina sem vísar niður hluta Stilla Columns tækjastikuhnappur og sig velja falinn dálk (s) frá annaðhvort almennt, Properties eða Viðhengi söfn. Raðir getur verið flokkaðar með gildi dálki sínum með því að draga dálkafyrirsögn í bláa hagsmunafélagi bar á the toppur af the verslun. Á hvaða tíma þú geta tvöfaldur smellur á Vöruflokkar röð valog hoppa tilsamsvarandi hlutieða tengingí Explorer glugga.Property klefi gildi eru feitletruð þar sem þeir eru mismunandi að vanskil og italicized þar sem þeir eru að lesa-eini. Timestamp, Property og Attached Component dálka má lituð samkvæmt klefi gildismat eða eignarskattur meðfylgjandi íhluturinn er með því að hægrismella á dálkafyrirsögn og velja Column | Breyta Colour ... og þá Colour eftir Tímastimpill eða Colour By Property valkostur, þó aðeins List, Integer, Decimal, Boolean eða Date / Time gögn gerð eiginleikar munu lita. Property gildi fyrir Attached Component dálkum má sýnt með því að hægri-smella á dálkafyrirsögn og velja Column | Sýna Property ... og þá Show Property valkost. Og að lokum, þar sem það eru Nauðsynleg þvingun sett fyrir eign dálki þetta kann að vera sýnt með band (ásamt litarefni samkvæmt löggæslu magn þeirra) með því að hægri-smella á dálkafyrirsögn og velja Column | Sýna .

Vörulisti

Til bæta við / sýna dálka til a Vörulisti Farðu í Abacus

1. Tryggja að þú sért með Vörulisti skoða opinn.

2. Falinn dálkum má sig úr felum með því að smella á ör á hægri Stilla dálka tækjastika hnappurog velja falinn dálk frá annaðhvort General, Properties eða Viðhengi söfn.

Note

A kvarðastrik birtist ekki á nú sýnd dálka fyrir verslun.Auk aðeins ákveðnar viðhengi verður í boði undir Viðhengi kafla í samræmi við þvingun sem eru skilgreind í verkefninu. Einkum fyrir viðhengi að vera í boði að vera sýnt í hluti verslun sem íhluta fyrir verslun skal tilgreint annaðhvort uppruna eða sökkva (EKKI 'Allir') þvingun af "tenginguna verður að fylgja" fyrir tengingu gerð, og einnig verður að vera að minnsta kosti einn íhluta tilgreint annaðhvort sem uppspretta eða vaskur (EKKI 'Allir') annars 'enda' af sömu tegund tengingar.

- OR -

2. Marga dálka má úr felum (eða panta eða fasta) með því að smella á Stilla Columns tækjastikuhnappinnog nota Stilla dálka Dialog sést hér að neðan.

Note

Núvarandi dálkar eru sýndar í spjaldið á hægri með fyrirliggjandi dálkum sýnd í spjaldið á vinstri. Fyrirliggjandi dálkar má síuð í samræmi við Veldu Laus dálkadraga niður og þeir verði bætt með því að velja þá í pallborð á vinstri og smella á Bæta hnappur inbetween tveimur spjöldum.

Stilla Columns valmynd

Til fjarlægja / fela dálka A Vörulisti Farðu í Abacus

1. Tryggja að þú sért með Vörulisti skoða opinn.

2. Hægri-smelltu á dálkahöfuð fyrir í dálkinum sem þú vilt fjarlægja / fela og veldu Column | Fela Column.

- OR -

2. Marga dálka geta verið falin (eða panta eða fasta) með því að smella á Stilla Columns tækjastikuhnappinnog nota Stilla dálka Dialog sýnt hér að ofan.

Note

Núvarandi dálkar eru sýndar í spjaldið á hægri með fyrirliggjandi dálkum sýnd í spjaldið á vinstri. Núvarandi dálkum má falinn með því að velja dálk í spjaldið á hægri og smella á Fjarlægja hnappur inbetween tveimur spjöldum.

Til að byggja með Vörulisti Farðu í Abacus

1. Til bæta hluti eða tengingaf þessari tegund aðað verslun (og verkefni) smella á Bæta við nýjum Component / Bæta við nýjum Connection tækjastikuhnappinn. Röð ætti birtast og hluti eða Tengingin verður búin á efsta stigi af Hluti eða Tengingar safn fyrir valinn Architecture.

Note

Nýja hluti og tengingar er bætt við sjálfkrafa á efsta stigi á innihaldsefnum eða tengingar safni valið Architecture. Til að breyta foreldrum nýju hluti eða tengingar hægrismella á stigveldi Path klefi fyrir nýja hluti eða tengingar röð og veldu Breyta Parent ...og velja viðeigandi foreldri (taka mið af þvingun auðkenning ).

Note

Ný raðir / þættir bætt beint verslun í gegnum 'Bæta við nýju' hnappinn, límt inn í verslun, eða búin með innflutning í verslun frá MS Excel eru undanþegnir sía þar til verslun er lokað. Þetta er að gera allar nauðsynlegar breytingar á gildi dálki sem ekki uppfylla núverandi skilyrði sía á verslun. Þessar nýju frumefni raðir eru sýndir með '+' tákn í röð selector klefi í upphafi línunnar, sem er litað grænt ef þátturinn uppfyllir nú vistaða sía viðmiðanir verslun (þ.e. verður áfram á verslun ef aftur opnað), og rauður ef það virkar ekki.

2. Til fjarlægja a hluti eða tengingaf þessari tegund fráað verslun (og verkefni) velurðu línuna og annaðhvort ýta Del takkann eða hægri-smelltu á róður val og velja Eyða úr Arkitektúr. The róður að hverfa frá verslun og það verður eytt úr verkefninu.

Til sía með því að nota a Vörulisti Farðu í Abacus

1. Tryggja að þú sért með Vörulisti skoða opinn.

2. Ef sía röð birtist ekki efst verslun smelltu síðan á Sýna Sía Header Rowtækjastikuhnappur.

3. Í dálkinum sem þú vilt bæta við síu, tvöfaldur-smellur the sía róður klefi þar sem það sýnir "(All)".

4. Fyrir Timestamp, stigveldi Path, Nameeða Lýsingalmenn dálka eða Text, Integer, Decimal, Booleaneða Date / Timeeign dálka smelltu á ... hnappinn sem birtist í hægri sía röð klefa og slá inn klefi gildi sem eiga að vera í bæklingnum.

Note

Lokað er flutt eins og '*' algildistákn eru sjálfkrafa beitt fyrir og eftir hvaða band gildi svo að innganga í "köttur" (án gæsalappa) myndi fela raðir með 'Bobköttur','kötturkona "eða" til framkötturjón 'osfrv Multiple /' eða 'gildin má skrá á nýjum línum með Ctrl + Enter. Fyrir Integer og Decimal dálkum eign "og" rökfræði má tilgreina með "&"(Án gæsalappa) og hærri en / minna en etc rökfræði má tilgreina með '> =','>','<'Og'<="(Án gæsalappa) t.d. '> = 50000 & <90000'. Non-eyða metin raðir má með því að slá inn '(Non-Blanks)"(Án gæsalappa) og Blank metin raðir má með því að slá inn '(Blanks)"(Án gæsalappa).Og að lokum, eru allar síur sjálfgefið ræða særandi svo 'köttur "(án gæsalappa) myndi fela raðir með' köttur", "Cat" eða "CAT" o.fl. Til ræða viðkvæmar samsvörun, slá '(Case)"(Án gæsalappa) fyrir streng t.d. '(Case) Cat "(án gæsalappa) myndi aðeins eru raðir með' Cat" í þeim.

5. Fyrir Viðhengidálka, Standards dálkum eða List eign dálka smelltu á niður örina takkann sem birtist í hægri sía röð reitinn og velja klefi gildi frá gátreitunum sem ætti að vera í bæklingnum.

Note

The '(velja allt) "kassann gerir allar aðrar kassana í raun meðal öllum tiltækum raðir. The '(Non-Blanks)' kassann mun fela allir non-auður metin raðir. The '(Blanks) "kassann mun fela auðar metin raðir. Og að lokum, óhindraður neinar sérstakar metin reitina sjálfkrafa afvelja á '(velja allt) "og" (Non-blanks)' gátreit samkvæmni.

6. Smelltu OK að beita síu.

Til slökkva / kveikja sía á a Vörulisti Farðu í Abacus

1. Tryggja að þú sért með Vörulisti skoða opinn með sía beitt.

2. Smelltu á kassann vinstra megin við síuna röð.

Til fjarlægja síu frá a Vörulisti Farðu í Abacus

1. Tryggja að þú sért með Vörulisti skoða opinn með sía beitt.

2. Til að fjarlægja einstaka dálk síu hægrismellt á dálkahöfuð og veldu Column | Hreinsa Filtering.

3. Til að fjarlægja allar síur smelltu á Valkostir tækjastikuhnappur og veldu Hreinsa Síustillingar.

Til að spara / vista sem aVörulisti skoða

Note

Þó allt Architect notendur geta búið til nýjar Vörulistar, að vista breytingar á stillingum núverandi Vörulisti fékk notandi leyfisveitandi þarf Hönnuður bæta við-á hæfileiki. Þetta er til að "vernda" stillingar núverandi Vörulistar sem er heimilt að deila með mörgum notendum. Hins vegar Architect notar án Designer bæta við-á getur samt valið að "Save As" allar nýjar stillingar á nýju skránni. Og auðvitað allt notandaleyfi getur valið að "Fleygja 'allar breytingar á núverandi kennsluskrá. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarft hönnuður bæta við-á hæfileiki.Og muna, þetta er bara stillingar á skránni, eru allar breytingar sem gerðar eru til gögn í skránni í stað beitt geymsla, óháð.

1. Tryggja að þú hafa a nýr eða núverandi Vörulisti útsýni opinnog þú hefur gert nauðsynlegar breytingar.

2. Í Vörulisti skoðaToolbar Smelltu á Vistahnappinn til að vista Vörulisti skoða og allir formatting breytingar.

Note

Ef þú ert ekki með Vista hnappinn í Catalogue Sýn og tækjaslá þá þarft þú ekki að Designer bæta við-á og þú ert aðeins fær um að Vista semöllum stillingum breytist í nýja verslun þegar þú ferð að loka núverandi verslun.

3. Ef að VörulistiNamevalmynd birtist (vegna þess að vera nýja verslun) sláðu inn heiti fyrir verslun og ýttu OK.

Til útflutningur til MS Excel skrá

1. Tryggja að þú sért með Vörulisti skoða opinn.

2. Smelltu á Flytja út í Excel Vörulisti töflureiknitækjastikuhnappur.

3. Veldu skrá nafn til að vista MS Excel verslun sem. Smelltu Vista.

Note

Sjálfgefið skráarheiti útfluttar MS Excel Vöruflokkar mun vera Catalogue nafn merki á eftir Architecture nafni í sviga, td "Verkefni (2014 Actual) .xlsx. Þú getur breytt einhverju af þessu, þar á meðal hvort skrá snið er að vera .xlsx eða .xls. The Architecture nafn er innifalinn að minna notandann á að hver verslun hefur tiltekna efni (þ.e. auðkenni í dálki A og röð 1) til að leyfa því að vera kúlulaga skemmtiferðamaður aftur í Import frá MS Excel skrá sem greinir hér að neðan.

Note

Sjálfgefið falinn Column A innan útfluttar MS Excel skrá inniheldur einstakt auðkenni fyrir hvert atriði í Abacus geymsla. Þetta gerir einhverjar breytingar sem eru gerðar í MS Excel til að "passa upp 'til núverandi þætti innan Abacus á innflutning (sjá hér að neðan). Hins vegar er notkun þessarar einstöku auðkenni til að "passa upp 'raðir má yfirskrifaður með að Ytri | IDeign á frumefni. Það er, ef þátturinn er utanáliggjandi | ID eign og það er í bæklingnum um útflutning þá gildum á Ytri | ID dálkur verður notað til að passa upp á raðir á innflutning (sjá hér að neðan) og einstakt auðkenni gildi í falinn dálki A verða hunsaðar (og getur jafnvel verið auður). Falin Column A sjálft verður þó enn, einkum gildi í reit A1. Enn fremur, þegar bæta ytri ID er að núverandi ABACUS þátturinn safni við mælum bæta þeim við sem mismunandi eign fyrst, td Ytri | Temp og þá endurnefna eign til Ytri | ID. Annars afrit þættir verði bætt.

Vörulisti formattinger flutt sjálfgefið, þó að stór bæklingum þetta getur leitt til þess að útflutningur sé alveg hægt. Samkvæmt því, í Verkfæri | Valkostir ...þá á að Vörulistiflipi,þú ert fær um að draga úr the magn af formatting sem er fluttur eins og sést á Catalogue flipanum hér að neðan, þannig hraðakstur upp útflutning.

Vörulisti útflutningur möguleikar

4. An Export Lokið glugganum birtist. Smelltu OK.

Flutt til MS Excel skrá

Til innflutningur frá MS Excel skrá

Note

Sjálfgefið falinn Column A innan útfluttar MS Excel skrá (sjá hér að framan) inniheldur einstakt auðkenni fyrir hvert atriði í Abacus geymsla. Þetta gerir einhverjar breytingar sem eru gerðar í MS Excel til að "passa upp 'til núverandi þætti innan Abacus á innflutning. Hins vegar er notkun þessarar einstöku auðkenni til að "passa upp 'raðir má yfirskrifaður með að Ytri | IDeign á frumefni. Það er, ef þátturinn er utanáliggjandi | ID eign og það er í bæklingnum um útflutning (sjá að ofan) þá gildi ytra | ID dálkur verður notað til að passa upp á raðir við innflutning og einstaka ID gildi í falinn dálki A verða hunsaðar (og getur jafnvel verið auður). Falin Column A sjálft verður þó enn, einkum gildi í reit A1. Enn fremur, þegar bæta ytri ID er að núverandi ABACUS þátturinn safni við mælum bæta þeim við sem mismunandi eign fyrst, td Ytri | Temp og þá endurnefna eign til Ytri | ID. Annars afrit þættir verði bætt.

1. Tryggja að þú sért með Vörulisti skoða opinn.

2. Smelltu á Innflutningur frá Excel Vörulisti töflureiknitækjastikuhnappur.

3. Veldu skráarheiti flytja MS Excel verslun frá. Smelltu Open.

4. Ný Villur fundust og / eða nýjar villur / Varnaðarorð fundin valmynd birst fyrir nýja efni (þ.e. raðir í MS Excel) sem var bætt við. Taka mið af villum / viðvaranir og smella OK.

5. Innflutningur Lokið valmynd birtist og það kann að sýna viðvaranir vegna innflutnings (sjá skýringar hér að neðan). Smelltu OK.

Note

Fyrir úthlutað Standards eða fylgir Component dálka, nýjar færslur í gegnum MS Excel skrá verða að passa nákvæmlega Nafnið af núverandi staðall eða hluti af réttri gerð fyrir framsal eða tengingu til að bæta. Fyrsti heitir Leikurinn verður notað og allir ósamþykkt færslur mun búa viðvörun eins og á hér fyrir neðan. Ennfremur, en viðvaranir eru gefnar á aftur innflutning, eru þættir ekki eyttfrá Abacus ef þeir eru ekki til staðar í MS Excel verslun. Þetta er vegna þess að það er engin leið að ABACUS geta vita hvort úthlutað Standard eða fest Component til í Abacus verkefninu en er ekki til í MS Excel verslun vegna þess að það hefur verið eytt úr MS Excel verslun eða hefur verið bætt við Abacus verkefnið sem verslun var flutt. Samkvæmt því, ef notendur vilja til auðveldlega 'greina' hvaða tengsl hafa verið bætt á við innflutning þeir geta einfaldlega búa til nauðsynlegar eign á gerð tengingarinnar og setja það sjálfgefið að auður þannig að þeir munu vera vara um nýja tengingar í hvert sinn sem innflutningur er lokið.

Note

Við innflutning á MS Excel verslun ýmsar varnaðarorð geta birst. Í fyrsta lagi, ef nýr dálkur var bætt við Excel sem passar ekki "setningafræði" fyrir eign eða fest hluti dálkurinn verður hunsað. Next, línu-við-línu varnaðarorð birtist fyrir hvaða málefni við gögn um hverja röð Excel verslun. Þessar viðvaranir byrja með röð númer í hornklofum og ef við dálkinn umbúðum (þ.e. "[23, J] ... 'fyrir röð 23, dálki J) og getur vísað til Eydd atriði, ósamþykkt Standards eða fest Component nöfn (sem eru hunsuð eins og á huga ofan) eða ógild eða auður ID varðandi nýja röð / frumefni (sem verður bætt við). Fyrir nánari grein á populating Abacus með Excel bæklingum vinsamlegast vísa til Avolution Community eða Portfolio Manager námskeið.

Note

Nýja hluti og tengingar er bætt við sjálfkrafa á efsta stigi á innihaldsefnum eða tengingar safni valið Architecture. Til að breyta foreldrum nýju hluti eða tengingar hægrismella á stigveldi Path klefi fyrir nýja hluti eða tengingar röð og veldu Breyta Parent ...og velja viðeigandi foreldri (taka mið af þvingun auðkenning ).

Note

Elements bætt beint verslun í gegnum 'Bæta við nýju' hnappinn, límt inn í verslun, eða búin með innflutning í verslun frá MS Excel eru undanþegnir sía þar til verslun er lokað. Þetta er að gera allar nauðsynlegar breytingar á gildi dálki sem ekki uppfylla núverandi skilyrði sía á verslun. Þessar nýju frumefni raðir eru sýndir með '+' tákn í röð selector klefi í upphafi línunnar, sem er litað grænt ef þátturinn uppfyllir nú vistaða sía viðmiðanir verslun (þ.e. verður áfram á verslun ef aftur opnað), og rauður ef það virkar ekki.

Til bera saman innihald vörulista með annarri arkitektúr

1. Vinsamlegast vísa til efni hér .

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Populating vélina þína frá Visio | Populating vélina þína frá Excel


Populating með Fylki

Navigation: Populating vélina þína>

Populating með Fylki

Senda athugasemdir um þetta efni.

A fylki gerir þér kleift að skoða og breyta "bein" tengingar milli efnisþátta á einfaldan tabular háttog einnig að skoða "óbeinn leið 'milli efnisþátta samkvæmt hvaða millistig hluti (og tengingar).

Til búa a Matrix skoða í Abacus

Note

Þó allt Architect notendur geta búið fylkjum til að bjarga þeim og / eða stillingar þeirra við notandi leyfisveitandi þarf Hönnuður bæta við-á hæfileiki. Þetta er til að "vernda" stillingar núverandi Fylki sem er heimilt að deila með mörgum notendum. Hins vegar Architect notar án Designer bæta við-á getur samt valið að "Save As" allar nýjar stillingar á nýju Matrix. Og auðvitað allt notandaleyfi getur valið að "Fleygja 'allar breytingar á núverandi Matrix. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

1. Veldu Insert | Matrix.

2. Í rchitecturE>draga niður velja Architecture sem inniheldur hluti og tengingar sem þú vilt skoða.

3. Í <SourceSlá>draga niður velja íhluta sem þú vilt hafa tilvik sem talin eru upp sem "raðir' niður vinstrigrindarefnisins.

4. Í <SinkSlá>draga niður velja íhluta sem þú vilt hafa tilvik sem talin eru upp sem "dálkum' yfir the toppurgrindarefnisins.

5. Í rífa niður Það eru í raun tveir "stillingar" af fylkinu þú getur tilgreint ...

Tengingar "bein" fylki

6. Einfaldlega sútvöldu eitt (1) eða fleiri tenging tegundir á hægri hönd hlið af valmyndinni sem birtist ef þú vilt sjá í 'frumum' í fylkinu ef an skýrtenging er frá Lóðrétt/ 'róður"Hluti af fylkinu þess sem að Lárétt/ 'dálki"Hluti af fylkinu.

Note

Aðeins tengsl við uppruna endir fest við Lóðrétt/ 'róður'Hluti og vaskur enda tengdur við Lárétt/ 'dálki'Hluti verður sýnd. Skipta á Sourceog Sinkíhluta val til að skoða tengingar í gagnstæða átt.

7. The Matrix verður byggð með "X" í frumum (eða verðmæti eigna - sjá hér að neðan) ef það er tenging frá Lóðrétt/ 'röð 'hluti af fylkinu þess sem að Lárétt/ 'dálki"Hluti af fylkinu.

Note

Fyrir stór fylkjum aðeins að hámarki 100 raðir eða dálka (þ.mt hrundi raðir / dálka) verður sýnt í einu eins og sýnt með 'R' og vísar "C" í efst í vinstra haus klefi sig. Til að skoða fleiri línur nota skrunrönd. Á hvaða tíma þú geta tvöfaldur smellur á Lóðrétt/ 'róður"Eða HorizontAl / 'dálki'Hluti fyrirsagnir og hoppa tilsamsvarandi hluti í Explorer glugga.Foreldrar lóðrétta/ 'róður' og Lárétt/ 'dálki'Hlutis eru einnig mögulega sýnd sem stefnir raðir / dálka með gráum fyrirsögninni titil. Þegar hrunið (með einni smella á fyrirsögn klefi) ef börn viðhengi hendi þá "X" verður mögulega verið sýnd ef öll börnin voru fest eða 'O' verður mögulega verið sýnd ef aðeins nokkur af þeim börnum voru fest. Frumurnar geta verið lituð samkvæmt fasteignamati tenginga með því að smella á Options 'gír hjól' efst til hægri fylkið stikunni og velja Colour Settings ... og þá á Breyta hnappinn og velja Litur með timestamp eða Colour By Property valkostur og velja eign, sem Min og Max gildi svið og velja liti, þó aðeins List, Integer, Decimal, Boolean eða Date / Time gögn gerð eiginleikar munu lita. Ef hrunið klefi verður lituð samkvæmt meðaltali eignarskattur af tengingum. Í stað þess að "X", eign gildi fyrir frumur geta verið sýnt með því að smella á Options 'gír hjól' efst til hægri fylkið stikunni og velja að sýna gildi Settings ... og þá á Breyta hnappinn og velja Show eign valkost og velja eign.

Beinar tengingar Matrix sýna Servers þar Umsóknir eru hýst með litarefni og eignum sé sýnt í stað þess almenna 'X'

- OR -

"Óbeinn" tengingar fylki

6. Sútvölduruna tenging tegundir og hluti tegundirá hægri og vinstri hönd hlið af valmyndinni sem birtist ef þú vilt sjá í 'frumum' í fylkinu ef an óbeinn leið tengdra íhlutatil frá Lóðrétt/ 'róður"Hluti af fylkinu þess sem að Lárétt/ 'dálki"Hluti af fylkinu.

Note

Allar löglegar leið sem felur í sér þætti valin í slóð valmyndinni willa að sýnaán tillits til stefnu undirliggjandi tengsl, þó, þegar velja leið sem Fyrstaog Síðustu þættir valinn verður tegunda tenginga. Enn fremur er Til af þeim þáttum sem hafa verið valin birtist með tölulegar forskeytiðí veldi ('[]') sviga og gefið tegund getur verið innifalinn mutliple sinnumí götunni (eins og sést á tölulegum forskeyti). Röð val á hluti gerða eða tegunda tenginga er túlkuð sem 'Eða'slóð og stigveldi meðfylgjandi íhluta má mögulega með því að haka við "Einnig leitað Viðhengi foreldra / börn"Kassann. Skipta á Sourceog Sinkíhluta val til að skoða slóðir í gagnstæða átt.

7. The Matrix verður byggð meðHeim / safn af íhlutumí frumum, ef það er Slóðin frá Lóðrétt/ 'röð 'hluti af fylkinu þess sem að Lárétt/ 'dálki"Hluti af fylkinu.

Note

Fyrir stór fylkjum aðeins að hámarki 100 raðir eða dálka (þ.mt hrundi raðir / dálka) verður sýnt í einu eins og sýnt með 'R' og vísar "C" í efst í vinstra haus klefi sig. Til að skoða fleiri línur nota skrunrönd. Á hvaða tíma þú geta tvöfaldur smellur á Lóðrétt/ 'róður"Eða HorizontAl / 'dálki'Hluti fyrirsagnir og hoppa tilsamsvarandi hluti í Explorer glugga.Foreldrar lóðrétta/ 'róður' og Lárétt/ 'dálki'Hlutis eru einnig mögulega sýnd sem stefnir raðir / dálka með gráum fyrirsögninni titil. Þegar hrunið (með einni smella á fyrirsögn klefi) ef einhver börn brautir hendi þá "X" verður mögulega verið sýnd ef öll börnin voru fest eða 'O' verður mögulega verið sýnd ef aðeins nokkur af þeim börnum höfðu leiðir. The óbeinum hluti slóð getur verið lituð samkvæmt fasteignamati íhluta með því að smella á Options 'gír hjól' efst til hægri fylkið stikunni og velja Colour Settings ... og þá á Breyta hnappinn og velja Litur með timestamp eða Colour By Property valkostur og velja eign, sem Min og Max gildi svið og velja liti, þó aðeins List, Integer, Decimal, Boolean eða Date / Time gögn gerð eiginleikar munu lita. Property gildi fyrir óbeinum hluti slóð getur verið sýnt með því að smella á Options 'gír hjól' efst til hægri fylkið stikunni og velja að sýna gildi Settings ... og þá á Breyta hnappinn og velja Show eign valkost og velja eign.

Óbein tengsl Matrix sýna Forrit sem framkvæma tiltekið Þjónusta með deild

Til síaa Matrix skoða í Abacus

1. Tryggja að þú hafa a nýr Matrix skoða opinn.

2. Smelltu á síu ása 'trekt' efst til hægri fylkið stikunni.

3. Á Source og / eða vaskur flipa bæta Nafn, eigna, Lýsing, stigveldi eða Standard síur með því að smella á Bæta við hnappinn, velja Property ef þörf krefur og smella OK. Veldu viðeigandi valkosti í leitarorð / Items spjaldið með rökfræði / setningafræði eins og lýst er í skýringu hér að neðan. Forsýning spjaldið mun sjálfkrafa uppfæra til að sýna niðurstöður núverandi setja síur.

Note

Fyrir Timestamp, stigveldi Path, Nameeða Lýsingsíur eða Text, Integer, Decimal, Booleaneða Date / Timeeign síur samsvörun er flutt eins og '*' algildistákn eru sjálfkrafa beitt fyrir og eftir hvaða band gildi svo að innganga í "köttur" (án gæsalappa) myndi fela raðir með 'Bobköttur','kötturkona "eða" til framkötturjón 'osfrv Multiple /' eða 'gildin má skrá á nýjum línum með Ctrl + Enter. Fyrir Integer og Decimal eign síur "og" rökfræði kunna að vera með "&"(Án gæsalappa) og hærri en / minna en etc rökfræði má tilgreina með '> =','>','<'Og'<="(Án gæsalappa) t.d. '> = 50000 & <90000'. Non-eyða metin raðir má með því að slá inn '(Non-Blanks)"(Án gæsalappa) og Blank metin raðir má með því að slá inn '(Blanks)"(Án gæsalappa).Fyrir Standards eða List Eign filters The '(velja allt) "kassann gerir allar aðrar kassana í raun meðal öllum tiltækum atriði. The '(Non-Blanks)' kassann mun fela í sér allir utan auður eign metin þætti. The '(Blanks) "kassann mun fela auðar húsnæði sem þætti. Og óhindraður neinar sérstakar metin reitina sjálfkrafa afvelja the '(Merktu við allt) "og" (-blanks non)' gátreit samkvæmni. Og að lokum, eru allar síur sjálfgefið ræða særandi svo 'köttur "(án gæsalappa) myndi fela í sér þætti með' köttur", "Cat" eða "CAT" o.fl. Til ræða viðkvæmar samsvörun, slá '(Case)"(Án gæsalappa) fyrir streng t.d. '(Case) Cat "(án gæsalappa) myndi aðeins fela í sér þætti með' Cat" í þeim.

Að byggja með því að nota Matrix útsýni í Abacus

Note

Þú getur aðeins bæta við / fjarlægja tengingar þar einn tengingarinnar hefur verið notuð fyrir Path lýst er hér að ofan.

1. Til bæta tenginguaf þessari tegund milli a Lóðrétt/ 'róður'Hluti og Lárétt/ 'dálki"Hluti af fylkinu, þar sem" X "er ekki þegar fyrir hendi(eða sýnt eignarskattur - sjá skýringu að ofan), Tvöfaldur smellur the klefi. An "X" ætti að birtast (eða eignarskattur - sjá skýringu að ofan) og tenging verður búin á efsta stigi í Connections söfnun fyrir valið Architecture.

Note

Nafnið tengsl munu vera gerð tengingar nafn eins og á gerð tengingarinnar stilling fylki og ef verðmæti eigna er birt í stað "X" sjálfgefið gildi fyrir eign verður sýnt.

2. Til breyta sýnd gildi eigná tengsl a Lóðrétt/ 'róður'Hluti og Lárétt/ 'dálki"Hluti af fylkinu, Tvöfaldur smellur the klefi, eða hægri-smelltu á reitinn og veldu Edit Gildi ... og breyta gildi í Breyta Value valmynd.

3. Til fjarlægja tenginguaf þessari tegund milli a Lóðrétt/ 'róður'Hluti og Lárétt/ 'dálki"Hluti af fylkinu, þar sem" X "er þegar til(eða sýnt eignarskattur - sjá skýringu að ofan), rétt-smelltu klefiog veldu Aftengja. The X að hverfa og tengingin verður eytt úr verkefninu.

Til að spara / vista sem aMatrix skoða

Note

Þó allt Architect notendur geta búið fylkjum til að bjarga þeim og / eða stillingar þeirra við notandi leyfisveitandi þarf Hönnuður bæta við-á hæfileiki. Þetta er til að "vernda" stillingar núverandi Fylki sem er heimilt að deila með mörgum notendum. Hins vegar Architect notar án Designer bæta við-á getur samt valið að "Save As" allar nýjar stillingar á nýju Matrix. Og auðvitað allt notandaleyfi getur valið að "Fleygja 'allar breytingar á núverandi Matrix. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarft hönnuður bæta við-á hæfileiki.Og muna, þetta er bara stillingar Matrix, allar breytingarnar sem gerðar voru á gögnum í Matrix eru í stað beitt geymsla, óháð.

1. Tryggja að þú hafa a nýr Matrix skoða opinnog þú hefur gert nauðsynlegar breytingar.

2. Í Matrix skoðaTækjastika smella á lengst til vinstri Vista Matrixhnappinn til að vista Matrix skoða og allir formatting breytingar.

Note

Ef þú ert ekki með Vista hnappinn í Matrix skoða stikunni þá þarft þú ekki að Designer bæta við-á og þú ert aðeins fær um að Vista semöllum stillingum breytist í nýja fylkið þegar þú ferð að loka núverandi fylki.

3. Ef að MatrixNamevalmynd sem birtist (vegna þess að vera a New Matrix) sláðu inn heiti fyrir Matrixog ýttu OK.

Til útflutningur til MS Excel fylki

1. Tryggja að þú sért með Matrix skoða opinn.

2. Smelltu á Flytja út í Exceltækjastikuhnappur.

3. Veldu skrá nafn til að vista MS Excel fylki sem. Smelltu Vista.

Note

Sjálfgefið skráarheiti útfluttar MS Excel Fylki mun vera Matrix nafn merki á eftir Architecture nafni í sviga, td 'Umsóknir farfuglaheimili á Servers (2014 Actual) .xlsx. Þú getur breytt einhverju af þessu, þar á meðal hvort skrá snið er að vera .xlsx eða .xls.

Matrix formattinger flutt sjálfgefið, þó að stórum fylkjum þetta getur leitt til þess að útflutningur sé alveg hægt. Samkvæmt því, í Verkfæri | Valkostir ...þá á að Matrixflipi,þú ert fær um að draga úr the magn af formatting sem er fluttur eins og sést á Matrix flipi neðan, þannig hraðakstur upp útflutning.

Matrix útflutningur möguleikar

4. An Export Lokið glugganum birtist. Smelltu OK.

Flutt til MS Excel fylki

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Populating vélina þína frá Visio | Populating vélina þína frá Excel


Populating Skýringarmyndir

Navigation: Populating vélina þína> Using Teikningar>

Populating Skýringarmyndir

Senda athugasemdir um þetta efni.

Teikningar í Abacus eru fleiri en bara handahófskennt fulltrúa. Þeir eru sérsniðin útsýni yfir arkitektúr, snið og raða til að sýna ákveðna merkingu.

The Teikning Tól knýja hierarchic uppbyggingu arkitektúr, svo sem þættir eru sjónrænt hreiður innan aðra hluti - í raun að gefa 'grunnmynd "þá þætti. Þegar hluti eða tenging hefur verið skilgreind í arkitektúr, það geta vera notaður í allir tala af mismunandi skýringarmyndir. Mikilvægt er Teikning Tool er í nánum tengslum við byggingarlist fyrirmynd, þannig að breytingar gert á annaðhvort einn eru alltaf endurspeglast í hinu.

The tól virkar með því að tengja form með þá einkum tengsl og hluti gerðir eru skilgreindar í Tegundir hluta arkitektúr. Þessi samtök mismunandi eftir því hvaða gerð af myndinni dregin, og það er hægt að ein tegund af þætti (eða tengingu) getur haft mismunandi framsetning á mismunandi skýringarmyndir, fer eftir samhenginu.

Til að setja upp tengsl milli móta og component eða tegund tengingar

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn .

2. Maximise abacus forritið og stilla glugga hlutföllum eins og þú vilt.

3. Veldu Form flipanneða Tengi flipann í stencil glugga.

4. Í Gerðútibú Explorer, finndu íhluta eða gerð tengingar sem þú vilt tengja við lögun eða tengið.

5. Veldu valið tegund þáttur frá trénu, draga það yfir á form flipi eða Tengi flipann og sleppt því á lögun eða tengiþú vildi eins og til að nota.

Note

Þú getur staðfest tengsl þú hefur búið til með því að velja þá hluti eða tengingar flipann í stencil glugga, sem sýna nú í tengslum þætti.

Að bæta við nýjum form til skýringarmynd þinn / bókasafn

1. Búa til MS Sjón skýringarmynd með form sem þú vilt bæta við teikningu og flytja MS Sjón skýringarmynd .

Ábending

Það er mikilvægt hvað stærð þú gerir skipstjóra form í MS Visio því ABACUS striga er stór í pixlum og aðeins mm einingar í MS Visio umbreyta granularly að punkta á 4 punkta 1 mm hlutfall. Ennfremur eru sjálfgefnu Abacus form oftast 60 punktar á hæð svo það þýðir að 15 mm í MS Visio. Merking er ráðlegt Skipstjóri lögun stærð í MS Visioer 25mm breiður með 15mm háumeins og þetta mun þýða að 100 punktar á breidd með 60 punkta hár í Abacus.

Ábending

Ef þú vilt hafa smá 'táknið' efst í vinstra horninu á laginu þá getur þú einfaldlega að búa á 'táknið' í skipstjóra MS Sjón lögun með því að nota MS Visio teikning tól litatöflu (athugið að einungis einfaldar línur, hringi og ferhyrninga eru studd og röstuð / punktamynd form einkum eru ekki studdar). Enn fremur, ef þú vilt á táknið til að vera fastur í stærð / skalainnan lögun í Abacus þá getur hópur á 'táknmynd' í skipstjóra MS Sjón laginu með því að velja alla þætti þess, hægri-smella á einn þáttur, velja Shape | Group, þá hægri-smella á flokkaðar lögun og velja gögn | Shape gögn ..., velja Já í glugganum sem birtist og þá bæta við eign með Label stillt LockScale(athugið hástafi "L" og "S"), gerð stillt á Boolean og Gildi stillt á að vera TRUE (athugið að það er allt í hástafi).

Ábending

Ef þú vilt hafa hluta af laginu fryst sléttun lárétt eða lóðrétt (sem er einkennandi með laginu "sundbraut ') þá getur þú hægri-smelltu á hlutinn (s) af meistara MS Sjón lögun sem þú vilt fryst sléttun og veldu gögn | Shape gögn ..., velja Já í glugganum sem birtist og þá bæta við eign með Label stillt LockXScaleeða LockYScale (athugið hástafi "L" og "S"), gerð stillt á Boolean og Gildi stillt á að vera TRUE (athugið að það er allt í hástafi), fyrir læst lárétt eða lóðrétt stigstærð sig.

Ábending

Til að leyfa litarefni í formi í Abacus eftir að flytja frekar en lögun alltaf vera fastur litur það er ráðlegt að gera fylla skipstjóra MS Visio forms gagnsæ og þá nota innbyggðri getu í Abacus að lita bakgrunn a forms. Þetta virkar aðeins með rétthyrningur eða náinni rétthyrningur (td Ávalur rétthyrningur) stærðum eins og allt rétthyrndum bakgrunnur verður lituð.

2. Opna samsvarandi skýringarmynd og veldu Hluti flipií stencil glugga.

3. Fyrir hvert nýtt form sem þú vilt koma á framfæri við aðra skýringarmyndir Hægrismellalögun og velja Bæta við form bókasafnið. Þetta mun gera lögun boði á form flipann í stencil glugga.

4. Tengja viðeigandi íhluta með nýja lögun frá form bókasafninu samkvæmt skrefum sem lýst er hér að ofan.

Note

Aðeins einfalt og "vektor-undirstaða" form eru studd í Abacus í augnablikinu, eru þ.e. bitmaps ekki studd. Hins vegar tæki svo sem Vector Magic ( www.vectormagic.com ) Eru í boði sem mun fúslega umbreyta punktamynd myndir í vektor-undirstaða form (þ.e. SVG sniði) sem hægt er að opna í MS Visio og þess vegna notaðar í Abacus samkvæmt ofangreindum leiðbeiningum.

BætiHluti og Tengingar

The Teikning tól leyfir þér að bæta núverandi hluti og tengingar frá geymsla eða búa til nýjar hluti og tengingar sem þú ert að teikna skýringarmynd. Eins íhlutir og tengingar eru búnar í skýringarmyndum, eru þeir samtímis bætt inn í geymsla. Það eru þrír mælt leiðir að bæta hluti til skýringarmyndog þrír mælt leiðir bæta tengingar til skýringarmynd:

Til að búa til alveg nýja hluti eða tengingu á skýringarmyndfrá stencil

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Veldu Hlutieða Tengingarflipann í stencil glugga til að sjá tilheyrandi form. Aðeins þessi form er hægt að nota til að búa til nýja þætti líkan.

3. Smelltu og dragðueitt af tiltækum tengslum form yfir teikniborðinu striga. The nýr þáttur mun birtast á striga og í Explorer tré.

4. Byrja að slánafn fyrir nýja þáttur í glugganum og allir núverandi þætti sem eru samræmdar eru leiðbeinandi og má velja frekar en að bæta við nýjum þáttum að arkitektúr.

5. Smelltu OK.

6. Ef lögun var varpað á núverandi hluti, þá mun það annað hvort verða barn að hluti (ef lögun kom frá Hlutiflipanum), eða mun vera tengdur við þá hluti (ef lögun kom frá Tengingarflipanum).

Note

Það er stundum nauðsynlegt að stilla nýja hluti eða tengingu í annan stað í byggingarlist stigveldi með Explorer.

Til að setja núverandi hluti eða tengingu frá geymsla á skýringarmynd

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Vertu viss um að þú hafir bæði teikna tæki og Explorer gluggum sýnileg.

3. Í Explorer, finndu hlutieða tenging(element) sem þú vilt bæta við myndinni.

4. Smelltu og dragðuvalið þáttur á myndinni. A lögun fulltrúi þáttur mun birtast á striga.

Note

Ef gerð valið frumefni er þegar tengt við lögun, samsvarandi lögun mun birtast á striga. Ef hins vegar það er engin skilgreind félag fyrir viðkomandi frumefni, sjálfgefið lögun (rétthyrningur) mun birtast á striga nema Framfylgja Skýringarmynd Sjónarmið valkostur er í því tilviki móta verður ekki bætt við skýringarmynd.

Ábending

Þegar hluti er lögð á myndinni sem er tengdur við annan efnisþátt þegar á myndinni, teikniborðinu Tól mun fyrirspurn ef þú vildi eins og til að sýna tengingu (s) á milli þeirra. Einnig, ef það eru engin börn í hluti teikniborðinu Tól mun fyrirspurn ef þú vildi eins og til að fela börnin í endurkvæma hátt.

Til búa til tengingu milli 2 þætti eða tengda hluti á skýringarmynd með dynamic tengi

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Hover yfir hluti á myndinni sem þú vilt tengja við aðra hluti og þú munt taka eftir 2 tákn birtast utan efst hægra megin mörkum laginu eins og sýnt er hér að neðan. Ath: The toppur táknið er til að búa til tengingu þar sem sveima hluti er að vera uppspretta, the botn táknið er til að búa til tengingu þar sem sveima hluti er að vera vaskur.

3. Færa bendillinn yfir viðkomandi táknmynd og smelltu og dragðutáknið til yfir annað hvort yfir annað íhluta eða lausu plássi á striga eins og sýnt er hér fyrir neðan.

4. Til að tengjast núverandi hluti velja Hengja við ...atriði í pop-upp valmynd og ef þarf beit á undir-valmyndinni til að velja úr tiltækum tegunda tenginga.

- Eða -

4. Til að búa til tengingu hluti valdi úr New ...atriði í pop-upp valmynd og ef þörf krefur beit til undir-valmyndinni til að velja úr tiltækum tegunda tenginga eins og sýnt er hér fyrir neðan. Byrja að slánafn fyrir nýja þáttur í glugganum og allir núverandi þætti sem eru samræmdar eru leiðbeinandi og má velja frekar en að bæta við nýjum þáttum að arkitektúr.

Note

Framboð hluta í pop-up valmyndinni og undir-valmyndinni er stjórnað með þvingun í meta-líkan.Það er aðeins gild uppspretta eða sökkva hluti tegundir sem ræðst af tengingu þvingun verður kynnt sem Hengja ... og New ... matseðill atriði.

Til aftur opna þáttur val valmynd og setja núverandi hluti eða tengingar frá geymsla á skýringarmynd

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Smelltu að Open Element Valhnappinn í Skýringarmynd tækjastikunni. Athugið: þáttur val valmynd mun opna með seinustu af öllum síum vistuð.

3. Veldu hvaða aukaefni sem óskað er eftir að bætast við skýringarmynd og smella OK. Ath: nýja efni verður bætt til að hreinsa pláss á striga og skýringarmynd má síðan lagði út aftur í gegnum Skipulag Skýringarmyndhnappinn í Skýringarmynd tækjastikunni.

Using FreeformForm

Það er oft æskilegt að skapa sjónræna þætti í myndinni fyrir hreinum fagurfræðilegum ástæðum. Þessir þættir geta hjálpað bæta skipulag og útlit skýringarmynd, enn þeir hafa ekki strangar byggingarlistar þýðingu. The Teikning Tool gerir notkun Freeform form til að veita teikna sveigjanleika.

Til að bæta freeform lögun til skýringarmynd

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Veldu Formeða Tengiflipann í stencil glugga.

3. Smelltu og dragðueitt af tiltækum stærðum eða tengjum á teikniborðinu striga. The nýr þáttur mun birtast á striga - en ekkií landkönnuður tré.

Note

Freeform form eru "ekki tengd" form, eins og þeir hafa engin tengsl við neina sérstaka hluti eða tengsl í byggingarlist fyrirmynd.

Til birta geymsla upplýsingar í Freeform löguns áskýringarmynd

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Hægrismellasem Freeform lögun og veldu Umsögnina | Sýna.

3. Veldu til að sýna annað hvort Skýringarmynd Name, Skýringarmynd Lýsing, Skýringarmynd Property, Sjónarmið Nameeða Arkitektúr Name.

Note

Textinn í Freeform mun sjálfkrafa uppfæra eins undirliggjandi geymsla gagna breytingar.Á þennan hátt er hægt að skapa táknmynd 'titill blokk "fyrir, og þá er auðvelt að afrita yfir, skýringarmyndir.

Using Fljótandi form

Fljótandi form eru í raun önnur leið til að tákna hluti í myndinni. Íhuga stofnun með helstu deildum: Forstjóri, markaðssetningu, sölu og þróun.

Tree View

Þessi skilrúm mega vera sjónrænt fulltrúa í lagskiptu hátt:

Lagskipt View

Eða þeir kunna að vera sjónrænt fulltrúa í skjögur / Fljótandi hátt til að sýna stigveldi:

Skjögur / Fljótandi View

Síðarnefndu framsetning notar hugtakið fljótandi form.

Til að breyta lagskipt hluti lögun í fljótandi formi

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Veldu hlutií myndinni þinni sem þú vilt að tákna sem fljótandi form eða tengdu form í Hlutiflipanum stencil glugga sem þú vilt öll tilvik sem fljótandi form.

3. Hægri-smelltu á lögun og veldu Fljóta Component úr samhengi matseðill sem birtist. Athugið demantur headed tengingufrá foreldri hluti (m) á fljótandi hluti (s).

4. Smelltu og dragðusá hluti á réttan stað. Þegar fljótandiþáttur er valinn mun það hafa bláa útlínur.

Til að breyta fljótandi hluti lögun í lagskipt form

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Veldu hlutií myndinni þinni sem er nú verið sýnd sem fljótandi form eða tengdu form í Hlutiflipanum stencil gluggann sem þú vilt öll tilvik sem lagskipt form.

3. Smelltu og dragðuthe floating hluti (s) aftur við móður-(s) (í samræmi við demantur headed tengingu). Athugið: Ef þú gerir það ekki þetta þá þegar þú breyta hluti (s) aftur að vera lagskipt stigveldi af líkan gæti haft áhrif.

4. Hægri-smelltu á lögun og afvelja Fljóta Component úr samhengi matseðill sem birtist. Bent er á að demantur headed tengingufrá foreldri hluti (s) til fljótandi hluti (s) mun hverfa.

Eftirmynd

The Teikning tól leyfir þér að bæta við sama hluti til skýringarmynd nokkrum sinnum með hverja sjón eintak af hluti á myndinni kölluð eftirmynd. Þetta er einkum gagnlegt fyrir teikningar þar sem hluti hefur fjölda tenginga sem fylgir henni og það er æskilegt að sýna hluti í mörgum stöðum nær uppruna hvers tengingar, eða skýringarmynd þar sem einn-á-marga samband íhluta er æskilegt að sýna með því að nota fljótandi lögun (sem lýst er hér að ofan) með hluti í mörgum stöðum á toppur af the "mörgum 'hluti það er tengjast.

Note

Hægt er að hengja / taktu tengingar til / frá upprunalega eintak af hluti á skýringarmynd (eins og alltaf), en einnig einhverju eftirlíkingar, hins vegar þegar tengsl eru sjálfkrafa bætt við skýringarmynd þeir eru tengdir við fyrsta eintak af hluti á myndinni sjálfgefið.

Note

Eftirlíkingar geta sameinast hvert öðru með hægri-smella og dragaþá velja Sameina eftirmyndÞó sameina eftirmynd með mismunandi hluti í för með öðrum eftirlíkingar hverfa frá myndinni.

Note

Það er engin sjónræn munurinn á milli upprunalegu dæmis íhlutar á skýringarmynd og hvaða eftirmynd. Ennfremur, hægri smellur matseðill fyrir upprunalegu hluti á skýringarmynd og hvaða eftirlíkingar er eins, með til dæmis Sýna í Explorerog færir þig á sama hluti í trénu View af geymsla (aka líkaninu). Hins vegar hægrismella á hluti í trénu View af geymsla og velja Fara tilog beit til skýringarmynd með eftirlíkingar mun alltaf taka þig á "elsta" eintak af hluti á myndinni. Venjulega mun þetta vera frumleg dæmi sem var bætt við myndinni en ef að upprunalega eintak var síðan eytt eða sameinuð með eftirmynd þá fara að vilja hoppa til elsta af hinum eftirlíkingar sem var bætt.

Til bæta eftirmynd til a skýringarmynd

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Hægri-smelltu á núverandi hluti á myndinni og veldu Búa eftirmynd.A eftirmynd af völdum hluti verður búin til hægri upprunalegu hluti.

- OR -

Veldu fyrirliggjandi hlut á skýringarmynd og stutt Ctrl + Ceða hægri-smelltu á núverandi hluti á myndinni og veldu Afrita. Nú er hægrismellt á staðsetningu á myndinni sem þú vilt eftirmynd og veldu Líma sem Replica. Ath: ýta á Ctrl + V (eða með því að hægrismella og velja Paste) mun búa til afrit af upprunalegu íhluta sem ekki a eftirmynd.

- OR -

Smelltu og dragðuhluti úr tré View af geymsla (aka módelið) á skýringarmynd þar sem hluti er þegar til.

Stilli Connection Paprika / Endar

The Teikning tól leyfir þér að stilla nota táknið á endunum tengingu línur annaðhvort fastri tákn eða tákn háð á eign á sjálfrar tengingarinnar.Þetta er sérstaklega gagnlegt fyrir teikningar þar sem átt tengingu ber að vera sýnt, eða fyrir teikningar þar sem cardinality tengingar (eða átt sem er) er að finna í eign á sjálfrar tengingarinnar, td 'Einn-á-Margir' vs 'Margir-til-Margir' (eða 'Source að sökkva' vs 'Sink Heimild').

Til stilla tengistillingar húfur / endar á skýringarmynd

1. Tryggja að þú hafa a nýr eða núverandi skýringarmynd opinn.

2. Veldu Tengjastjónirflipann í stencil glugga.

3. Hægri-csleikja einn af tengd tegundum tengistillingar og veldu Stilla Paprika ....

4. Fyrir fast tengingu cap / enda í hvorum uppruna eða sökkva enda tengingu tryggja viðeigandi Fast útvarp hnappur er valinn og síðan velja endir tengsl tákn af rífa niður, td "Arrow Head 'eða' Diamond '.

- OR -

Fyrir eign-undirstaða tengingu cap / enda í hvorum uppruna eða sökkva enda tengingu tryggja viðeigandi Using Propertyútvarp hnappur er valinn, þá smelltu á '...' hnappinn og velja þarf eign og þá við hliðina á hverjum enda tengingu tákn slá eign gildi þar sem tiltekin tengsl tákn eru til að sýna fram á.

Note

Margar eign gildi fyrir tiltekið tengiendanum tákn má færa aðskilin með kommum.T.d. valmynd hér að neðan sýnir að ef "Data | Cardinality 'hóteli gildið' One-til-Margir 'þá uppspretta lok tengingu mun hafa tvær lína högg í gegnum það og vaskur lok tengingu mun hafa eitt línu heilablóðfall í gegnum það og þá aðdáandi-út af tveimur lína högg í lokin.

Stilla Caps valmynd

Sjá einnig

The Teikning Tól | Populating vélina þína | Greining arkitektúr þinn


Populating vélina þína

Navigation: Populating vélina þína>

Populating vélina þína

Senda athugasemdir um þetta efni.

Ferlið við að byggja upp líkan af arkitektúr er þekktur sem populating. Þegar þú hefur fundið vélina þína og greind kröfur þínar, þú ert tilbúinn til að fyrirmynd arkitektúr í Abacus.

Á íbúa, þú munt slá inn allar þær upplýsingar sem þú veist um arkitektúr og hvað þarf af því.

Að byggja vélina þína

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin , An landkönnuður birtist , Og An arkitektúr bætt .

2. Handvirkt byggja Aðal-hluti og tengingar vélina þína. Venjulega mun þetta vera meira abstrakt hluti og tengingar.

- Eða -

2. Myndrænt byggja hluti og tengingar sem þú vildi eins og sjá fulltrúa skýringar, með því að nota Teikning Tool .

Þú gætir einnig viljað

3. Byggja með Vörulistar - Er hægt að skoða og hluti og tengingar á einfaldan tabular hátt.

4. Byggja með Fylki - Þú getur skoðað og breytt tengsl milli efnisþátta á einfaldan tabular hátt.

5. Byggja frá Microsoft Access - Þú getur flutt arkitektúr frá og flytja til Microsoft Access.

6. Byggja frá Microsoft Visio - Þú getur flutt arkitektúr frá og flytja til Microsoft Visio.

7. Byggja frá Microsoft Excel - Þú getur flutt arkitektúr frá og flytja til Microsoft Excel.

8. Byggja frá Microsoft SharePoint - Þú getur flutt arkitektúr frá og flytja til Microsoft SQL Server.

9. Byggja frá Microsoft SQL Server - Þú getur flutt arkitektúr frá Microsoft SQL Server.

10. Innflutningur frá XML - Þú getur flutt arkitektúr frá Abacus XML brot eða ArchiMate Interchange Tungumál XML skrá.

Sjá einnig

Populating arkitektúr handvirkt | The Teikning Tól | Populating vélina þína frá Microsoft Access | Populating arkitektúr frá Microsoft Visio | Populating arkitektúr frá Microsoft Excel


Populating vélina þína frá Microsoft Access

Navigation: Populating> vélina þína Populating frá Microsoft vörum>

Populating vélina þína frá Microsoft Access

Senda athugasemdir um þetta efni.

Þú getur flutt vélina þína til að Microsoft Access til að framkvæma almennar tilgangi útreikningum meðhöndlun eða skýrslur á vélina þína. Þú getur þá flytja arkitektúr aftur í Abacus.

Note

The Open frá Access / Útflutningur til gagnagrunn eiginleiki krefst þess að Microsoft Access 2000eða nýrri er uppsett á tölvunni.

Að flytja vélina þína til Microsoft Access

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopin, þá Explorerbirtist, og arkitektúrbætt við.

2. Veldu File | Export | Til Gagnasafn.

3. Taka mið af viðvörun valmynd eins og lýst er hér að ofan og smella á Yes til að halda áfram.

4. Veldu staðsetningu og skráarheiti fyrir gagnagrunn.

Að flytja handleika arkitektúr í Abacus

1. Tryggja þú hafa Abacus opinn.

2. Veldu File | New og veldu Frá Aðgangurfrá glugganum sem birtist og smellt á OK.

3. Flokka í gagnagrunninn skránni sem þú vilt flytja inn.

Abacus 'MS Access Database stef

ABACUS hefur á hjarta þessn verufræði / Meta-meta-líkan samanstendur af íhlutum, Tengsl og þvingun. Þetta "CCC" nálgun var úr ýmsum stöðluðum aðferðum þróast frá 1960 og áfram lýkur í alþjóðlega staðlinum IEEE 1471, sem stofnendur Avolution er stuðlað að. Eftirfarandi frumform gilda;

1. ABACUS inniheldur Bókasöfnaf Standards(eða Standards), Componentog Tengingu ferðalaga, Þvingun, Sjónarmið, Sniðmát (eða Mynstur) Og margir Arkitektúr.

2. Standards, Tegundirog Sjónarmið geturvera rökrétt Flokkaðarfyrir þægindi.

3. Arkitektúr geta innihaldiðmargir afkomandi Arkitektúr(eða þróunar).

4. Hver Arkitektúr inniheldurmargir Hlutiog Tengingará ákveönum Tegundirog ýmis Views.

5. Hlutiog Tengingar getur verið niðurbrotí Undirþættiog Sub-Connections.

6. Hver Componenter föst viðallir tala um Tengingaren hver Tenginggetur aðeins verið föst viðað hámarki tvo Hluti.

7. Hlutiog Tengingargetur hafa Standardsmeð Propertiessvo sem upplýsingar, afköst, áreiðanleika, kostnaður o.fl.

8. Arkitektúr, Hlutiog Tengingargetur hafasérstakur Propertiessvo sem upplýsingar, afköst, áreiðanleika, kostnaður o.fl.

9. Þvingungetur eru fyrir hendi milli Hlutieða Tengingareða gegn Properties.

10. Sniðmáteru staðlaðar blöndur Componentog Tengingu ferðalaga.

11. Sjónarmiðeru staðlaðar samtök Componentog Tengingu ferðalagaað táknunum.

12. Viewssjónrænum framsetningar Hlutiog Tengingar.

Eftirfarandi MS Access Entity Samband Skýringarmynd (ERD) skjöl sem algerlegaArkitektúr, Þróunar, Component / Connection Tegundir (og hópar), Hluti / Connections og Sub hluti / tengingar hugtök.

The Core gagnasafn stefið

Note

Vísun heiðarleiki hefur ekki verið framfylgt á sambandið milli Hluti borð og Connections borð (fyrir 'viðhengi "milli ákveðinnar Heimild eða sökkva hluti og tengingu). Þetta er vegna þess að tengingin getur verið án hluti viðhengi. Við hefðum getað bætt við "viðhengi" borð en í þágu einfaldleika ákveðið gegn því. Auðvitað þýðir þetta að allir útgáfa af Component IDS eða eyðingu Component röðum saman mun leiða rangra gagna. ABACUS höndlar allar rangar á innflutning með því að hunsa þau röng gögn.

Eftirfarandi MS Access ERD skjöl sem Propertieshugtökum arkitektúr, Component / tengingar Tegundir og Hluti / Connections.

Properties gagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Standardshugtak fyrir arkitektúr, Component / tengingar Tegundir og Hluti / Connections.Ath: Töflurnar enn nota hugtakið "Framkvæmd" eins og á fyrri útgáfur af Abacus.

Standards gagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Þvingunhugtak fyrir Component / Connection Tegundir.

Þvingungagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Sjónarmið hugtak fyrir Arkitektúr.Ath: Töflurnar enn nota hugtakið 'TwoDTempl' eins og á fyrri útgáfur af Abacus.

Sjónarmiðgagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Vörulistarhugtak fyrir Arkitektúr.

Vörulistargagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Fylkihugtak fyrir Arkitektúr.

Fylkigagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Skýringarmyndirhugtak fyrir Arkitektúr.Ath: Töflurnar enn nota hugtakið 'TwoD' eins og á fyrri útgáfur af Abacus.

Note

The Component / Connection Type að stencil lögun kortlagning og Freeform móta hluta af MS Access ERD hefur verið sleppt til skýrleika.

Skýringarmyndirgagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem 3D Viewshugtak fyrir Arkitektúr.

3D Viewsgagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Chartshugtak fyrir Arkitektúr.

Chartsgagnasafn stefið

Eftirfarandi MS Access ERD skjöl sem Mælaborðhugtak.

Mælaborðgagnasafn stefið

Abacus 'MS AccessFyrirspurnir

Fylgir með MS Access Database eru nokkrar gagnlegar fyrirspurnir sem hér segir;

· Comps eftir Props- Þessi fyrirspurn birtir öll hluti í verkefninu (eftir arkitektúr og tegund) og inniheldur allar eignir sem dálkum. Notaðu þessa fyrirspurn með Filters / mælikvarðinn á íhluta og / eða arkitektúr til að framleiða "dæmigerður" töflur fyrir hverja íhluta með eiginleika þeirra.

· Kynsjúkdómar eftir Props- Þessi fyrirspurn er listi yfir allar kröfur sem eru í notkun, fjölda atvika af staðalsins og inniheldur allar eignir sem dálkum. Notaðu þessa fyrirspurn sem staðla verslun.

· Props eftir tegundum- Þessi fyrirspurn birtir öll hluti eiginleika og% þeirra heill hvers íhluta sem dálkum. Notaðu þessa fyrirspurn til að ákvarða hvort tiltekin eignir sé viðhaldið.

· Tegundir eftir Props- Þessi fyrirspurn birtir öll hluti gerðir og inniheldur% heill af öllum eiginleikum sem dálkum. Notaðu þessa fyrirspurn til að ákvarða hvort tiltekin eignir sé viðhaldið.

· Tegund Fjöldi- Þessi fyrirspurn birtir öll hluti tegundir og inniheldur fjölda atvika af hverri tegund í röð. Notaðu þessa fyrirspurn til að ákvarða vinsældir af hverri tegund í verkefninu.

A athugið á að vinna með orðsending sviðum í MS Access

Hluti, Connections og staðlar Nafn sviðum í töflunum eru skilgreind sem orðsending sviðum til að leyfa fyrir ótakmarkaðan fjölda stafa, eins og á Abacus. Fyrir Hluti og tengingar, sem veldur nokkur atriði vegna þess að þeir hafa einnig einkvæmt auðkennisnúmer reit fyrir tilvísun, en fyrir Standards þetta veldur nokkrum vandræðum þegar reynt var að ganga borðum vegna þess að þú getur ekki tekið þátt Minnir sviðum í MS Access. Einnig er hægt að setja a HVAR ákvæði viðmiðanir til að ná sömu áhrif og sýnt er í Visual Fyrirspurn Builder og samsvarandi SQL sýnishorn neðan þeim lista út alla erft Standards eignir til allir þættir í útfluttu Abacus verkefninu.

Minnir sviði 'tengir' í Visual Fyrirspurn Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Frá þáttum INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) OG (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), InnleiÃ INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

HVAR (((ComponentImplementationLinks.Name) = [InnleiÃ] [Nafn]).);

Minnir sviði 'tengir' í SQL

A athugið á sjálfkrafa að búa Abacus auðkenni í MS Access

Ýmsar ABACUS MS Access borð þurfa einstakt lengi heiltala ID svo einfalt VB aðferð er veitt til að aðstoða við kynslóð af þessum. Tvær aðferðir ResetCounter () og GetNextCounter () eru innan Abacus 'MS Access DB og notkun þeirra er sem hér segir; ResetCounter () vilja setja teljarann ​​aftur 0. GetNextCounter () verður aftur næsta gegn í röð.

Aðferðirnar nýta MS-Access 'quirk' að jafnvel ef þú hringja í ResetCounter () aðferð til á hverjum röð insert (þ.e. þegar þú keyrir líka GetNextCounter () virka) þar sem ResetCounter () virka ekki hafa allir breytur það keyrir bara það einu sinni og því ekki að núllstilla teljarann ​​fyrir hverri röð inn. Og einnig vegna þess að sama "quirk 'þú þarft að fara einhverjar gamlar dálk breytu til GetNextCounter () virka til að blekkja hann í gangi hverju sinni.

Það er líka bragð til að vera fær um að keyra ResetCounter () virka í innskoti í SQL staðhæfing því að þú skáhalli bara hafa það að sitja þarna sem súla á eigin spýtur, eins og ef það var að velja fyrirspurn. Það er mælt með því að gera ResetCounter () kalla hluti af einn af öðrum sviðum, því concatenating það til enda, eins og það skilar alltaf null samt.

Hér fyrir neðan er dæmigerð SQL notkun aðferðir til að bæta við lista yfir Component Tegundir frá borð / fyrirspurn kallast 'Component Type List ".

INSERT INTOComponentTypes (Id, nafn, lýsingu)

SELECT GetNextCounter ([Component Type List] .name)AS Auðkenni, [Component Tegund List] .name AS Nafn, [Component Tegund List] .description & ResetCounter ()AS Lýsing

FRÁ[Component Type List];

ABACUS ID / Counter kynslóð í SQL

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Populating vélina þína frá Visio | Populating vélina þína frá Excel


Populating arkitektúr frá Microsoft Excel

Navigation: Populating> vélina þína Populating frá Microsoft vörum>

Populating arkitektúr frá Microsoft Excel

Senda athugasemdir um þetta efni.

Þú getur flutt arkitektúr frá Excel töflureikni (.xls eða .xlsx skrá). The Excel innflytjandi gerir þér kleift að kortleggja lista yfir hluti og tengsl við gerðum, staðla, eiginleika og stöðluðum eiginleikum með því að velja dálkana í töflureikninum sem innihalda viðeigandi upplýsingar.Það er hins vegar meira háþróaður tækni en mælt nálgunfyrir innflutning frá MS Excel sem er með bæklingum eins og lýst er hér .

Note

Innflutningur frá / Export í Excel eiginleiki krefst að Microsoft Excel 2003eða nýrri er uppsett á tölvunni.

The aðalæð virka af Excel innflytjanda er að leyfa þér að skilgreina stillingar skrá (þ.e. valdakerfi byggingarlistar líkan þínum). Stillingaskránni geymir áður vistaðar kortlagning frá Excel skrá til Abacus skrá. Þegar skilgreindur vistuð stillingaskrá er síðar til frekari innflutning og útflutning til .xls skrá.

Note

Skrefin sýnt í köflunum hér að neðan eru sérstaklega fyrir notendur sem hafa enn til að skilgreina og vista stillingaskrá og eru að flytja úr Excel í fyrsta skipti. Þú verður að búa til og vista stillingar skrá til nota útflutning til að skara fram úr aðgerð.

Til að flytja inn Excel töflureikni inn abacus

1. Tryggja þú hafa Abacus opinn.

2. Veldu File | New og velja úr Excelfrá glugganum sem birtist og smellt á OK.

Note

Ef þú vilt flytja inn í núverandi Abacus verkefni þá annaðhvort hægri-smelltu á Components hnút innan Architecture, eða hægri-smelltu á einstaka hluti innan Architecture og þá velja Import | Frá Excel.

3. The Import Excel töflureiknirgluggi verður birt

Import Excel töflureiknir Window

4. Smelltu á Open Excel Filetáknið og beit fyrir Excel skrá sem þú vilt flytja inn.

5. Velja Verkstæðiþú vilt flytja inn úr fellilistanum.

Note

Eftir opnun Excel skrá þína, getur þú notað Gögn Previewflipann til að skoða dálkana og fyrstu 25 raðir af töflureikninum. Hér getur þú fengið dálkinum tölur þarf að fylla út Hlutiog Tengingarflipann.

Þú getur einnig valið hvort þú vilt þættir í Excel töflureikni til að flytja með há- og lágstöfum. Einfaldlega merkið á Innflutningur með há- og lágstöfumvalkostur (sjálfgefið þetta er alltaf merkt) og töflureikni verður flutt til samræmis.

Sýnið Excel File

Note

Í þessu dæmi ætlum við að flytja einfalda innviði og fólk arkitektúr frá Excel gögn sýnd í yfir screenshot. Tengingar verður milli "fólk sem ber ábyrgð" og "Servers" að þessir menn stjórna.

Að byggja á Components flipann

Þessi hluti er að skilgreina hluti gerðir og valdakerfi fyrir stillingaskránni.

1. Veldu Hlutiflipann. Endurnefna Set IDeftir vega þyngra (null)gildi

Note

Þessi eiginleiki gerir þér kleift að skilgreina öðruvísi Leikmyndfyrir virkni aðskilda hluti. Eins og sést á the screenshot niðri, getur þú vilt að greina Infrastructure hluti þinn frá fólki hluti þinn. Ef það eru tengsl (tenging) á milli þessara aðskildum hlutum, þeir geta verið skilgreind undir Tengingarflipann. Síðar í þessu dæmi ætlum við að skilgreina tengsl af tegundinni "umsjón" milli innviða og fólk Leikmynd.

Þú getur einnig valið hvort þú vilt bæta við efsta stig Flokkunhluti fyrir alla þætti af the setja. Einfaldlega merkið á Group Undir Set IDvalkostur (sjálfgefið er unticked) og töflureikni verður flutt til samræmis.

Úthlutun Setja ID

2. Þegar Leikmyndhafa verið skilgreind velja Setjaþú vilt að byggja og stækka með því að smella á [+]undirrita.

3. Veldu Magn Hluti í þessum hópfrá stækkuðu listanum.

4. The Component Stigveldi Leikmynd: Setja IDgluggi vilja birtast fyrir að Setja.

Component Stigveldi og Úthlutun gildi (Set ID: Infrastructure)

5. Endurnefna Level Fjöldidálki með vega þyngra (null)gildi.

Note

The Level Fjöldidálki gerir þér kleift að tengja stigveldi til hluti þinn. Hvert stig svarar til lag innan vélina þína þar sem fyrsti er efst mest foreldristigi. Til dæmis, Level Number "1" svarar til hæstur hierarchic lag, Level Number "2" er barn númer á "1" og svo framvegis.

6. Veldu og úthluta viðkomandi dálk frá Excel töflureikni til hvers Level Fjöldimeð því að slá það undir Component Columndálki.

Note

Þú getur valið að útiloka ákveðin raðir sem þú vilt ekki að eiga fulltrúa í vélina þína. Þetta kann að vera Dálkahausar, tómar raðir osfrv Til að útiloka raðir nota Raðir til Útiloka:texti kassi ofarlega í hægra horninu á glugganum. Í þessu dæmi sem við höfum útilokað röð 1 vegna þess að það inniheldur dálkahausana okkar.

7. Þú getur valið um að bæta við lýsingu til hluti þinn með skrifa of mikið á (null)gildi í Lýsing Column.

Note

Þessi lýsing er það sem mun birtast í Abacus undir Almennir eiginleikarkafla | Lýsingreit.

8. Ef gefið töflureiknir dálkurinn er meira en einn þátt á einingu (inn með Alt-Enter eða CHAR (10) stjórn) merktu þá kassann undir Treat nýjar línur sem aðskilin Hluti. Hver lína verður flutt sem aðskilda hluti.

Ábending

Að flytja inn 'Matrix' úr safni dálka, þar sem "X" í tilteknu 'Matrix' frumu (frumur B2: D2 segja) felur í sér að hluti tilgreinir röð (í reit A2 segja) er tengd við hluti tilgreint með dálkinum 'fyrirsögninni' (í röð 1 Say), einföld uppskrift er hægt að nota. Sláðu inn eftirfarandi formúlu fyrir hverja röð í dálk handan Matrix frumur (dálkur F segja); = IF (B2 B $ = "", "", 1 & char (10)) & IF (C2 = "", "", C $ 1 & char (10)) & IF (D2 = "", "", D 1 $ & char (10)). Þá setja upp pakkann eins og lýst er hér að neðan milli íhluta tilgreind af röð (í dálki A segja) og þá lýst af þessari formúlu (í dálki F segja). Vertu viss um að athuga Treat nýjar línur sem aðskilin Hlutikostur þegar íhlutir úr formúlunni eru flutt. Fyrir fleiri háþróaður fylkið innflutningi, þar á meðal fyrirsagnir með mörgum lögum af stigveldi eða frumna með mismunandi gildismat en bara venjulegur "X", vinsamlegast hafðu samband við Avolution Stuðningur .

9. Fylla í the hvíla af the dálkum eftir þörfum.

Note

Þú getur valið að fá þá tegund af súlunni raðir með því að merkja í kassann við undir Fá Tegund úr dálkidálki og slá viðkomandi dálk frá Excel töflureikni undir Component Tegund Value eða Columndálki. Þetta mun flytja alla hluti í þeim dálki og setja þá við gerð sem skilgreind er í dálkinum. Einnig, og eins og með skjámynd ofan og neðan, þú getur valið að nota fasta / fyrirfram skilgreind tegund nafn með því að slá inn tegund nafn undir Component Tegund Value eða Columndálki og gættu gátreitinn er un-köflóttur.

Component Stigveldi og Úthlutun gildi (Set ID: People)

Note

Í þessu dæmi sem við viljum hafa net okkar og fólk hópa á stigi 1 í arkitektúr. Á stigi 2 við viljum hafa netþjónum okkar og fólk sem ber ábyrgð á umsýslu þá netþjóna. The Hlutiflipi hefur verið fyllt út í samræmi við það, eins og sýnt er á tveimur screenshots hér að ofan. Í fyrsta screenshot ofan við höfum skilgreint stig 1 (sérþjónusta hagsmunafélagi) og stigi 2 (server) á íhlutum fyrir Infrastructure Setja. Og í screenshot fyrir ofan höfum við skilgreint stig 1 (fólk flokkunarmöguleika) og 2. stigs (fólk sem ber ábyrgð) hluti fyrir fólk Setja.

Að öðrum kosti, fyrir FólkSet, frekar en að nota dálk C sem fólk hópar, við gætum hafa notað Group Undir Set IDvalkostur á efsta stigi hluti flipann og síðan bara inn einn People undir-stig frá Column D. Þetta er sýnt á the screenshot niðri.

Component Stigveldi og Úthlutun gildi með Group Under Set barnsins möguleika (Set ID: People)

10. Þegar þættir hafa verið greind, velja hluti stigi þú vilt að byggja á eiginleikum og / eða staðla og auka með því að smella á [+]undirrita.

11. Veldu Eiginleikar Hluti á þessu stigieða Component Standards á þessu stigifrá stækkuðu listanum og byggja viðeigandi dálka eftir þörfum.

Populating Hluti

Note

Eiginleikar Hluti á þessu stigileyfir þér að skilgreina eiginleika fyrir hluti í valinn stigi. Component Standards á þessu stigigerir þér kleift að skilgreina staðla og staðlaða eiginleika þeirra fyrir hluti í valinn stigi.

12. Endurtaktu skref 2-11þar til allir hluti stigum hafa verið byggð fyrir alla skilgreint Leikmynd. Notaðu örina til baka nálægt efra hægra horninu á glugganum til að sigla aftur til Leikmyndsem þú skilgreint fyrr.

Að byggja á Connections flipann

Þessi hluti er að skilgreina tengistillingar gerðir og valdakerfi fyrir stillingaskránni.

1. Veldu Tengingarflipann. Fyrir hvern hóp tenginga sem þú þarft að bera kennsl á hluti Setjasem þú vilt vera uppspretta hluti og hluti Setjaþú vilt vera áfangastað hluti.

2. Undir Source Component Set IDslá inn SetjaNafnið sem svarar til Setjaskilgreint fyrr í Hlutiflipann. Undir Source Component Level Fjöldislá inn númerið sem svarar til hluti stigi sem þú vilt tengjast á the uppspretta lok tengingu.

3. Nú velja hvaða eining hópur verður á áfangastað lok tengingu. Undir Áfangastaður Component Set IDslá inn SetjaNafnið sem svarar til Setjaog skilgreint er í Hlutiflipann. Undir Áfangastaður Component Level Fjöldislá inn númerið sem svarar til hluti stigi sem þú vilt tengjast á áfangastað lok tengingu.

Note

Í þessu dæmi sem við viljum tengja fólk sem ber ábyrgð á umsýslu framreiðslumaður til the framreiðslumaður sem þeir stjórna. Að ábyrgðarmenn voru skilgreind í People Setjaog stigi 2 hluti á meðan the framreiðslumaður voru skilgreind í Infrastructure Setjasem stigi 2 hluti. The Tengingarflipi hefur verið fyllt út í samræmi við það, eins og sýnt er á the screenshot niðri.

Tengingar Tab Part 1 of 2

4. Ef þú flettir til hægri, munt þú finna viðföng flytja tengingum. Fá Tegund úr dálkiog Connection Type Value eða Columnvinna á sama hátt og fyrir Hlutiflipann.

5. Ef Source Component Set ID og Source Component Level Fjöldieru þau sömu eins og Áfangastaður Component Set ID og Áfangastaður Component Level Fjöldi(td ef þú ert að tengja sömu tegundir eininga, svo sem að gera tengingar frá netþjónum til annarra miðlara) þá þarftu að hafa annan dálk í töflureikninum sem inniheldur nöfn þeirra framreiðslumaður endurtekin. Í þessu ástandi sem þú myndi setja þessi töflureikni dálki í Áfangastaður Endurtekin í dálkidálki. Ef í því töflureikni dálki þú hefur gert meira en einn samfelldan hluti á frumu þá merktu við gátreitinn undir Treat nýjar línur sem aðskilin Hluti.

Tengingar Tab Part 2 af 2

6. Þegar tengingar hafa verið greind velja tenginguna sem þú vilt að byggja á eiginleikum og / eða staðla og auka með því að smella á [+]undirrita.

7. Veldu Eignir til þessar tengingareða Staðlar fyrir þessar Tengslfrá stækkuðu listanum og byggja viðeigandi dálka eftir þörfum.

Note

Eignir til þessar tengingarleyfir þér að skilgreina eignir fyrir valið tengingu hópnum. Staðlar fyrir þessar tengingargerir þér kleift að skilgreina staðla og staðlaðar eignir sínar fyrir valin tengingu hópnum.

8. Endurtaktu skref 2-7þar til allir tengingu hóparnir hafa verið skilgreind.

9. Þegar þú hefur lokið að skilgreina tengistillingar hópa, smelltu á Finishhnappinn og arkitektúr mun vera búin til úr innfluttum Excel skrá. Dæmið hér að ofan mun leiða í arkitektúr sýnd á the screenshot niðri.

Dæmi um Architecture Innflutt frá Excel

10. Nú vista varpað stillingar í skrá með því að smella á Vista stillingaricon. Uppsetningin þín vistuð er hægt að sækja með því að smella á Opna Stillingaricon ofarlega í hægra horninu á glugganum.

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Populating arkitektúr frá Access | Populating vélina þína frá Visio


Populating vélina þína frá Microsoft SharePoint

Navigation: Populating> vélina þína Populating frá Microsoft vörum>

Populating vélina þína frá Microsoft SharePoint

Senda athugasemdir um þetta efni.

Þú getur samstilla arkitektúr þinn meðMicrosoft SharePoint listi. Samstilling felur annaðhvort að búa til ný SharePoint listi (og dálka þeirra) frá Abacus gerðir, eiginleika þeirra og viðhengi, eða kortleggja núverandi SharePoint listi (og dálka þeirra) til abacus tegundir, eiginleikar þeirra og viðhengi, þá annaðhvort senda efni frá Abacus í SharePoint eða SharePoint að Abacus.

Note

The SharePoint Sync eiginleiki krefst þess aða Microsoft SharePoint 2010, 2013eða SharePoint Online Þessi síða er í boði til að tengjast og samstilla með.Þó að SharePoint Sync lögun getur skapað (með dálkum) á SharePoint síðuna frá einhverju abacus verkefni, Avolution getur einnig veitt ýmis SharePoint staður sniðmát til stuðnings stöðluðum ramma (td TOGAF, ArchiMate, ITIL etc) svo vinsamlegast hafðu samband Avolution Stuðningur ef þú þarfnast þessa getu.

Til búa til nýja SharePoint listi og landakort það til Abacus íhluta eða tegund tengingar

1. Tryggja þú hafa Abacus opinn.

2. Veldu Verkfæri | SharePoint Sync.

3. Smelltu á New Kortlagninghnappinn og SharePoint Kortlagning valmynd eins og sýnt er hér fyrir neðan birtist.

4. Sláðu inn Site URL, Notandanafn og Lykilorð fyrir SharePoint síðuna og smella Tengjast.

Note

Gilt Sharepoint 'Admin' eða reikningur 'Framlög' þarf að samstilla til og frá SharePoint og reikningi Lesandinn mun aðeins leyfa samstillingu frá SharePoint.

5. Veldu Abacus íhluta eða tengingar ferðar til kort frá Veldu Gerð rífa niður.

6. Smelltu á Bæta við nýjumhnappinn og þá fyrir hverja Abacus íhluta eða tegund tengingar hlið þú vilt landakort til samsvarandi SharePoint listi sviði velja atriði í myndinni til vinstri í hægri glugganum inn í nýja SharePoint skrá nafn í New lista dálki (aðeins fyrsta skipti) , þá SharePoint dálkurinn nafn í dálkinum Nafn (eða nota sjálfgefna) og smelltu Úthluta hvert skipti.

Note

Að lágmarki að leyfa samstillingu ABACUS EEID, Architecture og Nafn þætti verður sjálfkrafa varpað á SharePoint Fjöldi og tveggja (2) eina línu af texta (aka texta) dálkum sig. Þetta getur ekki verið unassigned. Ennfremur, aðeins ákveðin Abacus þættir geta nú verið varpað ákveðnum dálkum SharePoint og Column Type Niðurfallsvalmynd verður sjálfkrafa sett í þá SharePoint dálk tegund.Nefnilega;

· Abacus 'Stigveldi Path to SharePoint margar línur af texta (aka athugasemd) dálkum (Ath: SharePoint einni línu af texta (aka texti) dálka styðja aðeins 255 Sérstafir svo þeir eru ekki valinn),

· Abacus 'Meðfylgjandi Hluti til SharePoint leit dálka (Athugið: kortlagning verður þegar fyrir hendi til að lista fyrir meðfylgjandi hluti sjálfum),

· Abacus 'Texti og Lýsing eignir til SharePoint margar línur af texta (aka athugasemd) dálka (Ath: SharePoint einni línu af texta (aka texti) dálka styðja aðeins 255 Sérstafir svo þeir eru ekki valinn),

· Abacus 'Decimal eða Integer Fasteignir til SharePoint Fjöldi dálka,

· Abacus 'List Fasteignir til SharePoint Choice dálka (Ath: SharePoint ekki framfylgja val gildi svo List gögn gerð þarf ekki að vera framfylgt í Abacus),

· Abacus 'Dagsetning / Tími Fasteignir til SharePoint margar línur af texta (aka athugasemd) dálkum (ATH: SharePoint Dagsetning og tími dálkum er ekki hægt að nota sem enn vegna ósamræmi stuðning SharePoint er fyrir Tímabelti / svæðaskiptingu stillingar),

· Abacus 'Boolean Fasteignir til SharePoint já / nei (aka Boolean) dálkum.

Associated Standards An Abacus þáttur er ekki hægt að varpað SharePoint listi dálkum sem komið er.

7. Veldu Búa Kortlagning.

Til búa til nýja kortlagning á milli á Abacus íhlut eða tegund tengingar og núverandi SharePoint listi

1. Tryggja þú hafa Abacus opinn.

2. Veldu Verkfæri | SharePoint Sync.

3. Smelltu á New Kortlagninghnappinn og SharePoint Kortlagning valmynd eins og sýnt er hér fyrir neðan birtist.

4. Sláðu inn Site URL, Notandanafn og Lykilorð fyrir SharePoint síðuna og smella Tengjast.

Note

Gilt Sharepoint 'Admin' eða reikningur 'Framlög' þarf að samstilla til og frá SharePoint og reikningi Lesandinn mun aðeins leyfa samstillingu frá SharePoint.

5. Veldu Abacus íhluta eða tengingar ferðar til kort frá Veldu Gerð rífa niður.

6. Veldu SharePoint staður lista til kort frá Veldu List rífa niður.

7. Fyrir hverja Abacus íhluta eða tegund tengingar hlið þú vilt að kortleggja til samsvarandi SharePoint listi dálki þess velja hlut á vinstri, en til hægri spjaldið sig og smella Úthluta.

Note

Að lágmarki að leyfa samstillingu ABACUS EEID, Architecture og Nafn þættir sem þarf að vera varpað í SharePoint númer og þá fyrir arkitektúr og Nafn annað hvort ein lína af texta (aka Texti) eða margar línur af texta (aka athugasemd) dálkum sig. Fram að þeim er gert að búa Kortlagning hnappinn verður ekki virkjuð. Ennfremur, aðeins ákveðin Abacus þættir geta nú verið varpað ákveðnum dálkum SharePoint.Nefnilega;

· ABACUS 'Architecture þáttur til SharePoint eina línu af texta (aka Texti) eða margar línur af texta (aka athugasemd) dálka (þetta er nauðsynlegt fyrir efni tiltekna kortlagningu eins og lýst er hér að neðan),

· Abacus 'Stigveldi Path to Sharepoint eina línu af texta (aka Texti) eða margar línur af texta (aka athugasemd) dálkum (Ath: SharePoint einni línu af texta (aka Texti) dálka styðja aðeins 255 Sérstafir svo einhverjar fleiri stafi verður stytt og því það er mælt með því að breyta þeim til Margfeldi línur af texta (aka athugasemd) dálka í SharePoint fyrir kortlagning),

· Abacus 'Meðfylgjandi Hluti til SharePoint leit dálka (Athugið: kortlagning verður þegar fyrir hendi til að lista fyrir meðfylgjandi hluti sjálfum),

· Abacus 'Texti og Lýsing eignir til SharePoint eina línu af texta (aka Texti) eða margar línur af texta (aka athugasemd) dálkum (Ath: SharePoint einni línu af texta (aka Texti) dálka styðja aðeins 255 Sérstafir svo einhverjar fleiri stafi verður stytt og því er mælt með að breyta þeim til Margfeldi línur af texta (aka athugasemd) dálka í SharePoint fyrir kortlagning),

· Abacus 'Decimal eða Integer Fasteignir til SharePoint Fjöldi dálka (Ath:. SharePoint Reiknaður dálkum er hægt að nota þó þeir munu aðeins vera fær um að samstilla frá SharePoint til Abacus Reynt að samræma' í 'a reiknaður dálkur mun leiða í viðvörun sem greinir hér að neðan) ,

· Abacus 'List Fasteignir til SharePoint Choice dálka,

· Abacus 'Dagsetning / Tími Fasteignir til SharePoint margar línur af texta (aka athugasemd) dálkum (ATH: SharePoint Dagsetning og tími dálkum er ekki hægt að nota vegna þess að ósamræmi stuðning SharePoint er fyrir Tímabelti / svæðaskiptingu stillingar),

· Abacus 'Boolean Fasteignir til SharePoint já / nei (aka Boolean) dálkum.

Associated Standards An Abacus þáttur er ekki hægt að varpað SharePoint listi dálkum sem komið er. Og Gjaldmiðill Sharepoint það á mann eða hóp, Hyperlink eða Picture, Task Outcome, Ytri Gögn og Stýrður Lýsigögn dálkum er ekki hægt að varpað Abacus þætti sem komið er.

8. Veldu Búa Kortlagning.

Til samstillaMicrosoft þitt SharePoint listi (s)í Abacus

1. Tryggja þú hafa Abacus opinn.

2. Veldu Verkfæri | SharePoint Sync.

Note

Til samstilla SharePoint listi með aðABACUS verkefni sem notandinn leyfi þarf í SharePoint Syncbæta við-á hæfileiki. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

3. Veldu fyrirliggjandi SharePoint nágrenninu (eða kortlagning með Ctrl-smellaeða Velja allthnappur) frá SharePoint kortlagningspjaldiðeins og sýnt er í sýninu screenshot hér að framan. Ath: hér erum við að sýna bara 'mark (eða krafa)' Abacus íhluta nágrenninu á SharePoint listi kallast Goals verið valin.

4. Veldu Architecture (s) sem þú vilt samstilla efni með frá Sync Efnisyfirlit frá arkitektúrspjaldið sem sýnt í úrtaki screenshot hér að framan. Ath: hér erum við að sýna bara "2015 Raunveruleg 'arkitektúr sé samstillt.

5. Veldu Sync Frá SPhnappur.

Note

Ef SharePoint staður persónuskilríki eru ekki 'All Vistað' fyrir kortlagningu (s) valið þá Innskráning til SharePoint valmynd vilja birtast sem biður fyrir Site URL, Notandanafn og / eða Lykilorð.Vinsamlegast sláðu inn þetta. Ennfremur, samstillingu mun fela önnur kortlagning sem þarf til fylgja íhlutum / útlit dálkum. Allar frekari kortlagning sem eru sjálfkrafa innifalin verður sýnd í glugganum sem greinir hér að neðan.

6. Á farsælan samstillingu a SharePoint Sync Niðurstöður valmynd vilja birtast eins og sýnt er hér að neðan skrá breytingar og allar viðvaranir. Smelltu OK.

Til samstilla frá Abacus til Microsoft þitt SharePoint listi (s)

1. Tryggja þú hafa Abacus opinn.

2. Veldu Verkfæri | SharePoint Sync.

Note

Til samstilla SharePoint listi með aðABACUS verkefni sem notandinn leyfi þarf í SharePoint Syncbæta við-á hæfileiki. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

3. Veldu fyrirliggjandi SharePoint nágrenninu (eða kortlagning með Ctrl-smellaeða Velja allthnappur) frá SharePoint kortlagningspjaldiðeins og sýnt er í sýninu screenshot hér að framan. Ath: hér erum við að sýna bara 'mark (eða krafa)' Abacus íhluta nágrenninu á SharePoint listi kallast Goals verið valin.

4. Veldu Architecture (s) sem þú vilt samstilla efni með frá Sync Efnisyfirlit frá arkitektúrspjaldið sem sýnt í úrtaki screenshot hér að framan. Ath: hér erum við að sýna bara "2015 Raunveruleg 'arkitektúr sé samstillt.

5. Veldu Sync Til SPhnappur.

Note

Ef SharePoint staður persónuskilríki eru ekki 'All Vistað' fyrir kortlagningu (s) valið þá Innskráning til SharePoint valmynd vilja birtast sem biður fyrir Site URL, Notandanafn og / eða Lykilorð.Vinsamlegast sláðu inn þetta. Ennfremur, samstillingu mun fela önnur kortlagning sem þarf til fylgja íhlutum / útlit dálkum. Allar frekari kortlagning sem eru sjálfkrafa innifalin verður sýnd í glugganum sem greinir hér að neðan.

6. Á farsælan samstillingu a SharePoint Sync Niðurstöður valmynd vilja birtast eins og sýnt er hér að neðan skrá breytingar og allar viðvaranir. Smelltu OK.

Note

ABACUS mun uppfæra SharePoint dálka með auða gildi jafnvel þó 'krefjast þess að þessi dálkur inniheldur upplýsingar "er stillt á Já í SharePoint. Þetta er vegna þess að SharePoint ekki fletta ofan af þessari stillingu utan. Ef þetta er að koma í veg fyrir það er mælt með því að ABACUS Designer setur hömlur á Áskilið að True og framfylgt fyrir gisti- og veitingastaði með Abacus ' þvingun lögun .

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Populating vélina þína frá Visio | Populating vélina þína frá Excel


Populating arkitektúr frá Microsoft SQL Server

Navigation: Populating> vélina þína Populating frá Microsoft vörum>

Populating arkitektúr frá Microsoft SQL Server

Senda athugasemdir um þetta efni.

Þú getur flutt vélina þína frá Microsoft SQL Server gagnagrunn. Þú hefur valið að bara flytja á töflum og sambönd raun að flytja inn bara almenna uppbyggingu gagnagrunnsins eða borðum, Raðir og tengsla sem flytja ekki aðeins uppbyggingu en gögnin eins og heilbrigður.

Note

From SQL Server eiginleiki krefst að Microsoft SQL Server 20052008, 2008 R2, 2012 eða 2014er uppsett á tölvunni.

Til að flytja þitt Microsoft SQL Server gagnagrunn í Abacus

1. Tryggja þú hafa Abacus opinn.

2. Veldu File | New og veldu Frá SQL Serverfrá glugganum sem birtist og smellt á OK.

3. Í Import SQL Server glugganum sem birtist sett á 'MachineName' og gildi "SQLINSTANCE 'á tengingu band breytu og verðmæti' dbname 'á Database Name breytu til að fá rétt gildi þeirra eins og sýnt er í sýninu screenshot niðri.

4. Setja gagnasafn nafn breytu í sama gildi og upphaflega Verslun breytu sett í the stíga ofan, eins og sýnt er í úrtakinu screenshot niðri.

5. Ýta á Test Connection hnappinn og á töflum til að flytja hluta gluggans skal byggð með tiltækum borðum gagnagrunninum, eins og sýnt er í úrtakinu screenshot niðri.

6. Veldu borðin sem þú vilt flytja inn af annaðhvort hvert fyrir sig að velja þá eða nota allt saman, ekkert og hvolft hnappana til hægri í glugganum.

Note

Aðeins Erlendir Lykill Sambönd sem eru fyrir hendi milli töflunum sem þú velur verður að fá innflutt.

7. Notkun Import Style hnappinn velja hvort þú vilt flytja bara Töflur og tengsl milli þeirra eða töflum, raðir þeirra og sérstöku tengsla milli lína.

Note

Fyrsti valkostur flytur á töflum sem hluti af gerðinni 'töflu' og tengsl milli tveggja töflum (frá erlendum takkana) eru fluttar sem tengingar af gerðinni "Tafla Tengsl '. Þetta er klassískt "ERD 'stíl útsýni af the kerfi töflur. The second valkostur flytur Töflulínum sem stakar undirþætti af gerðinni "Tafla Row" með eignir sem samsvara hvert dálka / sviðum og með samskiptum Töflulínum af gerðinni "Tafla Tengsl '. Enn fremur, ef það er dálkur / sviði kallast 'Name' þá er þetta notað til að nefna einstaka Tafla Row undirþætti.

8. Veldu Import ... hnappinn.

9. Eftir stuttan tíma (með framfarir bar fyrir endurgjöf) nýtt ABACUS verkefni verður búin með töflum, Töflulínum (ef annar valkostur var valin í the stíga ofan) og sambönd frá Microsoft SQL Server gagnagrunn.

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Populating vélina þína frá Visio | Populating vélina þína frá Excel


Populating arkitektúr frá Microsoft Visio

Navigation: Populating> vélina þína Populating frá Microsoft vörum>

Populating arkitektúr frá Microsoft Visio

Senda athugasemdir um þetta efni.

Þú getur flutt arkitektúr frá Microsoft Visio. Form í Sjón myndina verður flutt sem hluti inn abacus. Tengingar í Sjón myndina verður flutt sem tengingar og teikna sjálft verður flutt inn Abacus sem skýringarmynd. Ennfremur, allir Custom Properties í Sjón myndina verður flutt sem eignir með Sort Key varpað á Property Type, umbúðir Property Nafn og gildi til eignarskattur.

Note

Innflutningur frá Sjón lögun krefst þess Microsoft Visio 2003eða nýrri er uppsett á tölvunni.

Til að flytja Sjón teikningar í Abacus

1. Tryggja þú hafa Abacus opinn.

2. Veldu File | New og veldu Frá Visiofrá glugganum sem birtist og smellt á OK.

Note

Ef þú vilt flytja inn í núverandi Abacus verkefni þá annaðhvort hægri-smelltu á Components hnút innan Architecture, eða hægri-smelltu á einstaka hluti innan Architecture og þá velja Import | Frá Visio.

3. Fletta að Sjón skránni sem þú vilt flytja inn.

Note

Hér fyrir neðan eru nokkrar einfaldar reglur eða mælt venjur Þegar byggingu (eða breytingum) a MS Visio teikna innflutningsleyfis til abacus.

1. Línurnar eða tengingum þarft að vera raunveruleg tengi, ekki form.

· Annars ABACUS verður bara flytja þá eins hluti og í samræmi við það sem þeir vilja ekki vera "fest" í neitt.

· Ef þú þarft að gera sumir "sviði" venja (þ.e. öðrum en beinni línu) þá nota Dynamic tengi á Basic form stencil, ABACUS mun flytja venja / akkeri stig fínn.

· Reyndu að forðast að nota "Ring net" og "Ethernet" form af netinu og Yfirborðslegur stencil sem leyfir hellingur af hlutum til að vera "tengdur" við það. Þó að við flytjum viðhengi fínn eins tengingar upprunalega lögun er enn "stækkað" til að endurspegla viðhengi. Notaðu aðskilja sérstakt "hub / rútu" lögun (án tengi "fætur") og þá sérstaklega að tengja hvern hluta til að miðstöð / strætó með aðskildum tengjum.

· Ef lína eða tenging hegðar sér eins og lögun, hægri smelltu á það og fara í 'Format | Hegðun ... "og ganga úr skugga um að Milliverkanir stíl er sett á línu (1-víddar).

2. The hluti þarf að vera form EKKI tengi.

· Annars ABACUS verður bara flytja þá eins tengingar og í samræmi öllum lögun upplýsingar glatast.

· Ef íhlutur hegðar sér eins og tengi, hægri smelltu á það og fara í 'Format | Hegðun ... "og ganga úr skugga um að Milliverkanir stíll er stillt á Box (2-víddar).

3. Tengi endar þarf að vera tengdur við form, ekki fljótandi um í bakgrunni lögun.

· Ef þú ekki tengja tengin á stærðum þá hefur ABACUS enga leið að vita að þú ætlaðir að hengja viðkomandi tengi til lögun / íhlutar og í samræmi við það mun fara að enda tengingu un-viðhengi.

4. Merki fyrir form ætti að vera (ef unnt er) innbyggðri texta fyrir laginu, ekki sérstakt textareitinn á teikningu.

· Aðskilja texta kassa vilja fá fluttar Abacus sem hluti í sjálfu sér og á meðan þú getur sameinast á "merki" hluti með alvöru hluti í abacus, eða bara breyta "merki" hluti til Freeform lögun (þ.e. ekki hluti sjálft) það er best að koma í veg fyrir þessi skref.

5. Nota sama grunn form fyrir hvert eintak af sömu gerð, ekki vera latur og nota rétthyrningur stundum og kassi aðra frá mismunandi lögun stencils.

· ABACUS notar grunn form og stöð lit til einstaklega þekkja íhlutinn og tengingu gerðir í teikningu svo "rauða rétthyrningur" og "rauður kassi" mun fá innflutt sem tvö aðskilin tegundir eininga. Þessar hluti tegundir er hægt að sameinast í Abacus en það er best að koma í veg fyrir þessi skref.

6. Að öllu leyti þjappa "börn" form innan "foreldrar" þeirra, EKKI láta þá hanga yfir brúnina.

· ABACUS mun uppgötva hvaða lögun sem er að fullu í encapsulated innan annars lögun sem barn foreldris svo tryggja allt form, þar á meðal merki hluta, fylgi.

7. EKKI stöðu lögun skarast tvö önnur form.

· Ef lögun skörun tvær aðrar form, að það "hópar" / bakgrunnur rétthyrningur eða annars, mun það vera flutt af Abacus sem hluti sem er barn hvorki skarast stærðum en um leið og þú velur hluti í Abacus 'teikningu tól , vegna þess að efst til vinstri vera hluti viðmiðunarpunkt, mun það verða barn vinstra skarast lögun / hluti.

8. Reyndu að draga úr notkun á athugasemdum á teikningu vegna þess að þetta mun fá flutt sem hluti í sjálfu sér og verður að vera breytt í Freeform form í Abacus. Hugsa um hvort þeir eru í raun nafn á fyrirliggjandi hluti eða tengingu.

9. Þó ABACUS styður ríkur / litað / vektor-undirstaða form, reyna að draga úr notkun á bitamyndir, erlend stærðum og auka metafiles fyrir form sem ABACUS er núekkistyðja þessar tegundir. Þeir vilja vera flutt eins einföldum hvítum rétthyrninga.

10. Reyndu að forðast flutning aftur (Shift-aftur) í merki eins og þeir eru flutt og sýnd sem sérstakur karakter "[]" í Abacus fyrir hluti nafn.

11. Reyndu að draga úr mismunandi litum sem eru notuð til form af sömu gerð. Eins og getið er hér að framan, grunn lit og stöð lögun auðkennir hluti og tengingu tegundir þannig að fleiri tilbrigði þar er meira samruna- og styrking sem þarf að gera post-Import í Abacus.

12. Verið varkár með fyllt form vegna þess að ef lögun er fyllt alla leið til hornum þá litarefni það síðar í Abacus mun ekki hafa áhrif.

13. Á flóknum línu byggir form sem þú verður að nota marghyrning sem er búið til með því að hafa línur byrja þar sem fyrri einn lýkur og þá á endanum fara aftur til byrjun. Ef þú vilt, getur þú notað fylla og línu breidd að gera marghyrningur líta út eins og "ör" eða hvað sem form sem þú vilt.

14. Gakktu úr skugga um að form ID MS Visio er þroskandi ekki bara Shape.xx. Þetta er editable með hægri-smelltu á "Sýna Shapesheet 'sem er í boði í MS Sjón forritunarham (virkt í gegnum Tools | Options í MS Visio).

15. Sporbauga og bogainnan stærðumeru studd í Abacus en nurbs og splínur eru ekki studdar.

16. Gakktu úr skugga um að allur lögun er flokkuð í MS Visio eða það vilja fá flutt inn nokkrum íhlutum / gerðum.

17. Reyndu að draga úr notkun á snúið stærðum innan subshapes eins og þeir vilja stundum ekki að flytja rétt.

Sjá einnig

Populating vélina þína - Yfirlit | Populating arkitektúr handvirkt | Populating arkitektúr frá Access | Populating vélina þína frá Excel


Populating arkitektúr handvirkt

Navigation: Populating> vélina þína Populating handvirkt>

Populating arkitektúr handvirkt

Senda athugasemdir um þetta efni.

Aðal-hluti og tengingar arkitektúr mun líklega þurfa að vera byggð handvirkt. Venjulega mun þetta vera meira abstrakt hluti og tengingar.

Til höndunum byggja vélina þína

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skráopinn, sem landkönnuðurbirtist, og arkitektúr bætt .

2. Bæta við hluti. Til að gera þetta, Hægrismellaá svæði trénu þú vilt að byggja og velja Bæta Sub-hluti ...Eða smelltu á New Componenthnappinn á View tækjastika . Þættir geta aðeins bætt undir Hluti útibú tré. Þú vilt tré skýringarmynd til að vera nákvæmur framsetning vélina þína. Þegar þú komst vélina þína, verður þú að hafa lært nákvæmlega hvernig það passar saman. Þú þarft þessa þekkingu þegar þú bætir hluti þinn og tengingar. Ef þú ert að bæta fyrsta hluta, munt þú bæta því beint til Hluti útibú. The hvíla af hluti þín getur verið annaðhvort á sama stigi í trénu, eða þeir geta verið undirliðir af fyrsta.

3. Uppfæra gildieignirhvers efnisþáttar sem þú bæta við það. Til að gera þetta, smellurá hluti, og breyta eiginleikum birtast í Properties glugganum(venjulega) til hægri. Eignir eru yfirleitt hluti eins og kröfur, vinnslu getu osfrv Þegar ABACUS metur vélina þína, það mun reikna nokkrar nýjar eignir, og vista þá aftur að arkitektúr. Nýju eignir eru gögn sem þú ert að reyna að greina, svo sem nýtingu, svar tími, bandbreidd, o.fl.

4. Bæta tengingarog uppfæraeiginleikar þeirraeins og þú fara - bara eins og þú gerir fyrir hluti (en undir Tengsl útibú tré).

5. Hengjatengingar og hluti. Til að gera þetta, finna tengingu skaltu ýta á einn af þess lýkur eða hlutverk Og draga það út á hluti. Einnig, smelltu á hluti og draga það á einn af tengingin er hlutverk (þ.e. annað hvort Source eða sökkva). Eða þú getur hægri smellt og draga hluti á annan efnisþátt og veldu Tengdu til. Eða einfaldlega hægrismellt er hluti og velja Tengjast .... Þegar þú dregur tengingu Hlutverk, Þú munt taka eftir a smákaka tákn þegar þú bendir á hluti sem þú getur látið hana til. Þetta gefur til kynna að þú ert ekki að gera afrit, þú ert bara að festa það. Gakktu úr skugga um að þú festa það við rétta áfangastað hluti. Til dæmis, ef það er Source á tengingu er Hlutverk, Draga það að gera fengið hluti (þ.e. hluti sem er uppspretta af the gögn flæði).

Ábending

Endurflokka aðila innan arkitektúr (td Components, Connections osfrv) í landkönnuðurer alveg auðvelt. Einfaldlega Smelltu| Haltu| Dragviðkomandi aðila og staður þar sem þess er óskað í vélina þína. Aftur röðun virkni gerir þér einnig að setja aðila innan mismunandi stigveldi vélina þína.

Þú gætir einnig viljað

6. Bæta Standards (pre-stilla setur eignir - forstilla) við íhlutum, tengingar eða gerðir

7. Breytið eiginleikum íhluta, tengingu eða tegund

8. Hætta við og Endurgera Rekstur

9. Breyta Tegund íhluta eða tengingu

10. Búa til nýja tegund eða gerð Group

11. Eyða hluti eða tenging

12. Búa til, afrit eða þróast arkitektúr

13. Innflutningur tegundir og staðlar úr safni

14. Innflutningur frá öðrum abacus skrá, XML, Excel eða Visio

15. Afrita og líma hlutar (eða allt) af arkitektúr þinn

16. Finna og Skipta atriði í vélina þína

17. Stækka / Collapse sum eða öll tengipunkta í trénu

18. Sameina atriði

19. Skilgreina og Sannprófa Þvingun að takmarka uppbyggingu arkitektúr þinn

20. Þróast vélina þína að búa til nokkrar byggingarlistar lausnir til að bera saman og grunngildi

Sjá einnig

Populating vélina þína - Yfirlit | Að búa til nýja skrá


Birta á vefinn

Navigation: Skýrslur um arkitektúr þinn>

Birta á vefinn

Senda athugasemdir um þetta efni.

ABACUS 'Birta Web leyfir byggingarlistar líkan til að skoða í gegnum örugga vefurinn. Arkitektúr eru flutt út til HTML-sniði og er ætlað að endurspegla útlit og feel af the Explorer í Abacus. Views (þ.mt Vörulistar, skýringarmyndir, 3D og Charts) eru einnig flutt í sniðum sýnileg með því að nota vafra.

Note

Eins og er, eru sjónarmið og Fylki ekki birt.

Til að birta byggingarlistar módel á netið

1. Tryggja þú hafa viðeigandi ABACUS skráopinn, sem inniheldur byggð arkitektúrsem þú vilt birta á vefnum.

2. Veldu File| Birta ....

3. The Birta Til Web stillingargluggi birtist.

Birta á vefinn stillingar

4. Sjálfgefið allir hlutar líkansins eru valdir á meðal valglugganum, the StandardsÞær tegundir, Sniðmát og arkitektúrdeild (s). Taktu hakið einhverjar hluta sem þú vilt ekki að birta á vefnum, þ.mt einstökum skoðunum arkitektúr (s).

Ábending

Ef þú vilt fela tilteknum hlutum, tengingar og / eða eiginleika þeirra og það er mælt með því að Administrator skapar hlutverki a 'almennings "með Abacus 'hlutverk-undirstaða aðgangur lögun og þá fjarlægir Lesa leyfi frá þeim hluti tegundir, tengingu tegund og / eða eiginleika sem þau vilja ekki vera birt. Þá notandi ættir að skrá þig í undir því hlutverki og birta á vef sem Abacus mun aðeins birta þætti sem hafa lesið leyfi sett fyrir hlutverkið. Ennfremur, notendur geta sjálfvirkt farartæki-birta frá skipanalínu eins og lýst er hér .

Note

Þú getur valið allar hluta birtast með því að smella á Allthnappinn eða hvolfa valið með því að smella á Inverthnappinn. Þú getur líka smellt á Ekkerthnappinn til að hreinsa valið.

Note

Ef þú óhindraður the Tree View möguleikaþá ekki tré ramma (sjá hér að neðan) verður birt. Í samræmi við það, þú ættir að velja upphafssíðu samkvæmt þrepi 6 hér að neðan eða eftir útgáfu þú þarft að aðlaga annaðhvort efsta stigi; a) index.htmlskrá með því að breyta "FRAME SRC =" mainPage.html "name =" element_details "'lína beint að tengja við viðkomandi HTML síðunni undir Content möppunni, eða, b) mainPage.htmlmeð því að veita tengil eða endurvísa viðkomandi HTML síðunni undir Content möppu.

5. Smelltu á Valkostur hnappinn og eftirfarandi Útgefandi Optionsvalmynd vilja sýna.

BirtaEr Options

6. Skjósa 3D, Skýringarmyndog Línurit snið og hvort að sýna titil, lýsingu eða Properties fyrir skoðunum út af tiltækum valkostum (sjá athugasemd hér að neðan um athugasemdir á hinum ýmsu sniðum).

7. Ef þú vilt setja upphafssíðuna yfir útgefið líkan til tiltekins augum þá athuga Notaðu Skoða sem upphafssíðuvalkostur og flettu að mati gegnum '...' hnappinn sem verður virkt.

Note

Aðeins skoðanir valdir í Areas kafla eins og í skrefi 4 hér að ofan eru í boði til að setja eins og upphafssíðan.

8. Ef þú vilt fá álit á tilteknum síðum í birt fyrirmynd þá ganga úr skugga um að Email Feedbackvalkostur er valinn, sláðu inn netfang í Netfangkennslubókog breyta Email Bodykafla eftir því sem við. Ef þú vilt ekki að hafa viðbrögð sendi þá hakið við Email Feedbackvalkostur og textareitinn auðan.

9. Smelltu á OKhnappinn.

10. Smelltu á Flokkahnappinn.

11. The Beit fyrir Foldergluggi birtist.

12. Veldu staðsetninguna sem þú vilt geyma efstu HTML skrá (og allar sjálfkrafa mynda skrár).

Note

Það er góð hugmynd að búa til sérstaka möppu (oftast kallaður "út") með því að nota Búa til nýja möppuhnappinn neðst í glugganum til að geyma efstu HTML skjalið og allir sjálfkrafa mynda skrár.

13. Smelltu á OKhnappinn.

14. The möppuslóð birtir í Directorykennslubók.

15. Smelltu á Finishhnappinn.

- Eða -

15. Sláðu möppuslóð í því Directorykennslubók þar sem þú vilt geyma efstu HTML skrá (og allar sjálfkrafa mynda skrár).

16. Smelltu á Finishhnappinn.

Note

Útflutning á Skýringarmyndirmjög stundum ekki, oftast þegar tölvan er út af minni (venjulega þegar mjög stórar skrár). A mistókst útflutningur Reynt verður að einu sinni. Það verður eitt viðvörun fyrir mistókst fyrstu tilraun, og annað viðvörun ef aftur tilraun mistekst. Því ef aðeins viðvaranir eru "fyrstu tilraun mistókst" sjálfur, sem birta var vel. Ef aftur mistekst reynir að birta smærri hluta skrá eða losa upp smá kerfi minni.

Vistaða HTML skrá (s) geta nú verið útsýni frá staðsetningu hennar eða afritaður örugga vefur staður.

Birta á vefinn í Internet Explorer10

Allir tengla sem voru búin til í upprunalegu fyrirmynd verður hélst í birt fyrirmynd og að smella á tengilinn mun fylgja tengil á áfangastað (ef það var birt). Ennfremur, allir þættir í birtum skýringarmyndir sem ekki eru þegar tengillinn í upprunalegu fyrirmynd mun eftir vefslóðartengdar aftur til samsvarandi einingar þeirra í tré útsýni (ef það var birt) og með því að smella þáttur í birt skýringarmynd áhersla mun hoppa til baka viðkomandi stað í trénu. Þessi eiginleiki er svipað og "sýna í Explorer" Hægri-smelltu lögun í Abacus.

Note

Avolution mælir eindregið eftirfarandi hugbúnaður og skrá snið ætti að nota að fullu nýta Birta Vefur virkni í Abacus:

1. Internet Explorer (80,0 og hér að ofan)geti séð birta landkönnuður útsýni. Mozilla Firefox (30,0 eða síðar)Einnig er mælt með og að fullu stuttHins vegar, ef nota ráðlagða SVG snið fyrir skýringarmynd þá í Firefox 9 þú getur aðeins notað móðurmál SVG áhorfandi stuðning sem því miður leyfir ekki zooming eða klyfjakarfa.

2. Adobe SVG Viewer 3.0 stinga inn (sækja frá hér ) og SVGskráarsnið fyrir birt skýringarmyndir. The SVG myndsnið fyrir skýringarmyndirMælt er með því að; SVG er vektor-undirstaða ímynd snið og því er það tap-minna "og lítur miklu betur á hverjum aðdrætti en einhverju öðru formi, SVG er hægt að flytja inn í MS Visio, SVG hægt að aðdregna til hvaða stigi eða upplausn , SVG hefur tengla til baka í tré útsýni fyrir tengingar (ekki bara hluti), SVG prentar alltaf betri upplausn, og, SVG er um helmingur skráarstærðin önnur snið. PNG er næsta ráðlegging, þó, eins og það er rasterised snið á ákveðnum stigum zoom skýrleika þeirrar skoðunar verði eytt og að smella tengingar á skýringarmyndum mun ekki hoppa aftur til viðkomandi stað í trénu. BMP er hugfallast eins og á meðan það er a 'taplausri' forsníða skráarstærðin er 100x að öðrum sniðum og 20MB myndir eru ekki óvenjulegt.

Málamiðlun með SVG er þessi SVG áhorfandi verður að vera uppsett og þú þarft að ganga úr skugga um að .svg image / svg + xml bætist MIME tegund vefþjóninn er. Eftir uppsetningu á SVG áhorfandi Microsoft Internet Explorer mun biðja þig um að samþykkja leyfisveitandi samkomulag áhorfandans og þá ætti að virka vel. Og meðanMozilla Firefox styður SVG-skrár innfæddur, Adobe tappi er samt mælt meðað vera fær um að súmma á skýringarmyndir ef þú ert að nota Firefox 8 eða fyrr (ef þú ert að nota Firefox 9 er ekki hægt að slökkva á móðurmáli SVG áhorfandi). Þegar uppsetningunni fyrir Adobe tappi hefur verið rekið, eftirfarandi skref eru nauðsynleg nota það í Firefox:

· Opinn upp eldur og sláðu inn "íaboutconfig:" (án umhverft kommum) í URL bar.

· Flettu niður og finna eign svg.enabled(ef þú ert að nota Firefox 9 þá innfæddur SVG skoða má ekki vera fatlaður og þessi eiginleiki er ekki til). Tvöfaldur smellur á það til að gera það.

· Nú finna skrá þar sem SVG tappi er settur (td C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Afrita skrár NPSVG3DLL og að NPSVG3zip og líma þær í Firefox plugins (td C: \ Program Files \ Mozilla Firefox \ viðbætur)

· Loka öllum tilvikum eldur

3. Avolution er ABACUS 3D Viewer (3,1 og hér að ofan)og .abacus3D Avolution erskráarsnið sem birt 3D útsýni. Þó að Cortona VRML Client stinga í (2,0 og hér að ofan)er í boði að skoða VRML útgáfur af birtum skoðunum það er ekki frjáls til nota í atvinnuskyni og enn þarf viðskiptavinur-hlið uppsetningu. Abacus 3D Viewer er lögun-ríkur en nokkur VRML áhorfandi og er fáanleg til niðurhals af hér . Í báðum tilvikum að tryggja að þú bæta .vrml x-heiminn / x-VRML og .abacus3d application / octet streyma til MIME tegund vefþjóninn er.

4. PNGskráarsnið sem birt Mynd útsýni. Mælt er með PNG snið fyrir töfluna útsýni því á meðan það er rasterised snið og það er "tap" málamiðlun milli stærð og mynd skýrleika er yfirleitt best. BMP er hugfallast eins og á meðan það er a 'taplausri' forsníða skráin er 20x að öðrum sniðum og 2MB töflur eru ekki óvenjulegt.

Ef þú vilt breyta útlit og feel af the vefur blaðsíða, þú getur breytt upphafssíðuna skrána mainPage.html og stíl lak skrána abacus.css. Þú vilja finna þessar skrár í sömu möppu þar sem þú velur að vista efstu HTML skrá. Fyrir frekari upplýsingar um uppbyggingu og semur við birt framleiðsla sjá næsta kafla.

Uppbygging Abacus birt módel

Abacus birt líkan er byggð upp á eftirfarandi:

1. Efsta mappa inniheldur nokkrar skrár og miðað alla möguleika eru í Abacus Birta á vefnum stillivalmyndar það mun fela í sér Vísitala.HTMLskrá samanstendur af þremur römmum; treeView.html, findNode.html og mainPage.html og svo shortcutError.htmlsíðu. The treeView.html er fjölmennasta með tree.js, tree_items.jsog tree_tpl.js JavaScript skrár staðsett undir fela möppu (rætt hér að neðan) og endurtekningar Explorer tré frá Abacus. The findNode.html gengurað find.js JavaScript skrá staðsett undir eru möppu (rætt hér að neðan) og það mun leita útibú tré frekar en bara sýnilega hnúta. THann mainPage.html er kyrrstæð HTML síðu sem hægt er að sníða með sameiginlegur lógó og þess háttarog verður sýnt nema upphafssíðu er valið þegar birta.Og að lokum, shortcutError.html síðu er áfangasíðu fyrir hvaða brotinn flýtileiðir frá trénu vegna viðeigandi síður ekki verið birt.

Ábending

Þú getur sleppt því mainPage.html öllu því velja að nota upphafssíðu þegar birta eða breyta index.html skjalið til að benda beint til tiltekins útsýni (segja) með því að breyta FRAME SRC = "mainPage.html" lína að benda beint til fyrsta mati í fyrsta arkitektúr, þá yfirleitt "ramma" skýringarmynd.

2. The efstu égncludemappa inniheldurIngýmsar javascript (JavaScript útlit) og Cascading stíll lak (CSS) skrár notuð af .html skrá yfir birt fyrirmynd.

3. Efsta Content mappa inniheldur, Í stafrófsröð;

· A '3D Views' mappa meðnúmeruðHTML síðu og VRML eða abacus3d skrá fyrir hvert birtar 3D útsýni. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· An Arkitektúr mappa með tölusettum HTML síðu fyrir hverja arkitektúr sem birt var. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· A Vörulistar möppuna sem inniheldur tölusett HTML síðu fyrir hverja birt bæklingum. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· A Charts mappa meðnúmeruðHTML síðu og PNG, JPG etc skrá fyrir hvert birtar Mynd útsýni. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· A Hluti möppuna sem inniheldur anúmeruðHTML síðu fyrir hverja birtar hluti. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· A Tengingar möppuna sem inniheldur anúmeruðHTML síðu fyrir hverja birtar tengingar. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· A Skýringarmyndir möppuna sem inniheldur anúmeruðHTML síðu og PNG, SVG etc skrá fyrir hvert af birt skýringarmyndir. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· An Tákn undir-mappa með ýmsar myndir notað um birt fyrirmynd.

· A Standards undir-möppu meðnúmeruðHTML síðu fyrir einhverju staðlarsem voru birtar. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

· A Sniðmát undir-folder með safn af númeruðum undirmöppur fyrir hvern sniðmát birt af verkefninu. Innan hvers undir-möppu er Components og Tengingar möppu og innan þeirra er númeruð HTML síðu fyrir hverja hluti og tengingu sniðmátið. Sjá athugasemd hér að neðan til að fá upplýsingar um möppu / skrá númerakerfið.

· A Tegundir undir-mappa með Component ogTenging undir-möppur meðnúmeruðHTML síðu fyrir einhverjum innihaldsefnum ogTenging Tegundir sem voru birtarog safn af númeruðum undirmöppur fyrir hverja tegund sem birtist út úr verkefninu sem inniheldur HTML síðu fyrir hverja þvingun. Sjá athugasemd hér að neðan til að fá upplýsingar um möppu / skrá númerakerfið.

· A Viewbendas undir-möppu ognúmeruðHTML síðu fyrir einhverju Útsýnibendas sem voru birtar. Sjá athugasemd hér að neðan til að fá upplýsingar um skrá númerakerfið.

Note

Tölusetning HTML síður (og í sumum tilvikum myndaskrár) passar einstakt ID fyrir hvern geymsla hlut sem var stilla hvenær það var búininnan Abacus (vísað til sem EEIDs). Þessi ID breytist ekki svo eins skýringarmyndir, tegundir, hluti etc eru uppfærð þeir munhalda sama ID eins og áður. Í öllum tilvikum, viðkomandi geymsla mótmælaNafnið er að finna nálægt upphafi HTML milli

... HTML tags.

Takmarka aðgang að tilteknum síðum / Skoðað með IIS

Ef nota IIS eins og þinn vefur framreiðslumaður sem birt fyrirmynd, þú mega vera fær til að takmarka aðgang að ákveðnum síðum / útsýni nýta aðferðina hér á eftir:

1. Búa til vefsíðu í IIS (annað ef það er núverandi einn þú vilt ekki að trufla).

2. Breyta Properties-> Directory Security> Anonymous aðgang - Taktu hakið nafnlaus aðgang og notkun sannvotta aðgang.

3. Ef þetta er bara eðlilegt framreiðslumaður án ríki fylgikvillum etc, þá ættir þú að nota "samþætta Windows Authentication valkostur sem myndi þá nota miðlara vél Local Notendur / tenging sem staðfesting, og bara bæta við notendum til the heimamaður tölva (vera varkár að þú ert meðvituð um afleiðingarnar, öryggi vitur, að bæta við nýjum notendum á vél, td eftir því hvort fjarlægur aðgangur er skipulag fyrir vél, etc).

4. Bæta heimildir til sérstakra skrár / möppur sem þarf. Hægri smelltu einstaka skrár / möppur -> Properties og stilla öryggi heimildir eins og venjulega fyrir skrár / möppur.

Þetta getur verið mismunandi eftir því hvaða útgáfa af IIS og hvaða sérstakar Windows OS er á þjóninum, og hvort þú ert með lén eða öðrum mismunandi skipulag.

Sjá einnig

Populating vélina þína | Greina vélina þína


Skráir Abacus

Navigation: Tilvísun>

Skráir Abacus

Senda athugasemdir um þetta efni.

Þegar þú byrjar fyrst Abacus (eða eftir tímabundna leyfi er útrunnið) þú þarft að skrá forritið gegn leyfi miðlara Avolution er með einstakt leyfi lykill veitt af staðbundnum Abacus Administrator eða beint frá Avolution. Ef þú ert ekki með leyfi lykill vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur .

Að skrá sig með leyfisveitandi lykill

1. Eftir uppsetningu, byrja Abacusmeð annað hvort því að tvísmella á flýtileið á skjáborðinu eða úr Windows Start valmyndinni.

2. Í Skráning glugganum sem birtist inn á 26 eðli leyfisveitandi lykillveitt af staðbundnum Abacus Administrator eða Avolution stuðningur Eða smellur Flakka ...og veldu undirritaður .dlsc skrá aftur úr Avolution Stuðningur eins og á athugasemd á Skref 4 hér á eftir. Ef nota á réttan hátt undirritað .dlsc skrá ABACUS ætti að byrja eins og í skrefi 5 hér að neðan.

Ábending

Þú getur límt leyfi lykill í glugganum með því að afrita það til Windows klemmuspjald og þá velja bakgrunn gluggans og ýta á Ctrl + V

Skráning valmynd

3. Smelltu OKog ef leyfisveitandi lykill er gildi ABACUS leyfisveitandi lykillABACUS mun nú reyna að hafa samband leyfi miðlara Avolution að staðfesta leyfi lykill.

Note

Ef þú færð Uppsetning er ógildurskráning villa það er líklegast að þú hafir slegið kóðann rangt. Prófaðu að afrita og líma kóðann sem á Vísbending ofan.

Að hafa samband við Avolution License Server

4. Smelltu OKog eftir stutta tíma ABACUS skal skrá með góðum árangri.

Árangursrík Skráning

Note

Ef þú færð Get ekki samband leyfi miðlaraskráning villa það er líklegast að við eldvegg (eða aðrar öryggisráðstafanir) á netinu eru hindra aðgang að leyfi miðlara Avolution er. Smelltu OK, Vista .dlsc skrá til þinni vél og þá annaðhvort email .dlsc skrá til Avolution Stuðningur og bíða frekari leiðbeiningareða reyna að undirrita leyfi skrá þig með því að nota eftirfarandi vefslóð - http://licensing.avolutionsoftware.com/LicenceSign/ .

Get ekki að hafa samband við leyfi miðlara

Opnaðu License undirritun vefsíðu

Handbók License undirritun webpage

Einnig, ef þú færð Þessi uppsetning kóðinn hefur verið notaður á fleiri kerfum en heimilt er samkvæmt leyfiskráning villa það er líklegt að þinni vél hefur verið endurbyggð síðan þú skráð síðast Abacus eða þú ert að reyna að skrá þig hjá leyfisveitandi lykill annars notanda. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur .

Uppsetning hefur nú þegar verið notað

5. Smelltu OKog ef skráð tókst ABACUS ætti að opna með Velkomin Screen .

Sjá einnig

Avolution Stuðningur | Hvað þýðir ABACUS gera?


Standard Element Val

Navigation: Greina vélina þína>

Standard Element Val

Senda athugasemdir um þetta efni.

Þegar þú býrð til skýringarmynd, 3D útsýni, Skýrsla,staðall grafeða keyra uppgerð, Staðlaða þáttur val gluggi er notaður til að velja atriði sem þú vilt að greina / skoða.

Standard Element Val Window

Pulldowns

· Sía eftir Viewmun eru þátturs frá áður vistað augum (þ.e. Mynd, mynd, 3D). Á þennan hátt er hægt að framkvæma flókin 'ganga' fyrirspurnir með því að meðhöndla aðra mynd sem er vistuð 'fyrirspurn'.

Gátreit

· Sýna LevelsVilji hópur þátturinn í samræmi við stig sem hún á sér stað í trénu. Level 1 er efst mest stig.

· Sýna ferðalagaVilji hópur þætti í samræmi við tegundir sem þeir eru.

· Foreldrar valdirmun fela foreldri þætti hvaða völdum þáttum. Á þennan hátt er hægt að tryggja að aðeins stigveldi ofan þau börn verða að vera með í "botn-upp" val.

· Börn valinnmun fela börnunum þætti sem valda þætti. Á þennan hátt er hægt að tryggja að aðeins stigveldi neðan við allar foreldra verður að vera með í "ofan" val.

· Name Matches gildimun fela aðeins þá þætti sem hafa nafn sem inniheldur tilgreint band (Vinsamlegast athugið: algildi (þ.e. og *) er hægt að nota?). Á þennan hátt er hægt að mynda "merkingartækni" fyrirspurn.

· Hefur Property Type / Name / Valuemun fela aðeins þá þætti sem hafa Property gerð, heiti og gildi sem inniheldur tilgreint band annaðhvort beint á frumefni eða staðla (Vinsamlegast athugið:?.? algildi (þ.e. og *) er hægt að nota td * í Value svæðið mun gefa alla þætti sem hafa ekki eyða gildi fyrir tiltekinn eign). Á þennan hátt er hægt að mynda "merkingartækni" fyrirspurn.

· Hefur Standardmun fela aðeins þá þætti sem hafa Standard nafn inniheldur tilgreint band (Vinsamlegast athugið: algildi (þ.e. og *) má td nota HP * mun gefa alla þætti með að minnsta kosti einn Standard byrja með bréf H og P?.). Á þennan hátt er hægt að mynda "merkingartækni" fyrirspurn.

· Hluti / Connections fest valinnmun fela í sér allar meðfylgjandi þætti til þeirra sem hafa verið valin. Á þennan hátt er "kalla-tré" eða "áhrif-analysis" er hægt að velja.

Note

Ef þú hefur bæði Sýna Levelsog Sýna ferðalagavalið þá getur þú valið að hafa tré sýna að styrkur fyrsta eða gerðir fyrst með hnappinn sem birtist fyrir ofan tvö reitina.

Ábending

Þegar söluhlutur er valið í Standard Element valgluggi, mun það ekki vera háð neinum frekari sía breytingar þar til það er deselected. Þar er ekki innfæddur leið til að leita að tveimur mismunandi sett af þáttum í einu (td hluti með Standard A eða staðall B) er hægt að leita fyrst fyrir eitt sett, veldu hluti, og þá framkvæma aðra leita annað sett .

Buttons

· Alltvelur alla þætti.

· InvertAfvelur alla sem valdar þætti og velur alla þá sem voru ekki valdir.

· EkkertAfvelur alla þætti.

· Bæta Síavelur leiðir innihald núverandi sía stillingar og gerir úrval af utanaðkomandi efni sem í raun er og eða taka þátt síu.

Sjá einnig

Greina vélina þína


The Teikning Tól

Navigation: Populating vélina þína> Using Teikningar>

The Teikning Tól

Senda athugasemdir um þetta efni.

The Teikning Tool leyfa the sköpun af a breiður fjölbreytni af byggingarlistar aðaldráttum og skýringarmyndir. Arkitektar nota jafnan fjölda mismunandi teikningar að taka upp og flytja hönnun arkitektúr. Two-víddar (2D) skýringarmyndir eru venjulega leið skrásetja og samskipti ýmsum hlutum kerfisins. Dæmigert teikningar tegundir notaðar í kerfi fyrirtækisins eru:

· Viðskipti ferli módel og skýringarmyndir;

· Skipurit;

· Samvinnu skýringarmyndir;

· Entity-Relationship (ER) skýringarmyndir;

· Data-flæðiritum (DFD er);

· Class skýringarmyndir;

· IDEF (innlimun af framangreindum); og

· UML (innlimun af framangreindum).

Það raunverulega er engin takmörk til hvers konar skýringarmyndir sem hægt er að skapa. ABACUS reynir að halda jafnvægi skýringarmynd sveigjanleika en varðveita heilleika arkitektúr og eyðublöð hennar við fyrirsvar.

Teikningin umhverfi er grábröndóttur köttur og dockable glugga inni í helstu Abacus umsókn. Þessi gluggi inniheldur striga þar sem teikningin fer fram og þegar teikna gluggi er opinn annað dockable glugga Er stencil glugga, er hægt að skoða með a setja af teikningu stencils. The stencil megin eru 4 flipa: Hluti, tengingar, stærðum og tengjum. The striga virðist sem hvítum bakgrunni með fínum línum rist (gagnlegt fyrir skipulag).

Þættir eru táknuð með ýmsum stærðum, en tengingar eru dregin sem beint línum. Tengingar hengja hluti með hlutverk (þ.e. annað hvort Source eða sökkva) Þó að þetta eru ekki sýndar fyrir fagurfræðilegu ástæðum.

Ábending

Þó skýringarmyndireru mjög gagnlegar til að sýna mismunandi hluta kerfi, eru þeir takmörkuð í sveigjanleika þeirra, sem er hvers vegna ABACUS notar 3D að sjón flókin mannvirki kerfi.

Þú vilt kannski að

1. Opna Diagramming Tool

2. Búa til nýjan skýringarmynd á hluta af arkitektúr þinn

3. Afrita skýringarmynd innan eða yfir arkitektúr

4. Bæta hluti til skýringarmynd

5. Búa nýja hluti og tengingar í vélina þína (með skýringarmynd) með því að nota teikningu tól

6. Eyða hluti frá skýringarmynd

7. Hengja & vinna tengingar

8. Breyta Display Properties á íhlutum og tengingar.

9. Nota tengla í skýringarmynd

10. Framfylgja félagsform og sjónarmið svo sem að takmarka þær tegundir skýringarmyndir sem draga má.

Sjá einnig

Populating vélina þína | Populating arkitektúr handvirkt | Greining arkitektúr þinn


Title Page

ABACUS

Fyrirvari

Avolution Pty Ltd ábyrgist ekki ábyrgð með tilliti til þessa handbók og, að því marki sem lög leyfa, sérstaklega takmarkar ábyrgð sína vegna brota á hvers kyns ábyrgð sem kann að vera óbein að skipta í þessari handbók við aðra. Ennfremur Avolution Pty Ltd áskilur sér rétt til að endurskoða þessa útgáfu hvenær sem er án incurring skylda til að tilkynna hvaða manneskja á endurskoðun.

Copyright

Copyright 2001-2015Avolution Pty Ltd. Öll réttindi áskilin.

Vörumerki

Avolution Pty Ltd hefur gert allt sem í valdi til að veita upplýsingar vörumerki um vöruheiti, fyrirtækjaheiti, vörur og þjónustu sem nefnd er í þessari handbók. Vörumerki sýnt hér að neðan voru fengnar úr ýmsum áttum.

Microsoft Windows, Access, Visio, Excel, SQL Server og Internet Explorereru vörumerki Microsoft Corporation.

General Tilkynning:

Sumir vöruheiti notuð í þessari handbók eru notuð til auðkenningar aðeins og geta verið vörumerki viðkomandi fyrirtækja.

Desember 2015Edition fyrir Avolution Abacus Útgáfa 4.5.

Manual Revision 1.0

Mynda, prentuð og bundin í Ástralíu.


ABACUS Uppsetning Pre-requisites

Navigation: Tilvísun>

ABACUS Uppsetning Pre-requisites

Senda athugasemdir um þetta efni.

Upplýsingar Varðandi Sjón Innflutningur og Excel Import / Export

ABACUS krefst þess að Microsoft Office að setja í því skyni að framkvæma Excel Import / Export og Sjón innflutningur rekstri. Vinsamlegast staðfestu að Microsoft Office 2003 eða nýrrier sett upp á réttan hátt. Ef þú lendir í frekari vandræðum, hafðu samband Avolution Stuðningur .

Til þess að framkvæma Visio Innflutningur og Excel Import / Export starfsemi, ABACUS notar Microsoft Office Primary Interop þing (PIA er). ABACUS nú kemur pakki með þingum nauðsynlegar til að framkvæma Excel Import / Export og Sjón Import.

Upplýsingar Varðandi SQL Server Import

ABACUS krefst þess að Microsoft SQL Server 20052008, 2008 R2, 2012 eða 2014er sett upp í því skyni að hefja nýtt verkefni úr SQL Server. Vinsamlegast staðfestu að Microsoft SQL Server 20052008, 2008 R2, 2012 eða 2014er sett upp á réttan hátt. Ef þú lendir í frekari vandræðum, hafðu samband Avolution Stuðningur .

Villur Opnun 3D visualisations

Ef ABACUS 3D Viewer virkar ekki fyrir þig, þú gætir verið vantar SlimDX DirectX afturkreistingur (sett upp sem hluti af fullum Abacus EXE setja). Þetta er hægt að sækja hér . Ef þú ert með 64bit útgáfu af Windows, getur þú einnig þurft að setja upp þetta .

Villur Breyti ABACUS Custom Skýrslur

Breyti Abacus 'Custom Skýrslur krefst Report Builder 3.0 að vera uppsett. ABACUS og Report Builder eru byggð á Microsoft .NET Framework 4.0, og á meðan þeir báðir þurfa ekki Microsoft .NET Framework 3.5, Microsoft hefur rangt stilltur Report Builder MSI að aðeins halda áfram ef Microsoft .NET Framework 3.5 er sett upp.

Samkvæmt því, Avolution hefur stytt útgáfa af Report Builder uppsetningu MSI skrá sem ekki krefst Microsoft .NET Framework 3.5, þetta er hægt að sækja hér .

Upprunalega Microsoft Report Builder MSI er hægt að sækja hér . Ef þú ert ekki þegar með Microsoft .NET Framework 3.5 sem það mun þurfa, getur þú sótt það hér . Ath: Til margra mannvirkja, auðkenni uppsetningu á Microsoft .NET Framework 3.5 frá hér getur verið meira viðeigandi.


Hætta við og Endurgera

Navigation: Populating vélina þína> Populating handvirkt> auka valkosti>

Hætta við og Endurgera

Senda athugasemdir um þetta efni.

Eins og margir nútíma forritum, ABACUS styður hæfni til að bæði losa og endurtaka nýlegar notandi breytingar á opnu verkefni. Til að hætta við nýjustu breytingar, einfaldlega virkja afturkalla skipunina. Breytingar sem hafa verið að afturkalla má redone með því að virkja endurtaka skipunina; aftur um nýjasta afturkalla breytingu.

Warning

Afturkalla breytingar eru ekki fær um að vera reapplied ef frekari breytingar verða á verkefninu frá því að vera að afturkalla.

Note

Þó að mikill meirihluti breytingar styðja afturkalla / endurtaka í rauntíma, sumir skýringarmynd stencil breytingar, eins og að búa til nýjan Type-Shape / Line félag eða breyta félag lit eiginleiki, er ekki hægt að afturkalla strax. Í þessum tilvikum er breytt Skýringarmynd (táknað með stjörnu) að vera lokað áður en þessar breytingar er hægt að afturkalla.

Hætta við og Endurgera stjórn stöðum

Hætta við og Endurgera skipanir má nálgast úr þremur mismunandi stöðum:

· Edit valmyndinni

· sem hefðbundin tækjastika

· á lyklaborði flýtilyklar CTRL + Z(losa) og CTRL + Y(endurtaka)

Ábending

Hætta við og Endurgera hnappana á stöðluðu stikunni veita listanum listum sem sýna 10 nýjustu breytingar sem hægt er að afturkalla og hefur verið redone sig. Þeir eru einnig hentug leið til að losa / endurtaka margar breytingar í einu.


Using Fjölvi

Navigation: Líkja vélina þína>

Using Fjölvi

Senda athugasemdir um þetta efni.

Ef þú framkvæma verkefni ítrekað í abacus, getur þú sjálfvirkan verkefni með því að nota fjölvi. Samkvæmt því, sem ABACUS fjölvi er skráð röð aðgerða sem hægt er að aukaleikur hvenær sem er.

Taka upp Macro

1. Veldu Tools | Record Macroeða að öðrum kosti að ýta Alt + F10.

2. Byrja að framkvæma aðgerðir sem þú vilt taka upp.

Warning

Á þessum tíma, það eru sumir þekkt vandamál með þjóðhagsleg upptöku. Vinsamlegast taka þetta með í reikninginn þegar hljóðritun Fjölvi þína:

· Eins Fjölvi bara taka þinn Microsoft Windows mínútum, mús hreyfingar og mús-smelli. Hins vegar, vegna takmarkana með efnahagslegu upptökutæki sig, það eru sumir mínútum sem eru ekki alltaf skráð. Meðal þeirra eru:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] á [F12]

· Því er mælt með að þú farir að flýtilykla er skráð af efnahagslegu upptökutæki fyrir upptöku stór röð af atburðum sem kann að ráðast á þessi flýtilykill vinna.

· Nú vegna takmarkana með efnahagslegu upptökutæki, eru samhengi matseðill ekki meðhöndlaðar á réttan hátt með Abacus þegar þau eru opnuð með aðgerð skráð af efnahagslegu upptökutæki. Þegar þú opnar valmynd, verður þú að framkvæma eitt af hlutverkum sem talin eru upp í samhengi matseðill gegnum valmynd, annars samhengi matseðill má vera opið á spilun, sem getur leitt til óviljandi aðgerðir eða aðgerðir sem gætu valdið mistök í Abacus.

· Athugaðu að venjulegur aðferðir loka valmynd (td ýta [Esc] á lyklaborðinu, eða vinstri-smella einhvers staðar annars staðar á skjánum) getur ekki í raun að loka valmynd meðan spilun á efnahagslegu.

Ábending

Í valmynd, frekar en að nota mús-smelli, er mælt með að nota Tab-takkann til að fara í gegnum fyrirliggjandi eftirlit og bendilinn takkana til að velja úr fellilista atriði eða valhnappar og Space bar til að velja / afvelja stöðva kassa.

Til að stöðva upptöku a Macro

1. Press Alt + F9eða að öðrum kosti að velja Tools | Hætta Macro.

2. Í Vista Macro Eins valmynd fletta að stað og velja ABACUS þjóðhagsleg (.abacusmac skrá) Skráar og smella á Vista.

Note

Using Verkfæri| Hætta Macromun fela þessa aðgerð í skráð efnahagslegu. Því er mælt með að notendur verða vandvirkur í að nota Alt + Virka helstu valkosti til að vinna með fjölva svo sem ekki að fela óþarfa efnahagslegu starfsemi í Fjölvi sjálfum.

Ábending

Eins og Fjölvi eru ekki nú editable það er mælt með því að taka langar verkefni sem röð stakra Fjölvi nota Alt + F10 / Alt + F9 'pör'.

Að spilun upptekið Macro

1. Veldu Tools | Spilun Macroeða að öðrum kosti að ýta Alt + F8.

2. Í Open Macro valmynd fletta að stað og velja ABACUS þjóðhagsleg (.abacusmac skrá) Skráar og smellt á Open.

Warning

Þegar þeir opna abacus efnahagslegu, ef þú tvöfaldur-smellur á macro skrá frá beit valmynd til að opna hana, efnahagslegu upptökutæki heimilt halda vinstri músarhnappi í vinstri-smellt ríkis þar upptekið vinstri-smelltu yfirhafin þetta ástand.

Note

Spilun hraði efnahagslegu er hægt að stilla á General flipanum undir Verkfæri| Valkostirsem annaðhvort Normal (sjálfgefið), hratt eða hægt. Bæði hratt og hægur spilun hraða er ekki mælt með því að þeir munu spila aftur upptekið Fjölvi á um 100 tímum og 1 / 100th rauntíma, í sömu röð. Normal spilun hraði mun enn spila á efnahagslegu u.þ.b. 30% hraðar en skráð hraða svo það er mælt með því á meðan upptöku til að gera hlé í stuttan tíma eftir einhverjar langar verkefni vinnslu til að tryggja að við spilun næsta aðgerð er ekki framkvæmd áður en vinnsla verkefni hefur lokið.

Til að stöðva spilun skráð Macro

1. Press Alt + F9.


Skoða 3D skýringarmynd

Navigation: Greina vélina þína> 3D skýringarmyndir>

Skoða 3D skýringarmynd

Senda athugasemdir um þetta efni.

ABACUS gerir þér kleift að skoða vélina þína sem 3D útsýni þar hluti og tengingu eignir eru tengd með liti, form og stærðir.

Til að skoða 3D mynd af arkitektúr þinn

1. Tryggja þú hafa opna Abacus skráinniheldur þínum byggð arkitektúr.

2. Stækkaðu Viewsútibú tré.

3. Stækkaðu 3Dútibú tré.

4. Tvísmella visualization þú vilt opna.

- Eða -

1. Tryggja þú hafa opna Abacus skráinniheldur þínum byggð arkitektúr.

2. Veldu Insert| 3Deða smelltu á stikunni hnappinn.

3. Opna núverandivisualization (.abacus3d)

- Eða -

1. Tryggja þú hafa opna Abacus skráinniheldur þínum byggð arkitektúr.

2. Veldu Insert| 3Deða smelltu á stikunni hnappinn.

3. Búa til nýjan visualization:

· Veldu Arkitektúrþú vilt skoða úr fellilistanum.

· Veldu Hlutiog Tengingarþú vilt hafa með í myndinni frá því staðall þáttur val gluggi .

· Tengja liti, form og stærðir með Component ferðalagaog Properties.

· Tengja liti og form með Tengingu ferðalagaog Properties.

Að flytja 3D view

1. Tryggja þú hafa opna núverandi 3D view.

2. Í fellivalmyndirnar í 3D view er valið Skrá | Export ...og valdi staðsetningu og skrá tegund fyrir visualization skrá (.abacus3d, .vrml eða .html).

3. Smelltu Vista.

Sjá einnig

Greina vélina þína | Navigation í 3D | The diagramming Tól


Skoðar Blöðrurit

Navigation: Greina vélina þína> Custom töflur>

Skoðar Blöðrurit

Senda athugasemdir um þetta efni.

A kúla graf gerir þér kleift að bera saman allt að 5 mál (þ.e. X, Y, stærð kúla / geisla, kúla lit og kúla landamæri lit) á einum skjá.

Til að skoða Blöðrurit

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Veldu Insert| Mynd| að Sérsniðin Chartsflipi | Bubble Mynd.

3. Í Arkitektúrkafla, merkið í arkitektúr (ef einhver) þú vilt að kortleggja, smelltu þá Næsta.

4. Veldu Hlutiog Tengingarsem þú vilt í myndinni (ef einhver) frá staðall þáttur val gluggi , Smelltu þá Næsta.

5. Veldu X-áseign, smelltu þá Næsta.

Note

Aðeins Integer, Decimal, Date / Time, Boolean og List eignir er hægt að nota fyrir X-ás. Ennfremur eru Integer, Decimal og Date / Time eignir samsæri vinstri til hægri meðfram ás minnkaðar í samræmi við verðmæti eignarinnar, hins vegar eru Boolean og List eignir einfaldlega samsæri vinstri til hægri í þeirri röð (eða í í öfugri röð ef kostur að snúa við röð er köflóttur) skilgreint fyrir eign óháð gildi þeirra. T.d. Low | Medium | Hátt eða 1, 2, 4, 8, 16.

6. Veldu Y-áseign, smelltu þá Næsta.

Note

Aðeins Integer, Decimal, Date / Time, Boolean og List eignir er hægt að nota fyrir y-ásnum. Ennfremur eru Integer, Decimal og Date / Time eignir samsæri botn-til-toppur meðfram ás minnkaðar í samræmi við verðmæti eignarinnar, þó Boolean og List eignir eru einfaldlega samsæri botn-til-toppur í þeirri röð (eða í í öfugri röð ef kostur að snúa við röð er köflóttur) skilgreint fyrir eign óháð gildi þeirra. T.d. Low | Medium | Hátt eða 1, 2, 4, 8, 16.

7. Veldu Stærð kúla / radíuseign, smelltu þá Næsta.

Note

Aðeins Integer, Decimal, Boolean og List eignir er hægt að nota til að bólustœrðin / radíus. Ennfremur, Integer og Decimal eignir í för með sér stærð kúla / radíus minnkaðar í samræmi við verðmæti eignarinnar, þó Boolean og List eignir jafnræði eykst skref í kúla stærð / radíus í þeirri röð (eða í öfugri röð ef möguleika á að snúa við röð er köflóttur) skilgreint fyrir eign óháð gildi þeirra. T.d. Low | Medium | Hátt eða 1, 2, 4, 8, 16.

8. Veldu annaðhvort fast lit kúlaeða tengja eign með kúla lit, Smelltu þá Næsta.

Note

Aðeins Integer, Decimal, Boolean og List eignir er hægt að nota til að lit blöðrunnar. Ennfremur, Integer og Decimal eignir í för með sér kúla lit innan valið svið minnkaðar í samræmi við verðmæti eignarinnar, þó Boolean og List eignir jafnræði eykst skref af kúla lit innan valið svið í þeirri röð sem skilgreind fyrir eign án tillits horf. T.d. Low | Medium | Hátt eða 1, 2, 4, 8, 16.

9. Veldu annaðhvort engin kúla landamæri liteða tengja eign með kúla landamæri lit, Smelltu þá Finish.

Note

Aðeins Integer, Decimal, Boolean og List eignir er hægt að nota til að kúla Rammalitur. Ennfremur, Integer og Decimal eignir í för með sér kúla landamæri lit innan valið svið minnkaðar í samræmi við verðmæti eignarinnar, þó Boolean og List eignir jafnræði eykst skref í kúla landamæri lit innan valið svið í þeirri röð sem skilgreind fyrir eign óháð gildi þeirra. T.d. Low | Medium | Hátt eða 1, 2, 4, 8, 16.

Blöðrurit

Til að vista Blöðrurit

Note

Kúla töflur Aðeins er hægt að vista ef þau innihalda aðeins hluti og tengingar, sem allir þurfa að vera frá einum arkitektúr innan núverandi verkefni.

1. Tryggja að þú hafa a nýr eða núverandi Blöðrurit opinnog þú hefur gert nauðsynlegar breytingar.

2. Í töflu stikunni smelltu á lengst til vinstri Vista Myndhnappinn til að vista töfluna og allir formatting breytingar.

3. Í Mynd Namevalmynd sem birtist slá inn heiti fyrir Blöðrurit og stutt OK.

Að flytja Blöðrurit

1. Tryggja þú hafa opna núverandi Blöðrurit.

2. Í graf stikunni smella á 2. frá vinstri Vista sem BMPhnappinn og valdi stað fyrir töfluna.

3. Smelltu Vista.

Sjá einnig

Greina vélina þína


Skoða pláss hæfileiki töfluna

Navigation: Greina vélina þína> Custom töflur>

Skoða pláss hæfileiki töfluna

Senda athugasemdir um þetta efni.

A Hæfileiki Space graf gerir þér kleift að skoða hvort arkitektúr þinn uppfyllir þarf kerfi getu með tilliti til eiginleika sem komu kerfi þörf greining ferli.

Til að skoða getu pláss töfluna

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr, Og að þú hafir metinarkitektúr þinn.

2. Veldu Insert| Mynd| Sérsniðin Charts| Hæfileiki Space. (The Getu Space Mynd Configvalmynd vilja sýna.)

3. Í Arkitektúrkafla, merkið í arkitektúr þú vilt töfluna, smelltu þá Næsta.

4. Í Propertiessvæði, merkið byggingarlistar eiginleika sem þú vildi eins fylgir sem ása töfluna.

5. Í Hæfileikisvæði, fyrir hverja eign með frá fyrra þrepi, velja hvort lágmarkskröfur eða hámörk hæfileiki til og gildi þessara marka. Sjálfgildi eru lágmarks og hámarks gildi metin fyrir arkitektúr eða þess Markmið fyrir eign ef það hefur verið sett.

Að flytja getu pláss töfluna

1. Að tryggja að þú ert með núverandi hæfileiki pláss grafopinn.

2. Í töflu stikunni smelltu á lengst til vinstri Vista sem BMPhnappinn og valdi stað fyrir töfluna.

3. Smelltu Vista.

Sjá einnig

Greina vélina þína | Skoða svar tími töfluna


Stöðluðum skýrslum

Navigation: Skýrslur um arkitektúr þinn>

Stöðluðum skýrslum

Senda athugasemdir um þetta efni.

ABACUS ' staðall skýrslur leyfa þér að fá lista yfir hluti og tengingar í einu eða fleiri af arkitektúr þínum. Skýrslan inniheldur allar upplýsingar sem tengjast íhlutum og tengingar völdum, þ.mt upplýsingar um hluti eða stað tengingu er í stigveldi, gerð, staðla, lýsingu, eiginleika og viðhengjum.

Note

Skýrslan efni erstillanlegtgegnum Tilkynna Options valmynd og lýst er hér, þó, teða finna út fleiri upplýsingar um hvernig á að búa til alveg stillanlegt sérsniðin skýrslurnota Abacus sérsniðnar skýrslurVinsamlegast vísa til efni hér eða samband Avolution Stuðningur .

Til að skoða staðall Skýrsla

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr(s).

2. Veldu Insert| Standard Reporteða smelltu á Búa Standard Report tækjastikuhnappur. The Skýrsla Configurationgluggi verður birt.

Skýrsla stillingaglugganum

3. Veldu Arkitektúr, Hlutiog Tengingarsem þú vilt í skýrslu frá Skýrsla stillingaglugganum.Vinsamlegast vísa til Standard Element Val hér efni fyrir hjálp.

4. Nú smellur á Valkostirhnappinn og Tilkynna Optionsgluggi birtist.

Skýrsla Options glugginn

5. Þú getur valið um að sýna Ný síða fyrir hvert frumefniEr Print Date, Print Time, Page Numbersog hvort að fela í titil í hausaf skýrslu tjalddúkur / unticking viðeigandi gátreiti. Þú gætir einnig viljað að aðlaga titilinn og höfundur með því að breyta Skýrsla Titleog Höfundur texta kassa. Þú getur einnig valið hvaða efni birtist á skýrslu með því að merkja / unticking stöðva hnefaleikar undir Skýrsla Contenthluta glugga. Þegar þú hefur lokið að smella á OK.

6. Smelltu á FinishÍ skýrslunni Stillingar glugga.

Að túlka sýnilega skýrslu

Dæmi Mynda Report með stuttar skýringar

Til að fletta í gegnum skýrslu síður, smellur á the helgimynd [image] staðsett á stikunni á efst í vinstra horninu á skjánum.

Note

Þú getur vista í skýrslunni að ýmsum sniðum með því að smella á Export Skýrslan icon [image] staðsett í stikunni. Þú getur valið að flytja í eftirfarandi snið: Excel, PDFog Bæta. Vistaðu skýrslu í viðkomandi stað til síðari nota. Ef breytingar eru gerðar á arkitektúr síðar, í nýrri skýrslu verður að vera búin að endurspegla breytingarnar.

Sjá einnig

Greina vélina þína


Skoða svar tími töfluna

Navigation: Greina vélina þína> Custom töflur>

Skoða svar tími töfluna

Senda athugasemdir um þetta efni.

A svar tími graf gerir þér kleift að skoða hvort tengsl eru í vinnslu á þurfa hraða (þ.e. innan frests þeirra).

Til að skoða svar tími töfluna

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin inniheldur þínum byggð arkitektúr, Og að þú hafir metinarkitektúr þinn.

2. Veldu Insert| Mynd| Sérsniðin Charts| Viðbragðstími. (The Svartími Mynd Configvalmynd vilja sýna.)

3. Frá Arkitektúrfalla-dúnn listi, velja arkitektúr þú vilt að kortleggja.

4. Í Tengingarsvæði, merkið tengingar sem þú vildi eins og með í myndinni.

5. The Scale Typesvæði, velja Línulegef þú vilt lóðrétta ásnum (svar tími) sem birtist sem línuleg framrás - hver hluti af tíma er úthlutað til jafns við konur ás. Veldu Lógaritmískumef þú vilt að hún birtist sem lógaritmískum framrás - hver hluti af ás táknar sífellt lengri tíma að hærra upp ás sem þú ferð. (The hlutfall af hækkun ræðst af Baseþú velur.)

Svartími graf lóðréttur ás mælikvarða

Að flytja svar tími töfluna

1. Að tryggja að þú ert með núverandi svar tími grafopinn.

2. Í töflu stikunni smelltu á lengst til vinstri Vista sem BMPhnappinn og valdi stað fyrir töfluna.

3. Smelltu Vista.

Sjá einnig

Greina vélina þína | Skoða pláss hæfileiki töfluna


Skoðar scatter söguþræði þróast arkitektúr þínum

Navigation: Greina vélina þína> Custom töflur>

Skoðar scatter söguþræði þróast arkitektúr þínum

Senda athugasemdir um þetta efni.

Þegar arkitektúr hefur verið þróast og markmið eru skilgreind, getur það þá verið visualized og samanburði við upprunalegu arkitektúr með punktana fylkjum. Þessi hluti lýsir því hvernig á að búa til og skilja einkenni á öðrum ásnum fylki.

Til að skoða punktana matrix þróast arkitektúr þínum

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Tryggja þú hafa þróastog Setja markmiðfyrir vélina þína eins og lýst er undir Þróun vélina þína

3. Veldu Insert| Mynd| að Sérsniðin Chartsflipi | Ásnum Matrix.

4. Smelltu á Finishhnappinn.

5. The Punktaritmeð skilgreint þróun arkitektúr og markmið verða birtar.

Note

Svæðið á vinstri hönd hlið af punktana fylkinu sýnir stillingar punktana fylki birt. Þetta felur í sér arkitektúr sem hefur verið þróast (í þessu tilfelli "ABC Ltd As-Is 2010") Sem og markmið sem sett hafa verið fyrir þessi arkitektúr. Þú verður í huga að markmið sem hafa merkið merki við hliðina á þeim eru fulltrúa sem X og Y ása punktana fylki (td KPI- Kostnaður, KPI - Gæði og KPI - Time). Þú gætir óþrifalegur þessum markmiðum á allir benda af tími til að fjarlægja þá frá punktana fylki.

Bláu punktarnir sem birtast á lóð þitt í fylkinu tákna eðlileg gildi, sem ræðst af bestu og verstu gildi (fram undir Setja markmið fyrir þróast vélina þína ). Þessi gildi eiga fulltrúa í Quality Space.

Tveir skilgreind markmið eru borin saman við annan í ásnum fylki og ferlið er endurtekið þar til allir markmið hafa verið borin saman (td Fyrsta söguþræði fylkinu í myndinni hér fyrir ofan saman við KPI - KostnaðurMarkmið með KPI - Quality Markmið. Annað er Kostnaður á móti Time og síðasta lóð er Quality á móti Time. Viðkomandi merki markmið eru sýnd efst og rétt eða hverja röð Lóðir.).

6. Veldu Arkitektúrútvarp hnappur ef þú vilt birta mælieiningar fyrir einstökum arkitektúr.

7. Veldu Þróunarútvarp hnappur ef þú vilt sýna Leiðréttur breytingar frá upprunalega arkitektúr (td Eins og-er 2010) Við þróast arkitektúr (s) (t.d. To-Be 2011 - Stefna A og til-Be 2011 - Stefna B).

Sjá einnig

Greina vélina þína | Skoða svar tími töfluna | Skoða stjarna söguþræði þróast arkitektúr þínum | Þróun vélina þína


Skoða staðlaða töflu

Navigation: Greina vélina þína> Standard töflur>

Skoða staðlaða töflu

Senda athugasemdir um þetta efni.

Abacus 'staðlaðar töflur eru lína, bar, dálki svæði, dreifa, baka, bugða, Pareto, skref, yfirborð, ratsjá, teningur, kleinuhring, pýramída, útlínur og ferill svæði töflur. Þegar þú hefur valið hvaða mynd sem þú vilt, en afgangurinn af ferlinu til að skoða hver þessara töflur er sú sama.

Til að skoða venjulega graf af arkitektúr þinn

1. Tryggja þú hafa opna Abacus skráinniheldur þínum byggð arkitektúr, Og að þú hafir metinarkitektúr þinn.

2. Veldu Insert| Myndeða smelltu á stikunni hnappinn. The Chartsgluggi verður birt.

Charts glugga

3. Veldu tegund töfluna sem þú vilt og setja töfluna Valkostir, smelltu þá Næsta.

Mynd Options

o Staflaðmun sýna tengsl einstakra liða í heildina. Þú getur notað staflað töflu þegar þú ætlar að hafa marga gögn röð (þ.e. margar eignir) og þegar þú vilt leggja áherslu á samtals.

o Staflað 100%mun bera hlutfall hvert gildi stuðlar að samtals yfir flokka. Þú getur notað 100% staflað töfluna þegar þú ætlar að hafa marga gögn röð (þ.e. margar eignir) og þú vilt leggja áherslu á framlög til alls, sérstaklega ef alls er það sama fyrir hvert frumefni.

o 3D Myndmunu einfaldlega birta gögn stig í 3-D sniði fyrir fagurfræði. Ef þú vilt að birta gögn röð meðfram 3 / z-ás vídd þá nota Cluster Series möguleika sem lýst er hér.

o Röð af Propertymun birta gögn röð fyrir hverja eign sem er á endanum valin. Ef þetta er hakað þá eiginleika verða flokkar og gögn röð verður fyrir hvert frumefni sem er valinn.

o Snúa myndmun snúa töfluna um 90 gráður réttsælis því að hafa skipti á x og y ásum. Þessi valkostur er aðeins í boði fyrir línurnar, skref og Cube töflurog er sérstaklega gagnlegar til að gera Milestone töflur eins og lýst er í síðar við hér fyrir neðan. Ath: Column og bar töflur eru þegar 'snúið' útgáfur af hvor öðrum.

o Cluster Seriesmun birta fjölda upplýsinga röð meðfram 3 / z-ás vídd. Þessi valkostur er aðeins í boði fyrir Column, Bar og Cube töflurog er sérstaklega gagnlegur fyrir gerð Gantt stíl töflur eins og lýst er í fyrstu Ábending neðan.

Ábending

Þú getur búið til Gantt grafmeð láréttum börum sem sýna tími / dagsetning eignir fyrir mismunandi þætti með því að velja í súluriti tegund og þá velja Cluster Series möguleika.Ennfremur, þegar búið, vinstri-mest bar á myndinni er hægt að gera "ósýnilegt" með því að lita það hvítur með því að hægri-smella á einn af börum, velja Litur úr valmyndinni sem birtist og velja efra vinstra lit úr stiku. Auk landamerkin til vinstri-mest bar er hægt að gera "ósýnilegt" með því að hægri-smella á einn af börum, velja Properties ... og á Series flipanum í glugganum sem birtist breyta Border Áhrif til enginn og Litur efst -left lit úr stiku.

Ábending

Þú getur búið til Milestone grafmeð litlum form sýna tími / dagsetning eignir fyrir mismunandi þætti með því að velja Cube töflugerð og þá velja Snúa Mynd og Cluster Series valkostir.Ennfremur, þegar búið, teningur hægt að breyta öðrum stærðum með því að hægri-smella á einn af the teningur í tilteknu gögn röð og velja Properties ... og á Series flipanum í glugganum sem birtist breyta barnum að annaðhvort Cylinder eða Keila . Ath: The Gap breidd gildi er einnig hægt að nota til að "skreppa" táknum á myndinni til að draga úr skörun, því hærri sem talan er minni skörun verður.

4. Í Arkitektúrkafla, merkið arkitektúr / s þú vilt að kortleggja arkitektúr stig eiginleikum, smelltu þá Næsta.

Note

Val arkitektúr stig eiginleika er alveg valfrjálst skref og ætti aðeins að nota þegar þú vilt að beinlínis kortleggja arkitektúr stig eiginleika sjálfir.Arkitektúr þarf ekki að vera valinn til að þá eru hluti eða tengistillingar eignir í næsta skref.

5. Veldu Hlutiog Tengingarsem þú vilt í taflan staðall þáttur val gluggi , Smelltu þá Næsta.

6. Veldu Propertiesþú vilt í myndinni og smella Finish.

Mynd Options

o Eru stöðluð eignirmun sýna arf eiginleika frá þeim stöðlum í boði fyrir val.

o Samanlagðar Propertiesmun telja dreifni milli röð gildum og kortleggja þær niðurstöður í stað þess að einstaklingur metur sig.Þessi valkostur er aðeins í boði ef Series með Property möguleikinn var valinn í lið 3 hér að ofan.

Ábending

Eiginleikar boði fyrir Gröf ráðast á þá þætti sem þú velur.

Til að vista töfluna

Note

Töflur Aðeins er hægt að vista ef þau innihalda aðeins hluti og tengingar, sem allir þurfa að vera frá einum arkitektúr innan núverandi verkefni.

1. Tryggja að þú hafa a nýr eða núverandi töfluna opinnog þú hefur gert nauðsynlegar breytingar.

2. Í töflu stikunni smelltu á lengst til vinstri Vista Myndhnappinn til að vista töfluna og allir formatting breytingar.

3. Í Mynd Namevalmynd sem birtist slá inn heiti fyrir töfluna og styddu OK.

Að flytja töflu

1. Að tryggja að þú ert með núverandi grafopinn.

2. Í graf stikunni smella á 2. frá vinstri Vista sem BMPhnappinn og valdi stað fyrir töfluna.

3. Smelltu Vista.

Sjá einnig

Greina vélina þína | Skoða svar tími töfluna | Skoða pláss hæfileiki töfluna


Skoða stjarna söguþræði þróast arkitektúr þínum

Navigation: Greina vélina þína> Custom töflur>

Skoða stjarna söguþræði þróast arkitektúr þínum

Senda athugasemdir um þetta efni.

Þegar arkitektúr hefur verið þróast og markmið eru skilgreind, getur það þá verið visualized og samanburði við upprunalegu arkitektúr með stjörnu Lóðir. Þessi hluti lýsir því hvernig á að búa til og vinna með stjörnu lóð.

Til að skoða stjörnu söguþræði þróast arkitektúr þínum

1. Tryggja þú hafa óákveðinn greinir í ensku ABACUS skrá er opin .

2. Tryggja þú hafa þróastog Setja markmiðfyrir vélina þína eins og lýst er undir Þróun vélina þína

3. Veldu Insert| Mynd| að Sérsniðin Chartsflipi | Star Plot.

4. Smelltu á Finishhnappinn.

5. The Star Plotmeð þróast arkitektúr og setja sér markmið birtast. ATH: ásar stjörnu lóð má endurstaðsettar með því að smella og draga ása í annað svæði innan marka stjörnunni lóð gæði rúm.

Note

Svæðið á vinstri hönd hlið af the stjörnu lóð sýnir stillingum stjörnu lóð birt. Þetta felur í sér arkitektúr sem hefur verið þróast (í þessu tilfelli "ABC Ltd As-Is 2010") Sem og markmið sem sett hafa verið fyrir þessi arkitektúr. Þú verður í huga að markmið sem hafa merkið merki við hliðina á þeim eru fulltrúa sem ása stjörnu lóð (td KPI- Kostnaður, KPI - Gæði og KPI - Time). Þú gætir óþrifalegur þessum markmiðum á allir benda af tími til að fjarlægja þá úr stjörnu lóð.

Rauða og græna "punktar" sem birtast á stjörnu lóð þitt tákna eðlileg gildi, sem ræðst af bestu og verstu gildi (fram undir Setja markmið fyrir þróast vélina þína ) Fyrir valda efstu arkitektúr og hvaða þróunar á það. Þessi gildi eiga fulltrúa í Quality Space.

Eins og lýst er í myndinni hér að ofan, er það greinilega að upprunalega arkitektúr (Eins og-er 2010) Hefur léleg Kostnaður, Á meðan á fyrsta þróast valkostur (To-Be 2011 - Stefna A) Hefur flutt í gæðum pláss til að bæta Kostnaður, Gæði og Timemarkmið. Að öðrum kosti, annar þróast valkostur (To-Be 2011 - Stefna B) en það hefur einnig batnað á Kostnaður umfang framför er minna en Stefna A en bæði gæði og tíma markmið hafa verið bætt meira en við Strategy A.Í þessu tilviki er arkitekt getur velja Stefna Ayfir Stefna Bsem tillögu þeirraog frekari þróast á þann kost (To-Be 2012 - Stefna A).

6. Taktu hakið úr Sýna þróunarkassann til að fela línu (s) stendur fyrir þróun (s) á milli upprunalegu (td Eins og-er 2010) Og þróast (t.d. To-Be 2011 - StefnaA) arkitektúr (s).

7. Veldu Sýna Stafurkassann til að sýna hlutfallslegt umfang hvers gæðum eigindi (þeim markmiðum sem skilgreind hafa verið á hverri ása) fyrir hverja arkitektúr.

8. Veldu Sýna Arkitektúr nöfnkassann ef þú vilt nöfn upprunalegu og þróast arkitektúr (s) til að birtast á stjörnu lóð.

Sjá einnig

Greina vélina þína | Skoða svar tími töfluna | Skoða á öðrum ásnum matrix þróast arkitektúr þínum | Þróun vélina þína


Greina vélina þína

Navigation: Greina vélina þína>

Greina vélina þína

Senda athugasemdir um þetta efni.

Þegar þú hefur fjölmennasta (og mögulega herma) vélina þína, þú ert tilbúinn til að nota Abacus að greina það. Með því að greina það, getur þú ákveðið hvort arkitektúr mun mæta þörfum þínum.

Hægt er að greina vélina þína í ýmsum mismunandi vegu:

· Skýringarmynd

· 3D útsýni

· staðall töflur (baka, lína, dálkur, Bar, osfrv)

· sérsniðin myndir ( viðbragðstími , rúm getu , stjörnu lóð , ásnum fylki og kúla graf )

· Arkitektúr Diff

Note

Þegar þú býrð til skýringarmynd, 3D útsýniSkýrslu eða staðall graf, sem staðall þáttur val gluggi er notað til að velja atriði sem þú vilt skoða.

Sjá einnig

Populating vélina þína | Líkja vélina þína | The Diagramming Tool


Hvað er arkitektúr?

Navigation: Inngangur að Abacus>

Hvað er arkitektúr?

Senda athugasemdir um þetta efni.

Arkitektúr er ágrip hugtak- Ekki líkamleg hlutur. Það er ríkur og alhliða lýsingu eða skilning á uppbyggingu kerfisins - handtaka hluti og hvernig þeir eru tengdir (samskipti). Þar sem hugmyndin um arkitektúr er svo allur-umkringja, er það grundvallaratriði að kostnaði, aðgengi, evolvability, hreinskilni, og árangur kerfisins. A hljóð arkitektúr er a pre-nauðsynlegur á hljóðkerfi.

Í abacus, þú fyrirmynd vélina þína. Fyrir einfaldleiki, við köllum þetta byggingarlistar líkan arkitektúr.

Myndin hér að neðan sýnir dæmigerða arkitektúr 5hluti (í stigveldi) tengdur við 2 tengingar. The merki tilgreina nöfn gefin hinum ýmsu hlutum í arkitektúr í Abacus.

Einföld arkitektúr

ABACUS telur alla þessa hluti til að vera hluti af arkitektúr:

· Hlutitákna stofnanirnar á vélina þína sem þú gætir lýst sem "hluti". Fyrir tryggingafélags hluti gæti verið kerfi fyrir vinnslu stefnu, kröfur, greiðslur og kvittanir.

· Tengingartákna sambandið milli þessara þátta. Til dæmis, í vátryggingafélagi, eru tekjur mynda af gildum reglum eru kröfur á hendur gild stefnu, og gildar kröfur leitt greiðslur. Þegar að hugsa Arkitektúrinn - sérstaklega þegar Abacus - tengingar eru eins mikilvæg og hluti, og þeir er fjallað í nánast sömu leið.

· Allt í trénu er hægt að hafa Properties. Eignir eru hlutir eins og the vegur þú þarfnast kerfi til að framkvæma, fjölda lína af kóða það hefur, sem hlutfall af þessum línum sem eru ummælin osfrv ABACUS telur alla þessa hluti til að vera hluti af arkitektúr.

· Með því að nota stigveldi(þ.e. undirliðir og undir-tengingar), Getur þú fela upplýsingar og de-semja vélina þína. Abacus byggingarlistar líkan er mjög sveigjanlegur. Einhver hluti á hvaða stigi er hægt að tengjast öðrum íhlut á öðrum vettvangi eftir tengsla á hvaða stigi.

· Viðhengier rekstur með hvaða hluti hafnir eru bundnir til tenginguhlutverk. Hafnir og Hlutverk eru tengismilli hluta og tengingar. Þau eru notuð til að festa tengingar við hluti. Tengingar hafa fengið og sökkul Hlutverk(auðvelda gagnaflæði frá upptökum hluti til vaskinn hluti)og eðli, hafa hluti hafnir. Fyrir einfaldleiki, þó í Abacus hluti hafnir eru ekki sýndar og tengingin hlutverk eru beint fest við hluti sjálfir.

· Hluti og tengingar eru ákveðin Gerð. Þetta er aðallega fyrir flokkun. Til dæmis stefna, kröfur, greiðslur og kvittanir eru hluti af þeirri gerð "kerfi". Gild stefnu, gilda kröfur, osfrv eru tengingar af gerðinni 'færslu. The Type úthlutað á íhlut eða tengingu veitir sniðmát fyrir eiginleika og staðla sem það hefur. Til dæmis, a Server íhluta gæti hafa "Gerðu Model ' staðallog IP Address eign. Ólíkt öðrum stíf verkfæri með grunn Vensla gögn-basa (RDB) bak-endir, í Abacus þú getur frjálslega búa til eigin nýja þínum Tegundir og úthluta eigin samsetningar þína á eignir og staðla til þeirra.

· Standard bókasöfn eignir getur verið skilgreindur og úthlutað til nokkuð annað í arkitektúr. Þessi bókasöfn eru þekkt sem Standards. Með því að nota Standards, Þú þarft aðeins að safna tilteknum kerfum eignir - venjulegt eignir eru þar nú þegar. Til dæmis staðlaða eiginleika árangur af Microsoft Windows 2000 er hægt að úthlutað til hvað þættir eru að nota Microsoft Windows 2000 stýrikerfi.

Sjá einnig

Hvernig er arkitektúr fulltrúa í Abacus? | Hvað þýðir ABACUS gera? | Hvernig þú gerir það (Yfirlit) | Að búa til nýja tegund


Vinna með Enterprise Server

Navigation: Administration>

Vinna með Enterprise Server

Senda athugasemdir um þetta efni.

ABACUS Enterprise Server er bæði 'ekki læsa' samvinna nálgun, en eitt 'ótengdur' einnig. ABACUS er 'ekki læsa' vegna þess að það ekki þvinga skrá til að vera læst við einn notanda fyrir það að vera uppfærð. Hver notandi hefur sitt eigið eintak af the skrá, og eins og þeir gera breytingar og vista skrá þeirra, eru þær breytingar skráðar og geymdar fyrir þegar notandi óskar að fremja þá til the framreiðslumaður.

ABACUS er 'ótengdur "í þeim skilningi að þú þarft ekki að vera tengdur við miðlara eða þörf aðgang meðan að vinna á skrá. ABACUS þarf aðeins aðgang að þjóninum þegar framkvæma aðgerðir eins og að búa til skrána, eða framkvæma stöðva, ásamt rekstri á núverandi skrá - uppfærslu, fremja, eða skoða skrána á síðasta skuldbindur. Aðgang að þjóninum er ekki skylt að vinna á skrá, og breytingarnar eru ekki send til miðlara strax (þetta gerir þér kleift að auðveldlega henda breytingum ef þú gerir mistök). Þegar þú vistar skrána, þú ert "bara" sparnaður þinn Afrita staðnum - það er ekki fyrr en þú fremja að heimamenn breytingar (breytingar gerðar frá síðustu fremja þinn), eru send til miðlara.

Að búa til nýtt fyrirtæki skrá

Til að búa til nýja Enterprise skrá skaltu velja File| New ...og þá velja einn af fyrstu tveimur valkostum undir Enterprise Model hluta af New Project valmynd (þ.e. annað hvort auður Enterprise skrá, eða búa til einn frá núverandi Abacus skrá). Þriðji kosturinn er að "Checkout" Enterprise skrá einhver annar hefur þegar búið til, verður þetta að falla í næsta kafla.

Þegar þú velur að búa til nýja Enterprise skrá, verður þú að vera gefið glugga sem leyfir þér að fletta að þar á geymsla miðlara sem þú vilt geyma skrá. Það mun einnig hafa núverandi skrá gangstígur og nafn inn allt toppinn ef þú valdir 'frá núverandi Gerðin frá New Project valmynd og fylgir skrá.

URL: Þetta er slóðin geymsla miðlara þar abacus Enterprise skrár eru geymdar. Þú ættir að spyrja mann sem er að stjórna framreiðslumaður hvað þetta URL ætti að vera.

Myndin hér að ofan sýnir geymsla með fjórir (4) núverandi ABACUS Enterprise verkefni, eftir að slá slóðina og ýta á Enter.Þú munt sjá eftir að þú býrð til nýtt Enterprise skrá, á næsta screenshot fyrir 'Checkout ", það mun vera annar mappa og skrá undir þessum geymsla.

Note

Ef þú ert að nota https (SSL) framreiðslumaður, og the framreiðslumaður er ekki með gilt SSL vottorð (algengt fyrir heimaneti eða non-almennum framreiðslumaður vegna að Kostnaður við SSL vottorðs) Það verður auka skref til að taka. Þú verður að vera nauðsynlegt til frambúðar samþykkja allar tengingar til þess miðlara í glugganum sem birtist (það mun einnig sýna aðeins meiri upplýsingar um miðlara). Til að gera þetta, tegund "p" (án gæsalappa) og ýttu á Enter. ABACUS mun skjóta upp skilaboð að minna þig á þetta áður sýna valmynd.

Note

Þú verður etv beðinn að skrá þig inn á miðlara en þá sá sem er stjórna framreiðslumaðurgetur veitt miðlara notandanafn og lykilorð. Einnig innskráningarskilríkin fyrir netþjóna sem þú hefur tengst eru vistaðar svo ef af einhverri ástæðu að þeir þurfa að vera hreinsaðar þetta er hægt að gera með Verkfæri | Valkostirog síðan á General flipann með því að smella Endurstilla Subversion Saved Innskráog velja miðlara úr fellilistanum og smella Hreinsa Innskráningog velja Í lagi í glugganum sem birtist.

Note

Ólíkt screenshot sést hér að ofan, oftast einn ABACUS Project er í hverju Abacus Repository því ef meira en 1 ABACUS Project er búin í einu abacus Repository, abacus breyting log tölur eru bornar á öllum Abacus Verkefni og þetta getur ruglað notendur.

Valinn FilenameÞetta hefur áhrif bæði möppu og skráarheiti sem verður notuð (ef ekki nú þegar tekið) þegar þú býrð skrána á geymsla miðlara. Athugaðu að ný mappa er búin til sjálfkrafa á geymsla miðlara fyrir hverja skrá (til að auka hraða, eru ABACUS Fyrirtæki skrár búnar til í eigin möppu þeirra undir stað beit í glugganum).

Geyma vinna eintak í Directory: Þegar Enterprise skrá er búin til á geymsla miðlara, þarf vinnuafrit skrár að vera búin á tölvunni þinni, svo þú getur unnið á skrá án þess að vera tengdur við netið. Þetta er staðurinn sem þú beit til þegar þú vilt opna / re-opna ABACUS Enterprise skrá.

Stöðva núverandi Enterprise Skrá

Ef einhver hefur þegar búið til nýja Enterprise skrá, get stöðva "þessa skrá, sem niðurhal staðbundin afrit og setur upp nauðsynlegar skrár þannig ABACUS viðurkennir þetta sem Enterprise skrá þig. The valmynd er svipað New Enterprise valglugga. Sláðu inn geymsla slóðina (undirmöppum getur verið innifalinn í slóðinni), velja þarf skrána og velja Í lagi. Með fyrirvara um skýringu fyrir neðan thann leggja verður þá opnuð.

Note

Þú verður etv beðinn að skrá þig inn á miðlara en þá sá sem er stjórna framreiðslumaðurgetur veitt miðlara notandanafn og lykilorð. Einnig innskráningarskilríkin fyrir netþjóna sem þú hefur tengst eru vistaðar svo ef af einhverri ástæðu að þeir þurfa að vera hreinsaðar þetta er hægt að gera með Verkfæri | Valkostirog síðan á General flipann með því að smella Endurstilla Subversion Saved Innskráog velja miðlara úr fellilistanum og smella Hreinsa Innskráningog velja Í lagi í glugganum sem birtist.

Enterprise File Mismunur

Þegar þú hefur búið til Enterprise skrá (annaðhvort nýtt, eða um 'kaup' á skrá búin til af einhverjum öðrum), mappa verður búin til á skrá, og það mun almennt innihalda þessar 3 helstu tegundir af skrám:

· '.abacus' File- Þetta er ABACUS skrá sig. Breytingar sem þú gerir á staðnum eru ekki strax vistuð í þessari skrá, það er aðeins skrifað til þegar þú fremja. Þessi skrá er "eðlilegt" ABACUS skrá, það er hægt að gefa ekki EE notendursem standa-einn verkefni (án .log skrá)Eða nota sem útgangspunkt fyrir nýja EE skrá.

· Skráin '.changes'- Staðbundin (óráðstafað) breytingar sem gerðar eru á skrá. Ef þessi skrá er sem vantar, þetta þýðir að það eru engar staðbundnar breytingar.

· '.log' File- Þessi skrá er aðeins þær breytingar sem voru gerðar af síðustu notanda (innihaldi .changes skrá notandans þegar þeir drýgðu).

Note

Það eru ýmsar aðrar skrár sem hægt er að búið við uppfærslu og fremja ferli, þ.e.; ‘.changesbefore'File- Þessi skrá er afrit af .changes skrá eftir að uppfærsla hefur verið flutt og er notað til að sjálfkrafa sætta allir ID átök milli uppfærslu og allir heimamaður (uncommitted) breytist áður fremja; ‘.backup'File- Þessi skrá er afrit af .changes skrá áður en notandi vistar til fleiri (inngang) breytingar á .changes skrá; og ‘.error'File- Þessi skrá er afrit af .changes skrá ef það væri einhver mál sem olli Abacus að mistakast að opna .abacus skrá og notandinn valdi að snúa þeirra breytist.Þessar skrár geta verið hunsuð.

Opna skrá

Til að opna skrá, þú þarft aðeins að skoða hvar þú velur að geyma vinna eintak, og opna Abacus sem geymd þar. Þegar ABACUS sér að það er a .annáll (og kannski .breytingar skrá ef þú hefur gert breytingar), það mun meðhöndla skrána sem fyrirtæki skrá.

Uppfæra skrá

Performing an 'Uppfæra' mun athuga hvort nýrri útgáfa af skrá er staðsett á þjóninum. Ef það er, það verður lokað núverandi skrá, uppfæra í nýrri skrá frá the framreiðslumaður, og sækja sumir tímabundnar skrár sem hafa númer á framlengingu - td "Demo.125 '. Þessar skrár eru eldri útgáfur af .log skrá, og eru notuð til að ákvarða hvaða breytingar hafa verið gerðar á skrá þar sem þú síðast uppfærð það. Þetta er nauðsynlegt til að greina ágreining sem kann að hafa átt sér stað þannig að þú getur leyst þau.

Ef á uppfærslu ferli eitthvað átökfundust, Þú þarft að leysa þau áður en þú getur opnað skrána þína aftur (þú getur hætt en þú verður beðinn um að leysa ágreining afturnæst þegar þú opnar skrána þína).

Vista skrá

Þegar þú vistar skrána, þessi Bætir allar breytingar sem þú hefur gert á þeim .changes skrá. Það gerir ekkibreyta .abacus skrá á þessu stigi - einungis þegar skrá er skuldbundinn til miðlara verður það ritað yfir (eða þegar þú færð uppfærslu frá þjóninum).

Hvar er 'Save As "?

Það er engin hugmynd um að spara eins fyrir Enterprise skrá. Þú getur hins vegar að afrita vinna eintak .abacus skrá, hafðu í huga að það vanur staðværar breytingar í henni.

Deilumála

Ef aðrir notendur hafa framið breytingar á skrá í svipuðum hluta af the skrá til þín, there mega vera sumir átök milli breytinga þeirra og ræða. Til dæmis, annar notandi getur eytt hluti sem þú hafðir uppfæra eign á. Þú þarft annaðhvort að losa breytingu þeirra (ef þú ert viss um að þeirra ættiekki hafa gerst), eða fleygja breytast (þú getur þá farið aftur inn í skrána og endurtaka breytast).

Sérstaklega eru 4 flokkar af átökum sem geta komið;

1. Eyða - Þegar einn notandi eyðir hlut að annar notandi breytingar. T.d. Notandi eytt efnisþátt en notandi B breytti nafni íhlutinn eða tengdur henni eða bætt barni hluti á það etc.

2. Eiginleiki - Þegar tveir notendur bæði breytt nákvæmlega sama 'eiginleiki' á hlut. T.d. Bæði Notandi A og User B breytti nafni A hluti er eða lýsingu hans eða virði einn eiginleika þess o.fl.

3. Tilvísun - Þegar tveir notendur breyta nákvæmlega sama 'tilvísun' hlut hefur til annars hlut. T.d. Bæði Notandi A og User B breytt gerð A hluti eða hvaðan / vaskur hluti fest við tengingu eða tengda sjónarhóli fyrir skýringarmynd osfrv

4. Safn - Þegar tveir notendur breyta 'safn' fyrir hlut. T.d. Bæði Notandi A og User B flutti hluti frá öðru foreldri til annars eða með tilvísun til-pantaði safn af börnum hluti.

Note

Ýmsar ómerkileg átök eru sjálfkrafa leyst af Abacus að lágmarka kostnaður á notendur.Til dæmis einhver andstæðar allri zoom stillingar fyrir skýringarmyndir eru leyst að halda nýjustu allri zoom stillingar.

Fremja breytingar

Þegar þú velur að fremja breytingarnar abacus skrá frá þjóninum er opnuð, þinn sveitarfélaga breytingar eru gerðargegn henni, og svo sveitarfélaga þitt skrá .abacus er plága með einn sem hefur breytingar í það. Breytingarnar þínar skrá þá birtist á .log skrá, og bæði .abacus skrá og .log skrá eru send til miðlara.Ef fremja tekst a Fel skilaboð valmynd eins og sýnt er hér fyrir neðan, er í boði til að slá inn skilaboð með fremja.

Skoða skrá yfir breytingar

Til sjá skrá yfir breytingar á að Enterprise VerkefniðVelja File| View Log...

Hámark færslunum: Þessi mun sjálfgefið að síðustu 10 færslum en frekari færslur er hægt að sækja með því að breyta gildi og smella á Sækja hnappinn.

Endurskoðun: ThE Revision dálki er listi yfir endurskoðun tölur framin á Enterprise Server, við vanræksla, í öfugri tímaröð.

Note

Endurskoðun tölur má ekki vera samfelld og aðeins ABACUS framið verður skráð á meðan sama Subversion geymsla má vera notaður fyrir aðrar Abacus verkefna og / eða öðrum forritum útgáfa stjórna.

Dagsetning: ThE Date dálkur listi dagsetningu að endurskoðun var framið á Enterprise Server.

Time: ThE Time dálkur listi tíma dags (í 24 tíma sniðs) að endurskoðun var framið á Enterprise Server.

Höfundur: ThE Author dálkur listar Microsoft Windows notandanafn fyrir notanda sem gerðar commit eftir þeirra ABACUS notandanafn Eða 'Anonymous' ef notandinn er ekki staðfest og óþekktir notendur voru leyfðar aðgang að framtak verkefni á þeim tíma sem fremja.

Log Message: ThE Log Message dálkur listar fremja skilaboðin sem var veitt með endurskoðun eins og á glugganum hér að ofan.

Sækja endurskoðun XX sem standa-einn Abacus skrá: Ef þú velur tiltekna leiðréttingu töflunni og smelltu svo á Sækja hnappinn verður þú að vera fær um að draga valið Abacus verkefnið endurskoðun frá þjóninum og vista hana sem staðværa / standa-einn Abacus verkefni.

Note

Að rúlla aftur til fyrri útgáfu sjá þetta Avolution samfélag grein .

(Admin) Sækja XML annálinn fyrir endurskoðun XX: Notendur með Abacus Administrator hæfileiki getur valið gefið leiðréttingu töflunni og smelltu síðan á Sækja hnappinn til að vinna úr valið ABACUS verkefnið fremja annáll frá þjóninum og vista það sem xml skrá.

Skoða endurskoðunarnefnd slóð breytingar

Til skoða skoðunarskrá af breytingum á hverjum frumefni (þ.e. hluti, tengingu, skoða, börn osfrv) af Enterprise Verkefnið, hægri-smelltu á hlutinn og velja Audit Trail..., Setja Frá og endurskoðun svið og smellur Leita.

Note

Þegar liður er eytt úr verkefninu sem þú ert ekki lengur fær um að fá aðgang að tilteknum skoðunarskrá upplýsingar um frumefni. Þú getur hins vegar enn aðgang að 'foreldri' hluti (til dæmis) og sjá skoðunarskrá upplýsingar um brottfall (í þessu tilfelli skráningu ID þáttur sem var eytt).Ennfremur, Component / Connection viðhengi er a 'eign' af tengingum svo breyttum fest hluti í gegnum Explorer glugga eða á skýringarmynd sýnir í endurskoðun slóð fyrir tengingu stöðugt innra, og eyða tengingu og búa til nýja tengingu (eins gerist ef þú hægri-smelltu á "Unattach 'og' Tengjast ..." í bæklingum) mun leiða til taps á endurskoðun slóð upplýsinga fyrir upprunalegu hluti - tengingu viðhengi öllu leyti.

Note

Sjálfgefið endurskoðun slóð mun endurkvæmt athuga hvort breytingar einhverju börn valda frumefni. Þetta getur leitt til lengri tíma svörun og í samræmi við endurskoðun slóð er hægt að takmarka við frumefni sig því að taka hakið á Endurkvæma valkostur undir Endurskoðun Options'gír hjól' tækjastikuhnappur í skoðunarskrá valmynd.

Frá Revision: Þessi mun sjálfgefið að fyrsta / elsta endurskoðun boði fyrir verkefnið á Enterprise Server.

Endurskoðun: Þessi mun sjálfgefið að síðasta / nýjustu endurskoðun boði fyrir verkefnið á Enterprise Server.

Note

Eftir að setja til og frá endurskoðun svið smelltu á hnappinn Leita að sækja einhverjar sérstakar breytingar á valið frumefni.

Endurskoðun: ThE Revision dálki er listi yfir endurskoðun tölur framin á Enterprise Server, við vanræksla, í framvirkum tímaröð.

Note

Endurskoðun tölur eru ekki líklegar til að vera samfelld og aðeins breytingar sem skipta máli við valið frumefni verður sýnt og aðeins ABACUS skuldbindur verður skráð á meðan sama Subversion geymsla má vera notaður fyrir aðrar Abacus verkefna og / eða útgáfa stjórna forritum.

Dagsetning: ThE Date dálkur listi dagsetningu sem notandinn aðgerð var gerð.

Note

Dagsetningin sést er notandi aðgerð dagsetningu, en ekki þegar endurskoðun var skuldbundinn til að Enterprise Server. Samkvæmt því, dagsetningu getur verið undanfari samsvarandi endurskoðun fremja dagsetning sést með Skrá | Skoða Innskráning ...stjórn.

Time: ThE Time dálkur listi tíma dags (í 24 klst sniði) sem notandinn aðgerð var gerð.

Note

Tíminn sem birtist er notandi aðgerð tími, ekki þeim tíma sem endurskoðun var skuldbundinn til að Enterprise Server. Samkvæmt því, sem tími mun sennilega undan samsvarandi endurskoðun fremja tíma og sýnt með Skrá | Skoða Innskráning ...stjórn.

Höfundur: ThE Author dálkur listi notanda sem gerðar Microsoft Windows notandanafn Aðgerðin er eftir þeirra ABACUS notandanafn Eða 'Anonymous' ef notandinn er ekki staðfest og óþekktir notendur voru leyfðar aðgang að framtak verkefni á þeim tíma sem notandi til aðgerða.

Note

The Höfundur skráð í skoðunarskrá glugganum er ekki endilega að passa við höfund sem skráð eru í View Log glugga ofan fyrir sama endurskoðun. Þetta er vegna þess að View Log valmynd listar innskráður í notandi á þeim tíma sem fremja meðan skoðunarskrá valmynd listar innskráður í notandi á þeim tíma sem notandi til aðgerða, og það er hægt að hafa einn notandi gera breytingar og senda sínum. breytingar skrá á annan notanda til að fremja - eins og raunin er þegar ytri notandi (eins og Avolution) er að vinna á EE verkefni.

Upplýsingar: ThE Upplýsingar dálki er listi nákvæmlega upplýsingar um notanda aðgerð sem skráð á Enterprise Server.

Ábending

Það er gagnlegt að hópur af Revision dálk (eins og sýnt er í glugganum hér að ofan) og / eða User Action dálk að auðveldlega flokka breytingar á frumefni af áhuga.

Notkun Scripting með Enterprise skrár

Ef þú notar forskriftarþarfir ásamt fyrirtækinu skrár, ættir þú að vera meðvitaðir um hvernig á að rétt að eyða hlut úr líkaninu. Almennt, þegar þú ert að eyða hlut, verður þú að hringja í .Delete () aðferð á það, frekar en bara að fjarlægja það frá foreldri sínu.

T.d. ef þú hefðir comp1 sem foreldri comp2 og að þú viljir eyða comp2 í skriftunni þinni, ættir þú að hringja comp2.Delete (), frekar en comp1.Components.Remove (comp2).

Þú getur notað fjarlægja ef þú ætlar að bæta comp2 hlut á annan stað innan arkitektúr, en það ætti ekki að nota ef ætlunin er að eyða hlut.

Það er undantekning að þessu, þegar þú vilt fjarlægja hlut sem "býr" annars staðar í líkaninu. Þegar þú vilt fjarlægja staðlað dæmi frá arkitektúr / íhluta / tengingu, þá myndi gera það með því að fjarlægja hana úr venjulegu safni dæmi er - arch1.Gerð.Remove (IMP) - því að eyða það myndi fjarlægja það úr öllum tilvikum.

Rétt með Delete í skriftum er mikilvægt vegna þess að ef hlutur er fjarlægður úr objectmodel og ekki bætt við aftur, þá mun það ekki vera fær um að vera staðsett, en þar sem það var ekki sérstaklega 'eytt', Átök Greining og upplausn mun ekki rétt greina átök ef annar notandi var að reyna að nota þessi hlut í einhverju breytingar þeirra, og niðurstaðan verður skemmd sett af breytingum fyrir þennan notanda.

Sjá einnig

Hvernig er arkitektúr fulltrúa í Abacus?


Vinna með Abacus skrár

Navigation: Inngangur að Abacus>

Vinna með Abacus skrár

Senda athugasemdir um þetta efni.

An ABACUS skrá er gámur fyrir líkan af þinn arkitektúr . Í einu abacus skrá, getur þú fyrirmynd allir tala um arkitektúr allir tala af sinnum.

Þegar þú opnar abacus, það eru engar skrár opinn. Til að vinna á vélina þína, þú þarft að annaðhvort búa til nýja skrá eða opna núverandi skrá.

Þegar þú opnar eða búa til nýja skrá, tré í Explorer glugga mun sjálfkrafa sýna. Þetta landkönnuður sýnir þér vélina þína til þessa. Þegar þú lokar skrá, tré í Explorer glugga einnig hverfa.

Til að búa til nýja Abacus skrá

1. Veldu File| New ...

2. Í New Project glugganum sem birtist (eins og sýnt er hér fyrir neðan) Velduað annaðhvort búa til auðan líkan, fyrirmynd frá a staðall ABACUS bókasafn , A fyrirmynd frá sérsniðnum abacus bókasafn, a fyrirmynd frá XML, MS Access , MS Visio , MS Excel , MS SQL Server , An Enterprise Server líkan eða sérsniðna ABACUS bókasafn (.abacuslib skrá).

3. Smelltu á OKhnappinn og fylgja allir valmynd sem kunna að birtast.

Ábending

Þú verður ekki beðinn um að nefna skrána þar til þú vistað eða loka henni. Það er góð hugmynd að vista skrána eins fljótt og þú býrð það. Þá munt þú ekki að hafa áhyggjur af því að nefna það síðar í ferlinu þegar þú ert að einbeita sér að öðrum flóknum hlutum (eins og populating vélina þína).

Búa til nýtt verkefni

Abacus Standard Libraries

ABACUS styður yfir 100 opinber umgjörð og rithætti sem sum hver eru sýnd hér fyrir neðan. Þegar þeir velja að búa til nýtt verkefni frá venjulegu safngestir hafa a fljótur að byrja að sitja innan koma ramma taka fullur kostur af neinum skilgreindum staka tegund, eiginleika, rithætti, sjónarmið og sniðmát eða mynstur. Á staðall bókasöfn eru fáanleg í gegnum Avolution bandalagsins hér .

New Project frá Standard Library

Til að vista nýja Abacus skrá

1. Veldu File| Vista sem

Ábending

Skráarnöfn getur verið hvaða lengd, og getur innihaldið einhverjar alfa-töluna stafi og bil. Þeir geta ekki innihaldið tilda (~) eðli, pípa (|) eðli, spurningarmerki, eða stafi venjulega notað fyrir slóða lýsingar svo sem sviga (\) - nema sem hluta af þeirri braut (?).

Til að opna Abacus skrá

1. Veldu File| Open

Note

Ef þú ert að opna skrá frá sameiginlegum net stað sem er nú þegar opinn á annan notanda, ABACUS mun veita þér með lesa aðeins aðgang. Þegar þú notar Abacus með lesa aðeins aðgang, þú vilja ekki vera fær um að framkvæma skrifa aðgerðir, svo sem populating vélina þína og keyra úttektaraðila. Þú getur hins vegar að skoða vélina þína með því að nota Explorer skoða og 3D útsýni.

Sjá einnig

Hvernig er arkitektúr fulltrúa í Abacus?


Vinna með Mælaborð

Navigation: Administration>

Vinna með Mælaborð

Senda athugasemdir um þetta efni.

Abacus verkefni getur haft hvaða stillingar skoðanir (td skýringarmyndir, Töflur o.fl.) vistað sem mælaborð og vistuðu mælaborð getur verið sett sem sjálfgefið byrja "skjár" á opna verkefni og / eða úthlutað til a sérstakur notendahópur og kynnt meðlimi notendahóp þegar þeir skrá sig inn til Abacus verkefni.

Note

Til að stilla mælaborð í Abacus verkefni notandinn leyfi þarf Stjórnandi getu. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

Skoða mælaborð

Dæmi Umsókn Portfolio Management (APM) mælaborð

Til að skoða vistað Mælaborð

1. Veldu View| Mælaborð

2. Velja vistaða mælaborð úr listanum yfir tiltækar mælaborð.

Note

Þegar valið Abacus mun byggja skoðanir sem þarf til mælaborðinu og það getur tekið nokkrar sekúndur. Vinsamlegast vertu þolinmóður.

Annast mælaborð

Annast mælaborð

Til að búa til nýja mælaborðið

1. Opnaðu þarf útsýni og raða og bryggju gluggar sem þarf til mælaborðinu.

2. Veldu View| Mælaborð| Stjórna mælaborð ...

Note

Ef þú sérð ekki Umsjón mælaborð valmyndaratriði þá þarftu ekki Stjórnandi getu. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

3. Í glugganum sem birtist velja Búahnappinn og slá inn Mælaborð nafn í Create New Mælaborð valmynd.

4. Smelltu á OKhnappinn.

Til að eyða núverandi Mælaborð

1. Veldu View| Mælaborð| Stjórna mælaborð ...

2. Í glugganum sem birtist velja Mælaborð þú vilt eyða úr listanum og velja Eyðahnappinn.

Note

Eyði mælaborð mun einnig eyða öllum notandi hópverkefnum til að mælaborðinu.

3. Smelltu á OKhnappinn.

Að skipta núverandi Mælaborð

1. Opnaðu þarf útsýni og raða og bryggju gluggar sem þarf til endurnýjunar mælaborðinu.

2. Veldu View| Mælaborð| Stjórna mælaborð ...

3. Í glugganum sem birtist skaltu velja mælaborðinu þú vilt skipta úr listanum og velja Skiptahnappinn.

4. Smelltu á OKhnappinn til að viðurkenna Mælaborð Skipt valmynd.

Til að tengja Mælaborðsem upphafsmanneskju Skjár

1. Veldu View| Mælaborð| Stjórna mælaborð ...

2. Í glugganum sem birtist velja Mælaborð úr listanum sem á að tengja eins upphafsmanneskju 'skjá'og veldu Úthluta ...hnappinn.

3. Í glugganum sem birtist velja færsla í hópa notenda dálk.

Note

Aðeins einn mælaborð má tengja sem byrja 'skjár' svo aftur verkefni mun fjarlægja verkefni frá fyrra mælaborðinu.Enn fremur, ef notandi skráir sig í eins og a félagi af a notandi hópur sem hefur úthlutað mælaborð þá úthlutað mælaborð verður opnuð í stað sjálfgefna verkefnisins mælaborðinu.

4. Smelltu á OKhnappinn.

Til að tengja User Group til Mælaborð

1. Veldu View| Mælaborð| Stjórna mælaborð ...

2. Í glugganum sem birtist velja Mælaborð úr listanum sem þú vilt tengja notendahópur til og velja Úthluta ...hnappinn.

3. Í glugganum sem birtist velja User Group (eða hópa)þú vilt tengja mælaborð sem "byrja upp 'skjár fyrir.

Note

Ef sama User Group er úthlutað til margra mælaborð þá fyrst verkefni á listanum verður notað.

4. Smelltu á OKhnappinn.

Til myndefni notanda hópur úr mælaborðinu

1. Veldu View| Mælaborð| Stjórna mælaborð ...

2. Í glugganum sem birtist auka Mælaborð atriði af listanum sem þú vilt að myndefni notanda hópur frá.

3. Veldu notendahópur þú vilt myndefni og velja Ógiltuhnappinn.

4. Smelltu á OKhnappinn.

Setja heimildir

Heimildir er hægt að stilla fyrir mælaborð til að leyfa fyrir mælaborð að vera hægt að skoða, Updateable og / eða deleteableuppgefnum hópa notenda.

Heimildir Management

Til að stilla heimild til Mælaborð

1. Veldu View| Mælaborð| Stjórna mælaborð ...

2. Í glugganum sem birtist velja Mælaborð úr listanum sem þú vilt stilla heimildir og veldu Heimildir ...hnappinn.

3. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

4. Sjálfgefið þú munt sjá að Lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

5. Smelltu á OKhnappinn.

Sjá einnig

Aðlagaðu abacus tengi | Vinna með heimildir


Vinna með heimildir

Navigation: Administration>

Vinna með heimildir

Senda athugasemdir um þetta efni.

Abacus verkefni getur haft hlutverk-undirstaðaheimildir sett fyrir hvert frumefni innan geymsla. Nánar tiltekið, Fínmalaður Create-Read-Update-Delete (CRUD) Heimildir er hægt að stilla á "hlut" (þ.e. hluti eða tengingu), skoða og eigindi (þ.e. eign) stigum.

Yfirlit

Þegar unnið er með ABACUS Enterprise Server , ABACUS veitir Fínmalaður, hlutverk-undirstaða crud heimildir til að stjórna aðgangi margra notenda að geymsla.

Note

Til að stilla heimildir á Abacus verkefni notandinn leyfi þarf Stjórnandi getu. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

Heimildir er hægt að stilla fyrir arkitektúr, hluti og tengingu gerðum, eiginleika (með gerðir þeirra), sniðmát, sjónarmið og skýringarmyndir, bæklingum, fylkjum, töflur og 3Dútsýni. Þegar heimildir eru sett fyrir íhluta eða tegund tengingar öllum tilvikum af því tagi í hvaða arkitektúr í því verkefni "erfa" þá heimildir. Sömuleiðis, þegar leyfi er sett fyrir eign íhluta eða tegund tengingar, ákveðins eign á þessum aðskildu eða tengingu tilvikum í hvaða arkitektúr í því verkefni "erfa" þá heimildir. Samkvæmt því, ákveðnar heimildir verður beitt á skoðanir sem þessir þættir eru fyrir hendi. Þegar heimildir eru sett fyrir skýringarmynd, útsýnið og / eða innihald augum sjálfs hafa ýmsir heimildir beitt til þess.

Note

Sjálfgefið engar heimildir eru sett fyrir þeim þáttum innan og abacus verkefni. Það er allt þættir eru Createable, læsileg, updateable og Deleteable af öllum notendum. Á þennan hátt ætti eingöngu að íhuga heimildir fyrir tiltekinn þáttur í gagnageymslu þegar ákveðinn leyfi er að vera Takmarkaðurí tiltekinn notendahóp. Til dæmis, ef heimildir fyrir tiltekið notendahóp var bætt við hlut (td íhluta), en fór með allar heimildir virkt, þá er þetta virkni sama og ef að notendahópur var ekki bætt við hlut.

Heimildir getur ekkiað setja fyrir sérstökum tilvikum af þætti arkitektúr er. Til dæmis, getur þú ekki að gera einn Umsókn hluti enn updateable annar ekki. Til að í raun að ná þessum "lén sérstakar 'heimildir þó Stjórnandi getur sett upp sérstakar gerðir frumefni fyrir gefnar lén, td Component types Umsókn - CRM ríki "og" Umsókn - HR ríki ", og þá setja heimildir fyrir hverja tegund samræmis. Þú getur gert sérstakar hagsmunafélagi gerðir fyrir hvert lén og þá fjarlægja uppfærslu leyfi fyrir tilteknum lénum hóp tegund og þetta mun takmarka sköpun innan og úrfellingum frá því Flokkun en ekki uppfæra barnanna. Auðvitað ef Lénbundið Flokkun var falin með því að fjarlægja lesa leyfi þá börnin yrðu falin og þar sem ekki updateable. Einnig, ef skoðanir (frekar en Explorer) eru aðallega notaðar til að stjórna / skoða geymsla þitt, gefið skoða fyrir hvert lén gætu komið, og þá Administrator gæti sett heimildir fyrir hvert skoða samræmi við það.

Annast Notendur og hópar

Heimildir eru skilgreind á að Hlutverkeða hópurstigi, öfugt við einstökum notanda, þannig að á meðan aðild hópa getur breyst, heimildir geta haldið föstum. Auðvitað ef þú vilt a sérstakur notandi leyfi þá einfaldlega gera þá hóp, eða nánar tiltekið að búa til hóp með þeim notanda sem eina aðilans.

Það skal tekið fram að hópar eru lotukerfinu, Það er að þeir geta ekki erfa heimildir eða notendur frá einum til annars, og ef notandi tilheyrir mörgum hópum þá mest 'svartsýnn' hópur leyfi mun hafa forgang á mál-við-tilfelli fyrir sig fyrir hvert einstakt leyfi (þ.e. Búa Lestu-Update-Delete). Til dæmis ef sami notandi er meðlimur Group A og B- og A-hefur bara Búa-Lesa leyfi fyrir Umsókn hluti gerðir meðan Group B hefur bara Lestu-Update leyfi fyrir Umsókn hluti tegundir þá mun notandinn aðeins hafa lesið leyfi fyrir Umsókn hluti tilvik.

Ennfremur, við vanræksla, ónefndir notendur(sem er notendur sem hafa ekki verið skilgreint eða sem hafa ekki skráður inn) með fullan aðgangtil verkefnisins. Þetta er til að tryggja að aðgangur er í boði í fyrstu uppsetningu. Til að loka fyrir aðgang óskráðir notendur einfaldlega óhindraður the "Leyfa nafnlaus notandi fullan aðgang að skrá 'valkostur í Stjórna notendum / hópa Dialog sést hér að neðan. Þegar hakað óskráðir notendur mun aðeins vera fær um að sjá Standards hluta hvers verkefnis.

Að lokum, ef kostur 'Nota Windows Notandanafn innskráningu' er valið notandanafn staðfesting er flutt gegn Windows Notandanafn Innskráningar á tölvunni hvers notanda gegn notandanafn er inn eins og á hér að neðan. Það er ef Windows Notandanafn Innskráning á vél tilteknu notanda til sem gilt notandanafn þá er ekki nauðsynlegt að lykilorð og notandinn er sjálfkrafa staðfesta. Ath: Þessi raun gerir notkun Windows Active Directory (AD) staðfesting.

Note

Í ljósi þess að heimildir eru aðeins skilgreint þegar þeir þurfa að taka í burtu (takmarkaður) frá notanda, hvaða notandi sem er ekki aðili að samstæðu eða einhver hópur sem hefur ekki heimildir skilgreind fyrir það gegn öllum hlutum, mun hafa fullan aðgang að verkefnið.

Notendur og User Groups

Til að búa til nýjan notanda

1. Veldu File| Stjórna notendum / hópa

Note

Ef þú sérð ekki Stjórna notendum / Groups valmyndinni þá þú þarft ekki Stjórnandi getu. Vinsamlegast hafðu samband við Abacus Administrator eða Avolution Stuðningur ef þú þarfnast þessa getu.

2. Í glugganum sem birtist velja Bæta notandahnappinn og slá inn notandanafn og lykilorð í búa til nýjan notanda valmynd nafn. Ath: Notendanafn og lykilorð eru há og lágstöfum.

Note

Ef valkostur 'Nota Windows Notandanafn innskráningu' er valið eins og lýst er hér að ofan þá gína lykilorð er hægt að færa sem staðfesting verður flutt í samræmi við Notandanafn innskráningu glugga notanda er eingöngu.

2. Sjálfgefið þú munt sjá að Notendur geta breytt eigin aðgangsorði sínu. Ef þörf krefur ABACUS Administrator má fjarlægjaað getu fyrir notendur til að setja eigin aðgangsorði sínu með óhindraðurthe stöðva hnefaleikar.

Note

Ef notendur geta breytt eigin aðgangsorði sínu munu þeir hafa Skrá | Breyta lykilorði...valmyndinni til að gera það.Einnig að vera meðvitaður um að ef margar fólk nota sama notendanafn þá einn notandi getur breytt lykilorðinu þannig að engin önnur fólk getur skráð þig inn á eftir. Samkvæmt því, það er mælt með því venja að hafa einn notandanafn á alvöru manneskju.

4. Mögulega, slá inn netfangið, Staðsetning og Símanúmer fyrir notendur til hliðsjónar í framtíðinni.

5. Smelltu á OKhnappinn í búa til nýjan notanda valmynd.

6. Smelltu á OKhnappinn.

Note

Þegar þú hefur búið fyrsta notandi sem þú ættir að íhuga að hindra aðgang óskráðir notendur við óhindraður á 'Leyfa nafnlaus notandi fullan aðgang að skrá' valkostur í Stjórna notendum / Groups valmyndinni.Einnig, þegar notandi hefur verið búinn til (og ef Enterprise verkefni, breyting skuldbundið sig til the framreiðslumaður), næst þegar verkefnið er opnuð notendur verður beðinn um að Innskráning á Auðkenndur aðgangeins og á glugganum hér fyrir neðan. Ef Tenging sjálfkrafa með þessar upplýsingarer valið þá notandanafn / lykilorð samsetning verður minnst fyrir verkefnið og beitt í hvert sinn á opnun. Til að hreinsa vistað innskráningu velja Skrá | Hreinsa Vistað Innskráningeftir opnun og þú verður beðinn um að skrá þig inn aftur næst þegar þú opnar verkefnið.

Skrá inn

Til að eyða núverandi notanda

1. Veldu File| Stjórna notendum / hópa

2. Í glugganum sem birtist skaltu velja notandann í Users spjaldið sem þú vilt eyða og veldu síðan nafnið Eyða notandahnappinn.

3. Smelltu á OKhnappinn.

Til að búa til nýjan hóp

1. Veldu File| Stjórna notendum / hópa

2. Í glugganum sem birtist velja Bæta Grouphnappinn og slá inn heiti Group í hópunum spjaldið.

Note

Nöfn hópur verður að vera einstakt.

3. Smelltu á OKhnappinn.

Til AfritaGroup

1. Veldu File| Stjórna notendum / hópa

2. Í glugganum sem birtist velja AfritaGrouphnappinn.

Note

A afrit hópur verður búin með forskeytinu "Afrit af".Sjálfgefið allar heimildir frá afriti hópnum verður tvöfalt fyrir "Afrit af" hópnum þ.mt notandi verkefni.

3. Endurnefna "eftirlíking af" hópnum sem við á með Edit Groupeða hægur tvöfaldur-smellur.

Til að eyða hóp sem

1. Veldu File| Stjórna notendum / hópa

2. Í glugganum sem birtist skaltu velja nafnið Group í hópunum spjaldið sem þú vilt eyða og veldu síðan Eyða hóphnappinn.

Note

Allar User verkefni til samstæðunnar verður einnig fjarlægt.

3. Smelltu á OKhnappinn.

Til að tengja notanda þátttöku í hópi

1. Veldu File| Stjórna notendum / hópa

2. Í glugganum sem birtist skaltu velja notandann í Users spjaldið sem þú vilt tengja við hóp nafn og draga og sleppaþað á nafni Group í hópunum spjaldið sem þú vilt að framselja það til.

3. Smelltu á OKhnappinn.

Note

Hópurinn (s) sem notandi er úthlutað til sýndir með því að auka á Í Users spjaldið notandanafnog notendur sem eru tengd við hóp eru sýndar með því að bæta Heiti hóps í hópunum spjaldið. Til dæmis, í ofangreindum screenshot, "AS1-Aus" notandi er úthlutað til þriggja (3) hópa, nefnilega; "App Support Team 1", "Raunveruleg" og "Ástralía".

Til myndefni til notanda úr Group

1. Veldu File| Stjórna notendum / hópa

2. Í glugganum sem birtist auka Group nafn sem inniheldur User verkefni sem þú vilt myndefni og velja notandanafn.

3. Smelltu á Ógiltu Userhnappinn.

4. Smelltu á OKhnappinn.

Til að flytja notendur og / eða Hópar (og allir samsvörun Heimildir)

1. Veldu File| Stjórna notendum / hópa

2. Smelltu á Innflutningurhnappinn.

3. Í glugganum sem birtist Flokkatil og opna Abacus verkefni sem inniheldur notendur og / eða Groups (og heimildir) sem þú vilt flytja inn í núverandi verkefni og smelltu Open. Notendum og hópum verður flutt og Import Niðurstöður valmynd birtist teknar innflutning á notendur og / eða hópa. Smelltu á OKhnappinn.

Note

Ef innflutt Notendur eða Hópar þegar verið í núverandi verkefni þá verður sameinuð núverandi Notendur eða Hópar.

4. Smelltu á OKhnappinn aftur í helstu stjórna notendum / Groups valmynd.

5. Ef það eru einhverjar samsvörunargerðum Sjónarmið, sniðmát eða arkitektúr milli núverandi verkefni og abacus verkefni sem þú ert að flytja inn frá, heill með leyfi sem ekki þegar eru fyrir hendi í núverandi verkefni, eru heimildir fluttar og annað Innflutningur Niðurstöður valmynd birtist teknar innflutning. Smelltu á OKhnappinn.

Note

Heimildir eru aðeins bætt við núverandi ferðalaga (og eiginleika þeirra), sjónarmið, sniðmát eða arkitektúr fyrir hópa þar sem heimildir hefur ekki nú þegar fyrir hendi fyrir félagið. Annaðhvort vegna þess Group er nýr eða samstæðan þegar verið í núverandi verkefni en engar heimildir hafði verið úthlutað fyrir þann hóp til þess liðar. Það er ekkert "samruna" á heimildir fyrir klárunum þar heimildir voru til fyrir samstæðuna í núverandi verkefni.

Setja heimildir

Heimildir er hægt að stilla fyrir arkitektúr, hluti og tengingu gerðum, eiginleika (með gerðir þeirra), sniðmát, sjónarmið og skýringarmyndir, bæklingum, fylkjum, töflur semD 3Dútsýni. Þegar heimildir eru sett fyrir íhluta eða tegund tengingar öllum tilvikum af því tagi í hvaða arkitektúr í því verkefni "erfa" þá heimildir. Sömuleiðis, þegar leyfi er sett fyrir eign íhluta eða tegund tengingar, ákveðins eign á þessum aðskildu eða tengingu tilvikum í hvaða arkitektúr í því verkefni "erfa" þá heimildir. Samkvæmt því, ákveðnar heimildir verður beitt á skoðanir sem þessir þættir eru fyrir hendi. Þegar heimildir eru sett fyrir skýringarmynd, útsýnið og / eða innihald augum sjálfs hafa ýmsir heimildir beitt til þess.

Heimildir Management

Til að stilla leyfi fyrir hluti (eða Connection) Gerð

1. Stækkaðu Tegundirútibú tré.

2. Stækkaðu Component (eða tengingar) Tegundirútibú tré.

3. Stækka Hóparef nauðsyn krefur.

4. Hægrismella á Component (eða Connection) Tegundþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

5. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

6. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

Note

Búa leyfi ræðr þegar þú getur afritað stak. Samkvæmt því, að hægt sé að afrita stak þarf Búa leyfi fyrir öll börn hennar (þar að afrita þáttur þýðir að afrita allt fyrir neðan það). Fjarlægi Update leyfi frá þáttur fjarlægir getu til að breyta tegund sjálft, jafnvel þó að notandinn hefur Hönnuður bæta við-á og það einnig fjarlægir Uppfæra leyfi fyrir alla eiginleika þess. Foreldri þáttur verður að hafa Update leyfi til að vera fær um að Búa til allar börn þætti eða Eyða Its núverandi börn þættir. Eyða leyfi fyrir stak einnig þarf að eyða leyfi fyrir öll börn hennar. Eyða leyfi fyrir hluti einnig þurfa Uppfæra leyfi öllum meðfylgjandi tengingar.Og að lokum, fjarlægja Eyða leyfi frá þáttur fjarlægir getu til að eyða tegund sjálft, jafnvel þó að notandinn hefur Hönnuður bæta við-á.

7. Smelltu á OKhnappinn.

Til að stilla leyfi fyrir hóp af þætti (eða Connection) Tegundir

1. Stækkaðu Tegundirútibú tré.

2. Stækkaðu Component (eða tengingar) Tegundirútibú tré.

3. Hægrismella á Groupsem inniheldur að Component (eða Connection) Tegundir sem þú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

6. Smelltu á OKhnappinn.

7. Í glugganum sem birtist smella á Jáhnappinn.

Til að stilla leyfi fyrir eign

1. Stækkaðu Tegundirútibú tré.

2. Stækkaðu Component (eða tengingar) Tegundirútibú tré.

3. Stækka Hóparef nauðsyn krefur.

4. Veldu Component (eða Connection) Sláðu sem inniheldur eign sem þú vilt að stilla heimildir.

5. Í Properties glugganum hægrismella á Propertyþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

6. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

7. Sjálfgefið þú munt sjá að lesa og Uppfæra heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

Note

Eiginleika sem hafa haft Uppfæra leyfi fjarlægt eru sýndar í skáletruní Properties glugganumog gildi þeirra er ekki hægt að uppfæra með þessu hlutverki. Einnig, getu til að breyta upplýsingum um eign (td nafn, einingar osfrv) þarf bæði Uppfæra leyfi á hótelinu og hönnuður bæta við-á.

8. Smelltu á OKhnappinn.

Til að stilla leyfi fyrir sniðmáti

1. Stækkaðu Sniðmátútibú tré.

2. Flokka við Sniðmátsem þú hefur áhuga á.

3. Hægrismella á Sniðmátþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að Lesa heimild er í boði. Taktu leyfi frá óhindraðurkassann.

6. Smelltu á OKhnappinn.

Til að stilla heimild til Sjónarmið

1. Stækkaðu Sjónarmiðútibú tré.

2. Stækka Hóparef nauðsyn krefur.

3. Hægrismella á Sjónarmiðþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

6. Smelltu á OKhnappinn.

Til að stilla leyfi fyrir Architecture

1. Stækkaðu Arkitektúrútibú tré.

2. Auka við Arkitektúrsem þú hefur áhuga á.

3. Hægrismella á Arkitektúrþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að Lesa heimild er í boði. Taktu leyfi frá óhindraðurkassann.

6. Smelltu á OKhnappinn.

Til að stilla heimildir fyrir a Vörulisti

1. Stækkaðu Vörulistarútibú arkitektúr þú hefur áhuga á.

2. Stækka Hóparef nauðsyn krefur.

3. Hægrismella á Vörulistiþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

6. Smelltu á OKhnappinn.

Til að stilla heimildir fyrir a Matrix

1. Stækkaðu Fylkiútibú arkitektúr þú hefur áhuga á.

2. Stækka Hóparef nauðsyn krefur.

3. Hægrismella á Matrixþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

6. Smelltu á OKhnappinn.

Til að stilla heimild til skýringarmynd

1. Stækkaðu Skýringarmyndirútibú arkitektúr þú hefur áhuga á.

2. Stækka Hóparef nauðsyn krefur.

3. Hægrismella á Skýringarmyndþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

Note

Þó að þú getur stillt crud heimildir beint fyrir myndinni, ætti það að vera tekið fram að heimildir af þeim þáttum á myndinni getur haft áhrif á heimildir fyrir augum sjálfs. Til dæmis, ef það er jafnvel bara einn þáttur á þeirri skoðun sem hefur haft lesið eða Uppfæra leyfi sitt fjarlægt þá skýringarmynd verður Update leyfi hennar fjarlægt. Þetta er vegna þess að; a) þætti á þeirri skoðun að hafa haft Lesa leyfi þeirra fjarlægt verður ekki sýnt á mati fara 'hvítt rúm' þar sem þú gætir annars setja nokkrar nýja þætti ef útsýnið var updateable og b) þætti á þeirri skoðun að hefur haft Update leyfi þeirra fjarlægt gæti þá hafa aðra þætti lækkað á þeim til að verða börn ef útsýnið var updateable. Einnig, búa til og uppfæra leyfi fyrir myndinni krefst þess að allir þættir á mati hafa Lesa leyfi og þættir hafa Uppfæra leyfi (þetta er vegna þess að að færa hluti á annan efnisþátt, verður þú að vera fær um að uppfæra hana þar sem hún mun verða barn).

6. Smelltu á OKhnappinn.

Til að stilla leyfi fyrir 3D View

1. Stækkaðu 3D Viewsútibú arkitektúr þú hefur áhuga á.

2. Stækka Hóparef nauðsyn krefur.

3. Hægrismella á 3D Viewþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

6. Smelltu á OKhnappinn.

Til að stilla heimildir fyrir a Mynd

1. Stækkaðu Chartsútibú arkitektúr þú hefur áhuga á.

2. Stækka Hóparef nauðsyn krefur.

3. Hægrismella á Myndþú vilt að setja heimildir fyrir og veldu Breyta Heimildir.

4. Í glugganum sem birtist smella á Bæta við ...hnappinn og veldu Groupþú vilt bæta með því að annaðhvort því að tvísmella það eða velja það og smella á OKhnappinn.

5. Sjálfgefið þú munt sjá að búa til, lesa, uppfæra og eyða heimildir eru aðgengilegar. Fjarlægja heimildir af óhindraðurviðeigandi kassa stöðva.

6. Smelltu á OKhnappinn.

Sjá einnig

Hvernig er arkitektúr fulltrúa í Abacus?


Ritun Scripts

Navigation: Líkja vélina þína>

Ritun Scripts

Senda athugasemdir um þetta efni.

The Script Editor er einfalt og hagnýtur gagnsemi til að skrifa og framkvæma VB eða C # handrit gegn nú opnað ABACUS skrá(Libraries eru ekki studd í forskriftarþarfir). Það hefur venjulega File Open, Loka og Save skipanir, svo þú getur sparað og sótt forrit sem þú skrifar. Það hefur einnig undirstöðu hlaupa og kemba leikni. The Script Manager leyfir þér að auðveldlega framkvæma ýmis forrit sem þú hefur skrifað með því að setja matseðill-atriði fyrir þá beint í valmyndinni.

Til að opna Script Editor

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Veldu Verkfæri | Script Editorog Script Editor gluggi opnast. Þá annað hvort;

3. Opna fyrirliggjandi handrit í gegnum File | Open í Script Editor valmyndir,

eða

3. Opna dæmi handrit í gegnum Dæmi atriði í Script Editor valmyndir,

eða

3. Setja sjálfgefið tungumál annaðhvort VB eða C # í gegnum Tungumál atriði í Script Editor valmyndir,

eða

3. Open forskriftarþarfir sérstakur Hjálp gegnum Hjálp atriði í Script Editor valmyndir

Þegar þú skrifar handritin, verður þú að fylgja annaðhvort VB eða C # setningafræðieins og á að setja undir Tungumál liða í Script Editor valmyndir.

ATH:

· Að nota stöðluðu VB virka eins MsgBox ()Þú verður að láta Innflutningur Microsoft.VisualBasicyfirlýsing í upphafi handritið. Þetta var ekki nauðsynlegt fyrir útgáfu 3.0 af Abacus.

· Þessi hjálp er ekki að geyma upplýsingar um hvernig á að skrifa VB handrit, né er það að innihalda VB tilvísun. Feel frjáls til að skrifa handritin í uppáhalds IDE eða ritstjóri, þá afrita og líma þær í Script Editor.

Þegar þú byrjar fyrst Script Editor er Script Editor verður tómur. Þú getur fengið aðgang að beinagrind handrit í gegnum dæmin valmyndinni. Í fyrsta skipti sem þú byrjar Script Editor þína, ættir þú að keyra Snið beinagrind að sjá að það virkar. Í samlagning, there ert tveir dæmi forskriftir sem hægt er að nálgast í gegnum dæmin valmyndinni.

Til að skrifa gagnlegar handrit þú þarft að vísa abacus ObjectModel. Hann er fáanlegur í handritið með því að Innflutningur ABACUS.ObjectModelyfirlýsing í höfuðið á handritið. A heill tilvísun öllu Abacus mótmæla líkan fylgir með Script Editor. Þú getur fundið það með því að velja Hjálp | Efnisyfirlitfrá Script Editor glugga.

Handritið ritstjóri inniheldur ýmsa gagnlega eiginleika til að skrifa handrit, þar á meðal AutoComplete eins og sést á the screenshot niðri. Hins vegar fyrir enn ríkari upplifun notenda MS Visual Studio er hægt að samþætta við Abacus og nákvæmar leiðbeiningar eru í boði hér .

Script Editor með AutoComplete

Til að nota Script Manager

1. Tryggja þú hafa abacus skráInniheldur þínum byggð arkitektúr, opinn.

2. Veldu Tools | Script Manager.

3. Smelltu á Bætaicon og Opengluggi.

4. Fletta að Abacus Script (.abacusscript, .vb Eða .cs) Skrá sem þú vilt bæta við valmyndina Tools.

5. Smelltu OKog tilvísun í handritið verður sýnd í Script Manager glugganum. Sláðu inn heiti fyrir handrit eins og þú vilt að það birtist í Tools valmyndina. Ath: The Script Manager glugga er hægt að búa til að sjá fulla slóð ef þörf krefur.

6. Endurtaktu skref 3-5til að búa til tengla á fleiri Abacus forskriftir.

7. Smelltu Lokaað loka Script Manager og athugaðu að ABACUS handrit (s) birtast nú undir valmyndina Tools.

Var að keyra skriftuna

Annaðhvort;

1. Open, tegund í eða afrita og líma inn í handritinu sem þú vilt keyra, svo það birtist í the aðalæð gluggi af Script Editor.

2. Smelltu á Runhnappinn.

3. Ef handritið inniheldur villur, Villa Lýsing kafla neðst á Skrifturitill verður listi upplýsingar þ.mt lína númer. ATH: Hver einstaklingur villa í Villa Lýsing hluta getur verið tvöfaldur-smellur til að taka þig á samsvarandi línu í handriti.

- Eða -

1. Veldu Verkfæriog þá ABACUS Script nafn valmyndinni sem búin með Script Manager.

2. Ef handritið inniheldur villur, Script Editor verður opnuð með innihaldi handriti sýnd í aðalglugganum (hápunktur á the lína af fyrsta villa) og lýsing á villunni kafla neðst á Skrifturitill set upplýsingar eða villa (s) þ.mt lína númer. ATH: Hver einstaklingur villa í Villa Lýsing hluta getur verið tvöfaldur-smellur til að taka þig á samsvarandi línu í handriti.

Scripting Uppsöfnunarvillur

Uppsöfnunarvillur eiga sér stað þegar setningafræði handriti kóða er ekki rétt. Þessar villur mun mæta neðst í glugganum í Villa lið, með lýsingu á villunni, og línu númer. Það er lína númer sem aðgreinir samantekt villa frá a afturkreistingur villa (sjá hér að neðan), sem mun ekki hafa línu númer. Uppsöfnunarvillur má tvöfaldur smellur til að hoppa til og varpa ljósi á ákveðna línu sem um ræðir.

Scripting Runtime Villa (Mikilvægt)

Runtime villur eiga sér stað eftir að handrit kóða hefur verið unnin án þess að villur, en villa kemur á afturkreistingur (sjá dæmi um frekar). Runtime villur eru mikilvæg eins og þeir geta leitt skemmd gerðum, þegar hlutir búin og vísað af öðrum hlutum í líkaninu, eru ekki sjálfir hluti af líkaninu (yfirleitt vegna þess að afturkreistingur villa hefur átt sér stað áður kóða sem hefði sett þá í líkaninu einhvers staðar, var tekinn af lífi).

Ef handritið skapar hluti til að bæta við líkanið, getur þú forðast spillingu af völdum afturkreistingur villa með því að vista handritið, loka forskriftarþarfir, og framkvæma að afturkalla á þeim breytingum sem voru búin til af handriti (ef handritið framkvæmd ekki ljúka að jafnaði ). Hins vegar eru einnig aðrar leiðir til að koma í veg fyrir hvers spillingu sér stað (sjá hér að neðan). Note: Hvaða forskriftir sem eingöngu lesa úr líkaninu og ekki skrifað það, er öruggur og mun ekki valda neinum vandræðum, án tillits til þess hvort afturkreistingur villur koma á framkvæmd þeirra.

Til að forðast spillingu, þegar skrifa handrit kóða sem er að skapa hluti og bæta þeim við mótmæla líkan, það er leiðbeinandi þessi hlutir eru bætt í líkanið eins fljótt og auðið er ef þeir eru vísað af öðrum hlutum.

Til dæmis, ef þú ert að búa til nýja tengingu og 2 nýja hluti, og þá festa þær saman, það er best að búa til fyrsta hluta, bæta því við fyrirmynd, þá seinni og bæta við það, og síðan að búa til tengingu og bæta við það, og þá loks búa viðhengi. Þetta þýðir að ef það átti að vera afturkreistingur villa sem truflar handrit framkvæmd, allir hlutir sem þarf að vera í objectmodel áður viðhengi er búin, eru í líkaninu. Spilling getur komið fram ef, til dæmis aðeins tengingin hefði verið bætt við, viðhengi gert, og þá a afturkreistingur villa átti sér stað fyrir handritið bætt að lokum nýja hluti til model.Corruption geta komið fram hvenær sem hlutur sem er vísað af öðrum hlut í sem objectmodel, er sig ekki í objectmodel.

Dæmi afturkreistingur villur eru:

· Object tilvísun ekki sett til dæmi af hlut - þetta gerist þegar hlut breyta er null tilvísun, og aðferð eða eign á hlutnum er notað. Null tilvísanir getur verið merkt með 'Ef objectVariable Is Nothing Þá ... "

· Index var utan marka fylkisins - þetta gerist þegar array er að nota með vísitölu sem er utan við mörk - td minna en 0 eða jafnt og eða meiri en lengd / Count fylkisins. Array eða Collection lengd geta vera köflóttur af .Length eða .Count eignir hins vegar.

· Engin heimild Undantekning - Þú hefur ekki leyfi til ... - þetta gerist ef þú hefur ekki leyfi til að gera viðkomandi breytingu

· Primary Key Undantekning - Duplicate / vantar Nafn / ID - þetta gerist ef breyting er gerð að einstöku eiginleiki sem stangast á við annað mótmæla. T.d. Arkitektúr verður að vera einstakt að nafni, sömuleiðis með Standards.

· Vísun Heiðarleiki Undantekning - Setja tilvísun reit til hlut sem er ekki gild. T.d. er 'ekkert' eða null sem barn að mörgum söfnum í objectmodel.

· Zero Length Undantekning - þetta getur komið ef þú reynir að setja nafn á hlut til tómur strengur. Flestir hlutir að nöfn þeirra hafa að minnsta kosti 1 staf.

Innflutningur yfirlýsingar

Athugið að í upphafi beinagrindinni forskriftir eru yfirlýsingar á borð við Innflutningur ABACUS.ObjectModel. Þessar yfirlýsingar mun ekki fela í sér DLL þessi er ekki þegar vísað af handriti - tilgangur þeirra er að veita "smákaka" að þurfa að tilgreina allt heiti á bekknum.

Til dæmis, að lýsa yfir breytu af tegund CComponent (sem jafngildir hluti í abacus), með Innflutningur ABACUS.ObjectModelYfirlýsing átt að efst á handriti, myndi aðeins þurfa það að vera skilgreind sem lítil samningur sem CComponent, Vegna þess að þýðandinn veit að líta í ABACUS.ObjectModel Nafnrými fyrir CComponent bekknum. Án innflutningi yfirlýsingu, það þyrfti að vera lýst sem dim Comp ABACUS.ObjectModel.CComponent. Samkoma (td mscorlib.dll eða System.Windows.Forms.dll) geta innihaldið fleiri en einn nafnrými - innflutningur staðhæfing er fyrir þessum nafnrýmum, ekki fyrir söfnuðunum sjálfum. The ABACUS.ObjectModel.dll samkoma hefur aðeins einn ABACUS.ObjectModel Nafnrými er aðgengileg Scripting.

Sjálfkrafa vísað þingum

Eftirfarandi DLLs eru vísað sjálfkrafa af Scripting:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (óbeint vísað af þýðanda)

· ABACUS.ObjectModel.dll

Að gera frekari tilvísanir í annaðhvort öðrum NET þingum, eða eigin þingum þínum, sjá eftirfarandi hluta: Lýsingu á #ImportDLL yfirlýsingu.

#ImportDLL Statement

Byrjar í abacus 3.1, getur þú vísað fleiri þingum sem þú getur þurft að forskriftarþarfir með notkun á #ImportDLL yfirlýsingu. Til dæmis, ef þú vildir að fá aðgang að sérsniðnum DLL af þinn og nýta virkni í það, myndir þú setja hana í Abacus skrá og fela í yfirlýsingu sem fyrstu línu (s) í handritið. Ef það er NET DLL, þá yfirleitt þú þarft ekki að slá allt slóð, bara DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Sumir aðrir hlutir að hafa í huga:

1. Vegna þess að DLLs þarf að finna á saman og afturkreistingur, þetta takmarkar sérsniðin (ekki NET) DLLs eru sett í Abacus forritið aðeins möppu.

2. #ImportDLL yfirlýsingar verða vera the fyrstur lína (s) á handriti - ef þú ert með 5 yfirlýsingar, þá ættu þeir að vera á fyrstu 5 línur af handriti

3. An #ImportDLL yfirlýsingu sett hvar en fyrstu línur af handriti (td ef það var sett eftir athugasemd eða Innflutningur yfirlýsingu) mun ekki virka rétt og / eða geta valdið óskyld þýðanda villur.

#ImportDLL með Office þing

Ef þú hefur Microsoft Office uppsett, og handritið krefst Office Interop þingum, það er hægt að vísa þeim einfaldlega með því að nota #ImportDLL með nafni samkoma (sem talin eru upp hér að neðan, t.d. #ImportDLL Excel). Using this aðferð hefur þann kost að alger DLL leið þarf ekki að nota, þannig að handritið er flytjanlegur (ætti að vinna á bæði Office 2003 og 2007 án þess að breyta handriti).

Þegar þú notar þennan möguleika, GAC (Global þing Cache) er leitað fyrir interop samkoma, og handritið safnar með leið til þess safnaðar ef stofna. Ef það er ekki að finna, forskriftarþarfir mun athuga Abacus program skrá (sem inniheldur Excel og Sjón interops aðeins). Ef óskað interop er ekki af þessum tíma, viðvörun birtist.

The interops eru yfirleitt ekki sett í GAC ef þú hefur sett Microsoft Office fyrir uppsetningu NET Framework (sem er hluti af fullum Abacus uppsetningu). Þú getur sett upp þá með því að framkvæma á Breyta möguleika fyrir Microsoft Office frá Add / Remove Programs og velja NET programmability valkosti. Fyrir frekari upplýsingar, sjá þetta grein á MSDN.

Þingum sem þessi flýtileið er studd eru:

· Aðgangur

· Access.Dao

· Excel

· Línurit

· MSProject

· Outlook

· OutlookViewCtl

· Owc11

· PowerPoint

· Útgefandi

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Bæta

It er ekki alveg ljóst hvort öll ofangreind þingum eru gagnlegar, herbergi havebeen í þessari lögun regardeless eins og sumir notendur feb hafa þörf fyrir jafnvel hylja þingum.

Sjá einnig

Líkja vélina þína