ABACUSは何をするのでしょうか？

ナビゲーション：ABACUSの紹介>

ABACUSは何をするのでしょうか？

コメントを送信 このトピックに関する。

他の言語/翻訳でヘルプを表示するにはクリックしてください。 ここに .

ABACUSは、溶液、システム、ソフトウェア、情報、技術、ビジネスプロセスおよび/または全体の企業（総称してアーキテクチャと呼ばれる）を扱うのうち当て推量を取ります。それはあなたが実用的、設計、監視、シミュレーション、分析、およびあなたを視覚化するのを助けることができます アーキテクチャ 、それをモデル化（例えばグラフ、図、3D）直感的な方法でそれを分析してから、非機能要件に対してそれを評価することもできます。

注意

非機能要件製品がどのように動作するかに直接関係しないこれらの要件があります。その代わりに、彼らはそれがどのように動作するかWELLと懸念しています。 （このボタンがクリックされたときに、この光をオンにする、などの機能要件とは対照的に）非機能要件など、パフォーマンス、開放性、発展性、品質、拡張性、モジュール性、などが含まれます。不可能ではない - - 測定することが伝統的に、非機能要件が困難でした。実際には、ABACUSは、客観的かつ定量的に最初の三つを測定することができる唯一の​​製品です - パフォーマンス, 開放性、 そして 発展性.

簡単に言えば、あなたはアーキテクチャとあなたがそれを行うために必要と入力します。 ABACUSは、その後、必要に応じて、それがどうなるかどうかを通知し、任意の弱点やギャップを指摘しています。

ABACUSは、システムの研究と確立されたシステム理論のより多くの年の20年間に描画します。それはあなたの定量化、信頼性の高い、目的の回答を与えるので、あなたは、主観的な評価に頼っていません。

ABACUSの略 Architecture-BASED Analysis, Communicationと Understanding の Systems。これは、任意の大規模なアーキテクチャのお手伝いをすることができますが、それは一般に、4つの（4）のものを使用しています：

· 進化します現在のアーキテクチャ。既存のアーキテクチャが性能を欠いている場合たとえば、ABACUSはあなたを教え、その後、問題（ボトルネックなど）を識別し、あなたのためのアーキテクチャを視覚化します 正確にアーキテクチャを改善する方法について説明します。

· 設計の新しいアーキテクチャ。あなたはまったく新しいアーキテクチャを必要とし、あなたがそれを自分で設計している場合たとえば、ABACUSはあなたを教えてくれます 正確にどのコンポーネントあなたが必要とどのように接続する必要があります。

· 購入新しいアーキテクチャ。たとえば、新しいアーキテクチャの設計上の入札を求めている、とあなたは3の間のデザインを選択している場合、ABACUSはあなたを教えてくれます 正確にこれは1最高の要件に適しています。

· 組み合わせ現在、既存のアーキテクチャ。たとえば、2つ以上の別々のアーキテクチャを結合する必要がある場合は、ABACUSがご案内します。

参照してください

どのようにあなたがそれを行う（概要） | アーキテクチャとは何ですか？ | どのようなアーキテクチャは、ABACUSに表されていますか？

©2001-2015 Avolution Pty Ltdのすべての権利を保有。


ABACUS（概要）を使用する方法

ナビゲーション：ABACUSの紹介>

ABACUS（概要）を使用する方法

コメントを送信 このトピックに関する。

このトピックでは、ABACUSの使用に関連するタスクの基本的な概要を説明します。

次の図は、ABACUS新規またはターゲットアーキテクチャに現在のアーキテクチャを進化させるために提供するアーキテクチャベースの分析プロセスを示します。

ABACUSプロセス

ABACUSを使用するには：

1。 監査 - あなたがABACUSを使用する前に、すべてのアーキテクチャについてあなたが持っている情報、およびその要件を収集する必要があります。

· アーキテクチャ - アーキテクチャの潜在的なコンポーネントを特定し、それらがどのように相互作用しますか。トップレベルだけでいくつかのコンポーネントが必要です。これらは、「必須コンポーネント」と呼ばれています。最も複雑なアーキテクチャは、10未満の必須成分を持っている必要があります。例えば保険会社のアーキテクチャの必須成分は、ポリシー、領収書、特許請求の範囲、および支払いすることができます。

· 要件 - あなたはそれが十分であるかどうかを判断するためにアーキテクチャを期待されているものを知っている必要があります。例えば時間当たりのトランザクションの数。

· どこでそれを見つけるのですか？ - この情報は、基本的に利用可能な任意の材料は、アーキテクチャに関するABACUS情報を提供しています要求仕様、設計ドキュメント、利害関係者へのインタビュー、展開コードなどから来るかもしれません。

2。 移入 - あなたのアーキテクチャをモデル化するために、建築はに対して測定される要件を指定するには、ABACUSを使用してください。

· アーキテクチャ - ABACUSでは、空のアーキテクチャから始める - あなたが持っています 投入しますそれ。これは、上記収集されたすべてのアーキテクチャ情報を入力することを意味します。あなたは（右クリックメニューを使用して）手動でアーキテクチャを移入することもできますし、（Microsoft Visioの、エクセル、アクセスなどから）自動的に取り込むことができます。一般的なアーキテクチャの最上位レベル（より抽象的な）は手動で投入され、低いレベル（より具体的な）が自動的に表示されます。

· 要件 - あなたのコンポーネントとの接続を追加すると、あなたはそれらのプロパティを指定します。ほとんどの場合、これらの特性は、アーキテクチャの要求です。あなたは1250 MIPSノード/クラスタを持つことになります場合たとえば、あなたは、コンポーネントとしてノードを追加し、パフォーマンスのプロパティを追加し、1250 MIPSの値を割り当てます。

3。 分析します - エレガントに分析し、あなたのアーキテクチャの複雑な構造を可視化するABACUSを使用してください。 君が いくつかの方法で、または図、3Dおよびエクスプローラなどの視点数から、あなたのアーキテクチャを分析することができます。別の方法としては、次のようにいくつかのより具体的なビューを使用したい場合があります。

· お使いのアーキテクチャ図表 - 性能（応答時間、帯域幅、など）、コスト（バー、円グラフなど）や発展性（能力スペース、トレードオフ、など）のビューを取得します。

· お使いのアーキテクチャ上でレポートを作成します。

4。 シミュレート - など、あなたのアーキテクチャのパフォーマンス、可用性、コスト、オープン性をシミュレートするためにABACUSを使用して、

· これを行うには、シミュレータのいずれかを実行します。 ABACUSはあなたを評価 あなたの要件に対するアーキテクチャシミュレーションを行うこともできます。これは、読み込み、現在のアーキテクチャを分析し、シミュレーションを実行し、いくつかの新しいプロパティを計算します。これらのプロパティは、当時のアーキテクチャに保存されます。新しいプロパティを使用すると、TCO等の利用、応答時間、帯域幅、％の可用性、として、分析しようとしているデータであり、

5。 エンジニア - 様々な「もしも」のシナリオに答え、あなたのアーキテクチャの進化を制御するために使用ABACUS。エンジニアリングは、繰り返しのプロセスであり、 移入 - 分析する - シミュレート サイクル。

· この時点で、あなた'VEのおそらく、現在のアーキテクチャの理解を開発し、あなたが進化する必要がある領域を強調しました。かなり頻繁に、しかし、あなたは移入を繰り返す必要があります - 分析する - プロセスを何回もシミュレートします。あなたがターゲットアーキテクチャを見つける前に、それは反復のカップルを取ることができるので、これはおそらくされます。あなたのアーキテクチャは非常に複雑である場合も、あなたはそれぞれの建築 "レベル"のためのプロセスを繰り返す必要がある場合があります。

6。 計画ABACUSによって提供された情報を使用して、あなたのアーキテクチャの未来。

注意

あなたが既存のアーキテクチャを進化しようとしていない場合は、いくつかのステップの回数、および異なる順序でを繰り返す必要があります。それはあなたがしようとしているものに依存します。あなたは新しいアーキテクチャを設計している場合たとえば、あなたはおそらく一度だけあなたのアーキテクチャを移入します、その後、アーキテクチャの将来の発展（複数可）を案内するために長期間にわたってABACUSを使用しています。あなたは新しいアーキテクチャを購入してから選択するいくつかの選択肢を持っている一方、あなたは選択肢のそれぞれに発見し、移入する必要がありますし、その後の最終比較を実行する前に、独立してそれぞれを分析し、シミュレート終わり。

参照してください。

ABACUSは何をするのでしょうか？ | アーキテクチャとは何ですか？ | どのようなアーキテクチャは、ABACUSに表されていますか？ | あなたのアーキテクチャへの移入 | あなたのアーキテクチャを分析します | あなたのアーキテクチャをシミュレートします


アーキテクチャとは何ですか？

ナビゲーション：ABACUSの紹介>

アーキテクチャとは何ですか？

コメントを送信 このトピックに関する。

アーキテクチャは抽象的です 概念 - 物理的ではありません 事。コンポーネントを取り込み、それらが接続しているか（対話） - これは、システムの構造の豊富で包括的な説明や理解です。アーキテクチャの概念は非常にすべての包括的なであるため、システムのコスト、利用可能性、発展性、開放性、およびパフォーマンスの基本です。サウンドアーキテクチャは、サウンドシステムの前提条件です。

ABACUSでは、あなたのアーキテクチャをモデル化します。簡単にするために、我々は、このアーキテクチャモデルアーキテクチャと呼びます。

以下の図は、典型的なアーキテクチャを示して 5コンポーネント （階層内） 2接続によって接続されています。ラベルはABACUSアーキテクチャのさまざまな部分を与えられた名前を示しています。

シンプルなアーキテクチャ

ABACUSは、これらの事のすべてはアーキテクチャの一部であるとみなします。

· コンポーネントあなたのアーキテクチャのエンティティを表します これはあなたが「もの」として記述することができます。保険会社の場合、コンポーネントは、処理方針、請求、支払い、および領収書のためのシステムであるかもしれません。

· 接続これらの構成要素間の関係を表します。たとえば、保険会社では、領収書が有効な政策のために生成される、請求項は、有効なポリシーに対して行われており、有効な請求は支払いになります。 ABACUSを使用する場合は特に - - アーキテクチャを考えたときに接続が構成要素と同様に重要であり、それらはほぼ同じ方法で対処しています。

· ツリー内のすべてが持つことができます プロパティ。プロパティは、あなたが実行するためにあなたのシステムを必要とする方法のようなものであり、それが持っているコードの行数は、コメントでこれらの行の割合は、等ABACUSは、これらすべてのものは、アーキテクチャの一部と考えています。

· 使用することにより 階層（すなわち、 サブコンポーネント そして サブ接続）、その情報を隠すことができ、あなたのアーキテクチャをデ構成しています。 ABACUSアーキテクチャモデルは非常に柔軟です。任意のレベルで任意のコンポーネントは、任意のレベルで任意の接続により、他のレベルでは、他のコンポーネントに関連することができます。

· アタッチメント成分による操作があります ポート 接続にバインドされています役割. ポート そして 役割 インタフェースですsコンポーネントと接続の間。それらコンポーネントへの接続を取り付けるために使用されます。接続は、ソースおよびシンクを持っています 役割（シンクコンポーネントにソースコンポーネントからのデータの流れを促進します）そして、概念的に、コンポーネントは、ポートを持っています。簡単にするために、しかし、ABACUSコンポーネントポートには示されていないと、接続の役割を直接部品自体に取り付けられています。

· コンポーネントとの接続は、特定のもの タイプ。これは、分類目的のために主にあります。たとえば、ポリシー、請求、支払い、および領収書はタイプ「システム」の構成要素です。有効なポリシーは、有効なクレームなどはタイプ 'トランザクション'が接続されています。コンポーネントまたは接続に割り当てられたタイプは、それが持っているプロパティと標準のテンプレートを提供しています。たとえば、サーバーのコンポーネントタイプは「メイク＆モデル」場合があります 標準そして、IPアドレスのプロパティ。あなたが自由に独自の新しいタイプを作成して、独自のプロパティの組み合わせと基準を割り当てることができABACUSで基本的なリレーショナル・データ・ベース（RDB）バックエンドと他の剛性ツールとは異なり。

· プロパティの標準ライブラリが指定されており、アーキテクチャの何か他のものに割り当てることができます。これらのライブラリは次のように知られています スタンダード。使用することにより スタンダード、あなただけの特定のシステムのプロパティを収集する必要がある - 標準プロパティが既にあります。例えば、マイクロソフトのWindows 2000の標準的な性能特性は、Microsoft Windows 2000オペレーティングシステムを使用しているどんなコンポーネントに割り当てることができます。

参照してください

どのようなアーキテクチャは、ABACUSに表されていますか？ | ABACUSは何をするのでしょうか？ | どのようにあなたがそれを行う（概要） | 新しいタイプの作成


ABACUSインタフェース

ナビゲーション：ABACUSの紹介>

ABACUSインタフェース

コメントを送信 このトピックに関する。

あなたがABACUSを起動すると、メニューとツールバー上部に、空のエクスプローラウィンドウとタイトルバーを除いて空である、メイン画面が表示されます。この画面には、ABACUSであなたの相互作用のハブになります。

主な要素は次のとおりです。

· メインメニュー

· ツールバー

· 右クリックメニュー

· エクスプローラとプロパティウィンドウ

· ステータスバー

メインメニュー

メニューは、論理的な順序で配置されています。

次のようにメニューが記載されています。

· [ファイル]メニュー - [ファイル]メニューはクローズ、オープン、あなたが作成することができ、保存、エクスポートおよびABACUSファイルを公開します。また、オープン、あなたが作成することができます近く、ABACUSライブラリファイルを保存します.

· [編集]メニュー - [編集]メニューを使用して、要素を、切り取り、コピー、貼り付け、削除、名前の変更、検索およびソートすることができますおよび/やり直し操作を元に戻します。

· [表示]メニュー - [表示]メニューでは、さまざまなインターフェース、Windowsとステータスバーを開いたり閉じたりすることができます、前後に移動し、特定のビューに移動し、ダッシュボードを管理します.

· [挿入]メニュー - [挿入]メニューを使用すると、新しい追加することができます スタンダード、テンプレート、型、要素、ビューポイントs、カタログ、図、 チャート、レポートや行列。

· Analysisメニュー - 分析メニューでは、などの建築に対する評価を実行することができます。性能、コスト、信頼性、モ​​ジュール性とオープン性.

· [ツール]メニュー - [ツール]メニューを使用すると、スクリプトを実行することができます, アーキテクチャの目標を設定「差分」を実行するとアーキテクチャ。また、プログラムのオプションを変更し、ツールメニューからインターフェイスをカスタマイズすることができます.

· [ウィンドウ]メニュー - [ウィンドウ]メニューでは、ドッキングすることができ、アレンジ、ショーと開いているウィンドウを非表示にします.

· [ヘルプ]メニュー - [ヘルプ]メニューから、このABACUSヘルプファイルにアクセスすることができます。あなたは、あなたを表示するには、Webサイトにアクセスすることができます ライセンス ソフトウェアのバージョンとABACUSサポートと連絡先の詳細など、ABACUSについての一般的な詳細を契約し、表示します。あなたは、問題の通知ページを経由してフィードバックを提供することができます。必要な場合は、[ヘルプ]メニューを経由して登録キーを入力することができます.

これは、あなたのタスクを実行しているときには、一般的に従うだろうためであります;あなたが作成または開いた後 ファイル、通常はその後、自分のアーキテクチャを移入します 見ますそれ（エクスプローラで、図、3D、チャート、など）。この時点では、どちらかを実行します エバリュエータ、または同じアーキテクチャや異なるアーキテクチャとプロセスを繰り返します。 （見る ABACUS（概要）を使用する方法 詳細については。）

メインメニューを見ていると、あなたのシステムに適用しますか想像してみてください。

注意

あなたはできる あなたのメニューをカスタマイズ いつでも。

ツールバー

デフォルトでは、次のツールバーがあります。

· メインツールバー -

· ザ・ シミュレーション ツールバー -

· 表示ツールバー -

· ザ・ ダイアグラムツールバー（ある場合 ダイアグラム ）オープンしています -

· マクロ レコーディング ツールバー -

ツールチップ（ショートカットキー）を参照するためにそれらの上にマウスを移動して、各ツールバーのボタンを通してご覧になれます。

注意

のみ特定のボタンを使用すると、エクスプローラのウィンドウで選択したとすることができますどのように応じてアクティブになります あなたのツールバーをカスタマイズ いつでも。さらに、メインツールバーのボタン「検証は/プロジェクトの制約チェック」をし、シミュレーションツールバーのボタンが強調表示されます 赤 根底にあるリポジトリへの変更は、プロジェクトまたはそれぞれそのシミュレータの再シミュレーションの再検証が必要な場合。影響を受けるのアーキテクチャを参照するには、ボタンの上にマウスを移動。

右クリックメニュー

メインメニューとツールバーは、 ではありませんしかし、すべてのために使用されます。これは、様々な操作のために右クリックしてコンテキストメニューを使用すると便利な場合があります。 （また、右クリックでは使用できないすべてのコマンドは、メインメニュー、ツールバー、またはキーボードコマンドを介して利用可能です。）

あなたがファイルを作成しました、あなたはあなたのアーキテクチャのツリー図を持っていたら、例えば、それは新しいアーキテクチャを追加するには、ツリー内のアーキテクチャ上で右クリックした方がよいです。同様に、新しいコンポーネントを追加するコンポーネントを右クリックする必要があります。あなたは何ができるかを確認するために、ツリー内のいくつかを右クリックします。

先端

一般的に、あなたはあなたのアーキテクチャを評価するように、より高レベルのタスクを実行するためにメインメニューを使用します。低レベルのタスク - 個々のコンポーネントとの接続を追加することなどを - ツールバーおよび/または右クリックメニューを使用して行われています。

エクスプローラとプロパティウィンドウ

あなたがファイルを開くか作成すると、ツリー図は、エクスプローラウィンドウに表示されます。それはあなたのアーキテクチャにウィンドウです。そして、あなたはエクスプローラウィンドウ内の要素を選択すると 3 他のウィンドウ;一般プロパティ、参考文献[プロパティ]ウィンドウには、あなたの選択についての詳細な情報を反映するために更新されます。

注意

一般プロパティ、参考文献[プロパティ]ウィンドウは、デフォルトでは非表示になっています。 見る インタフェースのカスタマイズ 以下のためどのようにそれらを再表示するには、潜在的に恒久的に表示されたそれらを残します。

あなたはあなたのアーキテクチャを構築している間に、エクスプローラ、プロパティウィンドウは、最も有用な表現です。彼らは折りたたみと展開することができるために必要な、そして、彼らは面倒になりませんよう。

エクスプローラウィンドウがツリー（ステータスバー）を有し、[プロパティ]ウィンドウが持っています 5セクション：

· タイプ

· スタンダード

· 説明

· 参考文献

· プロパティ

ABACUSは、これらの事のすべてはアーキテクチャの一部と考えています。

木

このセクションでは、ツリーを持っています 3つの領域に分類 次のように：

1。 メタモデル

· スタンダード - 多数のコンポーネントが同じプロパティのセットを持っている場合は、アップフロントセットを定義し、コンポーネントだけに割り当てることができます。同じことが、接続、および他の要素のいずれかのために行きます。標準プロパティのこれらのセットは、に格納されています スタンダード木の枝。代わりに、すべてのコンポーネントのすべてのプロパティ、およびすべての接続などのためのすべてのプロパティを定義するだけ割り当てます 標準。の例については、標準的な特性 Unix系HP / UX保存することができます 標準 そして、使用して、任意のコンポーネントに割り当てられました Unix系HP / UXオペレーティング・システムについて示されるように OS01 スクリーンショットのサーバー 上記.

· タイプ - ツリーのこのブランチは、使用可能なコンポーネントと接続の種類のライブラリです。種類は、お使いのアーキテクチャを表示するとき、あなたのアーキテクチャ用に分類し、フィルタリングのためのメタモデルを定義するために使用されます。彼らはまた、何のためのテンプレートを決定 スタンダード、プロパティと制約があなたのコンポーネント/接続が持つことができます。

· 視点 - 見ますポイントSは既存の図から作成することができ、新たな図を作成するために使用することができます。彼らは、図ステンシルです。

· テンプレート - テンプレートストア 再利用可能な コンポーネントのパターンと、それらを表現または表示される方法と一緒に接続。これらは、既存のアーキテクチャの中に配置することができる「ミニ」アーキテクチャまたは溶液として考えることができ.

2。 アーキテクチャ - アーキテクチャ ブランチ ビルドどこ木であります アーキテクチャ お使いのシステムの（複数可）。 （これは、アーキテクチャを投入すると呼ばれています。）あなたは、単一のABACUSファイル内のアーキテクチャの任意の番号を持つことができます。

3。 ダッシュボード - あなたは、保存されたアクセスできる場所木のダッシュボード分岐があります ダッシュボード プロジェクトの。

注意

自分を持っていたエクスプローラのツリーの項目 更新権限 グレーで表示されている（すなわち、それらは読み取り専用です）削除。

タイプ

このセクションでは、ツリー内で現在選択されている要素の特定のコンポーネントまたは接続タイプを表します。

スタンダード

このセクションでは、のリストを提供 スタンダード ツリー内で現在選択されている要素の。

説明

このセクションでは、ツリー内で選択した要素について簡単に説明します。関連するハイパーリンクも、このセクションに追加することができます。これらは、ウェブサイトや、指定された要素についての更なる情報を指しローカル絶対パスが含まれています。複数行も許可されています。有効なハイパーリンクは、5文字列のいずれかで開始する必要があります。 http：//、https：//には、ftp：//、ファイル：///かのmailto :.

先端

スペースをハイパーリンクの場合は、ユーザーが必要なテキストを選択し、URLまたはパスを入力することができ、 右クリック| ハイパーリンク。これは、任意のスペースに変更されます ％20そう、全体のURLまたはパスが正しく動作します。

作成および変更

これら セクションs提供しますユーザおよび日付/時刻を作成するための、およびへの最後の変更、 ツリーで現在選択されている要素。

参考文献

このセクションでは、のリストを提供 発信および着信コンポーネント ツリー内で現在選択されている要素の。また、現在選択されている要素がに表示されていることを図、3Dおよびチャート図を示す。図が選択されている場合は、図のためおよび一般的なビューの適用はそれがビューが表示されます任意のダッシュボードが表示されている場合の視点を示している。そして、時の標準ツリーで選択され、それはタイプ、コンポーネントと接続することにより、標準の使用法を示しています。

プロパティ

あなたがの特性を定義し、このセクションでは、 内の要素 など、あなたが実行するためにそれを必要とする方法のようなあなたのアーキテクチャ、それが持っているコードの行数、コメントでこれらのラインの割合、

事前に構築されたの「入力」と「出力」のプロパティ シミュレータ （プロパティの入力行セレクタアイコンで[プロパティ]ウィンドウに表示されます [image] ）と出力アイコン（ [image] ）をそれぞれ示すツールヒントとする事前に構築されたプロパティが関連するシミュレータは、例えば「モジュール方式の出力」または「パフォーマンス入力」。出力アイコンの矢印が強調表示されます 赤 ( [image] ）プロパティは、原資産に期日またはに従って再シミュレーションを必要とするシミュレータでリポジトリへの構造変化の外にあるとき 赤 ハイライト シミュレーションツールバー .

ステータスバー

ステータスバーの左側部分には、現在の合焦リポジトリ要素への完全なパスを表示し、いずれかのエクスプローラウィンドウまたは上で選択 ダイアグラム キャンバス。指定された要素のリポジトリ階層内の正確な場所は、常に容易に決定することができるようにするためです。ステータスバーの右側部分には、「オープンABACUSファイルの成功」と「完了コスト計算」など、さまざまな操作メッセージが表示されます。

参照してください

どのようにあなたがそれを行う（概要） | インタフェースのカスタマイズ | アーキテクチャとは何ですか？ | どのようなアーキテクチャは、ABACUSに表されていますか？ | ABACUSファイルの操作


ABACUSインタフェースのカスタマイズ

ナビゲーション：ABACUSの紹介>

ABACUSインタフェースのカスタマイズ

コメントを送信 このトピックに関する。

あなたは多くの方法でABACUSインターフェイスの外観と動作を変更することができます。 ABACUSは、インターフェイスにカスタマイゼーションのグループを適用するために使用できるいくつかの定義済みの設定の組み合わせを含みます。また、このようなウィンドウ、ツールバー、ショートカットキー、および各種表示オプションなどの項目に個別なカスタマイズを行うことができます。

アレンジとドックのWindows

あなたは、次のような、ABACUSためのインタフェース内のウィンドウを配置するための多くのオプションがあります：

· タブドックの窓。

· インタフェースのフレームのエッジにドッキングウィンドウ。

· インタフェースの縁に沿ってツールウィンドウを最小化します。

· デフォルトのレイアウトにウィンドウの配置をリセットします。

ドッキングのWindows

ウィンドウがドッキング可能である場合には、インタフェース内のフレームの一側に固定され得るか、またはそれがフレーム内のタブ付きペインに配置することができます。インターフェイス内の別の場所に現在の場所からのウィンドウをドラッグすると、ガイドダイヤモンドが表示されます。ガイドダイヤモンドはすぐにフレームの4辺の一方またはタブ付きペインなどの中央にウィンドウを再ドッキングすることができます。ウィンドウがドッキングまたはドッキング可能なされていない場合は、他のウィンドウの上に浮かびます。

ウィンドウをドッキングするには

1。 集中それを与えるために、あなたがドッキングするウィンドウをクリックします。

2。 上の ウィンドウメニューをクリック ドッキング可能.

3。 あなたがそれをドッキングしたいフレームの中央に向かって現在の場所からのウィンドウをドラッグします。

ガイドダイヤモンドが表示されます。フレームの四隅と中央に向​​かってダイヤモンドポイントの4方向の矢印は、タブ付きペインを表します。

先端

それをドラッグしながら、所定の位置にスナップすることなく、Ctrlキーを押しながらドッキング可能なウィンドウを移動します。

4。 ドラッグしているウィンドウは、あなたがそれをドッキングしたい位置に到達すると、ガイドダイヤモンドの対応する部分の上にポインタを移動します。ウィンドウの輪郭が指定された領域に表示されます。

5。 指示された位置にウィンドウをドッキングするには、マウスボタンを離します。

例えば、もし エクスプローラインタフェースの左端にドッキングして、右端にそれをドッキングしたいし、あなたがドラッグう エクスプローラインターフェイスの中央に向かって、ガイドダイヤモンドの右側にポインタを移動し、マウスボタンを離します。

最小化Windowsの

Windowsの（彼らはツールウィンドウであるかどうか - に登場 見ますメニュー、またはドキュメントのWindows - に登場 ウィンドウメニュー）自動的に隠すと呼ばれる機能をサポートしています。自動非表示が使用されていないインターフェイスの縁に沿ってウィンドウを最小化することにより、一度にあなたのアーキテクチャの詳細を参照することができます。

自動非表示をオンにするには

1。 あなたが集中するそれを与えるために非表示にするウィンドウをクリックします。

2。 上の ウィンドウメニューをクリック 自動的に隠します.

- または -

2。 ウィンドウのタイトルバーの画鋲アイコンをクリックします。

自動的に隠すには有効

自動隠されたウィンドウがフォーカスを失ったとき、それは自動的にインターフェイスの端に戻って、そのタブにスライドします。ウィンドウが自動非表示になっているが、その名前とアイコンは、インターフェイスの端にあるタブに表示されます。自動隠されたウィンドウを表示するには、タブの上にポインタを移動します。ウィンドウには、ビューに戻ってスライドし、使用可能な状態です。

注意

自動隠されているウィンドウはドッキングすることはできません。ウィンドウをドッキングするには、以下に説明するように自動的に隠すをオフにする必要があります。

自動非表示をオフにするには

1。 あなたが集中するそれを与えるために目に見える保ちたいウィンドウをクリックします。

2。 上の ウィンドウメニューをクリック 自動的に隠しますチェックマークをオフにします。

- または -

2。 ウィンドウのタイトルバーの画鋲アイコンをクリックします。

自動無効隠します

先端

ウィンドウにフォーカスがあるときに自動的に隠すを持っているWindowsが一時的に視野にスライド可能となりました。ウィンドウを再度非表示にするには、現在のウィンドウの外にアイテムを選択します。ウィンドウがフォーカスを失うと、それは背面図のうちスライドします。

Windowsのレイアウトをリセット

あなたが使用して、デフォルトのウィンドウレイアウトへのインターフェイスを返すことができます ウィンドウのレイアウトをリセット コマンド。このコマンドを実行すると、次のアクションが発生します。

· すべてのウィンドウはデフォルトの位置に移動します。

· デフォルトのウィンドウレイアウトで閉じているWindowsには、コマンドによって閉じられています。

· デフォルトのウィンドウレイアウトで開いているWindowsは、コマンドによって開かれます。

· デフォルトのウィンドウレイアウトで/可視隠されているのWindowsは、コマンドによって、可視/非表示の作られています。

デフォルトのレイアウトにウィンドウの配置をリセットするには

1。 上の Windowsのメニューをクリック ウィンドウのレイアウトをリセット.

メニューとツールバーのカスタマイズ

あなたは、インターフェイスのメニューやツールバーのレイアウト、位置、および内容を変更することができます。また、ツールバーにボタンを追加し、いずれかのボタンに割り当てられたアイコンを変更することができます。

新しいツールバーを作成します。

新しいツールバーを作成するには

1。 上の ツールメニュー、選択 カスタマイズ.

2。 の中に カスタマイズダイアログボックスで、選択し ツールバー タブ。

3。 選択してください 新しい.

4。 の中に 新しい ツールバーダイアログボックスは、ツールバーの名前を入力します。

5。 選択してください [OK].

メニューまたはツールバーにコマンドボタンを追加するには

1。 上の ツールメニュー、選択 カスタマイズ.

2。 の中に カスタマイズダイアログボックスで、選択し コマンド タブ。

3。 カテゴリを選択し、メニューまたはツールバーにダイアログボックスからコマンドをドラッグします。

4。 選択してください 閉じる.

先端

Altキーを押しながらキーを押したままにすると、カスタマイズダイアログが開いたかのように、コマンドをクイックカスタマイズすることができます。

参照してください

ABACUSインタフェース


ABACUSファイルの操作

ナビゲーション：ABACUSの紹介>

ABACUSファイルの操作

コメントを送信 このトピックに関する。

ABACUSファイルあなたのモデルのコンテナです アーキテクチャ 。単一ABACUSファイル内では、アーキテクチャの任意の数を任意の回数をモデル化することができます。

あなたが最初にABACUSを開くと、何のファイルが開いてありません。あなたのアーキテクチャ上で動作するには、新しいファイルを作成したり、既存のファイルを開くには、いずれかを持っています。

あなたが開いたり、新しいファイルを作成すると、エクスプローラウィンドウのツリーが自動的に表示されます。このエクスプローラビューは、現在までに、あなたのアーキテクチャを示しています。あなたがファイルを閉じると、エクスプローラウィンドウのツリーにも表示されなくなります。

新しいABACUSファイルを作成するには

1。 選択 ファイル| 新しい ...

2。 表示される[新しいプロジェクト]ダイアログで（下図のように） 選択してくださいAから空白のモデル、モデルを作成するのいずれかに 標準ABACUSライブラリ カスタムABACUSライブラリー、XMLからモデルからモデル、 MS Accessの , MS Visioの , エクセル , MS SQL Serverの 、 企業 サーバ モデルやカスタムABACUSライブラリ（.abacuslibファイル）。

3。 クリックします [OK]ボタンと表示されることがあります任意のダイアログに従ってください。

先端

あなたはそれを保存するか閉じるまでファイルに名前を付けるために求められることはありません。それはすぐにあなたがそれを作成するようにファイルを保存することをお勧めします。そして、あなたは（あなたのアーキテクチャを取り込むように）他の複雑なものに集中しているプロセスの後半でそれを命名を心配する必要はありません。

新しいプロジェクトを作成します

ABACUS標準ライブラリ

ABACUSは終わっサポート 100公共のフレームワークとの表記はそのうちのいくつかを以下に示します。標準ライブラリのユーザーからの新規プロジェクトを作成することを選択すると、任意の定義された要素タイプ、属性、表記、視点やテンプレートやパターンをフル活用して確立する枠組みの中でモデル化への迅速なスタートを持っています。追加の標準ライブラリはAvolutionコミュニティを自由にご利用いただけます ここに .

標準ライブラリから新規プロジェクト

新しいそろばんファイルを保存するには

1。 選択 ファイル| 名前を付けて保存

先端

ファイル名は任意の長さにすることができ、任意の英数字、スペースを含めることができます。 （？）などのバックスラッシュ（\）として、通常、パスの記述に使用される文字、疑問符、または文字 - パスの一部として以外に|（）彼らは、チルダ（〜）文字、パイプを含めることはできません。

既存のABACUSファイルを開くには

1。 選択 ファイル| オープン

注意

すでに別のユーザーに開放されている共有ネットワークの場所からファイルを開いている場合、ABACUSは、読み取り専用アクセスを提供します。読み取り専用アクセスをABACUSを使用するときは、そのようなあなたのアーキテクチャを取り込むと、評価を実行するように、書き込み操作を実行することはできません。ただし、エクスプローラビューと3Dビューを使用してアーキテクチャを表示することができます。

参照してください

どのようなアーキテクチャは、ABACUSに表されていますか？


どのようなアーキテクチャは、ABACUSに表されていますか？

ナビゲーション：ABACUSの紹介>

どのようなアーキテクチャは、ABACUSに表されていますか？

コメントを送信 このトピックに関する。

ABACUSでは、あなたのアーキテクチャをモデル化します。簡単にするために、我々は、このアーキテクチャモデルアーキテクチャと呼びます。

以下の図は、どのように典型的なアーキテクチャを示して 5コンポーネント （階層内） 2接続によって接続がABACUSで表されます。

シンプルなアーキテクチャは、ABACUSに表されている方法

あなたは、単一のABACUSファイル内のアーキテクチャの任意の番号を持つことができます。

ツリーの最初のアーキテクチャ

変更を評価したいときはいつでも通常は、新しいアーキテクチャを作成します。たとえば、あなたが最初にあなたの既存のアーキテクチャをモデル化したい - これは、ツリー内の最初のアーキテクチャであろう。あなたは「現在の」それを呼ぶかもしれません。

二番目

あなたがあなたの既存のアーキテクチャ（例えば増加した要件）への変更をモデル化し、評価したい場合には、新しいアーキテクチャを作成したいです。これを行う最も簡単な方法は、「現在」のコピーを作成し、「進化1試行1 'に名前を変更することであろう。これは、ツリー内の第二のアーキテクチャであろう。 「進化1試行1 'のあなたの評価が成功した場合、単に「進化1」に名前を変更することができます。

第3

「進化1試行1 'が要件を満たさない場合は、そのコピーを作成する」の進化1試行2」に名前を変更し、再度試すことができます。これは、ツリー内の第三のアーキテクチャであろう。

参照してください

ABACUSは何をするのでしょうか？ | どのようにあなたがそれを行う（概要） | アーキテクチャとは何ですか？ | ABACUSファイルの操作 | アーキテクチャを作成または複製


他の言語のヘルプ

ナビゲーション：ABACUSの紹介>

他の言語のヘルプ

コメントを送信 このトピックに関する。

ABACUS ヘルプには、様々な他の言語/翻訳で利用可能で、下記のリンクからダウンロードすることができます。

に 現在ABACUSのヘルプファイルを置き換えます翻訳されたヘルプファイルに次の手順に従ってください。

1。 下記の関連リンクからヘルプファイルを保存.

2。 ABACUS.chmにヘルプファイルの名前を変更します.

3。 それをダブルクリックしてと場合に、ファイルを開く「ファイルを開く - セキュリティの警告」ダイアログは、オプション「常にファイルを開く前に尋ねる」をクリックして[開く]をオフに表示されます。

4。 ファイルを閉じます。

5。 「一般的に、ABACUSプログラムファイルフォルダにABACUS.chmファイルを置き換えC：\プログラムファイル\ Avolution \ ABACUS"または"C：\プログラムファイル（x86）の\ Avolution \ ABACUS"。

注意

状況依存ヘルプは、翻訳されたヘルプファイルで作業していきます。

他の言語のABACUSヘルプファイル：

· アラビア語 / العربية .

· ブルガリア語 / български .

· 中国語（簡体字） / 中文（简体） .

· チェコ語 / チェスカ .

· デンマーク語 / ダンスク .

· エストニア語 / EESTI .

· フィンランド語 / Suomen .

· フランス語 / フランス語 .

· ドイツ語 / ドイチュ .

· ハンガリー語 / マジャール .

· アイスランド語 / アイスランド語 .

· インドネシアの / インドネシア .

· イタリア語 / イタリア語 .

· 日本語 / 日本の .

· ラトビアの / Latvijas .

· マレーシアの / マレーシア .

· マルタ語 / 麦芽 i .

· Norweigen / Norweigen .

· 研磨 / ポー川 lska .

· ポルトガル語 / ポルトガル語 .

· ロシア / русский .

· スロバキア語 / Slovenskí .

· スロベニア語 / Slovenski .

· スペイン語 / エスパノーレス .

· スウェーデン語 / スヴェンスカ .

· トルコ語 / チュルク .

· ウェールズ語 / Cymraeg .

参照してください

ABACUSは何をするのでしょうか？


あなたのアーキテクチャへの移入

ナビゲーション：あなたのアーキテクチャへの移入>

あなたのアーキテクチャへの移入

コメントを送信 このトピックに関する。

あなたのアーキテクチャのモデルを構築するプロセスは、以下のように知られています 移入。あなたのアーキテクチャーを発見し、あなたの要件を特定したら、あなたはABACUSであなたのアーキテクチャをモデル化する準備が整いました。

人口の間に、あなたはあなたのアーキテクチャとそれに必要です知っているすべての詳細を入力します。

お使いのアーキテクチャを移入するには

1。 あなたが持っていることを確認 ABACUSファイルオープン 、 エクスプローラ表示 、 アーキテクチャが追加されました .

2。 手動で移入 より高いレベルのコンポーネントと、あなたのアーキテクチャの接続。通常、これは、より抽象的なコンポーネントとの接続になります。

- または -

2。 グラフィカル移入 ご希望のコンポーネントとの接続が使用して、図式表現を参照してください 描画ツール .

次の操作も実行できます。

3。 カタログを使用して移入 - あなたが見ることができますし、 コンポーネントと 簡単な表形式の方法で接続。

4。 行列を使用して移入 - あなたは、単純な表形式の方法で、コンポーネント間の接続を表示し、編集することができます。

5。 マイクロソフトのAccessからの移入 - あなたはからアーキテクチャをインポートすることができます 輸出へ Microsoft Accessの。

6。 Microsoft Visioのからの移入 - あなたはからアーキテクチャをインポートすることができます 輸出へ Microsoft Visioの。

7。 Excelからの移入 - あなたはからアーキテクチャをインポートすることができます 輸出へ Microsoft Excelの。

8。 マイクロソフトのSharePointからの移入 - あなたはからアーキテクチャをインポートすることができます 輸出へ Microsoft SQL Serverの。

9。 Microsoft SQL Serverからの移入 - あなたは、Microsoft SQL Serverからのアーキテクチャをインポートすることができます。

10。 XMLからのインポート - あなたはABACUSのXMLフラグメントまたはArchiMateインターチェンジ言語のXMLファイルからアーキテクチャをインポートすることができます。

参照してください

手動であなたのアーキテクチャへの移入 | 描画ツール | マイクロソフトのAccessからあなたのアーキテクチャへの移入 | Microsoft Visioのからあなたのアーキテクチャへの移入 | Excelからあなたのアーキテクチャへの移入


手動であなたのアーキテクチャへの移入

ナビゲーション：>あなたのアーキテクチャへの移入手動で取り込み>

手動であなたのアーキテクチャへの移入

コメントを送信 このトピックに関する。

あなたのアーキテクチャのより高いレベルのコンポーネントとの接続はおそらく手動で移入する必要があります。通常、これは、より抽象的なコンポーネントとの接続になります。

手動であなたのアーキテクチャを移入するには

1。 あなたが持っていることを確認 ABACUSファイルオープン、AN エクスプローラ表示され、AN アーキテクチャが追加されました .

2。 コンポーネントを追加します。 これをする、 右クリック木の領域にあなたが移入し、選択したいです サブコンポーネントを追加...、またはをクリックします 新しいコンポーネント上のボタン 表示ツールバー 。コンポーネントは唯一のツリーのコンポーネントの枝の下に追加することができます。あなたは、あなたのツリー図は、あなたのアーキテクチャの正確な表現になりたいです。あなたのアーキテクチャーを発見したとき、あなたはそれがすべて一緒にフィットする正確にどのように学んできたでしょう。あなたのコンポーネントとの接続を追加するときに、この知識が必要になります。あなたが最初のコンポーネントを追加している場合は、コンポーネントの支店に直接追加します。あなたの残りの成分は、いずれかのツリー内の同じレベルにすることができ、またはそれらは、最初のサブコンポーネントであることができます。

3。 の値を更新プロパティあなたがそれを追加すると、各コンポーネントの。これをする、 クリックコンポーネントに、とに表示されるプロパティを編集 [プロパティ]ウィンドウ（通常は）右に。プロパティは、一般的にABACUSは、お使いのアーキテクチャを評価するとき、それはいくつかの新しいプロパティを計算し、バックアーキテクチャにそれらを保存するなどの要件、処理能力、のようなものです。新しいプロパティは、などの利用、応答時間、帯域幅、など、分析しようとしているデータ、あります

4。 あなたの接続を追加します。 そして 更新そのプロパティあなたは（ただし、ツリーの接続ブランチの下）のコンポーネントの場合と同様 - あなたが行くように。

5。 添付接続およびコンポーネント。これを行うには、接続を探し、のいずれかをクリックして、 終了しますか 役割 、およびコンポーネントの上にドラッグします。また、コンポーネントをクリックして、接続のの一つにドラッグします 役割（すなわち、ソースまたはシンクのいずれか）。それとも、右クリックして、別のコンポーネント上にコンポーネントをドラッグして選択することができます に接続します。あるいは、単にコンポーネントを右クリックして選択 接続...。あなたは、接続をドラッグすると 役割あなたはそれを添付することができるコンポーネントでポイントすると、ショートカットのシンボルに気づくでしょう。これは、あなたがそれを装着している、コピーを行っていないことを示しています。あなたが正しい宛先コンポーネントに添付していることを確認します。例えば、それは、接続のソースの場合 役割、それは（データフローのソースであるコンポーネント、すなわち）ソース・コンポーネントを行うドラッグします。

先端

再注文であなたのアーキテクチャ（例えばコンポーネント、接続など）内のエンティティ エクスプローラ非常に簡単です。単に クリック| ホールド| ドラッグあなたのアーキテクチャで望ま関連するエンティティと場所。並べ替え機能は、あなたのアーキテクチャの異なる階層内のエンティティを配置することができます。

次の操作も実行できます。

6。 規格を追加 （プロパティの事前設定されたセット - プリセット）、コンポーネント、接続またはタイプへ

7。 プロパティを変更します コンポーネント、接続またはタイプの

8。 元に戻すとやり直し 操作

9。 タイプを変更します 部品や接続の

10。 新しい型または型グループを作成します。

11。 削除 コンポーネントまたは接続

12。 作成し、複製したり、進化 アーキテクチャ

13。 インポートタイプと規格 ライブラリから

14。 別のABACUSファイルからのインポート、XML、ExcelやVisioの

15。 コピーアンドペースト あなたのアーキテクチャの一部（または全部）

16。 検索および置換 あなたのアーキテクチャ内の項目

17。 展開/折りたたみ ツリー内のノードの一部またはすべて

18。 マージ アイテム

19。 定義 そして 検証 制約 あなたのアーキテクチャの構造を制限します

20。 あなたのアーキテクチャの進化 いくつかのアーキテクチャの比較するためのソリューションやベースラインを作成します

参照してください

お使いのアーキテクチャの移入 - 概要 | 新しいファイルを作成します


元に戻すとやり直し

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

元に戻すとやり直し

コメントを送信 このトピックに関する。

現代の多くのアプリケーションと同様に、ABACUSは、開いているプロジェクトに対して行われた最近のユーザーの変更を元に戻すとやり直すの両方の能力をサポートしています。最新の変更を元に戻すには、単に元に戻す]コマンドをアクティブにします。元に戻すされた変更は、redoコマンドを活性化することにより、やり直すことができます。再適用し、最近、元に戻す変更を。

警告

さらに変更が取り消されているので、プロジェクトに行われた場合、元に戻す変更を再適用することができません。

注意

変更の大半は、元に戻す/リアルタイムでやり直し、いくつかサポートしていますが ダイアグラム このような新しいタイプ形状/ラインの関連付けを作成するか、または関連のカラー属性の変更などのステンシルの変更は、すぐに元に戻すことはできません。これらの変更を元に戻すことができる前に、これらのケースでは、（アスタリスクで示す）が変更されたダイアグラムを閉じる必要があります。

コマンドの位置を元に戻すとやり直し

アンドゥとリドゥのコマンドは、3つの異なる場所からアクセスすることがあります。

· [編集]メニュー

· 標準ツールバー

· キーボードのショートカットキー Ctrl + Z（元に戻す）と Ctrl + Y（やり直し）

先端

元に戻すと、標準ツールバーのボタンをやり直すには、元に戻すことができ、それぞれやり直されてきた10の最新の変更を表示するドロップダウンリストを提供します。また、一度に複数の変更をアンドゥ/リドゥするための便利な方法です。


コンポーネント/接続のタイプの変更

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

コンポーネント/接続のタイプの変更

コメントを送信 このトピックに関する。

部品および接続のタイプは、主に、分類の目的のために使用されます。お使いのアーキテクチャを表示するときには、フィルタとしてのタイプを使用することができます。たとえば、代わりに全体を見て、あなただけのアプリケーション・コンポーネントを表示することができます。

コンポーネント/接続の種類を変更します

1。 右クリックコンポーネントまたは接続に。

2。 選択 タイプの変更.

3。 リストから別のタイプを選択します。

先端

あなたはタイプを変更すると、あなたはいくつかの新しいを得ることができます スタンダードやプロパティ（タイプに関連付けられているものは何でも - 木の種類の枝を参照してください）​​。既存の スタンダード プロパティは変更されません。あなたはあなた自身の新しいタイプを作成し、独自の組み合わせを割り当てることができます スタンダード それらにプロパティ。

参照してください

新しいタイプの作成 | お使いのアーキテクチャの移入 - 概要 | 解析法 あなたのアーキテクチャ


新しいコンポーネント/接続タイプまたはタイプのグループを作成します

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

新しいコンポーネント/接続タイプまたはタイプのグループを作成します

コメントを送信 このトピックに関する。

部品および接続のタイプは、主に、分類の目的のために使用されます。お使いのアーキテクチャを表示するときには、フィルタとしてのタイプを使用することができます。たとえば、代わりに全体を見て、あなただけのアプリケーション・コンポーネントを表示することができます。

新しいコンポーネント/接続タイプを作成するには

注意

ABACUSプロジェクトの種類やタイプグループを追加するにはユーザー・ライセンスは、デザイナーのアドオン機能を必要とします。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

1。 拡大 タイプ木の枝。

2。 右クリック に コンポーネントタイプ（または 接続タイプ）。

3。 選択 コンポーネントタイプを追加（または 接続タイプを追加）または グループを作成.

先端

あなたはタイプを作成したら、そのアイコン（下記参照）を変更し、追加する必要があります プロパティ そして スタンダード それへの「継承」へのコンポーネントまたは接続インスタンスのため。

コンポーネント/接続タイプのアイコンを変更するには

注意

ユーザーライセンスは、デザイナーアドオン機能を必要とするABACUSプロジェクトの種類のアイコンを変更します。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

1。 右クリック上の コンポーネントタイプ（または 接続タイプ）あなたは、アイコンを変更したいです。

2。 選択 アイコンの変更.

3。 場所を選択アイコンダイアログ閲覧では、画像ファイルを選択し、[開く]をクリックします。

注意

あなたは、任意のサイズのカスタムアイコンイメージを持つことができますが、それは常にエクスプローラウィンドウで16x16ピクセルのイメージに合うように調整されます。あなたのオリジナルのカスタムアイコンイメージが同じ高さではなく、幅のであれば、あなたのエクスプローラウィンドウのアイコンが引き伸ばされます。したがって、カスタムイメージは、少なくとも16×16ピクセルにする必要があり、あなたのカスタムアイコンイメージがピクセル単位で同じ高さと幅（16×16以上）であることを確認してくださいカスタムアイコンの正確な形状を保持する場合。また、それはお互いに隣接するアイコン「出血」でエクスプローラウィンドウに悪いになりますように着色された「ピクセル」は、カスタムアイコンイメージの国境にすべての道を行く持っていないに注意する必要があります。したがって、あなたは、少なくとも1ピクセルの白のボーダーを残す必要があります。

先端

あなたのカスタムアイコンイメージ.ICO、.BMP、.GIF、.JPGまたは.PNG形式のファイルにすることができますが、[表示]メニューのオプションを持っている場合により、Windowsの制限のためだけの.ico形式は、ABACUS選択アイコン]ダイアログボックスでプレビューしますサムネイル以外に設定。

参照してください

お使いのアーキテクチャの移入 - 概要 | 解析法 あなたのアーキテクチャ


コンポーネントまたは接続を削除します

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

コンポーネントまたは接続を削除します

コメントを送信 このトピックに関する。

コンポーネントまたは接続を削除するには

1。 右クリックコンポーネントまたは接続に。

2。 選択 削除.

注意

ABACUSは、削除によって影響されるようにビューを警告し、削除を確認するように要求されます。要素は多くの図に存在する可能性があるためである、それは提案された削除が影響するかどうか確認することを支払います。

先端

コンポーネントを削除すると、そのサブコンポーネントもすべて削除されます。あなたは、コンポーネントの内部および外部接続を削除するかを選択できます。あなたがそれらを削除しないことを選択した場合、接続がそれです 添付の 残りますが、彼らはもはや添付されません。すべてのコンポーネントとの接続は、特定のもの タイプ 。コンポーネント/接続を削除すると、（木の種類ブランチで）タイプには影響を与えません。同様に、コンポーネント/接続がある場合は 標準 割り当てられた、削除は標準ブランチのマスターへの影響はありません。

参照してください

お使いのアーキテクチャの移入 - 概要


アーキテクチャを作成または複製

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

アーキテクチャを作成または複製

コメントを送信 このトピックに関する。

あなたは、単一のABACUSファイル内のアーキテクチャの任意の番号を持つことができます。通常は、新しいアーキテクチャにあなたのシステムの進化をモデル化して評価するたびに作成すると思います。

新しいアーキテクチャを作成するには

1。 右クリック上の アーキテクチャ木の枝。

2。 選択 新しいアーキテクチャ.

既存のアーキテクチャのコピーを作成するには

1。 右クリックアーキテクチャ上。

2。 選択 コピー.

3。 右クリック上の アーキテクチャ木の枝。

4。 選択 ペースト.

5。 新しいアーキテクチャは、「...のコピー」と呼ばれます。

既存のアーキテクチャを進化させるために、

1。 右クリックアーキテクチャ上。

2。 選択 進化させます.

3。 新しいアーキテクチャは、 '... 0.1」と呼ばれます。

注意

進化するアーキテクチャの詳細な説明があります ここに .

参照してください

どのようなアーキテクチャは、ABACUSに示されています | あなたのアーキテクチャの進化


あなたのアーキテクチャへのインポート

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

あなたのアーキテクチャへのインポート

コメントを送信 このトピックに関する。

ABACUSは、ことができます インポートします あなたのアーキテクチャ から .abacus（ABACUSファイル）、 .xmlファイル（そろばんXMLフラグメントまたはArchiMateインターチェンジ言語のXMLファイル）、.VSD（Microsoft Visioの）フォーマット、および .XLS（Microsoft Excelの）形式。これはあなたがすることができます すぐに外部ソースからあなたのアーキテクチャを構築.

に インポート あなたのアーキテクチャ から.abacus（ABACUSファイル）

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 右クリックアーキテクチャのノードで、モデル内の任意のアーキテクチャやコンポーネントツリーの任意の部分。

3。 選択 インポート| から ファイル...メニューから選択します。

4。 場所を選択し、 .abacus ファイル クリックします オープン ボタン。

注意

インポートしたいファイルを選択した後、あなたは基準をインポートしたいのかを質問されます, タイプそして、視点。あなたは、標準をインポートすることができます, タイプ そして、視点 新規またはマージされたいずれかの基準として、, タイプそして、視点。デフォルトの設定は標準のためであります, タイプ そして、視点 既存の標準と合併します, タイプ そして、視点 彼らはすでに存在する場合 （同じ名前を持ちます） あなたの中 プロジェクト.

に インポートあなたのアーキテクチャ から.xmlファイル （ABACUS XMLフラグメントまたはArchiMate交換言語XMLファイル）

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 右クリックアーキテクチャのノードで、モデル内の任意のアーキテクチャまたはコンポーネントツリーの任意の部分。

3。 選択 インポート| から XML ...メニューから選択します。

4。 場所を選択し、 .xmlファイル ファイルをクリックします オープン ボタン。

注意

ABACUSのみ適切に形成されたそろばんXMLフラグメントまたはArchiMateインターチェンジ言語のXMLファイルをインポートします。 あなたがインポートするXMLファイルを選択した後、あなたは基準をインポートしたいのかを質問されます, タイプそして、視点。あなたは、標準をインポートすることができます, タイプ そして、視点 新規またはマージされたいずれかの基準として、, タイプそして、視点。デフォルトの設定は標準のためであります, タイプ そして、視点 既存の標準と合併します, タイプ そして、視点 彼らはすでに存在する場合 （同じ名前を持ちます） あなたの中 プロジェクト.

に インポートあなたのアーキテクチャ から。VSD（Visioの ファイル） 見る ここに .

に インポートあなたのアーキテクチャ から.XLS（Excelファイル） 見る ここに .


ライブラリから種類や規格のインポート

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

ライブラリから種類や規格のインポート

コメントを送信 このトピックに関する。

あなたはABACUSライブラリファイルから種類や規格をインポートすることができます。また、あなたのABACUSファイルからABACUSライブラリファイルにタイプと標準をエクスポートすることができます。

あなたのアーキテクチャにライブラリからのタイプと基準をインポートするには

1。 あなたが持っていることを確認 ABACUSファイルオープンと エクスプローラウィンドウ表示されました。

2。 ファイルを選択します| オープンオープンします ABACUSライブラリファイル.

3。 ABACUSライブラリは、エクスプローラウィンドウの第二のタブ付きシートで開きます、あなたはする必要があります このタブ付きシートをドッキング解除 元ABACUSファイルにそこからドラッグ・アンド・ドロップをすることができるようにします。

4。 ドラッグアンドドロップあなたのアーキテクチャへのライブラリから種類や規格。

- または -

1。 ファイルを選択します| 新しい ...

2。 新しいを作成します。 ABACUSファイル基づいて、 ABACUSライブラリファイル.

ライブラリにあなたのアーキテクチャから種類や規格をエクスポートするには

1。 あなたが持っていることを確認 ABACUSファイルオープン、 エクスプローラウィンドウ表示されました、 ABACUSライブラリファイルオープンと ライブラリーウィンドウ表示されました。

2。 ドラッグアンドドロップライブラリにあなたのアーキテクチャから種類や規格。

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入


コピーと貼り付け

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

コピーと貼り付け

コメントを送信 このトピックに関する。

あなたは一部またはあなたのアーキテクチャのすべてをコピーして、ツリー内の別の場所に貼り付けることができます。

コピーするには

1。 右クリック項目にあなたがコピーしたいと思います。

2。 選択 コピー.

貼り付けるには

1。 あなたがアイテムをペーストしたい場所を見つけるためにツリーをナビゲートします。

2。 右クリック枝にあなたはそれが内に表示します。

3。 選択 ペースト.

4。 （元のブランチにそれをコピーしない限り - それは 'の...コピー」と呼ばれます）の項目は元の名前でコピーされます。

参照してください

どのようなアーキテクチャは、ABACUSに示されています


お使いのアーキテクチャでアイテムを見つけると交換

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

お使いのアーキテクチャでアイテムを見つけると交換

コメントを送信 このトピックに関する。

発見できる そして、交換してください 特定のコンポーネントは、接続タイプABACUSを使用することにより、標準またはプロパティ 'の検索します そして、交換してください 施設。

アイテムを検索するには

1。 あなたは内を検索したいのですが、ツリーのノードをクリックします。

2。 選択 編集| 検索しますまたはを押して Ctrl + Fキー.

3。 入力してください テキスト アイテム「何を検索]フィールドに検索します。

4。 クリック 次を検索.

に 交換します アイテム

1。 あなたは内を検索したいのですが、ツリーのノードをクリックします。

2。 選択 編集| 交換してくださいまたはを押して Ctrlキー+ H.

3。 入力してください テキストアイテムフィールドとフィールド 'で置き換え'内でそれを置き換えるために、テキスト「何検索]内で検索します （またはフィールドを空白のままにすると何もありません）.

4。 クリック 次を検索「検索する文字列」テキストとクリックの最初のインスタンスを検索します 交換してください 'で置き換え」のテキストまたはクリックでこのインスタンスを交換します すべて置換すべてのインスタンスを置き換えます。

あなたは、にオプションがあります。

o その場合にマッチし、

o 単語全体にマッチ、

o プロジェクトの最初から検索し、

o アーキテクチャを無視する - それは、アーキテクチャ自体がノードです。このような部品や接続などのアーキテクチャのノードの下の任意のノードがまだ検索されます、

o コンポーネントを無視する - これは、コンポーネントが自分自身をノードであります

o 接続を無視する - それは、接続自体がノードであります

o 基準を無視する - それは、すべてのアーキテクチャ、コンポーネントとの接続標準ノードが無視されています

o タイプを無視する - それはタイプが自分自身をノードです。タイプノードの下の任意の制約ノードは、まだ検索されます、

o テンプレートと内容を無視する - それがテンプレートノード自体だけでなく、それらの下に任意のテンプレート・コンポーネントとの接続ノードです、

o プロパティを無視 - 無視されるすべてのプロパティのタイプ、名前、値、およびすべてのモデルの要素の単位であること、

o 説明を無視する - すべてのモデルの要素の記述は無視されていること。

参照してください

どのようなアーキテクチャは、ABACUSに示されています


ツリーの拡大と崩壊

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

ツリーの拡大と崩壊

コメントを送信 このトピックに関する。

ツリー内のノードは、サブコンポーネントおよびコレクションを含有する場合、それは小さいがあります [image] または [image] その左側にサインインします。あなたがクリックすることができます [image] ノードを展開し、そのサブコンポーネントとの接続を確認してください。同様に、あなたがクリックすることができます [image] （より多くの部屋を作るか、理解し、ツリーを容易にするために）サブコンポーネントとの接続を非表示にするノードを縮小します。

あるいは、全体のサブすべてのノードも拡大される場合には、ノード、およびそれらのサブノードを展開することができ、彼らは...等は同様に、全体のノードを折りたたむことができます - 一度に複数のレベルを閉じます。

さらに、唯一のアーキテクチャ、要素（すなわちコンポーネントとの接続）、コンポーネントまたは接続を拡張するためのオプションがあります。

（等、およびそのサブノード）全体のノードを展開または縮小するには

1。 右クリックノード上で。

2。 選択 展開します|すべて または 崩壊.

アーキテクチャのすべてを拡大するには（S）

1。 右クリックアーキテクチャまたはアーキテクチャ上。

2。 選択 展開します|すべて.

エレメントを展開するには

1。 右クリックアーキテクチャまたはアーキテクチャ上。

2。 選択 展開します|要素.

コンポーネントを展開するには

1。 右クリックコンポーネント、コンポーネントまたはサブコンポーネントに。

2。 選択 展開します|コンポーネント|すべて.

接続を展開するには

1。 右クリック接続で、接続またはサブ接続。

2。 選択 展開します|接続|すべて.


マージアイテム

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

マージアイテム

コメントを送信 このトピックに関する。

するときは、項目をマージするでしょうか？

あなたは最高の単一のインスタンスで表されているモデル内の2つ（またはそれ以上）のオブジェクトを持っているときに、アイテムをマージすることになります。あなたは含めて、これを実行することができます多くの状況があります。

· 複製したり、既存の情報に取って代わるかもしれモデルへの情報の新しいセットをインポートした結果。たとえば、あなたのモデルに、スプレッドシートの更新バージョンをインポートした場合。

· 時間が経つにつれて「同じ 'コンポーネントの複製が作成されている、あなたはこれらの重複をクリーンアップしたいと思います。

· あなたは何-場合のシナリオを実行していて、モデル化されている項目は、実際には実際にマージしている。場合たとえば、組織内の2つの部門をマージしている場合、または次の2つのサーバーをマージしている場合。

何をマージすることができますか？

アイテムの種類は次のマージされるサポートされています。

· スタンダード

· コンポーネントおよび接続タイプ

· コンポーネントとの接続

アイテムをマージする方法

マージを開始するには、マウスの右ボタンを使用して、別の上にエクスプローラでの項目をドラッグします。ドラッグしている項目がソースであり、あなたが上にドラッグする項目が先です。マウスの右ボタンを離す時に、あなたは2つの項目がマージすることを選択できるメニューが表示されます。あなたが保存または送信先を上書きするかどうかを選択する必要があります。これは、以下でさらに説明されます。

マージ右ドラッグメニュー

送信先を維持し、上書きの違いは何ですか？

保存または上書きするオプションがあれば何が起こるかを規定する送信元と送信先の項目の一致の名前、説明またはプロパティ。

保存先を選択した場合

· 宛先の名前と説明が保持されます。

· 唯一の情報源に存在するすべてのプロパティが先に追加されます。

上書きインストール先を選択した場合：

· 宛先の名前は、ソースから上書きされます。

· ソースの説明が空白でない限り、先の説明では、ソースから上書きされます。

· 唯一の情報源に存在するすべてのプロパティが先に追加されます。

· ソースの値または単位が空白でない限り、送信元と宛先の両方に存在するすべてのプロパティの値と単位は、ソースから上書きされます。

特殊なケース

· タイプ：タイプをマージする場合、アクセス許可は、ソース上の許可が先に存在していなかった場合、それは追加されるだろうし、それは、個々の場合、先に存在しなかった場合、そのようなことは、「悲観的」な方法で、マージされますユーザー・グループ（作成、読み取り、更新、または削除）の許可は、その許可が拒否されます（1つは1が拒否された、許可され）と一致しませんでした。

· コンポーネント：コンポーネントをマージする場合、ソースのサブコンポーネントは、先に移行され、その名前が同一である場合、宛先にサブコンポーネントとマージされ関係なく、種類の.また、同じ名前のソースの複数のサブコンポーネントは、目的地での単一のサブコンポーネントに結合されます。

· 接続：トップレベルの接続自体は、両方が同じ添付ファイルを持っている（またはその欠如）マージすることを許可する必要があります。接続をマージする場合、ソースのサブ接続は先に移行され、その名前が同一であれば目的地でのサブ接続にマージされます そしてその添付ファイルは同じです。添付ファイルが同一でない場合、ソースサブ接続が既に存在し、一致接続をマージすることなく先に追加されます。何の添付ファイルが失われないようにするためです。


制約の定義と検証

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

制約の定義と検証

コメントを送信 このトピックに関する。

アーキテクチャの構造及び特性は、制約を使用することによって制限することができます。制約は、2つの方法で建築の構造を制限するために、コンポーネントのタイプと接続タイプに適用することができます。最初の方法は、制限することです 階層定義することによって、関係「子供は/親を持っている必要がありますする必要があります」「親は/子供を持っている必要がありますする必要があります」と。第二の方法は、制限することです トポロジー定義することで、「コンポーネントを/接続に接続する必要がありますする必要があります」との関係「接続/コンポーネントに添付されなければならないはずです」。さらに、制約は、コンポーネントの種類、接続の種類、テンプレート、視点、アーキテクチャの特性に適用することができ、 図および3Dビュー2つのさらなる様式アーキテクチャ（複数可）を制限します。最初の方法は、設定することです データ・タイプすなわち、それが持つことができる有効な値を制限するプロパティの。テキスト、整数、10進数、日付/時刻、ブール値またはリスト。第二の方法は、設定することです 必須財産の状況値がプロパティに入力する必要があるかどうかを示す（注：必須の制約が唯一のコンポーネントと接続タイプのプロパティに適用されます）。プロパティの制約の詳細については、で提供され コンポーネント、接続またはタイプのプロパティの変更 ヘルプトピック。制約が定義されると、それは、制約に対してアーキテクチャを検証することが可能です。 ABACUSが侵害された任意の制約について警告します。

制約を記述するために使用される正確な言語で嘘を定義するためにどの制約（複数可）を決定するための鍵。階層上の制約のために、彼らは一般的に、フォームの "あります名詞/ / n個に分解されなければならない必要がありますすることができ 名詞"または"名詞/ /によって集約されなければならない必要がありますすることができ 名詞「等たとえば、「部門分解されなければなりません チーム"または"アプリケーション分解することができます モジュール"。トポロジーの制約のために、彼らは一般的に、フォームのです」名詞CAN /べき/しなければなりません 動詞 名詞"。 例えば、 "プロセスすることができます によって演奏された チーム"または"アプリケーションあります でホストされています サーバー。 "今、あなたは様々なことができ/すべき/しなければならない「修飾子」は存在する各制約で見ることができ、これらは3種類があります。

· 任意 - これらは通常の単語/フレーズが好きで使用します。 「かもしれない」、「缶」、「可能性」、「任意」など

· おすすめ - これらは通常の単語/フレーズが好きで使用します。 「お勧め」など "助言" "必要があります」

· 義務的な - これらは通常の単語/フレーズが好きで使用します。 、「ある」「しなければならない」、「ある」、「持つ」、「しなければならない」など

制約（階層またはトポロジ）の種類と、それを説明するのに使用される修飾子に依存して、特定の制約（複数可）が定義されるべきである（下記参照）。 「上記の階層例部門分解されなければなりません チーム親が子供を持っている必要があります "制約と強制する執行を設定します。上記のトポロジー例えば「an」は、1つは定義する必要があります」プロセスすることができます によって演奏された チーム。接続は、接続の種類によって実行のいずれかの端の制約」のコンポーネントに添付されなければならない」1は2つだけが（2）を作成する必要があります」具体的には、次の制約は、様々なオプションについては、（下記参照）に定義することを推奨します。

· 階層制約;

o 名詞A することができます分解 名詞B、または 名詞B することができますによって集約 名詞Aまたは 名詞B でなければなりませんによって集約 名詞A - 名詞B、親名詞Aとタイプと警告さとして執行などの子タイプの「子が親を持たなければならない」制約を定義します。

注意

これは、子が存在する場合、それは特定のタイプの親を持つべきであることを意味します。ない場合は、警告が表示されます。

o 名詞A でなければなりません分解 名詞B - 名詞Aと警告として名詞Bと執行などの子タイプとして親の型で「親は子を持たなければならない」制約を定義します。

注意

これは親が存在する場合、それは特定のタイプの子を持つべきであることを意味します。ない場合は、警告が表示されます。

o 名詞A でなければなりません分解 名詞B - 名詞A、強制などの名詞Bと執行などの子タイプとして親の型で「親は子を持たなければならない」制約を定義します。

注意

これは親が存在する場合、それは特定のタイプの子を持たなければならないことを意味します。ない場合は、エラーが発生します。

o 名詞A でなければなりませんによって集約 名詞B - 名詞A、強制などの名詞Bと執行などの親タイプとして子型の「子が親を持たなければならない」制約を定義します。

注意

これは、子が存在する場合、それは特定のタイプの親を持たなければならないことを意味します。ない場合は、エラーが発生します。

· トポロジの制約;

o 名詞A することができます 動詞 名詞B - 2（2）制約」の接続は、コンポーネントに添付されなければならない」を定義します。接続タイプのソース端との最初のビーイング 動詞強制に設定されたコンポーネント型と執行を名詞に取り付けます。接続タイプのシンクの端部と第二ビーイング 動詞強制に設定名詞B成分の種類と執行に取り付けられています。

注意

これは、接続が存在する場合、それは特定のタイプのコンポーネントを接続しなければならないことを意味します。ない場合は、エラーを取得します。全体として、これは、これらの構成要素は、依然として互いに接続されて存在しないことを保証します。それらが接続されている場合は、右のタイプの接続を使用する必要があります。

o 名詞A でなければなりません 動詞 名詞B - 2（2）制約 "コンポーネントが接続に接続する必要があります」を定義します。名詞とのソース端部に取り付けられたコンポーネントタイプである第1 動詞警告さに設定された接続タイプと施行。第二は、シンクの端部に取り付けられた名詞B成分の種類と一緒にいます 動詞警告さに設定された接続タイプと施行。さらに、2つ（2）制約」の接続は、コンポーネントに添付されなければならない」を定義します。接続タイプのソース端との最初のビーイング 動詞強制に設定されたコンポーネント型と執行を名詞に取り付けます。接続タイプのシンクの端部と第二ビーイング 動詞強制に設定名詞B成分の種類と執行に取り付けられています。

注意

これは、いずれかのタイプの構成要素が存在する場合、それらは特定のタイプの接続に添付されるべきであることを意味します。ない場合は、警告が表示されます。また、これは、接続が存在する場合、それは指定されたタイプの部品に接続されなければならないことを意味します。ない場合は、エラーが発生します。全体として、これは、これらのタイプの成分が存在する場合、それらは相互に接続されていない場合は、警告を受けることを保証します。

o 名詞A でなければなりません 動詞 名詞B - 2（2）制約 "コンポーネントが接続に接続する必要があります」を定義します。名詞とのソース端部に取り付けられたコンポーネントタイプである第1 動詞強制に設定された接続タイプと施行。第二は、シンクの端部に取り付けられた名詞B成分の種類と一緒にいます 動詞強制に設定された接続タイプと施行。さらに、2つ（2）制約」の接続は、コンポーネントに添付されなければならない」を定義します。接続タイプのソース端との最初のビーイング 動詞強制に設定されたコンポーネント型と執行を名詞に取り付けます。接続タイプのシンクの端部と第二ビーイング 動詞強制に設定名詞B成分の種類と執行に取り付けられています。

注意

これは、どちらのタイプのコンポーネントが存在する場合、それらは特定のタイプの接続に添付しなければならないことを意味します。ない場合は、エラーが発生します。また、これは、接続が存在する場合、それは指定されたタイプの部品に接続されなければならないことを意味します。ない場合は、エラーが発生します。全体として、これは、これらのタイプの成分が存在する場合、それらは相互に接続されていない場合、エラーを取得することを保証します。

制約を定義するには

1。 あなたが持っていることを確認 ABACUSファイルオープンと エクスプローラウィンドウ表示されました。

2。 Explorerツリーで拡大 種類|コンポーネントタイプまたは拡大 種類|接続タイプ.

3。 右クリックコンポーネントタイプまたは接続タイプを選択 制約の追加.

制約を追加します

親が特定の子を持っている必要があり、階層制約を定義するには

4。 上の 制約の追加ウィンドウはダニ 制約を作成します。下のチェックボックス 親は子の制約を持たなければなりません エリア。

5。 選択 コンポーネントタイプ手順3で選択したコンポーネントタイプの子として指定するドロップダウンボックスから。

注意

すでに存在する場合は有効になって親コンポーネントの種類と他の子コンポーネントのタイプに定義された制約の親が子を持たなければならない」、この新しい制約は、「AND」として扱われます。それはタイプは、子タイプAの親でなければなりません そしてどんな執行レベルの子タイプB、（例えば無効と警告または強制 - ステップ7を参照）各制約に指定されています。

6。 オプションで、右クリックし、手順3でコンポーネントタイプの子でなければなりません指定されたコンポーネント型の構成要素の最小値と最大数を定義することができます。

7。 あなたが制約になりたいかどうかを選択します 無効, 警告または 強制.

注意

無効な制約が制約検証から無視され、それらは、それらが検出された場合の制約が検証ウィンドウにエラーが発生します検出され、強制された場合の制約が検証ウィンドウで警告が生成されますと警告しました。また、すべてのエラーは前に解決されなければなりません 企業 サーバ プロジェクトは、コミットすることができます。

8。 クリック [OK].

注意

制約は、矢印は、制約の方向を示し、この場合のダウンポイントと右ます手順3で右クリックしたコンポーネントタイプの下エクスプローラツリーに表示されます。南京錠は制約が無効（灰色）であるかどうかに応じて着色され、（黄色）を警告さや強制（赤）。

親は、子供が制約を警告している必要があります

子供が特定の親を持っている必要があり、階層制約を定義するには

4。 上の 制約の追加ウィンドウはダニ 制約を作成します。下のチェックボックス 子供は親の制約を持たなければなりません エリア。

5。 選択 コンポーネントタイプあなたがコンポーネントタイプの親として指定するドロップダウンボックスから、ステップ3で右クリック。

注意

すでに存在する場合は有効になって、この新しい制約は「OR」として扱われる子コンポーネントの種類と別の親コンポーネントタイプに対して定義された制約「子供は親を持たなければなりません」。それはタイプが親タイプAの子でなければなりません または親B型、および強制レベル（例えば警告さや強制 - 次のステップを参照）と同じそれ以外の場合は強制制約は常に警告したものを上書きしますする必要があります。

6。 あなたが制約になりたいかどうかを選択します 無効, 警告または 強制.

注意

無効な制約が制約検証から無視され、それらは、それらが検出された場合の制約が検証ウィンドウにエラーが発生します検出され、強制された場合の制約が検証ウィンドウで警告が生成されますと警告しました。また、すべてのエラーは前に解決されなければなりません 企業 サーバ プロジェクトは、コミットすることができます。

7。 クリック [OK].

注意

制約は、矢印は、制約の方向を示し、この場合、ポイントアップし、左ますステップ5で選択したコンポーネント・タイプの下エクスプローラービュ​​ーに表示されます。南京錠は制約が無効（灰色）であるかどうかに応じて着色され、（黄色）を警告さや強制（赤）。

子供は親が制約を警告している必要があります

コンポーネントは特定の接続に接続する必要がありトポロジー制約を定義するには

4。 上の 制約の追加ウィンドウはダニ 制約を作成します。下のチェックボックス コンポーネントの制約を接続する必要があります エリア。

5。 選択 接続タイプあなたがコンポーネントタイプの添付接続として指定するドロップダウンボックスから、手順3で右クリック（または選択 コンポーネントタイプ手順3で使用すると、接続の種類を右クリックした場合添付コンポーネントとして指定するドロップダウンボックスから。）

注意

すでに存在する場合は有効になって、この新しい制約は「AND」として扱われます制約がコンポーネントタイプと、別の接続タイプ用に定義された」コンポーネントが接続されている必要があり」。それはコンポーネントタイプは、接続タイプAに接続する必要がありますされています そして何でも強制レベルへの接続タイプB、（例えば無効と警告または強制 - ステップ7を参照）各制約に指定されています。

6。 オプションで、接続を選択することができます 役割あなたは、制約に追加すること。 S特定を選出 役割 （すなわち、ソースまたはシンクのいずれか） ドロップダウンボックスから。

7。 あなたが制約になりたいかどうかを選択します 無効, 警告または 強制.

注意

無効な制約が制約検証から無視され、それらは、それらが検出された場合の制約が検証ウィンドウにエラーが発生します検出され、強制された場合の制約が検証ウィンドウで警告が生成されますと警告しました。また、すべてのエラーは前に解決されなければなりません 企業 サーバ プロジェクトは、コミットすることができます。

8。 クリック [OK].

接続が特定のコンポーネントに添付されなければならないトポロジー制約を定義するには

4。 上の 制約の追加ウィンドウはダニ 制約を作成します。下のチェックボックス 接続が制約を接続する必要があります エリア。

5。 選択 接続タイプあなたがコンポーネントタイプの添付接続として指定するドロップダウンボックスから、手順3で右クリック（または選択 コンポーネントタイプ手順3で使用すると、接続の種類を右クリックした場合添付コンポーネントとして指定するドロップダウンボックスから。）

注意

すでに存在する場合は有効制約が同じ接続を使用して接続タイプと、別のコンポーネント・タイプに対して定義された「接続が接続する必要があります」 役割（すなわち、いずれか ソースまたはシンク）は、この新しい制約は、「OR」として扱われます。つまり、接続タイプがコンポーネントタイプAに接続する必要がありますです またはコンポーネントタイプB、および強制レベル（例えば、警告さや強制 - ステップ7を参照）と同じそれ以外の場合は強制制約は常に警告したものを上書きしますする必要があります。場合は接続している複数の制約があること、また、注意してください 役割「任意の」（と特異的にソースまたはシンクはなく）として指定され、接続の両端には、制約で指定されたコンポーネントタイプのいずれかに接続する必要があります。

6。 オプションで、接続を選択することができます 役割あなたは、制約に追加すること。 S特定を選出 役割 （すなわち、いずれか ソース または シンク) ドロップダウンボックスから。

注意

ソースまたはシンクの役割のいずれかが明示的にするために選択する必要があります アタッチメント コンポーネントに表示するavilableする列 カタログ .

7。 あなたが制約になりたいかどうかを選択します 無効, 警告または 強制.

注意

無効な制約が制約検証から無視され、それらは、それらが検出された場合の制約が検証ウィンドウにエラーが発生します検出され、強制された場合の制約が検証ウィンドウで警告が生成されますと警告しました。また、すべてのエラーは前に解決されなければなりません 企業 サーバ プロジェクトは、コミットすることができます。

8。 クリック [OK].

リアルタイム モデル検査と 制約検証

ABACUSが含まリアルタイムモデル検査と の検証機能 すぐに 表示 効果は、与えられたユーザの操作がオンになります いずれかに起因する現在のプロジェクトとの警告とエラー、 階層 そして トポロジー 定義されている制約。これは、すべてのエラーが前に解決しなければならないことに留意すべきです 企業 サーバ プロジェクトは、コミットすることができます。

図での直接エクスプローラウィンドウに取り込む際に、リアルタイム制約の検証機能は、最も顕著です。具体的には、以下の操作中に、ガイダンスは色のハイライトを使用して、指定された場合の動作は、に与える影響に関して、 現在のプロジェクトとの警告とエラー;

1。 親の色の上または図の周りの要素をドラッグ（またはアタッチ）する場合、コンポーネントの境界線以下で説明するスキームに従って着色されます（もしあれば）。

2。 右クリックしてドラッグを使用してコンポーネントを接続する場合|利用可能な接続タイプのリストは、以下に記載のスキームに従って着色されている特徴に接続します。

3。 コネクタモードを使用して図にコンポーネントを接続すると、カーソルは、以下に記載のスキームに従って色を変更します。

4。 サブコンポーネントを追加する際に利用可能なコンポーネントタイプのリストは、下記のスキームに従って着色されています。

一般的に次の色がユーザ操作が現在のプロジェクトとの警告とエラーになります効果を示すために使用されます。

ブラック ：警告またはエラーへの影響はありません。

緑 ：操作が明示的です に従い、プロジェクトの定義された階層とトポロジ制約。

赤 ：操作が明示的です 違反でプロジェクトの階層表示とトポロジの制約を定義し、警告および/またはエラーになります。

バックグラウンド モデル検査と 制約検証

ABACUSが含ま 検証は定義されている任意の制約により、現在のプロジェクトでのすべての警告とエラーを表示する機能。これは、すべてのエラーが前に解決しなければならないことに留意すべきです 企業 サーバ プロジェクトは、コミットすることができます。

注意

検証は、手動での「検証/確認プロジェクトの制約」ボタンを経由して実行する必要があります メインツールバー 。 検証ウィンドウはデフォルトでは非表示になってしかし、ツールバーのボタンがクリックされたときに表示されます。見る インタフェースのカスタマイズ 以下のためどのようにそれを再表示するには、潜在的に永久に表示されたままにしておきます。また、プロジェクト内の関連する要素に「ジャンプ」に検証ウィンドウ内の任意の行をダブルクリックすることができます。

検証ウィンドウ

次のように検証ウィンドウでデフォルトの列が記述されています。

警告またはエラー：この列には、違反が警告（感嘆符付きの黄色い三角形）またはエラー（クロスと赤い円）であるかどうかのアイコンが表示されます。

数：この列には、違反の数が表示されます。

注意

唯一の200違反が一度に表示され、プロジェクト内の200以上の違反がある場合、ウィンドウの右上にある[スタート]、[前のページ、次のページおよび終了行ナビゲーターは、追加の違反を閲覧するために使用することができます。

説明：これは、エンティティと関係の制約などの違反の完全な記述です。

エンティティ：この列には、違反への懸念のエンティティが表示されます。

タイプ：この列には、エンティティの要素の型が表示されます。

アーキテクチャ：この列には、違反が発生している内アーキテクチャが表示されます。

検出されました：この列には、違反が検出された時刻が表示されます。

先端

これは、最新の違反がリストの「トップ」に表示されます保証するために、（上記のダイアログに示すように）検出された列で降順にソートすると便利です。

背景モデルの検証の動作を変更するには、いくつかのユーザーオプションがあります。例えばtのo デフォルト以外のものに制約違反のために使用される色を変更します 赤、 クリック ツール上で| オプション... その後に行きます ザ・ 検証タブ、および 経由して色を設定 変化する ボタン。

検証 オプション

手動で制約を検証するために、

1。 右クリック上の アーキテクチャいずれかのノードで、どんなアーキテクチャやどこでも コンポーネントまたは 接続エクスプローラビューの一部を選択 制約を確認してください.

制約を検証

2。 クリック 細部上のボタン 警告アーキテクチャが定義されている任意の制約に違反して場所を確認するウィンドウ。

注意

違反のみが警告さや強制に設定されているこれらの制約のために示されています。さらに、警告の文言は、制約は単なる警告であったか、強制された場合は「しなければならない ''べきである」場合に含まれます。

3。 クリック [OK].

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入


あなたのアーキテクチャの進化

ナビゲーション：手動]> [追加オプション>取り込み>あなたのアーキテクチャへの移入

あなたのアーキテクチャの進化

コメントを送信 このトピックに関する。

アーキテクチャは、明示的に進化し、アーキテクチャの階層を作成することができます。したがって、ABACUSであなたのアーキテクチャの進化により、高度な建築ソリューションの数は、作成した比較およびベースラインすることができます。目標（またはメトリック）は、既存のアーキテクチャのための建築任意の数のプロパティを定義することができます。

アーキテクチャの進化を検討するための簡単​​な方法は、概念に関連すること 子孫アーキテクチャ。アーキテクチャが進化したとき、 コピー親アーキテクチャを作成されます。このコピーは、直接であるといえます 子孫オリジナルの 親 アーキテクチャ。

注意

このオンラインヘルプドキュメントとABACUSツールセット自体では、用語 進化しますより一般用語よりも使用されています 子孫、両方が同じ機能性を指すことに注意してください。

既存のアーキテクチャを進化させるために、

1。 あなたが持っていることを確認 ABACUSファイルオープンと エクスプローラウィンドウ表示されました。

2。 あなたはエクスプローラツリーから進化したい、関連するアーキテクチャを選択します。

3。 右クリックアーキテクチャ上を選択 進化させますメニューから選択します。

選ばれたアーキテクチャの進化

4。 進化したアーキテクチャでは、選択されたアーキテクチャの下に表示されます。

進化したアーキテクチャ

注意

進化したアーキテクチャは、アーキテクチャと選択を右クリックして名前を変更することができます 名前の変更.さらに、進化したアーキテクチャのすべての図やカタログは自動的に設定されます ベースラインアーキテクチャに対する「差分」 それから進化したこと。

あなたの進化アーキテクチャの目標を設定します

あなたの進化アーキテクチャの目標を設定すると、あなたのアーキテクチャの進化を評価するための基準を作成することができます。目標は、プロパティタイプとあなたの進化アーキテクチャ内の既存のこれらのプロパティの名前によって決定されます。目標はまた、手動で定義しアーキテクチャに追加することができます。目標を設定するには、以下の手順に従ってください。

あなたの進化アーキテクチャ用の既存のプロパティから目標を設定します

1。 あなたが持っていることを確認 ABACUSファイルオープンと エクスプローラウィンドウ表示されました。

2。 [ツール| 目標を設定しますメインメニューバーから。

3。 ザ・ 目標入力ウィンドウが表示されます。

目標入力ウィンドウ

4。 クリックします 現存します ボタン。

5。 ザ・ プロパティを選択しますウィンドウが表示されます。

6。 あなたの進化のアーキテクチャのためにあなたが目標として設定するプロパティを選択し、をクリックしてください [OK] ボタン。

7。 選択した目標は、今に表示されます 目標入力 ウィンドウ。

8。 目標を選択し、をクリックしてください 編集 ボタン。

9。 ザ・ 編集ゴールウィンドウが表示されます。

注意

このウィンドウでは、そのプロパティのプロパティ名と型目標が反映されます、だけでなく、最悪と最高値（または最小値/最大値）を変更することができます。これらの値は、すべてのアーキテクチャを比較し、その特定のプロパティのそれぞれにおいて、最小値と最大値を見つけることによって発見されます。これらの値は、手動で定義することができます。たとえば、あなたがいた場合、名前付きプロパティのための目標を設定します レスポンス（アベニュー）そして、タイプの 動作、あなたの最悪と最高値は、最適な性能（最良値）と、処理すべき唯一の主な用途のために必要な処理速度（最悪値）のために必要な処理速度を反映することができます。

10。 関連する値が定義されると、選択 [OK].

あなたの進化アーキテクチャ用の新しいプロパティのゴールを設定します

1。 あなたが持っていることを確認 ABACUSファイルオープンと エクスプローラウィンドウ表示されました。

2。 [ツール| 目標を設定しますメインメニューバーから。

3。 ザ・ 目標入力ウィンドウが表示されます。

4。 クリックします 新しい ボタン。

5。 ザ・ 新たな目標ウィンドウが表示されます。

注意

このウィンドウでは、プロパティ名とタイプ目標が反映されます、だけでなく、そのプロパティの最悪と最高値（または最小値/最大値）を定義することができます。たとえば、あなたがいた場合、名前付きプロパティのための目標を設定します レスポンス（アベニュー）そして、タイプの 動作、あなたの最悪と最高値は、最適な性能（最良値）と、処理すべき唯一の主な用途のために必要な処理速度（最悪値）のために必要な処理速度を反映することができます。

6。 関連する値が定義されると、選択 [OK].

7。 ダイアログへ すべてのアーキテクチャに追加以下のように表示されます。

8。 クリック はい関連するすべてのアーキテクチャにプロパティとしての目標を追加します。これは、新しく定義された目標とそのプロパティは、ファイル内のすべてのアーキテクチャに追加されることを保証します。あなたはアーキテクチャでプロパティを含めたくない場合は、上でクリックすることができます ノー.

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | あなたの進化アーキテクチャのスタープロットを表示 | あなたの進化アーキテクチャの散布図を表示します


描画ツール

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

描画ツール

コメントを送信 このトピックに関する。

描画ツールは、建築図と図の多種多様を作成することができます。建築家は、伝統的建築の設計を記録し、伝えるために異なる図面の範囲を使用しています。二次元（2D）図は、システムのさまざまな部分を文書化し、通信の通常の方法です。エンタープライズ・システムで使用される典型的な図面の種類は次のとおりです。

· ビジネス・プロセス・モデルや図。

· 組織チャート。

· コラボレーション図。

· エンティティ関連（ER）の図。

· データフロー図（DFDの）;

· クラス図。

· IDEF（上記のいくつかを組み込みました）。そして

· UML（上記のいくつかを組み込みます）。

実際に作成することができる図の種類に制限はありません。 ABACUSは、アーキテクチャの整合性と表現のその形態を維持しながら、図の柔軟性のバランスをとろうとします。

描画環境であります タブ付きとドッキング可能なウィンドウ メインABACUSアプリケーションの内部。このウィンドウには、第二の描画が行われ、描画ウィンドウが開いているときにキャンバスが含まれています ドッキング可能なウィンドウ 、ステンシルウィンドウは、図面ステンシルのセットで閲覧可能です。コンポーネント、接続、図形とコネクタ：ステンシルペインには、4つのタブがあります。キャンバスが細かいグリッド線（レイアウトするのに役立つ）と白の背景として表示されます。

接続が指示線として描画されている間構成要素は、形状の範囲で表されています。接続が使用してコンポーネントにアタッチ 役割 （すなわち、ソースまたはシンクのいずれか） これらが、美的理由のために図示されていません。

先端

一方 図システムの異なる部分を示すために非常に有用であり、それらは、ABACUSに複雑なシステム構造を可視化するために、3Dを使用する理由は、そのスケーラビリティが制限されます。

あなたがしたいこと

1。 開きます 作図 ツール

2。 新しい図を作成します あなたのアーキテクチャの一部の

3。 図をコピーします 内またはアーキテクチャ間

4。 コンポーネントを追加します 図を

5。 新しいコンポーネントとの接続を作成します。 あなたのアーキテクチャでは（概略）描画ツールを使用して、

6。 コンポーネントの削除 図から

7。 取り付け＆接続を操作します

8。 変更 表示特性 構成要素との接続。

9。 内のリンクを使用して ダイアグラム

10。 種類の関連付けを強制し、 視点 描画することができる図の種類を制限するようになっています。

参照してください

あなたのアーキテクチャへの移入 | 手動であなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


ダイアグラムを開きます

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

ダイアグラムを開きます

コメントを送信 このトピックに関する。

図を開くか作成されたときに描画ステンシルとキャンバスウィンドウが自動的に表示されます。ダイアグラムが閉じている場合も同様に、キャンバスウィンドウの対応するタブ付シートが消え、それ以上の図面が開いていないならば、ステンシルウィンドウが閉じられています。

に 作ります新しい図

1。 あなたが持っていることを確認ABACUSファイルオープンあなたを含みます 人口アーキテクチャ.

2。 クリックします Diagram表示ツールバーのアイコン。

- または -

2。 選択 インサート| Diagram.

- または -

2。 右クリックザ・ ダイアグラム与えられたのブランチ アーキテクチャツリーのセクションを選択 作り出します ダイアグラム.

3。 選択 アーキテクチャあなたは、プルダウンメニューから、ピントを合わせたいです。注：新しいダイアグラムを開くためには、上記のステップ3を使用した場合のアーキテクチャは、すでにあなたのために選択されています。

4。 選択 観点 あなたは、プルダウンメニューから使用します。注：選択された視点は、視点で使用可能な唯一のものにするコンポーネントとの接続のリストをフィルタリングします。

5。 必要に応じてからビューを選択 ビューによってフィルタープルダウンメニューを選択したビューからのコンポーネントとの接続を事前に選択。注意：これは効果的に保存されたクエリとして選択されたビューを使用しています。

6。 選択 レイアウト いずれかに ラジアル または グリッド.

7。 選択 コンポーネント そして 接続あなたはから図にしたいこと 標準の要素の選択ウィンドウ .

8。 クリック [OK].

注意

新しいダイアグラムが追加され ダイアグラムアーキテクチャの枝。それはあなたがそれを右クリックして、後で変更することができ、デフォルトの名前を持つことになります。また、コンポーネントおよび接続選択フィルタの最後の状態は、図が効果的に図を作成するために使用される「クエリ」を保存で保存されます。

既存のダイアグラムを開くには

1。 特定の人口のアーキテクチャでは、拡大 ダイアグラム木の枝。

2。 ダブルクリック 図は、あなたが開きたいです。

図を保存するには

1。 あなたは、新規または既存の図を持っていることを確認してください オープンあなたは、必要な変更を行いました。注：保存する変更がある場合は、アスタリスク '*'は、タブ付きシートヘッダー内のビュー名の後に表示されます。

2。 エクスプローラービュ​​ーでをクリックしてください セーブボタンまたはになりました ファイル| セーブまたは低下させます Ctrl + Sキーお使いのアーキテクチャのすべての変更を保存し、それをファイルに書き込みます。

ダイアグラムを保存するには 観点

1。 あなたはABACUSファイル内の既存の図を持っていることを確認してください。

2。 右クリックのダイアグラム ダイアグラムツリーの一部。

3。 選択 名前を付けて保存 図の見方.

4。 新しいの名前を入力します 図の視点クリックします [OK].

参照してください

描画ツール | あなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


コピー・ダイアグラム

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

コピー・ダイアグラム

コメントを送信 このトピックに関する。

既存の図をコピーする2つの基本的なシナリオがあります。アーキテクチャ内、またはアーキテクチャ間.

に コピーダイアグラムアーキテクチャ内

1。 あなたが持っていることを確認ABACUSファイルオープンあなたを含みます 人口アーキテクチャ少なくとも1つと ダイアグラム.

2。 拡大ザ・ ダイアグラム ブランチ （および任意の必要な 図のグループ) について アーキテクチャツリーのセクション.

3。 あなたがコピーして押したい図を選択 Ctrl + Cキーまたは 右クリック選択し コピー メニューから.

注意

A のコピー ダイアグラムが追加され ダイアグラムのブランチ 同じ アーキテクチャ。それは持っています 名前の先頭に付加」のコピー」、あなたは、後で変更することができました F2キーまたはを押して その上で右クリック名前の変更を選択します.

に アーキテクチャ間で図をコピーします

1。 あなたが持っていることを確認ABACUSファイルオープンあなたを含みます 人口アーキテクチャs少なくとも1つと ダイアグラム.

2。 拡大ザ・ ダイアグラム ブランチ （および任意の必要な 図のグループ) の ザ・ アーキテクチャツリーのセクションあなたがコピーしたい図が含まれていアーキテクチャの。

3。 コピーしたい図を選択し、上 一般プロパティ窓ノート 観点 図は（Typeフィールドで）にリンクされています。

4。 今、 拡大しますザ・ ダイアグラム ブランチ （および任意の必要な 図のグループ) の ザ・ アーキテクチャツリーのセクションあなたに図をコピーしたい他のアーキテクチャのための。

5。 右クリックザ・ ダイアグラム ノード（または 図のグループ）を選択し ダイアグラムを作成します...。選択表示されたダイアログで 観点 それは、右上のドロップダウンで上記のステップ3で注目されました。であるとして他のすべてのままにしてクリック [OK]。図名ダイアログで（すぐになるように）コピーされたダイアグラムの名前を入力します。注：選択された視点に応じて、空白の図のキャンバスが開きます。

6。 あなたがすることによってそれをコピーして、開きたい図に戻ります 右クリックノードと選択 オープン または単に ダブルクリックそれ。

7。 背景を選択します コピーしたいダイアグラムのキャンバスとプレス Ctrl + Aキー。これは、ダイアグラム上のすべての要素を選択します。今プレス Ctrl + Cキークリップボードに内容をコピーします。

8。 さて、あなたにコンテンツをコピーしたいアーキテクチャの空白図に戻り、 背景を選択キャンバスとのいずれか 右クリック選択し ペースト または単にプレス Ctrl + Vキーコンテンツを貼り付けます。短い時間の後、コンテンツはすべての新しい空白の図に貼り付けられます。

注意

要素は、新しいアーキテクチャの最上位に追加され、再配置する必要があるであろう、または 合併 それに応じて既存のコンテンツと.

参照してください

描画ツール | あなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


移入ダイアグラム

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

移入ダイアグラム

コメントを送信 このトピックに関する。

ABACUSで図面は、単に任意の表現以上のもの。彼らは、アーキテクチャのビューをカスタマイズフォーマットされ、特定の意味を表示するように配置されています。

効果的要素の「平面図」を与える - コンポーネントが視覚的に他のコンポーネント内にネストされるように、描画ツールは、アーキテクチャの階層構造を適用します。部品または接続がアーキテクチャで定義された後、それは、異なる図の任意の数で使用することができます。どちらか一方で行われた変更は、常に他にも反映されるように重要なのは、描画ツールは密接に、建築モデルにリンクされています。

このツールは、アーキテクチャの種類]セクションで定義された特定の接続とコンポーネントタイプの形状を関連付けることによって動作します。これらの団体は、描かれている図の種類によって異なり、それは一成分の種類（または接続）が状況に応じて、異なる図において異なる表現を有することが可能です。

形状や部品や接続タイプとの間の関連付けを設定するには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 ABACUSアプリケーションを最大化し、 ウィンドウの比率を設定します あなたが望むように。

3。 選択 シェイプ]タブ または コネクタ]タブ ステンシルウィンドウに表示されます。

4。 の中に タイプエクスプローラの枝、シェイプやコネクタに関連付けしたいコンポーネントまたは接続タイプを探します。

5。 ツリーから選択したタイプの要素を選択し、シェイプタブまたはコネクタ]タブにそれを上にドラッグし、 形状やコネクタの上にドロップしますあなたが使用したいと思います。

注意

あなたが現在関連付けられている要素を表示しステンシルウィンドウ内のコンポーネントまたは[接続]タブを選択して作成した関連付けを確認することができます。

あなたのダイアグラム/ライブラリに新しい図形を追加するには

1。 あなたがダイアグラムに追加する形で、MS Visioの図を作成し、 MS Visio図をインポート .

先端

ABACUSキャンバスをピクセル単位でサイズのとMS Visioでのみミリメートル単位は1ミリ比4ピクセルの画素に粒状に変換されるので、それはあなたが、MS Visioでマスタシェイプを作るもののサイズが重要です。また、デフォルトABACUS形状は典型的には60ピクセルの高さですので、それは、MS Visioで15ミリに変換されます。お勧め意味 MS Visioでマスタシェイプのサイズあります 高15ミリメートル、幅25ミリメートルこれはABACUSの高い60ピクセルにより、広い100ピクセルに変換されるように。

先端

シェイプの左上隅にある小さな「アイコン」を持つようにしたいなら、あなたは単にMS Visioの描画ツールパレットを使用して、マスターのMS Visioのシェイプの「アイコン」を作成することができます（つまり、単純な線、円の点に注意してください。や長方形）がサポートされており、特に、ラスタライズ/ビットマップの形状はサポートされていません。また、必要に応じてアイコンがあることを サイズ/スケールで固定その後のことができます。グループのすべての要素を選択することによって、マスターMS Visio図形の「アイコン」を右クリックして一つの要素、形状を選択ABACUSで形状内|グループは、右クリックしグループ化された形状をし、データを選択|形状データ...、表示されるダイアログで[はいを選択してからに設定されたラベルを持つプロパティを追加 LockScaleに設定タイプ（大文字の 'L'と 'S'を注意してください） ブーリアン そして、設定した値であることが判明しました TRUE （それはすべて大文字であることに注意）。

先端

あなたが水平または垂直（「スイムレーン」形状の典型的であるように）スケーリングから凍結形状の部分を持つようにしたい場合は、あなたはスケーリングから冷凍するマスターのMS Visioの形状の部分（複数可）を右クリックすることができますデータを選択|形状データ...、表示されるダイアログで[はいを選択してからに設定されたラベルを持つプロパティを追加 LockXScaleまたは LockYScale に設定タイプ（大文字の 'L'と 'S'を注意してください） ブーリアン そして、設定した値であることが判明しました TRUE それぞれ水平または垂直スケーリングをロックするために、（それはすべて大文字であることに注意）。

先端

インポートではなく、形状は常にそれがマスターのMS Visioの図形の塗りつぶしを作成することをお勧めし固定色された後にABACUSにおける形状の着色を可能にするために、 トランスペアレント して、図形の背景を着色するABACUSで作り付けの機能を使用しています。全体の長方形の背景が着色されるように、これは、長方形またはほぼ長方形（例えば角の丸い四角形）の形状に対応しています。

2。 対応する図を開き、選択 [コンポーネント]タブステンシルウィンドウに表示されます。

3。 あなたは他の図を利用できるようにするそれぞれの新しい形状について 右クリック形状を選択 図形ライブラリに追加。これは、ステンシルウィンドウ内の図形タブの形状が利用できるようになります。

4。 上記の手順に従って、シェイプライブラリから新しい形状の関連するコンポーネントタイプを関連付けます。

注意

単純なおよび「ベクターベース」の形状は、現時点ではABACUSでサポートされている、すなわちビットマップはサポートされていません。しかし、このようなベクター魔法のようなツール（ www.vectormagic.com ）容易にMS Visioで開かれ、したがって、上記の指示に従ってABACUSで利用することができるベクトルベースの​​形状（すなわちSVG形式）にビットマップイメージに変換することが可能です。

追加コンポーネントとの接続

描画ツールは、あなたがすることができます リポジトリから既存のコンポーネントと接続を追加したり、 あなたが図を描いているように、新しいコンポーネントとの接続を作成します。構成要素および接続は図に作成されると、それらは同時にに添加します リポジトリ。がある 推奨3 図にコンポーネントを追加する方法そして、3は図に接続を追加する方法をお勧めします:

図上で完全に新しいコンポーネントまたは接続を作成するにはステンシルから

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 選択 コンポーネントまたは 接続ステンシルウィンドウのタブは、関連する図形を表示します。唯一のこれらの形状は、新たなモデル要素を作成するために使用することができます。

3。 クリックしてドラッグ描画キャンバス上に利用可能な関連した形状の一つ。新しい要素がキャンバスにし、エクスプローラのツリーに表示されます.

4。 入力を開始します新しい要素の名前 ダイアログと一致している既存の要素で提案されており、むしろアーキテクチャに新しい要素を追加するよりも選択することができます。

5。 クリック [OK].

6。 形状は既存のコンポーネントの上にドロップした場合は形状がから来たならば、それはどちらか（そのコンポーネントの子になります コンポーネント形状がどこから来た場合はタブ）、または（そのコンポーネントに添付されます 接続 タブ）。

注意

これは、エクスプローラを使用して建築階層内の別の場所に新しいコンポーネントや接続を調整する必要がある場合があります。

から既存のコンポーネントまたは接続を配置するには リポジトリ 図の上に

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 あなたが描画ツールとExplorerのウィンドウ表示可能なの両方を持っていることを確認してください。

3。 エクスプローラで、探し 成分または 接続（エレメント）は図に追加したいと思います。

4。 クリックしてドラッグダイアグラム上に選択した要素。要素を表す形状がキャンバスに表示されます。

注意

選択した要素の型が既に形状に関連付けられている場合、対応する形状がキャンバスに表示されます。しかし、その特定の要素には定義された関連付けがない場合は、デフォルトの形状（長方形）がない限り、キャンバス上に表示されます ダイアグラムを強制 視点 オプションでは、形状が図に追加されません。その場合にはオンになっています。

先端

コンポーネントがダイアグラムにすでに別のコンポーネントに接続されている図に配置されている場合、あなたがそれらの間の接続（複数可）を表示したい場合には、描画ツールを照会します。コンポーネントの子がある場合は、子供たちを含めたい場合にも、描画ツールは、再帰的に、照会します。

に ダイナミックコネクタを使用してダイアグラムの2つのコンポーネントまたは接続されたコンポーネント間の接続を作成します

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 ホバー あなたが別のコンポーネントに接続したいとあなたは以下に示すように2アイコンが形状の境界の右上外側に表示がわかります図上のコンポーネント上。注：一番上のアイコンをホバーコンポーネントが元となる接続を作成するために、下部のアイコンがホバーコンポーネントはシンクとなる接続を作成するためです。

3。 移動 目的のアイコンの上にカーソルと クリックしてドラッグ以下に示すように、キャンバス上の別のコンポーネントまたは空き領域の上のいずれか以上にアイコンが表示されます。

4。 既存のコンポーネントに接続するには選択します にアタッチ...ポップアップメニューの項目およびサブメニューに必要な閲覧は、利用可能な接続の種類から選択します。

- または -

4。 連結成分から選ん作成するには 新しい...以下に示すように、サブメニューに必要な閲覧ポップアップメニューの場合とアイテムが利用可能な接続の種類から選択します。入力を開始します新しい要素の名前 ダイアログと一致している既存の要素で提案されており、むしろアーキテクチャに新しい要素を追加するよりも選択することができます。

注意

ポップアップメニューとサブメニュー内の項目の可用性はによって支配されます 制約 メタモデルで.接続制約によって決定されるようなことは、唯一の有効なソースまたはシンクコンポーネントタイプでは、...に接続し、新規...メニュー項目として表示されます。

に 要素の選択ダイアログを再オープンし、ダイアグラム上にリポジトリからコンポーネントまたは接続を既存の配置

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 クリック ザ・ オープン要素の選択図ツールバーにあるボタン。注意： 要素の選択ダイアログ 保存された任意のフィルタの最後の状態で開きます。

3。 図に追加されることが望まれる任意の追加コンテンツを選択してクリック [OK]。注：新しいコンテンツがキャンバスに明確なスペースに追加され、図は、その後することができます 再びレイアウト 経由 見取り図図ツールバーにあるボタン。

無料使用形態シェイプ

それは純粋に美的な理由のために図中のビジュアル要素を作成することが望ましい場合が多いです。これらの要素は、図のレイアウトと外観を向上させることがあり、まだ彼らは厳しい建築的意義を持っていません。描画ツールは描画の柔軟性を提供する自由形式の形状を使用することができます。

ダイアグラムにフリーフォームの図形を追加するには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 選択 シェイプまたは コネクタステンシルウィンドウのタブ。

3。 クリックしてドラッグ描画キャンバス上に利用可能な形状やコネクタのいずれか。新しい要素がキャンバスに表示されます - しかし、 ではありませんエクスプローラツリーインチ

注意

彼らはアーキテクチャモデル内の任意の特定のコンポーネントまたは接続との関連を持っていないとして、フリーフォーム形状は、「非関連」の形です。

に でリポジトリの情報を表示 フリーフォームの形状息子ダイアグラム

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 右クリックフリーフォームの形状を選択 注釈|表示.

3。 いずれかを表示するかを選択します 図名, 図の説明, ダイアグラムプロパティ, 視点名または アーキテクチャ名.

注意

自由形式のテキストが自動的に基礎となるリポジトリデータの変化に応じて更新されます.このように、図「タイトルブロックが」のために作成した後、簡単に、図を越えてコピーすることができます。

フローティングシェイプを使用しました

フローティング形状は、基本的に図の構成要素を表現する別の方法です。最高経営責任者（CEO）、マーケティング、販売および開発：キーの部門を持つ組織を考えてみましょう。

ツリー表示

これらの部門は、視覚的に層状に表すことができます。

レイヤーの表示

あるいはそれらは視覚的に千鳥状に表すことができます。 / フローティング 階層を表示する方法：

互い違いの / フローティング 見ます

後者の表現は浮動図形の概念を使用します。

フローティング状に層状の部品形状を変換するには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 選択 成分ダイアグラムでは、浮遊状又は関連する形として表現したいです コンポーネントステンシルウィンドウのタブでは、フローティング形状など、すべてのインスタンスをしたいです。

3。 シェイプを右クリックし、 コンポーネントのフロート 表示されるコンテキストメニューから。注意 ダイヤモンド向かっ接続浮遊成分（複数可）への親コンポーネント（複数可）から。

4。 クリックしてドラッグ所望の場所にコンポーネント。とき フローティングコンポーネントは、それが青のアウトラインを持つことになり、選択されています。

層状に浮遊部品形状を変換するには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 選択 成分現在で浮動形状または関連形状として表示されているダイアグラムで コンポーネントステンシルウィンドウのタブでは、層状形状として、すべてのインスタンスをしたいです。

3。 クリックしてドラッグバック親（複数可）に浮遊成分（単数または複数）（に従って ダイヤモンド向かっ接続）。注意：あなたが戻ってあなたのモデルの階層が影響を受ける可能性がある重層されることに成分を変換するときには、このようにしないと。

4。 形状や非選択を右クリックし、 コンポーネントのフロート 表示されるコンテキストメニューから。ことに注意してください ダイヤモンド向かっ接続親コンポーネント（複数可）からの浮遊成分（複数可）に表示されなくなります。

レプリカ

描画ツールは、あなたがすることができます レプリカと呼ばれるダイアグラム上のコンポーネントの追加の各視覚インスタンスを図に数回、同じコンポーネントを追加します。これは、コンポーネントがそれに接続されている多数の接続を持っており、それが近いの各接続の起源に複数の場所にコンポーネントを表示することが好ましい図の特定に有用であるか、または1対多の関係図について成分からそれが関連して「多くの「コンポーネントの上の複数の場所でのコンポーネントで（上記）のフローティング機能を使用して表示することが好ましいです。

注意

接続が自動的に図に追加されたときは、/取り付けだけでなく、レプリカのいずれかに（いつものように）図に、コンポーネントの元のインスタンスへ/からの接続を切り離すことができ、しかし、彼らは、コンポーネントの最初のインスタンスに接続されていますデフォルトでは、ダイアグラム上。

注意

レプリカはによって相互にマージすることができます 右クリックしてドラッグその後選択 レプリカのマージしかし、別のコンポーネントでレプリカをマージすると、図から消え、他のレプリカになります。

注意

図と任意のレプリカ上のコンポーネントの元のインスタンスの間には視覚的な違いはありません。さらに、図と任意のレプリカで元のコンポーネントの右クリックメニューは、例えばで、同じです エクスプローラーに書いてある（モデル別名）リポジトリのツリービューで同じコンポーネントにあなたを取ります。しかし、リポジトリのツリービューでコンポーネントを右クリックして選択します へ行きますレプリカとの図をブラウジングが常にダイアグラム上のコンポーネントの「最古」のインスタンスが表示されます。通常、これは図に追加された元のインスタンスになりますが、その元のインスタンスが、その後削除またはレプリカと合併したならば、移動するためには、追加された残りのレプリカの最古にジャンプします。

に にレプリカを追加 ダイアグラム

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 図に既存のコンポーネントを右クリックし、 レプリカを作成します。.選択したコンポーネントの複製は、元のコンポーネントの右に作成されます。

- または -

ダイアグラムを押し上の既存のコンポーネントを選択します Ctrl + Cキーまたはダイアグラム上の既存のコンポーネントを右クリックして選択 コピー。今、あなたはレプリカをしたいダイアグラム上の場所を右クリックして選択し レプリカとして貼り付け。注：Ctrl + Vキーを押す（または右クリックをし、[貼り付け]を選択すると）元の構成要素ではないレプリカのコピーを作成します。

- または -

クリックしてドラッグコンポーネントが既に存在する図の上にリポジトリ（別名モデル）のツリービューからコンポーネント。

接続キャップ/エンドの設定

描画ツールは、あなたがすることができます 接続自体のプロパティに依存して、固定シンボルまたはシンボルに接続線のいずれかの端部で使用されるシンボルを設定.これは、接続の方向を示すことが必要である図のために特に有用である、または接続（または方向）のカーディナリティは、接続自体のプロパティに含まれている図の、例えば「多対多」VS「対多ワン '（または'ソースへのシンクの「対」ソースは、シンクに '）。

に 接続キャップを設定/の終了 ダイアグラム

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン.

2。 選択 つなぎますイオンステンシルウィンドウのタブ。

3。 右Cなめます 一つ 関連する接続の種類を選択 キャップを設定し....

4。 どちらかのソースで固定接続キャップ/終了の場合または接続の終了をシンク関連することを確認してください 一定 ラジオボタンを選択し、その後、例えばプルダウンから接続終了記号を選択しています「アローヘッド」または「ダイヤモンド」.

- または -

どちらかのソースでのプロパティベースの接続キャップ/終了の場合または接続の終了をシンク関連することを確認してください プロパティの使用ラジオボタンが選択され、その後、「...」ボタンをクリックして必要なプロパティを選択し、次の各接続端シンボルに、特定の接続シンボルが表示されるべきのプロパティ値を入力します。

注意

指定された接続の終了記号のための複数のプロパティ値は、カンマで区切って入力することができます. 例えば。以下のダイアログがあれば「データことを示し|カーディナリティ」、接続のソース端は、2つの行がそれを介してストロークし、接続のシンク側がそれを介して1ラインのストロークを持っており、2つのファンアウトされますがあります一対多 'プロパティは値を持っています」行が最後にストローク。

キャップダイアログを設定

参照してください

描画ツール | あなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


操作ダイアグラム

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

操作ダイアグラム

コメントを送信 このトピックに関する。

図が作成されたら、その中に表示される要素を再配置することができ、再サイズの望まれます。

図にコンポーネントを移動するには

1。 既存していることを確認してください 図オープン .

2。 クリック・アンド・ホールドそれを移動するための任意のコンポーネント。選択したコンポーネントが親を持つ場合、親コンポーネントが強調表示されます。

3。 要素であるようにドラッグ その親コン​​ポーネントからの、およびその他のコンポーネントの上に、「潜在的な」両親が強調表示になります。 使用するカラースキームは、操作は現在のプロジェクトでの警告やエラーに与える影響を示し、に記載されています 制約の定義と検証 。 このようにして、グラフィカルに「平面図」から階層を移動することができます。

4。 解放その新しい場所に要素をドロップするマウスのボタンを押します。

注意

また、描画キャンバス上の要素位置の再キーボードを使用することができます。単にあなたが移動し、目的の場所に図形を移動するには、キーボード上にある矢印キーを使用するコンポーネントまたはフリーフォーム形状を選択します。

また、別のコンポーネントの上にマウスでコンポーネントをドラッグするとドラッグしているコンポーネントの左上隅には、別のコンポーネントと重なったときに、「潜在的な」親コンポーネントが強調表示されていることに注意してください。

先端

フリーフォーム そして フローティング形状 によって注文することができます 右クリックそして、選択 前面に移動または 背面へ移動メニューから選択します。それによって、フリーフォームの形状に変換することができ、そのコンポーネントの形状に注意することが重要です 右クリック特定のコンポーネントの形状や選択に フリーフォームに変換.

図中のコンポーネントのサイズを変更するには

1。 既存していることを確認してください 図オープン .

2。 クリックしてホールドドラッグコンポーネントのハンドルのいずれかと所望のサイズに形状のサイズを変更します。

3。 あるいは、図形の縦横比を維持するために、押し Shiftキー+クリックホールドドラッグ.

図中の接続を移動するには

1。 既存していることを確認してください 図オープン .

2。 クリック・アンド・ホールド任意の接続は、それを移動します。

3。 解放その新しい場所に要素をドロップするマウスのボタンを押します。

注意

あなただけのすべてのコンポーネントに添付されていない接続を移動することができます。それらが結合している場合は、あなただけの自由端を移動することができますs、または 再ルーティング接続 .

コンポーネントおよび接続の削除

図から部品や接続を削除するときは、アーキテクチャ全体からそれを削除するオプションがあります。アーキテクチャから削除されているすべてのコンポーネントが自動的に表示され、他の図から削除されます。フリーフォームのインスタンスは一つだけの図に表示されますので、それらを削除するアーキテクチャモデルまたはその他の図には影響しません。

図から部品や接続を削除するには

1。 既存していることを確認してください 図オープン .

2。 クリック関連するすべての接続またはコンポーネントでそれを選択します。

3。 プレス 削除図からそれを削除するためのキー、または + Shiftキーを押しながら削除モデル全体からそれを削除します。

- または -

2。 関連する要素またはコンポーネントを右クリックします。コンテキストメニューが表示されます。

3。 選択 ビューから削除または から削除 アーキテクチャコンテキストメニューから。

注意

あなたはビューから削除したい要素に子がないだけ、そのビューで発生した場合、ABACUSはあなたにもリポジトリから要素を削除するかどうかを尋ねます。

注意

子コンポーネントを持つモデルからコンポーネントを削除すると、子どもたちはまた、潜在的に、警告ダイアログに応じて削除されます。

マージコンポーネント

既存の二つの成分をマージすることができます 同図の（およびアーキテクチャ内）。これは多くの理由のために行われてもよいです、 例えば、 二つのサーバは、会社のinfrastructure- H内に存在します01 H02.これらの二つのサーバは、アーキテクチャ内の2つのコンポーネントとして表されます。 H0図1は、不必要と考えられ、したがって、使用停止させるされています。 H上で実行されているすべての既存のアプリケーション0図1はHにシフトされます02（まだ手数料で）。この変更は、2つのコンポーネントH "にマージ」の作用により反射させることができます01 H02 図の（と アーキテクチャ内).

マージの詳細な説明についてはマージアイテムのトピックを参照してください。 ここに .

2つの既存のコンポーネントをマージするには

1。 既存していることを確認してください 図オープン .

2。 右クリックし、ホールドコンポーネントにマージすると、 ドラッグそれはコンポーネントの上にあなたがそれをマージします。宛先コンポーネントの輪郭が、それが選択されていることを示す赤の強調表示されていることを確認します。

3。 選択 マージ|先を保存または 上書き先メニューから選択します。

注意

ザ・ 先を保存彼らは同様に元のコンポーネントに存在する場合、このオプションは、送信先コンポーネントのプロパティの値を保持します。

ザ・ 上書き先オプションは、元のコンポーネントから任意の一般的な性質と宛先コンポーネントのプロパティを上書きします。

接続を変更

図のように接続 常にアーキテクチャ自体に定義されたような構造を反映しています。描画ツールを使用すると、コンポーネントからの接続を切り離し、それらを移動することができ、 カーブ、それらは、再ルーティングし および他のコンポーネントにそれらを再接続します。

コンポーネントへの/からの接続をアタッチ/デタッチするには

1。 既存していることを確認してください 図オープン .

2。 クリック・アンド・ホールド任意の接続に。

3。 選択接続 終わり（すなわち、 ソースまたはシンク）アタッチ/デタッチしたいこと。注：接続端は、小さな白丸で示されている第二のための白い円の上にマウスを移動すると、それぞれに表示される「ツールチップ」を引き起こします 役割 名（すなわち、ソースまたはシンクのいずれか）.

4。 ドラッグ接続は、新しい場所（空いている場所またはコンポーネントのいずれか）に終了し、マウスボタンを離します。

注意

接続端が有効なコンポーネントの上に配置されたときに、宛先コンポーネントの概略を点線で強調表示されています。 使用するカラースキームは、操作は現在のプロジェクトでの警告やエラーに与える影響を示し、に記載されています 制約の定義と検証 。 いったん解放 目の端e 接続とコンポーネント 自動的に接続されています（または添付）、これはアーキテクチャモデルに反映されます。

再ルーティング接続に

1。 既存していることを確認してください 図オープン .

2。 接続の上にマウスポインタを置きます。

3。 ホールド シフトキーダウンし、 クリックマウスボタンが接続アンカー・ポイントを配置します。リリース シフト キー。あなたは、同じ操作を行うことにより、アンカーポイントを削除することができます。

4。 クリックとドラッグ再ルーティングするためのアンカーポイント接続。

先端

使用Altキー キーの代わりに、 シフト直交接続を作成するための鍵。

に カーブまたはまっすぐ接続

1。 既存していることを確認してください 図オープン .

2。 接続の上にマウスポインタを置きます。

3。 右クリックトン彼の接続を選択し、表示されるコンテキストメニューで 曲線, 直交します または まっすぐ.

先端

すべての接続図上で指定されたタイプは、上のタイプに関連した行を右クリックすることでストレート湾曲、直交またはに設定することができますの [接続]タブの ステンシルウィンドウ曲線、直交またはストレートを選択.

に 形状のエッジ上の特定の点に固定

1。 既存していることを確認してください 図オープン .

2。 接続を選択します。

3。 上にマウスポインタを置きます の末尾に「白点」 接続。

4。 右クリックトン彼接続端を選択し、表示されるコンテキストメニューで 形状にエンドポイントをアンカー.形状のエッジ上の所望の位置に接続端を移動します。

OR

ホールド Ctrlキーキーダウンし、 cなめるとドラッグザ・ 接続端 指し示す 形状のエッジ上の欲求の場所。

注意

接続は、その接続された形状の実際の切片の代わりに、その形状のバウンディングボックスにスナップします。

参照してください

描画ツール | あなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


描画ツールの機能

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

描画ツールの機能

コメントを送信 このトピックに関する。

描画ツールは、描画機能をサポートしています。

ズーミング

図面の縮尺は、ズーム機能を使用して変更することができます。

スケールまたは「ズームイン」を減少させるために、

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 押す Ctrlキー'='キー。

- または -

2。 選択 ズームイン上のボタン Diagramツールバー。

- または -

2。 押す Ctrlキーマウスホイールを回転 フォワード。注：このモードでは、キャンバスは、マウスがキャンバスの上にマウスを移動した場合に向かってズームします。

規模を大きくするか、「ズームアウト」に

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 押す Ctrlキー' - 'キー。

- または -

2。 選択 ズームアウトする上のボタン Diagramツールバー。

- または -

2。 押す Ctrlキーマウスホイールを回転 後方。注：このモードでは、キャンバスは、マウスがキャンバスの上にマウスを移動され、そこから外側にズームします。

自動レイアウト

図中の構成要素のレイアウトを自動的に変更することができます。

レイアウトに すべて コンポーネント on個の図

1。 Cなめます ザ・ 見取り図図ツールバーのボタン.

2。 選択どちらか 放射状配置 または グリッドレイアウト.

注意

放射状のレイアウトは、未接続のコンポーネントが離れて強制されている間の連結成分が一緒に描かれているような「力指向」アルゴリズムと呼ばれるものを使用します。グリッドレイアウトは固定幅と高さ間隔アルゴリズムを使用します。以下に示すようにして、両側にし、列と行の間隔：それは、まずユーザーは全体図の縦横比（9、A4（ポートレート）、手紙（風景）、例えば16）を選択することができます.それは単に、キャンバスの左上から右下に（自分の名前で）アルファベット順にコンポーネントを配置としてグリッドレイアウトでコンポーネント間のすべての接続は、レイアウトに影響を与えません。両方のアルゴリズムでは、フリーフォームの形状が移動されません。

レイアウトに 子供 コンポーネント 単一の親Oでn個の図

1。 右クリックその子供あなたは、自動レイアウトにご希望のハイレベルのコンポーネント。

2。 選択 レイアウトの子供.

注意

デフォルトでのみラジアルレイアウトアルゴリズムが使用され.

要素を変更します 美学 以下のような 色、 透明、影と回転

すべての図の要素は、必要に応じて操作することができる美学を持っています。関連した形状の場合には、これらの側面を設定することができます タイプごとにほとんどの場合においても インスタンスごと。自由形式の形状の場合には、これらのプロパティを設定することができます インスタンスごとキャンバス上。

注意

同じ態様は、対応するタイプに変更された場合、関連する形状に設定された任意のインスタンスごとの側面が「上書き」されます。

関連する形状の色やフリーフォームの形状を変更するには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状またはフリーフォーム形状。

3。 選択 カラー変更.

4。 選択 固定カラーラジオボタン（該当する場合）。

5。 基本カラーを選択するか、ダイアログにカスタムカラーを定義し、クリック [OK].

- または -

4。 選択 勾配ラジオボタン（該当する場合）。

5。 横長、縦長、前方斜めまたはプルダウンとクリックで勾配方向のための斜め後方のいずれかを選択してください [OK].

6。 基本カラーを選択するかのダイアログでカスタムカラーを定義します 開始 そして 終わりクリックします [OK].

注意

ABACUSは、形状の場合のフォアグラウンドに色をします。
A）それは、単一の基盤となるのグラフィカル要素（例えば円、矩形、多角形など）を備えた「シンプル」な形状ですか、
B）それは互いにまたはsubshapesがLockScale = TRUEセットを持っているように、すべて同じ色/グラデーションされた複数の基礎となるsubshapesと「複雑な」形状です。
上記の条件が満たされない場合は、図形の背景が着色されています.

特性に応じて関連する形状の色を設定するには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブ（NOT ）描画キャンバス上.

3。 選択 カラー変更.

4。 選択 プロパティの使用ラジオボタン。

5。 テキストボックスの右にある「...」ボタンをクリックしてプロパティを選択します。

6。 選択 範囲 ラジオボタン。

7。 調整 ミン そして マックス値は、所望に応じ。注意：最小値以下のいずれかの値が最小の色として表示され、最大上記のいずれかの値が最大の色として表示されます。ブール、リストまたは日付/時刻のプロパティを使用している場合、次のようにも、値がインデックスに変換されます。 （偽= 0、真= 1）ブール値、リスト、および日付/時刻（1900年1月1日からの日数（各単位フィールドで指定された彼らの昇順で有効な値の1からnまでの整数の谷） - など、小数点のための時間、分、秒部分 - と日付）が1990年以前には負の数である場合。

8。 基本カラーを選択するかのダイアログでカスタムカラーを定義します ミン そして マックスクリックします [OK].

先端

もし 緑 （RGB - 128,255,0）が最小色として選択され、 赤 （RGB - 255,0,0）は、値の範囲を持つプロパティの最大の色として選ばれます 1 に 4その後の値 1表示されます 緑の値 2 として 黄, 3 として オレンジ そして 4 として 赤.

また、プロパティの範囲について 1 に 3の値 1以下のようになります。 緑の値 2 として アンバー そして 3 として 赤別名「信号機」またはRAG状況。

1〜5の特性範囲の場合について ブルー （RGB - 0,0,255）が最小色として選択され、 赤 （RGB - 255,0,0）が最大の値が1色として選択されているようになります ブルー、2の値として アクア、3の値として 緑、4の値として 黄 および5の値として 赤.

1〜6の特性範囲であれば用 バイオレット （RGB - 255,0,255）が最小色として選択され、 赤 （RGB - 255,0,0）が最大の値が1色として選択されているようになります バイオレット、2の値として ブルー、3の値として アクア、4の値として 緑、5の値として 黄 そして、6の値として 赤.

そして最後に、1〜7の特性範囲のための1の値は、のようになります。 バイオレット、2の値として 暗い青、3の値として ライトブルー、4の値として ブルーグリーン、5の値として 緑、6の値として アンバー および7の値として 赤

注意

背景着色対フォアグラウンドに上記の注意を参照してください。

- または -

7。 選択 特定値ラジオボタン。

8。 クリック 編集カラーバリエーション ボタン。

9。 順番にそれぞれの値を選択してをクリックします カラーを設定します。各値の特定の色を設定します。

注意

ダイアグラム上に存在する要素の値の範囲は事前に入力されます。

10。 （例えば特性範囲が再設定された後に）事前に移入したものに追加の値の色を追加するにはクリック 値の追加.

関連する形状の色透明性やフリーフォームの形状を変更するには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状またはフリーフォーム形状。

3。 選択 カラー変更.

4。 透明パネルではベースカラーに対する所望の透明性を最スライダーを設定します。

5。 グラデーションまたはプロパティのオプションを使用するには使用されている場合は、透明パネルに第二の色に対する所望の透明度に底スライダーを設定します。

6。 クリック [OK].

表示します 影 ために すべての 関連しました 図中の図形

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントステンシルウィンドウのタブ。

3。 選択 追加 影.

に 影を表示 部品形状やフリーフォームの形状

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 右-クリックキャンバス上のコンポーネントまたはフリーフォームの形状に。

3。 選択 追加 影.

図に部品形状やフリーフォームの図形を回転させるには

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 部品形状や回転させたいキャンバスにフリーフォームの図形を選択します。

3。 右クリック形状や選択に ローテートそして、あなたがすることによって図形を回転したい、関連する角度を選択します。

変化 要素注釈およびフリーフォームテキストラベル

すべての図要素を持っています 注釈 これは所望のように操作することができます。関連した形状の場合には、これらの側面を設定することができます タイプごとにほとんどの場合においても インスタンスごと。フリーフォーム形状の場合コネクタ、テキストラベル 設定することができ インスタンスごとキャンバス上。エイト（8）の注釈の異なるタイプの図の要素に対して表示することができる（すなわち名前、タイプ、標準とタイムスタンプ（作成、）などにより、変更されたプロパティ値、プロパティマーカー、付属のコンポーネント、コンポーネントのみのための子供（））二十に5（25）の異なる位置（例えばセンター - 外トップ、内側は左 - 右外センター、 - 外底を）。

注意

同じ態様は、対応するタイプに変更された場合、関連する形状に設定された任意のインスタンスごとの側面が「上書き」されます。2以上の注釈は、単一のフォント、フォントスタイル、フォントの色とサイズを使用することができ、同じ位置と区切りを占める場合はさらに、（例えばカンマ、スペース、改行）を選択する必要があります。

表示します 名前または種類 関連するコンポーネントまたは接続のための

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状やコネクタ。

3。 選択 注釈.

注意

キャンバス上の個々の関連する形状やコネクタのためにあなたが選択する必要があります ステンシル注釈をオーバーライドします初めてのチェックボックスをオンにします。

4。 ツールバーの[新規注釈を選択し、[選択] 名 または タイプ.

5。 ブラケットとフォント、フォントスタイル、フォントの色とサイズを含む所望された表示オプションを選択して表示されるダイアログで。また、水平および垂直方向の配置（すなわち、注釈の位置）と角度（すなわち回転）を含む所望されているレイアウトオプションを選択します。選択 [OK].

プロパティを表示するには 値 関連するコンポーネントまたは接続のための

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状やコネクタ。

3。 選択 注釈.

注意

キャンバス上の個々の関連する形状やコネクタのためにあなたが選択する必要があります ステンシル注釈をオーバーライドします初めてのチェックボックスをオンにします。

4。 ツールバーの[新規注釈を選択し、[選択] プロパティ値.

5。 「...」ボタンとセレクトAプロパティ]ダイアログボックスでプロパティを選択します。プロパティをクリックしてプロパティを選択し、表示されるダイアログで選択し [OK]. ブラケットとフォント、フォントスタイル、フォントの色とサイズを含む所望された表示オプションを選択します。また、水平および垂直方向の配置（すなわち、注釈の位置）と角度（すなわち回転）を含む所望されているレイアウトオプションを選択します。選択 [OK].

プロパティを表示するには マーカー 関連するコンポーネントまたは接続のための

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状やコネクタ。

3。 選択 注釈.

注意

キャンバス上の個々の関連する形状やコネクタのためにあなたが選択する必要があります ステンシル注釈をオーバーライドします初めてのチェックボックスをオンにします。

4。 ツールバーの[新規注釈を選択し、[選択] プロパティマーカー.

5。 「...」ボタンとセレクトAプロパティ]ダイアログボックスでプロパティを選択します。プロパティをクリックしてプロパティを選択し、表示されるダイアログで選択し [OK]. ピクセル単位でマーカーやプロパティでカラーによって範囲またはカラーのいずれかに着色方法の半径を設定し、色の割り当てを設定します。また、水平および垂直方向の配置（すなわち、注釈の位置）と角度（すなわち回転）を含む所望されているレイアウトオプションを選択します。選択 [OK].

表示します 付け部品 関連するコンポーネントまたは接続のための

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状やコネクタ。

3。 選択 注釈.

注意

キャンバス上の個々の関連する形状やコネクタのためにあなたが選択する必要があります ステンシル注釈をオーバーライドします初めてのチェックボックスをオンにします。

4。 ツールバーの[新規注釈を選択し、[選択] 付属のコンポーネント.

5。 「...」ボタンをクリックし、設定コンポーネントの種類の選択]ダイアログでコンポーネントタイプを選択する：関連するコンポーネントは、添付をクリックして、添付のコンポーネントの種類を選択するために、表示されるダイアログで選択し [OK]. 接続ビアをクリックして、添付の接続タイプを選択します。「...」ボタンをクリックし、設定された接続の種類]ダイアログで接続タイプを選択します選択し [OK].関連する接続の送信元を選択することにより、接続端を選択するか、接続端からシンク：プルダウンメニュー. 関連するコンポーネントと接続の両方のためのブラケットとフォント、フォントスタイル、フォントの色とサイズを含む所望された表示オプションを選択します。また、水平および垂直方向の配置（すなわち、注釈の位置）と角度（すなわち回転）を含む所望されているレイアウトオプションを選択します。選択 [OK].

表示します 子どもたち 関連するコンポーネントの

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントステンシルウィンドウのタブまたはキャンバス上の関連する形状。

3。 選択 注釈.

注意

キャンバス上の個々の関連する形状のためにあなたが選択する必要があります ステンシル注釈をオーバーライドします初めてのチェックボックスをオンにします。

4。 ツールバーの[新規注釈を選択し、[選択] 子供.

5。 ブラケットとフォント、フォントスタイル、フォントの色とサイズを含む所望された表示オプションを選択して表示されるダイアログで。また、水平および垂直方向の配置（すなわち、注釈の位置）と角度（すなわち回転）を含む所望されているレイアウトオプションを選択します。選択 [OK].

表示します スタンダード 関連するコンポーネントまたは接続のための

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状やコネクタ。

3。 選択 注釈.

注意

キャンバス上の個々の関連する形状やコネクタのためにあなたが選択する必要があります ステンシル注釈をオーバーライドします初めてのチェックボックスをオンにします。

4。 ツールバーの[新規注釈を選択し、[選択] スタンダード.

5。 ブラケットとフォント、フォントスタイル、フォントの色とサイズを含む所望された表示オプションを選択して表示されるダイアログで。また、水平および垂直方向の配置（すなわち、注釈の位置）と角度（すなわち回転）を含む所望されているレイアウトオプションを選択します。選択 [OK].

表示します タイムスタンプ 関連するコンポーネントまたは接続のための

1。 既存していることを確認してください 図オープン .

2。 右クリック内の関連する形状やコネクタの コンポーネントまたは 接続ステンシルウィンドウのタブまたはキャンバスに関連した形状やコネクタ。

3。 選択 注釈.

注意

キャンバス上の個々の関連する形状やコネクタのためにあなたが選択する必要があります ステンシル注釈をオーバーライドします初めてのチェックボックスをオンにします。

4。 ツールバーの[新規注釈を選択し、[選択] 、作成した作成者、マーカーを作成、修正、変更者、または変更されたマーカー.

5。 表示されるダイアログ、そうでない場合は、マーカーでは、ブラケットとフォント、フォントスタイル、フォントの色とサイズを含む所望された表示オプションを選択します。マーカー場合は、ピクセル単位でマーカーや色によって範囲やカラーによってプロパティのいずれかに着色方法の半径を設定し、色の割り当てを設定します。また、水平および垂直方向の配置（すなわち、注釈の位置）と角度（すなわち回転）を含む所望されているレイアウトオプションを選択します。選択 [OK].

フリーフォームの形状のフォントスタイルを変更するにはまたはコネクタ

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 右クリックフリーフォームの形状に またはコネクタ キャンバス上。注：場合 コネクタ テキストラベルは、接続を表示するには、次に表示されていませんまたは テキストラベル: 右クリックコネクトまたは選択し 注釈| ショーの注釈.

3。 選択 フォントの変更.

4。 ダイアログのフォント、フォントスタイルとサイズを選択し、[選択] [OK].

フォントを変更するには 色 フリーフォームの形状のまたはコネクタ

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 右クリックフリーフォームの形状に またはコネクタ キャンバス上。注：場合 コネクタ テキストラベルは、接続を表示するには、次に表示されていませんまたは テキストラベル: 右クリックコネクトまたは選択し 注釈| ショーの注釈.

3。 選択 変化する フォントの色.

4。 フォントを選択しますカラー（や形状リンクカラー用）「...」ボタンをクリックして色を選択することにより、 ダイアログを選択中 [OK].

5。 0は完全に透明であり、かつ255は完全に不透明であることでスライダを調整することによって、テキストラベルの透明度を選択します。

フリーフォームの図形のテキストラベルを回転させるにはまたはコネクタ

1。 あなたは、新規または既存のを持っていることを確認してください 図オープン .

2。 右クリックフリーフォームの形状に またはコネクタ キャンバス上。注：場合 コネクタ テキストラベルは、接続を表示するには、次に表示されていませんまたは テキストラベル: 右クリックコネクトまたは選択し 注釈| ショーの注釈.

3。 選択 ローテートそして、あなたが回転したい関連角度を選択 テキストラベル こともできます。

参照してください

描画ツール | あなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


ダイアグラム内のリンクを使用して

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

ダイアグラム内のリンクを使用して

コメントを送信 このトピックに関する。

シェイプ（フリーフォームとコンポーネント） およびコネクタ（遊離体または接続） 図の中にあなたのABACUSの既存の建築の表現だけでなく、外部ファイル/フォルダやURLにリンクすることができます。これらのリンクは、その後、ABACUSツールセットを経由して（作成、変更、削除）管理することができます。この機能は、概略的アーキテクチャのナビゲーションおよび全体的な理解を高めるために使用することができます。

ダイアグラムへのリンクを追加するには

1。 既存していることを確認してください 図オープン .

2。 関連する図形を選択 またはコネクタ あなたのダイアグラムから.

3。 右クリック形状についてまたはコネクタ.

4。 選択 オープンリンクと リンクスウィンドウが表示されます。

5。 クリックします 追加アイコンとA 新規リンクウィンドウが表示されます。

6。 関連を選択 カタログ|マトリックス|ダイアグラム| 3Dビュー|チャートラジオボタンは、その後、関連の選択 カタログ、マトリックス、 ダイアグラム, 3Dまたはチャート から現在のアーキテクチャのビュー へのリンク ドロップダウンメニュー。

- または -

6。 選択 ウェブサイトその後、ラジオボタンは、該当するURLを入力してください （例えばHTTP：//www.avolutionソフトウェア.COM /）フィールドでのWebページにリンクします。有効なURLは次のいずれかで開始する必要があります 5文字列; http：//、https：//には、ftp：//, ファイル：または\\。任意のスペースは「％20」で入力する必要があります。

- または -

6。 選択 絶対ファイル|相対ファイルラジオボタンS、その後」をクリックします...ダイアグラムにリンクする外部ファイルを参照する」ボタンを押します。

7。 クリック [OK]そして新しいリンクがリンク・ウィンドウに表示されます。注：リンク・ウィンドウは、必要に応じて完全な名前を参照するためにサイズを変更できます。

8。 手順を繰り返し 5-7より多くのリンクを作成します。

9。 、作成されたリンクをたどるに表示され、関連するリンクを選択するには リンクスウィンドウとクリック リンクを開きます.

注意

いつ 複数の注釈がのために示されています 形状やコネクタ リンクを編集注釈ダイアログの注釈のリストの最初の注釈​​に表示されます.

ダイアグラムからのリンクに従ってください

1。 既存していることを確認してください 図オープン .

2。 関連する図形を選択 またはコネクタ あなたのダイアグラムから.

3。 クリック関連するハイパーリンクを形状（青コンポーネント名を強調） またはコネクタ 図に開き、形状から最初のリンクを表示するにはまたはコネクタ.注意：リンクをクリックする準備ができたときにカーソルが「手」に変更する必要があります。

- または -

3。 関連する図形を選択 またはコネクタ ダイアグラムから。

4。 右クリック形状についてまたはコネクタ.

5。 選択 オープンリンク そしてその リンクスウィンドウが表示されます。

6。 あなたが見たい、関連リンクを選択します。

7。 クリックします リンクを開きますボタンが開き、該当するリンクを表示します。

ダイアグラム内のリンクを削除するには

1。 既存していることを確認してください 図オープン .

2。 関連する図形を選択またはコネクタダイアグラムから。

3。 右クリック形状についてまたはコネクタ.

4。 選択 オープンリンク そしてその リンクスウィンドウが表示されます。

5。 削除する必要がある関連リンクを選択します。

6。 クリックします 削除 ボタン。そしてリンクはから削除されます リンクス ウィンドウ。

あなたの図中の整理のリンク

あなたはダイアグラム、外部ファイルをリンクされ、または形状のラベルにCtrl +ダイアグラムでクリックしたときにウェブのURLが表示されて選択することができます。

1。 既存していることを確認してください 図オープン .

2。 関連する図形を選択 またはコネクタ ダイアグラムから。

3。 右クリック形状についてまたはコネクタ.

4。 選択 オープンリンク そしてその リンクスウィンドウが表示されます。

5。 リンクの順序を変更するにはをクリックしてください |上へ移動下に移動の右側のボタン リンクス ウィンドウ。

6。 の左側に表示される最初のリンク リンクスウィンドウは表示するリンクです Ctrlキーを押しながらクリックハイパーリンクされた形状 またはコネクタ 名。

参照してください

あなたのアーキテクチャへの移入 | 手動であなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


ダイアグラムビューポイント

ナビゲーション：図面を用いて>自分のアーキテクチャへの移入>

ダイアグラムビューポイント

コメントを送信 このトピックに関する。

目Eの視点特徴は、図に追加する前に、図に追加されたコンポーネントとの接続は以前に定義されたタイプの関連付けを持たなければならないことを保証します。この機能は、コンポーネントに関連付けられている図形＆コネクタを制限することによって描画することができる図の種類の制限を可能にし、 接続あなたのアーキテクチャ内に​​存在します。

施行図を有効化または無効化 視点

強制する能力 図の視点 自動的にデフォルトで有効になっています。ツールでこの機能のクリックを有効/無効にするには| オプション...|ザ・ ダイアグラム選択/タブ、および選択を解除 ダイアグラムを強制 視点それに応じてチェックボックスをオンにします。

注意

あなたが表示されない場合は「ダイアグラムを強制します 視点[ダイアグラム]タブのオプションは、あなたがデザイナーのアドオンを持っていないとオプションはデフォルトでオンになっています。

強制力の図を作成します 観点

1。 あなたが持っていることを確認 ABACUSファイル とのオープン エクスプローラビューが表示されます。

2。 エクスプローラービュ​​ーで右クリックしました 見ますポイントsとをクリック 作り出します 図の見方

3。 ザ・ 図の見方ウィンドウが表示されます。

4。 に関連する名前を割り当て 図の視点とことに注意してください 観点 で保存されます 視点エクスプローラのセクション。

5。 ザ・ 図の見方ウィンドウが表示されます。

6。 今すぐにあなたのアーキテクチャ内の関連するコンポーネントタイプと接続タイプをクリックしてドラッグします 視点形状あなたが欲しいです。 コンポーネントのタイプ上にドラッグする必要があります 形状 の中に シェイプタブ、一方 接続タイプ上にドラッグする必要があります 5線のスタイルの形の一つ の中に コネクタ タブ。

7。 保存するには 図の視点あなたは上でクリックを作成しました [image] あなたの右上に 図の見方 ウィンドウ。

注意

ザ・ 図の視点右クリックして編集することができます 観点 そして、選択 オープンまたは ダブルクリックザ・ 観点.

ダイアグラムで更新視点をSynchonising

1。 あなたが持っていることを確認 ABACUSファイル オープン.

2。 のいずれかで視点を右クリック エクスプローラ 下の窓 メタモデル|視点選択し 同期ダイアグラムマッピング...

- または -

3。 閉じる オープンして更新視点 ウィンドウを選択 はい の中に 視点に同期します表示されるダイアログ。

4。 ザ・ 視点の同期化ダイアログは、以下のように表示されます。

チェックボックス

· 行方不明のマッピングを追加 - 追加された団体（接続タイプ）にすべての新しい（コンポーネントタイプ）形状やコネクタ 視点にに追加され 対応する図S（すなわち、そのステンシル秒） その 視点にリンクされています。

· 既存の更新マッピング - （接続タイプ）は、既存の（コンポーネントタイプ）形状やコネクタのどれ更新側面に関する団体 観点（例えば、色、フォントスタイル）で更新されます 対応する図S（すなわち、そのステンシル秒） その 視点にリンクされています。

· エクストラ削除マッピング - 追加された団体（接続タイプ）に任意の追加（コンポーネントタイプ）形状やコネクタ へ 図（すなわち、そのステンシル）が、していません 観点から削除されます 対応する図S（すなわち、そのステンシル秒） その 視点にリンクされています。

· 追加または更新マッピングのためのローカル設定を上書きします（相違点のみ） - （接続タイプ）は、既存の（コンポーネントタイプ）形状やコネクタのどれ更新側面に関する団体 観点（例えば、色、フォントスタイル）の​​視点にリンクされているダイアグラム上の対応する要素に適用されます.視点に行われたのみ更新」の違いは「そのように適用される視点に更新されていない図の既存のローカル設定は変更されません。

· [image] 注釈 – 上記が、特に注釈のように。

参照してください

描画ツール | あなたのアーキテクチャへの移入 | 解析法 あなたのアーキテクチャ


カタログを使用して取り込み

ナビゲーション：あなたのアーキテクチャへの移入>

カタログを使用して取り込み

コメントを送信 このトピックに関する。

A カタログ あなたがコンポーネントを表示し、編集することができます 接続とそのプロパティまたは 簡単な表形式の方法です。

に 新しいカタログを作成します で表示 ABACUS

注意

すべてのアーキテクトのユーザーは、既存のカタログの設定に変更を保存するには、新しいカタログを作成することはできますが ユーザーライセンスは、デザイナーのアドオン機能を必要とします。 これは、多くのユーザが共有することができる既存のカタログの構成を「保護」することです。しかし、建築家は、アドオン、まだ「名前を付けて保存」の新しいカタログに新しい設定を選択することができますデザイナーずに使用しています。そしてもちろん、すべてのユーザー・ライセンスは、「廃棄」に、既存のカタログへの変更を選択することができます。 お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたが必要な場合 デザイナーはアドオン 能力。 覚えて、これはカタログの設定だけで、カタログ内のデータに対して行われたすべての編集内容は即座に関係なく、リポジトリに適用されます。

1。 挿入]を選択します| カタログ。

2。 の中に <アーキテクチャ>プルダウンコンポーネントが含まれているアーキテクチャを選択 または表示したい接続。

3。 の中に <要素タイプ>プルダウンコンポーネントを選択 または接続タイプ あなたは」と記載されているインスタンスを持つことを望むこと行' カタログで.

4。 ザ・ カタログ が取り込まれます選択したコンポーネントまたは接続タイプのインスタンスごとに行.

注意

デフォルトでは、一番左の 階層パスカラムと第二（選択したインスタンス上の親コンポーネントまたは接続の階層すなわち） 名 列は（選択したコンポーネントまたは接続インスタンスのリストIE）カタログの左に凍結されます。列を変更するには 凍結 [名前]列の右に列セパレータをドラッグします。 あなたはできる リオーダー単にその列見出しをドラッグ＆ドロップして列。青い下線付きの列の細胞があります ハイパーリンク 他のプロジェクトの要素とハイパーリンクにCtrlキーを押しながらリンクをクリックすることで追跡することができます。列は、することができます 隠されました 右クリックし、列見出しにと列を選択することで|列を非表示にします。非表示の列は、以下に示すように列の構成]ツールバーボタンをクリックし、ダイアログ列の構成を使用して再表示、または列の構成]ツールバーボタンの下矢印部分を選択し、個別に一般のいずれかから非表示の列（複数可）を選択して、[プロパティ]することができますまたは添付ファイルのコレクション。行は、することができます グループ化 カタログの上部にある青色のグループ化バーに列見出しをドラッグして、その列の値によって。 いつでもダブルクリックすることができます カタログ行セレクター そして にジャンプ対応するコンポーネントまたは接続エクスプローラウィンドウに表示されます。プロパティセルの値があります 太字 それらはデフォルトに異なる場合、および イタリック体の 彼らは読み取り専用されます。タイムスタンプ、プロパティおよび付属コンポーネントの列であってもよいです 色付きの |セルの値または列見出しを右クリックし、列を選択して、添付コンポーネントのプロパティ値に応じてカラー変更...とプロパティオプションでタイムスタンプやカラーによって、次にカラー、しかし、唯一の リスト、整数、10進数、ブールまたは日付/時刻 データ型の特性は、色になります。付属コンポーネント列のプロパティ値とすることができます 示します 右クリックし、列見出しにと列を選択することで|プロパティ...そして表示プロパティオプションを表示します。そして最後に、どこにあります 必要な制約 プロパティ列に設定され、これらを示すことができます <必須>右クリックし、列見出しおよび列を選択して、文字列（一緒に施行レベルに応じて着色付き）| <必要なもの>表示します。

カタログ

に に/ショー列を追加 a カタログ ABACUSで見ます

1。 あなたが持っていることを確認してください カタログビュー オープン.

2。 非表示の列を個別にクリックして再表示することができます 列の構成のツールバーボタンの右側の矢印そして、のいずれかから非表示列を選択します 一般, プロパティ または 添付ファイル コレクション。

注意

チェックマークがカタログの現在表示されている列の隣に表示されます.さらに、唯一の特定の添付ファイルは、に応じて添付ファイル]セクションの下で利用できるようになります 制約 それはあなたのプロジェクトで定義されています。添付ファイルは、カタログのコンポーネント・タイプがいずれかのソースとして指定されるか（NOT「でも」）をシンクする必要がありますコンポーネントカタログに表示されるために利用可能であるために、特に接続するための制約を「接続接続する必要があります」タイプ、また、同じ接続タイプの他の「終了」のソースまたはシンクのいずれかとして指定された少なくとも一つの成分の種類（NOT "でも '）が存在しなければなりません。

- または -

2。 複数の列には、クリックして再表示（または注文または固定）することができます 列のツールバーボタンを設定しますそして、列の構成]ダイアログボックスを使用すると、以下に示します。

注意

現在表示されている列は、左側のパネルに表示されている使用可能な列と右側のパネルに表示されます。使用可能な列は、に応じてフィルタリングしてもよいです 使用可能な列を選択してから、プルダウン、彼らは左側のパネルで、それらを選択してクリックすることによって添加することができます 追加 二つのパネルその間のボタンを押します。

Columnsダイアログを設定

に から列を非表示/削除 カタログ ABACUSで見ます

1。 あなたが持っていることを確認してください カタログビュー オープン.

2。 あなたは/非表示を削除して、選択したい列の列ヘッダーを右クリックします コラム|列を非表示にします.

- または -

2。 複数の列は非表示（または注文または固定）をクリックすることができます 列のツールバーボタンを設定しますそして上に示した列の構成]ダイアログボックスを使用して。

注意

現在表示されている列は、左側のパネルに表示されている使用可能な列と右側のパネルに表示されます。現在表示されている列は、右側のパネルで列を選択し、クリックすることで非表示にすることが可能 削除 二つのパネルその間のボタンを押します。

使用して移入するには カタログ ABACUSで見ます

1。 に 加えます コンポーネントまたは 接続選択したタイプの にザ・ カタログ（およびプロジェクト）/新しいコンポーネントを追加します。新しい接続]ツールバーボタンを追加]をクリックします。 行すべき 表示され、 コンポーネントまたは 接続は、最上位レベルで作成されます。 コンポーネントまたは 選択したアーキテクチャ用の接続コレクション。

注意

新しいコンポーネントとの接続は、選択されたアーキテクチャのコンポーネントまたは接続コレクションのトップレベルにデフォルトで追加されます。新しいコンポーネントまたは接続の親を変更するには、新しいコンポーネントや接続の行の階層パスのセルを右クリックして選択 変更親...そして目的の親を選択します（メモを取ります 制約ハイライト ).

注意

新しい行が/要素は、MS Excelからのカタログへのインポートを経由してカタログに貼り付け、または作成し、「新規追加」ボタンを経由してカタログに直接添加したカタログがクローズされるまでフィルタリングを免除されています。これは、カタログの現在のフィルタリング基準を満たしていない可能性がいずれかの列の値に必要な編集を可能にすることです。これらの新しいエレメント列が着色されている行の先頭に行セレクターセルに「+」記号で示されています 緑色 要素が現在のカタログの保存されたフィルタリング基準を満たしている場合（つまり、再オープンした場合はカタログに残ります）、および 赤 それがない場合。

2。 に 削除します コンポーネントまたは 接続選択したタイプの からザ・ カタログ（およびプロジェクト）の行のいずれかを押してDelキーまたは行セレクタを右クリックし、[選択]を選択 建築から削除。ザ・ 行 消えるはず カタログから それを プロジェクトから削除されます。

に フィルタ 使用して カタログ ABACUSで見ます

1。 あなたが持っていることを確認してください カタログビュー オープン.

2。 フィルタ行は、カタログの最上部に表示されていない場合は、をクリックしてください 表示フィルタのヘッダー行ツールバーのボタン。

3。 列では、それが示しているフィルター行のセル '（すべて）'をダブルクリックして、フィルタを追加したいと思います。

4。 ために タイムスタンプ、階層パス、名前または 説明一般的な列または テキスト、整数、10進数、ブールまたは 日付時刻プロパティの列がフィルター行のセルの右側に表示される[...]ボタンをクリックし、カタログに含まれるべきであるセルの値を入力します。

注意

マッチングは、（引用符なし）「猫」のエントリーが「ボブを持つ行が含まれるように、 '*'ワイルドカードが自動的に任意の文字列値の前と後に適用されているかのように行われていますネコ'、'ネコ女性 'または'アプリネコイオン」などの複数の/ 'または'の値は、使用して新しい行に入力することができます Ctrlキーを押しながら入力してください。整数と小数のプロパティの列 'と'のために論理は 'を使用して含まれていてもよいです&「（引用符なし）より大きいの/ etcロジック未満を使用して含めることができます '> ='、'>'、'<' そして '<=「（引用符なし）、例えば、 '> = 50000＆<90000」。非ブランクの値を持つ行が '入力して含めることができます（非ブランク）「（引用符なし）とブランク大切行に入力して含めることができます '（ブランク）「（引用符なし）.最後に、すべてのフィルタは、デフォルトのケースによって小文字は区別されませんので、（引用符なし）「猫は ''、大文字と小文字の区別が一致するために「猫」など「猫」または「CAT」で行を含む入力します。（場合）「（引用符なし）、例えば、文字列の前に（引用符なし）」（ケース）キャット」はそれらだけで「猫」を持つ行が含まれます。

5。 ために 添付ファイル列、 スタンダード 列または リスト プロパティの列がフィルター行のセルの右側に表示される下矢印ボタンをクリックして、カタログに含まれるべきであるチェックボックスからセルの値を選択します。

注意

'（すべて選択）」のチェックボックスは、使用可能なすべての行を含む実質的に、他のすべてのチェックボックスが有効になります。 「（非ブランク）」のチェックボックスは、空白以外の任意の値を持つ行が含まれます。 「（空白）」のチェックボックスは空白の大切な行が含まれます。一貫性のためにそして最後に、任意の特定の値を持つチェックボックスをオフに自動的に '（すべて選択）「非選択と'（非ブランク）」のチェックボックス.

6。 クリック [OK] フィルタを適用します。

に 上のフィルタリングを有効/無効にします a カタログ ABACUSで見ます

1。 あなたが持っていることを確認してください カタログビュー オープン ととも​​に フィルタ 適用されました.

2。 フィルタ行の左側にあるチェックボックスをクリックします。

に からフィルタを削除します a カタログ ABACUSで見ます

1。 あなたが持っていることを確認してください カタログビュー オープン ととも​​に フィルタ 適用されました.

2。 個々の列フィルタを削除するには、列ヘッダを右クリックして選択 コラム|クリアフィルタリング.

3。 すべてのフィルタを削除するにはクリック オプション ツールバーのボタンを選択 クリアフィルタの設定.

保存する /として保存 aカタログビュー

注意

すべてのアーキテクトのユーザーは、既存のカタログの設定に変更を保存するには、新しいカタログを作成することはできますが ユーザーライセンスは、デザイナーのアドオン機能を必要とします。 これは、多くのユーザが共有することができる既存のカタログの構成を「保護」することです。しかし、建築家は、アドオン、まだ「名前を付けて保存」の新しいカタログに新しい設定を選択することができますデザイナーずに使用しています。そしてもちろん、すべてのユーザー・ライセンスは、「廃棄」に、既存のカタログへの変更を選択することができます。 お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたが必要な場合 デザイナーはアドオン 能力。覚えて、これはカタログの設定だけで、カタログ内のデータに対して行われたすべての編集内容は即座に関係なく、リポジトリに適用されます。

1。 あなたは新しいがあることを確認してください または既存のカタログビュー オープンあなたは、必要な変更を行いました。

2。 の中に カタログビュー上のツールバーをクリック セーブボタンを押して保存します カタログビュー 任意の書式の変更。

注意

あなたがカタログビューのツールバーの[保存]ボタンを持っていないなら、あなたはデザイナーのアドオンを持っていないとあなただけのことができます 名前を付けて保存新しいカタログへの設定変更は、既存のカタログを閉じるために行くとき.

3。 もし ザ・ カタログ 名ダイアログボックスが表示されます （新しいカタログであることに起因します） 名前を入力します カタログ プレス [OK].

に MS Excelのカタログへのエクスポート

1。 あなたが持っていることを確認してください カタログビュー オープン.

2。 クリック エクセルカタログのスプレッドシートへのエクスポートツールバーのボタン。

3。 MS Excelのカタログを保存するファイル名を選択します。 クリック セーブ.

注意

デフォルトではエクスポートされたMS Excelのカタログのファイル名は、例えば括弧でアーキテクチャ名サフィックスカタログ名になります「プロジェクト（2014年実績）の.xlsx」。あなたは、ファイル形式は.xlsx形式または.XLSするかどうかを含めて、これのいずれかを変更することができます。アーキテクチャ名は各カタログは、それが戻って以下の通りMS Excelのカタログからのインポートを使用してラウンドトリップすることを可能にするために、特定のコンテンツ（列Aと行1すなわちID）を持つユーザーを思い出させるために含まれています。

注意

デフォルトではエクスポートされたMS Excelのカタログ内の非表示列AはABACUSリポジトリ内の各要素の一意のIDが含まれています。これは、MS Excelで行われたすべての変更は、（下記参照）輸入にABACUS内の既存の要素に「最大一致」することができます。しかし、行を「一致」するには、この一意のIDを使用することがで上書きすることができます 外部| ID要素のプロパティ。要素が外部を有する場合すなわち、| IDプロパティと、それは外部の、値輸出上のカタログに含まれています| ID列は、（下記参照）インポート時に行を一致させるために使用され、非表示の列Aの固有のID値は無視されます（さらに空白にすることができます）。隠されたカラムAは、それ自体は、特に、しかし、セルA1の値でなければなりません。既存のABACUS要素コレクションに外部IDを追加するときにさらに、我々は例えば、第1の別のプロパティとしてそれらを追加することをお勧めします外部| Tempと、外部へのプロパティの名前を変更します| ID。それ以外の場合は重複する要素が追加されます。

カタログフォーマットデフォルトでエクスポートされているが、大規模なカタログのために、これは輸出が非常に遅くされる可能性があります。したがって、中 ツール|オプション...その後に ザ・ カタログ タブ、あなたは、それによって輸出をスピードアップ、以下のカタログ]タブに表示としてエクスポートされるフォーマットの量を削減することができます。

カタログのエクスポート オプション

4。 エクスポート完了ダイアログが表示されます。 クリック [OK].

MS Excelのカタログに輸出

に MS Excelのカタログからのインポート

注意

デフォルトではエクスポートされたMS Excelのカタログ内に隠された列A（上記参照）ABACUSリポジトリ内の各要素の一意のIDが含まれています。これは、MS Excelで行われたすべての変更は、インポート時にABACUS内の既存の要素に「最大一致」することができます。しかし、行を「一致」するには、この一意のIDを使用することがで上書きすることができます 外部| ID要素のプロパティ。要素が外部を有する場合すなわち、| IDプロパティと、それが輸出上のカタログに含まれています（上記参照）外部の、値| ID列は隠し列Aは無視されます（さらに空白にすることができます）にインポートし、一意のID値の行を一致させるために使用されます。隠されたカラムAは、それ自体は、特に、しかし、セルA1の値でなければなりません。既存のABACUS要素コレクションに外部IDを追加するときにさらに、我々は例えば、第1の別のプロパティとしてそれらを追加することをお勧めします外部| Tempと、外部へのプロパティの名前を変更します| ID。それ以外の場合は重複する要素が追加されます。

1。 あなたが持っていることを確認してください カタログビュー オープン.

2。 クリック エクセルカタログスプレッドシートからのインポートツールバーのボタン。

3。 からMS Excelのカタログをインポートするファイル名を選択します。 クリック オープン.

4。 ダイアログを検出し検出された新しいエラーおよび/または新たなエラー/警告が追加された任意の新しいコンテンツ（MS Excelの行）のために表示されることがあります。エラー/警告のノートを取り、クリック [OK].

5。 インポート完了ダイアログが表示され、それが輸入に起因する警告を（下記の注を参照）表示されることがあります。 クリック [OK].

注意

割り当てられた標準または接続コンポーネントの列の場合、MS Excelのカタログを経由して、新しいエントリが正確に一致する必要があります 名 割り当てまたは接続に適したタイプの既存の標準またはコンポーネントの追加します。最初の名前の一致が使用され、任意の比類のないエントリは、以下のとおり、警告を生成します。警告が再インポート時に与えられている間にさらに、要素があります 削除されていませんABACUSからの彼らは、MS Excelのカタログに存在しない場合。 ABACUSは、割り当てられた標準または接続コンポーネントがそろばんプロジェクトに存在するが、それは、MS Excelのカタログから削除されたか、ABACUSに追加されているので、MS Excelのカタログに存在していないかどうかを知ることができる方法がないためですカタログをエクスポートしてからプロジェクト。したがって、ユーザーは簡単に接続がインポート処理中に追加された「検​​出」したい場合は、彼らは単に接続タイプで必要なプロパティを作成することができ、彼らは新しい接続ごとに、インポートの警告が表示されますように、それは空白にデフォルトのset完了する。

注意

MS Excelのカタログをインポートする場合、さまざまな警告が表示されることがあります。まず、新しい列が列が無視されるプロパティまたは接続されたコンポーネントの '構文'と一致しませんExcelに追加された場合。次に、ライン・バイ・ラインの警告は、Excelカタログの各行のデータを持つすべての問題のために表示されます。これらの警告は（行23、列Jのために '... [23、J]'すなわち）列ラベル角括弧内及び該当する場合、行番号で始まり、（削除済みアイテム、比類のない標準または接続コンポーネント名を参照してください可能性があります上記音符当たりとして無視）、または無効または空白のIDが追加される新しい行/要素（）に関連しています。 Excelのカタログを使用してABACUSを移入に関する詳細記事についてをご覧ください。 Avolutionコミュニティ またはポートフォリオ・マネージャーのトレーニングコース。

注意

新しいコンポーネントとの接続は、選択されたアーキテクチャのコンポーネントまたは接続コレクションのトップレベルにデフォルトで追加されます。新しいコンポーネントまたは接続の親を変更するには、新しいコンポーネントや接続の行の階層パスのセルを右クリックして選択 変更親...そして目的の親を選択します（メモを取ります 制約ハイライト ).

注意

要素は、MS Excelからのカタログへのインポートを経由してカタログに貼り付け、または作成し、「新規追加」ボタンを経由してカタログに直接添加したカタログがクローズされるまでフィルタリングを免除されています。これは、カタログの現在のフィルタリング基準を満たしていない可能性がいずれかの列の値に必要な編集を可能にすることです。これらの新しいエレメント列が着色されている行の先頭に行セレクターセルに「+」記号で示されています 緑色 要素が現在のカタログの保存されたフィルタリング基準を満たしている場合（つまり、再オープンした場合はカタログに残ります）、および 赤 それがない場合。

に 別のアーキテクチャを持つカタログの内容を比較します

1。 トピックを参照してください。 ここに .

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | Visioのからあなたのアーキテクチャへの移入 | Excelからあなたのアーキテクチャへの移入


行列を使用して取り込み

ナビゲーション：あなたのアーキテクチャへの移入>

行列を使用して取り込み

コメントを送信 このトピックに関する。

行列は、表示および編集することができます '直接' 簡単な表形式の方法で、コンポーネント間の接続また、任意の中間部品（および接続）に応じてコンポーネント間の「間接的なパス」を表示するには.

に 作ります ABACUSでマトリックスビュー

注意

すべてのアーキテクトのユーザーがそれらおよび/またはその設定保存するために行列を作成することはできますが ユーザーライセンスは、デザイナーのアドオン機能を必要とします。 これは、多くのユーザが共有することができる既存の行列の構成を「保護」することです。しかし、建築家は、アドオン、まだ新しいMatrixへの新しい設定「名前を付けて保存」を選択できますデザイナーずに使用しています。そしてもちろん、すべてのユーザー・ライセンスは、「廃棄」に、既存のマトリックスに変更を選択することができます。 お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

1。 挿入]を選択します|マトリックス。

2。 の中に rchitecturE>プルダウンを表示したいコンポーネントとの接続が含まれているアーキテクチャを選択します。

3。 の中に <ソースタイプ>プルダウンを使用すると、 "としてリストされているインスタンスを希望するコンポーネントの種類を選択行' 左ダウン行列の。

4。 の中に <シンクタイプ>プルダウンを使用すると、 "としてリストされているインスタンスを希望するコンポーネントの種類を選択コラム' 上部に行列の。

5。 の中に <パスタイプ（S）> 引き下げる あなたが定義することができ、マトリックスの2つの「モード」は基本的にあります...

「直接」接続行列

6。 単にS選民 一方（1）以上 接続 タイプ 場合に表示されるメニューの右側に 場合は、行列の「セル」に表示したいですnは明示接続が存在しているから 垂直/ '行に行列の 'コンポーネント 水平の/ 'カラム行列の 'コンポーネント。

注意

に接続されているソース端との接続だけ 垂直/ '行'コンポーネントとシンク端部に取り付けられました 水平の/ 'カラム'コンポーネントが表示されます。スイッチ ソース そして シンク逆方向の接続を表示するコンポーネントの種類の選択。

7。 行列は 'X'が設定されます 細胞（またはプロパティ値 - 下の注を参照） からの接続がある場合 垂直/ '行'の行列のコンポーネント 水平の/ 'カラム行列の 'コンポーネント。

注意

大規模な行列に対して100行または（折り畳まれた行/列を含む）列の唯一の最大値は、それぞれ左上のヘッダーセルに「R」と「C」の指標によって示されるように一度に表示されます。追加の行を表示するにはスクロールバーを使用しています。 いつでもダブルクリックすることができます 垂直/ '行'または ホリゾントアル/ 'カラム' 成分 見出しや にジャンプエクスプローラウィンドウで対応するコンポーネント。垂直の両親/ '行' そして 水平の/ 'カラム' 成分Sはまた、必要に応じて灰色の見出しタイトルで行/列見出しとして表示されます。子供の添付ファイルは、その後、 'X'が存在する場合（シングルクリック見出しセルによって）崩壊したとき、すべての子どもたちが添付された場合、必要​​に応じて表示されるか、子供だけの一部が添付された場合は、 'O'は、必要に応じて表示されます。細胞であってもよいです 色付きの 行列のツールバーの右上にあるオプション「歯車」をクリックし、[編集]ボタンを...色の設定]を選択し、タイムスタンプやカラーによってプロパティオプションでカラーを選択し、選択して接続のプロパティの値に応じてプロパティ、最小値と最大値の範囲のみ、しかし、色を選択します リスト、整数、10進数、ブールまたは日付/時刻 データ型の特性は、色になります。崩壊した場合、セルは、接続の平均プロパティ値に従って着色されます。代わりに 'X'を、セルのプロパティ値とすることができます 示します 行列のツールバーの右上にあるオプション「歯車」をクリックし、表示値の設定]を選択する... [編集]ボタンと表示プロパティオプションを選択し、プロパティを選択することもできます。

アプリケーションが発色し、プロパティでホストされているサーバーを示す直接接続行列の代わりに示されている一般的な 'X'

- または -

「間接的」な接続のマトリックス

6。 S選民一連の 接続 タイプ そして コンポーネントタイプ場合に表示されるメニューの右側と左側の 場合は、行列の「セル」に表示したいです連結成分のn個の間接パスから存在します 垂直/ '行に行列の 'コンポーネント 水平の/ 'カラム行列の 'コンポーネント。

注意

パスメニューワットで選択した要素を含む任意の有効なパス病気を示すこと関係なく、基礎となる接続の方向の、しかし、パスを選択する際 最初 そして 選択した最後の要素は、接続タイプでなければなりません. また、 注文 で示され、選択された要素の 数値接頭辞広場に（ '[]'）ブラケットと指定された型が含まれていてもよいです mutliple回パスで（数値接頭辞によって示されるように）。コンポーネント・タイプまたは接続タイプの連続選択があると解釈され 「OR」パスおよび接続されているコンポーネントの階層は、必要に応じて確認することにより含ませることができます」また、添付ファイルの親/子供を検索「チェックボックス。 スイッチ ソース そして シンク表示するコンポーネントタイプの選択 パス 反対方向インチ

7。 行列が移入されますコンポーネントのパス/コレクション細胞中に存在する場合 パス から 垂直/ '行'の行列のコンポーネント 水平の/ 'カラム行列の 'コンポーネント。

注意

大規模な行列に対して100行または（折り畳まれた行/列を含む）列の唯一の最大値は、それぞれ左上のヘッダーセルに「R」と「C」の指標によって示されるように一度に表示されます。追加の行を表示するにはスクロールバーを使用しています。 いつでもダブルクリックすることができます 垂直/ '行'または ホリゾントアル/ 'カラム' 成分 見出しや にジャンプエクスプローラウィンドウで対応するコンポーネント。垂直の両親/ '行' そして 水平の/ 'カラム' 成分Sはまた、必要に応じて灰色の見出しタイトルで行/列見出しとして表示されます。子のパスは、次に 'X'が存在する場合（シングルクリック見出しセルによって）崩壊したとき、すべての子どもたちが添付された場合、必要​​に応じて表示されるか、子供だけのいくつかは、パスを持っていた場合は、 'O'は、必要に応じて表示されます。間接的なパスコンポーネントであってもよいです 色付きの 行列のツールバーの右上にあるオプション「歯車」をクリックし、[編集]ボタンを...色の設定]を選択し、およびタイムスタンプやカラーによってプロパティオプションでカラーを選択し、選択してコンポーネントのプロパティ値に応じてプロパティ、最小値と最大値の範囲のみ、しかし、色を選択します リスト、整数、10進数、ブールまたは日付/時刻 データ型の特性は、色になります。間接パスコンポーネントのプロパティの値とすることができます 示します 行列のツールバーの右上にあるオプション「歯車」をクリックし、表示値の設定]を選択する... [編集]ボタンと表示プロパティオプションを選択し、プロパティを選択することもできます。

省によって与えられたサービスを実装するアプリケーションを示す間接的な接続のマトリックス

に フィルタABACUSでマトリックスビュー

1。 あなたは新しいがあることを確認してください マトリックスビュー オープン.

2。 行列のツールバーの右上にあるフィルターの軸「漏斗」をクリックします。

3。 ソースおよび/またはシンク]タブで、[追加]ボタンをクリックし、必要に応じてプロパティを選択してクリックすることで、名前、プロパティ、説明、階層または標準フィルタを追加 [OK]。下記の注で説明したように、論理/構文を使用して、キーワード/アイテムパネルで関連するオプションを選択します。プレビューパネルが自動的にフィルタの現在のセットの結果を表示するために更新されます。

注意

ために タイムスタンプ、階層パス、名前または 説明フィルタまたは テキスト、整数、10進数、ブールまたは 日付時刻（引用符なし）「猫」のエントリーが「ボブを持つ行が含まれるであろうように、プロパティフィルタマッチングは '*'ワイルドカードは自動的に前に、任意の文字列の値の後に適用されているかのように行われていますネコ'、'ネコ女性 'または'アプリネコイオン」などの複数の/ 'または'の値は、使用して新しい行に入力することができます Ctrlキーを押しながら入力してください。 ために 整数 そして 10進数 プロパティー・フィルター」と「​​ロジック」は使用して含まれていてもよいです&「（引用符なし）より大きいの/ etcロジック未満を使用して含めることができます '> ='、'>'、'<' そして '<=「（引用符なし）、例えば、 '> = 50000＆<90000」。非ブランクの値を持つ行が '入力して含めることができます（非ブランク）「（引用符なし）とブランク大切行に入力して含めることができます '（ブランク）「（引用符なし）. ために スタンダード または リスト プロパティが '（すべて選択）」のチェックボックスが使用可能なすべての要素を含む実質的に、他のすべてのチェックボックスを有効にするフィルタ。 「（非ブランク）」のチェックボックスは、空白以外の任意のプロパティ値を持つ要素が含まれます。 「（空白）」チェックボックスが空白のプロパティ値要素が含まれます。そして、特定の数値のチェックボックスをオフに自動的に整合性を保つために '（すべて選択）」と「（非ブランク）」チェックボックスの選択を解除。最後に、すべてのフィルタは、デフォルトのケースによって小文字は区別されませんので、（引用符なし）「猫は ''、大文字と小文字の区別が一致するために「猫」など「猫」または「CAT」と要素を含む入力します。（場合）「（引用符なし）、例えば、文字列の前に（引用符なし）」（ケース）キャット」はそれらだけで「猫」を持つ要素を含むことになります。

ABACUSでマトリックスビューを使用して移入するには

注意

あなたは、単一の接続タイプは、上記のパスに使用されている接続を追加/削除することができます。

1。 に 接続を追加間の選択したタイプの 垂直/ '行'コンポーネントとA 水平の/ 'カラムX 'はすでに存在していない」行列のコンポーネントの（示されたプロパティ値または - 上記の注を参照）、ダブルセルをクリックします。 「X」は表示されます （プロパティ値または - 上記の注を参照） そして、の接続は、選択されたアーキテクチャ用の接続コレクションのトップレベルで作成されます。

注意

接続名は次のようになります 接続の種類名 行列の接続タイプの設定に従って、プロパティ値が表示されている代わりのプロパティの 'X'デフォルト値が表示されます場合.

2。 に 示すプロパティ値を編集間の接続 a 垂直/ '行'コンポーネントとA 水平の/ 'カラム行列の 'コンポーネント、ダブルセルをクリックするか、セルを右クリックし、... [値の編集]を選択し、値の変更]ダイアログボックスで値を編集します。

3。 に 接続を削除します間の選択したタイプの 垂直/ '行'コンポーネントとA 水平の/ 'カラムX 'は既に存在」行列のコンポーネントの（示されたプロパティ値または - 上記の注を参照）, 右-セルをクリックそして、[切断]を選択。 Xは消えるはずとの接続は、プロジェクトから削除されます。

保存する /として保存 aマトリックスビュー

注意

すべてのアーキテクトのユーザーがそれらおよび/またはその設定保存するために行列を作成することはできますが ユーザーライセンスは、デザイナーのアドオン機能を必要とします。 これは、多くのユーザが共有することができる既存の行列の構成を「保護」することです。しかし、建築家は、アドオン、まだ新しいMatrixへの新しい設定「名前を付けて保存」を選択できますデザイナーずに使用しています。そしてもちろん、すべてのユーザー・ライセンスは、「廃棄」に、既存のマトリックスに変更を選択することができます。 お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたが必要な場合 デザイナーはアドオン 能力。覚えて、これはマトリックスの設定だけで、マトリックス内のデータに対して行われたすべての編集内容は即座に関係なく、リポジトリに適用されます。

1。 あなたは新しいがあることを確認してください マトリックスビュー オープンあなたは、必要な変更を行いました。

2。 の中に マトリックスビュー一番左のツールバーをクリック セーブ マトリックスボタンを押して保存します マトリックスビュー 任意の書式の変更。

注意

あなたはマトリックスビューツールバーの[保存]ボタンを持っていないなら、あなたはデザイナーのアドオンを持っていないとあなただけのことができます 名前を付けて保存新しい行列への設定変更は、既存の行列を閉じるために行くとき.

3。 もし ザ・ マトリックス 名表示されるダイアログ （新しい行列であることに起因します） 名前を入力します マトリックスプレス [OK].

に MS Excelの行列へのエクスポート

1。 あなたが持っていることを確認してください マトリックスビュー オープン.

2。 クリック Excelへエクスポートツールバーのボタン。

3。 MS Excelの行列を保存するファイル名を選択してください。 クリック セーブ.

注意

デフォルトではエクスポートされたMS Excelの行列のファイル名は、例えば括弧でアーキテクチャ名サフィックスマトリックス名になります「サーバー（2014年実績）でホストされているアプリケーションの.xlsx」。あなたは、ファイル形式は.xlsx形式または.XLSするかどうかを含めて、これのいずれかを変更することができます。

マトリックスフォーマットデフォルトでエクスポートされているが、大規模な行列に対して、これは輸出が非常に遅くされる可能性があります。したがって、中 ツール|オプション...その後に ザ・ マトリックス タブ、あなたは、それによって輸出をスピードアップ、以下のマトリックス]タブに表示としてエクスポートされるフォーマットの量を削減することができます。

マトリックスのエクスポート オプション

4。 エクスポート完了ダイアログが表示されます。 クリック [OK].

MS Excelの行列にエクスポート

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | Visioのからあなたのアーキテクチャへの移入 | Excelからあなたのアーキテクチャへの移入


マイクロソフトのAccessからあなたのアーキテクチャへの移入

ナビゲーション：>あなたのアーキテクチャへの移入Microsoft製品からの取り込み>

マイクロソフトのAccessからあなたのアーキテクチャへの移入

コメントを送信 このトピックに関する。

あなたはあなたのアーキテクチャ上の汎用計算、操作やレポートを実行するためのMicrosoft Accessに自分のアーキテクチャをエクスポートすることができます。その後、ABACUSに戻すアーキテクチャをインポートすることができます。

注意

データベース機能へのアクセス/エクスポートから開くことが必要です Microsoft Access 2000以降は、コンピュータにインストールされています。

マイクロソフトのAccessにあなたのアーキテクチャをエクスポートするには

1。 あなたが持っていることを確認 ABACUSファイルオープン、 エクスプローラ表示され、AN アーキテクチャ追加されました。

2。 ファイルを選択します| エクスポート | データベースに.

3。 上記のように警告ダイアログを書き留めはいをクリックして続行します。

4。 データベースファイルの場所とファイル名を選択します。

ABACUSに操作アーキテクチャをインポートするには

1。 あなたはそろばん開いていることを確認します。

2。 ファイルを選択します|新規および選択 Accessから表示され、[OK]をクリックし、ダイアログから。

3。 インポートするデータベースファイルを参照します。

ABACUS「MS Accessのデータベーススキーマ

ABACUSは、心臓Aの持っていますNオントロジー/ コンポーネント、接続、および制約で構成されたメタメタモデル。この「CCC」アプローチは、以降Avolutionの創設者はに貢献し、国際標準のIEEE 1471、で最高潮に達する1960年代から開発され、様々な標準的なアプローチに由来するものでした。以下のプリミティブが適用されます。

1。 ABACUS 含まれています ライブラリ の スタンダード（または標準）, 成分 そして 接続タイプ, 制約, 視点, テンプレート （または パターン） そして たくさんの アーキテクチャ.

2。 スタンダード, タイプ そして 視点 かもしれません論理的になります グループ化便宜上。

3。 アーキテクチャ 含まれていてもよいです多くの子孫 アーキテクチャ（またはエボリューション）。

4。 各 アーキテクチャ 含まれています たくさんの コンポーネント そして 接続特定の タイプそして、様々な ビュー.

5。 コンポーネント そして 接続することができます 分解されました に サブコンポーネント そして サブ接続.

6。 各 成分あります に添付いくつでも 接続しかし、各 接続のみすることができます に添付最大2つ コンポーネント.

7。 コンポーネント そして 接続 缶 持っています スタンダードととも​​に プロパティなどの情報、パフォーマンス、信頼性、コストなど

8。 アーキテクチャ, コンポーネント そして 接続 缶 持っています 特定 プロパティなどの情報、パフォーマンス、信頼性、コストなど

9。 制約 缶 間に存在します コンポーネントまたは 接続または に対して プロパティ.

10。 テンプレートの標準的な組成物であります 成分 そして 接続タイプ.

11。 視点の標準団体であります 成分 そして 接続タイプ表記します。

12。 ビューの視覚的表現は、 コンポーネント そして 接続.

以下のMS Accessのエンティティ関係図（ERD）は、文書化 コアアーキテクチャ、 エボリューション、 コンポーネント/接続タイプ（およびグループ）、コンポーネント/接続およびサブコンポーネント/接続の概念。

コアデータベーススキーマ

注意

参照整合性は、（特定のソースまたはシンクコンポーネントとの接続の間の「添付ファイル」の）部品表と接続表との関係に適用されていません。接続は、コンポーネントの添付ファイルなしでは存在することができるからです。私たちは、「添付ファイル」の表を追加しましたが、それに対して決定したシンプルさの利益のためにしている可能性があります。もちろん、これはすべて一緒にコンポーネントIDまたはコンポーネント行の削除のいずれかの編集を誤ったデータになりますことを意味します。 ABACUSは、不正なデータを無視して、インポートの任意の不正を処理します。

以下のMS AccessのERDは、文書化 プロパティアーキテクチャの概念、コンポーネント/接続タイプとコンポーネント/接続。

プロパティデータベーススキーマ

以下のMS AccessのERDは、文書化 スタンダードアーキテクチャの概念、コンポーネント/接続タイプとコンポーネント/接続。注：表はまだABACUSの以前のバージョンごとに用語「実装」を使用しています。

標準データベーススキーマ

以下のMS AccessのERDは、文書化 制約コンポーネント/接続タイプのコンセプト。

制約データベーススキーマ

以下のMS AccessのERDは、文書化 視点 コンセプト アーキテクチャ.注：表はまだABACUSの以前のバージョンごとに用語「TwoDTempl 'を使用します。

視点データベーススキーマ

以下のMS AccessのERDは、文書化 カタログコンセプト アーキテクチャ.

カタログデータベーススキーマ

以下のMS AccessのERDは、文書化 行列コンセプト アーキテクチャ.

行列データベーススキーマ

以下のMS AccessのERDは、文書化 ダイアグラムコンセプト アーキテクチャ.注：表はまだABACUSの以前のバージョンごとに用語「TwoD 'を使用します。

注意

MS AccessのERDの形状マッピングとフリーフォーム形状部分をステンシルするコンポーネント/接続タイプは、明確にするために省略されています.

ダイアグラムデータベーススキーマ

以下のMS AccessのERDは、文書化 3Dビューコンセプト アーキテクチャ.

3Dビューデータベーススキーマ

以下のMS AccessのERDは、文書化 チャートコンセプト アーキテクチャ.

チャートデータベーススキーマ

以下のMS AccessのERDは、文書化 ダッシュボード 概念。

ダッシュボードデータベーススキーマ

ABACUS」のMS Accessクエリ

次のようにいくつかの有用なクエリは、MS Accessのデータベースに含まれています。

· 小道具によってコンプ - このクエリは、（アーキテクチャと種類別）プロジェクト内のすべてのコンポーネントが一覧表示され、列など、すべてのプロパティが含まれています。そのプロパティで、各コンポーネント・タイプの「典型的な」テーブルを生成するために、コンポーネントの種類および/またはアーキテクチャ上のフィルタ/判断基準と、このクエリを使用します。

· 小道具によって性感染症 - このクエリを使用しているすべての規格、標準の出現回数をリストし、列など、すべてのプロパティが含まれています。標準カタログとしてこのクエリを使用してください。

· タイプ別の小道具 - このクエリは、列と、各コンポーネントの種類によって、完全なすべてのコンポーネントのプロパティとその％を示しています。特定の特性が維持されているかどうかを判断するには、このクエリを使用します。

· 小道具によってタイプ - このクエリは、すべてのコンポーネントタイプが一覧表示され、列など、すべてのプロパティの完全な％を含んでいます。特定の特性が維持されているかどうかを判断するには、このクエリを使用します。

· タイプカウント - このクエリは、すべてのコンポーネントタイプを一覧表示し、降順にそれぞれのタイプの出現回数が含まれています。プロジェクトの各タイプの人気を決定するために、このクエリを使用します。

MS Accessのメモフィールドでの作業上の注意事項

テーブル内のコンポーネント、接続、および標準名フィールドはABACUSごとに、文字の数に制限を可能にするために、メモフィールドとして定義されています。彼らはまた、参照するための一意のIDフィールドを持っているので、コンポーネントとの接続のために、これはいくつかの問題が発生していますが、MS Accessのメモフィールドに参加できませんので、テーブルを結合しようとすると、規格のために、これはいくつかの問題が発生します。また、あなたはすべてのアウトビジュアルクエリビルダに示したのと同じ効果を達成するために、Where句の基準を設定し、そのリストの下に、対応するSQLスニペットできます 継承された規格 エクスポートされたそろばんプロジェクト内のすべてのコンポーネントのプロパティ。

メモフィールドは、ビジュアルクエリビルダで「参加します」

Components.Architecture_Id、Components.Id、Components.Name、ComponentImplementationLinks.Name、ImplementationProperties.Type、ImplementationProperties.Name、ImplementationProperties.Value、ImplementationProperties.Unitを選択

コンポーネントINNER FROM ComponentImplementationLinks ONのJOIN（Components.InternalId = ComponentImplementationLinks.Id）AND（Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id）、実装INNERはImplementations.Id = ImplementationProperties.Implementation_Id ON ImplementationPropertiesを登録しよう

WHERE（（（ComponentImplementationLinks.Name）= [実装] [名前]）。）;

メモフィールドは、SQLで「参加します」

自動的にMS AccessでABACUS IDの生成に関する注意

単純なVB法は、これらの生成を助けるために提供されるように、様々なABACUS MS Accessのテーブルには、一意の長い整数のIDが必要です。二つの方法ResetCounter（）とGetNextCounter（）はABACUS「MS AccessのDB内に提供し、次のようにそれらの使用であるされています。 ResetCounter（）は、シーケンス内の次のカウンタを返しますバック0 GetNextCounter（へ）カウンタを設定します。

ResetCounter（）関数は、それだけで実行される任意のパラメータを持っていないための方法は、あなたが（あなたもGetNextCounter（）関数を実行すると、IE）のすべての行を挿入するためのResetCounter（）メソッドを呼び出した場合でも、MS Accessの「癖」を活用しますそれは一度、したがって、それぞれの行挿入のためのカウンタをリセットしません。そしてためにも同じ「癖」の毎回の実行中にそれをばかにGetNextCounter（）関数に任意の古い列変数を渡す必要があります。

あなたはそれが自分自身で列としてそこに座っているカントので、それは、選択クエリだった場合のように、SQL文に挿入でResetCounter（）関数を実行することができることにトリックもあります。それは、それは常にとにかくnullを返したように、最後にそれを連結することで、他のフィールドのいずれかのResetCounter（）呼び出しの一部を行うことをお勧めします。

下記の「コンポーネントの種類のリスト」と呼ばれるテーブル/クエリからコンポーネントタイプのリストを追加する方法の典型的なSQLの使用です。

INSERT INTOComponentTypes（ID、名前、説明）

SELECT GetNextCounter（[コンポーネントの種類の一覧] .NAME）IDとして、[コンポーネントの種類一覧]名として.NAME、[コンポーネントの種類の一覧] .DESCRIPTION＆ ResetCounter（）説明AS

から[コンポーネントの種類の一覧];

SQLのABACUS ID /カウンタの生成

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | Visioのからあなたのアーキテクチャへの移入 | Excelからあなたのアーキテクチャへの移入


Microsoft Visioのからあなたのアーキテクチャへの移入

ナビゲーション：>あなたのアーキテクチャへの移入Microsoft製品からの取り込み>

Microsoft Visioのからあなたのアーキテクチャへの移入

コメントを送信 このトピックに関する。

あなたは、Microsoft Visioのからあなたのアーキテクチャをインポートすることができます。 Visio図面内の図形は、ABACUSにコンポーネントとしてインポートされます。 Visio図面での接続は、接続としてインポートされ、描画自体が図としてABACUSにインポートされます。また、Visio図面内の任意のカスタムプロパティは、施設のタイプ、プロパティ値のプロパティ名と値をラベルにマッピングされたソート・キーを持つプロパティとしてインポートされます。

注意

Visioの機能からのインポートことが必要です Microsoft Visioの2003以降は、コンピュータにインストールされています。

ABACUSにあなたのVisio図面をインポートするには

1。 あなたはそろばん開いていることを確認します。

2。 ファイルを選択します|新規および選択 Visioのから表示され、[OK]をクリックし、ダイアログから。

注意

既存のそろばんプロジェクトにインポートしたい場合は、アーキテクチャ内のコンポーネントノードを右クリックするか、またはアーキテクチャ内の個々のコンポーネントを右クリックし、[インポート]を選択します| Visioのから。

3。 インポートするVisioファイルを参照します。

注意

以下にいくつかの簡単なルールや推奨事項MS VisioがABACUSにインポートする図面の構築（または変更）しています。

1。 線や接続は実際のコネクタ、NOT形状にする必要があります。

· それ以外の場合はABACUSはちょうどコンポーネントとしてインポートされますし、それに応じて、彼らは何に「添付」されることはありません。

· あなたには、いくつかの "スマート"ルーティング（すなわち、直線以外）を実行する必要がある場合は基本図形ステンシルで動的コネクタを使用した後、ABACUSはうまくルーティング/アンカーポイントをインポートします。

· コンポーネントの多くはそれに「接続」することを可能にするネットワークと周辺機器ステンシルから「リングネットワーク」と「イーサネット」形状を使用しないようにしてください。我々が接続などの添付ファイルが正常にインポートしている間に元の形状は、まだ添付ファイルを反映するために、「拡大」されています。 （コネクタ「足」を含まない）の別々の独立した「ハブ/バス」形状を使用して、明示的に別々のコネクタをハブ/バスに各コンポーネントを接続します。

· 回線または接続が形と同じように動作している場合、その上で右クリックし、[書式]に行きます|行動... 'とインタラクションスタイルはライン（1次元）に設定されていることを確認します。

2。 コンポーネントは、形状、NOTコネクタする必要があります。

· それ以外の場合はABACUSは、単に接続としてそれらをインポートしますし、それに応じてすべての形状情報が失われます。

· コンポーネントは、コネクタのように動作している場合、その上で右クリックし、[書式]に行きます|行動... 'とインタラクションスタイルはボックス（2次元）に設定されていることを確認します。

3。 コネクタの端が形状の背景に漂っないで、形状に添付する必要があります。

· あなたは形状にコネクタを接続しない場合は、ABACUSでは、形状/コンポーネントに与えられたコネクタを添付することを目的とし、それに応じて、接続、未接続の終わりを残すことを知る方法がありません。

4。 形状のラベルは（可能な場合）形状、NOT図面上の別のテキストボックスの作り付けのテキストラベルでなければなりません。

· 個別のテキストボックスには、自分の権利のコンポーネントとしてABACUSが輸入してしまいますと、あなたはABACUSで実数成分と「ラベル」コンポーネントをマージするか、単に自由形式の形状（すなわちないコンポーネント自体）に「ラベル」コンポーネントを変換することができながら、それは、これらの手順を回避するのが最善です。

5。 怠惰に、異なる形状のステンシルから時々長方形とボックスその他を使用しないでください、同じタイプのインスタンスごとに同じ基本形状を使用してください。

· ABACUSは、ベース形状を使用し、一意のコンポーネントと接続タイプの図で非常に「赤い四角形」と「赤い箱」を識別するためのベースカラーは、2つの別々のコンポーネントタイプとしてインポートされます。これらのコンポーネントタイプは、ABACUSにマージすることができますが、これらの手順を回避するのが最善です。

6。 完全端にぶら下がって、それらを残していない、彼らの "親"内 "子供"の形をカプセル化します。

· ABACUSは、完全にそのようにラベル部分を含め、必ず全体の形状を作る親の子として別の形状内にカプセル化された任意の形状、封入されているが検出されます。

7。 2その他の形状に重なる形状を配置しないでください。

· 形状は、2つの他の形状と重なる場合は、それを「グループ化」/背景の長方形になるか、そうでなければ、それが重なった形状でもないの子であるが、コンポーネントとしてABACUSによってインポートされるとすぐにABACUS「描画ツールでコンポーネントを選択するとポイントを参照し、原因左上のコンポーネントであることに、それは左オーバーラップ形状/コンポーネントの子になります。

8。 これらは、自分の権利のコンポーネントとしてインポート取得し、ABACUSでフリーフォームの形状に変換する必要がありますので、図面にテキストメモの使用を最小限に抑えるようにしてください。彼らは本当に既存のコンポーネントまたは接続の名前であるかどうかについて考えてみよう。

9。 ABACUSが豊富なサポートしていますがABACUSは現在、同じように/色の/ベクトルベースの​​形状は、形状のためにビットマップ、外国の形状および拡張メタファイルの使用を最小限に抑えるようにしてくださいではありませんこれらの型をサポートしています。彼らはシンプルな白い四角形としてインポートされます。

10。 彼らは特殊文字 "[]" ABACUS inのコンポーネント名としてインポートして示しているようにラベルで、キャリッジリターン（シフト・リターン）を避けるようにしてください。

11。 同じ型の形状のために使用される異なる色を最小限に抑えるようにしてください。前述のように複数のバリエーションがABACUSでポストインポートを実行する必要がありますより多くの合併や統合がありますので、ベースカラーとベース形状が一意のコンポーネントとの接続の種類を識別します。

12。 形状はコーナーにすべての方法を満たされていれば、効果がありませんABACUSの後半でそれを着色するために満たされた形状を有するように注意してください.

13。 複雑なラインベース形状のためには、以前のものが終了する場所始まる行を有し、その後、最終的には、開始点に戻って行くことによって作成されたポリゴンを使用する必要があります。必要に応じて、ポリゴンは「矢印」または任意の形状、あなたが望むように見えるようにするために塗りつぶしと線幅を使用することができます。

14。 MS Visioで図形IDがちょうどShape.xx意味がないことを確認してください。これは、MS Visioの開発者モード（| MS Visioでオプションツールを使用して有効）で利用可能で、右クリックして[シェイプシートの表示」を使用して編集可能です。

15。 楕円と円弧図形内ABACUSでサポートされていますが、NURBSとスプラインは、現在サポートされていません。

16。 全体の形状は、MS Visioでグループ化されているか、いくつかの構成要素/タイプとしてインポートしまいますことを確認してください。

17。 彼らは時々正しくインポートされませんようsubshapes内で回転形状の使用を最小限に抑えるようにしてください。

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | Accessからあなたのアーキテクチャへの移入 | Excelからあなたのアーキテクチャへの移入


Excelからあなたのアーキテクチャへの移入

ナビゲーション：>あなたのアーキテクチャへの移入Microsoft製品からの取り込み>

Excelからあなたのアーキテクチャへの移入

コメントを送信 このトピックに関する。

あなたがExcelのスプレッドシートから、あなたのアーキテクチャをインポートすることができます（.XLS または.xlsx形式 ファイル）。 Excelのインポートを使用すると、関連するデータが含まれているスプレッドシート内の列を選択することによって種類、規格、特性と標準プロパティを持つコンポーネントと接続のリストをマッピングすることができます。しかしながら、より高度な技術であり、 推奨されるアプローチ経由でMS Excelからインポートします カタログ 説明されているように ここに .

注意

インポート/エクスポートからExcelへの機能は、ことが必要です Microsoft Excelの2003以降は、コンピュータにインストールされています。

Excelの輸入の主な機能は、あなたが（あなたのアーキテクチャモデルの階層構造IE）の設定ファイルを定義できるようにすることです。設定ファイルを格納ABACUSファイルにExcelファイルから以前に保存されたマッピング。一度定義すると、保存された設定ファイルは、後のさらなるインポートするために使用され、.xlsファイルにエクスポートしています。

注意

以下のセクションに示す手順では、構成ファイルを定義し、保存するためには至っていないと、初めてExcelからインポートされているユーザーのために特別です。あなたは機能をExcelにエクスポートを使用するように設定ファイルを作成し、保存する必要があります。

ABACUSにExcelスプレッドシートをインポートするには

1。 あなたはそろばん開いていることを確認します。

2。 ファイルを選択します|新規およびから選択 秀でます表示され、[OK]をクリックし、ダイアログから。

注意

既存のそろばんプロジェクトにインポートしたい場合は、アーキテクチャ内のコンポーネントノードを右クリックするか、またはアーキテクチャ内の個々のコンポーネントを右クリックし、[インポート]を選択します| Excelから。

3。 ザ・ インポートExcelスプレッドシートウィンドウが表示され

インポートExcelスプレッドシートウィンドウ

4。 クリック オープンExcelファイルアイコンとExcelは、インポートしたいファイルを参照します。

5。 選択してください ワークシートあなたは、ドロップダウンボックスからインポートしたいです。

注意

お使いのExcelファイルを開いた後、あなたが使用することができます データプレビュースプレッドシートの列と最初の25行を表示するタブをクリックします。ここから、記入するために必要な列番号を取得することができます コンポーネント そして 接続 タブ。

また、あなたがExcelスプレッドシート内のコンポーネントは大文字と小文字の区別をインポートするかどうかを選択することができます。単にダニ 大文字と小文字を区別してインポートオプション（デフォルトでは、これは常にチェックされます）と、スプレッドシートは、それに応じてインポートされます。

サンプルExcelファイル

注意

この例では、上記のスクリーンショットに示されているExcelデータからの簡単なインフラや人々の建築をインポートします。接続は、それらの人々が管理することを「責任者」および「サーバー」の間で行われます。

[コンポーネント]タブを移入するには

このセクションでは、コンポーネントのタイプと構成ファイルの階層構造を定義するためのものです。

1。 選択 コンポーネント タブ。名前の変更 セットIDオーバーライドし （ヌル） 値

注意

この機能を使用すると、完全に異なる定義することができます セット機能的に独立したコンポーネントの。下のスクリーンショットに示すように、あなたの人々の構成要素からあなたのインフラストラクチャコンポーネントを区別することができます。コンポーネントのこれらの別個の組の関係（接続）がある場合は、下に定義することができます。 接続 タブ。その後、この例では、インフラと人との間にタイプ「管理する」の接続を定義します セット.

また、あなたはトップレベルを追加するかどうかを選択することができます グループ化セットのすべての要素のためのコンポーネント。単にダニ グループで設定IDオプション（デフォルトではチェックを外す）でスプレッドシートは、それに応じてインポートされます。

セットIDの割り当て

2。 一度 セット定義されている選択 セットあなたが移入し、をクリックして拡大したいです [+] 符号。

3。 選択 このセット内のコンポーネントのレベル展開されたリストから。

4。 ザ・ コンポーネント階層のセット：セットIDウィンドウは、そのために表示されます セット.

コンポーネント階層と値の代入（セットID：インフラストラクチャ）

5。 名前の変更 レベル番号オーバーライドした列 （ヌル） 値。

注意

ザ・ レベル番号列は、あなたのコンポーネントに階層を割り当てることができます。最初のレベルは、ほとんどのトップとなる各レベルは、あなたのアーキテクチャ内の層に相当します 親 レベル。例えば、レベル番号が「1」で最上位階層に対応し、レベル番号が「2」というようにレベル番号「1」の子です。

6。 それぞれにExcelスプレッドシートから関連する列を選択し、割り当てます レベル番号以下の下でそれを入力することによって、 構成列 カラム。

注意

あなたは、あなたのアーキテクチャで表現されないようにする特定の行を除外するように選択することができます。これらの行が使用除外するには、列ヘッダーなど、空の行であってもよく、 除外する行：ウィンドウの右上隅付近にテキストボックス。この例では、それが私たちの列ヘッダーが含まれているため、行1を除外しました。

7。 あなたは、上書きしてあなたのコンポーネントに説明を追加することを選択できます （ヌル）の値 説明列.

注意

この説明は、下ABACUSに表示されるものです 一般プロパティセクション| 説明 フィールド。

8。 指定されたスプレッドシートの列がセルごとに複数のコンポーネント（Alt-EnterキーまたはCHAR（10）コマンドを使用して入力）している場合は、下のチェックボックスをチェック 新しい行は、別個の構成要素として扱います。各行は別々​​のコンポーネントとしてインポートされます。

先端

行で指定されたコンポーネントは、（セルA2で言う）コンポーネントに接続されていることを意味します。与えられた「マトリックス」のセル（D2は言う細胞B2）中の「X」列のコレクションから、「マトリックス」をインポートするには（行1で言う）「見出し」欄で指定された、単純な式を使用することができます。マトリックスセルを越えて列の各行に、次の式を入力します（F列は言います）。 = IF（B2 = ""、 "" $ 1＆CHAR（10）B）＆IF（C2 = ""、 ""、C $ 1とCHAR（10））＆IF（D2 = ""、 ""、D $ 1とCHAR（10））。次に行で指定されるコンポーネント（カラムAで言う）、この式で記載されているものとの間で下記のように設定された接続（F列で言う）を設定。確認してください 新しい行は、別個の構成要素として扱います式のコンポーネントがインポートされているオプション。ただの 'X'よりも階層または異なる値を持つセルの複数の層との見出しを含む、より高度な行列のインポートについては、お問い合わせください Avolutionサポート .

9。 必要に応じて、残りの列に入力します。

注意

あなたは、下のチェックボックスをカチカチして、列の行からタイプを取得するために選択することができます 列から型を取得します列と下のExcelのスプレッドシートから関連する列を入力します コンポーネントの種類の値または列 カラム。これは、その列のすべてのコンポーネントをインポートし、列に定義された型にそれらを設定します。また、上記と以下のスクリーンショットのように、あなたは下のタイプ名を入力することにより、固定/事前定義されたタイプ名を使用するように選択することができます コンポーネントの種類の値または列チェックボックスが未チェックされていることを確認列となっています。

コンポーネント階層と値の代入（セットID：人）

注意

この例では、アーキテクチャのレベル1で、当社のネットワークや人々のグループ化を希望します。レベル2では、私たちは当社のサーバーおよびそれらのサーバーを管理する責任者を持つことを望みます。ザ・ コンポーネント上記の二つのスクリーンショットに示すように、タブは、それに応じて記入されています。最初のスクリーンショットでは、インフラストラクチャのために、レベル1（ネットワークグループ）とレベル2（サーバー）のコンポーネントを定義した上に セット。そして、スクリーンショットに、私たちは人々のために、レベル1（グループ名）とレベル2（人責任）の構成要素を定義した直上 セット.

また、用 人セットではなく、人々のグループのように列Cを使用するよりも、我々が使用している可能性が グループで設定IDトップレベルのコンポーネント]タブの[オプションとそしてちょうどこれは、以下のスクリーンショットに示されている列Dから1人のサブレベルに入りました。

コンポーネント階層とグループで設定したIDオプションを使用して、値の代入（セットID：人）

10。 コンポーネントが特定されたら、あなたは特性および/または基準を移入し、をクリックして拡大するコンポーネントレベルを選択 [+] 符号。

11。 選択 このレベルでのコンポーネントのプロパティ または このレベルでのコンポーネントの標準化展開されたリストから、必要に応じて、関連するカラムを投入。

取り込みコンポーネント

注意

このレベルでのコンポーネントのプロパティあなたが選択したレベルでのコンポーネントのプロパティを定義することができます。 このレベルでのコンポーネントの標準化あなたが選択したレベルでの部品の標準化とその標準プロパティを定義することができます。

12。 手順を繰り返し 2から11すべてのコンポーネントのレベルが定義されているすべてのために移植されているまで、 セット。背面に移動するには、ウィンドウの右上隅の近くに戻って矢印を使用し セットこれは以前に定義しました。

[接続]タブを移入するには

このセクションでは、接続タイプ、および構成ファイルの階層構造を定義するためのものです。

1。 選択 接続 タブ。接続の各セットのためには、コンポーネントを識別しなければなりません セットあなたは、ソース・コンポーネントおよびコンポーネントになりたいこと セットあなたは先のコンポーネントになりたいです。

2。 下に ソースコンポーネントセットID入力します セットに対応する名前 セット以前で定義されています コンポーネント タブ。下に ソースコンポーネントレベル番号あなたは、接続のソース端に接続したいコンポーネントレベルに対応する番号を入力してください。

3。 今すぐ接続の先端にされるコンポーネントグループを選択します。下に デスティネーションコンポーネントセットID入力します セットに対応する名前 セットで定義されています コンポーネント タブ。下に 宛先コンポーネントレベル数あなたは、接続の先端部に接続するコンポーネントのレベルに対応する番号を入力してください。

注意

この例では、我々は、彼らが管理するサーバーへのサーバーの管理を担当する人を接続したいです。責任者は、人々の中で定義されました セットレベルとしてサーバながら2つのコンポーネントは、インフラストラクチャ内で定義されていました セットレベルとして2つのコンポーネント。ザ・ 接続次のスクリーンショットに示すように、タブは、それに応じて記入されています。

接続2のタブパート1

4。 あなたが右にスクロールすると、あなたの接続をインポートするための追加オプションがあります。 列から型を取得します そして 接続タイプの値または列以下の場合と同じように動作します コンポーネント タブ。

5。 もし ソースコンポーネントセットID そしてその ソースコンポーネントレベル番号同じです デスティネーションコンポーネントセットID そしてその 宛先コンポーネントレベル数その後、繰り返し、それらのサーバーの名前が含まれているスプレッドシート内の別の列を持っている必要があります（たとえば、あなたは、他のサーバーへのサーバーからの接続を行うように、同じコンポーネント・タイプを接続している場合）。このような状況では、そのスプレッドシート内の列を置きます コラムで繰り返し先 カラム。そのスプレッドシートの列に、セルごとに複数の連結成分を入力した場合は、下のチェックボックスをチェック 新しい行は、別個の構成要素として扱います.

接続2のタブパート2

6。 接続は、接続を選択し同定されているたら、特性および/または基準を移入し、をクリックして拡大したいです [+] 符号。

7。 選択 これらの接続のプロパティまたは これらの接続のための標準展開されたリストから、必要に応じて、関連するカラムを投入。

注意

これらの接続のプロパティあなたが選択した接続グループのプロパティを定義できます。 これらの接続のための基準あなたが選択した接続グループの基準とそれらの標準プロパティを定義することができます。

8。 手順を繰り返し 2から7すべての接続のグループが定義されるまで。

9。 あなたが接続グループの定義が終了したら、をクリックしてください フィニッシュボタンとあなたのアーキテクチャでは、インポートされたExcelファイルから作成されます。上記の例は、以下のスクリーンショットに示すアーキテクチャになります。

サンプルのアーキテクチャは、Excelからインポート

10。 今をクリックしてファイルにマッピングされた設定を保存 設定の保存 アイコン。保存した設定はをクリックして、後で取り出すことができます 設定を開きますウィンドウの左上隅の近くにアイコンが表示されます。

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | Accessからあなたのアーキテクチャへの移入 | Visioのからあなたのアーキテクチャへの移入


マイクロソフトのSharePointからあなたのアーキテクチャへの移入

ナビゲーション：>あなたのアーキテクチャへの移入Microsoft製品からの取り込み>

マイクロソフトのSharePointからあなたのアーキテクチャへの移入

コメントを送信 このトピックに関する。

あなたはできる 同期します あなたのアーキテクチャ ととも​​にマイクロソフト SharePointリスト. 同期は、どちらかがABACUSの種類、それらのプロパティと添付ファイルから新しいSharePointリスト（とその列）を作成、またはABACUSタイプに既存のSharePointリストをマッピング（およびその列）、そのプロパティと添付ファイルは、いずれかのSharePointまたはSharePointにABACUSからコンテンツを送信することを伴いますABACUSへ.

注意

ザ・ SharePointの同期 機能は、ことが必要ですA マイクロソフト SharePoint 2010の2013年または SharePoint Onlineの サイトに接続し、と同期可能です.SharePointの同期機能は、任意のABACUSプロジェクトからSharePointサイト上の（列の）リストを作成することはできますが、Avolutionもそうお問い合わせください標準フレームワークのサポート（例えば、TOGAF、ArchiMate、ITILなど）のさまざまなSharePointサイトのテンプレートを提供することができます Avolutionサポート あなたはこの機能を必要とする場合.

に 新しいSharePointリストを作成し、ABACUSコンポーネントまたは接続タイプにマップ

1。 あなたはそろばん開いていることを確認します。

2。 選択 ツール| SharePointの同期.

3。 クリック 新しいマッピングボタンとSharePointのマッピング]ダイアログ以下に示すように表示されます。

4。 SharePointサイトの[サイトのURL、ユーザー名とパスワードを入力し、クリックして つなぎます.

注意

有効なSharePointの「管理者」または「貢献者」アカウントは、SharePointからとに同期することが要求されると「読者」のアカウントのみのSharePointから同期が可能になります。

5。 からマッピングするためにABACUSコンポーネントまたは接続タイプを選択 タイプを選択 引き下げる。

6。 クリック 新しく追加するボタンを押して、あなたが左側のパネルで項目を選択し、右側のパネルで新規一覧カラム（初回のみ）に新しいSharePointリストの名前を入力し、対応するSharePointリストのフィールドにマップしたい各ABACUSコンポーネントまたは接続タイプの側面のための、その後、SharePointの列列名に名前（またはデフォルトを使用します）、クリック 割り当てる 毎回。

注意

同期にそろばんEEIDを可能にするために最低でも、建築と名前の側面は自動的にSharePointの番号とテキストの2つ（2）シングルライン（別名テキスト）列それぞれにマッピングされます。これらは、割り当てられていないことはできません。また、唯一の特定のそろばんの側面は、現在、特定のSharePoint列にマップすることができ、列タイプのプルダウンは自動的に必要なSharePointの列タイプに設定されます.すなわち、

· SharePointの複数のテキスト行（別名注）列にABACUS「階層パス（注：テキストのSharePointのシングルライン（これらは好ましいものではないので、別名テキスト）列のみ255文字をサポートしています）、

· SharePointのルックアップ列にABACUS」付け部品（注：マッピングがすでに接続コンポーネント自分自身のために、リストに存在している必要があります）、

· ABACUS「テキストと説明プロパティテキストのSharePointの複数行（別名注）カラム（注：テキストのSharePointのシングルライン（これらは好ましいものではないので、別名テキスト）列のみ255文字をサポートしている）に、

· SharePointの数の列にABACUS「小数または整数の性質、

· SharePointの選択列にABACUS「リストのプロパティ（注：リストのデータ型はABACUSに施行する必要はありませんので、SharePointは選択値を強制しません）、

· テキストのSharePointの複数行（注別名）の列（注：SharePointの日付と時刻の列が原因でタイムゾーン/地域化の設定のためのSharePointの一貫性のない支援にまだとして使用することはできません）にABACUS「日付/時刻のプロパティ、

· SharePointのはい/いいえ（別名ブール）列にABACUS「ブールプロパティ。

ABACUS要素の関連規格はまだSharePointリストの列にマップすることはできません。

7。 選択 マッピングの作成.

に ABACUSコンポーネントまたは接続タイプと、既存のSharePointリストの間に新しいマッピングを作成

1。 あなたはそろばん開いていることを確認します。

2。 選択 ツール| SharePointの同期.

3。 クリック 新しいマッピングボタンとSharePointのマッピング]ダイアログ以下に示すように表示されます。

4。 SharePointサイトの[サイトのURL、ユーザー名とパスワードを入力し、クリックして つなぎます.

注意

有効なSharePointの「管理者」または「貢献者」アカウントは、SharePointからとに同期することが要求されると「読者」のアカウントのみのSharePointから同期が可能になります。

5。 からマッピングするためにABACUSコンポーネントまたは接続タイプを選択 タイプを選択 引き下げる。

6。 からマッピングするために、SharePointサイトのリストを選択 選択リスト 引き下げる。

7。 各ABACUSコンポーネントまたは接続タイプの側面のためには、それぞれ左パネルと右のパネルで項目を選択してクリックし、対応するSharePointリストの列にマップしたいです 割り当てる.

注意

同期を可能にするために最低でもABACUS EEID、建築と名前の側面には、テキスト（別名テキスト）のシングルラインまたはそれぞれのテキスト（注別名）の列の複数行のいずれかに建築と名前のためにし、SharePoint番号にマップする必要があり、。それが完了するまでマッピングの作成]ボタンが有効になりません。また、唯一の特定のそろばんの側面は、現在、特定のSharePoint列にマップすることができます.すなわち、

· テキスト（別名テキスト）または複数行のテキスト（別名注）列のSharePointのシングルラインにABACUS「アーキテクチャの側面（以下に説明するように、これはコンテンツ固有のマッピングのために必要とされます）、

· SharePointのシングルテキスト（別名テキスト）の行またはテキスト（別名注）の複数行にABACUS「階層パス列（注：テキストのSharePointのシングルライン（別名テキスト）列のみ255文字をサポートしているので、任意の追加の文字なので切り捨てとなりますそれは、複数行のテキストマッピングする前に、SharePointで（別名注）列）に変換することが推奨され、

· SharePointのルックアップ列にABACUS」付け部品（注：マッピングがすでに接続コンポーネント自分自身のために、リストに存在している必要があります）、

· SharePointのシングルテキスト（別名テキスト）の行またはテキスト（注別名）の列の複数行にABACUS「テキストと説明プロパティ（注：テキストのSharePointのシングルラインを（別名テキスト）列のみ255文字をサポートしているので、追加の文字が切り捨てられますそのためには、複数行のテキスト（別名注）マッピングする前に、SharePointで列）に変換することが推奨され、

· ABACUS「SharePointの数の列に小数または整数の性質（注：SharePointの算出列は、しかし、彼らは唯一のSharePointからABACUSに同期できるようになります使用することができます同期しようとしています。「計算された列」には、以下のとおり警告が発生します） 、

· SharePointの選択列にABACUS「リストのプロパティ、

· テキストのSharePointの複数行（注別名）の列（注：SharePointの日付と時刻の列が原因でタイムゾーン/地域化の設定のためのSharePointの矛盾サポートするために使用することはできません）にABACUS「日付/時刻のプロパティ、

· SharePointのはい/いいえ（別名ブール）列にABACUS「ブールプロパティ。

ABACUS要素の関連規格はまだSharePointリストの列にマップすることはできません。また、SharePointの通貨、個人またはグループ、ハイパーリンクや画像、タスクの結果、外部データと管理メタデータ列は、まだABACUSの側面にマップすることはできません。

8。 選択 マッピングの作成.

に 同期しますあなたのマイクロソフト SharePointリスト（複数可）ABACUSへ

1。 あなたはそろばん開いていることを確認します。

2。 選択 ツール| SharePointの同期.

注意

に でSharePointリストを同期させますABACUSプロジェクトユーザーライセンスが必要 SharePointの同期アドオン機能。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

3。 既存のSharePointのマッピングを選択します（またはマッピングが使用して Ctrlキーを押しながらクリック または すべて選択からボタン） SharePointのマッピング パネルサンプルのスクリーンショットに示すように、 上記。注意：ここでは目標が選択されていると呼ばれるSharePointリストにちょうど 'ゴール（または要件）「ABACUSコンポーネントタイプのマッピングを示しています.

4。 あなたがからでコンテンツを同期することアーキテクチャ（複数可）を選択 アーキテクチャからの同期の内容パネル等 サンプルのスクリーンショットに示されています 上記。注意：ここでは同期され、単に「2015年実績」アーキテクチャを示しています。

5。 選択 SPからの同期 ボタン.

注意

SharePointサイトの認証情報をマッピングするための「保存されたすべての '（s）が選択されていない場合は、SharePointのダイアログへのログインを求めて表示されます。 サイトURL, ユーザー名 または パスワード.これらを入力してください。また、同期が付け部品/ルックアップ列のために必要とされる任意の他のマッピングが含まれます。自動的に含まれる任意の追加のマッピングは以下の通りダイアログに表示されます。

6。 変更と警告をリストの下に示すように、正常な同期でSharePointの同期結果]ダイアログが表示されます。 クリック [OK].

に ABACUSからに同期 あなたのマイクロソフト SharePointリスト（複数可）

1。 あなたはそろばん開いていることを確認します。

2。 選択 ツール| SharePointの同期.

注意

に でSharePointリストを同期させますABACUSプロジェクトユーザーライセンスが必要 SharePointの同期アドオン機能。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

3。 既存のSharePointのマッピングを選択します（またはマッピングが使用して Ctrlキーを押しながらクリック または すべて選択からボタン） SharePointのマッピング パネルサンプルのスクリーンショットに示すように、 上記。注意：ここでは目標が選択されていると呼ばれるSharePointリストにちょうど 'ゴール（または要件）「ABACUSコンポーネントタイプのマッピングを示しています.

4。 あなたがからでコンテンツを同期することアーキテクチャ（複数可）を選択 アーキテクチャからの同期の内容パネル等 サンプルのスクリーンショットに示されています 上記。注意：ここでは同期され、単に「2015年実績」アーキテクチャを示しています。

5。 選択 SPに同期 ボタン.

注意

SharePointサイトの認証情報をマッピングするための「保存されたすべての '（s）が選択されていない場合は、SharePointのダイアログへのログインを求めて表示されます。 サイトURL, ユーザー名 または パスワード.これらを入力してください。また、同期が付け部品/ルックアップ列のために必要とされる任意の他のマッピングが含まれます。自動的に含まれる任意の追加のマッピングは以下の通りダイアログに表示されます。

6。 変更と警告をリストの下に示すように、正常な同期でSharePointの同期結果]ダイアログが表示されます。 クリック [OK].

注意

ABACUS 'は、この列には情報が含まれていることを必要とするが、「SharePointで[はい]に設定されている場合でも、ブランク値とのSharePoint列を更新します。 SharePointは、外部からこの設定を公開しないためです。これを防止しようとする場合には、ABACUSデザイナーが「ABACUSを使用して、指定されたプロパティにTrueにし、強制に必要な制約を設定することをお勧めします 制約 特徴 .

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | Visioのからあなたのアーキテクチャへの移入 | Excelからあなたのアーキテクチャへの移入


Microsoft SQL Serverのからあなたのアーキテクチャへの移入

ナビゲーション：>あなたのアーキテクチャへの移入Microsoft製品からの取り込み>

Microsoft SQL Serverのからあなたのアーキテクチャへの移入

コメントを送信 このトピックに関する。

あなたは、Microsoft SQL Serverデータベースからあなたのアーキテクチャをインポートすることができます。あなただけの効果だけでなく構造が、データだけでなく、インポートするデータベースやテーブル、行との関係だけの一般的な構造をインポートするテーブルとリレーションシップをインポートするかを選択できます。

注意

SQL Serverの機能からそのを必要とします Microsoft SQL Serverの20052008年、2008、2012または2014コンピュータにインストールされています。

ABACUSにMicrosoft SQL Serverデータベースをインポートするには

1。 あなたはそろばん開いていることを確認します。

2。 ファイルを選択します|新規および選択 SQL Serverから表示され、[OK]をクリックし、ダイアログから。

3。 以下のサンプルのスクリーンショットのように「MACHINENAME 'と接続文字列変数とその正しい値にデータベース名変数の「DBNAME」値の「SQLINSTANCE」の値を設定する表示されますインポートSQL Serverのダイアログで。

4。 以下のサンプルのスクリーンショットに示すように、上記の手順で設定した初期カタログ変数と同じ値にデータベース名変数を設定します。

5。 ダイアログのセクションをインポートするテスト接続]ボタンとテーブルを押して以下のサンプルのスクリーンショットに示すように、利用可能なデータベーステーブルに移入する必要があります。

6。 あなたがそれらを個別に選択するか、ダイアログの右側にあるすべて、なしと反転ボタンを使用していないいずれかの方法でインポートするテーブルを選択します。

注意

インポートしてしまいます選択テーブルの間に存在するだけの外部キー関係。

7。 インポートスタイルのラジオボタンを使用すると、あなただけのテーブルとテーブルやテーブル間の関係、その行と列の間に特定の関係をインポートするかを選択します。

注意

最初のオプションは、型 'テーブルの関係」の接続として輸入されている型'テーブル 'と（外部キー）から任意の2つのテーブル間のリレーションシップの構成要素としての表をインポートします。これは、システムテーブルの古典的な「ERD」形式のビューです。 2番目のオプションは、カラム/フィールドのそれぞれに対応するプロパティを持つタイプ 'テーブルの行」の個別のサブコンポーネントとしておよび型'テーブルの関係」の表の行との関係で表の行をインポートします。また、これは個々のテーブル行のサブコンポーネントに名前を付けるために使用されている「名前」という列/フィールドが存在する場合。

8。 インポート...]ボタンを選択します。

9。 （フィードバックのためのプログレスバー付き）、短時間（第2オプションは上記のステップで選択された場合）、新しいそろばんプロジェクトがテーブル、テーブルの行を使用して作成された後、およびMicrosoft SQL Serverデータベースからの関係。

参照してください

お使いのアーキテクチャの移入 - 概要 | 手動であなたのアーキテクチャへの移入 | Visioのからあなたのアーキテクチャへの移入 | Excelからあなたのアーキテクチャへの移入


コンポーネント、接続またはタイプに事前設定プロパティを追加します

ナビゲーション：あなたのアーキテクチャへの移入> [プロパティ]> [

コンポーネント、接続またはタイプに事前設定プロパティを追加します

コメントを送信 このトピックに関する。

プロパティの標準ライブラリが指定されており、アーキテクチャの何か他のものに割り当てることができます。これらのライブラリは次のように知られています スタンダード。使用することにより スタンダード、あなただけの特定のシステムのプロパティを収集する必要がある - 標準プロパティが既にあります。

例えば、マイクロソフトのWindows 2000の標準的な性能特性は、として保存することができます 標準およびすべてのコンポーネントに割り当てられました （または接続ではなく、それが典型的であること） Microsoft Windows 2000オペレーティングシステムを使用しました。

追加します 標準コンポーネント、接続またはタイプ

1。 右クリックコンポーネント/接続/タイプに。

2。 選択 割り当てる 標準.

3。 選択A 標準リストから。

参照してください

お使いのアーキテクチャの移入 - 概要 | コンポーネント、接続またはタイプのプロパティの変更 | 集計プロパティ


コンポーネント、接続またはタイプのプロパティの変更

ナビゲーション：あなたのアーキテクチャへの移入> [プロパティ]> [

コンポーネント、接続またはタイプのプロパティの変更

コメントを送信 このトピックに関する。

プロパティは、一般的に、ユーザーが定義し、システム要件、またはABACUS「評価の結果です。 （ABACUSは、その評価を行う場合、それは戻ってファイルにプロパティを書き込みます。）つまり、プロパティは、あなたのシステムについて知っているもの、またはあなたが見つけるためにABACUSを使用しているものです。

コンポーネント、接続または型のプロパティ値を変更するには

1。 クリックコンポーネント/接続/種類（そのプロパティは、右の[プロパティ]ウィンドウに表示されます）。

2。 クリック変更するプロパティをハイライトします。

3。 タイプ新しい値。

重要

また、多くのプロパティが使用して定義されます スタンダード 。内のプロパティを変更することにより 標準、あなただけの現在のオブジェクトを変更しないで、あなたはまた、マスターを変更 標準 （下 標準でツリーの最上部）。これを行う前に、他のコンポーネント、接続や種類、使用しているかどうか確認 標準、変更がそれらに適切ではないかもしれませんので、 - あなたは、このための参照ウィンドウを使用することができます.

先端

あなたは木（およびその逆）のコンポーネント支店内からの接続のプロパティを変更することができます。だから、何の接続を見ている場合には、例えば、成分に結合され、あなたはあなたができる、あなたは1を変更する必要が実現しています。

（タイプによって）コンポーネントまたは接続に新しいプロパティを追加するには

注意

プロパティのタイプとコンポーネントまたはタイプの接続にのみを追加することができますが、それらの特性を「継承」。

1。 クリックタイプ（そのプロパティは、右の[プロパティ]ウィンドウに表示されます）。

2。 クリック[プロパティ]ウィンドウの上部にある[追加]ボタンの上に新しいプロパティのためのプロパティグリッドの最上部に行を追加します。

3。 追加 タイプ新しいプロパティの。

4。 追加 名新しいプロパティの。

5。 追加 省略時の値新しいプロパティの。

6。 追加 ユニット新しいプロパティの。

7。 設定 データ型新しいプロパティの。

注意

データタイプフィールドは、プロパティを持つことができる有効な値を制限するために使用することができます。あれは;テキスト、整数、10進数、日付/時刻、ブール値またはリスト。

o A テキストプロパティは、文字の数に制限があり、本質的価値に制限はありませんものです。プロパティの値が適切に形成されたハイパーリンクである場合（つまり、 URLは、のいずれかで開始する必要があります 5文字列; http：//、https：//には、ftp：//, ファイル：または\\と任意のスペースは「％20」で入力する必要があります）、リンク）は、CTRL +クリックを経由して（クリック可能です。

o アン 整数プロパティには、正または負の整数でなければなりませんプロジェクトのに応じて、桁区切りのための期間、スペース、アポストロフィまたはカンマが含まれていてもよいです リージョンの設定 から ファイル|プロジェクトオプション.地域の設定と。ネット Long.TryParse方法 あります 有効決定するために使用 整数価値観.

o A 10進数プロパティが含まれていることができます 小数点のピリオドやカンマとプロジェクトのに応じて、桁区切りのための期間、スペース、アポストロフィまたはカンマが含まれていてもよいです リージョンの設定 から ファイル|プロジェクトオプション.地域の設定と。ネット Decimal.TryParse方法 あります 有効決定するために使用 10進数 価値観.

o A 日付時刻プロパティは、日付部分または時刻部分のいずれか、または両方を可能にします。地域設定.NET DateTime.TryParse方法 主に有効な日付/時刻値を決定するために使用されます。しかし、適用が有効であるために、少なくとも日と月（年は現在の年と見なされます）、または月と年の部分を必要とする場合は日付の部分。すなわち6月には、2010年第3四半期あるいは単に2010が無効です。 （ ' - '）またはスラッシュ（ '/'）それは別の地域の設定で異なりますが、通常は日、月、年の部分は、スペース、コンマ、ダッシュで分離することができます。日の部分は、通常、月の部分は、典型的には1〜12の整数である1から31の整数である、月（例えば月、2月、マル）または完全な月名の有効な3文字の省略形（1月、2月など、 行進）。 >タのデータ>カレンダー - 年の部分は、典型的には4桁の正の数が、1、2、3桁の年は、コントロールパネル]> [地域と言語のオプション] - > [地域オプション] - > [カスタマイズ（ボタン）の設定に応じて受け入れられています。通常、それらは次のように解釈されます。 0-29は、1930年から1999年と100から999などの100から999のように99に、2000年から2029年として30を解釈されます。このような2010年6月31日と31/9/2010として無効な日付が検出されます。該当する場合時刻部分は、必要に応じて時間と分の部分と秒の部分を必要とします。 （ '：'）および秒の部分は、小数点で指定することができる時間、分、秒の任意の部分は、一般的に、コロンで区切られます（ '。'）。有効な形式の詳細についてはネット上の解説セクションを参照してください DateTime.TryParse方法 .

先端

これは、これらの値は依存ほとんどの地域全体で検証するように日付値ではなく、数値の書式設定のために少なくとも3文字の月名の形式（すなわち、「7月」または「7月」）（すなわち、「7」または「07」）を使用することをお勧めしますプロジェクトの上 リージョンの設定 から ファイル|プロジェクトオプション.すなわちそれはむしろ「15/7/2010」より「2010年7月15日」または「2010年7月15日」を使用することをお勧めします。この例では、「15/7/2010」は「英語（米国）」の検証に失敗し、「2010年7月15日」は「英語（イギリス）」のために失敗する、しかし「2010年7月15日には」を渡しますどちらも。

o A ブーリアンプロパティには、TrueまたはFalseのいずれかになります。しかしはい、いいえ、1、0等は、すべての任意のプロパティの制約を失敗するも使用することができますので、TRUEまたはFALSE大文字と小文字を区別しません。

o A リスト|プロパティは、このような低としてあらかじめ定義された値のコレクションを可能にします中| Highまたは保持|リフレッシュ|再設計|引退と値の範囲のいずれかのカンマやパイプなどのプロパティの単位フィ​​ールドから来ます '|'区切られた値。プロパティがあると考えることができます 序数 チャート上で使用し、上の要素を着色するときので（名目、間隔または比率とは対照的に） ダイアグラムSと3DSの値は、昇順（または降順）ために、単純に処理されます。それは値がチャート軸または色の範囲の昇順（または降順）にプロットされています。

8。 データ型が設定することができます 無効, 警告または 強制ことで、任意の任意の文字がとても今まで間違ったことはできないことができ、テキスト以外の設定のためのデータ型のフィールドを右クリック。

9。 設定 必須新しいプロパティのフラグ。

注意

必須フィールドは、値はプロパティに入力する必要があるかどうかを示すために使用することができます。つまり、空白または空にすることはできませんということです。 偽デフォルトで、プロパティが空または空白であることを意味し、 真プロパティが値を持つ必要があり、空または空白にすることはできませんことを意味します。必要になるように設定することができ 無効, 警告または 強制それがTrueに設定されている場合が必要とするフィールドを右クリック。

参照してください

お使いのアーキテクチャの移入 - 概要 | コンポーネント、接続またはタイプに事前設定プロパティを追加します | 集計プロパティ


プロジェクトの地域設定を変更します

ナビゲーション：あなたのアーキテクチャへの移入> [プロパティ]> [

プロジェクトの地域設定を変更します

コメントを送信 このトピックに関する。

プロパティの値 いずれかに一致する異なる領域に特定の書式を必要とします 整数、10進数、および日付/時刻のデータ型の制約 プロパティ。ドイツでは「123.456,789」としてrepresntedことになる、フランスでそれは次のようになりながら、例えばオーストラリアでは、小数点「123456点7 8 9 "は"、 "123,456.789」として表現さ​​れます123 456789 ".同様に、米国では「1970年12月の第二は、 "" 1970年12月2日」などの短い日付として表現さ​​れていますが、イギリスでは1970年から1912年」として「1970年2月12日」とポーランドのように表されます-02 "。したがって、地域間ABACUSプロジェクトで動作するようにそろばんプロジェクトごとにグローバルな設定が必要です。

変える ABACUSプロジェクトのリージョン設定

1。 あなたが持っていることを確認 ABACUSファイル オープン.

2。 選択 ファイル| プロジェクトオプション... そして、表示​​されたダイアログから 選択します 領域 そして [OK]をクリックします。。注：地域のデフォルト値については、以下のセクションを参照してください。

注意

あなたが表示されない場合 プロジェクトオプション... メニュー項目あなたはデザイナーを持っていません および管理者 アドオンs そして あなたは、プロジェクトの地域を変更することはできません.また、何のリージョンが設定されていないならば、それぞれが（プロジェクトオプションでリージョンIEが「なし（システム領域）」です） ユーザーのMS Windowsの現在のカルチャ設定（つまり、地域の設定）プロパティを検証するために使用されます。

リージョンのデフォルト設定

次の表は、 設定された各地域のデフォルト ファイル|プロジェクトオプション...メニュー項目.使用されるシンボルのリストについては、次の表を参照してください。

領域 | 小数点記号 | 桁区切り | 負の符号 | 短時間 | 長い時間 | AM / PMシンボル | 短い日付 | 長い日付
英語（オーストラリア） | . | , | - | HH：MM | HH：MM：SS | AM | PM | DD / MM / YYYY | DD MMMMのYYYY
英語（イギリス） | . | , | - | HH：MM | HH：MM：SS | AM | PM | DD / MM / YYYY | DD MMMMのYYYY
英語（米国） | . | , | - | H：ミリメートルTT | H：mm：ssのTT | AM | PM | M / D / YYYY | DDDD、MMMM ddと、YYYY
フランス語（フランス） | , | スペース | - | HH：MM | HH：MM：SS | | | DD / MM / YYYY | DDDD D MMMM YYYY
ドイツ語（ドイツ） | , | . | - | HH：MM | HH：MM：SS | | | DD.MM.YYYY | DDDD、D。 MMMMのYYYY
イタリア語（イタリア） | , | . | - | HH：MM | HH：MM：SS | | | DD / MM / YYYY | DDDD D MMMM YYYY
スペイン語（スペイン） | , | . | - | H：MM | H：mm：ssの | | | DD / MM / YYYY | DDDD、D-D 'デ・MMMM「デ' YYYY
英語（カナダ） | . | , | - | H：ミリメートルTT | H：mm：ssのTT | AM | PM | DD / MM / YYYY | MMMM-DD-YY
フランス語（カナダ） | , | スペース | - | HH：MM | HH：MM：SS | | | YYYY-MM-DD | dはMMMM YYYY
アラビア語（U.A.E.） | . | , | - | HH：MMのTT | HH：mm：ssのTT | ص|م | DD / MM / YYYY | DD MMMM、yyyyの
アラビア語（サウジアラビア） | . | , | - | HH：MMのTT | HH：mm：ssのTT | ص|م | DD / MM / YY | DD / MMMM / YYYY
英語（南アフリカ） | , | スペース | - | HH：MMのTT | HH：mm：ssのTT | AM | PM | YYYY / MM / DD | DD MMMMのYYYY
英語（ニュージーランド） | . | , | - | H：ミリメートルTT | H：mm：ssのTT | 午前| p.m。 | D / MM / YYYY | DDDD、MMMM DのYYYY
英語（インド） | . | , | - | HH：MM | HH：MM：SS | AM | PM | DD-MM-YYYY | DD MMMMのYYYY
ドイツ語（スイス） | . | ' | - | HH：MM | HH：MM：SS | | | DD.MM.YYYY | DDDD、D。 MMMMのYYYY
フランス語（ベルギー） | , | . | - | HH：MM | HH：MM：SS | | | D / MM / YYYY | DDDD D MMMM YYYY
オランダ語（ベルギー） | , | . | - | H：MM | H：mm：ssの | | | D / MM / YYYY | DDDD D MMMM YYYY
チェコ（チェコ共和国） | , | スペース | - | H：MM | H：mm：ssの | DOP |。ODP。 | d.M.yyyy | D。 MMMMのYYYY
デンマーク語（デンマーク） | , | . | - | HH：MM | HH：MM：SS | | | DD-MM-YYYY | D。 MMMMのYYYY
ギリシャ語（ギリシャ） | , | . | - | H：ミリメートルTT | H：mm：ssのTT | πμ|μμ | D / M / YYYY | DDDD、MMMM DのYYYY
フィンランド語（フィンランド） | , | スペース | - | H：MM | H：mm：ssの | | | d.M.yyyy | D。 MMMM'ta 'YYYY
ハンガリー語（ハンガリー） | , | スペース | - | H：MM | H：mm：ssの | デ|。デュ。 | yyyy.MM.dd. | YYYY。 MMMM dを。
オランダ語（オランダ） | , | . | - | H：MM | H：mm：ssの | | | D-M-YYYY | DDDD D MMMM YYYY
ノルウェー語、ブークモール（ノルウェー） | , | スペース | - | HH：MM | HH：MM：SS | | | DD.MM.YYYY | D。 MMMMのYYYY
ポーランド語（ポーランド） | , | スペース | - | HH：MM | HH：MM：SS | | | YYYY-MM-DD | dはMMMM YYYY
ロシア語（ロシア） | , | スペース | - | H：MM | H：mm：ssの | | | DD.MM.YYYY | D MMMM YYYY "г.」
スウェーデン語（スウェーデン） | , | スペース | - | HH：MM | HH：MM：SS | | | YYYY-MM-DD | 「デン」MMMM YYYY日間
韓国語（韓国） | . | , | - | TTのH：MM | TTのH：mm：ssの | 오전|오후 | YYYY-MM-DD | YYYY「년 'M'월 'D'일「DDDD
ヘブライ語（イスラエル） | . | , | - | HH：MM | HH：MM：SS | AM | PM | DD / MM / YYYY | DDDD DD MMMMのYYYY

以下の記号は、日付と時刻の表示方法を指定するために使用されています。

時間シンボル |
h | 時間（hhは先行ゼロでの時間を表示します）
m | 分（MMは先行ゼロで分を表示します）
s | 第二に（ssが先行ゼロで秒を表示します）
TT | A.M.またはP.M.
H / H | 12または24時間の表示
日付シンボル |
D、DD | 日
DDD、DDDD | 曜日
M | 月
y | 年

参照してください

お使いのアーキテクチャの移入 - 概要 | コンポーネント、接続またはタイプのプロパティの変更 | コンポーネント、接続またはタイプに事前設定プロパティを追加します


集計プロパティ

ナビゲーション：あなたのアーキテクチャへの移入> [プロパティ]> [

集計プロパティ

コメントを送信 このトピックに関する。

操作「集計 プロパティ「あなたが選択した親要素のプロパティに結果を一緒に類似したプロパティの値を追加し、書き込み（または追加）することができます。それはまた、集計の範囲を定義することを可能にし、すべてのサブ要素またはないのプロパティを更新するかどうか。

集計プロパティに

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 集計を行うと、選択した素子（アーキテクチャ、コンポーネントまたは接続）を右クリックします 集計プロパティ.

3。 （集計オプションのいずれかを選択します。すべてのサブレベルトラバースまたは 唯一の直接サブレベル）。あなたが選択した場合 すべてのサブレベルトラバース、あなたもするかどうかのオプションを選択することができます 更新サブレベル.

o すべてのサブレベルトラバース集計の範囲は、選択した要素の下のすべてのレベルの要素が含まれることを意味します。

o 更新サブレベルあなたはまた、オプションを選択した場合にのみ行うことができます すべてのサブレベルトラバース。これは、下から上の特性を集約しながら、あらゆるレベルでの集計結果は、対応する要素のそれぞれに更新されることを意味します。

o 唯一の直接サブレベル直接選択した要素の下の要素のプロパティだけが集約されることを意味します。

o 選択 含まれます 標準プロパティあなたは、で定義されたプロパティが必要な場合 スタンダード 含めることができます。それ以外の場合は、各コンポーネントインスタンスに固有のプロパティのみが使用されます。

4。 あなたが集約したいプロパティを選択します。彼らは、彼らの中にグループ化されています タイプ.

5。 クリック 次 ボタン。

6。 するかどうかのオプションを選択します 値を上書きまたは 値を追加します選択した要素に。

o 値を上書き選択した要素のプロパティに直接結果を書き込みます。

o 値を追加します選択した要素の既存のプロパティに結果を追加します。

参照してください

コンポーネント、接続またはタイプに事前設定プロパティを追加します | コンポーネント、接続またはタイプのプロパティの変更 | あなたのアーキテクチャを評価します


あなたのアーキテクチャを分析します

ナビゲーション：あなたのアーキテクチャを分析します>

あなたのアーキテクチャを分析します

コメントを送信 このトピックに関する。

あなたのアーキテクチャを人口（および必要に応じてシミュレート）したら、あなたはそれを分析するためにABACUSを使用する準備が整いました。あなたのアーキテクチャでは、あなたのニーズを満たす場合は、それを分析することで、あなたが決定することができます。

あなたは、様々な方法であなたのアーキテクチャを分析することができます：

· ダイアグラム

· 3D 見ます

· 標準チャート （パイ、行、列、バー、など）

· カスタムグラフ（ 反応時間 , 能力スペース , スタープロット , 散布 そして バブルチャート )

· アーキテクチャ デフ

注意

図を作成し、3D 見ます、レポートまたは標準チャート、 標準の要素の選択ウィンドウ 表示したい要素を選択するために使用されます。

参照してください

あなたのアーキテクチャへの移入 | あなたのアーキテクチャをシミュレートします | ザ・ 作図 ツール


標準要素の選択

ナビゲーション：あなたのアーキテクチャを分析します>

標準要素の選択

コメントを送信 このトピックに関する。

図を作成し、3D 見ます、 報告する,標準チャートまたはシミュレーションの実行標準要素選択ウィンドウは、/ビューを分析する要素を選択するために使用されます。

標準要素の選択ウィンドウ

プルダウン

· ビューによるフィルタ 意志 含めます 要素以前に保存されたビューからの（すなわち図、グラフ、3D）。このようにして、保存された「クエリ」として別のビューを処理することにより、クエリを「参加」複雑な実行することができます.

チェックボックス

· 表示レベルグループ要素は、彼らが木に発生することにより、レベルに応じます。レベル1は、最上位レベルです。

· 表示タイプ彼らは種類に応じて、グループのエレメントはなります。

· 選択の両親任意の選択された要素の親要素を含みます。この方法では、任意の子供上記のみ階層は「ボトムアップ」の選択のために含まれることを確実にすることができます。

· 選択の子供たちいずれかの選択した要素の子要素が含まれます。この方法では、任意の両親以下のみ階層が「トップダウン」の選択のために含まれることを確実にすることができます。

· 名前は、値が一致しました（？：ワイルドカード（IEと*）を使用することができるのでご注意ください）​​指定された文字列を含む名前を持つ要素のみが含まれます。この方法では、「意味」クエリを形成することができます。

· 施設のタイプ/名前/値を持っています？施設のタイプ、名前と要素またはその規格に直接指定された文字列を含む値は、（注意してください持っているだけで、これらの要素が含まれます：ワイルドカード（IEと*）を使用することができるが例えば*値フィールドにします？指定されたプロパティの、非ブランク値を持つすべての要素）を与えます。この方法では、「意味」クエリを形成することができます。

· 標準を持っています指定された文字列を含む標準的な名前を持っている要素のみが含まれます（：つまり、ワイルドカードを（と*）を使用することができる例えばHPが*少なくとも一つの標準文字HとPで始まるすべての要素を与えますのでご注意ください！）。この方法では、「意味」クエリを形成することができます。

· 選択に接続されているコンポーネント/接続選択されたものに接続されているすべての要素が含まれます。このように、「コールツリー」または「衝撃解析」を選択することができます。

注意

あなたは両方を持っている場合 表示レベル そして 表示タイプ選択した後、あなたは、2つのチェックボックスの上に表示されますボタンで第一またはタイプ最初の木ショーのレベルを持つように選択することができます。

先端

アイテムが標準要素の選択ウィンドウで選択されると、それが選択解除されるまで、それはそれ以上のフィルター交換の対象にはなりません。一度に要素の異なる2組を検索するためのネイティブな方法（標準Aまたは標準Bは例えばコンポーネント）がないので、あなたは、一組のために最初に検索したいコンポーネントを選択し、2番目のセットの2番目の検索を行うことができます。

ボタン

· すべてすべての要素が選択されます。

· インバートすべての現在選択された要素の選択が解除され、選択されな​​かったすべてのものを選択します。

· なしすべての要素を選択解除します。

· フィルタを追加現在のフィルタ設定の結果のコンテンツを選択し、同様に効果的、追加コンテンツの選択を可能にし、またはフィルタに参加します。

参照してください

あなたのアーキテクチャを分析します


3D図を表示します

ナビゲーション：あなたのアーキテクチャを分析する> 3D図>

3D図を表示します

コメントを送信 このトピックに関する。

ABACUSは、コンポーネントと接続プロパティが色、形、およびサイズ​​に関連付けられている3Dビューとしてあなたのアーキテクチャを表示することができます。

あなたのアーキテクチャの3Dビューを表示するには

1。 あなたが持っていることを確認 ABACUSファイルを開きますあなたを含みます 人口アーキテクチャ.

2。 拡大 ビュー木の枝。

3。 拡大 3D木の枝。

4。 ダブルクリック 可視化は、あなたが開きたいです。

- または -

1。 あなたが持っていることを確認 ABACUSファイルを開きますあなたを含みます 人口アーキテクチャ.

2。 選択 インサート| 3Dまたはツールバーのボタンをクリックします。

3。 開きます 既存の可視化（.abacus3d）

- または -

1。 あなたが持っていることを確認 ABACUSファイルを開きますあなたを含みます 人口アーキテクチャ.

2。 選択 インサート| 3Dまたはツールバーのボタンをクリックします。

3。 新しいビジュアライゼーションを作成します。

· 選択 アーキテクチャあなたは、プルダウンメニューから、表示します。

· 選択 コンポーネント そして 接続あなたはからダイアグラムに含めます 標準の要素の選択ウィンドウ .

· 准色、形や大きさを持ちます コンポーネントタイプ そして プロパティ.

· 准色と形を持ちます 接続タイプ そして プロパティ.

3Dビューをエクスポートするには

1。 あなたが持っていることを確認 既存の3Dビューを開きます.

2。 3Dビューのプルダウンメニューで選択 ファイル|エクスポート...およびビジュアル化ファイル（.abacus3d、.vrmlまたは.html）の場所とファイルの種類を選択しました。

3。 クリック セーブ.

参照してください

あなたのアーキテクチャを分析します | 3Dでのナビゲーション | 作図ツール


3Dダイアグラムのナビゲーション

ナビゲーション：あなたのアーキテクチャを分析する> 3D図>

3Dダイアグラムのナビゲーション

コメントを送信 このトピックに関する。

ABACUSは、簡単に3Dであなたのアーキテクチャをナビゲートすることができます。経験が飛行に似ています。ナビゲーションの2つのモードがあります：

· 基本的な制御モード（デフォルト）。そして

· アドバンストコントロールモード - 選択して、このモードへの変更 制御| アドバンストコントロールモード.

注意

基本制御と高度な制御モードを切り替えるには、使用することができます F4キーボードショートカット機能。

基本的な制御モード

· 左ボタンを保持し、前後にマウスを移動し、ピッチを変更します。

· 左ボタンを押しながら左マウスを動かすか、右ヨーを変更します。

· 右ボタンを押したまま、マウスのパンにビューを移動します。

· ダウン両方のボタンを保持し、前後にマウスを移動し、建築の内外ズームし;そして

· ダウン両方のボタンを押しながらマウスを左または右に移動し、左右のロール。

- または -

· 押します 左矢印キーボードやテンキーの左側になります。

· 押します 右矢印キーボードやテンキーの右折します。

· 押します 上矢印キーボードやテンキーにズームインします。

· 押します 下矢印キーボードやテンキーのズームアウトします。

· 押します ページアップキーボードやテンキーのピッチアップします。そして

· 押します ページダウンキーボードやテンキーのピッチダウンします。

アドバンストコントロールモード

· 移動前後、上下のマウスは、（それぞれ）ピッチとヨーを変更します。

· 押します Wまたは 上矢印（フォワード）アーキテクチャにズームイン。

· 押します Sまたは 下矢印アーキテクチャから（後方）ズームアウト。

· 押します Aまたは 左矢印左にロール。

· 押します Dまたは 右矢印右にロール。

· 押します Qまたは ページダウン（視点を下げて）ビューを上昇させます。そして

· 押します Eまたは ページアップ（視点を上昇させることにより）ビューを低下させます。

対話制御モード

長押しすると、 シフトキーキーボード上の対話制御モードに入るために、電流モード（基本または詳細）をオーバーライドします。このモードでは以下のことが可能です：

· ロール部品や接続の上にマウスカーソルが、コンポーネントまたは接続の名前を表示します。

· クリックそのコンポーネントにズームインするためのコンポーネントの。

· クリックとドラッグコンポーネントにそのコンポーネントの周囲にビューを回転させます。そして

· 右クリックコンポーネントまたは接続を選択 エクスプローラーに書いてあるそのコンポーネントまたはツリー内の接続の位置を確認します。

コモンコントロール

· 使って ALT-ENTER / ESCフルスクリーンモードを切り替えます。

· 使って F2表示モードを変更します。これはまた、アクセスすることができます 見ます メニュー。

· 使用 マウスホイールまたは +/-速度を変更します。速度は、左下隅にある番号で示されている - それは変化している場合にのみ表示。 1が最も遅く、100は最速です。


標準チャートの表示

ナビゲーション：あなたのアーキテクチャを分析する>標準チャート>

標準チャートの表示

コメントを送信 このトピックに関する。

ABACUS「標準チャートはライン、バー、列、エリア、散布図、円グラフ、曲線、パレート、ステップ、表面、レーダー、キューブ、ドーナツ、ピラミッド、輪郭曲線面積のチャートが含まれています。あなたが望むチャートのタイプを選択したら、これらのチャートのそれぞれを表示するためのプロセスの残りの部分は同じです。

あなたのアーキテクチャの標準チャートを表示するには

1。 あなたが持っていることを確認 ABACUSファイルを開きますあなたを含みます 人口アーキテクチャ、あなたが持っています 評価あなたのアーキテクチャ。

2。 選択 インサート| チャートまたはツールバーのボタンをクリックします。ザ・ チャートウィンドウが表示されます。

チャートウィンドウ

3。 希望するチャートのタイプを選択し、グラフオプションを設定し、をクリックします 次.

グラフオプション

o 積み上げ全体に個々の項目の関係を示します。あなたは（つまり、複数のプロパティ）複数のデータ系列を持つように計画するとき、あなたは合計を強調したいときは、積み上げグラフを使用することができます。

o 積み上げ100％各値は、カテゴリーでの合計に貢献する割合を比較します。あなたは（つまり、複数のプロパティ）複数のデータ系列を持つように計画し、あなたは合計は、各要素に対して同じである場合は特に、全体への貢献を強調したいときは、100％積み上げグラフを使用することができます。

o 3Dチャート単に美学のための3-Dフォーマットのデータポイントが表示されます。あなたは第3回/ z軸寸法に沿ってデータ系列を表示したい場合は、以下で説明するクラスタシリーズオプションを使用します。

o プロパティによってシリーズ最終的に選択されている各プロパティのデータ系列が表示されます。これがオフの場合、プロパティは、カテゴリとデータ系列が選択されている各要素のためになりなります。

o グラフを回転グラフをx軸とy軸を交換することによって時計回りに90度回転します。このオプションは、行、ステップとキューブチャートでのみ使用可能ですそして、下の2番目の先端に記載されているようにマイルストーン・チャートを作成するために特に有用です。注：列とバーチャートは、すでに互いのバージョンを「回転」されています。

o クラスタシリーズ第三/ z軸寸法に沿って、複数の系列のデータを表示します。このオプションは、列、バー、キューブチャートでのみ使用可能ですおよび下記の最初のヒントで説明したようにガントチャートのスタイルを作るために特に有用です.

先端

あなたが作成することができます ガントチャートバーグラフの種類を選択し、[クラスタシリーズオプションを選択することによって、異なる要素のための時間/日付の特性を示す水平のバーで。また、一度作成し、チャート上の一番左のバーは、バーの1つを右クリックして表示されるメニューからカラーを選択し、パレットから左上の色を選択することで、白、それを着色することにより、「見えない」とすることができます。さらに、一番左のバーの境界線は、... [プロパティ]を選択し、バーの1つを右クリックして、トップになしとカラーにボーダーエフェクトを変更する表示されるダイアログで[系列]タブにある「見えない」とすることができますパレットから色-left。

先端

あなたが作成することができます マイルストーンチャート小さな形状はキューブグラフの種類を選択することによって、異なる要素のための時間/日付のプロパティを表示した後、回転させてチャートを選択し、クラスタシリーズのオプションで。また、一度作成、キューブは、与えられたデータ系列のキューブの1つを右クリックして[プロパティ...]を選択し、バーに円筒または円錐のいずれかを変更する表示されるダイアログで[系列]タブ上のことで、他の形状に変更することができます。注：ギャップ幅の値はまた、以下が存在することになる重複する重複、より高い数を減らすために、グラフ上の記号を「収縮」するために使用することができます。

4。 の中に アーキテクチャセクション、クリックし、あなたがアーキテクチャレベルのプロパティをグラフ化したいアーキテクチャ/秒をチェック 次.

注意

アーキテクチャレベルのプロパティを選択すると、完全に任意のステップであり、あなたが明示的にアーキテクチャレベルプロパティ自体をグラフ化したい場合にのみ使用する必要があります.アーキテクチャは、次のステップで、コンポーネントまたは接続プロパティを含むその後に選択する必要がありません。

5。 選択 コンポーネント そして 接続あなたはからグラフにしたいこと 標準の要素の選択ウィンドウ 、をクリックします 次.

6。 選択 プロパティあなたは、グラフやクリックで欲しいです フィニッシュ.

グラフオプション

o 標準のプロパティを含めます 意志 選択可能な基準から継承されたプロパティを表示.

o 集計プロパティ 意志 系列値の間の差異をカウントし、個々の値そのものとは対照的に、それらの結果をグラフ化.シリーズプロパティでオプションが上記の手順3で選択した場合のみ、本オプションが使用可能です。

先端

チャート作成のための利用可能なプロパティは、選択した要素に依存します。

チャートを保存するには

注意

彼らは、現在のプロジェクト内の単一のアーキテクチャからでなければならないすべてはコンポーネントとの接続を、含まれている場合はチャートにのみ保存することができます。

1。 あなたは、新規または既存のグラフを持っていることを確認してください オープンあなたは、必要な変更を行いました。

2。 グラフツールバーの左端をクリックしてください チャートを保存グラフと任意の書式設定の変更を保存するためのボタン。

3。 の中に チャート名チャートプレスの名前を入力し、表示されるダイアログ [OK].

チャートをエクスポートするには

1。 既存ていることを確認 チャート オープン。

2。 左から2番目のグラフのツールバーをクリックして BMPとして保存ボタンとチャートの場所を選びました。

3。 クリック セーブ.

参照してください

あなたのアーキテクチャを分析します | 応答時間のチャートを表示します | 機能空間チャートの表示


機能空間チャートの表示

ナビゲーション：あなたのアーキテクチャを分析する>カスタムチャート>

機能空間チャートの表示

コメントを送信 このトピックに関する。

能力スペース・チャートは、あなたのアーキテクチャは、システム要件分析プロセス中に識別特性に関して必要なシステム機能を満たしているかどうかを表示することができます。

機能空間チャートを表示するには

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ、あなたが持っています 評価あなたのアーキテクチャ。

2。 選択 インサート| チャート| カスタムチャート| 能力スペース。 （ 能力スペースチャートコンフィグダイアログが表示されます。）

3。 の中に アーキテクチャセクション、あなたがチャートをご希望のアーキテクチャをチェックし、をクリックします 次.

4。 の中に プロパティエリア、あなたはチャートの軸として含またい建築のプロパティをチェック。

5。 の中に 能力面積は、各プロパティのいずれかの最小または最大能力の限界が存在するかどうかを選択して、これらの制限の値は、前のステップから含まれています。デフォルト値は、アーキテクチャまたはのために評価最小値と最大値であり、 プロパティの目標 それが設定されている場合。

機能空間チャートをエクスポートするには

1。 既存ていることを確認 機能空間チャート オープン。

2。 グラフツールバーの左端をクリックしてください BMPとして保存ボタンとチャートの場所を選びました。

3。 クリック セーブ.

参照してください

あなたのアーキテクチャを分析します | 応答時間のチャートを表示します


応答時間のチャートを表示します

ナビゲーション：あなたのアーキテクチャを分析する>カスタムチャート>

応答時間のチャートを表示します

コメントを送信 このトピックに関する。

応答時間チャートは、あなたの接続は（すなわち、その期限内に）必要なレートで処理されているかどうかを表示することができます。

応答時間のチャートを表示するには

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ、あなたが持っています 評価あなたのアーキテクチャ。

2。 選択 インサート| チャート| カスタムチャート| 反応時間。 （ 応答時間チャートコンフィグダイアログが表示されます。）

3。 から アーキテクチャドロップダウンリストを、あなたがグラフ化したいアーキテクチャを選択します。

4。 の中に 接続エリア、グラフに含まれるご希望の接続をチェック。

5。 ザ・ スケールタイプエリアを選択 リニアあなたが線形進行として表示される縦軸（応答時間）が必要な場合 - 時間の各セグメントは、軸の同じシェアを割り当てられます。選択 対数あなたがしたい場合には、対数進行として表示 - 軸の各セグメントは、あなたが行く軸までの高い時​​間のますます長い期間を表しています。 （増加率は、以下によって決定されます ベースあなたが選択します。）

レスポンスタイムチャートの縦軸の目盛り

レスポンスタイムチャートをエクスポートするには

1。 既存ていることを確認 レスポンスタイムチャート オープン。

2。 グラフツールバーの左端をクリックしてください BMPとして保存ボタンとチャートの場所を選びました。

3。 クリック セーブ.

参照してください

あなたのアーキテクチャを分析します | 機能空間チャートの表示


あなたの進化アーキテクチャのスタープロットを表示

ナビゲーション：あなたのアーキテクチャを分析する>カスタムチャート>

あなたの進化アーキテクチャのスタープロットを表示

コメントを送信 このトピックに関する。

アーキテクチャは、進化しており、目標が定義されると、それはその後、可視化し、スタープロットを使用して、元のアーキテクチャと比較することができます。このセクションでは、スタープロットを作成および操作する方法について説明します。

あなたの進化アーキテクチャのスタープロットを表示するには

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 あなたが持っていることを確認 進化 そして 目標を設定しますあなたのアーキテクチャのための下で概説したように あなたのアーキテクチャの進化

3。 選択 インサート| チャート|ザ・ カスタムチャートタブ| スタープロット.

4。 クリックします フィニッシュ ボタン。

5。 ザ・ スタープロット進化したアーキテクチャとし、目標が表示されます設定します。注意：星プロットの軸は、スタープロット品質スペースの範囲内で別の領域に軸をクリックしてドラッグして再配置することができます。

注意

スタープロットの左側の領域が表示されたスタープロットの設定を示しています。これは、この場合には（進化されたアーキテクチャを含みます 「ABC株式会社そのまま2010」）と同様に、そのアーキテクチャ用に設定されている目標。あなたはそれらの横にチェックマークを持っている目標がスタープロット（例えばの軸として表現さ​​れることに注意します KPI - コスト、KPI - 品質とKPI - タイム）。あなたは星のプロットからそれらを削除するには、時間の任意の時点でこれらの目標を外しますがあります。

あなたの星のプロットに表示される赤と緑の「ドット」は正規化された値を表す、最高の最悪値によって決定される（下概説 あなたの進化アーキテクチャの目標を設定します ）選択されたトップレベルのアーキテクチャとそれのいずれかの進化のために。これらの値は、Aで表され 品質スペース.

上の画像で概説したように、それははっきりと表示されるオリジナルアーキテクチャ（そのまま2010）悪いています コスト、（最初の進化のオプションしばらくTO-BE 2011 - 戦略A）を向上させるために、高品質の空間内で移動しました コスト, 品質と時間ゴール。あるいは、第二は、（オプションの進化しました-することで2011 - 戦略 B）それはまた、改善されている一方で コスト 改善の大きさは、それよりも小さいです 戦略 A しかし、両方の品質と時間の目標は戦略Aとよりも改善されましたこの場合、建築家 かもしれません 選択します 戦略Aオーバー 戦略Bその勧告としてさらに、そのオプションを進化させる（2012-BE - 戦略A）.

6。 選択を解除 ショーエボリューション元の間の進化（複数可）を表す線（複数可）を非表示にする]チェックボックスをオンにし（例えば、 そのまま2010）と進化した（例えば、 -することで2011 - 戦略A）アーキテクチャ（複数可）。

7。 選択 ショースティック各アーキテクチャ用の各品質属性（各軸上に定義されている目標）の相対的な大きさを表示するには、チェックボックスをオンにします。

8。 選択 ショーアーキテクチャ名あなたは星のプロットに表示される元と進化アーキテクチャ（複数可）の名前にしたい場合はチェックボックスをオンにします。

参照してください

あなたのアーキテクチャを分析します | 応答時間のチャートを表示します | あなたの進化アーキテクチャの散布図を表示します | あなたのアーキテクチャの進化


あなたの進化アーキテクチャの散布図を表示します

ナビゲーション：あなたのアーキテクチャを分析する>カスタムチャート>

あなたの進化アーキテクチャの散布図を表示します

コメントを送信 このトピックに関する。

アーキテクチャは、進化しており、目標が定義されると、それはその後、可視化し、散布図行列を使用して、元のアーキテクチャと比較することができます。このセクションでは、作成して、散布図の特性を理解する方法について説明します。

あなたの進化アーキテクチャの散布図を表示するには

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 あなたが持っていることを確認 進化 そして 目標を設定しますあなたのアーキテクチャのための下で概説したように あなたのアーキテクチャの進化

3。 選択 インサート| チャート|ザ・ カスタムチャートタブ| 散布.

4。 クリックします フィニッシュ ボタン。

5。 ザ・ 散布図アーキテクチャと目標の定義された進化で表示されます。

注意

散布図の左側の領域が表示された散布図の設定を示しています。これは、この場合には（進化されたアーキテクチャを含みます 「ABC株式会社そのまま2010」）と同様に、そのアーキテクチャ用に設定されている目標。あなたはそれらの横にチェックマークを持っている目標は散布図（例のX軸とY軸として表現さ​​れていることに注意します KPI - コスト、KPI - 品質とKPI - タイム）。あなたは、散布図行列からそれらを削除するには、時間の任意の時点でこれらの目標を外しますがあります。

マトリックスであなたのプロットに表示される青い点は、正規化した値を表し、最良と最悪値によって決定される（下概説 あなたの進化アーキテクチャの目標を設定します ）。これらの値は、Aで表され 品質スペース.

2つの定義された目標は、散布図において互いに比較され、すべての目標を比較されるまで処理を繰り返す（例えば、上図の行列の最初のプロットは比較 KPI - コストと目標 KPI - 品質 ゴール。第二は、 コスト 対 時間 最後のプロットであります 品質 対 時間。関連する目標ラベルは上と右またはプロットの各列に表示されます。）。

6。 選択 アーキテクチャラジオボタンは、個々のアーキテクチャのメトリックを表示する場合。

7。 選択 エボリューションあなたは、元のアーキテクチャからの正規化された変更を表示する場合は、ラジオボタン（例えば、 そのまま2010）進化したアーキテクチャ（複数可）（例えばへ 2011 BE-へ - 戦略AおよびTo-BE 2011 - 戦略B）。

参照してください

あなたのアーキテクチャを分析します | 応答時間のチャートを表示します | あなたの進化アーキテクチャのスタープロットを表示 | あなたのアーキテクチャの進化


バブルチャートの表示

ナビゲーション：あなたのアーキテクチャを分析する>カスタムチャート>

バブルチャートの表示

コメントを送信 このトピックに関する。

バブルチャートは、1つのビューに5寸法（すなわち、X、Y、気泡の大きさ/半径、バブルの色とバブル境界線の色）まで比較することができます。

バブルチャートを表示するには

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 選択 インサート| チャート|ザ・ カスタムチャートタブ| バブル・チャート.

3。 の中に アーキテクチャセクションで、グラフ化したい（もしあれば）、次にクリックアーキテクチャをチェック 次.

4。 選択 コンポーネント そして 接続（もしあれば）あなたはからグラフにしたいこと 標準の要素の選択ウィンドウ 、をクリックします 次.

5。 選択 X軸プロパティをクリックします 次.

注意

のみ 整数、10進数、日付/時刻、ブール型とリストのプロパティ X軸のために使用することができます。さらに、整数、10進数、および日付/時刻のプロパティがプロパティの値に応じて拡大縮小軸に沿って左から右にプロットされている、しかし、ブールとリストのプロパティは、単純に正確な順序（または左から右にプロットされていますかかわらず、その値のプロパティに定義された順序を逆にするオプションがチェックされている場合は逆の順番）。例えば。低|中|ハイまたは1、2、4、8、16。

6。 選択 Y軸プロパティをクリックします 次.

注意

のみ 整数、10進数、日付/時刻、ブール型とリストのプロパティ Y軸のために使用することができます。さらに、整数、10進数、および日付/時刻のプロパティがプロパティの値に応じて拡大縮小軸に沿って下から上にプロットされている、しかし、ブールおよびリストのプロパティは、単純に正確な順序で下から上にプロットした（またはされていますかかわらず、その値のプロパティに定義された順序を逆にするオプションがチェックされている場合は逆の順番）。例えば。低|中|ハイまたは1、2、4、8、16。

7。 選択 気泡の大きさ/半径プロパティをクリックします 次.

注意

のみ 整数、10進数、ブール型とリストのプロパティ 気泡の大きさ/半径のために使用することができます。さらに、整数および小数のプロパティがプロパティの値に応じてスケーリングされた気泡の大きさ/半径になり、しかし、ブール型とリストのプロパティは、正確な順序（または逆の順序であれば中の気泡の大きさ/半径の同じステップ状増加につながります順序を逆にするオプションがチェックされている）に関係なく、その値のプロパティに定義されました。例えば。低|中|ハイまたは1、2、4、8、16。

8。 いずれかを選択 固定バブル色または バブルの色とプロパティを関連付けます、をクリックします 次.

注意

のみ 整数、10進数、ブール型とリストのプロパティ 泡の色のために使用することができます。さらに、整数および小数のプロパティがプロパティの値に応じてスケール選択した範囲内のバブルの色になる、しかし、ブール型とリストのプロパティが定義されているため正確な順序で選択した範囲内のバブルの色の均等ステップ状増加につながりますかかわらず、その値のプロパティです。例えば。低|中|ハイまたは1、2、4、8、16。

9。 いずれかを選択 何のバブル境界線の色ませんまたは バブル境界線の色とプロパティを関連付けます、をクリックします フィニッシュ.

注意

のみ 整数、10進数、ブール型とリストのプロパティ 気泡の境界線の色のために使用することができます。さらに、整数および小数のプロパティがプロパティの値に応じてスケーリングされ選択された範囲内でバブル境界線の色になる、しかし、ブール型とリストのプロパティが定義された正確な順序で選択した範囲内での気泡の境界線の色の均等ステップ状増加につながりますかかわらず、その値のプロパティの。例えば。低|中|ハイまたは1、2、4、8、16。

バブルチャート

バブルチャートを保存するには

注意

彼らは、現在のプロジェクト内の単一のアーキテクチャからでなければならないすべてはコンポーネントとの接続を、含まれている場合はバブルチャートのみを保存することができます。

1。 あなたは、新規または既存のバブルチャートを持っていることを確認してください オープンあなたは、必要な変更を行いました。

2。 グラフツールバーの左端をクリックしてください チャートを保存グラフと任意の書式設定の変更を保存するためのボタン。

3。 の中に チャート名バブルチャートを押しの名前を入力し、表示されるダイアログ [OK].

バブルチャートをエクスポートするには

1。 あなたが持っていることを確認 既存のバブルチャートを開きます.

2。 左から2番目のグラフのツールバーをクリックして BMPとして保存ボタンとチャートの場所を選びました。

3。 クリック セーブ.

参照してください

あなたのアーキテクチャを分析します


建築差分と同期

ナビゲーション：あなたのアーキテクチャを分析します>

建築差分と同期

コメントを送信 このトピックに関する。

あなたが視覚的に「差分」二つのアーキテクチャを使用してすることができ、いずれか、進化またはベースラインアーキテクチャのようにして2以上のアーキテクチャを持っている場合 カタログまたは図の比較や 建築差分機能。これは、発見/再発見あなたはアーキテクチャの進化とABACUSでロードマップを開発する別のアーキテクチャから作られた正確な変更をする場合に特に便利です。

に 図を介して他のアーキテクチャを備えた「差分」を示します

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 あなたを確認してください 持っています プロジェクト内の少なくとも2アーキテクチャ。

3。 あなたが別のアーキテクチャに比較したい図を開きます。

4。 図ツールバーの「別のアーキテクチャの内容に、この図を比較」ボタンをクリックします。

5。 に比較するために、ドロップダウンリストから他のアーキテクチャを選択してください。

6。 あなたは、例えば、図ツールバー上の「違い」ボタンをクリックし、オプションの選択を解除して示されているものの違いフィルタリングすることができます追加/変更/不明と 不定の / 同期の推奨/ キープ推奨.

注意

ダイアグラム上のコンポーネントとの接続がでハイライト表示さ​​れます 赤, 緑色 または パープル 現在のダイアグラムに表示されているコンテンツおよびその他のアーキテクチャの内容との相違がある場合は. 赤 それが違いを同期することが推奨される（下記参照）が使用され、 緑 それが違いを同期することは推奨されていない場合に使用され、それはそれらを保つです（下記参照）と パープル ABACUS（下記参照）の違いを同期に関する勧告を行うことができない場合に使用されます。唯一のダイアグラム上で可視コンテンツは、注釈は、リポジトリのプロパティ値を示しているかのように比較され、その値は、指定されたコンポーネントを変更したり、接続がで表示されます かすかな赤, かすかな緑または かすかな紫 他のいくつかの基礎となるリポジトリのプロパティ値は、その注釈に示されていない変更された場合は、トップ左コンポーネント用に示されている「*」の記号は、しかし、その後、何の指示が与えられません。現在のダイアグラムで発生するが一致が比較アーキテクチャで発見されていないコンテンツは、で表示されます 強い赤, 強い緑色または 強い紫そして「+」記号は、コンポーネントの左上に示します。マッチングは、コンポーネントまたは接続の種類や名前が他のアーキテクチャでは変更されている場合一致が見つからないことを、このような部品の種類と名前によって行われます。確実に他のアーキテクチャからの追加コンテンツは、現在の図（右の比較アーキテクチャから図に下記のように2つのコンポーネント間の例えば追加の界面）で示されているかどうかを判断する方法がないように、これらの違いはありません（これらは以下の通りカタログのために示されている）図について示します。変更された各項目の上に置くと、ツールチップの違いを表示します。図の左上にある「*」マークの上に置くと、図のコンテンツや他のアーキテクチャの内容の間の変更（または変更なし）の概要を説明します。

カラーレジェンド

· 緑 示しています それが違いを同期することは推奨されませんアイテム、それはそれらを保つことです.

· 赤 示しています それが違いを同期することをお勧めしますアイテム.

· パープル 示しています ABACUSは違いを同期に関する勧告を行うことができないアイテム.

に 図を介して別と1のアーキテクチャから（「同期」）コンテンツを同期させます

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 あなたを確認してください 持っています プロジェクト内の少なくとも2アーキテクチャ。

3。 あなたが別のアーキテクチャに比較したい図を開きます。.

4。 図ツールバーにある「他のアーキテクチャの内容にこのカタログを比較」ボタンをクリックします.

5。 に比較するために、ドロップダウンリストから他のアーキテクチャを選択してください.

注意

ABACUSは、カタログ内の2のアーキテクチャ間の「差分」を示している方法については、上記を参照してください。特に、どのように 赤 どこに使用されています あります違いを同期することをお勧めし、 緑 それがどこにある使用されています ではありません違いを同期することをお勧めし、 パープル ABACUSは違いを同期に関する勧告を行うことができない場合に使用されます.

6。 「差分」を示す図である要素（またはShiftキーまたはすべて同期にダイアグラムのキャンバスを使用した要素）を右クリックし、[同期]メニュー項目を選択します。

注意

任意の同期の変更には、現在フォーカスのカタログでは、所属するアーキテクチャに適用されます。他のアーキテクチャに変更を適用するには、他のアーキテクチャでは、カタログを使用する必要があります。さらに、ユーザーがいる場合にのみ、同期の変更を適用することができるようになります彼ら そうする権限を持っています .

注意

メニュー項目を右クリックした場所に応じて正確に同期するために何が起こっているかについてのガイダンスが表示されます. 例えば。図中の単一のコンポーネントのみがそのコンポーネントを同期します右クリックします。一方ダイアグラムのキャンバスを右クリックして[すべて同期は、すべての現在表示されている相違が同期されます選択。

に カタログを介して他のアーキテクチャを備えた「差分」を示します

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 あなたを確認してください 持っています プロジェクト内の少なくとも2アーキテクチャ。

3。 あなたが別のアーキテクチャに比較したいカタログを開きます。

4。 カタログのツールバーにある「他のアーキテクチャの内容にこのカタログを比較」ボタンをクリックします。

5。 に比較するために、ドロップダウンリストから他のアーキテクチャを選択してください。

6。 あなたは、図ツールバーと非選択オプションに「違い」ボタンをクリックすると表示されているものの違いなどをフィルタリングすることができます追加/変更/不明と 不定の / 同期の推奨/ キープ推奨.

注意

カタログ内の細胞はで強調表示されます 赤, 緑色 または パープル 現在のカタログ内のコンテンツおよびその他のアーキテクチャに一致する内容との相違がある場合は. 赤 それが違いを同期することが推奨される（下記参照）が使用され、 緑 それが違いを同期することは推奨されていない場合に使用され、それはそれらを保つです（下記参照）と パープル ABACUS（下記参照）の違いを同期に関する勧告を行うことができない場合に使用されます。現在表示されている行を超えた行またはその後は差が示されません差が示されていない列の値に差があるので、もしカタログだけに表示される行と列が比較されます。個々のセルの値は、セルの境界が強調表示されます比較アーキテクチャに一致するセルと異なる場合。列ヘッダと行セレクタもで網掛けされます かすかな紫そして、 '*'記号で示しました。これらの「*」の記号は、それぞれの列または行の次の違いにジャンプするをクリックすることができます。現在のカタログに起こるが、一致するものが比較アーキテクチャで発見されていない行は、左側の行セレクタに「+」記号で表示され、行全体の境界線が強調表示されます。 、左側の行セレクタ内のシンボルの境界線を「 - 」カタログ（すなわち、同じフィルタなどを含む）の比較アーキテクチャのバージョンで発生しているだろうが、一致が現在のアーキテクチャで発見されていない行はで表示されます行全体が強調表示され、行全体のセルの内容がで表示されます かすかな紫そして、打たスルー、例えば 午後6時まで午前8時。マッチングは、コンポーネントまたは接続の種類や名前が他のアーキテクチャでは変更されている場合一致が見つからないことを、このような部品の種類と名前によって行われます。変更された各項目の上に置くと、ツールチップの違いを表示します。図の左上に「*」マークの上に置くと、図のコンテンツや他のアーキテクチャの内容の間の変更（または変更なし）の概要を説明します.

カラーレジェンド

· 緑 示しています それが違いを同期することは推奨されませんアイテム、それはそれらを保つことです.

· 赤 示しています それが違いを同期することをお勧めしますアイテム.

· パープル 示しています ABACUSは違いを同期に関する勧告を行うことができないアイテム.

に カタログを介して他のであるアーキテクチャから（「同期」）コンテンツを同期させます

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 あなたを確認してください 持っています プロジェクト内の少なくとも2アーキテクチャ。

3。 あなたが別のアーキテクチャに比較したいカタログを開きます.

4。 カタログのツールバーにある「他のアーキテクチャの内容にこのカタログを比較」ボタンをクリックします.

5。 に比較するために、ドロップダウンリストから他のアーキテクチャを選択してください.

注意

ABACUSは、カタログ内の2のアーキテクチャ間の「差分」を示している方法については、上記を参照してください。特に、どのように 赤 どこに使用されています あります違いを同期することをお勧めし、 緑 それがどこにある使用されています ではありません違いを同期することをお勧めし、 パープル ABACUSは違いを同期に関する勧告を行うことができない場合に使用されます.

6。 「差分」を示すセル、行または列見出し（またはすべてのために、ShiftキーまたはCtrl + Aキーを使用して複数の項目）を右クリックし、[同期]メニュー項目を選択します。

注意

任意の同期の変更には、現在フォーカスのカタログでは、所属するアーキテクチャに適用されます。他のアーキテクチャに変更を適用するには、他のアーキテクチャでは、カタログを使用する必要があります。さらに、ユーザーがいる場合にのみ、同期の変更を適用することができるようになります彼ら そうする権限を持っています .

注意

あなた右クリック（すなわち、細胞、列または行の見出しが）メニュー項目を正確に同期させるために何が起こっているかについてのガイダンスを表示する場所に応じて. 例えば。カタログで右クリックする単一のプロパティまたは接続されたコンポーネントのセルにのみ、そのプロパティまたは接続されたコンポーネントを同期します。一方見出し行を右クリック（またはShiftキーを使用して見出しが）行全体（または列）を同期します。列ヘッダは、その列のすべての違いを同期します右クリックします。

表示します 'デフ'2の 全体 アーキテクチャ

1。 あなたが持っていることを確認 ABACUSファイルオープン .

2。 あなたを確認してください 持っています プロジェクト内の少なくとも2アーキテクチャ。

3。 選択 ツール| 建築デフ....

4。 /第一及び第二/アーキテクチャと比較するために選択表示されるダイアログで。

5。 クリックします [OK] ボタン。

建築差分

カラーレジェンド

· 緑ノードは、第2 /アーキテクチャに追加されたことを示しています。

· 赤ノードアーキテクチャ/秒で削除されたことを示しています。

· ブルーノードが第二/アーキテクチャに異なる属性（例えばプロパティまたは標準）を有していることを示しています。

· 黄ノードが展開される必要がありますので、ノードが第二/アーキテクチャにその子の違いがあることを示しています。

注意

あなたは右クリックして「エクスプローラで表示」のすべてのノードで詳細を確認し、ノードが選択されているときより多くの情報が違い概要]パネルの違いに与えられていることができます。

参照してください

あなたのアーキテクチャを分析します | 応答時間のチャートを表示します | あなたの進化アーキテクチャの散布図を表示します | あなたのアーキテクチャの進化


あなたのアーキテクチャをシミュレートします

ナビゲーション：あなたのアーキテクチャをシミュレートします>

あなたのアーキテクチャをシミュレートします

コメントを送信 このトピックに関する。

あなたが人口とあなたのアーキテクチャを分析した後、あなたはあなたのアーキテクチャでは、あなたの定量的なニーズを満たすかどうかを判断するためにABACUSを使用する準備が整いました。これが必要です シミュレーション。お使いのアーキテクチャをシミュレートするには、まず、検出する情報の種類を決定する必要があります。これらの情報は、多くの場合、KPIの、または主要業績評価指標と呼ばれています。たとえば、パフォーマンス、発展性、および開放性を分析しますか、またはあなたは、このような総所有コストなどの測定データを収集したいです。この情報のすべては、いくつかの方法で明らかにすることができます。あなたはこのデータを持っていたら、グラフィカルなさまざまな形式であなたのアーキテクチャを分析する（または直接新しい値を分析する）ことができるようになります。

あなたのアーキテクチャをシミュレートするための3つのオプションがあります。

· シンプルなメトリック ;

· 構築済みのシミュレータ ;または

· スクリプト記述 .

シンプルなメトリック

ABACUSのアプリケーションにカスタムすることがあり、その多く - あなたのアーキテクチャのすべてのコンポーネントは、プロパティがあります。これらのプロパティは、コンポーネントの様々な特性を表します。いくつかのケースでは、単に（KPIのを構築するために）これらのメトリックを収集することはあなたのアーキテクチャに関する重要な情報を伝えるのに十分なことができます。例えば、KLOCS、または何千行ものコードは、広く複雑性の尺度として使用されています。他のケースでは、あなたがしたいこと データをエクスポート 別のツールを使用して、それを分析。さらに、シミュレーションの別の種類を実行した後にプロパティを収集することができます。

プロパティの過程を通じて収集することができます アグリゲーション 。集計は、親コンポーネントに反映され、合計に指定されたサブプロパティを追加します。集計は、サブコンポーネントを含むコンポーネント上で動作します。

構築済みのシミュレータ

ABACUSで使用することができる5事前に構築されたシミュレータがあります。これらは：

· パフォーマンス;

· モジュール性;

· 総所有コスト（TCO）。

· オープン性; そして

· 信頼性。

注意

ABACUSは自動的に通って再実行する必要があるこれらのシミュレータのどの強調表示されます 赤 上で強調表示 シミュレーションツールバー .

スクリプト記述

スクリプトは、カスタムの方法であなたのアーキテクチャをシミュレートするための柔軟性を提供します。によって スクリプトを書きます あなたはABACUSの内蔵容量に現在を超えてシミュレーションを行うことができます。全体ABACUSオブジェクトモデルは、スクリプトエンジンに利用可能であるので、あなただけのスクリプトを書くためにあなたの能力によって制限されています！

それは合理的に簡単な形式で必須のプログラミング機能を提供するので、Visual Basicのスクリプトは、ABACUSでサポートされているスクリプト言語です。

参照してください

あなたのアーキテクチャのエクスポート | 集計プロパティ | スクリプトを書きます


スクリプトの作成

ナビゲーション：あなたのアーキテクチャをシミュレートします>

スクリプトの作成

コメントを送信 このトピックに関する。

スクリプトエディタは、VBを書いて実行するためのシンプルで機能的なユーティリティです またはCの＃ スクリプト 現在開いてABACUSファイル（ライブラリは、スクリプトではサポートされません）。これは、通常のファイルを開くを持って閉じて、あなたが書くスクリプトを保存し、検索することができるように、コマンドを保存します。また、基本的な実行とデバッグ機能があります。スクリプトマネージャを使用すると、簡単に[ツール]メニューに直接彼らのためにメニュー項目を配置することによって書かれているさまざまなスクリプトを実行することができます。

スクリプトエディタにアクセスするには

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 選択 ツール | スクリプトエディタそして、スクリプトエディタウィンドウが開きます。そして、いずれか;

3。 経由して既存のスクリプトを開きます ファイル | オープン スクリプトエディタのメニューで、

または

3。 経由してスクリプトの例を開きます 例 スクリプトエディタのメニュー内の項目、

または

3。 VBやC＃を経由してのいずれかにデフォルトの言語を設定 言語 スクリプトエディタのメニュー内の項目、

または

3。 経由を開き、スクリプトの特定のヘルプ 助けて スクリプトエディタのメニュー内の項目

スクリプトを書くとき、あなたはに従う必要があります どちらか VB またはCの＃ 構文スクリプトエディタのメニューの言語項目で設定通りに.

注意：

· 以下のような標準的なVBの関数を使用するには、 MsgBox（）あなたが含まれている必要があります 輸入Microsoft.VisualBasicあなたのスクリプトの先頭にステートメント。これは、ABACUSのバージョン3.0の前に必要ではなかったです。

· このヘルプは、VBスクリプトを作成する方法についての情報が含まれていません。また、VBの参照が含まれていません。コピーし、お好みのIDEまたはエディタでスクリプトを記述すること自由に感じ、スクリプトエディタに貼り付けます。

あなたが最初にスクリプトエディタを起動すると、スクリプトエディタは空になります。あなたは例のメニューからスケルトンスクリプトにアクセスすることができます。あなたのスクリプトエディタを初めて起動するときは、それが動作することを確認するためにテンプレートの骨格を実行する必要があります。また、実施例のメニューからアクセスできる2つのサンプル・スクリプトがあります。

便利なスクリプトを作成するには、ABACUS ObjectModelを参照する必要があります。これは含めることによって、スクリプトを使用できるようになります 輸入ABACUS.ObjectModelスクリプトの先頭にステートメント。全体ABACUSオブジェクトモデルへの完全なリファレンスは、スクリプトエディタに含まれています。あなたが選択することでそれを見つけることができます ヘルプ|内容物スクリプトエディタウィンドウから。

スクリプトエディタには、以下のスクリーンショットに示すように、オートコンプリートなどのスクリプトを書くための多くの便利な機能が含まれています。しかし、リッチなユーザーエクスペリエンスのために、MS Visual Studioは、ABACUSに統合することができ、詳細な手順が用意されています ここに .

オートコンプリートとスクリプトエディタ

スクリプトマネージャを使用するには

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 [ツール| スクリプトマネージャ.

3。 クリックします 追加アイコンとAN オープンウィンドウが表示されます。

4。 .abacusscript（ABACUSスクリプトを参照します、の.vbまたは.csファイル）[ツール]メニューに追加したいファイル。

5。 クリック [OK]スクリプトを参照するには、スクリプトマネージャ]ウィンドウに表示されます。 [ツール]メニューに表示されるためにそれを望むようにスクリプトの名前を入力します。注意：スクリプトマネージャ]ウィンドウには、必要に応じて完全なパスを確認するためにサイズを変更できます。

6。 手順を繰り返し 3-5もっとABACUSスクリプトへのリンクを作成します。

7。 クリック 閉じるスクリプトマネージャを閉じ、ABACUSスクリプト（s）は今、[ツール]メニューの下に表示されることに注意すること。

スクリプトを実行するには

どちらか;

1。 オープン、で入力するか、それがメインウィンドウに表示されるように、実行するスクリプトにコピー＆ペースト スクリプトエディタ.

2。 クリック ファイル名を指定して実行 ボタン。

3。 スクリプトにエラーが含まれている場合は、スクリプトエディタの下部にあるエラーの説明セクションには、行番号を含む詳細が一覧表示されます。 注意： エラー説明セクションの各個々のエラーをダブルクリックし、スクリプト内の対応する行にあなたを取るようにすることができます。

- または -

1。 選択 ツールした後、 ABACUSスクリプト名 で作成されたメニュー項目 スクリプトマネージャ.

2。 スクリプトにエラーがある場合、スクリプトエディタが（最初のエラーの行で強調表示）のメインウィンドウに表示されるスクリプトの内容で開かれ、スクリプトエディタの下部にあるエラーの説明セクションには、詳細情報を一覧表示したりします行番号を含むエラー（複数可）。 注意： エラー説明セクションの各個々のエラーをダブルクリックし、スクリプト内の対応する行にあなたを取るようにすることができます。

スクリプトコンパイルエラー

スクリプトコードの構文が正しくない場合、コンパイルエラーが発生します。これらのエラーは、エラーの説明、および行番号と、エラー・セクションのウィンドウの下部に表示されます。これは、行番号を持っていませんランタイムエラー（下記参照）から、コンパイルエラーを区別行番号です。コンパイルエラーは、二重にジャンプし、問題の特定の行を強調表示するためにクリックすることができます。

スクリプトランタイムエラー（重要）

（さらなる例を下参照）スクリプトコードが正常にエラーなしでコンパイルされた後にランタイムエラーが発生しますが、エラーは実行時に発生します。彼らは、破損したモデルをもたらすことができるようにランタイムエラーは、実行時エラーがモデルでそれらを置いたであろうコードの前に発生しているため、通常モデルの一部（モデル内の他のオブジェクトによって作成され、参照されるオブジェクトは、自分自身でない場合、重要であり、どこかで、）実行されました。

スクリプトがモデルに追加するオブジェクトを作成する場合、あなたは、あなたのスクリプトを保存するスクリプトを閉じて、スクリプトの実行が正常に完了しなかった場合（スクリプトによって作成された変更のアンドゥを実行することにより、実行時エラーに起因する破損を回避することができます）。しかし、（下記参照）に生じた破損を回避する他の方法もあります。 注意：単にモデルから読み、そこに書いていない任意のスクリプトは、安全であるとにかかわらず、実行時エラーは、その実行中に発生するかどうかの、いずれかの問題が発生することはありません。

オブジェクトの作成とオブジェクトモデルに追加されたスクリプトコードを書くときに破損を回避するために、それは彼らが他のオブジェクトによって参照されている場合、オブジェクトはできるだけ早くモデルに追加されていることが示唆されました。

あなたは、新しい接続を作成し、2つの新しいコンポーネント、その後、それらを一緒に接続している場合たとえば、それは、最初のコンポーネントを作成後、第2、モデルに追加し、それを追加し、接続を作成するのが最善であり、それを追加し、最終的には添付ファイルを作成します。これは、スクリプトの実行を中断し、実行時エラーがあるとした場合、添付ファイルが作成される前にobjectmodelであることが要求されているすべてのオブジェクトは、モデルにあることを意味します。例えば、唯一の接続が追加されていたが、添付ファイルが作られ、場合破損が発生する可能性があり、スクリプトが最終的に発生する可能性がありますmodel.Corruptionに新しいコンポーネントを追加する前に、次に実行時エラーが発生するたびに別のオブジェクトによって参照されるオブジェクトobjectmodelは、objectmodel自体ではありません。

例のランタイムエラーは、次のとおりです。

· オブジェクト変数がnull参照である場合、これが発生し、そのオブジェクトのメソッドやプロパティが使用されている - オブジェクト参照がオブジェクトインスタンスに設定されていません。 「objectVariableは、何もしない場合は...「ヌル参照は、によって確認することができます

· インデックスが配列の境界外だった - 例えば - 配列が範囲外にあるインデックスを使用してアクセスしているときに発生します0未満か等しいまたは配列の長さ/数よりも大きいです。配列またはコレクションの長さがそれぞれ.LENGTHまたは.Countプロパティで確認できます。

· 無断例外ません - あなたは、特定の変更を行うためのアクセス許可を持っていない場合は、このいずれかが発生した - あなたに...権限がありません

· 主キー例外 - 重複/名前/ IDがありません - 変更が別のオブジェクトと競合するユニークな属性に行われた場合、このいずれかが発生します。例えば。アーキテクチャは、同様に標準で、名前で一意である必要があります。

· 参照整合性の例外 - 無効なオブジェクトへの参照フィールドを設定します。例えば。 「何も」またはobjectmodel内のコレクションの多くの子としてnullを追加しません。

· 長さゼロの例外 - あなたは空の文字列にオブジェクトの名前を設定しようとすると、これが発生する可能性があります。ほとんどのオブジェクトは、少なくとも1文字を持つように自分の名前が必要です。

Importsステートメント

スケルトンスクリプトの開始時のような文があることに注意してください 輸入ABACUS.ObjectModel。これらの記述は、既にスクリプトによって参照されていないDLLが含まれません - その目的は、クラスの名前全体を指定することに「ショートカット」を提供することです。

と例えば、（ABACUSで成分を表す）型CComponentの変数を宣言します 輸入ABACUS.ObjectModelスクリプトの先頭に向かって文は、専用として宣言することを必要とします CComponentとして薄暗いコンプ、コンパイラはCComponentクラスのABACUS.ObjectModel名前空間に見て知っているから。 Importsステートメントがなければ、それはのように宣言しなければならないであろう ABACUS.ObjectModel.CComponentとしてコンプを暗く。 （例えばmscorlib.dllで、またはのSystem.Windows.Forms.dllなど）アセンブリは、複数の名前空間を含めることができます - Importsステートメントは、これらの名前空間のためではなく、アセンブリ自身のためです。 ABACUS.ObjectModel.dllアセンブリは、唯一のスクリプトを介してアクセス可能な単一ABACUS.ObjectModelの名前空間を持っています。

自動的に参照されるアセンブリ

次のDLLは、スクリプトによって自動的に参照されます。

· mscorlib.dllで

· System.dllの

· System.Drawing.dll

· System.Windows.Forms.dll

· （暗黙的にコンパイラによって参照される）がmicrosoft.visualbasic.dll

· ABACUS.ObjectModel.dll

他の.NETアセンブリ、またはあなた自身のアセンブリのいずれかに追加の参照を作成するには、上の次のセクションを参照してください #ImportDLL声明。

#ImportDLLステートメント

ABACUS 3.1以降では、あなたがを使用してスクリプトのために必要な場合があり、追加のアセンブリを参照することができます #ImportDLL声明。あなたはあなたのカスタムDLLにアクセスし、その中の機能を利用したい場合たとえば、あなたはABACUSディレクトリに置き、スクリプトの最初の行（複数可）などのステートメントが含まれるであろう。それは、.NET DLLである場合、通常は全体のパス、単にDLLを入力する必要はありません。

· #ImportDLL C：\プログラムファイル\ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

注意すべきいくつかの他の事：

1。 DLLをコンパイルし、実行時に検出する必要があるため、これが唯一のABACUSプログラムフォルダに配置されているにカスタム（非.NET）のDLLを制限します。

2。 #ImportDLL文は、スクリプトの最初の行（複数可）でなければなりません - あなたは5文を持っている場合、それらは、スクリプトの最初の5行にする必要があります

3。 アン #（それは、コメントまたはImportsステートメントの後に配置された場合など）の任意の場所に配置ImportDLLステートメントが、スクリプトの最初の行は正しく動作しませんおよび/または無関係なコンパイラエラーが発生することがあります。

#オフィスアセンブリとImportDLL

あなたはMicrosoft Officeがインストールされているし、あなたのスクリプトは、Office相互運用機能アセンブリを必要とする場合、それは単に使用してそれらを参照することが可能です #下記のように（アセンブリ名でImportDLL, 例えば #ImportDLLエクセル）。この方法を使用すると、絶対DLLパスを使用する必要がないという利点を持っているので、スクリプトは（スクリプトを編集することなく、両方のOffice 2003および2007で動作するはずです）、よりポータブルです。

この機能を使用すると、GAC（グローバルアセンブリキャッシュ）は、相互運用アセンブリが​​検索され、見つかった場合、スクリプトは、そのアセンブリへのパスでコンパイルします。それが見つからない場合は、スクリプトは（のみExcelとVisioのinteropsを含む）ABACUSプログラムディレクトリを確認します。要求された相互運用は、この時点で検出されない場合、警告が示されています。

あなたは（完全ABACUSのインストールの一部である）の.NET Frameworkをインストールする前に、Microsoft Officeのインストールした場合interopsは通常、GACにインストールされていません。あなたが追加/からMicrosoft Officeの[変更]オプションを実行してインストールプログラムの追加と削除、および.NETプログラマビリティオプションを選択することができます。詳細情報については、これを参照してください。 記事 MSDNの。

このショートカットがサポートされているアセンブリは、以下のとおりです。

· アクセス

· Access.Dao

· 秀でます

· グラフ

· MSProject

· 見通し

· OutlookViewCtl

· OWC11

· パワーポイント

· 出版社

· スマートタグ

· Visioの

· Visio.SaveAsWeb

· VisOcx

· ワード

Itは上記のすべてのアセンブリが​​役立つかどうか一部のユーザーの2月にもあいまいなアセンブリを必要としているように、客室にはこの機能をregardelessに含まhavebeen完全には明らかではありません。

参照してください

あなたのアーキテクチャをシミュレートします

©2001-2015 Avolution Pty Ltdの無断複写・転載を禁じます。


マクロの使用

ナビゲーション：あなたのアーキテクチャをシミュレートします>

マクロの使用

コメントを送信 このトピックに関する。

あなたがABACUSで繰り返しタスクを実行する場合は、マクロを使用してタスクを自動化することができます。したがって、ABACUSマクロはいつでも再生することができる操作の記録シリーズです。

マクロの記録

1。 [ツール| マクロの記録または代わりに押してください Altキー+ F10.

2。 録音したい操作を実行開始します。

警告

このとき、マクロ記録を持ついくつかの既知の問題があります。あなたのマクロを記録する際に考慮にこれらを取るしてください：

· 現在、ちょうどMicrosoft Windowsのキーストローク、マウスの動きやマウスのクリックを記録するマクロ。しかし、マクロの記録自体に制限により、常に記録されていないいくつかのキーストロークがあります。これらを含めます：

· [タブ]

· [Ctrl]キー

· [Alt]キー

· [ESC]

· [開始]

· [F1]から[F12]

· したがって、あなたがキーボードショートカットをそのキーボードショートカットの作業に依存することができるイベントの巨大なシーケンスを記録する前に、マクロレコーダーで記録されていることを確認することをお勧めします。

· これらはマクロの記録によって記録されたアクションによって開かれると、現在原因マクロの記録との制限のために、コンテキストメニューは、ABACUSにより適切に処理されません。あなたは、コンテキストメニューを開くと、コンテキストメニューからコンテキストメニューにリストされた関数のいずれかを実行する必要があり、そうでない場合はコンテキストメニューがABACUSのエラーを引き起こす可能性が意図しないアクションまたはアクションにつながる可能性がある、再生中に開いたままになることがあります。

· コンテキストメニューを閉じ、通常の方法（例えば、キーボードの[Esc]キーを押す、または画面上のどこかに左クリック）が実際にマクロの再生時にコンテキストメニューを閉じないことに注意してください。

先端

ダイアログで、むしろマウスクリックを使用するよりも、それは/選択解除チェックを選択するには、プルダウンメニュー項目やラジオボタンオプションとスペースバーを選択するために利用可能なコントロールとカーソルキーを移動するには、Tabキーを使用することをお勧めしますボックス。

マクロの記録を停止します

1。 押す Altキー+ F9または代わりに[ツール| マクロの停止.

2。 場所にダイアログブラウズ名前を付けて保存マクロのとABACUSマクロ（.abacusmacファイル）のファイル名を選択し、[保存]をクリックします。

注意

使い方 ツール| マクロの停止記録されたマクロでこの操作が含まれます。したがって、ユーザーはマクロ自身で不要なマクロの操作を含まないように、マクロを使用するためのAltキー+ファンクションキーのオプションを使用することに習熟することをお勧めします。

先端

マクロは、現在編集できないように、それはAltキー+ F10キー/ Altキー+ F9「ペア」を使用して独立した一連のマクロとして長いタスクを記録することをお勧めします。

記録されたマクロを再生するには

1。 [ツール| 再生マクロまたは代わりに押してください Altキー+ F8.

2。 場所に開くマクロ]ダイアログブラウズInとABACUSマクロ（.abacusmacファイル）のファイル名を選択し、[開く]をクリックします。

警告

あなたがそれを開くために、参照ダイアログからマクロファイルをダブルクリックすると、そろばんマクロを開くと、マクロの記録は、記録された左クリックオーバーライドするまで、この状態を左クリックした状態でマウスの左ボタンを保持することができます。

注意

マクロの再生速度は、下の[全般]タブで設定することができます ツール| オプションノーマル（デフォルト）、高速または低速のいずれかと。彼らはそれぞれ約100倍、1/100リアルタイムで記録されたマクロを再生しますように高速と低速の両方の再生速度が推奨されていません。それが推奨されますので、任意の長い処理作業後の短い時間のために一時停止する記録が、再生時にその処理タスクを持つ前に、次の動作が実行されていないことを確実にするためにしながら、通常の再生速度は、まだ記録された速度よりも約30％高速化するマクロを再生します完了しました。

記録したマクロの再生を停止するには

1。 押す Altキー+ F9.


シミュレーションパフォーマンス

ナビゲーション：あなたのアーキテクチャをシミュレートする>シミュレーター>

シミュレーションパフォーマンス

コメントを送信 このトピックに関する。

バックグラウンド

パフォーマンスのためのアーキテクチャの評価者は、アーキテクチャ全体にメッセージ（またはトークン）の流れをシミュレートすることによって動作します離散事象シミュレータです。この背後にある理論は、シドニー工科大学によって行われた研究に由来し、そして基づいています 階層型キューイングネットワークモデル（LQNM）、 時限とカラーペトリネット-（TCPN）と 活動サイクルダイアグラム（ACD）。

ABACUS性能シミュレーションでは、一つの成分の処理は、別のコンポーネントから渡されたメッセージによって主に駆動されます。この技術の原理は、4つの主要な部分で理解することができます：

1。 ザ・ メッセージセントリック通信は、使用してABACUSでモデル化されています 論理的（または間接的な）接続。論理接続は、コンポーネント間で渡されるメッセージの動作（周波数およびデータ）を定義します。論理接続の良い例は、シーケンスは、2つの（2）ビジネスプロセスまたは2（2）アプリケーション間の論理インターフェイスとの間を流れるであろう。

2。 論理メッセージが経由して目的地に輸送され 階層（このようなリソーススイムレーンのような）または 直接（物理的な配線など）の接続。これを行うには、彼らは全体で、アップルーティングされ、直接経路を追従する階層（階層化アプローチ）をダウンバックアップすることができます。

3。 モデルの忠実度に合わせて調整することができます。例えば、プロセスは、これまでの各基本処理及び機能は、別個の処理のフットプリントを有するように分周することができます。あるいは、反射、プロセス全体のためのちょうど1の値を持つのに十分であり 平均メッセージに対する処理応答。

4。 実際 処理ない（またはある）構成要素、プロセッサにより実行されます。プロセッサは、一般的なもので、CPU、人、組織単位、または作業を実行することができる何か他のものである可能性があります。例えば、ビジネス・プロセスは、任意の実際の処理を行いません。これは、（分散処理の表記が使用される場合）は、その親階層（スイムレーンの表記が使用される場合）、またはその処理ネットワークのいずれかに位置する最初の「プロセッサ」によって行われます。

評価は、すべての接続は、少なくとも一回シミュレートされるように、システム内の（指定された）トラフィックをシミュレートすることによって行われます。メッセージの到着時間は、ランダムに、その指定された周波数に関して生成されます。モデルは、様々な出力特性などの道に沿って統計を収集、資源処理と競合し、メッセージのキューイングをシミュレートします。

キー・パフォーマンス・インプット要因

1。 周波数 - 接続が発生する頻度。

2。 処理 - 一つのプロセスを完了するために実行時間の量。これは、時間、分、日、業務等であってもよく、

3。 速度 - プロセッサのリソースの速度。つまり、時間の1単位で行うことができますどのように多くのサイクル/指示/アクションです。それは、処理のために使用される単位と一致することが重要です。

4。 プロセッサ - プロセッサのリソースの数。プロセッサは、人々は、CPUの、外部機関等とすることができます

キー・パフォーマンス・出力要因

1。 スループット - を通して単位時間あたりのメッセージ数 接続。この実際の値は、システムの飽和状態を推定することが期待/理論値（すなわち、周波数）と比較することができます。

2。 メッセージレート - を通して単位時間あたりのメッセージ数 成分。これは、すべてのコンポーネントの受信および送信メッセージの合計です。

3。 応答 - このための最小/平均/最大待ち時間 接続。これは、シンクと任意のキューイングと処理にソースからの接続をすべて観察待ち時間の和である（双方向場合ソースに待ち時間）。

4。 利用 - の利用 成分。コンポーネントは、デバイス/プロセッサがない場合、これは0％になります（すなわち、上記で定義されたプロセッサと速度の特性を持っていません）。

上記のように離散事象シミュレーションは、様々な出力特性を算出するために実行されているが、以下の式（システムが飽和していない）結果の概略検証として使用されてもよいです。

すべての着信接続のための周波数域の利用=合計*加工/（スピード*プロセッサー）

全体的な概念は、おそらく最高の二つの異なる性能のメタモデルを示し、以下の図を考慮することによって実証されています。左側のスタイルは、そのプロセッサリソース内階層的に基づいて、処理タスクとの古典的な「スイムレーン」の表記です。右側のスタイルは、そのプロセッサのリソースへのプロセス接続を介して接続された処理タスクと「分散型」の表記です。この後者の表記法は限られたスイムレーン表記とは異なり、特定の処理タスクのために複数のプロセッサ・リソースを可能にします。

注意

各メタモデルに示されている（青）の入力特性（赤）と出力特性であります：

パフォーマンスのメタモデル：分散表記対スイムレーン

性能シミュレータを実行します

パフォーマンスの面であなたのアーキテクチャをシミュレートするために、

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 選択 分析| パフォーマンスまたはツールバーのボタンをクリックします。

3。 選択 アーキテクチャあなたは、プルダウンメニューから評価したいです。

注意

デフォルトでは、ABACUSは自動的に再シミュレーションは、任意の原資産や構造変化に起因して必要とされる最初のアーキテクチャを選択します.このハイライトは、に示されています 赤 上の シミュレーションツールバー .

4。 選択 コンポーネント そして 接続あなたがから、評価したいです 標準の要素の選択ウィンドウ .

5。 設定 ランタイムスケールファクタ スライダー。

注意

値が大きいほど、より多くの統計的に一貫した結果が得られるが、計算に時間がかかります。

追加 チェックボックスへ 標準の要素の選択ウィンドウ

· Saveの形質転換されたモデル 意志 現在のプロジェクトと同じフォルダにプロジェクトのRBD変換さ​​れたバージョンのコピーを保存し、プロジェクト名に「_transformed "を追加.この変換されたプロジェクトについて詳細にABACUSによって行わ信頼性シミュレーションを診断するために使用することができます。

その他のオプション 標準の要素の選択ウィンドウ

· ランタイムスケールファクタ 以上でシミュレーション時間と精度を制御 値収率INGより統計的に一貫した結果が、 取ること 長い時間に ラン.

注意

ABACUSは、シミュレーション時間を計算するときには、この接続の（オーバー周波数すなわち1）期間のための「ウォームアップ」をシミュレートするために選択された最も遅い間接的な接続の頻度を決定します（ランダムにすべての接続のための定期的なメッセージ・ジェネレータを開始このウォームアップ時間の間に、それらを開始）し、その接続の実行時間スケールファクタの時間期間にシミュレートするためにすべてのチャンスを与え。または、（1 /周波数）ウォームアップ時間+（1 /周波数）*ランタイムスケールファクタのシミュレーション時間。これは、統計が収集され、その後、最も遅い接続が少なくとも一回のシミュレーションでシミュレートされる前にすべての接続が開始されていることを確認することです。 例えば。 （時間単位は日であれば月に一度または年頃）最も遅い間接的な接続が0.033時間単位の周波数を有する場合には、ウォームアップ時間は30.3時間単位とシミュレーション時間は30.3時間単位の倍となるだろうファイル名を指定して実行時間スケールファクタ.

6。 クリック フィニッシュあなたが取得します 警告 ダイアログ。

7。 必要に応じてクリックして警告を探ります 詳細>>.

8。 クリック 持続する.

注意

この時点で、ABACUSは、アーキテクチャの離散イベントシミュレーションを実行し、短い時間の後（フィードバックのためのプログレスバーで）計算の完全なダイアログが表示されます。

9。 クリック [OK]シミュレーションを承認します。

先端

トレーニングコースと性能シミュレーションにさらにヘルプについてを参照してください Avolutionコミュニティ .

コンポーネントのプロパティ

次の表は、パフォーマンスを評価するために必要なプロパティを示します。見つからない場合は、プロパティは、コンポーネントのインスタンスで最初に検索され、[コンポーネント規格と、デフォルト値が使用されます。これらのプロパティは、（プロパティ入力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップの性能を入力」と。に示すように、これらの「入力」プロパティとリポジトリへの様々な構造変化のいずれかの変更は、再シミュレーションを必要とする性能シミュレータになります 赤 上の シミュレーションツールバー .

タイプ | 名 | 既定値 | ユニット | データ型 | 必須 | 説明
動作 | b_pack | 0.0 |  | 10進数 | 偽 | 固定サービス時間は秒単位でパックします。 このプロパティ 典型的には、 標準タイプとして指定して、複数のコンポーネントインスタンスに使用されます。たとえば、CORBAは= 0.23ミリ秒b_packました。
動作 | m_pack | 0.0 |  | 10進数 | 偽 | 秒/バイトにパックする変数サービス時間。 このプロパティ 典型的には、 標準タイプとして指定して、複数のコンポーネントインスタンスに使用されます。
動作 | b_unpack | 0.0 |  | 10進数 | 偽 | 固定サービス時間は秒単位で解凍します。 このプロパティ 典型的には、標準タイプとして指定して、複数のコンポーネントインスタンスに使用されます。
動作 | m_unpack | 0.0 |  | 10進数 | 偽 | 秒/バイトで解凍する変数サービス時間。 このプロパティ 典型的には、標準タイプとして指定して、複数のコンポーネントインスタンスに使用されます。
動作 | 処理 | 0.0 |  | 10進数 | 真 | 一つのプロセスを完了するために実行時間の量。これは、時間、分、日、業務等であってもよく、
動作 | プロセッサ | 1 |  | 整数 | 真 | プロセッサのリソースの数。プロセッサは、人々は、CPUの、外部機関等とすることができます
動作 | 速度 | 100 |  | 整数 | 真 | プロセッサー・リソースの速度。つまり、時間の1単位で行うことができますどのように多くのサイクル/指示/アクションです。それは、処理のために使用される単位と一致することが重要です。
動作 | k_bkgd | 0.0 |  | 10進数 | 偽 | コンポーネントのバックグラウンド処理。 これは、％のための任意の固定されたオフセットに一致するように、結果を調整するために使用されます。これはおそらく無視することができます。

次の表は、パフォーマンス評価して、コンポーネントのプロパティの出力を示しています。これらのコンポーネントのプロパティのセットは、各パフォーマンスの実行の各コンポーネントに対して生成されます。これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「パフォーマンス出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっているとパフォーマンスシミュレータに応じて再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | ユニット | データ型 | 必須 | 説明
動作 | メッセージレート |  | 10進数 | 偽 | コンポーネントを介して単位時間あたりのメッセージ数。 これは、すべてのコンポーネントの受信および送信メッセージの合計です。
動作 | 帯域幅 |  | 10進数 | 偽 | コンポーネントを介して全体の帯域幅。 受信メッセージと送信メッセージの両方に起因する合計。
動作 | 利用 | % | 10進数 | 偽 | コンポーネントの利用。 コンポーネントは、デバイス/プロセッサでない場合、これは0％になります（つまり、これは上記で定義されたプロセッサと速度の特性を持っていません）

接続のプロパティ

次の表は、パフォーマンスを評価するために必要なプロパティを示します。プロパティは、Connectionインスタンス、[接続の標準と見つからない場合は、デフォルトが使用されている中で最初に検索されます。これらのプロパティは、（プロパティ入力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップの性能の入力」または「コスト/パフォーマンスの入力」と。これらの「入力」プロパティとリポジトリへの様々な構造変化のいずれかに変更がパフォーマンスシミュレータになり、および/または コストシミュレータ に示すように、再シミュレーションを必要とします 赤 上の シミュレーションツールバー .

タイプ | 名 | 既定値 | ユニット | データ型 | 必須 | 説明
動作 | 種類 | 双方向の | [双方向|単方向] | 検索/一覧 | 真 | 接続は、双方向（双方向）または一方向（単方向）であるかどうか。 このプロパティの許容値は、「双方向」または「単方向」です。 双方向は、単一の非同期 "イベント"一方向の手段に対し、同期要求/応答メッセージを意味します。
動作 | 抽象概念 | 間接的な | [間接|直接] | 検索/一覧 | 真 | 接続は、物理的または論理的であるかどうか。 直接接続は、論理接続に沿って流れる2つの構成要素間の物理的な「パイプ」です。 このプロパティの許容値は、「直接」または「間接的」です。 値が「直接」の場合、接続は（プロパティ種類と抽象を除く）他のプロパティを必要としません。
データ | L_app1 | 0 |  | 整数 | 偽 | バイト単位での要求/イベントサイズ。 すべての接続は、通常、このために特定の値を持つことになります。 CORBAでは、イベントは実際には双方向であり、常に（L_app2）12バイトは認めています。それが真の単一方向接続の場合、プロパティL_app2を残します。
データ | L_app2 | 0 |  | 整数 | 偽 | 応答/バイト単位でサイズを認めます。 すべての接続は、通常、このために特定の値を持つことになります。一方向の接続はL_app2を持っていません。
動作 | 周波数 | 1 |  | 10進数 | 真 | 接続が発生する頻度。 すべての接続は、通常、このために特定の値を持つことになります。プロパティ周波数を省略すると、デフォルトが使用されます。
動作 | 関係 | プロセス | [プロセス| ]サポートしています | 検索/一覧 | 偽 | 「プロセス」プロパティを持つ接続は、接続の開始時にコンポーネントが接続の終了時にコンポーネントで処理されるように変換されることを示しています。実際には「ソース」コンポーネントは、「シンク」コンポーネント（添付の接続もこの動きを「ドラッグ」している）の子になるように移動されます。 「プロセス」プロパティが次に存在する場合は、他のすべての接続プロパティは、以下で説明するオプションの「％」プロパティを除き、無視されます。
動作 | % | 100.0 |  | 10進数 | 偽 | （上述の）「プロセス」性質を持っている接続は、必要に応じて宛先コンポーネントに起因する処理の割合を示す「％​​」特性を有することができます。このようにして、単一のソース・コンポーネントは、様々％年代に複数の宛先コンポーネントによって処理することができます。 ％値は、100％まで追加する必要はなく、単にそれが宛先コンポーネントの子になるように変換されるように、ソースコンポーネントの（上記参照）、「処理」プロパティを拡張するために使用されます。

次の表は、パフォーマンス評価によって生成されたプロパティを示します。これらの接続プロパティのセットは、各パフォーマンスの実行の各接続のために生成されます。これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「パフォーマンス出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっているとパフォーマンスシミュレータに応じて再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | ユニット | データ型 | 必須 | 説明
動作 | 帯域幅 |  | 10進数 | 偽 | 接続のための全体的な帯域幅。 これは、間接的な接続のために計算され、（L_app1 + L_app2）*スループット本質的です。
動作 | 帯域幅の1/2 |  | 10進数 | 偽 | 接続の発信（1）と着信（2）メッセージのための具体的な帯域幅。 これは、間接的な接続のために計算され、基本的にL_app1 *スループットとL_app2 *スループットです。
動作 | スループット |  | 10進数 | 偽 | 接続を介して単位時間あたりのメッセージ数。 この実際の値は、システムの飽和状態を推定することが期待/理論値（すなわち、周波数）と比較することができます。
動作 | 完了 | % | 10進数 | 偽 | 接続するためのメッセージが正常に完了処理のパーセント。 これは、間接的な接続のために計算され、スループット/スイッチング周波数です。わずかに高いメッセージ生成周波数でメッセージ生成結果のランダム性が指定よりもため時折完了値が100％を超えます。
動作 | レスポンス（最小/アベニュー/最大） |  | 10進数 | 偽 | 最小/平均/最大待ち時間。 これは、間接的な接続のために計算され、ソースからシンクへの接続や、任意のキューイングおよび処理のため、観察された待ち時間である（双方向場合ソースにレイテンシ）されます。

アーキテクチャのプロパティ

次の表は、パフォーマンス評価によって生成されたシステム全体のアーキテクチャのプロパティを示しています。アーキテクチャの性質の単一のセットは、各パフォーマンスの実行のために「集約」されています。これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「パフォーマンス出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっているとパフォーマンスシミュレータに応じて再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | ユニット | データ型 | 必須 | 説明
動作 | メッセージレート |  | 10進数 | 偽 | アーキテクチャのコンポーネントを介して、単位時間あたりのメッセージ数。 これは、すべてのコンポーネントの受信および送信メッセージの合計です。
動作 | スループット |  | 10進数 | 偽 | アーキテクチャの接続を介して単位時間あたりのメッセージ数。 これは、全ての間接的な接続」のスループットの合計であり、この実際の値は、システムの飽和を推定することが期待/理論値（すなわち、周波数）と比較することができます。
動作 | 帯域幅 |  | 10進数 | 偽 | 全体の帯域幅。 アーキテクチャの接続帯域幅の合計。
動作 | 利用 | % | 10進数 | 偽 | すべてのコンポーネントを利用します。 それは、すべてのアーキテクチャのコンポーネントutilisationsの単なる和であるとして、100％よりも大きくすることができます。
動作 | レスポンス（最小/アベニュー/最大） |  | 10進数 | 偽 | 最小/平均/最大待ち時間。 （双方向場合ソースへと）ソースからシンクへアーキテクチャの接続のためのすべての観察された待ち時間の合計。


シミュレーションモジュール性

ナビゲーション：あなたのアーキテクチャをシミュレートする>シミュレーター>

シミュレーションモジュール性

コメントを送信 このトピックに関する。

モジュール化シミュレータは、各コンポーネントの着信およ​​び発信接続の数を計算します。

モジュール性の面であなたのアーキテクチャをシミュレートするために、

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 選択 分析| モジュール性.

3。 選択してください アーキテクチャ（複数可）あなたは、評価に含めます。

注意

デフォルトでは、ABACUSは自動的に再シミュレーションが何らかの根本的な構造変化に必要とされているアーキテクチャ（複数可）を選択します.このハイライトは、に示されています 赤 上の シミュレーションツールバー .

4。 クリック 次.

5。 選択してください 接続タイプ（S）あなたは、評価に含めます。

6。 クリック 次.

7。 必要に応じて計算結果のプロパティ名をカスタマイズします。

8。 クリック フィニッシュ.

注意

この時点で、ABACUSは、アーキテクチャ（複数可）の構造評価を実行し、短い時間の後（フィードバックのためのプログレスバーで）計算の完全なダイアログが表示されます。

9。 クリック [OK]評価を承認します。

先端

トレーニングコースとモジュール性評価に関するさらなるヘルプについてを参照してください Avolutionコミュニティ .

コンポーネントのプロパティ

次の表は、モジュールの評価によって出力されるコンポーネントプロパティを示します。これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「モジュール化出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性が原因で、リポジトリとモジュール性シミュレータへの根本的な構造変化に期限が切れている場合は、に応じて再シミュレーションが必要です 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | データ型 | 必須 | 説明
モジュール性 | （ローカル）でのカップリングファン | 整数 | 偽 | このコンポーネントにそのファンの接続の数。
モジュール性 | カップリング・ファンアウト（ローカル） | 整数 | 偽 | このコンポーネントのうち、そのファンの接続の数。
モジュール性 | でカップリングファン | 整数 | 偽 | サブコンポーネントにそのファンの接続を含む、このコンポーネントにそのファンの接続数、。
モジュール性 | カップリング・ファンアウト | 整数 | 偽 | サブコンポーネントにそのファンの接続を含む、このコンポーネントのうち、そのファンの接続の数。


所有権のシミュレーショントータルコスト（TCO）

ナビゲーション：あなたのアーキテクチャをシミュレートする>シミュレーター>

所有権のシミュレーショントータルコスト（TCO）

コメントを送信 このトピックに関する。

バックグラウンド

総所有コスト（TCO）は、保有資産に関連した（取得から廃棄/処分）総負担ライフサイクルコストを測定するために設計され、金融推定値です。 TCOは購入の費用を反映しているだけでなく、資産の更なる使用および保守内の他のすべての側面を含んでいます。

TCOは、システムに過ごすために必要な労力と予算のコストを決定するために使用されます。 TCOのためのABACUSにおけるモデリングの簡単な方法は、コンポーネントにITシステムを破壊することです。我々は、それは、これらのコンポーネントのいずれかを実行するコストどのくらい平均的に調べることができます。私たちはその後、別のコストの要因は、システムがすでに稼働している場合は、ITシステム等進化可能か開いているかどうかに応じて可能性があり、この後に、考慮すべき主な要因は、メンテナンスや使用停止にするには、おそらくコストのコストです。

例

計算例のための図

組織またはその規格のコンポーネントは、これらのプロパティがあります。

· FTE= 100 000 $ /年

· サポートの取り組み= 0.01 FTE + 0.001 FTE /年= 1000 $ + $ 100 /年

· メンテナンス費用= 100 $ - $ 10 /年

· 資本コスト= 2000 $

· 努力をインストール= 2 FTE /日= 0.01 FTE /年= 1000 $

組織の下のコンポーネントは、これらのプロパティがあります。

· ホライゾンのイ​​ンストール= -2年（システムが2年前に現在インストールされたIE）

· 寿命= 3年

いつ ホライゾン+寿命<= 0をインストールします。 、これ以上のメンテナンスコストはありません。

計算

次のような計算は、次のとおりです。

注意

TCは、年間コストを=。 SE =サポート努力。 MCは、メンテナンスコストを=。

· 初期コスト=資本コスト+努力をインストール= 2000 + 1000年= 3000 $

· Tにおける= -2（1年時）、 TC =イニシャルコスト+ SE + MC+ 100 + 1000年= 3000 = 4100 $

· T = -1で、 TC = SE + MC=（1,000 + 100）+（100から10）= 1190 $

· t = 0で、TC =（200 + 1000）+（100 - 20）= 1280 $

· T = 1（最終年度）では、TC =（+ 300 1000）+（100から30）= 1370 $

例計算のグラフ

システムが退役するまでのTCOは、現在および将来のすべてのコストの合計です。

· Tにおける= -2（1年時）、TCOが= 4100 + 1190 + 1280 + 1370 = 7940 $

· T = -1で、TCOが= 1190 + 1280 + 1370 = 3840 $

· t = 0で、TCOは= 1280 + 1370 = 2650 $

· Tにおける= 1（最終年度）、TCO = 1370 $

主なコスト要因

あるABACUSにおける資産のTCOを算出する際に重要なコスト要因が考慮されます。

· ハードウェアの取得 - 機器のイニシャルコスト（資本コスト）。

· ソフトウェアの取得 - ソフトウェアのライセンスの初期コスト（資本コスト）。

· インスタレーション - 初期セットアップに関連した費用。

· トレーニング - 初期設定後、外部ベンダーのトレーニングに関連するコスト。

· サポート - 社内のサポートに関連するコスト。

· メンテナンス - ベンダーの保守契約、供給および災害復旧費を交換またはアップグレードするコスト。

· インフラ - サポート資産に関連する費用。

主なコスト要因のABACUS例表現

コストシミュレータの実行

コストの面であなたのアーキテクチャをシミュレートするために、

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 選択 分析| コスト.

3。 選択してください アーキテクチャ（複数可）あなたは、評価に含めます。

注意

デフォルトでは、ABACUSは自動的に再シミュレーションは、任意の原資産や構造変化に起因して必要とされているアーキテクチャ（複数可）を選択します.このハイライトは、に示されています 赤 上の シミュレーションツールバー .

4。 選択 通貨プルダウンから。

5。 移動 計算する年必要な年数にスライダー。

注意

デフォルトでは、年が計算する場合の費用は、自動的に各個々の年に計算されます（およびプロパティのコレクションが追加/更新された）、その後も計算年の全体数の累積値を超える1年です。唯一の累積値が必要とされる場合には、オフ 毎年のコストを計算プロジェクトのプロパティの数を節約するために、以下のようなオプションを選択します。

6。 ままにするかどうかを選択します 毎年のコストを計算チェックしたり、それをオフにします。

7。 クリック 次.

8。 必要に応じて選択します 接続あなたは評価の一部として一緒にコストを属性したいです。

注意

使い方 コスト|属性接続コストのプロパティ することができます 起因します ソース端部に取り付けられたコンポーネントへの接続のシンク端部に取り付けられた部品から（すなわちコスト|アトリビューション= "シンクソースに」）、または に接続されているコンポーネントから ソース に接続されているコンポーネントへの接続の終了 シンク 終わり（すなわちコスト|アトリビューション= "シンクにソース」）。 さらに、 ABACUSは自動的に行動とそれらの接続を選択します|関係=「プロセス」または「サポート」そして、帰属の方向は、「シンクソースする」となります。さらに、コストがあります 配分 いずれかの行動に応じ| ％またはコスト| ％接続のプロパティ、あるいは多くのソースにシンクからの複数の接続が存在する場合多くのシンクまたはソース、任意の行動に応じ|ソースコンポーネントのプロパティを処理またはそれぞれのコンポーネントをシンク.

9。 クリック フィニッシュあなたが取得します 警告 ダイアログ。

10。 必要に応じてクリックして警告を探ります 詳細>>.

11。 クリック 持続する.

注意

この時点で、ABACUSは、アーキテクチャ（複数可）のアクティビティベースの原価計算の評価を実行し、短い時間の後（フィードバックのためのプログレスバーで）計算の完全なダイアログが表示されます。

12。 クリック [OK]評価を承認します。

先端

トレーニングコースとコストのシミュレーションに関するさらなるヘルプについてを参照してください Avolutionコミュニティ .

成分 および/または接続 プロパティ

次の表は、コンポーネントを示しています および/または接続 コストを評価するために必要なプロパティ。これらのプロパティは、（プロパティ入力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップ「コスト入力」と。に示すように、これらの「入力」プロパティとリポジトリへの様々な構造変化のいずれかの変更は、再シミュレーションを必要とするコストシミュレータになります 赤 上の シミュレーションツールバー .

タイプ | 名 | 既定値 | ユニット | データ型 | 必須 | 説明
コスト | ホライゾンのイ​​ンストール | 0 | 年 | 整数 | 真 | ときに、コンポーネントを指定します または接続 されている、またはインストールされます。 · 0（デフォルト）の値は、コンポーネントことを示しています または接続 現在の年に設置されています。 · 0より小さい値は、そのコンポーネントを示しています または接続 過去にインストールされています。 · 0より大きい値は、そのコンポーネントを示しています または接続 将来的にインストールされます。
コスト | 寿命 | 0 | 年 | 整数 | 真 | コンポーネント内の時間の長さを指定します。 または接続 それは退役された後、操作のままになります。
コスト | FTE | 100,000.00 | $ /年 | 10進数 | 偽 | 各フルタイム従業員の年間コスト。 このプロパティは、コンポーネントで発見されていない場合それ自体または接続の場合、コンポーネントは、接続のシンク端部に取り付けられました、それは他のコンポーネントで検索されます。 まず、 任意の「シンク」 成分s の終わりに a 「サポート」の関係との接続 コンポーネントへ 続いて、検索されます その「シンク」コンポーネントの親秒。 FTEプロパティが見つからない場合、コンポーネントの 親-componentsはその後、検索されます。 FTEがまだ見つからない場合は、デフォルト値が使用されます。 ご注意：FTEは、コンポーネント上でのみ有効な入力プロパティです。
コスト | メンテナンスコスト（固定） | 0.00 | $ /年 | 10進数 | 偽 | コンポーネントを維持するための年間固定費または接続.
コスト | メンテナンスコスト（変数） | 0.00 | $ /年 | 10進数 | 偽 | コンポーネントを維持することにより、総費用額 または接続 毎年変更されます。 例えば、$ -500の値は$ 500の値が$それぞれ500年による総維持費が高くなることを示しながら、総維持費は、$それぞれ500年によって減少することを示しています。
コスト | サポートエフォート（固定） | 0.00 | FTE /年 | 10進数 | 偽 | コンポーネントをサポートしているの年間固定努力または接続、人・年単位で指定。
コスト | サポートエフォート（変数） | 0.00 | FTE /年 | 10進数 | 偽 | コンポーネントをサポートすることにより、総努力量 または接続 毎年変更されます。 例えば、-0.01の値が0.01の値がトータルサポート努力が毎年0.01によって増加させることを示している一方でトータルサポート努力は、毎年0.01人年によって減少することを示しています。
コスト | 資本コスト | 0.00 | $ | 10進数 | 偽 | 部品を購入する初期コストまたは接続.
コスト | 努力をインストール | 0.00 | FTE | 10進数 | 偽 | コンポーネントをインストールするには、人・年で、必要な作業、または接続.

次の表は、コンポーネントを示しています および/または接続 TCO評価によって出力される性質。 これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「コスト出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっており、コストシミュレータに応じて再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

注意

TCO評価の特性は（また、「銀行」が丸めとも呼ばれる）「ラウンド半分にさえ」アプローチを「丸く」される必要がある出力が使用される場合.この技術は、より均等に任意の0.5を解決するために使用される結果に「タイブレーク」は切り上げまたは最寄りのダウンされています 偶数 その結果、むしろ常に切り上げまたはダウンして、結果を歪めるより。すなわち3.5は、それらの両方が、2と3に切り捨てまたは3および4に切り上げされているいずれかのではなく、4に切り上げられながら2.5は、2に切り捨てられます。

タイプ | 名 | ユニット | データ型 | 必須 | 説明
コスト | 関係者への総コスト - 次のx年。 | $ | 整数 | 偽 | 次にわたる総所有コスト（TCO） xxが評価を実行するときに指定した時間の長さです年、。これは、コンポーネントのコストを含み または接続の 標準、サブコンポーネントまたはサブ接続（すなわち 子供）と任意の帰属するコストを削減できます。
コスト | 関係者への総コスト（ローカル） - 次のx年。 | $ | 整数 | 偽 | 次にわたる所有の「ローカル」費用 x年、ここで x評価を実行するときに指定した時間の長さです。これはありません ではありませんコンポーネントのサブコンポーネントのコストを含みます または接続のサブ接続 (すなわち子供）または起因するコスト。
コスト | 次のx年 - （子供）の関係者への総コスト。 | $ | 整数 | 偽 | 次にわたる所有の「子どものコスト xxが評価を実行するときに指定した時間の長さです年、。この のみ コンポーネントのサブコンポーネントのコストを含みます または接続のサブ接続 (すなわち 子供）。
コスト | 関係者への総コスト（起因） - 次のx年。 | $ | 整数 | 偽 | 次にわたる所有の「帰属する」費用 xxが評価を実行するときに指定した時間の長さです年、。この のみ 付け部品から任意起因する費用が含ま（これはもちろん、接続されているすべての接続から起因するコストを含んでいてもよいです）.

次の表は、コンポーネントを示しています および/または接続 TCO評価によって出力されるプロパティ計算ごとの年間コストのオプションが選択されている場合. これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「コスト出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっており、コストシミュレータに応じて再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

注意

出力特性の可能な丸めに上記の注意を参照してください。

タイプ | 名 | ユニット | データ型 | 必須 | 説明
コスト | 関係者への総コスト - 年X. | $ | 整数 | 偽 | 総所有コスト（TCO） ために 年 x、xが​​ある場合 各年の 評価を実行するときに指定しました。これは、コンポーネントのコストを含みまたは接続の 標準、サブコンポーネント またはサブ接続 (すなわち 子供）と任意の帰属するコストを削減できます。
コスト | 関係者への総コスト（ローカル） - 年X。 | $ | 整数 | 偽 | 所有権の「ローカル」費用 1年間 xここで、 xあります 各年の 評価を実行するときに指定しました。これはありません ではありませんコンポーネントのサブコンポーネントのコストを含みます または接続のサブ接続 (すなわち 子供）または起因するコスト。
コスト | （子供）の関係者への総コスト - 年X。 | $ | 整数 | 偽 | 所有権の「子どものコスト 1年間 x、xが​​ある場合 各年の 評価を実行するときに指定しました。この のみ コンポーネントのサブコンポーネントのコストを含みます または接続のサブ接続 (すなわち 子供）。
コスト | 関係者への総コスト（起因） - 年X。 | $ | 整数 | 偽 | 所有権の「帰属する」費用 1年間 x、xが​​ある場合 各年の 評価を実行するときに指定しました。この のみ 付け部品から任意起因する費用が含ま（これはもちろん、接続されているすべての接続から起因するコストを含んでいてもよいです）.

追加 接続のプロパティ

次の表は、 追加の TCO評価によって必要とされる接続プロパティ。 これらのプロパティは、（プロパティ入力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップ「コスト/パフォーマンスの入力」または単に「コスト入力」と。これらの「入力」プロパティとリポジトリへの様々な構造変化のいずれかに変更がコストになり、および/または 性能シミュレータ に示すように、再シミュレーションを必要とします 赤 上の シミュレーションツールバー .

タイプ | 名 | 既定値 | ユニット | データ型 | 必須 | 説明
コスト | 属性 | ソースに沈みます | [ソースをシンクに|ソースにシンク] | 検索/一覧 | 真 | 「もしシンクのソース「この接続 意志 持っています 持っています コストs起因 'に沿いました」 それ から ソースのコンポーネント シンク 成分。また、場合 "ソースに沈みます「この接続 意志 費用は、「一緒に」起因しています それ シンクコンポーネントからソースコンポーネントへ.
動作 | 関係 | サポート | [プロセス| ]サポートしています | 検索/一覧 | 偽 | 「サポート」の場合、この接続は「ソース」成分は、「シンク」コンポーネントによってサポートされていることを示しています。 さらに、いずれかの「サポート」または「プロセス」の場合、接続は自動的にそのコストは、ソース・コンポーネントにシンクコンポーネントから 'に沿って」起因持つように接続して選択されます。
コスト | % | 100.0 | % | 10進数 | 偽 | ソースコンポーネントに帰属されるシンク部品コストの割合を示します。 ％値を100％まで追加する必要はありません、それは単にスケーリングするために使われる「関係者への総コストを - 。次のx年」シンクコンポーネントのプロパティが（上記参照）には、ソースコンポーネントに起因しています。

アーキテクチャのプロパティ

次の表ではTCOの評価によって出力されるアーキテクチャのプロパティを示します。 これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「コスト出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっており、コストシミュレータに応じて再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

注意

出力特性の可能な丸めに上記の注意を参照してください。

タイプ | 名 | ユニット | データ型 | 必須 | 説明
コスト | 関係者への総コスト - 次のx年。 | $ | 整数 | 偽 | 次のx年間のアーキテクチャ全体のTCO（総所有コスト）。

次の表ではTCOの評価によって出力されるアーキテクチャのプロパティを示します計算ごとの年間コストのオプションが選択されている場合. これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「コスト出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっており、コストシミュレータに応じて再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

注意

出力特性の可能な丸めに上記の注意を参照してください。

タイプ | 名 | ユニット | データ型 | 必須 | 説明
コスト | 関係者への総コスト - 年X。 | $ | 整数 | 偽 | 総所有コスト（TCO） ために 全体のアーキテクチャ 1年間 x未来へ.


信頼性と可用性のシミュレーション

ナビゲーション：あなたのアーキテクチャをシミュレートする>シミュレーター>

信頼性と可用性のシミュレーション

コメントを送信 このトピックに関する。

バックグラウンド

信頼性評価者は、入力コンポーネントおよび接続を使用してアーキテクチャの信頼度を算出します。

コンポーネントとの直接接続では、信頼性が障害発生までの平均時間（MTBF）に基づいています。建築要素の信頼性を計算するのに必要な唯一の変数は次のとおりです。

· ザ・ MTBF（年）の値。

· ザ・ 修復するには時間平均（MTTR）（年）の障害。そして

· 信頼性の上にテストするために定義された期間。

信頼性の計算に使用される式は次のように与えられます：

信頼性= -e（-y×年齢）
ここで、yは1÷MTBFは=

コンポーネントと接続の可用性はMTBFとMTTRに基づいています。信頼性とは異なり、それはテストされている期間に影響されない、その有効性を注意してください。

可用性= MTBF /（MTBF + MTTR）

変換方法ながら 信頼性ブロック図最も正確な結果が得られる（簡単直列および並列構造を使用して）、これらの方法は非常になります イム実用的には、我々は、要素の数千人の巨大なネットワーク内のミッションのための信頼性を計算しようとします。さらに、これらの変革のアプローチは、このようなネットワーク「メッシュ」など、多くの一般的な構造のためにブレークダウン。

ザ・ モンテカルロこの方法は、任意のサイズと複雑さのシステムの信頼性と可用性を計算することができます。モンテカルロ法は、多くのシナリオをシミュレートします そしてfまたは各 シナリオ ランダム状態、 利用できます または 利用できません、各物理要素に割り当てられています。利用可能な状態にある指定された要素の確率は、部品の信頼性/可用性に基づいています。

例えば、90％の利用可能性を有する成分は、シナリオの約90％で使用可能であると予想することができます。間接的な接続の信頼性と可用性は、したがって、要素のパスが送信元から宛先への利用可能state-に存在するランダムscenarios-の割合として推定することができます。

注意

地元の信頼性と可用性の計算が、異なるパラメータと異なる式（従って異なる値が得られる）に基づいているので、それぞれの要素を割り当てることが必要です 二状態、可用性の一つ、および信頼性のための1つ。信頼度の計算は、各シナリオの信頼性の状態を使用するのに対し、可用性の計算は、それぞれのシナリオで利用可能状態を使用します。

信頼性評価者は、特定のアーキテクチャの信頼性を動作するように、モンテカルロシミュレーション技術を使用しています。アーキテクチャは、個々のシミュレーションの数千を通して置かれ、その結果、信頼性の指標を導出するために集計します。前述したように、モンテカルロは、大規模なネットワークをシミュレートするための最速の技術であり、任意の複合体（すなわち、メッシュ構造）構造で動作します。

評価者は、4つの値を出力します。

1。 ミッションの信頼性数年にわたり、

2。 可用性の アーキテクチャ;

3。 確実の ローカルコンポーネント数年にわたり、そして

4。 可用性の ローカルコンポーネント.

評価者は、確率をうまくいきます ザ・ 部品や接続作業（すなわち 失敗）および時間は、修理に取られていません。

どのMTBFsと基準 および/またはMTTRs 扱われます

要素（コンポーネントまたは接続）が割り当てられたMTBFと基準を持っている場合 および/またはMTTR 値は、これらの値は、ローカルの信頼性の計算に使用されています 可用性 直列接続として要素の。

例えば、成分 A、割り当てられた基準に B, C、 そして DそれぞれがMTBFを持っています そして、MTTR ローカル値、 確実 = R(A)× R(B) × R(C) × R(D)ここで、 R =コンポーネント/標準の（式を使用して）算出した信頼度 そして ローカル アベイル能力 = （A)× （B) × （C) × （D)ここで、 A =計算されました アベイル機能コンポーネント/規格（式を使用して）。要素三基準を持っている場合には、あります 各 MTBFと そして、MTTR 値s、また、MTBF そして、MTTR 値s要素のプロパティの、地元の信頼性 そして、avilability 標準の各々の一連の値と素子自体として与えられます。

別の例として、成分 A基準を割り当てています B, C、 そして Dしかし、唯一の標準 B標準ながら、MTBFとMTTR値の両方を持っています C唯一のMTBF値および標準を持っています DローカルのみMTTR値を有しており、 確実 = R（A）× R（B）× R（C）ここで、 R=コンポーネント/規格と地方の（式を使用して）算出した信頼度 可用性 = （A）× （B）× （C）ここで、 A=標準のみMTBF値を有するので、（C）を算出する（式を使用して）コンポーネント/規格が、で算出可用性it '検索'マッチングMTTR値（複数可）およびすべてのMTTRはそれがドンことを検出した値を追加します'この場合には、標準のMTTR値を使用するので、それ自体が一致するMTBF値を持つのt D。別の標準があった場合、言います E、ちょうどMTTR値を持つだけでなく、その後 （C）のMTBFを使用します CのMTTRで D そして E一緒に加えます。別の標準場合は、言います F、そしてちょうどMTBF値を持っていました （F）またのMTTRを使用します D そして E一緒に加えます。

ミッション信頼度を算出

地元の信頼度を算出することは簡単な数式を使用しての問題ですが、間接的な接続（ミッション）の計算は、我々はインターレースパス（接続）とコンポーネントの複雑かつ大規模なネットワークを持っている、特に後に、そう簡単ではありません。

アカウントにネットワーク全体を撮影

間接的な接続は物理的な接続を表すものではありませんように、我々は、ソース・コンポーネントがその宛先コンポーネントに得ることができる方法を見つける必要があります。そして、これは、ネットワーク全体を見て、すべての異なった方法（およびパス）私たちのソースコンポーネントが宛先コンポーネント（シンク）に到達するために取ることができますを意味します。

注意

限りがあるので、 少なくとも 1 コンプリートソースから宛先へのパス、ミッションは成功します間接接続が閉じられた接続と呼ばれています.

リンクマトリックスを理解します

何に接続されている部品/直接接続知るために、我々はすぐに二つのブロックが特定の方向に接続されているかどうかを確認するアーティファクトを必要としています。これは、リンク行列の関数です。要するに、リンクマトリックスは、特定の構成要素が直接、別のコンポーネントに到達できるかどうかを示すブール変数の二次元アレイです。そのサイズは、ネットワーク内のコンポーネントの合計数の二乗に等しいです。

シンプルな信頼性ブロック図（RBD）

信頼性ブロック図については、関連リンクマトリックス（RBD）

いないすべての接続が双方向（両方の方法を行く）であるので、それは正しくリンク行列の読み方を知っていることが重要です。信頼性評価では、最初の引数はソース、2番目の引数は、送信先（シンク）です。

リンク行列（A、B）がTrueの場合=したがって、それは、Aが（単方向）に直接Bに得ることができることを意味します。リンクマトリックス（B、A）が真=場合だけBはAに得ることができます。これが真である場合、これは、双方向接続を意味しています。

与えられた例では、 上記:

· ソース1は、（ソース1と宛先0がTrueの結果を与える）宛先0に到達することができます。そして

· 0と1の間のリンクが双方向であるように、ソース0は、（ソース0と宛先1がTrueの結果を与える）は、宛先1に到達することができます。

· ソース2は、光源1は、宛先2（ソース1と宛先2がTrueの結果を与える）に達することができる場合であっても（ソース2と宛先1がFalseの結果を与える）は、宛先1に到達することはできません。これは、1と2の間のリンクが単方向であることを意味しています。

信頼性ブロック図を理解します

信頼性ブロック図（RBD）は、ブロックおよびリンクの面で全体のオブジェクトモデルの構造をカプセル化します。すべてのブロックは、それらを接続するリンク/パスに係る故障や成功の可能性を持っている要素を表します。両方のコンポーネントとの接続は、RBDの「ブロック」になることができます。

例RBDブロックとリンク

図 上記のRBDの例を表しています。赤い点線は、1〜4のミッションのために2つだけの可能な経路があるか1。注への単一のミッション4を表します。

1に0から3までの経路4、および7 1に点線のブロック2への経路4を検討 5および6は、それらが考慮されていない1にミッション4の故障/非故障に影響を与えないため、無視されているブロックを表します。ほとんどのミッションのために特定のミッションの成功には影響しません冗長ブロックが多数存在しますので、これは重要です。冗長ブロックの数は、シミュレーション結果が不正確になりますそれによってこれは、大規模なネットワークでより明白です。

シミュレーション時間をスピードアップし、より正確な結果を確保するためには、全体のRBDから抽象化する必要があり、ミッションの成功に影響を与える要素のみを使用します。

注意

単一ルート/パスは二回、任意のコンポーネントを介して行くことはできません。

この段階で私達はリンクマトリックスを作成し、モンテカルロ・シミュレーションを実行することができます。

計算アーキテクチャの可用性

アーキテクチャの可用性は、すべての間接的な接続が任意の時点で利用可能になる確率です。各間接的な接続の可用性は、しかし、これらの間接的な接続は、（通常は）物理的要素の同じセットに依存して、モンテカルロシミュレーションの各反復中に決定されます。したがって、単純にこれらの個々の空室状況を集計すると、悲観的なアーキテクチャ全体の可用性を与え、これらの未利用可能性」をダブルカウント」だろう。また、全体的なアーキテクチャの可用性は、各反復を見て、興味の間接的な接続に関わる要素が利用可能であるかどうかを見て計算されます。そして、シミュレーションの最後にこれらの結果を集約します。

信頼性シミュレータの実行

信頼性の面であなたのアーキテクチャをシミュレートするために、

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 選択 分析| 確実.

3。 選択 アーキテクチャあなたは、プルダウンメニューから評価したいです。

注意

デフォルトでは、ABACUSは自動的に再シミュレーションは、任意の原資産や構造変化に起因して必要とされる最初のアーキテクチャを選択します.このハイライトは、に示されています 赤 上の シミュレーションツールバー .

4。 選択 コンポーネント そして 接続あなたからの評価を希望します 標準の要素の選択ウィンドウ 「ショーの直接接続」と「ショー・プロセスの接続]ダイアログの左下にあるラジオボタンフィルタを使用すると、あなたの選択を補助します。

追加 チェックボックスへ 標準の要素の選択ウィンドウ

· Saveの形質転換されたモデル 意志 現在のプロジェクトと同じフォルダにプロジェクトのRBD変換さ​​れたバージョンのコピーを保存し、プロジェクト名に「_transformed "を追加.この変換されたプロジェクトについて詳細にABACUSによって行わ信頼性シミュレーションを診断するために使用することができます。

追加の放射性ボタンへ 標準の要素の選択ウィンドウ

· 直接接続を表示します 自動的に接続を設定しますプロパティType =行動、名前=抽象化と価値=直接のプロパティフィルターを持っています.このオプションはデフォルトで選択され、上記、下記のように「直接」接続の選択を支援します。

· 表示プロセスの接続 自動的に接続がプロパティType =行動、名前=関係と値=プロセスのプロパティフィルターを持って設定します.上記および下記のように、このオプションは、「直接」接続の選択を助けます.

5。 クリック 次.

6。 選択してください ミッションあなたは、シミュレーションに含めるすなわち接続。

7。 設定 ランタイムスケールファクタ スライダー。

注意

値が大きいほど、より多くの統計的に一貫した結果が得られるが、計算に時間がかかります.

チェックボックス

· を表示 閉じられた接続 意志 のみ上記のRBDの選択に従って宛先コンポーネントにソースコンポーネントからの少なくとも1つの完全な物理パスを有するものが含まれるように、自動的に利用可能な接続をフィルタリングします。

· 間接接続を表示 自動的に接続を設定しますプロパティType =行動、名前=抽象化と価値=間接のプロパティフィルターを持っています.このオプションはデフォルトで選択され、上記、下記のように「間接的」またはミッションの接続の選択を支援されています.

ボタン

· すべてすべて選択 接続.

· インバートすべての現在選択されて選択解除 接続 そして、選択されな​​かったすべてのものを選択します。

· なしすべて選択解除 接続.

その他のオプション

· ランタイムスケールファクタ 以上でシミュレーション時間と精度を制御 値収率INGより統計的に一貫した結果が、 取ること 長い時間に ラン.

注意

ABACUSは、反復回数を計算するとき、それは完全に信頼できない最も信頼性の高い要素を決定しますシミュレートし、その要素をプラス1反復は、使用できなくにわたって実行時間スケールファクタ回1用にシミュレートします。または（MTBF + MTTR）/ MTTR *実行時間スケールファクタ+ 1これは、その要素がまだ少なくとも一度のシミュレーションで失敗したことを確認することです。 例えば。完全に信頼できない最も信頼性の高い要素が1万時間のMTBF（平均故障間隔）と8時間のMTTRを持っている場合、シミュレーションは（10,000 + 8）/ 8 = 1,251回の実行時間のスケールファクタは+ 1回の繰り返しになります.

· 控えシミュレートするために、年 以下のために計算されるミッションの信頼性のための年の数を決定.

· Nスレッドのアンバーデ処理スレッドの数は、モンテカルロシミュレーションに使用するtermines.このオプションは、全体的なシミュレーション時間を最小限にするために（ハイパースレッディングコアを含む）利用可能なCPU /コアの数と一致するようにデフォルト設定されます。

8。 クリック フィニッシュあなたが取得します 警告 ダイアログ。

9。 必要に応じてクリックして警告を探ります 詳細>>.

10。 クリック 持続する.

注意

この時点で、ABACUSが実行されます モンテカルロアーキテクチャのシミュレーションと短い時間の後（フィードバックのためのプログレスバーで）計算の完全なダイアログが表示されます。

11。 クリック [OK]シミュレーションを承認します。

先端

トレーニングコースと信頼性シミュレーションに関するさらなるヘルプについてを参照してください Avolutionコミュニティ .

コンポーネントと接続のプロパティ

次の表は、コンポーネントが一覧表示され、 '直接'接続プロパティは、信頼性を評価するために必要。 これらのプロパティは、（プロパティ入力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「信頼入力」。に示すように、これらの「入力」プロパティとリポジトリへの様々な構造変化のいずれかの変更は、再シミュレーションを必要とする信頼性シミュレータになります 赤 上の シミュレーションツールバー .

タイプ | 名 | 既定値 | ユニット | データ型 | 必須 | 説明
確実 | MTBF | ∞ | 年、週、日または時間 | 10進数 | 真 | 要素の障害が発生する前の平均時。注：値は、次のように'24 / 7を以下の「可用性の概念年、週、日または時間の単位で表すことができ、変換されます。 - 1年= 52週または365日もしくは8,760時間 - 1週間= 7日または168時間 - 1日= 24時間
確実 | MTTR | 0 | 年、週、日または時間 | 10進数 | 真 | 平均時要素の修復します。注：値は、次のように'24 / 7を以下の「可用性の概念年、週、日または時間の単位で表すことができ、変換されます。 - 1年= 52週または365日もしくは8,760時間 - 1週間= 7日または168時間 - 1日= 24時間

次の表は、コンポーネントが一覧表示され、 '直接' 信頼性評価による接続のプロパティを出力します。 これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「信頼出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっており、信頼性シミュレータは、に従って再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | ユニット | データ型 | 必須 | 説明
確実 | 信頼性 - X年 |  | 10進数 | 偽 | 要素は次のx年以内に故障しない確率。これは、0と1の間の値です。
確実 | 非信頼性 - X年 |  | 10進数 | 偽 | 要素は次のx年以内に失敗する確率。これは、0と1の間の値です。
確実 | 可用性 | % | 10進数 | 偽 | 部品や接続の計算された利用できます。これは、0％と100％の間の値です。
確実 | 使用できなくて | % | 10進数 | 偽 | 部品や接続の計算された使用できません。これは、0％と100％の間の値です。

次の表は、 '間接的な'信頼性評価による接続のプロパティを出力します。 これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「信頼出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっており、信頼性シミュレータは、に従って再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | ユニット | データ型 | 必須 | 説明
確実 | ミッション信頼性 - X年 |  | 10進数 | 偽 | 間接的な接続は、次のx年以内に故障しない確率。これは、0と1の間の値です。
確実 | ミッション非信頼性 - X年 |  | 10進数 | 偽 | 間接的な接続は、次のx年以内に失敗する確率。これは、0と1の間の値です。
確実 | 可用性 | % | 10進数 | 偽 | 間接的な接続の計算された利用できます。これは、0％と100％の間の値です。
確実 | 使用できなくて | % | 10進数 | 偽 | 間接的な接続の計算された使用できません。これは、0％と100％の間の値です。

アーキテクチャのプロパティ

次の表は、信頼性の評価者によるアーキテクチャのプロパティの出力を示しています。 これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「信頼出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、原資産またはリポジトリへの構造変化に時代遅れになっており、信頼性シミュレータは、に従って再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | ユニット | データ型 | 必須 | 説明
確実 | 可用性 | % | 10進数 | 偽 | 評価に含まれているすべての間接的な接続の可用性を提供します。すなわち、その確率であります すべて間接的な接続は、任意の時点で利用できるようになります。これは、0％と100％の間の値です。注意：これは、「ダブルカウント」であるように、これは、関連するコンポーネントのアンアベイラビリティ個々の接続可用性の乗算ではありません。
確実 | 使用できなくて | % | 10進数 | 偽 | 評価に含まれている間接的な接続が利用できません。すなわち、その確率であります 少なくても一つ間接的な接続は、特定の時点で使用できなくなります。これは、0％と100％の間の値です。注意：これは、「ダブルカウント」であるように、これは、関連するコンポーネントのアンアベイラビリティ個々の接続unavailabilitiesの乗算ではありません。
確実 | ミッション信頼性 - X年 |  | 10進数 | 偽 | 評価に含まれている間接的な接続のすべてが次の内失敗しないされる確率 x年。これは、0と1の間の値です。注：これは、関連するコンポーネントのアンアベイラビリティ「ダブルカウント」になります。このように、個々の接続信頼性の乗算ではありません。
確実 | ミッション非信頼性 - X年 |  | 10進数 | 偽 | 評価に含まれている間接的な接続の少なくとも一つは、次の範囲内に失敗する確率 x年。これは、0と1の間の値です。注：これは、関連するコンポーネントのアンアベイラビリティ「ダブルカウント」になります。このように、個々の接続unreliabilitiesの乗算ではありません。


シミュレーションオープン性

ナビゲーション：あなたのアーキテクチャをシミュレートする>シミュレーター>

シミュレーションオープン性

コメントを送信 このトピックに関する。

開放性シミュレータはアーキテクチャとその要素が「オープン」であり程度を決定し、それは、最小限の影響で部品の交換を処理するシステムの能力です。

開放性の面であなたのアーキテクチャをシミュレートするために、

1。 あなたが持っていることを確認 ABACUSファイル、あなたを含みます 人口アーキテクチャ, オープン.

2。 分析を選択します| オープン性.

3。 選択してください アーキテクチャ（複数可）あなたは、評価に含めます。

注意

デフォルトでは、ABACUSは自動的に再シミュレーションは、任意の原資産や構造変化に起因して必要とされる最初のアーキテクチャを選択します.このハイライトは、に示されています 赤 上の シミュレーションツールバー .

4。 クリック フィニッシュあなたが取得します 警告 ダイアログ。

5。 必要に応じてクリックして警告を探ります 詳細>>.

6。 クリック 持続する.

注意

この時点で、ABACUSは、アーキテクチャ（複数可）の構造評価を実行し、短い時間の後（フィードバックのためのプログレスバーで）計算の完全なダイアログが表示されます。

7。 クリック [OK]シミュレーションを承認します。

先端

トレーニングコースと開放性の評価に関するさらなるヘルプについてを参照してください Avolutionコミュニティ .

コンポーネントおよび接続標準プロパティ

次の表では、開放性を評価するために必要なコンポーネントとの接続標準のプロパティを示します。これらのプロパティは、（プロパティ入力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップ「オープン性の入力」と。に示すように、リポジトリ内のこれらの「入力」のいずれかのプロパティを変更すると、再シミュレーションを必要とするオープン性シミュレータになります 赤 上の シミュレーションツールバー .

タイプ | 名 | 既定値 | ユニット | データ型 | 必須 | 説明
オープン性 | 規格・標準の成熟度、組織レベル |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 責任標準化団体のレベル 0：/独自の組織 1：コンソーシアム/デファクト 2：ナショナル/ミリタリー 3： 国際
オープン性 | 規格・標準の成熟度、ステータス |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 承認レベルは、標準化団体で達成 0：ワーキング/委員会草案 1：公開草案/バロット 2：暫定ドラフト 3：承認
オープン性 | 規格・標準の成熟度、安定性 |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 標準は変更される可能性はありますか？ 0：廃止された標準 1：次の1〜2年に変更することは非常に対象 2：既存の機能に既知の変更/更新情報 3：非常に安定（2年以内に変更なし）
オープン性 | 規格・標準の成熟度・ベンダーサポート |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | ベンダーサポート 0：いいえ製品やベンダーが標準をサポートしていません 1：標準の一部を実装する1つまたは複数のベンダー 2：標準のすべての部分を実装した製品で複数のベンダー 3：標準のすべての部分を実装した製品であるベンダーよりも多くの
オープン性 | 規格・標準の明示 - ドキュメント |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 標準のドキュメントの品質 0：プア 1：フェア 2： 良い 3：エクセレント
オープン性 | 規格・標準の明示、標準幅 |  |  | 整数 | 偽 | 機能の数。 Sfの - 最も低いレベルの標準機能のカウント
オープン性 | 規格・標準の明示-SM |  | % | 10進数 | 偽 | 必須の特徴の総数の割合
オープン性 | 規格・標準の明示-SO |  | % | 10進数 | 偽 | オプションである特徴の総数の割合
オープン性 | 規格・標準の明示-SC |  | % | 10進数 | 偽 | 条件付きで定義されている機能の総数の割合
オープン性 | プロファイル - プロファイルドキュメント、ドキュメント |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 標準のドキュメントの品質 0： なし 1：プア 2：フェア 3：エクセレント
オープン性 | プロファイル - プロファイルドキュメント精度 |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | ドキュメントは、実際のシステム設計を反映していますか？プロファイル機能のどのようなレベルでは、システムで使用されていますか？ 0：いいえ機能しません 1：いくつかの機能 2：ほとんどの機能 3：すべての機能
オープン性 | プロファイル - プロファイルドキュメント、成熟度 |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | プロファイルは、成熟しており、利用できますか？ 0： このために 1：プロジェクトベース 2：組織 3： パブリック
オープン性 | プロファイル - プロファイルの明示 - 明示的な幅 |  |  | 整数 | 偽 | プロファイルに必要に応じて指定された標準的な機能の数
オープン性 | プロファイル - プロファイル明示-PM |  | % | 10進数 | 偽 | プロファイル内の必須機能の割合
オープン性 | プロファイル - プロファイルの明示 - ポー |  | % | 10進数 | 偽 | プロファイル内のオプション機能の割合
オープン性 | プロファイル - プロファイル明示-PC |  | % | 10進数 | 偽 | プロファイル内の条件付きで定義された機能の割合
オープン性 | プロファイル - プロファイルの明示性カバレッジ |  | % | 10進数 | 偽 | 標準的な機能の割合は、具体的には、プロファイルで対処
オープン性 | プロファイル - プロファイルの拡張機能、拡張幅 |  |  | 整数 | 偽 | プロファイルで指定された非標準的な機能の数
オープン性 | プロファイル - プロファイルの拡張機能カバレッジ |  | % | 10進数 | 偽 | プロファイルで詳述の拡張の割合
オープン性 | 製品・製品の可用性と製品の適合性、数 |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 標準の必須の機能をサポートする製品の数 0：いいえ製品は、標準をサポートしていません 1：1つまたは複数の製品は、標準の一部を実装します 2：複数の製品には、標準のすべての部分を実装 3：多くの複数の製品には、標準のすべての部分を実装
オープン性 | 製品・製品の可用性と適合性 - アプリケーションの適合 |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 製品が規格に準拠のどのレベルを持っていますか？ 0： なし 1：主張 2：実証 3：認定と実証
オープン性 | 製品・製品の可用性と適合性、適合品質 |  | [0 | 1 | 2 | 3] | 検索/一覧 | 偽 | 適合試験の品質 0： なし 1：製品開発者による社内テスト 2：独立テスト（例えば、NIST） 3：関連する製品の文脈において明らかに

コンポーネント、接続、およびアーキテクチャのプロパティ

次の表は、開放性の評価によってコンポーネント、接続、およびアーキテクチャの特性の出力を示しています。次のプロパティのすべてがゼロ（0）最も望ましくないという三（3）最も望ましいという、（0）ゼロ〜3個の（3）に評価されます。これらのプロパティは、（プロパティ出力行セレクタのアイコンが[プロパティ]ウィンドウに表示されます [image] ）ツールチップと「オープン性出力」。アイコン上の矢印が強調表示されます 赤 ( [image] ）これらの特性は、リポジトリへの根本的な性質の変化に古くなっていると開放性シミュレータは、に従って再シミュレーションを必要とする場合 赤 上で強調表示 シミュレーションツールバー .

タイプ | 名 | データ型 | 必須 | 説明
オープン性 | オープン性 | 10進数 | 偽 | アイテムの開放性の全体的な評価。
オープン性 | 規格標準の成熟度 | 10進数 | 偽 | 標準の現在の状態、それが使用されているどのくらいの期間、承認され、どれだけ受け入れられ、それは開発者のコ​​ミュニティ内でされているかどうかを反映しています。
オープン性 | 規格標準の明示 | 10進数 | 偽 | その後の基準の潜在的な曖昧さを反映した基準の明示、
オープン性 | プロファイル - プロファイルのドキュメント | 10進数 | 偽 | インターフェイスプロファイルドキュメントの程度が開発され、プロファイルのドキュメントは、実際のシステム設計を反映しているかどうか、および/または実装されたシステム
オープン性 | プロファイル - プロファイルの明示 | 10進数 | 偽 | プロファイル/プロファイル仕様で提供される詳細レベル
オープン性 | プロファイル - プロファイルの拡張 | 10進数 | 偽 | プロファイルは、それが基づいている規格に準拠する程度
オープン性 | 製品・製品の可用性と適合性 | 10進数 | 偽 | プロジェクトで利用するための利用可能なオープン標準に準拠した製品があるかどうか


標準レポート

ナビゲーション：あなたのアーキテクチャのレポート>

標準レポート

コメントを送信 このトピックに関する。

ABACUS」 標準 レポートは、あなたのアーキテクチャの一つ以上のコンポーネントとの接続のリストを取得することができます。報告書は、コンポーネントまたは階層、タイプ、標準、説明、プロパティとその添付ファイル内の接続の場所に関する情報を含む選択されたコンポーネントとの接続に関連するすべての情報が含まれています。

注意

レポートの内容 あります構成可能[レポートオプション]ダイアログは、以下に説明を通して、しかし、トンO作成方法に関する詳細な情報を検索します 完全に設定カスタム レポートABACUSカスタムレポートを使用して、、 お願いします トピックを参照してください。 ここに または 接触 Avolutionサポート .

表示します 標準 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ（S）.

2。 選択 インサート| 標準報告書またはをクリックします 標準レポートを作成します。 ツールバーのボタン。ザ・ レポートの設定ウィンドウが表示されます。

レポート設定ウィンドウ

3。 選択 アーキテクチャ, コンポーネント そして 接続あなたがからのレポートに含めること レポートの設定]ウィンドウ.標準要素の選択を参照してください ここに ヘルプのトピック。

4。 今をクリックしてください オプションボタンと レポートオプションウィンドウが表示されます。

レポートオプションウィンドウ

5。 あなたは、表示することができます 各要素の新しいページ、 印刷日付, 印刷時間, ページ番号そして、するかどうか ヘッダーにタイトルを含めます関連するチェックボックスをunticking /刻々と過ぎて、レポートの。また、編集して、タイトルと著者をカスタマイズすることができます レポートタイトル そして 著者 テキストボックス。また、下のチェックボックスをunticking /カチカチして、レポートに表示されているどのようなコンテンツを選択することができ レポートの内容ウィンドウのセクション。あなたが完了したらをクリック [OK].

6。 今すぐにクリック フィニッシュレポート設定ウィンドウに表示されます。

表示可能なレポートを解釈するために、

簡単な説明と例生成されたレポート

レポートのページ間を移動するには、アイコンをクリックしてください [image] 画面の左上隅のツールバーにあります。

注意

あなたはできる セーブ レポート 様々なフォーマットに クリックして エクスポート レポートアイコン [image] 位置して に ツールバー。あなたは、次の形式でエクスポートすることができます。 秀でます, PDF そして ワード。後で使用するために、目的の場所にレポートを保存してください。変更は後の段階でのアーキテクチャに行われた場合、新しいレポートには、変更を反映するために作成する必要があります。

参照してください

あなたのアーキテクチャを分析します


カスタムレポート

ナビゲーション：あなたのアーキテクチャのレポート>

カスタムレポート

コメントを送信 このトピックに関する。

ABACUS「カスタムレポートを使用すると、完全に設定カスタムレポートを作成することができます。レポートでは、カスタムイメージやグラフィックだけでなく、すべてのコンポーネント、接続を詳述するか（TCO、パフォーマンスと信頼性を含む）の様々なシミュレーションからABACUSリポジトリだけでなく、詳細な分析結果から属性を含めることができます。さらに、報告書は、図、表、カタログ、行列/ピボットテーブル、マップ、ゲージ、スパークライン、データバーと指標（例えばトラフィックライトを含めることができます).

注意

すべてのユーザーが既存のカスタムレポートを開くことができますが、トンOの設定 レポート ユーザーライセンスが必要 レポートの設定 能力。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

表示します カスタム 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ（S）.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポートウィンドウが表示されます。

カスタムレポート ウィンドウ

3。 選択既存の 報告するあなたがしたいこと 表示します から 利用可能なレポート セクション。

4。 クリック レポートの実行.レポートには、Microsoftレポートビューアとtで開きますOアイコンをクリックして、レポートのページを移動 [image] 画面の左上隅のツールバーにあります。

注意

あなたはできる セーブ レポート 様々なフォーマットに クリックして エクスポート レポートアイコン [image] 位置して に ツールバー。あなたは、次の形式でエクスポートすることができます。 秀でます, PDF そして ワード。後で使用するために、目的の場所にレポートを保存してください。変更は後の段階でのアーキテクチャに行われた場合、新しいレポートには、変更を反映するために作成する必要があります。

に に送られ、リポジトリデータを編集 a カスタム 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ（S）.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポート ウィンドウ （上図） 表示されます.

注意

すべてのユーザーが既存のカスタムレポートを開くことができますが、トンOの設定 カスタムレポートに送信されるデータ ユーザーライセンスが必要 レポートの設定 能力。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

3。 選択既存の 報告するあなたがしたいこと 表示します から 利用可能なレポート セクション。

4。 クリック 編集データセット. ザ・ データセットエディタウィンドウが表示されます。このウィンドウには、現在のカスタムレポートに送信されているデータセットの集合を示します。以下の例では3つ（3）があります。

· （その基準のプロパティと接続されているすべてのコンポーネントを含む）「2015年実績」アーキテクチャ内のすべてのアプリケーションコンポーネントのすべての詳細を指定されたApplicationProxyデータセット、

· 名前が一致した一つ以上のダイアグラムを指定されたTwoDViewProxyデータセット 'アプリケーション風景（オーストラリア）'、

· （付け部品を含む）「2015年実績」アーキテクチャのすべてのターゲット接続のすべての詳細を指定されたTargetProxyデータセット。

データセットエディタ ウィンドウ

注意

クエリ名は、Microsoftレポートビルダ（下記参照）でデータセット名に使用されます。含めるフィールドデータセットは、すべてのコンポーネントタイプ、すべての接続タイプ、一つ以上のアーキテクチャ、一つ以上のダイアグラムまたは1つ以上のチャート単一の要素、要素のコレクションのいずれかであるかどうかを指定します。データ '要素のコレクション」は、[フィルタ]ボタンをクリックしたときには、エレメントを使用して、特定のアーキテクチャから、および/または特定の種類の、および/または特定の基準に要素だけを返すように複数のフィルタを適用することを可能にするウィンドウをフィルター開きが提供される設定について、および/または特定のコンポーネントに接続されている、および/または特定の両親と、および/または特定のダイアグラムで、および/または特定のチャートでのおよび/または特定のプロパティ値を持ちます。他のデータ・セット・タイプの名前のフィールドが提供され、あなたがデータセットに含まれるように、オブジェクト（複数可）を選択することができます[選択]ボタンを使用しています。

注意

データ・セットは中に格納されていますデータ（ファイルを設定します。XML)同じベースファイル名を持つように AN関連しました レポート定義ファイル（。RDL)。このファイルが存在しない場合は、データ・セット・エディタが自動的に存在する任意のクエリ名に移入されます レポート定義ファイル（。RDL)そして、新しいです データ（ファイルを設定します。XML)クエリのAA有効なリストが定義されると作成されます。

3。 既存のデータセットを削除したい場合は、選択 クエリの削除 ボタン。

4。 あなたは、新しいデータセットを追加したい場合はをクリックします 新しいデータセットを追加上記の注意事項に従って設定されたデータをボタンと設定します。

に 新しいカスタムを作成します 報告する（テンプレートから）

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポート ウィンドウ （上図） 表示されます.

3。 クリック 新しい そして、のどちらかを選択 A4 - ポートレート, A4-風景, A3 - ポートレート, A3-風景, 米国の手紙 - ポートレート, 米国の手紙 - 風景, 米タブロイド - ポートレートまたは 米タブロイド - 風景希望されるレポートの向きと用紙サイズによって異なります。

4。 レポート定義ファイル（の.rdl / .rdlc）と一致するデータセットファイル（.xmlファイル）を保存する場所を参照し、クリック セーブ。これは、カスタムレポート]ウィンドウの[使用可能なレポート]セクションに新しいカスタムレポートを追加し、それが開かれるか、上記のように編集することができます。

に 既存のカスタムを追加します 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポート ウィンドウ （上図） 表示されます.

3。 クリック 追加 そして、（の.rdl / .rdlc）レポート定義ファイルの場所を参照し、クリック オープン。これは、カスタムレポート]ウィンドウの[使用可能なレポート]セクションに新しいカスタムレポートを追加し、それが開かれるか、上記のように編集することができます。

注意

これは、一致するデータセットファイル（.xmlファイル）がレポート定義ファイルと同じ場所に存在することを想定しています。

に 既存のカスタムをコピーします 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポート ウィンドウ （上図） 表示されます.

3。 選択既存の 報告するあなたがしたいこと コピーします から 利用可能なレポート セクション。

4。 クリック コピー そして、（ 'のコピー...'という名前の）選択された報告書の写しは、カスタムレポート]ウィンドウの[使用可能なレポート]セクションに追加され、上記のように、それを開いたり、編集することができます。

注意

これにより、レポートのコピーを作成します。 レポート定義 ファイル （の.rdl / .rdlc） ならびにその 一致するデータセットファイル（.xmlファイル）（存在する場合）。

に 既存のカスタムを削除 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポート ウィンドウ （上図） 表示されます.

3。 選択既存の 報告するあなたがしたいこと 削除する から 利用可能なレポートセクションとクリック 削除.

注意

レポートを削除すると、それはもはや、レポートリストに表示されません。しかし、これは削除されません レポートのレポート定義 ファイル （の.rdl / .rdlc） または データセット ファイル（.xmlファイル）。必要であれば、これらのファイルを削除すると、ファイルシステムを介して達成することができます。

に 既存のカスタムの名前を変更します 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポート ウィンドウ （上図） 表示されます.

3。 選択既存の 報告するあなたがしたいこと で名前を変更します ザ・ 利用可能なレポートセクションとクリック 名前の変更.

4。 レポートの新しい名前を入力します。

注意

レポート定義ファイル（の.rdl / .rdlc）と一致するデータセットファイル（.xmlファイル）の両方がそれに応じて変更されます.

に のデザインを編集 カスタム 報告する

1。 あなたが持っていることを確認 ABACUSファイルオープン あなたを含みます 人口アーキテクチャ.

2。 選択 インサート| カスタムレポートまたはをクリックします カスタムレポートを作成します。 ツールバーのボタン。ザ・ カスタムレポート ウィンドウ （上図） 表示されます.

注意

すべてのユーザーが既存のカスタムレポートを開くことができますが、トンOの設定 カスタムレポートのデザイン ユーザーライセンスが必要 レポートの設定 能力。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。さらに、Microsoftレポートビルダ3.0は、レポートを設計するために必要とされ、それはから無料でダウンロードすることができます ここに .

3。 選択既存の 報告するあなたがしたいこと 表示します から 利用可能なレポート セクション。

4。 クリック [レポートの編集.レポートには、Microsoftレポートビルダー3.0で開きます。特定のヘルプと以下のセクションを参照してくださいレポートをデザインで、より一般的なタスクのいくつかのいくつかの 'のTips＆Tricks」について。レポートの設計に関する一般的なヘルプについて ご参照ください マイクロソフトレポートビルダー3.0ヘルプページへ ここに .

あなたのレポートにテーブルを追加します

1。 あなたが持っていることを確認 ABACUSカスタムレポート定義ファイル（の.rdl / .rdlc）は、Microsoftレポートビルダー3.0で開きました。

2。 選択ザ・ インサート その後、上部の「リボン」のタブ、 クリック 表 ボタンデータ領域のセクションを選択で 表の挿入.

3。 今 カーソルをドラッグします配置には、テーブルの左上隅をレポートキャンバス上の位置へ。 キャンバスをクリックしてください。デフォルトでは、テーブルには、ヘッダー行と、その後詳細グループ（グループがレポートデータセットのビューを整理するために使用されている）で追加されます。グループを削除する、のいずれかの行を削除したり、グループ化ツールバーの行グループを削除します。

先端s

数式は/表のセル内の式は<< Exprに>>テキストを右クリックして[式]を選択し、セルを選択して編集しています...。 [プロパティ]パネルで> SortExpressionsフィールドと式を入力 - テーブルの行をソートするテーブルを選択し、その他までブラウズすることによって行われます。テーブルの最後に合計の行の後に（外部）の行を追加し、グループ化して、次の式を使用 = SUM（フィールド！名。値）ここで 'name'が集計されている分野です。列がbackgroundColorプロパティで「IIF 'ステートメントを使用するために着色を適用します。テーブル内のセルのようにゲージを追加するには、最初のセルにゲージを挿入して、ゲージに必要なデータフィールドをドロップします。高さ＆テーブル行の幅を編集する場合は、正しい行を選択を確認し、あなたがして、サイ​​ズ変更、アップ/ダウンカーソルの矢印を取得するまで、灰色の線の周りにあなたのマウスカーソルを合わせます。

レポートにチャートを追加します

1。 あなたが持っていることを確認 ABACUSカスタムレポート定義ファイル（の.rdl / .rdlc）は、Microsoftレポートビルダー3.0で開いて.

2。 選択ザ・ インサート その後、上部の「リボン」のタブ、 クリック チャート ボタンデータ領域のセクションを選択で グラフを挿入.

3。 今 カーソルをドラッグしますあなたが置かに、チャートの左上隅をレポートキャンバス上の位置へ。 キャンバスをクリックしてください その後 グラフを選択あなたは、オプションとクリックしてから必要 [OK].

先端s

チャート上の注釈としての特性を表示するには、右図をクリックして、表示​​データラベルを選択し、[追加されたラベルの1つを選択し、その他設定 - （[プロパティ]パネルでFalseに> UseValueAsLabelを、式を追加する例=その他のフィールドがName.value）！ - >ラベル。具体的にするための バブルチャート;バブルチャートは散布図の見出しの下に表示されます。シリーズフィールドにX軸プロパティをドロップ（または系列のプロパティに追加します）。データフィールドにY軸プロパティをドロップ（または系列のプロパティに追加します）。気泡の大きさを定義するためにプロパティを使用するには、データフィールドにこれをドロップ（または系列のプロパティに追加します）。バブルチャートは、あまりにも多くのデータ（200 +アイテム）がある場合に表示することができない、時々これは表示されないようにレポート全体を引き起こします。マーカータイプ - 円に設定します。データフィールドにフィールドをドロップすると、デフォルトで、それはそれらを追加します 和（）式なので、これを削除してください。具体的にするための 積み上げグラフ/タイムライン/ガントチャート;ガントチャートの場合、範囲チャートを使用して、データフィールドで高い値と低い値などのプロパティを追加します。あなたがいずれかの低値が別のために高い値と一致し、より多くの範囲を追加することで、複数の「バー」を、持つことができます。具体的にするための 円グラフ;集計円グラフの場合は、式を追加し、カテゴリフィールドに及びデータフィールドのデータをドロップ = COUNTROWS（）。 （コスト・チャート上などで）任意の0の値を除外、そうでなければこれらのラベルは依然としてチャートに表示されます。

IIFステートメントを使用すると、表やグラフに色を追加します

1。 あなたが持っていることを確認 ABACUSカスタムレポート定義ファイル（の.rdl / .rdlc）は、Microsoftレポートビルダー3.0で開いて.

2。 色のテーブルとクリックでセルを右クリック テキストボックスのプロパティ.

3。 選択 塗りつぶし クリックします FXBackgroundColorをフィールドの表現塗りのカラーラベルの右側にあるとセットでボタンが式を入力し、例えば = IIF（フィールド！InformationStatus.Value =「ライトグリーン」は、IIFは、（フィールドが！InformationStatus.Valueは= "再設計" "保持"、 "黄"、IIF（フィールド！InformationStatus.Value = "リフレッシュ"、 "オレンジ"、 "鮭"）））。これは、ステータス「再設計」を含む各セルのための黄色、ステータスが「保持」を含むセルごとにライトグリーンに背景色を変更すると、ステータス「更新」や他のステータス値が含まれている各セルのオレンジ色は着色されます「サーモン」インチ

注意

色はグラフの系列を選択し、外観を設定することにより、チャートのために添加することができる - > Col​​orプロパティ（またはバブルのためのチャートの外観を - >マーカー - > Col​​orプロパティ）は、上記の例と同様の表現に。

カスタムレポートを設計するとき心に留め地図

· あなたが（別またはソートによる除算つの性質のような）彼らと任意の「表現」を行いたい場合はInteger型を除くすべてのプロパティは、レポートビューアにABACUSから文字列として送信されるため、バックグラウンドの小数点や日付などに変換する必要があります、 この記事 良いリファレンスです。 例えば。 = CDate関数（フィールド！LifecycleEndDate.Value） 注意： 変換が失敗します（後述のように）それは、デフォルトでは、mm / dd / yyyy形式を期待として、DD / MM / YYYYを受け入れるために、レポート言語は専用バスGBに設定されていることを確認し、それに応じて31/7/2011ください。 =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency（フィールド！CostTotalCosttoOwnnext5years.Value、0）

· あなたが苦労しているにことが判明した場合 1つのページに表やグラフのすべてを保ちます、あなたのドキュメント空間を管理するためのいくつかの主要な方法があります。

· 改ページ - このテーブルの設定は、あなたが同じページ上にあるとする各テーブルに対してオフになっていることを確認してください。

· まとめて - このテーブルの設定は、あなたが同じページ上にあるとする各テーブルについても同様であることを確認してください。

· 周りのものを移動するときは、そのページの右下にあるコントロールを使用して、マルチアイテムを選択してドラッグをズームアウトする方が簡単です

· テーブル内の画像行については、「サイズ」ことを確認してください| 「サイジング」プロパティは、そうでない場合は、画像が大きく表示されることがあり「フィット」に設定されている、またはそれがひどく引き伸ばされます。

· に 各ページにテーブルのヘッダ行を繰り返しますレポートの：

1。 グループ化ペインで開く詳細モード。 （列グループの右側にある矢印をクリックし、[詳細モード]を選択します。）

2。 行グループ領域（列ではないグループ）で、Tablixの中で対応するテキストボックスを強調表示し、静的グループ、クリックしてください。それは左端の列ヘッダーを強調表示されるまで、各静的グループをクリックしていきます。これは一般的にリストされた最初の静的グループです。

3。 [プロパティ]ウィンドウで、TrueにRepeatOnNewPageプロパティを設定します。

4。 KeepWithGroupプロパティが後に設定されていることを確認します。

· 変更 言語設定あなたが必要とするデータの形式に合わせて、レポートのプロパティで、例えばエンGB英国の日付形式（DD / MM / YYYY）を生成します。

参照してください

あなたのアーキテクチャを分析します


Webに公開

ナビゲーション：あなたのアーキテクチャのレポート>

Webに公開

コメントを送信 このトピックに関する。

ABACUSは、「ウェブ機能に公開建築モデルは安全なウェブサイトで見ることができます。アーキテクチャは、HTML形式にエクスポートされ、ABACUSでエクスプローラのルックアンドフィールを反映するように設計されています。 カタログ、ダイアグラムを含むビュー（、 3D そして、チャート） また、インターネットブラウザを使用して閲覧可能な形式にエクスポートされます。

注意

現在、視点と行列が公開されていません.

ウェブにあなたの建築模型を公開するには

1。 あなたは関連があることを確認してください ABACUSファイルオープン含みます 人口アーキテクチャあなたがウェブに公開すること。

2。 選択 ファイル| 公開....

3。 ザ・ Web設定に公開ウィンドウが表示されます。

Web設定に公開

4。 デフォルトでは、モデルのすべての部分は、ツリービューなど、選択されています スタンダード、タイプ、テンプレートおよびアーキテクチャ（複数可）。あなたはアーキテクチャ（複数可）内の任意の個々のビューを含む、ウェブに公開したくない部分のチェックを外します。

先端

あなたが特定のコンポーネント、接続、および/またはそのプロパティを非表示にする場合には、管理者が使用して「公共の役割を作成することをお勧めします ABACUS「役割ベースのアクセス機能 次にそれらのコンポーネントタイプ、接続タイプおよび/またはそれらが公開されることはしたくないプロパティから読み取りアクセス許可を削除します。その後、ユーザーはその役割でログインし、役割のみに設定されたアクセス権を読んでいる要素を公開しますABACUSなど、Webに公開する必要があります。記載されているようにさらに、ユーザーがコマンドラインから自動公開することができます ここに .

注意

あなたはをクリックして表示されたすべての部分を選択することができます。 すべてボタンまたはをクリックして選択を反転 インバート ボタン。また、上でクリックすることができます なしあなたの選択を解除するためのボタン。

注意

もしあなた ツリービューのオプションをオフにその後、何の木枠（下記参照）は公開されません。したがって、 あなたは、以下のステップ6かに応じて、スタートページを選択する必要があります 公開後には、トップレベルのいずれかをカスタマイズする必要があります。 A） index.htmlを「フレームSRC = "mainPage.html"名前= "element_details" '行を変更することにより、ファイルが直接、または、b）は、コンテンツフォルダの下に関連するHTMLページにリンクします mainPage.htmlハイパーリンクを提供することによって、またはContentフォルダの下に関連するHTMLページにリダイレクトします。

5。 クリック オプション ボタンと次の 出版社のオプションダイアログが表示されます。

パブリッシュERオプション

6。 S3Dを選出、 ダイアグラムそして、チャート形式 そして、タイトル、説明、またはプロパティを表示するかどうか 利用可能なオプションのうちビューに（様々な形式のコメントについては、以下のノートを参照してください）​​。

7。 あなたが特定のビューに発行されたモデルの開始ページを設定したい場合は、チェック スタートページにビューを使用オプションと有効になる「...」ボタンを経由してビューを参照します。

注意

ステップ4通りエリアのセクションで選択したビューは、上記の開始ページとして設定することが可能です.

8。 あなたが公表されたモデル内の特定のページに関するフィードバックを受け取りたい場合は、確認してください メールフィードバックオプションが選択されています, に電子メールアドレスを入力してください 電子メールアドレス テキストボックスおよび編集 メールの本文適切なセクション。あなたはチェックをはずした後のフィードバックを送信しているしたくない場合 メールフィードバックオプションと空のテキストボックスのままにしておきます。

9。 クリックします [OK] ボタン。

10。 クリックします ブラウズ ボタン。

11。 ザ・ フォルダの参照ウィンドウが表示されます。

12。 あなたはトップレベルのHTMLファイル（および自動的に生成されたファイル）を保存する場所を選択します。

注意

これは、使用して（典型的には、「公開」と呼ばれる）は、特定のフォルダを作成することをお勧めです 新しいフォルダを作成しますトップレベルのHTMLファイルと任意の自動的に生成されたファイルを保存するダイアログ下部のボタンを押します。

13。 クリックします [OK] ボタン。

14。 フォルダパスは、で表示されます ディレクトリ テキストボックス。

15。 クリックします フィニッシュ ボタン。

- または -

15。 フォルダのパスを入力してください ディレクトリあなたはトップレベルのHTMLファイル（および自動的に生成されたファイル）を保存するテキストボックス。

16。 クリックします フィニッシュ ボタン。

注意

のエクスポート ダイアグラムコンピュータのメモリが不足しているときに非常に時折、ほとんどの場合、失敗した（通常は非常に大きなファイルを使用する場合）。失敗したエクスポートは一度再試行されます。再試行が失敗した場合失敗した最初の試み、および第2の警告のために1の警告があります。したがって、場合にのみ警告が公開に成功した、ものを「初期の試みは失敗しました」されています。再試行が失敗した場合、あなたのファイルの小さい部分を公開しようとか、いくつかのシステムメモリを解放。

保存されたHTMLファイル（複数可）は、現在の場所からの眺めや安全なウェブサイトにコピーすることができます。

Internet ExplorerでWebに公開10

どれか ハイパーリンク 元のモデルで作成された公開されたモデルに永続化され、（それが公開されている場合）のリンクをクリックすると、その宛先へのリンクに従います。また、すでに元のモデルにハイパーリンクされていない公開された図のいずれかの要素は、（それが公開された場合）ツリービュー内の対応する要素にフォーカスがに戻ってジャンプします公開された図の要素をクリックして戻ってハイパーリンクによってされますツリー内の該当する場所。この機能は、「エクスプローラで表示」ABACUSの右クリック機能に似ています。

注意

Avolutionは強く、次のソフトウェアとファイルフォーマットは完全にABACUSでWeb機能に公開を利用するために使用する必要がありますお勧めします。

1。 インターネットエクスプローラ （80.0以上）公開されたエクスプローラビューを表示します。 Mozilla Firefoxの（30.0またはそれ以降）また、推奨されており、完全にサポートされていますFirefoxの9の後、図の推奨SVG形式を使用している場合、しかし、あなただけ残念ながらズームやパンを許可しないネイティブSVGビューアのサポートを使用することができます.

2。 アドビのSVGビューア 3.0 接続する （からダウンロード ここに ) そして SVG公開されたのファイル形式 図。ためのSVG画像フォーマット 図のでお勧めします。 SVGはベクターベースの画像フォーマットであるため、それは「ロスレス」であり、他のいずれかの形式よりも、任意のズームレベルではるかに良く見える、SVGは、MS Visioの、SVGにインポートすることができる任意のレベルまたは解像度にズームすることができます、SVGは接続（だけでなく、コンポーネント）のために戻って、ツリービューへのリンクがあり、SVGは常にSVGは他のフォーマットの約半分のファイルサイズで、優れた解像度で印刷し、。それは、ビューの透明性が失われ、ダイアグラム上で接続をクリックすると、ツリーに戻って該当箇所にジャンプしません特定のズームレベルでのラスター化フォーマットであるとしてPNGは、しかし、次の推奨事項です。 BMPは、「損失のない」フォーマットファイルサイズは他のフォーマットと20Mbの画像のことを珍しいことではないされている100倍されている間のようにお勧めします。

SVGとトレードオフSVGビューアをインストールする必要がありますし、あなたがする必要があるということです .SVG画像/ SVG + XMLは、WebサーバーのMIMEタイプを追加されていることを確認してください. SVGビューアをインストールした後のMicrosoft Internet Explorerは、視聴者のライセンス契約を受け入れるように求められますし、それが正常に動作する必要があります。そして、一方でMozilla Firefoxのは、Adobeのプラグインがまだ推奨され、ネイティブSVGファイルをサポートしていますあなたは、Firefox 8またはそれ以前のバージョンを使用している場合は、図を拡大表示できるようにします（Firefoxの9を使用している場合は、ネイティブSVGビューアを無効にすることはできません）。アドビのプラグインのインストールが実行された後、以下のステップが必要とされているFirefoxでそれを使用します：

· Firefoxのを開き、入力してください "について：設定"（引用符なし）URLバーに。

· スクロールダウンして、プロパティを見つけるsvg.enabled（あなたは、Firefox 9を使用している場合は、ネイティブSVGの表示を無効にすることができず、このプロパティが存在しません）。それを無効にするには、それをダブルクリックします。

· 今すぐ検索 SVGプラグインがインストールされているディレクトリ（例：C：\ Program Files \ Commonファイル\のAdobe \ SVGビューア 30.0 \）

· ファイルをコピーしNPSVG3.dllファイルおよび ザ・ NPSVG3.zipファイルとFirefoxのプラグインディレクトリに貼り付けます（例： C：\プログラムファイル\ Mozilla Firefoxの\プラグイン）

· Firefoxのすべてのインスタンスを閉じます

3。 AvolutionのABACUS 3Dビューア（3.1以上） そして Avolutionの.abacus3D公開された3Dビューのファイル形式。一方 コルトーナVRML Clientプラグイン（2.0以上）それは商業的な使用のために自由ではなく、まだクライアント側のインストールを必要とする公開されたビューのVRMLのバージョンを表示することが可能です。 ABACUS 3D Viewerは、より豊富な機能を備えた任意のVRMLビューワよりもとから無料でダウンロードすることが可能です ここに 。いずれの場合も、あなたを確認してください WebサーバーのMIMEタイプに.vrml X-世界/ X-VRMLと.abacus3dアプリケーション/ octet-streamのを追加.

4。 PNG公開されたチャート・ビューのファイル形式。それはラスター化フォーマットであり、「損失」はあるもののので、チャート・ビューのPNG画像形式が推奨されるトレードオフのファイルサイズとチャートの明瞭度との間には、一般的に最高です。 BMPは、それが「損失のない」ファイルのサイズが他のフォーマットと2Mbのチャートでは珍しいことではないであることを20倍でフォーマットされているようお勧めします。

あなたがWebページのルック・アンド・フィールを変更したい場合は、mainPage.htmlという名前の開始ページ・ファイルとabacus.cssという名前のスタイルシートファイルを編集することができます。あなたはトップレベルのHTMLファイルを保存するために選択したのと同じフォルダにこれらのファイルを検索します。公開された出力の構造とテーラリングの詳細については、次のセクションを参照してください。

ABACUSの構造は、モデルを発表

次のようにABACUS発行されたモデルは、構造化されています。

1。 最上位のフォルダは、それが含まれるダイアログWeb設定に公開ABACUSに含まれているすべてのオプションを想定したいくつかのファイルとが含まれています インデックス。HTMLファイルは、3つのフレームから構成される。 treeView.html, findNode.html そして mainPage.html その後 shortcutError.html ページ。 treeView.htmlはによって移入されます tree.js, tree_items.js そして tree_tpl.js 含まれるフォルダの下にJavaScriptファイルは、（後述します） そして、ABACUSからExplorerツリーを複製します。 findNode.htmlはによって供給されていますザ・ find.js JavaScriptのファイルが含まフォルダ（後述）の下に位置しており、それ 木の枝だけではなく、目に見えるノードを検索します。 T彼mainPage.htmlは、会社のロゴなどを調整することができる静的なHTMLページです公開時にスタートページが選択されな​​い限り表示されます.そして最後に、shortcutError.htmlページが公開されていない適切なページのために木から壊れたショートカットのランディングページです。

先端

次の方法で完全にmainPage.htmlをスキップすることができます スタートページを使用するように選択する際に公開または 最初のアーキテクチャの最初のビューを直接指定するフレームSRC = "mainPage.html"行、一般的に「フレームワーク」の図を編集して、特定のビュー（例えば）を直接指すようにindex.htmlファイルを変更します。

2。 トップレベルIncludeフォルダが含まれていますINGさまざまな 公開されたモデル全体の.htmlファイルで使用されるJavaScriptの（.jsファイル）およびカスケーディングスタイルシート（.css）ファイル.

3。 トップレベルのコンテンツフォルダが含まれていますアルファベット順;

· A '3D ビュー' のフォルダ番号付きHTMLページと公開された3Dビューのそれぞれについて、VRMLやabacus3dファイル。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· アン アーキテクチャ 出版されたアーキテクチャごとに番号のHTMLページとフォルダ。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A カタログ 公開されたカタログのそれぞれに番号HTMLページを含むフォルダ。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A チャート のフォルダ番号付きHTMLページと公開されたチャートビューのそれぞれについて、PNG、JPGなどのファイル。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A コンポーネント フォルダ含みます番号付き公開された構成要素のそれぞれのHTMLページ。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A 接続 フォルダ含みます番号付き公開された接続のそれぞれのためのHTMLページ。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A ダイアグラム フォルダ含みます番号付きHTMLページおよび公開のそれぞれについて、PNG、SVGなどのファイル 図。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· アン アイコン サブフォルダ ととも​​に 公開されたモデル全体で使用される様々な画像.

· A スタンダード とサブフォルダ番号付き任意のためのHTMLページ スタンダードそれが発表されました。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A テンプレート サブ-フォルダ プロジェクトから発表された各テンプレートの番号のサブフォルダのコレクションを持ちます。各サブフォルダ内のコンポーネントと接続フォルダであり、これらの内の各構成要素とテンプレートを接続するための番号のHTMLページです。 フォルダ/ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A タイプ コンポーネントとサブフォルダ そしてとの接続のサブフォルダ番号付き任意のコンポーネント用のHTMLページ そして発表された接続タイプ制約のそれぞれについてHTMLページを含むプロジェクトから発表された各タイプの番号のサブフォルダのコレクション. フォルダ/ファイルの番号付け方式の詳細については、下記の注を参照してください。

· A 見ますポイントs サブフォルダおよびA番号付きビューのいずれかのHTMLページポイント発表されたの。 ファイルの番号付け方式の詳細については、下記の注を参照してください。

注意

HTMLページの番号（と ある場合には 画像ファイル）と一致 ユニーク ID た各リポジトリオブジェクトについて ときに設定 そうだった 作成ABACUS（EEIDsと呼ばれる）内。このIDはそれほど変わりません として 図、タイプ コンポーネント 等 あります 更新しました 彼ら 意志以前と同じIDを保持します。すべての場合には、関連します リポジトリ・オブジェクト名前は ... のHTMLタグ間のHTMLページの先頭近くで発見することができます。

IISで特定のページ/ビューへのアクセスの制限

発行されたモデルのためのWebサーバーとしてIISを使用する場合は、以下の方法を利用して特定のページ/ビューへのアクセスを制限することができる場合があります

1。 IISのウェブサイト（あなたがに干渉したくない既存のものがある場合は別のもの）を作成します。

2。 プロパティ - > [ディレクトリセキュリティ] - > [匿名アクセスの変更 - チェックを外し匿名アクセスをし、認証済みアクセスを使用しています。

3。 これは普通、サーバが無ドメイン合併症などである場合には、注意しながら（あなたは、認証などのサーバー・マシンのローカルユーザー/ログインを使用する「統合Windows認証」オプションを使用する必要があり、ちょうどローカルコンピュータにユーザーを追加あなたが）等、例えば、マシンに新しいユーザーを追加するリモートアクセスは、マシンのセットアップであるか​​どうかに応じての、賢明な意味合い、セキュリティを意識していること。

4。 必要に応じて特定のファイル/フォルダへのアクセス許可を追加します。右個々のファイル/フォルダをクリックします - > [プロパティ]を、あなたは、通常のファイル/フォルダの場合と同じようにセキュリティ権限を調整します。

これは、IISのバージョンとどのような特定のWindows OSがサーバ上にある、あなたがドメインまたは他の異なるセットアップを持っているかどうかに応じて異なる場合があります。

参照してください

あなたのアーキテクチャへの移入 | あなたのアーキテクチャを分析します


あなたのアーキテクチャのエクスポート

ナビゲーション：あなたのアーキテクチャのレポート>

あなたのアーキテクチャのエクスポート

コメントを送信 このトピックに関する。

ABACUSは、ことができます に（Microsoft Accessを）.MDBためにあなたのアーキテクチャをエクスポートし、 MS SQL Serverの、 .abacus（ABACUSファイル）、および.XLS（Microsoft Excelの）形式。また、あなたをエクスポートすることができます ダイアグラムPNG、JPG、SVG（スケーラブルベクターグラフィックス）、TIFF、GIFとBMP形式と（HTML）を.htmlにレポート、PDFファイル（Adobe Acrobatの）、.XLS（Microsoft Excelの）、.DOC（マイクロソフトワード）と秒.RTF（リッチテキストフ​​ォーマット）形式。これは、あなたが好きなようにアーキテクチャとそのデータを分析し、表示することができます。

.MDBにあなたのアーキテクチャをエクスポートするには（Microsoft Accessの）

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 クリックします ファイル メニュー。

3。 選択 エクスポート、 その後 MDBに.

4。 警告のノートを取り、クリック [OK].

5。 ファイルの名前を入力します。

6。 クリック セーブ ボタン。

注意

.MDBデータベースのエクスポート形式です ABACUSと任意のスキーマの変更に固有の再インポートすることができないことになります。見てください MS Accessでの移入 MS Accessのスキーマについて.

にあなたのアーキテクチャをエクスポートするには MS SQL Serverの

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 クリックします ファイル メニュー。

3。 選択 エクスポート、 その後 MS SQL Serverに.

4。 クリックし表示されるダイアログで エクスポート空白MDB ...ボタンとあなたのMS SQL Serverデータベースサーバにこれをインポートします。

5。 データベース情報および接続文字列を入力し.

6。 クリック エクスポート ボタン。

注意

のエクスポート形式 MS SQL Serverのデータベースがあります ABACUSと任意のスキーマの変更に固有の再インポートすることができないことになります。見てください MS Accessでの移入 データベーススキーマについて.

.XLS（Excelファイル）に自分のアーキテクチャをエクスポートするには

1。 あなたが持っていることを確認 ABACUSファイルオープン 、 エクスプローラ表示 、 アーキテクチャが追加されました .

2。 あなたが持っていることを確認 Excelのインポート/エクスポート設定ファイルの 定義されています。

3。 右クリックモデル内のアーキテクチャまたはのいずれかの部分に コンポーネントノード（指定されたアーキテクチャ内）を使用すると、Excelの設定ファイルにエクスポートしたいです。

4。 選択 エクスポート | に エクセル... メニューから選択します。

5。 ザ・ 使用するために、Excelインポート/エクスポート設定ファイルの選択ウィンドウが表示されます。

6。 あなたのアーキテクチャモデルに関連する設定ファイルを選択し、をクリックしてください オープン ボタン。

7。 自動的に行っていない場合は、マップ へのあなたの現在のアーキテクチャでトップレベルのコンポーネント IDを設定（以前に定義されている）とをクリック エクスポート....

例トップレベルのコンポーネントのマッピング

8。 お使いのExcelファイルの場所とファイル名を選択してクリック セーブ ボタン。

.abacusにあなたのアーキテクチャをエクスポートするには（ABACUSファイル）

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 右クリックアーキテクチャのノードで、モデル内の任意のアーキテクチャやコンポーネントツリーの任意の部分。

3。 選択 エクスポート| に ファイル...メニューから選択します。

4。 場所とファイル名を選択してクリック セーブ ボタン。

注意

次の手順によりバックABACUS ABACUSにファイルをインポートすることができます 1-2上記した後、選択 インポート| から ファイル...。インポートしたいファイルを選択した後、あなたは規格や種類をインポートしたいのかを質問されます。あなたは、新規またはマージされた規格や種類のいずれかとして基準と型をインポートすることができます。デフォルト設定では、彼らはすでにあなたの中に存在する場合、既存の規格や種類とマージするための基準とタイプのためのものです プロジェクト.

.xmlにあなたのアーキテクチャをエクスポートするには

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 右クリックアーキテクチャのノードで、モデル内の任意のアーキテクチャまたはコンポーネントツリーの任意の部分。

3。 選択 エクスポート| に XML ...メニューから選択します。別の方法としては、メニューをクリックすることができます ファイル| エクスポート| に XML ...

4。 場所とファイル名を選択してクリック セーブ ボタン。

注意

次の手順によりバックABACUSにXMLファイルをインポートすることができます 1-2上記した後、選択 インポート| から XML ...。あなたがインポートするXMLファイルを選択した後、あなたは規格や種類をインポートしたいのかを質問されます。あなたは、新規またはマージされた規格や種類のいずれかとして基準と型をインポートすることができます。デフォルト設定では、彼らはすでにあなたの中に存在する場合、既存の規格や種類とマージするための基準とタイプのためのものです プロジェクト.

PNG、JPG、SVG、TIFF、GIFまたはBMPにダイアグラムをエクスポートするには

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 開きます ダイアグラムあなたがエクスポートしたいと思います。

3。 クリックします エクスポートDiagram上のボタン ダイアグラム ツールバー。

4。 ザ・ エクスポートダイアグラムウィンドウが表示されます。

5。 選択 ブラウズ所望の位置に可視化を保存するためのボタン。

6。 選択 タイプとして保存ファイルの種類を選択するプルダウンメニュー。

7。 クリック セーブ ボタン。

PDFファイル（Adobe Acrobatの）にレポートをエクスポートするには、.XLS（Microsoft Excelの）または.DOC（Microsoft Wordの）

1。 あなたが持っていることを確認 ABACUSファイル オープン。

2。 作り出します 報告する あなたがエクスポートしたいと思います。

3。 クリックします エクスポートレポートツールバーのボタンをクリックします。

4。 選択 エクセル、PDFやWordドロップダウンボックスから。

5。 レポートの輸出ながら、しばらく待ちます。

6。 場所とファイル名を選択してクリック セーブ ボタン。


エンタープライズサーバでの作業

ナビゲーション：管理>

エンタープライズサーバでの作業

コメントを送信 このトピックに関する。

そろばんエンタープライズ サーバ 「非ロック」共同アプローチだけでなく、「切断」1両方です。 ABACUSはので「非ロック」です しません それを更新するために一人のユーザによってロックされるようにファイルを強制。各ユーザーは、ファイルの独自のローカルコピーを持っており、彼らは変更を行い、それらのファイルを保存するように、それらの変更は、ユーザーがサーバーにコミットしたい場合のために記録され、保存されます。

ABACUSは、サーバーに接続する必要があるか、ファイルで作業しながら、ネットワークアクセスを必要としないという意味で「切断」されています。 、更新、コミット、または過去のコミットのログの表示 - ABACUSは、既存のファイルに対する操作と一緒に、ファイルを作成、またはチェックアウトを実行するなどの操作を実行するときにサーバーにアクセスする必要があります。サーバーへのアクセスは、ファイル上で動作するように要求され、変更されていません ありません すぐにサーバーに送信され（これは、あなたがミスをした場合は、簡単に変更を破棄することができます）。あなたがファイルを保存するときは、「単に 'あなたを保存しています コピー ローカルで - あなたがあなたのローカルの変更、サーバーに送信されます（変更はあなたの最後のコミット以降に行われた）ことをコミットするまでそれではありません。

新規エンタ​​ープライズ・ファイルの作成

新しいエンタープライズ・ファイルを作成するには、[ ファイル| 新しい ...そしてその後のエンタープライズモデルセクションで最初の2つのオプションのいずれかを選択します。 [新しいプロジェクト]ダイアログ （つまり、いずれかの空白エンタープライズファイル、または既存のABACUSファイルから作成）。第三の選択肢は、「チェックアウト」他の誰かがすでに作成している企業のファイルに、これは次のセクションで説明しますです。

新しいエンタープライズ・ファイルを作成することを選択した場合、あなたはあなたがあなたのファイルを保存したい場合は、リポジトリサーバ上にブラウズすることができますダイアログが与えられます。また、あなたが新しいプロジェクト]ダイアログから「既存のモデルから「選択し、ファイルを指定した場合は、既存のファイルのパスと名前がトップを入力しています。

URL：これは、ABACUSエンタープライズファイルが格納されているリポジトリサーバのURLです。このURLはどうあるべきか、サーバーを管理している人に依頼する必要があります。

上の写真は、リポジトリとを示しています 4つ URLを入力し、Enterキーを押した後、ABACUSエンタープライズプロジェクトを既存の。 君が 新しいエンタープライズ・ファイルを作成した後、このリポジトリの下に別のフォルダとファイルが存在します、「チェックアウト」については、次のスクリーンショットに、表示されます。

注意

あなたは、HTTPS（SSL）サーバーを使用しており、サーバーが起因して、イントラネットまたは非パブリックサーバのための共通の有効なSSL証明書を（持っていない場合 ザ・ SSL証明書のコストs）を取るために余分なステップがあるでしょう。あなたは永久にポップアップするダイアログで、そのサーバーへのすべての接続に同意する必要があります（これは、サーバー上のビットより多くの情報が表示されます）。これを行うには、タイプ（引用符なし）「P」と入力し、Enterキーを押します。 ABACUSは、ダイアログを表示する前にこのことを思い出させるメッセージをポップアップ表示されます。

注意

あなたは、人がある場合に、サーバーにログインするように要求することができます 管理サーバサーバのユーザ名とパスワードを提供することができます。また、あなたが保存されているために接続されているすべてのサーバーのログイン資格情報何らかの理由で、彼らはこれを介して行うことができるクリアする必要がある場合に ツール|オプションそして、その後に 一般 クリックしてタブ Subversionの保存されたログインをリセットドロップダウンリストとクリックからサーバーを選択します クリアログインそして、表示​​されるダイアログで[OK]を選択します.

注意

以上1 ABACUSプロジェクトは、単一のABACUSリポジトリに作成されている場合、ABACUS変更ログ番号がすべてABACUSプロジェクト間で共有されており、これはユーザーを混乱させる可能性があるため、上記に示したスクリーンショットとは異なり、通常、単一のABACUSプロジェクトは、各ABACUSリポジトリに含まれています。

優先ファイル名：これは、（すでに使われていない場合）、リポジトリサーバ上のファイルを作成するときに使用されるフ​​ォルダとファイル名の両方に影響します。新しいフォルダが（パフォーマンス上の理由から、ABACUSエンタープライズファイルはダイアログでに閲覧場所の下、自分のフォルダに作成されている）は、各ファイルのリポジトリサーバ上に自動​​的に作成されることに注意してください。

ディレクトリ内の作業コピーを保管してください：エンタープライズファイルをリポジトリサーバ上に作成されると、ローカルの作業ファイルがコンピュータ上に作成する必要があるので、あなたは、ネットワークに接続しなくても、ファイルで作業することができます。これは、あなたが開くように/再オープンABACUSエンタープライズファイルをしたいときに参照します場所です。

既存のエンタープライズ・ファイルのチェックアウト

誰かが既に新しいエンタープライズファイルを作成している場合は、「チェックアウト」ローカルコピーをダウンロードし、ABACUSエンタープライズファイルとしてこれを認識するように、必要なファイルを設定し、このファイルを、することができます。ダイアログには、新規エンタ​​ープライズファイルダイアログに似ています。リポジトリのURLを入力します（サブディレクトリは、URLに含めることができる）、必要なファイルを選択し、[OK]をクリックします。 トン以下の注意に従うことを条件彼はその後、開かれるファイル。

注意

あなたは、人がある場合に、サーバーにログインするように要求することができます 管理サーバサーバのユーザ名とパスワードを提供することができます。また、あなたが保存されているために接続されているすべてのサーバーのログイン資格情報何らかの理由で、彼らはこれを介して行うことができるクリアする必要がある場合に ツール|オプションそして、その後に 一般 クリックしてタブ Subversionの保存されたログインをリセットドロップダウンリストとクリックからサーバーを選択します クリアログインそして、表示​​されるダイアログで[OK]を選択します.

エンタープライズファイルの違い

あなたはエンタープライズ・ファイル（新しいもの、または他の誰かが作成したファイルの「チェックアウト 'を介してのいずれか）を作成したら、フォルダがファイルのために作成され、それは一般的にこれらのファイルの3つの主要なタイプが含まれます。

· 「.abacus 'ファイル - これはABACUSファイルそのものです。変更は、ローカルで行います ありません すぐにこのファイルに保存され、それが唯一あなたがコミットしたときに書き込まれます。このファイルには、「通常の」ABACUSファイルでは、非EEのユーザに与えることができます。（.logファイルなし）、スタンドアローンプロジェクトとして、または新しいEEファイルの開始点として使用されます。

· 「.CHANGES 'ファイル - ファイルに対して行われたローカル（コミットされていない）の変更。このファイルが欠落している場合、これは局所的な変化がないことを意味します。

· 「.logの 'ファイル - このファイルには、最後のユーザー（彼らが犯しユーザーの.CHANGESファイルの内容）によって行われた変更のみを持っています。

注意

更新中に作成され、すなわち、プロセスをコミットすることができる様々な他のファイルがあります。 ‘.changesbefore' ファイル; - 更新が行われていると自動的に更新し、任意のローカル（コミットされていない）との間のIDの競合を調整するために使用された後、このファイルには、コミットの前に変更された.changesファイルのコピーです ‘。バックアップ' ファイル - ユーザーが.CHANGESファイルに複数のローカル（コミットされていない）の変更を保存する前に、このファイルには、た.changesファイルのコピーです。そして ‘。エラー' ファイル - このファイルは.abacusファイルを開くために失敗するABACUSの原因となったすべての問題があった場合.CHANGESのコピーがファイルであり、ユーザーはその変更を元に戻すことを選択しました.これらのファイルは無視することができます。

ファイルを開きます

ファイルを開くには、あなただけでは作業コピーを保存することを選択した場所を参照し、そこに保存されているABACUSファイルを開く必要があります。 ABACUSがあることを確認すると .ログファイル（そしておそらく .あなたが変更を加えた場合の変更は、それが企業のファイルとして扱います）ファイル。

ファイルの更新

実行ファイルの新しいバージョンがサーバー上にある場合n 'を更新'をチェックします。ある場合、それは、あなたの現在のファイルを閉じて、サーバーから新しいファイルに更新し、拡張子として番号を持ついくつかの一時ファイルをダウンロードします - 例えば「Demo.125」。 これらのファイルは、.logファイルの古いバージョンであり、あなたが最後に更新したので、ファイルに加えられた変更を決定するために使用されています。これは、あなたがそれらを解決できるように発生した可能性のある競合を検出するために必要とされます。

もし 更新プロセス中の任意の 競合発見されましたあなたは（あなたがキャンセルすることができます再度ファイルを開くことができます前に、あなたはそれらを解決する必要があります。 だけど あなたが再び衝突を解決するように求められますあなたがファイルを開く次の時間）。

ファイルの保存

ファイルを保存すると、これはあなたがた.changesファイルに加えた変更を追加します。それ ではないこの段階で.abacusファイルを変更 - ファイルがサーバーにコミットされた場合にのみ（サーバーからの更新を受信したときや）それが上書きされます。

「名前を付けて保存」はどこにありますか？

エンタープライズ・ファイルの名前を付けて保存の概念はありません。ただし、それは文句を言わないことでローカルの変更を持っていることを念頭に置いて、ファイル.abacus作業コピーをコピーすることができます。

競合の解消

他のユーザーがあなたにファイルの同様の部分のファイルに変更をコミットした場合、その変更とあなたの間で衝突があるかもしれません。たとえば、別のユーザは、あなたが持っていたコンポーネントを削除することがあります 上のプロパティを更新。あなたは彼らがすべきことが確実な場合は、（自分の変更を元に戻す必要があるのいずれかではありません （あなたが戻ってファイルに移動して、あなたの変更をやり直すこと））が起こったか、変更を破棄しています。

具体的に発生する可能性があります競合の4つのクラスがあります。

1。 削除 - ユーザーが別のユーザーの変更、そのオブジェクトを削除するとき。 例えば。ユーザAは、コンポーネントを削除したが、ユーザBは、コンポーネントの名前が変更されたか、またはそれに接続されているかなどに子コンポーネントを追加しました

2。 属性 - 二人のユーザーの両方が対象の正確な同じ「属性」を変更すると。 例えば。両方のユーザAとユーザBは、コンポーネントの名前またはその記述またはその他の特性のいずれかの値を変更しました

3。 リファレンス - 2人のユーザーがまったく同じ「参照」を変更するとオブジェクトが別のオブジェクトにあります。 例えば。ユーザーAとユーザーBの両方が、コンポーネントのタイプや図などに接続またはリンクされた視点に接続されているソース/シンクコンポーネントを変更しました

4。 コレクション - 2人のユーザがオブジェクトに対して「コレクション」を変更すると。 例えば。どちらのユーザーAとユーザーBが別の親からコンポーネントを移動したり、子コンポーネントのコレクションを再注文しました。

注意

様々な取るに足らない競合は自動的にユーザーのオーバーヘッドを最小限に抑えるためにABACUSによって解決されます.例えば図の競合パン・ズームの設定は、最新のパン・ズームの設定を維持するために解決されます。

変更のコミット

変更をコミットすることを選択し、ABACUSファイル サーバーから 開かれ、あなた ローカル 変更が行われますそれに対して、、 その後 お近くの .abacusファイルは、その中の変更内容を持つもので上書きされます。変更内容は、[ファイル.logファイルを上書きし、.abacusファイルと.logファイルの両方をサーバーに送信されます。コミットが成功した場合は、以下に示すコミットしてメッセージを入力するために提供されるメッセージダイアログをコミットします。

変更のログを表示します

に への変更のログを表示します 企業 プロジェクト選択 ファイル| ログの表示...

最大ログエントリ： この 最後の10個のエントリがデフォルトになりますが、追加のエントリは、値を変更し、クリックして検索することができます 検索 ボタン。

リビジョン：番目Eリビジョン列が新しい順に、デフォルトでは、エンタープライズサーバにコミットリビジョン番号を示します。

注意

唯一ABACUSが表示されますコミットと同じSubversionリ​​ポジトリは、他のそろばんプロジェクトおよび/または他のバージョン管理アプリケーションに使用されている可能性がありながら、リビジョン番号は、連続的ではないかもしれません.

日付：番目E日付列は、リビジョンがEnterpriseサーバーにコミットされた日付を示しています。

時間：番目電子タイム列はリビジョンがEnterpriseサーバーにコミットされたことを（24時間形式で）一日の時間を示しています。

著者：番目E著者列が続くコミット実行したユーザーのために、Microsoft Windowsのログイン名を一覧表示し、それら ABACUSのユーザー名 、または「匿名」ユーザーが認証されていないと、匿名ユーザーがコミット時のエンタープライズプロジェクトへのアクセスを許可された場合。

ログメッセージ：番目電子ログメ​​ッセージの欄には、上に示したダイアログのとおり改正で提供されたコミットメッセージを一覧表示します。

ダウンロード改訂XXスタンドアロンABACUSファイルとして: あなたは、テーブル内の指定されたリビジョンを選択し、[ダウンロード]ボタンをクリックすると、サーバーから選択されたそろばんプロジェクトのリビジョンを抽出し、ローカル/スタンドアロンABACUSプロジェクトとして保存することができます。

注意

以前のリビジョンにロールバックするには、これを参照してください。 Avolutionコミュニティ記事 .

（管理者）改正XXのXMLログファイルをダウンロード: ABACUS管理者の能力を持つユーザーは、テーブル内の指定されたリビジョンを選択し、選択されたそろばんプロジェクトはサーバからのログファイルをコミット抽出し、.xmlファイルとして保存するには、[ダウンロード]ボタンをクリックすることができます。

変更の監査証跡を表示します

に のいずれかの特定の要素への変更（すなわち、コンポーネント、接続、ビュー、子供など）の監査証跡を表示 企業 プロジェクト, 要素を右クリックして、 選択します 監査証跡...およびリビジョンの範囲とクリックに設定 サーチ.

注意

要素をプロジェクトから削除されたら、もはやその要素に関する具体的な監査証跡情報にアクセスすることができません。ただし、まだ（例えば）「親」のコンポーネントにアクセスし、（削除された要素のIDをリストこの場合は）削除に関する監査証跡情報を見ることができます.また、コンポーネント/接続アタッチメントには、接続しないで、コンポーネント、および接続を削除して新しい接続を作成するための監査証跡に表示されますので、エクスプローラのウィンドウを介して、またはダイアグラムに取り付け部品を変更する接続の 'プロパティは'（ようです接続アタッチメントを完全に - あなたは、元のコンポーネントの監査証跡情報が失われます）「Unattach」を右クリックしたあと、「接続...」カタログに場合に発生します。

注意

デフォルトでは、監査証跡には、再帰的に選択した要素の子のいずれかに変更を確認します。これは、長い応答時間をもたらすことがあり、それに応じて監査証跡を選択解除して要素自体に限定することができます 再帰 下のオプション 監査オプション監査証跡ダイアログの「歯車」ツールバーボタン。

リビジョンから： この エンタープライズ・サーバー上で、プロジェクトの使用可能な最初/一番古いリビジョンがデフォルトになります。

リビジョンに： この エンタープライズ・サーバー上で、プロジェクトの使用可能な最後の/最新のリビジョンがデフォルトになります。

注意

Fromおよびリビジョンに設定した後に選択した要素に特定の変更を取得するには、[検索]ボタンをクリックしてレンジ.

リビジョン：番目Eリビジョン列が前方に時系列順に、デフォルトでは、エンタープライズサーバにコミットリビジョン番号を示します。

注意

選択した要素に関連する唯一のリビジョンが表示されるようにリビジョン番号が連続していることはほとんどありませんし、唯一のABACUSは同じSubversionリ​​ポジトリは、他のそろばんプロジェクトおよび/またはバージョン管理アプリケーションのために使用されていることができるが表示されますコミット.

日付：番目E日]列には、ユーザーのアクションが行われた日付を示しています。

注意

示された日付は、ユーザーのアクションではなく日リビジョンがEnterpriseサーバーにコミットされた日付です。したがって、日付が日付で示さコミット対応する改正に​​先行してもよいです ファイル|ログを表示... コマンド。

時間：番目電子時刻欄には、ユーザーのアクションが行われたことを（24時間形式で）一日の時間を示しています。

注意

表示される時間は、ユーザーの行動時間ではなく、リビジョンがEnterpriseサーバーにコミットされた時刻です。したがって、時間はおそらくコミット時に示された対応する改正に​​先行します ファイル|ログを表示... コマンド。

著者：番目電子者の列は、その続くアクションのMicrosoft Windowsのログイン名を実行したユーザーを一覧表示します ABACUSのユーザー名 、または「匿名」ユーザーが認証されていないと、匿名ユーザーがユーザーの操作時にエンタープライズプロジェクトへのアクセスを許可された場合。

注意

監査証跡ダイアログにリストされている著者は、必ずしも同じリビジョンのために上記の[ログの表示]ダイアログボックスにリストされている者と一致しない場合があります。 [ログの表示]ダイアログボックスのリストが監査証跡ダイアログのリストがユーザーの操作時にユーザにログインした状態で、コミット時にユーザにログインしているため、これがあり、それは一人のユーザが変更を行い、それらのを送信することが可能です。変更はコミットする他のユーザにファイル - （例えばAvolutionなど）外部ユーザーはEEプロジェクトに取り組むことである場合のように。

細部：番目エンタープライズサーバーに記録されたとして、電子詳細]列には、ユーザーのアクションの正確な詳細を示しています。

先端

それはに便利です リビジョン列によってグループ （上記のダイアログに示すように） および/またはユーザーアクション列 に 簡単に興味の要素への変更を分類.

エンタープライズファイルとスクリプトの使用

あなたはエンタープライズファイルでスクリプトを使用する場合は、正しくモデルからオブジェクトを削除する方法を知っておく必要があります。あなたがオブジェクトを削除する際に一般的に、あなただけの、その親から削除するのではなく、その上に.Delete（）メソッドを呼び出します。

例えば。あなたがCOMP2の親としてCOMP1を持っていたし、あなたのスクリプトでCOMP2を削除したい場合は、むしろcomp1.Components.Removeよりcomp2.Delete（）、（COMP2）を呼び出す必要があります。

あなたはアーキテクチャ内の別の場所にCOMP2オブジェクトを追加する予定がある場合は、削除を使用してもよいが、意図はオブジェクトを削除する場合には使用すべきではありません。

他の場所でモデルの「住んで」ということは、オブジェクトを削除したいときのためにこれには例外が存在します。 arch1 - あなたはアーキテクチャ/コンポーネント/接続から標準インスタンスを削除したいときは、あなたは、インスタンスの標準のコレクションから、それを削除することによってそれを行うだろう。実装.Removeは（IMP） - それを削除すると、すべてのインスタンスから削除してしまうため。

正しくスクリプトで削除使用すると、オブジェクトがobjectmodelから削除し、それを配置することができなくなり、再追加されていない場合ので、重要ですが、それはありませんでしたので、特に「削除」、競合の検出と解決はしません正しく、他のユーザーがその変更のいずれかでそのオブジェクトを使用しようとすることであった場合、競合を検出し、最終的な結果は、そのユーザの変更を破損設定されます。

参照してください

どのようなアーキテクチャは、ABACUSに表されていますか？


アクセス許可の操作

ナビゲーション：管理>

アクセス許可の操作

コメントを送信 このトピックに関する。

ABACUSプロジェクトが持つことができます 役割ベースの権限は、リポジトリ内のすべての要素に設定。具体的には、 きめの細かいです Create-Read-Update-Delete（CRUD）の権限は 'オブジェクト'（すなわち、コンポーネントまたは接続）、ビューと属性（つまりプロパティ）レベルで設定できます。

概説

で作業する場合 そろばんエンタープライズ サーバ 、ABACUSはリポジトリに複数のユーザーのアクセスを制御するために、きめの細かい、役割ベースのCRUDアクセス権を提供します。

注意

ABACUSプロジェクトユーザーライセンスでアクセス許可を設定するには管理者の能力を必要とします。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

権限が（その種類によって）のアーキテクチャ、コンポーネント、および接続の種類、プロパティを設定することができ、テンプレート、視点と 図、カタログ、マトリックス、チャート 3Dビュー。そのプロジェクト内のすべてのアーキテクチャでそのタイプの権限は、コンポーネントまたは接続タイプに設定されているすべてのインスタンスこれらのアクセス許可を「継承」。同様に、許可は、コンポーネントまたは接続タイプのプロパティに設定されている場合、そのプロジェクト内の任意のアーキテクチャ内のコンポーネントまたは接続インスタンスに指定されたプロパティ、これらの権限を「継承」。したがって、特定のアクセス許可は、これらの要素が存在しているビューに適用されます。権限がダイアグラム、ビューおよび/またはビュー自体の内容に設定されている場合には、様々なアクセス許可が適用されています。

注意

デフォルトでは、アクセス許可は、ABACUSプロジェクト内の要素に設定されていません。つまり、すべての要素は、すべてのユーザーによって作成可能、読み取り可能、更新可能と削除可能ですです。特定の許可をする場合にはこのように権限のみリポジトリ内の特定の要素を考慮すべきです 制限されました特定のユーザグループのため。そして、これは機能的に、そのユーザー・グループの場合と同じであり、例えば、特定のユーザーグループのアクセス許可は、オブジェクト（例えばコンポーネント・タイプ）に追加された場合が、有効になってすべての権限を残し ありませんでした オブジェクトに追加。

パーミッション することはできません建築の要素の特定のインスタンスに設定します。たとえば、あるアプリケーションコンポーネントが更新可能にするさらに別のではないことはできません。効果的しかしこれらの「ドメイン固有の許可を得るためには、管理者は、例えば特定のドメインのための具体的な要素タイプを設定することができますコンポーネントタイプ 'アプリケーション - CRMドメイン」と「アプリケーション - 人事ドメイン」、およびそれに応じて各タイプごとにアクセス権を設定します。 あなたは、ドメインごとに特定のグループ化の種類を作成し、その後、ドメイン固有のグループタイプの更新権限を削除し、これはそのグループ化の中で創作および削除を制限するが、子どもの更新されませんすることができます。もちろん、ドメイン固有のグループ化は、読み取り許可後、子供たちは隠されるだろうし、それによって非更新可能を除去することによって隠されていた場合。 （むしろExplorer以外）ビューは、あなたのリポジトリを表示/管理するために主に使用している場合は別の方法として、各ドメインの指定されたビューを確立することができ、その後、管理者はそれに応じて各ビューのアクセス権を設定することができます。

ユーザーとグループの管理

許可はで定義されています 役割または グループグループのメンバーシップが変更される可能性がありながら、権限が固定されたままできるように、個々のユーザーレベルではなくレベル、。あなたが特定のユーザー権限が必要な場合はもちろん、単純にそれらをグループにする、またはより正確に唯一のメンバーとして、そのユーザーとグループを作成します。

これは、グループがあることに留意すべきです アトミック、つまり、彼らは別のからのアクセス許可やユーザーを継承することはできませんし、ユーザーが複数のグループに属していれば、ほとんどの「悲観的」グループのアクセス権は、（つまり、作成した各個別の許可をケースバイケースで優先されます - 読み取り更新-削除）。たとえば、同じユーザがグループBは、単にアプリケーション・コンポーネント・タイプのためだけに作成し、読み取りアクセス許可の読み取りを更新していたが、グループAとグループBとグループAのメンバーで、ユーザーが唯一の許可を読むことになるアプリケーションのコンポーネントタイプの許可がある場合アプリケーションコンポーネントのインスタンス。

また、デフォルトでは、 匿名ユーザーしている（それが定義されていないか、ログインしていない人のユーザーです） フルアクセスプロジェクトに。これにより、アクセスは、初期設定で利用可能であることを保証することです。匿名ユーザーによるアクセスをブロックするには、単に以下のようなダイアログの管理ユーザー/グループにオプション「匿名ユーザーの完全なアクセス権をファイルに許可する」のチェックを外し。オフの場合、匿名ユーザーは任意のプロジェクトの標準部分を見ることができます。

最後に、「使用してWindowsユーザー名のログイン 'オプションがチェックされている場合、ユーザー名の認証は、ユーザー名の下のあたりで入力に対して、各ユーザーのマシン上のWindowsユーザー名、ログインに対して実行されます。指定したユーザーのマシンのWindowsユーザー名ログイン後、パスワードが必要とされない有効なユーザ名として存在し、ユーザーが自動的に認証された場合にそれがあります。注意：これは効果的にWindowsのActive Directory（AD）認証の使用を可能にします。

注意

彼らは離れて（制限付き）、ユーザから撮影する必要がある場合に許可がのみ定義されていることを考えると、グループのメンバー、または任意のオブジェクトに対してそれに定義された権限を持っていない任意の基でないすべてのユーザーが、への完全なアクセスを持っていますプロジェクト。

ユーザとユーザグループ

新しいユーザーを作成するには

1。 選択 ファイル| ユーザ/グループの管理

注意

あなたが管理するユーザー/グループ]メニュー項目が表示されない場合、あなたは管理者の能力を有していません。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

2。 選択表示されたダイアログで ユーザーの追加ボタンと新規ユーザーの作成]ダイアログでユーザー名とパスワードを入力します。注：ユーザー名とパスワードは大文字と小文字が区別されます。

注意

ダミーパスワードは、認証として入力することができます上記のように「使用してWindowsユーザー名のログイン」オプションがチェックされている場合のみ、ユーザーのWindowsのユーザー名ログインに応じて実行されます。

2。 デフォルトでは、ことがわかります ユーザーが自分のパスワードを変更することができます. 必要に応じて、ABACUS管理者が削除することができザ・ 自分のパスワードを設定するユーザーのための能力 によって チェックを外しますチェックボックスをオンにします。

注意

ユーザーが自分のパスワードを変更することができれば、彼らは持っています ファイル|パスワードを変更する...これを行うには、メニュー項目.また、複数の人が同じユーザー名を使用するならば、一人のユーザが他の人が後からログインすることができないようにパスワードを変更する可能性があることに注意してください。したがって、それは持ってすることをお勧めします 実際の人物ごとに単一のユーザー名.

4。 必要に応じて、電子メールアドレスを入力してください, ロケーション そして、電話番号 今後の参考のためにユーザーのため。

5。 クリックします [OK]新規ユーザーの作成]ダイアログボックスでボタンを押します。

6。 クリックします [OK] ボタン。

注意

あなたが最初のユーザーを作成したら、管理ユーザー/グループ]ダイアログボックスでオプションを「匿名ユーザーの完全なアクセス権をファイルに許可する」オフにして、匿名ユーザーによるアクセスをブロックする検討すべきです。また、一度ユーザーが作成されている（およびエンタープライズプロジェクト、サーバーにコミット変更した場合）、プロジェクトがユーザーに開かれる次回に求めるメッセージが表示されます 認証されたアクセスのためのログイン以下のようなダイアログのとおり。もし これらの詳細を使用して自動的にログインオプションは、次にチェックされているユーザー名/パスワードの組み合わせは、プロジェクトのために記憶し、開口部に毎回適用されます。保存されたログインの選択をクリアするには ファイル|クリア保存ログイン開き、後に再度次回プロジェクトを開いてログインするように要求されます。

ログイン

既存のユーザーを削除するには

1。 選択 ファイル| ユーザ/グループの管理

2。 削除してから選択したいユーザーパネルでユーザー名を選択して表示されたダイアログで ユーザの削除 ボタン。

3。 クリックします [OK] ボタン。

新しいグループを作成するには

1。 選択 ファイル| ユーザ/グループの管理

2。 選択表示されたダイアログで グループの追加ボタンを押すと、グループパネルのグループ名を入力します。

注意

グループ名は一意である必要があります。

3。 クリックします [OK] ボタン。

に 既存のコピー グループ

1。 選択 ファイル| ユーザ/グループの管理

2。 選択表示されたダイアログで コピー グループ ボタン。

注意

重複するグループは、「コピー〜」が付い作成されます。.デフォルトでは、コピーされたグループのすべての権限は、任意のユーザーの割り当てを含むグループ」のコピー」のために複製されます。

3。 使用して、必要に応じてグループ」のコピーを「名前の変更 グループの編集または低速ダブルクリック.

既存のグループを削除するには

1。 選択 ファイル| ユーザ/グループの管理

2。 削除してから選択したいグループ]パネルでグループ名を選択し表示されたダイアログで グループの削除 ボタン。

注意

グループへのすべてのユーザーの割り当ても削除されます。

3。 クリックします [OK] ボタン。

グループにユーザーを割り当てるには

1。 選択 ファイル| ユーザ/グループの管理

2。 あなたがグループに割り当てるユーザーのパネルでユーザー名を選択し、表示されたダイアログで ドラッグアンドドロップそれあなたがそれを割り当てるグループ]パネルで、グループ名の上に。

3。 クリックします [OK] ボタン。

注意

ユーザが拡張することによって示されるように割り当てられていることをグループ（複数可） ユーザーパネルでユーザー名グループに割り当てられているユーザは、グループパネルでグループ名を展開して示されています。例えば、上のスクリーンショットでは、「AS1-アウス」ユーザーは、すなわち、3（3）グループに割り当てられています。 「アプリケーションのサポートチーム1」、「実」と「オーストラリア」。

グループからのユーザーの割り当てを解除するには

1。 選択 ファイル| ユーザ/グループの管理

2。 [ユーザー名の割り当てを解除し、選択したいユーザーの割り当てを含むグループ名を展開表示されたダイアログで。

3。 クリックします 割り当て解除ユーザー ボタン。

4。 クリックします [OK] ボタン。

ユーザーおよび/またはグループ（および任意のマッチングのアクセス許可）をインポートするには

1。 選択 ファイル| ユーザ/グループの管理

2。 クリックします インポート ボタン。

3。 表示されるダイアログで ブラウズユーザーと/またはグループ（と権限）が含まれABACUSプロジェクトを開き、現在のプロジェクトにインポートし、クリックしたいです オープン。ユーザーとグループがインポートされ、インポート結果]ダイアログには、ユーザーおよび/またはグループのインポートを要約表示されます。クリックします [OK] ボタン。

注意

インポートされたユーザーまたはグループが既に現在のプロジェクトに存在していた場合、それらは、既存のユーザーまたはグループとマージされます。

4。 クリックします [OK]バックメインの管理ユーザー/グループダイアログのボタンをクリックします。

5。 現在のプロジェクトとあなたから読み込んでいるABACUSプロジェクトとの間のマッチングの種類、視点、テンプレートまたはアーキテクチャがある場合、既に現在のプロジェクトに存在しない、アクセス権がインポートされている権限と第二のインポート結果ダイアログで完了インポートを要約表示されます。クリックします [OK] ボタン。

注意

アクセス権は、既存のタイプ（およびそのプロパティ）、ビューポイント、テンプレートまたは許可が既にグループのために存在していなかったグループのアーキテクチャに追加されます。グループが新しいかので、いずれかのグループが既に現在のプロジェクトに存在していたが、何の権限は、その項目にそのグループに割り当てられていました。許可が既に現在のプロジェクトのグループの存在一致するアイテムに対する権限のない「マージ」はありません。

アクセス権の設定

権限が（その種類によって）のアーキテクチャ、コンポーネント、および接続の種類、プロパティを設定することができ、テンプレート、視点と 図、カタログ、マトリックス、チャートANDの3Dビュー。そのプロジェクト内のすべてのアーキテクチャでそのタイプの権限は、コンポーネントまたは接続タイプに設定されているすべてのインスタンスこれらのアクセス許可を「継承」。同様に、許可は、コンポーネントまたは接続タイプのプロパティに設定されている場合、そのプロジェクト内の任意のアーキテクチャ内のコンポーネントまたは接続インスタンスに指定されたプロパティ、これらの権限を「継承」。したがって、特定のアクセス許可は、これらの要素が存在しているビューに適用されます。権限がダイアグラム、ビューおよび/またはビュー自体の内容に設定されている場合には、様々なアクセス許可が適用されています。

権限管理

コンポーネント（または接続）のアクセス許可を設定するタイプ

1。 拡大 タイプ木の枝。

2。 拡大 コンポーネント（または接続）タイプ木の枝。

3。 拡大 グループ必要に応じて。

4。 右クリック上の コンポーネント（または接続）タイプあなたがアクセス許可を設定し、選択したいです 許可を編集.

5。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

6。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

注意

許可を作成することで、要素をコピーすることができたときにも支配します。したがって、要素をコピーすることができるようにする（要素をコピーすることは、その下のすべてをコピーすることを意味するので）、そのすべての子供たちのために作成権限が必要です。素子からの更新権限を削除します ユーザーがアドオンやデザイナーを持っている場合でも、型自体を変更する機能を削除します また、すべてのプロパティの更新権限を削除します。親要素のことができるようにするための更新権限を持っている必要があります すべての子要素を作成しますか、 その削除 既存の 子要素。要素の許可を削除すると、すべての子の削除権限が必要です。コンポーネントの許可を削除しても接続されているすべての接続の更新権限が必要です。そして最後に、削除の権限を削除します 要素から ユーザーはデザイナーアドオンがあっても、型自体を削除する機能が削除されます。

7。 クリックします [OK] ボタン。

コンポーネントのグループ（または接続）タイプのアクセス許可を設定するには

1。 拡大 タイプ木の枝。

2。 拡大 コンポーネント（または接続）タイプ木の枝。

3。 右クリック上の グループそれはあなたがアクセス許可を設定し、選択したいコンポーネント（または接続）の種類が含まれています 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

7。 クリックし表示されるダイアログで はい ボタン。

プロパティのアクセス許可を設定するには

1。 拡大 タイプ木の枝。

2。 拡大 コンポーネント（または接続）タイプ木の枝。

3。 拡大 グループ必要に応じて。

4。 コンポーネント（または接続）を選択それはあなたがのために設定されたアクセス許可にするプロパティが含まれています入力します。

5。 [プロパティ]ウィンドウで 右クリック上の プロパティあなたがアクセス許可を設定し、選択したいです 許可を編集.

6。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

7。 デフォルトでは、読み取りと更新権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

注意

削除更新権限を持っていたプロパティに示されています イタリック[プロパティ]ウィンドウでその値は、その役割によって更新することができません。また、能力に プロパティの詳細を変更（例えば、名前、ユニットなど）プロパティの更新権限の両方を必要とし、 デザイナーはアドオン。

8。 クリックします [OK] ボタン。

テンプレートのアクセス許可を設定するには

1。 拡大 テンプレート木の枝。

2。 を参照 テンプレートあなたが興味を持っていること。

3。 右クリック上の テンプレートあなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、読み取りアクセス許可が使用可能であることがわかります。の許可を削除します チェックを外しますチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

視点のアクセス許可を設定するには

1。 拡大 視点木の枝。

2。 拡大 グループ必要に応じて。

3。 右クリック上の 観点あなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

建築の許可を設定するには

1。 拡大 アーキテクチャ木の枝。

2。 に展開 アーキテクチャあなたが興味を持っていること。

3。 右クリック上の アーキテクチャあなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、読み取りアクセス許可が使用可能であることがわかります。の許可を削除します チェックを外しますチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

アクセス許可を設定するには カタログ

1。 拡大 カタログアーキテクチャの枝に興味があります。

2。 拡大 グループ必要に応じて。

3。 右クリック上の カタログあなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

アクセス許可を設定するには マトリックス

1。 拡大 行列アーキテクチャの枝に興味があります。

2。 拡大 グループ必要に応じて。

3。 右クリック上の マトリックスあなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

ダイアグラムのアクセス許可を設定するには

1。 拡大 ダイアグラムアーキテクチャの枝に興味があります。

2。 拡大 グループ必要に応じて。

3。 右クリック上の ダイアグラムあなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

注意

あなたがダイアグラムに直接CRUD権限を設定できますが、それはダイアグラムの要素のアクセス権は、ビュー自体の権限に影響を与える可能性があることに留意すべきです。例えば、その後の図は、その更新権限が削除されます削除の読み取りまたは更新権限を持っていたビュー上だけでも、一つの要素が存在する場合。それの訳は; a）は、それらの読み取りアクセス許可を削除持っていたビュー上の要素は、そのビューが更新可能であった場合は、そうでない場合は、いくつかの新しい要素が配置される可能性のある「ホワイトスペース」、およびビューのb）の要素を残してビューに表示されませんビューが更新可能であったならば、他の要素を持っている可能性が取り除かその更新権限が子になるためにそれらの上に落としてきました。別のコンポーネント上にコンポーネントを移動するので、また、作成し、ダイアグラムの更新権限がビュー上のすべての要素が読み取りアクセス許可を持っているとコンポーネントが更新権限を持っている必要があります（これは、あなたはそれがするので、それを更新することができなければなりません）子供になります。

6。 クリックします [OK] ボタン。

3Dビューのアクセス許可を設定するには

1。 拡大 3Dビューアーキテクチャの枝に興味があります。

2。 拡大 グループ必要に応じて。

3。 右クリック上の 3Dビューあなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

アクセス許可を設定するには チャート

1。 拡大 チャートアーキテクチャの枝に興味があります。

2。 拡大 グループ必要に応じて。

3。 右クリック上の チャートあなたがアクセス許可を設定し、選択したいです 許可を編集.

4。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

5。 デフォルトでは、作成、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

6。 クリックします [OK] ボタン。

参照してください

どのようなアーキテクチャは、ABACUSに表されていますか？


ダッシュボードでの作業

ナビゲーション：管理>

ダッシュボードでの作業

コメントを送信 このトピックに関する。

ABACUSプロジェクトは、ビューの任意の構成を有することができる（例えば、 図、チャートなど）ダッシュボードとして保存され、これらの保存されたダッシュボードをすることができます プロジェクトを開くには「スクリーン」を開始、デフォルトとして設定され、および/または 特定に割り当てられました ユーザグループ 彼らはそろばんプロジェクトにログインし、そのユーザー・グループのメンバーに提示しました。

注意

ABACUSプロジェクトユーザーライセンスでダッシュボードを設定するには管理者の能力を必要とします。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

ダッシュボードの表示

たとえばアプリケーション・ポートフォリオ管理（APM）ダッシュボード

保存されたダッシュボードを表示するには

1。 選択 見ます| ダッシュボード

2。 使用可能なダッシュボードのリストから保存されたダッシュボードを選択します。

注意

選択ABACUSたらダッシュボードに必要なビューを構築し、これが数秒かかる場合があります。しばらくお待ちください。

ダッシュボードの管理

ダッシュボードの管理

新しいダッシュボードを作成するには

1。 必要なビューを開き、 アレンジとドック ダッシュボードに必要とされるような窓。

2。 選択 見ます| ダッシュボード| ダッシュボードの管理...

注意

あなたが管理ダッシュボードのメニュー項目が表示されない場合、あなたは管理者の能力を有していません。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート あなたは、この機能が必要な場合。

3。 選択表示されたダイアログで 作り出しますボタンを押すと、新規作成ダッシュボードダイアログでダッシュボード名を入力します。

4。 クリックします [OK] ボタン。

既存のダッシュボードを削除するには

1。 選択 見ます| ダッシュボード| ダッシュボードの管理...

2。 あなたはリストから削除したいダッシュボードを選択し、選択表示されたダイアログで 削除 ボタン。

注意

ダッシュボードを削除すると、そのダッシュボードに任意のユーザグループの割り当てが削除されます。

3。 クリックします [OK] ボタン。

既存のダッシュボードを交換するには

1。 必要なビューを開き、 アレンジとドック 交換用のダッシュボードに必要とされるような窓。

2。 選択 見ます| ダッシュボード| ダッシュボードの管理...

3。 あなたはリストから交換して選択したいダッシュボードを選択し表示されたダイアログで 交換してください ボタン。

4。 クリックします [OK]ダッシュボードを認めるためのボタンでダイアログを置き換え。

ダッシュボードを割り当てるにはデフォルトのスタート画面など

1。 選択 見ます| ダッシュボード| ダッシュボードの管理...

2。 リストからダッシュボードを選択して表示されるダイアログでは、割り当てたいです デフォルトの開始」画面」など選択し 割り当てる... ボタン。

3。 選択表示されたダイアログで <デフォルトのプロジェクト> ユーザーグループ列のエントリ.

注意

前のダッシュボードから<デフォルトの[プロジェクト]> [割り当てを削除します再割り当てので、一つだけのダッシュボードには、<デフォルトの[プロジェクト]> [開始]画面」として割り当てることができます.さらに、ユーザは、割り当てられたダッシュボードは、デフォルトのプロジェクトダッシュボードの代わりに開かれます割り当てられたダッシュボードを持つユーザーグループのメンバーとしてログオンした場合。

4。 クリックします [OK] ボタン。

ダッシュボードにユーザグループを割り当てるには

1。 選択 見ます| ダッシュボード| ダッシュボードの管理...

2。 リストからダッシュボードを選択して表示されるダイアログでは、ユーザーにグループを割り当てて、選択したいです 割り当てる... ボタン。

3。 選択表示されたダイアログで ユーザグループ（またはグループ）あなたはのための「起動」画面としてダッシュボードを割り当てます。

注意

同じユーザーグループが複数のダッシュボードに割り当てられている場合は、リスト内の最初の割り当てが使用されます。

4。 クリックします [OK] ボタン。

ダッシュボードからユーザグループの割り当てを解除するには

1。 選択 見ます| ダッシュボード| ダッシュボードの管理...

2。 リストからダッシュボードの項目を展開表示されたダイアログでは、からユーザグループの割り当てを解除したいです。

3。 あなたが割り当てを解除したいユーザーグループを選択し、[選択] 割り当て解除 ボタン。

4。 クリックします [OK] ボタン。

アクセス権の設定

パーミッションは、ダッシュボードが表示可能であることを可能にするために、ダッシュボードに設定することができます、更新可能および/または削除可能特定のユーザーグループに。

権限管理

ダッシュボードのアクセス許可を設定するには

1。 選択 見ます| ダッシュボード| ダッシュボードの管理...

2。 リストからダッシュボードを選択して表示されるダイアログでは、アクセス許可を設定し、選択したいです アクセス許可の... ボタン。

3。 クリックして表示されるダイアログで 追加...ボタンを選択し グループあなたはどちらかそれをダブルクリックするか、それを選択してクリックして追加したいです [OK] ボタン。

4。 デフォルトでは、読み取り、更新、削除権限がすべて利用可能であることがわかります。してアクセス許可を削除します チェックを外します該当するチェックボックスをオンにします。

5。 クリックします [OK] ボタン。

参照してください

ABACUSインタフェースのカスタマイズ | アクセス許可の操作


ABACUSの登録

ナビゲーション：リファレンス>

ABACUSの登録

コメントを送信 このトピックに関する。

あなたが最初にABACUS（または一時ライセンスの期限が切れた後）を起動すると、あなたの地元のABACUS管理者が直接Avolutionから提供された固有のライセンスキーを使用してAvolutionのライセンスサーバーに対してアプリケーションを登録する必要があります。ライセンスキーを持っていない場合は、お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート .

ライセンスキーを登録するには

1。 インストール後、 ABACUSを開始デスクトップまたはWindowsの[スタート]メニューからショートカットをダブルクリックしていずれかの方法で。

2。 入力表示される登録ダイアログで 26文字のライセンスキーお近くのABACUS管理者によって提供されるか、または Avolutionサポート 、またはクリック ブラウズ...署名された.dlscファイルから返さ選択 Avolutionサポート 以下の手順4でメモあたりとして。正しく署名.dlscファイルを使用している場合ABACUSは、以下のステップ5のとおりに開始する必要があります。

先端

あなたのWindowsのクリップボードにコピーし、ダイアログの背景を選択し、Ctrlキー+ Vを押して、ダイアログにライセンスキーを貼り付けることができます

登録ダイアログ

3。 クリック [OK]ライセンスキーがある場合に 有効なABACUSライセンスキーABACUSは現在、ライセンスキーを認証するAvolutionのライセンスサーバーに接続しようとします。

注意

あなたが取得する場合 インストールコードは無効です。登録エラーが、それはあなたが間違ったコードを入力した可能性が最も高いです。コピーしてみて、前述のヒントに従ってコードを貼り付けます。

Avolutionライセンスサーバーへの連絡

4。 クリック [OK]時間の短い期間の後ABACUSが正常に登録する必要があります。

正常に登録

注意

あなたが取得する場合 ライセンスサーバーに接続できません登録エラーは、ネットワーク上のファイアウォール（または他のセキュリティ対策は）Avolutionのライセンスサーバーへのアクセスを妨げている可能性が最も高いです。クリック [OK]、ローカルマシンに.dlscファイルを保存し、 どちらか に.dlscファイルを電子メールで送信 Avolutionサポート し、指示を待ちますまたはライセンスは、次のURLを使用してファイルを自分でサインインしよう - http://licensing.avolutionsoftware.com/LicenceSign/ .

ライセンスサーバーに接続できません

ライセンス署名Webページを開きます。

マニュアルライセンス署名ウェブページ

また、あなたが取得する場合 このインストール・コードは、ライセンスで許可されている以上のシステムで使用されています登録エラーが、それはあなたが最後にABACUSを登録しているため、ローカルマシンが再構築されているか、他のユーザーのライセンスキーを登録しようとしている可能性があります。お近くのそろばん管理者に連絡してくださいまたは Avolutionサポート .

インストール・コードが既に使用されています

5。 クリック [OK]登録されている場合、正常にABACUSはで開く必要があります ようこそ画面 .

参照してください

Avolutionサポート | ABACUSは何をするのでしょうか？


ABACUSのインストールの前提条件

ナビゲーション：リファレンス>

ABACUSのインストールの前提条件

コメントを送信 このトピックに関する。

VisioのインポートおよびExcelのインポート/エクスポートに関する情報

ABACUSは、Microsoft OfficeがExcelインポート/エクスポートおよびVisioインポート操作を実行するためにインストールする必要があります。それを確認してください Microsoft Office 2003の以降正しくインストールされています。あなたは、さらに問題が発生した場合、接触 Avolutionサポート .

VisioのインポートおよびExcelのインポート/エクスポート操作を実行するためには、ABACUSは、Microsoft Officeプライマリ相互運用機能アセンブリ（PIAの）を使用します。 ABACUSは、現在、Excelのインポート/エクスポートおよびVisioインポートを実行するために必要なアセンブリをパッケージ化しています。

SQL Serverのインポートに関する情報

ABACUSは、Microsoft SQL Server 2005を必要とします2008年、2008、2012または2014SQL Serverから新しいプロジェクトを開始するために設置されています。それを確認してください Microsoft SQL Serverの20052008年、2008、2012または2014正しくインストールされています。あなたは、さらに問題が発生した場合、接触 Avolutionサポート .

3Dビジュアライゼーションを開くエラー

ABACUS 3D Viewerはあなたのために動作しない場合は、SlimDX DirectXのランタイム（フルABACUS EXEインストールの一部としてインストール）をされないことがあります。これは、ダウンロードすることができます ここに 。あなたは、Windowsの64bit版を持っている場合は、インストールする必要があるかもしれません この .

エラー 編集 ABACUS カスタム レポート

編集ABACUS「カスタムレポートは、レポートビルダー3.0をインストールする必要があります。 ABACUSとレポートビルダは、Microsoftの.NET Frameworkの4.0に基づいて構築され、それらの両方は、Microsoftの.NET Frameworkの3.5を必要としない一方で、Microsoftが間違ってMicrosoftの.NET Frameworkの3.5がインストールされている場合にのみ続行するには、レポートビルダのMSIを設定しています。

したがって、AvolutionはMicrosoftの.NET Frameworkの3.5を必要としない、レポートビルダーのインストールMSIファイルの編集されたバージョンを持っている、これはダウンロードすることができます ここに .

元のMicrosoftレポートビルダのMSIをダウンロードすることができます ここに 。あなたはすでにそれが必要になりますは、Microsoft .NET Framework 3.5を持っていない場合、あなたはそれをダウンロードすることができます ここに 。注：複数のインストールの場合は、オフラインからMicrosoftの.NET Frameworkの3.5のインストールを ここに より適切な場合があります。


コマンドラインオプション

ナビゲーション：リファレンス>

コマンドラインオプション

コメントを送信 このトピックに関する。

あなたは、最も一般的な操作は特定のプロジェクトファイルを開いて、HTMLにそれを公開していると、コマンドラインから直接様々なそろばん操作を行うことができます。

具体的には、以下のようABACUSのコマンドラインの使用があります。

ABACUS.exe ProjectFile【OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ユーザ "ユーザ" / "PASS"を渡します]

引数 | 説明
ProjectFile | ProjectFileはABACUSプロジェクトファイル（.abacus）、ライブラリファイル（.abacuslib）、XMLファイル（.xmlファイル）またはMS Accessのデータベース（.mdb）、および指定されたファイル（開かれますのいずれかのいずれかであることができる場合.abacusまたは.abacuslib ）、または作成した新しいプロジェクト（.xmlファイルまたは.MDBファイルの場合）。
OptionalFile | .abacusscript、.vbの場合（OptionalFileはABACUSスクリプト（.abacusscript、の.vbまたは.csファイル）、マクロ（.abacusmac）またはライブラリファイル（.abacuslib）のいずれかにすることができ、指定したファイルがProjectFileを開いた後に実行されるのいずれか単にまたは.csファイルまたは.abacusmac）または開かれた（.abacuslib場合）。
/ exitOnCompletion | ABACUSを終了し、必要に応じては、任意のスクリプトやマクロの完了時にオープン.abacusプロジェクトへの変更を保存し、コミットされます。 注：このフラグは、大文字と小文字が区別されるので、示されるように、テキストに大文字 'O'と 'C'を使用してください。
/ dontShowDialogs | プロジェクトを開いたときに表示からABACUSエンタープライズエディション（EE）更新通知ダイアログを防ぐことができます。 注：このフラグは、大文字と小文字が区別されるので、示されるように、テキストに大文字 'S'と 'D'を使用してください。
/ユーザ "USER" / "PASS"を渡します | ユーザ名USERとパスワードPASSが保存されたユーザーの資格情報を上書きする、とプロジェクトへのログインに使用されます。注：二重引用符は、ユーザーの周囲に配置されなければならないとPASSフラグと2つの二重引用符は、USERまたはPASSフラグのいずれかで二重引用符をエスケープするために使用することができます。

例えば。;

ABACUS.exe「データ\ Example.abacus ""スクリプト\PublishExample.VB"/ exitOnCompletion / dontShowDialogs /ユーザ "公共" / "123456"を渡します

いつ どこディレクトリから実行 ザ・ ABACUS.exe バイナリ あります 位置して 意志 オープン 例プロジェクト 記載されているように（パスワード123456を持つユーザーとしてログイン公開 ここに ）、）例えば、「更新成功」またはエンタープライズプロジェクトのための「いいえ更新が利用可能 '（すべての道に沿って任意のダイアログを表示せずにプロジェクトを閉じHTMLにそれを公開し、.

例えば。;

ABACUS.exe「データ\ Example.abacus ""スクリプト\カタログExcelのインポート.VB"/ exitOnCompletion / dontShowDialogs

いつ どこディレクトリから実行 ザ・ ABACUS.exe バイナリ あります 位置して 意志 オープン 例プロジェクト そして道に沿って任意のダイアログを表示して、終了時にプロジェクトを閉じずにMS Excelのプロジェクトの「2014実際の「アーキテクチャの「サーバのカタログにファイル」（2014年実績）の.xlsxがサーバー」をインポートします。操作は、プロジェクトに変更を加えた場合は閉じるときに変更がローカルに保存され、エンタープライズプロジェクトがEnterprise Serverにコミットしている場合.

注意

標準のASCII文字セットだけ正しいもので正常に動作するWindowsのコマンドプロンプトでいくつかあるとして正しい二重引用符を使用してください。正しい二重引用符文字コードが10進数の34（16進数22）.これには、そこからそれをコピー/ペースト気軽に上記の例で使用されるものです。


タイトルページ

ABACUS

免責事項

Avolution Pty Ltdは、本マニュアルに関して一切の保証責任を負いませんと、法律により許容される最大限の範囲に、明示別では、このマニュアルの置き換えを暗示することができる任意の保証の違反に対して、その責任を制限しています。さらに、Avolution Pty Ltdは、リビジョンのすべての人に通知する義務を負うことなく、随時、この文書を改訂する権利を有します。

コピーライト

著作権2001-2015Avolution Pty Ltdのすべての権利を保有。

商標

Avolution Pty Ltdは、このマニュアルに記載されている会社名、製品やサービスに関する商標情報を提供するためにあらゆる努力をしてきました。以下に示す商標は、様々な供給源から得られました。

Microsoft Windowsの、アクセス、 Visioの、エクセル、SQL ServerとのInternet ExplorerMicrosoft Corporationの商標または登録商標です。

一般的な注意事項：

このマニュアルで使用されている一部の製品名は識別のみを目的として使用されており、各社の商標である場合があります。

2015年12月Avolution ABACUSバージョンエディション 4.5.

マニュアル改訂1.0

、生成されたプリント、およびオーストラリアで結合しました。