Kāda ABACUS darīt?

Navigation: Ievads ABACUS>

Kāda ABACUS darīt?

Nosūtīt komentārus par šo tēmu.

Lai saņemtu palīdzību citās valodās / tulkojumi lūdzu, noklikšķiniet šeit .

ABACUS ņem uzminēt-darbu no nodarbojas ar risinājumu, sistēmām, programmatūru, informācijas, tehnoloģijas, biznesa procesu un / vai veselu uzņēmumu (sauktas arhitektūras). Tas var palīdzēt jums, lai pragmatiski projektēt, uzraudzīt, simulēt, analizēt un vizualizēt savu arhitektūra modelējot to, analizējot to intuitīvu veidos (piemēram, kartes, diagrammas un 3D) un pēc tam izvērtējot to pret saviem nefunkcionālās prasības.

Piezīme

Nefunkcionālās prasībasir šīs prasības, kas nav tieši saistīti ar to, kā produkts darbojas. Tā vietā, tie ir saistīti ar to, cik labi tas darbojas. Nefunkcionālās prasības ietver tādas lietas kā veiktspēju, atvērtību, evolvability, kvalitāti, mērogojamību, modularitāti, utt (atšķirībā no funkcionālajām prasībām, piemēram, ieslēgt šo gaismu, kad šī poga ir noklikšķinājuši). Tradicionāli, nefunkcionālās prasības ir grūti - ja ne neiespējami - izmērīt. Patiesībā, ABACUS ir vienīgais produkts, kas var objektīvi un kvantitatīvi izmērīt pirmo trīs - sniegums, atklātība, Un evolvability.

Vienkārši runājot, jūs ievadiet arhitektūru un to, ko jums nepieciešams to darīt. ABACUS tad stāsta jums, ja tā darīs, kā to pieprasa un norāda jebkādus trūkumus vai nepilnības.

ABACUS pamatā ir vairāk nekā 20 gadu sistēmu pētījumu un vēl daudz vairāk gadiem izveidotā sistēmu teorijas. Tas dod jums kvantitatīvi, ticamu, objektīvu atbildes, lai jūs neesat paļaujoties uz subjektīvo vērtējumu.

ABACUS stendi Architecture-Based AANALĪZE, Communication un UZPRATNE PAR Eno Systems. Tas var palīdzēt jums ar jebkuru liela mēroga arhitektūru, bet tas parasti izmanto četras (4) lietas:

· Attīstāsstrāvas arhitektūra. Piemēram, ja jūsu esošo arhitektūra trūkst sniegumu, ABACUS būs vizualizēt arhitektūru jums, identificējot problēmas (vājās vietas, uc), tad pateiks, tieši tākā uzlabot arhitektūru.

· Projektēšanajauna arhitektūra. Piemēram, ja jums ir nepieciešams pilnīgi jaunu arhitektūru, un jūs projektēšana pats, ABACUS pateiks tieši tākādi komponenti jums nepieciešams un kā tās būtu savienotas.

· Purchasingjauna arhitektūra. Piemēram, ja jums ir aicinājuši uz konkursu par dizainu jaunā arhitektūra, un jūs izvēlēties starp trim dizainu, ABACUS pateiks tieši tākuriem viens ir piemērots jūsu prasībām vislabāk.

· Apvienojotspēkā esošās arhitektūras. Piemēram, ja jums ir nepieciešams apvienot divus vai vairākus atsevišķus arhitektūras, ABACUS palīdzēs jums.

Skatīt arī

Kā jūs to darīt (Pārskats) | Kas ir arhitektūra? | Kā ir arhitektūras pārstāvēta ABACUS?

© 2001-2015 Avolution Pty Ltd Visas tiesības aizsargātas.


Kā lietot Abacus (pārskats)

Navigation: Ievads ABACUS>

Kā lietot Abacus (pārskats)

Nosūtīt komentārus par šo tēmu.

Šī tēma sniedz pamata pārskatu par iesaistīto ar izmantojot ABACUS uzdevumiem.

Nākamajā diagramma ilustrē arhitektūras bāzes analīzes procesu, kas ABACUS paredz attīstās pašreizējo arhitektūru uz jaunu vai mērķa arhitektūru.

Abacus Process

Lai izmantotu ABACUS:

1. Audit - Pirms lietojat Abacus, jums ir apkopot visu informāciju, jums ir par arhitektūru un tās prasībām.

· Arhitektūra - Identificēt iespējamās sastāvdaļas arhitektūras un kā tie mijiedarbojas. Ir jābūt tikai dažas detaļas augšpusē līmenī. Tos sauc par "būtiskas sastāvdaļas". Pat vissarežģītākās arhitektūras jābūt mazāk nekā 10 būtiskas sastāvdaļas. piem Būtiskās sastāvdaļas apdrošināšanas sabiedrības arhitektūru var būt politikai, kvītis, pretenzijas, un maksājumi.

· Prasības- Jums ir jāzina, kas tiek sagaidīts no arhitektūras, lai noteiktu, vai tas ir apmierinoša. piem Darījumu skaits stundā.

· Ja jūs atrast? - Šī informācija var nākt no prasību specifikācijas, projektēšanas dokumentiem, intervijas ar ieinteresētajām personām, izvērstajā kodu utt Būtībā jebkurš materiāls, kas ir pieejams piedāvā Abacus informāciju par arhitektūru.

2. Apdzīvot -Izmantojiet Abacus modelēt savu arhitektūru un precizētu prasības arhitektūra mērīs.

· Arhitektūra - In ABACUS sākat veic ar tukšu arhitektūra - Jums ir apdzīvottā. Tas nozīmē, ievadot visu arhitektūras informāciju jūs savākta iepriekš. Jūs varat aizpildīt savu arhitektūru manuāli (izmantojot peles labo pogu noklikšķiniet uz izvēlnes), vai arī jūs varat aizpildīt to automātiski (no Microsoft Visio, Excel, Access uc). Parasti top-visvairāk līmenis (vairāk abstrakts) arhitektūras tiks apdzīvots ar rokām, un zemākie līmeņi (vairāk betona) tiks apdzīvots automātiski.

· Prasības - Kā jūs pievienot savus komponentus un savienojumus, jūs norādāt to īpašības. Vairumā gadījumu šīs īpašības būs arhitektūras prasībām. Piemēram, ja jums būs 1250 MIPS mezglu / kopu, jūs varētu pievienot mezglā kā sastāvdaļu, tad pievieno sniegumu īpašumu, un piešķirt vērtību 1250 MIPS.

3. Analizēt - Izmantojiet Abacus lai eleganti analizēt un vizualizēt sarežģīto struktūru jūsu arhitektūru.Jūs var analizēt savu arhitektūru vairākos veidos vai no vairākiem skatpunktiem, ieskaitot diagrammas, 3D un Explorer. Alternatīvi jūs varētu vēlēties izmantot dažas konkrētākas viedokli šādi:

· Diagramma savu arhitektūru - lai iegūtu veiktspēju (reakcijas laiks, joslas platums, uc), izmaksas (bārs, pīrāgs, uc) vai evolvability (spējas telpa, kompromiss, uc) viedokli.

· Izveidojiet pārskatu par savu arhitektūru.

4. Simulēt - Izmantojiet Abacus lai modelētu savu arhitektūru veiktspēju, pieejamību, izmaksām, atvērtību, utt

· Lai to izdarītu, palaist vienu no simulatori. ABACUS izvērtē Jūsu arhitektūra pret savām prasībāmveicot simulāciju. Tas skan un analizē pašreizējo arhitektūru, iet simulācijas, un aprēķina dažas jaunas īpašības. Šīs īpašības tiek saglabātas pēc tam atpakaļ uz arhitektūru. Jaunās īpašības ir dati jūs mēģināt analizēt, piemēram, izmantošanas, reakcijas laiks, joslas platums,% pieejamību, TCO uc

5. Inženieris- Izmantojiet ABACUS atbildēt dažādas "Ko darīt, ja" scenāriju un kontrolēt evolūciju savu arhitektūru. Engineering ir process, atkārtojot Aizpildīt - Analizēt - Stimulētcikls.

· Šajā brīdī, jums'veIespējams izstrādāja izpratni par pašreizējo Arhitektūras un uzsvēra jomas, jums ir nepieciešams attīstīties. Diezgan bieži, tomēr, jums vajadzēs atkārtot aizpildīt - Analizēt - imitē procesu vairākas reizes. Tas būs iespējams, jo tas var aizņemt pāris atkārtojumiem, pirms jūs atrast mērķi arhitektūru. Arī tad, ja jūsu arhitektūra ir ļoti sarežģīts, jūs varat atkārtot procesu katram arhitektūras "līmenī".

6. Plānsnākotne savu arhitektūru, izmantojot ar ABACUS sniegto informāciju.

Piezīme

Ja jūs neesat mēģināt attīstīties esošo arhitektūru, jums var būt nepieciešams atkārtot dažus pasākumus, vairākas reizes, un citā secībā. Tas atkarīgs no tā, ko jūs mēģināt darīt. Piemēram, ja jūs projektējot jaunu arhitektūru, jūs, iespējams, tikai aizpildīt savu arhitektūru vienreiz, un pēc tam izmantot Abacus ilgā laika periodā, lai vadītu turpmāko attīstību (-us) arhitektūru. No otras puses, ja jūs pērk jaunu arhitektūru un ir vairākas alternatīvas, no kuriem izvēlēties, jums būs nepieciešams atklāt un aizpildīt par katru no alternatīvām, un pēc tam analizē un simulēt katrs neatkarīgi pirms veikt galīgo salīdzināšanu tajā beigas.

Skatīt arī

Kāda ABACUS darīt? | Kas ir arhitektūra? | Kā ir arhitektūras pārstāvēta ABACUS? | Aizpildi savu arhitektūru | Analizējot savu arhitektūru | Imitē savu arhitektūru


Kas ir arhitektūra?

Navigation: Ievads ABACUS>

Kas ir arhitektūra?

Nosūtīt komentārus par šo tēmu.

Arhitektūra ir abstrakts jēdziens- Ne fiziski lieta. Tā ir bagāta un pilnīgu aprakstu vai izpratni par struktūru sistēmu - notveršanā sastāvdaļas un kā viņi savienots (mijiedarboties). Tā kā jēdziens arhitektūra ir tik visaptverošs, tā ir būtiska izmaksu, pieejamību, evolvability, atvērtību un sistēmas darbību. Stabila arhitektūra ir priekšnoteikums par skaņas sistēmu.

In ABACUS, jums modelēt savu arhitektūru. Vienkāršības labad mēs saucam arhitektūras modelis arhitektūras.

Diagrammā uzskatāmi parādītas tipisku arhitektūru 5sastāvdaļas (hierarhijā) savienota ar 2 savienojumiem. Etiķetes norāda vārdus dota dažādām daļām arhitektūras ABACUS.

Vienkāršs arhitektūra

ABACUS uzskata, visas šīs lietas ir daļa no arhitektūras:

· Sastāvdaļaspārstāvēt vienības savas arhitektūras ko jūs varētu aprakstīt kā "lietas". Par apdrošināšanas sabiedrības, sastāvdaļas varētu būt sistēmas pārstrādes politiku, prasījumi, maksājumiem un ieņēmumiem.

· Savienojumipārstāvēt attiecības starp šiem komponentiem. Piemēram, apdrošināšanas sabiedrība, kvītis tiek ģenerētas derīgu politiku, tiek apgalvots, pret derīgām politiku un spēkā esošos prasījumus izraisīt maksājumiem. Domājot arhitektoniski - īpaši, ja izmantojat ABACUS - savienojumi ir tikpat svarīga kā detaļām, un tie ir aplūkoti gandrīz identiskā veidā.

· Viss kokā var būt Properties. Properties ir lietas, piemēram, kā jums nepieciešama jūsu sistēma, lai veiktu skaits koda rindiņas tas ir procentuāli no šīm līnijām, kas ir komentāri, uc ABACUS uzskata, visas šīs lietas ir daļa no arhitektūras.

· Izmantojot hierarhijas(t.i. apakškomponenti un sub-savienojumi), Jūs varat paslēpt informāciju un de-sacerēt savu arhitektūru. Abacus arhitektūras modelis ir ļoti elastīga. Jebkura sastāvdaļa jebkurā līmenī, var būt saistīts ar jebkuru citu sastāvdaļu jebkurā citā līmenī jebkura pieslēgumu jebkurā līmenī.

· Pieķeršanāsir darbība, ar kuru komponenti ostām ir pienākums pieslēgumulomas. Ports un Lomas ir interfeisssstarp sastāvdaļām un savienojumiem. Tie tiek izmantoti, lai pievienotu savienojumus ar sastāvdaļu. Savienojumi ir avots un izlietne loma(atvieglojot datu plūsma no avota sastāvdaļu, izlietnes sastāvdaļas)un konceptuāli, sastāvdaļas ir ostas. Vienkāršības labad, tomēr ABACUS komponentu ostās netiek parādīta un savienojuma lomas ir tieši pievienoti komponentiem paši.

· Komponenti un savienojumi ar noteiktu Type. Tas ir galvenokārt par klasifikācijas nolūkos. Piemēram politikām, pretenzijas, maksājumi un ieņēmumi ir sastāvdaļas tipa "sistēma". Derīgi politika, derīgas norādes, utt savienojumi Tipa "darījums". Tips piešķirts komponentu vai savienojumu nodrošina paraugu īpašībām un standartiem tas ir. Tā, piemēram, servera komponentu tips varētu būt "veikt & modelis" standartsun IP adrese īpašums. Atšķirībā no citām cietām darbarīkiem ar pamata relāciju datu bāzē (RDB) back-end, jo ABACUS jūs varat brīvi izveidot savu jauno veidi un piešķir savas kombinācijas īpašības un standartus, lai tiem.

· Standarta bibliotēkas īpašības var noteikt un piešķirt kaut kas cits šajā arhitektūrā. Šīs bibliotēkas ir pazīstami kā Standarti. Izmantojot Standarti, Jums tikai nepieciešams apkopot konkrētus sistēmas īpašības - standarta īpašības ir jau tur. Piemēram standarta darbības raksturojums Microsoft Windows 2000 var piešķirt, lai neatkarīgi no sastāvdaļām ir, izmantojot Microsoft Windows 2000 operētājsistēmu.

Skatīt arī

Kā ir arhitektūras pārstāvēta ABACUS? | Kāda ABACUS darīt? | Kā jūs to darīt (Pārskats) | Radīt jauna veida


Abacus saskarne

Navigation: Ievads ABACUS>

Abacus saskarne

Nosūtīt komentārus par šo tēmu.

Kad jūs sākat Abacus, jūs redzēsiet galveno ekrānu, kas ir tukša, izņemot izvēlnes un rīkjoslas augšpusē, tukšā Explorer logā un nosaukums-bārā. Šis ekrāns būs rumbas jūsu mijiedarbību ar ABACUS.

Galvenie elementi ir:

· Galvenās izvēlnes

· rīkjoslas

· labo klikšķi izvēlnē

· Explorer un īpašuma logi

· statusa joslā

Galvenās izvēlnes

Izvēlnes ir sakārtotas loģiskā secībā.

Izvēlnes ir aprakstīti šādi:

· Izvēlne Fails- Izvēlne File ļauj izveidot, atvērt, aizvērt, saglabāt, eksportēt un publicēt ABACUS failus. Tas arī ļauj jums izveidot, atvērt, aizvērt un saglabāt ABACUS bibliotēkas failus.

· Izvēlne Edit- Izvēlne Edit ļauj samazināt, kopēt, ielīmēt, dzēst, pārdēvēt, atrast un kārtot elementusun undo / redo operācijas.

· Izvēlne Skats- The View izvēlnē ļauj atvērt vai aizvērt dažādi interfeiss Windows un statusa joslu, Virzītos uz priekšu un atpakaļ, iet uz konkrētiem viedokļiem un pārvaldīt paneļus.

· Ievietot izvēlni- Ieliktni izvēlne ļauj pievienot jaunu standarti, Veidnes, veidi, elementi, viewpunktss, Katalogi, diagrammas, grafiki, Ziņojumi un matricas.

· Analīze ēdienkarte- Analīzes izvēlne ļauj jums vadīt novērtējumus pret arhitektūru, ieskaitot; sniegumu, izmaksas, uzticamība, modularitāte un atklātība.

· Menu Tools- Izvēlne Tools ļauj palaist skriptu, izvirzītos mērķus attiecībā uz arhitektūruun veikt un arhitektūra "diff '. Jūs varat arī mainīt programmas iespējas un pielāgot interfeisu no rīku izvēlnē.

· Logu ēdienkarte- Logu izvēlne ļauj doks, sakārtot, parādīt un paslēpt windows jums ir atvērts.

· Help menu- No Help izvēlnē var piekļūt šim ABACUS palīdzības failu. Jūs varat piekļūt mājas lapā, skatīt savu licence līgums un apskatīt vispārēju informāciju par ABACUS tostarp programmatūras versiju un Abacus atbalsta un kontaktinformāciju. Jūs varat sniegt atgriezenisko saiti, izmantojot jautājums paziņošanas lapā. Ja nepieciešams, jūs varat ievadīt reģistrācijas atslēgu izmantojot izvēlnē Palīdzība.

Tas ir rīkojums jūs parasti sekot, ja jūs esat veicot savus uzdevumus;Kad esat izveidojis vai atvērta fails, Jūs parasti aizpildīt savu arhitektūru, tad skatstā (Explorer, diagrammas, 3D, diagrammas, utt). Šajā brīdī, jums ir vai nu palaist vērtētājaVai jūs atkārtojiet procesu ar to pašu arhitektūru vai citu arhitektūru. (Skat Kā lietot Abacus (pārskats) sīkāku informāciju.)

Vai paskatīties caur galvenās izvēlnes un mēģināt iedomāties, kā jūs pieteikties tos jūsu sistēmā.

Piezīme

Tu vari Pielāgot jūsu izvēlnes jebkurā laikā.

Par rīkjoslas

Pēc noklusējuma ir šādas rīkjoslas;

· Main rīkjosla -

· Simulācija rīkjosla -

· skatīšanās rīkjosla -

· Diagramma rīksbar (ja diagramma ir atvērts) -

· Makro Ierakstīšana rīkjosla -

Vai paskatīties caur pogām katrā rīkjoslu, lidinājās pār tām, lai redzētu rīks-tip (īsceļu-atslēgu).

Piezīme

Tikai dažas pogas būs aktīvs, atkarībā no tā, ko esat izvēlējies ar Explorer logā, un jūs varat Pielāgot savu rīkjoslas jebkurā laikā.Bez tam, "Apstiprināt / Check projektam ierobežojumiem" pogu uz galvenās rīkjoslas un pogas uz simulācijas rīkjoslā izcelt Sarkans ja izmaiņas pamata glabātuvē prasa atkārtotu apstiprināšanu projekta vai šī simulatora atkārtotu simulāciju attiecīgi. Lidināties virs pogas, lai redzētu, kas arhitektūras ietekmē.

Tiesības klikšķi izvēlnē

Galvenās izvēlnes un rīkjoslas ir navizmanto visu, though. Tas bieži vien ir ērtāk izmantot labo klikšķi konteksta izvēlni dažādām operācijām. (Arī ne visas komandas, kas pieejamas, izmantojot peles labo pogu ir pieejami, izmantojot galvenās izvēlnes, rīkjoslas vai tastatūras komandas.)

Piemēram, pēc tam, kad esat izveidojis failu, un jums ir koku diagramma savu arhitektūru, tas ir labāk, lai pievienotu jaunu arhitektūru peles labo pogu noklikšķiniet uz arhitektūru kokā. Tāpat, jums vajadzētu pievienot jaunu komponentu peles labo pogu noklikšķiniet uz detaļām. Ar peles labo pogu noklikšķiniet uz dažām lietām kokā, lai redzētu, ko jūs varat darīt.

Gals

Parasti, jūs izmantot galvenās izvēlnes, lai veiktu vairāk augsta līmeņa uzdevumus, piemēram, izvērtējot savu arhitektūru. Ar zema līmeņa uzdevumi - piemēram, pievienojot atsevišķus komponentus un savienojumi - tiek darīts, izmantojot rīkjoslas un / vai labo klikšķi izvēlnē.

Explorer un īpašības logi

Atverot vai izveidot failu, koks diagramma būs redzama Explorer logā. Tas ir logs savā arhitektūrā. Un, kā jūs izvēlaties elementus ietvaros Explorer logā trīs pārējie logi; Vispārējie PropertiesAtsaucesun īpašības logi atjaunina, lai atspoguļotu detalizētu informāciju par savu izvēli.

Piezīme

Vispārējie PropertiesAtsaucesun īpašības logi ir paslēptas pēc noklusējuma. Redzēt Pielāgošana saskarni par to, kā parādīt tos un potenciāli atstāt tos pastāvīgi redzams.

Kamēr jūs veidot savu arhitektūru, pētnieks un Properties logi ir visnoderīgākā pārstāvība. Tāpēc, ka viņi var sabruka un paplašināta, kā paredzēts, un tie nekļūst apgrūtinošas.

Explorer logs ir koka (un statusa josla) un Properties logiem ir 5sadaļas:

· Type

· Standarti

· Apraksts

· Atsauces

· Properties

ABACUS uzskata, visas šīs lietas ir daļa no arhitektūras.

Koks

Šī sadaļa ir koks sagrupēti 3 zonās sekojoši:

1. Meta-modelis

· Standarti- Ja daudzās sastāvdaļas ir pašu kopu īpašības, jūs varat definēt, kas izveidota, priekšā, un tad tikai piešķirt to sastāvdaļām. Tas pats attiecas uz savienojumiem un kādu citu elementu. Šie komplekti standarta īpašības tiek glabāti Standartifiliāle koku. Tā vietā, nosakot katru īpašumu katram komponentam, un katru īpašumu par katru pieslēgumu uc, tikai piešķirtu standarts. Piemēram standarta īpašības Unix-HP / UXvar saglabāt kā Standarts un piešķirts jebkādiem komponentiem kas izmanto Unix-HP / UXoperētājsistēma kā parādīts par OS01 serveris screenshot iepriekš.

· Veidi - Šī koka zars ir bibliotēka veidiem sastāvdaļu un savienojumu jūs varat izmantot. Veidi tiek izmantoti, lai noteiktu meta-modeli savu arhitektūru un klasifikācijas un filtrēšanu, apskatot savu arhitektūru. Tās arī nosaka veidni, ko standarti, Īpašības un ierobežojumi jūsu sastāvdaļas / savienojumi var būt.

· Viedokļi- Skatspunktss var izveidot no esošajiem diagrammām un to var izmantot, lai radītu jaunas shēmas.Tie ir diagramma stencils.

· Veidnes - Veidnes veikals re-izmantojamu komponentu modeļi un savienojumi kopā ar veidu, kādā tie tiek pārstāvētas vai apskatīt. Tās var uzlūkot kā "Mini" arhitektūrām vai risinājumu, kas var ievietot esošajiem arhitektūras.

2. Arhitektūras -Par arhitektūras filiāle koku ir vieta, kur jums veidot arhitektūra (-i) no jūsu sistēmā. (To sauc aizpildi arhitektūru.) Jūs varat būt jebkurš arhitektūras skaits vienā ABACUS failā.

3. Paneļi - Par paneļi filiāle koks ir vieta, kur jūs varat piekļūt saglabāto paneļi par projektu.

Piezīme

Preces Explorer koka, kas ir bijusi viņu Atjaunināt atļauja izņemta (ti, tie ir tikai lasāmi) ir parādīti pelēkā krāsā.

Type

Šajā sadaļā norāda uz konkrēto komponentu vai pieslēguma veida pašreiz izvēlētā elementa koku.

Standarti

Šajā sadaļā ir sniegts saraksts no standarti pašlaik izvēlētā elementa koku.

Apraksts

Šajā sadaļā ir sniegts īss apraksts par izvēlētā elementa koku. Jebkuras saistītie hipersaites var pievienot arī šajā sadaļā. Tie ietver mājas lapas vai vietējās absolūtā ceļus norāda uz papildu informāciju par konkrēto elementu. Vairāki līnijas arī atļauta. Derīgas hipersaites jāsāk ar vienu no 5 stīgas; http: //, https: //, ftp: //, file: /// vai mailto :.

Gals

Par hipersaites ar atstarpēm, lietotāji var ierakstīt URL vai ceļš, izvēlēties nepieciešamo tekstu un Labo klikšķi| Hipersaite. Tas mainīsies jebkādus telpām % 20tāpēc visa URL vai ceļš darbosies pareizi.

Izveidots un modificēti

Tie sekcijasnodrošinātlietotājs un datuma / laika radīšanai, un pēdējā modifikācija, lai, pašlaik izvēlētais elements kokā.

Atsauces

Šajā sadaļā ir sniegts saraksts no izejošo un ienākošo sastāvdaļas pašlaik izvēlētā elementa koku.Tas arī parāda diagrammas, 3D un viedokļus diagramma, kas pašlaik izvēlētais elements parādās. Ja ir izvēlēts diagramma tas liecina viedokli ja piemērojams diagrammā un viedokļiem kopumā tas liecina par visām paneļi viedoklis parādās in. Un, kad Standard tiek izvēlēts koks tas parāda izmantošanu standarta pa veidiem, detaļām un savienojumiem.

Properties

Šī sadaļa ir, ja jūs noteikt tās īpašības elementi robežās Jūsu arhitektūra, tāpat kā jūs to prasa veikt, skaitu koda rindiņas tas ir procentuāli no šīm līnijām, kas ir komentāri, uc

Par "ievadi" un "izejas" īpašībām pre-built simulatori tiks parādīts Properties loga ar īpašuma ievades rinda atlasītājs ikonas ( [image] ) Un izejas ikona ( [image] ), Attiecīgi ar rīka padoms, norādot, kas pre-built simulators īpašums ir saistīts ar, piemēram, "Modularitāte Output" vai "Performance Input". Bulta uz izejas ikonas izcelt Sarkans ( [image] ) Ja īpašums ir novecojusi sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā ar simulatora pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Statusa josla

Kreisā daļa statusa joslā rāda pilnu ceļu uz pašlaik fokusā repozitorija elements, vai nu izvēlas Explorer logā vai uz diagrammaaudekls. Tas ir tā, ka precīza vieta glabātuvju hierarhijā par dotā elementa vienmēr var viegli noteikt. Labajā daļa statusa joslā rāda dažādas operatīvās ziņas, piemēram, "Atvērtā ABACUS Fails Veiksmīga" un "izmaksu aprēķina Pabeigts".

Skatīt arī

Kā jūs to darīt (Pārskats) | Pielāgošana saskarni | Kas ir arhitektūra? | Kā ir arhitektūras pārstāvēta ABACUS? | Darbs ar failiem ABACUS


Pielāgošana Abacus interfeisu

Navigation: Ievads ABACUS>

Pielāgošana Abacus interfeisu

Nosūtīt komentārus par šo tēmu.

Jūs varat mainīt izskatu un uzvedību ABACUS interfeisu daudzos veidos. ABACUS ietver vairākas iepriekš noteiktiem iestatījumiem kombinācijas, kuras varat izmantot, lai piemērotu grupu pielāgojumus saskarni. Turklāt, jūs varat veikt atsevišķus pielāgojumus uz posteņiem, piemēram, logiem, rīkjoslas, īsceļu taustiņi, un dažādas displejiem iespējām.

Organizēt un Dock Windows

Jums ir daudzas iespējas, organizējot logus ietvaros interfeisu ABACUS, tostarp šādus:

· Tab dokā logi.

· Dock logi uz malas rāmja interfeisu.

· Samazinātu instruments Windows gar malu interfeisu.

· Reset logu izvietojumu noklusējuma izkārtojumu.

Docking Windows

Kad logs ir Dockable, tas var piestiprināt uz vienu pusi no rāmja ietvaros interfeisu vai tas var tikt izvietoti uz tabbed rūtis rāmī. Ceļvedis dimants parādās, kad velkat logus no to pašreizējās atrašanās vietas uz citu vietu interfeisu. Ceļvedis dimanta ļauj ātri atjaunot doks logs uz vienu no četrām pusēm rāmja vai pilsētas centrā, kā tabbed rūts. Ja logs ir undocked vai nav dockable, tas pludiņiem virs citiem logiem.

Doks logus

1. Noklikšķiniet uz loga, ko vēlaties, lai doks, lai dotu to koncentrēties.

2. Uz Logsizvēlne, noklikšķiniet uz Dockable.

3. Velciet logu no savas pašreizējās atrašanās vietas uz kadra vidū vēlaties doks to ar.

Parādās guide dimantu. Četri bultas dimantu punkta uz četrām malām rāmi un centra pārstāv tabbed rūti.

Gals

Lai pārvietotu dockable logu bez bojājumiem to vietu, nospiediet taustiņu kombināciju Ctrl velkot to.

4. Kad logs esat velkot sasniedz stāvokli, kurā vēlaties doks to, novietojiet rādītāju virs atbilstošo daļu no orientējošās dimantu. Izklāsts loga parādās norādītajā apgabalā.

5. Doks logu stāvoklī norādītajā, atlaidiet peles pogu.

Piemēram, ja Pētnieksir pietauvots uz kreiso malu saskarni, un jūs vēlaties, lai doks to uz labo malu, jūs varētu vilkt Pētnieksvidusdaļā saskarni, novietojiet rādītāju virs labajā pusē orientējošās dimants, un pēc tam atlaidiet peles pogu.

Samazināšana Windows

Windows (vai tie ir rīks Windows - parādās uz Skatsizvēlni, vai dokuments Windows - parādās uz Logsizvēlne) atbalsta funkciju sauc Auto Hide. Auto Hide ļauj jums redzēt vairāk par savu arhitektūras vienā reizē līdz minimumam samazinot logus gar malām saskarni, kad to nelieto.

Lai ieslēgtu Auto Hide

1. Noklikšķiniet uz loga, ko vēlaties paslēpt, lai dotu to koncentrēties.

2. Uz Logsizvēlne, noklikšķiniet uz Auto Hide.

- Vai -

2. Noklikšķiniet uz spraudīte ikonas virsrakstjoslā loga.

Auto Hide Enabled

Kad auto-slēpts logs zaudē fokusu, tas automātiski slīd atpakaļ uz tās izcilni uz malas interfeisu. Kamēr logs ir auto-slēpta, tā nosaukums un ikona ir redzami uz cilnes malā interfeisu. Lai parādītu auto-paslēptas logu, pārvietojiet kursoru virs cilnes. Logs slaidi atpakaļ skatu un ir gatavs lietošanai.

Piezīme

Logs, kas ir auto-slēpta nevar docked. Doks logu jums būs nepieciešams, lai izslēgtu automātisko Slēpt kā aprakstīts tālāk.

Lai izslēgtu automātisko Slēpt

1. Noklikšķiniet uz loga, ko vēlaties paturēt redzams dot to koncentrēties.

2. Uz Logsizvēlne, noklikšķiniet uz Auto Hidelai notīrītu atzīmi.

- Vai -

2. Noklikšķiniet uz spraudīte ikonas virsrakstjoslā loga.

Auto Hide Invalīdu

Gals

Windows, kas ir automātisko Slēpt ļāva īslaicīgi ieslīdēt domām, ja logs ir fokusu. Lai paslēptu logu, izvēlieties objektu ārpus pašreizējā logā. Kad logs zaudē koncentrēšanos, tā slaidi atpakaļ no skatu.

Atiestatīšana Windows izkārtojumi

Jūs varat atgriezties interfeisu noklusējuma loga izkārtojumu, izmantojot Reset Window Layoutkomanda. Palaižot šo komandu, šādi pasākumi notiek:

· Visi logi ir pārvietoti uz to noklusējuma pozīcijām.

· Windows, kas ir slēgti ar noklusējuma loga izkārtojumu ir slēgti ar komandu.

· Windows, kas ir atvērta noklusējuma loga izkārtojumu, ir atvērta ar komandu.

· Windows, kas ir paslēptas / redzamas noklusējuma loga izkārtojumu tiek pieņemti slēptā / redzama ar komandu.

Lai atjaunotu logu izvietojumu noklusējuma izkārtojums

1. Uz Windowsizvēlne, noklikšķiniet uz Reset Window Layout.

Pielāgošana Izvēlnes un rīkjoslas

Jūs varat mainīt izkārtojumu, vietu un saturu izvēlnes un rīkjoslas interfeisu. Jūs varat pievienot arī pogas uz rīkjoslas un mainīt piešķirto ikonu jebkuru pogu.

Izveidot jaunas rīkjoslas

Lai izveidotu jaunu rīkjoslu

1. Uz Darbarīkimenu, izvēlieties Pielāgot.

2. Iekš Pielāgotdialoglodziņš, izvēlieties Rīkjoslastab.

3. Izvēlēties Jauns.

4. Iekš Jauns Toolbardialoglodziņš, ierakstiet nosaukumu rīkjoslā.

5. Izvēlēties labi.

Lai pievienotu komandu pogu uz izvēlnes vai rīkjoslas

1. Uz Darbarīkimenu, izvēlieties Pielāgot.

2. Iekš Pielāgotdialoglodziņš, izvēlieties Komandastab.

3. Izvēlieties kategoriju un vilkt komandu no dialoglodziņa uz izvēlnes vai rīkjoslas.

4. Izvēlēties Aizvērt.

Gals

Turot nospiestu Alt taustiņu ļauj ātri pielāgot komandas, it kā Pielāgot dialog bija vaļā.

Skatīt arī

Abacus saskarne


Darbs ar failiem ABACUS

Navigation: Ievads ABACUS>

Darbs ar failiem ABACUS

Nosūtīt komentārus par šo tēmu.

ABACUS fails ir konteiners modeli jūsu arhitektūra . Vienā ABACUS failu, jūs varat modelēt jebkuru no arhitektūras numurs neierobežotu skaitu reižu.

Kad jūs pirmo reizi atvērt Abacus, nav faili atvērti. Strādāt pie sava arhitektūra, jums ir vai nu izveidot jaunu failu vai atvērt esošo failu.

Atverot vai izveidot jaunu failu, koks ar Explorer logā automātiski parādīs. Šis pētnieks skats parāda jums jūsu arhitektūru līdz šim. Aizverot failu, koks Explorer logā būs arī pazudīs.

Lai izveidotu jaunu ABACUS failu

1. Atlasīt Fails| New ...

2. New Project Dialoglodziņā, kas parādās (kā norādīts zemāk) Izvēlētiesvai nu izveidot tukšu modeli, modeli no standarts ABACUS bibliotēka , Modelis no pasūtījuma ABACUS bibliotēkā, modelis no XML, MS Access , MS Visio , MS Excel , MS SQL Server , Kas ir Uzņēmums Server modelis vai pielāgotu ABACUS bibliotēka (.abacuslib fails).

3. Klikšķiniet uz labipogu un jāievēro visi dialogs, kas var parādīties.

Gals

Jums nebūs lūgts nosaukt failu, kamēr jūs saglabāt vai tuvu tai. Tā ir laba ideja, lai saglabātu failu, tiklīdz jūs to izveidotu. Tad jums nebūs jāuztraucas par nosaucot to vēlāk šajā procesā, kad jūs koncentrējoties uz citām sarežģītām lietām (piemēram, aizpildi savu arhitektūru).

Izveidot jaunu projektu

ABACUS Standarta Bibliotēkas

ABACUS atbalsta vairāk nekā 100 sabiedriskās sistēmas un notācijas, no kuriem daži ir parādīts zemāk. Izvēloties, lai izveidotu jaunu projektu no standarta bibliotēkas lietotājiem ir ātrs sākums, lai modelēšanai ietvaros noteiktu shēmu, ņemot pilnībā izmantot jebkuru definēto elementu veidiem, atribūtiku, apzīmējumi, viedokļus un veidnes vai modeļus. Papildus standarta bibliotēkas ir brīvi pieejami, izmantojot Avolution Kopienā šeit .

Jaunceltne no standarta bibliotēka

Lai saglabātu jaunu ABACUS failu

1. Atlasīt Fails| Saglabāt kā

Gals

Failu nosaukumi var būt jebkurš garums, un var ietvert jebkādus burtu un ciparu rakstzīmes un atstarpes. Viņi nevar saturēt tildes (~) raksturu, cauruļu (|) rakstzīmi, jautājuma zīmes vai simbolus parasti izmanto ceļa aprakstus, piemēram, slīpsvītru (\) - izņemot, kā daļu no ceļa (?).

Lai atvērtu esošu ABACUS failu

1. Atlasīt Fails| Atvērts

Piezīme

Ja atverat failu no koplietojamā tīkla vietā, kas ir jau atvērta citam lietotājam, ABACUS sniegs jums lasīt tikai piekļuvi. Lietojot Abacus ar lasīt tikai piekļuvi, jūs nevarēsiet veikt rakstīt operācijas, piemēram, aizpildi savu arhitektūru un darbojas vērtētāji. Jūs tomēr varat apskatīt savu arhitektūru, izmantojot Explorer skatu un 3D viedokli.

Skatīt arī

Kā ir arhitektūras pārstāvēta ABACUS?


Kā ir arhitektūras pārstāvēta ABACUS?

Navigation: Ievads ABACUS>

Kā ir arhitektūras pārstāvēta ABACUS?

Nosūtīt komentārus par šo tēmu.

In ABACUS, jums modelēt savu arhitektūru. Vienkāršības labad mēs saucam arhitektūras modelis arhitektūras.

Zemāk redzamā diagramma parāda, kā tipisku arhitektūru 5sastāvdaļas (hierarhijā) savienota ar 2 savienojumi tiktu pārstāvētas ABACUS.

Kā vienkāršs arhitektūra ir pārstāvēta ABACUS

Jums var būt jebkurš no arhitektūras skaits vienā ABACUS failā.

Pirmais arhitektūra kokā

Parasti, jūs varētu izveidot jaunu arhitektūru, ja jūs vēlaties, lai novērtētu izmaiņas. Piemēram, jūs modelēt savu esošo arhitektūru Pirmais - tas būtu pirmais arhitektūras kokā. Jūs varētu to sauc par "Pašreizējais".

Otrais

Ja jūs vēlaties, lai modelētu un novērtēt izmaiņas esošajā arhitektūrā (piemēram, paaugstinātas prasības), jūs vēlaties izveidot jaunu arhitektūru. Vieglākais veids, kā to izdarīt, būtu izveidot kopiju "Pašreizējais" un pārdēvēt to "Evolution 1 Mēģinājums 1". Šī būs jau otrā arhitektūras kokā. Ja jūsu novērtējumi "Evolution 1. Mēģinājums 1 'ir veiksmīgs, jūs varat pārdēvēt to vienkārši" Evolution 1 ".

Trešais

Ja 'Evolution 1 Mēģinājums 1 "neatbilst jūsu prasībām, varat izveidot tā kopiju, pārdēvēt to" Evolution 1. mēģinājums 2 ", un mēģiniet vēlreiz. Tas būtu trešais arhitektūras kokā.

Skatīt arī

Kāda ABACUS darīt? | Kā jūs to darīt (Pārskats) | Kas ir arhitektūra? | Darbs ar failiem ABACUS | Radīt vai dublējot arhitektūru


Palīdzība citās valodās

Navigation: Ievads ABACUS>

Palīdzība citās valodās

Nosūtīt komentārus par šo tēmu.

ABACUS palīdzība ir pieejama dažādās citās valodās / tulkojumu, un to var lejupielādēt no saites zemāk.

Līdz aizstāt pašreizējo ABACUS palīdzības failuar iztulkotā palīdzības failu, lūdzu, rīkojieties šādi:

1. Saglabāt palīdzības failu no attiecīgās saites zemāk.

2. Pārdēvēt palīdzības failu ABACUS.chm.

3. Atveriet failu, divreiz noklikšķinot uz tā un, ja par "Open File - Security Warning" dialog parādās tad atzīmēšanu "Vienmēr jautāt pirms atver failu" opciju un noklikšķiniet uz Atvērt.

4. Aizveriet failu.

5. Nomainiet ABACUS.chm failu ABACUS Program Files mapē, parasti "C: \ Program Files \ Avolution \ ABACUS"Vai"C: \ Program Files(x86)\ Avolution \ ABACUS".

Piezīme

Konteksta jutīga palīdzēt turpinās strādāt ar tulkoto palīdzības failus.

ABACUS palīdzības failus citās valodās:

· Arābu / العربية .

· Bulgārijas / български .

· Ķīniešu (vienkāršotā) / 中文 (简体) .

· Čehu / Česká .

· Dāņu / Dansk .

· Igauņu / Eesti .

· Somu / Suomen .

· Franču / Français .

· Vācu / Deutsch .

· Ungārijas / Magyar .

· Islandiešu / Islandiešu .

· Indonēziešu / Indonēzija .

· Itālijas / Italiano .

· Japānas / 日本 の .

· Latvijā / Latvijas .

· Malaizijas / Malaizija .

· Maltiešu / Iesals i .

· Norweigen / Norweigen .

· Poļu / Po lska .

· Portugāļu / Português .

· Krievu / русский .

· Slovaku / Slovenskí .

· Slovēņu / Slovenski .

· Spāņu / Españoles .

· Zviedru / Svenska .

· Turku / Türk .

· Velsiešu / Cymraeg .

Skatīt arī

Kāda ABACUS darīt?


Aizpildi savu arhitektūru

Navigācija: Populating savu arhitektūru>

Aizpildi savu arhitektūru

Nosūtīt komentārus par šo tēmu.

No ēkas modelis jūsu arhitektūras process ir pazīstams kā populating. Kad esat atklājuši savu arhitektūru un identificēt jūsu prasībām, jūs esat gatavs, lai modelētu savu arhitektūru ABACUS.

Iedzīvotājiem laikā, jūs varēsiet ievadīt visas detaļas jūs zināt par savu arhitektūru un to, kas nepieciešams no tā.

Aizpildīt savu arhitektūru

1. Pārliecinieties, vai ir ABACUS fails atvērts , Kas ir pētnieks parādīts , Un arhitektūra pievienotās .

2. Manuāli apdzīvot augstāka līmeņa komponenti un savienojumi savu arhitektūru. Parasti tas būs vairāk abstraktām detaļas un savienojumi.

- Vai -

2. Grafiski apdzīvot sastāvdaļas un savienojumi, kuras jūs vēlētos redzēt pārstāvēja shematiski, izmantojot Zīmēšanas Tool .

Jūs arī varat

3. Apdzīvot izmantojot Katalogi - Jūs varat apskatīt un sastāvdaļas un savienojumi vienkāršā tabulas veidā.

4. Aizpildīt, izmantojot matricas - Jūs varat apskatīt un rediģēt savienojumus starp komponentiem vienkāršā tabulas veidā.

5. Aizpildīt no Microsoft Access - Jūs varat importēt arhitektūru no un eksportēt uz Microsoft Access.

6. Aizpildīt no Microsoft Visio - Jūs varat importēt arhitektūru no un eksportēt uz Microsoft Visio.

7. Aizpildīt no Microsoft Excel - Jūs varat importēt arhitektūru no un eksportēt uz Microsoft Excel.

8. Aizpildīt no Microsoft SharePoint - Jūs varat importēt arhitektūru no un eksportēt uz Microsoft SQL Server.

9. Aizpildīt no Microsoft SQL Server - Jūs varat importēt arhitektūru no Microsoft SQL Server.

10. Imports no XML - Jūs varat importēt arhitektūra no ABACUS XML fragmentu vai ArchiMate Interchange valodas XML failu.

Skatīt arī

Aizpildi savu arhitektūru manuāli | Zīmējuma Tool | Aizpildi savu arhitektūru no Microsoft Access | Aizpildi savu arhitektūru no Microsoft Visio | Aizpildi savu arhitektūru no Microsoft Excel


Aizpildi savu arhitektūru manuāli

Navigācija: Populating savu arhitektūru> Populating manuāli>

Aizpildi savu arhitektūru manuāli

Nosūtīt komentārus par šo tēmu.

Augstāka līmeņa komponenti un savienojumi jūsu arhitektūra būs nepieciešams apdzīvots manuāli. Parasti tas būs vairāk abstraktām detaļas un savienojumi.

Lai manuāli aizpildīt savu arhitektūru

1. Pārliecinieties, vai ir ABACUS failsatvērts, kas ir pētnieksparādīta, un arhitektūra pievienotās .

2. Pievienot sastāvdaļa. Lai to izdarītu, Labo klikšķipar platību koku vēlaties aizpildīt, un izvēlieties Pievienot subkomponenta ..., Vai noklikšķiniet uz Jaunais komponentspogu uz View rīkjosla . Sastāvdaļas var pievienot tikai komponenti filiāles koku. Jūs vēlaties, lai jūsu koku diagramma būt precīzs attēlojums savu arhitektūru. Kad esat atklājuši savu arhitektūru, jūs esat iemācījušies, kā tieši tas viss iederas kopā. Jums būs nepieciešams šīs zināšanas, kad jūs pievienot savus komponentus un savienojumus. Ja jūs pievienojat savu pirmo komponentu, jūs pievienojiet to tieši komponenti filiālē. No jūsu sastāvdaļām pārējo var būt vai nu tajā pašā līmenī kokā, vai arī tie var būt par pirmās daļas komponenti.

3. Atjaunināt vērtībasīpašībasKatras sastāvdaļas, kā jūs pievienot to. Lai to izdarītu, klikšķisuz sastāvdaļas, un rediģēt parādīta īpašības Properties logs(parasti) uz labo pusi. Properties parasti ir lietas, piemēram, prasības, pārstrādes jaudu utt Kad ABACUS izvērtē savu arhitektūru, to aprēķinās dažas jaunas īpašības, un saglabājiet tos atpakaļ uz arhitektūru. Jaunās īpašības ir dati jūs mēģināt analizēt, piemēram, izmantošanas, reakcijas laiks, joslas platums, uc

4. Pievienot savu savienojumusun updateto īpašībaskā jums iet - tāpat kā to darītu, komponentu (bet zem Connections filiāle koks).

5. Pievienotun detaļas. Lai to izdarītu, atrodiet savienojumu, noklikšķiniet uz vienas no tās galiem vai lomas , Un velciet to uz sastāvdaļu. Alternatīvi, noklikšķiniet uz sastāvdaļu un velciet to uz vienu no pieslēguma s lomas (tas nu Avots vai Sink). Vai jūs varat ar peles labo pogu noklikšķiniet un velciet komponents uz citu komponentu un izvēlieties Savienojumu ar. Vai vienkārši ar peles labo pogu sastāvdaļa un izvēlieties Savienot .... Kad velkat savienojumu loma, Jūs pamanīsiet īsceļu simbolu, kad norādāt pie sastāvdaļa jūs varat pievienot to. Tas norāda, ka jūs neesat padarīt kopiju, jūs vienkārši pievienojot to. Pārliecinieties, ka jūs pievienojiet to uz pareizo galamērķi sastāvdaļa. Piemēram, ja tas ir savienojumu avota loma, Velciet to darīt avota komponentu (ti, sastāvdaļu, kas ir avots datu plūsmas).

Gals

Re-pasūtīšanas vienības savā arhitektūrā (piemēram, komponenti, savienojumi uc), tādā pētnieksir diezgan viegli. Vienkārši Uzklikšķiniet| Turēt| Vilktattiecīgais uzņēmums un vieta, kur vēlamo savā arhitektūrā. Atkārtotas pasūtīšanas funkcionalitāte ļauj jums izvietot uzņēmumus dažādās hierarhijas jūsu arhitektūru.

Jūs arī varat

6. Pievienot standarti (iepriekš konfigurēta komplekti īpašībām - presets) uz jūsu sastāvdaļu un savienojumu vai veidiem

7. Mainīt rekvizītus EK detaļas, savienojumu vai tipa

8. Undo un Redo operācijas

9. Mainiet tips Sastāvdaļu vai savienojumu

10. Izveidot jaunu tipa vai grupas

11. Izdzēst sastāvdaļa vai savienojums

12. Izveidot, dublēt vai attīstīties arhitektūra

13. Importa veidi un standarti no bibliotēkas

14. Imports no citas ABACUS failu, XML, Excel vai Visio

15. Kopēt un ielīmēt detaļas (vai visas) no jūsu arhitektūras

16. Atrast un Aizstāt Preces jūsu arhitektūrā

17. Izvērst / sakļaut dažas vai visas no mezgliem koka

18. Apvienot priekšmeti

19. Definēt un Apstiprināt Ierobežojumi ierobežot struktūru jūsu arhitektūras

20. Attīstīties savu arhitektūru izveidot vairākas arhitektūras risinājumi, lai salīdzinātu un bāzlīnija

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Radīt jaunu failu


Undo un Redo

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Undo un Redo

Nosūtīt komentārus par šo tēmu.

Tāpat kā daudzi mūsdienu pieteikumus, ABACUS atbalsta spēju gan Undo un Redo nesenās lietotāju veiktās izmaiņas atklātu projektu. Lai atsauktu pēdējo maiņu, vienkārši aktivizēt undo komandu. Izmaiņas, kas ir novērstas var redone, aktivizējot pārtaisīt komandu; atkārtoti piemērojot pēdējo atsaukt izmaiņas.

Brīdinājums

Atsaukt izmaiņas nevar tikt atkārtoti, ja turpmākas izmaiņas tiek veiktas, lai projektu, jo tiek atsaukta.

Piezīme

Lai gan lielākā daļa izmaiņu atbalsts undo / redo reālajā laikā, daži diagramma trafaretu izmaiņas, piemēram, izveidojot jaunu Type-formas / Line asociāciju vai mainot asociācijas krāsu atribūts, nevar atsaukt nekavējoties. Šādos gadījumos pārveidotais diagramma (apzīmēti ar zvaigznīti), ir slēgtas, pirms šīs izmaiņas var atsaukt.

Undo un Redo komandu vietas

Ar Undo un Redo komandas var piekļūt no trim dažādām vietām:

· izvēlne Edit

· Standarta rīkjosla

· tastatūras īsceļu taustiņi CTRL + Z(atsaukt) un CTRL + Y(redo)

Gals

Atsaukt un Redo pogas uz standarta rīkjoslā nodrošināt nolaižamo sarakstu izlikšana 10 pēdējās izmaiņas, kas var atsaukt un ir redone attiecīgi. Tās ir arī ērts veids, kā atsaukt / pārtaisīt vairākas izmaiņas uzreiz.


Mainot sastāvdaļu / pieslēguma veids

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Mainot sastāvdaļu / pieslēguma veids

Nosūtīt komentārus par šo tēmu.

Komponentu un savienojumu tipi ir galvenokārt izmanto klasifikācijas nolūkos. Jūs varat izmantot veidus kā filtri, apskatot savu arhitektūru. Piemēram, tā vietā, lai skatīšanās viss, jūs varētu apskatīt tikai pieteikumu sastāvdaļas.

Lai mainītu sastāvdaļu / pieslēguma veids

1. Labo klikšķipar komponentu vai savienojumu.

2. Atlasīt Mainīt Type.

3. Izvēlēties veidu sarakstā citu.

Gals

Mainot veidu, jūs varat saņemt kādu jaunu standartivai īpašības (kāds ir saistītas ar tipa - sk veidi filiāle koku). Jūsu esošais standarti un īpašības paliks nemainīgs. Jūs varat izveidot savu jaunus veidus un piešķirt savas kombinācijas standarti un īpašības uz tiem.

Skatīt arī

Radīt jauna veida | Aizpildi savu arhitektūru - pārskats | Analizējot Jūsu arhitektūra


Radot jaunu sastāvdaļu / savienojuma tipa vai grupas

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Radot jaunu sastāvdaļu / savienojuma tipa vai grupas

Nosūtīt komentārus par šo tēmu.

Komponentu un savienojumu tipi ir galvenokārt izmanto klasifikācijas nolūkos. Jūs varat izmantot veidus kā filtri, apskatot savu arhitektūru. Piemēram, tā vietā, lai skatīšanās viss, jūs varētu apskatīt tikai pieteikumu sastāvdaļas.

Lai izveidotu jaunu sastāvdaļu / Connection Type

Piezīme

Lai pievienotu veidus vai tipa grupas kādā ABACUS projektā lietotājs licence nepieciešama projektētāja pievienot-on spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

1. Paplašināt Veidifiliāle koku.

2. Labo klikšķiuz Komponentu veidi(vai Savienojuma veidi).

3. Atlasīt Pievienot detaļas tipa(vai Pievienot Connection Type) Vai Izveidot grupu.

Gals

Kad esat izveidojis veidu, jums vajadzētu mainīt tās ikonas (skatīt zemāk) un pievienot īpašības un standarti tai par komponentu vai savienojumu gadījumos uz "mantot".

Lai mainītu ikonu uz detaļas / pieslēguma veids

Piezīme

Lai mainītu ikonas veidiem, kādā ABACUS projektā lietotājs licence nepieciešama projektētāja pievienot-on spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

1. Labo klikšķi uz Detaļas tipa(vai Savienojuma tips), Jūs vēlaties mainīt ikonu.

2. Atlasīt Change Icon.

3. Jo Select Icon dialog pārlūkojat atrašanās vietu un izvēlieties attēla failu un noklikšķiniet uz Atvērt.

Piezīme

Jums var būt custom ikonas attēlu jebkura lieluma, bet tas vienmēr tiks samazināti, lai ietilptu uz 16x16 pikseļu attēla, Explorer logā. Tātad, ja jūsu sākotnējais pasūtījuma ikona attēls nav vienādas augstuma un platuma jūsu Explorer logs ikona tiks izstiepts. Attiecīgi pasūtījuma attēliem jābūt vismaz 16x16 pikseļi, un, ja jūs vēlaties, lai saglabātu precīzu formu pasūtījuma ikonas pārliecinieties, ka jūsu pasūtījuma ikona attēls ir vienāds augstums un platums pikseļos (16x16 vai lielāku). Jums ir arī jābūt uzmanīgiem par to, kam nav krāsas "pikseļi" iet visu ceļu līdz robežai no pasūtījuma ikona attēlu, kā tas izskatīsies nabagi Explorer logā ar blakus ikonām "asiņošanas" stāšanās otru. Tādējādi, jums vajadzētu atstāt vismaz 1 pikseļu baltu apmali.

Gals

Jūs varat padarīt savu custom ikonas attēls ICO, bmp, .gif, .jpg vai .png formāta failu, bet sakarā ar ierobežojumiem Windows tikai ICO formātā būs preview ar ABACUS Select Icon dialog, ja jums ir View izvēlnes iespēju iestatīts uz jebko, kas nav Sīktēli.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Analizējot Jūsu arhitektūra


Izdzēšot komponentu vai savienojumu

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Izdzēšot komponentu vai savienojumu

Nosūtīt komentārus par šo tēmu.

Lai izdzēstu komponentu vai savienojumu

1. Labo klikšķipar komponentu vai savienojumu.

2. Atlasīt Izdzēst.

Uzmanību

ABACUS brīdina jūs, kas viedokļi skars svītrojot un aicinu jūs, lai apstiprinātu dzēšanu. Tas ir tāpēc, ka elementi var būt daudzos diagrammas, un tas maksā, lai pārbaudītu to, ko ierosināja svītrot ietekmēs.

Gals

Ja izdzēšat sastāvdaļa, visu tās apakšgrupu sastāvdaļām arī tiks dzēsti. Jūs varat izvēlēties, lai izdzēstu iekšējos un ārējos sakarus uz sastāvdaļu. Ja nevēlaties, lai tos dzēstu, savienojumi, tas ir pievienots lai paliek, bet tie vairs netiks pievienots. Visas sastāvdaļas un savienojumi ir īpaši Type . Dzēšana detaļas / savienojumu neietekmē tipa (jo veidiem filiāle koks). Līdzīgi, ja sastāvdaļa / savienojumam ir Standarts piešķirts, svītrošana neietekmēs kapteiņa standartos filiālē.

Skatīt arī

Aizpildi savu arhitektūru - pārskats


Radīt vai dublējot arhitektūru

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Radīt vai dublējot arhitektūru

Nosūtīt komentārus par šo tēmu.

Jums var būt jebkurš no arhitektūras skaits vienā ABACUS failā. Parasti, jūs izveidot jaunu arhitektūru ikreiz, kad vēlaties, lai modelētu un izvērtēt attīstību jūsu sistēmā.

Lai izveidotu jaunu arhitektūru

1. Labo klikšķi uz Arhitektūrasfiliāle koku.

2. Atlasīt New Architecture.

Lai izveidotu kopiju esošas arhitektūru

1. Labo klikšķipar arhitektūru.

2. Atlasīt Kopija.

3. Labo klikšķi uz Arhitektūrasfiliāle koku.

4. Atlasīt Pasta.

5. Jaunā arhitektūra sauksies "Copy of ...".

Attīstīties esošo arhitektūru

1. Labo klikšķipar arhitektūru.

2. Atlasīt Attīstīties.

3. Jaunā arhitektūra sauksies "... .1".

Piezīme

Ir detalizēts apraksts par pieaugošajām arhitektūras šeit .

Skatīt arī

Kā ir arhitektūras pārstāvēta ABACUS | Attīstās savu arhitektūru


Importēt savu arhitektūru

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Importēt savu arhitektūru

Nosūtīt komentārus par šo tēmu.

ABACUS ļauj ievest Jūsu arhitektūra raugoties no .abacus (ABACUS fails), .xml (AN ABACUS XML fragments vai ArchiMate Interchange Language XML fails), .vsd (Microsoft Visio) formātā, un .xls (Microsoft Excel) formātā. Tas ļauj jums veidot savu arhitektūru no ārējiem avotiem ātri.

Līdz imports Jūsu arhitektūra no.abacus (ABACUS fails)

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Labo klikšķipar arhitektūras mezglā, kāds arhitektūras savu modeli vai jebkuru no sastāvdaļām koku.

3. Atlasīt Imports| No File ...no izvēlnes.

4. Izvēlieties vietu un .abacus fails un noklikšķiniet uz Atvērtspoga.

Piezīme

Pēc tam, kad esat izvēlējies failu, kuru vēlaties importēt, jums tiks jautāts, kā jūs vēlētos, lai importētu standartus, veidiun viedokļi. Jūs varat importēt standartus, veidi un viedokļi vai nu kā jaunu vai apvienoto standartiem, veidiun viedokļi. Noklusējuma iestatījums ir uz standartiem, veidi un viedokļi jāapvieno ar esošajiem standartiem, veidi un viedokļi ja tie jau eksistē (ar to pašu precīzu nosaukumu) In Your projekts.

Līdz importsJūsu arhitektūra no.xml (AN ABACUS XML fragments vai ArchiMate Interchange Language XML fails)

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Labo klikšķipar arhitektūras mezglā, kāds arhitektūras savu modeli vai kāda no komponenta koku.

3. Atlasīt Imports| No XML ...no izvēlnes.

4. Izvēlieties vietu un .xml failu un noklikšķiniet uz Atvērtspoga.

Piezīme

ABACUS tikai importēt pareizi noformēts Abacus XML fragments vai ArchiMate Interchange valodas XML failu. Pēc tam, kad esat izvēlējies XML failu, kuru vēlaties importēt, jums tiks jautāts, kā jūs vēlētos, lai importētu standartus, veidiun viedokļi. Jūs varat importēt standartus, veidi un viedokļi vai nu kā jaunu vai apvienoto standartiem, veidiun viedokļi. Noklusējuma iestatījums ir uz standartiem, veidi un viedokļi jāapvieno ar esošajiem standartiem, veidi un viedokļi ja tie jau eksistē (ar to pašu precīzu nosaukumu) In Your projekts.

Līdz importsJūsu arhitektūra no.VSD(Visiofails)redzēt šeit .

Līdz importsJūsu arhitektūra noxls (Excel fails)redzēt šeit .


Importēšana veidus un standartus no bibliotēkas

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Importēšana veidus un standartus no bibliotēkas

Nosūtīt komentārus par šo tēmu.

Jūs varat importēt veidus un standartus no ABACUS bibliotēkas failu. Jūs varat arī eksportēt veidu un standartus no jūsu ABACUS failu uz ABACUS bibliotēkas failu.

Lai importētu veidus un standartus no bibliotēkas savā arhitektūrā

1. Pārliecinieties, vai ir ABACUS failsatvērtas un Explorer Windowparādīts.

2. Izvēlieties File | Atvērts, lai atvērtu ABACUS bibliotēkas fails.

3. Abacus bibliotēka tiks atvērta otrā tabbed lapai Explorer logā, un jums būs undock šo tabbed lapu lai varētu vilkt un nomest no tā sākotnējās ABACUS failu.

4. Velciet un nometietveidi un standarti no bibliotēkas ievietota Jūsu arhitektūru.

- Vai -

1. Izvēlieties File | New ...

2. Izveidot jaunu ABACUS fails, kuras pamatā ir ABACUS bibliotēkas fails.

Lai eksportētu veidus un standartus no sava arhitektūra uz bibliotēku

1. Pārliecinieties, vai ir ABACUS failsatvērts, Explorer Windowredzams, kas ir ABACUS bibliotēkas failsatvērtas un Bibliotēka Windowparādīts.

2. Velciet un nometietveidi un standarti no jūsu arhitektūru bibliotēkā.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli


Kopēšana un līmēšana

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Kopēšana un līmēšana

Nosūtīt komentārus par šo tēmu.

Jūs varat kopēt daļu vai visu savu arhitektūru un ielīmēt to citā vietā kokā.

Lai kopētu

1. Labo klikšķiuz posteni, kuru vēlaties kopēt.

2. Atlasīt Kopija.

Lai ielīmētu

1. Virzīties koku, lai atrastu vietu, jūs vēlaties, lai ielīmētu objektu.

2. Labo klikšķipar filiāles jūs vēlaties, lai parādās laikā.

3. Atlasīt Pasta.

4. Punkts kopēt būs ar sākotnējo nosaukumu (ja vien jūs kopēt to sākotnējo filiāle - tad to sauks "Copy of ...").

Skatīt arī

Kā ir arhitektūras pārstāvēta ABACUS


Meklējot un priekšmetus aizstājot savā arhitektūrā

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Meklējot un priekšmetus aizstājot savā arhitektūrā

Nosūtīt komentārus par šo tēmu.

Tu vari atrast un Aizstāt īpašs komponents, pieslēgšana, tipa, standarta vai īpašumu, izmantojot Abacus "Atrast un Aizstāt iekārta.

Lai atrastu objektu

1. Noklikšķiniet uz mezglu no koka vēlaties meklēt ietvaros.

2. Atlasīt Rediģēt| Atrastvai nospiediet Ctrl + F.

3. Ievadiet teksts postenisatrast ar "atrast to, ko" laukā.

4. Uzklikšķiniet Atrast nākamo.

Līdz aizstāt postenis

1. Noklikšķiniet uz mezglu no koka vēlaties meklēt ietvaros.

2. Atlasīt Rediģēt| Aizstātvai nospiediet Ctrl + H.

3. Ievadiet tekstspostenisatrast 'Atrast to, kas laukā un tekstu, lai aizstātu to ar šajā "Aizstāt ar' laukā (vai nekas, ja laukā ir atstāta tukša).

4. Uzklikšķiniet Atrast nākamoatrast pirmo instanci "Atrast to, ko" tekstu un noklikšķiniet Aizstāt aizstāt šo instanci ar "Aizstāt ar" tekstu vai klikšķi Aizstātu visusaizstāt visus gadījumus.

Jums ir iespējas:

o Match savu lietu,

o Match visu vārdu,

o Meklēt no projekta sākuma,

o Ignorēt arhitektūras - tas ir arhitektūras mezgli paši. Jebkuras mezgli zem arhitektūras mezgliem, piemēram, sastāvdaļu un savienojumu joprojām būs meklēti,

o Ignorēt sastāvdaļas - tas ir komponents mezgli paši,

o Ignorēt savienojumus - tas ir savienojums mezgli paši,

o Ignorēt standartus - tas ir viss, arhitektūra, to sastāvdaļas un savienojuma standarta mezgli tiks ignorēts,

o Ignorēt veidi - tas ir veids, mezglu sevi. Jebkurš ierobežojums mezgli zem no tipa mezglu joprojām būs meklēti,

o Ignorēt veidnes un saturs - tas ir veidne mezglu sevi, kā arī jebkura veidne sastāvdaļa un savienojuma mezgli zem tiem,

o Ignorēt īpašības - tas ir visi īpašuma veidi, nosaukumus, vērtības un vienības no visiem modeļa elementiem tiks ignorēts,

o Ignorēt apraksti - tas ir apraksti par visiem modelī izmantotajiem elementiem tiks ignorētas.

Skatīt arī

Kā ir arhitektūras pārstāvēta ABACUS


Paplašinot un sabrukšanu koku

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Paplašinot un sabrukšanu koku

Nosūtīt komentārus par šo tēmu.

Ja mezglu kokā satur apakšprogrammas komponenti un kolekcijas, tas būs mazs [image] vai [image] pierakstīties savā kreisajā pusē. Jūs varat noklikšķināt uz [image] paplašināt mezglu un redzēt savas apakšgrupas komponentus un savienojumus. Līdzīgi, jūs varat noklikšķināt uz [image] sabrukt mezglu, lai paslēptu apakšgrupas komponentus un savienojumi (lai padarītu vairāk vietas vai padarītu koks vieglāk saprast).

Alternatīvi, jūs varat paplašināt visu mezglu, un tādā gadījumā visi tās sub-mezglu arī tiks paplašināta, un to sub-mezglu, un viņu ... utt Tāpat var sabrukt visu mezglu - slēdzot vairākus līmeņus uzreiz .

Bez tam, pastāv iespējas paplašināt tikai arhitektūra, elementus (ti, detaļas un savienojumi), sastāvdaļas vai savienojumus.

Lai izvērstu vai sakļautu visu mezgla (un tās apakšgrupu mezgliem, uc)

1. Labo klikšķiuz mezglu.

2. Atlasīt Izvērst | Visi vaiSabrukums.

Lai paplašinātu visi no arhitektūras (-i)

1. Labo klikšķipar arhitektūru vai arhitektūru.

2. Atlasīt Izvērst | Visi.

Lai paplašinātu elementus

1. Labo klikšķipar arhitektūru vai arhitektūru.

2. Atlasīt Izvērst | Elements.

Lai paplašinātu sastāvdaļas

1. Labo klikšķipar komponentes, detaļas vai subkomponenta.

2. Atlasīt Izvērst | Komponenti | Visi.

Lai paplašinātu savienojumus

1. Labo klikšķipar savienojumi, savienojumu vai sub-savienojumu.

2. Atlasīt Izvērst | Savienojumi | Visi.


Sapludināšana priekšmetus

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Sapludināšana priekšmetus

Nosūtīt komentārus par šo tēmu.

Kad jūs apvienot priekšmetus?

Jūs apvienot priekšmetus, ja jums ir divi (vai vairāk) objektus savu modeli, kas vislabāk pārstāv vienu gadījumu. Ir daudzas situācijas, kad jūs varētu vēlēties, lai to izdarītu, tai skaitā:

· Kā rezultātā importē jaunu informācijas kopumu savā modeli, kas var dublēt vai aizstāt esošo informāciju. Piemēram, ja jums importēt atjauninātu versiju izklājlapas jūsu modeli.

· Laika gaitā dublikātus no "tiem pašiem" sastāvdaļu ir izveidotas un jūs vēlaties, lai attīrītu šos dublikātus.

· Ja jums ir veikt ko-ja scenārijs un preces jums ir modelēšanas faktiski apvienojas realitātē. Piemēram, ja jūs apvienojot divas struktūrvienības jūsu organizācijā, vai, ja jūs apvienojas divas serveriem.

Ko var apvienot?

Par šādu veidu vienību atbalsts tiek apvienotas:

· Standarti

· Komponentu un Savienojuma veidi

· Komponenti un savienojumi

Kā apvienot priekšmetus

Lai uzsāktu sapludināšanu, izmantojot peles labo pogu, velciet vienu objektu pētnieks uz otru. Objekts, ko velkot ir avots, un objekts, kas jums vilkt uz ir galamērķis. Pēc atbrīvojot peles labo taustiņu jums tiks iesniegts ar izvēlni, no kuras jūs varat izvēlēties, lai Apvienot divus objektus. Jums būs jāizvēlas, vai vēlaties, lai saglabātu vai pārrakstīt galamērķi. Tas ir sīkāk paskaidrots turpmāk.

Sapludināšanas labo drag menu

Kāda ir atšķirība starp saglabāšanu un pārrakstot galamērķi?

Saglabāt vai pārrakstīt variants nosaka, kas notiek, ja nosaukumu, aprakstu vai Properties starp avota un mērķa preces maču.

Ja Saglabāt galamērķis ir izvēlēta

· Galamērķa nosaukums un apraksts tiks saglabāti.

· Jebkuras Properties, kas pastāv tikai avotā tiek pievienoti galamērķi.

Ja Pārrakstīt Galamērķis ir izvēlēts:

· Galamērķis nosaukums tiks pārrakstīti no avota.

· Galamērķis apraksts tiks pārrakstīti no avota, ja vien tās iztekas aprakstā ir tukšs.

· Jebkuras Properties, kas pastāv tikai avotā tiek pievienoti galamērķi.

· Vērtība un vienība jebkuru Properties, kas pastāv gan avotu un galamērķi tiks pārrakstīti no avota, ja vien tās iztekas vērtība vai vienība ir tukšs.

Īpaši gadījumi

· VeidiKad apvienojas veidu, atļaujas tiek apvienotas, jo "pesimistiska" veidā, piemēram, ka, ja atļauja par avota nepastāvēja uz galamērķi, tas būtu pievienots, un, ja tā pastāv galamērķa, tad, ja indivīds atļauja lietošanas grupā (izveidot, lasīt, atjaunināt vai dzēst) nesakrita (viens piešķirts, viens noliedza), tad šī atļauja tiktu liegta.

· SastāvdaļasKad apvienojot komponentus, tad no avota sub-komponenti tiek pārvietoti uz galamērķi, un tiek apvienotas ar apakškomponentos galamērķa, ja to nosaukumi ir identiski, Neatkarīgi no to veida.Turklāt no avota ar tādu pašu nosaukumu vairākas apakšgrupas komponenti tiks apvienoti vienā sub-komponenta galamērķi.

· Savienojumi: Augstākā līmeņa pašiem savienojumiem jābūt abiem ir vienādas pielikumi (vai tās trūkuma) jāļauj jāapvieno. Kad apvienojas savienojumus, sub-savienojumi avota tiek pārvietoti uz galamērķi, un tiek apvienotas ar apakšgrupas savienojumiem galamērķi, ja to nosaukumi ir identiski UNto pielikumi ir identiski. Ja pielikumi nav identiski, avota apakšgrupas savienojumi tiks pievienota galamērķi bez apvienojas ar atbilstīgiem savienojumiem jau klāt. Tas ir tā, ka nav pielikumi tiek zaudēti.


Definēšana un apstiprināšana Ierobežojumi

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Definēšana un apstiprināšana Ierobežojumi

Nosūtīt komentārus par šo tēmu.

Struktūra un īpašības no arhitektūras var ierobežot, izmantojot ierobežojumus. Ierobežojumi var piemērot sastāvdaļu veidu un savienojuma veidu, lai ierobežotu struktūru arhitektūra divos veidos. Pirmais veids ir ierobežot hierarhijadefinējot "vecākiem ir / jābūt bērns" un "bērnam vajadzētu / jābūt vecāku" attiecības. Otrs veids ir ierobežot topoloģijadefinējot "sastāvdaļa ir / ir jāpievieno savienojumu" un "pieslēgums būtu / jāpievieno komponents" attiecībām. Turklāt ierobežojumi var piemērot īpašībām sastāvdaļu veidu, pieslēguma veidu, veidnes, viedokļu, arhitektūras, diagrammasun 3D ierobežot arhitektūru (-s) divas papildu veidos. Pirmais veids ir noteikt datu tipsĪpašuma ierobežot spēkā esošās vērtības, ka tā var būt, proti; Teksts, Integer, Decimal, Date / Time, Boolean vai saraksts. Otrs veids ir noteikt nepieciešamsstatuss īpašuma norādīt, vai vērtība jāievada par īpašumu (Piezīme: Nepieciešamās ierobežojumi attiecas tikai uz īpašībām detaļas un savienojuma veidiem). Papildu informācija par īpašuma ierobežojumiem ir sniegta Mainot rekvizītus sastāvdaļu, savienojumu vai tipa help tēmu. Pēc tam, kad ierobežojumi ir noteikti, tas ir iespējams, lai apstiprinātu arhitektūru pret ierobežojumiem. ABACUS brīdinās par jebkādiem ierobežojumiem, kas ir pārkāptas.

Galvenais, lai noteiktu, kura ierobežojumu (-iem), lai definētu slēpjas precīzā valodā, ko izmanto, lai aprakstītu ierobežojumu. Par hierarhijas ierobežojumiem tie parasti ir no formas "lietvārdivar / vajadzētu / jābūt sadalīt n lietvārdi"Vai"lietvārdivar / vajadzētu / jāapvieno ar lietvārdi"Utt Piemēram,"Departamentiir sadalīt Teams"Vai"Pieteikumivar sadalīt Moduļi". Par topoloģiju ierobežojumiem tie parasti ir no formas"lietvārdivar / vajadzētu / must darbības vārds lietvārdi". Piemēram, "Procesi var būt izpilda Teams"Vai"Pieteikumiir izvietots uz Serveri. "Tagad jūs varat redzēt katrā ierobežojums ir dažādi var / vajadzētu / must" kvalificējušies ", un tie var būt 3 veidu;

· Fakultatīvs- Tie parasti izmanto vārdus / frāzes, piemēram; "var", "iespējams", "varētu", "pēc izvēles" uc

· Ieteicams- Tie parasti izmanto vārdus / frāzes, piemēram; "vajadzētu", "ieteica", "ieteica" uc

· Obligāti- Tie parasti izmanto vārdus / frāzes, piemēram; "must", "ir", "ir", "ir", "shall" uc

Atkarībā veidu ierobežojumiem (hierarhijas vai topoloģiju), kā arī kvalifikācijas, ko izmanto aprakstot to, īpašs ierobežojums (-i) būtu jānosaka (skatīt zemāk). Par iepriekš minēto hierarhijas piemērs "Departamentiir sadalīt Teams"Vajadzētu definēt" Parent jābūt bērns "ierobežojumus un noteikt izpildi, kas jāizpilda. Par minēto topoloģiju piemērs"Procesi var būt izpilda Teams. "Vajadzētu izveidot tikai divas (2)" Savienojums jāpievieno komponents "ierobežojumiem vai nu beigās ar savienojuma veidu veic Konkrēti, šādi ierobežojumi ir ieteicams definēt (skatīt zemāk) par dažādām iespējām;

· Hierarhija ierobežojumi;

o Lietvārdi var būtsadalīt Lietvārdi B, Vai Lietvārdi B var būtapkopotais Lietvārdivai Lietvārdi B vajadzētu būtapkopotais Lietvārdi- Noteikt "bērnam ir jābūt mātes sabiedrību" ierobežojums ar bērnu tipa, kā lietvārds B, mātes tipa, kā lietvārds A un izpildi, kā brīdināja.

Piezīme

Tas nozīmē, ka, ja bērns ir, tam vajadzētu būt vecāks par noteikta veida. Ja ne, jūs saņemsiet brīdinājumu.

o Lietvārdi vajadzētu būtsadalīt Lietvārdi B- Noteikt "Parent ir jābūt bērns" ierobežojums ar mātes tipam kā lietvārds A, bērnu tipa, kā lietvārds B un izpildi, kā brīdināja.

Piezīme

Tas nozīmē, ka gadījumā, ja viens no vecākiem pastāv, tai vajadzētu būt bērni noteikta veida. Ja ne, jūs saņemsiet brīdinājumu.

o Lietvārdi jābūtsadalīt Lietvārdi B- Noteikt "Parent jābūt bērns" ierobežojums ar mātes tipam kā lietvārds A, bērnu tipa, kā lietvārds B un izpildi, kā izpildīt.

Piezīme

Tas nozīmē, ka gadījumā, ja viens no vecākiem ir, tai jābūt bērni noteikta veida. Ja ne, jūs saņemsiet kļūdas.

o Lietvārdi jābūtapkopotais Lietvārdi B- Noteikt "bērnam ir jābūt mātes sabiedrību" ierobežojums ar bērnu tipa, kā lietvārds A, mātes tipa, kā lietvārds B un izpildi, kā izpildīt.

Piezīme

Tas nozīmē, ka, ja bērns ir, tai ir jābūt vecākiem par noteikta veida. Ja ne, jūs saņemsiet kļūdas.

· Topoloģija ierobežojumi;

o Lietvārdi var būt darbības vārds Lietvārdi B- Noteikt divu (2) "Savienojums jāpievieno komponents" ierobežojumiem. Pirmais būtne ar Source beigām savienojuma tipu darbības vārdspievienots lietvārds detaļas tipa un izpildes piespiedu. Otrais būtne ar izlietni beigām savienojuma tipu darbības vārdspievienots lietvārds B detaļas tipa un izpildi, kas to izpildi.

Piezīme

Tas nozīmē, ka gadījumā, ja savienojums eksistē, tas ir savienot komponentus noteiktu veidu. Ja ne, jūs saņemsiet kļūda. Kopumā tas nodrošina, ka vēl var pastāvēt šīs sastāvdaļas un nav saistīti viens ar otru. Tomēr, ja tie ir saistīti, savienojumi pareizā tipa jāizmanto.

o Lietvārdi vajadzētu būt darbības vārds Lietvārdi B- Noteikt divu (2) "sastāvdaļa ir jāpievieno Connection" ierobežojumiem. Pirmais ir ar Noun Detaļas tipa pievienots kods beidzies darbības vārdssavienojuma veids un izpilde, kas, lai brīdinājusi. Otrais būtne ar lietvārdu B detaļas tipa pievienots izlietnes beigām no darbības vārdssavienojuma veids un izpilde, kas, lai brīdinājusi. Turklāt, definēt divas (2) "Savienojums jāpievieno komponents" ierobežojumiem. Pirmais būtne ar Source beigām savienojuma tipu darbības vārdspievienots lietvārds detaļas tipa un izpildes piespiedu. Otrais būtne ar izlietni beigām savienojuma tipu darbības vārdspievienots lietvārds B detaļas tipa un izpildi, kas to izpildi.

Piezīme

Tas nozīmē, ka tad, ja komponenti abu veidu, tie ir pievienoti, lai savienojumu noteikta veida. Ja ne, jūs saņemsiet brīdinājumu. Turklāt tas nozīmē, ka, ja savienojums ir, tai jābūt savienotai ar komponentiem norādītā veida. Ja ne, jūs saņemsiet kļūdas. Kopumā tas nodrošina, ka gadījumā, ja komponenti šiem veidiem pastāv, jūs saņemsiet brīdinājumu, ja tie nav saistīti viens ar otru.

o Lietvārdi jābūt darbības vārds Lietvārdi B- Noteikt divu (2) "sastāvdaļa ir jāpievieno Connection" ierobežojumiem. Pirmais ir ar Noun Detaļas tipa pievienots kods beidzies darbības vārdssavienojuma veids un izpilde iestatīts uz izpildi. Otrais būtne ar lietvārdu B detaļas tipa pievienots izlietnes beigām no darbības vārdssavienojuma veids un izpilde iestatīts uz izpildi. Turklāt, definēt divas (2) "Savienojums jāpievieno komponents" ierobežojumiem. Pirmais būtne ar Source beigām savienojuma tipu darbības vārdspievienots lietvārds detaļas tipa un izpildes piespiedu. Otrais būtne ar izlietni beigām savienojuma tipu darbības vārdspievienots lietvārds B detaļas tipa un izpildi, kas to izpildi.

Piezīme

Tas nozīmē, ka tad, ja komponenti abu veidu, tie ir pievienoti, lai savienojumu noteikta veida. Ja ne, jūs saņemsiet kļūdas. Turklāt tas nozīmē, ka, ja savienojums ir, tai jābūt savienotai ar komponentiem norādītā veida. Ja ne, jūs saņemsiet kļūdas. Kopumā tas nodrošina, ka gadījumā, ja komponenti šiem veidiem pastāv, jūs saņemsiet kļūdas, ja tie nav saistīti viens ar otru.

Lai definētu ierobežojumu

1. Pārliecinieties, vai ir ABACUS failsatvērtas un Explorer Windowparādīts.

2. Jo pētnieks kokā paplašināt Veidi | Komponentu veidivai paplašināt Veidi | Savienojuma veidi.

3. Labo klikšķidetaļas tipa vai savienojuma veids un izvēlieties Pievienot Ierobežojums.

Pievienojot ierobežojums

Lai definētu hierarhiju ierobežojums, ja viens no vecākiem ir jābūt konkrētam bērnam

4. Uz Pievienot Ierobežojumslogu atzīmējiet Izveidot Ierobežojumsrūtiņu zem Parent Must Have Bērnu Ierobežojumszona.

5. Izvēlieties detaļas tipaNo nolaižamā kuru vēlaties norādīt kā bērna detaļas tipa izvēlētā 3. solī.

Piezīme

Ja jau pastāv iespējots "Parent Must Have Child" ierobežojums noteikts mātes detaļas tipa un citu bērnu detaļas tipa tad šī jaunā ierobežojums tiks apstrādāta kā "un". Tas ir veids ir vecāks par bērnu tipa unbērns tips B, lai kāds izpildes līmenim (piemēram, invalīdi, jābrīdina vai piespiedu - skatīt 7. solis) ir noteikts katrai ierobežojumiem.

6. Pēc izvēles jūs varat noteikt minimālo un maksimālo skaitu komponentu detaļas tipa noteikts, ka jābūt bērni detaļas tipa labo klikšķi 3. solī.

7. Izvēlieties, vai vēlaties ierobežojums būt Invalīdu, Brīdinājavai Piespiedu.

Piezīme

Invalīdiem ierobežojumi tiks ignorēti no ierobežojumu apstiprināšanas, brīdināja ierobežojumi ražos brīdinājums validācijas logā, ja tie ir atklāti un izpilda ierobežojumi radīs kļūda validācijas logā, ja tie ir atklāti. Turklāt visi Kļūdas ir jāatrisina, pirms Uzņēmums Server projektu var izdarīts.

8. Uzklikšķiniet labi.

Piezīme

Ierobežojums tiks parādīti pētnieks kokā zem detaļas tipa labo klikšķi 3. solī Bulta norāda virzienu ierobežojumiem, un šajā gadījumā būs punkts uz leju un pa labi. Slēdzene ir iekrāsoti saskaņā ar to, vai ierobežojums ir Invalīdu (pelēka), jābrīdina (dzeltena) vai piespiedu (sarkans).

Parent jābūt bērnu brīdināja ierobežojumu

Lai definētu hierarhiju ierobežojums, ja bērns ir jābūt īpaša vecāks

4. Uz Pievienot Ierobežojumslogu atzīmējiet Izveidot Ierobežojumsrūtiņu zem Bērnu Must Have Parent Ierobežojumszona.

5. Izvēlieties detaļas tipaNo nolaižamā kuru vēlaties norādīt kā vecākam par detaļas tipa labo klikšķi 3. solī.

Piezīme

Ja jau pastāv iespējots "Bērnu Must Have mātesuzņēmuma ierobežojumu definēts bērnam detaļas tipa un cita mātes detaļas tipa tad šī jaunā ierobežojums tiks apstrādāta kā" vai ". Tas ir veids, jābūt bērns mātes tipa vaimātes tips B, un izpildes līmeni (piemēram, jābrīdina vai piespiedu - skatīt nākamo soli), vajadzētu būt tās pašas citādi piespiedu ierobežojumi vienmēr ignorēs brīdināja ones.

6. Izvēlieties, vai vēlaties ierobežojums būt Invalīdu, Brīdinājavai Piespiedu.

Piezīme

Invalīdiem ierobežojumi tiks ignorēti no ierobežojumu apstiprināšanas, brīdināja ierobežojumi ražos brīdinājums validācijas logā, ja tie ir atklāti un izpilda ierobežojumi radīs kļūda validācijas logā, ja tie ir atklāti. Turklāt visi Kļūdas ir jāatrisina, pirms Uzņēmums Server projektu var izdarīts.

7. Uzklikšķiniet labi.

Piezīme

Ierobežojums tiks parādīti pētnieks domām zem izvēlētā 5. solī detaļas tipa Bulta norāda virzienu ierobežojumiem, un šajā gadījumā būs punkts uz augšu un pa kreisi. Slēdzene ir iekrāsoti saskaņā ar to, vai ierobežojums ir Invalīdu (pelēka), jābrīdina (dzeltena) vai piespiedu (sarkans).

Bērnu jābūt mātes brīdināja ierobežojumu

Lai definētu topoloģiju ierobežojums, kurā sastāvdaļa ir jāpievieno konkrētu savienojumu

4. Uz Pievienot Ierobežojumslogu atzīmējiet Izveidot Ierobežojumsrūtiņu zem Komponents jāpievieno Ierobežojumszona.

5. Izvēlieties savienojuma veidsNo nolaižamā kuru vēlaties norādīt kā pievienoto pieslēguma detaļas tipa labo klikšķi 3. posmā (vai izvēlieties detaļas tipaNo nolaižamā kuru vēlaties norādīt kā pievienoto sastāvdaļu, ja 3. solī jums labo klikšķi savienojuma veidu.)

Piezīme

Ja jau pastāv iespējots "Detaļas jāpievieno" ierobežojums noteiktas detaļas tipa un citu savienojuma veidu, tad šī jaunā ierobežojums tiks uzskatīta kā "UN". Tas ir detaļas tipa jāpievieno savienojumu tipa unsavienojuma tips B, lai kāds izpildes līmenim (piemēram, invalīdi, jābrīdina vai piespiedu - skatīt 7. solis) ir noteikts katrai ierobežojumiem.

6. Pēc izvēles jūs varat izvēlēties savienojumu lomaka jūs vēlaties pievienot ierobežojumu. Sievēlēt īpašo loma (tas nu Avots vai Sink) No nolaižamā.

7. Izvēlieties, vai vēlaties ierobežojums būt Invalīdu, Brīdinājavai Piespiedu.

Piezīme

Invalīdiem ierobežojumi tiks ignorēti no ierobežojumu apstiprināšanas, brīdināja ierobežojumi ražos brīdinājums validācijas logā, ja tie ir atklāti un izpilda ierobežojumi radīs kļūda validācijas logā, ja tie ir atklāti. Turklāt visi Kļūdas ir jāatrisina, pirms Uzņēmums Server projektu var izdarīts.

8. Uzklikšķiniet labi.

Lai definētu topoloģiju ierobežojums, kur savienojums ir jāpievieno īpaša sastāvdaļa

4. Uz Pievienot Ierobežojumslogu atzīmējiet Izveidot Ierobežojumsrūtiņu zem Savienojums jāpievieno Ierobežojumszona.

5. Izvēlieties savienojuma veidsNo nolaižamā kuru vēlaties norādīt kā pievienoto pieslēguma detaļas tipa labo klikšķi 3. posmā (vai izvēlieties detaļas tipaNo nolaižamā kuru vēlaties norādīt kā pievienoto sastāvdaļu, ja 3. solī jums labo klikšķi savienojuma veidu.)

Piezīme

Ja jau pastāv iespējots "Connection jāpievieno" ierobežojums noteikts, lai savienojuma veidu un citas detaļas tipa, izmantojot to pašu savienojumu loma(proti, vai nu Source vai Sink), tad šis jaunais ierobežojums tiks uzskatīta kā "vai". Tas ir savienojums tips jāpievieno detaļas tipa A vaiDetaļas tipa B, un izpildes līmeni (piemēram, jābrīdina vai piespiedu - skatīt 7. solis), vajadzētu būt tās pašas citādi piespiedu ierobežojumi vienmēr ignorēs brīdināja ones. Ņemiet vērā arī to, ka, ja ir vairāki ierobežojumi, kas ir savienojumu lomanorādīts kā "Jebkurš" (atšķirībā īpaši Source vai Sink), tad katrs gals savienojuma jāpievieno vienu sastāvdaļu tipiem norādītajiem ierobežojumiem.

6. Pēc izvēles jūs varat izvēlēties savienojumu lomaka jūs vēlaties pievienot ierobežojumu. Sievēlēt īpašo loma (t.i., vai nu Avots vai Izlietne) No nolaižamā.

Piezīme

Nu Source vai Sink loma ir jābūt skaidri izraudzīti Pieķeršanās kolonna būt avilable tiks parādīta sastāvdaļa katalogs .

7. Izvēlieties, vai vēlaties ierobežojums būt Invalīdu, Brīdinājavai Piespiedu.

Piezīme

Invalīdiem ierobežojumi tiks ignorēti no ierobežojumu apstiprināšanas, brīdināja ierobežojumi ražos brīdinājums validācijas logā, ja tie ir atklāti un izpilda ierobežojumi radīs kļūda validācijas logā, ja tie ir atklāti. Turklāt visi Kļūdas ir jāatrisina, pirms Uzņēmums Server projektu var izdarīts.

8. Uzklikšķiniet labi.

Īsts laiks modelis pārbaude un piespiešanavalidācija

ABACUS ietverreāllaika Modeļa pārbaude un Validation iezīme nekavējoties displejs ietekme konkrētā lietotāja operācija būs uz brīdinājumi un kļūdas ar pašreizējo projektu, jo jebkura hierarhija un topoloģija ierobežojumi, kas ir definēti. Jāatzīmē, ka visas kļūdas ir jāatrisina, pirms Uzņēmums Server projektu var izdarīts.

Reālā laika ierobežojums validācija iezīme ir ļoti manāms, kad populating ar diagrammām vai tieši Explorer logā. Jo īpaši, šādas darbības laikā, vadlīnijas tiek dota, izmantojot krāsu akcentus, kā par to darbība būs uz brīdinājumi un kļūdas ar pašreizējo projektu;

1. Kad velkot elementus uz vai ap diagrammā krāsu vecāka (vai pievienot) komponenta (ja tādi ir) robeža tiks iekrāsoti saskaņā ar tālāk aprakstīto shēmu.

2. Kad savieno komponentus, izmantojot labo klikšķi velciet | Pievienojiet iezīme sarakstu pieejamo savienojuma veidu ir nokrāsota saskaņā ar tālāk aprakstīto shēmu.

3. Kad savieno komponentus uz diagrammas, izmantojot savienotāju režīmā kursors krāsas mainās saskaņā ar tālāk aprakstīto shēmu.

4. Pievienojot apakškomponentos saraksts pieejamo komponentu veidiem ir iekrāsoti saskaņā ar tālāk aprakstīto shēmu.

Parasti šādas krāsas tiek izmantoti, lai norādītu ietekmi lietotājs operācija būs uz brīdinājumiem un kļūdas ar pašreizējo projektu;

Melns : Nav ietekmes uz brīdinājumu vai kļūdām.

Zaļš : Operācija ir skaidri saskaņā arnoteikta hierarhija un topoloģija ierobežojumi projektā.

Sarkans : Operācija ir skaidri pārkāpjotdefinētie hierarhija un topoloģija ierobežojumi projekta un radīs brīdinājumiem un / vai kļūdas.

Fons modelis pārbaude un piespiešanavalidācija

ABACUS ietver Validation funkciju, lai parādītu visus brīdinājumus un kļūdas ar pašreizējo projektu, sakarā ar jebkādiem ierobežojumiem, kas ir definētas. Jāatzīmē, ka visas kļūdas ir jāatrisina, pirms Uzņēmums Server projektu var izdarīts.

Piezīme

Validation nepieciešams manuāli palaist caur "apstiprināt / Check projektam ierobežojumiem" pogu Galvenā rīkjosla . Validēšanas logs ir slēpta pēc noklusējumabet, parādīsies, kad poga rīkjosla ir noklikšķinājuši. Redzēt Pielāgošana saskarni par to, kā parādīt to, un, iespējams, atstājiet to pastāvīgi redzams. Tāpat jūs varat dubultklikšķi uz jebkuru rindu Validation loga "lēcienu", lai attiecīgā projekta elementiem.

Validācija logu

Noklusējuma kolonnas validācijas logā ir aprakstīti šādi:

Brīdinājums vai kļūdaŠī sleja parāda ikonu, vai pārkāpums ir brīdinājums (dzeltens trijstūris ar izsaukuma zīmi), vai kļūda (sarkans aplis ar krustu).

Numurs: Šī sleja parāda pārkāpuma numuru.

Piezīme

Tikai 200 pārkāpumi tiek rādīti vienlaicīgi, un, ja ir vairāk nekā 200 pārkāpumus projektā Start, Iepriekšējā, Next un beigas rindu stūrmaņiem augšējā labajā stūrī loga var izmantot, lai pārlūkotu papildu pārkāpumus.

Apraksts: Tas ir pilns apraksts par pārkāpumu, tostarp uzņēmumu un Ierobežojums attiecas.

Entity: Šī sleja parāda subjekta bažas pārkāpumu.

Type: Šī sleja parāda elementa tips attiecībā uz struktūru.

Arhitektūra: Šī sleja parāda arhitektūrā, kurā pārkāpums ir noticis.

Atklātie: Šī sleja parāda laiku, kas tika atklāti pārkāpumi.

Gals

Tas ir noderīgi, lai sakārtotu dilstošā ar konstatētajiem kolonnas (kā parādīts dialoglodziņā augstāk), lai nodrošinātu jaunākās pārkāpumi parādās pie "top" saraksta.

Ir vairākas iespējas lietotājiem, lai mainītu uzvedību fona modeļu apstiprināšanas. Piemēram, to mainīt krāsas, ko izmanto ierobežojumu pārkāpumiem, lai kaut ko citu nekā noklusējuma SarkansNoklikšķiniet uz Tools | Iespējas ... tad iet uz Validācijatab, un noteikt krāsas, izmantojot Maiņa pogas.

Validācija iespējas

Lai manuāli apstiprinātu ierobežojumus

1. Labo klikšķi uz Arhitektūrasmezglā, jebkura arhitektūras vai jebkur nu Sastāvdaļasvai Savienojumidaļa pētnieks skatu un izvēlieties Pārbaudiet ierobežojumi.

Apstiprināt ierobežojumi

2. Noklikšķiniet uz Sīkāka informācijapogu uz Brīdinājumilogu, lai redzētu, kur arhitektūras pārkāpj jebkādus ierobežojumus, kas ir definēti.

Piezīme

Pārkāpumi tiek parādītas tikai tiem ierobežojumiem, kas ir noteikti, lai jābrīdina vai izpildīt. Turklāt formulējums brīdinājuma ietvers "vajadzētu", ja ierobežojums ir tikai brīdinājums vai "must", ja tas tika ieviests.

3. Uzklikšķiniet labi.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli


Attīstās savu arhitektūru

Navigācija: Populating savu arhitektūru> Populating manuāli> papildus iespējas>

Attīstās savu arhitektūru

Nosūtīt komentārus par šo tēmu.

Arhitektūras var nepārprotami attīstījies un hierarhija arhitektūras izveidots. Līdz ar jaunām savu arhitektūru ABACUS, var izveidot vairākas uzlabotas arhitektonisko risinājumu, salīdzinot un baselined. Mērķi (vai metrika) var definēt jebkuram arhitektūras īpašībām esošajiem arhitektūras numuru.

Vienkāršs veids, kā apsvērt attīstību arhitektūra ir saistīt to ar jēdzienu pēcnācējs arhitektūra. Ja arhitektūra ir attīstījusies A kopijamātes arhitektūru ir izveidots. Šo eksemplāru var teikt, ka tieši pēcnācējsno oriģināla vecāksarhitektūra.

Piezīme

Šajā tiešsaistes palīdzība dokumentācijas un ABACUS rīku komplekts pati, termins attīstītir biežāk izmanto nekā termins pēcnācējsLūdzu, ņemiet vērā, ka gan attiecas uz pašu funkcionalitāti.

Attīstīties esošo arhitektūru

1. Pārliecinieties, vai ir ABACUS failsatvērtas un Explorer Windowparādīts.

2. Izvēlieties atbilstošu arhitektūru vēlaties attīstīties no pētnieks koka.

3. Labo klikšķipar arhitektūru un izvēlieties Attīstītiesno izvēlnes.

Attīstās izvēlētajā Arhitektūra

4. Izdalījusies arhitektūra parādīsies zem izvēlētā arhitektūru.

Evolved Arhitektūra

Piezīme

Izdalījusies arhitektūra var pārdēvēt ar tiesības noklikšķinot uz arhitektūru un izvēloties Pārdēvēt.Turklāt visas diagrammas un katalogus, kas attīstījusies arhitektūrā tiks automātiski iestatīts uz "diff" pret sākotnējo arhitektūru ka tā ir attīstījusies no.

Nosakot mērķus jūsu attīstījusies arhitektūra

Nosakot mērķus jūsu attīstījusies arhitektūra ļauj jums izveidot kritērijus, lai novērtētu attīstību savu arhitektūru. Mērķi nosaka īpašuma veidiem un nosaukumiem tām īpašībām, kas pastāv jūsu attīstījās arhitektūrā. Mērķi var būt arī manuāli definēt un pievieno jums arhitektūru. Izpildiet soļus, lai izvirzītos mērķus.

Nosakot mērķus no esošajiem īpašumiem jūsu attīstījusies arhitektūra

1. Pārliecinieties, vai ir ABACUS failsatvērtas un Explorer Windowparādīts.

2. Izvēlieties Rīki | Uzstādīt mērķusNo galvenās izvēlnes joslā.

3. Goal Inputlogs.

Goal ievades logu

4. Klikšķiniet uz Esošāspoga.

5. Izvēlieties īpašumulogs.

6. Izvēlieties īpašumu, kuru vēlaties iestatīt kā mērķi savu attīstījies arhitektūru un noklikšķiniet uz labipoga.

7. Izvēlētais mērķis tagad parādīsies Goal Inputlogu.

8. Izvēlieties mērķi un noklikšķiniet uz Rediģētpoga.

9. Edit Goallogs.

Piezīme

Šis logs ļauj mainīt īpašuma nosaukumu un veidu, ka mērķis būs jāatspoguļo kā arī sliktāko un labāko cenas (vai minimālo / maksimālo vērtību) par šo īpašumu. Šīs vērtības ir atrodami, salīdzinot visus arhitektūras un atrast mazāko un lielāko vērtību, katrs par šo konkrēto īpašumu. Šīs vērtības var arī manuāli definēt. Piemēram, ja tu būtu, lai uzstādītu vārtus īpašuma nosaukumu Response (Ave)un tipa Uzvedība, Jūsu sliktākā un labāko cenas varētu atspoguļot darījuma ātrumu, kāds nepieciešams, lai nodrošinātu optimālu veiktspēju (Best Value) un darījuma ātrumu, kas vajadzīgs tikai galvenajiem lietojumiem tiks pārstrādātas (sliktākais vērtības).

10. Kad attiecīgie vērtības ir noteiktas, izvēlieties labi.

Nosakot mērķus no jaunām īpašībām jūsu attīstījusies arhitektūra

1. Pārliecinieties, vai ir ABACUS failsatvērtas un Explorer Windowparādīts.

2. Izvēlieties Rīki | Uzstādīt mērķusNo galvenās izvēlnes joslā.

3. Goal Inputlogs.

4. Klikšķiniet uz Jaunspoga.

5. New Goallogs.

Piezīme

Šis logs ļauj noteikt nekustamā īpašuma nosaukumu un veidu, ka mērķis būs atspoguļot, kā arī sliktāko un labāko vērtību (vai minimālās / maksimālās vērtības) par šo īpašumu. Piemēram, ja tu būtu, lai uzstādītu vārtus īpašuma nosaukumu Response (Ave)un tipa Uzvedība, Jūsu sliktākā un labāko cenas varētu atspoguļot darījuma ātrumu, kāds nepieciešams, lai nodrošinātu optimālu veiktspēju (Best Value) un darījuma ātrumu, kas vajadzīgs tikai galvenajiem lietojumiem tiks pārstrādātas (sliktākais vērtības).

6. Kad attiecīgie vērtības ir noteiktas, izvēlieties labi.

7. Dialoga ar Pievienot visiem arhitektūrasparādīs, kā norādīts zemāk:

8. Klikšķiniet uz Jāpievienot mērķi kā īpašumu uz visiem attiecīgajiem arhitektūrām. Tas nodrošina, ka nesen definēts mērķis, un tā īpašības tiks pievienots visiem arhitektūras failā. Ja jūs nevēlaties iekļaut īpašumu par arhitektūras, jūs varat noklikšķināt uz Nē.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Apskata zvaigzne apzaļumota jūsu attīstījusies arhitektūru | Apskatot izbārstīt gabals jūsu attīstījusies arhitektūru


Zīmējuma Tool

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Zīmējuma Tool

Nosūtīt komentārus par šo tēmu.

Zīmējumā rīks ļauj izveidot plašu arhitektūras shēmas un diagrammas. Arhitekti tradicionāli izmanto virkni dažādu zīmējumi ierakstīt un nodot dizainu ar arhitektūru. Divdimensiju (2D) diagrammas ir parastais veids, dokumentējot un paziņot dažādu daļu no sistēmas. Tipiski zīmējumi veidi, ko izmanto uzņēmumu sistēmās, ir:

· Biznesa procesu modeļi un diagrammas;

· Struktūras shēmu;

· Sadarbības diagrammas;

· Entity-Attiecības (ER) diagrammas;

· Datu plūsmu diagrammas (DFD s);

· Klašu diagrammas;

· IDEF (iekļaujot vairākas no iepriekš minētajām); un

· UML (iekļaujot vairākas no iepriekš minētajām).

Tur tiešām nav ierobežojumu ar diagrammām veidiem, ko var izveidot. ABACUS mēģina līdzsvarot diagramma elastību, vienlaikus saglabājot integritāti arhitektūru un tās formām pārstāvību.

Zīmējums vide ir tabbed un dockable logu iekšpusē galvenais ABACUS pieteikumu. Šis logs ir audekls, kurā zīmējums notiek, un tad, kad zīmēšanas logs ir atvērts otru dockable logu , Trafaretu logs, ir apskatāms ar virkni zīmēšanas stencils. Trafaretu rūts ir 4 cilnes: sastāvdaļu un savienojumu, formas un savienotājus. Audekls parādās kā balta fona ar smalku režģa līnijas (noderīga izkārtojums).

Sastāvdaļas pārstāv virkni formas, bet savienojumi ir sagatavots kā vērsti līnijas. Savienojumi pievienot komponentiem, izmantojot lomas (tas nu Avots vai Sink) lai gan tie nav parādītas estētisku apsvērumu dēļ.

Gals

Kamēr diagrammasir ļoti noderīga, lai parādītu dažādas daļas sistēmu, tie ir ierobežoti savā mērogojamību, kas ir iemesls, kāpēc ABACUS izmanto 3D vizualizēt sarežģītas sistēmas struktūras.

Jūs varat

1. Atveriet Shēmu Instruments

2. Izveidot jaunu diagrammu par daļu no jūsu arhitektūru

3. Kopēt diagrammu ietvaros vai starp arhitektūru

4. Sajauc komponentus ar diagrammu

5. Izveidot jaunas detaļas un savienojumi savā arhitektūrā (shematiski), izmantojot zīmēšanas rīku

6. Dzēst sastāvdaļas no diagrammā

7. Pievienojiet & manipulēt savienojumi

8. Mainīt displeja īpašības Detaļu un savienojumu.

9. Izmantojot saites diagramma

10. Ieviest veida apvienības un viedokļi tā kā ierobežot diagrammas tipu, kas izdarāmi.

Skatīt arī

Aizpildi savu arhitektūru | Aizpildi savu arhitektūru manuāli | Analizējot Jūsu arhitektūra


Atvēršanas diagrammas

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Atvēršanas diagrammas

Nosūtīt komentārus par šo tēmu.

Zīmējumā trafaretu un audekla logi parādās automātiski, kad shēma ir atvērts vai izveidots. Līdzīgi, kad diagramma ir slēgta, atbilstošais tabbed lapa ir audekls logā pazūd, un, ja nav turpmākas zīmējumi ir vaļā, tad trafaretu logs ir aizvērts.

Līdz izveidotjauna diagramma

1. Pārliecinieties, vai irABACUS fails atvērtssatur Jūsu apdzīvots arhitektūra.

2. Klikšķiniet uz Diagramikona View rīkjoslā.

- Vai -

2. Atlasīt Ievietot| Diagram.

- Vai -

2. Labo klikšķi Diagrammasfiliāle konkrētā Arhitektūrasadaļa koku un izvēlieties Izveidot Diagramma.

3. Izvēlieties ArhitektūraJūs vēlaties, lai koncentrētos uz no nolaižamās izvēlnes. Piezīme: arhitektūra jau būs atlasīta, ja tu izmanto 3. solis augstāk, lai atvērtu jaunu diagrammu.

4. Izvēlieties Viedoklis vēlaties izmantot no nolaižamās izvēlnes. Piezīme: izvēlētais viedoklis filtrēs sastāvdaļas un savienojumiem sarakstus, lai būtu tie, kas pieejami par viedokļa tikai.

5. Pēc izvēles izvēlies skatījumu no laukuma Filter By Viewpull-down menu iepriekš izvēlētos sastāvdaļas un savienojumus no izvēlētā skatu. Piezīme: šis ir efektīvi lietot izvēlēto skatu kā saglabāto vaicājumu.

6. Izvēlieties Izkārtojums vai nu Radiāls vai Grid.

7. Izvēlieties Sastāvdaļasun Savienojumika jūs vēlaties diagrammā no standarta elements izvēles logs .

8. Uzklikšķiniet labi.

Piezīme

Jauna diagramma tiek pievienota ar Diagrammasfiliāle arhitektūru. Tas būs noklusējuma nosaukumu, kuru jūs varat mainīt vēlāk, ar peles labo pogu noklikšķinot uz tā.Turklāt pēdējais stāvoklis sastāvdaļu un savienojums atlases filtri tiks saglabāts ar diagramma efektīvi ietaupot "vaicājumu", ko izmanto, lai izveidotu diagrammu.

Lai atvērtu esošu diagramma

1. Konkrētajā apdzīvotās arhitektūru, paplašināt Diagrammasfiliāle koku.

2. Dubultklikšķi diagramma vēlaties atvērt.

Lai saglabātu diagramma

1. Pārliecinieties, ka jums ir jaunu vai esošu diagrammu atvērtsun esat veicis nepieciešamās izmaiņas. Piezīme: zvaigznīti "*", tiks parādīti pēc skata nosaukuma tabbed lapas galvenē ja ir izmaiņas tiks saglabātas.

2. Jo pētnieks uzskata, noklikšķiniet uz Saglabātpogu vai nokļuvis Fails| Saglabātvai nospiediet Ctrl + Slai saglabātu visas izmaiņas savā arhitektūrā un rakstīt to failā.

Lai saglabātu diagramma kā viedoklis

1. Pārliecinieties, ka jums ir esošo diagrammu jūsu ABACUS failā.

2. Labo klikšķizīmējumā Diagrammasdaļa no koka.

3. Atlasīt Saglabāt kā Diagramma Viedoklis.

4. Ievadiet savu jauno diagramma viedoklisun noklikšķiniet labi.

Skatīt arī

Zīmējuma Tool | Aizpildi savu arhitektūru | Analizējot Jūsu arhitektūra


Kopēšanas diagrammas

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Kopēšanas diagrammas

Nosūtīt komentārus par šo tēmu.

Ir 2 galvenie scenāriji kopējot esošo diagrammu; ietvaros arhitektūru, vai pāri arhitektūras.

Līdz kopijadiagrammaietvaros arhitektūru

1. Pārliecinieties, vai irABACUS fails atvērtssatur Jūsu apdzīvots arhitektūraar vismaz vienu diagramma.

2. Paplašināt Diagrammasfiliāle (un jebkuru nepieciešama Diagramma grupas) no konkrētā Arhitektūrasadaļa koka.

3. Izvēlieties diagrammu vēlaties kopēt, un pēc tam nospiediet Ctrl + Cvai labo klikšķiun izvēlieties Kopija no izvēlnes.

Piezīme

A eksemplārs diagramma tiek pievienota ar Diagrammasfiliāle tas pats arhitektūra. Tas būs "Kopija", pievieno sākuma nosaukuma, Kuru jūs varat mainīt vēlāk nospiežot F2 vai peles labo pogu noklikšķinot uz tāun izvēloties Pārdēvēt.

Līdz kopēt diagrammu pāri arhitektūras

1. Pārliecinieties, vai irABACUS fails atvērtssatur Jūsu apdzīvots arhitektūrasar vismaz vienu diagramma.

2. Paplašināt Diagrammasfiliāle (un jebkuru nepieciešama Diagramma grupas) no Arhitektūrasadaļa kokapar arhitektūru, kas satur diagrammu vēlaties kopēt.

3. Izvēlieties diagrammu vēlaties kopēt, un par Vispārējie Propertieslogs piezīme Viedoklis ka diagramma ir saistīts ar (Laukā Type).

4. Tagad, paplašināt Diagrammasfiliāle (un jebkuru nepieciešama Diagramma grupas) no Arhitektūrasadaļa kokapar citu arhitektūru, kas jūs vēlaties kopēt diagrammu vērā.

5. Labo klikšķi Diagrammas mezgls (vai Diagramma grupa) Un izvēlieties Izveidot diagramma .... Dialoglodziņā, kas parādās, izvēlieties Viedoklis kas tika norādīts iepriekš 3. solis nolaižamā pie augšējā labajā stūrī. Atstājiet viss pārējais, kas ir un noklikšķiniet labi. Diagrammā nosaukums dialog ievadiet nosaukumu (drīzumā) nokopēto diagrammā. Piezīme: Tukša diagramma audekls atbilstoši izvēlētajai viedokļa tiks atklāta.

6. Atgriezties uz diagrammas, kuru vēlaties kopēt, un atvērt, ka, peles labo pogumezglu un izvēloties Atvērts vai vienkārši dubultklikšķitā.

7. Izvēlieties fona audekls no diagrammas vēlaties kopēt, un nospiediet Ctrl + A. Tas būs izvēlēties visus elementus par šo diagrammā. Tagad nospiediet Ctrl + CLai kopētu saturu uz starpliktuvi.

8. Tagad, atgriezties tukšajā diagrammā arhitektūrā vēlaties kopēt saturu, izvēlieties fonuaudekls un vai nu labo klikšķiun izvēlieties Pasta vai vienkārši nospiediet Ctrl + Vielīmēt saturu. Pēc īsa laika saturs visi tiks ielīmēts jaunajā tukšu diagrammā.

Piezīme

Elementi tiks pievienota jaunā arhitektūra augšējā līmenī un būs pārkārtoti vai apvienojās ar esošo saturu atbilstoši.

Skatīt arī

Zīmējuma Tool | Aizpildi savu arhitektūru | Analizējot Jūsu arhitektūra


Aizpildi diagrammas

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Aizpildi diagrammas

Nosūtīt komentārus par šo tēmu.

Zīmējumi ABACUS ir vairāk nekā tikai patvaļīgu pārstāvniecībām. Tie ir pielāgoti skats uz arhitektūru, formatēti un izvietotas tā, lai parādītu īpašu nozīmi.

Zīmējumā Tool īsteno hierarhisko struktūru arhitektūru, lai sastāvdaļas ir vizuāli ligzdots citas sastāvdaļas - faktiski dodot "plāns viedokli" par elementiem. Pēc tam, kad sastāvdaļa vai savienojums ir definēts arhitektūru, to var izmantot jebkurā no dažādu diagrammu skaitu. Svarīgi, ka Drawing Tool ir cieši saistīta ar arhitektūras modeli, lai izmaiņas darīts vai nu vienā vienmēr atspoguļojas otru.

Rīks darbojas, saistot formas ar īpaša saikne un sastāvdaļu tipiem, kas definēti veidi sadaļā arhitektūru. Šīs apvienības mainīties atkarībā no diagrammas tips tiek izstrādāts, un tas ir iespējams, ka viena veida sastāvdaļu (vai savienojumu), var būt dažādas pārstāvniecības dažādās diagrammas, atkarībā no konteksta.

Izveidot asociāciju starp formu un sastāvdaļas vai savienojuma veidu

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Palieliniet Abacus pieteikumu, un konfigurēt logu proporcijas kā jūs vēlaties.

3. Izvēlieties Tab Shapesvai Tab savienotāji ar trafaretu logā.

4. Iekš Typefiliāle Explorer atrodiet detaļas vai savienojuma veidu, kuru vēlaties saistīt ar formas vai savienotāju.

5. Izvēlieties izvēlēto tipa elementu no koka, velciet to pa tab formas vai cilnes Connectors, un nometiet to uz formas vai savienotājuJūs vēlētos izmantot.

Piezīme

Jūs varat pārbaudīt asociāciju esat izveidojis, izvēloties sastāvdaļas vai cilni Savienojumi trafaretu logā, kas liecina, ka pašlaik saistītos elementus.

Lai pievienotu jaunas formas, lai jūsu diagrammas / bibliotēkā

1. Izveidot MS Visio diagrammu ar formām, ko vēlaties pievienot savam diagrammu un importēt MS Visio diagrammu .

Gals

Tas ir svarīgi, kāda izmēra jūs veicat galveno formu MS Visio jo ABACUS audekls tiek lieluma pikseļos un tikai milimetri vienības MS Visio pārvērst granularly uz pikseļiem uz 4 pikseļu līdz 1 milimetru attiecību. Turklāt, noklusējuma ABACUS formas parasti ir 60 pikseļus augsts, lai pārveido līdz 15 milimetriem MS Visio. Paredzot ieteicams meistars forma izmērs MS Visioir 25mm plata un 15mm augstsjo tas tulkot uz 100 pikseļiem plats 60 pikseļu augstu ABACUS.

Gals

Ja jūs vēlaties, lai būtu nedaudz "ikonu" augšējā kreisajā stūrī formas, tad jūs varat vienkārši radītu "ikonu" galvenajā MS Visio formas, izmantojot MS Visio zīmēšanas rīku palete (ņemiet vērā, ka tikai vienkāršas līnijas, apļi un taisnstūri tiek atbalstītas un rastrētam / bitmap figūras īpaši netiek atbalstīti). Turklāt, ja jūs vēlaties ikona būt noteikta izmēra / skalāietvaros formas ABACUS tad jūs varat Grupa "ikonu" galvenajā MS Visio formas, izvēloties visus tās elementus, peles labo pogu noklikšķinot vienu elementu, izvēloties formas | Grupa, tad ar peles labo noklikšķinot sagrupētas formu un izvēloties dati | Forma datus ..., izvēloties Jā Dialoglodziņā, kas parādās, un pēc tam pievienojot īpašumu ar etiķeti, kas līdz LockScale(ņemiet vērā, ka lielais "L" un "S"), tipa iestatīts uz Bula un noteikt vērtības, kas TRUE (ņemiet vērā, tas ir viss, ar lielajiem burtiem).

Gals

Ja jūs vēlaties, lai būtu daļa no formas saldēta no mērogošana horizontāli vai vertikāli (kā tas ir tipisks ar "swimlane" formas), tad jūs varat ar peles labo pogu noklikšķiniet uz daļu (-us) kapteiņa MS Visio formas, kuru vēlaties saldētas no mērogošana un izvēlieties dati | Forma datus ..., izvēloties Jā Dialoglodziņā, kas parādās, un pēc tam pievienojot īpašumu ar etiķeti, kas līdz LockXScalevai LockYScale (ņemiet vērā, ka lielais "L" un "S"), tipa iestatīts uz Bula un noteikt vērtības, kas TRUE (ņemiet vērā, tas ir viss, ar lielajiem burtiem), par aizslēgtas horizontāli vai vertikāli mērogošana attiecīgi.

Gals

Lai atļautu iekrāsojums formas ABACUS pēc importēšanas, nevis forma vienmēr ir fiksēts krāsa ieteicams padarīt meistars MS Visio SHAPE ir aizpildīt caurspīdīgs un pēc tam izmantot iekšēja spēju ABACUS uz krāsu formas ir fona. Tas darbojas tikai ar taisnstūra vai gandrīz taisnstūra (piem noapaļota taisnstūra formas), kā visa taisnstūra fons tiks krāsots.

2. Atveriet atbilstošo diagrammu un izvēlieties Tab komponentiar trafaretu logā.

3. Par katru jaunu formu, kuru vēlaties padarīt pieejamu citiem diagrammas Labo klikšķiforma un izvēlieties Pievienot formas bibliotēka. Tas padarīs forma pieejami cilnē formas trafaretu logā.

4. Iesaistīt attiecīgo detaļas tipa ar jauno formas no formas bibliotēkas saskaņā ar iepriekš aprakstītās.

Piezīme

Tikai vienkāršs un "vektora balstītu" formas, tiek atbalstīta ABACUS brīdī, ti, bitkartes netiek atbalstīti. Tomēr instrumentus, piemēram, Vector Magic ( www.vectormagic.com ) Ir pieejams, kas būs viegli pārvērst bitmap attēlus vektoru balstītas formas (ti SVG formāts), kas var atvērt MS Visio un līdz ar to izmantotiem ABACUS kā par iepriekš minētajiem norādījumiem.

PievienojotKomponenti un savienojumi

Zīmējumā rīks ļauj jums pievienot esošās sastāvdaļas un savienojumus no glabātavas vai izveidot jaunus komponentus un savienojumus, kā jūs zīmējat diagrammu. Kā komponenti un savienojumi ir izveidoti diagrammas, tos vienlaicīgi pievienoti uz krātuve. Tur ir trīs ieteicams veidi pievienojot komponentus, lai diagrammāun trīs ieteica veidus, pievienojot savienojumus ar diagrammu:

Lai izveidotu pilnīgi jaunu sastāvdaļu vai savienojumu diagrammāno trafaretu

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Izvēlieties Sastāvdaļasvai Savienojumitab trafaretu logā, lai redzētu saistītos formas. Tikai šie formas var izmantot, lai izveidotu jaunu modeļa blokus.

3. Noklikšķiniet un velcietviens no pieejamajiem saistīto formas uz zīmējuma kanvas. Jaunais elements parādīsies uz audekla, gan pētnieks kokā.

4. Sāciet rakstītnosaukumu jaunā elementa dialog un jebkuriem esošajiem elementiem, kas tiek salīdzināti tiek ierosināts, un var izvēlēties, nevis pievienojot jaunu elementu arhitektūrai.

5. Uzklikšķiniet labi.

6. Ja forma bija nokritusi uz esošas detaļas, tad tas būs vai nu kļūt bērns šī komponenta (ja forma nāca no Sastāvdaļastab), vai tiks pievienots šim komponentam (ja forma nāca no Savienojumitab).

Piezīme

Dažreiz ir nepieciešams pielāgot jauno komponentu vai savienojumu uz citu vietu arhitektūras hierarhijas izmantojot pētnieks.

Lai novietotu esošo komponentu vai savienojumu no krātuve uz diagrammā

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Pārliecinieties, ka jums ir gan zīmēšanas rīku un Explorer logus apskatīt.

3. Jo Explorer, atrodiet komponentsvai saistība(elements) jūs vēlētos pievienot diagrammu.

4. Noklikšķiniet un velcietizvēlētais elements uz diagrammā. Formu, kas pārstāv elementu parādīsies uz audekla.

Piezīme

Ja izvēlētā elementa tips jau ir saistīts ar formu, atbilstošā forma parādīsies uz audekla. Ja tomēr nav noteikta apvienība konkrēto elementa, noklusējuma forma (taisnstūris) parādīsies uz audekla, ja vien Ieviest diagramma Viedokļi iespēja ir par un tādā gadījumā forma netiks pievienots ar diagrammu.

Gals

Ja sastāvdaļa ir likts uz diagrammu, kas ir savienots ar citu sastāvdaļu jau diagrammā, zīmējuma Tool griezīsies, ja jūs vēlētos, lai parādītu saikni (-i) starp tiem. Arī tad, ja ir kādi komponenta bērni zīmējuma Tool griezīsies, ja jūs vēlaties, lai iekļautu bērnus, tādā rekursīvo veidā.

Līdz izveidotu savienojumu starp 2 komponentu vai pievienotā komponenta diagrammā, izmantojot dinamisku savienotājs

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Savilkties vairāk detaļas uz diagrammā, kuru vēlaties izveidot savienojumu ar citu sastāvdaļu, un jūs ievērosiet 2 ikonas ārpus augšējā labajā stūrī robežas formas, kā parādīts zemāk. Piezīme: Top ikona ir, lai izveidotu savienojumu, kur lidinājās komponents ir avots, apakšā ikona ir, lai izveidotu savienojumu, kur lidinājās elements ir izlietne.

3. Pārvietot kursoru vajadzīgajai ikonai un noklikšķiniet un velcietikona līdz vairāk vai nu uz citu komponentu vai brīvas vietas uz audekla, kā parādīts zemāk.

4. Lai izveidotu savienojumu ar esošo komponentu izvēlēties Pievienot ...prece pop-up izvēlnē un, ja nepieciešams, pārlūkojiet apakšizvēlnē izvēlēties no pieejamajām pieslēguma veidu.

- Vai -

4. Lai izveidotu saistīts komponents izvēlējās no New ...Preces pop-up izvēlnē un, ja nepieciešams, pārlūkojiet apakšizvēlnē izvēlēties no pieejamajām pieslēguma veidu, kā parādīts zemāk. Sāciet rakstītnosaukumu jaunā elementa dialog un jebkuriem esošajiem elementiem, kas tiek salīdzināti tiek ierosināts, un var izvēlēties, nevis pievienojot jaunu elementu arhitektūrai.

Piezīme

Par posteņiem pop-up izvēlnē un apakšizvēlnē pieejamība regulē ierobežojumi meta-modeli.Tas ir tikai derīgs avots vai izlietne komponentu veidus kā to nosaka pieslēguma ierobežojumi tiks prezentēts kā Pievienojiet to ... un New ... izvēlnes elementiem.

Līdz atkārtoti atvērt elements izvēles dialogu un novietot esošās sastāvdaļas vai savienojumus no glabātavas uz diagrammā

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Uzklikšķiniet Atvērt Element atlasepoga diagrammā rīkjoslā. Piezīme: elements atlase dialog atklās ar pēdējo stāvokli filtrus saglabātas.

3. Izvēlēties jebkādu papildu saturu, kas ir vēlamā jāpievieno ar diagrammu un klikšķi labi. Piezīme: jaunais saturs tiks pievienota skaidru vietu uz audekla un diagramma var būt tam izklāstīts atkal caur Layout diagrammapoga diagrammā rīkjoslā.

Izmantojot FreeformaFormas

Tas bieži vien ir vēlams radīt vizuālos elementus diagrammu par tīri estētisku apsvērumu dēļ. Šie elementi var palīdzēt uzlabot izkārtojumu un izskatu diagrammā, tomēr tie nav stingru arhitektūras nozīmi. Zīmējumā rīks ļauj izmantot brīvās formas formas izmantošanu, lai nodrošinātu zīmēšanas elastību.

Lai pievienotu brīvformas formu diagrammā

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Izvēlieties Formasvai Savienotājitab trafaretu logā.

3. Noklikšķiniet un velcietviens no pieejamajiem formas vai savienotāju uz zīmējuma kanvas. Jaunais elements parādīsies uz audekla - bet navšajā pētnieks kokā.

Piezīme

Brīvo formu formas tiek "neasimilēto" formas, jo viņiem nav saistību ar kādu konkrētu komponentu vai savienojumu arhitektūras modeli.

Līdz parādīt krātuve informāciju brīvformas formas uzdiagramma

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Labo klikšķibrīvformas forma un izvēlieties Anotācija | Displejs.

3. Izvēlieties, lai parādītu vai nu Diagramma nosaukums, Diagramma Apraksts, Diagramma Property, Viedoklis Namevai Arhitektūra Name.

Piezīme

Tekstam Freeform automātiski atjauninās, jo pamatā esošo glabātavu datu izmaiņām.Tādā veidā diagramma "title bloks" var izveidot, un tad viegli kopēt pāri, diagrammas.

Izmantojot Floating formas

Peldošās formas būtībā ir vēl viens veids, kā pārstāvēt komponentus diagrammā. Apsveriet organizācija ar galveno nodaļām: izpilddirektors, mārketinga, pārdošanas un attīstības.

Tree View

Šos pārsegumus var vizuāli pārstāvētas slāņveida veidā:

Layered View

Vai tie var būt vizuāli pārstāvētas pa daļām / Peldošās veids, lai parādītu hierarhiju:

Pa daļām / Peldošās Skats

Pēdējais pārstāvniecība lieto jēdzienu peldošo formas.

Lai pārvērstu slāņveida detaļas forma vērā mainīgo formu

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Izvēlieties komponentsJūsu diagrammā vēlaties pārstāvēt kā peldošā formas vai asociētā veidojās Sastāvdaļastab par trafaretu loga vēlaties, visus gadījumus, kā peldošo formas.

3. Ar peles labo pogu noklikšķiniet uz formas un izvēlieties Float Daļas no konteksta izvēlnes, kas parādās. Ņemiet vērā, ka dimanta vada savienojumuno mātes komponenta (u) uz peldošā sastāvdaļu (-ām).

4. Noklikšķiniet un velcietkomponents uz vajadzīgo vietu. Kad peldošsir izvēlēts elements tas būs zils kontūru.

Lai pārvērstu peldošu detaļas forma uz slāņveida formu

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Izvēlieties komponentsJūsu diagramma, kas pašlaik tiek parādīts kā peldošā formas vai asociētā veidojās Sastāvdaļastab par trafaretu loga vēlaties visus gadījumus, kā kārtojumu formas.

3. Noklikšķiniet un velcietpeldošais komponents (-i), atpakaļ uz vecākiem (-iem) (saskaņā ar dimanta vada savienojumu). Piezīme: Ja jums nav darīt, tad, kad jūs pārvērst sastāvdaļa (s) atpakaļ tiek kārtains hierarhija savu modeli varētu tikt ietekmēta.

4. Ar peles labo pogu noklikšķiniet uz formas un unselect Float Daļas no konteksta izvēlnes, kas parādās. Ņemiet vērā, ka dimanta vada savienojumuno mātes komponents (-i) uz peldošā sastāvdaļu (-ām) izzūd.

Kopijas

Zīmējumā rīks ļauj jums pievienojiet to pašu komponentu diagrammā vairākas reizes ar katru papildu vizuālo instancē komponentes diagrammā tekstā reprodukcija. Tas ir īpaši noderīgi, lai diagrammas, kur komponents ir liels skaits, kas tai pievienoti savienojumiem, un tas ir vēlams, lai parādītu komponentu vairākās vietās tuvāk izcelsmi katru no savienojumu, vai diagrammām, kur viens pret daudziem attiecības kādas sastāvdaļas ir vēlams, lai parādītu, izmantojot peldošo funkciju (kā aprakstīts iepriekš) ar komponenta vairākām vietām uz augšu "daudziem" komponentiem tas ir saistīts ar.

Piezīme

Var pievienot / atdalīt savienojumus uz / no sākotnējā piemēram komponenta diagrammā (kā vienmēr), bet arī uz kādu no kopijas, tomēr, kad savienojumi tiek automātiski pievienota pie diagrammu tie ir pievienoti, pirmkārt, no komponenta diagrammā pēc noklusējuma.

Piezīme

Kopijas var apvienot ar otru ar ar peles labo pogu un velciettad izvēloties Apvienot kopijasTomēr, apvienojot reprodukcija ar citu komponentu radīs jebkādu citu atdarinājumus pazūd no diagrammas.

Piezīme

Nav vizuālā atšķirība starp sākotnējo gadījumu sastāvdaļas diagrammā un jebkuru atdarinājumus. Turklāt labo klikšķi izvēlnē uz sākotnējo komponenti diagrammā un jebkuru atdarinājumiem ir identisks, ar piemēram Rādīt Explorerņemot jums uz to pašu sastāvdaļu koka skatā no glabātavas (aka no modeļa). Tomēr labo noklikšķinot komponentu koka skatījumā glabātavas un izvēloties Iet uzun pārlūkošanas uz diagramma ar atdarinājumus vienmēr aizvedīs uz "vecākā" instanci komponentes diagrammā. Parasti tas būs oriģināls instance, kas tika pievienots ar diagrammu, bet, ja tas oriģināls instance vēlāk tika dzēsts vai apvienots ar reprodukcija tad iet uz būs lēkt uz vecākā no atlikušajām atdarinājumiem, kas tika pievienoti.

Līdz pievienot reprodukcija līdz A diagramma

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Ar peles labo pogu noklikšķiniet esošo komponentu diagrammā un izvēlieties Izveidot Replica.Reprodukcija no izvēlētās sastāvdaļas tiks izveidota pa labi no sākotnējās sastāvdaļas.

- Vai -

Izvēlieties esošu sastāvdaļa diagrammā un nospiediet Ctrl + Cvai peles labo pogu noklikšķiniet esošo komponentu diagrammā un izvēlieties Kopija. Tagad labo pogu noklikšķiniet uz atrašanās vietu diagrammā, ko vēlaties reprodukcija un izvēlieties Ielīmēt kā Replica. Piezīme: Nospiežot Ctrl + V (vai peles labo pogu noklikšķinot un izvēloties pastas) radīs oriģināla kopiju sastāvdaļas nav reprodukcija.

- Vai -

Noklikšķiniet un velcietkomponents no koka skatā no glabātavas (aka modeļa) uz diagrammu, kur jau pastāv komponents.

Savienojuma griesti / Beigas konfigurēšana

Zīmējumā rīks ļauj jums noteikts simbols, ko izmanto galos un savienojumu līnijas vai nu ar noteiktu simbolu vai simbolu kas ir atkarīgs no īpašuma par savienojuma pats.Tas ir īpaši noderīgi, lai diagrammas, kur virziens pieslēgumu ir pienākums pierādīt, vai uz diagrammām, kur cardinality savienojuma (vai virzienā) ir ietverti īpašumu uz savienojuma pati, piemēram, "One-to-Daudzi" vs "daudzi pret daudziem" (vai "Avots izlietne" vs "izlietne avots").

Līdz konfigurēt savienojumu vāciņi / beidzas diagramma

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open.

2. Izvēlieties Savienotjonitab trafaretu logā.

3. Right-claizīšana viens no saistīta savienojuma veidu un izvēlieties Konfigurēšana Caps ....

4. Uz noteiktu savienojuma vāciņu / beigām nu avotu vai izlietne galu savienojumu pārliecināties attiecīgais Fiksēts ir izvēlēts radio pogas un pēc tam izvēlieties savienojuma beigu simbolu no nojaukt, piemēram, "Arrow Head" vai "Diamond".

- Vai -

Par nekustamā īpašuma bāzes savienojuma uzgalis / beigām nu avotu vai izlietne galu savienojumu pārliecināties attiecīgais Izmantojot īpašumuir izvēlēts radio pogas, tad noklikšķiniet uz "..." pogu un izvēlēties nepieciešamo mantu un tad pie katra savienojuma gala simbolu ievadiet īpašuma vērtības, par kuru konkrētais savienojums simbols tiek parādīts.

Piezīme

Vairāki īpašuma vērtības konkrētā savienojuma gala simbolu var ievadīt atdalītas ar komatiem.Piem Turpmāk dialogs pierāda, ka, ja "datu | Cardinality "īpašums ir vērtība" One-to-Daudzi ", tad avots beigas savienojuma būs divas līnijas insultu caur to un izlietne beigas savienojuma būs viena līnija insults caur to, un pēc tam ventilators-out no divām līnija insultu beigās.

Konfigurēt Caps dialog

Skatīt arī

Zīmējuma Tool | Aizpildi savu arhitektūru | Analizējot Jūsu arhitektūra


Manipulēšana diagrammas

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Manipulēšana diagrammas

Nosūtīt komentārus par šo tēmu.

Kad diagramma ir izveidota, elementi, kas parādās tajā var pārkārtoti un atkārtoti izmēra, kā vēlamo.

Lai pārvietotu komponentu diagrammu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Click-un-turētjebkurš komponents, lai to pārvietotu. Ja izvēlētais elements ir vecāks, vecāks komponents tiks iezīmēts.

3. Tā kā elements irvilka no savas mātes sastāvdaļas, un salīdzinājumā ar citiem komponentiem, "iespējams" vecāki kļūs izcelti. Izmantotā krāsu shēmu norāda efektu darbība būs uz brīdinājumiem un kļūdas ar pašreizējo projektu un ir aprakstīta Definēšana un apstiprināšana Ierobežojumi . Tādā veidā, jūs varat grafiski orientēties hierarhiju no "plāna skatā".

4. Atbrīvošanapeles pogu, lai nomestu elementu savā jaunajā atrašanās vietā.

Piezīme

Jūs varat arī izmantot tastatūru, lai atkārtoti pozīcijas elementus zīmējuma kanvas. Vienkārši izvēlieties detaļas vai brīvas formas formu vēlaties pārvietot un izmantot bultiņu taustiņus, kas atrodas uz tastatūras, lai pārvietotu formu uz vēlamo vietu.

Tāpat ņemiet vērā, ka tad, kad velkot komponentu ar peli uz citu sastāvdaļu, ir "potenciāls" mātes komponents ir iezīmēts, kad augšējā kreisajā stūrī komponenta jūs velkot pārklāj citu komponentu.

Gals

Freeform un Peldošās formas var pasūtīt peles labo poguun izvēloties Bring to Frontvai Nosūti Atpakaļno izvēlnes. Ir svarīgi atzīmēt, ka sastāvdaļas formas var pārveidot brīvās formas formas ar peles labo pogupar konkrētu detaļu formas un izvēloties Pārveidot uz Freeform.

Lai mainītu sastāvdaļa kādā diagrammā

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Click-hold-dragviena komponenta rokturiem un mainīt formu līdz vēlamajam izmēram.

3. Alternatīvi, lai saglabātu formu ir proporcijas, nospiediet Shift + klikšķis-turēt-vilkšanas.

Lai pārvietotu savienojumu diagrammā

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Click-un-turētjebkurš savienojums, lai to pārvietotu.

3. Atbrīvošanapeles pogu, lai nomestu elementu savā jaunajā atrašanās vietā.

Piezīme

Jūs varat pārvietot tikai savienojumi, kas nav pievienoti nekādi komponentiem. Ja tie ir pievienoti, var pārvietoties tikai brīvo galus, Vai mainīt maršrutu savienojumu .

Komponenti un savienojumi dzēšana

Dzēšot sastāvdaļu vai savienojumu no diagrammas, jums ir iespēja izdzēst to no visa arhitektūru. Jebkura sastāvdaļa, kas svītro no arhitektūras tiks automātiski izņemti no jebkurām citām diagrammām, kur tas minēts. Tā brīvformas gadījumi parādās tikai vienā diagrammā, svītrojot tos neietekmē arhitektūras modeli vai jebkuru citu diagrammu.

Lai izdzēstu komponentu vai savienojumu no diagrammā

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Uzklikšķinietpar jebkādu citu saistīto savienojumu vai sastāvdaļas, lai to izvēlētos.

3. Nospiediet IzdzēstGalvenais, lai to izdzēstu no diagrammas, vai Shift + Deleteizdzēst to no visa modeļa.

- Vai -

2. Ar peles labo pogu noklikšķiniet uz jebkura saistītā elementa vai tā sastāvdaļas. Parādīsies konteksta izvēlne.

3. Atlasīt Dzēst no skatavai Dzēst Arhitektūrano konteksta izvēlnes.

Piezīme

Ja elements, kuru vēlaties izdzēst no domām nav bērni, un tikai notiek uz šo viedokli, ABACUS jautās, vai vēlaties izdzēst elementu no krātuvei, kā arī.

Uzmanību

Dzēšot sastāvdaļa no modeļa, kas ir bērnu sastāvdaļas, bērni tiks potenciāli svītrots saskaņā ar brīdinājuma dialog.

Apvienojas komponenti

Jūs varat apvienot abas sastāvdaļas esošo tajā pašā diagrammā (un robežās no arhitektūras). To var izdarīt daudzu iemeslu dēļ, piemēram, Divi serveri pastāv laikā uzņēmuma infrastructure- H01 un H02. Šie divi serveri pārstāvēja divas atsevišķas sastāvdaļas ietvaros arhitektūru. H01 ir nepieciešami un tādējādi tiks nojaukta. Visas esošās lietojumprogrammas darbojas uz H01 tiek pārvietoti uz H02 (vēl komisijā). Šīs izmaiņas, tad var atspoguļot ko "apvienojas" abu sastāvdaļu darbības H01 un H02 diagrammā (un ietvaros arhitektūru).

Par detalizētu diskusiju par apvienojot lūdzu, skatiet, kuras apvienojas vienumi tēmu šeit .

Apvienot divas esošās sastāvdaļas

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Right-click-turētuz sastāvdaļas jūs vēlaties apvienot un vilkttas uz komponentu jūs vēlaties apvienot to ar. Pārliecinieties izklāsts mērķa sastāvdaļa ir iezīmēts sarkanā krāsā, norādot, ka tas ir izvēlēts.

3. Atlasīt Apvienot | Saglabāt galamērķivai Pārrakstīt Destinationno izvēlnes.

Piezīme

Saglabāt galamērķiopcija saglabā vērtības galamērķa komponenta īpašībām, ja tie pastāv uz izcelsmes sastāvdaļas, kā arī.

Pārrakstīt Destinationiespēja pārraksta galamērķis komponenta īpašības ar visiem kopējiem īpašības no izcelsmes sastāvdaļas.

Mainot Connections

Norādītie savienojumi diagrammu vienmēratspoguļo struktūru, kas definēta arhitektūras pati. Zīmējumā rīks ļauj atdalīt savienojumus no sastāvdaļām, pārvietot tos, līkne viņiem, atkārtoti maršruts tos un atkārtoti pievieno tos citiem komponentiem.

Atraut / pievienotu savienojumu no / uz sastāvdaļu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Click-un-turētpar jebkuru pieslēgumu.

3. Atlasītsavienojums beigas(t.i. Source vai Sink), Ka jūs vēlētos, lai atvienotu / pievienot. Piezīme: savienojuma gali ir norādītas ar maziem baltiem apļiem un lidinājās pār balto apli uz otru izraisīs "Tooltip" ierasties ar attiecīgo lomanosaukums(tas nu Avots vai Sink).

4. Vilktsavienojums galu uz jaunu atrašanās vietu (nu vakantu vietu vai sastāvdaļa) un atlaidiet peles pogu.

Piezīme

Kad savienojums gals atrodas virs derīga sastāvdaļa, kontūra mērķa sastāvdaļas tiek iezīmēts ar pārtrauktu kontūru. Izmantotā krāsu shēmu norāda efektu darbība būs uz brīdinājumiem un kļūdas ar pašreizējo projektu un ir aprakstīta Definēšana un apstiprināšana Ierobežojumi . Kad atbrīvots ka beigas the savienojums un detaļas tiek automātiski savienots(vai pievienot), Un tas ir atspoguļots arhitektūras modeli.

Lai atkārtoti maršrutam savienojumu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Novietojiet peles rādītāju virs savienojuma.

3. Turiet Shifttaustiņu uz leju un Uzklikšķinietpeles pogu izvietot savienojuma enkura punktu. Atbrīvot Shift atslēgu. Jūs varat noņemt enkura punktu, veicot to pašu darbību.

4. Click-and-dragenkura punkts atkārtoti maršruts savienojumu.

Gals

IzmantojietAlt Galvenais nevis no ShiftGalvenais, lai radītu taisnleņķa savienojumus.

Līdz līkne vai iztaisnotsavienojums

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Novietojiet peles rādītāju virs savienojuma.

3. Labo klikšķitviņš pieslēgums un konteksta izvēlnē, kas parādās, izvēlieties Līkne, Taisnleņķa vai Taisni.

Gals

Visi savienojumikonkrētā modeļa diagrammā var iestatīt, lai saliecas, taisnleņķa vai Straight ar peles labo pogu noklikšķinot uz saistīto līniju tipam, no Tab Connections no Stencil loguun izvēloties Curve, taisnleņķa vai Straight.

Līdz enkura uz noteiktu punktu uz malas formu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Izvēlieties savienojumu.

3. Novietojiet peles rādītāju virs par "balts punkts 'beigās savienojums.

4. Labo klikšķitviņš savienojums beigas un konteksta izvēlnē, kas parādās, izvēlieties Anchor Endpoint Shape.Pārvietot savienojuma galu pie vēlmes atrašanās vietu uz malas formas.

VAI

Turiet Ctrltaustiņu uz leju un claizīt-and-drag savienojums beigas Norādīt uz vēlēšanās atrašanās vietu uz malas formu.

Piezīme

Connections snap ar faktisko krustošanās to pieslēgtā formas, nevis no izgriezums no šīs formas.

Skatīt arī

Zīmējuma Tool | Aizpildi savu arhitektūru | Analizējot Jūsu arhitektūra


Zīmēšanas rīku Features

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Zīmēšanas rīku Features

Nosūtīt komentārus par šo tēmu.

Zīmējumā rīks atbalsta vairākas zīmēšanas funkcijas.

Attālināt

Mērogs diagrammā var mainīt, izmantojot tālummaiņas funkciju.

Lai samazinātu apmēru vai "zoom in"

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Prese Ctrlun "=" taustiņu.

- Vai -

2. Izvēlieties Pietuvinātpogu uz Diagramrīkjoslu.

- Vai -

2. Prese Ctrlun roll peles riteni uz priekšu. Piezīme: Šajā režīmā audekls tiks tuvinātu virzienā, kur pele ir lidinājās pār audekla.

Lai palielinātu apjomu vai "zoom out"

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Prese Ctrlun "-" taustiņu.

- Vai -

2. Izvēlieties Zoom Outpogu uz Diagramrīkjoslu.

- Vai -

2. Prese Ctrlun roll peles riteni atpakaļ. Piezīme: Šajā režīmā audekls tiks tuvinātu āru no kurienes pele ir lidinājās pār audekla.

Auto-izkārtojums

Par sastāvdaļām diagrammas izkārtojumu var mainīt automātiski.

Lai izkārtojums visi sastāvdaļas on diagramma

1. Claizīšana Layout diagrammapogu uz diagramma rīkjoslā.

2. Atlasītvai Radial Layout vai Grid Layout.

Piezīme

Radiālais izkārtojums būs izmantot to, ko sauc par "force vērsta" algoritmu, piemēram, kas saistīti komponenti ir izstrādāti kopā, bet nav saistītas sastāvdaļas ir spiesti intervālu. Grid izkārtojums izmantos fiksēts platums un augstums attāluma algoritmu. Tas, pirmkārt, ļauj lietotājam izvēlēties kopumā diagramma malu attiecību (piemēram, 16: 9, A4 (portrets), Letter (Landscape)), un tad atstarpe pie sāniem un starp kolonnām un rindām, kā parādīts zemāk.Ar Grid izkārtojums kādi savienojumi starp detaļām neietekmē izkārtojumu, jo tas vienkārši organizē komponentus alfabēta (pēc nosaukuma), no augšas pa kreisi uz leju pa labi audekla. Ar abiem algoritmiem brīvformas formas netiek pārvietotas.

Lai izkārtojums bērni sastāvdaļas vienā mātes on diagramma

1. Labo klikšķiaugsta līmeņa komponente kuru bērni vēlaties auto-izkārtojumu.

2. Atlasīt Layout Bērni.

Piezīme

Pēc noklusējuma tikai Radial izkārtojums algoritms tiek izmantots.

Mainot Element Estētika tāpat Krāsa, Pārredzamība, Shadows un Rotācija

Visas diagrammas elementiem ir estētika, ko var manipulēt, kā vēlamo. Attiecībā uz asociēto formas, šie aspekti var iestatīt vienu tipuun vairumā gadījumu arī per instancē. Attiecībā uz brīvās formas formu, šīs īpašības var iestatīt per instancēuz audekla.

Piezīme

Jebkura per piemēram aspektiem, kas tika noteikti par asociēto formas tiks "pārrakstīts", ja tas pats aspekts tiek mainīts atbilstošā veida.

Lai mainītu krāsu asociētā formas vai brīvas formas formu

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai brīvas formas formas uz audekla.

3. Atlasīt Mainīt Colour.

4. Izvēlieties Fiksētie Colourradio pogu (ja piemērojams).

5. Izvēlieties Basic Colour vai definētu pielāgotu Colour dialog un noklikšķiniet labi.

- Vai -

4. Izvēlieties Gradientsradio pogu (ja piemērojams).

5. Izvēlēties vai nu horizontāli, vertikāli, Forward Diagonal vai atpakaļ pa diagonāli uz gradienta virzienā Nolaižamo un klikšķi labi.

6. Izvēlieties Basic Colour vai definētu pielāgotu Colour dialogā par Sākumsun Galsun noklikšķiniet labi.

Piezīme

ABACUS būs krāsu priekšplānā formā, ja;
a) tas ir "vienkāršs" forma ar vienu pamata grafisko elementu (piemēram, aplis, taisnstūris, poligons uc), vai
b) tas ir "sarežģīts" forma ar vairākiem pamatā subshapes ka visi ir tādā pašā krāsā / gradients kā otru vai subshapes ir LockScale = true komplektu.
Ja iepriekš minētie nosacījumi nav izpildīti, tad fona forma ir krāsains.

Lai iestatītu krāsu asociētā formas saskaņā ar īpašuma

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga(NOT uz zīmējuma kanvas).

3. Atlasīt Mainīt Colour.

4. Izvēlieties Izmantojot īpašumuradio pogas.

5. Izvēlieties īpašumu, noklikšķinot uz "..." pogu pa labi no textbox.

6. Izvēlieties Diapazons radio pogas.

7. Pielāgot Minun Maxvērtībām kā vēlamo. Piezīme: jebkura vērtība mazāka par minimālo vērtību, tiks parādīts kā Min krāsu un jebkura vērtība pārsniedz maksimāli tiks parādīti kā Max krāsu. Arī tad, kad, izmantojot Būla, sarakstu vai Date / Time īpašības vērtības tiek konvertētas uz indeksu šādi; Boolean (False = 0, True = 1), saraksts (vesels skaitlis vale no 1 līdz n katram derīgu vērtību savā augošā secībā norādītā vienības jomā) un datums / laiks (dienu skaits kopš 1. janvāra 1900 - tostarp decimāldaļu par stundas, minūtes, sekundes porcijas - un ja datums ir pirms 1990 tas ir negatīvs skaitlis).

8. Izvēlieties Basic Colour vai definētu pielāgotu Colour dialogā par Minun Maxun noklikšķiniet labi.

Gals

Ja Zaļš (RGB - 128,255,0) ir izvēlēts par Min krāsu un Sarkans (RGB - 255,0,0) ir izvēlēts par Max krāsu par īpašumu, kura vērtība ir diapazonā 1līdz 4tad vērtība 1Tiks parādīts kā Zaļš, Kura vērtība ir 2kā Dzeltens, 3kā Oranžsun 4kā Sarkans.

Alternatīvi, par nekustamā īpašuma klāstu 1līdz 3vērtība ir 1būs kā Zaļš, Kura vērtība ir 2kā Dzintarsun 3kā Sarkansaka "luksofori" vai RAG statuss.

Par nekustamā īpašuma robežās no 1 līdz 5 Ja Zils (RGB - 0,0,255) ir izvēlēts par Min krāsu un Sarkans (RGB - 255,0,0) ir izvēlēta kā Max krāsu vērtība no 1 būs tikpat Zils, Kura vērtība ir 2, kā Aqua, Vērtība gada 3. kā Zaļš, Vērtība gada 4. kā Dzeltens un kura vērtība ir 5, kā Sarkans.

Par nekustamā īpašuma robežās no 1 līdz 6 Ja Violets (RGB - 255,0,255) ir izvēlēts par Min krāsu un Sarkans (RGB - 255,0,0) ir izvēlēta kā Max krāsu vērtība no 1 būs tikpat Violets, Kura vērtība ir 2, kā Zils, Vērtība gada 3. kā Aqua, Vērtība gada 4. kā Zaļš, Kura vērtība ir 5, kā Dzeltens un vērtību robežās no 6 kā Sarkans.

Un visbeidzot, par īpašuma robežās no 1 līdz 7 vērtība no 1 būs tikpat Violets, Kura vērtība ir 2, kā Tumši zils, Vērtība gada 3. kā Gaiši zils, Vērtība gada 4. kā Blue Green, Kura vērtība ir 5, kā Zaļš, Vērtību robežās no 6 kā Dzintars un vērtība gada 7. kā Sarkans

Piezīme

Skatīt piezīmi iepriekš par jaunām zināšanām pret fona krāsojuma.

- Vai -

7. Izvēlieties Īpašs Valueradio pogas.

8. Noklikšķiniet uz Edit Krāsaspoga.

9. Izvēlieties katru vērtību kārtas un noklikšķiniet Uzstādīt krāsaiestatīt noteiktu krāsu katrai vērtībai.

Piezīme

Par vērtībām elementiem klātesošo diagrammā klāsts būs iepriekš apdzīvots.

10. Lai pievienotu papildu vērtību krāsas tām iepriekš apdzīvotos (piemēram, pēc nekustamā īpašuma klāsts ir pārkonfigurēt) klikšķi Pievienot vērtību.

Lai mainītu asociētā formas krāsu caurspīdīgumu vai brīvas formas formu

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai brīvas formas formas uz audekla.

3. Atlasīt Mainīt Colour.

4. Jo Transparency panelī uzstādītu top slīdni uz vēlamo pārredzamību par bāzes krāsu.

5. Ja tiek izmantota gradienta vai lietojot Property iespējas, jo Atklātības panelī uzstādītu apakšējo slīdni uz vēlamo pārredzamību par otro krāsu.

6. Uzklikšķiniet labi.

Parādīt ēnaspar visas šīs saistīta formas diagrammā

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļastab par trafaretu loga.

3. Atlasīt Pievienot Shadows.

Līdz parādīt ēnu uz sastāvdaļa forma vai brīvas formas formas

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Pa labiUzklikšķinietpar detaļas vai brīvas formas formas uz audekla.

3. Atlasīt Pievienot Shadows.

Lai pagrieztu komponentu formas un brīvas formas formas diagrammās

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Izvēlieties detaļas formu vai brīvas formas formu uz audekla, kuru vēlaties pagriezt.

3. Labo klikšķipar formas un izvēlieties Pagrieztun pēc tam izvēlieties attiecīgo leņķi vēlaties pagriezt formu pēc.

Mainot Elementu Anotācijas un Brīvo formu teksta etiķetes

Visiem diagramma elementiem ir anotācijas kas var manipulēt, kā vēlamo. Attiecībā uz asociēto formas, šie aspekti var iestatīt vienu tipuun vairumā gadījumu arī per instancē. Gadījumā, brīvas formas formasun savienotāji, Tadteksta etiķetes var iestatīt per instancēuz audekla.Astoņu (8) dažādu veidu anotācijām var tikt parādīts diagrammas elementiem (ti nosaukums, tips, Īpašuma vērtību, mantiska Marker, Pievienotie komponentes, bērni (tikai komponentiem), standarti un Laikspiedoli (Izveidots grozītais uc)), kas divdesmit pieci (25) dažādās pozīcijās (piemēram, Centre - Ārpus Top, Inside kreisi - centrs, Āra Right - Outside apakšā).

Piezīme

Jebkura per piemēram aspektiem, kas tika noteikti par asociēto formas tiks "pārrakstīts", ja tas pats aspekts tiek mainīts atbilstošā veida.Turklāt, ja 2 vai vairāk anotācijas ieņemt tādu pašu nostāju tikai vienu fontu, fonta stilu, fontu krāsu un izmēru var tikt izmantots un ir atdalītājs (piemēram, komats, atstarpe, jauna līnija) jāizvēlas.

Parādīt nosaukums vai veids par asociētā sastāvdaļas vai savienojumu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai savienotāju uz audekla.

3. Atlasīt Anotācijas.

Piezīme

Lai individuāli saistīts formas vai savienotāju uz audekla, jums būs nepieciešams, lai izvēlētos Ignorēt trafaretu anotācijasrūtiņu pirmo reizi.

4. Izvēlieties Jauna anotācija rīkjoslā un izvēlieties Nosaukums vai Type.

5. Dialoglodziņā, kas parādās, izvēlieties displeja iespējām, kuras vēlamo tostarp kronšteini un fontu, fonta stilu, fonta krāsu un izmēru. Arī izvēlieties izkārtojuma opcijas, kas ir vēlamas, tostarp horizontālā un vertikālā stāvokļa (ti anotācija amats) un leņķis (ti, rotācijas). Atlasīt labi.

Lai parādītu īpašumu vērtība par asociētā sastāvdaļas vai savienojumu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai savienotāju uz audekla.

3. Atlasīt Anotācijas.

Piezīme

Lai individuāli saistīts formas vai savienotāju uz audekla, jums būs nepieciešams, lai izvēlētos Ignorēt trafaretu anotācijasrūtiņu pirmo reizi.

4. Izvēlieties Jauna anotācija rīkjoslā un izvēlieties Īpašuma vērtība.

5. Dialoglodziņā, kas parādās, izvēlieties īpašumu, noklikšķinot īpašums: "..." pogu un izvēloties īpašumu Select īpašumu dialogun izvēlieties labi. Izvēlieties displeja iespējām, kuras vēlamo tostarp kronšteini un fontu, fonta stilu, fonta krāsu un izmēru. Arī izvēlieties izkārtojuma opcijas, kas ir vēlamas, tostarp horizontālā un vertikālā stāvokļa (ti anotācija amats) un leņķis (ti, rotācijas). Atlasīt labi.

Lai parādītu īpašumu marķētājs par asociētā sastāvdaļas vai savienojumu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai savienotāju uz audekla.

3. Atlasīt Anotācijas.

Piezīme

Lai individuāli saistīts formas vai savienotāju uz audekla, jums būs nepieciešams, lai izvēlētos Ignorēt trafaretu anotācijasrūtiņu pirmo reizi.

4. Izvēlieties Jauna anotācija rīkjoslā un izvēlieties Īpašuma Marker.

5. Dialoglodziņā, kas parādās, izvēlieties īpašumu, noklikšķinot īpašums: "..." pogu un izvēloties īpašumu Select īpašumu dialogun izvēlieties labi. Uzstādīt rādiusu marķieri pikseļiem un krāsojamā metodi uz nu Colour By loks Colour pa īpašuma un noteikt krāsas uzdevumus. Arī izvēlieties izkārtojuma opcijas, kas ir vēlamas, tostarp horizontālā un vertikālā stāvokļa (ti anotācija amats) un leņķis (ti, rotācijas). Atlasīt labi.

Parādīt Pievienotie sastāvdaļas par asociētā sastāvdaļas vai savienojumu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai savienotāju uz audekla.

3. Atlasīt Anotācijas.

Piezīme

Lai individuāli saistīts formas vai savienotāju uz audekla, jums būs nepieciešams, lai izvēlētos Ignorēt trafaretu anotācijasrūtiņu pirmo reizi.

4. Izvēlieties Jauna anotācija rīkjoslā un izvēlieties Pievienotie komponenti.

5. Dialoglodziņā, kas parādās, asociētiem sastāvdaļas izvēlēties pievienoto detaļas tipa, noklikšķinot uz Attached "..." pogu un izvēloties detaļas tipa komplektā detaļas tipa dialogun izvēlieties labi. Izvēlieties pievienoto savienojuma veidu, noklikšķinot uz pieslēgts caur: "..." pogu un izvēloties savienojuma veidu, kas Set Connection Type dialogun izvēlieties labi.Saistītiem savienojumiem izvēlēties savienojuma beigām, izvēloties avotu vai Izlietne no Connection End: pull-down menu. Lai abas saistītas detaļas un savienojumi izvēlēties displeja opcijas, kas ir vēlamas arī iekavās un fontu, fonta stilu, fonta krāsu un izmēru. Arī izvēlieties izkārtojuma opcijas, kas ir vēlamas, tostarp horizontālā un vertikālā stāvokļa (ti anotācija amats) un leņķis (ti, rotācijas). Atlasīt labi.

Parādīt bērni par asociētā sastāvdaļa

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļastab par trafaretu loga vai asociētā forma uz audekla.

3. Atlasīt Anotācijas.

Piezīme

Lai individuāli saistītā formā uz audekla, jums būs nepieciešams, lai izvēlētos Ignorēt trafaretu anotācijasrūtiņu pirmo reizi.

4. Izvēlieties Jauna anotācija rīkjoslā un izvēlieties Bērni.

5. Dialoglodziņā, kas parādās, izvēlieties displeja iespējām, kuras vēlamo tostarp kronšteini un fontu, fonta stilu, fonta krāsu un izmēru. Arī izvēlieties izkārtojuma opcijas, kas ir vēlamas, tostarp horizontālā un vertikālā stāvokļa (ti anotācija amats) un leņķis (ti, rotācijas). Atlasīt labi.

Parādīt standarti par asociētā sastāvdaļas vai savienojumu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai savienotāju uz audekla.

3. Atlasīt Anotācijas.

Piezīme

Lai individuāli saistīts formas vai savienotāju uz audekla, jums būs nepieciešams, lai izvēlētos Ignorēt trafaretu anotācijasrūtiņu pirmo reizi.

4. Izvēlieties Jauna anotācija rīkjoslā un izvēlieties Standarti.

5. Dialoglodziņā, kas parādās, izvēlieties displeja iespējām, kuras vēlamo tostarp kronšteini un fontu, fonta stilu, fonta krāsu un izmēru. Arī izvēlieties izkārtojuma opcijas, kas ir vēlamas, tostarp horizontālā un vertikālā stāvokļa (ti anotācija amats) un leņķis (ti, rotācijas). Atlasīt labi.

Parādīt laikspiedolus par asociētā sastāvdaļas vai savienojumu

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Labo klikšķiuz asociētā formas vai savienotāju Sastāvdaļasvai Savienojumitab par trafaretu loga vai ar to saistītās formas vai savienotāju uz audekla.

3. Atlasīt Anotācijas.

Piezīme

Lai individuāli saistīts formas vai savienotāju uz audekla, jums būs nepieciešams, lai izvēlētos Ignorēt trafaretu anotācijasrūtiņu pirmo reizi.

4. Izvēlieties Jauna anotācija rīkjoslā un izvēlieties Izveidots, Izveidoja, Created Marker, Modificēts grozītais vai pārveidoti Marker.

5. Dialoglodziņā, kas parādās, ja ne marķieri, izvēlieties displeja iespējām, kuras vēlamo tostarp kronšteini un fontu, fonta stilu, fonta krāsu un izmēru. Ja marķieri, noteikt rādiusu marķieri pikseļiem un krāsojamā metodi uz nu Colour By loks Colour pa īpašuma un noteikt krāsas uzdevumus. Arī izvēlieties izkārtojuma opcijas, kas ir vēlamas, tostarp horizontālā un vertikālā stāvokļa (ti anotācija amats) un leņķis (ti, rotācijas). Atlasīt labi.

Lai mainītu fonta stilu brīvas formas formasvai savienotājs

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Labo klikšķiuz brīvas formas formas vai savienotājs uz audekla. Piezīme: Ja savienotājs teksta etiķetes nav parādīt, tad, lai parādītu savienotvai teksta etiķetes: Labo klikšķiConnectvaiun izvēlieties Anotācija | Rādīt Anotācija.

3. Atlasīt Mainīt fonta.

4. Izvēlieties fontu, fonta stilu un izmēru dialoglodziņā un izvēlieties labi.

Lai mainītu fontu krāsa no brīvas formas formasvai savienotājs

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Labo klikšķiuz brīvas formas formas vai savienotājs uz audekla. Piezīme: Ja savienotājs teksta etiķetes nav parādīt, tad, lai parādītu savienotvai teksta etiķetes: Labo klikšķiConnectvaiun izvēlieties Anotācija | Rādīt Anotācija.

3. Atlasīt Maiņa Fonts Colour.

4. Izvēlieties fontuKrāsa (un formas Link Krāsu), noklikšķinot uz "..." pogu un izvēloties krāsu dialog un izvēlieties labi.

5. Izvēlieties pārredzamību teksta etiķetes, koriģējot slīdni ar 0 ir pilnīgi pārredzama un 255 ir pilnīgi necaurspīdīgs.

Lai pagrieztu teksta etiķetes brīvas formas formasvai savienotājs

1. Pārliecinieties, ka jums ir jaunas vai esošas diagramma open .

2. Labo klikšķiuz brīvas formas formas vai savienotājs uz audekla. Piezīme: Ja savienotājs teksta etiķetes nav parādīt, tad, lai parādītu savienotvai teksta etiķetes: Labo klikšķiConnectvaiun izvēlieties Anotācija | Rādīt Anotācija.

3. Atlasīt Pagrieztun pēc tam izvēlieties attiecīgo leņķi jūs vēlaties, lai pagrieztu teksta etiķetes līdz.

Skatīt arī

Zīmējuma Tool | Aizpildi savu arhitektūru | Analizējot Jūsu arhitektūra


Izmantojot saites diagrammās

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Izmantojot saites diagrammās

Nosūtīt komentārus par šo tēmu.

Formas (brīvā formā un sastāvdaļas) un savienotāji (brīvā veidā vai savienojumi) ietvaros diagrammām var būt saistīts ar jūsu esošo arhitektūras pārstāvniecībām ABACUS, kā arī ārējos failus / mapes un URL. Šīs saites tad var pārvaldīt (izveidots, modificēts un svītrots), izmantojot ABACUS rīku komplekts. Šo funkciju var izmantot, lai uzlabotu navigāciju un vispārēju izpratni par savu arhitektūru shematiski.

Pievienot saites uz jūsu diagramma

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Izvēlieties atbilstošu formu vai savienotājs no tavām.

3. Labo klikšķino formasvai savienotājs.

4. Atlasīt Atvērt Saitesun SaitesParādās logs.

5. Klikšķiniet uz Pievienotikona un New LinkParādās logs.

6. Izvēlieties attiecīgā Katalogs | Matrix | Diagramma| 3D View| Diagrammaradio pogas, tad izvēlieties attiecīgo katalogs, matrica, diagramma, 3Dvai diagramma skats pašreizējā arhitektūra no Saite uznolaižamo izvēlni.

- Vai -

6. Izvēlieties Mājas laparadio pogas, tad, ievadiet attiecīgo URL (piemēram, http: //www.avolutionprogrammatūra.com /)jomā saiti uz mājas lapu. Derīgas URL jāsāk ar vienu no 5stīgas; http: //, https: //, ftp: //,failu:vai \\. Jebkuras vietas jānorāda ar "% 20 '.

- Vai -

6. Izvēlieties Absolūtais File | Relatīvais Fileradio pogaS,tad noklikšķiniet uz "..."Pogu, lai pārlūkotu ārēju failu, lai saite uz jūsu diagrammu.

7. Uzklikšķiniet labiun jaunā saite tiks parādīts Saites logā. Piezīme: Saites logs var tikt mainīti, lai redzētu pilno nosaukumu, ja nepieciešams.

8. Atkārtojiet 5-7radīt vairāk saites.

9. Sekot izveidoto saiti, izvēlieties attiecīgo saiti parādīts Saiteslogu un klikšķi Atvērt Link.

Piezīme

Kad vairākas anotācijas tiek parādīts priekšlikums forma vai savienotājs saite ir parādīts pirmajā anotācijas sarakstā anotāciju rediģēšanas anotāciju dialog.

Sekot saites no tavām

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Izvēlieties atbilstošu formu vai savienotājs no tavām.

3. Uzklikšķinietuz attiecīgās hipersaites (zils pasvītrots komponents nosaukumu) formā vai savienotājs diagrammā atvērt un apskatīt pirmo saiti no formasvai savienotājs.Piezīme: kursors vajadzētu mainīt uz "rokas", ja saite ir gatava uzklikšķināt.

- Vai -

3. Izvēlieties atbilstošu formu vai savienotājs no tavām.

4. Labo klikšķino formasvai savienotājs.

5. Atlasīt Atvērt Saitesun SaitesParādās logs.

6. Izvēlieties attiecīgo saiti, ka jūs vēlētos, lai apskatītu.

7. Klikšķiniet uz Atvērt Linkpogu, lai atvērtu un apskatītu attiecīgo saiti.

Lai dzēstu saites jūsu diagrammā

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Izvēlieties atbilstošu formuvai savienotājsno tavām.

3. Labo klikšķino formasvai savienotājs.

4. Atlasīt Atvērt Saitesun SaitesParādās logs.

5. Izvēlieties attiecīgo saiti, kas jāsvītro.

6. Klikšķiniet uz Izdzēstpoga. un saite ir noņemts no Saites logu.

Organizēšana saites jūsu diagrammā

Jūs varat izvēlēties, kuras saistītas diagramma, ārējo failu vai tīmekļa URL tiek parādīts, kad forma etiķete ir Ctrl + uzklikšķināt diagrammā.

1. Pārliecinieties, ka jums ir esošo diagramma open .

2. Izvēlieties atbilstošu formu vai savienotājs no tavām.

3. Labo klikšķino formasvai savienotājs.

4. Atlasīt Atvērt Saitesun SaitesParādās logs.

5. Lai mainītu secību no saitēm uzklikšķiniet uz Pārvietot uz augšu | Pārvietot uz lejupogas labajā pusē Saiteslogu.

6. Pirmais posms, kas parādās kreisajā pusē Saiteslogs ir saite, kas parāda, kad jūs Ctrl + Clickhipersaiti forma vai savienotājs nosaukums.

Skatīt arī

Aizpildi savu arhitektūru | Aizpildi savu arhitektūru manuāli | Analizējot Jūsu arhitektūra


Diagramma Viedokļi

Navigācija: Populating savu arhitektūru> Izmantojot Zīmējumi>

Diagramma Viedokļi

Nosūtīt komentārus par šo tēmu.

The viedokļifunkcija nodrošina, ka detaļas un savienojumi, kas tiek pievienoti diagrammas ir jābūt tipa asociācija iepriekš noteikts, pirms tās var pievienot diagrammu. Šī funkcija ļauj par veidu diagrammām, ko var izņemt, ierobežojot formas un savienotāji, kas ir saistīti ar detaļu un ierobežojumiem Savienojumiesošais jūsu arhitektūru.

Atļaušana vai aizliegšana izpildē diagramma viedokļi

Spēja izpildīt diagramma viedokļi tiek automātiski aktivizēta pēc noklusējuma. Atslēgt / iespējotu šo funkciju, noklikšķiniet uz Tools | Iespējas ...| Diagrammatab, un noņemiet atzīmi / izvēlieties Ieviest diagramma Viedokļirūtiņu atbilstoši.

Piezīme

Ja jūs neredzat "Ieviest diagramma Viedokļi"Variants uz cilnes diagramma, tad jums nav Designer add-on un iespēja ir ieslēgta pēc noklusējuma.

Radīt izpildāmu diagrammu viedoklis

1. Pārliecinieties, vai ir ABACUS fails atvērt ar pētnieksskats redzams.

2. Jo pētnieks domām labo klikšķi uz Skatspunktssun noklikšķiniet uz Izveidot Diagramma Viedoklis

3. Diagramma Viedoklislogs tiks parādīts.

4. Piešķiriet attiecīgu nosaukumu uz diagramma viedoklisun atzīmē, ka viedoklis tiek saglabāti Viedokļisadaļā pētnieks.

5. Diagramma Viedoklislogs tiks parādīts.

6. Tagad noklikšķiniet un velciet attiecīgos komponentu tipus un savienojuma veidu jūsu arhitektūras izlīdziniet viedoklis formas tu gribi. Komponentu veidiir vilkt uzforma iekš formastab, kamēr savienojumu tipiir vilkt uz viens no 5 līnijas stila formas iekš savienotājitab.

7. Lai saglabātu diagramma viedoklisesat izveidojis noklikšķināt uz [image] augšējā labajā stūrī Diagramma Viedoklislogu.

Piezīme

diagramma viedoklisvar edited by tiesības noklikšķinot uz viedoklis un izvēloties Atvērtsvai dubultklikšķi viedoklis.

Synchonising atjauninātu viedokli ar diagrammām

1. Pārliecinieties, vai ir ABACUS fails atvērts.

2. Vai nu ar peles labo pogu viedokli šajā Pētnieks logu saskaņā Meta-modelis | Viedokļiun izvēlieties Sync diagramma kartējumi ...

- Vai -

3. Aizvērt atvērtā un atjaunināta viedoklis logu un izvēlieties Jā iekš Sinhronizēšana ar Viewpointdialog kas tiek parādīts.

4. Viedoklis sinhronizācijadialogs tiks parādīts, kā parādīts zemāk.

Rūtiņas

· Pievienot nenorādītu kartēšanu- Jebkura jauna forma (uz detaļas tipa) vai savienotājs (līdz savienojuma veida) asociācijām, kas ir pievienotas viedoklimtiks pievienota ar atbilstošais diagrammaS (t.i., totrafaretss)ka ir saistīti ar viedokļa.

· Atjaunināt EsošāsSamērošanai- Visi jaunākie aspekti esošās formas (līdz detaļas tipa) vai savienotājs (līdz savienojuma veida) asociācijām viedoklis(piemēram, krāsu, fontu stilus) tiks atjaunināta atbilstošais diagrammaS (t.i., totrafaretss)ka ir saistīti ar viedokļa.

· Noņemt ExtraSamērošanai- Jebkura papildu forma (uz detaļas tipa) vai savienotājs (līdz savienojuma veida) asociācijām, kas ir pievienotas uz diagrammas (t.i. to Trafareti), bet kas nav iekļauti viedoklistiks noņemts no atbilstošais diagrammaS (t.i., totrafaretss)ka ir saistīti ar viedokļa.

· Pārrakstīt Lokālie uzstādījumi pievienots vai atjaunināt samērošanai (atšķiras tikai)- Visi jaunākie aspekti esošās formas (līdz detaļas tipa) vai savienotājs (līdz savienojuma veida) asociācijām viedoklis(piemēram, krāsu, fontu stilus) tiks piemērots attiecīgajiem elementiem diagrammās, kas ir saistīti ar viedokļa.Ir veiktas tik visi esošie vietējie iestatījumi Diagrammā, kas nebija atjaunināti viedokļa paliks nemainīga tikai atjaunotie "atšķirības" veikti viedokļa.

· [image] Anotācijas – Kā iepriekš, bet īpaši anotācijās.

Skatīt arī

Zīmējuma Tool | Aizpildi savu arhitektūru | Analizējot Jūsu arhitektūra


Aizpildi izmantojot Katalogi

Navigācija: Populating savu arhitektūru>

Aizpildi izmantojot Katalogi

Nosūtīt komentārus par šo tēmu.

A katalogs ļauj jums apskatīt un rediģēt sastāvdaļas vai savienojumi un to īpašības vienkāršā tabulas veidā.

Līdz izveidot jaunu katalogs skatīt in ABACUS

Piezīme

Lai gan visas Arhitekts lietotāji var izveidot jaunas Katalogi, lai saglabātu izmaiņas esošam Katalogs ir iestatījumiem lietotāja licence vajadzīga Designer pievienot-on spējas. Tas nepieciešams, lai "aizsargātu" konfigurāciju esošo katalogos, kas var tikt attiecināta uz daudziem lietotājiem. Tomēr Arhitekts izmanto bez Designer pievienot-on joprojām var izvēlēties "Save As" jebkādu jaunu iestatījumus uz jaunu katalogu. Un, protams, visi lietotāju licences var izvēlēties "atbrīvoties" jebkādām izmaiņām esošajā katalogā. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums nepieciešama Designer add-on spējas. Un atcerieties, tas ir tikai iestatījumi katalogā, visi labojumi veikti datiem katalogā uzreiz tiek piemēroti repozitorijā neatkarīgi.

1. Izvēlieties Ielikt | Katalogs.

2. Iekš pull-down atlasiet Arhitektūra, kas satur sastāvdaļas vaisavienojumi vēlaties apskatīt.

3. Iekš pull-down izvēlētos komponentu vai savienojuma veids ka jūs vēlaties, lai būtu gadījumi uzskaitīti kā "rindas' katalogā.

4. katalogs tiks apdzīvots arrinda par katru gadījumu izvēlētā detaļas vai savienojuma tipu.

Piezīme

Pēc noklusējuma kreisās visvairāk Hierarhija Pathkolonna (ti hierarhijā mātes komponentu vai savienojumu iepriekš izvēlētajiem instancēs) un 2. Nosaukums kolonna (ti saraksta izvēlēto komponentu vai savienojuma gadījumos) tiek iesaldēta kreisi no kataloga. Lai mainītu kolonnu iesaldēšana velciet kolonnu atdalītāju pa labi no nosaukums kolonnas. Tu vari re-laikolonnas vienkārši velkot un nometot to kolonnu virsrakstus. Šūnas kolonnas ar zilu pasvītrojumu ir hipersaites citiem elementiem projektā un hipersaites var sekot, turot Ctrl un noklikšķinot uz saites. Kolonnas var būt paslēpts ar peles labo pogu noklikšķinot uz kolonnas virsraksta un izvēloties sleja | Paslēpt kolonnu. Slēptās kolonnas var unhidden noklikšķinot Konfigurēt Columns rīkjoslas pogu un izmantojot konfigurēšana Columns dialoglodziņu, kā norādīts zemāk, vai izvēloties lejupvērstās bultiņas daļu Konfigurēt Columns rīkjoslas pogas un individuāli izvēloties slēpto kolonnu (-as) vai nu no General, Rekvizīti vai Aprīkojums kolekcijas. Rindas var būt sagrupēti ar to kolonnu vērtībām, velkot kolonnas virsraksta uz zilā grupēšanas joslas augšpusē kataloga. Jebkurā laikā jūs varat dubultklikšķi uz katalogs rinda selektorsun pāriet uzatbilstošo komponentsvai savienojumsšajā Explorer logā.Īpašums šūnu vērtības treknrakstā ja tie atšķiras ar saistību nepildīšanu, un italicized ja tie ir tikai lasāms. Timestamp, Īpašuma un Pievienotie komponentu kolonnas var būt krāsots saskaņā ar šūnu vērtībām vai ievietotajā komponenta īpašuma vērtības, ar peles labo pogu noklikšķinot uz kolonnas virsraksta un izvēloties sleja | Mainīt krāsu ... un tad Colour ar Laikspiedols vai Colour By īpašuma variantu, tomēr tikai Saraksts, Integer, Decimal, Boolean vai Date / Time datu tipu īpašības būs krāsu. Īpašuma vērtības Attached komponentu kolonnām var būt parādīts ar peles labo pogu noklikšķinot uz kolonnas virsraksta un izvēloties sleja | Parādīt Property ... un tad Show īpašumu iespēju. Un visbeidzot, ja ir Nepieciešamie ierobežojumi noteikt nekustamā īpašuma kolonnā tie var parādīt ar string (ar krāsvielu, atbilstoši to izpildes līmeni), ar peles labo pogu noklikšķinot uz kolonnas virsraksta un izvēloties sleja | Parādīt .

Katalogs

Līdz pievienot / rādīt kolonnas a Katalogs Skatīt arī ABACUS

1. Pārliecinieties, ka jums ir Katalogs view atvērts.

2. Slēptās kolonnas var individuāli unhidden, noklikšķinot uz saites bultiņa pa labi no kolonnas Konfigurēt rīkjoslas pogasun izvēloties slēptās kolonnas no nu General, Properties vai Pielikumi kolekcijas.

Piezīme

Ķeksīti zīmi tiks parādīts blakus šobrīd norādītajiem kolonnas kataloga.Turklāt, tikai daži pielikumi būs pieejami saskaņā ar pielikumiem sadaļa saskaņā ar ierobežojumi ka tiek noteikti jūsu projektā. Jo īpaši attiecībā uz pielikumu būs pieejami tiks parādīta komponentu katalogā detaļas tipa katalogam jānorāda kā nu avotu vai izlietne (nevis "Jebkurš") ar "pieslēgumi jāpievieno" ierobežojums savienojumu veids, un tur jābūt arī vismaz viens detaļas tipa norādīts vai nu avotu vai izlietne (nav "Jebkurš"), no otras "galā" ar tādu pašu savienojuma veidu.

- Vai -

2. Vairāki kolonnas var unhidden (vai pasūtīt vai fiksēta), noklikšķinot uz Konfigurēšana Slejas rīkjoslas poguun izmantojot konfigurēšana Columns Dialog parādīts zemāk.

Piezīme

Pašreiz redzamo kolonnas tiek parādīti paneļa labajā pusē ar pieejamajiem kolonnām parādīti paneļa kreisajā pusē. Pieejamie kolonnas var filtrēt saskaņā ar Izvēlieties Pieejamie slejaspull-down, un tās var pievienot, izvēloties tos paneļa kreisajā pusē un noklikšķinot uz Pievienot poga inbetween diviem paneļiem.

Konfigurēšana dialog Slejas

Līdz noņemt / paslēpt kolonnas no Katalogs Skatīt arī ABACUS

1. Pārliecinieties, ka jums ir Katalogs view atvērts.

2. Ar peles labo pogu noklikšķiniet uz kolonnas virsraksta, kolonnas, kuru vēlaties noņemt / slēpt un izvēlieties Sleja | Slēpt sleja.

- Vai -

2. Vairāki kolonnas var būt paslēptas (vai pasūtīt vai fiksēta), noklikšķinot uz Konfigurēšana Slejas rīkjoslas poguun izmantojot konfigurēšana Columns Dialog norādīts iepriekš.

Piezīme

Pašreiz redzamo kolonnas tiek parādīti paneļa labajā pusē ar pieejamajiem kolonnām parādīti paneļa kreisajā pusē. Pašreiz redzamo kolonnas var būt paslēptas, izvēloties kolonnu panelī pa labi un noklikšķinot uz Noņemt poga inbetween diviem paneļiem.

Aizpildīt, izmantojot Katalogs Skatīt arī ABACUS

1. Līdz pievienot sastāvdaļa vai saistībano izvēlētā tipa līdz katalogs (un projekta) noklikšķiniet uz Pievienot jaunu Daļas / Add New Connection rīkjoslas pogu. Rinda būtu parādās un sastāvdaļa vai savienojums tiks izveidots augšējā līmenī Sastāvdaļas vai Savienojumi vākšana par izvēlēto arhitektūru.

Piezīme

Jauni detaļas un savienojumi, tiek atjaunots pēc noklusējuma augšējā no sastāvdaļām vai savienojumiem kolekciju izvēlētā Arhitektūras līmenī. Lai mainītu vecāks jauno sastāvdaļu vai savienojumu ar peles labo pogu hierarhijā Path šūnu jaunās detaļas vai savienojumus rindā un izvēlieties Mainīt Parent ...un izvēlēties vēlamo vecākiem (ņemot zināšanai ierobežojums izceļot ).

Piezīme

Jauni rindas / elementi, pievieno tieši katalogu starpniecību "pievienot jaunu 'pogu, ielīmēt katalogā, vai izveidota, izmantojot ievest katalogā no MS Excel ir atbrīvoti no filtrējot līdz katalogā ir slēgta. Tas nepieciešams, lai varētu visu vajadzīgo rediģēšanu kolonnu vērtību, kas varētu neatbilst pašreizējos filtrēšanas kritērijiem kataloga. Šīs jaunās elementu rindas ir apzīmēti ar '+' simbola rinda selektora šūnas sākumā rindas, kas ir krāsaina zaļš ja elements šobrīd atbilst saglabātos filtrēšanas kritērijus katalogs (ti, paliks uz katalogu ja atkārtoti atvērts), un sarkans ja tā nav.

2. Līdz izņemtu sastāvdaļa vai saistībano izvēlētā tipa no katalogs (un projekta) izvēlieties rindu, un vai nu nospiediet Del taustiņu vai peles labo pogu noklikšķiniet uz rindas selektoru un izvēlieties Dzēst no Architecture. rinda vajadzētu izzust no kataloga un to tiks izdzēsti no projekta.

Līdz filtrs izmantojot Katalogs Skatīt arī ABACUS

1. Pārliecinieties, ka jums ir Katalogs view atvērts.

2. Ja filtrs rinda nerāda augšpusē kataloga, tad uzklikšķiniet uz Rādīt Filter Header Rowrīkjoslas pogu.

3. Ailē jūs vēlētos pievienot filtru, veiciet dubultklikšķi uz filtra rindas šūnu, kur tas parāda "(All)".

4. Par Timestamp, hierarhija Path, Namevai Aprakstsvispārējie kolonnas vai Teksts, Integer, Decimal, Booleanvai Datums Laiksīpašuma kolonnas noklikšķiniet uz ... pogu, kas parādās pa labi no filtra rindas šūnu un ievadiet šūnu vērtības, kas būtu jāiekļauj katalogā.

Piezīme

Saskaņošana tiek veikta tā, it kā '*' aizstājējzīmes automātiski tiek piemēroti pirms un pēc jebkurām stīgu vērtībām, lai ieraksts par "kaķis" (bez pēdiņām) ietver rindās ar 'bobukaķis','kaķissieviete "vai" pieteikaķision "uc Vairāku /" vai "var ierakstīt vērtības, uz jaunām līnijām, izmantojot Ctrl + Enter. Par skaitlim un decimālgrādos īpašuma kolonnu "un" loģika var iekļaut, izmantojot "&"(Bez pēdiņām) un lielāks / mazāks nekā etc loģika var iekļaut izmantojot"> =','>','<'Un'<="(Bez pēdiņām), piemēram, '> = 50000 & <90000 ". Non-blank vērtē rindas var iekļaut, ievadot "(Non-Blanks)"(Bez pēdiņām) un Blank vērtē rindas var iekļaut, ievadot"(Blanks)"(Bez pēdiņām).Un visbeidzot, visi filtri ir pēc noklusējuma gadījumā nejutīgu tik "kaķis" (bez pēdiņām), būtu jāietver rindas ar "kaķis", "kaķis" vai "kaķis" uc lieta jutīga saskaņošana, ievadiet "(Lieta)"(Bez pēdiņām) pirms string piem "(Lieta) Kaķi" (bez pēdiņām) ietvertu tikai rindās ar "kaķis" tiem.

5. Par Pielikumikolonnas, Standarti kolonnas vai Saraksts īpašuma kolonnas noklikšķiniet uz lejupvērstās bultiņas, kas parādās pa labi no filtra rindas šūnu un atlasiet šūnu vērtības no attiecīgo pogu, kas jāiekļauj katalogā.

Piezīme

Ar "(Atlasīt visu)" rūtiņu ļaus visas pārējās rūtiņas, faktiski ieskaitot visus pieejamos rindām. Ar "(Non-Blanks)" rūtiņu ietver jebkuru valsti, tukšs vērtē rindas. Ar "(Blanks)" rūtiņu ietvers nevienu tukšu vērtē rindas. Un visbeidzot, noņemot atzīmi nekādas īpašas vērtē rūtiņas automātiski atceliet "(Atlasīt visu)" un "(Non-sagataves)" rūtiņas konsekvences.

6. Uzklikšķiniet labi pielietot filtru.

Līdz atspējot / iespējot filtrēšanu a Katalogs Skatīt arī ABACUS

1. Pārliecinieties, ka jums ir Katalogs view atvērts ar filtrs lietišķā.

2. Uzklikšķiniet rūtiņu pa kreisi no filtra rindā.

Līdz izņemt filtru no a Katalogs Skatīt arī ABACUS

1. Pārliecinieties, ka jums ir Katalogs view atvērts ar filtrs lietišķā.

2. Lai noņemtu individuālu kolonnas filtru labo pogu noklikšķiniet uz kolonnas galvenes un izvēlieties Sleja | Skaidrs filtrēšana.

3. Lai noņemtu visus filtrus noklikšķiniet uz Iespējas rīkjoslas pogu un izvēlieties Notīrīt Filter Settings.

Saglabāt / saglabāt kā aKatalogs view

Piezīme

Lai gan visas Arhitekts lietotāji var izveidot jaunas Katalogi, lai saglabātu izmaiņas esošam Katalogs ir iestatījumiem lietotāja licence vajadzīga Designer pievienot-on spējas. Tas nepieciešams, lai "aizsargātu" konfigurāciju esošo katalogos, kas var tikt attiecināta uz daudziem lietotājiem. Tomēr Arhitekts izmanto bez Designer pievienot-on joprojām var izvēlēties "Save As" jebkādu jaunu iestatījumus uz jaunu katalogu. Un, protams, visi lietotāju licences var izvēlēties "atbrīvoties" jebkādām izmaiņām esošajā katalogā. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums nepieciešama Designer add-on spējas.Un atcerieties, tas ir tikai iestatījumi katalogā, visi labojumi veikti datiem katalogā uzreiz tiek piemēroti repozitorijā neatkarīgi.

1. Pārliecinieties, ka jums ir jauna vai esošo Katalogs skats atvērtsun esat veicis nepieciešamās izmaiņas.

2. Iekš Katalogs viewrīkjoslā noklikšķiniet uz Saglabātpogu, lai saglabātu Katalogs view un jebkādas formatēšanas izmaiņas.

Piezīme

Ja jums nav Saglabāt pogu Katalogs skata rīkjoslā, tad jums nav Designer add-on, un jums ir tikai spēj Saglabāt kākādi uzstādījumi mainās uz jaunu katalogu, kad iet aizvērt esošo katalogu.

3. Ja KatalogsNosaukumsParādās dialoglodziņš (sakarā ar to jaunu katalogs) ievadiet nosaukumu katalogs un nospiediet labi.

Līdz eksports uz MS Excel katalogs

1. Pārliecinieties, ka jums ir Katalogs view atvērts.

2. Noklikšķiniet uz Eksportēt uz Excel Katalogs izklājlapurīkjoslas pogu.

3. Izvēlieties faila nosaukumu, lai saglabātu MS Excel katalogu kā. Uzklikšķiniet Saglabāt.

Piezīme

Pēc noklusējuma eksportēto MS Excel katalogs ir filename būs Katalogs nosaukums suffixed ko Arhitektūras nosaukuma iekavās, piemēram, "Projekti (2014 Faktiskais) .xlsx". Jūs varat mainīt kādu no šā, tostarp, vai faila formāts ir jābūt .xlsx vai .xls. Arhitektūras vārds ir iekļauts, lai lietotājam atgādināt, ka katrs katalogs ir īpašs saturu (ti, IDS A ailē un 1. kārtas), lai to varētu apaļā paklupu atpakaļ, izmantojot importa no MS Excel kataloga kā vienu zemāk.

Piezīme

Pēc noklusējuma slēptās sleja laikā eksportētā MS Excel katalogs satur unikālu ID katram no elementiem ABACUS glabātavā. Tas ļauj visas izmaiņas, kas tiek veiktas laikā MS Excel, lai "saskaņota līdz" ar esošajiem elementiem ABACUS par importu (skatīt zemāk). Tomēr šo unikālo ID izmantošana "atbilstīgām" rindas var tikt pārsniegts ar Ārējā | IDīpašums uz elementa. Tas ir, ja elements ir ārējais | ID īpašums un tā ir iekļauta katalogā eksportu tad vērtībām Ārējo | ID kolonna tiks izmantoti, lai atbilstu up rindas uz importu (skatīt zemāk) un unikāls ID vērtības slēptā A ailē tiks ignorētas (un var pat būt tukšs). Slēptās sleja pašai jāpaliek, tomēr, jo īpaši vērtība šūnā A1. Turklāt, pievienojot ārējo SD esošam ABACUS elementu kolekciju mēs iesakām pievienot tos kā cits īpašums pirmo reizi, piemēram, Ārējā | Temp un tad pārdēvējot īpašumu External | ID. Pretējā dublikātu elementi tiks pievienoti.

Katalogs formatējumseksportē pēc noklusējuma, tomēr lieliem katalogos tas var izraisīt eksporta ir diezgan lēns. Attiecīgi, Tools | Iespējas ...tad uz Katalogstab,Jums ir iespēja samazināt formatējumu, kas eksportē, kā norādīts uz cilnes Katalogs zemāk, tādējādi paātrinot eksportu.

Katalogs eksports iespējas

4. Tiek parādīts Export Pabeigts dialog. Uzklikšķiniet labi.

Eksportēti uz MS Excel katalogs

Līdz imports no MS Excel kataloga

Piezīme

Pēc noklusējuma slēptās sleja laikā eksportētā MS Excel katalogs (skatīt iepriekš) satur unikālu ID katram no elementiem ABACUS glabātavā. Tas ļauj visas izmaiņas, kas tiek veiktas laikā MS Excel, lai "saskaņota līdz" ar esošajiem elementiem ABACUS par importu. Tomēr šo unikālo ID izmantošana "atbilstīgām" rindas var tikt pārsniegts ar Ārējā | IDīpašums uz elementa. Tas ir, ja elements ir ārējais | ID īpašums un tā ir iekļauta katalogā eksportu (skatīt iepriekš), tad vērtības no ārējā | ID kolonna tiks izmantoti, lai atbilstu up rindas uz importa un unikālu ID vērtības slēpto A ailē tiks ignorētas (un var pat būt tukšs). Slēptās sleja pašai jāpaliek, tomēr, jo īpaši vērtība šūnā A1. Turklāt, pievienojot ārējo SD esošam ABACUS elementu kolekciju mēs iesakām pievienot tos kā cits īpašums pirmo reizi, piemēram, Ārējā | Temp un tad pārdēvējot īpašumu External | ID. Pretējā dublikātu elementi tiks pievienoti.

1. Pārliecinieties, ka jums ir Katalogs view atvērts.

2. Noklikšķiniet uz Imports no Excel Katalogs izklājlapasrīkjoslas pogu.

3. Izvēlieties faila nosaukumu importēt MS Excel katalogu no. Uzklikšķiniet Atvērts.

4. Jaunas Kļūdas, kas uzietas un / vai jaunas kļūdas / Brīdinājumi Atklātie dialogs var parādīties uz jebkuru jaunu saturu (ti rindas MS Excel), kas tika pievienots. Ņemt vērā kļūdu / brīdinājumu un noklikšķiniet labi.

5. Import Pabeigts dialogs tiek parādīts, un tas var parādīt brīdinājumus Sakarā ar importu (skatīt piezīmes zemāk). Uzklikšķiniet labi.

Piezīme

Par piešķirtajiem standarti vai pievienotajos komponentu kolonnas, jauni ieraksti caur MS Excel katalogam jāsakrīt tieši nosaukums esoša standarta detaļas vai pareizā veida piešķiršanai vai savienojuma, kas jāpievieno. Pirmais nosaukts mačs tiks izmantoti un kādi nesaskaņotās ieraksti radīs brīdinājumu kā vienu zemāk. Turklāt, lai gan brīdinājumi ir norādīti uz atkārtotu importu, elementi nav svītrotsno ABACUS ja tie nav klāt MS Excel katalogā. Tas ir tāpēc, ka nav tā, ka ABACUS var zināt, vai pastāv ABACUS projektā piešķirto Standard vai pievienot Komponentu bet nepastāv MS Excel katalogam, jo ​​tā ir svītrota no MS Excel kataloga vai ir pievienota ABACUS projekts kopš kataloga tika eksportēts. Attiecīgi, ja lietotāji vēlas vienkārši "atklāt", kas ir pievienotas savienojumi importēšanas laikā tie var vienkārši izveidot nepieciešamo īpašumu par savienojuma veidu un noteikt tā noklusējuma tukšs tā, ka tie tiks brīdināti par jebkuru jaunu savienojumu katru reizi, kad importa ir pabeigta.

Piezīme

Kad importē MS Excel katalogu dažādi brīdinājumi var parādīties. Pirmkārt, ja jauna kolonna tika pievienota Excel, kas neatbilst ar "sintakse" Par nekustamā īpašuma vai pievienotajā sastāvdaļas kolonna tiks ignorētas. Tālāk, line-by-line brīdinājumi tiks parādīts par problēmām saistībā ar datiem par katras rindas Excel katalogā. Šie brīdinājumi sākas ar rindu skaitu kvadrātiekavās un ja attiecīgā kolonnas etiķetes (ti, "[23, J] ..." 23 kārtas, J ailē) un var atsaukties uz svītrots priekšmetus, nesaskaņoto standartiem vai pievienotajos komponentu nosaukumi (kas tiek ignorēti kā vienu piezīmi iepriekš) vai invalīds vai tukšu ID, kas attiecas uz jaunu rindu / elementu (kas tiks pievienots). Par detalizētu rakstu par aizpildi Abacus, izmantojot Excel katalogus lūdzu, skatiet Avolution Kopiena vai portfeļa pārvaldnieks mācību kurss.

Piezīme

Jauni detaļas un savienojumi, tiek atjaunots pēc noklusējuma augšējā no sastāvdaļām vai savienojumiem kolekciju izvēlētā Arhitektūras līmenī. Lai mainītu vecāks jauno sastāvdaļu vai savienojumu ar peles labo pogu hierarhijā Path šūnu jaunās detaļas vai savienojumus rindā un izvēlieties Mainīt Parent ...un izvēlēties vēlamo vecākiem (ņemot zināšanai ierobežojums izceļot ).

Piezīme

Elementi pievienots tieši katalogu starpniecību "pievienot jaunu 'pogu, ielīmēt katalogā, vai izveidota, izmantojot ievest katalogā no MS Excel ir atbrīvoti no filtrējot līdz katalogā ir slēgta. Tas nepieciešams, lai varētu visu vajadzīgo rediģēšanu kolonnu vērtību, kas varētu neatbilst pašreizējos filtrēšanas kritērijiem kataloga. Šīs jaunās elementu rindas ir apzīmēti ar '+' simbola rinda selektora šūnas sākumā rindas, kas ir krāsaina zaļš ja elements šobrīd atbilst saglabātos filtrēšanas kritērijus katalogs (ti, paliks uz katalogu ja atkārtoti atvērts), un sarkans ja tā nav.

Līdz salīdzināt saturu krājums ar citu arhitektūru

1. Lūdzu, skatiet tēmu šeit .

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Aizpildi savu arhitektūru no Visio | Aizpildi savu arhitektūru no Excel


Aizpildi izmantojot matricas

Navigācija: Populating savu arhitektūru>

Aizpildi izmantojot matricas

Nosūtīt komentārus par šo tēmu.

Matricas ļauj jums apskatīt un rediģēt "tieša" savienojumi starp detaļām vienkāršā tabulas veidāun, lai arī apskatīt "netiešu ceļu" starp komponentiem saskaņā ar jebkuru starpposma sastāvdaļām (un savienojumi).

Līdz izveidot Matrix view in ABACUS

Piezīme

Lai gan visas Arhitekts lietotāji var radīt matricas lai saglabātu tos un / vai to iestatījumi lietotāja licence vajadzīga Designer pievienot-on spējas. Tas nepieciešams, lai "aizsargātu" konfigurāciju esošo matrices, kas var tikt attiecināta uz daudziem lietotājiem. Tomēr Arhitekts izmanto bez Designer pievienot-on joprojām var izvēlēties "Save As" visiem jaunajiem uzstādījumiem jaunā Matrix. Un, protams, visi lietotāju licences var izvēlēties "atbrīvoties" jebkādām izmaiņām esošajā Matrix. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

1. Izvēlieties Ielikt | Matrix.

2. Iekš rchitecture>pull-down atlasiet Arhitektūra, kas satur sastāvdaļas un savienojumi vēlaties apskatīt.

3. Iekš <AvotsTips>pull-down izvēlētos detaļas tipa, kuru vēlaties ir gadījumi uzskaitīti kā "rindas' uz leju pa kreisino matricas.

4. Iekš <IzlietneTips>pull-down izvēlētos detaļas tipa, kuru vēlaties ir gadījumi uzskaitīti kā "kolonnas' augšdaļāno matricas.

5. Iekš vilkt lejā ir būtībā divi "režīmi" par matricas jūs varat definēt ...

"Tieša savienojumus matrices

6. Vienkārši sievēlēt viens (1) vai vairāk saistība veidi labajā pusē izvēlnē, kas parādās, ja Jūs vēlaties redzēt ar "šūnām" matricas jan skaidrusavienojums pastāv no Vertikāls/ "rinda"Komponents no matrices uz Horizontāls/ "kolonna"Komponents no matricas.

Piezīme

Tikai savienojumus ar kods beidzies piestiprināta Vertikāls/ "rinda"Sastāvdaļa un izlietne beigas piestiprināta Horizontāls/ "kolonna"Sastāvdaļa būs redzams. Ieslēdziet Avotsun Izlietnedetaļas tipa izvēle, lai apskatītu savienojumus pretējā virzienā.

7. Matrica tiks apdzīvots ar "X" šūnās (vai īpašuma vērtības - skatīt piezīmi zemāk) ja ir savienojums no Vertikāls/ "rinda "komponents no matrices uz Horizontāls/ "kolonna"Komponents no matricas.

Piezīme

Lieliem matricās tikai maksimums 100 rindas vai kolonnas (ieskaitot sabruka rindas / slejas) būs redzams laikā, kā redzams ar "R" un "C" rādītāju augšējā kreisajā galvenes šūnas attiecīgi. Lai skatītu papildu rindas izmantot ritjoslas. Jebkurā laikā jūs varat dubultklikšķi uz Vertikāls/ "rinda'Vai Horizontal / 'kolonna"Komponents pozīcijas un pāriet uzattiecīgie komponenti Explorer logā.Vecāki vertikālo/ "rinda' un Horizontāls/ "kolonna"Komponentss ir arī izvēles parādītas kā pozīcijas rindas / kolonnas ar pelēku virsrakstu titulu. Kad sabruka (ar vienu klikšķi virsrakstu šūnu), ja bērni pielikumi pastāvēja tad "X" būs izvēles tiek parādīts, ja visi bērni bija pievienotas vai "O" būs izvēles tiek parādīts, ja tikai daži no bērniem tika pievienots. Šūnas var būt krāsots saskaņā ar īpašuma vērtību savienojumus, noklikšķinot uz Options "zobrats" augšējā labajā stūrī matricas rīkjoslas un izvēloties Krāsu iestatījumi ... un pēc tam uz pogas Edit un izvēloties Colour ar laikspiedolu vai Colour By īpašuma opciju un izvēloties īpašuma, Min un Max vērtību klāsts, un izvēloties krāsas, tomēr tikai Saraksts, Integer, Decimal, Boolean vai Date / Time datu tipu īpašības būs krāsu. Ja sabruka šūna tiks iekrāsoti saskaņā ar vidējo īpašuma vērtību savienojumu. Tā vietā, lai par "X", īpašuma vērtības šūnās var būt parādīts noklikšķinot opcijas "zobrats" augšējā labajā stūrī matricas rīkjoslas un izvēloties Rādīt Vērtība Settings ... un pēc tam uz pogas Edit un izvēloties Show īpašuma opciju un izvēloties īpašumu.

Tiešie savienojumi matrica parādot Servers ja pieteikumi tiek izvietots ar krāsvielu un mantas tiek parādīts, nevis vispārējs "X"

- Vai -

"Netiešais savienojumus matrices

6. Sievēlētsecība saistība veidi un komponentu veidilabajā un kreisajā pusē izvēlnē, kas parādās, ja Jūs vēlaties redzēt ar "šūnām" matricas jan netiešais ceļš saistītu komponentupastāv no Vertikāls/ "rinda"Komponents no matrices uz Horizontāls/ "kolonna"Komponents no matricas.

Piezīme

Jebkuru spēkā esošu ceļš, kas ietver izvēlēto ceļā izvēlnē w elementislims jāparādaneatkarīgi no virziena notikušo savienojumiem, tomēr, izvēloties ceļu, pa kuru pirmaisun pēdējie elementi izvēlēts jābūt savienojumu tipi. Turklāt pasūtījums no elementiem, kas ir izvēlēti tiek parādīts ar skaitliskā priedēklisin laukumā ("[]"), skavas un veidam var iekļaut mutliple reizesceļā (kā norādīts ar skaitlisko prefiksu). Secīgā izvēle sastāvdaļu tipiem vai pieslēguma veidiem tiek interpretēts kā "Vai"ceļš un hierarhija pievienoto komponentu var pēc izvēles iekļaut, pārbaudot "Arī meklēt Pielikums vecākiem / bērniem"Rūtiņu. Ieslēdziet Avotsun Izlietnedetaļas tipa izvēle, lai apskatītu ceļi pretējā virzienā.

7. Matrica tiks apdzīvots arceļš / kolekcija sastāvdaļušūnās, ja ir taka no Vertikāls/ "rinda "komponents no matrices uz Horizontāls/ "kolonna"Komponents no matricas.

Piezīme

Lieliem matricās tikai maksimums 100 rindas vai kolonnas (ieskaitot sabruka rindas / slejas) būs redzams laikā, kā redzams ar "R" un "C" rādītāju augšējā kreisajā galvenes šūnas attiecīgi. Lai skatītu papildu rindas izmantot ritjoslas. Jebkurā laikā jūs varat dubultklikšķi uz Vertikāls/ "rinda'Vai Horizontal / 'kolonna"Komponents pozīcijas un pāriet uzattiecīgie komponenti Explorer logā.Vecāki vertikālo/ "rinda' un Horizontāls/ "kolonna"Komponentss ir arī izvēles parādītas kā pozīcijas rindas / kolonnas ar pelēku virsrakstu titulu. Kad sabruka (ar vienu klikšķi virsrakstu šūnu), ja tādi bērni ceļi pastāvēja tad "X" būs izvēles tiek parādīts, ja visi bērni bija pievienotas vai "O" būs izvēles tiek parādīts, ja tikai daži no bērniem bija ceļus. Netiešie ceļš sastāvdaļas var būt krāsots saskaņā ar īpašuma vērtību komponentu, noklikšķinot Options "zobrats" augšējā labajā stūrī matricas rīkjoslas un izvēloties Krāsu iestatījumi ... un pēc tam uz pogas Edit un izvēloties Colour ar laikspiedolu vai Colour By īpašuma opciju un izvēloties īpašuma, Min un Max vērtību klāsts, un izvēloties krāsas, tomēr tikai Saraksts, Integer, Decimal, Boolean vai Date / Time datu tipu īpašības būs krāsu. Īpašuma vērtības netiešo ceļu komponentu var būt parādīts noklikšķinot opcijas "zobrats" augšējā labajā stūrī matricas rīkjoslas un izvēloties Rādīt Vērtība Settings ... un pēc tam uz pogas Edit un izvēloties Show īpašuma opciju un izvēloties īpašumu.

Netieša savienojumi matrica parādot lietojumprogrammas, kas īsteno attiecīgo pakalpojumu, ko departaments

Līdz filtrsMatrix view in ABACUS

1. Pārliecinieties, ka jums ir jauna Matrix view atvērts.

2. Uzklikšķiniet Filtrs virzieniem "piltuvi" augšējā labajā stūrī matricas rīkjoslas.

3. No avota un / vai izlietnē cilnes pievienot nosaukums, īpašuma, apraksts, hierarhiju vai standarta filtrus, noklikšķinot uz Pievienot pogu, izvēloties īpašumu, ja nepieciešams, un noklikšķinot labi. Izvēlieties attiecīgās opcijas Atslēgvārdi / posteņos paneļa, izmantojot loģisko / sintaksi, kā aprakstīts zemāk piezīmē. Priekšskatījuma panelis automātiski atjaunināt, lai parādītu no pašreizējās filtru kopa rezultātus.

Piezīme

Par Timestamp, hierarhija Path, Namevai Aprakstsfiltrus vai Teksts, Integer, Decimal, Booleanvai Datums Laiksīpašuma filtri saskaņošana tiek veikta tā, it kā '*' aizstājējzīmes automātiski tiek piemēroti pirms un pēc jebkurām stīgu vērtībām, lai ieraksts par "kaķis" (bez pēdiņām) ietver rindās ar 'bobukaķis','kaķissieviete "vai" pieteikaķision "uc Vairāku /" vai "var ierakstīt vērtības, uz jaunām līnijām, izmantojot Ctrl + Enter. Par Vesels skaitlis un Decimal īpašuma filtri "un" loģiku var iekļaut, izmantojot "&"(Bez pēdiņām) un lielāks / mazāks nekā etc loģika var iekļaut izmantojot"> =','>','<'Un'<="(Bez pēdiņām), piemēram, '> = 50000 & <90000 ". Non-blank vērtē rindas var iekļaut, ievadot "(Non-Blanks)"(Bez pēdiņām) un Blank vērtē rindas var iekļaut, ievadot"(Blanks)"(Bez pēdiņām).Par Standarti vai Saraksts īpašums filtri "(Atlasīt visu)" rūtiņu ļaus visas pārējās rūtiņas, faktiski ieskaitot visus pieejamos elementus. Ar "(Non-Blanks)" rūtiņu ietvers neviena nav tukšs īpašuma vērtē elementus. Ar "(Blanks)" rūtiņu ietvers nevienu tukšu īpašumu, vērtē elementus. Un noņemot atzīmi kādas īpašas vērtē rūtiņas automātiski atceliet "(Atlasīt visu)" un "(Non-sagataves)" pogu, kas atrodās konsekvences. Un visbeidzot, visi filtri ir pēc noklusējuma gadījumā nejutīgu tik "kaķis" (bez pēdiņām) ietver elementus ar "kaķis", "kaķis" vai "kaķis" uc lieta jutīga saskaņošana, ievadiet "(Lieta)"(Bez pēdiņām) pirms string piem "(Lieta) Kaķi" (bez pēdiņām) ietvertu tikai elementus ar "kaķis" tiem.

Aizpildīt, izmantojot Matrix viedokli ABACUS

Piezīme

Jūs varat pievienot tikai / noņemt savienojumi, kur viena pieslēguma veids ir izmantots Ceļš iepriekš aprakstīto.

1. Līdz pievienot savienojumsno izvēlētā tipa starp Vertikāls/ "rinda"Sastāvdaļa un Horizontāls/ "kolonna"Sastāvdaļa matricas, kur" X "nav jau eksistē(vai parādīts īpašuma vērtība - skatīt piezīmi iepriekš), Divreiz noklikšķiniet šūnā. "X" vajadzētu parādīties (vai īpašuma vērtība - skatīt piezīmi iepriekš) un savienojums tiks izveidots augšējā līmenī Connections vākšanas izvēlētajā arhitektūru.

Piezīme

Savienojuma nosaukums būs savienojuma veids nosaukums kā vienu savienojuma veidu nosakot matricas un, ja īpašuma vērtība tiek parādīts, nevis "X" noklusējuma vērtība nekustamajam īpašumam tiks parādīts.

2. Līdz rediģēt redzamo īpašuma vērtībupar saikni starp a Vertikāls/ "rinda"Sastāvdaļa un Horizontāls/ "kolonna"Komponents no matrices, Divreiz noklikšķiniet uz šūnas, vai ar peles labo pogu noklikšķiniet uz šūnas un izvēlieties Edit vērtība ..., un rediģēt vērtību maiņa Value dialog.

3. Līdz noņemt savienojumuno izvēlētā tipa starp Vertikāls/ "rinda"Sastāvdaļa un Horizontāls/ "kolonna"Komponents no matrices, kur" X "jau pastāv(vai parādīts īpašuma vērtība - skatīt piezīmi iepriekš), labāsnoklikšķiniet uz šūnasun izvēlieties Atvienot. X vajadzētu izzust un savienojums tiks dzēsta no projekta.

Saglabāt / saglabāt kā aMatrix view

Piezīme

Lai gan visas Arhitekts lietotāji var radīt matricas lai saglabātu tos un / vai to iestatījumi lietotāja licence vajadzīga Designer pievienot-on spējas. Tas nepieciešams, lai "aizsargātu" konfigurāciju esošo matrices, kas var tikt attiecināta uz daudziem lietotājiem. Tomēr Arhitekts izmanto bez Designer pievienot-on joprojām var izvēlēties "Save As" visiem jaunajiem uzstādījumiem jaunā Matrix. Un, protams, visi lietotāju licences var izvēlēties "atbrīvoties" jebkādām izmaiņām esošajā Matrix. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums nepieciešama Designer add-on spējas.Un atcerieties, tas ir tikai iestatījumus, Matrix, visi labojumi veikti datiem Matrix uzreiz tiek piemēroti repozitorijā neatkarīgi.

1. Pārliecinieties, ka jums ir jauna Matrix view atvērtsun esat veicis nepieciešamās izmaiņas.

2. Iekš Matrix viewrīkjoslā noklikšķiniet uz kreisās malas Saglabāt Matricapogu, lai saglabātu Matrix view un jebkādas formatēšanas izmaiņas.

Piezīme

Ja jums nav Saglabāt pogu Matrix skata rīkjoslā, tad jums nav Designer add-on, un jums ir tikai spēj Saglabāt kākādi uzstādījumi mainās uz jaunu matricu, kad iet aizvērt esošo matricu.

3. Ja MatricaNosaukumsdialog kas parādās (sakarā ar to jaunu matrica) ievadiet nosaukumu matricaun nospiediet labi.

Līdz eksports uz MS Excel matricu

1. Pārliecinieties, ka jums ir Matrix view atvērts.

2. Noklikšķiniet uz Eksportēt uz Excelrīkjoslas pogu.

3. Izvēlieties faila nosaukumu, lai saglabātu MS Excel matrica kā. Uzklikšķiniet Saglabāt.

Piezīme

Pēc noklusējuma eksportēto MS Excel Matrix ir filename būs Matrix nosaukums suffixed ko Arhitektūras nosaukuma iekavās, piemēram, "Pieteikumus hosted at serveri (2014 Faktiskais) .xlsx". Jūs varat mainīt kādu no šā, tostarp, vai faila formāts ir jābūt .xlsx vai .xls.

Matrix formatējumseksportē pēc noklusējuma, tomēr lieliem matricām tas var izraisīt eksporta ir diezgan lēns. Attiecīgi, Tools | Iespējas ...tad uz Matricatab,Jums ir iespēja samazināt formatējumu, kas eksportē, kā norādīts uz cilnes Matrix zemāk, tādējādi paātrinot eksportu.

Matrix eksports iespējas

4. Tiek parādīts Export Pabeigts dialog. Uzklikšķiniet labi.

Eksportēti uz MS Excel matricu

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Aizpildi savu arhitektūru no Visio | Aizpildi savu arhitektūru no Excel


Aizpildi savu arhitektūru no Microsoft Access

Navigācija: Populating savu arhitektūru> Populating no Microsoft produktiem>

Aizpildi savu arhitektūru no Microsoft Access

Nosūtīt komentārus par šo tēmu.

Jūs varat eksportēt savu arhitektūru, lai Microsoft Access veikt vispārējas aprēķiniem, manipulāciju vai pārskatus par savu arhitektūru. Pēc tam Jūs varat importēt arhitektūru atpakaļ ABACUS.

Piezīme

Open Access no / Eksportēt uz datu bāzes funkcija paredz, ka Microsoft Access 2000vai jaunāka ir instalēta datorā.

Lai eksportētu savu arhitektūru, lai Microsoft Access

1. Pārliecinieties, vai ir ABACUS failsatvērts, Pētnieksparādīta, un arhitektūrapiebilda.

2. Izvēlieties File | Eksports | Datubāzei.

3. Ņem vērā brīdinājuma dialogā, kā aprakstīts iepriekš, un noklikšķiniet uz Jā, lai turpinātu.

4. Izvēlieties vietu un faila nosaukumu, lai datu bāzes failu.

Importēt manipulē arhitektūru ABACUS

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Izvēlieties File | Jauns un izvēlieties No Accessno dialoga logā un noklikšķiniet uz Labi.

3. Pārlūkot datu bāzes failu, kuru vēlaties importēt.

Abacus "MS Access Database shēma

ABACUS ir tās sirds an ontoloģija / meta-meta-modelis, kas sastāv no komponentiem, savienojumi un ierobežojumus. Šī "CCC" pieeju, tika iegūta no dažādiem standarta pieejas izstrādāta no 1960 gada, kas beidzas ar starptautiskā standarta IEEE 1471, kas Avolution dibinātāji veicināja. Turpmāk primitīvi piemēro;

1. ABACUS satur Bibliotēkasno Standarti(vai standartiem), Komponentsun Savienojuma veidi, Ierobežojumi, Viedokļi, Veidnes (vai Patterns) Un daudz Arhitektūras.

2. Standarti, Veidiun Viedokļi varbūt loģiski Sagrupētsērtības.

3. Arhitektūras var saturētdaudzi pēcnācējs Arhitektūras(vai arī izmaiņas).

4. Katrs Arhitektūra saturdaudz Sastāvdaļasun SavienojumiDažu Veidiun dažādi Views.

5. Sastāvdaļasun Savienojumi var būt sadalījušiesuz Sub-Componentsun Sub-Connections.

6. Katrs Komponentsir pievienotsjebkuru skaits Savienojumibet katrs Savienojumsvar būt tikai pievienotsne vairāk kā divas Sastāvdaļas.

7. Sastāvdaļasun Savienojumivar būt Standartiar Propertiespiemēram, informācija, veiktspēju, uzticamību, izmaksas utt

8. Arhitektūras, Sastāvdaļasun Savienojumivar būtspecifisks Propertiespiemēram, informācija, veiktspēju, uzticamību, izmaksas utt

9. Ierobežojumivar pastāv starp Sastāvdaļasvai Savienojumivai pret Properties.

10. Veidnesir standarta kompozīcijas Komponentsun Savienojuma veidi.

11. Viedokļiir standarta apvienības Komponentsun Savienojuma veidiuz piezīmēm.

12. Viewsir vizuāli pārstāvniecības Sastāvdaļasun Savienojumi.

Nākamajā MS Access Entity Saistība diagramma (ERD) dokumentiem kodolsArhitektūras, Notikumi, Komponentu / Savienojuma veidi (un grupas), komponenti / Savienojumi un Sub komponents / Savienojuma jēdzieni.

Core datubāzes shēmu

Piezīme

Godbijīgs integritāti netika izpildīts par attiecībām starp komponentiem galda un savienojumi tabulu (par "pielikumu" starp avotam vai nogrimt sastāvdaļu un savienojumu). Tas ir tāpēc, ka saistība var pastāvēt bez sastāvdaļu pielikumiem. Mēs varētu būt pievienojuši "pielikumu" galda, bet vienkāršības labad nolēma pret to. Protams, tas nozīmē, ka jebkurš rediģēšana detaļas ID vai dzēšanu detaļas rindās visi kopā radīs nepareizus datus. ABACUS tiks galā ar jebkuru nepareizību importam, ignorējot nepareizus datus.

Nākamajā MS Access ERD dokumentiem Propertieskoncepcijas arhitektūru, Component / pieslēguma veidi un komponenti / savienojumi.

Properties datubāzes shēmu

Nākamajā MS Access ERD dokumentiem Standartikoncepts arhitektūru, Component / pieslēguma veidi un komponenti / savienojumi.Piezīme: Tabulas joprojām izmantot terminu "īstenošanu", kā vienu iepriekšējām versijām ABACUS.

Standarti datubāzes shēmu

Nākamajā MS Access ERD dokumentiem Ierobežojumikoncepcija detaļas / savienojuma veidu.

Ierobežojumidatubāzes shēmu

Nākamajā MS Access ERD dokumentiem Viedokļi koncepcija Arhitektūras.Piezīme: Tabulas joprojām izmantot terminu "TwoDTempl" kā vienu iepriekšējām versijām ABACUS.

Viedokļidatubāzes shēmu

Nākamajā MS Access ERD dokumentiem Katalogikoncepcija Arhitektūras.

Katalogidatubāzes shēmu

Nākamajā MS Access ERD dokumentiem Matricaskoncepcija Arhitektūras.

Matricasdatubāzes shēmu

Nākamajā MS Access ERD dokumentiem Diagrammaskoncepcija Arhitektūras.Piezīme: Tabulas joprojām izmantot terminu "TwoD" kā vienu iepriekšējām versijām ABACUS.

Piezīme

Sastāvdaļas / Connection Type ar trafaretu formas kartēšanu un Freeform formu porcijas MS Access ERD ir izlaisti skaidrība.

Diagrammasdatubāzes shēmu

Nākamajā MS Access ERD dokumentiem 3D Viewskoncepcija Arhitektūras.

3D Viewsdatubāzes shēmu

Nākamajā MS Access ERD dokumentiem Chartskoncepcija Arhitektūras.

Chartsdatubāzes shēmu

Nākamajā MS Access ERD dokumentiem Paneļijēdziens.

Paneļidatubāzes shēmu

Abacus 'MS AccessVaicājumi

Iekļaušana ar MS Access datu bāze ir vairākas noderīgas vaicājumi šādi;

· Datori ar Props- Šis jautājums ir uzskaitītas visas sastāvdaļas projektā (ar arhitektūru un veida), un ietver visas īpašības, kā kolonnas. Izmantojiet šo jautājumu ar filtri / no kritērijiem par detaļas tipa un / vai arhitektūra, lai ražotu "tipisku" tabulas par katru detaļas tipa ar to īpašībām.

· STS ar Props- Šis jautājums ir uzskaitīti visi standarti, kas tiek izmantoti, atkārtojumu skaitu standarta un ietver visas īpašības, kā kolonnas. Izmantojiet šo vaicājumu, kā standartu kataloga.

· Balsti pa veidiem- Šis jautājums ir uzskaitīti visi komponentu īpašības un to% katras detaļas tipa kā kolonnām pabeigta. Izmantojiet šo vaicājumu, lai noteiktu, vai specifiskās īpašības tiek saglabāta.

· Veidus, kurus Props- Šis jautājums ir uzskaitīti visi komponentu veidus un ietver% pilnīgi visu īpašībām kā kolonnām. Izmantojiet šo vaicājumu, lai noteiktu, vai specifiskās īpašības tiek saglabāta.

· Type skaits- Šis jautājums ir uzskaitīti visi komponentu veidus un ietver atkārtojumu skaitu katra veida dilstošā secībā. Izmantojiet šo vaicājumu, lai noteiktu popularitāti katra veida projektā.

Piezīme par darbu ar Memo laukiem MS Access

Komponentiem, Savienojumi un standarti Vārds lauki tabulās tiek definēti kā ārpusbilances jomās, lai ļautu neierobežotu skaitu rakstzīmju, kā vienu ABACUS. Sastāvdaļu un savienojumi tas rada dažus jautājumus, jo tie arī ir unikāls ID lauks norādes, bet standartiem tas rada dažas problēmas, mēģinot pievienoties tabulas, jo jūs nevarat pievienoties memo laukiem MS Access. Alternatīvi, jūs varat iestatīt, ja klauzulas kritērijus, lai panāktu tādu pašu efektu kā parādīts Visual Query Builder un atbilst SQL fragmentus turpmāk šajā sarakstā visus iedzimta standarti īpašības attiecībā uz visiem komponentiem eksportētā ABACUS projektā.

Memo lauks "pievienojas" Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

No sastāvdaļām INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) AND (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), implementācijas INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

Kur (((ComponentImplementationLinks.Name) = [Izpildīšanas] [nosaukums]).);

Memo lauks "pievienojas" SQL

Piezīme par automātiski radot ABACUS ID MS Access

Dažādas ABACUS MS Access tabulas nepieciešama unikāla ilgi veselam ID tik vienkārša VB metode ir paredzēta, lai palīdzētu paaudzes šiem. Divas metodes ResetCounter () un GetNextCounter () ir nodrošinātas Abacus 'MS Access DB un to izmantošana ir šāds; ResetCounter () tiks noteikti counter atpakaļ uz 0. GetNextCounter () atgriezīsies nākamo counter secībā.

Metodes izmantot MS Access "untums", ka pat tad, ja jūs izsauktu ResetCounter () metodi, lai katrā rindā ieliktni (ti, ja jūs arī palaist GetNextCounter () funkciju), jo ResetCounter () funkcija nav neviena parametrus tas vienkārši ilgst tā vienu reizi, un tāpēc nav reset skaitītāju katrā rindā ieliktni. Un arī tāpēc, ka tajā pašā "untums" jums jānokārto jebkuru veco kolonnu mainīgo ar GetNextCounter () funkciju, lai muļķis to darbojas katru reizi.

Ir arī triks, lai to var palaist ResetCounter () funkcija ir ievietot SQL jo jūs aprunāt vienkārši ir tas sēdēja kā kolonnu tīrā veidā, piemēram, ja tas bija izvēlieties vaicājumu. Ir ieteicams veikt ResetCounter () izsaukuma daļu kādu no citām jomām, ko konkatenācijas to līdz beigām, jo ​​tas vienmēr atgriež null anyway.

Zemāk ir tipisks SQL izmantošana metodēm, lai pievienotu sarakstu komponentu veidi no galda / vaicājumu, ko sauc par "sastāvdaļas tipa saraksts".

INSERT INTOComponentTypes (Id, vārds, apraksts)

SELECT GetNextCounter ([detaļas tipa List] Nosaukumu)AS Id, [detaļas tipa List] Nosaukumu AS Vārds, [detaļas tipa List] .description & ResetCounter ()AS Apraksts

NO[Detaļas tipa List];

ABACUS ID / Counter paaudzes SQL

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Aizpildi savu arhitektūru no Visio | Aizpildi savu arhitektūru no Excel


Aizpildi savu arhitektūru no Microsoft Visio

Navigācija: Populating savu arhitektūru> Populating no Microsoft produktiem>

Aizpildi savu arhitektūru no Microsoft Visio

Nosūtīt komentārus par šo tēmu.

Jūs varat importēt savu arhitektūru no Microsoft Visio. Formas jūsu Visio zīmēšanas tiks importēti kā komponentiem ABACUS. Savienojumi Jūsu Visio zīmēšanas tiks importēti kā savienojumiem un zīmējums pats tiks ievesti ABACUS kā diagrammā. Turklāt jebkurš Custom Properties jūsu Visio zīmēšanas tiks importēti kā īpašumiem ar tāda veida atslēga plānots Īpašuma tips, etiķete uz īpašumu nosaukumu un vērtību īpašuma vērtības.

Piezīme

Importa no Visio iezīme ir noteikts, ka Microsoft Visio 2003vai jaunāka ir instalēta datorā.

Lai importētu Visio zīmējumus ABACUS

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Izvēlieties File | Jauns un izvēlieties No Visiono dialoga logā un noklikšķiniet uz Labi.

Piezīme

Ja vēlaties ievest esošā ABACUS projekta tad nu ar peles labo pogu komponentiem mezglu ietvaros Arhitektūra, vai peles labo pogu noklikšķiniet individuālu komponentu robežās Arhitektūra un pēc tam atlasiet Importēt | No Visio.

3. Pārlūkot Visio failu, kuru vēlaties importēt.

Piezīme

Zemāk ir daži vienkārši noteikumi vai ieteicamās prakses Būvējot (vai groza) MS Visio zīmēšanas importam ABACUS.

1. Līnijas vai savienojumiem jābūt faktiskā savienotāji, nevis formas.

· Pretējā ABACUS vienkārši importēt tos kā sastāvdaļu un attiecīgi tie netiks "pievienots", lai kaut ko.

· Ja jums ir nepieciešams veikt dažas "smart" maršrutēšanu (ti, izņemot taisnā līnijā), tad izmantojiet Dynamic savienotāju uz pamatformām trafaretu, ABACUS importēs maršrutēšanas / enkuru punkti fine.

· Centieties izvairīties, izmantojot "Ring tīkla" un "Ethernet" formas no tīkla un perifērija trafareta, kas ļauj daudz komponentu, kas "saistīti" ar to. Kamēr mēs importējam pielikumi naudas soda savienojumi sākotnējā forma ir vēl "paplašināta", lai atspoguļotu pielikumus. Izmantojiet atdalītu atsevišķu "HUB / autobusu" formu (bez savienotāja "kājas"), un pēc tam skaidri savienot katras detaļas rumbas / autobusu ar atsevišķām savienotājiem.

· Ja līnija vai savienojumu uzvedas kā forma, tiesības noklikšķiniet uz tā un iet uz "formāts | Uzvedība ... "un pārliecināties, ka Mijiedarbība stils ir iestatīta Line (1-dimensiju).

2. Komponenti jābūt formas NE savienotāji.

· Pretējā ABACUS vienkārši importēt tos kā savienojumus un attiecīgi visa forma informācija tiks zaudēta.

· Ja sastāvdaļa uzvedas kā savienotāju, tiesības noklikšķiniet uz tā un iet uz "formāts | Uzvedība ... "un pārliecināties, ka Mijiedarbība stils ir iestatīts uz Box (2-dimensiju).

3. Connector gali ir jāpievieno formas, NOT peldošs ap fonā aiz formas.

· Ja jums nav savienot savienotāji ar formām, tad ABACUS ir nekādi nevar zināt, kas jums paredzēts pievienot doto savienotāju formas / detaļas un attiecīgi tas atstās, ka galu savienojuma ANO pievienots.

4. Uzlīmes formām vajadzētu būt (ja iespējams) Iekšēja teksts etiķete formas, nav atsevišķs tekstlodziņš uz zīmējumu.

· Atsevišķas teksta kastes saņems importējis ABACUS kā sastāvdaļu savām tiesībām, un, kamēr jūs varat apvienot "etiķeti" sastāvdaļa ar reālo komponentu ABACUS, vai vienkārši konvertēt "etiķeti" komponentu brīvas formas formas (ti, ne sastāvdaļa pati) tas ir labākais, lai izvairītos no šīs darbības.

5. Izmantot to pašu bāzes forma katram gadījumam tā paša tipa, Neesiet slinki un izmantot taisnstūra dažreiz un kastu citus no dažādu formu stencils.

· ABACUS izmanto bāzes formu un tās bāzes krāsu, lai unikāli identificētu komponentu un savienojuma tipu zīmējumā tik "sarkans taisnstūris" un "red box" saņems ievest kā divu atsevišķu sastāvdaļu veidu. Šīs sastāvdaļas veidi var tikt apvienotas ABACUS, bet tas ir labākais, lai izvairītos no šīs darbības.

6. Pilnīgi rezumēju "bērni" figūras savās "vecākiem", neatstājiet tos karājas pāri malai.

· ABACUS būs atklāt jebkuru formu, kas ir pilnībā ietverts kādā citā formā, kā bērns ar vecākiem, lai pārliecinātos par visu formu, ieskaitot etiķetes daļu, ir iežogota.

7. Nenovietojiet formu pārklājas divas citas formas.

· Ja forma pārklājas divas citas formas, vai tas būtu "grupēšanas" / fona taisnstūri vai citādi, tas tiks importēti ar ABACUS kā sastāvdaļu, kas ir bērns, nedz pārklājās formas, bet, tiklīdz jūs izvēlēties komponentu Abacus "zīmēšanas rīks , jo augšējā kreisajā to sastāvdaļas atskaites punkts, tas kļūs bērns kreisi pārklāšanās formas / komponentu.

8. Centieties, lai samazinātu lietošanu teksta piezīmes uz zīmējuma, jo tie saņems ievest kā sastāvdaļas pašas par sevi, un būs nepieciešams pārvērst brīvās formas formas ABACUS. Padomā par to, vai tie ir patiesi nosaukumu esoša sastāvdaļas vai savienojumu.

9. Kaut ABACUS atbalsta bagāts / krāsaini / vektoru balstītas formas, mēģināt samazināt izmantošanu bitkartes, ārvalstu formas un uzlabota metafaili par formām, kā ABACUS šobrīd daranavatbalstītu šos veidus. Tie tiks importēti kā vienkāršu baltu taisnstūri.

10. Centieties izvairīties no pārvadāšanas ienesīgumu (maiņās Atpakaļ) marķējumu, jo tie tiek importēti un parādīts kā īpašu raksturu "[]" in ABACUS par komponentu nosaukumu.

11. Centieties, lai samazinātu dažādas krāsas, kas tiek izmantoti formām tā paša tipa. Kā minēts iepriekš, bāzes krāsa un bāzes forma unikāli identificē sastāvdaļas un savienojuma veidu tāpēc vairāk variācija ir vairāk apvienošanās un konsolidācija, kas būs jādara pēc importa in ABACUS.

12. Esiet uzmanīgi ar pildītiem formām, jo, ja forma ir piepildīta visu ceļu uz stūriem, tad krāsošana to vēlāk ABACUS neietekmēs.

13. Par sarežģītu līniju balstītu formu jums ir jāizmanto daudzstūri, kas ir izveidots, ņemot līnijas, sākot kur iepriekšējais beidz un tad galu galā dodas atpakaļ uz sākuma punktu. Ja vēlaties, varat izmantot aizpildījuma un līnijas platums padarīt daudzstūris izskatās "bultas" vai kāds formas jūs vēlaties.

14. Pārliecinieties formas ID MS Visio ir nozīmīgs ne tikai Shape.xx. Tas ir rediģējams, izmantojot peles labo pogu 'Rādīt Shapesheet ", kas ir pieejams MS Visio izstrādātāja režīmā (ļāva caur Tools | Iespējas MS Visio).

15. Elipses un lokiemlaikā formastiek atbalstīta ABACUS bet NURBS un splainu pašlaik netiek atbalstīta.

16. Pārliecinieties, ka visa forma ir sagrupēti MS Visio vai tas kļūs ievest kā vairākas sastāvdaļas / veida.

17. Centieties, lai samazinātu lietošanu pagriež formas ietvaros subshapes jo tie dažreiz netiek importētas pareizi.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Aizpildi savu arhitektūru no Access | Aizpildi savu arhitektūru no Excel


Aizpildi savu arhitektūru no Microsoft Excel

Navigācija: Populating savu arhitektūru> Populating no Microsoft produktiem>

Aizpildi savu arhitektūru no Microsoft Excel

Nosūtīt komentārus par šo tēmu.

Jūs varat importēt savu arhitektūru no Excel izklājlapu (.xls vai XLSX fails). Excel importētājs ļauj karte sastāvdaļu sarakstus un savienojumi ar veidu, standartiem, īpašības un standarta īpašības, izvēloties kolonnas jūsu izklājlapu, kas satur attiecīgos datus.Tomēr ir daudz modernu tehniku, nekā ieteicamā pieejaimportēt no MS Excel, kas ir via katalogi kā aprakstīts šeit .

Piezīme

Importa no / Eksportēt uz Excel funkciju nosaka, ka Microsoft Excel 2003vai jaunāka ir instalēta datorā.

Galvenā funkcija Excel Importētājs ir, lai jūs varētu noteikt konfigurācijas failu (ti, hierarhisko struktūru jūsu arhitektūras modelis). Konfigurācijas fails veikali iepriekš saglabātu kartēšanas no Excel failā ar ABACUS failu. Kad noteikts, saglabātais konfigurācijas fails vēlāk tiek izmantots tālākai importēšanu un eksportēšanu uz xls failus.

Piezīme

Pasākumus redzamie turpmākajās iedaļās ir speciāli tiem lietotājiem, kuri vēl varētu noteikt un saglabāt konfigurācijas failu un importēt no Excel pirmo reizi. Jums ir izveidot un saglabāt konfigurācijas failu izmantot eksportēt uz Excel funkciju.

Importēt Excel izklājlapu ABACUS

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Izvēlieties File | Jauns un izvēlieties no Izceltiesno dialoga logā un noklikšķiniet uz Labi.

Piezīme

Ja vēlaties ievest esošā ABACUS projekta tad nu ar peles labo pogu komponentiem mezglu ietvaros Arhitektūra, vai peles labo pogu noklikšķiniet individuālu komponentu robežās Arhitektūra un pēc tam atlasiet Importēt | No Excel.

3. Import Excel izklājlapalogs tiks parādīts

Import Excel izklājlapa Window

4. Noklikšķiniet uz Atvērt Excel failuikona un pārlūkot Excel failā vēlaties importēt.

5. Izvēlieties Darba lapaJūs vēlaties importēt no nolaižamā.

Piezīme

Pēc atvēršanas jūsu Excel failu, jūs varat izmantot Data Previewtab lai apskatītu kolonnas un pirmos 25 rindas savas izklājlapas. No šejienes jūs varat saņemt, kas vajadzīgi, lai aizpildītu kolonnas numuri Sastāvdaļasun Savienojumitab.

Varat arī izvēlēties, vai jūs vēlaties komponenti Excel izklājlapu, kas importēti ar tiesu jutību. Vienkārši atzīmējiet Imports ar tiesu jutībuvariants (pēc noklusējuma tas ir vienmēr atķeksēts) un izklājlapu tiks importēts atbilstoši.

Paraugs Excel failu

Piezīme

Šajā piemērā mēs importējam vienkāršu infrastruktūru un cilvēki Arhitektūra no Excel datiem, kas norādīti iepriekš screenshot. Savienojumi tiks veikti starp "Cilvēki atbildīgi" un "serveri", ka šie cilvēki pārvalda.

Aizpildīt cilni komponenti

Šī sadaļa ir, lai noteiktu komponentu veidus un hierarhisko struktūru konfigurācijas failā.

1. Izvēlieties Sastāvdaļastab. Pārdēvēt Set IDar ignorējot (null)vērtība

Piezīme

Šī funkcija ļauj noteikt pilnīgi atšķirīgs Setspar funkcionāli atsevišķas sastāvdaļas. Kā redzams attēlā zemāk, jūs varat atšķirt savas infrastruktūras sastāvdaļām no jūsu cilvēki sastāvdaļām. Ja ir attiecības (savienojumi) starp šīm atsevišķajām kopām sastāvdaļām, tos var definēt saskaņā ar Savienojumitab. Vēlāk šajā piemērā mēs noteiksim savienojumus no veida "administrē" starp Infrastruktūra un cilvēki Sets.

Varat arī izvēlēties, vai jūs vēlaties pievienot augstākā līmeņa Grupēšanakomponents visiem elementiem komplekta. Vienkārši atzīmējiet Grupas Saskaņā Set IDvariants (pēc noklusējuma tas ir unticked) un izklājlapu tiks importēts atbilstoši.

Piešķirot Set ID

2. Kad Setsir noteikti izvēlētos Uzliktjūs vēlaties aizpildīt un paplašināt, noklikšķinot uz [+]paraksta.

3. Atlasīt Līmeņi komponenti šajā SetNo paplašinātā saraksta.

4. Komponents Hierarhija nosaka: Set IDlogs parādīsies, ka Uzlikt.

Komponentu hierarhija un Piešķirot vērtību (Set ID: Infrastructure)

5. Pārdēvēt Level skaitskolonna ar ignorējot (null)vērtība.

Piezīme

Level skaitskolonna ļauj piešķirt hierarhiju jūsu sastāvdaļām. Katrs līmenis atbilst slāni laikā savu arhitektūru, saskaņā ar kuru vispirms līmenis ir top visvairāk vecākslīmenis. Piemēram, Level numurs "1" atbilst augšējais hierarhijas slāni, Level skaits "2" ir bērns līmeņa skaitli "1", un tā tālāk.

6. Izvēlieties un piešķirt attiecīgo kolonnu no Excel izklājlapas uz katru Level skaitsievadot to zem Komponents slejakolonna.

Piezīme

Jūs varat izvēlēties izslēgt atsevišķas rindas, ka jūs nevēlaties, lai tās pārstāvētu savu arhitektūru. Tie var būt kolonnu galvenes, tukšas rindas, uc Lai izslēgtu rindas izmantotu Rindas uz Izslēgt:tekstlodziņš pie augšējā labajā stūrī loga. Šajā piemērā mēs esam izslēgti 1 rindu, jo tā satur mūsu kolonnu galvenes.

7. Jūs varat izvēlēties pievienot aprakstus, lai jūsu sastāvdaļām ar pārrakstot (null)vērtība In Apraksts sleja.

Piezīme

Šis apraksts ir tas, kas parādīsies ABACUS saskaņā ar Vispārējie Propertiesiedaļa | Aprakstslauks.

8. Ja konkrētā izklājlapu kolonna ir vairāk nekā viens komponents vienu šūnu (stājās izmantojot Alt-Enter vai CHAR (10) komanda), tad atzīmējiet rūtiņu zem Ārstēt Jaunās līnijas par atsevišķām sastāvdaļām. Katra līnija tiks importēts par atsevišķām sastāvdaļām.

Gals

Importēt "matricu" kolekcijā kolonnu, kur "X" attiecīgajā "matricas" šūnas (šūnas B2: D2 teikt) nozīmē, ka elements ar rindu norādīts (šūnā A2 teikt) ir savienota ar komponentu norāda ailē "virsraksta" (jo rinda 1 teikt), vienkāršu formulu var izmantot. Ievadiet šādu formulu katras rindas kolonnā aiz matricas šūnu (F aile teikt); = IF (B2 = "", "", B $ 1 & CHAR (10)) un IF (C2 = "", "", C $ 1 & CHAR (10)) un IF (D2 = "", "", D $ 1 & CHAR (10)). Tad izveidot savienojumu kopu, kā aprakstīts tālāk starp sastāvdaļām ar rindu noteiktajā (kolonnā teikt), un tiem, ar šo formulu, kas aprakstīta (F ailē teikt). Noteikti pārbaudiet Ārstēt Jaunās līnijas par atsevišķām sastāvdaļāmiespēja, kad tiek importēti sastāvdaļas no formulas. Lai iegūtu vairāk uzlabotas matricu importu, ieskaitot pozīcijās ar vairākiem slāņiem hierarhijas vai šūnu ar atšķirīgām vērtībām nekā tikai plain "X", lūdzu, sazinieties ar Avolution Support .

9. Aizpildiet pārējo kolonnu, cik nepieciešams.

Piezīme

Jūs varat izvēlēties, lai iegūtu veidu no kolonnu rindas, atzīmējot rūtiņu saskaņā ar Saņemt veida no slejakolonna un ievadot attiecīgajā ailē no Excel izklājlapu, kurus veic no Detaļas tipa vērtība vai slejakolonna. Tas importēt visus komponentus šajā slejā, un izlaist tos noteiktā tipa kolonnā. Alternatīvi, un kā ar ekrānuzņēmums virs un zem, jūs varat izvēlēties izmantot fiksētu / iepriekš noteiktu tipa nosaukumu, ievadot tipa nosaukumu saskaņā ar Detaļas tipa vērtība vai slejakolonna un pārliecinoties rūtiņa ir ANO pārbaudīta.

Komponentu hierarhija un Piešķirot vērtību (Set ID: People)

Piezīme

Šajā piemērā mēs vēlamies, lai būtu mūsu tīklos un cilvēki grupējumiem no Arhitektūras 1. līmenim. 2. līmenī mēs vēlamies ir mūsu serveriem un cilvēkus, kas atbild par šiem serveriem administrēšanu. Sastāvdaļastab ir aizpildīts atbilstoši, kā parādīts divos ekrānšāviņi iepriekš. Pirmajā screenshot iepriekš esam definēti 1. līmeņa (tīkla grupēšanas) un 2. līmenis (servera) sastāvdaļas infrastruktūras Uzlikt. Un screenshot tieši virs mums ir definēti 1. līmeņa (cilvēkus grupēšanas) un 2. līmenis (cilvēki, kas atbild) komponentus par cilvēkiem Uzlikt.

Alternatīvi, lai CilvēkiKomplekts, nevis izmantojot C slejā kā Tautas grupā, mēs varētu būt izmantots Grupas Saskaņā Set IDiespēja uz līmeņa komponentu cilnes augšējā un tad tikko ienāca viena tauta sub-līmenis no D slejā Tas parādīts attēlā zemāk.

Komponentu hierarhija un Piešķirot vērtību, izmantojot Group Saskaņā Set ID opciju (Set ID: People)

10. Kad sastāvdaļas ir identificēti, izvēlieties komponentu līmenī jūs vēlaties aizpildīt īpašības un / vai standartus un paplašināt, noklikšķinot uz [+]paraksta.

11. Atlasīt Sastāvdaļu īpašību šajā līmenīvai Komponentu standarti šajā līmenīno paplašināto sarakstu un aizpildīt attiecīgās ailes, cik nepieciešams.

Aizpildi komponenti

Piezīme

Sastāvdaļu īpašību šajā līmenīļauj definēt īpašības komponentiem pie izvēlētā līmenī. Komponentu standarti šajā līmenīļauj noteikt standartus un to standarta īpašības komponentiem pie izvēlētā līmenī.

12. Atkārtojiet 2 - 11līdz visas sastāvdaļas līmenis ir apdzīvots visiem definēti Sets. Izmanto bultiņas Atpakaļ pie augšējā labajā stūrī loga, lai pārvietotos atpakaļ uz Setskas jums noteikts iepriekš.

Aizpildīt cilni Connections

Šī sadaļa ir, lai noteiktu pieslēguma veidus un hierarhisko struktūru konfigurācijas failā.

1. Izvēlieties Savienojumitab. Par katru komplektu savienojumiem jums ir identificēt komponentu Uzliktka jūs vēlaties būt avots komponenti un komponentu UzliktJūs vēlaties būt galamērķis sastāvdaļas.

2. Zem Avots Component Set IDievadiet Uzliktnosaukums, kas attēlo Uzliktdefinēts agrāk Sastāvdaļastab. Zem Avots sastāvdaļu līmenī skaitsievadiet numuru, kas atbilst komponentu līmenī vēlaties pieslēgties pie avota beigās savienojumu.

3. Tagad izvēlēties, kuru sastāvdaļa grupa būs galapunkta beigās savienojumu. Zem Galamērķis Component Set IDievadiet Uzliktnosaukums, kas attēlo Uzliktdefinēts Sastāvdaļastab. Zem Galamērķis sastāvdaļu līmenī skaitsievadiet numuru, kas atbilst komponentu līmenī, kuru vēlaties savienot galapunkta beigās savienojumu.

Piezīme

Šajā piemērā mēs vēlamies savienot cilvēkus, kas atbild par administrēšanu serveriem uz serveriem, ka viņi pārvalda. Atbildīgās cilvēki tika noteikts Cilvēki Uzliktkā 2. līmeņa sastāvdaļas kamēr serveriem tika noteikts infrastruktūras Uzliktkā 2. līmeņa sastāvdaļas. Savienojumitab ir aizpildīts atbilstoši, kā parādīts attēlā zemāk.

Savienojumi Tab Part 1 of 2

4. Ja jūs ritiniet pa labi, jūs atradīsiet papildus iespējas importēt jūsu savienojumus. Saņemt veida no slejaun Connection Type vērtība vai slejastrādāt tāpat kā par Sastāvdaļastab.

5. Ja Avots Component Set IDun Avots sastāvdaļu līmenī skaitsir tāds pats kā Galamērķis Component Set IDun Galamērķis sastāvdaļu līmenī skaits(piemēram, ja jūs pievienojat tādas pašas atsevišķo veidus, piemēram, padarot savienojumus no serveriem uz citiem serveriem), tad jums ir nepieciešams, lai ir cits kolonnu jūsu izklājlapu, kas satur vārdus šiem serveriem atkārtotiem. Šādā situācijā jūs varētu nodot šo izklājlapu kolonnas Galamērķis Atkārtota ailēkolonna. Ja šajā izklājlapas slejā esat ievadījis vairāk nekā viens saistīts komponents vienā šūnā, tad atzīmējiet rūtiņu zem Ārstēt Jaunās līnijas par atsevišķām sastāvdaļām.

Savienojumi Tab Part 2 no 2

6. Kad savienojumi ir identificēti izvēlieties savienojumu vēlaties aizpildīt īpašības un / vai standartus un paplašināt, noklikšķinot uz [+]paraksta.

7. Atlasīt Properties Šiem savienojumiemvai Standarti Šiem savienojumiemno paplašināto sarakstu un aizpildīt attiecīgās ailes, cik nepieciešams.

Piezīme

Properties Šiem savienojumiemļauj definēt īpašības izvēlētā pieslēguma grupā. Standarti šos savienojumusļauj noteikt standartus un to standarta īpašības izvēlētā pieslēguma grupā.

8. Atkārtojiet 2 - 7kamēr ir definēti visi savienojuma grupām.

9. Kad esat pabeidzis, nosakot savienojuma grupas, noklikšķiniet uz Finišspogu un jūsu struktūra tiks izveidota no importētā Excel failā. Iepriekš minētajā piemērā radīs arhitektūrā parādīts attēlā zemāk.

Piemērs Arhitektūra importēta no Excel

10. Tagad saglabājiet samērot konfigurāciju failā, noklikšķinot uz Save Configurationikona. Jūsu saglabāti konfigurācija var iegūt vēlāk, noklikšķinot uz Atveriet konfigurācijuikona pie augšējā kreisajā stūrī loga.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Aizpildi savu arhitektūru no Access | Aizpildi savu arhitektūru no Visio


Aizpildi savu arhitektūru no Microsoft SharePoint

Navigācija: Populating savu arhitektūru> Populating no Microsoft produktiem>

Aizpildi savu arhitektūru no Microsoft SharePoint

Nosūtīt komentārus par šo tēmu.

Tu vari sinhronizēt Jūsu arhitektūra arMicrosoft SharePoint saraksti. Sinhronizācija ietver vai nu radot jaunas SharePoint saraksti (un viņu kolonnas) no Abacus veidiem, to īpašībām un pielikumus, vai apzināt esošās SharePoint sarakstiem (un viņu kolonnas) līdz Abacus veidiem, to īpašības un pielikumus, tad vai nu nosūtot saturu no ABACUS SharePoint vai SharePoint līdz ABACUS.

Piezīme

SharePoint Sync funkcija paredz, ka Microsoft SharePoint 2010., 2013.vai SharePoint Online vietne ir pieejama, lai izveidotu savienojumu un sinhronizēt ar.Kamēr SharePoint Sync funkcija var izveidot sarakstus (ar kolonnām) uz SharePoint vietni no jebkuras ABACUS projekta Avolution var arī sniegt dažādus SharePoint vietnes veidnes atbalstam standarta ietvaros (piemēram TOGAF, ArchiMate, ITIL uc), tāpēc, lūdzu, sazinieties ar Avolution Support ja jums nepieciešama šīs spējas.

Līdz izveidot jaunu SharePoint sarakstu un karti to uz ABACUS detaļas vai savienojuma tipu

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Atlasīt Tools | SharePoint Sync.

3. Noklikšķiniet uz New kartēšanapoga un SharePoint Mapping dialog kā parādīts zemāk parādīsies.

4. Ievadiet Site URL, lietotājvārdu un paroli SharePoint vietni un noklikšķiniet Savienot.

Piezīme

Derīgu SharePoint "admin" vai "ziedotāja kontā ir nepieciešams, lai sinhronizētu no un uz SharePoint un" lasītāja "kontā tikai ļauj sinhronizēt no SharePoint.

5. Izvēlieties Abacus detaļas vai savienojuma veidu, lai karti no Izvēlieties Type vilkt lejā.

6. Noklikšķiniet uz Pievieno jaunupogu un pēc tam par katru ABACUS detaļas vai savienojuma tipa aspektu vēlaties kartēt atbilstošu SharePoint saraksta laukā izvēlētos objektu kreisajā panelī un pareizajā panelī ievadiet jauno SharePoint saraksta nosaukumu Jaunais saraksts kolonnā (tikai pirmo reizi) , tad SharePoint kolonnas nosaukums kolonnas nosaukuma (vai izmantojiet noklusējuma) un noklikšķiniet Piešķirt katru reizi.

Piezīme

Kā minimums, lai ļautu sinhronizācija EEID, Arhitektūra ABACUS un Vārds aspekti tiks automātiski plānots SharePoint numuru un divu (2) Vienotās teksta rindiņu (aka teksts) kolonnas attiecīgi. Tie nevar būt nav piešķirts. Turklāt tikai daži ABACUS aspektus, pašreiz var nodibināt uz noteiktām SharePoint kolonnas un kolonnu Type pull-down tiks automātiski iestatīts uz nepieciešamo SharePoint kolonnas tipa.Proti;

· Abacus "hierarhija Ceļš uz SharePoint Multiple teksta rindiņām (aka piezīme) kolonnām (Piezīme: SharePoint vienu rindiņu teksta (aka teksts) slejas atbalsta tikai 255 simboli, lai tie nav vēlams),

· Abacus "Pievienotie Components SharePoint Uzmeklēšanas kolonnu (Piezīme: kartēšana jābūt jau uz sarakstu par pievienotajām sastāvdaļām paši),

· Abacus "Teksta un Apraksts īpašības SharePoint vairākas teksta rindiņas (aka piezīme) kolonnas (Piezīme: SharePoint vienu rindiņu teksta (aka teksts) slejas atbalsta tikai 255 simboli, lai tie nav vēlams),

· Abacus "Decimal vai Integer īpašības uz SharePoint skaits kolonnām,

· Abacus "Saraksts īpašības uz SharePoint Choice kolonnām (Piezīme: SharePoint neuzspiež izvēle vērtības tāpēc Uzņēmumu datu tips nav nepieciešams jāizpilda ABACUS),

· Abacus "Datums / Laiks īpašības SharePoint Multiple teksta rindiņām (aka piezīme) kolonnu (Piezīme: SharePoint datums un laiks kolonnas nevar izmantot kā vēl jo SharePoint ir nekonsekventas atbalstu laika joslu / reģionalizācijas iestatījumiem),

· Abacus "Būla īpašības SharePoint jā / nē (aka Būla) kolonnām.

Abacus elementa Associated Standarti nav iespējams samērot ar SharePoint saraksta kolonnas kā vēl.

7. Atlasīt Izveidot kartēšana.

Līdz izveidot jaunu kartēšanu starp darba ABACUS sastāvdaļas vai pieslēguma veidu un esošai SharePoint saraksta

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Atlasīt Tools | SharePoint Sync.

3. Noklikšķiniet uz New kartēšanapoga un SharePoint Mapping dialog kā parādīts zemāk parādīsies.

4. Ievadiet Site URL, lietotājvārdu un paroli SharePoint vietni un noklikšķiniet Savienot.

Piezīme

Derīgu SharePoint "admin" vai "ziedotāja kontā ir nepieciešams, lai sinhronizētu no un uz SharePoint un" lasītāja "kontā tikai ļauj sinhronizēt no SharePoint.

5. Izvēlieties Abacus detaļas vai savienojuma veidu, lai karti no Izvēlieties Type vilkt lejā.

6. Izvēlieties SharePoint vietņu sarakstu, lai karti no Izvēlieties saraksts vilkt lejā.

7. Katram ABACUS detaļas vai savienojuma tipa aspektu vēlaties kartēt savu atbilstošo SharePoint saraksta kolonnā izvēlieties objektu kreisajā panelī un pareizo paneli attiecīgi un noklikšķiniet Piešķirt.

Piezīme

Kā minimums, lai ļautu sinhronizācija EEID, Arhitektūra ABACUS un Vārds aspekti nepieciešams samērot ar SharePoint numuru un pēc tam uz Arhitektūras un nosaukumu, lai vai nu vienu rindiņu teksta (aka tekstā) vai vairākām līnijām teksta (aka piezīmi) kolonnas attiecīgi. Kamēr tas tiek darīts ar samērošanas pogu Izveidot netiks aktivizēta. Turklāt tikai daži ABACUS aspektus, pašreiz var nodibināt uz noteiktām SharePoint kolonnām.Proti;

· ABACUS "Arhitektūra aspekts SharePoint vienu rindiņu teksta (aka tekstā) vai vairākām līnijām teksta (aka piezīme) kolonnām (tas ir nepieciešams satura konkrētu kartēšanu, kā aprakstīts zemāk),

· Abacus "hierarhija Ceļš SharePoint vienu rindiņu teksta (aka tekstā) vai vairākām līnijām teksta (aka piezīme) kolonnām (Piezīme: SharePoint vienu rindiņu teksta (aka teksts) kolonnas atbalstītu tikai 255 chars tāpēc jebkurš papildu rakstzīmes tiks saīsināts, un tādēļ ieteicams, lai pārvērstu tos Multiple teksta rindiņām (aka piezīme) kolonnas SharePoint pirms kartēšanu),

· Abacus "Pievienotie Components SharePoint Uzmeklēšanas kolonnu (Piezīme: kartēšana jābūt jau uz sarakstu par pievienotajām sastāvdaļām paši),

· Abacus "Teksta un Apraksts īpašības SharePoint vienu rindiņu teksta (aka tekstā) vai vairākām līnijām teksta (aka piezīme) kolonnām (Piezīme: SharePoint vienu rindiņu teksta (aka teksts) kolonnas atbalstītu tikai 255 chars tāpēc jebkurš papildu rakstzīmes tiks saīsināts un tāpēc ir ieteicams, lai pārvērstu tos Multiple teksta rindiņām (aka piezīme) kolonnas SharePoint pirms kartēšanu),

· Abacus "Decimal vai Integer īpašības uz SharePoint skaits kolonnām (Piezīme:. SharePoint Aprēķina kolonnas var izmantot, taču tie būs tikai iespēja sinhronizēti no SharePoint ABACUS Mēģina sinhronizēt" uz "aprēķināto kolonnu radīs brīdinājums kā vienu zemāk) ,

· Abacus "Saraksts īpašības uz SharePoint Choice kolonnām,

· Abacus "Datums / Laiks īpašības SharePoint Multiple teksta rindiņām (aka piezīme) kolonnu (Piezīme: SharePoint datums un laiks kolonnas nevar izmantot, jo SharePoint ir nekonsekventas atbalstu laika joslu / reģionalizācijas iestatījumiem),

· Abacus "Būla īpašības SharePoint jā / nē (aka Būla) kolonnām.

Abacus elementa Associated Standarti nav iespējams samērot ar SharePoint saraksta kolonnas kā vēl. Un SharePoint valūta, personas vai personu grupas, Hyperlink vai Attēls, Task Iznākums, External Data un pārvalda metadatu kolonnas nevar samērot ar Abacus aspektiem kā vēl.

8. Atlasīt Izveidot kartēšana.

Līdz sinhronizētJūsu Microsoft SharePoint sarakstu (s)uz ABACUS

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Atlasīt Tools | SharePoint Sync.

Piezīme

Līdz sinhronizēt SharePoint sarakstu arABACUS projekts lietotājam licence būtu jānoskaidro SharePoint Syncadd-on spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

3. Izvēlieties esošu SharePoint kartēšanu (vai attēlojumi, izmantojot Ctrl-clickvai Izvēlēties visupoga) no SharePoint kartējumipaneliskā parādīts parauga attēlā iepriekš. Piezīme: šeit mēs demonstrējam tikai "Goal (vai prasība)" Abacus detaļas tipa kartēšanu uz SharePoint sarakstu sauc par mērķi tiek izvēlēts.

4. Izvēlieties arhitektūra (-us), ko vēlaties sinhronizēt saturu ar kādu no Sync saturu no arhitektūrupanelis kā parādīts parauga attēlā iepriekš. Piezīme: šeit mēs demonstrējam tikai "2015 Faktiskais" arhitektūra tiek sinhronizēti.

5. Izvēlieties Sync No SPpoga.

Piezīme

Ja SharePoint vietnes pilnvaras ir nevis "Viss Saglabātās" par kartēšanu (-as), tad Ieeja dialog SharePoint parādīsies lūdzot Site URL, Lietotājvārds un / vai Parole.Ievadiet tiem. Turklāt sinhronizācija ietver visus citus samērošanai, kas nepieciešami pievienoti components / Meklēt kolonnas. Visus papildu samērošanai, kas tiek automātiski iekļauti, tiks parādīts dialoglodziņā kā vienu zemāk.

6. Par veiksmīgu sinhronizācija parādīsies SharePoint Sync Rezultāti dialog kā redzams zemāk uzskaitītas izmaiņas un visus brīdinājumus. Uzklikšķiniet labi.

Līdz sinhronizēt no ABACUS līdz Jūsu Microsoft SharePoint sarakstu (s)

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Atlasīt Tools | SharePoint Sync.

Piezīme

Līdz sinhronizēt SharePoint sarakstu arABACUS projekts lietotājam licence būtu jānoskaidro SharePoint Syncadd-on spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

3. Izvēlieties esošu SharePoint kartēšanu (vai attēlojumi, izmantojot Ctrl-clickvai Izvēlēties visupoga) no SharePoint kartējumipaneliskā parādīts parauga attēlā iepriekš. Piezīme: šeit mēs demonstrējam tikai "Goal (vai prasība)" Abacus detaļas tipa kartēšanu uz SharePoint sarakstu sauc par mērķi tiek izvēlēts.

4. Izvēlieties arhitektūra (-us), ko vēlaties sinhronizēt saturu ar kādu no Sync saturu no arhitektūrupanelis kā parādīts parauga attēlā iepriekš. Piezīme: šeit mēs demonstrējam tikai "2015 Faktiskais" arhitektūra tiek sinhronizēti.

5. Izvēlieties Sync Lai SPpoga.

Piezīme

Ja SharePoint vietnes pilnvaras ir nevis "Viss Saglabātās" par kartēšanu (-as), tad Ieeja dialog SharePoint parādīsies lūdzot Site URL, Lietotājvārds un / vai Parole.Ievadiet tiem. Turklāt sinhronizācija ietver visus citus samērošanai, kas nepieciešami pievienoti components / Meklēt kolonnas. Visus papildu samērošanai, kas tiek automātiski iekļauti, tiks parādīts dialoglodziņā kā vienu zemāk.

6. Par veiksmīgu sinhronizācija parādīsies SharePoint Sync Rezultāti dialog kā redzams zemāk uzskaitītas izmaiņas un visus brīdinājumus. Uzklikšķiniet labi.

Piezīme

ABACUS atjauninās SharePoint kolonnas ar tukšu vērtību, pat ja "pieprasīt, lai šī kolonna satur informāciju" uzstādījums ir Jā SharePoint. Tas ir tāpēc, ka SharePoint nav pakļaut šo iestatījumu ārēji. Ja tas ir jānovērš, ir ieteicams, ka ABACUS Designer iestata vajadzīgo spiedienu uz True un jāizpilda, lai konkrētā īpašuma izmantojot Abacus " piespiešana iezīme .

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Aizpildi savu arhitektūru no Visio | Aizpildi savu arhitektūru no Excel


Aizpildi savu arhitektūru no Microsoft SQL Server

Navigācija: Populating savu arhitektūru> Populating no Microsoft produktiem>

Aizpildi savu arhitektūru no Microsoft SQL Server

Nosūtīt komentārus par šo tēmu.

Jūs varat importēt savu arhitektūru no Microsoft SQL Server datu bāzē. Jums ir iespēja vienkārši importēt tabulas un attiecības faktiski importē tikai vispārīgu datubāzes struktūru vai tabulām, rindas un attiecībām, kas ieved ne tikai struktūru, bet datus, kā arī.

Piezīme

From SQL Server iezīme ir noteikts, ka Microsoft SQL Server 20052008, 2008 R2, 2012. vai 2014. gadāir uzstādīts uz datora.

Lai importētu jūsu Microsoft SQL Server datubāzi ABACUS

1. Pārliecinieties, vai ir ABACUS Atvērt.

2. Izvēlieties File | Jauns un izvēlieties No SQL Serverno dialoga logā un noklikšķiniet uz Labi.

3. Jo Import SQL Server Dialoglodziņā, kas parādās, kas ar "MACHINENAME 'un' 'SQLINSTANCE vērtības savienojuma virkni mainīgo un" dbname "vērtību Database Name mainīgo uz to pareizās vērtības, kā parādīts parauga attēlā zemāk.

4. Uzstādīt Database Name mainīgo to pašu vērtību kā sākotnējo Katalogs mainīgais, kas iepriekšējā posmā, kā redzams parauga attēlā zemāk.

5. Nospiediet Test Connection pogu un tabulās Import sadaļa dialogā būtu apdzīvots ar pieejamajiem datu bāzes tabulām, kā redzams parauga attēlā zemāk.

6. Izvēlieties tabulas, kuru vēlaties importēt, vai nu individuāli, izvēloties tos vai izmantojot Visi, neviens un invertcukura pogas pa labi no dialoga.

Piezīme

Tikai ārējā atslēga attiecības, kas pastāv starp tabulām, ka jūs izvēlaties saņemsiet importētas.

7. Izmantojot pogu Import Style izvēlēties, vai jūs vēlaties importēt tikai tabulas un attiecības starp tām vai tabulās, to rindās un īpašās attiecības starp rindām.

Piezīme

Pirmais variants importē tabulās kā sastāvdaļu tipa "tabulu" un attiecības starp jebkuriem diviem tabulā (no ārvalstu atslēgas) ieved kā savienojumiem tipa "Tabula Relation". Šis ir klasisks "ERD" stils skats no sistēmas tabulās. Otrais variants importē tabulas rindas, jo šāda tipa "Row tabula" ar īpašībām, kas attiecas uz katru no kolonnām / laukiem diskrētiem apakškomponentos un ar attiecībām starp tabulā rindas tipa "Tabula Relation". Turklāt, ja ir kolonna / lauks sauc "Nosaukums", tad tas tiek izmantots, lai nosaukt atsevišķus tabulas rindas apakšgrupas komponentus.

8. Izvēlieties Importēt ... pogu.

9. Pēc neilga laika (ar progresa bāru atsauksmes) jauna ABACUS projekts tiks izveidots ar tabulās, tabulas rindas (ja otrais variants tika izvēlēts iepriekšējā solī) un attiecības no Microsoft SQL Server datu bāzē.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Aizpildi savu arhitektūru manuāli | Aizpildi savu arhitektūru no Visio | Aizpildi savu arhitektūru no Excel


Pievienojot preset rekvizītus uz sastāvdaļu, savienojumu vai tipa

Navigācija: Populating savu arhitektūru> Properties>

Pievienojot preset rekvizītus uz sastāvdaļu, savienojumu vai tipa

Nosūtīt komentārus par šo tēmu.

Standarta bibliotēkas īpašības var noteikt un piešķirt kaut kas cits šajā arhitektūrā. Šīs bibliotēkas ir pazīstami kā Standarti. Izmantojot Standarti, Jums tikai nepieciešams apkopot konkrētus sistēmas īpašības - standarta īpašības ir jau tur.

Piemēram standarta darbības raksturojums Microsoft Windows 2000 var saglabāt kāStandartsun piešķirts jebkādiem komponentiem (vai savienojumiem, nevis, ka tas būtu tipisks) izmantojot Microsoft Windows 2000 operētājsistēmu.

Lai pievienotustandartsuz sastāvdaļu, savienojumu vai tipa

1. Labo klikšķiuz sastāvdaļas / savienojumu / veidu.

2. Atlasīt Piešķirt Standarts.

3. AtlasītStandartsno saraksta.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Mainot rekvizītus sastāvdaļu, savienojumu vai tipa | Kopējie īpašības


Mainot rekvizītus sastāvdaļu, savienojumu vai tipa

Navigācija: Populating savu arhitektūru> Properties>

Mainot rekvizītus sastāvdaļu, savienojumu vai tipa

Nosūtīt komentārus par šo tēmu.

Properties parasti sistēmas prasības, kas jums nosaka, vai no Abacus "novērtējumu rezultātus. (Kad ABACUS pilda savus novērtējumus, tā raksta īpašības atpakaļ failā.) Citiem vārdiem sakot, īpašības ir lietas, kas jums jāzina par jūsu sistēmā, vai lietas, ko jūs izmantojat Abacus, lai uzzinātu.

Lai mainītu īpašuma vērtību sastāvdaļu, savienojumu vai tipa

1. Uzklikšķinietuz sastāvdaļas / savienojuma / tipu (tā īpašības parādīs Properties logā pa labi).

2. Uzklikšķinietizcelt īpašumu, kuru vēlaties mainīt.

3. Typejaunu vērtību.

Svarīgs

Arī daudzas īpašības nosaka, izmantojot Standarti . Mainot īpašumu citāStandarts, Jūs ne tikai mainīt pašreizējo objektu, jūs arī mainīt kapteinis Standarts (zem Standartitop no koka). Pirms tam, pārbaudīt, kādi citas sastāvdaļas, savienojumi vai veidi izmantojat Standarts, Jo izmaiņas var nebūt saistīti ar tiem- Jūs varat izmantot Atsauces logu šis.

Gals

Jūs varat mainīt savienojumu īpašības, no iekšienes komponenti filiāles koku (un otrādi). Tā, piemēram, ja jūs meklējat pie ko savienojumi ir pievienoti sastāvdaļa, un tu saproti, jums ir mainīt vienu, jūs varat.

Lai pievienotu jaunas īpašības, lai sastāvdaļas vai savienojumu (izmantojot tipa)

Piezīme

Īpašības var pievienot tikai veidiem un detaļām vai savienojumiem veida "mantot" šos īpašumus.

1. Uzklikšķinietno veida (tā īpašības parādīs Properties logā pa labi).

2. Uzklikšķinietuz pogas Pievienot augšdaļā Īpašuma logu, lai pievienotu rindu augšpusē īpašuma tīklam jauno īpašumu.

3. Pievienot Typepar jaunu īpašumu.

4. Pievienot Nosaukumspar jaunu īpašumu.

5. Pievienot Noklusējuma vērtībapar jaunu īpašumu.

6. Pievienot Vienībapar jaunu īpašumu.

7. Uzstādīt Datu tipspar jaunu īpašumu.

Piezīme

Datu tips lauku var izmantot, lai ierobežotu derīgās vērtības, ka īpašums var būt. Tas ir; Teksts, Integer, Decimal, Date / Time, Boolean vai saraksts.

o A Tekstaīpašums ir viens, kas ir neierobežotu skaitu rakstzīmju, un būtībā nav ierobežojumu attiecībā uz vērtību.Ja īpašuma vērtība ir pareizi noformēts hipersaites (ti, URL jāsāk ar vienu no 5stīgas; http: //, https: //, ftp: //,failu:vai \\ un jebkuršatstarpes jānorāda ar "% 20 '), Tad saite ir klikšķināmos (via Ctrl + klikšķi).

o Vesels skaitlisiestādē jābūt veselu virkni pozitīva vai negatīvaun var ietvert periods, telpu, apostrofu vai komatu par ciparu grupu atkarībā no projekta Reģiona iestatījumi no Failu | Projekta opcijas.Reģionam uzstādījumi un.Neto Long.TryParse metode ir izmanto, lai noteiktu derīgs Vesels skaitlisvērtības.

o A Decimalīpašums var saturēt periods vai komats par decimāldaļu simbolu, un var būt uz laiku, telpu, apostrofu vai komatu par ciparu grupu atkarībā no projekta Reģiona iestatījumi no Failu | Projekta opcijas.Reģionam uzstādījumi un.Neto Decimal.TryParse metode ir izmanto, lai noteiktu derīgs Decimal vērtības.

o A Datums Laiksiestādē atļauts vai nu datums daļu vai Time daļu vai abus. Reģionsiestatījumiun Net DateTime.TryParse metode galvenokārt izmanto, lai noteiktu derīgu datumu un / vai laika vērtības. Tomēr datums daļa ja piemērojams prasa vismaz dienu un mēnesi (gads tiks pieņemts, ka pašreizējais gads) vai mēnesis un gads daļas par spēkā esošu. T Jūnijā, Q3 2010 vai pat tikai 2010. gadā spēkā neesošu. Lai gan tas atšķiras ar dažādiem reģionālajiem iestatījumiem, parasti dienu, mēnesi un gadu daļas var atdalīt ar atstarpi, komats, domuzīme ("-") vai slīpsvītra ("/"). Day daļa parasti ir vesels skaitlis no 1 līdz 31. mēnesī daļa ir parasti vesels skaitlis no 1 līdz 12, derīgu 3 burtu saīsinājums par mēnešiem (piemēram, Jan, Feb, Mar) vai Pilns mēneša nosaukums (piemēram, janvārī, februārī marts). Gads daļa parasti ir 4 ciparu pozitīvs skaitlis, bet 1, 2 un 3 ciparu gadiem tiek pieņemti saskaņā ar iestatījumiem Control Panel> Reģionālās un valodu Options-> Reģionālās Options-> Pielāgot (poga) -> Date-> Kalendārs. Parasti tie tiek interpretēti šādi; 0-29 tiek interpretēts kā 2000-2029, 30 līdz 99, jo 1930-1999 un 100-999 kā 100-999. Nederīgas datumi, piemēram, 31/9/2010 2010. gada jūnija 31. un tiks atklāta. Laika daļa, ja piemērojams prasa stundas un minūtes daļu un pēc izvēles sekundes daļu. Stundas, minūtes un sekundes izvēles daļas parasti atdala ar kolu (":") un Seconds daļa var norādīt ar komatu ('.'). Sīkāku informāciju par spēkā esošajiem formātiem skatiet piezīmju sadaļā par Net DateTime.TryParse metode .

Gals

Ir ieteicams lietot vismaz 3 burtu mēnesis nosaukums formātā (ti, "jūlijs" vai "jūlijs") par datumu vērtībām, nevis skaitliskā formatējumu (ti, "7" vai "07"), jo šīs vērtības visā vairumā reģionu apstiprinās atkarībā par projekta Reģiona iestatījumi no Failu | Projekta opcijas.T ieteicams izmantot "15 Jul 2010", nevis "15/7/2010" vai "7/15/2010". Ar šo piemēru, "15/7/2010" varētu neizdoties apstiprināšanu par "angļu (ASV)" un "2010/07/15" varētu neizdoties "English (United Kingdom)", tomēr "15 Jūl 2010" būs caurlaide abi.

o A Bulaīpašums var būt patiess vai nepatiess.Tas ir gadījums, nejutīga tik patiess vai nepatiess, var arī tikt izmantoti tomēr Jā, nē, 1, 0 utt visi neizdoties nekādus īpašuma ierobežojumus.

o A Sarakstsiestādē atļauts kolekcija iepriekš noteiktām vērtībām, piemēram, zema | Vidēja | Augsts vai paturēt | Atsvaidzināt | Redizains | Pensijā un vērtību diapazons nāk no laukā Vienība par īpašumu, vai nu kā komatu vai caurulē "|" atdalītas vērtības. Īpašumu var uzskatīt par kārtas (pretstatā nominālo, intervāla vai attiecība), jo, ja to izmanto par kartēm un izkrāsot elementus, uz diagrammas un 3DS vērtības izturas vienkārši augošā (vai dilstošā secībā). Tas ir vērtības atzīmē augošā (vai noņemšana) rīkojumu par topu virzienu vai krāsu diapazonu.

8. Datu Type var iestatīt, lai būtu Invalīdu, Brīdinājavai Piespieduar peles labo pogu noklikšķinot uz datu tips apstākļus jebkurā vidē, kas nav teksts, kas ļauj jebkuram rakstzīmes tāpēc nevar nekad būt nepareizs.

9. Uzstādīt Nepieciešamaiskarogs jaunajam īpašumu.

Piezīme

Nepieciešamais lauks var izmantot, lai norādītu, vai vērtība jāievada par īpašumu. Tas ir tas, ka tā nevar būt tukšs vai tukšas. Nepatiessir noklusējuma un nozīmē īpašums var būt tukšas vai tukša, Patiessnozīmē, ka īpašums būtu vērtība un nevar būt tukša vai tukšs. Nepieciešamais var iestatīt, lai būtu Invalīdu, Brīdinājavai Piespieduar peles labo pogu noklikšķinot uz vajadzīgo laukumu, ja tas ir iestatīts uz True.

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Pievienojot preset rekvizītus uz sastāvdaļu, savienojumu vai tipa | Kopējie īpašības


Mainot projekts, ir reģiona iestatījumi

Navigācija: Populating savu arhitektūru> Properties>

Mainot projekts, ir reģiona iestatījumi

Nosūtīt komentārus par šo tēmu.

Īpašuma vērtības nepieciešama zināma formatējums dažādos reģionos, lai atbilstu jebkuru Datu tips ierobežojumi skaitlim, Decimal un datuma / laika īpašības. Piemēram, Austrālijā decimāldaļu "123456 punkts septiņi astoņi deviņi" tiek attēlots kā "123,456.789", bet Vācijā tas būtu represnted kā "123.456,789" un Francijā tas būtu " 123 456789 ".Tāpat ASV "otrais 1970. gada decembra" ir pārstāvēta kā īsu dienā, "12/2/1970", bet Apvienotajā Karalistē tas tiek attēlots kā "2/12/1970" un Polijā, kā "1970-1912 -02 ". Attiecīgi, lai strādātu ar ABACUS projektu dažādos reģionos ir nepieciešama globāla uzstādījums par ABACUS projektam.

Mainīt Abacus projekta reģions iestatījumi

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Atlasīt Failu | Projekta Options ... un no dialoglodziņā parādās izvēlieties Apgabalsun noklikšķiniet uz Labi. Piezīme: Lūdzu, skatiet sadaļā zemāk par reģionālo nepildīšanu.

Piezīme

Ja jūs neredzat Projekta Options ... izvēlnes vienumstad jums nav Designer un Administrator add-onsun Jūs nevarat mainīt projekta reģionu.Arī tad, ja neviens reģions ir iestatīts (ti, projekta Iespējas reģionā ir "Nav (System reģions)"), tad katrs lietotāja MS Windows pašreizējais kultūras iestatījumus (ti Regional Settings)tiek izmantoti, lai apstiprinātu īpašības.

Reģions noklusējumus

Nākamajā tabulā ir uzskaitīti noklusējumus katrā reģionā, kā noteikts, izmantojot Failu | Projekta Options ...izvēlnes vienums.Lūdzu, skatīt zemāk tabulā par sarakstu izmantoto simbolu.

Apgabals | Decimal Symbol | Cipars grupējums | Negatīvs signāls | Short Time | Ilgu laiku | AM / PM simbols | Short Date | Long Date
Angļu (Austrālija) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / gggg | dd MMMM gggg
English (United Kingdom) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / gggg | dd MMMM gggg
English (United States) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / gggg | DDDD, MMMM dd, gggg
Franču (Francija) | , | telpa | - | HH: mm | HH: mm: ss | | | dd / mm / gggg | DDDD d MMMM gggg
Vācu (Vācija) | , | . | - | HH: mm | HH: mm: ss | | | dd.mm.gggg | DDDD, d. MMMM gggg
Itāļu (Itālija) | , | . | - | HH: mm | HH: mm: ss | | | dd / mm / gggg | DDDD d MMMM gggg
Spāņu (Spānija) | , | . | - | H: mm | H: mm: ss | | | dd / mm / gggg | DDDD, dd 'de' mmmm 'de' gggg
Angļu (Kanāda) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / mm / gggg | MMMM-dd-gggg
Franču (Kanāda) | , | telpa | - | HH: mm | HH: mm: ss | | | gggg-MM-dd | d MMMM gggg
Arābu (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / gggg | dd MMMM, gggg
Arābu (Saūda Arābija) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / gg | dd / MMMM / gggg
Angļu (Dienvidāfrika) | , | telpa | - | hh: mm tt | hh: mm: ss tt | AM | PM | / MM dd gggg / | dd MMMM gggg
Angļu (Jaunzēlande) | . | , | - | h: mm tt | h: mm: ss tt | no rīta | p.m. | d / mm / gggg | DDDD, d MMMM gggg
Angļu (Indija) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd-MM-gggg | dd MMMM gggg
Vācu (Šveice) | . | ' | - | HH: mm | HH: mm: ss | | | dd.mm.gggg | DDDD, d. MMMM gggg
Franču (Beļģija) | , | . | - | HH: mm | HH: mm: ss | | | d / mm / gggg | DDDD d MMMM gggg
Holandiešu (Beļģija) | , | . | - | H: mm | H: mm: ss | | | d / mm / gggg | DDDD d MMMM gggg
Čehija (Čehija) | , | telpa | - | H: mm | H: mm: ss | DOP |. ONP. | d.M.yyyy | d. MMMM gggg
Dāņu (Dānija) | , | . | - | HH: mm | HH: mm: ss | | | dd-MM-gggg | d. MMMM gggg
Grieķu (Grieķija) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / gggg | DDDD, d MMMM gggg
Somu (Somija) | , | telpa | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'gggg
Ungāru (Ungārija) | , | telpa | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | gggg. MMMM d.
Holandiešu (Nīderlande) | , | . | - | H: mm | H: mm: ss | | | d-M-gggg | DDDD d MMMM gggg
Norvēģu, bukmols (Norvēģija) | , | telpa | - | HH: mm | HH: mm: ss | | | dd.mm.gggg | d. MMMM gggg
Poļu (Polija) | , | telpa | - | HH: mm | HH: mm: ss | | | gggg-MM-dd | d MMMM gggg
Krievu (Krievija) | , | telpa | - | H: mm | H: mm: ss | | | dd.mm.gggg | d MMMM gggg 'г. "
Zviedru (Zviedrija) | , | telpa | - | HH: mm | HH: mm: ss | | | gggg-MM-dd | "den" d MMMM gggg
Korean (Koreja) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | gggg-MM-dd | gggg '년' M '월' d '일' DDDD
Ebreju (Izraēla) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / gggg | DDDD dd MMMM gggg

Šādi simboli tiek izmantoti, lai norādītu, kā tiek parādīti datumi un laiki:

Laika simboli |
h | Stunda (hh parāda stundu ar nulli)
m | Minute (mm parāda minūti ar nulli)
s | Otrais (ss parāda otro ar nulli)
tt | Rītā vai atgādinājums
h / H | 12 vai 24 stundu laika displejs
Datums simboli |
d, dd | Day
DDD, DDDD | Nedēļas diena
M | Mēnesis
y | Gads

Skatīt arī

Aizpildi savu arhitektūru - pārskats | Mainot rekvizītus sastāvdaļu, savienojumu vai tipa | Pievienojot preset rekvizītus uz sastāvdaļu, savienojumu vai tipa


Kopējie īpašības

Navigācija: Populating savu arhitektūru> Properties>

Kopējie īpašības

Nosūtīt komentārus par šo tēmu.

Operācija "Agregātu Properties"Ļauj jums pievienot vērtības līdzīgiem īpašumiem kopā un rakstīt (vai pievienot) rezultātu izvēlētajā mātes elementa īpašības. Tas arī ļauj definēt apkopošanas un vai atjaunināt īpašības visu pakārtoto elementu vai ne.

Apkopot īpašībām

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Ar peles labo pogu noklikšķiniet uz elementa (arhitektūra, komponentu vai savienojumu), kurā, lai veiktu summēšanu un izvēlieties Kopējie Properties.

3. Izvēlieties vienu no kopējās Options (Traverse All apakšlīmeņiemvai Tikai Direct Sub-Level). Ja esat izvēlējies Traverse All apakšlīmeņiemJūs varat arī izvēlēties iespēju, vai Update Sub-Levels.

o Traverse All apakšlīmeņiemnozīmē, ka darbības joma apkopojuma ietvers elementus visos līmeņos zem jūsu izvēlēto elementu.

o Update Sub-Levelsvar izdarīt tikai tad, ja esat arī izvēlējušās Traverse All apakšlīmeņiem. Tas nozīmē, ka, kamēr jūs apkopot īpašības no apakšas uz augšu, kopējais rezultāts katrā līmenī tiks atjaunināts katrā no attiecīgajiem elementiem.

o Tikai Direct Sub-Levelnozīmē, ka tikai īpašības elementiem tieši zem izvēlētā elementa tiks summēti.

o Atlasīt Ietvert StandartsPropertiesja jūs vēlaties īpašības vienības, kas noteiktas standarti jāiekļauj. Pretējā gadījumā tikai īpašības unikāls katram detaļas, piemēram, tiks izmantota.

4. Izvēlēties, kuru īpašības vēlaties apkopot. Tās ir sagrupētas viņu Veidi.

5. Noklikšķiniet uz Nākamaispoga.

6. Izvēlieties opciju, vai Pārrakstīt Vērtībasvai Pievienot vērtībasuz izvēlēto elementu.

o Pārrakstīt Vērtībasrakstīt rezultātus tieši īpašībām izvēlētā elementa.

o Pievienot vērtībaspievienos rezultātus ar esošajām īpašībām izvēlētā elementa.

Skatīt arī

Pievienojot preset rekvizītus uz sastāvdaļu, savienojumu vai tipa | Mainot rekvizītus sastāvdaļu, savienojumu vai tipa | Izvērtējot savu arhitektūru


Analizējot savu arhitektūru

Navigācija: Analizējot savu arhitektūru>

Analizējot savu arhitektūru

Nosūtīt komentārus par šo tēmu.

Kad esat apdzīvotas (un pēc izvēles imitētas) savu arhitektūru, jūs esat gatavs izmantot Abacus analizēt to. Analizējot to, jūs varat noteikt, vai jūsu arhitektūra atbilst jūsu vajadzībām.

Jūs varat analizēt savu arhitektūru dažādos veidos:

· Diagramma

· 3D skats

· standarta grafiki (pie, rinda, kolonna, bārs, uc)

· pasūtījuma grafiki ( reakcijas laiks , spējas telpa , star gabals , scatterplot matrica un burbulis diagramma )

· Arhitektūra Diff

Piezīme

Veidojot diagrammu, 3D skats, Ziņojums vai standarta diagramma, tad standarta elements izvēles logs tiek izmantots, lai izvēlētos elementus, kurus vēlaties apskatīt.

Skatīt arī

Aizpildi savu arhitektūru | Imitē savu arhitektūru | Shēmu Instruments


Standard Element atlase

Navigācija: Analizējot savu arhitektūru>

Standard Element atlase

Nosūtīt komentārus par šo tēmu.

Veidojot diagrammu, 3D skats, Ziņojums,standarts diagrammavai darbojas simulāciju, Standarta elements izvēles logs tiek izmantots, lai izvēlētos elementus, jūs vēlaties, lai analizētu / viedokli.

Standard Element izvēles logs

Pulldowns

· Atlasīt pēc Viewgriba ietvert elementss no iepriekš saglabāto nolūkā (ti, diagramma, Chart, 3D). Tādā veidā jūs varat veikt komplekss "pievienoties", vaicājumus, apstrādājot citu viedokli par ietaupīto "vaicājumu".

Rūtiņas

· Rādīt līmeņigriba grupa elements atkarībā no līmenī, kuru tie kokā. 1 līmenis ir top visvairāk līmenī.

· Rādīt veidigriba grupa elementi atkarībā no veidiem, kas viņi ir.

· Vecāki izvēlētsietvers mātes elementus tādiem atsevišķajiem elementiem. Tādā veidā jūs varat nodrošināt, ka tikai hierarhija iepriekš jebkādu bērniem tiks iekļauti par "bottom-up" atlasē.

· Bērni izvēlētsietvers bērniem elementus jebkuru izvēlēto elementu. Tādā veidā jūs varat nodrošināt, ka tiks iekļauti zem jebkuriem vecākiem tikai hierarhija par "top-down" atlasē.

· Vārds Sērkociņi vērtībaietvers tikai tos elementus, kas ir nosaukums, kurā norādīto virkni (Lūdzu, ņemiet vērā: aizstājējzīmes (ti un *) var izmantot?). Tādā veidā jūs varat veidot "semantisko" vaicājumu.

· Vai Īpašuma tips / Nosaukums / Valueietvers tikai tos elementus, kas ir īpašums veidu, nosaukumu un vērtību, kas satur norādīto virkni vai nu tieši uz elementu vai tās standartiem (Lūdzu, ņemiet vērā:?.? aizstājējzīmes (IE un *), var izmantot, piemēram, * Vērtību lauks sniegt visus elementus, kas ir, kas nav tukša vērtība attiecībā uz konkrēto īpašumu). Tādā veidā jūs varat veidot "semantisko" vaicājumu.

· Ir standartaietvers tikai tos elementus, kas ir standarts nosaukums, kurā norādīto virkni (Lūdzu, ņemiet vērā: aizstājējzīmes (IE un *), var izmantot, piemēram, HP * sniegs visus elementus ar vismaz vienu Standard sākas ar burtiem H un P?.). Tādā veidā jūs varat veidot "semantisko" vaicājumu.

· Komponenti / Savienojumi pievienota izvēlētaietvers jebkurus pievienotos elementus tiem, kas ir izvēlēti. Tādā veidā "call-koks" vai "ietekmes analīze" var izvēlēties.

Piezīme

Ja jums ir gan Rādīt līmeņiun Rādīt veidiizvēlēts, tad jūs varat izvēlēties, lai koks rādīt līmeņus pirmo vai veidus vispirms ar pogu, kas parādīsies virs abiem rūtiņas.

Gals

Kad prece ir izvēlēts Standard Element izvēles logs, tas nebūs pakļauti jebkādām turpmākām izmaiņām filtru, līdz tas ir atcelts. Tā kā nav dzimtā veidu, kā meklēt diviem dažādiem komplektiem elementu uzreiz (piemēram Sastāvdaļas ar standarta A vai standarta B), jūs varat meklēt vispirms uz vienu komplektu, izvēlieties vajadzīgo sastāvdaļas, un pēc tam veikt otru meklēt otro kopumu .

Pogas

· Visiatlasa visus elementus.

· Apgāztdeselects visus pašreiz izvēlēto elementu un izvēlas visiem tiem, kas netika izvēlēts.

· Neviensdeselects visus elementus.

· Noņemt filtruizvēlas iegūto saturu filtrs iestatījumus un ļauj atlases papildu saturu, kā efektīvi AND vai pievienoties filtru.

Skatīt arī

Analizējot savu arhitektūru


Apskata 3D diagrammu

Navigācija: Analizējot savu arhitektūru> 3D diagrammas>

Apskata 3D diagrammu

Nosūtīt komentārus par šo tēmu.

ABACUS ļauj apskatīt savu arhitektūru kā 3D skatā, kur sastāvdaļas un savienojuma īpašības ir saistīta ar krāsām, formas un izmēriem.

Lai skatītu 3D skatu savu arhitektūru

1. Pārliecinieties, vai ir atvērt ABACUS failusatur Jūsu apdzīvots arhitektūra.

2. Paplašināt Viewsfiliāle koku.

3. Paplašināt 3Dfiliāle koku.

4. Dubultklikšķi vizualizācijas vēlaties atvērt.

- Vai -

1. Pārliecinieties, vai ir atvērt ABACUS failusatur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| 3Dvai noklikšķiniet uz pogas rīkjoslas.

3. Atvērt esošaisvizualizācija (.abacus3d)

- Vai -

1. Pārliecinieties, vai ir atvērt ABACUS failusatur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| 3Dvai noklikšķiniet uz pogas rīkjoslas.

3. Izveidot jaunu vizualizāciju:

· Izvēlieties Arhitektūravēlaties apskatīt no nolaižamās izvēlnes.

· Izvēlieties Sastāvdaļasun SavienojumiJūs vēlaties iekļaut diagrammā no standarta elements izvēles logs .

· Associate krāsas, formas un izmēri ar Komponentu veidiun Properties.

· Asociētā krāsas un formas ar Savienojuma veidiun Properties.

Eksportēt 3D skats

1. Pārliecinieties, vai ir atvērtu esošu 3D skats.

2. 3D skats ir pull-down izvēlnes izvēlieties Failu | Eksporta ...un izvēlējās vietu un faila tipu vizualizācijas failu (.abacus3d, .vrml vai .html).

3. Uzklikšķiniet Saglabāt.

Skatīt arī

Analizējot savu arhitektūru | Navigation 3D | Diagramming Tool


Navigācija 3D diagramma

Navigācija: Analizējot savu arhitektūru> 3D diagrammas>

Navigācija 3D diagramma

Nosūtīt komentārus par šo tēmu.

ABACUS ļauj viegli pārvietoties pa savu arhitektūras 3D. Pieredze ir līdzīgs peld. Ir divi veidi navigācija:

· Basic Control Mode (Default); un

· Advanced Control Mode - izmaiņas šajā režīmā, izvēloties Kontrole| Advanced Control Mode.

Piezīme

Lai pārslēgtos starp pamata kontroles un Advanced vadības režīmiem, jūs varat izmantot F4tastatūras īsceļu funkcionalitāti.

Pamata Control Mode

· Turot kreiso pogu un pārvietojot peli uz priekšu vai atpakaļ maina piķis;

· Turot kreiso pogu un pārvietojot peli pa kreisi vai pa labi, maina kustības virzienā;

· Turot labo pogu un pārvietojot peli pannas viedokli;

· Turot abas pogas uz leju un pārvietojot peli uz priekšu vai atpakaļ, zooms un ārā no arhitektūras; un

· Turot abas pogas uz leju un pārvietojot peli pa kreisi vai pa labi, ruļļos pa kreisi un pa labi.

- Vai -

· Nospiežot Left Arrowuz klaviatūras vai cipartastatūru būs jānogriežas pa kreisi;

· Nospiežot Right Arrowuz klaviatūras vai cipartastatūru būs jānogriežas pa labi;

· Nospiežot Up Arrowuz klaviatūras vai cipartastatūru tiks tuvinātu;

· Nospiežot Down Arrowuz klaviatūras vai cipartastatūru tālinās;

· Nospiežot Page Upuz klaviatūras vai cipartastatūru tiks Piķis up; un

· Nospiežot Page Downuz klaviatūras vai cipartastatūru būs piķis leju.

Advanced Control Mode

· Movingpele uz priekšu un atpakaļ, un uz augšu un uz leju, maina piķis un virziena (attiecīgi);

· Nospiežot Wvai Up Arrowzooms (uz priekšu), arhitektūrai;

· Nospiežot Svai Down Arrowzooms out (atpakaļ) no arhitektūras;

· Nospiežot Avai Left Arrowruļļos pa kreisi;

· Nospiežot Dvai Right Arrowruļļos pa labi;

· Nospiežot Qvai Page Downpaaugstina viedokli (samazinot perspektīvu); un

· Nospiežot Evai Page Uppazemina viedokli (ar paaugstinātu perspektīvu).

Interaktīvā Control Mode

Nospiežot un turot pārslēdzējsuz klaviatūras ignorēšanas pašreizējo režīmu (Basic vai Advanced), lai ievadītu interaktīvo vadības režīmu. Šajā režīmā šādi ir iespējams:

· Rullispeles kursoru komponentu vai savienojumu, lai redzētu detaļas vai pieslēguma nosaukums;

· Uzklikšķinietuz sastāvdaļu, lai tuvinātu šo komponentu;

· Click-and-draguz sastāvdaļa, lai pagrieztu skatu ap šo komponentu; un

· Labo klikšķisastāvdaļa vai savienojumu un izvēlieties Rādīt Explorerredzēt, ka detaļas vai pieslēguma vietā, koku.

Bieži kontrole

· Lietošana ALT-Enter / ESClai pārslēgtos pilnekrāna režīmā;

· Lietošana F2lai mainītu displeja režīmu. To var arī piekļūst SkatsMenu.

· Izmantojiet peles ritenivai +/-lai mainītu ātrumu. Ātrums ir norādīta ar numuru apakšējā kreisajā stūrī - parādīts tikai tad, kad tā mainās. 1 ir vislēnākais un 100 ir ātrākais.


Apskata standarta diagrammu

Navigācija: Analizējot savu arhitektūru> Standarta grafiki>

Apskata standarta diagrammu

Nosūtīt komentārus par šo tēmu.

Abacus "standarta diagrammas ietver līnija, bārs, kolonnu, platību, izkliedi, pīrāgs, līkni, Pareto, soli, virsma, radaru, kubu, virtulis, piramīda, kontūru un līkne platību diagrammas. Kad esat izvēlējies no diagrammas veidu, ko vēlaties, pārējā procesa apskati katrā no šīm kartēm ir tas pats.

Lai apskatītu standarta diagrammu jūsu arhitektūru

1. Pārliecinieties, vai ir atvērt ABACUS failusatur Jūsu apdzīvots arhitektūra, Un ka jums ir novērtētsJūsu arhitektūra.

2. Atlasīt Ievietot| Diagrammavai noklikšķiniet uz pogas rīkjoslas. Chartslogs tiks parādīts.

Charts logu

3. Izvēlieties diagrammas vēlaties veidu un noteikt diagrammu Opcijas, pēc tam noklikšķiniet uz Nākamais.

Chart Options

o Stackedrādīs attiecības atsevišķu vienību uz visu. Jūs varat izmantot stacked diagrammu, kad jūs plānojat ir vairākas datu sērijas (ti, vairākas īpašības), un, ja jūs vēlaties, lai uzsvērtu visu.

o Stacked 100%salīdzinās procentuālo katra vērtība veicina totālai kategorijās. Jūs varat izmantot 100% stacked diagrammu, ja jūs plānojat ir vairākas datu sērijas (ti, vairākas īpašības), un jūs vēlaties, lai uzsvērtu iemaksas kopumā, it īpaši, ja kopējā summa ir vienāda katram elementam.

o 3D attēlsvienkārši parādīt datu punkti 3-D formātā estētiku. Ja vēlaties, lai parādītu datu sērijas pa 3 / z-ass dimensiju tad izmantojiet Cluster Series iespēju turpmāk aprakstīto.

o Series Propertyparādīs datu rindas par katru īpašumu, kas galu galā izvēlēto. Ja tas ir apkarotas tad īpašības kļūs kategorijas un datu sērija būs katram elementam, kas ir izvēlēts.

o Pagriezt Chartrotēs diagrammu 90 grādiem pulksteņrādītāja virzienā ar savstarpējo apmaiņu ar X un Y asīm. Šī opcija ir pieejama tikai līnijām, soli un Cube diagrammasun ir īpaši noderīgi, lai padarītu Milestone diagrammas, kā aprakstīts otrajā galu zemāk. Piezīme: Column un joslu diagrammas ir jau "rotē" versijas otru.

o Cluster Seriesparādīs vairākas sērijas datus pa 3 / z-ass dimensiju. Šī opcija ir pieejama tikai kolonnas, joslas un Cube diagrammasun ir īpaši noderīgi, lai padarītu Ganta stila diagrammas, kā aprakstīts pirmajā Tip zemāk.

Gals

Jūs varat izveidot Ganta diagrammaar horizontāliem stieņiem rāda laiks / datums īpašības dažādu elementu, atlasot Bar diagrammas tipu un pēc tam izvēloties Cluster Series iespēju.Turklāt, tiklīdz izveidota, kreisās visvairāk bar uz diagrammas var veikt "neredzami", nokrāsojot to baltu ar peles labo pogu noklikšķinot vienu no bāriem, izvēloties Colour no izvēlnes, kas parādās un izvēloties augšējā kreisajā krāsu no paletes. Bez tam robeža kreisās visvairāk joslā var veikt "neredzami", ar peles labo pogu noklikšķinot vienu no bāriem, izvēloties Properties ... un par sērijas cilnes Dialoglodziņā, kas parādās maina robežu ietekmi uz Nav un krāsu uz augšu -left krāsu no paletes.

Gals

Jūs varat izveidot Milestone diagrammaar mazo formas parādot laiks / datums īpašības dažādiem elementiem, ko izvēloties Cube diagrammas tipu un pēc tam izvēloties Pagriezt Chart un Cluster Series iespējas.Turklāt, tiklīdz izveidota, kubi var mainīt uz citām formām ar peles labo pogu noklikšķinot vienu no kubiem konkrētā datu sērijām un izvēloties Properties ... un par sērijas cilnes Dialoglodziņā, kas parādās mainot joslu, lai nu cilindra vai konusa . Piezīme: Gap platums vērtību var arī izmantot, lai "sarauties" simboliem uz diagrammas, lai samazinātu pārklāšanās, jo lielāks skaitlis, jo mazāk pārklājas tur būs.

4. Iekš Arhitektūrassadaļa, atzīmējiet arhitektūra / s vēlaties, lai nospraustu arhitektūra līmeņa rekvizītus, tad noklikšķiniet Nākamais.

Piezīme

Izvēloties arhitektūra līmeņa īpašības ir pilnīgi obligāts solis, un būtu jāizmanto tikai tad, ja jūs vēlaties, lai skaidri nospraustu paši arhitektūra līmeņa īpašības.Arhitektūra nav jāizvēlas, lai tad arī sastāvdaļas vai savienojuma īpašības nākamo soli.

5. Izvēlieties Sastāvdaļasun Savienojumika jūs vēlaties diagrammā no standarta elements izvēles logs , Tad noklikšķiniet Nākamais.

6. Izvēlieties Propertiesvēlaties diagrammā un noklikšķiniet Finišs.

Chart Options

o Ietver standarta īpašībasgriba parādīt mantotos īpašumus no standartiem, kas pieejami izvēlei.

o Kopējie Propertiesgriba skaitīt novirzi starp sērijas vērtībām un nospraustu minētos rezultātus, nevis indivīds vērtības sevi.Šī opcija ir pieejama tikai tad, ja Series ar īpašuma variantu tika izvēlēts iepriekš 3. solī.

Gals

Īpašības pieejamie diagrammu atkarīgs no elementiem jūs izvēlaties.

Lai saglabātu diagrammu

Piezīme

Diagrammas var saglabāt tikai tad, ja tie satur tikai detaļas un savienojumi, kas visi jābūt no vienas arhitektūras pašreizējā projekta ietvaros.

1. Pārliecinieties, ka jums ir jaunu vai esošu diagrammu atvērtsun esat veicis nepieciešamās izmaiņas.

2. Diagrammā rīkjoslā noklikšķiniet uz kreisās malas Saglabāt Chartpogu, lai saglabātu diagrammu un visas formatēšanas izmaiņas.

3. Iekš Chart Namedialog kas parādās ievadiet diagrammas un nospiediet labi.

Lai eksportētu diagrammu

1. Pārliecinieties, vai ir esošs diagrammaatvērts.

2. Jo diagramma rīkjoslā noklikšķiniet uz 2. no kreisās Saglabāt kā BMPpogu un izvēlējās vietu tabulā.

3. Uzklikšķiniet Saglabāt.

Skatīt arī

Analizējot savu arhitektūru | Apskata reakcijas laiks diagrammu | Apskatot spējas kosmosa diagrammu


Apskatot spējas kosmosa diagrammu

Navigācija: Analizējot savu arhitektūru> Custom grafiki>

Apskatot spējas kosmosa diagrammu

Nosūtīt komentārus par šo tēmu.

Spēj Space diagramma ļauj apskatīt, vai jūsu arhitektūra izpilda prasīto sistēmas spējas attiecībā uz īpašumiem sistēma prasību analīzes procesā gaitā.

Lai apskatītu spēju kosmosa diagrammu

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra, Un ka jums ir novērtētsJūsu arhitektūra.

2. Atlasīt Ievietot| Diagramma| Custom Charts| Capability Space. (Uz Spēju Space Chart Configdialog parādīs.)

3. Iekš Arhitektūrassadaļa, atzīmējiet arhitektūras vēlaties diagrammas, un pēc tam noklikšķiniet Nākamais.

4. Iekš Propertieszona, atzīmējiet arhitektūras īpašības jūs vēlētos iekļautas kā asīm diagrammā.

5. Iekš Spējasplatība, par katru iekļauto no iepriekšējā solī īpašumu, izvēlieties, vai par minimālo vai maksimālo spēju robežas pastāv un vērtības šiem ierobežojumiem. Noklusējuma vērtības ir minimālās un maksimālās vērtības, kas novērtēti par arhitektūras vai arī mērķis īpašumu ja tas ir noteikts.

Lai eksportētu spēju kosmosa diagrammu

1. Pārliecinieties, vai ir esošs spējas kosmosa diagrammaatvērts.

2. Diagrammā rīkjoslā noklikšķiniet uz kreisās malas Saglabāt kā BMPpogu un izvēlējās vietu tabulā.

3. Uzklikšķiniet Saglabāt.

Skatīt arī

Analizējot savu arhitektūru | Apskata reakcijas laiks diagrammu


Apskata reakcijas laiks diagrammu

Navigācija: Analizējot savu arhitektūru> Custom grafiki>

Apskata reakcijas laiks diagrammu

Nosūtīt komentārus par šo tēmu.

Reakcijas laiks diagramma ļauj apskatīt, vai jūsu savienojumi tiek apstrādāti vajadzīgajā likmi (ti, to termiņa beigām).

Lai apskatītu reakcijas laiks diagrammu

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra, Un ka jums ir novērtētsJūsu arhitektūra.

2. Atlasīt Ievietot| Diagramma| Custom Charts| Reakcijas laiks. (Uz Reakcijas laiks Chart Configdialog parādīs.)

3. No Arhitektūrasnolaižamo sarakstu, izvēlieties arhitektūru vēlaties diagramma.

4. Iekš Savienojumizona, atzīmējiet savienojumus jūs vēlētos iekļautos grafikā.

5. Mērogs Tipszona, izvēlieties Lineārsja jūs vēlaties, vertikālo asi (reakcijas laiks), kas tiek rādīts kā lineāru progresijā - katru segments laika tiek piešķirti vienādu daļu no ass. Atlasīt Logaritmiskaja jūs vēlaties, tas redzams kā logaritmiskā progresijā - katru segmentu asi veido arvien ilgāku laiku augstāk asi jums iet. (Par palielinājuma likme tiek noteikta ar Bāzeizvēlaties.)

Reakcijas laiks diagramma vertikālā ass skala

Lai eksportētu reakcijas laiks diagrammu

1. Pārliecinieties, vai ir esošs reakcijas laiks diagrammaatvērts.

2. Diagrammā rīkjoslā noklikšķiniet uz kreisās malas Saglabāt kā BMPpogu un izvēlējās vietu tabulā.

3. Uzklikšķiniet Saglabāt.

Skatīt arī

Analizējot savu arhitektūru | Apskatot spējas kosmosa diagrammu


Apskata zvaigzne apzaļumota jūsu attīstījusies arhitektūru

Navigācija: Analizējot savu arhitektūru> Custom grafiki>

Apskata zvaigzne apzaļumota jūsu attīstījusies arhitektūru

Nosūtīt komentārus par šo tēmu.

Kad arhitektūra ir attīstījusies, un mērķi ir definēti, tas pēc tam var vizualizēt, un, salīdzinot ar sākotnējo arhitektūru, izmantojot zvaigžņu gabaliem. Šajā sadaļā izklāstīts, kā izveidot un manipulēt zvaigzne gabals.

Lai apskatītu zvaigzne apzaļumota jūsu attīstījusies arhitektūru

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Pārliecinieties, vai ir attīstījiesun izvirzītos mērķusJūsu arhitektūru, kā norādīts saskaņā Attīstās savu arhitektūru

3. Atlasīt Ievietot| Diagramma| Custom Chartstab | Star Plot.

4. Klikšķiniet uz Finišspoga.

5. Star Plotar izdalījusies arhitektūrām un noteikt mērķus, tiks parādīts. Piezīme: No zvaigžņu gabala asis var pārvietot, noklikšķinot un velkot asis uz citu teritoriju robežās zvaigzne gabals kvalitātes telpu.

Piezīme

Teritorija kreisajā pusē zvaigžņu gabala rāda iestatījumus parādītā zvaigžņu gabala. Tas ietver arhitektūru, kas ir attīstījusies (šajā gadījumā "ABC SIA as-is 2010"), Kā arī mērķus, kas ir noteikti šajā arhitektūru. Jūs ņemiet vērā, ka mērķi, kas ir ķeksīti zīmi blakus tiem pārstāvēja asīm zvaigžņu gabala (piemēram, KPI- Izmaksas, KPI - Kvalitāte un KPI - Laiks). Jūs varat untick šos mērķus jebkurā brīdī, lai novērstu tos no zvaigžņu gabala.

Sarkanie un zaļie "punkti", kas parādās uz jūsu zvaigžņu gabala pārstāv normalizējies vērtību, kā to nosaka labāko un sliktāko vērtības (norādīts ar Nosakot mērķus jūsu attīstījusies arhitektūra ) Izvēlētajā augstākā līmeņa arhitektūras un jebkādas norisēm tajā. Šīs vērtības ir pārstāvētas Kvalitāte Space.

Kā norādīts iepriekš attēlu, tas ir skaidri redzams, ka sākotnējā arhitektūra (As-ir 2010. gada) Ir slikts Izmaksas, Kamēr pirmā attīstījusies variants (To-Be 2011 - Stratēģija) Ir pārvietota kvalitātes telpu, lai uzlabotu Izmaksas, Kvalitāte un laiksmērķus. Alternatīvi, otrais attīstījusies iespēju (To-Be 2011 - Stratēģija B), bet tas ir arī uzlabojusi Izmaksas lielums uzlabošanai, ir mazāks nekā Stratēģija A bet gan kvalitāte un laiks mērķi ir uzlabota vairāk nekā ar stratēģijas A.Šajā gadījumā arhitekts var izvēlēties Stratēģijavairāk Stratēģija Bkā savu ieteikumuun tālāk attīstīties šo iespēju (To-Be 2012 - Stratēģija).

6. Atceltu Rādīt arī izmaiņasrūtiņu, lai paslēptu līniju (-as), kas pārstāv evolūciju (-i) starp oriģinālu (piemēram, As-ir 2010. gada) Un attīstījās (piem To-Be 2011 - StratēģijaA) arhitektūra (-i).

7. Izvēlieties Rādīt Sticksrūtiņu, lai parādītu relatīvo lielumu katru kvalitātes atribūtu (mērķus, kas ir definēti uz katra asīm) katram arhitektūru.

8. Izvēlieties Rādīt Arhitektūra Namesrūtiņu, ja vēlaties nosaukumiem sākotnējā un attīstījušās arhitektūra (-iem), kas parādīsies uz zvaigznītes zemes gabalu.

Skatīt arī

Analizējot savu arhitektūru | Apskata reakcijas laiks diagrammu | Apskatot scatterplot matricu jūsu attīstījusies arhitektūru | Attīstās savu arhitektūru


Apskatot izbārstīt gabals jūsu attīstījusies arhitektūru

Navigācija: Analizējot savu arhitektūru> Custom grafiki>

Apskatot izbārstīt gabals jūsu attīstījusies arhitektūru

Nosūtīt komentārus par šo tēmu.

Kad arhitektūra ir attīstījusies, un mērķi ir definēti, tas pēc tam var vizualizēt, un, salīdzinot ar sākotnējo arhitektūru, izmantojot scatterplot matricas. Šajā sadaļā izklāstīts, kā izveidot un saprast kādas scatterplot matricas īpašības.

Lai apskatītu scatterplot Matrix jūsu attīstījusies arhitektūru

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Pārliecinieties, vai ir attīstījiesun izvirzītos mērķusJūsu arhitektūru, kā norādīts saskaņā Attīstās savu arhitektūru

3. Atlasīt Ievietot| Diagramma| Custom Chartstab | Scatterplot Matrix.

4. Klikšķiniet uz Finišspoga.

5. Scatter Plotar definēto attīstības arhitektūru un mērķiem tiks parādīts.

Piezīme

Teritorija kreisajā pusē scatterplot matricas rāda uzstādījumus scatterplot matricas parādīta. Tas ietver arhitektūru, kas ir attīstījusies (šajā gadījumā "ABC SIA as-is 2010"), Kā arī mērķus, kas ir noteikti šajā arhitektūru. Jūs ņemiet vērā, ka mērķi, kas ir ķeksīti zīmi blakus tiem ir pārstāvētas kā x un y asīm scatterplot matricu (piemēram, KPI- Izmaksas, KPI - Kvalitāte un KPI - Laiks). Jūs varat untick šos mērķus jebkurā brīdī, lai novērstu tos no scatterplot matricas.

Zilie punkti, kas parādās uz jūsu zemes gabala matricā pārstāv normalizējies vērtību, kā to nosaka labāko un sliktāko vērtības (norādīts ar Nosakot mērķus jūsu attīstījusies arhitektūra ). Šīs vērtības ir pārstāvētas Kvalitāte Space.

Divi definētie mērķi tiek salīdzināti viens pret otru kādā scatterplot matricā, un process tiek atkārtots, kamēr tika salīdzināti visi mērķi (piemēram, pirmais gabals no matricas iepriekš diagrammā salīdzina KPI - CostMērķis ar KPI - Kvalitāte mērķis. Otrais ir Izmaksas pret Laiks un pēdējais gabals ir Kvalitāte pret Laiks. Attiecīgie Vārtu uzlīmes tiek parādīts augšā un pa labi vai katras rindas gabaliem.).

6. Izvēlieties Arhitektūrasradio pogu, ja jūs vēlaties, lai parādītu metrika atsevišķiem arhitektūras.

7. Izvēlieties Notikumiradio pogu, ja jūs vēlaties, lai parādītu normalizētās izmaiņas no sākotnējā arhitektūrā (piemēram, As-ir 2010. gada) Uz evolucionējusī arhitektūru (-u) (piemēram, To-Be 2011 - Stratēģija un to-Be 2011 - Stratēģija B).

Skatīt arī

Analizējot savu arhitektūru | Apskata reakcijas laiks diagrammu | Apskata zvaigzne apzaļumota jūsu attīstījusies arhitektūru | Attīstās savu arhitektūru


Apskate burbulis diagrammu

Navigācija: Analizējot savu arhitektūru> Custom grafiki>

Apskate burbulis diagrammu

Nosūtīt komentārus par šo tēmu.

Burbulis diagramma ļauj salīdzināt līdz 5 dimensiju (ti, x, y, burbulis izmēra / rādiusu, burbulis krāsu un burbulis robežu krāsu) vienā skatā.

Lai apskatītu burbulis diagrammu

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Atlasīt Ievietot| Diagramma| Custom Chartstab | Bubble Chart.

3. Iekš Arhitektūrassadaļa, atzīmējiet arhitektūras (ja tādi ir), jūs vēlaties, lai diagrammu, tad noklikšķiniet Nākamais.

4. Izvēlieties Sastāvdaļasun Savienojumika jūs vēlaties diagrammā (ja tāda ir) no standarta elements izvēles logs , Tad noklikšķiniet Nākamais.

5. Izvēlieties X-assīpašums, tad noklikšķiniet Nākamais.

Piezīme

Tikai Integer, Decimal, Date / Time, Boolean un saraksts īpašības var lietot, lai uz X ass. Turklāt, Integer, Decimal un datuma / laika īpašības tiek vilkta kreisās uz labo pa asi samazināts atkarībā no īpašuma vērtības, tomēr, Boolean un Saraksts īpašības ir vienkārši vilkta kreisās uz labo precīzā secībā (vai apgrieztā secībā, ja iespēja mainīt kārtību tiek pārbaudīta) noteikta par īpašumu, neatkarīgi no to vērtības. Piem Zema | Vidēja | Augsts vai 1, 2, 4, 8, 16.

6. Izvēlieties Y-assīpašums, tad noklikšķiniet Nākamais.

Piezīme

Tikai Integer, Decimal, Date / Time, Boolean un saraksts īpašības var lietot, lai uz Y ass. Turklāt, Integer, Decimal un datuma / laika īpašības tiek attēlots apakšā-to-top gar asi samazināts atkarībā no īpašuma vērtības, tomēr, Boolean un Saraksts īpašības ir vienkārši attēlots apakšā-to-top precīzā secībā (vai apgrieztā secībā, ja iespēja mainīt kārtību tiek pārbaudīta) noteikta par īpašumu, neatkarīgi no to vērtības. Piem Zema | Vidēja | Augsts vai 1, 2, 4, 8, 16.

7. Izvēlieties burbulis izmērs / rādiussīpašums, tad noklikšķiniet Nākamais.

Piezīme

Tikai Integer, Decimal, Boolean un saraksts īpašības var izmantot burbulis izmēra / rādiusu. Turklāt, Integer un Decimal īpašības izraisīt burbulis izmēra / rādiusā samazināts atkarībā no īpašuma vērtības, tomēr, Boolean un Saraksts īpašības izraisīt vienādās solis palielinās par burbuļa izmēru / rādiusa precīzā secībā (vai apgrieztā secībā, ja iespēja mainīt kārtību tiek pārbaudīta) noteikta par īpašumu, neatkarīgi no to vērtības. Piem Zema | Vidēja | Augsts vai 1, 2, 4, 8, 16.

8. Izvēlieties vai nu fiksētā burbulis krāsavai saistīt īpašumu ar burbuļu krāsu, Tad noklikšķiniet Nākamais.

Piezīme

Tikai Integer, Decimal, Boolean un saraksts īpašības var izmantot, lai burbulis krāsu. Turklāt, Integer un Decimal īpašības izraisīt burbulis krāsā ietvaros izvēlētajā diapazonā samazināts atkarībā no īpašuma vērtības, tomēr, Boolean un Saraksts īpašības izraisīt vienādās soļa pieaugumu burbuļa krāsu ietvaros izvēlētajā diapazonā tādā secībā, kas noteikti, lai īpašums, neatkarīgi no to vērtības. Piem Zema | Vidēja | Augsts vai 1, 2, 4, 8, 16.

9. Izvēlieties vai nu nē burbulis apmales krāsavai saistīt īpašumu ar burbulis robežas krāsu, Tad noklikšķiniet Finišs.

Piezīme

Tikai Integer, Decimal, Boolean un saraksts īpašības var izmantot, lai burbulis apmales krāsa. Turklāt, Integer un Decimal īpašības izraisīt burbulis pierobežas krāsā ietvaros izvēlētajā diapazonā samazināts atkarībā no īpašuma vērtības, tomēr, Boolean un Saraksts īpašības izraisīt vienādās solis palielinās no burbulis robežu krāsu ietvaros izvēlētajā diapazonā tādā secībā, kas definēti par īpašumu, neatkarīgi no to vērtības. Piem Zema | Vidēja | Augsts vai 1, 2, 4, 8, 16.

Bubble diagramma

Lai saglabātu burbulis diagrammu

Piezīme

Bubble diagrammas var saglabāt tikai tad, ja tie satur tikai detaļas un savienojumi, kas visi jābūt no vienas arhitektūras pašreizējā projekta ietvaros.

1. Pārliecinieties, ka jums ir jaunu vai esošu burbulis diagrammu atvērtsun esat veicis nepieciešamās izmaiņas.

2. Diagrammā rīkjoslā noklikšķiniet uz kreisās malas Saglabāt Chartpogu, lai saglabātu diagrammu un visas formatēšanas izmaiņas.

3. Iekš Chart Namedialog kas parādās ievadiet burbulis diagrammu un nospiediet labi.

Eksportēt burbulis diagrammu

1. Pārliecinieties, vai ir atvērtu esošu burbulis diagrammu.

2. Jo diagramma rīkjoslā noklikšķiniet uz 2. no kreisās Saglabāt kā BMPpogu un izvēlējās vietu tabulā.

3. Uzklikšķiniet Saglabāt.

Skatīt arī

Analizējot savu arhitektūru


Arhitektūra Diff un Sync

Navigācija: Analizējot savu arhitektūru>

Arhitektūra Diff un Sync

Nosūtīt komentārus par šo tēmu.

Ja jums ir 2 vai vairāk arhitektūru, nu kā evolūciju vai bāzes arhitektūra, jūs varat vizuāli 'diff "divi arhitektūras izmantojot katalogā vai diagramma Salīdzinājums vai Arhitektūra Diff iezīme. Tas ir īpaši noderīgi, lai iepazītu / re-atklājot precīzu izmaiņas, no vienas arhitektūra uz citu, kā jūs attīstīties arhitektūras un izstrādāt plānus in ABACUS.

Līdz rādīt 'diff' ar citu arhitektūru, izmantojot diagrammu

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Nodrošināt jums būt vismaz 2 arhitektūras projektā.

3. Atveriet diagrammu vēlaties salīdzināt ar citu arhitektūru.

4. Klikšķiniet uz "salīdzināt šo zīmējumu saturam citas arhitektūras" pogu uz diagramma rīkjoslā.

5. Izvēlieties citu arhitektūru no nolaižamā saraksta, lai salīdzinātu to.

6. Jūs varat filtrēt, kādas atšķirības ir parādīts, noklikšķinot uz "atšķirības" pogu uz diagramma rīkjoslā un atsijājot iespējas, piemēram, Mainīts / Pievienots / Nezināms un Nenoteikts / Sync Ieteicams/ Keep Ieteicams.

Piezīme

Komponenti un savienojumi diagrammā tiks izcelti sarkans, zaļš vai purpurs ja pastāv atšķirības starp saturu, kas ir redzams uz pašreizējo diagrammā un saturu citā arhitektūrā. Sarkans tiek izmantota, ja ir ieteicams Sync atšķirības (skatīt zemāk), Zaļš tiek izmantota, ja tas nav ieteicams, lai sinhronizētu atšķirības, kas ir saglabāt to (skatīt zemāk) un Purpurs tiek izmantots, kad ABACUS nevar sniegt ieteikumu par sinhronizēšana atšķirības (skatīt zemāk). Redzamais saturs diagrammā salīdzināts tikai tādēļ, ja anotācija izrāda krātuve īpašuma vērtību, un šī vērtība tiek mainīta doto komponentu vai savienojums tiks parādīts noģībt red, noģībt zaļavai noģībt violeta un "*" simbols parādīta augšējā kreisajā komponentiem, tomēr, ja kāda cita pamata krātuve īpašuma vērtība mainījusies, kas netiek parādīts anotāciju, tad nekādas norādes, tiks dota. Saturu, kas notiek pašreizējā shēmā, bet sakritības ir atrodams salīdzināšanas arhitektūrā tiks parādīts stipra red, spēcīga zaļavai stipra violetaun "+" simbolu parādīts augšējā kreisajā komponentu. Saskaņošana tiek veikta ar detaļas tipa un nosaukumu tādā, ka, ja tips vai nosaukums komponentu vai savienojumu ir mainījusies otrā arhitektūras sakritības tiks atrasts. Jo nav veids, kā droši noteikt, vai papildu saturu no otras arhitektūras tiktu parādīts pašreizējā diagrammā (piem papildu saskarne starp 2 komponentiem, kā norādīts zemāk diagrammā no salīdzinājuma arhitektūru labajā pusē), šīs atšķirības nav parādīts diagrammas (tie tiek parādīti katalogiem kā vienu zemāk). Paceltais pār katru posteni pārveidotā rādīs atšķirību Tooltip. Paceltais pār "*" simbolu augšējā kreisajā stūrī diagrammā sniegts kopsavilkums par izmaiņām (vai bez izmaiņām) starp diagrammā saturu un satura citu arhitektūru.

Colour Legend

· Zaļš norāda preces, kurām tas nav ieteicams, lai sinhronizētu atšķirības, kas ir, lai saglabātu tos.

· Sarkans norāda preces, tas ir ieteicams, lai sinhronizētu atšķirības.

· Purpurs norāda priekšmeti kur ABACUS nevar sniegt ieteikumu par sinhronizēšana atšķirības.

Līdz sinhronizēt ("sync") saturu no vienas arhitektūru ar otru, izmantojot diagrammu

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Nodrošināt jums būt vismaz 2 arhitektūras projektā.

3. Atveriet diagrammu vēlaties salīdzināt ar citu arhitektūru.

4. Klikšķiniet uz "salīdzināt šo katalogu saturam citas arhitektūras" pogu uz diagramma rīkjoslā.

5. Izvēlieties citu arhitektūru no nolaižamā saraksta, lai salīdzinātu ar.

Piezīme

Skatīt iepriekš par to, kā ABACUS parāda 'diff "starp 2 arhitektūrām katalogā. Jo īpaši, kā Sarkans tiek izmantots, ja to irieteicams Sync atšķirības, Zaļš tiek izmantots, kur tas ir navieteica sinhronizēt atšķirības un Purpurs tiek izmantots, kad ABACUS nevar sniegt ieteikumu par sinhronizēšana atšķirības.

6. Ar peles labo pogu noklikšķiniet uz diagrammas elementu (vai elementus, izmantojot Shift vai diagramma audekls sinhronizēt visas), norādot uz 'diff' un izvēlieties Sync izvēlnes elementu.

Piezīme

Jebkuras sinhronizācijas izmaiņas būs tikai uz arhitektūru, ka šobrīd fokusā katalogā pieder. Lai pieteiktos izmaiņas pārējām arhitektūra jums ir jāizmanto katalogu otrā arhitektūrā. Turklāt lietotāji būs tikai iespēja pieteikties sinhronizācijas izmaiņas, ja tie ir atļauja to darīt .

Piezīme

Atkarībā no tā, kur jūs peles labo pogu noklikšķiniet uz izvēlnes elementu parādīs vadlīnijas par to, kas tieši tiks sinhronizētas.Piem Peles labo pogu noklikšķinot vienu komponentu diagrammā būs tikai sinhronizēt šo komponentu. Tā labo noklikšķinot diagramma audekls un izvēloties Sync Viss būs sinhronizēt visas šobrīd redzamos atšķirības.

Līdz rādīt 'diff' ar citu arhitektūru, izmantojot katalogu

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Nodrošināt jums būt vismaz 2 arhitektūras projektā.

3. Atveriet katalogu vēlaties salīdzināt ar citu arhitektūru.

4. Klikšķiniet uz "salīdzināt šo katalogu saturam citas arhitektūras" pogu uz Katalogs rīkjoslā.

5. Izvēlieties citu arhitektūru no nolaižamā saraksta, lai salīdzinātu to.

6. Jūs varat filtrēt, kādas atšķirības ir parādīts, noklikšķinot uz "atšķirības" pogu diagramma rīkjoslā un unselecting iespējas, piemēram, Mainīts / Pievienots / Nezināms un Nenoteikts / Sync Ieteicams/ Keep Ieteicams.

Piezīme

Šūnas katalogā tiks izcelti sarkans, zaļš vai purpurs ja pastāv atšķirības starp saturu pašreizējā katalogam un saskaņošanas satura otras arhitektūrā. Sarkans tiek izmantota, ja ir ieteicams Sync atšķirības (skatīt zemāk), Zaļš tiek izmantota, ja tas nav ieteicams, lai sinhronizētu atšķirības, kas ir saglabāt to (skatīt zemāk) un Purpurs tiek izmantots, kad ABACUS nevar sniegt ieteikumu par sinhronizēšana atšķirības (skatīt zemāk). Redzamās rindas un kolonnas katalogā tiek salīdzinātas tikai tad, ja ir atšķirība pēc kārtas aiz šobrīd parādītas rindas vai vērtību kolonnu, kas netiek parādīta ir atšķirība, tad nekādas atšķirības tiks norādīta. Ja vērtība atsevišķā kamerā atšķiras ar atbilstīgiem šūnu salīdzinājuma arhitektūrā šūnas robeža tiks iezīmēts. Kolonna galvenes un rinda selektoru tiks iekrāsoti noģībt violetaun parādīts ar "*" simbolu. Šie '*' simbolus var uzklikšķināt, lai pārietu uz nākamo atšķirību aili attiecīgi. Rindas, kas notiek pašreizējā kataloga, bet ne spēles ir atrasti salīdzināšanas arhitektūrā tiks parādīts ar "+" simbolu rindā selektoru pa kreisi un robežu visa rinda tiks iezīmēts. Rindas, kas būtu notikušas salīdzināšanas Arhitektūras versiju katalogs (ti, ar tādiem pašiem filtriem utt), bet nav spēles ir atrasti pašreizējā arhitektūrā tiks parādīts ar "-" simbolu rindā selektoru pa kreisi, uz robežas visa rinda tiks izcelti un viss rindas šūnas saturs tiks parādīts noģībt violetapārsteidza-through, piemēram, 8:00 līdz 6pm. Saskaņošana tiek veikta ar detaļas tipa un nosaukumu tādā, ka, ja tips vai nosaukums komponentu vai savienojumu ir mainījusies otrā arhitektūras sakritības tiks atrasts. Paceltais pār katru posteni pārveidotā rādīs atšķirību Tooltip. Paceltais pār "*" simbolu augšējā kreisajā stūrī diagrammā sniegts kopsavilkums par izmaiņām (vai bez izmaiņām) starp diagrammā saturu un saturs citu arhitektūras.

Colour Legend

· Zaļš norāda preces, kurām tas nav ieteicams, lai sinhronizētu atšķirības, kas ir, lai saglabātu tos.

· Sarkans norāda preces, tas ir ieteicams, lai sinhronizētu atšķirības.

· Purpurs norāda priekšmeti kur ABACUS nevar sniegt ieteikumu par sinhronizēšana atšķirības.

Līdz sinhronizēt ("sync") saturu no vienas arhitektūru ar citu, izmantojot katalogu

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Nodrošināt jums būt vismaz 2 arhitektūras projektā.

3. Atveriet katalogu vēlaties salīdzināt ar citu arhitektūru.

4. Klikšķiniet uz "salīdzināt šo katalogu saturam citas arhitektūras" pogu uz Katalogs rīkjoslā.

5. Izvēlieties citu arhitektūru no nolaižamā saraksta, lai salīdzinātu ar.

Piezīme

Skatīt iepriekš par to, kā ABACUS parāda 'diff "starp 2 arhitektūrām katalogā. Jo īpaši, kā Sarkans tiek izmantots, ja to irieteicams Sync atšķirības, Zaļš tiek izmantots, kur tas ir navieteica sinhronizēt atšķirības un Purpurs tiek izmantots, kad ABACUS nevar sniegt ieteikumu par sinhronizēšana atšķirības.

6. Ar peles labo pogu noklikšķiniet uz šūnas, aili pozīcijā (vai vairākas vienības, izmantojot Shift vai Ctrl + A par visu), kurā ir "diff 'un izvēlieties Sync izvēlnes elementu.

Piezīme

Jebkuras sinhronizācijas izmaiņas būs tikai uz arhitektūru, ka šobrīd fokusā katalogā pieder. Lai pieteiktos izmaiņas pārējām arhitektūra jums ir jāizmanto katalogu otrā arhitektūrā. Turklāt lietotāji būs tikai iespēja pieteikties sinhronizācijas izmaiņas, ja tie ir atļauja to darīt .

Piezīme

Atkarībā no tā, kur jūs ar peles labo pogu (ti, šūnu, kolonnu vai rindas nosaukums) izvēlnes vienums parādīs vadlīnijas par to, kas tieši tiks sinhronizētas.Piem Peles labo pogu noklikšķinot vienu īpašumu vai pievienoto komponentu šūnu katalogā būs tikai sinhronizēt šo īpašumu vai pievienoto sastāvdaļu. Tā kā peles labo pogu noklikšķinot uz rindas nosaukums (vai virsraksti, izmantojot Shift) būs sinhronizēt visa rinda (vai rindas). Peles labo pogu noklikšķinot kolonnu galvenes būs sinhronizēt visas atšķirības šajā slejā.

Lai apskatītu 'diff'no 2 viss arhitektūras

1. Pārliecinieties, vai ir ABACUS fails atvērts .

2. Nodrošināt jums būt vismaz 2 arhitektūras projektā.

3. Atlasīt Darbarīki| Arhitektūra Diff ....

4. Dialoglodziņā, kas parādās, izvēlieties pirmais / No otrā un / Lai arhitektūrām salīdzināt.

5. Klikšķiniet uz labipoga.

Arhitektūra Diff

Colour Legend

· Zaļšnorāda, ka mezgls tika pievienots otrajā / Lai arhitektūru.

· Sarkansnorāda, ka mezgls tika dzēsts otrajā / uz arhitektūru.

· Zilsnorāda, ka mezgls ir dažādi atribūti (piemēram, īpašības vai standartus) otrajā / uz arhitektūru.

· Dzeltensnorāda, ka mezgls ir atšķirības tās bērniem otrajā / arhitektūrai tik mezglu jāpaplašina.

Piezīme

Jūs varat ar peles labo pogu un "Show Explorer" uz visiem mezgliem, lai redzētu detaļas un vairāk tiek sniegta informācija par atšķirībām atšķirībām kopsavilkums paneli, kad ir izvēlēta mezgls.

Skatīt arī

Analizējot savu arhitektūru | Apskata reakcijas laiks diagrammu | Apskatot scatterplot matricu jūsu attīstījusies arhitektūru | Attīstās savu arhitektūru


Imitē savu arhitektūru

Navigācija: Imitē savu arhitektūru>

Imitē savu arhitektūru

Nosūtīt komentārus par šo tēmu.

Kad esat apdzīvotas un analizē savu arhitektūru, jūs esat gatavs izmantot Abacus, lai noteiktu, vai jūsu arhitektūra atbilst jūsu kvantitatīvos vajadzībām. Tas prasa simulācija. Lai modelētu savu arhitektūru jums vispirms jāizlemj par to, kāda veida informāciju, ko vēlaties atklāt. Šīs informācijas veidi ir bieži sauc par KPI, vai galvenajiem darbības rādītājiem. Piemēram, jūs vēlaties, lai analizētu veiktspēju, evolvability un atvērtību, vai arī jūs vēlaties, lai savāktu rādītājus, piemēram, kopējās izmaksas. Visa šī informācija var atklāt kaut kādā veidā. Kad esat šo informāciju, jums būs iespēja analizēt savu arhitektūru dažādos grafiskos formātos (vai analizēt jaunas vērtības tieši).

Ir trīs iespējas, modelējot savu arhitektūru:

· Vienkāršā metrika ;

· Pre-built simulatori ; vai

· Scripting .

Vienkāršā Metrics

Katrs elements jūsu arhitektūrā ir īpašības, - no kuriem daudzi var būt pasūtījuma jūsu piemērošanu ABACUS. Šīs īpašības pārstāv dažādus sastāvdaļu īpašībām. Dažos gadījumos, vienkārši savācot šos rādītājus (būvēt KPI), var būt pietiekami, lai pastāstītu jums svarīgu informāciju par savu arhitektūru. Piemēram, KLOCS vai Tūkstošiem koda rindiņas, ir plaši izmantots kā pasākums sarežģītības. Citos gadījumos, jūs varat eksportēt datus un analizēt to, izmantojot citu rīku. Turklāt, jūs varat savākt īpašumus pēc veicot cita veida simulācija.

Īpašības var savākt, izmantojot procesu, apkopošana . Summēšana piebilst norādītas apakšprogrammas īpašības kopumā, kas ir atspoguļots mātes sastāvdaļa. Apkopošana darbojas tikai uz detaļām, kas satur apakšprogrammas komponentus.

Pre-built simulatori

Ir pieci iepriekš būvētas simulatori, ko var lietot ar ABACUS. Šie ir:

· Performance;

· Modularitāte;

· Kopējās izmaksas (TCO);

· Atvērtība; un

· Uzticamība.

Piezīme

ABACUS automātiski izcelt, kurš no šiem simulatori nepieciešams atkārtoti palaist caur Sarkans izceļot uz Simulācijas rīkjosla .

Scripting

Scripting nodrošina elastību, lai modelētu savu arhitektūru pasūtījuma veidos. Ar rakstīšanas skripti Jūs varat veikt simulācijas pēc pašreizējā apdzīvotās jaudu ABACUS. Visa ABACUS objekta modelis ir pieejams ar skriptu, tāpēc jums ir tikai ierobežo savu spēju rakstīt skriptus!

Visual Basic skriptu ir skriptu valoda, ko atbalsta ABACUS, jo tas nodrošina būtiskus programmēšanas funkcijas samērā vienkāršā veidā.

Skatīt arī

Eksportē savu arhitektūru | Kopējie īpašības | Rakstīšanas skripti


Rakstīšanas skripti

Navigācija: Imitē savu arhitektūru>

Rakstīšanas skripti

Nosūtīt komentārus par šo tēmu.

Script Editor ir vienkārša un funkcionāla lietderība rakstīšanai un izpildes VB vai C # script pret Pašlaik atvērtas ABACUS fails(Bibliotēkas netiek atbalstīti skriptu). Tā ir parastā failu atvērt, aizvērt un Save komandas, lai jūs varat saglabāt un ielādēt skriptus jums rakstīt. Tā arī ir pamata vadīt un atkļūdot objektā. Script Manager ļauj jums viegli izpildīt dažādus skriptus, kas jums ir rakstīts, ievietojot izvēlnes-posteni par tiem tieši izvēlnē Rīki.

Lai piekļūtu Script Editor

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Atlasīt Darbarīki | Script Editorun Script Editor logs atvērsies. Tad nu;

3. Atvērtu esošu skriptu caur Fails | Atvērts In The Script Editor izvēlnēm,

vai

3. Atvērt piemērs skriptu caur Piemērs prece scenāriju redaktoru izvēlnēm,

vai

3. Uzstādīt noklusēto valodu, lai nu VB vai C # caur Valoda prece scenāriju redaktoru izvēlnēm,

vai

3. Atvērt skriptu īpašs Palīdzība caur Palīdzēt prece scenāriju redaktoru izvēlnēs

Rakstot skriptus, jums ir jāievēro vai nu VB vai C # sintaksekā vienu, kurā saskaņā ar Valodu posteņa scenāriju redaktoru izvēlnēs.

PIEZĪME:

· Lai izmantotu standarta VB funkcijas, piemēram, MsgBox ()Jums ir jāiekļauj Imports Microsoft.VisualBasicapgalvojums sākumā jūsu skriptu. Nav Tas bija nepieciešams, pirms ABACUS Version 3.0.

· Šī palīdzība nav ietverta informācija par to, kā rakstīt VB skriptu, nedz arī ietver VB atsauci. Jūtieties brīvi rakstīt savu skriptu jūsu mīļākie IDE vai redaktors, tad kopēt un ielīmēt tos Script Editor.

Kad jūs pirmo reizi sākt scenāriju redaktoru, Script Editor būs tukša. Jūs varat piekļūt skelets skriptu, izmantojot izvēlni piemēriem. Pirmo reizi startējot Script Editor, jums vajadzētu palaist Template skelets, lai redzētu, ka tas darbojas. Bez tam, pastāv divi piemērs skriptus, kas var piekļūt, izmantojot izvēlni piemēriem.

Lai rakstītu noderīgu skripts jums būs nepieciešams, lai norādītu ABACUS ObjectModel. Tā ir pieejama jūsu rakstībā tostarp Imports ABACUS.ObjectModelapgalvojums pie galvas jūsu skriptu. Pilnīgs atsauce uz visu ABACUS objekta modelis ir iekļauts Script Editor. Jūs varat atrast to, izvēloties Palīdzība | SatursNo Script Editor logā.

Skripts redaktors ietver daudzas noderīgas funkcijas rakstot skriptus, tostarp AutoComplete kā parādīts attēlā zemāk. Tomēr, lai vēl bagātīgāku lietotāju pieredzi MS Visual Studio var tikt integrēta ar ABACUS un detalizētas instrukcijas ir pieejamas šeit .

Script Editor ar automātisko pabeigšanu

Lai izmantotu Script pārvaldnieku

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Izvēlieties Rīki | Script vadītājs.

3. Klikšķiniet uz Pievienotikona un AtvērtsParādās logs.

4. Pārlūkojiet ABACUS Script (.abacusscript, VB vai .cs) Failu, kuru vēlaties pievienot izvēlnē Rīki.

5. Uzklikšķiniet labiun atsauce uz skripts tiks parādīts Script Manager logā. Ievadiet nosaukumu rakstībā, kā jūs vēlaties, lai to redz izvēlnē Rīki. Piezīme: Script pārvaldnieks logs var tikt mainīti, lai redzētu pilnu ceļu, ja nepieciešams.

6. Atkārtojiet 3-5izveidot saites uz vairākām ABACUS skriptus.

7. Uzklikšķiniet Aizvērtslēgt Script Manager, un ņemiet vērā, ka ABACUS skripts (s), tagad parādīsies zem izvēlnes Rīki.

Lai palaistu skriptu

Nu;

1. Atvērts, ierakstiet vai nokopējiet un ielīmējiet skriptu vēlaties palaist, tāpēc tas tiek parādīts galvenajā logā Script Editor.

2. Noklikšķiniet uz Skrējienspoga.

3. Ja jūsu skriptu ir kļūdas, kļūdas apraksts sadaļā apakšā Script Editor tiks uzskaitīti informāciju, tostarp līniju numuri. PIEZĪME: Katrs indivīds kļūda kļūdas aprakstu sadaļā var būt divreiz uzklikšķināt aizvedīs uz attiecīgo līniju skriptu.

- Vai -

1. Atlasīt Darbarīkiun pēc tam ABACUS Script nosaukums izvēlnes elementu, kas izveidota ar Script vadītājs.

2. Ja jūsu skriptu ir kļūdas, tad Script Editor atklās ar saturu skriptu parādīts galvenajā logā (iezīmētā pie līnijas pirmā kļūda) un kļūda Apraksts sadaļā apakšā Script Editor tiks uzskaitīti informāciju vai kļūdu (-as), ieskaitot līniju numuri. PIEZĪME: Katrs indivīds kļūda kļūdas aprakstu sadaļā var būt divreiz uzklikšķināt aizvedīs uz attiecīgo līniju skriptu.

Scripting Apkopošanas kļūdas

Compilation kļūdas rodas, ja sintakse skripta kods nav pareizs. Šīs kļūdas parādīsies apakšā loga Kļūda sadaļā, ar aprakstu par kļūdu, un ieraksta numurs. Tā ir līnija numurs, kas atšķir kompilācija kļūdu no Runtime kļūdas (skatīt zemāk), kas nebūs ieraksta numurs. Compilation kļūdas var dubultā noklikšķinājuši, lai pārietu uz un izcelt konkrēto pozīciju.

Scripting Runtime kļūdas (Svarīgi)

Runtime kļūdas rodas pēc tam, kad skripts kods ir veiksmīgi apkopoti bez kļūdām, bet rodas kļūda runtime (skatīt piemērus leju tālāk). Runtime kļūdas ir svarīgi, jo tie var izraisīt bojāti modeļos, kad izveidots un piesaistītas ar citiem objektiem modeļa objekti, nav paši modeļa sastāvdaļa (parasti, jo ir noticis izpildlaika kļūda pirms kodu, kas būtu novieto tos modelī kaut kur, tika izpildīts).

Ja jūsu skripts izveido objektus jāpieskaita modeli, jūs varat izvairīties no korupcijas, ko izraisa izpildlaika kļūda, ietaupot savu skriptu, slēdzot skriptu, un veicot undo par izmaiņām, kas tika izveidota ar skriptu (ja skriptu izpildi neaizpildīja parasti ). Tomēr ir arī citi veidi, kā izvairīties no jebkādas korupcijas rašanos (skatīt zemāk). Piezīme: Jebkurš skriptus, kas tikai lasa no modeļa un nav rakstīt to, ir drošas un neradīs nekādas problēmas, neatkarīgi no tā, vai runtime kļūdas rodas to izpildes laikā.

Lai izvairītos no korupcijas, rakstot skriptu kodu, kas ir radīt objektus un pievienojot tos objekta modeli, ir ierosināts, ka objekti tiek pievienotas paraugam cik drīz vien iespējams, ja tie ir atsauce ar citiem objektiem.

Piemēram, ja jūs veidojat jaunu savienojumu, un 2 jaunas detaļas, un pēc tam pievienojot tos kopā, tas ir labākais, lai izveidotu pirmo komponentu, pievienojiet to modeli, tad otrā un pievienot to, un pēc tam izveidot savienojumu un pievienojiet to, un tad beidzot izveidot pielikumus. Tas nozīmē, ka, ja būtu jābūt izpildlaika kļūda, kas pārtrauc skriptu izpildi, visi objekti, kas ir nepieciešami, lai būt objectmodel pirms aresta tiek radīts, ir modelī. Korupcija var rasties, ja, piemēram, tikai savienojums tika pievienots, pielikumi veikti, un tad radās izpildlaika kļūda pirms skripts beidzot pievienojusi jaunus komponentus uz model.Corruption var notikt, kad objekts, kas ir atsauce cita objekta objectmodel, ir sevi nevis objectmodel.

Piemērs runtime kļūdas ietver:

· Objekta norāde nav iestatīts gadījumu objektu - tas notiek tad, kad objekts mainīgais ir spēkā atsauces, un metode, vai īpašums uz šo objektu tiek izmantota. Null atsauces var pārbaudīt ar "Ja objectVariable nav nekas tam ..."

· Indekss bija ārpus robežas masīva - tas notiek tad, kad masīvs tiek apskatīta ar indeksu, kas ir ārpus robežām - piemēram, mazāk nekā 0 vai vienāds ar vai lielāks par garumu / Count no masīva. Array vai Collection garumu var pārbaudīt ar .Length vai .Count īpašībām attiecīgi.

· Nav atļaujas Izņēmums - Jums nav atļaujas, lai ... - šis viens notiek, ja jums nav atļaujas veikt doto izmaiņas

· Primārā Key Izņēmums - Duplicate / Missing vārds / ID - tas viens būs notikt, ja izmaiņas tiek veiktas unikālu atribūtu, kas ir pretrunā ar citu objektu. Piem Arhitektūras jābūt unikālam pēc nosaukuma, tāpat ar standartiem.

· Godbijīgs integritāti Izņēmums - atsauces lauks iestatīšana uz objektu, kas nav derīgs. Piem pievienojot "neko" vai null kā bērnam daudzas kolekcijām objectmodel.

· Zero Garums Izņēmums - tas var notikt, ja jūs mēģināt noteikt nosaukumu objektu uz tukšu virkni. Lielākā daļa objektu pieprasa viņu vārdus, lai būtu vismaz 1 raksturu.

Imports paziņojumi

Ņemiet vērā, ka sākumā skeletu skripti ir apgalvojumi, piemēram, Imports ABACUS.ObjectModel. Šie paziņojumi netiks iekļauta DLL, kas vēl nav atsauce ar skriptu - to mērķis ir nodrošināt "īsceļu", kam, lai precizētu visu nosaukumu klasē.

Piemēram, deklarēt mainīgo tipa CComponent (kas pārstāv sastāvdaļa ABACUS), ar Imports ABACUS.ObjectModelpaziņojums uz augšu skriptu, būtu tikai prasīt tā jādeklarē kā dim comp kā CComponent, Jo kompilators zina ieskatīties ABACUS.ObjectModel namespace par CComponent klasē. Bez importu paziņojumu, tas ir jādeklarē kā dim comp kā ABACUS.ObjectModel.CComponent. Agregāts (piemēram, mscorlib.dll, vai System.Windows.Forms.dll) var saturēt vairāk nekā vienu namespace - importa paziņojums ir šajās palīglapās, nevis pašiem komplektiem. ABACUS.ObjectModel.dll montāža ir tikai vienoto ABACUS.ObjectModel namespace pieejama caur skriptu.

Automātiski atsauces mezgli

Šādi DLL ir atsauce automātiski skriptu:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (netieši atsauce uz kompilators)

· ABACUS.ObjectModel.dll

Lai veiktu papildu norādes vai nu citiem NET komplektiem, vai jūsu pašu mezgli, skatiet nākamajā sadaļā par to #ImportDLL paziņojums.

#ImportDLL paziņojums

Sākot ar ABACUS 3.1, jūs varat atsaukties papildu komplektus, kas jums var būt nepieciešama skriptu ar izmantošanu uz #ImportDLL paziņojums. Piemēram, ja jūs vēlaties, lai piekļūtu pasūtījuma DLL no jums un izmantot funkcionalitāti tajā, jūs ievietojiet to ABACUS direktorijā un iekļaut aprēķinā kā pirmajā līnijā (iem), Jūsu skriptu. Ja tas ir NET dll, tad parasti jums nav nepieciešams ievadīt visu ceļu, tikai DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Dažas citas lietas, kas jāņem vērā:

1. Jo DLL jāatrod kompilēšanas un runtime, tas ierobežo pasūtījuma (non NET), DLL, kas tiek ievietoti ABACUS programmas mapē tikai.

2. #ImportDLL paziņojumi ir jābūt pirmajā rindā (s) skriptu - ja jums ir 5 paziņojumus, tad tie būtu par pirmajiem 5 līnijas skriptu

3. #ImportDLL paziņojums novietot jebkur, bet pirmie rindas skriptu (piemēram, ja tas tika ievietots pēc komentārā vai Imports aprēķinā) nestrādās pareizi un / vai var izraisīt nesaistīti kompilatoru kļūdas.

#ImportDLL ar Office asambleju

Ja jums ir Microsoft Office instalēta, un jūsu skriptu prasa Office Interop mezgli, tas ir iespējams, lai norādītu tos vienkārši, izmantojot #ImportDLL ar montāžas nosaukumu (kā norādīts zemāk, piem #ImportDLL Excel). Izmantojot šo metodi, ir priekšrocība, ka absolūtais dll ceļš nav jāizmanto, lai skripts ir daudz pārnēsājamu (jāstrādā gan Office 2003 un 2007 bez rediģēšanas skriptu).

Kad jūs izmantot šo funkciju, GAC (Global Assembly Cache) tiek meklēja INTEROP montāžas, un skripts apkopo ar ceļu uz šo komplektu, ja atrasts. Ja tas nav atrasts, skriptu pārbaudīs Abacus programmas direktorijā (kas satur Excel un Visio interops tikai). Ja pieprasītā INTEROP nav atrasts līdz šim laikam, tiek parādīts brīdinājums.

Par interops parasti nav uzstādītas GAC, ja jums ir uzstādīta Microsoft Office pirms .NET Framework (kas ir daļa no pilnas ABACUS uzstādīšanu) instalēšanu. Jūs varat instalēt tos, veicot Mainīt iespēju Microsoft Office no Add / Remove Programs, un izvēlēties NET programmējamību iespējas. Lai iegūtu vairāk informācijas, skatiet šī raksts MSDN.

Par komplektus, kam šī saīsne tiek atbalstīti, ir:

· Piekļūšana

· Access.Dao

· Izcelties

· Graph

· MSProject

· Perspektīva

· OutlookViewCtl

· Owc11

· PowerPoint

· Izdevējs

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Vārds

It nav pilnīgi skaidrs, vai visi minētie komplekti ir noderīgi, istabas havebeen iekļauta šajā funkciju regardeless kā daži lietotāji feb ir vajadzīga pat neskaidra komplektiem.

Skatīt arī

Imitē savu arhitektūru

© 2001-2015 Avolution Pty Ltd. Visas tiesības aizsargātas.


Izmantojot Makro

Navigācija: Imitē savu arhitektūru>

Izmantojot Makro

Nosūtīt komentārus par šo tēmu.

Ja jūs veikt uzdevumu atkārtoti ABACUS, jūs varat automatizēt uzdevumu, izmantojot makro. Attiecīgi, ABACUS makro ir ierakstīta virkne darbību, ko var atskaņotas jebkurā laikā.

Ierakstot makro

1. Izvēlieties Rīki | Record Macrovai arī nospiediet Alt + F10.

2. Sāk veikt darbības, kuru vēlaties ierakstīt.

Brīdinājums

Šajā laikā, ir daži zināmi jautājumi ar makro ierakstīšanas. Lūdzu ņemt tās vērā, ierakstot savu makro:

· Šobrīd makro vienkārši ierakstīt savu Microsoft Windows keystrokes, peles kustības un peles klikšķiem. Tomēr, ņemot vērā ierobežojumus, ar makro ierakstītājs pati, ir daži keystrokes, kas ne vienmēr ir ierakstītas. Tie ir šādi:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1], lai [F12]

· Tādēļ ir ieteicams, ka jūs pārbaudīt, ka īsinājumtaustiņš ieraksta ar makro ierakstītājs pirms ierakstīšanas lielu notikumu secību, kas var būt atkarīgs īsinājumtaustiņu darba.

· Šobrīd sakarā ar ierobežojumiem, ar makro ierakstītājs, konteksta izvēlnes netiek apstrādāti pareizi, ABACUS kad tie tiek atvērti ar prasību, kas reģistrēta ar makro ierakstītāju. Atverot konteksta izvēlni, jums ir jāveic viens no uzskaitītajiem konteksta izvēlnē, izmantojot konteksta izvēlni funkcijas, pretējā gadījumā konteksta izvēlni var palikt atvērtas atskaņošanas laikā, kas var novest pie neparedzētas darbības vai darbības, kas varētu izraisīt kļūdas ABACUS.

· Ņemiet vērā, ka parastās metodes, slēdzot konteksta izvēlni (piemēram, nospiežot uz tastatūras, vai [Esc] kreisās noklikšķinot kaut kur citur uz ekrāna) nedrīkst faktiski slēgt konteksta izvēlni atskaņošanas makro laikā.

Gals

In dialogs, nevis izmantojot peles klikšķiem, ieteicams izmantot Tab taustiņu, lai pārvietotos pa pieejamo kontroles un kursora taustiņus, lai izvēlētos nolaižamās izvēlnes objektus vai radio pogas iespējas un SPACE, lai izvēlētos / de-izvēlieties pārbaudi kastes.

Lai pārtrauktu ierakstīšanu, makro

1. Prese Alt + F9vai arī izvēlieties Tools | Stop Macro.

2. Jo Saglabāt makro Kā dialog pārlūkojat atrašanās vietu un izvēlēties ABACUS makro (.abacusmac fails) faila nosaukumu un noklikšķiniet uz Saglabāt.

Piezīme

Izmantojot Darbarīki| Stop Macroietvers šo operāciju ierakstīto makro. Tādēļ ir ieteicams, ka lietotāji kļūtu lietpratējs izmantojot Alt + funkciju taustiņu iespējas darbam ar makro tā, lai iekļautu nevēlamas makro operācijām paši makro.

Gals

Tā kā makro pašlaik nav rediģējams ieteicams ierakstīt garas uzdevumus kā virkni atsevišķu makro, izmantojot Alt + F10 / Alt + F9 "pāriem".

Lai atskaņotu ierakstīto makro

1. Izvēlieties Rīki | Atskaņošanas Macrovai arī nospiediet Alt + F8.

2. Open Macro dialog pārlūkojat atrašanās vietu un izvēlēties ABACUS makro (.abacusmac fails) faila nosaukumu un noklikšķiniet uz Atvērt.

Brīdinājums

Atverot Abacus makro, ja jūs dubultklikšķi uz makro failu no pārlūkošanas dialogā, lai to atvērtu, makro ierakstītājs var turēt kreiso peles pogu uz kreisās uzklikšķināt stāvoklī līdz ierakstītajai kreisās noklikšķiniet ignorēšanu šī valsts.

Piezīme

Atskaņošanas ātrumu no makro var iestatīt uz cilnes Vispārīgi saskaņā Darbarīki| Iespējaskā nu Normal (noklusējuma), ātri vai lēni. Gan ātri un lēni atskaņošanas ātrums, nav ieteicams, jo tie būs atkārtot ierakstīto makro pie aptuveni 100 reizes un 1 / 100th reāllaikā, attiecīgi. Parasta atskaņošanas ātrums joprojām būs atkārtot makro aptuveni 30% ātrāk nekā reģistrētā ātrums tāpēc ieteicams ierakstīšanas laikā, lai apturētu uz īsu laiku pēc jebkādām ilgstošām apstrādes uzdevumiem, lai nodrošinātu, ka uz atskaņošanas nākamā darbība netiek izpildīts pirms apstrādes uzdevums ir pabeigts.

Lai pārtrauktu atskaņot ierakstītu makro

1. Prese Alt + F9.


Imitē Performance

Navigācija: Imitē savu arhitektūru> Simulātori>

Imitē Performance

Nosūtīt komentārus par šo tēmu.

Fons

Arhitektūras vērtētājs veikšanai ir diskrētu notikumu simulators, kas darbojas, imitējot plūsmu ziņu (vai žetonu) visā arhitektūru. Aiz šī teorija ir atvasināts no pētījumiem, ko veica Tehnoloģiju universitātē, Sidnejā, un ir balstīta uz Layered Queuing Tīkla modeļi(LQNM), Ierobežot un Krāsainās Petri-Nets(TCPN) un Aktivitātes cikla diagrammas(ACD).

Jo ABACUS veiktspējas simulācijas, apstrāde uz vienas sastāvdaļas virza galvenokārt ar ziņojumiem nodots uz to no citas sastāvdaļas. Aiz šīs tehnikas principus var saprast četrās galvenajās daļās:

1. ziņa orientētuskomunikācija tiek veidota ABACUS izmantojot loģisks(vai netieša) savienojumus. Loģiski savienojumi definēt uzvedību (biežums un dati) par ziņu pagājis starp sastāvdaļām. Labs piemērs loģiskos savienojumus būtu secība plūsmas starp divām (2) biznesa procesu vai loģisko saskarnēm starp diviem (2) pieteikumiem.

2. Loģiskās ziņojumi tiek transportētas uz savu galamērķi, izmantojot hierarhija(piemēram, resursu swimlanes) vai tiešssavienojumiem (piemēram, fiziskām vadi). Lai to izdarītu, viņi var būt novirzīts uz augšu, pāri un atpakaļ uz leju, hierarhiju (slāņveida pieeja) sekot tiešu ceļu.

3. Modeļa uzticība var pielāgot, lai tie atbilstu. Piemēram, ir process, var tik tālu, piemēram, ka katrs process un funkcija ir atsevišķa apstrādes nospiedumu sadalīta uz leju. Alternatīvi, tas var būt pietiekami, lai ir tikai viena vērtība visā procesā, atspoguļojot vidējaisapstrāde reakcija uz ziņu.

4. Faktiskais apstrādetiek veikta tikai ar sastāvdaļām, kas ir (vai ir) procesoru. Procesors ir vispārējs lieta, un tas varētu būt CPU, persona, kas ir organizatoriska vienība, vai jebkas cits, kas ir spējīga veikt darbu. Piemēram, biznesa procesu nav darīt jebkuru faktisko pārstrādi; Tas tiek darīts ar pirmo "apstrādātājs" tas atrod vai nu tās mātes hierarhiju (ja izmanto swimlane notācija) vai tās apstrādes tīklu (ja izmanto sadala apstrādes notācija).

Novērtējumu veic, imitējot (precizēts) satiksmes sistēmā tā, ka katrs savienojums ir imitētas vismaz vienu reizi. Ierašanās laiki ziņojumi tiek nejauši ģenerēta attiecībā uz to noteiktiem intervāliem. Šis modelis simulē resursu pārstrādi un apgalvojumu un ierindošana ziņas, apkopojot statistiku pa ceļam, kā dažādas izvades īpašībām.

Galvenie Performance Ieejas faktori

1. Frekvence- Frekvencē, kurā notiek savienojums.

2. Apstrāde- Par izpildes laiks summa, lai pabeigtu viena procesu. Tas var būt stundas, minūtes, dienas, operācijas uc

3. Ātrums- Par procesora resursa ātrums. Tas ir, cik cikli / instrukcijas / darbības tā var veikt vienā laika vienībā. Svarīgi ir jāsaskan ar vienībām, ko izmanto pārstrādei.

4. Pārstrādātāji- Par procesora resursu skaits. Pārstrādātāji varētu būt cilvēki, CPU, ārējās organizācijas uc

Galvenie Performance Izejas faktori

1. Caurlaide- Ziņojumu skaits laika vienībā caur skaits saistība. Šī reālā vērtība var salīdzināt ar paredzamie / teorētiskajām vērtībām (ti, biežums) secināt piesātinājums sistēmas.

2. Message Rate- Ziņojumu skaits laika vienībā caur skaits komponents. Tas ir visu sastāvdaļu "ienākošo un izejošo ziņu summa.

3. Atbilde- Minimālā / vidējā / maksimālā latentuma par šo saistība. Tas ir visu novēroto latencies par savienojumu no tās iztekas līdz izlietni un jebkuru ierindošana un pārstrādes summa (un latentuma atpakaļ uz avotu, ja divvirzienu).

4. Izmantošana- Par izmantošana komponents. Tas būs 0%, ja komponents nav ierīce / procesors (ti, tas nav pārstrādātāji un ātruma īpašības iepriekš definēto).

Lai gan diskrēto notikumu simulācijas tiek veikta, lai aprēķinātu dažādus produkcijas īpašības, kā aprakstīts iepriekš, šādu formulu var izmantot kā aptuvenu pārbaudes rezultātu (kur sistēma nav piesātināto):

Izmantošana = summa biežums visiem ienākošajiem savienojumiem * apstrāde / (ātrums * Procesori)

Kopējais koncepcija, iespējams, vislabāk pierādīja, apsverot šādu diagrammu, kas parāda divus atšķirīgus darbības meta-modeļus. Kreisās puses stils ir klasisks "swimlane 'notācija ar apstrādes uzdevumiem, pamatojoties hierarhiski savās procesora resursus. Labajā stils ir "sadalīti" notācija ar apstrādes uzdevumiem, kas saistīti, izmantojot procesu pieslēgumu viņu procesora resursu. Šis pēdējais notācija ļauj vairākiem procesora resursus konkrētā apstrādes uzdevumu, atšķirībā no ierobežoto swimlane papildinājumiem.

Piezīme

Parādīts katrā meta-modelim ir ievades īpašības (sarkanā krāsā) un izejas īpašības (zilā krāsā):

Veiktspējas meta-modeļus: Swimlane versus Distributed notācija

Running Performance simulators

Lai modelētu savu arhitektūru veiktspējas izteiksmē

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Atlasīt Analīze| Sniegumsvai noklikšķiniet uz pogas rīkjoslas.

3. Izvēlieties ArhitektūraJūs vēlaties, lai novērtētu no nolaižamās izvēlnes.

Piezīme

Pēc noklusējuma ABACUS automātiski izvēlēsies pirmo arhitektūru, par kuru atkārtoti simulācija ir nepieciešama sakarā ar jebkādu bāzes īpašuma vai strukturālām izmaiņām.Šis izceļot tiek parādīts Sarkans uz Simulācijas rīkjosla .

4. Izvēlieties Sastāvdaļasun SavienojumiJūs vēlaties, lai novērtētu, no standarta elements izvēles logs .

5. Uzstādīt Run Time Scale Factorslider.

Piezīme

Augstākas vērtības dos vairāk statistiski konsekventus rezultātus, bet nepieciešams ilgāks laiks, lai aprēķinātu.

Papildu Rūtiņauz standarta elements izvēles logs

· Save pārveidots modelisgriba ietaupīt kopiju RBD pārveidota versijas projekta tajā pašā mapē, kā pašreizējā projektā un pievienot "_transformed" projekta nosaukuma.Tas pārveidots projektu var izmantot, lai diagnosticētu detalizēti uzticamību simulācija ar ABACUS uzņēmusies.

Citas iespējas, lai standarta elements izvēles logs

· Run Time Scale Factor kontrolē simulācijas laiku un precizitāti ar augstāku vērtības ražaingvairāk statistiski konsekventus rezultātus, bet ņemot ilgāks laiks, lai skrējiens.

Piezīme

Kad ABACUS aprēķina simulācijas laikā tas noteiks vislēnāko netieša savienojuma biežumu, kas tika izvēlēts tiek modelēta un pēc tam "iesildīšanās" laika posmam (ti, 1 pār biežumu) šajā sakarā (uzsākšanas periodiski ziņu ģeneratori visiem savienojumiem nejauši laikā šīs uzsilšanas laiks, dodot viņiem visiem iespēju uzsākt), un tad simulēt uz Run Time Scale Factor reizes periodā sakarā. Vai (1 / Frequency) iesildīšanās laiks + (1 / Frequency) * Run Time Scale Factor simulācija laiks. Tas nepieciešams, lai pārliecinātos, ka to, ka visi savienojumi ir uzsākta pirms statistiku vāc un tad vislēnākais savienojums joprojām simulēta vismaz reizi simulāciju. Piem Ja vislēnākais netieša saistība ir biežums 0,033 laika vienībās (vai apm reizi mēnesī, ja termiņi vienības dienas), tad iesildīšanās laiks būs 30.3 termiņi vienības un simulācija laiks būs 30.3 termiņi vienības reizes Run laiks Scale Factor.

6. Uzklikšķiniet Finišsun jūs saņemsiet Brīdinājumsdialog.

7. Pēc izvēles izpētīt brīdinājumus, noklikšķinot Sīkāka informācija >>.

8. Uzklikšķiniet Turpināt.

Piezīme

Šajā brīdī, ABACUS veiks diskrēto notikumu simulācijas arhitektūras un pēc neilga laika (ar progresa stieņu atsauksmes) parādīsies pilns dialogs aprēķins.

9. Uzklikšķiniet labiatzīt simulāciju.

Gals

Mācību kursiem un papildu palīdzība Performance Simulācijas lūdzu, skatiet Avolution Kopiena .

Komponentu Properties

Tabulā ir uzskaitītas nepieciešamās īpašības, lai novērtētu sniegumu. Properties tiek meklēti vispirms detaļai, gadījumos, tad komponentu standarti, un, ja nav atrasts, noklusējuma tiek izmantots.Šīs īpašības tiks parādīts Properties loga ar īpašuma ievades rinda atlasītājs ikonas ( [image] ) Ar Tooltip "Performance ievades". Maiņa uz kādu no šiem "ievadi" īpašībām un dažādas strukturālās izmaiņas repozitorijā radīs Performance simulatorā pieprasa atkārtotu simulāciju, kā norādīts Sarkans uz Simulācijas rīkjosla .

Type | Nosaukums | Noklusējuma vērtība | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzvedība | b_pack | 0.0 |  | Decimal | Nepatiess | Fiksētā dienesta laiks iepakot sekundēs. Šis īpašums parasti precizēta kā standarta tipa un pēc tam izmantot daudzkomponentu instancēs. Piemēram, CORBA ir b_pack = 0.23 ms.
Uzvedība | m_pack | 0.0 |  | Decimal | Nepatiess | Mainīgais pakalpojums laiks pack sekundēm / baitu. Šis īpašums parasti precizēta kā standarta tipa un pēc tam izmantot daudzkomponentu instancēs.
Uzvedība | b_unpack | 0.0 |  | Decimal | Nepatiess | Fiksētā dienesta laiks izkravāt sekundēs. Šis īpašums parastiprecizēta kā standarta tipa un pēc tam izmantot daudzkomponentu instancēs.
Uzvedība | m_unpack | 0.0 |  | Decimal | Nepatiess | Mainīgais pakalpojums laiks izkravāt sekundēs / baitu. Šis īpašums parastiprecizēta kā standarta tipa un pēc tam izmantot daudzkomponentu instancēs.
Uzvedība | Apstrāde | 0.0 |  | Decimal | Patiess | Par izpildes laiks summa, lai pabeigtu viena procesu. Tas var būt stundas, minūtes, dienas, operācijas uc
Uzvedība | Pārstrādātāji | 1 |  | Vesels skaitlis | Patiess | No procesora resursus skaits. Pārstrādātāji varētu būt cilvēki, CPU, ārējās organizācijas uc
Uzvedība | Ātrums | 100 |  | Vesels skaitlis | Patiess | No procesora resursa ātrums. Tas ir, cik cikli / instrukcijas / darbības tā var veikt vienā laika vienībā. Svarīgi ir jāsaskan ar vienībām, ko izmanto pārstrādei.
Uzvedība | k_bkgd | 0.0 |  | Decimal | Nepatiess | Fona apstrāde uz sastāvdaļu. Tas tiek izmantots, lai pielāgotu rezultātus, lai tie atbilstu jebkurus fiksētus nobīdes par%. To var droši ignorēt.

Tabulā detaļas īpašības izlaidi par izpildes vērtētājs. Kopums Šo komponentu īpašības tiek ģenerēti katrai sastāvdaļai, par katru izpildes termiņā.Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Performance Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un Performance simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzvedība | Message Rate |  | Decimal | Nepatiess | Ziņojumu skaits laika vienībā caur sastāvdaļu skaitu. Tas ir visu sastāvdaļu "ienākošo un izejošo ziņu summa.
Uzvedība | Joslas platums |  | Decimal | Nepatiess | Kopumā joslas caur sastāvdaļu. Likumības gan ienākošo un izejošo ziņu summa.
Uzvedība | Izmantošana | % | Decimal | Nepatiess | No komponenta izmantošana. Tas būs 0%, ja komponents nav ierīce / procesors (ti, tas nav procesori un ātruma īpašības iepriekš noteikts)

Connection Properties

Tabulā ir uzskaitītas nepieciešamās īpašības, lai novērtētu sniegumu. Properties tiek meklēti vispirms pieslēguma gadījumos, tad savienojuma standartiem un, ja nav atrasts, noklusējuma tiek izmantots.Šīs īpašības tiks parādīts Properties loga ar īpašuma ievades rinda atlasītājs ikonas ( [image] ) Ar Tooltip "Performance Input" vai "Cost / Performance viedokli". Maiņa uz kādu no šiem "ievadi" īpašībām un dažādas strukturālās izmaiņas repozitorijā radīs Performance simulatorā un / vai Izmaksas simulators pieprasot atkārtotu simulāciju, kā norādīts Sarkans uz Simulācijas rīkjosla .

Type

Nosaukums

Noklusējuma vērtība

Vienība

Datu tips

Nepieciešamais

Apraksts

Uzvedība

Laipns

divvirzienu

[divvirzienu | vienvirziena]

Meklēt / saraksts

Patiess

Vai savienojums ir divvirzienu (divvirzienu) vai vienvirziena (vienvirziena).

Atļautās vērtības šajā iestādē ir "divvirzienu" vai "vienvirziena".

Divvirzienu nozīmē sinhrono pieprasījuma / atbildes vēstules, turpretim vienvirziena ir vienots asinhronā "notikums".

Uzvedība

Abstrakcija

netiešs

[netiešs | tiešais]

Meklēt / saraksts

Patiess

Vai savienojums ir fiziska vai loģiska. Tiešie savienojumi ir fiziskie "caurules" starp diviem komponentiem, kas loģiski savienojumi plūst gar.

Atļautās vērtības šajā iestādē ir "tiešs" vai "netiešs".

Ja vērtība ir "tiešs", tad savienojums nav vajadzīgas nekādas citas īpašības (izņemot īpašībām Kind un ieguvei).

Dati

L_app1

0

Vesels skaitlis

Nepatiess

Pieprasījums / notikums izmērs baitos.

Katrs savienojums parasti ir īpaša vērtība šim. In CORBA, notikumi ir faktiski divvirzienu un vienmēr ir 12 baitu atzīstat (L_app2). Ja tā ir taisnība, vienvirziena savienojums tad atstāt īpašumu L_app2.

Dati

L_app2

0

Vesels skaitlis

Nepatiess

Response / atzīt izmēru baitos.

Katrs savienojums parasti ir īpaša vērtība šim. Vienvirziena savienojums nebūs L_app2.

Uzvedība

Frekvence

1

Decimal

Patiess

Frekvencē, kurā notiek savienojums.

Katrs savienojums parasti ir īpaša vērtība šim. Ja īpašums biežums tiek izlaisti tad noklusējuma tiek izmantots.

Uzvedība

Radniecība

procesi

[procesi | atbalsta]

Meklēt / saraksts

Nepatiess

Savienojumi, kas ir "procesi" īpašumu norāda, ka detaļa sākumā pieslēguma tiks pārveidota jāapstrādā pie komponenta beigās savienojumu. Būtībā "avots" komponents tiek pārvietota kļūt bērns "izlietne" sastāvdaļa (pievienotos savienojumi ir arī "vilka" ar šo soli).

Ja "procesi" īpašums eksistē, tad visi pārējie savienojuma īpašības, tiks ignorētas, izņemot turpmāk aprakstīto izvēles "%" īpašums.

Uzvedība

%

100.0

Decimal

Nepatiess

Savienojumi, kas ir "procesi" īpašumu (kā aprakstīts iepriekš) izvēles var būt "%" īpašums, lai norādītu īpatsvaru apstrādes, kas tiks attiecināta uz galamērķa sastāvdaļu. Tādā veidā viens avots komponents var apstrādāt ar vairākām mērķa komponentu dažādos% 's. Šīs% vērtības nav nepieciešams pievienot līdz pat 100%, un tas ir vienkārši izmanto, lai skalu "apstrāde" īpašumu (skatīt iepriekš), lai avota sastāvdaļa, jo tas ir pārveidots, lai kļūtu bērns mērķa sastāvdaļa.

Tabulā ir uzskaitītas īpašības, ko izpildes vērtētāja radīts. Komplekts no šiem savienojuma īpašības tiek ģenerētas katru savienojumu katrā izpildes termiņā.Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Performance Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un Performance simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzvedība | Joslas platums |  | Decimal | Nepatiess | Kopējais joslas platums savienojumam. Tas tiek aprēķināts tikai netiešiem savienojumiem un būtībā (L_app1 + L_app2) * Caurlaide.
Uzvedība | Joslas platums 1/2 |  | Decimal | Nepatiess | Joslas platums īpaši izejošajiem (1) un ienākošo (2) ziņas par savienojumu. Tas tiek aprēķināts tikai netiešiem savienojumiem un būtībā L_app1 * Caurlaide un L_app2 * Caurlaide.
Uzvedība | Caurlaide |  | Decimal | Nepatiess | Ziņojumu skaits laika vienībā, izmantojot pieslēgumu skaits. Šī reālā vērtība var salīdzināt ar paredzamie / teorētiskajām vērtībām (ti, biežums) secināt piesātinājums sistēmas.
Uzvedība | Pabeigts | % | Decimal | Nepatiess | Procents ziņu, ka sekmīgi pabeigta apstrāde savienojumu. Tas tiek aprēķināts tikai netiešiem savienojumiem un ir caurlaides / frekvence. Reizēm Pabeigts vērtība pārsniedz 100%, jo nejaušība ziņa paaudzes rezultātu nedaudz augstāku ziņu paaudzes frekvenci, nekā noteikts.
Uzvedība | Response (Min / Ave / Max) |  | Decimal | Nepatiess | Minimālā / vidējā / maksimālā latentuma. Tas tiek aprēķināts tikai netiešiem savienojumiem un ir novērota latentuma par savienojumu no avota izlietne un jebkuru ierindošana un pārstrādi (un latentuma atpakaļ uz avotu, ja divvirzienu).

Arhitektūra Properties

Tabulā sistēmas mēroga arhitektūras īpašības, izpildes vērtētāja radīts. Vienots kopums īpašību par arhitektūras "apkopoti" par katru izpildes termiņā.Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Performance Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un Performance simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzvedība | Message Rate |  | Decimal | Nepatiess | Ziņojumu skaits laika vienībā skaits caur komponentu arhitektūrā. Tas ir visu sastāvdaļu "ienākošo un izejošo ziņu summa.
Uzvedība | Caurlaide |  | Decimal | Nepatiess | Ziņojumu skaits laika vienībā skaits caur savienojumiem arhitektūrā. Tas ir par visām netiešajām savienojumi 'throughputs summa, un šī faktiskā vērtība var salīdzināt ar paredzamie / teorētiskajām vērtībām (ti, biežums) secināt piesātinājums sistēmas.
Uzvedība | Joslas platums |  | Decimal | Nepatiess | Kopējais joslas platumu. Sum no arhitektūras pieslēguma joslas platumu.
Uzvedība | Izmantošana | % | Decimal | Nepatiess | Visu sastāvdaļu izmantošana. Var būt lielāka par 100%, jo tā ir tikai daļa no visiem arhitektūras ir komponentu saistītos veidos summa.
Uzvedība | Response (Min / Ave / Max) |  | Decimal | Nepatiess | Minimālā / vidējā / maksimālā latentuma. Summa no visiem novērotajiem latencies par arhitektūru s savienojumiem no avota grimt (un atpakaļ uz avotu, ja divvirzienu).


Imitē Modularitāte

Navigācija: Imitē savu arhitektūru> Simulātori>

Imitē Modularitāte

Nosūtīt komentārus par šo tēmu.

Modularitāti simulators aprēķina skaitu ienākošo un izejošo savienojumu katram komponentam.

Lai modelētu savu arhitektūru ziņā modularitāte

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Atlasīt Analīze| Modularitāte.

3. Izvēlieties Arhitektūra (-i)Jūs vēlaties iekļaut novērtēšanā.

Piezīme

Pēc noklusējuma ABACUS automātiski izvēlēsies arhitektūru (-as), kam atkārtoti simulācija ir nepieciešama sakarā ar kādu pakārtotu strukturālām izmaiņām.Šis izceļot tiek parādīts Sarkans uz Simulācijas rīkjosla .

4. Uzklikšķiniet Nākamais.

5. Izvēlieties Savienojuma veidi (s)Jūs vēlaties iekļaut novērtēšanā.

6. Uzklikšķiniet Nākamais.

7. Pēc izvēles pielāgot īpašuma nosaukumus aprēķinu rezultātiem.

8. Uzklikšķiniet Finišs.

Piezīme

Šajā brīdī, ABACUS uzstāsies strukturālu novērtējumu arhitektūrā (-iem) un pēc neilga laika (ar progresa stieņu atsauksmes) parādīsies pilns dialogs aprēķins.

9. Uzklikšķiniet labiatzīt novērtēšanu.

Gals

Mācību kursiem un turpmāku palīdzību modularitāte novērtēšanas lūdzu, skatiet Avolution Kopiena .

Komponentu Properties

Tabulā komponentu īpašības, kas produkciju, ko no moduļiem vērtētājs.Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Modularitāte Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši, jo pamatā esošā strukturālās izmaiņas repozitorijā un modularitāti simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Datu tips | Nepieciešamais | Apraksts
Modularitāte | Sakabes-ventilators (vietējās) | Vesels skaitlis | Nepatiess | Pieslēgumu skaits, kas ventilators šajā komponentā.
Modularitāte | Sakabes-fan out (vietējās) | Vesels skaitlis | Nepatiess | Pieslēgumu skaits, kas ventilators no šo komponentu.
Modularitāte | Sakabes-fanu | Vesels skaitlis | Nepatiess | Pieslēgumu skaits, kas ventilators uz šo komponentu, ieskaitot savienojumus, kas ventilators vērā apakškomponentos.
Modularitāte | Sakabes-fan out | Vesels skaitlis | Nepatiess | Pieslēgumu skaits ka ventilators no šā komponenta, ieskaitot savienojumus, kas ventilators vērā apakškomponentos.


Imitē īpašuma kopējās izmaksas (TCO)

Navigācija: Imitē savu arhitektūru> Simulātori>

Imitē īpašuma kopējās izmaksas (TCO)

Nosūtīt komentārus par šo tēmu.

Fons

Kopējās izmaksas (TCO), ir finanšu novērtējums, kas paredzēti, lai izmērītu kopējo radušās dzīves cikla izmaksas (no iegādes līdz nojaukšanas / apglabāšanai), kas saistīta ar piederošu īpašumu. TCO ne tikai atspoguļo iegādes izmaksas, tas ietver arī visus citus aspektus turpmāku izmantošanu un uzturēšanu aktīva.

TCO tiek izmantots, lai noteiktu piepūli un budžeta izmaksas, kas nepieciešamas, lai tērēt uz sistēmu. Vienkāršs veids, kā modelēšanas ABACUS par TCO ir lauzt IT sistēmu leju sastāvdaļām. Tad mēs varam uzzināt, cik daudz vidēji tas maksā, lai palaistu vienu no šiem komponentiem. Pēc tam mēs varētu pēc tam faktors dažādas izmaksas, atkarībā no tā, vai IT sistēma ir evolvable vai atvērts uc Ja sistēma ir jau izveidota un darbojas, galvenais faktors, kas jāapsver, ir uzturēšanas izmaksas un, iespējams izmaksām ekspluatācijas pārtraukšanai.

Piemērs

Diagramma piemērs aprēķināšanas

Komponents ar organizācijas vai tās standartu ir šādas īpašības:

· FTE= 100 000 $ / gadā

· Atbalsts Intensitātes= 0,01 FTE + 0.001 FTE / gadā = 1000 $ + 100 $ / gadā

· Uzturēšanas izmaksas= 100 $ - 10 $ / gadā

· Kapitāla izmaksas= $ 2000

· Instalējiet Piepūles= 2 PLE / dienas = 0,01 FTE / gadā = 1000 $

Komponents saskaņā organizācijas ir šādas īpašības:

· Instalējiet Horizon= -2 Gadi (ti, sistēma tika uzstādīta 2 gadus pirms mūsdienām)

· Mūžs= 3 gadi

Kad Instalējiet Horizon + dzīves ilgums <= 0 Nav daudz uzturēšanas izmaksas.

Aprēķini

Aprēķini ir šādi:

Piezīme

TC = izmaksas uz vienu gadu. SE = Support pūles. MC = uzturēšanas izmaksas.

· Sākotnējās izmaksas = Capital Cost + Install Piepūles= 2000 + 1000 = 3000 $

· Pie t = -2 (1. gadā), TC = Sākotnējā vērtība + SE + MC= 3000 + 1000 + 100 = 4100 $

· Pie t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1190 $

· T = 0, TC = (1000 + 200) + (100 - 20) = 1280 $

· Pie t = 1 (pēdējais gads), TC = (1000 + 300) + (100 - 30) = 1370 $

Graph piemērs aprēķināšanas

TCO ir visu pašreizējo un turpmāko izmaksu summa, kamēr sistēma ir nojaukta.

· Pie t = -2 (1. gadā), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Pie t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Pie t = 0, TCO = 1280 + 1370 = 2650 $

· T = 1 (pēdējais gads), TCO = 1370 $

Galvenie izmaksu faktori

Galvenie izmaksu faktori, kas jāņem vērā, aprēķinot TCO no aktīva ABACUS ir:

· Aparatūras iegāde- Sākotnējās izmaksas saistībā ar iekārtu (kapitāla izmaksas).

· Programmatūras iegāde- Sākotnējā vērtība licences programmatūras (kapitāla izmaksas).

· Uzstādīšana- Izmaksas, kas saistītas ar sākotnējo iestatīšanu.

· Treniņš- Izmaksas, kas saistītas ar ārējo piegādātāju apmācību pēc sākotnējās uzstādīšanas.

· Atbalsts- Izmaksas, kas saistītas ar iekšējo atbalstu.

· Uzturēšana- Izmaksas, nomainīt vai uzlabot pārdevēja uzturēšanas līgumu, piegādes un katastrofu seku izmaksas.

· Infrastruktūras- Izmaksas, kas saistītas ar atbalsta aktīvu.

ABACUS Piemērs pārstāvniecība galveno izmaksu faktoru

Running izmaksām simulators

Lai modelētu savu arhitektūru izmaksu ziņā

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Atlasīt Analīze| Izmaksas.

3. Izvēlieties Arhitektūra (-i)Jūs vēlaties iekļaut novērtēšanā.

Piezīme

Pēc noklusējuma ABACUS automātiski izvēlēsies arhitektūru (-as), kam atkārtoti simulācija ir nepieciešama sakarā ar jebkādu bāzes īpašuma vai strukturālām izmaiņām.Šis izceļot tiek parādīts Sarkans uz Simulācijas rīkjosla .

4. Izvēlieties Valūtano nolaižamās.

5. Pārvietot Gadi, lai aprēķinātuslīdni gadu skaitu nepieciešamo.

Piezīme

Pēc noklusējuma, ja turpmākajos gados, lai aprēķinātu, ir vairāk nekā 1 gadu izmaksas tiks automātiski aprēķināts katram atsevišķam gadam (un kolekcija īpašības piebilda / papildināta) un pēc tam kumulatīvā vērtība visai vairākus gadus arī aprēķināti. Ja ir nepieciešama tikai uzkrātā vērtība, tad noņemiet atzīmi Aprēķināt Per-gada izmaksuiespēja, kā aprakstīts tālāk, lai ietaupītu uz numuru īpašumu projektā.

6. Izvēlieties, vai atstāt Aprēķināt Per-gada izmaksupārbauda, ​​vai izņemiet to.

7. Uzklikšķiniet Nākamais.

8. Pēc izvēles izvēlēties SavienojumiJūs vēlaties piešķirt izmaksas kopā kā daļa no vērtēšanas.

Piezīme

Izmantojot Izmaksas | Attiecinājumsīpašums savienojumos izmaksām var būt saistīt no komponenta, kas pievienots izlietne beigām savienojumam ar komponenta, kas pievienots avota beigām(ti, izmaksas | Attribution = "Sink avots"), vai no komponenta, kas piestiprinātas pie avots beigām, savienojuma ar sastāvdaļu, kas piestiprinātas pie izlietne beigas(t Izmaksas | Attribution = "Source izlietne"). Bez tam, ABACUS automātiski izvēlas šos savienojumus ar prakses | Attiecības = "procesi" vai "atbalsta"un virziens piešķiršanu būs "izlietne avots". Turklāt izmaksas ir sadalīta saskaņā ar jebkuru Behaviour | % Vai izmaksas | % Īpašības savienojumos vai arī, ja ir vairāki savienojumi no izlietni daudziem avotiemvai avots daudziem izlietnes, Saskaņā ar jebkuru Behaviour | Apstrādes īpašības par avotu komponentusvai nogrimt sastāvdaļas attiecīgi.

9. Uzklikšķiniet Finišsun jūs saņemsiet Brīdinājumsdialog.

10. Pēc izvēles izpētīt brīdinājumus, noklikšķinot Sīkāka informācija >>.

11. Uzklikšķiniet Turpināt.

Piezīme

Šajā brīdī, ABACUS veiks darbību izmaksu kalkulācijas novērtējumu arhitektūrā (-iem) un pēc neilga laika (ar progresa stieņu atsauksmes) parādīsies pilns dialogs aprēķins.

12. Uzklikšķiniet labiatzīt novērtēšanu.

Gals

Mācību kursiem un turpmāku palīdzību uz izmaksu Simulācijas lūdzu, skatiet Avolution Kopiena .

Komponents un / vai Savienojums Properties

Tabulā komponentu un / vai savienojums īpašības nepieciešamas, lai izvērtētu izmaksas.Šīs īpašības tiks parādīts Properties loga ar īpašuma ievades rinda atlasītājs ikonas ( [image] ) Ar Tooltip "Izmaksas ievades". Maiņa uz kādu no šiem "ievadi" īpašībām un dažādas strukturālās izmaiņas repozitorijā radīs izmaksu simulatorā pieprasa atkārtotu simulāciju, kā norādīts Sarkans uz Simulācijas rīkjosla .

Type

Nosaukums

Noklusējuma vērtība

Vienība

Datu tips

Nepieciešamais

Apraksts

Izmaksas

Instalējiet Horizon

0

gadiem

Vesels skaitlis

Patiess

Norāda, kad sastāvdaļa vai savienojums ir bijis, vai tiks uzstādīts.

· Vērtība 0 (noklusētais) norāda, ka detaļa vai savienojums tiek uzstādīts kārtējā gadā.

· Vērtība ir mazāka par 0 norāda, ka komponenta vai savienojums ir uzstādīts pagātnē.

· Kuru vērtība ir lielāka par 0 norāda, ka komponenta vai savienojums Tiks uzstādītas arī nākotnē.

Izmaksas

Mūžs

0

gadiem

Vesels skaitlis

Patiess

Norāda laiku, kurā sastāvdaļa vai savienojums paliks ekspluatācijā, pēc tam tā tiks nojaukta.

Izmaksas

FTE

100,000.00

$ / gadā

Decimal

Nepatiess

Gada izmaksas par katru pilnas slodzes darbinieks.

Ja šis īpašums nav atrodams komponentapati vai gadījumā, ja savienojumi komponents pievienots izlietnes beigām savienojuma, Tas tiks meklēti citi komponenti.

Pirmkārt, jebkurš "izlietne" komponentss beigās a savienojums ar "atbalsta" attiecības ar komponentu Tiks meklēti, kam seko ka "izlietne" komponenta vecākiems.

Ja īpašums FTE nav atrasts, komponenta vecāks-components tiks meklēti. Ja FTE joprojām nav atrasts, tiek izmantota noklusējuma vērtība.

Lūdzu, ņemiet vērā: FTE ir tikai derīga ieejas īpašumu uz detaļām.

Izmaksas

Uzturēšanas izmaksas (fiksēts)

0.00

$ / gadā

Decimal

Nepatiess

Gada fiksēto uzturēšanas izmaksas komponentuvai savienojums.

Izmaksas

Uzturēšanas izmaksas (mainīgās)

0.00

$ / gadā

Decimal

Nepatiess

Summa, par kuru kopējās izmaksas, saglabājot komponentu vai savienojums katru gadu mainīsies.

Piemēram, vērtība -500 $ liecina, ka kopējais uzturēšanas izmaksas samazinās par $ 500 katru gadu, bet vērtība 500 $ norāda, ka kopējie uzturēšanas izmaksas palielinās par $ 500 katru gadu.

Izmaksas

Atbalsta intensitāte (fiksēts)

0.00

FTE / gadā

Decimal

Nepatiess

Gada fiksētā centieni atbalstīt komponentuvai savienojums, Norādīts uz personas gadus.

Izmaksas

Atbalsta intensitāte (mainīgs)

0.00

FTE / gadā

Decimal

Nepatiess

Summa, par kuru kopējais centieni atbalstīt komponentu vai savienojums katru gadu mainīsies.

Piemēram, vērtība -0.01 norāda, ka kopējais atbalsts pūles samazinās ar katru gadu 0,01 persona gadiem, bet vērtība 0.01 norāda, ka kopējais atbalsta intensitāti palielinās par 0,01 katru gadu.

Izmaksas

Kapitāla izmaksas

0.00

$

Decimal

Nepatiess

Sākotnējās izmaksas iegādes komponentuvai savienojums.

Izmaksas

Instalējiet Piepūles

0.00

FTE

Decimal

Nepatiess

Pūles nepieciešams, personīgi gadu, lai instalētu komponentuvai savienojums.

Tabulā komponentu un / vai savienojums īpašības, kas produkciju ar TCO vērtētājs. Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Izmaksas Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un izmaksas simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Piezīme

Ja izejas īpašības no TCO vērtētāja jābūt "noapaļota" "apaļā pusi līdz pat" pieeja (arī saukta par "baņķieri" noapaļošanu) tiek izmantots.Šī metode tiek izmantota, lai vienmērīgāk atrisināt jebkuru .5 "kaklasaišu pauzes" ar rezultātu noapaļojot uz augšu vai uz leju līdz tuvākajam pat rezultāts, nevis vienmēr noapaļojot uz augšu vai uz leju un sagrozīšanu rezultātu. T 2.5 noapaļo uz leju līdz 2, bet 3,5 noapaļo līdz 4, nevis tiem gan ir vai nu noapaļojot uz leju līdz 2 un 3 vai noapaļojot līdz 3 un 4.

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Izmaksas | Kopējās izmaksas uz pašu - nākamie x gadiem. | $ | Vesels skaitlis | Nepatiess | Kopējās izmaksas īpašumtiesības pār nākamo xgadi, kur x ir ilgums norādīts, braucot vērtētājs. Tas ietver izmaksas komponenta vai savienojums ir standarti, sub-sastāvdaļasvai pasugai savienojumi(t bērni) un jebkuras rezultātā radušās izmaksas.
Izmaksas | Total Cost uz pašu (vietējais) - nākamā x gadiem. | $ | Vesels skaitlis | Nepatiess | "Vietējās" izmaksas īpašumtiesības pār nākamo xgadiem, ja xir ilgums norādīts, braucot vērtētājs. Tas nav navietver izmaksas komponenta apakškomponentos vai savienojums ir sub-savienojumi (tbērni) vai jebkuras rezultātā radušās izmaksas.
Izmaksas | Kopējās izmaksas uz pašu (bērniem) - blakus x gadus. | $ | Vesels skaitlis | Nepatiess | Ar "Bērnu izmaksas īpašumtiesības pār nākamo xgadi, kur x ir ilgums norādīts, braucot vērtētājs. Šis tikai ietver izmaksas komponenta apakškomponentos vai savienojums ir sub-savienojumi (t bērni).
Izmaksas | Total Cost uz pašu (attiecināt) - nākamā x gadiem. | $ | Vesels skaitlis | Nepatiess | Ar "piedēvēt" izmaksas īpašumtiesības pār nākamo xgadi, kur x ir ilgums norādīts, braucot vērtētājs. Šis tikai ietver visus attiecināt izmaksas no pievienotajām sastāvdaļām(kas, protams, var ietvert attiecina izmaksas no jebkuriem pievienotajiem savienojumiem).

Tabulā komponentu un / vai savienojums īpašības, kas produkciju ar TCO novērtētājsja Aprēķināt Per-Year Izmaksas ir atlasīta opcija. Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Izmaksas Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un izmaksas simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Piezīme

Skatīt piezīmi iepriekš par iespējamo noapaļošanu produkcijas īpašības.

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Izmaksas | Kopējās izmaksas uz pašu - gadsx. | $ | Vesels skaitlis | Nepatiess | Kopējās izmaksas īpašumtiesību par gads x, Kur x ir par katru gadu norādīts, braucot vērtētājs. Tas ietver izmaksas komponentavai savienojums ir standarti, sub-sastāvdaļas vai pasugai savienojumi (t bērni) un jebkuras rezultātā radušās izmaksas.
Izmaksas | Total Cost uz pašu (vietējais) - gadsx. | $ | Vesels skaitlis | Nepatiess | "Vietējās" izmaksas īpašumtiesības gadā x, Kur xir par katru gadu norādīts, braucot vērtētājs. Tas nav navietver izmaksas komponenta apakškomponentos vai savienojums ir sub-savienojumi (t bērni) vai jebkuras rezultātā radušās izmaksas.
Izmaksas | Kopējās izmaksas uz pašu (bērni) - gadsx. | $ | Vesels skaitlis | Nepatiess | Par "Bērnu izmaksas īpašumtiesības gadā x, Kur x ir par katru gadu norādīts, braucot vērtētājs. Šis tikai ietver izmaksas komponenta apakškomponentos vai savienojums ir sub-savienojums (t bērni).
Izmaksas | Total Cost uz pašu (piedēvēt) - gadsx. | $ | Vesels skaitlis | Nepatiess | Ar "piedēvēt" izmaksas īpašumtiesības gadā x, Kur x ir par katru gadu norādīts, braucot vērtētājs. Šis tikai ietver visus attiecināt izmaksas no pievienotajām sastāvdaļām(kas, protams, var ietvert attiecina izmaksas no jebkuriem pievienotajiem savienojumiem).

Papildu Connection Properties

Tabulā papildu savienojuma īpašības, kas nepieciešamas ar TCO vērtētājs. Šīs īpašības tiks parādīts Properties loga ar īpašuma ievades rinda atlasītājs ikonas ( [image] ) Ar Tooltip "Cost / Performance Input" vai vienkārši "Izmaksas ievades". Maiņa uz kādu no šiem "ievadi" īpašībām un dažādas strukturālās izmaiņas repozitorijā radīs izmaksas un / vai Performance simulators pieprasot atkārtotu simulāciju, kā norādīts Sarkans uz Simulācijas rīkjosla .

Type | Nosaukums | Noklusējuma vērtība | Vienība | Datu tips | Nepieciešamais | Apraksts
Izmaksas | Attiecinājums | Izlietne Source | [Avots grimt | Izlietne Source] | Meklēt / saraksts | Patiess | Ja "Source izlietne", Šis savienojums griba būt būt cenaspiedēvēt "kopā" tas no avotskomponents uz izlietne komponents. Alternatīvi, ja "Izlietne Source", Šis savienojums griba ir izmaksas attiecina "kopā" tas no izlietnes sastāvdaļas ar avota sastāvdaļu.
Uzvedība | Radniecība | atbalsta | [procesi | atbalsta] | Meklēt / saraksts | Nepatiess | Ja "atbalsta", šajā sakarā norāda, ka "avots" sastāvdaļa ir atbalsta "izlietne" sastāvdaļa. Bez tam, ja nu "atbalsta" vai "procesi", tad savienojums tiks automātiski izvēlēts savienojumiem, lai būtu to izmaksas attiecina "gar" no izlietnes sastāvdaļas ar avota sastāvdaļu.
Izmaksas | % | 100.0 | % | Decimal | Nepatiess | Norāda īpatsvaru izlietnes sastāvdaļu izmaksām, kas tiks attiecināti uz avota sastāvdaļu. Šīs% vērtības nav nepieciešams pievienot līdz pat 100%, un tas ir vienkārši izmanto, lai skalu "kopējās izmaksas uz pašu -. Nākamos x gadi" iestādē (skat iepriekš) no izlietnes komponentu, kā tas ir attiecināma uz avota sastāvdaļu.

Arhitektūra Properties

Tabulā arhitektūras īpašības, kas produkciju ar TCO vērtētājs. Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Izmaksas Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un izmaksas simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Piezīme

Skatīt piezīmi iepriekš par iespējamo noapaļošanu produkcijas īpašības.

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Izmaksas | Kopējās izmaksas uz pašu - nākamie x gadiem. | $ | Vesels skaitlis | Nepatiess | Kopējās izmaksas īpašumtiesības uz visu arhitektūras nākamo x gadiem.

Tabulā arhitektūras īpašības, kas produkciju ar TCO novērtētājsja Aprēķināt Per-Year Izmaksas ir atlasīta opcija. Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Izmaksas Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un izmaksas simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Piezīme

Skatīt piezīmi iepriekš par iespējamo noapaļošanu produkcijas īpašības.

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Izmaksas | Kopējās izmaksas uz pašu - gadsx. | $ | Vesels skaitlis | Nepatiess | Kopējās izmaksas īpašumtiesību par viss arhitektūra gadā xnākotnē.


Imitē Drošums un darbspēja

Navigācija: Imitē savu arhitektūru> Simulātori>

Imitē Drošums un darbspēja

Nosūtīt komentārus par šo tēmu.

Fons

Uzticamību vērtētājs aprēķina ticamību arhitektūru, izmantojot ievades komponentus un savienojumus.

Komponentiem un tiešo savienojumu, uzticamība balstās vidējais laiks starp Failure (MTBF). Vienīgie mainīgie, kas nepieciešami, lai aprēķinātu ticamību arhitektūras elementi ir:

· MTBFvērtība (gados);

· Vidējais laiks līdz Remonts (MTTR)neveiksme (gados); un

· Noteiktais laika periods, lai pārbaudītu uzticamību vairāk.

Ko izmanto, aprēķinot uzticamība formula ir dota kā:

Uzticamība = -e (-y × vecums)
Ja y = 1 ÷ MTBF

Par sastāvdaļu un savienojumu pieejamība ir balstīts uz MTBF un MTTR. Ņemiet vērā, ka pieejamība, atšķirībā uzticamību, neietekmē laika periodu, par kuru tā tiek pārbaudīta.

Pieejamība = MTBF / (MTBF + MTTR)

Lai gan metodes, kas transformē Drošuma bloku diagrammas(izmantojot vienkāršu sērijas un paralēlas konstrukcijas) dod visvairāk precīzus rezultātus, šīs metodes kļuvušas ļoti IMpraktisks, kad mēs cenšamies, lai aprēķinātu uzticamību komandējumiem ietvaros milzīgu tīklu tūkstošu elementiem. Turklāt šīs transformācijas pieejas nojauktu daudziem kopīgiem struktūras, piemēram, tīkla "acis".

Monte CarloMetode ļauj uzticamība un pieejamība sistēmas patvaļīgu lieluma un sarežģītības jāaprēķina. Monte Carlo metode simulē daudzus scenārijus un fvai katrs scenārijs izlases valsts, pieejams vai nepieejams, Kas piešķirts katrai fiziskai elementam. Par konkrētā elementa atrašanos pieejamā valsts varbūtība ir balstīta uz komponentei uzticamība / pieejamība.

Piemēram, komponents ar 90% pieejamību var sagaidīt, būs pieejami aptuveni 90% no scenārijiem. Netiešajā savienojums ir uzticamība un pieejamība tāpēc var novērtēt kā īpatsvara izlases scenarios- par kuru pastāv ceļš no elementiem pieejamā pārskatos no avota līdz galamērķim.

Piezīme

Tā kā aprēķins vietējo uzticamību un pieejamību balstās uz dažādiem parametriem un dažādām formulām (un līdz ar to rada dažādas vērtības), ir nepieciešams piešķirt katru elementu divivalstis, vienu pieejamības, un viens par uzticamību. Pieejamības aprēķins izmanto pieejamības stāvokli katrā scenārijā, tā kā aprēķinu uzticamības izmanto uzticamības stāvokli katrā scenārijā.

Ticamība vērtētājs izmanto Monte Carlo simulācijas metodi, izstrādāt ticamību konkrētā arhitektūru. Arhitektūra ir likts caur tūkstošiem atsevišķu simulācijas, un rezultāti attēlo lai iegūtu uzticamības pasākumu. Kā minēts iepriekš, Monte Carlo ir ātrākais paņēmiens imitē lielākus tīklus un strādās ar jebkuru sarežģītu (ti režģotais) struktūrai.

Vērtētājs izejas četras vērtības:

1. Misija Uzticamībavairāku gadu laikā;

2. Pieejamība no arhitektūra;

3. Uzticamība no vietējais komponentsvairāku gadu laikā; un

4. Pieejamība no vietējais komponents.

Vērtētājs izstrādā varbūtību sastāvdaļa vai savienojums darba (t nav nedarot) un laiks, lai labotu.

Kā standartus ar MTBFs un / vai MTTRs izturas

Ja elements (elements vai savienojums) ir standarti, kam uzticēti MTBF un / vai MTTR vērtībām, šīs vērtības ir arī izmanto, aprēķinot vietējo uzticamību un pieejamība elementa kā sērijas savienojumu.

Piemēram, ja komponents A, Ar piešķirtajiem standartiem B, C, Un Dkatram ir MTBF un MTTR vērtība, Vietējais Uzticamība = R(A)× R(B) × R(C) × R(D), Kur R = Aprēķināts ticamība (izmantojot formulu) sastāvā / standartiemun Vietējs Izdevīgumsspēja = A (A)× A (B) × A (C) × A (D), Kur A = Aprēķināts izdevīgumsSpēja (izmantojot formulu) sastāvā / standartiem. Tas ir, ja elements ir trīs standarti katrs ar MTBF un MTTR vērtības, Un arī MTBF un MTTR vērtībaspar elementa īpašību, vietējā uzticamība un avilability ievada kā sērija vērtību katra standartiem un elementu pati.

Vēl viens piemērs, ja komponents Apiešķīris standarti B, C, Un Dbet tikai standarta Bir gan MTBF un MTTR vērtību, bet standarts Cir tikai MTBF vērtību un standarta Dir tikai MTTR vērtību, Local Uzticamība = R (A)× R (B)× R (C), Kur R= Aprēķināts ticamība (izmantojot formulu) sastāvā / standartiem un Local Pieejamība = A (A)× A (B)× A (C), Kur A= Aprēķināts pieejamība (izmantojot formulu) sastāvā / standartiem, bet, aprēķinot A (C), jo standarts ir vienīgais ir MTBF vērtību tā 'meklējumi'par atbilstības MTTR vērtībai (-ām), un pievienot visu MTTR vērtības tā konstatē, ka don't pašiem ir atbilstošas ​​MTBF vērtību, tāpēc šajā gadījumā tas izmantotu MTTR vērtību standarts D. Ja tur bija vēl viens standarts, teiksim E, Tikai ar MTTR vērtību, kā arī pēc tam A (C)varētu izmantot MTBF par Car MTTR par Dun Eskaitīt kopā. Ja citu standartu, teiksim F, Bija tikai par MTBF vērtību, tad A (F)varētu izmantot arī MTTR par Dun Eskaitīt kopā.

Aprēķinot misija Drošums

Aprēķinot vietējo uzticamība ir jautājums, izmantojot vienkāršu formulu, aprēķinot netiešo savienojumu (misija) ir ne tik viegli, it īpaši tad, kad mums ir sarežģītas un lielas tīklus savstarpēji savītiem ceļus (līnija), un sastāvdaļām.

Ņemot visu tīklu, konta

Tā kā netiešas kopsakarības nerada fizisku savienojumu, mums ir jāatrod, kā avots komponents var nokļūt līdz galamērķim sastāvdaļu. Un tas nozīmē apskatot visu tīklu un visas dažādos veidos (un ceļiem) mūsu avots komponents var veikt, lai sasniegtu mērķi komponentu (izlietne).

Piezīme

Tik ilgi, kamēr pastāv vismaz viens pilnīgsCeļš no avota līdz galamērķim, misija būs veiksmīgaun netiešais savienojums tiek minēta kā slēgtu savienojumu.

Izpratne Link Matrix

Lai uzzinātu, kuras sastāvdaļas / tiešie savienojumi ir saistīti ar to, kas mums ir nepieciešams artefakts ātri pārbaudīt, vai divi bloki ir savienoti kādā konkrētā virzienā. Tas ir funkcija no saites matricas. Īsumā, saikne matrica ir divdimensiju masīvs Būla mainīgie, kas nosaka, vai konkrētā sastāvdaļa var sasniegt citu komponentu tieši. Tās izmēri ir vienāds ar kvadrāta kopskaita komponentu tīklā.

Vienkāršs Uzticamība Block diagramma (UBA)

Saistītās Link Matrix uzticamības blokshēma (UBA)

Tā kā ne visi savienojumi ir divvirzienu (notiek abos virzienos), ir svarīgi zināt, kā lasīt saiti matricu pareizi. Jo Drošuma novērtētāja, pirmais arguments ir avots un otrais arguments ir galamērķis (izlietne).

Tāpēc, ja saite matricu (A, B) = True, tad tas nozīmē, ka var nokļūt līdz punktam B tieši (vienvirziena). B var nokļūt, ja tikai tad, ja saite matrica (B, A) = True. Ja tā ir taisnība, tas nozīmē divvirzienu savienojumu.

Dotajā piemērā iepriekš:

· Source 1 var sasniegt galamērķi 0 (Avots 1 un Destination 0 dod rezultātu patiess); un

· Avots 0 var sasniegt galamērķi 1 (Avots 0 un Destination 1 dod rezultātu patiess), jo saikne starp 0 un 1 ir divvirzienu.

· Source 2 nevar sasniegt galamērķi 1 (Avots 2 un Destination 1 dod rezultātu False), pat tad, ja avots 1. var sasniegt galamērķi 2 (avots: 1 un Destination 2 dod rezultātu patiess). Tas ir nozīmē, ka saikne starp 1 un 2 ir vienvirziena.

Izpratne uzticamību blokshēma

Ticamība blokshēma (UBA) apkopo struktūru visa objekta modeli ziņā bloku un saites. Katrs bloks ir elements, kas ir iespēja pozitīvu vai negatīvu Saskaņā ar saites / ceļus, kas savieno tos. Gan detaļas un savienojumi var kļūt par "bloķēt", kas RBD.

Piemērs Rbd Bloki un saites

Skaitlis Iepriekš pārstāv Rbd piemērs. Pārtrauktā sarkanā līnija ir viena misija 4 ar 1. piezīmi, kā tur ir tikai divi iespējamie ceļi misijas 4 pret 1.

Aplūkosim ceļu 4 līdz 3 līdz 0 līdz 1, un ceļu no 4. līdz 7. līdz 1. punktētā blokiem 2, 5un 6. pārstāvēt blokiem, kas neietekmē mazspēja / ne-neveiksmes misijas 4 līdz 1. Tās netiek izskatīti un tiek ignorētas. Tas ir svarīgi, jo lielākajai daļai misijām būs liels skaits atlaisto blokiem, kas neietekmēs konkrēta misijas panākumus. Tas ir vairāk redzams lielākiem tīkliem kuru skaits atlaisto bloki dos modelēšanas rezultāti neprecīzi.

Lai paātrinātu simulācijas laikā, un nodrošināt precīzākus rezultātus, ir nepieciešams abstrakts no visas RBD un izmantot tikai tos elementus, kas ietekmē misijas panākumus.

Piezīme

Viens ceļš / taka nevar iet caur jebkuru sastāvdaļu divreiz.

Šajā posmā mēs varam izveidot saiti matricu un veikt Monte Carlo simulācijas.

Aprēķinot Arhitektūra Pieejamība

Arhitektūra pieejamība ir varbūtība, ka visi netiešas kopsakarības būs pieejami jebkurā brīdī. Par katru netiešo savienojuma pieejamība tiek noteikta katra atkārtojuma no Monte Carlo simulācijas laikā, tomēr šie netiešie savienojumi (parasti) balstās uz to pašu kopu fiziskiem elementiem. Tāpēc, vienkārši sasummējot šie atsevišķie pieejamību būtu "double-count" šos ANO resursiem, sniedzot pesimistisku vispārējo arhitektūras pieejamību. Alternatīvi, kopējais arhitektūra pieejamība tiek aprēķināta, aplūkojot katra atkārtojuma un redzot to, vai iesaistītas netiešās savienojumiem interešu elementi ir pieejami. Un tad summējot šos rezultātus beigās simulāciju.

Running uzticamību simulators

Lai modelētu savu arhitektūru attiecībā uz uzticamību

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Atlasīt Analīze| Uzticamība.

3. Izvēlieties ArhitektūraJūs vēlaties, lai novērtētu no nolaižamās izvēlnes.

Piezīme

Pēc noklusējuma ABACUS automātiski izvēlēsies pirmo arhitektūru, par kuru atkārtoti simulācija ir nepieciešama sakarā ar jebkādu bāzes īpašuma vai strukturālām izmaiņām.Šis izceļot tiek parādīts Sarkans uz Simulācijas rīkjosla .

4. Izvēlieties Sastāvdaļasun SavienojumiJūs vēlaties, lai novērtētu no standarta elements izvēles logs izmantojot "Rādīt tiešajiem savienojumiem" un "Show Procesi savienojumi 'radio-pogas filtriem apakšējā kreisajā dialogā, lai palīdzētu jums ar izvēli.

Papildu Rūtiņauz standarta elements izvēles logs

· Save pārveidots modelisgriba ietaupīt kopiju RBD pārveidota versijas projekta tajā pašā mapē, kā pašreizējā projektā un pievienot "_transformed" projekta nosaukuma.Tas pārveidots projektu var izmantot, lai diagnosticētu detalizēti uzticamību simulācija ar ABACUS uzņēmusies.

Papildu Radio-Pogasuz standarta elements izvēles logs

· Rādīt tiešo savienojumu automātiski noteikt savienojuma īpašumu filtru Īpašuma veids = Behaviour, name = ieguvei un vērtība = tiešs.Šī opcija ir atlasīta pēc noklusējuma un AIDS izvēli "tiešajām" savienojumiem, kā aprakstīts iepriekš, un zemāk.

· Rādīt procesi Connections automātiski noteikt savienojuma īpašumu filtru Īpašuma veids = Behaviour, name = Attiecības un vērtība = procesiem.Šī iespēja noder, lai veiktu izvēli "tiešajām" savienojumiem, kā aprakstīts iepriekš, un zemāk.

5. Uzklikšķiniet Nākamais.

6. Izvēlieties Komandējumiti Savienojumi vēlaties iekļaut simulācijas.

7. Uzstādīt Run Time Scale Factorslider.

Piezīme

Augstākas vērtības dos vairāk statistiski konsekventus rezultātus, bet nepieciešams ilgāks laiks, lai aprēķinātu.

Rūtiņas

· Parādīt Slēgts Connectionsgriba automātiski filtrētu pieejamos savienojumus, ka tikai tie, kas ir vismaz vienu pilnu fizisko ceļu no avota sastāvdaļas uz galapunkta sastāvdaļu kā vienu Rbd atlases aprakstīts iepriekš.

· Rādīt netiešas kopsakarības automātiski noteikt savienojuma īpašumu filtru Īpašuma veids = Behaviour, name = ieguvei un vērtība = netieša.Šī opcija ir atlasīta pēc noklusējuma un AIDS izvēli par "netiešo" vai misijas savienojumiem, kā aprakstīts iepriekš, un zemāk.

Pogas

· Visiizvēlas visu savienojumi.

· Apgāztdeselects visi pašlaik izvēlētais savienojumi un izvēlas visi tie, kas netika izvēlēts.

· Neviensdeselects visu savienojumi.

Citas iespējas

· Run Time Scale Factor kontrolē simulācijas laiku un precizitāti ar augstāku vērtības ražaingvairāk statistiski konsekventus rezultātus, bet ņemot ilgāks laiks, lai skrējiens.

Piezīme

Kad ABACUS aprēķina skaitu iterāciju lai modelētu tā noteiks visticamākais elements, kas nav pilnīgi ticama un tad simulēt uz Run Time mēroga koeficienta reizes 1 pār nepieejamības šī elementa plus 1 atkārtojuma. Vai (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Tas nepieciešams, lai pārliecinātos, ka šis elements joprojām neizdodas vismaz reizi simulāciju. Piem Ja visticamākais elements, kas nav pilnīgi uzticams ir 10000 stundas MTBF un MTTR 8 stundas tad simulācija notiks (10000 + 8) / 8 = 1251 reizes Run laiks Mēroga koeficients + 1 atkārtojumiem.

· Gadi, lai Stimulēt Ahead Nosaka gadu skaits misijai uzticamība jāaprēķina.

· NSkaits Pavedienudetermines skaits apstrādes pavedieni izmantot Monte-Carlo simulācijas.Šī iespēja būs noklusējuma, lai atbilstu skaitu pieejamo CPU / serdeņiem (ieskaitot Hyper-Threading serdes), lai samazinātu kopējo simulācijas laikā.

8. Uzklikšķiniet Finišsun jūs saņemsiet Brīdinājumsdialog.

9. Pēc izvēles izpētīt brīdinājumus, noklikšķinot Sīkāka informācija >>.

10. Uzklikšķiniet Turpināt.

Piezīme

Šajā brīdī, ABACUS veiks Monte-Carlono arhitektūras simulācijas un pēc neilga laika (ar progresa stieņu atsauksmes) parādīsies pilns dialogs aprēķins.

11. Uzklikšķiniet labiatzīt simulāciju.

Gals

Mācību kursiem un turpmāku palīdzību ticamība Simulācijas lūdzu, skatiet Avolution Kopiena .

Komponentu un Connection Properties

Tabulā sastāvdaļu un"tieša"savienojuma īpašības nepieciešamas, lai novērtētu ticamību. Šīs īpašības tiks parādīts Properties loga ar īpašuma ievades rinda atlasītājs ikonas ( [image] ) Ar Tooltip "Uzticamība ievades". Maiņa uz kādu no šiem "ievadi" īpašībām un dažādas strukturālās izmaiņas repozitorijā radīs uzticamību simulatorā pieprasa atkārtotu simulāciju, kā norādīts Sarkans uz Simulācijas rīkjosla .

Type | Nosaukums | Noklusējuma vērtība | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzticamība | MTBF | ∞ | gadi, nedēļas, dienas vai stundas | Decimal | Patiess | Tajā pašā laikā, pirms neveiksmes elementa. Piezīme: Vērtības var izteikt vienībās gadiem, nedēļu, dienu vai stundu, un tiek konvertētas pēc '24 / 7 'pieejamības koncepciju šādi; - 1 gads = 52 nedēļas jeb 365 dienas vai 8,760 stundas - 1 nedēļa = 7 dienas vai 168 stundas - 1 diena = 24 stundas
Uzticamība | MTTR | 0 | gadi, nedēļas, dienas vai stundas | Decimal | Patiess | Vidējais laiks līdz Remonts elementa. Piezīme: Vērtības var izteikt vienībās gadiem, nedēļu, dienu vai stundu, un tiek konvertētas pēc '24 / 7 'pieejamības koncepciju šādi; - 1 gads = 52 nedēļas jeb 365 dienas vai 8,760 stundas - 1 nedēļa = 7 dienas vai 168 stundas - 1 diena = 24 stundas

Tabulā sastāvdaļu un"tieša" savienojuma īpašības izlaide uzticamības vērtētājs. Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Uzticamība Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un uzticamību simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzticamība | Uzticamība - x gadi |  | Decimal | Nepatiess | Varbūtība, ka elements nepievils nākamo x gadu laikā. Tas ir ar vērtību no 0 līdz 1.
Uzticamība | Neuzticamība - x gadi |  | Decimal | Nepatiess | Varbūtība, ka elements nebūs nākamajos x gadu laikā. Tas ir ar vērtību no 0 līdz 1.
Uzticamība | Pieejamība | % | Decimal | Nepatiess | Aprēķinātais pieejamība komponentu vai savienojumu. Tas ir vērtība no 0% līdz 100%.
Uzticamība | Nepieejamība | % | Decimal | Nepatiess | Aprēķinātais nepieejamība komponentu vai savienojumu. Tas ir vērtība no 0% līdz 100%.

Nākamajā tabulā ir uzskaitīti 'netiešs'savienojuma īpašības izlaide uzticamības vērtētājs. Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Uzticamība Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un uzticamību simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzticamība | Misija Uzticamība - x gadi |  | Decimal | Nepatiess | Varbūtība, ka netiešais savienojums nepievils nākamo x gadu laikā. Tas ir ar vērtību no 0 līdz 1.
Uzticamība | Misija neuzticamību - x gadi |  | Decimal | Nepatiess | Varbūtība, ka netiešais pieslēgums neizdosies nākamajos x gadu laikā. Tas ir ar vērtību no 0 līdz 1.
Uzticamība | Pieejamība | % | Decimal | Nepatiess | Aprēķinātais pieejamība netiešajā savienojumu. Tas ir vērtība no 0% līdz 100%.
Uzticamība | Nepieejamība | % | Decimal | Nepatiess | Aprēķinātais nepieejamība netiešajā savienojumu. Tas ir vērtība no 0% līdz 100%.

Arhitektūra Properties

Tabulā arhitektūras īpašības izlaidi par uzticamības vērtētājs. Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Uzticamība Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši sakarā ar pamata īpašuma vai strukturālo izmaiņu repozitorijā un uzticamību simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Vienība | Datu tips | Nepieciešamais | Apraksts
Uzticamība | Pieejamība | % | Decimal | Nepatiess | No visiem netiešajiem savienojumiem, kas ir iekļauti novērtēšanā pieejamība. Tas nozīmē, ka varbūtība, ka visinetiešas kopsakarības būs pieejams konkrētajā brīdī. Tas ir vērtība no 0% līdz 100%. Piezīme: Šis nav reizināšanas individuālo pieslēguma resursiem, jo ​​tas būtu "dubulta uzskaite" ANO pieejamību attiecīgo sastāvdaļu.
Uzticamība | Nepieejamība | % | Decimal | Nepatiess | Par netiešo savienojumu, kas ir iekļauti novērtēšanā nepieejamība. Tas nozīmē, ka varbūtība, ka vismaz viensnetiešais pieslēgums būs pieejams kādā noteiktā brīdī. Tas ir vērtība no 0% līdz 100%. Piezīme: Šis nav reizināšanas individuālo pieslēguma unavailabilities jo tas būtu "dubulta uzskaite" ANO pieejamību attiecīgo sastāvdaļu.
Uzticamība | Misija Uzticamība - x gadi |  | Decimal | Nepatiess | Varbūtība, ka visas netiešās savienojumu, kas ir iekļauti izvērtēšanā tiks nepievils, ka nākamajos xgadiem. Tas ir vērtība starp 0 un 1. Piezīme: Šis nav reizināšanas individuālo pieslēguma reliabilities jo tas būtu "dubulta uzskaite" ANO pieejamību attiecīgo sastāvdaļu.
Uzticamība | Misija neuzticamību - x gadi |  | Decimal | Nepatiess | Varbūtība, ka vismaz tas ir iekļauti izvērtēšanā viens no netiešajām savienojumu neizdosies laikā nākamais xgadiem. Tas ir vērtība starp 0 un 1. Piezīme: Šis nav reizināšanas individuālo pieslēguma unreliabilities jo tas būtu "dubulta uzskaite" ANO pieejamību attiecīgo sastāvdaļu.


Imitē Atklātība

Navigācija: Imitē savu arhitektūru> Simulātori>

Imitē Atklātība

Nosūtīt komentārus par šo tēmu.

Atvērtība simulators nosaka, cik lielā mērā arhitektūras un tā elementi ir "atvērta", tas ir, spēja sistēmas rīkoties komponentu nomaiņa ar minimālu ietekmi.

Lai modelētu savu arhitektūru ziņā atklātību

1. Pārliecinieties, vai ir Abacus fails, Kas satur Jūsu apdzīvots arhitektūra, atvērts.

2. Izvēlieties analīze | Atklātība.

3. Izvēlieties Arhitektūra (-i)Jūs vēlaties iekļaut novērtēšanā.

Piezīme

Pēc noklusējuma ABACUS automātiski izvēlēsies pirmo arhitektūru, par kuru atkārtoti simulācija ir nepieciešama sakarā ar jebkādu bāzes īpašuma vai strukturālām izmaiņām.Šis izceļot tiek parādīts Sarkans uz Simulācijas rīkjosla .

4. Uzklikšķiniet Finišsun jūs saņemsiet Brīdinājumsdialog.

5. Pēc izvēles izpētīt brīdinājumus, noklikšķinot Sīkāka informācija >>.

6. Uzklikšķiniet Turpināt.

Piezīme

Šajā brīdī, ABACUS uzstāsies strukturālu novērtējumu arhitektūrā (-iem) un pēc neilga laika (ar progresa stieņu atsauksmes) parādīsies pilns dialogs aprēķins.

7. Uzklikšķiniet labiatzīt simulāciju.

Gals

Mācību kursiem un turpmāku palīdzību uz atklātību novērtēšanas lūdzu, skatiet Avolution Kopiena .

Komponentu un Savienojuma Standarta Properties

Tabulā ir uzskaitītas sastāvdaļas un savienojuma standarta īpašības, kas nepieciešamas, lai izvērtētu atklātību.Šīs īpašības tiks parādīts Properties loga ar īpašuma ievades rinda atlasītājs ikonas ( [image] ) Ar Tooltip "Atklātība ievades". Maiņa uz kādu no šiem "ievadi" īpašumiem repozitoriju radīs atklātību simulatorā pieprasa atkārtotu simulāciju, kā norādīts Sarkans uz Simulācijas rīkjosla .

Type | Nosaukums | Noklusējuma vērtība | Vienība | Datu tips | Nepieciešamais | Apraksts
Atklātība | Standarti-Standard Termiņš-organizācija Level |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Līmenis atbildīgās standartu Body 0:Organizācijas / Patentēti 1:Konsorcijs / Defacto 2:Valsts / Military 3:Starptautisks
Atklātība | Standarti-Standard Termiņš-Status |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Apstiprinājumu līmenis sasniegts ar standartu struktūra 0:Darba / Komitejas projekts 1:Public projekts / balloted 2:Pagaidu projekts 3:Apstiprināts
Atklātība | Standarti-Standard Termiņš-stabilitāte |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Vai standarta iespējams mainīt? 0:Standard novecojis 1:Ļoti mainīties nākamās 1 līdz 2 gadiem 2:Zinu Change / atjauninājumus esošās funkcijas 3:Ļoti stabils (bez izmaiņām 2 gadu laikā)
Atklātība | Standarti-Standard Termiņš-Vendor Support |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Vendor Support 0:Nav produktu vai pārdevēji atbalstīt standarts 1:Viens vai vairāki pārdevēji, kas īsteno daļu no standarta 2:Vairāk nekā viens pārdevējs ar produktiem, kas īsteno visas daļas standarta 3:Daudz vairāk nekā viens pārdevējs ar produktiem, kas īsteno visas daļas standarta
Atklātība | Standarti-Standard skaidrība-Dokumentācija |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Kvalitātes standarta dokumentācijas 0:Nabags 1:Godīgi 2:Labs 3:Teicams
Atklātība | Standarti-Standard skaidrība-Standard Platums |  |  | Vesels skaitlis | Nepatiess | Funkciju skaitu. Skaitījuši zemākais līmenis standarta funkcijas - SF
Atklātība | Standarti-Standard skaidrība-Sm |  | % | Decimal | Nepatiess | No kopējā skaita funkcijas īpatsvars, kas ir obligāti
Atklātība | Standarti-Standard skaidrība-So |  | % | Decimal | Nepatiess | No kopējā skaita funkcijas īpatsvars, kas ir obligāta
Atklātība | Standarti-Standard skaidrība-Sc |  | % | Decimal | Nepatiess | No kopējā skaita funkcijas īpatsvars, kas ir nosacīti definēti
Atklātība | Profili-Profile Dokumentācija-Documentation |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Kvalitātes standarta dokumentācijas 0:Neviens 1:Nabags 2:Godīgi 3:Teicams
Atklātība | Profili-Profile Dokumentācija-Precizitāte |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Vai dokumentācija atspoguļo faktisko sistēmu projektēšana? Ko līmenis no profila funkcijas tiek izmantoti sistēmā? 0:Nav pazīmes 1:Dažas funkcijas 2:Lielākā daļa iezīmes 3:Visas funkcijas
Atklātība | Profili-Profile Dokumentācija-Termiņš |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Vai profilu nobriedis un pieejams? 0:Ad-hoc 1:Projekta pamatā 2:Organizatoriskā 3:Publisks
Atklātība | Profili-Profile skaidrība-Nepārprotama Platums |  |  | Vesels skaitlis | Nepatiess | Skaits standarta funkcijas, kas noteiktas kā prasīts profilā
Atklātība | Profili-Profile skaidrība-PM |  | % | Decimal | Nepatiess | Obligātu funkcijas profilā procents
Atklātība | Profili-Profile skaidrība-Po |  | % | Decimal | Nepatiess | Fakultatīvo procentuālais funkcijas profilā
Atklātība | Profili-Profile skaidrība-PC |  | % | Decimal | Nepatiess | Nosacīti procentpunktiem DEFINĒTAJĀ funkcijas profilā
Atklātība | Profili-Profile skaidrība-Coverage |  | % | Decimal | Nepatiess | Standarta funkcijām procents īpaši aplūkots profilā
Atklātība | Profili-Profila paplašinājumi-Extension Platums |  |  | Vesels skaitlis | Nepatiess | Skaits nav standarta funkcijas, ko noteikusi profils
Atklātība | Profili-Profila paplašinājumi-Coverage |  | % | Decimal | Nepatiess | Pagarinājumus procents sīki profilā
Atklātība | Produkti, produktu pieejamība un Atbilstība-grozs Preču |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Produktu skaits atbalstīt obligātās funkcijas standarta 0:Nav produktu atbalstīt standarts 1:Viena vai vairākas ierīces īstenot daļu no standarta 2:Vairāk nekā viens produkts īsteno visus šī standarta daļas 3:Daudz vairāk nekā viens produkts īsteno visus šī standarta daļas
Atklātība | Produkti, produktu pieejamība un Atbilstība-Application Atbilstība |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Kāda līmeņa atbilstība to produkti ir standarta? 0:Neviens 1:Pretendē 2:Pierādīta 3:Sertificēts un demonstrēšanai
Atklātība | Produkti, produktu pieejamība un Atbilstība-Atbilstība Quality |  | [0 | 1 | 2 | 3] | Meklēt / saraksts | Nepatiess | Kvalitāte atbilstības testēšanas 0:Neviens 1:In-house testēšana pēc produkta izstrādātājs 2:Neatkarīgā testēšanas (piemēram NIST) 3:Pierādīta saistībā ar attiecīgā produkta

Komponents, Savienojums un Arhitektūra Properties

Tabulā detaļas, savienojumu un arhitektūras īpašības izejas atvērtība vērtētājs. Visi no šādām īpašībām novērtēt, lai starp nulli (0) un trīs (3), nulle (0) ir vismaz vēlams un trīs (3), kas ir visvairāk vēlams.Šīs īpašības tiks parādīts Properties loga ar īpašuma izejas rindu atlasītājs ikonas ( [image] ) Ar Tooltip "Atklātība Output". Bulta uz ikonas izcelt Sarkans ( [image] ), Ja šīs īpašības ir novecojuši, jo pamatā esošā īpašuma izmaiņas repozitorijā un atvērtību simulatoru pieprasa atkārtotu simulācijas saskaņā ar Sarkans izceļot uz Simulācijas rīkjosla .

Type | Nosaukums | Datu tips | Nepieciešamais | Apraksts
Atklātība | Atklātība | Decimal | Nepatiess | Kopumā novērtējums posteņa atvērtību.
Atklātība | Standarti-Standard Termiņš | Decimal | Nepatiess | Pašreizējais stāvoklis standarta, atspoguļojot to, vai tā ir vai nav apstiprināts, cik ilgi tas ir bijis izmantot un cik labi pieņemts tas ir kopienā izstrādātājiem.
Atklātība | Standarti-Standard skaidrība | Decimal | Nepatiess | Standartu skaidrība, atspoguļojot potenciālo neskaidrības izrietošajām standartiem
Atklātība | Profili-Profile Dokumentācija | Decimal | Nepatiess | Cik lielā mērā saskarne profilu dokumentācija ir izstrādāta un vai profils dokumenti atspoguļo faktisko sistēmu projektēšanas un / vai īstenoti sistēma
Atklātība | Profili-Profile skaidrība | Decimal | Nepatiess | Detalizācijas līmenis sniegta profila / profila specifikāciju
Atklātība | Profili līmeņa paplašinājumi | Decimal | Nepatiess | Pakāpe, līdz kurai profils atbilst standarta, uz kuras tā ir balstīta
Atklātība | Produkti, produktu pieejamību un Atbilstība | Decimal | Nepatiess | To, vai ir atvērts standarts standartatbilstība produkti pieejami izmantošanai šajā projektā


Standarta Ziņojumi

Navigācija: Ziņojums par jūsu arhitektūru>

Standarta Ziņojumi

Nosūtīt komentārus par šo tēmu.

ABACUS " standarts ziņojumi ļauj jums iegūt sarakstu ar detaļām un savienojumiem vienu vai vairākas no jūsu arhitektūru. Ziņojumā ietver visu informāciju, kas saistīta ar detaļām un savienojumiem izvēlēti, tostarp informāciju par sastāvdaļu vai pieslēguma vietu hierarhijā, tipa, standartiem, aprakstu, īpašību un tā pielikumiem.

Piezīme

Ziņojumā saturs irkonfigurējamaTurpmāk caur dialog Paziņo aprakstītās iespējas, tomēr, to uzzinātu vairāk informācijas par to, kā izveidot pilnībā konfigurējams pasūtījuma ziņojumiizmantojot ABACUS Custom Ziņojumi, Lūdzu atsaukties uz tēmu šeit vai kontakts Avolution Support .

Lai apskatītu standarts ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra(i).

2. Atlasīt Ievietot| Standard pārskatsvai noklikšķiniet uz Izveidot Standard pārskatu rīkjoslas pogu. Ziņojums konfigurācijalogs tiks parādīts.

Ziņojums konfigurācijas logs

3. Izvēlieties Arhitektūras, Sastāvdaļasun Savienojumika jūs vēlaties ziņojumā no Ziņojums konfigurācijas logs.Lūdzu, skatiet standarta Element atlase šeit temats palīdzību.

4. Tagad noklikšķiniet uz Iespējaspogu un Ziņot opcijaslogs.

Ziņojums Options logs

5. Jūs varat izvēlēties, lai parādītu Jauna lapa katram elementam, Tad Print Date, Print Time, Page Numbersun vai ietver nosaukumu galvenēZiņojuma atzīmējot / unticking attiecīgās izvēles rūtiņas. Jūs arī varat pielāgot nosaukumu un autoru, rediģējot Ziņojums Nosaukumsun Autors teksta kastes. Jūs varat arī izvēlēties, kādu saturu tiek parādīts uz ziņojumu, atzīmējot / unticking rūtiņas zem Ziņojums Contentsadaļā loga. Kad esat pabeidzis, noklikšķiniet uz labi.

6. Tagad noklikšķiniet uz FinišsŠajā ziņojumā konfigurācijas logā.

Interpretēt redzamo ziņojumu

Piemērs Radītais Ziņojums ar īsi paskaidrojumi

Lai pārvietotos pa pārskata lapas, noklikšķiniet uz ikonas [image] atrodas rīkjoslā uz augšējā kreisajā stūrī ekrānu.

Piezīme

Tu vari glābt pārskats dažādos formātos , uzklikšķinot uz Eksports ziņojums icon [image] kas atrodas uz rīkjoslu. Jūs varat izvēlēties eksportēt šādos formātos: Izcelties, PDFun Vārds. Lūdzu, saglabājiet šo ziņojumu vēlamajā vietā vēlākai izmantošanai. Ja ir veiktas izmaiņas arhitektūru vēlākā posmā, jauns ziņojums būs izveidota, lai atspoguļotu izmaiņas.

Skatīt arī

Analizējot savu arhitektūru


Custom Ziņojumi

Navigācija: Ziņojums par jūsu arhitektūru>

Custom Ziņojumi

Nosūtīt komentārus par šo tēmu.

Abacus "pasūtījuma ziņojumi ļauj jums izveidot pilnīgi konfigurējamas pielāgotus pārskatus. Ziņojumos var ietvert pasūtījuma attēlus un grafikas, kā arī sniegta informācija par sastāvdaļu un savienojumu vai atribūtus no ABACUS krātuvei, kā arī detalizētas analītisko rezultātu no dažādām simulācijām (ieskaitot TCO, veiktspēja un uzticamība). Turklāt ziņojumi var saturēt shēmas, diagrammas, katalogi, matricas / rakurstabulas, kartes, mērinstrumenti, sīkdiagrammas, datu bāri un rādītājus (piemēram, satiksmes apgaismojums).

Piezīme

Kaut arī jebkurš lietotājs var atvērt esošos pielāgotus pārskatus, to konfigurēt ziņojumi lietotāja licence būtu jānoskaidro Ziņojums konfigurācija spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

Lai apskatītu paraža ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra(i).

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs tiks parādīts.

Custom Ziņojumilogs

3. Izvēlietiesesošais Ziņojumska jūs vēlaties Parādīt no Pieejamie Ziņojumisadaļa.

4. Uzklikšķiniet Run pārskats.Ziņojumā tiks atvērts Microsoft ziņojums Viewer un to Virzīties caur pārskata lapas, noklikšķiniet uz ikonas [image] atrodas rīkjoslā uz augšējā kreisajā stūrī ekrānu.

Piezīme

Tu vari glābt pārskats dažādos formātos , uzklikšķinot uz Eksports ziņojums icon [image] kas atrodas uz rīkjoslu. Jūs varat izvēlēties eksportēt šādos formātos: Izcelties, PDFun Vārds. Lūdzu, saglabājiet šo ziņojumu vēlamajā vietā vēlākai izmantošanai. Ja ir veiktas izmaiņas arhitektūru vēlākā posmā, jauns ziņojums būs izveidota, lai atspoguļotu izmaiņas.

Līdz rediģēt krātuve datus, kas tiek nosūtīts uz a paraža ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra(i).

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs (norādīts iepriekš) tiks parādīts.

Piezīme

Kaut arī jebkurš lietotājs var atvērt esošos pielāgotus pārskatus, to konfigurēt dati, kas tiek nosūtīti uz pielāgotu ziņojumu lietotāja licence būtu jānoskaidro Ziņojums konfigurācija spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

3. Izvēlietiesesošais Ziņojumska jūs vēlaties Parādīt no Pieejamie Ziņojumisadaļa.

4. Uzklikšķiniet Klientiem Sets. Data Set Editorlogs tiks parādīts.Šis logs parāda kolekciju datu kopu, kas pašlaik tiek nosūtīti uz pielāgotu ziņojumu. Šajā piemērā zemāk ir trīs (3);

· ApplicationProxy datu kopa, kas ir norādot visas detaļas visiem piemērošanai sastāvdaļām "2015 Faktiskais" arhitektūrā (ieskaitot īpašībām par to standartu un visi ar komponentu),

· TwoDViewProxy datu kopa, kas ir norādot vienu vai vairākas diagrammas, kur nosaukums atbilst "Application Ainava (Austrālija)",

· TargetProxy datu kopa, kas ir norādot visas detaļas visām mērķa savienojumiem "2015 Faktiskais" arhitektūras (ieskaitot pievienotajiem sastāvdaļām).

Data Set Editorlogs

Piezīme

Query nosaukums tiks izmantots datu kopas nosaukumu Microsoft Report Builder (skatīt zemāk). Iekļaut laukā norāda, vai datu kopa ir vai nu viens elements, kolekciju Elements, visas to sastāvdaļas veidi, visus savienojuma veidu, viens vai vairāki arhitektūra, vienai vai vairākām diagrammām vai viens vai vairāki Charts. Par "kolekcijas elementu" datu kopas poga filtrs ir paredzēts, kas, kad uzklikšķināt atver Element Filter logu, kas ļauj piemērot vairākus filtrus, lai atgrieztos tikai elementus no dažiem arhitektūru, un / vai noteiktu veidu, un / vai ar noteiktiem standartiem , un / vai pievieno dažām detaļām, un / vai ar konkrētiem vecākiem, un / vai atsevišķos diagrammas, un / vai atsevišķās diagrammas un / vai ar dotajiem īpašuma vērtības. Attiecībā uz citiem datu kopu veidiem tiek nodrošināta, un, izmantojot izvēles pogu, jūs varat izvēlēties objektu (-iem), kas iekļauts ar datu kopas nosaukumu lauks.

Piezīme

Datu kopas, tiek saglabāti uzData Sets failu (.xml)ar to pašu bāzes faila nosaukumu kā saistīta Ziņojums Definition fails (.RDL). Ja šis fails neeksistē datu kopa redaktors automātiski aizpildīt ar jebkuru pieprasījumu nosaukumiem, kas pastāv Ziņojums Definition fails (.RDL)un jaunu Data Sets failu (.xml)tiks izveidots tiklīdz ir noteikta aa derīgs saraksts vaicājumiem.

3. Ja vēlaties, lai dzēstu esošu datu kopu, tad izvēlieties Dzēst Querypoga.

4. Ja vēlaties pievienot jaunu datu kopu, tad noklikšķiniet uz Pievienot jaunu datu kopapogu un konfigurēt datu kopumu kā vienu virs piezīmi.

Līdz izveidotu jaunu pielāgotu ziņojums(no veidnes)

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs (norādīts iepriekš) tiks parādīts.

3. Uzklikšķiniet Jauns un atlasiet A4 - Portrait, A4 Landscape, A3 - Portrait, A3- Landscape, US Letter - Portrait, US Letter - Landscape, ASV Tabloid - Portraitvai ASV Tabloid - Landscapeatkarībā no pārskata orientāciju un papīra izmēru, kas ir vēlama.

4. Pārlūkojiet atrašanās vietu, lai saglabātu ziņojumu definīciju failu (.rdl / .rdlc) un attiecīgais datu kopa failu (xml) un noklikšķiniet Saglabāt. Tas būs pievienot jaunu pielāgotu ziņojumu pieejamie ziņojumi sadaļā Custom Ziņojumi logu un to var atvērt vai rediģēt, kā aprakstīts iepriekš.

Līdz pievienot esošu pasūtījuma ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs (norādīts iepriekš) tiks parādīts.

3. Uzklikšķiniet Pievienot un pārlūkojiet vietu ziņojumu definīciju failu (.rdl / .rdlc) un noklikšķiniet Atvērts. Tas būs pievienot jaunu pielāgotu ziņojumu pieejamie ziņojumi sadaļā Custom Ziņojumi logu un to var atvērt vai rediģēt, kā aprakstīts iepriekš.

Piezīme

Tiek pieņemts, ka saskaņošanas Data Set fails (.xml) pastāv tajā pašā vietā, kur ziņojums definīciju failu.

Līdz kopēt esošu pasūtījuma ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs (norādīts iepriekš) tiks parādīts.

3. Izvēlietiesesošais Ziņojumska jūs vēlaties kopēt no Pieejamie Ziņojumisadaļa.

4. Uzklikšķiniet Kopija un kopiju izvēlēto ziņojuma (nosaukta "kopija ...") tiks pievienota pieejamie ziņojumi sadaļā Custom Ziņojumi logu un to var atvērt vai rediģēt, kā aprakstīts iepriekš.

Piezīme

Tādā veidā jūs radīs kopiju ziņojuma Ziņojums Definīcija fails (.rdl / .rdlc) kā arī tās saskaņojot Data Set fails (.xml)(ja tas ir).

Līdz esoša pasūtījuma ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs (norādīts iepriekš) tiks parādīts.

3. Izvēlietiesesošais Ziņojumska jūs vēlaties noņemt no Pieejamie Ziņojumiiedaļā un klikšķi Noņemt.

Piezīme

Noņemot ziņojumu tas vairs neparādīsies uz ziņojumu sarakstā. Tomēr tas nebūs dzēst Ziņojuma ziņojums definīcija fails (.rdl / .rdlc) vai Data Set fails(.xml). Ja nepieciešams, dzēšot šos failus var panākt, izmantojot failu sistēmu.

Līdz pārdēvēt esošu pasūtījuma ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs (norādīts iepriekš) tiks parādīts.

3. Izvēlietiesesošais Ziņojumska jūs vēlaties pārdēvēt in Pieejamie Ziņojumiiedaļā un klikšķi Pārdēvēt.

4. Ievadiet jaunu nosaukumu ziņojumu.

Piezīme

Gan ziņojums Definition fails (.rdl / .rdlc) un saskaņojot datu Set fails (.xml) tiks atbilstoši pārdēvēta.

Līdz rediģēt, izstrādājot paraža ziņojums

1. Pārliecinieties, vai ir ABACUS fails atvērts satur Jūsu apdzīvots arhitektūra.

2. Atlasīt Ievietot| Custom ziņojumsvai noklikšķiniet uz Izveidot pielāgoto pārskatu rīkjoslas pogu. Custom Ziņojumilogs (norādīts iepriekš) tiks parādīts.

Piezīme

Kaut arī jebkurš lietotājs var atvērt esošos pielāgotus pārskatus, to konfigurēt dizains pasūtījuma ziņojumus lietotāja licence būtu jānoskaidro Ziņojums konfigurācija spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.Bez tam, Microsoft Report Builder 3.0 ir nepieciešama, lai izstrādātu ziņojumus un to var lejupielādēt bez maksas no šeit .

3. Izvēlietiesesošais Ziņojumska jūs vēlaties Parādīt no Pieejamie Ziņojumisadaļa.

4. Uzklikšķiniet Edit pārskats.Ziņojumā tiks atvērts Microsoft Report Builder 3.0. Par konkrētu palīdzību un dažiem "padomus un trikus," uz kādu no biežāk uzdevumus ar projektēšanas ziņojumi, lūdzu, skatiet tālāk sadaļās. Vispārīgu palīdzību uz projektēšanas ziņojumus lūdzu, skatiet uz Microsoft Report Builder 3.0 palīdzības lappusēm šeit .

Pievienojot tabulas jūsu ziņojumu

1. Pārliecinieties, vai ir ABACUS Custom ziņojums Definition fails (.rdl / .rdlc) atvērt Microsoft Report Builder 3.0.

2. Atlasīt Ievietot tab no "lenti" augšpusē, tad noklikšķiniet uz Galds pogadatos, Reģionu sadaļā un izvēlieties Ievietot tabula.

3. Tagad velciet kursoruuz viedokli par ziņojumu audekla kur vēlaties augšējā kreisajā stūrī galda novieto. Noklikšķiniet uz audekla. Pēc noklusējuma tabula tiks pievienota ar galvenes rindu un tad detaļas grupā (grupa tiek izmantota, lai organizētu skats uz ziņojumu datu kopā). Lai noņemtu grupu, vai nu svītrot rindu vai dzēst rindu Group Grupējuma rīkjoslā.

Galss

Formulas / Expressions tabulā šūnās ir rediģējis izvēloties šūnas, tad ar peles labo pogu noklikšķinot uz << izteiksme >> tekstu un atlasot izteiksmi .... Šķirošanas rindas tabulā tiek darīts, izvēloties galdu un pēc tam pārlūkojot leju, uz otru -> SortExpressions lauka Properties panelī un ievadot izteiksmi. Attiecībā uz kopējo kārtas beigās tabulas pievienot rindu pēc (un ārpus tās) grupēšanu un pēc tam izmantot šādu izteiksmi = Sum (Fields!Nosaukums.Value)kur "Nosaukums" ir lauks tiek sasniedza. Lai pieteiktos krāsošana uz kolonnas izmantot "IIF" paziņojumu īpašumā BackgroundColor. Lai pievienotu mērierīci kā šūnā tabulā vispirms ievietojiet gabarītu šūnā un tad kritums datu laukus, kas nepieciešami, lai mērierīces. Labojot augstumu & platumu tabulas rindas, nodrošinātu jums izvēlēties pareizo rindu, un pēc tam virziet peles kursoru ap pelēkajiem līnijas, līdz jūs saņemsiet bultu uz augšu / leju kursoru, tad mainīt.

Pievienojot Charts uz jūsu ziņojumu

1. Pārliecinieties, vai ir ABACUS Custom ziņojums Definition fails (.rdl / .rdlc) atvērt Microsoft Report Builder 3.0.

2. Atlasīt Ievietot tab no "lenti" augšpusē, tad noklikšķiniet uz Diagramma pogadatos, Reģionu sadaļā un izvēlieties Ievietot Chart.

3. Tagad velciet kursoruuz viedokli par ziņojumu audekla kur vēlaties augšējā kreisajā stūrī, diagrammas, lai ievietots. Noklikšķiniet uz audekla un tad Izvēlieties diagrammujums ir nepieciešama no iespējām un klikšķi labi.

Galss

Lai parādītu rekvizītu kā anotācijā kartēs, tiesības noklikšķiniet uz diagrammas un izvēlieties Show datu Etiķetes, tad izvēlieties vienu no etiķetēm, kas ir pievienoti, un noteikt Misc -> UseValueAsLabel uz False Properties panelī un pievienot izteiksmi (piemēram, = Name.Value) in Misc Lauki -!> Label. Īpaši par burbulis grafiki; Bubble grafiki tiek parādīti ar Scatter diagrammas pozīcijā. Drop X asi īpašumu sērijveida laukiem (vai pievienot sērijās Properties). Drop y asi īpašumu datos laukiem (vai pievienot sērijās Properties). Lai izmantotu īpašumu, lai definētu burbulis lielumu, piliens to vērā datu laukus (vai pievienot sērijās Properties). Bubble diagrammas nevar parādīt, ja ir pārāk daudz datu (200 + raksti), dažkārt tas izraisa visu ziņojumu ne parādīt. Marker Type - Uzstādīt uz apli. Pēc noklusējuma, kad krītot laukus datu laukiem, tā piebilst, tos ar summa ()formula, lai noņemtu to. Īpaši par Saliek diagrammas / Timeline / Ganta diagrammas; Par Ganta diagrammas izmantot virkni diagrammu un pievienot īpašības kā augsta un zema vērtībām datu laukiem. Jums var būt vairāki "stieņi", pievienojot vairāk un vairāk diapazonu, kur Low vērtība uz vienu sakrīt ar augstu vērtību par citu. Īpaši par Sektoru diagrammas; Par kopējām sektoru diagrammas, piliens datus kategorijas laukiem un datu laukos, pievienojiet formulu = CountRows (). Filtrēt 0 vērtības (piemēram, uz izmaksu diagrammas), citādi etiķetes tie joprojām parādās uz diagrammas.

Izmantojot IIF paziņojumu pievienot krāsas tabulas un diagrammas

1. Pārliecinieties, vai ir ABACUS Custom ziņojums Definition fails (.rdl / .rdlc) atvērt Microsoft Report Builder 3.0.

2. Ar peles labo pogu noklikšķiniet uz šūnas tabulā, lai krāsu un klikšķi Tekstlodziņš Properties.

3. Atlasīt Aizpildīt un noklikšķiniet uz FXpogu pa labi no aizpildījuma krāsu etiķetes un komplektā izteiksmi BackgroundColor laukā ievadīt izteiksmi, piemēram, = IIF (Jomas! InformationStatus.Value = "Saglabāt", "tumši dzeltens", IIF (Jomas! InformationStatus.Value = "pārstrādāt", "Yellow", IIF (Jomas! InformationStatus.Value = "Refresh", "Orange", " laša "))). Tas maina fona krāsu uz gaiši zaļas uz katru šūnu, kas satur statusu "paturēt", dzeltenā par katru šūnu, kas satur statusu "pārprojektēšana" Orange katrā šūnā, kas satur statusu "Atsvaidzināt" un jebkura cita statusa vērtība tiks krāsots in 'Salmon'.

Piezīme

Krāsas var pievienot diagrammas, izvēloties sēriju uz diagrammas un pēc tam nosakot Izskats -> Color īpašuma (vai burbulis kartēm izskats -> Marker -> Color īpašums) izpausme līdzīgi iepriekš minētajā piemērā.

Izstrādājot pielāgotus pārskatus lietas, kas jāpatur prātā

· Jo visi īpašumi, izņemot Integer tiek nosūtīti kā virkne no ABACUS uz ziņojumu skatītājs, ja jūs vēlaties darīt visiem "izpausmes" ar tiem (piemēram, plaisu vienu īpašumu, ko citu vai kārtot), jums ir nepieciešams, lai pārvērstu tos aiz komata vai datums utt fona , Šis raksts ir labs atskaites. Piem = CDate (Jomas! LifecycleEndDate.Value) Piezīme: Lūdzu, pārliecinieties, ka ziņojums valoda ir iestatīta en-GB (kā aprakstīts tālāk) pieņemt dd / mm / gggg jo tā sagaida mm / dd / gggg formātā pēc noklusējuma un attiecīgi 31/7/2011 neizdosies konversiju. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields CostTotalCosttoOwnnext5years.Value!, 0)

· Ja jūs konstatējat, ka jūs cīnās, lai saglabāt visas tabulas un diagrammas vienā lapā, Ir daži galvenie veidi, kā pārvaldīt jūsu dokumentu telpas:

· Page Break - Nodrošināt, ka šī tabula uzstādījums ir izslēgts katrai tabulai, kuru vēlaties būt tajā pašā lapā.

· Keep Kopā - Nodrošināt šī tabula iestatījums ir True katrai tabulai, kuru vēlaties būt tajā pašā lapā.

· Pārvietojot lietas apkārt, tas ir vieglāk, lai tuvinātu, izmantojot kontroli apakšā labajā stūrī un pēc tam vairāku izvēlētos objektus un velciet

· Par attēla rindu tabulā, pārliecinieties, ka "lielums" | 'Šķirošana pēc lieluma "īpašums ir iestatīts uz" Fit "citādi attēla var šķist pārāk liela, vai arī tas būs slikti izstiepts.

· Līdz atkārtot galvenes rindu tabulas par katru lapuZiņojuma:

1. Atvērt Advanced Mode rūtī grupējumi. (Klikšķiniet uz bultiņas pa labi no kolonnas grupu un izvēlieties uzlabotajā režīmā.)

2. Rindā Grupas zonā (ne Kolonnas grupas), noklikšķiniet uz Static grupā, kurā ir uzsvērta atbilstošu textbox šajā tablix. Uzklikšķiniet caur katru Static grupā līdz tā izceļ kreisās malas kolonnā galvenes. Tas parasti ir pirmais Static grupa uzskaitīti.

3. Jo Properties logā, kas īpašumu RepeatOnNewPage uz True.

4. Pārliecinieties, ka īpašums KeepWithGroup ir iestatīts uz Pēc.

· Mainīt valodas iestatījumiziņojumā īpašības, lai tie atbilstu datu formāti jums ir nepieciešama, piemēram, en-GB ražot UK datuma formātu (dd / mm / gggg).

Skatīt arī

Analizējot savu arhitektūru


Publicēt tīmeklī

Navigācija: Ziņojums par jūsu arhitektūru>

Publicēt tīmeklī

Nosūtīt komentārus par šo tēmu.

ABACUS "Publicēt Web funkcija ļauj arhitektūras modeļi jāuzskata, izmantojot drošu tīmekļa vietni. Arhitektūras tiek eksportēti uz HTML formātā un ir paredzēti, lai atspoguļotu izskatu un in ABACUS Explorer. Views (ieskaitot Katalogi, diagrammas, 3D un diagrammas) tiek eksportēta formātos skatāmo, izmantojot interneta pārlūku arī.

Piezīme

Šobrīd Viedokļi un Matricas netiek publicēti.

Publicēt savu arhitektūras modeļus, lai tīmeklī

1. Pārliecinieties, vai ir attiecīgā ABACUS failsatvērts, kas satur apdzīvots arhitektūraka jūs vēlaties publicēt tīmeklī.

2. Atlasīt Fails| Publicēt ....

3. Publicēt Web konfigurācijalogs.

Publicēt Web konfigurācija

4. Pēc noklusējuma visas porcijas modeļa tiek atlasīti tostarp Tree domām, Standarti, Veidi, veidnes un arhitektūra (s). Noņemiet atzīmi porcijas jūs nevēlaties publicēt tīmeklī, tostarp jebkuras individuālo viedokļu arhitektūrā (-iem).

Gals

Ja jūs vēlaties paslēpt konkrētus sastāvdaļu un savienojumu un / vai to īpašības, ir ieteicams, ka administrators rada "sabiedrības" loma, izmantojot Abacus "loma balstīta piekļuves funkcija un pēc tam noņem Lasīt atļauja no tiem sastāvdaļu tipiem, pieslēguma veidu un / vai īpašības, ka tie nevēlas publicēt. Tad lietotājs jāieiet ar šo lomu un publicēt to internetā kā ABACUS tikai publicēs elementus, kas ir lasīšanas atļaujām kas par lomu. Turklāt lietotāji var auto-publicēt no komandrindas, kā aprakstīts šeit .

Piezīme

Jūs varat izvēlēties visus porcijas redzams, noklikšķinot uz Visipogu vai apgriezt savu izvēli, noklikšķinot uz Apgāztpoga. Jūs varat arī noklikšķināt uz Nevienspogu, lai notīrītu savu izvēli.

Piezīme

Ja jums atzīmēšanu koka skatījumā iespējutad neviens koks rāmis (skatīt zemāk), tiks publicēts. Attiecīgi, Jums vajadzētu izvēlēties sākumlapu atbilstoši turpmāk 6. soli vai Pēc publicēšanas jums būs nepieciešams, lai pielāgotu vai nu augstākā līmeņa; a) index.htmlfails, mainot "rāmja src =" mainPage.html "name =" element_details "" līniju tieši saistīt ar attiecīgo html lapas sadaļā Satura mapi, vai, b) mainPage.htmlsniedzot hipersaiti vai novirzīt uz attiecīgo html lapā zem Satura mapē.

5. Noklikšķiniet uz Option pogu un pēc Izdevējs opcijasdialog parādīs.

Publicēter opcijas

6. Sievēlēt 3D, Diagrammaun diagrammas formāti un vai parādīt nosaukumu, aprakstu vai Properties par viedokļiem izvešanu no pieejamajām iespējām (skatīt zemāk piezīmi komentārus par dažādiem formātiem).

7. Ja vēlaties, lai uzstādītu sākuma lapā publicētā modeli ar konkrētu nolūku, tad pārbaudiet Izmantojiet Skatīt kā Start Pageiespēja un pārlūkojiet skatu caur "..." pogu, kas kļūst ļāva.

Piezīme

Tikai izvēlētie jomās sadaļā, kā par 4 ātrumi viedokli iepriekš ir pieejami jānosaka kā sākuma lapu.

8. Ja vēlaties saņemt atgriezenisko saiti par īpašiem lapās publicēto modeli, tad pārliecinieties, ka E-pasta Atsauksmesir atlasīta opcija, ievadiet e-pasta adresi E-pasta adresetextboxun rediģēt E-Bodyiedaļu pēc vajadzības. Ja jūs nevēlaties, lai būtu atgriezeniskā nosūtīts tad Noņemiet atzīmi E-pasta Atsauksmesvariants un atstāj textbox tukšs.

9. Klikšķiniet uz labipoga.

10. Klikšķiniet uz Pārlūkotpoga.

11. Atrodiet mapilogs.

12. Izvēlieties vietu, kuru vēlaties saglabāt augstākā līmeņa HTML failu (un jebkurus automātiski rada failus).

Piezīme

Tā ir laba ideja, lai izveidotu īpašu mapi (parasti sauc par "Publicēts"), izmantojot Padarīt Jauna mapepogu apakšā dialogloga uzglabāt augstākā līmeņa HTML failu un jebkuru automātiski rada failus.

13. Klikšķiniet uz labipoga.

14. Mape ceļš būs displejs Directorytextbox.

15. Klikšķiniet uz Finišspoga.

- Vai -

15. Ievadiet mapes ceļš šajā Directorytextbox kur vēlaties saglabāt augstākā līmeņa HTML failu (un jebkurus automātiski rada failus).

16. Klikšķiniet uz Finišspoga.

Piezīme

Eksportu Diagrammasļoti reizēm neizdodas, visbiežāk, kad dators ir ārpus atmiņa (parasti izmantojot ļoti lielus failus). Nenokārtotā eksports tiks no jauna vienreiz. Tur būs viens brīdinājums par neizdevās sākotnējā mēģinājuma, un otrs brīdinājums, ja atkārtoti mēģinājums neizdodas. Tāpēc, ja vienīgie brīdinājumi ir "Pirmais mēģinājums neizdevās" pieredzētās, publicēt bija veiksmīga. Ja atkārtoti neizdodas mēģinājums mēģināt publicēt mazāku daļu no jūsu failu vai bez dažas sistēmas atmiņas.

Ietaupīto HTML failu (s), tagad var būt skats no tās atrašanās vietas, vai kopēts drošu tīmekļa vietni.

Publicēt tīmeklī Internet Explorer10

Jebkurš hipersaites kas tika izveidots sākotnējo modeli tiks saglabājās publicētajā modeli un uzklikšķinot uz saites sekos saiti uz savu galamērķi (ja tas tika publicēta). Turklāt jebkādi elementi publicētajiem diagrammas, kas nav jau hipersaiti sākotnējā modeļa, ko hipersaiti atpakaļ uz saviem attiecīgajiem elementiem koka skatījumā (ja tas tika publicētas) un, noklikšķinot uz elementa publicētajā diagrammā fokuss būs lēkt atpakaļ attiecīgais vieta kokā. Šī funkcija ir līdzīga "šovu Explorer" labo klikšķi funkciju ABACUS.

Piezīme

Avolution stingri iesaka šādas programmatūras un failu formātus būtu jāizmanto, lai pilnībā izmantotu Publicēt Web funkcionalitāti ABACUS:

1. Internet Explorer (80,0 un augstāk)lai apskatītu publicēto pētnieks viedokli. Mozilla Firefox (30,0 vai vēlāk)ir arī ieteicams, un pilnībā atbalstaTomēr, ja izmanto ieteikto SVG formātu diagrammās tad Firefox 9. jūs varat izmantot tikai native SVG skatītāju atbalstu, kas diemžēl neļauj attālināt vai panoramēšana.

2. Adobe SVG Viewer 3.0 iespraust (lejupielādēt no šeit ) un SVGfaila formāts, kas publicēta diagrammas. SVG attēlu formātu, lai diagrammasir ieteicams, jo; SVG ir vektora balstītu attēlu formātu, un tāpēc tas ir "zaudējumus mazāk" un izskatās daudz labāk jebkurā tālummaiņas līmenī nekā jebkurā no citiem formātiem, SVG var ievest MS Visio, SVG var pietuvināto jebkurā līmenī vai rezolūciju , SVG ir saites uz koka skatu savienojumus (ne tikai komponentiem), SVG vienmēr izdrukā ar labāku izšķirtspēju, un, SVG ir aptuveni puse no faila izmērs no citiem formātiem. PNG ir nākamais ieteikums, tomēr, kā tas ir rastrs formāts atsevišķos pietuvināšanas līmeņi skaidrība uzskata tiks zaudēts un noklikšķinot savienojumus diagrammas netiks lēkt atpakaļ uz attiecīgo vietu kokā. BMP ir atrunāja, jo, kamēr tas ir "zaudējums mazāk" formatēt faila izmērs ir 100x, ka no citiem formātiem un 20MB attēli nav nekas neparasts.

Kompromiss ar SVG ir tas, ka SVG skatītājam būs nepieciešams uzstādīt un jums ir nepieciešams, lai pārliecinieties, ka .svg image / svg + xml pievieno web serveri ir MIME tipu. Pēc uzstādīšanas SVG skatītāja Microsoft Internet Explorer lūgs jums pieņemt skatītāja licences līgumu un tad jāstrādā labi. Un tajā pašā laikāMozilla Firefox atbalsta SVG failus natively, Adobe spraudnis joprojām ir ieteicamslai varētu tuvinātu diagrammas, ja jūs izmantojat Firefox 8 vai agrāk (ja jūs izmantojat Firefox 9 nevarat atslēgt dzimtā SVG skatītāju). Kad uzstādīšana uz Adobe spraudnis ir darbināts, šādi pasākumi ir nepieciešami to izmantot Firefox:

· Atvērt Firefox un ievadiet "about: config" (bez pēdiņām) uz URL joslā.

· Ritiniet uz leju un atrast īpašumu svg.enabled(ja jūs izmantojat Firefox 9 tad dzimtā SVG skatīšanās nevar būt invalīdiem un šis īpašums neeksistē). Divreiz uzklikšķiniet uz tā, lai izslēgtu to.

· Tagad atrast direktorijā, kur ir uzstādīts SVG spraudnis (piemēram, C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Kopēt failus NPSVG3.dll un NPSVG3.zip un ielīmējiet tos Firefox plugins direktorijā (piem C: \ Program Files \ Mozilla Firefox \ plugins)

· Slēgt visus gadījumus Firefox

3. Avolution s ABACUS 3D Viewer (3.1 un augstāk)un Avolution s .abacus3Dfaila formāts publicētajos 3D skatu. Kamēr Cortona VRML Client plug-in (2.0 un augstāk)ir pieejams, lai apskatītu VRML versijas publicētajiem viedokļiem tas nav bezmaksas komerciālai lietošanai un joprojām ir nepieciešama klienta puses uzstādīšana. Abacus 3D Viewer ir vairāk iezīme bagāts nekā jebkurš VRML skatītājs un ir brīvi pieejama lejupielādei no šeit . Jebkurā gadījumā pārliecinieties, ka jūs pievienot .vrml x-pasaule / X-VRML un .abacus3d pieteikumu / okteta klipā uz web servera MIME tipiem.

4. PNGfaila formāts publicētajos diagramma viedokļiem. PNG attēlu formātu viedokļiem diagramma ir ieteicams, jo, kamēr tas ir rastrs formāts un tur ir "zaudējums" kompromiss starp faila izmēru un diagrammas skaidrības parasti ir labākais. BMP ir atrunāja, jo, kamēr tas ir "zaudējums mazāk" formatēt faila izmērs ir 20x, ka no citiem formātiem un 2MB diagrammas, nav nekas neparasts.

Ja Jūs vēlaties mainīt izskatu un justies no tīmekļa lapām, jūs varat rediģēt sākuma lapu failu ar nosaukumu mainPage.html un stila lapas failu ar nosaukumu abacus.css. Jūs atradīsiet šos failus tajā pašā mapē, kur jūs izvēlējāties, lai saglabātu augstākā līmeņa HTML failu. Plašāku informāciju par struktūru un šūšana publicētā produkcijas skatiet nākamo sadaļu.

Par ABACUS struktūra publicēts modeļus

Abacus publicēts modelis ir strukturēta šādi:

1. Mape augstākā līmeņa satur vairākus failus un pieņemot, ka visas iespējas ir iekļauti ABACUS Publicēt Web konfigurācijas logā tas ietvers indekss.htmlfails, kas sastāv no trim kadriem; treeView.html, findNode.html un mainPage.html un tad shortcutError.htmllappuse. TreeView.html ir apdzīvots ar tree.js, tree_items.jsun tree_tpl.js JavaScript failus, kas atrodas zem ietver mapes (aplūkoti turpmāk) un atkārto Explorer koku no ABACUS. FindNode.html ir powered by find.js javascript fails atrodas zem ietver mapi (aplūkoti turpmāk), un tas meklēs filiāles koku, nevis tikai redzamās mezgliem. Tviņš mainPage.html ir statisks HTML lapas, ko var pielāgot ar logotipi un tamlīdzīgiun būs redzams, ja vien sākumlapā tiek izvēlēts, publicējot.Un visbeidzot, shortcutError.html lapa ir galvenā lapa jebkuru šķelto īsceļus no koka, jo attiecīgajām lapām netiek publicēts.

Gals

Jūs varat izlaist mainPage.html kopā ar Izvēloties izmantot sākumlapu, publicējot vai modificējot index.html failu norādīt tieši uz konkrētā nolūkā (piemēram), rediģējot rāmja src = "mainPage.html" līnijas norādīt tieši uz pirmo skatu pirmajā arhitektūrā, parasti "pamata" diagrammu.

2. Augstākā līmeņa includemape saturingdažādi JavaScript (js) un kaskādes stila lapas (Css) failus ar Html faili izmanto visā publicēto modeli.

3. Augstākā līmeņa Content mape satur, Alfabētiski;

· A '3D Views' mape arnumurētasHTML lapas un VRML vai abacus3d fails par katru publicēto 3D skatiem. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· Arhitektūras mapi ar numurētu HTML lapas par katru arhitektūru, kas tika publicēts. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· A Katalogi mape satur numurētu HTML lapu par katru publicēto katalogos. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· A Charts mape arnumurētasHTML lapas un PNG, JPG utt fails par katru publicēto Chart uzskatiem. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· A Sastāvdaļas mapi, kurānumurētasHTML lapu par katru no publicētajiem komponentu. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· A Savienojumi mapi, kurānumurētasHTML lapu par katru no publicētajiem savienojumiem. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· A Diagrammas mapi, kurānumurētasHTML lapas un PNG, SVG etc fails par katru publicēto diagrammas. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· ikonas sub-mape ar dažādus attēlus izmanto visā publicēto modeli.

· A Standarti sub-mapes arnumurētasHTML lapa jebkurš standartikas tika publicēti. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

· A Veidnes sub-folder ar savākšanas numurētas sub-mapes par katru publicēto no projekta veidnes. Katrā sub-mapes ir komponenti un Connections mapi un to robežās ir numurētas HTML lapas par katru sastāvdaļu un pieslēgumu no veidnes. Skatīt piezīmi zemāk, lai iegūtu informāciju par mapi / failu numerācijas shēmu.

· A Veidi sub-mapes ar komponentes unSavienojums sub-mapes arnumurētasHTML lapa jebkuras sastāvdaļas unPieslēguma veidi, kas tika publicētiun kolekcija numurētas apakšmapes katram veidam publicēto no projekta, kas satur HTML lapu par katru no ierobežojumiem. Skatīt piezīmi zemāk, lai iegūtu informāciju par mapi / failu numerācijas shēmu.

· A Skatspunktss sub-mapes unnumurētasHTML lapa kādu no Viewpunktss, kas tika publicēti. Skatīt piezīmi zemāk informāciju par failu numerācijas shēmu.

Piezīme

No HTML lapu numerācijas (un dažos gadījumos attēlu failus) sakrīt ar unikāls ID katram glabātavu objektā, kas bija iestatītu tas bija izveidotsietvaros ABACUS (turpmāk tekstā EEIDs). Šis ID nemainās tik kā diagrammas, veidi, sastāvdaļas utt ir papildināta viņi gribakā iepriekš saglabā to pašu ID. Katrā gadījumā attiecīgā krātuve objektsnosaukumu var atrast pie sākuma HTML lapu starp ... HTML tagiem.

Ierobežojot piekļuvi atsevišķām lapām / viedokļu IIS

Ja izmantojat IIS kā jūsu tīmekļa serveri publicētā modeli, jums, iespējams, var ierobežot piekļuvi noteiktām lpp / viedokļiem izmantojot metodi zemāk:

1. Izveidot mājas lapā IIS (vēl vienu, ja pastāv esošais viens jūs nevēlaties traucēt).

2. Mainiet Properties> katalogs ar drošību> anonīmu piekļuvi - noņemiet atzīmi izvēles rūtiņā anonīmu piekļuvi un izmantošanu autentiskums piekļuvi.

3. Ja tas ir tikai normāla serveris bez domēna komplikācijām utt, tad jums vajadzētu izmantot "integrētie Windows autentifikāciju" opciju, kas pēc tam izmantot servera mašīnas vietējiem lietotājiem / logins kā autentifikāciju, un vienkārši pievienot lietotājus uz vietējo datoru (raugoties ka jums ir zināms par ietekmi, drošības gudrs, pievienojot jaunus lietotājus ar mašīnu, piemēram, atkarībā no tā, vai attālo piekļuvi ir setup uz mašīnu, uc).

4. Pievienot atļaujas īpašos failus / mapes, cik nepieciešams. Tiesības, noklikšķiniet atsevišķus failus / mapes -> Properties, un pielāgojiet drošības atļaujas, kā Jūs parasti mapju / failu.

Tas var atšķirties atkarībā no tā, kāda versija IIS un kādi īpaši Windows OS ir uz servera, un vai jums ir domēna vai cita citu iestatīšanu.

Skatīt arī

Aizpildi savu arhitektūru | Analizējot savu arhitektūru


Eksportē savu Arhitektūra

Navigācija: Ziņojums par jūsu arhitektūru>

Eksportē savu Arhitektūra

Nosūtīt komentārus par šo tēmu.

ABACUS ļauj līdzeksportēt savu arhitektūru mdb (Microsoft Access), MS SQL Server, .abacus (ABACUS fails), un .xls (Microsoft Excel) formātā. Jūs varat arī eksportēt savu diagrammas uz PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF un BMP formātā un jūsu ziņojumus, .html (HTML), .pdf (Adobe Acrobat), xls (Microsoft Excel), .doc (Microsoft Word) un rtf (Rich Text Format) formātā. Tas ļauj analizēt un apskatīt arhitektūru un tās datus nekādā veidā vēlaties.

Lai eksportētu savu arhitektūru, lai mdb (Microsoft Access)

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Klikšķiniet uz Failsmenu.

3. Atlasīt Eksports, un tad Uz MDB.

4. Ņem vērā brīdinājuma un noklikšķiniet labi.

5. Ierakstiet faila nosaukumu.

6. Noklikšķiniet uz SaglabātPoga.

Piezīme

Eksporta formāts mdb datu bāzē ir specifiski ABACUS un jebkuras shēmas izmaiņas radīs nespēju atkārtoti importu. Lūdzu, skatiet Populating ar MS Access aprakstu par MS Access shēmu.

Lai eksportētu savu arhitektūru, lai MS SQL Server

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Klikšķiniet uz Failsmenu.

3. Atlasīt Eksports, un tad Lai MS SQL Server.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Eksporta Blank MDB ...pogu un importēt to savā MS SQL Server datu bāzes serveri.

5. Aizpildiet datu bāzes informāciju un savienojuma virkne.

6. Noklikšķiniet uz EksportsPoga.

Piezīme

Eksporta formāts MS SQL ServerDatu bāze ir specifiski ABACUS un jebkuras shēmas izmaiņas radīs nespēju atkārtoti importu. Lūdzu, skatiet Populating ar MS Access aprakstu par datubāzes shēmu.

Lai eksportētu savu arhitektūru, lai .xls (Excel fails)

1. Pārliecinieties, vai ir ABACUS fails atvērts , Kas ir pētnieks parādīts , Un arhitektūra pievienotās .

2. Pārliecinieties, vai ir Excel Import / Export konfigurācijas failu definēts.

3. Labo klikšķipar arhitektūras savu modeli vai kādu daļu no Sastāvdaļasmezglu (noteiktā arhitektūrā) Jūs vēlaties eksportēt uz Excel konfigurācijas failā.

4. Atlasīt Eksports | Līdz Excel ... no izvēlnes.

5. Izvēlieties Excel Import / Export konfigurācijas failu lietotlogs tiks parādīts.

6. Izvēlieties atbilstošo konfigurācijas failu, jūsu arhitektūras modeli un noklikšķiniet uz Atvērtspoga.

7. Ja ne automātiski izdarīts, karte augstākā līmeņa komponenti savu pašreizējo arhitektūras līdz Set Id(kā iepriekš noteikts) un noklikšķiniet uz Eksporta ....

Piemērs Top-Level Component kartēšana

8. Izvēlieties vietu un faila vārdu Excel failu un noklikšķiniet uz Saglabātpoga.

Lai eksportētu savu arhitektūru, lai .abacus (ABACUS fails)

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Labo klikšķipar arhitektūras mezglā, kāds arhitektūras savu modeli vai jebkuru no sastāvdaļām koku.

3. Atlasīt Eksports | Līdz File ...no izvēlnes.

4. Izvēlieties vietu un faila nosaukumu un noklikšķiniet uz Saglabātpoga.

Piezīme

Jūs varat importēt Abacus failu atpakaļ ABACUS ar šādiem soļiem 1-2iepriekš un pēc tam izvēloties Imports | No File .... Pēc tam, kad esat izvēlējies failu, kuru vēlaties importēt, jums tiks jautāts, kā jūs vēlētos, lai importētu standartus un veidus. Jūs varat importēt standartus un veidus kā jauns vai apvienoti standartu un tipu. Noklusējuma iestatījums ir standartu un tipu, kas apvienotas ar esošajiem standartiem un tipiem, ja tie jau ir jūsu projekts.

Lai eksportētu savu arhitektūru, lai .xml

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Labo klikšķipar arhitektūras mezglā, kāds arhitektūras savu modeli vai kāda no komponenta koku.

3. Atlasīt Eksports | Līdz XML ...no izvēlnes. Alternatīvi jūs varat noklikšķināt uz izvēlnes Fails| Eksports| Līdz XML ...

4. Izvēlieties vietu un faila nosaukumu un noklikšķiniet uz Saglabātpoga.

Piezīme

Jūs varat importēt XML failu atpakaļ ABACUS ar šādiem soļiem 1-2iepriekš un pēc tam izvēloties Imports | No XML .... Pēc tam, kad esat izvēlējies XML failu, kuru vēlaties importēt, jums tiks jautāts, kā jūs vēlētos, lai importētu standartus un veidus. Jūs varat importēt standartus un veidus kā jauns vai apvienoti standartu un tipu. Noklusējuma iestatījums ir standartu un tipu, kas apvienotas ar esošajiem standartiem un tipiem, ja tie jau ir jūsu projekts.

Lai eksportētu savu diagramma PNG, JPG, SVG, TIFF, GIF vai BMP

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Atveriet diagrammajūs vēlētos eksportēt.

3. Klikšķiniet uz Eksporta Diagrampogu uz Diagramma rīkjoslu.

4. Eksporta diagrammaparādīsies logs.

5. Izvēlieties Pārlūkotpogu, lai saglabātu vizualizācijas vēlamajā vietā.

6. Izvēlieties Saglabāt kā tipupull-down izvēlni, lai izvēlētos faila tipu.

7. Noklikšķiniet uz Saglabātpoga.

Lai eksportētu savu ziņojumu .pdf (Adobe Acrobat), .xls (Microsoft Excel)vai.doc (Microsoft Word)

1. Pārliecinieties, vai ir ABACUS failsatvērts.

2. Izveidot ziņojums jūs vēlētos eksportēt.

3. Klikšķiniet uz Eksportspogu uz ziņojumiem rīkjoslā.

4. Atlasīt Excel, PDF vai WordNo nolaižamā.

5. Pagaidiet dažus mirkļus savukārt ziņojumā eksportu.

6. Izvēlieties vietu un faila nosaukumu un noklikšķiniet uz Saglabātpoga.


Darbs ar Enterprise Server

Navigācija: Administrācija>

Darbs ar Enterprise Server

Nosūtīt komentārus par šo tēmu.

ABACUS Enterprise Server ir gan "ne-bloķēšanu" sadarbības pieeja, bet gan "atslēgts" viens arī. ABACUS ir "non-atslēga", jo tā nav piespiest failu aizslēgt viens lietotājs, lai to atjaunināt. Katram lietotājam ir savs lokālo kopiju failu, un kā tās izdara izmaiņas un saglabāt to failu, šīs izmaiņas reģistrē un uzglabā, kad lietotājs vēlas apņemties tos uz servera.

ABACUS tiek "atslēgts", kas nozīmē, ka jums nav nepieciešams pieslēgt ar serveri vai nepieciešama tīkla piekļuvi Strādājot uz failu. ABACUS nepieciešama tikai pieeja serverim, veicot darbības, piemēram, izveidojot failu, vai veicot kases, kā arī ar darbībām uz esošo failu - atjauninājumu, izdarīt, vai apskatot žurnālu par pagātnes apņemas. Piekļuvi serverim nav nepieciešama, lai strādātu par failu, un jūsu veiktās izmaiņas nav nosūtīti uz serveri nekavējoties (tas ļauj viegli atmest izmaiņas, ja jūs veicat kļūda). Kad jūs saglabāt savu failu, jums ir "tikai" ietaupot jūsu kopija lokāli - tas nav tikai jūs apņemties, ka jūsu vietējā izmaiņas (izmaiņas veiktas kopš Jūsu pēdējā izdarīt), tiek nosūtīti uz serveri.

Radīt jaunu uzņēmumu File

Lai izveidotu jaunu Enterprise failu, izvēlieties Fails| New ...un pēc tam izvēlieties vienu no pirmajām divām iespējām saskaņā ar uzņēmuma modeļa sadaļā Jaunceltne dialog (ti, vai nu tukšu Enterprise fails, vai izveidot vienu no esoša ABACUS failu). Trešā iespēja ir "Checkout" Enterprise fails kāds cits jau ir izveidots, tas tiks aplūkoti nākamajā nodaļā.

Kad jūs izvēlaties, lai izveidotu jaunu Enterprise failu, jums tiks dota dialogu, kas ļaus jums, lai pārlūkotu, kur uz repozitoriju serveri jūs vēlētos, lai saglabātu failu. Tā būs arī esošo faila ceļu un nosaukumu ieraksta up augšpusē, ja jūs izvēlējāties "No Esošās Modelis" no jaunā projekta dialogā un piegādā failu.

URL: Šis ir URL uz jūsu glabātavas serveri kur ABACUS Enterprise faili tiek saglabāti. Jums vajadzētu lūgt personai, kas pārvalda serveri, ko šis URL vajadzētu būt.

Attēlā redzams repozitoriju ar četri (4) esošie ABACUS uzņēmējdarbības projektiem, pēc ieceļošanas URL un nospiežot Enter.Jūs redzēs pēc izveidot jaunu Enterprise failu, uz nākamo screenshot par "Checkout", būs vēl viena mape un failu šajā repozitorijā.

Piezīme

Ja jūs izmantojat https (SSL) serveri, un serveris nav derīga SSL sertifikātu (kopēju iekštīkla vai nav valsts serveriem dēļ izmaksas SSL sertifikātas) Būs papildu solis, lai ņemtu. Jums būs nepieciešams, lai pastāvīgi pieņemt visus savienojumus uz šo serveri dialogā, kas NOP augšu (tas parādīs arī mazliet vairāk informācijas par serveri). Lai to izdarītu, ierakstiet "p" (bez pēdiņām) un nospiediet Enter. ABACUS būs pop up ziņu atgādinot jums par šo pirms parāda dialogu.

Piezīme

Jums var lūgt, lai pieteiktos uz servera tādā gadījumā persona, kas ir pārvaldības serveravar nodrošināt servera lietotājvārdu un paroli. Arī pieteikšanās akreditācijas dati par jebkuriem serveriem, kas jums ir pieslēgti tiek saglabāti, lai, ja kāda iemesla dēļ tie ir noskaidroti to var izdarīt, izmantojot Tools | Iespējasun tad uz General tab, noklikšķinot Reset Subversion Saglabātie Pieteikšanāsun izvēloties serveri no nolaižamā saraksta un noklikšķinot Skaidrs Pieteikšanāsun izvēloties OK dialogā, kas parādās.

Piezīme

Atšķirībā no screenshot iepriekš norādīts, parasti viena ABACUS projekts ir iekļauts katrā ABACUS krātuve, jo, ja vairāk nekā 1 ABACUS Projekts ir izveidots vienā ABACUS Repository, Abacus maiņa žurnāla numuri tiek dalīta visās Abacus projektu un tas var maldināt lietotājus.

Vēlamā Filename: Tas ietekmē gan mapi un faila nosaukumu, kas tiks izmantoti (ja jau nav veikti), izveidojot failu uz repozitorija serveri. Ņemiet vērā, ka tiek izveidota jauna mape automātiski glabātuvju serveri katram failu (tehnisku iemeslu dēļ, ABACUS Enterprise faili tiek izveidoti savā mapē zem vietā pārlūkot uz dialog).

Uzglabāt darba kopiju direktorija: Kad uzņēmums fails tiek izveidots uz repozitoriju serveri, vietējās darba failus jārada datorā, lai jūs varētu strādāt ar dokumentiem, tos savienots ar tīklu. Šī ir vieta, ka jūs pārlūkot, kad jūs vēlaties, lai atvērtu / atkārtoti atvērt ABACUS Enterprise failu.

Checkout esošā uzņēmumā File

Ja kāds jau ir izveidojis jaunu Enterprise failu, jūs varat "kases" šis fails, kas lejupielādē lokālo kopiju un nosaka nepieciešamos failus, lai ABACUS atzīst to kā uzņēmums failu. Dialogs ir līdzīgs jaunu uzņēmumu File Dialog. Ievadiet krātuve URL (subdirectories var iekļaut URL), izvēlieties vajadzīgo failu, un noklikšķiniet uz Labi. Ievērojot zem t piezīmiviņš fails tiks atvērts.

Piezīme

Jums var lūgt, lai pieteiktos uz servera tādā gadījumā persona, kas ir pārvaldības serveravar nodrošināt servera lietotājvārdu un paroli. Arī pieteikšanās akreditācijas dati par jebkuriem serveriem, kas jums ir pieslēgti tiek saglabāti, lai, ja kāda iemesla dēļ tie ir noskaidroti to var izdarīt, izmantojot Tools | Iespējasun tad uz General tab, noklikšķinot Reset Subversion Saglabātie Pieteikšanāsun izvēloties serveri no nolaižamā saraksta un noklikšķinot Skaidrs Pieteikšanāsun izvēloties OK dialogā, kas parādās.

Enterprise Failu Atšķirības

Kad esat izveidojis Enterprise fails (vai nu jauna, vai ar "kases" par failu, kas izveidots kāds cits), mape tiks izveidota par failu, un tas parasti ietver šos 3 galvenie veidi failu:

· ".abacus" Fails- Tas ir ABACUS failu pati. Izmaiņas, ko veicat uz vietas nav nekavējoties saglabāta šajā failā, tas ir rakstīts, lai tad, kad jūs izdarīt tikai. Šis fails ir "normāls" ABACUS fails, to var dot ne-EE lietotājukā stand-alone projektu (bez log failu), Vai izmantot kā sākumpunktu par jaunu EE failā.

· ".changes" Fails- Vietējās (nesaistītos) veiktās izmaiņas failā. Ja šis fails ir pazudis, tas nozīmē, ka nav vietējie izmaiņas.

· "Log" fails- Šis fails ir tikai tās izmaiņas, kas tika veiktas pēc pēdējā lietotājs (saturam lietotāja .changes failu, kad viņi izdarījuši).

Piezīme

Ir dažādi citi faili, kas var tikt izveidotas atjaunināšanas laikā un apņemas procesus, proti; ‘.changesbefore"Fails- Šis fails ir kopija .changes fails pēc atjauninājums ir veikta, un tiek izmantoti, lai automātiski saskaņot jebkādus ID konfliktus starp atjauninājumā un vietējos (uzņemšanās) izmaiņas pirms izdarīt; ‘.backup"Fails- Šis fails ir kopija .changes failu pirms lietotājs ietaupa vairāk vietējo (nesadalīto) izmaiņas .changes failā; un ‘.error"Fails- Šis fails ir kopija no .changes failu, ja ir kāds jautājums, kas izraisīja Abacus neizdoties atvērt .abacus failu un lietotājs izvēlējās atgriezties to izmaiņas.Šos failus var ignorēt.

Atvērt failu

Lai atvērtu failu, Jums ir tikai nepieciešams, lai pārlūkotu, kur jūs izvēlējāties, lai saglabātu darba kopiju, un atveriet Abacus failu, kas tur glabājas. Kad ABACUS redz, ka ir .log failu (un varbūt .izmaiņas failu, ja esat veicis izmaiņas), tas būs pret failu kā uzņēmums failu.

File atjaunināšana

Veikšanan 'Update ", pārbaudīs, vai atrodas jaunāka versija failu uz servera. Ja ir, tas slēgs savu pašreizējo failu, atjauniniet uz jaunāku failu no servera, un lejupielādēt dažas pagaidu failus, kas ir vairāki kā paplašinājums - piemēram, "Demo.125". Šie faili ir vecākas versijas log failu, un tiek izmantoti, lai noteiktu, kādas izmaiņas ir veiktas failā, kopš pēdējo reizi atjaunināts to. Tas ir nepieciešams, lai atklātu jebkādus konfliktus, kas varētu būt noticis, lai jūs varētu tās atrisināt.

Ja atjaunināšanas procesa laikā jebkurš konfliktiTika atrasti, Jums būs nepieciešams, lai atrisinātu tos, pirms jūs varat atvērt savu failu vēlreiz (jūs varat atcelt bet Jums tiks piedāvāts vēlreiz atrisināt konfliktusnākamreiz atverot failu).

Saglabājot failu

Saglabājot failu, šis appends jebkādas izmaiņas veicāt ar .changes failu. Tas navmodificēt .abacus failu šajā posmā - tikai tad, kad fails ir apņēmusies serveri tā būs rakstiskas vairāk (vai tad, kad jūs saņemat atjauninājumu no servera).

Kur ir "Save As"?

Nav jēdziens saglabāt kā Uzņēmējdarbības failus. Varat tomēr kopēt savu darba kopiju .abacus failu, paturot prātā, ka tas paradis būt vietējos izmaiņas tajā.

Konfliktu risināšanā

Ja citi lietotāji ir izdarījuši izmaiņas failā līdzīgā dokumentācijas daļas jums, var būt daži konflikti starp to izmaiņām un jums. Piemēram, cits lietotājs var izdzēst komponents, kas jums bija atjaunināt īpašumu par. Jums ir nepieciešams vai nu atsaukt savu maiņu (ja esat pārliecināts, ka viņu vajadzētunav ir noticis), vai izmest savu maiņu (jūs tad varat doties atpakaļ uz failu un pārtaisīt savu maiņu).

Konkrēti ir 4 klases konfliktu, kas var rasties;

1. Izdzēst - Kad viens lietotājs dzēš objektu, cits lietotājs izmaiņām. Piem Lietotājam svītrots sastāvdaļa, bet lietotājs B mainīja komponenta nosaukumu vai saistīts ar to, vai pievienoja bērnu komponents tai uc

2. Atribūts - Kad divi lietotāji abi mainīt tieši tādu pašu "atribūtu" objekta. Piem Gan User A un B Lietotāja mainīja komponenta nosaukumu vai tās aprakstu vai vērtību vienam no saviem īpašumiem uc

3. Atsauces - Kad divi lietotājiem mainīt tieši tādu pašu "Atskaites" objekts ir uz citu objektu. Piem Gan User A un B Lietotāja mainīja komponents tips vai avots / izlietne sastāvdaļa pievienots savienojuma vai saistīts viedokļa par diagramma uc

4. Kolekcija - Kad divi lietotāji mainīt "savākšana" par objektu. Piem Gan User A un B Lietotājs pārcēlās sastāvdaļa no viena vecāka uz otru vai atkārtoti pasūtīt kolekciju bērniem sastāvdaļu.

Piezīme

Dažādas mazsvarīgi konflikti tiek automātiski atrisinātas, ABACUS lai samazinātu pieskaitāmās par lietotāju.Piemēram pretrunīgi visā tālummaiņas iestatījumus diagrammas ir atrisinātas, lai saglabātu jaunāko visā tālummaiņas iestatījumus.

Apņemoties izmaiņas

Kad jūs izvēlaties, lai izdarītu izmaiņas, tad ABACUS fails no servera ir atvērts, jūsu vietējs izmaiņas tiek veiktaspret to, un tad jūsu vietējā .abacus fails tiek pārrakstīts ar vienu, kas ir izmaiņas tajā. Jūsu izmaiņas failu tad pārraksta log failu, un gan .abacus failu un log failu tiek nosūtīti uz serveri.Ja izdarīt ir veiksmīgs Apņemties dialogu ziņojumu, kā parādīts zemāk ir paredzēts, lai ievadītu ziņu ar izdarīt.

Apskatot Ieiet izmaiņu

Līdz apskatīt žurnālu izmaiņu Uzņēmums projektsIzvēlieties Fails| View Log...

Maksimālais žurnāla ierakstusŠī būs noklusējuma uz pēdējo 10 ierakstiem, bet papildu ierakstus var iegūt, mainot vērtību un noklikšķinot Ielādēt poga.

Pārskatīšana: The redakcijas slejā uzskaitīti pārskatīšanas numuru apņēmušās Enterprise Server, pēc noklusējuma, apgrieztā hronoloģiskā secībā.

Piezīme

Šīs pārskatīšanas numuri nedrīkst būt nepārtraukta, jo tikai līdzdalībniece, tiks uzskaitīti Abacus bet pats Subversion repozitoriju var tikt izmantota citiem Abacus projektiem un / vai citu versiju kontroles sistēmas.

Datums: The Datums slejā ir uzskaitīti datumu, ka pārskatīšana tika izdarīts ar Enterprise Server.

Laiks: The Time slejā ir uzskaitīti dienas laiku (24 stundu formātā), ka pārskatīšana tika izdarīts ar Enterprise Server.

Autors: The Autors slejā ir uzskaitīti Microsoft Windows lietotāja vārdu, lai lietotājs, kas veic attiecīgo izdarīt seko viņu ABACUS lietotāja vārds Vai "Anonymous", ja lietotājs nav autentificēts un anonīmiem lietotājiem tika atļauta piekļuve uzņēmuma projektu brīdī no izdarīt.

Log Message: The Log Message slejā ir uzskaitīti izdarīt ziņu, kas tika sniegta ar pārskatīšanu kā vienu dialog parādīts iepriekš.

Download pārskatīšana XX kā stand-alone ABACUS failu: Ja izvēlaties doto pārskatīšanu tabulā un pēc tam noklikšķiniet uz pogas Lejupielādēt jūs varēsiet iegūt izvēlēto Abacus projekta pārskatīšanu no servera, un saglabājiet to kā vietējo / ​​stand-alone ABACUS projektu.

Piezīme

Roll atpakaļ uz iepriekšējo pārskatīšanu, lūdzu, skatīt šo Avolution kopiena raksts .

(Admin) Lejupielādēt XML log failu pārskatīšanas XX: Lietotāji ar ABACUS administratora spējas var izvēlēties konkrētu pārskatīšanu tabulā un pēc tam noklikšķiniet uz pogas Lejupielādēt, lai iegūtu izvēlētais ABACUS projekts izdarīt log failu no servera, un saglabājiet to kā .xml failu.

Skatās revīzijas liecības par izmaiņu

Līdz apskatītu revīzijas liecības par izmaiņām jebkurā attiecīgajā elementu (ti, detaļas, savienojuma, uzskata, bērniem utt) par kādu Uzņēmums projekts, peles labo pogu noklikšķiniet uz elementa un atlasīt Audit Trail..., Kas From un pārskatīšanai diapazonu un klikšķi Meklēt.

Piezīme

Kad elements ir svītrots no projekta jums vairs nespēj piekļūt konkrētu revīzijas taka informāciju par šo elementu. Jūs varat, tomēr joprojām piekļūt "mātes" sastāvdaļa (piemēram) un redzēt revīzijas taka informāciju par dzēšanu (šajā gadījumā uzskaitot ID elementa, kas tika svītrots).Turklāt, Component / Connection pieķeršanās ir "īpašums" no savienojumu, lai mainot pievienoto komponentu caur Explorer logā vai shēmas rādīs revīzijas liecības par savienojumu nav sastāvdaļu, un izdzēšot savienojumu un izveidot jaunu savienojumu (kā notiks, ja jūs ar peles labo pogu 'Unattach' un tad 'Savienot ... "katalogos) radīs zudumu revīzijas liecības informāciju par sākotnējo komponenti - pieslēguma pielikumu vispār.

Piezīme

Pēc noklusējuma revīzijas liecības būs rekursīvi pārbaudiet izmaiņas pret kādu no bērniem izvēlētā elementa. Tas var izraisīt ilgu reakcijas laiku un attiecīgi revīzijas liecības var ierobežot ar elementu pati ar ķeksīti Rekursīvas iespēja saskaņā ar Audita opcijas"zobrats" rīkjoslas pogu Audit Trail dialog.

No pārskatīšanaŠī būs noklusējuma uz pirmo / vecākā pārskatot pieejamo projektam par Enterprise Server.

PārskatīšanaiŠī tiks iestatīts pēdējais / visvairāk nesenās pārskatīšanas pieejamā projektu par Enterprise Server.

Piezīme

Pēc iestatījumu From un pārskatīt klāsts pogu Meklēt, lai ielādētu nekādas īpašas izmaiņas izvēlētā elementa.

Pārskatīšana: The redakcijas slejā uzskaitīti pārskatīšanas numuru apņēmušās Enterprise Server, pēc noklusējuma, jo priekšu hronoloģiskā secībā.

Piezīme

Šīs pārskatīšanas skaitļi ir maz ticams, ka nepārtraukti, jo tikai pārskatīšanu, kas attiecas uz izvēlētā elementa tiks parādīts un tikai ABACUS apņemas tiks uzskaitīti bet pats Subversion repozitoriju var tikt izmantota citiem Abacus projektiem un / vai versiju kontroles sistēmas.

Datums: The Datums slejā ir uzskaitīti datumu, ka lietotājs prasība tika veikts.

Piezīme

Norādītā datums ir lietotāja iejaukšanās datums, nevis datums pārskatīšana bija apņēmusies Enterprise Server. Attiecīgi datums var būt pirms atbilstošo pārskatīšanu izdarīt datums pierādīts ar Failu | Skatīt žurnālu ...komanda.

Laiks: The Time slejā ir uzskaitīti dienas laiku (24 stundu formātā), ka lietotājs prasība tika veikts.

Piezīme

Parādītais laiks ir lietotāja iejaukšanās laiks, nav īstais laiks pārskatīšana bija apņēmusies Enterprise Server. Tādējādi laiks visticamāk seko atbilstošā pārskatīšanu izdarīt parādīts ar laiku Failu | Skatīt žurnālu ...komanda.

Autors: The Autors slejā ir uzskaitīti lietotājam, kas veica rīcība ir Microsoft Windows lietotāja vārdu, kam seko to ABACUS lietotāja vārds Vai "Anonymous", ja lietotājs nav autentificēts un anonīmiem lietotājiem tika atļauta piekļuve uzņēmuma projektu brīdī lietotāja darbības.

Piezīme

Uzskaitītā revīzijas liecības dialogā Autors ne vienmēr atbilstu Autors uzskaitītā View Log dialog virs par to pašu pārskatīšanai. Tas ir tāpēc, ka View Log dialog saraksti pieteicies lietotājs brīdī COMMIT bet Audit Trail dialog saraksti pieteicies lietotājs brīdī lietotāja darbības, un tas ir iespējams, ir viens lietotājs veikt izmaiņas un sūtīt savus. izmaiņas failu citam lietotājam izdarīt - kā tas ir gadījumā, kad ārējie lietotājs (piemēram, Avolution) ir strādāt uz EE projektu.

Sīkāka informācija: The Details slejā uzskaitīti precīzu informāciju par lietotāja darbības kā tās ir reģistrētas Enterprise Server.

Gals

Ir lietderīgi grupa tās pārskatīšanas kolonnas (kā parādīts dialoglodziņā iepriekš) un / vai Lietotājs darbība kolonna līdz viegli klasificēt izmaiņas procentu elementa.

Izmantot skriptu ar Enterprise failiem

Ja jūs izmantojat skriptu ar Enterprise failus, jums ir jābūt informētiem par to, kā pareizi izdzēstu objektu no modeļa. Parasti, kad dzēšat objektu, jūs aicinās uz .Delete () metode par to, nevis tikai noņemot to no vecākiem.

Piem ja tu būtu comp1 kā mātes comp2 un vēlaties dzēst comp2 jūsu skriptu, jums vajadzētu zvanīt comp2.Delete (), nevis comp1.Components.Remove (comp2).

Jūs varat izmantot noņemt, ja jūs plānojat pievienot comp2 objektu uz citu vietu ietvaros arhitektūru, bet to nedrīkst lietot, ja ir nodoms dzēst objektu.

Ir izņēmums tam, kad jūs vēlaties, lai novērstu objektu, kas "dzīvo" citur modelī. Kad jūs vēlaties, lai novērstu standarta gadījumu no arhitektūras / detaļas / savienojumu, tad jūs varētu darīt, izņemot to no instancē standarta kolekcija - arch1.Realizācijas.Remove (Imp) - jo svītrojot to varētu noņemt to no visiem gadījumiem.

Pareizi lietojot Dzēst skriptus, ir svarīgi, jo, ja objekts tiek noņemts no objectmodel un nav atkārtoti piebilda, tad tas nebūs iespējams jāatrodas, bet tā kā tas nebija speciāli "dzēsts", konfliktu atklāšanas un risināšanas nebūs pareizi atklātu konfliktu, ja cits lietotājs bija, lai mēģinātu izmantot šo objektu kādā no to izmaiņām, un gala rezultāts būs bojāti kopums izmaiņu šim lietotājam.

Skatīt arī

Kā ir arhitektūras pārstāvēta ABACUS?


Darbs ar Atļaujas

Navigācija: Administrācija>

Darbs ar Atļaujas

Nosūtīt komentārus par šo tēmu.

ABACUS projekti var būt loma balstītaatļaujas, kas katram elementam ietvaros glabātavā. Konkrēti, sīkgraudains Create-Read-Update-Delete (Crud) Atļaujas var iestatīt pie "objektu" (ti, sastāvdaļas vai savienojums), apskatīt un atribūtu (ti, īpašuma) līmenī.

Pārskats

Strādājot ar ABACUS Enterprise Server , ABACUS nodrošina smalkgraudains, lomu bāzes Crud atļaujas, lai kontrolētu piekļuvi vairākiem lietotājiem glabātavas.

Piezīme

Konfigurēt atļaujas kādā ABACUS projektā lietotājs licence ir nepieciešama administratora spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

Atļaujas var iestatīt, lai arhitektūrām, komponentu un pieslēguma veidu, īpašības (via to veidiem), veidnes, viedokļi un diagrammas, katalogi, matricas, diagrammas un 3Dviews. Kad atļaujas ir noteikti par detaļas vai savienojuma veidu visus gadījumus šā veida jebkurā arhitektūras šajā projektā "mantot" šīs atļaujas. Tāpat, ja atļauja ir noteikts īpašuma kādas sastāvdaļas vai savienojuma veidu, dotajā īpašumu par detaļas vai pieslēguma instancēs jebkuros arhitektūrām šajā projektā "mantot" šīs atļaujas. Attiecīgi, daži atļaujas tiks piemēroti viedokļiem, par kuriem pastāv minētie elementi. Kad atļaujas ir noteikti par diagrammu, viedokli un / vai satura domām pati ir dažādas atļaujas, piemēro to.

Piezīme

Pēc noklusējuma nekādas atļaujas ir noteikti attiecībā uz elementiem par ABACUS projekta ietvaros. Tas ir visi elementi ir Createable, salasāms, updateable un Deleteable visi lietotāji. Tādā veidā atļaujas jāapsver tikai konkrētam elementu glabātavā, kad noteikta atļauja ir jābūt ierobežotspar noteiktu lietotāju grupai. Piemēram, ja atļaujas konkrētā lietotāju grupai tika pievienotas objektu (piemēram, detaļas tipa), bet atstāja ar visām atļaujām aktivizēta, tad tas ir funkcionāli tāds pats kā tad, ja lietotājs grupa nebija pievienota objekta.

Atļaujas nevarjānosaka konkrētiem gadījumiem arhitektūras elementiem. Piemēram, jūs nevarat veikt vienu pieteikumu komponents updateable vēl viens nav. Lai efektīvi sasniegtu šos "domēna īpašus" atļaujas Tomēr administrators var izveidot īpašus elementu tipus dotajiem jomās, piemēram, komponents veidiem 'Application - CRM domēns "un" Application - HR domēns ", un pēc tam noteikt atļaujas katram tipam atbilstoši. Jūs varat veikt īpašus grupējuma veidu katrā jomā un pēc tam noņemt atjauninājumu atļauju domēna specifiskas grupas tipa un tas ierobežos darbi iekšienē un svītrojumiem no šā grupējuma bet ne atjaunināt no bērniem. Protams, ja domēna specifisku grupējums bija paslēptas noņemot lasīšanas atļaujām, tad bērni tiks paslēpta un tādējādi nav updateable. Alternatīvi, ja viedokļi (nevis pētnieks) tiek izmantoti, galvenokārt, lai pārvaldītu / skatītu savu repozitoriju, konkrēts viedoklis par katrā jomā varētu izveidot, un tad administrators var noteikt atļaujas katru skatu atbilstoši.

Managing lietotāji un grupas

Atļaujas ir definēti pie lomavai grupalīmenis, nevis individuālā lietotāja līmenī, tā ka, lai gan dalība grupu var mainīties, atļaujas var palikt nemainīgi. Protams, ja jūs vēlaties īpašu lietotāja atļauju, tad vienkārši padarītu tos grupu, vai precīzāk izveidot grupu ar šo lietotāju kā vienīgo īpašnieku.

Jāatzīmē, ka grupas ir atomu, Ka ir viņi nevar mantot atļaujas vai lietotājus no viena uz otru, un ja lietotājs pieder vairākām grupām, tad lielākā daļa "pesimistiski" grupa atļauja būs pārāki katrā gadījumā atsevišķi katram atsevišķam atļaujas (ti Izveidot -Read-Update-Delete). Piemēram, ja pats lietotājs ir biedrs A un B grupas un A grupas nosacījumiem tikko Izveidot-Read atļauja Application sastāvdaļu tipiem, bet B grupa ir tikai lasīt-Update atļauja Application sastāvdaļu tipiem tad lietotājam būs tikai lasījis atļauju Pieteikums komponentu gadījumi.

Turklāt, pēc noklusējuma, anonīmi lietotāji(tas ir lietotāji, kuri nav definēti vai kuri nav ienācis) ir pilnīgu piekļuviprojektam. Tas nepieciešams, lai nodrošinātu, ka ir pieejams sākotnējo konfigurāciju. Lai bloķētu piekļuvi anonīmiem lietotājiem vienkārši atzīmēšanu "Atļaut anonīms lietotājs pilnīga piekļuve lietas materiāliem" opciju pārvaldīt lietotājus / grupas Dialog parādīts zemāk. Kad nekontrolētu anonīmi lietotāji būs tikai iespēja redzēt standartiem daļu jebkuru projektu.

Visbeidzot, ja 'lietot Windows lietotājvārdu un paroli,' opcija ir iezīmēta username autentifikācija tiek veikta pret Windows Segvārds Logins uz katra lietotāja mašīna pret lietotājvārds ir ievadīta kā vienu zemāk. Tas ir, ja Windows Lietotājvārds Login attiecībā uz konkrētu lietotāja mašīna pastāv kā derīgu lietotājvārdu, tad parole nav nepieciešama, un lietotājs tiek automātiski autentiskums. Piezīme: Tas faktiski ļauj izmantošana Windows Active Directory (AD) autentifikāciju.

Piezīme

Ņemot vērā, ka atļaujas ir tikai definēt, kad viņi ir jāņem prom (ierobežotas), no lietotāja, jebkurš lietotājs, kas nav grupas biedrs, vai jebkura grupa, kas nav atļaujas definēti to pret jebkādiem priekšmetiem, būs pilna piekļuve projekts.

Lietotājiem un lietotāju grupām

Lai izveidotu jaunu lietotāju

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

Piezīme

Ja jūs neredzat Pārvaldīt lietotāju / grupas izvēlnes elementu, tad jums nav administratora spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

2. Dialoglodziņā, kas parādās, izvēlieties Pievienot lietotājupogu un ievadiet lietotāja vārdu un paroli Izveidot jaunu lietotāju dialog. Piezīme: lietotāju vārdus un paroles ir jutīgi.

Piezīme

Ja "izmantojat Windows lietotājvārdu un paroli, 'opcija ir iezīmēta kā aprakstīts iepriekš, tad fiktīvu paroli var ievadīt kā autentifikāciju tiks veikta atbilstoši lietotāja loga Lietotājvārds Logins tikai.

2. Pēc noklusējuma jūs redzēsiet, ka Lietotāji var mainīt savu paroli. Ja nepieciešams, tad ABACUS administrators var noņemt spēja, lai lietotāji varētu noteikt savu paroli līdz Uncheckingizvēles rūtiņas.

Piezīme

Ja lietotāji var mainīt savu paroli, viņiem būs Failu | Mainīt paroli ...izvēlnes vienums darīt.Tāpat jāapzinās, ka, ja ir vairāki cilvēki izmanto to pašu lietotājvārdu, tad viens lietotājs var mainīt paroli, tā, ka nav citu cilvēku varat ieiet vēlāk. Tādējādi ir ieteicams prakse, lai būtu single username par faktisko personai.

4. Pēc izvēles, ievadiet e-pasta adresi, Atrašanās vieta un tālruņa numurs lietotājiem turpmākai izmantošanai.

5. Klikšķiniet uz labipogu Izveidot jaunu lietotāju dialog.

6. Klikšķiniet uz labipoga.

Piezīme

Kad esat izveidojis savu pirmo lietotājs jums vajadzētu apsvērt bloķēt piekļuvi anonīmiem lietotājiem, noņemot atzīmi "Atļaut anonīms lietotājs pilnīga piekļuve lietas materiāliem" opciju pārvaldīt lietotājus / grupas dialogā.Arī pēc tam, kad lietotājs ir izveidots (un ja Enterprise projekts, izmaiņas apņēmusies serveri), nākamreiz, kad projekts ir atvērts lietotājiem tiks piedāvāts Ieeja par autentiskums piekļuvekā vienu dialog parādīts zemāk. Ja Ieeja automātiski ar šo informācijuopcija ir iezīmēta, tad lietotāja vārdu / paroli kombinācija būs atceras projektam un jāpiemēro ikreiz atvēršanu. Lai nodzēstu saglabāts pieteikšanās izvēlieties Failu | Dzēst saglabātās Pieteikšanāspēc atvēršanas un jums tiks piedāvāts pieteikties atkal nākamreiz atverot projektu.

Pieslēgties

Lai dzēstu esošu lietotāju

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

2. Dialoglodziņā, kas parādās, izvēlieties lietotāja vārdu lietotājus panelī, kuru vēlaties izdzēst, un pēc tam izvēlieties Dzēst lietotājupoga.

3. Klikšķiniet uz labipoga.

Lai izveidotu jaunu grupu

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

2. Dialoglodziņā, kas parādās, izvēlieties Pievienot grupupogu un ievadiet grupas nosaukumu grupās panelī.

Piezīme

Grupu nosaukumi ir unikāls.

3. Klikšķiniet uz labipoga.

Līdz kopēt esošsGrupa

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

2. Dialoglodziņā, kas parādās, izvēlieties KopijaGrupapoga.

Piezīme

Dublikātu grupa tiks izveidota prefiksu ar "kopija".Pēc noklusējuma visas atļaujas no kopētā grupas tiks dublētas par "kopija" grupas, ieskaitot jebkuru lietotāja cesiju.

3. Pārdēvēt "kopija" grupas vajadzības gadījumā izmantojot Edit Groupvai lēni double-click.

Lai dzēstu esošu grupu

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

2. Dialoglodziņā, kas parādās, izvēlieties grupu nosaukumu Grupas panelī, kuru vēlaties izdzēst, un pēc tam izvēlieties Dzēst grupupoga.

Piezīme

Jebkurš lietotājs piešķīrumi grupas tiks noņemts.

3. Klikšķiniet uz labipoga.

Lai piešķirtu lietotāju grupai

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

2. Dialoglodziņā, kas parādās, izvēlieties lietotāja vārdu lietotājus panelī, kuru vēlaties piešķirt grupai un velciet un nometiettas uz grupas nosaukuma Grupas panelī, kuru vēlaties piešķirt to.

3. Klikšķiniet uz labipoga.

Piezīme

Grupa (-as), kas lietotājam ir piešķirtas ir parādīti ar paplašinot Lietotāja vārds lietotājiem panelīun lietotāji, kas tiek piešķirti grupai ir redzams, paplašinot grupas nosaukumu grupās panelī. Tā, piemēram, iepriekš screenshot, tad "AS1-Aus" lietotājam tiek piešķirta trīs (3) grupām, proti; "App Support Team 1", "faktiskais" un "Australia".

Lai izņemt no tās lietotāju no grupas

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

2. Dialoglodziņā, kas parādās, paplašināt Grupas nosaukums, kas satur lietotāja uzdevumu, kuru vēlaties izņemt no tās un izvēlieties lietotāja vārdu.

3. Klikšķiniet uz Anulēšana Userpoga.

4. Klikšķiniet uz labipoga.

Lai importētu lietotāju un / vai grupām (un jebkuru saskaņošanas atļaujas)

1. Atlasīt Fails| Pārvaldīt lietotājus / grupas

2. Klikšķiniet uz Importspoga.

3. Dialogā, kas parādās Pārlūkotlai un atveriet Abacus projektu, kas satur lietotāju un / vai grupas (un atļaujas), kuras vēlaties importēt pašreizējā projektā un noklikšķiniet Atvērts. Lietotāji un grupas tiks importēti un importa rezultāti dialog tai šķiet, apkopojot lietotāju un / vai grupām importu. Klikšķiniet uz labipoga.

Piezīme

Ja importētās Lietotāji vai Grupas, kas jau pastāvēja pašreizējā projektā, tad tie tiks apvienoti ar esošajiem lietotājiem vai grupām.

4. Klikšķiniet uz labipoga atpakaļ galvenais pārvaldīt lietotājus / grupas dialog.

5. Ja ir kādi atbilstības veidus, kā Viedokļi, Veidnes vai arhitektūras starp pašreizējo projektu un ABACUS projektu jūs esat importējis, komplektā ar atļaujām, kas nav jau pastāv pašreizējā projektā, atļaujas tiek importētas un otrais Importa rezultāti dialog Šķiet, apkopojot importu. Klikšķiniet uz labipoga.

Piezīme

Atļaujas ir tikai papildina esošo tipu (un to īpašībām), viedokļiem, Veidnes vai arhitektūru Grupu kur nebija jau pastāv atļaujas par grupas. Vai nu tāpēc, ka grupa ir jauna vai Grupa jau pastāvēja pašreizējā projektā, bet ne atļaujas tika piešķirts šai grupai šim postenim. Nav "apvienošana" par atļauju par atbilstīgiem posteņiem, ja atļaujas jau pastāvēja grupas pašreizējā projektā.

Nosakot atļaujas

Atļaujas var iestatīt, lai arhitektūrām, komponentu un pieslēguma veidu, īpašības (via to veidiem), veidnes, viedokļi un diagrammas, katalogi, matricas, diagrammasd 3Dviews. Kad atļaujas ir noteikti par detaļas vai savienojuma veidu visus gadījumus šā veida jebkurā arhitektūras šajā projektā "mantot" šīs atļaujas. Tāpat, ja atļauja ir noteikts īpašuma kādas sastāvdaļas vai savienojuma veidu, dotajā īpašumu par detaļas vai pieslēguma instancēs jebkuros arhitektūrām šajā projektā "mantot" šīs atļaujas. Attiecīgi, daži atļaujas tiks piemēroti viedokļiem, par kuriem pastāv minētie elementi. Kad atļaujas ir noteikti par diagrammu, viedokli un / vai satura domām pati ir dažādas atļaujas, piemēro to.

Atļaujas Management

Lai uzstādītu atļauju komponents (vai Connection) Tips

1. Paplašināt Veidifiliāle koku.

2. Paplašināt Komponents (vai savienojums) veidifiliāle koku.

3. Paplašināt Grupasja nepieciešams.

4. Labo klikšķi uz Komponents (vai Connection) Tipsvēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

5. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

6. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

Piezīme

Izveidot atļauja nosaka arī tad, kad jūs varat kopēt elements. Attiecīgi, lai varētu nokopēt elements prasa izveidot atļauju visiem saviem bērniem (kopš kopēt elementu nozīmē kopēšanu viss zem tā). Noņemot Update atļauju no elementa novērš iespēju mainīt pašu tipu, pat tad, ja lietotājs ir Designer add-on un to arī novērš Update atļauju par visiem saviem īpašumiem. Vecākiem elementam jābūt Update atļauja, lai varētu Neradīt bērnu elementus vai Dzēst ITS esošais bērnu elementi. Dzēst atļauju par elementu arī pieprasa dzēst atļauju visiem saviem bērniem. Dzēst atļauju sastāvdaļām prasa arī atjaunināšanas atļauju visiem pievienotajiem savienojumiem.Un visbeidzot, noņemot Dzēst atļauju no elementa novērš iespēju dzēst pašu tipu, pat tad, ja lietotājs ir Designer add-on.

7. Klikšķiniet uz labipoga.

Lai uzstādītu atļauju grupai komponentu (vai savienojumu) veidi

1. Paplašināt Veidifiliāle koku.

2. Paplašināt Komponents (vai savienojums) veidifiliāle koku.

3. Labo klikšķi uz Grupakas satur sastāvdaļas (vai savienojums) veidus, ko vēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

6. Klikšķiniet uz labipoga.

7. Dialoglodziņā, kas parādās, noklikšķiniet uz Jāpoga.

Lai uzstādītu atļauju īpašumu

1. Paplašināt Veidifiliāle koku.

2. Paplašināt Komponents (vai savienojums) veidifiliāle koku.

3. Paplašināt Grupasja nepieciešams.

4. Izvēlieties komponentu (vai Connection) veids, kas ietver īpašumu, kuru vēlaties ar iestatītu atļaujas.

5. Jo Properties logā labo klikšķi uz Īpašumsvēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

6. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

7. Pēc noklusējuma jūs redzēsiet, ka lasīt un atjaunināšana atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

Piezīme

Īpašības, kas ir bijusi Update atļauja izņemta tiek attēloti slīprakstāProperties logāun to vērtības nevar atjaunināt ar šo lomu. Arī, spēja modificēt informāciju par īpašuma (piemēram, nosaukums, vienības un tt) prasa gan Update atļauju uz īpašumu un Designer add-on.

8. Klikšķiniet uz labipoga.

Lai uzstādītu atļauju veidni

1. Paplašināt Veidnesfiliāle koku.

2. Pārlūkojiet Templatekas jūs interesē.

3. Labo klikšķi uz Templatevēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka Read atļauja ir pieejams. Noņemiet atļauju ar Uncheckingrūtiņu.

6. Klikšķiniet uz labipoga.

Lai uzstādītu atļauju viedokli

1. Paplašināt Viedokļifiliāle koku.

2. Paplašināt Grupasja nepieciešams.

3. Labo klikšķi uz Viedoklisvēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

6. Klikšķiniet uz labipoga.

Lai uzstādītu atļauju arhitektūra

1. Paplašināt Arhitektūrasfiliāle koku.

2. Izvērst uz Arhitektūrakas jūs interesē.

3. Labo klikšķi uz Arhitektūravēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka Read atļauja ir pieejams. Noņemiet atļauju ar Uncheckingrūtiņu.

6. Klikšķiniet uz labipoga.

Lai uzstādītu Atļauja Katalogs

1. Paplašināt Katalogifiliāle arhitektūra jūs interesē.

2. Paplašināt Grupasja nepieciešams.

3. Labo klikšķi uz Katalogsvēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

6. Klikšķiniet uz labipoga.

Lai uzstādītu Atļauja Matrica

1. Paplašināt Matricasfiliāle arhitektūra jūs interesē.

2. Paplašināt Grupasja nepieciešams.

3. Labo klikšķi uz Matricavēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

6. Klikšķiniet uz labipoga.

Lai uzstādītu atļauju diagramma

1. Paplašināt Diagrammasfiliāle arhitektūra jūs interesē.

2. Paplašināt Grupasja nepieciešams.

3. Labo klikšķi uz Diagrammavēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

Piezīme

Lai gan jūs varat iestatīt Crud atļaujas tieši diagrammā, jāatzīmē, ka atļaujas par elementu diagrammā var ietekmēt atļaujas skatu pati. Piemēram, ja ir pat tikai viens elements uz uzskatu, ka ir bijusi savu lasīt vai atjaunināšanas atļauja izņemta tad diagramma būs tās atjaunināšana atļauja noņemts. Tas ir tāpēc, ka; a) elementiem, uzskatu, ka ir bijusi viņu Lasīt atļauja izņemta netiks rādīts skatā atstājot "balto laukumu", kur jūs citādi varētu ievietot dažus jaunus elementus, ja viedoklis bija updateable, un b) elementus, uz viedokli, ka ir bijusi viņu Update atļauja izņemta tad varētu būt citi elementi samazinājies uz tiem kļūt bērni, ja viedoklis bija updateable. Arī Izveidot un Update atļauja diagrammā ir noteikts, ka visi elementi uz domām, ir lasīšanas atļaujām un komponenti ir atjaunināšanas atļauja (tas ir tāpēc, lai pārvietotu sastāvdaļa uz citu sastāvdaļu, jums ir jābūt iespējai atjaunināt to, jo tas būs kļūt) bērnu.

6. Klikšķiniet uz labipoga.

Lai uzstādītu atļauju 3D View

1. Paplašināt 3D Viewsfiliāle arhitektūra jūs interesē.

2. Paplašināt Grupasja nepieciešams.

3. Labo klikšķi uz 3D Viewvēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

6. Klikšķiniet uz labipoga.

Lai uzstādītu Atļauja Diagramma

1. Paplašināt Chartsfiliāle arhitektūra jūs interesē.

2. Paplašināt Grupasja nepieciešams.

3. Labo klikšķi uz Diagrammavēlaties iestatīt atļaujas un izvēlieties Rediģēt atļaujas.

4. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

5. Pēc noklusējuma jūs redzēsiet, ka izveidot, lasīt, atjaunināt un dzēst atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

6. Klikšķiniet uz labipoga.

Skatīt arī

Kā ir arhitektūras pārstāvēta ABACUS?


Darbs ar paneļi

Navigācija: Administrācija>

Darbs ar paneļi

Nosūtīt komentārus par šo tēmu.

ABACUS projekti var būt jebkuras konfigurācijas viedokļu (piemēram, diagrammas, Diagrammas uc), kas saglabāti kā paneļa un šie saglabātos paneļus var būt iestatīt kā noklusējuma sāk "ekrāns" atvēršanas projektu un / vai piešķirts īpašs lietotāju grupa un iepazīstināja locekļiem šīs lietotāju grupas, ja viņi pieteiktos uz ABACUS projektu.

Piezīme

Lai konfigurētu paneļus kādā ABACUS projektā lietotājs licence ir nepieciešama administratora spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

Apskata paneļi

Piemērs Application Portfolio Management (APM) panelis

Lai apskatītu saglabātu Dashboard

1. Atlasīt Skats| Paneļi

2. Saglabāto paneli no saraksta pieejamo paneļus.

Piezīme

Kad izvēlētā ABACUS būs veidot viedokli, kas nepieciešami paneļa un tas var ilgt dažas sekundes. Lūdzu, esiet pacietīgi.

Managing paneļi

Managing paneļi

Lai izveidotu jaunu Dashboard

1. Atveriet nepieciešamos viedokli un organizēt un doks logi, kas vajadzīga paneļa.

2. Atlasīt Skats| Paneļi| Pārvaldīt paneļi ...

Piezīme

Ja jūs neredzat Pārvaldīt paneļi izvēlnes elementu, tad jums nav administratora spējas. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support ja jums ir nepieciešama šo spēju.

3. Dialoglodziņā, kas parādās, izvēlieties Izveidotpogu un ievadiet Dashboard nosaukumu Create New Dashboard dialog.

4. Klikšķiniet uz labipoga.

Lai dzēstu esošu Dashboard

1. Atlasīt Skats| Paneļi| Pārvaldīt paneļi ...

2. Dialoglodziņā, kas parādās, izvēlieties paneli vēlaties dzēst no saraksta un izvēlieties Izdzēstpoga.

Piezīme

Izdzēšot paneli būs arī izdzēst lietotāju grupu uzdevumus līdz šim paneļa.

3. Klikšķiniet uz labipoga.

Lai aizstātu esošu Dashboard

1. Atveriet nepieciešamos viedokli un organizēt un doks logi, kā vajadzīgs rezerves paneļa.

2. Atlasīt Skats| Paneļi| Pārvaldīt paneļi ...

3. Dialoglodziņā, kas parādās, izvēlieties vadības paneli jūs vēlaties, lai aizstātu no saraksta un izvēlieties Aizstātpoga.

4. Klikšķiniet uz labipogu, lai atzīt Dashboard Aizstāts dialogu.

Lai piešķirtu Dashboardkā noklusējuma sākuma ekrāna

1. Atlasīt Skats| Paneļi| Pārvaldīt paneļi ...

2. Dialoglodziņā, kas parādās, izvēlieties paneli no saraksta, kuru vēlaties piešķirt kā noklusējuma sākuma ekrāna ''un izvēlieties Piešķirt ...poga.

3. Dialoglodziņā, kas parādās, izvēlieties ierakstu lietotāju grupām kolonnā.

Piezīme

Tikai viena paneļa var piešķirt kā sākt "ekrāns" tā atkārtoti uzdevums būs noņemt norīkojumu no iepriekšējā paneļa.Turklāt, ja lietotājs piesakās kā loceklis lietotāju grupas, kam ir piešķirts paneli, tad piešķirts panelis tiks atvērts vietā noklusējuma projekta paneļa.

4. Klikšķiniet uz labipoga.

Lai piešķirtu lietotāju grupas, lai panelī

1. Atlasīt Skats| Paneļi| Pārvaldīt paneļi ...

2. Dialoglodziņā, kas parādās, izvēlieties paneli no saraksta jūs vēlaties piešķirt lietotāju grupu, lai un izvēlieties Piešķirt ...poga.

3. Dialoglodziņā, kas parādās, izvēlieties User Group (vai grupas)Jūs vēlaties, lai piešķirtu paneli kā "uzsākšanas" ekrāna.

Piezīme

Ja tas pats User Group piešķirts vairākiem paneļi, tad pirmais uzdevums sarakstā tiks izmantota.

4. Klikšķiniet uz labipoga.

Lai izņemt no lietotāju grupas no Dashboard

1. Atlasīt Skats| Paneļi| Pārvaldīt paneļi ...

2. Dialoglodziņā, kas parādās, paplašināt Dashboard objektu no saraksta vēlaties izņemt no tās lietotāju grupu no.

3. Izvēlieties lietotāju grupas, kuru vēlaties izņemt no tās un izvēlieties Anulēšanapoga.

4. Klikšķiniet uz labipoga.

Nosakot atļaujas

Atļaujas var iestatīt, lai paneļi, lai varētu instrumentu panelis ir apskatāms, Updateable un / vai deleteableuz dotajiem lietotāju grupām.

Atļaujas Management

Lai uzstādītu atļauju Dashboard

1. Atlasīt Skats| Paneļi| Pārvaldīt paneļi ...

2. Dialoglodziņā, kas parādās, izvēlieties paneli no saraksta, kuru vēlaties iestatīt atļaujas un izvēlieties Atļaujas ...poga.

3. Dialoglodziņā, kas parādās, noklikšķiniet uz Pievienot ...pogu un izvēlieties Grupavēlaties pievienot vai nu dubultklikšķi vai izvēloties to un noklikšķinot uz labipoga.

4. Pēc noklusējuma jūs redzēsiet, ka Read, Update un Delete atļaujas visi ir pieejami. Noņemt atļaujas, ko Uncheckingattiecīgās izvēles rūtiņas.

5. Klikšķiniet uz labipoga.

Skatīt arī

Pielāgošana Abacus interfeisu | Darbs ar Atļaujas


Reģistrējot ABACUS

Navigācija: Reference>

Reģistrējot ABACUS

Nosūtīt komentārus par šo tēmu.

Kad jūs pirmo reizi sākt Abacus (vai pēc pagaidu licenci ir beidzies), jums būs nepieciešams reģistrēt pieteikumu pret Avolution apliecība serveri, izmantojot unikālu licences atslēga ar savu vietējo ABACUS administrators vai tieši no Avolution sniegta. Ja jums nav licences atslēga, lūdzu, sazinieties ar vietējo ABACUS administratora vai Avolution Support .

Lai reģistrētu ar licences atslēga

1. Pēc uzstādīšanas, sākt ABACUSko nu dubultklikšķi uz saīsnes darbvirsmā vai no Windows Start izvēlnē.

2. Reģistrācijas Dialoglodziņā, kas parādās iekļūt 26 rakstzīmju licences atslēguJūsu vietējā ABACUS administratoru, kas paredzēts vai Avolution atbalsts , Vai klikšķis Pārlūkot ...un izvēlieties parakstīja .dlsc fails atgriezies no Avolution Support kā vienu piezīmi pie 4. solī zemāk. Ja izmantojat pareizi parakstītu .dlsc failu ABACUS jāsāk kā vienu Solis 5 zemāk.

Gals

Jūs varat ielīmēt licences atslēgu dialog, kopējot to uz Windows starpliktuvē un pēc tam izvēloties fonu dialog un nospiežot Ctrl + V

Reģistrācijas dialog

3. Uzklikšķiniet labiun ja licences atslēgu ir derīgs ABACUS licences atslēguABACUS tagad mēģinās sazināties Avolution apliecība serveri, lai apstiprinātu licences atslēga.

Piezīme

Ja jums Uzstādīšana kods nav derīgsreģistrācija kļūda tas ir ļoti iespējams, ka esat ievadījis kodu nepareizi. Izmēģiniet nokopējot un ielīmējot kodu kā vienu minēts iepriekš Padoms.

Kontaktēšanās Avolution License Server

4. Uzklikšķiniet labiun pēc īsa laika ABACUS veiksmīgi jāreģistrējas.

Veiksmīga Reģistrācija

Piezīme

Ja jums ir Nevar sazināties licences serverireģistrācija kļūda tas ir ļoti iespējams, ka ugunsmūris (vai citus drošības pasākumus) savā tīklā ir lai novērstu piekļuvi Avolution apliecība serveri. Uzklikšķiniet labi, Saglabājiet .dlsc failu uz jūsu vietējo mašīna un pēc tam vai e-pastu .dlsc failu Avolution Support un gaida turpmākus norādījumusvai mēģināt pierakstīties licences fails pats, izmantojot šādu URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Nevar sazināties ar licences serveri

Atveriet License parakstīšanas mājas lapā

Manuālā License parakstīšana mājas lapa

Alternatīvi, ja jūs saņemsiet Šī instalācija kods ir izmantota vairāku sistēmu licencē nekā atļautsreģistrācija kļūda tas ir iespējams, ka jūsu vietējā mašīna ir pārbūvēta, kopš pēdējo reizi reģistrēts Abacus vai jūs mēģināt reģistrēties ar cita lietotāja licences atslēgu. Lūdzu, sazinieties ar savu vietējo ABACUS administratora vai Avolution Support .

Uzstādīšana kods jau ir izmantots

5. Uzklikšķiniet labiun ja tā ir reģistrēta veiksmīgi ABACUS jāatver ar Welcome Screen .

Skatīt arī

Avolution Support | Kāda ABACUS darīt?


ABACUS Uzstādīšana priekšnoteikumi

Navigācija: Reference>

ABACUS Uzstādīšana priekšnoteikumi

Nosūtīt komentārus par šo tēmu.

Informācija par Visio importa un Excel importa / eksporta

ABACUS paredz, ka Microsoft Office jāuzstāda, lai veiktu Excel importa / eksporta un Visio importa operācijas. Lūdzu, pārbaudiet, Microsoft Office 2003 vai jaunākair uzstādīta pareizi. Ja jums rodas citas problēmas, kontakts Avolution Support .

Lai veiktu Visio Import un Excel importa / eksporta operācijām, ABACUS izmanto Microsoft Office Primārā Interop asamblejām (PIA s). ABACUS šobrīd nāk komplektā ar kompleksiem nepieciešami, lai veiktu Excel importa / eksporta un Visio Importēt.

Informācija par SQL Server Import

ABACUS paredz, ka Microsoft SQL Server 20052008, 2008 R2, 2012. vai 2014. gadāir uzstādīta, lai sāktu jaunu projektu no SQL Server. Lūdzu, pārbaudiet, Microsoft SQL Server 20052008, 2008 R2, 2012. vai 2014. gadāir uzstādīta pareizi. Ja jums rodas citas problēmas, kontakts Avolution Support .

Kļūdas atvēršana 3D vizualizāciju

Ja ABACUS 3D Viewer nedarbojas jums, jums var būt trūkst SlimDX DirectX Runtime (uzstādītas kā daļa no pilnīgas ABACUS EXE instalēt). To var lejupielādēt šeit . Ja jums ir 64bit Windows versija, jums var būt nepieciešams instalēt šis .

Kļūdas Rediģēšana ABACUS Paraža Ziņojumi

Rediģēšanas Abacus "Custom Ziņojumi prasa Report Builder 3.0 ir uzstādīta. ABACUS un Report Builder ir būvētas uz Microsoft .NET Framework 4.0, un, kamēr viņi abi neprasa Microsoft .NET Framework 3.5, Microsoft ir nepareizi konfigurēta Report Builder MSI tikai turpināt, ja Microsoft .NET Framework 3.5 ir uzstādīta.

Attiecīgi Avolution ir edited versija Report Builder instalācijas MSI failu, kas neprasa Microsoft .NET Framework 3.5, to var lejupielādēt šeit .

Sākotnējais Microsoft Report Builder MSI var lejupielādēt šeit . Ja jums nav jau ir Microsoft .NET Framework 3.5, kas būs nepieciešama, jūs varat lejupielādēt to šeit . Piezīme: Par vairākām iekārtām, bezsaistes instalēt Microsoft .NET Framework 3.5 no šeit var būt piemērotāka.


Komandrindas opcijas

Navigācija: Reference>

Komandrindas opcijas

Nosūtīt komentārus par šo tēmu.

Jūs varat veikt dažādas ABACUS operācijas tieši no komandrindas ar visbiežāk operācija ir atvērt īpašu projekta failu un publicēt to HTML.

Konkrēti, komandrindas izmantošana ABACUS ir šāds;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ lietotājs "lietotājs" / pass "ieskaitīts"]

Arguments | Apraksts
ProjectFile | ProjectFile var būt vai nu ABACUS projekta fails (.abacus), bibliotēkas fails (.abacuslib), XML failu (xml) vai MS Access DB (mdb) un norādītais fails tiks vai nu atvērts (ja .abacus vai .abacuslib ) vai jauns projekts radīts (ja xml vai mdb failu).
OptionalFile | OptionalFile var būt vai nu ABACUS skriptu (.abacusscript, VB vai .cs), makro (.abacusmac) vai bibliotēkas fails (.abacuslib) un norādītais fails tiks vai nu darboties pēc atvēršanas ProjectFile (ja .abacusscript, VB vai .cs vai .abacusmac) vai vienkārši atvēra (ja .abacuslib).
/ exitOnCompletion | Izies Abacus un, ja nepieciešams, glābt un izdarīt jebkādas izmaiņas atklātajiem .abacus projektiem pabeigšanas jebkuru skriptu vai makro. Piezīme: Šis karogs ir Case Sensitive tāpēc pārliecinieties, lai izmantotu lielos "O" un "C" tekstā, kā parādīts.
/ dontShowDialogs | Novērsīs ABACUS Enterprise Edition (EE) update paziņošanas dialogs no parāda atverot projektu. Piezīme: Šis karogs ir Case Sensitive tāpēc pārliecinieties, lai izmantotu lielos "S" un "D" tekstā, kā parādīts.
/ lietotājs "lietotājs" / pass "ieskaitīts" | Lietotājvārds lietotājs un parole PASS tiks izmantoti, lai pieteiktos projektā ar, sevišķi svarīgi jebkādus saglabātos lietotāja akreditācijas datus. Piezīme: pēdiņās jānovieto ap lietotājs un nodot karogiem un divas pēdiņas, var izmantot, lai izvairītos dubultās pēdiņas, kas vai nu lietotājs vai vest karogiem.

Piem;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / lietotājs "Public" / pass "123456"

kad palaist no direktoriju, kur ABACUS.exe binārs ir kas atrodas griba atvērts Piemērā projekts un piesakieties kā lietotājs sabiedrību ar paroli 123456 (kā aprakstīts šeit ), Publicēt to HTML un pēc tam aizveriet projektu visu nerādot nekādus dialogus pa ceļu (piemēram, "Update Veiksmīga" vai "nē atjauninājumi pieejami" Uzņēmējdarbības projektiem).

Piem;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalogs Excel Import.vb"/ exitOnCompletion / dontShowDialogs

kad palaist no direktoriju, kur ABACUS.exe binārs ir kas atrodas griba atvērts Piemērā projekts un importēt "Serveri (2014 Actual) .xlsx" MS Excel failu ar "serveru katalogā" 2014. Faktiskais "arhitektūras projekta nerādot nekādus dialogus pa ceļu, un pēc tam aizverot projekta pabeigšanas. Ja darbība izdara izmaiņas projektā tad, aizverot izmaiņas tiek saglabātas lokāli, un ja uzņēmums projekts apņēmusies Enterprise Server.

Piezīme

Noteikti izmantojiet pareizo dubultu quote raksturu, kā ir vairāki standarta ASCII rakstzīmju kopu un Windows Command Prompt darbosies tikai pareizi ar pareizo vienu. Pareizs double quote raksturs kods ir Decimal 34 (Heksadecimālais 22).Tas ir tas, ko izmanto, piemēram, iepriekš, lai justies brīvi copy / paste to no turienes.


Titullapa

ABACUS

Atruna

Avolution Pty Ltd neuzņemas nekādu atbildību vai garantijas attiecībā uz šo rokasgrāmatu un, cik to atļauj likums, skaidri ierobežo savu atbildību par pārkāpumu, jebkādas garantijas, kas var būt netieši uz nomaiņu šīs rokasgrāmatas ar citu. Turklāt Avolution Pty Ltd patur tiesības pārskatīt šo publikāciju jebkurā laikā, nemaksājot par pienākumu paziņot jebkurai personai par pārskatīšanu.

Autortiesības

Copyright 2001-2015Avolution Pty Ltd Visas tiesības aizsargātas.

Preču zīmes

Avolution Pty Ltd ir darījusi visu iespējamo, lai sniegtu preču zīmju informāciju par uzņēmumu nosaukumi, produktiem un pakalpojumiem, kas minēti šajā rokasgrāmatā. Preču zīmes zemāk redzamie tika iegūti no dažādiem avotiem.

Microsoft Windows, Access, Visio, Excel, SQL Server un Internet Explorerir Microsoft Corporation preču zīmes.

Vispārīgs paziņojums:

Daži produktu nosaukumi, kas izmantoti šajā rokasgrāmatā tiek izmantoti tikai identifikācijas nolūkos un var būt preču zīmes to attiecīgajās uzņēmumiem.

2015. gada decembrimEdition Avolution ABACUS versija 4.5.

Manual pārskats 1.0

Radītais, drukā, un saistoši Austrālijā.