Legge forhåndsinnstilte egenskapene til en komponent, tilkobling eller type

Navigasjon: Fyller ditt arkitektur> Egenskaper>

Legge forhåndsinnstilte egenskapene til en komponent, tilkobling eller type

Send kommentarer om dette emnet.

Standard biblioteker av egenskaper kan spesifiseres og tildelt noe annet i arkitekturen. Disse biblioteker er kjent som Standarder. Ved bruk av Standarder, Trenger du bare å samle spesifikke systemer egenskaper - de vanlige egenskapene er allerede der.

For eksempel de vanlige egenskapene til Microsoft Windows 2000 kan lagres som en Standardog overdratt til eventuelle komponenter (eller tilkoblinger, ikke at det ville være typisk) hjelp av Microsoft Windows 2000-operativsystemet.

For å legge til en standardtil en komponent, forbindelse eller type

1. Høyreklikkpå komponent / tilkobling / type.

2. Velge Tildele Standard.

3. Velge en Standardfra listen.

Se også

Fyller din arkitektur - Oversikt | Endre egenskapene til en komponent, tilkobling eller type | Samlede eiendommer

© 2001-2015 Avolution Pty Ltd. All rights reserved.


Samlede eiendommer

Navigasjon: Fyller ditt arkitektur> Egenskaper>

Samlede eiendommer

Send kommentarer om dette emnet.

Operasjonen "Aggregate Egenskaper"Lar deg legge til verdier av lignende eiendommer sammen og skrive (eller legge til) resultatet i den valgte forelder elementets egenskaper. Den lar deg også til å definere omfanget av aggregering og om du vil oppdatere egenskapene til alle underelementer eller ikke.

Å samlede eiendommer

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Høyreklikk på et element (en arkitektur, en komponent eller en tilkobling) der å gjøre aggregering og velg Samlede Properties.

3. Velg en av de Aggregate Options (Traverse Alle undernivåer eller Bare Direct Sub-nivå). Hvis du har valgt Traverse Alle undernivåer, Kan du også velge alternativet om du vil Oppdater undernivåer.

o Traverse Alle undernivåerbetyr at omfanget av aggregering vil inneholde elementene i alle nivåer i henhold til din valgte elementet.

o Oppdater undernivåerkan bare gjøres hvis du også har valgt alternativet Traverse Alle undernivåer. Dette betyr at mens man samlet egenskaper fra bunnen og opp, det samlede resultatet på hvert nivå blir også oppdatert i hver av de tilsvarende elementer.

o Bare Direct Sub-nivåbetyr at bare egenskapene av elementene direkte under det valgte element, vil bli regnet.

o Velge Inkludere Standard EgenskaperHvis du vil ha de egenskapene som er definert i standarder å bli inkludert. Ellers vil bare de egenskaper som er unike for hver komponent eksempel benyttes.

4. Velg hvilke egenskaper du ønsker å samle. De er gruppert i deres Typer.

5. Klikk på Neste knapp.

6. Velg alternativet om du vil Skriving Verdier eller Legg Verdiertil det valgte elementet.

o Skriving Verdiervil skrive resultatene direkte inn i egenskapene til det valgte element.

o Legg Verdiervil legge resultatene til de eksisterende egenskapene til det valgte elementet.

Se også

Legge forhåndsinnstilte egenskapene til en komponent, tilkobling eller type | Endre egenskapene til en komponent, tilkobling eller type | Evaluere arkitektur


Arkitektur Diff og Sync

Navigasjon: Analyse din arkitektur>

Arkitektur Diff og Sync

Send kommentarer om dette emnet.

Når du har 2 eller flere arkitekturer, enten som utviklinger eller baseline arkitekturer, kan du visuelt 'diff' de to arkitekturer hjelp katalog eller diagram Sammenligning eller Arkitektur Diff funksjonen. Dette er spesielt nyttig for å oppdage / re-oppdage presise endringer gjort fra en arkitektur til en annen som du utvikler arkitekturer og utvikle veikart i ABACUS.

Til viser 'diff' med en annen arkitektur via et diagram

1. Kontroller at du har en ABACUS fil åpen .

2. Sikre deg ha minst 2 arkitekturer i prosjektet.

3. Åpne diagrammet du ønsker å sammenligne med en annen arkitektur.

4. Klikk på "Sammenlign dette Diagram til innholdet i en annen arkitektur" -knappen på Diagram verktøylinjen.

5. Velg den andre arkitekturen fra rullegardinlisten for å sammenligne med.

6. Du kan filtrere hva forskjellene er vist ved å klikke på 'Forskjeller' knappen på Diagram verktøylinjen og fjerne merkingen alternativer, f.eks Endret / lagt til / Unknown og Ubestemmelige / Sync Anbefalt/ Hold Anbefalt.

Notat

Komponenter og tilkoblinger på diagrammet vil bli markert i rød, grønn eller lilla der det er forskjeller mellom de innhold som er synlig på den aktuelle diagrammet, og innholdet i den andre arkitektur. rød brukes der det anbefales å synkronisere forskjellene (se nedenfor), Grønn brukes der det ikke er anbefalt å synkronisere forskjellene, er at holde dem (se nedenfor) og Purple brukes der ABACUS ikke kan gi en anbefaling om synkronisering av forskjellene (se nedenfor). Bare den synlige innhold på diagrammet blir sammenlignet slik at hvis en merknad viser et depot egenskap verdi og at verdien er endret gitt komponent eller forbindelsen vil bli vist i svakt rødt, svak grønn eller svak lilla og en "*" symbolet vises øverst til venstre på komponenter, men hvis noen andre underliggende depot eiendommens verdi endres som ikke blir vist i en kommentar da ingen indikasjon vil bli gitt. Innhold som oppstår på gjeldende diagrammet, men ingen match er funnet i sammenligningen arkitekturen vil bli vist i sterk rød, sterk grønn eller sterk lillaog et '+' symbol vises øverst til venstre for komponenter. Matching er gjort av komponent type og navn slik at hvis typen eller navnet på komponenten eller forbindelsen har endret seg i den andre arkitekturen ingen kamp vil bli funnet. Ettersom det ikke er noen måte for på en pålitelig måte å bestemme hvorvidt ytterligere innhold fra den andre arkitektur ville ha blitt vist på den aktuelle diagrammet (for eksempel et ekstra grensesnitt mellom 2 komponenter som vist nedenfor i et diagram av en sammenligning arkitekturen til høyre), er disse forskjellene er ikke vist for diagrammer (de er vist for kataloger som per nedenfor). Svever over hvert endret elementet vil vise forskjellen i verktøytipset. Svever over '*' symbolet øverst til venstre i diagrammet gir en oppsummering av endringene (eller ingen endring) mellom diagrammet innhold og innholdet i den andre arkitekturen.

Farge Legend

· Grønn indikerer elementer som det ikke er anbefalt å synkronisere forskjellene, er at for å holde dem.

· rød indikerer elementer som det er anbefalt å synkronisere forskjellene.

· Purple indikerer elementer der ABACUS ikke kan gjøre en anbefaling om synkronisering av forskjellene.

Til synkron ('sync') innhold fra en arkitektur med hverandre via et diagram

1. Kontroller at du har en ABACUS fil åpen .

2. Sikre deg ha minst 2 arkitekturer i prosjektet.

3. Åpne diagrammet du ønsker å sammenligne med en annen arkitektur.

4. Klikk på "Sammenlign dette Katalog til innholdet i en annen arkitektur" -knappen på Diagram verktøylinjen.

5. Velg den andre arkitekturen fra rullegardinlisten for å sammenligne.

Notat

Se over for måten ABACUS viser 'diff' mellom de 2 arkitekturer i katalogen. Spesielt hvordan rød anvendes der det eranbefales å synkronisere forskjeller, Grønn brukes der det er ikkeanbefales å synkronisere forskjellene og Purple brukes der ABACUS ikke kan gi en anbefaling om synkronisering av forskjellene.

6. Høyreklikk på diagrammet element (eller elementer med Shift eller diagrammet lerret å synkronisere alle) som viser en "diff" og velg menypunktet Sync.

Notat

Eventuelle synkroniserings endringer vil kun bli brukt til arkitektur som for øyeblikket er i fokus katalogen tilhører. Å bruke endringene til den andre arkitekturen må du bruke en katalog i den andre arkitekturen. Videre vil brukere kunne bruke synkroniserings endringer hvis de har tillatelse til å gjøre det .

Notat

Avhengig av hvor du høyreklikke på menyelement vises veiledning om hva nettopp kommer til å bli synkronisert.F.eks Høyreklikke på en enkelt komponent i diagrammet vil bare synkronisere den komponenten. Mens høyreklikke på diagrammet lerretet og velge Sync Alle vil synkronisere alle for tiden vist forskjeller.

Til viser 'diff' med en annen arkitektur via en katalog

1. Kontroller at du har en ABACUS fil åpen .

2. Sikre deg ha minst 2 arkitekturer i prosjektet.

3. Åpne katalogen du ønsker å sammenligne med en annen arkitektur.

4. Klikk på "Sammenlign dette Katalog til innholdet i en annen arkitektur" -knappen på Catalogue verktøylinjen.

5. Velg den andre arkitekturen fra rullegardinlisten for å sammenligne med.

6. Du kan filtrere hva forskjellene er vist ved å klikke på 'Forskjeller' knappen på Diagram verktøylinjen og fjerne valg av alternativer, f.eks Endret / lagt til / Unknown og Ubestemmelige / Sync Anbefalt/ Hold Anbefalt.

Notat

Celler i katalogen vil bli markert i rød, grønn eller lilla hvor det er forskjeller mellom innholdet i gjeldende katalog og målrettet innhold i annen arkitektur. rød brukes der det anbefales å synkronisere forskjellene (se nedenfor), Grønn brukes der det ikke er anbefalt å synkronisere forskjellene, er at holde dem (se nedenfor) og Purple brukes der ABACUS ikke kan gi en anbefaling om synkronisering av forskjellene (se nedenfor). Bare de synlige rader og kolonner i katalogen blir sammenlignet slik at hvis det er en forskjell i en rad utover de for øyeblikket vises radene eller en verdi i en søyle som ikke er vist har en forskjell da ingen forskjell vil bli angitt. Hvor verdien i en enkelt celle er annerledes med den matchende celle i sammenligning arkitektur cellen grensen vil bli markert. Kolonneoverskriften og rad velgeren vil også bli skyggelagt i svak lillaog vist med en '*' symbol. Disse "*" symboler kan klikkes for å hoppe til neste forskjellen i kolonnen eller raden hhv. Rader som oppstår i den aktuelle katalogen, men ingen match er funnet i sammenligningen arkitekturen vil bli vist med en "+" symbol i raden velgeren til venstre og grensen til hele raden vil bli markert. Rader som ville ha skjedd i sammenligningen arkitekturens versjon av katalogen (dvs. med de samme filtre etc), men ingen match er funnet i den nåværende arkitekturen vil bli vist med en '-' symbol i raden velgeren til venstre, grensen hele raden vil bli markert og hele rader celler innholdet vil bli vist i svak lillaog slo gjennom, f.eks 8am til 18:00. Matching er gjort av komponent type og navn slik at hvis typen eller navnet på komponenten eller forbindelsen har endret seg i den andre arkitekturen ingen kamp vil bli funnet. Svever over hvert endret elementet vil vise forskjellen i verktøytipset. Svever over '*' symbolet øverst til venstre i diagrammet gir en oppsummering av endringene (eller ingen endring) mellom diagrammet innhold og innholdet i den andre arkitektur.

Farge Legend

· Grønn indikerer elementer som det ikke er anbefalt å synkronisere forskjellene, er at for å holde dem.

· rød indikerer elementer som det er anbefalt å synkronisere forskjellene.

· Purple indikerer elementer der ABACUS ikke kan gjøre en anbefaling om synkronisering av forskjellene.

Til synkron ('sync') innhold fra en arkitektur med hverandre via en katalog

1. Kontroller at du har en ABACUS fil åpen .

2. Sikre deg ha minst 2 arkitekturer i prosjektet.

3. Åpne katalogen du ønsker å sammenligne med en annen arkitektur.

4. Klikk på "Sammenlign dette Katalog til innholdet i en annen arkitektur" -knappen på Catalogue verktøylinjen.

5. Velg den andre arkitekturen fra rullegardinlisten for å sammenligne.

Notat

Se over for måten ABACUS viser 'diff' mellom de 2 arkitekturer i katalogen. Spesielt hvordan rød anvendes der det eranbefales å synkronisere forskjeller, Grønn brukes der det er ikkeanbefales å synkronisere forskjellene og Purple brukes der ABACUS ikke kan gi en anbefaling om synkronisering av forskjellene.

6. Høyreklikk på cellen, kolonne eller rad på vei (eller flere elementer ved hjelp av Shift eller Ctrl + A for alt) som viser en "diff" og velg menypunktet Sync.

Notat

Eventuelle synkroniserings endringer vil kun bli brukt til arkitektur som for øyeblikket er i fokus katalogen tilhører. Å bruke endringene til den andre arkitekturen må du bruke en katalog i den andre arkitekturen. Videre vil brukere kunne bruke synkroniserings endringer hvis de har tillatelse til å gjøre det .

Notat

Avhengig av hvor du høyreklikker (dvs. en celle, kolonne eller rad overskriften) menypunktet vises veiledning om hva nettopp kommer til å bli synkronisert.F.eks Høyreklikke på et enkelt eiendom eller festet komponent celle i katalogen vil kun synkronisere at eiendom eller festet komponent. Mens høyreklikke på rad på vei (eller overskrifter ved å bruke Shift) vil synkronisere hele raden (eller rader). Høyreklikke på en kolonneoverskrift vil synkronisere alle forskjellene i denne kolonnen.

Hvis du vil vise en 'diff'2 hel arkitekturer

1. Kontroller at du har en ABACUS fil åpen .

2. Sikre deg ha minst 2 arkitekturer i prosjektet.

3. Velge Verktøy| Arkitektur Diff ....

4. I dialogboksen som vises velger du først / Fra og andre / Til arkitekturer å sammenligne.

5. Klikk på OK knapp.

Arkitektur Diff

Farge Legend

· Grønnindikerer at noden ble tilsatt i den andre / Til arkitektur.

· rødindikerer at noden er slettet i den andre / Til arkitektur.

· Blåindikerer at noden har forskjellige egenskaper (f.eks egenskaper eller standarder) i den andre / til arkitektur.

· Gulindikerer at noden har forskjeller i sine barn i den andre / To-arkitektur, slik at noden skal ekspanderes.

Notat

Du kan høyreklikke og "Show in Explorer" på alle nodene for å se detaljer og mer informasjon er gitt på forskjellene i forskjellene Oppsummering-panelet når en node er valgt.

Se også

Analysere din arkitektur | Vise en responstid diagram | Vise en scatterplot matrise av dine utviklet seg arkitekturer | Utviklende din arkitektur


Endre egenskapene til en komponent, tilkobling eller type

Navigasjon: Fyller ditt arkitektur> Egenskaper>

Endre egenskapene til en komponent, tilkobling eller type

Send kommentarer om dette emnet.

Egenskapene er vanligvis systemkravene som du definerer, eller resultatene av ABACUS 'evalueringer. (Når ABACUS utfører sine vurderinger, skriver den eiendommer tilbake til filen.) Med andre ord, egenskaper er de tingene du vet om systemet ditt, eller de tingene du bruker ABACUS å finne ut.

For å endre eiendommens verdi av en komponent, tilkobling eller type

1. Klikkpå komponent / tilkobling / type (dens egenskaper vil vises i vinduet Egenskaper til høyre).

2. Klikkfor å markere den eiendommen du ønsker å endre.

3. Typeen ny verdi.

Viktig

Dessuten er mange egenskaper definert ved hjelp Standarder . Ved å endre en eiendom innenfor en StandardDu ikke bare endre gjeldende objekt, kan du også endre master Standard (under Standarder påtoppen av treet). Før du gjør dette, sjekk hva andre komponenter, koblinger eller typer bruker Standard, Fordi endringen ikke kan være relevant for dem- Du kan bruke referanser vinduet for denne.

Tupp

Du kan endre egenskaper en tilkoblings s fra innenfor Components gren av treet (og vice-versa). Så, for eksempel, hvis du ser på hvilke tilkoblinger er festet til en komponent, og du innser at du må endre en, du kan.

For å legge til nye egenskaper til en komponent eller tilkobling (via type)

Notat

Egenskaper kan bare legges til typer og komponentene eller tilkoblinger av typen "arve" disse egenskapene.

1. Klikkpå type (dens egenskaper vil vises i vinduet Egenskaper til høyre).

2. Klikkpå knappen Legg på toppen av eiendommen vinduet for å legge til en rad på toppen av eiendommen nettet for den nye eiendommen.

3. Legg en Typefor den nye eiendommen.

4. Legg en Navnfor den nye eiendommen.

5. Legg en Standardverdifor den nye eiendommen.

6. Legg en Enhetfor den nye eiendommen.

7. Sett Datatypefor den nye eiendommen.

Notat

Datatype-feltet kan brukes til å begrense de gyldige verdier at en eiendom kan ha. Det er; Tekst, Integer, Desimal, dato / tid, boolsk eller Liste.

o A TekstEiendommen er en som har et ubegrenset antall tegn og i hovedsak har ingen restriksjoner på verdien.Dersom eiendommen verdien er en skikkelig dannet hyperkobling (dvs. URLer trenger for å starte med en av 5strenger; http: //, https: //, ftp: //, fil:eller \\ og eventuellearealer bør legges inn med en '% 20') Deretter koblingen er klikkbare (via ctrl + klikk).

o En IntegerEiendommen må være et helt tall enten positiv eller negativog kan inneholde en periode, mellomrom, apostrof eller komma for sifret gruppering avhengig av prosjektets Soneinnstillinger fra Fil | Alternativer prosjekt.Regionen innstillinger og den.Nett Long.TryParse metode er brukes til å bestemme gyldige Integerverdier.

o A DesimalEiendommen kan inneholde en punktum eller komma for desimaltegnet symbol og kan inneholde en periode, mellomrom, apostrof eller komma for sifret gruppering avhengig av prosjektets Soneinnstillinger fra Fil | Alternativer prosjekt.Regionen innstillinger og den.Nett Decimal.TryParse metode er brukes til å bestemme gyldige Desimal verdier.

o A Dato tidHotellet tillater enten en dato del eller en Time del eller begge deler. Regioneninnstillingerog .Net DateTime.TryParse metode er først og fremst brukes til å bestemme gyldig dato og / eller tid verdier. Men den Date del hvis aktuelt krever minst dag og måned (the Year vil bli antatt å være inneværende år) eller måned og år deler for å være gyldig. Dvs. Juni Q3 2010 eller til og med bare 2010 er ugyldig. Selv om det vil variere med ulike regionale innstillinger, typisk dag, måned og år deler kan skilles med et mellomrom, komma, bindestrek ("-") eller skråstrek ('/'). The Day delen er vanligvis et tall fra 1 til 31. måned delen er vanligvis et tall fra 1 til 12, et gyldig 3 bokstav forkortelse for månedene (f.eks Jan, Feb, Mar) eller hele måneden navn (for eksempel januar, februar , Mars). Årets delen er vanligvis en fire sifret positivt tall, men 1, 2 og 3 sifrede år er akseptert i henhold til innstillingene i Kontrollpanel-> Regional and Language Valg-> Regional Valg-> Skreddersy (knapp) -> dato-> Kalender. Vanligvis de tolkes som følger; 0-29 tolkes som 2000-2029, 30-99 som 1930-1999 og 100-999 som 100-999. Ugyldige datoer slik som 31 juni 2010, og 31/9/2010 vil bli oppdaget. The Time del eventuelt krever en timer og minutter del og eventuelt en sekunddelen. Timer, minutter og valgfrie Sekunder deler er vanligvis atskilt med et kolon (':') og Seconds del kan spesifiseres med et desimaltegn ('.'). For ytterligere informasjon om gyldige formater henvises til avsnittet Merknader på .Net DateTime.TryParse metode .

Tupp

Det anbefales å bruke minst tre brev måneden navn format (dvs. "Jul" eller "July") for datoverdier fremfor numerisk formatering (dvs. "7" eller "07") som disse verdiene vil validere tvers av de fleste regioner avhengig på prosjektets Soneinnstillinger fra Fil | Alternativer prosjekt.Dvs. anbefales det å bruke "15 jul 2010" heller enn "15/7/2010" eller "7/15/2010". Med dette eksempelet "15/7/2010" ville mislykkes validering for 'English (United States) "og" 7/15/2010 "ville mislykkes for' English (United Kingdom)", men "15 jul 2010" ville passere for både.

o A BooleanEiendommen kan være enten sant eller usant.Det er små bokstaver så SANN eller USANN kan også brukes, men ja, nei, 1, 0 etc vil alle mislykkes eventuelle eiendoms begrensninger.

o A ListeHotellet tillater bare en samling av forhåndsdefinerte verdier som lav | Medium | Høy eller Beholde | Oppdater | Redesign | Pensjonere seg og verdiområdet kommer fra feltet Enhet for eiendom enten som komma eller rør '|' separerte verdier. Egenskapen kan anses å være ordens (i motsetning til den nominelle, intervall eller forhold) fordi når den brukes på diagrammer og å farge elementer på diagrams og 3ds verdiene blir behandlet rett og slett i en stigende (eller synkende) rekkefølge. Det er verdier plottes i stigende (eller synkende) rekkefølge på chart akser eller fargeområder.

8. Datatype kan settes til å være Funksjonshemmet, Advart eller Håndhevesved å høyreklikke Datatype-feltet for noen annen innstilling enn tekst, noe som gir noen tegn så kan aldri være feil.

9. Sett Påkrevdflagg for den nye eiendommen.

Notat

Den Obligatorisk felt kan brukes til å indikere om en verdi må oppgis for eiendommen. Det er at det ikke kan være tom eller tom. falsker standard, og betyr at eiendommen kan være tom eller tom, ektebetyr at eiendommen skal ha en verdi, og kan ikke være tom eller tom. Nødvendig kan settes til å være Funksjonshemmet, Advart eller Håndhevesved å høyreklikke Obligatorisk felt hvis det er satt til True.

Se også

Fyller din arkitektur - Oversikt | Legge forhåndsinnstilte egenskapene til en komponent, tilkobling eller type | Samlede eiendommer


Endre en komponent / tilkobling s Type

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Endre en komponent / tilkobling s Type

Send kommentarer om dette emnet.

Komponent- og tilkoblingstypene er i hovedsak brukt i klassifiseringsøyemed. Du kan bruke typer som filtre når du viser din arkitektur. For eksempel, i stedet for å se på hele greia, kan du vise bare programkomponentene.

For å endre en komponent / tilkobling s Type

1. Høyreklikkpå komponenten eller forbindelsen.

2. Velge Endringstype.

3. Velg en annen type fra listen.

Tupp

Når du endrer Type, kan du få noen nye standardereller egenskaper (det som er assosiert med den typen - se Typer gren av treet). Den eksisterende standarder og egenskaper vil forbli uendret. Du kan lage dine egne nye typer og tildele dine egne kombinasjoner av standarder og egenskaper til dem.

Se også

Opprette en ny type | Fyller din arkitektur - Oversikt | Analyse din arkitektur


Endre en Prosjektets Region innstillinger

Navigasjon: Fyller ditt arkitektur> Egenskaper>

Endre en Prosjektets Region innstillinger

Send kommentarer om dette emnet.

Eiendomsverdiene krever visse formatering i ulike regioner for å matche ethvert Datatype begrensninger for Integer, Desimal og dato / klokkeslett egenskaper. For eksempel i Australia desimaltegnet "123456 punkt sju åtte ni" er representert som "123,456.789", mens i Tyskland ville det bli represnted som "123.456,789" og i Frankrike ville det være " 123 456 789 ".Tilsvarende i USA "andre av desember 1970" er representert som en kort date som "12/2/1970", men i Storbritannia er representert som "2/12/1970" og i Polen som "1970-1912 -02 ". Følgelig, for å jobbe med en ABACUS prosjekt på tvers av regioner kreves en global innstilling per ABACUS prosjekt.

Å endre en ABACUS prosjektets Region innstillinger

1. Kontroller at du har en ABACUS fil åpne.

2. Velge Fil | Prosjekt alternativer ... og fra dialogboksen som dukker opp velg Region og Klikk på OK. Merk: Vennligst referer til avsnittet nedenfor for de regionale mislighold.

Notat

Hvis du ikke ser den Prosjekt alternativer ... menyvalgetså du ikke har Designer og Administrator Legg tils og du kan ikke endre prosjektets region.Også, hvis ingen Region er satt (dvs. Region i Prosjekt alternativer er "Ingen (System Region) ') og deretter hver brukerens MS Windows-innstillinger nåværende kultur (dvs. Regional Settings)brukes til å validere egenskaper.

Region mislighold

Tabellen nedenfor viser den standardverdier for hver region som er satt gjennom Fil | Prosjekt alternativer ...menyvalget.Vennligst se under bordet for en liste med symboler som brukes.

Region | Desimalsymbol | Digit gruppering | Negativt fortegn | Kort tid | Lang tid | AM / PM symbol | Kort Dato | Long Dato
English (Australia) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / åååå | dd MMMM åååå
English (United Kingdom) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / åååå | dd MMMM åååå
English (United States) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / åååå | dddd, MMMM dd, åååå
Fransk (Frankrike) | , | rom | - | HH: mm | HH: mm: ss | | | dd / mm / åååå | dddd d MMMM åååå
Tysk (Tyskland) | , | . | - | HH: mm | HH: mm: ss | | | DD.MM.ÅÅÅÅ | dddd, d. MMMM åååå
Italiensk (Italia) | , | . | - | HH: mm | HH: mm: ss | | | dd / mm / åååå | dddd d MMMM åååå
Spansk (Spania) | , | . | - | H: mm | H: mm: ss | | | dd / mm / åååå | dddd, dd 'de' MMMM 'de' åååå
English (Canada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / mm / åååå | MMMM-dd-yy
Fransk (Canada) | , | rom | - | HH: mm | HH: mm: ss | | | åååå-MM-dd | d MMMM åååå
Arabisk (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / åååå | dd MMMM, åååå
Arabisk (Saudi Arabia) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / åå | dd / MMMM / åååå
Norsk (Sør-Afrika) | , | rom | - | hh: mm tt | hh: mm: ss tt | AM | PM | åååå / MM / dd | dd MMMM åååå
Norsk (New Zealand) | . | , | - | h: mm tt | h: mm: ss tt | a.m. | pm. | d / MM / åååå | dddd, d MMMM åååå
English (India) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd-MM-test | dd MMMM åååå
Tysk (Sveits) | . | ' | - | HH: mm | HH: mm: ss | | | DD.MM.ÅÅÅÅ | dddd, d. MMMM åååå
French (Belgia) | , | . | - | HH: mm | HH: mm: ss | | | d / MM / åååå | dddd d MMMM åååå
Nederlandsk (Belgia) | , | . | - | H: mm | H: mm: ss | | | d / MM / åååå | dddd d MMMM åååå
Tsjekkia (Tsjekkia) | , | rom | - | H: mm | H: mm: ss | Dop |. ODP. | d.M.yyyy | d. MMMM åååå
Danish (Danmark) | , | . | - | HH: mm | HH: mm: ss | | | dd-MM-test | d. MMMM åååå
Gresk (Hellas) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / åååå | dddd, d MMMM åååå
Finsk (Finland) | , | rom | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'åååå
Ungarsk (Ungarn) | , | rom | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | åååå. MMMM d.
Nederlandsk (Nederland) | , | . | - | H: mm | H: mm: ss | | | d-M-test | dddd d MMMM åååå
Norsk, bokmål (Norge) | , | rom | - | HH: mm | HH: mm: ss | | | DD.MM.ÅÅÅÅ | d. MMMM åååå
Polish (Poland) | , | rom | - | HH: mm | HH: mm: ss | | | åååå-MM-dd | d MMMM åååå
Russisk (Russland) | , | rom | - | H: mm | H: mm: ss | | | DD.MM.ÅÅÅÅ | d MMMM åååå 'г.'
Svensk (Sverige) | , | rom | - | HH: mm | HH: mm: ss | | | åååå-MM-dd | 'hi' d MMMM åååå
Korean (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | åååå-MM-dd | åååå '년' M '월' d '일' dddd
Hebraisk (Israel) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / mm / åååå | dddd dd MMMM åååå

Følgende symboler brukes for å angi hvordan datoer og klokkeslett:

Tid symboler |
h | Time (tt viser timen med en ledende null)
m | Minutt (mm viser minuttet med en ledende null)
s | Sekund (ss viser andre med en ledende null)
tt | ER. eller P.M.
h / H | 12 eller 24 timers visning
Dato symboler |
d, dd | Dag
ddd, dddd | Dag i uken
M | Måned
y | År

Se også

Fyller din arkitektur - Oversikt | Endre egenskapene til en komponent, tilkobling eller type | Legge forhåndsinnstilte egenskapene til en komponent, tilkobling eller type


Kommandolinjevalg

Navigasjon: Referanse>

Kommandolinjevalg

Send kommentarer om dette emnet.

Du kan utføre ulike ABACUS operasjoner direkte fra kommandolinjen med den vanligste operasjonen er å åpne et bestemt prosjekt fil og publisere den på HTML.

Spesifikt, kommandolinje bruk av ABACUS er som følger;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "BRUKER" / pass "PASS"]

Argument | Beskrivelse
ProjectFile | Den ProjectFile kan enten være en ABACUS prosjektfilen (.abacus), bibliotekfilen (.abacuslib), XML-fil (XML) eller MS Access DB (MDB) og den angitte filen vil enten bli åpnet (hvis .abacus eller .abacuslib ) eller et nytt prosjekt opprettet (hvis XML eller MDB-fil).
OptionalFile | Den OptionalFile kan enten være en ABACUS script (.abacusscript, .vb eller .cs), makro (.abacusmac) eller bibliotekfil (.abacuslib) og den angitte filen vil enten bli kjørt etter å ha åpnet ProjectFile (hvis .abacusscript, .vb eller .cs eller .abacusmac) eller rett og slett åpnet (hvis .abacuslib).
/ exitOnCompletion | Vil avslutte ABACUS og om nødvendig redning og forplikte eventuelle endringer i de åpne .abacus prosjekter på ferdigstillelse av noen script eller makro. Merk: Dette flagget er Case Sensitive så pass på å bruke store bokstaver 'O' og 'C' i teksten som vist.
/ dontShowDialogs | Vil hindre ABACUS Enterprise Edition (EE) oppdatering varslingsdialogbokser vises på åpning et prosjekt. Merk: Dette flagget er Case Sensitive så pass på å bruke store bokstaver "S" og "D" i teksten som vist.
/ bruker "BRUKER" / pass "PASS" | Brukernavnet bruker og passord PASS vil bli brukt til å logge på prosjektet med, og overstyrer eventuelle lagrede brukerlegitimasjon. Merk: Doble anførselstegn må plasseres rundt brukeren og PASS flagg og to doble anførselstegn kan brukes til å unnslippe doble sitater i enten bruker eller PASS flagg.

F.eks;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / bruker "Public" / pass "123456"

når kjøres fra katalogen der de ABACUS.exe binær er plassert vilje åpne eksempelprosjekt og logg inn som bruker offentlig med passord 123 456 (som beskrevet her ), Publiserer det til HTML og deretter avslutte prosjektet alt uten å vise noen dialoger underveis (f.eks 'Update Vellykket "eller" Ingen oppdateringer tilgjengelig "for Enterprise prosjekter).

F.eks;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalog Excel Import.vb"/ exitOnCompletion / dontShowDialogs

når kjøres fra katalogen der de ABACUS.exe binær er plassert vilje åpne eksempelprosjekt og importere "Servers (2014 Actual) .xlsx" MS Excel-fil inn i 'servere' katalog av "2014 Actual 'arkitektur av prosjektet uten å vise noen dialoger underveis og deretter lukke prosjektet ved ferdigstillelse. Hvis operasjonen gjør endringer i prosjektet så når du lukker endringene er lagret lokalt, og hvis en Enterprise prosjektet forpliktet til Enterprise Server.

Notat

Pass på å bruke riktig doble anførselstegn som det er flere i standard ASCII tegnsettet og Windows Command Prompt vil kun fungere riktig med det riktige. Den korrekte dobbelt anførselstegn kode er Desimal 34 (heksadesimal 22).Dette er hva som er brukt i eksempelet ovenfor så gjerne kopiere / lime det derfra.


Kopiere og lime inn

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Kopiere og lime inn

Send kommentarer om dette emnet.

Du kan kopiere hele eller deler av arkitektur og lime den inn i et annet sted i treet.

Hvis du vil kopiere

1. Høyreklikkpå elementet vil du kopiere.

2. Velge Kopiere.

Hvis du vil lime

1. Navigere i treet for å finne stedet du ønsker å lime inn elementet.

2. Høyreklikkpå grenen du vil det skal vises innenfor.

3. Velge Lim.

4. Elementet vil bli kopiert med det opprinnelige navnet (med mindre du kopiere den til den opprinnelige avslaget - så vil det bli kalt "Kopi av ...").

Se også

Hvordan er en arkitektur representert i ABACUS


Kopiering diagrammer

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

Kopiering diagrammer

Send kommentarer om dette emnet.

Det er 2 grunnleggende scenarier til å kopiere et eksisterende diagram; innenfor en arkitektur, eller på tvers av arkitekturer.

Til kopiereet diagraminnenfor en arkitektur

1. Kontroller at du har enABACUS fil åpeninneholder din befolket arkitekturmed minst ett diagram.

2. Utvide de Diagrammergren (og eventuelle nødvendige Diagram grupper) av en gitt Arkitekturseksjon av treet.

3. Velg diagrammet du ønsker å kopiere og trykk deretter på Ctrl + C eller Høyreklikkog velg Kopiere fra menyen.

Notat

A kopi av diagram vil bli lagt til Diagrammergren av samme arkitektur. Den vil ha "Kopier av" legges til begynnelsen av navnet, Som du kan endre senere ved trykke F2 eller høyreklikke på detog velge Rename.

Til kopiere et diagram over arkitekturer

1. Kontroller at du har enABACUS fil åpeninneholder din befolket arkitektursmed minst ett diagram.

2. Utvide de Diagrammergren (og eventuelle nødvendige Diagram grupper) av de Arkitekturseksjon av treetfor arkitektur som inneholder diagrammet du ønsker å kopiere.

3. Velg diagrammet du ønsker å kopiere og på Generelle egenskapervindu notat Utsiktspunkt at diagrammet er knyttet til (i Type-feltet).

4. Nå, utvide de Diagrammergren (og eventuelle nødvendige Diagram grupper) av de Arkitekturseksjon av treetfor det andre arkitektur som du ønsker å kopiere diagrammet inn.

5. Høyreklikk de Diagrammer node (eller Diagram gruppe) Og velg Opprett Diagram .... I dialogboksen som vises velger Utsiktspunkt som ble notert i trinn 3 ovenfor i rullegardin øverst til høyre. La alt annet som er og klikk OK. I dialogboksen Diagram Name skriv inn et navn for den (snart) kopiert diagram. Merk: En blank diagram lerretet i henhold til valgt synspunkt vil bli åpnet.

6. Gå tilbake til diagrammet som du ønsker å kopiere og åpne det ved å høyreklikkenoden og velge Åpne eller rett og slett dobbeltklikke den.

7. Velg bakgrunns lerret av diagrammet du ønsker å kopiere, og trykk Ctrl + A. Dette vil velge alle elementene på at diagrammet. Nå trykker Ctrl + Cå kopiere innholdet til utklippstavlen.

8. Nå, tilbake til den tomme diagram i arkitekturen du ønsker å kopiere innholdet i, velge bakgrunnslerret og enten Høyreklikkog velg Lim eller bare trykke Ctrl + Vå lime inn innholdet. Etter en kort tid innholdet vil alle bli limt inn i ny blank diagrammet.

Notat

Elementer vil bli lagt til det øverste nivået av den nye arkitekturen og må re-arrangert eller slått sammen med eksisterende innhold tilsvar.

Se også

The Drawing Tool | Fyller din arkitektur | Analyse din arkitektur


Opprette en ny komponent / tilkoblingstype eller Typegruppe

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Opprette en ny komponent / tilkoblingstype eller Typegruppe

Send kommentarer om dette emnet.

Komponent- og tilkoblingstypene er i hovedsak brukt i klassifiseringsøyemed. Du kan bruke typer som filtre når du viser din arkitektur. For eksempel, i stedet for å se på hele greia, kan du vise bare programkomponentene.

For å opprette en ny komponent / tilkobling Type

Notat

For å legge til typer eller type grupper i en ABACUS prosjekt brukerlisensen må Designer add-on evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

1. Utvid Typergren av treet.

2. Høyreklikk på Komponenttyper (eller Tilkoblingstyper).

3. Velge Legg Component Type (eller Legg Tilkoblingstype) eller Opprett gruppe.

Tupp

Når du har opprettet en type, bør du endre ikonet (se nedenfor) og legge egenskaper og standarder til det for komponent eller tilkoblings tilfeller å "arve".

For å endre ikonet for en komponent / tilkobling Type

Notat

Å endre ikonene for typer i en ABACUS prosjekt brukerlisensen må Designer add-on evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

1. Høyreklikk på Komponent type (eller Tilkoblingstype) Du ønsker å endre ikonet for.

2. Velge Endre ikon.

3. I Velg Ikon dialog bla til en plassering, og velg en bildefil og klikk Åpne.

Notat

Du kan ha et egendefinert ikon bilde av alle størrelser, men det vil alltid bli skalert til å passe til en 16x16 pixel bilde i Explorer-vindu. Så hvis den opprinnelige egendefinert ikon bildet er ikke av samme høyde og bredde ditt Explorer-vindu ikon vil bli strukket. Følgelig bør tilpassede bilder være minst 16x16 piksler, og hvis du ønsker å beholde den eksakte formen på tilpasset ikon sørge for din egendefinerte ikonbilde er lik høyde og bredde i piksler (16x16 eller større). Du bør også være forsiktig med å ikke ha fargede 'piksler' gå hele veien til grensen av tilpasset ikon bildet slik det vil se dårlig i Explorer-vindu med tilstøtende ikoner 'blødning' inn i hverandre. Følgelig bør du la det være minst en 1 pixel hvit kant.

Tupp

Du kan lage din egendefinerte ikonbilde ICO, BMP, GIF, JPG eller PNG-format fil, men på grunn av en begrensning i Windows bare Ico formatet vil forhåndsvise i dialogboksen ABACUS Velg Ikon hvis du har menyen Vis alternativet satt til noe annet enn Thumbnails.

Se også

Fyller din arkitektur - Oversikt | Analyse din arkitektur


Opprette eller duplisere en arkitektur

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Opprette eller duplisere en arkitektur

Send kommentarer om dette emnet.

Du kan ha en rekke arkitekturer i en enkelt ABACUS fil. Vanligvis ville du oppretter en ny arkitektur hver gang du ønsker å modellere og vurdere en videreutvikling av systemet.

For å opprette en ny arkitektur

1. Høyreklikk på Arkitekturergren av treet.

2. Velge New Architecture.

Å lage en kopi av en eksisterende arkitektur

1. Høyreklikkpå arkitekturen.

2. Velge Kopiere.

3. Høyreklikk på Arkitekturergren av treet.

4. Velge Lim.

5. Den nye arkitekturen vil bli kalt "Kopi av ...".

Å utvikle en eksisterende arkitektur

1. Høyreklikkpå arkitekturen.

2. Velge Evolve.

3. Den nye arkitekturen vil bli kalt '... 0,1 ".

Notat

Det er en detaljert beskrivelse på utvikling arkitekturer her .

Se også

Hvordan er en arkitektur representert i ABACUS | Utviklende din arkitektur


Tilpassede rapporter

Navigasjon: Rapportering på arkitektur>

Tilpassede rapporter

Send kommentarer om dette emnet.

ABACUS 'egendefinerte rapporter tillate deg å lage helt konfigurerbare definerte rapporter. Rapportene kan omfatte tilpassede bilder og grafikk samt detaljering eventuelle komponenter, tilkoblinger eller attributter fra en ABACUS depot samt detaljerte analytiske resultater fra ulike simuleringer (inkludert TCO, ytelse og pålitelighet). I tillegg kan rapportene inneholder diagrammer, diagrammer, kataloger, matriser / pivottabeller, kart, måleinstrumenter, Sparklines, datalinjer og indikatorer (f.eks trafikklysene).

Notat

Mens alle brukere kan åpne eksisterende egendefinerte rapporter, to configure rapporter brukerlisensen må Rapporter Configuration evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

Hvis du vil vise en skikk rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur(s).

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapportervindu vises.

Tilpassede rapporter vindu

3. Velgeksisterende Rapporteresom du vil å vise fra Tilgjengelige rapporter avsnitt.

4. Klikk Kjør rapport.Rapporten åpnes i Microsoft Report Viewer og to Naviger gjennom rapportsider, klikk på ikonene [image] plassert på verktøylinjen øverst i venstre hjørne av skjermen.

Notat

Du kan spare rapporten til ulike formater ved å klikke på Eksport Rapporten ikon [image] plassert i verktøylinjen. Du kan velge å eksportere i følgende formater: Excel, PDF og Ord. Vennligst lagre rapporten på ønsket sted for senere bruk. Dersom det gjøres endringer i arkitekturen på et senere tidspunkt, vil en ny rapport må være opprettet for å gjenspeile endringene.

Til redigere depotet data som sendes til a skikk rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur(s).

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapporter vindu (vist ovenfor) vises.

Notat

Mens alle brukere kan åpne eksisterende egendefinerte rapporter, to configure dataene som sendes til en egendefinert rapport brukerlisensen må Rapporter Configuration evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

3. Velgeksisterende Rapporteresom du vil å vise fra Tilgjengelige rapporter avsnitt.

4. Klikk Rediger datasett. De Data Set Editorvindu vises.Dette vinduet viser samlingen av datasett som for tiden blir sendt til en egendefinert rapport. I eksemplet nedenfor er det tre (3);

· en ApplicationProxy datasett som spesifiserer alle detaljer for alle programkomponentene i '2015 Actual' arkitektur (inkludert egenskapene på sine standarder og eventuelle tilkoblede komponenter),

· en TwoDViewProxy datasett som spesifiserer en eller flere Diagrams hvor navnet matcher 'Application Landskap (Australia)',

· en TargetProxy datasett som spesifiserer alle detaljer for alle Target forbindelser i '2015 Actual' arkitektur (inkludert vedlagte komponenter).

Data Set Editor vindu

Notat

Spørre navn vil bli brukt til datasettet navnet i Microsoft Report Builder (se nedenfor). Inkluder feltet angir om datasettet er enten et enkeltelement, en samling elementer, alle komponenttyper, alle tilkoblingstyper, en eller flere arkitekturer, ett eller flere diagrammer eller en eller flere Charts. For den "Innsamling av Elements 'datasett et Filter-knappen er gitt som når klikket åpner Element Filter vindu som lar deg bruke flere filtre for å gå tilbake bare elementer fra visse arkitekturer, og / eller av visse typer og / eller med visse standarder og / eller knyttet til visse komponenter, og / eller med visse foreldre, og / eller i enkelte diagrammer, og / eller i visse Charts og / eller med gitte eiendomsverdier. For de øvrige datasett typer et navnefelt er gitt og bruker Select-knappen kan du velge objekt (er) som skal inkluderes med datasettet.

Notat

De datasett som er lagret i enDatasett fil (.xml)med samme base filnavn som enassosiert Rapporter Definition-fil (.rdl). Hvis denne filen ikke finnes datasettet redaktøren vil automatisk fylle med alle spørsmål navnene som finnes i Rapporter Definition-fil (.rdl)og en ny Datasett fil (.xml)vil bli laget mens aa gyldig liste over spørsmål er definert.

3. Hvis du ønsker å slette en eksisterende datasett velg Slett Query knapp.

4. Hvis du ønsker å legge til et nytt datasett deretter klikker du på Legg til ny datasettknappen for å konfigurere datasettet som per Note ovenfor.

Til lage en ny tilpasset rapportere(fra en mal)

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur.

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapporter vindu (vist ovenfor) vises.

3. Klikk Ny og velg enten A4 - Portrett, A4- Landscape, A3 - Portrett, A3- Landscape, US Letter - Portrett, US Letter - Landskap, US Tabloid - Portrett eller US Tabloid - Landskapavhengig rapporten orientering og papirstørrelse som er ønsket.

4. Naviger til stedet for å lagre rapportdefinisjon fil (.rdl / .rdlc) og matchende Data Set-fil (XML) og klikk Spare. Dette vil legge til en ny tilpasset rapport til Available Reports delen av Custom Reports vinduet, og det kan åpnes eller redigert som beskrevet ovenfor.

Til legge til en eksisterende egendefinert rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur.

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapporter vindu (vist ovenfor) vises.

3. Klikk Legg til og bla til plasseringen av rapportdefinisjon fil (.rdl / .rdlc) og klikk Åpne. Dette vil legge til en ny tilpasset rapport til Available Reports delen av Custom Reports vinduet, og det kan åpnes eller redigert som beskrevet ovenfor.

Notat

Det antas at en matchende Data Set-fil (XML) som finnes på samme sted som den rapportdefinisjon filen.

Til kopiere en eksisterende egendefinert rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur.

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapporter vindu (vist ovenfor) vises.

3. Velgeksisterende Rapporteresom du vil å kopiere fra Tilgjengelige rapporter avsnitt.

4. Klikk Kopiere og en kopi av den valgte rapporten (som heter "Kopi av ...") vil bli lagt til Available Reports delen av Custom Reports vinduet, og det kan åpnes eller redigert som beskrevet ovenfor.

Notat

Ved å gjøre dette vil du lage en kopi av rapporten Rapportdefinisjon fil (.rdl / .rdlc) så vel som dens matchende Data Set-fil (XML)(hvis den finnes).

Til fjerne en eksisterende egendefinert rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur.

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapporter vindu (vist ovenfor) vises.

3. Velgeksisterende Rapporteresom du vil for å fjerne fra Tilgjengelige rapporterseksjon og klikk Fjerne.

Notat

Når du fjerner en rapport vil det ikke lenger vises på rapportlisten. Men dette vil ikke slette Rapportens rapportdefinisjon fil (.rdl / .rdlc) eller Data Set fil(XML). Ved behov kan slette disse filene oppnås gjennom filsystemet.

Til endre navn på en eksisterende egendefinert rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur.

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapporter vindu (vist ovenfor) vises.

3. Velgeksisterende Rapporteresom du vil å endre navn på de Tilgjengelige rapporterseksjon og klikk Gi nytt navn.

4. Skriv inn et nytt navn for rapporten.

Notat

Både rapportdefinisjon fil (.rdl / .rdlc) og matchende Data Set-fil (XML) vil bli omdøpt tilsvar.

Til endre utformingen av en skikk rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur.

2. Velge Sett| Custom Rapportereller klikk på Opprett egendefinert rapport knappen på verktøylinjen. De Tilpassede rapporter vindu (vist ovenfor) vises.

Notat

Mens alle brukere kan åpne eksisterende egendefinerte rapporter, to configure utformingen av en tilpasset rapporter brukerlisensen må Rapporter Configuration evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.I tillegg er Microsoft Report Builder 3.0 kreves for å designe rapporter og det kan lastes ned gratis fra her .

3. Velgeksisterende Rapporteresom du vil å vise fra Tilgjengelige rapporter avsnitt.

4. Klikk Edit Report.Rapporten åpnes i Microsoft Report Builder 3.0. For spesifikk hjelp og noen tips og triks "på noen av de mer vanlige oppgaver med å designe rapporter henvises til avsnittene nedenfor. For generell hjelp på utforme rapporter Vennligst referer til Microsoft Report Builder 3.0 hjelpesider her .

Legge Bord til rapporten

1. Kontroller at du har en ABACUS Custom rapportdefinisjon fil (.rdl / .rdlc) åpen i Microsoft Report Builder 3.0.

2. Velge de Sett fanen i "bånd" øverst, deretter klikk på Bord knappI data Regioner delen og velg Sett inn tabell.

3. Nå dra markørentil posisjonen på rapport lerretet der du vil ha øvre venstre hjørne av tabellen for å plasseres. Klikk på lerretet. Som standard tabellen vil bli lagt med en header rad og deretter en detaljer gruppe (en gruppe brukes til å organisere en visning av en rapport datasettet). For å fjerne gruppen, enten slette raden eller slette Row konsernet i Gruppering verktøylinjen.

Tupps

Formler / uttrykk i tabellceller er redigert ved å markere cellen og deretter høyreklikke << Uttrykk >> tekst og velge Expression .... Sortere rader i en tabell gjøres ved å velge tabellen og deretter blar ned til Other -> SortExpressions feltet i Properties panelet og inn et uttrykk. For en total rad på slutten av en tabell legge til en rad etter (og utenfor) gruppering og deretter bruke følgende uttrykk = Sum (Fields!Navn.Verdi)"Name", der er det feltet som blir summert. Hvis du vil bruke farge til kolonner bruke en "iif 'uttalelse i bakgrunnsfarge eiendom. For å legge til en måler som en celle i en tabell først sette måleren inn i en celle, og deretter slippe datafelt som kreves for måleren. Når du redigerer høyden og bredder på tabellrader, sikre at du velger riktig rad, og deretter holder musepekeren rundt de grå linjene til du får pil opp / ned-markøren, deretter endre størrelsen.

Legge Charts til rapporten

1. Kontroller at du har en ABACUS Custom rapportdefinisjon fil (.rdl / .rdlc) åpen i Microsoft Report Builder 3.0.

2. Velge de Sett fanen i "bånd" øverst, deretter klikk på Chart knappI data Regioner delen og velg Sett Chart.

3. Nå dra markørentil posisjonen på rapport lerretet der du vil ha øvre venstre hjørne av kartet for å plasseres. Klikk på lerretet og så velge diagramdu ønsker fra alternativene og klikk OK.

Tupps

For å vise en eiendom som en merknad på listene, høyreklikk på diagrammet og velg Show dataetiketter, velg en av etikettene som er lagt til og sette Diverse -> UseValueAsLabel til False i Properties panelet og legge et uttrykk (f.eks = Name.Value Fields) i Generelt -> etikett. Spesielt for boble diagrammer; Boble diagrammer vises under Scatter diagrammet overskriften. Slippe X-aksen eiendom i serien felt (eller legge til i Properties-serien). Slipp Y-aksen eiendommen til datafelt (eller legge til i Properties-serien). For å bruke en eiendom for å definere boblestørrelse, slippe dette inn datafelt (eller legge til i Properties-serien). Boble diagrammer er ikke i stand til å vise om det er for mye data (200+ stk), noen ganger dette fører til at hele rapporten for å ikke vise. Marker Type - Sett til sirkelen. Som standard når slippe felt i datafeltene, legger det dem med sum()formel, så fjern dette. Spesielt for Stablet diagrammer / Timeline / Gantt-diagrammer; For et Gantt-diagram bruker en rekke diagram og legge til egenskaper som høy og lav verdier i datafeltene. Du kan ha flere "barer 'ved å legge til flere og flere områder, der lav verdi for én kamper den høye verdien for en annen. Spesielt for Kakediagrammer; For aggregerte kakediagrammer, slippe inn data i Kategori felt og i datafelt, legge formelen = CountRows (). Filtrere ut noen 0-verdier (f.eks på kostnads ​​diagrammer), vil ellers etikettene for disse fortsatt vises på kartet.

Bruke en Iif statement å legge farger til tabeller og diagrammer

1. Kontroller at du har en ABACUS Custom rapportdefinisjon fil (.rdl / .rdlc) åpen i Microsoft Report Builder 3.0.

2. Høyreklikk på cellen i tabellen til farge og klikk Tekstboks Properties.

3. Velge Fylle og klikk fxknappen til høyre for Fill fargeetiketten og i det ligger et uttrykk for bakgrunnsfarge felt inn et uttrykk, for eksempel = IIF (Fields! InformationStatus.Value = "Retain", "Lys grønn", iif (Fields! InformationStatus.Value = "Redesign", "Yellow", iif (Fields! InformationStatus.Value = "Refresh", "Orange", " Laks"))). Dette endrer bakgrunnsfargen til lys grønn for hver celle som inneholder Status 'Behold', gult for hver celle som inneholder Status 'Redesign', Orange for hver celle som inneholder statusen "Refresh" og alle andre statusverdien vil være farget i "Laks".

Notat

Farger kan legges for diagrammer ved å velge serien på diagrammet og deretter sette Utseende -> Color eiendom (eller for boble diagrammer Utseende -> Marker -> Color eiendom) til et uttrykk som ligner på eksempelet ovenfor.

Ting å huske på når du utformer egendefinerte rapporter

· Fordi alle eiendommer unntatt Integer sendes som en streng fra ABACUS rapporten seer hvis du ønsker å gjøre noen "uttrykk" med dem (som skillet en eiendom av en annen eller sort), må du konvertere dem til desimal eller Dato etc. For bakgrunn , denne artikkelen er en god referanse. F.eks = CDate (LifecycleEndDate.Value Fields!) notat: Sørg for at rapporten språket er satt til en-GB (som beskrevet nedenfor) for å godta dd / mm / åååå som det forventer mm / dd / åååå format som standard, og følgelig 31/7/2011 vil mislykkes konvertering. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = (CostTotalCosttoOwnnext5years.Value Fields!, 0) FormatCurrency

· Hvis du finner ut at du sliter med å holde alle tabeller og diagrammer på én sideEr det noen hoved måter å håndtere dokumentet plass:

· Page Break - Pass på at denne tabellen innstillingen er slått av for hver tabell som du ønsker å være på samme side.

· Hold sammen - Sikre denne tabellen innstillingen gjelder for hver tabell som du ønsker å være på samme side.

· Når du flytter rundt på ting, er det lettere å zoome ut med styre nederst til høyre på siden og deretter multi velge elementer og dra

· For bildet rad i en tabell, sørg for at den "Size" | 'Dimensjonering' eiendom er satt til 'Fit' ellers bildet kan virke for stor, eller det vil bli dårlig strukket.

· Til gjenta en header rad i en tabell på hver sideav rapporten:

1. Åpne Avansert modus i Grupperinger ruten. (Klikk på pilen til høyre for kolonnen Grupper og velg Avansert modus.)

2. I radgrupper området (ikke kolonnegrupper), klikk på en statisk gruppe, som fremhever den tilsvarende lærebok i tablix. Klikk gjennom hver Statisk gruppen inntil det fremhever kolonnen lengst til venstre spissen. Dette er vanligvis den første statiske gruppen oppført.

3. I vinduet Egenskaper, sett RepeatOnNewPage eiendommen til True.

4. Kontroller at KeepWithGroup eiendommen er satt til etter.

· Endre språkinnstillingeri Rapport eiendommer å matche dataformater du trenger, for eksempel en-GB å produsere UK datoformatet (dd / mm / åååå).

Se også

Analysere din arkitektur


Tilpasse ABACUS grensesnitt

Navigasjon: Introduksjon til ABACUS>

Tilpasse ABACUS grensesnitt

Send kommentarer om dette emnet.

Du kan endre utseendet og oppførselen til ABACUS grensesnittet på mange måter. ABACUS inneholder flere forhåndsdefinerte innstillinger kombinasjoner som du kan bruke til å gjelde en gruppe av tilpasninger til grensesnittet. I tillegg kan du gjøre individuelle tilpasninger til elementer som vinduer, verktøylinjer, hurtigtaster, og ulike viser alternativer.

Ordne og Dock Windows

Du har mange muligheter for å arrangere vinduer i grensesnittet for ABACUS, inkludert følgende:

· Tab-dock vinduer.

· Dock vinduer til kanten av en ramme i grensesnittet.

· Minimer verktøy vinduer langs kanten av grensesnittet.

· Tilbakestill vindu plassering til standardoppsettet.

Dokking Windows

Når et vindu er dokk, kan den festes til en side av en ramme i grensesnittet, eller det kan være anordnet på faner ruter innenfor rammen. En guide diamant vises når du drar vinduer fra sin nåværende posisjon til et annet sted i grensesnittet. Guiden diamant kan du raskt gjen forankre et vindu på en av de fire sidene av rammen eller i sentrum som et fanebasert ruten. Når et vindu ikke er forankret eller ikke kan forankres, det flyter på toppen av de andre vinduene.

Å forankre vinduer

1. Klikk på vinduet du vil forankre, for å gi det fokus.

2. På Vindumenyen klikker Kan forankres.

3. Dra vinduet fra gjeldende plassering mot midten av bildet du ønsker å forankre den med.

En guide diamant vises. De fire piler diamant peker mot de fire kantene av rammen og sentrum representerer faneruten.

Tupp

For å flytte en dokk vinduet uten å klikke det på plass, trykk CTRL mens du drar den.

4. Når vinduet du drar når posisjonen der du vil forankre den, flytter du markøren over den tilsvarende del av veiledningen diamant. Et omriss av vinduet vises i det angitte området.

5. Å forankre vinduet i posisjon angitt, slipper du museknappen.

For eksempel, hvis Explorerer forankret på venstre kant av grensesnittet, og du ønsker å forankre den på høyre kant, ville du drar Explorermot midten av grensesnittet, flytter du markøren over høyre side av styre diamant, og deretter slipper du museknappen.

Minimising Windows

Windows (enten de er Tool Windows - vises på Utsiktmenyen, eller Dokument Windows - vises på Vindumenyen) støtter en funksjon kalt Auto Hide. Auto Hide gjør at du kan se mer av arkitektur på en gang ved å minimere vinduer langs kantene av grensesnittet når den ikke er i bruk.

Slik slår du på Auto Hide

1. Klikk på vinduet du ønsker å skjule for å gi det fokus.

2. På Vindumenyen klikker Auto Hide.

- eller -

2. Klikk stiften ikonet på tittellinjen i vinduet.

Auto Hide Aktivert

Når en auto-skjult vindu mister fokus, automatisk glir den tilbake til fanen på kanten av grensesnittet. Mens et vindu er automatisk skjult, navnet og ikonet er synlig på en fane på kanten av grensesnittet. For å vise en auto-skjult vindu, flytter du markøren over fanen. Vinduet glir tilbake til syne, og er klar til bruk.

Notat

Et vindu som er auto-skjult kan ikke forankret. Hvis du vil forankre et vindu må du slå av Auto Hide som beskrevet nedenfor.

Slik slår du av Auto Hide

1. Klikk på vinduet du vil beholde synlig for gi det fokus.

2. På Vindumenyen klikker Auto Hidefor å fjerne haken.

- eller -

2. Klikk stiften ikonet på tittellinjen i vinduet.

Auto Hide Funksjonshemmede

Tupp

Vinduer som har Auto Hide aktivert midlertidig gli inn utsikten når vinduet har fokus. For å skjule vinduet igjen, velger du et element utenfor gjeldende vindu. Når vinduet mister fokus, glir den tilbake ut av visningen.

Stille Windows utforminger

Du kan returnere grensesnittet til Standard utforming bruker Tilbakestill uforming kommando. Når du kjører denne kommandoen, følgende skje:

· Alle vinduer er flyttet til standard stillinger.

· Windows som er stengt i Standard utforming er stengt av kommandoen.

· Vinduer som er åpne i Standard utforming blir åpnet av kommandoen.

· Vinduer som er skjult / synlig i Standard utforming er gjort skjult / synlig ved kommandoen.

Å tilbakestille vindu emisjon til standard layout

1. På Windowsmenyen klikker Tilbakestill uforming.

Tilpasse menyer og verktøylinjer

Du kan endre oppsettet, posisjon, og innholdet i menyer og verktøylinjer i grensesnittet. Du kan også legge til knapper på verktøylinjer og endre den tildelte ikon for hvilken som helst knapp.

Skape nye verktøylinjer

For å opprette en ny verktøylinje

1. På Verktøymenyen, velg Tilpass.

2. I Tilpassdialogboksen, velg Verktøylinjertab.

3. Velge Ny.

4. I Ny Verktøylinjedialogboksen Skriv inn et navn for verktøylinjen.

5. Velge OK.

For å legge til en kommandoknapp til en meny eller verktøylinje

1. På Verktøymenyen, velg Tilpass.

2. I Tilpassdialogboksen, velg Kommandoertab.

3. Velg en kategori og dra en kommando ut av dialogboksen til menyen eller verktøylinjen.

4. Velge Lukke.

Tupp

Holder nede Alt-tasten lar deg raskt tilpasse kommandoer som om dialogboksen Tilpass var åpen.

Se også

Den ABACUS grensesnitt


Definere og validere begrensninger

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Definere og validere begrensninger

Send kommentarer om dette emnet.

Strukturen og egenskapene til en arkitektur kan begrenses ved hjelp av begrensninger. Begrensninger kan brukes på komponenttyper og tilkoblingstyper for å begrense oppbyggingen av en arkitektur på to måter. Den første måten er å begrense hierarkived å definere "forelder bør / må ha barn" og "barn bør / må ha foreldre» -forhold. Den andre måten er å begrense topologived å definere "komponent bør / må festes til connection" og "connection bør / må festes til komponent» -forhold. Videre kan begrensninger brukes på egenskapene til komponenttyper, tilkoblingstyper, maler, utsiktspunkter, arkitekturer, diagrammerog 3D-visninger for å begrense arkitektur (r) i ytterligere to måter. Den første måten er å sette datatypeav eiendommen for å begrense de gyldige verdier som det kan ha, nemlig; Tekst, Integer, Desimal, dato / tid, boolsk eller Liste. Den andre måten er å sette påkrevdstatus av eiendommen for å indikere om en verdi må oppgis for eiendommen (Merk: Nødvendig begrensninger gjelder kun eiendommer for komponent- og tilkoblingstyper). Ytterligere informasjon om eiendoms begrensninger er gitt i Endre egenskapene til en komponent, tilkobling eller type hjelpeemnet. Når begrensninger er blitt definert, er det mulig å validere en arkitektur mot de begrensninger. ABACUS vil varsle om eventuelle begrensninger som har blitt krenket.

Nøkkelen til å bestemme hvilken begrensning (e) å definere ligger i nøyaktig språket som brukes til å beskrive begrensningen. For hierarki begrensninger er de vanligvis på formen "substantiverkan / bør / må deles opp i n substantiver" eller "substantiverkan / bør / må samles ved substantiver"Etc. For eksempel"Avdelingermå dekomponeres i Lag" eller "Søknaderkan dekomponeres i Moduler". For topologi begrensninger er de vanligvis på formen"substantiverkan / bør / må verb substantiver". For eksempel, "Prosesser kan være fremført av Lag" eller "Søknaderer vert på Servere. "Nå kan du se i hvert tvang det er ulike kan / bør / må" kvalifiseringen "og disse kan være av 3 typer;

· Valgfri- Disse vil vanligvis bruker ord / setninger som; "kan", "kan", "kunne", "eventuelt" etc.

· Anbefalt- Disse vil vanligvis bruker ord / setninger som; "bør", "anbefalte", "rådet" etc.

· Påbudt- Disse vil vanligvis bruker ord / setninger som; "must", "er", "er", "har", "skal" etc.

Avhengig av typen av begrensningen (hierarki eller topologi) og kvalifiserings benyttes for å beskrive den, bør spesifikk begrensning (e) være definert (se nedenfor). For de ovennevnte hierarkiet eksempel på "Avdelingermå dekomponeres i Lag"Man bør definere en" Parent må ha Child "begrensning og sette håndheving å bli håndhevet. For de ovennevnte topologi eksempel på"Prosesser kan være fremført av Lag. "Bør man bare lage to (2)" Connection må vedlegges Component "begrensninger for hver ende av utført av tilkoblingstype Konkret er følgende begrensninger anbefales å bli definert (se nedenfor) for de ulike alternativene;

· Hierarki begrensninger;

o Substantiver A kan væredekomponeres i Substantiver B, eller Substantiver B kan væreaggregeres etter Substantiver A eller Substantiver B burde væreaggregeres etter Substantiver A- Definer en "Child må ha Parent" begrensningen med barnet type som Noun B, forelder type som Noun A og håndheving som advart.

Notat

Dette betyr at hvis et barn foreligger, bør den ha en forelder av en viss type. Hvis ikke, vil du få en advarsel.

o Substantiver A burde væredekomponeres i Substantiver B- Definer en "Parent må ha Child" begrensningen med den overordnede type som Noun A, barn type som Noun B og håndheving som advart.

Notat

Dette betyr at dersom en av foreldrene foreligger, bør den ha barn i en bestemt type. Hvis ikke, vil du få en advarsel.

o Substantiver A må væredekomponeres i Substantiver B- Definer en "Parent må ha Child" begrensningen med den overordnede type som Noun A, barn type som Noun B og håndheving som håndheves.

Notat

Dette betyr at dersom en av foreldrene eksisterer, må den ha barn i en bestemt type. Hvis ikke vil du få en feilmelding.

o Substantiver A må væreaggregeres etter Substantiver B- Definer en "Child må ha Parent" begrensningen med barnet type som Noun A, forelder type som Noun B og håndheving som håndheves.

Notat

Dette betyr at hvis et barn eksisterer, må den ha en forelder av en viss type. Hvis ikke, vil du få en feilmelding.

· Topologi begrensninger;

o Substantiver A kan være verb Substantiver B- Definer to (2) "Connection må vedlegges Component" begrensninger. Den første var med Kilden slutten av tilkoblingstype verbknyttet til substantiv En komponent type og håndheving satt til håndhevet. Den andre blir med Sink slutten av tilkoblingstype verbfestet til Noun B komponent type og håndheving satt til håndhevet.

Notat

Dette betyr at hvis forbindelsen eksisterer, må det kobles komponenter av visse typer. Hvis ikke vil du få en feil. Samlet sikrer dette at disse komponentene kan fremdeles eksistere, og ikke forbundet med hverandre. Men hvis de er koblet til, må forbindelser av riktig type benyttes.

o Substantiver A burde være verb Substantiver B- Definer to (2) "Component må vedlegges Connection" begrensninger. Den første var med Noun En komponenttypen festet til enden av kilde verbtilkoblingstype og håndheving sett til advart. Den andre vesen med Noun B komponenttypen knyttet til Sink slutten av verbtilkoblingstype og håndheving sett til advart. I tillegg definerer to (2) "Connection må vedlegges Component" begrensninger. Den første var med Kilden slutten av tilkoblingstype verbknyttet til substantiv En komponent type og håndheving satt til håndhevet. Den andre blir med Sink slutten av tilkoblingstype verbfestet til Noun B komponent type og håndheving satt til håndhevet.

Notat

Dette betyr at hvis komponenter av enten type finnes, bør de være festet til en forbindelse av en bestemt type. Hvis ikke vil du få en advarsel. I tillegg betyr dette at hvis forbindelsen eksisterer, må det kobles til komponenter av den angitte typen. Hvis ikke vil du få en feilmelding. Samlet sikrer dette at hvis komponentene i disse typer finnes, vil man få advarsler om de ikke er forbundet med hverandre.

o Substantiver A må være verb Substantiver B- Definer to (2) "Component må vedlegges Connection" begrensninger. Den første var med Noun En komponenttypen festet til enden av kilde verbtilkoblingstype og håndheving satt til håndhevet. Den andre vesen med Noun B komponenttypen knyttet til Sink slutten av verbtilkoblingstype og håndheving satt til håndhevet. I tillegg definerer to (2) "Connection må vedlegges Component" begrensninger. Den første var med Kilden slutten av tilkoblingstype verbknyttet til substantiv En komponent type og håndheving satt til håndhevet. Den andre blir med Sink slutten av tilkoblingstype verbfestet til Noun B komponent type og håndheving satt til håndhevet.

Notat

Dette betyr at hvis komponenter av enten type finnes, må de festes til en forbindelse av en bestemt type. Hvis ikke vil du få en feilmelding. I tillegg betyr dette at hvis forbindelsen eksisterer, må det kobles til komponenter av den angitte typen. Hvis ikke vil du få en feilmelding. Samlet sikrer dette at hvis komponentene i disse typer finnes, oppstår det feil hvis de ikke er forbundet med hverandre.

For å definere en begrensning

1. Kontroller at du har en ABACUS filåpen og Explorer-vinduvises.

2. I explorer treet utvide Typer | Komponenttypereller utvide Typer | Tilkoblingstyper.

3. Høyreklikken komponent type eller en tilkoblingstype, og velg Legg Constraint.

Legge til en begrensning

For å definere et hierarki begrensning, hvor en forelder må ha et konkret barn

4. På Legg Constraintvindu huke av Lag Constraintavkrysnings under Forelder må ha Child begrensning område.

5. Velg komponenttypefra drop-down boks som du ønsker å spesifisere som barn av komponenttypen som er valgt i trinn 3.

Notat

Hvis det allerede finnes en aktivert 'Parent Må Ha Child' begrensning definert for den overordnede komponent type og et annet barn komponent typen så denne nye begrensningen vil bli behandlet som en "OG". Det er den type må være en forelder til barnet type A ogBarnet type B, til hva håndheving nivå (for eksempel funksjonshemmede, advart eller Tvungen - se trinn 7) er spesifisert for hvert begrensningen.

6. Alternativt kan du definere minimum og maksimum antall komponenter av komponenttypen som er angitt som må være barn av komponenttypen høyreklikket i trinn tre.

7. Velg om du vil begrensningen være Funksjonshemmet, Advart eller Håndheves.

Notat

Funksjonshemmede begrensninger vil bli ignorert fra begrensningen validering, vil advart begrensninger produsere en advarsel i Validation vinduet hvis de blir oppdaget og håndheves begrensninger vil produsere en feil under Validering vinduet hvis de blir oppdaget. Videre må alle feilene løses før en Enterprise Server Prosjektet kan være begått.

8. Klikk OK.

Notat

Begrensningen vil bli vist i utforskeren treet under komponenttypen høyreklikket i trinn 3. Pilen angir retningen av tvang og i dette tilfellet vil peke ned og høyre. Hengelåsen er farget i henhold til om begrensningen er deaktivert (grå), Advart (gul) eller tvungen (rød).

Forelder må ha barnet advart begrensningen

For å definere et hierarki begrensning, hvor et barn må ha en bestemt forelder

4. På Legg Constraintvindu huke av Lag Constraintavkrysnings under Barnet må ha Parent begrensning område.

5. Velg komponenttypefra drop-down boks som du ønsker å spesifisere som den overordnede av komponenttypen høyreklikket i trinn tre.

Notat

Hvis det allerede finnes en aktivert 'Barnet må ha Parent' begrensning definert for barnet komponent type og en annen forelder komponent typen så denne nye begrensningen vil bli behandlet som en "OR". Dette er den type som må være et barn av moder type A ellerforelder type B, og håndhevingen nivå (f.eks advart eller Tvungen - se neste trinn) bør være de samme ellers håndheves begrensninger vil alltid overstyre advarte de.

6. Velg om du vil begrensningen være Funksjonshemmet, Advart eller Håndheves.

Notat

Funksjonshemmede begrensninger vil bli ignorert fra begrensningen validering, vil advart begrensninger produsere en advarsel i Validation vinduet hvis de blir oppdaget og håndheves begrensninger vil produsere en feil under Validering vinduet hvis de blir oppdaget. Videre må alle feilene løses før en Enterprise Server Prosjektet kan være begått.

7. Klikk OK.

Notat

Begrensningen vil bli vist i den oppdag vis under komponenttypen valgt i trinn 5. Pilen angir retningen av den begrensning og i dette tilfellet vil peke oppover og til venstre. Hengelåsen er farget i henhold til om begrensningen er deaktivert (grå), Advart (gul) eller tvungen (rød).

Barnet må ha foreldre advarte begrensningen

For å definere en topologi begrensning, hvor en komponent må være knyttet til en bestemt tilkobling

4. På Legg Constraintvindu huke av Lag Constraintavkrysnings under Komponent må vedlegges begrensning område.

5. Velg tilkoblingstypefra drop-down boks som du ønsker å spesifisere som vedlagte tilkobling av komponenttypen høyreklikket i trinn 3. (Eller velg komponenttypefra drop-down boks som du ønsker å spesifisere som vedlagte komponent hvis i trinn 3 du høyreklikket en tilkoblingstype.)

Notat

Hvis det allerede finnes en aktivert 'Component må festes' begrensning definert for komponent type og en annen tilkoblingstype, så dette nye begrensningen vil bli behandlet som en "OG". Det er den komponenten type må festes til tilkoblingstype A ogtilkoblingstype B, til hva håndheving nivå (for eksempel funksjonshemmede, advart eller Tvungen - se trinn 7) er spesifisert for hvert begrensningen.

6. Alternativt kan du velge en tilkobling rollesom du ønsker å legge til begrensningen. Svelge den spesifikke rolle (dvs. enten Source eller Sink) fra rullegardinlisten.

7. Velg om du vil begrensningen være Funksjonshemmet, Advart eller Håndheves.

Notat

Funksjonshemmede begrensninger vil bli ignorert fra begrensningen validering, vil advart begrensninger produsere en advarsel i Validation vinduet hvis de blir oppdaget og håndheves begrensninger vil produsere en feil under Validering vinduet hvis de blir oppdaget. Videre må alle feilene løses før en Enterprise Server Prosjektet kan være begått.

8. Klikk OK.

For å definere en topologi begrensning, hvor en sammenheng må være knyttet til en spesifikk komponent

4. På Legg Constraintvindu huke av Lag Constraintavkrysnings under Tilkobling må vedlegges begrensning område.

5. Velg tilkoblingstypefra drop-down boks som du ønsker å spesifisere som vedlagte tilkobling av komponenttypen høyreklikket i trinn 3. (Eller velg komponenttypefra drop-down boks som du ønsker å spesifisere som vedlagte komponent hvis i trinn 3 du høyreklikket en tilkoblingstype.)

Notat

Hvis det allerede finnes en aktivert 'Tilkobling må festes' begrensning definert for tilkoblingstype og en annen komponent type med samme tilkobling rolle(dvs. enten Kilde eller Sink), så dette nye begrensningen vil bli behandlet som en "OR". Som tilkoblingstype må festes til komponent type A ellerkomponent type B, og håndhevingen nivå (f.eks advart eller Tvungen - se trinn 7) skal være de samme ellers håndheves begrensninger vil alltid overstyre advarte de. Legg også merke til at hvis det er flere begrensninger som har tilkoblingen rolleangitt som 'Alle' (i motsetning til spesifikt kilde eller sink) deretter hver ende av forbindelsen må være festet til en av de komponenttyper som er angitt i de begrensninger.

6. Alternativt kan du velge en tilkobling rollesom du ønsker å legge til begrensningen. Svelge den spesifikke rolle (dvs. enten Kilde eller Synke) fra rullegardinlisten.

Notat

Enten en kilde eller rolle Sink må eksplisitt valgt for en Vedlegg kolonne for å være disponible for å bli vist i en komponent katalog .

7. Velg om du vil begrensningen være Funksjonshemmet, Advart eller Håndheves.

Notat

Funksjonshemmede begrensninger vil bli ignorert fra begrensningen validering, vil advart begrensninger produsere en advarsel i Validation vinduet hvis de blir oppdaget og håndheves begrensninger vil produsere en feil under Validering vinduet hvis de blir oppdaget. Videre må alle feilene løses før en Enterprise Server Prosjektet kan være begått.

8. Klikk OK.

Sanntid modellsjekking og begrensningvalidering

ABacus inkluderer ensanntid Model Kontroll og Valideringsfunksjonen til med det samme utstilling effektene en gitt bruker operasjonen vil ha på advarsler og feil med det aktuelle prosjektet, på grunn av noen hierarki og topologi begrensninger som er definert. Det bør bemerkes at alle feil må løses før en Enterprise Server Prosjektet kan være begått.

Sanntids begrensning valideringsfunksjonen er mest merkbart når fylle med diagrammer eller direkte i Explorer-vinduet. Spesielt under følgende operasjoner, er veiledning gis ved hjelp av farge høydepunkter som til effekten operasjonen vil ha på advarsler og feil med det aktuelle prosjektet;

1. Når du drar elementer på eller rundt et diagram fargen på den overordnede (eller feste) komponent (hvis noen) grensen vil være farget i henhold til ordningen som er beskrevet nedenfor.

2. Når du kobler komponenter ved hjelp av høyre-klikk drag | Koble til-funksjonen listen over tilgjengelige Tilkoblingstyper er farget i henhold til ordningen som er beskrevet nedenfor.

3. Når du kobler komponentene på diagrammer som bruker Connector Mode markøren vil endre fargene i henhold til ordningen som er beskrevet nedenfor.

4. Når du legger delkomponenter listen over tilgjengelige komponenttyper er farget i henhold til ordningen som er beskrevet nedenfor.

Generelt følgende farger er brukt for å indikere effekten brukeren operasjonen vil ha på advarslene og feil med det aktuelle prosjektet;

Svart : Ingen innvirkning på advarsler eller feil.

Grønn : Operasjonen er eksplisitt i samsvar meddefinerte hierarki og topologi begrensninger for prosjektet.

rød : Operasjonen er eksplisitt i bruddde definerte hierarki og topologi begrensninger for prosjektet og vil resultere i advarsler og / eller feil.

Bakgrunn modellsjekking og begrensningvalidering

ABACUS inkluderer en Valideringsfunksjonen til å vise alle advarsler og feil med det aktuelle prosjektet, på grunn av eventuelle begrensninger som er angitt. Det bør bemerkes at alle feil må løses før en Enterprise Server Prosjektet kan være begått.

Notat

Validering må kjøres manuelt via "Bekreft / Sjekk Prosjekt Begrensninger 'knappen på Hovedverktøylinjen . Validerings vinduet er skjult som standardmen vises når verktøylinjen knappen klikkes. Se Tilpasse grensesnittet for hvordan du viser det, og potensielt la den permanent vises. Du kan også dobbeltklikke på en rad i Validation vinduet for å "hoppe" til relevant element i prosjektet.

Validering vindu

Standard kolonnene i validerings vinduet beskrives som følger;

Advarsel eller feil: Denne kolonnen viser et ikon for om overtredelsen er en Warning (gul trekant med et utropstegn) eller feil (rød sirkel med et kryss).

Antall: Denne kolonnen viser brudd nummer.

Notat

Bare 200 brudd blir vist på en gang, og hvis det er mer enn 200 brudd i et prosjekt på Start, Forrige, Neste og End rad navigatører øverst til høyre i vinduet kan brukes til å bla gjennom flere brudd.

Beskrivelse: Dette er en fullstendig beskrivelse av brudd inkludert Entity og Constraint bekymret.

Entity: Denne kolonnen viser Entity av interesse for overtredelsen.

Type: Denne kolonnen viser element type for foretaket.

Arkitektur: Denne kolonnen viser Architecture innen overtredelsen har skjedd.

Oppdaget: Denne kolonnen viser tiden at overtredelsen ble oppdaget.

Tupp

Det er nyttig å sortere synkende ved Detected kolonne (som vist i dialogboksen ovenfor) for å sikre de nyligste brudd vises på "toppen" av listen.

Det finnes flere bruker alternativer for å endre atferden til bakgrunnen modell validering. For eksempel to endre fargene som brukes for brudd på begrensningsregler til noe annet enn standard rødKlikk på Verktøy | Alternativer ... så gå til de Valideringkategorien, og stille inn fargene via Endring knapper.

Validering alternativer

For å validere begrensninger manuelt

1. Høyreklikk på Arkitekturernode, noe arkitektur eller hvor som helst i enten Komponenter eller Tilkoblingerdel av explorer visningen og velger Sjekk Begrensninger.

Validere begrensninger

2. Klikk på Detaljerknappen på Advarslervinduet for å se hvor arkitekturen trer noen begrensninger som er angitt.

Notat

Brudd blir kun vist for de begrensninger som er satt til Advart eller håndhevet. Videre ordlyden i advarselen vil omfatte 'burde' hvis begrensningen var bare en advarsel eller 'must' hvis det ble håndhevet.

3. Klikk OK.

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt


Slette en komponent eller tilkobling

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Slette en komponent eller tilkobling

Send kommentarer om dette emnet.

For å slette en komponent eller tilkobling

1. Høyreklikkpå komponenten eller forbindelsen.

2. Velge Slett.

Forsiktighet

ABACUS vil advare deg hvilke synspunkter vil bli berørt av sletting og ber deg om å bekrefte slettingen. Dette er fordi elementene kan finnes på mange diagrammer og det lønner seg å sjekke hva den foreslåtte slettingen vil påvirke.

Tupp

Hvis du sletter en komponent, alle dens delkomponenter vil også bli slettet. Du kan velge å slette de interne og eksterne tilkoblinger til komponenten. Hvis du velger å ikke slette dem, tilkoblingene er det vedlagte til vil forbli, men de vil ikke lenger være festet. Alle komponenter og tilkoblinger er av en bestemt Type . Slette komponent / tilkobling har ingen innvirkning på Type (i Typer gren av treet). Tilsvarende, hvis komponent / forbindelse har en Standard tildelt, vil sletting ha noen innvirkning på master i Standards grenen.

Se også

Fyller din arkitektur - Oversikt


Diagram Synspunkter

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

Diagram Synspunkter

Send kommentarer om dette emnet.

The synspunkterfunksjonen sikrer at komponenter og tilkoblinger som er lagt til et diagram må ha en type forening tidligere definert før de kan legges til et diagram. Denne funksjonen gjør det mulig for en begrensning av hvilke typer diagrammer som kan trekkes ved å begrense former og kontakter som er knyttet til komponenter og Tilkoblingereksisterende innenfor arkitektur.

Aktivere eller deaktivere Håndheving diagram synspunkter

Evnen til å håndheve diagram synspunkter blir automatisk aktivert som standard. For å deaktivere / aktivere denne funksjonen, klikk på Verktøy | Alternativer ...| de Diagramfanen, og velg bort / velg Håndheve Diagram Synspunkterboksen deretter.

Notat

Hvis du ikke ser den "Håndheve Diagram Synspunkter'Alternativet i kategorien Diagram så du ikke har Designer add-on og alternativet er aktivert som standard.

Opprette en rettskraftig diagram utsiktspunkt

1. Kontroller at du har en ABACUS fil åpen med explorervisningen.

2. I explorer visning høyreklikk på Utsiktpunktsog klikk på Lage Diagram Point

3. De Diagram Pointvindu vises.

4. Tilordne et relevant navn til diagram synspunktog merk at utsiktspunkt lagres under Synspunkterdelen av explorer.

5. De Diagram Pointvindu vises.

6. Nå klikke og dra de aktuelle typene komponent og tilkoblingstyper i dine arkitekturer på synspunkt figurer du vil. Komponenttypermå dras inn en formi figurertab, mens tilkoblingstypermå dras inn en av de fem linjestil figureri kontaktertab.

7. Hvis du vil lagre diagram synspunktdu har opprettet klikk på [image] i øverste høyre hjørne av Diagram Point vindu.

Notat

De diagram synspunktkan bli redigert ved å høyreklikke på utsiktspunkt og velge Åpne eller dobbeltklikke de utsiktspunkt.

Synchonising en oppdatert utsiktspunkt med diagrammer

1. Kontroller at du har en ABACUS fil åpne.

2. Enten høyreklikke på utsiktspunktet i Explorer vinduet under Meta-modellen | Synspunkterog velg Synkroniserings Diagram Kartlegginger ...

- eller -

3. Lukke den åpne og oppdatert synspunkt vinduet og velg Jai Synkroniser til Viewpointdialogboksen som vises.

4. De Viewpoint Synkroniseringdialog vil bli vist som vist nedenfor.

Avmerkingsboksene

· Legg til manglende Kartlegginger- Enhver ny form (til komponent type) eller kontakt (til tilkoblingstype) foreninger som har blitt lagt til til utsiktspunktetvil bli lagt til tilsvarende diagrams (dvs. deressjablonge) at er knyttet til utsiktspunktet.

· Oppdater EksisterendeKartlegginger- Eventuelle oppdaterte sider ved eksisterende form (til komponenttypen) eller kontakt (til tilkoblingstype) foreninger for utsiktspunktet(f.eks farge, skrifttyper) vil bli oppdatert i tilsvarende diagrams (dvs. deressjablonge) at er knyttet til utsiktspunktet.

· Fjern ExtraKartlegginger- Noen ekstra form (til komponent type) eller kontakt (til tilkoblingstype) foreninger som har blitt lagt til til diagrammer (dvs. deres stensiler), men er ikke i utsiktspunktvil bli fjernet fra tilsvarende diagrams (dvs. deressjablonge) at er knyttet til utsiktspunktet.

· Skrive Lokale innstillinger for lagt til eller oppdatert kartlegginger (Forskjeller Only)- Eventuelle oppdaterte sider ved eksisterende form (til komponenttypen) eller kontakt (til tilkoblingstype) foreninger for utsiktspunktet(f.eks farge, skrifttyper) vil bli brukt til de tilsvarende elementene på diagrammene som er knyttet til utsiktspunktet.Bare de oppdaterte 'forskjeller' gjort til utsiktspunktet er brukt slik at eventuelle eksisterende lokale innstillinger i diagrammet som ikke ble oppdatert i synspunktet vil forbli uendret.

· [image] Merknader – Som over, men spesielt for de merknader.

Se også

The Drawing Tool | Fyller din arkitektur | Analyse din arkitektur


Tegneverktøy Funksjoner

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

Tegneverktøy Funksjoner

Send kommentarer om dette emnet.

Tegneverktøyet støtter en rekke tegnefunksjoner.

Zooming

Omfanget av diagrammet kan endres ved hjelp av zoom-funksjonen.

For å redusere omfanget eller "zoom in '

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Pressen Ctrlog '=' tasten.

- eller -

2. Velg Zoom innknappen på Diagramverktøylinjen.

- eller -

2. Pressen Ctrlog rull musehjulet framover. Merk: I denne modusen lerretet vil zoome inn der musen svever over lerretet.

Å øke omfanget eller "zoome ut"

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Pressen Ctrlog '-' tasten.

- eller -

2. Velg Zoome utknappen på Diagramverktøylinjen.

- eller -

2. Pressen Ctrlog rull musehjulet bakover. Merk: I denne modusen lerretet vil zoome utover fra der musen svever over lerretet.

Auto-layout

Utformingen av komponentene i diagrammet kan endres automatisk.

Til layout alle komponenter on et diagram

1. Cslikke de Layout Diagramknappen på Diagram verktøylinjen.

2. Velgeenten Radial Layout eller Grid Layout.

Notat

Den Radial layout vil bruke det som kalles en "force-regisserte" algoritmen slik at tilkoblede komponentene er trukket sammen mens usammenhengende komponenter blir tvunget fra hverandre. The Grid layout vil bruke en fast bredde og høyde avstand algoritme. Den lar først brukeren å velge den generelle diagram Aspect Ratio (f.eks 16: 9, A4 (Portrett), Letter (Liggende)) og deretter avstanden på sidene og mellom kolonner og rader som vist nedenfor.Med Grid layout eventuelle forbindelser mellom komponentene ikke påvirker oppsettet som det rett og slett ordner komponentene alfabetisk (ved navn) fra øverst til venstre til nederst til høyre på lerretet. Med begge algoritmer frihåndsformer ikke flyttes.

Til layout barn komponenter i en eneforsørger on et diagram

1. Høyreklikket høyt nivå komponent som har barn du ønsker å auto-oppsett.

2. Velge Layout Barn.

Notat

Som standard er bare den Radial layouten algoritmen blir brukt.

Endre Element Estetikk like Farge, Åpenhet, Shadows og Rotasjon

Alle diagram elementene har estetikk som kan manipuleres som ønsket. I tilfellet med tilhørende figurer, kan disse aspekter angis per typenog i de fleste tilfeller også per forekomst. I tilfelle av frihånds figurer, kan disse egenskapene angis per forekomstpå lerretet.

Notat

Enhver per instans aspekter som er satt for tilknyttede former vil bli "overskrevet" hvis det samme aspektet blir endret for tilsvarende type.

Å endre fargen på en tilknyttet form eller en frihåndsform

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller friform form på lerretet.

3. Velge Endre farge.

4. Velg Fast Fargealternativknappen (hvis aktuelt).

5. Velg en Basic farge eller Definer en egendefinert farge i dialogboksen og klikk OK.

- eller -

4. Velg Gradientalternativknappen (hvis aktuelt).

5. Velg enten Horisontal, Vertikal, Forward Diagonal eller bakover Diagonal for graderingen retning i nedtrekk og klikk OK.

6. Velg en Basic farge eller Definer en egendefinert farge i dialogboksen for Begynne og Sluttog klikk OK.

Notat

ABACUS vil farge forgrunnen av en form hvis;
a) det er en "enkel" form med et enkelt underliggende grafisk element (f.eks sirkel, rektangel, polygon etc), eller
b) det er en "kompleks" -form med flere underliggende subshapes som alle er i samme farge / gradient som hverandre eller subshapes har LockScale = TRUE sett.
Hvis de ovennevnte vilkårene ikke er oppfylt så bakgrunnen av formen er farget.

Til å sette farge på en tilknyttet form i henhold til en eiendom

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu(IKKE på lerret).

3. Velge Endre farge.

4. Velg Bruke Eiendom radioknapp.

5. Velg en egenskap ved å klikke på "..." knappen til høyre for tekstboksen.

6. Velg Område radioknapp.

7. Juster Min og MaxVerdiene som ønsket. Merk: noen verdi under minimumsverdien vil bli vist som Min farge og noen verdi over maksimum vil bli vist som Max farge. Også når du bruker boolsk, liste eller dato / klokkeslett egenskaper verdiene konverteres til en indeks som følger; Boolean (False = 0, Sann = 1), List (et heltall vale fra 1 til n for hver gyldig verdi i sin stigende rekkefølge angitt i Units feltet) og dato / klokkeslett (antall dager siden 1 januar 1900 - inkludert desimaler for timer, minutter, sekunder porsjoner - og hvis datoen er pre-1990 det er et negativt tall).

8. Velg en Basic farge eller Definer en egendefinert farge i dialogboksen for Min og Maxog klikk OK.

Tupp

Hvis Grønn (RGB - 128,255,0) er valgt som Min farge og rød (RGB - 255,0,0) er valgt som Max farge for en eiendom med verdi spekter av 1 til 4Da verdien 1vises som Grønn, En verdi av 2 som Gul, 3 som Oransje og 4 som rød.

Alternativt, for en egenskap rekke 1 til 3en verdi av 1vil være like Grønn, En verdi av 2 som Rav og 3 som rødaka "Traffic Lights 'eller RAG status.

For en eiendom fra 1 til 5 Hvis Blå (RGB - 0,0,255) er valgt som Min farge og rød (RGB - 255,0,0) er valgt som Max farge en verdi på 1 vil være like BlåEn verdi på 2 så AquaEn verdi på 3 i Grønn, En verdi på 4, som Gul og en verdi på 5 så rød.

For en eiendom fra 1 til 6 dersom Violet (RGB - 255,0,255) er valgt som Min farge og rød (RGB - 255,0,0) er valgt som Max farge en verdi på 1 vil være like VioletEn verdi på 2 så BlåEn verdi på 3 i Aqua, En verdi på 4, som GrønnEn verdi på 5 så Gul og en verdi på 6 i rød.

Og til slutt, for en egenskap mellom 1 til 7 en verdi på 1, vil være så VioletEn verdi på 2 så MørkeblåEn verdi på 3 i Lyse blå, En verdi på 4, som Blå grønnEn verdi på 5 så Grønn, En verdi på 6 i Rav og en verdi på 7 som rød

Notat

Se note ovenfor på forgrunn mot bakgrunn fargelegging.

- eller -

7. Velg Spesifikk verdi radioknapp.

8. Klikk på Edit Farger knapp.

9. Velg hver verdi i sving og klikk Set Fargeå sette en bestemt farge for hver verdi.

Notat

Utvalget av verdier for de elementene som finnes på diagrammet vil bli forhåndsutfylt.

10. For å legge til noen ekstra verdi farger til de forhåndsutfylt (for eksempel etter at eiendommen serien har blitt omstrukturert) klikk Legg til verdi.

Å endre fargen gjennomsiktigheten tilknyttet form eller en frihåndsform

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller friform form på lerretet.

3. Velge Endre farge.

4. I Transparency panelet satt den øverste glidebryteren til ønsket åpenhet for basisfargen.

5. Hvis Gradient eller Bruke Eiendom alternativer blir brukt, i Transparency panelet satt bunnen glidebryteren til ønsket åpenhet for den andre fargen.

6. Klikk OK.

Å vise skygger til alle assosiert former i et diagram

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i KomponenterKategorien av sjablongen vinduet.

3. Velge Legg til Shadows.

Til viser en skygge på en komponent form eller friform form

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Høyre-klikkpå komponenten eller friform form på lerretet.

3. Velge Legg til Shadows.

Å rotere komponent former og gratis danner figurer i diagrammer

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Velg komponenten form eller en freeform form på lerretet du vil rotere.

3. Høyreklikkpå form og velg Rotereog velg deretter den aktuelle vinkelen du ønsker å rotere figuren ved.

Endring Element Stempler og fritekst etiketter

Alle diagram elementene har merknader som kan manipuleres som ønsket. I tilfellet med tilhørende figurer, kan disse aspekter angis per typenog i de fleste tilfeller også per forekomst. I tilfelle av frihåndsformerog kontakter, detekstetiketter kan innstilles per forekomstpå lerretet.Åtte (8) ulike typer merknader kan vises for diagramelementer (dvs. Navn, Type, Property Value, Eiendom Marker, Attached Components, Barn (for bare komponenter), Standarder og tidsstempler (Laget, Endret av etc)) i tjue fem (25) forskjellige posisjoner (f.eks Centre - utenfor topp, venstre Inside - Centre, Outside Høyre - Utenfor Bottom).

Notat

Enhver per instans aspekter som er satt for tilknyttede former vil bli "overskrevet" hvis det samme aspektet blir endret for tilsvarende type.Videre hvor 2 eller flere anmerkninger okkupere samme posisjon bare en enkelt skrift, skriftstil, Font farge og størrelse kan brukes og en separator (f.eks komma, mellomrom, ny linje) må velges.

Å vise navn eller type for en tilhørende komponent eller tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller kontakten på lerretet.

3. Velge Merknader.

Notat

For en person tilknyttet form eller kontakten på lerretet må du velge Styre Stencil kommentareravmerkingen for første gang.

4. Velg Ny Kommentar i verktøylinjen, og velg Navn eller Type.

5. I dialogboksen som vises velger du visningsalternativer som er ønsket inkludert konsoller og Skrift, skriftstil, Font farge og størrelse. Velg også oppsettalternativene som er ønsket blant de horisontale og vertikale justeringen (dvs. merknad posisjon) og Angle (dvs. rotasjon). Velge OK.

For å vise en eiendom verdi for en tilhørende komponent eller tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller kontakten på lerretet.

3. Velge Merknader.

Notat

For en person tilknyttet form eller kontakten på lerretet må du velge Styre Stencil kommentareravmerkingen for første gang.

4. Velg Ny Kommentar i verktøylinjen, og velg Eiendomsverdien.

5. I dialogboksen som vises velger du egenskapen ved å klikke på eiendom: "..." knappen og velge en eiendom i dialogboksen Velg en eiendomog velg OK. Velg visningsalternativer som er ønsket inkludert konsoller og Skrift, skriftstil, Font farge og størrelse. Velg også oppsettalternativene som er ønsket blant de horisontale og vertikale justeringen (dvs. merknad posisjon) og Angle (dvs. rotasjon). Velge OK.

For å vise en eiendom markør for en tilhørende komponent eller tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller kontakten på lerretet.

3. Velge Merknader.

Notat

For en person tilknyttet form eller kontakten på lerretet må du velge Styre Stencil kommentareravmerkingen for første gang.

4. Velg Ny Kommentar i verktøylinjen, og velg Eiendom Marker.

5. I dialogboksen som vises velger du egenskapen ved å klikke på eiendom: "..." knappen og velge en eiendom i dialogboksen Velg en eiendomog velg OK. Sett radius av markør i piksler og farging metode til enten Colour By Range eller Colour By Eiendom og stille inn fargene oppdrag. Velg også oppsettalternativene som er ønsket blant de horisontale og vertikale justeringen (dvs. merknad posisjon) og Angle (dvs. rotasjon). Velge OK.

Å vise vedlagte komponenter for en tilhørende komponent eller tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller kontakten på lerretet.

3. Velge Merknader.

Notat

For en person tilknyttet form eller kontakten på lerretet må du velge Styre Stencil kommentareravmerkingen for første gang.

4. Velg Ny Kommentar i verktøylinjen, og velg Vedlagte Components.

5. I dialogboksen som vises, for tilhørende komponenter velge den vedlagte komponenttype ved å klikke Vedlagt: "..." knappen og velge en komponent type i dialogboksen Set Component Typeog velg OK. Velg vedlagte tilkoblingstype ved å klikke tilkoblet via: "..." knappen og velge en tilkoblingstype i dialogboksen Set Tilkoblingstypeog velg OK.For forbundet tilkoblinger velge tilkoblings slutten ved å velge Kilde eller synke fra Connection End: rullegardinmenyen. For begge tilhørende komponenter og forbindelser velge visningsalternativer som er ønsket inkludert konsoller og Skrift, skriftstil, Font farge og størrelse. Velg også oppsettalternativene som er ønsket blant de horisontale og vertikale justeringen (dvs. merknad posisjon) og Angle (dvs. rotasjon). Velge OK.

Å vise barna for en tilhørende komponent

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i KomponenterKategorien av sjablongen vindu eller en tilknyttet form på lerretet.

3. Velge Merknader.

Notat

For en person tilknyttet form på lerretet må du velge Styre Stencil kommentareravmerkingen for første gang.

4. Velg Ny Kommentar i verktøylinjen, og velg Barn.

5. I dialogboksen som vises velger du visningsalternativer som er ønsket inkludert konsoller og Skrift, skriftstil, Font farge og størrelse. Velg også oppsettalternativene som er ønsket blant de horisontale og vertikale justeringen (dvs. merknad posisjon) og Angle (dvs. rotasjon). Velge OK.

Å vise standardene for en tilhørende komponent eller tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller kontakten på lerretet.

3. Velge Merknader.

Notat

For en person tilknyttet form eller kontakten på lerretet må du velge Styre Stencil kommentareravmerkingen for første gang.

4. Velg Ny Kommentar i verktøylinjen, og velg Standarder.

5. I dialogboksen som vises velger du visningsalternativer som er ønsket inkludert konsoller og Skrift, skriftstil, Font farge og størrelse. Velg også oppsettalternativene som er ønsket blant de horisontale og vertikale justeringen (dvs. merknad posisjon) og Angle (dvs. rotasjon). Velge OK.

Å vise tidsstempler for en tilhørende komponent eller tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikkpå en tilhørende form eller kontakten i Komponenter eller TilkoblingerKategorien av sjablongen vindu eller en tilknyttet form eller kontakten på lerretet.

3. Velge Merknader.

Notat

For en person tilknyttet form eller kontakten på lerretet må du velge Styre Stencil kommentareravmerkingen for første gang.

4. Velg Ny Kommentar i verktøylinjen, og velg Laget, Laget av, skapte Marker, Modified, Modified By eller Modifisert Marker.

5. I dialogboksen som vises, om ikke en markør, velg visningsalternativer som er ønsket inkludert konsoller og Skrift, skriftstil, Font farge og størrelse. Hvis en markør, angi radius av markør i piksler og farging metode til enten Colour By Range eller Colour By Eiendom og stille inn fargene oppdrag. Velg også oppsettalternativene som er ønsket blant de horisontale og vertikale justeringen (dvs. merknad posisjon) og Angle (dvs. rotasjon). Velge OK.

For å endre skriftstil av en frihåndsformeller kontakten

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Høyreklikkpå friform form eller kontakten på lerretet. Merk: Hvis kontakten tekstetikett ikke vise så å vise connecteller tekst etikett: Høyreklikkconnectellerog velg Stempler | Vis merknad.

3. Velge Endre skrift.

4. Velg en skrifttype, skriftstil og størrelse i dialogboksen og velg OK.

For å endre skrifttype farge av en frihåndsformeller kontakten

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Høyreklikkpå friform form eller kontakten på lerretet. Merk: Hvis kontakten tekstetikett ikke vise så å vise connecteller tekst etikett: Høyreklikkconnectellerog velg Stempler | Vis merknad.

3. Velge Endring Font Farge.

4. Velg en FontColour (og for figurer Link Farge) ved å klikke på "..." knappen og velge en farge i dialogboksen og velg OK.

5. Velg Transparency av teksten etiketten ved å justere glide der 0 er helt gjennomsiktig og 255 er helt ugjennomsiktig.

Hvis du vil rotere teksten etiketten av en frihåndsformeller kontakten

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Høyreklikkpå friform form eller kontakten på lerretet. Merk: Hvis kontakten tekstetikett ikke vise så å vise connecteller tekst etikett: Høyreklikkconnectellerog velg Stempler | Vis merknad.

3. Velge Rotereog velg deretter den aktuelle vinkelen du ønsker å rotere tekst etikett av.

Se også

The Drawing Tool | Fyller din arkitektur | Analyse din arkitektur


Simulerer Total Cost of Ownership (TCO)

Navigasjon: Simulerer din arkitektur> Treningsutstyr>

Simulerer Total Cost of Ownership (TCO)

Send kommentarer om dette emnet.

Bakgrunn

Total Cost of Ownership (TCO) er et økonomisk estimat, designet for å måle den totale pådratt levetidskostnader (fra oppkjøp til opphugging / avhending) forbundet med eide eiendeler. TCO gjenspeiler ikke bare kostnadene ved kjøp, det inkluderer også alle andre aspekter i videre bruk og vedlikehold av eiendelen.

TCO brukes til å bestemme innsatsen og budsjett koster nødvendig å bruke på et system. En enkel måte å modellering i ABACUS for TCO er å bryte IT-systemet ned i komponenter. Vi kan da finne ut hvor mye i gjennomsnitt koster det å kjøre en av disse komponentene. Etter dette kunne vi deretter faktor i ulike kostnader avhengig av om IT-systemet er evolvable eller åpen etc. Hvis et system er allerede oppe og går, den viktigste faktoren for å vurdere er kostnaden for vedlikehold og kanskje kostnaden for å avvikle.

Et eksempel

Diagram for eksempel Beregning

Komponenten i henhold organisasjon eller dens standard har disse egenskapene:

· FTE= 100 000 $ / år

· Support Effort= 0,01 årsverk + 0.001 årsverk / år = 1000 $ + 100 $ / år

· Vedlikehold Cost= 100 $ - 10 $ / år

· Capital Cost= 2000 $

· Installer Effort= 2 FTE / dager = 0,01 årsverk / år = 1 000 $

Komponenten henhold Organisasjonen har disse egenskapene:

· Installer Horizon= -2 År (dvs. Systemet ble satt til 2 år før den fore)

· Livstid= 3 år

Når Installer Horizon + Levetid <= 0 Det er ikke mer vedlikeholdskostnader.

Beregninger

Beregningen er som følger:

Notat

TC = kostnaden per år. SE = Support Effort. MC = vedlikeholdskostnader.

· Opprinnelige kostnaden = Capital Cost + Installer Effort= 2000 + 1000 = 3000 $

· Ved t = -2 (under første året), TC = Initial kostnader + SE + MC= 3000 + 1000 + 100 = 4100 $

· Ved t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1 190 $

· Ved t = 0, TC = (1000 + 200) + (100 - 20) = 1280 $

· Ved t = 1 (siste år), TC = (1000 + 300) + (100 - 30) = 1370 $

Graf for eksempel Beregning

TCO er summen av alle nåværende og fremtidige kostnader inntil systemet har blitt tatt ut av drift.

· Ved t = -2 (under første året), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Ved t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Ved t = 0, TCO = 1280 + 1 370 = 2650 $

· Ved t = 1 (siste år), TCO = 1370 $

Nøkkelkostnadsfaktorer

De viktigste kostnadsfaktorer som skal vurderes ved beregning av TCO for en eiendel i ABACUS er:

· Hardware Acquisition- Innledende kostnaden for utstyret (kapitalkostnader).

· Programvare Anskaffelses- Innledende kostnaden for lisens for programvaren (kapitalkostnader).

· Installasjon- Kostnader knyttet til førstegangs oppsett.

· Opplæring- Kostnader knyttet til ekstern leverandør trening etter første oppsettet.

· Støtte- Kostnader forbundet med intern støtte.

· Vedlikehold- Kostnadene for å erstatte eller oppgradere leverandørens vedlikeholdskontrakter, forsyninger og katastrofegjenoppretting kostnader.

· Infrastruktur- Kostnader forbundet med støtte eiendelen.

ABACUS Eksempel Representasjon av viktige kostnadsfaktorer

Kjøre Kostnad simulator

For å simulere arkitektur i form av kostnader

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Velge Analyse| Koste.

3. Velg Arkitektur (s)du ønsker å inkludere i evalueringen.

Notat

Som standard vil ABACUS automatisk velge arkitektur (e) som en re-simulering er nødvendig på grunn av en underliggende eiendom eller strukturelle endringer.Det opplyser vises i rød på Simulering verktøylinje .

4. Velg Valutafra rullegardin.

5. Flytt År for å beregneglidebryteren til antall år som kreves.

Notat

Som standard er hvis Years å beregne mer enn ett år kostnadene vil automatisk bli beregnet for hvert enkelt år (og en samling av eiendommer lagt til / oppdatert) og deretter en kumulativ verdi for hele antall år også beregnet. Hvis bare den akkumulerte verdien kreves da fjernet den Beregn Per-År Kostnaderalternativet som beskrevet nedenfor for å spare på antall eiendommer i prosjektet.

6. Velg om du vil forlate Beregn Per-År Kostnadersjekket eller fjerne merkingen.

7. Klikk Neste.

8. Eventuelt velge Tilkoblingerdu ønsker å tilskrive kostnader sammen som en del av evalueringen.

Notat

Ved hjelp av en Kostnad | Attributioneiendom på kostnadene tilkoblinger kan være tilskrives fra komponenten er festet til vasken ende av forbindelsen til den komponenten som er knyttet til kildeende(dvs. Cost | Attribution = "Sink til kilden"), eller fra komponenten festet til kilde ende av forbindelsen til den komponenten som er knyttet til synke slutt(dvs. Cost | Attribution = "Kilde til Sink"). I tillegg ABACUS vil automatisk velge disse forbindelsene med en Behaviour | Forholdet = "prosesser" eller "støtter"og retning av navngivelse vil være "Synk Kilde '. Videre kostnadene er fordeles i henhold til hvilket som helst Behaviour | % Eller Cost | % Egenskaper på tilkoblingene, eller alternativt der det er flere tilkoblinger fra en vask til mange kildereller kilde til mange vasker, I henhold til hvilket som helst Behaviour | Prosesseringsegenskaper på kildekode-komponentereller synke komponenter henholdsvis.

9. Klikk Finishog du vil få en Advarseldialog.

10. Eventuelt utforske advarsler ved å klikke Detaljer >>.

11. Klikk Fortsette.

Notat

På dette punktet, vil ABACUS utføre en aktivitetsbasert kalkulasjon evaluering av arkitektur (e), og etter en kort tid (med fremdriftsindikatorer for tilbakemeldinger) en beregning komplett dialog vil vises.

12. Klikk OKå erkjenne evalueringen.

Tupp

For kurs og ytterligere hjelp på Cost Simulering henvises det til Avolution fellesskap .

Komponent og / eller Connection Egenskaper

Tabellen nedenfor viser den komponenten og / eller tilkobling egenskaper som kreves for å evaluere kostnader.Disse egenskapene vil bli vist i vinduet med et ikon eiendom innspill rad velgeren Properties ( [image] ) Med verktøytipset "Cost Input". En endring til noen av disse "inngangs 'egenskaper og ulike strukturelle forandringer til depotet vil resultere i Cost simulator krever en re-simulering som angitt i rød på Simulering verktøylinje .

Type

Navn

Standardverdi

Enhet

Datatype

Påkrevd

Beskrivelse

Koste

Installer Horizon

0

år

Integer

ekte

Angir når komponenten eller tilkobling har vært, eller vil bli installert.

· En verdi på 0 (standard) indikerer at komponenten eller tilkobling blir installert i inneværende år.

· En verdi mindre enn 0 indikerer at komponenten eller tilkobling er installert i det siste.

· En verdi som er større enn 0 indikerer at komponenten eller tilkobling vil bli installert i fremtiden.

Koste

Livstid

0

år

Integer

ekte

Angir hvor lang tid der komponenten eller tilkobling vil være i drift, etter som det vil bli nedlagt.

Koste

FTE

100,000.00

$ / år

Desimal

falsk

Den årlige kostnaden for hver Fulltid Employee.

Hvis denne egenskapen er ikke funnet i komponenti seg selv eller i tilfelle av forbindelser komponenten er festet til vasken enden av forbindelsenVil det søkes etter i andre komponenter.

For det første, noen 'vask' komponents ved slutten av a forbindelse med en "støtte" forhold til komponenten vil bli søkt, etterfulgt av at 'vask' komponent foreldres.

Hvis FTE eiendommen ikke er funnet, komponentens forelder-komponenter vil da bli søkt. Hvis FTE er fortsatt ikke funnet, er standardverdien brukt.

Merk: FTE er bare et gyldig innspill eiendom på komponenter.

Koste

Vedlikehold Cost (fast)

0.00

$ / år

Desimal

falsk

Den årlige faste kostnader ved å opprettholde den komponenteneller tilkobling.

Koste

Vedlikehold Cost (variabel)

0.00

$ / år

Desimal

falsk

Det beløp som den totale kostnaden for å opprettholde den komponenten eller tilkobling vil endres hvert år.

For eksempel viser en verdi på $ -500 at den totale vedlikeholdskostnadene reduseres med $ 500 hver år, mens en verdi på $ 500 indikerer at de totale vedlikeholdskostnader øker med $ 500 hver år.

Koste

Support Effort (fast)

0.00

FTE / år

Desimal

falsk

Den årlige faste innsats for å støtte den komponenteneller tilkobling, Spesifisert i form av årsverk.

Koste

Support Effort (variabel)

0.00

FTE / år

Desimal

falsk

Det beløp som den totale innsats for å støtte den komponenten eller tilkobling vil endres hvert år.

For eksempel viser en verdi på -0,01 at den totale støtten innsats reduseres med 0,01 årsverk hvert år, mens en verdi på 0,01 indikerer at den totale støtten innsats øker med 0,01 hvert år.

Koste

Capital Cost

0.00

$

Desimal

falsk

Den opprinnelige kostnaden ved å kjøpe den komponenteneller tilkobling.

Koste

Installer Effort

0.00

FTE

Desimal

falsk

Den innsatsen som kreves, i årsverk, for å installere komponenteneller tilkobling.

Tabellen nedenfor viser den komponenten og / eller tilkobling egenskaper som er skrevet ut av TCO evaluator. Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset "Cost Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Cost simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Notat

Hvor utgangs egenskapene fra TCO evaluator må være "avrundet" den "Round halv til selv" tilnærming (også referert til som "bankfolk 'avrunding) brukes.Denne teknikken brukes til mer jevnt løse eventuelle 0,5 'tie-breaks "med resultatet blir rundet opp eller ned til nærmeste til og med Resultatet, i stedet for alltid å runde opp eller ned, og forvrenger resultatet. Dvs. 2,5 rundes ned til to, mens 3,5 er rundet opp til fire, i stedet for dem begge blir enten rundet ned til 2 og 3 eller rundet opp til 3 og 4.

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Koste | Totalkostnad å eie - neste x årene. | $ | Integer | falsk | Den totale eierkostnader over neste xår, der x er hvor lang tid som er angitt når du kjører evaluator. Dette inkluderer kostnaden av komponentens eller tilkobling er standarder, sub-komponentereller under tilkoblinger(dvs. barn) og eventuelle tilskrives kostnader.
Koste | Totalkostnad å Eier (lokal) - neste x årene. | $ | Integer | falsk | The 'lokal' eierkostnader over neste xår, hvor xer hvor lang tid som er angitt når du kjører evaluator. Dette gjør ikkeinkluderer kostnadene til komponenten underkomponenter eller tilkoblings er under tilkoblinger (dvs.barn) eller eventuelle tilskrives kostnader.
Koste | Totalkostnad å Eier (barn) - neste x årene. | $ | Integer | falsk | The 'barn' eierkostnader over neste xår, der x er hvor lang tid som er angitt når du kjører evaluator. Dette bare inkluderer kostnaden til komponenten underkomponenter eller tilkoblings er under tilkoblinger (dvs. barn).
Koste | Totalkostnad å Eier (tilskrevet) - neste x årene. | $ | Integer | falsk | The 'tilskrevet' eierkostnader over neste xår, der x er hvor lang tid som er angitt når du kjører evaluator. Dette bare omfatter alle henføres kostnader fra vedlagte komponenter(som kan selvfølgelig inkludere tilskrives kostnader fra eventuelle tilkoblede tilkoblinger).

Tabellen nedenfor viser den komponenten og / eller tilkobling egenskaper som er skrevet ut av TCO evaluatorhvis Beregn Per-Year Kostnader er valgt. Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset "Cost Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Cost simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Notat

Se note ovenfor om mulige avrunding av utgangsegenskaper.

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Koste | Totalkostnad å eie - årx. | $ | Integer | falsk | Den totale eierkostnader til år x, Hvor x er for hvert år spesifisert når du kjører evaluator. Dette inkluderer kostnaden av komponentenseller tilkobling er standarder, sub-komponenter eller under tilkoblinger (dvs. barn) og eventuelle tilskrives kostnader.
Koste | Totalkostnad å Eier (lokal) - årx. | $ | Integer | falsk | The 'lokal' eierkostnader for året x, hvor x er for hvert år spesifisert når du kjører evaluator. Dette gjør ikkeinkluderer kostnadene til komponenten underkomponenter eller tilkoblings er under tilkoblinger (dvs. barn) eller eventuelle tilskrives kostnader.
Koste | Totalkostnad å Eier (barn) - årx. | $ | Integer | falsk | De 'barn' eierkostnader for året x, Hvor x er for hvert år spesifisert når du kjører evaluator. Dette bare inkluderer kostnaden til komponenten underkomponenter eller tilkobling sub-tilkobling (dvs. barn).
Koste | Totalkostnad å Eier (tilskrevet) - årx. | $ | Integer | falsk | The 'tilskrevet' eierkostnader for året x, Hvor x er for hvert år spesifisert når du kjører evaluator. Dette bare omfatter alle henføres kostnader fra vedlagte komponenter(som kan selvfølgelig inkludere tilskrives kostnader fra eventuelle tilkoblede tilkoblinger).

Ytterligere Egenskaper tilkoblings

Tabellen nedenfor viser ytterligere tilkoblingsegenskaper som kreves av TCO evaluator. Disse egenskapene vil bli vist i vinduet med et ikon eiendom innspill rad velgeren Properties ( [image] ) Med verktøytipset «pris / ytelse Input" eller bare "Cost Input". En endring til noen av disse "inngangs 'egenskaper og ulike strukturelle forandringer til depotet vil resultere i kostnadene og / eller Ytelse simulator krever en ny simulering som angitt i rød på Simulering verktøylinje .

Type | Navn | Standardverdi | Enhet | Datatype | Påkrevd | Beskrivelse
Koste | Attribution | Synke til Source | [Kilde til Sink | Synke til Source] | Oppslag / liste | ekte | Hvis "Kilde til Sink"Denne sammenheng vilje ha ha kostestilskrevet 'sammen' den fra kildekomponent til synke komponent. Alternativt, hvis "Synke til Source"Denne sammenheng vilje har kostnader knyttet 'sammen' den fra vasken komponent til kildekomponenten.
Atferd | Forhold | støtter | [prosesser | støtter] | Oppslag / liste | falsk | Hvis "støtter", indikerer denne sammenheng at "kilden" komponent er støttet av "synke" komponent. I tillegg, hvis enten "støtter" eller "prosesser" er forbindelsen vil automatisk bli valgt i tilkoblingene til å ha sine kostnader knyttet 'sammen' fra vasken komponent til kildekomponenten.
Koste | % | 100,0 | % | Desimal | falsk | Indikerer hvor stor andel av vasken komponenter kostnader som vil bli knyttet til kildekomponenten. De% verdier trenger ikke å legge opp til 100%, og det er rett og slett brukes til å skalere "Total Cost å eie -. Neste x år" eiendom (se ovenfor) fra vasken komponenten som det er knyttet til kildekomponenten.

Arkitektur Properties

Tabellen nedenfor viser de arkitektoniske egenskaper som er skrevet ut av TCO evaluator. Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset "Cost Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Cost simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Notat

Se note ovenfor om mulige avrunding av utgangsegenskaper.

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Koste | Totalkostnad å eie - neste x årene. | $ | Integer | falsk | Den totale kostnaden for eierskap av hele arkitekturen løpet av de neste x årene.

Tabellen nedenfor viser de arkitektoniske egenskaper som er skrevet ut av TCO evaluatorhvis Beregn Per-Year Kostnader er valgt. Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset "Cost Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Cost simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Notat

Se note ovenfor om mulige avrunding av utgangsegenskaper.

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Koste | Totalkostnad å eie - årx. | $ | Integer | falsk | Den totale eierkostnader til hele arkitektur for året xinn i fremtiden.


Simulere Modularitet

Navigasjon: Simulerer din arkitektur> Treningsutstyr>

Simulere Modularitet

Send kommentarer om dette emnet.

Den modularitet simulator beregner antall innkommende og utgående tilkoblinger for hver komponent.

For å simulere arkitektur i form av modularitet

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Velge Analyse| Modularitet.

3. Velg Arkitektur (s)du ønsker å inkludere i evalueringen.

Notat

Som standard vil ABACUS automatisk velge arkitektur (e) som en re-simulering er nødvendig på grunn av eventuelle underliggende strukturelle endringer.Det opplyser vises i rød på Simulering verktøylinje .

4. Klikk Neste.

5. Velg Tilkoblingstyper (s)du ønsker å inkludere i evalueringen.

6. Klikk Neste.

7. Eventuelt tilpasse egenskapsnavnene for beregningsresultatene.

8. Klikk Finish.

Notat

På dette punktet, vil ABACUS utføre en strukturell evaluering av arkitektur (e), og etter en kort tid (med fremdriftsindikatorer for tilbakemeldinger) en beregning komplett dialog vil vises.

9. Klikk OKå erkjenne evalueringen.

Tupp

For kurs og ytterligere hjelp på Modularitet Evaluering henvises det til Avolution fellesskap .

Komponent Properties

Tabellen nedenfor viser komponent egenskaper som er utgang av modularitet evaluator.Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset 'Modularitet Output'. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende strukturelle endringer til depotet og Modularitet simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Datatype | Påkrevd | Beskrivelse
Modularitet | Kobling-fan i (lokal) | Integer | falsk | Antallet tilkoblinger som fan i denne komponenten.
Modularitet | Kobling-fan out (lokal) | Integer | falsk | Antallet tilkoblinger som fan av denne komponenten.
Modularitet | Kobling-fan i | Integer | falsk | Antallet tilkoblinger som fan i denne komponenten, inkludert forbindelser som fan i sub-komponenter.
Modularitet | Kobling-fan ut | Integer | falsk | Antallet tilkoblinger som fan av denne komponenten, inkludert forbindelser som fan i sub-komponenter.


Simulere Åpenhet

Navigasjon: Simulerer din arkitektur> Treningsutstyr>

Simulere Åpenhet

Send kommentarer om dette emnet.

Åpenheten simulator bestemmer i hvilken grad en arkitektur og dets elementer er "åpne", det vil si evnen til systemet for å håndtere utskifting av komponenter med minimal innvirkning.

For å simulere arkitektur i form av åpenhet

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Velg analyse | Åpenhet.

3. Velg Arkitektur (s)du ønsker å inkludere i evalueringen.

Notat

Som standard vil ABACUS automatisk velge den første arkitekturen som en re-simulering er nødvendig på grunn av en underliggende eiendom eller strukturelle endringer.Det opplyser vises i rød på Simulering verktøylinje .

4. Klikk Finishog du vil få en Advarseldialog.

5. Eventuelt utforske advarsler ved å klikke Detaljer >>.

6. Klikk Fortsette.

Notat

På dette punktet, vil ABACUS utføre en strukturell evaluering av arkitektur (e), og etter en kort tid (med fremdriftsindikatorer for tilbakemeldinger) en beregning komplett dialog vil vises.

7. Klikk OKå erkjenne simuleringen.

Tupp

For kurs og ytterligere hjelp på Åpenhet Evaluering henvises det til Avolution fellesskap .

Komponent- og tilkobling Standard Properties

Tabellen nedenfor viser komponent og tilkoblings standard egenskaper som kreves for å vurdere åpenhet.Disse egenskapene vil bli vist i vinduet med et ikon eiendom innspill rad velgeren Properties ( [image] ) Med verktøytipset «Åpenhet Input". En endring til noen av disse "inngangs 'eiendommer i depotet vil resultere i Åpenhet simulator krever en re-simulering som angitt i rød på Simulering verktøylinje .

Type | Navn | Standardverdi | Enhet | Datatype | Påkrevd | Beskrivelse
Åpenhet | Standarder-Standard Forfall-Organisasjon nivå |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Nivået på ansvarlig Standards Body 0:Organisasjons / Proprietary 1:Consortium / Defacto 2:National / Military 3: Internasjonal
Åpenhet | Standarder-Standard Forfall-Status |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Godkjenning nivå oppnås med standardiseringsorgan 0:Arbeids / Committee Draft 1:Offentlig Utkast / balloted 2:Interim Draft 3:Godkjent
Åpenhet | Standarder-Standard Forfall-Stability |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Er sannsynlig å endre standard? 0:Standard foreldet 1:Meget endres i neste ett til to år 2:Kjente endre / oppdateringer til eksisterende funksjoner 3:Meget stabil (ingen endring innen 2 år)
Åpenhet | Standarder-Standard Forfall-Vendor Support |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Vendor Support 0:Ingen produkter eller leverandører støtter standarden 1:En eller flere leverandører som implementerer en del av standard 2:Mer enn én leverandør med produkter som implementerer alle deler av standard 3:Mange flere enn én leverandør med produkter som implementerer alle deler av standard
Åpenhet | Standarder-Standard tydelighet-dokumentasjon |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Kvaliteten på standard dokumentasjon 0: Dårlig 1: Rettferdig 2: God 3: Meget god
Åpenhet | Standarder-Standard tydelighet-Standard Bredde |  |  | Integer | falsk | Antall funksjoner. En opptelling av de laveste nivå standard funksjoner - Sf
Åpenhet | Standarder-Standard tydelighet-Sm |  | % | Desimal | falsk | Prosent av totalt antall funksjoner som er obligatoriske
Åpenhet | Standarder-Standard tydelighet-So |  | % | Desimal | falsk | Prosent av totalt antall funksjoner som er valgfrie
Åpenhet | Standarder-Standard tydelighet-Sc |  | % | Desimal | falsk | Prosent av totalt antall funksjoner som er betinget definert
Åpenhet | Profiler-profil Dokumentasjon-dokumentasjon |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Kvaliteten på standard dokumentasjon 0:None 1: Dårlig 2: Rettferdig 3: Meget god
Åpenhet | Profiler-profil Dokumentasjon-Nøyaktighet |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Har dokumentasjon reflektere selve systemet design? Hvilket nivå av profilelementer blir brukt i systemet? 0:Ingen funksjoner 1:Noen funksjoner 2:De fleste funksjoner 3:Alle funksjoner
Åpenhet | Profiler-profil Dokumentasjon-Forfall |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Er profilen moden og tilgjengelig? 0:Ad-hoc 1:Prosjekt basert 2:Organisasjons 3: Offentlig
Åpenhet | Profiler-profil tydelighet-Explicit Bredde |  |  | Integer | falsk | Antall vanlige funksjonene som er angitt som kreves i profilen
Åpenhet | Profiler-profil tydelighet-Pm |  | % | Desimal | falsk | Prosent av OBLIGATORISKE funksjoner i profilen
Åpenhet | Profiler-profil tydelighet-Po |  | % | Desimal | falsk | Andel av valgfrie funksjoner i profil
Åpenhet | Profiler-profil tydelighet-Pc |  | % | Desimal | falsk | Andel betinget DEFINERT funksjoner i profilen
Åpenhet | Profiler-profil tydelighet-dekning |  | % | Desimal | falsk | Andel av standard funksjoner spesielt adressert i profilen
Åpenhet | Profiler-Profil Extensions-Extension Bredde |  |  | Integer | falsk | Antall ikke-standard funksjoner spesifisert av profilen
Åpenhet | Profiler-Profil Extensions-dekning |  | % | Desimal | falsk | Andel av utvidelser detaljert i profilen
Åpenhet | Produkter-produkt tilgjengelighet og Konformitet-Antall produkter |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Antallet produkter som støtter de obligatoriske funksjonene i standard 0:Ingen produkter støtter standarden 1:Ett eller flere produkter implementere en del av standard 2:Mer enn ett produkt implementerer alle deler av standarden 3:Mange flere enn ett produkt implementerer alle deler av standarden
Åpenhet | Produkter-produkt tilgjengelighet og Samsvar-Application Konformitet |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Hvilket nivå av conformance trenger produkter må standard? 0:None 1:Hevdet 2:Demonstrerte 3:Sertifisert og Demonstrert
Åpenhet | Produkter-produkt tilgjengelighet og Samsvar-Konformitet Kvalitet |  | [0 | 1 | 2 | 3] | Oppslag / liste | falsk | Kvaliteten på conformance testing 0:None 1:In-house testing av produktutvikler 2:Uavhengige tester (f.eks NIST) 3:Demonstrert i sammenheng med relevante produkt

Komponent, Connection og Arkitektur Properties

Tabellen nedenfor viser den komponenten, tilkobling og arkitektur egenskaper produksjonen med åpenhet evaluator. Alle de følgende egenskaper for å evaluere mellom null (0) og tre (3) null (0) er den minst ønskelige og tre (3) er det mest ønskelige.Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset «Åpenhet Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom forandring til depotet og Åpenhet simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Datatype | Påkrevd | Beskrivelse
Åpenhet | Åpenhet | Desimal | falsk | Helhetsvurdering av elementets åpenhet.
Åpenhet | Standarder-Standard Forfall | Desimal | falsk | Den nåværende tilstand av standard, noe som reflekterer hvorvidt det har blitt godkjent, hvor lenge den har vært i bruk og hvor godt akseptert det er innenfor fellesskapet av utviklere.
Åpenhet | Standarder-Standard tydelighet | Desimal | falsk | Den tydelighet av standardene, gjenspeiler den potensielle tvetydighet i påfølgende standarder
Åpenhet | Profiler-profil Dokumentasjon | Desimal | falsk | I hvilken grad grensesnitt profil dokumentasjonen er utviklet og om profilen dokumentasjonen reflekterer den faktiske systemdesign og / eller implementert system
Åpenhet | Profiler-profil tydelighet | Desimal | falsk | Detaljnivået gitt i en profil / profil spesifikasjon
Åpenhet | Profiler-Profil Extensions | Desimal | falsk | Graden til hvilken profil i henhold til standarden som den er basert
Åpenhet | Produkter-produkt tilgjengelighet og Konformitet | Desimal | falsk | Hvorvidt det er åpne standardsamsvarende produkter tilgjengelig for utnyttelse i prosjektet


Simulere Ytelse

Navigasjon: Simulerer din arkitektur> Treningsutstyr>

Simulere Ytelse

Send kommentarer om dette emnet.

Bakgrunn

Den arkitektoniske evaluator for forestillingen er en diskret hendelse simulator som fungerer ved å simulere flyt av meldinger (eller tokens) gjennom en arkitektur. Teorien bak dette er hentet fra forskning gjort ved University of Technology, Sydney, og er basert på Lagdelt Queuing Network Modeller(LQNM), Tidsbestemt og Fargede Petri-nett(TCPN) og Aktivitets Cycle Diagrams(ACD).

I ABACUS ytelse simulering, er prosessering på en komponent drevet hovedsakelig av meldinger som sendes til det fra en annen komponent. Prinsippene bak denne teknikken kan forstås i fire hoveddeler:

1. De Meldingen-sentriskekommunikasjon er modellert i ABACUS hjelp logisk(eller indirekte) tilkoblinger. Logiske forbindelser definerer atferd (og frekvensdata) av de meldinger som blir ført mellom komponentene. Et godt eksempel på logiske sammenhenger ville være sekvensen flyter mellom to (2) forretningsprosesser eller de logiske grensesnitt mellom to (2) applikasjoner.

2. Logiske meldinger blir transportert til bestemmelsesstedet via hierarki(slik som ressurs swimlanes) eller direktetilkoblinger (for eksempel fysiske ledninger). For å gjøre dette de kan rutes opp, over og ned igjen hierarkiet (en lagdelt tilnærming) for å følge den direkte banen.

3. Troskap modellen kan tilpasses. For eksempel, kan en prosess som deles opp så langt ned slik at hver elementær prosess og funksjon har en separat behandling fotavtrykk. Alternativt kan det være tilstrekkelig å ha bare en verdi for hele prosessen, noe som reflekterer gjennomsnittligbehandling respons på en melding.

4. Selve behandlingutføres kun av komponenter som har (eller er) en prosessor. En prosessor er en generisk ting, og kan være en CPU, en person, en organisatorisk enhet eller noe annet som er i stand til å utføre arbeid. For eksempel ikke en forretningsprosess ikke gjøre noen faktiske behandlingen; Dette gjøres ved den første "prosessor" det finner i enten dens moder hierarki (hvis en svømmebane notasjon er brukt), eller dets prosesseringsnettverket (hvis et distribuert prosessering notasjon er brukt).

Evalueringen blir utført ved å simulere (spesifisert) trafikk i systemet, slik at hver forbindelse er simulert minst én gang. Ankomsttidene for meldingene blir tilfeldig generert med hensyn til deres spesifisert frekvens. Modellen simulerer ressurs prosessering og strid og kø av meldinger, samle statistikk underveis som forskjellige utgangsegenskaper.

Key Performance innsatsfaktorer

1. Hyppighet- Frekvensen ved hvilken forbindelsen.

2. Behandling- Mengden av henrettelsen tid til å fullføre en prosess. Dette kan være i timer, minutter, dager, drift etc.

3. Fart- Hastigheten på prosessorressurser. Det er, hvor mange sykluser / instrukser / handlinger det kan utføre i en tidsenhet. Det er viktig å være i samsvar med de enhetene som brukes for behandling.

4. Prosessorer- Antallet prosessorressurser. Prosessorer kan være mennesker, CPU-er, eksterne organisasjoner etc.

Key Performance Output Factors

1. Gjennomstrømming- Antallet meldinger per tidsenhet gjennom forbindelse. Denne faktiske verdi kan sammenlignes med de forventede / teoretiske verdier (dvs. frekvens) for å utlede metning av systemet.

2. Melding Rate- Antallet meldinger per tidsenhet gjennom komponent. Dette er summen av alle komponentenes innkommende og utgående meldinger.

3. Svar- Minste / gjennomsnittlig / maksimal ventetid for denne forbindelse. Dette er summen av alle de observerte ventetider for tilkobling fra kilden til vasken og noen kø og behandling (og ventetid tilbake til kilden hvis toveis).

4. Utnyttelse- Utnyttelsen av komponent. Dette vil være 0% hvis komponenten ikke er en enhet / prosessor (dvs. at det ikke har de prosessorer og tilgang egenskaper som er definert ovenfor).

En separat arrangement simulering blir utført for å beregne de forskjellige utgangsegenskaper, slik som beskrevet ovenfor, kan følgende formel benyttes som en grov verifikasjon av resultatene (hvor systemet ikke er mettet):

Utnyttelse = Sum av Frequency for alle innkommende tilkoblinger * Behandling / (hastighet * prosessorer)

Det totale konseptet er kanskje best demonstrert ved å vurdere følgende diagram, som viser to forskjellige ytelses meta-modeller. Den venstre stilen er den klassiske "svømmebane 'notasjon med behandling oppgaver basert hierarkisk innenfor sine prosessorressurser. Den høyre stil er en "distribuert" notasjon med behandlingen oppgaver forbundet via en prosesser forbindelse til deres prosessorressurser. Dette siste notasjon gjør at flere prosessorressurser for en gitt behandling oppgave, i motsetning til den begrensede svømmebane notasjon.

Notat

Vist på hver meta-modellen er inngangs egenskaper (i rødt) og utgangsegenskaper (i blått):

Ytelses meta-modeller: svømmebane versus Distributed notasjon

Running Performance simulator

For å simulere arkitektur i form av ytelse

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Velge Analyse| Opptredeneller klikk på knappen på verktøylinjen.

3. Velg Arkitekturdu ønsker å evaluere fra rullegardinmenyen.

Notat

Som standard vil ABACUS automatisk velge den første arkitekturen som en re-simulering er nødvendig på grunn av en underliggende eiendom eller strukturelle endringer.Det opplyser vises i rød på Simulering verktøylinje .

4. Velg Komponenter og Tilkoblingerdu ønsker å vurdere, fra standard element utvalg vindu .

5. Sett Run Time Scale Factorglidebryteren.

Notat

Høyere verdier vil gi mer statistisk konsistente resultater, men tar lengre tid å beregne.

Ytterligere Avmerkingsboks til standard element utvalg vindu

· Save Transformert Model vilje lagre en kopi av RBD forvandlet versjon av prosjektet i samme mappe som gjeldende prosjekt og føyer "_transformed" til prosjektet navn.Denne transform prosjektet kan brukes for å diagnostisere i detalj påliteligheten simuleringen utført av ABACUS.

Andre alternativer til standard element utvalg vindu

· Run Time Scale Factor styrer simulering og nøyaktighet med høyere verdier utbytteingmer statistisk konsistente resultater, men tar lengre tid å løpe.

Notat

Når ABACUS beregner simuleringen tid vil det avgjøre den tregeste indirekte forbindelse Frequency som ble valgt ut til å bli simulert og deretter "warm-up" for perioden (dvs 1 over Frequency) i denne forbindelse (initiering periodiske beskjed generatorer for alle tilkoblinger tilfeldig i løpet av denne oppvarmingstid, gi dem alle en sjanse til å sette i gang), og deretter simulere for Run Time Scale Factor ganger Periode den forbindelse. Eller (1 / Frequency) oppvarmingstid + (1 / Frequency) * Run Time Scale Factor simulering tid. Dette er for å sørge for at at alle tilkoblinger er igangsatt før statistikk er samlet og deretter den tregeste tilkoblingen er fortsatt simulert minst én gang i simuleringen. F.eks Hvis den tregeste indirekte forbindelse har en frekvens på 0,033 tidsheter (eller circa en gang i måneden hvis tiden enhetene er dager) så oppvarmingstiden vil være 30,3 time-enheter og simuleringen tid vil være 30,3 time-enheter ganger Kjør tid Scale Factor.

6. Klikk Finishog du vil få en Advarseldialog.

7. Eventuelt utforske advarsler ved å klikke Detaljer >>.

8. Klikk Fortsette.

Notat

På dette punktet, vil ABACUS utføre en diskret-event simulering av arkitektur og etter kort tid (med fremdriftsindikatorer for tilbakemeldinger) en beregning komplett dialog vil vises.

9. Klikk OKå erkjenne simuleringen.

Tupp

For kurs og ytterligere hjelp på Ytelse Simulering henvises det til Avolution fellesskap .

Komponent Properties

Tabellen nedenfor viser de egenskapene som kreves for å evaluere resultatene. Egenskaper som er søkt etter først i Component tilfeller deretter komponenten Standards og hvis ikke funnet, standard brukes.Disse egenskapene vil bli vist i vinduet med et ikon eiendom innspill rad velgeren Properties ( [image] ) Med verktøytipset «Ytelse Input". En endring til noen av disse "inngangs 'egenskaper og ulike strukturelle forandringer til depotet vil resultere i ytelse simulator krever en re-simulering som angitt i rød på Simulering verktøylinje .

Type | Navn | Standardverdi | Enhet | Datatype | Påkrevd | Beskrivelse
Atferd | b_pack | 0.0 |  | Desimal | falsk | Den faste tjeneste tide å pakke i sekunder. Denne egenskapen er typisk spesifisert som en standard type, og deretter brukes for flere komponent tilfeller. For eksempel har CORBA b_pack = 0,23 ms.
Atferd | m_pack | 0.0 |  | Desimal | falsk | Den variable tjeneste tide å pakke i sekunder / byte. Denne egenskapen er typisk spesifisert som en standard type, og deretter brukes for flere komponent tilfeller.
Atferd | b_unpack | 0.0 |  | Desimal | falsk | Den faste tjeneste tide å pakke ut i løpet av sekunder. Denne egenskapen er typiskspesifisert som en standard type, og deretter brukes for flere komponent tilfeller.
Atferd | m_unpack | 0.0 |  | Desimal | falsk | Den variable tjenesten tid til å pakke ut i sekunder / byte. Denne egenskapen er typiskspesifisert som en standard type, og deretter brukes for flere komponent tilfeller.
Atferd | Behandling | 0.0 |  | Desimal | ekte | Mengden av kjøring tid til å fullføre en prosess. Dette kan være i timer, minutter, dager, drift etc.
Atferd | Prosessorer | 1 |  | Integer | ekte | Antall prosessorressurser. Prosessorer kan være mennesker, CPU-er, eksterne organisasjoner etc.
Atferd | Fart | 100 |  | Integer | ekte | Hastigheten på prosessorressurser. Det er, hvor mange sykluser / instrukser / handlinger det kan utføre i en tidsenhet. Det er viktig å være i samsvar med de enhetene som brukes for behandling.
Atferd | k_bkgd | 0.0 |  | Desimal | falsk | Bakgrunnsbehandling på komponenten. Dette brukes til å justere resultatene å matche noen faste forskyvninger for%. Dette kan trolig bli ignorert.

Tabellen nedenfor viser komponentegenskaper produksjonen av forestillingen evaluator. Et sett av disse komponent egenskapene er generert for hver komponent i hver opptreden løp.Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset «Ytelse Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Performance simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Atferd | Melding Rate |  | Desimal | falsk | Antall meldinger per tidsenhet gjennom komponent. Dette er summen av alle komponentenes innkommende og utgående meldinger.
Atferd | Båndbredde |  | Desimal | falsk | Samlet båndbredde gjennom komponenten. Summen skyldes både innkommende og utgående meldinger.
Atferd | Utnyttelse | % | Desimal | falsk | Utnyttelsen av komponenten. Dette vil være 0% hvis komponenten er ikke en enhet / prosessor (dvs. Det har ikke prosessorer og Hastighet egenskaper definert ovenfor)

Egenskaper tilkoblings

Tabellen nedenfor viser de egenskapene som kreves for å evaluere resultatene. Egenskaper som er søkt etter først i de tilfellene Connection, er forbindelsen Standarder og hvis ikke funnet, er standard brukes.Disse egenskapene vil bli vist i vinduet med et ikon eiendom innspill rad velgeren Properties ( [image] ) Med verktøytipset «Ytelse Input eller Pris / ytelse Input". En endring til noen av disse "inngangs 'egenskaper og ulike strukturelle forandringer til depotet vil resultere i Performance simulator og / eller Kostnad simulator krever en ny simulering som angitt i rød på Simulering verktøylinje .

Type

Navn

Standardverdi

Enhet

Datatype

Påkrevd

Beskrivelse

Atferd

Type

toveis

[toveis | ensrettet]

Oppslag / liste

ekte

Om tilkoblingen er toveis (toveis) eller enveis (enveis).

De tillatte verdier for denne eiendommen er "toveis" eller "ensrettet".

Toveis betyr synkron forespørsel / svarmeldinger mens enveis betyr en enkelt asynkron "hendelse".

Atferd

Abstraksjon

indirekte

[indirekte | direkte]

Oppslag / liste

ekte

Om tilkoblingen er fysisk eller logisk. Direkte forbindelser er fysiske "rør" mellom to komponenter som logiske forbindelser flyter sammen.

De tillatte verdier for denne eiendommen er "direkte" eller "indirekte".

Hvis verdien er "direkte" er forbindelsen ikke trenger noen andre egenskaper (med unntak av eiendommene Kind og abstraksjon).

Data

L_app1

0

Integer

falsk

Forespørsel / event størrelse i byte.

Hver forbindelse vil typisk ha en bestemt verdi for dette. I CORBA, hendelser er faktisk toveis og alltid ha en 12 byte erkjenner (L_app2). Hvis det er en sann enveis forbindelse deretter la ut eiendommen L_app2.

Data

L_app2

0

Integer

falsk

Response / erkjenner størrelse i byte.

Hver forbindelse vil typisk ha en bestemt verdi for dette. En enveis forbindelse vil ikke ha L_app2.

Atferd

Hyppighet

1

Desimal

ekte

Frekvensen ved hvilken forbindelsen.

Hver forbindelse vil typisk ha en bestemt verdi for dette. Dersom eiendommen Frekvensen er utelatt da standard brukes.

Atferd

Forhold

prosesser

[prosesser | støtter]

Oppslag / liste

falsk

Forbindelser som har den "prosesser" egenskap indikerer at komponenten ved starten av forbindelsen vil bli transformert til å bli behandlet på komponenten ved enden av forbindelsen. I praksis er flyttet "kilden" komponent for å bli et barn av "synke" komponent (vedlagte tilkoblinger er også "dratt" med dette trekket).

Hvis en "prosesser" egenskapen finnes da alle de andre egenskapene tilkoblings vil bli ignorert, bortsett fra valgfri "%" eiendom beskrevet nedenfor.

Atferd

%

100,0

Desimal

falsk

Forbindelser som har den "prosesser" -egenskap (beskrevet ovenfor), kan eventuelt ha en "%" egenskap for å indikere hvor stor andel av den behandling som skal tilbakeføres til bestemmelsesstedet komponent. På denne måten kan en enkelt kilde komponent kan behandles av flere mottakerkomponenter ved ulike% 's. De% verdier trenger ikke å legge opp til 100%, og det er rett og slett brukes til å skalere "behandling" eiendom (se ovenfor) for kildekomponenten som det er forvandlet til å bli et barn av reisemålet komponent.

Tabellen nedenfor viser de egenskapene som genereres av ytelsen evaluator. Et sett av disse tilkoblingsegenskaper genereres for hver tilkobling på hver forestilling løp.Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset «Ytelse Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Performance simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Atferd | Båndbredde |  | Desimal | falsk | Den samlede båndbredde for forbindelsen. Dette er kun beregnet for indirekte tilkoblinger og er i hovedsak (L_app1 + L_app2) * gjennomstrømming.
Atferd | Båndbredde 1/2 |  | Desimal | falsk | Båndbredden spesielt for utgående (1) og innkommende (2) meldinger av tilkoblingen. Dette er kun beregnet for indirekte tilkoblinger og er i hovedsak L_app1 * Gjennomstrømning og L_app2 * gjennomstrømming.
Atferd | Gjennomstrømming |  | Desimal | falsk | Antall meldinger per tidsenhet gjennom tilkoblingen. Denne faktiske verdi kan sammenlignes med de forventede / teoretiske verdier (dvs. frekvens) for å utlede metning av systemet.
Atferd | Fullført | % | Desimal | falsk | Prosent av meldingene som fullfører behandlingen for tilkoblingen. Dette er kun beregnet for indirekte tilkoblinger og er gjennomstrømningen / frekvens. Av og til Fullført verdien overstiger 100% fordi tilfeldigheten melding generasjons resulterer i en noe høyere melding generasjon frekvens enn angitt.
Atferd | Respons (Min / Ave / Max) |  | Desimal | falsk | Minimum / gjennomsnittlig / maksimal ventetid. Dette er kun beregnet for indirekte tilkoblinger og er den observerte ventetid for tilkobling fra kilden til vask og noe kø og behandling (og ventetid tilbake til kilden hvis toveis).

Arkitektur Properties

Tabellen nedenfor viser de systemomfattende arkitektoniske egenskaper som genereres av ytelsen evaluator. Et enkelt sett med egenskaper for arkitekturen er "aggregert" for hver opptreden løp.Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset «Ytelse Output '. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Performance simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Atferd | Melding Rate |  | Desimal | falsk | Antall meldinger pr tidsenhet gjennom komponentene i arkitekturen. Dette er summen av alle komponentenes innkommende og utgående meldinger.
Atferd | Gjennomstrømming |  | Desimal | falsk | Antall meldinger per tidsenhet gjennom forbindelser i arkitekturen. Dette er summen av alle de indirekte tilkoblingenes gjennomstrømning og dette er-verdi kan sammenlignes med de forventede / teoretiske verdier (dvs. frekvens) for å utlede metning av systemet.
Atferd | Båndbredde |  | Desimal | falsk | Den samlede båndbredden. Summen av arkitektur er tilkoblingsbåndbredder.
Atferd | Utnyttelse | % | Desimal | falsk | Utnyttelsen av alle komponentene. Kan være større enn 100% som det er bare summen av alle arkitektur komponent utilisations.
Atferd | Respons (Min / Ave / Max) |  | Desimal | falsk | Minimum / gjennomsnittlig / maksimal ventetid. Summen av alle de observerte ventetider for arkitektur forbindelser fra kilde til å synke (og tilbake til kilden hvis toveis).


Simulere Pålitelighet og tilgjengelighet

Navigasjon: Simulerer din arkitektur> Treningsutstyr>

Simulere Pålitelighet og tilgjengelighet

Send kommentarer om dette emnet.

Bakgrunn

Påliteligheten Evaluator beregner påliteligheten av arkitekturen ved å bruke inngangs komponenter og tilkoblinger.

For komponenter og direkte forbindelser, er pålitelighet basert på Mean Time Between Failure (MTBF). De eneste variabler som trengs for å beregne påliteligheten av arkitektoniske elementer er:

· De MTBFverdi (i år);

· De Mean Time To Repair (MTTR)en fiasko (i år); og

· Den definerte periode for å teste Pålitelighet over.

Formelen som brukes i beregningen av Pålitelighet er gitt som:

Pålitelighet = -e (y × alder)
Der y = 1 ÷ MTBF

Tilgjengeligheten av komponenter og tilkoblinger er basert på MTBF og MTTR. Legg merke til at tilgjengeligheten, i motsetning til påliteligheten, er upåvirket av det tidsrom som det blir testet.

Tilgjengelighet = MTBF / (MTBF + MTTR)

Mens metoder som forvandler Pålitelighetsblokkskjemaer(ved hjelp av enkel serie og parallelle konstruksjoner) gi de mest nøyaktige resultater, disse metodene blitt svært impraktisk når vi prøver å beregne pålitelighet for oppdrag innenfor store nettverk av tusenvis av elementer. Videre disse transformativ tilnærminger bryte ned for mange vanlige strukturer, slik som nettverks "masker".

De Monte CarloFremgangsmåten gjør det mulig pålitelighet og tilgjengelighet av et system av vilkårlig størrelse og kompleksitet som skal beregnes. Monte Carlo-metoden simulerer mange scenarier og feller hvert scenario en tilfeldig tilstand, tilgjengelig eller utilgjengeligEr tildelt hver fysisk element. Sannsynligheten for et gitt element er i en ledig tilstand er basert på påliteligheten / tilgjengelighet av komponenten.

For eksempel kan en komponent med 90% tilgjengelighet forventes å være tilgjengelig i ca 90% av scenariene. Den indirekte forbindelse pålitelighet og tilgjengelighet kan derfor beregnes som andel av tilfeldig scenarios- eksisterer i et tilgjengelig uttalelse fra kilde til destinasjon hvor en sti av elementer.

Notat

Siden beregningen av lokale pålitelighet og tilgjengelighet er basert på forskjellige parametre og forskjellige formler (og følgelig resulterer i ulike verdier), er det nødvendig å tildele hvert element tostater, en for tilgjengelighet, og en for pålitelighet. Beregningen av tilgjengelighet bruker tilgjengeligheten stat i hvert scenario, mens beregning av pålitelighet bruker påliteligheten stat i hvert scenario.

Påliteligheten evaluator bruker Monte Carlo simulering teknikk for å trene påliteligheten av en bestemt arkitektur. Arkitekturen er satt gjennom tusenvis av individuelle simuleringer og resultatene ordnet å utlede en pålitelighet tiltak. Som nevnt ovenfor, er Monte Carlo den raskeste teknikken for å simulere større nettverk og vil arbeide med en kompleks (dvs. masket) struktur.

Evaluator utganger fire verdier:

1. Mission Pålitelighetover et antall år;

2. Tilgjengelighet av arkitektur;

3. Pålitelighet av lokal komponentover et antall år; og

4. Tilgjengelighet av lokal komponent.

Evaluator funker sannsynligheten for de komponent eller tilkobling arbeids (dvs. ikke sviktende) og tiden det tar å reparere.

Hvordan standarder med MTBFs og / eller MTTRs behandles

Hvis et element (komponent eller tilkobling) har standarder med tildelt MTBF og / eller MTTR verdier, er disse verdiene også benyttes i beregningen av den lokale pålitelighet og tilgjengelighet av et element som en serieforbindelse.

For eksempel, hvis en komponent A, Med tildelte standarder B, C, og Dhver har en MTBF og en MTTR verdi, Local Pålitelighet = R(A)× R(B) × R(C) × R(D), hvor R = Beregnet pålitelighet (ved hjelp av formelen) av komponent / standarder og Lokal Nytteevne = EN(A)× EN(B) × EN(C) × EN(D), hvor A = Beregnet nytteevne (ved hjelp av formelen) av komponent / standarder. Det vil si, dersom et element har tre standarder hver med MTBF og MTTR verdis, Og også MTBF og MTTR verdisfor elementets egenskaper, den lokale pålitelighet og avilability er gitt som en serie verdien for hver av standardene, og selve elementet.

Som et annet eksempel, dersom en komponent Ahar tildelt standarder B, C, og Dmen bare standard Bhar både en MTBF og en MTTR verdi, mens standard Cbare har en MTBF verdi og standard Dhar bare en MTTR verdi, Local Pålitelighet = R (A)× R (B)× R (C), hvor R= Beregnet pålitelighet (ved å bruke formelen) av komponent / standarder og lokal Tilgjengelighet = A (A)× A (B)× A (C), hvor A= Beregnet ledig (ved hjelp av formelen) av komponent / standarder, men i beregningen av A (C), fordi standard bare har en verdi det MTBF 'søk'for den matchende MTTR verdien (e), og vil legge all MTTR verdier den finner at don't selv har en matchende MTBF verdi, så i dette tilfellet vil den bruke MTTR verdien av standard D. Hvis det var en annen standard, sier EMed bare en MTTR verdi også da A (C)ville bruke MTBF av Cmed MTTR av D og Elegges sammen. Hvis en annen standard, sier FHadde bare en MTBF verdi da A (F)ville også bruke MTTR av D og Elegges sammen.

Beregning Mission Pålitelighet

Mens beregning lokale pålitelighet er et spørsmål om å bruke en enkel formel, er beregningen av indirekte tilkoblinger (oppdrag) ikke så lett, spesielt når vi har komplekse og store nettverk av interlaced baner (tilkoblinger) og komponenter.

Tar hele nettverket i betraktning

Som de indirekte tilkoblinger ikke representerer en fysisk tilkobling, må vi finne ut hvordan kildekomponenten kan komme til sin destinasjon komponent. Og dette innebærer å se på hele nettverket og alle de forskjellige måter (og stier) vår kilde komponent kan ta for å nå målet komponent (vask).

Notat

Så lenge det finnes i det minste en fullstendigsti fra kilde til destinasjon, vil oppdraget bli vellykketog indirekte forbindelse er referert til som en lukket tilkobling.

Forstå Link Matrix

Å vite hvilke komponenter / direkte forbindelser er koblet til det, trenger vi en gjenstand for å raskt sjekke om to blokker er koblet i en bestemt retning. Dette er funksjonen av koblingen matrisen. I korte trekk, er koblingen matrisen en todimensjonal matrise av boolske variabler som sier hvorvidt en bestemt komponent kan nå en annen komponent direkte. Dens størrelse er lik kvadratet av det totale antall komponenter i nettverket.

En enkel Pålitelighet Block Diagram (RBD)

Relatert Link Matrix for Pålitelighet Block Diagram (RBD)

Som ikke alle tilkoblinger er toveis (går begge veier), er det viktig vite hvordan du skal lese linken matrise riktig. I pålitelighet evaluator, er det første argumentet kilden og det andre argumentet er målet (vask).

Derfor, hvis koblingen matrisen (A, B) = Sant nok så det betyr at A kan komme til B direkte (ensrettet). B kan komme til A hvis bare hvis lenken matrise (B, A) = Sant. Hvis dette er sant, innebærer dette en toveis forbindelse.

I den gitte eksemplet over:

· Source en kan nå målet 0 (kilde 1 og Destination 0 gir et resultat av True); og

· Kilde 0 kan nå målet en (Kilde 0 og Destination 1 gir et resultat av True), som bindeledd mellom 0 og 1 er toveis.

· Kilde 2 kan ikke nå målet en (kilde 2 og Destination 1 gir et resultat av False) selv når kilde en kan nå målet 2 (kilde 1 og Destination 2 gir et resultat av sann). Dette innebærer at forbindelsen mellom 1 og 2 er ensrettet.

Forstå Pålitelighet Block Diagram

Påliteligheten blokkdiagram (RBD) innkapsler strukturen av hele objektmodellen i form av blokker og lenker. Hver blokk representerer et element som har en mulighet for å mislykkes eller lykkes i henhold til lenker / stier som forbinder dem. Begge komponenter og tilkoblinger kan bli en "blokk" i RBD.

Eksempel RBD Blokker og Lenker

Figuren ovenfor representerer en RBD eksempel. Den stiplede røde linjen representerer en enkelt oppgave 4 til 1. Legg merke til hvordan det bare er to mulige veier for misjonen 4 til 1.

Betrakt ruten 4 til 3 0 eller 1, og ruten 4 til 7 til 1. De stiplede blokk 2, 5og 6 representerer blokkene som ikke påvirker svikt / non-svikt i oppgave 4 til 1. De er ikke vurdert og blir ignorert. Dette er viktig som for de fleste oppdrag vil det være et stort antall overflødige blokker som ikke vil innvirke på et bestemt oppdrag suksess. Dette er mer tydelig i større nettverk, hvorved antall redundante blokker vil gjøre simuleringsresultatene unøyaktig.

Å fremskynde simulering tid, og sikre mer nøyaktige resultater, er det nødvendig å abstrahere fra hele RBD og bruker kun de elementer som påvirker et oppdrag suksess.

Notat

En enkelt rute / Banen kan ikke gå gjennom noen komponent to ganger.

På dette stadiet kan vi lage en link matrise og utføre en Monte Carlo simulering.

Beregning Arkitektur Tilgjengelighet

Arkitekturen tilgjengelighet er sannsynligheten for at alle de indirekte tilkoblinger vil være tilgjengelig til enhver tid. Tilgjengeligheten av hver indirekte forbindelse blir bestemt i løpet av hver iterasjon av Monte Carlo-simulering, men disse indirekte forbindelser (vanligvis) er avhengige av de samme sett av fysiske elementer. Derfor er det bare å samle disse individuelle ledige plasser ville "double-count" disse un-ledige, noe som gir et pessimistisk generelle arkitekturen tilgjengelighet. Alternativt, er den generelle arkitekturen tilgjengelighet beregnes ved å se på hver iterasjon, og se om de elementene som er involvert i de indirekte forbindelser av interesse er tilgjengelig. Og så aggregere disse resultatene ved slutten av simuleringen.

Kjøre Pålitelighet simulator

For å simulere arkitektur i form av pålitelighet

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Velge Analyse| Pålitelighet.

3. Velg Arkitekturdu ønsker å evaluere fra rullegardinmenyen.

Notat

Som standard vil ABACUS automatisk velge den første arkitekturen som en re-simulering er nødvendig på grunn av en underliggende eiendom eller strukturelle endringer.Det opplyser vises i rød på Simulering verktøylinje .

4. Velg Komponenter og Tilkoblingerdu ønsker å evaluere fra standard element utvalg vindu bruke valget 'Vis Direkte Connections "og" Vis prosesser Connections' radio-knappen filtre i nederst til venstre i dialogboksen for å hjelpe med deg valget.

Ytterligere Avmerkingsboks til standard element utvalg vindu

· Save Transformert Model vilje lagre en kopi av RBD forvandlet versjon av prosjektet i samme mappe som gjeldende prosjekt og føyer "_transformed" til prosjektet navn.Denne transform prosjektet kan brukes for å diagnostisere i detalj påliteligheten simuleringen utført av ABACUS.

Tilleggs Radio-Knapper til standard element utvalg vindu

· Vis Direkte Tilkoblinger vil automatisk sette en tilkobling Eiendom filter for eiendommen Type = Behaviour, Name = Abstraction og verdi = direkte.Dette alternativet er valgt som standard, og bistår i valg av den «direkte» tilkoblinger som er beskrevet ovenfor og nedenfor.

· Vis Prosesser Tilkoblinger vil automatisk sette en tilkobling Eiendom filter for eiendommen Type = Behaviour, navn = Slektskap og verdi = prosesser.Dette alternativet hjelpemidler utvelgelsen av den «direkte» tilkoblinger som beskrevet ovenfor og nedenfor.

5. Klikk Neste.

6. Velg Oppdragdvs. Connections du ønsker å inkludere i simuleringen.

7. Sett Run Time Scale Factorglidebryteren.

Notat

Høyere verdier vil gi mer statistisk konsistente resultater, men ta lengre tid å beregne.

Avmerkingsboksene

· Vise Lukkede Tilkoblinger vilje automatisk filtrerer de tilgjengelige forbindelser for å bare omfatter de som har minst en fullstendig fysisk bane fra kildekomponenten til målet komponenten i henhold til RBD valget som er beskrevet ovenfor.

· Vis Indirekte Tilkoblinger vil automatisk sette en tilkobling Eiendom filter for eiendommen Type = Behaviour, Name = Abstraction og verdi = indirekte.Dette alternativet er valgt som standard, og bistår i valg av "indirekte" eller Mission tilkoblinger som beskrevet ovenfor og nedenfor.

Knapper

· Allevelger alle tilkoblinger.

· Inverteropphever hele tiden valgt tilkoblinger og velger alle de som ikke ble valgt.

· Noneopphever alle tilkoblinger.

Andre alternativer

· Run Time Scale Factor styrer simulering og nøyaktighet med høyere verdier utbytteingmer statistisk konsistente resultater, men tar lengre tid å løpe.

Notat

Når ABACUS beregner antall iterasjoner for å simulere det vil avgjøre den mest pålitelige element som ikke er helt pålitelig og deretter simulere for Run Time skalafaktoren ganger 1 løpet av utilgjengelighet av dette elementet pluss en iterasjon. Eller (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Dette er for å sørge for at dette elementet ikke klarer fortsatt minst én gang i simuleringen. F.eks Dersom den mest pålitelige element som ikke er helt pålitelig har en MTBF på 10.000 timer og en MTTR på 8 timer og deretter simuleringen tar (10 000 + 8) / 8 = 1.251 ganger Run tidsskalafaktor + 1 iterasjoner.

· År for å simulere Ahead bestemmer antall år for Mission Pålitelighet skal beregnes for.

· Numbra av tråderdetermines antall prosessortråder skal brukes til Monte-Carlo simulering.Dette alternativet vil misligholde å matche antall tilgjengelige prosessorer / kjerner (inkludert hyper threading kjerner) for å minimere den totale simuleringen tid.

8. Klikk Finishog du vil få en Advarseldialog.

9. Eventuelt utforske advarsler ved å klikke Detaljer >>.

10. Klikk Fortsette.

Notat

På dette punktet, vil ABACUS utføre en Monte-Carlosimulering av arkitektur og etter kort tid (med fremdriftsindikatorer for tilbakemeldinger) en beregning komplett dialog vil vises.

11. Klikk OKå erkjenne simuleringen.

Tupp

For kurs og ytterligere hjelp på Pålitelighet Simulering henvises det til Avolution fellesskap .

Komponent- og Connection Properties

Tabellen nedenfor viser den komponenten og 'direkte'tilkoblingsegenskaper som kreves for å vurdere påliteligheten. Disse egenskapene vil bli vist i vinduet med et ikon eiendom innspill rad velgeren Properties ( [image] ) Med verktøytipset 'Pålitelighet Input ". En endring til noen av disse "inngangs 'egenskaper og ulike strukturelle forandringer til depotet vil resultere i Pålitelighet simulator krever en re-simulering som angitt i rød på Simulering verktøylinje .

Type | Navn | Standardverdi | Enhet | Datatype | Påkrevd | Beskrivelse
Pålitelighet | MTBF | ∞ | år, uker, dager eller timer | Desimal | ekte | Den Mean Time Før Svikt av elementet. Merk: Verdier kan uttrykkes i enheter av år, uker, dager eller timer, og blir konvertert etter en '24 / 7 "tilgjengelighet konsept som følger; - 1 år = 52 uker eller 365 dager eller 8760 timer - 1 uke = 7 dager eller 168 timer - En dag = 24 timer
Pålitelighet | MTTR | 0 | år, uker, dager eller timer | Desimal | ekte | The Mean Time To Repair av elementet. Merk: Verdier kan uttrykkes i enheter av år, uker, dager eller timer, og blir konvertert etter en '24 / 7 "tilgjengelighet konsept som følger; - 1 år = 52 uker eller 365 dager eller 8760 timer - 1 uke = 7 dager eller 168 timer - En dag = 24 timer

Tabellen nedenfor viser den komponenten og 'direkte' tilkoblingsegenskaper produksjonen av pålitelighet evaluator. Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset 'Pålitelighet Output'. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Pålitelighet simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Pålitelighet | Pålitelighet - x år |  | Desimal | falsk | Sannsynligheten for at elementet ikke vil svikte i løpet av de neste x årene. Dette er en verdi mellom 0 og 1.
Pålitelighet | Upålitelighet - x år |  | Desimal | falsk | Sannsynligheten for at elementet vil svikte i løpet av de neste x årene. Dette er en verdi mellom 0 og 1.
Pålitelighet | Tilgjengelighet | % | Desimal | falsk | Den beregnede tilgjengeligheten av komponenten eller forbindelsen. Dette er en verdi mellom 0% og 100%.
Pålitelighet | Utilgjengelighet | % | Desimal | falsk | Den beregnede utilgjengelighet av komponenten eller forbindelsen. Dette er en verdi mellom 0% og 100%.

Tabellen nedenfor viser den 'indirekte'tilkoblingsegenskaper produksjonen av pålitelighet evaluator. Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset 'Pålitelighet Output'. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Pålitelighet simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Pålitelighet | Mission Pålitelighet - x år |  | Desimal | falsk | Sannsynligheten for at den indirekte tilkobling ikke vil mislykkes i løpet av de neste x årene. Dette er en verdi mellom 0 og 1.
Pålitelighet | Mission Upålitelighet - x år |  | Desimal | falsk | Sannsynligheten for at den indirekte forbindelse vil mislykkes i løpet av de neste x årene. Dette er en verdi mellom 0 og 1.
Pålitelighet | Tilgjengelighet | % | Desimal | falsk | Den beregnede tilgjengeligheten av indirekte forbindelse. Dette er en verdi mellom 0% og 100%.
Pålitelighet | Utilgjengelighet | % | Desimal | falsk | Den beregnede utilgjengelighet av indirekte forbindelse. Dette er en verdi mellom 0% og 100%.

Arkitektur Properties

Tabellen nedenfor viser den arkitektoniske egenskaper utgangen av pålitelighet evaluator. Disse egenskapene vil bli vist i vinduet med et ikon eiendom utgang rad velger Properties ( [image] ) Med verktøytipset 'Pålitelighet Output'. Pilen på ikonet vil fremheve rød ( [image] ) Når disse egenskapene er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet og Pålitelighet simulator krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Type | Navn | Enhet | Datatype | Påkrevd | Beskrivelse
Pålitelighet | Tilgjengelighet | % | Desimal | falsk | Tilgjengeligheten av alle indirekte tilkoblinger som er tatt med i evalueringen. Det vil si at sannsynligheten for at alleindirekte tilkoblinger vil være tilgjengelig på et gitt tidspunkt. Dette er en verdi mellom 0% og 100%. Merk: Dette er IKKE multiplikasjon av de enkelte tilkoblings ledige plasser som dette ville være "dobbelttelling" un-tilgjengeligheten av de aktuelle komponentene.
Pålitelighet | Utilgjengelighet | % | Desimal | falsk | Utilgjengelighet av de indirekte tilkoblinger som er tatt med i evalueringen. Det vil si at sannsynligheten for at minst enindirekte forbindelse vil være utilgjengelig på et gitt tidspunkt. Dette er en verdi mellom 0% og 100%. Merk: Dette er IKKE multiplikasjon av de enkelte tilkoblings unavailabilities som dette ville være "dobbelttelling" un-tilgjengeligheten av de aktuelle komponentene.
Pålitelighet | Mission Pålitelighet - x år |  | Desimal | falsk | Sannsynligheten for at alle de indirekte tilkoblinger som er tatt med i evalueringen skal ikke mislykkes i løpet av den neste xår. Dette er en verdi mellom 0 og 1. Merk: Dette er IKKE multiplikasjon av de enkelte tilkoblings reliabilities som dette ville være "dobbelttelling" un-tilgjengeligheten av de aktuelle komponentene.
Pålitelighet | Mission Upålitelighet - x år |  | Desimal | falsk | Sannsynligheten for at minst én av de indirekte tilkoblinger som er tatt med i evalueringen vil mislykkes i løpet av den neste xår. Dette er en verdi mellom 0 og 1. Merk: Dette er IKKE multiplikasjon av de enkelte tilkoblings unreliabilities som dette ville være "dobbelttelling" un-tilgjengeligheten av de aktuelle komponentene.


Simulere din arkitektur

Navigasjon: Simulerer din arkitektur>

Simulere din arkitektur

Send kommentarer om dette emnet.

Når du har befolket og analysert din arkitektur, er du klar til å bruke ABACUS å fastslå om arkitektur vil møte dine kvantitative behov. Dette krever simulering. For å simulere arkitektur må du først bestemme seg for hva slags informasjon du ønsker å oppdage. Disse typer informasjon blir ofte referert til som KPI, eller Key Performance Indicators. For eksempel vil du analysere resultatene, evolvability, og åpenhet, eller ønsker du å samle beregninger som de totale eierkostnadene. All denne informasjonen kan bli avslørt på en eller annen måte. Når du har denne informasjonen, vil du være i stand til å analysere arkitektur i en rekke grafiske formater (eller analysere de nye verdiene direkte).

Det er tre alternativer for å simulere din arkitektur:

· Enkle beregninger ;

· Pre-bygget simulatorer ; eller

· Scripting .

Enkle beregninger

Hver komponent i arkitekturen har egenskaper - mange som kan være tilpasset til din bruk av ABACUS. Disse egenskapene representerer forskjellige egenskaper ved komponentene. I noen tilfeller, er det bare å samle disse beregningene (for å bygge KPI-er) kan være nok til å fortelle deg viktig informasjon om arkitektur. For eksempel KLOCS, eller tusenvis av linjer med kode, har vært mye brukt som et mål på kompleksitet. I andre tilfeller kan det være lurt å eksportere data og analysere den ved hjelp av et annet verktøy. I tillegg kan det være lurt å samle egenskaper etter å ha utført en annen type simulering.

Egenskaper kan samles gjennom prosessen aggregering . Aggregering legger spesifiserte under eiendommer til en samlet noe som gjenspeiles i den overordnede komponenten. Aggregering fungerer bare på komponenter som inneholder delkomponenter.

Pre-bygget simulatorer

Det er fem forhåndsinne simulatorer som kan brukes sammen med ABACUS. Disse er:

· Opptreden;

· Modularitet;

· Total Cost of Ownership (TCO);

· Åpenhet; og

· Pålitelighet.

Notat

ABACUS vil automatisk markere hvilke av disse simulatorene må re-run gjennom rød utheving på Simulering verktøylinje .

Scripting

Scripting gir fleksibilitet til å simulere din arkitektur i tilpassede måter. Av skrive skript du kan utføre simuleringer utover dagens i innekapasitet på ABACUS. Hele ABACUS objektmodell er tilgjengelig for skriptmotoren, slik at du er bare begrenset av din evne til å skrive manus!

Visual Basic script er skriptspråk som støttes av ABACUS, siden det gir viktige programmeringsfunksjoner i en rimelig enkel format.

Se også

Eksporterer arkitektur | Samlede eiendommer | Skrive skript


Utviklende din arkitektur

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Utviklende din arkitektur

Send kommentarer om dette emnet.

Arkitekturer kan være eksplisitt utviklet seg og et hierarki av arkitekturer opprettet. Dermed ved å utvikle din arkitektur i ABACUS, kan en rekke avanserte arkitektoniske løsninger skapes, mot og fryses. Mål (eller beregninger) kan defineres for en rekke arkitektoniske egenskaper for eksisterende arkitekturer.

En enkel måte å vurdere utviklingen av en arkitektur er å knytte det til begrepet kommer arkitektur. Når en arkitektur er utviklet seg, en kopiereav den overordnede arkitektur er opprettet. Denne kopien kan sies å være en direkte kommerav den opprinnelige forelder arkitektur.

Notat

I denne hjelpen dokumentasjon og ABACUS verktøysett selv, begrepet utvikle seger mer vanlig enn begrepet kommerVær oppmerksom på at begge refererer til den samme funksjonaliteten.

Å utvikle en eksisterende arkitektur

1. Kontroller at du har en ABACUS filåpen og Explorer-vinduvises.

2. Velg aktuelt arkitektur du ønsker å utvikle seg fra explorer treet.

3. Høyreklikkpå arkitekturen og velg Evolvefra menyen.

Utvikle Chosen Architecture

4. Den utviklet seg arkitekturen vil vises under den valgte arkitekturen.

Evolved Arkitektur

Notat

Den utviklet seg arkitekturen kan få nytt navn ved å høyreklikke på arkitektur og velge Gi nytt navn.Videre vil alle diagrammer og kataloger i utviklet arkitekturen automatisk bli satt til 'diff' mot baseline arkitektur at det ble utviklet seg fra.

Sette mål for din utviklet seg arkitektur

Sette mål for din utviklet seg arkitekturen lar deg lage et kriterium for å vurdere utviklingen av dine arkitekturer. Mål bestemmes av eiendomstyper og navnene på disse egenskapene som finnes i din utviklet seg arkitektur. Mål kan også stilles manuelt defineres og legges til du arkitektur. Følg trinnene nedenfor for å sette mål.

Sette mål fra eksisterende eiendommer for din utviklet seg arkitektur

1. Kontroller at du har en ABACUS filåpen og Explorer-vinduvises.

2. Velg Verktøy | Sette målFra hovedmenyen.

3. De Målet Inputvinduet vil vise.

Målet Input Window

4. Klikk på Eksisterende knapp.

5. De Velg en eiendomvinduet vil vise.

6. Velg en eiendom du ønsker å stille som et mål for din utviklet seg arkitektur og klikk på OK knapp.

7. Den valgte målet vil nå vises i Målet Input vindu.

8. Velg mål og klikk på Redigere knapp.

9. De Edit Goalvinduet vil vise.

Notat

Dette vinduet kan du endre eiendommen navn og type at målet vil reflektere, samt verste og beste verdi (eller minimum / maksimum) for denne eiendommen. Disse verdiene er funnet ved å sammenligne alle arkitekturer og finne den minste og største verdi i hvert for den spesifikke eiendommen. Disse verdiene kan også manuelt definert. For eksempel, hvis du var å sette et mål for eiendommen heter Respons (Ave)og av typen Atferd, Din verste og beste verdi kunne reflektere transaksjonen hastigheten som trengs for optimal ytelse (best verdi) og transaksjonen hastigheten som trengs for bare hoved søknader som skal behandles (dårligst verdi).

10. Etter at de relevante verdiene er definert, velger OK.

Sette mål fra nye eiendommer for din utviklet seg arkitektur

1. Kontroller at du har en ABACUS filåpen og Explorer-vinduvises.

2. Velg Verktøy | Sette målFra hovedmenyen.

3. De Målet Inputvinduet vil vise.

4. Klikk på Ny knapp.

5. De New Goalvinduet vil vise.

Notat

Dette vinduet lar deg definere eiendommen navn og type at målet vil reflektere, så vel som den verste og beste verdi (eller minimum / maksimum) for denne eiendommen. For eksempel, hvis du var å sette et mål for eiendom oppkalt Respons (Ave)og av typen Atferd, Din verste og beste verdi kunne reflektere transaksjonen hastigheten som trengs for optimal ytelse (best verdi) og transaksjonen hastigheten som trengs for bare hoved søknader som skal behandles (dårligst verdi).

6. Etter at de relevante verdiene er definert, velger OK.

7. En dialogboks for å Legg til alle arkitekturervises som nedenfor:

8. Klikk på Jaå legge til målet som en eiendom til alle relevante arkitekturer. Dette sikrer at den nylig definerte mål og dens egenskaper vil bli lagt til alle arkitekturer i filen. Hvis du ikke ønsker inkludere eiendom i arkitekturer, kan du klikke på Nei.

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Vise en stjerne tomt på dine utviklet seg arkitekturer | Ser på et punktplott av dine utviklet seg arkitekturer


Utvide og skjule treet

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Utvide og skjule treet

Send kommentarer om dette emnet.

Når en node i treet inneholder delkomponenter og samlinger, vil det ha en liten [image] eller [image] signere på sitt venstre. Du kan klikke på [image] å utvide noden og se dens delkomponenter og tilkoblinger. På samme måte kan du klikke på [image] å kollapse noden for å skjule under komponenter og forbindelser (for å få mer plass, eller la treet lettere å forstå).

Alternativt kan du utvide en hel node, i så fall alle sine undernoder vil også utvides, og deres undernoder, og deres ... etc. På samme måte du kan skjule en hel node - lukke flere nivåer samtidig .

I tillegg er det muligheter for å utvide bare arkitekturer, elementer (dvs. komponenter og forbindelser), komponenter eller tilkoblinger.

Å vise eller skjule en hel node (og undernoder, etc.)

1. Høyreklikkpå noden.

2. Velge Utvid | Alle eller Kollapse.

Å utvide alle en arkitektur (s)

1. Høyreklikkpå arkitekturer eller en arkitektur.

2. Velge Utvid | Alle.

Å utvide elementer

1. Høyreklikkpå arkitekturer eller en arkitektur.

2. Velge Utvid | Elements.

Å utvide komponenter

1. Høyreklikkom komponenter, en komponent eller en underkomponent.

2. Velge Utvid | Komponenter | Alle.

Å utvide tilkoblinger

1. Høyreklikkpå Connections, en tilkobling eller et sub-tilkobling.

2. Velge Utvid | Tilkoblinger | Alle.


Eksporterer Arkitektur

Navigasjon: Rapportering på arkitektur>

Eksporterer Arkitektur

Send kommentarer om dette emnet.

ABACUS lar deg tileksportere arkitektur til MDB (Microsoft Access), MS SQL Server, .abacus (ABACUS fil), og XLS (Microsoft Excel) format. Du kan også eksportere diagrams til PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF og BMP-format og rapporter til no.html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) og RTF (Rich Text Format) formater. Dette gjør det mulig å analysere og se arkitektur og sine data på noen måte du ønsker.

Å eksportere arkitektur til MDB (Microsoft Access)

1. Kontroller at du har en ABACUS fil åpne.

2. Klikk på Fil meny.

3. Velge Eksport, og så Til MDB.

4. Legg merke til advarselen og klikk OK.

5. Skriv inn et navn på filen.

6. Klikk på Spare Knapp.

Notat

Eksport formatet på MDB-database er spesifikke for ABACUS og eventuelle skjemaendringer vil føre til manglende evne til å re-import. Vær snill å se Fyller med MS Access for en beskrivelse av MS Access skjema.

Å eksportere arkitektur MS SQL Server

1. Kontroller at du har en ABACUS fil åpne.

2. Klikk på Fil meny.

3. Velge Eksport, og så Til MS SQL Server.

4. I dialogboksen som dukker opp klikker du på Eksport Blank MDB ...knappen og importere dette inn i MS SQL Server-database server.

5. Fyll i databasen informasjon og tilkoblingsstrengen.

6. Klikk på Eksport Knapp.

Notat

Eksport formatet på MS SQL Serverdatabase er spesifikke for ABACUS og eventuelle skjemaendringer vil føre til manglende evne til å re-import. Vær snill å se Fyller med MS Access for en beskrivelse av databaseskjema.

Å eksportere arkitektur til .xls (Excel-fil)

1. Kontroller at du har en ABACUS fil åpen En explorer vises Og en arkitektur lagt .

2. Kontroller at du har en Excel Import / Export konfigurasjonsfil definert.

3. Høyreklikkpå en arkitektur i din modell eller noen del av Komponenternode (innen en gitt arkitektur) du ønsker å eksportere til Excel konfigurasjonsfil.

4. Velge Eksport | Til Excel ... fra menyen.

5. De Velg Excel Import / Export konfigurasjonsfil brukervindu vises.

6. Velg den relevante konfigurasjonsfilen for arkitektmodell og klikk på Åpne knapp.

7. Hvis ikke automatisk gjort det, kart toppnivå komponentene i din nåværende arkitekturen til Set Id(som tidligere definert) og klikk på Eksport....

Eksempel Top-Level Component Mapping

8. Velg en plassering og filnavn for Excel-filen og klikk Spare knapp.

Å eksportere arkitektur til .abacus (ABACUS fil)

1. Kontroller at du har en ABACUS fil åpne.

2. Høyreklikkpå Architecture node, noe arkitektur i din modell eller noen del av komponenter treet.

3. Velge Eksport | Til Fil...fra menyen.

4. Velg en plassering og et filnavn og klikk Spare knapp.

Notat

Du kan importere en ABACUS filen tilbake til ABACUS av følgende trinn 1-2ovenfor, og deretter velge Import | Fra Fil.... Etter at du har valgt filen du ønsker å importere, vil du bli spurt om hvordan du ønsker å importere standarder og typer. Du kan importere standarder og typer som enten nye eller fusjonerte standarder og typer. Standardinnstillingen er for standarder og typer å bli slått sammen med eksisterende standarder og typer hvis de allerede eksisterer i ditt prosjekt.

Å eksportere arkitektur til XML

1. Kontroller at du har en ABACUS fil åpne.

2. Høyreklikkpå en Architecture node, noe arkitektur i din modell eller noen del av Component treet.

3. Velge Eksport | Til XML ...fra menyen. Alternativt kan du klikke på menyen Fil| Eksport| Til XML ...

4. Velg en plassering og et filnavn og klikk Spare knapp.

Notat

Du kan importere en XML-fil tilbake i ABACUS av følgende trinn 1-2ovenfor, og deretter velge Import | Fra XML .... Etter at du har valgt XML-filen du vil importere, vil du bli spurt om hvordan du ønsker å importere standarder og typer. Du kan importere standarder og typer som enten nye eller fusjonerte standarder og typer. Standardinnstillingen er for standarder og typer å bli slått sammen med eksisterende standarder og typer hvis de allerede eksisterer i ditt prosjekt.

Å eksportere diagram til PNG, JPG, SVG, TIFF, GIF eller BMP

1. Kontroller at du har en ABACUS fil åpne.

2. Åpne diagramdu ønsker å eksportere.

3. Klikk på Eksport Diagramknappen på Diagram verktøylinjen.

4. De Eksport Diagramvinduet vil vises.

5. Velg Blaknappen for å lagre visualisering på ønsket sted.

6. Velg Lagre som typerullegardinmenyen for å velge filtypen.

7. Klikk på Spare knapp.

Å eksportere rapporten til .pdf (Adobe Acrobat), .xls (Microsoft Excel) eller.doc (Microsoft Word)

1. Kontroller at du har en ABACUS fil åpne.

2. Lage en rapportere du ønsker å eksportere.

3. Klikk på Eksportknappen på rapporter verktøylinjen.

4. Velge Excel, PDF eller Wordfra rullegardinlisten.

5. Vent et øyeblikk mens rapporten eksport.

6. Velg en plassering og et filnavn og klikk Spare knapp.


Finne og erstatte elementer i arkitekturen

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Finne og erstatte elementer i arkitekturen

Send kommentarer om dette emnet.

Du kan finne og erstatt en spesifikk komponent, tilkobling, type, standard eller eiendom ved hjelp ABACUS 'Finn og erstatt studio.

For å finne et element

1. Klikk på node i treet du ønsker å søke i.

2. Velge Redigere| Finneeller trykk Ctrl + F.

3. Skriv inn tekst for elementetå finne i "Finn hva" feltet.

4. Klikk Finn Neste.

Til erstatte en gjenstand

1. Klikk på node i treet du ønsker å søke i.

2. Velge Redigere| Erstatteeller trykk Ctrl + H.

3. Skriv inn tekst forelementetå finne i "Finn hva" -feltet og teksten for å erstatte den med i "Erstatt med" -feltet (eller ingenting hvis feltet er tomt).

4. Klikk Finn Nesteå finne den første forekomsten av "Finn hva" tekst og klikk Erstatte å erstatte dette tilfellet med "Erstatt med" tekst eller klikk Erstatt allefor å erstatte alle forekomster.

Du har muligheter til:

o Matche sin sak,

o Match hele ordet,

o Søk fra begynnelsen av prosjektet,

o Ignorer arkitekturer - det er arkitekturen noder selv. Eventuelle noder under arkitekturen noder som komponentene og tilkoblinger vil fortsatt søkes,

o Ignorer komponenter - som er komponenten noder selv,

o Ignorer tilkoblinger - som er sammenhengen noder selv,

o Ignorer standarder - det er alle arkitektur, komponent- og tilkoblings standard noder vil bli ignorert,

o Ignorer typer - som er den type noder selv. Eventuelle begrensningen noder under av den type noder vil fortsatt søkes,

o Ignorer maler og innhold - som er malen noder seg selv så vel som en mal komponent og tilkoblings noder under dem,

o Ignorer egenskaper - som er alle eiendomstyper, navn, verdier og enheter av alle modellens elementer vil bli ignorert,

o Ignorer beskrivelser - som er beskrivelsene av alle modellens elementer vil bli ignorert.

Se også

Hvordan er en arkitektur representert i ABACUS


Hjelp på andre språk

Navigasjon: Introduksjon til ABACUS>

Hjelp på andre språk

Send kommentarer om dette emnet.

ABACUS hjelp er tilgjengelig i ulike andre språk / oversettelser og kan lastes ned fra linkene nedenfor.

Til erstatte dagens ABACUS hjelpefilenmed en oversatt hjelp-filen kan du følge disse trinnene:

1. Lagre hjelpefilen fra den aktuelle linken nedenfor.

2. Endre navnet på filen til ABACUS.chm.

3. Åpne filen ved å dobbeltklikke på den og hvis en "Åpne fil - Sikkerhetsadvarsel 'dialogboks så fjern" Spør alltid før du åpner filen "og klikk på Åpne.

4. Lukke filen.

5. Erstatte ABACUS.chm filen i ABACUS programfiler mappen, typisk "C: \ Program Files \ Avolution \ ABACUS" eller "C: \ Program Files(x86)\ Avolution \ ABACUS".

Notat

Kontekstsensitiv hjelp vil fortsette å jobbe med de oversatte hjelpefiler.

ABACUS hjelpefiler på andre språk:

· Arabic / العربية .

· Bulgarian / български .

· Kinesisk (forenklet) / 中文 (简体) .

· Czech / Česká .

· Danish / Dansk .

· Estonian / Eesti .

· Finnish / Suomen .

· fransk / Français .

· tysk / Deutsch .

· Hungarian / Magyar .

· Icelandic / Icelandic .

· Indonesisk / Indonesia .

· Italiensk / Italiano .

· Japansk / 日本 の .

· Latvisk / Latvijas .

· Malaysian / Malaysia .

· Maltese / Malt i .

· Norweigen / Norweigen .

· Pusse / Po lska .

· Portugisisk / Português .

· Russian / русский .

· Slovak / Slovenski .

· Slovensk / Slovenski .

· Spansk / Españoles .

· Swedish / Svenska .

· Turkish / Türk .

· Welsh / Cymraeg .

Se også

Hva gjør ABACUS gjøre?


Hvordan er en arkitektur representert i ABACUS?

Navigasjon: Introduksjon til ABACUS>

Hvordan er en arkitektur representert i ABACUS?

Send kommentarer om dette emnet.

I ABACUS, modellere deg din arkitektur. For enkelhets skyld kaller vi dette arkitektoniske modellen en arkitektur.

Diagrammet nedenfor viser hvordan en typisk arkitektur 5komponenter (i et hierarki) koblet sammen med 2 tilkoblinger vil være representert i ABACUS.

Hvordan en enkel arkitektur er representert i ABACUS

Du kan ha en rekke arkitekturer i en enkelt ABACUS fil.

Den første arkitektur i treet

Vanligvis ville du oppretter en ny arkitektur når du ønsker å vurdere en endring. For eksempel, vil du modellere den eksisterende arkitekturen først - dette ville være den første arkitekturen i treet. Du kan kalle det "Current".

Den andre

Når du ønsker å modellere og vurdere en endring i eksisterende arkitektur (for eksempel økt krav) du vil opprette en ny arkitektur. Den enkleste måten å gjøre dette ville være å lage en kopi av "Current" og endre navnet 'Evolution 1 Avslutning 1'. Dette vil være den andre arkitektur i treet. Hvis evalueringer av «Evolution 1 Forsøk 1 'er vellykket, kan du endre navnet til bare" Evolution 1'.

Den tredje

Hvis "Evolution 1 Forsøk en" ikke tilfredsstiller dine krav, kan du lage en kopi av det, endre navnet til "Evolution 1 Forsøk 2 ', og prøv igjen. Dette ville være det tredje arkitektur i treet.

Se også

Hva gjør ABACUS gjøre? | Hvordan du gjør det (oversikt) | Hva er arkitektur? | Arbeide med ABACUS filer | Opprette eller duplisere en arkitektur


Hvordan bruke ABACUS (oversikt)

Navigasjon: Introduksjon til ABACUS>

Hvordan bruke ABACUS (oversikt)

Send kommentarer om dette emnet.

Dette emnet gir en grunnleggende oversikt over oppgavene med å bruke ABACUS.

Diagrammet nedenfor viser arkitekturen basert analyse prosess som ABACUS gir for utvikling en aktuell arkitektur til en ny eller target arkitektur.

Den ABACUS Process

Slik bruker ABACUS:

1. Revidere - Før du bruker ABACUS, må du samle all informasjon du har om arkitektur, og dens krav.

· Arkitektur - Identifisere potensielle komponentene i arkitektur og hvordan de samhandler. Det skal bare være noen få komponenter på øverste nivå. Disse kalles "essensielle komponenter". Selv de mest komplekse arkitekturer bør ha mindre enn 10 essensielle komponenter. f.eks De essensielle komponenter i et forsikringsselskap arkitektur kan være politikk, kvitteringer, krav og betalinger.

· Krav- Du må vite hva som forventes av arkitekturen for å fastslå om det er tilfredsstillende. f.eks Antall transaksjoner per time.

· Hvor finner du det? - Denne informasjonen kan komme fra kravspesifikasjoner, design dokumenter, intervjuer med interessenter, det utplassert kode, etc. I utgangspunktet noe materiale som er tilgjengelig tilbyr ABACUS informasjon om arkitektur.

2. Befolke -Bruk ABACUS å modellere arkitektur og spesifisere kravene arkitekturen vil bli målt mot.

· Arkitektur - I ABACUS du starter med en tom arkitektur - du må befolke den. Dette betyr å legge inn all arkitektur informasjonen du har samlet over. Du kan fylle ut din arkitektur manuelt (ved hjelp av høyreklikkmenyen), eller du kan fylle den automatisk (fra Microsoft Visio, Excel, Access etc). Vanligvis den øverste nivåer (mer abstrakte) av arkitektur vil være befolket manuelt, og de lavere nivåene (mer betong) skal fylles ut automatisk.

· Krav - Som du legge til dine komponenter og tilkoblinger, du spesifiserer deres egenskaper. I de fleste tilfeller vil disse egenskapene være kravene arkitekturen. For eksempel, hvis du vil ha en 1250 MIPS node / klynge, vil du legge til noden som en komponent, og deretter legge den ytelsen eiendom, og tilordne en verdi av 1250 MIPS.

3. Analysere - Bruk ABACUS til elegant analysere og visualisere komplekse strukturen i arkitekturen. Du kan analysere arkitektur på en rekke måter, eller fra en rekke synspunkter, inkludert diagrammer, 3D og Explorer. Alternativt kan du ønsker å bruke noen mer spesifikke visninger som følger:

· Kartlegge din arkitektur - for å få ytelse (responstid, båndbredde, etc.), kostnader (bar, pai, etc.) eller evolvability (evne plass, trade-off, etc.) visninger.

· Lag en rapport på arkitektur.

4. Simulere - Bruk ABACUS å simulere din arkitekturens ytelse, tilgjengelighet, pris, åpenhet, etc.

· For å gjøre dette, kjører en av simulatorer. ABACUS evaluerer arkitektur mot dine kravved å utføre en simulering. Den leser og analyserer dagens arkitektur, kjører simuleringer, og beregner noen nye egenskaper. Disse egenskapene blir da lagret tilbake til arkitekturen. De nye egenskapene er de dataene du prøver å analysere, for eksempel utnyttelse, responstid, båndbredde,% tilgjengelighet, TCO etc.

5. Ingeniør- Bruk ABACUS å svare på ulike "hva om" scenarier og styre utviklingen av arkitektur. Engineering er prosessen med å gjenta Befolke - Analyser - Simuler syklus.

· På dette punktet, du'vesannsynligvis utviklet en forståelse av Current Architecture og fremhevet de områdene du trenger for å utvikle seg. Ganske ofte, derimot, må du gjenta Befolke - Analyser - Simuler prosessen flere ganger. Dette vil trolig være fordi det kan ta et par gjentakelser før du finner Target Architecture. Også, hvis arkitektur er svært kompleks, kan det være lurt å gjenta prosessen for hver arkitektonisk "nivå".

6. Planfremtiden for din arkitektur ved hjelp av informasjon fra ABACUS.

Notat

Hvis du ikke prøver å utvikle en eksisterende arkitektur, kan det hende du trenger å gjenta noen av trinnene en rekke ganger, og i en annen rekkefølge. Det avhenger av hva du prøver do. For eksempel, hvis du designer en ny arkitektur, vil du sannsynligvis bare fylle ditt arkitektur gang, og deretter bruke ABACUS over en lang periode for å lede den fremtidige utviklingen (e) av arkitekturen. På den annen side, hvis du kjøper en ny arkitektur og har flere alternativer å velge mellom, vil du trenger for å oppdage og Befolke for hvert av alternativene, og deretter analysere og simulere hver og en uavhengig før du utfører en endelig sammenligning på slutt.

Se også

Hva gjør ABACUS gjøre? | Hva er arkitektur? | Hvordan er en arkitektur representert i ABACUS? | Fyller din arkitektur | Analysere din arkitektur | Simulere din arkitektur


Importere inn Architecture

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Importere inn Architecture

Send kommentarer om dette emnet.

ABACUS lar deg å importere til din arkitektur fra en .abacus (ABACUS fil), XML (en ABACUS XML fragment eller en ArchiMate Interchange Språk XML-fil), .vsd (Microsoft Visio) format, og .xls (Microsoft Excel) format. Dette gjør at du kan bygge din arkitektur fra eksterne kilder raskt.

Til import din arkitektur fra.abacus (ABACUS fil)

1. Kontroller at du har en ABACUS fil åpne.

2. Høyreklikkpå Architecture node, noe arkitektur i din modell eller noen del av komponenter treet.

3. Velge Import| Fra Fil...fra menyen.

4. Velg et sted og den .abacus fil og klikk Åpne knapp.

Notat

Etter at du har valgt filen du ønsker å importere, vil du bli spurt om hvordan du ønsker å importere standardene, typerog synspunkter. Du kan importere standarder, typer og synspunkter som enten nye eller fusjonert standarder, typerog synspunkter. Standardinnstillingen er for standarder, typer og synspunkter å bli slått sammen med eksisterende standarder, typer og synspunkter hvis de allerede eksisterer (med de samme navn) i prosjekt.

Til importdin arkitektur fra.xml (en ABACUS XML fragment eller en ArchiMate Interchange Språk XML-fil)

1. Kontroller at du har en ABACUS fil åpne.

2. Høyreklikkpå en Architecture node, noe arkitektur i din modell eller noen del av Component treet.

3. Velge Import| Fra XML ...fra menyen.

4. Velg et sted og .xml filen og klikk Åpne knapp.

Notat

ABACUS vil bare importere en riktig dannet ABACUS XML fragment eller en ArchiMate Interchange Språk XML-fil. Etter at du har valgt XML-filen du vil importere, vil du bli spurt om hvordan du ønsker å importere standardene, typerog synspunkter. Du kan importere standarder, typer og synspunkter som enten nye eller fusjonert standarder, typerog synspunkter. Standardinnstillingen er for standarder, typer og synspunkter å bli slått sammen med eksisterende standarder, typer og synspunkter hvis de allerede eksisterer (med de samme navn) i prosjekt.

Til importdin arkitektur fra.VSD(Visio fil) se her .

Til importdin arkitektur fra.xls (Excel-fil) se her .


Importere typer og standarder fra et bibliotek

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Importere typer og standarder fra et bibliotek

Send kommentarer om dette emnet.

Du kan importere typer og standarder fra en ABACUS bibliotekfilen. Du kan også eksportere typer og standarder fra ABACUS fil til en ABACUS bibliotekfilen.

Slik importerer typer og standarder fra et bibliotek i din arkitektur

1. Kontroller at du har en ABACUS filåpen og Explorer-vinduvises.

2. Velg Fil | Åpnefor å åpne en ABACUS bibliotekfilen.

3. Den ABACUS Library åpnes i andre faneblad i Explorer-vinduet, og du blir nødt til å løser dette fanearket å være i stand til å dra-og-slipp fra den til den opprinnelige ABACUS filen.

4. Dra og slipptyper og standarder fra biblioteket inn i arkitekturen.

- eller -

1. Velg Fil | Ny ...

2. Opprett en ny ABACUS filbasert på en ABACUS bibliotekfilen.

Slik eksporterer typer og standarder fra arkitektur til et bibliotek

1. Kontroller at du har en ABACUS filåpen, Explorer-vinduvises, en ABACUS bibliotekfilenåpen og Bibliotek Windowvises.

2. Dra og slipptyper og standarder fra din arkitektur inn i biblioteket.

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt


Den ABACUS grensesnitt

Navigasjon: Introduksjon til ABACUS>

Den ABACUS grensesnitt

Send kommentarer om dette emnet.

Når du starter ABACUS, vil du se på hovedskjermen, som er tom, bortsett fra menyene og verktøylinjen øverst, et tomt Utforsker-vindu og tittellinjen. Denne skjermen vil være navet i din interaksjon med ABACUS.

De viktigste elementene er:

· hovedmenyene

· verktøylinjene

· høyreklikk-menyen

· de explorer og eiendoms vinduer

· statuslinjen

Hovedmenyene

Menyene er ordnet i en logisk rekkefølge.

Menyene er beskrevet som følger;

· Filmenyen- Fil-menyen lar deg opprette, åpne, lukke, lagre, eksportere og publisere ABACUS filer. Den lar deg også til å opprette, åpne, lukke og lagre ABACUS bibliotek filer.

· Edit menyen- Rediger-menyen lar deg klippe ut, kopiere, lime inn, slette, endre navn, finne og sortere elementerog angre / gjenta operasjoner.

· Vis-menyen- Vis-menyen kan du åpne eller lukke ulike grensesnitt Windows og statuslinjen, Navigere frem og tilbake, gå til bestemte synspunkter og administrere oversikter.

· Sett inn-menyen- Sett inn-menyen lar deg legge til nye standarder, Maler, typer, elementer, utsiktpunkts, Kataloger, diagrammer, diagrammer, Rapporter og matriser.

· Analyse-menyen- Analyse-menyen lar deg kjøre evalueringer mot en arkitektur, inkludert; ytelse, pris, pålitelighet, modularitet og åpenhet.

· Verktøy-menyen- Verktøy-menyen lar deg kjøre skript, sette mål for arkitekturog utføre og arkitektur 'diff'. Du kan også endre programmets alternativer og tilpasse grensesnittet fra verktøymenyen.

· Vindu-menyen- Vindu-menyen lar deg dokke, ordne, vise og skjule vinduer du har åpne.

· Hjelp-menyen- Fra Hjelp-menyen kan du få tilgang til denne ABACUS hjelpefilen. Du får tilgang til nettstedet, vise tillatelse avtalen og vise generell informasjon om ABACUS inkludert den versjonen av programvaren og ABACUS støtte og kontaktinformasjon. Du kan gi tilbakemelding via varslings problemet siden. Hvis det er nødvendig, kan du skrive inn en registreringsnøkkel via Hjelp-menyen.

Dette er den rekkefølgen du vil vanligvis følge når du utfører dine oppgaver;Når du har opprettet eller åpnet en fil, Vil du normalt fylle din arkitektur, deretter utsiktdet (i Explorer, diagrammer, 3D, diagrammer, etc). På dette punktet, vil du enten kjøre en evaluator, Eller vil du gjenta prosessen med den samme arkitekturen eller en annen arkitektur. (Se Hvordan bruke ABACUS (oversikt) for ytterligere detaljer.)

Ta en titt gjennom hovedmenyene og prøve å forestille seg hvordan du vil bruke dem til systemet ditt.

Notat

Du kan Tilpass menyer når som helst.

Verktøylinjene

Som standard er det følgende verktøylinjer;

· Hovedverktøylinjen -

· de Simulering verktøylinje -

· View-verktøylinjen -

· de Diagram verktøybar (hvis en diagram er åpen) -

· Macro Innspilling verktøylinje -

Ta en titt gjennom knapper på hver verktøylinje ved å holde markøren over dem for å se verktøytips (snarvei-tast).

Notat

Bare visse knapper vil være aktiv avhengig av hva du har valgt i Explorer-vinduet og kan du Tilpass verktøylinjer når som helst.I tillegg er "Bekreft / Sjekk Prosjekt Begrensninger 'knappen på hovedverktøylinjen og knappene på Simulering verktøylinjen vil markere rød når en endring i den underliggende depotet krever en re-godkjenning av prosjektet eller en re-simulering av at simulator hhv. Hold markøren over for å se hvilke arkitekturer er berørt.

Høyreklikkmenyen

De viktigste menyer og verktøylinjer er ikkebrukes til alt, skjønt. Det er ofte mer praktisk å bruke høyreklikkkontekstmenyen for ulike operasjoner. (Også, ikke alle kommandoene som er tilgjengelige via høyreklikk er tilgjengelig via hoved menyer, verktøylinjer, eller tastaturkommandoer.)

For eksempel, når du har opprettet en fil, og du har en trestruktur av arkitektur, er det bedre å høyreklikke på arkitekturer i treet for å legge til en ny arkitektur. På samme måte bør du høyreklikker på komponenter for å legge til en ny komponent. Høyreklikk på et par ting i treet for å se hva du kan gjøre.

Tupp

Vanligvis vil du bruke hovedmenyene til å utføre flere høyt nivå oppgaver, som å evaluere arkitektur. Lavnivå oppgaver - som å legge til enkeltkomponenter og tilkoblinger - er gjort ved hjelp av verktøylinjer og / eller høyreklikk menyen.

Utforskeren og egenskaper vinduer

Når du åpner eller oppretter en fil, vil et tre diagram vises i Explorer-vinduet. Det er et vindu inn i arkitekturen. Og som du velger elementer innen Explorer-vinduet tre andre vinduer; Generelle Properties, Referanserog egenskaper vinduene vil oppdateres med detaljert informasjon om ditt valg.

Notat

Generelle Properties, Referanserog egenskaper vinduer er skjult som standard. Se Tilpasse grensesnittet for hvordan du viser dem og potensielt la dem permanent vises.

Mens du bygger din arkitektur, Explorer og egenskaper vinduer er den mest nyttige representasjon. Fordi de kan være sammen og utvides etter behov, og de trenger ikke bli tungvint.

Explorer-vinduet har et tre (og statuslinjen) og egenskapene vinduene har 5seksjoner:

· Type

· Standarder

· Beskrivelse

· Referanser

· Egenskaper

ABACUS anser alle disse tingene for å være en del av arkitekturen.

Tre

Denne delen har et tre gruppert i 3 områder som følger:

1. Meta-modellen

· Standarder- Hvis mange komponenter har samme sett med egenskaper, kan du definere set up-front, og så bare tilordne den til komponentene. Det samme gjelder for forbindelser og noen av de andre elementene. Disse sett med standard egenskaper er lagret i Standardergren av treet. I stedet for å definere hver eiendom for hver komponent, og hver eiendom for hver tilkobling etc, bare tildele en standard. For eksempel kan de vanlige egenskapene til Unix-HP / UXkan lagres som en Standard og overdratt til noen komponenter som bruker Unix-HP / UXoperativsystem som vist for OS01 server i skjermbildet over.

· Typer - Denne grenen av treet er et bibliotek av de typer komponenter og tilkoblinger du kan bruke. Typer brukes for å definere den meta-modellen for arkitektur og for klassifisering og filtrering når du viser din arkitektur. De bestemmer også en mal for hva standarder, Egenskaper og begrensninger dine komponenter / tilkoblinger kan ha.

· Synspunkter- Utsiktpunkts kan lages fra eksisterende diagrammer, og kan brukes til å skape nye diagrammer.De er diagram sjablonger.

· Maler - Maler butikken re-brukbar mønstre av komponenter og forbindelser sammen med den måten de er representert eller vist. De kan betraktes som "mini" arkitekturer eller løsninger som kan plasseres i eksisterende arkitekturer.

2. Arkitekturer -De arkitekturer gren av treet er der du bygge arkitektur (r) av systemet. (Dette kalles fyller arkitekturen.) Du kan ha en rekke arkitekturer i en enkelt ABACUS fil.

3. Dashbord - Den Dashbord gren av treet er, hvor du kan få tilgang til alle lagrede oversikter for prosjektet.

Notat

Elementer i Explorer tre som har hatt sin Oppdater tillatelse fjernet (dvs. de er skrivebeskyttet) er vist i grått.

Type

Denne delen betegner spesifikk komponent eller tilkoblingstype på den valgte element i treet.

Standarder

Denne delen inneholder en liste over standarder for det valgte elementet i treet.

Beskrivelse

Dette avsnittet gir en kort beskrivelse av det valgte element i treet. Eventuelle relaterte hyperkoblinger kan også legges til denne delen. Disse inkluderer nettsteder eller lokale absolutte stier som peker til mer informasjon om det gitte elementet. Flere linjer er også tillatt. Gyldige hyperkoblinger trenger for å starte med en av 5 strenger; http: //, https: //, ftp: //, file: /// eller mailto :.

Tupp

For hyperkoblinger med mellomrom, kan brukerne skrive inn URL eller bane, velger du ønsket tekst og Høyreklikk| Link. Dette vil endre noen mellomrom til % 20så hele URL eller bane vil fungere korrekt.

Laget og Modified

Disse avsnittsgibrukeren og dato / klokkeslett for etablering av, og siste endring til, gjeldende valgte element i treet.

Referanser

Denne delen inneholder en liste over utgående og innkommende komponenter for det valgte elementet i treet.Det viser også de diagrammer, 3D og utsikt mere som for øyeblikket er valgt element vises i. Hvis et diagram er valgt det viser Point hvis aktuelt for diagrammet og for visninger generelt det viser noen Dashbord visningen vises i. Og når en Standard velges i treet det viser bruken av standarden typer, komponenter og tilkoblinger.

Egenskaper

Denne delen er der du definere hva som kjennetegner elementene i din arkitektur, liker måten du trenger det for å utføre, antall linjer med kode den har, hvor mange prosent av disse linjene som er kommentarer, etc.

De 'inngang' og 'utgang' egenskaper for pre-bygget simulatorer vil bli vist i vinduet med et ikon eiendom innspill rad velgeren Properties ( [image] ) Og utgang ikonet ( [image] ) Henholdsvis med et verktøytips som angir hvilke forhåndsbygd simulator eiendommen er knyttet til, for eksempel 'Modularitet Output' eller 'Ytelse Input ". Pilen på utgangs ikonene vil markere rød ( [image] ) Når eiendommen er utdatert på grunn av en underliggende eiendom eller strukturelle endringer i depotet med simulatoren krever re-simulering i henhold til rød utheving på Simulering verktøylinje .

Statuslinjen

Den venstre delen av statuslinjen viser hele banen til nå i fokus repository element, enten valgt i Explorer-vinduet eller på diagram lerret. Dette er slik at nøyaktig sted i lageret hierarkiet for det gitte element kan alltid lett bestemmes. Den høyre delen av statuslinjen viser ulike driftsmeldinger som "Åpen ABACUS File Vellykket 'og' kostnadsberegning Fullført '.

Se også

Hvordan du gjør det (oversikt) | Tilpasse grensesnittet | Hva er arkitektur? | Hvordan er en arkitektur representert i ABACUS? | Arbeide med ABACUS filer


Hva gjør ABACUS gjøre?

Navigasjon: Introduksjon til ABACUS>

Hva gjør ABACUS gjøre?

Send kommentarer om dette emnet.

Hvis du trenger hjelp på andre språk / oversettelser vennligst klikk her .

ABACUS tar gjette-arbeid ut av arbeider med løsninger, systemer, programvare, informasjon, teknologi, forretningsprosesser og / eller hele bedrifter (samlet referert til som arkitekturer). Det kan hjelpe deg til pragmatisk design, overvåke, simulere, analysere og visualisere arkitektur ved å modellere den, analysere den i intuitive måter (f.eks diagrammer, diagrammer og 3D) og deretter evaluere den mot ikke-funksjonelle krav.

Notat

Ikke-funksjonelle kraver de krav som ikke forholder seg direkte til hvordan et produkt fungerer. I stedet er de opptatt av hvor godt den fungerer. Ikke-funksjonelle krav omfatter slike ting som ytelse, åpenhet, evolvability, kvalitet, skalerbarhet, modularitet, etc. (i motsetning til funksjonskrav som, slå på dette lyset når denne knappen klikkes). Tradisjonelt har de ikke-funksjonelle krav vært vanskelig - hvis ikke umulig - å måle. Faktisk er ABACUS det eneste produktet som objektivt og quantifiably kan måle de tre første - opptreden, åpenhet, og evolvability.

Enkelt sagt, du går inn i arkitektur og hva du trenger den å gjøre. ABACUS så forteller deg om det vil gjøre som kreves, og påpeker eventuelle svakheter eller hull.

ABACUS trekker på over 20 år med systemer forskning og mange flere år med etablert systemteori. Det gir deg kvantifiserbare, pålitelige, objektive svar, så du er ikke avhengig av subjektiv vurdering.

ABACUS står for Architecture-Based Analysis, Communication og Understanding av Systems. Det kan hjelpe deg med noen storskala arkitektur, men det er vanligvis brukt for fire (4) ting:

· Evolvingen aktuell arkitektur. For eksempel, hvis din eksisterende arkitektur mangler ytelse, vil ABACUS visualisere arkitekturen for deg, identifisere problemer (flaskehalser, etc.), så fortelle deg nettopphvordan du kan forbedre arkitekturen.

· Prosjekteringen ny arkitektur. For eksempel, hvis du trenger en helt ny arkitektur, og du designer det selv, vil ABACUS fortelle deg nettopphvilke komponenter du trenger og hvordan de skal kobles.

· Innkjøpen ny arkitektur. For eksempel, hvis du har kalt for anbud på utformingen av en ny arkitektur, og du velger mellom tre design, vil ABACUS fortelle deg nettopphvilken som passer dine behov best.

· Kombineredagens eksisterende arkitekturer. For eksempel, hvis du trenger å kombinere to eller flere separate arkitekturer, vil ABACUS veilede deg.

Se også

Hvordan du gjør det (oversikt) | Hva er arkitektur? | Hvordan er en arkitektur representert i ABACUS?


Bruke koblinger i Diagrams

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

Bruke koblinger i Diagrams

Send kommentarer om dette emnet.

Former (fri form og komponenter) og kontakter (fri form eller tilkoblinger) innen diagrammer kan knyttes til eksisterende arkitektoniske representasjoner i ABACUS, samt eksterne filer / mapper og URLer. Disse lenkene kan da bli styrt (opprettet, endret og slettet) via ABACUS verktøysett. Denne funksjonen kan brukes til å forbedre navigasjon og generell forståelse av arkitektur skjematisk.

For å legge til linker til diagrammet

1. Sørg for at du har en eksisterende diagram åpen .

2. Velg aktuelt form eller kontakten fra diagrammet.

3. Høyreklikkpå figureneller kontakten.

4. Velge Åpne linkerog en Lenkeråpnes.

5. Klikk på Legg tilikon og en New Linkåpnes.

6. Velg aktuelt Katalog | Matrix | Diagram| 3D-visning| Chartradioknapper, og velg den aktuelle katalog, matrise, diagram, 3Deller diagram visning i dagens arkitektur fra Link til nedtrekksmenyen.

- eller -

6. Velg Nettstedradio-knappen, angir den aktuelle nettadressen (f.eks http: //www.avolutionprogramvare.com /)i feltet for å lenke til en nettside. Gyldige URLer trenger for å starte med en av 5strenger; http: //, https: //, ftp: //, fil: eller \\. Mellomrom bør legges inn med en '% 20'.

- eller -

6. Velg Absolute Fil | Relativ File radioknapps,klikk deretter på '..."-knappen For å finne en ekstern fil å linke til diagrammet.

7. Klikk OKog den nye koblingen vil bli vist i Koblinger vinduet. Merk: The Links vinduet kan bli endret for å se fullt navn hvis det er nødvendig.

8. Gjenta trinn 5-7å opprette flere koblinger.

9. Å følge linken opprettet, velger du den aktuelle koblingen vises i Lenkervinduet og klikk Åpne kobling.

Notat

Når flere merknader blir vist for en form eller kontakt koblingen er vist på den første merknaden i listen over kommentarer i dialogboksen Rediger merknader.

For å følge lenker fra diagrammet

1. Sørg for at du har en eksisterende diagram åpen .

2. Velg aktuelt form eller kontakten fra diagrammet.

3. Klikkpå den aktuelle hyperkobling (blå understreket komponent navn) på en form eller kontakten i diagrammet for å åpne og vise den første linken fra formeneller kontakten.Merk: Markøren bør endres til en "hånd" når lenken er klar til å bli klikket på.

- eller -

3. Velg aktuelt form eller kontakten fra diagrammet.

4. Høyreklikkpå figureneller kontakten.

5. Velge Åpne linker og Lenkeråpnes.

6. Velg den aktuelle linken som du ønsker å vise.

7. Klikk på Åpne koblingknappen for å åpne og vise relevant link.

Slik sletter lenker i diagrammet

1. Sørg for at du har en eksisterende diagram åpen .

2. Velg aktuelt formeller kontaktenfra diagrammet.

3. Høyreklikkpå figureneller kontakten.

4. Velge Åpne linker og Lenkeråpnes.

5. Velg den aktuelle linken som må slettes.

6. Klikk på Slett knapp. og koblingen er fjernet fra Lenker vindu.

Organisere lenker i diagrammet

Du kan velge hvilke knyttet diagram, ekstern fil, eller web URL vises når en figur etiketten er Ctrl + klikket i diagrammet.

1. Sørg for at du har en eksisterende diagram åpen .

2. Velg aktuelt form eller kontakten fra diagrammet.

3. Høyreklikkpå figureneller kontakten.

4. Velge Åpne linker og Lenkeråpnes.

5. Hvis du vil endre rekkefølgen på linkene klikk på Flytt opp | Flytt nedknappene på høyre side av Lenker vindu.

6. Den første linken som vises på venstre side av Lenkervindu er linken som vises når du Ctrl + klikken hyperkoblet form eller kontakten navn.

Se også

Fyller din arkitektur | Fyller din arkitektur manuelt | Analyse din arkitektur


Manipulere Diagrams

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

Manipulere Diagrams

Send kommentarer om dette emnet.

Når et diagram har blitt opprettet, de elementene som vises i den kan bli re-arrangert og re-størrelse som ønsket.

For å bevege en komponent i et diagram

1. Sørg for at du har en eksisterende diagram åpen .

2. Klikk-og-holden hvilken som helst komponent for å flytte den. Hvis den valgte komponenten har en forelder, vil den overordnede komponenten bli markert.

3. Når elementet erdras fra overordnet komponent, og i forhold til andre komponenter, 'potensielle foreldre vil bli markert. Fargevalget brukes indikerer effekten operasjonen vil ha på advarslene og feil med det aktuelle prosjektet og er beskrevet i Definere og validere begrensninger . På denne måten kan du grafisk navigere i hierarkiet fra en 'grunnriss ".

4. Gi utmuseknappen for å slippe elementet i den nye plasseringen.

Notat

Du kan også bruke tastaturet til å re-position elementer på lerret. Bare velg komponenten eller fri form form du vil flytte, og bruk piltastene på tastaturet for å flytte formen til ønsket sted.

Vær også oppmerksom på at når du drar en komponent med musen over en annen komponent, er en "potensiell" forelder komponent markert når øverste venstre hjørne av komponenten du drar lapper en annen komponent.

Tupp

Freeform og Flytende former kan bestilles ved høyreklikkeog velge Legg foran eller Send til Backfra menyen. Det er viktig å merke seg at komponent former kan omdannes til former ved frihånds høyreklikkepå spesifikk komponent form og velge Konverter til friform.

Å endre størrelsen på en komponent i et diagram

1. Sørg for at du har en eksisterende diagram åpen .

2. Klikk-hold-dragen av komponentens håndtak og endre størrelsen på formen til ønsket størrelse.

3. Alternativt å opprettholde formen bildeformat, trykk Shift + Klikk og hold-drag.

Slik flytter du en tilkobling i et diagram

1. Sørg for at du har en eksisterende diagram åpen .

2. Klikk-og-holdnoen forbindelse for å bevege den.

3. Gi utmuseknappen for å slippe elementet i den nye plasseringen.

Notat

Du kan bare flytte tilkoblinger som ikke er knyttet til noen komponenter. Hvis de er festet, kan du bare flytte den frie endens, eller re-rute tilkoblingen .

Slette komponenter og tilkoblinger

Når du sletter en komponent eller tilkobling fra et diagram, har du muligheten til å slette den fra hele arkitekturen. Komponenter som er slettet fra arkitekturen blir automatisk fjernet fra alle andre diagrammer der det vises. Siden frihånds tilfeller vises bare i ett diagram, slette dem ikke påvirker den arkitektoniske modell eller noe annet diagram.

For å slette en komponent eller tilkobling fra et diagram

1. Sørg for at du har en eksisterende diagram åpen .

2. Klikkpå eventuelle tilknyttede tilkobling eller komponent for å velge det.

3. Trykk på Sletttasten for å slette det fra diagrammet, eller Shift + Deleteå slette den fra hele modellen.

- eller -

2. Høyreklikk på eventuell tilknyttet element eller komponent. En hurtigmeny vises.

3. Velge Slett fra Vis eller Slett fra Arkitekturfra kontekstmenyen.

Notat

Hvis elementet som du ønsker å slette fra visningen har ingen barn og bare skjer på denne visningen, vil ABACUS spør om du vil slette elementet fra depotet i tillegg.

Forsiktighet

Når du sletter en komponent fra den modellen som har barn komponenter, barna vil også bli potensielt slettes i henhold til advarselen.

Sammenslåing Components

Det kan være lurt å slå sammen to komponenter eksisterende på samme diagram (og innenfor arkitekturen). Dette kan gjøres mange grunner, for eksempel, To servere eksisterer innenfor et selskaps i infrastruktur H01 og H02. Disse to serverne er representert som to separate komponenter i en arkitektur. H01 har vært ansett unødvendig og dermed er å bli tatt ut av drift. Alle eksisterende programmer som kjører på H01 er til å bli forskjøvet til H02 (fortsatt i provisjon). Denne endringen kan så bli reflektert ved virkningen av "sammenslåing" de to komponenter H01 og H02 på diagrammet (og innenfor arkitekturen).

For en detaljert diskusjon om sammenslåing henvises til Sammenslåing Items emnet her .

Å slå sammen to eksisterende komponenter

1. Sørg for at du har en eksisterende diagram åpen .

2. Høyreklikk-holdpå komponenten du ønsker å slå sammen og dradet på den komponenten du ønsker å slå det sammen med. Sørg for at omrisset av reisemålet komponent er merket rødt for å indikere at det er valgt.

3. Velge Flett | Bevar Destinasjon eller Skrivings Destinasjonfra menyen.

Notat

De Bevar Destinasjonalternativet beholder verdiene av bestemmelses komponentens egenskaper hvis de finnes på den opprinnelige komponent samt.

De Skrivings Destinasjonalternativet overskriver destinasjonen komponentens egenskaper med noen felles egenskaper fra den opprinnelige komponenten.

Endre Tilkoblinger

Koblingene som vises i et diagram alltidreflekterer strukturen som definert i selve arkitekturen. Tegneverktøyet kan du koble tilkoblinger fra komponenter, flytte dem, kurve dem, re-rute dem og re-feste dem til andre komponenter.

Å løsne / feste en forbindelse fra / til en komponent

1. Sørg for at du har en eksisterende diagram åpen .

2. Klikk-og-holdpå noen sammenheng.

3. Velgetilkoblingen slutt(dvs. Kilde eller Sink) Som du ønsker å løsne / feste. Merk: tilkoblingsendene er markert med små hvite sirkler og svever over den hvite sirkelen for andre vil føre til en "verktøytips" for å dukke opp med den respektive rolle navn(dvs. enten Source eller Sink).

4. Dratilkoblingen ende til et nytt sted (enten en ledig plass eller en komponent) og slipper museknappen.

Notat

Når en forbindelse ende er plassert over en gyldig komponent, blir omrisset av bestemmelsesdelen markert med en stiplet omriss. Fargevalget brukes indikerer effekten operasjonen vil ha på advarslene og feil med det aktuelle prosjektet og er beskrevet i Definere og validere begrensninger . Når løslatt den enden av the forbindelse og komponenten kobles automatisk(eller festet)Er og dette gjenspeiles i den arkitektoniske modell.

Å omdirigere en tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Plasser musepekeren over en tilkobling.

3. Hold Skiftetasten nede og Klikkmuseknappen for å plassere en sammenheng ankerpunkt. Slipp Skifte nøkkel. Du kan fjerne ankerpunkt ved å gjøre den samme operasjonen.

4. Klikk-og-draankerpunktet for å re-rute tilkoblingen.

Tupp

BrukeAlt tasten i stedet for SkifteNøkkelen til å skape ortogonale tilkoblinger.

Til kurve eller retteen tilkobling

1. Sørg for at du har en eksisterende diagram åpen .

2. Plasser musepekeren over en tilkobling.

3. HøyreklikktHan tilkobling og i hurtigmenyen som vises velg Kurve, Orthogonal eller Rett.

Tupp

Alle tilkoblingerav en gitt type på diagrammet kan settes til Buet, Orthogonal eller Straight ved å høyreklikke den tilhørende linjen for type på Kategorien Tilkoblinger av Stencil vinduog velge Curve, Orthogonal eller Straight.

Til anker på et bestemt punkt på kanten av en form

1. Sørg for at du har en eksisterende diagram åpen .

2. Velg en tilkobling.

3. Plasser musepekeren over den "hvite dot 'ved enden av en tilkobling.

4. HøyreklikktHan forbindelse enden og i hurtigmenyen som vises velg Forankre Endpoint til Shape.Flytt forbindelse slutten til ønsket plassering på kanten av formen.

ELLER

Hold Ctrltasten nede og cslikk-og-dra de tilkobling slutten punkt til ønsket beliggenhet på kanten av formen.

Notat

Tilkoblinger vil knipse til selve skjærings av deres tilkoblede form i stedet for markeringsrammen for den formen.

Se også

The Drawing Tool | Fyller din arkitektur | Analyse din arkitektur


Sammenslåing elementer

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Sammenslåing elementer

Send kommentarer om dette emnet.

Når ønsker du fletter elementer?

Du ville fusjonere elementer når du har to (eller flere) objekter i modellen som er best representert ved en enkelt forekomst. Det er mange situasjoner når du kanskje ønsker å gjøre dette, inkludert:

· Som et resultat av å importere et nytt sett med informasjon inn i modellen som kan kopiere eller erstatte eksisterende informasjon. For eksempel hvis du importerer en oppdatert versjon av et regneark i modellen.

· Over tid duplikater av den "samme" komponent er opprettet og du ønsker å rydde opp i disse duplikater.

· Hvis du utfører en hva-hvis-scenario og elementene du er modellering faktisk sammenslåing i virkeligheten. For eksempel, hvis du er å slå sammen to avdelinger i organisasjonen, eller hvis du slå sammen to servere.

Hva kan flettes?

Følgende typer elementer støtter slås sammen:

· Standarder

· Komponent- og Tilkoblingstyper

· Komponenter og tilkoblinger

Hvordan slå sammen elementer

For å initiere en sammenslåing, ved hjelp av høyre museknapp, dra ett element i explorer til en annen. Varen du drar er kilden, og elementet du drar over er målet. Ved å slippe høyre museknapp vil du bli presentert med en meny der du kan velge å slå sammen de to elementene. Du må velge om du ønsker å bevare eller skrive over mål. Dette er nærmere forklart nedenfor.

Flettingen høyre-dra-menyen

Hva er forskjellen mellom å bevare og skrive reisemålet?

Bevare eller overskrive alternativ dikterer hva som skjer hvis Navn, Beskrivelse eller Properties mellom kilden og destinasjons elementer kamp.

Hvis Bevar Destination er valgt

· Destinasjonens Navn og beskrivelse vil bli holdt.

· Noen egenskaper som bare finnes i kilden tilsettes til bestemmelsesstedet.

Hvis Write Destination er valgt:

· Destinasjonens navn vil bli overskrevet fra kilden.

· Destinasjonens Beskrivelse vil bli overskrevet fra kilden, med mindre kildens beskrivelse er blank.

· Noen egenskaper som bare finnes i kilden tilsettes til bestemmelsesstedet.

· Verdien og Enhet for egenskapene som finnes i både kilden og målet vil bli overskrevet fra kilden, med mindre kildens verdi eller Unit er blank.

Spesielle tilfeller

· Typer: Når sammenslåing typer er adgangen slått sammen, i en "pessimistisk" måte, slik at dersom tillatelse på kilden ikke eksisterte på destinasjonen, ville det bli lagt til, og hvis det fantes i målet, så hvis den enkelte tillatelse for en brukergruppe (opprette, lese, oppdatere eller slette) samsvarte ikke med (en gitt, én benektet), så at tillatelse vil bli avslått.

· Komponenter: Når sammenslåing komponenter er under komponenter av kilden migrert til destinasjonen, og slås sammen med delkomponenter i mål hvis navnene deres er identiske, Uavhengig av type.Videre vil flere underkomponenter av kilden med samme navn slås sammen til en enkelt sub-komponent i målet.

· Tilkoblinger: Den øverste nivå tilkoblinger selv må begge ha samme vedlegg (eller mangel på sådan) for å få lov til å bli slått sammen. Når sammenslåing tilkoblinger, under tilkoblingene til kilden migrert til destinasjonen, og slås sammen med sub-tilkoblinger i mål hvis navnene deres er identiske OGvedleggene er identiske. Hvis vedlegg er ikke identiske, vil kildeunder tilkoblinger legges til destinasjonen uten sammenslåing med matchende tilkoblinger som allerede finnes. Dette er slik at ingen vedlegg går tapt.


Navigasjon i en 3D-diagram

Navigasjon: Analyse din arkitektur> 3D-diagrammer>

Navigasjon i en 3D-diagram

Send kommentarer om dette emnet.

ABACUS lar deg enkelt navigere gjennom arkitektur i 3D. Opplevelsen er lik flyr. Det er to moduser av navigasjon:

· Basic Control Mode (standard); og

· Advanced Control Mode - endring i denne modusen ved å velge Kontroll| Advanced Control Mode.

Notat

Slik bytter du mellom Basic Kontroll og Advanced Control Modes, kan du bruke F4hurtigtast funksjonalitet.

Basic Control Mode

· Holde venstre knapp og flytte musen forover eller bakover endrer banen;

· Holde venstre knapp og flytte musen til venstre eller høyre endrer yaw;

· Holder den høyre knappen og flytte musen panner utsikten;

· Holde begge knappene ned og flytte musen forover eller bakover, zoomer inn og ut av arkitektur; og

· Holde begge knappene ned og flytte musen til venstre eller høyre, ruller venstre og høyre.

- eller -

· Ved å trykke på Pil venstrepå tastatur eller numerisk tastatur vil slå venstre;

· Ved å trykke på Høyrepilpå tastatur eller numerisk tastatur vil ta til høyre;

· Ved å trykke på Pil opppå tastatur eller numerisk tastatur vil zoome inn;

· Ved å trykke på Down Arrowpå tastatur eller numerisk tastatur vil zoome ut;

· Pressing Side opppå tastatur eller numerisk tastatur vil kaste opp; og

· Pressing Side nedpå tastatur eller numerisk tastatur vil kaste ned.

Advanced Control Mode

· Flyttingmusen frem og tilbake, og opp og ned, endrer pitch og yaw (henholdsvis);

· Pressing W eller Pil oppzoomer inn (forover) til arkitektur;

· Pressing S eller Down Arrowzoomer ut (bakover) fra arkitekturen;

· Pressing A eller Pil venstreruller til venstre;

· Pressing D eller Høyrepilruller til høyre;

· Pressing Q eller Side nedløfter visningen (ved å senke perspektiv); og

· Pressing E eller Side oppsenker view (ved å heve perspektiv).

Interaktiv Control Mode

Trykke og holde inne Shift-tastenpå tastaturet styrer gjeldende modus (Basic eller avansert) for å gå inn i interaktiv kontroll modus. I denne modusen følgende er mulig:

· Rullemusepekeren over en komponent eller tilkobling for å se komponent eller navn forbindelse er;

· Klikkpå en komponent for å zoome inn på denne komponenten;

· Klikk-og-drapå en komponent for å rotere rundt det syn komponenten; og

· Høyreklikken komponent eller tilkobling og velg Vis i Utforskerfor å se at komponent eller forbindelse beliggenhet i treet.

Vanlige kontroller

· Bruk ALT-ENTER / ESCå veksle fullskjermmodus;

· Bruk F2å endre visningsmodus. Dette kan også nås på Utsikt Meny.

· Bruke musehjulet eller +/-å endre hastigheten. Hastigheten er angitt med et nummer i nedre venstre hjørne - vises bare når det er i endring. 1 er lavest og 100 er raskest.


Åpning Diagrams

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

Åpning Diagrams

Send kommentarer om dette emnet.

Tegningen sjablong og lerret vinduer vises automatisk når et diagram er åpnet eller opprettet. Tilsvarende når et diagram er lukket, tilsvarende faneblad i lerretet vinduet forsvinner og hvis ingen ytterligere tegninger er åpne deretter sjablongen vinduet er lukket.

Til lageet nytt diagram

1. Kontroller at du har enABACUS fil åpeninneholder din befolket arkitektur.

2. Klikk på Diagramikonet i View-verktøylinjen.

- eller -

2. Velge Sett| Diagram.

- eller -

2. Høyreklikk de Diagrammergren av en gitt Arkitekturdelen av treet og velg Lage Diagram.

3. Velg Arkitekturdu ønsker å fokusere på, fra rullegardinmenyen. Merk: arkitekturen vil allerede være valgt for deg hvis du brukte Trinn 3 ovenfor for å åpne den nye diagrammet.

4. Velg Utsiktspunkt du ønsker å bruke fra rullegardinmenyen. Merk: den valgte synspunkt vil filtrere komponenter og forbindelser lister for å bare være de som er tilgjengelige på utsiktspunktet.

5. Eventuelt velge en visning fra Filter etter Utsiktrullegardinmenyen for å forhåndsvelge komponenter og forbindelser fra den valgte visningen. Merk: Dette er en effektiv måte å bruke den valgte visningen som en lagret spørring.

6. Velg Oppsett å være enten Radial eller Grid.

7. Velg Komponenter og Tilkoblingersom du ønsker i diagrammet fra standard element utvalg vindu .

8. Klikk OK.

Notat

En ny diagram vil bli lagt til Diagrammergren av arkitekturen. Den vil ha et standardnavn, som du kan endre senere ved å høyreklikke på den.Videre vil det siste av komponent og utvalgs forbindelse filtre lagres med diagrammet effektivt redde 'spørringen "som brukes til å opprette diagrammet.

For å åpne en eksisterende Diagram

1. I den konkrete befolket arkitektur, utvide Diagrammergren av treet.

2. Dobbeltklikk diagrammet du vil åpne.

Slik lagrer du et diagram

1. Sørg for at du har en ny eller eksisterende diagram åpneog du har gjort de nødvendige endringene. Merk: en stjerne '*' vil bli vist etter navnet på fanebladet header utsikt hvis det er endringer for å bli frelst.

2. I explorer visning klikk på Spareknappen eller fikk Fil| Spareeller trykke Ctrl + Sfor å lagre alle endringer i arkitekturen og skrive det til fil.

Slik lagrer du et diagram som en utsiktspunkt

1. Sørg for at du har et eksisterende diagram i ABACUS fil.

2. Høyreklikkdiagrammet i Diagrammerdel av treet.

3. Velge Lagre som Diagram Point.

4. Skriv inn et navn for den nye diagram synspunktog klikk OK.

Se også

The Drawing Tool | Fyller din arkitektur | Analyse din arkitektur


Fyller bruker Kataloger

Navigasjon: Fyller ditt arkitektur>

Fyller bruker Kataloger

Send kommentarer om dette emnet.

A katalog kan du vise og redigere komponenter eller tilkoblinger og deres egenskaper på en enkel tabell måte.

Til opprette en ny katalog se i ABACUS

Notat

Mens alle Arkitekt brukere kan opprette nye kataloger, for å lagre endringer i en eksisterende Katalog innstillinger på brukerlisens må Designer add-on evne. Dette er for å "beskytte" konfigurasjonen av eksisterende kataloger som kan deles av mange brukere. Men bruker Arkitekt uten Designer add-on kan fortsatt velge å "Lagre som" alle nye innstillinger til en ny katalog. Og selvfølgelig alle brukerlisenser kan velge å "Kast" eventuelle endringer i en eksisterende katalog. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger Designer add-on evne. Og husk, dette er bare innstillingene for Catalogue, er alle endringer som er gjort til dataene i katalogen umiddelbart påføres depotet, uansett.

1. Velg Sett inn | Katalog.

2. I pull-down velge Arkitektur som inneholder komponenter ellertilkoblinger du ønsker å se.

3. I pull-down velge komponenten eller tilkoblingstype som du ønsker å ha de tilfeller oppført som 'rader' i katalogen.

4. De katalog vil bli befolket med enrad for hver forekomst av den valgte komponenten eller tilkoblingstype.

Notat

Som standard lengst til venstre Hierarki Stikolonne (dvs. hierarki av overordnede komponenter eller forbindelser over de valgte tilfeller) og 2. Navn kolonne (dvs. en liste over de valgte komponent eller tilkoblings tilfeller) er frosset til venstre for katalog. Hvis du vil endre kolonne frysing separator kolonnen dra til høyre for kolonnen Navn. Du kan re-orderkolonner rett og slett ved å dra og slippe sine kolonneoverskriftene. Celler av kolonner med blå understreking er hyperkoblinger til andre elementer i prosjektet og hyperkoblinger kan følges ved å holde nede Ctrl og klikke på linkene. Kolonner kan være skjult ved å høyreklikke på kolonneoverskriften og velge Column | Skjul kolonne. Skjulte kolonner kan vises av å klikke på Konfigurer Kolonner-knappen på verktøylinjen og bruker Konfigurer kolonner dialogboksen som vist nedenfor, eller ved å velge pil ned delen av Konfigurer Kolonner-knappen på verktøylinjen og individuelt velge den skjulte kolonnen (e) fra enten General, Properties eller vedlegg samlinger. Rader kan være gruppert av sine kolonneverdier av kolonneoverskriften dra inn i den blå gruppering linjen øverst av katalogen. Til enhver tid kan du dobbeltklikke på katalog rad velger og hoppe tilden tilsvarende komponenteller tilkoblingi Explorer-vinduet.Eiendom celleverdier er uthevet hvor de er annerledes enn standardinnstillingene, og kursiv hvor de er skrivebeskyttet. Tidsstempel, Eiendom og Attached Component kolonner kan være farget henhold til celleverdier eller en vedlagt komponentens eiendomsverdi ved å høyreklikke på kolonneoverskriften og velge Column | Endre farge ... og deretter farge ved Stempel eller Colour By Eiendom alternativet, men bare List, Integer, Desimal, boolsk eller dato / klokkeslett data type eiendommer vil farge. Eiendomsverdiene for Attached Komponent kolonner kan være vist ved å høyreklikke på kolonneoverskriften og velge Column | Vis Property ... og deretter Show Eiendom alternativet. Og til slutt, hvor det finnes Obligatoriske begrensninger satt for en eiendom kolonne disse kan vises med et string (sammen med fargestoffer i henhold til deres håndheving nivåer) av kolonneoverskriften høyreklikke og velge Column | Vis .

Katalog

Til legge til / vise kolonner a Katalog visningen i ABACUS

1. Sørg for at du har en Katalog view åpne.

2. Skjulte kolonner kan være individuelt unhidden ved å klikke på pil på høyre side av Konfigurer Kolonner-knappen på verktøylinjenog velge den skjulte kolonnen fra enten General, Egenskaper eller Vedlegg samlinger.

Notat

En hake vises ved siden av tiden vist kolonner for katalog.I tillegg vil kun enkelte vedlegg være tilgjengelig under vedleggsseksjonen i henhold til begrensninger som er definert i prosjektet. Spesielt til for et vedlegg være tilgjengelig for å bli vist i en komponent katalog komponenttypen for katalogen må spesifiseres som enten kilde eller synke (ikke "Enhver") av en "connection må vedlegges" begrensningen for en tilkobling typen, og det må også være i det minste en komponent type som er angitt som enten kilden eller synke (ikke 'Enhver') på den andre 'ende' av samme tilkoblingstype.

- ELLER -

2. Flere kolonner kan unhidden (eller bestilt eller fast) ved å klikke på Konfigurere Kolonner-knappen på verktøylinjenog bruke Konfigurer kolonner dialogboksen vist nedenfor.

Notat

De som vises kolonner vises i panelet på høyre side med de tilgjengelige kolonner som vises i panelet til venstre. De tilgjengelige kolonner kan filtreres i henhold til Velg Tilgjengelige kolonner frapull-down og de kan legges til ved å velge dem i panelet til venstre og klikke på Legg til knappen inbetween de to panelene.

Konfigurer dialog kolonner

Til fjerne / skjule kolonner fra en Katalog visningen i ABACUS

1. Sørg for at du har en Katalog view åpne.

2. Kolonneoverskriften Høyreklikk for kolonnen du ønsker å fjerne / skjule og velg Kolonne | Hide Column.

- ELLER -

2. Flere kolonner kan skjules (eller bestilt eller fast) ved å klikke på Konfigurere Kolonner-knappen på verktøylinjenog bruke Konfigurer kolonner Dialog vist ovenfor.

Notat

De som vises kolonner vises i panelet på høyre side med de tilgjengelige kolonner som vises i panelet til venstre. De som vises kolonner kan være skjult ved å velge kolonnen i panelet til høyre og klikke på Fjerne knappen inbetween de to panelene.

Å fylle ved hjelp av en Katalog visningen i ABACUS

1. Til legge en komponent eller forbindelseav den valgte typen til de katalogen (og prosjekt) klikk på Legg til ny Component / Legg til ny verktøylinje Connection-knappen. Den bør rad vises og en komponent eller forbindelsen vil bli opprettet på øverste nivå i Komponenter eller Tilkoblinger kolleksjon for den valgte Architecture.

Notat

Nye komponenter og tilkoblinger er lagt til som standard på øverste nivå i Komponenter eller Connections samling av det valgte Architecture. For å endre den overordnede av de nye komponentene eller tilkoblinger høyreklikk Hierarkiet Sti celle for den nye komponenten eller tilkoblinger rad og velg Endre Parent ...og velg ønsket forelder (ta notat av begrensning utheving ).

Notat

Nye rader / elementer legges direkte til en katalog via "Legg til ny" -knappen, limt inn i katalogen, eller opprettet via import til katalogen fra MS Excel er unntatt fra filtrering før katalogen er stengt. Dette er for å tillate noen nødvendig redigering av kolonneverdier som ikke tilfredsstiller dagens filtreringskriteriene av katalogen. Disse nye elementrader er angitt med et "+" symbol i raden velgeren cellen ved begynnelsen av rekken, som er farget grønn hvis elementet møter i dag de lagrede filtreringskriteriene i katalogen (dvs. vil forbli på katalogen hvis re-åpnet), og rød Hvis den ikke gjør det.

2. Til fjerne en komponent eller forbindelseav den valgte typen fra de katalogen (og prosjekt) velger du raden og enten trykke Del-tasten eller høyreklikk på rad velgeren og velg Slett fra Architecture. De rad bør forsvinne fra katalogen og det vil bli slettet fra prosjektet.

Til filter ved hjelp av en Katalog visningen i ABACUS

1. Sørg for at du har en Katalog view åpne.

2. Hvis filteret rad ikke vises på toppen av katalogen klikk deretter på Vis Filter Header Rowknappen på verktøylinjen.

3. I kolonnen ønsker du å legge til et filter, dobbeltklikker du på filter rad cellen der det viser '(alle)'.

4. Til Tidsstempel, Hierarki Path, Name eller Beskrivelsegenerelle kolonner eller Tekst, Integer, desimal, boolsk eller Dato tideiendoms kolonner klikker du på ... knappen som vises i den høyre av filteret rad celle og inn celleverdier som bør inkluderes i katalogen.

Notat

Matching er utført som om '*' jokertegn brukes automatisk før og etter eventuelle strengverdier, slik at en oppføring av "katt" (uten anførselstegn) vil inkludere rader med "bobkatt','kattkvinne "eller" appakattion 'etc. Multiple /' eller 'verdier kan legges inn på nye linjer ved hjelp Ctrl + Enter. For Integer og desimal eiendoms kolonner "og" logikk kan inkluderes ved å bruke '&"(Uten anførselstegn) og større enn / mindre enn etc logikk kan inngå bruker '> =','>','<' og '<="(Uten anførselstegn) f.eks '> = 50000 & <90000 ". Non-tomme verdsatte rader kan inkluderes ved å skrive '(Non-Blanks)"(Uten anførselstegn) og Blank verdsatte rader kan inkluderes ved å skrive '(Blanks)"(Uten anførselstegn).Og til slutt, alle filtre er som standard små bokstaver så "katt" (uten anførselstegn) vil inkludere rader med "katt", "Cat" eller "CAT" etc. For store og små bokstaver matching, skriv '(Sak)"(Uten anførselstegn) før strengen f.eks '(Sak) Cat' (uten anførselstegn) ville bare omfatte rader med "Cat" i dem.

5. Til Vedleggkolonner, Standarder kolonner eller Liste eiendoms kolonner klikker du på pil ned-knappen som vises i riktig av filteret rad celle og velger celleverdiene fra sjekkboksene som bør inkluderes i katalogen.

Notat

The '(Velg alle) "boksen vil gjøre alle de andre avkrysningsbokser, i effekt inkludert alle tilgjengelige radene. The '(Non-Blanks) "boksen vil inneholde enhver ikke-blank verdsatte rader. The '(Blanks) "boksen vil inneholde noen tomme verdsatt rader. Og til slutt, fjerne krysset noen spesifikke verdsettes boksene vil automatisk velg bort den "(Velg alle)" og "(Non-Blanks) 'boksene for konsistens.

6. Klikk OK å bruke filteret.

Til deaktivere / aktivere filtrering på a Katalog visningen i ABACUS

1. Sørg for at du har en Katalog view åpne med en filter anvendt.

2. Klikk i boksen til venstre for filteret rad.

Til fjerne et filter fra a Katalog visningen i ABACUS

1. Sørg for at du har en Katalog view åpne med en filter anvendt.

2. En individuell kolonne filter for å fjerne høyreklikke på kolonneoverskriften og velg Kolonne | Clear Filtrering.

3. Hvis du vil fjerne alle filtre klikk på Alternativer knappen på verktøylinjen og velg Klare Filter Innstillinger.

Å redde / lagre som aKatalog view

Notat

Mens alle Arkitekt brukere kan opprette nye kataloger, for å lagre endringer i en eksisterende Katalog innstillinger på brukerlisens må Designer add-on evne. Dette er for å "beskytte" konfigurasjonen av eksisterende kataloger som kan deles av mange brukere. Men bruker Arkitekt uten Designer add-on kan fortsatt velge å "Lagre som" alle nye innstillinger til en ny katalog. Og selvfølgelig alle brukerlisenser kan velge å "Kast" eventuelle endringer i en eksisterende katalog. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger Designer add-on evne.Og husk, dette er bare innstillingene for Catalogue, er alle endringer som er gjort til dataene i katalogen umiddelbart påføres depotet, uansett.

1. Sørg for at du har en ny eller eksisterende Katalog visning åpneog du har gjort de nødvendige endringene.

2. I Katalog viewverktøylinje klikk på Spareknappen for å lagre Katalog view og eventuelle formateringsendringer.

Notat

Hvis du ikke har en Lagre-knappen på verktøylinjen Katalog visning så du ikke har Designer add-on, og du er bare i stand til å Lagre somnoen innstillinger endres til en ny katalog når du går for å lukke den eksisterende katalog.

3. Hvis de Katalog NavnDialogboksen vises (grunn til å være en ny katalog) skriv et navn for katalog og trykk OK.

Til eksport til MS Excel katalog

1. Sørg for at du har en Katalog view åpne.

2. Klikk på Eksporter til Excel Catalogue regnearkknappen på verktøylinjen.

3. Velg et filnavn for å redde MS Excel katalogen som. Klikk Spare.

Notat

Som standard er eksportert MS Excel Katalog filnavn blir Katalog navn suffikset ved Arkitektur navnet i parentes, for eksempel 'Prosjekter (2 014 Actual) XLSX'. Du kan endre noe av dette, herunder om filformatet er å være .xlsx eller .xls. The Architecture navn er inkludert for å minne brukeren om at hver katalog har bestemt innhold (dvs. IDer i kolonne A og rad 1) for å tillate det å være rund-utløst tilbake i å bruke Importer fra MS Excel katalogen som per nedenfor.

Notat

Som standard er skjult kolonne A i den eksporterte MS Excel katalog inneholder en unik ID for hvert av elementene i ABACUS depotet. Dette gjør at eventuelle endringer som er gjort innen MS Excel til å være "matchet opp" til eksisterende elementer innen ABACUS om import (se nedenfor). Imidlertid kan bruk av denne unike ID for å "matche" rader overstyres med en Ekstern | IDeiendom på elementet. Det vil si, hvis element har en utvendig | ID eiendom, og det er inkludert i butikk eksport deretter verdiene av External | ID-kolonnen vil bli brukt til å matche opp radene på import (se nedenfor), og de unike ID-verdier i det skjulte kolonne A vil bli ignorert (og kan også være blank). Den skjulte Kolonne A selv må gjenstår imidlertid, spesielt verdien i cellen A1. Videre, når du legger eksterne ID-er til en eksisterende ABACUS element samling vi anbefaler å legge dem som en annen eiendom først, f.eks Ekstern | Temp og deretter døpe eiendommen til External | ID. Ellers dupliserte elementene vil bli lagt til.

Katalog formateringeksporteres som standard, men for store kataloger dette kan resultere i eksporten blir ganske treg. Følgelig, i Verktøy | Alternativer ...deretter på de Katalogtab,du er i stand til å redusere mengden av formatering som eksporteres som vist på Catalogue fanen nedenfor, og dermed påskynde eksport.

Katalog eksport alternativer

4. En Export Fullført dialogboks vises. Klikk OK.

Eksporteres til MS Excel katalog

Til import fra MS Excel katalog

Notat

Som standard er skjult kolonne A i den eksporterte MS Excel katalogen (se ovenfor) inneholder en unik ID for hvert av elementene i ABACUS depotet. Dette gjør at eventuelle endringer som er gjort innen MS Excel til å være "matchet opp" til eksisterende elementer innen ABACUS på import. Imidlertid kan bruk av denne unike ID for å "matche" rader overstyres med en Ekstern | IDeiendom på elementet. Det vil si, hvis element har en utvendig | ID eiendom, og det er inkludert i butikk eksport (se ovenfor) vil verdiene for External | ID-kolonnen vil bli brukt til å matche opp rader på import og den unike ID-verdier i skjulte kolonne A vil bli ignorert (og kan også være blank). Den skjulte Kolonne A selv må gjenstår imidlertid, spesielt verdien i cellen A1. Videre, når du legger eksterne ID-er til en eksisterende ABACUS element samling vi anbefaler å legge dem som en annen eiendom først, f.eks Ekstern | Temp og deretter døpe eiendommen til External | ID. Ellers dupliserte elementene vil bli lagt til.

1. Sørg for at du har en Katalog view åpne.

2. Klikk på Import fra Excel Katalog regnearkknappen på verktøylinjen.

3. Velg et filnavn for å importere MS Excel katalog fra. Klikk Åpne.

4. Nye Feil oppdages og / eller nye feil / advarsler Detected dialoger kan vises for alt nytt innhold (dvs. rader i MS Excel) som ble lagt til. Legg merke til feil / advarsler og klikk OK.

5. En Import Fullført dialog vises og det kan vise advarsler på grunn av den import (se merknadene nedenfor). Klikk OK.

Notat

For de tildelte Standards eller vedlegges Component kolonner, må nye oppføringer via MS Excel katalogen matche akkurat det navn av en eksisterende Standard eller Component av riktig type for oppdraget eller tilkobling som skal legges. Den første heter Kampen vil bli brukt og alle umatchede oppføringer vil generere en advarsel som per nedenfor. Videre, mens advarsler er gitt på re-import, elementene er slettes ikkefra ABACUS hvis de ikke er til stede i MS Excel katalogen. Dette er fordi det er ingen måte at ABACUS kan vite om den tildelte Standard eller festet Component eksisterer i ABACUS prosjektet, men finnes ikke i MS Excel katalogen fordi det har blitt slettet fra MS Excel katalogen eller har blitt lagt til ABACUS prosjektet siden katalogen ble eksportert. Følgelig, hvis brukerne ønsker å enkelt 'oppdage' hvilke tilkoblinger har blitt lagt under importprosessen de kan rett og slett skape en nødvendig egenskap på tilkoblingstype og sette det er standard til blank, slik at de vil bli advart om eventuelle nye tilkoblinger hver gang import er fullført.

Notat

Når du importerer en MS Excel katalog ulike advarsler kan vises. For det første, hvis en ny kolonne ble lagt i Excel som ikke samsvarer med "syntaks" for en eiendom eller festet komponent kolonnen vil bli ignorert. Deretter vil linje for linje advarsler skal vises for noen problemer med dataene på hver rad i Excel katalogen. Disse advarslene begynne med radnummer i hakeparentes, og hvis relevant kolonneetiketten (dvs. "[23, J] ... 'for rad 23, kolonne J) og kan henvise til slettede elementer, uovertruffen standarder eller tilkoblede Komponent navn (som ignoreres som per note ovenfor) eller et ugyldig eller blank ID knyttet til en ny rad / element (som vil bli lagt til). For en detaljert artikkel om populere ABACUS bruker Excel kataloger henvises det til Avolution fellesskap eller porteføljeforvalteren kurs.

Notat

Nye komponenter og tilkoblinger er lagt til som standard på øverste nivå i Komponenter eller Connections samling av det valgte Architecture. For å endre den overordnede av de nye komponentene eller tilkoblinger høyreklikk Hierarkiet Sti celle for den nye komponenten eller tilkoblinger rad og velg Endre Parent ...og velg ønsket forelder (ta notat av begrensning utheving ).

Notat

Elementer legges direkte til en katalog via "Legg til ny" -knappen, limt inn i katalogen, eller opprettet via import til katalogen fra MS Excel er unntatt fra filtrering før katalogen er stengt. Dette er for å tillate noen nødvendig redigering av kolonneverdier som ikke tilfredsstiller dagens filtreringskriteriene av katalogen. Disse nye elementrader er angitt med et "+" symbol i raden velgeren cellen ved begynnelsen av rekken, som er farget grønn hvis elementet møter i dag de lagrede filtreringskriteriene i katalogen (dvs. vil forbli på katalogen hvis re-åpnet), og rød Hvis den ikke gjør det.

Til sammenligne innholdet i en katalog med en annen arkitektur

1. Vennligst referer til emnet her .

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Fyller du arkitektur fra Visio | Fyller du arkitektur fra Excel


Fyller bruker matriser

Navigasjon: Fyller ditt arkitektur>

Fyller bruker matriser

Send kommentarer om dette emnet.

En matrise kan du vise og redigere 'direkte' tilkoblinger mellom komponenter i en enkel tabell måteog også vise 'indirekte sti "mellom komponenter i henhold til noen mellomliggende komponenter (og tilkoblinger).

Til lage en Matrix-visning i ABACUS

Notat

Mens alle Arkitekt brukere kan opprette matriser for å redde dem og / eller deres innstillinger brukerlisens må Designer add-on evne. Dette er for å "beskytte" konfigurasjonen av eksisterende Matriser som kan deles av flere brukere. Men bruker Arkitekt uten Designer add-on kan fortsatt velge å "Lagre som" alle nye innstillinger til en ny Matrix. Og selvfølgelig alle brukerlisenser kan velge å "Kast" eventuelle endringer i en eksisterende Matrix. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

1. Velg Sett inn | Matrix.

2. I rchitecture>pull-down velge Arkitektur som inneholder komponenter og tilkoblinger du ønsker å vise.

3. I <KildeSkriv inn>pull-down velge komponenten typen som du ønsker å ha de tilfeller som er oppført som 'rader' nedover venstreav matrisen.

4. I <SynkeSkriv inn>pull-down velge komponenten typen som du ønsker å ha de tilfeller som er oppført som 'kolonner' øverstav matrisen.

5. I trekk ned Det er i hovedsak to "moduser" av matrisen du kan definere ...

"Direkte" tilkoblinger matriser

6. Bare svelge en (1) eller mer forbindelse typer på høyre side av menyen som vises hvis du ønsker å se i "celler" i matrisen hvis enn eksplisittsammenheng eksisterer fra Vertikal/ 'rad'Komponent av matriksen i Horisontal/ 'søyle'Komponent av matriksen.

Notat

Kun forbindelser med kilden ende festet til Vertikal/ 'rad'Komponent og vask ende festet til Horisontal/ 'søyle'Komponent vil bli vist. Slå Kilde og SynkeKomponenttype valg for å se sammenhengene i motsatt retning.

7. Matrisen vil bli fylt med en "X" i cellene (eller en eiendomsverdi - se merknad nedenfor) hvis det er en forbindelse fra Vertikal/ 'rad'komponent av matriksen i Horisontal/ 'søyle'Komponent av matriksen.

Notat

For store matriser bare maksimalt 100 rader eller kolonner (inkludert kollapset rader / kolonner) vil bli vist på et tidspunkt som vist med 'R' og 'C' indikatorer i øverste venstre tittelcelle hhv. Å vise flere rader bruke rullefeltene. Til enhver tid kan du dobbeltklikke på Vertikal/ 'rad' eller Horizontal / 'søyle' komponent overskrifter og hoppe tilde tilsvarende komponenter i Explorer-vinduet.Foreldrene til Vertical/ 'rad' og Horisontal/ 'søyle' komponents er også eventuelt vist som overskrift rader / kolonner med en grå overskrift tittel. Når kollapset (ved å enkelt klikke overskriften celle) hvis barn vedlegg eksisterte da en "X" vil eventuelt bli vist hvis alle barna var festet eller en 'O' vil eventuelt bli vist hvis bare noen av barna var festet. Cellene kan bli farget i henhold til en eiendomsverdi på tilkoblingene ved å klikke Alternativer 'tannhjulet øverst til høyre i matrisen verktøylinjen og velge Fargeinnstillinger ... og deretter på Rediger-knappen og velge farge ved Stempel eller Colour By Eiendom alternativet og velge en eiendom, min og maks verdi utvalg og velge farger, men bare List, Integer, Desimal, boolsk eller dato / klokkeslett data type eiendommer vil farge. Hvis kollapset cellen vil være farget i henhold til den gjennomsnittlige eiendomsverdi på tilkoblingene. I stedet for en "X", kan egenskapsverdier for cellene bli vist ved å klikke på Options "tannhjulet øverst til høyre i matrisen verktøylinjen og velge Vis Verdi Innstillinger ... og deretter på Rediger-knappen og velge Show eiendommen alternativet og velge en eiendom.

Direkte forbindelser matrise som viser servere hvor Søknader vert med farge og en eiendom blir vist i stedet for den generiske 'X'

- ELLER -

'Indirekte' tilkoblinger matriser

6. Svelgeen sekvens av forbindelse typer og komponenttyperpå høyre og venstre side av menyen som vises hvis du ønsker å se i "celler" i matrisen hvis enn indirekte sti tilkoblede komponenteneeksisterer fra Vertikal/ 'rad'Komponent av matriksen i Horisontal/ 'søyle'Komponent av matriksen.

Notat

Enhver gyldig bane som inneholder elementene valgt i banen menyen will bli vistuavhengig av retningen av de underliggende forbindelsene, men ved valg av banen først og siste elementer velges må være tilkoblingstyper. Videre bestille av de elementene som er valgt er vist med en numerisk prefiksi square ('[]') parentes og en gitt type kan inkluderes utover flere gangeri banen (som indikert ved den numeriske prefiks). Fortløpende utvalg av komponenttyper eller tilkoblingstyper blir tolket som en 'ELLER'sti og hierarkiet av vedlagte komponenter kan eventuelt inkluderes ved å sjekke 'Også søke Vedlegg foreldre / barn'Boksen. Slå Kilde og SynkeKomponenttype valg å vise baner i motsatt retning.

7. Matrisen vil bli befolket med ensti / samling komponenteri cellene hvis det er en sti fra Vertikal/ 'rad'komponent av matriksen i Horisontal/ 'søyle'Komponent av matriksen.

Notat

For store matriser bare maksimalt 100 rader eller kolonner (inkludert kollapset rader / kolonner) vil bli vist på et tidspunkt som vist med 'R' og 'C' indikatorer i øverste venstre tittelcelle hhv. Å vise flere rader bruke rullefeltene. Til enhver tid kan du dobbeltklikke på Vertikal/ 'rad' eller Horizontal / 'søyle' komponent overskrifter og hoppe tilde tilsvarende komponenter i Explorer-vinduet.Foreldrene til Vertical/ 'rad' og Horisontal/ 'søyle' komponents er også eventuelt vist som overskrift rader / kolonner med en grå overskrift tittel. Når kollapset (ved å enkelt klikke overskriften celle) om noen barn veier eksisterte da en "X" vil eventuelt bli vist hvis alle barna var festet eller en 'O' vil eventuelt bli vist hvis bare noen av barna hadde baner. De indirekte banekomponenter kan være farget i henhold til en eiendomsverdi på komponentene ved å klikke på Options "tannhjulet øverst til høyre i matrisen verktøylinjen og velge Fargeinnstillinger ... og deretter på Rediger-knappen og velge farge ved Stempel eller Colour By Eiendom alternativet og velge en eiendom, min og maks verdi utvalg og velge farger, men bare List, Integer, Desimal, boolsk eller dato / klokkeslett data type eiendommer vil farge. Eiendomsverdier for de indirekte sti komponenter kan være vist ved å klikke på Options "tannhjulet øverst til høyre i matrisen verktøylinjen og velge Vis Verdi Innstillinger ... og deretter på Rediger-knappen og velge Show eiendommen alternativet og velge en eiendom.

Indirekte tilkoblinger matrise som viser Søknader som implementerer en gitt tjeneste fra Department

Til filteren Matrix-visning i ABACUS

1. Sørg for at du har en ny Matrix view åpne.

2. Klikk på Filter Akser 'trakt "øverst til høyre i matrisen verktøylinjen.

3. På Source og / eller fanene Sink legge navn, Eiendom, Beskrivelse, hierarki eller Standard filtre ved å klikke på knappen Legg til, velger en eiendom hvis det er nødvendig og klikke OK. Velg de aktuelle alternativene i nøkkelord / punkter panel ved hjelp av logikk / syntaks som beskrevet i notatet nedenfor. Forhåndsvisningspanelet vil automatisk oppdatere vise resultatene av gjeldende sett med filtre.

Notat

Til Tidsstempel, Hierarki Path, Name eller Beskrivelsefiltre eller Tekst, Integer, desimal, boolsk eller Dato tideiendoms filtre matchende utføres som om '*' jokertegn brukes automatisk før og etter eventuelle strengverdier, slik at en oppføring av "katt" (uten anførselstegn) vil inkludere rader med "bobkatt','kattkvinne "eller" appakattion 'etc. Multiple /' eller 'verdier kan legges inn på nye linjer ved hjelp Ctrl + Enter. Til Integer og Desimal eiendoms filtre "og" logikk kan inngå hjelp '&"(Uten anførselstegn) og større enn / mindre enn etc logikk kan inngå bruker '> =','>','<' og '<="(Uten anførselstegn) f.eks '> = 50000 & <90000 ". Non-tomme verdsatte rader kan inkluderes ved å skrive '(Non-Blanks)"(Uten anførselstegn) og Blank verdsatte rader kan inkluderes ved å skrive '(Blanks)"(Uten anførselstegn). Til Standarder eller Liste Eiendommen filtrerer The '(Velg alle) "boksen vil gjøre alle de andre avkrysningsbokser, i effekt inkludert alle tilgjengelige elementer. The '(Non-Blanks) "boksen vil inneholde alle ikke-blank eiendom verdsatt elementer. The '(Blanks) "boksen vil inneholde noen blank eiendom verdsatte elementer. Og fjerne krysset noen spesifikke verdsettes boksene vil automatisk velge bort "(Select All)" og "(ikke-Blanks) 'boksene for konsistens. Og til slutt, alle filtre er som standard små bokstaver så "katt" (uten anførselstegn) vil inkludere elementer med "katt", "Cat" eller "CAT" etc. For store og små bokstaver matching, skriv '(Sak)"(Uten anførselstegn) før strengen f.eks '(Sak) Cat' (uten anførselstegn) ville bare inkludere elementer med "Cat" i dem.

Å fylle ved hjelp av en matrise visning i ABACUS

Notat

Du kan bare legge til / fjerne tilkoblinger der en enkelt tilkoblingstype har blitt brukt til bane beskrevet ovenfor.

1. Til legge en forbindelseav den valgte type mellom en Vertikal/ 'rad'Komponent og en Horisontal/ 'søyle'Komponent av matriksen, hvor en X betyr ikke allerede eksisterer(eller et vist eiendommens verdi - se note ovenfor)Dobbeltklikk på cellen. En «X» skal vises (eller en eiendomsverdi - se note ovenfor) og tilkoblingen vil bli opprettet på øverste nivå i Connections kolleksjon for den valgte Architecture.

Notat

Tilkoblingsnavnet vil være det tilkoblingstype navn som per tilkoblingstype innstilling av matrisen, og hvis en eiendomsverdi blir vist i stedet for en "X" standardverdien for eiendommen vil bli vist.

2. Til redigere et vist eiendomsverdipå sammenhengen mellom a Vertikal/ 'rad'Komponent og en Horisontal/ 'søyle'Komponent av matriksenDobbeltklikk cellen, eller høyreklikke på cellen, og velg Rediger verdi ... og redigere verdien i Change Verdi dialogen.

3. Til fjerne en tilkoblingav den valgte type mellom en Vertikal/ 'rad'Komponent og en Horisontal/ 'søyle'Komponent av matriksen, hvor en "X" eksisterer allerede(eller et vist eiendommens verdi - se note ovenfor), høyre-Klikk på cellenog velg Koble. X skal forsvinne og tilkoblingen vil bli slettet fra prosjektet.

Å redde / lagre som aMatrix view

Notat

Mens alle Arkitekt brukere kan opprette matriser for å redde dem og / eller deres innstillinger brukerlisens må Designer add-on evne. Dette er for å "beskytte" konfigurasjonen av eksisterende Matriser som kan deles av flere brukere. Men bruker Arkitekt uten Designer add-on kan fortsatt velge å "Lagre som" alle nye innstillinger til en ny Matrix. Og selvfølgelig alle brukerlisenser kan velge å "Kast" eventuelle endringer i en eksisterende Matrix. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger Designer add-on evne.Og husk, dette er bare innstillingene for Matrix, alle endringer som er gjort i dataene i Matrix er øyeblikkelig brukt til depotet, uansett.

1. Sørg for at du har en ny Matrix view åpneog du har gjort de nødvendige endringene.

2. I Matrix viewverktøylinje klikk på lengst til venstre Spare Matrixknappen for å lagre Matrix view og eventuelle formateringsendringer.

Notat

Hvis du ikke har en Lagre-knappen på verktøylinjen Matrix visningen så du ikke har Designer add-on, og du er bare i stand til å Lagre somnoen innstillinger endres til en ny matrise når du går for å lukke eksisterende matrise.

3. Hvis de Matrix Navndialogruten som vises (på grunn av at en ny matrise) skriv et navn for matriseog trykk OK.

Til eksport til MS Excel matrise

1. Sørg for at du har en Matrix view åpne.

2. Klikk på Eksporter til Excelknappen på verktøylinjen.

3. Velg et filnavn for å redde MS Excel matrise som. Klikk Spare.

Notat

Som standard er eksportert MS Excel matrise filnavn blir Matrix navn suffikset ved Arkitektur navnet i parentes, for eksempel "Søknader vert på servere (2014 Actual) XLSX '. Du kan endre noe av dette, herunder om filformatet er å være .xlsx eller .xls.

Matrix formateringeksporteres som standard, men for store matriser dette kan resultere i eksporten blir ganske treg. Følgelig, i Verktøy | Alternativer ...deretter på de Matrixtab,du er i stand til å redusere mengden av formatering som eksporteres som vist på Matrix-fanen nedenfor, og dermed påskynde eksport.

Matrix eksport alternativer

4. En Export Fullført dialogboks vises. Klikk OK.

Eksporteres til MS Excel matrise

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Fyller du arkitektur fra Visio | Fyller du arkitektur fra Excel


Fyller Diagrams

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

Fyller Diagrams

Send kommentarer om dette emnet.

Tegninger i ABACUS er mer enn bare vilkårlige representasjoner. De er tilpasset utsikt over arkitektur, formatert og arrangert for å vise spesiell betydning.

Den tegneverktøy håndhever den hierarkiske strukturen i arkitekturen, slik at komponentene er visuelt nestet innenfor andre komponenter - effektivt og gir en "grunnriss" av elementene. Når en komponent eller en forbindelse er definert i arkitekturen, kan den brukes i en rekke forskjellige diagrammer. Viktigere er tegneverktøy nært knyttet til den arkitektoniske modellen, slik at endringer som er gjort i det ene er alltid reflektert i den andre.

Verktøyet fungerer ved å knytte figurer med særlig tilknytning og komponenttypene som er definert i Typer delen av arkitekturen. Disse forbindelser varierer avhengig av typen av diagrammet som blir trukket, og det er mulig at en type av komponent (eller forbindelse) kan ha forskjellige representasjoner i de forskjellige diagrammer, avhengig av sammenhengen.

For å sette opp en forbindelse mellom en form og en komponent eller tilkoblingstype

1. Sørg for at du har en ny eller eksisterende diagram åpen .

2. Maksimer ABACUS søknaden, og konfigurere vindus proporsjoner som du ønsker.

3. Velg Kategorien figurer eller Kontakter tab i sjablongen vinduet.

4. I Typegren av Utforsker finner du komponent eller tilkoblingstype du ønsker å assosiere med en form eller kontakt.

5. Velg den valgte typen element fra treet, dra den over til kategorien figurer eller fane kontakter, og slipp den på formen eller kontaktendu ønsker å bruke.

Notat

Du kan kontrollere en forening du har opprettet ved å velge komponenter eller fanen Tilkoblinger i Stencil vindu som viser de for tiden tilknyttet elementene.

For å legge til nye figurer til din diagrammer / bibliotek

1. Opprett en MS Visio diagram med figurer som du ønsker å legge til din diagram og importere MS Visio diagram .

Tupp

Det er viktig hvilken størrelse du gjør mester form i MS Visio fordi ABACUS lerretet er dimensjonert i piksler og bare Millimeter enheter i MS Visio konvertere granularly å piksler på en 4 piksler til en Millimeter ratio. Videre standard ABACUS figurene er vanligvis 60 piksler høyt, slik at oversettes til 15 millimeter i MS Visio. Betydning en tilrådelig Hoved form størrelse i MS Visio er 25mm bred og 15mm høyda dette vil oversette til 100 piksler bred og 60 piksler høy i ABACUS.

Tupp

Hvis du ønsker å ha en liten "ikonet" i øverste venstre hjørne av en form så kan du bare lage den "ikonet" i master MS Visio form ved hjelp av MS Visio tegneverktøy paletten (merk at bare enkle linjer, sirkler og rektangler støttes og rastrert / bitmap former i særdeleshet støttes ikke). Videre, hvis du vil at ikonet for å være fast i størrelse / målestokki form i ABACUS så kan du gruppen "ikonet" i master MS Visio form ved å velge alle elementene, høyreklikke et element, velger Shape | Gruppe, deretter høyreklikke gruppert form og velge data | Shape data ..., velge Ja i dialogboksen som vises, og deretter legge en eiendom med Label satt til LockScale(legg merke til store bokstaver "L" og "S"), Type satt til Boolean og verdien satt til å være EKTE (merk det er alt i store bokstaver).

Tupp

Hvis du vil ha en del av formen frosset fra skalering horisontalt eller vertikalt (som er typisk med en svømmebane "-form) så kan du høyreklikke på delen (e) av master MS Visio figuren du vil frosset fra skalering og velg Data | Shape data ..., velge Ja i dialogboksen som vises, og deretter legge en eiendom med Label satt til LockXScale eller LockYScale (legg merke til store bokstaver "L" og "S"), Type satt til Boolean og verdien satt til å være EKTE (merk det er alt i store bokstaver), for låst horisontal eller vertikal skalering hhv.

Tupp

Å tillate farging av formen i ABACUS etter import snarere enn form alltid være en fast farge det er tilrådelig å gjøre master MS Visio figurens fill gjennomsiktig og deretter bruke den innebygde evne i ABACUS å farge en form bakgrunn. Dette fungerer bare med rektangel eller nær-rektangel (f.eks avrundet rektangel) figurer som hele rektangulære bakgrunn vil være farget.

2. Åpne tilsvarende diagram og velg Komponenter tabi sjablongen vinduet.

3. For hver ny form som du ønsker å gjøre tilgjengelig for andre diagrammer Høyreklikkformen og velger Legg til figurer Library. Dette vil gjøre formen tilgjengelig i kategorien Figurer i sjablongen vinduet.

4. Knytte den aktuelle komponent type med den nye formen fra Shapes bibliotek i henhold til trinnene som er beskrevet ovenfor.

Notat

Bare enkel og "vektorbaserte" figurer støttes i ABACUS i øyeblikket, dvs. at bitmaps støttes ikke. Imidlertid verktøy som Vector Magic ( www.vectormagic.com ) Er tilgjengelig som vil lett konvertere bitmap bilder til vektorbaserte former (dvs. SVG-format) som kan åpnes i MS Visio og dermed benyttes i ABACUS som per instruksjonene ovenfor.

LeggeKomponenter og tilkoblinger

Tegneverktøyet kan du legge til eksisterende komponenter og forbindelser fra depotet eller skape nye komponenter og tilkoblinger som du tegne et diagram. Som komponenter og forbindelser er opprettet i diagrammene, blir de samtidig tilsatt til oppbevaringssted. Det er tre anbefalte måter å legge til komponenter til et diagramog tre anbefalte måter å legge forbindelser til et diagram:

For å opprette en helt ny komponent eller tilkobling på et diagramfra sjablongen

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Velg Komponenter eller Tilkoblingerfanen i sjablongen vinduet for å se de tilhørende figurer. Bare disse former kan brukes til å skape nye modellelementer.

3. Klikk og draen av de tilgjengelige tilhørende figurer bort på lerret. Det nye elementet vises på lerretet og i explorer treet.

4. Begynn å skriveet navn for den nye element i dialogboksen og eventuelle eksisterende elementer som velges ut er veiledende og kan velges i stedet for å legge til et nytt element til arkitekturen.

5. Klikk OK.

6. Hvis en form som ble dryppet inn i en eksisterende komponent, så vil det enten bli et barn av at komponent (hvis form kom fra Komponentertab), eller vil bli knyttet til denne komponenten (hvis formen kom fra Tilkoblingertab).

Notat

Det er noen ganger nødvendig å justere den nye komponenten eller tilkobling til et annet sted i den arkitektoniske hierarkiet bruker explorer.

Å plassere en eksisterende komponent eller tilkobling fra oppbevaringssted på et diagram

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Vær sikker på at du har både tegneverktøy og Explorer-vinduer vises.

3. I Utforsker finner komponent eller forbindelse(element) du ønsker å legge til diagrammet.

4. Klikk og dradet valgte element på tegningen. En form som representerer elementet vises på lerretet.

Notat

Hvis typen av det valgte elementet er allerede knyttet til en form, vil den tilsvarende formen vises på lerretet. Hvis imidlertid det ikke er definert krets for det aktuelle elementet, vil en standard form (rektangel) vises på lerretet mindre Håndheve Diagram Synspunkter alternativ er på i hvilket tilfelle formen ikke vil bli lagt til tegningen.

Tupp

Når en komponent er plassert på et diagram som er koblet til en annen komponent som allerede er på diagrammet, vil tegneverktøy spørring hvis man ønsker å vise forbindelsen (e) mellom dem. Også, hvis det er noen barn av komponenten tegneverktøyet vil spørre om du ønsker å inkludere barna, på en rekursiv måte.

Til opprette en forbindelse mellom 2 komponenter eller en tilkoblet komponent på et diagram ved hjelp av dynamisk kontakten

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Hover over en komponent på diagrammet som du ønsker å koble til en annen komponent, og du vil merke 2 ikoner vises utenfor øverst til høyre på grensen av formen som vist nedenfor. Merk: Den øverste ikonet er for å skape en sammenheng der svevet komponenten er å være kilden, er den nederste ikonet for å opprette en forbindelse der svevet komponenten er å være vasken.

3. Bevege seg markøren over ønsket ikon og klikk og draikonet til over enten over en annen komponent eller ledig plass på lerretet som vist nedenfor.

4. For å koble til et eksisterende komponent velge Fest til ...elementet i hurtigmenyen, og hvis nødvendig bla til undermenyen for å velge fra de tilgjengelige tilkoblingstyper.

- eller -

4. For å opprette en tilkoblet komponent valgte fra Ny...elementer i menyen og om nødvendig bla til undermenyen for å velge fra de tilgjengelige tilkoblingstypene som vist nedenfor. Begynn å skriveet navn for den nye element i dialogboksen og eventuelle eksisterende elementer som velges ut er veiledende og kan velges i stedet for å legge til et nytt element til arkitekturen.

Notat

Tilgjengeligheten av elementene i menyen og undermenyen er styrt av begrensninger i meta-modellen.Det er bare gyldig kilde eller synke komponenttypene som bestemmes av tilkoblings begrensninger vil bli presentert som Fest til ... og varer New ... meny.

Til re-åpne dialogboksen element valg og plassere eksisterende komponenter eller tilkoblinger fra depotet på et diagram

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Klikk de Åpne Element Selectionknappen i Diagram verktøylinjen. Merk: element dialog utvalg åpnes med det siste av noen filtre lagret.

3. Velg tilleggsinnhold som er ønsket å bli lagt til diagrammet og klikk OK. Merk: det nye innholdet vil bli lagt til klar plass på lerretet og diagrammet kan være i ettertid lagt ut på nytt via Layout Diagramknappen i Diagram verktøylinjen.

Bruke FreeskjemaShapes

Det er ofte ønskelig å skape visuelle elementer i et diagram for rent estetiske grunner. Disse elementene kan bidra til å forbedre utformingen og utseende av et diagram, men de har ikke en streng arkitektonisk betydning. Den tegneverktøy tillater bruk av frihånds former for å gi tegning fleksibilitet.

For å legge til en frihånds form til et diagram

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Velg Shapes eller Kontakterfanen i sjablongen vinduet.

3. Klikk og draen av de tilgjengelige figurer eller kontakter bort på lerret. Det nye elementet vises på lerretet - men ikkei explorer treet.

Notat

Frihånds former er 'non-assosiert' former, som de har ingen tilknytning til noen bestemt komponent eller tilkobling i den arkitektoniske modell.

Til vise repository informasjon i friform formsønnet diagram

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Høyreklikkfreeform form og velg Stempler | Utstilling.

3. Velg å vise enten Diagram Name, Diagram Beskrivelse, Diagram Eiendom, Viewpoint Name eller Arkitektur Name.

Notat

Teksten i freeform vil automatisk oppdatere som de underliggende depotet data endres.På denne måten et diagram 'tittel blokk "kan opprettes for, og deretter enkelt kopieres over, diagrammer.

Bruke Flytende Figurer

Flytende former er i det vesentlige en annen måte å fremstille komponenter i et diagram. Vurdere en organisasjon med viktige divisjoner: CEO, markedsføring, salg og utvikling.

Trevisning

Disse divisjonene kan visuelt representert i en lagdelt måte:

Lagdelt Vis

Eller de kan bli visuelt fremstilt i en forskjøvet / Flytende måte for å vise hierarki:

Forskjøvet / Flytende Utsikt

Sistnevnte fremstilling anvender begrepet flytende former.

Å konvertere en lagdelt komponent form til en flytende form

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Velg komponenti diagrammet du ønsker å representere som en flytende form eller en tilhørende form i KomponenterKategorien av sjablongen vinduet du vil at alle instanser som flytende former.

3. Høyreklikk på form og velg Flyte Component fra kontekstmenyen som vises. Legg merke til diamant ledet tilkoblingfra den overordnede bestanddelen (e) til den flytende komponenten (e).

4. Klikk og drakomponenten til ønsket sted. Når en flytendekomponent velges det vil ha en blå disposisjon.

For å konvertere en flytende komponent form til en lagdelt form

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Velg komponenti diagrammet som for øyeblikket blir vist som en flytende form eller en tilhørende form i KomponenterKategorien av sjablongen vinduet du vil at alle instanser som lagvis former.

3. Klikk og draden flytende komponenten (e) tilbake til moder (e) (i henhold til diamant ledet tilkobling). Merk: Hvis du ikke gjør dette så når du konverterer komponenten (e) tilbake til å være lagdelte hierarkiet av modellen kan bli påvirket.

4. Høyreklikk på form og velg bort Flyte Component fra kontekstmenyen som vises. Legg merke til at diamant ledet tilkoblingfra den overordnede bestanddelen (e) til den flytende komponent (er) vil forsvinne.

Replicas

Tegneverktøyet kan du legge den samme komponenten i et diagram flere ganger med hver visuell forekomst av komponenten på diagrammet referert til som en kopi. Dette er særlig nyttig for diagrammer hvor en komponent som har et stort antall forbindelser som er knyttet til den, og det er å foretrekke for å vise den komponent i flere steder nærmere opprinnelsen av hver av forbindelsene, eller for diagrammer hvor en en-til-mange-relasjon av en komponent er å foretrekke å vise ved hjelp av flytende-funksjonen (beskrevet ovenfor) med komponenten flere plasser på toppen av de "mange" komponenter den er knyttet til.

Notat

Man kan feste / løsne forbindelser til / fra den opprinnelige forekomsten av komponenten på et diagram (som alltid), men også for en hvilken som helst av de kopier, men når forbindelsene blir automatisk innført i et diagram som de er knyttet til den første forekomsten av komponenten på diagrammet som standard.

Notat

Kopier kan bli slått sammen med hverandre ved høyre-klikk og draderetter velge Flett ReplicasMen sammenslåing en replika med en annen komponent vil resultere i noen andre replikaer forsvinner fra diagrammet.

Notat

Det er ingen visuell forskjell mellom den opprinnelige forekomsten av en komponent på et diagram og eventuelle kopier. Videre er høyreklikkmenyen for den opprinnelige komponenten på et diagram og eventuelle kopier identiske, med for eksempel Vis i Utforskertar deg til den samme komponenten i trevisningen av depotet (aka modellen). Men høyreklikke på komponenten i trevisningen av depotet og velge Gå tilog surfing til et diagram med kopier vil alltid ta deg til "eldste" forekomst av komponenten i diagrammet. Typisk vil dette være opprinnelige forekomsten som ble lagt til diagrammet, men hvis det opprinnelige forekomsten ble senere slettet eller slått sammen med en kopi og deretter gå til vil hoppe til den eldste av de gjenværende kopier som ble lagt.

Til legge en kopi til en diagram

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Høyreklikk en eksisterende komponent på diagrammet og velg Lag Replica.En kopi av den valgte komponenten vil bli opprettet til høyre for den opprinnelige komponenten.

- ELLER -

Velg en eksisterende komponent på et diagram og trykk Ctrl + Celler høyreklikk en eksisterende komponent på diagrammet og velg Kopiere. Nå høyreklikk plasseringen på diagrammet som du vil at replika og velg Lim inn som Replica. Merk: Ved å trykke Ctrl + V (eller høyreklikke og velge Paste) vil lage en kopi av den opprinnelige komponenten ikke en kopi.

- ELLER -

Klikk og draen komponent fra trevisningen av depotet (aka modellen) på et diagram hvor komponenten allerede eksisterer.

Konfigurering Connection Caps / Slutter

Tegneverktøyet kan du angir symbolet som brukes ved endene av tilkoblingsledninger enten til en fast symbol eller et symbol er avhengig av en egenskap på selve tilkoblingen.Dette er spesielt nyttig for diagrammer der retning av en tilkobling er nødvendig for å bli vist, eller for diagrammer hvor kardinaliteten for tilkoblingen (eller retning) inngår i en eiendom på selve tilkoblingen, f.eks "En-til-mange" vs "mange-til-mange" (eller "Kilde til Sink" vs "Sink Kilde ').

Til konfigurere tilkoblings caps / slutter et diagram

1. Sørg for at du har en ny eller eksisterende diagram åpen.

2. Velg Kobleionerfanen i sjablongen vinduet.

3. Høyre-cslikke en av assosiert tilkoblingstyper og velge Konfigurer Caps ....

4. For en fast forbindelse cap / slutt på enten kilden eller synke enden av forbindelsen må den aktuelle Fast radioknappen er valgt, og velg deretter tilkoblingen slutten symbol fra rullegardin, f.eks 'Arrow Leder' eller 'Diamond'.

- ELLER -

For en eiendom basert tilkobling cap / slutt på enten kilden eller synke enden av forbindelsen må den aktuelle Bruke Eiendomradioknappen er valgt, og klikk deretter på "..." knappen og velg ønsket eiendommen og deretter ved siden av hver tilkobling slutten symbol inn eiendomsverdier for hvor spesifikk forbindelse symbol skal vises.

Notat

Flere eiendomsverdier for en gitt forbindelse slutten symbol kan føres atskilt med komma.F.eks dialogboksen nedenfor viser at dersom 'Data | Kardinalitet 'Eiendommen har en verdi på "En-til-mange" og deretter kilden enden av forbindelsen vil ha to linjer stryker gjennom det og vasken enden av forbindelsen vil ha en linje slag gjennom det og deretter en fan-ut av to linje slag på slutten.

Konfigurer Caps dialog

Se også

The Drawing Tool | Fyller din arkitektur | Analyse din arkitektur


Fyller din arkitektur

Navigasjon: Fyller ditt arkitektur>

Fyller din arkitektur

Send kommentarer om dette emnet.

Prosessen med å bygge en modell av den arkitektur som er kjent som Fyller. Når du har oppdaget din arkitektur og identifisert dine krav, er du klar til å modellere arkitektur i ABACUS.

Under befolkningen, vil du gå inn alle detaljene du vet om arkitektur og hva som kreves av den.

Hvis du vil fylle din arkitektur

1. Kontroller at du har en ABACUS fil åpen En explorer vises Og en arkitektur lagt .

2. Manuelt befolke på høyere nivå komponenter og tilkoblinger for arkitektur. Typisk vil dette være mer abstrakte komponenter og tilkoblinger.

- eller -

2. Grafisk befolke komponenter og tilkoblinger som du ønsker ha representert skjematisk, ved hjelp av Tegning Tool .

Du kan også være lurt å

3. Befolke bruker Kataloger - Du kan se og komponenter og forbindelser i en enkel tabell måte.

4. Befolke bruker matriser - Du kan vise og redigere tilkoblinger mellom komponenter i en enkel tabell måte.

5. Befolke fra Microsoft Access - Du kan importere en arkitektur fra og eksportere til Microsoft Access.

6. Befolke fra Microsoft Visio - Du kan importere en arkitektur fra og eksportere til Microsoft Visio.

7. Befolke fra Microsoft Excel - Du kan importere en arkitektur fra og eksportere til Microsoft Excel.

8. Befolke fra Microsoft Sharepoint - Du kan importere en arkitektur fra og eksportere til Microsoft SQL Server.

9. Befolke fra Microsoft SQL Server - Du kan importere en arkitektur fra Microsoft SQL Server.

10. Import fra XML - Du kan importere en arkitektur fra en ABACUS XML fragment eller en ArchiMate Interchange Språk XML-fil.

Se også

Fyller din arkitektur manuelt | The Drawing Tool | Fyller du arkitektur fra Microsoft Access | Fyller du arkitektur fra Microsoft Visio | Fyller du arkitektur fra Microsoft Excel


Fyller du arkitektur fra Microsoft Access

Navigasjon: Fyller ditt arkitektur> Fylle fra Microsoft-produkter>

Fyller du arkitektur fra Microsoft Access

Send kommentarer om dette emnet.

Du kan eksportere arkitektur til Microsoft Access til å utføre universal beregninger, manipulasjoner eller rapporter på arkitektur. Du kan deretter importere arkitekturen tilbake i ABACUS.

Notat

The Open fra Access / Eksporter til Database funksjonen krever at Microsoft Access 2000eller nyere er installert på datamaskinen.

Å eksportere arkitektur til Microsoft Access

1. Kontroller at du har en ABACUS filåpen, Explorervist, og en arkitektur la til.

2. Velg Fil | Eksport | Til database.

3. Legg merke til advarselen som beskrevet ovenfor, og klikk Ja for å fortsette.

4. Velg en plassering og et filnavn for databasefilen.

Å importere manipulert arkitektur i ABACUS

1. Kontroller at du har ABACUS åpen.

2. Velg Fil | Ny og velg Fra Accessfra dialogboksen som vises, og klikk på OK.

3. Bla for databasefilen du ønsker å importere.

ABACUS 'MS Access Database Schema

ABACUS har på hjertet sitt enn ontologi / meta-meta-modellen består av komponenter, Tilkoblinger og begrensninger. Denne "CCC" tilnærming ble avledet fra ulike standard tilnærminger utviklet fra 1960-tallet og utover kulminerte i internasjonal standard IEEE 1471, som Avolution grunnleggere bidratt til. Følgende primitiver gjelder;

1. ABACUS inneholder Biblioteker av Standarder(eller Standards), Komponent og Tilkoblingstyper, Begrensninger, Synspunkter, Maler (eller Oppskrifter) og mange Arkitekturer.

2. Standarder, Typer og Synspunkter kanvære logisk Gruppertfor enkelhets skyld.

3. Arkitekturer kan inneholdemange etterkommer Arkitekturer(eller Evolutions).

4. Hver Arkitektur inneholder mange Komponenter og Tilkoblingerav visse Typerog diverse Visninger.

5. Komponenter og Tilkoblinger kan være dekomponeres inn i Delkomponenter og Sub-tilkoblinger.

6. Hver Komponent er festet tilhvilket som helst antall Tilkoblingermen hver Forbindelsekan bare festet tilmaksimalt to Komponenter.

7. Komponenter og Tilkoblinger kan ha Standarder med Egenskaperslik som informasjon, ytelse, pålitelighet, pris etc.

8. Arkitekturer, Komponenter og Tilkoblinger kan ha bestemt Egenskaperslik som informasjon, ytelse, pålitelighet, pris etc.

9. Begrensninger kan eksisterer mellom Komponenter eller Tilkoblinger eller imot Egenskaper.

10. Malerer standard komposisjoner av Komponent og Tilkoblingstyper.

11. Synspunkterer standard sammenslutninger av Komponent og Tilkoblingstypertil notasjoner.

12. Visningerer visuelle representasjoner av Komponenter og Tilkoblinger.

Følgende MS Access Entity Relationship Diagram (ERD) dokumenterer kjerneArkitekturer, Evolutions, Komponent / Tilkoblingstyper (og grupper), Komponenter / Tilkoblinger og Sub komponent / Connection konsepter.

The Core databaseskjema

Notat

Referanseintegritet har ikke blitt håndhevet på forholdet mellom Components bordet og tilkoblinger tabellen (for den "feste" mellom en gitt kilde eller Sink Component og en Connection). Dette er fordi en tilkobling kan eksistere uten komponent vedlegg. Vi kunne ha lagt til en 'vedlegg' bord, men av hensyn til enkelhet besluttet mot det. Selvfølgelig betyr dette at noen redigering av komponent-IDer eller sletting av Component rekker alt sammen vil føre til feil. ABACUS vil håndtere eventuelle uriktigheter på import ved å ignorere de som er feil.

Følgende MS Access ERD dokumenterer Egenskaperkonsepter for arkitekturer, Component / Tilkoblingstyper og Komponenter / Connections.

Egenskaper databaseskjema

Følgende MS Access ERD dokumenterer Standarderkonsept for arkitekturer, Component / Tilkoblingstyper og Komponenter / Connections.Merk: Tabellene fortsatt bruker begrepet "Gjennomføring" som per tidligere versjoner av ABACUS.

Standarder databaseskjema

Følgende MS Access ERD dokumenterer Begrensningerkonsept for Component / Tilkoblingstyper.

Begrensningerdatabaseskjema

Følgende MS Access ERD dokumenterer Synspunkter konsept for Arkitekturer.Merk: Tabellene fortsatt bruker begrepet "TwoDTempl" som per tidligere versjoner av ABACUS.

Synspunkterdatabaseskjema

Følgende MS Access ERD dokumenterer Katalogerkonsept for Arkitekturer.

Katalogerdatabaseskjema

Følgende MS Access ERD dokumenterer Matriserkonsept for Arkitekturer.

Matriserdatabaseskjema

Følgende MS Access ERD dokumenterer Diagrammerkonsept for Arkitekturer.Merk: Tabellene fortsatt bruker begrepet "TwoD" som per tidligere versjoner av ABACUS.

Notat

Component / tilkoblingstype til sjablong form kartlegging og Freeform form deler av MS Access ERD er utelatt for klarhet.

Diagrammerdatabaseskjema

Følgende MS Access ERD dokumenterer 3D-visningerkonsept for Arkitekturer.

3D-visningerdatabaseskjema

Følgende MS Access ERD dokumenterer Diagrammerkonsept for Arkitekturer.

Diagrammerdatabaseskjema

Følgende MS Access ERD dokumenterer Dashbord konsept.

Dashborddatabaseskjema

ABACUS 'MS AccessSpørringer

Følger med MS Access-database er flere nyttige spørsmål som følger;

· Comps etter Props- Dette søket viser alle komponentene i prosjektet (ved arkitektur og type) og omfatter alle de egenskaper som kolonner. Bruk dette søket med filtre / kriterier på komponent type og / eller arkitektur for å produsere "typiske" tabeller for hver komponent type med sine egenskaper.

· Kjønnssykdommer etter Props- Dette søket viser alle standarder som er i bruk, antall forekomster av standard og inneholder alle de egenskapene som kolonner. Bruk dette søket som en standard katalog.

· Props etter Typer- Dette søket viser alle komponent egenskaper og deres% fullført av hver komponent type som kolonner. Bruk denne spørring for å finne ut av hvilke egenskaper blir opprettholdt.

· Typer av Props- Dette søket viser alle komponenttypene og inkluderer% fullført av alle de egenskapene som kolonner. Bruk denne spørring for å finne ut av hvilke egenskaper blir opprettholdt.

· Type Count- Dette søket viser alle komponenttypene og inkluderer antall forekomster av hver type i synkende rekkefølge. Bruk denne spørring for å bestemme populariteten av hver type i prosjektet.

Et notat om arbeidet med Notatfelt i MS Access

Komponentene, Tilkoblinger og standarder navn felt i tabellene er definert som notatfelt for å tillate et ubegrenset antall tegn, som per ABACUS. For de komponenter og tilkoblinger dette fører til noen problemer fordi de har også en unik ID-feltet for å registrere, men for de Standards dette fører til noen problemer når du prøver å bli med tabeller fordi du ikke kan bli med notatfelt i MS Access. Alternativt kan du sette en klausul der kriterier for å oppnå samme effekt som vist i Visual Query Builder og tilsvarende SQL-snutter under den listen ut alle arvet Standards egenskaper for alle komponenter i den eksport ABACUS prosjektet.

Memo feltet 'blir' in Visual Query Builder

VELG Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Fra Components INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) AND (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), implementeringer INNER JOIN ImplementationProperties PÅ Implementations.Id = ImplementationProperties.Implementation_Id

HVOR (((ComponentImplementationLinks.Name) = [implementeringer] [navn]).);

Memo feltet 'blir' i SQL

Et notat på automatisk generering ABACUS IDer i MS Access

Forskjellige ABACUS MS Access tabeller krever en unik ID lang heltall slik at en enkel VB fremgangsmåte er tilveiebrakt for å hjelpe til i dannelsen av disse. To metoder Reset Teller () og GetNextCounter () leveres innen ABACUS 'MS Access DB og deres bruk er som følger; Reset Teller () vil sette disken tilbake til 0. GetNextCounter () vil returnere neste disken i sekvensen.

Metodene utnytte en MS Access 'innfall' at selv om du kaller Reset Teller () -metoden for hver rad innsats (dvs. når du også kjøre GetNextCounter () -funksjonen) fordi Reset Teller () -funksjonen har ikke noen parametere det bare renner det en gang og derfor ikke nullstille telleren for hver rad innsats. Og også på grunn av den samme "innfall" du har noen gamle kolonne variabel å passere til GetNextCounter () -funksjonen til å lure den til å kjøre hver gang.

Det er også et triks for å være i stand til å kjøre Reset Teller () -funksjonen i et innstikk i SQL-setning fordi du ikke bare ha det sitter der som en kolonne av seg selv, som om det var en velger søket. Det anbefales å gjøre Reset Teller () kaller en del av en av de andre feltene, ved å sette sammen den til slutt, som det alltid returnerer null uansett.

Nedenfor er en typisk SQL bruk av metoder for å legge til en liste over komponenttyper fra en tabell / spørring kalt "Component Type List".

INSERT INTOComponentTypes (Id, Navn, Beskrivelse)

VELG GetNextCounter ([Component Type Liste] .name)AS Id, [Component Type Liste] .name AS navn, [Component Type Liste] .description & Reset Teller ()AS Beskrivelse

FRA[Component Type List];

ABACUS ID / Counter generasjon i SQL

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Fyller du arkitektur fra Visio | Fyller du arkitektur fra Excel


Fyller du arkitektur fra Microsoft Excel

Navigasjon: Fyller ditt arkitektur> Fylle fra Microsoft-produkter>

Fyller du arkitektur fra Microsoft Excel

Send kommentarer om dette emnet.

Du kan importere din arkitektur fra et Excel-regneark (.xls eller XLSX fil). Excel-importøren lar deg kartlegge lister over komponent og forbindelser med typer, standarder, egenskaper og standard egenskaper ved å velge kolonnene i regnearket som inneholder relevante data.Det er imidlertid en mer avansert teknikk enn anbefalt tilnærmingfor import fra MS Excel som er via kataloger som beskrevet her .

Notat

Import fra / Eksporter til Excel-funksjonen krever at Microsoft Excel 2003eller nyere er installert på datamaskinen.

Den viktigste funksjonen til Excel Importør er å tillate deg å definere en konfigurasjonsfil (dvs. den hierarkiske strukturen i arkitektmodellen). Konfigurasjonsfilen lagres en tidligere lagret kartlegging fra en Excel-fil til en ABACUS fil. Når definert, er den lagrede konfigurasjonsfilen senere brukt for ytterligere import av og eksport til XLS-filer.

Notat

Trinnene vist i punktene nedenfor er spesielt for brukere som har ennå til å definere og lagre en konfigurasjonsfil og importerer fra excel for første gang. Du må opprette og lagre en konfigurasjonsfil å bruke eksport til excel funksjonen.

Slik importerer en Excel-regneark i ABACUS

1. Kontroller at du har ABACUS åpen.

2. Velg Fil | Ny og velg Fra Excelfra dialogboksen som vises, og klikk på OK.

Notat

Hvis du ønsker å importere til en eksisterende ABACUS prosjekt da enten høyreklikker Components node innenfor en Architecture, eller høyreklikker en individuell komponent i et Arkitektur og deretter velger du Importer | Fra Excel.

3. De Import Excel regnearkvindu vises

Import Excel regneark Window

4. Klikk på Åpne Excel-filikon og bla for Excel-filen du ønsker å importere.

5. Velg Regnearkdu ønsker å importere fra rullegardinlisten.

Notat

Etter å ha åpnet Excel-filen, kan du bruke Data Previewfanen for å vise kolonner og første 25 radene i regnearket. Herfra kan du få kolonnenumrene som trengs for å fylle ut Komponenter og Tilkoblingertab.

Du kan også velge om du vil ha komponenter i et excel regneark til å bli importert med store og små bokstaver. Bare å huke av Import med små bokstaveralternativ (som standard er dette alltid krysset) og regnearket vil bli importert tilsvarende.

Eksempel Excel-fil

Notat

I dette eksempelet vil vi importere en enkel Infrastruktur og Folk Architecture fra Excel-data vist i skjermbildet over. Tilkoblinger vil bli gjort mellom "ansvarlige" og "Servers" at disse menneskene administrerer.

Å fylle fanen Komponenter

Denne delen er for å definere komponenttypene og hierarkisk struktur for konfigurasjonsfilen.

1. Velg Komponentertab. Gi nytt navn til Set IDved å overstyre (null) verdi

Notat

Denne funksjonen gjør at du kan definere helt annet Stillerfor funksjonelt separate komponenter. Som vist i skjermbildet nedenfor, kan det være lurt å skille dine infrastrukturkomponenter fra People komponenter. Hvis det er forhold (tilkoblinger) mellom disse separate sett av komponenter, kan de bli definert i henhold til Tilkoblingertab. Senere i dette eksempelet vil vi definere tilkoblinger av type "forvalter" mellom Infrastruktur og People Stiller.

Du kan også velge om du vil legge til en topp-nivå Grupperingkomponent for alle elementene i settet. Bare å huke av Gruppe Under Set IDalternativet (som standard er dette merket av), og regnearket vil bli importert tilsvarende.

Tildele Set ID

2. Når StillerDet er definert velge Settdu ønsker å befolke og utvide ved å klikke på [+] skilt.

3. Velge Nivåene av komponenter i dette settetfra den utvidede listen.

4. De Component Hierarki Stiller: Set IDvindu vil vises for at Sett.

Component Hierarki og tilordner verdier (Set ID: Infrastruktur)

5. Gi nytt navn til Nivå Antallkolonne ved å overstyre (null) verdi.

Notat

De Nivå Antallkolonne lar deg tilordne et hierarki til komponentene. Hvert nivå tilsvarer et lag i en arkitektur hvor det første nivået er den øverste forelder nivå. For eksempel Nivå nummer "1" tilsvarer det øverste hierarkiske lag, Level nummer "2" er barn av nivå nummer "1" og så videre.

6. Velg og tildele den aktuelle kolonnen fra Excel regneark til hver Nivå Antallved å taste den under Komponent Kolonne søyle.

Notat

Du kan velge å ekskludere visse rader som du ikke ønsker å være representert i arkitekturen. Disse kan være kolonneoverskriftene, tomme rader, etc. For å utelukke rader bruke Rader å utelukke:tekstboksen øverst til høyre i vinduet. I dette eksempelet har vi utelatt rad 1 fordi det inneholder våre kolonneoverskriftene.

7. Du kan velge å legge til beskrivelser til komponentene ved å overskrive (null)verdi i Beskrivelse Column.

Notat

Denne beskrivelsen er hva som vil dukke opp i ABACUS under Generelle egenskaper§ | Beskrivelsefeltet.

8. Hvis en gitt regneark kolonne har mer enn én komponent per celle (inn med Alt-Enter eller CHAR (10) kommandoen), kryss av i boksen under Behandle nye linjer som separate komponenter. Hver linje vil bli importert som separate komponenter.

Tupp

For å importere en "matrise" fra en samling av søyler, der en "X" i en gitt "matrix" celle (cellene B2: D2 si) innebærer at komponenten som er angitt av raden (i celle A2 si) er koplet til komponenten spesifisert av kolonnen 'overskriften' (i rad en si), kan en enkel formel brukes. Skriv inn følgende formel for hver rad i en kolonne utover matriseceller (kolonne F si); = HVIS (B2 = "", "", B $ 1 & CHAR (10)) og IF (C2 = "", "", C $ 1 & CHAR (10)) og IF (D2 = "", "", D $ 1 & CHAR (10)). Deretter sette opp en forbindelse satt som beskrevet nedenfor mellom komponentene er spesifisert av rad (i kolonne A si) og de beskrevet av denne formelen (i kolonne F si). Husk å sjekke Behandle nye linjer som separate komponenteralternativet når komponentene fra formelen er importert. For mer avansert matrise import, inkludert overskrifter med flere lag av hierarki eller celler med ulike verdier enn bare en vanlig "X", kan du kontakte Avolution Support .

9. Fyll i resten av kolonnene etter behov.

Notat

Du kan velge å få den type fra radene kolonne ved å krysse av i boksen under Få Type Fra Columnkolonne og skrive inn den aktuelle kolonnen fra Excel regneark under Component Type Verdi eller kolonne søyle. Dette vil importere alle komponentene i denne kolonnen, og sette dem til den type som er angitt i kolonnen. Alternativt, og som med skjermbildet over og under, du kan velge å bruke en fast / pre-definerte typenavnet ved å skrive den type navn under Component Type Verdi eller kolonnekolonne og gjør at avmerkingsboksen er un-kontrollert.

Component Hierarki og tilordner verdier (Set ID: People)

Notat

I dette eksempelet ønsker vi å ha våre nettverk og mennesker grupperinger på nivå 1 av Architecture. På nivå 2 ønsker vi å ha våre servere og folk som er ansvarlige for å administrere disse serverne. De KomponenterKategorien har blitt fylt ut tilsvarende, som vist i de to skjermbilder over. I det første skjermbildet ovenfor har vi definert nivå 1 (nettverks gruppering) og nivå 2 (server) komponenter for Infrastruktur Sett. Og i skjermbildet umiddelbart over vi har definert nivå 1 (folk gruppering) og nivå 2 (personer som er ansvarlige) komponenter for the People Sett.

Alternativt, for MenneskerSet, heller enn å bruke kolonne C som et folk gruppering, vi kunne ha brukt Gruppe Under Set IDalternativ på toppnivå komponenter -fanen og deretter bare inn ett folk sub-nivå fra kolonne D. Dette er vist i skjermbildet nedenfor.

Component Hierarki og tilordne verdier ved hjelp av gruppe Under Set ID alternativ (Set ID: People)

10. Når komponentene har blitt identifisert, velger du komponentnivå du ønsker å fylle egenskaper og / eller standarder for og utvide ved å klikke på [+] skilt.

11. Velge Egenskapene til komponenter på dette nivået eller Komponent Standarder på dette nivåetfra den utvidede listen og fylle de aktuelle kolonnene etter behov.

Fyller Components

Notat

Egenskapene til komponenter på dette nivåetkan du definere egenskaper for komponenter på valgt nivå. Komponent Standarder på dette nivåetlar deg definere standarder og deres standard egenskaper for komponenter på valgt nivå.

12. Gjenta trinn 2-11inntil alle komponent nivåer har vært befolket for alle definert Stiller. Bruk tilbakepilen øverst i høyre hjørne av vinduet for å navigere tilbake til Stillersom du definerte tidligere.

Å fylle kategorien Tilkoblinger

Denne delen er for å definere tilkoblingstypene og den hierarkiske strukturen for konfigurasjonsfilen.

1. Velg Tilkoblingertab. For hvert sett av tilkoblinger du har til å identifisere den komponenten Settat du ønsker å være kilde komponenter og komponent Settdu ønsker å være målet komponenter.

2. Under Kilde Component Set IDangi Settnavn som tilsvarer Settdefinert tidligere i Komponentertab. Under Kilde komponentnivå Antalltaste inn nummeret som tilsvarer komponentnivå du ønsker å koble på kilden enden av forbindelsen.

3. Nå velger hvilken komponent gruppen vil være på bestemmelses enden av forbindelsen. Under Destinasjon Component Set IDangi Settnavn som tilsvarer Settdefinert i Komponentertab. Under Destinasjon komponentnivå Antalltaste inn nummeret som tilsvarer komponentnivå du ønsker å koble på destinasjonen enden av forbindelsen.

Notat

I dette eksempelet ønsker vi å koble de ansvarlige for å administrere servere til serverne som de administrerer. De ansvarlige ble definert i Folke Settsom nivå 2 komponenter mens serverne ble definert i infrastruktur Settsom nivå 2 komponenter. De TilkoblingerKategorien har blitt fylt ut tilsvarende, som vist i skjermbildet nedenfor.

Tab-tilkoblinger del 1 av 2

4. Hvis du blar til høyre, vil du finne ekstra muligheter for å importere dine forbindelser. Få Type Fra Column og Connection Type Verdi eller kolonnefungerer på samme måte som for Komponentertab.

5. Dersom Kilde Component Set ID og Kilde komponentnivå Antaller de samme som den Destinasjon Component Set ID og Destinasjon komponentnivå Antall(for eksempel hvis du kobler de samme komponenttypene, som gjør tilkoblinger fra servere til andre servere) så må du ha en annen kolonne i regnearket som inneholder navnene på disse serverne gjentatte. I denne situasjonen vil du sette det regneark kolonne i Destinasjon Gjentatte i kolonne søyle. Hvis det i det regne kolonnen har du tastet inn mer enn én tilkoblede komponenten per celle, kryss av i boksen under Behandle nye linjer som separate komponenter.

Tab-tilkoblinger Del 2 av 2

6. Når tilkoblinger er identifisert velge tilkoblingen du vil fylle eiendommene og / eller standarder for og utvide ved å klikke på [+] skilt.

7. Velge Egenskaper for disse tilkoblingene eller Standarder for disse tilkoblingenefra den utvidede listen og fylle de aktuelle kolonnene etter behov.

Notat

Egenskaper for disse tilkoblingenelar deg definere egenskaper for tilkoblingen gruppen valgt. Standarder for disse tilkoblingenelar deg definere standarder og deres standard egenskaper for mellomgruppen valgt.

8. Gjenta trinn 2 - 7inntil alle tilkoblings gruppene er definert.

9. Når du er ferdig med å definere tilkoblingsgrupper, klikk på Finishknappen og arkitektur vil bli opprettet fra den importerte Excel-filen. Eksempelet ovenfor vil resultere i arkitekturen vist i skjermbildet nedenfor.

Eksempel Arkitektur Importert fra Excel

10. Nå lagre kartlagt konfigurasjonen til en fil ved å klikke på Lagre konfigurasjon ikon. Din lagret konfigurasjon kan hentes senere ved å klikke på Åpne en konfigurasjonsikonet øverst i venstre hjørne av vinduet.

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Fyller du arkitektur fra Access | Fyller du arkitektur fra Visio


Fyller du arkitektur fra Microsoft Sharepoint

Navigasjon: Fyller ditt arkitektur> Fylle fra Microsoft-produkter>

Fyller du arkitektur fra Microsoft Sharepoint

Send kommentarer om dette emnet.

Du kan synkron din arkitektur medMicrosoft Sharepoint-lister. Synkronisering innebærer enten lage nye Sharepoint-lister (og deres kolonner) fra ABACUS typer, deres egenskaper og vedlegg, eller kartlegge eksisterende Sharepoint-lister (og deres kolonner) i Abacus typer, deres egenskaper og vedlegg, og deretter enten å sende innhold fra ABACUS til Sharepoint eller Sharepoint til ABACUS.

Notat

De Sharepoint Sync funksjonen krever at en Microsoft Sharepoint 2010 2013 eller Sharepoint Online Siden er tilgjengelig for å koble til og synkronisere med.Mens Sharepoint Sync-funksjonen kan lage lister (med kolonner) på et Sharepoint-område fra noen ABACUS prosjektet, kan Avolution også gi ulike Sharepoint nettsted maler til støtte for standard rammeverk (f.eks TOGAF, ArchiMate, ITIL etc), så ta kontakt Avolution Support hvis du trenger denne evnen.

Til opprette en ny Sharepoint-liste og kartlegge den til en ABACUS komponent eller tilkoblingstype

1. Kontroller at du har ABACUS åpen.

2. Velge Verktøy | Sharepoint Sync.

3. Klikk på New Mappingknappen og en Sharepoint Mapping dialogboks som vist nedenfor vises.

4. Skriv inn nettadressen, brukernavn og passord for Sharepoint-området, og klikk Koble.

Notat

En gyldig Sharepoint "admin" eller "bidragsyteren 'konto for å synkronisere fra og til Sharepoint og en" leser "kontoen vil bare tillate synkronisering fra Sharepoint.

5. Velg ABACUS komponent eller tilkoblingstype for å kartlegge fra Velg Type trekk ned.

6. Klikk på Legg til nyknappen og deretter for hvert ABACUS komponent eller tilkoblingstype aspekt du ønsker å kartlegge en tilsvarende Sharepoint-listefelt velge et element i panelet til venstre og i høyre panel angi det nye Sharepoint-liste navn i New List kolonne (kun første gang) Da Sharepoint kolonnenavnet i Kolonnenavn (eller bruk standard), og klikk Tildele hver gang.

Notat

Som et minimum for å tillate synkronisering ABACUS EEID, arkitektur og navn aspekter vil automatisk bli koblet til en Sharepoint-nummer og to (2) Enkelttekstlinje (aka tekst) kolonner hhv. Disse kan ikke være tilordnet. Videre kan bare visse ABACUS aspekter tiden tilordnes bestemte Sharepoint kolonner og kolonnen Type rullegardin vil automatisk bli satt til den nødvendige Sharepoint kolonnetype.Nemlig;

· ABACUS 'Hierarki Sti til Sharepoint flere linjer med tekst (aka Note) kolonner (Merk: Sharepoint enkelt tekstlinje (aka Tekst) kolonner støtter bare 255 tegn, så de er ikke foretrukket),

· ABACUS 'Vedlagte Komponenter til Sharepoint Oppslag kolonner (Merk: En kartlegging må allerede finnes på en liste for de vedlagte komponenter selv),

· ABACUS 'Tekst og beskrivelse egenskapene til Sharepoint flere linjer med tekst (aka Note) kolonner (Merk: Sharepoint enkelt tekstlinje (aka Tekst) kolonner støtter bare 255 tegn, så de er ikke foretrukket),

· ABACUS 'desimal eller Integer egenskapene til Sharepoint Antall kolonner,

· ABACUS 'List eiendommer til Sharepoint Choice kolonner (Merk: Sharepoint ikke håndheve valget verdiene slik listedatatypen trenger ikke å bli håndhevet i ABACUS),

· ABACUS 'dato / klokkeslett egenskapene til Sharepoint flere linjer med tekst (aka Note) kolonner (Merk: Sharepoint dato og klokkeslett kolonner kan ikke brukes som ennå på grunn av Sharepoint er inkonsekvent støtte for tidssoner / regionaliserings innstillinger),

· ABACUS 'Boolske egenskaper til Sharepoint Ja / Nei (aka boolsk) kolonner.

En ABACUS elementets Associated Standards kan ikke tilordnes til Sharepoint-liste kolonner som ennå.

7. Velge Lag Mapping.

Til opprette en ny tilordning mellom en ABACUS komponent eller tilkoblingstype og en eksisterende Sharepoint-liste

1. Kontroller at du har ABACUS åpen.

2. Velge Verktøy | Sharepoint Sync.

3. Klikk på New Mappingknappen og en Sharepoint Mapping dialogboks som vist nedenfor vises.

4. Skriv inn nettadressen, brukernavn og passord for Sharepoint-området, og klikk Koble.

Notat

En gyldig Sharepoint "admin" eller "bidragsyteren 'konto for å synkronisere fra og til Sharepoint og en" leser "kontoen vil bare tillate synkronisering fra Sharepoint.

5. Velg ABACUS komponent eller tilkoblingstype for å kartlegge fra Velg Type trekk ned.

6. Velg Sharepoint-området listen for å kartlegge fra Velg Liste trekk ned.

7. For hver ABACUS komponent eller tilkoblingstype aspekt du ønsker å kartlegge til den tilsvarende Sharepoint-liste kolonne velge et element i panelet til venstre og høyre panel henhold og klikk Tildele.

Notat

Som et minimum for å tillate synkronisering ABACUS EEID, arkitektur og navn aspekter må kartlegges til et Sharepoint nummer og deretter for arkitektur og navn til enten enkelt tekstlinje (aka Tekst) eller flere linjer med tekst (aka Note) kolonner hhv. Inntil det er gjort Opprett Mapping knappen vil ikke bli aktivert. Videre kan bare visse ABACUS aspekter tiden tilordnes til visse Sharepoint kolonner.Nemlig;

· ABACUS 'Arkitektur aspekt til et Sharepoint enkelt tekstlinje (aka Tekst) eller flere linjer med tekst (aka Note) kolonner (dette er nødvendig for innhold spesifikk kartlegging som beskrevet nedenfor),

· ABACUS 'Hierarki Sti til Sharepoint enkelt tekstlinje (aka Tekst) eller flere linjer med tekst (aka Note) kolonner (Merk: Sharepoint enkelt tekstlinje (aka Text) kolonner støtter bare 255 chars så noen flere tegn vil bli avkortet, og derfor anbefales det å konvertere dem til flere linjer med tekst (aka Note) kolonner i Sharepoint før mapping),

· ABACUS 'Vedlagte Komponenter til Sharepoint Oppslag kolonner (Merk: En kartlegging må allerede finnes på en liste for de vedlagte komponenter selv),

· ABACUS 'Tekst og beskrivelse egenskapene til Sharepoint enkelt tekstlinje (aka Tekst) eller flere linjer med tekst (aka Note) kolonner (Merk: Sharepoint enkelt tekstlinje (aka Text) kolonner støtter bare 255 chars så noen flere tegn vil bli avkortet og derfor anbefales det å konvertere dem til flere linjer med tekst (aka Note) kolonner i Sharepoint før mapping),

· ABACUS 'desimal eller Integer egenskapene til Sharepoint Antall kolonner (Merk:. Sharepoint Beregnet kolonner kan brukes, men de vil bare være i stand til å synkroniseres fra Sharepoint til ABACUS Prøver å synkronisere "til" en beregnet kolonne vil resultere i en advarsel som per nedenfor) ,

· ABACUS 'liste egenskaper til Sharepoint Choice kolonner,

· ABACUS 'dato / klokkeslett egenskapene til Sharepoint flere linjer med tekst (aka Note) kolonner (Merk: Sharepoint dato og klokkeslett kolonner kan ikke brukes på grunn av Sharepoint er inkonsekvent støtte for tidssoner / regionaliserings innstillinger),

· ABACUS 'Boolske egenskaper til Sharepoint Ja / Nei (aka boolsk) kolonner.

En ABACUS elementets Associated Standards kan ikke tilordnes til Sharepoint-liste kolonner som ennå. Og Sharepoint valuta, person eller gruppe, link eller bilde, Task Outcome, eksterne data og Managed Metadata kolonner kan ikke tilordnes til ABACUS aspekter som ennå.

8. Velge Lag Mapping.

Til synkronMicrosoft Sharepoint-liste (s)i ABACUS

1. Kontroller at du har ABACUS åpen.

2. Velge Verktøy | Sharepoint Sync.

Notat

Til synkronisere en Sharepoint-liste med enABACUS prosjekt brukerlisensen må Sharepoint Syncadd-on evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

3. Velg en eksisterende Sharepoint-kartlegging (eller kartlegginger hjelp Ctrl-klikk eller Velg alleknappen) fra Sharepoint Kartleggingerpanelsom vist i prøven skjermbilde over. Merk: her viser vi bare "Goal (eller Krav) 'ABACUS komponenttypen kartlegging til en Sharepoint-liste kalt mål å bli valgt.

4. Velg Architecture (e) du ønsker å synkronisere innhold med fra Synkroniser Innhold fra arkitekturerpanel som vist i prøven skjermbilde over. Merk: her viser vi bare "2015 Actual 'arkitektur synkroniseres.

5. Velg Sync From SP knapp.

Notat

Hvis Sharepoint-området legitimasjon er ikke "All Lagret 'for kartleggingen (e) valgt deretter et Pålogging til dialog Sharepoint som ber for Side URL, Brukernavn og / eller Passord.Fyll inn disse. Videre vil synkronisering inkludere eventuelle andre kartlegginger som er nødvendige for tilkoblede komponenter / oppslags kolonner. Eventuelle ytterligere kartlegginger som automatisk følger vil bli vist i dialogboksen som vist nedenfor.

6. Ved vellykket synkronisering et Sharepoint-Sync Results får opp dialogboksen som vist nedenfor liste opp endringene og eventuelle advarsler. Klikk OK.

Til synkronisere fra ABACUS til Microsoft Sharepoint-liste (s)

1. Kontroller at du har ABACUS åpen.

2. Velge Verktøy | Sharepoint Sync.

Notat

Til synkronisere en Sharepoint-liste med enABACUS prosjekt brukerlisensen må Sharepoint Syncadd-on evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

3. Velg en eksisterende Sharepoint-kartlegging (eller kartlegginger hjelp Ctrl-klikk eller Velg alleknappen) fra Sharepoint Kartleggingerpanelsom vist i prøven skjermbilde over. Merk: her viser vi bare "Goal (eller Krav) 'ABACUS komponenttypen kartlegging til en Sharepoint-liste kalt mål å bli valgt.

4. Velg Architecture (e) du ønsker å synkronisere innhold med fra Synkroniser Innhold fra arkitekturerpanel som vist i prøven skjermbilde over. Merk: her viser vi bare "2015 Actual 'arkitektur synkroniseres.

5. Velg Sync Å SP knapp.

Notat

Hvis Sharepoint-området legitimasjon er ikke "All Lagret 'for kartleggingen (e) valgt deretter et Pålogging til dialog Sharepoint som ber for Side URL, Brukernavn og / eller Passord.Fyll inn disse. Videre vil synkronisering inkludere eventuelle andre kartlegginger som er nødvendige for tilkoblede komponenter / oppslags kolonner. Eventuelle ytterligere kartlegginger som automatisk følger vil bli vist i dialogboksen som vist nedenfor.

6. Ved vellykket synkronisering et Sharepoint-Sync Results får opp dialogboksen som vist nedenfor liste opp endringene og eventuelle advarsler. Klikk OK.

Notat

ABACUS vil oppdatere Sharepoint kolonner med tomme verdier selv om Krev at denne kolonnen inneholder informasjon 'er satt til Ja i Sharepoint. Dette er fordi Sharepoint ikke utsetter denne innstillingen eksternt. Hvis dette skal forebygges, anbefales det at en ABACUS Designer setter Nødvendig begrensningen til True og håndheves for gitt eiendommen ved hjelp ABACUS ' begrensning trekk .

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Fyller du arkitektur fra Visio | Fyller du arkitektur fra Excel


Fyller du arkitektur fra Microsoft SQL Server

Navigasjon: Fyller ditt arkitektur> Fylle fra Microsoft-produkter>

Fyller du arkitektur fra Microsoft SQL Server

Send kommentarer om dette emnet.

Du kan importere din arkitektur fra en Microsoft SQL Server-database. Du har valget mellom å bare importere Tabeller og relasjoner effektivt importerer bare den generiske strukturen i databasen eller tabeller, rader og relasjoner som vil importere ikke bare strukturen men dataene også.

Notat

Fra SQL Server funksjonen krever at Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014er installert på datamaskinen.

Slik importerer du din Microsoft SQL Server-database til ABACUS

1. Kontroller at du har ABACUS åpen.

2. Velg Fil | Ny og velg Fra SQL Serverfra dialogboksen som vises, og klikk på OK.

3. I Import SQL dialog Server som vises sette 'maskin' og 'SQLINSTANCE' verdier av Connection String variable og 'DBNAME' verdien av Database Name variabelen til sine riktige verdier som vist i eksempelet skjermbildet nedenfor.

4. Sett Database Name variabelen til samme verdi som Initial Catalog variabel satt i trinnet ovenfor, som vist i eksempelet skjermbildet nedenfor.

5. Trykk på knappen Test Connection og tabellene som skal importeres i dialogen bør fylles med de tilgjengelige databasetabeller, som vist i eksempelet skjermbildet nedenfor.

6. Velg tabellene som du ønsker å importere ved enten enkeltvis velge dem eller bruke Alle, Ingen og Inverter knappene til høyre i dialogboksen.

Notat

Bare Utenlandske viktige relasjoner som eksisterer mellom tabellene som du velger vil bli importert.

7. Velg om du vil importere bare tabellene og relasjonene mellom dem eller tabellene, deres Rader og de spesifikke relasjoner mellom radene ved hjelp av Import stil radioknappen.

Notat

Det første alternativet importerer tabellene som komponenter av typen «Tabell» og relasjoner mellom to tabeller (fra de utenlandske nøkler) importeres som forbindelser av typen "Table Relation". Dette er en klassisk "ERD 'stil visning av systemtabeller. Det andre alternativet importerer tabellrader som diskrete delkomponenter av typen 'Table Row "med egenskaper som svarer til hver av de kolonner / felt og med relasjoner mellom tabellrader av typen' Table Relation". Videre, hvis det er en kolonne / felt kalt 'Navn' da dette brukes til å navngi de enkelte Table Row delkomponenter.

8. Velg Import ... knappen.

9. Etter en kort tid (med en fremdriftslinje for tilbakemeldinger) en ny ABACUS prosjektet vil bli opprettet med tabeller, tabellrader (hvis det andre alternativet ble valgt i trinn over) og relasjoner fra Microsoft SQL Server-database.

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Fyller du arkitektur fra Visio | Fyller du arkitektur fra Excel


Fyller du arkitektur fra Microsoft Visio

Navigasjon: Fyller ditt arkitektur> Fylle fra Microsoft-produkter>

Fyller du arkitektur fra Microsoft Visio

Send kommentarer om dette emnet.

Du kan importere din arkitektur fra Microsoft Visio. Figurer i Visio tegningen vil bli importert som komponenter i ABACUS. Tilkoblinger i din Visio tegningen vil bli importert som tilkoblinger og tegningen i seg selv vil bli importert til ABACUS som et diagram. Videre vil eventuelle Custom Properties i Visio tegningen bli importert som eiendommer med Sort Key kartlagt til Eiendomstype, Etikett til Property navn og verdien til boligens verdi.

Notat

Import fra Visio funksjonen krever at Microsoft Visio 2003eller nyere er installert på datamaskinen.

Å importere Visio-tegninger i ABACUS

1. Kontroller at du har ABACUS åpen.

2. Velg Fil | Ny og velg Fra Visiofra dialogboksen som vises, og klikk på OK.

Notat

Hvis du ønsker å importere til en eksisterende ABACUS prosjekt da enten høyreklikker Components node innenfor en Architecture, eller høyreklikker en individuell komponent i et Arkitektur og deretter velger du Importer | Fra Visio.

3. Bla for Visio-filen du ønsker å importere.

Notat

Nedenfor er noen enkle regler eller anbefalt praksis når bygging (eller modifisere) en MS Visio-tegning for import til ABACUS.

1. Linjene eller tilkoblinger må være reelle kontakter, IKKE former.

· Ellers ABACUS vil bare importere dem som komponenter og følgelig vil de ikke bli "festet" til noe.

· Hvis du trenger å gjøre noe "smart" routing (dvs. annet enn en rett linje) bruker deretter Dynamic kontakten på Basic Shapes sjablongen vil ABACUS importere ruting / ankerpunktene fine.

· Prøv å unngå å bruke "Ring nettverk" og "Ethernet" figurer fra nettverket og eksterne enheter sjablong som gjør at mange komponenter som skal "koblet" til det. Mens vi importere vedlegg fin som tilkoblinger den opprinnelige formen er fortsatt "utvidet" for å reflektere vedleggene. Bruk skille en egen "hub / buss" form (uten kontakten "ben") og deretter eksplisitt koble hver komponent til huben / buss med separate kontakter.

· Hvis en linje eller tilkobling oppfører seg som en form, høyreklikk på den og gå til "Format | Oppførsel ... "og sørge for at Interaksjon stil er satt til linjen (en-dimensjonal).

2. Komponentene må være figurer IKKE kontakter.

· Ellers ABACUS vil bare importere dem som tilkoblinger og følgelig all form, går tapt.

· Hvis en komponent oppfører seg som en kontakt, høyreklikk på den og gå til "Format | Atferd ... "og sørge for at Interaksjon stil er satt til Box (to-dimensjonal).

3. Connector endene må være knyttet til former, ikke flyter rundt i bakgrunnen bak formen.

· Hvis du ikke kobler kontaktene til figurene så ABACUS har ingen måte å vite at du hadde tenkt å feste den gitte kontakten til form / komponent og følgelig vil det etterlate at enden av forbindelsen un-festet.

4. Etiketter til figurer skal være (om mulig) den innebygde tekst etikett for formen, ikke en egen tekstboks på tegningen.

· Separate tekstbokser vil bli importert av ABACUS som komponenter i sin egen rett, og mens du kan flette "label" komponent med den virkelige komponenten i ABACUS, eller bare konvertere "label" komponent til en freeform form (dvs. ikke en komponent i seg selv) det er best å unngå disse trinnene.

5. Bruk samme basen form for hver forekomst av samme type, ikke være lat og bruke rektangel noen ganger og boksen andre fra forskjellige form sjablonger.

· ABACUS bruker basen form og sin base farge for å identifisere komponent og tilkoblingstyper i tegningen så en "rød firkant" og en "rød boks" vil bli importert som to separate komponenttypene. Disse komponenttypene kan flettes i ABACUS, men det er best å unngå disse trinnene.

6. Wholly kapsle "barn" figurer innenfor sine "foreldre", ikke la dem henge over kanten.

· ABACUS vil oppdage eventuelle form som er helt innkapslet i en annen form som et barn av foreldre så sørg for at hele formen, inkludert etiketten del, er vedlagt.

7. IKKE plasser en form overlappende to andre figurer.

· Hvis en form lapper to andre former, det være seg en "gruppering" / bakgrunn rektangel eller på annen måte, vil det bli importert av ABACUS som en komponent som er et barn av verken overlappende figurer, men så snart du velge komponenten i ABACUS 'tegneverktøy På grunn av den øverst til venstre blir komponentene referansepunktet, vil det bli et barn av den venstre overlappet form / komponent.

8. Prøv å minimere bruken av tekstnotater på tegningen fordi disse vil bli importert som komponenter i sin egen rett, og må konverteres til frihånds figurer i ABACUS. Tenke på om de er virkelig navnet på en eksisterende komponent eller tilkobling.

9. Mens ABACUS støtter rik / farget / vektorbaserte former, prøve å minimere bruken av punktgrafikk, utenlandske former og Enhanced Metafiler for figurer som ABACUS gjør i dagikkestøtter disse typene. De vil bli importert som enkle hvite rektangler.

10. Prøv å unngå linjeskift (shift-retur) på etiketter som de er importert og vist som et spesialtegn "[]" i ABACUS for komponenten navn.

11. Prøv å minimalisere de forskjellige fargene som brukes for former av samme type. Som nevnt ovenfor, grunnfarge og basen form identifiserer komponenter og tilkoblingstyper slik at jo mer variasjon det er mer sammenslåing og konsolidering som må gjøres post-import i ABACUS.

12. Vær forsiktig med fylte former fordi hvis en formen er fylt helt til hjørnene deretter fargelagt det senere i ABACUS vil ikke ha noen effekt.

1. 3. For komplekse linjebaserte figurer må du bruke et polygon som er skapt ved å ha linjer som starter der den forrige er ferdig, og deretter til slutt kommer tilbake til startpunktet. Hvis ønskelig, kan du bruke fyll og linjebredde for å gjøre polygon ser ut som en "pil" eller hvilken form du ønsker.

14. Pass på at formene ID i MS Visio er meningsfylt ikke bare Shape.xx. Dette er redigerbar bruker høyreklikk "Show Shape 'som er tilgjengelig i MS Visio utviklermodus (aktivert via Verktøy | Alternativer i MS Visio).

15. Ellipser og buerinnen figurerstøttes i ABACUS men NURBS og splines støttes foreløpig ikke.

16. Pass på at hele formen er gruppert i MS Visio eller det vil bli importert som flere komponenter / typer.

17. Prøv å minimere bruken av roterte figurer innen subshapes som de vil noen ganger ikke importeres riktig.

Se også

Fyller din arkitektur - Oversikt | Fyller din arkitektur manuelt | Fyller du arkitektur fra Access | Fyller du arkitektur fra Excel


Fyller din arkitektur manuelt

Navigasjon: Fyller ditt arkitektur> Fylle manuelt>

Fyller din arkitektur manuelt

Send kommentarer om dette emnet.

De høyere nivå komponenter og tilkoblinger for arkitektur vil sannsynligvis må fylles ut manuelt. Typisk vil dette være mer abstrakte komponenter og tilkoblinger.

Hvis du vil fylle din arkitektur manuelt

1. Kontroller at du har en ABACUS filåpen, en explorervist, og en arkitektur lagt .

2. Legg til en komponent. Å gjøre dette, Høyreklikkpå området av treet man ønsker å fylle, og velger Legg Sub-Komponent ..., Eller klikk på New Componentknappen på Vis verktøylinje . Komponenter kan bare legges under komponenter gren av treet. Du vil at trestruktur å være en nøyaktig representasjon av arkitektur. Når du oppdaget din arkitektur, vil du ha lært nøyaktig hvordan alt henger sammen. Du trenger denne kunnskapen når du legger dine komponenter og tilkoblinger. Hvis du legger til din første komponenten, vil du legge det direkte til Components grenen. Resten av komponentene kan være enten på samme nivå i treet, eller de kan være under komponenter av den første.

3. Oppdatere verdieneeiendommeneav hver komponent som du legger det. Å gjøre dette, klikkpå komponenten, og redigere egenskapene som vises i Egenskaper-vinduet(typisk) mot høyre. Egenskapene er vanligvis ting som krav, prosesseringskapasitet, etc. Når ABACUS evaluerer arkitektur, vil den beregne noen nye egenskaper, og lagre dem tilbake til arkitekturen. De nye egenskapene er de dataene du prøver å analysere, for eksempel utnyttelse, responstid, båndbredde, etc.

4. Legg til dine tilkoblinger og oppdateringderes egenskapersom du går - akkurat som du gjør for komponenter (men under Connections gren av treet).

5. Festetilkoblinger og komponenter. For å gjøre dette, finn tilkoblingen, klikker du på en av sine slutter eller roller , Og dra det til en komponent. Alternativt kan du klikke på en komponent og dra den inn på en av forbindelsen er roller (dvs. enten Source eller Sink). Eller du kan høyreklikke og dra en komponent til en annen komponent, og velg Koble til. Eller bare høyreklikke på en komponent og velg Koble .... Når du drar en tilkobling rolle, Vil du merke en snarvei symbol når du peker på en komponent du kan feste den til. Dette indikerer at du ikke lage en kopi, du er bare å feste den. Pass på at du fester den til riktig destinasjon komponent. For eksempel, hvis det er en sammenheng kilde rolleDra den gjøre kildekomponenten (dvs. den komponenten som er kilden til dataflyt).

Tupp

Re-bestilling enheter innenfor arkitektur (f.eks Components, tilkoblinger etc.) i explorerer ganske enkelt. Ganske enkelt Klikk| Holde| Draden aktuelle enheten og sted hvor ønsket i arkitekturen. Re-bestilling funksjonalitet gjør det også mulig å plassere enheter innenfor ulike hierarkier av din arkitektur.

Du kan også være lurt å

6. Legg Standards (pre-konfigurerte sett med egenskaper - presets) til komponenter dine, tilkoblinger eller typer

7. Endre egenskapene av en komponent, forbindelse eller type

8. Angre og Gjør om operasjoner

9. Endre Type av en komponent eller tilkobling

10. Opprett en ny type eller Typegruppe

11. Slett en komponent eller tilkobling

12. Opprette, kopiere eller utvikle seg en arkitektur

1. 3. Import typer og standarder fra et bibliotek

14. Importer fra et annet ABACUS fil, XML, Excel eller Visio

15. Kopiere og lime inn deler (eller alle) av arkitektur

16. Finn og erstatt varer i arkitektur

17. Utvid / trekk noen av eller alle nodene i treet

18. Fusjonere elementer

19. Definere og Validere Begrensninger å begrense strukturen i arkitektur

20. Utvikle din arkitektur å opprette flere arkitektoniske løsninger for å sammenligne og baseline

Se også

Fyller din arkitektur - Oversikt | Opprette en ny fil


Publiser til Web

Navigasjon: Rapportering på arkitektur>

Publiser til Web

Send kommentarer om dette emnet.

ABACUS 'Publiser til web-funksjonen lar arkitektoniske modeller for å bli sett via et sikkert nettsted. Arkitekturer eksporteres til HTML-format og er designet for å reflektere utseendet og følelsen av Explorer i ABACUS. Visninger (inkludert Kataloger, diagrammer, 3D og diagrammer) eksporteres også til formater som kan vises ved hjelp av en nettleser.

Notat

Foreløpig er Synspunkter og matriser ikke publisert.

For å publisere dine arkitektoniske modeller til nettet

1. Sørg for at du har relevant ABACUS filåpen, inneholder befolket arkitekturat du ønsker å publisere på nettet.

2. Velge Fil| Publisere....

3. De Publiser til Web-konfigurasjonvinduet vil vise.

Publiser til Web-konfigurasjon

4. Som standard alle deler av modellen er valgt blant trevisningen, den Standarder, Hvilke typer, Maler og arkitektur (s). Fjern merkingen noen deler som du ikke ønsker å publisere på nettet, inkludert eventuelle individuelle visninger innen arkitektur (e).

Tupp

Hvis du ønsker å skjule bestemte komponenter, tilkoblinger og / eller deres egenskaper, anbefales det at en administrator oppretter en "Public" rolle hjelp ABACUS 'rollebasert tilgangskontroll funksjonen og deretter fjerner Les tillatelse fra de komponenttyper, typer og / eller eiendommer tilkoblings at de ikke ønsker å bli publisert. Så en bruker skal logge på under denne rollen og publisere til web som ABACUS vil bare publisere elementer som har lest tillatelsen satt for rollen. Videre kan brukerne automatisk publisere fra kommandolinjen som beskrevet her .

Notat

Du kan velge alle delene som vises ved å klikke på Alleknappen eller invertere utvalget ved å klikke på Inverter knapp. Du kan også klikke på Noneknappen for å fjerne valget.

Notat

Hvis du fjern haken trevisningen alternativetDa intet tre ramme (se nedenfor) vil bli publisert. Tilsvarende, du bør velge en startside i henhold til trinn 6 nedenfor eller etter publisering må du tilpasse enten på øverste nivå; en) index.htmlfil ved å endre "ramme src =" mainPage.html "name =" element_details "'linje for å lenke direkte til den aktuelle html side under Content-mappen, eller, b) mainPage.htmlved å tilby en hyperkobling eller omdirigere til den aktuelle html side under Content mappen.

5. Klikk på Alternativ -knappen og følgende Utgiver AlternativerDialogboksen vises.

publisereeh Alternativer

6. Svelge 3D, Diagramog diagrammer formater og om å vise tittel, beskrivelse eller Properties for utsikten ut av de tilgjengelige alternativene (se merknaden nedenfor for kommentarer til de ulike formatene).

7. Hvis du ønsker å stille start siden av den publiserte modellen til et bestemt syn så sjekk Bruk Vis som startsidealternativet, og bla til visningen via "..." knappen som blir aktivert.

Notat

Bare utsikten valgt i Områder delen som per trinn 4 ovenfor er tilgjengelige for å bli angitt som startside.

8. Hvis du ønsker å få tilbakemelding på bestemte sider i den publiserte modellen så sørg for at den E-post Tilbakemeldingeralternativet er valgt, oppgi en e-postadresse i Epostadresse tekstboksog redigere E-post Bodyseksjonen som hensiktsmessig. Hvis du ikke ønsker å ha tilbakemeldinger sendte da fjernet den E-post Tilbakemeldingeralternativet og la tekstboksen tom.

9. Klikk på OK knapp.

10. Klikk på Bla knapp.

11. De Bla etter mappevinduet vil vise.

12. Velg stedet du vil lagre på øverste nivå HTML-fil (og eventuelle automatisk genererte filer).

Notat

Det er en god idé å lage en bestemt mappe (vanligvis kalt "Publisert") ved hjelp av Opprett ny mappeknappen nederst i dialogboksen for å lagre toppnivå HTML-fil og eventuelle automatisk genererte filer.

1. 3. Klikk på OK knapp.

14. Mappebanen vil vises i Katalog tekstboks.

15. Klikk på Finish knapp.

- eller -

15. Skriv inn mappebanen i Katalogtekstboks der du vil lagre toppnivå HTML-fil (og eventuelle automatisk genererte filer).

16. Klikk på Finish knapp.

Notat

Eksport av Diagrammeren sjelden gang svikter, oftest når maskinen er tom for minne (normalt ved bruk av svært store filer). En mislykket eksport vil prøves en gang. Det vil være en advarsel for en mislykket første forsøk, og en andre varsel hvis re-forsøket mislyktes. Derfor, hvis de eneste advarsler er "første forsøk mislyktes" seg, publisere var vellykket. Hvis re-forsøket mislykkes prøver å publisere en mindre del av filen eller gratis opp noen systemminne.

Den lagrede HTML-filen (e) kan nå være utsikten fra sin plassering eller kopieres til et sikkert nettsted.

Publiser på Internett med Internet Explorer10

Noen hyperkoblinger som ble opprettet i den opprinnelige modellen vil bli faste i den publiserte modellen og klikke på linken vil følge linken til sin destinasjon (hvis den ble publisert). Videre vil noen elementer i publiserte diagrammer som ikke allerede er hyperkoblet i den opprinnelige modellen ved hyperkoblet tilbake til sine tilsvarende elementer i trevisningen (hvis den ble publisert), og ved å klikke på elementet i den publiserte diagrammet fokuset vil hoppe tilbake til vedkommende sted i treet. Denne funksjonen er lik den "Show In Explorer" høyreklikk-funksjonen i ABACUS.

Notat

Avolution anbefaler sterkt følgende programvare og filformater bør brukes til å utnytte Publiser til web funksjonalitet i ABACUS:

1. Internet Explorer (80,0 og over)for å vise den publiserte explorer visning. Mozilla Firefox (30,0 eller senere)er også anbefalt og støttes fullt utMen hvis du bruker den anbefalte SVG format for diagrammer deretter i Firefox 9 kan du bare bruke mors SVG viewer støtte som dessverre ikke tillater zooming eller panorering.

2. Adobe SVG Viewer 3.0 koble til (last ned fra her ) og SVGfilformat for den publiserte diagrammer. SVG-bildeformat for diagrammeranbefales fordi; SVG er et vektorbasert bildeformat og derfor er det "tapsfri" og ser langt bedre til enhver zoomnivå enn noen av de andre formatene, SVG kan importeres til MS Visio, SVG kan zoomes til ethvert nivå eller oppløsning har SVG lenker tilbake til trevisningen for tilkoblingene (ikke bare komponentene), SVG skriver alltid på en bedre oppløsning, og SVG er omtrent halvparten av filstørrelsen på de andre formatene. PNG er neste anbefaling, men som det er en rasterised format på visse zoomnivåer klarhet i visningen vil gå tapt og klikke tilkoblinger på diagrammer vil ikke gå tilbake til den aktuelle plasseringen i treet. BMP er motet som når det er en "tapsfri" formatere filstørrelsen er 100x at av de andre formater og 20MB bilder er ikke uvanlig.

Avveiningen med SVG er at en SVG viewer må være installert og du trenger å sørge for at .svg image / svg + xml er lagt til webserveren MIME-typer. Etter installasjon av SVG viewer Microsoft Internet Explorer vil be deg om å godta betrakterens lisensavtalen og så bør det fungere fint. Og mensMozilla Firefox støtter SVG-filer problemfritt, Adobe-plugin anbefales fortsattå kunne zoome diagrammene hvis du bruker Firefox 8 eller tidligere (hvis du bruker Firefox 9 du ikke kan deaktivere den innfødte SVG viewer). Når installasjonen for Adobes plugin er kjørt, kan fremgangsmåten er nødvendig å bruke den i Firefox:

· Åpne opp firefox og skriv "about: config" (uten anførselstegn) i adressefeltet.

· Scroll ned og finne eiendommen svg.enabled(hvis du bruker Firefox 9 da de innfødte SVG seer ikke kan være deaktivert, og denne egenskapen ikke finnes). Dobbeltklikk på den for å deaktivere den.

· Nå finner katalogen der SVG plugin er installert (for eksempel C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Kopier filene NPSVG3.dll og de NPSVG3.zip og lime dem inn i firefox plugins katalogen (f.eks C: \ Program Files \ Mozilla Firefox \ plugins)

· Lukk alle forekomster av firefox

3. Avolution er ABACUS 3D Viewer (3.1 og høyere) og Avolution er .abacus3Dfilformat for de publiserte 3D-visninger. Mens Cortona VRML Client plug-in (2.0 og høyere)er tilgjengelig for visning VRML versjoner av de publiserte utsikten er det ikke fritt for kommersiell bruk, og krever fortsatt en klientsiden installasjon. Den ABACUS 3D Viewer er mer funksjonsrik enn noen VRML seer og er fritt tilgjengelig for nedlasting fra her . I begge tilfeller sørge for at du legge .vrml x-world / x-vrml og .abacus3d application / octet-stream til webserveren MIME-typer.

4. PNGfilformat for de publiserte visninger mere. PNG-bildeformatet for synspunkter hjul anbefales fordi mens det er en rasterised format, og det er "tap" trade-off mellom filstørrelse og diagram klarhet er vanligvis den beste. BMP er motet som når det er en "tapsfri" formatere filstørrelsen er 20x at av de andre formater og 2Mb diagrammer er ikke uvanlig.

Hvis du ønsker å endre utseendet av nettsidene, kan du redigere startside fil kalt mainPage.html og style sheet fil kalt abacus.css. Du vil finne disse filene i samme mappe der du valgte å lagre toppnivå HTML-fil. For mer informasjon om strukturen og skreddersøm av den publiserte utgang se neste avsnitt.

Strukturen i ABACUS publisert modeller

Den ABACUS publisert modellen er strukturert som følger:

1. Den øverste mappen inneholder flere filer og forutsatt at alle alternativer er inkludert i ABACUS Publiser til Web Konfigurasjon dialogen den vil inneholde en indeks.htmlfil består av tre rammer; treeView.html, findNode.html og mainPage.html og så shortcutError.html side. Den treeView.html er befolket av tree.js, tree_items.js og tree_tpl.js Javascript-filer som ligger under inkluderer mappe (omtalt nedenfor) og replikerer Explorer treet fra ABACUS. Den findNode.html er drevet av de find.js Javascript-fil som ligger under inkluderer mappe (omtalt nedenfor), og det vil søke i grenene på treet i stedet for bare de synlige noder. Than mainPage.html er en statisk HTML-side som kan skreddersys med firmalogoer og lignendeog vil bli vist med mindre en startside velges ved publisering.Og til slutt, er det shortcutError.html siden en destinasjonsside for eventuelle ødelagte snarveier fra treet på grunn av de aktuelle sidene ikke blir publisert.

Tupp

Du kan hoppe over mainPage.html helt av velger å bruke en startside ved publisering eller modifisere index.html fil å peke direkte til en gitt visning (si) ved å redigere rammen src = "mainPage.html" -linjen til å peke direkte til den første visningen i første arkitektur, typisk 'rammen' diagram.

2. Toppnivå includemappen inneholdeing diverse Javascript (JS) og gjennomgripende stilark (CSS) filer som brukes av HTML-filer gjennom den publiserte modellen.

3. Den øverste nivå Content mappe inneholderAlfabetisk;

· EN '3D Visninger' mappe med etnummerertHTML-side og en VRML eller abacus3d fil for hver av de publiserte 3D-visninger. Se note nedenfor for informasjon om ordningen filen nummerering.

· En Arkitekturer mappe med en nummerert HTML-side for hver arkitektur som ble publisert. Se note nedenfor for informasjon om ordningen filen nummerering.

· A Kataloger mappe som inneholder en nummerert HTML-side for hver av de publiserte kataloger. Se note nedenfor for informasjon om ordningen filen nummerering.

· A Diagrammer mappe med etnummerertHTML-side og en PNG, JPG osv fil for hver av de publiserte visninger hjul. Se note nedenfor for informasjon om ordningen filen nummerering.

· A Komponenter mappe som inneholder ennummerertHTML-side for hver av de publiserte komponentene. Se note nedenfor for informasjon om ordningen filen nummerering.

· A Tilkoblinger mappe som inneholder ennummerertHTML-side for hver av de publiserte tilkoblinger. Se note nedenfor for informasjon om ordningen filen nummerering.

· A Diagrammer mappe som inneholder ennummerertHTML-side og en PNG, SVG etc fil for hver av de publiserte diagrammer. Se note nedenfor for informasjon om ordningen filen nummerering.

· En ikoner sub-mappe med ulike bilder som brukes i hele den publiserte modellen.

· A Standarder sub-mappe med etnummerertHTML-side for alle standardersom ble publisert. Se note nedenfor for informasjon om ordningen filen nummerering.

· A Maler sub-mappe med en samling av nummererte undermapper for hver mal publisert fra prosjektet. Innenfor hver undermappe er en Components og en mappe Tilkoblinger og innenfor disse er en nummerert HTML-side for hver komponent og tilkobling av malen. Se note nedenfor for informasjon om nummerering ordningen mappen / filen.

· A Typer sub-mappe med Component ogTilkobling undermapper mednummerertHTML-side for noen Component ogTilkoblingstyper som ble publisertog en samling av nummererte undermapper for hver type publisert fra prosjektet inneholder en HTML-side for hver av de begrensninger. Se note nedenfor for informasjon om nummerering ordningen mappen / filen.

· A Utsiktpunkts sub-mappe og ennummerertHTML-side for noen av Vispunkts som ble publisert. Se note nedenfor for informasjon om ordningen filen nummerering.

Notat

Nummereringen av HTML-sider (og i noen tilfeller bildefiler) matcher unik ID for hvert depot objekt som var angi når det var opprettetinnen ABACUS (referert til som EEIDs). Denne ID endrer ikke så som diagrammer, typer, komponenter etc er oppdatert de viljebeholder samme ID som før. I hvert tilfelle, vil den aktuelle repository objektNavnet kan bli funnet i nærheten av starten av HTML-side mellom ... HTML-koder.

Begrense tilgangen til bestemte sider / Visninger med IIS

Hvis du bruker IIS som webserver for den publiserte modellen, kan du være i stand til å begrense tilgangen til visse sider / utsikt benytter metoden nedenfor:

1. Lag et nettsted i IIS (en annen hvis det er en eksisterende en du ikke ønsker å forstyrre).

2. Endre Egenskaper-> Directory Security> Anonymous tilgang - uncheck anonym tilgang og bruk autentisert tilgang.

3. Hvis dette er bare en vanlig server uten domene komplikasjoner osv, så bør du bruke 'integrert Windows-godkjenning alternativet som da ville bruke tjenermaskiner lokale brukere / pålogginger som autentisering, og bare legge til brukere i den lokale datamaskinen (å være forsiktig at du er klar over konsekvensene, sikkerhet klok, for å legge til nye brukere på maskinen, for eksempel avhengig av om fjerntilgang er oppsettet for maskinen, etc).

4. Legg tillatelser til de spesifikke filer / mapper etter behov. Høyreklikk de enkelte filer / mapper -> Egenskaper, og justere sikkerhetstillatelsene som vanlig for filer / mapper.

Dette kan variere avhengig av hvilken versjon av IIS og hvilke konkrete Windows OS er på serveren, og om du har et domene eller annet annet oppsett.

Se også

Fyller din arkitektur | Analysere din arkitektur


Registrere ABACUS

Navigasjon: Referanse>

Registrere ABACUS

Send kommentarer om dette emnet.

Når du først starter ABACUS (eller etter en midlertidig lisens er utløpt) må du registrere søknaden mot Avolution lisens server ved hjelp av en unik lisensnøkkel gitt av din lokale ABACUS Administrator eller direkte fra Avolution. Hvis du ikke har en lisensnøkkel kan du kontakte din lokale ABACUS Administrator eller Avolution Support .

For å registrere deg med en lisensnøkkel

1. Etter installasjon, starte ABACUSenten ved å dobbeltklikke på snarveien på skrivebordet eller fra Start-menyen i Windows.

2. I Registrering dialogboksen som dukker opp skriver du inn 26 tegn lisensnøkkelgitt av din lokale ABACUS Administrator eller Avolution støtte , Eller klikk Bla ...og velg den signerte .dlsc filen tilbake fra Avolution Support som per Note på trinn 4 nedenfor. Hvis du bruker en riktig signert .dlsc fil ABACUS bør starte så per trinn 5 nedenfor.

Tupp

Du kan lime inn lisensnøkkelen i dialogen ved å kopiere den til utklippstavlen i Windows og deretter velge på bakgrunn av dialog og trykke Ctrl + V.

Dialog Registrering

3. Klikk OKog hvis lisensnøkkelen er en gyldig ABACUS lisensnøkkelABACUS vil nå forsøke å kontakte Avolution lisens server for å godkjenne lisensnøkkelen.

Notat

Hvis du får en Installasjon Koden er ugyldigregistreringsfeil er det mest sannsynlig at du har skrevet inn koden feil. Prøv å kopiere og lime inn koden som per Tips nevnt ovenfor.

Kontakte Avolution License Server

4. Klikk OKog etter en kort periode ABACUS bør registrere hell.

Vellykket Registrering

Notat

Hvis du får en Kan ikke kontakte lisensserverregistreringsfeil er det mest sannsynlig at en brannmur (eller andre sikkerhetstiltak) på nettverket ditt er å hindre tilgang til Avolution lisens server. Klikk OK, Lagre .dlsc filen til din lokale maskin og deretter enten email .dlsc filen til Avolution Support og avvente videre instruksjonereller prøve å signere lisensfilen selv ved hjelp av følgende URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Kan ikke kontakte lisensserveren

Åpne License signering nettsiden

Manuell License nettside signering

Alternativt, hvis du får Denne installasjonskode har blitt brukt på flere systemer enn tillatt av lisensenregistreringsfeil er det sannsynlig at din lokale maskin har blitt ombygd siden du sist var registrert ABACUS, eller du prøver å registrere seg med en annen brukers lisensnøkkel. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support .

Installasjon kode har allerede blitt brukt

5. Klikk OKog hvis registrert hell ABACUS bør åpne med Velkommen Screen .

Se også

Avolution Support | Hva gjør ABACUS gjøre?


Standard Element Selection

Navigasjon: Analyse din arkitektur>

Standard Element Selection

Send kommentarer om dette emnet.

Når du oppretter et diagram, 3D utsikt, rapportere,standardskjemaeller kjører en simulering, Standard element valgvinduet brukes til å velge elementer du vil analysere / visning.

Standard Element Selection Window

Nedtrekk

· Filtrer etter Utsikt vilje inkludere elementets fra en tidligere lagret view (dvs. Diagram, Chart, 3D). På denne måten kan du utføre komplekse 'join' spørringer ved å behandle en annen visning som en lagret "spørring".

Avmerkingsboksene

· Vis Levelsvilje gruppe elementet i henhold til nivået av de forekommer i treet. Nivå 1 er den øverste nivå.

· Vis Typervilje gruppe elementene i henhold til de typene som de er.

· Foreldre til valgtvil inneholde den overordnede elementene i noen utvalgte elementer. På denne måten kan du sikre at bare hierarkiet over eventuelle barn vil inngå i en "bottom-up" utvalg.

· Barn av valgtvil inkludere barna elementer av noen utvalgte elementer. På denne måten kan du sikre at bare hierarkiet under noen foreldre vil bli inkludert i en "top-down" utvalg.

· Navn Kamper Verdivil omfatte kun de elementene som har et navn som inneholder den spesifiserte strengen (OBS: Wildcards (ie og *) kan brukes?). På denne måten kan du danne en "semantisk" søket.

· Har Eiendomstype / navn / verdivil omfatte kun de elementene som har en Eiendomstype, navn og verdi som inneholder den spesifiserte strengen enten direkte på elementet eller på sine Standards (OBS:?.? Wildcards (dvs. og *) kan brukes Eg * i feltet Verdi gi alle elementer som har en ikke-blank verdi for den gitte Eiendom). På denne måten kan du danne en "semantisk" søket.

· Har Standardvil omfatte kun de elementene som har en Standard navn som inneholder den spesifiserte strengen (OBS: Jokertegn (dvs. og *) kan brukes Eg HP * vil gi alle elementer med minst én Standard starter med bokstavene H og P?.). På denne måten kan du danne en "semantisk" søket.

· Komponenter / Tilkoblinger knyttet til utvalgtevil inkludere eventuelle tilkoblede elementer til de som har blitt valgt. På denne måten kan velges en "call-treet" eller "impact-analyse".

Notat

Hvis du har både Vis Levels og Vis Typervalgt så kan du velge å ha de tre vise nivåer første eller typer først av knappen som vises over de to avmerkingsboksene.

Tupp

Når et element er valgt i Standard Element Selection Window, vil det ikke være underlagt ytterligere filterskift før det ikke er valgt. Siden det er ingen innfødte måte å søke etter to ulike sett av elementer på en gang (f.eks Komponenter med Standard A ELLER Standard B), kan du søke først for ett sett, velger du de ønskede komponenter, og deretter utføre en andre søk etter det andre settet .

Knapper

· Allevelger alle elementene.

· Inverteropphever alle de valgte elementene og velger alle de som ikke ble valgt.

· Noneopphever alle elementene.

· Legg til filtervelger den resulterende innholdet av gjeldende filterinnstillinger og lar utvalg av tilleggsinnhold som effektivt en AND eller BLI filter.

Se også

Analysere din arkitektur


The Drawing Tool

Navigasjon: Fyller ditt arkitektur> Bruke Tegninger>

The Drawing Tool

Send kommentarer om dette emnet.

Den tegneverktøy tillater etablering av et bredt spekter av arkitektoniske skjemaer og diagrammer. Arkitekter tradisjonelt bruker en rekke forskjellige tegninger til å registrere og formidle utformingen av en arkitektur. To-dimensjonale (2D) diagrammer er den vanlige måten å dokumentere og kommunisere forskjellige deler av et system. Typiske tegninger typer som brukes i bedriftens systemer er:

· Forretningsprosessmodeller og diagrammer;

· Organisasjonskart;

· Samarbeid diagrammer;

· Entity-Relationship (ER) diagrammer;

· Dataflytdiagrammer (DFD s);

· Klassediagrammer;

· IDEF (som omfatter flere av de ovennevnte); og

· UML (som omfatter flere av de ovennevnte).

Det er egentlig ingen grense for hva slags diagrammer som kan opprettes. ABACUS forsøker å balansere diagram fleksibilitet samtidig bevare integriteten av arkitekturen og dets former for representasjon.

Tegningen miljøet er en faner og ein annan vindu inne i hoved ABACUS programmet. Dette vinduet inneholder et lerret hvor tegningen skjer og når tegnevinduet er åpent en andre ein annan vindu , Sjablongen vinduet er synlig med et sett med tegne sjablonger. Sjablongen panelet har 4 kategorier: Komponenter, Tilkoblinger, former og kontakter. Lerretet vises som en hvit bakgrunn med fine rutenettet (nyttige for layout).

Komponenter er representert ved en rekke former, mens tilkoblinger er trukket som anvist linjer. Tilkoblinger feste til komponenter ved hjelp roller (dvs. enten Source eller Sink) selv om disse ikke er vist for estetiske grunner.

Tupp

Mens diagrammerer svært nyttig for å vise forskjellige deler av et system, er de begrenset i sin skalerbarhet, og det er derfor ABACUS bruker 3D for å visualisere komplekse system strukturer.

Det kan være lurt å

1. Åpne Diagram Verktøy

2. Opprett et nytt diagram av en del av en din arkitektur

3. Kopiere et diagram innenfor eller på tvers av arkitekturer

4. Legg komponenter til et diagram

5. Lag nye komponenter og forbindelser i arkitektur (skjematisk) ved hjelp av tegneverktøyet

6. Slett komponenter fra et diagram

7. Fest og manipulere tilkoblinger

8. Endre visningsegenskaper av komponenter og forbindelser.

9. Bruke koblinger i diagram

10. Håndheve typen foreninger og synspunkter slik som å begrense hvilke typer diagrammer som kan trekkes.

Se også

Fyller din arkitektur | Fyller din arkitektur manuelt | Analyse din arkitektur


Tittelside

ABACUS

Ansvarsfraskrivelse

Avolution Pty Ltd gir ingen garantier med hensyn til denne håndboken og, i den grad det er tillatt ved lov, uttrykkelig begrenser sitt ansvar for brudd på garantien som kan være underforstått til utskifting av manualen med en annen. Videre forbeholder Avolution Pty Ltd seg retten til å revidere denne publikasjonen når som helst uten å pådra seg en forpliktelse til å varsle om revisjonen.

opphavsrett

Copyright 2001-2015Avolution Pty Ltd. All rights reserved.

Varemerker

Avolution Pty Ltd har gjort vårt ytterste for å levere varemerke informasjon om firmanavn, produkter og tjenester som er nevnt i denne håndboken. Varemerker vist nedenfor ble hentet fra ulike kilder.

Microsoft Windows, Access, Visio, Excel, SQL Server og Internet Explorerer varemerker for Microsoft Corporation.

Generell merknad:

Noen produktnavn som brukes i denne håndboken er kun for identifiseringsformål og kan være varemerker for sine respektive selskaper.

Desember 2015Edition for Avolution ABACUS versjon 4.5.

Manuell Revision 1.0

Generert, skrives ut og bundet i Australia.


ABACUS Installasjon Forutsetninger

Navigasjon: Referanse>

ABACUS Installasjon Forutsetninger

Send kommentarer om dette emnet.

Informasjon Angå Visio Import og Excel Import / Export

ABACUS krever at Microsoft Office være installert for å utføre Excel Import / Eksport og Visio Import operasjoner. Vennligst bekreft at Microsoft Office 2003 eller nyereer riktig installert. Hvis du opplever flere problemer, kontakt Avolution Support .

For å utføre Visio Import og Excel Import / Export operasjoner, bruker ABACUS Microsoft Office Primary Interop Assemblies (PIA-tallet). ABACUS tiden kommer pakket med menighetene er nødvendige for å utføre Excel Import / Export og Visio Import.

Informasjon angående SQL Server Import

ABACUS krever at Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014er installert for å starte et nytt prosjekt fra SQL Server. Vennligst bekreft at Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014er riktig installert. Hvis du opplever flere problemer, kontakt Avolution Support .

Feil Åpning 3D-visualisering

Hvis ABACUS 3D Viewer ikke fungerer for deg, kan du gå glipp av SlimDX DirectX Runtime (installert som en del av hele ABACUS EXE installasjon). Dette kan lastes ned her . Hvis du har en 64bit versjon av Windows, kan du også installere dette .

Feil Redigerer ABACUS Skikk Rapporter

Redigerer ABACUS 'Custom Reports krever Report Builder 3.0 skal installeres. ABACUS og Report Builder er bygget på Microsoft .NET Framework 4.0, og mens de begge ikke krever Microsoft .NET Framework 3.5, Microsoft har feilkonfigurert Report Builder MSI å bare fortsette hvis Microsofts .NET Framework 3.5 er installert.

Følgelig har Avolution en redigert versjon av Report Builder installasjons MSI-fil som ikke krever Microsoft .NET Framework 3.5, kan dette lastes ned her .

Den opprinnelige Microsoft Report Builder MSI kan lastes ned her . Hvis du ikke allerede har Microsoft .NET Framework 3.5 som det vil kreve, kan du laste det ned her . Merk: For flere installasjoner, offline installasjon av Microsoft .NET Framework 3.5 fra her kan være mer hensiktsmessig.


Angre og Gjør om

Navigasjon: Fyller ditt arkitektur> Fylle manuelt> Tillegg>

Angre og Gjør om

Send kommentarer om dette emnet.

Som mange moderne applikasjoner, støtter ABACUS evnen til å både angre og gjøre siste bruker endringer som gjøres i et åpent prosjekt. Hvis du vil angre den siste endringen, bare aktivere angrefunksjonen. Endringene som er ugjort kan bli slengt ved å aktivere redo kommando; re-påføre sist angret endring.

Advarsel

Angret endringer er ikke i stand til å være nytt hvis ytterligere endringer er gjort i prosjektet siden blir ugjort.

Notat

Mens det store flertallet av endringer støtter angre / gjøre i sanntid, noe diagram sjablong endringer, som å lage en ny type-Shape / Linje forening eller endre en forening fargeattributten, er ikke i stand til å omgjøres umiddelbart. I slike tilfeller må den modifiserte Diagram (merket med en stjerne) lukkes før disse endringene kan angres.

Angre og Gjør om kommando steder

Angre og Gjenopprett kommandoer kan nås fra tre forskjellige steder:

· Rediger-menyen

· Standard-verktøylinjen

· tastaturet hurtigtaster CTRL + Z(angre) og CTRL + Y(redo)

Tupp

Angre og gjøre om knappene på standardverktøylinjen gi dropdown lister som viser de 10 siste endringene som kan angres og har vært redone hhv. De er også en praktisk måte å angre / gjøre flere endringer på gang.


Ved hjelp av makroer

Navigasjon: Simulerer din arkitektur>

Ved hjelp av makroer

Send kommentarer om dette emnet.

Hvis du utfører en oppgave flere ganger i ABACUS, kan du automatisere oppgaven ved hjelp av en makro. Følgelig er det et ABACUS makro en innspilt serie av operasjoner som kan spilles på nytt til enhver tid.

Spille inn en makro

1. Velg Verktøy | Registrer makroeller alternativt trykk Alt + F10.

2. Begynne å utføre operasjoner som du ønsker å ta opp.

Advarsel

På denne tiden, er det noen kjente problemer med opptak makro. Vennligst ta disse i betraktning ved opptak makroene:

· Foreløpig makroer bare registrere dine Microsoft Windows tastetrykk, musebevegelser og museklikk. Imidlertid, på grunn av begrensninger med makro opptakeren seg selv, er det noen tastetrykk som ikke alltid er registrert. Disse inkluderer:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Begynne]

· [F1] til [F12]

· Det anbefales derfor at du bekrefte at en tastatursnarvei er registrert av makro opptaker før opptak av et stort sekvens av hendelser som kan stole på at tastatursnarvei arbeidsmiljø.

· Tiden på grunn av begrensninger med makro opptaker, er kontekstmenyer ikke håndteres riktig av ABACUS når de blir åpnet av en handling registrert av makro opptaker. Når du åpner en hurtigmeny, må du utføre en av funksjonene som er oppført i hurtigmenyen via kontekstmenyen, ellers kontekstmenyen kan forbli åpen under avspilling, noe som kan føre til utilsiktede handlinger eller handlinger som kan føre til feil i ABACUS.

· Merke til at vanlige metoder for å lukke en hurtigmeny (f.eks å trykke [Esc] på tastaturet, eller venstre-klikke et annet sted på skjermen) kan faktisk ikke lukke hurtigmenyen under avspilling av en makro.

Tupp

I dialoger, heller enn å bruke museklikk, anbefales det å bruke Tab-tasten for å gå gjennom de tilgjengelige kontrollene og piltastene til å velge rullegardinmenyelementer eller radioknapper og mellomromstasten for å velge / de-velger check bokser.

Å stoppe innspillingen en Macro

1. Pressen Alt + F9eller alternativt velg Verktøy | Stopp Macro.

2. I Lagre Macro Som bla dialog til et sted og velg et ABACUS makro (.abacusmac fil) filnavn, og klikk Lagre.

Notat

Bruke Verktøy| Stopp Macrovil inkludere denne operasjonen i den innspilte makro. Derfor anbefales det at brukerne bli dyktigere i å bruke Alt + Funksjonstast alternativer for å arbeide med makroer for ikke å inkludere uønskede makro operasjoner i makroene selv.

Tupp

Som makroene er foreløpig ikke redigeres, anbefales det å ta opp langvarige oppgaver som en rekke separate makroer ved hjelp av Alt + F10 / Alt + F9 'par'.

For å spille av en innspilt Macro

1. Velg Verktøy | Avspilling Macroeller alternativt trykk Alt + F8.

2. I Åpne dialogboksen Makro bla til en plassering, og velg en ABACUS makro (.abacusmac fil) filnavn og klikk Åpne.

Advarsel

Når du åpner en ABACUS makro, hvis du dobbeltklikker på en makro-fil fra dialogboksen Bla gjennom for å åpne den, kan den makro opptaker hold venstre museknapp i en venstre klikket tilstand før en innspilt venstreklikk styrer denne tilstanden.

Notat

Avspillingshastigheten av makroen kan settes i kategorien Generelt i henhold Verktøy| Alternativersom enten Normal (standard), fort eller sakte. Både raske og langsomme avspillingshastigheter anbefales ikke som de vil spille av innspilte makroer på ca 100 ganger og 1 / 100th real-time, hhv. Normal avspillingshastighet vil fortsatt spille av makro ca 30% raskere enn den registrerte hastigheten så det anbefales under opptak til pause for en kort tid etter at eventuelle langvarige behandlingen oppgaver for å sikre at på avspilling neste operasjon utføres ikke før behandlingen oppgaven har fullført.

Å slutte å spille en innspilt Macro

1. Pressen Alt + F9.


Ser på en 3D-diagram

Navigasjon: Analyse din arkitektur> 3D-diagrammer>

Ser på en 3D-diagram

Send kommentarer om dette emnet.

ABACUS kan du vise din arkitektur som en 3D-visning der komponent og tilkoblingsegenskaper er forbundet med farger, former og størrelser.

Hvis du vil se en 3D-visning av arkitektur

1. Kontroller at du har åpne ABACUS filinneholder din befolket arkitektur.

2. Utvid Visningergren av treet.

3. Utvid 3Dgren av treet.

4. Dobbeltklikk visualisering du vil åpne.

- eller -

1. Kontroller at du har åpne ABACUS filinneholder din befolket arkitektur.

2. Velge Sett| 3Deller klikk på knappen på verktøylinjen.

3. Åpne en eksisterendevisualisering (.abacus3d)

- eller -

1. Kontroller at du har åpne ABACUS filinneholder din befolket arkitektur.

2. Velge Sett| 3Deller klikk på knappen på verktøylinjen.

3. Opprett en ny visualisering:

· Velg Arkitekturdu ønsker å se fra rullegardinmenyen.

· Velg Komponenter og Tilkoblingerdu ønsker å inkludere i diagrammet fra standard element utvalg vindu .

· Førsteamanuenser farger, former og størrelser med Komponenttyper og Egenskaper.

· Knytte farger og former med Tilkoblingstyper og Egenskaper.

Slik eksporterer du en 3D-visning

1. Kontroller at du har åpne et eksisterende 3D-visning.

2. I 3D-visning er rullegardinmenyene velg Fil | Eksport...og valgte plasseringen og filtype for visualisering fil (.abacus3d, .vrml eller HTML).

3. Klikk Spare.

Se også

Analysere din arkitektur | Navigasjon i 3D | Den diagram Tool


Ser boblediagrammer

Navigasjon: Analyse din arkitektur> Custom diagrammer>

Ser boblediagrammer

Send kommentarer om dette emnet.

En boble diagrammet kan du sammenligne opptil 5 dimensjoner (dvs. X, Y, boblestørrelse / radius, boble farge og boble grensen farge) i én visning.

Hvis du vil vise en boble diagram

1. Kontroller at du har en ABACUS fil åpen .

2. Velge Sett| Chart| de Tilpassede ChartsKategorien | Bubble Chart.

3. I Arkitekturerseksjonen, merk av arkitekturer (hvis noen) du ønsker å kartlegge, og klikk deretter Neste.

4. Velg Komponenter og Tilkoblingerat du vil ha i diagrammet (hvis noen) fra standard element utvalg vindu Klikk på Neste.

5. Velg X-akseneiendom, og klikk deretter Neste.

Notat

Bare Heltall, desimal, dato / tid, boolsk og List eiendommer kan brukes for X-aksen. Videre er heltall, desimal og dato / klokkeslett egenskaper plottet venstre mot høyre langs aksen dimensjoneres i forhold til verdien av eiendommen, men er boolske og List egenskaper bare plottet fra venstre mot høyre i den rekkefølgen (eller i motsatt rekkefølge hvis muligheten til å snu rekkefølgen blir kontrollert) definert for eiendommen uavhengig av deres verdier. F.eks Low | Medium | Høy eller 1, 2, 4, 8, 16.

6. Velg Y-akseneiendom, og klikk deretter Neste.

Notat

Bare Heltall, desimal, dato / tid, boolsk og List eiendommer kan brukes til Y-aksen. Videre er heltall, desimal og dato / klokkeslett egenskaper plottet bunn-til-topp langs aksen dimensjoneres i forhold til verdien av eiendommen, men boolske og Liste egenskaper er bare plottet bunn-til-topp i den rekkefølgen (eller i motsatt rekkefølge hvis muligheten til å snu rekkefølgen blir kontrollert) definert for eiendommen uavhengig av deres verdier. F.eks Low | Medium | Høy eller 1, 2, 4, 8, 16.

7. Velg boblestørrelse / radiuseiendom, og klikk deretter Neste.

Notat

Bare Heltall, desimal, boolsk og List eiendommer kan brukes for boblestørrelsen / radius. Videre Integer og desimal egenskaper resultere i en boble størrelse / radius dimensjoneres i forhold til verdien av eiendommen, men boolske og List egenskaper resultere i like trinn øker i boblestørrelse / radius i den rekkefølgen (eller i motsatt rekkefølge hvis muligheten til å snu rekkefølgen blir kontrollert) definert for eiendommen uavhengig av deres verdier. F.eks Low | Medium | Høy eller 1, 2, 4, 8, 16.

8. Velg enten en fast boble farge eller knytte en eiendom med boblen fargeKlikk på Neste.

Notat

Bare Heltall, desimal, boolsk og List eiendommer kan brukes for boblen farge. Videre Integer og desimal egenskaper resultere i en boble farge innenfor det valgte utvalget dimensjoneres i forhold til verdien av eiendommen, men boolske og List egenskaper resultere i like trinn øker av boblen farge innenfor det valgte utvalget i den rekkefølgen som er definert for eiendom uavhengig av deres verdier. F.eks Low | Medium | Høy eller 1, 2, 4, 8, 16.

9. Velg enten ingen boble kantfarge eller knytte en eiendom med boblen grensen fargeKlikk på Finish.

Notat

Bare Heltall, desimal, boolsk og List eiendommer kan brukes for boblegrense farge. Videre Integer og desimal egenskaper resultere i en boble kantfarge innenfor det valgte utvalget dimensjoneres i forhold til verdien av eiendommen, men boolske og List egenskaper resultere i like trinn øker av boblen grensen farge innenfor det valgte utvalget i den rekkefølgen definert for eiendommen uavhengig av deres verdier. F.eks Low | Medium | Høy eller 1, 2, 4, 8, 16.

Boblediagram

Slik lagrer du et boblediagram

Notat

Boble diagrammer kan bare reddes hvis de bare inneholde komponenter og forbindelser, som alle må være fra en enkelt arkitektur innenfor det aktuelle prosjektet.

1. Sørg for at du har en ny eller eksisterende boblediagram åpneog du har gjort de nødvendige endringene.

2. I diagrammet verktøylinjen klikker på den venstre Lagre Chartknappen for å lagre diagrammet og eventuelle formateringsendringer.

3. I Chart Namedialogboksen som vises skriver du inn et navn for boblediagram og trykk OK.

Hvis du vil eksportere et boblediagram

1. Kontroller at du har åpne et eksisterende boblediagram.

2. I diagrammet verktøylinjen, klikk på andre fra venstre Lagre som BMPknappen og valgte plasseringen for diagrammet.

3. Klikk Spare.

Se også

Analysere din arkitektur


Ser en evne plass diagram

Navigasjon: Analyse din arkitektur> Custom diagrammer>

Ser en evne plass diagram

Send kommentarer om dette emnet.

Et Capability Space diagrammet kan du se om din arkitektur oppfyller de nødvendige system evne med hensyn til egenskaper identifisert under system behovsanalyse prosessen.

Hvis du vil vise en evne plass diagram

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur, Og at du har evaluertdin arkitektur.

2. Velge Sett| Chart| Tilpassede Charts| Capability Space. (De Capability Space Chart ConfigDialogboksen vises.)

3. I Arkitekturerseksjonen, merk av arkitekturer du ønsker å diagrammet, og klikk deretter Neste.

4. I Egenskaperområde, huke av arkitektoniske egenskaper som du vil inkludere som aksene i diagrammet.

5. I Evneområdet, for hver eiendom inkludert fra forrige trinn, velger du om noen Minimum eller maksimale evne grenser finnes, og verdiene av disse grensene. Standardverdiene er vurdert for de arkitekturer eller minimum og maksimum verdier Målet for eiendommen om det har blitt stilt.

Slik eksporterer en evne plass diagram

1. Kontroller at du har et eksisterende evne plass diagram åpne.

2. I diagrammet verktøylinjen klikker på den venstre Lagre som BMPknappen og valgte plasseringen for diagrammet.

3. Klikk Spare.

Se også

Analysere din arkitektur | Vise en responstid diagram


Standardrapporter

Navigasjon: Rapportering på arkitektur>

Standardrapporter

Send kommentarer om dette emnet.

ABACUS ' standard rapporter kan du få en liste over komponenter og forbindelser i en eller flere av dine arkitekturer. Rapporten inneholder all informasjon relatert til komponenter og forbindelser utvalgte, herunder opplysninger om komponenten eller forbindelsen sin plass i hierarkiet, type, standarder, beskrivelse, egenskaper og dens vedlegg.

Notat

Rapporten innhold erkonfigurerbargjennom dialog Rapporter alternativer beskrevet nedenfor, men to For mer informasjon om hvordan du oppretter helt konfigurerbar tilpasset rapporterbruker ABACUS tilpassede rapporter, vennligst leser du emnet her eller kontakt Avolution Support .

Hvis du vil vise en standard rapportere

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur(s).

2. Velge Sett| Standard Rapportereller klikk på Opprett Standard Rapporter knappen på verktøylinjen. De Rapporter Configurationvindu vises.

Vindu rapport Configuration

3. Velg Arkitekturer, Komponenter og Tilkoblingersom du ønsker i rapporten fra Rapporter Configuration Window.Vennligst referer til Standard Element Selection her Temaet for hjelp.

4. Nå klikk på Alternativerknappen og Rapporter Alternativervinduet vil vise.

Rapporter vinduet Alternativer

5. Du kan velge å vise en Ny side for hvert element, de Skriv ut siden, Print Tid, Sidetallog om å inkluderer tittelen i overskriftenav rapporten ved å sette / fjerne kryss de aktuelle avmerkingsboksene. Du kan også være lurt å tilpasse tittel og forfatter ved å redigere Rapporter tittel og Forfatter tekstbokser. Du kan også velge hvilket innhold vises på rapporten ved å sette / fjerne kryss i boksene under Rapporter innholddelen av vinduet. Når du er ferdig klikker du på OK.

6. Nå klikker du på Finishi vinduet Rapporter Configuration.

Å tolke det synlige rapporten

Eksempel generert rapport med korte forklaringer

Å navigere gjennom rapportsider, klikk på ikonene [image] plassert på verktøylinjen øverst i venstre hjørne av skjermen.

Notat

Du kan spare rapporten til ulike formater ved å klikke på Eksport Rapporten ikon [image] plassert i verktøylinjen. Du kan velge å eksportere i følgende formater: Excel, PDF og Ord. Vennligst lagre rapporten på ønsket sted for senere bruk. Dersom det gjøres endringer i arkitekturen på et senere tidspunkt, vil en ny rapport må være opprettet for å gjenspeile endringene.

Se også

Analysere din arkitektur


Vise en responstid diagram

Navigasjon: Analyse din arkitektur> Custom diagrammer>

Vise en responstid diagram

Send kommentarer om dette emnet.

En responstid diagrammet kan du se om dine forbindelser blir behandlet på ønsket hastighet (dvs. innen deres frist).

Hvis du vil vise en responstid diagram

1. Kontroller at du har en ABACUS fil åpen inneholder din befolket arkitektur, Og at du har evaluertdin arkitektur.

2. Velge Sett| Chart| Tilpassede Charts| Responstid. (De Responstid Chart ConfigDialogboksen vises.)

3. Fra Arkitekturerrullegardinlisten velger arkitektur du ønsker å kartlegge.

4. I Tilkoblingerområde, huke av tilkoblinger som du vil inkludere i diagrammet.

5. De Scale Typeområdet velger LineærHvis du vil ha den vertikale aksen (responstid) som skal vises som en lineær progresjon - hvert segment av tid er avsatt en lik andel av aksen. Velge LogaritmiskHvis du ønsker det vises som en logaritmisk progresjon - hvert segment av aksen representerer stadig lengre perioder av gangen jo høyere opp aksen du går. (Graden av økningen bestemmes av Utgangspunktdu velger.)

Responstid diagram vertikale aksen skala

Slik eksporterer en responstid diagram

1. Kontroller at du har et eksisterende responstid diagram åpne.

2. I diagrammet verktøylinjen klikker på den venstre Lagre som BMPknappen og valgte plasseringen for diagrammet.

3. Klikk Spare.

Se også

Analysere din arkitektur | Ser en evne plass diagram


Ser på et punktplott av dine utviklet seg arkitekturer

Navigasjon: Analyse din arkitektur> Custom diagrammer>

Ser på et punktplott av dine utviklet seg arkitekturer

Send kommentarer om dette emnet.

Når en arkitektur har blitt utviklet og målene er definert, kan det da bli visualisert og sammenlignet med den opprinnelige arkitekturen hjelp scatterplot matriser. Denne delen beskriver hvordan du oppretter og forstå egenskapene til et scatterplot matrise.

Hvis du vil vise en scatterplot Matrix dine utviklet seg arkitekturer

1. Kontroller at du har en ABACUS fil åpen .

2. Kontroller at du har utviklet seg og sette målfor arkitektur som skissert i henhold Utviklende din arkitektur

3. Velge Sett| Chart| de Tilpassede ChartsKategorien | Scatterplot Matrix.

4. Klikk på Finish knapp.

5. De Scatter Plotmed den definerte utviklingen av arkitekturer og mål vil bli vist.

Notat

Området på venstre side av scatterplot matrisen viser innstillingene for scatterplot matrise vises. Dette inkluderer den arkitekturen som er blitt utviklet seg (i dette tilfellet "ABC Ltd As-Is 2010") Samt de mål som er satt for at arkitektur. Du vil merke at de målene som har en hake ved siden av dem er representert som X og Y aksene i scatterplot matrise (f.eks KPI- Kostnader, KPI - Kvalitet og KPI - Time). Du kan rotete disse målene til enhver tid å fjerne dem fra scatterplot matrise.

De blå prikkene som vises på tomten i matrisen representerer en normalisert verdi, som bestemmes av de beste og verste verdi (skissert i henhold Sette mål for din utviklet seg arkitektur ). Disse verdiene er representert i en Kvalitet Space.

To definerte mål blir sammenlignet med hverandre i et spredningsplott matrise, og prosessen gjentas inntil alle de mål har blitt sammen (f.eks Den første handlingen av matrisen i det ovenstående diagram sammenligner KPI - KostnadsMålet med KPI - Kvalitet mål. Den andre er Koste mot Tid og den siste tomten er Kvalitet mot Tid. De relevante mål merkene vises øverst og til høyre eller hver rad av tomter.).

6. Velg Arkitektureralternativknappen hvis du vil vise statistikk for de enkelte arkitekturer.

7. Velg Evolutionsalternativknappen hvis du vil vise de normaliserte endringer fra den opprinnelige arkitekturen (f.eks As-Is 2 010) Til den utviklede arkitektur (er) (f.eks To-Be 2011 - Strategi A og å være 2011 - Strategi B).

Se også

Analysere din arkitektur | Vise en responstid diagram | Vise en stjerne tomt på dine utviklet seg arkitekturer | Utviklende din arkitektur


Vise en standardoversikt

Navigasjon: Analyse din arkitektur> Standard diagrammer>

Vise en standardoversikt

Send kommentarer om dette emnet.

ABACUS 'standard diagrammer inkluderer linje, bar, kolonne, område, scatter, pai, kurve, Pareto, step, overflate, radar, kube, smultring, pyramide, kontur og kurve områdediagrammer. Når du har valgt diagramtypen du ønsker, er resten av prosessen for visning hver av disse listene samme.

Hvis du vil vise et standardskjema for din arkitektur

1. Kontroller at du har åpne ABACUS filinneholder din befolket arkitektur, Og at du har evaluertdin arkitektur.

2. Velge Sett| Charteller klikk på knappen på verktøylinjen. De Diagrammervindu vises.

Diagrammer vindu

3. Velg diagramtypen du ønsker og sette hjul Alternativer, og klikk deretter Neste.

Chart Alternativer

o Stabletviser forholdet mellom enkeltelementer til helheten. Du kan bruke et stablet diagram når du planlegger å ha flere serier data (dvs. flere eiendommer) og når du vil fremheve den totale.

o Stablet 100%sammenligner den prosentvise hver verdi bidrar til en total på tvers av kategorier. Du kan bruke en 100% stablet diagram når du planlegger å ha flere dataserier (dvs. flere eiendommer) og du ønsker å legge vekt på bidrag til det hele, spesielt hvis den totale er den samme for hvert element.

o 3D kartvil bare vise datapunktene i 3-D format for estetikk. Hvis du ønsker å vise dataseriene langs en tredje / z-aksen dimensjon deretter bruke Cluster Series alternativet beskrevet nedenfor.

o Serien av eiendomvil vise en dataserie for hver eiendom som til slutt velges. Hvis dette ikke er avkrysset så eiendommene vil bli kategoriene og dataserier vil være for hvert element som er valgt.

o Roter Chartvil rotere diagrammet 90 grader med klokken ved å bytte x- og y-aksen. Dette alternativet er bare tilgjengelig for linjene, trinn og Cube diagrammerog er spesielt nyttig til å Milestone diagrammer som beskrevet i den andre spissen nedenfor. Merk: Kolonne og Bar diagrammer er allerede "rotert" versjoner av hverandre.

o Cluster Seriesvil vise flere seriedata langs en tredje / z-aksen dimensjon. Dette alternativet er bare tilgjengelig for Column, Bar og Cube diagrammerog er spesielt nyttig for å lage Gantt stil diagrammer som beskrevet i den første Tip nedenfor.

Tupp

Du kan opprette en Gantt-diagrammed vannrette streker som viser tid / dato egenskaper for ulike elementene ved å velge en Bar diagramtype og deretter velge alternativet Cluster Series.Videre, når opprettet, kan den venstre mest bar på diagrammet gjøres "usynlig" ved å farge det hvite ved å høyreklikke på en av barene, velge farge fra menyen som vises, og velger den øverste venstre farge fra paletten. I tillegg grensen for lengst til venstre bar kan gjøres "usynlig" ved å høyreklikke på en av barene, velge Egenskaper ... og i kategorien Series i dialogruten som vises endre Border Effect til Ingen og farge til toppen -Venstre farge fra paletten.

Tupp

Du kan opprette en Milepæl diagrammed små figurer som viser tid / dato egenskaper for ulike elementer ved å velge en Cube diagramtype og deretter velge Roter Chart og alternativer Cluster-serien.Videre, når opprettet, kuber kan endres til andre former ved å høyreklikke på en av kubene i en gitt dataserier og velge Egenskaper ... og i kategorien Series i dialogruten som vises endrer Bar til enten Cylinder eller Cone . Merk: Bredden verdi Gap kan også brukes til å "krympe" symbolene på diagrammet for å redusere overlapping, jo høyere tall, jo mindre overlapping vil det være.

4. I Arkitekturerdelen, merk av arkitektur / s du ønsker å kartlegge arkitektur nivå egenskaper for, og klikk deretter Neste.

Notat

Velge arkitektur nivå egenskaper er en helt valgfritt trinn, og bør bare brukes når du ønsker å eksplisitt kartlegge arkitektur nivå egenskapene seg.En arkitektur trenger ikke å bli valgt for å inkludere så komponent eller tilkoblings egenskaper i det neste trinnet.

5. Velg Komponenter og Tilkoblingerat du vil ha i diagrammet fra standard element utvalg vindu Klikk på Neste.

6. Velg Egenskaperdu vil i kartet og klikk Finish.

Chart Alternativer

o Inkluder Standard egenskaper vilje viser de arvede egenskaper fra de standarder som er tilgjengelige for valg.

o Samlede Properties vilje telle avviket mellom seriene verdier og kartlegge disse resultatene i motsetning til den enkelte verdier selv.Dette alternativet er bare tilgjengelig hvis den serien av Property alternativet ble valgt i trinn 3 ovenfor.

Tupp

Eiendommene som er tilgjengelige for kartlegging avhenger av elementene du velger.

For å lagre et diagram

Notat

Diagrammer kan bare reddes hvis de bare inneholde komponenter og forbindelser, som alle må være fra en enkelt arkitektur innenfor det aktuelle prosjektet.

1. Sørg for at du har en ny eller eksisterende diagram åpneog du har gjort de nødvendige endringene.

2. I diagrammet verktøylinjen klikker på den venstre Lagre Chartknappen for å lagre diagrammet og eventuelle formateringsendringer.

3. I Chart Namedialogboksen som vises skriver du inn et navn for diagrammet og trykk OK.

Slik eksporterer et diagram

1. Kontroller at du har et eksisterende diagram åpne.

2. I diagrammet verktøylinjen, klikk på andre fra venstre Lagre som BMPknappen og valgte plasseringen for diagrammet.

3. Klikk Spare.

Se også

Analysere din arkitektur | Vise en responstid diagram | Ser en evne plass diagram


Vise en stjerne tomt på dine utviklet seg arkitekturer

Navigasjon: Analyse din arkitektur> Custom diagrammer>

Vise en stjerne tomt på dine utviklet seg arkitekturer

Send kommentarer om dette emnet.

Når en arkitektur har blitt utviklet og målene er definert, kan det da bli visualisert og sammenlignet med den opprinnelige arkitekturen ved hjelp av stjerne plott. Denne delen beskriver hvordan du kan opprette og manipulere en stjerne plot.

Hvis du vil se en stjerne tomt på dine utviklet seg arkitekturer

1. Kontroller at du har en ABACUS fil åpen .

2. Kontroller at du har utviklet seg og sette målfor arkitektur som skissert i henhold Utviklende din arkitektur

3. Velge Sett| Chart| de Tilpassede ChartsKategorien | Stjerne Plot.

4. Klikk på Finish knapp.

5. De Stjerne Plotmed de utviklet seg arkitekturer og sette mål vil bli vist. Merk: Aksene stjernen tomten kan flyttes ved å klikke og dra aksene til et annet område innenfor rammene av stjernen tomten kvalitet plass.

Notat

Området på venstre side av stjernen tomten viser innstillingene av stjernen tomten vises. Dette inkluderer den arkitekturen som er blitt utviklet seg (i dette tilfellet "ABC Ltd As-Is 2010") Samt de mål som er satt for at arkitektur. Du vil merke at de målene som har en hake ved siden av dem er representert som aksene stjernen tomten (f.eks KPI- Kostnader, KPI - Kvalitet og KPI - Time). Du kan rotete disse målene til enhver tid å fjerne dem fra stjernen tomten.

De røde og grønne "prikker" som vises på din stjerne tomten representerer en normalisert verdi, som bestemmes av de beste og verste verdi (skissert i henhold Sette mål for din utviklet seg arkitektur ) For den valgte toppnivå arkitektur og eventuelle utviklinger av det. Disse verdiene er representert i en Kvalitet Space.

Som beskrevet i bildet ovenfor, er det tydelig at den opprinnelige arkitekturen (As-Is 2 010) Har dårlig Koste, Mens den første utviklet alternativ (To-Be 2011 - Strategi A) Har beveget seg inne i kvalitet plass for å forbedre Koste, Kvalitet og Tidmål. Alternativt, utviklet det andre alternativet (To-Be 2011 - Strategi B), mens det har også forbedret Koste størrelsen av forbedring er mindre enn for Strategi A men både kvalitet og tid mål har blitt forbedret mer enn med Strategi A.I dette tilfellet en arkitekt kan velge Strategi A over Strategi Bsom sin anbefalingog videre utvikle det alternativet (To-Be 2012 - Strategi A).

6. Oppheve valget Vis Evolutionsboksen for å skjule linjen (e) som representerer utviklingen (e) mellom den opprinnelige (f.eks As-Is 2 010) Og utviklet seg (f.eks To-Be 2011 - StrategiA) arkitektur (s).

7. Velg Vis Sticksboksen for å vise den relative størrelsen av hver kvalitet attributt (de målene som er satt på hver akser) for hver arkitektur.

8. Velg Vis Arkitektur Namesboksen hvis du vil navnene på de opprinnelige og utviklet arkitektur (e) skal vises på stjernen tomten.

Se også

Analysere din arkitektur | Vise en responstid diagram | Vise en scatterplot matrise av dine utviklet seg arkitekturer | Utviklende din arkitektur


Analysere din arkitektur

Navigasjon: Analyse din arkitektur>

Analysere din arkitektur

Send kommentarer om dette emnet.

Når du har befolket (og eventuelt simulert) din arkitektur, er du klar til å bruke ABACUS å analysere det. Ved å analysere det, kan du finne ut om arkitektur vil møte dine behov.

Man kan analysere arkitekturen i en rekke forskjellige måter:

· Diagram

· 3D utsikt

· standard diagrammer (pai, linje, kolonne, bar, etc.)

· definerte diagrammer ( responstid , evne plass , stjerners tomt , scatterplot matrise og boblediagram )

· Arkitektur Diff

Notat

Når du oppretter et diagram, 3D utsikt, Rapport eller standard kartet, standard element utvalg vindu brukes til å velge elementer du vil vise.

Se også

Fyller din arkitektur | Simulere din arkitektur | De Diagram Verktøy


Hva er arkitektur?

Navigasjon: Introduksjon til ABACUS>

Hva er arkitektur?

Send kommentarer om dette emnet.

Arkitektur er et abstrakt konsept- Ikke en fysisk ting. Det er en rik og omfattende beskrivelse eller forståelse av strukturen i et system - fange komponentene og hvordan de er koblet (samhandle). Fordi oppfatningen av arkitekturen er så altomfattende, er det grunnleggende for pris, tilgjengelighet, evolvability, åpenhet, og ytelsen til systemet. En lyd arkitektur er en forutsetning for et lydanlegg.

I ABACUS, modellere deg din arkitektur. For enkelhets skyld kaller vi dette arkitektoniske modellen en arkitektur.

Diagrammet nedenfor viser en typisk arkitektur 5komponenter (i et hierarki) koblet sammen med 2 tilkoblinger. Etikettene angir navnene gitt de forskjellige deler av arkitekturen i ABACUS.

En enkel arkitektur

ABACUS anser alle disse tingene for å være en del av arkitekturen:

· Komponenterrepresenterer enhetene i din arkitektur som du kan beskrive som "ting". For et forsikringsselskap, kan komponentene være systemene for behandling av politikk, krav, betalinger og kvitteringer.

· Tilkoblingerrepresenterer forholdet mellom disse komponentene. For eksempel i et forsikringsselskap, er kvitteringer generert for gyldige politikk, er utsagn mot gyldige politikk, og gyldige krav resultere i utbetalinger. Når du tenker arkitektonisk - spesielt når du bruker ABACUS - tilkoblinger er like viktig som komponenter, og de blir behandlet i en nesten identisk måte.

· Alt i treet kan ha Egenskaper. Egenskaper er ting som måten du trenger systemet å utføre, antall linjer med kode den har, hvor mange prosent av disse linjene som er kommentarer osv ABACUS anser alle disse tingene for å være en del av arkitekturen.

· Ved bruk av hierarkier(dvs. delkomponenter og sub-tilkoblinger), Kan du skjule informasjon og de-komponere din arkitektur. Den ABACUS arkitektoniske modellen er ekstremt fleksibel. Enhver komponent på ethvert nivå som kan knyttes til en hvilken som helst annen komponent på et annet nivå ved en hvilken som helst forbindelse på ethvert nivå.

· Vedlegger den operasjon ved hvilken komponentene porter er bundet til tilkoblingroller. Ports og Roller er grensesnittetsmellom komponenter og forbindelser. De brukes til å feste forbindelser til komponentene. Connections har en kilde og en Sink rolle(tilrettelegge datastrøm fra kilden komponenten til vasken komponent)og konseptuelt, komponentene har porter. For enkelhets skyld, men i ABACUS komponentporter er ikke vist, og forbindelses roller er direkte knyttet til selve komponentene.

· Komponenter og tilkoblinger er av en viss Type. Dette er hovedsakelig i klassifiseringsøyemed. For eksempel politikk, krav, betalinger og kvitteringer er komponenter av den typen 'System'. De gyldige politikk, gyldige krav, etc. er forbindelser av typen "Transaksjons '. Type tildelt en komponent eller tilkobling gir en mal for eiendommene og standarder det har. For eksempel kan en Server-komponenten typen har 'og merke' standardog en IP-adresse eiendom. I motsetning til andre stive verktøy med en grunnleggende relasjonelle data-base (RDB) back-end, i ABACUS kan du fritt opprette egne nye Typer og tildele dine egne kombinasjoner av egenskaper og standarder til dem.

· Standard biblioteker av egenskaper kan spesifiseres og tildelt noe annet i arkitekturen. Disse biblioteker er kjent som Standarder. Ved bruk av Standarder, Trenger du bare å samle spesifikke systemer egenskaper - de vanlige egenskapene er allerede der. For eksempel de vanlige egenskapene til Microsoft Windows 2000 kan tildeles uansett komponenter bruker Microsoft Windows 2000-operativsystemet.

Se også

Hvordan er en arkitektur representert i ABACUS? | Hva gjør ABACUS gjøre? | Hvordan du gjør det (oversikt) | Opprette en ny type


Arbeide med Enterprise Server

Navigasjon: Administrasjon>

Arbeide med Enterprise Server

Send kommentarer om dette emnet.

ABACUS Enterprise Server er både en "non-låsing" samarbeidende tilnærming, men en "frakoblet" en også. ABACUS er "non-låsing" fordi det ikke tvinge filen skal være låst av en bruker på det å bli oppdatert. Hver bruker har sin egen lokal kopi av filen, og som de gjør endringer og lagre sine filer, blir disse endringene registreres og lagres for når brukeren ønsker å forplikte dem til serveren.

ABACUS er "koblet" i den forstand at du ikke trenger å være koblet til serveren eller trenger nettverkstilgang mens du arbeider på en fil. ABACUS krever kun tilgang til serveren når du utfører operasjoner som å lage en fil, eller utføre en kassa, sammen med operasjoner på en eksisterende fil - oppdatering, begå, eller viser loggen av tidligere forplikter. Tilgang til serveren ikke er nødvendig å arbeide på filen, og endringene ikke er sendes til serveren umiddelbart (dette lar deg enkelt slette endringene hvis du gjør en feil). Når du lagrer filen, blir du "bare" lagre kopiere lokalt - det er ikke før du forplikte seg at lokale endringer (endringer siden sist forplikte), blir sendt til serveren.

Opprette en ny Enterprise File

For å opprette en ny Enterprise fil, velger Fil| Ny ...og velg deretter en av de to første alternativene under Enterprise Model delen av Ny dialog Prosjekt (dvs. enten en blank Enterprise-fil, eller lage en fra en eksisterende ABACUS fil). Det tredje alternativet er å "kassen" en Enterprise-fil noen andre allerede har skapt, vil dette bli dekket i neste avsnitt.

Når du velger å lage en ny Enterprise-fil, vil du bli gitt en dialogboks som lar deg bla til hvor på et depot serveren du ønsker å lagre filen. Det vil også ha den eksisterende filen banen og navnet kom inn opp til toppen hvis du velger 'From Eksisterende Model "fra dialogboksen Nytt prosjekt og levert en fil.

URL: Dette er nettadressen til depotet serveren der ABACUS Enterprise filene er lagret. Du bør spørre den personen som administrerer serveren hva denne nettadressen skal være.

Bildet over viser et depot med fire (4) eksisterende ABACUS Enterprise prosjekter, etter inn nettadressen og trykke enter. Du vil se etter at du oppretter en ny Enterprise-fil, på neste skjermbilde for 'kassen', vil det være en annen mappe og fil under dette arkivet.

Notat

Hvis du bruker en https (SSL) server, og serveren ikke har en gyldig SSL-sertifikat (felles for intranett eller ikke-offentlige servere på grunn av de Kostnaden for SSL-sertifikats) Vil det være en ekstra skritt å ta. Du vil bli bedt om å godta alle tilkoblinger til denne serveren i dialogboksen som dukker opp permanent (det vil også vise litt mer informasjon på serveren). For å gjøre dette, type "p" (uten anførselstegn) og trykk Enter. ABACUS vil dukke opp en melding som minner deg om dette før du viser dialogboksen.

Notat

Du kan bli bedt om å logge inn på serveren i hvilket tilfelle den personen som er administrere serverenkan gi brukernavn og passord server. Også påloggingsinformasjon for alle servere som du har koblet til blir lagret slik at hvis en eller annen grunn de må fjernes kan dette gjøres via Verktøy | Alternativerog deretter på General fane ved å klikke Tilbakestill Subversion Lagret Påloggingog velge server fra nedtrekkslisten og klikke Clear Loginog velge OK i dialogboksen som kommer opp.

Notat

I motsetning til skjermbilde vist ovenfor, er vanligvis en enkelt ABACUS prosjektet inngår i hver ABACUS Repository fordi hvis mer enn ett ABACUS Prosjektet er opprettet i en enkelt ABACUS Repository, er kuleramme endring logg tall delt på tvers av alle ABACUS Prosjekter og dette kan forvirre brukerne.

Preferred Name: Dette påvirker både mappen og filnavnet som skal brukes (hvis det ikke allerede er tatt) når du oppretter filen på depotet server. Merk at en ny mappe opprettes automatisk på depotet server for hver fil (for ytelseshensyn, er ABACUS Enterprise filer som er opprettet i egen mappe under plasseringen bladde til i dialog).

Lagre arbeidskopi i Directory: Når en Enterprise-filen er opprettet på et oppbevaringssted server, lokale arbeidsgrupper filer må opprettes på datamaskinen, slik at du kan arbeide på filen uten å være koblet til nettverket. Dette er stedet du vil bla til når du ønsker å åpne / re-åpne en ABACUS Enterprise-fil.

Kassen en eksisterende Enterprise File

Dersom noen allerede har opprettet en ny Enterprise-fil, kan "kassa" på dette bildet, som laster ned en lokal kopi og setter opp de nødvendige filene så ABACUS gjenkjenner dette som en Enterprise-fil du. Dialogboksen ligner på New Enterprise File Dialog. Skriv inn URL i depotet (underkataloger kan inkluderes i URL), velg ønsket fil, og klikk OK. Lagt notatet under tHan fil vil da bli åpnet.

Notat

Du kan bli bedt om å logge inn på serveren i hvilket tilfelle den personen som er administrere serverenkan gi brukernavn og passord server. Også påloggingsinformasjon for alle servere som du har koblet til blir lagret slik at hvis en eller annen grunn de må fjernes kan dette gjøres via Verktøy | Alternativerog deretter på General fane ved å klikke Tilbakestill Subversion Lagret Påloggingog velge server fra nedtrekkslisten og klikke Clear Loginog velge OK i dialogboksen som kommer opp.

Enterprise File Forskjeller

Når du har opprettet en Enterprise-fil (enten en ny en, eller via 'checkout' av en fil laget av noen andre), en mappe vil bli opprettet for filen, og det vil vanligvis inneholde disse 3 hovedtyper av filer:

· '.abacus' Fil- Dette er den ABACUS filen selv. Endringer du gjør lokalt ikke er umiddelbart lagret i denne filen, er det bare skrevet til når du begår. Denne filen er et "normalt" ABACUS fil, kan det bli gitt til ikke-EE brukeresom et frittstående prosjekt (uten .log-fil)Eller brukes som utgangspunkt for en ny EE fil.

· '.changes' Fil- De lokale (ikke-iverk) endringer i filen. Hvis denne filen mangler, betyr det at det ikke er noen lokale endringer.

· '.loggfil- Denne filen har bare endringene som ble gjort av den siste brukeren (innholdet i brukerens .changes fil når de begått).

Notat

Det finnes ulike andre filer som kan opprettes under oppdateringen og begår prosesser, nemlig; ‘.changesbefore' fil- Denne filen er en kopi av .changes filen etter en oppdatering er utført, og brukes til automatisk avstemme eventuelle ID-konflikter mellom oppdatering og noen lokale (uengasjert) endres før begå; ‘.backup' fil- Denne filen er en kopi av .changes filen før en bruker lagrer mer lokale (ikke-iverk) endringer i .changes fil; og ‘.feil' fil- Denne filen er en kopi av de .changes fil hvis det var noen problem som forårsaket ABACUS å unnlate å åpne .abacus filen og brukeren valgte å gå tilbake sine endringer.Disse filene kan bli ignorert.

Åpne en fil

Å åpne en fil, trenger du bare å bla til der du valgte å lagre arbeidskopien, og åpne ABACUS fil som er lagret der. Når ABACUS ser at det er en .loggfilen (og kanskje en .endringer fil hvis du har gjort endringer), det vil behandle filen som en Enterprise-fil.

Oppdatere en fil

Utføre enn 'Update' vil undersøke om en nyere versjon av en fil ligger på serveren. Hvis det er, vil det avslutte den eksisterende filen, må du oppdatere til nyere fil fra serveren, og laste ned noen midlertidige filer som har et nummer som en forlengelse - f.eks 'Demo.125'. Disse filene er eldre versjoner av .log-filen, og brukes til å bestemme hvilke endringer har blitt gjort til en fil siden sist du oppdaterte den. Dette er nødvendig for å oppdage eventuelle konflikter som kan ha skjedd, slik at du kan løse dem.

Hvis under oppdateringsprosessen eventuelle konflikter ble funnet, Vil du trenger for å løse dem før du kan åpne filen på nytt (du kan avbestille men vil du bli bedt om å løse konfliktene på nyttneste gang du åpner filen).

Lagre en fil

Når du lagrer en fil, legger dette alle endringer du har gjort i .changes filen. Den gjør ikkemodifisere .abacus fil på dette stadiet - bare når filen er forpliktet til serveren vil det bli skrevet over (eller når du mottar en oppdatering fra serveren).

Hvor er "Lagre som"?

Det er ikke begrepet Lagre som for Enterprise-filer. Du kan imidlertid kopiere arbeidskopien .abacus fil, husk at det ikke vil ha lokale endringer i den.

Løse konflikter

Hvis andre brukere har engasjerte endringer i filen i en lignende del av filen for deg, kan det være noen konflikter mellom sine endringer og ditt. For eksempel kan en annen bruker sletter en komponent som du hadde oppdatere en eiendom på. Du må enten angre deres endring (hvis du er sikker på at deres børikke har skjedd), eller forkaste endringen (du kan deretter gå tilbake til filen og gjør et nytt endring).

Spesielt er det 4 klasser av konflikter som kan oppstå;

1. Slett - Når en bruker sletter et objekt som en annen bruker endringer. F.eks Bruker En slettet en komponent, men bruker B endret komponentens navn eller er koblet til den, eller lagt et barn komponent til det etc.

2. Egenskap - Når to brukere både endre nøyaktig samme 'attributt "av et objekt. F.eks Både Bruker A og bruker B endret en komponent navn eller sin beskrivelse eller verdien av en av sine eiendommer etc.

3. Referanse - Når to brukere endre nøyaktig samme 'referanse' et objekt har til et annet objekt. F.eks Både Bruker A og bruker B endret en komponent type eller kilde / vask komponenten festet til en tilkobling eller den koblede utsiktspunkt for et diagram etc.

4. Samling - Når to brukere endre en "samling" for et objekt. F.eks Både Bruker A og bruker B flyttet en komponent fra en av foreldrene til en annen eller re-bestilt en samling av barns komponenter.

Notat

Ulike inkonsekvente konflikter blir automatisk løst av ABACUS å redusere overhead på brukerne.For eksempel konflikt pan-zoominnstillinger for diagrammer er løst for å holde de nyeste pan-zoominnstillinger.

Begår Endringer

Når du velger å legge inn forandringene, ABACUS fil fra serveren er åpnet, din lokal endringene er utførtmot det, og så din lokale .abacus fil blir overskrevet med en som har endringene i den. Endringene fil deretter overskriver .log-filen, og både .abacus filen og .log-filen sendes til serveren.Hvis begå er vellykket en Commit dialog melding som vist nedenfor er gitt for å skrive inn en melding med begå.

Vise en logg over endringer

Til vise en logg over endringer i en Enterprise prosjekt, velge Fil| Se Logg...

Maksimal loggoppføringer: Dette som standard de siste 10 oppføringene men flere oppføringer kan hentes ved å endre verdien og klikke Hente knapp.

Revisjon: The Revisjon kolonne viser revisjonsnumre forpliktet til Enterprise server, som standard, i omvendt kronologisk rekkefølge.

Notat

De revisjonsnumre kan ikke være sammenhengende som bare ABACUS forplikter vil bli oppført, mens det samme Subversion repository kan brukes til andre ABACUS prosjekter og / eller andre versjonskontrollsystemer programmer.

Dato: The Dato kolonnen viser datoen at revisjonen ble forpliktet til Enterprise server.

Tid: The Tid kolonnen viser tiden på dagen (i 24 timers format) at revisjonen ble forpliktet til Enterprise server.

Forfatter: The Forfatter kolonnen viser Microsoft Windows påloggingsnavnet for brukeren som utførte begår fulgt av deres ABACUS brukernavn , Eller "Anonym" hvis brukeren ikke er autentisert og uregistrerte brukere fikk tilgang til Enterprise prosjektet på tidspunktet for iverksetting.

Logg Message: The Logg Message kolonnen viser begå melding som ble levert med revisjonen som per dialogboksen vist ovenfor.

Last ned revisjon XX som frittstående ABACUS fil: Hvis du velger en gitt revisjon i tabellen og klikk deretter på nedlastingsknappen vil du være i stand til å trekke ut det valgte ABACUS prosjektet revisjon fra serveren og lagre det som en lokal / frittstående ABACUS prosjektet.

Notat

Å rulle tilbake til en tidligere versjon kan du se denne Avolution samfunnet artikkelen .

(Admin) Last ned XML loggfilen for revisjon XX: Brukere med ABACUS Administrator evnen kan velge en gitt revisjon i tabellen og klikk deretter på Last ned for å hente ut det valgte ABACUS prosjektet loggfilen fra serveren og lagre det som en XML-fil.

Vise et revisjons Trail of Changes

Til vise et revisjonsspor av endringer til et gitt element (dvs. komponent, forbindelse, utsikt, barn osv) av en Enterprise prosjekt, høyreklikk elementet og velge Audit Trail..., Sett fra og til revisjonsområde og klikk Søke.

Notat

Når et element er slettet fra prosjektet du ikke lenger er i stand til å få tilgang til spesifikk sporingsinformasjon om dette elementet. Du kan imidlertid fortsatt få tilgang til "overordnede" komponent (for eksempel) og se sporingsinformasjon om sletting (i dette tilfellet notering ID av elementet som ble slettet).Videre er Component / vedlegg Connection et «eiendom» av tilkoblinger så skiftende en vedlagt komponent via Utforsker-vinduet eller på Diagrams vil vises i revisjonsspor for en tilkobling IKKE komponenten, og slette en tilkobling og opprette en ny tilkobling (som skjer hvis du høyreklikker 'Unattach "og deretter" Koble ...' i kataloger) vil resultere i tap av sporingsinformasjon for den opprinnelige komponent - tilkobling vedlegg helt.

Notat

Som standard revisjonssporet vil rekursivt se etter endringer i noen av barna til det valgte elementet. Dette kan resultere i lange svartider og følgelig revisjonsspor kan være begrenset til selve elementet ved å deaktivere Rekursive alternativ under Revisjons Alternativer"tannhjul" knappen på verktøylinjen i dialogboksen Audit Trail.

Fra Revision: Dette vil standard til første / eldste revisjon tilgjengelig for prosjektet på Enterprise server.

Til Revisjon: Dette vil tilbake til den siste / nyeste revisjonen tilgjengelig for prosjektet på Enterprise server.

Notat

Etter innstilling fra og til revisjonsområde klikk Søk-knappen for å hente noen konkrete endringer i det valgte elementet.

Revisjon: The Revisjon kolonne viser revisjonsnumre forpliktet til Enterprise server, som standard, i fremover kronologisk rekkefølge.

Notat

De revisjonsnumre er usannsynlig å være kontinuerlig som bare de revisjoner som er relevante for det valgte elementet vil bli vist og bare ABACUS begår vil bli oppført, mens det samme Subversion repository kan brukes til andre ABACUS prosjekter og / eller versjonskontroll programmer.

Dato: The Dato kolonnen viser datoen at handlingen brukeren ble gjort.

Notat

Datoen som vises er brukerhandling dato, ikke datoen revisjonen ble forpliktet til Enterprise server. Følgelig kan date foran den tilsvarende revisjon begår dato vist med Fil | Se Logg... kommando.

Tid: The Tid kolonnen viser tiden på dagen (i 24 timers format) at handlingen brukeren ble gjort.

Notat

Tiden som vises er brukerhandling tid, ikke tiden revisjonen ble forpliktet til Enterprise server. Følgelig tiden vil mest sannsynlig gå foran den tilsvarende revisjon forplikte tid vist med Fil | Se Logg... kommando.

Forfatter: The Forfatter kolonnen viser brukeren som utførte handlingen er Microsoft Windows påloggingsnavn etterfulgt av deres ABACUS brukernavn , Eller "Anonym" hvis brukeren ikke er autentisert og uregistrerte brukere fikk tilgang til Enterprise-prosjektet på tidspunktet for handlingen brukeren.

Notat

Forfatteren oppført i Audit Trail dialog ikke nødvendigvis samsvarer med forfatteren oppført i dialogboksen Vis logg over for samme revisjon. Dette er fordi Vis logg dialoglister den påloggede brukeren på tidspunktet for den forplikte mens Audit Trail dialoglister den påloggede brukeren på tidspunktet for handlingen brukeren, og det er mulig å ha en bruker gjøre endringer og sende sine. endringer fil til en annen bruker til å begå - slik tilfellet er når en ekstern bruker (for eksempel Avolution) er å jobbe på en EE prosjekt.

Detaljer: The Detaljer kolonnen viser de nøyaktige detaljene i handlingen brukeren som er registrert på Enterprise server.

Tupp

Det er nyttig å gruppe av Revision kolonne (som vist i dialogboksen ovenfor) og / eller bruker Handling kolonne til lett klassifisere endringene i element av interesse.

Bruk av Scripting med Enterprise-filer

Hvis du bruker scripting med Enterprise-filer, bør du være klar over hvordan du skal slette et objekt fra modellen. Vanligvis, når du sletter et objekt, vil du ringe .Delete () metoden på det, snarere enn bare å fjerne den fra sin overordnede.

F.eks hvis du hadde KOMP1 som forelder til KOMP2 og du ønsker å slette KOMP2 i skriptet, bør du ringe comp2.Delete (), heller enn comp1.Components.Remove (KOMP2).

Du kan bruke fjerne hvis du har tenkt å legge den KOMP2 objekt til et annet sted innenfor arkitektur, men det bør ikke brukes dersom hensikten er å slette objektet.

Det er et unntak til dette, for når du vil fjerne et objekt som "bor" andre steder i modellen. Når du ønsker å fjerne en standard eksempel fra en arkitektur / komponent / tilkobling, så ville du gjøre det ved å fjerne den fra forekomsten standard samling - arch1.Implementeringer.Fjern (Imp) - fordi slette den ville fjerne den fra alle instanser.

Riktig å bruke Delete i skript er viktig fordi hvis et objekt er fjernet fra objectmodel og ikke re-lagt, da det ikke vil være i stand til å bli plassert, men siden det ikke var spesielt 'slettet', Conflict Detection og oppløsning vil ikke gjenkjente en konflikt hvis en annen bruker var å forsøke å bruke det objektet i noen av sine endringer, og det endelige resultatet vil være en ødelagt sett endringer for den brukeren.

Se også

Hvordan er en arkitektur representert i ABACUS?


Arbeide med ABACUS filer

Navigasjon: Introduksjon til ABACUS>

Arbeide med ABACUS filer

Send kommentarer om dette emnet.

En ABACUS fil er en beholder for en modell av din arkitektur . Innenfor en enkelt ABACUS fil, kan du modellere en rekke arkitekturer ubegrenset antall ganger.

Når du først åpner ABACUS, er det ingen filer åpne. Å jobbe på arkitektur, må du enten lage en ny fil, eller åpne en eksisterende fil.

Når du åpner eller oppretter en ny fil, vil et tre i explorer vinduet automatisk vise. Dette explorer visning viser deg din arkitektur oppdatert. Når du lukker filen, vil treet i explorer vinduet også forsvinne.

For å opprette en ny ABACUS fil

1. Velge Fil| Ny ...

2. I dialogboksen Nytt prosjekt som vises (som vist nedenfor) Velgetil enten å skape et tomt modell, en modell fra et standard ABACUS bibliotek , En modell fra en tilpasset ABACUS bibliotek, en modell fra XML, MS Access , MS Visio , MS Excel , MS SQL Server En Enterprise Server modell eller en tilpasset ABACUS bibliotek (.abacuslib fil).

3. Klikk på OKknappen og følg eventuelle dialogbokser som kan vises.

Tupp

Du vil ikke bli bedt om å navngi filen før du lagrer eller lukker den. Det er en god idé å lagre filen så snart du har opprettet den. Da vil du ikke å bekymre deg for å navngi det senere i prosessen når du konsentrerer deg om andre komplekse ting (som fyller ditt arkitektur).

Opprett et nytt prosjekt

ABACUS Standard Libraries

ABACUS støtter over 100 offentlige rammer og notasjoner hvorav noen er vist nedenfor. Når du velger å opprette et nytt prosjekt fra en standard bibliotekbrukere har en rask start på modellering innenfor et etablert rammeverk tar full nytte av noen definerte elementtyper, attributter, notasjoner, synspunkter og maler eller mønstre. Ytterligere standardbibliotekene er fritt tilgjengelig gjennom Avolution Fellesskapet her .

Nytt prosjekt fra Standard Library

Hvis du vil lagre en ny ABACUS fil

1. Velge Fil| Lagre som

Tupp

Filnavn kan være hvilken som helst lengde, og kan inneholde alfanumeriske tegn og mellomrom. De kan ikke inneholde tilde (~) karakter, røret (|) karakter, spørsmålstegn eller tegn som vanligvis brukes til bane beskrivelser som backslash (\) - bortsett fra som en del av banen (?).

For å åpne en eksisterende ABACUS fil

1. Velge Fil| Åpne

Notat

Hvis du åpner en fil fra en delt nettverksplassering som allerede er åpen til en annen bruker, vil ABACUS gi deg lesetilgang. Ved bruk av ABACUS med lesetilgang, vil du ikke være i stand til å utføre skriveoperasjoner, slik som fyller ditt arkitektur og kjører evaluatorer. Du kan imidlertid vise arkitektur bruker explorer visning og 3D-visninger.

Se også

Hvordan er en arkitektur representert i ABACUS?


Arbeide med oversikter

Navigasjon: Administrasjon>

Arbeide med oversikter

Send kommentarer om dette emnet.

ABACUS prosjekter kan ha noen konfigurasjon av visninger (f.eks diagrammer, Diagrammer osv) lagret som et dashbord og disse lagrede instrumentbord kan være angitt som standard starter "skjerm" på åpne et prosjekt og / eller er tildelt en spesifikk brukergruppe og presentert for medlemmene av at brukergruppen når de logger seg på en ABACUS prosjekt.

Notat

For å konfigurere dashbord i en ABACUS prosjekt brukerlisensen må Administrator evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

Ser Dashbord

Et eksempel Application Portfolio Management (APM) dashbord

Hvis du vil vise en lagret Dashboard

1. Velge Utsikt| Dashbord

2. Velg en lagret dashbord fra listen over tilgjengelige oversikter.

Notat

Når du har valgt ABACUS vil bygge visningene som kreves for dashbordet, og dette kan ta noen sekunder. Vær tålmodig.

Administrerende Dashbord

Administrerende Dashbord

For å opprette en ny Dashboard

1. Åpne de nødvendige utsikt og ordne og forankre Vinduer som kreves for dashbordet.

2. Velge Utsikt| Dashbord| Administrer Dashbord ...

Notat

Hvis du ikke ser Behandle Dashbord menyvalget så du ikke har administrator evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

3. I dialogboksen som vises velger Lageknappen og skriv inn Dashboard navn i Opprett ny Dashboard dialog.

4. Klikk på OK knapp.

For å slette en eksisterende Dashboard

1. Velge Utsikt| Dashbord| Administrer Dashbord ...

2. I dialogboksen som vises velger Dashboard du vil slette fra listen, og velg Slett knapp.

Notat

Slette et dashbord vil også slette alle brukergruppeoppgaver til at dashbordet.

3. Klikk på OK knapp.

Å erstatte en eksisterende Dashboard

1. Åpne de nødvendige utsikt og ordne og forankre Vinduer som kreves for erstatning dashbordet.

2. Velge Utsikt| Dashbord| Administrer Dashbord ...

3. I dialogboksen som vises velger Dashboard du ønsker å erstatte fra listen, og velg Erstatte knapp.

4. Klikk på OKknappen for å bekrefte Dashboard Erstattet dialogen.

Å tildele en Dashboardsom standard Start-skjermen

1. Velge Utsikt| Dashbord| Administrer Dashbord ...

2. I dialogboksen som vises velger Dashboard fra listen du ønsker å tildele som standard start 'skjerm'og velger Tildele... knapp.

3. I dialogboksen som vises velger oppføring i User Groups kolonne.

Notat

Bare én dashbordet kan tildele som start "skjerm" så re-oppdrag vil fjerne oppdrag fra den forrige oversikten.Videre, hvis brukeren logger inn som medlem av en brukergruppe som har en tildelt dashbordet da den tildelte dashbordet vil bli åpnet i stedet for standardprosjektet dashbordet.

4. Klikk på OK knapp.

Hvis du vil tilordne en brukergruppe til en Dashboard

1. Velge Utsikt| Dashbord| Administrer Dashbord ...

2. I dialogboksen som vises velger Dashboard fra listen du ønsker å tildele en brukergruppe til og velg Tildele... knapp.

3. I dialogboksen som vises velger User Group (eller grupper)du ønsker å tildele dashbordet som "starte opp" skjerm for.

Notat

Hvis den samme User Group er tildelt flere oversikter deretter første oppdrag i listen vil bli brukt.

4. Klikk på OK knapp.

Til fraordne en brukergruppe fra en Dashboard

1. Velge Utsikt| Dashbord| Administrer Dashbord ...

2. I dialogboksen som vises utvide Dashboard elementet fra listen du ønsker å oppheve tildelingen en brukergruppe fra.

3. Velg Brukergruppe du ønsker å oppheve tilordningen og velg Fjern tildeling knapp.

4. Klikk på OK knapp.

Angi tillatelser

Tillatelser kan stilles for oversikter for å tillate dashbordet for å være synligOppdateringsmuligheter og / eller deleteabletil gitte brukergrupper.

Tillatelser Ledelse

Hvis du vil angi tillatelse for en Dashboard

1. Velge Utsikt| Dashbord| Administrer Dashbord ...

2. I dialogboksen som vises velger Dashboard fra listen du ønsker å angi tillatelser for, og velg Tillatelser ... knapp.

3. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

4. Som standard vil du se at Read, Update og Slett tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

5. Klikk på OK knapp.

Se også

Tilpasse ABACUS grensesnitt | Arbeide med Tillatelser


Arbeide med Tillatelser

Navigasjon: Administrasjon>

Arbeide med Tillatelser

Send kommentarer om dette emnet.

ABACUS prosjekter kan ha rollebaserttillatelser satt for hvert element i depotet. Spesifikt, finkornet Create-Read-Update-Delete (CRUD) Tillatelser kan settes på "objekt" (dvs. komponent eller tilkobling), visning og attributt (dvs. eiendoms) nivåer.

Oversikt

Når du arbeider med ABACUS Enterprise Server Gir ABACUS finkornede, rollebaserte crud tillatelser til å styre tilgangen av flere brukere til depotet.

Notat

For å konfigurere tillatelser i en ABACUS prosjekt brukerlisensen må Administrator evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

Tillatelser kan stilles for arkitekturer, komponent og tilkoblingstyper, egenskaper (via deres typer), maler, synspunkter og diagrammer, kataloger, matriser, diagrammer og 3Dvisninger. Når tillatelsene er angitt for en komponent eller tilkoblingstype alle forekomster av denne typen i noen arkitekturer i at prosjektet "arve" disse tillatelsene. På samme måte når en tillatelse er satt for en eiendom av en komponent eller tilkoblingstype, gitt eiendom på komponent eller tilkoblings tilfeller i noen arkitekturer i at prosjektet "arve" disse tillatelsene. Følgelig vil enkelte tillatelser brukes til synspunktene som disse elementene finnes. Når tillatelsene er satt for et diagram, utsikten og / eller innholdet av selve visningen har ulike tillatelser brukes til det.

Notat

Som standard ingen tillatelser er satt for elementene i en ABACUS prosjekt. Det er alle elementene er Createable, lesbar, oppdateres for og Deleteable av alle brukere. På denne måten tillatelser bør kun vurderes for et gitt element i depotet når en viss tillatelse er å være begrensetfor en bestemt brukergruppe. For eksempel, hvis tillatelser for et gitt brukergruppe ble lagt til et objekt (f.eks en komponent type), men igjen med alle tillatelser er aktivert, så dette er funksjonelt det samme som om at brukergruppen var ikke tilsatt til objektet.

Tillatelser kan ikkesettes for konkrete tilfeller av en arkitektur er elementer. For eksempel kan du ikke lage ett program komponent oppdaterbar enda en ikke. Å effektivt oppnå disse 'domene spesifikke tillatelser kan imidlertid Administrator satt opp spesifikke elementtyper for de gitte domener, for eksempel komponenttypene 'Application - CRM domene "og" Application - HR domene', og deretter sette rettighetene for hver type tilsvarende. Du kan lage spesifikke Gruppering typer for hvert domene og deretter fjerne oppdateringen tillatelse for domenet spesifikke gruppetype, og dette vil begrense kreasjoner innenfor og slettinger fra at Gruppering men ikke oppdatere til barna. Selvfølgelig om domenet spesifikke Gruppering ble skjult ved å fjerne leserettigheter da barna ville bli skjult og dermed ikke-oppdaterbar. Alternativt, hvis visninger (i stedet for explorer) brukes først og fremst til å administrere / vise depotet, en gitt visning for hvert domene kan opprettes, og deretter Administrator kan sette rettighetene for hver visning tilsvarende.

Administrere brukere og grupper

Tillatelser er definert på rolle eller gruppenivå, i motsetning til den enkelte bruker nivå, slik at mens medlemskap i gruppene kan endres, tillatelser kan være fast. Selvfølgelig hvis du ønsker en bestemt bruker tillatelse så bare gjøre dem en gruppe, eller mer presist opprette en gruppe med den brukeren som eneste medlem.

Det bør bemerkes at gruppene er atomisk, Er at de ikke kan arve tillatelser eller brukere fra til hverandre, og hvis en bruker tilhører flere grupper så er det mest "pessimistiske" gruppe tillatelse forrang fra sak til sak for den enkelte tillatelse (dvs. Lag -Les-Update-Delete). Hvis den samme brukeren er medlem av gruppe A og gruppe B og gruppe A har nettopp Lag-Les tillatelse for Application komponenttypene mens gruppe B har nettopp lest-Update tillatelse for Application komponenttypene så brukeren vil bare ha Les tillatelse til for eksempel Søknad komponent tilfeller.

Videre, som standard, anonyme brukere(det vil si brukere som ikke er definert eller som ikke har logget inn) har full tilgangtil prosjektet. Dette er for å sikre at tilgang er tilgjengelig i en innledende konfigurasjon. Å blokkere tilgangen av anonyme brukere bare ruten 'Tillat anonym bruker full tilgang til fil' i Administrer brukere / grupper dialogboksen vist nedenfor. Når ukontrollert anonyme brukere vil bare være i stand til å se Standards del av ethvert prosjekt.

Endelig er hvis 'Bruk Windows Brukernavn Pålogging' er sjekket brukernavn autentisering utført mot Windows-brukernavnet pålogginger på hver brukers maskin mot brukernavnet er oppgitt som per nedenfor. Det er hvis Windows Brukernavn Logg inn for en bruker gitt maskin eksisterer som et gyldig brukernavn da ingen passord er nødvendig, og brukeren blir automatisk godkjent. Merk: Dette gjør effektivt bruk av Windows Active Directory (AD) godkjenning.

Notat

Gitt at tillatelser bare definert når de trenger å bli tatt bort (begrenset) fra en bruker, alle brukere som ikke er medlem av en gruppe, eller en gruppe som ikke har noen tillatelser som er definert for det mot gjenstander, vil ha full tilgang til prosjektet.

Brukere og brukergrupper

For å opprette en ny bruker

1. Velge Fil| Administrere brukere / grupper

Notat

Hvis du ikke ser den Administrere brukere / grupper menyvalget så du ikke har administrator evne. Ta kontakt med din lokale ABACUS Administrator eller Avolution Support hvis du trenger denne evnen.

2. I dialogboksen som vises velger Legg til brukerknappen og skriver inn brukernavn og passord i Create New User dialog. Merk: Brukernavn og passord er case sensitive.

Notat

Hvis 'Bruk Windows Brukernavn Pålogging alternativet kontrolleres som beskrevet ovenfor så en dummy passord kan angis som autentisering vil bli utført i henhold til brukerens vinduets Brukernavn Pålogging bare.

2. Som standard vil du se at Brukere kan endre sitt eget passord. Ved behov kan det ABACUS Administrator fjern de muligheten for brukerne til å sette sitt eget passord av fjerne merketboksene.

Notat

Hvis brukere kan endre sitt eget passord de vil ha en Fil | Bytt passord...menyvalget for å gjøre det.Vær også oppmerksom på at hvis flere personer bruker samme brukernavn da en bruker kan endre passordet slik at ingen andre personer kan logge etterpå. Følgelig er det anbefalt praksis for å ha en enkelt brukernavn per faktiske person.

4. Eventuelt skriv inn e-postadressen din, Sted og Telefonnummer for brukerne for fremtidig referanse.

5. Klikk på OKknappen Opprett ny bruker dialog.

6. Klikk på OK knapp.

Notat

Når du har opprettet din første brukeren bør du vurdere å blokkere tilgangen av anonyme brukere ved å fjerne "Tillat anonym bruker full tilgang til fil 'i Administrer Brukere / dialoggrupper.Og når en bruker har blitt laget (og hvis en Enterprise-prosjekt, endringen forpliktet til server), neste gang prosjektet åpnes brukere vil bli bedt om å Logg inn for autentisert tilgangsom per dialogboksen vist nedenfor. Dersom Logg inn automatisk med disse detaljeneer krysset av blir brukernavn / passord-kombinasjon vil bli husket for prosjektet og brukt hver gang på åpningen. Å fjerne den lagrede påloggings velg Fil | Clear Saved Påloggingetter åpning, og du blir bedt om å logge deg inn igjen neste gang du åpner prosjektet.

Logg inn

For å slette en eksisterende bruker

1. Velge Fil| Administrere brukere / grupper

2. I dialogboksen som vises velger brukernavnet i Brukere panel som du ønsker å slette, og velg deretter Slett bruker knapp.

3. Klikk på OK knapp.

For å opprette en ny gruppe

1. Velge Fil| Administrere brukere / grupper

2. I dialogboksen som vises velger Legg til gruppeknappen og skriv inn et gruppenavn i grupper panel.

Notat

Gruppenavn må være unike.

3. Klikk på OK knapp.

Til kopiere et eksisterende Gruppe

1. Velge Fil| Administrere brukere / grupper

2. I dialogboksen som vises velger Kopiere Gruppe knapp.

Notat

En lik gruppe vil bli opprettet prefiks "Kopi av".Som standard alle tillatelser fra den kopierte gruppen vil bli duplisert for "Kopi av" gruppe inkludert eventuelle brukeren oppdraget.

3. Gi nytt navn til "Kopi av" gruppe som hensiktsmessig å bruke Rediger gruppeeller sakte dobbeltklikk.

For å slette en eksisterende gruppe

1. Velge Fil| Administrere brukere / grupper

2. I dialogboksen som vises velger du gruppenavnet i grupper panel som du ønsker å slette, og velg deretter Slett gruppe knapp.

Notat

Enhver bruker oppdrag for konsernet vil også bli fjernet.

3. Klikk på OK knapp.

Å tildele en bruker til en gruppe

1. Velge Fil| Administrere brukere / grupper

2. I dialogboksen som vises velger brukernavnet i Brukere-panelet som du vil gi til en gruppe og dra og slippdet på gruppenavnet i grupper panel som du ønsker å tilordne den til.

3. Klikk på OK knapp.

Notat

Gruppen (e) som en bruker er tildelt vises ved å utvide Brukernavn i Brukere panelog brukerne som er tilordnet en gruppe vises ved å utvide gruppenavnet i grupper panel. For eksempel, i skjermbildet over, er "AS1-Aus" user tildelt tre (3) grupper, nemlig; "App Support Team 1", "Virkelig" og "Australia".

Til fraordne en bruker fra en gruppe

1. Velge Fil| Administrere brukere / grupper

2. I dialogboksen som vises utvide konsernets navn som inneholder bruker oppgave som du ønsker å oppheve tilordningen og velge brukernavnet.

3. Klikk på Fjern tildeling User knapp.

4. Klikk på OK knapp.

Slik importerer Brukere og / eller grupper (og eventuelle samsvarende tillatelser)

1. Velge Fil| Administrere brukere / grupper

2. Klikk på Import knapp.

3. I dialogboksen som dukker opp Blatil og åpne ABACUS prosjektet som inneholder Brukere og / eller grupper (og tillatelser) du ønsker å importere til det aktuelle prosjektet og klikk Åpne. Brukere og grupper vil bli importert og en dialog Import Results vises oppsummerer import av Brukere og / eller grupper. Klikk på OK knapp.

Notat

Hvis de importerte brukere eller grupper som allerede eksisterte i det aktuelle prosjektet så vil de bli slått sammen med eksisterende brukere eller grupper.

4. Klikk på OKknappen tilbake i hoved Administrer brukere / dialoggrupper.

5. Hvis det er noen matchende Typer, Utsiktspunkt, maler eller arkitekturer mellom det aktuelle prosjektet og ABACUS prosjektet du importerer fra, komplett med tillatelser som ikke allerede finnes i det aktuelle prosjektet er adgangen importert og en ny dialog Import Results vises oppsummerer importen. Klikk på OK knapp.

Notat

Tillatelser er bare lagt til eksisterende Typer (og deres egenskaper), Utsiktspunkt, maler eller arkitekturer for grupper der tillatelsene ikke allerede finnes for konsernet. Enten fordi konsernet er ny eller konsernet allerede eksisterte i det aktuelle prosjektet, men ingen tillatelser var blitt tildelt for at konsernet til dette elementet. Det finnes ingen "sammenslåing" av tillatelser for samsvarende elementer der tillatelser allerede eksisterte for konsernet i det aktuelle prosjektet.

Angi tillatelser

Tillatelser kan stilles for arkitekturer, komponent og tilkoblingstyper, egenskaper (via deres typer), maler, synspunkter og diagrammer, kataloger, matriser, diagrammer end 3Dvisninger. Når tillatelsene er angitt for en komponent eller tilkoblingstype alle forekomster av denne typen i noen arkitekturer i at prosjektet "arve" disse tillatelsene. På samme måte når en tillatelse er satt for en eiendom av en komponent eller tilkoblingstype, gitt eiendom på komponent eller tilkoblings tilfeller i noen arkitekturer i at prosjektet "arve" disse tillatelsene. Følgelig vil enkelte tillatelser brukes til synspunktene som disse elementene finnes. Når tillatelsene er satt for et diagram, utsikten og / eller innholdet av selve visningen har ulike tillatelser brukes til det.

Tillatelser Ledelse

Hvis du vil angi tillatelse for en komponent (eller Connection) Type

1. Utvid Typergren av treet.

2. Utvid Komponent (eller Connection) Typergren av treet.

3. Utvide Grupperder det er nødvendig.

4. Høyreklikk på Komponent (eller Connection) Typedu ønsker å sette rettighetene for, og velg Rediger tillatelser.

5. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

6. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

Notat

Lag tillatelse styrer også når du kan kopiere et element. Følgelig, for å være i stand til å kopiere et element krever Lag tillatelse for alle sine barn (siden du vil kopiere elementet betyr kopiere alt under den). Fjerne Update tillatelse fra et element fjerner muligheten til å endre den type selv, selv om brukeren har Designer add-on, og det også fjerner Update tillatelse for alle sine eiendommer. En forelder element må ha Update tillatelse til å være i stand til å Lag noen barn elementer eller Slett sin eksisterende barn elementer. Slett tillatelse for et element krever også slette tillatelse for alle sine barn. Slett tillatelse for komponenter krever også Update tillatelse fra alle de vedlagte tilkoblinger.Og til slutt, fjerne slette tillatelse fra et element fjerner muligheten til å slette den type selv, selv om brukeren har Designer add-on.

7. Klikk på OK knapp.

Å sette tillatelse for en gruppe av Component (eller Connection) Typer

1. Utvid Typergren av treet.

2. Utvid Komponent (eller Connection) Typergren av treet.

3. Høyreklikk på Gruppesom inneholder komponent (eller Connection) Typer som du ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

6. Klikk på OK knapp.

7. I dialogboksen som dukker opp klikker du på Ja knapp.

Hvis du vil angi tillatelse for en eiendom

1. Utvid Typergren av treet.

2. Utvid Komponent (eller Connection) Typergren av treet.

3. Utvide Grupperder det er nødvendig.

4. Velg Component (eller Connection) Type som inneholder eiendommen du ønsker å angi tillatelser for.

5. I vinduet Egenskaper Høyreklikk på Eiendomdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

6. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

7. Som standard vil du se at de lese og oppdatere tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

Notat

Egenskaper som har hatt Update tillatelse fjernet er vist i kursivi vinduet Egenskaperog deres verdier kan ikke oppdateres ved at rollen. Også evnen til å endre detaljene for en eiendom (f.eks navn, enheter osv) krever både Update tillatelse på eiendommen og Designer add-on.

8. Klikk på OK knapp.

Hvis du vil angi tillatelse for en mal

1. Utvid Malergren av treet.

2. Bla til Malat du er interessert i.

3. Høyreklikk på Maldu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at Les tillatelse er tilgjengelig. Fjern tillatelse av fjerne merketi boksen.

6. Klikk på OK knapp.

Hvis du vil angi tillatelse for en Viewpoint

1. Utvid Synspunktergren av treet.

2. Utvide Grupperder det er nødvendig.

3. Høyreklikk på Utsiktspunktdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

6. Klikk på OK knapp.

Slik stiller tillatelsen til et Architecture

1. Utvid Arkitekturergren av treet.

2. Utvid til Arkitekturat du er interessert i.

3. Høyreklikk på Arkitekturdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at Les tillatelse er tilgjengelig. Fjern tillatelse av fjerne merketi boksen.

6. Klikk på OK knapp.

Hvis du vil angi tillatelse for en Katalog

1. Utvid Katalogergren av arkitekturen du er interessert i.

2. Utvide Grupperder det er nødvendig.

3. Høyreklikk på Katalogdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

6. Klikk på OK knapp.

Hvis du vil angi tillatelse for en Matrix

1. Utvid Matrisergren av arkitekturen du er interessert i.

2. Utvide Grupperder det er nødvendig.

3. Høyreklikk på Matrixdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

6. Klikk på OK knapp.

Hvis du vil angi tillatelse for en Diagram

1. Utvid Diagrammergren av arkitekturen du er interessert i.

2. Utvide Grupperder det er nødvendig.

3. Høyreklikk på Diagramdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

Notat

Selv om du kan stille crud tillatelser direkte for et diagram, bør det bemerkes at tilgangen av elementene i diagrammet kan påvirke rettighetene til selve visningen. For eksempel, hvis det er enda bare ett element på det syn som har hatt sin lese eller oppdatere tillatelse fjernet da diagrammet vil ha sin Update tillatelse fjernet. Dette er fordi; a) elementene på visningen som har hatt sin Les tillatelse fjernet vil ikke bli vist på visningen forlate "white space" der du ellers kunne plassere noen nye elementer hvis utsikten var oppdateres, og b) elementene på den oppfatning at har hatt sin Update tillatelse fjernet kunne da ha andre elementer slippes på dem til å bli barn hvis utsikten var oppdateres. Også Opprett og Oppdater tillatelse for et diagram krever at alle elementene på utsikten har Les tillatelse og komponentene har Oppdater tillatelse (dette er fordi å flytte en komponent til en annen komponent, må du være i stand til å oppdatere det siden det vil bli et barn).

6. Klikk på OK knapp.

Hvis du vil angi tillatelse for en 3D-visning

1. Utvid 3D Viewsgren av arkitekturen du er interessert i.

2. Utvide Grupperder det er nødvendig.

3. Høyreklikk på 3D-visningdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

6. Klikk på OK knapp.

Hvis du vil angi tillatelse for en Chart

1. Utvid Diagrammergren av arkitekturen du er interessert i.

2. Utvide Grupperder det er nødvendig.

3. Høyreklikk på Chartdu ønsker å sette rettighetene for, og velg Rediger tillatelser.

4. I dialogboksen som vises, klikker du på Legg til...knappen og velg Gruppedu ønsker å legge ved enten å dobbeltklikke på den eller velge den og klikke OK knapp.

5. Som standard vil du se at opprette, lese, oppdatere og slette tillatelser er alle tilgjengelige. Fjern tillatelsene etter fjerne merketde aktuelle avmerkingsboksene.

6. Klikk på OK knapp.

Se også

Hvordan er en arkitektur representert i ABACUS?


Skrive Scripts

Navigasjon: Simulerer din arkitektur>

Skrive Scripts

Send kommentarer om dette emnet.

The Script Editor er et enkelt og funksjonelt verktøy for å skrive og gjennomføring av VB eller C # script mot i dag åpnet ABACUS fil(Bibliotekene ikke støttes i scripting). Den har de vanlige Åpne fil, Lukk og Lagre kommandoer, slik at du kan lagre og hente skript du skriver. Det har også en grunnleggende gjennomgang og feilsøke anlegget. The Script Manager lar deg enkelt utføre de ulike skript som du har skrevet ved å plassere et menyelement for dem direkte i Verktøy-menyen.

Du får tilgang til Script Editor

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Velge Verktøy | Script Editorog vinduet Script Editor åpnes. Så enten;

3. Åpne et eksisterende skript via Fil | Åpne i Script Editor menyer,

eller

3. Åpne et eksempel script via Eksempel element i Script Editor menyer,

eller

3. Angi standard språk til enten VB eller C # via Språk element i Script Editor menyer,

eller

3. Åpne scripting spesifikk Hjelp via Hjelp element i Script Editor menyene

Når du skriver manus, må du følge enten VB eller C # syntakssom per innstillingen under Språk element i Script Editor menyene.

NOTAT:

· Hvis du vil bruke standard VB funksjoner som MsgBox ()du må inkludere Importen Microsoft.VisualBasicuttalelse i begynnelsen av skriptet. Dette var ikke nødvendig før versjon 3.0 av ABACUS.

· Denne hjelpen omfatter ikke informasjon om hvordan du skriver VB script, og heller ikke inneholder det en VB referanse. Føl deg fri til å skrive skript i din favoritt IDE eller redaktør, deretter kopiere og lime dem inn i Script Editor.

Når du først starter Script Editor, vil Script Editor være tom. Du får tilgang til et skjelett script gjennom Eksempler menyen. Første gang du starter Script Editor, bør du kjøre Mal skjelettet for å se at det fungerer. I tillegg er det to eksempel scripts som kan nås via Eksempler menyen.

Å skrive en nyttig script må du referere til ABACUS ObjectModel. Den er gjort tilgjengelig for skriptet ved å inkludere Importen ABACUS.ObjectModeluttalelse på hodet av skriptet. En komplett referanse til hele ABACUS objektmodellen er inkludert i Script Editor. Du finner den ved å velge Hjelp | Innholdfra vinduet Script Editor.

Den script editor inneholder mange nyttige funksjoner for å skrive manus, inkludert Autofullfør som vist i skjermbildet nedenfor. Men for en enda bedre brukeropplevelse MS Visual Studio kan integreres med ABACUS og detaljerte instruksjoner er tilgjengelige her .

Script Editor med Autofullfør

For å bruke Script Manager

1. Kontroller at du har ABACUS fil, Som inneholder din befolket arkitektur, åpne.

2. Velg Verktøy | Script Manager.

3. Klikk på Legg tilikon og en Åpneåpnes.

4. Bla til ABACUS Script (.abacusscript, .vb Eller .cs) Fil du ønsker å legge til Verktøy-menyen.

5. Klikk OKog en referanse til skriptet vil bli vist i vinduet Script Manager. Skriv inn navnet på skriptet som du ønsker det skal vises i Verktøy-menyen. Merk: Script Manager-vinduet kan bli endret for å se hele banen hvis det er nødvendig.

6. Gjenta trinn 3-5å lage lenker til flere ABACUS skript.

7. Klikk Lukkeå lukke Script Manager og merk at ABACUS script (e) nå vises under Verktøy-menyen.

Å kjøre et skript

Enten;

1. Åpen, skriv inn, eller kopiere og lime inn i skriptet du vil kjøre, så det vises i hovedvinduet til Script Editor.

2. Klikk på Løpe knapp.

3. Hvis skriptet inneholder feil, vil feil Beskrivelse delen på bunnen av Script Editor liste detaljene inkludert linjenumrene. NOTAT: Hver enkelt feil i feilbeskrivelsen delen kan være dobbelt-klikket for å ta deg til den tilsvarende linje i manuset.

- eller -

1. Velge Verktøyog deretter ABACUS Script navn menyelement som er opprettet med Script Manager.

2. Hvis skriptet inneholder feil, vil Script Editor åpnes med innholdet i skriptet vises i hovedvinduet (uthevet på linje med den første feilen) og Feil Beskrivelse delen på bunnen av Script Editor lister opp detaljer eller feilen (e) inkludert linjenumrene. NOTAT: Hver enkelt feil i feilbeskrivelsen delen kan være dobbelt-klikket for å ta deg til den tilsvarende linje i manuset.

Scripting Compilation feil

Compilation feil oppstår når syntaksen til skriptkode er ikke riktig. Disse feilene vil dukke opp nederst i vinduet i feil seksjon, med en beskrivelse av feilen, og et linjenummer. Det er linjenummeret som skiller en samling feil fra en Runtime feil (se nedenfor), som ikke vil ha et linjenummer. Kompilering feil kan dobbeltklikket å hoppe til og markere bestemt linje i spørsmålet.

Scripting Runtime feil (Viktig)

Runtime feil oppstår etter at skriptkode har blitt kompilert uten feil, men det oppstår en feil under kjøring (se eksempler ned ytterligere). Runtime feil er viktige fordi de kan føre til ødelagte modeller, når gjenstander laget og referert til av andre objekter i modellen, er ikke selv en del av modellen (som regel fordi en runtime feil har oppstått før koden som ville ha plassert dem i modellen et sted, ble henrettet).

Hvis skriptet skaper objekter som skal legges til modellen, kan du unngå korrupsjon forårsaket av en runtime error ved å lagre skriptet, lukking scripting, og utfører en angre på endringene som ble opprettet av script (hvis skriptet ikke full normalt ). Men det finnes også andre måter å unngå korrupsjon forekommer (se nedenfor). NotatEventuelle skript som bare leser fra modellen og ikke skrive til den, er trygge og vil ikke skape noen problemer, uansett om runtime feil oppstår under utførelsen.

For å unngå korrupsjon, når du skriver en skriptkode som skaper objekter og legge dem til objektmodellen, er det foreslått at gjenstandene blir lagt til modellen så snart som mulig dersom de blir referert til av andre objekter.

For eksempel, hvis du oppretter en ny tilkobling, og 2 nye komponenter, og deretter feste dem sammen, er det best å lage den første komponenten, legge den til modellen, så det andre og legge den, og deretter opprette tilkoblingen og legge den, og så til slutt skape vedleggene. Dette betyr at hvis det skulle være en kjøretidsfeil som avbryter skriptet, alle objekter som kreves for å være i objectmodel før et vedlegg er opprettet, er i modellen. Korrupsjon kan oppstå hvis du for eksempel bare forbindelsen hadde blitt lagt, vedleggene gjort, og deretter en runtime feil oppstod før skriptet endelig lagt de nye komponentene til model.Corruption kan oppstå når et objekt som er referert til av et annet objekt i den objectmodel, er i seg selv ikke i objectmodel.

Eksempel runtime feil inkluderer:

· Objekt referanse ikke satt til en instans av et objekt - dette skjer når en gjenstand variabel er en null referanse, og en fremgangsmåte eller eiendom på at objektet er i bruk. Null referanser kan sjekkes ved å "Hvis objectVariable Er Ingenting Så ... '

· Indeksen var utenfor grensene av tabellen - dette skjer når en rekke leses med en indeks som er utenfor grensene - f.eks mindre enn 0 og lik eller større enn den lengde / Count i matrisen. Array eller Samling lengde kan sjekkes ved .Length eller .Count egenskaper hhv.

· Ingen tillatelse Unntak - Du har ikke tillatelse til å ... - dette skjer hvis du ikke har tillatelse til å gjøre det gitt endring

· Primary Key Unntak - Duplicate / mangler navn / ID - dette vil skje hvis en endring er gjort til en unik egenskap som er i konflikt med et annet objekt. F.eks Arkitekturer må være unikt ved navn, likeså med standarder.

· Referanseintegritet Unntak - Stille et referansefelt til et objekt som ikke er gyldig. F.eks legge "ingenting" eller null som et barn til mange av samlingene i objectmodel.

· Zero Lengde Unntak - dette kan skje hvis du prøver å sette navnet på et objekt til en tom streng. De fleste objekter krever navnene deres for å ha minst en karakter.

Import uttalelser

Vær oppmerksom på at ved starten av skjelettet skript det er utsagn som Importen ABACUS.ObjectModel. Disse uttalelsene vil ikke inkludere en dll som ikke allerede er referert av manuset - deres formål er å gi en "snarvei" til å måtte oppgi hele navnet på en klasse.

For eksempel, for å erklære en variabel av typen CComponent (som representerer en komponent i ABACUS), med Importen ABACUS.ObjectModeluttalelse mot toppen av manuset, ville bare krever det å bli erklært som dim komp som CComponent, Fordi kompilatoren vet å se i ABACUS.ObjectModel navnerom for CComponent klassen. Uten import uttalelse, ville det ha å bli erklært som dim komp som ABACUS.ObjectModel.CComponent. En sammenstilling (som Mscorlib.dll eller System.Windows.Forms.dll) kan inneholde mer enn ett navnerom - den Imports uttalelsen er for disse navnerom, ikke for menighetene selv. Den ABACUS.ObjectModel.dll forsamlingen bare har én ABACUS.ObjectModel navne tilgjengelig via skripting.

Automatisk refererte forsamlinger

Følgende DLL-filer er referert automatisk av Scripting:

· Mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (implisitt referert av kompilatoren)

· ABACUS.ObjectModel.dll

Å foreta ytterligere referanser til enten andre NET forsamlinger, eller dine egne forsamlinger, se neste avsnitt på #ImportDLL uttalelse.

#ImportDLL Statement

Starter i ABACUS 3.1, kan du referere til flere samlinger som du kan kreve for skripting med bruk av #ImportDLL uttalelse. For eksempel, hvis du ønsket å få tilgang til en egendefinert DLL av deg og utnytte funksjonaliteten i den, vil du plassere den i ABACUS katalog og inkluderer uttalelsen som den første linjen (e) i skriptet. Hvis det er en .NET dll, da normalt at du ikke trenger å oppgi hele banen, bare DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.xml.dll

Noen andre ting å merke seg:

1. Fordi DLL-filer trenger å bli funnet ved kompilering og kjøring, begrenser dette tilpassede (ikke NET) DLL-filer for å bli plassert i ABACUS programmappen bare.

2. #ImportDLL uttalelser må være den første linjen (e) av et skript - hvis du har 5 uttalelser, så de bør være på de første 5 linjer med skriptet

3. En #ImportDLL uttalelse plasseres hvor som helst, men de første linjene av script (f.eks hvis den ble plassert etter en kommentar eller et Importen setning) vil ikke fungere skikkelig og / eller kan føre til urelaterte kompilatorfeil.

#ImportDLL med Office Assemblies

Hvis du har Microsoft Office installert, og skriptet krever Office Interop forsamlinger, er det mulig å referere dem ganske enkelt ved hjelp #ImportDLL med forsamlingen navn (som er nevnt nedenfor, f.eks #ImportDLL Excel). Ved hjelp av denne metoden har den fordelen at en absolutt dll banen må ikke brukes, slik at manuset er mer portabel (skal fungere på både Office 2003 og 2007 uten å redigere script).

Når du bruker denne funksjonen, blir GAC (Global Assembly Cache) søkte for Interop montering, og manuset kompilerer med banen til at forsamlingen om funnet. Hvis det ikke blir funnet, vil scripting sjekke ABACUS program katalogen (som inneholder Excel og Visio interops only). Hvis den forespurte Interop ikke er funnet av denne tiden, er en advarsel vises.

De interops er vanligvis ikke installert i GAC hvis du har installert Microsoft Office før du installerer .NET Framework (som er en del av hele ABACUS installasjon). Du kan installere dem ved å utføre alternativet Endre for Microsoft Office fra Legg til / fjern programmer, og velg NET programmerbarhet alternativer. For mer info, se denne artikkel på MSDN.

Menighetene som denne snarveien som støttes er:

· Adgang

· Access.Dao

· Excel

· Kurve

· MSProject

· Outlook

· OutlookViewCtl

· Owc11

· PowerPoint

· Forlegger

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Word

It is not entirely clear if all the above assemblies are useful, but they have been included in this feature regardless as some users may have a need for even the obscure assemblies.

See Also

Simulating your architecture