CHM Ediutf-8


Jak używać liczydła (Przegląd)

Nawigacja: Wprowadzenie do ABACUS>

Jak używać liczydła (Przegląd)

Wyślij komentarzy w tym temacie.

Ten temat zawiera podstawowy przegląd zadań związanych z wykorzystaniem Abacus.

Poniższy diagram ilustruje proces analizy oparte na architekturze ABACUS przewiduje, że rozwija aktualną architekturę do nowego lub docelowej architektury.

Proces ABACUS

Aby używać liczydła:

1. Rewizja - Przed użyciem Abacus, musisz zebrać wszystkie informacje masz na temat architektury i jej wymagania.

· Architektura - Zidentyfikować potencjalne elementy architektury i sposobu interakcji. Nie powinno być tylko kilka komponentów na najwyższym poziomie. Są to tak zwane "zasadnicze elementy". Nawet najbardziej skomplikowane architektury powinien mieć mniej niż 10 podstawowych elementów. na przykład Zasadnicze elementy architektury firma ubezpieczeniowa może być polityka, wpływy, roszczeń i płatności.

· Wymagania- Musisz wiedzieć, czego oczekuje się od architektury w celu ustalenia, czy wynik jest zadowalający. na przykład Liczba transakcji na godzinę.

· Gdzie można go znaleźć? - Informacje te mogą pochodzić od wymagań specyfikacji, dokumentów projektowych, wywiadów z zainteresowanymi stronami, wdrożonej kodu itp zasadzie każdy materiał, który jest dostępny oferuje ABACUS informacje na temat architektury.

2. Zaludniać -Użyj Abacus modelować swoją architekturę i określić wymagania architektury będą mierzone.

· Architektura - W ABACUS zaczynasz z pustym architektury - trzeba zaludniać ono. Oznacza to, wprowadzając wszystkie informacje zebrane powyżej można architektury. Możesz wypełnić swoją architekturę ręcznie (za pomocą menu prawego przycisku myszy), można też wypełnić go automatycznie (z programu Microsoft Visio, Excel, Access itp). Zazwyczaj najwyższym, poziomy (bardziej abstrakcyjne) architektury będą wypełniane ręcznie, a niższe poziomy (więcej beton) zostanie wypełnione automatycznie.

· Wymagania - Jak dodawać elementy i połączenia, należy określić ich właściwości. W większości przypadków te właściwości będą wymagania architektury. Na przykład, jeśli masz węzła MIPS 1250 / klastra, należy dodać węzeł jako składnik, a następnie dodać właściwość wydajności i przypisać wartość 1250 MIPS.

3. Analizować - Użyj Abacus elegancko analizy i wizualizacji złożoną strukturę architektury. Ty można przeanalizować strukturę na szereg sposobów i z wielu punktów widzenia, takich diagramów, 3D i Explorer. Alternatywnie możesz użyć jakieś bardziej konkretne poglądy, co następuje:

· Wykres swoją architekturę - aby uzyskać wydajność (czas odpowiedzi, przepustowość, etc.), koszty (bar, pie, itp) lub evolvability (przestrzeń możliwości, kompromis, itp) poglądy.

· Tworzenie raportu na temat architektury.

4. Symulować - Użyj Abacus symulować architektury w wydajności, dostępności, kosztów, otwartość, etc.

· Aby to zrobić, wykonaj jedną z symulatorów. ABACUS ocenia swój Architektura ze swoimi wymaganiamiprzez przeprowadzenie symulacji. Czyta i analizuje obecną architekturę, prowadzi symulacje i oblicza kilka nowych właściwości. Właściwości te są następnie zapisywane z powrotem do architektury. Nowe właściwości są dane starasz się analizować, takie jak wykorzystanie, czas odpowiedzi, przepustowość,% dostępności, TCO itp

5. Inżynier- Wykorzystanie ABACUS odpowiedzieć na różne "co by było gdyby" i kontrolować rozwój architektury. Inżynieria jest proces powtarzania Wypełnianie - Analiza - Symulacja cykl.

· W tym momencie,'veprawdopodobnie opracowany zrozumienie Aktualny Architektury i wyróżnione obszary, musisz rozwijać. Dość często jednak trzeba powtórzyć wypełnić - Analiza - Symulacja procesowi kilka razy. Będzie to prawdopodobnie dlatego, że może to potrwać kilka iteracji, zanim znajdziesz docelową architekturę. Ponadto, jeśli architektura jest bardzo skomplikowane, możesz powtórzyć ten proces dla każdego architektonicznego "poziom".

6. Planprzyszłość architektury korzystając z informacji podanych przez ABACUS.

Notatka

Jeśli nie próbujemy się rozwijać istniejącą architekturę, być może trzeba będzie powtórzyć niektóre kroki kilka razy, a w innej kolejności. To zależy od tego, co chcesz do. Na przykład, jeśli jesteś projektowania nowej architektury, prawdopodobnie tylko zapełnić architekturę raz, a następnie za pomocą liczydła przez długi okres czasu, aby kierować przyszłą ewolucję (y) architektury. Z drugiej strony, jeśli kupujesz nową architekturę i mają kilka opcji do wyboru, musisz Odkryj i wypełnić dla każdej z alternatyw, a następnie analiza i symulować każdy niezależnie przed wykonaniem ostatecznego porównania na tym koniec.

Zobacz też

Co ABACUS zrobić? | Co to jest architektura? | Jak architektura reprezentowana w ABACUS? | Wypełnianie swoją architekturę | Analizując swoją architekturę | Symulacja swoją architekturę

© 2001-2015 Avolution Pty Ltd. Wszystkie prawa zastrzeżone.


Co to jest architektura?

Nawigacja: Wprowadzenie do ABACUS>

Co to jest architektura?

Wyślij komentarzy w tym temacie.

Architektura jest abstrakcyjny pojęcie- Nie fizyczny rzecz, Jest to bogaty i wszechstronny opis i zrozumienie struktury systemu - uchwycenie komponenty i jak są one połączone (interakcje). Ponieważ pojęcie architektury jest tak wszechogarniająca, że ​​ma fundamentalne znaczenie dla kosztów, dostępności, evolvability, otwartości i wydajności systemu. Dźwięk architektura jest warunkiem wstępnym z nagłośnieniem.

W ABACUS, modelować swoją architekturę. Dla uproszczenia nazywamy ten model architektoniczny architektura.

Poniższy schemat przedstawia typową architekturę 5 podzespoły (w hierarchii) połączone 2 połączeń. Etykiety wskazać nazwiska podane różne części architektury w ABACUS.

Prosta architektura

ABACUS uważa wszystkie te rzeczy, aby być częścią architektury:

· podzespołyreprezentowania tych podmiotów swojej architektury które można opisać jako "rzeczy". Dla firmy ubezpieczeniowej, elementy mogą być systemy dla polityki przetwarzania, roszczeń, płatności i wpływów.

· Znajomościstanowią relacje między tymi komponentami. Na przykład, w firmie ubezpieczeniowej, przychody są generowane dla ważnych polityk, roszczenia są wobec obowiązujących zasad, a ważne roszczenia spowodować płatności. Myśląc architektonicznie - szczególnie, gdy za pomocą liczydła - połączenia są równie ważne, jak komponentów, a są one rozpatrywane w niemal identyczny sposób.

· Wszystko w drzewie może mieć Właściwości, Właściwości są takie rzeczy jak sposób, w jaki wymagają systemu do wykonania, liczba linii kodu nie ma, odsetek tych linii, które są komentarze itp ABACUS uważa wszystkie te rzeczy, aby być częścią architektury.

· Używając hierarchie (to znaczy. pod-elementy i sub-połączenia), Można ukryć informacje i de-skomponować architekturę. Model architektoniczny ABACUS jest niezwykle elastyczny. Każdy składnik, na każdym poziomie mogą być związane z jakimkolwiek innym komponentem w innym poziomie przez dowolne połączenie na każdym poziomie.

· ZałącznikJest to działanie, dzięki któremu składniki Porty są zobowiązane do związkurole. Porty i Role to interfejssmiędzy komponentami i połączeń. Są one wykorzystywane do mocowania połączenia składników. Połączenia mają źródło i umywalkę rola(ułatwiając przepływ danych z elementu źródłowego składnika sink)i koncepcyjnie, komponenty mają porty. Dla uproszczenia, jednakże w ABACUS otwory elementów nie są pokazane, a role przyłączeniowe są bezpośrednio przyłączone do samych elementów.

· Komponenty i połączenia są pewne Rodzaj, To jest przede wszystkim do celów klasyfikacji. Na przykład polityka, roszczenia, płatności i wpływy są elementy typu "System". Prawidłowe polityki, ważne są roszczenia, itp połączenia typu "transakcja". Type przypisany do elementu lub połączenia zapewnia szablon do właściwości i standardów ma. Na przykład, typu komponent serwera może mieć "Marki i modele" standardi nieruchomości Adres IP. W przeciwieństwie do innych sztywnych narzędzi z podstawowej relacyjnej bazy danych (RDB) back-end, w ABACUS można swobodnie tworzyć własne nowych typów oraz przypisania własnych kombinacji właściwości i standardów do nich.

· Standardowe biblioteki właściwości można określić i przypisać do niczego innego w architekturze. Biblioteki te są znane jako Standardy, Używając Standardy, Trzeba tylko zebrać specyficzne właściwości systemów - standardowe właściwości już tam są. Na przykład standardowe cechy wydajności systemu Microsoft Windows 2000 może być przypisany do co komponenty są za pomocą systemu operacyjnego Microsoft Windows 2000.

Zobacz też

Jak architektura reprezentowana w ABACUS? | Co ABACUS zrobić? | Jak to zrobić (Przegląd) | Tworzenie nowego typu


Interfejs ABACUS

Nawigacja: Wprowadzenie do ABACUS>

Interfejs ABACUS

Wyślij komentarzy w tym temacie.

Po uruchomieniu Abacus, zobaczysz ekran główny, który jest pusty, z wyjątkiem menu i paska narzędzi na górze, pustym oknie Eksploratora i tytułowym-bar. Ekran ten będzie ośrodkiem interakcji z Abacus.

Głównymi elementami są:

· główne menu

· paski narzędzi

· menu kliknij prawym

· explorer i usługi na okna

· pasek stanu

Menu główne

Menu są ułożone w porządku logicznym.

Menu są opisane w następujący sposób;

· Menu Plik- Menu Plik pozwala na tworzenie, otwieranie, zamykanie, zapisywać, eksportować i publikowania plików ABACUS. Pozwala także na tworzenie, otwieranie, zamykanie i zapisywanie plików ABACUS Biblioteka.

· Menu Edycja- W menu Edycja umożliwia cięcie, kopiowanie, wklejanie, usuwanie, zmiana nazwy, znaleźć i sortować elementyi cofania / powtarzania operacji.

· Menu Widok- Menu Widok pozwala na otwarcie lub zamknięcie różnych interfejsu systemu Windows i paska stanuPrzejdź do przodu i do tyłu, przejdź do określonych poglądów i zarządzać kokpity.

· Menu Wstaw- W menu Wstaw pozwala na dodanie nowego Standardy, Szablony, rodzaje, elementy, widokpunkts, Katalogi, schematy, wykresy, Raporty i macierze.

· Menu Analiza- W menu Analiza pozwala na prowadzenie ewaluacji przed architektury, w tym; wydajność, koszty, niezawodność, modularność i otwartość.

· Menu Narzędzia- Menu Narzędzia umożliwia uruchamianie skryptów, zestaw cele na architekturzei wykonywać i architektura "diff", Można również zmodyfikować opcje programu i dostosować interfejs z menu narzędziowego.

· Menu Okno- Menu Okno pozwala na dok, zorganizować, pokazywać i ukrywać oknom masz otwarte.

· Menu Pomoc- Z menu Pomoc można uzyskać dostęp do tego pliku pomocy ABACUS. Możesz uzyskać dostęp do witryny internetowej, wyświetl licencja Umowa i przeglądać dane ogólne dot ABACUS w tym wersji oprogramowania oraz wsparcia i kontaktu Abacus szczegółów. Możesz przekazać opinię za pośrednictwem strony powiadomień problem. W razie potrzeby można wprowadzić klucz rejestracyjny poprzez menu Pomoc.

Jest to zamówienie będziesz zazwyczaj podążać, kiedy nosisz swoje zadania;Po utworzeniu lub wszczęła plikBędziesz normalnie wypełnić swoją architekturę, a następnie widokto (w Eksploratorze, diagramy, 3D, Wykresy, etc). W tym momencie, to albo uruchomić Oceniający, Lub będziesz powtórzyć proces z tej samej architekturze lub inną architekturę. (Widzieć Jak używać liczydła (Przegląd) dla dalszych szczegółów.)

Zapraszamy do obejrzenia przez główne menu i spróbować wyobrazić sobie, jak będziesz stosować je do systemu.

Notatka

Możesz Dostosuj swoje menu kiedykolwiek.

Paski narzędzi

Standardowo dostępne są następujące paski narzędzi;

· głównym pasku narzędzi -

· Symulacja pasek narzędzi -

· Pasek View -

· Narzędzie Schematbar (jeśli diagram jest otwarte) -

· Macro Nagranie pasek narzędzi -

Zapraszamy do obejrzenia poprzez przyciski na pasku narzędzi przez każdego unoszące się nad nimi, aby zobaczyć podpowiedzi (skrót-klucz).

Notatka

Tylko niektóre przyciski będą aktywne w zależności od tego, co zostało zaznaczone w oknie Eksploratora i można Dostosuj paski narzędzi kiedykolwiek.Dodatkowo, "Zatwierdź / Sprawdzić ograniczeń projektu" przycisk na pasku narzędzi i przyciski na pasku narzędzi symulacji podkreśli Rudy gdy zmiana w podstawowej repozytorium wymaga ponownego zatwierdzenie projektu lub ponownej symulacji tego symulatora odpowiednio. Najedź kursorem myszy na przycisk, aby zobaczyć, które architektury są naruszone.

W menu kliknij prawym przyciskiem myszy

Główne menu i paski narzędzi są nieużywane do wszystkiego, choć. Często jest to bardziej wygodne w użyciu menu kontekstowe prawego przycisku myszy dla różnych operacji. (Ponadto, nie wszystkie polecenia dostępne poprzez kliknięcie prawym przyciskiem myszy są dostępne za pośrednictwem głównych menu, pasków narzędzi lub poleceń klawiaturowych.)

Na przykład, po utworzeniu pliku i masz schemat drzewa architektury, to lepiej, aby kliknąć prawym przyciskiem myszy w drzewie architektur, aby dodać nową architekturę. Podobnie, należy kliknąć prawym przyciskiem myszy na części składowe, aby dodać nowy składnik. Kliknij prawym przyciskiem myszy na kilka rzeczy w drzewie, aby zobaczyć, co możesz zrobić.

napiwek

Ogólnie rzecz biorąc, można użyć menu główne, aby wykonać więcej zadań na wysokim poziomie, podobnie jak ocena swoją architekturę. Zadania niskiego poziomu - jak dodawanie pojedynczych elementów i połączeń - są wykonywane przy użyciu pasków narzędzi i / lub menu podręcznego.

Explorer i właściwości okna

Po otwarciu lub utworzyć plik, schemat drzewa zostaną wyświetlone w oknie Eksploratora. To okno do architektury. A jak wybrać elementy w obrębie okna Eksploratora trzy inne okna; Właściwości ogólne, Referencjei okna Właściwości zostaną zaktualizowane, aby odzwierciedlić szczegółowe informacje o wyborze.

Notatka

Właściwości ogólne, Referencjei okna Właściwości są domyślnie ukryte. Widzieć Dostosowywanie interfejsu na, jak je odkryć i potencjalnie zostawić je wyświetlany na stałe.

Podczas gdy budujesz swoją architekturę, okna Explorer i właściwości są najbardziej przydatne reprezentacji. Ponieważ mogą one być zwinięte i rozbudowany zgodnie z wymaganiami, a nie stają się uciążliwe.

Okno Explorer ma drzewa (i pasek stanu), a okna Właściwości mają 5 Sekcje:

· Rodzaj

· Standardy

· Opis

· Referencje

· Właściwości

ABACUS uważa wszystkie te rzeczy, aby być częścią architektury.

Drzewo

Ta sekcja ma na drzewo zgrupowane w 3 obszarach następująco:

1. Meta-modelu

· Standardy- Jeśli liczne elementy mają ten sam zestaw właściwości, można zdefiniować zestaw up-front, a potem po prostu przypisać go do komponentów. To samo dotyczy połączeń oraz wszelkich innych elementów. Te zestawy właściwości standardowych są przechowywane w Standardygałąź drzewa. Zamiast definiować każdą właściwość dla każdego komponentu, a każdy obiekt dla każdego połączenia itp, po prostu przypisać standard, Dla przykładu standardowe cechy Unix-HP / UXmożna zapisać jako Standard i przypisany żadnej komponenty przy użyciu Unix-HP / UXsystem operacyjny, jak przedstawiono dla OS01 Serwer na zrzucie ekranu nad.

· Typy - Ta gałąź drzewa jest biblioteką z rodzajów elementów i połączeń można użyć. Typy są używane do określenia meta-modelu architektury i klasyfikacji i filtrowania podczas oglądania architekturę. Określają one również szablon dla co Standardy, Właściwości i ograniczenia komponentów / połączenia mogą mieć.

· Punkty widzenia- WidokpunktS może być utworzone z istniejących schematów i może być stosowane do tworzenia nowych schematów.Są schemat szablony.

· Szablony - Szablony sklepu wielokrotnego użytku Wzory składników i połączenia, wraz z, w jaki sposób są one reprezentowane lub wyświetlenia. Mogą one być traktowane jako "mini" architektur i rozwiązań, które mogą być umieszczone w istniejących architektur.

2. Architektury -Architektur gałąź drzewa jest gdzie budować architektura (s) z systemu. (To się nazywa wypełniania architekturę.) Możesz mieć dowolną liczbę architektur w jednym pliku ABACUS.

3. Kokpity menedżerskie - Paneli kontrolnych gałąź drzewa, gdzie można uzyskać dostęp do dowolnej zapisany kokpity dla projektu.

Notatka

Produkty w drzewie Explorer, które miały ich Pozwolenie aktualizacja usunąć (tj są one tylko do odczytu) są wyświetlane w kolorze szarym.

Rodzaj

Ta sekcja oznacza składnik lub połączenia określonego typu aktualnie wybranego elementu w drzewie.

Standardy

Ta sekcja zawiera listę takich Standardy dla aktualnie wybranego elementu w drzewie.

Opis

Ta sekcja zawiera krótki opis wybranego elementu w drzewie. Wszelkie związane z linki mogą być również dodawane do tej sekcji. Są to strony internetowe lub lokalne ścieżki bezwzględne wskazujące na dalsze informacje na temat danego elementu. Wiele linii są dozwolone. Prawidłowe hiperłącza trzeba zacząć z jednym z 5 strun; http: //, https: //, ftp: //, file: /// lub mailto :.

napiwek

Dla hiperłącza ze spacjami, użytkownik może wpisać w adresie URL lub ścieżki, wybierz żądany tekst i Kliknij prawym przyciskiem myszy| Hiperłącze, Spowoduje to zmianę spacji do % 20więc cały adres URL lub ścieżka działa poprawnie.

Tworzyć i modyfikować

Te sekcjas zapewniaćużytkownik i data / czas na tworzenie, a ostatnia modyfikacja, aktualnie wybrany element w drzewie.

Referencje

Ta sekcja zawiera listę takich elementy wychodzące i przychodzące dla aktualnie wybranego elementu w drzewie.Pokazuje również schematy, 3D i widoki wykresu, że aktualnie wybrany element. Jeśli wybrany jest diagram pokazuje Punkt widzenia, jeśli stosuje się do diagramu i poglądów w ogóle to widać żadnych pulpitów widok pojawia się. A kiedy Standardowy został wybrany w drzewie to pokazuje, jak posługiwać się standardem, według typów, komponentów i połączeń.

Właściwości

Ta sekcja jest gdzie określenia cech elementy w Twoja architektura, jak sposób można wymagać, że do wykonania, liczba linii kodu ma odsetek tych linii, które są komentarze, itp

W "wejście" i "wyjście" właściwości w pre-wbudowany symulatory pojawi się w oknie Właściwości z ikoną selektor wiersza wejściowego nieruchomości ( [image] ) I ikona wyjście ( [image] ) Odpowiednio z podpowiedzi, wskazując, które wcześniej zbudowany symulator nieruchomość jest związana, np "Wyjście Modułowość" lub "Wejście Wydajność". Strzałki na ikonach wyjść podkreśli Rudy ( [image] ), Gdy właściwość jest nieaktualna ze względu na nieruchomość lub zmian strukturalnych do repozytorium z symulatora wymagającej ponownego symulację zgodnie z Rudy podświetlenie Pasek narzędzi Symulacja .

Pasek stanu

W lewej części paska stanu pokazuje pełną ścieżkę do repozytorium elementu obecnie ostrości, albo wybrany w oknie Eksploratora lub na diagram brezentowy. To jest tak, że dokładne miejsce w hierarchii repozytorium dla danego elementu zawsze można łatwo określić. Prawa część strony paska stanu pokazuje różne komunikaty operacyjne, takie jak "Plik Otwórz ABACUS Sukces" i "kalkulacji kosztów Zakończony".

Zobacz też

Jak to zrobić (Przegląd) | Dostosowywanie interfejsu | Co to jest architektura? | Jak architektura reprezentowana w ABACUS? | Praca z plikami Abacus


Dostosowywanie interfejsu ABACUS

Nawigacja: Wprowadzenie do ABACUS>

Dostosowywanie interfejsu ABACUS

Wyślij komentarzy w tym temacie.

Możesz zmienić wygląd i zachowanie interfejsu ABACUS na wiele sposobów. ABACUS zawiera kilka predefiniowanych ustawień kombinacji, których można użyć, aby zastosować grupę do dostosowywać interfejs. Ponadto możesz dostosowywać do poszczególnych elementów, takich jak okna, paski narzędzi, skrótów klawiszowych oraz różne wyświetla opcji.

Umów i Dock systemu Windows

Masz wiele możliwości aranżacji okien w interfejsie dla ABACUS, w tym:

· Okna Tab-dock.

· Okna Dock do krawędzi ramki w interfejsie.

· Minimalizacji okna narzędzia wzdłuż krawędzi interfejsu.

· Zresetować położenie okna do układu domyślnego.

Okna dokujące

Gdy okno jest dockable, może być przymocowany do jednej stronie ramy w interfejsie lub może być umieszczone na kartach szyb wewnątrz ramki. Przewodnik diament po przeciągnięciu okna z bieżącej lokalizacji do innej lokalizacji w interfejsie pojawia. Przewodnik diament pozwala szybko ponownie zadokować okno na jednym z czterech bokach ramy lub w centrum jako kartach okienku. Kiedy okno jest zadokowany lub nie dockable, pływa na wierzchu innych okien.

Aby zadokować okno

1. Kliknij okno, które ma do dokowania, aby dać się skupić.

2. Na Oknomenu, kliknij Dockable.

3. Przeciągnąć okno z bieżącej lokalizacji w połowie kadru chcesz zadokować go.

Pojawi się przewodnik diament. Cztery strzałki punktu diamentu wobec czterech rogów ramy i środka reprezentuje okienko kartami.

napiwek

Aby przenieść dockable okno bez zatrzaskując go, naciśnij klawisz CTRL podczas przeciągania go.

4. Kiedy okno przeciągania się w pozycji, w której chcesz go zadokować, przesuń wskaźnik myszy nad odpowiednią częścią diament prowadzącej. Zarys oknie pojawi się w wyznaczonym miejscu.

5. Aby zadokować okno w pozycji wskazanej, zwolnij przycisk myszy.

Na przykład, jeśli Odkrywcajest zadokowany na lewej krawędzi interfejsu i chcesz zadokować na prawej krawędzi, należy przeciągnąć Odkrywcaw połowie interfejsu, przesuń kursor na prawą stronę diament prowadnicy, a następnie zwolnij przycisk myszy.

Minimalizacja systemu Windows

Okna (czy są to narzędzia Windows - pojawiające się na WidokMenu lub dokumentu Windows - pojawiające się na OknoMenu) obsługują funkcję o nazwie Auto Hide. Auto Hide pozwala zobaczyć więcej architektury jednocześnie minimalizując okien wzdłuż krawędzi interfejsu, gdy nie jest w użyciu.

Aby włączyć Auto Ukryj

1. Kliknij okno, które chcesz ukryć, aby dać się skupić.

2. Na Oknomenu, kliknij Automatyczne chowanie.

- lub -

2. Kliknij ikonę pinezki na pasku tytułowym okna.

Auto Hide Włączone

Kiedy okno automatycznie ukryte traci ostrość, automatycznie przesuwa się z powrotem do zakładki na skraju interfejsu. Podczas gdy okno jest automatycznie ukryty, jego nazwę i ikony są widoczne na karcie, na skraju interfejsu. Aby wyświetlić okno automatycznego ukryte, przesuń wskaźnik nad kartą. Okno slajdy z powrotem do widoku i jest gotowy do użycia.

Notatka

Okno to jest automatycznie ukryte nie może być kopiowany. Aby zadokować okno trzeba będzie wyłączyć Auto Hide jak opisano poniżej.

Aby wyłączyć Auto Hide

1. Kliknij okno, które chcesz zachować widoczne dać się skupić.

2. Na Oknomenu, kliknij Automatyczne chowanieaby usunąć zaznaczenie.

- lub -

2. Kliknij ikonę pinezki na pasku tytułowym okna.

Auto Hide niepełnosprawnych

napiwek

Okna, które mają włączoną Auto Hide tymczasowo wsunąć widzenia, gdy okno ma fokus. Aby ponownie ukryć okno, wybierz element, poza bieżącym oknie. Gdy okno traci ostrość, że odsuwa się z widzenia.

Przywracanie systemu Windows podzial

Możesz powrócić do interfejsu Domyślny układ okien za pomocą Zresetować oknie układu rozkaz. Po uruchomieniu tego polecenia, następujące działania:

· Wszystkie okna są przenoszone do ich standardowej pozycji.

· Okna, które są zamknięte w układzie domyślnym okna są zamknięte przez polecenie.

· Okna otwarte w układzie domyślnym okna są otwarte przez polecenie.

· Okna, które są ukryte w / widoczne Domyślny układ okna są ukryte / widoczne przez polecenie.

Aby zresetować położenie okna do układu domyślnego

1. Na Oknamenu, kliknij Zresetować oknie układu.

Dostosowywanie menu i paski narzędzi

Możesz zmienić układ, położenie i zawartość menu i pasków narzędzi w interfejsie. Możesz również dodać przyciski do paska narzędzi i zmienić przypisany ikonę dowolnego przycisku.

Tworzyć nowe paski narzędzi

Aby utworzyć nowy pasek narzędzi

1. Na PrzyboryMenu, wybierz Dostosowywanie.

2. W Dostosujokno dialogowe, wybierz Paski narzędzi patka.

3. Wybierać Nowy.

4. W Nowy pasek narzędziokno dialogowe, wpisz nazwę paska narzędzi.

5. Wybierać ok.

Aby dodać przycisk polecenia do menu lub paska narzędzi

1. Na PrzyboryMenu, wybierz Dostosowywanie.

2. W Dostosujokno dialogowe, wybierz Polecenia patka.

3. Wybierz kategorię i przeciągnij polecenie z okna dialogowego do menu lub paska narzędzi.

4. Wybierać Zamknij.

napiwek

Przytrzymanie klawisza Alt pozwala szybko dostosować polecenia jakby dialogowe Dostosuj była otwarta.

Zobacz też

Interfejs ABACUS


Praca z plikami Abacus

Nawigacja: Wprowadzenie do ABACUS>

Praca z plikami Abacus

Wyślij komentarzy w tym temacie.

Plik ABACUS jest kontenerem dla swojego modelu architektura , W jednym pliku ABACUS, można modelować dowolną liczbę architektur dowolną liczbę razy.

Przy pierwszym otwarciu Abacus, nie ma żadnych plików otwarte. Do pracy w architekturze, trzeba albo stworzyć nowy plik lub otworzyć istniejący plik.

Po otwarciu lub utworzyć nowy plik, drzewa w oknie eksploratora automatycznie wyświetli. Ten widok explorer pokazuje swoją architekturę do tej pory. Po zamknięciu pliku, drzewa w oknie eksploratora również zniknie.

Aby utworzyć nowy plik ABACUS

1. Wybierz Plik| Nowy ...

2. W oknie dialogowym Nowy projekt, który pojawia się (jak pokazano poniżej) Wybieraćalbo utworzyć pusty model model z Standardowa biblioteka ABACUS , Model z niestandardowego ABACUS biblioteki, model z XML, MS Access , MS Visio , MS Excel , MS SQL Server , na Przedsiębiorstwo serwer model lub zwyczaj ABACUS biblioteki (.abacuslib plik).

3. Kliknij na okprzycisk i postępuj zgodnie z wyświetlanymi okna dialogowe, które mogą.

napiwek

Nie zostaną poproszeni o nazwę pliku do momentu zapisania lub zamknąć. To dobry pomysł, aby zapisać plik tak szybko, jak go utworzyć. Wtedy nie będziesz musiał martwić się o nazwanie go później w procesie, gdy jesteś koncentrując się na innych skomplikowanych rzeczy (jak wypełnianie swoją architekturę).

Utwórz nowy projekt

ABACUS standardowe biblioteki

ABACUS obsługuje ponad 100 ramy publiczne i zapisy, z których niektóre zostały przedstawione poniżej. Wybierając się do tworzenia nowego projektu ze standardowej biblioteki mają użytkownicy szybki początek modelowania w ramach współpracy ustalenia pełnego wykorzystania wszelkich określonych typów elementów, atrybutów, zapisów, punkty widzenia i szablonów lub wzorów. Dodatkowe standardowe biblioteki są udostępniane za darmo przez Avolution Wspólnoty tutaj .

Nowy projekt z biblioteki standardowej

Aby zapisać nowy plik ABACUS

1. Wybierz Plik| Zapisz jako

napiwek

Nazwy plików mogą być dowolnej długości, i może zawierać dowolne znaki alfanumeryczne i spacji. Nie mogą zawierać znaku tyldy (~), do potoku (|), znak, znak zapytania, czy znaki normalnie używany opisy ścieżek takich jak backslash (\) - z wyjątkiem części ścieżki (?).

Aby otworzyć istniejący plik ABACUS

1. Wybierz Plik| Otwarte

Notatka

Jeśli otwierasz plik z udostępnionej lokalizacji sieciowej, która jest już otwarty do innego użytkownika, ABACUS zapewni Ci dostęp tylko do odczytu. Podczas korzystania z Abacus z dostępem tylko do odczytu, nie będzie w stanie wykonywać operacje zapisu, takich jak wypełnianie swoją architekturę i działa ewaluatorów. Możesz jednak wyświetlić architekturą przy użyciu widoku eksploratora i widoki 3D.

Zobacz też

Jak architektura reprezentowana w ABACUS?


Jak architektura reprezentowana w ABACUS?

Nawigacja: Wprowadzenie do ABACUS>

Jak architektura reprezentowana w ABACUS?

Wyślij komentarzy w tym temacie.

W ABACUS, modelować swoją architekturę. Dla uproszczenia nazywamy ten model architektoniczny architektura.

Poniższy schemat pokazuje jak typowy architektury 5 podzespoły (w hierarchii) połączone złączami 2 będzie reprezentowane Abacus.

Jak prosta architektura jest reprezentowana w ABACUS

Możesz mieć dowolną liczbę architektur w jednym pliku ABACUS.

Pierwszy architektury w drzewie

Zazwyczaj, by utworzyć nową architekturę, gdy chcesz ocenić zmiany. Na przykład, można modelować istniejącej architektury pierwsze - to będzie pierwsza architektura w drzewie. Można nazwać to "Prąd".

Drugi

Jeśli chcesz modelować i oceniać zmianę istniejącej architektury (np zwiększone wymagania) chcesz utworzyć nową architekturę. Najprostszym sposobem na to byłoby utworzyć kopię "Aktualny" i zmień jego nazwę na "Evolution 1 Próba 1 '. To będzie drugi architektury w drzewie. Jeśli twoje oceny "Evolution 1 Próba 1 'są skuteczne, można zmienić jego nazwę po prostu" Evolution 1 ".

Trzeci

Jeśli "Evolution 1 Próba 1" nie spełnia wymagań, można utworzyć jego kopię, zmienić jego nazwę na "Evolution 1 Próba 2 ', i spróbuj ponownie. To będzie trzeci architektury w drzewie.

Zobacz też

Co ABACUS zrobić? | Jak to zrobić (Przegląd) | Co to jest architektura? | Praca z plikami Abacus | Tworzenie lub powielania architekturę


Pomoc w innych językach

Nawigacja: Wprowadzenie do ABACUS>

Pomoc w innych językach

Wyślij komentarzy w tym temacie.

LICZYDŁO pomoc jest dostępna w wielu innych językach / tłumaczeń i można pobrać z poniższych linków.

Do zastąpienie obecnego ABACUS plik pomocyz przetłumaczonego pliku pomocy, wykonaj następujące czynności:

1. Zapisz plik pomocy z odpowiedniego linku poniżej.

2. Zmień nazwę pliku pomocy do ABACUS.chm.

3. Otwórz plik, klikając go dwukrotnie, a jeśli na "Otwórz plik - ostrzeżenie o zabezpieczeniach" pojawi się okno dialogowe, a następnie usuń zaznaczenie "Zawsze pytaj przed otwarciem pliku" opcję i kliknij przycisk Otwórz.

4. Zamknij plik.

5. Zamień plik ABACUS.chm w folderze Program Files ABACUS, zazwyczaj "C: \ Program Files \ Avolution \ ABACUS" lub "C: Program Files \(x86)\ Avolution \ ABACUS".

Notatka

Pomoc kontekstowa będzie nadal współpracować z przetłumaczonych plików pomocy.

Pliki pomocy ABACUS w innych językach:

· arabski / العربية .

· bułgarski / български .

· Uproszczony chiński) / 中文 (简体) .

· Czech / Česká .

· duński / Dansk .

· estoński / Eesti .

· fiński / Suomen .

· Francuski / Français .

· Niemiecki / Deutsch .

· język węgierski / Magyar .

· islandzki / islandzki .

· indonezyjski / Indonezja .

· Włoski / Italiano .

· Japoński / 日本 の .

· łotewski / Latvijas .

· Malezyjski / Malezja .

· Maltańczyk / Słód i .

· Norweigen / Norweigen .

· Polskie / Po Śląska .

· Portugalski / Português .

· Rosyjski / русский .

· słowacki / Slovenski .

· słoweński / Slovenski .

· hiszpański / Españoles .

· szwedzki / Svenska .

· turecki / Turek .

· walijski / Cymraeg .

Zobacz też

Co ABACUS zrobić?


Wypełnianie swoją architekturę

Nawigacja: Wypełnianie swoją architekturę>

Wypełnianie swoją architekturę

Wyślij komentarzy w tym temacie.

Proces budowy modelu architektury jest znany jako zaludnienie, Po odkrył swoją architekturę i określone wymagania, jesteś gotowy, aby modelować swoją architekturę w ABACUS.

Podczas populacji, można wprowadzić wszystkie szczegóły wiesz o swojej architekturze i co jest wymagane od niego.

Aby wypełnić swoją architekturę

1. Sprawdź, czy jest Plik ABACUS otwarta , na explorer wyświetlona , Oraz Architektura dodany .

2. Ręcznie wypełnić elementy wyższego poziomu i połączenia z architektury. Zazwyczaj będzie to bardziej abstrakcyjne elementy i połączenia.

- lub -

2. Graficznie wypełnić elementy i połączenia, które chciałbyś patrz reprezentowany schematycznie, za pomocą Rysunek Narzędzie .

Można też do

3. Wypełnić przy użyciu Katalogi - Można przeglądać i Komponenty i połączenia w prosty tabelarycznej sposób.

4. Wypełnić przy użyciu matryc - Można przeglądać i edytować połączeń między elementami w prosty tabelarycznej sposób.

5. Wypełnianie z programu Microsoft Access - Można importować architekturę z i eksport do Microsoft Access.

6. Wypełnianie z Microsoft Visio - Można importować architekturę z i eksport do Microsoft Visio.

7. Wypełnianie z programu Microsoft Excel - Można importować architekturę z i eksport do Microsoft Excel.

8. Wypełnianie z Microsoft SharePoint - Można importować architekturę z i eksport do Microsoft SQL Server.

9. Wypełnianie z Microsoft SQL Server - Można importować architekturę z Microsoft SQL Server.

10. Import z XML - Można importować architekturę z XML fragmentu ABACUS lub pliku XML ArchiMate Interchange Język.

Zobacz też

Wypełnianie swoją architekturę ręcznie | Losowanie Narzędzie | Wypełnianie swoją architekturę z programu Microsoft Access | Wypełnianie swoją architekturę z Microsoft Visio | Wypełnianie swoją architekturę z programu Microsoft Excel


Wypełnianie swoją architekturę ręcznie

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręczne>

Wypełnianie swoją architekturę ręcznie

Wyślij komentarzy w tym temacie.

Komponenty i połączenia z architektury wyższego poziomu prawdopodobnie będzie musiała być wypełniona ręcznie. Zazwyczaj będzie to bardziej abstrakcyjne elementy i połączenia.

Aby ręcznie wypełnić swoją architekturę

1. Sprawdź, czy jest Plik ABACUSotwarte, odkrywcawyświetlane, oraz Architektura dodany .

2. Dodaj komponent. Aby to zrobić, Kliknij prawym przyciskiem myszyna obszarze drzewa chcesz wypełnić, a następnie wybierz Dodaj podkomponentem ...Lub kliknij Nowy komponentPrzycisk na Pokaż pasek narzędzi , Składniki mogą być dodawane tylko w branży komponentów drzewa. Chcesz, aby Twój schemat drzewa, aby być dokładnym odwzorowaniem architektury. Gdy odkrył swoją architekturę, nauczysz się dokładnie, jak to wszystko działa. Trzeba tę wiedzę podczas dodawania komponentów i połączeń. Jeśli dodajesz swój pierwszy składnik, można go dodawać bezpośrednio do oddziału Components. Reszta komponentów może być na tym samym poziomie w drzewie, lub mogą być pod-elementy pierwsze.

3. Aktualizacja wartościWłaściwościskładowych, jak go dodać. Aby to zrobić, trzaskna części i edytować właściwości wyświetlane w Okno właściwości(zazwyczaj) na prawo. Właściwości są zazwyczaj takie rzeczy jak wymagania, możliwości przetwarzania, itp Gdy ABACUS ocenia swoją architekturę, to obliczyć kilka nowych właściwości, i zapisać je do architektury. Nowe właściwości są dane starasz się analizować, takie jak wykorzystanie, czas odpowiedzi, przepustowość, itd

4. Dodaj połączeń i aktualizacjaich właściwościjak przejść - tak samo jak dla komponentów (ale pod Połączenia gałęzi drzewa).

5. Dołączaćpołączenia i komponenty. Aby to zrobić, znajdź połączenie, kliknij na jednym z jego końców lub role I przeciągnij go na składnik. Alternatywnie, kliknij na element i przeciągnij go na jednym z CONNECTION na role (czyli albo Źródło lub Sink), Możesz też kliknąć prawym przyciskiem myszy i przeciągnąć element na inny składnik i wybierz Połącz z, Lub po prostu kliknij prawym przyciskiem myszy i wybierz komponent Połącz..., Podczas przeciągania połączenia rolaZauważysz symbol skrótu przy wskazywaniu elementu można dołączyć go do. Oznacza to, że nie jesteś wykonywania kopii, jesteś po prostu podłączeniu go. Upewnij się dołączyć go do odpowiedniego elementu docelowego. Na przykład, jeśli jest to źródło połączenia za rolaPrzeciągnij zrobić źródło sygnału (czyli składnika, który jest źródłem przepływu danych).

napiwek

Ponownego zamawiania podmiotów w ramach architektury (np Komponenty, połączeń itp) w odkrywcajest dość prosta. Po prostu Trzask| Trzymać| Opórdany podmiot, a miejsce, gdzie pożądana w architekturze. Funkcja ponownego zamawiania pozwala również na umieszczenie jednostki w ramach różnych hierarchii architektury.

Można też do

6. Dodaj Standardy (wstępnie skonfigurowane zestawy właściwości - presetów) pomiędzy elementami, połączenia lub rodzajów

7. Zmień właściwości składnika, połączenia lub rodzaju

8. Undo i Redo Operacje

9. Zmiana typu części lub połączenia

10. Tworzenie nowego typu lub typu grupy

11. Usunąć komponent lub połączenie

12. Tworzenie, powielanie lub ewoluują architektura

13. Rodzaje importu i standardy z biblioteki

14. Import z innego pliku ABACUS, XML, Excel lub Visio

15. Kopiuj i wklej części (lub wszystkie) z architektury

16. Znajdź i zamień pozycje w architekturze

17. Rozwiń / Zwiń niektóre lub wszystkie węzły w drzewie

18. Łączyć przedmiotów

19. Określić i Uprawomocnić Ograniczenia ograniczyć struktury architektury

20. Rozwijaj swoją architekturę utworzyć kilka architektonicznych rozwiązań do porównania i odniesienia

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Tworzenie nowego pliku


Undo i Redo

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Undo i Redo

Wyślij komentarzy w tym temacie.

Podobnie jak wiele nowoczesnych aplikacji, ABACUS obsługuje możliwość zarówno Undo i Redo ostatnie zmiany dokonane przez użytkownika do otwartego projektu. Aby cofnąć ostatnią zmianę, wystarczy włączyć polecenia Cofnij. Zmiany, które zostały zlikwidowane mogą zostać przerobione przez aktywację polecenia Powtórz; ponownie stosując ostatnio cofnąć zmiany.

Ostrzeżenie

Undone zmiany nie są w stanie się go ponownie, jeżeli są wprowadzane kolejne zmiany do projektu od chwili cofnąć.

Notatka

Podczas gdy większość zmian wsparcie cofania / powtarzania w czasie rzeczywistym, niektóre diagram wzornik zmiany, takie jak tworzenie nowego typu Shape / stowarzyszenie linii lub zmiany atrybut koloru stowarzyszenie, nie są w stanie cofnąć się natychmiast. W tych przypadkach, zmodyfikowany Diagram (oznaczony gwiazdką) musi zostać zamknięty przed Te zmiany mogą być cofnięte.

Undo i Redo lokalizacji poleceń

W Undo i Redo polecenia mogą być dostępne z trzech różnych miejscach:

· Edycja menu

· pasek narzędzi Standardowy

· klawisze skrótów klawiaturowych CTRL + Z(aś) i CTRL + Y (przerobić)

napiwek

Undo i Redo przycisków na standardowym pasku narzędzi rozwijanych list wyświetlania zapewniają 10 najnowszych zmian, które można cofnąć i zostały przerobione odpowiednio. Są również wygodnym sposobem cofania / powtarzania wiele zmian na raz.


Zmiana komponentowego / typ połączenia do

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Zmiana komponentowego / typ połączenia do

Wyślij komentarzy w tym temacie.

Typy komponentów i połączenia wykorzystywane są głównie do celów klasyfikacji. Możesz użyć typów jako filtry podczas oglądania architekturę. Na przykład, zamiast oglądania całość, można zobaczyć tylko komponentów aplikacji.

Aby zmienić typ połączenia komponentowego / w

1. Kliknij prawym przyciskiem myszyna części lub połączenia.

2. Wybierz Zmień typ.

3. Wybierz inny typ z listy.

napiwek

W przypadku zmiany typu, może pojawić się jakiś nowy Standardylub właściwości (co jest związane z typem - patrz Typy gałąź drzewa). Istniejąca Standardy i właściwości pozostaną niezmienione. Możesz tworzyć własne nowe typy i przypisać własne kombinacje Standardy i właściwości do nich.

Zobacz też

Tworzenie nowego typu | Wypełnianie swoją architekturę - Przegląd | Analizowanie Twoja architektura


Tworzenie nowego połączenia typu części / lub typ grupy

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Tworzenie nowego połączenia typu części / lub typ grupy

Wyślij komentarzy w tym temacie.

Typy komponentów i połączenia wykorzystywane są głównie do celów klasyfikacji. Możesz użyć typów jako filtry podczas oglądania architekturę. Na przykład, zamiast oglądania całość, można zobaczyć tylko komponentów aplikacji.

Aby utworzyć nowy komponent / typ połączenia

Notatka

Aby dodać typy lub grupy typu w projekcie ABACUS licencji użytkownik musi projektant add-on możliwości. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

1. Rozwiń Rodzajegałąź drzewa.

2. Kliknij prawym przyciskiem myszy na Składowe Rodzaje (lub Rodzaje połączeń).

3. Wybierz Dodaj homologacji części, (lub Dodaj typ połączenia) lub Stworzyć grupę.

napiwek

Po utworzeniu typu, należy zmienić jego ikonę (patrz niżej) i dodać właściwości i Standardy do niego dla komponentu lub przypadkach podłączenie do "dziedziczą".

Aby zmienić ikonę dla części / typ połączenia

Notatka

Aby zmienić ikony typów w projekcie ABACUS licencji użytkownik musi projektant add-on możliwości. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

1. Kliknij prawym przyciskiem myszy na Składnik Typ (lub Rodzaj połączenia), Które chcesz zmienić ikonę.

2. Wybierz Zmień ikonę.

3. W oknie dialogowym wybierz ikonę Wybierz do lokalizacji i wybrać plik obrazu i kliknij przycisk Otwórz.

Notatka

Możesz mieć niestandardowego obrazu ikony o dowolnej wielkości, ale to zawsze być skalowany w celu dopasowania do obrazu 16x16 pikseli w oknie Eksploratora. Więc jeśli oryginalny zwyczaj ikona obraz nie jest tej samej wysokości i szerokości zostanie rozciągnięty okna ikonę Explorer. Odpowiednio, obrazy niestandardowe powinny być co najmniej 16x16 pikseli, a jeśli chcesz zachować dokładny kształt ikony niestandardowej upewnić, niestandardowe ikony obrazu jest równa wysokość i szerokość w pikselach (16x16 lub większe). Należy również być ostrożnym, nie mając kolorowe "pikseli" dzieje się aż do granicy zwyczaj Obraz ikony będzie wyglądać ubogich w oknie Eksploratora z sąsiednimi ikon "krwawienia" do siebie. W związku z powyższym, należy pozostawić co najmniej 1 białą obwódkę pikseli.

napiwek

Możesz tworzyć niestandardowe ikony obrazu .ico, .bmp, .gif, .jpg lub .png format pliku, ale ze względu na ograniczenia w systemie Windows będzie tylko w formacie .ico w oknie podglądu ABACUS Wybierz ikonę, jeśli masz opcję menu View ustawiony na coś innego niż miniatury.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Analizowanie Twoja architektura


Usuwanie elementu lub połączenie

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Usuwanie elementu lub połączenie

Wyślij komentarzy w tym temacie.

Aby usunąć komponent lub połączenie

1. Kliknij prawym przyciskiem myszyna części lub połączenia.

2. Wybierz Usunąć.

Ostrożność

ABACUS ostrzeże Cię, które widoki zostaną naruszone przez skreślenie i poprosi o potwierdzenie usunięcia. To dlatego, że elementy mogą występować na wielu wykresach i warto sprawdzić, jakie proponowane skreślenie wpłynie.

napiwek

Jeśli usuniesz składnik, wszystkich jego podzespołów również zostaną usunięte. Możesz wybrać, aby usunąć połączeń wewnętrznych i zewnętrznych do komponentu. Jeśli nie chcesz, aby je usunąć, połączenia to przywiązany na pozostanie, ale nie będzie już w załączeniu. Wszystkie elementy i połączenia są szczególne Rodzaj , Usuwanie komponentów / połączenie nie ma wpływu na rodzaj (w rodzajach gałęzi drzewa). Podobnie, jeśli składnik / połączenie ma Standard przypisane, usunięcie nie będzie miało wpływu na mistrza w branży Standardów.

Zobacz też

Wypełnianie swoją architekturę - Przegląd


Tworzenie lub powielania architekturę

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Tworzenie lub powielania architekturę

Wyślij komentarzy w tym temacie.

Możesz mieć dowolną liczbę architektur w jednym pliku ABACUS. Zazwyczaj, można by stworzyć nową architekturę każdym razem chcesz modelować i oceniać ewolucję systemu.

Aby utworzyć nową architekturę

1. Kliknij prawym przyciskiem myszy na Architekturgałąź drzewa.

2. Wybierz Nowa Architektura.

Aby utworzyć kopię istniejącej architektury

1. Kliknij prawym przyciskiem myszyw architekturze.

2. Wybierz Kopiuj.

3. Kliknij prawym przyciskiem myszy na Architekturgałąź drzewa.

4. Wybierz Pasta.

5. Nowa architektura będzie nazywany "Kopia ...".

Rozwijać istniejącą architekturę

1. Kliknij prawym przyciskiem myszyw architekturze.

2. Wybierz Ewoluować.

3. Nowa architektura będzie nazywany "... 0,1".

Notatka

Jest to szczegółowy opis na zmieniające się architektur tutaj .

Zobacz też

Jak architektura reprezentowana w ABACUS | Się rozwija swoją architekturę


Importowanie do swojej Architektury

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Importowanie do swojej Architektury

Wyślij komentarzy w tym temacie.

ABACUS pozwala na przywóz do Twoja architektura ze związku .abacus (plik ABACUS), Format (Microsoft Visio) .xml (fragment XML ABACUS lub plik XML ArchiMate Interchange Język), .vsd i Format .xls (Microsoft Excel). To pozwala na zbudować architekturę z zewnętrznych źródeł szybko.

Do import Twoja architektura od.abacus (plik ABACUS)

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Kliknij prawym przyciskiem myszyna węźle Architektury każda architektura w modelu lub części drzewa Components.

3. Wybierz Import| Od Plik...z menu.

4. Wybierz lokalizację i .abacus plik i kliknij Otwarte przycisk.

Notatka

Po wybraniu pliku, który chcesz zaimportować, pojawi się pytanie, w jaki sposób chcesz zaimportować standardy, typyi punkty widokowe, Możesz importować standardy, typy i punkty widokowe jako nowe lub połączonych standardów, typyi punkty widokowe, Domyślnym ustawieniem jest do standardów, typy i punkty widokowe zostać połączone z istniejącymi standardami, typy i punkty widokowe jeśli już istnieją (z tym samym dokładną nazwą) w telefonie projekt.

Do importTwoja architektura od.xml (fragment ABACUS XML lub plik XML ArchiMate Interchange Język)

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Kliknij prawym przyciskiem myszyna węźle Architektury każda architektura w modelu lub części składowej drzewa.

3. Wybierz Import| Od XML ...z menu.

4. Wybierz lokalizację i .xml plik i kliknij Otwarte przycisk.

Notatka

ABACUS będzie importować tylko odpowiednio uformowaną ABACUS XML fragment lub plik XML ArchiMate Interchange Język. Po wybraniu pliku XML, który chcesz zaimportować, pojawi się pytanie, w jaki sposób chcesz zaimportować standardy, typyi punkty widokowe, Możesz importować standardy, typy i punkty widokowe jako nowe lub połączonych standardów, typyi punkty widokowe, Domyślnym ustawieniem jest do standardów, typy i punkty widokowe zostać połączone z istniejącymi standardami, typy i punkty widokowe jeśli już istnieją (z tym samym dokładną nazwą) w telefonie projekt.

Do importTwoja architektura od,VSD(Visio plik) widzieć tutaj .

Do importTwoja architektura od.xls (Excel plik) widzieć tutaj .


Importowanie typów i standardy z biblioteki

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Importowanie typów i standardy z biblioteki

Wyślij komentarzy w tym temacie.

Możesz importować rodzaje i standardy z pliku biblioteki ABACUS. Można także eksportować typy i standardy z pliku ABACUS do pliku biblioteki ABACUS.

Aby zaimportować rodzaje i standardy z biblioteki do swojej architektury

1. Sprawdź, czy jest Plik ABACUSotwarte i Explorer Okno wystawiany.

2. Wybierz Plik | OtwarteAby otworzyć Plik biblioteki ABACUS.

3. ABACUS biblioteka zostanie otwarta w drugim kartach arkusza w oknie Eksploratora i trzeba będzie oddokuj ten kartach arkusz aby móc przeciągnij i upuść z niego do oryginalnego pliku ABACUS.

4. Przeciągnij i upuśćtypy i standardy z biblioteki w swojej architekturze.

- lub -

1. Wybierz Plik | Nowy ...

2. Stwórz nowy Plik ABACUSW oparciu o Plik biblioteki ABACUS.

Aby wyeksportować rodzaje i norm z architektury w bibliotece

1. Sprawdź, czy jest Plik ABACUS otworzyć Explorer Oknowyświetlane, Plik biblioteki ABACUSotwarte i Okno biblioteki wystawiany.

2. Przeciągnij i upuśćtypy i wzorce z architektury do biblioteki.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie


Kopiowanie i wklejanie

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Kopiowanie i wklejanie

Wyślij komentarzy w tym temacie.

Możesz skopiować część lub całość swojej architekturze i wkleić go w innym miejscu w drzewie.

Kopiować

1. Kliknij prawym przyciskiem myszyna pozycję chcesz skopiować.

2. Wybierz Kopiuj.

Aby wkleić

1. Przejdź do drzewa, aby znaleźć miejsce, które chcesz przenieść element.

2. Kliknij prawym przyciskiem myszyna gałęzi chcesz go do stawienia się w terminie.

3. Wybierz Pasta.

4. Element zostanie skopiowany z oryginalną nazwą (chyba, skopiować go do pierwotnego oddziału - to będzie się nazywać "Kopia ...").

Zobacz też

Jak architektura reprezentowana w ABACUS


Znajdowanie i zastępowanie elementów w architekturze

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Znajdowanie i zastępowanie elementów w architekturze

Wyślij komentarzy w tym temacie.

Możesz znaleźć i zamień konkretny komponent, połączenia, typu standard lub nieruchomość za pomocą liczydła "Znajdź i zamień obiekt.

Aby znaleźć przedmiot

1. Kliknij węzeł drzewa, które chcesz przeszukać.

2. Wybierz Edytować| Odnaleźćlub naciśnij Ctrl + F.

3. Wejdz do tekst przedmiotznaleźć w "Znajdź Co polu.

4. Trzask Znajdź następny.

Do zastąpić przedmiot

1. Kliknij węzeł drzewa, które chcesz przeszukać.

2. Wybierz Edytować| wymienićlub naciśnij Ctrl + H.

3. Wejdz do tekst przedmiotznaleźć w "Znajdź to," pole, a tekst zastąpić go w "Zamień na" polu (lub nic, jeśli pole jest puste).

4. Trzask Znajdź następnyznaleźć pierwsze wystąpienie w tekście "Znajdź to, co 'i kliknij wymienić zastąpić to wystąpienie z tekstem "Wymień" lub kliknięcie Zamień wszystkowymienić wszystkie instancje.

Masz opcje do:

o Dopasuj swoje sprawy,

o Dopasuj całe słowo,

o Szukaj od początku projektu,

o Ignoruj ​​architektury - to jest architektura węzłów siebie. Wszelkie węzły pod architektury węzłów, takich jak części i połączeń nadal będą przeszukiwane,

o Ignoruj ​​komponenty - to składnik węzły się,

o Ignoruj ​​połączeń - to połączenie węzłów siebie,

o Ignoruj ​​standardy - to wszystkie standardowe węzły architektura, komponentów i połączeń będą ignorowane,

o Ignoruj ​​rodzaje - to rodzaj węzłów siebie. Wszelkie węzły ograniczające Beneath węzłów typu nadal będzie szukał,

o Ignoruj ​​szablony i zawartość - czyli węzły się szablon jak również każdy komponent Szablon i węzły łączące pod nimi,

o Ignoruj ​​właściwości - czyli wszystkie rodzaje nieruchomości, nazwy, wartości i jednostki wszystkich elementów tego modelu będą ignorowane,

o Ignoruj ​​opisy - czyli opisy wszystkich elementów tego modelu będą ignorowane.

Zobacz też

Jak architektura reprezentowana w ABACUS


Rozwijanie i zwijanie drzewa

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Rozwijanie i zwijanie drzewa

Wyślij komentarzy w tym temacie.

Kiedy węzeł w drzewie zawiera elementy podrzędne i kolekcje, to będzie mała [image] lub [image] podpisać na jej lewej stronie. Możesz kliknąć [image] aby rozwinąć węzeł i zobaczyć jego sub-komponentów i połączeń. Podobnie, można kliknąć [image] aby zwinąć węzeł, aby ukryć pod-elementy i połączenia (tak aby więcej miejsca lub zrobić drzewo łatwiejszy do zrozumienia).

Alternatywnie, można poszerzyć całego węzła, w którym to przypadku wszystkie jego węzłów podrzędnych będzie również rozbudowany i ich węzły podrzędne, a ich ... itd. Podobnie, można zwinąć cały węzeł - zamknięcie wielu poziomach naraz ,

Dodatkowo, istnieją opcje rozbudowy tylko architektury, elementów (czyli elementy i połączenia), części lub połączeń.

Aby rozwinąć lub zwinąć cały węzeł (i jego pod-węzły, itd.)

1. Kliknij prawym przyciskiem myszyw tym węźle.

2. Wybierz Rozwiń | wszystko lub Upadek.

Aby rozwinąć wszystkie architektury (s)

1. Kliknij prawym przyciskiem myszyna architekturach lub architektury.

2. Wybierz Rozwiń | wszystko.

Aby rozwinąć elementy

1. Kliknij prawym przyciskiem myszyna architekturach lub architektury.

2. Wybierz Rozwiń | Elementy.

Aby rozwinąć komponenty

1. Kliknij prawym przyciskiem myszyczęści składowych, części lub składowej.

2. Wybierz Rozwiń | Komponenty | wszystko.

Aby rozwinąć połączenia

1. Kliknij prawym przyciskiem myszyPołączenia, połączenia lub sub-związku.

2. Wybierz Rozwiń | Połączenia | wszystko.


Łączenie elementów

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Łączenie elementów

Wyślij komentarzy w tym temacie.

Gdy chcesz połączyć elementy?

Można by połączyć elementy, gdy masz dwie (lub więcej) obiekty w modelu, które są najlepiej reprezentowane przez jeden przykład. Istnieje wiele sytuacji, kiedy może chcesz to zrobić, w tym:

· W wyniku importu nowy zestaw informacji do modelu, które mogą powielać lub zastępują dotychczasowe informacje. Na przykład, jeśli import zaktualizowaną wersję arkusza kalkulacyjnego do swojego modelu.

· Z czasem duplikatami 'sam' komponentu zostały utworzone i chcesz, aby oczyścić te duplikaty.

· Jeśli wykonując co jeśli scenariusz i elementy, które są w rzeczywistości połączenie modelowania są w rzeczywistości. Na przykład, jeśli połączenia dwóch działów w organizacji, lub jeśli połączenie dwóch serwerów.

Co może być połączone?

Następujące typy elementów wsparcia jest połączone:

· Standardy

· Komponentów i połączeń Rodzaje

· Komponenty i Połączenia

Jak połączyć elementy

Aby zainicjować korespondencję seryjną, używając prawego przycisku myszy, przeciągnij jeden element w Eksploratorze na inny. Pozycja przeciągania jest źródłem, i że przeciągnąć na element jest cel. Po zwolnieniu prawy przycisk myszy zostanie przedstawiony z menu, z którego można wybrać połączenie tych dwóch elementów. Będziesz musiał wybrać, czy chcesz zachować lub zastąpić cel. Jest to wyjaśnione poniżej.

W menu po prawej przeciągnij seryjnej

Jaka jest różnica między zachowaniem i nadpisanie miejsce docelowe?

Opcja zachować lub nadpisać dyktuje, co się stanie, jeśli nazwa, opis lub Właściwości pomiędzy źródłowym i elementy docelowe meczu.

Jeśli zostanie wybrany Zachowaj Destination

· Nazwa miejsca docelowego i opis będą przechowywane.

· Wszelkie cechy, które występują tylko w źródle dodaje się do miejsca przeznaczenia.

Jeśli zostanie wybrany docelowy nadpisywania:

· Nazwa miejsca docelowego zostaną nadpisane od źródła.

· Opis miejsca przeznaczenia zostaną zastąpione od źródła, chyba że opis źródła dźwięku jest puste.

· Wszelkie cechy, które występują tylko w źródle dodaje się do miejsca przeznaczenia.

· Wartość i Jednostka żadnych właściwości, które istnieją zarówno w źródłowym i docelowym zostaną zastąpione od źródła, chyba że wartość kanałów źródła dźwięku lub urządzenia jest pusty.

Przypadki szczególne

· RodzajeKiedy połączenia typu, uprawnienia są połączone, w "pesymistycznym 'sposób, tak, że jeżeli uprawnienie źródła nie istnieje na cel, to nie być dodawane, i jeśli nie występuje w miejscu, a następnie, jeśli osoba Pozwolenie dla grupy użytkownika (Create, Read, Update lub Delete) nie pasuje (jeden pewnik, jeden zaprzeczył), a następnie będzie się zaprzeczyć, że pozwolenie.

· podzespoły: Podczas łączenia elementów, pod-składniki źródła zostaną przeniesione do miejsca przeznaczenia, i są połączone z podzespołów w celu turystycznym, jeśli ich nazwy są identyczne, Niezależnie od ich rodzaju.Ponadto, wiele podrzędne składniki źródła o tej samej nazwie będą połączone w jedno składowej w miejscu przeznaczenia.

· Znajomości: Top połączenia na poziomie sami muszą oba mają te same załączniki (lub jej brak), aby mogły zostać połączone. Podczas łączenia połączeń, pod-powiązaniach źródła zostaną przeniesione do miejsca przeznaczenia, i są połączone z pod-połączeń w okolicy, jeśli ich nazwy są identyczne Iich załączniki są identyczne. Jeśli narzędzia nie są identyczne, pod-połączenia źródłowe zostaną dodane do miejsca przeznaczenia, bez połączenia z połączeń pasujące już obecnych. To jest tak, że żadne załączniki zostaną utracone.


Definiowanie i Members Ograniczenia

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Definiowanie i Members Ograniczenia

Wyślij komentarzy w tym temacie.

Strukturę i właściwości architektury, mogą być ograniczone przez zastosowanie ograniczenia. Ograniczenia mogą być stosowane do typów elementów i rodzaju połączenia, aby ograniczyć strukturę architekturę na dwa sposoby. Pierwszym sposobem jest ograniczenie hierarchiapoprzez zdefiniowanie "rodzic powinien / musi mieć dziecko" i "dziecko powinno / musi być dominująca" relacji. Drugim sposobem jest ograniczenie topologiapoprzez określenie "komponent powinien / musi być dołączony do połączenia" i "połączenie powinno / musi być dołączony do komponentu" relacji. Ponadto, ograniczenia mogą być stosowane do właściwości typów komponentów, typów połączeń, szablony, punktów widzenia, architektur, Schematyi 3D, aby ograniczyć architekturę (y) w dwóch dodatkowych sposobów. Pierwszym sposobem jest, aby ustawić typ danychnieruchomości w celu ograniczenia obowiązujących wartości, że może mieć, a mianowicie; Tekst, Integer, dziesiętny, data / czas, Boolean lub Lista. Drugim sposobem jest, aby ustawić wymaganyStan nieruchomości, aby wskazać, czy wartość musi być wprowadzona dla nieruchomości (Uwaga: Wymagane ograniczenia mają zastosowanie tylko do nieruchomości dla typów komponentów i połączeń). Dalsze informacje na temat ograniczeń właściwości przedstawiono w Zmiana właściwości komponentów, połączenia lub rodzaju temat pomocy. Raz ograniczenia zostały określone, to jest możliwe, aby potwierdzić architekturę przed ograniczeń. ABACUS ostrzega o jakichkolwiek ograniczeń, które zostały naruszone.

Kluczem do określenia, które przymusu (ów) do definiowania polega na dokładnym język używany do opisania ograniczenie. Dla ograniczenia hierarchii są zazwyczaj w postaci "rzeczownikimoże / powinna / musi być rozłożona na n rzeczowniki" lub "rzeczownikimoże / powinna / musi być agregowane przez rzeczowniki"Itd. Na przykład,"Wydziałymusi być rozłożona Drużyny" lub "Aplikacjemoże być rozłożona Moduły". W celu ograniczenia topologii są zazwyczaj w postaci"rzeczownikimoże / powinna / musi czasownik rzeczowniki". Na przykład, "Procesy może być w wykonaniu Drużyny" lub "Aplikacjesą hostowane na Serwery". Teraz można zobaczyć w każdym ograniczenia istnieją różne CAN / powinna / musi" eliminacje ", a te mogą być 3 typy;

· do wyboru- Będą one zazwyczaj używają słowa / frazy takie jak; "może", "może", "może", "ewentualnie" etc.

· Zalecana- Będą one zazwyczaj używają słowa / frazy takie jak; "powinien", "zalecane", "zaleca się" itd.

· Zleceniobiorca- Będą one zazwyczaj używają słowa / frazy takie jak; "koniecznością", "jest", "to", "ma", "powinien" itd.

W zależności od rodzaju ograniczeń lub topologii (hierarchii) i kwalifikacjach stosowane w opisie tego, określone ograniczenie (a) powinien być określony (patrz poniżej). Na powyższym przykładzie hierarchii "Wydziałymusi być rozłożona Drużyny"Należy zdefiniować" Jednostka musi mieć dziecko "ograniczenia i ustawić egzekwowania być egzekwowane. W powyższym przykładzie topologii"Procesy może być w wykonaniu Drużyny. "Należy stworzyć tylko dwa (2)" Połączenie musi być dołączony do komponentu "ograniczeń na obu końcach w wykonaniu typu połączenia szczególności następujące ograniczenia zaleca się określone (patrz poniżej) dla różnych opcji;

· Hierarchia ograniczeń;

o Rzeczowniki może byćrozłożona Rzeczowniki B, lub Rzeczowniki B może byćagregowane przez Rzeczowniki lub Rzeczowniki B powinno byćagregowane przez Rzeczowniki- Określenie "dziecko musi mieć dominująca" ograniczenie z typem pensjonatów dzieci jako rzeczownik, rodzaj dominującego jako rzeczownik A i egzekwowania, jak ostrzegał.

Notatka

Oznacza to, że jeżeli dziecko, powinien on mieć rodzica pewnego typu. Jeśli nie, to dostaniesz ostrzeżenie.

o Rzeczowniki powinno byćrozłożona Rzeczowniki B- Zdefiniuj "nadrzędna" Dziecko musi mieć ograniczenia z typem dominującym jako rzeczownik A, typu B dzieci jako rzeczownik i egzekwowania, jak ostrzegał.

Notatka

Oznacza to, że jeśli rodzic, powinien on mieć dzieci pewnego typu. Jeśli nie, to dostaniesz ostrzeżenie.

o Rzeczowniki musi byćrozłożona Rzeczowniki B- Definiowanie "Jednostka musi mieć ograniczenia z dziećmi" nadrzędnego typu A, jako rzeczownik dziecka jako rzeczownik typu B i egzekwowania, jak egzekwowane.

Notatka

Oznacza to, że jeśli rodzice nie istnieje, musi on mieć dzieci pewnego typu. Jeśli nie pojawi się błąd.

o Rzeczowniki musi byćagregowane przez Rzeczowniki B- Określenie "dziecko musi mieć dominująca" ograniczenie z typem A dzieci jako rzeczownik, rodzaj dominującego jako rzeczownik B i egzekwowania, jak egzekwowane.

Notatka

Oznacza to, że dziecko nie istnieje, musi mieć rodzica pewnego typu. Jeśli nie, pojawi się błąd.

· Ograniczenia topologii;

o Rzeczowniki może być czasownik Rzeczowniki B- Określ dwa (2) "Połączenie musi być dołączony do komponentów" ograniczeń. Pierwszy był do końca Źródło typu połączenia czasownikdołączone do rzeczownika typu części i egzekwowania ustawiony na przymusowych. Druga istota z końcem Sink od typu połączenia czasownikrzeczownik rodzaju dołączone do komponentu B i egzekwowania ustawionym na przymusowych.

Notatka

Oznacza to, że połączenie nie istnieje, musi połączyć elementy pewnego rodzaju. Jeśli nie pojawi się błąd. Ogólnie jest to zapewnia, że ​​te części składowe mogą nadal istnieje i nie mogą być ze sobą połączone. Jednak jeśli są połączone, należy stosować połączenia z prawej typu.

o Rzeczowniki powinno być czasownik Rzeczowniki B- Określ dwa (2) "Komponent musi być dołączony do połączenia" ograniczeń. Pierwszy jest z Rzeczownik typu części przymocowany do końca źródła czasownikTyp podłączenia i egzekwowania, aby ostrzegał. Druga jest z rzeczownik typ składnika B przymocowany do końca Sink z czasownikTyp podłączenia i egzekwowania, aby ostrzegał. Dodatkowo zdefiniować dwa (2) "Połączenie musi być dołączony do komponentów" ograniczeń. Pierwszy był do końca Źródło typu połączenia czasownikdołączone do rzeczownika typu części i egzekwowania ustawiony na przymusowych. Druga istota z końcem Sink od typu połączenia czasownikrzeczownik rodzaju dołączone do komponentu B i egzekwowania ustawionym na przymusowych.

Notatka

Oznacza to, że jeśli elementy obu typów występują, powinny być przyłączone do podłączenia do określonego typu. Jeśli nie otrzymasz ostrzeżenie. Ponadto, oznacza to, że połączenie nie istnieje, musi być podłączony do elementów określonego typu. Jeśli nie pojawi się błąd. Ogólnie jest to zapewnia, że ​​jeśli elementy z tych typów istnieje, można uzyskać ostrzeżeń, gdy nie są one połączone ze sobą.

o Rzeczowniki musi być czasownik Rzeczowniki B- Określ dwa (2) "Komponent musi być dołączony do połączenia" ograniczeń. Pierwszy jest z Rzeczownik typu części przymocowany do końca źródła czasowniktyp połączenia i egzekwowanie ustawiony na przymusowych. Druga jest z rzeczownik typ składnika B przymocowany do końca Sink z czasowniktyp połączenia i egzekwowanie ustawiony na przymusowych. Dodatkowo zdefiniować dwa (2) "Połączenie musi być dołączony do komponentów" ograniczeń. Pierwszy był do końca Źródło typu połączenia czasownikdołączone do rzeczownika typu części i egzekwowania ustawiony na przymusowych. Druga istota z końcem Sink od typu połączenia czasownikrzeczownik rodzaju dołączone do komponentu B i egzekwowania ustawionym na przymusowych.

Notatka

Oznacza to, że jeśli elementy obu typów występują, muszą być przymocowane do podłączenia do określonego typu. Jeśli nie pojawi się błąd. Ponadto, oznacza to, że połączenie nie istnieje, musi być podłączony do elementów określonego typu. Jeśli nie pojawi się błąd. Ogólnie jest to zapewnia, że ​​jeśli elementy z tych typów istnieje, to występują błędy, jeżeli nie są one połączone ze sobą.

Aby zdefiniować ograniczenie

1. Sprawdź, czy jest Plik ABACUSotwarte i Explorer Okno wystawiany.

2. W drzewie Explorer rozwiń Typy | Składowe Rodzajelub rozwinąć Typy | Rodzaje połączeń.

3. Kliknij prawym przyciskiem myszytyp części lub rodzaj połączenia i wybierz Dodaj Wiązanie.

Dodawanie ograniczenia

Aby zdefiniować ograniczenie hierarchii, gdzie rodzic musi mieć konkretnego dziecka

4. Na Dodaj Wiązanieokna zaznacz pole Tworzenie Wiązaniepole pod Dziecko rodzic musi mieć Wiązanie powierzchnia.

5. Wybierz część składowaz rozwijanej listy, który chcesz określić jako dziecko typ składnika wybranego w kroku 3.

Notatka

Jeśli jest już włączony "nadrzędna musi mieć dziecko" ograniczenia zdefiniowane dla typu elementu nadrzędnego i innego typu komponentu dziecka to ten nowy ograniczeniem będzie traktowana jako "I". To jest typ musi być rodzicem dziecka typu A iDziecko typu B, na jakimkolwiek poziomie egzekucyjnego (np Osób Niepełnosprawnych, Warned lub Wymuszone - patrz punkt 7) jest określony dla każdego ograniczeń.

6. Opcjonalnie można zdefiniować liczbę minimalnych i maksymalnych z elementów określonego typu części, które muszą być dziećmi typ składnika prawym kliknięciu w kroku 3.

7. Wybierz, czy ograniczenie się Wyłączone, Ostrzeżony lub Wymuszone.

Notatka

Niepełnosprawnych ograniczenia będą ignorowane z więzów walidacji, ostrzegł ograniczenia wyświetli ostrzeżenie w oknie walidacji, jeżeli są one wykryte i egzekwowane ograniczenia spowoduje błąd w oknie walidacji, jeżeli są one wykryte. Ponadto, wszystkie błędy muszą zostać rozwiązane, zanim Przedsiębiorstwo serwer Projekt może być zaangażowana.

8. Trzask ok.

Notatka

Ograniczenie będzie wyświetlany w drzewie eksploratora pod prawym typu części kliknięciu w kroku 3. strzałka oznacza kierunek ograniczeniem w tym przypadku będzie wskazywać w dół iw prawo. Kłódka jest koloru w zależności, czy ograniczenie jest wyłączony (szary), Warned (żółty) lub wykonane (czerwony).

Rodzic musi mieć dzieci ostrzegł ograniczenie

Aby zdefiniować hierarchii ograniczenie, gdy dziecko musi mieć konkretnego rodzica

4. Na Dodaj Wiązanieokna zaznacz pole Tworzenie Wiązaniepole pod Dziecko musi mieć Parent Wiązanie powierzchnia.

5. Wybierz część składowaz rozwijanej listy, który chcesz określić jako rodzica typu komponent prawym przyciskiem myszy w punkcie 3.

Notatka

Jeśli jest już włączony "dziecko musi mieć rodzica ograniczenie zdefiniowane dla dziecka typu części składowej i innego rodzaju macierzystego wtedy ten nowy ograniczeniem będzie traktowana jako" lub ". To jest typ musi być dzieckiem typu rodzic A lubTyp rodzic B, a poziom egzekwowania prawa (np Warned lub Wymuszone - patrz następny krok) powinny być takie same w inny sposób egzekwowane ograniczenia ostrzegali będzie zawsze zastępują te.

6. Wybierz, czy ograniczenie się Wyłączone, Ostrzeżony lub Wymuszone.

Notatka

Niepełnosprawnych ograniczenia będą ignorowane z więzów walidacji, ostrzegł ograniczenia wyświetli ostrzeżenie w oknie walidacji, jeżeli są one wykryte i egzekwowane ograniczenia spowoduje błąd w oknie walidacji, jeżeli są one wykryte. Ponadto, wszystkie błędy muszą zostać rozwiązane, zanim Przedsiębiorstwo serwer Projekt może być zaangażowana.

7. Trzask ok.

Notatka

Ograniczenie będzie wyświetlany w widoku eksploratora pod typ składnika wybranego w kroku 5. Strzałka wskazuje kierunek ograniczeniem w tym przypadku będzie wskazywać w górę iw lewo. Kłódka jest koloru w zależności, czy ograniczenie jest wyłączony (szary), Warned (żółty) lub wykonane (czerwony).

Dziecko musi mieć rodzica ostrzegł ograniczenie

Aby zdefiniować ograniczenia topologii, w którym komponent musi być dołączony do określonego połączenia

4. Na Dodaj Wiązanieokna zaznacz pole Tworzenie Wiązaniepole pod Składnik musi być dołączony Wiązanie powierzchnia.

5. Wybierz rodzaj połączeniaz rozwijanej listy, który chcesz określić jako załączonym połączenia typu komponent prawym przyciskiem myszy w punkcie 3. (lub wybierz część składowaz rozwijanej listy, który chcesz określić jako załączonego komponentu, jeśli w kroku 3 kliknij prawym kliknięciu typu połączenia.)

Notatka

Jeśli jest już włączony "Komponent musi być dołączony" ograniczenia zdefiniowane dla typu połączenia komponentowego i innego typu to ten nowy ograniczeniem będą traktowane jako "I". To jest rodzaj części musi być dołączony do typu połączenia A iPołączenie typu B, na jakimkolwiek poziomie egzekucyjnego (np Osób Niepełnosprawnych, Warned lub Wymuszone - patrz punkt 7) jest określony dla każdego ograniczeń.

6. Opcjonalnie można wybrać połączenie rolaktóre chcesz dodać do przymusu. Swybiera konkretny rola (czyli albo Źródło lub Sink) z rozwijanej listy.

7. Wybierz, czy ograniczenie się Wyłączone, Ostrzeżony lub Wymuszone.

Notatka

Niepełnosprawnych ograniczenia będą ignorowane z więzów walidacji, ostrzegł ograniczenia wyświetli ostrzeżenie w oknie walidacji, jeżeli są one wykryte i egzekwowane ograniczenia spowoduje błąd w oknie walidacji, jeżeli są one wykryte. Ponadto, wszystkie błędy muszą zostać rozwiązane, zanim Przedsiębiorstwo serwer Projekt może być zaangażowana.

8. Trzask ok.

Aby zdefiniować ograniczenia topologii, gdzie połączenie musi być dołączony do konkretnego komponentu

4. Na Dodaj Wiązanieokna zaznacz pole Tworzenie Wiązaniepole pod Połączenie musi być dołączony Ograniczenie powierzchnia.

5. Wybierz rodzaj połączeniaz rozwijanej listy, który chcesz określić jako załączonym połączenia typu komponent prawym przyciskiem myszy w punkcie 3. (lub wybierz część składowaz rozwijanej listy, który chcesz określić jako załączonego komponentu, jeśli w kroku 3 kliknij prawym kliknięciu typu połączenia.)

Notatka

Jeśli jest już włączony "Połączenie musi być dołączony" ograniczenia zdefiniowane dla typu połączenia i innego typu komponentu przy użyciu tego samego połączenia rola(czyli albo Źródło lub zlew), to nowe ograniczenia będą traktowane jako "LUB". To jest typ połączenia musi być dołączony do komponentu typu A lubTyp składnika B, a poziom egzekwowania prawa (np Warned lub Wymuszone - patrz punkt 7) powinny być takie same w inny sposób egzekwowane ograniczenia ostrzegali będzie zawsze zastępują te. Należy również zwrócić uwagę, że jeśli istnieje kilka ograniczeń, które mają połączenia rolaokreślić jako "każdy" (w przeciwieństwie do specyficznego źródła lub Sink), wówczas każdy z końców połączenia muszą być przyłączone do jednego z rodzajów składników podanych w ograniczeniach.

6. Opcjonalnie można wybrać połączenie rolaktóre chcesz dodać do przymusu. Swybiera konkretny rola (to jest zarówno Źródło lub Umywalka) z rozwijanej listy.

Notatka

Albo Źródło lub Sink rola musi być wyraźnie zaznaczony na Załącznik Kolumna być avilable być wyświetlane w składniku katalog .

7. Wybierz, czy ograniczenie się Wyłączone, Ostrzeżony lub Wymuszone.

Notatka

Niepełnosprawnych ograniczenia będą ignorowane z więzów walidacji, ostrzegł ograniczenia wyświetli ostrzeżenie w oknie walidacji, jeżeli są one wykryte i egzekwowane ograniczenia spowoduje błąd w oknie walidacji, jeżeli są one wykryte. Ponadto, wszystkie błędy muszą zostać rozwiązane, zanim Przedsiębiorstwo serwer Projekt może być zaangażowana.

8. Trzask ok.

Czas rzeczywisty Model kontroli i przymus uprawomocnienie

ABacus zawieramodelu w czasie rzeczywistym Sprawdzanie i Funkcja walidacji natychmiast pokaz skutki danej operacji użytkownik będzie miał on ostrzeżenia i błędy z bieżącego projektu, ze względu na dowolny hierarchia i topologia ograniczenia, które zostały zdefiniowane. Należy zauważyć, że wszystkie błędy muszą być rozwiązane zanim Przedsiębiorstwo serwer Projekt może być zaangażowana.

Funkcja sprawdzania poprawności ograniczenie w czasie rzeczywistym jest najbardziej zauważalne podczas wypełniania z diagramami lub bezpośrednio w oknie Eksploratora. W szczególności, podczas następujących operacji, wytyczne podane są za pomocą kolorów podświetlenia, co do efektu operacja będzie miała na ostrzeżenia i błędy z bieżącego projektu;

1. Podczas przeciągania elementów na lub wokół schematu koloru rodzica (lub mocowania) komponentu (jeśli istnieje) granica będzie kolorowe według schematu opisanego poniżej.

2. Podczas łączenia elementów za pomocą prawego przycisku myszy przeciągnij | Połącz z funkcji listę dostępnych typów połączeń jest kolorowe według schematu opisanego poniżej.

3. Podczas łączenia elementów na wykresach z wykorzystaniem trybu Connector kursor zmieni barwy według schematu opisanego poniżej.

4. Podczas dodawania podkomponentów lista dostępnych typów komponent jest kolorowe według schematu opisanego poniżej.

Na ogół następujące kolory są wykorzystywane do wskazania skutków operacji użytkownik będzie miał na ostrzeżeń i błędów z bieżącego projektu;

czarny : Brak wpływu na ostrzeżeń lub błędów.

Zielony : Operacja jest wyraźnie zgodnie zzdefiniowane ograniczenia hierarchii i topologii dla projektu.

Rudy : Operacja jest wyraźnie z naruszeniemzdefiniowane ograniczenia hierarchii i topologii dla projektu i spowoduje ostrzeżenia i / lub błędów.

Tło Model kontroli i przymus uprawomocnienie

ABACUS zawiera Funkcja sprawdzania poprawności, aby wyświetlić wszystkie ostrzeżenia i błędy z bieżącego projektu, ze względu na wszelkich ograniczeń, które zostały określone. Należy zauważyć, że wszystkie błędy muszą być rozwiązane zanim Przedsiębiorstwo serwer Projekt może być zaangażowana.

Notatka

Walidacja należy ręcznie uruchomić poprzez "Zatwierdź / Sprawdzić ograniczeń projektu" przycisk na Główny pasek narzędzi , Okno Walidacja jest domyślnie ukrytyale gdy pojawi się na pasku narzędzi przycisk kliknięciu, Widzieć Dostosowywanie interfejsu dla jak go odkryć i potencjalnie pozostawić wyświetlany na stałe. Ponadto, można dwukrotnie kliknąć dowolny wiersz w oknie walidacji do "skoku" do odpowiedniego elementu w projekcie.

Okno walidacji

Domyślne kolumny w oknie walidacji są opisane w następujący sposób;

Ostrzeżenie lub błąd: Ta kolumna wyświetla ikonę, czy naruszenie to Ostrzeżenie (żółty trójkąt z wykrzyknikiem) lub błędu (czerwone kółko z krzyżykiem).

Numer: Ta kolumna wyświetla liczbę naruszenia.

Notatka

Tylko 200 naruszeń są pokazane w czasie, a jeśli jest ich więcej niż 200 naruszeń w projekcie Start, Prev, Next i nawigator Koniec wiersza w prawej górnej części okna mogą być wykorzystywane do przeglądania dodatkowych naruszeń.

Opis: Jest to pełny opis naruszenia, w tym jednostki i Constraint danego.

Jednostka: Ta kolumna wyświetla Podmiot troski naruszenia.

Rodzaj: Ta kolumna wyświetla typ elementu dla jednostki.

Architektura: Ta kolumna wyświetla Architecture, w którym nastąpiło naruszenie.

Wykrywane: Ta kolumna wyświetla czas, który został wykryty naruszenie.

napiwek

Warto uporządkować malejąco wg Wykryte kolumnie (jak pokazano w oknie powyżej), aby zapewnić najnowsze naruszenia pojawiają się na "szczycie" listy.

Istnieje kilka opcji użytkownikowi na zmianę zachowania walidacji modelu tła. Na przykład, To zmienić kolory używane do naruszenia ograniczeń na coś innego niż domyślny Rudy, trzask Narzędzia | Opcji ... a następnie przejść do Uprawomocnieniekartę, a ustawić kolory poprzez Zmiana pikolak.

Uprawomocnienie Opcje

Aby ręcznie zweryfikować ograniczeń

1. Kliknij prawym przyciskiem myszy na ArchitekturWęzeł każda architektura lub w dowolnym miejscu albo podzespoły lub Znajomościczęść widoku eksploratora i wybierz Sprawdzić Ograniczenia.

Weryfikacja ograniczeń

2. Kliknij Bliższe danePrzycisk na Ostrzeżeniaokno, aby zobaczyć gdzie architektura narusza żadnych ograniczeń, które zostały określone.

Notatka

Naruszenia są wyświetlane tylko dla tych ograniczeń, które zostały ustawione na Warned lub egzekwowane. Ponadto treść ostrzeżenia będzie to "powinno", czy ograniczenie było tylko ostrzeżenie lub "musi" jeśli to było egzekwowane.

3. Trzask ok.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie


Się rozwija swoją architekturę

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie ręcznie> Dodatkowe opcje>

Się rozwija swoją architekturę

Wyślij komentarzy w tym temacie.

Architektur można wyraźnie ewoluował i hierarchia architektur stworzył. W ten sposób rozwija swoją architekturę przez w ABACUS szereg zaawansowanych rozwiązań architektonicznych mogą być tworzone, porównywane i baselined. Cele (lub metryki) można zdefiniować dowolną liczbę właściwości architektonicznych dla istniejących architektur.

Prosty sposób, aby uwzględnić ewolucję architektury jest odnosić się do koncepcji potomkiem architektury, Gdy architektura ewoluowała, A Kopiujarchitektury macierzystego utworzony. Ten egzemplarz może być uznane za bezpośrednie potomekoryginału roślina mateczna architektura.

Notatka

W tej dokumentacji i pomocy online ABACUS sam w sobie zestaw narzędzi, termin ewoluowaćsą powszechnie stosowane od terminu potomekNależy pamiętać, że oba odnoszą się do tej samej funkcjonalności.

Rozwijać istniejącą architekturę

1. Sprawdź, czy jest Plik ABACUSotwarte i Explorer Okno wystawiany.

2. Wybierz odpowiednią architekturę, którą chcesz się rozwijać z drzewa Explorer.

3. Kliknij prawym przyciskiem myszyna architekturze i wybierz Ewoluowaćz menu.

Ewoluuje wybranego Architektura

4. Rozwijaną architektura pojawi się poniżej wybranej architektury.

Evolved Architecture

Notatka

Rozwijaną architektury można zmienić klikając prawym przyciskiem myszy i wybierając architektury Przemianować.Ponadto, wszystkie schematy i katalogi w ewoluował architektury zostanie automatycznie ustawiona na "diff" przeciw architektury bazowej że został on ewoluował od.

Wyznaczanie celów dla swojej ewoluował architektury

Wyznaczanie celów dla swojej ewoluował architektury pozwala na stworzenie kryteriów oceny rozwoju swojej architektury. Cele są określane przez rodzaje nieruchomości oraz nazwy tych właściwości istniejących w ewoluował architektury. Cele mogą być ręcznie zdefiniowany i dodany do architektury. Wykonaj poniższe czynności, aby ustalić cele.

Wyznaczanie celów z istniejących właściwości dla ewoluował architektury

1. Sprawdź, czy jest Plik ABACUSotwarte i Explorer Okno wystawiany.

2. Wybierz Narzędzia | Wyznaczone celeZ głównego menu.

3. Wejście bramkiwyświetlane jest okno.

Celem Okno wejściowe

4. Kliknij na Istniejący przycisk.

5. Wybierz nieruchomościwyświetlane jest okno.

6. Wybierz nieruchomość, którą chcesz ustawić jako cel dla ewoluował architektury i kliknij ok przycisk.

7. Wybrany cel pojawi się w Wejście bramki okno.

8. Wybierz cel i kliknij Edytować przycisk.

9. Edycja bramkiwyświetlane jest okno.

Notatka

To okno pozwala zmienić nazwę właściwości i rodzaj, że celem będzie odzwierciedlać, jak również najgorsze i najlepsze wartości (lub minimum / wartości maksymalne) dla tej nieruchomości. Wartości te znajdują się przez porównanie wszystkich architektur i znalezienie najmniejszej i największej wartości w każdym dla tej konkretnej nieruchomości. Wartości te mogą być ręcznie określone. Na przykład, jeśli były, aby wyznaczyć sobie cel dla nieruchomości o nazwie Odpowiedź (Ave)oraz typ ZachowanieTwój najgorszy i najlepszy stosunek może odzwierciedlać szybkość transakcji potrzebne do optymalnej wydajności (najlepsza wartość) i szybkość transakcji potrzebne tylko głównych aplikacji do przetworzonej (najgorsza wartość).

10. Po odpowiednie wartości zostały określone, wybierz ok.

Wyznaczanie celów z nowych właściwości dla ewoluował architektury

1. Sprawdź, czy jest Plik ABACUSotwarte i Explorer Okno wystawiany.

2. Wybierz Narzędzia | Wyznaczone celeZ głównego menu.

3. Wejście bramkiwyświetlane jest okno.

4. Kliknij na Nowy przycisk.

5. Nowe bramkiwyświetlane jest okno.

Notatka

Okno to pozwala zdefiniować nazwę właściwości i rodzaju, że celem będzie odzwierciedlać, jak również najgorsze i najlepsze wartości (lub wartości minimalnych /) dla tej nieruchomości. Na przykład, jeśli były, aby wyznaczyć sobie cel na nieruchomości o nazwie Odpowiedź (Ave)oraz typ ZachowanieTwój najgorszy i najlepszy stosunek może odzwierciedlać szybkość transakcji potrzebne do optymalnej wydajności (najlepsza wartość) i szybkość transakcji potrzebne tylko głównych aplikacji do przetworzonej (najgorsza wartość).

6. Po odpowiednie wartości zostały określone, wybierz ok.

7. Okno dialogowe do Dodaj do wszystkich architekturachpokaże, jak poniżej:

8. Kliknij Takdodać cel jako właściwość do wszystkich odpowiednich architektur. Zapewnia to, że nowo określony cel i jego właściwości będą dodane do wszystkich architektur pliku. Jeśli nie chcesz, to nieruchomości w architekturze, możesz kliknąć na Nie.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Przedstawiamy gwiazda fabułę swojego ewoluowały architektur | Przedstawiamy wykres punktowy swoimi ewoluowały architektur


Losowanie Narzędzie

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Losowanie Narzędzie

Wyślij komentarzy w tym temacie.

Losowanie Narzędzie pozwala na tworzenie wielu różnych schematów architektonicznych i schematów. Architekci tradycyjnie korzysta z wielu różnych rysunków do nagrywania i przekazać projekt architektury. Dwuwymiarowe (2D) schematy są zwykle sposób dokumentowania i komunikowania różnych części systemu. Typowe rodzaje rysunków stosowanych w systemach przedsiębiorstwa są:

· Modele procesów biznesowych i wykresy;

· Schemat organizacyjny;

· Schematy współpracy;

· Związków encji (ER) schematy;

· Diagramy przepływu danych (DFD użytkownika);

· Diagramy klas;

· IDEF (zawierające kilka z powyższych); i

· UML (zawierające kilka z powyższych).

Naprawdę nie ma ograniczeń co do rodzaju diagramów, które można utworzyć. ABACUS próbuje zrównoważyć elastyczność schemat, przy jednoczesnym zachowaniu integralności architektury i jej form reprezentacji.

Środowisko rysunek jest zakładkami i dockable okno wewnątrz głównej aplikacji ABACUS. Okno to zawiera rysunek płótno, gdzie i kiedy odbywa się w oknie rysunku piewszej sekundę dockable okno Okno szablon, jest widoczny z zestawem szablonów rysunkowych. Okienko szablon posiada 4 zakładki: części, połączenia, kształtów i łączników. Płótno pojawia się jako białym tle z drobnych linii siatki (pomocne dla układu).

Są reprezentowane przez różnych kształtach, a połączenia są przedstawione jako skierowane linie. Połączenia dołączyć do elementów za pomocą role (czyli albo Źródło lub Sink) chociaż nie pokazano ze względów estetycznych.

napiwek

Podczas Schematysą bardzo przydatne do pokazywania różnych części systemu, są ograniczone w ich skalowalność, dlatego ABAKUS wykorzystuje 3D do wizualizacji złożonych struktur systemu.

Możesz

1. Otworzyć Diagramów Narzędzie

2. Utwórz nowy schemat w ramach architektury

3. Skopiuj schemat wewnątrz lub na wszystkich architekturach

4. Dodaj elementy na schemacie

5. Tworzenie nowych komponentów i połączeń w architekturze (w uproszczeniu) za pomocą narzędzia rysowania

6. Usuń składniki ze schematem

7. Dołączyć i manipulować połączenia

8. Zmienić Właściwości wyświetlania komponentów i połączeń.

9. Korzystanie linki w diagram

10. Egzekwowanie skojarzenia typów i punkty widzenia tak, aby ograniczyć typy diagramów, które można wyciągnąć.

Zobacz też

Wypełnianie swoją architekturę | Wypełnianie swoją architekturę ręcznie | Analizowanie Twoja architektura


Otwarcie Schematy

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Otwarcie Schematy

Wyślij komentarzy w tym temacie.

Rysunku wzornik i płótno okna pojawia się automatycznie, kiedy schemat jest otwarty lub utworzony. Podobnie, kiedy schemat jest zamknięty, odpowiednie blachy zakładkami w oknie płótno znika, gdy żadne dalsze rysunki są otwarte wówczas okno wzornik jest zamknięty.

Do Stwórznowy schemat

1. Sprawdź, czy jestPlik ABACUS otwartazawierające swojej zaludnionych architektury.

2. Kliknij na Diagramikony na pasku narzędzi Widok.

- lub -

2. Wybierz Wstawić| Diagram.

- lub -

2. Kliknij prawym przyciskiem myszy Schematygałąź dana Architekturaczęść drzewa i wybierz Stwórz Diagram.

3. Wybierz Architekturachcesz skupić się na z menu rozwijanego. Uwaga: architektura będzie już wybrana dla Ciebie, jeśli używany Krok 3 powyżej, aby otworzyć nowy schemat.

4. Wybierz Punkt widzenia chcesz korzystać z menu rozwijanego. Uwaga: wybrany punkt widzenia będzie filtrować komponentów i listy połączeń za te dostępne tylko punktu widzenia.

5. Opcjonalnie można wybrać widok z Filtruj według Viewrozwijanego menu wybierz wstępnie elementy i połączenia z wybranego widoku. Uwaga: ten jest skutecznie za pomocą wybranego widoku jako zapisanego zapytania.

6. Wybierz Układ być albo Promieniowy lub Ruszt.

7. Wybierz podzespoły i Znajomościże chcesz na schemacie z Okno wyboru standardowym elementem .

8. Trzask ok.

Notatka

Nowy wykres zostanie dodany do Schematygałąź architektury. Będzie mieć nazwę domyślną, którą można później zmienić klikając prawym przyciskiem myszy na jej temat.Ponadto ostatni stan filtrów składowych i selekcji połączenia zostaną zapisane w schemat skutecznie ratowanie "zapytanie", używany do tworzenia diagramu.

Aby otworzyć istniejący diagram

1. W konkretnym zaludnionym architektury rozwiń Schematygałąź drzewa.

2. Podwójne kliknięcie schemat, który chcesz otworzyć.

Aby zapisać schemat

1. Upewnij się, że masz nowy lub istniejący schemat Otwartei dokonaniu niezbędnych zmian. Uwaga: gwiazdkę '*' zostanie pokazany po nazwie widoku w kartach nagłówku arkusza, czy są zmiany zostaną zapisane.

2. W widoku eksploratora kliknij Ratowaćprzycisk lub dostał się do Plik| Ratowaćlub nacisnąć Ctrl + Saby zapisać wszystkie zmiany w architekturze i pisać go do pliku.

Aby zapisać schemat w postaci punkt widzenia

1. Upewnij się, że masz już schemat w pliku ABACUS.

2. Kliknij prawym przyciskiem myszyschemat w Schematyczęść drzewa.

3. Wybierz Zapisz jako Schemat Widzenia.

4. Wprowadź nazwę dla nowego Schemat widzeniai kliknij ok.

Zobacz też

Losowanie Narzędzie | Wypełnianie swoją architekturę | Analizowanie Twoja architektura


Schematy Kopiowanie

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Schematy Kopiowanie

Wyślij komentarzy w tym temacie.

Istnieją 2 podstawowe scenariusze do kopiowania istniejący schemat; w ramach architektury, czy na wszystkich architekturach.

Do Kopiujschematw architekturze

1. Sprawdź, czy jestPlik ABACUS otwartazawierające swojej zaludnionych architekturyco najmniej jeden diagram.

2. Rozszerzać Schematy gałąź (i wszelkie wymagane Diagramie) danej ArchitekturaSekcja drzewa.

3. Wybierz wykres chcesz skopiować, a następnie naciśnij Ctrl + C lub kliknij prawym przyciskiem myszyi wybierz Kopiuj z menu.

Notatka

A kopią Schemat zostanie dodany do SchematyOddział z podobnie architektura. To będzie mieć "Kopia" dołączany do początku nazwy, Które można zmienić później naciskając klawisz F2 lub kliknięcie prawym przyciskiem myszy na nimi wybierając polecenie Zmień nazwę.

Do skopiować schemat całej architektury

1. Sprawdź, czy jestPlik ABACUS otwartazawierające swojej zaludnionych architekturysco najmniej jeden diagram.

2. Rozszerzać Schematy gałąź (i wszelkie wymagane Diagramie) z ArchitekturaSekcja drzewadla architektury, która zawiera schemat, który chcesz skopiować.

3. Wybierz wykres chcesz skopiować, a na Właściwości ogólneOkno Uwaga Punkt widzenia że schemat jest związana z (w zakresie rodzaju).

4. Ale już, rozszerzać Schematy gałąź (i wszelkie wymagane Diagramie) z ArchitekturaSekcja drzewadla drugiej architektury, które chcesz skopiować schemat do.

5. Kliknij prawym przyciskiem myszy Schematy węzła (lub Grupa schemat) I wybierz Tworzenie diagramu ..., W wyświetlonym oknie dialogowym zaznacz Punkt widzenia Odnotowano, że w punkcie 3 powyżej, w menu rozwijanym w prawym górnym rogu. Zostaw wszystko inne, jak jest i kliknij ok, W oknie dialogowym Schemat Nazwa wpisz nazwę (wkrótce) skopiowanego schemacie. Uwaga: Otworzy się puste schemat płótno według wybranego punktu widzenia.

6. Powrót do schematu, który chcesz skopiować i otworzyć, że kliknięcie prawym przyciskiem myszywęzeł i wybierając Otwarte lub po prostu podwójne kliknięcie ono.

7. Wybierz tło płótno wykresu, który chcesz skopiować, a następnie naciśnij Ctrl + A, Spowoduje to zaznaczenie wszystkich elementów na tym schemacie. Teraz naciśnij Ctrl + Caby skopiować zawartość do schowka.

8. Teraz powrót do pustego diagramu w architekturze, który chcesz skopiować zawartość do, wybrać tłopłótno i albo kliknij prawym przyciskiem myszyi wybierz Pasta lub po prostu naciśnij Ctrl + Vaby wkleić zawartość. Po krótkim czasie zawartość będzie wszystko wklejony do nowego schematu pusty.

Notatka

Elementy zostaną dodane do najwyższego poziomu nową architekturę i będą musiały być ponownie umieszczone lub scalone z istniejącej zawartości odpowiednio.

Zobacz też

Losowanie Narzędzie | Wypełnianie swoją architekturę | Analizowanie Twoja architektura


Wypełnianie Schematy

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Wypełnianie Schematy

Wyślij komentarzy w tym temacie.

Rysunki w ABACUS to coś więcej niż arbitralne reprezentacji. Są one dostosowane widoki architektury, sformatowane i rozmieszczone, aby pokazać szczególne znaczenie.

Narzędzie wymusza na rysunku hierarchiczną strukturę architektury, tak, że komponenty są wizualnie zagnieżdżone w innych składników - skutecznie dając "rzut" elementów. Gdy składnik lub połączenie zdefiniowano w architekturze, może być wykorzystywane w dowolnej liczbie różnych wykresów. Co istotne, narzędzie rysowania jest ściśle powiązana z modelu architektonicznego, więc, że zmiany dokonane w jeden zawsze są widoczne w drugiej.

Narzędzie działa poprzez kształty z poszczególnych rodzajów połączeń i komponentów określonych w sekcji Typy architektury. Związki te różnią się w zależności od rodzaju schematu ciągniętą, i jest możliwe, że jeden rodzaj komponentu (lub połączenia) mogą mieć różne reprezentacje w różnych schematów, w zależności od kontekstu.

Aby założyć stowarzyszenie między kształtu i typu części lub połączenia

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Maksymalizacja aplikację ABACUS i skonfigurować proporcje okien jak chcesz.

3. Wybierz Zakładka Kształty albo Zakładka Złącza W oknie wzornika.

4. W Rodzajoddział Explorer, znajdź typ komponentu lub połączenia, które chcesz skojarzyć z kształtu lub złącza.

5. Wybierz typ elementu wybranego w drzewie, przeciągnij go do karty kształty lub karcie Connectors, a upuść go kształtu lub złączachcesz używać.

Notatka

Możesz sprawdzić, utworzonego przez wybranie części lub kartę Połączenia w oknie szablon, które pokazują aktualnie skojarzone elementy stowarzyszenie.

Aby dodać nowe kształty do diagramów / biblioteki

1. Utwórz wykres MS Visio z kształtów, które chcesz dodać do wykresu i zaimportować schemat MS Visio .

napiwek

Ważne jest, jaki rozmiar sprawiają, że kształt głównego w MS Visio, ponieważ płótno ABACUS ma rozmiar w pikselach, a tylko jednostki milimetrów MS Visio konwersji granularly do pikseli na 4 piksele do 1 stosunek milimetra. Ponadto standardowe kształty ABACUS są zazwyczaj 60 pikseli wysokości tak, że przekłada się na 15 milimetrów w MS Visio. Znaczenie niepożądana Mistrz wielkość kształtu w MS Visio jest 25mm szerokości i 15mm wysokiejjak to przełoży się na 100 pikseli szerokości i 60 pikseli wysokości w ABACUS.

napiwek

Jeśli chcesz mieć "ikonę" trochę w górnym lewym rogu kształtu, to możesz po prostu stworzyć 'ikonę' w głównej MS Visio kształtu przy użyciu palety MS Visio narzędzie do rysowania (należy pamiętać, że tylko proste linie, okręgi i prostokąty są obsługiwane i kształtów rasteryzacji / bitmap w szczególności nie są obsługiwane). Ponadto, jeśli chcesz ikona być Rodzaj / stałe w skaliw kształcie w ABACUS następnie można grupować 'ikona' w głównej MS Visio kształt, wybierając wszystkie jego elementy, klikając prawym przyciskiem myszy jeden element, wybierając kształt | Grupa, a następnie kliknij prawym przyciskiem myszy i wybierając kształt zgrupowanych danych | Kształt danych ..., wybierając Tak w oknie dialogowym, a następnie dodanie nieruchomość na rzecz znaku ustawiony na LockScale(zwróć uwagę na wielkie litery "L" i "S"), typ ustawiony na Boolean a wartość ustawiona na PRAWDZIWE (Uwaga: to wszystko wielkimi literami).

napiwek

Jeśli chcesz mieć część kształtu zamrożone od skalowania w poziomie lub w pionie (co jest typowe z "tor" kształtu), a następnie kliknij prawym przyciskiem myszy element (y) Mistrza MS Visio kształt, który ma zamrożone od skalowania i wybierz danych | Kształt danych ..., wybierając Tak w oknie dialogowym, a następnie dodanie nieruchomość na rzecz znaku ustawiony na LockXScale lub LockYScale (zwróć uwagę na wielkie litery "L" i "S"), typ ustawiony na Boolean a wartość ustawiona na PRAWDZIWE (Uwaga: to wszystko wielkimi literami), dla zablokowana skalowanie poziome lub pionowe, odpowiednio.

napiwek

Aby zezwolić na kolorystykę kształcie w ABACUS po zaimportowaniu niż kształt zawsze jest stały kolor wskazane jest, aby wypełnić mistrza MS Visio dla kształtu w przezroczysty a następnie za pomocą wbudowanego umiejętności w ABACUS do koloru tła kształt jest. To działa tylko z prostokąta lub prawie prostokąta (np zaokrąglony prostokąt) kształty prostokątne, jak cała będą kolorowe tło.

2. Otworzyć odpowiedni schemat i wybierz Zakładka SkładnikiW oknie wzornika.

3. Dla każdego nowego kształtu, który chcesz udostępnić innych schematów Kliknij prawym przyciskiem myszykształt i wybierz Dodaj do kształtów Bibliotece, Spowoduje to, że kształt dostępne na karcie kształty w oknie szablonu.

4. Kojarzy odpowiedni typ komponentu z nowym kształcie z biblioteki kształtów według kroków opisanych powyżej.

Notatka

Tylko proste i "wektor własnych" kształty są obsługiwane w ABACUS w tej chwili, czyli bitmapy nie są obsługiwane. Jednak narzędzia, takie jak Vector Magii ( www.vectormagic.com ) Są dostępne, które łatwo przekonwertować bitmapy do kształtów wektorowych (oparte na formacie SVG) znaczy, że może być otwarty w MS Visio, a więc wykorzystywane w ABACUS według powyższych instrukcji.

DodawanieKomponenty i Połączenia

Losowanie narzędzie pozwala na dodać istniejące komponenty i połączenia z repozytorium lub tworzyć nowe elementy i połączenia, jak są rysunek schemat. Jako elementy i połączenia są tworzone w schematach są dodawane jednocześnie do magazyn, Są trzy poleca sposoby dodawania składników do schematua trzy zalecane sposoby na dodanie połączeń do schematu:

Aby utworzyć zupełnie nowy komponent lub połączenie na schemaciez wzornika

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Wybierz podzespoły lub Znajomościzakładka w oknie szablonu, aby zobaczyć powiązane kształty. Tylko te kształty mogą być stosowane do tworzenia nowych elementów wzorów.

3. Kliknij i przeciągnijjeden z dostępnych związanych kształtów na płótno rysunku. Nowy element pojawi się na płótnie i na drzewie eksploratora.

4. Zacznij pisaćnazwę nowego elementu w oknie dialogowym i wszelkich istniejących elementów, które są dopasowane są sugerowanymi i mogą być wybrane zamiast dodawać nowy element do architektury.

5. Trzask ok.

6. Jeśli kształt został upuszczony istniejącego komponentu, to będzie albo stać się dzieckiem tego składnika (jeżeli kształt przyszedł z podzespołyZakładka), lub zostanie dołączony do tego składnika (jeżeli kształt przyszedł z Znajomości patka).

Notatka

Czasami konieczne jest, aby ustawić nowy komponent lub połączenie do innego miejsca w hierarchii architektonicznej przy użyciu Eksploratora.

Aby umieścić istniejący komponent lub połączenie z magazyn na schemacie

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Upewnij się, że masz zarówno narzędzia do rysowania i Windows Explorer widoczne.

3. W Eksploratorze, zlokalizować składnik lub połączenie(element) chcesz dodać do wykresu.

4. Kliknij i przeciągnijwybranego elementu na schemacie. Kształt reprezentujący element pojawi się na płótnie.

Notatka

Jeśli typ wybranego elementu jest już związana z kształtem, odpowiedni kształt pojawi się na płótnie. Jeśli jednak nie ma ustalonego dla danej stowarzyszenie elementu, domyślny kształt (prostokąt) pojawi się na płótnie, chyba że Egzekwowanie Diagram Punkty widzenia Opcja ta jest w tym przypadku nie dodaje się kształt na schemacie.

napiwek

Gdy element jest umieszczony na schemacie, który jest połączony z innym elementem już na schemacie na rysunku Narzędzie zapytanie, czy chcesz pokazują połączenie (a) pomiędzy nimi. Ponadto, jeśli są jakieś dzieci komponentu rysunku Narzędzie wyśle ​​zapytanie, czy chcesz, aby to dzieci, rekursywnym sposób.

Do tworzenie połączenia między 2 komponentów lub podłączonego urządzenia na schemacie za pomocą dynamicznego złącze

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Wahać się ponad elementu na schemacie, który chcesz połączyć z innym elementem i można zauważyć 2 ikony pojawiają się poza prawym górnym rogu granicy kształtu, jak pokazano poniżej. Uwaga: Górna ikona jest do tworzenia połączenia, gdzie unosił się elementem ma być źródłem dolna ikona jest do tworzenia połączenia, gdzie unosił się elementem ma być zlew.

3. Poruszać się kursor na żądaną ikonę i Kliknij i przeciągnijikona do ponad albo nad innym komponentem lub wolnego miejsca na płótnie, jak pokazano poniżej.

4. Aby podłączyć się do istniejącego komponentu wybrać Dołączyć do...pozycja w menu podręcznym, a w razie potrzeby przejść do podmenu, aby wybrać jedną z dostępnych typów połączeń.

- lub -

4. Aby utworzyć podłączony komponent wybrał z Nowy...pozycje w menu podręcznym, a w razie potrzeby przejdź do podmenu, aby wybrać jedną z dostępnych typów połączeń, jak pokazano poniżej. Zacznij pisaćnazwę nowego elementu w oknie dialogowym i wszelkich istniejących elementów, które są dopasowane są sugerowanymi i mogą być wybrane zamiast dodawać nowy element do architektury.

Notatka

Dostępność pozycji w menu pop-up i podmenu jest regulowane przez Ograniczenia w meta-modelu.To jest tylko ważne źródło lub tonąć typy komponentów określonych przez ograniczenia połączeń zostanie przedstawiony jako ... Dołącz do Nowego ... i elementów menu.

Do ponownie otworzyć okno wyboru elementu i miejsce istniejących komponentów lub połączenia z repozytorium na diagramie

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Trzask Otwórz Wybór ElementPrzycisk na pasku narzędzi Wykres. Uwaga: Okno wyboru elementem otworzy ostatniego stanu filtrów, zapisanych.

3. Wybrać dowolne dodatkowe materiały, które chce się dodać do diagramu i kliknięcie ok, Uwaga: nowa treść zostanie dodana do wolnej przestrzeni na płótnie i schemat może być później rozplanowane ponownie za pośrednictwem Układ SchematPrzycisk na pasku narzędzi Wykres.

Korzystanie BezpłatneformaKształty

Często jest pożądane, aby utworzyć elementy wizualne w schemacie ze względów czysto estetycznych. Elementy te mogą przyczynić się do poprawy układ i wygląd wykresu, ale nie mają ścisłego znaczenia architektonicznego. Losowanie Narzędzie pozwala na korzystanie z swobodnych kształtów, aby zapewnić elastyczność rysunek.

Aby dodać kształt nieregularnych kształtach z wykresem

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Wybierz Kształty lub Złączazakładka w oknie szablonu.

3. Kliknij i przeciągnijjeden z dostępnych kształtów lub złączy na płótno rysunku. Nowy element pojawi się na płótnie - ale niew drzewie eksploratora.

Notatka

Freeform kształty są "nie wiąże się" kształtów, ponieważ nie mają one związek z konkretnym składniku lub połączenia w modelu architektonicznego.

Do wyświetlić repozytorium informacji w dowolnych kształtówsynschemat

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Kliknij prawym przyciskiem myszydowolnych kształtów i wybierz Adnotacja | Pokaz.

3. Wybierz, aby wyświetlić albo Schemat Nazwa, Schemat Opis, Schemat nieruchomości, Widzenia Nazwa lub Architektura Nazwa.

Notatka

Tekst w Freeform automatycznie zaktualizuje jako podstawowych repozytorium zmian danych.W ten sposób schemat "Tytuł bloku" mogą być tworzone dla, a następnie łatwo skopiowane, diagramy.

Korzystanie Kształty Pływające

Pływające kształty są zasadniczo inny sposób do reprezentowania elementów w diagramie. Należy rozważyć organizację z kluczowych działów: CEO, marketingu, sprzedaży i rozwoju.

Widok drzewa

Przegrody te mogą być wizualnie reprezentowane warstwowo:

Warstwowa Zobacz

Lub mogą one być wizualnie przedstawione w układzie schodkowym / ruchomy sposób, aby pokazać hierarchię:

Zatoczył / Ruchomy Widok

To ostatnie przedstawienie wykorzystuje pojęcie pływających kształtach.

Aby przekonwertować warstwową komponentów kształt na pływający kształcie

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Wybierz składnikw schemacie chcesz reprezentować jako pływające kształtu lub podmiotu stowarzyszonego kształt w podzespołyZakładka okna szablonu chcesz wszystkie instancje jak pływające kształtach.

3. Kliknij prawym przyciskiem myszy i wybierz kształt Float komponent z menu kontekstowego, które się pojawi. Zauważ, że diament czele połączeniaze składnika (ów) Jednostka do składnika (ów) pływającej.

4. Kliknij i przeciągnijskładnik w odpowiednim miejscu. Kiedy ruchomyskładnik wybrany będzie mieć zarys niebieski.

Aby przekonwertować pływającą kształt komponentów do warstwowej kształcie

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Wybierz składnikw schemacie, który jest aktualnie wyświetlany jako pływającą kształtu lub podmiotu stowarzyszonego kształt w podzespołyZakładka okna szablonu chcesz wszystkie instancje jak warstwowe kształty.

3. Kliknij i przeciągnijskładnik (e) pływających powrotem do rodzica (ów) (zgodnie z diament czele połączenia). Uwaga: Jeśli tego nie zrobi to podczas konwersji składnika (ów) z powrotem do ich warstwowe hierarchia modelu może mieć wpływ.

4. Kliknij prawym przyciskiem myszy kształt i odznacz Float komponent z menu kontekstowego, które się pojawi. Należy zauważyć, że diament czele połączeniaz składnikiem (a), dominująca do składnika (ów) unoszące zniknie.

Repliki

Losowanie narzędzie pozwala na dodać ten sam element w schemacie kilka razy z każdej dodatkowej wizualnej przykład składnika na schemacie określany jako repliki. Jest to szczególnie użyteczne w schematach, w których komponent ma wiele połączeń z nim związane i korzystne jest, aby pokazać składnik w wielu miejscach bliżej pochodzeniu każdego połączenia lub na wykresach, w którym relacja jeden-do-wielu składnika w postaci korzystne jest, aby pokazać użyciu funkcji pływającego (opisanego powyżej) ze składnikiem w wielu miejscach na górnej części "wiele" części jest związane.

Notatka

Można dołączyć / odłączenie połączenia do / z pierwotnego przykład składnika na wykresie (jak zwykle), ale również do każdego z replik jednak, gdy połączenia są dodawane automatycznie do diagramu są przyłączone do pierwszego przykładu komponentu na schemacie domyślnie.

Notatka

Repliki mogą być połączone ze sobą za pomocą kliknij prawym przyciskiem myszy i przeciągnijnastępnie wybierając Scalanie ReplikiJednak połączenie replikę innym komponentem spowoduje żadnych innych replik znikają z wykresu.

Notatka

Nie ma widocznej różnicy między oryginalnej instancji składnika na diagramie i wszelkich replik. Co więcej, kliknij prawym przyciskiem myszy menu dla oryginalnego elementu na schemacie i dowolnej repliki jest identyczna, na przykład Pokazać w przeglądarcebiorąc do tego samego elementu w widoku drzewa repozytorium (aka modelu). Jednakże, kliknięcie prawym przyciskiem myszy komponent w widoku drzewa repozytorium i wybraniu Iść doi przeglądanie na schemacie z replikami zawsze będzie można dostać się do "najstarszych" przykład elementu na schemacie. Zazwyczaj będzie to oryginalna instancji, który został dodany do schematu, ale jeśli to oryginalne wystąpienie zostało następnie usunięte lub połączone z repliką a następnie przejść do przeskoczy najstarszy, które zostały dodane do pozostałych replik.

Do dodać repliki do diagram

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Kliknij prawym przyciskiem myszy istniejący element na schemacie, a następnie wybierz Tworzenie repliki.Replika wybranego składnika zostanie utworzony na prawo od pierwotnego elementu.

- LUB -

Wybierz element istniejącego na schemacie i naciśnij Ctrl + Club kliknij prawym przyciskiem myszy istniejący element na schemacie, a następnie wybierz Kopiuj, Teraz kliknij prawym przyciskiem myszy lokalizację na schemacie, który ma replikę i wybierz Wklej jako Replika, Uwaga: Naciśnięcie Ctrl + V (lub kliknąć prawym przyciskiem myszy i wybierając polecenie Wklej) utworzy kopię oryginalnego komponentu nie replikę.

- LUB -

Kliknij i przeciągnijelement z widoku drzewa repozytorium (aka modelu) na wykresie, gdzie składnik już istnieje.

Konfiguracja połączenia Czapki / Kończące

Losowanie narzędzie pozwala na ustawić symbol używany na końcach przewodów przyłączeniowych albo do stałego symbolu lub zależnych od właściwości dla samego związku symbolu.Jest to szczególnie użyteczne w schematach, gdzie wymagany jest kierunek połączenia, aby wykazać, czy na schematach, gdzie cardinality połączenia (lub kierunku) znajduje się na właściwości samego związku, na przykład "Jeden do wielu" vs "wiele do wielu" (lub "Źródło zatopić" vs "Sink Source").

Do skonfigurować czapki połączenia / kończy się na schemat

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta.

2. Wybierz PołączJonyzakładka w oknie szablonu.

3. Prawo-clizać jeden z związane typów połączeń i wybierz Skonfiguruj Czapki ....

4. Dla stałych połączeń cap / koniec w obu źródła lub tonąć koniec połączenia upewnij się, że istotne Stały element jest zaznaczony, a następnie wybierz symbol zakończenia połączenia z pociągnięciem w dół, np "Grot Strzały" lub "diament".

- LUB -

W przypadku połączenia cap / koniec oparte na własności zarówno źródła lub tonąć koniec połączenia upewnij się, że istotne Korzystanie obiektelement jest zaznaczony, a następnie kliknij przycisk "..." i wybierz żądany obiekt, a następnie obok każdego symbolu końcowego połączenia wprowadzić wartości nieruchomości w przypadku których symbolem połączenia mają być pokazane.

Notatka

Wiele wartości nieruchomości do końca danego symbolu połączenia mogą być wprowadzane oddzielone przecinkami. Na przykład. Okno poniżej pokazuje, że jeśli "danych | Liczności 'ma wartość "jeden do wielu", a następnie koniec źródłem połączenia będzie miała dwóch linii gładzi przez to i koniec zlewozmywak połączenia będzie miał jedną linię skok przez niego, a następnie fan-out z dwóch Linia gładzi na końcu.

Konfiguracja Czapki okno

Zobacz też

Losowanie Narzędzie | Wypełnianie swoją architekturę | Analizowanie Twoja architektura


Manipulowanie Schematy

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Manipulowanie Schematy

Wyślij komentarzy w tym temacie.

Gdy wykres został utworzony, elementy, które występują w nim może zostać ponownie umieszczone i ponownie wielkości zależnie od potrzeb.

Aby przenieść element w schemacie

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij i przytrzymajdowolny składnik, aby go przenieść. Jeśli wybrany składnik ma rodzica, rodzic składnik zostanie podświetlona.

3. Ponieważ element jestprzeciągnięty ze składowej dominującej, a nad innymi komponentami, "potencjalne" rodzice zostają podświetlone. Kolory używane wskazuje na efekt operacji będzie miał na ostrzeżeń i błędów z obecnego projektu i jest opisany w Definiowanie i Members Ograniczenia , W ten sposób, można graficznie nawigacja hierarchii z "widoku z góry".

4. Uwolnić sięprzycisk myszy, aby upuścić element w nowym miejscu.

Notatka

Możesz także użyć klawiatury do ponownego położenia elementów kanwy rysunku. Wystarczy wybrać kształt komponentów lub postaci wolnej, który chcesz przenieść, a za pomocą klawiszy strzałek znajdujących się na klawiaturze, aby przenieść kształt do pożądanego miejsca.

Należy również pamiętać, że podczas przeciągania elementu myszką na inny składnik, a "potencjał" element nadrzędny jest podświetlony, gdy lewy górny róg elementu przeciągania pokrywa inny komponent.

napiwek

Dowolna forma i Pływające kształty można zamówić kliknięcie prawym przyciskiem myszyoraz wybranie Przesuń na wierzch lub Na spódz menu. Ważne jest, aby zauważyć, że kształty składnik może być przekształcony o dowolnych kształtach przez kliknięcie prawym przyciskiem myszyna specyficzny kształt komponentów i wybierając Konwersja do nieregularnych kształtach.

Aby zmienić rozmiar elementu w schemacie

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij przytrzymania przeciągnijjeden z uchwytów komponentu i zmieniać kształt do pożądanej wielkości.

3. Alternatywnie, aby utrzymać proporcje kształtu, w nacisnąć Shift + kliknięcie przytrzymania przeciągnij.

Aby przenieść połączenie w diagramie

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij i przytrzymajwszystkie połączenia, aby przenieść go.

3. Uwolnić sięprzycisk myszy, aby upuścić element w nowym miejscu.

Notatka

Można poruszać się tylko połączenia, które nie są podłączone do jakichkolwiek składników. Jeśli są one przyłączone, można przenosić tylko wolny koniecs, lub przekierowują połączenia .

Usuwanie podzespołów oraz złączy

Podczas usuwania komponent lub połączenie z diagramu, masz możliwość usunięcia go z całej architektury. Każdy składnik, który jest usuwany z architektury będą automatycznie usuwane z innych schematów, w których pojawia. Od freeform przypadków pojawiają się tylko w jednym wykresie, usuwanie ich nie ma wpływu na modelu architektury lub dowolny inny schemat.

Aby usunąć komponent lub połączenie z diagramu

1. Upewnij się, że istniejące Schemat otwarta .

2. Trzaskna dowolnym związanego związku lub składnika, aby go wybrać.

3. naciśnij Usunąćklawisz, aby usunąć go z wykresu, lub Shift + Deleteaby usunąć je z całego modelu.

- lub -

2. Kliknij prawym przyciskiem myszy na dowolnym związane elementu lub składnika. Pojawi się menu kontekstowe.

3. Wybierz Usuń z widoku lub Usuń z Architekturaz menu kontekstowego.

Notatka

Jeśli element, który chcesz usunąć z widoku nie ma dzieci i występuje tylko na tym widoku, ABACUS zapyta, czy chcesz, aby usunąć element z repozytorium, jak również.

Ostrożność

Podczas usuwania elementu z modelu, który posiada elementy potomne, dzieci będą również potencjalnie usuwane zgodnie oknie ostrzeżenia.

Elementy łączące

Możesz połączyć dwa składniki istniejących tego samego schematu (a w architekturze), To może być wykonane z wielu powodów, na przykład, Dwa serwery istnieje wewnątrz firmy infrastrukturze H01 i H02. Te dwa serwery są reprezentowane przez dwie oddzielne części, w architekturze. H01 zostały uznane za niepotrzebne, a więc ma być wycofany ze służby. Wszystkie istniejące aplikacje uruchomione na H01 są przesunięte H02 (jeszcze w komisji). Zmiana ta może być następnie odbijane przez działanie "łączących" dwóch składników H01 i H02 na diagramie (a w architekturze).

Szczegółowe omówienie na łączenie patrz łączących Elementy temacie tutaj .

Aby połączyć dwie istniejące komponenty

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszy, przytrzymajna części chcesz połączyć i opórto na składnik chcesz połączyć go. Upewnij się, że obrys elementu docelowego jest podświetlony na czerwono, wskazując, że jest on wybrany.

3. Wybierz Scalanie | Zachowaj Cel podróży lub Zastąp Destinationz menu.

Notatka

Zachowaj Cel podróżyOpcja zachowuje wartości właściwości komponentu docelowego, jeżeli istnieją na części pochodzące również.

Zastąp Destinationopcja nadpisuje właściwości komponentu docelowego wszelkich wspólnych właściwości z komponentu pochodzenia.

Zmiana Połączenia

Połączenia przedstawione na schemacie zawszeodpowiada strukturze, jak zdefiniowano w samej architektury. Losowanie Narzędzie pozwala na odłączenie połączenia z elementów, przenosić je, Krzywa je, zmiana trasy ich i ponownie połączyć je z innymi składnikami.

Aby odłączyć / podłączyć połączenie z / do komponentu

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij i przytrzymajna każde połączenie.

3. Wybierz połączenie koniec (to znaczy. Źródło lub Sink), Które chcesz odłączyć / podłączyć. Uwaga: końce połączenia są wskazane z małych białych okręgów i unoszące się nad białym kole na sekundę będzie powodować "podpowiedź" do stawienia się z reprezentantem rola imię(czyli albo Źródło lub Sink).

4. Opórpołączenie zakończyć do nowej lokalizacji (albo wolne miejsce lub składnik) i zwolnij przycisk myszy.

Notatka

Gdy końcówka wtykowa jest umieszczona na ważny składnik, zarys elementu jest zaznaczony przerywaną zarys. Kolory używane wskazuje na efekt operacji będzie miał na ostrzeżeń i błędów z obecnego projektu i jest opisany w Definiowanie i Members Ograniczenia , Po zwolnieniu że koniec the Podłączenie i składnik są automatycznie połączone(lub w załączeniu)I jest to odzwierciedlone w modelu architektury.

Do zmiany planu połączenia

1. Upewnij się, że istniejące Schemat otwarta .

2. Umieść wskaźnik myszy nad połączeniem.

3. Przytrzymaj Przesunięciew dół i Trzaskprzycisk myszy, aby umieścić punkt zaczepienia połączenia. Zwolnij Przesunięcie klawisz. Możesz usunąć punkt kontrolny, wykonując te same czynności.

4. Kliknij i przeciągnijpunkt kotwicy do zmiany trasy połączenia.

napiwek

UżyjAlt Klucz zamiast PrzesunięcieKluczem do tworzenia połączeń prostopadłe.

Do Krzywa lub prostowaniepołączenie

1. Upewnij się, że istniejące Schemat otwarta .

2. Umieść wskaźnik myszy nad połączeniem.

3. Kliknij prawym przyciskiem myszyton gra i w menu kontekstowym, które się pojawi wybierz Krzywa, Prostokątny lub Proste.

napiwek

Wszystkie połączeniadanego typu na schemacie można ustawić na zakrzywione, ortogonalne lub Prosto, klikając prawym przyciskiem skojarzony linię do pisania na Karta Połączeniaz Okno Wzorniki wybierając Krzywa, ortogonalne lub Prosto.

Do kotwicy na konkretnym punkcie na krawędzi kształtu

1. Upewnij się, że istniejące Schemat otwarta .

2. Wybierz połączenie.

3. Umieść wskaźnik myszy nad "Biała kropka" na końcu połączenie.

4. Kliknij prawym przyciskiem myszytPołączenie i już koniec z menu kontekstowego, które się pojawi wybierz Zakotwiczyć punkt końcowy na kształt.Poruszać końcówkę łączącą do położenia pożądanie na krawędzi formy.

LUB

Przytrzymaj Ctrlw dół i clizać i przeciągnij koniec połączenia wskaż Położenie pożądanie na krawędzi formy.

Notatka

Połączenia będą przyciągane do rzeczywistego przecięcia ich podłączonego kształcie zamiast obwiedni tym kształcie.

Zobacz też

Losowanie Narzędzie | Wypełnianie swoją architekturę | Analizowanie Twoja architektura


Rysunek funkcje narzędziowe

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Rysunek funkcje narzędziowe

Wyślij komentarzy w tym temacie.

Narzędzie obsługuje rysunek wiele funkcji rysowania.

Powiększanie

Skala wykresu można zmienić za pomocą funkcji zoom.

Aby zmniejszyć skalę lub "powiększanie"

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. naciśnij Ctrli klawisz "=".

- lub -

2. Wybierz ZbliżeniePrzycisk na Diagram pasek narzędzi.

- lub -

2. naciśnij Ctrli toczyć kółka myszy Naprzód, Uwaga: W tym trybie płótno będzie powiększać myszy w kierunku, gdzie znajduje się nad płótnie.

Aby zwiększyć skalę lub "pomniejszyć"

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. naciśnij Ctrli "-" klucz.

- lub -

2. Wybierz OddalaniePrzycisk na Diagram pasek narzędzi.

- lub -

2. naciśnij Ctrli toczyć kółka myszy wstecz, Uwaga: W tym trybie płótno będzie powiększać się na zewnątrz skąd myszy znajduje się nad płótnie.

Auto-układ

Rozmieszczenie elementów w schemacie można modyfikować automatycznie.

Do układu wszyscy podzespoły on schemat

1. Clizać Układ SchematPrzycisk na pasku narzędzi Wykres.

2. Wybierz bądź Układ Radial lub Układ sieci.

Notatka

Układ Radial wykorzysta to, co nazywa się '' w reżyserii siły algorytmu tak, że podłączone urządzenia są ściągane podczas niezwiązane elementy są zmuszeni siebie. Układ Siatka użyje stały odstęp algorytm wysokość i szerokość. To po pierwsze, pozwala użytkownikowi wybrać proporcje ogólny schemat (np 16: 9, format A4 (Portret), List (Pejzaż)), a następnie odstęp po bokach oraz między kolumn i wierszy, jak pokazano poniżej.Z układu siatki wszelkie połączenia między składnikami nie wpływają na wygląd, jak po prostu układa komponenty alfabetycznie (przez ich nazwy) od lewego górnego rogu do prawego dolnego rogu płótna. Z obu algorytmów freeform kształty nie są przenoszone.

Do układu dzieci podzespoły w jednej dominującej On schemat

1. Kliknij prawym przyciskiem myszykomponent na wysokim szczeblu, których dzieci chcesz automatycznego układu.

2. Wybierz Układ Dzieci.

Notatka

Domyślnie tylko algorytm układ Radial służy.

Zmiana elementu Estetyka lubie Kolor, Przejrzystość, Cienie i obrotów

Wszystkie elementy schemat mają estetyczne, które można modyfikować w miarę potrzeby. W przypadku towarzyszących kształtach, elementy te można ustawiać od rodzajui w większości przypadków są także na przykład, W przypadku o dowolnych kształtach, te właściwości mogą być ustawione na przykładna płótnie.

Notatka

Każdy na aspektach instancji, które zostały ustawione dla stowarzyszonych kształtach będą "nadpisywane", jeśli ten sam aspekt zmienia dla danego rodzaju.

Aby zmienić kolor lub kształt powiązanej kształt o nieregularnych kształtach

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształtu lub dowolnych kształtów na płótnie.

3. Wybierz Zmień Kolor.

4. Wybierz Naprawiono KolorPrzycisk radiowy (jeśli dotyczy).

5. Wybierz Kolor podstawowy lub zdefiniować niestandardowy Kolor w oknie dialogowym i kliknij ok.

- lub -

4. Wybierz GradientPrzycisk radiowy (jeśli dotyczy).

5. Wybierz zarówno w poziomie, w pionie, do przodu lub do tyłu Przekątna Przekątna w kierunku gradientu w menu rozwijanego i kliknij ok.

6. Wybierz Kolor podstawowy lub zdefiniować niestandardowy Kolor w oknie dialogowym dla Początek i Konieci kliknij ok.

Notatka

Abacus kolor pierwszego planu kształtu jeśli;
a) jest to "proste" kształt z jednego podstawowego elementu graficznego (np koło, prostokąt, wielokąt itp), lub
b) jest to "skomplikowane" kształt z wieloma subshapes bazowych, które są tego samego koloru / Gradient jak siebie lub subshapes mają LockScale = TRUE.
Jeśli powyższe warunki nie są spełnione, to w tle kształtu jest w kolorze.

Aby ustawić kolor towarzyszącego kształcie w zależności od własności

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu(NIE na płótnie rysunku).

3. Wybierz Zmień Kolor.

4. Wybierz Korzystanie obiekt Przycisk radiowy.

5. Wybierz właściwość klikając na przycisk "..." po prawej stronie pola tekstowego.

6. Wybierz Strzelnica Przycisk radiowy.

7. Regulacja Min i MaxWartości to pożądane. Uwaga: każda wartość poniżej wartości minimalnej będzie pokazany jako kolor Min i każda wartość powyżej maksimum będzie pokazany jako kolor Max. Ponadto, przy użyciu Boolean, Lista lub Date / Time właściwości wartości są konwertowane do indeksu w następujący sposób; Boolean (fałsz = 0, True = 1), listy (e vale całkowitą od 1 do n dla każdej ważnej wartości w ich rosnącej kolejności określonej w polu Units) i Date / Time (liczba dni od 1 stycznia 1900 roku - w tym po przecinku dla godziny, minuty, sekundy części - a jeśli data jest pre-1990 jest to liczba ujemna).

8. Wybierz Kolor podstawowy lub zdefiniować niestandardowy Kolor w oknie dialogowym dla Min i Maxi kliknij ok.

napiwek

Gdyby Zielony (RGB - 128,255,0) wybrany jest z kolorem min i Rudy (RGB - 255,0,0) jest wybierany jako kolor Max na nieruchomość z zakresu wartości 1 do 4wówczas wartość 1będą wyświetlane jako Zielony, Wartość 2 jak Żółty, 3 jak Pomarańczowy i 4 jak Rudy.

Alternatywnie, w zakresie właściwości z 1 do 3wartość 1będzie wynosić Zielony, Wartość 2 jak Bursztyn i 3 jak Rudyaka "Traffic Lights" lub stan RAG.

Dla zakresu własności od 1 do 5, jeżeli Niebieski (RGB - 0,0,255) wybrany jest z kolorem min i Rudy (RGB - 255,0,0) jest wybrana jako Max kolor wartość 1 będzie tak Niebieski, Wartość 2 jako wodny, Wartość 3 jako Zielony, Wartość 4, jak Żółty a wartość 5 a Rudy.

Dla zakresu własności od 1 do 6, jeżeli Fioletowy (RGB - 255,0,255) wybrany jest z kolorem min i Rudy (RGB - 255,0,0) jest wybrana jako Max kolor wartość 1 będzie tak Fioletowy, Wartość 2 jako Niebieski, Wartość 3 jako wodny, Wartość 4, jak ZielonyWartość 5 a Żółty a wartość 6, jak Rudy.

I wreszcie, w zakresie nieruchomości od 1 do 7 wartość 1 będzie tak Fioletowy, Wartość 2 jako Ciemno niebieski, Wartość 3 jako Jasny niebieski, Wartość 4, jak Niebieski zielonyWartość 5 a ZielonyWartość 6, jak Bursztyn a wartość 7, jak Rudy

Notatka

Patrz uwaga powyżej tła na pierwszym planie w porównaniu zabarwienia.

- lub -

7. Wybierz Określonej wartości Przycisk radiowy.

8. Kliknij Zmień kolory przycisk.

9. Wybierz każdą wartość z kolei i kliknij Ustaw KolorDo określenia koloru dla każdej wartości.

Notatka

Zakres wartości dla elementów obecnych na wykresie zostaną wstępnie wypełnione.

10. Aby dodać żadnych dodatkowych kolorów wartości do tych wstępnie wypełnione (na przykład po zakres nieruchomość została zmieniona) Kliknij Dodać wartość.

Aby zmienić przezroczystość kolorów skojarzonego kształtu lub nieregularnych kształtach kształt

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształtu lub dowolnych kształtów na płótnie.

3. Wybierz Zmień Kolor.

4. W panelu Przezroczystość ustawić górny suwak do żądanej przejrzystości dla koloru bazowego.

5. Jeśli są używane Gradient lub Korzystanie z opcji nieruchomości, w panelu Przezroczystość ustawić dolny suwak do żądanej przejrzystości w drugim kolorze.

6. Trzask ok.

Pokazywać cienie dla wszystkie z tych związane kształty w diagramie

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespołyZakładka okna szablonu.

3. Wybierz Dodaj Cienie.

Do pokazać cień na kształt części lub dowolnych kształtów

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Dobrze-trzaskna części lub w kształcie nieregularnym kształcie na płótnie.

3. Wybierz Dodaj Cienie.

Aby obrócić kształty komponentów i bezpłatne kształty formularza w diagramach

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Wybierz kształt komponentu lub nieregularnych kształtach kształt na płótnie chcesz obrócić.

3. Kliknij prawym przyciskiem myszyna kształt i wybierz Obracaća następnie wybrać odpowiedni kąt, który chcesz obrócić kształt przez.

Wymiana pieniędzy Element Adnotacje i Freeform Etykiety tekstowe

Wszystkie elementy Schemat mają adnotacje które mogą być zmieniane w razie potrzeby. W przypadku towarzyszących kształtach, elementy te można ustawiać od rodzajui w większości przypadków są także na przykład, W przypadku o dowolnych kształtachi złączaTheetykiety tekstowe można ustawić na przykładna płótnie.Osiem (8) różne rodzaje adnotacji mogą być wyświetlane na wykresie (czyli elementów Nazwa, typ, Wartość właściwości, Marker nieruchomości, elementy zamontowane, tylko dla dzieci (komponentów), Normy i Sygnatury (utworzenie, modyfikacja Przez itp)) w dwudziestu pięć (25) różnych pozycjach (np fitness - Poza Góra, Wewnątrz lewej - Centrum, na zewnątrz Prawa - Poza dołu).

Notatka

Każdy na aspektach instancji, które zostały ustawione dla stowarzyszonych kształtach będą "nadpisywane", jeśli ten sam aspekt zmienia dla danego rodzaju.Ponadto, w przypadku 2 lub więcej adnotacji zajmują tę samą pozycję tylko pojedyncze czcionki, styl czcionki, kolor czcionki i rozmiar może być używany i separator (np przecinek, spacja, nowa linia) musi być wybrana.

Pokazywać nazwa lub typ dla skojarzonego składnika lub związku

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształt lub złącze na płótnie.

3. Wybierz Adnotacje.

Notatka

Do indywidualnego kształtu lub wiąże się złącza na płótnie trzeba będzie wybrać Przestawianie Stencil adnotacjecheckbox po raz pierwszy.

4. Wybierz Nowy adnotacji na pasku narzędzi i wybierz Imię lub Rodzaj.

5. W wyświetlonym oknie dialogowym zaznacz opcje wyświetlania, które są pożądane w tym uchwytów i stylu czcionki, czcionki, kolor i rozmiar czcionki. Również wybrać opcje układu, które są pożądane w tym wyrównania poziomego i pionowego położenia (tj adnotacji) i kąt (czyli obrotów). Wybierz ok.

Aby wyświetlić właściwości wartość dla skojarzonego składnika lub związku

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształt lub złącze na płótnie.

3. Wybierz Adnotacje.

Notatka

Do indywidualnego kształtu lub wiąże się złącza na płótnie trzeba będzie wybrać Przestawianie Stencil adnotacjecheckbox po raz pierwszy.

4. Wybierz Nowy adnotacji na pasku narzędzi i wybierz Wartość nieruchomości.

5. W wyświetlonym oknie dialogowym wybierz właściwość klikając na obiekt: "..." przycisk i wybierając właściwości w oknie dialogowym wybierz właściwośći wybierz ok. Wybierz opcje wyświetlania, które są pożądane w tym uchwytów i stylu czcionki, czcionki, kolor i rozmiar czcionki. Również wybrać opcje układu, które są pożądane w tym wyrównania poziomego i pionowego położenia (tj adnotacji) i kąt (czyli obrotów). Wybierz ok.

Aby wyświetlić właściwości znacznik dla skojarzonego składnika lub związku

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształt lub złącze na płótnie.

3. Wybierz Adnotacje.

Notatka

Do indywidualnego kształtu lub wiąże się złącza na płótnie trzeba będzie wybrać Przestawianie Stencil adnotacjecheckbox po raz pierwszy.

4. Wybierz Nowy adnotacji na pasku narzędzi i wybierz Marker nieruchomości.

5. W wyświetlonym oknie dialogowym wybierz właściwość klikając na obiekt: "..." przycisk i wybierając właściwości w oknie dialogowym wybierz właściwośći wybierz ok. Ustaw promień znacznika w pikselach i metody barwienia do obu Colour przez zakres lub Colour posesją i ustawić przypisania kolorów. Również wybrać opcje układu, które są pożądane w tym wyrównania poziomego i pionowego położenia (tj adnotacji) i kąt (czyli obrotów). Wybierz ok.

Pokazywać dołączone elementy dla skojarzonego składnika lub związku

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształt lub złącze na płótnie.

3. Wybierz Adnotacje.

Notatka

Do indywidualnego kształtu lub wiąże się złącza na płótnie trzeba będzie wybrać Przestawianie Stencil adnotacjecheckbox po raz pierwszy.

4. Wybierz Nowy adnotacji na pasku narzędzi i wybierz Załączone Składniki.

5. W oknie dialogowym, które się pojawi, na związane z nimi elementy wybrać podłączone typ komponentu klikając przycisk załączonej: "..." i wybierając typ komponentu w oknie dialogowym ustaw typ Komponenti wybierz ok. Wybierz typ połączenia załączony klikając na podłączonych przez: przycisk '...' i wybierając typ połączenia w oknie dialogowym Ustaw Typ połączeniai wybierz ok.W przypadku połączeń związanych zaznaczyć koniec połączenia wybierając źródło lub Sink od końca gra: menu rozwijanego. Na oba związane z nimi elementy i połączenia wybierz Opcje wyświetlania, które są pożądane w tym uchwytów i stylu czcionki, czcionki, kolor i rozmiar czcionki. Również wybrać opcje układu, które są pożądane w tym wyrównania poziomego i pionowego położenia (tj adnotacji) i kąt (czyli obrotów). Wybierz ok.

Pokazywać dzieci dla skojarzonego składnika

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespołyZakładka okna szablonu lub związane kształt na płótnie.

3. Wybierz Adnotacje.

Notatka

Dla indywidualnego związanego kształtu na płótnie trzeba będzie wybrać Przestawianie Stencil adnotacjecheckbox po raz pierwszy.

4. Wybierz Nowy adnotacji na pasku narzędzi i wybierz Dzieci.

5. W wyświetlonym oknie dialogowym zaznacz opcje wyświetlania, które są pożądane w tym uchwytów i stylu czcionki, czcionki, kolor i rozmiar czcionki. Również wybrać opcje układu, które są pożądane w tym wyrównania poziomego i pionowego położenia (tj adnotacji) i kąt (czyli obrotów). Wybierz ok.

Pokazywać normy dla skojarzonego składnika lub związku

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształt lub złącze na płótnie.

3. Wybierz Adnotacje.

Notatka

Do indywidualnego kształtu lub wiąże się złącza na płótnie trzeba będzie wybrać Przestawianie Stencil adnotacjecheckbox po raz pierwszy.

4. Wybierz Nowy adnotacji na pasku narzędzi i wybierz Standardy.

5. W wyświetlonym oknie dialogowym zaznacz opcje wyświetlania, które są pożądane w tym uchwytów i stylu czcionki, czcionki, kolor i rozmiar czcionki. Również wybrać opcje układu, które są pożądane w tym wyrównania poziomego i pionowego położenia (tj adnotacji) i kąt (czyli obrotów). Wybierz ok.

Pokazywać sygnatury czasowe dla skojarzonego składnika lub związku

1. Upewnij się, że istniejące Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna kształt lub powiązanej złącza w podzespoły lub ZnajomościZakładka okna szablonu lub związane kształt lub złącze na płótnie.

3. Wybierz Adnotacje.

Notatka

Do indywidualnego kształtu lub wiąże się złącza na płótnie trzeba będzie wybrać Przestawianie Stencil adnotacjecheckbox po raz pierwszy.

4. Wybierz Nowy adnotacji na pasku narzędzi i wybierz Utworzono, utworzonych przez Created Marker, Modified, zmienione lub modyfikacja Marker.

5. W wyświetlonym oknie dialogowym, jeśli nie markera, wybrać opcje wyświetlania, które są pożądane w tym uchwytów i stylu czcionki, czcionki, kolor i rozmiar czcionki. Jeśli marker, ustawić promień znacznika w pikselach i metody barwienia do obu Colour przez zakres lub Colour posesją i ustawić przypisania kolorów. Również wybrać opcje układu, które są pożądane w tym wyrównania poziomego i pionowego położenia (tj adnotacji) i kąt (czyli obrotów). Wybierz ok.

Aby zmienić styl czcionki nieregularnych kształtach kształcielub złącze

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna nieregularnym kształcie kształcie lub złącze na płótnie. Uwaga: Jeśli złącze Etykieta tekst nie jest pokazać to, aby pokazać connectlub etykiety tekstowe: Kliknij prawym przyciskiem myszyconnectlubi wybierz Adnotacja | Pokaż Adnotacja.

3. Wybierz Zmiana czcionki.

4. Wybierz styl czcionki, i rozmiar czcionki w oknie i wybierz ok.

Aby zmienić czcionkę kolor o nieregularnym kształcie kształcielub złącze

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna nieregularnym kształcie kształcie lub złącze na płótnie. Uwaga: Jeśli złącze Etykieta tekst nie jest pokazać to, aby pokazać connectlub etykiety tekstowe: Kliknij prawym przyciskiem myszyconnectlubi wybierz Adnotacja | Pokaż Adnotacja.

3. Wybierz Zmiana Kolor czcionki.

4. Wybierz czcionkęKolor (i kształtach Link kolor), klikając na przycisk "..." i wybierając kolor w oknie i wybierz ok.

5. Wybierz Przejrzystość etykiety tekstowe regulując suwak z 0 będąc w pełni przejrzyste, a 255 jest w pełni nieprzezroczyste.

Aby obrócić etykietę tekstową o nieregularnym kształcie kształcielub złącze

1. Upewnij się, że masz nowego lub istniejącego Schemat otwarta .

2. Kliknij prawym przyciskiem myszyna nieregularnym kształcie kształcie lub złącze na płótnie. Uwaga: Jeśli złącze Etykieta tekst nie jest pokazać to, aby pokazać connectlub etykiety tekstowe: Kliknij prawym przyciskiem myszyconnectlubi wybierz Adnotacja | Pokaż Adnotacja.

3. Wybierz Obracaća następnie wybrać odpowiedni kąt chcesz obrócić etykiety tekstowe przez.

Zobacz też

Losowanie Narzędzie | Wypełnianie swoją architekturę | Analizowanie Twoja architektura


Korzystanie linki w diagramach

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Korzystanie linki w diagramach

Wyślij komentarzy w tym temacie.

Kształty (postaci wolnej i komponentów) i złącza (postaci wolnej lub połączenia) w ramach schematów może być związane z istniejących przedstawień architektonicznych w ABACUS, jak i zewnętrznych plików / folderów i adresów URL. Linki te mogą być zarządzane (tworzone, modyfikowane i usuwane) za pośrednictwem zestawu narzędzi ABACUS. Funkcja ta może być stosowana w celu zwiększenia nawigację i ogólnego zrozumienia architektury schematycznie.

Do dodawania linków do diagramu

1. Upewnij się, że istniejące Schemat otwarta .

2. Wybierz odpowiedni kształt lub złącze z diagramu.

3. Kliknij prawym przyciskiem myszyod kształtulub złącze.

4. Wybierz Otwórz Linkioraz Spinki do mankietówPojawi się okno.

5. Kliknij na Dodajikona i Nowy linkPojawi się okno.

6. Wybierz odpowiedni Katalog | Matrix | Diagram| Widok 3D| Wykresprzyciski opcji, a następnie wybrać odpowiedni Katalog, macierz, diagram, 3Dlub wykres Widok w obecnej architektury z Łączyć zw menu rozwijanym.

- lub -

6. Wybierz Strona wwwprzycisk opcji, a następnie wpisz odpowiedni adres URL (np http: //www.avolutionoprogramowaniecom /)w polu link do strony internetowej. Poprawne adresy URL należy uruchomić z jednym z 5 smyczki; http: //, https: //, ftp: //, plik: lub \\, Wszelkie pomieszczenia powinny być wprowadzone z '% 20'.

- lub -

6. Wybierz Absolute Plik | Względna pliku Przycisk radiowys,a następnie kliknij '..."Przycisk, aby wyszukać plik zewnętrzny link do schematu.

7. Trzask oka nowy link zostanie pokazany w oknie odsyłacze. Uwaga: Okno menu można zmieniać, aby zobaczyć pełną nazwę, jeśli to konieczne.

8. Powtórz kroki 5-7tworzyć więcej linków.

9. Śledzić utworzony link, wybierz odpowiedni link wyświetlany w Spinki do mankietówokna i kliknij Otwórz odnośnik.

Notatka

Gdy liczne adnotacje są pokazane dla kształt lub złącze link jest pokazany na pierwszym adnotacji w liście adnotacji w oknie dialogowym Edytuj Adnotacje.

Aby śledzić linki z diagramu

1. Upewnij się, że istniejące Schemat otwarta .

2. Wybierz odpowiedni kształt lub złącze z diagramu.

3. Trzaskna właściwej hiperłącza (niebieski podkreślony nazwę komponentu) w kształcie lub złącze na rysunku, aby otworzyć i zobaczyć pierwszy link z kształtulub złącze.Uwaga: Kursor powinien zmienić się na "strony", kiedy link jest gotowy do kliknięcia.

- lub -

3. Wybierz odpowiedni kształt lub złącze z diagramu.

4. Kliknij prawym przyciskiem myszyod kształtulub złącze.

5. Wybierz Otwórz Linkioraz Spinki do mankietówPojawi się okno.

6. Wybierz odpowiedni link, który chcesz zobaczyć.

7. Kliknij na Otwórz odnośnikprzycisk, aby otworzyć i wyświetlić odpowiedni link.

Aby usunąć linki w schemacie

1. Upewnij się, że istniejące Schemat otwarta .

2. Wybierz odpowiedni kształtlub złączez diagramu.

3. Kliknij prawym przyciskiem myszyod kształtulub złącze.

4. Wybierz Otwórz Linkioraz Spinki do mankietówPojawi się okno.

5. Wybierz odpowiedni link, który musi być usunięty.

6. Kliknij na Usunąć przycisk. i związek jest usuwany z Spinki do mankietów okno.

Organizowanie linki w schemacie

Można wybrać, które związane schemat, zewnętrznego pliku lub URL internetowej jest wyświetlany, gdy etykieta kształt Ctrl + kliknięcie na wykresie.

1. Upewnij się, że istniejące Schemat otwarta .

2. Wybierz odpowiedni kształt lub złącze z diagramu.

3. Kliknij prawym przyciskiem myszyod kształtulub złącze.

4. Wybierz Otwórz Linkioraz Spinki do mankietówPojawi się okno.

5. Aby zmienić kolejność linków, kliknij na W górę | PadnijPrzyciski po prawej stronie strony Spinki do mankietów okno.

6. Pierwszy link, który pojawia się po stronie lewej Spinki do mankietówOkno jest link, który pokazuje, kiedy Ctrl + kliknięcieodsyłacza kształt lub złącze imię.

Zobacz też

Wypełnianie swoją architekturę | Wypełnianie swoją architekturę ręcznie | Analizowanie Twoja architektura


Diagram Punkty widzenia

Nawigacja: Wypełnianie swoją architekturę> Używanie rysunków>

Diagram Punkty widzenia

Wyślij komentarzy w tym temacie.

The punkty widzeniaFunkcja ta zapewnia, że ​​elementy i połączenia, które są dodawane do schematu musi mieć skojarzenie typu wcześniej zdefiniowane, zanim będą mogły być dodawane do rysunku. Funkcja ta pozwala na ograniczenie typów wykresów, które można wyciągnąć poprzez ograniczenie kształty i złącza, które są związane z komponentami oraz Znajomościistniejących w obrębie architektury.

Włączanie i wyłączanie schemat egzekwowanie punkty widzenia

Możliwość egzekwowania Schemat punkty widzenia jest automatycznie włączona domyślnie. Aby wyłączyć / włączyć tę funkcję, kliknij na Narzędzia | Opcji ...| DiagramZakładka i odznacz / zaznacz Egzekwowanie Diagram Punkty widzeniapole wyboru odpowiednio.

Notatka

Jeśli nie widzisz "Wymuszanie Diagram Punkty widzenia"Opcja na karcie Diagram wtedy nie trzeba Projektant add-on, a opcja jest domyślnie włączona.

Tworzenie diagramu wyegzekwowania punkt widzenia

1. Sprawdź, czy jest Plik ABACUS otwarty z odkrywcaWidok wyświetlane.

2. W widoku eksploratora kliknij prawym przyciskiem myszy Widokpunktsi kliknij Stwórz Schemat Widzenia

3. Schemat Widzeniapojawi się okno.

4. Przypisać odpowiednią nazwę na Schemat widzeniai pamiętać, że punkt widzenia jest zapisany pod Punkty widzeniaodcinek odkrywcy.

5. Schemat Widzeniapojawi się okno.

6. Teraz kliknij i przeciągnij odpowiednie rodzaje komponentów oraz typów połączeń w swoich architektur na kształty punkt widzenia Ty chcesz. Składowe typymuszą być przeciągane na układzie kształtw kształtyZakładka, podczas gdy rodzaje połączeńmusi być przeciągnięty na jeden z kształtów typu 5 liniowychw Złącza patka.

7. Aby zapisać Schemat widzeniautworzono kliknij na [image] w prawym górnym rogu swoje Schemat Widzenia okno.

Notatka

Schemat widzeniamoże być edytowany, klikając prawym przyciskiem myszy na punkt widzenia oraz wybranie Otwarte lub podwójne kliknięcie punkt widzenia.

Synchonising zaktualizowany punkt widzenia ze schematami

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Albo kliknij prawym przyciskiem myszy punkt widzenia w Odkrywca Okno pod Meta-modelu | Punkty widzeniai wybierz Sync Wykres Mapowanie ...

- lub -

3. Zamknij otwarty i aktualizowane widzenia okna i wybierz Takw Synchronizacja z Widzeniadialogowe, które jest wyświetlane.

4. Widzenia SynchronizacjaZostanie wyświetlone okno dialogowe jak poniżej.

Pola wyboru

· Dodaj brak mapowania- Każdy nowy kształt (do typu elementu) lub złącze (typu połączenia) stowarzyszeń, które zostały dodane z punktu widzeniazostaną dodane do Odpowiedni diagrams (czyli ich szablone) że są połączone z punktu widzenia.

· Aktualizacja IstniejąceMapowania- Wszelkie aktualne aspekty istniejącego kształtu (do typu elementu) lub złącze (typu połączenia) Stowarzyszenia na punkt widzenia(np kolor, style czcionek) będą aktualizowane w Odpowiedni diagrams (czyli ich szablone) że są połączone z punktu widzenia.

· Usuń ExtraMapowania- Wszelkie dodatkowe kształt (do typu elementu) lub złącze (typu połączenia) stowarzyszeń, które zostały dodane do Schematy (czyli ich matryce), ale nie są w punkt widzeniazostaną usunięte z Odpowiedni diagrams (czyli ich szablone) że są połączone z punktu widzenia.

· Zastąp lokalne Ustawienia dodane lub zaktualizowane mapowania (różnice Tylko)- Wszelkie aktualne aspekty istniejącego kształtu (do typu elementu) lub złącze (typu połączenia) Stowarzyszenia na punkt widzenia(np kolor, style czcionek) będą stosowane do odpowiednich elementów na schematach, które są związane z punktu widzenia.Tylko stosowane są aktualizowane 'różnice' wykonane z punktu widzenia więc wszelkie istniejące lokalne ustawienia w diagramie, które nie zostały zaktualizowane w punktu widzenia pozostanie bez zmian.

· [image] Adnotacje – Jak wyżej, ale specjalnie dla adnotacji.

Zobacz też

Losowanie Narzędzie | Wypełnianie swoją architekturę | Analizowanie Twoja architektura


Wypełnianie za pomocą Katalogi

Nawigacja: Wypełnianie swoją architekturę>

Wypełnianie za pomocą Katalogi

Wyślij komentarzy w tym temacie.

A katalog pozwala na przeglądanie i edycję komponentów lub połączeń i ich właściwości w prosty sposób tabeli.

Do utworzyć nowy katalog zobaczyć w LICZYDŁO

Notatka

Podczas gdy wszyscy użytkownicy Architekt może tworzyć nowe katalogi, aby zapisać zmiany ustawień istniejącego katalog był na licencji użytkownik musi projektant add-on możliwości. To jest "ochrona" konfigurację istniejących katalogi, które mogą być wspólne dla wielu użytkowników. Jednak Architekt używa bez Designer add-on może nadal wybrać "Zapisz jako" nowych ustawień do nowego katalogu. I oczywiście wszystkie licencje użytkownik może wybrać "usuwać" jakichkolwiek zmian w istniejącym katalogu. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają Projektant add-on zdolność. I pamiętaj, to jest tylko ustawienia katalogu, wszystkie zmiany dokonane w danych w katalogu są natychmiast stosowane do repozytorium, niezależnie.

1. Wybierz Wstaw | Katalog.

2. W rozwijanego wybierz Architecture, który zawiera elementy lubPołączenia chcesz zobaczyć.

3. W rozwijanego wybierz komponent lub typ połączenia że chcesz mieć przypadki wymienione jako "wydziwianie' w katalogu.

4. katalog zostaną wypełnione zwiersz dla każdej instancji składnika lub wybranego typu połączenia.

Notatka

Domyślnie lewy najbardziej Hierarchia Ścieżkakolumna (tj hierarchii elementów dominujących lub połączeń powyższych wybranych przypadkach) oraz 2 Imię kolumna (tj listy wybranych przypadkach składowych lub połączenia) są zamrożone na lewo od katalogu. Zmienić kolumnę zamrażanie przeciągania separator kolumna po prawej kolumnie Nazwa. Możesz ponowne zamówienieKolumny po prostu przeciągając i upuszczając ich nagłówki kolumn. Komórki kolumn z niebieskim podkreślenia są hiperłącza do innych elementów projektu i hiperłączy można następnie trzymając wciśnięty klawisz Ctrl i klikając na linki. Kolumny mogą być ukryty klikając prawym przyciskiem myszy nagłówek kolumny i wybierając kolumny | Ukryj kolumnę. Ukryte kolumny można nieskrywaną klikając przycisk paska narzędzi Kolumny konfiguracji i użyciu Konfiguruj kolumny dialogowe, jak pokazano poniżej, lub wybierając strzałka w dół części przycisku paska narzędzi Kolumny skonfigurować i indywidualnie wybierając ukrytą kolumnę (y) albo z generalnego Właściwości lub wyposażenie kolekcje. Wiersze mogą być zgrupowane ich wartości kolumny, przeciągając nagłówek kolumny w niebieskim grupowania pasku w górnej części katalogu. W dowolnym momencie możesz kliknąć dwukrotnie na Przełącznik Katalog wiersz i Skocz doodpowiedni składniklub połączeniew oknie Eksploratora.Wartości komórek nieruchomości są pogrubione gdzie są różne od domyślnych, a kursywą gdzie są tylko do odczytu. Datownika własności i dołączone kolumny składnik można kolorowy zgodnie z wartościami komórkowych lub dołączonym składnika wartości nieruchomości przez kliknięcie prawym przyciskiem myszy nagłówek kolumny i wybierając kolumny | Zmień Kolor ... a potem Kolor według datownika lub opcji Kolor posesją, jednak tylko Lista, Integer, dziesiętny, Boolean lub Date / Time Właściwości typu dane kolor. Wartości nieruchomości dla podłączonych kolumn składnik można pokazano klikając prawym przyciskiem myszy nagłówek kolumny i wybierając kolumny | Pokaż obiekt ... a następnie opcję Pokaż właściwości. I wreszcie, gdy istnieją Wymagane ograniczenia ustawić dla kolumny nieruchomości te mogą być wyświetlane z ciąg znaków (wraz z kolorowanie według ich poziomu egzekwowania), klikając prawym przyciskiem myszy nagłówek kolumny i wybierając kolumny | Pokaż .

Katalog

Do dodaj / pokaz kolumn a Katalog Widok w ABACUS

1. Upewnij się, że masz Zobacz katalog Otwarte.

2. Ukryte kolumny mogą być indywidualnie nieskrywaną klikając strzałka na prawo od kolumny przycisku paska narzędzi Konfiguracjai wybierając z ukrytą kolumnę albo Generał, Właściwości lub Załączniki kolekcje.

Notatka

Znak kleszcza pojawi się obok aktualnie pokazanych kolumnach do katalogu.Dodatkowo, tylko niektóre załączniki będą dostępne w ramach sekcji Załączniki zgodnie z Ograniczenia które są określone w projekcie. W szczególności, dla załączniki mają być dostępne do wyświetlania w katalogu komponentów typu części do katalogu musi być określony albo jako źródła lub tonąć (nie "Każdy") o "związku musi być dołączony" ograniczenie do połączenia Typ, i nie musi być co najmniej jedna część składowa określony albo jako źródła lub tonąć (NIE "Każdy"), z drugiej 'końca' tego samego typu połączenia.

- LUB -

2. Wiele kolumn można nieskrywaną (zamawiana lub stałe), klikając przycisk Skonfiguruj Kolumny przycisk paska narzędzii za pomocą Konfiguruj kolumny dialogowe pokazane poniżej.

Notatka

Aktualnie wyświetlanych kolumny są pokazane w tablicy na prawo od istniejących kolumn podanych w panelu po lewej stronie. Dostępne kolumny mogą być filtrowane zgodnie z Wybierz Dostępne kolumny zrozwijane i mogą być dodawane wybierając je w panelu po lewej stronie i klikając Dodaj Przycisk pomiędzy nimi dwoma panelami.

Okno Kolumny skonfigurować

Do usunąć / ukryć kolumny z Katalog Widok w ABACUS

1. Upewnij się, że masz Zobacz katalog Otwarte.

2. Kliknij prawym przyciskiem myszy nagłówek kolumny na kolumnę, którą chcesz usunąć / ukryć i wybierz Kolumna | Kolumny Ukryj.

- LUB -

2. Wiele kolumn może być ukryta (lub zamówić lub stałe), klikając przycisk Skonfiguruj Kolumny przycisk paska narzędzii za pomocą Konfiguruj kolumny dialogowe pokazane powyżej.

Notatka

Aktualnie wyświetlanych kolumny są pokazane w tablicy na prawo od istniejących kolumn podanych w panelu po lewej stronie. Aktualnie wyświetlane kolumny mogą być ukryte, wybierając kolumny w panelu po prawej stronie i klikając Usunąć Przycisk pomiędzy nimi dwoma panelami.

Aby wypełnić przy użyciu Katalog Widok w ABACUS

1. Do dodać części lub połączenieod wybranego rodzaju do Katalog (i projekt) kliknij Dodaj nowy składnik / Dodaj nowy przycisk paska narzędzi połączenia. Wiersz powinien pojawiają się i części lub Połączenie zostanie utworzone na najwyższym poziomie Elementy lub Kolekcja połączenia dla wybranej architektury.

Notatka

Nowe komponenty i połączenia są dodawane domyślnie na najwyższym poziomie komponentów lub Połączenia kolekcji wybranego Architektury. Aby zmienić rodzica nowych elementów lub połączeń kliknij prawym przyciskiem myszy komórkę hierarchii ścieżka dla nowego komponentu lub połączeń rzędu i wybierz Zmień nadrzędna ...i wybrać żądaną rodzica (odnotowując ograniczenie podświetlanie ).

Notatka

Nowe wiersze / elementy dodawane bezpośrednio do katalogu poprzez "Dodaj nowy" przycisk, wkleić do katalogu, lub utworzone poprzez import do katalogu z MS Excel, są zwolnione z filtrowania, dopóki katalog jest zamknięty. Jest to niezbędne, aby umożliwić dowolną edycję wartości kolumn, które mogą nie spełniać aktualne kryteria filtrowania katalogu. Te nowe rzędy elementów są oznaczone przez "+" symbolu w komorze sterującej row na początku wiersza, który jest kolorowy zielony jeśli element aktualnie spełnia zapisane kryteria filtrowania katalogu (czyli pozostanie na katalogu, jeśli ponownie otwarty), a Rudy Jeśli tak nie jest.

2. Do usunąć części lub połączenieod wybranego rodzaju od Katalog (i projekt) zaznacz wiersz i albo naciśnij klawisz Del lub kliknąć prawym przyciskiem myszy i wybierz selektor wiersza Usuń z Architektury, rząd powinien zniknąć z katalogu i to zostaną usunięte z projektu.

Do filtr za pomocą Katalog Widok w ABACUS

1. Upewnij się, że masz Zobacz katalog Otwarte.

2. Jeżeli rząd filtru nie jest widoczne w górnej części katalogu następnie kliknij Pokaż Filtr wiersz nagłówkaprzycisk paska narzędzi.

3. W kolumnie chcesz dodać filtr, kliknij dwukrotnie komórkę filtr wiersza, gdzie pokazuje '(wszystkie) ".

4. Dla Datownik, Hierarchia ścieżka, nazwa lub Opisogólne kolumny lub Tekst, Integer, dziesiętny, Boolean lub Data / godzinaKolumny własności kliknij przycisk ..., która pojawia się po prawej stronie filtra komórki wiersza i wprowadzić wartości komórek, które powinny być zawarte w katalogu.

Notatka

Dopasowanie odbywa się tak, jakby "*" dzikie karty są automatycznie stosowane przed i po wszelkich wartości ciągów tak, że wpis "kot" (bez cudzysłowów) będzie zawierać wiersze z "bobkot''kotkobieta "lub" Zgłoszeniekotjonowy "itd. Wiele /" lub "wartości mogą być wprowadzone na nowych liniach wykorzystujących Ctrl + Enter, Dla Integer i dziesiętne kolumn własności "i" logiczne mogą być uwzględnione przy użyciu "&"(Bez cudzysłowów) i powyżej / poniżej itp logiki mogą być uwzględnione przy użyciu"> =''>''<' i '<="(Bez cudzysłowów), np "> = 50000 & <90000". Nie puste wyceniane wiersze mogą być włączone przez wpisanie "(Dla Blanks)"(Bez cudzysłowów) i puste wyceniane wiersze mogą być włączone przez wpisanie"(Puste)"(Bez cudzysłowów).I wreszcie, wszystkie filtry są domyślnie wielkość liter ma znaczenie, więc "kot" (bez cudzysłowów) będzie zawierać wiersze z "kot", "kot" czy "kot", itp Do wielkość liter dopasowywania, wpisz "(Walizka)"(Bez cudzysłowów), przed ciągiem np "(Sprawa) Kot" (bez cudzysłowów) będzie zawierać tylko wiersze z "kot" w nich.

5. Dla Załącznikikolumny, Standardy kolumny lub Lista Kolumny własności kliknij przycisk strzałki w dół, która pojawia się po prawej stronie filtra komórki wiersza i wybierz wartości komórek z pola wyboru, które powinny być uwzględnione w katalogu.

Notatka

W "(Zaznacz wszystko)" pole pozwoli wszystkie pozostałe pola wyboru, w efekcie w tym wszystkich dostępnych wierszy. W "(dla Blanks)" pole będzie zawierać Wszystkie niepuste cenionych wiersze. W "(Puste)" pole będzie zawierać żadnych pustych wyceniane wiersze. I wreszcie, usuwając zaznaczenie pola wyboru jakieś szczególne cenione automatycznie odznacz "(Zaznacz wszystko)" i "(dla Blanks)" pola wyboru dla spójności.

6. Trzask ok do zastosowania filtra.

Do włączyć / wyłączyć filtrowanie a Katalog Widok w ABACUS

1. Upewnij się, że masz Zobacz katalog Otwarte z filtr stosowany.

2. Kliknij pole wyboru po lewej stronie wiersza filtra.

Do wyjąć filtr z a Katalog Widok w ABACUS

1. Upewnij się, że masz Zobacz katalog Otwarte z filtr stosowany.

2. Aby usunąć pojedynczy filtr kolumn kliknij prawym przyciskiem myszy nagłówek kolumny i wybierz Kolumna | Wyczyść Filtrowanie.

3. Aby usunąć wszystkie filtry kliknij Opcje przycisk paska narzędzi i wybierz Ustawienia filtru Wyczyść.

Zachować / Zapisz jako aZobacz katalog

Notatka

Podczas gdy wszyscy użytkownicy Architekt może tworzyć nowe katalogi, aby zapisać zmiany ustawień istniejącego katalog był na licencji użytkownik musi projektant add-on możliwości. To jest "ochrona" konfigurację istniejących katalogi, które mogą być wspólne dla wielu użytkowników. Jednak Architekt używa bez Designer add-on może nadal wybrać "Zapisz jako" nowych ustawień do nowego katalogu. I oczywiście wszystkie licencje użytkownik może wybrać "usuwać" jakichkolwiek zmian w istniejącym katalogu. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają Projektant add-on zdolność.I pamiętaj, to jest tylko ustawienia katalogu, wszystkie zmiany dokonane w danych w katalogu są natychmiast stosowane do repozytorium, niezależnie.

1. Upewnij się, że masz nowy lub istniejących widok katalogowy Otwartei dokonaniu niezbędnych zmian.

2. W Zobacz katalogPasek narzędzi kliknij na Ratowaćprzycisk, aby zapisać Zobacz katalog a wszelkie zmiany formatowania.

Notatka

Jeśli nie masz przycisk Zapisz na pasku narzędzi widoku katalog to nie masz Projektant add-on i są w stanie Zapisz jakowszelkie ustawienia zmienia się w nowym katalogu, gdy idziesz do zamknięcia istniejącego katalogu.

3. Gdyby Katalog ImięPojawi się okno dialogowe (ze względu na to nowy katalog) wpisz nazwę dla katalog i naciśnij ok.

Do eksport do katalogu MS Excel

1. Upewnij się, że masz Zobacz katalog Otwarte.

2. Kliknij Eksport do arkusza kalkulacyjnego Excel katalogprzycisk paska narzędzi.

3. Wybierz nazwę pliku, aby zapisać katalog MS Excel jako. Trzask Ratować.

Notatka

Domyślnie nazwa pliku eksportowanego katalogu MS Excel będzie nazwa katalog sufiksem nazwy architektury w nawiasach, np "Projekty (+2014 Rzeczywista) .xlsx". Możesz zmienić cokolwiek z tego, tym, czy format pliku jest za .xlsx lub .xls. Nazwa Architektura wliczone jest przypomnieć użytkownikowi, że każdy katalog ma określoną treść (tj identyfikatory w kolumnie A i wierszu 1), aby umożliwić to być okrągłe potknął się w użyciu Importuj z katalogu MS Excel, jak na poniżej.

Notatka

Domyślnie ukryte Kolumna A w eksportowanego katalogu MS Excel zawiera unikatowy identyfikator dla każdego z elementów w repozytorium ABACUS. Dzięki temu wszelkie zmiany dokonane w MS Excel, aby być "dopasowane" do istniejących elementów w Abakus na import (patrz poniżej). Jednakże stosowanie tego unikalnego identyfikatora, aby "dopasować się" wiersze mogą być zmienione ze związkiem Zewnętrzna | IDnieruchomości na elemencie. To jest, jeśli element posiada zewnętrzną | Właściwość ID i to jest wliczone w katalogu eksportu wówczas wartości zewnętrznego | Kolumna ID będą wykorzystywane, aby dopasować się wiersze od importu (patrz poniżej) i unikalne wartości ID w ukrytej kolumnie A będą ignorowane (a nawet może być puste). Ukryty Kolumna A sama musi pozostać jednak w szczególności wartość w komórce A1. Ponadto, podczas dodawania ID zewnętrznego do istniejącego zbioru elementów ABACUS zalecamy dodanie ich jako inny własności pierwszy, np Zewnętrzna | Temp, a następnie zmiana nazwy właściwość Zewnętrzne | ID. W przeciwnym razie zduplikowane elementy zostaną dodane.

Formatowanie katalogeksportowana jest domyślnie, jednak dla dużych katalogów może to spowodować eksport jest dość powolna. Zgodnie z tym, w Narzędzia | Opcji ...następnie Katalog patka,jesteś w stanie zmniejszyć ilość formatowania, które są wywożone, jak pokazano na karcie katalog poniżej, tym samym przyspieszając eksport.

Eksport katalog Opcje

4. Eksport jest wyświetlany Zakończony dialogowe. Trzask ok.

Eksportowane do katalogu MS Excel

Do import z katalogu MS Excel

Notatka

Domyślnie ukryte Kolumna A w eksportowanego katalogu MS Excel (patrz wyżej) zawiera unikalny identyfikator dla każdego z elementów w repozytorium ABACUS. Dzięki temu wszelkie zmiany dokonane w MS Excel, aby być "dopasowane" do istniejących elementów w Abakus na imporcie. Jednakże stosowanie tego unikalnego identyfikatora, aby "dopasować się" wiersze mogą być zmienione ze związkiem Zewnętrzna | IDnieruchomości na elemencie. To jest, jeśli element posiada zewnętrzną | Właściwość ID i to jest wliczone w katalogu eksportu (patrz wyżej), a następnie wartości zewnętrznego | Kolumna ID będą wykorzystywane, aby dopasować się wierszy na temat importu i unikalne wartości identyfikatorów w ukrytej kolumnie A będą ignorowane (a nawet może być puste). Ukryty Kolumna A sama musi pozostać jednak w szczególności wartość w komórce A1. Ponadto, podczas dodawania ID zewnętrznego do istniejącego zbioru elementów ABACUS zalecamy dodanie ich jako inny własności pierwszy, np Zewnętrzna | Temp, a następnie zmiana nazwy właściwość Zewnętrzne | ID. W przeciwnym razie zduplikowane elementy zostaną dodane.

1. Upewnij się, że masz Zobacz katalog Otwarte.

2. Kliknij Import z arkusza kalkulacyjnego Excel katalogprzycisk paska narzędzi.

3. Wybierz nazwę pliku do importu katalogu z programu MS Excel. Trzask Otwarte.

4. Nowe wykrytych błędów i / lub nowych Błędy / Ostrzeżenia wykryto dialogi mogą pojawić się w każdej nowej zawartości (czyli wiersze w MS Excel), które zostało dodane. Należy wziąć pod uwagę z błędów / ostrzeżeń i kliknij ok.

5. Pojawi się okno dialogowe Importuj Wypełniony i może pokazać ostrzeżenia w związku z importem (patrz uwagi poniżej). Trzask ok.

Notatka

Dla przypisanych Standardy lub podłączonych kolumn składowe nowe wpisy za pośrednictwem katalogu MS Excel musi pasować dokładnie imię istniejącego standardu lub Component prawidłowego typu dla zadania lub połączenia do dodania. Pierwszy nazwany mecz będzie używany, a wszelkie niedopasowane wpisy wygeneruje ostrzeżenie jak na poniżej. Ponadto, choć ostrzeżenia na ponownym przywozem, elementy są nie usuniętez ABACUS jeśli nie są one obecne w katalogu MS Excel. To dlatego, że nie ma sposobu, że ABACUS może wiedzieć, czy istnieje przypisane Komponent Standard lub dołączone do projektu ABACUS, ale nie istnieje w katalogu MS Excel, ponieważ został usunięty z katalogu MS Excel lub został dodany do ABACUS Projekt od katalogu została wyeksportowana. W związku z powyższym, jeśli użytkownicy chcą łatwo "wykrywania", które połączenia zostały dodane podczas procesu importowania mogą po prostu stworzyć wymaganą nieruchomości na typ połączenia i ustawić to domyślnie puste, że będą one ostrzegł nowych połączeń po każdym imporcie jest zakończony.

Notatka

Podczas importowania katalog MS Excel mogą być wyświetlane różne ostrzeżenia. Po pierwsze, jeśli nowa kolumna została dodana do programu Excel, który nie pasuje do "składni dla danej nieruchomości lub załączonego komponentu kolumna będą ignorowane. Następnie ostrzeżenia linia po linii będzie wyświetlany na wszelkie problemy z danymi dotyczącymi każdego wiersza katalogu Excel. Ostrzeżenia te rozpoczynają się od numeru wiersza w nawiasach kwadratowych, a jeśli dotyczy etykiety kolumny (czyli "[23 J] ... 'do rzędu 23, kolumna J) i może odnosić się do usuniętych elementów, bezkonkurencyjnych Standardami lub dołączonych nazwy komponentów (które są ignorowane, jak na nocie powyżej) lub nieważne lub puste ID odnoszące się do nowego wiersza / elementu (które zostaną dodane). Szczegółowy artykuł na temat wypełniania Abacus używając katalogów Excel należy odnieść się do Avolution Społeczność lub szkolenia Portfolio Manager.

Notatka

Nowe komponenty i połączenia są dodawane domyślnie na najwyższym poziomie komponentów lub Połączenia kolekcji wybranego Architektury. Aby zmienić rodzica nowych elementów lub połączeń kliknij prawym przyciskiem myszy komórkę hierarchii ścieżka dla nowego komponentu lub połączeń rzędu i wybierz Zmień nadrzędna ...i wybrać żądaną rodzica (odnotowując ograniczenie podświetlanie ).

Notatka

Elementy dodawane bezpośrednio do katalogu poprzez "Dodaj nowy" przycisk, wkleić do katalogu, lub utworzone poprzez import do katalogu z MS Excel, są zwolnione z filtrowania, dopóki katalog jest zamknięty. Jest to niezbędne, aby umożliwić dowolną edycję wartości kolumn, które mogą nie spełniać aktualne kryteria filtrowania katalogu. Te nowe rzędy elementów są oznaczone przez "+" symbolu w komorze sterującej row na początku wiersza, który jest kolorowy zielony jeśli element aktualnie spełnia zapisane kryteria filtrowania katalogu (czyli pozostanie na katalogu, jeśli ponownie otwarty), a Rudy Jeśli tak nie jest.

Do porównanie zawartości katalogu z inną architekturą

1. Proszę odnieść się do tematu tutaj .

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Wypełnianie swoją architekturę z Visio | Wypełnianie swoją architekturę z programu Excel


Wypełnianie przy użyciu macierzy,

Nawigacja: Wypełnianie swoją architekturę>

Wypełnianie przy użyciu macierzy,

Wyślij komentarzy w tym temacie.

Matryca pozwala na przeglądanie i edytowanie 'bezpośredni' Połączenia pomiędzy elementami w prosty tabelarycznej sposóba także zobaczyć "drogę pośrednią" między komponentami według dowolnych elementów pośrednich (i przyłączy).

Do Stwórz widok Matrix w ABACUS

Notatka

Podczas gdy wszyscy użytkownicy mogą tworzyć architekt matryc do nich i / lub zapisać swoje ustawienia w licencji użytkownik musi projektant add-on możliwości. To jest "ochrona" konfiguracji istniejących podłóż, które mogą być wspólne dla wielu użytkowników. Jednak Architekt używa bez Designer add-on może nadal wybrać "Zapisz jako" nowych ustawień do nowego Matrix. I oczywiście wszystkie licencje użytkownik może wybrać "usuwać" jakichkolwiek zmian w istniejącej macierzy. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

1. Wybierz Wstaw | Matryca.

2. W rchitecture>rozwijanego wybierz Architecture, który zawiera elementy i połączenia, które chcesz zobaczyć.

3. W <ŹródłoWpisz>rozwijanego wybierz typ komponentu, który chcesz mieć przypadki wymienione jako "wydziwianie' w dół w lewoz matrycy.

4. W <UmywalkaWpisz>rozwijanego wybierz typ komponentu, który chcesz mieć przypadki wymienione jako "Kolumny' na górzez matrycy.

5. W <Ścieżka Rodzaj (e)> rozbierać istnieją zasadniczo dwa "tryby" macierzy można zdefiniować ...

Połączenia "bezpośrednia" macierze

6. Po prostu selekt jednego (1) lub większej połączenie typy na prawej stronie wyświetlonego menu, jeśli chcesz zobaczyć w "komórkach" macierzy Jeślin jawneistnieje połączenie z Pionowy/ 'rząd"Składnikiem macierzy do Poziomy/ 'kolumna"Składnik matrycy.

Notatka

Jedynie połączenia ze źródłem koniec przymocowany do Pionowy/ 'rząd'Koniec składnikiem i umywalka przymocowana do Poziomy/ 'kolumna"Element zostanie wyświetlony. Przełącznik Źródło i UmywalkaWybór typu komponentów, aby wyświetlić połączenia w przeciwnym kierunku.

7. Matryca zostanie wypełniona "X" w komórkach (lub wartości nieruchomości - patrz uwaga poniżej) jeśli nie ma połączenia z Pionowy/ 'rząd'składnikiem macierzy do Poziomy/ 'kolumna"Składnik matrycy.

Notatka

Dla dużych matrycach tylko maksymalnie 100 wierszy lub kolumn (w tym załamał / kolumny) zostaną pokazane w czasie, jak wynika z "R" i "C" wskaźników w górnej lewej komórce nagłówka odpowiednio. Aby zobaczyć dodatkowe rzędy użyć pasków przewijania. W dowolnym momencie możesz kliknąć dwukrotnie na Pionowy/ 'rząd' lub Horizontglin / 'kolumna' składnik Nagłówki i Skocz doodpowiednie elementy w oknie Eksploratora.Rodzice pionie/ 'rząd' i Poziomy/ 'kolumna' składnika także opcjonalnie pokazany jako pozycja / kolumny z szarego nagłówka. Gdy upadł (poprzez pojedyncze kliknięcie komórki nagłówek), jeśli dzieci załączniki istniała wówczas "X" pojawi się opcjonalnie, jeśli zostały dołączone wszystkie dzieci lub "O" pojawi się opcjonalnie, jeśli tylko niektóre dzieci zostały dołączone. Komórki mogą być kolorowy według wartości nieruchomości z połączeń, klikając opcje "koło zębate" w prawym górnym rogu paska narzędzi matrycy i wybierając Ustawienia kolorów ... a następnie przycisk Edytuj i wybierając Barwa przez timestamp lub Colour By właściwości i wyboru nieruchomości, zakres wartości Min i Max i wybierając kolory, jednak tylko Lista, Integer, dziesiętny, Boolean lub Date / Time Właściwości typu dane kolor. Jeśli upadł komórka będzie w kolorach według średniej wartości nieruchomości przyłączy. Zamiast "X", wartości właściwości dla komórek może być pokazano klikając w "koło zębate" opcje w prawym górnym rogu paska narzędzi matrycy i wybierając Pokaż ustawienia wartości ... a następnie przycisk Edytuj i wybierając opcję Pokaż właściwości i wyborze nieruchomości.

Połączenia bezpośrednie Tabela przedstawiająca serwerach aplikacji obsługiwanych z wybarwienia i właściwości są pokazane zamiast generic "X"

- LUB -

Połączenia 'pośrednie' macierze

6. Selektsekwencją połączenie typy i typy elementówpo prawej i lewej strony, jeśli pojawi się menu chcesz zobaczyć w "komórkach" macierzy Jeślin droga pośrednia z podłączonych urządzeńistnieje od Pionowy/ 'rząd"Składnikiem macierzy do Poziomy/ 'kolumna"Składnik matrycy.

Notatka

Każda prawidłowa ścieżka, która zawiera elementy wybrane w menu ścieżki wagźle być pokazaneniezależnie od kierunku połączenia bazowych, jednak przy wyborze trasy pierwszy i ostatnie elementy muszą być wybrane typy połączeń. Ponadto, zamówienie z elementów, które zostały wybrane jest pokazany z Przedrostek numerycznana placu ("[]") wsporniki i dany typ może być włączone mutliple razyna drodze (jak wskazano przedrostkiem liczbowej). Kolejny wybór rodzajów składników lub typów połączeń jest interpretowane jako 'LUB'Ścieżka i hierarchia dołączonych elementów może ewentualnie być włączone poprzez zaznaczenie "Szukaj również załączników rodziców / dzieciSkrzynka "kontrola. Przełącznik Źródło i UmywalkaWybór typu komponentów, aby zobaczyć Ścieżki w drugą stronę.

7. Matryca zostanie wypełnione zścieżka / zbiór elementóww komórkach, gdy jest ścieżka z Pionowy/ 'rząd'składnikiem macierzy do Poziomy/ 'kolumna"Składnik matrycy.

Notatka

Dla dużych matrycach tylko maksymalnie 100 wierszy lub kolumn (w tym załamał / kolumny) zostaną pokazane w czasie, jak wynika z "R" i "C" wskaźników w górnej lewej komórce nagłówka odpowiednio. Aby zobaczyć dodatkowe rzędy użyć pasków przewijania. W dowolnym momencie możesz kliknąć dwukrotnie na Pionowy/ 'rząd' lub Horizontglin / 'kolumna' składnik Nagłówki i Skocz doodpowiednie elementy w oknie Eksploratora.Rodzice pionie/ 'rząd' i Poziomy/ 'kolumna' składnika także opcjonalnie pokazany jako pozycja / kolumny z szarego nagłówka. Gdy upadł (poprzez pojedyncze kliknięcie komórki nagłówek) czy jakieś dzieci ścieżki istniał wtedy "X" pojawi się opcjonalnie, jeśli zostały dołączone wszystkie dzieci lub "O" pojawi się opcjonalnie, jeśli tylko niektóre dzieci miały ścieżki. Elementy pośrednie ścieżka może być kolorowy według wartości rzeczowych składników klikając opcje "koło zębate" w prawym górnym rogu paska narzędzi matrycy i wybierając Ustawienia kolorów ... a następnie przycisk Edytuj i wybierając Barwa przez timestamp lub Colour By właściwości i wyboru nieruchomości, zakres wartości Min i Max i wybierając kolory, jednak tylko Lista, Integer, dziesiętny, Boolean lub Date / Time Właściwości typu dane kolor. Wartości nieruchomości dla pośrednich elementów ścieżki może być pokazano klikając w "koło zębate" opcje w prawym górnym rogu paska narzędzi matrycy i wybierając Pokaż ustawienia wartości ... a następnie przycisk Edytuj i wybierając opcję Pokaż właściwości i wyborze nieruchomości.

Pośrednie połączenia macierzy pokazując Aplikacje, które implementują danej usługi przez Departament

Do filtrwidok Matrix w ABACUS

1. Upewnij się, że masz nowy Widok Matrix Otwarte.

2. Kliknij Filtr osi 'lejek' w prawym górnym rogu paska narzędzi matrycy.

3. Od źródła i / lub kart Sink Dodaj nowe, obiekt, opis, hierarchii czy filtry standardowe klikając przycisk Dodaj, wybierając obiekt, w razie potrzeby, a kliknięcie ok, Wybierz odpowiednie opcje w panelu Słowa kluczowe / pozycje za pomocą logiki / składnię, jak to opisano w poniższej nocie. Panel podglądu zostanie automatycznie aktualizować, aby pokazać wyniki bieżącego zestawu filtrów.

Notatka

Dla Datownik, Hierarchia ścieżka, nazwa lub Opisfiltry lub Tekst, Integer, dziesiętny, Boolean lub Data / godzinaFiltry własności dopasowanie odbywa się tak, jakby "*" dzikie karty są automatycznie stosowane przed i po wszelkich wartości ciągów tak, że wpis "kot" (bez cudzysłowów) będzie zawierać wiersze z "bobkot''kotkobieta "lub" Zgłoszeniekotjonowy "itd. Wiele /" lub "wartości mogą być wprowadzone na nowych liniach wykorzystujących Ctrl + Enter, Dla Liczba całkowita i Dziesiętny Filtry własności "i" logiczne mogą być włączone przy użyciu "&"(Bez cudzysłowów) i powyżej / poniżej itp logiki mogą być uwzględnione przy użyciu"> =''>''<' i '<="(Bez cudzysłowów), np "> = 50000 & <90000". Nie puste wyceniane wiersze mogą być włączone przez wpisanie "(Dla Blanks)"(Bez cudzysłowów) i puste wyceniane wiersze mogą być włączone przez wpisanie"(Puste)"(Bez cudzysłowów). Dla Standardy lub Lista Nieruchomość filtrów The "(Zaznacz wszystko)" pole pozwoli wszystkie pozostałe pola wyboru, w efekcie w tym wszystkich dostępnych elementów. W "(dla Blanks)" pole będzie zawierać żadnych nie puste nieruchomości wyceniane elementy. W "(Puste)" pole będzie zawierać żadnego majątku Blank cenionych elementów. I odznaczając pola wyboru jakieś szczególne cenione automatycznie odznacz "(Zaznacz wszystko)" i "(nie Blanks)" pól wyboru konsystencji. I wreszcie, wszystkie filtry są domyślnie wielkość liter ma znaczenie, więc "kot" (bez cudzysłowów) będzie zawierać elementy z "kot", "kot" czy "kot", itp Do wielkość liter dopasowywania, wpisz "(Walizka)"(Bez cudzysłowów), przed ciągiem np "(Sprawa) Kot" (bez cudzysłowów) będzie zawierać tylko elementy z "kot" w nich.

Aby wypełnić przy użyciu widoku Matrix w ABACUS

Notatka

Można tylko dodać / usunąć połączenia, gdzie jeden typ połączenia zostały wykorzystane do ścieżki opisanej powyżej.

1. Do dodać połączenieod wybranego rodzaju pomiędzy położeniem Pionowy/ 'rząd"Element i Poziomy/ 'kolumna"Składnikiem macierzy, gdzie" X "nie istnieje(lub pokazano wartość nieruchomości - patrz uwaga powyżej)Dwukrotnie kliknąć komórkę. Powinno pojawić się "X" (lub wartość nieruchomości - patrz uwaga powyżej) i połączenie zostanie utworzone na najwyższym poziomie kolekcji Połączenia dla wybranej architektury.

Notatka

Nazwa połączenia będzie Połączenie nazwa typu jak na ustawienie typu połączenia matrycy i jeśli wartość nieruchomości jest wyświetlany zamiast "x" wartość domyślna właściwości zostaną pokazane.

2. Do edycji pokazano wartości nieruchomościna połączeniu pomiędzy a Pionowy/ 'rząd"Element i Poziomy/ 'kolumna"Składnik matrycyDwukrotnie kliknąć komórkę, lub kliknij prawym przyciskiem myszy komórkę i wybierz Edytuj wartość ... i edycji wartości w oknie dialogowym Zmiana wartości.

3. Do usunąć połączenieod wybranego rodzaju pomiędzy położeniem Pionowy/ 'rząd"Element i Poziomy/ 'kolumna"Składnikiem macierzy, gdzie" X już istnieje "(lub pokazano wartość nieruchomości - patrz uwaga powyżej), dobrze-kliknij komórkęi wybierz Rozłącz, X powinien zniknąć, a połączenie zostanie usunięty z projektu.

Zachować / Zapisz jako aWidok Matrix

Notatka

Podczas gdy wszyscy użytkownicy mogą tworzyć architekt matryc do nich i / lub zapisać swoje ustawienia w licencji użytkownik musi projektant add-on możliwości. To jest "ochrona" konfiguracji istniejących podłóż, które mogą być wspólne dla wielu użytkowników. Jednak Architekt używa bez Designer add-on może nadal wybrać "Zapisz jako" nowych ustawień do nowego Matrix. I oczywiście wszystkie licencje użytkownik może wybrać "usuwać" jakichkolwiek zmian w istniejącej macierzy. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają Projektant add-on zdolność.I pamiętaj, to jest tylko ustawienia matrycy, wszystkie zmiany dokonane w danych w macierzy są natychmiast stosowane do repozytorium, niezależnie.

1. Upewnij się, że masz nowy Widok Matrix Otwartei dokonaniu niezbędnych zmian.

2. W Widok MatrixPasek narzędzi kliknij na skrajnej lewej Ratować Matrycaprzycisk, aby zapisać Widok Matrix a wszelkie zmiany formatowania.

Notatka

Jeśli nie masz przycisk Zapisz na pasku narzędzi widoku Matrix to nie masz Projektant add-on i są w stanie Zapisz jakowszelkie ustawienia zmienia się na nowej matrycy, gdy idziesz do zniesienia istniejącej macierzy.

3. Gdyby Matryca Imiędialogowe, które pojawia się (ze względu na to nowa macierz) wpisz nazwę dla matrycai naciśnij ok.

Do eksport do matrycy MS Excel

1. Upewnij się, że masz Widok Matrix Otwarte.

2. Kliknij Eksport do Excelaprzycisk paska narzędzi.

3. Wybierz nazwę pliku, aby zapisać macierz MS Excel jako. Trzask Ratować.

Notatka

Domyślnie nazwa pliku eksportowanego Matrix MS Excel będzie nazwa Matrix sufiksem nazwy architektury w nawiasach, np "Aplikacje hostowane na serwerach (2014 Rzeczywista) .xlsx". Możesz zmienić cokolwiek z tego, tym, czy format pliku jest za .xlsx lub .xls.

Formatowanie Matrixeksportowana jest domyślnie, jednak w przypadku dużych macierzy może to spowodować eksport jest dość powolna. Zgodnie z tym, w Narzędzia | Opcji ...następnie Matryca patka,jesteś w stanie zmniejszyć ilość formatowania, które są wywożone, jak pokazano na karcie Matrix poniżej, tym samym przyspieszając eksport.

Eksport Matrix Opcje

4. Eksport jest wyświetlany Zakończony dialogowe. Trzask ok.

Eksportowane do matrycy MS Excel

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Wypełnianie swoją architekturę z Visio | Wypełnianie swoją architekturę z programu Excel


Wypełnianie swoją architekturę z programu Microsoft Access

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie z produktów firmy Microsoft>

Wypełnianie swoją architekturę z programu Microsoft Access

Wyślij komentarzy w tym temacie.

Możesz wyeksportować architekturę do programu Microsoft Access do wykonywania ogólnych celów obliczenia, manipulacji lub raportów od architektury. Następnie można zaimportować architektury z powrotem do ABACUS.

Notatka

Otwarta z Access / Eksport do bazy danych funkcja wymaga Microsoft Access 2000lub nowszy jest zainstalowany na komputerze.

Aby wyeksportować swoją architekturę do programu Microsoft Access

1. Sprawdź, czy jest Plik ABACUS otworzyć Odkrywcawyświetlane, oraz architektura w dodatku.

2. Wybierz Plik | Eksport | Do bazy danych.

3. Zanotuj okno dialogowe z ostrzeżeniem, jak opisano powyżej, a następnie kliknij przycisk Tak, aby kontynuować.

4. Wybierz lokalizację i nazwę pliku dla pliku bazy danych.

Aby zaimportować manipulować architekturę w ABACUS

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Plik | Nowy i wybierz Od Dostępz wyświetlonym oknie dialogowym i kliknij OK.

3. Znajdź plik bazy danych, które chcesz zaimportować.

Abacus "Schemat Baza danych MS Access

ABACUS ma do sercan ontologii / meta-meta-modelu składa się z komponentów, połączeń i ograniczeń. To podejście "KSH" pochodzi od różnych standardowych rozwiązań opracowanych z 1960 roku zakończone międzynarodowym standardem IEEE 1471, którego założycielami Avolution przyczyniły się do. Obowiązują następujące prymitywy;

1. LICZYDŁO Zawiera Biblioteki z Standardy(lub Standardów), Składnik i Rodzaje połączeń, Ograniczenia, Punkty widzenia, Szablony (lub Wzory) i wiele Architektur.

2. Standardy, Rodzaje i Punkty widzenia majbyć logicznie Zgrupowane dla wygody.

3. Architektur może zawieraćwielu potomkiem Architektur(lub Ewolucje).

4. Każdego Architektura Zawiera wiele podzespoły i Znajomościniektórych Rodzajei różne Widoki.

5. podzespoły i Znajomości może być rozkładany w Podzespołów i Sub-Połączenia.

6. Każdego Składnik jest przymocowany dodowolnej liczby Znajomościale każdy Połączeniemoże być tylko przymocowany domaksymalnie dwa podzespoły.

7. podzespoły i Znajomości mogą mają Standardy z Właściwościtakich jak informacje, wydajności, niezawodności, kosztów itd.

8. Architektur, podzespoły i Znajomości mogą mają konkretny Właściwościtakich jak informacje, wydajności, niezawodności, kosztów itd.

9. Ograniczenia mogą istnieją między podzespoły lub Znajomości lub przeciwko Właściwości.

10. SzablonySą to standardowe kompozycje Składnik i Rodzaje połączeń.

11. Punkty widzeniaSą to standardowe stowarzyszenia Składnik i Rodzaje połączeńdo wpisu.

12. Widokisą wizualne reprezentacje podzespoły i Znajomości.

Poniższy MS Access Podmiot związku Diagram (ERD) dokumentuje rdzeńArchitektury, Ewolucje, Rodzaje Komponent / połączeń (i grupy), Komponenty / Połączenia i Sub koncepcje Komponent / połączeń.

Schemat bazy danych Rdzeń

Notatka

Więzy integralności nie została wykonana na temat relacji między stołem Składniki i tabeli Połączenia (do "przywiązania" między danego źródła lub tonąć komponentu i połączenia). To dlatego, że połączenie może istnieć bez załączników składowych. Mogliśmy dodaje się tabelę "załączników", ale w interesie uproszczenia zdecydowaliśmy się, że. Oczywiście oznacza to, że każda edycja składnika identyfikatorów lub usuwanie wierszy składowych wszystkich razem spowoduje nieprawidłowych danych. ABACUS będzie obsługiwać żadnych nieprawidłowości w imporcie przez ignorowanie nieprawidłowych danych.

Poniższy MS Access ERD dokumentuje WłaściwościKoncepcje dla architektur, Rodzaje Komponent / połączeń i komponentów / połączenia.

Właściwości schematu bazy danych

Poniższy MS Access ERD dokumentuje Standardykoncepcja architektury, typy komponentów / połączeń i komponentów / połączenia.Uwaga: W tabelach nadal używać terminu "dokonanie", jak na poprzednich wersjach ABACUS.

Standardy schematu bazy danych

Poniższy MS Access ERD dokumentuje OgraniczeniaKoncepcja składowe Rodzaje / połączeń.

OgraniczeniaSchemat bazy danych

Poniższy MS Access ERD dokumentuje Punkty widzenia Koncepcja Architektur.Uwaga: W tabelach nadal używać terminu "TwoDTempl", jak na poprzednich wersjach ABACUS.

Punkty widzeniaSchemat bazy danych

Poniższy MS Access ERD dokumentuje KatalogiKoncepcja Architektur.

KatalogiSchemat bazy danych

Poniższy MS Access ERD dokumentuje MacierzeKoncepcja Architektur.

MacierzeSchemat bazy danych

Poniższy MS Access ERD dokumentuje SchematyKoncepcja Architektur.Uwaga: W tabelach nadal używać terminu "TwoD", jak na poprzednich wersjach ABACUS.

Notatka

Typ składnika / Podłączenie do Wzornik odwzorowanie kształtu i kształt części o nieregularnym kształcie z MS Access ERD zostały pominięte dla jasności.

SchematySchemat bazy danych

Poniższy MS Access ERD dokumentuje Widoki 3DKoncepcja Architektur.

Widoki 3DSchemat bazy danych

Poniższy MS Access ERD dokumentuje WykresyKoncepcja Architektur.

WykresySchemat bazy danych

Poniższy MS Access ERD dokumentuje Kokpity menedżerskie pojęcie.

Kokpity menedżerskieSchemat bazy danych

Abacus "MS AccessZapytania

W zestawie z bazy danych MS Access kilka przydatnych zapytań w następujący sposób;

· Comps by Rekwizyty- To zapytanie zawiera wszystkie elementy w projekcie (o architekturze i rodzaju) i zawiera wszystkie właściwości jak kolumny. Użyj tej kwerendy z filtrami / criterias od rodzaju i / lub komponentów architektury produkować "typowe" tabel dla każdego typu części z ich właściwości.

· Stds przez Rekwizyty- To zapytanie zawiera wszystkie standardy, które są w użytku, liczbę wystąpień normy i zawiera wszystkie właściwości jak kolumny. Użyj tej kwerendy jako standardy katalogu.

· Rekwizyty według rodzajów- To zapytanie zawiera wszystkie właściwości komponentów i ich% kompletne przez każdego typu części jako kolumny. Użyj tej kwerendy w celu ustalenia, czy określone właściwości są utrzymywane.

· Rodzaje przez Rekwizyty- To zapytanie zawiera wszystkie typy komponentów i obejmuje% kompletne wszystkich właściwości jak kolumny. Użyj tej kwerendy w celu ustalenia, czy określone właściwości są utrzymywane.

· Typ Liczba- To zapytanie zawiera wszystkie typy komponentów i zawiera liczbę wystąpień każdego typu w porządku malejącym. Użyj tej kwerendy, aby określić popularność każdego typu w projekcie.

Uwaga na pracę z pola Memo w MS Access

Połączenia elementów, Standardy Imię i pola w tabelach są definiowane jako pola memo, aby umożliwić nieograniczonej liczby znaków, jak na ABACUS. Dla części oraz złącza powoduje kilka problemów, ponieważ mają również unikalną pole ID w przedstawieniu, ale dla Norm powoduje kilka problemów podczas próby łączenia tabel, ponieważ nie można przyłączyć pola memo w MS Access. Alternatywnie, można ustawić kryteria klauzula WHERE, aby osiągnąć ten sam efekt, jak pokazano w Visual Query Builder i odpowiednich poniżej tej listy fragmentów SQL wszystkie odziedziczone Standardy właściwości wszystkich składników w eksportowanym projekcie ABACUS.

Pola Memo "dołącza" w Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Od składników INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) I (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Wdrożenia INNER JOIN ImplementationProperties NA Implementations.Id = ImplementationProperties.Implementation_Id

WHERE (((ComponentImplementationLinks.Name) = [Realizacje] [Nazwa]).);

Pola Memo "dołącza" w SQL

Uwaga na automatyczne generowanie identyfikatorów ABACUS w MS Access

Różne tabele ABACUS MS dostępu wymaga unikalny identyfikator tak długo całkowita prosty sposób VB są dostarczone, aby pomóc w tworzeniu tych. Dwie metody ResetCounter () i GetNextCounter () są dostarczane w ramach Abacus "MS Access DB, a ich stosowanie jest w sposób następujący; ResetCounter () ustawia licznik z powrotem na 0. GetNextCounter () zwróci następny licznik w sekwencji.

Sposoby wykorzystania MS Access "dziwactwo", że nawet jeśli wywołujemy metodę ResetCounter () dla każdego wiersza wkładki (czyli gdy również uruchomić funkcję GetNextCounter ()), ponieważ funkcja ResetCounter () nie ma żadnych parametrów po prostu działa to raz, a więc nie wyzerować licznik dla każdego Wstaw wiersz. A także dlatego, że w tym samym "dziwactwo" trzeba przejść dowolną zmienną stare kolumny do funkcji GetNextCounter (), aby oszukać go do działa za każdym razem.

Istnieje również podstęp jest w stanie uruchomić funkcję ResetCounter () na wkładkę do instrukcji SQL, ponieważ nie mogę po prostu nie to siedzi tam jako kolumny na własną rękę, jak gdyby był to wybierz zapytania. Zaleca się, aby ResetCounter () część rozmowy z jednym z innych dziedzin, przez złączenie go do końca, jak to zawsze zwraca null tak.

Poniżej przedstawiono typowe użycie SQL metod, aby dodać listę typy komponentów z tabeli / kwerendy o nazwie "Składnik Typ listy".

WŁÓŻ WComponentTypes (Id, nazwa, opis)

WYBIERZ GetNextCounter ([Component Rodzaj Lista] .name)AS Id, [Component Rodzaj Lista] .name jak nazwisko, [Component Rodzaj Lista] .description & ResetCounter ()AS Opis

OD[Component Rodzaj Lista];

ABACUS ID generacji / Licznik w SQL

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Wypełnianie swoją architekturę z Visio | Wypełnianie swoją architekturę z programu Excel


Wypełnianie swoją architekturę z Microsoft Visio

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie z produktów firmy Microsoft>

Wypełnianie swoją architekturę z Microsoft Visio

Wyślij komentarzy w tym temacie.

Możesz importować architekturę z Microsoft Visio. Kształty w rysunku Visio zostanie zaimportowany jako elementami w ABACUS. Połączenia w rysunku Visio zostanie zaimportowany jako połączenia i samego rysunku zostaną zaimportowane do ABACUS jako diagram. Ponadto, wszelkie Właściwości niestandardowe w rysunku Visio zostanie zaimportowany jako właściwości z Sortuj Key odwzorowywane na typ własności, etykieta z nazwą rzeczy i wartości do wartości nieruchomości.

Notatka

Import z funkcji Visio wymaga Microsoft Visio 2003lub nowszy jest zainstalowany na komputerze.

Aby zaimportować rysunków programu Visio w ABACUS

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Plik | Nowy i wybierz Od Visioz wyświetlonym oknie dialogowym i kliknij OK.

Notatka

Jeśli chcesz zaimportować do istniejącego projektu ABACUS następnie albo kliknij prawym przyciskiem myszy węzeł Komponenty w ramach Architektury, lub kliknij prawym przyciskiem myszy komponent w ramach indywidualnej architektury, a następnie wybierz polecenie Importuj | Od Visio.

3. Znajdź plik programu Visio, który chcesz zaimportować.

Notatka

Poniżej kilka prostych zasad lub zalecanych praktyk podczas budowy (lub modyfikacja) MS Visio rysunek do przywozu do ABACUS.

1. Linie lub połączenia muszą być rzeczywiste złącza, NIE kształty.

· W przeciwnym razie ABACUS po prostu zaimportować je jako składniki, a zatem nie będą one "przywiązany" do niczego.

· Jeśli musisz zrobić routing "inteligentny" (czyli inne niż linii prostej), a następnie za pomocą dynamicznego złącze na szablon Kształty podstawowe, ABACUS będzie importować punkty trasy / kotwica dobrze.

· Staraj się unikać korzystania z sieci "dzwonka" i "Ethernet" kształty z wzornika sieci i urządzeń peryferyjnych, który umożliwia wiele elementów, aby być "podłączony" do niego. Podczas gdy sprowadzamy załączniki porządku, połączeń oryginalny kształt jest nadal "rozszerzone", aby odzwierciedlić załączników. Użyj oddzielić oddzielny "piasty / Autobus" kształt (bez złącza "nogi"), a następnie jawnie podłączenia każdego urządzenia do koncentratora / autobusem z oddzielnymi złączami.

· Jeśli linia lub połączenie zachowuje się jak kształt, kliknij prawym przyciskiem myszy i przejdź do "Format | Zachowanie ... "i upewnij się, że styl Interakcje jest ustawiony na linii (1 wymiarowe).

2. Składniki muszą być NIE kształty gniazda.

· W przeciwnym razie po prostu importować ABACUS je jako połączenia, a zatem wszystkie informacje kształt zostaną utracone.

· Jeśli element zachowuje się jak złącza, kliknij prawym przyciskiem myszy i przejdź do "Format | Zachowanie się ... "i upewnij się, że styl Interakcje jest ustawiony na polu (2-wymiarowej).

3. Końcówki przyłączeniowe muszą być przymocowane do form, nie krąży w tle za kształtu.

· Jeśli nie podłączyć konektory do kształtów następnie ABACUS nie ma możliwości dowiedzenia się, które przeznaczone są do mocowania złącza do danego kształtu / części, a zatem będzie opuścić to koniec un-załączonym połączenia.

4. Etykiety na kształtach powinna być (w miarę możliwości) Wbudowana tekst etykiety dla kształtu, a nie oddzielne pole tekstowe na rysunku.

· Osobne pola tekstowe dostanie importowane przez ABACUS jako składniki same w sobie, a jednocześnie można połączyć "label" komponent z prawdziwym składnik ABACUS, lub po prostu przekształcić "label" komponent do nieregularnym kształcie kształcie (tzn nie jest sam w sobie komponent) najlepiej jest unikać tych czynności.

5. Użyj tej samej bazy kształt dla każdego wystąpienia tego samego typu, nie leń i używać pole prostokąta czasem i innych z różnych szablonów kształtu.

· ABAKUS wykorzystuje kształt podstawowy i kolor bazowy, aby jednoznacznie zidentyfikować typy komponentów i połączeń w rysunku tak "Czerwony prostokąt" i "czerwone pole" będzie się importowane jako dwa odrębne rodzaje komponentów. Te rodzaje składników mogą być łączone w ABACUS, ale najlepiej jest unikać tych czynności.

6. Całości hermetyzacji "dzieci" kształty w swoich "rodziców", nie zostawiaj je wiszące na krawędzi.

· ABACUS wykryje dowolny kształt, który jest całkowicie zamknięty w innym kształcie jak dziecko rodzica, więc upewnij się, że cały kształt, w tym części etykiety, jest zamknięty.

7. NIE umieścić kształt nakładających dwa inne kształty.

· Jeśli kształt pokrywa dwie inne kształty, czy to "grupowania" / tła prostokąta lub w inny sposób, to będzie importowane przez ABACUS jako składnika, który jest dzieckiem że ani nakładających się kształtów, ale jak tylko wybrać komponent w narzędzia rysowania Abacus " ze względu na lewym górnym rogu jest punkt odniesienia komponentów, stanie się dzieckiem lewej pokrywały kształt / komponent.

8. Staraj się zminimalizować wykorzystanie notatek tekstowych na rysunku bo to będzie się importowane jako składniki w sobie i będą musiały zostać przekształcone do swobodnych kształtów w ABACUS. Zastanów się, czy są one naprawdę nazwa istniejącego komponentu lub połączenia.

9. Podczas ABACUS wspiera bogatych / kolorowe / oparte kształtów wektorowych, starają się zminimalizować wykorzystanie bitmap, zagranicznych kształtach i rozszerzone metapliki kształtów jak ABACUS obecnie robiniewspierać te typy. Będą one importowane jako prostych białych prostokątów.

10. Staraj się unikać powrotu karetki (Shift-Return) w etykietach, ponieważ są one importowane i pokazane jako znak specjalny "[]" w ABACUS do nazwy składnika.

11. Starać się zminimalizować różnych barw, które są wykorzystywane do kształtu tego samego typu. Jak wspomniano powyżej, kolor bazowy i podstawa kształt jednoznacznie identyfikuje typy komponentów i połączeń, więc tym bardziej nie jest to odmiana bardziej łączenie i konsolidacji, które będą musiały być wykonane po przywozie w ABACUS.

12. Bądź ostrożny z pełnych kształtów, ponieważ jeśli kształt jest wypełniona aż po rogach następnie kolorowanie później w ABACUS nie będzie miało wpływu.

13. W przypadku złożonych kształtów opartych na linii należy użyć wielokąta, który jest tworzony poprzez linie zaczynające gdzie poprzedni kończy, a następnie ostatecznie wraca do punktu startu. Jeśli chcesz, możesz użyć wypełnienia i linii szerokość, aby wygląd wielokąta jak "strzałką" lub niezależnie od kształtu chcesz.

14. Upewnij się, że ID kształty w MS Visio ma znaczenie nie tylko Shape.xx. To jest edytowalny za pomocą kliknij prawym przyciskiem myszy "Pokaż ShapeSheet", który jest dostępny w trybie dewelopera MS Visio (aktywny przez Narzędzia | Opcje w MS Visio).

15. Elipsy i łukiw ciągu kształtachsą obsługiwane w ABACUS ale NURBS i wypusty nie są obecnie obsługiwane.

16. Upewnij się, że cały kształt jest zgrupowane w MS Visio lub zostanie on importowany jako kilka komponentów / typów.

17. Staraj się zminimalizować wykorzystanie obróconych kształtów ciągu subshapes, ponieważ czasami nie będzie się poprawnie importowane.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Wypełnianie swoją architekturę z programu Access | Wypełnianie swoją architekturę z programu Excel


Wypełnianie swoją architekturę z programu Microsoft Excel

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie z produktów firmy Microsoft>

Wypełnianie swoją architekturę z programu Microsoft Excel

Wyślij komentarzy w tym temacie.

Możesz importować architekturę z arkusza kalkulacyjnego Excel (.xls lub .xlsx plik). Importer Excel umożliwia mapowanie listy składników i połączenia z typów, norm, właściwości i właściwości standardowych, wybierając kolumny w arkuszu kalkulacyjnym, które zawierają odpowiednie dane.Jest to jednak bardziej zaawansowane techniki niż Zalecane podejściena import z MS Excel, który jest poprzez katalogi jak opisano tutaj .

Notatka

Import / eksport z programu Excel funkcja wymaga Microsoft Excel 2003lub nowszy jest zainstalowany na komputerze.

Główną funkcją programu Excel jest Importer pozwala na zdefiniowanie pliku konfiguracyjnego (tj hierarchicznej strukturze modelu architektonicznego). Plik konfiguracyjny przechowuje wcześniej zapisane mapowania z pliku programu Excel do pliku ABACUS. Po wyznaczeniu zapisany plik konfiguracyjny jest później wykorzystywany do dalszego importu i eksportu do plików .xls.

Notatka

Kroki przedstawione w poniższych rozdziałach są specjalnie dla użytkowników, którzy mają jeszcze zdefiniować i zapisać plik konfiguracyjny i importowania z programu Excel są po raz pierwszy. Musisz utworzyć i zapisać plik konfiguracyjny, aby korzystać z funkcji eksportu do Excela.

Aby zaimportować arkusz programu Excel do ABACUS

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Plik | Nowy i wybrać z Przewyższaćz wyświetlonym oknie dialogowym i kliknij OK.

Notatka

Jeśli chcesz zaimportować do istniejącego projektu ABACUS następnie albo kliknij prawym przyciskiem myszy węzeł Komponenty w ramach Architektury, lub kliknij prawym przyciskiem myszy komponent w ramach indywidualnej architektury, a następnie wybierz polecenie Importuj | Z programu Excel.

3. Arkusz kalkulacyjny Excel importzostanie wyświetlone okno

Arkusz kalkulacyjny Excel import Okno

4. Kliknij Otwórz plik Excelikony i wskaż plik Excel chcesz importować.

5. Wybierz Arkuszchcesz importować z rozwijanej listy.

Notatka

Po otwarciu pliku Excel, można użyć Dane PodglądZakładka, aby zobaczyć pierwsze 25 kolumn i wierszy arkusza kalkulacyjnego. Stąd można uzyskać numery kolumn potrzebnych do wypełnienia podzespoły i Znajomości patka.

Można również wybrać, czy chcesz komponenty w arkuszu kalkulacyjnym Excel być importowane z małych liter. Po prostu zaznacz Importuj z małych literopcja (domyślnie jest to zawsze zaznaczone) i arkusz kalkulacyjny zostanie odpowiednio importowane.

Przykładowy plik Excel

Notatka

W tym przykładzie będziemy importować proste Architektura Infrastruktura i ludzie excel z danych przedstawionych na powyższym zrzucie ekranu. Połączenia będą między "osoby odpowiedzialne" i "Serwery", że ci ludzie zarządzają.

Aby wypełnić kartę Components

Ta sekcja jest do definiowania typów komponentów oraz hierarchiczną strukturę dla pliku konfiguracyjnego.

1. Wybierz podzespoły patka. Zmień nazwę Set IDpoprzez nadpisanie (zero) wartość

Notatka

Funkcja ta pozwala na zdefiniowanie zupełnie inaczej Zestawyfunkcjonalnie odrębnych elementów. Jak pokazano na poniższym zrzucie ekranu, może chcesz wyróżnić swoje elementów infrastruktury z twoich ludzi komponentów. Jeśli istnieją relacje (połączenia) między tymi oddzielnych zestawów składników, mogą być określone zgodnie z Znajomości patka. Później w tym przykładzie tworzenia połączeń typu "administruje" między Infrastruktury i ludzie Zestawy.

Można również wybrać, czy chcesz dodać do najwyższego poziomu GrupowanieSkładnik dla wszystkich elementów zestawu. Po prostu zaznacz Grupa Pod Set IDopcja (domyślnie jest zaznaczona) i arkusz kalkulacyjny zostanie odpowiednio importowane.

Przypisywanie Ustaw ID

2. Kiedyś Zestawyzdefiniowano zaznaczyć Zestawchcesz wypełnić i rozwinąć klikając na [+] znak.

3. Wybierz Poziomy komponentów w zestawiez rozszerzonej listy.

4. Komponent Hierarchia Ustawia: Ustaw IDOkno pojawi się za to Zestaw.

Komponent Hierarchia i przypisanie wartości (Set ID: Infrastruktura)

5. Zmień nazwę Ilość PoziomKolumna poprzez nadpisanie (zero) wartość.

Notatka

Ilość Poziomkolumna pozwala na przypisanie do hierarchii komponentów. Każdy poziom odpowiada warstwie w swojej architekturze, przy czym pierwszy poziom znajduje się na najwyższym roślina mateczna poziom. Na przykład, numer poziomu "1" odpowiada najwyższej warstwie hierarchicznej, Poziom Numer "2" jest dzieckiem numer poziomu "1" i tak dalej.

6. Wybierz i przypisać odpowiednią kolumnę z arkusza kalkulacyjnego Excel dla każdego Ilość Poziomwprowadzając go pod Komponent Kolumna kolumna.

Notatka

Możesz wybrać, aby wykluczyć niektóre wiersze, które nie chcą być reprezentowane w architekturze. Te mogą być umieszczone w nagłówkach kolumn, puste wiersze itp Aby wykluczyć rzędy użyć Wiersze do wykluczenia:pole tekstowe, w pobliżu górnego prawego rogu okna. W tym przykładzie mamy wyłączone wiersz 1, ponieważ zawiera nasze nagłówki kolumn.

7. Możesz wybrać, aby dodać opisy do swoich komponentów przez zastępowanie (zero)Wartość w Opis Kolumna.

Notatka

Ten opis jest to, co pojawi się w ABACUS pod Właściwości ogólnesekcja | Opis pole.

8. Jeśli dana kolumna arkusz kalkulacyjny ma więcej niż jeden składnik na komórkę (wprowadzane za pomocą Alt-Enter lub CHAR (10) polecenia), a następnie zaznacz pole wyboru pod spodem Nowe linie traktować jako oddzielne składniki, Każdy wiersz zostanie zaimportowany jako oddzielne składniki.

napiwek

Do importowania Matrix' ze zbioru kolumny, gdzie "X" w danym Matrix' komórki (komórki B2: D2 Say) oznacza, że ​​składnik określony przez rzędu (w komórce A2 Say) jest połączony z elementem określone w kolumnie "nagłówkiem" (w wierszu 1 powiedzenia), prosta formuła może być używany. Wpisz następującą formułę dla każdego wiersza w kolumnie poza komórkami macierzy (kolumna F powiedzieć); = JEŻELI (B2 = "", "", B $ 1 & ZNAK (10)) i IF (C2 = "", "", C $ 1 & ZNAK (10)) i IF (D2 = "", "", D 1 $ & CHAR (10)). Następnie skonfigurować połączenie zgodnie z opisem poniżej pomiędzy elementów określonych przez rząd (w kolumnie A mówią) i opisane przez tego wzoru (w kolumnie F powiedzieć). Pamiętaj, aby sprawdzić Nowe linie traktować jako oddzielne składnikiOpcja gdy składniki ze wzoru są importowane. Dla bardziej zaawansowanych importu macierzy, takich nagłówków z wielu warstw hierarchii lub komórki z różnych wartościach niż tylko zwykły "X", proszę skontaktować Wsparcie Avolution .

9. Wypełnienie pozostałej kolumny stosownie do potrzeb.

Notatka

Możesz wybrać, aby uzyskać typ z rzędami kolumn, zaznaczając pole wyboru pod Pobierz Type z kolumnyKolumna i wprowadzając odpowiednie kolumny z arkusza kalkulacyjnego Excel pod Składnik Typ Wartość lub kolumny kolumna. W ten import wszystkich składników w tym kolumnę i ustawić je w rodzaju zdefiniowanego w kolumnie. Alternatywnie, i jak przy zrzucie ekranu powyżej i poniżej, można zdecydować się na stosowanie stałej / predefiniowany nazwę typu, wpisując nazwę typu pod Składnik Typ Wartość lub kolumnyKolumna i upewniając się, że pole wyboru jest odznaczone.

Komponent Hierarchia i przypisanie wartości (Set ID: Ludzie)

Notatka

W tym przykładzie chcemy, aby nasze sieci i ludzi ugrupowania na poziomie 1 Architektury. Na poziomie 2 chcemy mieć nasze serwery i osoby odpowiedzialne za administrowanie te serwery. podzespołypłytka została wypełniona Odpowiednio, jak pokazano w dwóch zrzuty ekranu powyżej. W pierwszym zrzucie ekranu powyżej określiliśmy na poziomie 1 (grupowania sieci) i poziomu 2 (serwer) dla elementów infrastruktury Zestaw, I na zrzucie ekranu bezpośrednio nad zdefiniowaliśmy na poziom 1 (ludzi) i poziom grupowania (2) komponentów odpowiedzialnych ludzi dla ludzi Zestaw.

Alternatywnie, dla LudzieUstaw, a nie za pomocą kolumny C jako People grupy, mogliśmy używany Grupa Pod Set IDopcji na karcie składników najwyższego poziomu, a potem po prostu wszedł jeden Ludzie niższego poziomu z kolumny D. Widać to na poniższym zrzucie ekranu.

Komponent Hierarchia i przypisywanie wartości za pomocą opcji Grupa Pod Set ID (Set ID: Ludzie)

10. Gdy składniki zostały zidentyfikowane, wybrać poziom komponentów chcesz wypełnić właściwości i / lub standardy i rozwinąć klikając na [+] znak.

11. Wybierz Właściwości składników na tym poziomie albo Standardy komponentów na tym poziomiez rozszerzonej listy i wypełnić odpowiednie kolumny w razie potrzeby.

Składniki wypełniania

Notatka

Właściwości składników na tym poziomiepozwala definiować właściwości elementów na wybranym poziomie. Standardy komponentów na tym poziomiepozwala na zdefiniowanie standardów i ich standardowe właściwości komponentów na wybranym poziomie.

12. Powtórz kroki 2 - 11dopóki wszystkie poziomy składników zostały wypełnione dla wszystkich zdefiniowanych Zestawy, Użyj strzałki wstecz w pobliżu górnego prawego rogu okna, aby przejść z powrotem do Zestawyktóre zdefiniowano wcześniej.

Aby wypełnić kartę Połączenia

Ta sekcja jest do definiowania typów połączeń i hierarchiczną strukturę dla pliku konfiguracyjnego.

1. Wybierz Znajomości patka. Dla każdego zestawu połączeń trzeba określić składnik Zestawże chcesz być komponenty źródłowe i składnik Zestawchcesz mieć elementy docelowe.

2. Pod Źródło Element Set ID wejdz do Zestawnazwę odnoszącą się do Zestawzdefiniowane wcześniej w podzespoły patka. Pod Component Poziom Ilośćwpisz numer odpowiadający poziomie komponentu, który chcesz podłączyć na końcu źródła połączenia.

3. Teraz wybierz, który składnik grupa będzie na końcu docelowego połączenia. Pod Destination Element Set ID wejdz do Zestawnazwę odnoszącą się do Zestawzdefiniowane w podzespoły patka. Pod Komponent docelowy poziom Ilośćwpisz numer odpowiadający poziomie komponentu, który chcesz podłączyć na końcu docelowego połączenia.

Notatka

W tym przykładzie chcemy połączyć ludzi odpowiedzialnych za administrowanie serwerami z serwerami, że zarządzają. Osoby odpowiedzialne zostały określone w Ludzie Zestawjako poziom 2 elementy, podczas gdy serwery zostały określone w Infrastruktury Zestawna poziomie 2 elementy. Znajomościpłytka została wypełniona Odpowiednio, jak pokazano w poniższej ekranu.

Zakładka Połączenia część 1 z 2

4. Jeśli przejdziesz do prawej, znajdziesz dodatkowe opcje importowania połączeń. Pobierz Type z kolumny i Rodzaj połączenia Wartość lub kolumnydziałają w ten sam sposób jak w przypadku podzespoły patka.

5. Jeśli Źródło Element Set IDoraz Component Poziom Ilośćsą takie same jak Destination Element Set IDoraz Komponent docelowy poziom Ilość(na przykład, jeśli łączysz się te same typy komponentów, takich jak wykonywanie połączeń z serwerami do innych serwerów), to musisz mieć inną kolumnę w arkuszu kalkulacyjnym, który zawiera nazwy tych serwerów powtarzane. W tej sytuacji nie można umieścić tę kolumnę arkusza kalkulacyjnego w Destination powtórnie w kolumnie kolumna. Jeśli w tej kolumnie arkusza wprowadzeniu więcej niż jednego podłączonego urządzenia na komórkę, a następnie zaznacz pole wyboru pod spodem Nowe linie traktować jako oddzielne składniki.

Zakładka Połączenia Część 2 z 2

6. Po połączenia zostały zidentyfikowane wybierz połączenie chcesz wypełnić właściwości i / lub standardy i rozwinąć klikając na [+] znak.

7. Wybierz Właściwości te połączenia lub Standardy dla tych połączeńz rozszerzonej listy i wypełnić odpowiednie kolumny w razie potrzeby.

Notatka

Właściwości te połączeniapozwala definiować właściwości dla wybranej grupy przyłączeniowej. Standardy dla tych połączeńpozwala na zdefiniowanie standardów i ich standardowe właściwości dla wybranej grupy przyłączeniowej.

8. Powtórz kroki 2 - 7aż wszystkie grupy łączące zostały zdefiniowane.

9. Po zakończeniu definiowania grup połączeń, kliknij koniecPrzycisk i twój architektury będą tworzone z importowanego pliku Excel. Powyższy przykład prowadzić w strukturze przedstawionej w poniższej ekranu.

Architektura próbka Importowane z programu Excel

10. Teraz zapisać odwzorowany konfiguracji do pliku, klikając na Zapisz konfigurację ikona. Twój zapisanej konfiguracji mogą być pobierane później, klikając na Otwórz KonfiguracjaIkona obok górnego lewego rogu okna.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Wypełnianie swoją architekturę z programu Access | Wypełnianie swoją architekturę z Visio


Wypełnianie swoją architekturę z Microsoft SharePoint

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie z produktów firmy Microsoft>

Wypełnianie swoją architekturę z Microsoft SharePoint

Wyślij komentarzy w tym temacie.

Możesz synchronizować Twoja architektura zMicrosoft List SharePoint. Synchronizacja obejmuje zarówno tworzenie nowych list SharePoint (i ich kolumn) z rodzaju liczydła, ich właściwości i załączników lub mapowanie istniejących list SharePoint (i ich kolumn) do rodzaju liczydła, ich właściwości i załączniki, a następnie albo wysyłanie treści z ABACUS do SharePoint lub SharePoint Abacus.

Notatka

SharePoint Sync funkcja wymaga za Microsoft SharePoint 2010, 2013 lub SharePoint Online Strona dostępna jest podłączenie i synchronizacji z.Podczas gdy funkcja SharePoint Sync mogą tworzyć listy (z kolumn) na witrynie programu SharePoint z dowolnego projektu ABACUS, Avolution może również zapewnić różne szablony witryn programu SharePoint na poparcie standardowych ram (np TOGAF, ArchiMate, ITIL itp), więc proszę o kontakt Wsparcie Avolution jeśli wymagają takiej możliwości.

Do utworzyć nową listę programu SharePoint i mapować go do urządzenia lub połączenia typu ABACUS

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Narzędzia | SharePoint Sync.

3. Kliknij Nowy MapowaniePrzycisk i dialogowe Mapowanie SharePoint, jak pokazano poniżej pojawi.

4. Wpisz adres URL strony, nazwę użytkownika i hasło do witryny programu SharePoint, a następnie kliknij Połącz.

Notatka

Poprawny SharePoint "admin" lub konto "uczestnika funduszu 'jest wymagane do synchronizacji z oraz do SharePoint i konta" czytelnika "pozwala jedynie synchronizację z SharePoint.

5. Wybierz komponent lub połączenia typu ABACUS mapowania z Wybierz typ rozbierać.

6. Kliknij Dodaj noweprzycisk, a następnie dla każdego komponentu lub typ połączenia aspekcie ABACUS chcesz mapować odpowiednim polu listy programu SharePoint, wybierz element w lewym panelu, w prawym panelu wprowadzić nową nazwę listy programu SharePoint w kolumnie Nowa lista (tylko za pierwszym razem) , a następnie nazwę kolumny w polu Nazwa programu SharePoint Column (lub użyć domyślnego) i kliknij Przydzielać za każdym razem.

Notatka

Jako minimum, aby umożliwić synchronizację ABACUS EEID, Architektura i aspekty Nazwa zostanie automatycznie mapowane do numeru programu SharePoint i dwa (2) pojedynczą linię tekstu (Text) kolumn aka odpowiednio. To nie może być obsadzony. Ponadto tylko niektóre aspekty ABACUS można obecnie mapowane do niektórych kolumn SharePoint i Kolumna typu pull-down zostanie automatycznie ustawiona na wymaganego typu kolumny SharePoint. Mianowicie;

· Abacus "Hierarchia Ścieżka do programu SharePoint wielu wierszy tekstu (aka uwaga) kolumn (Uwaga: SharePoint pojedynczą linię tekstu (aka tekstowe) kolumny obsługuje tylko 255 znaków, więc nie są one preferowane),

· Abacus "Załączone Komponenty do kolumny SharePoint Lookup (Uwaga: Mapowanie musi już istnieć na liście na załączonych samych elementów),

· Opis właściwości tekstowe i Abacus 'do SharePoint wielu wierszy tekstu (aka Uwaga) Kolumny (Uwaga: SharePoint pojedynczą linię tekstu (aka tekstowe) kolumny obsługuje tylko 255 znaków, więc nie są one preferowane),

· Abacus 'dziesiętne lub całkowite właściwości do SharePoint Liczba kolumn,

· Właściwości Lista Abacus 'do kolumny SharePoint Choice (Uwaga: program SharePoint nie wymusza wartości wybór więc typ danych Lista nie musi być wykonywane w ABACUS),

· Abacus "data / czas, aby właściwości SharePoint wielu wierszy tekstu (aka uwaga) kolumn (UWAGA: SharePoint Data i kolumn czas nie może być stosowany jako jeszcze ze względu na niezgodny obsługi programu SharePoint za strefę czasową Ustawienia / regionalizacji),

· Abacus 'logicznych właściwości do SharePoint Tak / Nie (aka Boolean) kolumn.

Standardy połączony element Abacus nie mogą być przypisane do listy kolumn SharePoint jeszcze.

7. Wybierz Tworzenie Mapowanie.

Do utworzyć nowe mapowanie pomiędzy składnika ABACUS lub typu połączenia i istniejącej listy programu SharePoint

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Narzędzia | SharePoint Sync.

3. Kliknij Nowy MapowaniePrzycisk i dialogowe Mapowanie SharePoint, jak pokazano poniżej pojawi.

4. Wpisz adres URL strony, nazwę użytkownika i hasło do witryny programu SharePoint, a następnie kliknij Połącz.

Notatka

Poprawny SharePoint "admin" lub konto "uczestnika funduszu 'jest wymagane do synchronizacji z oraz do SharePoint i konta" czytelnika "pozwala jedynie synchronizację z SharePoint.

5. Wybierz komponent lub połączenia typu ABACUS mapowania z Wybierz typ rozbierać.

6. Wybierz listę witryn programu SharePoint na mapę z Wybierz Lista rozbierać.

7. Dla każdego składnika lub typu połączenia aspekcie ABACUS chcesz mapować do listy kolumnie odpowiadającej SharePoint wybierz element w lewym panelu, a prawy panel odpowiednio i kliknij Przydzielać.

Notatka

Jako minimum, aby umożliwić synchronizację ABACUS EEID, Architektura i aspekty nazwy muszą być przypisane do numeru programu SharePoint, a następnie dla Architektury i imię albo pojedynczą linię tekstu (aka Tekst) lub kolumn odpowiednio wiele wierszy tekstu (aka uwaga). Do tego jest wykonywana przycisk mapowania Stwórz nie zostanie włączona. Ponadto tylko niektóre aspekty ABACUS można obecnie mapowane do niektórych kolumn SharePoint. Mianowicie;

· ABACUS "Architektura aspektem do SharePoint pojedynczą linię tekstu (aka Tekst) lub wiele wierszy tekstu (aka uwaga) kolumny (jest to wymagane dla konkretnego odwzorowania zawartości jak opisano poniżej),

· Hierarchia Ścieżka Abacus 'do SharePoint pojedynczą linię tekstu (aka Tekst) lub wiele wierszy tekstu (aka uwaga) kolumn (Uwaga: SharePoint pojedynczą linię tekstu (aka Text) kolumny nośne tylko 255 znaków więc wszelkie dodatkowe znaki zostaną obcięte i dlatego zaleca się, aby przekonwertować je na wiele wierszy tekstu (aka uwaga) kolumny w SharePoint przed mapowaniem),

· Abacus "Załączone Komponenty do kolumny SharePoint Lookup (Uwaga: Mapowanie musi już istnieć na liście na załączonych samych elementów),

· Tekst i opis właściwości Abacus 'do SharePoint pojedynczą linię tekstu (aka Tekst) lub wiele wierszy tekstu (aka uwaga) kolumn (Uwaga: SharePoint pojedynczą linię tekstu (aka Text) kolumny nośne tylko 255 znaków więc wszelkie dodatkowe znaki zostaną obcięte iw związku z tym zaleca się, aby przekonwertować je na wiele wierszy tekstu (aka uwaga) kolumny w SharePoint przed mapowaniem),

· Abacus 'dziesiętne lub całkowite właściwości do SharePoint Liczba kolumn (Uwaga:. SharePoint Obliczone kolumny mogą być używane jednak będą mogli tylko zsynchronizowane z SharePoint do ABACUS Próba synchronizacji' do 'kolumnie obliczeniowej będzie skutkować ostrzeżeniem, jak na poniżej) ,

· Właściwości Lista Abacus 'do kolumny SharePoint wybór,

· Abacus "data / czas, aby właściwości SharePoint wielu wierszy tekstu (aka uwaga) kolumn (UWAGA: SharePoint Data i kolumn czas nie mogą być stosowane ze względu na niezgodny obsługi programu SharePoint za strefę czasową Ustawienia / regionalizacji),

· Abacus 'logicznych właściwości do SharePoint Tak / Nie (aka Boolean) kolumn.

Standardy połączony element Abacus nie mogą być przypisane do listy kolumn SharePoint jeszcze. A Waluta SharePoint jest, osoba lub grupa, hiperłącza lub zdjęcia, Wynik Zadanie, danych kolumny zewnętrzne i Managed Metadata nie mogą być przypisane do aspektów Abacus jeszcze.

8. Wybierz Tworzenie Mapowanie.

Do synchronizowaćTwój Microsoft Wykaz (y) SharePointw ABACUS

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Narzędzia | SharePoint Sync.

Notatka

Do synchronizację listy SharePoint zProjekt ABACUS potrzebuje licencja użytkownika pozwala SharePoint Syncadd-on możliwości. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

3. Wybierz istniejącą mapowanie SharePoint (lub mapowania za pomocą Przytrzymując klawisz Ctrl albo Zaznacz wszystkoprzycisk) z SharePoint Mapowanie płytajak pokazano na zdjęcie próbki nad. Uwaga: tutaj pokazujemy tylko "Cel (lub)" wymóg typu komponent mapowanie ABACUS do listy programu SharePoint zostanie wybrany zwane cele.

4. Wybierz Architektura (y), które chcesz synchronizować zawartość z od Synchronizuj zawartość z architekturamiPanel jako pokazane na zrzucie ekranu próbki nad. Uwaga: tutaj pokazujemy tylko "2015 Rzeczywista" architektura synchronizowane.

5. Wybierz Synchronizacja z SP przycisk.

Notatka

Jeśli poświadczenia witryny programu SharePoint nie "Wszyscy święci" są do mapowania (ów) wybranej Zaloguj się wówczas pojawi się okno dialogowe z prośbą SharePoint dla Adres strony, Nazwa użytkownika i / lub Hasło.Podaj nich. Oprócz tego synchronizacja będzie zawierać żadnych innych odwzorowań, które są wymagane do załączonych elementów / kolumn odnośników. Wszelkie dodatkowe mapowania, które są dołączane automatycznie pojawi się w oknie, jak na poniżej.

6. Po pomyślnym synchronizacji dialogowe SharePoint Sync wyników pojawi się, jak pokazano poniżej listy zmian i ewentualnych ostrzeżeń. Trzask ok.

Do Synchronizacja z ABACUS do Twój Microsoft Wykaz (y) SharePoint

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Narzędzia | SharePoint Sync.

Notatka

Do synchronizację listy SharePoint zProjekt ABACUS potrzebuje licencja użytkownika pozwala SharePoint Syncadd-on możliwości. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

3. Wybierz istniejącą mapowanie SharePoint (lub mapowania za pomocą Przytrzymując klawisz Ctrl albo Zaznacz wszystkoprzycisk) z SharePoint Mapowanie płytajak pokazano na zdjęcie próbki nad. Uwaga: tutaj pokazujemy tylko "Cel (lub)" wymóg typu komponent mapowanie ABACUS do listy programu SharePoint zostanie wybrany zwane cele.

4. Wybierz Architektura (y), które chcesz synchronizować zawartość z od Synchronizuj zawartość z architekturamiPanel jako pokazane na zrzucie ekranu próbki nad. Uwaga: tutaj pokazujemy tylko "2015 Rzeczywista" architektura synchronizowane.

5. Wybierz Sync Aby SP przycisk.

Notatka

Jeśli poświadczenia witryny programu SharePoint nie "Wszyscy święci" są do mapowania (ów) wybranej Zaloguj się wówczas pojawi się okno dialogowe z prośbą SharePoint dla Adres strony, Nazwa użytkownika i / lub Hasło.Podaj nich. Oprócz tego synchronizacja będzie zawierać żadnych innych odwzorowań, które są wymagane do załączonych elementów / kolumn odnośników. Wszelkie dodatkowe mapowania, które są dołączane automatycznie pojawi się w oknie, jak na poniżej.

6. Po pomyślnym synchronizacji dialogowe SharePoint Sync wyników pojawi się, jak pokazano poniżej listy zmian i ewentualnych ostrzeżeń. Trzask ok.

Notatka

ABACUS aktualizuje kolumn SharePoint z pustymi wartościami, nawet jeśli "Wymagaj, że kolumna ta zawiera informacje" jest ustawiona na Tak w SharePoint. To dlatego, że SharePoint nie narażać tego ustawienia na zewnątrz. Jeśli jest to, aby zapobiec zaleca się, że projektant ABACUS ustawia ograniczenie Wymagane True i wykonywane dla danej nieruchomości za pomocą liczydła " przymus cecha .

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Wypełnianie swoją architekturę z Visio | Wypełnianie swoją architekturę z programu Excel


Wypełnianie swoją architekturę z Microsoft SQL Server

Nawigacja: Wypełnianie swoją architekturę> Wypełnianie z produktów firmy Microsoft>

Wypełnianie swoją architekturę z Microsoft SQL Server

Wyślij komentarzy w tym temacie.

Możesz importować architekturę z bazy danych Microsoft SQL Server. Masz do wyboru po prostu zaimportować tabele i relacje skutecznie importowania tylko ogólną strukturę bazy danych lub tabel, wierszy i relacji, które importujemy nie tylko strukturę, ale dane, jak również.

Notatka

Funkcja From SQL Server wymaga, aby Microsoft SQL Server 20052008, 2008 R2, 2012 lub 2014zainstalowany jest na komputerze.

Aby zaimportować bazę danych Microsoft SQL Server w ABACUS

1. Sprawdź, czy masz ABACUS otwarty.

2. Wybierz Plik | Nowy i wybierz Z SQL Serverz wyświetlonym oknie dialogowym i kliknij OK.

3. W oknie dialogowym Importuj SQL Server pojawi ustawić "urządzenia" w "SQLINSTANCE i wartości" połączenia zmiennej String i wartości 'dbname' zmiennej Nazwa bazy danych do ich właściwych wartości, jak pokazano na przykładowym zrzucie ekranu poniżej.

4. Ustaw zmienną nazwa bazy danych do tej samej wartości, co początkowy zmiennej Catalog określonym w punkcie powyżej, jak pokazano na przykładowym zrzucie ekranu poniżej.

5. Naciśnij przycisk Testuj połączenie i stoły importować części okna powinny być wypełniane dostępnych tabel bazy danych, jak pokazano na przykładowym zrzucie ekranu poniżej.

6. Wybierz tabele, które chcesz zaimportować przez zarówno indywidualnie, wybierając je lub za pomocą All, None i przycisków Odwróć z prawej strony okna.

Notatka

Tylko obce kluczowych relacji, które istnieją między tabelami, że wybrany będzie się importować.

7. Korzystanie opcję Importuj styl wybrać, czy chcesz zaimportować tylko tabele i relacje między nimi lub tabelach, ich wierszy i specyficznych relacji między rzędami.

Notatka

Pierwsza opcja importuje tabele jako elementy typu 'table' i relacji między dwoma tabelami (z kluczy obcych) są importowane jako połączenia typu "Relacja Tabela". Jest to klasyczny "ERD" Widok styl tabelach systemowych. Druga opcja importuje wiersze tabeli w postaci pojedynczych podzespołów typu 'Tabela Row "o właściwościach odpowiadających każdej z kolumn / pól i stosunków między wiersze tabeli typu" Relacja Tabela ". Ponadto, jeśli jest to kolumna / pole o nazwie 'Nazwa' to ten jest używany do nazwy poszczególnych wiersz tabeli sub-komponentów.

8. Wybierz przycisk Importuj ....

9. Po krótkim czasie (z paskiem postępu sprzężenia) nowy projekt ABACUS zostanie utworzony w tabelach, Wiersze stołowe (jeśli druga opcja została wybrane w poprzednim kroku) i relacje z bazy danych Microsoft SQL Server.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Wypełnianie swoją architekturę ręcznie | Wypełnianie swoją architekturę z Visio | Wypełnianie swoją architekturę z programu Excel


Dodawanie właściwości gotowych do komponentowego, połączenia lub rodzaju

Nawigacja: Wypełnianie swoją architekturę> Właściwości>

Dodawanie właściwości gotowych do komponentowego, połączenia lub rodzaju

Wyślij komentarzy w tym temacie.

Standardowe biblioteki właściwości można określić i przypisać do niczego innego w architekturze. Biblioteki te są znane jako Standardy, Używając Standardy, Trzeba tylko zebrać specyficzne właściwości systemów - standardowe właściwości już tam są.

Na przykład standardowe cechy wydajności systemu Microsoft Windows 2000 mogą być zapisywane jako Standardi przypisane do wszystkich elementów (lub połączenia, a nie, że to będzie typowy) korzystania z systemu operacyjnego Microsoft Windows 2000.

Aby dodać standarddo komponentowego, połączenia lub rodzaju

1. Kliknij prawym przyciskiem myszyna części / połączenia / typu.

2. Wybierz Przydzielać Standard.

3. Wybierz za Standardz listy.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Zmiana właściwości komponentów, połączenia lub rodzaju | Właściwości kruszywa


Zmiana właściwości komponentów, połączenia lub rodzaju

Nawigacja: Wypełnianie swoją architekturę> Właściwości>

Zmiana właściwości komponentów, połączenia lub rodzaju

Wyślij komentarzy w tym temacie.

Właściwości są zazwyczaj wymagania systemowe, które określają, czy wyniki ocen Abacus ". (Gdy ABACUS wykonuje swoje oceny, to pisze własności z powrotem do pliku.) Innymi słowy, własności są rzeczy wiedzieć o systemie lub rzeczy używasz Abacus się dowiedzieć.

Aby zmienić wartość właściwości komponentu, połączenia lub rodzaju

1. Trzaskna części / połączeń / rodzaju (jego właściwości będą wyświetlane w oknie Właściwości w prawo).

2. Trzaskpodkreślić właściwości chcesz zmienić.

3. Rodzajnowa wartość.

Ważny

Również wiele właściwości, są definiowane przy użyciu Standardy , Poprzez zmianę własności nieruchomości w Standard, Nie tylko zmienić bieżący obiekt, można także zmienić mistrza Standard (pod Standardy wwierzchołek drzewa). Przedtem należy sprawdzić, jakie inne elementy, połączenia lub typy są za pomocą Standard, Ponieważ zmiany mogą nie być odpowiednie dla nich- Można użyć okna na ten temat:.

napiwek

Możesz zmienić właściwości połączenia od wewnątrz branży komponentów drzewa (i odwrotnie). Tak więc, na przykład, jeśli szukasz na które połączenia są dołączane do komponentu, i zdajesz sobie sprawę, trzeba zmienić jeden, można.

Aby dodać nowe właściwości do komponentu lub połączenia (poprzez typu)

Notatka

Właściwości mogą być dodawane tylko do typów i elementów lub połączeń typu "odziedziczy" te właściwości.

1. Trzaskrodzaju (jego właściwości będą wyświetlane w oknie Właściwości w prawo).

2. Trzaskprzycisk dodaje się na górze okna właściwości dodać wiersz na wierzchu siatki właściwości dla nowego obiektu.

3. Dodać Rodzajdla nowej nieruchomości.

4. Dodać Imiędla nowej nieruchomości.

5. Dodać Domyślna wartośćdla nowej nieruchomości.

6. Dodać Jednostkadla nowej nieruchomości.

7. Ustaw Typ danychdla nowej nieruchomości.

Notatka

W polu Typ danych może być wykorzystywane do ograniczania prawidłowych wartości, że nieruchomość może mieć. To jest; Tekst, Integer, dziesiętny, data / czas, Boolean lub Lista.

o A TekstObiekt jest taki, który ma nieograniczoną liczbę znaków i zasadniczo nie ma ograniczeń na wartości.Jeśli wartość nieruchomości jest odpowiednio uformowany hiperłącze (tj Adresy URL należy uruchomić z jednym z 5 smyczki; http: //, https: //, ftp: //, plik:lub \\ a wszelkieprzestrzenie powinny być wprowadzone z '% 20'), A następnie link jest klikalny (przez Ctrl + kliknięcie).

o Na Liczba całkowitaObiekt musi być cały liczby dodatnie lub ujemnei może zawierać okres, przestrzeń, apostrof lub przecinek na cyfrowym grupy w zależności od projektu Ustawienia regionu od File | Opcje projektu.Ustawienia regionu i.Netto Metoda Long.TryParse jest stosuje się w celu określenia ważność Liczba całkowitaWartości.

o A Dziesiętnynieruchomość może zawierać Okres lub przecinek symbolu dziesiętnego i może zawierać okres, przestrzeń, apostrof lub przecinek na cyfrowym grupy w zależności od projektu Ustawienia regionu od File | Opcje projektu.Ustawienia regionu i.Netto Metoda Decimal.TryParse jest stosuje się w celu określenia ważność Dziesiętny Wartości.

o A Data / godzinaWłaściwość ta umożliwia zarówno część daty lub część czasu lub obu. RegionUstawieniai .NET Metoda DateTime.TryParse są przede wszystkim wykorzystywane do określenia prawidłowych wartości daty i / lub czasu. Jednak Data częścią jeżeli dotyczy wymaga co najmniej dzień i miesiąc (rok będzie uznać za bieżący rok) lub części miesiąc i rok ważność. To znaczy. Czerwca Q3 2010 lub nawet 2010 są nieważne. Choć będzie się różnić z różnymi ustawieniami regionalnymi, zwykle części dnia, miesiąca i roku mogą być rozdzielone spacją, przecinkiem, myślnikiem ("-") lub ukośnik ("/"). Część Dzień zazwyczaj jest liczbą całkowitą od 1 do 31. Część Miesiąc zazwyczaj liczbę całkowitą od 1 do 12, ważny skrót 3 litera za miesiące (np sty, luty, mar) lub nazwę pełny miesiąc (np styczeń, luty , Marsz). Część rok jest zazwyczaj 4 cyfrowy numer pozytywne, ale 1, 2 i 3 cyfra roku są przyjmowane zgodnie z ustawieniami w Panel sterowania-> regionalne i językowe Opcje-> Opcje-> Personalizuj Regionalnego (przycisk) -> Data-> Kalendarz. Zazwyczaj są one interpretowane w następujący sposób; 0-29 jest interpretowana jako 2000-2029, 30 do 99, w 1930-1999 i 100-999 jako 100-999. Będą wykrywane nieprawidłowe daty, takie jak 31 czerwca 2010 roku oraz na 31/9/2010. Czas częścią, jeśli zastosowanie wymaga godzin i minuty udział i ewentualnie sekund części. Godziny, minuty i części opcjonalne Sekund są zwykle oddzielone dwukropkiem (':') i część sekundy można określić z przecinkiem ("."). Więcej informacji na temat obowiązujących formatów można znaleźć w sekcji Uwagi o .NET Metoda DateTime.TryParse .

napiwek

Zaleca się stosować co najmniej 3 się nazw miesięcy formatu (czyli "lipiec" lub "lipiec") dla aktualnych wartości, a nie formatowania numerycznego (tj "7" lub "07"), jak te wartości zweryfikuje poprzek większości regionów w zależności od projektu Ustawienia regionu od File | Opcje projektu. To znaczy. zaleca się, aby użyć "15 lip 2010" zamiast "15/7/2010" lub "7/15/2010". Z tym przykładzie "15/7/2010" zawiedzie walidację dla "angielski (Stany Zjednoczone)" i "15/07/2010" nie doprowadzi do "English (United Kingdom)", jednak "15 lip 2010" przejdzie do obie.

o A Booleannieruchomość może być Prawda czy fałsz.To jest wielkość liter ma znaczenie tak PRAWDA lub FAŁSZ mogą być również wykorzystywane jednak tak, nie, 1, 0 itd nie będzie żadnych ograniczeń wszystkie własności.

o A ListaWłaściwość ta umożliwia zbiór predefiniowanych wartości, takie jak niskie | Średni | Wysokie lub Zachowaj | Odśwież | Redesign | Emeryturę i zakres wartości pochodzi z pola sztukę dla nieruchomości albo jako przecinka lub rury '|' Oddzielone wartości. Właściwość ta może być uznana za porządkowy (w przeciwieństwie do nominalnego, częstotliwości lub proporcji), ponieważ gdy stosuje się na wykresach i kolor elementów, na diagrams i 3DS wartości traktowane są po prostu w porządku rosnącym lub malejącym) (zamówienia. To wartości są wykreślane w porządku rosnącym (lub malejącym) na osiach wykresu lub zakresów kolorów.

8. Type Dane mogą być ustawione Wyłączone, Ostrzeżony lub Wymuszoneklikając prawym przyciskiem myszy w polu Typ danych dla pozycji innej niż tekst, który umożliwia dowolne znaki, więc nigdy nie może być nieprawidłowe.

9. Ustaw WymaganyFlaga dla nowej nieruchomości.

Notatka

Pole Wymagane może być używany do wskazania, czy wartość musi być wprowadzona dla nieruchomości. Oznacza to, że nie może być puste lub pusty. Fałszywejest domyślnym i oznacza, że ​​nieruchomość może być puste lub puste, Prawdziweoznacza, że ​​nieruchomość powinna mieć wartość i nie może być puste lub puste. Wymagane mogą być ustawione Wyłączone, Ostrzeżony lub Wymuszoneklikając prawym przyciskiem myszy pole wymagane, jeżeli została ona ustawiona na True.

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Dodawanie właściwości gotowych do komponentowego, połączenia lub rodzaju | Właściwości kruszywa


Zmiana ustawień regionowi Projektu

Nawigacja: Wypełnianie swoją architekturę> Właściwości>

Zmiana ustawień regionowi Projektu

Wyślij komentarzy w tym temacie.

Wartości nieruchomości wymagają pewne formatowanie w różnych regionach, aby dopasować dowolny Ograniczenia typ danych Integer, dziesiętne i Date / Time właściwości. Na przykład w Australii po przecinku "sto dwudziestu tysiące czterysta trzy i pięćdziesiąt sześć siedem osiem dziewięć punkt" jest przedstawiony jako "123,456.789", podczas gdy w Niemczech byłoby represnted jako "123.456,789", a we Francji byłoby " 123 456789 ".Podobnie w USA "drugiego grudnia 1970 r" jest reprezentowany w krótkim terminie jako "12/2/1970", ale w Wielkiej Brytanii jest reprezentowany jako "2/12/1970" oraz w Polsce jako "1970/12 -02 ". W związku z powyższym, do pracy przy projekcie ABACUS w regionach wymagane jest ustawienie globalne na projekt ABACUS.

Zmienić Region projektu ustawienia Abacus

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Wybierz File | Opcje projektu ... oraz w oknie dialogowym, które pojawia się wybierz Region i kliknij OK, Uwaga: Proszę zapoznać się z sekcją poniżej dla regionalnych domyślnych.

Notatka

Jeśli nie zobaczyć Opcje projektu ... pozycja w menuwtedy nie ma Designer i Administrator dodateks i nie można zmienić obszaru projektu.Ponadto, jeśli żaden region jest ustawiony (czyli regionu w opcjach projektu jest "Brak (Region System)"), a następnie każda Ustawienia obecna kultura użytkownika MS Windows (czyli ustawienia regionalne)jest używana do sprawdzania właściwości.

Domyślnie Region

Poniższa tabela zawiera listę domyślne dla każdego regionu, jak ustawić poprzez File | Opcje projektu ... pozycja w menu.Proszę zobaczyć poniżej tabeli znajduje się lista używanych symboli.

Region | Dziesiętny Symbol | Grupowanie cyfr | Znak minus | Krótki czas | Długi czas | AM / PM Symbol | Krótki Data | Długi Data
Angielski (Australia) | . | , | - | Hh: mm | HH: mm: ss | AM | PO POŁUDNIU | dd / mm / rrrr | dd MMMM rrrr
Angielski (Wielka Brytania) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / rrrr | dd MMMM rrrr
Angielskie Stany Zjednoczone) | . | , | - | g: mm TT | g: mm: ss tt | AM | PM | M / d / rrrr | dddd, MMMM dd, rrrr
French (France) | , | przestrzeń | - | Hh: mm | HH: mm: ss | | | dd / mm / rrrr | dddd d MMMM rrrr
Niemiecki (Niemcy) | , | . | - | Hh: mm | HH: mm: ss | | | dd.mm.rrrr | dddd, d. MMMM rrrr
Włoski (Włochy) | , | . | - | Hh: mm | HH: mm: ss | | | dd / mm / rrrr | dddd d MMMM rrrr
Hiszpański (Hiszpania) | , | . | - | H: mm | H: mm: ss | | | dd / mm / rrrr | dddd, dd 'de' MMMM 'de' rrrr
Angielski (Kanada) | . | , | - | g: mm TT | g: mm: ss tt | AM | PM | dd / mm / rrrr | MMMM-dd-yy
Francuski (Kanada) | , | przestrzeń | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM rrrr
Arabski (U.A.E.) | . | , | - | hh: mm TT | hh: mm: ss tt | ص | م | dd / mm / rrrr | dd MMMM, rrrr
Arabski (Arabia Saudyjska) | . | , | - | hh: mm TT | hh: mm: ss tt | ص | م | dd / mm / rr | dd / MMMM / rrrr
Angielski (Republika Południowej Afryki) | , | przestrzeń | - | hh: mm TT | hh: mm: ss tt | AM | PM | rrrr / mm / dd | dd MMMM rrrr
Angielski (Nowa Zelandia) | . | , | - | g: mm TT | g: mm: ss tt | przed południem | p.m. | d / mm / rrrr | dddd, d MMMM rrrr
Angielski (Indie) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd-mm-rrrr | dd MMMM rrrr
Niemiecki (Szwajcaria) | . | ' | - | Hh: mm | HH: mm: ss | | | dd.mm.rrrr | dddd, d. MMMM rrrr
French (Belgium) | , | . | - | Hh: mm | HH: mm: ss | | | d / mm / rrrr | dddd d MMMM rrrr
Holenderski (Belgia) | , | . | - | H: mm | H: mm: ss | | | d / mm / rrrr | dddd d MMMM rrrr
Czeski (Czechy) | , | przestrzeń | - | H: mm | H: mm: ss | dop |. odp. | d.M.yyyy | re. MMMM rrrr
Duński (Dania) | , | . | - | Hh: mm | HH: mm: ss | | | dd-mm-rrrr | re. MMMM rrrr
Grecki (Grecja) | , | . | - | g: mm TT | g: mm: ss tt | πμ | μμ | d / M / rrrr | dddd, d MMMM rrrr
Fiński (Finlandia) | , | przestrzeń | - | H: mm | H: mm: ss | | | d.M.yyyy | re. Rrrr MMMM'ta '
Węgierski (Węgry) | , | przestrzeń | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | rrrr. MMMM d.
Holenderski (Holandia) | , | . | - | H: mm | H: mm: ss | | | d-M-rrrr | dddd d MMMM rrrr
Norweski Bokmål (Norwegia) | , | przestrzeń | - | Hh: mm | HH: mm: ss | | | dd.mm.rrrr | re. MMMM rrrr
Polski (Polska) | , | przestrzeń | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM rrrr
Rosyjski (Rosja) | , | przestrzeń | - | H: mm | H: mm: ss | | | dd.mm.rrrr | d MMMM rrrr "г."
Szwedzki (Szwecja) | , | przestrzeń | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | "den" d MMMM rrrr
Koreański (Korea) | . | , | - | tt g: mm | tt h: mm: ss | 오전 | 오후 | yyyy-MM-dd | yyyy "년 'M' 월" d "일" dddd
Hebrajski (Izrael) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / rrrr | dddd dd MMMM rrrr

Następujące symbole są używane do określania sposobu wyświetlania daty i godziny:

Symbole czasu |
h | Godzina (gg wyświetla godzinę z zerem)
m | Minut (mm wyświetla minuty z zerem)
s | Drugie (ss wyświetla drugi z zerem)
tt | RANO. lub P.M.
h / H | 12 lub 24-godzinny wyświetlacz czasu
Data symbole |
d, dd | Dzień
ddd, dddd | Dzień tygodnia
M | Miesiąc
y | Rok

Zobacz też

Wypełnianie swoją architekturę - Przegląd | Zmiana właściwości komponentów, połączenia lub rodzaju | Dodawanie właściwości gotowych do komponentowego, połączenia lub rodzaju


Właściwości kruszywa

Nawigacja: Wypełnianie swoją architekturę> Właściwości>

Właściwości kruszywa

Wyślij komentarzy w tym temacie.

Operacja "Kruszywo Właściwości"Pozwala na dodanie wartości podobnych właściwościach razem i pisać (lub dodać) wynik do właściwości wybranego elementu nadrzędnego. Pozwala również na określenie zakresu agregacji i czy zaktualizować właściwości wszystkich pod-elementów lub nie.

Do właściwości kruszyw

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Kliknij prawym przyciskiem myszy na elemencie (architektury, komponent lub połączenia), w których do zrobienia agregacji i wybierz Właściwości kruszywa.

3. Wybierz jedną z opcji Zagregowane (Traverse wszystkie pod-poziomów lub Tylko bezpośrednie Podpoziom). Jeśli wybrałeś Traverse wszystkie pod-poziomów, Można też wybrać opcję, czy Aktualizacja Sub-Levels.

o Traverse wszystkie pod-poziomówOznacza to, że zakres agregacji będzie zawierać elementy wszystkich poziomach w ramach wybranego elementu.

o Aktualizacja Sub-LevelsMożna to zrobić tylko wtedy, gdy wybrano także opcję Traverse wszystkie pod-poziomów, Oznacza to, że podczas agregacji właściwości z dołu do góry, w wyniku kruszywo na każdym poziomie również być aktualizowana w każdym z odpowiednich elementów.

o Tylko bezpośrednie PodpoziomOznacza to, że tylko właściwości elementów bezpośrednio poniżej wybranego elementu będą sumowane.

o Wybierz Zawierać Standard Właściwościjeśli chcesz właściwości określonych w Standardy które należy uwzględnić. W przeciwnym razie zostaną wykorzystane tylko właściwości charakterystyczne dla każdej instancji składnika.

4. Wybierz właściwości, które chcesz zsumować. Są one pogrupowane w ich Rodzaje.

5. Kliknij Dalej przycisk.

6. Wybierz opcję, czy Zastąp wartości lub Dodaj wartościna wybranym elemencie.

o Zastąp wartościzapisze wyniki bezpośrednio na właściwości wybranego elementu.

o Dodaj wartościdoda wyniki do istniejących właściwości wybranego elementu.

Zobacz też

Dodawanie właściwości gotowych do komponentowego, połączenia lub rodzaju | Zmiana właściwości komponentów, połączenia lub rodzaju | Oceniając swoją architekturę


Analizując swoją architekturę

Nawigacja: Analizując swoją architekturę>

Analizując swoją architekturę

Wyślij komentarzy w tym temacie.

Po zaludnionych (i opcjonalnie symulowane) swoją architekturę, jesteś gotowy do użycia Abacus, aby go przeanalizować. Poprzez analizę, możesz określić, czy architektura swoich potrzeb.

Można analizować swoją architekturę w różny sposób:

· Diagram

· 3D widok

· standardowe wykresy (pie, wiersz, kolumna, bar, itd.)

· Wykresy niestandardowe ( czas odpowiedzi , Przestrzeń możliwości , gwiazda Działka , Macierz rozproszenia i Wykres bąbelkowy )

· Architektura Diff

Notatka

Podczas tworzenia wykresu, 3D widok, Raport lub standardowej tabeli, Okno wyboru standardowym elementem służy do wyboru elementów, które chcesz zobaczyć.

Zobacz też

Wypełnianie swoją architekturę | Symulacja swoją architekturę | Diagramów Narzędzie


Standardowe Wybór Element

Nawigacja: Analizując swoją architekturę>

Standardowe Wybór Element

Wyślij komentarzy w tym temacie.

Podczas tworzenia wykresu, 3D widok, raport,standardowy wykreslub uruchomieniu symulacji, Średnia okno wyboru elementu służy do wyboru elementów, które chcesz analizować / widoku.

Okno standardowe Wybór Element

Pulldowns

· Sortuj według View będzie zawierać elements od wcześniej zapisanego widoku (czyli diagram, wykres, 3D). W ten sposób można wykonywać złożone "dołączyć" zapytań traktując inny widok jako zapisanego "zapytania".

Pola wyboru

· Pokaż PoziomyGrupa wola element w zależności od poziomu, w którym one powstały w drzewie. Poziom 1 jest się na najwyższym poziomie.

· Pokaż RodzajeGrupa wola elementy w zależności od rodzaju, że są.

· Rodzice wybranebędzie zawierać elementy nadrzędne wszelkich wybranych elementów. W ten sposób można zapewnić, że tylko w hierarchii wyżej jakichkolwiek dzieci będą wliczone do wyboru "bottom-up".

· Dzieci wybranebędzie zawierać dzieciom elementy dowolnych wybranych elementów. W ten sposób można zapewnić, że tylko hierarchia poniżej wszelkich rodziców zostaną włączone do "top-down" selekcji.

· Nazwa zestawienia wartościbędzie zawierać tylko te elementy, które mają nazwę, która zawiera określony ciąg (Uwaga: Symbole wieloznaczne (np oraz *) mogą być używane?). W ten sposób można utworzyć "semantyczną" zapytania.

· Ma właściwości Typ / Nazwa / Wartośćbędzie zawierać tylko te elementy, które mają Typ własności, nazwę i wartość zawierającą określony ciąg bezpośrednio na elemencie lub na jego Standardów (Uwaga:?.? Znaków (tzn oraz *) mogą być stosowane np * w polu Wartość będzie podać wszystkie elementy, które mają niepuste wartości dla danej nieruchomości). W ten sposób można utworzyć "semantyczną" zapytania.

· Posiada standardowebędzie zawierać tylko te elementy, które mają standardową nazwę zawierającą określony ciąg (Uwaga: Symbole wieloznaczne (np oraz *) mogą być wykorzystywane Np HP * da wszystkie elementy, z co najmniej jednym Standardowy rozpoczynające się od liter H i P.?.). W ten sposób można utworzyć "semantyczną" zapytania.

· Komponenty / Połączenia dołączone do wybranobędzie zawierać wszystkie podłączone elementów do tych, które zostały wybrane. W ten sposób można wybrać "call-drzewa" lub "analiza uderzenia".

Notatka

Jeśli masz zarówno Pokaż Poziomy i Pokaż Rodzajewybrany, to możesz zdecydować się na poziom drzewa przedstawiają pierwszy lub typy najpierw przycisk, który pojawi się powyżej dwóch pól wyboru.

napiwek

Gdy element jest zaznaczony w oknie Wybór standardowy element, nie będzie przedmiotem dalszych zmian filtrów dopóki nie zostanie wyłączony. Ponieważ nie ma natywną sposób wyszukiwania dla dwóch różnych zestawów elementów na raz (np Składniki wraz Standard A lub Standard B), można wyszukiwać pierwszy dla jednego zestawu, wybierz żądane elementy, a następnie przeprowadzić drugą poszukiwania drugiego seta ,

Pikolak

· wszystkowybiera wszystkie elementy.

· Odwracaćodznacza wszystkie zaznaczone elementy i wybiera wszystkie te, które nie zostały wybrane.

· Żadenusunięcie zaznaczenia wszystkich elementów.

· Dodaj filtrwybiera wynikowy treści aktualnych ustawień filtra i pozwala na wybór dodatkowych treści, jak skutecznie AND lub dołączyć filtr.

Zobacz też

Analizując swoją architekturę


Przedstawiamy schemat 3D

Nawigacja: Analizując swoją architekturę> wykresy 3D>

Przedstawiamy schemat 3D

Wyślij komentarzy w tym temacie.

ABACUS pozwala przeglądać swoją architekturę w widoku 3D, gdzie właściwości elementów i połączeń są związane z kolorów, kształtów i rozmiarów.

Aby wyświetlić widok 3D architektury

1. Sprawdź, czy masz otworzyć plik ABACUSzawierające swojej zaludnionych architektury.

2. Rozwiń Widokigałąź drzewa.

3. Rozwiń 3Dgałąź drzewa.

4. Podwójne kliknięcie wizualizacja chcesz otworzyć.

- lub -

1. Sprawdź, czy masz otworzyć plik ABACUSzawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| 3Dlub kliknij przycisk na pasku narzędzi.

3. Otwieranie istniejącywizualizacja (.abacus3d)

- lub -

1. Sprawdź, czy masz otworzyć plik ABACUSzawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| 3Dlub kliknij przycisk na pasku narzędzi.

3. Utwórz nową wizualizację:

· Wybierz Architekturachcesz, aby z menu rozwijanego.

· Wybierz podzespoły i Znajomościchcesz umieścić na wykresie od Okno wyboru standardowym elementem .

· Kolory kojarzą, kształtów i wielkości Składowe Rodzaje i Właściwości.

· Kojarzenie kolorów i kształtów z Rodzaje połączeń i Właściwości.

Aby wyeksportować widok 3D

1. Sprawdź, czy masz otworzyć istniejący widok 3D.

2. W rozwijanych menu w widoku 3D wybierz File | Eksport...i wybrał lokalizację i typ pliku dla pliku wizualizacji (.abacus3d, .vrml lub .html).

3. Trzask Ratować.

Zobacz też

Analizując swoją architekturę | Nawigacja w 3D | Diagramming Narzędzie


Nawigacja w 3d schemat

Nawigacja: Analizując swoją architekturę> wykresy 3D>

Nawigacja w 3d schemat

Wyślij komentarzy w tym temacie.

ABACUS pozwala na łatwe poruszanie się po architekturze w 3D. Doświadczenie jest podobna do latania. Istnieją dwa tryby nawigacji:

· Podstawowy tryb sterowania (domyślnie); i

· Zaawansowany tryb sterowania - zmiana w tym trybie, wybierając Kontrola| Zaawansowany tryb sterowania.

Notatka

Aby przełączać się między Kontroli podstawowe i zaawansowane tryby sterowania, można użyć F4Funkcja skrótu klawiaturowego.

Podstawowy tryb sterowania

· Trzymając lewy przycisk myszy i przesuwając do przodu lub do tyłu zmienia wysokość;

· Trzymając lewy przycisk myszy i przesuwając w lewo lub prawo zmienia yaw;

· Trzymając prawy przycisk i przesuwając mysz patelni widok;

· Trzymając oba przyciski w dół i przesunięcie myszy do przodu lub do tyłu, powiększa i obecnie architektury; i

· Trzymając oba przyciski w dół i przesuwając mysz w lewo lub prawo, rzuca na lewo i prawo.

- lub -

· Naciśnięcie Lewa strzałkana klawiaturze lub klawiaturze numerycznej skręcamy w lewo;

· Naciśnięcie Prawa strzałkana klawiaturze lub klawiatury numerycznej będzie skręcić w prawo;

· Naciśnięcie Strzałka w góręna klawiaturze lub klawiaturze numerycznej powiększyć;

· Naciśnięcie Strzałka w dółna klawiaturze lub klawiatury numerycznej spowoduje oddalenie;

· Pilny Strona do góryna klawiaturze lub klawiatury numerycznej będzie rozbić się; i

· Pilny Strona w dółna klawiaturze lub klawiaturze numerycznej skoku w dół.

Zaawansowany tryb sterowania

· W ruchumysz do przodu i do tyłu, w górę iw dół, zmienia kąt nachylenia (odpowiednio);

· Pilny W lub Strzałka w górępowiększa (do przodu) do architektury;

· Pilny S lub Strzałka w dółoddala (tył) z architektury;

· Pilny A lub Lewa strzałkarolki w lewo;

· Pilny D lub Prawa strzałkarzuca się w prawo;

· Pilny Q lub Strona w dółpodnosi widok (poprzez obniżenie perspektywy); i

· Pilny E lub Strona do góryobniża widok (przez podwyższenie perspektywy).

Tryb sterowania Interactive

Naciśnięcie i przytrzymanie klawisz Shiftna klawiaturze zastępuje bieżący tryb (podstawowym lub rozszerzonym), aby wejść do trybu sterowania interaktywną. W tym trybie możliwe jest następujące:

· Bułkakursor myszy nad częścią lub związku, aby zobaczyć element lub nazwę połączenia do;

· Trzaskna komponencie, aby powiększyć tego składnika;

· Kliknij i przeciągnijw składniku obrócić, wokół tego składnika; i

· Kliknij prawym przyciskiem myszykomponent lub połączenie i wybierz Pokazać w przeglądarceaby zobaczyć, że komponent lub lokalizację połączenia w drzewie.

Wspólne kontrole

· Posługiwać się ALT-ENTER / ESC, aby włączyć tryb pełnoekranowy;

· Posługiwać się F2zmienić tryb wyświetlania. To może być także dostępny w Widok Menu.

· Użyj kółko w myszce lub +/-aby zmienić prędkość. Prędkość jest oznaczony numerem w lewym dolnym rogu - pokazano tylko wtedy, gdy to się zmienia. 1 jest najwolniejszy i 100 jest najszybciej.


Przedstawiamy standardowy wykres

Nawigacja: Analizując swoją architekturę> standardowe wykresy>

Przedstawiamy standardowy wykres

Wyślij komentarzy w tym temacie.

Standardowe wykresy Abacus "to wiersz, bar, kolumny, obszar, rozrzut, ciasto, krzywa, Pareto, krok, powierzchnię, radar, kostka, pączka, piramidy, kontur i wykresy w obszarze krzywej. Po wybraniu typu wykresu, który chcesz, reszta procesu przeglądania każdej z tych wykresów jest to samo.

Aby wyświetlić standardowy wykres architektury

1. Sprawdź, czy masz otworzyć plik ABACUSzawierające swojej zaludnionych architektury, I że masz ocenianeTwoja architektura.

2. Wybierz Wstawić| Wykreslub kliknij przycisk na pasku narzędzi. Wykresypojawi się okno.

Okno Wykresy

3. Wybierz typ wykresu, który chcesz i ustawić Opcje wykresu, a następnie kliknij przycisk Dalej.

Opcje wykresu

o Ułożonepokaże relacje poszczególnych elementów do całości. Możesz użyć wykresie skumulowanym, gdy planujesz mieć wiele serii danych (czyli wiele właściwości) i gdy chcesz podkreślić sumie.

o Ułożone w 100%będzie porównanie odsetka każda wartość wpisuje się w sumie w całej kategorii. Możesz użyć 100% skumulowany wykres, gdy masz zamiar mieć wiele serii danych (tj wiele właściwości) i chcesz podkreślić wkład w całości, szczególnie jeśli suma jest taka sama dla każdego elementu.

o Wykres 3Dpo prostu wyświetlić punkty danych w formacie 3-D dla estetyki. Jeśli chcesz, aby wyświetlić serię danych wzdłuż wymiaru 3rd / oś Z następnie wybierz opcję Cluster Series opisaną poniżej.

o Seria o własnościwyświetli serię danych dla każdej nieruchomości, która zostanie ostatecznie wybrany. Jeśli to nie jest zaznaczone, a następnie właściwości będzie kategorie i serie danych będzie dla każdego elementu, który jest wybierany.

o Obróć Wykresbędzie się obracać wykres 90 stopni w prawo przez zamianę na osiach X i Y. Ta opcja jest dostępna tylko dla linii, STEP i Cube wykresówi jest szczególnie przydatna do tworzenia wykresów Milestone, jak opisano w drugiej końcówki pod, Uwaga: Kolumna i Wykresy słupkowe są już "obracać" wersje siebie.

o Seria Klasterbędzie wyświetlać dane z wielu serii wzdłuż wymiaru 3rd / osi z. Ta opcja jest dostępna tylko dla kolumny, bar i Cube wykresyi jest on szczególnie przydatny do wytwarzania Gantta wykresy stylu, jak opisano w pierwszym Tip poniższej.

napiwek

Możesz utworzyć Wykres Ganttaz prętów poziomych wykazujących właściwości data / czas dla różnych elementów, wybierając typ wykresu bar, a następnie wybierając opcję Cluster Series,Ponadto, gdy stworzył, pierwsza z lewej pasek na wykresie może być "niewidoczne" kolorując go białe klikając prawym przyciskiem myszy jeden z barów, wybierając Kolor z menu, które się pojawi i wybierając lewy górny kolor z palety. Dodatkowo granica dla skrajnej lewej baru mogą być wykonane "niewidoczne" klikając prawym przyciskiem myszy jeden z barów, wybierając Właściwości ... i na karcie Series w wyświetlonym oknie dialogowym zmieniając efekt granicy na None i Kolor na górę -left kolor z palety.

napiwek

Możesz utworzyć Wykres Milestonez małych kształty pokazując czasu / daty dla różnych właściwości elementów wybierając typ wykresu Cube, a następnie wybierając opcje obracania i Chart Klaster Series,Ponadto, gdy stworzył, kostki można zmienić na inne kształty, klikając prawym przyciskiem myszy jeden z modułów w danej serii danych i wybierając Właściwości ... i na karcie Series w wyświetlonym oknie dialogowym zmieniającym paska albo cylindra lub Cone , Uwaga: wartość szerokości przerw może być również stosowany do "kurczą 'symboli na wykresie w celu zmniejszenia nakładania się, im większa liczba, tym mniejsza będzie nakładanie.

4. W ArchitekturSekcja, zaznacz architekturę / s chcesz wytyczyć właściwości poziomu architektura, a następnie kliknij przycisk Dalej.

Notatka

Wybór właściwości poziom architektury jest całkowicie opcjonalny krok i powinny być stosowane tylko wtedy, gdy chcesz, aby jednoznacznie wytyczyć samych właściwości poziomie architektury.Architektura nie musi być wybrany, aby potem to właściwości komponentów lub połączenia w następnym kroku.

5. Wybierz podzespoły i Znajomościże chcesz w tabeli z Okno wyboru standardowym elementem , A następnie kliknij przycisk Dalej.

6. Wybierz Właściwościchcesz w tabeli i kliknij koniec.

Opcje wykresu

o Dołącz właściwości Standardowe będzie pokazać odziedziczone właściwości od norm dostępnych do wyboru.

o Właściwości kruszywa będzie policzyć odchylenie między wartościami serii i wykres tych wyników, w przeciwieństwie do poszczególnych wartości się.Ta opcja jest dostępna tylko wtedy, gdy opcja Property Series by został wybrany w punkcie 3 powyżej.

napiwek

Właściwości dostępne dla wykresów zależy od wybranych elementów.

Aby zapisać wykres

Notatka

Wykresy mogą być zapisywane tylko wtedy, gdy zawiera tylko elementy i połączenia, z których wszystkie muszą być z jednej architektury w bieżącym projekcie.

1. Upewnij się, że masz nowy lub istniejący wykres Otwartei dokonaniu niezbędnych zmian.

2. W pasku narzędzi wykresu kliknij na skrajnej lewej Zapisz Wykresprzycisk, aby zapisać tabelę i zmiany formatowania.

3. W Wykres Nazwadialogowe, które pojawia się wprowadzić nazwę tabeli i naciśnij ok.

Aby wyeksportować wykres

1. Sprawdź, czy istniejący wykres Otwarte.

2. Na pasku narzędzi kliknij na wykres 2 od lewej Zapisz jako BMPprzycisk i wybrać lokalizację na mapie.

3. Trzask Ratować.

Zobacz też

Analizując swoją architekturę | Przedstawiamy wykres czasu reakcji | Przedstawiamy wykres kosmicznej możliwości


Przedstawiamy wykres kosmicznej możliwości

Nawigacja: Analizując swoją architekturę> wykresy niestandardowe>

Przedstawiamy wykres kosmicznej możliwości

Wyślij komentarzy w tym temacie.

Wykres Możliwość Przestrzeń pozwala przeglądać czy architektura spełnia wymaganą zdolność systemu w odniesieniu do właściwości określonych w trakcie procesu analizy wymagań systemu.

Aby zobaczyć wykres zdolność przestrzeni

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury, I że masz ocenianeTwoja architektura.

2. Wybierz Wstawić| Wykres| Wykresy niestandardowe| Możliwość Kosmos, (THE Wykres możliwości przestrzeni konfiguracyjnejdialogowe wyświetli.)

3. W Architektursekcji, zaznacz architektur, które chcesz wykresu, a następnie kliknij przycisk Dalej.

4. W WłaściwościObszar, zaznacz właściwości architektonicznych, co chcielibyście zawarte w osi wykresu.

5. W ZdolnośćObszar, dla każdej nieruchomości zawartej z poprzedniego etapu, wybrać, czy jakakolwiek minimalna lub maksymalna ogranicza możliwość istnieje, a wartości tych limitów. Wartości domyślne są minimalne i maksymalne wartości ocenianych dla architektur i tym Celem dla nieruchomości Jeśli jest on ustawiony.

Aby wyeksportować zdolność wykres kosmicznej

1. Sprawdź, czy istniejący Możliwość wykres miejsca Otwarte.

2. W pasku narzędzi wykresu kliknij na skrajnej lewej Zapisz jako BMPprzycisk i wybrać lokalizację na mapie.

3. Trzask Ratować.

Zobacz też

Analizując swoją architekturę | Przedstawiamy wykres czasu reakcji


Przedstawiamy wykres czasu reakcji

Nawigacja: Analizując swoją architekturę> wykresy niestandardowe>

Przedstawiamy wykres czasu reakcji

Wyślij komentarzy w tym temacie.

Wykres czas reakcji pozwala na przeglądanie, czy połączenia są przetwarzane w wymaganej stopy (czyli w ich terminie).

Aby zobaczyć wykres czasu reakcji

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury, I że masz ocenianeTwoja architektura.

2. Wybierz Wstawić| Wykres| Wykresy niestandardowe| Czas odpowiedzi, (THE Czas reakcji Wykres Configdialogowe wyświetli.)

3. Z Architekturlisty rozwijanej wybierz architekturę, którą chcesz do wykresu.

4. W ZnajomościObszar, zaznacz połączenia, co chcielibyście zawarte w tabeli.

5. Skala TypObszar, wybierz Liniowyjeśli chcesz osi pionowej (czas reakcji), który ma być wyświetlany jako liniowej progresji - każdy segment czasu przeznaczono równy udział osi. Wybierz Logarytmicznajeśli chcesz wyświetlić ją jako logarytmicznej progresji - każdy segment osi reprezentuje coraz dłuższe okresy czasu wyżej osi udać. (Tempo wzrostu jest określana przez Opierać ty wybierz.)

Odpowiedź wykres skali osi pionowej w czasie

Aby wyeksportować wykres czasu reakcji

1. Sprawdź, czy istniejący Odpowiedź wykres czasu Otwarte.

2. W pasku narzędzi wykresu kliknij na skrajnej lewej Zapisz jako BMPprzycisk i wybrać lokalizację na mapie.

3. Trzask Ratować.

Zobacz też

Analizując swoją architekturę | Przedstawiamy wykres kosmicznej możliwości


Przedstawiamy gwiazda fabułę swojego ewoluowały architektur

Nawigacja: Analizując swoją architekturę> wykresy niestandardowe>

Przedstawiamy gwiazda fabułę swojego ewoluowały architektur

Wyślij komentarzy w tym temacie.

Po architektura została ewoluował i cele są zdefiniowane, to może być następnie wizualizowane i w porównaniu z oryginalną architekturą przy użyciu działek gwiazdkowe. Ta sekcja opisuje, jak tworzyć i manipulować działkę gwiazdek.

Aby wyświetlić wykres swoimi gwiazda ewoluowały architektur

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Sprawdź, czy masz ewoluowały i wyznaczone celedla architektury jak w punkcie Się rozwija swoją architekturę

3. Wybierz Wstawić| Wykres| Wykresy niestandardoweZakładka | Działka Gwiazda.

4. Kliknij na koniec przycisk.

5. Działka Gwiazdaz ewoluowały architektury i ustawione zostaną wyświetlone cele. Uwaga: Osie działki gwiazda może być przeniesiony, klikając i przeciągając osi do innego obszaru w granicach przestrzeni gwiazda jakości wydruku.

Notatka

Obszar po lewej stronie działki gwiazda pokazuje ustawienia fabuły gwiazdkowy wyświetlany. Obejmuje architekturę, która w wyniku ewolucji (w tym przypadku "ABC Ltd jak jest 2010") Oraz cele, które zostały ustalone dla takiej struktury. Można zauważyć, że cele, które mają znacznik wyboru obok nich są reprezentowane osi fabuły gwiazdy (np KPI- Koszt, KPI - Jakość i KPI - Czas). Możesz odznacz te cele w dowolnym momencie, aby usunąć je z terenu gwiazdkowy.

Czerwone i zielone "kropki", które pojawiają się na gwiazdkowy działki stanowią wartość znormalizowaną, jak określono w najlepszych i najgorszych wartości (przedstawione na mocy Wyznaczanie celów dla swojej ewoluował architektury ) Dla wybranej architektury na najwyższym poziomie oraz wszelkie ewolucji nim. Wartości te są reprezentowane w sposób Przestrzeń jakości.

Jak przedstawiono na powyższym zdjęciu, to jest wyraźnie widoczne, że oryginalna architektura (Jak jest 2010) Ma słabe Koszt, Podczas gdy pierwszy rozwinął opcja (To-Be 2011 - Strategia) Przeniósł się w przestrzeni w celu poprawy jakości Koszt, Jakość i Czascele. Alternatywnie, drugi rozwinęła opcji (To-Be 2011 - Strategia B), podczas gdy był to również poprawić Koszt wielkość poprawy jest mniejsza niż Strategia A ale oba cele jakościowe i czasowe zostały ulepszone więcej niż w Strategii A.W tym przypadku architekta maj wybierać Strategią koniec Strategia Bjak ich zaleceniai dalej rozwijać tę opcję (To-Be 2012 - Strategia A).

6. Usuń zaznaczenie Pokaż Ewolucjepole wyboru, aby ukryć linię (y) przedstawiający ewolucję (s) pomiędzy oryginał (np Jak jest 2010) I ewoluowała (np To-Be 2011 - StrategiaA) architektura (s).

7. Wybierz Pokaż Stickspole wyboru, aby wyświetlić względną wielkość każdego atrybutu jakości (celów, które zostały określone na każdej osi) dla każdej architektury.

8. Wybierz Pokaż Architektura Nazwypole wyboru, jeśli chcesz, aby nazwy oryginalnej architektury i wydzielonego (-ych) do stawienia się na działce gwiazdkowy.

Zobacz też

Analizując swoją architekturę | Przedstawiamy wykres czasu reakcji | Przedstawiamy matrycę Scatterplot swojego ewoluowały architektur | Się rozwija swoją architekturę


Przedstawiamy wykres punktowy swoimi ewoluowały architektur

Nawigacja: Analizując swoją architekturę> wykresy niestandardowe>

Przedstawiamy wykres punktowy swoimi ewoluowały architektur

Wyślij komentarzy w tym temacie.

Raz architektura jest ewolucji i cele są zdefiniowane, może być następnie wizualizowane i porównano z pierwotnym architekturą używając matryc wykres rozrzutu. Ta sekcja opisuje sposób tworzenia i zrozumieć właściwości matrycy Scatterplot.

Aby wyświetlić Matrix Scatterplot swojego ewoluowały architektur

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Sprawdź, czy masz ewoluowały i wyznaczone celedla architektury jak w punkcie Się rozwija swoją architekturę

3. Wybierz Wstawić| Wykres| Wykresy niestandardoweZakładka | Scatterplot Matrix.

4. Kliknij na koniec przycisk.

5. Wykres punktowybędzie wyświetlany z określonym ewolucji architektury i celów.

Notatka

Obszar z lewej strony macierzy wykres rozrzutu przedstawiono ustawienia macierzy Scatterplot wyświetlane. Obejmuje architekturę, która w wyniku ewolucji (w tym przypadku "ABC Ltd jak jest 2010") Oraz cele, które zostały ustalone dla takiej struktury. Można zauważyć, że cele, które mają znacznik wyboru obok nich są reprezentowane w osiach X i Y macierzy Scatterplot (np KPI- Koszt, KPI - Jakość i KPI - Czas). Możesz odznacz te cele w dowolnym momencie, aby usunąć je z matrycy Scatterplot.

Niebieskie kropki pojawiające się na swojej działce w macierzy stanowią wartość znormalizowaną, jak określono w najlepszych i najgorszych wartości (przedstawione na mocy Wyznaczanie celów dla swojej ewoluował architektury ). Wartości te są reprezentowane w sposób Przestrzeń jakości.

Dwa określone cele są porównywane ze sobą w matrycy na wykresie rozrzutu, a proces powtarza się, aż wszystkie cele zostały porównane (np Pierwszy wykres matrycy w powyższym schemacie porównuje KPI - kosztcel z KPI - Jakość cel. Drugi jest Koszt przeciw Czas i ostatni Działka Jakość przeciw Czas, Odpowiednie etykiety cel są pokazane na górze i w prawo lub w każdym rzędzie działek.).

6. Wybierz Architekturprzycisk opcji, jeśli chcesz wyświetlić metryki dla poszczególnych architektur.

7. Wybierz Ewolucjeprzycisk opcji, jeśli chcesz wyświetlić znormalizowane zmiany z oryginalnej architektury (np Jak jest 2010) Do rozwijana architektura (ów) (na przykład To-Be 2011 - Strategia A i To-Be 2011 - Strategia B).

Zobacz też

Analizując swoją architekturę | Przedstawiamy wykres czasu reakcji | Przedstawiamy gwiazda fabułę swojego ewoluowały architektur | Się rozwija swoją architekturę


Przedstawiamy wykres bąbelkowy

Nawigacja: Analizując swoją architekturę> wykresy niestandardowe>

Przedstawiamy wykres bąbelkowy

Wyślij komentarzy w tym temacie.

Wykres bąbelkowy pozwala porównać do 5 wymiarów (czyli X, Y, wielkość pęcherzyków / promieniu, bańka bańka kolor i kolor obramowania) w jednym widoku.

Aby zobaczyć wykres bąbelkowy

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Wybierz Wstawić| Wykres| Wykresy niestandardoweZakładka | Wykres bąbelkowy.

3. W Architektursekcji, zaznacz architektur (jeśli w ogóle) chcesz do wykresu, a następnie kliknij przycisk Dalej.

4. Wybierz podzespoły i Znajomościktóry ma w wykresie (jeśli istnieją) z Okno wyboru standardowym elementem , A następnie kliknij przycisk Dalej.

5. Wybierz X OśObiekt, a następnie kliknij przycisk Dalej.

Notatka

Tylko Integer, dziesiętny, data / czas, logiczna i właściwości Lista mogą być stosowane do osi x. Ponadto, Integer, dziesiętne i Data / Czas Właściwości są rysowane od lewej do prawej wzdłuż osi skalowane w zależności od wartości nieruchomości, jednak logiczne i Lista właściwości są po prostu wykreślone od lewej do prawej w dokładnej kolejności (lub w w odwrotnej kolejności, jeśli opcja, aby odwrócić kolejność jest zaznaczone) zdefiniowane dla nieruchomości, niezależnie od ich wartości. Na przykład. Niski | Średni | Wysokie lub 1, 2, 4, 8, 16.

6. Wybierz Y OśObiekt, a następnie kliknij przycisk Dalej.

Notatka

Tylko Integer, dziesiętny, data / czas, logiczna i właściwości Lista mogą być stosowane do osi y. Ponadto, Integer, dziesiętne i Data / Czas właściwości są wykreślane z dołu do góry wzdłuż osi skalowane w zależności od wartości nieruchomości, jednak logiczne i Lista właściwości są po prostu wykreślone z dołu do góry, w takiej kolejności (lub w w odwrotnej kolejności, jeśli opcja, aby odwrócić kolejność jest zaznaczone) zdefiniowane dla nieruchomości, niezależnie od ich wartości. Na przykład. Niski | Średni | Wysokie lub 1, 2, 4, 8, 16.

7. Wybierz wielkość pęcherzyków / PromieńObiekt, a następnie kliknij przycisk Dalej.

Notatka

Tylko Integer, dziesiętny, logiczna i właściwości Lista mogą być stosowane do bańki wielkości / promień. Ponadto, Integer i właściwości dziesiętne spowodować wielkość pęcherzyków / promieniu skalowane w zależności od wartości nieruchomości, jednak logiczne i Lista właściwości powodują równych wzrostem kroku bańki Rodzaj / promieniu w takiej kolejności (lub w odwrotnej kolejności, jeśli opcja, aby odwrócić kolejność jest zaznaczone) zdefiniowane dla nieruchomości, niezależnie od ich wartości. Na przykład. Niski | Średni | Wysokie lub 1, 2, 4, 8, 16.

8. Wybierz albo stała bańka kolor lub skojarzyć właściwość z kolorem bubble, A następnie kliknij przycisk Dalej.

Notatka

Tylko Integer, dziesiętny, logiczna i właściwości Lista mogą być używane jako kolor pęcherzy. Ponadto, Integer i właściwości dziesiętne spowodować koloru bańki w wybranym zakresie skalowane w zależności od wartości nieruchomości, jednak logiczne i Lista właściwości powodują równych wzrostem etapie koloru bańki w wybranym zakresie w dokładnie takiej kolejności, określonych dla nieruchomości, niezależnie od ich wartości. Na przykład. Niski | Średni | Wysokie lub 1, 2, 4, 8, 16.

9. Wybierz opcję brak koloru bańki granicy lub skojarzyć właściwość z kolorem bańka granicznego, A następnie kliknij przycisk koniec.

Notatka

Tylko Integer, dziesiętny, logiczna i właściwości Lista mogą być używane jako kolor bubble granicznej. Ponadto, Integer i właściwości dziesiętne w kolorze bańka granicznego w wybranym zakresie skalowane w zależności od wartości nieruchomości, jednak logiczne i Lista właściwości powodują równych wzrostem etapie koloru bańki granicznego w wybranym zakresie w dokładnie takiej kolejności, określonych dla nieruchomości, niezależnie od ich wartości. Na przykład. Niski | Średni | Wysokie lub 1, 2, 4, 8, 16.

Wykres bąbelkowy

Aby zapisać wykres bąbelkowy

Notatka

Bubble wykresy mogą być zapisywane tylko wtedy, gdy zawiera tylko elementy i połączenia, z których wszystkie muszą być z jednej architektury w bieżącym projekcie.

1. Upewnij się, że masz nowy lub istniejący wykres bąbelkowy Otwartei dokonaniu niezbędnych zmian.

2. W pasku narzędzi wykresu kliknij na skrajnej lewej Zapisz Wykresprzycisk, aby zapisać tabelę i zmiany formatowania.

3. W Wykres Nazwadialogowe, które pojawia się wprowadzić nazwę wykresu bąbelkowego i naciśnij ok.

Aby wyeksportować wykres bąbelkowy

1. Sprawdź, czy masz otworzyć istniejący wykres bąbelkowy.

2. Na pasku narzędzi kliknij na wykres 2 od lewej Zapisz jako BMPprzycisk i wybrać lokalizację na mapie.

3. Trzask Ratować.

Zobacz też

Analizując swoją architekturę


Architektura Diff i Sync

Nawigacja: Analizując swoją architekturę>

Architektura Diff i Sync

Wyślij komentarzy w tym temacie.

Kiedy masz 2 lub więcej architektury, zarówno podstawowych, jak i ewolucji architektury, można wizualnie 'diff' dwie architektury za pomocą Katalog lub wykres Porównanie lub Architektura Diff funkcja. Jest to szczególnie przydatne do wykrywania / ponowne odkrywanie dokładnych zmian z jednej architektury na inną, jak rozwijać architekturę i opracowywać plany w ABACUS.

Do pokazać 'diff' z innej architektury za pomocą diagramu

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Upewnij się, mają co najmniej 2 architektury w projekcie.

3. Otwórz schemat, który chcesz porównać z inną architekturą.

4. Kliknij przycisk "Porównaj ten diagram do zawartości innej architektury" na pasku narzędzi Wykres.

5. Wybierz inną architekturę z listy rozwijanej, aby porównać do.

6. Można filtrować jakie różnice są wyświetlane po kliknięciu przycisku "różnic" na pasku narzędzi Wykres i opcje odznaczenie, np Zmienione / dodane / nieznane i Nieokreślony / Sync Zalecane/ Przechowywać Zalecane.

Notatka

Komponenty i połączenia na schemacie będą podświetlone Rudy, zielony lub fioletowy gdy istnieją różnice w zawartości, który jest widoczny na wykresie obecnej, a zawartość w drugim architektury. Rudy jest używany do których zaleca się, aby zsynchronizować różnice (patrz poniżej), Zielony stosowany jest tam, gdzie nie jest zalecane, aby zsynchronizować różnic, to zachować ich (patrz poniżej) i Fioletowy ABACUS jest używany, gdy nie można wydać zalecenie o synchronizacji różnice (patrz poniżej). Treść tylko widoczne na wykresie porównywany jest więc jeśli adnotacja pokazuje wartość właściwości repozytorium i że zmienia się wartość danego składnika lub połączenie zostanie pokazany w słaby czerwony, słaby zielony lub słaby fioletowy i "*" symbol pokazany w lewym górnym rogu do komponentów, jednak jeśli jakaś inna podstawowa wartość nieruchomości repozytorium zmieniła, który nie jest pokazany na dopiskiem to nie wskazuje, będzie dany. Treści, które pojawia się na bieżącym wykresie, ale nie znaleziono w architekturze porównania zostaną pokazane w mocne czerwone, mocne zielone lub silne fioletowyi "+" Symbol przedstawiony w lewym górnym komponentów. Dopasowanie odbywa się nazwy typu części i tak, że jeżeli rodzaj lub nazwa składnika lub związku zmieniło się w drugiej architektury nie pasuje będzie można znaleźć. Ponieważ nie ma możliwości niezawodnego ustalania, czy dodatkowe materiały z drugiej architektury to wykazano od aktualnego schematu (np dodatkowy interfejs między 2 składników, jak pokazano poniżej na schemacie z architekturą porównania z prawej strony), różnice te nie są przedstawione na schematach (są pokazane w katalogach według niżej). Unoszące się nad każdą zmianą pozycji pokaże różnicę w dymku. Unoszące się nad symbolem '*' w lewym górnym rogu wykresu zawiera podsumowanie zmian (lub bez zmian) między zawartością diagramu oraz zawartości innych architektury.

Kolor Legenda

· Zielony wskazuje, przedmioty, które nie jest zalecane, aby zsynchronizować różnice, to ich utrzymanie.

· Rudy wskazuje, elementy, które zaleca się zsynchronizować różnice.

· Fioletowy wskazuje, przedmiotów, gdzie ABACUS nie może wydać zalecenie o synchronizowaniu różnice.

Do synchronizacji ('') do synchronizacji zawartości z jednej architektury ze sobą za pomocą diagramu

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Upewnij się, mają co najmniej 2 architektury w projekcie.

3. Otwórz schemat chcesz porównać do innej architektury.

4. Kliknij przycisk "Porównaj tego katalogu do zawartości innej architektury" na pasku narzędzi Wykres.

5. Wybierz inną architekturę z listy rozwijanej, aby porównać do.

Notatka

Patrz wyżej na drodze ABACUS pokazuje 'diff' między 2 architektur w katalogu. W szczególności, w jaki Rudy jest używany, gdy go jestZaleca się, aby zsynchronizować różnice, Zielony są stosowane tam, gdzie jest to nieZaleca się, aby zsynchronizować różnice i Fioletowy ABACUS jest używany, gdy nie można wydać zalecenie o synchronizowaniu różnice.

6. Kliknij prawym przyciskiem myszy element diagramu (lub elementów za pomocą Shift lub płótna wykres, aby synchronizować wszystkie) pokazując 'diff' i wybrać opcję menu Sync.

Notatka

Wszelkie zmiany synchronizacji zostaną zastosowane tylko do architektury, że obecnie w centrum uwagi Katalog należy. Aby zastosować zmiany do innej architektury należy używać katalog w drugim architektury. Ponadto, użytkownicy będą w stanie zastosować zmiany synchronizacji, jeśli mają na to zgody .

Notatka

W zależności od miejsca kliknij prawym przyciskiem myszy menu wyświetla wskazówki na temat tego, co dokładnie ma być zsynchronizowane. Na przykład. Kliknięcie prawym przyciskiem myszy jeden element na rysunku będzie synchronizować tylko tego składnika. Natomiast kliknięcie prawym przyciskiem myszy i wybierając płótno schemat synchronizacji Wszystko będzie synchronizować wszystkie aktualnie widoczne różnice te.

Do pokazać 'diff' z inną architekturą poprzez katalogu

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Upewnij się, mają co najmniej 2 architektury w projekcie.

3. Otwórz katalog, który chcesz porównać z inną architekturą.

4. Kliknij przycisk "Porównaj tego katalogu do zawartości innej architektury" na pasku narzędzi katalog.

5. Wybierz inną architekturę z listy rozwijanej, aby porównać do.

6. Można filtrować jakie różnice są wyświetlane po kliknięciu przycisku "różnic" na pasku narzędzi Wykres i opcji odznaczania, np Zmienione / dodane / nieznane i Nieokreślony / Sync Zalecane/ Przechowywać Zalecane.

Notatka

Komórki w katalogu będą podświetlone Rudy, zielony lub fioletowy gdzie istnieją różnice między zawartością w bieżącym katalogu i treści w inny dopasowania architektury. Rudy jest używany do których zaleca się, aby zsynchronizować różnice (patrz poniżej), Zielony stosowany jest tam, gdzie nie jest zalecane, aby zsynchronizować różnic, to zachować ich (patrz poniżej) i Fioletowy ABACUS jest używany, gdy nie można wydać zalecenie o synchronizacji różnice (patrz poniżej). Tylko widocznych wierszy i kolumn w katalogu porównuje się więc, czy istnieje różnica w rzędzie poza aktualnie przedstawionych rzędach lub o wartości w kolumnie, który nie jest pokazany ma znaczenie wtedy być oznaczone bez różnicy. W przypadku gdy wartość pojedynczej komórki jest inna z komórką w architekturze pasującej porównania zostanie podświetlona granica komórek. Selektor nagłówków kolumn i wierszy będą również zacienione słaby fioletowyi wyświetlane z symbolem '*'. Te "*" symbole można kliknąć, aby przejść do następnej różnicy w kolumnie lub wierszu odpowiednio. Wiersze, które pojawia się w bieżącym katalogu, ale nie znaleziono w architekturze porównania będą wyświetlane z symbolem "+" w selektor wiersza po lewej stronie i granicy z całego rzędu zostaną podświetlone. Wiersze, które miały miejsce w stosunku do architektury w wersji katalogu (czyli z tych samych filtrów, itp), ale nie znaleziono w obecnej architektury zostaną pokazane z '-' symbolu w selektor wiersza po lewej stronie, na granicy cały wiersz zostanie podświetlony, a zawartość całe wiersze komórki pojawi się w słaby fioletowyi uderzył-through, np 8 rano do 6pm, Dopasowanie odbywa się nazwy typu części i tak, że jeżeli rodzaj lub nazwa składnika lub związku zmieniło się w drugiej architektury nie pasuje będzie można znaleźć. Unoszące się nad każdą zmianą pozycji pokaże różnicę w dymku. Unoszące się nad symbolem '*' w lewym górnym rogu wykresu zawiera podsumowanie zmian (lub bez zmian) między zawartością diagramu, a zawartość drugiej architektury.

Kolor Legenda

· Zielony wskazuje, przedmioty, które nie jest zalecane, aby zsynchronizować różnice, to ich utrzymanie.

· Rudy wskazuje, elementy, które zaleca się zsynchronizować różnice.

· Fioletowy wskazuje, przedmiotów, gdzie ABACUS nie może wydać zalecenie o synchronizowaniu różnice.

Do synchronizacji ('') do synchronizacji zawartości z jednej architektury z drugim za pośrednictwem katalogu

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Upewnij się, mają co najmniej 2 architektury w projekcie.

3. Otwórz katalog, który chcesz porównać z inną architekturą.

4. Kliknij przycisk "Porównaj tego katalogu do zawartości innej architektury" na pasku narzędzi katalog.

5. Wybierz inną architekturę z listy rozwijanej, aby porównać do.

Notatka

Patrz wyżej na drodze ABACUS pokazuje 'diff' między 2 architektur w katalogu. W szczególności, w jaki Rudy jest używany, gdy go jestZaleca się, aby zsynchronizować różnice, Zielony są stosowane tam, gdzie jest to nieZaleca się, aby zsynchronizować różnice i Fioletowy ABACUS jest używany, gdy nie można wydać zalecenie o synchronizowaniu różnice.

6. Kliknij prawym przyciskiem myszy komórki, kolumny lub wiersza pozycji (lub kilka pozycji za pomocą klawiszy Shift lub Ctrl + A na wszystko) pokazuje 'diff' i wybrać opcję menu Sync.

Notatka

Wszelkie zmiany synchronizacji zostaną zastosowane tylko do architektury, że obecnie w centrum uwagi Katalog należy. Aby zastosować zmiany do innej architektury należy używać katalog w drugim architektury. Ponadto, użytkownicy będą w stanie zastosować zmiany synchronizacji, jeśli mają na to zgody .

Notatka

W zależności od miejsca kliknij prawym przyciskiem myszy (czyli komórki, kolumny lub nagłówku) pozycja menu wyświetla wskazówki na temat tego, co dokładnie ma być zsynchronizowane. Na przykład. Kliknięcie prawym przyciskiem myszy jedną właściwość lub podłączone komórkę komponentu w katalogu będzie synchronizować tylko, że nieruchomość lub dołączony komponent. Natomiast kliknięcie prawym przyciskiem myszy wiersz nagłówka (lub za pomocą klawiszy Shift) nagłówki zsynchronizuje cały wiersz (lub wiersze). Kliknięcie prawym przyciskiem myszy nagłówek kolumny zsynchronizuje wszystkie różnice w tej kolumnie.

Jak wyświetlić 'diff'z 2 cały architektur

1. Sprawdź, czy jest Plik ABACUS otwarta .

2. Upewnij się, mają co najmniej 2 architektury w projekcie.

3. Wybierz Przybory| Architektura Diff ....

4. W wyświetlonym oknie dialogowym wybierz pierwszy / Z i drugi / Do architektur porównać.

5. Kliknij na ok przycisk.

Architektura Diff

Kolor Legenda

· Zielonywskazuje, że węzeł został dodany w drugim / architektury.

· Rudywskazuje, że węzeł został usunięty w drugim / architektury.

· Niebieskiwskazuje, że węzeł ma różne właściwości (np właściwości lub norm) w drugim / architektury.

· Żółtywskazuje, że węzeł ma różnic w swoich dzieci w drugim / Do architektury tak, węzeł powinien zostać rozszerzony.

Notatka

Możesz kliknąć prawym przyciskiem myszy i "Pokaż w Eksploratorze" na wszystkich węzłach, aby zobaczyć szczegóły i więcej informacji podana jest na różnicach w panelu Podsumowanie różnic, gdy wybrany węzeł.

Zobacz też

Analizując swoją architekturę | Przedstawiamy wykres czasu reakcji | Przedstawiamy matrycę Scatterplot swojego ewoluowały architektur | Się rozwija swoją architekturę


Symulacja swoją architekturę

Nawigacja: Symulacja swoją architekturę>

Symulacja swoją architekturę

Wyślij komentarzy w tym temacie.

Po zaludnionych i przeanalizował swoją architekturę, jesteś gotowy do użycia Abacus, aby ustalić, czy architektura swoich potrzeb ilościowych. Wymaga to symulacja, Aby symulować architekturę należy najpierw podjąć decyzję w sprawie rodzaju informacji, które chcesz zwiedzić. Tego typu informacje są często określane jako KPI lub kluczowych wskaźników wydajności. Na przykład, chcesz do analizy wydajności, evolvability i otwartość, czy chcesz, aby zebrać wskaźników, takich jak całkowity koszt posiadania. Wszystkie te informacje mogą być ujawnione w jakiś sposób. Gdy masz te dane, będzie w stanie analizować swoją architekturę w różnych formatach graficznych (lub przeanalizować nowe wartości bezpośrednio).

Istnieją trzy opcje symulacji swoją architekturę:

· Proste metryki ;

· Gotowych symulatory ; lub

· Skrypty .

Proste Metryki

Każdy element w architekturze ma właściwości - z których wiele może być niestandardowe do stosowania ABACUS. Właściwości te reprezentują różne właściwości składników. W niektórych przypadkach po prostu zbierania tych wskaźników (KPI budować) może być wystarczający, aby powiedzieć wam ważne informacje na temat architektury. Na przykład, KLOCS lub tysiące linii kodu, były szeroko stosowane jako miara złożoności. W innych przypadkach, może chcesz eksport danych i analizować je za pomocą innego narzędzia. Dodatkowo, możesz zbierać właściwości po wykonaniu innego rodzaju symulacji.

Właściwości mogą być zbierane przez proces zbiór , Agregacja dodaje określone właściwości podrzędne w sumie co znajduje odzwierciedlenie w komponencie dominującej. Agregacja działa tylko na elementach, które zawierają elementy podrzędne.

Gotowych Symulatory

Istnieje pięć gotowych symulatory, które mogą być używane z Abacus. To są:

· Wydajność;

· Modułowość;

· Całkowity koszt posiadania (TCO);

· Otwartość; i

· Niezawodność.

Notatka

ABACUS automatycznie zaznaczyć, które z tych symulatorów należy ponownie uruchomić poprzez Rudy podkreślając na Pasek narzędzi Symulacja .

Skrypty

Skrypty zapewnia elastyczność, aby symulować architekturę w niestandardowych sposobów. Przez Pisanie skryptów można wykonać symulacje poza prądu w wybudowanym pojemności ABACUS. Cały obiekt modelu ABACUS jest dostępny do silnika skryptowego, więc jesteś ograniczony tylko przez swoją umiejętność pisania skryptów!

Skrypt Visual Basic jest językiem skryptowym wspierane przez ABACUS, ponieważ zapewnia podstawowe funkcje programowania w stosunkowo prosty format.

Zobacz też

Eksportowanie architekturę | Właściwości kruszywa | Pisanie skryptów


Pisanie skryptów

Nawigacja: Symulacja swoją architekturę>

Pisanie skryptów

Wyślij komentarzy w tym temacie.

The Script Editor to proste i funkcjonalne narzędzie do pisania i wykonywania VB lub C # Skrypt przeciwko aktualnie otwarty plik ABACUS(Biblioteki nie są obsługiwane w skryptach). Ma zwykle Plik Otwórz, Zamknij i Zapisz poleceń, więc można zapisać i pobrać skrypty piszesz. Posiada również podstawowe uruchamiania i debugowania siłownia. The Script Manager umożliwia łatwe wykonywanie różnych skryptów, które zostały napisane przez umieszczenie pozycję menu dla nich bezpośrednio w menu Narzędzia.

Aby uzyskać dostęp do edytora skryptów

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Wybierz Przybory | Script Editori otworzy się okno Script Editor. Następnie obaj;

3. Otwórz istniejący skrypt poprzez Plik | Otwarte w menu Script Editor,

lub

3. Otwórz Przykład skryptu przez Przykład pozycja w menu Script Editor,

lub

3. Ustawić domyślny język albo VB lub C # za pośrednictwem Język pozycja w menu Script Editor,

lub

3. Pomoc specyficzna otwarta skryptów za pośrednictwem Pomoc pozycja w menu Script Editor

Podczas pisania skryptów, należy stosować się do albo VB lub C # składniazgodnie z ustawieniem w pozycji języka w menu Script Editor.

UWAGA:

· Aby użyć standardowych funkcji VB, takich jak MsgBox ()należy zaliczyć Import Microsoft.VisualBasicOświadczenie na początku skryptu. To nie było konieczne przed wersji 3.0 Abacus.

· Pomoc ta nie zawiera informacji na temat jak napisać skrypt VB, ani nie zawierają odniesienie VB. Zapraszam do pisania skryptów w swoim ulubionym IDE lub edytorze, a następnie skopiuj i wklej je w edytorze skryptów.

Po pierwszym uruchomieniu edytora skryptów, edytor skryptów będzie pusta. Możesz uzyskać dostęp do skryptu szkielet poprzez menu przykładach. Przy pierwszym uruchomieniu edytora skryptów, należy uruchomić szkielet szablonów, aby zobaczyć, że to działa. Ponadto, istnieją dwa przykładowe skrypty, które mogą być dostępne przez menu przykładach.

Aby napisać użyteczny skrypt trzeba będzie odwołać ABACUS ObjectModel. Jest udostępniany do skryptu przez w tym Import ABACUS.ObjectModelOświadczenie na czele skryptu. Kompletny odniesienie do całego modelu obiektów ABACUS jest zawarty w edytorze skryptów. Można go znaleźć, wybierając Pomoc | Zawartośćz okna Script Editor.

Edytor skryptów zawiera wiele przydatnych funkcji do pisania skryptów, w tym Autouzupełnianie, jak pokazano na poniższym zrzucie ekranu. Jednak na jeszcze bogatsze doświadczenia użytkownika MS Visual Studio może być zintegrowany z Abacus i szczegółowe instrukcje są dostępne tutaj .

Script Editor z autouzupełniania

Aby użyć skryptu Menedżera

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Wybierz Narzędzia | Menedżer skryptów.

3. Kliknij na Dodajikona i OtwartePojawi się okno.

4. Przejdź do skryptu ABACUS (.abacusscript, .vb Lub .cs) Plik, który chcesz dodać do menu Narzędzia.

5. Trzask oki odniesienie do skryptu zostaną wyświetlone w oknie Script Manager. Wpisz nazwę skryptu, jak chcesz go do stawienia się w menu Narzędzia. Uwaga: W oknie Menedżer skryptów może być zmieniany, aby zobaczyć pełną ścieżkę, jeśli to konieczne.

6. Powtórz kroki 3-5do tworzenia linków do kilku skryptów Abacus.

7. Trzask Zamknijaby zamknąć Script Manager i pamiętać, że skrypt (ów) ABACUS teraz pojawiają się w menu Narzędzia.

Aby uruchomić skrypt

Bądź;

1. Otwarte, wpisać lub skopiować i wkleić w skrypt, który chcesz uruchomić, więc jest wyświetlane w głównym oknie Script Editor.

2. Kliknij Bieg przycisk.

3. Jeśli skrypt zawiera błędy, błąd Opis sekcja na dole edytora skryptów będzie lista szczegóły łącznie z numerami linii. UWAGA: Każdy pojedynczy błąd w error Opis sekcji mogą być dwukrotnie kliknąć, aby dostać się do odpowiedniej linii w skrypcie.

- lub -

1. Wybierz Przyborya następnie Nazwa ABACUS Script element menu, który został stworzony z Menedżer skryptów.

2. Jeśli skrypt zawiera błędy, edytor skryptów zostanie otwarty z treścią scenariusza przedstawionego w oknie głównym (zaznaczonego na linii pierwszego błędu) i błędu Opis sekcji na dole edytora skryptów będzie lista szczegóły lub błąd (s) włącznie z numerami linii. UWAGA: Każdy pojedynczy błąd w error Opis sekcji mogą być dwukrotnie kliknąć, aby dostać się do odpowiedniej linii w skrypcie.

Błędy kompilacji skryptów

Błędów kompilacji występują, gdy składnia kodu skryptu nie jest poprawne. Błędy te będą wyświetlane w dolnej części okna, w sekcji błędów, wraz z opisem błędu i numerem linii. To jest numer linii, która odróżnia błąd kompilacji z Runtime error (patrz poniżej), który nie będzie miał numer linii. Błędów kompilacji można dwukrotnie kliknąć, aby przejść do i wybrać odpowiedni wiersz w pytaniu.

Błędy Scripting Runtime (Ważne)

Wystąpić błędy runtime po kodzie skrypt został pomyślnie skompilowany bez błędów, ale występuje błąd przy starcie (patrz przykłady w dół dalej). Błędy czasu wykonania są ważne, ponieważ mogą one spowodować uszkodzonych modeli, gdy obiekty tworzone i odwołuje innych obiektów w modelu, same nie są częścią modelu (zazwyczaj z powodu runtime error wystąpiło przed kodu, który byłby umieszczony je w modelu gdzieś, został stracony).

Jeśli skrypt tworzy obiekty mają być dodane do modelu, można uniknąć uszkodzenia spowodowanego błędem wykonawczym zapisując swój skrypt, zamykając włączony i wykonywania funkcji cofnięcia zmian, które zostały utworzone przez skrypt (w przypadku wykonywania skryptu nie zakończyć normalnie ). Jednak istnieją również inne sposoby, by uniknąć korupcji występującej (patrz poniżej). Notatka: Wszystkie skrypty, które tylko czytają od modelu i nie pisać do niego, są bezpieczne i nie powodują żadnych problemów, niezależnie od tego, czy występują błędy runtime w trakcie ich realizacji.

Aby zapobiec uszkodzeniu podczas pisania kod skryptowy, który jest tworzenie obiektów i ich dodanie do modelu przedmiotu, proponuje się, że przedmioty są dodawane do modelu, tak szybko jak to jest możliwe wtedy, gdy są wymienione przez inne obiekty.

Na przykład, jeśli tworzysz nowe połączenie, a 2 nowe elementy, a następnie łączenie ich ze sobą, to najlepiej, aby utworzyć pierwszy składnik, dodaj go do modelu, potem drugi i dodać go, a następnie utworzyć połączenie i dodać go, a następnie w końcu stworzyć załączników. Oznacza to, że jeśli nie było się, że błąd wykonania przerywa wykonywanie skryptu, wszystkie obiekty, które są wymagane, aby być w objectmodel przed tworzony jest załącznik, są w modelu. Korupcja może wystąpić, jeśli, na przykład, tylko połączenie zostało dodane, załączniki wykonane, a następnie wystąpił błąd czasu zanim skrypt końcu dodaje nowe elementy do model.Corruption może wystąpić gdy obiekt, który jest wymieniony przez inny obiekt w objectmodel, to się nie w objectmodel.

Błędy Przykład uruchomieniowe obejmują:

· Odwołanie do obiektu nie jest ustawiony na wystąpienie obiektu - występuje, gdy obiekt jest zmienna referencyjna null, a metoda lub właściwość tego obiektu jest używany. Odniesienia Null można sprawdzić "Jeśli objectVariable Czy Nic Potem ..."

· Indeks poza granice tablicy - występuje, gdy tablica jest dostępne z indeksem, który jest poza granicami - na przykład mniej niż 0, lub jest równa lub większa niż długość / hr tablicy. Kolekcja Array lub długość można sprawdzić właściwości .length lub .Count odpowiednio.

· Nie Zezwolenie Wyjątek - Nie masz uprawnień, aby ... - ten występuje, jeśli nie masz uprawnień, aby daną zmianę

· Klucz główny Wyjątek - Duplikat / Missing Nazwa / ID - ten wystąpi, jeśli zmiana jest do unikalnego atrybutu, który jest sprzeczny z innym obiektem. Na przykład. Architektury muszą być unikalne nazwy, podobnie z normami.

· Więzy integralności Wyjątek - Ustawienie pola odniesienia do obiektu, który nie jest ważny. Na przykład. dodanie 'nic' lub wartość null jako dziecko do wielu kolekcji w objectmodel.

· Zero Długość Wyjątek - może to nastąpić, jeśli spróbujesz ustawić nazwę obiektu na pusty ciąg. Większość obiektów wymaga ich nazwy, aby mieć przynajmniej 1 znak.

Oświadczenia importuje

Należy pamiętać, że na początku szkieletu skrypty są wypowiedzi takie jak Import ABACUS.ObjectModel, Oświadczenia te nie obejmują dll, że nie jest już odwołuje skryptu - ich celem jest zapewnienie "skrót" do konieczności podać całą nazwę klasy.

Na przykład, aby zadeklarować zmienną typu CComponent (reprezentującą składową w ABACUS), z Import ABACUS.ObjectModelOświadczenie w kierunku górnej części skryptu, wymaga jedynie, że należy uznać jako ciemny zarys, jak CComponent, Ponieważ kompilator wie szukać w przestrzeni nazw ABACUS.ObjectModel dla klasy CComponent. Bez rachunku importu, to musiałoby być zgłoszone jako dim komp jak ABACUS.ObjectModel.CComponent, Zespół (takich jak pliku mscorlib.dll lub System.Windows.Forms.dll) może zawierać więcej niż jedną przestrzeń nazw - oświadczenie Import jest dla tych nazw, a nie dla samych zespołów. Zespół ABACUS.ObjectModel.dll ma tylko jeden ABACUS.ObjectModel nazw dostępną poprzez skryptów.

Zespoły automatycznie przywoływane

Następujące pliki DLL są odniesione automatycznie przez skryptów:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (pośrednio odniesione przez kompilator)

· ABACUS.ObjectModel.dll

Aby wprowadzić dodatkowe odniesienia do .NET albo innych zespołów, lub własnych zespołów, patrz następny rozdział na #Oświadczenie ImportDLL.

#Oświadczenie ImportDLL

Począwszy od ABACUS 3.1, można odwoływać dodatkowe zespoły, które mogą być potrzebne do wykonywania skryptów z wykorzystaniem z #Oświadczenie ImportDLL. Na przykład, jeśli chcesz uzyskać dostęp do twój własny DLL i korzystać z funkcjonalności w niej, należy umieścić go w katalogu ABACUS i to oświadczenie jako pierwszej linii (i) w swoim skrypcie. Jeśli jest to dll .NET, to zwykle nie ma potrzeby, aby przejść całą drogę, tylko DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL system.Xml.dll

Niektóre inne rzeczy do uwaga:

1. Ponieważ pliki DLL należy znaleźć na kompilacji i wykonywania, ogranicza to niestandardowe (nie .NET) biblioteki DLL do umieszczenia w katalogu z programem tylko ABACUS.

2. #ImportDLL oświadczenia muszą być w pierwszej linii (y) skryptu - jeśli masz 5 stwierdzeń, to powinny one być na pierwszych 5 linii skryptu

3. Na #Oświadczenie ImportDLL umieścić w dowolnym miejscu, ale pierwsze linie skryptu (na przykład, jeżeli został umieszczony po komentarzu lub instrukcji importu) nie będzie działać prawidłowo i / lub może spowodować niepowiązanych błędy kompilatora.

#ImportDLL z pakietu Office Zgromadzeń

Jeśli masz zainstalowany pakiet Microsoft Office, a skrypt wymaga zespoły Siedziba Interop, możliwe jest, aby odwoływać się do nich po prostu za pomocą #ImportDLL z nazwą zespołu (wymienionych poniżej, na przykład #ImportDLL Excel). Korzystając z tej metody ma tę zaletę, że ścieżka bezwzględna dll nie musi być stosowana, więc skrypt jest bardziej przenośne (powinien pracować zarówno pakietu Office 2003 i 2007 bez edycji skryptu).

Podczas korzystania z tej funkcji, GAC (Global Assembly Cache) jest poszukiwany zestawu międzyoperacyjnego, a skrypt kompiluje ścieżką do tego zgromadzenia, jeśli znalazł. Jeśli nie jest to znaleźć, skrypty sprawdzi katalogu programu ABACUS (zawierającego Excel i Visio interops tylko). Jeżeli wniosek nie zostanie znaleziony współdziałanie w tym czasie, pojawi się ostrzeżenie.

W interops nie są zazwyczaj instalowane w GAC, jeśli masz zainstalowany pakiet Microsoft Office przed zainstalowaniem systemu .NET Framework (które jest częścią pełnej instalacji ABACUS). Możesz zainstalować je wykonując opcję Zmień dla pakietu Microsoft Office z Dodaj / Usuń programy, a następnie wybierz opcje programowania .NET. Aby uzyskać więcej informacji, zobacz artykuł na MSDN.

Zespoły, dla których ten skrót jest wspierane są:

· Dostęp

· Access.Dao

· Przewyższać

· Wykres

· MSProject

· Perspektywy

· OutlookViewCtl

· Owc11

· PowerPoint

· Wydawca

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Słowo

It nie jest do końca jasne, czy wszystkie wyżej wymienione zespoły są przydatne, pokoje havebeen zawarte w tej funkcji regardeless jak niektórzy użytkownicy lut mają potrzebę nawet niejasnych zespołów.

Zobacz też:

Symulacja swoją architekturę

© 2001-2015 Avolution Pty Ltd. Wszelkie prawa zastrzeżone.


Korzystanie z makr

Nawigacja: Symulacja swoją architekturę>

Korzystanie z makr

Wyślij komentarzy w tym temacie.

Jeśli wykonywać wielokrotnie zadania w ABACUS, można zautomatyzować zadania za pomocą makra. Zgodnie z tym, makro ABACUS jest rejestrowane serie operacji, które mogą być odtwarzane w dowolnym czasie.

Nagrywanie makra

1. Wybierz Narzędzia | Nagrywanie makrolub alternatywnie naciśnij Alt + F10.

2. Rozpocznij wykonywanie operacji, które chcesz nagrać.

Ostrzeżenie

W tej chwili istnieją pewne znane problemy z makro nagrywania. Proszę wziąć to pod uwagę podczas nagrywania makra:

· Obecnie makra po prostu nagrywać sekwencje klawiszy Microsoft Windows, ruchy myszy i kliknięć myszką. Jednakże, ze względu na ograniczenia z samym rejestratora makro, istnieje kilka klawiszy, które nie zawsze są rejestrowane. Obejmują one:

· [Patka]

· [Ctrl]

· [Alt]

· [Wyjście]

· [Początek]

· [F1] do [F12]

· Dlatego zaleca się, aby sprawdzić, czy skrót klawiaturowy jest rejestrowane przez rejestrator makr przed nagraniem dużą sekwencję zdarzeń, które mogą zależeć od tej pracy skrótów klawiatury.

· Obecnie ze względu na ograniczenia ze rejestrator makr, menu kontekstowe nie są właściwie traktowane przez ABACUS, gdy są one otwarte przez działania zarejestrowanych przez rejestrator makr. Gdy otwiera się menu kontekstowe, należy wykonać jedną z funkcji wymienionych w menu kontekstowego za pomocą menu kontekstowego, w przeciwnym razie menu kontekstowe mogą pozostawać otwarte w czasie odtwarzania, co może prowadzić do niezamierzonych działań lub działań, które mogłyby spowodować błędy w ABACUS.

· Należy pamiętać, że normalne metody zamykania menu kontekstowe (np naciskając klawisz [Esc] na klawiaturze, lub w lewo kliknięcie gdzieś na ekranie) nie może właściwie zamknąć menu kontekstowe podczas odtwarzania makra.

napiwek

W oknach dialogowych, a nie za pomocą kliknięć myszką, zaleca się użyć klawisza Tab, aby poruszać się po dostępnych kontroli i klawiszy strzałek, aby wybrać pozycje menu rozwijanego lub radiowych przycisk Opcje i spacji, aby zaznaczyć / odznaczyć check pudełka.

Aby zatrzymać nagrywanie makra

1. naciśnij Alt + F9lub alternatywnie wybierz Narzędzia | Zatrzymanie Makro.

2. W Zapisz makro, jak oknie dialogowym wybierz do lokalizacji i wybrać liczydło makro (.abacusmac pliku) nazwę pliku i kliknij przycisk Zapisz.

Notatka

Za pomocą Przybory| Zatrzymanie Makrobędzie zawierać tę operację w nagranego makra. Dlatego zaleca się, że użytkownicy stają się biegle używając opcji klawisz Alt + funkcja do pracy z makrami, aby nie zawierać zbędnych operacji makro w samych makr.

napiwek

Ponieważ makra nie są obecnie zalecane jest edytowalny do nagrywania długich zadań jak szereg odrębnych makr za pomocą Alt + F10 / Alt + F9 "pary".

Aby odtworzyć nagrane makra

1. Wybierz Narzędzia | Odtwarzanie Makrolub alternatywnie naciśnij Alt + F8.

2. W Otwartym oknie dialogowym wybierz makro do lokalizacji i wybrać liczydło makro (.abacusmac pliku) nazwę pliku i kliknij przycisk Otwórz.

Ostrzeżenie

Podczas otwierania makro ABACUS, jeśli klikniesz dwukrotnie na pliku makro z okna dialogowego przeglądania, aby go otworzyć, makro rejestrator może przytrzymać lewy przycisk myszy w stanie lewym kliknięciu aż nagranego kliknij lewym przyciskiem myszy nadpisania tego państwa.

Notatka

Prędkość odtwarzania makra można ustawić na karcie Ogólne w ramach Przybory| Opcjealbo jako normalna (domyślnie), szybko lub wolno. Obaj szybko i wolno prędkości odtwarzania nie są zalecane, ponieważ będą one odtwarzać nagrane makra na około 100 razy i 1 / 100th czasie rzeczywistym, odpowiednio. Normalna prędkość odtwarzania będzie nadal odtwarzać makra około 30% szybszy niż nagranego prędkości, więc jest zalecane podczas nagrywania, aby zatrzymać na krótki czas po wszelkich długich zadań przetwarzania w celu zapewnienia, że ​​podczas odtwarzania następna operacja nie jest wykonywana przed zadaniem przetwarzania ma zakończony.

Aby zatrzymać odtwarzanie nagranego makra

1. naciśnij Alt + F9.


Symulacja Wydajność

Nawigacja: Symulacja swoją architekturę> Symulatory>

Symulacja Wydajność

Wyślij komentarzy w tym temacie.

Tło

Oceniający architektoniczny dla wydajności jest dyskretnym symulator wydarzenie, które działa poprzez symulację przepływu wiadomości (lub żetony) w całej architekturze. Teoria ta wywodzi się z badań przeprowadzonych przez University of Technology, i opiera się na Modele warstwowe kolejkowania sieciowe(LQNM) Tymczasowy i Coloured Petri-Nets(TCPN) i Działalność rowerowe Schematy(ACD).

W symulacji wydajności ABACUS, przetwarzanie na jednego składnika jest napędzany głównie przez komunikatów przekazywanych do niej z innego komponentu. Zasady leżące tej techniki może być rozumiany w czterech głównych części:

1. komunikat-centrickomunikacja jest modelowane w ABACUS użyciu logiczny(lub pośrednie) połączenia. Połączenia logiczne określają zachowanie (częstotliwości i danych) przekazy między komponentami. Dobrym przykładem połączeń logicznych będzie sekwencja przepływa między dwoma (2) procesów biznesowych lub logicznych interfejsów pomiędzy dwoma (2) wniosków.

2. Logika wiadomości są transportowane do miejsca przeznaczenia za pośrednictwem hierarchia(takie jak swimlanes zasobów) lub bezpośrednipołączenia (takie jak przewody fizyczne). W tym celu mogą być kierowane do góry, po drugiej zrobić iz powrotem w dół hierarchii (warstwowe podejście) śledzić bezpośrednią drogę.

3. Wierność modelu można dopasować do. Na przykład, proces ten może być podzielona na tyle, w taki sposób, przy czym każda elementarna funkcja procesu i posiada oddzielną dwutlenku przetwarzania. Alternatywnie, może to wystarczy mieć tylko jedną wartość dla całego procesu, odzwierciedlając średniOdpowiedź przetwarzania do wiadomości.

4. Aktualny przetwarzaniejest wykonywana tylko przez składniki, które mają (lub są) procesor. Procesor to ogólne rzeczy, a może być procesor, osoba, jednostka organizacyjna lub cokolwiek innego, że jest zdolna do wykonywania pracy. Na przykład, proces biznesowy nie wykonują żadnej obróbki; To jest realizowane przez pierwszego "procesor" lokalizuje albo hierarchii macierzystego (jeżeli stosowany jest tor notacja) lub sieci przetwórczego (jeżeli jest stosowany zapis rozproszonego przetwarzania).

Ocenę przeprowadza się symulację (określony) ruchu w systemie, tak że każde połączenie jest symulowana co najmniej jeden raz. Czasy przybycia wiadomości są generowane losowo w odniesieniu do ich określoną częstotliwością. Model symuluje przetwarzanie zasobów i rywalizacji oraz kolejkowanie wiadomości, gromadzenia statystyk po drodze, jak różne właściwości wyjściowych.

Kluczowe czynniki wejściowe Wydajność

1. Częstotliwość- Częstotliwość, przy której następuje połączenie.

2. Przetwarzanie- Czas wykonania na wykonanie jednego procesu. Może to być godzina, minuta, dzień, operacje itp

3. Prędkość- Szybkość zasobów procesora. To jest, jak wiele cykli / instrukcje / działania może wykonywać w jednej jednostce czasu. Ważne jest, aby być zgodne z jednostek służących do przetwarzania.

4. Procesory- Ilość zasobów procesora. Procesory mogą być ludzie, procesorów, organizacje zewnętrzne itp

Kluczowe czynniki parametrów wyjściowych

1. Wydajność- Liczba wiadomości w jednostce czasu przez połączenie, Ta rzeczywista wartość może być w porównaniu z wartościami oczekiwanymi / teoretyczne (tj częstotliwość) wydedukować nasycenie systemu.

2. Wiadomość Kursy- Liczba wiadomości w jednostce czasu przez składnik, Jest to suma wiadomości przychodzących i wychodzących wszystkich komponentów.

3. Odpowiedź- Minimalna / średni / maksymalny czas oczekiwania na to połączenie, Jest to suma wszystkich zaobserwowanych opóźnień w połączeniach od źródła do zlewu i dowolnym kolejkowania i przetwarzania (i opóźnienia z powrotem do źródła, jeśli dwukierunkowy).

4. Wykorzystanie- Wykorzystanie z składnik, Będzie to 0%, jeśli składnik nie jest urządzeniem / procesor (czyli nie ma procesorów i właściwości prędkości określonej powyżej).

Podczas symulacji dyskretne zdarzenia jest wykonywana w celu obliczenia różnych właściwości wyjściowych, jak opisano powyżej, następujący wzór może być użyty jako ogólna weryfikacji wyniki (w których system nie jest nasycone):

Wykorzystanie = suma częstotliwości dla wszystkich połączeń przychodzących * tworzenie / (prędkość * Procesory)

Ogólna koncepcja jest chyba najlepiej przedstawiony na poniższy wykres, który pokazuje dwie różne wydajności meta-model. Lewa styl jest klasyczny "tor" Zapis z zadań przetwarzania na podstawie hierarchicznie w swoich zasobów procesora. Prawo styl ręka jest "rozdzielone" Zapis z zadań przetwarzania związanych poprzez procesy związane z ich zasobów procesora. Ten ostatni zapis pozwala na wiele zasobów procesora dla danego zadania przetwarzania, w przeciwieństwie do ograniczonego notacji tor.

Notatka

Pokazany na każdej meta-modelu są właściwości wejściowe (na czerwono) i właściwości wyjściowe (na niebiesko):

Metamodele wydajności: tor w porównaniu Ukazuje notacji

Uruchomienie symulatora wydajności

Aby symulować architektury pod względem wydajności

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Wybierz Analiza| Wydajnośćlub kliknij przycisk na pasku narzędzi.

3. Wybierz Architekturachcesz ocenić z menu rozwijanego.

Notatka

Domyślnie ABACUS automatycznie wybrać pierwszą architekturę, dla których wymagana jest ponowna symulacji z powodu jakiejkolwiek nieruchomości lub zmian strukturalnych.Wyróżnienie jest pokazany na Rudy na Pasek narzędzi Symulacja .

4. Wybierz podzespoły i Znajomościchcesz ocenić, z Okno wyboru standardowym elementem .

5. Ustaw Run Time Scale Factor suwak.

Notatka

Wyższe wartości dają bardziej spójne wyniki statystycznie dłuższy czas, ale się do obliczenia.

Dodatkowy Pole wyboru do Okno wyboru standardowym elementem

· Save Transformed model będzie zapisać kopię RBD przekształconej wersji projektu w tym samym folderze co bieżącego projektu i dołączyć "_transformed" do nazwy projektu.Projekt ten przekształcił można wykorzystać do zdiagnozowania w szczegółach symulację wiarygodność podejmowanych przez ABACUS.

Inne opcje do Okno wyboru standardowym elementem

· Run Time Scale Factor kontroluje czas symulacji i dokładność z wyższym Wydajność wartościingwięcej statystycznie zgodne wyniki, ale nabierający dłuższy czas bieg.

Notatka

Gdy ABACUS oblicza czas symulacji będzie określić najwolniejszy pośredniej częstotliwości połączenia, który został wybrany, aby być symulowane, a następnie "rozgrzewkę" na okres (tj 1 nad częstotliwość) tego związku (inicjowanie okresowych generatory wiadomości dla wszystkich połączeń losowo w tym czas nagrzewania, podając wszystkie szansę zainicjować) i symulacji dla Run Time Scale Factor razy Okresu tego połączenia. Lub (1 / częstotliwość) Czas nagrzewania + (1 / częstotliwość) * Run Time Scale Factor czas symulacji. To jest, aby upewnić się, że wszystkie połączenia są inicjowane przed statystyki są zbierane, a następnie najwolniejszy połączenie jest nadal symulowane co najmniej raz w symulacji. Na przykład. Jeśli najwolniejszy połączenia pośrednie ma częstotliwość 0,033 czasowych jednostek (lub OKOŁO raz w miesiącu, jeśli terminy jednostkami są dni) to czas nagrzewania będzie 30,3 jednostkami-czasu, a czas symulacji będzie 30,3 czasowe jednostki razy Współczynnik skali czasu Run.

6. Trzask konieci dostaniesz Ostrzeżenie dialog.

7. Opcjonalnie zwiedzanie ostrzeżenia klikając Szczegóły >>.

8. Trzask kontynułuj.

Notatka

W tym momencie, ABACUS wykona symulację dyskretnych zdarzeń architektury i po krótkim czasie (z paski postępu dla sprzężenia zwrotnego) pojawi się okno dialogowe pełne obliczenia.

9. Trzask okuznać symulacji.

napiwek

Na szkolenia i dalszej pomocy na wyniki symulacji należy odnieść się do Avolution Społeczność .

Właściwości komponentów

Poniższa tabela zawiera listę właściwości wymaganych do oceny wydajności. Właściwości są wyszukiwane najpierw w przypadkach Component, potem Standardy komponentów i jeśli nie znaleziono, używany jest domyślny.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wejściowego nieruchomości ( [image] ) Z podpowiedzi "Wejście Wydajność". Zmiana któregokolwiek z tych właściwości "wejściowych" i różnych zmian strukturalnych do repozytorium spowoduje symulatorze Wydajność wymagającej ponownego symulację, jak wskazano w Rudy na Pasek narzędzi Symulacja .

Rodzaj | Imię | Domyślna wartość | Jednostka | Typ danych | Wymagany | Opis
Zachowanie | b_pack | 0.0 |  | Dziesiętny | Fałszywe | Stały czas obsługi zapakować w sekundach. Ta nieruchomość typowo określona jako typ standardowy, a następnie wykorzystywane przez wielu przypadkach składowych. Na przykład, CORBA ma b_pack = 0,23 ms.
Zachowanie | m_pack | 0.0 |  | Dziesiętny | Fałszywe | Zmienna czas obsługi zapakować w sekundach / bajt. Ta nieruchomość typowo określona jako typ standardowy, a następnie wykorzystywane przez wielu przypadkach składowych.
Zachowanie | b_unpack | 0.0 |  | Dziesiętny | Fałszywe | Stała obsługa rozpakować czas w sekundach. Ta nieruchomość typowookreślona jako typ standardowy, a następnie wykorzystywane przez wielu przypadkach składowych.
Zachowanie | m_unpack | 0.0 |  | Dziesiętny | Fałszywe | Zmienna czas obsługi rozpakować w sekundach / bajt. Ta nieruchomość typowookreślona jako typ standardowy, a następnie wykorzystywane przez wielu przypadkach składowych.
Zachowanie | Przetwarzanie | 0.0 |  | Dziesiętny | Prawdziwe | Ilość czasu wykonania na wykonanie jednego procesu. Może to być godzina, minuta, dzień, operacje itp
Zachowanie | Procesory | 1 |  | Liczba całkowita | Prawdziwe | Ilość zasobów procesora. Procesory mogą być ludzie, procesorów, organizacje zewnętrzne itp
Zachowanie | Prędkość | 100 |  | Liczba całkowita | Prawdziwe | Prędkością zasobów procesora. To jest, jak wiele cykli / instrukcje / działania może wykonywać w jednej jednostce czasu. Ważne jest, aby być zgodne z jednostek służących do przetwarzania.
Zachowanie | k_bkgd | 0.0 |  | Dziesiętny | Fałszywe | Przetwarzanie w tle na części. Ta funkcja służy do regulacji wyniki dopasować żadnych stałych przesunięcia dla%. Prawdopodobnie może to być ignorowane.

Poniższa tabela zawiera listę właściwości komponentu wyjście przez oceniającego wydajność. Zestaw tych właściwości komponentów są generowane dla każdego komponentu na każdym biegu wydajności.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Wyjście Wydajność". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora wymaga ponownego Wyniki symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Zachowanie | Wiadomość Kursy |  | Dziesiętny | Fałszywe | Liczba wiadomości w jednostce czasu poprzez składnik. Jest to suma wiadomości przychodzących i wychodzących wszystkich komponentów.
Zachowanie | Pasmo |  | Dziesiętny | Fałszywe | Całkowita przepustowość przez komponent. Suma zarówno ze względu na wiadomości przychodzących i wychodzących.
Zachowanie | Wykorzystanie | % | Dziesiętny | Fałszywe | Wykorzystanie składnika. Będzie to 0%, jeśli składnik nie jest urządzeniem / procesor (tj Nie ma Procesory i właściwości prędkości podane powyżej)

Właściwości połączenia

Poniższa tabela zawiera listę właściwości wymaganych do oceny wydajności. Właściwości są wyszukiwane najpierw w przypadkach połączenia, a następnie połączenie i Norm jeśli nie znaleziono, domyślnie jest używany.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wejściowego nieruchomości ( [image] ) Z podpowiedzi "Wejście Wydajność" lub "jakość / Wejście". Zmiana któregokolwiek z tych właściwości "wejściowych" i różnych zmian strukturalnych do repozytorium spowoduje symulatorze wydajności i / lub Symulator kosztów wymagające ponownego symulacji jak pokazano na Rudy na Pasek narzędzi Symulacja .

Rodzaj

Imię

Domyślna wartość

Jednostka

Typ danych

Wymagany

Opis

Zachowanie

Dobry

dwukierunkowa

[dwukierunkowy | jednokierunkowa]

Lookup / Lista

Prawdziwe

Czy połączenie jest dwukierunkowa (dwukierunkowy) lub jedną stronę (jednokierunkowy).

Dozwolone wartości dla tej właściwości są "dwukierunkowe" lub "jednokierunkowy".

Dwukierunkowy oznacza synchronicznych wiadomości żądania / odpowiedzi, podczas gdy jednokierunkowy pomocą pojedynczego asynchronicznego "zdarzenie".

Zachowanie

Abstrakcja

pośredni

[pośrednie | bezpośredni]

Lookup / Lista

Prawdziwe

Czy połączenie jest fizyczne lub logiczne. Połączenia bezpośrednie są fizyczne "Rury" między dwoma elementami, które płyną wzdłuż połączenia logiczne.

Dozwolone wartości dla tej właściwości jest "bezpośrednim" lub "pośrednie".

Jeśli wartość jest "bezpośrednie" to połączenie nie wymaga żadnych innych właściwości (z wyjątkiem właściwości Kind i abstrakcji).

Dane

L_app1

0

Liczba całkowita

Fałszywe

Zapytanie / rozmiar wydarzenie w bajtach.

Każde połączenie ma zwykle konkretną wartość dla tego. W CORBA, zdarzenia są rzeczywiście dwukierunkowy i zawsze mają 12 bajtów potwierdzić (L_app2). Jeśli jest to prawda, jednokierunkowe połączenie następnie opuścić nieruchomość L_app2.

Dane

L_app2

0

Liczba całkowita

Fałszywe

Odpowiedź / potwierdzić rozmiar w bajtach.

Każde połączenie ma zwykle konkretną wartość dla tego. Jednokierunkowe połączenie nie będzie miał L_app2.

Zachowanie

Częstotliwość

1

Dziesiętny

Prawdziwe

Częstotliwość, przy której następuje połączenie.

Każde połączenie ma zwykle konkretną wartość dla tego. Jeśli częstotliwość nieruchomość jest pominięty używane jest domyślne.

Zachowanie

Związek

Procesy

[Procesy | obsługuje]

Lookup / Lista

Fałszywe

Połączenia, które mają "procesy" właściwość wskazuje, że składnik na początku połączenia może być przekształcony do obróbki w składniku po zakończeniu połączenia. W efekcie składnik "źródło" jest przeniesiony, aby stać się dzieckiem "zatopić" składnika (załączone połączenia są także "wyciągnął" z tego ruchu).

Jeśli "procesy" właściwość istnieje wtedy wszystkie pozostałe właściwości połączenia będą ignorowane, z wyjątkiem opcjonalnego "%" nieruchomości opisanej poniżej.

Zachowanie

%

100,0

Dziesiętny

Fałszywe

Połączenia, które mają własności "procesu" (opisane powyżej) mogą ewentualnie mieć właściwości "%", aby wskazać część przetwarzania, które zostaną przypisane do elementu docelowego. W ten sposób element jednego źródła mogą być przetwarzane przez wielu komponentów docelowych w różnych% tych. Wartości% nie muszą sumować się do 100%, a to jest po prostu wykorzystywane do skalowania "przetwarzanie" własności (patrz wyżej) dla komponentu źródłowego, ponieważ przekształca stać się dzieckiem elementu docelowego.

Poniższa tabela zawiera listę właściwości generowane przez oceniającego wydajność. Zestaw tych właściwości połączenia są generowane dla każdego połączenia na każdym biegu wydajności.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Wyjście Wydajność". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora wymaga ponownego Wyniki symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Zachowanie | Pasmo |  | Dziesiętny | Fałszywe | Ogólna przepustowość połączenia. To jest obliczany tylko dla połączeń pośrednich i jest w istocie (L_app1 + L_app2) * Wydajność.
Zachowanie | Przepustowość 1/2 |  | Dziesiętny | Fałszywe | Przepustowość specjalnie dla wychodzących (1) i przychodzących (2) wiadomości połączenia. To jest obliczany tylko dla połączeń pośrednich i jest zasadniczo L_app1 * Wydajność i L_app2 * Wydajność.
Zachowanie | Wydajność |  | Dziesiętny | Fałszywe | Liczba wiadomości w jednostce czasu przez połączenie. Ta rzeczywista wartość może być w porównaniu z wartościami oczekiwanymi / teoretyczne (tj częstotliwość) wydedukować nasycenie systemu.
Zachowanie | Zakończony | % | Dziesiętny | Fałszywe | Odsetek wiadomości, które pomyślnie zakończyć przetwarzania dla połączenia. To jest obliczany tylko dla połączeń pośrednich i jest Przepustowość / Częstotliwość. Czasami zaktualizował wartość przekracza 100%, ponieważ losowość wyników generacji komunikatu w nieco wyższej częstotliwości generowania komunikatu niż określona.
Zachowanie | Odpowiedź (Min / Ave / Max) |  | Dziesiętny | Fałszywe | Minimalna / średni / maksymalny czas oczekiwania. Oblicza się wyłącznie do połączenia pośrednie i jest obserwowana opóźnienia dla połączenia ze źródła do zlewu i dowolnym kolejkowania i przetwarzania (i opóźnienia z powrotem do źródła, jeżeli dwukierunkowe).

Obiekty architektury

Poniższa tabela zawiera listę systemowych właściwości architektonicznych generowane przez oceniającego wydajność. Pojedynczy zestaw właściwości dla architektury są "łączone" dla każdego biegu wydajności.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Wyjście Wydajność". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora wymaga ponownego Wyniki symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Zachowanie | Wiadomość Kursy |  | Dziesiętny | Fałszywe | Liczby wiadomości przypadających na jednostkę czasu przez elementy w architekturze. Jest to suma wiadomości przychodzących i wychodzących wszystkich komponentów.
Zachowanie | Wydajność |  | Dziesiętny | Fałszywe | Liczba wiadomości w jednostce czasu przez połączenia w architekturze. Jest to suma przepustowości wszystkie połączenia pośrednie "i to rzeczywista wartość może być w porównaniu z wartościami oczekiwanymi / teoretyczne (tj Frequency) wydedukować nasycenie systemu.
Zachowanie | Pasmo |  | Dziesiętny | Fałszywe | Ogólna przepustowość. Suma przepustowości architektury za połączenia.
Zachowanie | Wykorzystanie | % | Dziesiętny | Fałszywe | Wykorzystanie wszystkich składników. Może być większa niż 100%, ponieważ jest to po prostu suma wszystkich składników ZASTOSOWANIA architektury jest.
Zachowanie | Odpowiedź (Min / Ave / Max) |  | Dziesiętny | Fałszywe | Minimalna / średni / maksymalny czas oczekiwania. Suma wszystkich obserwowanych opóźnień dla połączeń architektury jest z źródła do zlewu (iz powrotem do źródła, jeśli dwukierunkowy).


Symulacja Modułowość

Nawigacja: Symulacja swoją architekturę> Symulatory>

Symulacja Modułowość

Wyślij komentarzy w tym temacie.

Symulator modułowość oblicza liczbę połączeń przychodzących i wychodzących dla każdego komponentu.

Aby symulować w zakresie architektury modułowej

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Wybierz Analiza| Modułowość.

3. Wybierz Architecture (s)chcesz dołączyć do oceny.

Notatka

Domyślnie ABACUS automatycznie wybierze architekturę (y), dla których wymagana jest ponowna symulacji z powodu jakichkolwiek podstawowych zmian strukturalnych.Wyróżnienie jest pokazany na Rudy na Pasek narzędzi Symulacja .

4. Trzask Dalej.

5. Wybierz Rodzaje połączeń (s)chcesz dołączyć do oceny.

6. Trzask Dalej.

7. Opcjonalnie dostosować nazwy właściwości dla wyników obliczeń.

8. Trzask koniec.

Notatka

W tym momencie, ABACUS wykona strukturalnej oceny architektury (s) i po krótkim czasie (w paski postępu dla sprzężenia zwrotnego), pojawi się okno dialogowe pełne obliczenia.

9. Trzask okw celu potwierdzenia oceny.

napiwek

Na szkolenia i dalszej pomocy na modułowość oceny należy odnieść się do Avolution Społeczność .

Właściwości komponentów

Poniższa tabela zawiera listę właściwości komponentów, które są wyprowadzane przez oceniającego modularną.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Modułowość Wyjście". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu podstawowych zmian strukturalnych do repozytorium i symulatora modułowość wymaga ponownej symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Typ danych | Wymagany | Opis
Modułowość | Hak-wentylator (lokalne) | Liczba całkowita | Fałszywe | Liczba połączeń, wentylator do tego składnika.
Modułowość | Hak-fan out (lokalne) | Liczba całkowita | Fałszywe | Liczba połączeń, wentylator z tego składnika.
Modułowość | Hak-fan w | Liczba całkowita | Fałszywe | Liczba połączeń, wentylator do tego składnika, w tym połączeń wentylatora do podzespołów.
Modułowość | Hak-fan out | Liczba całkowita | Fałszywe | Liczba połączeń, wentylator z tego składnika, w tym połączeń wentylatora do podzespołów.


Symulacja całkowity koszt posiadania (TCO)

Nawigacja: Symulacja swoją architekturę> Symulatory>

Symulacja całkowity koszt posiadania (TCO)

Wyślij komentarzy w tym temacie.

Tło

Całkowity koszt posiadania (TCO) jest oszacowanie finansowe, przeznaczone do pomiaru całkowitych poniesionych kosztów cyklu życia (od nabycia do likwidacji / dyspozycji) związane z posiadanych aktywów. TCO odzwierciedla nie tylko koszty zakupu, to zawiera również wszystkie inne aspekty dalszego użytkowania i konserwacji aktywów.

TCO służy do określenia wysiłku i kosztuje budżet niezbędny do spędzenia w systemie. Prostym sposobem modelowania w Abakus dla TCO jest przełamanie systemu IT na różne elementy. Możemy dowiedzieć się, ile średnio kosztuje uruchomić jeden z tych składników. Po tym możemy następnie czynnikiem w różnych kosztów w zależności od tego, czy system IT jest evolvable lub otwarty itp Jeśli system jest już gotowy do pracy, głównym czynnikiem do rozważenia jest koszt utrzymania i być może koszty wycofania z eksploatacji.

Przykład

Schemat przykład obliczeniowy

Komponent ramach Organizacji lub jego standardu ma te właściwości:

· Przeliczeniu na pełne etaty= 100 000 $ / rok

· Wsparcie Wysiłek= 0,01 EPC + 0.001 etatów / rok = 1000 $ + 100 $ / rok

· Koszty utrzymania= 100 $ - 10 $ / rok

· Koszt kapitału= 2000 $

· Zainstaluj Effort= 2 FTE / dni = 0,01 EPC / rok = 1000 $

Komponent ramach Organizacji ma te właściwości:

· Zainstaluj Horizon= -2 Lat (czyli System został zainstalowany przed 2 lat obecnie)

· Długość życia= 3 lata

Gdy Zainstaluj Horizon + Żywotność <= 0 Nie ma więcej koszty utrzymania.

Obliczenia

Obliczenia są następujące:

Notatka

TC = koszt rocznie. SE = Pomoc wysiłku. MC = koszty utrzymania.

· Koszt Początkowy koszt = Kapitał + Install Effort= 2000 + 1000 = 3000 $

· W czasie t = -2 (w okresie 1 roku) TC = koszt początkowy + SE + MC= 3000 + 1000 + 100 = 4100 $

· W czasie t = -1 TC = SE + MC= (1000 + 100) + (100 - 10) = +1190 $

· W czasie t = 0, TC = (1000 + 200) + (100 - 20) = 1,28 tysięcy $

· W chwili t = 1 (ostatni rok), TC = (1000 + 300) + (100 - 30) = +1.370 $

Wykres na przykład obliczeniowy

TCO jest sumą wszystkich obecnych i przyszłych kosztów, aż system został wycofany ze służby.

· W chwili t = -2 (w okresie 1 roku), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· W t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· W czasie t = 0, TCO = 1.280 + tysięcy trzysta siedemdziesiąt = 2,65 tysiąc $

· W chwili t = 1 (ostatni rok), TCO = 1370 $

Kluczowe czynniki kosztowe

Kluczowe czynniki kosztowe, które należy uwzględnić przy obliczaniu całkowitego kosztu użytkowania składnika aktywów w ABACUS są:

· Nabycie Wyposażenie- Początkowy koszt sprzętu (koszt kapitału).

· Oprogramowanie Nabycie- Początkowy koszt licencji na oprogramowanie (koszt kapitału).

· Instalacja- Koszty związane z wstępnej konfiguracji.

· Szkolenie- Koszty związane z zewnętrznym szkolenia sprzedawca po wstępnej konfiguracji.

· Pomoc- Koszty związane z obsługą wewnętrzną.

· Konserwacja- Koszty wymiany lub modernizacji Sprzedającego umowy konserwacyjne, dostawy i koszty usuwania skutków awarii.

· Infrastruktura- Koszty związane z obsługą danego składnika aktywów.

ABACUS Przykład Przedstawienie kluczowych czynników kosztowych

Uruchomienie symulatora Cost

Aby symulować architekturę w zakresie kosztów

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Wybierz Analiza| Koszt.

3. Wybierz Architecture (s)chcesz dołączyć do oceny.

Notatka

Domyślnie ABACUS automatycznie wybierze architekturę (y), dla których wymagana jest ponowna symulacji z powodu jakiejkolwiek nieruchomości lub zmian strukturalnych.Wyróżnienie jest pokazany na Rudy na Pasek narzędzi Symulacja .

4. Wybierz Walutaz rozwijanym.

5. Przesuń Lat do obliczeniasuwak do liczby lat wymaganych.

Notatka

Domyślnie, jeśli latach do obliczenia jest więcej niż 1 roku koszty będą automatycznie obliczane dla każdego roku (i zbiór właściwości dodał / aktualizacja), a następnie skumulowana wartość dla całego szeregu lat obliczono również. Jeśli wymagana jest tylko wartość skumulowana następnie usuń zaznaczenie Oblicz Per-letnich kosztówrozwiązaniem, jak opisano poniżej, aby zaoszczędzić na szereg właściwości, w projekcie.

6. Wybierz, czy zostawić Oblicz Per-letnich kosztówsprawdzone lub odznacz je.

7. Trzask Dalej.

8. Opcjonalnie można wybrać Znajomościchcesz przypisać koszty razem jako część oceny.

Notatka

Używanie Koszt | Atrybucjanieruchomości na kosztach połączeń może być przypisać od składnika dołączony do końca umywalka do połączenia składnika dołączony do końca źródłowego(czyli koszt | Attribution = "Sink Source"), lub od elementu dołączonego do źródło Koniec połączenia elementu dołączonego do umywalka koniec(czyli koszt | Attribution = "Źródło zatopić"), Do tego, ABACUS automatycznie wybierze te połączenia z Behaviour | Powiązania = "procesy" lub "podpory"a kierunek atrybucji będzie "Sink Source ', Ponadto, koszty są rozdzielane według Behaviour | % Lub koszt | % Właściwości na połączeniach lub alternatywnie, gdzie istnieje wiele połączeń z umywalką do wielu źródełlub źródło wielu pochłaniaczyWedług dowolnego Behaviour | Właściwości przetwarzania na komponentów źródłowychlub tonąć komponenty odpowiednio.

9. Trzask konieci dostaniesz Ostrzeżenie dialog.

10. Opcjonalnie zwiedzanie ostrzeżenia klikając Szczegóły >>.

11. Trzask kontynułuj.

Notatka

W tym momencie, ABACUS wykona zadaniowego kosztuje ocenę architektury (s) i po krótkim czasie (w paski postępu dla sprzężenia zwrotnego), pojawi się okno dialogowe pełne obliczenia.

12. Trzask okw celu potwierdzenia oceny.

napiwek

Na szkolenia i dalszej pomocy na symulacji kosztów należy odnieść się do Avolution Społeczność .

Składnik i / lub połączenia Właściwości

Poniższa tabela zawiera komponent i / lub połączenie Właściwości wymagane w celu oceny kosztów.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wejściowego nieruchomości ( [image] ) Z podpowiedzi "Wejście kosztów". Zmiana któregokolwiek z tych właściwości "wejściowych" i różnych zmian strukturalnych do repozytorium spowoduje symulatora kosztów wymagających ponownego symulację, jak wskazano w Rudy na Pasek narzędzi Symulacja .

Rodzaj

Imię

Domyślna wartość

Jednostka

Typ danych

Wymagany

Opis

Koszt

Zainstaluj Horizon

0

lat

Liczba całkowita

Prawdziwe

Określa, gdy składnik lub połączenie została lub zostanie zainstalowany.

· Wartość 0 (domyślna) oznacza, że ​​składnik lub połączenie jest instalowany w bieżącym roku.

· Wartość mniejsza niż 0 wskazuje, że składnik lub połączenie zainstalowano w przeszłości.

· Wartość większa niż 0 oznacza, że ​​składnik lub połączenie będą instalowane w przyszłości.

Koszt

Długość życia

0

lat

Liczba całkowita

Prawdziwe

Określa się czas, w którym składnik lub połączenie pozostanie w pracy, po którym zostanie ono zlikwidowane.

Koszt

Przeliczeniu na pełne etaty

100.000,00

$ / rok

Dziesiętny

Fałszywe

Roczny koszt każdego pracownika na pełny etat.

Jeśli ta właściwość nie zostanie znaleziona w komponenciesamodzielnie lub w przypadku połączeń element przymocowany do końca zlewu połączeniaBędzie się poszukiwać w innych składnikach.

Po pierwsze, wszelkie "zlew" składniks na końcu a Połączenie z "wspiera" relacji składnikowi zostaną przeszukane, a następnie że "zlew" rodzica komponentus.

Jeżeli nieruchomość nie znaleziono przeliczeniu na pełne etaty, składnika roślina mateczna-components zostaną przeszukane. Jeśli FTE nadal nie znaleziono, jest używana wartość domyślna.

Uwaga: FTE jest tylko ważna właściwość wejście na komponentach.

Koszt

Koszt konserwacji (stałe)

0.00

$ / rok

Dziesiętny

Fałszywe

Roczny koszt utrzymania stały składniklub połączenie.

Koszt

Koszt konserwacji (zmienna)

0.00

$ / rok

Dziesiętny

Fałszywe

Kwota, o której całkowity koszt utrzymania składnika lub połączenie zmienia się każdego roku.

Na przykład, wartość $ -500 wskazuje, że całkowity koszt utrzymania zmniejsza się o $ 500 rocznie, a wartość $ 500 wskazuje, że wzrost kosztów ogółem o $ 500 Konserwacja każdego roku.

Koszt

Wsparcie Wysiłek (stałe)

0.00

FTE / rok

Dziesiętny

Fałszywe

Roczna stały wysiłek wspierania komponentlub połączenie, Określone pod względem osobo-lat.

Koszt

Wsparcie Wysiłek (zmienna)

0.00

FTE / rok

Dziesiętny

Fałszywe

Kwota, o której całkowity nakład wspierania komponent lub połączenie zmienia się każdego roku.

Na przykład, wartość -0.01 wskazuje, że całkowity nakład poparcie spada o 0,01 osobolat rocznie, a wartość 0,01 oznacza, że ​​łączne wsparcie wysiłku wzrasta o 0,01 rocznie.

Koszt

Koszt kapitału

0.00

$

Dziesiętny

Fałszywe

Początkowy koszt zakupu składnikalub połączenie.

Koszt

Zainstaluj Effort

0.00

Przeliczeniu na pełne etaty

Dziesiętny

Fałszywe

Wymaga wysiłku, w osobo-lat, w celu zainstalowania składnikalub połączenie.

Poniższa tabela zawiera komponent i / lub połączenie właściwości, które są Wyjście przez oceniającego TCO. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Wyjście kosztów". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora kosztów wymaga ponownej symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Notatka

Gdzie właściwości wyjściowe z oceniającego TCO musi być "zaokrąglone" "okrągłego pół do nawet" podejście (określane również jako "bankierzy" zaokrąglenia) jest używany.Technika ta jest stosowana do bardziej równomiernie rozwiązać wszelkie .5 "tie-break" w wyniku czego są zaokrąglane w górę lub w dół do najbliższej parzyste wynikiem, a nie zawsze zaokrąglenia w górę lub w dół i wypaczenia wyniku. To znaczy. 2.5 jest zaokrąglana w dół do 2, a 3.5 jest zaokrąglana w górę do 4, zamiast nich oba są albo zaokrąglona w dół do 2 i 3 lub w zaokrągleniu do 3 i 4.

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Koszt | Całkowity koszt z własnością - kolejne x lat. | $ | Liczba całkowita | Fałszywe | Całkowity koszt posiadania w ciągu najbliższych xlat, gdzie x jest określony czas podczas pracy ewaluatora. Obejmuje to koszty komponentu lub połączenia w normy, podzespołówlub sub-połączenia(to znaczy dzieci) i wszystkie przypisane koszty.
Koszt | Całkowity koszt z własnością (lokalne) - następne x lat. | $ | Liczba całkowita | Fałszywe | 'Local' koszty eksploatacji w ciągu najbliższych xroku, w którym xjest określony czas podczas pracy ewaluatora. Robi to nieobejmuje kosztów podzespołów komponentu lub sub-połączenia połączenia w (to znaczydzieci) lub jakiekolwiek przypisać koszty.
Koszt | Całkowity koszt z własnością (dzieci) - następne x lat. | $ | Liczba całkowita | Fałszywe | Koszt "dzieci" własności w ciągu najbliższych xlat, gdzie x jest określony czas podczas pracy ewaluatora. To tylko obejmuje koszt podzespołów komponentu lub sub-połączenia połączenia w (to znaczy dzieci).
Koszt | Całkowity koszt z własnością (przypisane) - następne x lat. | $ | Liczba całkowita | Fałszywe | W "przypisać" koszty eksploatacji w ciągu najbliższych xlat, gdzie x jest określony czas podczas pracy ewaluatora. To tylko obejmuje wszystkie przypisane koszty z załączonych elementów(co może oczywiście obejmować przypisać koszty od wszelkich załączonych połączeń).

Poniższa tabela zawiera komponent i / lub połączenie właściwości, które są Wyjście przez oceniającego TCOjeśli Oblicz Per-letnia Koszty opcja jest zaznaczona. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Wyjście kosztów". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora kosztów wymaga ponownej symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Notatka

Patrz uwaga powyżej sprawie ewentualnego zaokrąglania właściwości wyjściowych.

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Koszt | Całkowity koszt na własność - rokx. | $ | Liczba całkowita | Fałszywe | Całkowity koszt posiadania dla rok xGdzie x jest za każdy rok określone podczas pracy ewaluatora. Obejmuje to koszty komponentulub połączenia w normy, podzespołów lub sub-połączenia (to znaczy dzieci) i wszystkie przypisane koszty.
Koszt | Całkowity koszt z własnością (lokalne) - rokx. | $ | Liczba całkowita | Fałszywe | 'Local' koszt posiadania za rok x, gdzie x jest za każdy rok określone podczas pracy ewaluatora. Robi to nieobejmuje kosztów podzespołów komponentu lub sub-połączenia połączenia w (to znaczy dzieci) lub jakiekolwiek przypisać koszty.
Koszt | Całkowity koszt z własnością (dzieci) - rokx. | $ | Liczba całkowita | Fałszywe | Kosztować "dzieci" własności za rok xGdzie x jest za każdy rok określone podczas pracy ewaluatora. To tylko obejmuje koszt podzespołów komponentu lub sub-Połączenie Połączenie w (to znaczy dzieci).
Koszt | Całkowity koszt z własnością (przypisane) - rokx. | $ | Liczba całkowita | Fałszywe | W "przypisać" koszt posiadania za rok xGdzie x jest za każdy rok określone podczas pracy ewaluatora. To tylko obejmuje wszystkie przypisane koszty z załączonych elementów(co może oczywiście obejmować przypisać koszty od wszelkich załączonych połączeń).

Dodatkowy Właściwości połączenia

Poniższa tabela dodatkowy właściwości połączenia, które są wymagane przez oceniającego TCO. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wejściowego nieruchomości ( [image] ) Z podpowiedzi "Wejście koszt / wydajność" lub po prostu "Wejście kosztów". Zmiana któregokolwiek z tych właściwości "wejściowych" i różnych zmian strukturalnych do repozytorium spowoduje kosztów i / lub Symulator wydajność wymagające ponownego symulacji jak pokazano na Rudy na Pasek narzędzi Symulacja .

Rodzaj

Imię

Domyślna wartość

Jednostka

Typ danych

Wymagany

Opis

Koszt

Atrybucja

Umywalka do źródła

[Źródło tonąć | Opadają na źródło]

Lookup / Lista

Prawdziwe

Gdyby "Źródło tonąć"To połączenie będzie mają mają kosztsprzypisane "razem" ono z źródłoSkładnik do umywalka składnik, Alternatywnie, jeżeli "Umywalka do źródła"To połączenie będzie koszty przypisuje się "razem" ono od składnika opadają na urządzenie źródła.

Zachowanie

Związek

Wsporniki

[Procesy | obsługuje]

Lookup / Lista

Fałszywe

Jeśli "wspiera", połączenie to oznacza, że ​​komponent "źródło" jest wspierany przez "zatopić" komponentu.

Dodatkowo, jeśli albo "podpory" lub "procesy" to połączenie zostanie automatycznie wybrane w połączeniach, aby ich koszty przypisuje "razem" z komponentu zlewu do komponentu źródłowego.

Koszt

%

100,0

%

Dziesiętny

Fałszywe

Wskazuje część kosztów komponentów umywalka, które będą przypisane do elementu źródłowego. Wartości% nie muszą sumować się do 100%, a to jest po prostu wykorzystywane do skalowania "Całkowity koszt z własnością. - Kolejne X lat" własności (zobacz powyżej), z elementu opadania jest przypisany do elementu źródłowego.

Obiekty architektury

Poniższa tabela zawiera listę właściwości architektury, które są Wyjście przez oceniającego TCO. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Wyjście kosztów". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora kosztów wymaga ponownej symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Notatka

Patrz uwaga powyżej sprawie ewentualnego zaokrąglania właściwości wyjściowych.

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Koszt | Całkowity koszt z własnością - kolejne x lat. | $ | Liczba całkowita | Fałszywe | Całkowity koszt posiadania całej architektury w ciągu najbliższych x lat.

Poniższa tabela zawiera listę właściwości architektury, które są Wyjście przez oceniającego TCOjeśli Oblicz Per-letnia Koszty opcja jest zaznaczona. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Wyjście kosztów". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora kosztów wymaga ponownej symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Notatka

Patrz uwaga powyżej sprawie ewentualnego zaokrąglania właściwości wyjściowych.

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Koszt | Całkowity koszt na własność - rokx. | $ | Liczba całkowita | Fałszywe | Całkowity koszt posiadania dla cała architektura za rok x w przyszłość.


Symulacja niezawodność i dostępność

Nawigacja: Symulacja swoją architekturę> Symulatory>

Symulacja niezawodność i dostępność

Wyślij komentarzy w tym temacie.

Tło

Niezawodnoœć Oceniający oblicza niezawodność architektury przy użyciu składników i połączenia wejściowe.

Dla komponentów i połączeń bezpośrednich, wiarygodność opiera się Mean Time Between Failure (MTBF). Tylko zmienne potrzebne do obliczenia niezawodności elementów architektonicznych są:

· MTBFWartość (w latach);

· Średni czas naprawy (MTTR)awaria (w latach); i

· Określony okres czasu, aby sprawdzić niezawodność ponad.

Formuła stosowana w obliczeniach niezawodność jest wyrażony jako:

Niezawodność = -e (-y x wiek)
W przypadku, gdy y = 1 ÷ MTBF

Dostępności komponentów i połączeń jest oparty na MTBF i MTTR. Zauważ, że dostępność, w przeciwieństwie do niezawodności, pozostaje bez zmian przez okres, na który jest w fazie testów.

Dostępność = MTBF / (MTBF + MTTR)

Podczas metod, które przekształcają Niezawodność Schematy blokowe(przy użyciu prostych równoległych serii i konstrukcji) daje najbardziej dokładne wyniki, metody te stają się bardzo impraktyczne, gdy staramy się obliczyć niezawodność misji w wielkich sieciach tysięcy elementów. Ponadto, te sposoby transformacyjne rozbicie dla wielu typowych struktur, takich jak sieć "siatki".

Monte CarloMetoda pozwala na niezawodność i dostępność systemu dowolnej wielkości i złożoności być obliczona. Metoda Monte Carlo symuluje wiele scenariuszy oraz flub każdy scenariusz stan losowych, do dyspozycji lub niedostępneJest przypisany do każdego elementu fizycznej. Prawdopodobieństwo danego elementu jest w wolnym stanie bazuje na niezawodność / dostępność składnika.

Na przykład, składnik o 90% dostępności można się spodziewać, że będzie dostępna w około 90% z tych scenariuszy. Niezawodność i dostępność połączenie pośrednie mogą być w związku z tym szacuje się jako udział losowej scenarios-, dla których istnieje ścieżka z dostępnych elementów w deklaracjach od źródła do miejsca przeznaczenia.

Notatka

Ponieważ obliczanie miejscowego niezawodności i gotowości jest oparty na innych parametrach i różnych wzorów (a tym samym powoduje różne wartości), konieczne jest, aby przypisać każdy element dwastany, jeden dostępność, i jeden dla niezawodności. Obliczanie dostępności wykorzystuje stan dostępności w każdym scenariuszu, natomiast obliczenie niezawodności wykorzystuje stan niezawodność w każdej sytuacji.

Oceniający niezawodności wykorzystuje technikę symulacji Monte Carlo wypracować wiarygodność danej architektury. Architektura jest poddane tysięcy indywidualnych symulacji, a wyniki zestawiono w celu opracowania środka niezawodność. Jak wspomniano powyżej, Monte Carlo jest najszybszy technikę symulowania większych sieci i współpracować z każdym złożonym (tzn zazębienia) struktury.

Oceniający wyjścia cztery wartości:

1. Misja Niezawodnośćciągu wielu lat;

2. Dostępnośćz architektura;

3. Niezawodnośćz lokalny komponentciągu wielu lat; i

4. Dostępnośćz lokalny komponent.

Oceniający działa obecnie prawdopodobieństwo Połączenie części lub pracy (to znaczy nie braku), a czas potrzebny do naprawy.

Jak normy z MTBFs i / lub MTTRs traktuje

Jeśli element (część lub połączenia) ma standardy przypisanego MTBF i / lub MTTR Wartości te wartości są wykorzystywane do obliczenia lokalnej niezawodności i dostępność elementu jako połączenie szeregowe.

Na przykład, jeśli składnik A, Z przypisanymi normami B, C, i Dkażdy ma MTBF i MTTR Wartość, lokalny Niezawodność = R(A)× R(B) × R(C) × R(D), gdzie R = Obliczone niezawodność (za pomocą wzoru) z części / standardów i Lokalny Wykorzystaćzdolność = ZA(A)× ZA(B) × ZA(C) × ZA(D), gdzie A = Obliczone wykorzystaćmożliwość (za pomocą wzoru) komponentu / norm. To jest, jeśli element ma trzy standardy każdego z MTBF i MTTR wartośćs, A także MTBF i MTTR wartośćsdla właściwości elementu, lokalny niezawodności i avilability podano jako wartości serii każdej z normami i samego elementu.

Jako inny przykład, jeśli składnik Ama przypisane standardy B, C, i Dale tylko standardowe Bma zarówno wartość MTBF i MTTR, podczas gdy norma Cma tylko wartość MTBF i standardowe Dma tylko wartość MTTR, lokalne Niezawodność = R (A)× R (B)× R (C), gdzie R= Obliczone niezawodność (za pomocą wzoru) z części / standardów i lokalny Dostępność = A (A)× A (B)× AC), gdzie A= Obliczona dostępność (z użyciem wzoru) elementu / norm ale obliczania (C), ponieważ norma ma tylko charakter MTBF to 'wyszukiwania'dla wartości (y) dopasowanie MTTR i dodać wszystkie wartości MTTR stwierdzenia, że ​​don't sami mają wartość MTBF dopasowania, więc w tym przypadku byłoby użyć wartości MTTR wzorca D, Jeśli był inny standard, mówią E, Tylko z wartości MTTR oraz następnie AC)użyłby MTBF Cz MTTR z D i Esumowane. Jeśli innym standardzie, mówią F, Właśnie wartość MTBF następnie A (F)również użyć MTTR z D i Esumowane.

Obliczanie Mission niezawodność

Podczas obliczania lokalnego niezawodność jest sprawą za pomocą prostego wzoru, obliczanie połączeń pośrednich (misja) nie jest tak łatwo, zwłaszcza gdy mamy złożonych i dużych sieci (połączenia ścieżek z przeplotem) oraz komponentów.

Biorąc pod uwagę całą sieć

Jako połączenia pośrednie nie stanowią połączenia fizycznego, musimy dowiedzieć się, jak element źródłowy może dostać się do jego komponentu docelowego. A to zakłada, patrząc na całą sieć i wszystkie sposoby (i drogi) nasz komponent źródłowy może podjąć, aby osiągnąć docelowy komponentu (umywalka).

Notatka

Tak długo, jak nie ma przynajmniej jeden kompletnydroga od źródła do miejsca przeznaczenia, misja zakończy się sukcesemoraz połączenie pośrednie określa się jako zamkniętego połączenia.

Zrozumienie łącza Matrix

Aby wiedzieć, które komponenty / bezpośrednie połączenia są podłączone do tego, co potrzebujemy artefaktu, aby szybko sprawdzić, czy dwa bloki są połączone w określonym kierunku. Jest to funkcja macierzy łącza. W skrócie, matryca link jest dwuwymiarową tablicą zmiennych logicznych, które stwierdza, czy dany składnik może osiągnąć inny komponent bezpośrednio. Jego wielkość wynosi kwadrat całkowitej liczby komponentów w sieci.

Prosty Niezawodność Schemat blokowy (RBD)

Podobne link Matrix schemat blokowy niezawodności (RBD)

Ponieważ nie wszystkie połączenia są dwukierunkowe (w obie strony), ważne jest wiedzieć, jak prawidłowo odczytywać matrycę łącza. W oceniającego niezawodność, pierwszy argument jest źródłem i drugi argument jest cel (umywalka).

Dlatego też, jeśli macierz Link (A, B) = true to oznacza to, że można dostać się do B bezpośrednio (jednokierunkowy). B do A można uzyskać tylko wtedy, gdy macierz Link (B, A) = true. Jeśli to prawda, to oznacza dwukierunkowe połączenie.

W przedstawionym przykładzie nad:

· Źródło 1 może osiągnąć cel 0 (źródło 1 i Destination 0 daje wynik true); i

· Źródło może osiągnąć cel 0 1 (Źródło 0 i Destination 1 daje wynik true), jako związek między 0 a 1 jest dwukierunkowa.

· Źródło 2 nie może osiągnąć cel 1 (źródło 2 i Destination 1 daje wynik Fałsz) nawet wtedy, gdy źródło 1 może osiągnąć docelowy 2 (źródło 1 i przeznaczenie 2 daje wynik true). To oznacza, że ​​związek między 1 a 2 jest jednokierunkowy.

Zrozumienie Reliability Block Diagram

Schemat blokowy niezawodności (RBD) oddaje strukturę całego modelu obiektowego w kategoriach bloków i linki. Każdy blok reprezentuje element, który ma możliwość porażki lub sukcesu Według linki / ścieżek, które je łączą. Oba komponenty i złącza mogą stać się "blok" w RBD.

Przykład RBD Bloki i linki

Figura powyżej przedstawia przykład RBD. Linia przerywana czerwona reprezentuje pojedynczą misję 4 do 1. Uwaga, jak są tylko dwie możliwe ścieżki do misji 4 do 1.

Zastanów trasę 4 do 3 do 0 na 1, a trasa 4 do 7 do 1. przerywana blokach 2, 5i 6 stanowią bloki, które nie wpływają na awaryjność / Non-niepowodzenie misji 4 do 1. Nie są one uwzględnione i są ignorowane. Jest to ważne, ponieważ w większości misji będzie duża liczba nadmiarowych bloków, które nie wpływają na sukces konkretnego misji. Jest to bardziej widoczne w większych sieciach, przy czym liczba nadmiarowych bloków będzie wyniki symulacji niedokładne.

Aby przyspieszyć czas symulacji, oraz zapewnić dokładniejsze wyniki, konieczne jest abstrakcyjne z całego RBD i używać tylko te elementy, które wpływają na sukces misji jest.

Notatka

Jedna trasa / ścieżka nie może przejść przez dowolnego elementu dwukrotnie.

Na tym etapie możemy stworzyć macierz łącza i wykonać symulacji Monte Carlo.

Obliczanie Architektura Dostępność

Architektura dostępność jest prawdopodobieństwo, że wszystkie połączenia pośrednie będą dostępne w każdej chwili. Dostępność każdego połączenia pośredniego jest ustalana podczas iteracji symulacji Monte Carlo, jednak te połączenia pośrednie (zazwyczaj) opierają się na tym samym zestawie elementów fizycznych. Dlatego też, po prostu sumując te indywidualne ilości dostępnych będzie "double-count" te nie-dostępności, dając pesymistyczne ogólną dostępność architektura. Alternatywnie, ogólna dostępność architektura jest obliczana przez patrząc na każdej iteracji i zobaczyć, czy elementy uczestniczące w pośrednich połączeń zainteresowania są dostępne. A następnie zsumowanie tych wyników na koniec symulacji.

Uruchomienie symulatora niezawodności

Aby symulować architektury pod względem niezawodności

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Wybierz Analiza| Niezawodność.

3. Wybierz Architekturachcesz ocenić z menu rozwijanego.

Notatka

Domyślnie ABACUS automatycznie wybrać pierwszą architekturę, dla których wymagana jest ponowna symulacji z powodu jakiejkolwiek nieruchomości lub zmian strukturalnych.Wyróżnienie jest pokazany na Rudy na Pasek narzędzi Symulacja .

4. Wybierz podzespoły i Znajomościchcesz ocenić z Okno wyboru standardowym elementem za pomocą "Pokaż bezpośrednie połączenia" i "Pokaż procesy połączeń" filtry radiowe przycisk w dolnym lewym rogu okna, aby pomóc z Ciebie wyboru.

Dodatkowy Pole wyboru do Okno wyboru standardowym elementem

· Save Transformed model będzie zapisać kopię RBD przekształconej wersji projektu w tym samym folderze co bieżącego projektu i dołączyć "_transformed" do nazwy projektu.Projekt ten przekształcił można wykorzystać do zdiagnozowania w szczegółach symulację wiarygodność podejmowanych przez ABACUS.

Dodatkowe Radio-Pikolak do Okno wyboru standardowym elementem

· Pokaż bezpośrednie połączenia automatycznie ustawić filtr właściwości połączenia dla właściwości type = name = Zachowanie, abstrakcji i Value = bezpośrednie.Opcja ta jest domyślnie zaznaczona i wspomaga wybór połączeń "bezpośrednia", jak opisano powyżej i poniżej.

· Pokaż Procesy Połączenia automatycznie ustawić filtr właściwości połączenia dla właściwości type = Zachowanie, nazwa = wartość = Związek i procesów.Opcja ta ułatwia ich wybór połączeń "bezpośrednie", jak opisano powyżej i poniżej.

5. Trzask Dalej.

6. Wybierz Misjetj Połączenia chcesz dołączyć do symulacji.

7. Ustaw Run Time Scale Factor suwak.

Notatka

Wyższe wartości dają bardziej spójne wyniki statystycznie dłuższy czas, ale się do obliczenia.

Pola wyboru

· Pokaz Zamknięte Połączenia będzie automatycznie filtrowania dostępnych połączeń tylko obejmują te, które mają co najmniej jedną pełną ścieżkę fizyczną z komponentu źródłowego do elementu docelowego, jak na wybór RBD opisano powyżej.

· Pokaż połączenia pośrednie automatycznie ustawić filtr właściwości połączenia dla właściwości type = name = Zachowanie, abstrakcji i Value = pośrednie.Opcja ta jest domyślnie zaznaczona i wspomaga wybór z "pośrednich" lub Mission połączeń, jak to opisano powyżej i poniżej.

Pikolak

· wszystkowybiera wszystkie znajomości.

· Odwracaćodznacza wszystkie aktualnie wybrany znajomości i wybiera wszystkie te, które nie zostały wybrane.

· Żadenodznacza wszystkie znajomości.

Inne opcje

· Run Time Scale Factor kontroluje czas symulacji i dokładność z wyższym Wydajność wartościingwięcej statystycznie zgodne wyniki, ale nabierający dłuższy czas bieg.

Notatka

Gdy ABACUS oblicza liczbę powtórzeń do symulacji będzie określić najbardziej niezawodny element, który nie jest całkowicie niezawodny i symulacji dla czasów Run Time Scale Factor 1 nad niedostępnością tego elementu plus 1 iteracji. Lub (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. Jest to, aby upewnić się, że element ten nie powiedzie się co najmniej raz w symulacji. Na przykład. Jeśli najbardziej niezawodnym elementem, który nie jest całkowicie niezawodny ma MTBF 10.000 godzin oraz MTTR 8 godzin, a następnie symulacja odbędzie (10000 + 8) / 8 = jeden tysięcy dwieście pięćdziesiąt jeden razy Factor Run czas Skala + 1 iteracji.

· Lat Symulacja Ahead określa liczbę lat na misji Wiarygodność obliczana na.

· Numbra wątkówdetermines liczba wątków przetwarzania w użyciu symulacji Monte-Carlo.Opcja ta będzie domyślnie dopasować liczbę dostępnych CPU / rdzeni (w tym rdzeni Hyper-Threading), aby zminimalizować całkowity czas symulacji.

8. Trzask konieci dostaniesz Ostrzeżenie dialog.

9. Opcjonalnie zwiedzanie ostrzeżenia klikając Szczegóły >>.

10. Trzask kontynułuj.

Notatka

W tym momencie, ABACUS wykona Monte-CarloSymulacja architektury i po krótkim czasie (w paski postępu dla sprzężenia zwrotnego), pojawi się okno dialogowe pełne obliczenia.

11. Trzask okuznać symulacji.

napiwek

Na szkolenia i dalszej pomocy na niezawodności symulacji należy odnieść się do Avolution Społeczność .

Właściwości komponentów i połączeń

Poniższa tabela zawiera komponent oraz 'bezpośredni'Właściwości połączenia wymagane do oceny niezawodności. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wejściowego nieruchomości ( [image] ) Z podpowiedzi "Niezawodność wejścia". Zmiana któregokolwiek z tych właściwości "wejściowych" i różnych zmian strukturalnych do repozytorium spowoduje symulatorze Wiarygodność wymagającej ponownego symulację, jak wskazano w Rudy na Pasek narzędzi Symulacja .

Rodzaj | Imię | Domyślna wartość | Jednostka | Typ danych | Wymagany | Opis
Niezawodność | MTBF | ∞ | lat, tygodni, dni lub godzin | Dziesiętny | Prawdziwe | Średni czas Przed awarii elementu. Uwaga: Wartości te mogą być wyrażone w jednostkach lat, tygodni, dni lub godzin, przekształca się w następstwie '24 / 7 'dostępność koncepcji następujące; - 1 rok = 52 tygodni lub 365 dni lub 8760 godzin - 1 tydzień = 7 dni lub 168 godzin - 1 dzień = 24 godzin
Niezawodność | MTTR | 0 | lat, tygodni, dni lub godzin | Dziesiętny | Prawdziwe | Średni czas do Naprawa elementu. Uwaga: Wartości te mogą być wyrażone w jednostkach lat, tygodni, dni lub godzin, przekształca się w następstwie '24 / 7 'dostępność koncepcji następujące; - 1 rok = 52 tygodni lub 365 dni lub 8760 godzin - 1 tydzień = 7 dni lub 168 godzin - 1 dzień = 24 godzin

Poniższa tabela zawiera komponent oraz 'bezpośredni' Właściwości połączenia Wyjście przez oceniającego niezawodność. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Niezawodność Wyjście". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora wymaga ponownej niezawodności symulację zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Niezawodność | Niezawodność - x lat |  | Dziesiętny | Fałszywe | Prawdopodobieństwo, że element nie zawiedzie w ciągu najbliższych x lat. Jest to wartość między 0 i 1.
Niezawodność | Zawodność - x lat |  | Dziesiętny | Fałszywe | Prawdopodobieństwo, że element nie powiedzie się w ciągu najbliższych x lat. Jest to wartość między 0 i 1.
Niezawodność | Dostępność | % | Dziesiętny | Fałszywe | Obliczona dostępność składnika lub połączenia. Jest to wartość, od 0% do 100%.
Niezawodność | Niedostępność | % | Dziesiętny | Fałszywe | Obliczona niedostępność składnika lub połączenia. Jest to wartość, od 0% do 100%.

Poniższa tabela zawiera listę 'pośredni'Właściwości połączenia Wyjście przez oceniającego niezawodność. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Niezawodność Wyjście". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora wymaga ponownej niezawodności symulację zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Niezawodność | Misja Niezawodność - x lat |  | Dziesiętny | Fałszywe | Prawdopodobieństwo, że połączenie pośrednie nie zawiedzie w ciągu najbliższych x lat. Jest to wartość między 0 i 1.
Niezawodność | Misja Zawodność - x lat |  | Dziesiętny | Fałszywe | Prawdopodobieństwo, że połączenie pośrednie nie powiedzie się w ciągu najbliższych x lat. Jest to wartość między 0 i 1.
Niezawodność | Dostępność | % | Dziesiętny | Fałszywe | Obliczona dostępność związku pośredniego. Jest to wartość, od 0% do 100%.
Niezawodność | Niedostępność | % | Dziesiętny | Fałszywe | Obliczona niedostępność związku pośredniego. Jest to wartość, od 0% do 100%.

Obiekty architektury

Poniższa tabela zawiera listę właściwości architektura wyjście przez oceniającego niezawodność. Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Niezawodność Wyjście". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu nieruchomość lub zmian strukturalnych do repozytorium i symulatora wymaga ponownej niezawodności symulację zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Jednostka | Typ danych | Wymagany | Opis
Niezawodność | Dostępność | % | Dziesiętny | Fałszywe | Dostępność wszystkich połączeń pośrednich, które zostały uwzględnione w ocenie. Oznacza to, że prawdopodobieństwo wszyscyPołączenia pośrednie będą dostępne w danym momencie. Jest to wartość, od 0% do 100%. Uwaga: To nie jest mnożenie poszczególnych Wolne połączenia jak to będzie "podwójnego liczenia" ONZ-dostępności odpowiednich składników.
Niezawodność | Niedostępność | % | Dziesiętny | Fałszywe | Niedostępność połączeń pośrednich, które zostały uwzględnione w ocenie. Oznacza to, że prawdopodobieństwo chociaż jedenPodłączenie pośrednie będą niedostępne w danym momencie. Jest to wartość, od 0% do 100%. Uwaga: To nie jest mnożenie poszczególnych unavailabilities połączenia jak to będzie "podwójnego liczenia" ONZ-dostępności odpowiednich składników.
Niezawodność | Misja Niezawodność - x lat |  | Dziesiętny | Fałszywe | Prawdopodobieństwo, że wszystkie połączenia pośrednie, które zostały uwzględnione w ocenie nie powiedzie się w ciągu następnych xlat. Jest to wartość pomiędzy 0 a 1. Uwaga: nie jest mnożenie poszczególnych reliabilities połączenia jak to będzie "podwójnego liczenia" ONZ-dostępności odpowiednich składników.
Niezawodność | Misja Zawodność - x lat |  | Dziesiętny | Fałszywe | Prawdopodobieństwo, że co najmniej jedno z połączeń pośrednich, które zostały włączone do oceny nie powiedzie się w ciągu następnych xlat. Jest to wartość pomiędzy 0 a 1. Uwaga: nie jest mnożenie poszczególnych unreliabilities połączenia jak to będzie "podwójnego liczenia" ONZ-dostępności odpowiednich składników.


Symulacja Otwartość

Nawigacja: Symulacja swoją architekturę> Symulatory>

Symulacja Otwartość

Wyślij komentarzy w tym temacie.

Symulator otwarcie określa stopień, do którego architektura i jej elementy są "otwarte", to jest zdolność systemu do obsługi wymiany elementów o minimalnym wpływie.

Aby symulować architektury pod względem otwartości

1. Sprawdź, czy masz plik ABACUS, Zawierający Twój zaludnionych architektury, Otwarte.

2. Wybierz Analizy | Otwartość.

3. Wybierz Architecture (s)chcesz dołączyć do oceny.

Notatka

Domyślnie ABACUS automatycznie wybrać pierwszą architekturę, dla których wymagana jest ponowna symulacji z powodu jakiejkolwiek nieruchomości lub zmian strukturalnych.Wyróżnienie jest pokazany na Rudy na Pasek narzędzi Symulacja .

4. Trzask konieci dostaniesz Ostrzeżenie dialog.

5. Opcjonalnie zwiedzanie ostrzeżenia klikając Szczegóły >>.

6. Trzask kontynułuj.

Notatka

W tym momencie, ABACUS wykona strukturalnej oceny architektury (s) i po krótkim czasie (w paski postępu dla sprzężenia zwrotnego), pojawi się okno dialogowe pełne obliczenia.

7. Trzask okuznać symulacji.

napiwek

Na szkolenia i dalszej pomocy na otwartości oceny należy odnieść się do Avolution Społeczność .

Właściwości komponentów i połączeń Standardowe

Poniższa tabela zawiera listę właściwości standardowych komponentów i połączenia wymagane do oceny otwartości.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wejściowego nieruchomości ( [image] ) Z podpowiedzi "Otwartość wejścia". Zmiana któregokolwiek z tych właściwości "wejść" w repozytorium spowoduje symulatorze Otwartości wymagającej ponownego symulację, jak wskazano w Rudy na Pasek narzędzi Symulacja .

Rodzaj | Imię | Domyślna wartość | Jednostka | Typ danych | Wymagany | Opis
Otwartość | Standardy-Standard Dojrzałość-Organizacja Poziom |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Poziom odpowiedzialnej Standardów Ciała 0:Organizacyjna / Proprietary 1:Konsorcjum / DEFACTO 2:Narodowy / Wojskowy 3: Międzynarodowy
Otwartość | Standardy-Standard Dojrzałość-Stan |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Zatwierdzenie osiągnąć poziom z normami ciała 0:Pracy / Komitet Projekt 1:Projekt publiczny / Balloted 2:Tymczasowy Projekt 3: Zatwierdzony
Otwartość | Standardy-Standard Dojrzałość-Stabilność |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Czy średnia może się zmienić? 0:Standardowy nieaktualne 1:Bardzo ulec zmianie w przyszłym 1 do 2 lat 2:Znane zmiany / aktualizacje do istniejących funkcji 3:Bardzo stabilny (bez zmian w ciągu 2 lat)
Otwartość | Standardy-Standard Support Dojrzałość-Vendor |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Wsparcie sprzedawca 0:Brak produktów lub sprzedawców obsługuje standardu 1:Jednego lub więcej dostawców implementujące część standardu 2:Więcej niż jednego dostawcy z produktów, które realizują wszystkie części standardu 3:Wiele więcej niż jednego dostawcy z produktów, które realizują wszystkie części standardu
Otwartość | Standardy-Standard jednoznaczność-Dokumentacja |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Jakość standardowej dokumentacji 0: Ubogi 1: Sprawiedliwe 2: Dobry 3: Doskonały
Otwartość | Standardy-Standard jednoznaczność-Standard Szerokość |  |  | Liczba całkowita | Fałszywe | Szereg funkcji. Liczenie z najniższych poziom standardowych funkcji - Sf
Otwartość | Standardy-Standard jednoznaczność-Sm |  | % | Dziesiętny | Fałszywe | Procentowy udział ogólnej liczby funkcji, które są obowiązkowe
Otwartość | Standardy-Standard jednoznaczność-Tak |  | % | Dziesiętny | Fałszywe | Procentowy udział ogólnej liczby funkcji, które są opcjonalne
Otwartość | Standardy-Standard jednoznaczność-Sc |  | % | Dziesiętny | Fałszywe | Procentowy udział ogólnej liczby funkcji, które są warunkowo określona
Otwartość | Profile-Profil Dokumentacja-Dokumentacja |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Jakość standardowej dokumentacji 0: Żaden 1: Ubogi 2: Sprawiedliwe 3: Doskonały
Otwartość | Profile-Profil Dokumentacja-Dokładność |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Czy dokumentacja odzwierciedlać rzeczywisty projekt systemu? Jaki poziom cech profilu są wykorzystywane w systemie? 0:Brak funkcji 1:Niektóre funkcje 2:Większość funkcji 3:Wszystkie funkcje
Otwartość | Profile-Profil Dokumentacja terminu wymagalności |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Czy profil dojrzały i dostępne? 0: Doraźnie 1:Na podstawie projektu 2:Organizacyjna 3: Publiczny
Otwartość | Profile-Profil jednoznaczność-Explicit Szerokość |  |  | Liczba całkowita | Fałszywe | Liczba standardowych funkcji zgodnie z wymaganiami określonymi w profilu
Otwartość | Profile-Profil jednoznaczność-Pm |  | % | Dziesiętny | Fałszywe | Odsetek niezbędne funkcje w profilu
Otwartość | Profile-Profil jednoznaczność-Po |  | % | Dziesiętny | Fałszywe | Odsetek opcjonalnie wyposażony w profilu
Otwartość | Profile-Profil jednoznaczność-Pc |  | % | Dziesiętny | Fałszywe | Procent zdefiniowana warunkowo funkcje w profilu
Otwartość | Profile-Profil jednoznaczność-Coverage |  | % | Dziesiętny | Fałszywe | Odsetek standardowych funkcji adresowanych specjalnie w profilu
Otwartość | Rozszerzenia-profile-Profil przedłużający Szerokość |  |  | Liczba całkowita | Fałszywe | Ilość niestandardowe funkcje określone przez profil
Otwartość | Profile-Profil Rozszerzenia-Coverage |  | % | Dziesiętny | Fałszywe | Procent rozszerzeń szczegółowo w profilu
Otwartość | Dostępność produktów i produkty-Zgodność-Ilość produktów |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Liczba produktów wspieranie niezbędne funkcje standardu 0:Brak produktów obsługiwać standard 1:Jeden lub więcej produktów realizacji część standardu 2:Więcej niż jeden produkt realizuje wszystkie części standardu 3:Wiele więcej niż jeden produkt realizuje wszystkie części standardu
Otwartość | Dostępność produktów i produkty-Zgodność Zgodność-Application |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Jaki poziom zgodności czy produkty mają w standardzie? 0: Żaden 1:Twierdził 2:Wykazać 3:Certyfikowany i wykazać
Otwartość | Dostępność produktów i produkty, Zgodność ze standardami jakości |  | [0 | 1 | 2 | 3] | Lookup / Lista | Fałszywe | Jakość testów zgodności 0: Żaden 1:Testy w domu przez dewelopera produktu 2:Niezależne testy (np NIST) 3:Wykazano w kontekście danego produktu

Komponent, połączenie i właściwości Architektura

Poniższa tabela zawiera składnika połączenie właściwości architektura i wyjście przez oceniającego otwartości. Wszystkie z następujących właściwości ocenia się między 0 (zero) i trzy (3), zero (0), jest najmniej pożądane, a trzy (3), przy czym najbardziej pożądane.Właściwości te będą wyświetlane w oknie Właściwości z ikoną selektor wiersza wyjście nieruchomość ( [image] ) Z podpowiedzi "Otwartość Wyjście". Strzałka na ikonę podkreśli Rudy ( [image] ), Gdy właściwości te są nieaktualne z powodu zmiany bazowego nieruchomości do repozytorium i symulatora Otwartości wymaga ponownej symulacji zgodnie z Rudy podkreślając na Pasek narzędzi Symulacja .

Rodzaj | Imię | Typ danych | Wymagany | Opis
Otwartość | Otwartość | Dziesiętny | Fałszywe | Ogólna ocena otwartości elementu.
Otwartość | Standardy-Standard Dojrzałość | Dziesiętny | Fałszywe | Obecny stan standardzie, co odzwierciedla tego, czy został on zatwierdzony, jak długo był w użyciu i jak dobrze przyjmowana jest w społeczności programistów.
Otwartość | Standardy-Standard jednoznaczność | Dziesiętny | Fałszywe | Jednoznaczność standardów, co odzwierciedla potencjalne niejednoznaczności standardów wynikających
Otwartość | Profile-Profil Dokumentacja | Dziesiętny | Fałszywe | Zakres, w jakim profil interfejs dokumentacji opracowany i czy dokumentacja profil odzwierciedla rzeczywistą projekt systemu i / lub wdrożony system
Otwartość | Profile-Profil jednoznaczność | Dziesiętny | Fałszywe | Poziom szczegółowości przewidziane w specyfikacji profilu / profili
Otwartość | Profile-Profil Rozszerzenia | Dziesiętny | Fałszywe | Stopień, w którym profil zgodny z normą, w którym jest ona oparta
Otwartość | Produkty-Product i zgodności | Dziesiętny | Fałszywe | Czy nie są otwarte standardowe produkty zgodne z normą dostępne do wykorzystania w projekcie


Raporty standardowe

Nawigacja: Zgłaszanie od architektury>

Raporty standardowe

Wyślij komentarzy w tym temacie.

LICZYDŁO' standard raporty pozwalają uzyskać listę komponentów i połączeń w jednej lub więcej swoich architektur. Raport zawiera wszystkie informacje dotyczące elementów i połączeń wybranych, w tym informacji na temat komponentu lub miejsce połączenia w hierarchii typu, norm, opis, właściwości i jego załączników.

Notatka

Treść raportu jestkonfigurowalneRaport z okna dialogowego Opcje opisane poniżej, jednak tO dowiedzieć się więcej informacji na temat tworzenia w pełni konfigurowalna na zamówienie raportyRaporty niestandardowe za pomocą ABACUS, proszę odnoszą się do tematu tutaj lub Skontaktuj się Wsparcie Avolution .

Jak wyświetlić standard raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury(e).

2. Wybierz Wstawić| Zgłoś Standardowylub kliknij Utwórz raport Standardowy przycisk paska narzędzi. Raport konfiguracjipojawi się okno.

Okno konfiguracji Zgłoś

3. Wybierz Architektur, podzespoły i Znajomościże chcesz się w sprawozdaniu z Zgłoś Okno konfiguracji.Proszę odnieść się do selekcji elementów standardowego tutaj wątek o pomoc.

4. Teraz kliknij OpcjePrzycisk i Opcje raportuwyświetlane jest okno.

Okno Opcje Zgłoś

5. Możesz wybrać do wyświetlania Nowa strona dla każdego elementuThe Data wydruku, Czas wydruku, Numery stronoraz czy zawierać tytuł w nagłówkuraportu, zaznaczając / odznaczając odpowiednie pola wyboru. Można również dostosować tytuł i autora, edytując Tytuł raportu i Autor pola tekstowe. Możesz także wybrać, jaka treść jest wyświetlana w raporcie, zaznaczając / odznaczając pola wyboru pod Informowanie o treścisekcja okna. Po zakończeniu kliknij ok.

6. Teraz kliknij na koniecw oknie Configuration Report.

Do interpretacji raport widoczny

Przykład wygenerowany raport z krótkimi opisami

Aby poruszać się po stronach raportu, kliknij na ikony [image] znajduje się na pasku narzędzi w górnym lewym rogu ekranu.

Notatka

Możesz ratować raport do różnych formatów klikając na Eksport Raport icon [image] usytuowany w pasek narzędzi. Możesz wybrać, aby eksportować w następujących formatach: Przewyższać, PDF i Słowo, Proszę zapisać raport w żądanym miejscu do późniejszego wykorzystania. W przypadku wprowadzenia zmian do architektury na późniejszym etapie, nowy raport będzie musiał zostać stworzony w celu odzwierciedlenia zmian.

Zobacz też

Analizując swoją architekturę


Raporty niestandardowe

Nawigacja: Zgłaszanie od architektury>

Raporty niestandardowe

Wyślij komentarzy w tym temacie.

Raporty niestandardowe Abacus "pozwalają na tworzenie w pełni konfigurowalne raporty niestandardowe. Raporty mogą zawierać niestandardowe obrazy i grafikę, a także szczegółowo wszystkie elementy, połączenia lub atrybuty z repozytorium ABACUS oraz szczegółowych analitycznych wyników z różnych symulacji (w tym TCO, wydajności i niezawodności). Dodatkowo, raporty mogą zawierać diagramy, wykresy, katalogi, macierze / tabel przestawnych, mapy, manometry, Wykresy, barów i wskaźniki danych (np światłach).

Notatka

Choć każdy użytkownik może otwierać istniejące raporty niestandardowe, to configure raporty potrzebuje licencja użytkownika pozwala Raport konfiguracji zdolność. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

Jak wyświetlić zwyczaj raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury(e).

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowepojawi się okno.

Raporty niestandardowe okno

3. Wybierz istniejący Raportże chcesz do wyświetlenia z Dostępne Raporty sekcja.

4. Trzask Uruchom raport.Raport zostanie otwarty w programie Microsoft Report Viewer i to Nawigowanie po stronach raportu, kliknij na ikony [image] znajduje się na pasku narzędzi w górnym lewym rogu ekranu.

Notatka

Możesz ratować raport do różnych formatów klikając na Eksport Raport icon [image] usytuowany w pasek narzędzi. Możesz wybrać, aby eksportować w następujących formatach: Przewyższać, PDF i Słowo, Proszę zapisać raport w żądanym miejscu do późniejszego wykorzystania. W przypadku wprowadzenia zmian do architektury na późniejszym etapie, nowy raport będzie musiał zostać stworzony w celu odzwierciedlenia zmian.

Do edytować dane repozytorium, który jest wysyłany do a zwyczaj raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury(e).

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowe okno (pokazane powyżej) będzie wyświetlany.

Notatka

Choć każdy użytkownik może otwierać istniejące raporty niestandardowe, to configure Dane, które są przesyłane do raportu niestandardowego potrzebuje licencja użytkownika pozwala Raport konfiguracji zdolność. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

3. Wybierz istniejący Raportże chcesz do wyświetlenia z Dostępne Raporty sekcja.

4. Trzask Zestawy Edycja danych. Data Set Editorpojawi się okno.To okno pokazuje kolekcję zbiorów danych, które są obecnie wysyłane do raportu niestandardowego. W poniższym przykładzie są trzy (3);

· zestaw danych ApplicationProxy, że jest określenie wszystkich szczegółów dla wszystkich komponentów aplikacji w "2015" rzeczywista architektury (w tym nieruchomości na ich standardy i wszystkie podłączone komponenty),

· zestaw danych TwoDViewProxy, że jest określenie jednego lub więcej Schematy których nazwa pasuje "Application Landscape (Australia)",

· TargetProxy zestaw danych, który podając wszystkie szczegóły dla wszystkich połączeń docelowej w "2015" rzeczywista architektury (w tym dołączonych elementów).

Data Set Editor okno

Notatka

Nazwa kwerendy będą wykorzystywane do nazwy zestawu danych w programie Microsoft Report Builder (patrz poniżej). Pole Dołącz określa, czy zbiór danych jest albo pojedynczy, zbiorem elementów, wszystkie składowe Rodzaje, wszystkie rodzaje połączeń, jeden lub więcej architektury, jeden lub więcej schematów i jeden lub więcej Charts. Do "kolekcji elementów" zbiorów danych przycisk Filtr jest, który po kliknięciu otwiera okno Filter element, który pozwala na zastosowanie wielu filtrów, aby powrócić tylko elementy z niektórych architektur, i / lub niektórych rodzajów i / lub z niektórymi normami i / lub dołączone do niektórych części i / lub z niektórych rodziców, i / lub w pewnych schematów, i / lub w pewnych Charts i / lub z podanych wartości nieruchomości. Dla innych typów zestawów danych pole Nazwa jest i za pomocą przycisku Wybierz możesz wybrać obiekt (-y) być dołączony do zestawu danych.

Notatka

Zestawy danych są przechowywane wDane Ustawia plik (.xml)o tej samej nazwie pliku bazowa jako na związane Zgłoś pliku definicji (.RDL), Jeśli ten plik nie istnieje zestaw danych edytor automatycznie wypełnianie wszelkich nazw zapytań, które istnieją w Zgłoś pliku definicji (.RDL)a new Dane Ustawia plik (.xml)zostanie utworzone, gdy aa obowiązuje lista zapytań jest zdefiniowana.

3. Jeśli chcesz usunąć istniejący zestaw danych, a następnie wybierz DELETE przycisk.

4. Jeśli chcesz dodać nowy zestaw danych, a następnie kliknij Dodaj nowy zestaw danychPrzycisk i skonfigurować dane określone zgodnie z uwagą powyżej.

Do utworzyć nowy zwyczaj raport(od szablonu)

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowe okno (pokazane powyżej) będzie wyświetlany.

3. Trzask Nowy i wybierz opcję A4 - Portret, A4 Krajobraz, A3 - Portret, Formatu A3 Krajobraz, US Letter - Portret, US Letter - Krajobraz, US Tabloid - Portret lub US Tabloid - Krajobrazw zależności od orientacji raport i rozmiaru papieru, który jest pożądany.

4. Przejdź do lokalizacji, aby zapisać plik definicji raportu (rdl / .rdlc) oraz pasujący plik zestawu danych (.xml), a następnie kliknij Ratować, Spowoduje to dodanie nowego niestandardowego sprawozdanie Dostępne sekcji Raporty okna niestandardowych raportów i można go otworzyć lub edytować w sposób opisany powyżej.

Do dodać istniejący zwyczaj raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowe okno (pokazane powyżej) będzie wyświetlany.

3. Trzask Dodaj i przejdź do lokalizacji pliku definicji raportu (rdl / .rdlc) i kliknij Otwarte, Spowoduje to dodanie nowego niestandardowego sprawozdanie Dostępne sekcji Raporty okna niestandardowych raportów i można go otworzyć lub edytować w sposób opisany powyżej.

Notatka

Zakłada się, że istnieje plik Set dopasowanie danych (.xml) w tym samym miejscu co plik Report Definition.

Do skopiować istniejący zwyczaj raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowe okno (pokazane powyżej) będzie wyświetlany.

3. Wybierz istniejący Raportże chcesz kopiować z Dostępne Raporty sekcja.

4. Trzask Kopiuj oraz kopię wybranego raportu (o nazwie "Kopia ...") zostanie dodana do sekcji Dostępne Raporty okna niestandardowych raportów i można go otworzyć lub edytować w sposób opisany powyżej.

Notatka

W ten sposób można utworzyć kopię sprawozdania na Zgłoś Definicja plik (rdl / .rdlc) jak również jego zbiór danych dopasowanie pliku (.xml)(jeśli istnieje).

Do usunąć istniejący zwyczaj raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowe okno (pokazane powyżej) będzie wyświetlany.

3. Wybierz istniejący Raportże chcesz Usunąc z Dostępne Raportysekcji i kliknij Usunąć.

Notatka

Po usunięciu raport nie będzie już pojawiać się na liście raportów. Jednakże, to nie będzie usunąć raportu Report Definition plik (rdl / .rdlc) albo Zbiór danych plik(.xml), Jeśli to konieczne, usunięcie tych plików można osiągnąć poprzez system plików.

Do zmienić nazwę istniejącego zwyczaju raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowe okno (pokazane powyżej) będzie wyświetlany.

3. Wybierz istniejący Raportże chcesz aby zmienić nazwę w Dostępne Raportysekcji i kliknij Przemianować.

4. Wprowadź nową nazwę dla raportu.

Notatka

Zarówno plik definicji raportu (rdl / .rdlc) oraz zbiór danych dopasowanie pliku (.xml) zostanie odpowiednio zmieniona.

Do edytować projektowaniu zwyczaj raport

1. Sprawdź, czy jest Plik ABACUS otwarta zawierające swojej zaludnionych architektury.

2. Wybierz Wstawić| Custom Reportlub kliknij Utwórz raport niestandardowy przycisk paska narzędzi. Raporty niestandardowe okno (pokazane powyżej) będzie wyświetlany.

Notatka

Choć każdy użytkownik może otwierać istniejące raporty niestandardowe, to configure projektowaniu niestandardowych raportów potrzebuje licencja użytkownika pozwala Raport konfiguracji zdolność. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.Dodatkowo, Microsoft Report Builder 3.0 jest wymagane do projektowania raportów i można go pobrać za darmo z tutaj .

3. Wybierz istniejący Raportże chcesz do wyświetlenia z Dostępne Raporty sekcja.

4. Trzask Edycja Zgłoś.Raport zostanie otwarty w programie Microsoft Report Builder 3.0. Dla konkretnej pomocy i niektórych "poradami" na niektóre z bardziej typowych zadań z projektowania raportów znajdują się w poniższych sekcjach. Aby uzyskać pomoc na temat ogólnego raportów projektowych proszę odnieś się na stronach Microsoft Report Builder 3.0 pomocy tutaj .

Dodawanie tabel do raportu

1. Sprawdź, czy masz Raport ABACUS plik Niestandardowe rozdzielczości (rdl / .rdlc) otwarty w programie Microsoft Report Builder 3.0.

2. Wybierz Wstawić w zakładce "wstążką" u góry, a następnie Kliknij Stół przyciskw sekcji danych regionów i wybierz Wstaw tabelę.

3. Ale już przeciągnij kursordo położenia na płótnie raportu, w którym chcesz lewy górny róg tabeli umieszczone. Kliknij na płótnie, Domyślnie tabela zostanie dodana w wierszu nagłówka, a następnie grupy szczegółów (grupa służy do organizowania się widok zestawu danych raportu). Aby usunąć grupę, albo usunąć wiersz lub usunąć grupę wierszy na pasku narzędzi Grupowanie.

napiweks

Wzory / wyrażenia w komórkach tabeli są edytowane wybierając komórkę, a następnie kliknij prawym przyciskiem myszy << Expr >> tekst i wybierając wyrażenie .... Sortowanie wierszy w tabeli odbywa się poprzez wybranie z tabeli, a następnie w dół do przeglądania Inne -> SortExpressions pola w panelu Właściwości i wprowadzając wyrażenie. Za łączną rzędu na końcu tabeli dodać wiersz po (i na zewnątrz), grupowanie, a następnie użyć następującego wyrażenia = Sum (Fields!Imię.Wartość)gdzie "Nazwa" jest polem są sumowane. Aby zastosować kolorystykę do kolumny użyć "IIf" oświadczenie w nieruchomości BackgroundColor. Aby dodać wskaźnik jako komórka w tabeli, należy najpierw włożyć wskaźnik do komórki, a następnie upuść pola danych niezbędnych do miernika. Podczas edycji wysokości i szerokości wierszy tabeli, upewnij się wybrać odpowiedni wiersz, a następnie umieść kursor myszy wokół szarych linii, aż pojawi się góra / dół kursora, a następnie zmienić rozmiar.

Dodawanie wykresów do raportu

1. Sprawdź, czy masz Sprawozdanie z pliku definicji ABACUS klienta (rdl / .rdlc) otwarty w programie Microsoft Report Builder 3.0.

2. Wybierz Wstawić w zakładce "wstążką" u góry, a następnie Kliknij Wykres przyciskw sekcji danych regionów i wybierz Wykres Wstaw.

3. Ale już przeciągnij kursordo położenia na płótnie raportu, w którym chcesz się w lewym górnym rogu wykresu, aby umieścić. Kliknij na płótnie i wtedy Wybierz wykreswymagać od opcji i kliknięcie ok.

napiweks

Aby wyświetlić właściwości jako adnotacji na wykresach, kliknij prawym przyciskiem myszy na wykresie i wybierz Etykiety pokazują dane, a następnie wybrać jedną z etykiet, które zostały dodane i ustaw Różne -> UseValueAsLabel False w panelu Właściwości i dodać wyrażenie (np = Pola Name.Value) w Misc -> Label. Specjalnie dla Wykresy bąbelkowe; Bubble wykresy wyświetlane są pod nagłówkiem wykres punktowy. Rzuć X oś do pól własności serii (lub dodać w oknie Właściwości serii). Oś Y nieruchomości spadnie do pól danych (lub dodać w oknie Właściwości serii). Aby korzystać z nieruchomości w celu określenia wielkości pęcherzyków, spadek ten w pola danych (lub dodać w oknie Właściwości serii). Bubble wykresy nie są w stanie wyświetlić, jeśli nie jest zbyt dużo danych (ponad 200 pozycji), czasami to powoduje, że cały raport nie wyświetlać. Marker Type - Zestaw do okręgu. Domyślnie, gdy spada pól do pól danych, dodaje je z podsumować()Formuła, więc usunięcie tego. Specjalnie dla Ułożone wykresy / Timeline / wykresy Gantta; Na wykresie Gantta użyć wykresu zakres i dodać właściwości, jak wysokie i niskie wartości w polach danych. Można mieć wiele "bary", dodając coraz więcej zakresów, gdzie Niska wartość dla jednego mecze wysoką wartość dla drugiego. Specjalnie dla Wykresy kołowe; Dla kruszywa wykresów kołowych, spadek dane do pól Kategoria i pól danych, należy dodać formułę = CountRows (), Odfiltrować żadnych 0 wartości (na przykład na wykresach kosztów), w przeciwnym razie etykiety dla nich wciąż będą wyświetlane na wykresie.

Korzystanie oświadczenie IIF dodać kolory do tabel i wykresów

1. Sprawdź, czy masz Sprawozdanie z pliku definicji ABACUS klienta (rdl / .rdlc) otwarty w programie Microsoft Report Builder 3.0.

2. Kliknij prawym przyciskiem myszy komórkę w tabeli, aby kolor i kliknij Właściwości pola tekstowego.

3. Wybierz Wypełniać i kliknij fxPrzycisk po prawej stronie etykiety Kolor wypełnienia oraz Ustaw wyraz na polu BackgroundColor wprowadzić wyrażenie, np = IIF (Fields! InformationStatus.Value = "Zachowaj", "jasnozielony", IIF (Fields! InformationStatus.Value = "Redesign", "Żółty", IIF (Fields! InformationStatus.Value = "Refresh", "Orange", " Łosoś"))), Zmienia kolor tła na zielone światło dla każdej komórki, który zawiera status "zachowują", żółty dla każdej komórki, który zawiera status "Redesign" Orange dla każdej komórki, który zawiera status "Refresh" oraz wszelkie inne wartości stan będzie kolorowy w 'Salmon ".

Notatka

Kolory mogą być dodawane do wykresów wybierając serii na wykresie, a następnie ustawienie wyglądu -> właściwości kolorów (lub wykresów bąbelkowych wygląd -> Marker -> właściwość Kolor), aby wyraz podobny do powyższego przykładu.

Rzeczy pamiętać przy projektowaniu niestandardowych raportów

· Ponieważ wszystkie obiekty z wyjątkiem Integer wysyłane są jako łańcuch z ABACUS do widza raportu, jeśli chcesz zrobić jakieś "wyrażenia" z nimi (jak podzielić jedną właściwość przez inny lub sortowania) trzeba je przekonwertować na dziesiętny lub data itp Na tle , Ten artykuł jest dobre referencje. Na przykład. = CDate (Fields! LifecycleEndDate.Value) Notatka: Proszę upewnić się, że język raportu jest ustawiony na pl-PL (jak opisano poniżej), aby zaakceptować dd / mm / rrrr ponieważ oczekuje formacie dd / mm / rrrr domyślnie i odpowiednio 31/7/2011 zawiedzie konwersji. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Jeśli stwierdzisz, że jesteś stara się utrzymać wszystkich tabel i wykresów na jednej stronie, Istnieje kilka głównych sposobów zarządzania miejsca dokumentu:

· Podział strony - Upewnij się, że ta opcja jest wyłączona tabeli dla każdej tabeli, którą chcesz być na tej samej stronie.

· Trzymać się razem - Sprawdź to ustawienie tabeli jest prawda dla każdej tabeli, którą chcesz być na tej samej stronie.

· Podczas przenoszenia rzeczy wokół, łatwiej jest pomniejszyć za pomocą sterowania w prawym dolnym rogu strony, a następnie wielu wyboru elementów i przeciągnij

· Dla wiersza obrazu w tabeli, upewnij się, że "wielkość" | Nieruchomość "wielkości" jest ustawiony na "Fit" w przeciwnym przypadku obraz może wydawać się zbyt duże, albo będzie źle rozciągnięty.

· Do powtarzam wiersz nagłówka tabeli na każdej stronieraportu:

1. Otwórz Tryb zaawansowany w okienku ugrupowań. (Kliknij na strzałkę po prawej stronie kolumny grup i wybierz opcję Tryb zaawansowany).

2. W obszarze Grupy wierszy (nie Kolumna grup), kliknij na statyczne grupy, która podkreśla odpowiednie pole tekstowe w tablix. Kliknij po każdej grupy Static aż podkreśla skrajną lewą nagłówek kolumny. Na ogół jest to pierwsza grupa Static wymienione.

3. W oknie Właściwości ustaw właściwość RepeatOnNewPage True.

4. Upewnij się, że nieruchomość KeepWithGroup jest ustawione na Po.

· Zmienić ustawienia językaw nieruchomości Raport dopasować formatów danych, które wymagają, np pl-PL do produkcji brytyjskiego formatu daty (dd / mm / rrrr).

Zobacz też

Analizując swoją architekturę


Publikowanie w sieci

Nawigacja: Zgłaszanie od architektury>

Publikowanie w sieci

Wyślij komentarzy w tym temacie.

ABACUS "Publikowanie w sieci Web umożliwia funkcja modele architektoniczne do oglądania za pośrednictwem bezpiecznego stronie internetowej. Architektury są eksportowane do formatu HTML i są zaprojektowane tak, aby odzwierciedlać wygląd i Eksploratora w ABACUS. Odsłon (w tym katalogi, schematy, 3D i wykresy) są również eksportowane do formatów do oglądania za pomocą przeglądarki internetowej.

Notatka

Obecnie Punkty widzenia i macierze nie są publikowane.

Do publikowania modeli architektonicznych w internecie

1. Sprawdź, czy masz odpowiednie Plik ABACUSotwarty, zawierający zaludnionych architekturyktóre chcesz opublikować w internecie.

2. Wybierz Plik| Publikować....

3. Publikowanie do Konfiguracja sieciwyświetlane jest okno.

Publikowanie w konfiguracji sieci

4. Domyślnie wszystkie części modelu są wybierane w tym drzewa widzenia Standardy, Rodzajów, szablony i Architektura (s). Usuń zaznaczenie żadnych części, których nie chcesz, aby publikować w internecie, w tym wszelkich indywidualnych poglądów w ramach architektury (ów).

napiwek

Jeśli chcesz ukryć konkretnych składników, połączeń i / lub ich właściwości zaleca się, aby administrator tworzy rolę, a "publicznego" za pomocą Funkcja dostępu w oparciu o role Abacus " a następnie usuwa uprawnienie Odczyt z tych typów komponentów, rodzajów połączeń i / lub właściwości, które nie chcą, aby zostać opublikowane. Następnie użytkownik powinien zalogować się w ramach tej roli i publikuje na sieci Web jako ABACUS opublikuje tylko elementy, które zostały ustawione uprawnienia do odczytu do tej roli. Ponadto, użytkownicy mogą automatycznie publikować z linii poleceń, jak opisano tutaj .

Notatka

Możesz wybrać wszystkie części wyświetlane przez kliknięcie na wszystkoprzycisk lub odwrócić zaznaczenie, klikając na Odwracać przycisk. Możesz też kliknąć na przycisk Żadenprzycisk, aby usunąć wybór.

Notatka

Jeśli ty odznacz opcję Widok drzewato nie rama drzewa (patrz poniżej) zostanie opublikowany. Odpowiednio, należy wybrać stronę startową zgodnie kroku 6 poniżej, lub po opublikowaniu trzeba będzie dostosować albo najwyższego poziomu; za) index.htmlPlik zmieniając 'ramki src = "mainPage.html" name = "element_details" "linii bezpośrednio odwołuje się do odpowiedniej strony html w folderze Content, lub, b) mainPage.htmlpoprzez zapewnienie hiperłącze lub przekierowanie do odpowiedniej strony html w folderze Content.

5. Kliknij Opcja przycisk i po Opcje Wydawcadialogowe wyświetli.

PublikowaćOpcje er

6. Swybiera 3D, Diagrami formaty Wykresy i czy pokazać tytuł, opis lub Właściwości dla widokami z dostępnych opcji (patrz poniższa uwaga dla komentarzy do różnych formatów).

7. Jeśli chcesz ustawić stronę startową opublikowaną do konkretnego modelu widoku to sprawdzić Użyj Zobacz jako stronę startowąopcji i przejdź do widoku poprzez przycisk '...', który staje się aktywny.

Notatka

Tylko poglądy wybranych w sekcji obszarów, jak na punkcie 4 powyżej są dostępne do ustawienia jako strony startowej.

8. Jeśli chcesz otrzymywać informację na temat konkretnych stron w opublikowanej modelu następnie upewnij się, że Email Odpowiedzopcja jest zaznaczona, wpisz adres e-mail w Adres email pole tekstowei edytować E-mail ciałaSekcja odpowiednio, Jeśli nie chcesz mieć informacje zwrotne wysłane i wyłącz Email Odpowiedzopcji i pozostawić pole tekstowe puste.

9. Kliknij na ok przycisk.

10. Kliknij na Paść się przycisk.

11. Wyszukaj folderwyświetlane jest okno.

12. Wybierz lokalizację, w której chcesz zapisać plik HTML najwyższego poziomu (oraz automatycznie generowanych plików).

Notatka

To jest dobry pomysł, aby utworzyć specjalny katalog (zwykle nazywane "Opublikowano") przy użyciu Utwórz nowy folderprzycisk na dole okna, aby zapisać plik HTML najwyższego poziomu i wszystkie automatycznie generowane pliki.

13. Kliknij na ok przycisk.

14. Ścieżka folderu zostanie wyświetlona w Informator pole tekstowe.

15. Kliknij na koniec przycisk.

- lub -

15. Wpisz ścieżkę do folderu w Informatorpole tekstowe, w którym chcesz zapisać plik HTML najwyższego poziomu (oraz automatycznie generowanych plików).

16. Kliknij na koniec przycisk.

Notatka

Eksport Schematybardzo rzadko zawodzi, najczęściej, gdy komputer znajduje się pamięci (zazwyczaj przy użyciu bardzo dużych plików). Nieudany eksport zostanie ponowiona raz. Będzie się ostrzeżenie o nieudanej próbie wstępnej, i drugi ostrzegawczy, jeśli próba nie powiedzie się ponownie. Dlatego, jeśli tylko ostrzeżenia są "Pierwsza próba nie powiodła się" z nich, do publikowania powiodło. Jeśli ponowna próba nie powiedzie się spróbować publikowania mniejszą część pliku lub zwolnić część pamięci systemowej.

Zapisany plik (e) HTML może być teraz widok z jego lokalizacji lub skopiowane do bezpiecznej witryny internetowej.

Publikowanie w sieci Web w programie Internet Explorer10

jakikolwiek hiperłącza które zostały stworzone w oryginalnym modelu będą utrzymywały się w opublikowanym modelu i klikając na link będzie w link do miejsca przeznaczenia (jeśli została wydana). Ponadto, wszelkie elementy w publikowanych wykresach, które nie są już linkiem w oryginalnym modelu będzie być linkiem powrotem do ich odpowiednich elementów w widoku drzewa (jeśli został opublikowany) i klikając element w opublikowanym schematem nacisk będzie wrócić do odpowiednia lokalizacja w drzewo. Funkcja ta jest podobna do "Pokaż w Eksploratorze" funkcji prawym przyciskiem myszy w ABACUS.

Notatka

Avolution i oprogramowania zaleca następujące formaty plików należy stosować do pełnego wykorzystania funkcjonalności Publish Web w ABACUS:

1. Internet Explorer (80,0 i powyżej)aby wyświetlić opublikowane widok Eksploratora. Mozilla Firefox (30,0 lub nowszy)Zalecane jest również w pełni obsługiwanyJednak, jeśli używasz zalecanego formatu SVG dla diagramów następnie Firefox 9 można używać tylko natywne wsparcie przeglądarki SVG, które niestety nie pozwala na powiększanie lub panoramowanie.

2. Adobe SVG Viewer 3.0 podłącz (do pobrania z tutaj ) i SVGformat pliku dla opublikowana Schematy, Format obrazu SVG dla SchematyZalecane jest, ponieważ; SVG jest formatem wektorowym na bazie obrazu i dlatego jest "utrata mniej" i wygląda o wiele lepiej w danym powiększeniu niż którykolwiek z pozostałych formatach SVG można importować do MS Visio, SVG można powiększać do dowolnego poziomu lub rozdzielczości , SVG ma powiązania z powrotem do widoku drzewa dla połączeń (nie tylko komponenty), SVG zawsze drukuje w lepszej rozdzielczości, a SVG jest o połowę rozmiar pliku z innych formatów. PNG jest kolejna rekomendacja, jednak, jak to jest w niektórych formatu rasterised poziomach powiększenia przejrzystość widoku zostaną utracone i klikając na połączenia na wykresach nie przeskoczy z powrotem do odpowiedniej lokalizacji w drzewie. Odradza się jako BMP, gdy jest to format "utrata mniej" rozmiar pliku jest 100x, że z innych formatów i obrazów 20MB nie są niczym niezwykłym.

Kompromis z SVG jest to, że widz SVG musi być zainstalowany i trzeba upewnij się, że .svg image / svg + xml dodaje typów MIME serwera sieci Web. Po zainstalowaniu w przeglądarce Microsoft Internet Explorer SVG poprosi o zaakceptować umowę licencyjną widza i to powinno zadziałać. A jednocześnieMozilla Firefox obsługuje pliki SVG natywnie, wtyczka Adobe nadal zalecaaby móc powiększać schematy jeśli używasz przeglądarki Firefox 8 lub wcześniej (jeśli używasz przeglądarki Firefox 9 nie można wyłączyć natywną przeglądarkę SVG), Gdy instalacja do wtyczki Adobe prowadzony, następujące kroki są wymagane używać go w Firefox:

· Otwórz firefox i wpisz "about: config" (bez cudzysłowu) w pasku adresu.

· Przewiń w dół i znaleźć nieruchomość svg.enabled(jeśli używasz przeglądarki Firefox 9 to rodzimy wejść SVG nie może być wyłączona, a ta własność nie istnieje), Dwukrotnie kliknij na nią aby ją wyłączyć.

· Teraz znajdź katalog, w którym jest zainstalowany plugin SVG (np C: Common Files \ Program Files \ \ Adobe \ SVG Viewer 30,0 \)

· Skopiuj pliki NPSVG3.dll i NPSVG3.zip i wkleić je do katalogu plugins Firefox (np C: \ Program Files \ Mozilla Firefox \ plugins)

· Zamknij wszystkie instancje firefox

3. Avolution Abacus 3D Viewer (3.1 i wyżej) i Avolution w .abacus3Dformat plików dla publikowanych widoków 3D. Podczas Cortona VRML Client plug-in (2.0 i wyżej)jest dostępny, aby zobaczyć wersje VRML publikowanych poglądów nie jest darmowy do użytku komercyjnego i nadal wymaga instalacji po stronie klienta. ABACUS 3D Viewer jest bardziej bogate niż jakakolwiek przeglądarka VRML i jest swobodnie dostępne do pobrania tutaj , W każdym przypadku upewnij się, że dodać .vrml x-świat / X-VRML i .abacus3d application / octet-stream do typów MIME serwera WWW.

4. PNGformat plików dla publikowanych poglądów wykresie. Format PNG dla widoków wykresów jest zalecane, ponieważ jest to jednocześnie rasterised Format i tam jest "utrata" kompromis między rozmiarem pliku i wykres jasności jest zazwyczaj najlepsze. Odradza się jako BMP, podczas gdy jest to "mniej strat" ​​sformatować rozmiar pliku jest 20x, że z innych formatów i wykresy nie są niczym niezwykłym 2 Mb pamięci.

Jeśli chcesz zmienić wygląd stron internetowych, można edytować plik strony początkowej nazwie mainPage.html i plik arkusza stylów o nazwie abacus.css. Znajdziesz tu te pliki w tym samym folderze, w którym zdecydował się zapisać plik HTML najwyższego poziomu. Aby uzyskać więcej informacji na temat struktury i krawiectwa opublikowanej wyjścia patrz następny rozdział.

Struktura ABACUS opublikowane modele

ABACUS opublikowane model jest skonstruowany w następujący sposób:

1. Folder najwyższego poziomu zawiera kilka plików i przy założeniu, wszystkie opcje są wliczone w ABACUS Publikowanie w oknie dialogowym Konfiguracja sieci Web będzie zawierać indeks.htmlPlik składa się z trzech klatek; treeView.html, findNode.html i mainPage.html i wtedy shortcutError.html strona, TreeView.html jest wypełniana przez tree.js, tree_items.js i tree_tpl.js Pliki javascript znajdujące się w folderze include (omówione poniżej) i replikuje drzewo Explorer z ABACUS. FindNode.html jest zasilany find.js Plik javascript się pod to folder (omówione poniżej) i to wyszuka gałęzie drzewa, a nie tylko widoczne węzły. Ton mainPage.html to statyczna strona HTML, które mogą być dostosowane z logo firmy itpi pojawi się strona startowa, chyba że zostanie wybrany podczas publikowania.I wreszcie, strona shortcutError.html jest strona docelowa za uszkodzone skróty z drzewa ze względu na odpowiednich stronach nie są publikowane.

napiwek

Możesz pominąć mainPage.html łącznie o Wybierając użycie stronę startową przy publikacji lub modyfikując plik index.html zwrócić się bezpośrednio do danego widoku (powiedzmy) edytując ramki src = linia "mainPage.html" zwrócić się bezpośrednio do pierwszego widzenia w pierwszym architektury, typowo "ramy" schemat.

2. Najwyższego poziomu includeFolder zawieraing różnorodny Javascript (js) i kaskadowych arkuszy stylów (.css) pliki używane przez .html plików całym opublikowanego modelu.

3. Zawartość folderu najwyższego poziomu zawiera, alfabetycznie;

· ZA '3D Widoki' folder znumerowaneStrona HTML i plik VRML lub abacus3d dla każdej z opublikowanych widoków 3D, Poniżej notatkę o informacje na temat systemu numeracji plików.

· Na Architektur Folder z numerowanej stronie HTML dla każdej architektury, który został opublikowany. Poniżej notatkę o informacje na temat systemu numeracji plików.

· A Katalogi Folder zawierający numerowaną stronę HTML dla każdej z opublikowanych katalogów. Poniżej notatkę o informacje na temat systemu numeracji plików.

· A Wykresy folder znumerowaneStrona HTML i PNG, JPG plik etc dla każdego z publikowanych poglądów Chart, Poniżej notatkę o informacje na temat systemu numeracji plików.

· A podzespoły Folder zawierającanumerowaneStrona HTML dla każdego z opublikowanymi elementów, Poniżej notatkę o informacje na temat systemu numeracji plików.

· A Znajomości Folder zawierającanumerowaneStrona HTML dla każdego z opublikowanymi połączeń, Poniżej notatkę o informacje na temat systemu numeracji plików.

· A Schematy Folder zawierającanumerowaneStrona HTML i PNG, SVG plik etc dla każdego opublikowana schematy. Poniżej notatkę o informacje na temat systemu numeracji plików.

· Na ikony zastąpić-teczka z różne obrazy użyte w całym opublikowanego modelu.

· A Standardy sub-folder znumerowaneStrona HTML dla każdego Standardyktóre zostały opublikowane. Poniżej notatkę o informacje na temat systemu numeracji plików.

· A Szablony zastąpić-teczka z kolekcji ponumerowanych podfolderów dla każdego szablonu publikowane od projektu. W ramach każdego podkatalogu jest Komponenty i folder Połączenia i wewnątrz nich jest strona HTML policzone dla każdego składnika i związku szablonu. Poniżej notatkę o informacje na temat systemu numerowania folderów / plików.

· A Rodzaje sub-folder z komponentu iPołączenie podfoldery znumerowaneStrona HTML dla każdego składnika iRodzaje połączeń, które zostały opublikowaneoraz zbiór ponumerowanych podfolderów dla każdego typu opublikowany z projektu zawierającego stronę HTML dla każdej z ograniczeniami. Poniżej notatkę o informacje na temat systemu numerowania folderów / plików.

· A Widokpunkts podfolder inumerowaneStrona HTML dla każdego z widokupunkts, które zostały opublikowane. Poniżej notatkę o informacje na temat systemu numeracji plików.

Notatka

Numeracja stron HTML (i W niektórych przypadkach pliki graficzne) dopasowuje jedyne w swoim rodzaju ID dla każdego repozytorium obiektów, które było określić, kiedy było stworzonyw ciągu ABACUS (dalej EEIDs), Identyfikator ten nie zmienia się tak, jak Schematy, typy, podzespoły itp są aktualizacja oni będziejak poprzednio zachowują takie samo ID. W każdym przypadku dane Repozytorium obiektuNazwa może być znalezione w pobliżu początku strony HTML między

... znaczników HTML.

Ograniczanie dostępu do niektórych stron / Wyświetleń z IIS

W przypadku korzystania z usług IIS jako serwer WWW do opublikowanego modelu, może być w stanie ograniczyć dostęp do niektórych stron / poglądów wykorzystujących metodę poniżej:

1. Stworzenie strony internetowej w IIS (inny, jeśli nie jest istniejący użytkownik nie chce przeszkadzać).

2. Zmień dostęp Ustawienia-> katalog Security-> Anonymous - odznaczyć dostęp anonimowy, a korzystanie uwierzytelniony dostęp.

3. Jeśli jest to po prostu normalny serwer, bez powikłań domen itp, to należy użyć opcji "zintegrowane okna uwierzytelniania ', które następnie korzystania z serwerów lokalnych użytkowników / loginy jako uwierzytelniania, i po prostu dodać użytkowników do komputera lokalnego (uważając że są świadomi konsekwencji, bezpieczeństwa mądrego, dodawania nowych użytkowników do urządzenia, na przykład w zależności od tego, czy jest konfiguracja zdalnego dostępu do komputera, itp).

4. Dodaj uprawnienia do konkretnych plików / folderów w miarę potrzeb. Kliknij prawym przyciskiem myszy poszczególne plików / folderów -> Właściwości i ustawić uprawnienia zabezpieczeń tak jak zwykle dla plików / folderów.

To może się różnić w zależności od wersji IIS i co jest specyficzne dla systemu operacyjnego Windows na serwerze i czy masz domenę lub inną inną konfigurację.

Zobacz też

Wypełnianie swoją architekturę | Analizując swoją architekturę


Eksport architektury

Nawigacja: Zgłaszanie od architektury>

Eksport architektury

Wyślij komentarzy w tym temacie.

ABACUS pozwala dowyeksportować architekturę do MDB (Microsoft Access), MS SQL Server, .abacus (plik ABACUS) i formacie .xls (Microsoft Excel). Możesz również eksportować diagrams do PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF i BMP i raportów, aby .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) i .rtf (Rich Text Format) formaty. To pozwala na analizę i zobaczyć architekturę i dane w dowolny sposób.

Aby wyeksportować architekturę .mdb (Microsoft Access)

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Kliknij na Plik menu.

3. Wybierz Eksport, i wtedy Aby MDB.

4. Należy wziąć pod uwagę ostrzeżenie i kliknij ok.

5. Wpisz nazwę pliku.

6. Kliknij Ratować Przycisk.

Notatka

Format eksportu bazy danych mdb jest specyficzne dla ABACUS oraz wszelkie zmiany schematu spowoduje niemożność ponownego importu. Proszę zobaczyć Wypełnianie z MS Access dla opisu schematu MS Access.

Aby wyeksportować architekturę MS SQL Server

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Kliknij na Plik menu.

3. Wybierz Eksport, i wtedy Do MS SQL Server.

4. W wyświetlonym oknie dialogowym kliknij Eksport Blank MDB ...Ten przycisk i zaimportować do swojego serwera baz danych MS SQL Server.

5. Wypełnij informacji z bazy danych i ciąg połączenia.

6. Kliknij Eksport Przycisk.

Notatka

Format eksportu z MS SQL ServerBaza danych jest specyficzne dla ABACUS oraz wszelkie zmiany schematu spowoduje niemożność ponownego importu. Proszę zobaczyć Wypełnianie z MS Access dla opisu schematu bazy danych.

Aby wyeksportować architekturę .xls (Excel plik)

1. Sprawdź, czy jest Plik ABACUS otwarta , na explorer wyświetlona , Oraz Architektura dodany .

2. Sprawdź, czy jest Plik Excel Konfiguracja importu / eksportu zdefiniowane.

3. Kliknij prawym przyciskiem myszyna architekturę w modelu lub dowolną część podzespołyWęzeł (w danej architektury), który chcesz wyeksportować do pliku konfiguracyjnego Excel.

4. Wybierz Eksport | Do Przewyższać... z menu.

5. Wybierz plik Excel Importuj / Eksportuj do konfiguracji Użyjpojawi się okno.

6. Wybierz odpowiedni plik konfiguracyjny dla danego modelu architektonicznego i kliknij Otwarte przycisk.

7. Jeśli automatycznie nie zrobiłeś, mapa górne elementy szczebla w aktualnej architektury do Ustaw Id(jak zdefiniowano wcześniej) i kliknij Eksport....

Mapowanie Przykład Top-Level Komponent

8. Wybierz lokalizację i nazwę pliku dla pliku Excel i kliknij Ratować przycisk.

Aby wyeksportować architekturę .abacus (plik ABACUS)

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Kliknij prawym przyciskiem myszyna węźle Architektury każda architektura w modelu lub części drzewa Components.

3. Wybierz Eksport | Do Plik...z menu.

4. Wybierz położenie i nazwę pliku i kliknij Ratować przycisk.

Notatka

Można zaimportować plik ABACUS powrotem do ABACUS przez następujące etapy 1-2powyżej, a następnie wybierając Import | Od Plik..., Po wybraniu pliku, który chcesz zaimportować, pojawi się pytanie, w jaki sposób chcesz zaimportować standardy i rodzaje. Możesz importować standardy i typy jak nowe lub połączonych norm i typów. Domyślnym ustawieniem jest do normy i rodzaje zostać połączone z istniejącymi normami i typów, jeżeli już istnieją w projekt.

Aby wyeksportować architekturę .xml

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Kliknij prawym przyciskiem myszyna węźle Architektury każda architektura w modelu lub części składowej drzewa.

3. Wybierz Eksport | Do XML ...z menu. Alternatywnie możesz kliknąć na menu Plik| Eksport| Do XML ...

4. Wybierz położenie i nazwę pliku i kliknij Ratować przycisk.

Notatka

Można zaimportować plik XML z powrotem do ABACUS przez następujące etapy 1-2powyżej, a następnie wybierając Import | Od XML ..., Po wybraniu pliku XML, który chcesz zaimportować, pojawi się pytanie, w jaki sposób chcesz zaimportować standardy i rodzaje. Możesz importować standardy i typy jak nowe lub połączonych norm i typów. Domyślnym ustawieniem jest do normy i rodzaje zostać połączone z istniejącymi normami i typów, jeżeli już istnieją w projekt.

Aby wyeksportować schemat do PNG, JPG, SVG, TIFF, GIF lub BMP

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Otworzyć diagramchcesz wyeksportować.

3. Kliknij na Eksport DiagramPrzycisk na Diagram pasek narzędzi.

4. Eksport SchematPojawi się okno.

5. Wybierz Paść sięprzycisk, aby zapisać wizualizacji w odpowiednim miejscu.

6. Wybierz Zapisz jako typmenu rozwijanego, aby wybrać typ pliku.

7. Kliknij Ratować przycisk.

Aby wyeksportować raport do .pdf (Adobe Acrobat), .xls (Microsoft Excel) lub.doc (Microsoft Word)

1. Sprawdź, czy jest Plik ABACUS Otwarte.

2. Stwórz raport chcesz wyeksportować.

3. Kliknij na EksportPrzycisk na pasku narzędzi raportów.

4. Wybierz Excel, PDF lub Wordz rozwijanej listy.

5. Poczekaj chwilę, podczas gdy eksport raportów.

6. Wybierz położenie i nazwę pliku i kliknij Ratować przycisk.


Współpraca z Enterprise Server

Nawigacja: Administracja>

Współpraca z Enterprise Server

Wyślij komentarzy w tym temacie.

ABACUS Przedsiębiorstwo serwer jest zarówno "bez blokady" współpracy podejście, ale jeden "odłączony" również. ABACUS jest "bez blokady", ponieważ nie zmusić plik ma zostać zablokowany przez jednego użytkownika na to, aby być na bieżąco. Każdy użytkownik ma własną lokalną kopię pliku, a jak wprowadzanie zmian i zapisać swój plik, zmiany te są rejestrowane i przechowywane, gdy użytkownik chce zobowiązać je do serwera.

ABACUS jest "odłączony" w tym sensie, że nie trzeba być podłączony do serwera lub potrzebujesz dostępu do sieci podczas pracy nad plikiem. ABACUS wymaga dostępu do serwera tylko wtedy, gdy wykonywanie operacji takich jak tworzenie pliku, lub wykonując kasę, wraz z operacji na istniejącym pliku - aktualizację, popełnienia lub przeglądanie dziennika z przeszłości zobowiązuje. Dostęp do serwera nie jest wymagane do pracy na pliku, a wprowadzone zmiany nie natychmiast przesyłane do serwera (ta pozwala łatwo odrzucić zmiany, jeśli się pomylisz). Po zapisaniu pliku, jesteś "tylko" Zapisywanie Kopiuj lokalnie - nie jest aż zobowiązują się, że twoje lokalne zmiany (zmiany wprowadzone od ostatniego popełnić), są wysyłane do serwera.

Tworzenie nowego pliku Enterprise

Aby utworzyć nowy plik Enterprise, wybierz Plik| Nowy ...a następnie wybrać jedną z dwóch pierwszych opcji w ramach sekcji Przedsiębiorstwo model Dialogowe Nowy projekt (czyli albo pusty plik Enterprise lub utworzyć z istniejącego pliku ABACUS). Trzecią opcją jest "Checkout" plik Przedsiębiorstwo ktoś już stworzył, zostanie to omówione w następnym rozdziale.

Jeśli zdecydujesz się utworzyć nowy plik Enterprise, będziesz miał okno, które pozwoli Ci na przeglądanie, gdzie na serwerze repozytorium chcesz zapisać plik. Trzeba będzie również istniejącą ścieżkę do pliku i nazwa weszła do górnej jeśli wybrano "Od istniejącego modelu" od dialogowym Nowy projekt i dostarczane plik.

URL: Jest to adres URL do serwera repozytorium, gdzie przechowywane są pliki ABACUS Enterprise. Należy zwrócić się do osoby, która zarządza serwer, co ten adres URL powinien być.

Powyższe zdjęcie pokazuje repozytorium z cztery (4) istniejących projektów ABACUS Przedsiębiorstwo, po wpisaniu adresu URL i naciskając Enter. Ty będzie widać po utworzeniu nowego pliku Enterprise, na kolejnym ekranie dla "Checkout", nie będzie innego folderu i pliku w ramach tego repozytorium.

Notatka

Jeśli używasz protokołu HTTPS (SSL) serwera, a serwer nie posiada ważnego certyfikatu SSL (wspólne dla intranetu lub niepublicznych serwerów z powodu Koszt certyfikatu SSLs) Nie będzie dodatkowy krok do podjęcia. Użytkownik będzie zobowiązany do stałego akceptować wszystkie połączenia do tego serwera w oknie dialogowym, które się pojawi (będzie to również pokazać nieco więcej informacji na serwerze). Aby to zrobić, wpisz "p" (bez cudzysłowu) i naciśnij klawisz Enter. ABACUS pojawi się komunikat przypominający ci o tym wcześniej pokazując okno.

Notatka

Możesz zostać poproszony, aby zalogować się na serwer w takim przypadku osoba, która jest zarządzania serweremmoże dostarczyć nazwę użytkownika i hasło serwera. Ponadto, dane logowania do wszystkich serwerów, które zostały podłączone do zapisywane są tak, jeśli z jakiegoś powodu muszą być wyczyszczone można to zrobić poprzez Narzędzia | Opcjea następnie na Generał Zakładka klikając Zresetować Subversion zapisanych Zaloguji wybierając serwer z listy rozwijanej i kliknięcie Wyczyść Zaloguj sięi wybraniu OK w oknie dialogowym, które się pojawi.

Notatka

W przeciwieństwie do ekranu pokazanego powyżej, zazwyczaj jeden ABACUS Projekt jest w każdym ABACUS Repozytorium bo jeśli więcej niż 1 ABACUS Projekt jest tworzony w jednym ABACUS repozytorium, numery Zmian ABACUS są wspólne dla wszystkich projektów Abacus, a to może zmylić użytkowników.

Preferowana Nazwa pliku: Dotyczy to zarówno folder i nazwę pliku, który będzie używany (jeśli nie już) podczas tworzenia pliku na serwerze repozytorium. Zauważ, że nowy folder jest tworzony automatycznie na serwerze repozytorium dla każdego pliku (ze względu na wydajność, pliki ABACUS Przedsiębiorstwo są tworzone w swoim folderze pod lokalizacji przeglądanej w oknie dialogowym).

Zapisać kopię roboczą w katalogu: Gdy plik Przedsiębiorstwo jest tworzony na serwerze repozytorium, lokalne pliki robocze muszą być tworzone na komputerze, dzięki czemu można pracować na pliku, bez konieczności łączenia się z siecią. Jest to miejsce, które można przeglądać, gdy chcesz, aby otworzyć / ponownego otwarcia pliku ABACUS Enterprise.

Kasy istniejącego przedsiębiorstwa Plik

Jeżeli ktoś już stworzył nowy plik Enterprise, może "kasa" ten plik, który pobiera kopię lokalną i konfiguruje niezbędne pliki, tak ABACUS rozpoznaje to jako plik Enterprise można. Okno dialogowe jest podobne do New Enterprise File Dialog. Wpisz adres URL repozytorium (podkatalogi mogą być zawarte w adresie URL), wybierz żądany plik, a następnie kliknij przycisk OK. Podlega noty poniżej tże plik zostanie otwarty.

Notatka

Możesz zostać poproszony, aby zalogować się na serwer w takim przypadku osoba, która jest zarządzania serweremmoże dostarczyć nazwę użytkownika i hasło serwera. Ponadto, dane logowania do wszystkich serwerów, które zostały podłączone do zapisywane są tak, jeśli z jakiegoś powodu muszą być wyczyszczone można to zrobić poprzez Narzędzia | Opcjea następnie na Generał Zakładka klikając Zresetować Subversion zapisanych Zaloguji wybierając serwer z listy rozwijanej i kliknięcie Wyczyść Zaloguj sięi wybraniu OK w oknie dialogowym, które się pojawi.

Różnice Przedsiębiorstwo plików

Po utworzeniu pliku Enterprise (albo nowy, albo poprzez 'kasie' pliku stworzonego przez kogoś innego), folder zostanie utworzony plik, i to zwykle zawierają te 3 główne typy plików:

· ".abacus 'File- To sam plik ABACUS. Zmiany wprowadzone lokalnie nie natychmiast zapisane w tym pliku, to jest napisane tylko, gdy popełniają. Ten plik jest "normalne" ABACUS pliku, może to mieć dla użytkowników non-EEjako projekt samodzielny (bez pliku .log)Lub wykorzystywane jako punkt wyjścia dla nowego pliku EE.

· Plik '.changes "- Lokalne (niezakończonej) zmiany wprowadzone w pliku. Jeśli tego pliku nie ma, to znaczy nie ma lokalnych zmian.

· '.plik dziennika- Plik ten ma jedynie zmiany, które zostały wprowadzone przez ostatniego użytkownika (zawartość pliku .changes użytkownika, gdy popełnione).

Notatka

Istnieją różne inne pliki, które mogą być tworzone podczas aktualizacji i popełniają procesy, a mianowicie; ‘.changesbefore' plik- Ten plik jest kopią pliku .changes po aktualizacji została przeprowadzona i jest używany do automatycznego pogodzić wszelkie konflikty tożsamości między aktualizacją i każdy lokalny (niezatwierdzone) zmienia zanim zdecydują; ‘.kopię zapasową' plik- Ten plik jest kopią pliku .changes zanim użytkownik oszczędza więcej lokalnych (niezatwierdzone) zmiany w pliku .changes; i ‘.błąd' plik- Ten plik jest kopią .changes pliku, czy jest jakiś problem, który powodował Abacus na porażkę, aby otworzyć plik .abacus a użytkownik wybrał, aby przywrócić ich zmiany.Pliki te mogą być ignorowane.

Otwieranie pliku

Aby otworzyć plik, trzeba tylko przejść do których wybrał, aby zapisać kopię roboczą, i otwórz plik ABACUS, że jest tam przechowywane. Gdy ABACUS uważa, że ​​jest to .log file (a może .złożyć zmiany, jeśli dokonane zmiany), to traktują plik jako plik Przedsiębiorczości.

Aktualizacja pliku

Wykonywanien 'Aktualizacja' sprawdzi, czy jest nowsza wersja pliku znajduje się na serwerze. Jeśli nie ma, to zamknąć bieżący plik, aktualizację do nowszej pliku z serwera i pobrać pliki tymczasowe, które mają numer jako rozszerzenie - na przykład "Demo.125". Pliki te są starsze wersje pliku .log, i są wykorzystywane do określenia, jakie zmiany zostały dokonane w pliku od ostatniej aktualizacji go. Jest to konieczne w celu wykrycia wszelkich konfliktów, które mogą zaistnieć, aby można je rozwiązać.

Gdyby w trakcie procesu aktualizacji dowolny konflikty zostały znalezione, Trzeba je rozwiązać, zanim będzie można ponownie otworzyć plik (można anulować ale zostanie wyświetlony monit, aby ponownie rozwiązywać konfliktynastępnym razem otworzyć plik).

Zapisywanie pliku

Po zapisaniu pliku, to dołącza wszelkie zmiany dokonane w pliku .changes. Ono niezmodyfikować plik .abacus na tym etapie - tylko wtedy, gdy plik jest zobowiązana do serwera będzie to napisane na (lub w momencie otrzymania aktualizacji z serwera).

Gdzie jest "Zapisz jako"?

Nie ma pojęcia Zapisz jako pliki Enterprise. Można jednak skopiować kopię roboczą .abacus pliku, pamiętając, że przyzwyczajenie się lokalne w nim zmian.

Rozwiązywanie konfliktów

Jeśli inni użytkownicy popełnili zmian w pliku w podobny część pliku do Ciebie, nie mogą być pewne konflikty między ich zmian i twoje. Na przykład, inny użytkownik może usunąć element, który trzeba było zaktualizować obiekt na, Musisz albo cofnąć ich zmianę (jeśli jesteś pewien, że oni powinninie się stało), lub odrzucić swoją zmianę (może wrócić do pliku i ponowić zmiany).

W szczególności istnieją 4 klasy konfliktów, jakie mogą wystąpić;

1. Usunąć - Gdy jeden użytkownik usuwa obiekt, że kolejne zmiany użytkownika. Na przykład. Użytkownik Usunięty komponent, ale Użytkownik B zmienił nazwę komponentu lub podłączone do niej i dodał do niego składnik dzieci itp

2. Atrybut - Gdy dwaj użytkownicy zmienić dokładnie ten sam "atrybut" obiektu. Na przykład. Zarówno Użytkownik, a Użytkownik B zmienił nazwę skladnika lub jego opis lub wartość jednego ze swoich właściwości itp

3. referencja - Po dwóch użytkowników zmienić dokładnie ten sam "odniesienie" obiekt ma do innego obiektu. Na przykład. Zarówno Użytkownik, a Użytkownik B zmienił typu komponent lub składnik źródła / umywalka przymocowana do połączenia lub połączonego punktu widzenia dla schemat itp

4. Kolekcja - Po dwóch użytkowników zmienić "zbieranie" dla obiektu. Na przykład. Zarówno Użytkownik, a Użytkownik B przeniesiony komponent z jednego rodzica do drugiego lub ponownie zamówić kolekcję dzieci komponentów.

Notatka

Różne błahe konflikty są rozwiązywane automatycznie przez ABACUS, aby zminimalizować obciążenie na użytkowników.Na przykład wszelkie sprzeczne ustawienia zoom dla całej diagramy są zdecydowane utrzymać najnowsze ustawienia pan-zoom.

Zatwierdzanie zmian

Gdy zdecydujesz się na swoje zmiany, plik ABACUS z serwera jest otwarty, twój lokalny Zmiany są wykonywane przeciwko temu, i wtedy lokalny .abacus plik zostanie zastąpiony jednym, który ma zmian w nim. Zmiany plik nadpisuje plik .log, a zarówno plik .abacus i plik .log są wysyłane do serwera.Jeśli zobowiązać się powiedzie otwarte okno dialogowe komunikatu Zobowiązanie jak pokazano poniżej jest wpisać wiadomość z commit.

Przedstawiamy dziennik zmian

Do wyświetlić dziennik zmian do Przedsiębiorstwo projekt, wybierz Plik| Zobacz Zaloguj...

Maksymalnie Wpisy Zaloguj: To domyślnie ostatnich 10 wpisów, ale dodatkowe wpisy mogą być pobierane przez zmianę wartości i klikając Odzyskać przycisk.

Rewizja: CzwKolumna e edycji listę numerów wersji popełnionych na serwer Enterprise domyślnie w odwrotnym porządku chronologicznym.

Notatka

Numery wersji nie może być ciągłe, jak tylko ABACUS zobowiązuje będą wyświetlane podczas gdy ten sam repozytorium Subversion może być używany w innych projektach Abacus i / lub innych aplikacjach kontroli wersji.

Data: Czwe Data kolumna to data, że ​​przegląd został popełniony na serwer Enterprise.

Czas: CzwKolumna e Czas wymienia godzinę (w formacie 24-godzinnym), że przegląd został popełniony na serwer Enterprise.

Autor: Czwe Autor kolumna to nazwa użytkownika systemu Microsoft Windows dla użytkownika, który wykonał commit a następnie ich ABACUS nazwa użytkownika Lub "Anonimowy", jeśli użytkownik nie jest uwierzytelniony i anonimowi użytkownicy mogli dostęp do projektu Enterprise w momencie zatwierdzenia.

Zaloguj wiadomość: CzwKolumna E Zaloguj Listy wiadomości komunikat popełnienia, który został dostarczony wraz z rewizji, jak na pokazanym powyżej oknie dialogowym.

Pobierz wersja XX jako samodzielny plik ABACUS: Jeśli wybierzesz daną zmianę w tabeli, a następnie kliknij przycisk Pobierz, będzie można wyodrębnić wybrany ABACUS rewizji projektu z serwera i zapisać go jako lokalny autonomicznego projektu / ABACUS.

Notatka

Aby cofnąć się do poprzedniej wersji można zobaczyć Avolution społeczność artykuł .

(Admin) Pobierz plik XML dla dziennika rewizji XX: Użytkownicy z możliwością Administrator ABACUS może wybrać daną wersję w tabeli, a następnie kliknij przycisk Pobierz, aby wyodrębnić wybrany projekt ABACUS popełnienia plik dziennika z serwera i zapisać go jako plik .xml.

Przedstawiamy ścieżkę audytu Przemian

Do zobaczyć ścieżkę audytu zmian do danego elementu (tj komponentów, połączenia, widok, dzieci itp) od uzyskania Przedsiębiorstwo projekt, kliknij prawym przyciskiem myszy element i wybierz Audit Trail...Ustaw Od i Do zakresu wersji i kliknij Wyszukaj.

Notatka

Gdy element zostanie usunięty z projektu nie są już w stanie uzyskać dostęp do szczegółowych informacji ścieżki audytu o tym elemencie. Można jednak nadal dostęp do komponentu "rodzica" (na przykład) i zobaczyć informacje ślad rewizyjny o usunięciu (w tym przypadku aukcji identyfikator elementu, który został usunięty).Ponadto element mocujący / Połączenie jest "własnością" połączeń tak zmieniających dołączony komponent przez okno Eksploratora lub na wykresach pokaże w ścieżki audytu dla NOT związku składnika oraz usuwanie połączenie i tworzenia nowego połączenia (jak się stanie, jeśli klikniesz prawym przyciskiem myszy "Unattach ', a następnie' Połącz ... 'w katalogach) spowoduje utratę informacji ścieżkę audytu w zakresie pierwotnego komponentu - załącznik połączenia całkowicie.

Notatka

Domyślnie ścieżka audytu rekursywnie sprawdzić zmian do żadnej z dziećmi wybranego elementu. Może to doprowadzić do długich czasów reakcji, a zatem ślad rewizyjny może ograniczać się do samego elementu poprzez odznaczenie Rekurencyjne Opcja pod Opcje audytu"koło zębate" przycisk na pasku narzędzi w oknie Audit Trail.

Od Revision: To domyślnie pierwszej / najstarszej wersji dostępnej dla projektu na serwerze Enterprise.

Do Rewizji: To domyślnie ostatniego / Najnowszą wersję dostępną dla projektu na serwerze Enterprise.

Notatka

Po ustawieniu Od i Do rewizji range kliknij przycisk Szukaj, aby pobrać wszelkie zmiany w stosunku do wybranego elementu.

Rewizja: CzwKolumna e edycji listę numerów wersji popełnionych na serwer Enterprise domyślnie w przód porządku chronologicznym.

Notatka

Numery wersji są mało prawdopodobne, aby być ciągłe, jak tylko zmiany dotyczące wybranego elementu w danym okresie i tylko ABACUS zobowiązuje będą wyświetlane podczas gdy ten sam repozytorium Subversion może być używany w innych projektach Abacus i / lub aplikacji kontroli wersji.

Data: Czwe Data kolumna to data, że ​​działanie użytkownika został wykonany.

Notatka

Podana data jest datą działanie użytkownika, a nie data rewizja została zobowiązana do serwera Enterprise. Zgodnie z tym, termin może poprzedzić odpowiednią zmianę daty commit pokazany z File | Zobacz Zaloguj ... rozkaz.

Czas: CzwKolumna e Czas wymienia godzinę (w formacie 24-godzinnym), że działanie użytkownika został wykonany.

Notatka

Czas pokazywany jest czas działania użytkownika, a nie czas rewizja została zobowiązana do serwera Enterprise. W związku z tym czas, najprawdopodobniej poprzedzić odpowiednią zmianę popełnić czas pokazany z File | Zobacz Zaloguj ... rozkaz.

Autor: Czwe Autor kolumna to użytkownikowi, który przeprowadził akcję w Microsoft Windows login a następnie ich ABACUS nazwa użytkownika Lub "Anonimowy", jeśli użytkownik nie jest uwierzytelniony i anonimowi użytkownicy mogli dostęp do projektu Enterprise w czasie działania użytkownika.

Notatka

Autor wymienione w Trail oknie Audytu może niekoniecznie odpowiadać Autor wymienione w oknie dialogowym View Log powyżej dla tej samej wersji. To dlatego, że list dialogowych Zobacz Zaloguj zalogowanego użytkownika w momencie zatwierdzenia natomiast list dialogowych Audit Trail zalogowanego użytkownika w czasie działania użytkownika, a to jest możliwe, aby jeden użytkownik wprowadzić zmiany i wysłać ich. plik do innego użytkownika zmiany popełnić - tak jak w przypadku, gdy użytkownik zewnętrzne (takie jak Avolution) jest do pracy nad projektem EE.

Bliższe dane: Czwe Szczegóły kolumnie znajdują się dokładne dane na działania użytkownika, zapisane na serwerze Enterprise.

napiwek

Jest to użyteczne Grupa przez kolumny Przejrzano (jak pokazano w okienku powyżej) i / lub w kolumnie Akcja użytkownika do łatwo sklasyfikować zmiany elementu zainteresowania.

Zastosowanie skryptów z plikami Enterprise

Jeśli używasz włączony z plikami Enterprise, należy pamiętać o tym, jak poprawnie usunąć obiekt z modelu. Generalnie, gdy usuwasz obiekt, można wywołać metodę .Delete () na nim, a nie tylko usunięcie go z jego rodzica.

Na przykład. gdybyś COMP1 jako rodzica Comp2 i chcesz usunąć Comp2 w skrypcie, należy zadzwonić comp2.Delete (), a nie comp1.Components.Remove (Comp2).

Możesz użyć usunąć jeśli masz zamiar dodać obiekt Comp2 do innego miejsca, w architekturze, ale to nie powinno być stosowane, jeżeli intencją jest, aby usunąć obiekt.

Istnieje wyjątek od tej, gdy chcesz, aby usunąć obiekt, który "żyje" w innych częściach modelu. Gdy chcesz usunąć standardowej instancji z architektury / części / związku, wtedy można to zrobić poprzez usunięcie go z kolekcji standardowej instancji - Arch1.Wdrożenia.Wykręcić (Imp) - bo usunięcie go będzie usunąć go z wszystkich instancjach.

Prawidłowo przy użyciu Usuwanie skryptów jest ważna ponieważ, jeśli obiekt jest usuwany z objectmodel a nie powtórnie dodany, to nie będzie mógł być umieszczony, ale ponieważ nie jest specjalnie skasowany wykrywania konfliktu i rozdzielczością nie będzie poprawnie wykryć konflikt, jeśli inny użytkownik był próbować korzystać z tego obiektu w żadnym z ich zmian, a końcowy wynik będzie uszkodzony zestaw zmian dla tego użytkownika.

Zobacz też

Jak architektura reprezentowana w ABACUS?


Praca z uprawnień

Nawigacja: Administracja>

Praca z uprawnień

Wyślij komentarzy w tym temacie.

Projekty ABACUS może mieć oparte na rolachUprawnienia ustawione dla każdego elementu w repozytorium. Swoiście, drobnoziarnisty Create-Read-Update-Delete (CRUD) Uprawnienia można ustawić na "obiekt" (czyli składnika lub połączenia), widok i atrybutu (tj własności) poziomy.

Przegląd

Podczas pracy z ABACUS Przedsiębiorstwo serwer , ABACUS zapewnia drobnoziarniste, uprawnienia CRUD opartych na rolach kontroli dostępu wielu użytkowników do repozytorium.

Notatka

Aby skonfigurować uprawnienia w projekcie ABACUS licencja użytkownik potrzebuje możliwości administratora. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

Uprawnienia można ustawić dla architektur, typów komponentów i połączeń, właściwości (przez ich rodzaje), szablony, punkty widzenia i schematy, katalogi, macierze, wykresy i 3DWidoki, Gdy uprawnienia są ustawione dla typu części lub połączenia wszystkich wystąpień tego typu architektury w żadnej w tym projekcie "odziedziczy" te uprawnienia. Podobnie, gdy zgoda jest ustawiony na własność typu części lub połączenia, danej nieruchomości w przypadkach składowych lub połączeń w żadnej architektury w tym projekcie "odziedziczy" te uprawnienia. Zgodnie z tym, niektóre uprawnienia zostaną zastosowane do stanowiska, na których występują te elementy. Gdy uprawnienia są ustawione na wykresie, widoku i / lub treści samego widoku mają różne uprawnienia do niego stosować.

Notatka

Domyślnie żadne uprawnienia są ustawione dla elementów w ramach projektu ABACUS. To wszystkie elementy są Createable, Czytelny, z możliwością aktualizacji i go usunąć wszystkich użytkowników. W ten sposób uprawnienia powinny być traktowane wyłącznie dla danego elementu w repozytorium, gdy pewna zgoda ma być ograniczonydla danej grupy użytkowników. Na przykład, jeśli uprawnienia dla danej grupy użytkowników dodano do przedmiotu (na przykład typu części), ale pozostaje włączone wszystkie uprawnienia, a następnie jest funkcjonalnie takie same, jak gdyby grupa użytkowników Nie było dodania do tego obiektu.

Uprawnienia nie mogąbyć ustawione dla poszczególnych wystąpień elementów architektury w. Na przykład, nie można dokonać jeden składnik Zastosowanie aktualizować kolejny nie. Aby skutecznie osiągnąć te "specyficznych domen" uprawnienia jednak Administrator może skonfigurować określone typy elementów dla danych dziedzin, m.in. "Zastosowanie - domeny CRM" typy komponentów i "aplikacji - domeny HR", a następnie ustawić uprawnienia dla każdego typu związku. Można ustawić poszczególne typy Grupowanie dla każdej domeny, a następnie usunąć zgody aktualizacji do rodzaju grupy specyficzne dla domeny i będzie ograniczyć kreacje wewnątrz i usunięcia z tego ugrupowania, ale nie aktualizuje dzieci. Oczywiście, jeśli ugrupowanie specyficzne dla domeny została ukryta przez usuwanie uprawnień do odczytu, a następnie dzieci zostaną ukryte, a tym samym nie aktualizować. Alternatywnie, jeśli (a nie poglądy badacza) wykorzystywane są przede wszystkim do zarządzania / zobaczyć repozytorium, dany widok dla każdej domeny można było ustalić, a następnie administrator może ustawić uprawnienia dla każdego widoku odpowiednio.

Zarządzanie użytkownikami i grupami

Uprawnienia są definiowane w rola lub grupapoziom, w przeciwieństwie do indywidualnego poziomu użytkownika, tak że gdy członkostwo grup może się zmienić, uprawnienia mogą pozostają stałe. Oczywiście jeśli chcesz konkretne uprawnienie użytkownik po prostu uczynić z nich grupę, a dokładniej utworzyć grupę z użytkownikiem jako jedynego członka.

Należy zauważyć, że grupy są atomowy, Czyli nie mogą dziedziczyć uprawnienia lub użytkowników z jednego do drugiego, a jeśli użytkownik należy do wielu grup, a następnie najbardziej "pesymistyczne" Pozwolenie grupa będzie mieć pierwszeństwo w każdym przypadku z osobna dla każdego indywidualnego zezwolenia (tj Tworzenie -Read-Update-Delete). Na przykład, jeśli ten sam użytkownik jest członkiem grupy A i grupy B i grupy A właśnie uprawnienie Tworzenie lektura dla typów komponentów aplikacji, podczas gdy grupa B właśnie Przeczytaj-Update zezwolenia dla typów komponentów aplikacji, wówczas użytkownik będzie tylko przeczytałem zgody na wystąpień komponentu aplikacji.

Ponadto domyślnie anonimowych(czyli użytkowników, którzy nie zostały zdefiniowane lub którzy nie zalogowany) mają pełny dostępdo projektu. Ma to zagwarantować, że dostęp jest możliwy w początkowej konfiguracji. Aby zablokować dostęp przez anonimowych użytkowników po prostu usuń zaznaczenie pola wyboru "Zezwalaj na anonimowy użytkownik pełen dostęp do pliku 'opcji w Zarządzanie użytkowników / grup dialogowe pokazane poniżej. Gdy odznaczone anonimowi użytkownicy będą mogli zobaczyć część Standardów każdego projektu tylko.

Wreszcie, uwierzytelnianie, jeśli opcji "Użyj systemu Windows nazwy użytkownika" jest zaznaczona nazwa użytkownika jest wykonywane przed użytkownika identyfikatory logowania systemu Windows na maszynie użytkownika przed nazwa użytkownika wszedł jak na poniżej. To jest, jeśli dla systemu Windows Nazwa użytkownika Zaloguj komputerze danego użytkownika istnieje jako ważną nazwą użytkownika nie jest wymagane żadne hasło i użytkownik zostanie automatycznie potwierdzona. Uwaga: ten skutecznie umożliwia wykorzystanie uwierzytelniania Windows Active Directory (AD).

Notatka

Biorąc pod uwagę, że uprawnienia są zdefiniowane tylko wtedy, gdy muszą być zabrane (ograniczona) od użytkownika, każdy użytkownik, który nie jest członkiem grupy, lub każda grupa, która nie ma uprawnień określonych dla niego przed wszelkimi przedmiotami, będą mieli pełny dostęp do projekt.

Użytkownicy i grupy użytkowników

Aby utworzyć nowego użytkownika

1. Wybierz Plik| Zarządzaj użytkowników / grup

Notatka

Jeśli nie zobaczyć Zarządzanie użytkownikami / pozycja menu Grupy wtedy nie ma możliwości administratora. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

2. W wyświetlonym oknie dialogowym zaznacz Dodaj użytkownikaprzycisk i wprowadź nazwę użytkownika i hasło w oknie dialogowym Tworzenie nowego użytkownika. Uwaga: Nazwy użytkowników i hasła jest wielkość liter.

Notatka

W przypadku opcji "Użyj systemu Windows nazwy użytkownika" jest zaznaczona w sposób opisany powyżej, a następnie hasło obojętne mogą być wprowadzane jako uwierzytelniania będą wykonywane zgodnie użytkownika tło Windows Nazwa użytkownika tylko zalogować.

2. Domyślnie widać, że Użytkownicy mogą zmieniać swoje hasło. Jeśli to konieczne, administrator ABACUS może usunąć możliwość dla użytkowników, aby ustawić własne hasło przez Usunięcie zaznaczeniapola wyboru.

Notatka

Jeżeli użytkownicy mogą zmieniać swoje hasło będą mieć File | Zmień hasło...element menu, aby to zrobić.Należy również pamiętać, że jeśli wiele osób korzysta z tej samej nazwy użytkownika, a następnie jeden użytkownik może zmienić hasło takie, że inne osoby mogą zalogować się później. W związku z powyższym, zaleca się, praktyce mieć pojedyncza nazwa użytkownika na rzeczywistą osobę.

4. Opcjonalnie, wpisz adres e-mail, Lokalizacja i numer telefonu dla użytkowników, dla przyszłości.

5. Kliknij na okprzycisk w oknie dialogowym Tworzenie nowego użytkownika.

6. Kliknij na ok przycisk.

Notatka

Po utworzeniu pierwszego użytkownika należy rozważyć zablokowanie dostępu przez anonimowych użytkowników poprzez odznaczenie opcji "Zezwalaj na anonimowy użytkownik pełen dostęp do pliku '/ opcji w oknie dialogowym Zarządzanie Użytkownicy Grupy.Ponadto, gdy użytkownik został utworzony (jeśli projekt Przedsiębiorstwo zmiana zobowiązuje się do serwera), następnym razem, projekt jest otwarty użytkownik zostanie poproszony o Zaloguj uwierzytelnionego dostępujak w oknie poniżej. Jeśli Zaloguj się automatycznie z tymi szczegółamiopcja jest zaznaczona, a następnie nazwę użytkownika Połączenie / hasło zostanie zapamiętany projektu i stosowane za każdym razem na otwarciu. Aby usunąć zapisane logowania wybierz File | Usuń zapisane Zaloguj siępo otwarciu i zostaniesz poproszony, aby zalogować się ponownie przy kolejnym otwarciu projektu.

Zaloguj się

Aby usunąć istniejący Użytkownika

1. Wybierz Plik| Zarządzaj użytkowników / grup

2. W wyświetlonym oknie dialogowym wybierz nazwę użytkownika w panelu Użytkownicy, który chcesz usunąć, a następnie wybierz Usuń użytkownika przycisk.

3. Kliknij na ok przycisk.

Aby utworzyć nową grupę

1. Wybierz Plik| Zarządzaj użytkowników / grup

2. W wyświetlonym oknie dialogowym zaznacz Dodaj grupęprzycisk i wprowadź nazwę grupy w panelu grup.

Notatka

Nazwy grup muszą być unikalne.

3. Kliknij na ok przycisk.

Do skopiować istniejący Grupa

1. Wybierz Plik| Zarządzaj użytkowników / grup

2. W wyświetlonym oknie dialogowym zaznacz Kopiuj Grupa przycisk.

Notatka

Duplikat grupa zostanie utworzona z przedrostkiem "Kopia".Domyślnie wszystkie uprawnienia z kopiowanego grupy będą kopiowane na "Kopia" grupy w tym wszelkie zadania użytkownika.

3. Zmień nazwę "Kopia" grupy w zależności od przypadku korzystania z Edycja grupylub wolno podwójne kliknięcie.

Aby usunąć istniejącą grupę

1. Wybierz Plik| Zarządzaj użytkowników / grup

2. W wyświetlonym oknie dialogowym wybierz nazwę grupy w panelu grup, które chcesz usunąć, a następnie wybierz Usuń grupę przycisk.

Notatka

Wszelkie przypisania użytkownika do grupy zostaną również usunięte.

3. Kliknij na ok przycisk.

Aby przypisać użytkownika do grupy

1. Wybierz Plik| Zarządzaj użytkowników / grup

2. W wyświetlonym oknie dialogowym wybierz nazwę użytkownika w panelu Użytkownicy, który chcesz przypisać do grupy i przeciągnij i upuśćto na nazwę grupy w panelu grup, które chcesz przypisać do.

3. Kliknij na ok przycisk.

Notatka

Grupa (y), że użytkownik jest przypisany do pokazano poprzez rozszerzenie Nazwa użytkownika w panelu Użytkownicyi użytkowników, które są przypisane do grupy, są pokazane poprzez rozszerzenie nazwy grupy w panelu grup. Na przykład, w powyższym ekranu, określenie "AS1-Aus" użytkownik jest przypisany do trzech (3) grupy, a mianowicie; "App Support Team 1", "rzeczywista" i "Australia".

Aby cofnąć użytkownika z grupy

1. Wybierz Plik| Zarządzaj użytkowników / grup

2. W wyświetlonym oknie dialogowym rozwiń nazwę grupy, który zawiera przypisania użytkownika, które chcesz cofnąć i wybrać nazwę użytkownika.

3. Kliknij na Cofanie użytkownika przycisk.

4. Kliknij na ok przycisk.

Aby zaimportować użytkowników i / lub grupy (i żadnych uprawnień dopasowania)

1. Wybierz Plik| Zarządzaj użytkowników / grup

2. Kliknij na Import przycisk.

3. W wyświetlonym oknie dialogowym Paść siędo i otwórz projekt ABACUS zawierającą użytkowników i / lub grup (i uprawnienia), które chcesz zaimportować do bieżącego projektu i kliknij Otwarte, Użytkowników i grupy zostaną zaimportowane i pojawia się okno dialogowe Importuj Wyniki podsumowujące import Użytkowników i / lub grup. Kliknij na ok przycisk.

Notatka

Jeśli importowane Użytkownicy lub Grupy istniała już w bieżącym projekcie, zostaną one połączone z istniejących grup lub użytkowników.

4. Kliknij na okUżytkownicy Grupy przycisk / Dialog z powrotem w głównym Zarządzaj.

5. Jeśli są jakieś pasujące Rodzaje, punkty widokowe, Szablony lub architektury między bieżącego projektu i projektu ABACUS jesteś przywozu z, wraz z uprawnieniami, które nie występują już w bieżącym projekcie, uprawnienia są importowane i dialogowe Importuj drugi Wyniki wydaje podsumowujący importu. Kliknij na ok przycisk.

Notatka

Uprawnienia są dodawane tylko do istniejących typów (i ich własności), punkty widokowe, szablonów lub architektury dla grup, gdzie nie istnieją już uprawnienia dla Grupy. Albo dlatego, że Grupa jest nowa lub Grupa istniała już w bieżącym projekcie, ale nie ma uprawnień został przydzielony do tej Grupy na tej pozycji. Nie ma "łączenie" z uprawnieniami do dopasowania, gdzie istniały już uprawnienia dla Grupy w bieżącym projekcie.

Ustawianiem uprawnień

Uprawnienia można ustawić dla architektur, typów komponentów i połączeń, właściwości (przez ich rodzaje), szablony, punkty widzenia i schematy, katalogi, macierze, wykresyd 3DWidoki, Gdy uprawnienia są ustawione dla typu części lub połączenia wszystkich wystąpień tego typu architektury w żadnej w tym projekcie "odziedziczy" te uprawnienia. Podobnie, gdy zgoda jest ustawiony na własność typu części lub połączenia, danej nieruchomości w przypadkach składowych lub połączeń w żadnej architektury w tym projekcie "odziedziczy" te uprawnienia. Zgodnie z tym, niektóre uprawnienia zostaną zastosowane do stanowiska, na których występują te elementy. Gdy uprawnienia są ustawione na wykresie, widoku i / lub treści samego widoku mają różne uprawnienia do niego stosować.

Zarządzanie uprawnieniami

Aby ustawić uprawnienia dla składnika (lub połączenia) Typ

1. Rozwiń Rodzajegałąź drzewa.

2. Rozwiń Komponent (lub połączenia) Rodzajegałąź drzewa.

3. Rozszerzać Grupy gdzie jest to konieczne.

4. Kliknij prawym przyciskiem myszy na Składnik (lub połączenia) Typchcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

5. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

6. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

Notatka

Tworzenie uprawnień reguluje również, kiedy można skopiować element. Zgodnie z tym, w stanie skopiować element wymaga Tworzenie zgody dla wszystkich dzieci (ponieważ kopiowanie elementu oznacza, kopiując wszystko poniżej). Usuwanie uprawnień Aktualizacja z elementu usuwa możliwość modyfikowania samego typu, nawet jeśli użytkownik ma Designer add-on, a to Aktualizacja usuwa również uprawnienie dla wszystkich jego właściwości. Element rodzic musi mieć uprawnienia Update, aby być w stanie Tworzenie żadnych elementów dzieci lub Usuń ITS istniejący Elementy dzieci. Usuń zgodę na element wymaga również usuwać zgodę na wszystkie jego dzieci. Usuń zgodę na komponentów wymaga także zgody aktualizacji wszystkich załączonych połączeń.I w końcu, usunięcie uprawnienia Usuwanie z elementu usuwa możliwość usuwania samego typu, nawet jeśli użytkownik ma Designer add-on.

7. Kliknij na ok przycisk.

Aby ustawić uprawnienia dla grupy Component (lub połączenia) Rodzaje

1. Rozwiń Rodzajegałąź drzewa.

2. Rozwiń Komponent (lub połączenia) Rodzajegałąź drzewa.

3. Kliknij prawym przyciskiem myszy na Grupaże zawiera składnik (lub połączenia) typy, które chcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

6. Kliknij na ok przycisk.

7. W wyświetlonym oknie dialogowym kliknij Tak przycisk.

Aby ustawić uprawnienia do własności

1. Rozwiń Rodzajegałąź drzewa.

2. Rozwiń Komponent (lub połączenia) Rodzajegałąź drzewa.

3. Rozszerzać Grupy gdzie jest to konieczne.

4. Wybierz komponent (lub połączenia) Typ, który zawiera właściwość, którą chcesz się określić uprawnienia.

5. W oknie Właściwości kliknij prawym przyciskiem myszy na Nieruchomośćchcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

6. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

7. Domyślnie widać, że uprawnienia Odczyt i aktualizacji są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

Notatka

Właściwości, które miały pozwolenie Aktualizacja usuwane są przedstawione w kursywaw oknie Właściwościi ich wartości nie mogą być aktualizowane przez tę rolę, Ponadto, zdolność modyfikować szczegóły własności (np nazwa, jednostki itp) wymaga zarówno zgody Aktualizacja na nieruchomości i Projektant add-on.

8. Kliknij na ok przycisk.

Aby ustawić uprawnienia do szablonu

1. Rozwiń Szablonygałąź drzewa.

2. Przejdź do Szablonże jesteś zainteresowany.

3. Kliknij prawym przyciskiem myszy na Szablonchcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie widać, że uprawnienie Odczyt jest dostępny. Usuń zgody przez Usunięcie zaznaczeniapole wyboru.

6. Kliknij na ok przycisk.

Aby ustawić uprawnienia dla Widzenia

1. Rozwiń Punkty widzeniagałąź drzewa.

2. Rozszerzać Grupy gdzie jest to konieczne.

3. Kliknij prawym przyciskiem myszy na Punkt widzeniachcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

6. Kliknij na ok przycisk.

Aby ustawić uprawnienia dla Architektury

1. Rozwiń Architekturgałąź drzewa.

2. Rozwiń do Architekturaże jesteś zainteresowany.

3. Kliknij prawym przyciskiem myszy na Architekturachcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie widać, że uprawnienie Odczyt jest dostępny. Usuń zgody przez Usunięcie zaznaczeniapole wyboru.

6. Kliknij na ok przycisk.

Aby ustawić pozwolenie na Katalog

1. Rozwiń Katalogigałąź architektury jesteś zainteresowany.

2. Rozszerzać Grupy gdzie jest to konieczne.

3. Kliknij prawym przyciskiem myszy na Katalogchcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

6. Kliknij na ok przycisk.

Aby ustawić pozwolenie na Matryca

1. Rozwiń Macierzegałąź architektury jesteś zainteresowany.

2. Rozszerzać Grupy gdzie jest to konieczne.

3. Kliknij prawym przyciskiem myszy na Matrycachcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

6. Kliknij na ok przycisk.

Aby ustawić uprawnienia na wykresie

1. Rozwiń Schematygałąź architektury jesteś zainteresowany.

2. Rozszerzać Grupy gdzie jest to konieczne.

3. Kliknij prawym przyciskiem myszy na Diagramchcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

Notatka

Chociaż można ustawić uprawnienia CRUD bezpośrednio na wykresie, należy zauważyć, że uprawnienia z elementów na schemacie może mieć wpływ na uprawnienia dla samego widoku. Na przykład, jeśli nie jest jeszcze tylko jeden element w widoku, który miał swoje uprawnienia odczytu lub aktualizacji usunięto wówczas schemat będzie musiał usunąć jego zgody Aktualizacja. To dlatego, że; a) elementy na widoku, które miały usunąć ich uprawnienie Odczyt nie będą wyświetlane na widoku pozostawiając "spacji", gdzie można inaczej postawić kilka nowych elementów, jeśli widok był aktualizować, oraz b) elementy, na widoku, że mieli ich zgody Aktualizacja usunięte może to mieć inne elementy spadły na nich stać się dziećmi, jeśli widok był aktualizować. Ponadto, Tworzenie i zgody Aktualizacja schematu wymaga, aby wszystkie elementy w widoku mają uprawnienia Odczyt i komponenty mają pozwolenie aktualizacji (to dlatego, aby przenieść element do innego komponentu, musisz być w stanie zaktualizować go, ponieważ będzie stać się dziecko).

6. Kliknij na ok przycisk.

Aby ustawić uprawnienia dla widoku 3D

1. Rozwiń 3D Widokigałąź architektury jesteś zainteresowany.

2. Rozszerzać Grupy gdzie jest to konieczne.

3. Kliknij prawym przyciskiem myszy na Widok 3Dchcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

6. Kliknij na ok przycisk.

Aby ustawić pozwolenie na Wykres

1. Rozwiń Wykresygałąź architektury jesteś zainteresowany.

2. Rozszerzać Grupy gdzie jest to konieczne.

3. Kliknij prawym przyciskiem myszy na Wykreschcesz ustawić uprawnienia i wybrać Edytuj uprawnienia.

4. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

5. Domyślnie można zobaczyć, że Crud uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

6. Kliknij na ok przycisk.

Zobacz też

Jak architektura reprezentowana w ABACUS?


Praca z Dashboards

Nawigacja: Administracja>

Praca z Dashboards

Wyślij komentarzy w tym temacie.

Projekty ABACUS może mieć dowolną konfigurację widokiem (np Schematy, Wykresy itp) zapisane w desce rozdzielczej i te zapisane kokpity mogą być ustawiony jako domyślny począwszy 'screen' na otwarcie projektu i / lub przypisany do konkretnego Grupa użytkowników i przedstawił członków tej grupy użytkowników podczas logowania do projektu ABACUS.

Notatka

Aby skonfigurować panele kontrolne w projekcie ABACUS licencja użytkownik potrzebuje możliwości administratora. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

Przedstawiamy pulpitów

Przykładem aplikacji Portfolio Management (APM) deska rozdzielcza

Aby wyświetlić zapisaną Dashboard

1. Wybierz Widok| Kokpity menedżerskie

2. Wybierz zapisany deskę rozdzielczą z listy dostępnych paneli kontrolnych.

Notatka

Po wybranym ABACUS zbuduje poglądy wymagane do deski rozdzielczej, a to może potrwać kilka sekund. Proszę być cierpliwym.

Zarządzanie pulpitów

Zarządzanie pulpitów

Aby utworzyć nowy Dashboard

1. Otwórz wymaganych opinii i zorganizować i dok Okna wymagane do deski rozdzielczej.

2. Wybierz Widok| Kokpity menedżerskie| Zarządzaj pulpitów ...

Notatka

Jeśli nie widzisz menu Manage dashboardów wtedy nie masz możliwości administratora. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution jeśli wymagają takiej możliwości.

3. W wyświetlonym oknie dialogowym zaznacz Stwórzprzycisk i wprowadź nazwę w oknie dialogowym Dashboard Utwórz nowy Dashboard.

4. Kliknij na ok przycisk.

Aby usunąć istniejący Dashboard

1. Wybierz Widok| Kokpity menedżerskie| Zarządzaj pulpitów ...

2. W wyświetlonym oknie dialogowym zaznacz Dashboard, który chcesz usunąć z listy i wybierz Usunąć przycisk.

Notatka

Usuwanie dashboard będzie również usunąć wszystkie zadania grupy użytkowników na tej desce rozdzielczej.

3. Kliknij na ok przycisk.

Aby zastąpić istniejący Dashboard

1. Otwórz wymaganych opinii i zorganizować i dok Okna wymagane do deski rozdzielczej zastępczej.

2. Wybierz Widok| Kokpity menedżerskie| Zarządzaj pulpitów ...

3. W oknie dialogowym, które pojawia wybrać Dashboard, który chcesz zastąpić z listy i wybierz wymienić przycisk.

4. Kliknij na okprzycisk, aby potwierdzić okno Dashboard Zastąpiony.

Aby przypisać Dashboardjako domyślny startowa

1. Wybierz Widok| Kokpity menedżerskie| Zarządzaj pulpitów ...

2. W wyświetlonym oknie dialogowym zaznacz Dashboard z listy, którą chcesz przypisać jako "domyślnego ekranu" STARTi wybierz Przydzielać... przycisk.

3. W wyświetlonym oknie dialogowym zaznacz Grupy wpis w kolumnie użytkownika.

Notatka

Tylko jedna na desce rozdzielczej można przypisać jako zacząć "ekran", więc ponownie zadanie usunie Projekt> .Ponadto, jeśli użytkownik loguje się jako członek grupy użytkowników, która ma przypisany pulpit następnie przypisany deska rozdzielcza będzie otwarty w miejsce w desce rozdzielczej domyślne projektu.

4. Kliknij na ok przycisk.

Aby przypisać grupę użytkowników do Dashboard

1. Wybierz Widok| Kokpity menedżerskie| Zarządzaj pulpitów ...

2. W wyświetlonym oknie dialogowym zaznacz Dashboard z listy, który chcesz przypisać do grupy użytkowników i wybrać Przydzielać... przycisk.

3. W wyświetlonym oknie dialogowym zaznacz Grupa użytkownika (lub grupy)chcesz przypisać dashboard jako ekran dla "start up".

Notatka

Jeśli ta sama grupa użytkowników jest przypisany do wielu kokpitów następnie zostanie użyty pierwsze zadanie na liście.

4. Kliknij na ok przycisk.

Aby cofnąć przypisanie do grupy użytkowników z Dashboard

1. Wybierz Widok| Kokpity menedżerskie| Zarządzaj pulpitów ...

2. W wyświetlonym oknie dialogowym rozwiń pozycję Dashboard z listy chcesz cofnąć grupę użytkowników z.

3. Wybierz grupę użytkowników, którą chcesz cofnąć i wybrać Cofanie przycisk.

4. Kliknij na ok przycisk.

Ustawianiem uprawnień

Uprawnienia można ustawić dla kokpitów, aby umożliwić dashboard być widoczny, Aktualizować i / lub go usunąćdo określonych grup użytkowników.

Zarządzanie uprawnieniami

Aby ustawić uprawnienia dla Dashboard

1. Wybierz Widok| Kokpity menedżerskie| Zarządzaj pulpitów ...

2. W wyświetlonym oknie dialogowym zaznacz Dashboard z listy, którą chcesz ustawić uprawnienia dla i wybierz Uprawnienia ... przycisk.

3. W wyświetlonym oknie dialogowym kliknij Dodaj...przycisk i wybrać Grupachcesz dodać albo przez dwukrotne kliknięcie lub wybranie i kliknięcie ok przycisk.

4. Domyślnie widać, że Read, Update i Delete uprawnienia są dostępne. Usuń uprawnień przez Usunięcie zaznaczeniaodpowiednie pola wyboru.

5. Kliknij na ok przycisk.

Zobacz też

Dostosowywanie interfejsu ABACUS | Praca z uprawnień


Rejestracji Abacus

Nawigacja: Wniosek>

Rejestracji Abacus

Wyślij komentarzy w tym temacie.

Po pierwszym uruchomieniu Abacus (lub po wygaśnięciu licencji tymczasowej), musisz zarejestrować się stosowanie przed serwerem licencji Avolution Korzystanie unikalny klucz licencyjny dostarczony przez lokalnego administratora ABACUS lub bezpośrednio z Avolution. Jeśli nie masz klucza licencyjnego należy skontaktować się z administratorem ABACUS lub Wsparcie Avolution .

Aby zarejestrować się z kluczem licencyjnym

1. Po instalacji, rozpocząć Abacusalbo przez dwukrotne kliknięcie na skrót na pulpicie lub w menu Start systemu Windows.

2. W oknie dialogowym, które się pojawi rejestracji wprowadź 26 znaków klucz licencyjnydostarczony przez lokalnego administratora ABACUS lub Wsparcie Avolution Lub kliknij Paść się...i wybierz podpisany plik .dlsc wrócił z Wsparcie Avolution zgodnie z uwagą w kroku 4 poniżej. W przypadku korzystania z prawidłowo podpisany plik .dlsc ABACUS powinny rozpocząć się na punkcie 5 poniżej.

napiwek

Możesz wkleić klucz licencyjny do dialogu poprzez skopiowanie go do schowka Windows, a następnie wybierając tło okna i naciskając klawisze Ctrl + V.

Dialogowe Rejestracja

3. Trzask oki jeśli klucz licencyjny jest poprawny klucz licencyjny ABACUSABACUS będzie teraz próbował skontaktować serwer licencji Avolution do uwierzytelnienia klucz licencyjny.

Notatka

Jeśli masz Kod instalacji jest nieprawidłowybłąd w rejestracji jest bardzo prawdopodobne, że błędnie wpisany kod. Spróbuj skopiować i wkleić kod, jak na Tip mowa powyżej.

Kontaktowanie License Server Avolution

4. Trzask oki po krótkim okresie czasu ABACUS powinien pomyślnie zarejestrować.

Udane Rejestracja

Notatka

Jeśli dostaniesz Nie można skontaktować się z serwerem licencjibłąd w rejestracji jest bardzo prawdopodobne, że zapora (lub inne środki bezpieczeństwa) w sieci uniemożliwiają dostęp do serwera licencji Avolution jest. Trzask okZapisz plik .dlsc na komputerze lokalnym, a następnie bądź e-mail plik .dlsc do Wsparcie Avolution i czekać na dalsze instrukcjelub spróbuj zapisać plik licencji samodzielnie za pomocą następującego adresu URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Nie można skontaktować się z serwerem licencji

Otwórz stronę podpisania licencji

Instrukcja licencji podpisanie strona

Ewentualnie, jeśli masz Ten kod instalacyjny został użyty na większej liczbie systemów niż zezwala na to licencjaBłąd Rejestracja jest prawdopodobne, że lokalna maszyna została odbudowana od ostatniego zarejestrowana Abacus lub próbujesz zarejestrować się kluczem licencyjnym innego użytkownika. Proszę skontaktować się z administratorem ABACUS lub Wsparcie Avolution .

Kod instalacji został już użyty

5. Trzask oki jeśli pomyślnie zarejestrowany ABACUS należy otworzyć z Ekran powitalny .

Zobacz też

Wsparcie Avolution | Co ABACUS zrobić?


ABACUS Instalacja Warunki wstępne

Nawigacja: Wniosek>

ABACUS Instalacja Warunki wstępne

Wyślij komentarzy w tym temacie.

Informacje dotyczące programu Visio Importuj Import / Eksport Excel

ABACUS wymaga zainstalowania pakietu Microsoft Office w celu wykonania operacji Excel import / eksport oraz Visio Importuj. Proszę sprawdzić, Microsoft Office 2003 lub nowszyjest poprawnie zainstalowany. W przypadku wystąpienia dalszych problemów, kontakt Wsparcie Avolution .

W celu wykonania operacji Importuj programu Visio i Excel import / eksport, ABACUS korzysta z programu Microsoft Office Primary Interop zgromadzeń (PIA). ABACUS obecnie dostarczana wraz zespołów niezbędnych do realizacji programu Excel Import / Export i Visio Importuj.

Informacje dotyczące programu SQL Server importu

ABACUS wymaga Microsoft SQL Server 20052008, 2008 R2, 2012 lub 2014jest zainstalowany w celu rozpoczęcia nowego projektu z programu SQL Server. Proszę sprawdzić, Microsoft SQL Server 20052008, 2008 R2, 2012 lub 2014jest poprawnie zainstalowany. W przypadku wystąpienia dalszych problemów, kontakt Wsparcie Avolution .

Błędy Otwarcie 3D Wizualizacje

Jeśli ABACUS 3D Viewer nie działa, być może brakuje SlimDX DirectX Runtime (zainstalowany jako część pełnego ABACUS EXE instalacji). Można je pobrać tutaj , Jeśli masz 64-bitową wersję systemu Windows, możesz także zainstalować to .

Błędy Redagowanie LICZYDŁO Zwyczaj Raporty

Montaż Abacus 'raportów niestandardowych wymaga Report Builder 3.0 do zainstalowania. ABACUS i Report Builder są zbudowane na Microsoft .NET Framework 4.0, a gdy oboje nie wymagają Microsoft .NET Framework 3.5, Microsoft nieprawidłowo skonfigurowana Report Builder MSI tylko kontynuować, jeśli jest zainstalowany Microsoft .NET Framework 3.5.

W związku z powyższym, Avolution ma edytowanej wersji instalacyjnej programu Report Builder pliku MSI, który nie wymaga Microsoft .NET Framework 3.5, to można pobrać tutaj .

Oryginalny Microsoft Report Builder MSI można pobrać tutaj , Jeżeli nie masz jeszcze Microsoft .NET Framework 3.5, które będzie wymagać, można go pobrać tutaj , Uwaga: W przypadku wielu instalacji, instalacja w trybie offline Microsoft .NET Framework 3.5 z tutaj mogą być bardziej odpowiednie.


Opcje wiersza poleceń

Nawigacja: Wniosek>

Opcje wiersza poleceń

Wyślij komentarzy w tym temacie.

Można wykonywać różne operacje ABACUS bezpośrednio z linii poleceń z najczęściej praca jest, aby otworzyć określony plik projektu i opublikować go na HTML.

W szczególności, korzystanie z linii poleceń Abacus jest następujący;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ użytkownika "User" / pass "pass"]

Sprzeczka | Opis
ProjectFile | ProjectFile może być zarówno plik ABACUS projektu (.abacus), plik biblioteki (.abacuslib), plik XML (.xml) lub MS Access DB (.mdb) i określony plik będzie albo być otwarte (jeśli .abacus lub .abacuslib ) lub nowy projekt stworzony (jeśli plik .xml lub .mdb).
OptionalFile | OptionalFile może być skrypt ABACUS (.abacusscript, .vb lub .cs), makro (.abacusmac) lub plik biblioteki (.abacuslib) i określony plik będzie albo być uruchamiane po otwarciu ProjectFile (jeśli .abacusscript, .vb lub .cs lub .abacusmac) lub po prostu otwarty (jeśli .abacuslib).
/ exitOnCompletion | Wyjdzie Abacus iw razie potrzeby zapisać i zobowiązać się żadnych zmian w otwartych projektów .abacus na zakończenie każdego skryptu lub makro. Uwaga: Ta flaga jest wielkość liter, więc należy użyć wielkiej litery "O" i "C" w tekście, jak pokazano.
/ dontShowDialogs | Zapobiegnie ABACUS Enterprise Edition (EE) dialogi wyświetlanie powiadomienia o aktualizacji po otwarciu projektu. Uwaga: Ta flaga jest wielkość liter, więc należy używać wielkich liter "S" i "D" w tekście, jak pokazano.
/ użytkownika "User" / pass "PASS" | Nazwa użytkownika i hasło użytkownika PASS będą wykorzystywane do logowania się do projektu z, zastępując wszelkie zapisane poświadczenia użytkownika. Uwaga: Podwójne cudzysłowy muszą być umieszczone wokół użytkownika i przekazać flagi i dwa podwójne cudzysłowy mogą być używane do ucieczki cudzysłowia w użytkownika albo PASS flagi.

Na przykład.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.czas"/ exitOnCompletion / dontShowDialogs / użytkownik "publiczny" / pass "123456"

gdy uruchomić z katalogu, w którym ABACUS.exe dwójkowy jest usytuowany będzie Otwarte projekt Przykład i zaloguj się jako publiczny użytkownika z hasłem 123456 (jak opisano tutaj ), Publikuje je do HTML, a następnie zamknąć projekt ogóle nie pokazując żadnych dialogów po drodze (np "Aktualizacja Sukces" lub "Brak dostępnych aktualizacji" dla projektów Enterprise).

Na przykład.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalog Excel importu.czas"/ exitOnCompletion / dontShowDialogs

gdy uruchomić z katalogu, w którym ABACUS.exe dwójkowy jest usytuowany będzie Otwarte projekt Przykład i importować "Serwery (2.014 Rzeczywista) .xlsx" plik programu MS Excel do katalogu 'Servers' z '2014' rzeczywista architektury projektu bez wyświetlania okna dialogowe po drodze, a następnie zamykając projekt na ukończeniu. Jeśli operacja wprowadza zmiany do projektu następnie podczas zamykania zmiany są zapisywane lokalnie, a jeśli projekt Przedsiębiorstwo zobowiązuje się do Enterprise Server.

Notatka

Pamiętaj, aby używać odpowiedniego znaku cudzysłowu, jak jest ich kilka w standardowym zestawie znaków ASCII i wierszem polecenia systemu Windows będzie działać poprawnie tylko z właściwego. Prawidłowe podwójne cytat jest kod znaku przecinka 34 (szesnastkowy 22).To jest to, co jest wykorzystywane w powyższym przykładzie dlatego zachęcamy do kopiuj / wklej go stamtąd.


Strona tytułowa

LICZYDŁO

Zrzeczenie się

Avolution Pty Ltd nie ponosi odpowiedzialności, ani nie udziela gwarancji w odniesieniu do niniejszej instrukcji oraz, w maksymalnym zakresie dozwolonym przez prawo, wyraźnie ogranicza swoją odpowiedzialność za naruszenie jakichkolwiek gwarancji, które może wiązać się z wymianą tej instrukcji z innego. Ponadto Avolution Pty Ltd zastrzega sobie prawo do korekty tej publikacji w dowolnym czasie, bez ponoszenia obowiązku powiadamiania kogokolwiek o rewizji.

Prawo autorskie

Prawa autorskie 2001-2015Avolution Pty Ltd. Wszystkie prawa zastrzeżone.

Znaki towarowe

Avolution Sp.z oo dołożyła wszelkich starań, aby dostarczać informacji o znaku towarowego nazwy firm, produktów i usług wymienionych w niniejszej instrukcji. Towarowymi przedstawione poniżej pochodzą z różnych źródeł.

Microsoft Windows, Access, Visio, Excel, SQL Server i Internet Explorersą znakami towarowymi firmy Microsoft Corporation.

Uwaga ogólna:

Niektóre nazwy produktów użyte w niniejszej instrukcji są używane wyłącznie w celach identyfikacyjnych i mogą być znakami towarowymi odpowiednich firm.

Grudzień 2015Edition dla Avolution ABACUS wersji 4.5.

Podręcznik Wersja 1.0

Generowane, wydrukować, i związany w Australii.