O que ABACUS fazer?

Navegação: Introdução à ABACUS>

O que ABACUS fazer?

Envie seus comentários neste tópico.

Para obter ajuda em outros idiomas / traduções por favor clique Aqui .

ABACUS converte o trabalho de adivinhação de lidar com soluções, sistemas, software, informações, tecnologia, processos de negócios e / ou empresas inteiras (colectivamente referidos como arquiteturas). Ele pode ajudá-lo a projetar de forma pragmática, monitorar, simular, analisar e visualizar o seu arquitetura modelando-lo, analisá-lo em formas intuitivas (por exemplo, gráficos, diagramas e 3D) e depois avaliá-lo contra seus requisitos não-funcionais.

Nota

Requisitos não funcionaissão os requisitos que não se relacionam diretamente à forma como um produto funciona. Em vez disso, eles estão preocupados com a forma como ele opera. Requisitos não funcionais incluem coisas como o desempenho, a abertura, evolvability, qualidade, escalabilidade, modularidade, etc. (ao contrário de requisitos funcionais, como, ligar esta luz quando este botão é clicado). Tradicionalmente, os requisitos não-funcionais têm sido difícil - se não impossível - de medir. Na verdade, ABACUS é o único produto que pode objectiva e quantificável medir os três primeiros - desempenho, abertura, e evolvability.

Simplificando, você entra na arquitetura e que você precisa que ele faça. ABACUS diz-lhe então se ele vai fazer o necessário e assinala as debilidades e lacunas.

ABACUS baseia-se em mais de 20 anos de pesquisa de sistemas e muitos mais anos de teoria dos sistemas estabelecidos. Dá-lhe, respostas objetivas, confiáveis ​​quantificáveis, para que você não está confiando na avaliação subjetiva.

ABACUS significa Architecture-Based Análise, Comunicação e Understanding de Sfo r. Ele pode ajudá-lo com qualquer arquitetura de grande escala, mas é geralmente usado para quatro (4) coisas:

· Evolvinga arquitetura atual. Por exemplo, se sua arquitetura existente carece de desempenho, ABACUS irá visualizar a arquitetura para você, identificando os problemas (pontos de estrangulamento, etc.), em seguida, dizer-lhe exatamentecomo melhorar a arquitectura.

· Projecçãouma nova arquitetura. Por exemplo, se você precisar de uma arquitetura totalmente nova, e você está projetando-lo sozinho, ABACUS irá dizer-lhe exatamentequais os componentes que você precisa e como devem ser conectados.

· Aquisitivouma nova arquitetura. Por exemplo, se você tiver chamado para apresentação de propostas sobre o desenho de uma nova arquitetura, e você está escolhendo entre três projetos, ABACUS irá dizer-lhe exatamentequal deles se adapte às suas melhores requisitos.

· Combinandoatuais arquiteturas existentes. Por exemplo, se você precisa combinar duas ou mais arquiteturas distintas, ABACUS irá guiá-lo.

Veja também

Como você faz isso (visão geral) | O que é arquitetura? | Como é uma arquitetura representada em ABACUS?

© 2001-2015 Avolution Pty Ltd. Todos os direitos reservados.


Como usar ABACUS (visão geral)

Navegação: Introdução à ABACUS>

Como usar ABACUS (visão geral)

Envie seus comentários neste tópico.

Este tópico fornece uma visão geral básica das tarefas envolvidas com o uso de ABACUS.

O diagrama a seguir ilustra o processo de análise baseada em arquitetura que ABACUS prevê evolução de uma arquitetura atual para uma nova arquitetura ou de destino.

O Processo ABACUS

Para usar ABACUS:

1. Auditoria - Antes de utilizar o ABACUS, você deve reunir todas as informações que você tem sobre a arquitetura, e seus requisitos.

· Arquitetura - Identificar os potenciais componentes da arquitetura e como eles interagem. Deve haver apenas alguns componentes no nível superior. Estes são chamados de "componentes essenciais". Mesmo as arquiteturas mais complexos devem ter menos de 10 componentes essenciais. por exemplo. Os componentes essenciais da arquitetura de uma companhia de seguros pode ser políticas, recibos, reclamações e pagamentos.

· Requisitos- Você tem que saber o que é esperado da arquitetura, a fim de determinar se é satisfatório. por exemplo. Número de transações por hora.

· Onde você encontrá-lo? - Esta informação pode vir de especificações de requisitos, documentos de projeto, entrevistas com as partes interessadas, o código implementado, etc. Basicamente, qualquer material que está disponível ABACUS oferece informações sobre a arquitetura.

2. Povoar -Use ABACUS para modelar sua arquitetura e para especificar os requisitos da arquitetura serão medidos contra.

· Arquitetura - Em ABACUS você começa com uma arquitetura vazio - você tem que povoar isto. Isto significa introduzir todas as informações que recolheu arquitetura acima. Você pode preencher sua arquitetura manualmente (usando o menu do botão direito), ou você pode preenchê-lo automaticamente (a partir do Microsoft Visio, Excel, Access, etc.). Normalmente, os mais alto níveis (mais abstratos) da arquitetura será preenchida manualmente, e os níveis mais baixos (mais concretas) será preenchido automaticamente.

· Requisitos - Como você adicionar seus componentes e conexões, você especificar suas propriedades. Na maioria dos casos, estas propriedades serão os requisitos da arquitectura. Por exemplo, se você vai ter um nó 1250 MIPS / cluster, você deve adicionar o nó como um componente, em seguida, adicione a propriedade performance, e atribuir um valor de 1250 MIPS.

3. Analisar - Use ABACUS para analisar de forma elegante e visualizar a estrutura complexa de sua arquitetura. Vocês pode analisar sua arquitetura em uma série de maneiras ou de um número de pontos de vista, incluindo diagramas, 3D e Explorer. Alternativamente, você pode querer usar algumas vistas mais específicos como segue:

· Gráfico sua arquitetura - para obter desempenho (tempo de resposta, largura de banda, etc.), custo (barra, pizza, etc.) ou evolvability (espaço capacidade, trade-off, etc.) pontos de vista.

· Criar um relatório sobre a sua arquitectura.

4. Simular - Use ABACUS para simular de sua arquitetura de desempenho, disponibilidade, custo, abertura, etc.

· Para fazer isso, execute um dos simuladores. ABACUS avalia o seu arquitetura contra suas necessidadesatravés da realização de uma simulação. Ele lê e analisa a arquitetura atual, execute simulações, e calcula algumas novas propriedades. Estas propriedades são salvos de volta para a arquitetura. As novas propriedades são os dados que você está tentando analisar, como a utilização, tempo de resposta, largura de banda,% de disponibilidade, TCO etc.

5. Engenheiro- Use ABACUS para responder a várias "what if" cenários e controlar a evolução de sua arquitetura. Engenharia é o processo de repetir o Preencher - Analisar - Simular ciclo.

· Neste ponto, você'veprovavelmente desenvolveu uma compreensão da arquitetura atual e destacou as áreas que você precisa para evoluir. Muitas vezes, no entanto, você precisará repetir o Preencher - Analisar - processo de simular um número de vezes. Este será, provavelmente, porque pode levar um par de iterações antes de encontrar a Arquitetura Target. Além disso, se sua arquitetura é muito complexo, você pode querer repetir o processo para cada "nível" da arquitetura.

6. Planoo futuro de sua arquitetura utilizando a informação fornecida por ABACUS.

Nota

Se você não está tentando desenvolver uma arquitetura existente, você pode precisar repetir algumas etapas várias vezes, e em uma ordem diferente. Depende do que você está tentando fazer. Por exemplo, se você está projetando uma nova arquitetura, você provavelmente só preencher sua arquitetura de uma vez, e, em seguida, usar ABACUS durante um longo período de tempo para orientar a evolução futura (s) da arquitetura. Por outro lado, se você está comprando uma nova arquitetura e tem várias alternativas para escolher, você vai precisar descobrir e preencher para cada uma das alternativas, e, em seguida, analisar e simular cada um de forma independente antes de realizar uma comparação final no fim.

Veja também

O que ABACUS fazer? | O que é arquitetura? | Como é uma arquitetura representada em ABACUS? | Preenchendo sua arquitetura | Analisando sua arquitetura | Simulando sua arquitetura


O que é arquitetura?

Navegação: Introdução à ABACUS>

O que é arquitetura?

Envie seus comentários neste tópico.

A arquitetura é um resumo conceito- Não um físico coisa. É uma descrição rica e abrangente ou compreensão da estrutura de um sistema - capturando os componentes e como eles estão conectados (interagir). Porque a noção de arquitetura é tão abrangente, é fundamental para o custo, disponibilidade, capacidade de evoluir, abertura e desempenho do sistema. A arquitetura de som é um pré-requisito de um sistema de som.

Em ABACUS, você modela sua arquitetura. Para simplificar, nós chamamos este modelo arquitetônico de uma arquitetura.

O diagrama abaixo ilustra a arquitetura típica de 5componentes (numa hierarquia) ligados por ligações de 2. As etiquetas indicam os nomes dados as várias partes da arquitetura em ABACUS.

A arquitetura simples

ABACUS considera todas essas coisas para ser parte da arquitetura:

· Componentesrepresentam as entidades de sua arquitetura que você poderia descrever como "coisas". Para uma companhia de seguros, os componentes podem ser os sistemas para as políticas de processamento, reclamações, pagamentos e recebimentos.

· Conexõesrepresentam as relações entre estes componentes. Por exemplo, em uma companhia de seguros, as receitas são geradas para as políticas válidas, as reivindicações são feitas contra as políticas válidas e reivindicações válidas resultar em pagamentos. Ao pensar arquitetonicamente - especialmente quando se utiliza ABACUS - conexões são tão importantes como componentes, e eles são tratados de uma forma quase idêntica.

· Tudo na árvore pode ter Propriedades. As propriedades são coisas como a forma como você exigir o seu sistema para executar, o número de linhas de código que tem, a percentagem dessas linhas que são comentários, etc. ABACUS considera todas essas coisas a fazer parte da arquitetura.

· Por usar hierarquias(i.e. sub-componentes e sub-conexão), Você pode ocultar informações e de-compor sua arquitetura. O modelo de arquitetura ABACUS é extremamente flexível. Qualquer componente em qualquer nível pode ser relacionado a qualquer outro componente em qualquer outro nível por qualquer conexão em qualquer nível.

· Acessórioé a operação pela qual os componentes portos são obrigados a conexãopapéis. Portas e Roles são a interfacesentre os componentes e ligações. Eles são usados ​​para ligar as conexões para os componentes. Conexões têm uma origem e um dissipador Função(facilitar o fluxo de dados a partir do componente de fonte para o componente de pia)e, conceitualmente, os componentes têm portas. Para simplicidade, no entanto, em ABACUS portas componentes não são mostrados e os papéis de ligação estão directamente ligadas os próprios componentes.

· Os componentes e as ligações são de um certo Tipo. Isto é principalmente para fins de classificação. Por exemplo, as políticas, reclamações, pagamentos e recebimentos são componentes do tipo 'Sistema'. As políticas válidas, reclamações, etc, são válidas as conexões do tipo "Transação". O tipo atribuído a um componente ou uma ligação fornece um modelo para as propriedades e as normas que tem. Por exemplo, um tipo de componente de servidor pode ter 'Make & Model' padrãoe uma propriedade de Endereço IP. Ao contrário de outras ferramentas rígidas com uma base de dados de base relacional (RDB) back-end, em ABACUS você pode criar livremente seus próprios novos tipos e atribuir suas próprias combinações de propriedades e normas para eles.

· Bibliotecas padrão de propriedades podem ser especificadas e atribuído a qualquer outra coisa na arquitetura. Estas são conhecidas como bibliotecas Padrões. Por usar Padrões, Você só precisa de recolher as propriedades de sistemas específicos - as propriedades padrão já estão lá. Por exemplo, as características de desempenho do padrão do Microsoft Windows 2000 pode ser atribuído a qualquer componentes a utilizar o sistema operativo Microsoft Windows 2000.

Veja também

Como é uma arquitetura representada em ABACUS? | O que ABACUS fazer? | Como você faz isso (visão geral) | Criando um novo tipo


A interface ABACUS

Navegação: Introdução à ABACUS>

A interface ABACUS

Envie seus comentários neste tópico.

Quando você começar a ABACUS, você verá a tela principal, que está vazio, exceto para os menus e barra de ferramentas no topo, uma janela vazia Explorer ea barra de título. Esta tela será o hub de sua interação com ABACUS.

Os principais elementos são:

· os menus principais

· as barras de ferramentas

· o menu do botão direito

· os Windows Explorer e propriedade

· a barra de status

Os menus principais

Os menus são dispostos em uma ordem lógica.

Os menus são descritos como se segue;

· Menu Arquivo- O menu Arquivo permite criar, abrir, fechar, salvar, exportar e publicar arquivos ábaco. Ele também permite que você criar, abrir, fechar e salvar arquivos ABACUS Biblioteca.

· Menu Editar- O menu Editar permite-lhe cortar, copiar, colar, excluir, renomear, localizar e classificar elementose desfazer / refazer operações.

· Vista menu- O menu Exibir permite que você abra ou feche a vários interface do Windows e barra de status, Navegue para a frente e para trás, vá para visualizações específicas e gerir dashboards.

· Menu Inserir- O menu Inserir permite que você adicione novo padrões, Modelos, tipos, elementos, vistapontos, Catálogos, diagramas, gráficos, Relatórios e matrizes.

· Menu de análise- O menu Analysis permite executar avaliações em comparação com uma arquitetura inclusive; desempenho, custo, confiabilidade, modularidade e abertura.

· Menu Ferramentas- O menu Ferramentas permite executar scripts, Estabelecer metas para a arquiteturae realizar e arquitetura 'diff'. Você também pode modificar as opções do programa e personalizar a interface a partir do menu ferramenta.

· Menu Janela- O menu Janela permite atracar, organizar, mostrar e ocultar as janelas abertas.

· Menu Ajuda- No menu Ajuda, você pode acessar o arquivo de ajuda ABACUS. Você pode acessar o site, ver o seu licença acordo e visualizar detalhes gerais sobre ABACUS, incluindo a versão do software e ABACUS de apoio e informações de contacto. Você pode fazer comentários através da página de notificação questão. Se necessário, você pode digitar uma chave de registro por meio do menu Ajuda.

Esta é a ordem que você normalmente vai seguir quando você está realizando suas tarefas;Uma vez que você criou ou abriu um arquivo, Você normalmente preencher sua arquitetura, em seguida, Visão-lo (em Explorer, diagramas, 3D, gráficos, etc). Neste ponto, você quer executar um avaliador, Ou você vai repetir o processo com a mesma arquitetura ou uma arquitetura diferente. (Vejo Como usar ABACUS (visão geral) para mais detalhes.)

Dê uma olhada através dos menus principais e tente imaginar como você vai aplicá-las ao seu sistema.

Nota

Você pode Personalize seus menus a qualquer momento.

As barras de ferramentas

Por padrão, existem as seguintes barras de ferramentas;

· a barra de ferramentas principal -

· a Simulação barra de ferramentas -

· a barra de ferramentas View -

· a Ferramenta de diagramabar (se um diagrama está aberto) -

· o Macro Gravação barra de ferramentas -

Dê uma olhada através dos botões na barra de ferramentas cada passando o mouse sobre eles para ver a ferramenta de ponta (shortcut-key).

Nota

Apenas alguns botões estarão ativos, dependendo do que você tiver selecionado na janela do Explorer e você pode Personalize suas barras de ferramentas a qualquer momento.Além disso, o 'Validar / check Projeto Restrições' botão na barra de ferramentas principal e os botões da barra de ferramentas Simulation irá destacar Vermelho quando uma mudança para o repositório subjacente exige uma re-validação do projeto ou uma re-simulação desse simulador respectivamente. Passe o mouse sobre o botão para ver quais arquiteturas são afetados.

O menu do botão direito

Os principais menus e barras de ferramentas são nãousado para tudo, embora. Muitas vezes, é mais conveniente usar o menu de contexto do botão direito do mouse para várias operações. (Além disso, nem todos os comandos disponíveis através do botão direito do mouse estão disponíveis através dos principais menus, barras de ferramentas ou comandos de teclado.)

Por exemplo, uma vez que você criou um arquivo, e você tem um diagrama de árvore de sua arquitetura, é melhor botão direito do mouse em arquiteturas na árvore para adicionar uma nova arquitetura. Da mesma forma, você deve clicar com o botão direito sobre Componentes para adicionar um novo componente. Clique com o botão direito do mouse sobre algumas coisas na árvore para ver o que você pode fazer.

Dica

Geralmente, você vai usar os menus principais para executar as tarefas mais alto nível, como a avaliação de sua arquitetura. As tarefas de baixo nível - como a adição de componentes e conexões individuais - são feitas usando as barras de ferramentas e / ou menu do botão direito.

Os Windows Explorer e Propriedades

Quando você abrir ou criar um arquivo, um diagrama de árvore irá exibir na janela do Explorer. É uma janela para a sua arquitectura. E, como você selecionar elementos dentro janela do Explorer três outras janelas; As propriedades geraisReferências,e janelas de propriedades será atualizado para refletir a informação detalhada sobre a sua seleção.

Nota

As propriedades geraisReferências,e janelas de propriedades ficam ocultas por padrão. Vejo Personalizando a interface para saber como mostrá-los e deixá-los potencialmente expostas permanentemente.

Enquanto você está construindo sua arquitetura, as janelas do Explorer e propriedades são a representação mais útil. Porque eles podem ser recolhidas e expandido conforme necessário, e eles não se tornem pesados.

A janela do Explorer tem um Tree (ea barra de status) e as janelas propriedades têm 5 Seções:

· Tipo

· Padrões

· Descrição

· Referências

· Propriedades

ABACUS considera todas essas coisas a fazer parte da arquitetura.

Árvore

Esta secção tem uma árvore agrupados em 3 áreas do seguinte modo:

1. Meta-modelo

· Padrões- Se vários componentes têm o mesmo conjunto de propriedades, você pode definir o conjunto de up-front, e depois é só atribuí-lo aos componentes. O mesmo vale para conexões e qualquer um dos outros elementos. Estes conjuntos de propriedades padrão são armazenados na Padrõesgalho da árvore. Em vez de definir cada propriedade para cada componente, e cada propriedade para cada conexão etc, basta atribuir um padrão. Por exemplo, as características normais de Unix-HP / UXpodem ser salvos como um Padrão e atribuído a quaisquer componentes usando o Unix-HP / UXsistema operativo como mostrado pela OS01 servidor na imagem acima.

· Tipos - Este ramo da árvore é uma biblioteca dos tipos de componentes e conexões que você pode usar. Tipos são usados ​​para definir o meta-modelo para sua arquitetura e para a classificação e filtragem ao ver sua arquitetura. Eles também determinar um modelo para o padrões, Propriedades e limitações de seus componentes / conexões pode ter.

· Pontos de Vista- VisãopontoS pode ser criado a partir de diagramas existentes e podem ser usadas para criar novos diagramas.Eles são stencils diagrama.

· Modelos - Modelos loja reutilizável padrões de componentes e ligações, juntamente com a maneira pela qual eles são representados ou visualizada. Eles podem ser considerados como "mini" arquitecturas ou soluções que podem ser colocados em arquitecturas existentes.

2. Arquiteturas -As Arquiteturas filial da árvore é onde você construir o arquitetura (s) de seu sistema. (Isso é chamado de preencher a arquitetura.) Você pode ter qualquer número de arquiteturas em um único arquivo ABACUS.

3. Dashboards - O Dashboards ramo da árvore é o lugar onde você pode acessar qualquer salvos dashboards para o projeto.

Nota

Itens na árvore Explorer que tiveram sua Permissão atualização removido (ou seja, eles são somente leitura) são mostradas em cinza.

Tipo

Esta seção indica o componente ou tipo de conexão específica do elemento atualmente selecionado na árvore.

Padrões

Esta seção fornece uma lista da padrões para o elemento atualmente selecionado na árvore.

Descrição

Esta seção fornece uma breve descrição do elemento selecionado na árvore. Quaisquer hiperlinks relacionados também podem ser adicionados a esta seção. Estes incluem sites ou caminhos absolutos locais que apontam para mais informações sobre o elemento de dado. Várias linhas também são permitidos. Hiperlinks válidos precisa para começar com um dos 5 cordas; http: //, https: //, ftp: //, file: /// ou mailto :.

Dica

Para hiperligações com espaços, os usuários podem digitar o URL ou o caminho, selecione o texto necessário e Clique com o botão direito| Hyperlink. Isso vai mudar nenhum espaço para % 20por isso toda a URL ou caminho irá funcionar corretamente.

Criado e modificado

Estes seçãosfornecero usuário ea data / hora para a criação de e última modificação, o elemento atualmente selecionado na árvore.

Referências

Esta seção fornece uma lista da componentes de entrada e saída para o elemento atualmente selecionado na árvore.Ele também mostra os diagramas, 3D e pontos de vista gráfico que o elemento selecionado no momento aparecerá. Se um diagrama for selecionada, ela mostra o Ponto de Vista, se aplicável para o diagrama e de pontos de vista em geral mostra nenhum Dashboards a vista aparece em. E quando um Padrão é selecionado na árvore que mostra o uso da norma por tipos, componentes e conexões.

Propriedades

Esta seção é onde você define as características de os elementos dentro sua arquitetura, como a maneira que for necessário para executar, o número de linhas de código que tem, a percentagem dessas linhas que são comentários, etc.

Os 'input' e 'Propriedades de saída "do pré-construídos simuladores será mostrado na janela Propriedades com um ícone seletor de linha de entrada da propriedade ( [image] ) E o ícone de saída ( [image] ), Respectivamente, com uma dica de ferramenta que indica que por exemplo, pré-construído simulador a propriedade está relacionada com, 'Output modularidade' ou 'Entrada de Desempenho'. A seta sobre os ícones de saída destacará Vermelho ( [image] ) Quando a propriedade está desatualizado devido a uma propriedade subjacente ou mudança estrutural para o repositório com o simulador exigindo re-simulação de acordo com o Vermelho destacando em Barra de ferramentas Simulation .

A barra de status

A parte esquerda da barra de status mostra o caminho completo para o elemento repositório atualmente em foco, seja selecionado na janela do Explorer ou no diagrama lona. Isto é de modo que o local exacto na hierarquia repositório para o elemento de dado pode sempre ser facilmente determinada. A parte direita da barra de status mostra várias mensagens operacionais tais como 'Abrir arquivo ABACUS bem sucedida »e« Custo Cálculo Concluído'.

Veja também

Como você faz isso (visão geral) | Personalizando a interface | O que é arquitetura? | Como é uma arquitetura representada em ABACUS? | Trabalhando com arquivos ABACUS


Personalizando a interface ABACUS

Navegação: Introdução à ABACUS>

Personalizando a interface ABACUS

Envie seus comentários neste tópico.

Você pode alterar a aparência eo comportamento da interface ABACUS de muitas maneiras. ABACUS inclui várias combinações de configurações predefinidas que você pode usar para aplicar um grupo de personalizações para o interface. Além disso, você pode fazer personalizações individuais para itens como janelas, barras de ferramentas, teclas de atalho, e vários exibe as opções.

Organizar e Doca do Windows

Você tem muitas opções para organizar janelas dentro da interface para ABACUS, incluindo o seguinte:

· Janelas Tab-Dock.

· Janelas doca para a extremidade de uma armação na interface.

· Minimizar janelas de ferramentas ao longo da borda da interface.

· Repor a colocação da janela para o layout padrão.

O Windows Docking

Quando uma janela é acoplável, ele pode ser preso a um lado de uma estrutura dentro da interface, ou que podem ser dispostos em painéis com guias no interior da armação. Um diamante guia aparece quando você arrastar as janelas de seu local atual para outro local na interface. O diamante guia permite que você rapidamente voltar a encaixar uma janela em um dos quatro lados do quadro ou no centro, como um painel com guias. Quando uma janela está desencaixado ou não acoplável, ele flutua em cima das outras janelas.

Para encaixar janelas

1. Clique na janela que você deseja para atracar, para dar-lhe o foco.

2. No Janelamenu, clique em Acoplável.

3. Arraste a janela de seu local atual para o meio do quadro que você deseja encaixá-lo com.

Aparece uma guia de diamante. As quatro setas do ponto de diamante para as quatro bordas do quadro e do centro representa o painel de abas.

Dica

Para mover uma janela encaixável sem encaixando-a no lugar, pressione CTRL enquanto arrasta-lo.

4. Quando a janela que você está arrastando atinge a posição onde deseja encaixá-lo, mova o ponteiro sobre a parte correspondente do guia de diamante. Um esboço da janela aparece na área designada.

5. Para encaixar a janela na posição indicada, solte o botão do mouse.

Por exemplo, se Exploradorestá ancorado na borda esquerda da interface e você quer para encaixá-lo na borda direita, você iria arrastar Exploradorem direção ao meio da interface, mova o ponteiro sobre o lado direito da guia de diamante, e em seguida, solte o botão do mouse.

Minimização do Windows

Do Windows (se são ferramenta Windows - que aparece no Visãomenus, ou Document Windows - que aparece no Janelamenu) apoiar um recurso chamado Auto Hide. Ocultar automaticamente permite que você ver mais de sua arquitetura de uma só vez, minimizando as janelas ao longo das bordas da interface quando não estiver em uso.

Para ativar o Auto Hide

1. Clique na janela que você deseja ocultar a dar-lhe o foco.

2. No Janelamenu, clique em Auto ocultar.

- ou -

2. Clique no ícone de anotações na barra de título da janela.

Ocultar automaticamente Ativado

Quando uma janela de auto-ocultar perde o foco, ele desliza automaticamente de volta ao seu guia sobre a borda da interface. Enquanto uma janela é auto-ocultar, seu nome e ícone são visíveis em uma guia na borda da interface. Para exibir uma janela de auto-ocultar, mover o ponteiro sobre a guia. A janela desliza para trás à vista e está pronto para uso.

Nota

Uma janela que é auto-oculto não pode ser encaixado. Para encaixar uma janela você precisará desligar Ocultar automaticamente, conforme descrito abaixo.

Para desativar o Auto Hide

1. Clique na janela que você deseja manter visível a dar-lhe o foco.

2. No Janelamenu, clique em Auto ocultarpara limpar a marca de verificação.

- ou -

2. Clique no ícone de anotações na barra de título da janela.

Auto Esconder pessoas com mobilidade condicionada

Dica

Janelas que têm Ocultar automaticamente ativado deslize temporariamente em vista quando a janela tem o foco. Para ocultar a janela novamente, selecione um item para fora da janela atual. Uma vez que a janela perde o foco, ele desliza para trás para fora de vista.

Repor o Windows Layouts

Você pode retornar a interface para o layout da janela padrão usando o Redefinir Layout de Janela comando. Quando você executar este comando, ocorrem as seguintes ações:

· Todas as janelas são movidos para suas posições padrão.

· Windows que estão fechados no layout da janela padrão são fechados pelo comando.

· Janelas que estão abertas no layout da janela padrão são abertas pelo comando.

· Windows que estão escondidos / visíveis no layout de janela padrão são feitos escondido / visível pelo comando.

Para repor a colocação da janela para o layout padrão

1. No janelasmenu, clique em Redefinir Layout de Janela.

Menus e barras de ferramentas Personalizar

Você pode alterar o layout, posição e conteúdo de menus e barras de ferramentas na interface. Você também pode adicionar botões para as barras de ferramentas e alterar o ícone atribuído a qualquer botão.

Criar novas barras de ferramentas

Para criar uma nova barra de ferramentas

1. No Ferramentasmenu, selecione Personalize.

2. no Personalizecaixa de diálogo, selecione o Barras de ferramentastab.

3. Escolher Novo.

4. no Novo Barra de ferramentascaixa de diálogo, digite um nome para a barra de ferramentas.

5. Escolher Está bem.

Para adicionar um botão de comando a um menu ou barra de ferramentas

1. No Ferramentasmenu, selecione Personalize.

2. no Personalizecaixa de diálogo, selecione o Comandostab.

3. Selecione uma categoria e arraste um comando da caixa de diálogo para o menu ou barra de ferramentas.

4. Escolher Fechar.

Dica

Mantendo pressionada a tecla Alt permite rápida customizar comandos como se o diálogo Personalizar estava aberta.

Veja também

A interface ABACUS


Trabalhando com arquivos ABACUS

Navegação: Introdução à ABACUS>

Trabalhando com arquivos ABACUS

Envie seus comentários neste tópico.

Um arquivo ABACUS é um recipiente para um modelo de seu arquitetura . Dentro de um único arquivo ABACUS, você pode modelar qualquer número de arquiteturas de qualquer número de vezes.

Quando você abre ABACUS, não há arquivos abertos. Para trabalhar em sua arquitetura, você tem que criar um novo arquivo ou abrir um arquivo existente.

Quando você abrir ou criar um novo arquivo, uma árvore na janela do Explorer exibirá automaticamente. Este ponto de vista do explorador mostra sua arquitetura para data. Quando você fechar o arquivo, a árvore na janela do explorador também desaparecerá.

Para criar um novo arquivo de ABACUS

1. Selecionar Arquivo| Novo ...

2. Na caixa de diálogo New Project que aparece (como mostrado abaixo) Escolherque quer criar um modelo em branco, um modelo a partir de um ABACUS biblioteca padrão , Um modelo a partir de uma biblioteca ABACUS costume, um modelo de XML, MS Access , MS Visio , MS Excel , MS SQL Server , um Empresa Servidor modelo ou uma biblioteca ABACUS personalizado (arquivo .abacuslib).

3. Clique no Está bembotão e siga as caixas de diálogo que podem aparecer.

Dica

Você não será solicitado a nomear o arquivo até que você salvar ou fechar. É uma boa idéia para salvar o arquivo assim que você criá-lo. Então você não terá que se preocupar com a nomeá-lo mais tarde no processo quando você está se concentrando em outras coisas complexas (como preencher a sua arquitectura).

Criar um novo projeto

ABACUS Bibliotecas Padrão

ABACUS suporta mais 100 quadros públicos e notações alguns dos quais estão apresentados abaixo. Ao escolher para criar um novo projeto a partir de um usuários da biblioteca padrão tem um início rápido para modelagem dentro de uma estrutura estabelecer aproveitando ao máximo quaisquer tipos de elementos definidos, atributos, notações, pontos de vista e modelos ou padrões. Bibliotecas padrão adicionais estão disponíveis gratuitamente através da Comunidade Avolution Aqui .

Novo projeto de biblioteca padrão

Para salvar um novo arquivo ABACUS

1. Selecionar Arquivo| Salvar como

Dica

Os nomes de arquivo pode ser qualquer comprimento e pode conter quaisquer caracteres e espaços alfa-numérico. Eles não podem conter o caractere til (~), o pipe (|) personagem, o ponto de interrogação, ou os personagens normalmente utilizados nas descrições caminho, tais como a barra invertida (\) - exceto como parte do caminho (?).

Para abrir um arquivo existente ABACUS

1. Selecionar Arquivo| Aberto

Nota

Se você está abrindo um arquivo de um local de rede compartilhada que já está aberto para outro usuário, ABACUS irá lhe fornecer acesso somente-leitura. Ao usar ABACUS com acesso somente-leitura, você não será capaz de executar operações de gravação, tais como preencher sua arquitetura e em execução avaliadores. Você pode, no entanto, ver a sua arquitetura usando a visualização do explorador e visualizações em 3D.

Veja também

Como é uma arquitetura representada em ABACUS?


Como é uma arquitetura representada em ABACUS?

Navegação: Introdução à ABACUS>

Como é uma arquitetura representada em ABACUS?

Envie seus comentários neste tópico.

Em ABACUS, você modela sua arquitetura. Para simplificar, nós chamamos este modelo arquitetônico de uma arquitetura.

O diagrama abaixo ilustra como a arquitetura típica de 5componentes (numa hierarquia) ligados por ligações de 2 iria ser representada no ábaco.

Como uma arquitetura simples é representado em ABACUS

Você pode ter qualquer número de arquiteturas em um único arquivo ABACUS.

A primeira arquitetura na árvore

Normalmente, você deve criar uma nova arquitetura sempre que você deseja avaliar uma mudança. Por exemplo, você modelar sua arquitetura existente em primeiro lugar - esta seria a primeira arquitetura na árvore. Você pode chamá-lo de 'Actual'.

O segundo

Quando você deseja modelar e avaliar uma mudança para sua arquitetura existente (por exemplo, aumento requisitos) que você criar uma nova arquitetura. A maneira mais fácil de fazer isso seria a criação de uma cópia de 'Actual' e renomeá-lo "Evolution 1 Tentativa 1 '. Esta seria a segunda arquitectura em árvore. Se suas avaliações de 'Evolution 1 Tentativa 1' for bem sucedido, você pode renomeá-lo para simplesmente 'Evolution 1'.

O terceiro

Se 'Evolution 1 Tentativa 1' não satisfaz suas necessidades, você pode criar uma cópia do mesmo, renomeá-lo para 'Evolution 1 Tentativa 2', e tente novamente. Esta seria a terceira arquitectura em árvore.

Veja também

O que ABACUS fazer? | Como você faz isso (visão geral) | O que é arquitetura? | Trabalhando com arquivos ABACUS | Criando ou duplicação de uma arquitetura


Ajuda em outros idiomas

Navegação: Introdução à ABACUS>

Ajuda em outros idiomas

Envie seus comentários neste tópico.

ÁBACO a ajuda está disponível em várias outras línguas / traduções e pode ser baixado a partir dos links abaixo.

Para substituir o atual arquivo de ajuda ABACUScom um arquivo de ajuda traduzido por favor siga estes passos:

1. Salve o arquivo de ajuda a partir do link relevante abaixo.

2. Renomeie o arquivo de ajuda para ABACUS.chm.

3. Abra o arquivo clicando duas vezes nele e se um 'Abrir Arquivo - Aviso de Segurança "diálogo aparece, em seguida, desmarque a opção" Sempre perguntar antes de abrir o arquivo "opção e clique em Abrir.

4. Feche o arquivo.

5. Substitua o arquivo ABACUS.chm na pasta arquivos de programa ABACUS, tipicamente "C: \ Program Files \ Avolution \ ABACUS" ou "C: \ Program Files(x86)\ Avolution \ ABACUS".

Nota

Ajuda sensível ao contexto continuará a trabalhar com os arquivos de ajuda traduzidos.

Arquivos de ajuda ABACUS em outros idiomas:

· árabe / العربية .

· búlgaro / български .

· Chinês simplificado) / 中文 (简体) .

· checo / Česká .

· dinamarquês / Dansk .

· estoniano / Eesti .

· finlandês / Suomen .

· francês / Français .

· alemão / Deutsch .

· húngaro / Magiar .

· islandês / islandês .

· indonésio / Indonésia .

· italiano / Italiano .

· japonês / 日本 の .

· letão / Latvijas .

· Malásia / Malásia .

· maltês / Malte i .

· Norweigen / Norweigen .

· polonês / Po lska .

· Portugueses / Português .

· russo / русский .

· Eslovaco / Slovenski .

· esloveno / Slovenski .

· espanhol / Españoles .

· sueco / Svenska .

· turco / Turco .

· galês / Cymraeg .

Veja também

O que ABACUS fazer?


Preenchendo sua arquitetura

Navegação: Preenchendo sua arquitetura>

Preenchendo sua arquitetura

Envie seus comentários neste tópico.

O processo de construção de um modelo de sua arquitetura é conhecida como povoamento. Uma vez que você descobriu sua arquitetura e identificou suas necessidades, você está pronto para modelar sua arquitetura em ABACUS.

Durante população, você vai entrar todos os detalhes que você sabe sobre sua arquitetura eo que é exigido dele.

Para preencher sua arquitetura

1. Verifique se você tem um ABACUS arquivo aberto , um explorador exibido , e um arquitetura acrescentado .

2. Preencher manualmente os componentes de nível superior e conexões de sua arquitetura. Normalmente, esse será os componentes e conexões mais abstratos.

- ou -

2. Graficamente preencher os componentes e as conexões que você gostaria ver representado esquematicamente, usando o Ferramenta de desenho .

Você também pode querer

3. Preencher usando Catálogos - Você pode visualizar e e componentes conexões de uma forma tabular simples.

4. Preencher usando Matrizes - Você pode visualizar e editar as conexões entre os componentes de uma forma tabular simples.

5. Preencher a partir do Microsoft Access - Você pode importar uma arquitetura de e exportar para Microsoft Access.

6. Preencher a partir do Microsoft Visio - Você pode importar uma arquitetura de e exportar para Microsoft Visio.

7. Preencher a partir do Microsoft Excel - Você pode importar uma arquitetura de e exportar para Microsoft Excel.

8. Preencher a partir do Microsoft SharePoint - Você pode importar uma arquitetura de e exportar para Microsoft SQL Server.

9. Preencher a partir do Microsoft SQL Server - Você pode importar uma arquitetura a partir do Microsoft SQL Server.

10. Importar de XML - Você pode importar uma arquitetura de um fragmento XML ABACUS ou um arquivo XML ArchiMate Interchange Language.

Veja também

Preenchendo a arquitetura manualmente | A Ferramenta de Desenho | Preenchendo a arquitetura do Microsoft Access | Preenchendo a arquitetura do Microsoft Visio | Preenchendo a arquitetura a partir do Microsoft Excel


Preenchendo a arquitetura manualmente

Navegação: Preenchendo seu Arquitectura> Preencher manualmente>

Preenchendo a arquitetura manualmente

Envie seus comentários neste tópico.

Os componentes e conexões de sua arquitetura de alto nível, provavelmente, terá de ser preenchido manualmente. Normalmente, esse será os componentes e conexões mais abstratos.

Para preencher manualmente sua arquitetura

1. Verifique se você tem um Arquivo ABACUSaberta, um exploradorexibida, e um arquitetura acrescentado .

2. Adicionar um componente. Para fazer isso, Botão direito do mousena área da árvore você deseja preencher e selecione Adicionar Sub-Component ...Ou clique no Novo Componenteno botão Exibir barra de ferramentas . Componentes só podem ser adicionados no ramo componentes da árvore. Você quer que seu diagrama de árvore para ser uma representação precisa de sua arquitetura. Quando você descobriu sua arquitetura, você terá aprendido exatamente como tudo se encaixa. Você precisará desse conhecimento quando você adiciona seus componentes e conexões. Se você está adicionando seu primeiro componente, você poderá adicioná-lo diretamente para o ramo de componentes. O resto de seus componentes podem ser no mesmo nível na árvore, ou eles podem ser sub-componentes da primeira.

3. Atualize os valores deas propriedadesde cada componente como você adicioná-lo. Para fazer isso, cliqueno componente, e editar as propriedades exibidas na Janela Propriedades(tipicamente) para a direita. Propriedades são geralmente coisas como requisitos, capacidade de processamento, etc. Quando ABACUS avalia sua arquitetura, ele irá calcular algumas novas propriedades, e salvá-los de volta para a arquitetura. As novas propriedades são os dados que você está tentando analisar, como a utilização, tempo de resposta, largura de banda, etc.

4. Adicione suas conexões e atualizaras suas propriedadescomo você ir - assim como você faz para componentes (mas sob o ramo da árvore Connections).

5. Anexarconexões e componentes. Para fazer isso, localize a conexão, clique em um dos seus termina ou papéis E arraste-o para um componente. Como alternativa, clique em um componente e arraste-o para uma das conexões de funções (isto é, de origem ou de Sink). Ou você pode clicar com o botão direito e arraste um componente para outro componente e selecione Conectar a. Ou simplesmente botão direito do mouse em um componente e selecione Conectar.... Quando você arrasta uma conexão Função, Você verá um símbolo de atalho quando você aponta para um componente que você pode anexá-lo. Isso indica que você não está fazendo uma cópia, você está apenas anexá-lo. Certifique-se de anexá-lo para o componente de destino correto. Por exemplo, se é uma Fonte de conexão Função, Arrastá-lo fazer o componente de origem (isto é, o componente que é a fonte de fluxo de dados).

Dica

Re-ordenação entidades dentro de sua arquitetura (por exemplo, componentes, conexões etc.) no exploradoré bastante fácil. Simplesmente Clique| Aguarde| Arrastara entidade relevante e local em que desejar em sua arquitetura. A funcionalidade reordenação também permite que você coloque as entidades dentro de diferentes hierarquias de sua arquitetura.

Você também pode querer

6. Adicionar Standards (conjuntos pré-configurados de propriedades - presets) para os seus componentes, conexões ou de tipos

7. Altere as propriedades de um componente, ligação ou tipo

8. Desfazer e Refazer operações

9. Alterar o tipo de de um componente ou de conexão

10. Criar um novo tipo ou tipo de grupo

11. Excluir um componente ou conexão

12. Criar, duplicar ou evoluir uma arquitectura

13. Tipos de importação e normas a partir de uma biblioteca

14. Importar de outro arquivo ABACUS, XML, Excel ou Visio

15. Copiar e colar partes (ou todos) de sua arquitetura

16. Localizar e substituir itens em sua arquitetura

17. Expandir / Recolher alguns ou todos os nós na árvore

18. Fundir itens

19. Definir e Validar Restrições para restringir a estrutura de sua arquitetura

20. Desenvolva a sua arquitetura para criar várias soluções arquitetônicas para comparar e linha de base

Veja também

Preenchendo sua arquitetura - Visão geral | Criando um novo arquivo


Desfazer e Refazer

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Desfazer e Refazer

Envie seus comentários neste tópico.

Como muitos aplicativos modernos, ABACUS suporta a capacidade de ambos desfazer e refazer as alterações do usuário recentes feitas em um projeto aberto. Para desfazer a alteração mais recente, basta ativar o comando desfazer. As alterações que foram desfeitas podem ser refeitas, ativando o comando redo; reaplicar a mudança mais recentemente desfeito.

Aviso

Undone mudanças não são capazes de ser reaplicado se as modificações são feitas para o projeto desde que foi desfeita.

Nota

Enquanto a grande maioria das alterações suportam undo / redo em tempo real, alguns diagrama mudanças estêncil, como a criação de uma nova associação de tipo-Forma / Line ou alterar um atributo cor associação, não são capazes de ser desfeita imediatamente. Nestes casos, o diagrama modificado (indicado por um asterisco) deve ser fechada antes que estas alterações pode ser desfeita.

Desfazer e refazer posições de comando

Os comandos de desfazer e refazer pode ser acessado a partir de três locais diferentes:

· No menu Editar

· a barra de ferramentas Padrão

· as teclas de atalho de teclado CTRL + Z(desfazer) e CTRL + Y (refazer)

Dica

O desfazer e refazer botões na barra de ferramentas padrão fornecer listas suspensas exibindo as 10 alterações mais recentes que podem ser desfeitas e refeitas foram respectivamente. Eles também são uma maneira útil para desfazer / refazer várias alterações ao mesmo tempo.


Mudando um componente / Tipo de conexão

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Mudando um componente / Tipo de conexão

Envie seus comentários neste tópico.

Tipos de componentes e de conexão são utilizados principalmente para fins de classificação. Você pode usar tipos de filtros ao exibir sua arquitetura. Por exemplo, em vez de ver a coisa toda, você pode visualizar os componentes de aplicação apenas.

Para alterar um componente / Tipo de conexão

1. Botão direito do mouseno componente ou ligação.

2. Selecionar Alterar tipo de.

3. Escolha um tipo diferente a partir da lista.

Dica

Quando você alterar o tipo, você pode obter algo de novo padrõesou propriedades (tudo o que é associado com o tipo - ver o ramo Tipos da árvore). Seu existente padrões e as propriedades permanecerá inalterada. Você pode criar seus próprios novos tipos e atribuir suas próprias combinações de padrões e propriedades para eles.

Veja também

Criando um novo tipo | Preenchendo sua arquitetura - Visão geral | Analisar sua arquitetura


Criando um novo componente / Tipo de conexão ou tipo de grupo

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Criando um novo componente / Tipo de conexão ou tipo de grupo

Envie seus comentários neste tópico.

Tipos de componentes e de conexão são utilizados principalmente para fins de classificação. Você pode usar tipos de filtros ao exibir sua arquitetura. Por exemplo, em vez de ver a coisa toda, você pode visualizar os componentes de aplicação apenas.

Para criar um novo componente / Tipo de conexão

Nota

Para adicionar tipos ou grupos de tipos em um projeto ABACUS a licença de usuário precisa do Designer add-on capacidade. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

1. Expanda o Tiposgalho da árvore.

2. Botão direito do mouse ligar Tipos de componentes (ou Tipos de conexão).

3. Selecionar Adicionar tipo de componente (ou Adicionar Tipo de conexão) ou Criar grupo.

Dica

Depois de criar um tipo, você deve mudar seu ícone (veja abaixo) e adicionar Propriedades e padrões a ele para o componente ou instâncias de conexão para 'herdar'.

Ícone para mudar para um componente / Tipo de conexão

Nota

Para alterar os ícones para tipos em um projeto ABACUS a licença de usuário precisa do Designer add-on capacidade. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

1. Botão direito do mouse no Tipo de componente (ou Tipo de conexão) Que pretende alterar o ícone.

2. Selecionar Alterar ícone.

3. No browse diálogo Selecionar Ícone para uma localização e escolha um arquivo de imagem e clique em Abrir.

Nota

Você pode ter uma imagem de ícone personalizado de qualquer tamanho, mas ele vai ser sempre dimensionada para caber em uma imagem de 16x16 pixels na janela Explorer. Portanto, se sua imagem ícone personalizado original não é de igual altura e largura no ícone da janela do Explorer será esticada. Assim, imagens personalizadas deve ser de pelo menos 16x16 pixels e se você quiser manter a forma exata do ícone personalizado certificar-se de sua imagem ícone personalizado é igual altura e largura em pixels (16x16 ou maiores). Você também deve ter cuidado em não ter coloridas 'pixels' indo todo o caminho até a fronteira da imagem do ícone personalizado como ele vai olhar pobres na janela do Explorer com ícones adjacentes 'sangramento' em si. Assim, você deve deixar pelo menos uma borda branca 1 pixel.

Dica

Você pode fazer sua imagem ícone personalizado uma .ico, .bmp, .gif, .jpg ou arquivo de formato .png, mas devido a uma limitação no Windows única .ico formato irá visualizar na caixa de diálogo Selecionar Ícone ABACUS se você tem a opção Menu Exibir definido como algo diferente de Miniaturas.

Veja também

Preenchendo sua arquitetura - Visão geral | Analisar sua arquitetura


A exclusão de um componente ou conexão

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

A exclusão de um componente ou conexão

Envie seus comentários neste tópico.

Para excluir um componente ou conexão

1. Botão direito do mouseno componente ou ligação.

2. Selecionar Excluir.

Cuidado

ABACUS irá avisá-lo que pontos de vista serão afetados pela exclusão e pedir-lhe para confirmar a eliminação. Isto é porque os elementos podem existir em muitos diagramas e vale a pena verificar o que a supressão proposta afetará.

Dica

Se você excluir um componente, todos os seus sub-componentes também serão excluídos. Você pode optar por excluir as conexões internas e externas para o componente. Se você optar por não excluí-los, as conexões é anexado para permanecerá, mas eles deixarão de ser anexado. Todos os componentes e as ligações são de um determinado Tipo . Excluindo a componente / conexão não tem impacto sobre o tipo (no ramo Tipos da árvore). De modo semelhante, se o componente / ligação tem um Padrão atribuído, eliminação não terá qualquer impacto sobre o mestre no ramo Standards.

Veja também

Preenchendo sua arquitetura - Visão geral


Criando ou duplicação de uma arquitetura

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Criando ou duplicação de uma arquitetura

Envie seus comentários neste tópico.

Você pode ter qualquer número de arquiteturas em um único arquivo ABACUS. Normalmente, você criar uma nova arquitetura de cada vez que você deseja modelar e avaliar a evolução de seu sistema.

Para criar uma nova arquitetura

1. Botão direito do mouse no Arquiteturasgalho da árvore.

2. Selecionar Nova Arquitetura.

Para criar uma cópia de uma arquitetura existente

1. Botão direito do mousena arquitectura.

2. Selecionar Cópia.

3. Botão direito do mouse no Arquiteturasgalho da árvore.

4. Selecionar Colar.

5. A nova arquitetura será chamado 'Cópia de ...'.

Para evoluir uma arquitetura existente

1. Botão direito do mousena arquitectura.

2. Selecionar Evolua.

3. A nova arquitetura será chamado '... 0,1'.

Nota

Há uma descrição detalhada sobre evolução arquiteturas Aqui .

Veja também

Como é uma arquitetura representada em ABACUS | Evoluindo sua arquitetura


Importando em sua Arquitetura

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Importando em sua Arquitetura

Envie seus comentários neste tópico.

ABACUS permite- importar para sua arquitetura a partir de um .abacus (arquivo ABACUS), .xml (um fragmento XML ABACUS ou um arquivo XML ArchiMate Interchange Language), .vsd formato (Microsoft Visio), e .xls (Microsoft Excel) formato. Isso permite que você construir sua arquitetura de fontes externas rapidamente.

Para importar sua arquitetura a partir da.abacus (arquivo ABACUS)

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Botão direito do mouseno nó Arquitetura, qualquer arquitetura em seu modelo ou qualquer parte da árvore de componentes.

3. Selecionar Importar| A partir da Arquivo...a partir do menu.

4. Escolha um local e o .abacus arquivo e clique no Aberto botão.

Nota

Depois que você selecionou o arquivo que você deseja importar, você será solicitado como você deseja importar as normas, tipose pontos de vista. Você pode importar normas, tipos e pontos de vista quer como padrões novos ou fundidos, tipose pontos de vista. A configuração padrão é para os padrões, tipos e pontos de vista a ser mesclado com as normas existentes, tipos e pontos de vista se eles já existem (com o mesmo nome) na tua projeto.

Para importarsua arquitetura a partir da.xml (um fragmento ABACUS XML ou um arquivo XML ArchiMate Interchange Language)

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Botão direito do mouseem um nó Arquitetura, qualquer arquitetura em seu modelo ou qualquer parte da árvore de componentes.

3. Selecionar Importar| A partir da XML ...a partir do menu.

4. Escolha um local e o .xml arquivo e clique no Aberto botão.

Nota

ABACUS só vai importar um fragmento devidamente formado XML ABACUS ou um arquivo XML ArchiMate Interchange Language. Depois que você selecionou o arquivo XML que deseja importar, você será solicitado como você deseja importar as normas, tipose pontos de vista. Você pode importar normas, tipos e pontos de vista quer como padrões novos ou fundidos, tipose pontos de vista. A configuração padrão é para os padrões, tipos e pontos de vista a ser mesclado com as normas existentes, tipos e pontos de vista se eles já existem (com o mesmo nome) na tua projeto.

Para importarsua arquitetura a partir da.vsd(Visio arquivo) Vejo Aqui .

Para importarsua arquitetura a partir da.xls (Excel arquivo) Vejo Aqui .


Importação de tipos e padrões de uma biblioteca

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Importação de tipos e padrões de uma biblioteca

Envie seus comentários neste tópico.

Você pode importar os tipos e padrões de um arquivo de biblioteca ABACUS. Você também pode exportar tipos e padrões de seu arquivo ABACUS para um arquivo de biblioteca ABACUS.

Para importar os tipos e padrões de uma biblioteca em sua arquitetura

1. Verifique se você tem um Arquivo ABACUSaberto eo Windows Explorerexibida.

2. Selecione Arquivo | Abertopara abrir um Arquivo de biblioteca ABACUS.

3. A Biblioteca ABACUS será aberto em uma segunda folha com guias na janela do Explorer e você terá que desencaixar esta folha tabulada para ser capaz de arrastar-e-soltar dele para o arquivo ABACUS originais.

4. Drag-and-droptipos e padrões da biblioteca em sua arquitetura.

- ou -

1. Selecione Arquivo | Novo ...

2. Crie um novo Arquivo ABACUScom base numa Arquivo de biblioteca ABACUS.

Para exportar tipos e padrões de sua arquitetura em uma biblioteca

1. Verifique se você tem um Arquivo ABACUS abra a Windows Explorerapresentada, uma Arquivo de biblioteca ABACUSaberto eo Janela Bibliotecaexibida.

2. Drag-and-droptipos e padrões de sua arquitetura para a biblioteca.

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente


Copiar e colar

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Copiar e colar

Envie seus comentários neste tópico.

Você pode copiar parte ou a totalidade de sua arquitetura e colá-lo em um local diferente na árvore.

Copiar

1. Botão direito do mouseno item que você deseja copiar.

2. Selecionar Cópia.

Colar

1. Navegue pela árvore para encontrar o lugar que você gostaria de colar o item.

2. Botão direito do mousesobre o ramo que você quer que ele apareça dentro.

3. Selecionar Colar.

4. O item será copiado com o nome original (a menos que você copiá-lo para o ramo original - então ele vai ser chamado de "Copiar de ... ').

Veja também

Como é uma arquitetura representada em ABACUS


Localizar e substituir itens em sua arquitetura

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Localizar e substituir itens em sua arquitetura

Envie seus comentários neste tópico.

Você pode achar e Substituir um componente específico, conexão, tipo, padrão ou propriedade usando ABACUS 'Encontrar e Substituir instalação.

Para encontrar um item

1. Clique no nó da árvore que você gostaria de procurar dentro.

2. Selecionar Editar| Encontrarou pressione Ctrl + F.

3. Introduzir o texto para o itempara encontrar no campo 'Localizar'.

4. Clique Encontre o próximo.

Para substituir um item

1. Clique no nó da árvore que você gostaria de procurar dentro.

2. Selecionar Editar| Substituirou pressione Ctrl + H.

3. Introduzir o texto para o itempara encontrar no 'Localizar' campo eo texto para substituí-lo no "Substituir por" campo (ou nada se o campo for deixado em branco).

4. Clique Encontre o próximopara encontrar a primeira instância do texto 'Localizar' e clique Substituir para substituir esta instância com o texto "Substituir por" ou clique Substitua tudopara substituir todas as instâncias.

Você tem as opções para:

o Combinar o seu caso,

o Combinar a palavra inteira,

o Pesquisar a partir do início do projecto,

o Ignorar arquiteturas - que é a arquitetura nós de si mesmos. Quaisquer nós sob os nós de arquitetura, como os componentes e conexões ainda serão pesquisados,

o Ignorar componentes - que é o componente nós de si mesmos,

o Ignorar ligações - que é a conexão nós de si mesmos,

o Ignorar normas - que é todos os nós padrão de arquitetura, componentes e conexão será ignorada,

o Ignorar tipos - que é o tipo gânglios si. Quaisquer nós restrição abaixo dos nós do tipo ainda serão pesquisados,

o Ignorar modelos e conteúdo - que é o modelo nodos si, bem como qualquer componente modelo e nós de conexão abaixo deles,

o Ignorar propriedades - que é todos os tipos de propriedade, nomes, valores e unidades de todos os elementos do modelo serão ignorados,

o Ignorar descrições - isto é, as descrições de todos os elementos do modelo serão ignoradas.

Veja também

Como é uma arquitetura representada em ABACUS


Expandir e recolher a árvore

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Expandir e recolher a árvore

Envie seus comentários neste tópico.

Quando um nó na árvore contém sub-componentes e coleções, ele terá uma pequena [image] ou [image] sinal na sua esquerda. Você pode clicar no [image] para expandir o nó e ver seus sub-componentes e conexões. Da mesma forma, você pode clicar no [image] para recolher o nó para esconder as sub-componentes e conexões (a fim de dar mais espaço ou fazer a árvore mais fácil de entender).

Alternativamente, você pode expandir um nó inteiro, caso em que todas as suas sub-nós também será ampliado, e seus sub-nós, e deles ... etc Da mesma forma, você pode recolher um nó inteiro - fechar vários níveis ao mesmo tempo .

Além disso, existem as opções para expandir apenas as arquitecturas, os elementos (ou seja, componentes e ligações), componentes ou conexões.

Para expandir ou recolher um nó inteiro (e seus sub-nós, etc.)

1. Botão direito do mouseno nó.

2. Selecionar Expandir | Todos ou Colapso.

Para expandir todos de uma arquitectura (s)

1. Botão direito do mouseEm arquiteturas ou uma arquitetura.

2. Selecionar Expandir | Todos.

Para expandir elementos

1. Botão direito do mouseEm arquiteturas ou uma arquitetura.

2. Selecionar Expandir | Elementos.

Para expandir componentes

1. Botão direito do mousenos componentes, um componente ou um sub-componente.

2. Selecionar Expandir | Componentes | Todos.

Para expandir conexões

1. Botão direito do mouseem Conexões, uma ligação ou um sub-conexão.

2. Selecionar Expandir | Conexões | Todos.


Mesclando itens

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Mesclando itens

Envie seus comentários neste tópico.

Quando é que mesclar itens?

Você iria mesclar itens quando você tem duas (ou mais) objetos em seu modelo que são melhor representados por uma única instância. Há muitas situações em que você pode querer fazer isso, inclusive:

· Como resultado da importação de um novo conjunto de informações em seu modelo que pode duplicar ou substituir as informações existentes. Por exemplo, se você importar uma versão atualizada de uma planilha em seu modelo.

· Ao longo do tempo duplicatas do componente "mesmo" foram criados e você deseja limpar essas duplicatas.

· Se você estiver executando uma what-if cenário e os itens que estão modelando são, na verdade, a fusão na realidade. Por exemplo, se você estiver mesclando dois departamentos em sua organização, ou se você estiver mesclando dois servidores.

O que pode ser mesclado?

Os seguintes tipos de elementos de apoio a serem reunidos:

· Padrões

· Componente e Tipos de Conexão

· Componentes e Conexões

Como itens fundir

Para iniciar uma mala direta, usando o botão direito do mouse, arrastar um item no Explorer para outro. O item que você está arrastando é a fonte eo item que você arrastar para é o destino. Após soltar o botão direito do mouse você será presenteado com um menu de que você pode escolher para mesclar os dois itens. Você terá que escolher se deseja preservar ou substituir o destino. Isto é explicado mais adiante.

O menu da direita e arraste merge

Qual é a diferença entre a preservação e substituindo o destino?

A opção de manter ou substituir dita o que acontece se o Nome, Descrição ou propriedades entre a partida de origem e destino itens.

Se Preserve Destino é escolhido

· Nome do destino e descrição serão mantidos.

· Quaisquer propriedades que só existem na fonte são adicionados ao destino.

Se a opção Substituir destino é escolhido:

· Nome do destino será substituído a partir da fonte.

· Descrição do destino será substituído a partir da fonte, a menos que a descrição da fonte está em branco.

· Quaisquer propriedades que só existem na fonte são adicionados ao destino.

· O valor ea unidade de todas as propriedades que existem no tanto a origem eo destino será substituído a partir da fonte, a menos Valor da fonte ou a Unidade está em branco.

Casos especiais

· Tipos: Quando a fusão tipos, as permissões são intercaladas, de maneira 'pessimista', de tal modo que, se a permissão de fonte não existir no destino, seria adicionado, e se existia no destino, em seguida, se o indivíduo permissão para um grupo de usuários (Criar, Ler, Atualizar ou Excluir) não se encontraram (um concedida, uma negado), em seguida, que a permissão seria negado.

· Componentes: Ao mesclar componentes, as sub-componentes da fonte são migrados para o destino, e são mescladas com sub-componentes no destino, se os seus nomes são idênticos, Independentemente do seu tipo.Além disso, vários sub-componentes da fonte com o mesmo nome serão combinados em um único sub-componente no destino.

· Conexões: As próprias conexões de alto nível deve ambos têm os mesmos anexos (ou falta dela) para ser autorizado a ser mesclado. Ao mesclar conexões, a sub-conexão da fonte são migrados para o destino, e são mescladas com sub-ligações no destino, se os seus nomes são idênticos Eseus anexos são idênticos. Se os anexos não são idênticos, os sub-conexões de fonte será adicionado ao destino sem fusão com conexões de harmonização já presentes. Isso é para que nenhum anexo é perdido.


Pela definição e validação Restrições

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Pela definição e validação Restrições

Envie seus comentários neste tópico.

A estrutura e as propriedades de uma arquitectura pode ser restringida pela utilização de restrições. As restrições podem ser aplicadas para tipos de componentes e tipos de ligação para restringir a estrutura de uma arquitectura de duas maneiras. A primeira maneira é restringir a hierarquiaatravés da definição de "pai deve / tem de ter filho" e "criança deve / tem de ter" relações parentais. A segunda maneira é restringir a topologiaatravés da definição de "componente deve / tem de ser anexado a connection" e "conexão deve / tem de ser ligado a componentes" relacionamentos. Além disso, as limitações podem ser aplicados para as propriedades de tipos de componentes, tipos de ligação, moldes, os pontos de vista, arquitecturas, diagramase vistas 3D para restringir a arquitectura (s) de duas formas adicionais. A primeira maneira é definir a tipo de dadoda propriedade para restringir os valores válidos que ele pode ter, ou seja; Texto, inteiro, decimal, data / hora, booleano ou Lista. A segunda maneira é definir a requeridosstatus da propriedade para indicar se um valor precisa ser inserido para a propriedade (Nota: restrições obrigatórios só se aplicam a propriedades de componentes e tipos de conexão). Mais informações sobre restrições de propriedade é fornecida no Alterar as propriedades de um componente, ligação ou tipo tópico de ajuda. Uma vez que as restrições foram definidos, é possível validar uma arquitetura contra as restrições. ABACUS irá avisar sobre quaisquer restrições que foram violados.

A chave para determinar qual restrição (s) para definir reside no idioma exacto utilizado para descrever a restrição. Para restrições de hierarquia são normalmente do formulário "substantivospode / deve / tem de ser decomposta em n substantivos" ou "substantivospode / deve / tem de ser agregadas por substantivos", Etc. Por exemplo,"Departamentosdeve ser decomposto em Equipes" ou "Aplicaçõespode ser decomposto em Módulos". Para restrições de topologia são normalmente do formulário"substantivospode / deve / tem verbo substantivos". Por exemplo, "Processos pode ser executado por Equipes" ou "Aplicações estamos hospedado em Servidores. "Agora, você pode ver em cada restrição existem várias pode / deve / tem de 'qualifiers' e estes podem ser de 3 tipos;

· Opcional- Estes geralmente usam palavras / expressões como; "pode", "pode", "poderia", "opcionalmente" etc.

· Recomendado- Estes geralmente usam palavras / expressões como; "deveria", "recomendado", "aconselhou" etc.

· Obrigatório- Estes geralmente usam palavras / expressões como; "must", "é", "é", "tem", "deve" etc.

Dependendo do tipo de restrição (ou hierarquia topologia) e os qualificadores utilizados na descrição que, constrangimento (s) específico deve ser definido (ver abaixo). Para o exemplo de hierarquia "acimaDepartamentosdeve ser decomposto em Equipes"Deve-se definir um" "restrição e defina a aplicação para ser executada. Para o exemplo de topologia acima de" Pai deve ter CriançaProcessos pode ser executado por Equipes. "Só se deve criar dois (2)" Conexão deve ser anexado ao componente "constrangimentos para cada extremidade da realizada por tipo de conexão Especificamente, as seguintes restrições são recomendados a serem definidas (veja abaixo) para as várias opções;

· Restrições de hierarquia;

o Substantivos A pode serdecomposto em Substantivos B, ou Substantivos B pode seragregado por Substantivos A ou Substantivos B deveria estaragregado por Substantivos A- Defina uma "criança deve ter pai" constrangimento com o tipo de criança como substantivo B, tipo pai como substantivo Um e execução, conforme advertiu.

Nota

Isto significa que, se uma criança existir, ele deve ter uma matriz de um certo tipo. Se não, você receberá um aviso.

o Substantivos A deveria estardecomposto em Substantivos B- Definir um "Pai deve ter Child" constrangimento com o tipo pai como substantivo A, tipo B criança como substantivo e execução, conforme advertiu.

Nota

Isto significa que, se existe um progenitor, ele deve ter filhos de um determinado tipo. Se não, você receberá um aviso.

o Substantivos A devemos serdecomposto em Substantivos B- Definir um "Pai deve ter Child" constrangimento com o tipo pai como substantivo A, tipo B criança como substantivo e execução, conforme Forçados.

Nota

Isto significa que, se existe um progenitor, ele deve ter filhos de um determinado tipo. Se não você terá um erro.

o Substantivos A devemos seragregado por Substantivos B- Defina uma "criança deve ter pai" constrangimento com o tipo de criança como substantivo A, tipo pai como substantivo B e execução, conforme Forçados.

Nota

Isto significa que, se uma criança existir, ele deve ter uma matriz de um certo tipo. Se não, você receberá um erro.

· Restrições de topologia;

o Substantivos A pode ser verbo Substantivos B- Definir dois (2) "A conexão deve ser ligada a componentes" restrições. O primeiro ser com o fim Fonte do tipo de conexão verboanexado ao substantivo Um tipo de componente e execução previsto para Forçados. O segundo ser com o fim de Sink tipo de conexão verboanexado ao substantivo tipo de componente B e execução previsto para Forçados.

Nota

Isto significa que, se a ligação existir, ele deve ligar componentes de determinados tipos. Se não você terá um erro. Em geral, este garante que estes componentes podem ainda existir e não ser ligados uns aos outros. No entanto, se eles estão conectados, conexões do tipo certo deve ser utilizado.

o Substantivos A deveria estar verbo Substantivos B- Definir dois (2) "componente deve ser anexado à conexão" restrições. O primeiro é substantivo com um tipo de componente ligado à extremidade da Fonte verbotipo de conexão e conjunto para execução advertiu. A segunda estar com Substantivo tipo de componente B anexado ao final do Sink verbotipo de conexão e conjunto para execução advertiu. Além disso, definir dois (2) "A conexão deve ser ligada a componentes" restrições. O primeiro ser com o fim Fonte do tipo de conexão verboanexado ao substantivo Um tipo de componente e execução previsto para Forçados. O segundo ser com o fim de Sink tipo de conexão verboanexado ao substantivo tipo de componente B e execução previsto para Forçados.

Nota

Isto significa que, se existem componentes de qualquer tipo, que deve ser ligada a uma ligação de um determinado tipo. Se você não receberá um aviso. Além disso, isto significa que, se a ligação existir, ele deve ser ligado aos componentes do tipo especificado. Se não você terá um erro. No geral, este garante que, se existem componentes destes tipos, você receberá avisos se eles não estão conectados uns aos outros.

o Substantivos A devemos ser verbo Substantivos B- Definir dois (2) "componente deve ser anexado à conexão" restrições. O primeiro é substantivo com um tipo de componente ligado à extremidade da Fonte verbotipo de conexão e execução previsto para Forçados. A segunda estar com Substantivo tipo de componente B anexado ao final do Sink verbotipo de conexão e execução previsto para Forçados. Além disso, definir dois (2) "A conexão deve ser ligada a componentes" restrições. O primeiro ser com o fim Fonte do tipo de conexão verboanexado ao substantivo Um tipo de componente e execução previsto para Forçados. O segundo ser com o fim de Sink tipo de conexão verboanexado ao substantivo tipo de componente B e execução previsto para Forçados.

Nota

Isto significa que, se existem componentes de ambos os tipos, têm de estar ligadas a uma ligação de um determinado tipo. Se não você terá um erro. Além disso, isto significa que, se a ligação existir, ele deve ser ligado aos componentes do tipo especificado. Se não você terá um erro. No geral, este garante que, se existem componentes destes tipos, você receberá erros se eles não estão conectados uns aos outros.

Para definir uma restrição

1. Verifique se você tem um Arquivo ABACUSaberto eo Windows Explorerexibida.

2. Na árvore do explorador expandir Tipos | Tipos de componentesou expandir Tipos | Tipos de conexão.

3. Botão direito do mouseum tipo de componente ou um tipo de conexão e selecione Adicionar restrição.

Adicionando uma restrição

Para definir uma restrição de hierarquia, onde um pai deve ter um filho específico

4. No Adicionar restriçãojanela, marque a Criar Restriçãocheckbox sob a Pai Must Have Criança Restrição área.

5. Selecione os tipo de componentena caixa drop-down que você deseja especificar como o filho do tipo de componente selecionado na etapa 3.

Nota

Se já existe um enabled 'mãe ter Child' restrição definida para o tipo de componente pai e outro tipo de componente filho, então esta nova restrição será tratado como um 'E'. Esse é o tipo deve ser um pai do tipo A criança eTipo criança B, para qualquer nível de execução (por exemplo, pessoas com deficiência, advertido ou forçado - veja o passo 7) é especificado para cada restrição.

6. Opcionalmente, você pode definir o número mínimo e máximo de componentes do tipo componente especificado que deve ser filhos do tipo de componente direito-clicado na etapa 3.

7. Escolha se você quer a restrição de ser Desativado, Advertido ou Forçados.

Nota

Restrições pessoas com mobilidade será ignorado de validação de restrição, restrições advertiu irá produzir um aviso na janela de validação, se forem detectados e restrições forçados irá produzir um erro na janela de Validação se forem detectados. Além disso, todos os erros devem ser resolvidos antes de uma Empresa Servidor projeto pode ser comprometida.

8. Clique Está bem.

Nota

A restrição será exibido na árvore de explorador sob o tipo de componente direito-clicado no passo 3. A seta indica a direção da restrição e neste caso irá apontar para baixo e para a direita. O cadeado é de cor consoante a restrição está desativada (cinza), advertiu (amarelo) ou Forçados (vermelho).

Pai deve ter avisado restrição criança

Para definir uma restrição de hierarquia, onde uma criança deve ter um pai específico

4. No Adicionar restriçãojanela, marque a Criar Restriçãocheckbox sob a Criança deve ter restrição Pais área.

5. Selecione os tipo de componentena caixa drop-down que você deseja especificar como o pai do tipo de componente direito-clicado na etapa 3.

Nota

Se já existe um enabled 'criança deve ter Parent' restrição definida para o tipo de componente filho e outro tipo de componente pai, então esta nova restrição será tratado como um 'OR'. Esse é o tipo deve ser um filho do tipo pai Um outipo pai B, eo nível de execução (por exemplo, advertido ou forçado - veja o próximo passo) devem ser as mesmas restrições impostas caso contrário será sempre substituem os advertiu.

6. Escolha se você quer a restrição de ser Desativado, Advertido ou Forçados.

Nota

Restrições pessoas com mobilidade será ignorado de validação de restrição, restrições advertiu irá produzir um aviso na janela de validação, se forem detectados e restrições forçados irá produzir um erro na janela de Validação se forem detectados. Além disso, todos os erros devem ser resolvidos antes de uma Empresa Servidor projeto pode ser comprometida.

7. Clique Está bem.

Nota

A restrição será exibido na visualização do explorador sob o tipo de componente escolhido na etapa 5. A seta indica a direção da restrição e neste caso irá apontar para cima e à esquerda. O cadeado é de cor consoante a restrição está desativada (cinza), advertiu (amarelo) ou Forçados (vermelho).

Criança deve ter pai advertiu restrição

Para definir uma topologia de restrição, em que um componente tem de ser ligado a uma ligação específica

4. No Adicionar restriçãojanela, marque a Criar Restriçãocheckbox sob a Componente deve ser anexada Restrição área.

5. Selecione os Tipo de conexãona caixa drop-down que você deseja especificar como a conexão anexado do tipo de componente direito-clicado no passo 3. (ou selecione o tipo de componentena caixa drop-down que você deseja especificar como o componente ligado se na etapa 3, você clicou um tipo de conexão.)

Nota

Se já existir uma restrição habilitado "componente deve ser anexada 'definido para o tipo de componente e outro tipo de conexão, então esta nova restrição será tratado como um' E '. Esse é o tipo de componente deve ser anexado ao tipo de conexão A etipo de conexão B, a qualquer nível de execução (por exemplo, pessoas com deficiência, advertido ou forçado - veja o passo 7) é especificado para cada restrição.

6. Opcionalmente, você pode selecionar uma conexão Funçãoque você deseja adicionar à restrição. Seleger o específico Função (isto é, de origem ou de Sink) na caixa drop-down.

7. Escolha se você quer a restrição de ser Desativado, Advertido ou Forçados.

Nota

Restrições pessoas com mobilidade será ignorado de validação de restrição, restrições advertiu irá produzir um aviso na janela de validação, se forem detectados e restrições forçados irá produzir um erro na janela de Validação se forem detectados. Além disso, todos os erros devem ser resolvidos antes de uma Empresa Servidor projeto pode ser comprometida.

8. Clique Está bem.

Para definir uma topologia de restrição, em que a ligação tem de ser ligado a um componente específico

4. No Adicionar restriçãojanela, marque a Criar Restriçãocheckbox sob a Conexão deve ser anexado Restrição área.

5. Selecione os Tipo de conexãona caixa drop-down que você deseja especificar como a conexão anexado do tipo de componente direito-clicado no passo 3. (ou selecione o tipo de componentena caixa drop-down que você deseja especificar como o componente ligado se na etapa 3, você clicou um tipo de conexão.)

Nota

Se houver já um habilitado 'Conexão deve ser anexado' restrição definida para o tipo de conexão e outro tipo de componente usando a mesma conexão Função(isto é, tanto Fonte ou Sink), então esta nova restrição será tratado como um 'OR'. Esse é o tipo de conexão deve ser anexado ao tipo de componente A outipo de componente B, eo nível de execução (por exemplo, advertido ou forçado - veja o passo 7) devem ser as mesmas restrições impostas caso contrário será sempre substituem os advertiu. Note também que se houver vários constrangimentos que têm a conexão Funçãoespecificado como 'Qualquer' (em oposição a especificamente fonte ou dreno), em seguida, cada extremidade da ligação tem de ser ligado a um dos tipos de componentes especificados nas restrições.

6. Opcionalmente, você pode selecionar uma conexão Funçãoque você deseja adicionar à restrição. Seleger o específico Função (isto é, ou Fonte ou Lavatório) na caixa drop-down.

Nota

Uma fonte ou papel Sink precisa ser explicitamente selecionado para uma Acessório coluna para ser avilable para ser mostrado em um componente catálogo .

7. Escolha se você quer a restrição de ser Desativado, Advertido ou Forçados.

Nota

Restrições pessoas com mobilidade será ignorado de validação de restrição, restrições advertiu irá produzir um aviso na janela de validação, se forem detectados e restrições forçados irá produzir um erro na janela de Validação se forem detectados. Além disso, todos os erros devem ser resolvidos antes de uma Empresa Servidor projeto pode ser comprometida.

8. Clique Está bem.

Tempo real verificação de modelos e limitação validação

AInclui um BACUSem tempo real Modelo Verificação e Recurso de validação de imediatamente display os efeitos de uma dada operação usuário terá sobre os avisos e erros com o projeto atual, devido a qualquer hierarquia e topologia restrições que foram definidas. Note-se que todos os erros devem ser resolvidos antes de uma Empresa Servidor projeto pode ser comprometida.

O recurso de validação de restrição em tempo real é mais perceptível ao preencher com diagramas ou diretamente na janela do Explorer. Em particular, durante as seguintes operações, orientação é dada usando destaques cor quanto ao efeito da operação terá sobre os avisos e erros com o projeto atual;

1. Quando arrastando elementos sobre ou em torno de um diagrama a cor da matriz (ou colocar) da componente (se houver) fronteira serão coloridas de acordo com o esquema descrito a seguir.

2. Ao conectar componentes usando o botão direito do mouse arraste | Conecte-se a apresentar a lista de tipos de conexão disponíveis é de cor de acordo com o esquema descrito abaixo.

3. Ao conectar componentes em diagramas usando o modo Connector o cursor vai mudar as cores de acordo com o esquema descrito abaixo.

4. Ao adicionar sub-componentes da lista de tipos de componentes disponíveis é de cor de acordo com o esquema descrito abaixo.

Em geral, as seguintes cores são usadas para indicar os efeitos da operação usuário terá sobre os avisos e erros com o projeto atual;

Preto : Sem impacto sobre avisos ou erros.

Verde : A operação é explicitamente de acordo comdefinidos de hierarquia e de topologia constrangimentos para o projeto.

Vermelho : A operação é explicitamente em violação doa hierarquia e topologia restrições definidas para o projeto e vai resultar em advertências e / ou erros.

Antecedentes verificação de modelos e limitação validação

Inclui um ABACUS Recurso de validação para exibir todos os avisos e erros com o projeto atual, devido a quaisquer restrições que foram definidas. Note-se que todos os erros devem ser resolvidos antes de uma Empresa Servidor projeto pode ser comprometida.

Nota

A validação deve ser executada manualmente através do 'Validar / check Projeto Restrições' botão no Barra de ferramentas principal . A janela Validação está oculta por padrãomas aparece quando o botão da barra de ferramentas é clicado. Vejo Personalizando a interface para saber como mostrá-lo e deixá-lo potencialmente expostas permanentemente. Além disso, você pode dar um duplo-clique em qualquer linha na janela de validação para 'saltar' para o elemento relevante no projeto.

Janela Validação

As colunas padrão na janela de validação são descritas a seguir;

Aviso ou erro: Esta coluna exibe um ícone para saber se a violação é um aviso (triângulo amarelo com um ponto de exclamação) ou erro (círculo vermelho com uma cruz).

Número: Esta coluna exibe o número violação.

Nota

Apenas a 200 violações são mostrados em um momento e se houver mais de 200 violações em um projeto Start, Prev, Next e navegadores linha End no canto superior direito da janela pode ser usado para navegar pelas violações adicionais.

Descrição: Esta é uma descrição completa da violação, incluindo a Entidade e restrição em causa.

Entidade: Esta coluna exibe a Entidade de preocupação para a violação.

Tipo: Esta coluna exibe o tipo de elemento para a Entidade.

Arquitetura: Esta coluna exibe a arquitetura em que tenha ocorrido a violação.

Detectado: Esta coluna exibe o tempo que a violação foi detectada.

Dica

É útil para classificar descendo pela coluna detectado (como mostrado na caixa de diálogo acima) para garantir as violações mais recentes aparecem no 'top' da lista.

Existem várias opções de usuário para alterar o comportamento da validação do modelo de fundo. Por exemplo, to alterar as cores utilizadas para violações de restrição para algo diferente do padrão Vermelho, clique em Ferramentas | Opções ... em seguida, ir para a Validaçãoguia, e definir as cores através do Alterar botões.

Validação Opções

Para validar manualmente restrições

1. Botão direito do mouse no Arquiteturasnó, qualquer arquitectura, ou em qualquer lugar quer a Componentes ou Conexõesparte da visão Explorer e selecione Restrições de verificação.

Validar restrições

2. Clique no Detalhesno botão Advertênciasjanela para ver onde a arquitetura viole quaisquer restrições que foram definidas.

Nota

Violações são mostrados apenas para as restrições que foram estabelecidas para advertido ou executada. Além disso, a redacção do aviso incluirá "deveria" se a restrição era apenas uma advertência ou "deve" se ele foi forçado.

3. Clique Está bem.

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente


Evoluindo sua arquitetura

Navegação: Preenchendo seu Arquitectura> Preencher manualmente> Opções extras>

Evoluindo sua arquitetura

Envie seus comentários neste tópico.

Arquitecturas pode ser explicitamente evoluiu e uma hierarquia de arquitecturas criado. Assim evoluindo sua arquitetura em ABACUS, uma série de soluções arquitectónicas avançadas podem ser criados, em comparação e com baseline. Metas (ou métricas) pode ser definida para qualquer número de propriedades de arquitectura para arquiteturas existentes.

Uma maneira simples de considerar a evolução de uma arquitectura é relacioná-la com o conceito de arquitetura descendente. Quando uma arquitetura é evoluído, um cópiada arquitectura pai é criada. Esta cópia pode ser considerado um directa descendentedo original principal arquitetura.

Nota

Nesta documentação ajuda online eo próprio conjunto de ferramentas ABACUS, o termo desenvolveré mais comumente usado do que o termo descendente, Por favor, note que ambas se referem à mesma funcionalidade.

Para evoluir uma arquitetura existente

1. Verifique se você tem um Arquivo ABACUSaberto eo Windows Explorerexibida.

2. Selecione a arquitetura relevante você quer evoluir a partir da árvore explorador.

3. Botão direito do mousena arquitetura e selecione Evoluaa partir do menu.

Evoluindo a arquitectura escolhida

4. A arquitetura evoluiu aparecerá abaixo da arquitetura selecionada.

Evolved Arquitetura

Nota

A arquitetura evoluiu podem ser renomeados com o botão direito sobre a arquitetura e selecionando Renomeie.Além disso, todos os diagramas e catálogos na arquitetura evoluiu será automaticamente ajustado para 'diff' contra a arquitetura da linha de base que foi desenvolvido a partir de.

Definir metas para a sua arquitectura evoluiu

Definir metas para a sua arquitectura evoluiu permite que você crie um critério para avaliar a evolução das suas arquiteturas. Metas são determinados pelos tipos de propriedade e os nomes das propriedades existentes em sua arquitetura evoluiu. Objectivos também pode ser definido manualmente e adicionou-se-lhe arquitectura. Siga os passos abaixo para definir metas.

Definir metas de propriedades existentes para a sua arquitectura evoluiu

1. Verifique se você tem um Arquivo ABACUSaberto eo Windows Explorerexibida.

2. Selecione Ferramentas | Definir metasNa barra de menu principal.

3. o Entrada Goaljanela será exibida.

Janela de entrada Goal

4. Clique no Existir botão.

5. o Selecione uma propriedadejanela será exibida.

6. Selecione uma propriedade que você deseja definir como meta para a sua arquitectura evoluiu e clique no Está bem botão.

7. O objetivo selecionada deverá aparecer agora na Entrada Goal janela.

8. Selecione a meta e clique no Editar botão.

9. o Editar Goaljanela será exibida.

Nota

Esta janela permite que você altere o nome da propriedade eo tipo que a meta vai refletir, bem como o valor de pior e melhor (ou valores mínimo / máximo) para essa propriedade. Estes valores são encontrados comparando todas as arquiteturas e encontrar o valor menor e maior em cada um para essa propriedade específica. Estes valores podem também ser definidos manualmente. Por exemplo, se você tivesse que definir uma meta para a propriedade nomeada Resposta (Ave)e do tipo Comportamento, O seu valor de pior e melhor poderia refletir a velocidade de transação necessários para um melhor desempenho (melhor valor) ea velocidade de operação necessária para apenas aplicativos principais para serem processados ​​(pior valor).

10. Uma vez que os valores relevantes foram definidos, selecione Está bem.

Definir metas de novas propriedades para a sua arquitectura evoluiu

1. Verifique se você tem um Arquivo ABACUSaberto eo Windows Explorerexibida.

2. Selecione Ferramentas | Definir metasNa barra de menu principal.

3. o Entrada Goaljanela será exibida.

4. Clique no Novo botão.

5. o Novo Goljanela será exibida.

Nota

Esta janela permite que você defina o nome da propriedade eo tipo que a meta vai refletir, bem como o pior eo melhor valor (ou valores mínimo / máximo) para essa propriedade. Por exemplo, se você tivesse que definir uma meta para propriedade chamada Resposta (Ave)e do tipo Comportamento, O seu valor de pior e melhor poderia refletir a velocidade de transação necessários para um melhor desempenho (melhor valor) ea velocidade de operação necessária para apenas aplicativos principais para serem processados ​​(pior valor).

6. Uma vez que os valores relevantes foram definidos, selecione Está bem.

7. Uma caixa de diálogo para Adicionar a todas as arquiteturasserá exibido como a seguir:

8. Clique em simpara adicionar o objetivo como uma propriedade para todas as arquiteturas relevantes. Isto assegura que o objectivo recentemente definido e suas propriedades serão adicionados a todas as arquitecturas no arquivo. Se você não deseja incluir a propriedade nas arquiteturas, você pode clicar em Não.

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Vendo um terreno estrela de suas arquiteturas evoluíram | Visualizando um gráfico de dispersão de suas arquiteturas evoluíram


A Ferramenta de Desenho

Navegação: Preenchendo sua arquitetura> Usando Drawings>

A Ferramenta de Desenho

Envie seus comentários neste tópico.

A ferramenta de desenho permite a criação de uma grande variedade de esquemas de arquitectura e diagramas. Arquitetos tradicionalmente utilizam uma série de desenhos diferentes para gravar e transmitir o projeto de uma arquitetura. Bidimensionais (2D) diagramas são a maneira usual de documentação e comunicação várias partes de um sistema. Tipos de desenhos típicos usados ​​em sistemas corporativos são:

· Negócios modelos de processo e diagramas;

· Os organogramas;

· Os diagramas de colaboração;

· Diagramas de Entidade-Relacionamento (ER);

· Dados-Flow Diagrams (DFD); de

· Diagramas de classe;

· IDEF (incorporando vários dos acima); e

· UML (incorporando vários dos acima).

Realmente não há limite para os tipos de diagramas que podem ser criados. ABACUS tenta equilibrar flexibilidade diagrama, preservando a integridade da arquitetura e suas formas de representação.

O ambiente é um desenho tabulada e janela encaixável dentro do aplicativo principal ABACUS. Esta janela contém uma tela onde o desenho tem lugar e quando a janela de desenho é aberto um segundo janela encaixável , A janela de estêncil, é visível com um conjunto de stencils de desenho. O painel de estêncil tem 4 abas: Componentes, Conexões, formas e conectores. A tela aparece como um fundo branco com linhas de grade finas (votos para o layout).

Os componentes são representadas por uma variedade de formas, enquanto as ligações são desenhados como linhas dirigidas. Conexões anexar aos componentes usando papéis (isto é, de origem ou de Sink) embora estes não são mostradas por razões estéticas.

Dica

Enquanto diagramassão muito úteis para mostrar diferentes partes de um sistema, eles são limitados em sua escalabilidade, razão pela qual ABACUS usa 3D para visualizar estruturas complexas de sistema.

Você pode querer

1. Abra a Diagramação Ferramenta

2. Criar um novo diagrama de uma parte da sua arquitetura

3. Copie um diagrama dentro ou entre arquiteturas

4. Adicione componentes a um diagrama

5. Crie novos componentes e conexões em sua arquitetura (esquematicamente), utilizando a ferramenta de desenho

6. Excluir componentes a partir de um diagrama

7. Anexar e manipular conexões

8. Mudar o propriedades de exibição de componentes e ligações.

9. Usando links em diagrama

10. Impor associações de tipo e pontos de vista de modo a restringir os tipos de diagramas que podem ser extraídas.

Veja também

Preenchendo sua arquitetura | Preenchendo a arquitetura manualmente | Analisar sua arquitetura


Abrindo Diagrams

Navegação: Preenchendo sua arquitetura> Usando Drawings>

Abrindo Diagrams

Envie seus comentários neste tópico.

O desenho do estêncil e lona janelas aparece automaticamente quando um diagrama é aberto ou criado. Da mesma forma, quando um diagrama é fechado, a folha tabulada correspondente na janela de tela desaparece e se não houver novos levantamentos estão abertas, então a janela de estêncil está fechado.

Para crioum novo diagrama

1. Verifique se você tem umABACUS arquivo abertocontendo o seu arquitetura povoada.

2. Clique no Diagramícone na barra de ferramentas View.

- ou -

2. Selecionar Inserir| Diagram.

- ou -

2. Botão direito do mouse a Diagramasgalho de uma dada Arquiteturaseção da árvore e selecione Crio Diagrama.

3. Selecione os Arquiteturavocê deseja focar a partir do menu suspenso. Nota: a arquitetura já estará selecionado para você, se você usou etapa 3 acima para abrir o novo diagrama.

4. Selecione os Ponto de vista que pretende utilizar a partir do menu suspenso. Nota: o ponto de vista escolhido irá filtrar os componentes e listas de ligações para ser apenas as disponíveis no ponto de vista.

5. Opcionalmente, selecione uma vista da Filtrar por Vermenu suspenso para pré-selecionar os componentes e conexões do ponto de vista escolhido. Nota: esta é efetivamente usando a visualização escolhida como uma consulta salva.

6. Selecione os Disposição para ser Radial ou Grade.

7. Selecione os Componentes e Conexõesque você quer no diagrama do janela de seleção de elemento padrão .

8. Clique Está bem.

Nota

Um novo diagrama será adicionado à Diagramasramo da arquitetura. Ela terá um nome padrão, que você pode mudar mais tarde clicando com o botão direito sobre ele.Além disso, o último estado dos filtros e componentes de seleção de conexão serão salvos com o diagrama efetivamente salvar o 'consulta' usado para criar o diagrama.

Para abrir um diagrama existente

1. Na arquitetura povoada específico, expandir o Diagramasgalho da árvore.

2. Duplo click o diagrama que você deseja abrir.

Para salvar um diagrama

1. Certifique-se de que você tem um diagrama novo ou existente abertoe você fez as mudanças necessárias. Nota: um asterisco '*' será exibida após o nome da vista no cabeçalho da folha com separadores se houver alterações a serem salvas.

2. Na visão de explorador clique no Guardarbotão ou tem que Arquivo| Guardarou deprimir Ctrl + Spara salvar todas as mudanças em sua arquitetura e escrevê-lo para o arquivo.

Para salvar um diagrama como um ponto de vista

1. Certifique-se de que você tem um diagrama existente no seu arquivo ABACUS.

2. Botão direito do mouseO esquema em Diagramasparte da árvore.

3. Selecionar Salvar como Ponto de Vista diagrama.

4. Digite um nome para o seu novo ponto de vista diagramae clique em Está bem.

Veja também

A Ferramenta de Desenho | Preenchendo sua arquitetura | Analisar sua arquitetura


Copiando diagramas

Navegação: Preenchendo sua arquitetura> Usando Drawings>

Copiando diagramas

Envie seus comentários neste tópico.

Existem 2 cenários básicos para copiar um diagrama existente; dentro de uma arquitetura, ou através de arquiteturas.

Para cópiaum diagramadentro de uma arquitetura

1. Verifique se você tem umABACUS arquivo abertocontendo o seu arquitetura povoadacom pelo menos um diagrama.

2. Expandir a Diagramas filial (e qualquer exigido Grupos Diagrama) de uma dada Arquiteturasecção da árvore.

3. Selecione o diagrama que você deseja copiar e, em seguida, pressione Ctrl + C ou clique com o botão direitoe selecione Cópia a partir do menu.

Nota

A cópia do diagrama será adicionado à Diagramasramo da mesmo arquitetura. Terá "Copiar de" anexado ao início do nome, Que você pode mudar mais tarde por pressionando F2 ou clicando com o botão direito sobre elee selecionando Rename.

Para copiar um diagrama através de arquiteturas

1. Verifique se você tem umABACUS arquivo abertocontendo o seu arquitetura povoadascom pelo menos um diagrama.

2. Expandir a Diagramas filial (e qualquer exigido Grupos Diagrama) de a Arquiteturasecção da árvorepara a arquitetura que contém o diagrama que você deseja copiar.

3. Selecione o diagrama que você deseja copiar e na Propriedades geraisnota janela Ponto de vista que o diagrama está ligada à (no campo Tipo).

4. Agora, expandir a Diagramas filial (e qualquer exigido Grupos Diagrama) de a Arquiteturasecção da árvorepara a outra arquitetura que você deseja copiar o diagrama em.

5. Botão direito do mouse a Diagramas nó (ou o Grupo diagrama) E selecione Criar diagrama .... Na caixa de diálogo que aparece, selecione a Ponto de vista que foi observado na etapa 3 acima no drop-down no canto superior direito. Deixar tudo como está e clique Está bem. Na caixa de diálogo Nome do diagrama digite um nome para o (em breve) diagrama copiado. Nota: Uma tela em branco diagrama de acordo com o ponto de vista escolhido será aberto.

6. Voltar para o diagrama que você deseja copiar e abrir esse por botão direito do mouseo nó e selecionando Aberto ou simplesmente clicando duas vezes isto.

7. Selecione o plano de fundo canvas do diagrama que você deseja copiar e pressione Ctrl + A. Isso irá selecionar todos os elementos nesse diagrama. Agora pressione Ctrl + Cpara copiar o conteúdo para a área de transferência.

8. Agora, volte para o diagrama em branco na arquitetura que você deseja copiar o conteúdo em, selecionar o fundocanvas e quer clique com o botão direitoe selecione Colar ou simplesmente pressione Ctrl + Vpara colar o conteúdo. Depois de um breve período de tempo o conteúdo vai ser todos colado no novo diagrama em branco.

Nota

Os elementos serão adicionados ao de nível superior da nova arquitetura e terá de ser re-arranjadas ou fundiram com o conteúdo existente em conformidade.

Veja também

A Ferramenta de Desenho | Preenchendo sua arquitetura | Analisar sua arquitetura


Preenchendo Diagrams

Navegação: Preenchendo sua arquitetura> Usando Drawings>

Preenchendo Diagrams

Envie seus comentários neste tópico.

Desenhos em ABACUS são mais do que apenas representações arbitrárias. Elas são vistas da arquitetura personalizada, formatados e organizados para mostrar um significado particular.

A Ferramenta de Desenho reforça a estrutura hierárquica da arquitetura, de modo que os componentes são visualmente aninhados dentro de outros componentes - efetivamente dando uma "visão plano 'dos ​​elementos. Uma vez que um componente ou uma conexão foi definido na arquitectura, pode ser usado em qualquer número de diferentes diagramas. É importante ressaltar que a ferramenta de desenho está intimamente ligado ao modelo de arquitetura, de modo que as alterações feitas em qualquer um dos dois sempre são refletidas no outro.

A ferramenta funciona associando formas com determinados tipos de conexão e componentes definidos na seção Tipos de arquitetura. Estas associações variar dependendo do tipo de diagrama a ser tirado, e é possível que um tipo de componente (ou ligação) pode ter diferentes representações em diagramas diferentes, dependendo do contexto.

Para configurar uma associação entre uma forma e um tipo de componente ou conexão

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Maximize a aplicação ABACUS, e configurar as proporções de janela como você deseja.

3. Selecione os Guia Shapes ou o Guia Conectores na janela de stencil.

4. no Tiporamo do Explorer, localize o tipo de componente ou conexão que você gostaria de associar a uma forma ou conector.

5. Selecione o elemento tipo escolhido da árvore, arraste-o para o separador Shapes ou guia Conectores e solte-o na forma ou conectorvocê gostaria de usar.

Nota

Você pode verificar uma associação que tenha criado, selecionando os componentes ou guia Conexões na janela de stencil, que mostram os elementos atualmente associados.

Para adicionar novas formas ao seu diagramas / biblioteca

1. Criar um diagrama de MS Visio com as formas que você deseja adicionar ao seu diagrama e importar o esquema de MS Visio .

Dica

É importante que o tamanho você fazer a forma mestre em MS Visio porque a lona ABACUS é dimensionada em pixels e apenas as unidades milímetros de MS Visio converter de forma granular para pixels em um 4 pixels para uma relação de milímetro. Além disso, as formas ABACUS padrão são normalmente de 60 pixels de altura para que se traduz em 15 milímetros de MS Visio. Significado uma aconselhável mestre tamanho da forma em MS Visio é 25 milímetros de largura por 15 milímetros de altacomo isso vai se traduzir em 100 pixels de largura por 60 pixels de altura no ABACUS.

Dica

Se você quiser ter um 'icon' pouco no canto superior esquerdo de uma forma, então você pode simplesmente criar o 'icon' no mestre forma MS Visio usando a paleta MS Visio Ferramenta de Desenho (note que apenas linhas simples, círculos e retângulos são suportados e formas rasterized / bitmap em particular, não são suportados). Além disso, se você deseja que o ícone a ser fixa em tamanho / escaladentro da forma em ABACUS então você pode agrupar o 'icon' no mestre MS Visio forma selecionando todos os seus elementos, clicando com o botão direito um elemento, selecionando Forma | Grupo, em seguida, botão direito do mouse a forma agrupada e selecionando dados | Dados da Forma ..., selecionar Sim na caixa de diálogo que aparece e, em seguida, adicionar uma propriedade com o rótulo definido para LockScale(note a maiúscula 'L' e 'S'), o tipo de conjunto de Boolean e do valor definido para ser VERDADE (note que é tudo em maiúsculas).

Dica

Se você quiser ter uma parte da forma congelada de escala horizontal ou na vertical (como é típico com um "raia" forma), então você pode clicar com o botão direito na parte (s) do mestre forma MS Visio que você quer congelado de escala e selecione Dados | Dados da Forma ..., selecionar Sim na caixa de diálogo que aparece e, em seguida, adicionar uma propriedade com o rótulo definido para LockXScale ou LockYScale (note a maiúscula 'L' e 'S'), o tipo de conjunto de Boolean e do valor definido para ser VERDADE (note que é tudo em maiúsculas), para bloqueado escala horizontal ou vertical, respectivamente.

Dica

Para permitir que a coloração da forma no ABACUS depois de importar um pouco do que a forma sempre sendo uma cor fixa, é aconselhável fazer preenchimento do mestre MS Visio forma transparente e, em seguida, usar a habilidade inerente em ABACUS a cor de fundo de uma forma. Isso só funciona com retângulo ou quase retângulo (por exemplo, retângulo arredondado) formas como o fundo inteiro rectangular será colorida.

2. Abra o diagrama correspondente e selecione a Separador de componentesna janela de stencil.

3. Para cada novo formato que você deseja disponibilizar para outros diagramas Botão direito do mousea forma e selecione Adicionar à Biblioteca Shapes. Isso fará com que a forma disponível na guia Shapes na janela de stencil.

4. Associar o tipo de componente relevante com a nova forma da biblioteca de formas de acordo com os passos acima descritos.

Nota

Apenas simples e, ou seja, bitmaps não são suportados formatos são suportados no ABACUS no momento "baseadas em vetores". No entanto, ferramentas como Vector Magic ( www.vectormagic.com ) Estão disponíveis, que será prontamente converter imagens bitmap em formas baseadas em vetores (ou seja, formato SVG) que podem ser abertos em MS Visio e, portanto, utilizados em ABACUS conforme as instruções acima.

AdicionandoComponentes e Conexões

A ferramenta de desenho permite que você adicionar componentes e conexões existentes a partir do repositório ou criar novos componentes e conexões como você está desenhando um diagrama. Como componentes e ligações são criadas em diagramas, eles são adicionados em simultâneo no repositório. tem três recomendado formas de adição de componentes de um diagramae três recomenda maneiras de adicionar conexões a um diagrama:

Para criar um completamente novo componente ou conexão em um diagramaa partir do stencil

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Selecione os Componentes ou Conexõesaba na janela de estêncil para ver as formas associadas. Somente estas formas podem ser usadas para criar novos elementos do modelo.

3. Clique e arrasteuma das formas associadas disponíveis para a tela de desenho. O novo elemento aparece na tela e na árvore do explorador.

4. Comece a digitarum nome para o novo elemento no diálogo e quaisquer elementos existentes que são correspondidos são sugeridas e podem ser escolhidos em vez de adicionar um novo elemento para a arquitetura.

5. Clique Está bem.

6. Se uma forma foi solto em um componente existente, então ele quer se tornar um filho desse componente (se a forma veio do Componentesguia), ou será anexado a esse componente (se a forma veio do Conexõestab).

Nota

Às vezes é necessário para ajustar o novo componente ou conexão em um lugar diferente na hierarquia arquitetônica usando o explorer.

Para colocar um componente existente ou a conexão do repositório para um diagrama

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Certifique-se de que você tem tanto a ferramenta de desenho e janelas do Explorer visível.

3. No Explorer, localizar o componente ou conexão(elemento) que você gostaria de adicionar ao diagrama.

4. Clique e arrasteo elemento escolhido no diagrama. A forma que representa o elemento aparece na tela.

Nota

Se o tipo do elemento escolhido já está associado a uma forma, a forma correspondente aparece na tela. Se, no entanto, não existe uma associação definido para aquele elemento em particular, uma forma padrão (retângulo) aparecerá na tela a menos que o Impor Diagrama Pontos de Vista opção é no caso em que a forma não será adicionado ao diagrama.

Dica

Quando um componente é colocado em um diagrama que está ligado a um outro componente já no diagrama, a ferramenta de desenho irá consultar se você gostaria de mostrar a conexão (s) entre eles. Além disso, se houver algum filhos do componente a ferramenta de desenho irá consultar se você gostaria de incluir as crianças, de forma recursiva.

Para criar uma conexão entre 2 componentes ou um componente ligado em um diagrama usando o conector dinâmico

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Flutuar mais de um componente no diagrama que você deseja conectar a outro componente e você vai notar 2 ícones aparecem fora do top-direita do limite da forma como mostrado abaixo. Nota: O ícone de topo é para a criação de uma conexão em que o componente pairou é para ser a fonte, o ícone é inferior para a criação de uma conexão em que o componente pairou é para ser o pia.

3. Jogada o cursor sobre o ícone desejado e Clique e arrasteo ícone para mais, quer em relação a outro componente ou espaço livre na tela como mostrado abaixo.

4. Para se conectar a um componente existente escolher o Anexar a...item no menu pop-up e se browse necessário para o sub-menu para escolher os tipos de conexão disponíveis.

- ou -

4. Para criar um componente ligado escolhemos a partir do Novo...itens no menu pop-up e se browse necessário para o sub-menu para escolher os tipos de conexão disponíveis, como mostrado abaixo. Comece a digitarum nome para o novo elemento no diálogo e quaisquer elementos existentes que são correspondidos são sugeridas e podem ser escolhidos em vez de adicionar um novo elemento para a arquitetura.

Nota

A disponibilidade dos itens no menu pop-up e sub-menu é regida pela restrições na meta-modelo.Essa é apenas a fonte válida ou afundar tipos de componentes, conforme determinado por restrições de conexão será apresentado como o Attach to ... e itens de menu Novo ....

Para re-abrir o diálogo de seleção de elemento e colocar componentes ou ligações a partir do repositório existente para um diagrama

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Clique a Abrir elemento de selecçãobotão na barra de ferramentas Diagrama. Nota: o diálogo de seleção de elemento será aberta com o último estado de quaisquer filtros salvos.

3. Escolha qualquer conteúdo adicional que é desejado para ser adicionado ao diagrama e clique Está bem. Nota: o novo conteúdo será adicionado para abrir espaço na tela e o diagrama pode ser posteriormente colocado para fora novamente via Disposição Diagramabotão na barra de ferramentas Diagrama.

Usando gratuitoFormatoShapes

Muitas vezes é desejável para criar elementos visuais em um diagrama por razões puramente estéticas. Estes elementos podem ajudar a melhorar o layout ea aparência de um diagrama, mas eles não têm um estrito significado arquitetônico. A ferramenta de desenho permite o uso de formas livres para fornecer flexibilidade de desenho.

Para adicionar uma forma de forma livre em um diagrama

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Selecione os Shapes ou Conectoresaba na janela de stencil.

3. Clique e arrasteuma das formas disponíveis ou conectores para a tela de desenho. O novo elemento aparece na tela - mas nãona árvore do explorador.

Nota

Formas livres são "não-associados 'formas, como eles não têm associação com qualquer componente ou conexão no modelo arquitetônico particular.

Para exibir informações no repositório forma livrefilhoum diagrama

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Botão direito do mousea forma livre e selecione Anotação | Display.

3. Escolha para exibir ou a Nome diagrama, Diagrama Descrição, Diagrama de Propriedade, Ponto de Vista Nome ou Nome Arquitetura.

Nota

O texto na forma livre será atualizado automaticamente conforme as alterações de dados subjacentes repositório.Desta forma, um diagrama 'bloco de título' podem ser criados para, em seguida, facilmente copiados através de, diagramas.

Usando formas flutuantes

Formas flutuantes são, essencialmente, uma outra maneira de representar componentes em um diagrama. Considere uma organização com divisões principais: CEO, Marketing, Vendas e Desenvolvimento.

Ver a árvore

Essas divisões podem ser representados visualmente de forma em camadas:

Layered Vista

Ou podem ser representados visualmente numa escalonada / flutuante forma a mostrar hierarquia:

Cambaleou / Flutuante Visão

A última representação utiliza o conceito de formas flutuantes.

Para converter uma forma componente mergulhado em uma forma flutuante

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Selecione os componenteno seu diagrama você deseja representar como uma forma flutuante ou uma forma associada na Componentesaba da janela do stencil você quer todas as instâncias como formas flutuantes.

3. Botão direito do mouse e selecione a forma Float Component a partir do menu de contexto que aparece. Note-se a diamante conexão chefiadaa partir do componente (s) principal para o componente (s) flutuante.

4. Clique e arrasteo componente para o local desejado. Quando um flutuantecomponente é selecionado terá um contorno azul.

Para converter uma forma componente flutuante em forma de camadas

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Selecione os componenteno seu diagrama que está sendo mostrada como uma forma flutuante ou uma forma associada na Componentesaba da janela stencil você quer todas as instâncias como formas em camadas.

3. Clique e arrasteo componente (s) flutuante de volta para o pai (s) (de acordo com o diamante conexão chefiada). Nota: Se você não fizer isso, então quando você converte o componente (s) de volta para ser mergulhado na hierarquia do seu modelo pode ser afetada.

4. Direito do mouse na forma e unselect Float Component a partir do menu de contexto que aparece. Note-se que o diamante conexão chefiadaa partir do componente (s) principal para o componente (s) flutuante irá desaparecer.

Réplicas

A ferramenta de desenho permite que você adicionar o mesmo componente para um diagrama várias vezes com cada instância visual adicional do componente no diagrama referido como uma réplica. Isto é particularmente útil para os diagramas em que um componente tem um grande número de ligações ligados a ele e é preferível para mostrar o componente em várias localizações mais perto da origem de cada uma das ligações, ou por diagramas onde uma relação de um-para-muitos de um componente é preferível utilizar a funcionalidade de mostrar flutuante (descrito acima) com o componente em vários locais no topo dos componentes "muitos" que se relaciona.

Nota

Pode montar / desmontar conexões para / a partir do exemplo original do componente em um diagrama (como sempre), mas também com qualquer uma das réplicas, no entanto, quando as ligações são automaticamente adicionadas a um diagrama estão ligados à primeira ocorrência do componente no diagrama por padrão.

Nota

Réplicas podem ser fundidos uns com os outros por clique com o botão direito e arrasteem seguida, selecionando Mesclar RéplicasNo entanto, a fusão uma réplica com um componente diferente resultará em quaisquer outras réplicas desaparecendo a partir do diagrama.

Nota

Não existe qualquer diferença visual entre o exemplo original de um componente em um diagrama e quaisquer réplicas. Além disso, o menu do botão direito do mouse para o componente original em um diagrama e qualquer réplicas é idêntico, com, por exemplo, Mostrar no Explorerlevá-lo para o mesmo componente na Vista em Árvore do repositório (aka o modelo). No entanto, clicando com o botão direito no componente na Vista em Árvore do repositório e selecionando Vamos parae de navegação a um diagrama com réplicas será sempre levá-lo para a "mais antiga" instância do componente no diagrama. Normalmente, esse será instância original que foi adicionada ao diagrama, mas se essa instância original foi posteriormente excluído ou se fundiu com uma réplica, em seguida, Go To irá saltar para a mais antiga das restantes réplicas que foram adicionados.

Para adicionar uma réplica a um diagrama

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Botão direito do mouse um componente existente no diagrama e selecione Criar réplica.Uma réplica do componente seleccionado irá ser criado para a direita do componente original.

- OU -

Selecione um componente existente em um diagrama e pressione Ctrl + Cou clique com o botão direito um componente existente no diagrama e selecione Cópia. Agora botão direito do mouse o local no diagrama que você deseja que a réplica e selecione Colar como Replica. Nota: Pressionar Ctrl + V (ou-botão direito e selecione Colar) irá criar uma cópia do componente original não uma réplica.

- OU -

Clique e arrasteum componente a partir da árvore do repositório (aka o modelo) para um diagrama, onde já existe o componente.

Configurando Conexão Caps / Extremidades

A ferramenta de desenho permite que você definir o símbolo usado nas extremidades das linhas de ligação, nem a um símbolo de um símbolo fixo ou dependente de uma propriedade sobre a própria conexão.Isso é particularmente útil para os diagramas em que é necessária a direção de uma conexão a ser mostrado, ou para diagramas onde a cardinalidade da conexão (ou a direção) está contido em uma propriedade na própria conexão, por exemplo, 'Um-para-muitos' vs 'Many-to-Many "(ou" Fonte de afundar' vs 'Sink a fonte ").

Para configurar tampas de conexão / termina em um diagrama

1. Certifique-se de que você tem um novo ou existente diagrama aberto.

2. Selecione os Conectaríonsaba na janela de stencil.

3. Direito do clamber um dos associada tipos de conexão e selecione Configurar Caps ....

4. Para uma ligação fixa cap / end em qualquer fonte ou afundar fim da ligação verifique se a relevante Fixo botão de opção é selecionado e, em seguida, selecione o símbolo de fim de conexão do pull down, por exemplo, 'Seta Head' ou 'Diamond'.

- OU -

Para uma conexão cap / end baseado na propriedade de origem ou afundar fim da ligação verifique se a relevante Usando Propriedadebotão de opção é selecionado, em seguida, clique no botão '...' e selecione a propriedade necessária e, em seguida, ao lado de cada símbolo final conexão introduzir os valores de propriedade para o qual o símbolo de conexão específica são para ser mostrado.

Nota

Vários valores de propriedade para um determinado símbolo fim de conexão podem ser inseridos separados por vírgulas. Por exemplo. o diálogo abaixo mostra que, se o 'Dados | Cardinalidade 'propriedade tem um valor de' One-para-muitos ", então o fim fonte da conexão terá duas linhas traçados por ele e no final pia da conexão terá um traçado da linha através dele e, em seguida, um fan-out de dois A linha traçados no final.

Configure diálogo Caps

Veja também

A Ferramenta de Desenho | Preenchendo sua arquitetura | Analisar sua arquitetura


Manipulando Diagrams

Navegação: Preenchendo sua arquitetura> Usando Drawings>

Manipulando Diagrams

Envie seus comentários neste tópico.

Uma vez que um diagrama tenha sido criado, os elementos que aparecem em que pode ser re-arranjados e re-size como desejado.

Para mover um componente em um diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Clique e segurequalquer componente para movê-lo. Se o componente selecionado tem um pai, o componente pai será destacado.

3. À medida que o elemento éarrastaram de seu componente pai, e mais de outros componentes, os pais "potencial" ficará destacado. O esquema de cores usado indica o efeito da operação terá sobre os avisos e erros com o projeto atual e é descrito em Pela definição e validação Restrições . Desta forma, você pode navegar graficamente a hierarquia de uma "visão de plano '.

4. Lançamentoo botão do mouse para soltar o elemento em sua nova localização.

Nota

Você também pode usar o teclado para re-posicionar elementos na tela de desenho. Basta selecionar o formato do componente ou forma livre que você deseja mover e use as setas localizadas no teclado para mover a forma para o local desejado.

Observe também que ao arrastar um componente com o mouse sobre um outro componente, um "potencial" componente pai é realçado quando o canto superior esquerdo do componente que você está arrastando sobrepõe outro componente.

Dica

Forma livre e Formas flutuantes pode ser encomendado por botão direito do mousee selecionando Traga para frente ou Enviar para trása partir do menu. É importante notar que a forma dos componentes pode ser convertida em formas livres por botão direito do mouseem forma componente específico e selecionando Converter em Freeform.

Para redimensionar um componente em um diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Clique e segure e arrasteuma das alças do componente e redimensionar a forma para o tamanho desejado.

3. Como alternativa para manter a relação de aspecto da forma, deprimir Shift + Clique e arraste-hold.

Para mover uma ligação em um diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Clique e segurequalquer conexão para movê-lo.

3. Lançamentoo botão do mouse para soltar o elemento em sua nova localização.

Nota

Você só pode mover as conexões que não estão ligados a quaisquer componentes. Se eles estão ligados, você só pode mover a extremidade livres, ou re-rotear a conexão .

Excluindo componentes e ligações

Ao excluir um componente ou uma conexão a partir de um diagrama, você tem a opção de excluí-lo de toda a arquitetura. Qualquer componente que é excluído da arquitetura será automaticamente removido de quaisquer outros diagramas em que aparece. Desde instâncias de forma livre só aparecem em um diagrama, excluí-los não afeta o modelo de arquitetura ou qualquer outro diagrama.

Para eliminar um componente de ligação ou de um diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Cliqueem qualquer conexão associado ou componente para selecioná-lo.

3. aperte o Excluirchave para excluí-lo a partir do diagrama, ou Shift + Deletepara excluí-lo de todo o modelo.

- ou -

2. Clique com o botão direito do mouse em qualquer elemento associado ou componente. Um menu de contexto aparecerá.

3. Selecionar Excluir do Vista ou Excluir do Arquiteturano menu de contexto.

Nota

Se o elemento que você deseja excluir do ponto de vista não tem filhos e só ocorre em vista que, ABACUS irá perguntar se você deseja excluir o elemento a partir do repositório também.

Cuidado

Ao excluir um componente do modelo que tem componentes filhos, os filhos também serão potencialmente excluídos de acordo com o diálogo de aviso.

Componentes Mesclando

Você pode querer mesclar duas componentes existentes no mesmo diagrama (e dentro da arquitectura). Isto pode ser feito, por muitas razões, por exemplo, Dois servidores existe dentro de uma empresa Infra-estrutura de H01 e H02. Estes dois servidores estão representados como dois componentes separados dentro de uma arquitetura. H01 foi considerada desnecessária e, portanto, deve ser desmantelada. Todas as aplicações existentes que funcionam em H01 está a ser deslocada para a H02 (ainda em comissão). Esta alteração pode então ser reflectido pela acção de "fusão", os dois componentes H01 e H02 no diagrama (e dentro da arquitectura).

Para uma discussão detalhada sobre a fusão por favor consulte o tópico Itens Mesclando Aqui .

Para mesclar dois componentes existentes

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouse segure-no componente que você deseja mesclar e arrastar-o para o componente que você deseja mesclar com. Certifique-se o contorno do componente de destino é destacado em vermelho para indicar que ele está selecionado.

3. Selecionar Mesclar | Preserve Destino ou Overwrite Destinoa partir do menu.

Nota

o Preserve Destinoopção preserva os valores das propriedades do componente de destino se elas existirem no componente de origem também.

o Overwrite Destinoopção substitui propriedades do componente destino com quaisquer propriedades comuns a partir do componente de origem.

Mudando Conexões

As ligações mostradas num diagrama semprereflectir a estrutura tal como definida no próprio arquitectura. A ferramenta de desenho permite destacar as conexões de componentes, movê-los, curva-los, re-encaminhá-los e re-anexá-los a outros componentes.

Para desanexar / anexar uma ligação de / para um componente

1. Certifique-se de que você tem um existente diagrama aberto .

2. Clique e segureem qualquer ligação.

3. Selecionar a conexão fim(i.e. Fonte ou Sink) Que você gostaria de destacar / attach. Nota: as extremidades da conexão são indicados por pequenos círculos brancos e pairando sobre o círculo branco por um segundo fará com que uma 'dica' para aparecer com o respectivo Função nome(isto é, de origem ou de Sink).

4. Arrastara ligação terminar para um novo local (seja um lugar vago ou um componente) e solte o botão do mouse.

Nota

Quando uma conexão final é colocado sobre um componente válido, o contorno do componente de destino é realçada com um contorno tracejado. O esquema de cores usado indica o efeito da operação terá sobre os avisos e erros com o projeto atual e é descrito em Pela definição e validação Restrições . Uma vez liberado que extremidade do the conexão e o componente são automaticamente conectado(ou ligado), E isso se reflete no modelo de arquitetura.

Para re-rotear uma conexão

1. Certifique-se de que você tem um existente diagrama aberto .

2. Posicione o ponteiro do mouse sobre uma conexão.

3. Segure o Mudançabaixo chave e Cliqueo botão do mouse para colocar um ponto de ancoragem de conexão. Solte o Mudança chave. Você pode remover o ponto de ancoragem, fazendo a mesma operação.

4. Clique e arrasteo ponto de ancoragem para re-encaminhar a conexão.

Dica

Use oAlt chave em vez de o Mudançachave para criar conexões ortogonais.

Para curva ou endireitar uma conexão

1. Certifique-se de que você tem um existente diagrama aberto .

2. Posicione o ponteiro do mouse sobre uma conexão.

3. Botão direito do mousetele conexão e, no menu de contexto que aparece, selecione Curva, Ortogonal ou Hetero.

Dica

Todas as conexõesde um determinado tipo no diagrama pode ser configurado para Curvo, ortogonal ou em linha reta pelo botão direito do mouse a linha associada ao tipo no Guia Conexões do Janela Stencile Curve seleção, Orthogonal ou Hetero.

Para ancorar num ponto específico sobre a borda de uma forma

1. Certifique-se de que você tem um existente diagrama aberto .

2. Selecione uma conexão.

3. Posicione o ponteiro do mouse sobre o 'ponto branco "no final do uma conexão.

4. Botão direito do mousetele extremidade de conexão e, no menu de contexto que aparece, selecione Ancorar Endpoint em Forma.Mover a extremidade de ligação para o local desejo na borda da forma.

OU

Segure o Ctrlbaixo chave e clamber e arrastar a fim de conexão aponta para o desejo de localização na extremidade da forma.

Nota

Conexões se encaixará na intercepção real de sua forma ligado em vez da caixa delimitadora de que forma.

Veja também

A Ferramenta de Desenho | Preenchendo sua arquitetura | Analisar sua arquitetura


Desenho características da ferramenta

Navegação: Preenchendo sua arquitetura> Usando Drawings>

Desenho características da ferramenta

Envie seus comentários neste tópico.

A ferramenta de desenho suporta uma série de características de desenho.

Zooming

A escala do diagrama pode ser alterado usando a função de zoom.

Para diminuir a escala ou 'zoom in'

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. pressione Ctrlea tecla '='.

- ou -

2. Selecione os Mais Zoomno botão Diagrambarra de ferramentas.

- ou -

2. pressione Ctrle rolar a roda do mouse para a frente. Nota: Neste modo, a tela irá aumentar para onde o mouse está pairando sobre a tela.

Para aumentar a escala ou 'zoom'

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. pressione Ctrle a tecla - ''.

- ou -

2. Selecione os Afastarno botão Diagrambarra de ferramentas.

- ou -

2. pressione Ctrle rolar a roda do mouse para trás. Nota: Neste modo, a tela irá aumentar para o exterior a partir de onde o mouse está pairando sobre a tela.

Auto-disposição

A disposição dos componentes no diagrama pode ser modificada automaticamente.

Para o layout todos componentes on um diagrama

1. Clamber a Disposição Diagramabotão na barra de ferramentas Diagrama.

2. Selecionar ou Radial Disposição ou Layout de grade.

Nota

O layout Radial vai usar o que é chamado um algoritmo 'dirigida-força "de tal forma que os componentes conectados são desenhadas juntos enquanto os componentes não ligados são forçados a se separar. O layout da grade irá utilizar um algoritmo de largura e altura de espaçamento fixo. É em primeiro lugar permite ao usuário escolher a relação de aspecto diagrama geral (por exemplo, 16: 9, A4 (Retrato), Carta (Paisagem)) e, em seguida, o espaçamento para os lados e entre as colunas e linhas como mostrado abaixo.Com grade de layout quaisquer conexões entre os componentes não afetam o layout, uma vez que se limita a providenciar os componentes alfabeticamente (pelo seu nome) a partir do canto superior esquerdo ao canto inferior direito da tela. Com ambos os algoritmos de formas livres não são movidos.

Para o layout crianças componentes em um único o pain um diagrama

1. Botão direito do mouseum componente de alto nível cujos filhos você deseja auto-layout.

2. Selecionar Arranjo Crianças.

Nota

Por padrão, somente o algoritmo de layout Radial é usado.

Alterar Elemento Estética Como Cor, Transparência, sombras e Rotação

Todos os elementos do diagrama têm estética que podem ser manipuladas como desejado. No caso de formas associadas, estes aspectos podem ser definidos por tipoe na maioria dos casos, também por exemplo. No caso de formas livres, estas propriedades podem ser definidas por exemplona tela.

Nota

Qualquer instância por aspectos que foram definidas para formas associadas será "substituído", se o mesmo aspecto é alterado para o tipo correspondente.

Para mudar a cor de uma forma associada ou uma forma livre

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou forma livre na tela.

3. Selecionar Mudar cor.

4. Selecione os Cor fixobotão de rádio (se aplicável).

5. Escolha uma cor básica ou definir uma cor personalizada na caixa de diálogo e clique Está bem.

- ou -

4. Selecione os Gradientebotão de rádio (se aplicável).

5. Escolha qualquer Horizontal, Vertical, Atacante Diagonal ou Backward Diagonal para a direção do gradiente no menu suspenso e clique Está bem.

6. Escolha uma cor básica ou definir uma cor personalizada na caixa de diálogo para Começar e Fime clique em Está bem.

Nota

ABACUS irá colorir o primeiro plano de uma forma se;
a) é uma forma "simples" com um único elemento gráfico subjacente (por exemplo, círculo, retângulo, polígono etc), ou
b) é uma forma de "complexo" com várias subformas subjacentes que são todos da mesma cor / gradiente como o outro ou os subformas têm LockScale = TRUE set.
Se as condições acima não forem cumpridas, então o fundo da forma é colorido.

Para definir a cor de uma forma associado de acordo com uma propriedade

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil(NÃO na tela de desenho).

3. Selecionar Mudar cor.

4. Selecione os Usando Propriedade botao de radio.

5. Selecione um estabelecimento clicando no botão '...' à direita da caixa de texto.

6. Selecione os Alcance botao de radio.

7. Ajusta a Min e Maxvalores como desejado. Nota: qualquer valor abaixo do valor mínimo será mostrado como a cor Min e qualquer valor acima do máximo será mostrado como a cor Max. Além disso, ao usar booleano, Lista ou Data / Hora propriedades os valores são convertidos para um índice como se segue; Booleano (False = 0, True = 1), List (um vale inteiro de 1 a n para cada valor válido em sua ordem crescente especificado no campo unidades) e data / hora (número de dias desde 1 de janeiro de 1900 - incluindo decimais para horas, minutos, segundos porções - e se a data é anterior a 1990 é um número negativo).

8. Escolha uma cor básica ou definir uma cor personalizada na caixa de diálogo para Min e Maxe clique em Está bem.

Dica

E se Verde (RGB - 128,255,0) é escolhida como a cor e Min Vermelho (RGB - 255,0,0) é escolhido como a cor Max para uma propriedade com valor de gama 1 para 4em seguida, um valor de 1vai ser exibido como Verde, Um valor de 2 Como Amarelo, 3 Como laranja e 4 Como Vermelho.

Alternativamente, para uma gama de propriedades 1 para 3um valor de 1como será Verde, Um valor de 2 Como Âmbar e 3 Como Vermelhoaka 'Semáforo' ou estatuto RAG.

Para obter uma gama de propriedades de 1 a 5 se Azul (RGB - 0,0,255) é escolhido como a cor e Min Vermelho (RGB - 255,0,0) é escolhido como o Max colorir um valor de 1 como será Azul, Um valor de 2, tal como Água, Um valor de 3 a Verde, Um valor de 4, tal como Amarelo e um valor de 5 enquanto Vermelho.

Para obter uma gama de propriedades de 1 a 6 se Violeta (RGB - 255,0,255) é escolhido como a cor e Min Vermelho (RGB - 255,0,0) é escolhido como o Max colorir um valor de 1 como será Violeta, Um valor de 2, tal como Azul, Um valor de 3 a Água, Um valor de 4, tal como Verde, Um valor de 5 enquanto Amarelo e um valor de 6 quando Vermelho.

E, finalmente, para uma gama de propriedades de 1 a 7, um valor de 1 como será Violeta, Um valor de 2, tal como Azul escuro, Um valor de 3 a Azul claro, Um valor de 4, tal como Azul verde, Um valor de 5 enquanto Verde, Um valor de 6 quando Âmbar e um valor de 7, tal como Vermelho

Nota

Veja a nota acima no primeiro plano contra o fundo colorir.

- ou -

7. Selecione os Valor específico botao de radio.

8. Clique no Editar Colours botão.

9. Selecione cada valor, por sua vez e clique Definir Corpara definir uma cor específica para cada valor.

Nota

A gama de valores para os elementos presentes no diagrama será pré-preenchido.

10. Para adicionar todas as cores de valor adicional para os pré-preenchida (por exemplo, após o intervalo propriedade foi reconfigurado) clique Adicionar valor.

Para alterar a transparência da cor de uma forma associada ou uma forma de forma livre

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou forma livre na tela.

3. Selecionar Mudar cor.

4. No painel Transparência definir o controle deslizante superior para a transparência desejada para a cor de base.

5. Se estão sendo usados ​​a Gradiente ou utilizar as opções de propriedade, no painel Transparência defina o controle deslizante inferior para a transparência desejada para a segunda cor.

6. Clique Está bem.

Mostrar sombras para todos os associado formas em um diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentesaba da janela do stencil.

3. Selecionar Adicionar Sombras.

Para mostrar uma sombra sobre um componente de forma ou forma livre

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Certo-cliquena forma livre ou forma de componente na tela.

3. Selecionar Adicionar Sombras.

Para girar formas de componentes e formas de forma livre em diagramas

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Selecione a forma de componente ou uma forma livre sobre a tela que você deseja girar.

3. Botão direito do mousena forma e selecione Rotatee, em seguida, selecionar o ângulo relevante que você deseja girar a forma pela.

Alterar Elemento Anotações e rótulos de texto de forma livre

Todos os elementos do diagrama tem anotações que podem ser manipuladas como desejado. No caso de formas associadas, estes aspectos podem ser definidos por tipoe na maioria dos casos, também por exemplo. No caso de formas livrese conectores, arótulos de texto pode ser definida por exemplona tela.Oito (8) diferentes tipos de anotações pode ser exibido para elementos do diagrama (ou seja, nome, tipo, valor da propriedade, propriedade do marcador, componentes fixados, filhos (somente para componentes), Normas e Timestamps (Criado, Modificado por etc)) em vinte e cinco (25) posições diferentes (por exemplo, Centro - Top Outside, Inside left - Centro, à direita fora - Fundo Exterior).

Nota

Qualquer instância por aspectos que foram definidas para formas associadas será "substituído", se o mesmo aspecto é alterado para o tipo correspondente.Além disso, se 2 ou mais anotações ocupam a mesma posição apenas uma única fonte, estilo da fonte, cor e tamanho da fonte pode ser usado e um separador (por exemplo, vírgula, espaço, nova linha) deve ser selecionado.

Mostrar o nome ou tipo de um componente ou de conexão associado

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou conector na tela.

3. Selecionar Anotações.

Nota

Para uma forma individual ou associada conector na tela você precisará selecionar o Substituir estêncil Anotaçõesa caixa de verificação primeira vez.

4. Selecione New anotação na barra de ferramentas e selecione Nome ou Tipo.

5. Na caixa de diálogo que aparece, selecione as opções de exibição que são desejados incluindo suportes eo estilo da fonte, fonte, cor de fonte e tamanho. Além disso, selecione as opções de layout que são desejados, incluindo o alinhamento horizontal e vertical (ie posição anotação) eo Ângulo (ou seja, rotação). Selecionar Está bem.

Para mostrar uma propriedade valor de um componente ou de conexão associado

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou conector na tela.

3. Selecionar Anotações.

Nota

Para uma forma individual ou associada conector na tela você precisará selecionar o Substituir estêncil Anotaçõesa caixa de verificação primeira vez.

4. Selecione New anotação na barra de ferramentas e selecione Valor de propriedade.

5. Na caixa de diálogo que aparece, selecione a propriedade clicando no imóvel: '...' botão e escolha de uma propriedade na caixa de diálogo Selecione uma propriedadee selecione Está bem. Selecione as opções de exibição que são desejados incluindo suportes eo estilo da fonte, fonte, cor de fonte e tamanho. Além disso, selecione as opções de layout que são desejados, incluindo o alinhamento horizontal e vertical (ie posição anotação) eo Ângulo (ou seja, rotação). Selecionar Está bem.

Para mostrar uma propriedade marcador de um componente ou de conexão associado

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou conector na tela.

3. Selecionar Anotações.

Nota

Para uma forma individual ou associada conector na tela você precisará selecionar o Substituir estêncil Anotaçõesa caixa de verificação primeira vez.

4. Selecione New anotação na barra de ferramentas e selecione Propriedade Marcador.

5. Na caixa de diálogo que aparece, selecione a propriedade clicando no imóvel: '...' botão e escolha de uma propriedade na caixa de diálogo Selecione uma propriedadee selecione Está bem. Defina o raio do marcador em pixels eo método de coloração, quer Colour By Faixa ou cor por propriedade e definir as atribuições de cores. Além disso, selecione as opções de layout que são desejados, incluindo o alinhamento horizontal e vertical (ie posição anotação) eo Ângulo (ou seja, rotação). Selecionar Está bem.

Mostrar componentes ligados de um componente ou de conexão associado

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou conector na tela.

3. Selecionar Anotações.

Nota

Para uma forma individual ou associada conector na tela você precisará selecionar o Substituir estêncil Anotaçõesa caixa de verificação primeira vez.

4. Selecione New anotação na barra de ferramentas e selecione Componentes ligados.

5. Na caixa de diálogo que aparece, para componentes associados selecionar o tipo de componente anexado clicando no anexo: botão '...' e escolher um tipo de componente no diálogo Definir tipo de componentee selecione Está bem. Selecione o tipo de conexão anexado clicando no Via Conectado: '...' botão e escolher um tipo de conexão na caixa de diálogo Set Tipo de conexãoe selecione Está bem.Para conexões associadas selecionar o fim de conexão selecionando fonte ou a partir do final de Conexão: menu suspenso. Para ambos os componentes e conexões associadas selecione as opções de exibição que são desejados incluindo suportes eo estilo da fonte, fonte, cor de fonte e tamanho. Além disso, selecione as opções de layout que são desejados, incluindo o alinhamento horizontal e vertical (ie posição anotação) eo Ângulo (ou seja, rotação). Selecionar Está bem.

Mostrar as crianças para um componente associado

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentesaba da janela do stencil ou uma forma associada na tela.

3. Selecionar Anotações.

Nota

Para uma forma associada indivíduo na tela você precisará selecionar o Substituir estêncil Anotaçõesa caixa de verificação primeira vez.

4. Selecione New anotação na barra de ferramentas e selecione Crianças.

5. Na caixa de diálogo que aparece, selecione as opções de exibição que são desejados incluindo suportes eo estilo da fonte, fonte, cor de fonte e tamanho. Além disso, selecione as opções de layout que são desejados, incluindo o alinhamento horizontal e vertical (ie posição anotação) eo Ângulo (ou seja, rotação). Selecionar Está bem.

Mostrar as normas de um componente ou de conexão associado

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou conector na tela.

3. Selecionar Anotações.

Nota

Para uma forma individual ou associada conector na tela você precisará selecionar o Substituir estêncil Anotaçõesa caixa de verificação primeira vez.

4. Selecione New anotação na barra de ferramentas e selecione Padrões.

5. Na caixa de diálogo que aparece, selecione as opções de exibição que são desejados incluindo suportes eo estilo da fonte, fonte, cor de fonte e tamanho. Além disso, selecione as opções de layout que são desejados, incluindo o alinhamento horizontal e vertical (ie posição anotação) eo Ângulo (ou seja, rotação). Selecionar Está bem.

Mostrar a data e hora de um componente ou de conexão associado

1. Certifique-se de que você tem um existente diagrama aberto .

2. Botão direito do mouseem uma forma associada ou no conector Componentes ou Conexõesaba da janela do stencil ou uma forma associada ou conector na tela.

3. Selecionar Anotações.

Nota

Para uma forma individual ou associada conector na tela você precisará selecionar o Substituir estêncil Anotaçõesa caixa de verificação primeira vez.

4. Selecione New anotação na barra de ferramentas e selecione Criado, Criado por, criado marcador, Modificado Modificado por ou Modificado Marcador.

5. Na caixa de diálogo que aparece, se não um marcador, selecione as opções de exibição que são desejados incluindo suportes eo estilo da fonte, fonte, cor de fonte e tamanho. Se um marcador, definir o raio do marcador em pixels eo método de coloração, quer Colour By Faixa ou cor por propriedade e definir as atribuições de cores. Além disso, selecione as opções de layout que são desejados, incluindo o alinhamento horizontal e vertical (ie posição anotação) eo Ângulo (ou seja, rotação). Selecionar Está bem.

Para mudar o estilo de uma forma livreou conector

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Botão direito do mousena forma livre ou conector na tela. Nota: Se o conector rótulo de texto não é mostrar, em seguida, para mostrar a conexãoou rótulo de texto: Botão direito do mouseo connectoue selecione Anotação | Mostrar Anotação.

3. Selecionar Alterar fonte.

4. Selecione um estilo de fonte, Fonte e Tamanho na caixa de diálogo e selecione Está bem.

Para alterar o tipo de letra cor de uma forma livreou conector

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Botão direito do mousena forma livre ou conector na tela. Nota: Se o conector rótulo de texto não é mostrar, em seguida, para mostrar a conexãoou rótulo de texto: Botão direito do mouseo connectoue selecione Anotação | Mostrar Anotação.

3. Selecionar Alterar Cor da pia batismal.

4. Selecione um tipo de letraCor (e por formas a cor link), clicando no botão '...' e selecionando uma cor na caixa de diálogo e selecione Está bem.

5. Selecione a transparência do rótulo de texto, ajustando o controle deslizante com 0 sendo totalmente transparente e 255 sendo totalmente opaco.

Para girar o rótulo de texto de uma forma livreou conector

1. Certifique-se de que você tem um novo ou existente diagrama aberto .

2. Botão direito do mousena forma livre ou conector na tela. Nota: Se o conector rótulo de texto não é mostrar, em seguida, para mostrar a conexãoou rótulo de texto: Botão direito do mouseo connectoue selecione Anotação | Mostrar Anotação.

3. Selecionar Rotatee, em seguida, selecionar o ângulo relevante que pretende rodar o rótulo de texto de.

Veja também

A Ferramenta de Desenho | Preenchendo sua arquitetura | Analisar sua arquitetura


Usando links em Diagramas

Navegação: Preenchendo sua arquitetura> Usando Drawings>

Usando links em Diagramas

Envie seus comentários neste tópico.

Shapes (forma e componentes livres) e Conectores (forma livre ou conexões) dentro de diagramas podem ser ligados a suas representações arquitectónicas existentes no ABACUS, bem como arquivos / pastas externas e URLs. Esses links podem então ser gerenciados (criados, modificados e excluídos) por meio do conjunto de ferramentas ABACUS. Este recurso pode ser usado para melhorar a navegação e compreensão global da sua arquitetura diagrama.

Para adicionar links para seu diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Selecione a forma relevante ou conector a partir do seu diagrama.

3. Botão direito do mousena formaou conector.

4. Selecionar Abrir linkse um LigaçõesAparece a janela.

5. Clique no Adicionare um ícone New LinkAparece a janela.

6. Selecione o relevante Catálogo | Matrix | Diagrama| Ver 3D| Gráficobotões de rádio, em seguida, selecione o relevante catálogo, matriz, diagrama, 3Dou gráfico vista na arquitetura atual do Link para menu suspenso.

- ou -

6. Selecione os Sitebotão de rádio, em seguida, digite a URL relevante (por exemplo, http: //www.avolutionProgramas.com /)no campo para conectar-se a uma página da web. URLs válidos precisa para começar com um dos 5cordas; http: //, https: //, ftp: //, arquivo: ou \\. Os espaços devem ser inseridos com um '% 20'.

- ou -

6. Selecione os Arquivo Absolute | Arquivo Relativa botao de radios,em seguida, clique no botão '...'Botão para procurar um arquivo externo para conectar-se ao seu diagrama.

7. Clique Está bemeo novo link será exibido na janela de Links. Nota: A janela links podem ser redimensionadas para ver o nome completo, se necessário.

8. Repita os passos 5-7para criar mais ligações.

9. Para seguir o link criado, selecione o link relevante exibida no Ligaçõesjanela e clique Ligação aberta.

Nota

Quando várias anotações estão a ser mostrados para uma forma ou conector o link é exibido na primeira anotação na lista de anotações no diálogo Editar Anotações.

Para seguir links do seu diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Selecione a forma relevante ou conector a partir do seu diagrama.

3. Cliqueno link relevante (azul sublinhado nome do componente) em uma forma ou conector no diagrama para abrir e exibir o primeiro elo da formaou conector.Nota: O cursor deve mudar para uma 'mão' quando a ligação está pronta para ser clicado.

- ou -

3. Selecione a forma relevante ou conector a partir do seu diagrama.

4. Botão direito do mousena formaou conector.

5. Selecionar Abrir links e a LigaçõesAparece a janela.

6. Selecione o link relevante que você gostaria de ver.

7. Clique no Ligação abertabotão para abrir e visualizar o link relevante.

Para excluir links em seu diagrama

1. Certifique-se de que você tem um existente diagrama aberto .

2. Selecione a forma relevanteou conectora partir do seu diagrama.

3. Botão direito do mousena formaou conector.

4. Selecionar Abrir links e a LigaçõesAparece a janela.

5. Selecione o link relevante que precisa ser eliminado.

6. Clique no Excluir botão. e a ligação é removida a partir da Ligações janela.

Organizadoras ligações em seu diagrama

Você pode escolher quais ligados diagrama, arquivo externo, ou URL web é exibido quando uma etiqueta forma é Ctrl + clicado no diagrama.

1. Certifique-se de que você tem um existente diagrama aberto .

2. Selecione a forma relevante ou conector a partir do seu diagrama.

3. Botão direito do mousena formaou conector.

4. Selecionar Abrir links e a LigaçõesAparece a janela.

5. Para modificar a ordem dos links, clique no Move Up | Mover para baixobotões do lado direito da Ligações janela.

6. O primeiro link que aparece no lado esquerdo da Ligaçõeswindow é o link que aparece quando você Ctrl + Cliqueuma forma de hiperlink ou conector nome.

Veja também

Preenchendo sua arquitetura | Preenchendo a arquitetura manualmente | Analisar sua arquitetura


Viewpoints Diagrama

Navegação: Preenchendo sua arquitetura> Usando Drawings>

Viewpoints Diagrama

Envie seus comentários neste tópico.

ºe pontos de vistacaracterística assegura que os componentes e as ligações que são acrescentados a um diagrama deve ter uma associação do tipo anteriormente definido antes que pode ser adicionado a um diagrama. Este recurso permite a restrição dos tipos de diagramas que podem ser tiradas, restringindo as formas e conectores que estão associados com componentes e Conexõesexistente dentro de sua arquitetura.

Como ativar ou desativar Impondo diagrama pontos de vista

A capacidade de fazer valer pontos de vista diagrama é automaticamente ativado por padrão. Para ativar / desativar este recurso, clique em Ferramentas | Opções ...| a Diagramaguia e desmarque / selecionar o Impor Diagrama Pontos de Vistacaixa de verificação em conformidade.

Nota

Se você não ver o 'Impor Diagrama Pontos de Vista'Opção na guia Diagrama em seguida, você não tem o Designer add-on ea opção é ativada por padrão.

Criando um diagrama de força executória ponto de vista

1. Verifique se você tem um Arquivo ABACUS aberto com a exploradorvista exibida.

2. Na visão de explorador clique direito sobre Visãopontose clique em Crio Ponto de Vista diagrama

3. o Ponto de Vista diagramajanela será exibida.

4. Atribua um nome relevante para o ponto de vista diagramae note que o ponto de vista é salvo sob o Pontos de Vistaseção do explorador.

5. o Ponto de Vista diagramajanela será exibida.

6. Agora clique e arraste os tipos de componentes relevantes e tipos de conexão em suas arquiteturas para o formas de ponto de vista você quer. Tipos de componentesdeve ser arrastado para uma forma no formasguia, enquanto tipos de conexãodeve ser arrastado para uma das formas de linha de estilo 5 no conectorestab.

7. Para salvar o ponto de vista diagramaque você criou, clique no [image] no canto superior direito da sua Ponto de Vista diagrama janela.

Nota

o ponto de vista diagramapodem ser editadas pelo botão direito sobre o ponto de vista e selecionando Aberto ou clicando duas vezes a ponto de vista.

Synchonising um ponto de vista atualizado com diagramas

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Ou clique com o botão direito do mouse no ponto de vista na Explorador janela sob Meta-modelo | Pontos de Vistae selecione Sincronizar Diagrama Mapeamentos ...

- ou -

3. Fechar o ponto de vista aberta e atualizada janela e selecione sim no Sincronize para Ponto de Vistadiálogo que é exibida.

4. o Ponto de Vista Sincronizaçãodiálogo será exibida como mostrado abaixo.

Checkboxes

· Adicionar mapeamentos que faltam- Qualquer nova forma (para tipo de componente) ou conector (para tipo de conexão) associações que foram adicionadas ao ponto de vistaserá adicionado à diagrama correspondentes (isto é, a suastencils) aquele estão ligados ao ponto de vista.

· Atualização ExistenteMapeamentos- Quaisquer aspectos atualizadas da forma existente (a) ou tipo de componente conector (para tipo de conexão) para associações ponto de vista(por exemplo, cor, estilos de fonte) será atualizado no diagrama correspondentes (isto é, a suastencils) aquele estão ligados ao ponto de vista.

· Retirar extraMapeamentos- Qualquer forma adicional (para tipo de componente) ou conector (para tipo de conexão) associações que foram adicionadas ao diagramas (ou seja, os seus stencils), mas não está no ponto de vistavai ser removida do diagrama correspondentes (isto é, a suastencils) aquele estão ligados ao ponto de vista.

· Substituir Configurações Locais para adicionado ou atualizado de mapeamentos (Diferenças Only)- Quaisquer aspectos atualizadas da forma existente (a) ou tipo de componente conector (para tipo de conexão) para associações ponto de vista(por exemplo, cor, estilos de fonte) será aplicada aos elementos correspondentes nos diagramas que estão ligadas ao miradouro.Apenas são aplicadas as "diferenças" atualizados feitas no ponto de vista de modo quaisquer definições locais existentes no diagrama que não foram atualizadas no ponto de vista permanecerá inalterada.

· [image] Anotações – Como acima, mas especificamente para as anotações.

Veja também

A Ferramenta de Desenho | Preenchendo sua arquitetura | Analisar sua arquitetura


Preenchendo usando Catálogos

Navegação: Preenchendo sua arquitetura>

Preenchendo usando Catálogos

Envie seus comentários neste tópico.

A catálogo permite-lhe visualizar e editar componentes ou conexões e suas propriedades de uma forma tabular simples.

Para criar um novo Catálogo visualizar em ÁBACO

Nota

Enquanto todos os usuários do arquiteto pode criar novos catálogos, para salvar as alterações nas configurações de um Catálogo existente licença de usuário precisa do Designer add-on capacidade. Isso é para "proteger" a configuração de Catálogos existentes que podem ser compartilhados por muitos usuários. No entanto, arquiteto usa sem a Designer complemento ainda pode optar por 'Salvar como' quaisquer novas configurações para um novo catálogo. E, claro, todas as licenças de usuário pode optar por «desfazer» quaisquer alterações em um catálogo existente. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar Designer add-on capacidade. E lembre-se, este é apenas as configurações do Catálogo, todas as edições feitas nos dados do catálogo são aplicadas imediatamente para o repositório, independentemente.

1. Selecione Insert | Catálogo.

2. no pull-down, selecione a arquitetura que contém os componentes ouconexões que você deseja visualizar.

3. no pull-down selecione o componente ou tipo de conexão que você deseja ter as instâncias listado como 'linhas' no catálogo.

4. o catálogo será preenchida com umlinha para cada instância do tipo de componente ou de conexão selecionado.

Nota

Por padrão o mais à esquerda Caminho hierarquiacoluna (ou seja, a hierarquia de componentes pai ou conexões acima das instâncias selecionadas) eo segundo Nome coluna (ou seja, a lista das instâncias de componentes ou de conexão selecionadas) são congelados à esquerda do catálogo. Para alterar a coluna congelando arraste o separador de coluna à direita da coluna Nome. Você pode re-fimcolunas simplesmente arrastando e soltando os seus títulos de coluna. As células de colunas com um sublinhado azul são hyperlinks para outros elementos do projecto e os hiperlinks podem ser seguidas, mantendo pressionada a tecla Ctrl e clicando nos links. As colunas podem ser escondido clicando com o título da coluna e selecionar Coluna | Esconder Coluna. Colunas ocultas podem ser unhidden clicando no botão Configurar barra de ferramentas Colunas e usando o diálogo como mostrado abaixo Colunas Configurar, ou selecionando a parte de seta para baixo do botão Configurar barra de ferramentas Colunas e individualmente selecionando a coluna escondida (s) a partir de qualquer Geral, Propriedades ou coleções anexos. As linhas podem ser agrupados pelos seus valores coluna arrastando o título de coluna na barra de agrupamento azul no topo do catálogo. A qualquer momento você pode clicar duas vezes sobre o seletor de linha catálogo e pule parao componente correspondenteou conexãona janela do Explorer.Os valores das células são propriedade negrito onde eles são diferentes para os padrões e itálico onde eles são somente leitura. Timestamp, Propriedade e anexado colunas componente pode ser colori de acordo com os valores de célula ou valor de propriedade de um componente ligado ao clicar com o botão direito no título da coluna e selecionar Coluna | Mudar cor ... e, em seguida, a cor ou por Timestamp opção Colour By Property, no entanto, só Lista, Integer, Decimal, Boolean ou Data / Hora Propriedades de tipo de dados vão colorir. Os valores de propriedade para colunas de componentes anexados podem ser mostrando clicando com o título da coluna e selecionar Coluna | Mostrar Propriedades ... e, em seguida, a opção Mostrar imóvel. E, finalmente, onde existem Constrangimentos obrigatórios definido para uma coluna de propriedade estes podem ser mostrados com uma string (juntamente com corante, de acordo com seus níveis de execução) pelo botão direito do mouse no título da coluna e selecionar Coluna | Mostrar .

Catálogo

Para adicionar / mostrar as colunas para a Catálogo vista em ABACUS

1. Certifique-se de que você tem um Vista Catálogo aberto.

2. Colunas ocultas podem ser unhidden individualmente clicando no seta à direita do botão da barra de ferramentas Configurar Colunase seleccionando a coluna a partir de qualquer escondido Geral, Propriedades ou Anexos coleções.

Nota

Uma marca de seleção será exibida ao lado das colunas atualmente exibidos para o catálogo.Além disso, apenas certos anexos estarão disponíveis sob os Anexos seção de acordo com o restrições que são definidos em seu projeto. Em particular, para um anexo para estar disponível para ser mostrado em um catálogo de componentes do tipo de componente para o catálogo deve ser especificado como a origem ou afundar (não o 'Qualquer') restrição de uma "conexão deve ser anexado" para uma conexão tipo, e também deve haver pelo menos um tipo de componente especificado como a origem ou afundar (não o 'Qualquer') do outro "fim" do mesmo tipo de conexão.

- OU -

2. Várias colunas podem ser unhidden (ou ordenada ou fixo), clicando no Configurar barra de ferramentas botão Colunase usando as Configurar Colunas de diálogo mostrada abaixo.

Nota

As colunas exibidas atualmente são exibidos no painel à direita, com as colunas disponíveis mostrados no painel do lado esquerdo. As colunas disponíveis pode ser filtrada de acordo com o Selecione Colunas disponíveis A partirpull-down e eles podem ser adicionados, selecionando-os no painel à esquerda e clique no Adicionar botão inbetween os dois painéis.

Configurar diálogo Colunas

Para remover / ocultar colunas de um Catálogo vista em ABACUS

1. Certifique-se de que você tem um Vista Catálogo aberto.

2. Botão direito do mouse no cabeçalho da coluna para a coluna que você deseja remover / ocultar e selecione Coluna | Ocultar Coluna.

- OU -

2. Várias colunas podem ser escondidos (ou ordenada ou fixo), clicando no Configurar barra de ferramentas botão Colunase usando as Configurar Colunas diálogo mostrada acima.

Nota

As colunas exibidas atualmente são exibidos no painel à direita, com as colunas disponíveis mostrados no painel do lado esquerdo. As colunas exibidas atualmente podem estar ocultos, selecionando a coluna no painel à direita e clicando no Remover botão inbetween os dois painéis.

Para preencher usando um Catálogo vista em ABACUS

1. Para adicionar um ou componente conexãodo tipo seleccionado para a Catálogo (e no projeto), clique em Add New Componente / Adicionar botão New Connection barra de ferramentas. A linha deve aparecem e um ou componente conexão será criado no nível superior do Componentes ou Coleção Connections para a arquitectura escolhida.

Nota

Novos componentes e conexões são adicionados por padrão no nível superior dos componentes ou conexões coleção da arquitetura escolhida. Para alterar o pai dos novos componentes ou conexões botão direito do mouse na célula caminho de hierarquia para o novo componente ou conexões de linha e selecione Alterar Pai ...e escolher o pai desejado (tomando nota do realce de restrição ).

Nota

Novas linhas / elementos adicionados diretamente a um catálogo através do botão "Adicionar Novo", colado no catálogo, ou via importação criado para o catálogo a partir do MS Excel são isentos de filtragem até que o catálogo está fechado. Isto para permitir que qualquer edição necessária de valores de coluna que eventualmente não satisfaçam os critérios de filtragem actuais do catálogo. Estas novas linhas de elementos são indicados por um símbolo "+" na célula selector de linha no começo da linha, o qual é colorido verde se o elemento atende atualmente aos critérios de filtragem salvas do catálogo (ou seja, permanecerá no catálogo se re-aberto), e vermelho se isso não acontecer.

2. Para remover uma ou componente conexãodo tipo seleccionado a partir da a Catálogo (e no projeto), selecione a linha e quer pressionar a tecla Del ou clique com o botão direito do mouse no seletor de linha e selecione Excluir da Arquitetura. o fila deve desaparecer do catálogo e isso será excluído do projeto.

Para filtro usando um Catálogo vista em ABACUS

1. Certifique-se de que você tem um Vista Catálogo aberto.

2. Se a linha do filtro não está mostrando no topo do catálogo, em seguida, clique no Mostrar filtro linha de cabeçalhobotão da barra de ferramentas.

3. Na coluna que você gostaria de adicionar um filtro, clique duas vezes na célula de linha filtro onde ele mostra "(All) '.

4. Para Timestamp, caminho de hierarquia, Nome ou Descriçãocolunas gerais ou Texto, Integer, Decimal, Boolean ou Data horacolunas de propriedades, clique no botão ... que aparece na direita da célula linha de filtro e digite os valores das células que deveriam ser incluídos no catálogo.

Nota

Matching é realizada como se "*" curingas são automaticamente aplicados antes e depois de quaisquer valores de cadeia para que uma entrada de "gato" (sem as aspas) que incluem linhas com 'bobgato','gatomulher 'ou' appligatoion 'etc. Múltiplo /' ou 'valores podem ser introduzidos em novas linhas usando Ctrl + Enter. Para Integer e decimais colunas de propriedade "e" lógica podem ser incluídos usando '&"(Sem as aspas) e superior / inferior a lógica etc podem ser incluídos usando '> =','>','<' e '<="(Sem as aspas), por exemplo, > = 50000 & <90000 '. Não valorizados em branco linhas podem ser incluídos, digitando '(Non-Blanks)"(Sem as aspas) e linhas de valor em branco podem ser incluídas inserindo '(Blanks)"(Sem as aspas).E, finalmente, todos os filtros são de caso padrão insensível tão 'gato' (sem as aspas) que incluem linhas com 'gato', 'Cat' ou etc. 'CAT' Para o caso de correspondência sensível, digite '(Caso)"(Sem as aspas) antes da string, por exemplo, "(Case) Cat '(sem as aspas) só iria incluir linhas com' Cat 'neles.

5. Para Anexoscolunas, Padrões colunas ou Lista colunas de propriedades, clique no botão de seta para baixo que aparece na direita da célula linha de filtro e selecione os valores das células a partir das caixas de seleção que devem ser incluídos no catálogo.

Nota

A caixa de seleção "(Selecionar tudo) 'permitirá a todas as outras caixas de seleção, em efeito, incluindo todas as linhas disponíveis. A '(Non-Blanks) "caixa de seleção incluirão qualquer non-em branco linhas valorizados. A '(Blanks) "caixa de seleção incluirá quaisquer linhas em branco valorizado. E, finalmente, desmarcando quaisquer caixas específicas valorizado será automaticamente desmarque a '(Selecionar Todos) "e" (Non-Blanks)' caixas de consistência.

6. Clique Está bem para aplicar o filtro.

Para ativar / desativar a filtragem em a Catálogo vista em ABACUS

1. Certifique-se de que você tem um Vista Catálogo aberto com um filtro aplicado.

2. Clique na caixa de seleção à esquerda da linha de filtro.

Para remover um filtro a Catálogo vista em ABACUS

1. Certifique-se de que você tem um Vista Catálogo aberto com um filtro aplicado.

2. Para remover um filtro de coluna individual clique com o botão direito do mouse no cabeçalho da coluna e selecione Coluna | Limpar Filtering.

3. Para remover todos os filtros, clique no Opções botão da barra de ferramentas e selecione Limpar Configurações do Filtro.

Salvar / salvar como aVista Catálogo

Nota

Enquanto todos os usuários do arquiteto pode criar novos catálogos, para salvar as alterações nas configurações de um Catálogo existente licença de usuário precisa do Designer add-on capacidade. Isso é para "proteger" a configuração de Catálogos existentes que podem ser compartilhados por muitos usuários. No entanto, arquiteto usa sem a Designer complemento ainda pode optar por 'Salvar como' quaisquer novas configurações para um novo catálogo. E, claro, todas as licenças de usuário pode optar por «desfazer» quaisquer alterações em um catálogo existente. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar Designer add-on capacidade.E lembre-se, este é apenas as configurações do Catálogo, todas as edições feitas nos dados do catálogo são aplicadas imediatamente para o repositório, independentemente.

1. Certifique-se que você tem um novo ou exibição de catálogo existente abertoe você fez as mudanças necessárias.

2. no Vista Catálogoclique na barra de ferramentas Guardarbotão para salvar o Vista Catálogo e as alterações de formatação.

Nota

Se você não tem um botão Salvar na barra de ferramentas Catálogo de vista, em seguida, você não tem o Designer add-on e você só são capazes de Salvar comoquaisquer definições muda para um novo catálogo quando você vai para fechar o catálogo existente.

3. E se a Catálogo Nomediálogo aparece (devido a ser um novo catálogo) digite um nome para o catálogo e pressione Está bem.

Para exportação para MS Excel catálogo

1. Certifique-se de que você tem um Vista Catálogo aberto.

2. Clique no Exportar para planilha Excel Catálogobotão da barra de ferramentas.

3. Escolha um nome de arquivo para salvar o catálogo MS Excel como. Clique Guardar.

Nota

Por padrão nome do arquivo do catálogo MS Excel exportada será o nome de catálogo com o sufixo o nome Architecture entre parênteses, por exemplo, "Projetos (2014 Real) .xlsx '. Você pode mudar nada disso, inclusive se o formato do arquivo é para ser .xlsx ou .xls. O nome de Arquitetura está incluído para lembrar o usuário de que cada catálogo tem conteúdo específico (ou seja, IDs na coluna A e linha 1) para permitir que ele seja round-tropeçou novamente usando Importar do catálogo MS Excel conforme abaixo.

Nota

Por padrão, a coluna oculta Um dentro do catálogo MS Excel exportado contém a identificação única para cada um dos elementos no repositório ABACUS. Isso permite que quaisquer alterações que são feitas no prazo de MS Excel para ser "compensada" com os elementos existentes dentro ABACUS de importação (ver abaixo). No entanto, a utilização desta identificação única para "igualar-se" linhas podem ser substituídas com um Externo | Identidadepropriedade no elemento. Isto é, se o elemento tem um externo | ID da propriedade e está incluída no catálogo de exportação, em seguida, os valores da Externo | Coluna ID será usado para igualar-se as linhas de importação (ver abaixo) e os valores de ID exclusivos na coluna escondida Um será ignorada (e pode até mesmo ser em branco). A coluna oculta A própria deve permanecer, no entanto, em particular, o valor na célula A1. Além disso, quando a adição de ID de externos para uma coleção elemento ABACUS existente recomendamos adicionando-a como uma propriedade diferente em primeiro lugar, por exemplo, Externo | Temp e, em seguida, mudar o nome da propriedade para Externo | ID. Caso contrário, serão adicionados elementos duplicados.

Formatação de catálogoé exportado por padrão, no entanto, para grandes catálogos isso pode resultar na exportação de ser bastante lento. Por conseguinte, em Ferramentas | Opções ... Em seguida a Catálogotab,você é capaz de reduzir a quantidade de formatação que é exportado como mostrado na guia Catálogo abaixo, acelerando assim a exportação.

Exportação Catálogo Opções

4. Uma caixa de diálogo Exportação Concluída é exibida. Clique Está bem.

Exportado para catálogo MS Excel

Para importação de catálogo MS Excel

Nota

Por padrão, a coluna oculta Um dentro do catálogo MS Excel exportado (ver acima) contém a identificação única para cada um dos elementos no repositório ABACUS. Isso permite que quaisquer alterações que são feitas no prazo de MS Excel para ser "compensada" com os elementos existentes dentro ABACUS sobre a importação. No entanto, a utilização desta identificação única para "igualar-se" linhas podem ser substituídas com um Externo | Identidadepropriedade no elemento. Isto é, se o elemento tem um externo | ID da propriedade e está incluída no catálogo de exportação (ver acima), então os valores da Externo | Coluna ID será usado para igualar-se as linhas de importação e os valores ID exclusivos na coluna escondida Um será ignorada (e pode até mesmo ser em branco). A coluna oculta A própria deve permanecer, no entanto, em particular, o valor na célula A1. Além disso, quando a adição de ID de externos para uma coleção elemento ABACUS existente recomendamos adicionando-a como uma propriedade diferente em primeiro lugar, por exemplo, Externo | Temp e, em seguida, mudar o nome da propriedade para Externo | ID. Caso contrário, serão adicionados elementos duplicados.

1. Certifique-se de que você tem um Vista Catálogo aberto.

2. Clique no Importar do Catálogo planilha Excelbotão da barra de ferramentas.

3. Escolha um nome de arquivo para importar o catálogo MS Excel a partir. Clique Aberto.

4. Novos erros detectados e / ou novos erros / avisos detectado diálogos podem aparecer por qualquer conteúdo novo (ou seja, linhas na MS Excel) que foi adicionado. Tome nota dos erros / avisos e clique Está bem.

5. Uma caixa de diálogo Importação Concluída é exibido e pode mostrar avisos devido à importação (veja notas abaixo). Clique Está bem.

Nota

Para as colunas de componentes Standards subordinadas ou vinculadas, novas entradas através do catálogo MS Excel deve corresponder exatamente ao nome de uma norma existente ou componentes do tipo correto para a cessão ou conexão a ser adicionado. O primeiro jogo chamado será usado e nenhuma entrada incomparáveis ​​irá gerar um aviso conforme abaixo. Além disso, enquanto os avisos são emitidos em re-importação, são elementos não excluídade ABACUS se eles não estiverem presentes no catálogo MS Excel. Isso ocorre porque não há nenhuma maneira que ABACUS pode saber se o componente atribuído Standard ou anexado existe no projeto ABACUS mas não existe no catálogo MS Excel porque ele foi excluído do catálogo MS Excel ou que tenha sido adicionado à ABACUS projeto desde o catálogo foi exportado. Assim, se os usuários desejam facilmente 'detectar' que as ligações foram adicionados durante o processo de importação podem simplesmente criar uma propriedade necessária sobre o tipo de conexão e definir é padrão para a placa de modo que eles vão ser avisado de quaisquer novas conexões cada vez que a importação está completo.

Nota

Ao importar um catálogo MS Excel vários avisos podem ser exibidos. Em primeiro lugar, se uma nova coluna foi adicionada ao Excel que não coincide com o 'sintaxe' para uma propriedade ou um componente ligado a coluna será ignorado. Em seguida, avisos linha por linha será exibido para quaisquer problemas com os dados de cada linha do catálogo Excel. Estes avisos começam com o número da linha entre colchetes e, se relevante no rótulo da coluna (ou seja, "[23, J] ... 'para a linha 23, coluna J) e pode se referir a itens excluídos, padrões inigualáveis ​​ou nomes de componentes ligados (que são ignorados conforme nota acima) ou um ID inválido ou em branco, relativa a uma nova linha / elemento (que será adicionado). Para um artigo detalhado sobre o preenchimento ABACUS usando catálogos Excel, consulte o Avolution Comunidade ou o curso de formação Portfolio Manager.

Nota

Novos componentes e conexões são adicionados por padrão no nível superior dos componentes ou conexões coleção da arquitetura escolhida. Para alterar o pai dos novos componentes ou conexões botão direito do mouse na célula caminho de hierarquia para o novo componente ou conexões de linha e selecione Alterar Pai ...e escolher o pai desejado (tomando nota do realce de restrição ).

Nota

Elementos adicionado diretamente a um catálogo através do botão "Adicionar Novo", colado no catálogo, ou via importação criado para o catálogo a partir do MS Excel são isentos de filtragem até que o catálogo está fechado. Isto para permitir que qualquer edição necessária de valores de coluna que eventualmente não satisfaçam os critérios de filtragem actuais do catálogo. Estas novas linhas de elementos são indicados por um símbolo "+" na célula selector de linha no começo da linha, o qual é colorido verde se o elemento atende atualmente aos critérios de filtragem salvas do catálogo (ou seja, permanecerá no catálogo se re-aberto), e vermelho se isso não acontecer.

Para comparar o conteúdo de um catálogo com outra arquitetura

1. Por favor, consulte o tópico Aqui .

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Preenchendo a arquitetura a partir do Visio | Preenchendo a arquitetura a partir do Excel


Preenchendo usando Matrizes

Navegação: Preenchendo sua arquitetura>

Preenchendo usando Matrizes

Envie seus comentários neste tópico.

A matriz permite que você visualize e edite o "direta" conexões entre os componentes de uma forma tabular simplese para ver também o "caminho indirecto» entre os componentes de acordo com quaisquer componentes intermediários (e conexões).

Para crio uma visão Matrix em ABACUS

Nota

Enquanto todos os usuários do arquiteto pode criar matrizes para salvá-los e / ou suas configurações de as licença de usuário precisa do Designer add-on capacidade. Isso é para "proteger" a configuração de matrizes existentes que podem ser compartilhados por muitos usuários. No entanto, arquiteto usa sem a Designer add-on pode ainda optar por 'Salvar como' quaisquer novas configurações para um novo Matrix. E, claro, todas as licenças de usuário pode optar por «desfazer» quaisquer alterações a uma matriz existente. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

1. Selecione Insert | Matriz.

2. no rchitecturE>pull-down, selecione a arquitetura que contém os componentes e conexões que você deseja ver.

3. no <FonteDigite>pull-down selecionar o tipo de componente que você deseja ter as instâncias listados como 'linhas' pela esquerdada matriz.

4. no <LavatórioDigite>pull-down selecionar o tipo de componente que você deseja ter as instâncias listados como 'colunas' ao longo do topoda matriz.

5. no Puxar para baixo existem essencialmente dois "modos" de matriz você pode definir ...

Conexões "direta" matrizes

6. Simplesmente seleger um (1) ou mais conexão tipos no lado direito do menu que aparece se que você deseja ver nos "células" da matriz se umn explícitaconexão existe a partir do Vertical/ 'fila'Componente da matriz para o Horizontal/ 'coluna'Componente da matriz.

Nota

Apenas as conexões com a fonte extremidade ligada ao Vertical/ 'fila'End componente e pia em anexo ao Horizontal/ 'coluna«Componente será exibida. Alterne o Fonte e Lavatórioas seleções de tipo de componente para ver as conexões na direção oposta.

7. A matriz será preenchido com um 'X' nas células (ou um valor de propriedade - ver nota abaixo) Se existe uma ligação a partir do Vertical/ 'fila'componente da matriz para o Horizontal/ 'coluna'Componente da matriz.

Nota

Para grandes matrizes de apenas um máximo de 100 linhas ou colunas (incluindo desabaram linhas / colunas) será mostrada em um momento como mostrado pela 'R' e indicadores 'C' na célula do cabeçalho superior esquerdo, respectivamente. Para exibir linhas adicionais usar as barras de rolagem. A qualquer momento você pode clicar duas vezes sobre o Vertical/ 'fila' ou Horizontal / 'coluna' componente rubricas e pule paraos componentes correspondentes na janela do Explorer.Os pais da Vertical/ 'fila' e Horizontal/ 'coluna' componentes também são opcionalmente mostrado como título linhas / colunas com um título cinza título. Quando entrou em colapso (clicando única célula rubrica) se crianças anexos existia então um 'X' irá, opcionalmente, ser apresentada, se todas as crianças foram anexados ou um 'O' irá, opcionalmente, ser apresentada, se apenas algumas das crianças foram anexados. As células podem ser colori de acordo com um valor de propriedade das conexões clicando no Options 'roda de engrenagem' no canto superior direito da barra de ferramentas matriz e selecionando Definições de cor ... e, em seguida, no botão Editar e selecionando a cor por Timestamp ou Colour By Property opção e escolher a propriedade, a faixa de valores mínimo e máximo e escolher as cores, no entanto, só Lista, Integer, Decimal, Boolean ou Data / Hora Propriedades de tipo de dados vão colorir. Se entrou em colapso na célula vai ser colorido de acordo com o valor médio estabelecimento das ligações. Em vez de um "X", os valores de propriedade para as células podem ser mostrando clicando no Options 'roda de engrenagem' no canto superior direito da barra de ferramentas matriz e selecionando Mostrar configurações Valor ... e depois no botão Editar e selecionando a opção Mostrar propriedade e escolher um imóvel.

As conexões diretas matriz mostrando os servidores onde estão hospedados Aplicações com coloração e uma propriedade que está sendo mostrado em vez do genérico 'X'

- OU -

Conexões «indirecta» matrizes

6. Selegeruma sequência de conexão tipos e tipos de componentesno lado direito e esquerdo do menu que aparece se que você deseja ver nos "células" da matriz se umN caminho indirecto de componentes ligadosexistem desde o Vertical/ 'fila'Componente da matriz para o Horizontal/ 'coluna'Componente da matriz.

Nota

Qualquer caminho válido que inclui os elementos selecionados no menu caminho wdoente ser mostradoindependentemente do sentido de as ligações subjacentes, no entanto, quando se selecciona o caminho a primeiro e últimos elementos deve ser selecionado tipos de conexão. Além disso, o ordem dos elementos que foram seleccionadas é mostrado com um prefixo numéricoem quadrado ('[]') suportes e um determinado tipo pode ser incluído vezes mutlipleno percurso (como indicado pelo prefixo numérico). Seleção consecutiva de tipos de componente ou tipos de conexão é interpretado como um 'OU'caminho ea hierarquia de componentes ligados podem ser incluídos como opção, verificando o 'Procure também por pais / filhos de anexoCaixa 'cheque. Alterne o Fonte e Lavatórioas seleções de tipo de componente para ver o caminhos no sentido oposto.

7. A matriz será preenchida com umpath / coleção de componentesnas células se houver uma caminho de Vertical/ 'fila'componente da matriz para o Horizontal/ 'coluna'Componente da matriz.

Nota

Para grandes matrizes de apenas um máximo de 100 linhas ou colunas (incluindo desabaram linhas / colunas) será mostrada em um momento como mostrado pela 'R' e indicadores 'C' na célula do cabeçalho superior esquerdo, respectivamente. Para exibir linhas adicionais usar as barras de rolagem. A qualquer momento você pode clicar duas vezes sobre o Vertical/ 'fila' ou Horizontal / 'coluna' componente rubricas e pule paraos componentes correspondentes na janela do Explorer.Os pais da Vertical/ 'fila' e Horizontal/ 'coluna' componentes também são opcionalmente mostrado como título linhas / colunas com um título cinza título. Quando entrou em colapso (clicando única célula rubrica) se quaisquer crianças caminhos existia então um 'X' irá, opcionalmente, ser apresentada, se todas as crianças foram anexados ou um 'O' irá, opcionalmente, ser apresentada, se apenas algumas das crianças tinham caminhos. Os componentes do caminho indiretos pode ser colori de acordo com um valor de propriedade dos componentes clicando no Options 'roda de engrenagem' no canto superior direito da barra de ferramentas matriz e selecionando Definições de cor ... e, em seguida, no botão Editar e selecionando a cor por Timestamp ou Colour By Property opção e escolher a propriedade, a faixa de valores mínimo e máximo e escolher as cores, no entanto, só Lista, Integer, Decimal, Boolean ou Data / Hora Propriedades de tipo de dados vão colorir. Os valores de propriedade para os componentes do caminho indiretos pode ser mostrando clicando no Options 'roda de engrenagem' no canto superior direito da barra de ferramentas matriz e selecionando Mostrar configurações Valor ... e depois no botão Editar e selecionando a opção Mostrar propriedade e escolher um imóvel.

Matriz de conexões indiretas que mostra os aplicativos que implementam um determinado serviço por Departamento

Para filtrouma visão Matrix em ABACUS

1. Certifique-se que você tem um novo Ver Matrix aberto.

2. Clique no filtro Machados 'funil' no canto superior direito da barra de ferramentas matriz.

3. Na Fonte e / ou as guias de Pia adicione o nome, a propriedade, Descrição, hierarquia ou filtros padrão clicando no botão Adicionar, a seleção de uma propriedade se necessário, e clique Está bem. Selecione as opções relevantes no painel Palavras-chave / Artigos usando a lógica / sintaxe como descrito na nota abaixo. O painel de visualização é atualizada automaticamente para mostrar os resultados do actual conjunto de filtros.

Nota

Para Timestamp, caminho de hierarquia, Nome ou Descriçãoou filtros Texto, Integer, Decimal, Boolean ou Data horafiltros de propriedade correspondente será executado como se "*" curingas são automaticamente aplicados antes e depois de quaisquer valores de cadeia para que uma entrada de "gato" (sem as aspas) que incluem linhas com 'bobgato','gatomulher 'ou' appligatoion 'etc. Múltiplo /' ou 'valores podem ser introduzidos em novas linhas usando Ctrl + Enter. Para Número inteiro e Decimal filtros de propriedade "e" lógica podem ser incluídos usando '&"(Sem as aspas) e superior / inferior a lógica etc podem ser incluídos usando '> =','>','<' e '<="(Sem as aspas), por exemplo, > = 50000 & <90000 '. Não valorizados em branco linhas podem ser incluídos, digitando '(Non-Blanks)"(Sem as aspas) e linhas de valor em branco podem ser incluídas inserindo '(Blanks)"(Sem as aspas). Para Padrões ou Lista propriedade filtra A caixa de seleção "(Selecionar tudo) 'permitirá a todas as outras caixas de seleção, em efeito, incluindo todos os elementos disponíveis. A '(Non-Blanks) "caixa de seleção incluirá quaisquer elementos de propriedade não-branco valorizado. A '(Blanks) "caixa de seleção incluirão qualquer propriedade em branco elementos avaliados. E desmarcar quaisquer caixas específicas valorizado automaticamente desmarque as '(Selecionar tudo) "e" (-Blanks não)' caixas de consistência. E, finalmente, todos os filtros são de caso padrão insensível tão 'gato' (sem as aspas) incluiria elementos com 'gato', 'Cat' ou etc. 'CAT' Para o caso de correspondência sensível, digite '(Caso)"(Sem as aspas) antes da string, por exemplo, "(Case) Cat '(sem as aspas) só iria incluir elementos com' Cat 'neles.

Para preencher usando uma exibição de Matrix no ABACUS

Nota

Você só pode adicionar / remover conexões onde um único tipo de conexão tem sido usado para o caminho descrito acima.

1. Para adicionar uma conexãodo tipo seleccionado entre um Vertical/ 'fila'Componente e um Horizontal/ 'coluna'Componente da matriz, onde um' X 'já não existe(ou um valor de propriedade mostrado - ver nota acima), Dê um duplo clique na célula. Um 'X' deve aparecer (ou um valor de propriedade - ver nota acima) e uma conexão será criada no nível superior do conjunto de conexões para a arquitectura escolhida.

Nota

O nome da conexão será a nome do tipo de conexão de acordo com a configuração do tipo de ligação da matriz e se um valor de propriedade está sendo mostrado em vez de um 'X' o valor padrão para a propriedade será mostrado.

2. Para editar um valor de propriedade mostradosna conexão entre a Vertical/ 'fila'Componente e um Horizontal/ 'coluna'Componente da matriz, Dê um duplo clique na célula, ou clique direito do mouse na célula e selecione Editar valor ... e editar o valor na caixa de diálogo Alterar Valor.

3. Para remover uma conexãodo tipo seleccionado entre um Vertical/ 'fila'Componente e um Horizontal/ 'coluna'O componente de matriz, em que um "já existe X'(ou um valor de propriedade mostrado - ver nota acima), certo-clique na célulae selecione Desconectar. O X deve desaparecer ea conexão será excluído do projeto.

Salvar / salvar como aVer Matrix

Nota

Enquanto todos os usuários do arquiteto pode criar matrizes para salvá-los e / ou suas configurações de as licença de usuário precisa do Designer add-on capacidade. Isso é para "proteger" a configuração de matrizes existentes que podem ser compartilhados por muitos usuários. No entanto, arquiteto usa sem a Designer add-on pode ainda optar por 'Salvar como' quaisquer novas configurações para um novo Matrix. E, claro, todas as licenças de usuário pode optar por «desfazer» quaisquer alterações a uma matriz existente. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar Designer add-on capacidade.E lembre-se, este é apenas as configurações da Matrix, todas as edições feitas nos dados na Matriz são aplicadas imediatamente para o repositório, independentemente.

1. Certifique-se que você tem um novo Ver Matrix abertoe você fez as mudanças necessárias.

2. no Ver Matrixclique na barra de ferramentas à esquerda Guardar Matrizbotão para salvar o Ver Matrix e as alterações de formatação.

Nota

Se você não tem um botão Salvar na barra de ferramentas ver Matrix, em seguida, você não tem o Designer add-on e você só são capazes de Salvar comoquaisquer definições muda para uma nova matriz quando você vai para fechar a matriz existente.

3. E se a Matriz Nomediálogo que aparece (devido a ser uma nova matriz) digite um nome para o matrize pressione Está bem.

Para exportação para MS Excel matriz

1. Certifique-se de que você tem um Ver Matrix aberto.

2. Clique no Exportar para Excelbotão da barra de ferramentas.

3. Escolha um nome de arquivo para salvar a matriz de MS Excel como. Clique Guardar.

Nota

Por padrão nome de arquivo da matriz MS Excel exportada será o nome Matrix sufixo o nome Architecture entre parênteses, por exemplo, 'Aplicativos hospedados em servidores (2014 Real) .xlsx'. Você pode mudar nada disso, inclusive se o formato do arquivo é para ser .xlsx ou .xls.

Formatação Matrixé exportado por padrão, no entanto, para grandes matrizes isso pode resultar na exportação de ser bastante lento. Por conseguinte, em Ferramentas | Opções ... Em seguida a Matriztab,você é capaz de reduzir a quantidade de formatação que é exportado como mostrado na guia Matrix abaixo, acelerando assim a exportação.

Exportação Matrix Opções

4. Uma caixa de diálogo Exportação Concluída é exibida. Clique Está bem.

Exportados para a matriz MS Excel

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Preenchendo a arquitetura a partir do Visio | Preenchendo a arquitetura a partir do Excel


Preenchendo a arquitetura do Microsoft Access

Navegação: Preenchendo seu Arquitectura> Preencher a partir de produtos da Microsoft>

Preenchendo a arquitetura do Microsoft Access

Envie seus comentários neste tópico.

Você pode exportar sua arquitetura para o Microsoft Access para executar cálculos de uso geral, manipulações ou relatórios da sua arquitetura. Você pode então importar a arquitetura de volta para ABACUS.

Nota

O recurso Aberto de Acesso / Exportar para banco de dados requer que Microsoft Access 2000ou mais novo é instalado no computador.

Para exportar sua arquitetura para o Microsoft Access

1. Verifique se você tem um Arquivo ABACUS abra a Exploradorexibida, e um arquiteturaadicionado.

2. Selecione Arquivo | Exportar | Para Banco de Dados.

3. Tome nota do diálogo de aviso, como descrito acima e clique em Sim para continuar.

4. Selecione um local e nome de arquivo para o arquivo de banco de dados.

Para importar a arquitetura manipulado em ABACUS

1. Verifique se você tem ABACUS aberto.

2. Selecione Arquivo | Novo e selecione A partir de Acessona caixa de diálogo que aparece e clique em OK.

3. Procure o arquivo de banco de dados que deseja importar.

Database Schema MS Access ABACUS '

ABACUS tem no seu cerne uman ontologia / meta-meta-modelo composta de componentes, Conexões e Restrições. Esta abordagem "CCC" foi derivado de várias abordagens padrão desenvolvidas a partir da década de 1960 em diante, culminando em padrão internacional IEEE 1471, que os fundadores da Avolution contribuiu para. Os seguintes primitivas de aplicar;

1. ÁBACO contém Bibliotecas de Padrões(ou Standards), Componente e Tipos de conexão, Restrições, Pontos de Vista, Modelos (ou Padrões) e muitos Arquiteturas.

2. Padrões, Tipos e Pontos de Vista maioser logicamente Agrupados Por conveniência.

3. Arquiteturas pode contermuitos descendente Arquiteturas(ou Evolutions).

4. Cada Arquitetura contém muitos Componentes e Conexõesde certos Tipose várias Visualizações.

5. Componentes e Conexões pode ser decomposto para dentro Sub-Components e Sub-Conexões.

6. Cada Componente é anexado aqualquer número de Conexõesmas cada Conexãosó pode ser anexado aum máximo de dois Componentes.

7. Componentes e Conexões podem ter Padrões com Propriedadescomo Informações, desempenho, confiabilidade, custo etc.

8. Arquiteturas, Componentes e Conexões podem ter específico Propriedadescomo Informações, desempenho, confiabilidade, custo etc.

9. Restrições podem existir entre Componentes ou Conexões ou contra Propriedades.

10. Modelossão composições padrão de Componente e Tipos de conexão.

11. Pontos de Vistasão associações de padrão Componente e Tipos de conexãopara anotações.

12. Visualizaçõessão representações visuais de Componentes e Conexões.

A seguir Entidade MS Access relacionamento Diagrama (ERD) documenta a testemunhoArquiteturas, Evolutions, Tipos de componentes / Conexão (e grupos), Componentes / Conexões e conceitos Sub componente / Conexão.

O esquema do banco central

Nota

A integridade referencial não foi aplicado sobre a relação entre a tabela de Componentes ea tabela Conexões (para o 'anexo' entre uma dada origem ou de componentes da pia e uma Connection). Isso é porque uma ligação pode existir sem anexos componentes. Nós poderíamos ter adicionado uma tabela 'anexo', mas no interesse da simplicidade decidiu contra isso. Claro que isso significa que qualquer edição de IDs de componentes ou exclusão de linhas de componentes todos juntos vai resultar em dados incorretos. ABACUS vai lidar com qualquer incorreção na importação, ignorando os dados incorretos.

A seguir MS Access ERD documenta a Propriedadesconceitos para Arquitecturas, tipos de componentes / conexão e Componentes / Connections.

Propriedades esquema de banco

A seguir MS Access ERD documenta a Padrõesconceito para Arquitecturas, tipos de componentes / conexão e Componentes / Connections.Nota: Os quadros ainda usam o termo 'Implementação' como por versões anteriores do ABACUS.

Esquema de banco de Normas

A seguir MS Access ERD documenta a Restriçõesconceito para o componente Tipos / Conexão.

Restriçõesesquema de banco

A seguir MS Access ERD documenta a Pontos de Vista para conceito Arquiteturas.Nota: Os quadros ainda usam o termo 'TwoDTempl' como por versões anteriores do ABACUS.

Pontos de Vistaesquema de banco

A seguir MS Access ERD documenta a Catálogospara conceito Arquiteturas.

Catálogosesquema de banco

A seguir MS Access ERD documenta a Matrizespara conceito Arquiteturas.

Matrizesesquema de banco

A seguir MS Access ERD documenta a Diagramaspara conceito Arquiteturas.Nota: Os quadros ainda usam o termo 'TwoD' como por versões anteriores do ABACUS.

Nota

O tipo de componente / Conexão com estêncil mapeamento forma e porções forma livre do MS Access ERD foram omitidos para maior clareza.

Diagramasesquema de banco

A seguir MS Access ERD documenta a Vistas 3Dpara conceito Arquiteturas.

Vistas 3Desquema de banco

A seguir MS Access ERD documenta a Chartspara conceito Arquiteturas.

Chartsesquema de banco

A seguir MS Access ERD documenta a Dashboards conceito.

Dashboardsesquema de banco

ABACUS 'MS AccessConsultas

Incluído com o banco de dados MS Access são várias consultas úteis como se segue;

· Compensações por Props- Esta consulta lista todos os componentes do projeto (por arquitetura e tipo) e inclui todas as propriedades como colunas. Usar essa consulta com filtros / critérios do tipo de componente e / ou arquitetura para produzir tabelas "típicos" para cada tipo de componente com suas propriedades.

· Stds por Props- Esta consulta lista todas as normas que estão em uso, o número de ocorrências do padrão e inclui todas as propriedades como colunas. Use essa consulta como um catálogo de normas.

· Props por Tipos- Esta consulta lista todas as propriedades do componente e sua% concluída por cada tipo de componente como colunas. Use esta consulta para determinar se as propriedades específicas estão sendo mantidos.

· Tipos de Props- Esta consulta lista todos os tipos de componentes e inclui a% total de todas as propriedades como colunas. Use esta consulta para determinar se as propriedades específicas estão sendo mantidos.

· Contagem tipo- Esta consulta lista todos os tipos de componentes e inclui o número de ocorrências de cada tipo em ordem decrescente. Use esta consulta para determinar a popularidade de cada tipo no projeto.

Uma nota sobre como trabalhar com campos de memorando em MS Access

Os componentes, Conexões e campos Nome Standards nas tabelas são definidos como campos de memorando para permitir um número ilimitado de personagens, como por ABACUS. Para os Componentes e Conexões isso causa alguns problemas, porque eles também têm um campo de identificação exclusivo para referência, mas para as Normas isso causa alguns problemas ao tentar unir tabelas porque você não pode juntar-se campos de memorando em MS Access. Como alternativa, você pode definir um WHERE cláusula critérios para conseguir o mesmo efeito como mostrado no Visual Query Builder e correspondente trechos SQL abaixo essa lista fora todo o Normas herdadas Propriedades para todos os componentes do projeto ABACUS exportados.

Campo Memo 'junta' em Visual Query Builder

SELECIONE Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

A partir de componentes INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) E (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Implementações INNER JOIN ON ImplementationProperties Implementations.Id = ImplementationProperties.Implementation_Id

WHERE (((ComponentImplementationLinks.Name) = [Implementações] [Name]).);

Campo Memo 'junta' em SQL

Uma nota sobre a geração automática de IDs ABACUS em MS Access

Várias mesas ABACUS MS Access requerem um ID único inteiro longo para que um método simples VB é fornecido para auxiliar na geração destes. Dois métodos ResetCounter () e GetNextCounter () são fornecidos no prazo de ABACUS 'MS Access DB ea sua utilização é a seguinte; ResetCounter () irá definir o contador volta a 0. GetNextCounter () irá retornar o próximo contador na seqüência.

Os métodos de explorar um Access MS 'truque' que, mesmo se você chamar o método ResetCounter () para cada inserção linha (ou seja, quando você também executar a função GetNextCounter ()) porque a função ResetCounter () não tem nenhum parâmetro ele apenas corre -lo uma vez e, portanto, não repõe o contador para cada inserção linha. E também por causa do mesmo 'capricho' você tem que passar qualquer variável da coluna de idade para a função GetNextCounter () para enganá-lo a correr cada vez.

Há também um truque para ser capaz de executar a função ResetCounter () em uma inserção na instrução SQL porque você não pode apenas tê-lo sentado lá como uma coluna por conta própria, como se fosse uma consulta seleção. Recomenda-se fazer o ResetCounter () parte chamada de um dos outros campos, concatenando-lo até o fim, como sempre retorna null qualquer maneira.

Abaixo está uma utilização SQL típico dos métodos para adicionar uma lista de tipos de componentes de uma tabela / consulta chamado 'tipo de componente List'.

INSIRA DENTRO DEComponentTypes (Id, nome, descrição)

SELECIONAR GetNextCounter ([Tipo de componente List] .name)AS Id, [Tipo de componente List] .name como o nome, [tipo de componente List] .Descrição & ResetCounter ()AS Descrição

A PARTIR DA[Tipo de componente List];

ABACUS ID geração / Contador em SQL

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Preenchendo a arquitetura a partir do Visio | Preenchendo a arquitetura a partir do Excel


Preenchendo a arquitetura do Microsoft Visio

Navegação: Preenchendo seu Arquitectura> Preencher a partir de produtos da Microsoft>

Preenchendo a arquitetura do Microsoft Visio

Envie seus comentários neste tópico.

Você pode importar sua arquitetura a partir do Microsoft Visio. Formas no desenho do Visio serão importadas como componentes em ABACUS. Conexões no desenho do Visio serão importados como ligações e do próprio desenho será importado para ABACUS como um diagrama. Além disso, quaisquer propriedades personalizadas no desenho do Visio serão importadas como propriedades, com a chave de classificação mapeado para o tipo de propriedade, Etiqueta para o nome da propriedade eo valor para o valor do imóvel.

Nota

O recurso Importar do Visio requer que Microsoft Visio 2003ou mais novo é instalado no computador.

Para importar os desenhos do Visio em ABACUS

1. Verifique se você tem ABACUS aberto.

2. Selecione Arquivo | Novo e selecione A partir de Visiona caixa de diálogo que aparece e clique em OK.

Nota

Se você deseja importar para um projeto existente ABACUS em seguida, clique com botão direito do mouse no nó de componentes dentro de uma arquitetura, ou botão direito do mouse um componente individual dentro de uma Arquitetura e selecione Import | A partir de Visio.

3. Procure o arquivo Visio que você deseja importar.

Nota

Abaixo estão algumas regras simples e práticas recomendadas ao construir (ou modificar) a MS Visio desenho para importação para ABACUS.

1. As linhas ou conexões precisam ser conectores real, não formas.

· Caso contrário ABACUS só vai importá-los como componentes e, portanto, eles não vão ser "ligado" para qualquer coisa.

· Se você precisar fazer algum roteamento "inteligente" (ou seja, que não seja uma linha reta), então use o conector dinâmico no estêncil Formas básicas, ABACUS irá importar os pontos de roteamento / âncora bem.

· Tente evitar o uso da "rede Ring" e formas "Ethernet" da Rede e Periféricos estêncil que permite lotes de componentes para ser "ligado" a ele. Enquanto nós importamos os anexos bem como ligações a forma original ainda está "expandido" para refletir os anexos. Use separar um separado "hub / bus" forma (sem o conector "pernas") e, em seguida, conectar-se explicitamente cada componente para o hub / bus com conectores separados.

· Se uma linha ou conexão comporta-se como uma forma, clique direito sobre ele e vá para 'Format | Comportamento ... 'e certifique-se que o estilo de interação está definido para Line (1-dimensional).

2. Os componentes precisam estar NÃO formas conectores.

· Caso contrário ABACUS só vai importá-los como conexões e, consequentemente, toda a informação da forma será perdido.

· Se um componente se comporta como um conector, clique direito sobre ele e vá para 'Format | Comportamento ... 'e certifique-se que o estilo de interação está definido para Box (2-dimensional).

3. Extremidades do conector precisa ser anexado às formas, não flutuando no fundo atrás da forma.

· Se você não ligar os conectores para as formas então ABACUS tem nenhuma maneira de saber que você pretende anexar o conector dado ao / componente forma e consequentemente ele vai deixar que extremidade da conexão anexado-un.

4. Etiquetas para formas deve ser (sempre que possível) o rótulo de texto embutido para a forma, não uma caixa de texto em separado no desenho.

· Caixas de texto separadas vai se importado por ABACUS como componentes em seu próprio direito e, enquanto você pode mesclar o componente "label" com o componente real no ABACUS, ou apenas converter o componente "label" para uma forma livre (ou seja, não um componente em si) é melhor evitar estes passos.

5. Use a mesma forma de base para cada instância do mesmo tipo, não seja preguiçoso e usar rectângulo, por vezes, e caixa de outros de diferentes stencils forma.

· ABACUS usa a forma de base e sua cor de base para identificar os tipos de componentes e de ligação no desenho de modo a "retângulo vermelho" e uma "caixa vermelha" vai se importado como dois tipos de componentes separados. Estes tipos de componentes podem ser mescladas em ABACUS, mas é melhor evitar estes passos.

6. Totalmente encapsular "crianças" formas dentro de seus "pais", NÃO deixá-los pendurados sobre a borda.

· ABACUS irá detectar qualquer forma que é totalmente encapsulado dentro de outra forma como uma criança do pai para se certificar de toda a forma, incluindo a parte do rótulo, é fechado.

7. NÃO posicione uma forma sobreposição duas outras formas.

· Se uma forma sobrepõe duas outras formas, seja ele um "agrupamento" / fundo retângulo ou caso contrário, ele será importado por ABACUS como um componente que é um filho de nem formas sobrepostas, mas logo que você selecione o componente na ferramenta de desenho ABACUS ' , devido à superior esquerdo sendo os componentes de ponto de referência, ele vai se tornar um filho da esquerda sobreposta forma / componente.

8. Tente minimizar o uso de notas de texto no desenho, porque estes vão se importado como componentes em seu próprio direito e terá de ser convertida em formas livres em ABACUS. Pense se eles são realmente o nome de um componente ou conexão existente.

9. Enquanto ABACUS suporta rico / formas coloridas / baseados em vetores, tentar minimizar o uso de bitmaps, formas estrangeiras e metarquivos avançados para as formas como ABACUS atualmente faznãoapoiar estes tipos. Eles serão importadas como retângulos brancos simples.

10. Tente evitar retornos de carro (shift-return) em rótulos como eles são importados e mostrado como um caractere especial "[]" em ABACUS para o nome do componente.

11. Tentar minimizar as diferentes cores que são usadas para as formas do mesmo tipo. Como mencionado acima, cor de base e base de forma identifica exclusivamente componentes de conexão e tipos de modo que o mais variação não é o mais fusão e consolidação que terá de ser feito pós-importação no ABACUS.

12. Tenha cuidado com formas preenchidas porque se uma forma é preenchido todo o caminho para os cantos, em seguida, colori-lo mais tarde no ABACUS não terá nenhum efeito.

13. Para formas baseado em linha complexas você deve usar um polígono que é criado por ter linhas começando onde o anterior termina e, em seguida, em última análise, vai voltar para o ponto de início. Se desejar, você pode usar o preenchimento e linha largura para fazer o olhar do polígono como uma "seta" ou qualquer forma que você quiser.

14. Verifique se o ID formas em MS Visio é significativo não apenas Shape.xx. Este é editável usando botão direito do mouse 'Show Shapesheet ", que está disponível no modo de desenvolvedor MS Visio (ativado através Ferramentas | Opções em MS Visio).

15. Elipses e arcosdentro das formassão suportados no ABACUS mas nurbs e estrias não são atualmente suportados.

16. Certifique-se de toda a forma é agrupados em MS Visio ou ele vai ficar importados como vários componentes / tipos.

17. Tente minimizar o uso de formas giradas dentro subformas como eles vão, por vezes, não ser importados corretamente.

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Preenchendo a arquitetura de Acesso | Preenchendo a arquitetura a partir do Excel


Preenchendo a arquitetura a partir do Microsoft Excel

Navegação: Preenchendo seu Arquitectura> Preencher a partir de produtos da Microsoft>

Preenchendo a arquitetura a partir do Microsoft Excel

Envie seus comentários neste tópico.

Você pode importar sua arquitetura de uma planilha do Excel (.xls ou .xlsx arquivo). O importador Excel permite mapear listas de componente e conexões com tipos, padrões, propriedades e propriedades padrão, escolhendo as colunas em sua planilha que contêm os dados relevantes.No entanto, é uma técnica mais avançada do que a abordagem recomendadapara importar a partir do MS Excel que é via catálogos conforme descrito Aqui .

Nota

O recurso de importação de / Exportar para Excel exige que Microsoft Excel 2003ou mais novo é instalado no computador.

A principal função do Importador Excel é permitir que você defina um arquivo de configuração (ou seja, a estrutura hierárquica do seu modelo de arquitetura). O arquivo de configuração de um mapeamento salvo anteriormente a partir de um arquivo do Excel para um arquivo ABACUS. Uma vez definido, o arquivo de configuração salvo é usado posteriormente para posterior importação de e exportando para arquivos .xls.

Nota

Os passos mostrados nas seções abaixo são especificamente para os usuários que ainda têm de definir e salvar um arquivo de configuração e está a importar a partir do Excel pela primeira vez. Você deve criar e salvar um arquivo de configuração para usar a exportação para o Excel função.

Para importar uma planilha do Excel em ABACUS

1. Verifique se você tem ABACUS aberto.

2. Selecione Arquivo | New e selecione Sobressairna caixa de diálogo que aparece e clique em OK.

Nota

Se você deseja importar para um projeto existente ABACUS em seguida, clique com botão direito do mouse no nó de componentes dentro de uma arquitetura, ou botão direito do mouse um componente individual dentro de uma Arquitetura e selecione Import | A partir de Excel.

3. o Importação de planilha Exceljanela será exibida

Janela de importação de planilha Excel

4. Clique no Abrir arquivo Excelícone e navegar para o arquivo do Excel que você deseja importar.

5. Escolha o Planilhaque você deseja importar na caixa drop-down.

Nota

Depois de abrir o arquivo do Excel, você pode usar o Pré-visualização de dadosguia para exibir as colunas e 25 linhas de primeiros sua planilha. A partir daqui você pode obter os números de coluna necessários para preencher o Componentes e Conexõestab.

Você também pode selecionar se deseja ou não que os componentes em uma planilha do Excel a ser importado com maiúsculas e minúsculas. Basta assinalar a Importação com maiúsculas e minúsculasopção (por padrão, isso é sempre assinalada) ea planilha será importado em conformidade.

Exemplo de arquivo Excel

Nota

Neste exemplo vamos importar uma infra-estrutura simples e Pessoas Architecture a partir dos dados do Excel mostrados na imagem acima. Conexões será feita entre "pessoas responsáveis" e os "servidores" que essas pessoas administram.

Para preencher a guia Componentes

Esta seção é para definir os tipos de componentes ea estrutura hierárquica para o arquivo de configuração.

1. Selecione os Componentestab. Renomeie o Set IDsubstituindo o (nulo) valor

Nota

Este recurso permite que você defina completamente diferente Conjuntospara componentes funcionalmente separadas. Como mostrado na imagem abaixo, você pode querer distinguir os componentes de infra-estrutura de seu povo componentes. Se há relações (conexões) entre estes conjuntos separados de componentes, que podem ser definidas no âmbito do Conexõestab. Mais tarde, neste exemplo, vamos definir conexões do tipo "Administra" entre a infra-estrutura e Pessoas Conjuntos.

Você também pode selecionar se deseja ou não adicionar um de alto nível Agrupamentocomponente para todos os elementos do conjunto. Basta assinalar a Grupo Em Definir IDopção (por padrão esta opção estiver desligada) ea planilha será importado em conformidade.

Atribuindo Set ID

2. Uma vez o Conjuntosselecione foram definidos a Conjuntovocê deseja preencher e expandir clicando no [+] placa.

3. Selecionar Níveis de componentes neste conjuntoda lista expandida.

4. o Hierarquia componente Define: Definir IDjanela aparecerá para que Conjunto.

Hierarquia de componentes e Atribuição de Valores (Set ID: Infra-estrutura)

5. Renomeie o Número Nívelcoluna, substituindo o (nulo) valor.

Nota

o Número Nívelcoluna permite que você atribua uma hierarquia para os seus componentes. Cada nível corresponde a uma camada dentro de sua arquitetura em que o primeiro nível é o mais alto principal nível. Por exemplo, número de nível "1" corresponde ao mais alto camada hierárquica, número de nível "2" é o filho de Nível número "1" e assim por diante.

6. Selecionar e atribuir a coluna relevante na planilha do Excel para cada Número Nívelinserindo-a com a Coluna componente coluna.

Nota

Você pode optar por excluir determinadas linhas que você não deseja ser representado em sua arquitetura. Estes podem ser cabeçalhos de colunas, linhas vazias, etc. Para excluir linhas usar o Linhas para excluir:caixa de texto próximo ao canto superior direito da janela. Neste exemplo, nós excluímos a linha 1, pois contém nossos cabeçalhos de coluna.

7. Você pode optar por adicionar descrições a seus componentes substituindo a (nulo)no valor Descrição Coluna.

Nota

Esta descrição é o que aparecerá em ABACUS sob a Propriedades geraisseção | Descrição campo.

8. Se uma determinada coluna de planilha tem mais de um componente por célula (que entrou usando Alt-Enter ou o (10) de comando CHAR), em seguida, marque a caixa de seleção embaixo Novas linhas tratar como componentes separados. Cada linha será importado como componentes separados.

Dica

Para importar uma "matriz" de um conjunto de colunas, onde um "X" numa dada célula "matriz" (células B2: D2 dizem) implica que o componente especificado pela linha (na célula A2 dizer) é ligada ao componente especificado pela coluna "título" (por exemplo na linha 1), uma fórmula simples pode ser usado. Insira a seguinte fórmula para cada linha em uma coluna para além das células da matriz (coluna F dizer); = IF (B2 = "", "", B $ 1 & CHAR (10)) e SE (C2 = "", "", C $ 1 & CHAR (10)) e SE (D2 = "", "", D $ 1 & CHAR (10)). Em seguida, criar um conjunto de ligação, conforme descrito abaixo entre os componentes especificados pela linha (na coluna A exemplo) e os descritos por esta fórmula (na coluna F dizer). Certifique-se de verificar o Novas linhas tratar como componentes separadosopção quando os componentes da fórmula são importadas. Para importação matriz mais avançada, incluindo as designações com múltiplas camadas de hierarquia ou células com valores diferentes do que apenas um 'X' planície, entre em contato Suporte Avolution .

9. Preencher o resto das colunas, conforme necessário.

Nota

Você pode optar por obter o tipo das linhas de coluna marcando a caixa de seleção sob o Obter Tipo de Colunacoluna e entrando na coluna relevante da planilha Excel sob a Componente tipo de valor ou coluna coluna. Isto irá importar em que todos os componentes da coluna e colocá-las com o tipo definido na coluna. Em alternativa, e como com a captura de tela acima e abaixo, você pode optar por utilizar um pré-definido nome fixo / tipo, digitando o nome do tipo sob o Componente tipo de valor ou colunacoluna e certificando-se a caixa de seleção é desmarcada.

Hierarquia de componentes e Atribuição de Valores (Set ID: Pessoas)

Nota

Neste exemplo, queremos ter nossas redes e agrupamentos de pessoas no nível 1 da Arquitetura. No nível 2, queremos ter os nossos servidores e pessoas responsáveis ​​pela administração desses servidores. o Componentesguia foi preenchido em conformidade, como mostrado nas duas imagens acima. Na primeira imagem acima temos definido o 1 (agrupamento de rede) e nível 2 componentes (servidor) a nível da infra-estrutura Conjunto. E na imagem imediatamente acima nós definimos o nível 1 (agrupamento de pessoas) e 2 (pessoas responsáveis) componentes de nível para o Povo Conjunto.

Alternativamente, para a PessoasSet, ao invés de usar a coluna C como um agrupamento Pessoas, poderíamos ter usado o Grupo Em Definir IDopção na guia componentes de nível superior e, em seguida, apenas inseriu um Pessoas sub-nível da coluna D. Isso é mostrado na imagem abaixo.

Hierarquia de componentes e Atribuição de valores usando a opção Grupo Sob Set ID (Set ID: Pessoas)

10. Uma vez que os componentes tenham sido identificados, selecione o nível de componente que pretende preencher as propriedades e / ou normas de expandir e clicando no [+] placa.

11. Selecionar Propriedades de elementos a este nível ou o Padrões de componentes a este nívelda lista expandida e preencher as colunas relevantes, conforme necessário.

Componentes que povoam

Nota

Propriedades de elementos a este nívelpermite que você defina as propriedades para os componentes no nível escolhido. Padrões de componentes a este nívelpermite-lhe definir as normas e suas propriedades padrão para os componentes no nível escolhido.

12. Repita os passos 2 - 11até que todos os níveis de componentes ter sido preenchido por todos definidos Conjuntos. Use a seta para trás perto do canto superior direito da janela para navegar de volta para o Conjuntosque você definiu anteriormente.

Para preencher a guia Conexões

Esta seção é para definir os tipos de conexão e da estrutura hierárquica para o arquivo de configuração.

1. Selecione os Conexõestab. Para cada conjunto de conexões que você tem que identificar o componente Conjuntoque você quer ser os componentes de origem e o componente Conjuntovocê quer ser os componentes de destino.

2. Debaixo do Fonte Component Set ID introduzir o Conjuntonome que corresponde à Conjuntodefinido anteriormente na Componentestab. Debaixo do Fonte Componente Número Níveldigite o número correspondente ao nível de componente que você deseja se conectar no final origem da conexão.

3. Agora escolher qual o componente grupo será no final de destino da ligação. Debaixo do Destination Component Set ID introduzir o Conjuntonome que corresponde à Conjuntodefinido no Componentestab. Debaixo do Destino Número Componente Níveldigite o número correspondente ao nível de componente que você deseja conectar ao final destino da conexão.

Nota

Neste exemplo, queremos conectar as pessoas responsáveis ​​pela administração de servidores para os servidores que eles administram. Os responsáveis ​​foram definidos no Povo Conjuntocomo nível 2 componentes, enquanto os servidores foram definidos na infra-estrutura Conjuntocomo nível 2 componentes. o Conexõesguia foi preenchido em conformidade, como mostrado na imagem abaixo.

Guia Conexões Parte 1 de 2

4. Se você rolar para a direita, você vai encontrar opções adicionais para a importação de suas conexões. Obter Tipo de Coluna e Conexão tipo de valor ou colunafuncionam da mesma maneira como para o Componentestab.

5. Se o Fonte Component Set ID e a Fonte Componente Número Nívelsão os mesmos que o Destination Component Set ID e a Destino Número Componente Nível(por exemplo, se você está se conectando os mesmos tipos de componentes, como fazer conexões de servidores para outros servidores), então você precisa ter uma outra coluna na planilha que contém os nomes dos servidores repetidas. Nessa situação, você iria colocar essa coluna na planilha Destino repetidas na coluna coluna. Se nessa coluna planilha de ter introduzido mais do que um componente ligado por célula, em seguida, marque a caixa de seleção embaixo Novas linhas tratar como componentes separados.

Guia Conexões Parte 2 de 2

6. Uma vez que as conexões tenham sido identificados selecione a conexão que você deseja preencher as propriedades e / ou normas de expandir e clicando no [+] placa.

7. Selecionar Propriedades para essas conexões ou Normas para essas conexõesda lista expandida e preencher as colunas relevantes, conforme necessário.

Nota

Propriedades para essas conexõespermite que você defina as propriedades do grupo de conexão escolhida. Normas para essas conexõespermite-lhe definir as normas e suas propriedades padrão para o grupo de conexão escolhida.

8. Repita os passos 2 - 7até que tenham sido definidos todos os grupos de ligação.

9. Quando você terminar de definir os grupos de conexão, clique no Terminarbotão e sua arquitetura será criado a partir do arquivo importado Excel. O exemplo acima irá resultar na arquitetura mostrado na imagem abaixo.

Arquitetura amostra Importado do Excel

10. Agora salve a configuração mapeadas para um arquivo clicando no Guardar configuração ícone. Sua configuração salvos podem ser recuperados mais tarde, clicando no Abrir uma Configuraçãoícone próximo ao canto superior esquerdo da janela.

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Preenchendo a arquitetura de Acesso | Preenchendo a arquitetura a partir do Visio


Preenchendo a arquitetura do Microsoft SharePoint

Navegação: Preenchendo seu Arquitectura> Preencher a partir de produtos da Microsoft>

Preenchendo a arquitetura do Microsoft SharePoint

Envie seus comentários neste tópico.

Você pode sincronizar sua arquitetura comMicrosoft Listas do SharePoint. A sincronização envolve quer a criação de novas listas do SharePoint (e suas colunas) de tipos ABACUS, suas propriedades e os acessórios, ou mapeando listas do SharePoint existentes (e suas colunas) para tipos ABACUS, suas propriedades e anexos, em seguida, enviar o conteúdo de ABACUS para SharePoint ou SharePoint para ABACUS.

Nota

o SharePoint Sincronizar recurso requer que uma Microsoft SharePoint 2010, 2013 ou SharePoint Online site está disponível para se conectar e sincronizar com.Enquanto o recurso de sincronização do SharePoint podem criar listas (com colunas) em um site SharePoint a partir de qualquer projeto ABACUS, Avolution também pode fornecer vários modelos de site SharePoint em apoio de estruturas convencionais (por exemplo TOGAF, ArchiMate, ITIL etc) por favor contacte- Suporte Avolution se você precisar deste recurso.

Para criar uma nova lista do SharePoint e mapeá-lo para um componente ou tipo de conexão ABACUS

1. Verifique se você tem ABACUS aberto.

2. Selecionar Ferramentas | SharePoint Sincronizar.

3. Clique no New Mappingbotão e uma caixa de diálogo Mapeamento do SharePoint como mostrada abaixo aparecerá.

4. Digite a URL do site, usuário e senha para o site do SharePoint e clique Conectar.

Nota

A SharePoint válido 'admin' ou conta 'colaborador' é necessário para sincronizar a partir de e para a conta de um "leitor" SharePoint e só permitirá a sincronização de SharePoint.

5. Selecione o componente ou tipo de conexão ABACUS para mapear a partir do Selecionar Tipo Puxar para baixo.

6. Clique no Adicionar novobotão e, em seguida, para cada componente ou tipo de conexão aspecto ABACUS você deseja mapear para um campo de lista do SharePoint correspondente selecionar um item no painel esquerdo e, no painel direito digitar o novo nome de lista do SharePoint na coluna Lista Nova (apenas na primeira vez) , em seguida, o nome da coluna do SharePoint em nome da coluna (ou use o padrão) e clique Atribuir cada vez.

Nota

No mínimo, para permitir a sincronização do ABACUS EEID, Arquitetura e aspectos Nome será automaticamente mapeado para um número SharePoint e dois (2) linha de texto (também conhecido como texto) colunas, respectivamente. Estes não podem ser atribuído. Além disso, apenas certos aspectos ABACUS atualmente pode ser mapeado para determinadas colunas do SharePoint e o tipo de coluna pull-down será automaticamente ajustado para o tipo de coluna SharePoint necessária. Nomeadamente;

· Caminho Hierarquia ABACUS 'para SharePoint Várias linhas de texto (aka Nota) colunas (Nota: SharePoint linha de texto (aka texto) colunas suportam apenas 255 caracteres para que eles não são de preferência),

· Componentes anexadas ABACUS 'para colunas SharePoint Lookup (Nota: Um mapeamento já deve existir para uma lista para os próprios componentes ligados),

· Texto e Inscrição propriedades ABACUS 'para o SharePoint Várias linhas de texto (aka Nota) colunas (Nota: SharePoint linha de texto (aka texto) colunas suportam apenas 255 caracteres para que eles não são de preferência),

· Propriedades decimal ou Ábaco dos Inteiros "para colunas SharePoint Número,

· Propriedades da Lista de ABACUS 'para colunas SharePoint escolha (Nota: o SharePoint não impõe os valores de opções para o tipo de dados Lista não precisam ser aplicadas em ABACUS),

· ABACUS 'Propriedades de data / hora de SharePoint Várias linhas de texto (aka Nota) colunas (Nota: SharePoint Data e colunas de tempo não pode ser usado como ainda devido ao apoio inconsistente do SharePoint para timezone settings / regionalização),

· Propriedades booleanas ABACUS 'para SharePoint Sim / Não (aka Boolean) colunas.

Associated Normas de um elemento ABACUS não podem ser mapeados para colunas de lista do SharePoint como ainda.

7. Selecionar Criar Mapeamento.

Para criar um novo mapeamento entre um componente ABACUS ou tipo de conexão e uma lista existente do SharePoint

1. Verifique se você tem ABACUS aberto.

2. Selecionar Ferramentas | SharePoint Sincronizar.

3. Clique no New Mappingbotão e uma caixa de diálogo Mapeamento do SharePoint como mostrada abaixo aparecerá.

4. Digite a URL do site, usuário e senha para o site do SharePoint e clique Conectar.

Nota

A SharePoint válido 'admin' ou conta 'colaborador' é necessário para sincronizar a partir de e para a conta de um "leitor" SharePoint e só permitirá a sincronização de SharePoint.

5. Selecione o componente ou tipo de conexão ABACUS para mapear a partir do Selecionar Tipo Puxar para baixo.

6. Selecione a lista de sites do SharePoint para mapear a partir do Select List Puxar para baixo.

7. Para cada componente ou tipo de conexão aspecto ABACUS você deseja mapear para a sua coluna lista correspondente SharePoint selecionar um item no painel esquerdo e painel direito, respectivamente, e clique Atribuir.

Nota

No mínimo, para permitir a sincronização do ABACUS EEID, Arquitetura e aspectos Nome precisam ser mapeados para um número SharePoint e, em seguida, para Arquitetura e Nome a qualquer linha de texto (também conhecido como texto) ou Várias linhas de texto (aka Nota) colunas, respectivamente. Até que isso seja feito no botão Criar Mapeamento não será habilitado. Além disso, apenas certos aspectos ABACUS atualmente pode ser mapeado para determinadas colunas do SharePoint. Nomeadamente;

· ABACUS 'Architecture aspecto a uma única linha de texto SharePoint (aka texto) ou Várias linhas de texto (aka Nota) colunas (isso é necessário para o mapeamento de conteúdo específico, como descrito abaixo),

· Portanto, quaisquer caracteres adicionais serão truncados e, portanto, SharePoint linha de texto (também conhecido como texto) colunas suportam apenas 255 caracteres: Path Hierarquia ABACUS 'para o SharePoint linha de texto (também conhecido como texto) ou Várias linhas de texto (aka Nota) colunas (Nota recomenda-se a convertê-los para Várias linhas de texto (aka Nota) colunas no SharePoint antes de mapeamento),

· Componentes anexadas ABACUS 'para colunas SharePoint Lookup (Nota: Um mapeamento já deve existir para uma lista para os próprios componentes ligados),

· Portanto, quaisquer caracteres adicionais serão truncados SharePoint linha de texto (também conhecido como texto) colunas suportam apenas 255 caracteres: Texto e Inscrição propriedades ABACUS 'para o SharePoint linha de texto (também conhecido como texto) ou Várias linhas de texto (aka Nota) colunas (Nota e, portanto, recomenda-se a convertê-los para Várias linhas de texto (aka Nota) colunas no SharePoint antes de mapeamento),

· 'Propriedades decimal ou inteiro para colunas SharePoint Número (Nota.: Colunas SharePoint Calculado pode ser usado porém eles só será capaz de sincronizado do SharePoint para ABACUS tentando sincronizar' ábaco para 'uma coluna calculada irá resultar em uma advertência conforme abaixo) ,

· Propriedades da Lista de ABACUS 'para colunas SharePoint Escolha,

· ABACUS 'Propriedades de data / hora de SharePoint Várias linhas de texto (aka Nota) colunas (Nota: SharePoint Data e colunas de tempo não pode ser usado devido ao apoio inconsistente do SharePoint para timezone settings / regionalização),

· Propriedades booleanas ABACUS 'para SharePoint Sim / Não (aka Boolean) colunas.

Associated Normas de um elemento ABACUS não podem ser mapeados para colunas de lista do SharePoint como ainda. Moeda e do SharePoint, pessoa ou grupo, Hiperlink ou Imagem, Resultado de tarefas, dados externos e as colunas de metadados gerenciados não podem ser mapeados para aspectos ABACUS ainda.

8. Selecionar Criar Mapeamento.

Para sincronizaro Microsoft Lista (s) SharePointem ABACUS

1. Verifique se você tem ABACUS aberto.

2. Selecionar Ferramentas | SharePoint Sincronizar.

Nota

Para sincronizar uma lista do SharePoint com umProjeto ABACUS a licença de usuário precisa do SharePoint Sincronizaradd-on capacidade. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

3. Selecione um mapeamento de SharePoint existente (ou usando mapeamentos Ctrl-click ou o Selecionar tudobotão) a partir do SharePoint mapeamentos painelcomo mostrado na imagem de exemplo acima. Nota: aqui estamos mostrando apenas o 'Gol (ou exigência)' ABACUS tipo de componente de mapeamento para uma lista SharePoint chamados Objetivos de ser selecionado.

4. Selecione a Arquitetura (s) que você deseja sincronizar o conteúdo com o do Índice de sincronização de Arquiteturascomo painel mostrado na imagem de exemplo acima. Nota: aqui estamos mostrando apenas o "2015 Actual 'arquitetura a ser sincronizados.

5. Selecione os Sincronização de SP botão.

Nota

Se as credenciais do site do SharePoint não 'All Saved' são para o mapeamento (s) escolhida, em seguida, uma sesão de diálogo SharePoint irá aparecer pedindo para o URL do site, Nome de Usuário e / ou Senha.Por favor, indique estes. Além disso, a sincronização irá incluir quaisquer outros mapeamentos que são necessários para componentes / colunas de pesquisa em anexo. Quaisquer mapeamentos adicionais que são incluídos automaticamente será mostrado na caixa de diálogo conforme abaixo.

6. Em sincronização com êxito um diálogo Resultados SharePoint Sync irá aparecer como mostrado abaixo lista as alterações e de quaisquer avisos. Clique Está bem.

Para sincronizar a partir de ABACUS o Microsoft Lista (s) SharePoint

1. Verifique se você tem ABACUS aberto.

2. Selecionar Ferramentas | SharePoint Sincronizar.

Nota

Para sincronizar uma lista do SharePoint com umProjeto ABACUS a licença de usuário precisa do SharePoint Sincronizaradd-on capacidade. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

3. Selecione um mapeamento de SharePoint existente (ou usando mapeamentos Ctrl-click ou o Selecionar tudobotão) a partir do SharePoint mapeamentos painelcomo mostrado na imagem de exemplo acima. Nota: aqui estamos mostrando apenas o 'Gol (ou exigência)' ABACUS tipo de componente de mapeamento para uma lista SharePoint chamados Objetivos de ser selecionado.

4. Selecione a Arquitetura (s) que você deseja sincronizar o conteúdo com o do Índice de sincronização de Arquiteturascomo painel mostrado na imagem de exemplo acima. Nota: aqui estamos mostrando apenas o "2015 Actual 'arquitetura a ser sincronizados.

5. Selecione os Sync Para SP botão.

Nota

Se as credenciais do site do SharePoint não 'All Saved' são para o mapeamento (s) escolhida, em seguida, uma sesão de diálogo SharePoint irá aparecer pedindo para o URL do site, Nome de Usuário e / ou Senha.Por favor, indique estes. Além disso, a sincronização irá incluir quaisquer outros mapeamentos que são necessários para componentes / colunas de pesquisa em anexo. Quaisquer mapeamentos adicionais que são incluídos automaticamente será mostrado na caixa de diálogo conforme abaixo.

6. Em sincronização com êxito um diálogo Resultados SharePoint Sync irá aparecer como mostrado abaixo lista as alterações e de quaisquer avisos. Clique Está bem.

Nota

ABACUS irá atualizar colunas do SharePoint com valores em branco, mesmo que "Exigir que esta coluna contenha informações 'é definida como Sim em SharePoint. Isso ocorre porque o SharePoint não expõe essa configuração externamente. Se isso é ser prevenida recomenda-se que um Designer ABACUS define a restrição necessária para True e Forçados para a propriedade dada usando ABACUS ' limitação característica .

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Preenchendo a arquitetura a partir do Visio | Preenchendo a arquitetura a partir do Excel


Preenchendo a arquitetura do Microsoft SQL Server

Navegação: Preenchendo seu Arquitectura> Preencher a partir de produtos da Microsoft>

Preenchendo a arquitetura do Microsoft SQL Server

Envie seus comentários neste tópico.

Você pode importar sua arquitetura de um banco de dados Microsoft SQL Server. Você tem a opção de apenas importar as tabelas e relações efetivamente importadores apenas a estrutura genérica do banco de dados ou as tabelas, linhas e relacionamentos que importam não só a estrutura, mas os dados também.

Nota

A partir do SQL Server requer que recurso Microsoft SQL Server 2005, 2008, 2008 R2, 2012 ou 2014é instalado no computador.

Para importar seu banco de dados Microsoft SQL Server em ABACUS

1. Verifique se você tem ABACUS aberto.

2. Selecione Arquivo | Novo e selecione A partir do SQL Serverna caixa de diálogo que aparece e clique em OK.

3. Na caixa de diálogo Import SQL Server que parece definir o 'MACHINENAME "e valores" SQLinstance' da variável seqüência de conexão eo valor 'DBNAME' da variável de Nome do Banco com os valores corretos, como mostrado na captura de tela de exemplo abaixo.

4. Defina a variável de Nome do Banco de Dados para o mesmo valor que a variável catálogo inicial definido na etapa anterior, como mostrado na imagem de exemplo abaixo.

5. Pressione o botão Test Connection e as tabelas para importar seção da caixa de diálogo deve ser preenchido com as tabelas de banco de dados disponíveis, conforme mostrado na captura de tela de exemplo abaixo.

6. Selecione as tabelas que você deseja importar, quer seleccionando-os individualmente ou usando o All, None e inverter botões à direita da caixa de diálogo.

Nota

Apenas a chave de Relações Exteriores que existem entre as tabelas que você selecionar vai se importar.

7. Usando o botão de rádio Importar Estilo selecionar se você deseja importar apenas as tabelas e as relações entre eles ou as Mesas, as suas linhas e as relações específicas entre as fileiras.

Nota

A primeira opção importa as tabelas como componentes do tipo 'Tabela' e as relações entre quaisquer duas tabelas (de chaves estrangeiras) são importadas como as conexões do tipo 'Relação Table'. Este é um modo de exibição clássico "ERD" estilo das tabelas do sistema. A segunda opção importa as linhas da tabela como sub-componentes discretos do tipo 'Table Row' com propriedades correspondentes a cada uma das colunas / campos e com as relações entre as linhas da tabela do tipo 'Relação Table'. Além disso, se há uma coluna / campo chamado 'Name', então este é usado para nomear a mesa Row sub-componentes individuais.

8. Selecione o botão Importar ....

9. Depois de um curto período de tempo (com uma barra de progresso para o gabarito) um novo projeto ABACUS será criado com as tabelas, linhas da tabela (se a segunda opção foi selecionada na etapa anterior) e Relações do banco de dados do Microsoft SQL Server.

Veja também

Preenchendo sua arquitetura - Visão geral | Preenchendo a arquitetura manualmente | Preenchendo a arquitetura a partir do Visio | Preenchendo a arquitetura a partir do Excel


Adicionando propriedades predefinidas a um componente, ligação ou tipo

Navegação: Preenchendo sua arquitetura> Propriedades>

Adicionando propriedades predefinidas a um componente, ligação ou tipo

Envie seus comentários neste tópico.

Bibliotecas padrão de propriedades podem ser especificadas e atribuído a qualquer outra coisa na arquitetura. Estas são conhecidas como bibliotecas Padrões. Por usar Padrões, Você só precisa de recolher as propriedades de sistemas específicos - as propriedades padrão já estão lá.

Por exemplo, as características de desempenho padrão do Microsoft Windows 2000 pode ser salvo como um Padrãoe atribuído a quaisquer componentes (ou conexões, não que isso seria típico) usando o sistema operacional Microsoft Windows 2000.

Para adicionar um padrãoa um componente, ou conexão tipo

1. Botão direito do mouseno componente / ligação / tipo.

2. Selecionar Atribuir Padrão.

3. Selecionar uma Padrãoa partir da lista.

Veja também

Preenchendo sua arquitetura - Visão geral | Alterar as propriedades de um componente, ligação ou tipo | Propriedades de agregados


Alterar as propriedades de um componente, ligação ou tipo

Navegação: Preenchendo sua arquitetura> Propriedades>

Alterar as propriedades de um componente, ligação ou tipo

Envie seus comentários neste tópico.

As propriedades são tipicamente os requisitos do sistema que você define, ou os resultados das avaliações ABACUS '. (Quando ABACUS realiza suas avaliações, escreve propriedades de volta para o arquivo.) Em outras palavras, as propriedades são as coisas que você sabe sobre o seu sistema, ou as coisas que você está usando ABACUS para descobrir.

Para alterar o valor da propriedade de um componente, ligação ou tipo

1. Cliqueno componente / ligação / tipo (suas propriedades será exibida na janela Propriedades para a direita).

2. Cliquepara destacar a propriedade que você deseja alterar.

3. Tipoum novo valor.

Importante

Além disso, muitas propriedades são definidas usando Padrões . Ao alterar uma propriedade dentro de um Padrão, Você não só mudar o objeto atual, você também alterar o mestre Padrão (debaixo Os padrõeso topo da árvore). Antes de fazer isso, verificar o que outros componentes, conexões ou tipos estão usando a Padrão, Porque a mudança não pode ser relevante para eles- Você pode usar a janela de Referências para este.

Dica

Você pode alterar as propriedades de uma conexão de dentro da filial Componentes da árvore (e vice-versa). Assim, por exemplo, se você está olhando para o que as conexões estão associadas a um componente, e você percebe que tem de mudar, você pode.

Para adicionar novas propriedades ou a um componente de ligação (através do tipo de)

Nota

Propriedades só pode ser adicionado a tipos e os componentes ou as ligações do tipo 'herdar' essas propriedades.

1. Cliquedo tipo (suas propriedades será exibida na janela Propriedades para a direita).

2. Cliqueno botão Adicionar na parte superior da janela de propriedade para adicionar uma linha na parte superior da grade de propriedades para a nova propriedade.

3. Adicionar um Tipopara a nova propriedade.

4. Adicionar um Nomepara a nova propriedade.

5. Adicionar um Valor padrãopara a nova propriedade.

6. Adicionar um Unidadepara a nova propriedade.

7. Colocou o Tipo de dadopara a nova propriedade.

Nota

O campo tipo de dados pode ser utilizado para restringir os valores válidos que uma propriedade pode ter. Isso é; Texto, inteiro, decimal, data / hora, booleano ou Lista.

o A Textopropriedade é aquele que tem um número ilimitado de personagens e, essencialmente, não tem restrições sobre o valor.Se o valor da propriedade é um hiperlink adequadamente formado (ou seja, URLs precisa para começar com um dos 5cordas; http: //, https: //, ftp: //, arquivo:ou \\ e qualquerespaços devem ser inseridos com um '% 20'), Em seguida, o link é clicável (via ctrl + clique).

o Um Número inteiropropriedade deve ser um número inteiro positivo ou negativoe podem conter um período, espaço, de apóstrofo ou uma vírgula para agrupamento de dígitos, dependendo do projeto do As configurações de região a partir da Arquivo | Opções do Projecto.As configurações de região e no.Líquido Método Long.TryParse é utilizado para determinar válido Número inteirovalores.

o A Decimalpropriedade pode conter uma ponto ou vírgula para o símbolo decimal e pode conter um período, espaço, de apóstrofo ou uma vírgula para agrupamento de dígitos, dependendo do projeto do As configurações de região a partir da Arquivo | Opções do Projecto.As configurações de região e no.Líquido Método Decimal.TryParse é utilizado para determinar válido Decimal valores.

o A Data horapropriedade permite que seja uma parte de data ou uma parte Tempo ou ambos. A região configuraçõeseo .Net Método DateTime.TryParse são principalmente usados ​​para determinar os valores de data e / ou hora válida. No entanto, a parte de data se for o caso requer, pelo menos, o dia eo mês (o Ano será assumido ser o ano em curso) ou mês e ano partes para ser válido. Isto é, Junho, Q3 2010 ou até mesmo 2010 são inválidos. Enquanto isso vai ser diferente com diferentes configurações regionais, normalmente as partes do dia, mês e ano podem ser separados por um espaço, vírgula, hífen ("-") ou barra ('/'). A parte Dia tipicamente é um número inteiro de 1 a 31. A parte do mês é tipicamente um número inteiro de 1 a 12, um válido abreviatura de 3 letras para os meses (por exemplo, Jan, Fev, Mar) ou o nome do mês completo (por exemplo, Janeiro, Fevereiro , Março). A parte do ano é tipicamente um número positivo de 4 dígitos, mas 1, 2 e 3 anos dígitos são aceitas de acordo com as definições no Painel de Controle> Regional e idioma Options-> Regional Opções> Personalizar (botão) -> Date-> Calendário. Normalmente, eles são interpretados como se segue; 0-29 é interpretado como 2000-2029, de 30 a 99 como 1930-1999 e 100-999 como 100-999. Datas inválidas tais como 31 junho de 2010 e 31/9/2010 será detectado. A parte Tempo se for o caso exige uma horas e minutos parte e, opcionalmente, uma parte Segundos. As horas, minutos e peças Segundos opcionais são normalmente separados por dois pontos (":") ea parte Segundos pode ser especificado com um ponto decimal ('.'). Para mais informações sobre os formatos válidos, consulte a seção de comentários sobre o .Net Método DateTime.TryParse .

Dica

Recomenda-se utilizar, pelo menos, o formato do nome do mês de 3 letras (ou seja, "Julho" ou "Julho") para valores de data em vez de formatação numérica (ou seja, "7" ou "07") como esses valores irão validar através das maioria das regiões, dependendo no Projeto de As configurações de região a partir da Arquivo | Opções do Projecto.Isto é, é recomendado o uso de "Julho 15, 2010" em vez de "15/7/2010" ou "7/15/2010". Com este exemplo, "15/7/2010" iria falhar validação para "Inglês (Estados Unidos)" e "2010/07/15" seria um fracasso para "Inglês (Reino Unido)", no entanto "15 de julho de 2010" passaria por ambos.

o A Booleanpropriedade pode ser True ou False.É insensível caso assim VERDADEIRO ou FALSO também pode ser usado no entanto sim, não, 1, 0 etc serão todos falham quaisquer restrições de propriedade.

o A Listapropriedade permite que um conjunto de valores pré-definidos, tais como Baixa | Médio | Alta ou Manter | Atualizar | Redesenho | Aposentar e o intervalo de valores vem do campo Unidade para a propriedade, quer como vírgula ou pipe '|' valores separados. A propriedade pode ser considerado ordinal (em oposição ao nominal, ou intervalo de ratio) porque, quando usado em cartas e para colorir elementos em diagramas 3DS e os valores são tratados simplesmente em um ascendente (ou descendente) ordem. Ou seja os valores são plotados em ordem crescente (ou decrescente) de pedido no eixos do gráfico ou gamas de cores.

8. O tipo de dados pode ser configurada para ficar Desativado, Advertido ou Forçadosclicando com o campo tipo de dados para uma definição diferente de texto, que permite que quaisquer caracteres, portanto, não pode nunca ser incorreta.

9. Colocou o Requeridosbandeira para a nova propriedade.

Nota

O Campo obrigatório pode ser usado para indicar se um valor precisa ser inserido para a propriedade. Isso é que ele não pode estar em branco ou vazios. Falsoé o padrão e significa que a propriedade pode ser vazia ou em branco, Verdadesignifica que a propriedade deve ter um valor e não pode estar vazio ou em branco. O desejado pode ser ajustado para ser Desativado, Advertido ou Forçadosclicando com o campo Necessário se tiver sido definida como True.

Veja também

Preenchendo sua arquitetura - Visão geral | Adicionando propriedades predefinidas a um componente, ligação ou tipo | Propriedades de agregados


Alterar configurações de região de um projeto

Navegação: Preenchendo sua arquitetura> Propriedades>

Alterar configurações de região de um projeto

Envie seus comentários neste tópico.

Os valores de propriedade exigir determinada formatação em diferentes regiões para combinar com qualquer Restrições de tipo de dados para Inteiro, Decimal e Data / Hora Propriedades. Por exemplo, na Austrália, o decimal "123456 ponto sete oito nove" é representado como "123,456.789", enquanto na Alemanha seria represnted como "123.456,789" e na França seria " 123 456789 ".Da mesma forma, na US o "segundo de dezembro 1970" é representada como uma data abreviada como "1970/12/02" mas, no Reino Unido é representado como "1970/02/12" e na Polónia como "1970-1912 -02 ". Por conseguinte, a trabalhar com um projeto ABACUS em todas as regiões uma configuração global por projecto ABACUS é necessária.

Mudar As configurações de região de um projeto ABACUS

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Selecionar Arquivo | Opções do Projecto ... e na caixa de diálogo que aparece selecione os Região e clique em OK. Nota: Por favor, consulte a seção abaixo para os padrões regionais.

Nota

Se você não vê o Opções do Projecto ... item do menuem seguida, você não tem o Designer e Administrador adicionars e você não pode alterar a região do projeto.Além disso, se nenhuma região está definido (ou seja, a Região em Opções do Projecto é 'Nenhum (Região System)'), então cada MS Windows configurações de cultura atual do usuário (ou seja, configurações Regional)são usadas para validar as propriedades.

Defaults Região

A tabela a seguir lista o padrões para cada região, definidos através do Arquivo | Opções do Projecto ... item do menu.Por favor, veja abaixo a tabela para obter uma lista dos símbolos usados.

Região | Símbolo Decimal | Agrupamento de dígitos | Sinal negativo | Pouco tempo | Há muito tempo | AM / PM símbolo | Short Date | Long Date
Inglês (Austrália) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / aaaa | dd MMMM aaaa
Inglês (Reino Unido) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / aaaa | dd MMMM aaaa
Inglês dos Estados Unidos) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / aaaa | dddd, MMMM dd, aaaa
Francês (França) | , | espaço | - | Hh: mm | HH: mm: ss | | | dd / mm / aaaa | dddd d MMMM aaaa
Alemão (Alemanha) | , | . | - | Hh: mm | HH: mm: ss | | | DD.MM.YYYY | dddd, d. MMMM aaaa
Italian (Italy) | , | . | - | Hh: mm | HH: mm: ss | | | dd / mm / aaaa | dddd d MMMM aaaa
Espanhol (Espanha) | , | . | - | H: mm | H: mm: ss | | | dd / mm / aaaa | dddd, dd aaaa 'de' MMMM 'de'
Inglês (Canadá) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / mm / aaaa | MMMM-dd-aa
Francês (Canadá) | , | espaço | - | Hh: mm | HH: mm: ss | | | aaaa-mm-dd | d MMMM aaaa
Árabe (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / aaaa | dd MMMM, aaaa
Árabe (Arábia Saudita) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / aa | dd / MMMM / aaaa
Inglês (África do Sul) | , | espaço | - | hh: mm tt | hh: mm: ss tt | AM | PM | aaaa / MM / dd | dd MMMM aaaa
Inglês (Nova Zelândia) | . | , | - | h: mm tt | h: mm: ss tt | a.m. | p.m. | d / mm / aaaa | dddd, d MMMM aaaa
Inglês (Índia) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd-MM-aaaa | dd MMMM aaaa
Alemão (Suíça) | . | ' | - | Hh: mm | HH: mm: ss | | | DD.MM.YYYY | dddd, d. MMMM aaaa
Francês (Bélgica) | , | . | - | Hh: mm | HH: mm: ss | | | d / mm / aaaa | dddd d MMMM aaaa
Holandês (Bélgica) | , | . | - | H: mm | H: mm: ss | | | d / mm / aaaa | dddd d MMMM aaaa
Czech (República Tcheca) | , | espaço | - | H: mm | H: mm: ss | dop |. odp. | d.M.yyyy | d. MMMM aaaa
Dinamarquês (Dinamarca) | , | . | - | Hh: mm | HH: mm: ss | | | dd-MM-aaaa | d. MMMM aaaa
Grego (Grécia) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / aaaa | dddd, d MMMM aaaa
Finlandês (Finlândia) | , | espaço | - | H: mm | H: mm: ss | | | d.M.yyyy | d. Aaaa MMMM'ta '
Húngaro (Hungria) | , | espaço | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | aaaa. MMMM d.
Holandês (Holanda) | , | . | - | H: mm | H: mm: ss | | | d-M-aaaa | dddd d MMMM aaaa
Norueguês, Bokmål (Noruega) | , | espaço | - | Hh: mm | HH: mm: ss | | | DD.MM.YYYY | d. MMMM aaaa
Polonês (Polónia) | , | espaço | - | Hh: mm | HH: mm: ss | | | aaaa-mm-dd | d MMMM aaaa
Russo (Rússia) | , | espaço | - | H: mm | H: mm: ss | | | DD.MM.YYYY | d MMMM aaaa 'г.'
Sueco (Suécia) | , | espaço | - | Hh: mm | HH: mm: ss | | | aaaa-mm-dd | 'den' d MMMM aaaa
Coreano (Coréia) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | aaaa-mm-dd | aaaa '년' M '월' d '일' dddd
Hebraico (Israel) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / aaaa | dddd MMMM dd aaaa

Os seguintes símbolos são usados ​​para especificar como as datas e os horários são exibidos:

Símbolos do tempo |
h | Hora (hh exibe a hora com um zero à esquerda)
m | Minuto (mm exibe o minuto com um zero à esquerda)
s | Em segundo lugar (ss exibe o segundo com um zero à esquerda)
tt | SOU. ou P.M.
h / H | Exibição de tempo 12 ou 24 horas
Data símbolos |
d, dd | Dia
ddd, dddd | Dia da semana
M | Mês
y | Ano

Veja também

Preenchendo sua arquitetura - Visão geral | Alterar as propriedades de um componente, ligação ou tipo | Adicionando propriedades predefinidas a um componente, ligação ou tipo


Propriedades de agregados

Navegação: Preenchendo sua arquitetura> Propriedades>

Propriedades de agregados

Envie seus comentários neste tópico.

A operação "Aggregate Propriedades"Permite que você adicione valores de propriedades semelhantes juntos e escrever (ou adicionar) o resultado em propriedades do elemento pai escolheu. Ele também permite que você definir o escopo de agregação e de se atualizar as propriedades de todos os sub-elementos ou não.

Para propriedades de agregados

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Botão direito do mouse sobre um elemento (uma arquitetura, um componente ou uma ligação) em que para fazer a agregação e selecione Propriedades agregadas.

3. Escolha uma das opções de agregação (Traverse Todos os sub-níveis ou Nível Sub Só direto). Se você tiver escolhido Traverse Todos os sub-níveis, Você também pode escolher a opção de se Atualização de sub-níveis.

o Traverse Todos os sub-níveissignifica que o âmbito da agregação incluirão os elementos em todos os níveis no seu elemento escolhido.

o Atualização de sub-níveissó pode ser feito se você também tenha escolhido a opção Traverse Todos os sub-níveis. Isto significa que, enquanto você agregar propriedades de baixo para cima, o resultado agregado em todos os níveis também será atualizado em cada um dos elementos correspondentes.

o Nível Sub Só diretosignifica que apenas as propriedades dos elementos directamente abaixo do elemento escolhido irá ser agregados.

o Selecionar Incluir PadrãoPropriedadesse você quiser as propriedades definidas no padrões a ser incluídos. Caso contrário, apenas as propriedades únicas para cada ocorrência do componente será usado.

4. Escolha quais as propriedades que você deseja agregar. Eles são agrupados em sua Tipos.

5. Clique no Próximo botão.

6. Escolha a opção se Valores Substituir ou Adicionar valoresno elemento escolhido.

o Valores Substituirirá escrever os resultados directamente para as propriedades do elemento escolhido.

o Adicionar valoresirá adicionar os resultados para as propriedades existentes do elemento escolhido.

Veja também

Adicionando propriedades predefinidas a um componente, ligação ou tipo | Alterar as propriedades de um componente, ligação ou tipo | Avaliando sua arquitetura


Analisando sua arquitetura

Navegação: Analisando sua arquitetura>

Analisando sua arquitetura

Envie seus comentários neste tópico.

Depois de ter preenchido (e, opcionalmente, simulado) sua arquitetura, você está pronto para usar ABACUS para analisá-lo. Ao analisá-lo, você pode determinar se sua arquitetura irá atender às suas necessidades.

Você pode analisar sua arquitetura em uma variedade de maneiras diferentes:

· Diagrama

· 3D Visão

· gráficos padrão (torta, linha, coluna, bar, etc.)

· gráficos personalizados ( tempo de resposta , espaço capacidade , estrela enredo , matriz scatterplot e gráfico de bolhas )

· Arquitetura Diff

Nota

Ao criar um diagrama, 3D Visão, Relatório ou gráfico padrão, o janela de seleção de elemento padrão é usado para selecionar os elementos que você deseja visualizar.

Veja também

Preenchendo sua arquitetura | Simulando sua arquitetura | o Diagramação Ferramenta


Padrão elemento de selecção

Navegação: Analisando sua arquitetura>

Padrão elemento de selecção

Envie seus comentários neste tópico.

Ao criar um diagrama, 3D Visão, relatório,gráfico padrãoou executar uma simulação, A janela de seleção de elemento padrão é usado para selecionar os elementos que você deseja analisar / view.

Janela padrão Elemento Seleção

Pulldowns

· Filtrar por Ver irá incluir o elementos de uma exibição salvo anteriormente (ou seja, Diagrama, Gráfico, 3D). Desta forma, você pode executar complexo "junte-se a consultas por tratamento de uma outra vista como uma 'consulta' salvos.

Checkboxes

· Mostrar Níveisgrupo vontade o elemento de acordo com o nível, através da qual eles ocorrem na árvore. O nível 1 é o mais alto nível.

· Mostrar Tiposgrupo vontade os elementos de acordo com os tipos que são.

· Os pais de selecionadosincluirá os elementos pai de todos os elementos seleccionados. Desta forma, você pode garantir que apenas a hierarquia acima de todas as crianças serão incluídos para uma seleção "bottom-up".

· Filhos de selecionadosirá incluir as crianças elementos de quaisquer elementos selecionados. Desta forma, você pode garantir que apenas a hierarquia abaixo de qualquer pais serão incluídos para uma seleção "top-down".

· Nome Jogos Valorincluirá apenas os elementos que tem um nome que contém a seqüência de caracteres especificada (Por favor note: Os wildcards (ou seja, e *) pode ser usado?). Desta forma, você pode formar uma consulta "semântica".

· Tem de propriedade Tipo / Nome / Valorincluirá apenas os elementos que têm um tipo de propriedade, o nome eo valor que contém a seqüência de caracteres especificada quer directamente sobre o elemento ou em suas Normas (Por favor, note:?.? Wildcards (ou seja, e *) pode ser usado, por exemplo * no campo Valor será dar a todos os elementos que têm um valor diferente de espaço em branco para o imóvel dado). Desta forma, você pode formar uma consulta "semântica".

· Tem Padrãoincluirá apenas os elementos que tenham um nome padrão que contém a seqüência de caracteres especificada (Por favor note: Os wildcards (ou seja, e *) pode ser usado, por exemplo HP * dará a todos os elementos com pelo menos um padrão começando com as letras H e P?.). Desta forma, você pode formar uma consulta "semântica".

· Componentes / Conexões anexado ao selecionadoincluirá todos os elementos ligados às que foram selecionados. Desta maneira, uma "árvore de chamada" ou "Impacto-análise" pode ser seleccionado.

Nota

Se você tem tanto Mostrar Níveis e Mostrar Tiposselecionado, então você pode optar por ter os níveis Mostrar árvore de primeira ou tipos primeiro pelo botão que aparecerá acima das duas caixas de seleção.

Dica

Uma vez que um item é selecionado na Janela Padrão Elemento Seleção, não será sujeita a quaisquer outras alterações de filtro até que seja desmarcado. Desde que não há nenhuma maneira nativa para procurar dois conjuntos diferentes de elementos de uma só vez (por exemplo, componentes com padrão A ou Standard B), você pode procurar primeiro para um conjunto, selecione os componentes desejados e, em seguida, executar uma segunda pesquisa para o segundo conjunto .

Botões

· Todosseleciona todos os elementos.

· Invertidodesmarca todos os elementos atualmente selecionados e seleciona todos aqueles que não foram selecionados.

· Nenhumdesmarca todos os elementos.

· Adicionar Filtroseleciona o conteúdo resultante das configurações de filtro atuais e permite filtro de seleção de conteúdo adicional como uma forma eficaz ou para se filiar.

Veja também

Analisando sua arquitetura


Visualizando um diagrama 3D

Navegação: Analisando sua arquitetura> diagramas 3D>

Visualizando um diagrama 3D

Envie seus comentários neste tópico.

ABACUS permite visualizar sua arquitetura como uma visualização em 3D onde as propriedades de componentes e de ligação estão associados com cores, formas e tamanhos.

Para ver uma visualização em 3D de sua arquitetura

1. Verifique se você tem abra o arquivo ABACUScontendo o seu arquitetura povoada.

2. Expanda o Visualizaçõesgalho da árvore.

3. Expanda o 3Dgalho da árvore.

4. Duplo click a visualização que você deseja abrir.

- ou -

1. Verifique se você tem abra o arquivo ABACUScontendo o seu arquitetura povoada.

2. Selecionar Inserir| 3Dou clique no botão da barra de ferramentas.

3. Abra uma existirvisualização (.abacus3d)

- ou -

1. Verifique se você tem abra o arquivo ABACUScontendo o seu arquitetura povoada.

2. Selecionar Inserir| 3Dou clique no botão da barra de ferramentas.

3. Criar uma nova visualização:

· Selecione os Arquiteturavocê deseja exibir no menu suspenso.

· Selecione os Componentes e Conexõesvocê deseja incluir no diagrama do janela de seleção de elemento padrão .

· Associados cores, formas e tamanhos, com Tipos de componentes e Propriedades.

· Associados cores e formas com Tipos de conexão e Propriedades.

Para exportar uma vista 3D

1. Verifique se você tem abra uma tela 3D existente.

2. Em menus pull-down da vista 3D, selecione Arquivo | Exportar...e escolheu o local e tipo de arquivo para o arquivo de visualização (.abacus3d, .vrml ou .html).

3. Clique Guardar.

Veja também

Analisando sua arquitetura | Navegação em 3D | A ferramenta de diagramação


Navegação em um diagrama 3D

Navegação: Analisando sua arquitetura> diagramas 3D>

Navegação em um diagrama 3D

Envie seus comentários neste tópico.

ABACUS permite navegar facilmente através de sua arquitetura em 3D. A experiência é semelhante a voar. Existem dois modos de navegação:

· Modo de Controle Básico (padrão); e

· Modo de Controle Avançado - mudança para esse modo selecionando Ao controle| Modo de Controle Avançado.

Nota

Para alternar entre os modos de operação básica e Controle Avançado, você pode usar o F4funcionalidade atalho de teclado.

Modo de Controle Básico

· Segurando o botão esquerdo e movendo o mouse para a frente ou para trás muda o tom;

· Segurando o botão esquerdo e movendo o mouse para a esquerda ou direita altera a guinada;

· Segurando o botão direito do mouse e mover as panelas do rato a vista;

· Segurando ambos os botões para baixo e movendo o mouse para a frente ou para trás, aproxima e afasta da arquitetura; e

· Segurando ambos os botões para baixo e movendo o mouse para a esquerda ou direita, rola esquerda e direita.

- ou -

· Pressionando o Seta esquerdano teclado ou teclado numérico vai virar à esquerda;

· Pressionando o Seta direitano teclado ou teclado numérico vai virar à direita;

· Pressionando o Seta para cimano teclado numérico ou teclado irá aumentar o zoom;

· Pressionando o Seta para baixono teclado numérico ou teclado irá diminuir o zoom;

· Pressionando Subir páginano teclado ou teclado numérico vai lançar-se; e

· Pressionando Page Downno teclado ou teclado numérico irá lançar para baixo.

Modo de Controle Avançado

· Em movimentoo mouse para a frente e para trás, para cima e para baixo, muda o tom e guinada (respectivamente);

· Pressionando W ou Seta para cimaamplia (para frente) para a arquitetura;

· Pressionando S ou Seta para baixodiminui o zoom (para trás) a partir da arquitetura;

· Pressionando A ou Seta esquerdarolos para a esquerda;

· Pressionando D ou Seta direitarola para a direita;

· Pressionando Q ou Page Downeleva a vista (através da redução da perspectiva); e

· Pressionando E ou Subir páginaabaixa a vista (elevando a perspectiva).

Modo de Controle interativo

Pressionando e segurando o tecla Shiftno teclado substitui o modo atual (Básico ou Avançado) para entrar no modo de controle interativo. Neste modo, o seguinte é possível:

· Roloo cursor do mouse sobre um componente ou conexão para ver o componente ou o nome de conexão;

· Cliqueem um componente para fazer zoom e esse componente;

· Clique e arrasteem um componente para girar a vista em torno desse componente; e

· Botão direito do mouseum componente ou de conexão e selecione Mostrar no Explorerver que o componente ou a localização da ligação na árvore.

Controles comuns

· Uso ALT-ENTER / ESCpara alternar o modo de tela cheia;

· Uso F2para alterar o modo de exibição. Isso também pode ser acessado no Visão Cardápio.

· Use o roda do mouse ou +/-para alterar a velocidade. A velocidade é indicada por um número no canto inferior esquerdo - mostrado apenas quando se está a mudar. 1 é mais lento e mais rápido 100 é.


Visualizando um gráfico padrão

Navegação: Analisando sua arquitetura> Gráficos padrão>

Visualizando um gráfico padrão

Envie seus comentários neste tópico.

Gráficos padrão ABACUS 'inclui a linha, barra, coluna, área, dispersão, torta, curva, Pareto, passo, superfície, radar, cubo, filhós, pirâmide, contorno e gráficos de área curva. Depois de ter selecionado o tipo de gráfico que você quer, o resto do processo para a visualização de cada um destes gráficos é o mesmo.

Para visualizar um gráfico padrão de sua arquitetura

1. Verifique se você tem abra o arquivo ABACUScontendo o seu arquitetura povoada, E que você tem avaliadassua arquitetura.

2. Selecionar Inserir| Gráficoou clique no botão da barra de ferramentas. o Chartsjanela será exibida.

Janela Charts

3. Selecione o tipo de gráfico que você deseja e defina as opções de gráfico, clique em Próximo.

Opções de gráfico

o Empilhadosvai mostrar a relação de itens individuais com o todo. Você pode usar um gráfico empilhado quando você pretende ter várias séries de dados (ou seja, várias propriedades) e quando você quer enfatizar o total.

o Empilhadas 100%irá comparar a porcentagem de cada valor contribui para um total em todas as categorias. Você pode usar um gráfico empilhado de 100% quando você pretende ter várias séries de dados (ou seja, várias propriedades) e você quer enfatizar as contribuições para o todo, especialmente se o total é o mesmo para cada elemento.

o Gráfico 3Dsimplesmente exibir os pontos de dados em formato de 3-D para a estética. Se você deseja exibir a série de dados ao longo de uma dimensão terceiro-eixo z /, em seguida, use a opção Cluster Series descrito abaixo.

o Series by Propertyirá exibir uma série de dados para cada propriedade que é, em última instância selecionada. Se este for desmarcada, em seguida, as propriedades ficarão as categorias e as séries de dados será para cada elemento que está selecionado.

o Gráfico Rotateirá girar o gráfico 90º no sentido horário trocando os eixos x e y. Esta opção só está disponível para as linhas, step e Cube gráficose é particularmente útil para fazer gráficos marco como vem descrito na segunda ponta inferior. Nota: Coluna e gráficos de barras já estão 'rodado' versões do outro.

o Série Clustervai exibir vários dados de séries ao longo de uma dimensão terceiro-eixo z /. Gráficos Esta opção só está disponível para a coluna, barra e Cubee é particularmente útil para fazer gráficos estilo Gantt como descrito na primeira dica abaixo.

Dica

Você pode criar um gráfico de Ganttcom barras horizontais mostrando tempo / propriedades de data para diferentes elementos, selecionando um tipo de gráfico Bar e selecionando a opção Cluster Series.Além disso, uma vez criado, a esquerda mais-bar no gráfico pode ser feito 'invisível' colorindo o branco clicando com um dos bares, a seleção de cores no menu que aparece e escolher a cor superior esquerdo da paleta. Além disso, a fronteira para o mais à esquerda bar pode ser feito 'invisível', clicando com o botão direito num dos bares, selecionando Propriedades ... e na guia Series na caixa de diálogo que aparece alterando o efeito de borda para Nenhum e cor ao topo -left cor da paleta.

Dica

Você pode criar um Gráfico Milestonecom pequenas formas mostrando tempo / propriedades de data para diferentes elementos, selecionando um tipo de gráfico Cube e, em seguida, selecionando a Rotate Gráfico e opções Cluster Series.Além disso, uma vez criados, os cubos podem ser alteradas para outras formas, clicando com o botão direito um dos cubos de uma mesma série de dados e selecionando Propriedades ... e na guia Series na caixa de diálogo que aparece para mudar o Bar cilindro ou Cone . Nota: O valor de abertura de fenda também pode ser usada para encolher '' os símbolos no gráfico para reduzir a sobreposição, quanto maior o número a menos haverá sobreposição.

4. no Arquiteturasseção, marque a arquitetura / s que você deseja mapear as propriedades de nível de arquitetura para, em seguida, clique em Próximo.

Nota

Selecionando as propriedades de nível de arquitectura é um passo totalmente opcional e só deve ser usado quando você quiser fazer um mapa explicitamente as próprias propriedades de nível de arquitectura.Uma arquitetura não precisa ser selecionado para então incluir propriedades de componentes ou de conexão na próxima etapa.

5. Selecione os Componentes e Conexõesque você quer no quadro da janela de seleção de elemento padrão E clique em Próximo.

6. Selecione os Propriedadesvocê quer no gráfico e clique em Terminar.

Opções de gráfico

o Incluir propriedades padrão irá mostrar as propriedades herdadas das Normas disponíveis para seleção.

o Propriedades agregadas irá Quantidade de variância entre os valores da série e traçar esses resultados em oposição ao indivíduo próprios valores.Esta opção só está disponível se a opção Series by Propriedade foi selecionado no passo 3 acima.

Dica

As propriedades disponíveis para gráficos dependem dos elementos que você selecionar.

Para salvar um gráfico

Nota

Charts só pode ser salvo se eles só contêm componentes e conexões, todos os quais devem ser a partir de uma única arquitetura dentro do projeto atual.

1. Certifique-se de que você tem um gráfico novo ou existente abertoe você fez as mudanças necessárias.

2. Na barra de ferramentas gráfico, clique no mais à esquerda Salvar Gráficobotão para salvar o gráfico e as alterações de formatação.

3. no Nome do gráficodiálogo que aparece digite um nome para o gráfico e pressione Está bem.

Para exportar um gráfico

1. Verifique se você tem um já existente gráfico aberto.

2. Na barra de ferramentas clique gráfico na segunda da esquerda Salvar como BMPbotão e escolheu o local para o gráfico.

3. Clique Guardar.

Veja também

Analisando sua arquitetura | Visualizando um gráfico de tempo de resposta | Visualizando um gráfico espaço capacidade


Visualizando um gráfico espaço capacidade

Navegação: Analisando sua arquitetura> gráficos personalizados>

Visualizando um gráfico espaço capacidade

Envie seus comentários neste tópico.

Um gráfico de capacidade espacial permite que você veja se sua arquitetura cumpre a capacidade do sistema necessário com respeito a propriedades identificadas durante o processo de análise de requisitos do sistema.

Para visualizar um gráfico espaço capacidade

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada, E que você tem avaliadassua arquitetura.

2. Selecionar Inserir| Gráfico| Gráficos personalizados| Capacidade Espaço. (O Capacidade Espaço Gráfico de Configuraçãode diálogo será exibida.)

3. no Arquiteturasseção, assinalar as arquiteturas que você deseja gráfico, clique em Próximo.

4. no Propriedadesárea, marque as propriedades arquitetônicas que você gostaria incluído como os eixos do gráfico.

5. no Capacidadeárea, para cada propriedade incluída na etapa anterior, selecione se existir qualquer mínimo ou máximo de capacidade e os valores desses limites. Os valores padrão são os valores mínimos e máximos avaliadas para as arquiteturas ou o meta para a propriedade se tiver sido definido.

Para exportar um gráfico espaço capacidade

1. Verifique se você tem um já existente capacidade de gráfico espaço aberto.

2. Na barra de ferramentas gráfico, clique no mais à esquerda Salvar como BMPbotão e escolheu o local para o gráfico.

3. Clique Guardar.

Veja também

Analisando sua arquitetura | Visualizando um gráfico de tempo de resposta


Visualizando um gráfico de tempo de resposta

Navegação: Analisando sua arquitetura> gráficos personalizados>

Visualizando um gráfico de tempo de resposta

Envie seus comentários neste tópico.

Um gráfico de tempo de resposta permite que você veja se suas conexões estão sendo processadas a um ritmo exigido (ou seja, dentro do seu prazo).

Para visualizar um gráfico de tempo de resposta

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada, E que você tem avaliadassua arquitetura.

2. Selecionar Inserir| Gráfico| Gráficos personalizados| Tempo de resposta. (O Tempo de resposta Gráfico Configuraçãode diálogo será exibida.)

3. De Arquiteturasdrop-down lista, selecione a arquitetura que você deseja traçar.

4. no Conexõesárea, marque as conexões que você gostaria de incluir no gráfico.

5. o Tipo de escalaárea, selecione Linearse você deseja que o eixo vertical (tempo de resposta) a ser exibido como uma progressão linear - cada segmento de tempo é alocada uma parte igual do eixo. Selecionar Logarítmicase você deseja que seja exibido como uma progressão logarítmica - cada segmento do eixo representa vez mais longos períodos de tempo a mais acima do eixo que você vá. (A taxa de aumento é determinado pela Basevocê selecionar.)

Response gráfico de tempo escala eixo vertical

Para exportar um gráfico de tempo de resposta

1. Verifique se você tem um já existente resposta gráfico de tempo aberto.

2. Na barra de ferramentas gráfico, clique no mais à esquerda Salvar como BMPbotão e escolheu o local para o gráfico.

3. Clique Guardar.

Veja também

Analisando sua arquitetura | Visualizando um gráfico espaço capacidade


Vendo um terreno estrela de suas arquiteturas evoluíram

Navegação: Analisando sua arquitetura> gráficos personalizados>

Vendo um terreno estrela de suas arquiteturas evoluíram

Envie seus comentários neste tópico.

Uma vez que uma arquitectura tem evoluído e os objectivos são definidos, que podem então ser visualizados e comparados com a arquitectura original usando parcelas estrela. Esta seção descreve como criar e manipular um gráfico da estrela.

Para visualizar um gráfico da estrela de suas arquiteturas evoluíram

1. Verifique se você tem um ABACUS arquivo aberto .

2. Verifique se você tem evoluiu e definir metaspara sua arquitetura conforme destacado no Evoluindo sua arquitetura

3. Selecionar Inserir| Gráfico| a Gráficos personalizadosguia | Estrela Plot.

4. Clique no Terminar botão.

5. o Estrela Plotcom as arquiteturas evoluíram e definir metas serão exibidos. Nota: Os eixos da trama estrela pode ser reposicionada clicando e arrastando os eixos para outra área dentro dos limites do espaço de qualidade enredo estrela.

Nota

A área no lado esquerdo do terreno estrela mostra as configurações da trama estrela exibido. Isto inclui a arquitectura que tem evoluído (neste caso "ABC Ltd As-Is 2010"), Bem como as metas que foram definidas para essa arquitetura. Você vai notar que os objetivos que têm uma marca de seleção ao lado deles são representados como eixos da trama estrela (por exemplo, KPI- Custo, KPI - Qualidade e KPI - Time). Você pode desmarque essas metas em qualquer ponto do tempo para removê-los do enredo estrela.

Os vermelhos e verdes "pontos" que aparecem em seu enredo estrela representam um valor normalizado, conforme determinado pelo melhor e pior valor (esboçado sob Definir metas para a sua arquitectura evoluiu ) Para a arquitetura de alto nível selecionadas e quaisquer evoluções do mesmo. Estes valores estão representados numa Espaço de Qualidade.

Tal como indicado na imagem acima, é claramente visível que a arquitetura original (As-Is 2010) Tem fraca Custo, Enquanto a primeira opção evoluído (To-Be 2011 - Estratégia A) Moveu-se dentro do espaço de qualidade para melhorar a Custo, Qualidade e Tempoobjetivos. Alternativamente, a segunda opção evoluído (To-Be 2011 - Estratégia B) ao mesmo tempo que também tenha melhorado a Custo a magnitude da melhoria é menor do que a de Estratégia A mas ambas as metas de qualidade e de tempo foram melhorou mais do que com a estratégia A.Neste caso, um arquiteto maio escolher A Estratégia sobre Estratégia Bcomo a sua recomendaçãoe evoluir ainda mais essa opção (To-Be 2012 - Estratégia A).

6. Desmarque a Mostrar Evolutionsa caixa de seleção para ocultar a linha (s) que representa a evolução (s) entre o original (por exemplo, As-Is 2010) E evoluído (e.g. To-Be 2011 - EstratégiaA) arquitetura (s).

7. Selecione os Mostrar Sticksa caixa de seleção para exibir a magnitude relativa de cada atributo de qualidade (as metas que foram definidas em cada eixo) para cada arquitetura.

8. Selecione os Mostrar Arquitetura Namescaixa de seleção se você quiser os nomes da arquitectura (s) original e evoluída para aparecer na trama estrela.

Veja também

Analisando sua arquitetura | Visualizando um gráfico de tempo de resposta | Visualizando uma matriz de dispersão de suas arquiteturas evoluíram | Evoluindo sua arquitetura


Visualizando um gráfico de dispersão de suas arquiteturas evoluíram

Navegação: Analisando sua arquitetura> gráficos personalizados>

Visualizando um gráfico de dispersão de suas arquiteturas evoluíram

Envie seus comentários neste tópico.

Uma vez que uma arquitectura tem evoluído e os objectivos são definidos, que podem então ser visualizados e comparados com a arquitectura original utilizando matrizes de dispersão. Esta seção descreve como criar e entender as características de uma matriz de dispersão.

Para exibir uma matriz de dispersão de suas arquiteturas evoluíram

1. Verifique se você tem um ABACUS arquivo aberto .

2. Verifique se você tem evoluiu e definir metaspara sua arquitetura conforme destacado no Evoluindo sua arquitetura

3. Selecionar Inserir| Gráfico| a Gráficos personalizadosguia | Scatterplot Matrix.

4. Clique no Terminar botão.

5. o Dispersãocom a evolução das arquiteturas definidas e metas será exibida.

Nota

A área do lado esquerdo da matriz de dispersão mostra as definições de dispersão da matriz exibida. Isto inclui a arquitectura que tem evoluído (neste caso "ABC Ltd As-Is 2010"), Bem como as metas que foram definidas para essa arquitetura. Você vai notar que os objetivos que têm uma marca de seleção ao lado deles são representados como eixos X e Y da matriz de dispersão (por exemplo, KPI- Custo, KPI - Qualidade e KPI - Time). Você pode desmarque essas metas, em qualquer ponto do tempo para removê-los a partir da matriz de dispersão.

Os pontos azuis que aparecem em seu lote na matriz representam um valor normalizado, conforme determinado pelo melhor e pior valor (esboçado sob Definir metas para a sua arquitectura evoluiu ). Estes valores estão representados numa Espaço de Qualidade.

Dois objectivos definidos são comparados uns contra os outros numa matriz de dispersão e o processo é repetido até que todos os objectivos foram comparados (por exemplo, o primeiro lote de matriz no diagrama acima compara KPI - Custocom o objetivo KPI - Qualidade objetivo. O segundo é Custo contra Tempo eo último lote é Qualidade contra Tempo. As etiquetas de meta relevantes são mostrados no topo e à direita ou cada linha de parcelas.).

6. Selecione os Arquiteturasbotão de opção se você deseja exibir as métricas para as arquiteturas individuais.

7. Selecione os Evolutionsbotão de opção se você deseja exibir as alterações normalizadas a partir da arquitetura original (por exemplo, As-Is 2010) Para a arquitectura evoluída (s) (e.g. To-Be 2011 - Estratégia A e To-Be 2011 - Estratégia B).

Veja também

Analisando sua arquitetura | Visualizando um gráfico de tempo de resposta | Vendo um terreno estrela de suas arquiteturas evoluíram | Evoluindo sua arquitetura


Visualizando um gráfico de bolhas

Navegação: Analisando sua arquitetura> gráficos personalizados>

Visualizando um gráfico de bolhas

Envie seus comentários neste tópico.

Um gráfico de bolha lhe permite comparar até 5 dimensões (ou seja, X, Y, tamanho de bolha / raio, bolha de cor e bolha cor da borda) em uma exibição.

Para visualizar um gráfico de bolhas

1. Verifique se você tem um ABACUS arquivo aberto .

2. Selecionar Inserir| Gráfico| a Gráficos personalizadosguia | Bolha Gráfico.

3. no Arquiteturasseção, assinalar as arquiteturas (se houver) que deseja mapear, clique em Próximo.

4. Selecione os Componentes e Conexõesque você deseja na tabela (se houver) do janela de seleção de elemento padrão E clique em Próximo.

5. Selecione os Eixo das abcissaspropriedade, em seguida, clique em Próximo.

Nota

Somente Integer, Decimal, data / hora, booleano e propriedades da Lista de pode ser usado para o eixo x. Além disso, inteiro, decimal e Data / Hora propriedades são plotados da esquerda para a direita ao longo do eixo dimensionado de acordo com o valor da propriedade, no entanto, booleanos e Lista de propriedades são simplesmente plotado da esquerda para a direita na ordem exata (ou em pela ordem inversa, se a opção para inverter a ordem é verificada) definido para a propriedade, independentemente de seus valores. Por exemplo. Baixo | Médio | Alta ou 1, 2, 4, 8, 16.

6. Selecione os Eixo Ypropriedade, em seguida, clique em Próximo.

Nota

Somente Integer, Decimal, data / hora, booleano e propriedades da Lista de pode ser usado para o eixo Y. Além disso, inteiro, decimal e Data / Hora propriedades são plotados-baixo para cima ao longo do eixo dimensionado de acordo com o valor da propriedade, no entanto, booleanos e Lista de propriedades são simplesmente plotado-baixo para cima na ordem exata (ou em pela ordem inversa, se a opção para inverter a ordem é verificada) definido para a propriedade, independentemente de seus valores. Por exemplo. Baixo | Médio | Alta ou 1, 2, 4, 8, 16.

7. Selecione os o tamanho da bolha / raiopropriedade, em seguida, clique em Próximo.

Nota

Somente Integer, Decimal, Boolean e propriedades da Lista de pode ser usado para o tamanho de bolha / raio. Além disso, Integer e propriedades decimais resultar em um tamanho da bolha / raio escalado de acordo com o valor da propriedade, no entanto, booleanos e Lista de Propriedades resultar em aumentos passo iguais da bolha tamanho / raio na ordem exata (ou na ordem inversa se a opção para inverter a ordem é verificada) definido para a propriedade, independentemente de seus valores. Por exemplo. Baixo | Médio | Alta ou 1, 2, 4, 8, 16.

8. Selecione um bolha cor fixa ou associar uma propriedade com a cor da bolhaE clique em Próximo.

Nota

Somente Integer, Decimal, Boolean e propriedades da Lista de pode ser usada para a cor bolha. Além disso, Integer e propriedades decimais resultar em uma cor bolha dentro da gama escolhida dimensionado de acordo com o valor da propriedade, no entanto, Booleanas e lista Propriedades resultar em aumentos passo iguais da cor bolha dentro da gama escolhida na ordem exacta que foi definida para a propriedade, independentemente de seus valores. Por exemplo. Baixo | Médio | Alta ou 1, 2, 4, 8, 16.

9. Selecione nenhuma cor da borda bolha ou associar uma propriedade com a cor da borda bolhaE clique em Terminar.

Nota

Somente Integer, Decimal, Boolean e propriedades da Lista de pode ser utilizado para a cor da borda bolha. Além disso, Integer e propriedades decimais resultar em uma cor de borda bolha dentro da faixa escolhida escalado de acordo com o valor da propriedade, no entanto, booleanos e Lista de Propriedades resultar em aumentos passo iguais de a cor da borda bolha dentro da faixa escolhida na ordem exata definidos para a propriedade, independentemente de seus valores. Por exemplo. Baixo | Médio | Alta ou 1, 2, 4, 8, 16.

Gráfico de bolhas

Para salvar um gráfico de bolhas

Nota

Gráficos de bolhas só podem ser salvos se eles só contêm componentes e conexões, todos os quais devem ser a partir de uma única arquitetura dentro do projeto atual.

1. Certifique-se de que você tem um gráfico novo ou existente bolha abertoe você fez as mudanças necessárias.

2. Na barra de ferramentas gráfico, clique no mais à esquerda Salvar Gráficobotão para salvar o gráfico e as alterações de formatação.

3. no Nome do gráficodiálogo que aparece digite um nome para o gráfico de bolhas e pressione Está bem.

Para exportar um gráfico de bolhas

1. Verifique se você tem abrir um gráfico de bolhas existente.

2. Na barra de ferramentas clique gráfico na segunda da esquerda Salvar como BMPbotão e escolheu o local para o gráfico.

3. Clique Guardar.

Veja também

Analisando sua arquitetura


Arquitetura Diff e sincronização

Navegação: Analisando sua arquitetura>

Arquitetura Diff e sincronização

Envie seus comentários neste tópico.

Quando você tem 2 ou mais arquiteturas, seja como evoluções ou arquiteturas de linha de base, você pode visualmente 'diff' as duas arquiteturas usando catálogo ou Diagrama de Comparação ou o O recurso de arquitetura Diff. Isto é especialmente útil para descobrir / re-descobrir as mudanças precisas feitas a partir de uma arquitetura para outro como você evoluir arquitecturas e desenvolver roteiros em ABACUS.

Para mostrar o 'dif "com um outro por meio de um diagrama de arquitetura

1. Verifique se você tem um ABACUS arquivo aberto .

2. Certifique-se de ter pelo menos 2 arquiteturas no projeto.

3. Abra o diagrama que você deseja comparar com outra arquitetura.

4. Clique no botão "Compare este diagrama com o conteúdo de uma outra arquitetura 'na barra de ferramentas Diagrama.

5. Escolha a outra arquitetura a partir da lista drop-down para comparar.

6. Você pode filtrar o que diferenças são mostradas clicando no botão "diferenças" na barra de ferramentas Diagrama e opções desmarcando, por exemplo, Mudou / Adicionado / Unknown e Indeterminado / Sincronização Recomendado/ Mantenha Recomendado.

Nota

Componentes e conexões no diagrama será destaque na vermelho, verde ou roxo onde há diferenças entre o conteúdo que é visível no diagrama atual eo conteúdo na outra arquitetura. Vermelho é usado onde é recomendável sincronizar as diferenças (ver abaixo), Verde é utilizado onde não é recomendado para sincronizar as diferenças, que é mantê-los (ver abaixo) e Roxo ABACUS é usado onde não pode fazer uma recomendação sobre a sincronização as diferenças (veja abaixo). Apenas o conteúdo visível no diagrama é comparado por isso, se uma anotação está mostrando um valor de propriedade de repositório e que valor é alterado o componente dado ou conexão será mostrado na vermelho fraco, verde fraco ou roxo fraco e um símbolo '*' mostrado no canto superior esquerdo para componentes, no entanto, se algum outro valor da propriedade repositório subjacente mudou isso não está sendo mostrado em uma anotação, em seguida, nenhuma indicação será dado. Conteúdo que ocorre no diagrama atual, mas nenhuma correspondência for encontrada na arquitetura comparação será mostrado na forte vermelho, verde forte ou roxo fortee um símbolo '+' mostrada na parte superior esquerda para componentes. Correspondência é feito pelo tipo e nome de tal modo que se o tipo ou nome do componente ou conexão mudou na outra arquitetura nenhuma correspondência será encontrada componente. Como não há nenhuma maneira de determinar de forma fiável se o conteúdo adicionais da outra arquitectura teria sido mostrado no diagrama de corrente (por exemplo, uma interface adicional entre 2 componentes, como mostrado abaixo no diagrama da arquitectura comparação à direita), estas diferenças não são mostrados para os diagramas (eles são mostrados para catálogos conforme abaixo). Pairando sobre cada item alterado irá mostrar a diferença na dica. Pairando sobre o símbolo '*' no canto superior esquerdo do diagrama fornece um resumo das mudanças (ou sem alterações) entre o conteúdo do diagrama eo conteúdo da outra arquitetura.

Cor Legend

· Verde indica itens que não é recomendado para sincronizar as diferenças, que é mantê-los.

· Vermelho indica itens que são recomendados para sincronizar as diferenças.

· Roxo indica ABACUS itens onde não pode fazer uma recomendação sobre a sincronização as diferenças.

Para sincronizar ('sync') o conteúdo de uma arquitetura com outro através de um diagrama

1. Verifique se você tem um ABACUS arquivo aberto .

2. Certifique-se de ter pelo menos 2 arquiteturas no projeto.

3. Abra o diagrama que você deseja comparar com outra arquitetura.

4. Clique no botão "Compare isso Catálogo para o conteúdo de uma outra arquitetura 'na barra de ferramentas Diagrama.

5. Escolha a outra arquitetura a partir da lista drop-down para comparar.

Nota

Veja acima para o caminho ABACUS mostra o 'diff' entre os 2 arquiteturas no catálogo. Em particular, como Vermelho é utilizado onde érecomendada para sincronizar as diferenças, Verde é utilizado onde é nãorecomendada para sincronizar as diferenças e Roxo ABACUS é usado onde não pode fazer uma recomendação sobre a sincronização as diferenças.

6. Direito do mouse no elemento de diagrama (ou elementos usando a tecla Shift ou a tela diagrama para sincronizar todos) que apresenta um "diff" e selecione o item de menu Sync.

Nota

Quaisquer alterações de sincronização só será aplicado à arquitectura que o catálogo actualmente em foco pertence. Para aplicar as alterações para a outra arquitetura que você deve usar um catálogo na outra arquitetura. Além disso, os usuários só será capaz de aplicar as alterações de sincronização se tem permissão para fazê-lo .

Nota

Dependendo de onde você clica com o botão direito no item de menu irá exibir orientação sobre o que exatamente vai ser sincronizado. Por exemplo. Direita-clicando em um único componente no diagrama só irá sincronizar o componente. Clicando com o botão direito Considerando que a lona diagrama e selecionando Sincronizar tudo irá sincronizar todas as diferenças actualmente mostrados.

Para mostrar o 'dif "com um outro por meio de uma arquitectura catálogo

1. Verifique se você tem um ABACUS arquivo aberto .

2. Certifique-se de ter pelo menos 2 arquiteturas no projeto.

3. Abra o catálogo que você deseja comparar com outra arquitetura.

4. Clique no botão "Compare isso Catálogo para o conteúdo de uma outra arquitetura 'na barra de ferramentas Catálogo.

5. Escolha a outra arquitetura a partir da lista drop-down para comparar.

6. Você pode filtrar o que diferenças são mostradas clicando no botão "diferenças" na barra de ferramentas Diagrama e opções desmarcando, por exemplo, Mudou / Adicionado / Unknown e Indeterminado / Sincronização Recomendado/ Mantenha Recomendado.

Nota

As células do catálogo será destaque na vermelho, verde ou roxo onde há diferenças entre o conteúdo do catálogo atual eo conteúdo correspondente na outra arquitetura. Vermelho é usado onde é recomendável sincronizar as diferenças (ver abaixo), Verde é utilizado onde não é recomendado para sincronizar as diferenças, que é mantê-los (ver abaixo) e Roxo ABACUS é usado onde não pode fazer uma recomendação sobre a sincronização as diferenças (veja abaixo). Apenas as linhas e colunas visíveis no catálogo são comparados por isso, se existe uma diferença de uma fileira para além das linhas mostradas correntemente ou um valor de uma coluna que não está a ser mostrada uma diferença, então tem nenhuma diferença será indicado. Sempre que o valor em uma célula individual é diferente com a célula correspondente na arquitetura comparação a borda da célula será destacado. O seletor de cabeçalho da coluna e linha também será protegido em roxo fracoe mostrado com um símbolo '*'. Estes símbolos '*' pode ser clicado para saltar para a próxima diferença na coluna ou linha, respectivamente. As linhas que ocorre no catálogo atual, mas nenhuma correspondência for encontrada na arquitetura comparação será mostrado com um símbolo '+' no seletor de linha à esquerda e à fronteira de toda a linha será destacado. As linhas que teriam ocorrido na versão da arquitetura comparação do catálogo (ou seja, com os mesmos filtros, etc), mas nenhuma correspondência for encontrada na arquitetura atual será mostrado com um símbolo - no selector de linha à esquerda, o limite de '' a linha inteira será realçada e os conteúdos células fileiras inteiras serão mostrados em roxo fracoe feriu-through, por exemplo, Oito horas - seis horas. Correspondência é feito pelo tipo e nome de tal modo que se o tipo ou nome do componente ou conexão mudou na outra arquitetura nenhuma correspondência será encontrada componente. Pairando sobre cada item alterado irá mostrar a diferença na dica. Pairando sobre o símbolo '*' no canto superior esquerdo do diagrama fornece um resumo das mudanças (ou sem alterações) entre o conteúdo do diagrama e os conteúdos da outra arquitetura.

Cor Legend

· Verde indica itens que não é recomendado para sincronizar as diferenças, que é mantê-los.

· Vermelho indica itens que são recomendados para sincronizar as diferenças.

· Roxo indica ABACUS itens onde não pode fazer uma recomendação sobre a sincronização as diferenças.

Para sincronizar ('sync') o conteúdo de uma arquitetura com outro através de um catálogo

1. Verifique se você tem um ABACUS arquivo aberto .

2. Certifique-se de ter pelo menos 2 arquiteturas no projeto.

3. Abra o catálogo que você deseja comparar com outra arquitetura.

4. Clique no botão "Compare isso Catálogo para o conteúdo de uma outra arquitetura 'na barra de ferramentas Catálogo.

5. Escolha a outra arquitetura a partir da lista drop-down para comparar.

Nota

Veja acima para o caminho ABACUS mostra o 'diff' entre os 2 arquiteturas no catálogo. Em particular, como Vermelho é utilizado onde érecomendada para sincronizar as diferenças, Verde é utilizado onde é nãorecomendada para sincronizar as diferenças e Roxo ABACUS é usado onde não pode fazer uma recomendação sobre a sincronização as diferenças.

6. Clique com o botão, coluna celular ou linha de título (ou vários itens usando a tecla Shift ou Ctrl + A para tudo) que apresenta um "diff" e selecione o item de menu Sync.

Nota

Quaisquer alterações de sincronização só será aplicado à arquitectura que o catálogo actualmente em foco pertence. Para aplicar as alterações para a outra arquitetura que você deve usar um catálogo na outra arquitetura. Além disso, os usuários só será capaz de aplicar as alterações de sincronização se tem permissão para fazê-lo .

Nota

Dependendo de onde você clique com o botão direito (ou seja, uma célula, coluna ou cabeçalho da linha), o menu será exibido orientação sobre o que exatamente vai ser sincronizado. Por exemplo. Clicando com o botão direito uma única propriedade ou célula componente ligado no catálogo só irá sincronizar essa propriedade ou componente ligado. Considerando botão direito do mouse uma linha de título (ou títulos usando turno) irá sincronizar toda a linha (ou linhas). Clicando com o botão direito num cabeçalho de coluna irá sincronizar todas as diferenças nessa coluna.

Para ver uma 'diff'de 2 todo arquiteturas

1. Verifique se você tem um ABACUS arquivo aberto .

2. Certifique-se de ter pelo menos 2 arquiteturas no projeto.

3. Selecionar Ferramentas| Arquitetura Diff ....

4. Na caixa de diálogo que aparece, selecione a primeira / From e segunda / Para arquiteturas para comparar.

5. Clique no Está bem botão.

Arquitetura Diff

Cor Legend

· Verdeindica que o nó foi adicionado na segunda / Para arquitetura.

· Vermelhoindica que o nó foi eliminado na segunda / Para arquitetura.

· Azulindica que o nó apresenta diferentes características (por exemplo, propriedades ou padrões) no segundo / à arquitetura.

· Amareloindica que o nó tem diferenças em suas crianças na segunda / Para a arquitetura de modo que o nó deve ser expandida.

Nota

Você pode botão direito do mouse e "Mostrar no Explorer" em todos os nós para ver detalhes e mais informação é dada sobre as diferenças no painel de Resumo de Diferenças quando um nó é selecionado.

Veja também

Analisando sua arquitetura | Visualizando um gráfico de tempo de resposta | Visualizando uma matriz de dispersão de suas arquiteturas evoluíram | Evoluindo sua arquitetura


Simulando sua arquitetura

Navegação: simulando sua arquitetura>

Simulando sua arquitetura

Envie seus comentários neste tópico.

Depois de ter preenchido e analisados ​​sua arquitetura, você está pronto para usar ABACUS para determinar se sua arquitetura irá satisfazer as suas necessidades quantitativas. Isto exige simulação. Para simular sua arquitetura você deve primeiro decidir sobre o tipo de informação que você quer descobrir. Estes tipos de informação são muitas vezes referidos como indicadores chave de desempenho KPIs, ou. Por exemplo, você quer analisar o desempenho, capacidade de evoluir, e abertura, ou você quer para se reunir métricas como custo total de propriedade. Toda esta informação pode ser revelada de alguma forma. Depois de ter esses dados, você será capaz de analisar sua arquitetura em uma variedade de formatos gráficos (ou analisar os novos valores diretamente).

Há três opções para a simulação de sua arquitetura:

· Métricas simples ;

· Simuladores de pré-construídos ; ou

· Scripting .

Métricas simples

Cada componente em sua arquitetura tem propriedades - muitos dos quais podem ser personalizado para seu aplicativo de ABACUS. Estas propriedades representam várias características dos componentes. Em alguns casos, simplesmente coletando essas métricas (para construir KPI) pode ser suficiente para dizer-lhe informações importantes sobre a sua arquitectura. Por exemplo, KLOCS, ou milhares de linhas de código, têm sido amplamente utilizados como uma medida de complexidade. Em outros casos, você pode querer exportar os dados e analisá-lo usando outra ferramenta. Além disso, você pode querer coletar propriedades após a realização de um outro tipo de simulação.

As propriedades podem ser coletadas através do processo de agregação . Agregação adiciona especificados sub-unidades para um total o que se reflecte no componente progenitor. Agregação funciona apenas em componentes que contêm sub-componentes.

Simuladores pré-construídos

Há cinco simuladores pré-construídos que podem ser utilizados com ABACUS. Esses são:

· Atuação;

· Modularidade;

· Custo Total de Propriedade (TCO);

· Abertura; e

· Confiabilidade.

Nota

ABACUS destacará automaticamente qual destes simuladores precisam ser re-executado através de Vermelho realces na Barra de ferramentas Simulation .

Scripting

Scripting oferece a flexibilidade para simular a sua arquitetura de formas personalizadas. De escrever scripts você pode realizar simulações além da atual capacidade construída em de ABACUS. Todo o modelo de objeto ABACUS está disponível para o mecanismo de script, então você está limitado apenas pela sua capacidade de escrever scripts!

Script de Visual Basic é a linguagem de script suportada por ABACUS, uma vez que fornece recursos de programação essenciais em um formato razoavelmente simples.

Veja também

Exportando sua arquitetura | Propriedades de agregados | Escrever scripts


Scripts de escrita

Navegação: simulando sua arquitetura>

Scripts de escrita

Envie seus comentários neste tópico.

O Script Editor é um utilitário simples e funcional para escrever e executar VB ou C # roteiro contra o ABACUS arquivo atualmente aberto(Bibliotecas não são suportados no scripting). Ele tem o costume de arquivos abrir, fechar e salvar os comandos, para que você possa salvar e recuperar os scripts que você escreve. Ele também tem uma corrida e debug instalação de base. O Gerenciador de Script permite que você execute facilmente os vários scripts que você escreveu, colocando um menu de itens para eles diretamente no menu Ferramentas.

Para acessar o Editor de scripts

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Selecionar Ferramentas | Script Editorea janela Script Editor será aberta. Então, qualquer um;

3. Abrir um script existente via Arquivo | Aberto nos menus do Editor de Script,

ou

3. Abrir um script exemplo, através da Exemplo item nos menus do Editor de Script,

ou

3. Definir o idioma padrão para qualquer VB ou C # através do Idioma item nos menus do Editor de Script,

ou

3. Ajuda específica aberta a via scripting Socorro item nos menus do Editor de Script

Ao escrever scripts, você deve aderir a quer o VB ou C # sintaxeconforme a definição no item Idioma nos menus do Editor de Script.

NOTA:

· Para utilizar as funções padrão como VB MsgBox ()você deve incluir o Imports Microsoft.VisualBasicdeclaração no início do seu script. Este não era necessário antes de versão 3.0 do ábaco.

· Esta ajuda não inclui informações sobre como escrever um script VB, nem contém uma referência VB. Sinta-se livre para escrever seus scripts em seu IDE ou editor favorito, em seguida, copiar e colá-los no Editor de scripts.

Quando você começar o Script Editor, o Editor de scripts estará vazia. Você pode acessar um script esqueleto através do menu Exemplos. A primeira vez que iniciar o Editor de scripts, você deve executar o esqueleto de modelo para ver se funciona. Além disso, há dois scripts de exemplo que podem ser acessados ​​através do menu Exemplos.

Para escrever um script útil que você vai precisar fazer referência a ABACUS ObjectModel. Está disponível para o script, incluindo o Importações ABACUS.ObjectModeldeclaração na cabeça de seu script. A referência completa para todo o modelo de objeto ABACUS está incluído com o Editor de scripts. Você pode encontrá-lo, selecionando Ajuda | Conteúdoa partir da janela do Editor de scripts.

O editor de script inclui muitas características úteis para escrever scripts, incluindo AutoComplete como mostrado na imagem abaixo. No entanto, para uma experiência de usuário ainda mais rico MS Visual Studio pode ser integrado com ABACUS e instruções detalhadas estão disponíveis Aqui .

Script Editor com AutoComplete

Para usar o Gerenciador de Script

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Selecione Ferramentas | Gerenciador de Script.

3. Clique no Adicionare um ícone AbertoAparece a janela.

4. Navegue até o Script ABACUS (.abacusscript, .vb Ou .cs) Arquivo que você deseja adicionar ao menu Ferramentas.

5. Clique Está beme uma referência para o script será mostrado na janela do Gerenciador de Script. Digite o nome para o script como você deseja que ele apareça no menu Ferramentas. Nota: A janela do Gerenciador de scripts pode ser redimensionada para ver o caminho completo, se necessário.

6. Repita os passos 3-5para criar links para mais scripts ábaco.

7. Clique Fecharpara fechar o Gerenciador de scripts e observe que o script ABACUS (s) aparece agora no menu Ferramentas.

Para executar um script

Ou;

1. Open, digitar, ou copiar e colar no script que deseja executar, então ele é exibido na janela principal do Script Editor.

2. Clique no Executar botão.

3. Se o seu script contém erros, a seção Descrição de erro na parte inferior do Editor de scripts irá listar os detalhes, incluindo os números de linha. NOTA: Cada erro individual na seção Descrição de erro pode ser clicado duas vezes para levá-lo para a linha correspondente no script.

- ou -

1. Selecionar Ferramentase, em seguida, o Nome ABACUS Script como item de menu criado com o Gerenciador de Script.

2. Se o seu script contém erros, o Script Editor será aberta com o conteúdo do script mostrado na janela principal (destacado na linha do primeiro erro) e da seção Descrição de erro na parte inferior do Editor de scripts irá listar os detalhes ou o erro (s), incluindo os números de linha. NOTA: Cada erro individual na seção Descrição de erro pode ser clicado duas vezes para levá-lo para a linha correspondente no script.

Erros de script de compilação

Erros de compilação ocorrem quando a sintaxe do código de script não está correto. Estes erros poderão mostrar-se na parte inferior da janela na secção de erro, com uma descrição do erro, e um número de linha. É o número de linha que distingue um erro de compilação de um erro de execução (ver abaixo), o que não terá um número de linha. Erros de compilação pode ser clicado duas vezes para ir para e realçar a linha específica em questão.

Erros de tempo de execução de scripts (Importante)

Erros de execução ocorrer após o código de script foi compilado com sucesso, sem erros, mas ocorre um erro em tempo de execução (ver exemplos ainda mais para baixo). Erros de execução são importantes, pois podem resultar em modelos corrompidos, quando os objetos criados e referenciados por outros objetos no modelo, não são eles próprios parte do modelo (geralmente porque um erro de execução ocorreu antes do código que teria colocado-los no modelo em algum lugar, foi executado).

Se o script cria objetos a serem adicionados ao modelo, você pode evitar a corrupção causada por um erro de execução, salvando seu script, fechando scripting, e realizando uma desfazer as alterações que foram criados pelo script (se a execução do script não foi concluída normalmente ). No entanto, há também outras maneiras de evitar qualquer tipo de corrupção que ocorrem (veja abaixo). Nota: Qualquer script que simplesmente ler a partir do modelo e não escrevem para ele, são seguros e não irá causar qualquer problema, independentemente de erros de execução ocorrer durante a sua execução.

Para evitar a corrupção, ao escrever o código de script que está criando objetos e adicioná-los ao modelo de objeto, sugere-se que os objetos são adicionados ao modelo mais rapidamente possível se eles são referenciados por outros objetos.

Por exemplo, se você está criando uma nova conexão, e 2 novos componentes, e em seguida, anexá-los juntos, o melhor é criar o primeiro componente, adicioná-lo ao modelo, em seguida, o segundo e adicioná-lo, e em seguida, criar a conexão e adicioná-lo e, finalmente, criar anexos. Isto significa que, se houvesse um erro de execução que interrompe a execução do script, todos os objetos que são necessários para estar na ObjectModel antes de um anexo é criado, são no modelo. A corrupção pode ocorrer se, por exemplo, apenas a conexão tinha sido adicionado, os anexos feito, e, em seguida, ocorreu um erro de execução antes do script finalmente adicionou os novos componentes ao model.Corruption pode ocorrer sempre que um objeto que é referenciado por outro objeto no o ObjectModel, não é por si só no ObjectModel.

Exemplo erros de tempo de execução incluem:

· Referência de objeto não definida para uma instância de um objeto - isso ocorre quando uma variável de objeto é uma referência nula, e um método ou propriedade no objeto está sendo usado. Referências nulas podem ser verificados por «Se objectVariable é nada Então ... '

· Índice estava fora dos limites da matriz - isso ocorre quando uma matriz está sendo acessado com um índice que está fora dos limites - por exemplo, menos do que ou igual a 0 ou superior ao comprimento / Count da matriz. Array ou comprimento coleção pode ser verificado pelas propriedades .length ou .Count respectivamente.

· Sem exceção permissão - Você não tem permissão para ... - este ocorre se você não tem permissão para fazer a mudança dada

· Exceção chave primária - Duplicate / Faltando Nome / ID - este irá ocorrer se for feita uma alteração para um atributo exclusivo que está em conflito com outro objeto. Por exemplo. Arquiteturas deve ser exclusivo por nome, da mesma forma com as Normas.

· Integridade Referencial Exceção - A definição de um campo de referência para um objeto que não é válido. Por exemplo. acrescentando "nada" ou nulo como uma criança de muitas das coleções no ObjectModel.

· Comprimento Zero Exceção - isso pode ocorrer se você tentar definir o nome de um objeto para uma cadeia vazia. A maioria dos objetos exigem que seus nomes a ter pelo menos um personagem.

Instruções Imports

Note-se que no início dos scripts esqueleto há afirmações como Importações ABACUS.ObjectModel. Estas declarações não irá incluir uma dll que já não está referenciado pelo script - o seu objectivo é fornecer um 'atalho' para ter que especificar o nome completo de uma classe.

Por exemplo, para declarar uma variável do tipo CComponent (representando um componente em ABACUS), com o Importações ABACUS.ObjectModeldeclaração para a parte superior do script, só iria exigir que ele seja declarado como comp dim como CComponent, Porque o compilador sabe olhar no namespace ABACUS.ObjectModel para a classe CComponent. Sem a declaração importações, que teria de ser declarado como dim comp como ABACUS.ObjectModel.CComponent. Um conjunto (como mscorlib.dll, ou System.Windows.Forms.dll) pode conter mais de um namespace - a declaração Imports é para esses espaços para nome, e não para as próprias montagens. O conjunto ABACUS.ObjectModel.dll só tem o namespace ABACUS.ObjectModel único acessível através de scripts.

Assembléias automaticamente referenciados

As seguintes DLLs são referenciados automaticamente por Scripting:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.visualbasic.dll (implicitamente referenciados pelo compilador)

· ABACUS.ObjectModel.dll

Para fazer referências adicionais, quer outras montagens .NET, ou suas próprias montagens, consulte a seção seguinte no #Declaração ImportDLL.

#Declaração ImportDLL

A partir de ABACUS 3.1, você pode referenciar conjuntos adicionais que você pode exigir para a criação de scripts com o uso do #Declaração ImportDLL. Por exemplo, se você quiser acessar um DLL costume de vocês e utilizar as funcionalidades nele, você iria colocá-lo no diretório ABACUS e incluir a declaração como a primeira linha (s) em seu script. Se é uma dll .net, então normalmente você não precisa digitar o caminho inteiro, apenas o DLL.

· #ImportDLL C: \ Arquivos de Programas \ Avolution \ ABACUS \ yourdll.dll

· #ImportDLL System.XML.dll

Algumas outras coisas a nota:

1. Porque as DLLs precisa ser encontradas em compilação e execução, isso restringe personalizados (não .net) DLLs para serem colocados na pasta do programa ABACUS somente.

2. #ImportDLL declarações devem ser a primeira linha (s) de um script - se você tem 5 declarações, então eles devem estar nos primeiros 5 linhas do script

3. Um #Declaração ImportDLL colocado em qualquer lugar, mas as primeiras linhas do script (por exemplo, se ele foi colocado depois de um comentário ou instrução importações) não irá funcionar corretamente e / ou pode causar erros de compilador não relacionados.

#ImportDLL com as Assembléias Escritório

Se você tiver o Microsoft Office instalado, e seu script requer os conjuntos do Office Interop, é possível fazer referência a eles simplesmente usando #ImportDLL com o nome do assembly (conforme listado abaixo, por exemplo. #ImportDLL Excel). Usando este método tem a vantagem de que um caminho absoluto DLL não tem de ser usado, de modo que o roteiro é mais portátil (deve funcionar em ambos Office 2003 e 2007 sem editar o script).

Quando você usa esse recurso, o GAC (Global Assembly Cache) é procurado para a assemblagem de interoperabilidade, eo script compila com o caminho para que a montagem se encontrado. Se não for encontrado, o script irá verificar o diretório do programa ABACUS (que contém o Excel e Visio interops apenas). Se a interoperabilidade solicitada não se encontra por esta altura, um aviso será mostrado.

Os interops normalmente não são instalados no GAC se você tiver instalado o Microsoft Office antes de instalar o .NET Framework (que faz parte da instalação completa do ABACUS). Você pode instalá-los executando a opção Mudar para o Microsoft Office a partir de Adicionar / Remover Programas, e escolha as opções de programabilidade .NET. Para mais informações, consulte este artigo no MSDN.

Os conjuntos para os quais este atalho é suportados são:

· Acesso

· Access.Dao

· Sobressair

· Gráfico

· MSProject

· Perspectiva

· OutlookViewCtl

· OWC11

· Power Point

· Editor

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Palavra

It não é totalmente claro se todos os conjuntos acima são úteis, quartos havebeen incluídos neste regardeless característica como alguns usuários Fev têm uma necessidade, mesmo para os conjuntos obscuros.

Consulte também

Simulando sua arquitetura


Usando Macros

Navegação: simulando sua arquitetura>

Usando Macros

Envie seus comentários neste tópico.

Se você executar uma tarefa repetidamente no ABACUS, você pode automatizar a tarefa usando uma macro. Por conseguinte, uma macro ábaco é uma série de operações gravadas que podem ser reproduzidos em qualquer momento.

Gravando uma Macro

1. Selecione Ferramentas | Gravar Macroou, alternativamente, prima Alt + F10.

2. Iniciar as operações que você deseja gravar realizando.

Aviso

Neste momento, existem alguns problemas conhecidos com a gravação de macros. Por favor, tome isso em consideração durante a gravação de suas macros:

· Atualmente macros apenas gravar suas teclas, Microsoft Windows rato-movimentos e cliques do mouse. No entanto, devido a limitações com o próprio gravador de macro, existem algumas batidas de tecla que não são sempre registadas. Esses incluem:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Começar]

· [F1] a [F12]

· Portanto, é recomendável que você verificar que um atalho de teclado é gravado pelo gravador de macro antes de gravar uma grande seqüência de eventos que podem dependem desse trabalho atalho de teclado.

· Atualmente, devido às limitações com o gravador de macros, menus de contexto não são tratadas adequadamente por ABACUS quando eles são abertos por uma ação gravada pelo gravador de macro. Quando você abre um menu de contexto, você deve executar uma das funções listadas no menu de contexto através do menu de contexto, caso contrário, o menu de contexto pode permanecer aberta durante a reprodução, o que pode levar a ações ou ações não intencionais que podem causar erros no ABACUS.

· Observe que os métodos normais de fechar um menu de contexto (por exemplo, pressionando [Esc] no teclado, ou a esquerda clicando em outro lugar na tela) não pode realmente fechar o menu de contexto durante a reprodução de uma macro.

Dica

Em caixas de diálogo, em vez de usar cliques do mouse, recomenda-se usar a tecla Tab para percorrer os controles disponíveis e as teclas do cursor para selecionar itens de menu suspenso ou opções de botão de rádio ea barra de espaço para selecionar / de-select de seleção caixas.

Para parar de gravar uma macro

1. pressione Alt + F9ou, alternativamente, selecione Ferramentas | Parar Macro.

2. No Salvar Macro Como browse diálogo para uma localização e escolha um nome de arquivo ABACUS macro (arquivo .abacusmac) e clique em Salvar.

Nota

Usando Ferramentas| Parar Macroincluirá essa operação no macro gravada. Portanto, é recomendável que os usuários se tornar proficientes em usar as opções de teclas Alt + função para trabalhar com macros de forma a não incluir as operações de macro indesejados nas próprias macros.

Dica

Como as macros não estão atualmente editável é recomendado para gravar longas tarefas como uma série de macros separadas usando F9 "pares" Alt + F10 / Alt +.

Para reproduzir uma macro gravada

1. Selecione Ferramentas | Macro Reproduçãoou, alternativamente, prima Alt + F8.

2. Na Abrir browse diálogo Macro para uma localização e escolha um nome de arquivo ABACUS macro (arquivo .abacusmac) e clique em Abrir.

Aviso

Ao abrir uma macro ABACUS, se você clicar duas vezes em um arquivo de macro a partir do diálogo de navegação para abri-la, o gravador de macro pode segure o botão esquerdo do mouse em um estado esquerda-clicado até há gravados clique esquerdo substitui essa estaduais.

Nota

A velocidade de reprodução da macro pode ser definida na guia Geral em Ferramentas| Opçõesou como Normal (padrão), rápido ou lento. Ambos velocidades rápida e lenta de reprodução não são recomendados como eles vão reproduzir os macros gravados em cerca de 100 vezes e 1/100 em tempo real, respectivamente. Velocidade de reprodução normal continua a reproduzir a macro cerca de 30% mais rápido do que a velocidade registrada por isso é recomendado durante a gravação para fazer uma pausa por um curto período de tempo após quaisquer tarefas de processamento longos para assegurar que a reprodução da próxima operação não é executada antes da tarefa de processamento tem concluída.

Para parar de reproduzir uma macro gravada

1. pressione Alt + F9.


Simulando Desempenho

Navegação: simulando sua arquitetura> Simuladores>

Simulando Desempenho

Envie seus comentários neste tópico.

Antecedentes

O avaliador de arquitetura para desempenho é um simulador de eventos discretos que funciona através da simulação do fluxo de mensagens (ou tokens) em toda a arquitetura. A teoria por detrás desta investigação é derivado feito pela University of Technology, Sydney, e baseia-se Modelos em camadas de rede Queuing(LQNM), Temporário e coloridos Petri-Nets(TCPN) e Diagramas de ciclo de atividade(ACD).

Na simulação desempenho ABACUS, processamento em um componente é impulsionado em grande parte por mensagens passadas para ele a partir de outro componente. Os princípios subjacentes a esta técnica pode ser entendida em quatro partes principais:

1. o -centric mensagemcomunicação é modelado em ABACUS usando lógico(ou indireta) conexões. Conexões lógicas definir o comportamento (freqüência e dados) das mensagens passadas entre os componentes. Um bom exemplo de conexões lógicas seria a sequência flui entre dois (2) processos de negócios ou as interfaces lógicas entre dois (2) aplicações.

2. Mensagens lógicos são transportados para o seu destino através hierarquia(tais como as raias de recursos) ou diretoconexões (tais como fios física). Para fazer isso, eles podem ser encaminhados para cima, em frente e para trás para baixo na hierarquia (uma abordagem em camadas) para seguir o caminho direto.

3. A fidelidade do modelo pode ser ajustado para se adequar. Por exemplo, um processo pode ser dividido até ao momento de modo a que cada processo e função primária tem uma pegada de processamento separado. Alternativamente, pode ser suficiente ter apenas um valor para todo o processo, o que reflecte médiaresposta a uma mensagem de processamento.

4. O real processamentoé realizada apenas por componentes que têm (ou são) um processador. Um processador é uma coisa genérica, e poderia ser uma CPU, uma pessoa, uma unidade organizacional ou qualquer outra coisa que é capaz de realizar o trabalho. Por exemplo, um processo de negócio não faz qualquer processamento real; isso é feito pelo primeiro "processador" que localiza, quer na sua hierarquia de matriz (se uma notação é usada raia) ou a sua rede de processamento (se uma notação de processamento distribuído é usado).

A avaliação é realizada através da simulação do (especificados) o tráfego no sistema, de tal modo que cada conexão é simulada, pelo menos, uma vez. Horários de chegada das mensagens são gerados aleatoriamente no que diz respeito à sua frequência especificada. O modelo simula o processamento de recursos e de contenção eo enfileiramento de mensagens, reunindo estatísticas ao longo do caminho como várias propriedades de saída.

Fatores-chave de entrada de Desempenho

1. Freqüência- A freqüência com que a ligação ocorre.

2. Processamento- A quantidade de tempo para completar a execução de um processo. Isso pode ser em horas, minutos, dias, operações etc.

3. Velocidade- A velocidade do recurso de processador. Ou seja, quantos ciclos / instruções / ações que pode executar em uma unidade de tempo. É importante ser consistente com as unidades usadas para o processamento.

4. Processadores- O número de recursos do processador. Os processadores poderiam ser pessoas, CPU de organizações externas, etc.

Fatores-chave de saída Desempenho

1. Taxa de transferência- O número de mensagens por unidade de tempo através do conexão. Este valor real pode ser comparada com os valores esperados / teórico (ou seja, frequência) para deduzir a saturação do sistema.

2. Mensagem Classifique- O número de mensagens por unidade de tempo através do componente. Esta é a soma das mensagens recebidas e enviadas todas dos componentes.

3. Resposta- A / média / latência máxima mínimo para este conexão. Esta é a soma de todas as latências observadas para a ligação da fonte até a pia e qualquer filas e processamento (e latência de volta para a fonte, se bidirecional).

4. Utilização- A utilização da componente. Este será de 0% se o componente não é um dispositivo / processador (ou seja, ele não tem os processadores e velocidade propriedades definidas acima).

Enquanto uma simulação discreta é realizado para calcular as várias propriedades de saída, como descrito acima, a fórmula seguinte pode ser utilizado como uma verificação grosseira dos resultados (em que o sistema não está saturado):

Utilização = soma da freqüência para todas as conexões de entrada * Processing / (velocidade * Processors)

O conceito geral é talvez melhor demonstrada por considerar o seguinte diagrama, que mostra duas meta-modelos de desempenho diferentes. O estilo mão esquerda é a notação clássico "raia", com tarefas de processamento com base hierarquicamente dentro de seus recursos do processador. O estilo mão direita é uma notação 'distribuídas' com as tarefas de processamento ligados através de uma conexão de processos ao seu recurso de processador. Esta última notação permite que vários recursos do processador para uma determinada tarefa de processamento, ao contrário da notação raia limitada.

Nota

Mostrado em cada meta-modelo são as propriedades de entrada (em vermelho) e propriedades de saída (em azul):

Desempenho meta-modelos: Swimlane contra notação Distribuído

Executando o simulador de desempenho

Para simular sua arquitetura em termos de desempenho

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Selecionar Análise| atuaçãoou clique no botão da barra de ferramentas.

3. Selecione os Arquiteturavocê deseja avaliar a partir do menu suspenso.

Nota

Por padrão, ABACUS selecionará automaticamente a primeira arquitetura para o qual é necessária uma nova simulação devido a qualquer propriedade subjacente ou mudanças estruturais.Este destaque é mostrado na Vermelho no Barra de ferramentas Simulation .

4. Selecione os Componentes e Conexõesvocê deseja avaliar, a partir do janela de seleção de elemento padrão .

5. Colocou o Run Time Fator de Escalaslider.

Nota

Valores mais altos produzirão mais estatisticamente resultados consistentes, mas demoram mais tempo para calcular.

Adicional Caixa de seleção ao janela de seleção de elemento padrão

· STransformado ave Modelo irá salvar uma cópia da versão RBD transformada do projeto na mesma pasta que o projeto atual e acrescentar "_transformed" para o nome do projeto.Este projecto de transformada pode ser utilizada para diagnosticar a simulação em detalhe fiabilidade empreendido pelo ábaco.

Outras opções para a janela de seleção de elemento padrão

· Run Time Fator de Escala controla o tempo de simulação e com maior precisão valores de rendimentoingestatisticamente mais resultados consistentes, mas levando mais tempo para corre.

Nota

Quando ABACUS calcula o tempo de simulação que vai determinar o mais lento Frequency conexão indireta que foi selecionado para ser simulado e, em seguida, 'warm-up' para o período (ou seja, uma sobre a Frequency) desta conexão (iniciando geradores de mensagens periódicas para todas as conexões de forma aleatória durante este tempo de aquecimento, dando-lhes a todos a oportunidade de iniciar) e, em seguida, simular para Run Time Scale Factor de vezes o período da conexão. Ou (1 / Frequency) tempo de aquecimento + (1 / Frequency) tempo de simulação * Run Time Scale Factor. Isso é para se certificar de que que todas as ligações forem iniciadas antes de as estatísticas são recolhidas e, em seguida, a conexão mais lenta ainda é simulada pelo menos uma vez na simulação. Por exemplo. Se o mais lento conexão indireta tem uma freqüência de 0.033 unidades de tempo (ou CIRCA uma vez por mês, se as unidades de tempo são dias), então o tempo de aquecimento será de 30,3 unidades de tempo eo tempo de simulação será 30,3 unidades a tempo vezes O fator de escala de tempo Run.

6. Clique Terminare você terá uma Aviso diálogo.

7. Opcionalmente explorar os avisos clicando Detalhes >>.

8. Clique Continuar.

Nota

Neste ponto, ABACUS vai realizar uma simulação de eventos discretos da arquitetura e depois de um curto período de tempo (com barras de progresso para um feedback) um diálogo completo cálculo aparecerá.

9. Clique Está bema reconhecer a simulação.

Dica

Para os cursos de formação e obter ajuda adicional sobre a simulação de desempenho, consulte o Avolution Comunidade .

Propriedades do Componente

A tabela a seguir lista as propriedades necessárias para avaliar o desempenho. Propriedades são procurados primeiro nas instâncias de componentes, em seguida, os padrões de componentes e se não for encontrada, o padrão é usado.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de entrada da propriedade ( [image] ) Com a dica de ferramenta 'Input Desempenho'. Uma mudança para qualquer uma destas propriedades 'entrada' e várias mudanças estruturais no repositório irá resultar no simulador de desempenho que exige um re-simulação como indicado no Vermelho no Barra de ferramentas Simulation .

Tipo | Nome | Valor padrão | Unidade | Tipo de dado | Requeridos | Descrição
Comportamento | b_pack | 0.0 |  | Decimal | Falso | O tempo de serviço fixo de embalar em segundos. Esta propriedade é tipicamente especificado como um tipo padrão e, em seguida, usado para várias instâncias de componentes. Por exemplo, CORBA tem b_pack = 0.23 ms.
Comportamento | m_pack | 0.0 |  | Decimal | Falso | O tempo de serviço variável para embalar em segundos / byte. Esta propriedade é tipicamente especificado como um tipo padrão e, em seguida, usado para várias instâncias de componentes.
Comportamento | b_unpack | 0.0 |  | Decimal | Falso | O tempo de serviço fixo para desempacotar em segundos. Esta propriedade é tipicamenteespecificado como um tipo padrão e, em seguida, usado para várias instâncias de componentes.
Comportamento | m_unpack | 0.0 |  | Decimal | Falso | O tempo de serviço variável para desfazer as malas em segundos / byte. Esta propriedade é tipicamenteespecificado como um tipo padrão e, em seguida, usado para várias instâncias de componentes.
Comportamento | Processamento | 0.0 |  | Decimal | Verdade | A quantidade de tempo para completar a execução de um processo. Isso pode ser em horas, minutos, dias, operações etc.
Comportamento | Processadores | 1 |  | Número inteiro | Verdade | O número de recursos do processador. Os processadores poderiam ser pessoas, CPU de organizações externas, etc.
Comportamento | Velocidade | 100 |  | Número inteiro | Verdade | A velocidade do recurso de processador. Ou seja, quantos ciclos / instruções / ações que pode executar em uma unidade de tempo. É importante ser consistente com as unidades usadas para o processamento.
Comportamento | k_bkgd | 0.0 |  | Decimal | Falso | Processamento de fundo sobre o componente. Este é usado para ajustar os resultados para coincidir com quaisquer compensações fixadas para%. Isto pode, provavelmente, ser ignorado.

A tabela a seguir lista as propriedades de saída componente pelo avaliador desempenho. Um conjunto destas propriedades de componentes são gerados para cada componente em cada execução de desempenho.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta "Desempenho de saída '. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador de desempenho requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Comportamento | Mensagem Classifique |  | Decimal | Falso | O número de mensagens por unidade de tempo através do componente. Esta é a soma das mensagens recebidas e enviadas todas dos componentes.
Comportamento | Bandwidth |  | Decimal | Falso | Largura de banda geral através do componente. A quantia devida para ambas as mensagens recebidas e enviadas.
Comportamento | Utilização | % | Decimal | Falso | A utilização do componente. Este será de 0% se o componente não é um dispositivo / processador (ou seja, não têm processadores e propriedades velocidade definido acima)

Propriedades de conexão

A tabela a seguir lista as propriedades necessárias para avaliar o desempenho. Propriedades são procurados primeiro nas instâncias de conexão, então as Normas de ligação e se não for encontrado, o padrão é usado.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de entrada da propriedade ( [image] ) Com a dica de ferramenta 'Input Desempenho' ou 'Custo / Performance Input'. Uma mudança para qualquer uma destas propriedades 'entrada' e várias mudanças estruturais no repositório irá resultar no simulador de desempenho e / ou Simulador de custo requerendo um re-simulação, tal como indicado na Vermelho no Barra de ferramentas Simulation .

Tipo

Nome

Valor padrão

Unidade

Tipo de dado

Requeridos

Descrição

Comportamento

Tipo

bidirecional

[bidirecional | unidirecional]

Lookup / Lista

Verdade

Se a conexão for de duas vias (bidirecional) ou one-way (unidirecional).

Os valores permitidos para esta propriedade são "bidirecional" ou "unidirecional".

Bidirecional significa mensagens de pedido / resposta síncrona enquanto meio unidirecional um único "evento" assíncrona.

Comportamento

Abstração

indireto

[indireta | direta]

Lookup / Lista

Verdade

Se a conexão é física ou lógica. As conexões diretas são "canos" físicas entre dois componentes que fluem ao longo de conexões lógicas.

Os valores permitidos para esta propriedade são "direta" ou "indireta".

Se o valor é "direto" em seguida, a conexão não precisa de quaisquer outras propriedades (excepto para as propriedades amáveis ​​e abstração).

Dados

L_app1

0

Número inteiro

Falso

Pedido / size evento em bytes.

Cada conexão normalmente têm um valor específico para isso. Em CORBA, os eventos são realmente bidirecional e ter sempre um byte 12 reconhecem (L_app2). Se é uma verdadeira conexão unidirecional, em seguida, deixar de fora a propriedade L_app2.

Dados

L_app2

0

Número inteiro

Falso

Response / reconhecer tamanho em bytes.

Cada conexão normalmente têm um valor específico para isso. Uma conexão unidirecional não terá L_app2.

Comportamento

Freqüência

1

Decimal

Verdade

A freqüência com que a ligação ocorre.

Cada conexão normalmente têm um valor específico para isso. Se a propriedade Frequency é deixado de fora, em seguida, o padrão é usado.

Comportamento

Relação

processos

[processos | suporta]

Lookup / Lista

Falso

As conexões que têm a propriedade "processos" indicam que o componente no início da ligação será transformado para ser processada no componente no final da ligação. Com efeito, o componente de "origem" é movido para se tornar um filho do componente "afundar" (as conexões anexadas também são "arrastados" com esta jogada).

Se uma propriedade "processos" existe, então todas as outras propriedades da conexão será ignorado, exceto o opcional "%" propriedade descrita abaixo.

Comportamento

%

100.0

Decimal

Falso

As conexões que têm a propriedade "processos" (acima descrito) pode, opcionalmente, ter uma propriedade "%", para indicar a proporção do tratamento que vai ser atribuída ao componente de destino. Desta forma, um único componente de fonte pode ser processado por vários componentes de destino em vários% 's. Os valores% não precisa adicionar até 100% e é simplesmente usado para dimensionar a propriedade "transformação" (veja acima) para o componente de origem, uma vez que é transformado para se tornar um filho do componente de destino.

A tabela a seguir lista as propriedades geradas pelo avaliador desempenho. Um conjunto destas propriedades de conexão são gerados para cada conexão em cada execução de desempenho.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta "Desempenho de saída '. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador de desempenho requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Comportamento | Bandwidth |  | Decimal | Falso | A largura de banda total para a ligação. Isso só é calculado para conexões indiretas e é essencialmente (L_app1 + L_app2) * Taxa de transferência.
Comportamento | Largura de banda 1/2 |  | Decimal | Falso | A largura de banda de saída especificamente para (1) e de entrada (2) mensagens de a ligação. Isso só é calculado para conexões indiretas e é essencialmente L_app1 * Taxa de transferência e L_app2 * Taxa de transferência.
Comportamento | Taxa de transferência |  | Decimal | Falso | O número de mensagens por unidade de tempo através da conexão. Este valor real pode ser comparada com os valores esperados / teórico (ou seja, frequência) para deduzir a saturação do sistema.
Comportamento | Concluído | % | Decimal | Falso | A percentagem de mensagens de processamento que concluir com êxito para a conexão. Isso só é calculado para conexões indiretas e é a taxa de transferência / Frequência. Ocasionalmente, o valor Concluído superior a 100% porque a aleatoriedade dos resultados de geração de mensagem em uma freqüência de geração de mensagem ligeiramente mais elevado do que o especificado.
Comportamento | Response (Min / Ave / Max) |  | Decimal | Falso | A / média / mínima latência máxima. Isso só é calculado para conexões indiretas e é a latência observado para a conexão de fonte de afundar e qualquer filas e processamento (e latência de volta para a fonte, se bidirecional).

Propriedades Arquitetura

A tabela a seguir lista as propriedades de arquitectura de todo o sistema geradas pelo avaliador desempenho. Um único conjunto de propriedades para a arquitetura são "agregados" para cada execução de desempenho.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta "Desempenho de saída '. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador de desempenho requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Comportamento | Mensagem Classifique |  | Decimal | Falso | O número de mensagens por unidade de tempo através dos componentes da arquitectura. Esta é a soma das mensagens recebidas e enviadas todas dos componentes.
Comportamento | Taxa de transferência |  | Decimal | Falso | O número de mensagens por unidade de tempo através das conexões na arquitetura. Esta é a soma de todos os débitos das conexões indirectos e este valor real pode ser comparada com os valores esperados / teórico (ou seja, frequência) para deduzir a saturação do sistema.
Comportamento | Bandwidth |  | Decimal | Falso | A largura de banda total. Soma de conexão larguras de banda da arquitetura.
Comportamento | Utilização | % | Decimal | Falso | A utilização de todos os componentes. Pode ser superior a 100%, pois é apenas a soma de toda utilizações componentes da arquitetura.
Comportamento | Response (Min / Ave / Max) |  | Decimal | Falso | A / média / mínima latência máxima. Soma de todas as latências observadas para as conexões da arquitetura de fonte para afundar (e de volta à fonte, se bidirecional).


Simulando modularidade

Navegação: simulando sua arquitetura> Simuladores>

Simulando modularidade

Envie seus comentários neste tópico.

O simulador calcula modularidade o número de conexões de entrada e saída para cada componente.

Para simular sua arquitetura em termos de modularidade

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Selecionar Análise| Modularidade.

3. Escolha o Arquitectura (s)que pretende incluir na avaliação.

Nota

Por padrão, ABACUS selecionará automaticamente a arquitetura (s) para os quais é necessária uma nova simulação devido a quaisquer alterações estruturais subjacentes.Este destaque é mostrado na Vermelho no Barra de ferramentas Simulation .

4. Clique Próximo.

5. Escolha o Tipos de conexão (s)que pretende incluir na avaliação.

6. Clique Próximo.

7. Opcionalmente personalizar os nomes das propriedades para os resultados do cálculo.

8. Clique Terminar.

Nota

Neste ponto, ABACUS irá realizar uma avaliação estrutural da arquitectura (s) e depois de um curto período de tempo (com barras de progresso para um feedback) um diálogo completo cálculo aparecerá.

9. Clique Está bema reconhecer a avaliação.

Dica

Para os cursos de formação e de ajuda adicional sobre modularidade Avaliação consulte o Avolution Comunidade .

Propriedades do Componente

A tabela a seguir lista as propriedades de componentes que são produzidos pelo avaliador modularidade.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output modularidade'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma mudança estrutural subjacente para o repositório eo simulador modularidade requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Tipo de dado | Requeridos | Descrição
Modularidade | Coupling-ventilador em (local) | Número inteiro | Falso | Número de conexões que ventilador para esse componente.
Modularidade | Coupling-fan out (local) | Número inteiro | Falso | Número de conexões que se espalham deste componente.
Modularidade | Acoplamento de leque em | Número inteiro | Falso | Número de conexões que ventilador para este componente, incluindo conexões que fã em sub-componentes.
Modularidade | Coupling-fan out | Número inteiro | Falso | Número de conexões que se espalham deste componente, incluindo conexões que fã em sub-componentes.


Simulando Custo Total de Propriedade (TCO)

Navegação: simulando sua arquitetura> Simuladores>

Simulando Custo Total de Propriedade (TCO)

Envie seus comentários neste tópico.

Antecedentes

Custo Total de Propriedade (TCO) é uma estimativa financeira, projetado para medir totais incorridos os custos de ciclo de vida (desde a aquisição até a desativação / alienação) associados a activos detidos. TCO reflete não apenas os custos de aquisição, que inclui também todos os outros aspectos da continuação da utilização e manutenção do ativo.

TCO é usado para determinar o esforço e custos necessários orçamento para gastar em um sistema. Uma maneira simples de modelagem em ABACUS para TCO é quebrar o sistema de TI em componentes. Podemos, então, descobrir o quanto, em média, custa para executar um desses componentes. Após isso, poderia, então, fator em custos diferentes dependendo se o sistema de TI é evolvable ou aberto etc. Se um sistema já está instalado e funcionando, o principal fator a considerar é o custo de manutenção e, talvez, o custo para encerrar.

Um exemplo

Diagrama de exemplo de cálculo

O componente sob organização ou seu padrão tem as seguintes propriedades:

· FTE= 100 000 $ / ano

· Esforço apoio= 0,01 + 0,001 FTE FTE / ano = 1000 + $ 100 $ / ano

· Custo de manutenção= 100 $ - 10 $ / ano

· Custo capital= 2000 $

· Instale Esforço= 2 FTE / dias = 0,01 FTE / ano = 1000 $

O componente sob organização tem estas propriedades:

· Instale Horizon= -2 Anos (ou seja, o sistema foi instalado 2 anos antes do presente)

· Vida útil= 3 anos

Quando Instale Horizon + Lifespan <= 0 , Não há mais custos de manutenção.

Cálculos

Os cálculos são como se segue:

Nota

TC = custo por ano. SE = Esforço Suporte. MC = custo de manutenção.

· Custo custo = Capital Inicial + Instale Esforço= 2000 + 1000 = 3000 $

· Em t = -2 (durante 1 ano), TC = custo inicial + SE + MC= 3000 + 1000 + 100 = 4100 $

· No instante t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1190 $

· Em t = 0, = TC (1000 + 200) + (100 - 20) = 1280 $

· No instante t = 1 (último ano), TC = (1000 + 300) + (100 - 30) = 1370 $

Gráfico para Exemplo de Cálculo

TCO é a soma de todos os custos atuais e futuras até que o sistema tenha sido desclassificado.

· Em t = -2 (durante 1 ano), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Em t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Em t = 0, TCO = 1280 + 1370 = 2650 $

· Em t = 1 (último ano), TCO = 1370 $

Principais factores de custo

Os fatores de custo importantes a ser considerado no cálculo do TCO de um ativo em ABACUS são:

· Aquisição de hardware- O custo inicial do equipamento (custo de capital).

· Software de aquisição- O custo inicial da licença para software (custo de capital).

· Instalação- Os custos associados à configuração inicial.

· Treinamento- Custo associado à formação fornecedor externo após a configuração inicial.

· Apoio- Custo associado com o apoio interno.

· Manutenção- Custos de substituir ou atualizar fornecedor contratos de manutenção, suprimentos e custos de recuperação de desastres.

· A infraestrutura- Os custos associados ao apoiar o ativo.

ABACUS Exemplo Representação dos fatores-chave de custo

Executando o simulador Custo

Para simular sua arquitetura em termos de custo

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Selecionar Análise| Custo.

3. Escolha o Arquitectura (s)que pretende incluir na avaliação.

Nota

Por padrão, ABACUS selecionará automaticamente a arquitetura (s) para os quais é necessária uma nova simulação devido a qualquer propriedade subjacente ou mudanças estruturais.Este destaque é mostrado na Vermelho no Barra de ferramentas Simulation .

4. Selecione os Moedaa partir do pull down.

5. Mova o Anos para calcularcontrole deslizante para o número de anos necessários.

Nota

Por padrão, se os Anos para calcular é mais do que um ano os custos serão automaticamente calculada para cada ano (e uma coleção de propriedades adicionado / atualizado) e, em seguida, um valor acumulado para todo o número de anos também calculado. Se apenas o valor acumulado é necessário, em seguida, desmarque a Calcular os custos por anoopção como descrito abaixo para salvar o número de propriedades no projeto.

6. Escolha se a deixar Calcular os custos por anomarcada ou desmarque-a.

7. Clique Próximo.

8. Opcionalmente escolha o Conexõesvocê deseja atribuir os custos ao longo como parte da avaliação.

Nota

Usando um Custo | Atribuiçãopropriedade sobre os custos de conexões pode ser atribuído a partir do componente ligado à extremidade do dissipador de a ligação para o componente ligado à extremidade da fonte(ie Custo | Attribution = "Sink de origem"), ou a partir do componente ligado ao fonte extremidade da ligação para o componente ligado ao lavatório fim(isto é, custo | Attribution = "Fonte de afundar"). Adicionalmente, ABACUS selecionará automaticamente essas conexões com um Comportamento | Relação = "processos" ou "suportes"ea direção de atribuição será "Afundar com a Fonte '. Além disso, os custos são repartida Comportamento de acordo com qualquer | % Ou custo | Propriedades%, nas ligações, ou, alternativamente, onde existem várias ligações de um dissipador de muitas fontesou fonte de muitas pias, De acordo com qualquer Comportamento | Propriedades de processamento sobre os componentes de origemou afundar componentes respectivamente.

9. Clique Terminare você terá uma Aviso diálogo.

10. Opcionalmente explorar os avisos clicando Detalhes >>.

11. Clique Continuar.

Nota

Neste ponto, ABACUS irá realizar uma avaliação de custeio baseado em atividades da arquitectura (s) e depois de um curto período de tempo (com barras de progresso para um feedback) um diálogo completo cálculo aparecerá.

12. Clique Está bema reconhecer a avaliação.

Dica

Para os cursos de formação e obter ajuda adicional sobre Custo Simulação consulte o Avolution Comunidade .

Componente e / ou de conexão Propriedades

A tabela a seguir lista o componente e / ou conexão propriedades necessárias para avaliar custo.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de entrada da propriedade ( [image] ) Com a dica de ferramenta 'Custo Input'. Uma mudança para qualquer uma destas propriedades 'entrada' e várias mudanças estruturais no repositório irá resultar no simulador Custo exigindo uma re-simulação como indicado no Vermelho no Barra de ferramentas Simulation .

Tipo

Nome

Valor padrão

Unidade

Tipo de dado

Requeridos

Descrição

Custo

Instale Horizon

0

anos

Número inteiro

Verdade

Especifica quando o componente ou conexão foi ou será instalado.

· Um valor de 0 (o padrão) indica que o componente ou conexão está a ser instalado no ano em curso.

· Um valor menor que 0 indica que o componente ou conexão tiver sido instalado no passado.

· Um valor maior que 0 indica que o componente ou conexão irá ser instalado no futuro.

Custo

Vida útil

0

anos

Número inteiro

Verdade

Especifica o período de tempo em que o componente ou conexão permanecerá em operação, após o que serão desclassificadas.

Custo

FTE

100.000,00

$ / ano

Decimal

Falso

O custo anual de cada funcionário em tempo integral.

Se essa propriedade não for encontrada no componenteem si ou, no caso de ligações do componente ligado à extremidade do dissipador de conexão, Ele será procurado em outros componentes.

Em primeiro lugar, qualquer "sumidouro" componentes no fim de a conexão com um relacionamento "suportes" para o componente será procurado, seguido por que o pai do componente "sumidouro"s.

Se a propriedade FTE não for encontrado, o componente principal-Componentes será então procurou. Se FTE ainda não for encontrado, o valor padrão é usado.

Atenção: FTE é apenas uma propriedade de entrada válida em componentes.

Custo

Custo de Manutenção (fixo)

0.00

$ / ano

Decimal

Falso

O custo fixo anual de manutenção do componenteou conexão.

Custo

Custo de Manutenção (variável)

0.00

$ / ano

Decimal

Falso

A quantidade pela qual o custo total de manter o componente ou conexão vai mudar a cada ano.

Por exemplo, um valor de $ -500 indica que o custo total de manutenção diminui em US $ 500 a cada ano, enquanto que um valor de US $ 500 indica que o custo de manutenção total aumenta por US $ 500 cada ano.

Custo

Esforço Support (fixo)

0.00

ETI / ano

Decimal

Falso

O esforço anual fixa de apoiar o componenteou conexão, Especificados em termos de pessoas-ano.

Custo

Esforço Support (variável)

0.00

ETI / ano

Decimal

Falso

O montante em que o esforço total de apoiar o componente ou conexão vai mudar a cada ano.

Por exemplo, um valor de -0,01 indica que o esforço total apoio diminui em 0,01 anos pessoa a cada ano, enquanto um valor de 0,01 indica que o esforço total apoio aumenta em 0,01 a cada ano.

Custo

Custo capital

0.00

$

Decimal

Falso

O custo inicial da compra do componenteou conexão.

Custo

Instale Esforço

0.00

FTE

Decimal

Falso

O esforço necessário, em pessoas-ano, para instalar o componenteou conexão.

A tabela a seguir lista o componente e / ou conexão propriedades que estão de saída pelo avaliador TCO. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output Cost'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador de custos exige re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Nota

Onde as propriedades do avaliador TCO saída precisa ser "arredondado" a "metade Rodada até mesmo" abordagem (também referida como 'banqueiros' arredondamento) é usado.Esta técnica é usada para resolver de forma mais uniforme qualquer 0,5 "tie-breaks", com o resultado sendo arredondado para cima ou para baixo para o mais próximo até resultado, ao invés de sempre arredondamento para cima ou para baixo e distorcendo o resultado. Isto é, 2,5 é arredondado para 2, enquanto 3,5 é arredondado para 4, em vez de ambos sendo tanto arredondado para 2 e 3 ou arredondado para 3 e 4.

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Custo | Custo total para proprietário - próximos x anos. | $ | Número inteiro | Falso | O custo total de propriedade ao longo da próxima xanos, onde x é o período de tempo especificado ao executar o avaliador. Isto inclui o custo do componente de ou conexão de normas, sub-componentesou sub-conexões(isto é, crianças) e todos os custos atribuídos.
Custo | Custo total para Possuir (local) - ao lado x anos. | $ | Número inteiro | Falso | O custo 'local' de propriedade sobre o próximo xanos, onde xé o período de tempo especificado ao executar o avaliador. Isso faz nãoincluir o custo de sub-componentes do componente ou sub-conexões de conexão (isto é,crianças) ou quaisquer custos atribuídos.
Custo | Custo total para Possuir (crianças) - ao lado x anos. | $ | Número inteiro | Falso | O custo 'crianças' de propriedade sobre o próximo xanos, onde x é o período de tempo especificado ao executar o avaliador. este só inclui o custo de sub-componentes do componente ou sub-conexões de conexão (isto é, crianças).
Custo | Custo total para Possuir (atribuída) - ao lado x anos. | $ | Número inteiro | Falso | O custo 'atribuída' de propriedade sobre o próximo xanos, onde x é o período de tempo especificado ao executar o avaliador. este só inclui todos os custos atribuídos a partir dos componentes ligados(que podem, evidentemente, incluem os custos atribuídos a partir de qualquer conexão em anexo).

A tabela a seguir lista o componente e / ou conexão propriedades que estão de saída pelo avaliador TCOse o Calcular Per-Ano Custos opção for selecionada. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output Cost'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador de custos exige re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Nota

Veja a nota acima sobre a possível arredondamento de propriedades de saída.

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Custo | Custo total ao próprio - ano x. | $ | Número inteiro | Falso | O custo total de propriedade para ano x, Em que x é para cada ano especificado ao executar o avaliador. Isto inclui o custo do componente deou conexão de normas, sub-componentes ou sub-conexões (isto é, crianças) e todos os custos atribuídos.
Custo | Custo total para Possuir (local) - ano x. | $ | Número inteiro | Falso | O custo 'local' de propriedade por ano x, Onde x é para cada ano especificado ao executar o avaliador. Isso faz nãoincluir o custo de sub-componentes do componente ou sub-conexões de conexão (isto é, crianças) ou quaisquer custos atribuídos.
Custo | Custo total para Possuir (crianças) - ano x. | $ | Número inteiro | Falso | Custo de propriedade Os "crianças" por ano x, Em que x é para cada ano especificado ao executar o avaliador. este só inclui o custo de sub-componentes do componente ou sub-conexão de conexão (isto é, crianças).
Custo | Custo total para Possuir (atribuída) - ano x. | $ | Número inteiro | Falso | O custo 'atribuída' de propriedade por ano x, Em que x é para cada ano especificado ao executar o avaliador. este só inclui todos os custos atribuídos a partir dos componentes ligados(que podem, evidentemente, incluem os custos atribuídos a partir de qualquer conexão em anexo).

Adicional Propriedades de conexão

A tabela seguinte lista adicional propriedades de conexão que são necessários pelo avaliador TCO. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de entrada da propriedade ( [image] ) Com a dica de ferramenta 'Input Custo / Performance' ou simplesmente 'Input Custo ". Uma mudança para qualquer uma destas propriedades 'entrada' e várias mudanças estruturais no repositório irá resultar no custo e / ou Simulador de desempenho requerendo um re-simulação, tal como indicado na Vermelho no Barra de ferramentas Simulation .

Tipo

Nome

Valor padrão

Unidade

Tipo de dado

Requeridos

Descrição

Custo

Atribuição

Afundar a Fonte

[Fonte afundar | Afundar a Fonte]

Lookup / Lista

Verdade

E se "Fonte de afundar", Neste contexto irá ter ter custosatribuída 'ao longo' isto de fonteao componente lavatório componente. Alternativamente, se "Afundar a Fonte", Neste contexto irá ter custos atribuída 'junto' isto do componente de pia para o componente de origem.

Comportamento

Relação

suportes

[processos | suporta]

Lookup / Lista

Falso

Se "suportes", neste contexto, indica que a componente "fonte" é suportado pelo componente "afundar".

Além disso, se qualquer um "suporte" ou "processos", em seguida, a conexão será automaticamente selecionados nas conexões para ter seus custos atribuído "ao longo" do componente pia para o componente de origem.

Custo

%

100.0

%

Decimal

Falso

Indica a proporção dos custos de componentes pia que serão atribuídas ao componente de origem. Os valores% não precisa adicionar até 100% e é simplesmente usado para dimensionar o "Custo Total de proprietário -. Próximos x anos" Propriedade (ver acima) a partir do componente dissipador tal como é atribuída ao componente de origem.

Propriedades Arquitetura

A tabela a seguir lista as propriedades de arquitetura que são produzidos pelo avaliador TCO. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output Cost'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador de custos exige re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Nota

Veja a nota acima sobre a possível arredondamento de propriedades de saída.

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Custo | Custo total para proprietário - próximos x anos. | $ | Número inteiro | Falso | O custo total de propriedade de toda a arquitectura ao longo dos próximos x anos.

A tabela a seguir lista as propriedades de arquitetura que são produzidos pelo avaliador TCOse o Calcular Per-Ano Custos opção for selecionada. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output Cost'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador de custos exige re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Nota

Veja a nota acima sobre a possível arredondamento de propriedades de saída.

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Custo | Custo total para proprietário - ano x. | $ | Número inteiro | Falso | O custo total de propriedade para toda a arquitectura por ano x no futuro.


Simulando Fiabilidade e disponibilidade

Navegação: simulando sua arquitetura> Simuladores>

Simulando Fiabilidade e disponibilidade

Envie seus comentários neste tópico.

Antecedentes

O avaliador de Confiabilidade calcula a confiabilidade da arquitetura usando os componentes de entrada e conexões.

Para componentes e conexões diretas, fiabilidade baseia-se tempo médio entre falhas (MTBF). As únicas variáveis ​​necessárias para calcular a confiabilidade de elementos arquitetônicos são:

· o MTBFvalor (em anos);

· o Tempo médio de reparo (MTTR)uma falha (em anos); e

· O período definido de tempo para testar a fiabilidade face.

A fórmula utilizada no cálculo de fiabilidade é dada como:

Confiabilidade = -e (-y × idade)
Onde y = 1 ÷ MTBF

A disponibilidade de componentes e ligações é baseada na MTBF eo TMPR. Note-se que a disponibilidade, fiabilidade ao contrário, não é afectado por o período de tempo durante o qual está a ser testado.

Disponibilidade = MTBF / (MTBF + MTTR)

Enquanto os métodos que transformam Diagramas de Blocos de Confiabilidade(usando simples série e construções paralelas) dar os resultados mais exatos, estes métodos tornam-se altamente Eu souprático quando tentamos calcular a confiabilidade para missões dentro enormes redes de milhares de elementos. Além disso, estas abordagens transformacionais quebrar para muitas estruturas comuns, como a rede "malhas".

o Monte Carlométodo permite a confiabilidade e disponibilidade de um sistema de tamanho e complexidade arbitrária deve ser calculado. O método de Monte Carlo simula vários cenários e fou cada cenário um estado aleatório, disponível ou indisponível, É atribuído a cada elemento físico. A probabilidade de um determinado elemento de estar em um estado disponível baseia-se na fiabilidade / disponibilidade do componente.

Por exemplo, um componente com 90% de disponibilidade pode ser esperado para estar disponível em aproximadamente 90% dos cenários. Confiabilidade e disponibilidade da conexão indireta pode, portanto, ser calculado como a proporção de scenarios- aleatório para o qual existe um caminho de elementos em uma declaração disponível a partir de origem para o destino.

Nota

Uma vez que o cálculo de fiabilidade e disponibilidade local baseia-se diferentes parâmetros e fórmulas diferentes (e, portanto, resulta em valores diferentes), é necessário atribuir a cada elemento doisUnidos, uma disponibilidade, e um para a confiabilidade. O cálculo de disponibilidade usa o estado de disponibilidade em cada cenário, considerando que o cálculo da confiabilidade usa o estado de fiabilidade em cada cenário.

O avaliador confiabilidade utiliza a técnica de simulação de Monte Carlo para calcular a confiabilidade de uma arquitetura particular. A arquitetura é colocado através de milhares de simulações individuais e os resultados tabulados para derivar uma medida de confiabilidade. Como mencionado acima, Monte Carlo é a técnica mais rápida para simulação de redes maiores e irá funcionar com qualquer (ou seja, gradeadas) estrutura complexa.

O avaliador emite quatro valores:

1. Missão Confiabilidadeao longo de vários anos;

2. Disponibilidade do arquitetura;

3. Confiabilidade do componente localao longo de vários anos; e

4. Disponibilidade do componente local.

O avaliador trabalha para fora a probabilidade de a componente ou de trabalho de ligação (isto é, não falha) eo tempo necessário para reparar.

Como padrões com MTBFs e / ou MTTRs são tratados

Se um elemento (componente ou conexão) tem padrões com MTBF atribuído e / ou MTTR valores, esses valores também são utilizadas no cálculo da fiabilidade locais e disponibilidade de um elemento como uma ligação em série.

Por exemplo, se um componente A, Com padrões atribuídos B, C, e Dcada um tem um MTBF e um MTTR valor, local Confiabilidade = R(A)× R(B) × R(C) × R(D), Onde R = Fiabilidade calculado (usando a fórmula) do componente / normas e Local Aproveitarcapacidade = UMA(A)× UMA(B) × UMA(C) × UMA(D), Onde A = Calculada aproveitarcapacidade (usando a fórmula) do componente / padrões. Isto é, se um elemento tem três normas cada com MTBF e MTTR valors, E também MTBF e MTTR valorspara as propriedades do elemento, a fiabilidade locais e avilability é dada como um valor de série de cada um dos padrões e do próprio elemento.

Como outro exemplo, se um componente Atem atribuídos padrões B, C, e Dmas somente padrão Btem tanto um MTBF e um valor de MTTR, enquanto padrão Ctem apenas um valor de MTBF e padrão Dtem apenas um valor de MTTR, local Confiabilidade = R (A)× R (B)× R (C), Onde R= Fiabilidade calculado (usando a fórmula) do componente / normas e locais Disponibilidade = Uma (A)× Um (B)× Um (C), Onde A= Disponibilidade calculada (usando a fórmula) do componente / normas mas no cálculo A (C), porque o padrão tem apenas um valor de MTBF ele 'Pesquisas'para o valor (s) MTTR correspondência e irá adicionar todo o MTTR valores que considera que don't-se ter um valor de MTBF de correspondência, por isso, neste caso, seria usar o valor de MTTR padrão D. Se houvesse outro padrão, digamos E, Com apenas um valor de MTTR bem, em seguida, Um (C)usaria o MTBF de Ccom a TMPR de D e Esomados. Se outro padrão, digamos F, Teve apenas um valor de MTBF, em seguida, A (F)seria também usar o MTTR de D e Esomados.

Calculando Missão Confiabilidade

Ao calcular a confiabilidade local é uma questão de usar uma fórmula simples, o cálculo das conexões indiretas (missão) não é tão fácil, especialmente uma vez que temos redes complexas e grandes de caminhos entrelaçados (conexões) e componentes.

Considerando a totalidade da rede em conta

Como as conexões indiretas não representam uma conexão física, temos de descobrir como o componente de origem pode obter a sua componente de destino. E isto implica examinar toda a rede e todas as diferentes maneiras (e caminhos) nosso componente de origem pode tomar para chegar ao componente de destino (pia).

Nota

Enquanto existe finalmente um completocaminho da origem para o destino, a missão será bem sucedidae a ligação indirecta é referido como uma conexão fechada.

Compreender a Matrix link

Para saber quais componentes / ligações directas estão ligadas ao que, precisamos de um artefato para verificar rapidamente se dois blocos são ligados em uma determinada direção. Esta é a função da matriz de ligação. Em resumo, a matriz é uma matriz de ligação bidimensional de variáveis ​​booleanas que indica se um componente particular pode chegar a um outro componente directamente. O seu tamanho é igual ao quadrado do número total de componentes da rede.

A Confiabilidade simples diagrama de blocos (RBD)

Link relacionado Matrix para Confiabilidade Block Diagram (RBD)

Como nem todas as conexões são bidirecionais (que vai em ambos os sentidos), é importante saber como ler a matriz de ligação corretamente. No avaliador confiabilidade, o primeiro argumento é a fonte eo segundo argumento é o destino (pia).

Portanto, se matriz link (A, B) = True, então isso significa que um pode obter a B diretamente (unidirecional). B pode chegar a um caso apenas se matriz link (B, A) = True. Se isso for verdade, isso implica uma conexão bidirecional.

No exemplo dado acima:

· Fonte 1 pode chegar destino 0 (Fonte 1 e 0 Destino dá um resultado de True); e

· Fonte 0 pode chegar destino 1 (Fonte 0 e 1 Destino dá um resultado de True), como a ligação entre 0 e 1 é bidirecional.

· Fonte 2 não pode alcançar o destino 1 (Fonte 2 e 1 Destino dá um resultado de False) mesmo quando a fonte 1 pode alcançar o destino 2 (Fonte 1 e 2 Destino dá um resultado de True). Isto implica que é a ligação entre 1 e 2 é uni-direcional.

Entendendo a Confiabilidade Block Diagram

O diagrama de blocos de confiabilidade (RBD) encapsula a estrutura de todo o modelo de objeto em termos de blocos e links. Cada bloco representa um elemento que tem uma possibilidade de fracasso ou sucesso de acordo com os links / caminhos que os conectam. Ambos os componentes e ligações podem tornar-se um "bloco" na RBD.

Exemplo RBD Blocos e Links

A figura acima representa um exemplo RBD. A linha vermelha tracejada representa uma única missão 4 a 1. Observe como existem apenas dois caminhos possíveis para a missão 4-1.

Considere o percurso 4 para 3 a 0 a 1, e o percurso de 4 a 7 para 1. Os blocos pontilhados 2, 5e 6 representam blocos que não afecta a falha / não-fracasso da missão 4 para 1. Eles não são considerados e são ignorados. Isto é importante porque para a maioria das missões haverá um grande número de blocos redundantes que não irão afectar o sucesso de um determinado missão. Isso é mais evidente nas grandes redes em que o número de blocos redundantes fará com que os resultados da simulação impreciso.

Para acelerar o tempo de simulação, e garantir resultados mais precisos, é necessário abstrair de todo o RBD e usar apenas os elementos que afetam o sucesso de uma missão.

Nota

A única rota / caminho não pode passar por qualquer componente duas vezes.

Nesta fase, podemos criar uma matriz de ligação e executar uma simulação de Monte Carlo.

Calculando Arquitetura Disponibilidade

A disponibilidade arquitectura é a probabilidade de que todas as ligações indirectas irá estar disponível em qualquer ponto no tempo. A disponibilidade de cada conexão indireta é determinado durante cada iteração da simulação Monte Carlo, no entanto estas conexões indiretas (tipicamente) contam com o mesmo conjunto de elementos físicos. Portanto, simplesmente agregar estas disponibilidades individuais seria "dupla contagem" estas disponibilidades-un, dando um pessimista total disponibilidade arquitetura. Alternativamente, a disponibilidade global arquitetura é calculado por olhar para cada iteração e vendo se os elementos envolvidos nas conexões indiretas de interesse estão disponíveis. E, em seguida, a agregação destes resultados no final da simulação.

Executando o simulador de Confiabilidade

Para simular sua arquitetura em termos de confiabilidade

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Selecionar Análise| Confiabilidade.

3. Selecione os Arquiteturavocê deseja avaliar a partir do menu suspenso.

Nota

Por padrão, ABACUS selecionará automaticamente a primeira arquitetura para o qual é necessária uma nova simulação devido a qualquer propriedade subjacente ou mudanças estruturais.Este destaque é mostrado na Vermelho no Barra de ferramentas Simulation .

4. Selecione os Componentes e Conexõesvocê deseja avaliar a partir da janela de seleção de elemento padrão usando os 'Mostrar Conexões Diretas "e" Mostrar processos Conexões' Filtros de botão de rádio na parte inferior esquerda da caixa de diálogo para ajudar com sua seleção.

Adicional Caixa de seleção ao janela de seleção de elemento padrão

· STransformado ave Modelo irá salvar uma cópia da versão RBD transformada do projeto na mesma pasta que o projeto atual e acrescentar "_transformed" para o nome do projeto.Este projecto de transformada pode ser utilizada para diagnosticar a simulação em detalhe fiabilidade empreendido pelo ábaco.

Radio- adicionalBotões ao janela de seleção de elemento padrão

· Mostrar conexões diretas irá definir automaticamente uma ligação Tem filtro de propriedade para a propriedade Type = Comportamento, Name = Abstraction e Value = directo.Esta opção é selecionada por padrão e ajuda a selecção das ligações «directas», tal como descrito acima e abaixo.

· Mostrar processos Conexões irá definir automaticamente uma ligação Tem filtro de propriedade para a propriedade Type = Comportamento, Nome = Relação e value = processos.Esta opção auxilia a selecção das ligações "directos", tal como descrito acima e abaixo.

5. Clique Próximo.

6. Escolha o Missõesou seja, conexões que você deseja incluir na simulação.

7. Colocou o Run Time Fator de Escalaslider.

Nota

Valores mais altos trará mais resultados estatisticamente consistentes, mas demoram mais tempo para calcular.

Checkboxes

· exposição Conexões fechados irá filtrar automaticamente as ligações disponíveis para incluir apenas aqueles que têm, pelo menos, um caminho físico completo do componente de fonte para o componente de destino de acordo com a selecção RBD descrito acima.

· Mostrar conexões indiretas irá definir automaticamente uma ligação Tem filtro de propriedade para a propriedade Type = Comportamento, Name = Abstraction e Value = indireta.Esta opção é selecionada por padrão e ajuda a seleção das conexões 'indiretos' ou missão, tal como descrito acima e abaixo.

Botões

· Todosseleciona todo o conexões.

· Invertidodesmarca todos os atualmente selecionado conexões e seleciona todos aqueles que não foram selecionados.

· Nenhumdesmarca todos os conexões.

Outras opções

· Run Time Fator de Escala controla o tempo de simulação e com maior precisão valores de rendimentoingestatisticamente mais resultados consistentes, mas levando mais tempo para corre.

Nota

Quando ABACUS calcula o número de iterações para simular que vai determinar o elemento mais confiável que não é perfeitamente fiável e, em seguida, simular para Run Time Scale Factor de vezes 1 sobre a indisponibilidade desse elemento mais uma iteração. Ou (MTBF + MTTR) / MTTR * Run Time Fator de Escala + 1. Isso é para se certificar de que esse elemento ainda falhar pelo menos uma vez na simulação. Por exemplo. Se o elemento mais confiável que não é perfeitamente fiável tem um MTBF de 10.000 horas e um MTTR de 8 horas, em seguida, a simulação vai levar (10.000 + 8) / 8 = 1.251 vezes o fator de escala de tempo Run + 1 iterações.

· Anos simular Ahead Determina o número de anos para a Missão Confiabilidade deve ser calculado para.

· Número de Threadsdetermines o número de threads de processamento a ser usado para a simulação de Monte-Carlo.Esta opção será o padrão para corresponder ao número de CPUs / núcleos disponíveis (incluindo núcleos Hyper-Threading) para minimizar o tempo total de simulação.

8. Clique Terminare você terá uma Aviso diálogo.

9. Opcionalmente explorar os avisos clicando Detalhes >>.

10. Clique Continuar.

Nota

Neste ponto, irá executar uma ABACUS Monte-Carlosimulação da arquitetura e depois de um curto período de tempo (com barras de progresso para um feedback) um diálogo completo cálculo aparecerá.

11. Clique Está bema reconhecer a simulação.

Dica

Para os cursos de formação e de ajuda adicional sobre a confiabilidade Simulação consulte o Avolution Comunidade .

Propriedades do componente e Conexão

A tabela a seguir lista os componentes e"direta"propriedades de conexão necessários para avaliar a confiabilidade. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de entrada da propriedade ( [image] ) Com a dica de ferramenta 'Input Confiabilidade'. Uma mudança para qualquer uma destas propriedades 'entrada' e várias mudanças estruturais no repositório irá resultar no simulador Confiabilidade exigindo uma re-simulação como indicado no Vermelho no Barra de ferramentas Simulation .

Tipo | Nome | Valor padrão | Unidade | Tipo de dado | Requeridos | Descrição
Confiabilidade | MTBF | ∞ | anos, semanas, dias ou horas | Decimal | Verdade | O tempo médio antes da falha do elemento. Nota: Os valores podem ser expressos em unidades de anos, semanas, dias ou horas e são convertidos na sequência de uma disponibilidade conceito '24 / 7 'como se segue; - 1 ano = 52 semanas ou 365 dias ou 8.760 horas - 1 semana = 7 dias ou 168 horas - 1 dia = 24 horas
Confiabilidade | MTTR | 0 | anos, semanas, dias ou horas | Decimal | Verdade | The Mean Time To Repair do elemento. Nota: Os valores podem ser expressos em unidades de anos, semanas, dias ou horas e são convertidos na sequência de uma disponibilidade conceito '24 / 7 'como se segue; - 1 ano = 52 semanas ou 365 dias ou 8.760 horas - 1 semana = 7 dias ou 168 horas - 1 dia = 24 horas

A tabela a seguir lista os componentes e"direta" propriedades da conexão de saída pelo avaliador confiabilidade. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output Confiabilidade'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador Confiabilidade requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Confiabilidade | Confiabilidade - x anos |  | Decimal | Falso | A probabilidade de que o elemento não irá falhar nos próximos anos x. Este é um valor entre 0 e 1.
Confiabilidade | Unreliability - x anos |  | Decimal | Falso | A probabilidade de que o elemento irá falhar nos próximos anos x. Este é um valor entre 0 e 1.
Confiabilidade | Disponibilidade | % | Decimal | Falso | A disponibilidade calculado do componente ou ligação. Este é um valor entre 0% e 100%.
Confiabilidade | Indisponibilidade | % | Decimal | Falso | A indisponibilidade calculado do componente ou ligação. Este é um valor entre 0% e 100%.

A tabela a seguir lista o 'indireto'propriedades da conexão de saída pelo avaliador confiabilidade. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output Confiabilidade'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador Confiabilidade requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Confiabilidade | Missão Confiabilidade - x anos |  | Decimal | Falso | A probabilidade de que a ligação indirecta não irá falhar nos próximos anos x. Este é um valor entre 0 e 1.
Confiabilidade | Missão Unreliability - x anos |  | Decimal | Falso | A probabilidade de que a ligação indirecta falhará dentro dos próximos anos x. Este é um valor entre 0 e 1.
Confiabilidade | Disponibilidade | % | Decimal | Falso | A disponibilidade calculado da ligação indirecta. Este é um valor entre 0% e 100%.
Confiabilidade | Indisponibilidade | % | Decimal | Falso | A indisponibilidade calculada da conexão indireta. Este é um valor entre 0% e 100%.

Propriedades Arquitetura

A tabela a seguir lista a saída propriedades arquitetura pelo avaliador confiabilidade. Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output Confiabilidade'. A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma propriedade subjacente ou mudança estrutural para o repositório eo simulador Confiabilidade requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Unidade | Tipo de dado | Requeridos | Descrição
Confiabilidade | Disponibilidade | % | Decimal | Falso | A disponibilidade de todas as conexões indiretas que tenham sido incluídos na avaliação. Ou seja, a probabilidade de que todosconexões indiretas estarão disponíveis em um determinado ponto no tempo. Este é um valor entre 0% e 100%. Nota: Esta não é a multiplicação das disponibilidades de conexão individuais como isso seria "dupla contagem" o não-disponibilidade dos componentes relevantes.
Confiabilidade | Indisponibilidade | % | Decimal | Falso | A indisponibilidade de conexões indiretas que tenham sido incluídos na avaliação. Ou seja, a probabilidade de que pelo menos umconexão indireta não estará disponível em um determinado ponto no tempo. Este é um valor entre 0% e 100%. Nota: Esta não é a multiplicação das indisponibilidades de conexão individuais como isso seria "dupla contagem" o não-disponibilidade dos componentes relevantes.
Confiabilidade | Missão Confiabilidade - x anos |  | Decimal | Falso | A probabilidade de que todas as conexões indiretas que tenham sido incluídos na avaliação não será falhar no próximo x anos. Este é um valor entre 0 e 1. Nota: Esta não é a multiplicação das confiabilidades conexão individuais como isso seria "dupla contagem" o não-disponibilidade dos componentes relevantes.
Confiabilidade | Missão Unreliability - x anos |  | Decimal | Falso | A probabilidade de que pelo menos uma das ligações indirectas que foram incluídos na avaliação irá falhar na próxima x anos. Este é um valor entre 0 e 1. Nota: Esta não é a multiplicação das inseguranças de conexão individuais como isso seria "dupla contagem" o não-disponibilidade dos componentes relevantes.


Simulando Abertura

Navegação: simulando sua arquitetura> Simuladores>

Simulando Abertura

Envie seus comentários neste tópico.

O simulador de abertura determina o grau em que uma arquitetura e os seus elementos são "aberta", isto é, a capacidade do sistema para lidar com componentes de substituição com um impacto mínimo.

Para simular sua arquitetura em termos de abertura

1. Verifique se você tem o arquivo ABACUS, Contendo a sua arquitetura povoada, aberto.

2. Escolha Análise | Abertura.

3. Escolha o Arquitectura (s)que pretende incluir na avaliação.

Nota

Por padrão, ABACUS selecionará automaticamente a primeira arquitetura para o qual é necessária uma nova simulação devido a qualquer propriedade subjacente ou mudanças estruturais.Este destaque é mostrado na Vermelho no Barra de ferramentas Simulation .

4. Clique Terminare você terá uma Aviso diálogo.

5. Opcionalmente explorar os avisos clicando Detalhes >>.

6. Clique Continuar.

Nota

Neste ponto, ABACUS irá realizar uma avaliação estrutural da arquitectura (s) e depois de um curto período de tempo (com barras de progresso para um feedback) um diálogo completo cálculo aparecerá.

7. Clique Está bema reconhecer a simulação.

Dica

Para os cursos de formação e de ajuda adicional sobre Avaliação abertura consulte o Avolution Comunidade .

Componentes e Conexão propriedades padrão

A tabela a seguir lista as propriedades padrão de componentes e de ligação necessárias para avaliar a abertura.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de entrada da propriedade ( [image] ) Com a dica de ferramenta "A abertura de entrada '. Uma mudança para qualquer uma destas propriedades 'entrada' no repositório irá resultar no simulador Abertura exigindo uma re-simulação como indicado no Vermelho no Barra de ferramentas Simulation .

Tipo | Nome | Valor padrão | Unidade | Tipo de dado | Requeridos | Descrição
Abertura | Normas-Standard-Vencimento Organização Nível |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Nível de responsável Corpo Standards 0:Organizacional / Proprietary 1:Consortium / Defacto 2:Nacional / Militar 3: Internacional
Abertura | Normas-Standard Maturidade Estado- |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Nível de aprovação alcançado com o organismo de normalização 0:Trabalho do Comité / Draft 1:Projecto Público / balloted 2:Projecto Provisório 3:Aprovado
Abertura | Normas-Standard-Maturidade Estabilidade |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | É o padrão propensos a mudar? 0:Padrão obsoleto 1:Altamente sujeita a alterações em próxima 1 a 2 anos 2:Conhecidos mudanças / atualizações para os recursos existentes 3:Altamente estável (sem alteração no prazo de 2 anos)
Abertura | Normas-Standard Suporte Maturidade-Vendor |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Suporte Vendor 0:Nenhum produto ou fornecedores suportam o padrão 1:Um ou mais fornecedores que implementam uma porção do padrão 2:Mais de um fornecedor com produtos que implementam todas as partes do padrão 3:Muito mais do que um fornecedor com produtos que implementam todas as partes do padrão
Abertura | Normas-Standard explicitação-Documentação |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Qualidade de documentação padrão 0: Pobre 1: Feira 2: Boa 3: Excelente
Abertura | Normas-Standard explicitação-Standard Largura |  |  | Número inteiro | Falso | Número de recursos. Uma contagem dos mais baixos recursos padrão nível - Sf
Abertura | Normas-Standard explicitação-Sm |  | % | Decimal | Falso | Percentagem do número total de recursos que são de preenchimento obrigatório
Abertura | Normas-Standard explicitação-So |  | % | Decimal | Falso | Percentagem do número total de características que são opcionais
Abertura | Normas-Standard explicitação-Sc |  | % | Decimal | Falso | Percentagem do número total de recursos que são definidas condicionalmente
Abertura | Perfis-Perfil-Documentação Documentação |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Qualidade de documentação padrão 0: Nenhum 1: Pobre 2: Feira 3: Excelente
Abertura | Perfis-Profile Documentation-Precisão |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Será que a documentação que reflecte o design actual sistema? Qual o nível de recursos de perfil são usados ​​no sistema? 0:Não há novas funcionalidades 1:Alguns recursos 2:A maioria dos recursos 3:Todos os recursos
Abertura | Perfis-Perfil de Maturidade Documentation- |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | É o perfil maduro e disponível? 0: Ad hoc 1:Projeto baseado 2:Organizacional 3: Público
Abertura | Perfis-perfil Largura explicitação-Explicit |  |  | Número inteiro | Falso | Número de recursos padrão especificados conforme exigido no perfil
Abertura | Perfis-Profile explicitação-Pm |  | % | Decimal | Falso | Percentual de recursos obrigatórios no perfil
Abertura | Perfis-Profile explicitação-Po |  | % | Decimal | Falso | Percentual de recursos opcionais de perfil
Abertura | Perfis-Profile explicitação-Pc |  | % | Decimal | Falso | Percentagem de definida condicionalmente recursos no perfil
Abertura | Perfis-Profile explicitação-Coverage |  | % | Decimal | Falso | Percentual de recursos padrão abordadas especificamente no perfil
Abertura | Extensões-Extension Profiles-Largura Perfil |  |  | Número inteiro | Falso | Número de não-padrão de recursos especificados pelo perfil
Abertura | Perfis-Perfil-Extensions Cobertura |  | % | Decimal | Falso | Percentagem de extensões detalhado no perfil
Abertura | Disponibilidade produtos de Produto e Conformance-Número de produtos |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Número de produtos que suportam os recursos obrigatórios da norma 0:Não há produtos suportam o padrão 1:Um ou mais produtos implementar uma porção do padrão 2:Mais do que um produto implementa todas as partes da norma 3:Muitos mais de um produto implementa todas as partes da norma
Abertura | Disponibilidade produtos de Produto e Conformidade Conformidade-Aplicação |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | O nível de conformidade que os produtos têm o padrão? 0: Nenhum 1:Reivindicado 2:Demonstrado 3:Certificado e demonstraram
Abertura | Disponibilidade produtos de Produto e Conformance-Conformidade de Qualidade |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falso | Qualidade de teste de conformidade 0: Nenhum 1:Teste em casa pelo desenvolvedor do produto 2:Testes independentes (por exemplo NIST) 3:Demonstrada no contexto do produto relevante

Component, Conexão e Propriedades Arquitetura

A tabela a seguir lista o componente, conexão e saída propriedades arquitetura pelo avaliador abertura. Todas as seguintes propriedades para avaliar entre zero (0) e três (3), de zero (0), sendo o menos desejável e três (3), sendo o mais desejável.Estas propriedades serão mostrados na janela Propriedades com um ícone seletor de linha de saída da propriedade ( [image] ) Com a dica de ferramenta 'Output abertura ". A seta no ícone irá destacar Vermelho ( [image] ) Quando estas propriedades estão desatualizados devido a uma mudança de propriedade subjacente para o repositório eo simulador abertura requer re-simulação de acordo com o Vermelho realces na Barra de ferramentas Simulation .

Tipo | Nome | Tipo de dado | Requeridos | Descrição
Abertura | Abertura | Decimal | Falso | Avaliação global da abertura do item.
Abertura | Maturidade Standards-Standard | Decimal | Falso | O estado atual do padrão, refletindo se é ou não tenha sido aprovado, quanto tempo ele tem sido usado e como bem aceito que esteja dentro da comunidade de desenvolvedores.
Abertura | Normas Padrão explicitação- | Decimal | Falso | A explicitação das normas, refletindo a ambiguidade potencial em padrões que se seguiram
Abertura | Perfis-Profile Documentação | Decimal | Falso | A medida em que o perfil de interface documentação é desenvolvida e se a documentação perfil reflete a própria concepção do sistema e / ou o sistema implementado
Abertura | Perfis-Profile explicitação | Decimal | Falso | O nível de detalhes fornecidos em um perfil / especificação do perfil
Abertura | Perfis-Perfil Extensions | Decimal | Falso | O grau ao qual o perfil em conformidade com o padrão no qual se baseia
Abertura | Produtos de Produto Disponibilidade e Conformidade | Decimal | Falso | Ou não há padrão aberto conformant produtos disponíveis para utilização no projeto


Relatórios padrão

Navegação: Relatórios sobre sua arquitetura>

Relatórios padrão

Envie seus comentários neste tópico.

ÁBACO' padrão relatórios permitem-lhe obter uma lista dos componentes e conexões em uma ou mais das suas arquiteturas. O relatório contém todas as informações relacionadas com os componentes e conexões selecionadas, incluindo informações sobre o componente ou o lugar de conexão na hierarquia, tipo, normas, descrição, propriedades e seus anexos.

Nota

O conteúdo do relatório éconfigurávelatravés do diálogo Opções de relatório descrito abaixo, no entanto, to saber mais informações sobre como criar personalizado completamente configurável relatóriosusando ABACUS relatórios personalizados, por favor referem-se ao tópico Aqui ou contato Suporte Avolution .

Para ver uma padrão relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada(s).

2. Selecionar Inserir| Relatório Padrãoou clique no Criar Relatório Padrão botão da barra de ferramentas. o Relatório de configuraçãojanela será exibida.

Janela de configuração do relatório

3. Selecione os Arquiteturas, Componentes e Conexõesque você quer no relatório do Janela Configuração do relatório.Por favor, consulte o elemento de selecção Padrão Aqui tópico de ajuda.

4. Agora clique no Opçõesbotão eo Opções de Relatóriojanela será exibida.

Janela Opções de relatório

5. Você pode optar por exibir um Nova página para cada elemento, a Data de impressão, Tempo de Impressão, Números de páginae se deseja incluem o título no cabeçalhodo relatório, assinalando / desmarcando as caixas de seleção relevantes. Você também pode querer personalizar o título e autor, editando o Título do relatório e Autor caixas de texto. Você também pode escolher o conteúdo que é exibido no relatório marcando / desmarcando as caixas de seleção sob o Relatório de Conteúdosecção da janela. Depois de ter terminado clique em Está bem.

6. Agora clique em Terminarna janela de Configuração de relatórios.

Para interpretar o relatório visível

Exemplo de relatório gerado com breves explicações

Para navegar pelas páginas do relatório, clique nos ícones [image] localizado na barra de ferramentas no canto superior esquerdo do ecrã.

Nota

Você pode Guardar o relatório para vários formatos clicando no Exportar relatório ícone [image] localizado dentro a barra de ferramentas. Você pode optar por exportar nos seguintes formatos: Sobressair, PDF e Palavra. Por favor, salve o relatório no local desejado para uso posterior. Se forem feitas alterações à arquitectura, numa fase posterior, um novo relatório terá que ser criada para refletir as alterações.

Veja também

Analisando sua arquitetura


Relatórios Personalizados

Navegação: Relatórios sobre sua arquitetura>

Relatórios Personalizados

Envie seus comentários neste tópico.

Relatórios personalizados ABACUS 'permitem que você crie relatórios personalizados totalmente configuráveis. Os relatórios podem incluir imagens e gráficos personalizados, bem como detalhando quaisquer componentes, conexões ou atributos de um repositório ABACUS, bem como os resultados analíticos detalhados de várias simulações (incluindo TCO, Desempenho e Confiabilidade). Além disso, os relatórios podem conter diagramas, gráficos, catálogos, matrizes / tabelas dinâmicas, mapas, medidores, os minigráficos, barras de dados e indicadores (por exemplo semáforos).

Nota

Embora qualquer usuário pode abrir relatórios personalizados existentes, to configure relatórios a licença de usuário precisa do Relatório de configuração capacidade. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

Para ver uma personalizadas relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada(s).

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizadosjanela será exibida.

Relatórios Personalizados janela

3. Selecione os existir Relatório que você quer mostrar de Relatórios disponíveis seção.

4. Clique Executar Relatório.O relatório será aberto no Microsoft Report Viewer e to navegar pelas páginas do relatório, clique nos ícones [image] localizado na barra de ferramentas no canto superior esquerdo do ecrã.

Nota

Você pode Guardar o relatório para vários formatos clicando no Exportar relatório ícone [image] localizado dentro a barra de ferramentas. Você pode optar por exportar nos seguintes formatos: Sobressair, PDF e Palavra. Por favor, salve o relatório no local desejado para uso posterior. Se forem feitas alterações à arquitectura, numa fase posterior, um novo relatório terá que ser criada para refletir as alterações.

Para editar o repositório de dados que é enviado para a personalizadas relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada(s).

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizados janela (Mostrado acima) será exibido.

Nota

Embora qualquer usuário pode abrir relatórios personalizados existentes, to configure Os dados que são enviados para um relatório personalizado a licença de usuário precisa do Relatório de configuração capacidade. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

3. Selecione os existir Relatório que você quer mostrar de Relatórios disponíveis seção.

4. Clique Conjuntos Editar Dados. o Conjunto de dados do Editorjanela será exibida.Esta janela mostra a coleção de conjuntos de dados que estão sendo enviados para um relatório personalizado. No exemplo abaixo, existem três (3);

· um conjunto de dados ApplicationProxy que está especificando todos os detalhes para todos os componentes de aplicativos no '2015 Actual' arquitetura (incluindo as propriedades em seus padrões e quaisquer componentes em anexo),

· um conjunto de dados TwoDViewProxy que está especificando um ou mais diagramas de onde o nome corresponde 'Paisagem Aplicação (Austrália)',

· um conjunto de dados TargetProxy que está especificando todos os detalhes para todas as conexões de destino no '2015 Actual' arquitetura (incluindo os componentes ligados).

Conjunto de dados do Editor janela

Nota

A consulta de nome será usado para o nome do conjunto de dados em Microsoft Report Builder (veja abaixo). O campo Incluir especifica se o conjunto de dados é ou um único elemento, uma coleção de elementos, todos os tipos de componentes, todos os tipos de conexão, um ou mais arquiteturas, um ou mais diagramas ou um ou mais gráficos. Para a "coleção de elementos 'de dados define um botão de filtro é fornecida que, quando clicado, abre a janela Elemento de filtro que permite que você aplique múltiplos filtros para retornar apenas elementos de certas arquiteturas, e / ou de certos tipos, e / ou com certas normas , e / ou ligado a certos componentes, e / ou com certos pais, e / ou em determinados diagramas, e / ou em determinados gráficos e / ou com determinados valores de propriedade. Para os outros tipos de conjuntos de dados de um campo Nome é fornecido e utilizando o botão Select, você pode escolher o objeto (s) a ser incluído no conjunto de dados.

Nota

Os conjuntos de dados são armazenados numaOs dados conjuntos de arquivos (.xml)com o mesmo nome do arquivo de base como umassociado Arquivo de definição de relatório (.rdl). Se este arquivo não existir o editor de conjunto de dados irá preencher automaticamente com quaisquer nomes de consulta que existem no Arquivo de definição de relatório (.rdl)e um novo Os dados conjuntos de arquivos (.xml)será criado uma vez aa lista válida de consultas está definido.

3. Se você deseja excluir um conjunto de dados existente, em seguida, selecione o Excluir consulta botão.

4. Se você deseja adicionar um novo conjunto de dados, em seguida, clique no Adicionar novo conjunto de dadosbotão e configurar o conjunto de dados de acordo com a nota acima.

Para criar um novo personalizado relatório(a partir de um molde)

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada.

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizados janela (Mostrado acima) será exibido.

3. Clique Novo e selecione A4 - Retrato, A4 Paisagem, A3 - Retrato, A3 Paisagem, Carta EUA - Retrato, Carta EUA - Paisagem, Tabloid EUA - Retrato ou Tabloid EUA - Paisagemdependendo do tamanho e orientação do relatório de papel que é desejado.

4. Navegue até o local para salvar o arquivo de definição de relatório (.rdl / .rdlc) eo arquivo de conjunto de dados correspondentes (.xml) e clique Guardar. Isto irá adicionar um novo relatório personalizado para a seção Relatórios disponíveis da janela de relatórios personalizados e pode aberto ou editado como descrito acima.

Para adicionar um personalizado existente relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada.

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizados janela (Mostrado acima) será exibido.

3. Clique Adicionar e navegue até o local do arquivo de definição de relatório (.rdl / .rdlc) e clique Aberto. Isto irá adicionar um novo relatório personalizado para a seção Relatórios disponíveis da janela de relatórios personalizados e pode aberto ou editado como descrito acima.

Nota

Supõe-se que um arquivo de conjunto de dados correspondente (.xml) existe no mesmo local que o arquivo de definição de relatório.

Para copiar um personalizado existente relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada.

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizados janela (Mostrado acima) será exibido.

3. Selecione os existir Relatório que você quer copiar de Relatórios disponíveis seção.

4. Clique Cópia e uma cópia do relatório escolhido (chamado 'Cópia de ...') será adicionado à seção Relatórios disponíveis da janela de relatórios personalizados e pode aberto ou editado como descrito acima.

Nota

Ao fazer isso você vai criar uma cópia do relatório de Relatório Definição arquivo (.rdl / .rdlc) bem como a sua combinando arquivo de Conjunto de Dados (.xml)(se existir).

Para remover um personalizado existente relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada.

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizados janela (Mostrado acima) será exibido.

3. Selecione os existir Relatório que você quer para remover de Relatórios disponíveisseção e clique Remover.

Nota

Quando você remove um relatório que não aparecerá mais na lista de relatório. No entanto, isso não vai apagar o do relatório de definição de relatório arquivo (.rdl / .rdlc) ou o Conjunto de Dados arquivo(.xml). Se necessário, a exclusão destes ficheiros pode ser alcançado através do sistema de ficheiros.

Para renomear um personalizado existente relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada.

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizados janela (Mostrado acima) será exibido.

3. Selecione os existir Relatório que você quer renomear em a Relatórios disponíveisseção e clique Renomeie.

4. Digite um novo nome para o relatório.

Nota

Tanto o arquivo de definição de relatório (.rdl / .rdlc) eo arquivo de conjunto de dados correspondentes (.xml) será renomeado de acordo.

Para editar a concepção de um personalizadas relatório

1. Verifique se você tem um ABACUS arquivo aberto contendo o seu arquitetura povoada.

2. Selecionar Inserir| Relatório personalizadoou clique no Criar relatório personalizado botão da barra de ferramentas. o Relatórios Personalizados janela (Mostrado acima) será exibido.

Nota

Embora qualquer usuário pode abrir relatórios personalizados existentes, to configure O projeto de uma relatórios personalizados a licença de usuário precisa do Relatório de configuração capacidade. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.Além disso, a Microsoft Report Builder 3.0 é necessário para criar relatórios e pode ser baixado gratuitamente a partir de Aqui .

3. Selecione os existir Relatório que você quer mostrar de Relatórios disponíveis seção.

4. Clique Editar relatório.O relatório será aberto no Microsoft Report Builder 3.0. Para obter ajuda específica e algumas "dicas e truques" sobre algumas das tarefas mais comuns com criação de relatórios, consulte as seções abaixo. Para obter ajuda geral sobre a criação de relatórios consulte às páginas de ajuda 3.0 Microsoft Report Builder Aqui .

Adicionando tabelas para o seu relatório

1. Verifique se você tem um arquivo Relatório ABACUS Personalizado Definição (.rdl / .rdlc) aberto no Microsoft Report Builder 3.0.

2. Selecionar a Inserir guia no 'fita' no topo, em seguida, Clique no Mesa botãona seção regiões de dados e selecione Inserir tabela.

3. Agora arraste o cursorpara a posição na tela do relatório, onde você deseja que o canto superior esquerdo da tabela para colocado. Clique na tela. Por padrão, a tabela será adicionada com uma linha de cabeçalho e, em seguida, um grupo de detalhes (um grupo é usado para organizar uma vista de um conjunto de dados de relatório). Para remover o grupo, exclua a linha ou excluir o Grupo Row na barra de ferramentas Agrupamento.

Dicas

Fórmulas / Expressões em células da tabela são editados selecionando a célula, em seguida, clique com o botão direito do mouse no << Expr >> texto e selecionar Expressão .... Classificando linhas em uma tabela é feito selecionando a tabela e, em seguida, navegar até a outra -> campo SortExpressions no painel Propriedades e entrando em uma expressão. Para uma linha de total no final de uma tabela depois de adicionar uma linha (e fora) o agrupamento e, em seguida, use a seguinte expressão = Sum (Fields!Nome.Valor)onde "Nome" é o campo que está sendo totalizados. Para aplicar a coloração colunas usar um "IIF" declaração na propriedade BackgroundColor. Para adicionar um medidor como uma célula em uma tabela primeiro inserir o gabarito em uma célula e, em seguida, solte os campos de dados necessários para o indicador. Ao editar a altura e largura das linhas da tabela, certifique-se que você selecione a linha correta, e, em seguida, passe o cursor do mouse em torno das linhas cinzentas até obter a Seta para cima / baixo do cursor, em seguida, redimensionar.

Adicionando gráficos ao seu relatório

1. Verifique se você tem Um arquivo de definição ABACUS personalizada relatório (.rdl / .rdlc) aberto no Microsoft Report Builder 3.0.

2. Selecionar a Inserir guia no 'fita' no topo, em seguida, Clique no Gráfico botãona seção regiões de dados e selecione Inserir Gráfico.

3. Agora arraste o cursorpara a posição na tela do relatório, onde você deseja que o canto superior esquerdo do gráfico para colocado. Clique na tela e depois selecione o gráficode que necessita das opções e clique em Está bem.

Dicas

Para exibir uma propriedade como uma anotação sobre gráficos, clique direito sobre o gráfico e selecione Mostrar Rótulos de Dados, em seguida, selecione uma das etiquetas que tenha sido adicionado e definir o Misc -> UseValueAsLabel para Falso no painel de propriedades e adicione uma expressão (por exemplo, = name.value Fields) no Misc -!> Label. Especificamente para gráficos de bolhas; Gráficos de bolhas são exibidos sob o cabeçalho do gráfico de dispersão. Largar propriedade eixo X em campos de série (ou adicionar em Propriedades da Série). Largar propriedade eixo Y nos campos de dados (ou adicionar em Propriedades da Série). Para usar uma propriedade para definir o tamanho da bolha, solte isso em campos de Dados (ou adicionar em Propriedades da Série). Gráficos de bolhas são incapazes de mostrar se há dados demais (mais de 200 itens), às vezes, isso faz com que todo o relatório para não exibir. Tipo Marker - Definir como círculo. Por padrão, quando soltando campos em campos de dados, adiciona-los com o soma()fórmula, então eliminar esta. Especificamente para Gráficos empilhados / linha do tempo / gráficos de Gantt; Para um gráfico de Gantt usar um gráfico de intervalo e adicionar propriedades como valores altos e baixos nos campos de dados. Você pode ter várias 'barras', adicionando mais e mais faixas, quando o valor baixo para um corresponde ao valor elevado para outro. Especificamente para Gráfico de setores; Para gráficos de pizza agregados, largar os dados em campos de categoria e em campos de dados, adicione a fórmula = () CountRows. Filtrar quaisquer valores 0 (por exemplo, em cartas de custo), caso contrário as etiquetas para estes irão ainda aparecem no gráfico.

Usando uma instrução IIF para adicionar cores para tabelas e gráficos

1. Verifique se você tem Um arquivo de definição ABACUS personalizada relatório (.rdl / .rdlc) aberto no Microsoft Report Builder 3.0.

2. Botão direito do mouse na célula da tabela para colorir e clique em Propriedades da caixa de texto.

3. Selecionar Preencher e clique no fxbotão à direita do rótulo cor de preenchimento e no Conjunto de uma expressão para o campo BackgroundColor introduzir uma expressão, por exemplo = iif (Fields! InformationStatus.Value = "Manter", "Lightgreen", iif (Fields! InformationStatus.Value = "Redesenho", "Yellow", iif (Fields! InformationStatus.Value = "Atualizar", "laranja", " Salmão"))). Isso muda a cor do fundo a luz verde para cada célula que contém o status 'Manter', amarelo para cada célula que contém o status 'Redesign', Orange para cada célula que contém o status 'Atualizar' e qualquer outro valor de status será colorida em 'Salmon'.

Nota

As cores podem ser adicionados para gráficos selecionando a série no gráfico e, em seguida, definir a Aparência -> propriedade de cores (ou gráficos de bolhas a Aparência -> Marker -> propriedade de cores) para uma expressão semelhante ao exemplo acima.

Coisas para ter em mente ao criar relatórios personalizados

· Porque todas as propriedades, exceto Integer são enviados como uma seqüência de ABACUS para o espectador relatório se você quiser fazer quaisquer "expressões" com eles (como dividir uma propriedade por outra ou tipo), você precisa convertê-los para Decimal ou Data etc. Para o fundo , Esse artigo é uma boa referência. Por exemplo. = CDate (LifecycleEndDate.Value! Fields) Nota: Por favor, garantir que o idioma do relatório está definido para en-GB (conforme descrito abaixo) para aceitar dd / mm / aaaa como ele espera mm / dd / aaaa formato por padrão e, consequentemente, 31/7/2011 irá falhar a conversão. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (CostTotalCosttoOwnnext5years.Value Fields!, 0)

· Se você achar que você está lutando para manter todas as tabelas e gráficos em uma página, Existem algumas principais formas de gerir o seu espaço documento:

· Quebra de página - Certifique-se que este ajuste da tabela está desligado para cada tabela que você deseja estar na mesma página.

· Mantenha Juntos - Garantir este ajuste da tabela é verdadeiro para cada tabela que você deseja estar na mesma página.

· Quando mover as coisas, é mais fácil para diminuir o zoom usando o controle na parte inferior direita da página e, em seguida, vários selecionar itens e arraste-

· Para a linha de imagem em uma tabela, certifique-se de que o 'tamanho' | Propriedade 'Dimensionamento' é definido como 'Fit' caso contrário, a imagem pode parecer muito grande, ou ele vai ser mal esticada.

· Para repetir uma linha de cabeçalho de uma tabela em cada páginado relatório:

1. Abrir Modo Avançado no painel de agrupamentos. (Clique na seta à direita dos Grupos de Colunas e selecione Modo avançado.)

2. Na área Grupos de Linhas (Grupos não coluna), clique em um grupo estático, que destaca a caixa de texto correspondente no tablix. Clique por cada grupo estático até que destaca o cabeçalho da coluna mais à esquerda. Este é geralmente o primeiro grupo estático listados.

3. Na janela Propriedades, defina a propriedade RepeatOnNewPage para True.

4. Certifique-se de que a propriedade KeepWithGroup está definido para After.

· Mudar o configurações de linguagemem propriedades de relatório para coincidir com os formatos de dados que você precisa, por exemplo, pt-BR para produzir UK formato de data (dd / mm / aaaa).

Veja também

Analisando sua arquitetura


Publicar a Web

Navegação: Relatórios sobre sua arquitetura>

Publicar a Web

Envie seus comentários neste tópico.

ABACUS 'Publicar na Web recurso permite que os modelos de arquitetura para ser visto através de um web site seguro. Arquiteturas são exportados para o formato HTML e são projetados para refletir a aparência do Explorer no ABACUS. Visualizações (incluindo catálogos, diagramas, 3D e Gráficos) também são exportados em formatos visualizáveis ​​através de um navegador de internet.

Nota

Atualmente, Pontos de vista e Matrizes não são publicados.

Para publicar seus modelos arquitetônicos para a web

1. Verifique se você tem o relevante Arquivo ABACUSaberta, contendo a arquitetura povoadaque você deseja publicar na web.

2. Selecionar Arquivo| Publicar....

3. o Para publicar Configuração Webjanela será exibida.

Publicar a configuração Web

4. Por padrão, todas as partes do modelo são selecionadas incluindo o Vista em Árvore, a Padrões, Os tipos, modelos e Arquitetura (s). Desmarque quaisquer partes que você não deseja publicar na web, incluindo quaisquer pontos de vista individuais dentro da arquitetura (s).

Dica

Se você quiser esconder componentes específicos, conexões e / ou suas propriedades é recomendável que um administrador cria um papel 'Public' usando O recurso de acesso baseado em função ABACUS ' e, em seguida, remove a permissão de leitura a partir desses tipos de componentes, tipos de conexão e / ou propriedades que eles não desejam ser publicados. Em seguida, um usuário deve efetuar login sob esse papel e publicar a web como ABACUS só vai publicar elementos que têm permissão de leitura definido para o papel. Além disso, os usuários podem publicar automaticamente a partir da linha de comando como descrito Aqui .

Nota

Você pode selecionar todas as partes exibidas clicando no Todosbotão ou inverter sua seleção clicando no Invertido botão. Você também pode clicar no Nenhumbotão para limpar a sua selecção.

Nota

Se você desmarque a opção de exibição de árvoreentão nenhum quadro árvore (ver abaixo) será publicado. Por conseguinte, você deve selecionar uma página inicial de acordo com a etapa 6 abaixo ou após publicar você precisará personalizar tanto o de nível superior; a) index.htmlarquivo alterando o "quadro src =" mainPage.html "name =" element_details "" linha para conectar-se diretamente para a página html relevante sob a pasta de conteúdo, ou, b) mainPage.htmlfornecendo um link ou redirecionar para a página html relevante sob a pasta Conteúdo.

5. Clique no Opção botão ea seguinte Opções do Publisherde diálogo será exibida.

PublicarOpções de er

6. Seleger o 3D, Diagramae formatos gráficos e se é para mostrar o título, descrição ou Propriedades para as vistas fora das opções disponíveis (consulte a nota abaixo os comentários sobre os vários formatos).

7. Se você deseja definir a página inicial do modelo publicado em um ponto de vista particular, em seguida, verificar o Use Veja como página inicialopção e navegue até a vista através do botão '...' que fica ativado.

Nota

Somente os pontos de vista selecionados na seção Áreas como por Passo 4 acima estão disponíveis para ser definido como a página inicial.

8. Se você deseja receber feedback sobre páginas específicas do modelo publicado em seguida, certifique-se a Email feedbackopção for selecionada, digite um endereço de e-mail no Endereço de e-mail caixa de textoe editar o Email do corpoconforme apropriado secção. Se você não deseja ter o feedback enviado, em seguida, desmarque a Email feedbackopção e deixar a caixa de texto vazia.

9. Clique no Está bem botão.

10. Clique no Procurar botão.

11. o Procurar pastajanela será exibida.

12. Selecione o local que você deseja armazenar o arquivo HTML de nível superior (e quaisquer arquivos gerados automaticamente).

Nota

É uma boa idéia para criar uma pasta específica (normalmente chamado de "Publicado") usando o Criar nova pastabotão na parte inferior da caixa de diálogo para armazenar o arquivo HTML de nível superior e todos os arquivos gerados automaticamente.

13. Clique no Está bem botão.

14. O caminho da pasta será exibido na Diretório caixa de texto.

15. Clique no Terminar botão.

- ou -

15. Digite o caminho da pasta no Diretóriocaixa de texto onde você deseja armazenar o arquivo HTML de nível superior (e quaisquer arquivos gerados automaticamente).

16. Clique no Terminar botão.

Nota

Exportação de Diagramasmuito ocasionalmente falhar, na maioria das vezes quando o computador está sem memória (normalmente quando usando arquivos muito grandes). A exportação não será repetida uma vez. Haverá um aviso para uma tentativa inicial falhou, e um segundo aviso se o re-tentativa falhar. Portanto, se os únicos avisos são "tentativa inicial falhou" queridos, a publicar foi bem sucedida. Se o re-tentativa falhar tente publicar uma parcela menor de seu arquivo ou liberar alguma memória do sistema.

O arquivo HTML salvo (s) agora pode ser vista a partir de sua localização ou copiado para um web site seguro.

Publicar a Web no Internet Explorer10

Algum hyperlinks que foram criadas no modelo original será mantido no modelo publicado e clicar no link vai seguir o link para o seu destino (se foi publicado). Além disso, quaisquer elementos em diagramas publicados que ainda não estão linkados no modelo original será por hiperlinks de volta aos seus elementos correspondentes na visualização em árvore (se ele foi publicado) e clicando no elemento no diagrama publicado o foco vai saltar de volta para a localização relevante na Árvore. Este recurso é similar ao "Mostrar no Explorer" recurso clique com o botão direito em ABACUS.

Nota

Avolution recomenda os seguintes formatos de arquivos de software e deve ser usado para utilizar plenamente a Publicar para a funcionalidade da Web no ABACUS:

1. Internet Explorer (80,0 e acima)para ver a vista do explorador publicado. Mozilla Firefox (30,0 ou mais tarde)Também é recomendado e totalmente suportadoNo entanto, se estiver usando o formato SVG recomendado para diagramas, em seguida, no Firefox 9 você só pode usar o suporte visualizador SVG nativo que, infelizmente, não permite o zoom ou panning.

2. Adobe SVG Viewer 3.0 plugar (download de Aqui ) e SVGformato de arquivo para a publicação diagramas. O formato de imagem SVG para o diagramasé recomendado porque; SVG é um formato de imagem baseado em vetor e, portanto, é "perda-menos 'e parece muito melhor, em qualquer nível de zoom dado que qualquer um dos outros formatos, SVG pode ser importado para o MS Visio, SVG pode ser ampliado a qualquer nível ou resolução , SVG tem links para voltar à vista de árvore para as conexões (não apenas os componentes), SVG sempre imprime em uma melhor resolução, e, SVG é cerca de metade do tamanho do arquivo dos outros formatos. PNG é o próximo recomendação, no entanto, como é um formato rasterized em determinados níveis de zoom a clareza da visão serão perdidos e clicando em conexões em diagramas não vai saltar de volta para a localização relevante na árvore. BMP é desencorajado, pois ao mesmo tempo que é um 'sem perdas' formatar o tamanho do arquivo é 100x que um dos outros formatos e imagens 20MB não são incomuns.

O trade-off com SVG é que um visualizador SVG terá de ser instalado e você precisa certifique-se de que .svg image / svg + xml é adicionado tipos de MIME do servidor web. Após a instalação do visualizador SVG Microsoft Internet Explorer irá pedir-lhe para aceitar acordo de licença do espectador e, em seguida, ele deve funcionar bem. E enquantoMozilla Firefox suporta nativamente arquivos SVG, o plugin Adobe ainda é recomendadopara ser capaz de aumentar os diagramas se você estiver usando o Firefox 8 ou anterior (se você estiver usando o Firefox 9 não é possível desativar o visualizador SVG nativo). Assim que a instalação do plug-in Adobe foi executado, as seguintes etapas são necessárias usá-lo no Firefox:

· Abra o Firefox e digite "about: config" (sem as aspas) na barra de URL.

· Role para baixo e encontrar a propriedade svg.enabled(se você estiver usando o Firefox 9, em seguida, a visualização SVG nativo não pode ser desativada e essa propriedade não existe). Clique duas vezes nele para desativá-lo.

· Agora, encontrar o diretório no qual o plug-in SVG está instalado (por exemplo C: \ Arquivos de programas \ Arquivos comuns \ Adobe \ SVG Viewer 30,0 \)

· Copie os arquivos NPSVG3.dll e a NPSVG3.zip e colá-los para o diretório plugins firefox (por exemplo, C: \ Arquivos de Programas \ Mozilla Firefox \ plugins)

· Feche todas as instâncias do firefox

3. ABACUS 3D Viewer Avolution (3.1 e superior) e .abacus3D De Avolutionformato de arquivo para os pontos de vista publicados 3D. Enquanto o Plug-in Cortona VRML (Client 2.0 e acima)está disponível para visualização versões VRML dos pontos de vista publicados, não é livre para uso comercial e ainda requer uma instalação do lado do cliente. O ábaco 3D Viewer é mais do que qualquer visualizador VRML rico em recursos e está disponível gratuitamente para download Aqui . Em ambos os casos, certifique-se adicionar .vrml x-world / x-vrml e .abacus3d application / octet-stream para tipos de MIME do servidor web.

4. PNGformato de arquivo para as vistas Gráfico publicados. O formato de imagem PNG para a vista Gráfico é recomendado porque embora seja um formato rasterized e não há 'perda' o trade-off entre tamanho do arquivo e gráfico clareza normalmente é a melhor. BMP é desencorajado, pois ao mesmo tempo que é um 'sem perdas' formatar o tamanho do arquivo é de 20x que um dos outros formatos e gráficos 2Mb não são incomuns.

Se você quiser alterar a aparência das páginas da web, você pode editar o arquivo de página inicial nomeado mainPage.html eo arquivo de folha de estilo chamada abacus.css. Você vai encontrar esses arquivos na mesma pasta onde você optar por salvar o arquivo HTML de nível superior. Para obter mais informações sobre a estrutura e adaptação da produção publicada consulte a próxima seção.

A estrutura de ABACUS publicada modelos

O modelo publicada ABACUS está estruturado da seguinte forma:

1. A pasta de nível superior contém vários arquivos e assumindo todas as opções estão incluídas no ABACUS Publicar para configuração Web de diálogo que irá incluir uma índice.htmlarquivo composto de três quadros; treeView.html, findNode.html e mainPage.html e depois shortcutError.html página. O treeView.html é preenchido pelo tree.js, tree_items.js e tree_tpl.js arquivos javascript localizados dentro da pasta incluem (discutido abaixo) e replica a árvore Explorer a partir ABACUS. O findNode.html é alimentado por a find.js arquivo javascript localizado sob a incluir pasta (discutido abaixo) e irá procurar os galhos da árvore ao invés de apenas os nós visíveis. Tele mainPage.html é uma página HTML estático que pode ser adaptado com logotipos corporativos e afinse neste período a menos que uma página inicial é escolhido ao publicar.E, finalmente, a página shortcutError.html é uma página de destino para quaisquer atalhos quebrados da árvore devido às páginas apropriadas não ser publicados.

Dica

Você pode pular o mainPage.html por completo, optando por usar uma página inicial quando publicar ou modificar o arquivo index.html para apontar diretamente para uma determinada visão (digamos) editando o src frame = linha "mainPage.html" para apontar diretamente para a primeira vista na primeira arquitetura, tipicamente o diagrama "quadro".

2. O i de nível superiorncludepasta contêming vários JavaScript (.js) e Cascading Style Sheet (CSS) arquivos usados ​​pelos arquivos .html em todo o modelo publicado.

3. A pasta de conteúdo de nível superior contém, alfabeticamente;

· UMA '3D Visualizações' pasta com umnumeradaPágina HTML e um arquivo VRML ou abacus3d para cada uma publicadas as vistas 3D. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· Um Arquiteturas pasta com uma página HTML numerado para cada arquitetura que foi publicado. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· A Catálogos pasta contendo uma página HTML numeradas para cada um dos catálogos publicados. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· A Charts pasta com umnumeradaA página HTML e um PNG, etc arquivo JPG para cada um dos pontos de vista Gráfico publicados. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· A Componentes pasta que contém umnumeradaPágina HTML para cada um dos componentes publicados. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· A Conexões pasta que contém umnumeradaA página HTML para cada uma das conexões publicadas. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· A Diagramas pasta que contém umnumeradaA página HTML e um PNG, etc arquivo SVG para cada uma das publicada diagramas. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· Um Ícones sub-pasta com várias imagens usadas em todo o modelo publicado.

· A Padrões sub-pasta com umnumeradaA página HTML para qualquer padrõesque foram publicadas. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

· A Modelos sub-pasta com uma coleção de numeradas sub-pastas para cada modelo publicada a partir do projeto. Dentro de cada sub-pasta é uma componentes e uma pasta Conexões e dentro destes é uma página HTML numerado para cada componente e conexão do modelo. Veja a nota abaixo para obter informações sobre o esquema de numeração da pasta / arquivo.

· A Tipos sub-pasta com componentes eConexão sub-pastas com umnumeradaA página HTML para qualquer Componente eTipos de conexão que foram publicadose uma coleção de sub-pastas numeradas para cada tipo publicado a partir do projeto que contém uma página HTML para cada um dos constrangimentos. Veja a nota abaixo para obter informações sobre o esquema de numeração da pasta / arquivo.

· A Visãopontos sub-pasta e umnumeradaA página HTML para qualquer um dos Vistapontos que foram publicadas. Veja a nota abaixo para obter informações sobre o esquema de numeração de arquivos.

Nota

A numeração das páginas HTML (e em alguns casos, a ficheiros de imagem) corresponde a único Identidade para cada objeto repositório que foi definir quando era criadodentro ABACUS (referido como EEIDs). Este ID não altera de modo Como diagramas, tipos, componentes etc estamos Atualizada elas irámanter a mesma ID como antes. Em todos os casos, o relevante objeto de repositórionome pode ser encontrado perto do início da página HTML entre as marcas ... 1 tags HTML.

Restringir o acesso a páginas Certos / Visualizações com IIS

Se estiver usando o IIS como seu servidor web para o modelo publicado, você pode ser capaz de restringir o acesso a determinadas páginas / vistas utilizando o método a seguir:

1. Criar um site no IIS (outra se houver um já existente você não quer interferir com).

2. Alterar o acesso Properties-> Lista de Segurança-> Anonymous - acesso anônimo desmarque e utilização acesso autenticado.

3. Se este é apenas um servidor normal, sem domínio complicações etc, então você deve usar a opção 'integrada do Windows autenticação ", que passaria a usar as máquinas do servidor de usuários locais / logins como a autenticação, e apenas adicionar usuários ao computador local (tendo o cuidado que você está ciente das implicações, segurança sábio, de adicionar novos usuários para a máquina, por exemplo, dependendo se o acesso remoto está configurado para a máquina, etc).

4. Adicionar permissões para os arquivos / pastas específicas, conforme necessário. Botão direito do mouse os arquivos / pastas individuais -> Propriedades, e ajustar as permissões de segurança como faria normalmente para arquivos / pastas.

Isso pode variar, dependendo de qual versão do IIS eo que é específico do sistema operacional Windows no servidor, e se você tem um domínio ou outra configuração diferente.

Veja também

Preenchendo sua arquitetura | Analisando sua arquitetura


Exportando seu Architecture

Navegação: Relatórios sobre sua arquitetura>

Exportando seu Architecture

Envie seus comentários neste tópico.

ABACUS permite- paraexportar sua arquitetura para .mdb (Microsoft Access), MS SQL Server, .abacus (arquivo ABACUS), e .xls formato (Microsoft Excel). Você também pode exportar o seu diagramas para PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF e BMP e seus relatórios para .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) e .rtf (Rich Text Format) formatos. Isto permite-lhe analisar e ver a arquitetura e seus dados em qualquer maneira que você quer.

Para exportar sua arquitetura para mdb (Microsoft Access)

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Clique no Arquivo cardápio.

3. Selecionar Exportar, e depois Para MDB.

4. Tome nota do aviso e clique em Está bem.

5. Digite um nome para o arquivo.

6. Clique no Guardar Botão.

Nota

O formato de exportação do banco de dados .mdb é específico para ABACUS e quaisquer alterações de esquema irá resultar em incapacidade de re-importação. Por favor, veja Preencher com o MS Access para obter uma descrição do esquema de MS Access.

Para exportar sua arquitetura para MS SQL Server

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Clique no Arquivo cardápio.

3. Selecionar Exportar, e depois Para o MS SQL Server.

4. Na caixa de diálogo que aparece, clique no Exportação em branco MDB ...botão e importar isto em seu servidor de banco de MS SQL Server.

5. Preencha as informações do banco de dados ea cadeia de ligação.

6. Clique no Exportar Botão.

Nota

O formato de exportação do MS SQL Serverbanco de dados é específico para ABACUS e quaisquer alterações de esquema irá resultar em incapacidade de re-importação. Por favor, veja Preencher com o MS Access para uma descrição do esquema de banco.

Para exportar sua arquitetura para .xls (Excel arquivo)

1. Verifique se você tem um ABACUS arquivo aberto , um explorador exibido , e um arquitetura acrescentado .

2. Verifique se você tem um Arquivo Excel Import Configuration / Exportação definiram.

3. Botão direito do mouseem uma arquitetura em seu modelo ou qualquer parte do Componentesnó (dentro de uma dada arquitetura) que deseja exportar para o arquivo de configuração do Excel.

4. Selecionar Exportar | Para Excel ... a partir do menu.

5. o Selecione Arquivo Excel Import Configuration / Export to Usejanela será exibida.

6. Selecione o arquivo de configuração relevante para o seu modelo de arquitetura e clique no Aberto botão.

7. Se não for feito automaticamente, de forma, mapa os componentes de nível superior em sua arquitetura atual para a Set Id(conforme definido anteriormente) e clique em Exportar....

Mapeamento exemplo de componentes de nível superior

8. Escolha um local e nome de arquivo para seu arquivo de Excel e clique no Guardar botão.

Para exportar sua arquitetura para .abacus (arquivo ABACUS)

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Botão direito do mouseno nó Arquitetura, qualquer arquitetura em seu modelo ou qualquer parte da árvore de componentes.

3. Selecionar Exportação | Para Arquivo...a partir do menu.

4. Escolha um local e nome do arquivo e clique no Guardar botão.

Nota

Você pode importar um arquivo de volta para ABACUS ABACUS seguindo os passos 1-2acima e selecionando Importação | A partir da Arquivo.... Depois que você selecionou o arquivo que você deseja importar, você será solicitado como você deseja importar os padrões e tipos. Você pode importar padrões e tipos como em normas e tipos novos ou mescladas. A configuração padrão é para os padrões e tipos a serem mesclados com os padrões e tipos existentes se eles já existem na sua projeto.

Para exportar sua arquitetura para .xml

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Botão direito do mouseem um nó Arquitetura, qualquer arquitetura em seu modelo ou qualquer parte da árvore de componentes.

3. Selecionar Exportação | Para XML ...a partir do menu. Alternativamente, você pode clicar no menu Arquivo| Exportar| Para XML ...

4. Escolha um local e nome do arquivo e clique no Guardar botão.

Nota

Você pode importar um arquivo XML de volta para ABACUS seguindo os passos 1-2acima e selecionando Importação | A partir da XML .... Depois que você selecionou o arquivo XML que deseja importar, você será solicitado como você deseja importar os padrões e tipos. Você pode importar padrões e tipos como em normas e tipos novos ou mescladas. A configuração padrão é para os padrões e tipos a serem mesclados com os padrões e tipos existentes se eles já existem na sua projeto.

Para exportar o diagrama para PNG, JPG, SVG, TIFF, GIF ou BMP

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Abra a diagramavocê gostaria de exportar.

3. Clique no Exportação Diagramno botão Diagrama barra de ferramentas.

4. o Exportação Diagramajanela irá aparecer.

5. Selecione os Procurarbotão para salvar a visualização no local desejado.

6. Selecione os Salvar como tipomenu suspenso para escolher o tipo de arquivo.

7. Clique no Guardar botão.

Para exportar seu relatório para .pdf (Adobe Acrobat), .xls (Microsoft Excel) ou.doc (Microsoft Word)

1. Verifique se você tem um Arquivo ABACUS aberto.

2. Crie um relatório você gostaria de exportar.

3. Clique no Exportarbotão na barra de ferramentas de relatórios.

4. Selecionar Excel, PDF ou Wordna caixa drop-down.

5. Aguarde alguns instantes enquanto a exportação do relatório.

6. Escolha um local e nome do arquivo e clique no Guardar botão.


Trabalhando com Enterprise Server

Navegação: Administração>

Trabalhando com Enterprise Server

Envie seus comentários neste tópico.

ABACUS Empresa Servidor é tanto um 'non-locking' abordagem colaborativa, mas um 'desconectado' um também. ABACUS é "sem bloqueio", porque não faz forçar o arquivo a ser bloqueado por um usuário para que ele seja atualizado. Cada usuário tem sua própria cópia local do arquivo, e como eles fazer alterações e salvar o seu arquivo, essas alterações são gravadas e armazenadas para quando o usuário deseja cometê-los para o servidor.

ABACUS é 'desligado' no sentido de que você não precisa estar conectado ao servidor ou precisa de acesso à rede enquanto trabalhava em um arquivo. ABACUS só requer acesso ao servidor ao executar operações como a criação de um arquivo, ou a realização de um check-out, junto com operações em um arquivo existente - atualização, cometer, ou visualizar o log do passado comete. O acesso ao servidor não é obrigado a trabalhar no arquivo, e suas alterações não são enviado para o servidor imediatamente (isto permite que você facilmente descartar suas alterações se você cometer um erro). Quando você salvar o arquivo, você está "apenas" salvar o seu cópia localmente - não é até você confirmar que suas alterações locais (as alterações feitas desde o último commit), são enviados para o servidor.

Criar um novo ficheiro Empresa

Para criar um novo arquivo de Empresa, selecione Arquivo| Novo ...e, em seguida, selecione uma das duas primeiras opções na seção Empresa Modelo do Diálogo New Project (isto é, um arquivo em branco Empresa, ou criar uma de um arquivo ABACUS existente). A terceira opção é a 'Caixa' um arquivo Empresa alguém já criou, isso será abordado na próxima seção.

Quando você optar por criar um novo arquivo de Empresas, você será dado um diálogo que permitirá que você navegue até onde em um servidor de repositório que você gostaria de armazenar o arquivo. Ele também terá o caminho do arquivo existente e nome inserido até o topo se você escolheu "Do modelo existente 'na caixa de diálogo Novo projeto e forneceu um arquivo.

URL: Este é o URL para o seu servidor de repositório onde os arquivos são armazenados ABACUS empresa. Você deve perguntar a pessoa que está a gerir o servidor o que este URL deve ser.

A imagem acima mostra um repositório com quatro (4) ABACUS projectos empresariais existentes, depois de entrar e pressionar Enter a URL. Vocês vai ver depois de criar um novo arquivo de Empresa, na próxima captura de tela para 'Caixa', haverá outra pasta e arquivo sob este repositório.

Nota

Se você estiver usando uma https (SSL) do servidor, eo servidor não tem um certificado SSL válido (comum em servidores de intranet ou não públicos, devido à a custo do certificado SSLs) Haverá uma etapa extra de tomar. Você será obrigado a aceitar permanentemente todas as conexões com o servidor na caixa de diálogo que aparece (que também irá mostrar um pouco mais informações sobre o servidor). Para fazer isso, tipo 'p' (sem as aspas) e pressione Enter. ABACUS irá aparecer uma mensagem lembrando-o deste antes de mostrar a caixa de diálogo.

Nota

Você pode ser solicitado para acessar o servidor, caso em que a pessoa que está gerenciar o servidorpode fornecer o nome de usuário e senha do servidor. Além disso, as credenciais de login para todos os servidores que você se conectou ao são salvos por isso, se por algum motivo eles precisam ser apuradas isso pode ser feito via Ferramentas | Opçõese, em seguida, sobre o Geral guia clicando Redefinir Subversion Saved Entrare selecionando o servidor a partir da lista drop-down e clicando em Limpar dados de logine selecionando OK na caixa de diálogo que aparece.

Nota

Ao contrário de captura de tela mostrada acima, normalmente um único projeto ABACUS é incluído em cada ABACUS Repository porque se mais de 1 ABACUS projeto é criado em um único ABACUS Repository, os números do log de alterações ABACUS são compartilhados entre todos os projetos ABACUS e isso pode confundir os usuários.

Preferred Matrícula: Isso afeta tanto a pasta eo nome do arquivo que será usado (se já não tomadas) ao criar o arquivo no servidor de repositório. Observe que uma nova pasta será criada automaticamente no servidor de repositório para cada arquivo (por motivos de desempenho, os arquivos ABACUS empresa são criados em sua própria pasta no local visualizado no diálogo).

Armazenar Cópia de Trabalho em Diretório: Quando um arquivo é criado na empresa um servidor de repositório, os arquivos de trabalho locais precisam ser criados no seu computador, para que você possa trabalhar no arquivo sem estar conectado à rede. Este é o lugar que você vai ver quando você deseja abrir / re-aberto um arquivo ABACUS Empresa.

Compra um Enterprise arquivo existente

Se alguém já tiver criado um novo arquivo de Empresas, você pode 'check-out' esse arquivo, que baixa uma cópia local e configura os arquivos necessários para ABACUS reconhece isso como um arquivo da empresa. A caixa de diálogo é semelhante ao New Empresa arquivo de diálogo. Digite a URL do repositório (subdiretórios podem ser incluídos na URL), selecione o arquivo desejado e clique em OK. Assunto para a nota abaixo tele arquivo será então aberta.

Nota

Você pode ser solicitado para acessar o servidor, caso em que a pessoa que está gerenciar o servidorpode fornecer o nome de usuário e senha do servidor. Além disso, as credenciais de login para todos os servidores que você se conectou ao são salvos por isso, se por algum motivo eles precisam ser apuradas isso pode ser feito via Ferramentas | Opçõese, em seguida, sobre o Geral guia clicando Redefinir Subversion Saved Entrare selecionando o servidor a partir da lista drop-down e clicando em Limpar dados de logine selecionando OK na caixa de diálogo que aparece.

Diferenças Empresa de Arquivo

Quando você tiver criado um arquivo de Empresa (quer um novo, ou através de 'check-out' de um arquivo criado por outra pessoa), uma pasta será criada para o arquivo, e vai geralmente contêm estes 3 principais tipos de arquivos:

· Arquivo '.abacus'- Este é o arquivo ABACUS si. As alterações feitas localmente não são imediatamente gravado neste arquivo, ele só é escrito para quando você comete. Este arquivo é um arquivo 'normal' ABACUS, pode ser dado a usuários não-EEcomo um projeto autônomo (sem o arquivo de log), Ou usada como ponto de partida para um novo arquivo de EE.

· Arquivo '.changes'- As alterações locais (não confirmadas) feitas para o arquivo. Se esse arquivo estiver faltando, isso significa que não há alterações locais.

· '.arquivo de log- Este arquivo tem apenas as alterações que foram feitas pelo último usuário (o conteúdo do arquivo .changes do usuário quando eles cometeram).

Nota

Existem vários outros arquivos que podem ser criados durante a atualização e cometem processos, a saber; ‘.changesbefore' arquivo- Este arquivo é uma cópia do arquivo .changes após uma atualização foi realizada e é usado para reconciliar automaticamente os conflitos de ID entre a atualização e qualquer local (não confirmada) alterações antes de cometer; ‘.cópia de segurança' arquivo- Este arquivo é uma cópia do arquivo .changes antes que um usuário salva (não confirmadas) mudanças mais locais para o arquivo .changes; e ‘.erro' arquivo- Este arquivo é uma cópia dos arquivo .changes se havia algum problema que causou a falha ABACUS para abrir o arquivo .abacus eo usuário escolheu para reverter as suas alterações.Esses arquivos podem ser ignoradas.

Abrindo um arquivo

Para abrir um arquivo, você só precisa navegar para onde você escolheu para armazenar a cópia de trabalho, e abra o arquivo ABACUS que está armazenado lá. Quando ABACUS vê que há uma .arquivo de log (e talvez um .mudanças arquivo se você tiver feito alterações), ele vai tratar o arquivo como um arquivo de Empresa.

Atualizando um Arquivo

Executando uman 'Update' irá verificar se uma versão mais recente de um arquivo está localizado no servidor. Se houver, ele vai fechar a sua imagem atual, atualizar para o arquivo mais recente do servidor, e baixar alguns arquivos temporários que têm um número como uma extensão - por exemplo, 'Demo.125'. Esses arquivos são as versões mais antigas do arquivo de log, e são usados ​​para determinar que mudanças foram feitas para um arquivo desde a última atualização-lo. Isso é necessário para detectar quaisquer conflitos que possam ter ocorrido para que você possa resolvê-los.

E se durante o processo de atualização de qualquer conflitos foram achados, Você vai precisar para resolvê-los antes que você possa abrir o arquivo novamente (você pode cancelar mas você será solicitado a resolver os conflitos novamentea próxima vez que você abrir o seu arquivo).

Salvando um arquivo

Quando você salvar um arquivo, este acrescenta todas as alterações feitas no arquivo .changes. isto nãomodificar o arquivo .abacus nesta fase - apenas quando o arquivo é enviado para o servidor vai ser gravados novamente (ou quando você receber uma atualização a partir do servidor).

Onde está o 'Salvar como'?

Não existe o conceito de Salvar como para arquivos da empresa. No entanto, pode copiar sua cópia de trabalho .abacus arquivo, mantendo em mente que ele não terá suas alterações locais na mesma.

Resolvendo Conflitos

Se outros usuários têm alterações confirmadas para o arquivo em uma parte similar do arquivo para você, pode haver alguns conflitos entre suas mudanças e seu. Por exemplo, outro usuário pode excluir um componente que você teve atualizar uma propriedade em. Você precisa se quer desfazer sua alteração (se tiver certeza de que a deles devenão ter acontecido), ou descartar sua mudança (que você pode então voltar para o arquivo e refazer a sua alteração).

Especificamente existem 4 classes de conflitos que podem ocorrer;

1. Excluir - Quando um usuário exclui um objeto que outro usuário alterar. Por exemplo. Um usuário excluído um componente, mas o usuário B mudou o nome do componente ou conectado a ele ou adicionado um componente filho a ele etc.

2. Atributo - Quando dois usuários ambas mudar exatamente o mesmo 'atributo' de um objeto. Por exemplo. Ambos usuário A e B mudou o nome de um componente ou sua descrição ou o valor de uma de suas propriedades etc.

3. Referência - Quando dois usuários mudar exatamente o mesmo 'referência' um objeto tem para outro objeto. Por exemplo. Ambos usuário A e B alteradas tipo de um componente ou o componente de fonte / dreno ligado a uma conexão ou o ponto de vista ligado para um diagrama etc.

4. Coleção - Quando dois usuários alterar uma 'coleção' de um objeto. Por exemplo. Ambos usuário A e B movido um componente de um dos pais para outro, ou re-ordenou uma coleção de crianças componentes.

Nota

Vários conflitos inconsequentes são resolvidas automaticamente por ABACUS para minimizar a sobrecarga de usuários.Por exemplo quaisquer configurações pan-zoom conflitantes para diagramas são resolvidas para manter as configurações mais recentes pan-zoom.

Cometer Alterações

Quando você optar por confirmar as alterações, o arquivo ABACUS a partir do servidor é aberto, seu local alterações são realizadas contra isso, e depois o seu local de .abacus arquivo é substituído por um que tem as suas alterações nele. Suas alterações arquivo, em seguida, substitui o arquivo de log, e tanto o arquivo .abacus eo arquivo de log são enviados para o servidor.Se a cometer é bem sucedido, um diálogo mensagem de commit como mostrado abaixo é fornecido para inserir uma mensagem com a cometer.

Visualizando um Log de Alterações

Para visualizar um registro das alterações a uma Empresa projeto, Selecione Arquivo| Exibir Log...

Máximo de entradas de log: Este será o padrão para as últimas 10 entradas, mas as entradas adicionais podem ser recuperadas, alterando o valor e clicando no Recuperar botão.

Revisão: ºcoluna e Revisão lista os números de revisão comprometidos com o servidor do Enterprise, por padrão, em ordem cronológica inversa.

Nota

Os números de revisão podem não ser contínuo, como apenas o ABACUS compromete será listado enquanto o mesmo repositório Subversion pode ser a ser utilizado para outros projetos Ábaco e / ou em outros aplicativos de controle de versão.

Encontro: ºData e coluna lista a data em que a revisão foi comprometida com o servidor do Enterprise.

Tempo: ºcoluna e Tempo indica a hora do dia (no formato 24 horas) que a revisão foi comprometida com o servidor do Enterprise.

Autor: ºAutor e coluna lista o nome de login do Microsoft Windows para o usuário que executou o commit seguido do seu Nome do usuário ABACUS , Ou 'Anonymous' se o usuário não for autenticado e foi permitido o acesso ao projeto da empresa no momento da submissão usuários anônimos.

Mensagem de Log: ºcoluna e Log Mensagem listará a mensagem de commit que foi fornecido com a revisão de acordo com a caixa de diálogo mostrada acima.

Baixar revisão XX como arquivo ABACUS autônomo: Se você selecionar uma dada revisão na tabela e, em seguida, clique no botão Download que você vai ser capaz de extrair a revisão do projeto ABACUS escolhido a partir do servidor e salvá-lo como um / stand-alone projeto ABACUS local.

Nota

Para reverter para uma revisão anterior consulte este Artigo comunidade Avolution .

(Admin) Baixar arquivo de log XML para revisão XX: Os usuários com a capacidade do administrador ABACUS pode selecionar uma dada revisão na tabela e, em seguida, clique no botão Download para extrair o projeto ABACUS escolhido cometer arquivo de log do servidor e salvá-lo como um arquivo .xml.

Visualizando uma trilha de auditoria de Mudanças

Para ver uma trilha de auditoria das alterações a qualquer elemento (ou seja, componente, conexão, vista, crianças, etc.) de um Empresa projeto, clique com o botão direito do mouse no elemento e selecionar Audit Trail..., Defina o intervalo de e para Revisão e clique Pesquisa.

Nota

Uma vez que um elemento é excluído do projeto que você já não são capazes de acessar informações específicas trilha de auditoria sobre esse elemento. Você pode, no entanto, ainda acessar o componente 'pai' (por exemplo) e ver as informações de auditoria sobre a eliminação (neste caso, listando o ID do elemento que foi eliminada).Além disso, componentes de fixação / Connection é uma "propriedade" das conexões assim que mudar um componente ligado através da janela do Explorer ou em diagramas irá mostrar na trilha de auditoria para um NÃO conexão do componente, e exclusão de uma conexão e criar uma nova conexão (como acontece se você clicar o botão direito do "Solte" e então "Conecte-se ... 'em catálogos) irá resultar em perda de informações trilha de auditoria para o componente original - anexo de conexão completamente.

Nota

Por padrão, a auditoria irá recursivamente verificar se há alterações a qualquer um dos filhos do elemento selecionado. Isso pode resultar em longos tempos de resposta e, consequentemente, a trilha de auditoria pode ser restrita ao próprio elemento, desmarcando a Recursiva opção no Opções de auditoriabotão da barra de ferramentas 'roda de engrenagem' na caixa de diálogo Audit Trail.

De Revisão: Este será o padrão para a primeira revisão / mais antigo disponível para o projeto no servidor da empresa.

Para Revisão: Este será o padrão para a última revisão / mais recente disponível para o projeto no servidor da empresa.

Nota

Depois de definir de e para revisão gama clique no botão Procurar para recuperar quaisquer alterações específicas para o elemento escolhido.

Revisão: ºcoluna e Revisão lista os números de revisão comprometidos com o servidor do Enterprise, por padrão, em ordem cronológica para a frente.

Nota

Os números de revisão são susceptíveis de ser contínuo, como apenas as revisões relevantes para o elemento escolhido serão mostrados e apenas o ABACUS compromete será listado enquanto o mesmo repositório Subversion pode ser a ser utilizado para outros projetos ABACUS e / ou aplicações de controle de versão.

Encontro: ºData e coluna lista a data em que foi feita a ação do usuário.

Nota

A data indicada é a data a ação do usuário, e não a data em que a revisão foi comprometida com o servidor do Enterprise. Assim, a data pode preceder a revisão correspondente commit data assinalada com a Arquivo | Ver Log ... comando.

Tempo: ºcoluna e Tempo indica a hora do dia (no formato 24 horas) que a ação do usuário foi feito.

Nota

O tempo mostrado é o tempo de ação do usuário, e não o tempo que a revisão foi comprometida com o servidor do Enterprise. Assim, o tempo provavelmente vai preceder a revisão correspondente dedicar tempo mostrado com o Arquivo | Ver Log ... comando.

Autor: ºAutor e coluna lista o usuário que realizou Microsoft Windows nome de login do ação seguido do seu Nome do usuário ABACUS , Ou 'Anonymous' se o usuário não for autenticado e foi permitido o acesso ao projecto de empresa usuários anônimos no momento da ação do usuário.

Nota

O autor listado na caixa de diálogo Trilha de auditoria podem não necessariamente coincidir com o autor listado na caixa de diálogo View Log acima para a mesma revisão. Isso ocorre porque as listas de diálogo Exibir registro do usuário logado no momento do commit, enquanto as listas de diálogo Audit Trail do usuário logado no momento da ação do usuário, e é possível ter um usuário fazer alterações e enviar o seu. mudanças de arquivo para outro usuário de cometer - como é o caso quando um usuário externo (tais como Avolution) é trabalhar em um projeto de EE.

Detalhes: ºDetalhes e coluna lista os detalhes exatos da ação do usuário, como registrado no servidor do Enterprise.

Dica

É útil grupo pela coluna Revisão (como mostrado na janela acima) e ou da coluna / Ação do Usuário para facilmente classificar as alterações para o elemento de interesse.

O uso de scripts com arquivos da empresa

Se você usar scripts com arquivos da empresa, você deve estar ciente de como eliminar corretamente um objeto a partir do modelo. Geralmente, quando você estiver excluindo um objeto, você irá chamar o método .Delete () sobre ele, e não apenas removê-lo de seu pai.

Por exemplo. se você tivesse Comp1 como o pai de comp2 e que deseja excluir comp2 no seu script, você deve chamar comp2.Delete (), em vez de comp1.Components.Remove (comp2).

Você pode usar remover se você pretende adicionar o objeto comp2 para outro lugar dentro da arquitetura, mas não deve ser utilizado se a intenção é a de excluir o objeto.

Há uma exceção a esta, para quando você quiser remover um objeto que 'vive' em outras partes do modelo. Quando você quiser remover uma instância padrão a partir de uma arquitetura / componente / conexão, então você deve fazê-lo, retirando-o padrão de coleção da instância - Arch1.Implementações.remove (Imp) - porque excluí-lo iria removê-lo de todas as instâncias.

Corretamente usando Excluir em scripts é importante porque se um objeto é removido do ObjectModel e não re-adicionado, então não será capaz de ser localizado, mas desde que não foi especificamente 'excluído', detecção e resolução de conflitos não vai detectar corretamente um conflito se outro usuário foi a tentativa de usar esse objeto em qualquer de suas alterações, eo resultado final será um conjunto corrompido de mudanças para esse usuário.

Veja também

Como é uma arquitetura representada em ABACUS?


Trabalhando com Permissões

Navegação: Administração>

Trabalhando com Permissões

Envie seus comentários neste tópico.

Projetos ABACUS pode ter baseada em funçõespermissões definidas para cada elemento dentro do repositório. Especificamente, de grão fino Create-Read-Update-Delete (CRUDPermissões) pode ser definido no "objeto" (ou seja, o componente ou a conexão), visualizar e atributo (ou seja, de propriedade) níveis.

Visão geral

Ao trabalhar com o ABACUS Empresa Servidor , ABACUS fornece, permissões CRUD refinadas baseadas em funções para controlar o acesso de vários usuários para o repositório.

Nota

Para configurar permissões em um projeto ABACUS a licença de usuário necessária a capacidade de administrador. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

As permissões podem ser definidas para as arquiteturas, componentes e conexão tipos, propriedades (via seus tipos), modelos, pontos de vista e diagramas, catálogos, matrizes, gráficos e 3Dvisualizações. Quando as permissões estão definidas para um tipo de componente ou conexão de todas as ocorrências desse tipo em nenhum arquiteturas em que o projeto 'herdar' essas permissões. Da mesma forma, quando uma permissão é definida para uma propriedade de um componente ou tipo de conexão, a propriedade dada nas instâncias de componentes ou de conexão em qualquer arquiteturas em que o projeto 'herdar' essas permissões. Por conseguinte, certas permissões vai ser aplicada às vistas em que existem esses elementos. Quando as permissões são definidas para um diagrama, a vista e / ou o conteúdo da vista em si tem várias permissões aplicadas a ele.

Nota

Por padrão não há permissões são definidas para os elementos dentro de um projeto de ABACUS. Isso é todos os elementos são Createable, legível, atualizável e apagáveis ​​por todos os usuários. Desta forma, as permissões devem ser consideradas apenas para um determinado elemento no repositório quando uma determinada permissão é ser restringidopara um certo grupo de utilizadores. Por exemplo, se as permissões para um determinado grupo de usuários foram adicionados a um objeto (por exemplo, um tipo de componente), mas deixou com todas as permissões ativadas, então este é funcionalmente o mesmo que se esse grupo de usuários não foi adicionado ao objecto.

Permissões não podesser definido para os casos específicos de elementos de uma arquitetura. Por exemplo, você não pode fazer um componente da aplicação actualizável ainda outro não. Para alcançar efetivamente essas permissões 'de domínio específicos "no entanto, o administrador pode configurar tipos de elementos específicos para os domínios apresentados, por exemplo, 'Aplicação - domínio CRM' tipos de componentes e 'Aplicação - domínio HR', e em seguida, defina as permissões para cada tipo de acordo. Você pode fazer tipos de agrupamento específicos para cada domínio e, em seguida, remover a permissão atualização para o tipo de grupo de domínio específico e isso vai restringir criações e supressões no âmbito daquele agrupamento, mas não atualizar das crianças. É claro que se o Agrupamento de domínio específico foi escondido pela remoção de permissão de leitura, em seguida, as crianças seria escondido e, assim, não atualizável. Alternativamente, se ao invés de visualizações (explorador) são usados ​​principalmente para gerir / visualizar seu repositório, uma determinada visão para cada domínio pôde ser estabelecida, e, em seguida, o administrador pode definir as permissões para cada modo de exibição em conformidade.

Gerenciamento de Usuários e Grupos

As permissões são definidas no Função ou gruponível, em oposição ao nível de utilizador individual, de modo que, enquanto membros dos grupos podem ser alteradas, as permissões pode permanecer fixo. Claro, se você quer uma permissão do usuário específico, em seguida, simplesmente torná-los um grupo, ou mais precisamente criar um grupo com esse usuário como o único membro.

Deve notar-se que os grupos são atômico, Ou seja, eles não podem herdar permissões ou usuários de um para outro, e se um usuário pertence a vários grupos, em seguida, a permissão grupo mais 'pessimistas' terão precedência em uma base caso-a-caso para cada permissão individual (ie Criar --Read-Actualização Excluir). Por exemplo, se o mesmo usuário é um membro do Grupo A e do Grupo B e Grupo A acaba de criar-leitura permissão para os tipos de componentes de aplicativos enquanto o Grupo B acaba de leitura Atualização permissão para tipos de componente de aplicação, em seguida, o usuário só terá permissão de leitura para instâncias de componentes de aplicação.

Além disso, por padrão, usuários anônimos(isto é os usuários que não tenham sido definidos ou que não estejam logados) têm acesso completopara o projeto. Isto é para assegurar que o acesso está disponível numa configuração inicial. Para bloquear o acesso por usuários anônimos basta desmarcar a 'Permitir acesso completo usuário anônimo no arquivo' opção em Gerenciar Usuários / Grupos de diálogo mostrada abaixo. Quando os usuários anônimos não verificadas só será capaz de ver a parte de Padrões de qualquer projeto.

Finalmente, a autenticação de nome de usuário, se a opção "Usar o Windows usuário Login 'está marcada é realizada contra as janelas Nome de usuário Logins na máquina de cada usuário contra o nome de usuário do informado como por abaixo. Isto é, se o usuário do Windows Login de máquina de um determinado usuário existe como um nome de usuário válido, então nenhuma senha é necessária e que o usuário é automaticamente autenticado. Nota: isso efetivamente permite o uso do Windows Active Directory (AD) de autenticação.

Nota

Dado que as permissões são definidos apenas quando eles precisam ser tirado (restrito) de um usuário, qualquer usuário que não é membro de um grupo, ou qualquer grupo que não tem permissões definidos para ele contra nenhum objeto, terá acesso total a o projeto.

Usuários e Grupos de Usuários

Para criar um novo usuário

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

Nota

Se você não vê o Gerenciar Usuários / Grupos item de menu, em seguida, você não tem a capacidade de administrador. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

2. Na caixa de diálogo que aparece, selecione a Adicionar usuáriobotão e digite um nome de usuário e senha na caixa de diálogo Criar Novo Usuário. Nota: Os nomes de usuário e senhas são sensíveis ao caso.

Nota

Se a opção 'Usar o Windows usuário Login' está marcada como descrito acima, em seguida, uma senha simulada pode ser inserido como autenticação será realizada de acordo com a Janela do usuário Nome de usuário única Login.

2. Por padrão, você verá que o Os usuários podem alterar suas próprias senhas. Se necessário, o administrador pode remover ABACUS a capacidade dos usuários para definir sua própria senha de desmarcandoas caixas de seleção.

Nota

Se os usuários podem alterar suas próprias senhas terão um Arquivo | Alterar a senha...item de menu para o fazer.Além disso, estar ciente de que, se várias pessoas usam o mesmo nome de usuário, em seguida, um usuário poderá alterar a senha de tal forma que não há outras pessoas podem acessar mais tarde. Consequentemente prática, recomenda-se ter um nome de usuário único por pessoa real.

4. Opcionalmente, digite o endereço de e-mail, Localização e Número de telefone para os usuários para referência futura.

5. Clique no Está bembotão na caixa de diálogo Criar Novo Usuário.

6. Clique no Está bem botão.

Nota

Uma vez que você criou seu primeiro usuário que você deve considerar bloqueando o acesso por usuários anônimos, desmarcando a 'Permitir acesso completo usuário anônimo no arquivo' opção na / Grupos de diálogo Gerenciar Usuários.Além disso, uma vez que um usuário foi criado (e se um projeto Enterprise, a mudança comprometida com o servidor), a próxima vez que o projeto é aberto os usuários serão solicitados a Entrar para acesso autenticadode acordo com a caixa de diálogo mostrada abaixo. Se o Entrar automaticamente com esses detalhesopção estiver marcada, então a combinação nome de usuário / senha será lembrado para o projeto e aplicado a cada vez na abertura. Para limpar o login salvos selecione Arquivo | Limpar Saved Entrardepois de abrir e você será solicitado a entrar novamente na próxima vez que você abrir o projeto.

Entrar

Para excluir um usuário existente

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

2. Na caixa de diálogo que aparece, selecione o nome do usuário no painel de usuário que você deseja excluir e, em seguida, selecione o Excluir Usuário botão.

3. Clique no Está bem botão.

Para criar um novo grupo

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

2. Na caixa de diálogo que aparece, selecione a Adicionar grupobotão e digite um nome de grupo no painel de Grupos.

Nota

Os nomes de grupos devem ser exclusivos.

3. Clique no Está bem botão.

Para copiar um existente Grupo

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

2. Na caixa de diálogo que aparece, selecione a Cópia Grupo botão.

Nota

Um grupo duplicado será criado com o prefixo "Cópia de".Por padrão, todas as permissões do grupo copiado será duplicada para a "Cópia de" grupo incluindo qualquer atribuição de usuário.

3. Renomeie o "Cópia de" grupo como apropriado usando Editar Grupoou lento duplo clique.

Para excluir um grupo existente

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

2. Na caixa de diálogo que aparece, selecione o nome do grupo no painel Grupos que você deseja excluir e, em seguida, selecione o Excluir grupo botão.

Nota

Todas as atribuições de usuário ao grupo também serão removidos.

3. Clique no Está bem botão.

Para atribuir um usuário a um grupo

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

2. Na caixa de diálogo que aparece, selecione o nome do usuário no painel de usuário que você deseja atribuir a um grupo e drag-and-drop-lo para o nome do grupo no painel Grupos que você deseja atribuir.

3. Clique no Está bem botão.

Nota

O grupo (s) que um usuário é atribuído a são mostrados através da expansão da Nome de usuário no painel de Usuáriose os usuários que são atribuídos a um grupo são mostrados expandindo o nome do grupo no painel de Grupos. Por exemplo, na figura acima, o utilizador "AS1-Aus" é atribuída a três (3) grupos, a saber; "App Equipe de Suporte 1", "real" e "Austrália".

Para cancelar a atribuição de um usuário de um grupo

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

2. Na caixa de diálogo que aparece expandir o nome do grupo que contém a atribuição do usuário que você deseja remover a atribuição e selecione o nome do usuário.

3. Clique no Unassign Usuário botão.

4. Clique no Está bem botão.

Para importar usuários e / ou grupos (e quaisquer permissões correspondentes)

1. Selecionar Arquivo| Gerenciar Usuários / Grupos

2. Clique no Importar botão.

3. Na caixa de diálogo que aparece Procurare abrir o projeto ABACUS que contém os usuários e / ou grupos (e permissões) que você deseja importar para o projeto atual e clique Aberto. Os Usuários e Grupos será importado e um diálogo Resultados de importação aparecer resumindo a importação dos usuários e / ou grupos. Clique no Está bem botão.

Nota

Se os usuários ou grupos importados já existia no projeto atual, em seguida, eles serão mesclados com os usuários ou grupos existentes.

4. Clique no Está bembotão voltar no principal Gerenciar usuários de diálogo / Grupos.

5. Se houver qualquer tipo de harmonização, Viewpoints, Modelos ou Arquiteturas entre o projeto atual eo projeto ABACUS você está importando de, completos com permissões que ainda não existem no projeto atual, as permissões são importados e um segundo diálogo Resultados de importação será exibida, resumindo a importação. Clique no Está bem botão.

Nota

Permissões somente são adicionados aos tipos existentes (e suas propriedades), pontos de vista, Modelos ou Arquiteturas para os grupos em que não já existem as permissões para o Grupo. Ou porque o grupo é novo ou o Grupo já existia no projeto atual, mas nenhuma permissão havia sido designado para esse grupo a esse item. Não há 'fusão' de permissões para itens onde as permissões já existentes para o Grupo no projeto atual de harmonização.

Definindo permissões

As permissões podem ser definidas para as arquiteturas, componentes e conexão tipos, propriedades (via seus tipos), modelos, pontos de vista e diagramas, catálogos, matrizes, gráficos umd 3Dvisualizações. Quando as permissões estão definidas para um tipo de componente ou conexão de todas as ocorrências desse tipo em nenhum arquiteturas em que o projeto 'herdar' essas permissões. Da mesma forma, quando uma permissão é definida para uma propriedade de um componente ou tipo de conexão, a propriedade dada nas instâncias de componentes ou de conexão em qualquer arquiteturas em que o projeto 'herdar' essas permissões. Por conseguinte, certas permissões vai ser aplicada às vistas em que existem esses elementos. Quando as permissões são definidas para um diagrama, a vista e / ou o conteúdo da vista em si tem várias permissões aplicadas a ele.

Gerenciamento de Permissões

Para definir a permissão para um componente (ou conexão) Digite

1. Expanda o Tiposgalho da árvore.

2. Expanda o Componente (ou conexão) Tiposgalho da árvore.

3. Expandir Grupos onde necessário.

4. Botão direito do mouse no Componente (ou conexão) Digiteque pretende definir as permissões para e selecione Editar permissões.

5. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

6. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

Nota

Criar permissão governa também quando você pode copiar um elemento. Assim, para ser capaz de copiar um elemento requer permissão para criar em todos os seus filhos (uma vez que para copiar o elemento significa copiar tudo isso abaixo). Removendo a permissão de atualização a partir de um elemento remove a capacidade de modificar o próprio tipo, mesmo se o usuário tem o Designer add-on e também remove a permissão de atualização para todas as suas propriedades. Um elemento pai deve ter permissão de atualização para ser capaz de Criar quaisquer elementos ou crianças Apagar sua existir elementos filhos. Excluir permissão para um elemento também requer permissão para apagar todos os seus filhos. Excluir permissão para componentes também requer permissão atualização de todas as conexões anexadas.E, finalmente, a remoção de permissão Excluir a partir de um elemento remove a capacidade de excluir o próprio tipo, mesmo se o usuário tem o Designer add-on.

7. Clique no Está bem botão.

Para definir a permissão para um grupo de componentes (ou conexão) Tipos

1. Expanda o Tiposgalho da árvore.

2. Expanda o Componente (ou conexão) Tiposgalho da árvore.

3. Botão direito do mouse no Grupoque contém o componente (ou conexão) Tipos que você deseja definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

6. Clique no Está bem botão.

7. Na caixa de diálogo que aparece, clique no sim botão.

Para definir a permissão para uma propriedade

1. Expanda o Tiposgalho da árvore.

2. Expanda o Componente (ou conexão) Tiposgalho da árvore.

3. Expandir Grupos onde necessário.

4. Selecione o componente (ou conexão) Digite que contém a propriedade que você deseja definir as permissões para.

5. Na janela Propriedades clique com o botão direito no Propriedadeque pretende definir as permissões para e selecione Editar permissões.

6. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

7. Por padrão, você vai ver que as permissões de leitura e Atualizar estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

Nota

As propriedades que tiveram a permissão de atualização removidos são mostrados na itálicona janela Propriedadese seus valores não podem ser atualizados por essa função. Além disso, a capacidade de modificar os detalhes de uma propriedade (por exemplo, o nome, unidades etc.) requer a permissão de atualização na propriedade e Designer add-on.

8. Clique no Está bem botão.

Para definir a permissão para um modelo

1. Expanda o Modelosgalho da árvore.

2. Navegue até o Modeloque você está interessado.

3. Botão direito do mouse no Modeloque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que a permissão de leitura está disponível. Remova a permissão por desmarcandoa caixa de seleção.

6. Clique no Está bem botão.

Para definir a permissão para um Ponto de Vista

1. Expanda o Pontos de Vistagalho da árvore.

2. Expandir Grupos onde necessário.

3. Botão direito do mouse no Ponto de vistaque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

6. Clique no Está bem botão.

Para definir a autorização de uma Arquitetura

1. Expanda o Arquiteturasgalho da árvore.

2. Expandir para o Arquiteturaque você está interessado.

3. Botão direito do mouse no Arquiteturaque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que a permissão de leitura está disponível. Remova a permissão por desmarcandoa caixa de seleção.

6. Clique no Está bem botão.

Para definir a permissão para uma Catálogo

1. Expanda o Catálogosramo da arquitetura que você está interessado.

2. Expandir Grupos onde necessário.

3. Botão direito do mouse no Catálogoque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

6. Clique no Está bem botão.

Para definir a permissão para uma Matriz

1. Expanda o Matrizesramo da arquitetura que você está interessado.

2. Expandir Grupos onde necessário.

3. Botão direito do mouse no Matrizque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

6. Clique no Está bem botão.

Para definir a permissão para um diagrama

1. Expanda o Diagramasramo da arquitetura que você está interessado.

2. Expandir Grupos onde necessário.

3. Botão direito do mouse no Diagramaque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

Nota

Enquanto você pode definir as permissões CRUD diretamente para um diagrama, deve notar-se que as permissões dos elementos no diagrama pode afetar as permissões para o próprio ponto de vista. Por exemplo, se houver mesmo apenas um elemento na visão que teve seu ler ou atualizar permissão removido, em seguida, o diagrama terá a sua permissão Atualização removido. Isso é porque; a) os elementos na vista que tiveram sua permissão de leitura removido não será mostrado na vista deixando "espaço branco" onde você poderia colocar alguns elementos novos, se a vista era actualizável, e b) os elementos na vista que tiveram sua permissão Atualização removido poderia então ter outros elementos caiu sobre eles se tornarem filhos se a vista era atualizável. Além disso, criar e permissão de atualização para um diagrama exige que todos os elementos na vista tem a permissão de leitura e os componentes têm a permissão Update (isso é porque para mover um componente para outro componente, você deve ser capaz de atualizá-lo, uma vez que vai tornar-se uma criança).

6. Clique no Está bem botão.

Para definir a permissão para uma vista 3D

1. Expanda o 3D Visualizaçõesramo da arquitetura que você está interessado.

2. Expandir Grupos onde necessário.

3. Botão direito do mouse no Ver 3Dque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

6. Clique no Está bem botão.

Para definir a permissão para uma Gráfico

1. Expanda o Chartsramo da arquitetura que você está interessado.

2. Expandir Grupos onde necessário.

3. Botão direito do mouse no Gráficoque pretende definir as permissões para e selecione Editar permissões.

4. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

5. Por padrão, você verá que o CRUD permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

6. Clique no Está bem botão.

Veja também

Como é uma arquitetura representada em ABACUS?


Trabalhando com Dashboards

Navegação: Administração>

Trabalhando com Dashboards

Envie seus comentários neste tópico.

Projetos ABACUS pode ter qualquer configuração de pontos de vista (por exemplo, diagramas, Cartas, etc.) salvos como um painel de controle e esses dashboards podem ser salvos definido como o padrão de partida 'tela' sobre a abertura de um projecto e / ou atribuído a um específico grupo de usuários e apresentado aos membros daquele grupo de usuários quando fazem login em um projeto ABACUS.

Nota

Para configurar dashboards em um projeto ABACUS a licença de usuário necessária a capacidade de administrador. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

Ver os painéis

Um exemplo Application Portfolio Management (APM) dashboard

Para visualizar um painel salvos

1. Selecionar Visão| Dashboards

2. Selecione um dashboard salva a partir da lista de painéis disponíveis.

Nota

Uma vez selecionado ABACUS vai construir os pontos de vista necessários para o painel de instrumentos, o que pode demorar alguns segundos. Por favor, seja paciente.

Gerir Dashboards

Gerir Dashboards

Para criar um novo painel

1. Abra as vistas necessárias e organizar e doca janelas como necessário para o painel de instrumentos.

2. Selecionar Visão| Dashboards| Gerir Dashboards ...

Nota

Se você não vê o item de menu Gerir Dashboards, em seguida, você não tem a capacidade de administrador. Entre em contato com o administrador do local ou ABACUS Suporte Avolution se você precisar deste recurso.

3. Na caixa de diálogo que aparece, selecione a Criobotão e digite o nome do painel na caixa de diálogo Criar Nova Dashboard.

4. Clique no Está bem botão.

Para excluir um painel existente

1. Selecionar Visão| Dashboards| Gerir Dashboards ...

2. Na caixa de diálogo que aparece, selecione o painel que deseja excluir da lista e escolha a Excluir botão.

Nota

A exclusão de um painel também irá apagar quaisquer atribuições de grupos de usuários para esse painel.

3. Clique no Está bem botão.

Para substituir um painel existente

1. Abra as vistas necessárias e organizar e doca janelas como necessário para o painel de instrumentos de substituição.

2. Selecionar Visão| Dashboards| Gerir Dashboards ...

3. Na caixa de diálogo que aparece, selecione o painel que pretende substituir a partir da lista e escolha a Substituir botão.

4. Clique no Está bembotão para reconhecer o diálogo Painel substituído.

Para atribuir um Painelcomo a tela inicial padrão

1. Selecionar Visão| Dashboards| Gerir Dashboards ...

2. Na caixa de diálogo que aparece, selecione o Painel da lista que você deseja atribuir como "tela" do início padrãoe selecione a Atribuir... botão.

3. Na caixa de diálogo que aparece, selecione a entrada na coluna Grupos Usuário.

Nota

Somente um painel pode ser atribuir como o começar a 'tela' para re-atribuição irá remover o atribuição do painel anterior.Além disso, se o usuário fizer como um membro de um grupo de usuários que tem um painel de controle atribuído, em seguida, o painel de instrumentos atribuído será aberta em vez do painel do projeto padrão.

4. Clique no Está bem botão.

Para atribuir um grupo de usuários a um Painel

1. Selecionar Visão| Dashboards| Gerir Dashboards ...

2. Na caixa de diálogo que aparece, selecione o Painel da lista que você deseja atribuir um grupo de usuários e selecione o Atribuir... botão.

3. Na caixa de diálogo que aparece, selecione a Grupo de Usuários (ou Grupos)que você deseja atribuir o painel de instrumentos como o 'start up' tela para.

Nota

Se o mesmo grupo de usuário é atribuído a vários painéis, em seguida, a primeira tarefa na lista será usada.

4. Clique no Está bem botão.

Para cancelar a atribuição de um grupo de usuários a partir de um painel

1. Selecionar Visão| Dashboards| Gerir Dashboards ...

2. Na caixa de diálogo que aparece expandir o item Painel da lista que você deseja remover a atribuição de um grupo de usuários de.

3. Selecione o grupo de usuário que você deseja remover a atribuição e escolha a Unassign botão.

4. Clique no Está bem botão.

Definindo permissões

As permissões podem ser definidas para dashboards para permitir o dashboard para ser visualizado, Atualizável e / ou apagáveisa determinados grupos de usuários.

Gerenciamento de Permissões

Para definir a permissão para um Painel

1. Selecionar Visão| Dashboards| Gerir Dashboards ...

2. Na caixa de diálogo que aparece, selecione o Painel da lista que você deseja definir permissões para e selecione o Permissões ... botão.

3. Na caixa de diálogo que aparece, clique no Adicionar...botão e selecione a Grupoque você deseja adicionar clicando duas vezes nele ou selecionando-o e clicando no Está bem botão.

4. Por padrão, você verá que a Leia, UPDATE e DELETE permissões estão todos disponíveis. Remover as permissões, desmarcandoas caixas de seleção relevantes.

5. Clique no Está bem botão.

Veja também

Personalizando a interface ABACUS | Trabalhando com Permissões


Registrando ABACUS

Navegação: Referência>

Registrando ABACUS

Envie seus comentários neste tópico.

Quando você começa a ABACUS (ou depois de uma licença temporária expirou) você precisará registrar o pedido contra o servidor de licenças de Avolution usando uma chave de licença único fornecido pelo Administrador do ABACUS local ou directamente a partir Avolution. Se você não tem uma chave de licença, por favor entre em contato com o administrador do local ou ABACUS Suporte Avolution .

Para se registrar com uma chave de licença

1. Depois da instalação, iniciar ABACUSpor qualquer um duplo clique no atalho no desktop ou no menu Iniciar do Windows.

2. Na caixa de diálogo que aparece Registro entrar no Chave de licença de 26 caracteresfornecida pelo administrador local ou ABACUS Apoio Avolution , Ou clique Procurar ...e selecione o arquivo .dlsc assinado retornado de Suporte Avolution de acordo com a nota na Etapa 4 a seguir. Se estiver usando um arquivo .dlsc assinado corretamente ABACUS deve começar como por Passo 5 abaixo.

Dica

Você pode colar a chave de licença para o diálogo copiando-o para a área de transferência do Windows e, em seguida, selecionando o fundo da caixa de diálogo e pressionando Ctrl + V.

Diálogo Registro

3. Clique Está beme se a chave de licença é uma chave de licença válida ABACUSABACUS agora vai tentar entrar em contato com servidor de licenças de Avolution para autenticar a chave de licença.

Nota

Se você receber uma Código de Instalação é inválidoerro de registro é mais provável que você digitou o código corretamente. Tente copiar e colar o código conforme a Dica mencionado acima.

Entrando em contato com o License Server Avolution

4. Clique Está beme depois de um breve período de tempo ABACUS deve registrar com sucesso.

Registro de sucesso

Nota

Se você receber uma Não é possível contatar servidor de licençaserro de registro é mais provável que um firewall (ou outras medidas de segurança) na sua rede estão a impedir o acesso ao servidor de licenças de Avolution. Clique Está bem, Salve o arquivo .dlsc para sua máquina local e, em seguida, ou enviar e-mail o arquivo para .dlsc Suporte Avolution e aguardar novas instruçõesou tentar assinar o arquivo de licença-se com a seguinte URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Não é possível contatar o servidor de licença

Abra a página de assinatura de Licença

Licença manual de assinatura webpage

Alternativamente, se você começar a Este código de instalação tem sido utilizado em mais sistemas do que o permitido pela licençaerro de registo, é provável que a sua máquina local foi reconstruído desde a última registrado ABACUS ou você está tentando registrar com chave de licença de outro usuário. Entre em contato com o administrador do local ou ABACUS Suporte Avolution .

Código de instalação já foi utilizado

5. Clique Está beme se registrou com êxito ABACUS deve abrir com o Tela Bem-Vindo .

Veja também

Suporte Avolution | O que ABACUS fazer?


ABACUS instalação pré-requisitos

Navegação: Referência>

ABACUS instalação pré-requisitos

Envie seus comentários neste tópico.

Informações sobre Visio Importação e Excel Import / Export

ABACUS requer que o Microsoft Office ser instalado a fim de realizar operações Excel Importação / Exportação e Importação Visio. Por favor verifique se Microsoft Office 2003 ou mais recenteestá instalado corretamente. Se você tiver outros problemas, entre em contato Suporte Avolution .

A fim de executar as operações de importação e Visio Excel Import / Export, ABACUS usa o Microsoft Office assemblagens interoperabilidade primária (PIA de). ABACUS atualmente vem embalado com os conjuntos necessários para executar Excel Import / Export e Import Visio.

Informações sobre SQL Servidor de importação

ABACUS requer que o Microsoft SQL Server 2005, 2008, 2008 R2, 2012 ou 2014está instalado, a fim de iniciar um novo projeto de SQL Server. Por favor verifique se Microsoft SQL Server 2005, 2008, 2008 R2, 2012 ou 2014está instalado corretamente. Se você tiver outros problemas, entre em contato Suporte Avolution .

Erros abrir visualizações 3D

Se o ABACUS 3D Viewer não funcionar para você, você pode estar perdendo a SlimDX DirectX Runtime (instalado como parte do total ABACUS EXE instalar). Isso pode ser baixado Aqui . Se você tem uma versão de 64 bits do Windows, você também pode precisar instalar esta .

Erros Edição ÁBACO personalizadas Relatórios

Edição ABACUS 'Custom Reports requer Report Builder 3.0 para ser instalado. ABACUS eo Report Builder são construídos sobre .NET Framework 4.0, da Microsoft, e enquanto ambos não exigem .NET Framework 3.5 da Microsoft, a Microsoft configurado incorretamente o Report Builder MSI para continuar somente se .NET Framework 3.5 da Microsoft está instalado.

Assim, Avolution tem uma versão editada do arquivo de instalação MSI Report Builder, que não requer .NET Framework 3.5 da Microsoft, este pode ser baixado Aqui .

O original Microsoft Report Builder MSI pode ser baixado Aqui . Se você ainda não tiver o Microsoft .NET Framework 3.5 que vai exigir, você pode baixá-lo Aqui . Nota: Para várias instalações, o off-line de instalação do .NET Framework 3.5 da Microsoft a partir de Aqui pode ser mais apropriado.


Opções de linha de comando

Navegação: Referência>

Opções de linha de comando

Envie seus comentários neste tópico.

Você pode executar várias operações ABACUS diretamente da linha de comando com a operação mais comum é para abrir um arquivo de projeto específico e publicá-lo em HTML.

Especificamente, o uso de linha de comando de ABACUS é o seguinte;

ABACUS.exe projectfile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "USUÁRIO" / "PASS"]

Argumento | Descrição
Projectfile | O projectfile pode ser um arquivo ABACUS projeto (.abacus), arquivo de biblioteca (.abacuslib), o arquivo XML (.xml) ou MS Access DB (mdb) eo arquivo especificado será aberta (se .abacus ou .abacuslib ) ou um novo projeto criado (se .xml ou .mdb).
OptionalFile | O OptionalFile pode ser um roteiro ABACUS (.abacusscript, .vb ou .cs), macro (.abacusmac) ou arquivo de biblioteca (.abacuslib) eo arquivo especificado ou será executado após a abertura da projectfile (se .abacusscript, .vb ou cs ou .abacusmac) ou simplesmente aberta (se .abacuslib).
/ exitOnCompletion | Sairá ABACUS e, se necessário salvar e cometer quaisquer alterações aos projectos .abacus abertas na conclusão de qualquer script ou macro. Nota: Esta bandeira é sensível a maiúsculas isso não deixe de usar um 'O' maiúscula e 'C' no texto como mostrado.
/ dontShowDialogs | Irá impedir ABACUS Enterprise Edition (EE) caixas de diálogo de notificação de atualização de mostrar ao abrir um projeto. Nota: Esta bandeira é sensível a maiúsculas isso não deixe de usar uma maiúscula 'S' e 'D' no texto como mostrado.
/ user "USUÁRIO" / "PASS" | O USUÁRIO usuário e senha PASS será usado para efetuar login no projeto com, substituindo todas as credenciais do usuário salvos. Nota: As aspas duplas devem ser colocadas em torno das bandeiras de usuário e passar e duas aspas duplas podem ser utilizados para escapar aspas duplas em ambos os sinalizadores UTILIZADOR ou passar.

Por exemplo.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / user "Público" / pass "123456"

quando executado a partir do diretório onde a ABACUS.exe binário é localizado irá aberto o projeto de exemplo e faça login como usuário com senha Público 123.456 (conforme descrito Aqui ), Publicá-lo em HTML e, em seguida, fechar o projeto tudo sem mostrar quaisquer caixas de diálogo ao longo do caminho (por exemplo, "Atualização bem sucedida" ou "Não há atualizações disponíveis" para os projectos da empresa).

Por exemplo.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Catálogo Excel Import.vb"/ exitOnCompletion / dontShowDialogs

quando executado a partir do diretório onde a ABACUS.exe binário é localizado irá aberto o projeto de exemplo e importar os "Servidores (2014 Real) .xlsx" Arquivo MS Excel para o catálogo 'servidores' do '2014 Actual' arquitetura do projeto sem mostrar quaisquer caixas de diálogo ao longo do caminho e, em seguida, fechar o projeto na conclusão. Se a operação faz alterações para o projeto, em seguida, ao fechar as alterações são salvas localmente e se um projeto Enterprise comprometida com o Enterprise Server.

Nota

Certifique-se de usar o caractere de aspas duplas correto, pois há vários no conjunto de caracteres ASCII padrão e o Prompt de Comando do Windows só irá funcionar corretamente com o correto. A dupla código de caracteres citação correta é decimal 34 (hexadecimal 22).Isto é o que é usado no exemplo acima para se sentir livre para copiar / colar-lo de lá.


Folha de rosto

ÁBACO

aviso Legal

Avolution Pty Ltd não faz representações ou garantias com relação a este manual e, na máxima extensão permitida por lei, expressamente limita a sua responsabilidade por violação de qualquer garantia que pode ser implícito para a substituição deste manual com o outro. Além disso, Avolution Pty Ltd reserva-se o direito de revisar esta publicação a qualquer momento sem incorrer a obrigação de notificar qualquer pessoa sobre a revisão.

Direitos autorais

Direitos autorais 2001-2015Avolution Pty Ltd. Todos os direitos reservados.

Marcas Registradas

Avolution Pty Ltd fez todos os esforços para fornecer informações sobre a marca nomes de empresas, produtos e serviços mencionados neste manual. Marcas comerciais mostrados abaixo foram obtidos a partir de várias fontes.

Microsoft Windows, Access, Visio, Excel, SQL Server e Internet Explorersão marcas registradas da Microsoft Corporation.

Aviso geral:

Alguns nomes de produtos utilizados neste manual são utilizados apenas para fins de identificação e podem ser marcas comerciais de suas respectivas empresas.

Dezembro 2015Edition para Avolution ABACUS Versão 4,5.

Manual de Revisão 1.0

Gerado, impresso e encadernado em Austrália.