Что ABACUS делать?

Навигация: Введение в ABACUS>

Что ABACUS делать?

Отправить комментарии на эту тему.

Для помощи в других языках / переводы нажмите Вот .

ABACUS занимает догадки из решения решений, систем, программного обеспечения, информации, технологий, бизнес-процессов и / или целых предприятий (совместно именуемые архитектур). Это может помочь вам прагматично дизайн, мониторинг, моделировать, анализировать и визуализировать архитектура путем моделирования его, анализируя его в интуитивных путей (например, схемы, диаграммы и 3D), а затем оценить его против ваших нефункциональных требований.

Заметка

Номера для функциональных требованийте требования, которые не касаются непосредственно как продукт работает. Вместо этого, они обеспокоены тем, как хорошо она работает. Номера для функциональных требований включают в себя такие вещи, как производительность, открытость, evolvability, качества, масштабируемости, модульности и т.д. (в отличие от функциональных требований, как, включите этом свете, когда эта кнопка нажата). Традиционно, нефункциональные требования было трудно - если не невозможно - измерить. На самом деле, счеты единственный продукт, который может объективно и количественно измерить первые три - представление, открытость, а также evolvability.

Проще говоря, вы входите в архитектуру и что вам нужно это делать. ABACUS то говорит вам, если он будет делать, как требуется, и указывает каких-либо недостатков или пробелов.

ABACUS опирается на более чем 20 лет исследований систем и еще много лет, установленного теории систем. Это дает вам измеримые, надежные, объективные ответы, так что вы не полагаться на субъективные оценки.

ABACUS выступает за Architecture-BAsed Aнализ, Communication и Understandingиз Systems. Это может помочь вам с любой масштабной архитектуры, но это как правило, используется в течение четырех (4) вещей:

· Развивающийсяток архитектура. Например, если ваш существующий архитектура не хватает производительности, ABACUS будет визуализировать архитектуру для вас, выявление проблем (узкие места, и т.д.), то скажу вам в точкукак улучшить архитектуру.

· Проектированиеновая архитектура. Например, если вам нужно полностью новую архитектуру, и вы разрабатываете сами, ABACUS скажет вам, в точкукакие компоненты вам нужно, и как они должны быть подключены.

· Закупкановая архитектура. Например, если вы назвали тендеров на проектирование новой архитектуры, и вы выбираете между тремя конструкций, ABACUS скажет вам, в точкукоторой соответствует вашим требованиям лучших.

· Объединениетекущие существующие архитектуры. Например, если вам нужно, чтобы объединить два или более отдельных архитектур, ABACUS будет направлять вас.

Смотрите также

Как вы это делаете (Обзор) | Что такое архитектура? | Как архитектура представлена ​​в ABACUS?

© 2001-2015 Avolution Pty Ltd. Все права защищены.


Как использовать счеты (обзор)

Навигация: Введение в ABACUS>

Как использовать счеты (обзор)

Отправить комментарии на эту тему.

В этом разделе приведены обзор основных задач, связанных с использованием счеты.

Следующая диаграмма иллюстрирует процесс анализа на базе архитектуры, что обеспечивает ABACUS в целях доработки существующей архитектуры на новый или целевой архитектуры.

Процесс ABACUS

Чтобы использовать счеты:

1. Аудит - Прежде чем использовать счеты, необходимо собрать всю информацию, вы должны об архитектуре, и свои требования.

· Архитектура - Определить потенциальные компоненты архитектуры, и как они взаимодействуют. Там должны быть только несколько компонентов на верхнем уровне. Их называют "основными компонентами". Даже самые сложные архитектуры должна быть меньше, чем 10 основных компонентов. например Основные компоненты архитектуры страховой компании может быть политика, квитанции, заявления, и выплаты.

· Требования- Вы должны знать, что, как ожидается, архитектуры, чтобы определить, если это является удовлетворительным. например Количество транзакций в час.

· Где вы ее найти? - Эта информация может исходить от требований спецификаций, проектной документации, интервью с заинтересованными сторонами, развернутого кода, и т.д. В основном любой материал, который доступен предлагает ABACUS информацию об архитектуре.

2. Заселять -Используйте Abacus моделировать архитектуру и определить требования архитектура будет измеряться.

· Архитектура - В ABACUS вы начинаете с пустой архитектуры - вы должны заселять Это. Это означает, введя всю информацию, собранную архитектуры вы выше. Вы можете заполнить вашу архитектуру вручную (с помощью меню правой кнопкой мыши), или вы можете заполнить его автоматически (от Microsoft Visio, Excel, Access и т.д.). Обычно самый верхний уровень (более абстрактные) архитектуры будут заполнены вручную, и более низкие уровни (более конкретные) будет заполнен автоматически.

· Требования - Как вы добавить свои компоненты и соединения, указать их свойства. В большинстве случаев, эти свойства будут требования архитектуры. Например, если у вас будет 1250 MIPS узла / кластер, вы должны добавить узел в качестве компонента, а затем добавить свойство производительности и присвоить значение 1250 MIPS.

3. Анализ - Используйте Abacus элегантно анализа и визуализации сложную структуру вашей архитектуры. Вы может анализировать архитектуру в ряде способами или из ряда точек зрения, в том числе диаграммы, 3D и Explorer. В качестве альтернативы вы можете использовать некоторые более конкретные взгляды следующим образом:

· График архитектуру - получить производительность (время отклика, пропускной способности и т.д.), стоимость (бар, пирог, и т.д.) или evolvability (возможность пространство, компромисс, и т.д.) просмотров.

· Создание отчета по вашей архитектуры.

4. Имитировать - Используйте Abacus моделировать производительность, доступность, стоимость, открытость для вашей архитектуры, и т.д.

· Чтобы сделать это, выполните одну из тренажеров. ABACUS оценивает вашу архитектура против ваших требованийвыполняя моделирование. Он читает и анализирует текущую архитектуру, работает моделирования, и вычисляет некоторые новые свойства. Эти свойства будут сохранены обратно в архитектуре. Новые свойства являются данные, которые вы пытаетесь анализировать, например, использования, время отклика, пропускной способности,% доступности, ТШО и т.д.

5. Инженер- Использование ABACUS ответить различные "что если" сценарии и контролировать эволюцию вашей архитектуры. Инжиниринг процесс повторяя Заполните - Анализ - ИмитацияЦикл.

· В этот момент, вы'вевероятно, развили понимание текущей архитектуры и подчеркнул области, нужно развиваться. Довольно часто, однако, вы должны будете повторить команду Заполнить - Анализ - Имитация процессу несколько раз. Это, вероятно, будет, потому что это может занять несколько итераций, прежде чем найти целевую архитектуру. Кроме того, если ваша архитектура является очень сложным, вы можете повторить этот процесс для каждого архитектурного "уровне".

6. Планбудущее вашей архитектуры, используя информацию, предоставленную ABACUS.

Заметка

Если вы не пытаетесь развиваться в существующую архитектуру, вы, возможно, потребуется повторить некоторые шаги несколько раз, и в другом порядке. Это зависит от того, что вы пытаетесь делаю. Например, если вы разрабатываете новую архитектуру, вы, вероятно, только заполнить вашу архитектуру один раз, а затем использовать счеты в течение длительного периода времени, чтобы направлять будущую эволюцию (ы) архитектуры. С другой стороны, если Вы покупаете новую архитектуру и имеют несколько вариантов, чтобы выбрать из, вы должны открыть для себя и заполнить для каждого из вариантов, а затем анализировать и моделировать каждый независимо, прежде чем выполнять окончательную сравнение на конец.

Смотрите также

Что ABACUS делать? | Что такое архитектура? | Как архитектура представлена ​​в ABACUS? | Заполнение архитектуру | Анализируя архитектуру | Имитация архитектуру


Что такое архитектура?

Навигация: Введение в ABACUS>

Что такое архитектура?

Отправить комментарии на эту тему.

Архитектура является абстрактным концепция- Не физическое вещь, Это богатый и всеобъемлющее описание или представление о структуре системы - захвата компонентов и как они связаны (взаимодействовать). Потому что понятие архитектуры так всеохватывающим, это основополагающее значение для стоимости, доступности, evolvability, открытости и производительности системы. Звук архитектура предпосылкой звуковой системы.

В ABACUS, вы моделировать архитектуру. Для простоты, мы называем это архитектурная модель архитектуры.

Приведенная ниже диаграмма иллюстрирует типичную архитектуру 5 компоненты (в иерархии) связано с тем, 2 подключений. Этикетки указывают имена, данные различные части архитектуры в ABACUS.

Простой архитектура

ABACUS считает, что все эти вещи, чтобы быть частью архитектуры:

· Компонентыпредставляют субъекты вашей архитектуры которые вы могли бы описать как "вещи". Для страховой компании, компоненты могут быть системы для обработки политики, претензий, выплат и поступлений,.

· Связипредставляют отношения между этими компонентами. Например, в страховой компании, поступления формируются по уважительным политики, претензии предъявлены действительных политики и обоснованные претензии привести платежей. Когда вы думаете архитектурно - особенно при использовании Abacus - соединения, как важно, как компонентов, и они рассматриваются в почти одинаковым образом.

· Все в дереве может иметь Свойства, Свойства вещи, как пути вы требуете системы для выполнения, количество строк кода она имеет процент из этих линий, которые, комментарии и т.д. ABACUS считает, что все эти вещи, чтобы быть частью архитектуры.

· Используя иерархий(т.е. суб-компоненты а также суб-соединения), Вы можете скрыть информацию, а де-сочинять архитектуры. Архитектурный модель ABACUS является чрезвычайно гибкой. Любой компонент на любом уровне могут быть связаны с любым другим компонентом в любой другой уровня одного соединения на любом уровне.

· Привязанностьэто действие, посредством которого компоненты Порты связаны с связиРоли. Порты а также Роли являются интерфейсомsмежду компонентами и соединений. Они используются для подключения подключения к компонентам. Соединения имеют Источник и раковиной роль(содействие поток данных от исходного компонента к компоненту раковиной)и концептуально, компоненты имеют порты. Для простоты, однако, в ABACUS комплектующих порты не показаны, и роли подключения непосредственно присоединены к самих компонентов.

· Компоненты и соединения имеют определенный Тип, Это, главным образом, для целей классификации. Например, политика, претензии, платежи, поступления и являются компонентами типа «Система». Допустимые политики, обоснованные претензии и т.д., соединения типа "сделка". Тип присваивается компонента или соединение содержит шаблон для свойств и стандартов в. Например, тип компонента сервера может иметь "Сделать & модели" стандарти свойство IP-адрес. В отличие от других жестких инструментов с основной реляционной база данных (RDB) назад конце, в ABACUS вы можете свободно создавать свои собственные новые виды и назначить свои собственные комбинации свойств и стандартов для них.

· Стандартные библиотеки свойств могут быть указаны и назначен всего на архитектуру. Эти библиотеки известны как Стандарты, Используя Стандарты, Вам нужно только, чтобы собрать конкретные свойства системы - стандартные свойства уже есть. Например стандартные эксплуатационные характеристики Microsoft Windows 2000 может быть назначен на все компоненты с помощью операционной системы Microsoft Windows 2000.

Смотрите также

Как архитектура представлена ​​в ABACUS? | Что ABACUS делать? | Как вы это делаете (Обзор) | Создание нового типа


Интерфейс ABACUS

Навигация: Введение в ABACUS>

Интерфейс ABACUS

Отправить комментарии на эту тему.

Когда вы начинаете Abacus, вы увидите главный экран, который является пустым для меню и панели инструментов в верхней части, пустое окно Проводника и название-бар исключением. Этот экран будет центром вашего взаимодействия с ABACUS.

Основными элементами являются:

· Главное меню

· панели инструментов

· меню правой кнопкой мыши

· исследователь и имущественные окна

· в строке состояния

Главное меню

Меню расположены в логическом порядке.

Меню описаны следующим образом:

· В меню Файл- Меню Файл позволяет создавать, открывать, закрывать, сохранить, экспортировать и публиковать файлы ABACUS. Она также позволяет создавать, открывать, закрывать и сохранять файлы библиотеки ABACUS.

· В меню Правка выберите- Редактировать меню позволяет вырезать, копировать, вставлять, удалять, переименовывать, сортировать и найти элементыи отмена / повтор операций.

· Посмотреть меню- Меню Вид позволяет открывать или закрывать различные интерфейса для Windows и статус барПерейдите вперед и назад, перейти к конкретным видом и управлять панелей.

· Вставить меню- В меню Вставка позволяет добавлять новые стандарты, Шаблоны, типы, элементы, видточкаs, Каталоги, схемы, графики, Доклады и матрицы.

· Меню Анализ- Меню Анализ позволяет запускать оценки в отношении архитектуры, включая; производительность, экономичность, надежность, модульность и открытость.

· Меню Инструменты- Меню инструментов позволяет запускать сценарии, набор цели для архитектурыи выполнять и архитектура "Diff", Вы также можете изменить параметры программы и настроить интерфейс в меню инструмента.

· Меню Окно- Меню Окно позволяет док, организовать, шоу и скрыть окна, которые открыты.

· Меню Помощь- В меню Справка можно получить доступ к файл справки ABACUS. Вы можете получить доступ к веб-сайт, просматривать лицензия Соглашение и просматривать общую информацию о ABACUS в том числе версии программного обеспечения и счеты поддержки и контактные данные. Вы можете обеспечить обратную связь через страницу уведомлений вопрос. При необходимости, вы можете ввести регистрационный ключ через меню Помощь.

Это порядок вы, как правило, следуют, когда вы носите ваши задачи;После того как вы создали или открыли файл, Вы, как правило заполнить вашу архитектуру, то Посмотретьэто (в Проводнике, диаграммы, 3D, Диаграммы, и т.д.). В этот момент, вы либо запустить оценщикИли вы повторите процесс с той же архитектуре или иной архитектуры. (Видеть Как использовать счеты (обзор) для получения более подробной информации.)

Посмотрите через главное меню и попробовать представить, как вы будете применять их в вашей системе.

Заметка

Ты можешь Настройте ваши меню в любое время.

Панели инструментов

По умолчанию имеются следующие панели инструментов;

· Основная панель инструментов -

· Моделирование Панель инструментов -

· Вид панели инструментов -

· Схема инструментбар (если схема открыт) -

· Макрос Запись Панель инструментов -

Посмотрите через кнопки на каждой панели инструментов при наведении на них, чтобы увидеть всплывающей подсказке (ярлык-ключ).

Заметка

Только определенные кнопки будут активны в зависимости от того, что вы выбрали в окне Проводника, и вы можете Настройка панелей инструментов в любое время.Кроме того, "Проверка / Проверка проектных ограничений" кнопку на главной панели инструментов и кнопки на панели инструментов моделирования будут освещены Красный когда изменения в хранилище требует основной ре-валидации проекта или повторного моделирования этого тренажера соответственно. Наведите указатель мыши на кнопку, чтобы увидеть, который архитектур влияет.

Меню правой кнопкой мыши

Главное меню и панели инструментов неиспользуется для всего, хотя. Это часто более удобно использовать контекстное меню правой кнопкой мыши для различных операций. (Кроме того, не все команды, доступные через щелчок правой кнопкой мыши доступны через основных меню, панели инструментов, или команды с клавиатуры.)

Например, как только вы создали файл, и у вас есть дерево схему вашей архитектуры, это лучше правой кнопкой мыши на архитектур в дереве, чтобы добавить новую архитектуру. Кроме того, вы должны щелкнуть правой кнопкой мыши на компоненты, чтобы добавить новый компонент. Щелкните правой кнопкой мыши на несколько вещей, в дереве, чтобы увидеть то, что вы можете сделать.

Наконечник

Как правило, вы будете использовать основные меню, чтобы выполнить больше задач на высоком уровне, как и оценки архитектуру. Задачи низкого уровня - такие как добавление отдельных компонентов и соединений - выполнены с использованием панели инструментов и / или меню правой кнопки мыши.

Исследователь и свойства окна

Когда вы открываете или создать файл, древовидная схема будет отображаться в окне Проводника. Это окно в вашей архитектуре. И, как вы выберите элементы в окне Проводника три другие окна; Общие свойства, Рекомендациии свойства окна будут обновлять, чтобы отразить подробную информацию о вашего выбора.

Заметка

Общие свойства, Рекомендациии свойства окна скрыты по умолчанию. Видеть Настройка интерфейса о том, как отобразить их и, возможно, оставить их постоянно отображаться.

В то время как вы строите вашу архитектуру, окна Проводника и свойства наиболее полезным представлением. Потому что они могут быть свернуты и расширен по мере необходимости, и они не становятся громоздкими.

Окно Проводник имеет дерево (и строки состояния) и окна свойства 5разделы:

· Тип

· Стандарты

· Описание

· Рекомендации

· Свойства

ABACUS считает, что все эти вещи, чтобы быть частью архитектуры.

Дерево

В этом разделе есть дерево сгруппированы в 3 областях следующим образом:

1. Мета-модель

· Стандарты- Если многочисленные компоненты имеют тот же набор свойств, вы можете определить набор последнюю фронте, а затем просто назначить его компонентов. То же самое относится и соединений любого из других элементов. Эти наборы стандартных свойств хранятся в Стандартыветвь дерева. Вместо определения каждое свойство для каждого компонента, и каждое свойство для каждого соединения и т.д., просто назначить стандарт, Например, стандартные характеристики Unix-HP / UXмогут быть сохранены в качестве Стандарт и назначен на любых компонентов, использующих Unix-HP / UXоперационной системы, как показано для OS01 Сервер на скриншоте выше.

· Типы - Это ветвь дерева представляет собой библиотеку типов компонентов и соединений, которые можно использовать. Типы используются, чтобы определить мета-модель для вашей архитектуры и классификации и фильтрации при просмотре архитектуры. Они также определяют шаблон для того, что стандарты, Свойства и ограничения ваших компонентов / соединений может иметь.

· Точки зрения- Посмотретьточкас могут быть созданы из существующих схем и могут быть использованы для создания новых схем.Они схема трафареты.

· Шаблоны - Шаблоны магазин Повторного использования шаблоны компонентов и соединения вместе с тем, как они представлены или смотреть. Их можно рассматривать как «мини» архитектур или решений, которые могут быть размещены в существующих архитектур.

2. Архитектура -Архитектур филиал дерева, где вы строить архитектура (ы) в вашей системе. (Это называется заполнение архитектуру.) Вы можете иметь любое количество архитектур в одном файле ABACUS.

3. Панели - Панелях ветвь дерева, где вы можете получить доступ к любой спасены панели для проекта.

Заметка

Элементы в дереве Проводника, которые имели их Разрешение обновления удалить (то есть они доступны только для чтения) приведены в серый.

Тип

В этом разделе обозначает конкретный компонент или соединение типа выбранного элемента в дереве.

Стандарты

Этот раздел содержит список из стандарты для выбранного элемента в дереве.

Описание

Этот раздел содержит краткое описание выбранного элемента в дереве. Любые связанные гиперссылки также могут быть добавлены в этот раздел. Они включают в себя веб-сайты или местных абсолютные пути, указывающие на дополнительную информацию о данном элементе. Несколько строк также допускаются. Допустимые гиперссылки должны начать с одного из 5 строк; HTTP: //, HTTPS: //, FTP: //, файл: /// или MAILTO :.

Наконечник

Для гиперссылки с пробелами, пользователи могут ввести адрес или путь, выбрать нужный текст и Щелкните правой кнопкой мыши| Гиперссылка, Это изменит все пробелы в % 20так что весь URL или путь будет работать правильно.

Создание и изменение

Эти разделs предоставлятьпользователь и дата / время создания и последнего изменения, чтобы, выбранный элемент в дереве.

Рекомендации

Этот раздел содержит список из исходящие и входящие компоненты для выбранного элемента в дереве.Это также показывает диаграммы, 3D и вид диаграммы, что выбранный элемент появляется. Если выбран схема показывает точку зрения, если это применимо для диаграммы и видом в целом это показывает, какие панелей вид появляется. И когда Стандартный выбран в дереве показывает использование стандарта по видам, компонентов и соединений.

Свойства

В этом разделе, где вы определить характеристики Элементы внутри ваша архитектура, как, как вы требуют, чтобы это выполнить, число строк кода она имеет процент из этих линий, которые комментарии и т.д.

«Ввод» и «выход» свойства предварительно построен тренажеры будет показано в окне Свойства со значком селектора входа недвижимость строка ( [image] ) И выход значок ( [image] ), Соответственно, с подсказки, показывающий, какие предварительно построенный симулятор имущество, связанные с, например, "Модульность Выход» или «Производительность ввода. Стрелка на выходных значков будет выделить Красный ( [image] ), Когда имущество устарело в связи с закладываемого имущества или структурных изменений в хранилище с тренажера, требующего повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

В строке состояния

Левая часть строки состояния показывает полный путь к элементу хранилища в настоящее время в фокусе, либо выбираются в окне Проводника или на схемахолст. Это связано с тем, что точное место в хранилище иерархии для данного элемента всегда можно легко определить. Правая рука часть в строке состояния показывает различные оперативные сообщения, такие как "Открыть файл ABACUS Успешный» и «Стоимость расчета Завершен».

Смотрите также

Как вы это делаете (Обзор) | Настройка интерфейса | Что такое архитектура? | Как архитектура представлена ​​в ABACUS? | Работа с файлами ABACUS


Настройка интерфейса ABACUS

Навигация: Введение в ABACUS>

Настройка интерфейса ABACUS

Отправить комментарии на эту тему.

Вы можете изменить внешний вид и поведение интерфейса ABACUS во многих отношениях. ABACUS включает в себя несколько предопределенных настроек комбинации, которые вы можете использовать, чтобы применить группу настройках интерфейсу. Кроме того, вы можете сделать отдельные настройках таких элементов, как окна, панели инструментов, сочетания клавиш, и различные варианты дисплеев.

Организовать и док для Windows

У вас есть много вариантов компоновки окон в интерфейсе для ABACUS, в том числе следующие:

· Таб-док окна.

· Док окна в край кадра в интерфейсе.

· Минимизировать окна инструментов по краю интерфейса.

· Сброс расположения окон макета по умолчанию.

Док-Окна

Когда окно плавающим, он может быть прикреплен к одной стороне рамы в интерфейсе, или он может быть расположен на закладками панелей в кадре. Руководство алмаз появляется, когда вы перетаскивать окна из их текущего местоположения в другое место в интерфейсе. Руководство алмазов позволяет быстро снова прикрепить окно на одном из четырех сторон рамы или в центре в качестве вкладок панели. Когда окно Undocked или не закрепляемые, она плавает на вершине других окон.

Чтобы закрепить окна

1. Нажмите нужное окно, чтобы состыковаться, чтобы дать ему сосредоточиться.

2. На ОкноМеню, нажмите Плавающее.

3. Перетащите окно из текущего местоположения к середине кадра вы хотите, чтобы прикрепить ее с.

Появится руководство алмазов. Четыре стрелки точки алмазов к четырем краям кадра и центра представляет собой панель вкладок.

Наконечник

Чтобы переместить окно, не закрепляемых щелкая его в место, в то время как пресс-CTRL перетащив его.

4. Когда окно перетаскивании достигает положения, где вы хотите, чтобы прикрепить ее, переместите указатель на соответствующей части направляющей алмаза. Схема окна появляется в назначенный район.

5. Чтобы закрепить окно в положении, указанном отпустите кнопку мыши.

Например, если Исследовательпристыкован на левой стороне интерфейса, и вы хотите, чтобы прикрепить ее на правом краю, вы бы перетащить Исследовательк середине интерфейса, наведите курсор на правой стороне направляющей алмаза, а затем отпустите кнопку мыши.

Минимизация Окна

Окна (являются ли они Инструмент для Windows - появление на Посмотретьменю или документ Окна - появляться на ОкноМеню) поддерживают функцию под названием Auto Hide. Auto Hide позволяет видеть больше вашей архитектуры в свое время путем минимизации окна по краям интерфейса, когда он не используется.

Чтобы включить Auto Скрыть

1. Нажмите нужное окно, чтобы скрыть, чтобы дать ему фокус.

2. На ОкноМеню, нажмите Авто-скрытие.

- или -

2. Нажмите на значок канцелярской кнопки на заголовке окна.

Auto Hide Включено

Когда авто-скрытое окно теряет фокус, он автоматически скользит назад в его выступ, расположенный на краю интерфейса. В то время как окно авто-скрыты, его имя и значок видны на вкладке на краю интерфейса. Для отображения автоматического скрыты окно, наведите указатель мыши на вкладку. Окно скользит назад в поле зрения и готов к использованию.

Заметка

Окно это авто спрятаны не может быть пристыкован. Чтобы закрепить окно вам нужно будет выключить Автоскрытие, как описано ниже.

Чтобы выключить Автоскрытие

1. Щелкните окно вы хотите сохранить видимым, чтобы дать ему фокус.

2. На ОкноМеню, нажмите Авто-скрытиечтобы снять флажок.

- или -

2. Нажмите на значок канцелярской кнопки на заголовке окна.

Авто Скрыть инвалидов

Наконечник

Окна, которые Автоскрытие позволило временно скользить в поле зрения, когда окно имеет фокус. Чтобы скрыть окно снова, выберите пункт вне текущего окна. После того, как окно теряет фокус, он скользит обратно из поля зрения.

Сброс Окна Макеты

Вы можете вернуться интерфейс для макета окна по умолчанию с помощью Сброс окна LayoutКоманда. Когда вы запустите эту команду, происходят следующие действия:

· Все окна будут перемещены в их позициях по умолчанию.

· Окна, которые закрыты в макете окна по умолчанию закрыты командой.

· Окна, открытые в макете окна по умолчанию открываются с помощью команды.

· Окна, скрытые / видимые в макете окна по умолчанию сделаны скрытой / видимой с помощью команды.

Для сброса расположения окон макета по умолчанию

1. На WindowsМеню, нажмите Сброс окна Layout.

Настройка меню и панели инструментов

Вы можете изменить макет, положение и содержание меню и панелей инструментов в интерфейсе. Вы также можете добавить кнопки панели инструментов и изменить назначенный значок любой кнопки.

Создать новую панель инструментов

Чтобы создать новую панель инструментов

1. На инструментыменю, выберите Настройка.

2. в Настроитьдиалоговое окно, выберите Панели инструментовВкладка.

3. выберите Новый.

4. в Новый Панель инструментовдиалоговое окно, введите имя для панели инструментов.

5. выберите ОК.

Чтобы добавить кнопки в меню или панель инструментов

1. На инструментыменю, выберите Настройка.

2. в Настроитьдиалоговое окно, выберите КомандыВкладка.

3. Выберите категорию и перетащите команду из диалогового окна в меню или на панели инструментов.

4. выберите Закрыть.

Наконечник

Удерживая клавишу Alt-позволяет быстро настроить команды-как будто диалоговое окно Настройка была открыта.

Смотрите также

Интерфейс ABACUS


Работа с файлами ABACUS

Навигация: Введение в ABACUS>

Работа с файлами ABACUS

Отправить комментарии на эту тему.

Счеты файл представляет собой контейнер для модели вашего архитектура , В одном файле ABACUS, вы можете моделировать любое количество архитектур любое количество раз.

Когда вы впервые открываете счеты, нет открытых файлов. Для работы на архитектуре, вам придется либо создать новый файл или открыть существующий файл.

Когда вы открываете или создать новый файл, дерево в окне проводника будет отображаться автоматически. Эта точка зрения исследователя показывает архитектуру на сегодняшний день. При закрытии файла, дерево в окне проводника также исчезнет.

Чтобы создать новый файл ABACUS

1. Выбрать файл| Новый ...

2. В диалоговом окне New Project, который появляется (как показано ниже) выберителибо создать пустую модель, модель из Стандартная библиотека ABACUS , Модель из пользовательской библиотеки ABACUS, модель из XML, MS Access , MS Visio , MS Excel , MS SQL Server А.Н. Предприятие Сервер модели или обычай библиотека ABACUS (.abacuslib файл).

3. Нажать на ОККнопка и следуйте диалоги, которые могут появиться.

Наконечник

Вы не будет предложено назвать файл, пока вы не сохраните или закрыть его. Это хорошая идея, чтобы сохранить файл, как только вы его создать. Тогда вам не придется беспокоиться о назвав его позже в процессе, когда вы обогатительной на других сложных вещей (как заполнение архитектуру).

Создание нового проекта

ABACUS Стандартные библиотеки

ABACUS поддерживает более 100 общественные структуры и обозначения, некоторые из которых приведены ниже. При выборе, чтобы создать новый проект с помощью стандартного пользователи библиотеки имеют быстрый старт к моделированию в рамках создания рамок в полной мере ни к одному из типов элементов, атрибутов, обозначения, точки зрения и шаблоны или модели. Дополнительные стандартные библиотеки находятся в свободном доступе через Avolution сообщества Вот .

Новый проект от стандартной библиотеки

Чтобы сохранить новый файл ABACUS

1. Выбрать файл| Сохранить как

Наконечник

Имена файлов могут быть любой длины, и может содержать любые буквенно-цифровые символы и пробелы. Они не могут содержать тильды (~) характер, трубы (|) характер, вопросительный знак, или символы, обычно используемый для описания пути, такие как обратную косую черту (\) - за исключением части пути (?).

Чтобы открыть существующий файл ABACUS

1. Выбрать файл| открыто

Заметка

Если вы открываете файл из общей сетевой папке, которая уже открыта для другого пользователя, ABACUS предоставит вам доступом только для чтения. При использовании счеты с доступом только для чтения, вы не сможете выполнить операции записи, такие как заполнение архитектуру и работает по оценке. Можно, однако, просматривать архитектуру, используя представление проводника и 3D вид.

Смотрите также

Как архитектура представлена ​​в ABACUS?


Как архитектура представлена ​​в ABACUS?

Навигация: Введение в ABACUS>

Как архитектура представлена ​​в ABACUS?

Отправить комментарии на эту тему.

В ABACUS, вы моделировать архитектуру. Для простоты, мы называем это архитектурная модель архитектуры.

Диаграмма ниже иллюстрирует, как типичный архитектуры 5 компоненты (в иерархии) связано с тем, 2 соединений будут представлены в ABACUS.

Как простой архитектуры представлена ​​в ABACUS

Вы можете иметь любое количество архитектур в одном файле ABACUS.

Первый архитектура в дереве

Как правило, вам нужно будет создать новую архитектуру, когда вы хотите, чтобы оценить изменения. Например, вы моделировать существующую архитектуру в первую очередь - это будет первый архитектура в дереве. Вы могли бы назвать это "Текущий".

Второй

Если вы хотите, чтобы смоделировать и оценить изменения в существующей архитектуры (например, повышенные требования), вы бы создать новую архитектуру. Самый простой способ сделать это было бы создать копию "Текущий" и переименуйте его «Эволюция 1 Попытка 1 '. Это будет второй архитектура в дереве. Если ваши оценки "Эволюция 1 Попытка 1 'успешно, вы можете переименовать его в просто« Эволюция 1 ".

Третий

Если «Эволюция 1 Попытка 1 'не удовлетворяет вашим требованиям, вы можете создать его копию, переименуйте его в" Эволюция 1 Попытка 2', и попробуйте еще раз. Это будет третий архитектура в дереве.

Смотрите также

Что ABACUS делать? | Как вы это делаете (Обзор) | Что такое архитектура? | Работа с файлами ABACUS | Создание или дублирования архитектуры


Помощь на других языках

Навигация: Введение в ABACUS>

Помощь на других языках

Отправить комментарии на эту тему.

СЧЕТЫ помощь доступна в различных других языках / переводы и может быть загружен из ссылок внизу.

Для заменить текущую ABACUS файл справкис переведенной файл справки, пожалуйста, выполните следующие действия:

1. Сохраните файл справки из соответствующего ссылку ниже.

2. Переименовать файл справки к ABACUS.chm.

3. Откройте файл двойным щелчком, и если в "Открыть файл - Предупреждение безопасности» появится диалоговое окно, то снимите флажок "Всегда спрашивать перед открытием файла" и нажмите Открыть.

4. Закройте файл.

5. Замените файл ABACUS.chm в папке программных файлов ABACUS, как правило, "C: \ Program Files \ Avolution \ ABACUS" или "C: \ Program Files(x86)\ Avolution \ ABACUS".

Заметка

Контекстная помощь будет продолжать работать с переведенных файлов справки.

ABACUS файлы справки на других языках:

· арабский / العربية .

· болгарский / български .

· Китайский упрощенный) / 中文 (简体) .

· Чешский / Чешская .

· Датский / Dansk .

· эстонский / Eesti .

· Финский / Suomen .

· Французский / Вход .

· Немецкий / Deutsch .

· Венгерский / Венгерский .

· исландский / исландский .

· индонезийский / Индонезия .

· Итальянский / Итальянский .

· Японский / 日本 の .

· Латышский / Latvijas .

· Малазийский / Малайзия .

· Мальтийский / Солод i .

· Norweigen / Norweigen .

· Польский / По lska .

· Португальский / Português .

· русский / русский .

· словацкий / Словенский .

· словенский / Словенский .

· испанский / Españoles .

· Шведский / Svenska .

· турецкий / Тюрк .

· валлийский / Cymraeg .

Смотрите также

Что ABACUS делать?


Заполнение архитектуру

Навигация: Заполнение архитектуру>

Заполнение архитектуру

Отправить комментарии на эту тему.

Процесс построения модели вашей архитектуры известен как заселение, После того, как вы обнаружили вашу архитектуру и определили ваши требования, вы готовы, чтобы моделировать архитектуру ABACUS.

Во населения, вы войдете все детали вы знаете о вашей архитектуре и то, что требуется от него.

Для заполнения архитектуру

1. Убедитесь, у вас есть ABACUS открыть файл А.Н. исследователь отображается , И архитектура добавил .

2. Заполнить вручную компоненты более высокого уровня и соединения вашей архитектуры. Как правило, это будет более абстрактные компоненты и соединения.

- или -

2. Графически заполнения компоненты и соединения, которые вы хотели бы смотреть схематически, с помощью Инструмент для рисования, .

Вы также можете

3. Заполните помощью Каталоги - Вы можете просматривать и компоненты и соединения в простой табличной образом.

4. Заполните с помощью матриц - Вы можете просматривать и редактировать соединения между компонентами в простой табличной образом.

5. Заполните от Microsoft Access - Вы можете импортировать архитектуру и экспортировать в Microsoft Access.

6. Заполните от Microsoft Visio - Вы можете импортировать архитектуру и экспортировать в Microsoft Visio.

7. Заполните от Microsoft Excel - Вы можете импортировать архитектуру и экспортировать в Майкрософт Эксель.

8. Заполните от Microsoft SharePoint - Вы можете импортировать архитектуру и экспортировать в Microsoft SQL Server.

9. Заполните от Microsoft SQL Server - Вы можете импортировать архитектуру с Microsoft SQL Server.

10. Импорт из XML - Вы можете импортировать архитектуру из XML фрагмента ABACUS или ArchiMate обмена языка XML файла.

Смотрите также

Заполнение архитектуру вручную | Инструменты рисования | Заполнение архитектуру с Microsoft Access | Заполнение архитектуру с Microsoft Visio | Заполнение архитектуру из Microsoft Excel


Заполнение архитектуру вручную

Навигация: Заполнение архитектуру> Заполнение вручную>

Заполнение архитектуру вручную

Отправить комментарии на эту тему.

Компоненты и соединения вашей архитектуры высшего уровня, вероятно, нужно быть заполнен вручную. Как правило, это будет более абстрактные компоненты и соединения.

Чтобы вручную заполнить вашу архитектуру

1. Убедитесь, у вас есть ABACUS файлоткрытым, исследовательотображается, и архитектура добавил .

2. Добавить компонент. Сделать это, Щелкните правой кнопкой мышина площади дерева вы хотите, чтобы заполнить, и выберите Добавить Субкомпонент ..., Или нажмите Новый компонентКнопка на Посмотреть инструментов , Компоненты могут быть добавлены только под Компоненты ветви дерева. Вы хотите, чтобы ваш древовидная схема, чтобы быть точным представлением вашей архитектуры. Когда вы обнаружили вашу архитектуру, вы будете узнали, как именно все это вписывается вместе. Вы будете нуждаться в этом знания, когда вы добавляете свои компоненты и соединения. Если вы хотите добавить свой первый компонент, вы будете добавлять ее непосредственно в отделение компонентов. Остальные ваши компоненты могут быть либо на том же уровне в дереве, или они могут быть суб-компоненты первым.

3. Обновление значениясвойствакаждого компонента, как вы добавить его. Сделать это, щелчокна компоненте и редактировать отображаемые в свойства Окно свойств(обычно) вправо. Свойства, как правило, такие вещи, как требования, мощностью переработки, и т.д. Когда ABACUS оценивает вашу архитектуру, он будет рассчитывать новые свойства, и сохранить их в архитектуре. Новые свойства являются данные, которые вы пытаетесь анализировать, например, использования, время отклика, пропускной способности и т.д.

4. Добавьте связи а также Обновитьих свойствакак вы идете - просто, как и для компонентов (но под Connections ветви дерева).

5. Прикреплятьсоединения и компоненты. Чтобы сделать это, найдите соединение, нажмите на одну из его заканчивается или Роли И перетащите его на компонент. В качестве альтернативы, нажмите на компоненте и перетащите его на одну из этих подключений роли (т.е. либо источник или раковина), Или вы можете щелкнуть правой кнопкой мыши и перетащите компонент на другой компонент и выберите Подключиться к, Или просто щелкните правой кнопкой мыши компонент и выберите Подключите ..., При перетаскивании соединения роль, Вы заметите, контекстное символ, когда вы указываете на компоненты можно прикрепить его к. Это означает, что вы не делаете копию, вы просто подключив ее. Убедитесь, что вы приложите его к правильному компонента назначения. Например, если это Источник соединение в роль, Перетащите его сделать исходный компонент (то есть компонент, который является источником потока данных).

Наконечник

Re-заказе объектов в рамках архитектуры (например, компоненты, связи и т.д.) в исследовательдовольно легко. Просто Нажмите| Держать| Бремясоответствующая организация и место, где желательно в архитектуре. Функциональность изменение порядка также позволяет размещать объекты в различных иерархиях вашей архитектуры.

Вы также можете

6. Добавить стандарты (предварительно сконфигурированных наборов свойств - пресеты), к компонентам, соединениям и типов

7. Изменение свойств компонента, связи или типа

8. Отменить и Повторить операции

9. Изменение типа компонента или соединения

10. Создать новый тип или тип группы

11. Удалить компонент или соединение

12. Создание, дублировать или развиваться архитектура

13. Типы Импорт и стандарты из библиотеки

14. Импорт из другого файла ABACUS, XML, Excel или Visio

15. Скопировать и вставить части (или все) вашей архитектуры

16. Найти и заменить предметы в вашем архитектуры

17. Развернуть / свернуть некоторые или все из узлов в дереве

18. Слить Предметы

19. Определять а также Утверждать Ограничения ограничить структуру вашей архитектуры

20. Развиваться архитектуру создать несколько архитектурных решений для сравнения и базовые

Смотрите также

Заполнение архитектуру - Обзор | Создание нового файла


Отменить и Повторить

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Отменить и Повторить

Отправить комментарии на эту тему.

Как и многие современные приложения, ABACUS поддерживает возможность как отмены и повтора последних изменений пользовательских внесенные в открытом проекте. Чтобы отменить самое последнее изменение, просто активируйте команду отмены. Изменения, которые были отмененное может быть переделана активации команды повтора; повторного применения наиболее недавно отмененную изменения.

Предупреждение

Отменен- изменения не могут быть повторно, если дальнейшие изменения, внесенные в проект с момента его отменить.

Заметка

В то время как подавляющее большинство изменений поддержка отмены / повтора в режиме реального времени, некоторые схема трафарет изменения, такие как создание нового типа Shape / Line объединение или изменение значения атрибута цвета ассоциации, не в состоянии отменить немедленно. В этих случаях, модифицированный Схема (обозначены звездочкой) должны быть закрыты до эти изменения могут быть отменены.

Отменить и Повторить места команд

Отменить и Вернуть команды могут быть доступны из трех различных местах:

· В меню Правка

· Стандартная панель инструментов

· Клавиатура Клавиши быстрого CTRL + Z(отменить) и CTRL + Y(повтор)

Наконечник

Отменить и Вернуть кнопки на стандартной панели инструментов обеспечивают выпадающие списки отображения 10 самых последних изменений, которые могут быть отменены и были переделаны соответственно. Они также являются удобным способом, чтобы отменить / повторить несколько изменений сразу.


Изменение компонентного / Тип соединения в

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Изменение компонентного / Тип соединения в

Отправить комментарии на эту тему.

Комплектующие и подключение типа используются в основном для целей классификации. Вы можете использовать типы в качестве фильтров при просмотре архитектуры. Например, вместо просмотра все это, вы могли бы смотреть только компоненты приложения.

Чтобы изменить компонент / Тип соединения в

1. Щелкните правой кнопкой мышина компоненте или связи.

2. Выбрать Изменить тип.

3. Выберите другой тип из списка.

Наконечник

При изменении типа, вы можете получить некоторые новые стандартыили свойства (все, что связанные с Тип - см Типы ветви дерева). Существующая стандарты и свойства останутся неизменными. Вы можете создавать свои собственные новые типы и назначить свои собственные комбинации стандарты и с ними свойства.

Смотрите также

Создание нового типа | Заполнение архитектуру - Обзор | Анализ ваша архитектура


Создание нового компонента / Тип подключения или типа группы

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Создание нового компонента / Тип подключения или типа группы

Отправить комментарии на эту тему.

Комплектующие и подключение типа используются в основном для целей классификации. Вы можете использовать типы в качестве фильтров при просмотре архитектуры. Например, вместо просмотра все это, вы могли бы смотреть только компоненты приложения.

Для создания нового компонента / Тип подключения

Заметка

Чтобы добавить типы или группы типов в проекте ABACUS лицензия пользователь нуждается в Designer добавить-на возможности. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

1. Разверните Видыветвь дерева.

2. Щелкните правой кнопкой мыши на Комплектующие Типы (или Типы подключения).

3. Выбрать Добавить Component Type (или Добавить тип соединения) или Создать группу.

Наконечник

После того как вы создали тип, вы должны изменить свою иконку (см ниже) и добавить свойства а также стандарты к нему для компонента или случаях соединения на '' наследуют.

Чтобы изменить значок для компонента / Тип подключения

Заметка

Чтобы изменить значки для типов в проекте ABACUS лицензия пользователь нуждается в Designer добавить-на возможности. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

1. Щелкните правой кнопкой мыши на Компонент Тип (или Тип соединения) Вы хотите изменить иконку для.

2. Выбрать Изменить Иконка.

3. В диалоговом окне укажите Выберите значок на месте и выбрать файл изображения и нажмите кнопку Открыть.

Заметка

Вы можете иметь пользовательский значок изображение любого размера, но он всегда будет масштабироваться, чтобы поместиться на 16x16 пикселей изображения в окне Проводника. Так что, если ваш оригинальный пользовательский значок изображение не одинаковой высоты и ширины вашего значок окна Проводник будет растянуто. Соответственно, пользовательские изображения должен быть не менее 16х16 пикселей и, если вы хотите сохранить точную форму значка заказ убедитесь, что ваш заказ значок изображения равна высота и ширина в пикселях (16x16 или более). Вы также должны быть осторожны, не имея цветные «пикселей» собирается весь путь к границе пользовательский значок изображения, как это будет выглядеть бедным в окне проводника со смежными икон »кровотечения" друг в друга. Соответственно, вы должны оставить по крайней мере 1 пиксель белый границу.

Наконечник

Вы можете сделать пользовательский значок изображения .ico, .bmp, .gif, .jpg или .png формат файла, но из-за ограничений в Windows, только .ico формат просмотра в диалоговом окне ABACUS Выберите значок, если у вас есть возможность просмотра меню установлено что-то кроме миниатюр.

Смотрите также

Заполнение архитектуру - Обзор | Анализ ваша архитектура


Удаление компонента или соединение

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Удаление компонента или соединение

Отправить комментарии на эту тему.

Чтобы удалить компонент или соединение

1. Щелкните правой кнопкой мышина компоненте или связи.

2. Выбрать Удалить.

Внимание

ABACUS предупредит вас, какие взгляды будут затронуты удаления и попросить Вас подтвердить удаление. Это потому, что элементы могут существовать на многих схемах и он платит, чтобы проверить, что предложение об исключении повлияет.

Наконечник

Если вы удалите компонент, все его суб-компоненты будут также удалены. Вы можете выбрать для удаления внутренних и внешних подключений к компоненту. Если вы не хотите удалять их, это соединения прикрепленный чтобы останутся, но они больше не будут прилагаться. Все компоненты и соединения имеют определенный Тип , Удаление компонента / связь не имеет никакого влияния на Тип (по типам ветви дерева). Аналогично, если компонент / соединение имеет Стандарт назначен, удаление не будет иметь никакого влияния на хозяина в отрасли стандартам.

Смотрите также

Заполнение архитектуру - Обзор


Создание или дублирования архитектуры

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Создание или дублирования архитектуры

Отправить комментарии на эту тему.

Вы можете иметь любое количество архитектур в одном файле ABACUS. Как правило, вы бы создать новую архитектуру каждый раз, когда вы хотите, чтобы моделировать и оценивать эволюцию системы.

Чтобы создать новую архитектуру

1. Щелкните правой кнопкой мыши на Архитектурыветвь дерева.

2. Выбрать Новая архитектура.

Чтобы создать копию существующей архитектуры

1. Щелкните правой кнопкой мышина архитектуре.

2. Выбрать Копия.

3. Щелкните правой кнопкой мыши на Архитектурыветвь дерева.

4. Выбрать Вставить.

5. Новая архитектура будет называться "Копия ...".

Для развиваться в существующую архитектуру

1. Щелкните правой кнопкой мышина архитектуре.

2. Выбрать Развиваться.

3. Новая архитектура будет называться «... .1.

Заметка

Существует подробное описание на развивающихся архитектур Вот .

Смотрите также

Как архитектура представлена ​​в ABACUS | Развитие архитектуру


Импорт в вашей архитектуре

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Импорт в вашей архитектуре

Отправить комментарии на эту тему.

ABACUS позволяет импортировать в ваша архитектура из .abacus (ABACUS файл), .xml (XML-фрагмент ABACUS или ArchiMate обмена XML-файл Язык), .vsd формат (Microsoft Visio), и в формате .xls, (Microsoft Excel). Это позволяет построить архитектуру от внешних источников быстро.

Для Импортировать ваша архитектура из.abacus (ABACUS файл)

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Щелкните правой кнопкой мышина архитектуре узла, любая архитектура в вашей модели или любую часть дерева компонентов.

3. Выбрать Импортировать| Из Файл...из меню.

4. Выберите место и .abacus файл и нажмите открытоКнопка.

Заметка

После того как вы выбрали файл, который вы хотите импортировать, вам будет предложено, как вы хотели бы импортировать стандарты, типыи точки зрения, Вы можете импортировать стандарты, типы и точки зрения либо как новых или объединенных стандартов, типыи точки зрения, По умолчанию для стандартов, типы и точки зрения будут объединены с существующими стандартами, типы и точки зрения если они уже существуют (с той же точное название) в вашей проект.

Для Импортироватьваша архитектура из.xml (фрагмент ABACUS XML или ArchiMate обмена XML-файл Язык)

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Щелкните правой кнопкой мышина архитектуре узла, любая архитектура в вашей модели или любую часть компонентов дерева.

3. Выбрать Импортировать| Из XML ...из меню.

4. Выберите место и .xml в файл и нажмите открытоКнопка.

Заметка

ABACUS будет импортировать только правильно сформированный XML ABACUS фрагмент или ArchiMate обмена языка XML файл. После того как вы выбрали XML файл, который вы хотите импортировать, вам будет предложено, как вы хотели бы импортировать стандарты, типыи точки зрения, Вы можете импортировать стандарты, типы и точки зрения либо как новых или объединенных стандартов, типыи точки зрения, По умолчанию для стандартов, типы и точки зрения будут объединены с существующими стандартами, типы и точки зрения если они уже существуют (с той же точное название) в вашей проект.

Для Импортироватьваша архитектура из,ВСД(Visio файл) видеть Вот .

Для Импортироватьваша архитектура из.xls (Excel файл) видеть Вот .


Импорт типов и стандартов из библиотеки

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Импорт типов и стандартов из библиотеки

Отправить комментарии на эту тему.

Вы можете импортировать типы и стандарты от файла библиотеки ABACUS. Вы также можете экспортировать типы и стандарты файла ABACUS к библиотеке файл ABACUS.

Чтобы импортировать типы и стандарты из библиотеки в вашей архитектуре

1. Убедитесь, у вас есть ABACUS файлоткрыт и Окно Проводникотображается.

2. Выберите файл | открытоЧтобы открыть ABACUS файл библиотеки.

3. Счеты Библиотека откроется во втором вкладками листа в окне Проводника, и вы должны открепить эту вкладками лист чтобы иметь возможность перетащить и падение с него исходного файла ABACUS.

4. Перетащите и падениевиды и стандарты из библиотеки в вашей архитектуре.

- или -

1. Выберите файл | Новый ...

2. Создать новый ABACUS файлоснована на ABACUS файл библиотеки.

Чтобы экспортировать типы и стандарты вашей архитектуры в библиотеке

1. Убедитесь, у вас есть ABACUS файл Открой Окно Проводникотображается, А.Н. ABACUS файл библиотекиоткрыт и Библиотека Окноотображается.

2. Перетащите и падениевиды и стандарты от вашей архитектуры в библиотеку.

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную


Копирование и вставка

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Копирование и вставка

Отправить комментарии на эту тему.

Вы можете скопировать часть или все ваши архитектуры и вставьте его в другом месте в дереве.

Копировать

1. Щелкните правой кнопкой мышина предмет, который вы хотите скопировать.

2. Выбрать Копия.

Вставить

1. Перейдите по дереву, чтобы найти место, где вы хотели бы, чтобы вставить элемент.

2. Щелкните правой кнопкой мышина ветке вы хотите, чтобы появиться в течение.

3. Выбрать Вставить.

4. Деталь будет скопирована с оригинальным названием (если вы не скопировать его в оригинальной ветке - то он будет называться "Копия ...").

Смотрите также

Как архитектура представлена ​​в ABACUS


Поиск и замена товаров в Вашей архитектуры

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Поиск и замена товаров в Вашей архитектуры

Отправить комментарии на эту тему.

Ты можешь найти и заменить специфический компонент, подключение, тип, стандарт или имущество с помощью Abacus "Найти и заменить объект.

Чтобы найти пункт

1. Щелкните узел дерева вы хотели бы искать в.

2. Выбрать редактировать| найтиили нажмите Ctrl + F.

3. Введите текст предметнайти в «Найти» области.

4. Нажмите Найти следующее.

Для заменять пункт

1. Щелкните узел дерева вы хотели бы искать в.

2. Выбрать редактировать| Заменятьили нажмите Ctrl + H.

3. Введите текст предметнайти в "Найди то, что" поле и текст, чтобы заменить его в поле "Заменить на" поле (или ничего, если поле не пустое).

4. Нажмите Найти следующеечтобы найти первый экземпляр "Найди то, что« текст и нажмите Заменять заменить этот экземпляр с текстом "Заменить на" или щелчком мыши Заменить всечтобы заменить все экземпляры.

У вас есть варианты в:

o Подходим свое дело,

o Подходим целое слово,

o Поиск с начала проекта,

o Игнорировать архитектуры - это архитектура себя узлы. Все равно будет искать все узлы под архитектуры узлов, таких как компоненты и соединений,

o Игнорировать компоненты - это тот компонент, сами узлы,

o Игнорировать соединения - это соединения узлов себя,

o Игнорировать стандарты - то есть все архитектуры, комплектующих и подключение стандартных узлов будут игнорироваться,

o Игнорировать типы - это тип себя узлы. Будет по-прежнему искали каких-либо ограничений узлы под узлов типа,

o Игнорировать шаблоны и содержание - это шаблон узлов себя, а также любой шаблон компонента и узлы подключения под ними,

o Игнорировать свойства - это все виды собственности, названия, значения и единицы всех элементов модели будут игнорироваться,

o Игнорировать описания - это описания всех элементов модели будут игнорироваться.

Смотрите также

Как архитектура представлена ​​в ABACUS


Расширение и рушится дерево

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Расширение и рушится дерево

Отправить комментарии на эту тему.

Когда узел в дереве содержит вложенные компоненты и коллекции, это будет иметь небольшой [image] или [image] войдите на его влево. Вы можете нажать кнопку [image] расширить узел и посмотреть, вложенные компоненты и соединения. Кроме того, вы можете нажать кнопку [image] чтобы свернуть узел, чтобы скрыть суб-компоненты и соединения (для того, чтобы больше места или сделать дерево легче понять).

В качестве альтернативы, вы можете расширить весь узел, в этом случае все его суб-узлов также будет расширена, и их суб-узлов, а их ... и т.д. Кроме того, вы можете свернуть весь узел - закрытие нескольких уровнях одновременно ,

Кроме того, есть варианты для расширения только архитектуры, элементы (т.е. компоненты и соединения), компоненты или соединения.

Чтобы развернуть или свернуть все узел (и его суб-узлы и т.д.)

1. Щелкните правой кнопкой мышина узле.

2. Выбрать Развернуть | Все илиКрах.

Для расширения всех архитектуры (ы)

1. Щелкните правой кнопкой мышина архитектурах или архитектуры.

2. Выбрать Развернуть | Все.

Чтобы расширить элементы

1. Щелкните правой кнопкой мышина архитектурах или архитектуры.

2. Выбрать Развернуть | Элементы.

Для расширения компоненты

1. Щелкните правой кнопкой мышина компоненты, компонента или подкомпонента.

2. Выбрать Развернуть | Компоненты | Все.

Для расширения связей

1. Щелкните правой кнопкой мышина Connections, в связи или суб-связи.

2. Выбрать Развернуть | Соединения | Все.


Слияние элементов

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Слияние элементов

Отправить комментарии на эту тему.

Когда вы объединяете предметы?

Вы бы объединить элементы, когда у вас есть два (или более) объектов в модели, которые лучше всего представлены в одном экземпляре. Есть много ситуаций, когда вы, возможно, захотите, чтобы это сделать, в том числе:

· В результате импорта новый набор информации в вашей модели, которые могут дублировать или заменяют имеющуюся информацию. Например, если вы импортировать обновленную версию электронной таблицы в вашей модели.

· Со временем дубликаты "же" компонента были созданы, и вы хотите, чтобы очистить эти дубликаты.

· Если вы выполняете что-если сценарий и элементы вы моделирования на самом деле слияния на самом деле. Например, если вы объединяете два отделения в вашей организации, или если вы объединяете два сервера.

Что могут быть объединены?

Следующие типы элементов поддерживают сливается:

· Стандарты

· Комплектующие и подключение Виды

· Компоненты и соединения

Как объединить элементы

Чтобы начать слияние, используя правую кнопку мыши, перетащите один элемент в Проводнике на другой. Пункт перетаскивании является источником, а элемент, который вы перетащите на это место. После выпуска правую кнопку мыши вам будет представлен с меню, из которого вы можете выбрать, чтобы объединить эти два пункта. Вы должны выбрать, хотите ли вы сохранить или перезаписать назначения. Это дополнительно описано ниже.

Меню правой перетащить слияния

В чем разница между сохранением и перезаписи назначения?

В заповеднике или перезаписать вариант диктует, что произойдет, если имя, описание или свойства между исходным и адреса назначения матче.

Если заповедник назначения выбирается

· Будут храниться имя адресата и описание.

· Любые свойства, которые существуют только в источнике добавлены к месту назначения.

Если перезаписи назначения выбирается:

· Имя пункта назначения будут перезаписаны из источника.

· Описание Место будет перезаписана от источника, если описание источника никогда пустым.

· Любые свойства, которые существуют только в источнике добавлены к месту назначения.

· Значение и Единица каких-либо свойств, которые существуют как в источнике и назначения будут перезаписаны от источника, если стоимость источника или блок не является пустым.

Особые случаи

· Виды: При объединении типа, разрешения объединены, в "пессимистическим" способом, таким, что, если разрешение от источника не существует в месте назначения, он будет добавлен, а если он существует в месте назначения, то, если человек разрешение для группы пользователей (создание, чтение, обновление или удаление) не совпадают (один эксплуатацию, отрицала), то, что разрешение будет отказано.

· Компоненты: При объединении компонентов, суб-компоненты источника переносятся к месту назначения, и сливаются с суб-компонентов в пункт назначения, если их имена совпадают, Независимо от их типа.Кроме того, несколько суб-компоненты источника с тем же именем будут объединены в единый подкомпоненту в пункт назначения.

· Связи: Сами соединения на высшем уровне оба должны иметь одинаковые вложения (или их отсутствие), чтобы иметь возможность быть объединены. При слиянии соединений, суб-соединения источника переносятся к месту назначения, и сливаются с суб-соединений в места назначения, если их имена совпадают А ТАКЖЕих вложения являются идентичными. Если вложения не являются идентичными, источник суб-соединения будет добавлено в пункт назначения без слияния с соответствующими соединениями, уже присутствующих. Это объясняется тем, что никакие приложения не будут потеряны.


Определение и утверждение ограничений

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Определение и утверждение ограничений

Отправить комментарии на эту тему.

Структура и свойства архитектуры могут быть ограничены с помощью ограничений. Ограничения могут быть применены к компонентных типов и типов соединений ограничить структуру архитектуры двумя способами. Первый способ заключается в ограничении иерархияопределяя "родитель должен / должна иметь ребенка" и "ребенок должен / должна иметь родительские отношения». Второй способ заключается в ограничении топологияопределяя "компонент должен / должна быть прикреплена к связи" и "соединение должно / должен быть прикреплен к компоненту« отношений. Кроме того, ограничения могут быть применены к свойствам типов компонентов, типов соединений, шаблоны, точек зрения архитектур, диаграммыи 3D Вид, чтобы ограничить архитектура (ы) в двух дополнительных путей. Первый способ, чтобы установить тип данныхимущества, чтобы ограничить допустимые значения, что он может иметь, а именно: Текст, Целое, десятичной, дата / время, логическое или Список. Второй способ, чтобы установить обязательныйСтатус недвижимости, чтобы указать, должен ли значение вводится для свойства (Примечание: Обязательные ограничения применяются только к свойствам компонентов для подключения и типов). Дополнительная информация о ограничений собственности обеспечивается в Изменение свойств компонента, связи или типа помощь темы. После ограничения были определены, можно проверить архитектуру против ограничений. ABACUS будет предупреждать о каких-либо ограничений, которые были нарушены.

Основным фактором, определяющим каком ограничении (ы), чтобы определить ложь в точном языке, используемом для описания ограничений. Для ограничения иерархии они, как правило в форме "существительныеможет / должен / должна быть разложен на N существительные" или "существительныеможет / должен / должна быть агрегируется существительные"И т.д. Например,"Ведомствадолжны быть разложены в Команды" или "Приложенияможно разложить в Модули". Для топологии ограничений они, как правило в форме"существительныеможно / нужно / надо глагол существительные". Например, "Процессы возможно осуществляется Команды" или "Приложения находятся размещенного на Серверы. "Теперь, вы можете увидеть в каждом ограничения существуют различные можно / нужно / должны" отборочных ", и они могут быть 3-х видов;

· Необязательный- Они, как правило, использовать слова / фразы нравится; «может», «может», «могло бы», «необязательно» и т.д.

· рекомендуемые- Они, как правило, использовать слова / фразы нравится; "должен", "рекомендуется", "рекомендуется" и т.д.

· Обязательное- Они, как правило, использовать слова / фразы нравится; "обязательно", "есть", "являются", "имеет", "должен" и т.д.

В зависимости от типа связи (иерархии или топологии) и отборочных, используемых в описании его, удельная ограничение (ы) должны быть определены (см. Ниже) Для приведенного выше примера иерархии "Ведомствадолжны быть разложены в Команды"Надо определить" Родитель должен иметь ребенка "ограничение и установить исполнения должно быть исполнено. Для приведенного выше примера топологии"Процессы возможно осуществляется Команды. "Следует создавать только два (2)" Подключение должно быть присоединены к компоненту "ограничений для обоих концов осуществляется по типу подключения частности, следующие ограничения рекомендуются быть определены (см ниже) для различных вариантов;

· Иерархия ограничения;

o Существительные возможноразлагается в Существительные В, или Существительные В возможноагрегируется Существительные или Существительные В должно бытьагрегируется Существительные- Определить "ребенок должен иметь родительский" ограничение с типом ребенка как Существительное B, родительского типа как Существительное А и исполнения, как предупредил.

Заметка

Это означает, что если ребенок существует, он должен иметь родителя определенного типа. Если нет, то вы получите предупреждение.

o Существительные должно бытьразлагается в Существительные В- Определить "Родитель должен иметь ребенка" ограничение с типом родительского как Существительное А, типа ребенка как Существительное В и исполнения, как предупредил.

Заметка

Это означает, что если один из родителей существует, он должен иметь детей определенного типа. Если нет, то вы получите предупреждение.

o Существительные должно бытьразлагается в Существительные В- Определите "Родитель должен иметь ребенка" ограничение с типом родительского как Существительное А, типа ребенка как Существительное В и обеспечения соблюдения, насильственным.

Заметка

Это означает, что если один из родителей существует, то он должен иметь ребенка определенного типа. Если вы не получите сообщение об ошибке.

o Существительные должно бытьагрегируется Существительные В- Определить "ребенок должен иметь родительский" ограничение с типом ребенка как Существительное А, родительского типа как Существительное В и обеспечения соблюдения, насильственным.

Заметка

Это означает, что если ребенок существует, он должен иметь родителя определенного типа. Если нет, то вы получите сообщение об ошибке.

· Топология ограничения;

o Существительные возможно глагол Существительные В- Определить два (2) "Подключение должно быть присоединены к компоненту" ограничений. Первый существо с конца источника типа подключения глаголприкреплены к существительным типа компонента и исполнения установлен в насильственным. Второй существо с конца Sink типа подключения глаголприкреплены к Существительное типа компонента Б и обеспечения установленного на насильственным.

Заметка

Это означает, что если связь существует, то она должна соединить компоненты определенных типов. Если вы не получите сообщение об ошибке. В целом, это гарантирует, что эти компоненты могут все еще существуют и не связаны друг с другом. Однако, если они связаны, должны быть использованы соединения соответствующего типа.

o Существительные должно быть глагол Существительные В- Определить два (2) "Компонент должен быть прикреплен к подключению" ограничений. Первый будучи с существительного типа компонента прикреплены к концу источника глаголтип соединения и обеспечение Набор для предупредили. Второй существо с Существительное типа компонента Б прикреплены к концу раковина из глаголтип соединения и обеспечение Набор для предупредили. Кроме того, определить два (2) "Подключение должно быть присоединены к компоненту" ограничений. Первый существо с конца источника типа подключения глаголприкреплены к существительным типа компонента и исполнения установлен в насильственным. Второй существо с конца Sink типа подключения глаголприкреплены к Существительное типа компонента Б и обеспечения установленного на насильственным.

Заметка

Это означает, что если существуют компоненты обоих типов, они должны быть присоединены к соединению определенного типа. Если вы не получите предупреждение. Кроме того, это означает, что если соединение существует, то он должен быть подключен к компонентам указанного типа. Если вы не получите сообщение об ошибке. В целом, это гарантирует, что если существуют компоненты этих типов, вы получите предупреждение, если они не связаны друг с другом.

o Существительные должно быть глагол Существительные В- Определить два (2) "Компонент должен быть прикреплен к подключению" ограничений. Первый будучи с существительного типа компонента прикреплены к концу источника глаголтип соединения и обеспечение устанавливается на насильственным. Второй существо с Существительное типа компонента Б прикреплены к концу раковина из глаголтип соединения и обеспечение устанавливается на насильственным. Кроме того, определить два (2) "Подключение должно быть присоединены к компоненту" ограничений. Первый существо с конца источника типа подключения глаголприкреплены к существительным типа компонента и исполнения установлен в насильственным. Второй существо с конца Sink типа подключения глаголприкреплены к Существительное типа компонента Б и обеспечения установленного на насильственным.

Заметка

Это означает, что если существуют компоненты обоих типов, они должны быть присоединены к соединению определенного типа. Если вы не получите сообщение об ошибке. Кроме того, это означает, что если соединение существует, то он должен быть подключен к компонентам указанного типа. Если вы не получите сообщение об ошибке. В целом, это гарантирует, что если существуют компоненты этих типов, вы получите ошибки, если они не связаны друг с другом.

Чтобы определить ограничение

1. Убедитесь, у вас есть ABACUS файлоткрыт и Окно Проводникотображается.

2. В обозревателе дерева расширить Виды | Комплектующие Типыили расширить Виды | Типы подключения.

3. Щелкните правой кнопкой мышитип компонент или тип подключения и выберите Добавить Constraint.

Добавление ограничения

Чтобы определить иерархии ограничение, когда родитель должен иметь конкретного ребенка

4. На Добавить ConstraintОкно галочку Создать ConstraintФлажок под Родитель Иметь ребенка Constraint площадка.

5. Выберите тип компонентаот выпадающего списка, который вы хотите указать в качестве ребенка типа компонента, выбранного в шаге 3.

Заметка

Если уже есть включен "Родитель Иметь Детская ограничение определено для типа компонента материнской и детской другого типа компонента, то это новое ограничение будет рассматриваться как" и ". Это тип должен быть родителем типа А ребенок а такжеТип ребенок Б, к какой уровень органами (например, инвалидов, предупреждение или насильственное - см шаг 7) указывается для каждого ограничения.

6. При желании вы можете определить минимальное и максимальное количество компонентов типа компонента указано, что должны быть дети от типа правой кнопкой мыши на шаге 3 компонента.

7. Выберите, хотите ли вы, чтобы быть ограничение Отключено, Предупредил или Насильственные.

Заметка

Ограничения для инвалидов будут игнорироваться из ограничений проверки, предупредил ограничения будут производить предупреждение в окне проверки, если они обнаружены и Насильственные ограничения будут выдавать ошибку в окно проверки, если они обнаружены. Кроме того, все ошибки должны быть решены до того, как Предприятие Сервер Проект может быть совершено.

8. Нажмите ОК.

Заметка

Ограничение будет отображаться в Проводнике дерева в соответствии с типом правой кнопкой мыши в шаге 3. Стрелка обозначает направление ограничения, и в этом случае будет указывать вниз и вправо компонента. Висячий замок окрашена в зависимости от того ограничение инвалидов (серый), предупредил (желтый) или насильственным (красный).

Родитель должен иметь ребенка предупредил ограничение

Чтобы определить иерархии ограничение, где ребенок должен иметь определенный родителей

4. На Добавить ConstraintОкно галочку Создать ConstraintФлажок под Ребенок должен иметь Parent Constraint площадка.

5. Выберите тип компонентаот выпадающего списка, который вы хотите указать в качестве родителя типа компонента правой кнопкой мыши на шаге 3.

Заметка

Если уже есть включен "ребенок должен иметь родителя ограничение, определенное для типа компонента ребенок и другой родительского типа компонента, то это новое ограничение будет рассматриваться как 'или'. Это тип должен быть ребенок родитель типа А илиродительский тип B, и уровень правоприменения (например, предупреждение или насильственное - см следующий шаг) должно быть таким же иначе насильственные ограничения всегда будут преобладать те предупреждали.

6. Выберите, хотите ли вы, чтобы быть ограничение Отключено, Предупредил или Насильственные.

Заметка

Ограничения для инвалидов будут игнорироваться из ограничений проверки, предупредил ограничения будут производить предупреждение в окне проверки, если они обнаружены и Насильственные ограничения будут выдавать ошибку в окно проверки, если они обнаружены. Кроме того, все ошибки должны быть решены до того, как Предприятие Сервер Проект может быть совершено.

7. Нажмите ОК.

Заметка

Ограничение будет отображаться в проводнике в соответствии с типом компонента, выбранного в шаге 5. Стрелка обозначает направление ограничения, и в этом случае будет указывать вверх и влево. Висячий замок окрашена в зависимости от того ограничение инвалидов (серый), предупредил (желтый) или насильственным (красный).

Ребенок должен иметь родительский предупредил ограничение

Чтобы определить топологию ограничение, когда компонент должен быть прикреплен к определенному связи

4. На Добавить ConstraintОкно галочку Создать ConstraintФлажок под Компонент должен быть прикреплен Constraint площадка.

5. Выберите тип соединенияот выпадающего списка, который вы хотите указать в качестве прикрепленного соединения типа компонента правой кнопкой мыши в шаге 3. (Или выберите тип компонентаот выпадающего списка, который вы хотите указать в качестве прикрепленного компонента, если в шаге 3 вы нажали правой кнопкой тип подключения).

Заметка

Если уже есть включен "Компонент должен быть установлен" ограничение определено для типа компонента и другой тип подключения, то это новое ограничение будет рассматриваться как "И". То есть тип компонент должен быть прикреплен к типу соединения А а такжетип соединения B, чтобы какой-либо уровне органов (например, инвалидов, предупреждение или насильственное - см шаг 7) указывается для каждого ограничения.

6. При желании вы можете выбрать соединение рольчто вы хотите добавить к ограничению. Sизбрать конкретный роль (т.е. либо источник или раковина) из выпадающего списка.

7. Выберите, хотите ли вы, чтобы быть ограничение Отключено, Предупредил или Насильственные.

Заметка

Ограничения для инвалидов будут игнорироваться из ограничений проверки, предупредил ограничения будут производить предупреждение в окне проверки, если они обнаружены и Насильственные ограничения будут выдавать ошибку в окно проверки, если они обнаружены. Кроме того, все ошибки должны быть решены до того, как Предприятие Сервер Проект может быть совершено.

8. Нажмите ОК.

Чтобы определить топологию ограничение, когда соединение должно быть прикреплено к определенному компоненту

4. На Добавить ConstraintОкно галочку Создать ConstraintФлажок под Подключение должен быть прикреплен ограничений площадка.

5. Выберите тип соединенияот выпадающего списка, который вы хотите указать в качестве прикрепленного соединения типа компонента правой кнопкой мыши в шаге 3. (Или выберите тип компонентаот выпадающего списка, который вы хотите указать в качестве прикрепленного компонента, если в шаге 3 вы нажали правой кнопкой тип подключения).

Заметка

Если уже есть включен "Подключение должен быть установлен" ограничение определено для типа соединения и другого компонента типа, использующих соединение роль(т.е. либо Источник или раковины), то это новое ограничение будет рассматриваться как "ИЛИ". То есть тип соединения должны быть присоединены к компоненту типа А илиКомпонент типа В, а уровень соблюдения (например, предупреждение или насильственное - см шаг 7) должен быть таким же иначе насильственные ограничения всегда будут преобладать те предупреждали. Также отметить, что, если есть несколько ограничений, которые имеют связь рольопределяется как "любое" (в отличие от специально Источник или раковины), то каждый конец соединения должен быть прикреплен к одному из типов компонентов, указанных в ограничениях.

6. При желании вы можете выбрать соединение рольчто вы хотите добавить к ограничению. Sизбрать конкретный роль (т.е. либо Источник или Раковина) из выпадающего списка.

Заметка

Источника или раковина роль должна быть явно выбраны для Привязанность столбец будет строения будут показаны в компоненте каталог .

7. Выберите, хотите ли вы, чтобы быть ограничение Отключено, Предупредил или Насильственные.

Заметка

Ограничения для инвалидов будут игнорироваться из ограничений проверки, предупредил ограничения будут производить предупреждение в окне проверки, если они обнаружены и Насильственные ограничения будут выдавать ошибку в окно проверки, если они обнаружены. Кроме того, все ошибки должны быть решены до того, как Предприятие Сервер Проект может быть совершено.

8. Нажмите ОК.

Реального времени проверка модели и ограничение Проверка

AБакус включает в себяв режиме реального времени Модель Проверка и Проверка особенность, чтобы немедленно дисплей эффекты данной операции пользователь будет иметь на предупреждения и ошибки с текущего проекта, из-за какой-либо иерархия а также топология ограничения, которые были определены. Следует отметить, что все ошибки должны быть решены до того, как Предприятие Сервер Проект может быть совершено.

В режиме реального времени функция проверки ограничения наиболее заметно при заполнении с диаграммами или непосредственно в окне Проводника. В частности, в ходе следующих операций, руководство дается с помощью цветных бликов, как о том, операция будет иметь на предупреждения и ошибки с текущего проекта;

1. При перемещении элементов на или вокруг диаграммы цвета родителя (или имеется) компонента (если таковые имеются) границы будут окрашены в соответствии со схемой, описанной ниже.

2. При подключении компонентов с помощью правой кнопки мыши перетащите | Подключите Чтобы представить список доступных типов подключения окрашена по схеме, описанной ниже.

3. При подключении компонентов на схемах с использованием режима Connector курсор изменит цветы согласно схеме, описанной ниже.

4. При добавлении суб-компоненты в списке доступных типов компонентов окрашена по схеме, описанной ниже.

В целом используются следующие цвета для обозначения эффектов операция пользователь будет иметь на наличие ошибок и предупреждений с текущего проекта;

Черный Нет Воздействие на предупреждения или ошибки.

Зеленый : Операция явно в соответствии сопределенные иерархии и топология ограничения для проекта.

Красный : Операция явно в нарушениеОпределенные иерархии и топология ограничения для проекта и приведет к предупреждениям и / или ошибок.

Задний план проверка модели и ограничение Проверка

ABACUS включает в себя Функция проверки, чтобы отобразить все предупреждения и ошибки с текущего проекта, из-за каких-либо ограничений, которые были определены. Следует отметить, что все ошибки должны быть решены до того, как Предприятие Сервер Проект может быть совершено.

Заметка

Проверка должна быть запущена вручную с помощью "Подтвердить / регистрация проектных ограничений" кнопку на Главная панель инструментов , Окно проверки по умолчанию скрытано появляются, когда кнопка панели инструментов нажата, Видеть Настройка интерфейса о том, как отобразить его и, возможно оставить его постоянно отображаться. Кроме того, вы можете дважды щелкнуть любую строку в окне Проверка на «скачка» к соответствующему элементу в проекте.

Окно проверки

Столбцы по умолчанию в окне Проверка описаны следующим образом:

Предупреждение или ОшибкаВ этом столбце отображается значок для ли нарушение является предупреждение (желтый треугольник с восклицательным знаком) или ошибки (красный круг с крестом).

ЧислоВ этом столбце отображается количество нарушений.

Заметка

Только 200 нарушений показаны в то время, и если есть больше, чем 200 нарушений в проекте Пуск Предыдущая, Следующая и конец строки навигаторы в верхнем правом углу окна можно использовать для просмотра дополнительных нарушений.

Описание: Это полное описание нарушения, включая Entity и ограничении заинтересованного.

сущностьВ этом столбце отображается сущность озабоченность нарушения.

ТипВ этом столбце отображается тип элемента для объекта.

АрхитектураВ этом столбце отображается Архитектура, в течение которого произошло нарушение.

ОбнаруженныйВ этом столбце отображается время, что нарушение было обнаружено.

Наконечник

Это полезно для сортировки по убыванию по Обнаруженные колонке (как показано в приведенном выше диалоге), чтобы обеспечить самые последние нарушения появляются в "сверху" списка.

Есть несколько вариантов пользователю изменять поведение проверки фон модели. Например, третo изменить цвета, используемые для нарушения ограничений, чтобы что-то другое, чем по умолчанию Красный, Нажмите Сервис | Опции... затем перейдите к Проверказакладка, и установить цвета через + Изменить кнопки.

Проверка опции

Чтобы вручную проверить ограничения

1. Щелкните правой кнопкой мыши на АрхитектурыУзел, любая архитектура или где либо в Компоненты или Связичасть проводнике и выберите Проверьте ограничений.

Подтвердить ограничений

2. Нажмите ДеталиКнопка на Предупрежденияокно, чтобы увидеть, где архитектура нарушает каких-либо ограничений, которые были определены.

Заметка

Нарушения показаны только для тех ограничений, которые были установлены на предупреждение или насильственное. Кроме того, формулировка предупреждения будет включать в себя "следует", если ограничение было просто предупреждение или "должен", если она была жизнь.

3. Нажмите ОК.

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную


Развитие архитектуру

Навигация: Заполнение архитектуру> Заполнение вручную> Дополнительные параметры>

Развитие архитектуру

Отправить комментарии на эту тему.

Архитектура может быть явно развивалась и иерархия архитектур создан. Таким образом, развивается архитектуру в ABACUS, ряд передовых архитектурных решений могут быть созданы, по сравнению и базовая версия. Голы (или метрики) могут быть определены для любого числа архитектурных свойств существующих архитектур.

Простой способ рассмотреть эволюцию архитектуры связать его с понятием потомок архитектура, Когда архитектура выделяется, А копияродительского архитектуры создан. Эта копия, можно сказать, быть прямым потомокоригинала родитель архитектура.

Заметка

В этом онлайн документация помощи и сама набор инструментов ABACUS, срок развиватьсячаще используется, чем срок потомокПожалуйста, обратите внимание, что оба относятся к той же функциональности.

Для развиваться в существующую архитектуру

1. Убедитесь, у вас есть ABACUS файлоткрыт и Окно Проводникотображается.

2. Выберите соответствующую архитектуру вы хотите развиваться из дерева Проводника.

3. Щелкните правой кнопкой мышина архитектуре и выберите Развиватьсяиз меню.

Развитие Избранным Архитектура

4. Усовершенствованная архитектура ниже появится выбранной архитектуры.

Evolved Архитектура

Заметка

Усовершенствованная архитектура может быть переименован, щелкнув правой кнопкой по архитектуре и выборе Переименовать.Кроме того, все диаграммы и каталоги в сложившейся архитектуре будет автоматически установлен в "Разница" против базового архитектуры что он был эволюционировали от.

Постановка целей для вашего развивалась архитектура

Постановка целей для вашего развивалась архитектура позволяет создать критерии для оценки эволюции ваших архитектур. Цели определяются по видам собственности и имена тех свойств существующих в сложившейся архитектуре. Цели могут быть также определены вручную и добавил к вам архитектуре. Выполните следующие действия, чтобы установить цели.

Постановка целей из существующих свойств для развивалась архитектура

1. Убедитесь, у вас есть ABACUS файлоткрыт и Окно Проводникотображается.

2. Выберите Инструменты | Назначать целиИз главного меню.

3. Цель вводаОкно будет отображаться.

Цель Окно ввода

4. Нажать на СуществующийКнопка.

5. Выберите свойствоОкно будет отображаться.

6. Выберите свойство, которое вы хотите установить в качестве цели для вашей сложившейся архитектуры и нажмите на ОККнопка.

7. Выбранный цель теперь появится в Цель ввода окно.

8. Выберите цель и нажмите на редактироватьКнопка.

9. Редактировать ГолОкно будет отображаться.

Заметка

Это окно позволяет изменить имя и тип собственности, что цель будет отражать, а также худшее и лучшее значение (или минимум / максимум значения) для этого свойства. Эти значения находятся путем сравнения все архитектуры, и найти наименьшее и наибольшее значение в каждой для этого конкретного имущества. Эти значения могут быть также определены вручную. Например, если вы установите цели для свойства имени Ответ (пр)и типа Поведение, Ваш худший и лучший значение может отражать скорость транзакций, необходимую для обеспечения оптимальной производительности (лучше стоимость) и скорости транзакций, необходимой только для основных приложений, которые будут обработанного (худшее значение).

10. После того, как соответствующие значения были определены, выберите ОК.

Постановка целей из новых свойств для развивалась архитектура

1. Убедитесь, у вас есть ABACUS файлоткрыт и Окно Проводникотображается.

2. Выберите Инструменты | Назначать целиИз главного меню.

3. Цель вводаОкно будет отображаться.

4. Нажать на НовыйКнопка.

5. Новая цельОкно будет отображаться.

Заметка

Это окно позволяет определить имя свойства и тип, что цель будет отражать, а также худший и лучший значение (или минимальное / максимальное значения) для этого свойства. Например, если вы установите цель на недвижимость по имени Ответ (пр)и типа Поведение, Ваш худший и лучший значение может отражать скорость транзакций, необходимую для обеспечения оптимальной производительности (лучше стоимость) и скорости транзакций, необходимой только для основных приложений, которые будут обработанного (худшее значение).

6. После того, как соответствующие значения были определены, выберите ОК.

7. Откроется диалоговое окно для Добавить для всех архитектурбудет отображаться как ниже:

8. Нажмите на дадобавить цель в собственности всех соответствующих архитектур. Это гарантирует, что вновь определенные цель и его свойства будут добавлены ко всем архитектур в файле. Если вы не хотите включать в себя свойство в архитектурах, вы можете нажать на Нет.

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Просмотр звезда участок ваших развивались архитектур | Просмотр точечный график ваших развивались архитектур


Инструменты рисования

Навигация: Заполнение архитектуру> Использование чертежей>

Инструменты рисования

Отправить комментарии на эту тему.

Инструменты рисования позволяет создавать широкое разнообразие архитектурных схем и диаграмм. Архитекторы традиционно используют широкий спектр различных рисунков для записи и передать дизайн архитектуры. Двумерные (2D) диаграммы обычным способом документирования и общения различных частей системы. Типичные виды рисунков, используемых в корпоративных системах являются:

· Бизнес модели процесса и схемы;

· Организация графики;

· Сотрудничество диаграммы;

· Сущность-связь (ER), диаграммы;

· Диаграммы потоков данных DFD (годы);

· Диаграммы классов;

· IDEF (включающий несколько выше); а также

· UML (включающий несколько выше).

Там действительно нет ограничений на виды диаграмм, которые могут быть созданы. ABACUS пытается сбалансировать гибкость схема, сохраняя целостность архитектуры и ее форм представления.

Розыгрыш среда является вкладками и закрепляемые окна внутри основного приложения ABACUS. Это окно содержит полотно, где рисунок проходит и когда рисунок окно открыто второй закрепляемые окна Окно трафарета, можно просматривать с набором чертежей трафаретов. Трафарет панели есть 4 вкладки: Узлы, связи, формы и разъемы. Полотно появится в белом фоне с тонкими линиями сетки (полезные для макета).

Компоненты представлены в диапазоне форм, в то время как соединения показаны в виде линий, направленных. Соединения приложить к компонентам с помощью Роли (т.е. либо источник или раковина) хотя они не показаны по эстетическим причинам.

Наконечник

В то время как диаграммыочень полезно для показа различных частей системы, они ограничены в их масштабируемости, поэтому ABACUS использует 3D визуализации сложных системных структур.

Вы можете

1. Открой Построение диаграмм Инструмент

2. Создать новую диаграмму из части вашей архитектуры

3. Скопируйте диаграмму внутри страны или за архитектур

4. Добавление компонентов к диаграмме

5. Создание новых компоненты и соединения в архитектуре (схематично), используя инструмент рисования

6. Удалить компоненты из диаграммы

7. Прикрепите & манипулировать связи

8. Изменить свойства отображения компонентов и соединений.

9. Использование ссылок в схема

10. Обеспечение ассоциации типа и точки зрения таким образом, чтобы ограничить типы диаграмм, которые могут быть сделаны.

Смотрите также

Заполнение архитектуру | Заполнение архитектуру вручную | Анализ ваша архитектура


Открытие диаграммы

Навигация: Заполнение архитектуру> Использование чертежей>

Открытие диаграммы

Отправить комментарии на эту тему.

Чертеж трафарет и холст окна появляется автоматически, когда схема открыта или создана. Аналогичным образом, когда схема, закрыт, соответствующая вкладок листов в окне холст исчезает и, если никаких дальнейших чертежах не открыто, то окно трафарета закрыт.

Для Создайтеновая схема

1. Убедитесь, у вас естьABACUS открыть файлсодержащий ваши населенный архитектура.

2. Нажать на Diagramзначок в панели инструментов Вид.

- или -

2. Выбрать Вставить| Diagram.

- или -

2. Щелкните правой кнопкой мыши Диаграммыфилиал данное Архитектурараздел дерева и выберите Создайте Схема.

3. Выберите АрхитектураВы хотите, чтобы сосредоточиться на с выпадающего меню. Примечание: архитектура уже будет выбран для вас, если вы использовали Шаг 3 выше, чтобы открыть новую схему.

4. Выберите Смотровая площадка Вы хотите использовать, из выпадающего меню. Примечание: выбранный зрения будет фильтровать компоненты и соединения списки те доступны только от точки зрения.

5. При желании выбрать вид из Фильтр по ВидВ выпадающем меню для предварительного выбора компонентов и соединений из выбранного зрения. Примечание: это эффективно с использованием выбранного вид, как сохраненного запроса.

6. Выберите Расположение быть или Радиальный или Сетка.

7. Выберите Компоненты а также Связичто вы хотите на диаграмме от стандартный элемент окна выбора .

8. Нажмите ОК.

Заметка

Новую диаграмму будет добавлен к Диаграммыфилиал архитектуры. Он будет иметь имя по умолчанию, которое можно изменить позже, нажав правой кнопкой мыши на нем.Кроме того, последнее состояние компонентов и отбора подключение фильтров будут сохранены с диаграмма эффективно сохранения '' запрос, используемый для создания диаграммы.

Чтобы открыть существующий диаграмма

1. В конкретном населенном архитектуры, расширить Диаграммыветвь дерева.

2. Двойной клик диаграмма Вы хотите открыть.

Чтобы сохранить схему

1. Убедитесь, что у вас есть новый или существующий схему открытыйи вы сделали необходимые изменения. Примечание: звездочкой '*' будет показан после названия вида в заголовке листа вкладками, если есть изменения будут сохранены.

2. По мнению исследователя нажмите на СохранитьКнопка или получил файл| Сохранитьили нажмите Ctrl + Sчтобы сохранить все изменения в вашей архитектуре и написать его в файл.

Чтобы сохранить схему в виде смотровая площадка

1. Убедитесь, что у вас уже есть схема в файле ABACUS.

2. Щелкните правой кнопкой мышиДиаграмма в Диаграммычасть дерева.

3. Выбрать Сохранить как Схема Точка зрения.

4. Введите имя для вашего нового схема точка зренияи нажмите ОК.

Смотрите также

Инструменты рисования | Заполнение архитектуру | Анализ ваша архитектура


Копирование диаграммы

Навигация: Заполнение архитектуру> Использование чертежей>

Копирование диаграммы

Отправить комментарии на эту тему.

Есть 2 основных сценария к копирования существующей диаграммы; в архитектуре или по архитектур.

Для копиядиаграмма,в архитектуре

1. Убедитесь, у вас естьABACUS открыть файлсодержащий ваши населенный архитектурапо меньшей мере, одним схема.

2. Расширять Диаграммы филиал (и любые требуемые Диаграмма группы) данного Архитектурачасть дерева.

3. Выберите схему вы хотите скопировать, а затем нажмите Ctrl + C, или щелкните правой кнопкой мышии выберите Копия из меню.

Заметка

A копия Диаграмма будет добавлена ​​к Диаграммыветвь одна и та же архитектура. Это будет иметь "Копия" добавляется к началу имени, Который вы можете изменить позже нажав F2 или правой кнопкой мыши на неми выбрав Переименовать.

Для скопировать схему через архитектур

1. Убедитесь, у вас естьABACUS открыть файлсодержащий ваши населенный архитектураsпо меньшей мере, одним схема.

2. Расширять Диаграммы филиал (и любые требуемые Диаграмма группы) из Архитектурачасть деревадля архитектуры, которая содержит схему вы хотите скопировать.

3. Выберите схему вы хотите скопировать, и на Общие свойстваПримечание Окно Смотровая площадка что схема связана с (в поле Тип).

4. Теперь, расширять Диаграммы филиал (и любые требуемые Диаграмма группы) из Архитектурачасть деревадля другой архитектуры, что вы хотите, чтобы скопировать диаграмму в.

5. Щелкните правой кнопкой мыши Диаграммы узел (или Схема группа) И выберите Создать диаграмму ..., В появившемся диалоговом окне выберите Смотровая площадка что было отмечено в шаге 3 выше в выпадающем списке в правом верхнем углу. Оставьте все остальное как и нажмите ОК, В диалоговом окне Диаграмма Имя Введите имя для (скоро будет) скопированной схеме. Примечание: пустая схема холст в соответствии с выбранной точки зрения будет открыт.

6. Вернуться к диаграмме, которую вы хотите скопировать, и открыть что щелкнув правой кнопкой мышиузел и выбрав открыто или просто двойной щелчок Это.

7. Выберите фон холст диаграммы вы хотите скопировать, и нажмите Ctrl + A, Это позволит выбрать все элементы на этой диаграмме. Теперь нажмите Ctrl + C,чтобы скопировать содержимое в буфер обмена.

8. Теперь вернитесь к пустой диаграммы в архитектуре, который вы хотите скопировать содержимое в, выбрать фонхолст и либо щелкните правой кнопкой мышии выберите Вставить или просто нажать Ctrl + Vчтобы вставить содержимое. После краткого времени содержание все будут вставлены в новую пустую диаграмму.

Заметка

Элементы будут добавлены в топ-уровня в новой архитектуре и должны быть переоформлена или объединены с существующими содержание соответственно.

Смотрите также

Инструменты рисования | Заполнение архитектуру | Анализ ваша архитектура


Заполнение диаграммы

Навигация: Заполнение архитектуру> Использование чертежей>

Заполнение диаграммы

Отправить комментарии на эту тему.

Рисунки в ABACUS больше, чем просто произвольных представлений. Они настроены вид архитектуры, форматирования и расположены, чтобы показать особое значение.

Инструменты рисования усиливает иерархическую структуру архитектуры, так что компоненты визуально вложены в другие компоненты - эффективно дать «вид сверху» элементов. После того, как компонент или соединение было определено в архитектуре, он может быть использован в любом количестве различных схемах. Важно отметить, что инструмент рисования тесно связана с архитектурной модели, так что изменения, сделанные в любом одном всегда находят свое отражение в другом.

Инструмент работает, связывая формы с подключения и компонентов конкретных типов, определенных в разделе Типы архитектуры. Эти ассоциации варьироваться в зависимости от типа диаграммы втягивается, и вполне возможно, что один тип компонента (или соединение) может иметь различные представления в различных схемах, в зависимости от контекста.

Чтобы настроить связь между формой и компонента или соединения типа

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Максимально приложение ABACUS, и настроить окно пропорции как вы хотите.

3. Выберите Вкладка Формы или Вкладка Соединители в окне трафарета.

4. в Типфилиал Explorer, найдите компонент или тип подключения вы хотели бы ассоциировать с формой или разъема.

5. Выберите выбранного типа элемента из дерева, перетащите его на вкладке Shapes или вкладке Соединители и поместите его на форму или разъемВы хотели бы использовать.

Заметка

Вы можете проверить связь вы создали, выбрав компоненты или вкладку Подключения в окне трафаретов, которые показывают, на данный момент, связанные элементы.

Чтобы добавить новые формы, чтобы ваши диаграммы / библиотеки

1. Создать MS Visio диаграммы с формами, которые вы хотите добавить в диаграмму и импортировать схему MS Visio .

Наконечник

Важно, какой размер вы сделать мастер форму в MS Visio, потому что полотно счеты размером в пикселях, и только миллиметры единиц в MS Visio преобразовать гранулировано пикселям на 4 пикселя до 1 соотношении миллиметра. Кроме того, ABACUS формы по умолчанию, как правило, 60 пикселей в высоту, так что приводит к 15 миллиметров MS Visio. Значение рекомендуемый мастер форма размер в MS Visio является Шириной 25 мм на 15 мм высокойкак это будет перевести на 100 пикселей в ширину и 60 пикселей в высоту в ABACUS.

Наконечник

Если вы хотите, чтобы немного "значок" в верхнем левом углу формы, то вы можете просто создать "икону" в мастер-MS Visio формы, используя палитру MS Visio Drawing Tool (обратите внимание, что только простые линии, круги и прямоугольники поддерживаются и растеризации / растровые формы, в частности, не поддерживается). Кроме того, если вы хотите, чтобы значок фиксируется в размер /в форме в ABACUS, то вы можете группировать "значок" в мастер-MS Visio формы, выбрав все свои элементы, щелкнув правой кнопкой мыши один элемент, выбрав Форма | Группа, затем щелкните правой кнопкой мыши, сгруппированные форму и выбрав данные | Форма данных ..., выбрав Да в появившемся диалоговом окне, а затем добавить свойство с этикеткой, установленным в LockScale(обратите внимание на верхний регистр "L" и "S"), Тип установки для Логическое и значение, установленное быть ПРАВДА (обратите внимание, это все в верхнем регистре).

Наконечник

Если вы хотите, чтобы иметь часть формы заморожены от масштабирования по горизонтали или по вертикали (как это обычно бывает в «Swimlane" формы), то вы можете щелкнуть правой кнопкой мыши часть (ы) мастер MS Visio формы, что вы хотите замороженный от масштабирования и выберите данные | Форма данных ..., выбрав Да в появившемся диалоговом окне, а затем добавить свойство с этикеткой, установленным в LockXScale или LockYScale (обратите внимание на верхний регистр "L" и "S"), Тип установки для Логическое и значение, установленное быть ПРАВДА (обратите внимание, это все в верхнем регистре), для заблокирован по горизонтали или по вертикали масштабирование соответственно.

Наконечник

Чтобы разрешить раскраску формы в ABACUS после импорта, а не форма всегда быть фиксированного цвета желательно сделать заливку мастер MS Visio фигуры прозрачный а затем использовать встроенный в способность ABACUS, цвет фона формы в. Это работает только с прямоугольника или около прямоугольника (например, прямоугольник с закругленными углами) форм, как весь прямоугольный фон будут окрашены.

2. Откройте соответствующую диаграмму и выберите Вкладка Компонентыв окне трафарета.

3. Для каждого нового формы, что вы хотите сделать доступными для других диаграмм Щелкните правой кнопкой мышиформа и выберите Добавить в Shapes библиотеки, Это сделает форма доступны на вкладке Shapes в окне трафарета.

4. Связывание соответствующий тип компонента с новой формой из библиотеки фигур в соответствии с шагами, описанными выше.

Заметка

Только простой и "вектор на основе" формы поддерживаются в ABACUS на данный момент, то есть растровые изображения не поддерживается. Тем не менее, такие инструменты, как вектор магии ( www.vectormagic.com ) Имеются, которые будут легко конвертировать растровые изображения в векторную форму (т.е. формат SVG), которые могут быть открыты в MS Visio и, следовательно, используемых в ABACUS в соответствии с инструкциями выше.

ДобавлениеКомпоненты и соединения

Инструменты рисования позволяет добавить существующие компоненты и соединения из репозитория или создавать новые компоненты и соединения, как вы рисуете схему. Как компоненты и соединения создаются в схемах, они одновременно добавляют в хранилище, Есть три рекомендуется способы добавления компонентов в виде диаграммыи три рекомендуемых способов добавления подключений к диаграмме:

Чтобы создать полностью новый компонент или соединение на диаграммес трафарета

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Выберите Компоненты или СвязиВкладка в окне трафарета, чтобы увидеть связанные формы. Только эти формы могут быть использованы для создания новых элементов модели.

3. Нажать и перетащитьодин из доступных форм, связанных на холсте рисования. Новый элемент появится на холсте и в Проводнике дерева.

4. Начните вводитьимя для нового элемента в диалоге и любых существующих элементов, которые соответствовали предложены и могут быть выбраны вместо добавления нового элемента в архитектуре.

5. Нажмите ОК.

6. Если форма была сброшена на существующий компонент, то он будет либо стать ребенком этого компонента (если форма пришла из Компонентывкладка), или будут прикреплены к этому компоненту (если форма пришла из Связивкладка).

Заметка

Это иногда необходимо настроить новый компонент или соединение в другом месте в архитектурной иерархии, используя Проводник.

Чтобы разместить существующий компонент или соединение из хранилище на диаграмме

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Будьте уверены, что у вас есть и инструмент для рисования и окна Проводника просмотра.

3. В проводнике найдите компонент или подключение(элемент) вы хотели бы добавить к диаграмме.

4. Нажать и перетащитьвыбранный элемент на диаграмму. Форму, представляющую элемент появится на холсте.

Заметка

Если тип выбранного элемента уже связан с формой, соответствующей форме появится на холсте. Если, однако, нет ни одной ассоциации для этого элемента, форма по умолчанию (прямоугольник) появится на холсте, если только Обеспечение диаграмма Точки зрения опция на случай, в котором не будет добавлен форма схеме.

Наконечник

Когда компонент помещается на диаграмме, который подключен к другому компоненту, уже на диаграмме, Инструмент Рисование будет запрашивать, если вы хотите, чтобы показать связь (ы) между ними. Кроме того, если есть какие-либо дети компонента Инструмент Рисование будет запрашивать, если вы хотели бы включить детей в рекурсивным способом.

Для создать связь между 2 компонентами или подключенного компонента на диаграмме, используя динамический разъем

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Зависать над компонентом на диаграмме, что вы хотите подключиться к другому компоненту, и вы увидите 2 иконки появится за пределами верхней правой части границы формы, как показано ниже. Примечание: Верхняя иконка для создания соединения, где витали компонента является источником, нижняя иконка для создания соединения, где витали компонент должен быть раковина.

3. Переехать курсор на нужную пиктограмму и нажать и перетащитьзначок, чтобы над либо по другим компонента или свободного пространства на холсте, как показано ниже.

4. Для подключения к существующей компонента выберите Прикрепить к...пункт в контекстном меню и, если требуется перейдите к подменю, чтобы выбрать из доступных типов подключения.

- или -

4. Для создания компонента связности выбрал из Новый ...элементы в всплывающем меню и, если необходимо перейдите в подменю, чтобы выбрать из доступных типов подключения, как показано ниже. Начните вводитьимя для нового элемента в диалоге и любых существующих элементов, которые соответствовали предложены и могут быть выбраны вместо добавления нового элемента в архитектуре.

Заметка

Наличие элементов в меню всплывающем меню и подменю, регулируется ограничения В мета-модели.Это только действует источник или раковина типы компонентов, как определяется ограничениями подключения будут представлены как Присоединить к ... и пунктов меню Новый ....

Для Re-открыть диалоговое окно выбора элемента и поместить существующие компоненты или соединения из репозитория на диаграмме

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Нажмите Открыть Выбор элементаКнопка на панели инструментов Диаграмма. Обратите внимание диалоговое окно выбора элемента откроется в последнем состоянии каких-либо фильтров сохранены.

3. Выбрать любой дополнительный контент, который требуетс добавить к диаграмме и нажмите ОК, Примечание: новое содержание будет добавлена ​​в свободное пространство на холсте и диаграмма может быть впоследствии положил снова ЧЕРЕЗ Схема расположенияКнопка на панели инструментов Диаграмма.

Использование свободногоформаФормы

Часто желательно создавать визуальные элементы в виде диаграммы для чисто эстетических соображений. Эти элементы могут помочь улучшить внешний вид и внешний вид диаграммы, пока они не имеют строгой архитектурное значение. Инструменты рисования позволяет использовать произвольных форм, чтобы обеспечить гибкость рисунок.

Чтобы добавить произвольную форму диаграммы

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Выберите Формы или РазъемыВкладка в окне трафарета.

3. Нажать и перетащитьодин из доступных форм или разъемов на холсте рисования. Новый элемент появится на холсте, - но неВ обозревателе дерева.

Заметка

Freeform фигуры «не связаны» формы, так как они не имеют никакой связи с какой-либо конкретной детали или соединения в архитектурной модели.

Для отобразить хранилище информации в произвольной формы формасындиаграмма,

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Щелкните правой кнопкой мышисвободной формы форма и выберите Аннотация | Дисплей.

3. Выберите для отображения либо Схема Имя, Схема Описание, Схема недвижимости, Точка зрения Имя или Архитектура Имя.

Заметка

Текст в свободной форме будет автоматически обновляться, лежащих в основе хранилища данных изменений.Таким образом, схема, «надпись» могут быть созданы для, а затем легко скопированы, диаграммы.

Использование плавающей фигур

Плавающие формы, по существу, еще один способ представления компонентов в схеме. Рассмотрим организацию ключевых подразделений: генеральный директор по маркетингу, продажам и развитию.

В виде дерева

Эти подразделения могут быть визуально представлена ​​в виде слоев:

Многоуровневая Посмотреть

Или же они могут быть визуально представлен в шахматном / Плавающие Способ, чтобы показать иерархию:

Потрясенный / Плавающий Посмотреть

Последнее представление использует концепцию плавающих форм.

Чтобы преобразовать многоуровневую форму компонент в форме с плавающей

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Выберите компонентна диаграмме вы хотите, чтобы представлять в качестве плавучего формы или ассоциированного формы в КомпонентыВкладка окна трафарета вы хотите все экземпляры, как с плавающей формы.

3. Щелкните правой кнопкой мыши форму и выберите Поплавок компонент из контекстного меню, которое появляется. Обратите внимание алмаз главе соединениеот родительского компонента (ов) с плавающей компонента (ов).

4. Нажать и перетащитькомпонент в нужное место. Когда плавающийкомпонент выбран он будет иметь синий контур.

Для преобразования плавающего форму компонент в слоистой форме

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Выберите компонентна диаграмме, что в настоящее время показано, как плавающий формы или ассоциированного формы в КомпонентыВкладка окна трафарета вы хотите все экземпляры, как слоистых форм.

3. Нажать и перетащитьплавающий компонент (ы) обратно в родителя (родителей) (в соответствии с алмаз главе соединение). Примечание: Если вы не сделаете это, то при преобразовании компонент (ы) обратно в наслоится иерархия модели могут быть затронуты.

4. Щелкните правой кнопкой мыши форму и снимите флажок Поплавок компонент из контекстного меню, которое появляется. Следует отметить, что алмаз главе соединениеот родительский компонент (ы) с плавающей компонента (ов) исчезнет.

Реплики

Инструменты рисования позволяет добавить тот же компонент в схеме несколько раз с каждым дополнительным визуальным экземпляра компонента на диаграмме называют репликой. Это особенно полезно для диаграмм, когда компонент имеет большое количество соединений, присоединенных к нему, и предпочтительно, чтобы показать компонент в нескольких местах ближе к началу каждого из соединений, или для диаграмм, где один-к-многим компонента предпочтительно, чтобы показать с помощью плавающего элемента (описанный выше) с компонентом в нескольких местах в верхней части "много" компонентов, это связано с.

Заметка

Можно присоединить / отсоединить соединения в / из исходного экземпляра компонента на диаграмме (как всегда), но и к любой из реплик, тем не менее, когда соединения будут автоматически добавлены к схеме они присоединены к первому экземпляра компонента на диаграмме по умолчанию.

Заметка

Реплики могут быть объединены друг с другом щелкните правой кнопкой мыши и перетащитевыбрав Слияние репликОднако слияния реплику с другим компонентом приводит к любым другим реплик исчезает из диаграммы.

Заметка

Там нет визуальной разницы между первоначальной экземпляра компонента на диаграмме и любых копий. Кроме того, в меню правой кнопкой мыши на компоненте на оригинальной диаграмме и любой реплик идентичны, например с Показать в Проводникепринимая вас в то же компонента в виде дерева хранилища (ака модели). Тем не менее, щелкните правой кнопкой мыши компонент в виде дерева хранилища и выбора Идти ки просмотр на диаграмме с репликами всегда примет вас к '' старейший экземпляр компонента на схеме. Как правило, это будет оригинальным экземпляром, который был добавлен к схеме, но если оригинальный экземпляр был впоследствии удален или объединены с репликой затем перейдите к перейдет к старейшим из оставшихся копий, которые были добавлены.

Для добавить реплику к схема

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Щелкните правой кнопкой мыши существующий компонент на схеме и выберите Создание реплики.Копия выбранного компонента будут созданы в правой части исходного компонента.

- ИЛИ -

Выберите существующий компонент на диаграмме и нажмите Ctrl + C,или щелкните правой кнопкой мыши существующий компонент на схеме и выберите Копия, Теперь щелкните правой кнопкой мыши местоположение на диаграмме, что вы хотите реплику и выберите Вставить как Replica, Примечание: При нажатии Ctrl + V (или правой кнопкой мыши и выберите команду Вставить) создаст копию исходного компонента не является репликой.

- ИЛИ -

Нажать и перетащитькомпонент из Tree View хранилища (ака модели) на диаграмме, где компонент уже существует.

Настройка подключения Шапки / Окончание

Инструменты рисования позволяет установить символ, используемый на концах соединительных линий либо фиксированной символа или символ зависит от собственности на самом соединении.Это особенно полезно для диаграмм, где направление связи требуется, чтобы быть показано, или для диаграмм, где мощность передачи (или направления) содержится в собственности на самого соединения, например, "Один-ко-многим" против "многие-к-многим" (или "Источник тонуть" против "Sink к источнику»).

Для настроить шапки подключения / заканчивается диаграмма,

1. Убедитесь, что у вас есть новые или существующие схема открытой.

2. Выберите ПодключатьионыВкладка в окне трафарета.

3. Право-слизать один из связанных типов подключения и выберите Настройка Caps ....

4. Для фиксированной связи CAP / концом в любом источнике или раковина конец связи убедитесь, что соответствующие Исправлена радио-кнопка выбрана, а затем выберите конечную связь символ из тянуть вниз, например, "Стрелка Начальник" или "Алмаз".

- ИЛИ -

Для недвижимости на основе соединения крышки / конец на любом источнике или раковина конец связи убедитесь, что соответствующие Используя свойстворадио-кнопка выбрана, а затем нажмите кнопку "..." и выберите требуемое свойство, а затем рядом с каждой торцевой связь символа введите значения свойств, для которых конкретный символ соединения будут показаны.

Заметка

Несколько значений свойств для данного соединения концевой символ может быть введен через запятую. Например. ниже диалог показывает, что если "данных | Количество элементов 'не имеет значения' один-ко-многим ", то конец источником связи будут иметь две линии гладит через него и конец мойка связи будет иметь один ход линии через него, а затем фан-из двух Линия гладит в конце.

Настройка Caps диалог

Смотрите также

Инструменты рисования | Заполнение архитектуру | Анализ ваша архитектура


Операции над Диаграммы

Навигация: Заполнение архитектуру> Использование чертежей>

Операции над Диаграммы

Отправить комментарии на эту тему.

После того, как схема была создана, элементы, которые появляются в нем могут быть перестроены и повторно размера по желанию.

Чтобы переместить компонент в диаграмме

1. Убедитесь, что у вас есть существующий схема открытой .

2. Нажмите и удерживайтелюбой компонент, чтобы переместить его. Если выбранный компонент имеет родителя, будет выделен родительский компонент.

3. Как элементтащили от своего родительского компонента, и по сравнению с другими компонентами, "потенциал" родители станут выделены. Цветовая схема используется указывает на эффект операции будет иметь на наличие ошибок и предупреждений с текущего проекта и описан в Определение и утверждение ограничений , Таким образом, можно графически перемещаться по иерархии от «плана» зрения.

4. Выпусккнопку мыши, чтобы падение элемент в новое место.

Заметка

Вы также можете использовать клавиатуру, чтобы повторно расположения элементов на холсте рисования. Просто выберите компонент или свободной формы форму вы хотите переместить, и используйте клавиши со стрелками, расположенные на клавиатуре, чтобы переместить форму в нужное место.

Также обратите внимание, что при перетаскивании компонента с помощью мыши над другим компонентом, а 'потенциал' родительский компонент подсвечивается, когда верхний левый угол компонента, перетаскивая перекрывает другой компонент.

Наконечник

Свободная форма а также Плавающие формы можно заказать по щелкнув правой кнопкой мышии выбора На передний план или Отправить Назадиз меню. Важно отметить, что этот компонент формы могут быть преобразованы в произвольных форм путем щелкнув правой кнопкой мышина определенной формы компонентов и выбора Преобразовать в свободной форме.

Чтобы изменить размер компонента в диаграмме

1. Убедитесь, что у вас есть существующий схема открытой .

2. Нажмите удерживайте перетащитеодин из ручек компонента и изменять форму до нужного размера.

3. В качестве альтернативы для поддержания пропорций фигуры, нажмите Shift + клик-удержания сопротивление.

Для перемещения соединения в виде диаграммы

1. Убедитесь, что у вас есть существующий схема открытой .

2. Нажмите и удерживайтелюбое соединение, чтобы переместить его.

3. Выпусккнопку мыши, чтобы падение элемент в новое место.

Заметка

Вы можете двигаться только соединения, которые не прикреплены к любым компонентам. Если они присоединены, можно двигаться только свободный конецs, или Re-маршрута соединения .

Удаление компоненты и соединения

При удалении компонента или соединение с диаграммы, у вас есть возможность удалить его из всей архитектуры. Любой компонент, который удален от архитектуры будут автоматически удалены из каких-либо других диаграмм, где он появляется. С произвольной формы случаи появляются только в одной диаграмме, их удаление не влияет на архитектурную модель или любой другой схеме.

Чтобы удалить компонент или соединение с диаграммой

1. Убедитесь, что у вас есть существующий схема открытой .

2. Нажмитена любого связанного соединения или компонента, чтобы выбрать его.

3. нажмите УдалитьКлюч, чтобы удалить его из диаграммы, или Shift + Deleteчтобы удалить его из всей модели.

- или -

2. Щелкните правой кнопкой мыши на любом элементе связанной или компонента. Появится контекстное меню.

3. Выбрать Удалить из просмотра или Удалить из Архитектураиз контекстного меню.

Заметка

Если элемент, который вы хотите удалить из представления не имеет детей, и происходит только на этой точке зрения, ABACUS спросит, хотите ли вы удалить элемент из хранилища, а также.

Внимание

При удалении компонента из модели, который имеет дочерние компоненты, дети также будут потенциально удалено в соответствии с диалоговом окне предупреждения.

Объединение Компоненты

Вы можете объединить две составляющие существующие на той же схеме (и в архитектуре), Это может быть сделано по многим причинам, например, Два сервера существует в infrastructure- H компании01 и Н02. Эти два сервера представлены в виде двух отдельных компонентов в архитектуре. ЧАС01 был признан ненужным и, таким образом, чтобы быть выведены из эксплуатации. Все существующие приложения на H01 должны быть сдвинуты к H02 (все еще в комиссии). Это изменение может быть отражено в действии "слияния" двух компонентов H01 и Н02 на диаграмме (и в архитектуре).

Для детального обсуждения о слиянии пожалуйста, обратитесь к теме слияния элементов Вот .

Чтобы объединить два существующих компонентов

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мыши удерживайтена компоненте вы хотите объединить и бремяэто на компонент вы хотите, чтобы объединить его с. Убедитесь, что контур элемента назначения подсвечивается красным, показывая, что он выбран.

3. Выбрать Слияние | Заповедник назначения или Переписать назначенияиз меню.

Заметка

Заповедник назначенияОпция сохраняет значения свойств целевого компонента, если они существуют на компоненте исходящей, а также.

Переписать назначенияОпция перезаписывает свойства Размещение компонентов с любых общих свойств из компонента инициирующей.

Изменение подключения

Соединения, показанные на диаграмме всегдаотражать структуру, как определено в самой архитектуры. Инструменты рисования позволяет отделить соединения с компонентами, перемещать их, Кривая их, изменить маршрут их и вновь присоединить их к другим компонентам.

Чтобы отсоединить / присоединить соединение с / на компонент

1. Убедитесь, что у вас есть существующий схема открытой .

2. Нажмите и удерживайтена какой-либо связи.

3. Выбрать связь конец(т.е. Источник или раковины), Что вы хотели бы, чтобы отсоединить / присоединить. Примечание: концы подключения указаны с маленькими белыми кругами и парит над белым кругом на секунду вызовет '' подсказки, чтобы появиться с соответствующими роль имя(т.е. либо источник или раковина).

4. Бремясоединение конца, чтобы новое место (либо вакантное место или компонент) и отпустите кнопку мыши.

Заметка

Когда конец соединения находится над действительным компонента, контур компонента назначения подсвечивается с пунктирной линией. Цветовая схема используется указывает на эффект операции будет иметь на наличие ошибок и предупреждений с текущего проекта и описан в Определение и утверждение ограничений , После освобождения что конец гоe Соединение и компонент автоматически подключены(или прилагается), И это отражено в архитектурной модели.

Для перенаправить соединение

1. Убедитесь, что у вас есть существующий схема открытой .

2. Наведите указатель мыши на связи.

3. Держите сдвигКлюч вниз и Нажмитекнопку мыши, чтобы поместить опорную точку подключения. Выпустить сдвиг Ключ. Вы можете удалить узловую точку, делая ту же операцию.

4. Нажать и перетащитьточка привязки повторно маршрут соединения.

Наконечник

ИспользоватьAlt Ключ вместо сдвигКлюч для создания ортогональных соединений.

Для кривой или выпрямить связь

1. Убедитесь, что у вас есть существующий схема открытой .

2. Наведите указатель мыши на связи.

3. Щелкните правой кнопкой мышиTон соединения и в появившемся контекстном меню выберите Кривая, Ортогональный или Прямо.

Наконечник

Все соединенияданного типа на диаграмме может быть установлен в искривленном, ортогональных или прямой правой кнопкой мыши связанный линию типа на Вкладка Подключения из Трафарет окнои выбора кривой, ортогональным или прямой.

Для якорь на определенной точке на краю формы

1. Убедитесь, что у вас есть существующий схема открытой .

2. Выберите соединение.

3. Наведите указатель мыши на «белого точка" в конце связь.

4. Щелкните правой кнопкой мышиTон конец соединения и в появившемся контекстном меню выберите Якорь конечную точку формы.Перемещение торцевого соединения к месту желание на край формы.

ИЛИ

Держите CtrlКлюч вниз и cлизать и перетащите концевое соединение указать на расположение желание на край формы.

Заметка

Соединения привяжется к фактической перехвата их подключенного вместо формы ограничительной рамки этой формы.

Смотрите также

Инструменты рисования | Заполнение архитектуру | Анализ ваша архитектура


Инструмент для рисования Особенности

Навигация: Заполнение архитектуру> Использование чертежей>

Инструмент для рисования Особенности

Отправить комментарии на эту тему.

Инструменты рисования поддерживает ряд функций рисования.

Увеличение

Масштабы диаграммы можно изменить с помощью функции масштабирования.

Для уменьшения масштаба или «зум» в

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Нажмите Ctrlи '=' Ключ.

- или -

2. Выберите ПриблизитьКнопка на DiagramПанель инструментов.

- или -

2. Нажмите Ctrlи вращайте колесо мыши вперед, Примечание: В этом режиме полотно будет увеличить ту сторону, где располагается указатель мыши по холсту.

Для увеличения масштаба или «уменьшить»

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Нажмите Ctrlи "-" ключ.

- или -

2. Выберите УменьшитьКнопка на DiagramПанель инструментов.

- или -

2. Нажмите Ctrlи вращайте колесо мыши назад, Примечание: В этом режиме полотно будет увеличить наружу откуда указатель мыши по холсту.

Авто-макета

Компоновка компонентов в схеме может быть изменена автоматически.

Для макета все компоненты oн а схема

1. Cлизать Схема расположенияКнопка на панели инструментов Диаграмма.

2. Выбрать или Радиальная Планировка или Макет сетки.

Заметка

Макет Радиальная будет использовать то, что называется «силовую направленный 'алгоритм, который подключенные компоненты увязанных в то время как не связанные компоненты вынуждены друг от друга. Макет сетки будет использовать фиксированный ширина и высота межстрочного интервала алгоритма. Это, во-первых позволяет пользователю выбрать Общая схема Aspect Ratio (например, 16: 9, А4 (портрет), Письмо (Пейзаж)), а затем расстояние по бокам и между строк и столбцов, как показано ниже.С Grid Layout любые соединения между компонентами не влияет на расположение, как это просто организует компоненты по алфавиту (по имени) из верхней левой до правой нижней части холста. С обоих алгоритмов произвольных форм не переехал.

Для макета дети компоненты в одном родительском Oн а схема

1. Щелкните правой кнопкой мышикомпонент, чьи дети вы хотите автоматическом размещении высокого уровня.

2. Выбрать Макет Дети.

Заметка

По умолчанию используется только алгоритм Радиальная планировка.

Изменение элемента Эстетика как Цвет, Прозрачность, Тени и вращения

Все элементы имеют диаграмма эстетику, которые могут манипулировать, как требуется. В случае связанных форм, эти аспекты могут быть установлены от типаи в большинстве случаев также каждый экземпляр, В случае произвольных форм, эти свойства могут быть установлены каждый экземплярна холсте.

Заметка

Любое каждого экземпляра аспектов, которые были установлены для ассоциированных форм будет "перезаписаны", если же аспект изменяется для соответствующего типа.

Чтобы изменить цвет ассоциированного форме или свободной формы форму

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным формы или произвольной формы форма на холсте.

3. Выбрать Изменить цвет.

4. Выберите Исправлена ​​Цветрадио-кнопки (если применимо).

5. Выберите Basic Цвет или определить пользовательский цвет в диалоговом окне и нажмите ОК.

- или -

4. Выберите Градиентрадио-кнопки (если применимо).

5. Выберите либо по горизонтали, по вертикали, по диагонали вперед или назад по диагонали на направлении градиента в выпадающем меню и нажмите ОК.

6. Выберите Basic Цвет или определить пользовательский цвет в диалоговом окне для Начало а также Конеци нажмите ОК.

Заметка

ABACUS будет цвет переднего плана на форме, если;
а) это «простой» формы с одной основной графический элемент (например, круг, прямоугольник, многоугольник и т.д.), или
б) это «комплекс» форма с несколькими, лежащих в основе subshapes, которые все же цвет / градиент, как друг с другом или subshapes имеют LockScale = TRUE набор.
Если вышеуказанные условия не будут выполнены, то фон от формы окрашена.

Чтобы установить цвет ассоциированного форме в соответствии с имущества

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета(НЕ на холсте рисования).

3. Выбрать Изменить цвет.

4. Выберите Используя свойство переключатель.

5. Выберите свойство, нажав на кнопку '...' справа от текстового поля.

6. Выберите Ассортимент переключатель.

7. Настроить Минимальная а также Максимумзначения по желанию. Примечание: любое значение ниже минимального значения будет показано, как цвет мин и любое значение больше максимального будет показано, как Макс цвета. Кроме того, при использовании Boolean, список или даты / времени свойства значения преобразуются в индекс следующим образом Логический (False = 0, True = 1), Список (целое долина от 1 до п, для каждого действительного значения в порядке их возрастания, указанного в поле Units) и дата / время (количество дней с 1-го января 1900 года - в том числе десятичных знаков для часы, минуты, секунды части, - и если дата до 1990 это отрицательное число).

8. Выберите Basic Цвет или определить пользовательский цвет в диалоговом окне для Минимальная а также Максимуми нажмите ОК.

Наконечник

Если Зеленый (RGB - 128,255,0) выбрана в качестве цвета мин и Красный (RGB - 255,0,0) выбрана в качестве Макс цвета для свойства с диапазоном значений от 1для 4Затем значение 1будет отображаться как Зеленый, Значение 2 в виде Желтый, 3 в виде оранжевый а также 4 в виде Красный.

В качестве альтернативы, для имущества диапазоне 1для 3значение 1будет как Зеленый, Значение 2 в виде Янтарь а также 3 в виде Красныйака "Светофор" или статус тряпкой.

Для свойств диапазоне от 1 до 5, если Синий (RGB - 0,0,255) выбрана в качестве цвета мин и Красный (RGB - 255,0,0) выбран в качестве цвета Макс значение 1 будет как Синий, Значение 2, как Вода, А значение 3, как Зеленый, Значение 4 в Желтый и значение 5, как Красный.

Для свойств диапазоне от 1 до 6, если Фиолетовый (RGB - 255.0.255) выбрана в качестве цвета мин и Красный (RGB - 255,0,0) выбран в качестве цвета Макс значение 1 будет как Фиолетовый, Значение 2, как Синий, А значение 3, как Вода, Значение 4 в Зеленый, Значение 5, как Желтый а значение 6, как Красный.

И, наконец, на собственность диапазоне от 1 до 7 Значение 1 будет как Фиолетовый, Значение 2, как Темно-синий, А значение 3, как Светло-синий, Значение 4 в Цвет морской волны, Значение 5, как Зеленый, Значение 6, как Янтарь а значение 7, как Красный

Заметка

Смотрите примечание выше на переднем плане в сравнении с фоновой окраски.

- или -

7. Выберите Конкретное значение переключатель.

8. Нажмите Редактировать ЦветаКнопка.

9. Выберите каждое значение в свою очередь и нажмите Установите цветустановить определенный цвет для каждого значения.

Заметка

Диапазон значений для элементов, присутствующих на диаграмме будут предварительно заполняется.

10. Чтобы добавить какие-либо дополнительные цвета значения на те заранее (например, после диапазон недвижимости была изменена) щелчком мыши Добавить значение.

Чтобы изменить прозрачность цвета ассоциированного форме или свободной формы форму

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным формы или произвольной формы форма на холсте.

3. Выбрать Изменить цвет.

4. В панели Transparency установите верхний ползунок до нужной прозрачности для основного цвета.

5. Если градиент или Использование опций собственности используются в панели Transparency установите нижнюю ползунок в нужное прозрачности для второго цвета.

6. Нажмите ОК.

Показывать тени для Все связан формы в виде диаграммы

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем КомпонентыВкладка окна трафарета.

3. Выбрать Добавить Тени.

Для показать тень на форма компонент или произвольной формы форма

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Правильно-Щелкнитена компоненте или свободной формы формы на холсте.

3. Выбрать Добавить Тени.

Чтобы повернуть компонент формы и формы свободных форм в схемах

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Выберите форму компонент или свободной формы форму на холсте вы хотите повернуть.

3. Щелкните правой кнопкой мышиот формы и выберите Поворот, а затем выберите соответствующую угол вы хотите, чтобы повернуть форму по.

Изменения Элемент Аннотации и Freeform текста Этикетки

Все элементы диаграммы есть аннотации который можно манипулировать, как требуется. В случае связанных форм, эти аспекты могут быть установлены от типаи в большинстве случаев также каждый экземпляр, В случае произвольных форми разъемы, Тотекстовые метки может быть установлен каждый экземплярна холсте.Восемь (8) различных типов аннотаций может отображаться элементов диаграммы (т.е. имя, тип, значение недвижимости, Недвижимость Маркер, Присоединенные компоненты, дети (только для компонентов), стандарты и метки времени (создания, изменения и т.д. По)) в двадцать пять (25) разные позиции (например, Центр - Вне сверху, внутри слева - центр, Снаружи Направо - снаружи внизу).

Заметка

Любое каждого экземпляра аспектов, которые были установлены для ассоциированных форм будет "перезаписаны", если же аспект изменяется для соответствующего типа.Кроме того, если 2 или более аннотации занимают ту же позицию только один шрифт, стиль шрифта, цвет и размер шрифта могут быть использованы и сепаратор (например, запятая, пробел, новая линия) должен быть выбран.

Показывать имя или тип для соответствующего компонента или соединения

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным форма или разъем на холсте.

3. Выбрать Аннотации.

Заметка

Для индивидуального связаны форме или разъему на холсте вам нужно будет выбрать Перекрыть Stencil Аннотациифлажок в первый раз.

4. Выберите новую аннотацию в панели инструментов и выберите имя или Тип.

5. В появившемся диалоговом окне выберите параметры отображения, которые в том числе желаемых скобках и стиль шрифта, шрифт, цвет и размер шрифта. Кроме того, выбрать параметры макета, которые желаемых включая горизонтальное и вертикальное выравнивание (т.е. положение аннотации) и угол (т.е. вращения). Выбрать ОК.

Чтобы показать свойство стоимость для соответствующего компонента или соединения

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным форма или разъем на холсте.

3. Выбрать Аннотации.

Заметка

Для индивидуального связаны форме или разъему на холсте вам нужно будет выбрать Перекрыть Stencil Аннотациифлажок в первый раз.

4. Выберите новую аннотацию в панели инструментов и выберите Стоимость имущества.

5. В появившемся диалоговом окне выберите свойство, нажав кнопку недвижимости: '...' и выбрать недвижимость в диалоге Выберите свойствои выберите ОК. Выберите параметры отображения, которые в том числе желаемых скобках и стиль шрифта, шрифт, цвет и размер шрифта. Кроме того, выбрать параметры макета, которые желаемых включая горизонтальное и вертикальное выравнивание (т.е. положение аннотации) и угол (т.е. вращения). Выбрать ОК.

Чтобы показать свойство маркер для соответствующего компонента или соединения

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным форма или разъем на холсте.

3. Выбрать Аннотации.

Заметка

Для индивидуального связаны форме или разъему на холсте вам нужно будет выбрать Перекрыть Stencil Аннотациифлажок в первый раз.

4. Выберите новую аннотацию в панели инструментов и выберите Недвижимость Маркер.

5. В появившемся диалоговом окне выберите свойство, нажав кнопку недвижимости: '...' и выбрать недвижимость в диалоге Выберите свойствои выберите ОК. Установите радиус маркера в пикселях и метод окраски в любой цветовой по диапазону или Цвет имуществом и установить назначений цвета. Кроме того, выбрать параметры макета, которые желаемых включая горизонтальное и вертикальное выравнивание (т.е. положение аннотации) и угол (т.е. вращения). Выбрать ОК.

Показывать прикрепленные компоненты для соответствующего компонента или соединения

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным форма или разъем на холсте.

3. Выбрать Аннотации.

Заметка

Для индивидуального связаны форме или разъему на холсте вам нужно будет выбрать Перекрыть Stencil Аннотациифлажок в первый раз.

4. Выберите новую аннотацию в панели инструментов и выберите Прикрепленные компоненты.

5. В появившемся диалоговом окне, для связанных с ними компоненты, выберите прилагаемый тип компонента, нажав на кнопку Attached: '...' и выбрать тип компонента в диалоговом окне Установить компонент типаи выберите ОК. Выберите установленный тип соединения, нажав на подключенных через: '...' кнопку и выбрать тип соединения в диалоговом окне Установить тип соединенияи выберите ОК.Для связанных соединений выберите соединение конец выбрав источников или поглотителей из торцевого соединения: выпадающее меню. Для обоих связанные компоненты и соединения выберите параметры отображения, которые в том числе желаемых скобках и стиль шрифта, шрифт, цвет и размер шрифта. Кроме того, выбрать параметры макета, которые желаемых включая горизонтальное и вертикальное выравнивание (т.е. положение аннотации) и угол (т.е. вращения). Выбрать ОК.

Показывать дети для соответствующего компонента

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем КомпонентыВкладка окна трафарета или ассоциированным форма на холсте.

3. Выбрать Аннотации.

Заметка

Для отдельного связанного формы на холсте вам нужно будет выбрать Перекрыть Stencil Аннотациифлажок в первый раз.

4. Выберите новую аннотацию в панели инструментов и выберите Дети.

5. В появившемся диалоговом окне выберите параметры отображения, которые в том числе желаемых скобках и стиль шрифта, шрифт, цвет и размер шрифта. Кроме того, выбрать параметры макета, которые желаемых включая горизонтальное и вертикальное выравнивание (т.е. положение аннотации) и угол (т.е. вращения). Выбрать ОК.

Показывать стандарты для соответствующего компонента или соединения

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным форма или разъем на холсте.

3. Выбрать Аннотации.

Заметка

Для индивидуального связаны форме или разъему на холсте вам нужно будет выбрать Перекрыть Stencil Аннотациифлажок в первый раз.

4. Выберите новую аннотацию в панели инструментов и выберите Стандарты.

5. В появившемся диалоговом окне выберите параметры отображения, которые в том числе желаемых скобках и стиль шрифта, шрифт, цвет и размер шрифта. Кроме того, выбрать параметры макета, которые желаемых включая горизонтальное и вертикальное выравнивание (т.е. положение аннотации) и угол (т.е. вращения). Выбрать ОК.

Показывать временные метки для соответствующего компонента или соединения

1. Убедитесь, что у вас есть существующий схема открытой .

2. Щелкните правой кнопкой мышив ассоциированной форме или в разъем Компоненты или СвязиВкладка окна трафарета или ассоциированным форма или разъем на холсте.

3. Выбрать Аннотации.

Заметка

Для индивидуального связаны форме или разъему на холсте вам нужно будет выбрать Перекрыть Stencil Аннотациифлажок в первый раз.

4. Выберите новую аннотацию в панели инструментов и выберите Созданный, Создано, Разработано Маркер, модифицированный, модифицированный или модифицированный Маркер.

5. В появившемся диалоговом окне, если не маркером, выбрать параметры отображения, которые в том числе желаемых скобках и стиль шрифта, шрифт, цвет и размер шрифта. Если маркер, установите радиус маркера в пикселях и метод окраски в любой цветовой по диапазону или Цвет имуществом и установить назначений цвета. Кроме того, выбрать параметры макета, которые желаемых включая горизонтальное и вертикальное выравнивание (т.е. положение аннотации) и угол (т.е. вращения). Выбрать ОК.

Чтобы изменить стиль шрифта свободной формы формыили разъем

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Щелкните правой кнопкой мышина свободной формы формы или разъем на холсте. Примечание: Если соединитель Текст этикетки не показать то, чтобы показать соединенияили Текст этикетки: Щелкните правой кнопкой мышиПодключитьилии выберите Аннотация | Показать Аннотация.

3. Выбрать Смена шрифта.

4. Выберите стиль шрифта, шрифт и размер в диалоговом окне и выберите ОК.

Чтобы изменить шрифт цвет из свободной формы формыили разъем

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Щелкните правой кнопкой мышина свободной формы формы или разъем на холсте. Примечание: Если соединитель Текст этикетки не показать то, чтобы показать соединенияили Текст этикетки: Щелкните правой кнопкой мышиПодключитьилии выберите Аннотация | Показать Аннотация.

3. Выбрать + Изменить Шрифт Цвет.

4. Выберите шрифтЦвет (а для форм ЦВЕТ Ссылка), нажав кнопку '...' и выберите цвет В диалоговом окне выберите и ОК.

5. Выберите прозрачности текстовой метки помощью ползунка с 0 полностью прозрачный, а 255 является полностью непрозрачным.

Чтобы повернуть текст ярлык свободной формы формыили разъем

1. Убедитесь, что у вас есть новые или существующие схема открытой .

2. Щелкните правой кнопкой мышина свободной формы формы или разъем на холсте. Примечание: Если соединитель Текст этикетки не показать то, чтобы показать соединенияили Текст этикетки: Щелкните правой кнопкой мышиПодключитьилии выберите Аннотация | Показать Аннотация.

3. Выбрать Поворот, а затем выберите соответствующую угол вы хотите, чтобы повернуть Текст этикетки от.

Смотрите также

Инструменты рисования | Заполнение архитектуру | Анализ ваша архитектура


Использование ссылки на диаграммах

Навигация: Заполнение архитектуру> Использование чертежей>

Использование ссылки на диаграммах

Отправить комментарии на эту тему.

Формы (свободной форме и компоненты) и разъемы (свободной форме или соединения) в диаграммах могут быть связаны с существующими архитектурными представлений в счетах, а также внешних файлов / папок и URL-адресов. Эти ссылки, то можно управлять (создания, изменения и удалять) с помощью набора инструментов ABACUS. Эта функция может быть использована для повышения навигации и общее понимание вашей архитектуры схематично.

Чтобы добавить ссылки на диаграмме

1. Убедитесь, что у вас есть существующий схема открытой .

2. Выберите соответствующую форму или разъем от диаграмму.

3. Щелкните правой кнопкой мышиот формыили разъем.

4. Выбрать Открывать ссылкии СвязиПоявится окно.

5. Нажать на Добавитьиконка и Новый СсылкаПоявится окно.

6. Выберите соответствующий Каталог | Матрица | Схема| 3D View| Диаграммарадио-кнопки, а затем выберите соответствующий Каталог, матрица, схема, 3Dили диаграммы вид в текущей архитектуры от Ссылка к выпадающее меню.

- или -

6. Выберите Веб-сайтрадио-кнопки, а затем ввести соответствующий URL (например HTTP: //www.avolutionпрограммного обеспечения.com /)в поле ссылку на веб-странице. Допустимые URL-адреса должны начать с одного из 5струны; HTTP: //, HTTPS: //, FTP: //, файл: или \\, Пробелы должны быть введены с '% 20'.

- или -

6. Выберите Абсолютная файла | Относительная файла переключательс,затем щелкните на '..."Кнопку, чтобы просмотреть внешнего файла ссылаются на диаграмме.

7. Нажмите ОКи новая ссылка будет отображаться в окне Ссылки. Примечание: Окно Ссылки могут быть изменены, чтобы увидеть полное имя, если это необходимо.

8. Повторите шаги 5-7создать несколько ссылок.

9. Чтобы следовать созданный ссылку, выберите соответствующую ссылку на отображаемый в Связиокна и нажмите Открыть ссылку.

Заметка

когда несколько аннотации показывается для Форма или разъем ссылка показано на первом аннотации в список аннотаций в диалоговом окне Редактировать аннотации.

Чтобы следовать ссылки из диаграмме

1. Убедитесь, что у вас есть существующий схема открытой .

2. Выберите соответствующую форму или разъем от диаграмму.

3. Нажмитена соответствующей гиперссылке (синий подчеркнутый имя компонента) на форме или разъем на диаграмме, чтобы открыть и просмотреть первую ссылку из формыили разъем.Примечание: Курсор должен измениться на '' стороны, когда ссылка готов быть нажата.

- или -

3. Выберите соответствующую форму или разъем от диаграмме.

4. Щелкните правой кнопкой мышиот формыили разъем.

5. Выбрать Открывать ссылкии СвязиПоявится окно.

6. Выберите на соответствующую ссылку, что вы хотели бы смотреть.

7. Нажать на Открыть ссылкукнопку, чтобы открыть и просмотреть на соответствующую ссылку.

Чтобы удалить ссылки на диаграмме

1. Убедитесь, что у вас есть существующий схема открытой .

2. Выберите соответствующую формуили разъемот диаграмме.

3. Щелкните правой кнопкой мышиот формыили разъем.

4. Выбрать Открывать ссылкии СвязиПоявится окно.

5. Выберите на соответствующую ссылку, которая должна быть удалена.

6. Нажать на УдалитьКнопка. и ссылка удаляется из Связи окно.

Организационные звенья в диаграмме

Вы можете выбрать, какие связаны схему, внешний файл или отображается веб-страницы, когда этикетка форма Ctrl + нажал на диаграмме.

1. Убедитесь, что у вас есть существующий схема открытой .

2. Выберите соответствующую форму или разъем от диаграмме.

3. Щелкните правой кнопкой мышиот формыили разъем.

4. Выбрать Открывать ссылкии СвязиПоявится окно.

5. Чтобы изменить порядок ссылок нажмите на Вверх | Внизкнопки на правой стороне Связи окно.

6. Первая ссылка, которая появляется на левой стороне СвязиОкно ссылка, которая отображается при Нажмите Ctrl +гиперссылками форма или разъем имя.

Смотрите также

Заполнение архитектуру | Заполнение архитектуру вручную | Анализ ваша архитектура


Диаграмма Точки зрения

Навигация: Заполнение архитектуру> Использование чертежей>

Диаграмма Точки зрения

Отправить комментарии на эту тему.

Чте точки зренияфункция гарантирует, что компоненты и соединения, которые добавляются к диаграмме должны быть ассоциации типа определено ранее, прежде чем они могут быть добавлены к диаграмме. Эта функция позволяет ограничения типов диаграмм, которые могут быть сделаны путем ограничения формы & разъемы, связанные с компонентами и Связисуществующих в вашей архитектуре.

Включение или отключение, исполняющих схему точки зрения

Возможность применять Диаграмма точки зрения автоматически включена по умолчанию. Чтобы отключить / включить эту функцию, нажмите на Инструменты | Опции...| Схемазакладка, и снимите / выбрать Обеспечение диаграмма Точки зренияфлажок соответственно.

Заметка

Если вы не видите "Обеспечение диаграмма Точки зрения"Вариант на вкладке Диаграмма, то вы не должны Дизайнер дополнений и опция по умолчанию.

Создание правовой санкцией схему смотровая площадка

1. Убедитесь, у вас есть ABACUS файл открыт с исследовательВид отображается.

2. По мнению исследователя правой кнопкой мыши на Посмотретьточкаsи нажмите на Создайте Схема Точка зрения

3. Схема Точка зренияОткроется окно.

4. Назначьте соответствующую имени в схема точка зренияи обратите внимание, что смотровая площадка сохраняется под Точки зренияраздел Explorer.

5. Схема Точка зренияОткроется окно.

6. Теперь нажмите и перетащите соответствующие типы компонентов и типов подключения в ваших архитектур на точка зрения формы вы хотите. Комплектующие типыдолжны быть втянуты на аформа в формызакладка, в то время как Типы подключениядолжны быть перетащить один из форм стиля линии 5 в разъемыВкладка.

7. Чтобы сохранить схема точка зренияВы создали Кликните на [image] в правом верхнем углу вашего Схема Точка зрения окно.

Заметка

схема точка зрениямогут быть отредактированы, щелкнув правой кнопкой на смотровая площадка и выбора открыто или двойной щелчок смотровая площадка.

Synchonising обновленный точку зрения с диаграммами

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Либо щелкните правой кнопкой мыши точку зрения в Исследователь Окно под Мета-модель | Точки зренияи выберите Синхронизация Диаграмма Отображения ...

- или -

3. Закрыть открытый и обновляется точка зрения окна и выберите да в Синхронизация с Точка зрениядиалог, который отображается.

4. Точка зрения синхронизациипоявится диалоговое окно, как показано ниже.

Флажки

· Добавить отсутствующих Сопоставление- Любая новая форма (с типом компонента) или разъем (для типа соединения) объединений, которые были добавлены чтобы точки зрениябудут добавлены к соответствующая диаграммас (т.е. ихтрафаретс) что связаны с точки зрения.

· Обновление существующихОтображения- Любые обновленные аспекты существующей форме (в типа компонента) или разъем (для подключения) типа ассоциации для точка зрения(например, цвет, шрифт) будет обновляться в соответствующая диаграммас (т.е. ихтрафаретс) что связаны с точки зрения.

· Удалить экстраОтображения- Любая дополнительная форма (для типа компонента) или разъем (для типа соединения) объединений, которые были добавлены в диаграммы (т.е. их трафареты), но не в смотровая площадкабудут удалены из соответствующая диаграммас (т.е. ихтрафаретс) что связаны с точки зрения.

· Локальные настройки для добавлены или обновлены отображений (разница только)- Любые обновленные аспекты существующей форме (в типа компонента) или разъем (для подключения) типа ассоциации для точка зрения(например, цвет, шрифт) будет применяться к соответствующим элементам на диаграммах, которые связаны с точки зрения.Только применяются обновленные «различия», внесенные в точки зрения таким образом, любые существующие локальные настройки в схеме, которые не были обновлены в точки зрения останется неизменной.

· [image] Аннотации – Как и выше, но специально для аннотаций.

Смотрите также

Инструменты рисования | Заполнение архитектуру | Анализ ваша архитектура


Заполнение используя каталоги

Навигация: Заполнение архитектуру>

Заполнение используя каталоги

Отправить комментарии на эту тему.

A каталог позволяет просматривать и редактировать компоненты или соединения и их свойства в простом табличном образом.

Для создать новый каталог просмотра в СЧЕТЫ

Заметка

В то время как все пользователи архитектор может создать новые каталоги, чтобы сохранить изменения в настройках существующего КАТАЛОГ годов Пользовательская лицензия нужна Designer добавить-на возможности. Это «защитить» конфигурацию существующих каталогов, которые могут быть общими для многих пользователей. Тем не менее, архитектор использует без Designer добавить-на по-прежнему можно выбрать "Сохранить как" новых настроек в новом каталоге. И, конечно, все лицензии пользователь может выбрать «Сбросить» каких-либо изменений в существующей Каталоге. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется Дизайнер добавить-на Возможность. И помните, что это только настройки каталога, все изменения, внесенные данным в Каталоге сразу же применяются в хранилище, независимо.

1. Выберите Insert | Каталог.

2. в <Архитектура>потяните вниз выберите Архитектура, который содержит компоненты илисоединения вы хотите посмотреть.

3. в <Элемент Тип>потяните вниз выберите компонент или тип подключения что вы хотите, чтобы иметь случаи перечислены в "Строки' в каталоге.

4. каталог будут заполнены сстрока для каждого экземпляра выбранного компонента или подключение типа.

Заметка

По умолчанию самая левая Иерархия Путьколонка (т.е. иерархии родительских компонентов или соединений выше выделенных случаях) и 2 имя Колонка (т.е. список выбранных экземпляров компонентов или соединение) замораживают в левой части каталога. Чтобы изменить столбец замораживание перетащите разделитель столбцов справа столбце Name. Ты можешь Изменение порядкастолбцы просто перетаскиванием их заголовков столбцов. Клетки колонн с синей подчеркиванием являются гиперссылки с другими элементами в проекте и гиперссылок может сопровождаться удерживая Ctrl и щелкая ссылки. Колонки могут быть скрытый щелкнув правой кнопкой мыши на заголовке столбца и выбрав столбец | Скрыть столбец. Скрытые столбцы могут быть нескрываемым нажав кнопку на панели инструментов Колонны Настройка и использование диалоговое окно, показанное ниже Настроить столбцы или выбрав стрелку вниз часть кнопки панели инструментов Колонны Настройка и индивидуально подбирая скрытый столбец (ы) либо из Генеральный Свойства или Вложения коллекции. Строки могут быть сгруппированы их значений столбцов, перетаскивая заголовок столбца в строке синего группировки в верхней части каталога. В любое время вы можете дважды щелкнуть на Селектор Каталог ряд а также перейти ксоответствующая компонентаили соединениев окне Проводника.Значения ячеек недвижимости являются полужирным где они отличаются от значений по умолчанию, и выделенный курсивом где они доступны только для чтения. Timestamp, собственности и Присоединенные колонки компонента может быть цветной в соответствии со значениями клеток или стоимости имущества прикрепленным компонента щелкнув правой кнопкой мыши на заголовке столбца и выбрав столбец | Изменить цвет ... и то по Цвет Timestamp или опции Цвет По имуществом, однако, только Список, целое, десятичной, логическое или Дата / Время Свойства типа данных будет цвет. Значения свойств для Attached столбцов компонента может быть показано щелкнув правой кнопкой мыши на заголовке столбца и выбрав столбец | Показать объекты ... а затем параметр Показать объекты. И, наконец, где есть Обязательные ограничения установить для столбца собственности они могут быть показаны с <Требуемый>строка (вместе с окраски в соответствии с их уровнем органов), щелкнув правой кнопкой на заголовке столбца и выбрав столбец | Показать <Требуемый>.

Каталог

Для добавить / шоу столбцы a Каталог вид в ABACUS

1. Убедитесь, что у вас есть Каталог вид открытый.

2. Скрытые столбцы могут быть индивидуально нескрываемым, нажав Стрелка на правой части панели инструментов Столбцы Настройка кнопкии выбрав скрытый столбец либо из Генеральная, Свойства или Вложения коллекции.

Заметка

Галочка будет показано рядом с отображаемой в данный момент столбцов для каталога.Кроме того, только некоторые приложения будут доступны под Вложения раздел в соответствии с ограничения которые определены в проекте. В частности, для прикрепления быть доступны для показа в компоненте каталог тип компонента для каталога должны быть указаны как источник или раковина (не "любой") из "связи должны быть присоединены" ограничение для связи тип, и должен быть, по крайней мере один тип компонент определяется как источника или раковина (НЕ 'Любые "), с другой" конец "того же типа подключения.

- ИЛИ -

2. Несколько столбцов может быть нескрываемым (или заказать или фиксированная), нажав Настройка панели инструментов Столбцы кнопкуи использование Настроить столбцы диалоговое окно, показанное ниже.

Заметка

В отображаемые колонки показаны в панели справа с доступных столбцов, показанных на панели слева. Доступные столбцы могут быть отфильтрованы в соответствии с Выберите Доступные столбцыпотяните вниз, и они могут быть добавлены, выбирая их в панели слева и нажав Добавить Кнопка между ними двумя панелями.

Настройка диалогового окна Столбцы

Для удалить / скрыть столбцы из Каталог вид в ABACUS

1. Убедитесь, что у вас есть Каталог вид открытый.

2. Щелкните правой кнопкой мыши заголовок столбца для столбца, который требуется удалить / скрыть, и выберите Колонка | Скрыть столбец.

- ИЛИ -

2. Несколько столбцов могут быть скрыты (или заказать или фиксированная), нажав Настройка панели инструментов Столбцы кнопкуи использование Настроить столбцы диалоговое окно, показанное выше.

Заметка

В отображаемые колонки показаны в панели справа с доступных столбцов, показанных на панели слева. В отображаемые колонки могут быть скрыты путем выбора столбца в панели справа и нажав Удалить Кнопка между ними двумя панелями.

Для заполнения с помощью Каталог вид в ABACUS

1. Для добавить компонент или подключениевыбранного типа для Каталог (и проект) щелкните Добавить компонент / Добавить кнопку на панели инструментов Подключение. Строка должна появляются и компонент или соединение будет создано на верхнем уровне Компоненты или Соединения коллекция для выбранного архитектуры.

Заметка

Новые компоненты и соединения добавляются по умолчанию на высшем уровне компонентов или подключений коллекции выбранного архитектуры. Чтобы изменить родителя новых компонентов или соединений щелкните правой кнопкой мыши ячейку иерархии Path для нового компонента или соединения ряда и выберите Изменить Родитель ...и выберите нужный родителя (принимая к сведению ограничение подсветка ).

Заметка

Новые строки / элементы добавляют непосредственно в каталог с помощью "Добавить новую" кнопки, вставлять в каталоге, или созданы с помощью импорта в каталоге с MS Excel, освобождаются от фильтрации до тех пор, каталог не будет закрыт. Это позволит любую необходимую редактирование значений столбцов, которые не могут удовлетворить текущие критерии фильтрации каталога. Эти новые строки элементов обозначены символ '+' в клетке селектора строки в начале строки, которая окрашена зеленый если элемент в настоящее время встречается сохраненные критерии фильтрации каталога (т.е. останется на каталог, если вновь открыт), и красный если это не так.

2. Для удалить компонент или подключениевыбранного типа из Каталог (и проект) выберите строку, и нажмите клавишу Del ключ или щелкните правой кнопкой мыши селектор строки и выберите Удалить из архитектуры, ряд должен исчезнуть из каталога и это будут удалены из проекта.

Для фильтр используя Каталог вид в ABACUS

1. Убедитесь, что у вас есть Каталог вид открытый.

2. Если строка фильтра не показывается в верхней части каталога, то нажмите на Показать фильтр заголовок строкиПанель инструментов кнопку.

3. В колонке вы хотели бы добавить фильтр, дважды щелкните фильтр строк ячейку, где он показывает "(Все)".

4. Для Отметка, Иерархия путь, имя или Описаниеобщие столбцы или Текст, Целое, десятичной, логическое или Дата / времястолбцы щелкните на кнопку ..., который отображается в правой части строки фильтра ячейки и введите значения ячеек, которые должны быть включены в каталог.

Заметка

Соответствие выполняется, как если бы '*' подстановочные автоматически применяются до и после любых строковых значений таким образом, чтобы ввод 'кошка' (без кавычек) будет включать в себя строки с 'BobКот','Котженщина "или" примеКотионный "и т.д. Несколько / 'или' значения могут быть введены в новых линий с использованием Ctrl + Enter, Для целой и дробной столбцов собственности »и« логика может быть включена с помощью "&"(Без кавычек) и больше / меньше и т.д. логики может быть включена с помощью"> =','>','<' а также '<="(Без кавычек), например, '> = 50000 & <90000 ». Номера чистые ценные строки могут быть включены, введя '(Не Заготовки)"(Без кавычек) и пустой строки стоимостью, могут быть включены путем ввода '(Бланки)"(Без кавычек).И, наконец, все фильтры по умолчанию случае нечувствительной так "кошка" (без кавычек) будет включать в себя строки с "кошкой", "Кошка" или "САТ" и т.д. Для Соответствие чувствительно, введите "(Случай)"(Без кавычек) перед строкой, например "(Дело) Кошка" (без кавычек) будет включать в себя только строки с 'кот' в них.

5. Для Вложенияколонны, Стандарты колонки или Список столбцы щелкните на кнопку со стрелкой вниз, которая появляется в правой части строки фильтра ячейки и выберите значения ячеек из флажков, которые должны быть включены в каталог.

Заметка

Футов (Выбрать все) Флажок позволит все остальные флажки, в том числе эффект всех доступных строк. Футов (Non-Бланки) Флажок будет включать в себя любое не пустое сумму строк. Футов (Бланки) Флажок будет включать в себя все пустые строки ценится. И, наконец, сняв какие-либо конкретные ценится флажки автоматически снять выделение '(выбрать все)' и '(не пробелами)' для галочки консистенции.

6. Нажмите ОК чтобы применить фильтр.

Для отключить / включить фильтрацию по a Каталог вид в ABACUS

1. Убедитесь, что у вас есть Каталог вид открытый с фильтр прикладная.

2. Установите флажок слева от строки фильтра.

Для удалить фильтр из a Каталог вид в ABACUS

1. Убедитесь, что у вас есть Каталог вид открытый с фильтр прикладная.

2. Чтобы удалить отдельные фильтр столбца щелкните правой кнопкой мыши заголовок столбца и выберите Колонка | Ясно Фильтрация.

3. Чтобы удалить все фильтры нажмите Опции Панель инструментов кнопку и выберите Очистить фильтр Настройки.

Сохранить / сохранить как aКаталог вид

Заметка

В то время как все пользователи архитектор может создать новые каталоги, чтобы сохранить изменения в настройках существующего КАТАЛОГ годов Пользовательская лицензия нужна Designer добавить-на возможности. Это «защитить» конфигурацию существующих каталогов, которые могут быть общими для многих пользователей. Тем не менее, архитектор использует без Designer добавить-на по-прежнему можно выбрать "Сохранить как" новых настроек в новом каталоге. И, конечно, все лицензии пользователь может выбрать «Сбросить» каких-либо изменений в существующей Каталоге. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется Дизайнер добавить-на Возможность.И помните, что это только настройки каталога, все изменения, внесенные данным в Каталоге сразу же применяются в хранилище, независимо.

1. Убедитесь, что у вас есть новый или существующий вид Каталог открытыйи вы сделали необходимые изменения.

2. в Каталог видПанель инструментов нажмите на Сохранитькнопку, чтобы сохранить Каталог вид и любые изменения форматирования.

Заметка

Если вы не имеете кнопку Сохранить на панели инструментов просмотра каталога, то вы не должны Дизайнер добавить-на, и вы только в состоянии Сохранить каклюбые настройки меняется на новый каталог, когда вы идете, чтобы закрыть существующий каталог.

3. Если Каталог ИмяПоявится диалоговое (из-за того новый каталог) введите имя для каталог и нажмите ОК.

Для экспорт в MS Excel каталог

1. Убедитесь, что у вас есть Каталог вид открытый.

2. Нажмите Экспорт в Excel таблицу КаталогПанель инструментов кнопку.

3. Выберите имя файла для сохранения каталог MS Excel как. Нажмите Сохранить.

Заметка

По умолчанию имя файла экспортируемого каталоге MS Excel будет имя каталога прибавляется к имени архитектуры в скобках, например, "Проекты (2014 Фактический) .xlsx. Вы можете изменить любое из этого, в том числе ли формат файла должен быть .xlsx или .xls. Название Архитектура включен, чтобы напомнить пользователю, что каждый каталог имеет конкретное содержание (т.е. идентификаторы в колонке А и строки 1), чтобы позволить ему быть круглым споткнулся назад при помощи Импорт из каталога MS Excel в соответствии ниже.

Заметка

По умолчанию скрытые Колонка A в экспортируемой каталог MS Excel содержит уникальный идентификатор для каждого из элементов в хранилище ABACUS. Это позволяет какие-либо изменения, которые сделаны в MS Excel, чтобы быть "подобран" к существующим элементам внутри ABACUS на импорт (см. Ниже) Тем не менее, использование этого уникального ID для 'совпадают "строк может быть изменено с Внешний | Я БЫнедвижимость на элементе. То есть, если элемент имеет внешнюю | ID собственности и входит в каталог экспорта, то значения внешнего | ID столбец будет использоваться, чтобы совпасть строк на импорт (см ниже) и уникальные значения ID в скрытом столбце А будут игнорироваться (и даже может быть пустым). Скрытая колонка А сама должна оставаться, однако, в частности, значение в ячейке А1. Кроме того, при добавлении внешних идентификаторов к существующей коллекции ABACUS элемента мы рекомендуем добавить их в качестве различных форм собственности во-первых, например, Внешний | Темп, а затем переименовать свойство внешних | Я БЫ. В противном случае будут добавлены дублирующие элементы.

Каталог форматированиеэкспортируется по умолчанию, однако, для больших каталогов это может привести к экспорт будучи весьма медленно. Соответственно, в Инструменты | Опции... Затем на Каталогзакладка,Вы можете уменьшить количество форматирования, которые экспортируются, как показано на вкладке Каталог ниже, тем самым ускоряя экспорт.

Каталог экспорт опции

4. Отображается диалоговое Экспорт завершен. Нажмите ОК.

Экспорт в MS Excel каталог

Для импорт из каталога MS Excel

Заметка

По умолчанию скрытые Колонка A в экспортируемой каталог MS Excel (см выше) содержит уникальный идентификатор для каждого из элементов в хранилище ABACUS. Это позволяет какие-либо изменения, которые сделаны в MS Excel, чтобы быть "подобран" к существующим элементам внутри ABACUS на импорт. Тем не менее, использование этого уникального ID для 'совпадают "строк может быть изменено с Внешний | Я БЫнедвижимость на элементе. То есть, если элемент имеет внешнюю | ID собственности и входит в каталог экспорта (смотрите выше), то значения внешнего | ID столбец будет использоваться, чтобы совпасть строк на ввоз и уникальные значения ID в скрытой колонке А будут игнорироваться (и даже может быть пустым). Скрытая колонка А сама должна оставаться, однако, в частности, значение в ячейке А1. Кроме того, при добавлении внешних идентификаторов к существующей коллекции ABACUS элемента мы рекомендуем добавить их в качестве различных форм собственности во-первых, например, Внешний | Темп, а затем переименовать свойство внешних | Я БЫ. В противном случае будут добавлены дублирующие элементы.

1. Убедитесь, что у вас есть Каталог вид открытый.

2. Нажмите Импорт из Excel таблицы КаталогПанель инструментов кнопку.

3. Выберите имя файла для импорта каталог MS Excel с. Нажмите открыто.

4. Новые ошибки, обнаруженные и / или новые ошибки / предупреждения Обнаружено диалоги могут появиться для любого нового контента (т.е. строки в MS Excel), который был добавлен. Принять к сведению из ошибок / предупреждений и нажмите ОК.

5. Отображается диалоговое Импорт завершен, и он может показывать предупреждения в связи с импортом (см примечания ниже). Нажмите ОК.

Заметка

При заданных стандартов или подключенных колонок компонентов, новые записи через каталог MS Excel должен соответствовать точно имя существующего стандарта или компонента правильного типа для присвоения или связи, которые будут добавлены. Первый матч назвал будет использоваться, и любые несогласованные данные будут генерировать предупреждения согласно ниже. Кроме того, в то время как предупреждения приведены на реимпорта, элементы не удаляютсяот ABACUS, если они не присутствуют в каталоге MS Excel. Это потому, что нет никакого способа, которым ABACUS может знать, существует ли назначен Стандартный или прикреплены составляющая в проекте ABACUS, но не существуют в каталоге MS Excel, потому что она была удалена из каталога MS Excel или был добавлен к ABACUS Проект так каталоге было экспортировано. Соответственно, если пользователи хотят, чтобы легко "обнаружить", который соединения были добавлены в процессе импорта, они могут просто создать нужное свойство от типа соединения и установить его по умолчанию пустой, так что они будут предупреждены о любых новых подключений каждый раз при импортных выполнен.

Заметка

При импорте каталог MS Excel различные предупреждения могут быть отображены. Во-первых, если был добавлен новый столбец в Excel, что не соответствует "синтаксис" для свойства или прикрепленной компонента столбец будет игнорироваться. Далее, линия за линией предупреждения будут отображаться для всех вопросов с данными о каждом ряду каталоге Excel. Эти предупреждения начинается с номера строки в квадратных скобках, и если отношение заголовком столбца (т.е. "[23], Дж ..." для строки 23, колонка J) и может относиться к удаленных элементов, несогласованных стандартов или подключенных компонентов имен (который игнорируются, как в записке выше) или недействительным или пустым ID относящиеся к новой строке / элемента (который будет добавлен). Для подробной статьи о заполнении счеты с использованием Excel каталоги, пожалуйста, обратитесь к Avolution сообщество или учебный курс Менеджер портфолио.

Заметка

Новые компоненты и соединения добавляются по умолчанию на высшем уровне компонентов или подключений коллекции выбранного архитектуры. Чтобы изменить родителя новых компонентов или соединений щелкните правой кнопкой мыши ячейку иерархии Path для нового компонента или соединения ряда и выберите Изменить Родитель ...и выберите нужный родителя (принимая к сведению ограничение подсветка ).

Заметка

Элементы добавляют непосредственно в каталог с помощью "Добавить новую" кнопки, вставлять в каталоге, или созданы с помощью импорта в каталоге с MS Excel, освобождаются от фильтрации до тех пор, каталог не будет закрыт. Это позволит любую необходимую редактирование значений столбцов, которые не могут удовлетворить текущие критерии фильтрации каталога. Эти новые строки элементов обозначены символ '+' в клетке селектора строки в начале строки, которая окрашена зеленый если элемент в настоящее время встречается сохраненные критерии фильтрации каталога (т.е. останется на каталог, если вновь открыт), и красный если это не так.

Для сравнить содержимое каталога с другой архитектуре

1. Пожалуйста, обратитесь к разделу Вот .

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Заполнение архитектуру от Visio | Заполнение архитектуру с Excel


Заполнение с помощью матриц

Навигация: Заполнение архитектуру>

Заполнение с помощью матриц

Отправить комментарии на эту тему.

Матрица позволяет просматривать и редактировать 'непосредственный' соединения между компонентами в простой табличной образоми также просмотреть '' косвенный путь между компонентами в соответствии с любыми промежуточных компонентов (и соединений).

Для Создайте вид Матрица в ABACUS

Заметка

В то время как все пользователи архитектор может создать Матрицы для их сохранения и / или их параметров по Пользовательская лицензия нужна Designer добавить-на возможности. Это «защитить» конфигурацию существующих матриц, которые могут быть общими для многих пользователей. Тем не менее, архитектор использует без Designer добавить-на по-прежнему можно выбрать "Сохранить как" новых настроек в новую матрицу. И, конечно, все лицензии пользователь может выбрать «Сбросить» каких-либо изменений в существующей матрице. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

1. Выберите Insert | Матрица.

2. в <Аrchitecturе>потяните вниз выберите Архитектура, содержащий компоненты и соединения вы хотите, чтобы посмотреть.

3. в <ИсточникВведите>потяните вниз выберите тип компонента, который вы хотите, чтобы иметь экземпляры, перечисленные как "Строки' на левом флангематрицы.

4. в <РаковинаВведите>потяните вниз выберите тип компонента, который вы хотите, чтобы иметь экземпляры, перечисленные как "столбцы' в верхнейматрицы.

5. в <Путь Тип (ы)> тянуть вниз Есть по существу два '' режимы матрицы можно определить ...

Соединения "прямой" матрицы

6. Просто Sизбранный один (1) или более подключение типы на правой стороне меню, которое появляется, если Вы хотите видеть в "клетках" матрицы, если ап явноесвязь существует от Вертикальный/ 'ряд"Компонентом матрицы к Горизонтальный/ 'колонка"Компонентом матрицы.

Заметка

Только соединения с источником конец, прикрепленный к Вертикальный/ 'ряд"Компонент и раковина конец прикреплен к Горизонтальный/ 'колонка"Компонент будет показано. Переключите Источник а также Раковинакомпонент выбора типа для просмотра подключений в противоположном направлении.

7. Матрица будет заполнен с 'X' в клетках (или стоимости имущества - смотрите примечание ниже) если есть связь от Вертикальный/ 'ряд'компонентом матрицы к Горизонтальный/ 'колонка"Компонентом матрицы.

Заметка

Для больших матриц только максимум 100 строк или столбцов (в том числе разрушенных строк / столбцов) будет показано на время, как показано на 'R' и 'показателей C' в верхнем левом ячейки заголовка соответственно. Для просмотра дополнительных строк использовать полосы прокрутки. В любое время вы можете дважды щелкнуть на Вертикальный/ 'ряд' или Горизонталь / 'колонка' компонент Заголовки и перейти ксоответствующие компоненты в окне Проводника.Родители вертикали/ 'ряд' а также Горизонтальный/ 'колонка' компонентс также, возможно, как показано отправиться строк / столбцов с серым заголовком названия. После распада (по одной мыши заголовок клеток), если дети вложения существовала тогда в 'X', необязательно будет отображаться, если все дети были прикреплены или "O" будет необязательно показано, если только некоторые из детей были прикреплены. Клетки могут быть цветной в соответствии со значением имущества соединений, нажав Options '' шестерню в верхней правой части панели инструментов и выбрав матрицы Настройка цвета ... а потом кнопку Edit и выбрать цвет по Timestamp или Цвет По имуществом опции и выбрав свойство, диапазон значений Мин и Макс и выбор цвета, однако, только Список, целое, десятичной, логическое или Дата / Время Свойства типа данных будет цвет. Если рухнул ячейка будет закрашена по средней стоимости имущества из соединений. Вместо 'X', значения свойств клеток может быть показано нажав на Options '' шестерню в верхней правой части панели инструментов и выбрав матрицы Показать настройки Value ... а потом кнопку Edit и выбрав опцию Показать собственности и выборе недвижимости.

Прямые соединения матрица, показывающая, где серверы приложения размещаются с окраской и имущества, показали вместо родовой "X"

- ИЛИ -

"Косвенные" соединения матрицы

6. Sизбранныйпоследовательность подключение типы а также типы компонентовна правой и левой стороне меню, которое появляется, если Вы хотите видеть в "клетках" матрицы, если ап косвенным путь связных компонентсуществует от Вертикальный/ 'ряд"Компонентом матрицы к Горизонтальный/ 'колонка"Компонентом матрицы.

Заметка

Любой допустимый путь, который включает в себя элементы, выбранные в меню путь шплохо быть показанонезависимо от направления основных соединений, однако, при выборе тот путь, первый а также Последние элементы должны быть выбраны типы соединения. Кроме того, заказ из которые были выбраны показано с элементами Численное префиксв квадрате ("[]") кронштейны и могут быть включены данный тип mutliple разв пути (как указано численного префикса). Последовательный выбор типов компонентов или типов подключения интерпретируется как 'ИЛИ'путь и иерархия вложенных компонентов могут быть необязательно включены, проверяя "Кроме того, поиск вложений родителей / детей"Флажок. Переключите Источник а также Раковинакомпонент выбора типа для просмотра пути в противоположном направлении.

7. Матрица будет заполнен спуть / набор компонентовв клетках, если есть дорожка из Вертикальный/ 'ряд'компонентом матрицы к Горизонтальный/ 'колонка"Компонентом матрицы.

Заметка

Для больших матриц только максимум 100 строк или столбцов (в том числе разрушенных строк / столбцов) будет показано на время, как показано на 'R' и 'показателей C' в верхнем левом ячейки заголовка соответственно. Для просмотра дополнительных строк использовать полосы прокрутки. В любое время вы можете дважды щелкнуть на Вертикальный/ 'ряд' или Горизонталь / 'колонка' компонент Заголовки и перейти ксоответствующие компоненты в окне Проводника.Родители вертикали/ 'ряд' а также Горизонтальный/ 'колонка' компонентс также, возможно, как показано отправиться строк / столбцов с серым заголовком названия. После распада (по одной мыши заголовок клеток), если какие-либо дети дорожки существовала тогда 'X', необязательно будет отображаться, если все дети были прикреплены или "O" будет необязательно показано, если только некоторые из детей имели пути. Косвенные компоненты пути могут быть цветной в соответствии с стоимости имущества компонентов, нажав Options '' шестерню в верхней правой части панели инструментов и выбрав матрицы Настройка цвета ... а потом кнопку Edit и выбрать цвет по Timestamp или Цвет По имуществом опции и выбрав свойство, диапазон значений Мин и Макс и выбор цвета, однако, только Список, целое, десятичной, логическое или Дата / Время Свойства типа данных будет цвет. Значения свойств для косвенных компонентов пути может быть показано нажав на Options '' шестерню в верхней правой части панели инструментов и выбрав матрицы Показать настройки Value ... а потом кнопку Edit и выбрав опцию Показать собственности и выборе недвижимости.

Косвенное соединения матрица, показывающая приложений, которые реализуют данную услугу, Департамента

Для фильтрвид Матрица в ABACUS

1. Убедитесь, что у вас есть новый Вид матрицы открытый.

2. Нажмите фильтра оси "воронку" в правом верхнем углу панели инструментов матрицы.

3. Об источнике и / или вкладок моек добавить имя, собственность, описание, иерархия или стандартные фильтры, нажав кнопку Добавить, выберите свойство, если необходимо, и щелкнув ОК, Выберите соответствующие параметры в панели Ключевые слова / элементов с помощью логики / синтаксис, как описано ниже в примечании. Предварительный просмотр панель автоматически обновляется, чтобы показать результаты текущего набора фильтров.

Заметка

Для Отметка, Иерархия путь, имя или Описаниефильтры или Текст, Целое, десятичной, логическое или Дата / времяфильтры собственности соответствия осуществляется, как если бы '*' подстановочные автоматически применяются до и после любых строковых значений таким образом, чтобы ввод 'кошка' (без кавычек) будет включать в себя строки с 'BobКот','Котженщина "или" примеКотионный "и т.д. Несколько / 'или' значения могут быть введены в новых линий с использованием Ctrl + Enter, Для Целое число а также Десятичная дробь недвижимость фильтры "и" логика могут быть включены с помощью "&"(Без кавычек) и больше / меньше и т.д. логики может быть включена с помощью"> =','>','<' а также '<="(Без кавычек), например, '> = 50000 & <90000 ». Номера чистые ценные строки могут быть включены, введя '(Не Заготовки)"(Без кавычек) и пустой строки стоимостью, могут быть включены путем ввода '(Бланки)"(Без кавычек). Для Стандарты или Список недвижимость фильтрует "(Выбрать все) Флажок позволит все остальные флажки, в том числе эффект всех доступных элементов. Футов (Non-Бланки) Флажок будет включать в себя какие-либо непустая собственности оцениваются элементы. Футов (Бланки) Флажок будет включать в себя любой пустой имущество стоимостью элементы. И сняв какие-либо конкретные ценится флажки автоматически снять выделение »(Выбрать все)» и «(не пробелами) 'флажков для консистенции. И, наконец, все фильтры по умолчанию случае нечувствительной так "кошка" (без кавычек) будет включать в себя элементы с "кошкой", "Кошка" или "САТ" и т.д. Для Соответствие чувствительно, введите "(Случай)"(Без кавычек) перед строкой, например "(Дело) Кошка" (без кавычек) будет включать в себя только элементы с 'кот' в них.

Для заполнения с помощью представления матрицы в ABACUS

Заметка

Вы можете только добавить / удалить связи, где один тип соединения был использован для Пути, описанной выше.

1. Для добавить подключениевыбранного типа между а Вертикальный/ 'ряд"Компонент и Горизонтальный/ 'колонка"Компонент матрицы, где" X "не существует(или показано значение свойства - примечание выше)Дважды щелкните ячейку. Должен появиться значком «Х» (или стоимость имущества - примечание выше) и подключение будет создано на верхнем уровне коллекции Connections для выбранной архитектуры.

Заметка

Имя соединения будет Название тип соединения в соответствии с выбранным типом подключения матрицы и если значение свойства показывается вместо 'X' значение по умолчанию для свойства будут показаны.

2. Для редактировать показано значение свойствао связи между a Вертикальный/ 'ряд"Компонент и Горизонтальный/ 'колонка"Компонентом матрицыДважды щелкните ячейку, или щелкните правой кнопкой мыши ячейку и выберите Редактировать значение ..., и измените значение в диалоге изменить значение.

3. Для удалить соединениевыбранного типа между а Вертикальный/ 'ряд"Компонент и Горизонтальный/ 'колонка"Компонент матрицы, где" X "уже существует(или показано значение свойства - примечание выше), правильно-щелкните ячейкуи выберите Отключить, Х должна исчезнуть и связь будут удалены из проекта.

Сохранить / сохранить как aВид матрицы

Заметка

В то время как все пользователи архитектор может создать Матрицы для их сохранения и / или их параметров по Пользовательская лицензия нужна Designer добавить-на возможности. Это «защитить» конфигурацию существующих матриц, которые могут быть общими для многих пользователей. Тем не менее, архитектор использует без Designer добавить-на по-прежнему можно выбрать "Сохранить как" новых настроек в новую матрицу. И, конечно, все лицензии пользователь может выбрать «Сбросить» каких-либо изменений в существующей матрице. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется Дизайнер добавить-на Возможность.И помните, что это всего настройки Матрицы, все изменения, внесенные данным в матрице сразу же применяются в хранилище, независимо.

1. Убедитесь, что у вас есть новый Вид матрицы открытыйи вы сделали необходимые изменения.

2. в Вид матрицыПанель инструментов нажмите на крайнюю левую Сохранить Матрицакнопку, чтобы сохранить Вид матрицы и любые изменения форматирования.

Заметка

Если вы не имеете кнопку Сохранить на панели инструментов Вид матрицы, то вы не должны Дизайнер добавить-на, и вы только в состоянии Сохранить каклюбые настройки меняется на новую матрицу, когда вы идете, чтобы закрыть существующую матрицу.

3. Если Матрица Имядиалог, который появляется (из-за того новую матрицу) введите имя для матрицаи нажмите ОК.

Для экспорт в MS Excel матрицы

1. Убедитесь, что у вас есть Вид матрицы открытый.

2. Нажмите Экспорт в ExcelПанель инструментов кнопку.

3. Выберите имя файла для сохранения MS Excel матрицы как. Нажмите Сохранить.

Заметка

По умолчанию имя файла экспортируемого MS Excel Матрица будет имя Матрица прибавляется к имени архитектуры в скобках, например, "Приложения, размещенные на серверах (2014 Фактический) .xlsx. Вы можете изменить любое из этого, в том числе ли формат файла должен быть .xlsx или .xls.

Форматирование Матрицаэкспортируется по умолчанию, однако, для больших матриц это может привести к тому, экспорт будучи весьма медленно. Соответственно, в Инструменты | Опции... Затем на Матрицазакладка,Вы можете уменьшить количество форматирования, которые экспортируются, как показано на вкладке ниже матрице, тем самым ускоряя экспорт.

Экспорт Матрица опции

4. Отображается диалоговое Экспорт завершен. Нажмите ОК.

Экспорт в MS Excel матрицы

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Заполнение архитектуру от Visio | Заполнение архитектуру с Excel


Заполнение архитектуру с Microsoft Access

Навигация: Заполнение архитектуру> Заполнение из продуктов Microsoft>

Заполнение архитектуру с Microsoft Access

Отправить комментарии на эту тему.

Вы можете экспортировать архитектуру Microsoft Access для выполнения общего назначения расчеты, манипуляции или отчеты о вашей архитектуры. Вы можете импортировать архитектуру обратно в ABACUS.

Заметка

Открытый с Access / экспорт в базу данных функция требует Microsoft Access 2000или новее установлен на компьютере.

Чтобы экспортировать архитектуру Microsoft Access

1. Убедитесь, у вас есть ABACUS файл Открой Исследовательотображается, и архитектурадобавил.

2. Выберите файл | Экспорт | В базу данных.

3. Принять к сведению диалоговом окне предупреждения, как описано выше, и нажмите кнопку Да, чтобы продолжить.

4. Выберите местоположение и имя файла для файла базы данных.

Чтобы импортировать манипулировать архитектуры в ABACUS

1. Убедитесь, что вы есть ABACUS открытым.

2. Выберите файл | Новый и выберите Из Accessв диалоговом окне, которое появляется и нажмите кнопку ОК.

3. Просмотр файла базы данных вы хотите импортировать.

АБАК "База данных MS Access схемы

ABACUS имеет в своем сердцеп онтология / мета-мета-модель из компонентов, связей и ограничений. Это "ССС" подходом были получены из различных стандартных подходов, разработанных с 1960-ых годов кульминацией международного стандарта IEEE 1471, учредителями которого Avolution способствовали. Следующие примитивы применяются;

1. СЧЕТЫ содержит Библиотекииз Стандарты(или стандартами), Компонент а также Типы подключения, Ограничения, Точки зрения, Шаблоны (или Шаблоны) а также многие Архитектуры.

2. Стандарты, Виды а также Точки зрения майбыть логически Группировка для удобства.

3. Архитектуры может содержатьмногие потомком Архитектуры(или Эволюция).

4. Каждый Архитектура содержит многие Компоненты а также Связииз уверен Видыи различные Просмотры.

5. Компоненты а также Связи возможно разлагается в Суб-компоненты а также Суб-соединения.

6. Каждый Компонент является прикреплен кЛюбое количество Связино каждый Подключениеможет быть только прикреплен кмаксимум два Компоненты.

7. Компоненты а также Связи Можно иметь Стандарты с Свойстватаких, как информация, производительность, надежность, стоимость и т.д.

8. Архитектуры, Компоненты а также Связи Можно иметь конкретный Свойстватаких, как информация, производительность, надежность, стоимость и т.д.

9. Ограничения Можно существуют между Компоненты или Связи или против Свойства.

10. Шаблоныстандартные композиции Компонент а также Типы подключения.

11. Точки зрениястандартные ассоциации Компонент а также Типы подключенияв обозначениях.

12. Просмотрыявляются визуальными представлениями Компоненты а также Связи.

Ниже сущность MS Access Отношения Схема (ERD) документирует ядроАрхитектуры, Эволюция, Типы компонент / соединения (и группы), компоненты / Соединения и Sub понятия Компонент / соединение.

Схема базы данных Ядро

Заметка

Ссылочная целостность не было исполнено на отношениях между столом и компоненты таблицы Connections (для «привязанности» между данной источников или поглотителей компонента и соединение). Это потому, что соединение может существовать без составляющих вложений. Мы могли бы добавил «Приложение» стол, но в интересах простоты решили против этого. Конечно, это означает, что любое редактирование ИД компонентов или удаления строк компонентов все вместе приведет к неправильных данных. ABACUS будет справиться с любой некорректность на импорт, игнорируя неправильные данные.

В следующем MS Access ERD документирует Свойствапонятия для архитектуры, типы компонентов / соединений и компоненты / Соединения.

Схема базы данных Свойства

В следующем MS Access ERD документирует СтандартыКонцепция архитектуры, типы компонентов / соединений и компоненты / Соединения.Примечание: Таблицы по-прежнему использовать термин «осуществления», как за предыдущие версии ABACUS.

Стандарты схемы базы данных

В следующем MS Access ERD документирует ОграниченияКонцепция типов компонентов / Соединения.

ОграниченияСхема базы данных

В следующем MS Access ERD документирует Точки зрения Концепция Архитектуры.Примечание: Таблицы по-прежнему использовать термин «TwoDTempl", как в предыдущих версиях ABACUS.

Точки зренияСхема базы данных

В следующем MS Access ERD документирует КаталогиКонцепция Архитектуры.

КаталогиСхема базы данных

В следующем MS Access ERD документирует МатрицыКонцепция Архитектуры.

МатрицыСхема базы данных

В следующем MS Access ERD документирует ДиаграммыКонцепция Архитектуры.Примечание: Таблицы по-прежнему использовать термин «TwoD", как в предыдущих версиях ABACUS.

Заметка

Тип компонента / Подключение к Трафарет отображение формы и произвольной формы формы частей MS Access ERD были опущены для ясности.

ДиаграммыСхема базы данных

В следующем MS Access ERD документирует 3D ПросмотровКонцепция Архитектуры.

3D ПросмотровСхема базы данных

В следующем MS Access ERD документирует ДиаграммыКонцепция Архитектуры.

ДиаграммыСхема базы данных

В следующем MS Access ERD документирует ПанелиКонцепция.

ПанелиСхема базы данных

АБАК "MS AccessЗапросы

В комплекте с базой данных MS Access несколько полезных запросов следующим образом

· Ком по Реквизит- Этот запрос перечисляет все компоненты в проекте (по архитектуре и типа) и включает в себя все свойства, как столбцы. Используйте этот запрос с фильтрами / критериев от типа компонента и / или архитектуры, чтобы произвести "типичные" таблицы для каждого типа элемента с их свойствами.

· Stds по Реквизит- Этот запрос перечисляет все стандарты, которые используются, число вхождений стандарта и включает в себя все свойства, как столбцы. Используйте этот запрос как стандарты каталог.

· Реквизит по типам- Этот запрос перечисляет все свойства компонента и их полные% от каждого типа компонента в виде столбцов. Используйте этот запрос, чтобы определить, будут ли поддерживается специфические свойства.

· Виды по Реквизит- Этот запрос перечисляет все типы компонентов и включает в себя полный% всех свойств как колонны. Используйте этот запрос, чтобы определить, будут ли поддерживается специфические свойства.

· Тип Граф- Этот запрос перечисляет все типы компонентов и включает в себя количество вхождений каждого типа в порядке убывания. Используйте этот запрос, чтобы определить популярность каждого типа в проекте.

Замечание о работе с Memo полей в MS Access

Компоненты, соединения и стандарты Имя поля в таблицах определяется как мемо-поля, чтобы для неограниченного числа символов, а за ABACUS. Для компоненты и соединения это вызывает несколько вопросов, потому что они также имеют уникальный идентификационный поле для ссылки, но для стандартов это вызывает некоторые проблемы при попытке объединения таблиц, потому что вы не можете присоединиться к мемо поля в MS Access. Кроме того, вы можете установить А, где критерии положение, чтобы достичь того же эффекта, как показано в визуальном конструкторе запросов и соответствующих фрагментов SQL ниже этого списка из всех унаследованные стандарты свойства для всех компонентов в экспортируемого проекта счеты.

Памятка поле "присоединяется" В Visual Query Builder

ВЫБОР Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

От компонентов INNER JOIN ON ComponentImplementationLinks (Components.InternalId = ComponentImplementationLinks.Id) И (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Реализации INNER JOIN ImplementationProperties ПО Implementations.Id = ImplementationProperties.Implementation_Id

ГДЕ (((ComponentImplementationLinks.Name) = [Реализации] [Имя]).);

Памятка поле "присоединяется" в SQL

Замечание о генерации идентификаторов автоматически ABACUS в MS Access

Различные таблицы АБАКУС MS Access требует уникальный длинный целочисленный идентификатор так простой метод Б. обеспечивается, чтобы помочь в генерации них. Два метода ResetCounter () и GetNextCounter () предоставляются в рамках АБАК "MS Access БД и их использование в следующем; ResetCounter () устанавливает счетчик на 0. GetNextCounter () вернет следующий счетчик в последовательности.

Методы использовать не давал MS Access 'причуда', что, даже если вы вызвать метод ResetCounter () для каждой строки вставки (т.е., когда вы запустите функцию GetNextCounter ()), потому что функция ResetCounter () не имеет каких-либо параметров она просто бежит это раз и, следовательно, не сбросить счетчик для каждой строки вставки. А также из-за той же "причуда" Вы должны пройти любой старый переменную столбца функции GetNextCounter (), чтобы обмануть его в работает каждый раз.

Существует также трюк, чтобы быть в состоянии запустить функцию ResetCounter () в качестве вставки в SQL заявление, потому что вы не можете просто иметь его, сидя там, как колонны по себе, как если бы это был запрос на выборку. Рекомендуется сделать ResetCounter () вызова часть одного из других областей, путем объединения его до конца, как это всегда возвращает NULL в любом случае.

Ниже приводится типичный использование SQL из методов, чтобы добавить список типов компонентов из таблицы / запроса под названием «Тип компонента Список '.

INSERT INTOComponentTypes (Id, название, описание)

ВЫБОР GetNextCounter ([Тип компонента Список] .name)КАК Id [Тип компонента Список] .name как имя, [Компонент Тип Список] .description & ResetCounter ()КАК Описание

ИЗ[Тип компонента Список];

ABACUS ID поколения / Счетчик в SQL

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Заполнение архитектуру от Visio | Заполнение архитектуру с Excel


Заполнение архитектуру с Microsoft Visio

Навигация: Заполнение архитектуру> Заполнение из продуктов Microsoft>

Заполнение архитектуру с Microsoft Visio

Отправить комментарии на эту тему.

Вы можете импортировать архитектуру Microsoft Visio. Формы в вашем чертеже Visio будут импортированы в качестве компонентов в ABACUS. Соединения в вашем чертеже Visio будут импортированы в качестве соединений, а сам рисунок будет импортирован в ABACUS в виде диаграммы. Кроме того, любые пользовательские свойства Visio в вашем чертеже будут импортированы в качестве свойств с ключа сортировки отображается на Тип недвижимости, этикетка Имя собственности и значение в стоимости имущества.

Заметка

Импорт из Visio функции требует, чтобы Microsoft Visio 2003или новее установлен на компьютере.

Чтобы импортировать рисунки Visio в ABACUS

1. Убедитесь, что вы есть ABACUS открытым.

2. Выберите файл | Новый и выберите От Visioв диалоговом окне, которое появляется и нажмите кнопку ОК.

Заметка

Если вы хотите импортировать в существующий проект ABACUS затем либо щелкните правой кнопкой мыши узел Компоненты внутри архитектуры или щелкните правой кнопкой мыши отдельный компонент в рамках архитектуры, а затем выберите пункт Импорт | От Visio.

3. Найдите файл Visio, который вы хотите импортировать.

Заметка

Ниже приведены некоторые простые правила, или рекомендованных практик при построении (или модификации) а MS Visio рисунок для импорта в ABACUS.

1. Линии и соединения должны быть фактические коннекторы, не формы.

· В противном случае ABACUS просто импортировать их в качестве компонентов и, соответственно, они не будут "прикреплены" к чему.

· Если вам нужно, чтобы сделать некоторые "умные" маршрутизацию (т.е. кроме прямой), то использовать динамический разъем на трафарет Основные формы, ABACUS будет импортировать точки маршрутизации / анкерные порядке.

· Старайтесь избегать использования "сеть" и кольцо "Ethernet" формы от сети и периферийных устройств, что позволяет трафарет много компонентов, которые будут "подключен" к нему. В то время как мы импортируем вложения хорошо, как соединений, оригинальная форма до сих пор "расширил", чтобы отразить вложения. Используйте отделить отдельный "ступицы / автобус" форму (без разъема "ноги"), а затем явно подключения каждого компонента к хабу / автобусе с отдельными разъемами.

· Если линия или соединение ведет себя как форму, щелкните правой кнопкой мыши на нем и перейти к "Формат | Поведение ... »и убедитесь, что взаимодействие стиль установлен в линии (1-мерное).

2. Компоненты должны быть формы НЕ соединители.

· В противном случае ABACUS просто импортировать их как соединения и, соответственно, вся информация форма будут потеряны.

· Если компонент ведет себя как разъем, щелкните правой кнопкой мыши на нем и перейти к "Формат | Поведение ... »и убедитесь, что взаимодействие стиль установлен в коробке (2-мерное).

3. Концы разъемов должны быть присоединены к фигурам, НЕ плавает в фоновом режиме за форму.

· Если вы не подключите разъемы для форм, то ABACUS не имеет возможности узнать, что вы хотели, чтобы прикрепить данный разъем к форме / компонента и, соответственно, он оставит этот конец соединительного ООН-прилагается.

4. Этикетки для форм должно быть (где возможно) встроенный текст метки для формы, а не отдельной текстовое поле на чертеже.

· Отдельные текстовые поля будут импортироваться по ABACUS в качестве компонентов в их собственном праве и в то время как вы можете объединить компонент "Метка" с реальным компонентом в ABACUS, или просто конвертировать компонент "Метка" в свободной форме форме (т.е. не сам компонент) лучше, чтобы избежать этих шагов.

5. Используйте тот же базовый форму для каждого экземпляра того же типа, не ленитесь и использовать прямоугольник иногда и коробки другие из разных трафаретов формы.

· ABACUS использует базовую форму и ее основной цвет однозначно идентифицировать типы компонентов и соединений на чертеже так "красный прямоугольник" и "красный ящик" будет импортироваться в виде двух отдельных типов компонентов. Эти типы компонентов могут быть объединены в ABACUS, но это лучше, чтобы избежать этих шагов.

6. Полностью инкапсуляции "дети" формы в своих "родителей", не оставляйте их висит над краем.

· ABACUS обнаружит любую форму, полностью инкапсулированный в другой форме, как ребенок родителя поэтому убедитесь, что все формы, в том числе части этикетки, прилагается.

7. Не устанавливайте форму перекрытие двух других фигур.

· Если форма перекрывает две другие формы, будь то "группировка" / фоновый прямоугольник или иначе, это будет импортироваться ABACUS в качестве компонента, что является потомком ни перекрывающихся форм, но как только вы выберите компонент в АБАК "инструментом рисования , в связи с верхнего левого будучи компоненты опорного пункта, это станет ребенок слева перекрывается форму / компонент.

8. Постарайтесь свести к минимуму использование текстовых заметок на чертеже, потому что это будет импортироваться в качестве компонентов в их собственном праве и должны быть преобразованы в произвольных форм в ABACUS. Подумайте о том, являются ли они на самом деле имя существующего компонента или соединения.

9. В то время как ABACUS поддерживает богатый / цветные / вектор на основе форм, стараются свести к минимуму использование растровых изображений, форм и зарубежных Enhanced метафайлы для форм, как ABACUS настоящее время делаетнеподдержки этих типов. Они будут импортированы в качестве простых белых прямоугольников.

10. Старайтесь избегать возврата каретки (Shift-Return) в этикетках, как они импортируются и показано как специальный символ "[]" в ABACUS для имени компонента.

11. Попытка свести к минимуму различные цвета, которые используются для форм того же типа. Как упоминалось выше, основной цвет и форма базы однозначно определяет компонент и типы подключения, так что больше вариаций существует более слияние и консолидация, что нужно будет сделать, пост-импорт в ABACUS.

12. Будьте осторожны с заливкой, потому что если форма заполнена полностью по углам, то окрашивая его позже в ABACUS не будет иметь никакого эффекта.

13. Для сложных линий на основе форм необходимо использовать полигон, который создается при наличии строки, начинающиеся где предыдущий заканчивается, а затем, в конечном счете вернуться к начальной точке. При желании, вы можете использовать заливки и линии ширины, чтобы сделать полигон выглядеть "стрелки" или любую форму вы хотите.

14. Убедитесь, что формы ID в MS Visio имеет смысл не только Shape.xx. Это редактируемые с помощью правой кнопкой мыши 'Показать' ShapeSheet, которая доступна в режиме разработчика MS Visio (включается через Tools | Options в MS Visio).

15. Эллипсов и дугв формподдерживаются в ABACUS но NURBS и сплайны в настоящее время не поддерживается.

16. Убедитесь, что вся форма сгруппированы в MS Visio, или это будет импортироваться в нескольких компонентов / типов.

17. Постарайтесь свести к минимуму использование повернутых форм в subshapes как они иногда не быть импортированы правильно.

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Заполнение архитектуру от доступа | Заполнение архитектуру с Excel


Заполнение архитектуру из Microsoft Excel

Навигация: Заполнение архитектуру> Заполнение из продуктов Microsoft>

Заполнение архитектуру из Microsoft Excel

Отправить комментарии на эту тему.

Вы можете импортировать вашу архитектуру из таблицы Excel (.xls или .xlsx файл). Импортер Excel позволяет отображать списки компонента и соединения с типами, стандартов, свойств и стандартных свойств, выбрав столбцы в электронной таблице, которые содержат соответствующие данные.Это, однако, более продвинутая техника, чем Рекомендуемый подходдля импорта из MS Excel, которая с помощью каталоги как описано Вот .

Заметка

Функция импорта / экспорта из Excel в том, что требуется Microsoft Excel 2003или новее установлен на компьютере.

Основная функция импортера Excel, чтобы позволить вам определить конфигурационный файл (т.е. иерархической структуры вашего архитектурной модели). Файл конфигурации хранит сохраненные ранее отображение из в Excel файл в файл ABACUS. После того, как определены, сохраненного файла конфигурации используется позже для дальнейшего импорта в и экспорт в XLS-файлов.

Заметка

Шаги, показанные ниже в разделах, специально для пользователей, которые еще определить и сохранить файл конфигурации и импортеров из Excel в первый раз. Вы должны создать и сохранить файл конфигурации, чтобы использовать экспорт чтобы преуспеть функцию.

Чтобы импортировать Excel таблицу в ABACUS

1. Убедитесь, что вы есть ABACUS открытым.

2. Выберите файл | Новый и выберите Превосходитьв диалоговом окне, которое появляется и нажмите кнопку ОК.

Заметка

Если вы хотите импортировать в существующий проект ABACUS затем либо щелкните правой кнопкой мыши узел Компоненты внутри архитектуры или щелкните правой кнопкой мыши отдельный компонент в рамках архитектуры, а затем выберите пункт Импорт | От Excel.

3. Импорт таблицы ExcelОткроется окно

Импорт таблицы Excel Окно

4. Нажмите Открыть Excel файлазначок и просматривать для Excel файл, который вы хотите импортировать.

5. Выбрать Рабочий листВы хотите импортировать из раскрывающегося списка.

Заметка

После открытия файла Excel, вы можете использовать Предварительный просмотр данныхВкладка для просмотра колонок и первые 25 строк электронной таблицы. Отсюда вы можете получить число столбцов, необходимых, чтобы заполнить Компоненты а также СвязиВкладка.

Вы также можете выбрать хотите вы или нет компоненты в таблице Excel тобы быть импортированы с учетом регистра. Просто отметьте Импорт с учетом регистравариант (по умолчанию это всегда тикали) и таблицы будут импортированы соответственно.

Образец файла Excel

Заметка

В этом примере мы будем импортировать простой инфраструктуры и люди Архитектура из данных, показанных первенствовать на скриншоте выше. Соединения будут между "люди, ответственные» и «Серверы», что эти люди управляют.

Для заполнения вкладку Components

Этот раздел предназначен для определения компонентов видов и иерархическую структуру для файла конфигурации.

1. Выберите КомпонентыВкладка. Переименование Установить идентификаторпутем переопределения (ноль) стоимость

Заметка

Эта функция позволяет определить совершенно разные Наборыфункционально отдельных компонентов. Как показано на скриншоте ниже, вы можете выделить свои компоненты инфраструктуры от ваших людей компонентов. Если есть отношения (связи) между этими различными наборами компонентов, они могут быть определены под СвязиВкладка. Позже в этом примере мы определим соединения типа "управляет" между инфраструктуры и люди Наборы.

Вы также можете выбрать, хотите ли вы добавить топ-уровня Группировкакомпонент для всех элементов множества. Просто отметьте Группа Под Set IDвариант (по умолчанию это данную опцию) и таблицы будут импортированы соответственно.

Назначение Set ID

2. Однажды НаборыБыли определены выбрать ЗадаватьВы хотите, чтобы заполнить и расширить, нажав на [+] знак.

3. Выбрать Уровни компонентов в этом набореиз расширенного списка.

4. Компонент Иерархия наборы: Set IDПоявится окно для этого Задавать.

Компонент Иерархия и присвоения значений (Set ID: Инфраструктура)

5. Переименование Количество УровеньКолонка с помощью переопределения (ноль) стоимость.

Заметка

Количество Уровеньстолбец позволяет назначить иерархию компонентов. Каждый уровень соответствует уровню в вашей архитектуре причем первый уровень самый верхний родительУровень. Например, номер уровня "1" соответствует самой верхней иерархической слоя, Количество Уровень "2" является дочерним номер уровня "1" и так далее.

6. Выберите и назначьте соответствующую колонку в Excel из таблицы друг Количество Уровеньвведя его под Компонент Колонкаколонка.

Заметка

Вы можете выбрать, чтобы исключить определенные строки, которые вы не хотите, чтобы быть представлены в вашей архитектуре. Они могут быть заголовки столбцов, строк, пустые и т.д. Чтобы исключить строки использовать Строки Исключить:текстовое поле в верхнем правом углу окна. В этом примере мы исключили ряд 1, поскольку она содержит наши заголовки столбцов.

7. Вы можете добавить описание к компонентам путем перезаписи (ноль)значение в Описание Столбец.

Заметка

Это описание того, что появится в ABACUS под Общие свойствараздел | Описаниеполе.

8. Если данное таблицы столбец имеет более чем один компонент на клетку (вводится с помощью Alt-Enter или (10) Команда СИМВОЛ), то поставьте галочку под Лечить новые линии как отдельные компоненты, Каждая строка будет импортирована в виде отдельных компонентов.

Наконечник

Чтобы импортировать 'матрицу' из коллекции столбцов, где "X" в данном 'матрицы' ячейки (ячеек В2: D2 говорят) означает, что компонент определено в строке (в ячейке A2 сказать) соединен с компонентом указано в колонке '' (заголовок в строке 1 Say), простая формула может быть использована. Введите следующую формулу для каждой строки в колонке за матричных клеток (колонка F сказать); = ЕСЛИ (В2 = "", "", В $ 1 & СИМВОЛ (10)) и ЕСЛИ (C2 = "", "", С $ 1 & СИМВОЛ (10)) и ЕСЛИ (D2 = "", "", D $ 1 & СИМ (10)). Затем установите соединение установить, как описано ниже между компонентами указанных строке (в столбце А говорят) и те, которые описаны по этой формуле (в столбце F сказать). Будьте уверены, чтобы проверить Лечить новые линии как отдельные компонентывариант, когда компоненты из формулы импортируются. Для более продвинутых импорта матрицы, в том числе заголовков с несколькими слоями иерархии или клеток с различными значениями, чем просто один 'X', пожалуйста, свяжитесь с Поддержка Avolution .

9. Заполните остальных столбцов по мере необходимости.

Заметка

Вы можете выбрать, чтобы получить тип из строк столбцов, отметив флажок под Получить тип из колонныколонки и введя соответствующую колонку в Excel из таблицы под Компонент Тип Значение или колонкиколонка. Это будет импортировать все компоненты в этой колонке и установить их в типа, определенного в столбце. Кроме того, и как с скриншоте выше и ниже, вы можете выбрать, чтобы использовать фиксированный / предопределенный имя типа, введя имя типа под Компонент Тип Значение или колонкиколонки и убедившись, что флажок ООН проверены.

Компонент Иерархия и присвоения значений (Set ID: Люди)

Заметка

В этом примере мы хотим, чтобы наши сети, и люди группировки на уровне 1 Архитектура. На уровне 2 мы хотим, чтобы наши серверы и людей, ответственных за управление этими серверами. КомпонентыВкладка была заполнена соответствующим образом, как показано на двух скриншотах выше. В первом скриншоте выше мы определили 1 (сеть группировки) и 2-го уровня (серверных) компонентов уровня для инфраструктуры Задавать, И на скриншоте непосредственно над мы определили на уровне 1 (людей группировки) и 2 (люди, ответственные) компоненты уровня для людей Задавать.

В качестве альтернативы, для людиНабор, а не с помощью колонки C в Народной группировки, мы могли бы использоваться Группа Под Set IDвариант на вкладке верхней компоненты уровня, а затем только что вступили один человек подуровень из колонки D. Это показано на скриншоте ниже.

Компонент Иерархия и Присвоение значений, используя группу под Set ID опцию (Set ID: Люди)

10. После того, как компоненты были определены, выберите уровень компонента вы хотите, чтобы заполнить свойства и / или стандартов и расширить, нажав на [+] знак.

11. Выбрать Свойства компонентов на этом уровне или Стандарты компонентов на этом уровнеиз расширенного списка и заполнить соответствующие колонки по мере необходимости.

Заполнение компоненты

Заметка

Свойства компонентов на этом уровнепозволяет определить свойства для компонентов на выбранном уровне. Стандарты компонентов на этом уровнепозволяет определить стандарты и их стандартные свойства для компонентов на выбранном уровне.

12. Повторите шаги 2 - 11пока все уровни компонентов не была заселена для всех определенных Наборы, Используйте стрелку назад в правом верхнем углу окна, чтобы вернуться обратно к Наборыкоторые вы определили ранее.

Для заполнения вкладку Подключения

Этот раздел предназначен для определения типов соединений и иерархическую структуру файла конфигурации.

1. Выберите СвязиВкладка. Для каждого набора соединений, вы должны определить, какой компонент Задаватьчто вы хотите быть компоненты источника и компонент ЗадаватьВы хотите быть компоненты назначения.

2. Под Источник Набор компонентов ID введите Задаватьимя, которое соответствует Задаватьопределен ранее в КомпонентыВкладка. Под Источник Компонент Количество Уровеньвведите число, соответствующее уровню компонента вы хотите подключиться к сети в конце исходного соединения.

3. Теперь выберите, какой компонент группы будет в конце назначения соединения. Под Назначение Набор компонентов ID введите Задаватьимя, которое соответствует Задаватьопределены в КомпонентыВкладка. Под Направление Номер компонента Уровеньвведите число, соответствующее уровню компонента вы хотите подключиться к сети в конце назначения соединения.

Заметка

В этом примере мы хотим, чтобы соединить людей, ответственных за управление серверами на серверах, что они управляют. Лица, ответственные были определены в лицах Задаватькак уровень 2 компоненты Хотя серверы были определены в инфраструктуре Задаватькак уровень 2 компоненты. СвязиВкладка была заполнена соответственно, как показано на скриншоте ниже.

Вкладка Подключения Часть 1 из 2

4. Если вы прокрутите вправо, вы найдете дополнительные параметры импорта подключения. Получить тип из колонны а также Тип соединения Значение или колонкиработать так же, как для КомпонентыВкладка.

5. Если Источник Набор компонентов IDи Источник Компонент Количество Уровеньтакие же, как Назначение Набор компонентов IDи Направление Номер компонента Уровень(например, если вы подключаетесь те же типы компонентов, таких как создание соединений от серверов к другим серверам), то вы должны иметь еще один столбец в вашей таблице, который содержит имена этих серверов повторных. В этой ситуации вы бы положить, что столбец таблицы в Направление Повторное в колонкеколонка. Если в этом столбце таблицы Вы ввели более одной связную компоненту на ячейку, то поставьте галочку под Лечить новые линии как отдельные компоненты.

Вкладка Подключения Часть 2 из 2

6. После соединения были идентифицированы выберите соединение вы хотите, чтобы заполнить свойства и / или стандартов и расширить, нажав на [+] знак.

7. Выбрать Свойства для этих соединений или Стандарты для этих соединенийиз расширенного списка и заполнить соответствующие колонки по мере необходимости.

Заметка

Свойства для этих соединенийпозволяет определить свойства для выбранной группы соединения. Стандарты для этих соединенийпозволяет определить стандарты и их стандартные свойства для выбранной группы соединения.

8. Повторите шаги 2 - 7пока все группы соединения не были определены.

9. Когда вы закончите определение группы соединения, нажмите на КонецКнопка и ваша архитектура будет создана из импортируемого файла Excel. В приведенном выше примере приведет к архитектуре, показанной на рисунке ниже.

Образец архитектуры Пригнан из Excel

10. Теперь сохраните переведённый конфигурацию в файл, нажав на Сохранить настройки значок. Сохраненные конфигурации могут быть получены и позже, нажав на Откройте КонфигурацияЗначок в верхнем левом углу окна.

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Заполнение архитектуру от доступа | Заполнение архитектуру от Visio


Заполнение архитектуру с Microsoft SharePoint

Навигация: Заполнение архитектуру> Заполнение из продуктов Microsoft>

Заполнение архитектуру с Microsoft SharePoint

Отправить комментарии на эту тему.

Ты можешь синхронизировать ваша архитектура сMicrosoft Списки SharePoint. Синхронизация включает либо создания новых списков SharePoint (и их столбцов) из типов ABACUS, их свойства и вложений, или отображение существующих списков SharePoint (и их столбцы) для типов ABACUS, их свойства и вложения, то либо отправке контента с ABACUS в SharePoint или SharePoint чтобы ABACUS.

Заметка

SharePoint Синхронизация Функция требует, чтобы Microsoft SharePoint 2010 2013 или SharePoint Online Сайт доступен для подключения и синхронизации с.В то время как функция синхронизации SharePoint может создавать списки (с колоннами) на сайте SharePoint из любого проекта ABACUS, Avolution также можем предоставить различные шаблоны сайтов SharePoint в поддержку стандартных рамок (например, TOGAF, ArchiMate, ITIL и т.д.), так, пожалуйста, свяжитесь Поддержка Avolution если вам требуется такая возможность.

Для создать новый список SharePoint и отобразить его на компонент или подключение типа ABACUS

1. Убедитесь, что вы есть ABACUS открытым.

2. Выбрать Инструменты | SharePoint Синхронизация.

3. Нажмите Новое отображениекнопка и диалоговое Отображение SharePoint, как показано ниже появится.

4. Введите URL сайта, имя пользователя и пароль для сайта SharePoint и нажмите Подключать.

Заметка

'Admin' Действующие SharePoint или счета "вкладчика" требуется синхронизировать с SharePoint и и счета '' читателя только позволит синхронизировать с SharePoint.

5. Выберите ABACUS компонент или тип подключения к карте от Выберите тип тянуть вниз.

6. Нажмите Добавить новоекнопку, а затем для каждого ABACUS компонента или соединения типа аспекте вы хотите для отображения на соответствующем поле списка SharePoint выберите элемент в левой панели и на правой панели введите имя нового списка SharePoint в столбце Новый список (только в первый раз) , то имя столбца SharePoint в столбце Имя (или используйте значение по умолчанию) и нажмите Назначать каждый раз.

Заметка

Как минимум, чтобы позволить синхронизации счеты EEID, архитектуры и Имя аспекты будут автоматически отображаться на номер SharePoint и двух (2) одной строки текста (Text) ака столбцов соответственно. Они не могут быть присвоены. Кроме того, только некоторые аспекты ABACUS настоящее время могут быть отображены в отдельных столбцах SharePoint и его тип выпадающее будет автоматически установлен на требуемой колонного типа SharePoint.А именно,

· Иерархия Путь счеты ", чтобы SharePoint нескольких строк текста (ака Примечание) столбцов (Примечание: SharePoint одной строки текста (ака текст) колонки поддерживают только 255 символов, поэтому они не являются предпочтительным),

· АБАК "присоединенным компонентам столбцов SharePoint Lookup (Примечание: Отображение уже должен существовать в список для подключенных самих компонентов),

· Текст и Описание свойства счеты ", чтобы SharePoint нескольких строк текста (ака примечание) столбцов (Примечание: SharePoint одной строки текста (ака текст) колонки поддерживают только 255 символов, поэтому они не являются предпочтительным),

· АБАК "Десятичные или Integer свойства на номер SharePoint колонн,

· АБАК "Список свойства в столбцах SharePoint Choice (Примечание: SharePoint не обеспечивает значения выбор, так что тип данных Список не нужно быть исполнено в ABACUS),

· АБАК "Дата / Время свойства в SharePoint несколько строк текста (ака Примечание) столбцов (Примечание: SharePoint Дата и время столбцов не может быть использован в качестве еще из-за непоследовательной поддержке SharePoint для часового пояса / настроек регионализации),

· Логические свойства АБАК "в SharePoint Да / Нет (ака булевой) столбцов.

Связанные стандарты элемент в Abacus не могут быть отображены в столбцах список SharePoint, как еще.

7. Выбрать Создать Mapping.

Для создать новое отображение между компонентом ABACUS или типа соединения и существующего списка SharePoint

1. Убедитесь, что вы есть ABACUS открытым.

2. Выбрать Инструменты | SharePoint Синхронизация.

3. Нажмите Новое отображениекнопка и диалоговое Отображение SharePoint, как показано ниже появится.

4. Введите URL сайта, имя пользователя и пароль для сайта SharePoint и нажмите Подключать.

Заметка

'Admin' Действующие SharePoint или счета "вкладчика" требуется синхронизировать с SharePoint и и счета '' читателя только позволит синхронизировать с SharePoint.

5. Выберите ABACUS компонент или тип подключения к карте от Выберите тип тянуть вниз.

6. Выберите сайт SharePoint список отображение из Выберите Список тянуть вниз.

7. Для каждого компонента или соединения типа аспекте ABACUS вы хотите отобразить на своем столбце списка соответствующий SharePoint выберите элемент в левой панели и правую панель, соответственно и нажмите Назначать.

Заметка

Как минимум, чтобы позволить синхронизации счеты EEID, архитектуры и Имя аспекты должны быть отображены в номер SharePoint, а затем по архитектуре и имя либо одной строки текста (ака текст) или нескольких строк текста (ака Примечание) столбцов соответственно. Пока это не будет сделано кнопку Mapping Создание не будет включен. Кроме того, только некоторые аспекты ABACUS настоящее время могут быть отображены в отдельных столбцах SharePoint.А именно,

· АБАК "Архитектура аспект в SharePoint одной строки текста (ака текст) или нескольких строк текста (ака Примечание) колонки (это требуется для содержания конкретного отображения, как описано ниже),

· Иерархия Путь счеты ", чтобы SharePoint одной строки текста (ака текст) или нескольких строк текста (ака Примечание) столбцов (Примечание: SharePoint одной строки текста (ака текст) колонки поддерживают только 255 символов, так что любые дополнительные символы будут обрезаны и, следовательно, рекомендуется конвертировать их в несколько строк текста (ака Примечание) столбцов в SharePoint до отображения),

· АБАК "присоединенным компонентам столбцов SharePoint Lookup (Примечание: Отображение уже должен существовать в список для подключенных самих компонентов),

· Текст и Описание свойства счеты ", чтобы SharePoint одной строки текста (ака текст) или нескольких строк текста (ака Примечание) столбцов (Примечание: SharePoint одной строки текста (ака текст) колонки поддерживают только 255 символов, так что любые дополнительные символы будут усечены и, следовательно, рекомендуется конвертировать их в несколько строк текста (ака Примечание) столбцов в SharePoint до отображения),

· АБАК "Десятичные или Integer свойства на номер SharePoint колонки (Примечание:. Столбцы SharePoint Расчетное может быть использован, однако они смогут только синхронизировать с SharePoint, чтобы ABACUS Пытаясь синхронизировать 'до' вычисляемого столбца приведет к предупреждения как в ниже) ,

· АБАК "Список свойства в столбцах SharePoint выбор,

· АБАК "Дата / Время свойства в SharePoint несколько строк текста (ака Примечание) столбцов (Примечание: SharePoint Дата и время столбцов не могут быть использованы из-за непоследовательной поддержке SharePoint для часового пояса / настроек регионализации),

· Логические свойства АБАК "в SharePoint Да / Нет (ака булевой) столбцов.

Связанные стандарты элемент в Abacus не могут быть отображены в столбцах список SharePoint, как еще. И Валюта SharePoint, лица или группы, или Гиперссылка Изображение, результат задачи, внешних данных и управляемые колонны метаданных не может быть сопоставлен с ABACUS аспектов еще.

8. Выбрать Создать Mapping.

Для синхронизироватьВаш Microsoft Список SharePoint (ы)в ABACUS

1. Убедитесь, что вы есть ABACUS открытым.

2. Выбрать Инструменты | SharePoint Синхронизация.

Заметка

Для синхронизировать список SharePoint сПроект ABACUS нуждается лицензия пользователя по SharePoint Синхронизациядобавить-на возможности. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

3. Выберите существующий отображение SharePoint (или отображения с помощью Ctrl-клик или Выбрать всеКнопка) от SharePoint Отображенияпанелькак показано на скриншоте образца выше. Примечание: здесь мы показываем только 'Гол (или требование) "ABACUS типа компонент отображение к списку SharePoint называемые Цели выбирают.

4. Выберите архитектура (ы), которые вы хотите синхронизировать контент с от Содержание синхронизации с архитектурамиПанель также показано на скриншоте образца выше. Примечание: здесь мы показываем только "2015 Фактический" Архитектура синхронизируются.

5. Выберите Синхронизация С SPкнопка.

Заметка

Если учетные сайт SharePoint не являются "всех сохраненных 'для отображения (ов) выбранного затем Войти в диалоге SharePoint появится просят для адрес сайта, Имя пользователя и / или пароль.Пожалуйста, введите них. Кроме того, синхронизация будет включать в себя какие-либо другие отображения, которые необходимы для подключенных компонентов / столбцов поиска. Любые дополнительные отображения, которые автоматически включены будет показано в диалоге как на ниже.

6. На успешной синхронизации открывается диалог Результаты SharePoint Синхронизация появится, как показано ниже перечислены изменения, а также предупреждения. Нажмите ОК.

Для синхронизация с ABACUS в Ваш Microsoft Список SharePoint (ы)

1. Убедитесь, что вы есть ABACUS открытым.

2. Выбрать Инструменты | SharePoint Синхронизация.

Заметка

Для синхронизировать список SharePoint сПроект ABACUS нуждается лицензия пользователя по SharePoint Синхронизациядобавить-на возможности. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

3. Выберите существующий отображение SharePoint (или отображения с помощью Ctrl-клик или Выбрать всеКнопка) от SharePoint Отображенияпанелькак показано на скриншоте образца выше. Примечание: здесь мы показываем только 'Гол (или требование) "ABACUS типа компонент отображение к списку SharePoint называемые Цели выбирают.

4. Выберите архитектура (ы), которые вы хотите синхронизировать контент с от Содержание синхронизации с архитектурамиПанель также показано на скриншоте образца выше. Примечание: здесь мы показываем только "2015 Фактический" Архитектура синхронизируются.

5. Выберите Синхронизация с ИПкнопка.

Заметка

Если учетные сайт SharePoint не являются "всех сохраненных 'для отображения (ов) выбранного затем Войти в диалоге SharePoint появится просят для адрес сайта, Имя пользователя и / или пароль.Пожалуйста, введите них. Кроме того, синхронизация будет включать в себя какие-либо другие отображения, которые необходимы для подключенных компонентов / столбцов поиска. Любые дополнительные отображения, которые автоматически включены будет показано в диалоге как на ниже.

6. На успешной синхронизации открывается диалог Результаты SharePoint Синхронизация появится, как показано ниже перечислены изменения, а также предупреждения. Нажмите ОК.

Заметка

ABACUS будет обновить столбцы SharePoint с пустыми значениями, даже если "Требовать, чтобы этот столбец содержит информацию« установлено значение Да в SharePoint. Это потому, что SharePoint не подвергайте этот параметр внешне. Если это должно быть предотвращено рекомендуется счеты Дизайнер устанавливает необходимый ограничение Истина и насильственным для данного свойства, используя счеты " ограничение особенность .

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Заполнение архитектуру от Visio | Заполнение архитектуру с Excel


Заполнение архитектуру с Microsoft SQL Server

Навигация: Заполнение архитектуру> Заполнение из продуктов Microsoft>

Заполнение архитектуру с Microsoft SQL Server

Отправить комментарии на эту тему.

Вы можете импортировать вашу архитектуру из базы данных Microsoft SQL Server. У вас есть выбор, чтобы просто импортировать таблиц и связей эффективно импортирующие только общую структуру базы данных или таблиц, строк и отношений, которые будут импортированы в не только структуру, но данные, а также.

Заметка

От SQL сервера функция требует, чтобы Microsoft SQL Server 20052008, 2008 R2, 2012 или 2014установлен на компьютере.

Чтобы импортировать базу данных Microsoft SQL Server в ABACUS

1. Убедитесь, что вы есть ABACUS открытым.

2. Выберите файл | Новый и выберите С SQL Serverв диалоговом окне, которое появляется и нажмите кнопку ОК.

3. В диалоговом окне Импорт SQL Server, который появляется опция '' MachineName и ценности »SQLINSTANCE 'соединения переменной строку и значение' 'DbName переменной Имя базы данных к их правильными значениями, как показано на скриншоте ниже образец.

4. Установите переменную имя базы данных с тем же значением в качестве начального переменной Каталог установленного в предыдущем шаге, как показано на скриншоте ниже образец.

5. Нажмите кнопку Test Connection и таблицы для импорта секция диалога должны быть заполнены с имеющимися таблицами базы данных, как показано на скриншоте ниже образец.

6. Выберите таблицы, которые вы хотите импортировать либо индивидуально, выбирая их или не используя все, никто и кнопки от основания до правой части диалогового окна.

Заметка

Только Ключевые Отношения Иностранные которые существуют между таблицами, которые вы выбираете будет импортироваться.

7. С помощью кнопки радио Стиль Импорт выбрать, хотите ли вы импортировать только те таблицы и отношения между ними или таблицах, их рядов и конкретных отношений между строк.

Заметка

Первый вариант импортирует таблицы в качестве компонентов типа '' Таблица и отношений между любыми двумя таблицами (с внешними ключами) будут импортированы соединений типа «Таблица отношение". Это классический "ERD" вид стиль системных таблиц. Второй вариант импортирует строки таблицы в виде дискретных подгрупп компонентов типа «строка таблицы" со свойствами, соответствующими каждому из столбцов / полей и с отношениями между строк таблицы типа «Таблица отношение". Кроме того, если есть столбец / поле, называемое "Имя", то это используется, чтобы назвать отдельные строки таблицы суб-компонентов.

8. Выберите ... кнопку Импорт.

9. После короткого промежутка времени (с прогресс-бар для обратной связи) новый проект ABACUS будет создан с тумбочки, стол Строки (если второй вариант был выбран в предыдущем шаге) и отношения из базы данных Microsoft SQL Server.

Смотрите также

Заполнение архитектуру - Обзор | Заполнение архитектуру вручную | Заполнение архитектуру от Visio | Заполнение архитектуру с Excel


Добавление заданных свойств компонента, связи или типа

Навигация: Заполнение архитектуру> Свойства>

Добавление заданных свойств компонента, связи или типа

Отправить комментарии на эту тему.

Стандартные библиотеки свойств могут быть указаны и назначен всего на архитектуру. Эти библиотеки известны как Стандарты, Используя Стандарты, Вам нужно только, чтобы собрать конкретные свойства системы - стандартные свойства уже есть.

Например стандартные эксплуатационные характеристики Microsoft Windows 2000 могут быть сохранены какСтандарти назначены какие-либо компоненты (или соединения, не то что бы типичная) с помощью операционной системы Microsoft Windows 2000.

Чтобы добавитьстандартк компонентному, связи или типа

1. Щелкните правой кнопкой мышина компоненте / связи / типа.

2. Выбрать Назначать Стандарт.

3. ВыбратьСтандартиз списка.

Смотрите также

Заполнение архитектуру - Обзор | Изменение свойств компонента, связи или типа | Совокупные свойства


Изменение свойств компонента, связи или типа

Навигация: Заполнение архитектуру> Свойства>

Изменение свойств компонента, связи или типа

Отправить комментарии на эту тему.

Свойства, как правило, системные требования, которые вы определяете, или результаты оценки АБАК ". (При ABACUS выполняет свои оценки, он пишет свойства обратно в файл.) Другими словами, свойства вещи, вы знаете о вашей системе, или то, что вы используете счеты, чтобы узнать.

Чтобы изменить значение свойства компонента, связи или типа

1. Нажмитена компоненте / соединения / тип (его свойства будут отображаться в окне свойств справа).

2. Нажмитечтобы выделить имущество вы хотите изменить.

3. Типновое значение.

Важный

Кроме того, многие свойства определяются с помощью Стандарты , Изменяя свойство в пределахСтандарт, Вы не только изменить текущий объект, вы также изменить мастер Стандарт (под Стандарты нав верхней части дерева). Перед этим, проверьте, что другие компоненты, соединения или типы помощью Стандарт, Потому что изменения не могут быть актуальны для них- Вы можете использовать окно Ссылки для этого.

Наконечник

Вы можете изменить свойства соединение изнутри компонентов ветви дерева (и наоборот). Так, например, если вы ищете на то, что соединения присоединены к компоненту, и вы понимаете, что вы должны изменить один, вы можете.

Чтобы добавить новые свойства к компоненту или связи (с помощью типа)

Заметка

Свойства могут быть добавлены только к типам и компонентов или соединений типа «наследуют» эти свойства.

1. Нажмитеот типа (его свойства будут отображаться в окне свойств справа).

2. Нажмитена кнопку Add в верхней части окна свойств, чтобы добавить строку в верхней части сетки на имущество за новой собственности.

3. Добавить Типдля нового имущества.

4. Добавить имядля нового имущества.

5. Добавить Значение по умолчаниюдля нового имущества.

6. Добавить Ед. измдля нового имущества.

7. Установить Тип данныхдля нового имущества.

Заметка

Поле Тип данных может быть использована для ограничения допустимых значений, что свойство может иметь. То есть; Текст, Целое, десятичной, дата / время, логическое или Список.

o A Текстсвойство является одним, что имеет неограниченное количество символов, а по сути, не имеет ограничений по стоимости.Если свойство имеет значение является корректным гиперссылку (т.е. URL-адреса должны начать с одного из 5струны; HTTP: //, HTTPS: //, FTP: //, файл:или \\ и любойпомещения должны быть введены с '% 20'), То ссылка кликабельна (через Ctrl + клик).

o Целое числоИмущество должно быть целое число положительным или отрицательными может содержать период, пространство, апостроф или запятую для группировки цифр в зависимости от проекта Настройки Регион из Файл | Параметры проекта.Настройки региона и.Сеть Метод Long.TryParse является используется для определения действует Целое число значения.

o A Десятичная дробьимущество может содержать точка или запятая для десятичного символа и может содержать период, пространство, апостроф или запятую для группировки цифр в зависимости от проекта Настройки Регион из Файл | Параметры проекта.Настройки региона и.Сеть Метод Decimal.TryParse является используется для определения действует Десятичная дробь значения.

o A Дата / времясвойство позволяет либо часть даты или времени часть или оба. Областьнастройкии .NET Метод DateTime.TryParse в первую очередь используется для определения действительных Дата и / или время значения. Тем не менее, часть даты, если это применимо, требует, по крайней мере день и месяц (год будет считать текущий год) или месяц и год частей в силе. То есть Июня 3 квартал 2010 или даже просто 2010 являются недействительными. В то время как она будет отличаться с различными региональными настройками, как правило, детали день, месяц и год могут быть разделены пробелами, запятыми, тире ("-") или косой черты ('/'). День, как правило, часть представляет собой целое число от 1 до 31. Месяц часть обычно представляет собой целое число от 1 до 12, действительный 3-буквенное сокращение для месяца (например, январь, февраль, март) или полное название месяца (например, январь, февраль , Март). Год частью, как правило, положительное число 4-значный, но 1, 2 и 3 цифр года принимаются в соответствии с настройками в Панель управления-> Язык и региональные Настройки-> Настройки-> Региональный Настройка (кнопка) -> Дата-> Календарь. Как правило, они интерпретируются следующим образом; 0-29 интерпретируется как 2000-2029, от 30 до 99, как и 1930-1999 100-999 100-999 как. Неверно даты, такие как 31 июня 2010 года и 31/9/2010 будут обнаружены. Часть времени, если применимо требует в часах и минутах участие и необязательно секунды часть. Часы, минуты и секунды дополнительные детали, как правило, разделяются двоеточием (':') и часть секунды могут быть указаны с десятичной точкой ('.'). Для получения дополнительной информации о действительных форматов обратитесь к разделу Замечания о .Net Метод DateTime.TryParse .

Наконечник

Рекомендуется использовать по крайней мере 3 письмо формат название месяца (т.е. "Июль" или "Июль") для даты ценностях, а не числового форматирования (например, "7" или "07"), так как эти значения будет проверять через большинстве регионов зависимости на принадлежность проекта Настройки Регион из Файл | Параметры проекта.То есть рекомендуется использовать "15 июл 2010", а не "15/7/2010" или "7/15/2010". В этом примере, "15/7/2010" может не пройти валидацию для "Английский (США)" и "7/15/2010" не удастся за "English (United Kingdom)", однако "15 июл 2010" будет проходить в течение и то и другое.

o A Логическоеимущество может быть истинным или ложным.Это без учета регистра, так ИСТИНА или ЛОЖЬ также может быть использован, однако да, нет, 1, 0 и т.д. будет все неудачу никаких ограничений собственности.

o A Списоксвойство позволяет коллекцию предопределенных значений, таких как Лоу | Средний | Высокий или Сохранить | Обновить | Редизайн | Пенсию и диапазон значений приходит с поля за штуку на имущество либо как запятая или трубы "|" разделенные ценности. Свойство может считаться порядковый (в отличие от номинальной, или интервала соотношение), потому что при использовании на графиках и цветных элементов на схемас и 3ds значения рассматриваются просто в порядке возрастания (или убывания) порядка. Это значения приведены в порядке возрастания (или убывания) заказ на осях диаграммы или цветовых диапазонов.

8. Тип данных может быть установлена Отключено, Предупредил или Насильственныещелкнув правой кнопкой мыши на поле Type данных для любой настройки, кроме текста, что позволяет любые символы, так никогда не может быть неправильным.

9. Установить необходимыефлаг для нового свойства.

Заметка

Требуемое поле может быть использовано, чтобы указать, нужно ли значение вводится для свойства. Это то, что это не может быть пустым или пустой. Ложьпо умолчанию и означает, что имущество может быть пустым или пустой, Правдаозначает, что собственность должна иметь значение и не может быть пустым или пустой. Требуемое может быть установлено Отключено, Предупредил или Насильственныещелкнув правой кнопкой мыши на поле требуется, если он был установлен в True.

Смотрите также

Заполнение архитектуру - Обзор | Добавление заданных свойств компонента, связи или типа | Совокупные свойства


Изменение настроек регион проекта в

Навигация: Заполнение архитектуру> Свойства>

Изменение настроек регион проекта в

Отправить комментарии на эту тему.

Значения свойств требуют определенных форматирование в различных регионах, чтобы соответствовать любой Тип данных для ограничения Integer, Decimal и даты / времени свойства. Например, в Австралии десятичной "сто двадцать три тысячи четыреста пятьдесят шесть и семь десятых восемь девять" представлена ​​как "123,456.789", в то время как в Германии он будет represnted как "123.456,789", а во Франции это было бы " 123 456 789 ".Точно так же, как в США "второй декабря 1970" представлена ​​в виде короткого дня, как "12/2/1970", но в Великобритании она представлена ​​как "2/12/1970" и в Польше "1970-12 -02 ". Соответственно, чтобы работать с проектом ABACUS по регионам глобальная настройка на проект ABACUS требуется.

Изменить Настройки Регион проекта счеты в

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Выбрать Файл | Параметры проекта ... и в диалоговом окне, которое появляется выберите Область а также нажмите кнопку ОК, Примечание: Пожалуйста, обратитесь к разделу ниже для региональных дефолтов.

Заметка

Если вы не видите Параметры проекта ... пункт менюто вы не имеете Designer и администратор добавитьs а также Вы не можете изменить регион проекта.Кроме того, если ни один регион не установлен (т.е. области в Параметры проекта является «Отсутствует (Система Регион)"), то каждый MS Windows параметров текущей культуры пользователя (т.е. региональных настроек)используются для проверки свойств.

Регион по умолчанию

В следующей таблице перечислены по умолчанию для каждого региона, а установленные через Файл | Параметры проекта ... пункт меню.Пожалуйста, смотрите ниже таблице приведен список символов, используемых.

Область | Символ десятичной | Цифра группировка | Минус | Короткое время | Много времени | AM / PM символ | Краткое Дата | Длинные Дата
Английский (Австралия) | . | , | - | Чч: мм | Чч: мм: сс | М. | ВЕЧЕРА | дд / мм / гггг | дд ММММ гггг
Английский (Великобритания) | . | , | - | Чч: мм | Чч: мм: сс | М. | ЛС | дд / мм / гггг | дд ММММ гггг
Английский Соединенные Штаты) | . | , | - | ч: мм TT | ч: мм: сс тт | М. | ЛС | М / д / гггг | DDDD, ММММ дд, гггг
Французский (Франция) | , | пространство | - | Чч: мм | Чч: мм: сс | | | дд / мм / гггг | DDDD д ММММ гггг
Немецкий (Германия) | , | . | - | Чч: мм | Чч: мм: сс | | | ДД.ММ.ГГГГ | DDDD, д. ММММ гггг
Итальянский (Италия) | , | . | - | Чч: мм | Чч: мм: сс | | | дд / мм / гггг | DDDD д ММММ гггг
Испанский (Испания) | , | . | - | H: мм | Н: мм: сс | | | дд / мм / гггг | DDDD, DD 'гггг' де мммм 'де'
Английский (Канада) | . | , | - | ч: мм TT | ч: мм: сс тт | М. | ЛС | дд / мм / гггг | MMMM-DD-уу
Французский (Канада) | , | пространство | - | Чч: мм | Чч: мм: сс | | | гггг-мм-дд | d MMMM гггг
Арабский (U.A.E.) | . | , | - | чч: мм TT | чч: мм: сс тт | ص | م | дд / мм / гггг | дд ММММ, гггг
Арабский (Саудовская Аравия) | . | , | - | чч: мм TT | чч: мм: сс тт | ص | م | дд / мм / гг | дд / MMMM / гггг
Английский (Южная Африка) | , | пространство | - | чч: мм TT | чч: мм: сс тт | М. | ЛС | гггг / мм / дд | дд ММММ гггг
Английский (Новая Зеландия) | . | , | - | ч: мм TT | ч: мм: сс тт | утра | p.m. | д / MM / YYYY | DDDD, D ММММ гггг
Английский (Индия) | . | , | - | Чч: мм | Чч: мм: сс | М. | ЛС | дд-ММ-ГГГГ | дд ММММ гггг
Немецкий (Швейцария) | . | ' | - | Чч: мм | Чч: мм: сс | | | ДД.ММ.ГГГГ | DDDD, д. ММММ гггг
Французский (Бельгия) | , | . | - | Чч: мм | Чч: мм: сс | | | д / MM / YYYY | DDDD д ММММ гггг
Голландский (Бельгия) | , | . | - | H: мм | Н: мм: сс | | | д / MM / YYYY | DDDD д ММММ гггг
Чехия (Чешская Республика) | , | пространство | - | H: мм | Н: мм: сс | доп |. ОРС. | d.M.yyyy | д. ММММ гггг
Датский (Дания) | , | . | - | Чч: мм | Чч: мм: сс | | | дд-ММ-ГГГГ | д. ММММ гггг
Греческий (Греция) | , | . | - | ч: мм TT | ч: мм: сс тт | πμ | μμ | D / M / гггг | DDDD, D ММММ гггг
Финский (Финляндия) | , | пространство | - | H: мм | Н: мм: сс | | | d.M.yyyy | д. Гггг MMMM'ta '
Венгерский (Венгрия) | , | пространство | - | H: мм | Н: мм: сс | де |. дю. | yyyy.MM.dd. | гггг. MMMM d.
Голландский (Нидерланды) | , | . | - | H: мм | Н: мм: сс | | | д-М-гггг | DDDD д ММММ гггг
Норвежский букмол (Норвегия) | , | пространство | - | Чч: мм | Чч: мм: сс | | | ДД.ММ.ГГГГ | д. ММММ гггг
Польский (Польша) | , | пространство | - | Чч: мм | Чч: мм: сс | | | гггг-мм-дд | d MMMM гггг
Русский (Россия) | , | пространство | - | H: мм | Н: мм: сс | | | ДД.ММ.ГГГГ | d MMMM гггг "г."
Шведский (Швеция) | , | пространство | - | Чч: мм | Чч: мм: сс | | | гггг-мм-дд | вертепом "D ММММ гггг
Корейский (Корея) | . | , | - | тт ч: мм | тт ч: мм: сс | 오전 | 오후 | гггг-мм-дд | ГГГГ '년' M '월' D '일 "DDDD
Иврит (Израиль) | . | , | - | Чч: мм | Чч: мм: сс | М. | ЛС | дд / мм / гггг | DDDD DD ММММ гггг

Следующие символы используются для указания способа отображения даты и времени:

Время символы |
h | Час (чч отображает час с нулем)
m | Минуту (мм отображает минуту с нулем)
s | Во-вторых (сс отображает второе с нулем)
TT | Член-корреспондент или мол
ч / Н | 12 или 24 часовой дисплей
Встречи символы |
д, дд | День
DDD, DDDD | День недели
M | Месяц
y | Год

Смотрите также

Заполнение архитектуру - Обзор | Изменение свойств компонента, связи или типа | Добавление заданных свойств компонента, связи или типа


Совокупные свойства

Навигация: Заполнение архитектуру> Свойства>

Совокупные свойства

Отправить комментарии на эту тему.

Операция "Совокупный Свойства"Позволяет добавлять значения аналогичных свойств вместе и написать (или добавить) результат в свойства выбранной из родительского элемента. Это также позволяет определить область агрегации и стоит ли обновлять свойства всех суб-элементов или нет.

Для совокупности свойств

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Щелкните правой кнопкой мыши на элементе (архитектура, компонент или соединение), в котором, чтобы сделать агрегацию и выберите Совокупные свойства.

3. Выберите один из вариантов агрегат (Траверс всех подуровней или Только прямой Подуровень). Если вы выбрали Траверс всех подуровнейВы также можете выбрать опцию ли Обновление Подуровни.

o Траверс всех подуровнейозначает, что объем агрегации будет включать элементы по всем уровням в соответствии выбранной элемента.

o Обновление Подуровниможет быть сделано только если вы также выбрали опцию Траверс всех подуровней, Это означает, что, когда вы агрегировать свойства снизу вверх, совокупный результат на каждом уровне также будут обновлены в каждый из соответствующих элементов.

o Только прямой Подуровеньозначает, что только свойства элементов, непосредственно ниже выбранного элемента будут объединены.

o Выбрать Включают СтандартСвойстваесли вы хотите свойства, определенные в стандарты быть включенным. В противном случае, будет использоваться только свойства, уникальные для каждого экземпляра компонента.

4. Выберите, какие свойства вы хотите, чтобы объединить. Они сгруппированы в свою Виды.

5. Нажмите следующийКнопка.

6. Выберите опцию ли Значения перезаписи или Добавить значенияв выбранном элементе.

o Значения перезаписизапишет результаты непосредственно в свойствах выбранного элемента.

o Добавить значениядобавим результаты с существующими свойств выбранного элемента.

Смотрите также

Добавление заданных свойств компонента, связи или типа | Изменение свойств компонента, связи или типа | Оценка архитектуру


Анализируя архитектуру

Навигация: Анализ архитектуру>

Анализируя архитектуру

Отправить комментарии на эту тему.

После того как вы заполнили (и, возможно, моделируется) архитектуру, вы готовы, чтобы использовать счеты проанализировать его. Анализируя его, можно определить, если ваша архитектура будет соответствовать вашим потребностям.

Можно анализировать архитектуру в различных способов:

· Схема

· 3D Посмотреть

· Стандартные карты (пирог, линия, колонка, бар и т.д.)

· пользовательские графики ( время отклика , Возможность пространство , звездочный участок , рассеивания матрица а также пузырьковая диаграмма )

· Архитектура Разница

Заметка

При создании диаграммы, 3D Посмотреть, Отчет или стандартный график, то стандартный элемент окна выбора используется для выбора элементов, которые вы хотите просмотреть.

Смотрите также

Заполнение архитектуру | Имитация архитектуру | Построение диаграмм Инструмент


Стандартный элемент Выбор

Навигация: Анализ архитектуру>

Стандартный элемент Выбор

Отправить комментарии на эту тему.

При создании диаграммы, 3D Посмотреть, Отчет,стандартной диаграммыили запуска симуляции, То стандартное окно выбора элемент используется для выбора элементов, которые вы хотите проанализировать / вид.

Окно стандартного элемента Выбор

Pulldowns

· Фильтр по Вид будем включают элементс из ранее сохраненного зрения (т.е. схема, диаграмма, 3D). Таким образом, вы можете выполнять комплекс «присоединиться» запросы обработкой другой вид, как спас "запроса".

Флажки

· Показать УровниГруппа воля элемент в соответствии с уровнем, с помощью которых они происходят в дереве. Уровень 1 является самый верхний уровнем.

· Показать Типысгруппировать элементы по типам, что они будут.

· Родители выбранбудет включать в себя родительские элементы любых выбранных элементов. Таким образом, вы можете гарантировать, что выше любых детей только иерархия будет включен для "снизу-вверх" выбор.

· Дети выбраныбудет включать в себя детям элементы любых выбранных элементов. Таким образом, вы можете гарантировать, что только иерархия ниже любых родителей будут включены для "сверху-вниз" выбор.

· Имя Матчи значениебудет включать в себя только те элементы, которые имеют имя, содержащее указанную строку (Пожалуйста, обратите внимание: масок (т.е. и *) можно использовать?). Таким образом, вы можете сформировать «семантический» запрос.

· Имеет тип недвижимости / Название / значениебудет включать в себя только те элементы, которые имеют тип недвижимости, имя и значение, содержащее указанную строку или непосредственно на элемент или на его стандартов (Обратите внимание:?.? масок (т.е. и *) может использоваться, например * в поле значение дать все элементы, которые имеют не пустое значение для данного свойства). Таким образом, вы можете сформировать «семантический» запрос.

· Имеет стандартбудет включать в себя только те элементы, которые имеют стандартный имя, содержащее указанную строку (Обратите внимание: масок (т.е. и *) может использоваться, например HP * даст все элементы, по крайней мере, один стандарт, начинающиеся с букв Н и Р?.). Таким образом, вы можете сформировать «семантический» запрос.

· Компоненты / Подключения прилагается в избранноебудет включать в себя все подключенные элементы тех, которые были выбраны. Таким образом, можно выборе "звонок-дерево" или "воздействие-анализ".

Заметка

Если у вас есть и Показать Уровни а также Показать Типывыбрана, то вы можете выбрать, чтобы уровни дерево шоу первого или типа сначала кнопку, которая появится над двумя флажками.

Наконечник

После того, как элемент выбран в окне стандартного элемента выбора, это не будет предметом каких-либо дальнейших изменений фильтров до тех пор, пока не выбран. Поскольку нет родной способ поиска для двух различных наборов элементов сразу (например, компоненты со стандартными А или стандартный B), вы можете искать в первую очередь для одного набора, выберите нужные компоненты, а затем выполнить второй поиска для второго набора ,

Кнопки

· Всевыбирает все элементы.

· Инвертироватьотменяет все выбранные элементы и выбирает все те, которые не были выбраны.

· Никтоотменяет все элементы.

· Добавить фильтрвыбирает результате содержание текущих настроек фильтра и позволяет выбрать дополнительного контента, как эффективно А.Н., или присоединиться фильтр.

Смотрите также

Анализируя архитектуру


Просмотр 3D-диаграммы

Навигация: Анализ архитектуру> 3D диаграммы>

Просмотр 3D-диаграммы

Отправить комментарии на эту тему.

ABACUS позволяет просматривать вашу архитектуру в виде 3D, где свойств компонента и соединительные связанного с цветами, формами и размеров.

Для просмотра 3D-вид вашей архитектуры

1. Убедитесь, что вы есть открыть файл ABACUSсодержащий ваши населенный архитектура.

2. Разверните Просмотрыветвь дерева.

3. Разверните 3Dветвь дерева.

4. Двойной клик визуализация вы хотите открыть.

- или -

1. Убедитесь, что вы есть открыть файл ABACUSсодержащий ваши населенный архитектура.

2. Выбрать Вставить| 3Dили нажмите кнопку на панели инструментов.

3. Открыть существующийвизуализация (.abacus3d)

- или -

1. Убедитесь, что вы есть открыть файл ABACUSсодержащий ваши населенный архитектура.

2. Выбрать Вставить| 3Dили нажмите кнопку на панели инструментов.

3. Создать новый визуализации:

· Выберите АрхитектураВы хотите, чтобы вид из выпадающего меню.

· Выберите Компоненты а также СвязиВы хотите, чтобы включить в диаграмму с стандартный элемент окна выбора .

· Ассоциированные цвета, формы и размеров с Комплектующие Типы а также Свойства.

· Ассоциированные цвета и формы с Типы подключения а также Свойства.

Чтобы экспортировать 3D вид

1. Убедитесь, что вы есть открыть существующий 3D вид.

2. В раскрывающемся меню 3D-вид в выберите Файл | Экспорт ...и выбрал местоположение и тип файла для файла визуализации (.abacus3d, .vrml или .html).

3. Нажмите Сохранить.

Смотрите также

Анализируя архитектуру | Навигация в 3D | Диаграмм инструмент


Навигация в 3D-диаграммы

Навигация: Анализ архитектуру> 3D диаграммы>

Навигация в 3D-диаграммы

Отправить комментарии на эту тему.

ABACUS позволяет легко перемещаться по вашей архитектуры в 3D. Опыт похож на полет. Есть два режима навигации:

· Режим Основное управление (по умолчанию); а также

· Режим Advanced Control - изменение этого режима путем выбора Контроль| Режим Advanced Control.

Заметка

Для переключения между базового контроля и дополнительные режимы управления, вы можете использовать F4Функциональность клавиш на клавиатуре.

Режим управления Основные

· Удерживая левую кнопку и перемещая мышь вперед или назад изменяет высоту;

· Удерживая левую кнопку и перемещая мышь влево или вправо изменяет рыскания;

· Удерживая правую кнопку и перемещения кастрюли мышь мнение;

· Проведение обеих кнопок и перемещение мыши вперед или назад, масштабирование и из архитектуры; а также

· Проведение обеих кнопок и перемещение мыши влево или вправо, катится влево и вправо.

- или -

· Нажатие Стрелка влевона клавиатуре или цифровой клавиатуре повернуть налево;

· Нажатие Правая стрелкана клавиатуре или цифровой клавиатуре повернуть направо;

· Нажатие Стрелка вверхна клавиатуре или цифровой клавиатуре увеличения масштаба;

· Нажатие Кнопка "Стрелка внизна клавиатуре или цифровой клавиатуре уменьшения масштаба;

· Прессование Page Upна клавиатуре или цифровой клавиатуры будет браться до; а также

· Прессование Листать внизна клавиатуре или цифровой клавиатуры будет браться вниз.

Режим Advanced Control

· Движущихсямышь вперед и назад, вверх и вниз, изменяет высоту и рыскание (соответственно);

· Прессование W или Стрелка вверхмасштабирование (вперед) в области архитектуры;

· Прессование S или Кнопка "Стрелка внизотъезжает (назад) от зодчества;

· Прессование A или Стрелка влеворулоны слева;

· Прессование D или Правая стрелкарулоны вправо;

· Прессование Q или Листать внизподнимает взгляд (за счет снижения перспективу); а также

· Прессование E или Page Upснижает мнение (путем повышения перспективу).

Режим управления Интерактивная

Нажатие и удержание смена ключана клавиатуре отменяет текущий режим (Basic или Advanced), чтобы войти в режим интерактивного управления. В этом режиме возможно следующее:

· Рулонкурсор мыши над компонентом или связи, чтобы увидеть, какой компонент или название соединения;

· Нажмитена компоненте, чтобы увеличить этот компонент;

· Нажать и перетащитьна компоненте, чтобы вращать вид вокруг этого компонента; а также

· Щелкните правой кнопкой мышикомпонент или соединение и выберите Показать В обозревателевидеть, что компонент или место подключения в дереве.

Общие элементы управления

· Использование ALT-ENTER / ESCдля переключения в полноэкранный режим;

· Использование F2чтобы изменить режим отображения. Это также может быть доступен в Посмотреть Меню.

· Использовать колесико мыши или +/-чтобы изменить скорость. Скорость обозначается числом в нижнем левом углу - показано только тогда, когда она меняется. 1 медленным и 100 является самым быстрым.


Просмотр стандартный график

Навигация: Анализ архитектуру> Стандартные карты>

Просмотр стандартный график

Отправить комментарии на эту тему.

Стандартные карты АБАК "включают в себя линию, бар, колонка, площадь, разброс, пирог, кривая Парето, шаг, поверхность, радар, куб, пирамида, пончик, контур и диаграммы площадь кривой. После того, как вы выбрали тип диаграммы вы хотите, остальная часть процесса для просмотра каждого из этих графиков является то же самое.

Для просмотра стандартного график вашей архитектуры

1. Убедитесь, что вы есть открыть файл ABACUSсодержащий ваши населенный архитектура, И что у вас есть оцениваетсяваша архитектура.

2. Выбрать Вставить| Диаграммаили нажмите кнопку на панели инструментов. ДиаграммыОткроется окно.

Окно диаграммы

3. Выберите тип диаграммы вы хотите, и установить Параметры диаграммы, а затем нажмите следующий.

Параметры диаграммы

o В ячейкепокажет отношения отдельных элементов к целому. Вы можете использовать пакетный график, когда вы планируете иметь несколько рядов данных (например, несколько свойств), если вы хотите, чтобы подчеркнуть общее.

o С накоплением 100%Сравним процент каждого значения в общей по категориям. Вы можете использовать 100% укладываются в график, когда вы планируете иметь несколько рядов данных (например, несколько свойств), и вы хотите, чтобы подчеркнуть вклад в целом, особенно если общая сумма одинакова для каждого элемента.

o 3D Диаграммапросто отобразить точки данных в 3-D формате для эстетики. Если вы хотите, чтобы отобразить ряд данных по измерению 3-й / г-оси, то используйте опцию серии кластера, описанный ниже.

o Серия по свойствупокажет серию данных для каждого свойства, в конечном счете, выбранной. Если это не остановить, то это свойства станут категории и ряды данных будет для каждого элемента, выбранного.

o Поворот Графикбудет вращаться графике 90 градусов по часовой стрелке, переставляя оси х и у. Эта опция доступна только для линий, шаг и Cube диаграмми особенно полезен для изготовления Milestone диаграммы, как описано во втором наконечнике ниже, Примечание: Колонка и Гистограммы уже "вращается" версии друг друга.

o Серия кластерабудет отображать несколько рядов данных по измерению 3-й / г-оси. Эта опция доступна только для колонке, Бар и Cube графикии особенно полезен для создания диаграмм Ганта стиль, как описано в первом Tip ниже.

Наконечник

Вы можете создать Диаграмма Гантас горизонтальными полосами, показывая время / дата свойств для различных элементов по типу Бар диаграммы, а затем выберите опцию Series кластера,Кроме того, когда-то создал, самый левый бар на графике может быть «невидимым», окрашивая его белые, щелкнув правой кнопкой один из баров, выбирая цвет из меню, которое появляется, и выбрав верхний левый цвет из палитры. Кроме того граница для самой левой панели может быть «невидимым», щелкнув правой кнопкой один из баров, выбрав Свойства ... и на вкладке серии в диалоге, который появляется, изменяя эффект границы до None и цвет к началу -Выберите цвет из палитры.

Наконечник

Вы можете создать Веха Диаграммас небольшой формы показывая время / дата свойств для различных элементов, выбрав тип диаграммы куб, а затем выбрав Повернуть диаграмму и варианты серии кластера,Кроме того, когда-то создал, кубики могут быть изменены на другие формы, щелкнув правой кнопкой один из кубов в данной серии данных и выбрав Свойства ... и на вкладке серии в диалоге, который появляется, изменяя Бар либо цилиндра или конуса , Примечание: Ширина величины зазора также может быть использован, чтобы 'сжать' символов на графике, чтобы уменьшить перекрытие, тем выше число, тем меньше перекрывание будет.

4. в Архитектурыраздел, отметьте архитектура / с, которые вы хотите, чтобы наметить свойства на уровне архитектуры, затем нажмите кнопку следующий.

Заметка

Выбор свойства на уровне архитектуры является совершенно необязательный шаг и должны быть использованы только тогда, когда вы хотите явно наметить сами свойства на уровне архитектуры.Архитектура не должны быть выбраны, чтобы затем включить компонент или соединений свойства в следующем шаге.

5. Выберите Компоненты а также Связичто вы хотите на графике от стандартный элемент окна выбора , А затем нажмите следующий.

6. Выберите СвойстваВы хотите в графике и нажмите Конец.

Параметры диаграммы

o Включают в себя стандартные свойства будем показать наследуемые свойства от Стандартов, доступных для выбора.

o Совокупные свойства будем рассчитывать дисперсию между значениями серии и наметить те результаты, в отличие от индивидуального значения себя.Эта опция доступна, только если опция серии по собственности был выбран в шаге 3 выше.

Наконечник

Свойства, доступные для построения графиков зависит от элементов, которые вы выбираете.

Чтобы сохранить диаграмму

Заметка

Графики могут быть сохранены только если они содержат только компоненты и соединения, которые все должны быть из одной архитектуры в рамках текущего проекта.

1. Убедитесь, что у вас есть новый или существующий график открытыйи вы сделали необходимые изменения.

2. В панели инструментов графика нажмите на крайнюю левую Сохранить Графиккнопку, чтобы сохранить график и любые изменения форматирования.

3. в График Имядиалог, который появляется введите имя для диаграммы и нажмите ОК.

Чтобы экспортировать диаграмму

1. Убедитесь, что вы есть существующий диаграмма открытый.

2. В панели инструментов диаграммы щелчком на 2 слева Сохранить как BMPКнопка и выбрал место для диаграммы.

3. Нажмите Сохранить.

Смотрите также

Анализируя архитектуру | Просмотр диаграммы времени отклика | Просмотр космических возможностей график


Просмотр космических возможностей график

Навигация: Анализ архитектуру> Пользовательские графики>

Просмотр космических возможностей график

Отправить комментарии на эту тему.

Потенциал для космических график позволяет просматривать, отвечает ли ваша архитектура необходимое возможности системы по отношению к свойствам, выявленных в ходе процесса анализа требований к системе.

Для просмотра космических возможностей график

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура, И что у вас есть оцениваетсяваша архитектура.

2. Выбрать Вставить| Диаграмма| Пользовательские Графики| Возможность пространство, (The Возможность пространство Диаграмма конфигурацииПоявится диалог.)

3. в Архитектурыраздел, отметьте архитектур, которые вы хотите графике, затем нажмите кнопку следующий.

4. в Свойстваплощадь, отметьте архитектурные свойства вы хотите включить в качестве осей графика.

5. в Возможностьплощадь, для каждого свойства включены с предыдущей стадии, выберите существуют ли какие-либо минимальные или максимальные пределы возможностей и значения этих пределов. Значения по умолчанию являются минимальные и максимальные значения оцениваются для архитектур и тому Цель на имущество если он был установлен.

Чтобы экспортировать космических возможностей график

1. Убедитесь, что вы есть существующий Возможность пространство диаграммы открытый.

2. В панели инструментов графика нажмите на крайнюю левую Сохранить как BMPКнопка и выбрал место для диаграммы.

3. Нажмите Сохранить.

Смотрите также

Анализируя архитектуру | Просмотр диаграммы времени отклика


Просмотр диаграммы времени отклика

Навигация: Анализ архитектуру> Пользовательские графики>

Просмотр диаграммы времени отклика

Отправить комментарии на эту тему.

Время отклика график позволяет просматривать ли обрабатываются ваши соединения с требуемой скоростью (то есть в пределах их срока).

Для просмотра времени отклика диаграммы

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура, И что у вас есть оцениваетсяваша архитектура.

2. Выбрать Вставить| Диаграмма| Пользовательские Графики| Время отклика, (The Время отклика График ConfigПоявится диалог.)

3. Из Архитектурыраскрывающийся список, выберите архитектуру вы хотите, чтобы наметить.

4. в Связиплощадь, отметьте соединения вы хотите включить в диаграмме.

5. Масштаб Типобласть, выберите Линейныйесли вы хотите по вертикальной оси (время отклика), которое будет отображаться в виде линейной прогрессии - каждый сегмент времени выделяется равную долю оси. Выбрать Логарифмическийесли вы хотите, отображается как логарифмической прогрессии - каждый сегмент оси представляет более длительные периоды времени, тем выше на оси вы идете. (Скорость увеличения определяется Базавыбрать.)

Время отклика вертикальной шкале оси

Чтобы экспортировать диаграмму времени отклика

1. Убедитесь, что вы есть существующий время отклика график открытый.

2. В панели инструментов графика нажмите на крайнюю левую Сохранить как BMPКнопка и выбрал место для диаграммы.

3. Нажмите Сохранить.

Смотрите также

Анализируя архитектуру | Просмотр космических возможностей график


Просмотр звезда участок ваших развивались архитектур

Навигация: Анализ архитектуру> Пользовательские графики>

Просмотр звезда участок ваших развивались архитектур

Отправить комментарии на эту тему.

После того, как архитектура была развивались и цели определены, то могут быть визуализированы и по сравнению с оригинальной архитектурой, используя звезды участки. В этом разделе описывается, как создавать и манипулировать звезд сюжет.

Для просмотра звезд участок ваших развивались архитектур

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Убедитесь, что вы есть эволюционировали а также Назначать целидля вашей архитектуры, как указано под Развитие архитектуру

3. Выбрать Вставить| Диаграмма| Пользовательские ГрафикиВкладка | Звезда земля.

4. Нажать на КонецКнопка.

5. Звезда земляс эволюционировали архитектур и установить цели будут отображаться. Примечание: Оси звезды участка может быть повторно нажав и перетащив осей к другой области в пределах звездной качества участок пространства.

Заметка

Площадь на левой стороне звездообразной участка показаны параметры звезды участка отображаемой. Это включает в себя архитектуру, которая была развивалась (в данном случае "ABC Ltd как есть 2010»), А также цели, которые были установлены для этой архитектуры. Вы обратите внимание, что цели, которые имеют галочку рядом с их представлены в качестве осей звездной участка (например, КПИ- Стоимость, КПИ - Качество и КПИ - Время). Вы можете убрать галочку этих целей в любой момент времени, чтобы удалить их из звезд участка.

Красные и зеленые "точки", которые появляются на вашем участке звезды представляют собой нормализованное значение, как определено лучших и худших значение (изложенную в Постановка целей для вашего развивалась архитектура ) Для выбранной архитектуры верхнего уровня и любых эволюций него. Эти значения представлены в Космическая качества.

Как указано на картинке выше, ясно видно, что первоначальный архитектура (Как-намечен на 2010 год) Имеет плохое Стоимость, В то время как впервые появились вариант (Для-Be 2011 - Стратегия А) Переехал в качества места для улучшения Стоимость, Качество и времяЦели. Альтернативно, второй вариант развивались (Для-Be 2011 - стратегии Б) в то время как он также улучшил Стоимость величина улучшение меньше, чем у Стратегия A но оба цели качества и времени были улучшены более чем стратегии А.В этом случае архитектора май выберите Стратегия А над Стратегия Bкак их рекомендациии далее развиваться этот вариант (как должно быть 2012 - Стратегия А).

6. Снимите флажок Показать Эволюцияфлажок, чтобы скрыть строку (ы), представляющий эволюцию (ы) между оригинала (например, Как-намечен на 2010 год) И развивались (например Для-Be 2011 - стратегииА) архитектура (ы).

7. Выберите Показать палочкифлажок для отображения относительную величину каждого атрибута качества (цели, которые были определены на каждом осей) для каждой архитектуры.

8. Выберите Показать Архитектура Именафлажок, если вы хотите, чтобы имена исходного и усовершенствованной архитектуры (ы), чтобы появиться на звездной участка.

Смотрите также

Анализируя архитектуру | Просмотр диаграммы времени отклика | Просмотр рассеивания матрицу ваших развивались архитектур | Развитие архитектуру


Просмотр точечный график ваших развивались архитектур

Навигация: Анализ архитектуру> Пользовательские графики>

Просмотр точечный график ваших развивались архитектур

Отправить комментарии на эту тему.

После того, как архитектура была развивались и цели определены, то могут быть визуализированы и по сравнению с первоначальной архитектуры с использованием диаграммы рассеивания матрицы. В этом разделе описывается, как создавать и понимать характеристики рассеивания матрицы.

Для просмотра рассеивания Matrix ваших развивались архитектур

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Убедитесь, что вы есть эволюционировали а также Назначать целидля вашей архитектуры, как указано под Развитие архитектуру

3. Выбрать Вставить| Диаграмма| Пользовательские ГрафикиВкладка | Разброс точек Матрица.

4. Нажать на КонецКнопка.

5. Разброс земляс определенной эволюции архитектур и целей будут отображаться.

Заметка

Область на левой стороне матрицы рассеивания показывает настройки рассеивания матрицы отображается. Это включает в себя архитектуру, которая была развивалась (в данном случае "ABC Ltd как есть 2010»), А также цели, которые были установлены для этой архитектуры. Вы обратите внимание, что цели, которые имеют галочку рядом с их представлены как X и Y осей рассеивания матрицы (например, КПИ- Стоимость, КПИ - Качество и КПИ - Время). Вы можете убрать галочку этих целей в любой момент времени, чтобы удалить их из диаграммы рассеяния матрицы.

Синие точки, которые появляются на вашем участке в матрице представляют собой нормализованное значение, как определено лучших и худших значение (изложенную в Постановка целей для вашего развивалась архитектура ). Эти значения представлены в Космическая качества.

Два определенные цели сравниваются друг с другом в матрице рассеивания и процесс повторяется до тех пор все цели не были сопоставлены (например, первый участок матрицы на рисунке выше сравнивает КПИ - СтоимостьЦель с КПИ - Качество Цель. Второй Стоимость против Время и последний участок Качественный против Время, Соответствующие цель метки будут отображаться в верхней и правой или каждой строки участков.).

6. Выберите Архитектурырадио-кнопки, если вы хотите, чтобы отобразить метрики для отдельных архитектур.

7. Выберите Эволюциярадио-кнопки, если вы хотите, чтобы отобразить нормированные изменения от оригинальной архитектуры (например, Как-намечен на 2010 год) С усовершенствованной архитектурой (ы) (например, Для-Be 2011 - Стратегия А и В-Be 2011 - Стратегия B).

Смотрите также

Анализируя архитектуру | Просмотр диаграммы времени отклика | Просмотр звезда участок ваших развивались архитектур | Развитие архитектуру


Просмотр пузырьковая диаграмма

Навигация: Анализ архитектуру> Пользовательские графики>

Просмотр пузырьковая диаграмма

Отправить комментарии на эту тему.

Пузырь диаграмма позволяет сравнить до 5 размеров (т.е. X, Y, размер пузыря / радиус, пузырь и пузырь цвета границы цвет) в одном месте.

Для просмотра пузырьковая диаграмма

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Выбрать Вставить| Диаграмма| Пользовательские ГрафикиВкладка | Пузырьковая диаграмма.

3. в Архитектурыраздел, отметьте архитектур (если таковые имеются) вы хотите, чтобы наметить, а затем нажмите следующий.

4. Выберите Компоненты а также Связичто вы хотите на графике (если таковые имеются) от стандартный элемент окна выбора , А затем нажмите следующий.

5. Выберите Ось абсцисснедвижимость, а затем нажмите следующий.

Заметка

Только Целое, десятичной, дата / время, логическое и Список свойства может быть использован для X-оси. Кроме того, целое, десятичной и Дата / Время свойства графике слева-направо вдоль оси масштабируется в соответствии со значением свойства, однако, логические и Список свойства просто нанесены слева-направо в точном порядке (или в обратный порядок, если опция, чтобы изменить порядок установлен) определяется на имущество, независимо от их значений. Например. Низкая | Средний | Высокий или 1, 2, 4, 8, 16.

6. Выберите Ось ординатнедвижимость, а затем нажмите следующий.

Заметка

Только Целое, десятичной, дата / время, логическое и Список свойства может быть использован для Y-оси. Кроме того, целое, десятичной и Дата / Время свойства приведены снизу-сверху вдоль оси масштабируется в соответствии со значением свойства, однако, логические и Список свойства просто нанесены снизу-сверху в точном порядке (или в обратный порядок, если опция, чтобы изменить порядок установлен) определяется на имущество, независимо от их значений. Например. Низкая | Средний | Высокий или 1, 2, 4, 8, 16.

7. Выберите размер пузырьков / радиуснедвижимость, а затем нажмите следующий.

Заметка

Только Целое, десятичной, логическое и Список свойства может быть использован для пузырьков размером / радиуса. Кроме того, целой и дробной свойства привести размера пузыря / радиуса масштабируется в соответствии со значением свойства, однако, логические и Список свойства привести в равных шаг увеличивается пузырьковой размер / радиуса в точном порядке (или в обратном порядке, если опция, чтобы изменить порядок установлен) определяется на имущество, независимо от их значений. Например. Низкая | Средний | Высокий или 1, 2, 4, 8, 16.

8. Выберите либо фиксированный цвет пузыря или связать свойство с цветом пузырь, А затем нажмите следующий.

Заметка

Только Целое, десятичной, логическое и Список свойства может быть использован для цвета пузырьков. Кроме того, целой и дробной свойства привести в цвет пузыря в выбранном диапазоне масштабируется в соответствии со значением свойства, однако, логические и Список свойства привести в равных шаг увеличивается в цвет пузыря в выбранном диапазоне в точном порядке, определенных для недвижимость, независимо от их значений. Например. Низкая | Средний | Высокий или 1, 2, 4, 8, 16.

9. Выберите либо нет пузыря цвет границы или связать свойство с пузырь цвет границы, А затем нажмите Конец.

Заметка

Только Целое, десятичной, логическое и Список свойства может быть использован для пузыря цвет границы. Кроме того, целой и дробной свойства привести в пузырь цвет границы в пределах выбранного диапазона масштабируется в соответствии со значением свойства, однако, логические и Список свойства привести в равных шаг увеличивается в пузырь цвет границы в пределах выбранного диапазона в точном порядке, определенных за имущество, независимо от их значений. Например. Низкая | Средний | Высокий или 1, 2, 4, 8, 16.

Пузырьковая диаграмма

Чтобы сохранить пузырьковая диаграмма

Заметка

Пузырьковые диаграммы могут быть сохранены только если они содержат только компоненты и соединения, которые все должны быть из одной архитектуры в рамках текущего проекта.

1. Убедитесь, что у вас есть новый или существующий пузырьковая диаграмма открытыйи вы сделали необходимые изменения.

2. В панели инструментов графика нажмите на крайнюю левую Сохранить Графиккнопку, чтобы сохранить график и любые изменения форматирования.

3. в График Имядиалог, который появляется введите имя пузыря графике и нажмите ОК.

Чтобы экспортировать пузырьковая диаграмма

1. Убедитесь, что вы есть открыть существующий пузырьковая диаграмма.

2. В панели инструментов диаграммы щелчком на 2 слева Сохранить как BMPКнопка и выбрал место для диаграммы.

3. Нажмите Сохранить.

Смотрите также

Анализируя архитектуру


Архитектура и синхронизация Разница

Навигация: Анализ архитектуру>

Архитектура и синхронизация Разница

Отправить комментарии на эту тему.

Если у вас есть 2 или больше архитектур, как и эволюции или исходных архитектур, вы можете визуально 'Diff' два архитектур с помощью каталог или схема сравнения или Архитектура Разница особенность. Это особенно полезно для обнаружения / Re-открытие точные изменения, сделанные от одной архитектуры на другую, как вы развиваться архитектуры и разрабатывать дорожные карты в ABACUS.

Для показать '' Разница с другой архитектуре с помощью диаграммы

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Убедитесь, что вы иметь по крайней мере, 2 архитектуры в проекте.

3. Откройте схему вы хотите сравнить с другой архитектуре.

4. Нажмите кнопку 'Сравнить эту диаграмму с содержанием другой архитектуры "на панели инструментов Диаграмма.

5. Выберите другую архитектуру из раскрывающегося списка, для сравнения.

6. Вы можете фильтровать то, что различия показаны нажав на кнопку «различия» на панели инструментов Диаграмма и сняв варианты, например, Изменено / Добавлено / жительства и Неопределенный / Рекомендуем синхронизации/ Держите Рекомендуем.

Заметка

Компоненты и соединения на диаграмме будут выделены красный, зеленый или пурпурный где есть различия между содержанием, которая видна на текущей диаграммы и содержания в другой архитектуры. Красный используется там, где рекомендуется синхронизировать различия (см ниже), Зеленый используется там, где это не рекомендуется синхронизировать различия, то есть держать их (см ниже) и Пурпурный используется там, где ABACUS не может вынести рекомендацию о синхронизации различия (см. ниже) Только видно содержание на диаграмме сравнивается с тем, если аннотация показывает значение свойства хранилища, и это значение изменяется данного компонента или соединение будет показано в слабый красный, слабый зеленый или слабый фиолетовый и символ '*' показано в верхней левой для компонентов, однако, если некоторые другие базовое значение репозиторий недвижимости изменились, который не показан в аннотации, то на дисплее не будет предоставлена. Содержимое, которое происходит на текущей диаграммы, но не найдено совпадение в архитектуре сравнения не будет показано на сильный красный, сильный зеленый или сильный фиолетовыйи символ '+' показано в верхнем левом для компонентов. Сравнение производится по типу и названию, что если тип или имя компонента или соединения изменилось в другую архитектуру совпадение не будет найдено компонента. Поскольку не существует никакого способа надежно определении дополнительного содержимого с другой архитектуры были бы показаны на текущей диаграмме (например, дополнительный интерфейс между 2 компонентами, как показано ниже на диаграмме от архитектуры сравнения справа), эти различия не показано диаграмм (они показаны для каталогов согласно ниже). При наведении курсора на каждой измененного элемента покажет разницу в подсказке. При наведении на символом '*' в верхнем левом углу диаграммы представлена ​​сводка изменений (или каких-либо изменений) между содержанием диаграмме и содержания другую архитектуру.

Цвет Легенда

· Зеленый указывает предметы, которые не рекомендуется синхронизировать различия, то есть, чтобы держать их.

· Красный указывает предметы, которые он рекомендуется синхронизировать различия.

· Пурпурный указывает пункты, где ABACUS не может вынести рекомендацию о синхронизации различия.

Для синхронизировать ('') синхронизации содержимого из одной архитектуры с другом через диаграммы

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Убедитесь, что вы иметь по крайней мере, 2 архитектуры в проекте.

3. Откройте схему вы хотите сравнить с другой архитектуре.

4. Нажмите кнопку "Сравнить этот каталог с содержимым другой архитектуры" на панели инструментов Диаграмма.

5. Выберите другую архитектуру из списка выпадающего сравнить с.

Заметка

Смотрите выше способом ABACUS показывает '' Разница между 2 архитектур в каталоге. В частности, как Красный используется там, где это являетсяРекомендуется синхронизировать различия, Зеленый используется там, где это неРекомендуется синхронизировать различия и Пурпурный используется там, где ABACUS не может вынести рекомендацию о синхронизации различия.

6. Щелкните правой кнопкой мыши диаграмму элемент (или элементы, используя клавишу Shift или диаграмму холст для синхронизации всех), показывая '' различий и выберите пункт меню Синхронизировать.

Заметка

Любые изменения синхронизации будет применяться только к архитектуре, что в настоящее время в фокусе Каталог принадлежит. Чтобы применить изменения к другой архитектуре необходимо использовать каталог в другой архитектуре. Кроме того, пользователи смогут только, чтобы применить изменения синхронизации, если они есть на это разрешение .

Заметка

В зависимости от того, где вы щелкните правой кнопкой мыши пункт меню будет отображаться руководство по, что именно собирается быть синхронизированы. Например. Щелчок правой кнопкой мыши один компонент на схеме, только синхронизация этот компонент. В то время как правой кнопкой мыши диаграмму и выберите холст синхронизировать все будет синхронизировать все отображаемой в данный момент различия.

Для показать '' Разница с другой архитектуре с помощью каталога

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Убедитесь, что вы иметь по крайней мере, 2 архитектуры в проекте.

3. Откройте каталог, который вы хотите сравнить с другой архитектуре.

4. Нажмите кнопку "Сравнить этот каталог с содержимым другой архитектуры" на панели инструментов Каталог.

5. Выберите другую архитектуру из раскрывающегося списка, для сравнения.

6. Вы можете фильтровать то, что различия показаны нажав на кнопку «различия» на панели инструментов Диаграмма и снимите выделение опции, например, Изменено / Добавлено / жительства и Неопределенный / Рекомендуем синхронизации/ Держите Рекомендуем.

Заметка

Клетки в каталоге будут выделены красный, зеленый или пурпурный где есть различия между содержанием в текущем каталоге и содержание согласования в другой архитектуры. Красный используется там, где рекомендуется синхронизировать различия (см ниже), Зеленый используется там, где это не рекомендуется синхронизировать различия, то есть держать их (см ниже) и Пурпурный используется там, где ABACUS не может вынести рекомендацию о синхронизации различия (см. ниже) Только видимые строки и столбцы в каталоге сравнению, так что если есть разница в ряд за в настоящее время показанных строк или значение в столбце, который не показанной имеет разницу, то никакой разницы не будет показано. Если значение в отдельной ячейке отличается с соответствующим клетки в архитектуре сравнения будут выделены границы ячейки. Селектор заголовок столбца и строки также будет закрашены слабый фиолетовыйи показаны с символом '*'. Эти '*' символы могут быть нажата, чтобы перейти к следующему разницы в строке или столбце, соответственно. Строки, которые происходит в текущем каталоге, но ни в какое сравнение не найдено в архитектуре сравнения будут показаны с '+' символ в селекторе строк слева и границы всего подряд будет выделен. Строки, которые имели бы место в версии сравнение архитектуры в каталога (т.е. с теми же фильтрами и т.д.), но ни в какое сравнение не найдено в текущей архитектуры будет показано с '-' символ в селекторе строк слева, граница весь ряд будет выделен и содержание целые ряды клеток будет показано в слабый фиолетовыйи зачёркнутым, например С 8 утра до 6 вечера, Сравнение производится по типу и названию, что если тип или имя компонента или соединения изменилось в другую архитектуру совпадение не будет найдено компонента. При наведении курсора на каждой измененного элемента покажет разницу в подсказке. При наведении на символом '*' в верхнем левом углу диаграммы обеспечивает краткое изложение изменений (или каких-либо изменений) между содержанием диаграмме и содержимое другой архитектуры.

Цвет Легенда

· Зеленый указывает предметы, которые не рекомендуется синхронизировать различия, то есть, чтобы держать их.

· Красный указывает предметы, которые он рекомендуется синхронизировать различия.

· Пурпурный указывает пункты, где ABACUS не может вынести рекомендацию о синхронизации различия.

Для синхронизировать ('') синхронизации содержимого из одной архитектуры с другом через каталог

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Убедитесь, что вы иметь по крайней мере, 2 архитектуры в проекте.

3. Откройте каталог, который вы хотите сравнить с другой архитектуре.

4. Нажмите кнопку "Сравнить этот каталог с содержимым другой архитектуры" на панели инструментов Каталог.

5. Выберите другую архитектуру из списка выпадающего сравнить с.

Заметка

Смотрите выше способом ABACUS показывает '' Разница между 2 архитектур в каталоге. В частности, как Красный используется там, где это являетсяРекомендуется синхронизировать различия, Зеленый используется там, где это неРекомендуется синхронизировать различия и Пурпурный используется там, где ABACUS не может вынести рекомендацию о синхронизации различия.

6. Щелкните правой кнопкой мыши ячейки, колонки или строки заголовок (или несколько элементов, используя клавишу Shift или Ctrl + A для всего), показывающий '' различий и выберите пункт меню Синхронизировать.

Заметка

Любые изменения синхронизации будет применяться только к архитектуре, что в настоящее время в фокусе Каталог принадлежит. Чтобы применить изменения к другой архитектуре необходимо использовать каталог в другой архитектуре. Кроме того, пользователи смогут только, чтобы применить изменения синхронизации, если они есть на это разрешение .

Заметка

В зависимости от того, где вы щелкните правой кнопкой мыши (т.е. клеток, столбец или строка заголовка) пункт меню будет отображаться руководство по, что именно собирается быть синхронизированы. Например. Щелчок правой кнопкой мыши одно свойство или прикрепленный компонент клетки в каталоге будет синхронизировать только этого имущества или прикрепленный компонент. В то время как правой кнопкой мыши строку заголовок (или заголовки с использованием Shift) будет синхронизировать всю строку (или строки). Щелчок правой кнопкой мыши заголовок столбца будет синхронизировать все различия в этом столбце.

Для просмотра 'разница'2 все архитектуры

1. Убедитесь, у вас есть ABACUS открыть файл .

2. Убедитесь, что вы иметь по крайней мере, 2 архитектуры в проекте.

3. Выбрать инструменты| Архитектура Разница ....

4. В появившемся диалоговом окне выберите первый / С и второй / Для архитектур для сравнения.

5. Нажать на ОККнопка.

Архитектура Разница

Цвет Легенда

· Зеленыйозначает, что узел был добавлен в секунду / архитектуре.

· Красныйозначает, что узел был удален в секунду / архитектуре.

· Синийозначает, что узел имеет различные атрибуты (например, свойства и стандарты) в секунду / в архитектуре.

· Желтыйозначает, что узел имеет отличия в своих детей, во втором / Для архитектуры, так что узел должен быть расширен.

Заметка

Вы можете щелкнуть правой кнопкой мыши и "Показать в Проводнике" на всех узлах, чтобы увидеть детали и больше информации дается на различия в различиях Основная панели при выборе узла.

Смотрите также

Анализируя архитектуру | Просмотр диаграммы времени отклика | Просмотр рассеивания матрицу ваших развивались архитектур | Развитие архитектуру


Имитация архитектуру

Навигация: Имитация архитектуру>

Имитация архитектуру

Отправить комментарии на эту тему.

После того как вы заполнили и проанализированы архитектуру, вы готовы, чтобы использовать счеты, чтобы определить, ваша архитектура будет соответствовать вашим потребностям количественные. Это требует моделирование, Для имитации архитектуру вы должны сначала решить на какую информацию вы хотите, чтобы обнаружить. Эти виды информации, которые часто называют КПЭ или ключевых показателей эффективности. Например, вы хотите, чтобы проанализировать производительность, evolvability и открытость, или вы хотите, чтобы собрать такие показатели, как общая стоимость владения. Вся эта информация может быть раскрыта в некотором роде. Если у вас есть эти данные, вы сможете проанализировать архитектуру в различных графических форматах (или анализировать новые значения непосредственно).

Есть три варианта для моделирования архитектуру:

· Простые показатели ;

· Встроенных тренажеры ; или

· Сценарии .

Простые показатели

Каждый компонент в архитектуре имеет свойства - многие из которых могут быть изготовлены по Вашему применения ABACUS. Эти свойства представляют собой различные характеристики компонентов. В некоторых случаях, просто собирать эти показатели (построить КПЭ) может быть достаточно, чтобы сказать вам важную информацию о вашей архитектуры. Например, KLOCS или тысячи строк кода, которые были широко используется в качестве меры сложности. В других случаях, вы можете экспортировать данные и анализировать его, используя другой инструмент. Кроме того, вы можете собирать свойства после выполнения другой вид моделирования.

Свойства могут быть собраны в процессе агрегация , Объединение добавляет указанные подсвойства в общей который отражается в родительском компоненте. Объединение работает только на компоненты, которые содержат суб-компонентов.

Встроенных Симуляторы

Есть пять встроенных имитаторы, которые могут быть использованы с счеты. Эти:

· Представление;

· Модульность;

· Совокупная стоимость владения (TCO);

· Открытость; а также

· Надежность.

Заметка

ABACUS автоматически выделить, какие из этих тренажеров необходимо повторно запустить через Красный выделяя на Панель инструментов моделирования .

Сценарии

Сценарии обеспечивает гибкость для имитации архитектуру в пользовательских путей. От написания скриптов Вы можете осуществлять моделирование за тока в построенном мощностью ABACUS. Вся модель ABACUS объект доступен в скриптовый движок, так что вы ограничены только вашей способностью писать сценарии!

Visual Basic Script является языком сценариев поддерживается ABACUS, так как он обеспечивает существенные черты программирования в достаточно простом формате.

Смотрите также

Экспорт архитектуру | Совокупные свойства | Написание сценариев


Написание скриптов

Навигация: Имитация архитектуру>

Написание скриптов

Отправить комментарии на эту тему.

Редактор сценария является простым и функциональным утилита для записи и выполнения VB или С # Сценарий против В настоящее время открыт файл ABACUS(Библиотеки, не поддерживаются в сценарии). Он имеет обычную Файл Открыть, закрыть и сохранить команд, так что вы можете сохранить и восстановить сценарии вы пишете. Она также имеет основную запускать и отлаживать центр. Менеджер сценариев позволяет с легкостью выполнять различные скрипты, которые вы написали, помещая Пункт меню для них непосредственно в меню Сервис.

Чтобы получить доступ к Script Editor

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Выбрать инструменты | Редактор скриптови окно редактора сценариев откроется. Тогда либо;

3. Откройте существующий скрипт с помощью файл | открыто в меню редактора сценариев,

или

3. Откройте пример сценария при помощи пример Пункт в меню редактора сценариев,

или

3. Установить язык по умолчанию либо VB или C # с помощью Язык Пункт в меню редактора сценариев,

или

3. Открыть сценариев конкретных помощь через Помогите Пункт в меню редактора Script

При написании сценариев, необходимо придерживаться либо В.Б. или С # синтаксисв соответствии с настройкой под язык пункта в меню редактора Script.

ЗАМЕТКА:

· Чтобы использовать стандартные функции VB как MsgBox ()Вы должны включить Импорт Microsoft.VisualBasicЗаявление в начале вашего скрипта. Это не было необходимо перед Версия 3.0 ABACUS.

· Эта помощь не включает в себя информацию о том, как написать сценарий VB, а также не содержат ссылку VB. Не стесняйтесь писать свои скрипты в вашем любимом IDE или редактора, а затем скопировать и вставить их в редакторе сценариев.

Когда вы впервые запустите редактор сценариев, редактор сценариев будет пустым. Вы можете получить доступ сценарий скелет через меню Примеры. Первый раз, когда вы начинаете свой редактор сценариев, вы должны запустить скелет шаблона, чтобы увидеть, что он работает. Кроме того, существуют два примера сценарии, которые могут быть доступны через меню Примеры.

Чтобы записать полезную скрипт нужно будет ссылаться на ABACUS ObjectModel. Оно доступно в скрипт в том числе по Импорт ABACUS.ObjectModelЗаявление на голове вашего скрипта. Полный справочник для всей модели ABACUS объекта входит в редакторе сценариев. Вы можете найти его, выбрав Помощь | Содержаниеиз окна редактора сценариев.

Редактор Сценарий включает в себя множество полезных функций для написания скриптов, в том числе автозаполнения, как показано на скриншоте ниже. Тем не менее, для еще более богатого пользовательского опыта MS Visual Studio может быть интегрирована с ABACUS и подробные инструкции доступны Вот .

Редактор скриптов с автозаполнения

Чтобы использовать диспетчер Script

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Выберите Инструменты | Менеджер сценариев.

3. Нажать на ДобавитьЗначок и открытоПоявится окно.

4. Перейдите к ABACUS Script (.abacusscript, .vb Или .cs) Файл, который вы хотите добавить в меню Сервис.

5. Нажмите ОКи ссылку на сценарий будет показано в окне диспетчера сценариев. Введите имя для сценария, как вы хотите, чтобы она появилась в меню Tools. Примечание: Окно сценария менеджер может быть изменен, чтобы увидеть полный путь, если необходимо.

6. Повторите шаги 3-5для создания ссылок на более ABACUS скриптов.

7. Нажмите Закрытьзакрыть диспетчер скриптов и обратите внимание, что сценарий ABACUS (ы) в настоящее время появляются в меню Tools.

Чтобы запустить скрипт

Или;

1. Открыть введите в, или скопировать и вставить в сценарий, вы хотите запустить, так что отображается в главном окне Редактор скриптов.

2. Нажмите БегКнопка.

3. Если ваш сценарий содержит ошибки, то ошибки Описание раздела в нижней части редактора сценариев будет перечислить детали, включая номера строк. ЗАМЕТКА: Каждый ошибка в описание ошибки может быть разделе двойном щелчке, чтобы взять Вас к соответствующей строке в скрипте.

- или -

1. Выбрать инструментыа затем Имя ABACUS сценария Пункт меню, как создано с Менеджер сценариев.

2. Если ваш сценарий содержит ошибки, то редактор сценария будет открыт с содержанием сценария, показанного в главном окне (выделено на линии первой ошибки) и описание ошибки секции в нижней части редактора сценариев будут перечислены детали или ошибка (ы), включая номера строк. ЗАМЕТКА: Каждый ошибка в описание ошибки может быть разделе двойном щелчке, чтобы взять Вас к соответствующей строке в скрипте.

Ошибки компиляции скриптов

Ошибки компиляции возникают, когда синтаксис кода сценария не является правильным. Эти ошибки будут отображаться в нижней части окна в разделе Error, с описанием ошибки, и номер строки. Это номер строки, которая отличает ошибку компиляции из Ошибка выполнения (см ниже), которые не будут иметь номер строки. Ошибки компиляции могут быть дважды щелкнуть, чтобы перейти к и выделить конкретную линию в вопросе.

Ошибки выполнения сценариев (Важно)

Ошибки выполнения происходят после того, как код сценария был успешно скомпилирован без ошибок, но возникает ошибка во время выполнения (см примеры дальше вниз). Ошибки выполнения важны, поскольку они могут привести к поврежденных моделей, когда объекты создаются и используются другими объектами в модели, сами по себе не часть модели (обычно из-за ошибки во время выполнения произошла перед кодом, который поставил бы их в модели где был казнен).

Если ваш сценарий создает объекты, которые будут добавлены к модели, вы можете избежать коррупции, вызванной ошибкой выполнения, экономя ваш сценарий, закрывая был, и выполнения отмены изменений, которые были созданы с помощью сценария (если выполнение скрипта не завершаться нормально ). Тем не менее, есть и другие способы, чтобы избежать каких-либо коррупции, происходящих (см ниже). ЗаметкаЛюбые скрипты, которые просто прочитали от модели и не писать в него, являются безопасными и не вызывают каких-либо проблем, независимо от того, происходят ли ошибки во время выполнения во время их исполнения.

Чтобы избежать коррупции, при написании скрипта код, который создаем объекты и добавляем их в объектной модели, он предположил, что объекты будут добавлены к модели как можно скорее, если они ссылаются другие объекты.

Например, если вы создаете новое соединение, и 2 новые компоненты, а затем прикрепляя их вместе, то лучше, чтобы создать первый компонент, добавить его к модели, то второй и добавить его, а затем создать подключение и добавить его, а затем, наконец, создать вложения. Это означает, что если бы быть ошибка времени выполнения, что прерывает выполнение скрипта, все объекты, которые необходимы, чтобы быть в objectmodel, прежде чем вложение создается, в модели. Возможны повреждения, если, например, была добавлена ​​только соединение, вложения сделаны, а затем произошла ошибка выполнения сценария, прежде чем, наконец, добавили новые компоненты в model.Corruption может произойти, когда объект, на который ссылается другим объектом в objectmodel, сама не в objectmodel.

Ошибки во время выполнения Пример включают в себя:

· Ссылка на объект не указывает на экземпляр объекта - это происходит, когда переменная объект является пустой ссылкой, а метод или свойство этого объекта используется. Нулевые ссылки могут быть проверены "Если objectVariable ничего после этого ..."

· Индекс находился вне границ массива - это происходит, когда массив осуществляется доступ с индексом, что находится за пределами - например, меньше 0 или равно или больше, чем длина / графа массива. Массив или длина Коллекция может быть проверена по свойствам .Length или .Count соответственно.

· Нет доступа Исключение - Вы не имеют разрешения на ... - этот происходит, если вы не имеете прав, чтобы сделать данное изменение

· Первичный ключ Исключение - Дублировать / пропавших без вести / Имя ID - это одно произойдет, если изменение сделано с уникальным атрибутом, который конфликтует с другим объектом. Например. Архитектура должна быть уникальной по имени, также с стандартами.

· Ссылочная целостность Исключение - Установка опорного поля на объект, который не является действительным. Например. добавляя «ничего» или нуль в детстве многие из коллекций в objectmodel.

· Нулевой длины Исключение - это может произойти, если вы пытаетесь установить имя объекта в пустую строку. Большинство объектов требуют, чтобы их имена, по крайней мере 1 символ.

Импорт заявления

Следует отметить, что в начале скелета скриптов есть утверждения, такие как Импорт ABACUS.ObjectModel, Эти заявления не будет включать в себя DLL, которые уже не ссылается сценарий - их целью является, чтобы обеспечить '' ярлык для того, чтобы указать полное имя класса.

Например, чтобы объявить переменную типа CComponent (представляющий компонент в ABACUS), с Импорт ABACUS.ObjectModelЗаявление в направлении верхней части сценария, потребуется только его быть объявлен как тусклый комп, как CComponent, Потому что компилятор знает, чтобы посмотреть в пространстве имен ABACUS.ObjectModel для класса CComponent. Без заявления импорт, он должен быть объявлен как тусклый комп, как ABACUS.ObjectModel.CComponent, Узел (например, mscorlib.dll или System.Windows.Forms.dll) может содержать более одного пространства имен - оператор импорта для этих пространств имен, не самих узлов. Сборка ABACUS.ObjectModel.dll имеет только одно пространство имен ABACUS.ObjectModel доступны через сценарии.

Автоматически ссылки сборки

Следующие библиотеки DLL ссылаются автоматически сценарии:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (неявно ссылается компилятор)

· ABACUS.ObjectModel.dll

Для того, чтобы дополнительные ссылки на другие либо сборок .NET, или ваши собственные сборки, смотрите следующий раздел на #ImportDLL заявлении.

#ImportDLL себе

Начиная с ABACUS 3.1, вы можете ссылаться на дополнительные узлы, которые могут вам потребоваться для сценариев с использованием из #ImportDLL заявлении. Например, если вы хотите получить доступ к пользовательской DLL из ваших и использовать функциональные возможности в нем, вы бы разместить его в каталоге ABACUS и включают в себя заявление в качестве первой линии (ы) в вашем сценарии. Если это .NET DLL, то обычно вам не нужно вводить весь путь, только DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL system.Xml.dll

Некоторые другие вещи, чтобы отметить:

1. Поскольку библиотеки DLL должны быть найдены во время компиляции и выполнения, это ограничивает пользовательские (не .NET) библиотеки DLL, чтобы быть помещены в папку ABACUS программу только.

2. #ImportDLL заявления должны быть первая строка (ы) сценария - если у вас есть 5 заявлений, то они должны быть на первых 5 строк сценария

3. #ImportDLL заявление разместить в любом месте, но первые строки сценария (например, если он был помещен после комментария или оператора Imports) не будет работать правильно и / или может привести к несвязанных ошибок компилятора.

#ImportDLL с офиса Ассамблей

Если у вас установлен Microsoft Office, и ваш сценарий требует сборки Управление Interop, можно ссылаться на них просто с помощью #ImportDLL с именем сборки (как указано ниже, например #ImportDLL Excel). Используя этот метод имеет то преимущество, что абсолютный путь DLL не должны быть использованы, так что сценарий является более портативные (должен работать на обоих Office 2003 и 2007 без редактирования скрипта).

При использовании этой функции, ПКК (Global Assembly Cache) ищется сборки взаимодействия, и сценарий компилируется пути к этой сборке, если найден. Если это не найдено, сценариев будет проверять каталог программы ABACUS (который содержит Excel и Visio interops только). Если запрашиваемая Interop не найден в это время, отображается предупреждение.

В interops, как правило, не устанавливается в GAC, если вы установили Microsoft Office перед установкой .NET Framework (который является частью полной установки ABACUS). Вы можете установить их, выполнив Изменить параметр для Microsoft Office с Add / Remove Programs, и выберите .NET варианты программирования. Для получения дополнительной информации, видеть это статья на MSDN.

Узлы, для которых этот ярлык Поддерживаются:

· Доступ

· Access.Dao

· Превосходить

· График

· MSProject

· Прогноз

· OutlookViewCtl

· OWC11

· Силовая установка

· Издатель

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Слово

Iт не совсем ясно, если все вышеперечисленные узлы полезны, комнаты havebeen включены в эту особенность regardeless как некоторые пользователи фев есть необходимость даже для непонятных собраниях.

Смотрите также

Имитация архитектуру


Использование макросов

Навигация: Имитация архитектуру>

Использование макросов

Отправить комментарии на эту тему.

Если вы выполняете задачу неоднократно ABACUS, вы можете автоматизировать задачу с помощью макроса. Соответственно, макро счеты записанный ряд операций, которые могут быть воспроизведены в любое время.

Запись макроса

1. Выберите Инструменты | Запись макросалибо нажмите Alt + F10.

2. Начните выполнять операции, которые вы хотите записать.

Предупреждение

В это время, есть некоторые известные проблемы с записи макросов. При записи макросов Пожалуйста принять это во внимание:

· В настоящее время макрокоманд просто записывать нажатия клавиш Microsoft Windows, мышь-движений и щелчков мыши. Тем не менее, из-за ограничений с самого записи макросов, есть некоторые нажатия клавиш, которые не всегда записанные. К ним относятся:

· [Tab],

· [Ctrl]

· [Alt]

· [Esc]

· [Начало]

· [F1] [F12]

· Поэтому рекомендуется, что вы убедитесь, что сочетание клавиш записывается записи макросов, прежде чем записи большого последовательность событий, которые могут зависеть от этой клавиатуры контекстном работы.

· В настоящее время из-за ограничений с записи макросов, контекстные меню не обрабатываются должным образом ABACUS, когда они открыли действия записанного записи макросов. Когда вы открываете контекстное меню, необходимо выполнить одно из перечисленных функций в контекстном меню с помощью контекстного меню, в противном случае контекстное меню может оставаться открытым во время воспроизведения, которое может привести к непредвиденным действиям или действий, которые могут привести к ошибкам в ABACUS.

· Обратите внимание, что обычные методы закрытия контекстного меню (например, нажатием [Esc] на клавиатуре, или нажатием левой кнопки где-то еще на экране) не может на самом деле закрыть контекстное меню во время воспроизведения макроса.

Наконечник

В диалогах, а не с помощью щелчков мыши, рекомендуется использовать ключ Tab для перемещения по имеющимся управления и клавиш управления курсором выберите в раскрывающемся пункты меню или варианты радио кнопку и клавишу пробела, чтобы выбрать / отменить выбор проверку коробки.

Чтобы остановить запись макроса

1. Нажмите Alt + F9или, альтернативно, выберите Инструменты | Остановить макрос.

2. В Сохранить макрос как диалоговом окне укажите на месте и выбрать ABACUS макро (.abacusmac файла) имя файла и нажмите кнопку Сохранить.

Заметка

С помощью инструменты| Остановить макросбудет включать в себя эту операцию в записанного макроса. Поэтому, рекомендуется, что пользователи стали владеть в использовании функции Alt + варианты ключевых для работы с макросами, чтобы не включать в себя нежелательные операций макросов в самих макросов.

Наконечник

Как макросы в настоящее время не доступны для редактирования рекомендуется записывать длительные задачи в виде серии отдельных макросов с помощью Alt + F10 / Alt + F9 "пар".

Для воспроизведения записанного макроса

1. Выберите Инструменты | Воспроизведение Макролибо нажмите Alt + F8.

2. В диалоговом окне укажите Open Macro в место и выберите счеты макро (.abacusmac файла) имя файла и нажмите кнопку Открыть.

Предупреждение

При открытии макроса ABACUS, если вы дважды щелкните на файле макроса в диалоговом окне просмотра, чтобы открыть его, записи макросов не может держать левую кнопку мыши в левой кнопкой мыши состоянии до A Записанные щелкните левой кнопкой мыши переопределения этого государства.

Заметка

Скорость воспроизведения макроса можно установить на вкладке Общие в разделе инструменты| Опциилибо как обычная (по умолчанию), быстро или медленно. Быстрых и медленных скоростях воспроизведения не рекомендуется, так как они будут воспроизводить записанные макросы примерно в 100 раз и 1/100 в режиме реального времени, соответственно. Нормальная скорость воспроизведения будет по-прежнему воспроизводить макрос примерно 30% быстрее, чем зафиксированная скорость, так что рекомендуется во время записи на паузу в течение короткого времени после любых длительных задач обработки для того, чтобы при воспроизведении следующая операция не выполняется перед задачей обработки имеет завершена.

Чтобы остановить воспроизведение записанного макроса

1. Нажмите Alt + F9.


Моделирование Производительность

Навигация: Имитация архитектуру> Тренажеры>

Моделирование Производительность

Отправить комментарии на эту тему.

Задний план

Архитектурный оценщик для выполнения является дискретным симулятор событий, который работает, имитируя поток сообщений (токенов) или всей архитектуры. Теория позади этого происходит от исследования, проведенного в Университете Технологии, Сиднея, и основывается на Многоуровневая очереди Сетевые модели(LQNM), По времени и цветные Петри-сетей(TCPN) и Активность цикла Диаграммы(ACD).

При моделировании производительности ABACUS, обработка на одном компоненте во многом способствует сообщений переданных ему из другого компонента. Принципы, лежащие в этой технике могут быть поняты в четырех основных частей:

1. сообщение ориентированныхсвязи моделируется в ABACUS с помощью логический(или косвенной) соединения. Логические соединения определяют поведение (частота и данные) сообщений, передаваемых между компонентами. Хорошим примером логических связей будет последовательность потоков между двумя (2) бизнес-процессов или логических интерфейсов между двумя (2) приложений.

2. Логические сообщения транспортируются к месту назначения с помощью иерархия(например, Swimlanes ресурсов) или непосредственныйсоединения (например, физических проводов). Для этого они могут быть направлены вверх, по горизонтали и вниз по иерархии (многоуровневый подход), чтобы следить за прямой путь.

3. Верность модели могут быть скорректированы в соответствии с. Например, процесс может быть разделен вниз так далеко, так что каждый элементарный процесс и функция имеет отдельный след обработки. Альтернативно, это может быть достаточно, чтобы иметь только одно значение для всего процесса, что отражает в среднемответ обработки сообщения.

4. Настоящий обработкавыполняется только для компонентов, имеющих (или) процессор. Процессор является общим вещь, и может быть процессор, лицо, организационная единица или что-нибудь еще, что может выполнении работ. Например, бизнес-процесс не делает каких-либо фактических обработку; это делается в первом '' процессора он находит в любом его родительской иерархии (если используется Swimlane обозначения) или его обработки сети (если используется распределенная обработка обозначения).

Оценка осуществляется путем моделирования (указанный) трафика в системе, например, что каждое соединение моделируется по крайней мере, один раз. Врем прихода сообщений случайным образом в отношении их заданной частоты. Модель имитирует обработку ресурсов и утверждение и очередей сообщений, сбора статистических данных по пути, как различных выходных свойств.

Ключевые факторы Производительность ввода

1. Частота- Частота, на которой происходит соединение.

2. Обработка- Количество времени выполнения, чтобы завершить один процесс. Это может быть в часы, минуты, дни, операции и т.д.

3. Скорость- Скорость ресурса процессора. То есть, сколько циклов / инструкции / действия он может выполнять в единицу времени. Важно, чтобы быть в соответствии с единиц, используемых для обработки.

4. Процессоры- Количество процессорных ресурсов. Процессоры могут быть люди, процессора, внешних организаций и т.д.

Ключевые факторы Производительность Выходные

1. Пропускная способность- Количество сообщений в единицу времени через подключение, Это фактическое значение может быть по сравнению с ожидаемыми теоретическими значениями / (т.е. частота) выводить насыщенность системы.

2. Сообщение Оценить- Количество сообщений в единицу времени через компонент, Это сумма входящих и исходящих сообщений всех компонентов.

3. отклик- Минимальная / средняя / максимальная задержка для этого подключение, Это сумма всех наблюдаемых задержек для связи от источника к раковине и любой очереди и обработки (и задержки обратно к источнику, если двунаправленный).

4. Утилизация- Использование этой компонент, Это будет 0%, если компонент не является устройством / процессор (т.е. не имеют процессоры и свойства скорости, заданной выше).

В то время как моделирование дискретного событие выполняется для расчета различных свойств вывода, как описано выше, следующая формула может быть использована в качестве грубого проверки результатов (где система не насыщенных):

Утилизация = сумма частоты для всех входящих соединений * Обработка / (скорость * Процессоры)

Общая концепция, пожалуй, самый демонстрируется на следующую диаграмму, которая показывает два разных мета-модели производительности. Левая рука стиль классический "Swimlane" обозначение с задачами обработки на основе иерархически в своих процессорных ресурсов. Право ручной стиль является "распространяется" обозначение с задачами обработки, связанных через соединение процессов их ресурсов процессора. Последнее представление позволяет несколько процессорные ресурсы для данного обработки задачи, в отличие от ограниченного нотации Swimlane.

Заметка

Показанный на каждом мета-модели являются входными свойства (в красном) и выходные свойства (в синем):

Мета-модели Производительность: Swimlane против Distributed записи

Запуск симулятора Производительность

Для имитации архитектуру с точки зрения производительности

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Выбрать Анализ| Представлениеили нажмите кнопку на панели инструментов.

3. Выберите АрхитектураВы хотите, чтобы оценить из выпадающего меню.

Заметка

По умолчанию, ABACUS автоматически выберет первую архитектуру, для которой повторная моделирования требуется из-за имеющегося имущества или структурных изменений.Это выделение показано в Красный на Панель инструментов моделирования .

4. Выберите Компоненты а также СвязиВы хотите, чтобы оценить, от стандартный элемент окна выбора .

5. Установить Время работы Коэффициент масштабированияслайдер.

Заметка

Более высокие значения дадут более статистически достоверные результаты, но займет больше времени, чтобы вычислить.

Дополнительный Флажокв стандартный элемент окна выбора

· Sпр трансформированных Модель будем сохранить копию РосБР преобразованной версии проекта в той же папке, что и текущий проект и добавить "_transformed" с именем проекта.Это превратило проект может быть использован для диагностики подробно моделирование надежности, проводимую ABACUS.

Другие варианты в стандартный элемент окна выбора

· Время работы Коэффициент масштабирования контролирует время моделирования и точность с выше значения доходностиINGболее статистически достоверные результаты, но принятие больше времени, чтобы бег.

Заметка

Когда ABACUS вычисляет время моделирования, он будет определять медленный косвенное часто подключения, который был выбран, чтобы быть смоделированы, а затем "разминку" за период (т.е. 1 по частоте) этой связи (инициирование периодических сообщений генераторы для всех соединений в произвольном порядке в течение этого времени прогрева, давая им все шансы начать), а затем имитировать для раз время работы масштабный фактор в период этой связи. Или (1 / частота) время прогрева + (1 / частота) * время работы Коэффициент масштабирования время моделирования. Это, чтобы убедиться, что что все соединения инициируются, прежде чем собираться статистика, а затем медленный соединение все еще моделируется по крайней мере, один раз в симуляции. Например. Если медленный косвенная связь имеет частоту 0,033 временных единиц (или около раз в месяц, если временные единицы дни), то время прогрева будет 30,3 временные единицы и время моделирования будут 30,3 временные единицы раз Время работы Масштабный коэффициент.

6. Нажмите Конеци вы получите ПредупреждениеДиалог.

7. При желании исследовать предупреждения, нажав Подробнее >>.

8. Нажмите Продолжать.

Заметка

В этот момент, ABACUS будет выполнять моделирование дискретных событий архитектуры, и после короткого времени (с индикаторами прогресса для обратной связи) расчет полной появится диалоговое окно.

9. Нажмите ОКпризнать моделирование.

Наконечник

Для учебных курсов и дальнейшей помощи по эффективности моделирования пожалуйста, обратитесь к Avolution сообщество .

Свойства компонента

В следующей таблице перечислены свойства, необходимые для оценки производительности. Свойства искали сначала в экземплярах компонента, то стандарты и компонентный, если не найден, используется по умолчанию.Эти свойства будут показаны в окне Свойства со значком селектора входа недвижимость строка ( [image] ) С подсказки "Производительность ввода. Изменение любого из этих «вход» свойств и различных структурных изменений в хранилище приведет в симуляторе Performance, требующие повторного моделирования, как указано в Красный на Панель инструментов моделирования .

Тип | имя | Значение по умолчанию | Ед. изм | Тип данных | необходимые | Описание
Поведение | b_pack | 0.0 |  | Десятичная дробь | Ложь | Фиксированная служба времени, чтобы упаковать в секундах. Это свойство Обычно указано в качестве стандартного типа, а затем использоваться для нескольких экземпляров компонентов. Например, CORBA имеет b_pack = 0,23 мс.
Поведение | m_pack | 0.0 |  | Десятичная дробь | Ложь | Переменная время обслуживания, чтобы упаковать в секундах / байт. Это свойство Обычно указано в качестве стандартного типа, а затем использоваться для нескольких экземпляров компонентов.
Поведение | b_unpack | 0.0 |  | Десятичная дробь | Ложь | Фиксированная служба времени, чтобы распаковать в секундах. Это свойство Обычноуказано в качестве стандартного типа, а затем использоваться для нескольких экземпляров компонентов.
Поведение | m_unpack | 0.0 |  | Десятичная дробь | Ложь | Переменная время обслуживания, чтобы распаковать в секундах / байт. Это свойство Обычноуказано в качестве стандартного типа, а затем использоваться для нескольких экземпляров компонентов.
Поведение | Обработка | 0.0 |  | Десятичная дробь | Правда | Количество времени выполнения, чтобы завершить один процесс. Это может быть в часы, минуты, дни, операции и т.д.
Поведение | Процессоры | 1 |  | Целое число | Правда | Количество ресурсов процессора. Процессоры могут быть люди, процессора, внешних организаций и т.д.
Поведение | Скорость | 100 |  | Целое число | Правда | Скорость ресурса процессора. То есть, сколько циклов / инструкции / действия он может выполнять в единицу времени. Важно, чтобы быть в соответствии с единиц, используемых для обработки.
Поведение | k_bkgd | 0.0 |  | Десятичная дробь | Ложь | Обработка в фоновом режиме на компоненте. Это используется для корректировки результатов в соответствии с выполненными фиксированные смещения для%. Это, вероятно, может быть проигнорировано.

В следующей таблице перечислены свойства компонента вывод по производительности оценщика. Набор этих свойств компонентов генерируются для каждого компонента на каждой перспективе производительности.Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Производительность Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и симулятор Performance требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Поведение | Сообщение Оценить |  | Десятичная дробь | Ложь | Количество сообщений в единицу времени через компонента. Это сумма входящих и исходящих сообщений всех компонентов.
Поведение | Пропускная способность |  | Десятичная дробь | Ложь | Общая пропускная способность через компонент. Сумма за счет входящих и исходящих сообщений.
Поведение | Утилизация | % | Десятичная дробь | Ложь | Использование компонента. Это будет 0%, если компонент не является устройством / процессор (т.е. не имеют процессоры и свойства скорость определено выше)

Свойства подключения

В следующей таблице перечислены свойства, необходимые для оценки производительности. Свойства искали сначала в случаях подключения, затем стандартам подключения и, если не найден, используется по умолчанию.Эти свойства будут показаны в окне Свойства со значком селектора входа недвижимость строка ( [image] ) С подсказки "Performance вход 'или' цена / производительность ввода". Изменение любого из этих «вход» свойств и различных структурных изменений в хранилище приведет в симуляторе Performance и / или Стоимость тренажера требующие повторного моделирования, как указано в Красный на Панель инструментов моделирования .

Тип

имя

Значение по умолчанию

Ед. изм

Тип данных

необходимые

Описание

Поведение

вид

двунаправленный

[двунаправленный | однонаправленная]

Поиск / Список

Правда

Будь связи двухсторонняя (двунаправленный) или односторонним (однонаправленный).

Допустимые значения для этого свойства "двунаправленный" или "однонаправленный".

Двунаправленный означает, синхронные запрос / ответ сообщения, тогда как однонаправленный средств один асинхронный "событие".

Поведение

Абстракция

косвенное

[косвенное | непосредственный]

Поиск / Список

Правда

Ли связь физического или логического. Прямые соединения являются физическими "трубы" между двумя компонентами, которые текут логические соединения вместе.

Допустимые значения для этого свойства "прямой" или "косвенным".

Если значение "прямой", то соединение не требуется каких-либо других свойств (для свойств рода и абстракции, кроме).

Данные

L_app1

0

Целое число

Ложь

Запрос / размер в байтах событие.

Каждое соединение, как правило, имеют определенное значение для этого. В CORBA, события на самом деле двунаправленным и всегда иметь 12 байт в виду (L_app2). Если это настоящий однонаправленный соединение затем оставить в собственность L_app2.

Данные

L_app2

0

Целое число

Ложь

Ответ / признать размер в байтах.

Каждое соединение, как правило, имеют определенное значение для этого. Однонаправленный соединение не будет L_app2.

Поведение

Частота

1

Десятичная дробь

Правда

Частота, на которой происходит соединение.

Каждое соединение, как правило, имеют определенное значение для этого. Если свойство частоты остается вне затем по умолчанию.

Поведение

Отношения

процессы

[процессы | поддерживает]

Поиск / Список

Ложь

Соединения, которые имеют "процессы", показывают, что свойство компонента в начале соединения будут преобразованы, чтобы быть обработаны на компонент в конце соединения. В результате компонент "источник" перемещается, чтобы стать дитя "тонуть" компонента (прикрепленные соединения также "тащили" с этого шага).

Если "процессы" свойство существует, то все остальные свойства соединения будут игнорироваться, за исключением дополнительного "%" имущества, описанного ниже.

Поведение

%

100,0

Десятичная дробь

Ложь

Соединения, которые имеют "процессы" имущество (описанный выше) можно дополнительно есть "%" свойство, чтобы указать долю переработки, которые будут отнесены к компоненту назначения. Таким образом, один компонент-источник может быть обработан несколькими компонентами назначения на различных% х. В% значения не нужно, чтобы добавить до 100%, и это просто используется для масштабирования "обработки" имущество (см выше) для компонента источника, как он превращается стать ребенком компонента назначения.

В следующей таблице перечислены свойства, порожденные производительности оценщика. Набор этих свойств соединения создаются для каждого соединения на каждом счете производительности.Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Производительность Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и симулятор Performance требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Поведение | Пропускная способность |  | Десятичная дробь | Ложь | Общая пропускная способность соединения. Это рассчитывается только для косвенных связей и, по сути (L_app1 + L_app2) * Пропускная способность.
Поведение | Пропускная способность 1/2 |  | Десятичная дробь | Ложь | Пропускная способность специально для исходящих (1) и входящих (2) сообщений связи. Это рассчитывается только для косвенных связей и, по сути L_app1 * пропускная способность и L_app2 * Пропускная.
Поведение | Пропускная способность |  | Десятичная дробь | Ложь | Количество сообщений в единицу времени через соединение. Это фактическое значение может быть по сравнению с ожидаемыми теоретическими значениями / (т.е. частота) выводить насыщенность системы.
Поведение | Завершен | % | Десятичная дробь | Ложь | Процент сообщений, которые успешно прошли обработку для связи. Это рассчитывается только для косвенных связей и является пропускная способность / частота. Иногда Завершен значение превышает 100%, так как случайность результатов поколения сообщение в чуть более высокой частоте генерации сообщение, чем указано.
Поведение | Ответ (Мин / пр / Макс) |  | Десятичная дробь | Ложь | Минимальная / средняя / максимальная задержка. Это рассчитывается только для косвенных связей и наблюдаемый задержки для подключения от источника к раковине и любой очереди и обработки (и задержки обратно к источнику, если двунаправленный).

Архитектура Свойства

В следующей таблице перечислены общесистемные архитектурные свойства, порожденные производительности оценщика. Один набор свойств для архитектуры "объединяются" для каждого прогона производительности.Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Производительность Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и симулятор Performance требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Поведение | Сообщение Оценить |  | Десятичная дробь | Ложь | Сообщений в единицу времени через компоненты в архитектуре номер. Это сумма входящих и исходящих сообщений всех компонентов.
Поведение | Пропускная способность |  | Десятичная дробь | Ложь | Сообщений в единицу времени через связи в архитектуре номер. Это сумма всех пропускных непрямого подключения ", и это фактическое значение может быть по сравнению с ожидаемыми теоретическими значениями / (т.е. частота) выводить насыщенность системы.
Поведение | Пропускная способность |  | Десятичная дробь | Ложь | Общую ширину полосы пропускания. Сумма полос частот связи с архитектуры.
Поведение | Утилизация | % | Десятичная дробь | Ложь | Использование всех компонентов. Может быть больше, чем 100%, как это просто сумма всех компонентов utilisations архитектуры в.
Поведение | Ответ (Мин / пр / Макс) |  | Десятичная дробь | Ложь | Минимальная / средняя / максимальная задержка. Сумма всех наблюдаемых задержек для соединений архитектуры от источника к погрузиться (и обратно к источнику, если двунаправленный).


Имитация Модульность

Навигация: Имитация архитектуру> Тренажеры>

Имитация Модульность

Отправить комментарии на эту тему.

Модульность симулятор вычисляет количество входящих и исходящих соединений для каждого компонента.

Для имитации архитектуру с точки зрения модульности

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Выбрать Анализ| Модульность.

3. Выбрать Архитектура (ы)Вы хотите включить в оценке.

Заметка

По умолчанию, ABACUS будет автоматически выбирать архитектура (ы), для которых повторное моделирование необходимый из-за каких-либо основополагающих структурных изменений.Это выделение показано в Красный на Панель инструментов моделирования .

4. Нажмите следующий.

5. Выбрать Типы подключения (с)Вы хотите включить в оценке.

6. Нажмите следующий.

7. При желании настроить имена свойств для результатов расчета.

8. Нажмите Конец.

Заметка

В этот момент, ABACUS будет выполнять структурную оценку архитектура (ы) и после короткого времени (с индикаторами прогресса для обратной связи) расчет полной появится диалоговое окно.

9. Нажмите ОКпризнать оценку.

Наконечник

Для учебных курсов и дальнейшей помощи на модульность оценки пожалуйста, обратитесь к Avolution сообщество .

Свойства компонента

В следующей таблице перечислены свойства компонента, которые выводятся на модульность оценщика.Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Модульность Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за структурных изменений основного в хранилище и модульность симулятор требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Тип данных | необходимые | Описание
Модульность | Муфта-вентилятор (местный) | Целое число | Ложь | Количество соединений, которые вентилятор в этом компоненте.
Модульность | Муфта-веером (местный) | Целое число | Ложь | Количество соединений, которые веером этого компонента.
Модульность | Муфта-вентилятор | Целое число | Ложь | Количество соединений, которые вентилятор в этом компоненте, в том числе соединений, которые вентилятор в суб-компонентов.
Модульность | Муфта-веером | Целое число | Ложь | Количество соединений, которые веером этого компонента, в том числе соединений, которые вентилятор в суб-компонентов.


Имитация Совокупная стоимость владения (TCO)

Навигация: Имитация архитектуру> Тренажеры>

Имитация Совокупная стоимость владения (TCO)

Отправить комментарии на эту тему.

Задний план

Совокупная стоимость владения (TCO) является финансовым оценка, предназначен для измерения всего понесенные затраты жизненного цикла (от приобретения до вывода из эксплуатации / утилизации), связанные с принадлежащих активов. ТШО отражает не только затраты на приобретение, это также включает в себя все другие аспекты в дальнейшем использовании и обслуживания актива.

ТШО используется для определения усилий и расходов бюджета приходится тратить на системе. Простой способ моделирования в ABACUS для ТШО является разрушение системы ИТ на компоненты. Мы можем узнать, сколько в среднем стоит запустить один из этих компонентов. После этого мы могли бы фактором в различных затрат в зависимости от того, ИТ-система Evolvable или открыть и т.д. Если система уже работает, главным фактором является стоимость обслуживания и, возможно, стоимость по выводу из эксплуатации.

Пример

Схема Пример расчета

Компонент под организацией или ее стандарт имеет следующие свойства:

· FTE= 100 000 $ / год

· Поддержка усилий= 0,01 + 0,001 FTE FTE / год = 1000 $ + 100 $ / год

· Стоимость технического обслуживания= 100 $ - 10 $ / год

· Капитальные затраты= 2000 $

· Установите усилие= 2 / FTE дней = 0,01 FTE / год = 1000 $

Компонент под организацией имеет следующие свойства:

· Установите Horizon= -2 Лет (т.е. система была установлена ​​2 лет до настоящего времени)

· Продолжительность жизни= 3 года

когда Установите Горизонт + Продолжительность жизни <= 0 , Нет более расходы на техническое обслуживание.

Вычисления

Расчеты таковы:

Заметка

ТК = стоимость за год. SE = Поддержка усилий. МС = стоимости обслуживания.

· Первоначальная стоимость = Стоимость капитала + Установить усилие= 2000 + 1000 = 3000 $

· При Т = -2 (1-й год во время), ТК = Первоначальная стоимость + SE + МС= 3000 + 1000 + 100 = 4100 $

· При Т = -1, ТК = SE + МС= (1000 + 100) + (100 - 10) = 1 190 $

· При Т = 0, ТЦ = (1000 + 200) + (100 - 20) = 1 280 $

· При Т = 1 (окончательный год), ТЦ = (1000 + 300) + (100 - 30) = 1370 $

График для примера расчета

ТШО является суммой всех настоящих и будущих расходов, пока система не была выведена из эксплуатации.

· При Т = -2 (1-й год во время), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· При Т = -1, ТШО = 1190 + 1280 + 1370 = 3840 $

· При Т = 0, ТШО = +1280 + 1 370 = 2650 $

· При Т = 1 (последний год), TCO = 1370 $

Основные факторы затрат

Ключевые факторы стоимости следует учитывать при расчете совокупной стоимости владения актива в ABACUS являются:

· Приобретение Оборудование- Первоначальная стоимость оборудования (стоимость капитала).

· Приобретение программного обеспечения- Первоначальная стоимость лицензии на программное обеспечение (капитальных затрат).

· Монтаж- Расходы, связанные с первоначальной настройки.

· Обучение- Расходы, связанные с внешнего обучения поставщика после первоначальной настройки.

· Поддержка- Расходы, связанные с внутренней поддержки.

· Обслуживание- Расходы заменить или модернизировать поставщика контракты на техническое обслуживание, расходные материалы и расходы аварийного восстановления.

· Инфраструктура- Расходы, связанные с поддержки актив.

ABACUS Пример Представление ключевых факторов затрат

Запуск Стоимость тренажера

Для имитации архитектуру с точки зрения стоимости

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Выбрать Анализ| Стоимость.

3. Выбрать Архитектура (ы)Вы хотите включить в оценке.

Заметка

По умолчанию, ABACUS будет автоматически выбирать архитектура (ы), для которых повторное моделирование необходимый из-за имеющегося имущества или структурных изменений.Это выделение показано в Красный на Панель инструментов моделирования .

4. Выберите валютав выпадающем.

5. Перемещение Лет, чтобы рассчитатьползунок к числу лет, необходимых.

Заметка

По умолчанию, если лет, чтобы вычислить более 1 года расходы будут автоматически рассчитывается для каждого отдельного года (и набор свойств добавлены / обновлены), а затем накопленная величина для всей ряда лет также рассчитывается. Если требуется только накопленная величина, то снимите Рассчитать затраты на Год-Опция, как описано ниже, чтобы сохранить от количества объектов в проекте.

6. Выберите, нужно ли оставить Рассчитать затраты на Год-проверено или снимите его.

7. Нажмите следующий.

8. При желании выбрать СвязиВы хотите, чтобы приписать расходы вместе, как часть оценки.

Заметка

Используя Стоимость | Атрибуциянедвижимость на расходы соединений возможно отнести от компонента, прикрепленного к концу погружения в соединении с компонентом, прикрепленной к стороне источника(т.е. стоимость | авторства = "Раковина на источник"), или от компонента, прикрепленного к источник Конец связи с компонентом прилагается к раковина конец(т.е. стоимость | авторства = "Источник тонуть"), Дополнительно, ABACUS будет автоматически выбирать те связи с поведения | Отношения = "процессы" или "Опоры"и направление атрибуции будет "Раковина на источник", Кроме того, затраты распределяются по любому поведения | % Или Стоимость | % Свойства на связи, или, альтернативно, где есть несколько соединений из раковины для многих источниковили источник многих раковин, По любому поведения | Технологические свойства на исходных компонентовили раковина компоненты соответственно.

9. Нажмите Конеци вы получите ПредупреждениеДиалог.

10. При желании исследовать предупреждения, нажав Подробнее >>.

11. Нажмите Продолжать.

Заметка

В этот момент, ABACUS будет осуществлять деятельность на основе калькуляции оценку архитектура (ы) и после короткого времени (с индикаторами прогресса для обратной связи) расчет полной появится диалоговое окно.

12. Нажмите ОКпризнать оценку.

Наконечник

Для учебных курсов и дальнейшей помощи от стоимости моделирования пожалуйста, обратитесь к Avolution сообщество .

Компонент и / или соединения Свойства

В следующей таблице перечислены компонент и / или соединение свойства, необходимые для оценки стоимости.Эти свойства будут показаны в окне Свойства со значком селектора входа недвижимость строка ( [image] ) С подсказки "Стоимость входа". Изменение любого из этих «вход» свойств и различных структурных изменений в хранилище приведет в стоимость тренажера, требующего повторного моделирования, как указано в Красный на Панель инструментов моделирования .

Тип

имя

Значение по умолчанию

Ед. изм

Тип данных

необходимые

Описание

Стоимость

Установите Horizon

0

лет

Целое число

Правда

Указывает, когда компонент или соединение был, или будет установлен.

· Значение 0 (по умолчанию) указывает, что компонент или соединение будет установлен в текущем году.

· Значение меньше 0 показывает, что компонента или соединение был установлен в прошлом.

· Значение больше 0 указывает, что компонент или соединение будут установлены в будущем.

Стоимость

Продолжительность жизни

0

лет

Целое число

Правда

Указывает длину времени, в котором компонент или соединение будет оставаться в эксплуатации, после чего он будет выведен из эксплуатации.

Стоимость

FTE

100,000.00

$ / год

Десятичная дробь

Ложь

Годовая стоимость каждого работника полный рабочий день.

Если это свойство не найдено в компонентеСам или в случае соединений компонент присоединен к концу раковины соединения, Он будет искать в других компонентах.

В первую очередь, любой "раковина" компонентs в конце a связь с "поддерживает" отношения к компоненту будут найдены, а затем что "раковина" родителя компонентас.

Если свойство FTE не найден, компонента родительзатем будет искать -компонент. Если FTE до сих пор не найден, используется значение по умолчанию.

Обратите внимание: FTE только действительный входной недвижимость на компоненты.

Стоимость

Расходы на техническое обслуживание (фиксированная)

0.00

$ / год

Десятичная дробь

Ложь

Годовой фиксированная стоимость поддержания компонентили соединение.

Стоимость

Расходы на техническое обслуживание (переменная)

0.00

$ / год

Десятичная дробь

Ложь

Сумма, на которую общая стоимость поддержания компонент или соединение изменится каждый год.

Например, значение $ -500 показывает, что общая стоимость обслуживания уменьшается $ 500 каждый год, в то время как значение $ 500 означает, что общая стоимость обслуживания увеличивается на $ 500 каждый год.

Стоимость

Поддержка усилий (фиксированная)

0.00

FTE / год

Десятичная дробь

Ложь

Годовой фиксированной усилия в поддержке компонентили соединение, Определяется в терминах человеко-лет.

Стоимость

Поддержка усилий (переменная)

0.00

FTE / год

Десятичная дробь

Ложь

Сумма, на которую общая работа в поддержке компонент или соединение изменится каждый год.

Например, значение -0.01 указывает, что общее усилие поддержки уменьшается на 0,01 человеко-лет ежегодно, в то время как значение 0,01, что указывает на то, что общий объем поддержки усилий возрастает ежегодно 0,01.

Стоимость

Капитальные затраты

0.00

$

Десятичная дробь

Ложь

Первоначальная стоимость приобретения компонентили соединение.

Стоимость

Установите усилие

0.00

FTE

Десятичная дробь

Ложь

Усилия, необходимые, в человеко-лет, чтобы установить компонентили соединение.

В следующей таблице перечислены компонент и / или соединение свойства, которые выводятся на оценщика ТШО. Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Стоимость Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и стоимость тренажера требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Заметка

Где выход из свойства оценщика TCO должны быть "округляется" "круглый половину даже" подход (называемый также "банкиры" округления) используется.Этот метод используется для более равномерного разрешить любой .5 округляется "тай-брейки» с результатом вверх или вниз до ближайшего даже Результат, а не всегда округления вверх или вниз и перекос результат. То есть 2.5 округляется до 2, а 3.5 округляется до 4, а не их обоих время либо округляется до 2 и 3 или округляется до 3 и 4.

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Стоимость | Общая стоимость Собственность - следующая х лет. | $ | Целое число | Ложь | Общая стоимость владения в течение следующего xлет, где х длина времени, указанный при запуске оценщика. Это включает в себя стоимость компонента или соединение-х стандарты, к югу-компонентыили суб-соединения(то есть дети) и любые приписываемые расходы.
Стоимость | Общая стоимость Собственность (местный) - рядом х лет. | $ | Целое число | Ложь | «Локальной» стоимость владения в течение следующего xлет, где xдлина времени, указанный при запуске оценщика. Это делает невключают в себя стоимость суб-компонентов компонента или суб-соединения Подключение по (то естьдети) или какие-либо приписывали расходы.
Стоимость | Общая стоимость Собственность (детей) - в следующем х лет. | $ | Целое число | Ложь | Стоимость «Дети» собственности в течение следующего xлет, где х длина времени, указанный при запуске оценщика. Эта только включает в себя стоимость суб-компонентов компонента или суб-соединения Подключение по (то есть дети).
Стоимость | Общая стоимость Собственность (приписывается) - в следующем х лет. | $ | Целое число | Ложь | СО «отнести» стоимость владения в течение следующего xлет, где х длина времени, указанный при запуске оценщика. Эта только включает в себя каких-либо приписываемые расходы из прикрепленного к нему оборудования(который, конечно, может включать отнести расходы от любых приложенных соединений).

В следующей таблице перечислены компонент и / или соединение свойства, которые выводятся на оценщика ТШОесли Рассчитать Пер-Год расходы опция. Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Стоимость Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и стоимость тренажера требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Заметка

Смотрите примечание выше о возможном округления выходных свойств.

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Стоимость | Общая стоимость Собственность - год Икс. | $ | Целое число | Ложь | Общая стоимость владения для год x, Где х за каждый год указано при запуске оценщика. Это включает в себя стоимость компонентаили соединение-х стандарты, к югу-компоненты или суб-соединения (то есть дети) и любые приписываемые расходы.
Стоимость | Общая стоимость Собственность (местный) - год Икс. | $ | Целое число | Ложь | «Локальной» стоимость владения на год x, где x является за каждый год указано при запуске оценщика. Это делает невключают в себя стоимость суб-компонентов компонента или суб-соединения Подключение по (то есть дети) или какие-либо приписывали расходы.
Стоимость | Общая стоимость Собственность (детей) - год Икс. | $ | Целое число | Ложь | СО «детский» стоимость владения на год x, Где х за каждый год указано при запуске оценщика. Эта только включает в себя стоимость суб-компонентов компонента или суб-подключение Подключение по (то есть дети).
Стоимость | Общая стоимость Собственность (приписывается) - год Икс. | $ | Целое число | Ложь | СО «отнести» стоимость владения на год x, Где х за каждый год указано при запуске оценщика. Эта только включает в себя каких-либо приписываемые расходы из прикрепленного к нему оборудования(который, конечно, может включать отнести расходы от любых приложенных соединений).

Дополнительный Свойства подключения

В следующей таблице перечислены дополнительный свойства соединения, которые необходимы оценщиком ТШО. Эти свойства будут показаны в окне Свойства со значком селектора входа недвижимость строка ( [image] ) С подсказки "цена / производительность ввода" или просто "Стоимость входа". Изменение любого из этих «вход» свойств и различных структурных изменений в хранилище приведет к стоимости и / или Симулятор Производительность требующие повторного моделирования, как указано в Красный на Панель инструментов моделирования .

Тип | имя | Значение по умолчанию | Ед. изм | Тип данных | необходимые | Описание
Стоимость | Атрибуция | Раковина на источник | [Источник тонуть | Раковина на источник] | Поиск / Список | Правда | Если "Источник тонуть", Эта связь будем иметь иметь Стоимостьsотнести «по» Это из источниккомпонент в раковина компонент, Кроме того, если "Раковина на источник", Эта связь будем уже издержки отнести 'вдоль " Это из компонента раковиной компонента-источника.
Поведение | Отношения | опоры | [процессы | поддерживает] | Поиск / Список | Ложь | Если "опор", это означает, что соединение компонент "источник" при поддержке "тонуть" компонента. Кроме того, если либо "Опоры" или "процессы", то соединение будет автоматически выбран в связи, чтобы их расходы отнести 'вдоль "из компонента раковиной компонента-источника.
Стоимость | % | 100,0 | % | Десятичная дробь | Ложь | Показывает, какую часть расходов на компоненты раковина, которое будет числиться компонента-источника. В% значения не нужно, чтобы добавить до 100%, и это просто используется для масштабирования "Суммарная стоимость Собственность - следующая х лет." имущество (см выше) из компонента раковиной, как это связано с компонента-источника.

Архитектура Свойства

В следующей таблице перечислены архитектуры свойства, которые выводятся оценщиком ТШО. Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Стоимость Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и стоимость тренажера требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Заметка

Смотрите примечание выше о возможном округления выходных свойств.

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Стоимость | Общая стоимость Собственность - следующая х лет. | $ | Целое число | Ложь | Общая стоимость владения всей архитектуры в течение ближайших лет х.

В следующей таблице перечислены архитектуры свойства, которые выводятся оценщиком ТШОесли Рассчитать Пер-Год расходы опция. Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Стоимость Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и стоимость тренажера требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Заметка

Смотрите примечание выше о возможном округления выходных свойств.

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Стоимость | Общая стоимость Собственность - год Икс. | $ | Целое число | Ложь | Общая стоимость владения для вся архитектура на год x в будущее.


Моделирование надежности и доступности

Навигация: Имитация архитектуру> Тренажеры>

Моделирование надежности и доступности

Отправить комментарии на эту тему.

Задний план

Достоверность оценщика вычисляет надежность архитектуры с помощью входных компонентов и соединений.

Для компонентов и прямых связей, надежность основана на среднее время между отказами (MTBF). Единственные переменные, необходимые для расчета надежности архитектурных элементов:

· Среднее время безотказной работыЗначение (в годах);

· Среднее время ремонта (MTTR)отказ (в годах); а также

· Определенный период времени, чтобы проверить надежность в течение.

Формула для расчета надежности определяется как:

Надежность = -е (-у × возраст)
Где у = 1 ÷ наработки на отказ

Наличие компонентов и соединений основана на СПБ и MTTR. Обратите внимание, что наличие, в отличие от надежности, не зависит от срока, на который он проходит испытания.

Наличие = MTBF / (MTBF + MTTR)

В то время как методы, которые преобразуют Блок-схемы надежности(с помощью простого последовательного и параллельного конструкции) дают наиболее точные результаты, эти методы стали весьма япрактическая когда мы пытаемся вычислить надежность для миссий в рамках огромной сети тысяч элементов. Кроме того, эти трансформационные подходы сломать для многих общих структур, таких, как сети «сеток».

Монте-КарлоМетод позволяет надежность и доступность системы произвольного размера и сложности должны быть рассчитаны. Метод Монте-Карло моделирует много сценариев и еили каждый сценарий случайное состояние, доступный или недоступен, Который присваивается каждому физическому элемента. Вероятность данного элемента, находящегося в состоянии свободному основана на надежности / доступности компонента.

Например, компонент с 90% доступности можно ожидать, будет доступна в примерно 90% сценариев. Поэтому надежность и доступность косвенную связь может быть оценена как доля случайных scenarios-, для которых путь элементов существует в доступной государственно от источника к месту назначения.

Заметка

Поскольку вычисление локальной надежности и доступности основана на различных параметров и различных формул (и, следовательно, приводит к различным значениям), необходимо присвоить каждому элементу двагосударства, один для доступности, и один для надежности. Расчет доступности использует состояние доступности в каждом сценарии, в то время как расчет надежности использует состояние надежности в каждом сценарии.

Оценщик надежность использует технику моделирования Монте-Карло выработать надежность определенной архитектуры. Архитектура ставится через тысячи отдельных моделирования и результаты сведены в таблицу, чтобы получить меру надежности. Как уже упоминалось выше, Монте-Карло является самым быстрым методом для моделирования больших сетей и будет работать с любой сложной (т.е. отверстиями) структуры.

Оценщик выводит четыре значения:

1. Миссия надежностив течение ряда лет;

2. Доступность из архитектура;

3. Надежность из местная составляющаяв течение ряда лет; а также

4. Доступность из местная составляющая.

Оценщик работает вероятность компонент или рабочий соединение (то есть не забывая) и время, необходимое для ремонта.

Как стандарты с MTBF для и / или MTTRs рассматриваются

Если элемент (компонент или соединение) имеет стандарты назначенного MTBF и / или среднее время восстановления значения, эти значения используются также при расчете местного надежности и доступность элемента в соединении.

Например, если компонент A, С заданными стандартами B, C, а также DКаждый из нас имеет MTBF и среднее время восстановления Значение, Местная Надежность = R(A)× R(B) × R(C) × R(D), где R = Рассчитывается надежность (по формуле) компонента / стандартов а также Местный Пользаспособность = А (A)× А (B) × А (C) × А (D), где A = Рассчитывается пользаСпособность (по формуле) компонента / стандартов. То есть, если элемент имеет три уровня каждый с MTBF среднее время восстановления и стоимостьs, А также наработки на отказ среднее время восстановления и стоимостьsдля свойств элемента, местный надежность и avilability в качестве значения серии каждого из стандартов и самого элемента.

В качестве другого примера, если компонент Aприсвоило стандарты B, C, а также Dно только стандартные Bимеет как время наработки на отказ и значение MTTR, а стандарт Cимеет только значение MTBF и стандарт Dимеет только значение MTTR, Local Надежность = R (A)× R (B)× R (С), где R= Рассчитывается надежность (по формуле) компонента / стандартов и местных Доступность = А (А)× А (В)× А (С), где A= Рассчитывается доступности (по формуле) компонента / стандартов, но в расчете (С), так как стандарт имеет только значение MTBF это 'поиск'для значения (ов) соответствия MTTR и добавить все среднее время восстановления значения он находит, что дон'т сами по себе имеют значение MTBF на соответствие, так что в этом случае он будет использовать значение MTTR стандартных D, Если бы не было другой стандарт, скажем, E, Только с значением MTTR, а затем А (С)будет использовать наработки на отказ Cс MTTR из D а также Eсуммируются. Если другого стандарта, скажем, F, Был только значение MTBF, то A (F)будет также использовать MTTR из D а также Eсуммируются.

Расчет надежности Mission

При расчете местного надежность является вопрос с помощью простой формулы, расчет косвенных связей (миссия) не так легко, особенно когда у нас есть сложные и крупные сети переплетенных путей (соединений) и компонентов.

Принимая всю сеть в счет

Как косвенные соединения не представляют собой физическое соединение, мы должны выяснить, как исходный компонент может получить его компонента назначения. И это подразумевает, глядя на всей сети, и все по-разному (и путей) наш компонент источник может предпринять, чтобы достичь компонент назначения (раковины).

Заметка

Пока есть как минимум один полныйПуть от источника до пункта назначения, миссия будет успешнойи косвенный соединение называют закрытое подключение.

Понимание Link Matrix

Чтобы узнать, какие компоненты / прямые соединения связаны с тем, что нам нужен артефакт быстро проверить, являются ли два блока соединяются в определенном направлении. Это зависит от матрицы канала. Короче говоря, матрица ссылка двумерный массив булевых переменных, которые государства могут ли конкретный компонент достижения другой компонент напрямую. Его размер равен квадрату общего количества компонентов в сети.

Простой надежности Блок-схема (РосБР)

Ссылки Матрица надежности блок-схемы (РосБР)

Поскольку не все соединения являются двунаправленными (происходит в обоих направлениях), важно знать, как правильно читать матрицу связи. В оценщиком надежности, первый аргумент является источником, а второй аргумент является местом (раковина).

Поэтому, если ссылка матрица (A, B) = True, то это означает, что А может добраться до B непосредственно (однонаправленный). В может попасть в А, если только, если матрица ссылку (B, A) = True. Если это так, то это означает двунаправленный соединение.

В данном примере выше:

· Источник 1 можно достичь места назначения 0 (Источник 1 и назначения 0 дает результат true); а также

· Источник 0 может достичь места назначения 1 (Источник 0 и 1 Направление дает результат true), а связь между 0 и 1 является двунаправленным.

· Источник 2 не может достичь места назначения 1 (Источник 2 и назначения 1 дает результат False), даже если в качестве источника 1 может достигать назначения 2 (Source 1 и 2 Направление дает результат true). Это означает, что связь между 1 и 2 является однонаправленным.

Понимание надежности Block Diagram

Блок-схема надежности (RBD) инкапсулирует структуру всей объектной модели в терминах блоков и ссылок. Каждый блок представляет собой элемент, который имеет возможность неудачи или успеха в соответствии с ссылки / путей, которые соединяют их. Оба компоненты и соединения могут стать "блок" в РосБР.

Пример RBD Блоки и ссылки

На рисунке выше, представляет пример RBD. Пунктирная красная линия представляет собой одну миссию 4 в 1. Обратите внимание, как есть только два возможных пути для миссии 4 к 1.

Рассмотрим маршрут 4 до 3 до 0 до 1, и маршрут 4 до 7 к 1. пунктирной блоков 2, 5и 6 представляют блоки, которые не влияют на провал / безотказность миссии 4 к 1. Они не считаются и игнорируются. Это важно, поскольку для большинства миссий будет большое количество избыточных блоков, которые не повлияют на успех конкретного миссии. Это становится все более очевидным в больших сетях в результате чего количество избыточных блоков сделает результаты моделирования неточными.

Чтобы ускорить время моделирования, и обеспечить более точные результаты, необходимо абстрагироваться от всего РосБР и использовать только те элементы, которые влияют на успех миссии.

Заметка

Один маршрут / путь не может пройти через любой компонент два раза.

На этом этапе мы можем создать ссылку матрицу и выполнить моделирование Монте-Карло.

Расчет Архитектура Наличие

Наличие архитектура вероятность того, что все косвенные соединения будут доступны в любой момент времени. Наличие каждого косвенного соединения определяется в ходе каждой итерации моделирования Монте-Карло, однако эти косвенные соединения (как правило) полагаться на тот же набор физических элементов. Поэтому, просто агрегирования эти отдельные периоды будут "дважды считать" эти ООН-наличность, давая пессимистический общую доступность архитектуры. Кроме того, в целом наличие архитектура рассчитывается, глядя на каждой итерации и, видя, элементы, участвующие в косвенных связях интерес, доступны ли. И затем агрегирования этих результатов в конце моделирования.

Запуск симулятора надёжности

Для имитации архитектуру с точки зрения надежности

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Выбрать Анализ| Надежность.

3. Выберите АрхитектураВы хотите, чтобы оценить из выпадающего меню.

Заметка

По умолчанию, ABACUS автоматически выберет первую архитектуру, для которой повторная моделирования требуется из-за имеющегося имущества или структурных изменений.Это выделение показано в Красный на Панель инструментов моделирования .

4. Выберите Компоненты а также СвязиВы хотите, чтобы оценить из стандартный элемент окна выбора с помощью "Показать прямых связей 'и' Показать процессы соединения" радио-кнопки фильтров в левом нижнем углу диалогового окна, чтобы помочь с вами выбора.

Дополнительный Флажокв стандартный элемент окна выбора

· Sпр трансформированных Модель будем сохранить копию РосБР преобразованной версии проекта в той же папке, что и текущий проект и добавить "_transformed" с именем проекта.Это превратило проект может быть использован для диагностики подробно моделирование надежности, проводимую ABACUS.

Дополнительная Радио-Кнопкив стандартный элемент окна выбора

· Показать прямых соединений автоматически установить соединение фильтр объектах недвижимости Тип = Поведение, имя = Абстракция и значение = прямой.Эта опция выбрана по умолчанию и помогает отбор "прямых" связей, как описано выше и ниже.

· Показать Процессы Соединения автоматически установить соединение фильтр объектах недвижимости Тип = Поведение, имя = Отношения и стоимость = процессов.Эта опция помогает отбор "прямых" связей, как описано выше, и ниже.

5. Нажмите следующий.

6. Выбрать Миссиит.е. соединения вы хотите, чтобы включить в симуляции.

7. Установить Время работы Коэффициент масштабированияслайдер.

Заметка

Более высокие значения дадут более статистически достоверные результаты, но займет больше времени, чтобы вычислить.

Флажки

· Показать Закрытые Соединения будем автоматически фильтровать имеющиеся соединения, только те, которые включают в себя по крайней мере один полный физический путь от источника с компонентом назначения как в выборе RBD, описанной выше.

· Показать косвенных связей автоматически установить соединение фильтр объектах недвижимости Тип = Поведение, имя = Абстракция и значение = косвенным.Эта опция выбрана по умолчанию и помогает отбор "косвенных" или Миссия соединений, как описано выше, и ниже.

Кнопки

· Всевыбирает все связи.

· Инвертироватьотменяет все в настоящее время выбран связи и выбирает все те, которые не были выбраны.

· Никтоотменяет все связи.

Другие варианты

· Время работы Коэффициент масштабирования контролирует время моделирования и точность с выше значения доходностиINGболее статистически достоверные результаты, но принятие больше времени, чтобы бег.

Заметка

Когда ABACUS вычисляет количество итераций для имитации он будет определять наиболее надежным элементом, который не идеально надежным, а затем имитировать на время работы масштабный фактор времени 1 по недоступности этого элемента плюс 1 итерации. Или (MTBF + MTTR) / среднее время восстановления * время работы Коэффициент масштабирования + 1. Это, чтобы убедиться, что этот элемент все еще не по крайней мере раз в симуляции. Например. Если самый надежный элемент, который не является идеально надежным имеет среднее время безотказной работы 10000 часов и MTTR 8 часов, затем моделирование будет (10000 + 8) / 8 = 1,251 раза больше времени Масштаб Выполнить Factor + 1 итераций.

· Лет, чтобы Имитация Впереди определяет количество лет для Миссии надежности должны быть рассчитаны на.

· Nхариус из Темыдеtermines количество обрабатываемых потоков, используемых для моделирования Монте-Карло.Эта опция по умолчанию будет совпадать с количеством доступных процессоров / ядер (в том числе ядер Hyper-Threading), чтобы минимизировать общее время моделирования.

8. Нажмите Конеци вы получите ПредупреждениеДиалог.

9. При желании исследовать предупреждения, нажав Подробнее >>.

10. Нажмите Продолжать.

Заметка

В этот момент, АБАКУС выполнит Монте-Карломоделирование архитектуры, и после короткого времени (с индикаторами прогресса для обратной связи) расчет полной появится диалоговое окно.

11. Нажмите ОКпризнать моделирование.

Наконечник

Для учебных курсов и дальнейшей помощи по надежности моделирования пожалуйста, обратитесь к Avolution сообщество .

Комплектующие и подключение недвижимость

В следующей таблице перечислены компонент и 'непосредственный'Свойства подключения требуется оценить надежность. Эти свойства будут показаны в окне Свойства со значком селектора входа недвижимость строка ( [image] ) С подсказки "Надежность ввода. Изменение любого из этих «вход» свойств и различных структурных изменений в хранилище приведет в симуляторе надежности, требующей повторного моделирования, как указано в Красный на Панель инструментов моделирования .

Тип | имя | Значение по умолчанию | Ед. изм | Тип данных | необходимые | Описание
Надежность | Среднее время безотказной работы | ∞ | лет, недель, дней или часов | Десятичная дробь | Правда | Среднее время до разрушения элемента. Примечание: Значения могут быть выражены в единицах лет, недель, дней или часов и превращаются после наличия концепции на '24 / 7 'следующим образом - 1 год = 52 недель или 365 дней или 8760 часов - 1 неделя = 7 дней или 168 часов - 1 день = 24 часов
Надежность | Среднее время восстановления | 0 | лет, недель, дней или часов | Десятичная дробь | Правда | Среднее время на ремонт элемента. Примечание: Значения могут быть выражены в единицах лет, недель, дней или часов и превращаются после наличия концепции на '24 / 7 'следующим образом - 1 год = 52 недель или 365 дней или 8760 часов - 1 неделя = 7 дней или 168 часов - 1 день = 24 часов

В следующей таблице перечислены компонент и 'непосредственный' Свойства подключения выхода оценщиком надежности. Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Надежность Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и симулятор надежности требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Надежность | Надежность - х лет |  | Десятичная дробь | Ложь | Вероятность того, что элемент не удастся в ближайшие годы х. Это значение между 0 и 1.
Надежность | Ненадежность - х лет |  | Десятичная дробь | Ложь | Вероятность того, что элемент не удастся в ближайшие годы х. Это значение между 0 и 1.
Надежность | Доступность | % | Десятичная дробь | Ложь | Рассчитанное наличие компонента или соединения. Это значение между 0% и 100%.
Надежность | Отсутствие | % | Десятичная дробь | Ложь | Рассчитанное недоступность компонента или соединения. Это значение между 0% и 100%.

В следующей таблице перечислены 'косвенное'Свойства подключения выхода оценщиком надежности. Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Надежность Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и симулятор надежности требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Надежность | Миссия Надежность - х лет |  | Десятичная дробь | Ложь | Вероятность того, что косвенная связь не подведет в течение ближайших лет х. Это значение между 0 и 1.
Надежность | Миссия Ненадежность - х лет |  | Десятичная дробь | Ложь | Вероятность того, что косвенная связь не удастся в ближайшие годы х. Это значение между 0 и 1.
Надежность | Доступность | % | Десятичная дробь | Ложь | Рассчитанное наличие косвенного связи. Это значение между 0% и 100%.
Надежность | Отсутствие | % | Десятичная дробь | Ложь | Расчетная отсутствие косвенного соединения. Это значение между 0% и 100%.

Архитектура Свойства

В следующей таблице перечислены выход архитектура свойства оценщиком надежности. Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Надежность Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за закладываемого имущества или структурных изменений в репозиторий и симулятор надежности требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Ед. изм | Тип данных | необходимые | Описание
Надежность | Доступность | % | Десятичная дробь | Ложь | Наличие всех косвенных связей, которые были включены в оценки. То есть, вероятность того, что всекосвенные связи будут доступны на данный момент времени. Это значение между 0% и 100%. Примечание: Это не умножение отдельных наличность соединение, как это было бы "двойного счета" ООН-наличия соответствующих компонентов.
Надежность | Отсутствие | % | Десятичная дробь | Ложь | Недоступность косвенных связей, которые были включены в оценки. То есть, вероятность того, что хотя бы одинкосвенная связь будет недоступна в данный момент времени. Это значение между 0% и 100%. Примечание: Это не умножение отдельных неготовности присоединения, как это было бы "двойного счета" ООН-наличия соответствующих компонентов.
Надежность | Миссия Надежность - х лет |  | Десятичная дробь | Ложь | Вероятность того, что все косвенные связи, которые были включены в оценки не будут не в течение следующего xлет. Это значение между 0 и 1. Примечание: Это не умножение отдельных надежностей связи, как это будет "двойного счета" ООН-наличия соответствующих компонентов.
Надежность | Миссия Ненадежность - х лет |  | Десятичная дробь | Ложь | Вероятность того, что по крайней мере один из косвенных соединений, которые были включены в оценку будет не в течение следующего xлет. Это значение между 0 и 1. Примечание: Это не умножение отдельных ненадежности соединения, как это было бы "двойного счета" ООН-наличия соответствующих компонентов.


Имитация Открытость

Навигация: Имитация архитектуру> Тренажеры>

Имитация Открытость

Отправить комментарии на эту тему.

Открытость симулятор определяет степень, в которой архитектура и ее элементы "открытым", то есть, способность системы обрабатывать замену компонентов с минимальным воздействием.

Для имитации архитектуру в плане открытости

1. Убедитесь, что вы есть файл ABACUS, Содержащий ваши населенный архитектура, открытый.

2. Выберите Анализ | Открытость.

3. Выбрать Архитектура (ы)Вы хотите включить в оценке.

Заметка

По умолчанию, ABACUS автоматически выберет первую архитектуру, для которой повторная моделирования требуется из-за имеющегося имущества или структурных изменений.Это выделение показано в Красный на Панель инструментов моделирования .

4. Нажмите Конеци вы получите ПредупреждениеДиалог.

5. При желании исследовать предупреждения, нажав Подробнее >>.

6. Нажмите Продолжать.

Заметка

В этот момент, ABACUS будет выполнять структурную оценку архитектура (ы) и после короткого времени (с индикаторами прогресса для обратной связи) расчет полной появится диалоговое окно.

7. Нажмите ОКпризнать моделирование.

Наконечник

Для учебных курсов и дальнейшей помощи в оценке Открытость пожалуйста, обратитесь к Avolution сообщество .

Комплектующие и подключение стандартных свойств

В следующей таблице перечислены компоненты и соединения стандартные свойства, необходимые для оценки открытости.Эти свойства будут показаны в окне Свойства со значком селектора входа недвижимость строка ( [image] ) С подсказки "Открытость ввода. Изменение любого из этих «вход» свойств в хранилище приведет к Открытость симулятор, требующего повторного моделирования, как указано в Красный на Панель инструментов моделирования .

Тип | имя | Значение по умолчанию | Ед. изм | Тип данных | необходимые | Описание
Открытость | Стандарты-Стандарт погашения Организация Уровень- |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Уровень ответственного органа по стандартизации 0:Организационная / Собственность 1:Консорциум / Defacto 2:Национальный / Военная 3: Международный
Открытость | Стандарты-Стандарт погашения Статус- |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Уровень утверждении достигается с телом стандартов 0:Рабочая / Комитет Проект 1:Общественный проект / на голосование 2:Временный проект 3:Утвержденный
Открытость | Стандарты-Стандарт погашения Стабильность- |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Это стандартный, вероятно, изменится? 0:Стандартный устарели 1:Высоко изменяться в следующем 1 до 2 лет 2:Известные изменения / обновления существующих функций 3:Высокая стабильность не (без изменения в течение 2 лет)
Открытость | Стандарты-Стандарт погашения поставок и поддержки |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Поставщик поддержки 0:Нет товаров или поставщики не поддерживают стандарт 1:Один или более поставщиков, которые реализуют часть стандарта 2:Более один поставщик с продуктами, которые реализуют все части стандарта 3:Многие более одного поставщика с продуктами, которые реализуют все части стандарта
Открытость | Стандарты-Стандарт Ясность-документация |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Качество нормативной документации 0: Бедные 1: Справедливая 2: Хорошо 3: Отлично
Открытость | Стандарты-Стандарт Ясность-стандартная ширина |  |  | Целое число | Ложь | Количество функций. Подсчет из самых низких стандартных функций уровня - Sf
Открытость | Стандарты-Стандарт-СМ Ясность |  | % | Десятичная дробь | Ложь | Процент от общего числа возможностей, которые являются обязательными
Открытость | Стандарты-Стандарт Ясность-Так |  | % | Десятичная дробь | Ложь | Процент от общего числа возможностей, которые не являются обязательными
Открытость | Стандарты-Стандарт Ясность-SC |  | % | Десятичная дробь | Ложь | Процент от общего числа возможностей, которые определяются условно
Открытость | Профили-профиля Документация Документация- |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Качество нормативной документации 0: Никто 1: Бедные 2: Справедливая 3: Отлично
Открытость | Профили-профиля Документация-Точность |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Отражает ли документация фактическое проектирование системы? Какой уровень особенностей профиля используются в системе? 0:Нет возможности 1:Некоторые особенности 2:Большинство функций 3:Все особенности
Открытость | Профили-профиля Документация погашения |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Является ли профиль зрелым и доступны? 0: Для этого случая 1: Основанный на проекте 2:Организационная 3:Общественного
Открытость | Профили-профиля Ясность-Явная ширина |  |  | Целое число | Ложь | Количество стандартных функций, указанных в соответствии с требованиями в профиле
Открытость | Профили-профиля Ясность-мкм |  | % | Десятичная дробь | Ложь | Процент обязательных характеристик в профиль
Открытость | Профили-профиля Ясность-Po |  | % | Десятичная дробь | Ложь | Процент дополнительные функции в профиле
Открытость | Профили-профиля Ясность-ПК |  | % | Десятичная дробь | Ложь | Процент условно обозначить особенности в профиль
Открытость | Профили-профиля Ясность-Покрытие |  | % | Десятичная дробь | Ложь | Процент стандартных функций, специально обратился в профиле
Открытость | Профили-профиля Расширения-расширение Ширина |  |  | Целое число | Ложь | Количество нестандартных особенностей, указанных в профиле
Открытость | Профили-профиля Расширения охвата |  | % | Десятичная дробь | Ложь | Процент расширений подробно в профиле
Открытость | Продукты-Продукт Наличие и соответствие стандартам покупок Товаров |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Количество продуктов, поддерживающих обязательные функции стандарта 0:Нет товаров поддерживают стандарт 1:Один или несколько продуктов реализовать часть стандарта 2:Более чем один продукт реализует все части стандарта 3:Многие более чем один продукт реализует все части стандарта
Открытость | Продукты-Продукт Наличие и соответствия всех приложений Соответствие |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Какой уровень соответствия у продукция имеет стандарту? 0: Никто 1:Заявленное 2:Доказанная 3:Сертифицированный и продемонстрировал
Открытость | Продукты-Продукт Наличие и соответствия качества Соответствие- |  | [0 | 1 | 2 | 3] | Поиск / Список | Ложь | Качество проверки соответствия 0: Никто 1:В доме тестирование разработчик продукции 2:Независимое тестирование (например NIST) 3:Демонстрируется в контексте соответствующего продукта

Компонент, Соединение и Архитектура Свойства

В следующей таблице перечислены компонента, соединение и архитектура свойства выход открытостью оценщика. Все следующие свойства оценивают в диапазоне от нуля (0) и три (3), ноль (0) является наименее желательным, и три (3), является наиболее желаемым.Эти свойства будут показаны в окне Свойства со значком селектора ряд выход имущество ( [image] ) С подсказки "Открытость Выход". Стрелка на иконке будет выделить Красный ( [image] ), Когда эти свойства устарели из-за основного изменения свойств в хранилище и открытость симулятор требует повторного моделирования в соответствии с Красный выделяя на Панель инструментов моделирования .

Тип | имя | Тип данных | необходимые | Описание
Открытость | Открытость | Десятичная дробь | Ложь | Общая оценка открытости элемента.
Открытость | Стандарты-Стандарт погашения | Десятичная дробь | Ложь | Текущее состояние стандарта, задумываясь или не был одобрен его, как долго он был в использовании, и насколько хорошо принята она находится в пределах сообщества разработчиков.
Открытость | Стандарты-Стандарт Ясность | Десятичная дробь | Ложь | Открытым характером стандартов, отражающих потенциальный неоднозначность в последующие стандарты
Открытость | Профили-профиля Документация | Десятичная дробь | Ложь | Степень, в которой профиль интерфейса документация разрабатывается и отражает ли профиль документация фактического дизайн системы и / или Внедренная система
Открытость | Профили-профиля Ясность | Десятичная дробь | Ложь | Уровень детализации при условии, в профильной / Профиль спецификации
Открытость | Профили-профиля Расширения | Десятичная дробь | Ложь | Степень, в которой профиль в соответствии со стандартом, на котором она основана
Открытость | Продукты-Продукт Наличие и соответствия | Десятичная дробь | Ложь | Будь или не есть открытое стандартные совместимые продукты доступны для использования в проекте


Стандартные отчеты

Навигация: Отчетность по вашей архитектуры>

Стандартные отчеты

Отправить комментарии на эту тему.

СЧЕТЫ' стандарт Отчеты позволяют получить список компонентов и соединений в одном или более из ваших архитектур. Отчет содержит всю информацию, связанную с компонентами и соединений, выбранных, в том числе информации о компоненте или места подключения в иерархии, типа, стандарты, описание, свойства и его приложений.

Заметка

Содержание отчета являетсяконфигурируемыйчерез диалог Параметры отчета описано ниже, однако, тО найдете более подробную информацию о том, как создать настраиваемый пользовательский полностью Отчетыс помощью ABACUS пользовательских отчетов, пожалуйста обратитесь к теме Вот или контакт Поддержка Avolution .

Для просмотра стандарт отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура(ы).

2. Выбрать Вставить| Стандартный отчетили нажмите Создать стандартный отчет Панель инструментов кнопку. Отчет о конфигурацииОткроется окно.

Окно Конфигурация Сообщить

3. Выберите Архитектуры, Компоненты а также Связичто вы хотите в докладе от Окно настройки отчета.Пожалуйста, обратитесь к Element Selection Standard Вот тема для помощи.

4. Теперь нажмите на ОпцииКнопка и Параметры отчетаОкно будет отображаться.

Окно настроек отчета

5. Вы можете выбрать отображение Новая страница для каждого элемента, То Дата печати, Время печати, Номера страници стоит ли включать в себя название в заголовкедоклад по тикают / снятии выделения соответствующих флажки. Вы также можете настроить название и автора, редактируя Название отчета а также Автор текстовые поля. Вы также можете выбрать, какой контент отображается в отчете, отметив / сняв выделение флажки под Содержание отчетачасть окна. После того как вы закончили нажмите на ОК.

6. Теперь нажмите на Конецв окне Configuration отчетов.

Для интерпретации видимой отчет

Пример сформированного отчета с краткими пояснениями

Для перемещения по страницам отчета, нажмите на иконку [image] расположен на панели инструментов в левом верхнем углу экрана.

Заметка

Ты можешь спасти Отчет в различные форматы нажав на Экспорт Значок Отчет [image] располагается в панель инструментов. Вы можете экспортировать в следующие форматы: Превосходить, PDF а также слово, Пожалуйста, сохраните отчет в нужное место для дальнейшего использования. Если вносятся изменения в архитектуре на более позднем этапе, в новом докладе должны быть созданы, чтобы отразить изменения.

Смотрите также

Анализируя архитектуру


Пользовательские отчеты

Навигация: Отчетность по вашей архитектуры>

Пользовательские отчеты

Отправить комментарии на эту тему.

Пользовательские отчеты АБАК "позволит вам создать полностью настраивается пользовательских отчетов. Отчеты могут включать в себя пользовательский изображений и графики, а также подробным описанием всех компонентов, соединений или атрибуты из хранилища ABACUS, а также подробные аналитических результатов от различных симуляций (в том числе ТСО, производительность и надежность). Кроме того, отчеты могут содержать диаграммы, графики, каталоги, матрицы / сводные таблицы, карты, датчики, искрографики, бары и индикаторы данных (например, светофоры).

Заметка

В то время как любой пользователь может открыть существующие пользовательские отчеты, тО настроить Отчеты лицензия пользователь нуждается Отчет о конфигурации Возможность. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

Для просмотра обычай отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура(ы).

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчетыОткроется окно.

Пользовательские отчеты окно

3. Выберите существующий Отчет что ты хочешь для отображения из Доступные отчеты раздел.

4. Нажмите Выполнить отчет.В докладе будет открыть в Microsoft Report Viewer и тО перемещаться по страницам отчета, нажмите на иконку [image] расположен на панели инструментов в левом верхнем углу экрана.

Заметка

Ты можешь спасти Отчет в различные форматы нажав на Экспорт Значок Отчет [image] располагается в панель инструментов. Вы можете экспортировать в следующие форматы: Превосходить, PDF а также слово, Пожалуйста, сохраните отчет в нужное место для дальнейшего использования. Если вносятся изменения в архитектуре на более позднем этапе, в новом докладе должны быть созданы, чтобы отразить изменения.

Для редактировать данные репозитория, который отправляется a обычай отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура(ы).

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчеты окно (показано выше) будет отображаться.

Заметка

В то время как любой пользователь может открыть существующие пользовательские отчеты, тО настроить данные, которые передаются в специальный отчет лицензия пользователь нуждается Отчет о конфигурации Возможность. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

3. Выберите существующий Отчет что ты хочешь для отображения из Доступные отчеты раздел.

4. Нажмите Наборы редактировать данные. Набор данных РедакторОткроется окно.Это окно показывает коллекцию наборов данных, которые в настоящее время направляются к пользовательского отчета. В приведенном ниже примере есть три (3);

· набор данных ApplicationProxy что указав все детали для всех компонентов приложения в "2015" Фактическое архитектуры (в том числе свойств на свои стандарты и всех подключенных компонентов),

· набор TwoDViewProxy данные, указав один или несколько диаграмм, где имя совпадает 'Application Пейзаж (Австралия) ",

· набор данных, который TargetProxy указав все детали для всех целевых соединений в '2015' Фактическое архитектуры (в том числе прилагаемых компонентов).

Набор данных Редактор окно

Заметка

Имя Запрос будет использоваться в качестве имени набора данных в Microsoft Report Builder (см. Ниже) Поле Включить определяет, будет ли набор данных либо один элемент, набор элементов, Все типы компонентов, все типы соединений, один или несколько архитектур, один или несколько диаграмм или один или несколько графиков. Для "Коллекция элементов 'наборов данных кнопка Фильтр обеспечивается при щелчке открывается фильтра окно элемент, который позволяет применить несколько фильтров, чтобы вернуться только элементы из некоторых архитектур, и / или отдельных видов, и / или с определенными стандартами и / или прикреплены к определенным компонентам, и / или с определенными родителей, и / или в некоторых диаграммах, и / или в определенных Графики и / или с заданными значениями свойств. Для других типов наборов данных поле Имя предоставляется и с помощью Select кнопку, вы можете выбрать объект (ы), которые будут включены с набором данных.

Заметка

Наборы данных хранятся вНаборы данных файл (.XML)с тем же именем файла в качестве базы связан Файл определения отчета (.RDL), Если этот файл не существует набор данных редактор автоматически заполняет с любыми именами запросов, которые существуют в Файл определения отчета (.RDL)и новое Наборы данных файл (.XML)будет создан аа правильный список запросов определяется.

3. Если вы хотите, чтобы удалить существующий набор данных, то выберите Удалить запросКнопка.

4. Если вы хотите, чтобы добавить новый набор данных, то нажмите Добавить новый набор данныхКнопка и настроить набор в соответствии с приведенным выше примечанием данных.

Для создать новый обычай отчет(из шаблона)

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура.

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчеты окно (показано выше) будет отображаться.

3. Нажмите Новый и выберите либо А4 - Портрет, А4 Пейзаж, А3 - Портрет, A3- Пейзаж, США Письмо - Портрет, США Письмо - Пейзаж, США Таблоид - Портрет или США Таблоид - Пейзажв зависимости от ориентации отчет и размер бумаги, что является желательным.

4. Перейдите в папку для сохранения файла отчета Definition (.rdl / .rdlc) и соответствующий набор данных файла (.xml) и нажмите Сохранить, Это добавит новый пользовательский отчет Доступные разделе Отчеты окна пользовательских отчетов, и это может открыть или редактировать, как описано выше.

Для добавить существующий обычай отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура.

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчеты окно (показано выше) будет отображаться.

3. Нажмите Добавить и перейдите к расположению файла определения отчета (RDL-/ .rdlc) и нажмите открыто, Это добавит новый пользовательский отчет Доступные разделе Отчеты окна пользовательских отчетов, и это может открыть или редактировать, как описано выше.

Заметка

Предполагается, что набор сопоставления данных файла (.xml) существует в том же месте, что и файл Сообщить Определение.

Для скопировать существующую традицию отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура.

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчеты окно (показано выше) будет отображаться.

3. Выберите существующий Отчет что ты хочешь копировать из Доступные отчеты раздел.

4. Нажмите Копия и копию выбранного отчета (названный "Копия ...") будут добавлены к имеющимся разделе Отчеты окна пользовательских отчетов, и это может открыть или редактировать, как описано выше.

Заметка

Делая это, вы будете создавать копию отчета Сообщить Определение файл (.rdl / .rdlc) а также его соответствие набора данных файла (.xml)(если он существует).

Для удалить существующий обычай отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура.

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчеты окно (показано выше) будет отображаться.

3. Выберите существующий Отчет что ты хочешь удалять из Доступные отчетыраздел и нажмите Удалить.

Заметка

При удалении отчета он больше не будет появляться в списке отчета. Тем не менее, это не будет удалить отчета Отчет Определение файл (.rdl / .rdlc) или Набор данных файл(.xml), При необходимости, удаление этих файлов может быть достигнуто через файловую систему.

Для переименовать существующий обычай отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура.

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчеты окно (показано выше) будет отображаться.

3. Выберите существующий Отчет что ты хочешь переименовать в Доступные отчетыраздел и нажмите Переименовать.

4. Введите новое имя для отчета.

Заметка

Оба файла определения отчетов (RDL-/ .rdlc) и соответствующий набор данных файла (.xml) соответственно будет переименован.

Для редактировать дизайн обычай отчет

1. Убедитесь, у вас есть ABACUS открыть файл содержащий ваши населенный архитектура.

2. Выбрать Вставить| Пользовательский отчетили нажмите Создать пользовательский отчет Панель инструментов кнопку. Пользовательские отчеты окно (показано выше) будет отображаться.

Заметка

В то время как любой пользователь может открыть существующие пользовательские отчеты, тО настроить Конструкция пользовательских отчетов лицензия пользователь нуждается Отчет о конфигурации Возможность. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.Кроме того, Microsoft Report Builder 3.0 требуется для создания отчетов и может быть загружена бесплатно с Вот .

3. Выберите существующий Отчет что ты хочешь для отображения из Доступные отчеты раздел.

4. Нажмите Редактировать отчет.В докладе будет открыть в Microsoft Report Builder 3.0. Для получения конкретной помощи и некоторых «советов & уловки» на некоторые из наиболее распространенных задач с проектирования отчетов обратитесь к ниже разделах. Для получения общей помощи на проектирование отчетов пожалуйста, обратитесь в Microsoft Report Builder 3.0 справочных страниц Вот .

Добавление таблицы в отчет

1. Убедитесь, что вы есть файл ABACUS Пользовательский отчет четкости (.rdl / .rdlc) открыт в Microsoft Report Builder 3.0.

2. Выбрать Вставить Вкладка в «ленте» в верхней части, а затем нажмите Таблица кнопкав разделе Регионы данных и выберите Вставить таблицу.

3. Теперь перетащите курсорв положение на холсте доклад, в котором вы хотите верхний левый угол таблицы, чтобы размещены. Щелкните по холсту, По умолчанию таблица будет добавлена ​​с строке заголовка, а затем данные группы (группа используется для организации вид набора данных отчета). Чтобы удалить группу, либо удалить строку или Удалить группу Row в панели инструментов группировки.

Наконечникs

Формулы / выражений в ячейках таблицы редактируются, выбрав ячейку щелкните правой кнопкой мыши: << Expr >> текст и выбрав выражение .... Сортировка строк в таблице можно сделать, выбрав таблицу, а затем просматривают до другой -> поле SortExpressions в панели Properties и введя выражение. Для общего ряда на конце стола добавить строку после (и снаружи) группировку, а затем использовать следующее выражение = Sum (Fields!имя.Стоимость)где «Имя» это поле будучи составил. Чтобы применить окраску колонки использовать "IIF" заявление, в собственности BackgroundColor. Чтобы добавить датчик в ячейке таблицы сначала вставьте датчик в ячейку, а затем падение поля данных, необходимых для датчика. При редактировании высоты & ширины строк таблицы, убедитесь, что вы выбрали правильный ряд, а затем наведите курсор мыши вокруг серых линий, пока вы не получите стрелками вверх / вниз курсора, а затем изменить.

Добавление диаграмм в отчет

1. Убедитесь, что вы есть Файл определения ABACUS Пользовательский отчет (.rdl / .rdlc) открыт в Microsoft Report Builder 3.0.

2. Выбрать Вставить Вкладка в «ленте» в верхней части, а затем нажмите Диаграмма кнопкав разделе Регионы данных и выберите Вставить диаграмму.

3. Теперь перетащите курсорв положение на холсте доклад, в котором вы хотите верхний левый угол диаграммы, чтобы размещены. Щелкните по холсту а потом выберите диаграммуВам потребуется один из вариантов и нажмите ОК.

Наконечникs

Для отображения свойства в качестве аннотации на диаграммах, щелкните правой кнопкой мыши на графике и выберите Этикетки данные показывают, выберите один из ярлыков, которые были добавлены и установите Разное -> UseValueAsLabel к ложным в панели Properties и добавьте выражение (например, = Поля, Name.Value) в Разное -> Ярлык. Специально для графики пузырь; Пузырьковые диаграммы отображаются под заголовком точечная диаграмма. Бросьте X оси недвижимость в полях серии (или добавить в недвижимость серии). Оставьте Y оси недвижимость в полях данных (или добавить в недвижимость серии). Чтобы использовать свойство, чтобы определить размер пузырьков, отказаться от этого в поля данных (или добавить в недвижимость серии). Пузырьковые диаграммы не отображается, если есть слишком много данных (200+) ничего, иногда это вызывает весь отчет, чтобы не отображать. Маркер Тип - По кругу. По умолчанию, при удалении поля в областях данных, он добавляет их с сумма ()Формула, так что удалить это. Специально для С накоплением графики / Хронология / диаграммы Ганта; Для диаграммы Ганта использовать диапазон диаграммы и добавить свойства, высоких и низких значений в полях данных. Вы можете иметь несколько "баров", добавив больше и больше диапазонов, где Низкое значение для одного матчей высокое значение для другого. Специально для Круговые диаграммы; Для совокупности круговых диаграмм, падение данные в категории полях и в полях данных, добавить формулу = () CountRows, Фильтр любые значения 0 (например, на стоимости картах), в противном случае этикетки для них будет отображаться на графике.

Использование о IIF, чтобы добавить цвета в таблицах и графиках

1. Убедитесь, что вы есть Файл определения ABACUS Пользовательский отчет (.rdl / .rdlc) открыт в Microsoft Report Builder 3.0.

2. Щелкните правой кнопкой мыши ячейку в таблице, чтобы цвет и нажмите Текст окне Свойства.

3. Выбрать Заполнить и нажмите FXКнопка справа от метки цвет заливки и в Комплексе выражение для поля BackgroundColor ввести выражение, например = IIF (Fields! InformationStatus.Value = "Сохранить", "LightGreen", IIF (Fields! InformationStatus.Value = "Редизайн", "Желтый", IIF (Fields! InformationStatus.Value = "Обновить", "Апельсин", " Лосось"))), Это изменяет цвет фона светло-зеленый для каждой ячейки, содержащей положение 'сохранить', желтый для каждой ячейки, содержащей Статус "Редизайн", оранжевый для каждой ячейки, содержащей статус "Обновить" и любое другое значение состояния будут окрашены в 'Salmon.

Заметка

Цвета могут быть добавлены для диаграмм, выбрав серию на графике, а затем установив внешний вид -> свойство цвета (или пузырьковых диаграмм появление -> Маркер -> Цвет имущества) к выражению, аналогичному в примере выше.

Вещи иметь в виду при проектировании пользовательских отчетов

· Потому что все свойства, кроме Integer отправляются в виде строки из ABACUS к зрителю отчета, если вы хотите, чтобы делать какие-то "выражения" с ними (как разделяй одно свойство другой или рода), вы должны преобразовать их в десятичную или Дата и т.д. Историю , Эта статья является хорошим источником. Например. = CDate (Fields! LifecycleEndDate.Value) Заметка: Пожалуйста, убедитесь, что язык отчет установлен на ан-ГБ (как описано ниже), чтобы принять дд / мм / гггг как он ожидает формат мм / дд / гггг по умолчанию и, соответственно, 31/7/2011 удастся преобразование. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Если вы обнаружите, что вы боретесь, чтобы сохранить все таблицы и диаграммы на одной страницеЕсть несколько основных способов управления вашей документа пространство:

· Разрыв страницы - Убедитесь, что этот параметр выключен стол для каждой таблицы, которую вы хотите быть на той же странице.

· Держите вместе - Убедитесь, этот параметр таблицы Правда для каждой таблицы, которую вы хотите быть на той же странице.

· При перемещении вещи вокруг, это проще, чтобы уменьшить масштаб с помощью регулятора в правом нижнем углу страницы, а затем несколько выбора элементов и сопротивления

· Для ряда изображений в виде таблицы, чтобы убедиться, что 'Размер' | Недвижимость '' КАЛИБРОВКИ установлен в 'Fit' в противном случае изображение может появиться слишком большой, или он будет плохо растягивается.

· Для повторить строку заголовка таблицы на каждой страницедоклада:

1. Открыть Расширенный режим в панели группировки. (Нажмите на стрелку справа от колонки групп и выберите Advanced Mode).

2. В области групп строк (не столбцов групп), нажмите на Static группы, в которой подчеркивается, соответствующий текстом в табликсе. Нажмите через каждый Static группы до тех пор, пока подчеркивает крайнюю левую заголовок столбца. Это, как правило, первым Статический группа в списке.

3. В окне Свойства установите свойство RepeatOnNewPage Истина.

4. Убедитесь, что свойство KeepWithGroup установлен в конце.

· Изменить языковые настройкив свойствах Сообщить соответствовать форматы данных вы требуете, например ан-ГБ для получения даты UK формат (дд / мм / гггг).

Смотрите также

Анализируя архитектуру


Опубликовать в сети

Навигация: Отчетность по вашей архитектуры>

Опубликовать в сети

Отправить комментарии на эту тему.

АБАК "Опубликовать на веб-функция позволяет архитектурные модели, которые будут рассматриваться через защищенный веб-сайт. Архитектуры экспортируется в формат HTML и предназначены для отражения внешний вид Проводника в ABACUS. Просмотров (включая каталоги, схемы, 3D и Диаграммы) также экспортируется в форматы можно просмотреть с помощью Интернет-браузера.

Заметка

В настоящее время, точки зрения и Матрицы не публикуются.

Чтобы опубликовать архитектурные модели в Интернете

1. Убедитесь, что вы есть соответствующая ABACUS файлоткрыт, содержащую населенный архитектурачто вы хотите опубликовать в Интернете.

2. Выбрать файл| Публиковать....

3. Опубликовать в веб-конфигурацииОкно будет отображаться.

Опубликовать на веб-конфигурации

4. По умолчанию все части модели выбираются в том числе Tree зрения, Стандарты, Типы, шаблоны и архитектура (ы). Снимите любые части вы не хотите опубликовать в Интернете, в том числе каких-либо отдельных мнений в архитектуре (ов).

Наконечник

Если вы хотите, чтобы скрыть определенные компоненты, соединения и / или их свойства, рекомендуется администратор создает роли, которую «общественного» с помощью Функция доступа на основе ролей АБАК " а затем удаляет разрешение на чтение из этих типов компонентов, типов и / или свойств соединения, что они не желают быть опубликованы. Затем пользователь должен войти под этой роли и публиковать Сети как ABACUS будет публиковать только элементы, которые читали набор разрешений для этой роли. Кроме того, пользователи могут автоматически публиковать в командной строке, как описано Вот .

Заметка

Вы можете выбрать все отображаемые нажав на части ВсеКнопка или инвертировать выделение, нажав на ИнвертироватьКнопка. Вы также можете нажать на НиктоКнопка очистить выбор.

Заметка

если ты снимите флажок Дерево Просмотрто ни одно дерево рамка (см ниже) не будет опубликован. Соответственно, Вы должны выбрать стартовую страницу в соответствии со стадией 6 ниже или после публикации вам нужно будет настроить либо на высшем уровне; а) index.htmlФайл путем изменения 'кадров SRC = "mainPage.html" NAME = ""' element_details линии непосредственно связать с соответствующей HTML-страницы под содержимое папки, или б) mainPage.htmlпутем предоставления гиперссылку или перенаправлять на соответствующую страницу HTML под содержимое папки.

5. Нажмите Вариант Кнопка и следующий Издательство ОпцииПоявится диалог.

Публиковатьэр Опции

6. SИзбрать 3D, Схемаи Чарты форматы и показывать ли название, описание или Свойства взглядов из доступных вариантов (см ниже ноты для комментариев на различных форматов).

7. Если вы хотите, чтобы установить начальную страницу опубликованной модели к конкретной зрения, то проверьте Используйте View в качестве начальной страницывариант, и перейдите к мнению с помощью кнопки "...", который становится доступен.

Заметка

Только мнения, выбранные в разделе областях, как за шагом 4 выше доступны быть установлен как на стартовой странице.

8. Если вы хотите получить обратную связь по конкретным страницам в опубликованной модели, то убедитесь, что E-mail Обратная связьопция, введите адрес электронной почты, в Адрес электронной почты текстовое окнои редактировать E-mail телараздел в соответствующих, Если вы не хотите, чтобы обратная связь отправлено снимите флажок напротив E-mail Обратная связьвариант, и оставить текстовое пустым.

9. Нажать на ОККнопка.

10. Нажать на ПросматриватьКнопка.

11. Просмотр папокОкно будет отображаться.

12. Выберите нужное место для хранения HTML файл верхнего уровня (и любые автоматически сгенерированные файлы).

Заметка

Это хорошая идея, чтобы создать отдельную папку (как правило, называют "Опубликовано"), используя Создать папкуКнопка в нижней части диалогового окна, чтобы сохранить файл HTML верхнего уровня и любые автоматически сгенерированные файлы.

13. Нажать на ОККнопка.

14. Путь к папке будет отображаться в Каталог текстовое окно.

15. Нажать на КонецКнопка.

- или -

15. Введите путь к папке в Каталогтекстовое, где вы хотите, чтобы сохранить файл HTML верхнего уровня (и любые автоматически сгенерированные файлы).

16. Нажать на КонецКнопка.

Заметка

Экспорт из Диаграммыочень редко удается, чаще всего, когда компьютер находится вне памяти (как правило, при использовании очень больших файлов). Неудачная экспорт будет повторен один раз. Там будет одно предупреждение для неудачной первой попытки, и второе предупреждение, если повторно не удается попытка. Поэтому, если только предупреждения "Первая попытка не удалась" те, то публиковать был успешным. Если повторную попытку не удается, попробуйте издательство меньшую часть файла или освободить некоторые системные памяти.

Сохраненный HTML файл (ы) в настоящее время может быть вид из его местоположения или скопировать на защищенный веб-сайт.

Опубликовать в сети в Internet Explorer10

Любые гиперссылки которые были созданы в оригинальной модели будут сохранены в опубликованном модели и нажав на ссылку, перейдя по ссылке к месту назначения (если она была опубликована). Кроме того, какие-то элементы в опубликованных схемах, которые уже не гиперссылками в исходной модели будет от гиперссылкой назад к их соответствующим элементам в дереве (если он был) и опубликованных нажав элемент в опубликованном диаграмме внимание будет прыгать обратно в соответствующая расположение в дереве. Эта функция похожа на "Показать В обозревателе" правой кнопкой мыши функции в ABACUS.

Заметка

Avolution настоятельно рекомендует программное обеспечение и файл следующие форматы должны использоваться в полной мере использовать публикации в Интернете функциональности ABACUS:

1. Internet Explorer (80,0 и выше)Для просмотра опубликованного вид проводника. Mozilla Firefox (30,0 или более поздней версии)Также рекомендуется и полностью поддерживаетОднако, при использовании рекомендованного формата SVG для диаграмм, то в Firefox 9 Вы можете использовать только родной SVG Viewer поддержку, которая, к сожалению, не позволяет масштабирование или панорамирование.

2. Adobe SVG Viewer 3.0 вставной (скачать с Вот ) а также SVGФормат файла для опубликованный диаграммы, Формат изображения SVG для диаграммырекомендуется, потому что, SVG является формат изображения векторной и, следовательно, это "потеря менее" и выглядит намного лучше, на любом данном уровне масштабирования, чем любой из других форматов, SVG можно импортировать в MS Visio, SVG можно увеличивать до любого уровня или разрешения , SVG имеет ссылки на дереве для соединений (не только компоненты), SVG всегда печатает на лучшего разрешения, и, SVG составляет примерно половину размера файла из других форматов. PNG является Следующая рекомендация, однако, как это rasterised формат на определенных уровнях масштабирования ясность зрения будут потеряны и нажав соединения на диаграммах не будет прыгать обратно в соответствующем месте в дереве. БМП рекомендуется, так как в то время как это "без потерь" форматировать размер файла 100x, что из других форматов и 20MB изображений нет ничего необычного.

Компромисс с SVG является то, что зритель будет SVG должны быть установлены, и вы должны убедитесь, что .svg изображения / SVG + XML добавляется типы MIME веб-сервера. После установки зрителя SVG Microsoft Internet Explorer попросит вас принять условия лицензионного соглашения зрителя, а затем он должен работать нормально. И хотяMozilla Firefox поддерживает SVG файлы изначально, плагин Adobe по-прежнему рекомендуетсячтобы иметь возможность для увеличения диаграммы, если вы используете Firefox 8 или выше (если вы используете Firefox 9 Вы не можете отключить родной просмотра SVG), После установки плагина для Adobe была запущена, следующие шаги необходимые использовать его в Firefox:

· Откройте Firefox и введите "о: конфигурации" (без кавычек) в строке URL.

· Прокрутите вниз и найдите свойство svg.enabled(если вы используете Firefox 9, то просмотр родной SVG не может быть отключена, и это свойство не существует), Двойной щелчок на нем, чтобы отключить его.

· Теперь найти каталог, в котором установлен плагин SVG (например, C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Скопируйте файлы NPSVG3.dll и NPSVG3.zip и вставьте их в папку плагинов Firefox (например, C: \ Program Files \ Mozilla Firefox \ плагины)

· Закройте все экземпляры Firefox

3. ABACUS просмотра 3D Avolution в (3.1 и выше) а также .abacus3D Avolution вФормат файла для опубликованных 3D видом. В то время Кортона VRML Client плагин (2.0 и выше)доступно для просмотра VRML версии опубликованных видом это не бесплатно для коммерческого использования и по-прежнему требует установки на стороне клиента. Счеты 3D Viewer является более навороченный, чем любой VRML просмотра и находится в свободном доступе для скачивания Вот , В любом случае убедитесь, что вы добавить .vrml х-мир / X-VRML и .abacus3d приложений / октет-поток в типы MIME веб-сервера.

4. PNGФормат файла для опубликованных видом диаграммы. Формат изображения PNG взглядов График рекомендуется, потому что в то время как это rasterised формат и есть "потери" компромисс между размером файла и ясности графика, как правило, лучше. БМП рекомендуется, так как в то время как это "без потерь" форматировать размер файла 20x, что из других форматов и 2Mb графиках нет ничего необычного.

Если вы хотите изменить внешний вид веб-страниц, вы можете отредактировать файл начальной страницы имени mainPage.html и файл стилей с именем abacus.css. Вы найдете эти файлы в ту же папку, вы решили сохранить файл HTML верхнего уровня. Для получения более подробной информации о структуре и пошив опубликованной выхода в следующем разделе.

Структура ABACUS опубликованные модели

Счеты опубликованы модель структурирована следующим образом:

1. Папка верхнего уровня содержит несколько файлов и предполагая, что все варианты включены в ABACUS Опубликовать на веб-конфигурации диалог будет включать в себя индекс.HTMLФайл состоит из трех кадров; treeView.html, findNode.html а также mainPage.html а потом shortcutError.htmlстраница, TreeView.html населена tree.js, tree_items.js а также tree_tpl.js JavaScript файлы, расположенные под включать папки (обсуждается ниже) и повторяет Explorer, дерево из ABACUS. FindNode.html питается от find.js Javascript файл, расположенный в папке (обсуждается ниже) включают в себя и будет искать ветви дерева, а не только видимые узлы. Tон mainPage.html является статическим HTML-страница, которая может быть адаптирована с корпоративными логотипами и т.п.и будет показана, если начало страницы не выбирается при публикации.И, наконец, страница shortcutError.html является целевая страница для любых неправильных ярлыков из дерева из-за соответствующих страницах не опубликованы.

Наконечник

Вы можете пропустить mainPage.html вообще по предпочитают использовать стартовую страницу при публикации или изменив файл index.html, чтобы она указывала на данном зрения (скажем) путем редактирования кадра SRC = строки "mainPage.html", чтобы указать непосредственно на первый взгляд, в первую архитектуры, обычно '' рамочного схему.

2. Ввода верхнего уровняNCLUDEПапка содержитING различный JavaScript (.js) и каскадных таблиц стилей (CSS-файлы), используемые файлов .html всей опубликованной модели.

3. Папка Содержимое верхнего уровня содержитВ алфавитном порядке;

· А '3D Просмотры' Папка снумерованныйHTML-страница и VRML или abacus3d файл для каждого из опубликованных 3D видом, Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· Архитектуры Папка с номерным HTML страницы для каждой архитектуры, который был опубликован. Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· A Каталоги папка, содержащая нумерованный HTML-страницу для каждой из опубликованных каталогов. Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· A Диаграммы Папка снумерованныйHTML-страница и PNG, JPG и т.д. файл для каждого из опубликованных видом диаграммы, Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· A Компоненты папку, содержащуюнумерованныйHTML-страница для каждой из опубликованных компонентов, Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· A Связи папку, содержащуюнумерованныйHTML-страница для каждой из опубликованных соединений, Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· A Диаграммы папку, содержащуюнумерованныйHTML-страница и PNG, SVG и т.д. файл для каждого из опубликованных диаграммы. Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· иконки под-папка с различные образы, используемые в опубликованных модели.

· A Стандарты подпапка снумерованныйHTML-страница для любого стандартыкоторые были опубликованы. Смотрите примечание ниже для получения информации о схеме нумерации файлов.

· A Шаблоны суб-folder с коллекцией пронумерованных подпапки для каждого шаблона, опубликованной в рамках проекта. В каждой подпапке является Компоненты и папку Подключения и в них является номером страницы HTML для каждого компонента и подключения шаблона. Смотрите примечание ниже для получения информации о схеме нумерации папок / файлов.

· A Виды суб-папка с компонента а такжеПодключение суб-папок снумерованныйHTML-страница для любого компонента а такжеТипы подключения, которые были опубликованыи коллекция пронумерованных подпапки для каждого типа, опубликованной в рамках проекта, содержащего HTML-страницу для каждой из ограничений. Смотрите примечание ниже для получения информации о схеме нумерации папок / файлов.

· A Посмотретьточкаs подпапка инумерованныйHTML-страница для любого из видомточкас, которые были опубликованы. Смотрите примечание ниже для получения информации о схеме нумерации файлов.

Заметка

Нумерация страниц HTML (и В некоторых случаях Файлы изображений) совпадает с уникальный Я БЫ для каждого объекта хранилища, который был устанавливается при это было созданныйв ABACUS (именуемые EEIDs), Этот идентификатор не изменится, так в виде диаграммы, виды, компоненты и т.д находятся обновленный Oни будемкак и раньше сохраняют тот же идентификатор. В любом случае, соответствующая объект репозиторияИмя может быть найден рядом с начала страницы HTML между ... HTML-теги.

Ограничение доступа к определенным страницам / Просмотров с IIS

При использовании IIS в качестве веб-сервера для опубликованного модели, Вы можете быть в состоянии ограничить доступ к определенным страницам / Просмотров использованием метода ниже:

1. Создать сайт в IIS (еще один, если есть существующий вы не хотите мешать).

2. Изменение свойства-> Каталог Безопасность-> анонимный доступ - снимите флажок анонимный доступ и использование аутентификации доступа.

3. Если это просто обычный сервер без каких-либо осложнений доменных и т.д., то вы должны использовать опцию 'Integrated Windows аутентификации ", которая будет затем использовать серверные машины местных пользователей / логинов как аутентификации, и просто добавить пользователей на локальном компьютере (будьте осторожны, что вы осведомлены о последствиях, безопасности мудрым, из добавления новых пользователей к машине, например, в зависимости от того, удаленный доступ установка для машины, и т.д.).

4. Добавьте разрешения на конкретные файлов / папок, как требуется. Щелкните правой кнопкой мыши отдельные файлы / папки -> Свойства и настроить разрешения безопасности, как обычно для файлов / папок.

Это может отличаться в зависимости от версии IIS и какие конкретные Операционная система Windows находится на сервере, и есть ли у вас домен или другие различные настройки.

Смотрите также

Заполнение архитектуру | Анализируя архитектуру


Экспорт вашей архитектуры

Навигация: Отчетность по вашей архитектуры>

Экспорт вашей архитектуры

Отправить комментарии на эту тему.

ABACUS позволяет дляэкспортировать архитектуру .mdb (Microsoft Access), MS SQL Server, .abacus (ABACUS файл), и .xls формате (Microsoft Excel). Вы также можете экспортировать схемас до PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF и BMP формате и ваших отчетов .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) и .rtf (Rich Text Format) форматы. Это позволяет анализировать и просматривать архитектуру и свои данные в любом случае вы хотите.

Чтобы экспортировать архитектуру .mdb (Microsoft Access)

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Нажать на файл меню.

3. Выбрать Экспорт, а потом Для MDB.

4. Принять к сведению предупреждения и нажмите ОК.

5. Введите имя для файла.

6. Нажмите СохранитьКнопка.

Заметка

Формат экспорта базы данных MDB-это специфичные для ABACUS и каких-либо изменений в схеме приведет к невозможности повторного импорта. Пожалуйста, посмотри Заполнение с MS Access для описания схемы MS Access.

Чтобы экспортировать архитектуру MS SQL Server

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Нажать на файл меню.

3. Выбрать Экспорт, а потом Для MS SQL Server.

4. В появившемся диалоговом окне нажмите кнопку Экспорт Бланк MDB ...Кнопка и импортировать это в вашем сервере базы данных MS SQL Server.

5. Заполните информацию базы данных и строки подключения.

6. Нажмите ЭкспортКнопка.

Заметка

Формат экспорта из MS SQL ServerБаза данных специфичные для ABACUS и каких-либо изменений в схеме приведет к невозможности повторного импорта. Пожалуйста, посмотри Заполнение с MS Access для описания схемы базы данных.

Чтобы экспортировать архитектуру .xls (Excel файл)

1. Убедитесь, у вас есть ABACUS открыть файл А.Н. исследователь отображается , И архитектура добавил .

2. Убедитесь, у вас есть Excel Импорт / Экспорт конфигурации файла определены.

3. Щелкните правой кнопкой мышина архитектуре в вашей модели или любой части Компонентыузел (в данной архитектуре), вы хотите экспортировать в конфигурационный файл Excel.

4. Выбрать Экспорт | Для Excel ... из меню.

5. Выберите Excel Импорт / Экспорт конфигурации Файл использоватьОткроется окно.

6. Выберите соответствующий файл конфигурации для вашего архитектурной модели и нажмите на открытоКнопка.

7. Если автоматически не сделано, карта компоненты верхнего уровня в текущей архитектуры к Установить идентификатор(как определено ранее) и нажмите на Экспорт ....

Пример отображения компонентов верхнего уровня

8. Выберите местоположение и имя файла для файла Excel и нажмите СохранитьКнопка.

Чтобы экспортировать архитектуру .abacus (ABACUS файл)

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Щелкните правой кнопкой мышина архитектуре узла, любая архитектура в вашей модели или любую часть дерева компонентов.

3. Выбрать Экспорт | Для Файл...из меню.

4. Выберите местоположение и имя файла и нажмите СохранитьКнопка.

Заметка

Вы можете импортировать файл обратно в ABACUS ABACUS от следующих шагов 1-2выше, и затем выбора Импорт | Из Файл..., После того как вы выбрали файл, который вы хотите импортировать, вам будет предложено, как вы хотели бы импортировать стандарты и типы. Вы можете импортировать стандарты и типы как новые или объединены стандартов и типов. По умолчанию для стандартов и типов, которые будут объединены с существующими стандартами и типам, если они уже существуют в вашей проект.

Чтобы экспортировать архитектуру .xml

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Щелкните правой кнопкой мышина архитектуре узла, любая архитектура в вашей модели или любую часть компонентов дерева.

3. Выбрать Экспорт | Для XML ...из меню. В качестве альтернативы вы можете нажать на меню файл| Экспорт| Для XML ...

4. Выберите местоположение и имя файла и нажмите СохранитьКнопка.

Заметка

Вы можете импортировать XML файл обратно в ABACUS от следующих шагов 1-2выше, и затем выбора Импорт | Из XML ..., После того как вы выбрали XML файл, который вы хотите импортировать, вам будет предложено, как вы хотели бы импортировать стандарты и типы. Вы можете импортировать стандарты и типы как новые или объединены стандартов и типов. По умолчанию для стандартов и типов, которые будут объединены с существующими стандартами и типам, если они уже существуют в вашей проект.

Чтобы экспортировать диаграмму PNG, JPG, SVG, TIFF, GIF или BMP

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Открой схемаВы хотели бы экспортировать.

3. Нажать на Экспорт DiagramКнопка на Схема Панель инструментов.

4. Экспорт ДиаграммаПоявится окно.

5. Выберите ПросматриватьКнопка для сохранения визуализации в нужное место.

6. Выберите Сохранить какВ раскрывающемся меню выберите тип файла.

7. Нажмите СохранитьКнопка.

Чтобы экспортировать отчет в формате .pdf (Adobe Acrobat), .xls (Microsoft Excel) или.doc (Microsoft Word)

1. Убедитесь, у вас есть ABACUS файл открытый.

2. Создать отчет Вы хотели бы экспортировать.

3. Нажать на ЭкспортКнопка на панели инструментов отчетов.

4. Выбрать Excel, PDF или Словоиз выпадающего списка.

5. Подождите несколько секунд, пока экспорта отчетов.

6. Выберите местоположение и имя файла и нажмите СохранитьКнопка.


Работа с Enterprise Server

Навигация: Администрирование>

Работа с Enterprise Server

Отправить комментарии на эту тему.

ABACUS Предприятие Сервер является и «без блокировки» совместный подход, но "отключен" можно также. Счеты "не-замок", потому что это не заставить файл быть заблокирован одним пользователем для того, чтобы быть обновлены. Каждый пользователь имеет свой собственный локальную копию файла, и как они делают изменения и сохранить их файл, эти изменения регистрируются и хранятся в течение, когда пользователь желает совершить их на сервер.

Счеты "отключен" в том смысле, что вы не должны быть подключены к серверу или нужно доступ к сети во время работы с файлом. ABACUS требуется доступ к серверу только при выполнении операций, как создание файла или выполнение проверку, наряду с операциями на существующий файл - обновление, совершить или просмотра журнала прошлых совершает. Доступ к серверу не требуется, чтобы работать с файлом, и ваши изменения не отправляется на сервер сразу (это позволяет легко отменить изменения, если вы сделаете ошибку). Когда вы сохраните файл, вы "просто" экономить ваше копия локально - это не пока вы не зафиксируете, что ваши локальные изменения (изменения, внесенные со времени Вашего последнего совершить), отправляются на сервер.

Создание нового файла Enterprise

Чтобы создать новый файл Enterprise, выберите файл| Новый ...а затем выберите один из первых двух вариантов в разделе Предприятие модель Новый диалог Project (т.е. либо пустой файл Предприятие, или создать из существующего файла ABACUS). Третий вариант заключается в "Checkout" файл Предприятие кто-то уже создан, это будет рассмотрено в следующем разделе.

Когда вы решите создать новый файл Enterprise, вы получите диалоговое окно, которое позволит вам просмотреть, где на сервере репозитория вы хотели бы хранить ваш файл. Он также будет иметь существующий путь к файлу и имя вошло на вершину, если вы выбрали "От существующей модели 'в диалоговом окне New Project и поставляется файл.

Ссылка: Это URL на сервер репозитория, где файлы ABACUS Enterprise будут сохранены. Вы должны спросить человека, который управляет сервер, что этот адрес должен быть.

На рисунке выше показано хранилище с четыре (4) существующих проектов ABACUS предприятия, после ввода URL и нажав Enter. Вы увидите после создания нового файла Enterprise, на следующий скриншот для '' Checkout, там будет другой папки и файла под этот репозиторий.

Заметка

Если вы используете HTTPS (SSL) сервера, а сервер не имеет действительный сертификат SSL (общий для интранет или непубличных серверов из-за Стоимость сертификата SSLs) Будет дополнительный шаг. Вам будет необходимо постоянно принимать все подключения к этому серверу в диалоговом окне, которое всплывает (это также показать немного больше информации на сервере). Чтобы сделать это, типа «р» (без кавычек) и нажмите Enter. ABACUS появится сообщение с напоминанием об этом, прежде чем показывать диалог.

Заметка

Вас могут попросить, чтобы войти на сервер в этом случае человек, который управляющий серверможет обеспечить имя пользователя и пароль сервера. Кроме того, учетные данные для всех серверов, которые вы, подключенных к сохраняются, так что если какой-либо причине они должны быть очищены, это может быть сделано с помощью Инструменты | Опцииа затем на Генеральная Вкладка нажав Сброс Subversion Сохранено Логини выбрав сервер из раскрывающегося списка и нажав Ясно Войтии выбора ОК в появившемся диалоговом окне.

Заметка

В отличие от экрана, показанного выше, как правило, один ABACUS Проект включен в каждом ABACUS хранилище, потому что если более чем 1 ABACUS Проект создан в одном ABACUS хранилище, число журналов изменение ABACUS разделяют всех ABACUS проектов, и это может запутать пользователей.

Предпочтительный Супер: Это влияет как папку и имя файла, который будет использоваться (если уже не принято) при создании файла на сервере репозитория. Обратите внимание, что новая папка будет создана автоматически на сервере репозитория для каждого файла (из соображений производительности, файлы ABACUS Enterprise создаются в отдельной папке под расположение просматриваемой в диалоге).

Храните рабочую копию в каталог: Если файл Предприятие создается на сервере репозитория, местные рабочие файлы должны быть созданы на компьютере, так что вы можете работать с файлом без подключения к сети. Это то место, которое вы будете просматривать, когда вы хотите, чтобы открыть / вновь открыть файл ABACUS Enterprise.

Заказ существующего предприятия File

Если кто-то уже создал новый файл Enterprise, вы можете "проверка" это файл, который загружает локальную копию и устанавливает необходимые файлы, так ABACUS признает это как файл Enterprise. Этот диалог похож на Нью-Enterprise File Dialog. Введите URL репозитория (подкаталоги могут быть включены в URL), выберите нужный файл и нажмите кнопку ОК. С учетом записки ниже Тон файл будет открыт.

Заметка

Вас могут попросить, чтобы войти на сервер в этом случае человек, который управляющий серверможет обеспечить имя пользователя и пароль сервера. Кроме того, учетные данные для всех серверов, которые вы, подключенных к сохраняются, так что если какой-либо причине они должны быть очищены, это может быть сделано с помощью Инструменты | Опцииа затем на Генеральная Вкладка нажав Сброс Subversion Сохранено Логини выбрав сервер из раскрывающегося списка и нажав Ясно Войтии выбора ОК в появившемся диалоговом окне.

Различия Предприятие файлов

Когда вы создали файл Enterprise (или новый, или с помощью "проверки" в файл, созданный кем-то другим), папка будет создана для файла, и он будет часто содержат эти 3 основные типы файлов:

· Файл '.abacus "- Это сам файл счеты. Изменения, внесенные локально не немедленно сохраняются в этом файле, он написал только, когда вы совершаете. Этот файл является "нормальным" АБАК файл, он может быть предоставлена ​​пользователям не-е-екак проект автономного (без .log файл), Или использоваться в качестве отправной точки для нового файла EE.

· Файл '' .changes- Местные (неподтвержденные) изменения, внесенные в файл. Если этот файл отсутствует, это означает, что нет локальных изменений.

· '.журнальный файл- Этот файл имеет только изменения, которые были сделаны последним пользователем (содержание файла .changes пользователя, когда они совершенные).

Заметка

Есть различные другие файлы, которые могут быть созданы во время обновления и совершают процессы, а именно: ‘.changesbefore' файл- Этот файл является копией файла .changes после обновления была выполнена и используется для автоматического согласования любых ID конфликты между обновлением и любой местный (незавершенных) изменения, прежде чем совершить; ‘.резервное копирование' файл- Этот файл является копией файла .changes, прежде чем пользователь экономит больше местных (неподтвержденные) изменения в файле .changes; а также ‘.ошибка' файл- Этот файл является копией .changes файл, если какая-либо ошибка, которая приводила к сбою счеты, чтобы открыть файл .abacus и пользователь выбрал, чтобы вернуться их изменения.Эти файлы могут быть проигнорированы.

Открытие файла

Чтобы открыть файл, вам нужно только, чтобы просмотреть, где вы выбрали для хранения рабочей копии, и откройте файл ABACUS, которая хранится там. При АБАКУС видит, что существует .лог-файл (и, возможно, .изменения файла, если вы внесли изменения), это будет относиться к файл как файл Enterprise.

Обновление файла

ВыполнениеN 'Обновление' будет проверить, если новая версия файла находится на сервере. Если есть, он закроет текущий файл, обновление до новой файла с сервера, и скачать некоторые временные файлы, которые имеют ряд как расширение - например, "Demo.125. Эти файлы являются старые версии файл .log, и используются, чтобы определить, какие изменения были сделаны в файле, так как вы в последний раз обновлена. Это необходимо для выявления каких-либо конфликтов, что, возможно, произошло так, что вы можете решить их.

Если в процессе обновления любой конфликты были найдены, Вам нужно будет решить их, прежде чем вы можете открыть файл снова (вы можете отменить но Вам будет предложено разрешить конфликты сновав следующий раз вы открываете файл).

Сохранение файла

Когда вы сохраните файл, это добавляет любые изменения, внесенные в файл .changes. Это неизменить файл .abacus на данном этапе - только тогда, когда файл будет зафиксирован на сервер оно будет написано над (или когда вы получаете обновления с сервера).

Где "Сохранить как"?

Там не существует понятия Сохранить как для файлов Enterprise. Однако вы можете скопировать вашу рабочую копию файла .abacus, имея в виду, что это не будет иметь свои локальные изменения в ней.

Разрешение конфликтов

Если другие пользователи, совершившие изменения в файле в подобном части файла к вам, там могут быть некоторые конфликты между их изменениями и ваша. Например, другой пользователь может удалить компонент, который вы имели обновить собственности на, Вам нужно либо отменить их изменение (если вы уверены, что их следуетне произошло), или отказаться от вашего изменения (то вы можете вернуться в файл и повторить ваши изменения).

В частности есть 4 класса конфликтов, которые могут возникнуть;

1. Удалить - Когда один пользователь удаляет объект, который еще изменения пользователей. Например. Пользователь A удалил компонент, но пользователь B изменил название компонента или подключенных к нему или добавить компонент детского ему и т.д.

2. Атрибут - Когда два пользователя оба изменить тот же 'атрибут' объекта. Например. Оба пользователя А и пользователь Б сменил имя данного компонента или ее описание или значение одного из своих свойств и т.д.

3. Справка - Когда два пользователя изменить тот же "ссылка" объект имеет к другому объекту. Например. Оба пользователя А и пользователь Б изменилось тип компонент, или компонент-источник / приемник присоединен к связи или связанного точки зрения для схема, и т.д.

4. Коллекция - Когда два пользователя изменить "коллекцию" для объекта. Например. Оба пользователя А и пользователь Б переехал компонент из одного родителя к другому или повторно заказать коллекцию детских компонентов.

Заметка

Различные несущественные конфликты разрешаются автоматически по ABACUS, чтобы минимизировать накладные расходы на пользователей.Например конфликтующие настройки пан-зум для диаграмм решил сохранить все настройки пан-масштабирования.

Фиксация изменений

Когда вы решите совершить изменения, файл ABACUS с сервера открыт, ваш местный изменения выполняются против этого, а потом Ваш местный .abacus файл переписывается с одним, что имеет свои изменения в нем. Изменения файл перезаписывает файл .log, и оба файла .abacus и .log файл отправляются на сервер.Если совершить это успешные Диалог фиксации сообщение, как показано ниже, при условии, чтобы ввести сообщение с фиксации.

Просмотр журнал изменений

Для просмотреть журнал изменений к Предприятие проект, Выбрать файл| Посмотреть журнал...

Максимум записей в журнале: Эта по умолчанию в последних 10 записей, но дополнительные данные могут быть получены путем изменения значения и нажав Извлекать Кнопка.

Пересмотр: ЧтКолонка E Редакция перечислены номера версий, совершенные на сервер Enterprise, по умолчанию, в обратном хронологическом порядке.

Заметка

Номера ревизий не может быть непрерывным, как только ABACUS совершает будут перечислены в то время как тот же репозиторий Subversion может быть используется для других проектов ABACUS и / или других приложений, управления версиями.

Дата: ЧтE Дата столбце перечислены даты, что пересмотр было совершено на сервер Enterprise.

Время: ЧтКолонка E Время перечисляет время суток (в 24-часовом формате), что пересмотр было совершено на сервер Enterprise.

Автор: Чте Автор столбце перечислены регистрационное имя Microsoft Windows для пользователя, выполняющего процесс фиксирования с последующей их ABACUS имя пользователя Или "Анонимные", если пользователь не прошел проверку подлинности и анонимных пользователей разрешили доступ к проекту Enterprise во время фиксации.

Войти Сообщение: ЧтКолонка E Вход Сообщение перечислены совершить сообщение, предоставленный с пересмотром в соответствии с диалога, показанного выше.

Скачать редакция ХХ в автономном файле ABACUS: Если вы выберите данную ревизию в таблице, а затем нажмите кнопку Загрузить, вы сможете извлечь выбранную ревизию проекта ABACUS с сервера и сохраните его в качестве локального / автономного проекта ABACUS.

Заметка

Чтобы вернуться к предыдущей ревизии см это Avolution сообщество статья .

(Администратор) Скачать файл XML для Войдите пересмотра XX: Люди с возможностью администратора ABACUS можете выбрать данную ревизию в таблице, а затем нажмите кнопку Загрузить, чтобы извлечь выбранный проект ABACUS совершить файл журнала с сервера и сохранить его в виде файла .xml.

Просмотр в аудита изменений

Для смотреть аудита изменений в любой момент элемента (т.е. компонента, соединение, вид, детей и т.д.) Ан Предприятие проект, щелкните правой кнопкой мыши элемент и Выбрать Аудиторский след...Установите От и До диапазоне Ревизионной и нажмите Поиск.

Заметка

После того, как элемент будет удален из проекта вы больше не сможете получить доступ к информации контрольного журнала о том, что элемент. Вы можете, однако, по-прежнему обращаться к компоненту «родитель» (например) и увидеть информацию аудита след о удаления (в этом случае список идентификатор элемента, который был удален).Кроме того, компонент / крепление соединения является "собственностью" из соединения, так меняющихся прикрепленный компонент через окно Проводник или на диаграммах покажет в журнале аудита для связи не на компонент, и удаление соединения и создания нового соединения (как произойдет, если вы щелкните правой кнопкой мыши "Unattach", а затем "Connect ..." в каталогах) приведет к потере информации аудита для оригинального компонента - всего вложение соединения.

Заметка

По умолчанию аудита рекурсивно проверить изменения в любой из детей выбранного элемента. Это может привести к увеличению времени отклика и, соответственно, аудита могут быть ограничены самого элемента сняв флажок Рекурсивный Опция под Аудит Опции"шестерня" кнопка на панели инструментов в диалоговом окне аудита.

От пересмотра: Эта по умолчанию будет первой / старейшей пересмотра имеющихся в проекте на сервере предприятия.

Для пересмотра: Эта по умолчанию будет последней / недавний пересмотр имеющихся в проекте на сервере предприятия.

Заметка

После установки От и До пересмотра диапазон нажмите кнопку Search, чтобы получить какие-либо конкретные изменения в выбранного элемента.

Пересмотр: ЧтКолонка E Редакция перечислены номера версий, совершенные на сервер Enterprise, по умолчанию, в прямом хронологическом порядке.

Заметка

Номера ревизий, вряд ли будут непрерывно как только изменения, относящиеся к выбранной элемента будет показано и только ABACUS совершает будут перечислены в то время как тот же репозиторий Subversion может быть используется для других проектов ABACUS и / или приложений контроля версий.

Дата: ЧтE Дата столбце перечислены даты, которая была сделана действие пользователя.

Заметка

Дата показано дата действия пользователя, а не дата пересмотра было совершено на сервер Enterprise. Соответственно, дата может предшествовать соответствующий пересмотр фиксации даты, указанной с Файл | Посмотреть журнал...Команда.

Время: ЧтКолонка E Время перечисляет время суток (в 24-часовом формате), что действие пользователя было сделано.

Заметка

Время, показанное время действия пользователя, не время пересмотр было совершено на сервер Enterprise. Соответственно, время, скорее всего, предшествуют соответствующий пересмотр время фиксации, показанного с установленными Файл | Посмотреть журнал...Команда.

Автор: Чте Автор столбце перечислены пользователю, что выполняется действие в Microsoft Windows Войти Имя последующим их ABACUS имя пользователя Или "Анонимные", если пользователь не прошел проверку подлинности и анонимных пользователей разрешили доступ к проекту Enterprise во время действия пользователя.

Заметка

Автор перечислены в диалоге Audit Trail не обязательно соответствовать Автор перечисленные в диалоговом окне View Log выше для той же ревизии. Это потому, что диалог списки Просмотр журнала вошедшего в систему пользователя в момент фиксации пока диалог списки Audit Trail вошедшего в систему пользователя на время действия пользователя, и это возможно иметь один пользователь вносить изменения и отправить их. изменения файла другому пользователю совершить - как в случае, когда внешний пользователь (например, Avolution) является работа над проектом EE.

Детали: Чте Подробнее столбце перечислены точные детали действия пользователя, как записано на сервере Enterprise.

Наконечник

Полезно Группа в колонке Ревизионной (как показано в диалоге выше) и / или колонка Действие пользователя для легко классифицировать изменения интересующего элемента.

Использование сценариев с файлами Enterprise

Если вы используете скрипты с файлами Enterprise, вы должны быть осведомлены о том, как правильно удалить объект из модели. Как правило, когда вы удаляете объект, вы вызываете метод .Delete () на нем, а не только его удаления от своего родителя.

Например. если вы COMP1 как родитель comp2, и вы хотите, чтобы удалить COMP2 в сценарии, вы должны позвонить comp2.Delete (), а не comp1.Components.Remove (COMP2).

Вы можете использовать удалить, если вы намерены добавить объект COMP2 в другое место в пределах архитектуры, но это не должно использоваться, если есть намерение удалить объект.

Существует исключение из этого, когда вы хотите, чтобы удалить объект, который "живет" в другом месте модели. Если вы хотите, чтобы удалить стандартный экземпляр из архитектуры / Компонент / связи, то вы могли бы сделать так, удалив его из стандартного коллекции экземпляра - Arch1.Реализации.Снять (Имп) - из-за его удаления будет удалить его из всех случаях.

Правильно используя Удалить в скриптах важно, потому что, если объект будет удален из objectmodel и повторно не добавляется, то он не сможет быть расположен, но так как это не было специально «удален», Обнаружение и разрешение конфликтов не будет правильно обнаружить конфликт, если другой пользователь, чтобы попытаться использовать этот объект в любом их изменений, и конечный результат будет поврежден набор изменений для этого пользователя.

Смотрите также

Как архитектура представлена ​​в ABACUS?


Работа с разрешениями

Навигация: Администрирование>

Работа с разрешениями

Отправить комментарии на эту тему.

Проекты могут иметь ABACUS ролевойполномочия, установленные для каждого элемента в хранилище. В частности, мелкозернистый Create-Read-Update-Delete (CRUD) Права могут быть установлены на «объект» (то есть компонента или соединение), вид и атрибута (т.е. собственности) уровнях.

Обзор

При работе с ABACUS Предприятие Сервер , ABACUS обеспечивает мелкозернистых ролевые разрешения CRUD контролировать доступ нескольких пользователей к хранилищу.

Заметка

Чтобы настроить разрешения в проекте ABACUS лицензия пользователь нуждается в возможности администратора. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

Разрешения могут быть установлены для архитектур, комплектующих и соединительных типов, свойств (с помощью их типов), шаблоны, точки зрения и схемы, каталоги, матрицы, графики и 3D Просмотры, Когда позволения установлены для компонента или соединения типа все экземпляры этого типа в любых архитектур в этом проекте "наследуют" эти разрешения. Точно так же, когда установлено разрешение для свойства компонента или подключение типа, данного имущества на экземпляров компонента или соединения в любых архитектур в этом проекте "наследуют" эти разрешения. Соответственно, определенные права доступа будут применены к мнению, на которой существуют эти элементы. При права установлены на диаграмме, вид и / или содержимого самой зрения имеют различные права доступа к нему применимы.

Заметка

По умолчанию никаких разрешений не установлены для элементов в проекте ABACUS. То есть все элементы Createable, чтения, Обновляемые и Deleteable всех пользователей. Таким образом, права следует рассматривать только для данного элемента в хранилище, когда определенный разрешение должно быть ограниченныйдля определенной группы пользователей. Например, если разрешения для данного пользователя группы были добавлены к объекту (например, тип компонента), но оставил при включенном все разрешения, то это функционально то же самое, как если бы группа пользователей не добавлены к объекту.

Разрешения не могуустановить для конкретных экземпляров элементов для архитектуры. Например, вы не можете сделать один компонент Применение обновляемыми еще один нет. Для эффективного достижения этих "конкретной области" разрешения, однако администратор может настроить определенные типы элементов для заданных областей, например, Заявка - домен CRM »типов компонентов и« Применение - домен HR », а затем установите права доступа для каждого типа соответственно. Вы можете сделать определенные типы Группировка для каждого домена, а затем удалить разрешения обновления для предметно-ориентированного типа группы, и это будет ограничивать в пределах творения и удалений от Группировка, но не обновлять детей. Конечно, если домен конкретных Группировка была скрыта путем удаления разрешения чтения, то дети будут скрыты и, таким образом, не обновляемый. Кроме того, если просмотров (а не исследователя) используются в основном для управления / просмотра репозитория, данное представление для каждого домена может быть создана, а затем администратор может установить разрешения для каждого вида соответственно.

Управление пользователями и группами

Разрешения определяются на роль или группаУровень, в отличие от отдельных пользователей, так что в то время как состав групп может изменяться, разрешений может оставаться фиксированной. Конечно, если вы хотите специальное разрешение пользователя, то просто сделать их группу, или, точнее, создать группу с этим пользователем в качестве единственного члена.

Следует отметить, что группы атомная, То есть они не могут наследовать разрешения или пользователей от одного к другому, и если пользователь принадлежит к нескольким группам, то наиболее "пессимистический" разрешение группы будут иметь приоритет в каждом конкретном случае на индивидуальной основе для каждого отдельного разрешения (т.е. Создание -Чтение-Update-Delete). Например, если тот же самый пользователь является членом группы А и группы В и группы А только Create-разрешение на чтение для типов компонентов приложений, а группа B только для чтения Обновление разрешение для типов компонентов приложения, то пользователь будет иметь только разрешения на чтение для экземпляры компонентов приложения.

Кроме того, по умолчанию, анонимные пользователи(то есть пользователи, которые не были определены или которые не вошли в) имеют полный доступк проекту. Это делается для того, что доступ в Интернет предоставляется в начальной конфигурации. Чтобы заблокировать доступ анонимных пользователей просто снимите "Разрешить анонимный пользователь полный доступ к файлу" вариант в Управление пользователей / групп диалоговое окно, показанное ниже. Когда непроверенные анонимных пользователей будет только иметь возможность видеть часть стандартов любого проекта.

Наконец, если опция "Использовать в Windows имени пользователя Login 'проверяется аутентификации имени пользователя выполняется в окна Пользователь логинов на машине каждого пользователя против имени пользователя вошел в соответствии ниже. То есть, если винда Имя пользователя Логин для машины данного пользователя существует как действительный имя пользователя, то пароль не требуется, и пользователь автоматически аутентификацию. Обратите внимание: это позволяет эффективно использование Windows Active Directory (AD) аутентификации.

Заметка

Учитывая, что права определяются только, когда они должны быть приняты от (ограниченный) от пользователя, любой пользователь, который не является членом группы, или любую группу, которая не имеет права, определенные для нее в отношении каких-либо объектов, будут иметь полный доступ к проект.

Пользователи и группы пользователей

Для создания нового пользователя

1. Выбрать файл| Управление пользователей / групп

Заметка

Если вы не видите Управление пользователями / пункт меню Группы, то вы не имеете возможности администратора. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

2. В появившемся диалоговом окне выберите Добавить пользователяКнопка и введите имя пользователя и пароль в диалоговом окне Создание новых пользователей. Примечание: Имена пользователей и пароли чувствительны к регистру.

Заметка

Если опция "Использовать в Windows имени пользователя Login 'проверяется, как описано выше, то фиктивная пароль может быть введен как аутентификация будет выполнена в соответствии с окном пользователя из отдела Логин Логин только.

2. По умолчанию вы увидите, что Пользователи могут изменять свой пароль. При необходимости, администратор может удалить ABACUS Возможность для пользователей, чтобы установить свой пароль от Снятие флажкафлажки.

Заметка

Если пользователи могут изменять свой пароль они будут иметь Файл | Изменить пароль...Пункт меню, чтобы сделать так,.Кроме того, следует знать, что, если несколько человек используют один и тот же логин, то один пользователь может изменить пароль, так что ни один народ не можете войти после этого. Соответственно, рекомендуется практика, чтобы иметь один имя пользователя по фактическим человека.

4. При желании, введите адрес электронной почты, Место нахождения и телефон для пользователей для дальнейшего использования.

5. Нажать на ОККнопка в диалоговом окне Создание новых пользователей.

6. Нажать на ОККнопка.

Заметка

После того как вы создали свой первый пользователь, вы должны рассмотреть блокирует доступ анонимным пользователям, сняв "Разрешить анонимный пользователь полный доступ к файлу" вариант в Управление пользователями / группами диалога.Кроме того, как только пользователь был создан (а если проект предприятия, изменение стремится к серверу), в следующий раз, открывается проект пользователям будет предложено, чтобы Вход для доступа с проверкой подлинностиа за диалоге показанном ниже. Если Вход автоматически эти деталиопция включена, то имя пользователя / пароль сочетание запомнится проекта и применяться каждый раз при открытии. Чтобы очистить сохраненные Войти выберите Файл | Очистить сохраненные Войтипосле открытия и вам будет предложено войти в следующий раз вы открываете проект.

Авторизоваться

Чтобы удалить существующего пользователя

1. Выбрать файл| Управление пользователей / групп

2. В появившемся диалоговом окне выберите имя пользователя в панели Пользователи, которые вы хотите удалить, и затем выберите Удалить пользователяКнопка.

3. Нажать на ОККнопка.

Чтобы создать новую группу

1. Выбрать файл| Управление пользователей / групп

2. В появившемся диалоговом окне выберите Добавить группуКнопка и введите имя группы в панели Группы.

Заметка

Названия групп должны быть уникальными.

3. Нажать на ОККнопка.

Для скопировать существующийГруппа

1. Выбрать файл| Управление пользователей / групп

2. В появившемся диалоговом окне выберите КопияГруппаКнопка.

Заметка

Дубликат группа будет создана с префиксом "Копия".По умолчанию все разрешения от скопированного группы будет дублироваться на "Копия" группы, включающей любое задание пользователя.

3. Переименовать "Копия" группы при необходимости используя Изменить группуили медленно дважды нажмите.

Чтобы удалить существующую группу

1. Выбрать файл| Управление пользователей / групп

2. В появившемся диалоговом окне выберите имя группы на панели групп, которые вы хотите удалить, и затем выберите Удалить группуКнопка.

Заметка

Любые задания пользователя в группу также будут удалены.

3. Нажать на ОККнопка.

Чтобы назначить пользователя в группу

1. Выбрать файл| Управление пользователей / групп

2. В появившемся диалоговом окне выберите имя пользователя в панели Пользователи, которые вы хотите назначить для группы, и перетащить и падениеэто на имя группы в панели Группы, что вы хотите, чтобы назначить его.

3. Нажать на ОККнопка.

Заметка

Группа (ы), которые пользователь присваивается показаны посредством расширения Имя пользователя в панели Usersи пользователи, которые назначены в группу показаны расширения имени группы в панели Группы. Например, в приведенном выше скриншоте, "AS1-Aus" пользователю присваивается на три (3) группы, а именно; "Поддержка App Команда 1", "Actual" и "Австралия".

Для отмены назначения пользователя из группы

1. Выбрать файл| Управление пользователей / групп

2. В появившемся диалоговом окне разверните имя группы, которая содержит задание пользователя, который вы хотите отменить назначение и выберите имя пользователя.

3. Нажать на Отменить назначение пользователяКнопка.

4. Нажать на ОККнопка.

Чтобы импортировать пользователей и / или групп (и любых подходящих разрешений)

1. Выбрать файл| Управление пользователей / групп

2. Нажать на ИмпортироватьКнопка.

3. В появившемся диалоговом окне Просматриватьи откройте проект ABACUS, содержащий пользователей и / или групп (и разрешения), которые вы хотите импортировать в текущий проект и нажмите открыто, Пользователи и группы будут импортированы и диалог импорта Результаты обобщения появляется импорт пользователей и / или групп. Нажать на ОККнопка.

Заметка

Если импортные пользователей или групп уже существовал в текущем проекте, то они будут объединены с существующими пользователей или групп.

4. Нажать на ОККнопка назад на главной Управление пользователями / диалог Groups.

5. Если есть какие-либо типы соответствия, Точки зрения, Шаблоны или архитектуры между текущего проекта и проекта ABACUS вы импортера от, в комплекте с разрешениями, которые не уже существуют в текущем проекте, разрешения импортируются и второе диалоговое Импорт Результаты появляется подведения импорт. Нажать на ОККнопка.

Заметка

Разрешения добавляются только к существующим типам (и их свойства), точки зрения, шаблоны или архитектур для групп, где разрешений не уже существуют для Группы. Либо потому, что Группа является новым или Группа уже существовала в текущем проекте, но никаких разрешений не были назначены для этой группы к этому пункту. Там нет "слияние" разрешений на соответствие пунктов, где права уже существовали для Группы в текущем проекте.

Установка разрешений

Разрешения могут быть установлены для архитектур, комплектующих и соединительных типов, свойств (с помощью их типов), шаблоны, точки зрения и схемы, каталоги, матрицы, графикиd 3D Просмотры, Когда позволения установлены для компонента или соединения типа все экземпляры этого типа в любых архитектур в этом проекте "наследуют" эти разрешения. Точно так же, когда установлено разрешение для свойства компонента или подключение типа, данного имущества на экземпляров компонента или соединения в любых архитектур в этом проекте "наследуют" эти разрешения. Соответственно, определенные права доступа будут применены к мнению, на которой существуют эти элементы. При права установлены на диаграмме, вид и / или содержимого самой зрения имеют различные права доступа к нему применимы.

Разрешения управления

Чтобы установить разрешения для компонента (или соединение) Введите

1. Разверните Видыветвь дерева.

2. Разверните Комплектующие (или соединение) Типыветвь дерева.

3. Расширять Группы где необходимо.

4. Щелкните правой кнопкой мыши на Компонент (или соединения) ВведитеВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

5. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

6. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

Заметка

Создать разрешения регулирует также, когда вы можете скопировать элемент. Соответственно, чтобы иметь возможность копировать элемент требует разрешение на создание для всех своих детей (с, чтобы скопировать элемент означает копирование все под ним). Удаление разрешения Update от элемента удаляет возможность изменять тип сам, даже если пользователь имеет Designer добавить-на и его также удаляет Update разрешения для всех его свойств. Родитель элемент должен иметь разрешение на обновление, чтобы иметь возможность Создавать любые дочерние элементы или Удалите его существующий дочерние элементы. Удалить разрешение для элемента также требует Удалить разрешение для всех своих детей. Удалить разрешение для компонентов также требует обновления разрешение всех подключенных соединений.И, наконец, удаление Delete разрешение из элемента удаляет возможность удалить сам тип, даже если пользователь имеет Designer добавить-на.

7. Нажать на ОККнопка.

Чтобы установить разрешения для группы компонента (или соединение) Типы

1. Разверните Видыветвь дерева.

2. Разверните Комплектующие (или соединение) Типыветвь дерева.

3. Щелкните правой кнопкой мыши на Группакоторый содержит компонент (или соединение) Типы, которые вы хотите установить разрешения и выбрать Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

6. Нажать на ОККнопка.

7. В появившемся диалоговом окне нажмите кнопку даКнопка.

Чтобы установить разрешения на собственности

1. Разверните Видыветвь дерева.

2. Разверните Комплектующие (или соединение) Типыветвь дерева.

3. Расширять Группы где необходимо.

4. Выберите компонент (или соединения) Введите который содержит свойство, которое вы хотите с заданными правами доступа для.

5. В окне Свойства щелкните правой кнопкой мыши на ИмуществоВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

6. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

7. По умолчанию вы увидите, что разрешения на чтение и обновление всех доступных. Удалите разрешения, Снятие флажкасоответствующие флажки.

Заметка

Свойства, которые имели разрешение Update удалить приведены в курсивв окне Свойстваи их значения не могут быть обновлены этой роли, Кроме того, способность к изменить детали собственности (например, имя, единицы и т.д.) требуется как разрешение на обновление имущества и Дизайнер дополнения.

8. Нажать на ОККнопка.

Чтобы установить разрешения для шаблона

1. Разверните Шаблоныветвь дерева.

2. Перейдите к Шаблончто вы заинтересованы в.

3. Щелкните правой кнопкой мыши на ШаблонВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что разрешение на чтение доступно. Удалить разрешение на Снятие флажкафлажок.

6. Нажать на ОККнопка.

Чтобы установить разрешения на смотровой

1. Разверните Точки зренияветвь дерева.

2. Расширять Группы где необходимо.

3. Щелкните правой кнопкой мыши на Смотровая площадкаВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

6. Нажать на ОККнопка.

Чтобы установить разрешения для архитектуры

1. Разверните Архитектурыветвь дерева.

2. Развернуть на Архитектурачто вы заинтересованы в.

3. Щелкните правой кнопкой мыши на АрхитектураВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что разрешение на чтение доступно. Удалить разрешение на Снятие флажкафлажок.

6. Нажать на ОККнопка.

Чтобы установить разрешения на Каталог

1. Разверните Каталогифилиал архитектуры вы заинтересованы в.

2. Расширять Группы где необходимо.

3. Щелкните правой кнопкой мыши на КаталогВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

6. Нажать на ОККнопка.

Чтобы установить разрешения на Матрица

1. Разверните Матрицыфилиал архитектуры вы заинтересованы в.

2. Расширять Группы где необходимо.

3. Щелкните правой кнопкой мыши на МатрицаВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

6. Нажать на ОККнопка.

Чтобы установить разрешения на диаграмме

1. Разверните Диаграммыфилиал архитектуры вы заинтересованы в.

2. Расширять Группы где необходимо.

3. Щелкните правой кнопкой мыши на СхемаВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

Заметка

В то время как вы можете установить разрешения CRUD непосредственно на диаграмме, следует отметить, что разрешения элементов на диаграмме может повлиять на права для самого представления. Например, если есть даже просто один элемент на том, что имеет свои чтения или обновления разрешение удалить то диаграмма будет иметь свою Обновление разрешение удалены. Это потому что; а) элементы на том, что имели их разрешение Чтение удалены не будут показаны на изображении, оставляя «пустое пространство», где вы могли бы разместить некоторые новые элементы, если вид был обновляемым, и б) элементы на том, что имели их обновления разрешение удаляются, то может иметь другие элементы упал на них, чтобы стать детьми, если вид был обновляемыми. Кроме того, создание и обновление разрешение на диаграмме требует, чтобы все элементы на представлении имеют разрешение на чтение и компоненты имеют разрешение Update (это потому, что для перемещения компонента на другой компонент, вы должны быть в состоянии обновить его, поскольку он будет стать ребенка).

6. Нажать на ОККнопка.

Чтобы установить разрешения для 3D View

1. Разверните 3D Просмотровфилиал архитектуры вы заинтересованы в.

2. Расширять Группы где необходимо.

3. Щелкните правой кнопкой мыши на 3D ViewВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

6. Нажать на ОККнопка.

Чтобы установить разрешения на Диаграмма

1. Разверните Диаграммыфилиал архитектуры вы заинтересованы в.

2. Расширять Группы где необходимо.

3. Щелкните правой кнопкой мыши на ДиаграммаВы хотите, чтобы установить права доступа и выбора Изменить Разрешения.

4. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

5. По умолчанию вы увидите, что создавать, считывать, обновлять и удалять разрешения имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

6. Нажать на ОККнопка.

Смотрите также

Как архитектура представлена ​​в ABACUS?


Работа с Панели

Навигация: Администрирование>

Работа с Панели

Отправить комментарии на эту тему.

Проекты ABACUS может иметь любую конфигурацию мнениями (например, диаграммы, Графики и т.д.), сохраненные в приборной панели и эти сохраненные панели могут быть установить по умолчанию, начиная 'экран' на открытии проекта и / или назначен конкретный группа пользователей и представлены членам этой группы пользователя при входе в систему с проектом ABACUS.

Заметка

Для настройки панели в проекте ABACUS лицензия пользователь нуждается в возможности администратора. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

Просмотр панелей

Пример применения Управление портфелем (АРМ) приборной панели

Для просмотра сохраненного панель

1. Выбрать Посмотреть| Панели

2. Выберите сохраненный приборную панель из списка доступных панелей.

Заметка

После того, как выбранный ABACUS будет строить вид, необходимые для приборной панели, и это может занять несколько секунд. Пожалуйста, будьте терпеливы.

Управление информационных панелей

Управление информационных панелей

Чтобы создать новую приборную панель

1. Откройте необходимые мнения и организовать и состыковать окна, как требуется для приборной панели.

2. Выбрать Посмотреть| Панели| Управление панелей ...

Заметка

Если вы не видите пункт меню Управление приборные панели, то вы не имеете возможности администратора. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution если вам требуется такая возможность.

3. В появившемся диалоговом окне выберите СоздайтеКнопка и введите имя Dashboard в диалоговом окне Создание нового Dashboard.

4. Нажать на ОККнопка.

Чтобы удалить существующий панель

1. Выбрать Посмотреть| Панели| Управление панелей ...

2. В появившемся диалоговом окне выберите панель вы хотите удалить из списка, и выберите УдалитьКнопка.

Заметка

Удаление приборную панель также удалять любые группы пользователей поручения этой панели.

3. Нажать на ОККнопка.

Чтобы заменить существующий панель

1. Откройте необходимые мнения и организовать и состыковать окна, как требуется для приборной панели замены.

2. Выбрать Посмотреть| Панели| Управление панелей ...

3. В появившемся диалоговом окне выберите панель вы хотите заменить из списка и выберите ЗаменятьКнопка.

4. Нажать на ОККнопка признать Dashboard Заменены диалог.

Чтобы назначить панельа стартовом экране по умолчанию

1. Выбрать Посмотреть| Панели| Управление панелей ...

2. В появившемся диалоговом окне выберите панель из списка, который вы хотите назначить а начать по умолчанию "" экранеи выберите Связать ...Кнопка.

3. В появившемся диалоговом окне выберите <По умолчанию Проект> запись в группы столбцов User.

Заметка

Только один приборной панели может быть назначить в качестве <умолчанию проекта> 'начать' экран так переназначение будет удалить <умолчанию Проект> задание от предыдущего приборной панели.Кроме того, если пользователь входит в систему в качестве члена группы пользователя, который имеет назначенный приборную панель, то назначается панель будет открыт вместо приборной панели проекта по умолчанию.

4. Нажать на ОККнопка.

Чтобы назначить группу пользователей к панели

1. Выбрать Посмотреть| Панели| Управление панелей ...

2. В появившемся диалоговом окне выберите панель из списка вы хотите назначить группу пользователей и выберите Связать ...Кнопка.

3. В появившемся диалоговом окне выберите Пользователь Группа (или группы)Вы хотите, чтобы назначить приборную панель как "запуска" экран для.

Заметка

Если же группа пользователей присваивается нескольким панелей, то первое назначение в списке будут использоваться.

4. Нажать на ОККнопка.

Для отмены группы пользователей из панели

1. Выбрать Посмотреть| Панели| Управление панелей ...

2. В появившемся диалоговом окне разверните элемент Dashboard из списка вы хотите отменить назначение группы пользователей из.

3. Выберите группу, которую вы хотите отменить назначение и выберите Отменить назначениеКнопка.

4. Нажать на ОККнопка.

Установка разрешений

Разрешения могут быть установлены для панелей, чтобы позволить приборной панели будет просматриваться, Обновляемыми и / или deleteableс заданными групп пользователей.

Разрешения управления

Чтобы установить разрешения на панели

1. Выбрать Посмотреть| Панели| Управление панелей ...

2. В появившемся диалоговом окне выберите панель из списка, который вы хотите установить разрешения для и выберите Разрешения ...Кнопка.

3. В появившемся диалоговом окне нажмите на Добавить...Кнопка и выберите ГруппаВы хотите добавить, либо дважды щелкнув его или выбрав его и нажав ОККнопка.

4. По умолчанию вы увидите, что чтение, обновление и удаление разрешений имеются. Удалите разрешения, Снятие флажкасоответствующие флажки.

5. Нажать на ОККнопка.

Смотрите также

Настройка интерфейса ABACUS | Работа с разрешениями


Регистрация Abacus

Навигация: Справочник>

Регистрация Abacus

Отправить комментарии на эту тему.

При первом запуске Abacus (или после временной лицензии истек), вы должны будете зарегистрировать приложение от сервера лицензий Avolution, используя уникальный лицензионный ключ, предоставленный локального администратора ABACUS или непосредственно из Avolution. Если у вас нет лицензионного ключа, пожалуйста, свяжитесь с локального администратора или ABACUS Поддержка Avolution .

Для регистрации лицензионного ключа

1. После установки, начать Abacusлибо дважды щелкнув ярлык на рабочем столе или в меню Пуск Windows.

2. В диалоговом окне регистрации, которое появляется введите Лицензионный ключ 26 символовпредоставленный локального администратора или ABACUS Поддержка Avolution Или нажмите Просматривать...и выберите подписанный файл .dlsc вернулся из Поддержка Avolution в соответствии с Примечание на шаге 4 ниже. При использовании правильно подписанный .dlsc файл ABACUS должно начинаться за шагом 5 ниже.

Наконечник

Вы можете вставить лицензионный ключ в диалоге, скопировав его в буфер обмена Windows, а затем выбрав фон диалога и нажав Ctrl + V.

Диалог регистрации

3. Нажмите ОКи если лицензионный ключ является Лицензионный ключ ABACUSABACUS теперь попробуйте связаться лицензионный сервер Avolution для проверки подлинности лицензионного ключа.

Заметка

Если вы получаете Установка Кодекс Неверныйрегистрация ошибка, скорее всего, что вы набрали код неправильно. Попробуйте скопировать и вставить код в соответствии с упомянутой выше Совет.

Обращение в Avolution сервера лицензий

4. Нажмите ОКи после краткого периода времени ABACUS должны успешно зарегистрироваться.

Успешное Регистрация

Заметка

Если вы получаете Не удается связаться лицензионный серверрегистрация ошибка, скорее всего, что брандмауэр (или другие меры безопасности) в сети препятствуют доступ к серверу лицензий Avolution в. Нажмите ОКСохраните .dlsc файл на локальном компьютере, а затем или по электронной почте файл в .dlsc Поддержка Avolution и ждать дальнейших указанийили попытаться подписать файл лицензии самостоятельно, используя следующий адрес - http://licensing.avolutionsoftware.com/LicenceSign/ .

Не удается связаться с сервером лицензий

Откройте веб-страницу Лицензия подписания

Руководство Лицензия подписание веб-страницы

Кроме того, если вы получаете Этот код установки был использован на более чем систем допускается лицензиирегистрация ошибка, скорее всего, ваш локальный компьютер был восстановлен, так как вы в последний раз зарегистрирован счеты или вы пытаетесь зарегистрироваться лицензионного ключа другого пользователя. Пожалуйста, обратитесь к администратору ABACUS местного или Поддержка Avolution .

Код Установка уже используется

5. Нажмите ОКи если он зарегистрирован успешно ABACUS должны открыть с Экран приветствия .

Смотрите также

Поддержка Avolution | Что ABACUS делать?


ABACUS Установка предпосылок

Навигация: Справочник>

ABACUS Установка предпосылок

Отправить комментарии на эту тему.

Информация касается Visio Импорт и Excel Импорт / Экспорт

ABACUS требует Microsoft Office быть установлены для того, чтобы выполнять Excel Импорт / Экспорт и Visio импортных операций. Пожалуйста, убедитесь, что Microsoft Office 2003 или более поздней версииустановлен правильно. Если вы испытываете дальнейшие проблемы, свяжитесь с Поддержка Avolution .

Для того, чтобы выполнить Visio Импорт и Excel Импорт / экспортных операций, ABACUS использует Microsoft Office основные сборки взаимодействия (PIA-х). ABACUS настоящее время поставляется в комплекте с сборок, необходимых для выполнения Excel Импорт / Экспорт и импорт Visio.

Информация касается SQL Импорт сервер

ABACUS требует Microsoft SQL Server 20052008, 2008 R2, 2012 или 2014установлен для того, чтобы начать новый проект от SQL Server. Пожалуйста, убедитесь, что Microsoft SQL Server 20052008, 2008 R2, 2012 или 2014установлен правильно. Если вы испытываете дальнейшие проблемы, свяжитесь с Поддержка Avolution .

Ошибки Открытие 3D визуализации

Если счеты 3D Viewer не работает для вас, вы можете быть хватает SlimDX DirectX Runtime (устанавливается как часть полного ABACUS EXE установки). Это может быть загружено Вот , Если у вас есть 64-битной версии окон, вы также может понадобиться установить это .

Ошибки Редактирование СЧЕТЫ Обычай Отчеты

Редактирование АБАК "Пользовательские отчеты требует построитель отчетов 3.0 должны быть установлены. ABACUS и отчетов построены на Microsoft, .NET Framework 4.0, и в то время они оба не требуют от Microsoft .NET Framework 3.5, Microsoft неправильно настроен Сообщить Builder MSI только действовать, если установлен Microsoft, .NET Framework 3.5.

Соответственно, Avolution имеет отредактированную версию установочного отчетов MSI файл, который не требует от Microsoft .NET Framework 3.5, это может быть загружена Вот .

Оригинальный Microsoft Report Builder MSI можно загрузить Вот , Если вы не уже есть Microsoft .NET Framework 3.5, который он будет требовать, вы можете скачать его Вот , Примечание: Для нескольких установках форума установку Microsoft, .NET Framework 3.5 с Вот может быть более подходящим.


Параметры командной строки

Навигация: Справочник>

Параметры командной строки

Отправить комментарии на эту тему.

Вы можете выполнять различные операции ABACUS непосредственно из командной строки с наиболее распространенной операцией в том, чтобы открыть конкретный файл проекта и опубликовать его на HTML.

В частности, использование командной строки из ABACUS следующим образом;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ пользователь "USER" / пасс "PASS"]

Аргумент | Описание
ProjectFile | ProjectFile может быть либо файл ABACUS проект (.abacus), файл библиотеки (.abacuslib), XML-файл (.xml) или MS Access БД (.mdb) и указанный файл будет либо открыто (если .abacus или .abacuslib ) или новый проект, созданный (если .xml или файл .mdb).
OptionalFile | OptionalFile может быть либо сценарий ABACUS (.abacusscript, .vb или .cs), макро (.abacusmac) или файл библиотеки (.abacuslib), а указанный файл будет либо работать после открытия ProjectFile (если .abacusscript, .vb или .cs или .abacusmac) или просто открыл (если .abacuslib).
/ exitOnCompletion | Будет выхода счеты и, если требуется сохранить и совершать какие-либо изменения в открытых проектах .abacus о завершении любого сценария или макроса. Примечание: Этот флаг Учитывать так что не забудьте использовать прописную 'O' и 'C' в тексте, как показано.
/ dontShowDialogs | Помешает ABACUS Enterprise Edition (EE) уведомления обновление диалоги показывать при открытии проекта. Примечание: Этот флаг Учитывать так что не забудьте использовать заглавными буквами "S" и "D" в тексте, как показано.
/ пользователь "USER" / пасс "PASS" | Имя пользователя, имя пользователя и пароль PASS будет использоваться, чтобы войти в проект с, отвергая любые сохраненные учетные данные. Примечание: Двойные кавычки должны быть размещены вокруг пользователя и передать флаги и два двойные кавычки могут быть использованы, чтобы избежать двойных кавычек в пользователем или PASS флаги.

Например.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.VB"/ exitOnCompletion / dontShowDialogs / пользователь "Общественный" / пасс "123456"

когда запустить из каталога, где ABACUS.exe двоичный является располагается будем открытый Пример проекта и войти как пользователь общественности с паролем 123456 (как описано Вот ), Опубликовать его в HTML и закройте проект все без предъявления каких-либо диалогов по пути (например, "Обновление Успешный» или «Нет доступных обновлений» для проектов Enterprise).

Например.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Каталог Excel Импорт.VB"/ exitOnCompletion / dontShowDialogs

когда запустить из каталога, где ABACUS.exe двоичный является располагается будем открытый Пример проекта и импортировать "Серверы (2014 Фактический) .xlsx" MS Excel файл в каталоге 'Servers' в '2014' Фактическое архитектуры проекта, не проявляя никаких диалогов по пути, а затем закрытия проекта на доработку. Если операция вносит изменения в проект, то при закрытии изменения сохраняются локально и если проект Предприятие стремится к Enterprise Server.

Заметка

Будьте уверены, чтобы использовать правильный двойной кавычки, поскольку есть несколько в стандартный набор ASCII-символов и командной строки Windows будет работать только правильно с правильный. Правильный двойной код кавычки в десятичной 34 (шестнадцатеричный 22).Это то, что используется в примере выше, так не стесняйтесь копировать / вставить его оттуда.


Титульная страница

СЧЕТЫ

Отказ

Avolution Pty Ltd не дает никаких заверений или гарантий в отношении настоящего руководства, и, в максимальной степени, разрешенной законом, прямо ограничивает свою ответственность за нарушение каких-либо гарантий, которые могут быть подразумеваемой к замене данного руководства с другой. Кроме того, Avolution Pty Ltd оставляет за собой право пересматривать данную публикацию в любое время, не неся обязательства уведомлять какое-либо лицо пересмотра.

Авторские права

Copyright 2001-2015Avolution Pty Ltd. Все права защищены.

Торговые марки

Avolution Pty Ltd сделала все возможное, чтобы предоставить информацию об именах товарный знак компании, продукции и услуг, указанных в данном руководстве. Торговые марки, указанные ниже, были получены из различных источников.

Microsoft Windows, Access, Visio, Excel, SQL Server и Internet Explorerявляются товарными знаками корпорации Microsoft.

Общее уведомление:

Некоторые названия продуктов, используемые в данном руководстве, используются только для целей идентификации и могут быть товарными знаками соответствующих компаний.

Декабрь 2015Издание для Avolution ABACUS Версия 4.5.

Руководство Версия 1.0

Генерируется, распечатать, и связаны в Австралии.