Pridanie prednastavených vlastností komponentné, pripojenie alebo typu

Navigácia: Naplnenie vašej architektúry> Vlastnosti>

Pridanie prednastavených vlastností komponentné, pripojenie alebo typu

Odoslať pripomienky na túto tému.

Štandardné knižnice nehnuteľností môžu byť špecifikované a priradené k niečomu inému v architektúre. Tieto knižnice sú známe ako Normy, Používaním Normy, Len je potrebné zhromaždiť špecifické systémy vlastnosti - štandardné vlastnosti sú už tam.

Napríklad štandardný výkonové charakteristiky systému Microsoft Windows 2000 možno uložiť akoŠtandardnéa pridelený k ľubovoľnej súčasti (alebo spoje, nie že by to bolo typické) používate operačný systém Microsoft Windows 2000.

Ak chcete pridaťštandarddo zložky, pripojenie alebo typu

1. Kliknite pravým tlačidlom myšina komponentu / pripojenie / typu.

2. Vybrať Priradiť Štandardné.

3. VybraťŠtandardnézo zoznamu.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Zmena vlastností komponenty, pripojenie alebo typu | Súhrnné vlastnosti

© 2001-2015 Avolution Pty Ltd. Všetky práva vyhradené.


Súhrnné vlastnosti

Navigácia: Naplnenie vašej architektúry> Vlastnosti>

Súhrnné vlastnosti

Odoslať pripomienky na túto tému.

Operácie "Aggregate Vlastnosti"Vám umožní pridať hodnoty podobnými vlastnosťami spolu a písať (alebo pridať) výsledok do vlastností zvoleného rodičovského elementu je. To tiež umožňuje definovať rozsah agregácie a či aktualizovať vlastnosti všetkých čiastkových prvkov alebo nie.

Ak chcete súhrnných vlastnostiach

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Pravým tlačidlom myši na prvok (architektúru, súčasť alebo spojenie), v ktorom k tomu agregácie a vyberte Súhrnné Properties.

3. Vyberte si jednu z možností Súhrnné (Traverse všetkých podúrovníalebo Iba Direct Sub-Level). Ak ste zvolili Traverse všetkých podúrovní, Môžete tiež zvoliť možnosť, či sa má Aktualizácie podúrovní.

o Traverse všetkých podúrovníZnamená to, že rozsah agregácie bude obsahovať prvky vo všetkých úrovniach pod Vami vybraného prvku.

o Aktualizácie podúrovnímôže byť vykonané iba vtedy, ak ste tiež vybrali možnosť Traverse všetkých podúrovní, To znamená, že zatiaľ čo agregovať vlastnosti od zdola nahor, súhrnným výsledkom na každom stupni sa tiež aktualizuje do každého z príslušných prvkov.

o Iba Direct Sub-LevelZnamená to, že len vlastnosti prvkov priamo pod vybraný prvok bude sčítať.

o Vybrať Zahrnúť ŠtandardnéVlastnostiAk chcete, aby vlastnosti definované v Normy ktoré majú byť zahrnuté. V opačnom prípade bude použitý len vlastnosti špecifické pre každú inštanciu komponenty.

4. Vyberte si, ktoré vlastnosti chcete agregovať. Tie sú zoskupené do ich Druhy.

5. Kliknite na tlačidlo BudúciTlačidlo.

6. Zvoľte možnosť, či sa má Prepísať Hodnotyalebo Pridajte hodnotydo vybraný prvok.

o Prepísať Hodnotyzapíše výsledky priamo do vlastností vybraný prvok.

o Pridajte hodnotypridá výsledky do existujúcich vlastností vybraný prvok.

Pozri tiež

Pridanie prednastavených vlastností komponentné, pripojenie alebo typu | Zmena vlastností komponenty, pripojenie alebo typu | Vyhodnotenie vašej architektúry


Architektúra Diff a synchronizácia

Navigácia: Analýza vašej architektúry>

Architektúra Diff a synchronizácia

Odoslať pripomienky na túto tému.

Ak máte 2 alebo viac architektúr, buď ako evolúcia alebo základných architektúr, môžete vizuálne "diff" dve architektúry s použitím katalóg alebo diagram Porovnanie alebo Architektúra Diff vlastnosť. To je obzvlášť užitočné pre prehliadky / re-objavovať presné zmeny z jednej architektúre do druhého, ako ste sa vyvíjajú štruktúry a rozvoj plánov pre ABACUS.

K zobraziť "diff" s inou architektúrou pomocou diagramu

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Uistite sa, mať minimálne 2 architektúry v projekte.

3. Otvorte diagram, ktorý chcete porovnať na inej architektúre.

4. Kliknutím na tlačítko "Porovnať Toto schéma na obsah iného architektúry" na paneli nástrojov diagrame.

5. Vyberte inej architektúre z rozbaľovacieho zoznamu porovnávať s.

6. Môžete filtrovať, aké rozdiely sú zobrazené po kliknutí na tlačidlo "rozdiely" na paneli nástrojov Diagram a zrušením výberu možnosti, napríklad Zmenil / vedľajšej / Unknown a Neurčitý / Sync Odporúčané/ Majte Odporúčaná.

Poznámka

Komponenty a pripojenie na diagrame budú zvýraznené červená, zelená alebo nachový tam, kde sú rozdiely medzi obsahom, ktorý je viditeľný na aktuálnom diagramom a obsah v druhom architektúre. Red sa používa tam, kde je odporúčané synchronizovať rozdiely (pozri nižšie), Green Používa sa tam, kde sa neodporúča synchronizovať rozdiely, ktoré je držať ich (pozri nižšie) a Purple sa používa ak ABACUS nemožno urobiť odporúčania o synchronizáciu rozdielov (pozri nižšie). Viditeľná obsah na obrázku je v porovnaní len vtedy, ak anotácia vykazujú hodnotu vlastnosti úložiska, a táto hodnota sa mení danej súčasti alebo pripojenia sa zobrazí v slabý červený, slabý zelenýalebo slabé fialové a symbol A '*' môžete vidieť na obrázku vľavo hore pre zložky, však, ak nejaká iná základná hodnota úložisko vlastnosť zmenená, ktorý nie je uvedený v anotácii potom žiadny náznak, bude poskytnutá. Obsah, ktorý sa vyskytuje na aktuálnom schéme, ale je žiadna zhoda v porovnávacej architektúre bude zobrazený v silná červená, silný zelenýalebo silný fialováa symbol '+' zobrazený v ľavom hornom pre komponenty. Prispôsobenie sa vykonáva pomocou komponentu, a mená tak, že v prípade, že typ alebo názov priečinka alebo pripojenia zmenil v ostatných architektúry bude zhoda nájdená. Pretože neexistuje spôsob, ako spoľahlivo určiť, či ďalší obsah z druhého architektúry by bolo preukázané na aktuálnej schéme (napr Ďalšie rozhranie medzi 2 zložiek, ako je uvedené nižšie v diagrame z porovnania architektúry na pravej strane), tieto rozdiely nie sú je znázornené na schémach (sú uvedené pre katalógy podľa nižšie). Vznášajúce sa nad každou zmenené položky sa zobrazia rozdiel v popisku. Vznášajúce sa nad symbolom "*" v ľavom hornom diagrame je uvedený prehľad zmien (alebo žiadne zmeny) medzi obsahom schémy a obsahu druhej architektúry.

Colour Legend

· Green indikuje položky, ktoré nie je doporučené synchronizovať rozdiely, ktoré je, aby im.

· Red indikuje položky, ktoré sa odporúča, aby synchronizovať rozdiely.

· Purple indikuje položky, kde ABACUS nemôže dať odporúčania o synchronizáciu rozdielov.

K synchronizovať (synchronizačný) obsahu z jednej architektúry s inou cez diagramu

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Uistite sa, mať minimálne 2 architektúry v projekte.

3. Otvorte diagram chcete porovnať na inej architektúre.

4. Kliknutím na tlačítko "Porovnať tento katalóg k obsahu iného architektúry" na paneli nástrojov Diagram.

5. Vyberte iné architektúre zo zoznamu drop-down porovnávať s.

Poznámka

Pozri vyššie pre cestu ABACUS ukazuje "diff" medzi 2 architektúr v katalógu. Predovšetkým ako Red sa používa tam, kde to jeOdporúča sa synchronizovať rozdiely, Green sa používa tam, kde je to nieOdporúča sa synchronizovať rozdiely a Purple sa používa ak ABACUS nemožno urobiť odporúčania o synchronizáciu rozdielov.

6. Pravým tlačidlom myši na diagrame prvok (alebo prvky, pomocou Shift alebo diagramu plátno synchronizovať všetko) zobrazujúci "diff" a vyberte položku Sync.

Poznámka

Akékoľvek zmeny synchronizačný budú použité iba na architektúru, ktorá práve v centre pozornosti katalógu patrí. Ak chcete použiť zmeny na druhú architektúru, ktorú je potrebné použiť katalóg v inej architektúre. Navyše, užívatelia budú môcť v prípade, aby sa zmeny synchronizácia len oni má na to oprávnenie .

Poznámka

V závislosti na tom, kde ste pravým tlačidlom myši na položku ponuky sa zobrazia pokyny o tom, čo presne sa bude synchronizovať.Napr. Pravým tlačidlom myši jediným prvkom v diagrame budú synchronizovať len tejto súčasti. Vzhľadom k tomu, pravým kliknutím na diagram plátno a výberom Sync Všetko bude synchronizovať všetky aktuálne zobrazené rozdiely v.

K zobraziť "diff" s inou architektúrou prostredníctvom katalógu

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Uistite sa, mať minimálne 2 architektúry v projekte.

3. Otvorte katalóg, ktorý chcete porovnať na inej architektúre.

4. Kliknutím na tlačítko "Porovnať tento katalóg k obsahu iného architektúry 'na katalóg paneli nástrojov.

5. Vyberte inej architektúre z rozbaľovacieho zoznamu porovnávať s.

6. Môžete filtrovať, aké rozdiely sú zobrazené po kliknutí na tlačidlo "rozdiely" na paneli nástrojov diagramu a odobratím možnosti, napr Zmenil / vedľajšej / Unknown a Neurčitý / Sync Odporúčané/ Majte Odporúčaná.

Poznámka

Bunky v katalógu budú zvýraznené červená, zelená alebo nachový tam, kde sú rozdiely medzi obsahu v aktuálnom katalógu a zodpovedajúceho obsahu v druhom architektúre. Red sa používa tam, kde je odporúčané synchronizovať rozdiely (pozri nižšie), Green Používa sa tam, kde sa neodporúča synchronizovať rozdiely, ktoré je držať ich (pozri nižšie) a Purple sa používa ak ABACUS nemožno urobiť odporúčania o synchronizáciu rozdielov (pozri nižšie). Sú porovnávané len viditeľné riadky a stĺpce v katalógu, takže v prípade, že je rozdiel v rade nad rámec v súčasnosti publikované riadkov alebo hodnota v stĺpci, ktorý nie je znázornený má rozdiel potom žiadny rozdiel bude uvedené. V prípade, že hodnota v individuálnej bunke sa líši s zodpovedajúce bunkou v porovnávacej architektúre bude zvýraznená hranice bunka. Volič záhlavie stĺpca a riadku bude tiež v tieni v slabé fialovéa zobrazuje sa symbolom "*". Tieto "*" môžu byť symboly klikli pre skok na ďalšiu rozdiel v stĺpci alebo riadku, resp. Riadky, ktoré sa vyskytuje v aktuálnom katalógu, ale je žiadna zhoda v porovnávacej architektúre sa zobrazí so symbolom '+' v selektora rade naľavo a hranicou celý riadok sa zvýrazní. Riadky, ktoré by došlo v porovnaní architektúre verzii katalógu (tj s rovnakými filtre, atď), ale je žiadna zhoda v súčasnej architektúre sa zobrazí s - symbolom volič riadku vľavo, hranice '' celý riadok sa zvýrazní a obsah celého riadku bunky sa zobrazí v slabé fialovéa udrel-through, napr. 8 do 6pm, Prispôsobenie sa vykonáva pomocou komponentu, a mená tak, že v prípade, že typ alebo názov priečinka alebo pripojenia zmenil v ostatných architektúry bude zhoda nájdená. Vznášajúce sa nad každou zmenené položky sa zobrazia rozdiel v popisku. Vznášajúce sa nad symbolom "*" v ľavom hornom diagrame je uvedený prehľad zmien (alebo žiadne zmeny) medzi obsahom diagramu a obsah ostatných architektúry.

Colour Legend

· Green indikuje položky, ktoré nie je doporučené synchronizovať rozdiely, ktoré je, aby im.

· Red indikuje položky, ktoré sa odporúča, aby synchronizovať rozdiely.

· Purple indikuje položky, kde ABACUS nemôže dať odporúčania o synchronizáciu rozdielov.

K synchronizovať (synchronizačný) obsahu z jednej architektúry s inou cez katalóg

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Uistite sa, mať minimálne 2 architektúry v projekte.

3. Otvorte katalóg, ktorý chcete porovnať na inej architektúre.

4. Kliknutím na tlačítko "Porovnať tento katalóg k obsahu iného architektúry" na katalóg nástrojov.

5. Vyberte iné architektúre zo zoznamu drop-down porovnávať s.

Poznámka

Pozri vyššie pre cestu ABACUS ukazuje "diff" medzi 2 architektúr v katalógu. Predovšetkým ako Red sa používa tam, kde to jeOdporúča sa synchronizovať rozdiely, Green sa používa tam, kde je to nieOdporúča sa synchronizovať rozdiely a Purple sa používa ak ABACUS nemožno urobiť odporúčania o synchronizáciu rozdielov.

6. Pravým tlačidlom myši na bunku stĺpca alebo riadku čísel (alebo viac položiek pomocou Shift alebo Ctrl + A pre všetko) zobrazujúci "diff" a vyberte položku Sync.

Poznámka

Akékoľvek zmeny synchronizačný budú použité iba na architektúru, ktorá práve v centre pozornosti katalógu patrí. Ak chcete použiť zmeny na druhú architektúru, ktorú je potrebné použiť katalóg v inej architektúre. Navyše, užívatelia budú môcť v prípade, aby sa zmeny synchronizácia len oni má na to oprávnenie .

Poznámka

V závislosti na tom, kde pravým tlačidlom myši (tj bunky, stĺpec alebo riadok hlavičky) položka menu sa zobrazí pokyny o tom, čo presne sa bude synchronizovať.Napr. Pravým tlačidlom myši jedinú vlastnosť alebo pripojené komponenty bunku v katalógu budú synchronizovať len, že majetok alebo pripojené komponenty. Vzhľadom k tomu, kliknutím pravým tlačidlom myši na riadok hlavičky (alebo čísel pomocou Shift), bude synchronizovať celý riadok (alebo riadky). Pravým tlačidlom myši na záhlavie stĺpca sa bude synchronizovať všetky rozdiely v tomto stĺpci.

Ak chcete zobraziť 'diff'2 celý architektúry

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Uistite sa, mať minimálne 2 architektúry v projekte.

3. Vybrať Nástroje| Architektúra Diff ....

4. V dialógovom okne, ktoré sa objavia vyberte prvú / Od a druhým / Pre architektúr pre porovnanie.

5. Kliknite na OKTlačidlo.

Architektúra Diff

Colour Legend

· Greenznamená, že uzol bol pridaný v druhom / To architektúry.

· Redindikuje, že uzol bol odstránený v druhom / k architektúre.

· Modráindikuje, že uzol má rôzne atribúty (napr vlastností alebo noriem) v druhom / k architektúre.

· Yellowindikuje, že uzol má rozdiely vo svojich detí v druhom / s architektúrou, takže uzol by mal byť rozšírený.

Poznámka

Môžete pravým tlačidlom myši a "Show v Prieskumníkovi" na všetkých uzloch, aby zobraziť podrobnosti a ďalšie informácie sú uvedené na rozdiely v rozdieloch Súhrn paneli, keď je vybraný uzol.

Pozri tiež

Analýza vašej architektúry | Zobrazenie doba odozvy graf | Zobrazenie Scatterplot maticu vašich vyvinutých architektúr | Vyvíjajúce vašej architektúry


Zmena vlastností komponenty, pripojenie alebo typu

Navigácia: Naplnenie vašej architektúry> Vlastnosti>

Zmena vlastností komponenty, pripojenie alebo typu

Odoslať pripomienky na túto tému.

Vlastnosti sú typicky systémové požiadavky, ktoré definujete, alebo výsledky hodnotenia Abacus '. (Keď ABACUS plní svoje hodnotenie, zapíše vlastnosti späť do súboru). Inými slovami, vlastnosti sú veci, ktoré vedieť o vašom systéme, alebo veci, ktoré sa používajú Abacus zistiť.

Ak chcete zmeniť hodnotu vlastnosti komponenty, pripojenie alebo typu

1. Kliknite na tlačidlona komponentu / pripojenie / typ (jej vlastnosti sa zobrazí v okne Vlastnosti vpravo).

2. Kliknite na tlačidlooznačte vlastnosť, ktorú chcete zmeniť.

3. Druhnová hodnota.

Dôležitý

Tiež, veľa vlastnosti sú definované pomocou Normy , Zmenou nehnuteľnosti do inéhoŠtandardné, Môžete nielen zmeniť aktuálny objekt, môžete tiež zmeniť pána Štandardné (v rámci Noriem nav hornej časti stromu). Ako to urobíte, skontrolovať, čo ostatné komponenty, prípojky alebo typy používate Štandardné, Pretože zmena nemusí byť relevantné pre nich- Môžete použiť okno odkazy na toto.

Tip

Môžete meniť vlastnosti pripojenia zv rámci pobočky zložiek stromu (a naopak). Tak napríklad, ak sa pozeráte na to, čo spoje sú pripojené ku komponentu, a uvedomíte si, musíte zmeniť jeden, môžete.

Ak chcete pridať nové vlastnosti komponenty alebo pripojenia (prostredníctvom typu)

Poznámka

Vlastnosti je možné pridať len na typy a zložky alebo spojenia typu "zdedí" tieto vlastnosti.

1. Kliknite na tlačidlotypu (jeho vlastnosti sa zobrazí v okne Vlastnosti vpravo).

2. Kliknite na tlačidlona tlačidlo Pridať v hornej časti okna vlastností pridať riadok v hornej časti vlastností siete pre novú vlastnosť.

3. Pridať Druhpre nové vlastnosti.

4. Pridať Názovpre nové vlastnosti.

5. Pridať Predvolená hodnotapre nové vlastnosti.

6. Pridať Jednotkapre nové vlastnosti.

7. Nastavenie Typ dátpre nové vlastnosti.

Poznámka

Dátový typ poľa možno použiť na obmedzenie platné hodnoty, že nehnuteľnosť môže mať. To je; Text, Integer, desiatkovej, dátum / čas, Boolean alebo List.

o A Textovývlastnosť je ten, ktorý má neobmedzený počet znakov, a v podstate nemá žiadne obmedzenia na hodnotu.Ak je hodnota vlastnosti je správne vytvorený hypertextový odkaz (tj URL je potrebné začať s jedným z 5reťazca; http: //, https: //, ftp: //,file:alebo \\ a akejkoľvekpriestory by mali byť zadané s '% 20'), Potom je odkaz kliknúť (cez CTRL + kliknutie).

o Celé číslonehnuteľnosť musí byť celý rad buď pozitívne, alebo negatívnea môžu obsahovať bodku, medzeru, apostrof alebo čiarka pre zoskupovanie číslic v závislosti na projekte Nastavenie regiónu z Súbor | Možnosti projektu.Nastavenie kraja a.Net Metóda Long.TryParse je použitá pre určenie platnosti Celé čísloHodnoty.

o A Desatinnévlastnosť môže obsahovať obdobie alebo čiarka pre symbol desatinnej čiarky a môžu obsahovať bodku, medzeru, apostrof alebo čiarka pre zoskupovanie číslic v závislosti na projekte Nastavenie regiónu z Súbor | Možnosti projektu.Nastavenie kraja a.Net Metóda Decimal.TryParse je použitá pre určenie platnosti Desatinné Hodnoty.

o A Dátum Časvlastnosť umožňuje buď časť dáta alebo doby časť alebo oboje. Región nastaveniea .NET Metóda DateTime.TryParse sú primárne využívané pre stanovenie platný dátum a / alebo časovej hodnoty. Date však časť prípadne vyžaduje aspoň deň a mesiac (rok bude považovať za aktuálny rok) alebo mesiac a rok súčasti platná. Tj. Júna Q3 2010, alebo dokonca len 2010 sú neplatné. Aj keď to bude líšiť s rôznymi miestne nastavenia, typicky deň, mesiac a rok časti môžu byť oddelené medzerou, čiarkou, čiarka ("-"), alebo lomkou ("/"). Časť Day typicky je celé číslo od 1 do 31. Mesiac časť je typicky celé číslo od 1 do 12, platný 3 skratka listu za mesiace (napr Ľad, február, marec), alebo, názov celý mesiac (napr január, február , marec). Rok časť je typicky kladné číslo 4 číslice, ale 1, 2 a 3 roky číslice sú prijímané podľa nastavenia v Ovládací panely-> miestne a jazykové Options> Regionálne Options> Úprava (tlačidlo) -> Date- dátum> Kalendár. Typicky oni sú interpretované nasledovne; 0-29 je interpretovaný ako 2000-2029, 30 až 99, ako 1930-1999 a 100-999 ako 100-999. Bude detekovaná neplatné údaje, ako je 31. júna 2010 a 31/9/2010. The Time časť prípadne vyžaduje hodinách a minútach časť a prípadne Seconds časť. Hodiny, minúty a voliteľné Sekundy diely sú zvyčajne oddelené s dvojbodkou (":") a Seconds časť môže byť zadaný s desatinnej čiarky ('.'). Ďalšie informácie o platných formátoch nájdete v časti poznámky na rozhraní .NET Metóda DateTime.TryParse .

Tip

Odporúča sa použiť aspoň 3 list názov mesiaca vo formáte (tj "júla" alebo "júla") pre hodnoty dáta skôr ako číselné formátovanie (tj "7" alebo "07"), pretože tieto hodnoty bude overovať cez väčšinu regiónov v závislosti na projekte Nastavenie regiónu z Súbor | Možnosti projektu.Tj. je odporúčané použiť "15 Júl 2010" skôr ako "15/7/2010" alebo "7/15/2010". U tohto príkladu, "15/7/2010" by zlyhá potvrdenie pre "Angličtina (USA)" a "7/15/2010" by zlyhá na "angličtinu (Spojené kráľovstvo)", avšak "15 Júl 2010" by sa vydávať za oboje.

o A Booleanmajetok môže byť buď true alebo false.Je to malé a veľké písmená, takže TRUE alebo FALSE môžu byť taktiež použité však áno, nie, 1, 0, atď bude všetko zlyhá akékoľvek obmedzenia vlastníctva.

o A Zoznamvlastnosť umožňuje zbierku prednastavených hodnôt ako je nízka | Stredná | Vysoký alebo Zachovať | Obnoviť | Redesign | Dôchodku a rozsah hodnôt pochádza z poľa Unit pre vlastnosť buď ako čiarka alebo potrubia '|' oddelené hodnoty. Vlastnosť môže byť považovaný za poradový (na rozdiel od menovitej, intervalu alebo pomer), pretože pri použití na grafoch a vyfarbovať prvky, na diagrams a 3ds hodnoty sú ošetrené len v vzostupne alebo zostupne) (objednávky. To je hodnoty sú vynesené vo vzostupnom (alebo zostupne) poradie na grafe os alebo farebného rozsahu.

8. Dátový typ možné nastaviť, aby sa Zakázané, Varovalalebo Vynútenýpravým kliknutím na pole Typ dát pre akékoľvek iné nastavenie než text, ktorý umožňuje žiadne znaky, takže nemôže nikdy byť nesprávne.

9. Nastavenie Povinnépríznak pre nové nehnuteľnosti.

Poznámka

Požadované polia môže byť používaný na označenie, či hodnota je potrebné zadať pre vlastnosť. To znamená, že to nemôže byť prázdne alebo prázdny. Falseje predvolený a znamená, že nehnuteľnosť môže byť prázdny alebo prázdne, Pravdivýznamená, že majetok by mal mať hodnotu a nemôže byť prázdna alebo prázdne. Na požadovanú môže byť nastavená tak, aby Zakázané, Varovalalebo Vynútenýpravým kliknutím na pole Povinné, ak bol nastavený na TRUE.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Pridanie prednastavených vlastností komponentné, pripojenie alebo typu | Súhrnné vlastnosti


Zmena komponentný / typ pripojenia je

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Zmena komponentný / typ pripojenia je

Odoslať pripomienky na túto tému.

Typy komponentov a pripojenie sa používajú predovšetkým na účely klasifikácie. Môžete použiť typy ako filtre pri prezeraní architektúry. Napríklad, namiesto pohľadu na celú vec, môžete zobraziť iba súčasťou aplikácie.

Ak chcete zmeniť komponentný / typ pripojenia je

1. Kliknite pravým tlačidlom myšisúčasti alebo pripojenie.

2. Vybrať Zmeniť typ.

3. Zvoľte iný typ zo zoznamu.

Tip

Keď zmeníte typ, môžete získať niektoré nové Normyalebo vlastnosti (čo je spojené s typom - pozri typy vetva stromu). Vaše existujúce Normy a vlastnosti zostanú nezmenené. Môžete si vytvoriť svoje vlastné nové typy a priradiť vlastné kombinácie Normy a vlastnosti na ne.

Pozri tiež

Vytvorenie nového typu | Naplnenie vašej architektúry - Prehľad | Analýza Vaše architektúra


Zmena nastavenia regiónu na projekt

Navigácia: Naplnenie vašej architektúry> Vlastnosti>

Zmena nastavenia regiónu na projekt

Odoslať pripomienky na túto tému.

Majetkové hodnoty vyžadujú určité formátovanie v rôznych oblastiach, aby zodpovedali akýkoľvek Typ dát obmedzenia pre Integer, desiatkovej a dátum / čas Vlastnosti. Napríklad v Austrálii desiatkovej "123456 bod Sedem Osem Deväť" je reprezentovaný ako "123,456.789", zatiaľ čo v Nemecku to bolo by zastupovali ako "123.456,789", a vo Francúzsku, že by bolo " 123 456789 ".Podobne, v USA "Druhý z decembra 1970" je reprezentovaný ako krátke dátum ako "12/2/1970", ale v Spojenom kráľovstve je zastúpená ako "2/12/1970", a v Poľsku ako "1970 - 1912 -02 ". V súlade s tým pracovať s projektom ABACUS naprieč regiónmi je nutný globálne nastavenia na projekt ABACUS.

Zmeniť nastavenie regiónu projektu Abacus

1. Skontrolujte, či máte ABACUS súborotvorený.

2. Vybrať Súbor | Možnosti projektu ... a z dialógového okna, ktoré sa objavia vyberte Oblasťa kliknite na tlačidlo OK, Poznámka: Pozri nižšie pre regionálnu predvolené sekcie.

Poznámka

Ak nevidíte Možnosti projektu ... položka menupotom nemáte Designer a Administrator doplnoksa nemôžete zmeniť región projektu.Tiež, ak žiadny región nastavený (tj kraja v možnosti projektu je "None (System región)"), potom každý Nastavenie aktuálnej kultúra MS Windows užívateľa (tj Regional Settings)sú používané na overenie vlastností.

Región predvolené

V nasledujúcej tabuľke sú uvedené predvolené hodnoty pre každý región, ako nastaviť pomocou Súbor | Možnosti projektu ...položka menu.Pre zoznam použitých symbolov Prosím, pozri tabuľku nižšie.

Oblasť | Desatinné Symbol | Digit zoskupenia | Záporné znamienko | Krátka doba | Dlho | AM / PM symbol | Short Date | Long Date
Angličtina (Austrália) | . | , | - | Hh: mm | HH: mm: ss | AM | Premiér | dd / MM / YYYY | dd MMMM yyyy
Angličtina (Spojené kráľovstvo) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / MM / YYYY | dd MMMM yyyy
Angličtina (Spojené štáty) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / rrrr | dddd, MMMM dd, yyyy
Francúzsky (Francúzsko) | , | priestor | - | Hh: mm | HH: mm: ss | | | dd / MM / YYYY | dddd MMMM d rrrr
Nemčina (Nemecko) | , | . | - | Hh: mm | HH: mm: ss | | | dd.mm.yyyy | dddd, d. MMMM rrrr
Italian (Italy) | , | . | - | Hh: mm | HH: mm: ss | | | dd / MM / YYYY | dddd MMMM d rrrr
Španielčina (Španielsko) | , | . | - | H: mm | H: mm: ss | | | dd / MM / YYYY | dddd, dd "de" mmmm "de 'yyyy
Angličtina (Kanada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / MM / YYYY | MMMM-dd-yy
Francúzsky (Kanada) | , | priestor | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM rrrr
Arabčina (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / YYYY | dd MMMM, rrrr
Arabčina (Saudská Arábia) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / yy | dd / MMMM / rrrr
Angličtina (Južná Afrika) | , | priestor | - | hh: mm tt | hh: mm: ss tt | AM | PM | YYYY / MM / dd | dd MMMM yyyy
Angličtina (Nový Zéland) | . | , | - | h: mm tt | h: mm: ss tt | A. M. | p.m. | d / MM / YYYY | dddd, MMMM d rrrr
Angličtina (India) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd-MM-YYYY | dd MMMM yyyy
Nemčina (Švajčiarsko) | . | ' | - | Hh: mm | HH: mm: ss | | | dd.mm.yyyy | dddd, d. MMMM rrrr
Francúzsky (Belgicko) | , | . | - | Hh: mm | HH: mm: ss | | | d / MM / YYYY | dddd MMMM d rrrr
Dutch (Belgicko) | , | . | - | H: mm | H: mm: ss | | | d / MM / YYYY | dddd MMMM d rrrr
Česká (Česká republika) | , | priestor | - | H: mm | H: mm: ss | odp. | odp. | d.M.yyyy | d. MMMM rrrr
Dánčina (Dánsko) | , | . | - | Hh: mm | HH: mm: ss | | | dd-MM-YYYY | d. MMMM rrrr
Grécky (Grécko) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / rrrr | dddd, MMMM d rrrr
Fínsky (Fínsko) | , | priestor | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'yyyy
Hungarian (Maďarsko) | , | priestor | - | H: mm | H: mm: ss | de. | du. | yyyy.MM.dd. | rrrr. MMMM d.
Dutch (Netherlands) | , | . | - | H: mm | H: mm: ss | | | d-M-yyyy | dddd MMMM d rrrr
Nórčina, Bokm (Nórsko) | , | priestor | - | Hh: mm | HH: mm: ss | | | dd.mm.yyyy | d. MMMM rrrr
Polish (Poland) | , | priestor | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM rrrr
Ruská (Rusko) | , | priestor | - | H: mm | H: mm: ss | | | dd.mm.yyyy | d MMMM rrrr "г."
Švédsky (Švédsko) | , | priestor | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | "deň" d MMMM rrrr
Korean (Kórea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | yyyy-MM-dd | YYYY "년 'M' 월 'd' 일" dddd
Hebrejčina (Israel) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / MM / YYYY | dddd MMMM dd yyyy

Nasledujúce symboly sa používajú na určenie, ako sú zobrazené dáta a časy:

Časové symboly |
h | Hour (hh zobrazuje hodiny s nulou na začiatku)
m | Minute (mm zobrazuje minútu s nulou na začiatku)
s | Druhý (ss zobrazuje na druhom mieste s nulou na začiatku)
tt | A.M. alebo p.m.
h / H | 12 alebo 24 hodín zobrazenie času
Dátum symboly |
d, dd | Day
ddd, dddd | Deň v týždni
M | Mesiac
y | Rok

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Zmena vlastností komponenty, pripojenie alebo typu | Pridanie prednastavených vlastností komponentné, pripojenie alebo typu


Možnosti príkazového riadku

Navigácia: Referencie>

Možnosti príkazového riadku

Odoslať pripomienky na túto tému.

Môžete vykonávať rôzne operácie Abacus priamo z príkazového riadku s najčastejšie operácie bytia otvoriť konkrétny súbor projektu a publikovať na HTML.

Konkrétne sa jedná o použitie príkazového riadku ABACUS je nasledujúci;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "USER" / pass "PASS"]

Argument | Popis
ProjectFile | ProjectFile môže byť buď ABACUS Súbor projektu (.abacus), súbor knižnice (.abacuslib), súbor XML (.xml) alebo MS Access DB (.mdb) a určený súbor bude buď otvoriť (ak .abacus alebo .abacuslib ), alebo vytvorený nový projekt (ak je XML alebo súbor .mdb).
OptionalFile | OptionalFile môže byť buď skript ABACUS (.abacusscript, .vb alebo .cs), Makro (.abacusmac) alebo súbor knižnice (.abacuslib) a určený súbor bude buď spustený po otvorení ProjectFile (pokiaľ .abacusscript, .vb alebo .cs alebo .abacusmac), alebo jednoducho otvoriť (ak .abacuslib).
/ ExitOnCompletion | Sa ukončí Abakus a v prípade potreby uložiť a zaviazať všetky zmeny do otvoreného .abacus projektov na dokončenie každej skriptu alebo makro. Poznámka: Tento parameter je malé a veľké písmená, takže je nutné použiť znak veľkého písmena "o" a "C" v texte, ako je znázornené.
/ DontShowDialogs | Zabráni ABACUS Enterprise Edition (EE) oznámenie o aktualizácii dialógy zobrazovali pri otvorení projektu. Poznámka: Tento parameter je malé a veľké písmená a tak sa určite použiť veľké písmená "S" a "D" v texte, ako je znázornené.
/ User "USER" / pass "PASS" | Užívateľské meno používateľa a heslo PASS bude použitý na prihlásenie do projektu s, nahradí akákoľvek uložené poverenia používateľa. Poznámka: Úvodzovky musia byť umiestnené okolo používateľa a PASS vlajky a dve dvojité úvodzovky môžu byť použité na úteku úvodzoviek v jeden používateľ alebo PASS vlajky.

Napr.;

ABACUS.exe "Data \ Example.abacus" "\ ScriptsPublishExample.vb"/ ExitOnCompletion / dontShowDialogs / user "Public" / pass "123456"

kedy spustiť z adresára, kde ABACUS.exe dvojitý je Nachádza vôľa otvorený Projekt Príklad a prihláste sa ako používateľ s heslom verejnej 123456 (ako je popísané tu ), Uverejne- do HTML a potom zatvorte projekt a to všetko bez akýchkoľvek zobrazenie dialógové okná na ceste (napr Aktualizovať úspešné "alebo" k dispozícii žiadne aktualizácie "pre podnikové projekty).

Napr.;

ABACUS.exe "Data \ Example.abacus" "\ ScriptsKatalóg Excel import.vb"/ ExitOnCompletion / dontShowDialogs

kedy spustiť z adresára, kde ABACUS.exe dvojitý je Nachádza vôľa otvorený Projekt Príklad a importovať "servery (2014 Actual) Xlsx" MS Excel súbor do katalógu "serverov" na "2014" Aktuálny architektúre projektu bez vykazovali akékoľvek dialógové okná pozdĺž cesty, a potom uzatvorenie projektu po dokončení. Ak sa operácia vykoná zmeny v projekte, potom pri uzatváraní zmeny sa uložia lokálne a ak je Enterprise projekt zaviazala k Enterprise Server.

Poznámka

Uistite sa, že používate správny dvojité úvodzovky ako tam je niekoľko do štandardnej znakovej sady ASCII a príkazového riadku systému Windows bude pracovať správne iba so správnym jedným. Správny dvojitý kód citát znak Desatinné 34 (hexadecimálne 22).To je to, čo sa používa vo vyššie uvedenom príklade, takže neváhajte a kopírovať / vložiť ho odtiaľ.


Kopírovanie a vkladanie

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Kopírovanie a vkladanie

Odoslať pripomienky na túto tému.

Môžete kopírovať časť alebo všetky svoje architektúry a vložiť ho na inom mieste v strome.

Ak chcete skopírovať

1. Kliknite pravým tlačidlom myšina položku, ktorú chceli skopírovať.

2. Vybrať Kopírovať.

Ak chcete vložiť

1. Prejdite strom nájsť miesto, ktoré chcete vložiť položku.

2. Kliknite pravým tlačidlom myšina vetve chcete, aby sa objaví v.

3. Vybrať Paste.

4. Položka sa skopíruje s pôvodným názvom (pokiaľ ju skopírovať do pôvodnej vetvy - potom to bude volať "Kópia ...").

Pozri tiež

Ako sa architektúra zastúpená v ABACUS


Kopírovanie diagramy

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Kopírovanie diagramy

Odoslať pripomienky na túto tému.

K dispozícii sú 2 základné scenáre do skopírovaním existujúcej schému; v architektúre, alebo cez architektúry.

K kópieschémav rámci architektúry

1. Skontrolujte, či máteABACUS otvoriť súborobsahujúce Váš obývaný architektúras aspoň jedným diagram.

2. Rozbaliť Diagramyvetva (a prípadne zabezpečiť potrebné Diagram skupiny) z danej Staviteľstvočasť stromu.

3. Vyberte diagram, ktorý chcete kopírovať, a potom stlačte tlačidlo Ctrl + Calebo kliknite pravým tlačidlom myšia vyberte Kopírovať z ponuky.

Poznámka

A kópiu rozhodnutia schéma bude pridaná do Diagramyvetva z rovnaký architektúru. To bude mať "Kópia" pripojená na začiatok názvu, Ktorý môžete zmeniť neskôr stlačením F2 alebo kliknutí pravým tlačidlom myši na nehoa výberom Premenovať.

K kopírovať diagram cez architektúry

1. Skontrolujte, či máteABACUS otvoriť súborobsahujúce Váš obývaný architektúrass aspoň jedným diagram.

2. Rozbaliť Diagramyvetva (a prípadne zabezpečiť potrebné Diagram skupiny) z Staviteľstvočasť stromupre architektúru, ktorá obsahuje diagram, ktorý chcete kopírovať.

3. Vyberte diagram, ktorý chcete kopírovať, a na Všeobecné vlastnostiOkno Poznámka Hľadisko že diagram je spojený s (v poli Typ).

4. Teraz, rozšíriť Diagramyvetva (a prípadne zabezpečiť potrebné Diagram skupiny) z Staviteľstvočasť stromupre ostatné architektúry, ktorý chcete skopírovať do diagramu.

5. Kliknite pravým tlačidlom myši Diagramy uzol (alebo Diagram skupina) A vyberte Vytvoriť diagram ..., V dialógovom okne, ktoré sa objaví vyberte Hľadisko ktorá bola zaznamenaná v kroku 3 vyššie v rozbaľovacej ponuke v pravom hornom rohu. Nechajte všetko ostatné, ako je a kliknite na tlačidlo OK, V dialógu Diagram Názov zadajte názov (čoskoro byť) kopírované diagramu. Poznámka: prázdny diagram plátno podľa zvoleného hľadiska sa otvorí.

6. Vráťte sa do schémy, ktoré chcete kopírovať, a otvoriť, že kliknutí pravým tlačidlom myšiuzol a výberu Otvorené alebo jednoducho poklepanímza to.

7. Vyberte pozadie plátno diagramu, ktorý chcete kopírovať, a stlačte Ctrl + A, Tým sa vyberú všetky prvky na tomto diagrame. Teraz stlačte Ctrl + Ckopírovať obsah do schránky.

8. Teraz sa vráťte do prázdneho diagramu v architektúre, ktorú chcete skopírovať obsah do, zvoliť pozadieplátno a buď kliknite pravým tlačidlom myšia vyberte Paste alebo jednoducho stlačte Ctrl + Vvložiť obsah. Po krátkej dobe sa obsah všetko bude vložený do nového prázdneho diagramu.

Poznámka

Prvky bude pridaná do najvyššej úrovne novej architektúry a budú musieť byť re-zariadil alebo zlúčené s existujúci obsah v súlade s.

Pozri tiež

Nástroje na kreslenie | Naplnenie vašej architektúry | Analýza Vaše architektúra


Vytvorenie novej komponenty / Typ pripojenia alebo typu Group

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Vytvorenie novej komponenty / Typ pripojenia alebo typu Group

Odoslať pripomienky na túto tému.

Typy komponentov a pripojenie sa používajú predovšetkým na účely klasifikácie. Môžete použiť typy ako filtre pri prezeraní architektúry. Napríklad, namiesto pohľadu na celú vec, môžete zobraziť iba súčasťou aplikácie.

Ak chcete vytvoriť novú súčasť / Typ pripojenia

Poznámka

Ak chcete pridať typy alebo skupiny typov v projekte ABACUS licencie užívateľ potrebuje Designer add-on schopnosti. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

1. Rozbaľte Druhyvetva stromu.

2. Kliknite pravým tlačidlom myšina Component Druhy(alebo Typy pripojenia).

3. Vybrať Pridať Component Type(alebo Pridať typu pripojenia), Alebo Vytvoriť skupinu.

Tip

Potom, čo ste vytvorili typ, mali by ste zmeniť jeho ikonu (pozri nižšie) a pridať Vlastnosti a Normy jemu pre súčasti alebo inštancie pripojenie k "Dediť".

Ak chcete zmeniť ikonu pre komponent / Typ pripojenia

Poznámka

Ak chcete zmeniť ikony pre typy v projekte ABACUS licencie užívateľ potrebuje Designer add-on schopnosti. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

1. Kliknite pravým tlačidlom myšina Component Type(alebo Typ pripojenia) Ak chcete zmeniť ikonu.

2. Vybrať Zmeniť ikonu.

3. V dialógovom okne Prehľadávať Vybrať ikonu umiestnenia a vyberte súbor s obrázkom a kliknite na tlačidlo Otvoriť.

Poznámka

Môžete mať vlastný obrázok ikony ľubovoľnej veľkosti, ale to bude vždy byť zmenšený, aby sa vošli na obrázok 16x16 pixelov v okne Prieskumníka. Takže ak vaše pôvodné vlastný obrázok ikony nie je rovnaké výšky a šírky bude ikona Explorer Okno sa pretiahol. V súlade s tým, vlastné obrazy by mala byť najmenej 16x16 pixelov, a ak chcete zachovať presný tvar ikony vlastné uistite sa, že vaše vlastné obrázok ikony je rovnaká výška a šírka v pixeloch (16x16 alebo väčšie). Tiež by ste mali byť opatrní, o ktoré nemajú farebný 'obrazových bodov "ísť celú cestu na hranici vlastnej ikonu obrázka, ako to bude vyzerať chudobní v okne Prieskumníka s priľahlými ikonami" krvácanie "do seba. Preto by ste mali nechať aspoň 1 pixel biely okraj.

Tip

Môžete si vytvoriť svoj vlastný obrázok ikony ICO, BMP, GIF, JPG alebo PNG formát súboru, ale vzhľadom na obmedzenia v systéme Windows len ICO formáte bude náhľad v dialógovom okne ABACUS Select Icon, ak máte možnosť View menu nastavený na inú ako miniatúry.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Analýza Vaše architektúra


Vytvorenie alebo duplikovanie architektúru

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Vytvorenie alebo duplikovanie architektúru

Odoslať pripomienky na túto tému.

Môžete mať ľubovoľný počet architektúr v jedinom súbore ABACUS. Obvykle by ste vytvoriť novú architektúru zakaždým, keď chcete modelovať a vyhodnotiť vývoj vášho systému.

Ak chcete vytvoriť novú architektúru

1. Kliknite pravým tlačidlom myšina Architektúryvetva stromu.

2. Vybrať Nová architektúra.

Ak chcete vytvoriť kópiu existujúcej architektúry

1. Kliknite pravým tlačidlom myšina architektúre.

2. Vybrať Kopírovať.

3. Kliknite pravým tlačidlom myšina Architektúryvetva stromu.

4. Vybrať Paste.

5. Nová architektúra sa bude volať "Kópia ...".

Pre ďalší vývoj existujúcej architektúry

1. Kliknite pravým tlačidlom myšina architektúre.

2. Vybrať Vyvinúť.

3. Nová architektúra sa bude volať "... 0,1".

Poznámka

K dispozícii je podrobný popis na vyvíjajúci sa architektúrach tu .

Pozri tiež

Ako sa architektúra zastúpená v ABACUS | Vyvíjajúce vašej architektúry


Vlastné zostavy

Navigácia: Podávanie správ o vašu architektúru>

Vlastné zostavy

Odoslať pripomienky na túto tému.

Užívateľské zostavy Abacus 'umožňujú vytvárať plne konfigurovateľný vlastných zostáv. Správy môžu obsahovať vlastné snímky a grafiku, rovnako ako popisovať všetky časti, spoje alebo atribúty z úložiska ABACUS, ako aj podrobných analytických výsledkov z rôznych simulácií (vrátane TCO, efektívnosť a spoľahlivosť). Okrem toho môžu správy obsahujú diagramy, grafy, katalógy, matice / kontingenčnej tabuľky, mapy, meradla, Sparklines, dátové bary a ukazovateľov (napr dopravno-svetla).

Poznámka

Po dobu, kedy užívateľ môže otvoriť už existujúce vlastné zostavy, to configure Správy licencie užívateľ potrebuje Report Configuration schopnosť. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

Ak chcete zobraziť zvyk správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra(s).

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavysa zobrazí okno.

Vlastné zostavyokno

3. Vyberteexistujúce Reportže chcete zobraziť z Dostupné správyoddiel.

4. Kliknite na tlačidlo Run Report.Táto správa sa otvorí v aplikácii Microsoft Report Viewer a to Prechádzajte stránok správy, kliknite na ikony [image] umiestnené na paneli nástrojov v ľavom hornom rohu obrazovky.

Poznámka

Môžeš ušetriť správa do rôznych formátov kliknutím na tlačidlo Export Ikona správa [image] Nachádza v panel nástrojov. Môžete si vybrať, pre export do týchto formátov: Vynikať, PDFa Slovo, Prosím, uložte zostavu v požadovanom mieste pre neskoršie použitie. Ak sú vykonané zmeny v architektúre v neskoršej fáze, bude nová správa musí byť vytvorené tak, aby odrážali zmeny.

K upraviť dáta úložiska, ktorá je odoslaná a zvyk správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra(s).

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavyokno (pozri vyššie) Zobrazí.

Poznámka

Po dobu, kedy užívateľ môže otvoriť už existujúce vlastné zostavy, to configure dáta, ktorá je odoslaná na vlastnej správe licencie užívateľ potrebuje Report Configuration schopnosť. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

3. Vyberteexistujúce Reportže chcete zobraziť z Dostupné správyoddiel.

4. Kliknite na tlačidlo Upraviť Dátové sady. Dáta Set Editorsa zobrazí okno.Toto okno zobrazuje zbierku súborov dát, ktoré sú v súčasnej dobe zasielané vlastnej správe. V nižšie uvedenom príklade sú tri (3);

· súbor ApplicationProxy dáta, ktoré udáva všetky údaje pre všetky komponenty aplikácií v "2015" Aktuálny architektúry (vrátane vlastností o svojich normách a akýchkoľvek pripojených komponentov),

· sada TwoDViewProxy dát, ktorá je zadaním jedného alebo viacerých schém, kde názov zodpovedá "aplikačného prostredia (Austrália)",

· TargetProxy sada dát, ktorá udáva všetky údaje pre všetky cieľové spoje v roku 2015 "Skutočná" architektúry (vrátane pripojených komponentov).

Dáta Set Editorokno

Poznámka

Name dotazu bude použitý pre názov sady dát v aplikácii Microsoft Report Builder (pozri nižšie). Zahrnúť pole určuje, či dátový súbor je buď jednoduché čidlo, kolekciu prvkov, všetky typy komponentov, všetky typy pripojenia, jedno alebo viac architektúr, jedno alebo viac schém alebo jeden alebo viac grafov. Pre "Kolekcia prvkov" dátových sad tlačidlo Filter je poskytovaný, ktorý po kliknutí otvorí filtra okne prvku, ktorý vám umožní aplikovať viac filtrov, ktorá vráti iba prvky z určitých architektúr, a / alebo niektorých druhov, a / alebo s určitými štandardmi , a / alebo pripojené k určitej zložky, a / alebo s niektorými rodičmi, a / alebo v určitých diagramov, a / alebo v určitých grafov a / alebo s danými hodnotami vlastníctva. U ostatných typov súboru dát názov poľa je k dispozícii, a pomocou tlačidla Select si môžete vybrať objekt (y), ktoré majú byť súčasťou sady dát.

Poznámka

Dátové súbory sú uložené vSady dát súboru (.xml)s rovnakým názvom súboru ako základňa spojená Report Definition súbor (.RDL), Ak tento súbor neexistuje sada dát editor automaticky naplniť s akýmikoľvek názvami otázok, ktoré existujú v Report Definition súbor (.RDL)a nový Sady dát súboru (.xml)bude vytvorený, akonáhle je definovaná aa platný zoznam otázok.

3. Ak chcete odstrániť existujúci súbor dát potom vyberte Zmazať dotazTlačidlo.

4. Ak chcete pridať novú sadu dát a potom kliknite na tlačidlo Pridať nový Data SetTlačidlo a konfigurovať súbor dát podľa poznámke vyššie.

K vytvoriť nový vlastný správa(zo šablóny)

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra.

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavyokno (pozri vyššie) Zobrazí.

3. Kliknite na tlačidlo Nový a vyberte buď A4 - Portrét, A4- Krajina, A3 - Portrét, A3 Krajina, US Letter - Portrét, US Letter - Krajina, US Tabloid - Portrétalebo US Tabloid - KrajinaV závislosti na orientácii správu a papiera veľkosti, ktorá je požadovaná.

4. Vyhľadajte umiestnenie pre uloženie Report Definition súbor (.rdl / .rdlc) a zodpovedajúce dáta Set (XML) a kliknite na tlačidlo Save, To bude pridať novú vlastnú správu k dispozícii v časti Reports okna vlastné správy, a to môže otvoriť alebo upravovať, ako je popísané vyššie.

K pridať existujúce vlastné správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra.

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavyokno (pozri vyššie) Zobrazí.

3. Kliknite na tlačidlo Pridať a prejdite do umiestnenia súboru definície zostavy (.rdl / .rdlc) a kliknite na tlačidlo Otvorené, To bude pridať novú vlastnú správu k dispozícii v časti Reports okna vlastné správy, a to môže otvoriť alebo upravovať, ako je popísané vyššie.

Poznámka

Predpokladá sa, že súbor zodpovedajúci Data Set (.xml) existuje v rovnakom mieste ako súbor Report Definition.

K skopírovať existujúce zvyk správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra.

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavyokno (pozri vyššie) Zobrazí.

3. Vyberteexistujúce Reportže chcete kopírovať z Dostupné správyoddiel.

4. Kliknite na tlačidlo Kopírovať a kópiu zvoleného správy (s názvom "Kópia ..."), bude pridaný do časti Dostupné Reports okna vlastné správy, a to môže otvoriť alebo upravovať, ako je popísané vyššie.

Poznámka

Tým bude vytvoriť kópiu tejto správy je Report Definition súbor (.rdl / .rdlc) rovnako ako jeho zodpovedajúce Data Set (XML)(ak existuje).

K odobrať existujúce zvyk správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra.

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavyokno (pozri vyššie) Zobrazí.

3. Vyberteexistujúce Reportže chcete odobrať z Dostupné správyoddiel a kliknite na tlačidlo Odstrániť.

Poznámka

Pri odobratí správu, bude na zozname správ už nebudú zobrazovať. Avšak, toto nie je zmazať Správa uvádza správa definície súbor (.rdl / .rdlc) alebo Data Set súbor(.xml), Ak je to potrebné, odstránenie týchto súborov môže byť dosiahnuté pomocou systému súborov.

K premenovať existujúci zvyk správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra.

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavyokno (pozri vyššie) Zobrazí.

3. Vyberteexistujúce Reportže chcete premenovať na Dostupné správyoddiel a kliknite na tlačidlo Premenovať.

4. Zadajte nový názov pre zostavu.

Poznámka

Ako Report Definition súbor (.rdl / .rdlc) a zodpovedajúce Data Set (XML), bude zodpovedajúcim spôsobom premenovaná.

K upraviť navrhnutie zvyk správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra.

2. Vybrať Insert| Vlastné správaalebo kliknite na Vytvoriť vlastnú správu tlačidlo na paneli nástrojov. Vlastné zostavyokno (pozri vyššie) Zobrazí.

Poznámka

Po dobu, kedy užívateľ môže otvoriť už existujúce vlastné zostavy, to configure navrhnutie vlastných zostáv licencie užívateľ potrebuje Report Configuration schopnosť. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.Navyše, Microsoft Report Builder 3.0 je nutné navrhnúť správy a možno ho stiahnuť zadarmo z tu .

3. Vyberteexistujúce Reportže chcete zobraziť z Dostupné správyoddiel.

4. Kliknite na tlačidlo Edit Report.Táto správa sa otvorí v aplikácii Microsoft Tvorca zostáv 3.0. Pre konkrétnu pomoc a niektoré "tipy a triky" na niektoré z viac bežných úloh s navrhovanie správy nájdete na nasledujúcich sekciách. Pre všeobecnú pomoc na projektovanie správ nájdete na Microsoft Tvorca zostáv 3.0 stránkach nápovedy tu .

Pridanie tabuľky do zostavy

1. Uistite sa, že máte počítadla užívateľských zostáv Definition súbor (.rdl / .rdlc) otvorený v aplikácii Microsoft Tvorca zostáv 3.0.

2. Vybrať Insert Karta v "stuhou" na vrchole, potom kliknite na tlačidlo Tabuľka tlačidlov sekcii regiónov Data a vyberte Vložiť tabuľku.

3. Teraz pretiahnite kurzordo polohy o správe plátne, kde chcete, aby ľavý horný roh tabuľky umiestnené. Kliknite na plátno, Štandardne je v tabuľke bude pridaný riadok hlavičky a potom podrobností skupiny (skupina je použitá zorganizovať pohľad na zostavy dátovej sady). Ak chcete odstrániť skupinu, buď odstrániť riadok alebo odstránenie skupiny riadkov na paneli nástrojov zoskupenia.

Tips

Vzorca / Výrazy v bunkách tabuľky sa editujú výberom bunky kliknite pravým tlačidlom myši na << Expr >> text a výberom výraz .... Triedenie riadkov v tabuľke sa vykonáva výberom tabuľky a potom prechádzanie dole na strane druhej -> SortExpressions poľa v paneli Vlastnosti a zadaním výraz. Pre celkové riadok na konci tabuľky pridať riadok po (i mimo), zoskupovanie a potom použite nasledujúci výraz = Sum (Fields!Názov.Value)kde "Name" je pole je celkom. Ak chcete použiť farby na stĺpce použiť "IIF" vyhlásenie vo vlastníctve backgroundColor. Pre pridanie meradlo ako bunky v tabuľke najprv vložiť meradlo do bunky a potom padajú dátové polia potrebné pre rozchod. Pri úprave výšky & šírky riadky tabuľky, uistite sa, vyberte správny riadok, a potom prejdite kurzorom myši okolo šedé čiary, až sa dostanete hore / dole kurzor, a potom zmeniť veľkosť.

Pridanie grafy do zostavy

1. Uistite sa, že máte počítadla užívateľských zostáv Definition súbor (.rdl / .rdlc) otvorený v aplikácii Microsoft Tvorca zostáv 3.0.

2. Vybrať Insert Karta v "stuhou" na vrchole, potom kliknite na tlačidlo Graf tlačidlov sekcii regiónov Data a vyberte Vložiť Chart.

3. Teraz pretiahnite kurzordo polohy o správe plátne, kde chcete, aby ľavý horný roh grafu umiestniť. Kliknite na plátno a potom Vyberte grafpožadujete z možností a kliknite na tlačidlo OK.

Tips

Ak chcete zobraziť vlastnosť ako anotáciu na schémy, kliknite pravým tlačidlom myši na graf a vyberte Zobraziť menovky údajov, vyberte jednu z etikiet, ktoré boli pridané a nastavte Rôzne -> UseValueAsLabel na FALSE v paneli vlastností a pridajte výraz (napr = Name.Value Fields) v Ostatné -!> Label. Špeciálne pre bublina grafy; Bubble grafy sú zobrazené pod záhlavím bodový graf. Drop X vlastnosť osi do polí radu (alebo pridať vlastnosti série). Drop vlastnosť osi Y do dátových polí (alebo pridať vlastnosti série). Ak chcete použiť vlastnosť definovať veľkosť bublín, pokles toto do dátových polí (alebo pridať vlastnosti série). Bubble grafy sú schopné zobraziť, ak je príliš veľa dát (200 + položiek), niekedy to spôsobí, že celý správu nezobrazí. Marker Type - Nastavte na kruhu. V predvolenom nastavení, keď klesá polí do dátových polí, pridá im s súčet ()formula, a tak odstrániť to. Špeciálne pre Skladaný grafy / Timeline / Ganttov diagram; Pre Ganttovho diagramu používať rozsah grafu a pridať vlastnosti ako vysokých a nízkych hodnôt v dátových polí. Môžete mať viac "tyčí" pripočítaním viac a viac rozsahov, kde je nízka hodnota jedného stretnutia vysokú hodnotu za inú. Špeciálne pre Koláčové grafy; U súhrnných koláčové grafy, pretiahnutia dát do kategórie polí a dátové polia, pridajte vzorec = CountRows (), Odfiltrovať Hodnoty 0 (napr nákladov grafy), inak etikety pre tieto budú naďalej zobrazené v grafe.

Použitie príkazu IIF pridať farby do tabuliek a grafov

1. Uistite sa, že máte počítadla užívateľských zostáv Definition súbor (.rdl / .rdlc) otvorený v aplikácii Microsoft Tvorca zostáv 3.0.

2. Pravým tlačidlom myši na bunku v tabuľke farbu a kliknite Vlastnosti Text Box.

3. Vybrať Vyplniť a kliknite na tlačidlo fxTlačidlo vpravo farbu výplne štítku av nastaviť výraz pre backgroundColor poľa zadajte výraz, napr = IIF (Fields! InformationStatus.Value = "Zachovať", "zelená sv", IIF (Fields! InformationStatus.Value = "Redesign", "Yellow", IIF (Fields! InformationStatus.Value = "Refresh", "oranžová", " Salmon "))), Tým sa zmení farbu pozadia na svetlo zelenú pre každú bunku, ktorá obsahuje stav "Zachovať", žltá pre každú bunku, ktorá obsahuje stav "redesign", oranžová pre každú bunku, ktorá obsahuje stav "Aktualizovať" a akýkoľvek iný status hodnota bude farebný v "Salmon".

Poznámka

Farby môžu byť pridané grafov výberom série v grafe, a potom nastavenie vzhľadu -> vlastnosť Color (alebo bublina mapuje Vzhľad -> Marker -> Color vlastníctva) výrazu podobné vyššie uvedeného príkladu.

Veci mať na pamäti pri navrhovaní vlastných zostáv

· Vzhľadom k tomu všetky vlastnosti s výnimkou Integer sú odosielané ako reťazec z ABACUS k divákovi správu, ak chcete robiť žiadne "výrazmi" s nimi (ako priepasť jednu vlastnosť inú alebo druh), musíte ich previesť na desiatkovej alebo dátum atď. Na pozadí , tento článok Je dobré referencie. Napr. = CDATA (Fields LifecycleEndDate.Value!) Poznámka: Uistite sa, že jazyk, správa je nastavená na hodnotu en-GB (ako je popísané nižšie), prijať dd / mm / rrrr, ako to očakáva formát mm / dd / rrrr v predvolenom nastavení a podľa 31/7/2011 zlyhá konverzie. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (CostTotalCosttoOwnnext5years.Value Fields !, 0)

· Ak zistíte, že ste snaží držať všetky tabuliek a grafov na jednu stránku, Existuje niekoľko hlavné spôsoby správu dokumentov priestor:

· Koniec stránky - Uistite sa, že toto nastavenie tabuľka je vypnuté pre každú tabuľku, ktorú si prajete byť na rovnakej stránke.

· Keep Together - Zabezpečiť toto nastavenie tabuľka platí pre každú tabuľku, ktorú si prajete byť na rovnakej stránke.

· Pri pohybe veci okolo, je ľahšie pre oddialenie pomocou ovládača na pravej dolnej časti stránky a potom multi výber položiek a ťahať

· Pre obrazový riadok v tabuľke, uistite sa, že "veľkosť" | "Triedenie podľa veľkosti" je nastavená na "fit" inak obrazu sa môžu javiť ako príliš veľké, alebo to bude zle natiahnuté.

· K opakovať riadok hlavičky tabuľky na každej stránkesprávy:

1. Otvoriť Rozšírený režim v table zoskupení. (Kliknite na šípku vpravo od skupiny stĺpcov a vyberte Rozšírený režim.)

2. V oblasti skupín riadkov (ne Stĺpec skupiny), kliknite na statické skupine, ktorá zdôrazňuje zodpovedajúce textové pole v tablix. Preklikajte každé statické skupiny, kým sa zdôrazňuje, že je úplne vľavo hlavičku stĺpca. To je zvyčajne prvou Static skupine uvedeným.

3. V okne Vlastnosti nastaviť vlastnosť RepeatOnNewPage na hodnotu true.

4. Uistite sa, že vlastnosť KeepWithGroup je nastavená na hodnotu Po.

· Zmena Nastavenie jazykavo vlastnostiach Report, aby zodpovedali formáty dát, ktoré potrebujete, napríklad en-GB vyrábať UK formátu dátumu (dd / mm / rrrr).

Pozri tiež

Analýza vašej architektúry


Prispôsobenie rozhranie ABACUS

Navigácia: Úvod do ABACUS>

Prispôsobenie rozhranie ABACUS

Odoslať pripomienky na túto tému.

Môžete zmeniť vzhľad a správanie rozhrania ABACUS v mnohých ohľadoch. ABACUS obsahuje niekoľko preddefinovaných nastavení kombinácií, ktoré môžete použiť použiť skupinu customizáciu k rozhraniu. Okrem toho môžete vykonať individuálne customizácia na položky, ako sú okná, panely nástrojov, klávesové skratky, a možnosti rôzne displeja.

Usporiadať a Dock Windows

Máte veľa možností pre aranžovanie výkladov v rámci rozhrania pre ABACUS, vrátane nasledujúcich:

· Tab-dok okna.

· Dock okná na okraj rámu v rozhraní.

· Minimalizácia okna nástroj pozdĺž okraja rozhranie.

· Obnoviť umiestnenie okna na predvolené rozloženie.

Dokovacia Windows

Ak je okno ukotvitelných, môže byť pripevnená k jednej strane rámu v rámci rozhrania, alebo môže byť usporiadaná na kartami tabúľ v ráme. Sprievodca diamant objaví pri pretiahnutí okna z ich aktuálneho umiestnenia do iného umiestnenia v rozhraní. Vodiace diamant umožňuje rýchlo znovu ukotviť okno na jednej zo štyroch strán rámu alebo v stredu ako kartami panelu. Keď je okno Nekupírovaný alebo nie ukotvitelných, pláva nad ostatné okná.

Ak chcete ukotviť okná

1. Kliknite na okno, ktoré chcete ukotviť, dať sa zamerať.

2. Na Oknomenu, kliknite na tlačidlo Ukotvitelných.

3. Pretiahnite okno z jeho aktuálneho umiestnenia smerom k stredu snímky, ktorý chcete ukotviť sa.

Zobrazí sa Sprievodca diamant. Štyri šípky diamantového bodu smerom štyroch okrajov rámu a stredu predstavuje panel v paneloch.

Tip

Ak chcete presunúť ukotvené okno bez toho, aby zaklapnutím na miesto, stlačte CTRL pri preťahovaní ho.

4. Keď sa okno, ktoré preťahujete dosiahne polohy, kde ju chcete ukotviť, presuňte ukazovateľ myši na zodpovedajúce časti vodiaceho diamantu. Náčrt okna sa zobrazí vo vymedzenej oblasti.

5. Ak chcete ukotviť okno do polohy označenej, uvoľnite tlačidlo myši.

Napríklad, ak Cestovateľje ukotvený na ľavom okraji rozhraní a chcete ukotviť na pravom okraji, by preťahovanie Cestovateľsmerom k stredu rozhranie, presuňte ukazovateľ myši na pravej strane vodiaceho diamantu, a potom uvoľnite tlačidlo myši.

Minimalizácia Windows

Windows (či už sú nástroj Windows - objaviť sa na Pohľadmenu, alebo Dokument Windows - objaviť sa na Oknomenu) podporuje funkciu nazvanú Auto Hide. Auto Hide umožňuje vidieť viac z vašej architektúre naraz vďaka minimalizácii okien pozdĺž okrajov rozhranie, keď sa nepoužíva.

Ak chcete zapnúť automatické Skryť

1. Kliknite na okno, ktoré chcete skryť, aby sa zamerať.

2. Na Oknomenu, kliknite na tlačidlo Auto Hide.

- Alebo -

2. Kliknite na ikonu pripináčika v záhlaví okna.

Auto Hide Povolené

Keď stratí fokus okno auto-skrytá, to sa automaticky zasunie späť na záložku na okraji rozhraní. Kým okno je auto-skrytá, jej názov a ikony sú viditeľné na karte na okraji rozhraní. Ak chcete zobraziť okno automatické skryté, presuňte ukazovateľ myši na karte. Okno zasunie späť do zorného poľa a je pripravený na použitie.

Poznámka

Sa okno, ktoré je automatické skryté nemôže byť ukotvený. Ak chcete ukotviť okno, budete musieť vypnúť Schovávať ako je popísané nižšie.

Ak chcete vypnúť Schovávať

1. Kliknite na okno, ktoré chcete zachovať viditeľné, aby sa zamerať.

2. Na Oknomenu, kliknite na tlačidlo Auto Hidezrušte zaškrtnutie políčka.

- Alebo -

2. Kliknite na ikonu pripináčika v záhlaví okna.

Auto Skryť Disabled

Tip

Windows, ktoré majú Schovávať povolené dočasne skĺznuť do pohľadu, keď okno má fokus. Ak chcete znova skryť okno, vyberte položku mimo aktuálne okno. Akonáhle sa okno stratí fokus, že skĺzne späť pohľadu.

Resetovanie Windows rozvrhnutie

Môžete vrátiť rozhranie východiskovým rozvrhnutie okna pomocou Obnoviť rozvrhnutie oknapríkaz. Pri spustení tohto príkazu, dôjde k nasledujúcim akciám:

· Všetky okná sú presunuté do východiskových pozícií.

· Windows, ktoré sú uzavreté v predvolenom rozvrhnutie okná sú uzavreté príkazom.

· Windows, ktoré sú otvorené v predvolenom rozvrhnutie okná sa otvárajú príkazom.

· Windows, ktoré sú skryté / viditeľné v predvolenom rozvrhnutie okná sú skryté / viditeľný príkazom.

Ak chcete obnoviť umiestnenie okna na predvolené rozloženie

1. Na Windowsmenu, kliknite na tlačidlo Obnoviť rozvrhnutie okna.

Prispôsobenie ponúk a panelov nástrojov

Môžete zmeniť rozloženie, umiestnenie a obsah ponúk a panelov nástrojov v rozhraní. Môžete tiež pridať tlačidlá do panelov nástrojov a zmeniť priradenú ikonu ľubovoľného tlačidla.

Vytvorenie novej panely nástrojov

Ak chcete vytvoriť nový panel nástrojov

1. Na Nástrojemenu, vyberte Prispôsobenie.

2. V VlastnáDialógové okno, vyberte Panely nástrojovTab.

3. Zvoliť Nový.

4. V Nový ToolbarDialógové okno, zadajte názov panela nástrojov.

5. Zvoliť OK.

Ak chcete pridať tlačidlo príkazu ponuky alebo panela nástrojov

1. Na Nástrojemenu, vyberte Prispôsobenie.

2. V VlastnáDialógové okno, vyberte PríkazyTab.

3. Vyberte kategóriu a pretiahnite príkaz z dialógového okna do ponuky alebo panela nástrojov.

4. Zvoliť Zavrieť.

Tip

Podržaním klávesy Alt kľúč umožňuje rýchle prispôsobenie príkazy, ako by sa dialógové okno Vlastné boli otvorené.

Pozri tiež

Rozhranie ABACUS


Definovanie a overovanie Obmedzenia

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Definovanie a overovanie Obmedzenia

Odoslať pripomienky na túto tému.

Štruktúra a vlastnosti architektúry môže byť obmedzené pomocou väzieb. Obmedzenie je možné aplikovať na typy komponentov a typy pripojenia obmedziť štruktúru architektúry v dvoma spôsobmi. Prvým spôsobom je obmedziť hierarchiedefinovaním "rodič by mal / musí mať dieťa" a "dieťa by malo / musí mať materská" vzťahy. Druhým spôsobom je obmedziť topológiadefinovaním "zložka by mala / musí byť pripojený k pripojenie" a "pripojenie by malo / musí byť pripojený k zložka" vzťahov. Okrem toho obmedzenia môžu byť aplikované na charakteristiky typov komponentov, typy pripojenia, šablóny, pohľady, architektúry, diagramya 3D prehliadky obmedziť architektúry (y) v ďalších dvoch smeroch. Prvý spôsob je nastaviť dátový typnehnuteľnosti obmedziť platné hodnoty, že môže mať, a to; Text, Integer, desiatkovej, dátum / čas, Boolean alebo List. Druhý spôsob je nastaviť potrebnýStav nehnuteľnosti na označenie, či je hodnota, je potrebné zadať pre vlastnosť (Poznámka: Požadované obmedzenie sa vzťahujú len na vlastnosti pre komponentov a pripojenie typy). Ďalšie informácie o obmedzeniach nehnuteľnosť je ponúkaná v Zmena vlastností komponenty, pripojenie alebo typu téma pomocníka. Potom, čo boli definované obmedzenie, je možné overiť architektúry proti obmedzenia. ABACUS bude varovať o všetkých obmedzeniach, ktoré boli porušené.

Kľúčom na určenie toho, ktoré podmienka (podmienky), aby sa definovať spočíva v presnom jazyk použitý na opis obmedzenia. Pre hierarchických obmedzenia sú zvyčajne vo forme "podstatné menámôže / by mala / musí byť rozložený do n podstatné mená"Alebo"podstatné menámôže / by / musí byť zoskupené podľa podstatné mená"Atď. Napríklad"Oddeleniemusí byť rozložený do Tímy"Alebo"Aplikáciamožno rozdeliť na Moduly". Pre topológie obmedzením, že sú typicky vo forme"podstatné menámôže / by / musí sloveso podstatné mená". Napríklad, "Procesy môže byť vykonáva Tímy"Alebo"Aplikáciasú hosťuje Servery". Teraz môžete vidieť v každej obmedzení existujú rôzne CAN / mala by sa / musí" kvalifikačné "a tieto môžu byť 3 typov;

· Voliteľný- Tie budú typicky používať slová / frázy páči; "môže", "môže", "mohol", "prípadne" atď.

· Odporúčaná- Tie budú typicky používať slová / frázy páči; "by mali", "odporučil", "poradil" atď.

· Povinné- Tie budú typicky používať slová / frázy páči; "musí", "je", "sú", "má", "musí" atď.

V závislosti od typu obmedzenie (hierarchia alebo topológia) a kvalifikáciu používané v popise to, špecifická väzba (s), by mal byť definovaný (pozri nižšie). Pre vyššie uvedené hierarchie príkladom "Oddeleniemusí byť rozložený do Tímy"Jeden by mal definovať" Parent, musí mať dieťa "obmedzenia a nastaviť výkon má byť vykonaný. Pre vyššie uvedený príklad topológie"Procesy môže byť vykonáva Tímy. "Je potrebné vytvoriť len dva (2)" Pripojenie musí byť pripojený k Component "obmedzenia, ktoré pre oboch koncoch vykonané podľa typu pripojenia Konkrétne sa jedná o nasledujúce obmedzenia sa odporúča byť definované (pozri nižšie), pre rôzne možnosti;

· Hierarchie obmedzenia;

o Podstatné mená môže byťrozložený do Podstatné mená BAlebo Podstatné mená B môže byťzoskupených podľa Podstatné menáalebo Podstatné mená B by mala byťzoskupených podľa Podstatné mená- Definovať "Dieťa musí mať rodič" obmedzenia s typom detskej substantívum B, materská typu substantívum A a presadzovanie, ako je varoval.

Poznámka

To znamená, že ak dieťa existuje, mal by mať rodičia určitého typu. Ak nie, budete na to upozornení.

o Podstatné mená by mala byťrozložený do Podstatné mená B- Definovať "Parent musí mať dieťa" obmedzenia s materskou typom substantívum A, typ detskej substantívum B a presadzovanie, ako je varoval.

Poznámka

To znamená, že ak rodič existuje, mal by mať deti určitého typu. Ak nie, budete na to upozornení.

o Podstatné mená musí byťrozložený do Podstatné mená B- Definujte "rodič musí mať dieťa" obmedzenia s materskou typom substantívum A, typ detskej substantívum B a vymáhanie, aké presadzovaná.

Poznámka

To znamená, že ak rodič existuje, musí mať deti určitého typu. Ak nie, budete mať chybu.

o Podstatné mená musí byťzoskupených podľa Podstatné mená B- Definovať "Dieťa musí mať rodič" obmedzenia s typom detskej substantívum A, materská typu substantívum B a vymáhanie, aké presadzovaná.

Poznámka

To znamená, že ak dieťa existuje, musí mať rodičia určitého typu. Ak nie, dostanete chybu.

· Obmedzenie topológie;

o Podstatné mená môže byť sloveso Podstatné mená B- Definovať dve (2) "Pripojenie musí byť pripojený k zložka" obmedzenia. Prvá bytosť sa zdrojom koncom typu pripojenia slovesopripojené k podstatnému menu A schválenie komponentu a presadzovanie nastavená na vymáhané. Druhá bytosť s drezu koncom typu pripojenia slovesopripojené k Noun schválenie komponentu, B a výkonu nastaveným na vymáhané.

Poznámka

To znamená, že v prípade, že existuje spojenie, musí sa spojiť súčasti určitých typov. Ak nie, budete mať chybu. Celkovo tým je zaistené, že tieto zložky môžu stále existujú, a nesmie byť pripojené k sebe navzájom. Avšak v prípade, že sú pripojené, je nutné použiť spoje správneho typu.

o Podstatné mená by mala byť sloveso Podstatné mená B- Definovať dve (2) "Component musí byť pripojený k pripojenie" obmedzenia. Prvý bol s Noun Typ komponentov pripojený k zdrojovému koncu slovesoTyp pripojenia a presadzovanie set do varoval. Druhá bytosť s Noun komponentu B pripojená k umývadlu koncu slovesoTyp pripojenia a presadzovanie set do varoval. Okrem toho, definovať dve (2) "Pripojenie musí byť pripojený k zložka" obmedzenia. Prvá bytosť sa zdrojom koncom typu pripojenia slovesopripojené k podstatnému menu A schválenie komponentu a presadzovanie nastavená na vymáhané. Druhá bytosť s drezu koncom typu pripojenia slovesopripojené k Noun schválenie komponentu, B a výkonu nastaveným na vymáhané.

Poznámka

To znamená, že ak existujú súčasti oboch typov, by mali byť pripojené na pripojenie určitého druhu. Ak nie, budete na to upozornení. Okrem toho, to znamená, že v prípade, že existuje spojenie, musí byť pripojený k komponentov daného typu. Ak nie, budete mať chybu. Celkovo toto je zaistené, že ak existujú zložky týchto typov, získate varovanie v prípade, že nie sú pripojené k sebe navzájom.

o Podstatné mená musí byť sloveso Podstatné mená B- Definovať dve (2) "Component musí byť pripojený k pripojenie" obmedzenia. Prvý bol s Noun Typ komponentov pripojený k zdrojovému koncu slovesoTyp pripojenia a vymáhanie nastavená na vymáhané. Druhá bytosť s Noun komponentu B pripojená k umývadlu koncu slovesoTyp pripojenia a vymáhanie nastavená na vymáhané. Okrem toho, definovať dve (2) "Pripojenie musí byť pripojený k zložka" obmedzenia. Prvá bytosť sa zdrojom koncom typu pripojenia slovesopripojené k podstatnému menu A schválenie komponentu a presadzovanie nastavená na vymáhané. Druhá bytosť s drezu koncom typu pripojenia slovesopripojené k Noun schválenie komponentu, B a výkonu nastaveným na vymáhané.

Poznámka

To znamená, že ak existujú súčasti oboch typov, musí byť pripojená na pripojenie určitého druhu. Ak nie, budete mať chybu. Okrem toho, to znamená, že v prípade, že existuje spojenie, musí byť pripojený k komponentov daného typu. Ak nie, budete mať chybu. Celkovo toto je zaistené, že ak existujú zložky týchto typov, dostaneme chyby, ak nie sú navzájom spojené.

Ak chcete definovať obmedzenia

1. Skontrolujte, či máte ABACUS súborotvorené a Okno Prieskumníkazobrazené.

2. Vo stromu explorer expandovať Druhy | Component Druhyalebo rozšíriť Druhy | Typy pripojenia.

3. Kliknite pravým tlačidlom myšitypu zložka alebo typ pripojenia a vyberte Pridať Väzba.

Pridanie obmedzenia

Ak chcete definovať hierarchie obmedzenia, kedy musí rodič mať konkrétne dieťa

4. Na Pridať VäzbaOkno zaškrtnúť Vytvorenie CONSTRAINTcheckbox v rámci Rodič musí mať dieťa Väzbaoblasti.

5. Vyberte schválenie komponentuz rozbaľovacieho zoznamu, ktorý chcete označiť ako dieťa komponentu, vybrané v kroku 3.

Poznámka

Ak je už aktivovaný "materský Must Have Child" obmedzenia definované pre materskú schválenie komponentu a ďalšie dieťa schválenie komponentu, potom sa táto nová obmedzenia bude kvalifikovaná ako "a". To je typ, musí byť rodič typu dieťaťu atyp dieťa B, na akejkoľvek úrovni vymáhanie (napr Disabled varoval, alebo Vynútená - pozri krok 7) je stanovená pre každú obmedzenia.

6. Voliteľne možno definovať minimálny a maximálny počet priečinkov komponentu, spresnil, že musí byť deti komponentu klepli pravým tlačidlom myši v kroku 3.

7. Vyberte, či chcete, aby obmedzenia Zakázané, Varovalalebo Vynútený.

Poznámka

Telesne obmedzenia budú ignorované z obmedzovačmi validácie, bude varoval obmedzenia produkovať varovanie v okne Overenie, ak sú zistené a uplatňovanie obmedzení bude vyrábať chyba v okne Overenie, ak sú zistené. Ďalej, všetky chyby musia byť vyriešené pred prijatím Podnik Server projekt môže byť spáchaný.

8. Kliknite na tlačidlo OK.

Poznámka

Obmedzenia sa zobrazí v strome explorer podľa typu konštrukčnej klepli pravým tlačidlom myši v kroku 3. Šípka označuje smer obmedzenia, a v tomto prípade bude smerovať nadol a doprava. Visiaci zámok je sfarbený podľa toho, či obmedzenie je Disabled (sivá), Varoval (žltá) alebo vykonané (červená).

Rodič musí mať dieťa varoval obmedzenia

Ak chcete definovať hierarchie obmedzenia, kedy musí dieťa mať konkrétny rodičia

4. Na Pridať VäzbaOkno zaškrtnúť Vytvorenie CONSTRAINTcheckbox v rámci Dieťa musí mať Parent Väzbaoblasti.

5. Vyberte schválenie komponentuz rozbaľovacieho zoznamu, ktorý chcete označiť ako rodič komponentu klepli pravým tlačidlom myši v kroku 3.

Poznámka

Ak je už aktivovaný "Dieťa musí mať materskú" obmedzenia definované pre daný typ detskej komponentov a ďalšiu materskú schválenie komponentu, potom sa táto nová obmedzenia bude posudzovaná ako "alebo". To je typ, musí byť dieťa rodič typu A aleborodič typu B, a úroveň výkonu (napr upozornení alebo vykonané - viď ďalší krok) by mala byť rovnaká inak vynútené obmedzenie bude vždy prednosť varoval ty.

6. Vyberte, či chcete, aby obmedzenia Zakázané, Varovalalebo Vynútený.

Poznámka

Telesne obmedzenia budú ignorované z obmedzovačmi validácie, bude varoval obmedzenia produkovať varovanie v okne Overenie, ak sú zistené a uplatňovanie obmedzení bude vyrábať chyba v okne Overenie, ak sú zistené. Ďalej, všetky chyby musia byť vyriešené pred prijatím Podnik Server projekt môže byť spáchaný.

7. Kliknite na tlačidlo OK.

Poznámka

Obmedzenia sa zobrazí v zobrazení Prieskumník podľa typu konštrukčnej zvoleného v kroku 5. Šípka označuje smer obmedzenia, a v tomto prípade bude ukazovať nahor a doľava. Visiaci zámok je sfarbený podľa toho, či obmedzenie je Disabled (sivá), Varoval (žltá) alebo vykonané (červená).

Dieťa musí mať materskú varoval obmedzenia

Pre definovanie topológie obmedzenia, pokiaľ musí byť súčasť pripojená k konkrétne pripojenie

4. Na Pridať VäzbaOkno zaškrtnúť Vytvorenie CONSTRAINTcheckbox v rámci Súčasť musí byť priložená Väzbaoblasti.

5. Vyberte Typ pripojeniaz rozbaľovacieho zoznamu, ktorý chcete označiť ako priloženého pripojenie typu konštrukčnej klepli pravým tlačidlom myši v kroku 3 (alebo vyberte schválenie komponentuz rozbaľovacieho zoznamu, ktorý chcete označiť ako pripojené komponenty, ak v kroku 3 ste klikli pravým tlačidlom na typ pripojenia.)

Poznámka

Ak je už aktivovaný "Component musí byť pripojený" obmedzenie definovaná pre daný typ komponentu a iným typom pripojenia potom bude táto nová obmedzenia byť zaobchádzané ako "a". To znamená, musí byť schválenie komponentu pripojená k typu pripojenia aTyp pripojenia B, na akejkoľvek úrovni vymáhanie (napr Disabled varoval, alebo Vynútená - pozri krok 7) je stanovená pre každú obmedzenia.

6. Voliteľne si môžete vybrať pripojenie rolektoré chcete pridať do väzby. Svoliť konkrétny role (tj. buď Source alebo Sink) z rozbaľovacieho zoznamu.

7. Vyberte, či chcete, aby obmedzenia Zakázané, Varovalalebo Vynútený.

Poznámka

Telesne obmedzenia budú ignorované z obmedzovačmi validácie, bude varoval obmedzenia produkovať varovanie v okne Overenie, ak sú zistené a uplatňovanie obmedzení bude vyrábať chyba v okne Overenie, ak sú zistené. Ďalej, všetky chyby musia byť vyriešené pred prijatím Podnik Server projekt môže byť spáchaný.

8. Kliknite na tlačidlo OK.

Pre definovanie topológie obmedzenia, pokiaľ musí byť spojenie pripojená k špecifickej komponenty

4. Na Pridať VäzbaOkno zaškrtnúť Vytvorenie CONSTRAINTcheckbox v rámci Pripojenie musí byť priložená s obmedzujúcimi podmienkamioblasti.

5. Vyberte Typ pripojeniaz rozbaľovacieho zoznamu, ktorý chcete označiť ako priloženého pripojenie typu konštrukčnej klepli pravým tlačidlom myši v kroku 3 (alebo vyberte schválenie komponentuz rozbaľovacieho zoznamu, ktorý chcete označiť ako pripojené komponenty, ak v kroku 3 ste klikli pravým tlačidlom na typ pripojenia.)

Poznámka

Ak je už aktivovaný "Pripojenie musí byť pripojený" obmedzenie definovaná pre typ pripojenia a iného typu komponentu za použitia rovnaké pripojenie role(tj. buď Source alebo Sink), potom sa táto nová obmedzenia bude zaobchádzané ako "OR". To je nutné uviesť druh spojenia pripojená k priečinku typu A alebokomponentu B, a úroveň výkonu (napr upozornení alebo vykonané - pozri krok 7), by mala byť rovnaká inak vynútené obmedzenie bude vždy prednosť varoval ty. Všimnite si tiež, že ak existuje viac obmedzení, ktoré majú pripojenie rolešpecifikovaný ako "Každý" (na rozdiel od špecificky Source alebo drez), potom oba konce spojenie musí byť pripojený k jednému z typov zložiek špecifikovaných v obmedzení.

6. Voliteľne si môžete vybrať pripojenie rolektoré chcete pridať do väzby. Svoliť konkrétny role (tj. buď Zdroj alebo Sink) z rozbaľovacieho zoznamu.

Poznámka

Buď Source alebo Sink úloha musí byť výslovne vybraných pre Príloha stĺpec so skladom, ktoré majú byť zobrazené v komponente katalóg .

7. Vyberte, či chcete, aby obmedzenia Zakázané, Varovalalebo Vynútený.

Poznámka

Telesne obmedzenia budú ignorované z obmedzovačmi validácie, bude varoval obmedzenia produkovať varovanie v okne Overenie, ak sú zistené a uplatňovanie obmedzení bude vyrábať chyba v okne Overenie, ak sú zistené. Ďalej, všetky chyby musia byť vyriešené pred prijatím Podnik Server projekt môže byť spáchaný.

8. Kliknite na tlačidlo OK.

Reálny čas model checking a nátlakvalidácia

ABacus zahŕňareal-time model Kontrola a Overenie funkcie na okamžite zobrazenie účinky danej operácie bude mať užívateľ na varovania a chyby s aktuálnym projektu, v dôsledku akéhokoľvek hierarchie a topológia obmedzenia, ktoré boli definované. Je potrebné poznamenať, že všetky chyby musia byť vyriešené pred prijatím Podnik Server projekt môže byť spáchaný.

Funkcia validácia obmedzenia v reálnom čase je najviac viditeľné pri vyplnení s diagramy alebo priamo v okne Prieskumníka. Najmä počas nasledujúcich operácií, sú uvedené pokyny pomocou farebných svetiel, pokiaľ ide o efekt operácia bude mať na varovania a chyby s aktuálnym projektu;

1. Pri preťahovaní prvkov na alebo okolo diagrame farby materskej spoločnosti (alebo pripájanie) komponenty (ak existuje) border budú zafarbené podľa schémy popísaného nižšie.

2. Pri pripojení komponentov pomocou pravým tlačidlom myši ťahať | Pripojte k rysu zoznam dostupných typov pripojenia je sfarbená podľa schémy popísaného nižšie.

3. Pri pripájaní súčasti na diagrame pomocou režimu Connector kurzor sa bude meniť farby podľa schémy popísaného nižšie.

4. Pri pridávaní čiastkové komponenty sa zoznam dostupných typov súčasťou je sfarbený podľa schémy popísaného nižšie.

Všeobecne tieto farby sú použité pre indikáciu účinkov užívateľ operácia bude mať na varovanie a chýb s aktuálnym projektu;

Čerň : Žiaden vplyv na varovanie alebo chyby.

Green : Operácia je výslovne v súlade sdefinované hierarchie a topológia obmedzenia pre projekt.

Red : Operácia je výslovne v rozpore sdefinované hierarchie a topológia obmedzenia pre projekt, a bude mať za následok varovanie a / alebo chyby.

Súvislosti model checking a nátlakvalidácia

ABACUS zahŕňa Funkcie Validation zobraziť všetky varovania a chyby s aktuálnym projektu, kvôli akýchkoľvek obmedzení, ktoré boli definované. Je potrebné poznamenať, že všetky chyby musia byť vyriešené pred prijatím Podnik Server projekt môže byť spáchaný.

Poznámka

Overenie musí byť ručne spustiť pomocou "Potvrdiť / kontrolné podmienky projekt" tlačidlo na Hlavný panel nástrojov , Okno Overenie je v predvolenom nastavení skrytýale sa objaví, keď je tlačidlo na paneli nástrojov kliknutí, Vidieť Prispôsobenie rozhrania na to, ako ho zobraziť a prípadne nechať trvale zobrazené. Tiež môžete poklepaním na ľubovoľný riadok v okne Overenie na "skok" k príslušnej prvok v projekte.

Overenie okno

Východiskové stĺpce okná Overenie sú popísané nižšie;

Varovanie alebo Chyba: Tento stĺpec zobrazí ikonu, či je porušenie je varovanie (žltý trojuholník s výkričníkom), alebo chyby (červené koliesko s krížikom).

Číslo: Tento stĺpec zobrazuje číslo narušenia.

Poznámka

Iba 200 porušení sú zobrazené v čase, a ak existuje viac ako 200 porušení v projekte Štart, Predchádzajúce, Ďalšie a koniec rady navigátory v pravom hornom rohu okna možno použiť na prezeranie ďalšie porušovanie ľudských práv.

Popis: Toto je úplný opis porušenia, vrátane osobou a Obmedzenie sa týka.

Bytosť: Tento stĺpec zobrazuje Subjekt znepokojuje porušenie.

Druh: Tento stĺpec zobrazuje typ prvku pre osoby.

Staviteľstvo: Tento stĺpec zobrazuje architektúru, v ktorej k porušeniu došlo.

Zistené: Tento stĺpec zobrazuje čas, ktorý bol detekovaný porušenia.

Tip

Je užitočné Usporiadať zostupne podľa detekovaného kolóny (ako je uvedené v dialógu vyššie), aby zabezpečili, že najnovšie porušenie sa objaví v "top" zoznamu.

Existuje niekoľko možností užívateľovi zmeniť správanie validácie pozadie modelu. Napríklad to zmeniť farby použité pre porušenie podmienok na inú hodnotu ako predvolený Red, Kliknite na tlačidlo na Nástroje | Možnosti ... potom ísť do Overeniekarta, a nastaviť farby pomocou Zmena tlačidla.

Overenie Možnosti

Ak chcete manuálne overiť obmedzenia

1. Kliknite pravým tlačidlom myšina Architektúryuzol na ľubovoľné počítačovej architektúre alebo kdekoľvek buď Komponentyalebo Pripojeniečasť zobrazenie prieskumníka a zvoľte Skontrolujte Obmedzenie.

Overiť obmedzenia

2. Kliknite na tlačidlo PodrobnostiTlačidlo na Upozornenieokná vidieť, kde architektúra porušuje akékoľvek obmedzenia, ktoré boli definované.

Poznámka

Priestupky sú zobrazené iba u tých obmedzení, ktoré boli stanovené na Varoval alebo vykonať. Navyše znenie varovanie bude zahŕňať "mal by" v prípade, že obmedzenie bolo len varovanie, alebo "musí", ak to bolo presadené.

3. Kliknite na tlačidlo OK.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne


Odstránenie komponenty alebo spojenie

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Odstránenie komponenty alebo spojenie

Odoslať pripomienky na túto tému.

Ak chcete odstrániť priečinok alebo spojenie

1. Kliknite pravým tlačidlom myšisúčasti alebo pripojenie.

2. Vybrať Zmazať.

Pozor

ABACUS vás bude varovať, ktoré pohľady budú ovplyvnené vypustením a požiada vás na potvrdenie odstránenia. To je preto, že prvky môžu existovať na mnohých diagramy a oplatí sa skontrolovať, čo navrhovanej vypustenie bude mať vplyv.

Tip

Ak odstránite priečinok, budú odstránené tiež všetky jeho čiastkových komponentov. Môžete sa rozhodnúť odstrániť interné a externé pripojenie k súčasti. Ak sa rozhodnete ich odstrániť, pripojenie je to pripojený na zostanú, ale budú už nie byť pripojený. Všetky súčasti a spoje sú zvláštne Druh , Zmazanie komponentný / pripojenie nemá žiadny vplyv na typu (v typoch vetva stromu). Podobne, v prípade, že zložka a / alebo spojenie má Štandardné pridelený, vymazanie nebude mať žiadny vplyv na majstra v odborových noriem.

Pozri tiež

Naplnenie vašej architektúry - Prehľad


Diagram Uhly pohľadu

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Diagram Uhly pohľadu

Odoslať pripomienky na túto tému.

The názoryfunkcia zaisťuje, že zložky a spojov, ktoré sa pridávajú do diagramu, musí mať typ združenia bolo definované skôr, než môžu byť pridané do diagramu. Táto funkcia umožňuje obmedzenie typov grafov, ktoré možno čerpať obmedzením tvary a konektory, ktoré sú spojené s komponentmi a PripojenieExistujúce priamo vo Vašom architektúry.

Povolenie alebo zakázanie Presadzovanie diagramu názory

Schopnosť presadiť diagram názory je automaticky v predvolenom nastavení povolená. Ak chcete zakázať / povoliť túto funkciu, kliknite na Nástroje | Možnosti ...| DiagramKarta a zrušte výber / výber Vynútiť diagram Uhly pohľaduzaškrtnutie políčka podľa toho.

Poznámka

Ak nevidíte "Vynútiť diagram Uhly pohľadu"Možnosť na karte Diagram potom nemáte Návrhár doplnok a možnosť je v predvolenom nastavení.

Vytvorenie vykonateľný diagram hľadisko

1. Skontrolujte, či máte ABACUS súbor otvorené s cestovateľZobrazí pohľad.

2. V zobrazení Prieskumníka kliknite pravým tlačidlom myši na Pohľadbodsa kliknite na Vytvoriť Diagram Viewpoint

3. Diagram Viewpointsa zobrazí okno.

4. Priradiť zodpovedajúce meno na diagram hľadiskoa vedomie, že hľadisko je uložená pod Uhly pohľadučasť prieskumník.

5. Diagram Viewpointsa zobrazí okno.

6. Teraz kliknite a presuňte príslušné typy komponentov a typy spojenia vo vašich architektúrach Na tvary Viewpoint chceš. Component typyje potrebné pretiahnuťtvarv tvaryKarta, zatiaľ čo typy pripojeniaje potrebné pretiahnuť jeden z tvarov k 5 riadok štýluv konektoryTab.

7. Ak chcete uložiť diagram hľadiskoste vytvorili, kliknite na [image] v pravom hornom rohu Diagram Viewpointokno.

Poznámka

diagram hľadiskomôžu byť editované kliknutím pravým tlačidlom myši na strane hľadisko a výberu Otvorenéalebo poklepaním hľadisko.

Synchonising aktualizované stanovisko s diagramami

1. Skontrolujte, či máte ABACUS súbor otvorený.

2. Buď kliknite pravým tlačidlom na pohľad vo Cestovateľ Okno pod Meta-Model | Uhly pohľadua vyberte Sync Diagram mapovanie ...

- Alebo -

3. Zavrieť otvorené a aktualizované hľadisko okno a vyberte Áno,v Synchronizácia sa Viewpointdialóg, ktorý sa zobrazí.

4. Viewpoint Synchronizáciasa zobrazí dialógové okno, ako je uvedené nižšie.

Checkboxes

· Pridať chýbajúci mapovanie- Akýkoľvek nový tvar (komponentu), alebo konektor (typu pripojenia), asociácií, ktoré boli pridané k pohľadubude pridaný do Zodpovedajúce diagrams (tj. ichšablónas)že sú spojené s hľadiska.

· Aktualizáciu existujúcichMapovanie- Všetky aktualizované aspekty súčasného tvaru (až komponentu) alebo konektor (na type pripojenia) asociácie pre hľadisko(napr farby, fonty) budú aktualizované v Zodpovedajúce diagrams (tj. ichšablónas)že sú spojené s hľadiska.

· Odstrániť ExtraMapovanie- Akékoľvek ďalšie tvar (komponentu), alebo konektor (typu pripojenia), asociácií, ktoré boli pridané k diagramy (tj ich šablóny), ale nie sú v hľadiskobudú odstránené z Zodpovedajúce diagrams (tj. ichšablónas)že sú spojené s hľadiska.

· Prepísať Miestne nastavenia pre pridané alebo aktualizované mapovanie (Differences Only)- Všetky aktualizované aspekty súčasného tvaru (až komponentu) alebo konektor (na type pripojenia) asociácie pre hľadisko(napr farby, fonty) sa použije na zodpovedajúce prvky na obrázkoch, ktoré sú spojené s pohľadu.Sú použité iba aktualizovanú databázu "rozdiely" uskutočnenej pohľadu, takže všetky existujúce miestne nastavenia v diagrame, ktoré neboli aktualizované v pohľade zostane bezo zmeny.

· [image] Anotácia – Ako je uvedené vyššie, ale špeciálne pre poznámky.

Pozri tiež

Nástroje na kreslenie | Naplnenie vašej architektúry | Analýza Vaše architektúra


Kreslenie Funkcia Tool

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Kreslenie Funkcia Tool

Odoslať pripomienky na túto tému.

Nástroje na kreslenie podporuje množstvo funkcií pre kreslenie.

Zväčšenie

Mierka diagramu je možné zmeniť pomocou funkcie zoom.

Ak chcete zmenšiť mierku alebo "priblíženie"

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Press Ctrla "=" kľúč.

- Alebo -

2. Vyberte PriblížiťTlačidlo na Diagrampanel nástrojov.

- Alebo -

2. Press Ctrla otáčaním kolieska myši vpred, Poznámka: V tomto režime sa plátno priblíži k miestu, kde je myš umiestnená nad plátnom.

Ak chcete zvýšiť mierka alebo "oddialiť"

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Press Ctrla "-" kľúč.

- Alebo -

2. Vyberte OddialiťTlačidlo na Diagrampanel nástrojov.

- Alebo -

2. Press Ctrla otáčaním kolieska myši zaostalý, Poznámka: V tomto režime sa plátno priblíži von z miesta, kde je myš umiestnená nad plátnom.

Auto-layout

Usporiadanie zložiek v diagrame možno upraviť automaticky.

Ak chcete rozvrhnutie všetci komponenty on schéma

1. Colizovať Layout DiagramTlačidlo na paneli nástrojov Diagram.

2. Vybraťbuď Radiálne Layout alebo Layout Grid.

Poznámka

Rozloženie Radial bude používať to, čo sa nazýva "vyššia-réžia", algoritmus tak, že pripojené zariadenia sú zostavené dohromady, zatiaľ čo nesúvisiace komponenty sú nútení od seba. Rozloženie Grid bude použiť pevnú šírku a výšku riadkovanie algoritmus. To za prvé umožňuje užívateľovi zvoliť celkovej schéma pomer strán (napríklad 16: 9, A4 (výšku), Letter (šírku)), a potom je vzdialenosť po stranách a medzi stĺpcov a riadkov, ako je uvedené nižšie.S mriežkou rozvrhnutie prípadné spojenie medzi zložkami nemajú vplyv na rozloženie, ako to jednoducho usporiada komponenty abecedne (podľa názvu) zhora-vľavo na dolnom rohu plátna. S oboma algoritmy voľných tvarov nie sú presunuté.

Ak chcete rozvrhnutie deti komponenty v jednej materskej On schéma

1. Kliknite pravým tlačidlom myšisúčiastka na vysokej úrovni, ktorých deti si prajete automatické rozloženie.

2. Vybrať Rozvrhnutie Deti.

Poznámka

V predvolenom nastavení sa používa iba rozvrhnutie algoritmus Radial.

Zmena prvku Estetika Ako Farebný, Transparentnosť, Tiene a rotácie

Všetky prvky majú estetiku diagram, ktorý môže byť manipulovaná, ako je požadované. V prípade pridružených tvarov, tieto aspekty môžu byť nastavené podľa typua vo väčšine prípadov aj každú inštanciu, V prípade voľných tvarov, tieto vlastnosti môžu byť nastavené každú inštanciuna plátne.

Poznámka

Akékoľvek za aspektov, napríklad, ktoré boli stanovené pre pridružené tvary budú "prepísané" ak je rovnaký pomer sa zmení pre príslušný typ.

Ak chcete zmeniť farbu pridruženého tvaru alebo od ruky tvar

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo netradičný tvar na plátne.

3. Vybrať Change Color.

4. Vyberte Pevné Farbaprepínač (v prípade potreby).

5. Vyberte si Základné Farba alebo definovať vlastné Farba v dialógovom okne a kliknite na tlačidlo OK.

- Alebo -

4. Vyberte Gradientprepínač (v prípade potreby).

5. Vyberte si buď horizontálne, vertikálne, vpred alebo vzad Diagonal Diagonal k prechodu smeru v rozbaľovacej a kliknite na tlačidlo OK.

6. Vyberte si Základné Farba alebo definovať vlastné Farba v dialógu pre Začiatoka Konieca kliknite na tlačidlo OK.

Poznámka

ABACUS bude farba popredia tvaru, ak;
a) sa jedná o "jednoduché" tvar s jedným základným grafickom prvku (napr kruh, obdĺžnik, mnohouholník atď), alebo
b) sa jedná o "komplexné" tvar s viac podkladových subshapes, ktoré sú všetky rovnaké farby / sklon ako navzájom alebo subshapes majú LockScale = TRUE set.
Ak vyššie uvedené podmienky nie sú splnené, potom pozadia tvaru je sfarbený.

Ak chcete nastaviť farbu pridruženého tvaru podľa nehnuteľnosti

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka(NOT na kresliace plátno).

3. Vybrať Change Color.

4. Vyberte Použitie vlastnosťprepínač.

5. Vyberte vlastnosť kliknutím na tlačidlo "..." napravo od textového poľa.

6. Vyberte Sortiment prepínač.

7. Nastavte Mina Maxhodnoty, ako je požadované. Poznámka: akákoľvek hodnota nižšia ako minimálna hodnota sa zobrazí ako farba Min a ľubovoľná hodnota vyššia ako maximálna sa zobrazí ako Max farbu. Tiež pri použití Boolean, Zoznam alebo Dátum / Čas vlastnosti hodnoty sú prevedené na index takto; Boolean (False = 0, True = 1), zoznam (celé číslo vale 1 až N pre každý platnú hodnotu vo svojom vzostupnom poradí uvedenom v poli Units) a / času (počet dní od 1. januára 1900 Dátum - vrátane desatinných miest hodiny, minúty, sekundy časti - a ak je dátum pre-1990 je záporné číslo).

8. Vyberte si Základné Farba alebo definovať vlastné Farba v dialógu pre Mina Maxa kliknite na tlačidlo OK.

Tip

Ak Green (RGB - 128,255,0) je vybraný ako farbu Min a Red (RGB - 255,0,0) je vybraný ako Max farba pre vlastnosť s hodnotou rozsahom 1na 4potom hodnota 1sa zobrazí ako Green, Hodnota 2ako Yellow, 3ako Pomaranča 4ako Red.

Alternatívne, pre rad vlastností 1na 3Hodnota 1bude as Green, Hodnota 2ako Ambera 3ako Redaka "Dopravné Lights" alebo stav RAG.

Pre rozsah vlastností od 1 do 5, pokiaľ Modrá (RGB - 0,0,255) je vybraný ako farbu Min a Red (RGB - 255,0,0) je vybraný ako Max farby hodnota 1 bude as Modrá, Hodnota 2 as Aqua, Hodnota 3 as Green, Hodnota 4, as Yellow a hodnota 5 as Red.

Pre rozsah vlastností od 1 do 6, pokiaľ Fialka (RGB - 255,0,255) je vybraný ako farbu Min a Red (RGB - 255,0,0) je vybraný ako Max farby hodnota 1 bude as Fialka, Hodnota 2 as Modrá, Hodnota 3 as Aqua, Hodnota 4, as Green, Hodnota 5 as Yellow a hodnota 6 as Red.

A konečne, pre rad vlastností 1 až 7 hodnota 1 bude as Fialka, Hodnota 2 as Tmavomodrá, Hodnota 3 as Svetlomodrá, Hodnota 4, as Modrá Zelená, Hodnota 5 as Green, Hodnota 6 as Amber a hodnotu 7 as Red

Poznámka

Pozri poznámku vyššie na popredí proti pozadí sfarbenie.

- Alebo -

7. Vyberte Konkrétne hodnotyprepínač.

8. Kliknite na tlačidlo Upraviť farbyTlačidlo.

9. Vyberte každú hodnotu v poradí a kliknite na tlačidlo Set Colournastaviť konkrétne farby pre každú hodnotu.

Poznámka

Rozsah hodnôt pre prvkov prítomných v diagrame budú predbežne naplnená.

10. Ak chcete pridať ďalšie farby hodnotu tým, ktorí pre-obývaný (napríklad po rozsah majetok bol prekonfigurovanie) Kliknite na tlačidlo Pridať hodnotu.

Ak chcete zmeniť priehľadnosť farieb pridružené tvaru alebo od ruky tvar

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo netradičný tvar na plátne.

3. Vybrať Change Color.

4. V paneli Priehľadnosť nastaviť hornú posuvník na požadovanú transparentnosť pre základné farby.

5. V prípade, že Gradient alebo Používanie volieb vlastníctva sú používané, v paneli Priehľadnosť nastavte spodný posuvník na požadovanú transparentnosť pre druhú farbou.

6. Kliknite na tlačidlo OK.

Ukázať tienepre všetky spojená tvary v diagrame

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v KomponentyZáložka okne vzorkovníka.

3. Vybrať Pridať Tiene.

K vykazujú tieň na tvar súčasť alebo netradičný tvar

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. DopravaClickna komponenty alebo voľných tvarov na plátne.

3. Vybrať Pridať Tiene.

Ak chcete otočiť tvary súčasti a voľné tvary podobe, v diagramoch

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Vyberte tvar komponentu alebo netradičný tvar na plátno, ktorú chcete otočiť.

3. Kliknite pravým tlačidlom myšio tvare a vyberte Otočiťa potom vyberte príslušnú uhol, ktorý chcete otočiť tvar pomocou.

Meniace sa Element Anotácia a Voľné textové popisky

Všetky prvky majú diagram anotácie ktorá môže byť manipulovaná, ako je požadované. V prípade pridružených tvarov, tieto aspekty môžu byť nastavené podľa typua vo väčšine prípadov aj každú inštanciu, V prípade voľných tvarova konektorySatextové popisky môže byť nastavené každú inštanciuna plátne.Osem (8) rôzne typy anotácií môžu byť zobrazené na diagram prvky (meno, typ, Vlastnosť Hodnota, Nehnuteľnosť Marker, stavebné diely, Deti (iba pre komponenty), normy a časových pečiatok (Vytvorené, upravený atď)) vo dvadsať päť (25) rôzne polohy (napr Centre - Mimo Top, Inside vľavo - centrum, pravé vonkajšie - vonkajšej strane dna).

Poznámka

Akékoľvek za aspektov, napríklad, ktoré boli stanovené pre pridružené tvary budú "prepísané" ak je rovnaký pomer sa zmení pre príslušný typ.Okrem toho, ak 2 alebo viac anotácia na rovnakej pozícii iba jediná písma, štýl písma, farbu písma a veľkosť môže byť použitý a oddeľovač (napr čiarka, medzera, nový riadok) musí byť vybraný.

Ukázať názov alebo typ pre pridruženú komponentu alebo pripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo konektor na plátne.

3. Vybrať Anotácia.

Poznámka

Pre individuálne spojená tvaru alebo konektora na plátne, budete musieť vybrať Prepísať Stencil anotáciepolíčko prvýkrát.

4. Vyberte nové anotácie v paneli nástrojov a vyberte Názov alebo Druh.

5. V dialógovom okne, ktoré sa objavia vyberte možnosti zobrazenia, ktoré sú žiaduce, vrátane držiakov a štýl písma, písma, farbu písma a veľkosť. Tiež, vyberte možnosti rozvrhnutie, ktoré sú žiaduce, vrátane vodorovného a zvislého nastavenia (tj poloha anotácie) a uhla (tj rotácie). Vybrať OK.

Ak chcete zobraziť nehnuteľnosti hodnota pre pridruženú komponentu alebo pripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo konektor na plátne.

3. Vybrať Anotácia.

Poznámka

Pre individuálne spojená tvaru alebo konektora na plátne, budete musieť vybrať Prepísať Stencil anotáciepolíčko prvýkrát.

4. Vyberte nové anotácie v paneli nástrojov a vyberte Vlastnosť Hodnota.

5. V dialógovom okne, ktoré sa objavia vyberte vlastnosť kliknutím objektu: tlačidlo '...' a výberom vlastnosť v dialógovom okne vyberte vlastnosťa vyberte OK. Vyberte možnosti zobrazenia, ktoré sú žiaduce, vrátane držiakov a štýl písma, písma, farbu písma a veľkosť. Tiež, vyberte možnosti rozvrhnutie, ktoré sú žiaduce, vrátane vodorovného a zvislého nastavenia (tj poloha anotácie) a uhla (tj rotácie). Vybrať OK.

Ak chcete zobraziť nehnuteľnosti fix pre pridruženú komponentu alebo pripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo konektor na plátne.

3. Vybrať Anotácia.

Poznámka

Pre individuálne spojená tvaru alebo konektora na plátne, budete musieť vybrať Prepísať Stencil anotáciepolíčko prvýkrát.

4. Vyberte nové anotácie v paneli nástrojov a vyberte Nehnuteľnosť Marker.

5. V dialógovom okne, ktoré sa objavia vyberte vlastnosť kliknutím objektu: tlačidlo '...' a výberom vlastnosť v dialógovom okne vyberte vlastnosťa vyberte OK. Nastavte polomer značky v obrazových bodoch a spôsobu farbenia na oboch farieb rozsahom alebo Colour majetkom a nastaviť priradenie farby. Tiež, vyberte možnosti rozvrhnutie, ktoré sú žiaduce, vrátane vodorovného a zvislého nastavenia (tj poloha anotácie) a uhla (tj rotácie). Vybrať OK.

Ukázať pripojené komponenty pre pridruženú komponentu alebo pripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo konektor na plátne.

3. Vybrať Anotácia.

Poznámka

Pre individuálne spojená tvaru alebo konektora na plátne, budete musieť vybrať Prepísať Stencil anotáciepolíčko prvýkrát.

4. Vyberte nové anotácie v paneli nástrojov a vyberte Komponenty Priložené.

5. V dialógovom okne, ktoré sa objaví, vyberte pre pridružené komponenty pripojené komponentu kliknutím na tlačidlo 'pripevnené: ...' a výber typu komponentu v dialógovom okne Set Component Typea vyberte OK. Vyberte pripojený typ pripojenia kliknutím na pripojený cez: "..." tlačidlo a zvolíte typ spojenia v dialógovom okne Nastavenie typu pripojeniaa vyberte OK.Pre spojených pripojení vyberte koniec pripojenie výberom zdroja alebo drez z Upínanie: rozbaľovacom menu. Pre obidve pridružené komponenty a pripojenie vybrať možnosti zobrazenia, ktoré sú žiaduce, vrátane držiakov a štýl písma, písma, farbu písma a veľkosť. Tiež, vyberte možnosti rozvrhnutie, ktoré sú žiaduce, vrátane vodorovného a zvislého nastavenia (tj poloha anotácie) a uhla (tj rotácie). Vybrať OK.

Ukázať deti pre pridružené komponenty

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v KomponentyZáložka okne vzorkovníka, alebo spojený tvar na plátne.

3. Vybrať Anotácia.

Poznámka

Pre individuálne pridružené tvaru na plátne, budete musieť vybrať Prepísať Stencil anotáciepolíčko prvýkrát.

4. Vyberte nové anotácie v paneli nástrojov a vyberte Deti.

5. V dialógovom okne, ktoré sa objavia vyberte možnosti zobrazenia, ktoré sú žiaduce, vrátane držiakov a štýl písma, písma, farbu písma a veľkosť. Tiež, vyberte možnosti rozvrhnutie, ktoré sú žiaduce, vrátane vodorovného a zvislého nastavenia (tj poloha anotácie) a uhla (tj rotácie). Vybrať OK.

Ukázať normy pre pridruženú komponentu alebo pripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo konektor na plátne.

3. Vybrať Anotácia.

Poznámka

Pre individuálne spojená tvaru alebo konektora na plátne, budete musieť vybrať Prepísať Stencil anotáciepolíčko prvýkrát.

4. Vyberte nové anotácie v paneli nástrojov a vyberte Normy.

5. V dialógovom okne, ktoré sa objavia vyberte možnosti zobrazenia, ktoré sú žiaduce, vrátane držiakov a štýl písma, písma, farbu písma a veľkosť. Tiež, vyberte možnosti rozvrhnutie, ktoré sú žiaduce, vrátane vodorovného a zvislého nastavenia (tj poloha anotácie) a uhla (tj rotácie). Vybrať OK.

Ukázať časové pečiatky pre pridruženú komponentu alebo pripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myšina pridružené tvaru alebo konektora v Komponentyalebo PripojenieZáložka okne vzorkovníka alebo pridružené tvar alebo konektor na plátne.

3. Vybrať Anotácia.

Poznámka

Pre individuálne spojená tvaru alebo konektora na plátne, budete musieť vybrať Prepísať Stencil anotáciepolíčko prvýkrát.

4. Vyberte nové anotácie v paneli nástrojov a vyberte Vytvorené, Vytvorené, Vytvorené Marker, Modified, upravený alebo modifikované Marker.

5. V dialógovom okne, ktoré sa objavia, ak nie značky, vyberte možnosti zobrazenia, ktoré sú žiaduce, vrátane držiakov a štýl písma, písma, farbu písma a veľkosť. Ak marker, nastavte polomer značky v obrazových bodoch a spôsobu farbenia na oboch farieb rozsahom alebo Colour majetkom a nastaviť priradenie farby. Tiež, vyberte možnosti rozvrhnutie, ktoré sú žiaduce, vrátane vodorovného a zvislého nastavenia (tj poloha anotácie) a uhla (tj rotácie). Vybrať OK.

Ak chcete zmeniť štýl písma voľného tvaru tvarualebo konektor

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Kliknite pravým tlačidlom myšina voľného tvaru tvare alebo konektor na plátne. Poznámka: V prípade, že Konektor Text štítku sa nevykazujú potom ukázať connectalebo text štítku: Kliknite pravým tlačidlom myšiconnectaleboa vyberte Anotácia | Show Anotácia.

3. Vybrať Zmeniť písmo.

4. Vyberte štýl písma, písmo a veľkosť v dialógovom okne a vyberte OK.

Ak chcete zmeniť písmo farba z voľného tvaru tvaralebo konektor

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Kliknite pravým tlačidlom myšina voľného tvaru tvare alebo konektor na plátne. Poznámka: V prípade, že Konektor Text štítku sa nevykazujú potom ukázať connectalebo text štítku: Kliknite pravým tlačidlom myšiconnectaleboa vyberte Anotácia | Show Anotácia.

3. Vybrať Zmena Písmo Farba.

4. Vyberte písmoColour (a pre tvary Link farba) kliknutím na tlačidlo "..." a výberu farby v dialógovom okne a vyberte OK.

5. Vyberte Priehľadnosť textového popisku úpravou jazdca s 0 je plne transparentný a 255 je plne nepriehľadná.

Ak chcete otočiť textový popis o voľného tvaru tvarealebo konektor

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Kliknite pravým tlačidlom myšina voľného tvaru tvare alebo konektor na plátne. Poznámka: V prípade, že Konektor Text štítku sa nevykazujú potom ukázať connectalebo text štítku: Kliknite pravým tlačidlom myšiconnectaleboa vyberte Anotácia | Show Anotácia.

3. Vybrať Otočiťa potom vyberte príslušnú uhla chcete pre otočenie text štítku by.

Pozri tiež

Nástroje na kreslenie | Naplnenie vašej architektúry | Analýza Vaše architektúra


Simulácia celkové náklady na vlastníctvo (TCO)

Navigácia: Simulácia vašej architektúry> Simulátory>

Simulácia celkové náklady na vlastníctvo (TCO)

Odoslať pripomienky na túto tému.

Súvislosti

Celkové náklady na vlastníctvo (TCO) je finančná odhad, slúži na meranie nákladov celkovej vynaložené životného cyklu (od obstarania po vyradení z prevádzky / likvidácia) spojené s vlastnených aktív. TCO nielen odráža náklady na nákup, ale tiež zahŕňa všetky ostatné aspekty pri ďalšom použití a údržbu majetku.

TCO sa používa na stanovenie úsilie a náklady na rozpočet nutné vynaložiť na systéme. Jednoduchý spôsob modelovanie v ABACUS na TCO je rozbiť IT systému dole do zložiek. Môžeme potom zistiť, koľko priemerne stojí spustiť jednu z týchto zložiek. Potom sme mohli potom faktor v rôznych nákladov v závislosti na tom, či IT systém je evolvable alebo otvorený atď. Pokiaľ je systém už v prevádzke, hlavným faktorom, aby zvážila, náklady na údržbu a snáď nákladov pre vyradenie.

Príklad

Diagram pre príklad výpočtu

Zložka podľa organizácie alebo jej normy má tieto vlastnosti:

· FTE= 100 000 $ / rok

· Podpora úsilia= 0,01 FTE + 0,001 FTE / yr = $ 1000 + $ 100 / yr

· Náklady na údržbu= $ 100 - $ 10 / yr

· Kapitálové náklady= 2000 $

· Inštalácia Effort= 2 FTE / dní = 0,01 FTE / yr = $ 1000

Zložka podľa organizácie má tieto vlastnosti:

· Inštalácia Horizon= -2 Let (tj bol systém inštalovaný 2 roky pred darom)

· Dĺžka života= 3 roky

Kedy Inštalácia Horizon + Životnosť <= 0 , Nie je tam žiadny ďalšie náklady na údržbu.

Výpočty

Výpočty sú nasledovné:

Poznámka

TC = náklady za rok. SE = podpora úsilia. MC = náklady na údržbu.

· Počiatočné náklady = kapitálové náklady + Install Effort= 2000 + 1.000 = 3.000 $

· V čase t = 2 (v priebehu 1 roka), TC = počiatočné náklady + SE + MC= 3.000 + 1.000 + 100 = 4100 $

· V čase t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1.190 $

· V čase t = 0, TC = (1.000 + 200) + (100 - 20) = 1280 $

· V čase t = 1 (posledný rok), TC = (1000 + 300) + (100-30) = 1370 $

Graf pre príkladu výpočtu

TCO je súčet všetkých súčasných a budúcich nákladov, kým nie je vyradenie z prevádzky systému.

· V čase t = -2 (počas 1. ročníka), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· V čase t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· V čase t = 0, TCO = 1.280 + 1.370 = 2.650 $

· V čase t = 1 (posledný rok), TCO = $ 1370

Hlavné nákladové faktory

Kľúčové nákladové faktory je potrebné vziať do úvahy pri výpočte celkových nákladov na vlastníctvo aktíva v ABACUS sú:

· Hardware Acquisition- Počiatočné náklady na vybavenie (kapitálové náklady) na.

· Softvér Acquisition- Počiatočné náklady na licencie na softvér (kapitálové náklady).

· Inštalácia- Náklady spojené s úvodným nastavenia.

· Školenia- Náklady spojené so externé školenia predajcov po počiatočnom nastavení.

· Podpera- Náklady spojené s vnútornou podpory.

· Udržiavanie- Náklady sa vymieňať alebo vylepšovať dodávateľa servisné zmluvy, dodávky a náklady na obnovenie po havárii.

· Infraštruktúra- Náklady spojené s podporu aktívum.

ABACUS Príklad Zastúpenie kľúčových nákladových faktorov

Spustenie Cost simulátor

Pre simuláciu vašej architektúry z hľadiska nákladov

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Vybrať Rozbor| Náklady.

3. Vyberte si Architektúra (y)Ak chcete zahrnúť do hodnotenia.

Poznámka

V predvolenom nastavení bude ABACUS automaticky vyberie architektúra (y), pre ktoré je z dôvodu požaduje nové simulácie na akejkoľvek nehnuteľnosti alebo štrukturálnych zmien.Toto zvýraznenie je uvedené v Red na Panel nástrojov Simulácia .

4. Vyberte Menaod sťahovacie.

5. Presunúť Roky na výpočetposuvník na počet rokov potrebných.

Poznámka

V predvolenom nastavení, ak let pre výpočet je viac ako 1 rok budú automaticky vypočíta náklady pre každú jednotlivú rok (a zbierka vlastností pridané / aktualizované), a potom sa súhrnná hodnota pre celý rad rokov tiež vypočítať. Ak je vyžadovaná iba súhrnná hodnota potom zrušte zaškrtnutie políčka Vypočítať a rok Nákladymožností, ako je popísané nižšie, ako ušetriť na počte nehnuteľností v projekte.

6. Vyberte, či chcete nechať Vypočítať a rok Nákladykontrolované, alebo zrušte ho.

7. Kliknite na tlačidlo Budúci.

8. Voliteľne vybrať PripojenieAk chcete priradiť náklady spolu ako súčasť hodnotenia.

Poznámka

Používanie Náklady | Prisudzovanianehnuteľnosť na nákladoch Connections môže byť pridelený z komponenty pripojené ku koncu umývadla pripojenie k súčasti pripojené k zdroju koniec(tj Náklady | Attribution = "Sink k zdroju"), alebo z komponenty pripojené k zdroj Koniec pripojenie k súčasti pripojené k drez koniec(tj. Náklady | Attribution = "Zdroj Sink"), Ďalej, ABACUS automaticky vyberie tie spoje s Správanie | Vzťah = "procesy" alebo "podporuje"a smer pripočítaní bude "prepadom na zdroje", Okrem toho sú náklady rozdeľuje podľa ktoréhokoľvek z správania | % Alebo obstarávacia cena | % Reality na pripojenie, prípadne tam, kde sú viac pripojení od drezu mnohých zdrojovalebo zdroj mnohých drezy, Podľa ktoréhokoľvek zo správania | Spracovanie reality na zdrojové komponentyalebo drez komponentov, resp.

9. Kliknite na tlačidlo Skončiťa získate Výstrahadialóg.

10. Voliteľne preskúmať varovanie kliknutím Podrobnosti >>.

11. Kliknite na tlačidlo Pokračovať.

Poznámka

V tomto bode, ABACUS bude vykonávať podľa činností kalkulácie vyhodnotenie architektúry (ov) a po krátkej dobe (s barmi pokroku pre spätnú väzbu), zobrazí sa dialógové okno výpočet kompletný.

12. Kliknite na tlačidlo OKuznať hodnotenia.

Tip

Pre organizovanie školení a ďalšiu pomoc na náklady Simulácia nájdete na Avolution Community .

Zložka a / alebo pripojenie Vlastnosti

V nasledujúcej tabuľke sú uvedené komponenty a / alebo pripojenie požadované vlastnosti vyhodnotiť náklady.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou vstup nehnuteľnosť voliča riadku ( [image] ) S bubline "Ekonomický vstupné". Zmena na niektorú z týchto "vstup" vlastností a rôznych štrukturálnych zmien úložiska bude mať za následok náklady simulátore vyžadujúce re-simulácie, ako je uvedené v Red na Panel nástrojov Simulácia .

Druh

Názov

Predvolená hodnota

Jednotka

Typ dát

Povinné

Popis

Náklady

Inštalácia Horizon

0

leta

Celé číslo

Pravdivý

Určuje, kedy komponenta alebo pripojenie bol alebo bude nainštalovaný.

· Hodnota 0 (predvolené) označuje, že zložka alebo pripojenie je inštalovaná v bežnom roku.

· Hodnota menšia ako 0 naznačuje, že zložky alebo pripojenie bol nainštalovaný v minulosti.

· Hodnota vyššia ako 0 označuje, že zložky alebo pripojenie budú inštalované v budúcnosti.

Náklady

Dĺžka života

0

leta

Celé číslo

Pravdivý

Určuje dĺžku času, v ktorom zložka alebo pripojenie zostane v prevádzke, po ktorom bude vyradené z prevádzky.

Náklady

FTE

100.000,00

$ / Rok

Desatinné

False

Ročné náklady na každého Hlavný pracovný pomer.

Ak táto vlastnosť nie je nájdený v priečinkusamotný alebo v prípade pripojenia komponentu pripevnené na konci drezu spoje, Bude hľadať v ostatných zložiek.

Po prvé, akýkoľvek "umývadlo" zložkas na konci a Spojenie s "podporuje" vzťah ku komponentu budú hľadané, nasledovaný že "prepadom" komponenty rodičias.

Ak vlastnosť FTE nie je nájdený, komponenty rodič-components potom bude prehľadávať. Ak stále nie je nájdený FTE, je použitá predvolená hodnota.

Upozornenie: FTE je len platný vstup nehnuteľnosť na komponenty.

Náklady

Náklady na údržbu (pevné)

0.00

$ / Rok

Desatinné

False

Ročné fixné náklady na údržbu na komponentalebo pripojenie.

Náklady

Náklady na údržbu (variabilný)

0.00

$ / Rok

Desatinné

False

Suma, o ktorú sa celkové náklady na údržbu na komponent alebo pripojenie sa bude meniť každý rok.

Napríklad, hodnota $ -500 znamená, že celkové náklady na údržbu klesá každý rok $ 500, zatiaľ čo hodnota 500 $ ukazuje, že celkové náklady na údržbu sa zvyšuje každým rokom $ 500.

Náklady

Podpora úsilia (pevné)

0.00

FTE / rok

Desatinné

False

Ročná pevný úsilie podporovať komponentyalebo pripojenie, Ktoré sú uvedené v podmienkach osoboroků.

Náklady

Podpora úsilia (variabilný)

0.00

FTE / rok

Desatinné

False

Suma, o ktorú celková intenzita nosných komponent alebo pripojenie sa bude meniť každý rok.

Napríklad hodnota -0.01 ukazuje, že celková podpora úsilia klesá o 0,01 osoby rokoch každý rok, zatiaľ čo hodnota 0,01 znamená, že sa zvyšuje celková podpora úsilia o 0,01 každý rok.

Náklady

Kapitálové náklady

0.00

$

Desatinné

False

Počiatočné náklady na nákup komponentyalebo pripojenie.

Náklady

Inštalácia Effort

0.00

FTE

Desatinné

False

Úsilie povinná v osobe-rokov, nainštalovať súčasťalebo pripojenie.

V nasledujúcej tabuľke sú uvedené komponenty a / alebo pripojenie Vlastnosti, ktoré sú na výstup TCO hodnotiteľa. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Cost Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a náklady simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Poznámka

Tam, kde musí byť výstupné vlastnosti z TCO hodnotiteľa "zaoblené" "okrúhleho polovicu dokonca" prístup (označovaný aj ako "bankári" zaokrúhľovania) je používaný.Táto technika sa používa na rovnomernejšie vyriešeniu .5 'tie-breaky "s výsledkom byť zaokrúhlená nahor alebo nadol na najbližší dokonca Výsledkom je, skôr ako vždy zaokrúhlenie smerom hore alebo dole, a skosenie výsledok. Tj. 2.5 sa zaokrúhli nadol na 2, zatiaľ čo 3.5 sa zaokrúhľuje na 4, skôr než oni obaja sú buď zaokrúhli nadol na 2 a 3 alebo zaokrúhľuje nahor na 3 a 4.

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Náklady | Celkové náklady na vlastné - ďalších x rokov. | $ | Celé číslo | False | Celkové náklady na vlastníctvo počas najbližších xrokov, kde x je dĺžka doby zadaný pri spustení hodnotiteľom. To zahŕňa náklady na súčasti alebo pripojenie je normy, sub-komponentyalebo sub-spoje(tj. deti) a akékoľvek pripisovaných náklady.
Náklady | Celkové náklady na účely vlastníctva (miestna) - ďalší x rokov. | $ | Celé číslo | False | "Miestne" náklady na vlastníctvo počas najbližších xrokov, ak xje dĺžka doby zadaný pri spustení hodnotiteľ. To robí niezahŕňajú náklady na čiastkových komponentov tejto komponenty alebo sub-spoje pripojenie v systéme (tj.deti) alebo akékoľvek pripisovaných náklady.
Náklady | Celkové náklady na účely vlastníctva (deti) - ďalší x rokov. | $ | Celé číslo | False | Náklady na "deti" vlastníctva počas najbližších xrokov, kde x je dĺžka doby zadaný pri spustení hodnotiteľom. Toto iba zahŕňa náklady na čiastkových komponentov tejto komponenty alebo sub-spoje pripojenie v systéme (tj. deti).
Náklady | Celkové náklady na účely vlastníctva (pripísaný) - ďalší x rokov. | $ | Celé číslo | False | "Pripísať" náklady na vlastníctvo počas najbližších xrokov, kde x je dĺžka doby zadaný pri spustení hodnotiteľom. Toto iba zahŕňa všetky náklady pripisované z pripojených komponentov(ktorý môže samozrejme zahŕňať priradená nákladom od všetkých pripojených pripojenie).

V nasledujúcej tabuľke sú uvedené komponenty a / alebo pripojenie Vlastnosti, ktoré sú na výstup TCO hodnotiteľav prípade, že Vypočítať Per-Year náklady je vybraná možnosť. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Cost Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a náklady simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Poznámka

Pozri poznámku vyššie o možnom zaokrúhlenie výstupných vlastností.

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Náklady | Celkové náklady na vlastné - rokx. | $ | Celé číslo | False | Celkové náklady na vlastníctvo pre rok x, Kde x je za každý rok zadaný pri spustení hodnotiteľ. To zahŕňa náklady na súčastialebo pripojenie je normy, sub-komponenty alebo sub-spoje (tj. deti) a akékoľvek pripisovaných náklady.
Náklady | Celkové náklady na účely vlastníctva (miestna) - rokx. | $ | Celé číslo | False | "Miestne" náklady na vlastníctvo pre rok x, Kde xje za každý rok zadaný pri spustení hodnotiteľ. To robí niezahŕňajú náklady na čiastkových komponentov tejto komponenty alebo sub-spoje pripojenie v systéme (tj. deti) alebo akékoľvek pripisovaných náklady.
Náklady | Celkové náklady na účely vlastníctva (deti) - rokx. | $ | Celé číslo | False | Klávesy "deti" náklady na vlastníctvo pre rok x, Kde x je za každý rok zadaný pri spustení hodnotiteľ. Toto iba zahŕňa náklady na čiastkových komponentov tejto komponenty alebo pripojenie v sub-prípojka (tj. deti).
Náklady | Celkové náklady na účely vlastníctva (pripísaný) - rokx. | $ | Celé číslo | False | "Pripísať" náklady na vlastníctvo pre rok x, Kde x je za každý rok zadaný pri spustení hodnotiteľ. Toto iba zahŕňa všetky náklady pripisované z pripojených komponentov(ktorý môže samozrejme zahŕňať priradená nákladom od všetkých pripojených pripojenie).

Dodatočný Vlastnosti pripojenia

V nasledujúcej tabuľke ďalšie vlastnosti pripojenia, ktoré sú vyžadované TCO hodnotiteľa. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou vstup nehnuteľnosť voliča riadku ( [image] ) S bubline "Vstupná cena / výkon" alebo len "Ekonomický vstupné". Zmena na niektorú z týchto "vstup" vlastností a rôznych štrukturálnych zmien úložiska bude mať v cene a / alebo Výkon simulátor vyžadujúce opätovné simulácie, ako je uvedené v Red na Panel nástrojov Simulácia .

Druh | Názov | Predvolená hodnota | Jednotka | Typ dát | Povinné | Popis
Náklady | Prisudzovania | Drez na zdroj | [Zdroj potopiť | Drez na zdroj] | Vyhľadávanie / List | Pravdivý | Ak je "Zdroj Sink", Toto spojenie vôľa mať mať nákladyspridelený "spolu" to z zdrojkomponentov do drez zložka, Alternatívne, ak "Drez na zdroj", Toto spojenie vôľa boli náklady pripísať "spolu" to z drezu zložky k zdrojovej komponenty.
Správanie | Vzťah | podpery | [procesy | podporuje] | Vyhľadávanie / List | False | Ak je "podpery", toto spojenie znamená, že "zdroj" zložka je podporovaný "umývadlom" zložky. Navyše ak buď "podporuje" alebo "procesy", potom bude spojenie automaticky vybrané vo spojeniach, aby ich náklady pripísať 'po' od drezu komponenty k zdrojovému komponent.
Náklady | % | 100.0 | % | Desatinné | False | Udáva podiel nákladov drezu súčasti, ktoré budú pripisované na zdrojové komponenty. V% hodnoty nie je nutné pridať až 100%, a to je jednoducho použitý na zmenu veľkosti "Celkové náklady na vlastné -. Ďalšie x rokov" nehnuteľností (pozri vyššie), z komponenty výlevky tak, ako je pripisované zdrojovej komponente.

Vlastnosti Architektúra

V nasledujúcej tabuľke sú uvedené vlastnosti, architektúry, ktoré sú na výstup TCO hodnotiteľom. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Cost Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a náklady simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Poznámka

Pozri poznámku vyššie o možnom zaokrúhlenie výstupných vlastností.

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Náklady | Celkové náklady na vlastné - ďalších x rokov. | $ | Celé číslo | False | Celkové náklady na vlastníctvo celej architektúry v najbližších x rokoch.

V nasledujúcej tabuľke sú uvedené vlastnosti, architektúry, ktoré sú na výstup TCO hodnotiteľav prípade, že Vypočítať Per-Year náklady je vybraná možnosť. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Cost Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a náklady simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Poznámka

Pozri poznámku vyššie o možnom zaokrúhlenie výstupných vlastností.

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Náklady | Celkové náklady na vlastné - rokx. | $ | Celé číslo | False | Celkové náklady na vlastníctvo pre celá architektúra pre rok xdo budúcnosti.


Simulácia Modularita

Navigácia: Simulácia vašej architektúry> Simulátory>

Simulácia Modularita

Odoslať pripomienky na túto tému.

Modularita simulátor vypočíta počet prichádzajúcich a odchádzajúcich pripojenie pre každú zložku.

Pre simuláciu vašej architektúry z hľadiska modularity

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Vybrať Rozbor| Modularita.

3. Vyberte si Architektúra (y)Ak chcete zahrnúť do hodnotenia.

Poznámka

V predvolenom nastavení bude ABACUS automaticky vyberie architektúra (y), pre ktoré je z dôvodu požaduje nové simulácie na akékoľvek základovej zmeny štruktúry,.Toto zvýraznenie je uvedené v Red na Panel nástrojov Simulácia .

4. Kliknite na tlačidlo Budúci.

5. Vyberte si Typy pripojenia (y)Ak chcete zahrnúť do hodnotenia.

6. Kliknite na tlačidlo Budúci.

7. Voliteľne upraviť názvy vlastností pre výsledky výpočtov.

8. Kliknite na tlačidlo Skončiť.

Poznámka

V tomto bode, ABACUS bude vykonávať štrukturálne vyhodnotenie architektúry (ov) a po krátkej dobe (s barmi pokroku pre spätnú väzbu), zobrazí sa dialógové okno výpočet kompletný.

9. Kliknite na tlačidlo OKuznať hodnotenia.

Tip

Pre organizovanie školení a ďalšiu pomoc na Modularita ohodnotenie nájdete na Avolution Community .

Vlastnosti Component

V nasledujúcej tabuľke sú uvedené súčasti vlastnosti, ktoré sú na výstup modularity hodnotiteľom.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Modularita Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku základnej štrukturálne zmeny úložiska a modularita simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Typ dát | Povinné | Popis
Modularita | Spojka-fan v (miestnej) | Celé číslo | False | Počet spojení, ktoré ventilátor do tejto zložky.
Modularita | Spojka-fan out (miestne) | Celé číslo | False | Počet spojenie, ktoré vybiehajú z tejto zložky.
Modularita | Spojka-fan v | Celé číslo | False | Počet spojení, ktoré ventilátor do tejto zložky, vrátane prípojok, že ventilátor do čiastkových komponentov.
Modularita | Spojka-fan out | Celé číslo | False | Počet pripojení, ktoré vybiehajú z tejto zložky, vrátane prípojok, že ventilátor do čiastkových komponentov.


Simulácia Otvorenosť

Navigácia: Simulácia vašej architektúry> Simulátory>

Simulácia Otvorenosť

Odoslať pripomienky na túto tému.

Otvorenosť Simulátor určí, do akej miery architektúra, a jeho prvky sú "otvorené", to znamená, že schopnosť systému pre spracovanie výmena dielov s minimálnym dopadom.

Pre simuláciu vašej architektúry z hľadiska otvorenosti

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Vybrať analýza | Otvorenosť.

3. Vyberte si Architektúra (y)Ak chcete zahrnúť do hodnotenia.

Poznámka

V predvolenom nastavení bude ABACUS automaticky vyberte prvú architektúru, pre ktoré je z dôvodu požaduje nové simulácie na akejkoľvek nehnuteľnosti alebo štrukturálnych zmien.Toto zvýraznenie je uvedené v Red na Panel nástrojov Simulácia .

4. Kliknite na tlačidlo Skončiťa získate Výstrahadialóg.

5. Voliteľne preskúmať varovanie kliknutím Podrobnosti >>.

6. Kliknite na tlačidlo Pokračovať.

Poznámka

V tomto bode, ABACUS bude vykonávať štrukturálne vyhodnotenie architektúry (ov) a po krátkej dobe (s barmi pokroku pre spätnú väzbu), zobrazí sa dialógové okno výpočet kompletný.

7. Kliknite na tlačidlo OKuznať simuláciu.

Tip

Pre organizovanie školení a ďalšiu pomoc na otvorenosti ohodnotenie nájdete v časti Avolution Community .

Komponentov a pripojenia Štandardné vlastnosti

V nasledujúcej tabuľke sú uvedené štandardné vlastnosti komponenty a spojenia požadované pre hodnotenie otvorenosť.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou vstup nehnuteľnosť voliča riadku ( [image] ) S bubline "Otvorenosť Input". Zmena na niektorú z týchto "vstup" vlastnosti v úložisku bude mať za následok otvorenosti simulátore vyžadujúce re-simulácie, ako je uvedené v Red na Panel nástrojov Simulácia .

Druh | Názov | Predvolená hodnota | Jednotka | Typ dát | Povinné | Popis
Otvorenosť | Štandardy-Štandardné Splatnosť-Organizácia Level |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Úroveň zodpovedné orgány v oblasti noriem 0:Organizačné / Proprietárnu 1:Konzorcium / defacto 2:Národný / Military 3:Medzištátne
Otvorenosť | Štandardy-Štandardné Splatnosť-Status |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Dosiahnutá úroveň Schválenie s normalizačným orgánom 0:Pracovné / Výbor Návrh 1:Public Návrh / žrebuje 2:Dočasná Návrh 3:Schválené
Otvorenosť | Štandardy-Štandardné Splatnosť-Stability |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Je štandardná pravdepodobne zmení? 0:Štandardné zastaraný 1:Vysoko môžu zmeniť v ďalšej 1 až 2 roky 2:Známe zmena / aktualizácia existujúcich funkcií 3:Vysoko stabilný (bez zmeny do 2 rokov)
Otvorenosť | Štandardy-Štandardné Splatnosť-Vendor Support |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Podpora predajcu 0:Žiadne produkty alebo dodávatelia podporujú štandard 1:Jeden alebo viac predajcov, ktoré implementujú časť štandardu 2:Viac ako jeden predajca s produktmi, ktoré implementujú všetky časti normy 3:Oveľa viac ako jeden predajca s produktmi, ktoré implementujú všetky časti normy
Otvorenosť | Štandardy-Štandardné jednoznačnosti-Dokumentácia |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Kvalita štandardné dokumentáciu 0: Biedny 1:Fér 2:Dobrý 3:Vynikajúci
Otvorenosť | Štandardy-Štandardné jednoznačnosť-Štandardná šírka |  |  | Celé číslo | False | Počet funkcií. Udáva počet najnižších štandardnú úroveň funkcií - Sf
Otvorenosť | Štandardy-Štandardné jednoznačnosti-Sm |  | % | Desatinné | False | Percentuálny podiel celkového počtu funkcií, ktoré sú povinné
Otvorenosť | Štandardy-Štandardné jednoznačnosti-So |  | % | Desatinné | False | Percentuálny podiel celkového počtu funkcií, ktoré sú voliteľné
Otvorenosť | Štandardy-Štandardné jednoznačnosti-Sc |  | % | Desatinné | False | Percentuálny podiel celkového počtu funkcií, ktoré sú podmienene definované
Otvorenosť | Profily-Profile-Documentation Dokumentácia |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Kvalita štandardné dokumentáciu 0:Žiadny 1: Biedny 2:Fér 3:Vynikajúci
Otvorenosť | Profily-Profile Documentation-Presnosť |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Má dokumentácia odrážať skutočnú návrhu systému? Akú úroveň vlastností profilu sa používajú v systéme? 0:Žiadna funkcia 1:Niektoré funkcie 2:Väčšina funkcií 3:Všetky funkcie
Otvorenosť | Profily-Profile dokumentácie splatnosti |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Je profil zrelý a sú k dispozícii? 0:Ad-hoc 1:Založené Project 2:Organizačné 3:Verejný
Otvorenosť | Profily-Profile jednoznačnosť-Explicit Šírka |  |  | Celé číslo | False | Počet štandardných funkcií uvedených ako je požadované v profile
Otvorenosť | Profily-Profile jednoznačnosti-PM |  | % | Desatinné | False | Percento povinných prvkov v profile
Otvorenosť | Profily-Profile jednoznačnosti-Po |  | % | Desatinné | False | Percento voliteľných funkcií v profile
Otvorenosť | Profily-Profile jednoznačnosti-PC |  | % | Desatinné | False | Percento podmienečne definované funkcie v profile
Otvorenosť | Profily-Profile jednoznačnosti-Pokrytie |  | % | Desatinné | False | Percento štandardných funkcií osobitne v profile
Otvorenosť | Profily-Profil Extensions Extension Šírka |  |  | Celé číslo | False | Počet non-štandardných funkcií určené profilom
Otvorenosť | Profily-Profile-rozšírenie pokrytia |  | % | Desatinné | False | Percento predĺženia je podrobne uvedené v profile
Otvorenosť | Dostupnosť Výrobky produkt a Zhoda Číslo tovaru |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Počet produktov podporovať povinné funkcie štandardu 0:Žiadne produkty podporujú štandard 1:Jedného alebo viacerých produktov realizovať časť štandardu 2:Viac ako jeden produkt vykonáva všetky časti normy 3:Oveľa viac ako jeden produkt vykonáva všetky časti normy
Otvorenosť | Dostupnosť Výrobky produkt a zhody-prihláška Zhoda |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Akú úroveň zhody sa výrobky majú štandardu? 0:Žiadny 1:Vyhlasoval 2:Preukázaná 3:Certifikované a demonštroval
Otvorenosť | Dostupnosť Výrobky produkt a zhody, Zhoda Quality |  | [0 | 1 | 2 | 3] | Vyhľadávanie / List | False | Kvalita skúšanie zhody 0:Žiadny 1:In-house Testovanie produktu vývojára 2:Nezávislé testovanie (napr. NIST) 3:Preukázaná v rámci príslušného výrobku

Súčasť, pripojenie a vlastnosti architektúra

V nasledujúcej tabuľke sú uvedené súčasti, pripojenie a vlastnosti architektúra výstup otvorenosťou hodnotiteľa. Všetky z nasledujúcich vlastností vyhodnotiť medzi nulou (0) a tri (3), nula (0) je najmenej žiaduce a tri (3) je najviac žiaduce.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Otvorenosť Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku fundamentálnej zmene vlastníctva k úložisku a otvorenosti simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Typ dát | Povinné | Popis
Otvorenosť | Otvorenosť | Desatinné | False | Celkové hodnotenie otvorenosti položky.
Otvorenosť | Štandardy-Štandardné Splatnosť | Desatinné | False | Súčasný stav štandardu, čo odráža či alebo nie to bolo schválené, ako dlho to bolo v prevádzke a ako dobre prijatý, je v rámci komunity vývojárov.
Otvorenosť | Štandardy-Štandardné jednoznačnosti | Desatinné | False | Jednoznačnosť štandardov, čo odráža potenciálny nejasnosti v nasledujúcich normách
Otvorenosť | Profily-Profile dokumentácie | Desatinné | False | Rozsah, v ktorom profil interface dokumentácia je vyvinutý a či je dokumentácia profil vyjadruje skutočnú návrh systému a / alebo zavedený systém
Otvorenosť | Profily-Profile jednoznačnosti | Desatinné | False | Miera podrobnosti poskytované v profile / špecifikácii profil
Otvorenosť | Profily-profilu Rozšírenie | Desatinné | False | Miera, do akej profil zodpovedá norme, na ktorom je založený
Otvorenosť | Produkty produkt Dostupnosť a zhody | Desatinné | False | Či alebo nie tam sú otvorené spĺňajúceho štandard produktov pre využitie v rámci projektu


Simulácia Performance

Navigácia: Simulácia vašej architektúry> Simulátory>

Simulácia Performance

Odoslať pripomienky na túto tému.

Súvislosti

Architektonická Hodnotiteľ pre výkon je diskrétny simulátor udalosť, ktorá pracuje tým, že simuluje tok správ (alebo tokenov) v rámci celej architektúry. Teória za týmto je odvodený z výskumu uskutočnenom na University of Technology, Sydney, a je založený na Sieťové Layered Queuing Modely(LQNM), Dočasný a farebné Petriho siete(TCPN) a Aktivita Taktovacia diagramy(ACD).

V simuláciu výkonu ABACUS, spracovanie na jednu zložku je väčšinou spôsobovaný zasielané správy, ktoré jej z iného komponentu. Princípy za tejto techniky je možné chápať do štyroch hlavných častí:

1. message-centricKomunikácia je modelovaný v ABACUS použitím logický(alebo nepriame) pripojenie. Logické spojenie definovať správanie (frekvencia a dáta) správ zasielaných medzi komponentmi. Dobrým príkladom logických spojov by sekvencie toky medzi dvoma (2), obchodných procesov alebo logických rozhranie medzi dvoma (2) aplikácií.

2. Logické správy sú prepravované na miesto určenia prostredníctvom hierarchie(ako je napríklad swimlanes zdroja), alebo priamyspoje (napríklad fyzickými káble). K tomu môžu byť smerované hore, cez robiť a späť dole hierarchiu (odstupňovaný prístup), nasledovať priamu cestu.

3. Vernosť modelu je možné nastaviť tak, aby vyhovovali. Napríklad proces môže byť rozdelený dole tak ďaleko tak, aby každé jednotlivé základné proces a funkcia má samostatnú stopu. Alternatívne môže byť stačí mať len jednu hodnotu pre celý proces, čo je odrazom priemernýspracovanie odpoveď na správu.

4. Skutočná spracovaniesa vykonáva len jednotlivými zložkami, ktoré (alebo sú) procesora. Procesor je všeobecný vec, a môže byť CPU, osoba, organizačná zložka, alebo čokoľvek iné, ktorý je schopný vykonávať práce. Napríklad obchodný proces nerobí žiadne skutočné spracovanie; toto sa vykonáva pomocou prvej "procesor", sa to v jednej svojej materskej hierarchie (ak je použitý swimlane notácie) alebo jeho siete na spracovanie (ak je použitý distribuované spracovanie notácie).

Toto vyhodnotenie simulovaním (určené) prevádzky v systéme, tak, že každá prípojka je simulovaná aspoň raz. Čas príchodu správ sa náhodne generované s ohľadom na ich zadanej frekvenciu. Tento model simuluje spracovanie zdrojov a konflikty a radenie správ do fronty, zhromažďovanie štatistík po ceste sú rôzne výstupných vlastností.

Kľúčové faktory Vstupný výkon

1. Frekvencia- Frekvencia, pri ktorej dôjde k pripojenie.

2. Spracovanie- Množstvo času pre dokončenie prevedenie jeden proces. To môže byť v hodiny, minúty, dni, operácia atď.

3. Rýchlosť- Rýchlosť zdroje procesora. To znamená, že to, koľko cyklov / inštrukcie / akcia sa môže vykonávať v jednej jednotke času. Je dôležité, aby boli v súlade s jednotkami používanými pre spracovanie.

4. Procesory- Počet prostriedkov procesora. Spracovatelia mohli byť ľudia, CPU, externé organizácie atď

Kľúčové faktory Výstupný výkon

1. Priepustnosť- Počet správ za jednotku času prostredníctvom opatrení prípojka, Táto skutočná hodnota môže byť v porovnaní s očakávanými / teoretické hodnoty (tj Frequency) odvodiť nasýtenia systému.

2. Správa Rate- Počet správ za jednotku času prostredníctvom opatrení zložka, Jedná sa o súčet prichádzajúcich a odchádzajúcich správ všetky komponenty.

3. Odpoveď- Minimálna / priemerná / maximálna latencia pre tento prípojka, Jedná sa o súčet všetkých sledovaných čakacích dôb pre pripojenie od prameňa k drezu a akékoľvek Queuing a spracovanie (a latencie späť k zdroju, ak obojsmerne).

4. Využitie- Na využitie zložka, To bude 0%, ak súčasť nie je zariadenie / procesor (tj nemá procesory a vlastnosti Speed ​​definované vyššie).

Kým diskrétne simulácie udalosti sa vykonáva pre výpočet rôznych výstupné vlastnosti, ako je popísané vyššie, môže byť nižšie uvedený vzorec použitý ako hrubý overenie výsledkov (kde je systém nie je nasýtených):

Využitie = súčet frekvencie pre všetky prichádzajúce pripojenie * Spracovanie / (* Rýchlosť procesory)

Celková koncepcia je možno najlepšie demonštroval tým, že zvažuje nasledujúce diagram, ktorý ukazuje dva rôzne výkonnostné meta-modelov. Štýl Ľavá ruka je klasický "swimlane" notácie so spracovaním úlohy hierarchicky založených v rámci svojich procesorových zdrojov. Pravá ruka štýl je "distribuované" notácie s úlohami spracovanie pripojených cez spojenie procesov k ich prostriedku procesora. Tento druhý zápis umožňuje viac prostriedkov procesora pre danú úlohu spracovania, na rozdiel od obmedzenej swimlane notácie.

Poznámka

Zobrazovať na každom meta-modelu sú vstupné vlastnosti (v červenom) a výstupné vlastnosti (modro):

Výkonnostný meta-modely: swimlane proti distribuovaného notácie

Spustenie simulátora výkonu

Pre simuláciu vašej architektúry z hľadiska výkonu

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Vybrať Rozbor| Predstaveniealebo kliknite na tlačidlo na paneli nástrojov.

3. Vyberte StaviteľstvoAk chcete zhodnotiť z rozbaľovacieho menu.

Poznámka

V predvolenom nastavení bude ABACUS automaticky vyberte prvú architektúru, pre ktoré je z dôvodu požaduje nové simulácie na akejkoľvek nehnuteľnosti alebo štrukturálnych zmien.Toto zvýraznenie je uvedené v Red na Panel nástrojov Simulácia .

4. Vyberte Komponentya PripojenieAk chcete zhodnotiť, od okno pre výber štandardným prvkom .

5. Nastavenie Run Time Scale Factorslider.

Poznámka

Vyššie hodnoty prinesie viac štatisticky konzistentné výsledky, ale trvať dlhšiu dobu pre výpočet.

Dodatočný Checkboxk okno pre výber štandardným prvkom

· Save prevádzal modelvôľa uložiť kópiu RBD transformovaného verzia projektu v rovnakom priečinku ako aktuálny projekt a pridať "_transformed" k názvu projektu.Tento transformovaný projekt možno využiť na diagnostike podrobne simuláciu spoľahlivosti podnikané ABACUS.

Ďalšie možnosti znova na okno pre výber štandardným prvkom

· Run Time Scale Factor reguluje doba, simulácie a presnosť s vyšším Hodnoty výnosIngviac štatisticky konzistentné výsledky, ale prevzatia dlhší čas beh.

Poznámka

Pri ABACUS vypočíta čas simulácie, že bude určovať najpomalší nepriamej súvislosti frekvencie, ktorá bola vybraná byť simulovaná a potom "warm-up" pre obdobie (tj 1 nad frekvencii) týmto spojením (začatie pravidelnej generátory správ pre všetky pripojenie náhodne Počas tejto zahrievacia doba, čo im všetkým šancu iniciovať), a potom simulovať na Run Time Scale Factor násobok periódy tomto ohľade. Alebo (1 / frekvencia) Doba zahrievania + (1 / frekvencia) * Run Time Scale Factor simulačné čas. To je, aby sa ubezpečil, že, že všetky spoje sú začali pred štatistické údaje zhromažďované, a potom najpomalší pripojenie je stále simulovaná aspoň raz v simulácii. Napr. V prípade, že najpomalší nepriame spojenie má frekvenciu 0,033 časových jednotiek (alebo circa raz za mesiac, ak sa časové jednotky sú dni), potom warm-up čas bude 30,3 časové jednotky a doba simulácia bude 30,3 časové jednotky krát scale Factor Doba chodu.

6. Kliknite na tlačidlo Skončiťa získate Výstrahadialóg.

7. Voliteľne preskúmať varovanie kliknutím Podrobnosti >>.

8. Kliknite na tlačidlo Pokračovať.

Poznámka

V tomto bode, ABACUS bude vykonávať simulácie diskrétnych udalostí architektúry a po krátkej dobe (s tyčou pre spätnú väzbu o pokroku), zobrazí sa dialógové okno výpočet kompletný.

9. Kliknite na tlačidlo OKuznať simuláciu.

Tip

Pre organizovanie školení a ďalšiu pomoc na výkon Simulácia nájdete na Avolution Community .

Vlastnosti Component

V nasledujúcej tabuľke sú uvedené vlastnosti potrebné na hodnotenie výkonnosti. Nehnuteľnosti sú vyhľadávané ako prvé v komponente prípadoch, a ak nie je nájdený, je predvolený používa, potom štandardy komponentov.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou vstup nehnuteľnosť voliča riadku ( [image] ) S bubline "vstupný výkon". Zmena na niektorú z týchto "vstup" vlastností a rôznych štrukturálnych zmien v úložisku bude mať za následok simulátore Performance vyžadujúce opätovné simulácie, ako je uvedené v Red na Panel nástrojov Simulácia .

Druh | Názov | Predvolená hodnota | Jednotka | Typ dát | Povinné | Popis
Správanie | b_pack | 0.0 |  | Desatinné | False | Pevná doba prevádzky na balenie behom niekoľkých sekúnd. Táto vlastnosť je typicky zadaný ako štandardného typu, a potom použiť pre inštancie viacerých komponentov. Napríklad, CORBA má b_pack = 0,23 ms.
Správanie | m_pack | 0.0 |  | Desatinné | False | Premenná Doba služba balenie v sekúnd / byte. Táto vlastnosť je typicky zadaný ako štandardného typu, a potom použiť pre inštancie viacerých komponentov.
Správanie | b_unpack | 0.0 |  | Desatinné | False | Pevná doba služby rozbaliť v sekundách. Táto vlastnosť je typickyzadaný ako štandardného typu, a potom použiť pre inštancie viacerých komponentov.
Správanie | m_unpack | 0.0 |  | Desatinné | False | Premenná Doba služba rozbaliť v sekúnd / byte. Táto vlastnosť je typickyzadaný ako štandardného typu, a potom použiť pre inštancie viacerých komponentov.
Správanie | Spracovanie | 0.0 |  | Desatinné | Pravdivý | Množstvo času realizácie na dokončenie jeden proces. To môže byť v hodiny, minúty, dni, operácia atď.
Správanie | Procesory | 1 |  | Celé číslo | Pravdivý | Počet zdrojov procesora. Spracovatelia mohli byť ľudia, CPU, externé organizácie atď
Správanie | Rýchlosť | 100 |  | Celé číslo | Pravdivý | Rýchlosť zdroje procesora. To znamená, že to, koľko cyklov / inštrukcie / akcia sa môže vykonávať v jednej jednotke času. Je dôležité, aby boli v súlade s jednotkami používanými pre spracovanie.
Správanie | k_bkgd | 0.0 |  | Desatinné | False | Spracovanie na pozadí na komponent. To sa používa k úprave výsledkov, aby zodpovedali žiadne pevné offsety%. To môže byť pravdepodobne ignorované.

V nasledujúcej tabuľke sú pre komponentný výstup vlastností výkonom hodnotiteľa. Súbor týchto vlastností zložiek sú generované pre každú zložku v každom výkonu behu.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Performance Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a simulátora výkon vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Správanie | Správa Rate |  | Desatinné | False | Počet správ, za jednotku času prostredníctvom zložky. Jedná sa o súčet prichádzajúcich a odchádzajúcich správ všetky komponenty.
Správanie | Šírka pásma |  | Desatinné | False | Celková šírka pásma skrz súčasť. Súčet kvôli obom prichádzajúce a odchádzajúce správy.
Správanie | Využitie | % | Desatinné | False | Využitie komponenty. To bude 0%, ak súčasť nie je zariadenie / procesor (tj Nemá procesory a vlastnosti Rýchlosť definované vyššie)

Vlastnosti pripojenia

V nasledujúcej tabuľke sú uvedené vlastnosti potrebné na hodnotenie výkonnosti. Nehnuteľnosti sú vyhľadávané ako prvé v prípadoch spojenie, potom sa spojenie štandardov a pokiaľ nie je nájdený, je predvolený používa.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou vstup nehnuteľnosť voliča riadku ( [image] ) Sa v popisku "Vstup Performance" alebo "Ekonomický vstupný / výkon". Zmena na niektorú z týchto "vstup" vlastností a rôznych štrukturálnych zmien úložiska bude mať za následok simulátora výkonu a / alebo Náklady simulátor vyžadujúce opätovné simulácie, ako je uvedené v Red na Panel nástrojov Simulácia .

Druh

Názov

Predvolená hodnota

Jednotka

Typ dát

Povinné

Popis

Správanie

Druh

obojsmerný

[obojsmerný | jednosmerný]

Vyhľadávanie / List

Pravdivý

Či je pripojenie obojsmerný (obojsmerne), alebo jednosmerné (jednosmerný).

Povolené hodnoty pre túto vlastnosť sú "obojsmerná" alebo "jednosmerný".

Obojsmerné znamená synchrónny správy požiadavke / odpovede vzhľadom k tomu, jednosmerné prostriedky jeden asynchrónny "udalosť".

Správanie

Abstrakcie

nepriamy

[nepriame | priamy]

Vyhľadávanie / List

Pravdivý

Či je pripojenie fyzickej alebo logické. Priame spojenia sú fyzické "rúry" medzi dvoma zložkami, že logické pripojenie prúdi ďalej.

Povolené hodnoty pre túto vlastnosť sú "priame" alebo "nepriame".

Ak je hodnota "direct", potom sa spojenie nepotrebuje žiadne ďalšie vlastnosti (s výnimkou vlastností Kind a abstrakcie).

Údaje

L_app1

0

Celé číslo

False

Dopyt / veľkosť udalosti v bytoch.

Každé spojenie zvyčajne majú osobitnú hodnotu pre toto. V CORBA udalosti sú vlastne obojsmerná a vždy majú 12 byte potvrdiť (L_app2). Ak je pravda, jednosmerný spojenie potom vynechať vlastnosť L_app2.

Údaje

L_app2

0

Celé číslo

False

Odpoveď / potvrdiť veľkosť v bajtoch.

Každé spojenie zvyčajne majú osobitnú hodnotu pre toto. Jednosmerný spojenie nebude mať L_app2.

Správanie

Frekvencia

1

Desatinné

Pravdivý

Frekvencie, pri ktorej dôjde k pripojenie.

Každé spojenie zvyčajne majú osobitnú hodnotu pre toto. Ak vlastnosť Frekvencia je vynechaný, potom predvolený používa.

Správanie

Vzťah

procesy

[procesy | podporuje]

Vyhľadávanie / List

False

Pripojenie, ktoré majú "procesy" vlastníctva ukazujú, že zložka na začiatku spojenia, sa prevedú na spracovateľný pri zložky na konci spojenia. V skutočnosti je "zdrojom" zložka sa sťahoval, aby sa stal dieťaťom "potopiť" zložky (pripojené prípojky sú tiež "pretiahnuť" s týmto pohybom).

Ak sa "procesy" vlastnosť existuje potom všetky ostatné vlastnosti pripojenia sa ignorujú, s výnimkou voliteľného "%" vlastníctvo je popísaný nižšie.

Správanie

%

100.0

Desatinné

False

Pripojenie, ktoré majú "Procesy" vlastníctva (popísaného vyššie) môže voliteľne mať "%" vlastníctva k indikácii podiel spracovanie, ktoré bude pridelené do cieľovej zložky. Týmto spôsobom môže byť jediný zdroj komponenta spracováva viac súčasťou cieľových na rôznych% očiam. V% hodnoty nie je nutné pridať až 100%, a to je jednoducho používajú pre kalibráciu "spracovanie" vlastníctva (pozri vyššie) pre zdrojové komponenty, ako to je transformované, aby sa stal dieťaťom cieľovej zložky.

V nasledujúcej tabuľke sú uvedené vlastnosti generované výkonu hodnotiteľom. Súbor týchto vlastností pripojenia sú generované pre každé spojenie na každej výkon behu.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Performance Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a simulátora výkon vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Správanie | Šírka pásma |  | Desatinné | False | Celková šírka pásma pre pripojenie. Toto je počítaná len pre nepriame pripojenie a je v podstate (L_app1 + L_app2) * priepustnosť.
Správanie | Šírka pásma dvěina |  | Desatinné | False | Šírka pásma špeciálne pre odchádzajúce (1) a prichádzajúcich (2) správy o pripojení. Toto je počítaná len pre nepriame pripojenie a je v podstate L_app1 * Priepustnosť a L_app2 * priepustnosť.
Správanie | Priepustnosť |  | Desatinné | False | Počet správ za jednotku času prostredníctvom pripojenia. Táto skutočná hodnota môže byť v porovnaní s očakávanými / teoretické hodnoty (tj Frequency) odvodiť nasýtenia systému.
Správanie | Dokončené | % | Desatinné | False | Percento správ, ktoré úspešne dokončí spracovanie pre pripojenie. Toto je počítaná len pre nepriame pripojenie a je Priepustnosť / frekvencie. Občas Dokončené hodnota prekročí 100%, pretože náhodnosť výsledkov generácie správu v mierne vyššou frekvenciou generačný správu, ako je uvedené.
Správanie | Odpoveď (Min / Ave / Max) |  | Desatinné | False | Minimálna / priemerná / maximálna latencia. Toto je počítaná len pre nepriame pripojenie a je pozorovaný latencia pre pripojenie od zdroja do drezu a akejkoľvek Queuing a spracovanie (a latencie späť k zdroju, ak obojsmerne).

Vlastnosti Architektúra

V nasledujúcej tabuľke sú uvedené v rámci celého systému architektonické vlastnosti generované výkonu hodnotiteľom. Jednotný súbor vlastností pre architektúry sú "agregované" Pre každý výkon beh.Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Performance Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a simulátora výkon vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Správanie | Správa Rate |  | Desatinné | False | Počet správ, za jednotku času z častí v architektúre. Jedná sa o súčet prichádzajúcich a odchádzajúcich správ všetky komponenty.
Správanie | Priepustnosť |  | Desatinné | False | Počet správ, za jednotku času cez spojenie v architektúre. To je suma výkony všetkých nepriamych Connections "a táto skutočná hodnota môže byť v porovnaní s očakávanými / teoretické hodnoty (tj frekvencie) odvodiť nasýtenia systému.
Správanie | Šírka pásma |  | Desatinné | False | Celková šírka pásma. Súčet pripojovacích pásma architektúry je.
Správanie | Využitie | % | Desatinné | False | Využitie všetkých zložiek. Môže byť vyššia ako 100%, ako je to len súčet všetkých čiastkových utilisations architektúru je.
Správanie | Odpoveď (Min / Ave / Max) |  | Desatinné | False | Minimálna / priemerná / maximálna latencia. Súčet všetkých pozorovaných čakacích dôb pre pripojenie architektúre sa od zdroja ku dnu (a späť k zdroju, ak obojsmerne).


Simulácia Spoľahlivosť a dostupnosť

Navigácia: Simulácia vašej architektúry> Simulátory>

Simulácia Spoľahlivosť a dostupnosť

Odoslať pripomienky na túto tému.

Súvislosti

Spoľahlivosť Hodnotiteľ vypočíta spoľahlivosť architektúry pomocou vstupných komponentov a pripojenia.

Pre komponenty a priamym spojením, spoľahlivosť je založená na Stredná doba medzi poruchami (MTBF). Jediné premenné potrebné pre výpočet spoľahlivosti architektonických prvkov sú:

· MTBFhodnota (v rokoch);

· Stredná doba opravy (MTTR)zlyhania (v rokoch); a

· Definovaná doba si chcete otestovať spoľahlivosť cez.

Vzorec použitý pri výpočte spoľahlivosti je daná ako:

Spoľahlivosť = -e (-y x vek)
Tam, kde y = 1 ÷ MTBF

Dostupnosť súčiastok a spojov je založený na MTBF MTRS. Všimnite si, že dostupnosť, na rozdiel od spoľahlivosti, nie je ovplyvnená dobu, pre ktorý je testovaný.

Dostupnosť = MTBF / (MTBF + MTTR)

Kým metódy, ktoré prevádzajú Spoľahlivosť Bloková schémy(pomocou jednoduchej séria a paralelné konštrukcie), dať najviac presné výsledky, tieto metódy stávajú vysoko impraktický keď sa snažíme tiež k výpočtu spoľahlivosti pre misie v rámci veľkých sietí tisícov prvkov. Okrem toho tieto transformačné prístupy rozobrať pre mnoho bežných konštrukcií, ako sú sieťové "ok".

Monte Carlometóda umožňuje spoľahlivosť a dostupnosť systému ľubovoľnej veľkosti a zložitosti byť vypočítaná. Metóda Monte Carlo simuluje rad scenárov a falebo každý scenár náhodný stať, k dispozícii alebo nedostupné, Je priradený ku každej fyzický prvok. Pravdepodobnosť daného prvkom je v dostupnom stave je založený na spoľahlivosti / komponenty.

Napríklad, komponenta s 90% dostupnosťou možno očakávať, že bude k dispozícii v približne 90% scenárov. Spoľahlivosť a dostupnosť nepriamej súvislosti môže byť preto odhadnutá ako podiel náhodnej scenarios-, u ktorých cesta prvkov existuje vo dostupného výkazu zo zdroja k cieľu.

Poznámka

Vzhľadom k tomu, výpočet miestnej spoľahlivosti a dostupnosti je založený na rôznych parametrov a rôznych vzorcov (a teda má za následok rôzne hodnoty), je nutné priradiť každému prvku dvomastavy, jeden pre dostupnosť, a jeden pre spoľahlivosť. Výpočet dostupnosti používa stav dostupnosti v každom prípade, že výpočet spoľahlivosti využíva stav spoľahlivosť v každej situácii.

Spoľahlivosť Hodnotiteľ používa Monte Carlo simulačné techniku ​​vypracovať spoľahlivosť konkrétnej architektúry. Architektúra je podrobený tisícov jednotlivých simulácií a výsledky tabuľkovej odvodiť spoľahlivosti opatrení. Ako bolo uvedené vyššie, Monte Carlo je najrýchlejšia metóda pre simuláciu väčších sietí a bude pracovať v každom zložitom (tj prepojené) štruktúry.

Hodnotiteľ výstupy štyri hodnoty:

1. Misie Spoľahlivosťv priebehu niekoľkých rokov;

2. Obsadenosťz architektúra;

3. Spoľahlivosťz Miestny priečinokv priebehu niekoľkých rokov; a

4. Obsadenosťz Miestny priečinok.

Hodnotiteľ vyjde pravdepodobnosť súčasť alebo funkčné pripojenie (tj. nie zlyhanie) a čas potrebný na opravu.

Ako noriem s MTBFs a / alebo MTTRs zaobchádza

Ak prvok (komponent alebo pripojenie) má štandardov s priradenou MTBF a / alebo MTTR hodnoty, tieto hodnoty sa tiež používajú pri výpočte miestneho spoľahlivosti a dostupnosť prvku ako spojenie radov.

Napríklad, ak je komponent A, S priradenými štandardy B, CA Dkaždý majú MTBF MTRS hodnota, miestne Spoľahlivosť = R(A)× R(B) × R(C) × R(D), Kde R = Vypočítaná spoľahlivosť (podľa vzorca) zložiek / noriema Lokálne Úžitokschopnosť = A (A)× A (B) × A (C) × A (D), Kde A = Vypočítaná úžitokSchopnosť (pomocou vzorca) súčasti / normami. To znamená, že ak prvok má tri úrovne každý s MTBF MTRS hodnotas, A tiež MTBF MTRS hodnotaspre vlastnosti elementovýma, miestne spoľahlivosť a jej dostupnosti sa podáva ako séria hodnoty každej z noriem a samotného prvku.

Ako ďalší príklad, ak je komponent Amá priradené štandardy B, CA Dale iba štandardné Bmá ako MTBF a hodnotu MTTR, zatiaľ čo štandardné Cmá iba MTBF hodnotu a štandardné Dmá len hodnotu MTTR, Miestne Spoľahlivosť = R (A)× R (B)× R (C), Kde R= Vypočítaná spoľahlivosť (podľa vzorca) zložiek / normy a miestne Obsadenosť = A (A)× A (B)× A (C), Kde A= Vypočítaná dostupnosť (podľa vzorca) zložiek / normami, ale vo výpočte (C), pretože štandard má len hodnotu MTBF je 'vyhľadávanie'pre hodnotu zodpovedajúcu MTTR (y) a dodá všetky hodnoty MTTR zistí, že don't samy majú hodnotu MTBF zodpovedajúce, takže v tomto prípade by použiť hodnotu MTTR štandardných D, Ak tam bol ďalší štandard, hovoria E, Len s hodnotou MTTR aj potom A (C)by používal MTBF Cs MTTR z Da Esčítajú. Ak iného štandardu, povedzme F, Mal len hodnotu MTBF potom A (F)by sa tiež použiť MTTR z Da Esčítajú.

Výpočet Mission Spoľahlivosť

Pri výpočte miestnej spoľahlivosť, je vec pomocou jednoduchého vzorca, výpočet nepriamych pripojenie (misie) nie je tak jednoduché, zvlášť akonáhle budeme mať zložité a veľké siete prekladaných ciest (pripojenie) a komponenty.

Ak vezmeme do úvahy celú sieť

Vzhľadom k tomu, nepriame spojenie nepredstavujú fyzické pripojenie, musíme zistiť, ako zdrojová komponenta môže dostať do cieľovej zložky. A to znamená pri pohľade na celé siete a všetkých rôznych spôsobov, ako (a ciest), náš zdroj komponenta môže prijať na dosiahnutie cieľovej zložky (umývadlo).

Poznámka

Tak dlho, ako je tu aspoň človek kompletnéCesta od zdroja k cieľu, bude misia úspešnáa nepriame spojenie sa označuje ako uzavretý spojenie.

Pochopenie Link Matrix

Vedieť, ktoré súčasti / priame spoje sú spojené s tým, čo, potrebujeme artefakt rýchlo kontrolovať, či sú dva bloky spojené v určitom smere. Táto funkcia článkovej matrice. Stručne povedané, spojenie matice je dvojrozmerné pole boolovských premenných, ktoré stanovujú, či je konkrétna zložka môže dosiahnuť ďalší krok priamo. Jeho veľkosť je rovná štvorci celkového počtu súčastí v sieti.

Jednoduchý Spoľahlivosť Bloková schéma (RBD)

Súvisiace Link Matrix pre blokový diagram spoľahlivosti (RBD)

Pretože nie všetky spoje sú obojsmerné (bude v oboch smeroch), je dôležité vedieť, ako správne čítať prepojenie maticu. V spoľahlivosti hodnotiteľa, prvý argument je zdroj a druhý argument je cieľ (umývadlo).

Ak teda odkaz matice (A, B) = pravda, potom to znamená, že môžete dostať do B priamo (jednosmerná). B môže dostať do A keby len v prípade, odkaz matice (B, A) = true. Ak je to pravda, to znamená obojsmerné spojenie.

Vo vyššie uvedenom príklade vyššie:

· Zdroj 1 môže dosiahnuť cieľ 0 (zdroj 1 a Destination 0 dáva výsledok true); a

· Source 0 môže dosiahnuť cieľ 1 (zdroj 0 a Cieľ 1 dáva výsledok true), ako je súvislosť medzi 0 a 1 je obojsmerný.

· Zdroj 2 nemožno dosiahnuť cieľ 1 (zdroj 2 a Cieľ 1 dáva výsledok False), aj keď zdroj 1 môže dosiahnuť cieľového 2 (zdroj 1 a cieľ 2 dáva výsledok True). To znamená, že je spojenie medzi 1 a 2 je uni-riadiaci.

Pochopenie spoľahlivosť Block Diagram

Spoľahlivosť blokový diagram (RBD) zapuzdruje štruktúru celého modelu objektu, pokiaľ ide o bloky a odkazov. Každý blok predstavuje prvok, ktorý má možnosť úspešnosti alebo neúspešnosti v závislosti na Odkazy / ciest, ktoré ich spájajú. Obe zložky a spojenie sa môže stať "blok" v oblasti povodia.

Príklad RBD bloky a odkazy

Postava vyššie predstavuje príklad RBD. Prerušovaná červená čiara predstavuje jednoduchú misiu 4 na 1. Poznámka: ako tam sú len dve možné cesty k misii 4 na 1.

Vezmime si cestu 4: 3 na 0 na 1 a trasu 4 až 7 do 1. bodkovanou bloky 2, 5a 6 predstavujú bloky, ktoré nemajú vplyv na zlyhanie / non-zlyhanie misie 4 na 1. Sú nezohľadňuje a sú ignorované. To je dôležité, pretože pre väčšinu misie bude veľký počet redundantných bloky, ktoré nebude mať vplyv na úspešnosť konkrétneho misie. To je viac viditeľný vo väčších sieťach, pričom počet redundantných blokov bude výsledky simulácie nepresné.

Pre urýchlenie simulačné čas, a zaistí presnejšie výsledky, je nevyhnutné abstraktné z celej povodia a použiť len tie prvky, ktoré majú vplyv na úspešnosť danej misie.

Poznámka

Jediná cesta / cesta nemôže prejsť ktorúkoľvek zložku dvakrát.

V tejto fáze môžeme vytvoriť odkaz matice a vykonávať simulácie Monte Carlo.

Výpočet Architektúra Dostupnosť

Architektúra dostupnosť je pravdepodobnosť, že všetky nepriame pripojenie bude k dispozícii v každom okamihu. Dostupnosť každej nepriame spojenie určuje pri každom opakovaní simulácie Monte Carlo, však tieto nepriame spojenie (typicky) spoliehajú na rovnaký súbor fyzických prvkov. Preto, jednoducho agregáciu tieto jednotlivé dostupnosti by "double-počet" týchto un-hotely sú voľné, čo pesimistický celkovú architektúru dostupnosť. Alternatívne, celková architektúra dostupnosť sa vypočíta pri pohľade na každej iterácii a vidieť, či sú k dispozícii prvky, podieľajúce sa na nepriame pripojenie záujmu. A potom súčtom týchto výsledky na konci cvičenia.

Spustenie spoľahlivosť simulátor

Pre simuláciu vašej architektúry z hľadiska spoľahlivosti

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Vybrať Rozbor| Spoľahlivosť.

3. Vyberte StaviteľstvoAk chcete zhodnotiť z rozbaľovacieho menu.

Poznámka

V predvolenom nastavení bude ABACUS automaticky vyberte prvú architektúru, pre ktoré je z dôvodu požaduje nové simulácie na akejkoľvek nehnuteľnosti alebo štrukturálnych zmien.Toto zvýraznenie je uvedené v Red na Panel nástrojov Simulácia .

4. Vyberte Komponentya PripojenieAk chcete zhodnotiť od okno pre výber štandardným prvkom pomocou "Zobraziť priame spojenie 'a' show procesy zapojenia na radio-Button Filters v ľavej dolnej časti dialógového okna k pomoci s výberom vás.

Dodatočný Checkboxk okno pre výber štandardným prvkom

· Save prevádzal modelvôľa uložiť kópiu RBD transformovaného verzia projektu v rovnakom priečinku ako aktuálny projekt a pridať "_transformed" k názvu projektu.Tento transformovaný projekt možno využiť na diagnostike podrobne simuláciu spoľahlivosti podnikané ABACUS.

Ďalšie Radio-Tlačidlák okno pre výber štandardným prvkom

· Ukázať priame spojenie automaticky nastaví bolo prepojenie filtra majetku za Typ nehnuteľnosti = Správanie, Name = Abstrakcia a hodnota = priama.Táto voľba je vybratá v predvolenom nastavení a pomáha výber "priame" spojenie, ako je popísané vyššie a nižšie.

· Zobraziť procesy Pripojenie automaticky nastaví bolo prepojenie filtra majetku za Typ nehnuteľnosti = Správanie, Name = Vzťah a Hodnota = procesov.Táto možnosť napomáha výber "priame" spojenie, ako je popísané vyššie a nižšie.

5. Kliknite na tlačidlo Budúci.

6. Vyberte si Misietj Pripojenie budete chcieť zahrnúť do simulácie.

7. Nastavenie Run Time Scale Factorslider.

Poznámka

Vyššie hodnoty prinesie viac štatisticky konzistentné výsledky, ale trvať dlhšiu dobu pre výpočet.

Checkboxes

· Show Uzavreté Pripojenievôľa automaticky filtrovanie dostupných pripojenie k obsahujú iba tie, ktoré majú aspoň jednu úplnú fyzickú cestu zo zdrojovej zložky, ktorá sa v cieľovej zložky podľa výberu RBD popísané vyššie.

· Ukázať Nepriame pripojenie automaticky nastaví bolo prepojenie filtra majetku za Typ nehnuteľnosti = Správanie, Name = Abstrakcia a hodnota = nepriame.Táto voľba je vybratá v predvolenom nastavení a pomáha výber "nepriame" alebo Mission pripojenie, ako je popísané vyššie a nižšie.

Tlačidlá

· Všetcivyberie všetky Pripojenie.

· Obrátiťzruší všetky aktuálne vybraná Pripojenie a vyberie všetky tie, ktoré neboli vybrané.

· Žiadnyzruší výber všetky Pripojenie.

Ďalšie možnosti

· Run Time Scale Factor reguluje doba, simulácie a presnosť s vyšším Hodnoty výnosIngviac štatisticky konzistentné výsledky, ale prevzatia dlhší čas beh.

Poznámka

Pri ABACUS vypočítava počet iterácií simulovať to bude určovať najspoľahlivejšie prvok, ktorý nie je dokonale spoľahlivé a potom simulovať na Run Time Scale Factor časov 1 nad nedostupnosti tohto prvku a 1 opakovanie. Alebo (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. To je, aby sa ubezpečil, že tento prvok stále nedarí aspoň raz v simulácii. Napr. V prípade, že najspoľahlivejšie prvok, ktorý nie je dokonale spoľahlivá má MTBF 10.000 hodín a MTTR 8 hodín, potom simulácie bude trvať (10,000 + 8) / 8 = 1251 krát faktor Run časové meradlo + 1 iterácií.

· Roky simulovať Ahead určuje počet rokov pre misie spoľahlivosť byť vypočítaná pre.

· Nžltohnedý závitovdetermines počet spracovateľských vlákien použitých pre simulácie Monte-Carlo.Táto voľba bude východzí zodpovedal počtu dostupných CPU / jadra (vrátane Hyper-Threading jadra), aby sa minimalizovalo celkovej simulačné čas.

8. Kliknite na tlačidlo Skončiťa získate Výstrahadialóg.

9. Voliteľne preskúmať varovanie kliknutím Podrobnosti >>.

10. Kliknite na tlačidlo Pokračovať.

Poznámka

V tomto okamihu, ABACUS sa vykonať Monte-Carlosimulácia architektúry a po krátkej dobe (s barmi pokroku pre spätnú väzbu), zobrazí sa dialógové okno výpočet kompletný.

11. Kliknite na tlačidlo OKuznať simuláciu.

Tip

Pre organizovanie školení a ďalšiu pomoc na spoľahlivosť Simulácia nájdete na Avolution Community .

Komponentov a pripojenie vlastnosti

V nasledujúcej tabuľke sú uvedené komponenty a"priame"požadované vlastnosti pripojenia k hodnotenie spoľahlivosti. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou vstup nehnuteľnosť voliča riadku ( [image] ) S bubline "Spoľahlivosť Input". Zmena na niektorú z týchto "vstup" vlastností a rôznych štrukturálnych zmien úložiska bude mať za následok spoľahlivosti simulátore vyžadujúce re-simulácie, ako je uvedené v Red na Panel nástrojov Simulácia .

Druh | Názov | Predvolená hodnota | Jednotka | Typ dát | Povinné | Popis
Spoľahlivosť | MTBF | ∞ | rokov, týždne, dni alebo hodiny | Desatinné | Pravdivý | Priemerná doba pred výpadkom prvku. Poznámka: Hodnoty môžu byť vyjadrené v jednotkách rokov, týždňov, dní alebo hodín a sú premenené na základe vo 24/7 'obsadenosť koncepcie takto; - 1 rok = 52 týždňov alebo 365 dní alebo 8760 hodín - 1 týždeň = 7 dní alebo 168 hodín - 1 deň = 24 hodín
Spoľahlivosť | MTTR | 0 | rokov, týždne, dni alebo hodiny | Desatinné | Pravdivý | Priemerná doba do opravy prvku. Poznámka: Hodnoty môžu byť vyjadrené v jednotkách rokov, týždňov, dní alebo hodín a sú premenené na základe vo 24/7 'obsadenosť koncepcie takto; - 1 rok = 52 týždňov alebo 365 dní alebo 8760 hodín - 1 týždeň = 7 dní alebo 168 hodín - 1 deň = 24 hodín

V nasledujúcej tabuľke sú uvedené komponenty a"priame" Vlastnosti pripojenia na výstup spoľahlivosti hodnotiteľom. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Spoľahlivosť Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a spoľahlivosť simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Spoľahlivosť | Spoľahlivosť - x rokov |  | Desatinné | False | Pravdepodobnosť, že element nezlyhá v najbližších x rokov. Toto je hodnota medzi 0 a 1.
Spoľahlivosť | Nespoľahlivosť - x rokov |  | Desatinné | False | Pravdepodobnosť, že prvok sa nepodarí v nasledujúcich x rokov. Toto je hodnota medzi 0 a 1.
Spoľahlivosť | Obsadenosť | % | Desatinné | False | Vypočítaná dostupnosť zložky alebo pripojenie. Toto je hodnota medzi 0% a 100%.
Spoľahlivosť | Nedostupnosť | % | Desatinné | False | Vypočítaná nedostupnosť zložky alebo pripojenie. Toto je hodnota medzi 0% a 100%.

V nasledujúcej tabuľke sú uvedené 'nepriamy'Vlastnosti pripojenia na výstup spoľahlivosti hodnotiteľom. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Spoľahlivosť Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a spoľahlivosť simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Spoľahlivosť | Misie Spoľahlivosť - x rokov |  | Desatinné | False | Pravdepodobnosť, že nepriame spojenie nezlyhá v najbližších x rokoch. Toto je hodnota medzi 0 a 1.
Spoľahlivosť | Misie Nespoľahlivosť - x rokov |  | Desatinné | False | Pravdepodobnosť, že nepriame pripojenie zlyhá v nasledujúcich x rokov. Toto je hodnota medzi 0 a 1.
Spoľahlivosť | Obsadenosť | % | Desatinné | False | Vypočítaná dostupnosť nepriame pripojenie. Toto je hodnota medzi 0% a 100%.
Spoľahlivosť | Nedostupnosť | % | Desatinné | False | Vypočítaná nedostupnosť nepriame pripojenie. Toto je hodnota medzi 0% a 100%.

Vlastnosti Architektúra

V nasledujúcej tabuľke sú uvedené vlastnosti architektúra výstupu o spoľahlivosti hodnotiteľa. Tieto vlastnosti sa zobrazí v okne Vlastnosti s ikonou výstupom nehnuteľnosť voliča riadku ( [image] ) S bubline "Spoľahlivosť Output". Šípka na ikonu zdôrazní Red ( [image] ), Ak tieto vlastnosti sú zastarané v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko a spoľahlivosť simulátore vyžaduje opätovné simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Druh | Názov | Jednotka | Typ dát | Povinné | Popis
Spoľahlivosť | Obsadenosť | % | Desatinné | False | Dostupnosť všetkých nepriame pripojenie, ktoré boli zahrnuté do hodnotenia. To znamená, že pravdepodobnosť, že všetcinepriame pripojenie bude k dispozícii v danom okamihu. Toto je hodnota medzi 0% a 100%. Poznámka: Toto nie je násobenie jednotlivých pripojení dostupnosti pretože by to bolo "duplicitám" OSN dostupnosti príslušnej zložky.
Spoľahlivosť | Nedostupnosť | % | Desatinné | False | Nedostupnosť nepriamych pripojenie, ktoré boli zahrnuté do hodnotenia. To znamená, že pravdepodobnosť, že aspoň jedennepriame spojenie bude k dispozícii v danom okamihu. Toto je hodnota medzi 0% a 100%. Poznámka: Toto nie je násobenie jednotlivých pripojení unavailabilities pretože by to bolo "duplicitám" OSN dostupnosti príslušnej zložky.
Spoľahlivosť | Misie Spoľahlivosť - x rokov |  | Desatinné | False | Pravdepodobnosť, že všetky nepriame pripojenie, ktoré boli zahrnuté do hodnotenia bude to zlyhanie počas budúcej xroky. Toto je hodnota medzi 0 a 1. Poznámka: toto nie je násobenie jednotlivých pripojení spoľahlivosťou pretože by to bolo "duplicitám" OSN dostupnosti príslušnej zložky.
Spoľahlivosť | Misie Nespoľahlivosť - x rokov |  | Desatinné | False | Pravdepodobnosť, že aspoň jedna z nepriame pripojenie, ktoré boli zahrnuté do hodnotenia sa nepodarí počas nasledujúcich xroky. Toto je hodnota medzi 0 a 1. Poznámka: toto nie je násobenie jednotlivých pripojení unreliabilities pretože by to bolo "duplicitám" OSN dostupnosti príslušnej zložky.


Simulácie vašej architektúry

Navigácia: Simulácia vašej architektúry>

Simulácie vašej architektúry

Odoslať pripomienky na túto tému.

Potom, čo ste obývaných a analyzované vašej architektúry, ste pripravení na použitie Abacus na zistiť, či váš architektúra bude vyhovovať vašim potrebám kvantitatívne. To si vyžaduje Simulácia, Pre simuláciu vašej architektúry, musíte najprv rozhodnúť o druhu informácií, ktoré chcete nájsť. Tieto typy informácií, sú často označované ako KPI, alebo kľúčových ukazovateľov výkonnosti. Napríklad, chcete analyzovať výkon, evolvability, a otvorenosť, alebo chcete získať metriky, ako sú celkové náklady na vlastníctvo. Všetky tieto informácie môžu byť odhalený nejakým spôsobom. Akonáhle máte tieto dáta, budete schopní analyzovať vašej architektúry v rôznych grafických formátov (alebo analyzovať nové hodnoty priamo).

Existujú tri možnosti pre simuláciu vašej architektúry:

· Jednoduché metriky ;

· Pre-postavené simulátory ; alebo

· Scripting .

Jednoduché Metrics

Každá zložka v architektúre má vlastnosti - z ktorých mnohé môžu byť zvyk vašej aplikácii ABACUS. Tieto vlastnosti predstavujú rôzne vlastnosti komponentov. V niektorých prípadoch, jednoducho zberu týchto metriky (stavať KPI), môže byť dosť, aby vám povedať, dôležité informácie o vašej architektúre. Napríklad, KLOCS, alebo tisíce riadkov kódu, boli široko používané ako miera zložitosti. V iných prípadoch, možno budete chcieť export dát a analyzovať ho pomocou iného nástroja. Navyše, možno budete chcieť zbierať vlastností po vykonaní iný druh simulácie.

Vlastnosti môžu byť zhromažďované prostredníctvom procesu agregácie , Agregácie dodáva uvedenej podvlastnosti celkom, ktorý sa odráža v nadradenej zložky. Agregácie funguje len u komponentov, ktoré obsahujú čiastkové komponenty.

Pre-postavené Simulátory

Existuje päť prednastavených simulátory, ktoré môžu byť použité s ABACUS. Sú to:

· Výkon;

· Modularita;

· Celkové náklady na vlastníctvo (TCO);

· Otvorenosť; a

· Spoľahlivosť.

Poznámka

ABACUS automaticky zvýrazní, ktoré z týchto simulátorov je potrebné znovu spustiť prostredníctvom Red zvýraznenie na Panel nástrojov Simulácia .

Scripting

Skriptovanie poskytuje flexibilitu pre simuláciu vašej architektúry vo vlastných cestách. Podľa písanie skriptov môžete vykonávať simulácie mimo prúd v vybudovanej kapacity ABACUS. Celý model objektu ABACUS je k dispozícii skriptovací engine, takže ste obmedzení iba na vašej schopnosti písať skripty!

Visual Basic Script je skriptovací jazyk podporovaný ABACUS, pretože poskytuje základné programovacie funkcie v primerane jednoduchom formáte.

Pozri tiež

Export vašej architektúry | Súhrnné vlastnosti | Písanie skriptov


Vyvíjajúce vašej architektúry

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Vyvíjajúce vašej architektúry

Odoslať pripomienky na túto tému.

Architektúry môže byť explicitne vyvíjal a hierarchie architektúr vytvorená. Tak by vyvíjajúci svoju architektúru v ABACUS, môže byť vytvorená rad pokročilých architektonických riešení, porovnanie a baselined. Cieľa (alebo metriky) možno definovať pre ľubovoľný počet architektonických vlastností pre existujúce architektúry.

Jednoduchý spôsob, ako vziať do úvahy vývoj architektúry, je to súvisí s konceptom potomok architektúra, Keď je architektúra sa vyvinula, je kópiematerskej architektúry je vytvorený. Tento výtlačok môže byť povedal, aby priamy potomokoriginálu rodičarchitektúru.

Poznámka

V tomto on-line dokumentáciu pomocníka a Abacus sada nástrojov sám, termín vyvinúťje viac bežne používaný ako pojem potomokUpozorňujeme, že obe odkazujú na rovnakú funkciu.

Pre ďalší vývoj existujúcej architektúry

1. Skontrolujte, či máte ABACUS súborotvorené a Okno Prieskumníkazobrazené.

2. Vyberte príslušnú architektúru, ktorú chcete vyvíjať z Prieskumníka stromu.

3. Kliknite pravým tlačidlom myšina architektúru a vyberte Vyvinúťz menu.

Vyvíjajúce The Chosen Architecture

4. Vyvinutého architektúra sa objaví pod vybranú architektúry.

Evolved Architektúra

Poznámka

Vyvinutého architektúra môže byť premenovaný kliknutím pravým tlačidlom myši na architektúru a výberu Premenovať.Navyše, všetky diagramy a katalógy v architektúre sa vyvinul sa automaticky nastaví na "diff" proti základnej architektúry že bol vyvinutý z.

Stanovenie cieľov pre váš vyvinul architektúru

Stanovenie cieľov pre váš vyvinula architektúru umožňuje vytvoriť kritériá pre posúdenie vývoja svojich architektúr. Ciele sú stanovené typy vlastníctva a názvy týchto vlastností existujúcich v vyvinulo architektúre. Ciele môžu byť tiež ručne definované a pridal k vám architektúre. Postupujte podľa pokynov stanovených cieľov.

Stanovenie cieľov z existujúcich vlastností pre vašu vyvinul architektúru

1. Skontrolujte, či máte ABACUS súborotvorené a Okno Prieskumníkazobrazené.

2. Vyberte Nástroje | Stanovených cieľovZ hlavného menu.

3. Cieľ VstupZobrazí sa okno.

Cieľ okno vstupného

4. Kliknite na ExistujúceTlačidlo.

5. Vyberte vlastnosťZobrazí sa okno.

6. Vyberte vlastnosť, ktorú chcete nastaviť ako cieľ pre vyvinulo architektúru a kliknite na tlačidlo OKTlačidlo.

7. Zvolený cieľ sa teraz zobrazí v Cieľ Vstupokno.

8. Vyberte cieľ a kliknite na EditTlačidlo.

9. Upraviť GoalZobrazí sa okno.

Poznámka

Toto okno umožňuje zmeniť názov vlastnosti a typ, ktorý gól bude odrážať, rovnako ako najhorší a najlepší hodnoty (alebo minimálnej / maximálnej hodnoty), pre túto vlastnosť. Tieto hodnoty sú nájdené porovnávaním všetkých architektúrach a nájsť najmenšiu a najväčšiu hodnotu v každej pre túto špecifickú vlastnosť. Tieto hodnoty môžu byť tiež ručne definované. Napríklad, ak ste mali stanovila cieľ pre vlastnosť s názvom Response (Ave)a typu SprávanieVaša najhoršia a najlepšia hodnota by mohla odrážať rýchlosť transakcie potrebné pre optimálny výkon (najlepšia hodnota) a rýchlosť transakcií potrebné len na hlavné aplikácie na spracovanie (najhoršia hodnota).

10. Potom, čo boli definované príslušnej hodnoty, vyberte OK.

Stanovenie cieľov z nových vlastností pre vašu vyvinul architektúru

1. Skontrolujte, či máte ABACUS súborotvorené a Okno Prieskumníkazobrazené.

2. Vyberte Nástroje | Stanovených cieľovZ hlavného menu.

3. Cieľ VstupZobrazí sa okno.

4. Kliknite na NovýTlačidlo.

5. Nový cieľZobrazí sa okno.

Poznámka

Toto okno umožňuje definovať názov vlastnosti a typ, ktorý gól bude odrážať, rovnako ako najhorší a najlepšiu hodnotu (alebo minimálne / maximálne hodnoty) pre túto vlastnosť. Napríklad, ak ste mali nastaviť cieľ pre vlastnosť s názvom Response (Ave)a typu SprávanieVaša najhoršia a najlepšia hodnota by mohla odrážať rýchlosť transakcie potrebné pre optimálny výkon (najlepšia hodnota) a rýchlosť transakcií potrebné len na hlavné aplikácie na spracovanie (najhoršia hodnota).

6. Potom, čo boli definované príslušnej hodnoty, vyberte OK.

7. Dialóg, Pridať do všetkých architektúrachzobrazí ako je uvedené nižšie:

8. Kliknite na Áno,pridať cieľ ako majetku na všetkých príslušných architektúr. Tým je zaistené, že novo definovaný cieľ a jeho vlastnosti budú pridané do všetkých architektúr v súbore. Ak si neželáte zahrnúť nehnuteľnosť v architektúrach, môžete kliknúť na Žiadny.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Zobrazenie hviezda sprisahania svojich vyvinutých architektúr | Zobrazenie bodový graf vašich vyvinutých architektúr


Rozbalení a zbalenie strom

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Rozbalení a zbalenie strom

Odoslať pripomienky na túto tému.

Keď uzol v strome obsahuje čiastkové komponenty a zbierok, bude to mať malý [image] alebo [image] podpísať na jeho ľavej strane. Môžete kliknite na tlačidlo [image] rozbaľte uzol a vidieť jeho čiastkové časti a pripojenie. Podobne, môžete kliknúť na [image] kolaps uzol skryť čiastkové komponenty a spojenia (tak, aby viac priestoru, alebo aby strom zrozumiteľnejšie).

Prípadne môžete rozšíriť celý uzol, v ktorom prípade všetkých jej čiastkových uzlov budú tiež rozšírené, a ich sub-uzly a ich ... atď. Rovnako tak môžete zbaliť celý uzol - uzatvorenie viacerých úrovní naraz ,

Ďalej, tam sú možnosti na rozšírenie iba architektúry, prvky (tj komponenty a prípojky), súčasti alebo pripojenie.

Ak chcete rozbaliť alebo zbaliť celý uzol (a jeho sub-uzly, atď.)

1. Kliknite pravým tlačidlom myšiv uzle.

2. Vybrať Rozbaliť | Všetci aleboKolaps.

Ak chcete rozbaliť všetky architektúry (y)

1. Kliknite pravým tlačidlom myšiNa architektúrach a architektúry.

2. Vybrať Rozbaliť | Všetci.

Ak chcete rozbaliť prvky

1. Kliknite pravým tlačidlom myšiNa architektúrach a architektúry.

2. Vybrať Rozbaliť | Prvky.

Pre rozšírenie komponentov

1. Kliknite pravým tlačidlom myšina súčiastky, komponenty alebo čiastkové komponenty.

2. Vybrať Rozbaliť | Komponenty | Všetci.

Ak chcete rozšíriť pripojenie

1. Kliknite pravým tlačidlom myšina pripojenie, pripojenie alebo čiastkového pripojenia.

2. Vybrať Rozbaliť | Pripojenie | Všetci.


Export vašu architektúru

Navigácia: Podávanie správ o vašu architektúru>

Export vašu architektúru

Odoslať pripomienky na túto tému.

ABACUS umožňuje naexportovať architektúru MDB (Microsoft Access), MS SQL Server, .abacus (ABACUS súbor), a .xls formátu (Microsoft Excel). Môžete tiež exportovať diagrams až PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF a BMP a prehľadoch .html (HTML), .pdf (Adobe Acrobat), XLS (Microsoft Excel), .doc (Microsoft Word) a .rtf (Rich Text Format) formáty. To vám umožní analyzovať a zobraziť architektúru a jeho dáta akýmkoľvek spôsobom chcete.

Ak chcete exportovať svoju architektúru MDB (Microsoft Access)

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Kliknite na Súborponuka.

3. Vybrať Export, a potom Ak chcete MDB.

4. Vezmite na vedomie upozornenie a kliknite na tlačidlo OK.

5. Zadajte názov súboru.

6. Kliknite na tlačidlo SaveButton.

Poznámka

Vývoz Formát databázy MDB je špecifické pre ABACUS a akékoľvek zmeny schémy bude mať za následok nemožnosť spätného dovozu. Pozri Naplnenie s MS Access pre opis schémy MS Access.

Ak chcete exportovať architektúru MS SQL Server

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Kliknite na Súborponuka.

3. Vybrať Export, a potom Pre MS SQL Serveru.

4. V dialógovom okne, ktoré sa objavia kliknite na tlačidlo Export Blank MDB ...Tlačidlo a importovať do vášho databázového servera MS SQL Server.

5. Vyplňte informácie o databázy a reťazec pripojenia.

6. Kliknite na tlačidlo ExportButton.

Poznámka

Vývoz formát MS SQL ServerDatabáza je špecifické pre ABACUS a akékoľvek zmeny schémy bude mať za následok nemožnosť spätného dovozu. Pozri Naplnenie s MS Access pre opis schémy databázy.

Ak chcete exportovať svoju architektúru .xls (súbor Excel)

1. Skontrolujte, či máte ABACUS otvoriť súbor , Což Zobrazí explorer , A architektúra pridané .

2. Skontrolujte, či máte Excel import / export konfigurácie súbor definované.

3. Kliknite pravým tlačidlom myšina architektúre vo vašom modeli alebo akákoľvek časť Komponentyuzol (v rámci danej architektúry), ktorý chcete exportovať do konfiguračnom súbore Excel.

4. Vybrať Export | K Excel ... z menu.

5. Vyberte Excel Import / Export Configuration súbor sa má použiťsa zobrazí okno.

6. Vyberte príslušnú konfiguračný súbor pre váš architektonický model a kliknite na tlačidlo OtvorenéTlačidlo.

7. Ak tomu tak nie je automaticky neurobili, mapa zložky najvyššej úrovne v aktuálnom architektúry širokej Set Id(ako je definované vyššie) a kliknite na Exportovať ....

Mapovanie Príklad najvyššej úrovne Component

8. Vyberte umiestnenie a názov súboru pre súbor programu Excel a kliknite na tlačidlo SaveTlačidlo.

Ak chcete exportovať svoju architektúru .abacus (ABACUS súbor)

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Kliknite pravým tlačidlom myšina uzle Architecture, ľubovoľné počítačovej architektúre, vo vašom modeli alebo akákoľvek časť zložiek stromu.

3. Vybrať Export | K Súbor ...z menu.

4. Vyberte umiestnenie a názov súboru a kliknite na tlačidlo SaveTlačidlo.

Poznámka

Môžete importovať súbor ABACUS späť do ABACUS podľa nasledujúcich krokov 1-2vyššie a výberom Dovoz | Z Súbor ..., Potom, čo ste vybrali súbor, ktorý chcete importovať, sa otázka, ako by ste chceli importovať štandardy a typy. Môžete importovať štandardy a typy ako nové alebo zlúčených noriem a typov. Predvolené nastavenie je pre štandardy a typy, ktoré majú byť zlúčené s existujúcich štandardov a typov, ak už existujú vo vašom projekt.

Ak chcete exportovať svoju architektúru .xml

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Kliknite pravým tlačidlom myšina uzle Architecture, ľubovoľné počítačovej architektúre, vo vašom modeli alebo jeho časť z komponentov stromu.

3. Vybrať Export | K XML ...z menu. Prípadne môžete kliknúť v ponuke Súbor| Export| K XML ...

4. Vyberte umiestnenie a názov súboru a kliknite na tlačidlo SaveTlačidlo.

Poznámka

Môžete importovať súbor XML späť do ABACUS podľa nasledujúcich krokov 1-2vyššie a výberom Dovoz | Z XML ..., Potom, čo ste vybrali súbor XML, ktorý chcete importovať, sa otázka, ako by ste chceli importovať štandardy a typy. Môžete importovať štandardy a typy ako nové alebo zlúčených noriem a typov. Predvolené nastavenie je pre štandardy a typy, ktoré majú byť zlúčené s existujúcich štandardov a typov, ak už existujú vo vašom projekt.

Ak chcete exportovať diagramu do PNG, JPG, SVG, TIFF, GIF alebo BMP

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Otvorte diagramchcete exportovať.

3. Kliknite na Export DiagramTlačidlo na Diagram panel nástrojov.

4. Export DiagramObjaví sa okno.

5. Vyberte Brouzdattlačidlo pre uloženie vizualizáciu na požadované miesto.

6. Vyberte Uložiť ako typpull-down menu vyberte typ súboru.

7. Kliknite na tlačidlo SaveTlačidlo.

Ak chcete exportovať svoju správu vo formáte pdf (Adobe Acrobat), XLS (Microsoft Excel)alebo.doc (Microsoft Word)

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Vytvoriť správa chcete exportovať.

3. Kliknite na ExportTlačidlo na paneli nástrojov správ.

4. Vybrať Excel, PDF alebo Wordz rozbaľovacieho zoznamu.

5. Počkajte niekoľko okamihov, zatiaľ čo vývoz správy.

6. Vyberte umiestnenie a názov súboru a kliknite na tlačidlo SaveTlačidlo.


Vyhľadanie a nahradenie položky v architektúre

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Vyhľadanie a nahradenie položky v architektúre

Odoslať pripomienky na túto tému.

Môžeš nájsť a nahradiť pre určitú zložku, pripojenie, typ, štandardné alebo vlastnosť pomocou Abacus "Nájsť a nahradiť zariadení.

Ak chcete nájsť položku

1. Kliknite uzol stromu, ktorý chcete hľadať v.

2. Vybrať Edit| Nájsťalebo stlačte Ctrl + F.

3. Zadajte text pre položkanájsť v "Nájsť čo" poľa.

4. Kliknite na tlačidlo Nájsť ďalšie.

K vymeniť položka

1. Kliknite uzol stromu, ktorý chcete hľadať v.

2. Vybrať Edit| Nahradiťalebo stlačte Ctrl + H.

3. Zadajte text prepoložkanájsť v 'Nájsť čo polia a text nahradiť ho v' Nahradiť 'pole (alebo ak na poli nič nie je ponechané prázdne).

4. Kliknite na tlačidlo Nájsť ďalšienájsť prvé inštancie "Nájsť čo 'text a kliknite na tlačidlo Nahradiť nahradiť tento výskyt s 'Nahradiť' text alebo kliknite na tlačidlo Nahradiť všetkoktorý nahradí všetky inštancie.

Máte možnosti pre:

o Prispôsobte svoj prípad,

o Prispôsobte celé slovo,

o Hľadať od začiatku projektu,

o Ignorovať architektúry - to je architektúra uzly sami. Všetky uzly pod uzlov architektúry, ako sú komponenty a spojenie bude stále hľadal,

o Ignorovať komponenty - to je súčasť uzly sami,

o Ignorovať pripojenie - to je spojenie uzly sami,

o Ignorovať noriem - to je všetky štandardné uzly architektúra, komponenty a pripojenia budú ignorované,

o Ignorovať typov - to je typ uzly sami. Akékoľvek obmedzovačmi uzly pod uzly typu bude stále hľadal,

o Ignorovať šablóny a obsah -, že je šablóna uzly seba, ako aj niektorá časť šablóny a uzly pripojenie pod nimi,

o Ignorovať vlastnosti - to je všetky typy vlastníctva, mena, hodnoty a jednotky všetkých prvkov tohto modelu budú ignorované,

o Ignorovať názvami - to je popisy všetkých prvkov údajov modelu budú ignorované.

Pozri tiež

Ako sa architektúra zastúpená v ABACUS


Pomoc v iných jazykoch

Navigácia: Úvod do ABACUS>

Pomoc v iných jazykoch

Odoslať pripomienky na túto tému.

ABACUS nápoveda je k dispozícii v rôznych iných jazykoch / preklady a možno ho stiahnuť z nižšie uvedených odkazov.

K nahradiť aktuálny ABACUS súbor pomocníkas preložených súborov pomocníka postupujte podľa nasledujúcich krokov:

1. Uložte súbor Pomocníka z príslušnej odkaz nižšie.

2. Premenujte súbor pomocníka na ABACUS.chm.

3. Otvorte súbor poklepaním, a ak za "Otvoriť súbor - upozornenie zabezpečenia" zobrazí dialógové okno a potom zrušte zaškrtnutie "Vždy zobraziť dotaz pred otvorením súboru" možnosť a kliknite na tlačidlo Otvoriť.

4. Zatvorte súbor.

5. Nahradiť súbor ABACUS.chm do priečinka Program Files ABACUS, typicky "C: \ Program Files \ Avolution \ ABACUS"Alebo"C: \ Program Files(x86)\ Avolution \ ABACUS".

Poznámka

Kontextová nápoveda bude aj naďalej spolupracovať s preloženými súbory pomocníka.

Súbory pomocníka Abacus v iných jazykoch:

· Arabčina / العربية .

· Bulharčina / български .

· Chinese (Simplified) / 中文 (简体) .

· Čeština / Česká .

· Dánsky / Dansk .

· Estónsky / Eesti .

· Fínsky / Suomen .

· Francúzsky / Français .

· Nemec / Deutsch .

· Maďarčina / Magyar .

· Islandský / Islandský .

· Indonézsky / Indonézia .

· Taliansky / Italiano .

· Japonský / 日本 の .

· Lotyšský / Latvijas .

· Malajzijské / Malajzia .

· Maltčina / Slad i .

· Norweigen / Norweigen .

· Poľský / Po Španielska .

· Portugalčina / Português .

· Ruský / русский .

· Slovenský / Slovenskí .

· Slovinčina / Slovenski .

· Španielsky / Españoles .

· Švédsky / Svenska .

· Turečtina / Türk .

· Waleský / Cymraeg .

Pozri tiež

Čo ABACUS robiť?


Ako sa architektúra zastúpená v ABACUS?

Navigácia: Úvod do ABACUS>

Ako sa architektúra zastúpená v ABACUS?

Odoslať pripomienky na túto tému.

V ABACUS, modelovať svoju architektúru. Pre jednoduchosť nazývame tento architektonický model architektúra.

Nižšie uvedený graf ukazuje, ako typickú architektúru 5komponenty (v hierarchii) prepojené 2 spojov by byť zastúpené v ABACUS.

Ako jednoduché architektúra je zastúpená v ABACUS

Môžete mať ľubovoľný počet architektúr v jedinom súbore ABACUS.

Prvá architektúra vo stromu

Obvykle by ste vytvoriť novú architektúru, kedykoľvek budete chcieť vyhodnotiť zmenu. Napríklad, mali by ste modelovať svoje existujúce architektúry Prvý z nich - to by bol prvý architektúra v strome. Dalo by sa nazvať "Current".

Druhy

Ak chcete modelovať a vyhodnocovať zmenu vášho existujúceho architektúry (napr zvýšené nároky) by ste vytvoriť novú architektúru. Najjednoduchší spôsob, ako to urobiť, by bolo vytvoriť kópiu "Current" a premenujte ho "vývoj 1 Pokus 1". To by bol druhý architektúra v strome. Ak vaše hodnotenie "vývoj 1 Pokus 1 'sú úspešné, môžete premenovať ju jednoducho" Evolution 1'.

Tretia

Ak je "Evolution 1 pokus 1 'nespĺňa vaše požiadavky, môžete vytvoriť kópiu, premenovať ju na" Evolution 1 Pokus 2 ", a skúste to znova. To by bolo tretie architektúra v strome.

Pozri tiež

Čo ABACUS robiť? | Ako to robíte (prehľad) | Čo je to architektúra? | Práca so súbormi ABACUS | Vytvorenie alebo duplikovanie architektúru


Ako používať počítadlo (prehľad)

Navigácia: Úvod do ABACUS>

Ako používať počítadlo (prehľad)

Odoslať pripomienky na túto tému.

Táto téma obsahuje základný prehľad o úlohách, ktoré sa zaoberajú pomocou Abacus.

Nasledujúci diagram ilustruje architektúru na báze analýzy proces, ktorý ABACUS zaisťuje vyvíjajúci aktuálneho architektúru do novej alebo cieľovej architektúry.

Počítadlo proces

Ak chcete používať počítadlo:

1. Audit - Pred použitím Abacus, je potrebné zhromaždiť všetky informácie, ktoré máte o architektúre, a jeho požiadavky.

· Staviteľstvo - Identifikovať potenciálne komponenty architektúry a ako sú vzájomne prepojené. Tam by malo byť len niekoľko komponentov na špičkovej úrovni. Jedná sa o tzv "základnými zložkami". Dokonca aj tie najzložitejšie architektúry by mal mať menej ako 10 základné zložky. napr. Základnými prvkami architektúry poisťovne môže byť politika, potvrdenky, nároky, a platby.

· Požiadavky- Musíte vedieť, čo sa očakáva od architektúry za účelom zistenia, či je uspokojivý. napr. Počet transakcií za hodinu.

· Kde ho nájdete? - Tieto informácie môžu pochádzať od špecifikácií požiadaviek, projektovej dokumentácie, rozhovory so zainteresovanými subjektmi, nasadené kódu, atď podstate akýkoľvek materiál, ktorý je k dispozícii ponúka ABACUS informácie o architektúre.

2. Osídliť -Použite Abacus modelovať vašej architektúry a špecifikovať požiadavky architektúra bude meranie.

· Staviteľstvo - V ABACUS začnete s prázdnym architektúrou - musíte osídliťza to. To znamená, že zadávanie všetky informácie o architektúre ste zhromaždili v predchádzajúcom zozname. Môžete naplniť svoju architektúru ručne (pomocou pravého tlačidla myši), alebo môžete automaticky naplniť ju (z aplikácie Microsoft Visio, Excel, Access, atď). Typicky top-väčšina levelov (viac abstraktné) tejto architektúry sa vyplní ručne, a nižšie úrovne (konkrétnejšie) sa vyplní automaticky.

· Požiadavky - Ako môžete pridať súčasti a pripojenie, zadáte ich vlastnosti. Vo väčšine prípadov sa tieto vlastnosti požiadavky architektúry. Napríklad, ak budete mať 1250 MIPS uzla / cluster, mali by ste pridať uzol ako súčasť, pridajte vlastnosť výkon, a priradiť hodnotu 1250 MIPS.

3. Analyzujte - Použite Abacus sa elegantne analýzu a vizualizáciu zložitú štruktúru vašej architektúre.Vy môže analyzovať architektúry v mnohých spôsoby, alebo z radu hľadísk, vrátane diagramy, 3D a Explorer. Alebo budete chcieť používať niektoré konkrétnejšie názory takto:

· Graf vašej architektúry - dostať výkon (doba odozvy, šírku pásma, etc.), náklady (bar, koláče, atď.), Alebo evolvability (schopnosť priestor, trade-off, atď.), Výhľad.

· Vytvoriť správu o vašej architektúre.

4. Simulovať - Použite Abacus simulovať vašu architektúru je výkon, dostupnosť, náklady, otvorenosť, atď

· Ak chcete urobiť, spustite niektorý z simulátorov. ABACUS hodnotí Váš architektúra proti vašim požiadavkámprevedením simulácie. To číta a analyzuje súčasný architektúru, beží simulácie a vypočítava niektoré nové vlastnosti. Tieto vlastnosti sú potom uložené späť do architektúry. Tieto nové vlastnosti sú údaje sa snažíte analyzovať, ako je využitie, doba odozvy, šírka pásma,% dostupnosť, atď TCO

5. Inžinier- Použite ABACUS odpovedať rôzne "čo keby" scenárov a kontrolovať vývoj vašej architektúre. Engineering je proces opakujú Naplniť - Analýza - Simulovaťcyklus.

· V tomto bode, vy'sompravdepodobne vyvinul pochopenie aktuálnej architektúry, a upozornil na oblasti, ktoré potrebujete vyvíjať. Docela často, však, budete musieť opakovať naplniť - Analýza - simulovať proces niekoľkokrát. To bude pravdepodobne preto, že môže trvať niekoľko iterácií, než nájdete cieľovej architektúry. Tiež, ak vaša architektúra je veľmi zložité, možno budete chcieť, aby proces opakovať pre každú architektonickú "úroveň".

6. Plánovaťbudúcnosť vašej architektúre na základe informácií poskytnutých ABACUS.

Poznámka

Ak Nesnažíme sa vyvíjať existujúce architektúry, možno budete musieť opakovať niektoré kroky niekoľkokrát, a v inom poradí. Záleží na tom, čo sa snažíte do. Napríklad, ak ste navrhovaní novej architektúry, budete pravdepodobne len naplnenie vašej architektúry raz, a potom použite počítadlo po dlhú dobu, ako vodítko pre ďalší vývoj (y) architektúry. Na druhú stranu, ak si kupujete novú architektúru a majú niekoľko alternatív na výber, budete musieť objaviť a vyplnenie pre každú z alternatív, a potom analyzovať a simulovať každý z nich nezávisle na sebe pred uskutočnením konečnej porovnanie na end.

Pozri tiež

Čo ABACUS robiť? | Čo je to architektúra? | Ako sa architektúra zastúpená v ABACUS? | Naplnenie vašej architektúry | Analýza vašej architektúry | Simulácie vašej architektúry


Import do svojej architektúry

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Import do svojej architektúry

Odoslať pripomienky na túto tému.

ABACUS umožňuje dovážať do Vaše architektúra Z .abacus (ABACUS súbor), XML (XML fragment ABACUS alebo XML súbor ArchiMate Interchange Language), VSD (Microsoft Visio), formát, a XLS (Microsoft Excel) formát. To vám umožní budovať svoj architektúry z vonkajších zdrojov rýchlo.

K import Vaše architektúra z.abacus (ABACUS súbor)

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Kliknite pravým tlačidlom myšina uzle Architecture, ľubovoľné počítačovej architektúre, vo vašom modeli alebo akákoľvek časť zložiek stromu.

3. Vybrať Dovoz| Z Súbor ...z menu.

4. Vyberte si miesto a .abacus súbor a kliknite na tlačidlo OtvorenéTlačidlo.

Poznámka

Potom, čo ste vybrali súbor, ktorý chcete importovať, sa otázka, ako by ste chceli importovať normy, typya vyhliadky, Môžete importovať štandardy, typy a vyhliadky buď ako nových alebo zlúčené normy, typya vyhliadky, Predvolené nastavenie je pre štandardy, typy a vyhliadky sa spojil s existujúcimi štandardmi, typy a vyhliadky ak už existujú (s rovnakým presný názov) vo vašom projekt.

K importVaše architektúra z.xml (fragment ABACUS XML alebo XML súbor ArchiMate Interchange Language)

1. Skontrolujte, či máte ABACUS súborotvorené.

2. Kliknite pravým tlačidlom myšina uzle Architecture, ľubovoľné počítačovej architektúre, vo vašom modeli alebo jeho časť z komponentov stromu.

3. Vybrať Dovoz| Z XML ...z menu.

4. Vyberte si miesto a XML súboru a kliknite na tlačidlo OtvorenéTlačidlo.

Poznámka

ABACUS sa bude dovážať iba správne vytvorený ABACUS XML fragment alebo XML súbor ArchiMate Interchange Language. Potom, čo ste vybrali súbor XML, ktorý chcete importovať, sa otázka, ako by ste chceli importovať normy, typya vyhliadky, Môžete importovať štandardy, typy a vyhliadky buď ako nových alebo zlúčené normy, typya vyhliadky, Predvolené nastavenie je pre štandardy, typy a vyhliadky sa spojil s existujúcimi štandardmi, typy a vyhliadky ak už existujú (s rovnakým presný názov) vo vašom projekt.

K importVaše architektúra z,VSD(Visiosúbor)vidieť tu .

K importVaše architektúra zXLS (Excel súbor)vidieť tu .


Import typy a štandardy z knižnice

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Import typy a štandardy z knižnice

Odoslať pripomienky na túto tému.

Môžete importovať typy a štandardy zo súboru knižnice ABACUS. Môžete tiež exportovať typov a normy zo súboru ABACUS do súboru knižnice ABACUS.

Ak chcete importovať typy a štandardy z knižnice do vašej architektúre

1. Skontrolujte, či máte ABACUS súborotvorené a Okno Prieskumníkazobrazené.

2. Vyberte File | OtvorenéAk chcete otvoriť ABACUS súbor knižnice.

3. Počítadlo knižnica sa otvorí v druhom záložkách listu v okne Prieskumníka, a budete musieť oddokování tento kartami list aby bolo možné drag-and-drop z neho do pôvodného ABACUS súboru.

4. Drag-and-droptypy a štandardy z knižnice do vašej architektúre.

- Alebo -

1. Vyberte File | Nový ...

2. Vytvoriť nový ABACUS súborzaložený na ABACUS súbor knižnice.

Ak chcete exportovať typy a štandardy z architektúry do knižnice

1. Skontrolujte, či máte ABACUS súborotvorený, Okno Prieskumníkazobrazená, čo ABACUS súbor knižniceotvorené a Okno knižnicezobrazené.

2. Drag-and-droptypy a štandardy z vášho architektúry do knižnice.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne


Rozhranie ABACUS

Navigácia: Úvod do ABACUS>

Rozhranie ABACUS

Odoslať pripomienky na túto tému.

Pri spustení Abacus, uvidíte hlavnú obrazovku, ktorá je prázdna, až na menu a paneli nástrojov v hornej, prázdne okno Prieskumníka a titulnej-bar. Táto obrazovka bude centrom vášho interakcie s ABACUS.

Hlavnými prvkami sú:

· hlavné menu

· panely nástrojov

· pravé tlačidlo menu

· Prieskumníka a majetkové windows

· stavový riadok

Hlavné menu

Ponuky sú usporiadané v logickom poradí.

Tieto ponuky sú popísané nižšie;

· Ponuka Súbor- Ponuka Súbor vám umožní vytvoriť, otvoriť, zavrieť, uložiť, exportovať a publikovať počítadlo súborov. To tiež umožňuje vytvoriť, otvoriť, zatvoriť a uložiť súbory ABACUS knižnice.

· Menu Úpravy- Úpravy menu umožňuje vybrať, kopírovať, vložiť, odstrániť, premenovať, nájsť a triediť prvkya undo / redo operácií.

· Zobrazenie Menu- Ponuka View umožňuje otvorenie alebo zatvorenie rôznych rozhraní systému Windows a stavový pruhPrejdite dopredu a dozadu, choďte na špecifických pohľadov a spravovať panely.

· Ponuka Vložiť- V ponuke Vložiť umožňuje pridávať nové Normy, Šablóny, druhy, prvky, výhľadbods, Katalógy, diagramy, grafy, Správy a matice.

· Menu Analysis- Ponuka analýzy umožňuje spustenie hodnotenie proti architektúry vrátane; výkon, náklady, spoľahlivosť, modularita a otvorenosť.

· Ponuka Nástroje- Ponuka Nástroje umožňuje spustenie skriptovanie, stanovených cieľov pre architektúrua vykonávať a architektúra "diff", Môžete tiež upraviť nastavenie programu a prispôsobiť rozhranie z menu nástroje.

· Menu Okno- Ponuka Okno umožňuje ukotviť, usporiadať, skryť zobrazenie otvorených okien.

· Menu Pomocník- Z ponuky Pomocník môžete pristupovať tento súbor pomocníka ABACUS. Môžete prístup na webovú stránku, zobraziť vaše licencie Dohoda a zobraziť všeobecné informácie o ABACUS, vrátane verzie softvéru a Abacus podporu a detaily kontaktu. Spätnú väzbu môžete poskytnúť cez stránku problému oznámenia. V prípade potreby môžete zadať registračný kľúč cez menu Pomocník.

Toto je poradie, budete zvyčajne nasledovať, keď ste plnenie úloh;Potom, čo ste vytvorili, alebo otvorené súbor, Budete normálne naplnenie vašej architektúry, potom pohľadto (v Exploreri, diagramy, 3D, grafy, atď.) V tomto momente budete buď spustiť hodnotiteľ, Alebo budete opakovať proces s rovnakou architektúrou, alebo inú architektúru. (Pozri Ako používať počítadlo (prehľad) pre ďalšie podrobnosti.)

Pozrite sa cez hlavné menu a skúste si predstaviť, ako budete aplikovať do svojho systému.

Poznámka

Môžeš Upravte si menu kedykoľvek.

Panely nástrojov

V predvolenom nastavení sú tieto panely nástrojov;

· V hlavnom paneli nástrojov -

· Simulácia Panel s nástrojmi -

· View panel nástrojov -

· Diagram nástrojbar (v prípade, že diagram je otvorený) -

· makro Nahrávka Panel s nástrojmi -

Pozrite sa prostredníctvom tlačidiel na každom paneli nástrojov vznášajúce sa nad nimi vidieť britu (skratka-kľúč).

Poznámka

Iba niektoré tlačidla bude aktívny v závislosti na tom, čo ste vybrali v okne Prieskumníka a môžete Upraviť panely nástrojov kedykoľvek.Navyše "Skontrolovať / kontrolné podmienky projektu" tlačidlo na hlavnom paneli nástrojov a tlačidlá na paneli nástrojov Simulation zdôrazní Red keď zmena podkladové úložisko vyžaduje opakovanú validáciu projektu alebo re-simuláciu tohto simulátore resp. Umiestnite ukazovateľ myši na tlačidlo zistiť, ktoré architektúry sú ovplyvnené.

V ponuke kliknite pravým tlačidlom myši

Hlavné menu a nástrojové lišty sú niepoužíva pre všetko, hoci. Často je vhodnejšie použiť kontextovú ponuku kliknutím pravým tlačidlom myši pre rôzne operácie. (Tiež, nie všetky príkazy sú k dispozícii prostredníctvom pravým tlačidlom myši sú dostupné cez hlavnej ponuky, panely nástrojov alebo klávesové skratky.)

Napríklad, akonáhle ste vytvorili súbor, a budete mať strom schému vašej architektúre, je lepšie kliknite pravým tlačidlom myši na architektúrach v strome pridať novú architektúru. Podobne, mali by ste pravým tlačidlom myši na súčiastky pre pridanie nové komponenty. Pravým tlačidlom myši na pár vecí v strome, aby videli, čo môžete urobiť.

Tip

Všeobecne platí, že budete používať hlavné menu vykonávať viac úloh na vysokej úrovni, rovnako ako hodnotenie vašej architektúru. Úlohy sú low-level - ako pridávanie jednotlivých zložiek a pripojenie - sa vykonáva pomocou panelov nástrojov a / alebo ponuku kliknutím pravým tlačidlom myši.

Prieskumníka a vlastnosti okien

Pri otvorení alebo vytvoriť súbor, bude strom schéma sa zobrazí v okne Prieskumníka. Je to okno do vašej architektúre. A ako si vybrať prvky v okne Prieskumníka troch ostatné okná; všeobecné vlastnostiReferencie,a Vlastnosti okna bude aktualizovať tak, aby odrážali informácie o vašom výbere.

Poznámka

Všeobecné vlastnostiReferencie,Vlastnosti a okná sú v predvolenom nastavení skryté. Vidieť Prispôsobenie rozhrania na to, ako im odkryť a prípadne nechať je trvalo zobrazený.

Aj keď ste budovanie svojej architektúry, Explorer a vlastnosti okna sú najužitočnejšie reprezentácie. Vzhľadom k tomu, že môžu byť zrútil a rozširovať podľa potreby, a nemajú stal ťažkopádnym.

Okno Explorer má Tree (a stavový riadok) a okná Vlastnosti majú 5sekcia:

· Druh

· Normy

· Popis

· Referencie

· Vlastnosti

ABACUS domnieva sa, všetky tieto veci byť súčasťou architektúry.

Strom

Táto sekcia má strom rozdelené do 3 oblastí nasledovne:

1. Meta-Model

· Normy- Ak veľký komponenty majú rovnakú sadu vlastností, môžete definovať sadu up-front, a potom už len priradiť ku komponentom. To isté platí pre pripojenie a niektoré z ďalších prvkov. Tieto sady štandardných vlastností sú uložené v Normyvetva stromu. Namiesto toho, aby definovanie každá vlastnosť pre každú zložku, a každá vlastnosť pre každé pripojenie atď, len priradiť štandard, Napríklad štandardný charakteristiky Unix-HP / UXmožno uložiť ako Štandardné a pridelená žiadnemu komponenty pomocou Unix-HP / UXoperačného systému, ako je znázornené pre OS01 server v screenshotu vyššie.

· Typy - Táto vetva stromu je knižnica typov súčasťou a spojov, ktoré môžete použiť. Typy slúži na definovanie meta-model pre svoju architektúru a pre klasifikáciu a filtrovanie pri prezeraní vašej architektúry. Oni tiež určiť šablónu pre to, čo Normy, Vlastnosti a obmedzenia svoje komponenty / spoje môžu mať.

· Uhly pohľadu- Pohľadbods môžu byť vytvorené z existujúcich grafov a môžu byť použité na vytvorenie nových diagramy.Sú diagram šablóny.

· Šablóny - Šablóny obchod re-použiteľná vzory komponentov a spojenie spolu so spôsobom, v ktorom sú zastúpené alebo pohľadu. Môžu byť myšlienka ako "mini", architektúry alebo riešenie, ktoré môžu byť umiestnené do existujúcich architektúr.

2. Architektúry -Architektúr vetva stromu je miesto, kde budete budovať architektúra (y) vášho systému. (To sa nazýva vyplnenie architektúry.) Môžete mať ľubovoľný počet architektúr v jedinom súbore ABACUS.

3. Dashboards - Panelov dashboard vetva stromu je miesto, kde môžete pristupovať akýkoľvek uložené dashboardy pre tento projekt.

Poznámka

Položky v strome Prieskumníka, ktoré mali svoje Aktualizácia povolenia odstránené (tj sú iba na čítanie) sú sivé.

Druh

Táto časť označuje špecifické zložky alebo spojenia typu aktuálne vybraného prvku v strome.

Normy

Táto časť obsahuje zoznam tých Normy pre aktuálne vybraného prvku v strome.

Popis

Táto časť obsahuje stručný opis vybraného prvku v strome. Všetky súvisiace hypertextové odkazy môžu byť tiež pridané do tejto sekcie. Medzi ne patrí weby alebo miestne absolútnej cesty ukazujúce na ďalšie informácie o danom prvku. Viac linky sú tiež povolené. Platné hypertextové odkazy je potrebné začať s jednou z 5 reťazcov; http: //, https: //, ftp: //, file: /// alebo mailto:.

Tip

Pre hypertextové odkazy s medzerami, môžu používatelia zadať URL alebo cesty, vyberte požadovaný text a Kliknite pravým tlačidlom myši| Hypertextový odkaz, To sa zmení na medzery % 20takže sa celá adresa URL alebo cesta bude fungovať správne.

Vytvoril a Modified

Títo časťsposkytnúťužívateľa a dátum / čas vytvorenia a posledné úpravy, aktuálne vybraný prvok v strome.

Referencie

Táto časť obsahuje zoznam tých odchádzajúce i prichádzajúce komponenty pre aktuálne vybraného prvku v strome.To tiež ukazuje diagramy, 3D a pohľady graf, ktorý aktuálne vybraný prvok sa objaví v. Ak je vybraný graf ukazuje hľadiska v prípade potreby pre diagram a pre pohľady všeobecne sa zobrazí nejaké Dashboards pohľad objaví. A keď štandard je vybraný vo stromu ukazuje využitie štandardu podľa typov, súčastí a spojov.

Vlastnosti

Táto sekcia je miesto, kde môžete definovať charakteristiky prvky vnútri Vaše architektúra, rovnako ako, ako budete potrebovať to urobiť, počet riadkov kódu má, percento týchto liniek, ktoré sú poznámky, atď

Tieto "vstupné" a "výstupný" vlastnosti pre-postavený simulátory sa zobrazí v okne Vlastnosti s ikonou vstup nehnuteľnosť voliča riadku ( [image] ) A výstup ikona ( [image] ) Respektíve s popisku označujúci ktorý pre-postavený simulátor vlastnosť súvisí, napr "Modularita Output" alebo "Input Performance". Šípka na výstupných ikony zdôrazní Red ( [image] ), Keď je vlastnosť je zastaraná v dôsledku nehnuteľnosti alebo štrukturálne zmeny úložisko s simulátore vyžadujúce re-simulácie v závislosti na Red zvýraznenie na Panel nástrojov Simulácia .

Stavový riadok

Ľavá časť stavového riadku zobrazuje úplnú cestu k úložisku prvok v súčasnej dobe in-zameranie, a to buď vybraný v okne Prieskumníka, alebo na diagramplátno. Je tomu tak preto, že presné miesto v úložisku hierarchii pre daný prvok môže byť vždy ľahko určiť. Pravá časť stavového riadku zobrazuje rôzne prevádzkové správy, ako napríklad "Otvoriť ABACUS File úspešné" a "Kalkulácia nákladov Dokončené".

Pozri tiež

Ako to robíte (prehľad) | Prispôsobenie rozhrania | Čo je to architektúra? | Ako sa architektúra zastúpená v ABACUS? | Práca so súbormi ABACUS


Čo ABACUS robiť?

Navigácia: Úvod do ABACUS>

Čo ABACUS robiť?

Odoslať pripomienky na túto tému.

Pre pomoc v iných jazykoch / preklady kliknite tu .

ABACUS sa hádať-pracovať von z rokovaní s riešenie, systémy, softvér, informácie, technológie, obchodných procesov a / alebo celých podnikov (súhrnne označované ako architektúry). To vám môže pomôcť pragmaticky navrhovať, sledovanie, simulovať, analyzovať a vizualizovať architektúra modelovaním to, analyzuje ho intuitívnymi spôsobmi (napr grafy, diagramy a 3D), a potom ocenia to proti svojim non-funkčné požiadavky.

Poznámka

Non-funkčné požiadavkysú tie požiadavky, ktoré priamo nesúvisia sa, ako produkt funguje. Miesto toho, oni sú znepokojení tým, ako dobre to funguje. Non-funkčné požiadavky zahŕňajú také veci ako výkon, otvorenosť, Evolvability, kvalitu, škálovateľnosť, modularita, apod (na rozdiel od funkčných požiadaviek, ako je, zapnite svetlo pri kliknutí na toto tlačidlo). Tradične, non-funkčné požiadavky bolo ťažké - ak nie nemožné, - pre meranie. V skutočnosti, ABACUS je jediným produktom, ktorý možno objektívne a kvantitatívne meranie prvé tri - výkon, otvorenosťA evolvability.

Jednoducho povedané, zadáte architektúru a čo ju budete potrebovať urobiť. ABACUS potom vám povie, či to bude robiť, ako je požadované, a poukazuje na to, slabé stránky či medzery.

ABACUS čerpá z viac než 20 rokoch výskumu systémov a mnoho ďalších rokov zavedeného teórie systémov. To vám dáva kvantifikovateľné, spoľahlivé a objektívne odpovede, takže nie ste spoliehať na subjektívnom posúdení.

ABACUS je skratka pre Architecture-Based AANALÝZA, COMUNIKÁCIA a Understandingz Systems. To vám môže pomôcť s akýmkoľvek veľkom meradle architektúre, ale to je všeobecne používané pre štyri (4) veci:

· Vyvíjajúci saprúd architektúra. Napríklad, ak vaše existujúce architektúra postráda výkonnosť, ABACUS bude predstaviť architektúru pre vás, pomenuje problémy (úzke miesta, etc.), a potom vám povedať, presneako zlepšiť architektúru.

· Projektovanienová architektúra. Napríklad, ak potrebujete úplne novú architektúru, a že ho máte na projektovanie sami, ABACUS vám povedia, presneaké komponenty budete potrebovať a ako by mali byť pripojené.

· Nákupnová architektúra. Napríklad, ak ste volali k účasti v súťaži na návrh novej architektúry, a vy ste sa rozhodli medzi tri návrhy, ABACUS vám povedia, presnektorý vyhovuje vašim požiadavkám najlepšie.

· KombináciaSúčasné existujúce architektúry. Napríklad, ak potrebujete spojiť dva alebo viac oddelených architektúry, ABACUS vás.

Pozri tiež

Ako to robíte (prehľad) | Čo je to architektúra? | Ako sa architektúra zastúpená v ABACUS?


Pomocou odkazov v diagramoch

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Pomocou odkazov v diagramoch

Odoslať pripomienky na túto tému.

Tvary (voľné forme a symboly) a konektory (voľnej forme alebo pripojenie) v diagramoch možno prepojiť s vašou existujúce architektonické zastúpenie v ABACUS, ako aj externých súborov / zložiek a adries URL. Tieto odkazy potom môžu byť riadené (vytvorený, upravovať a mazať) cez ABACUS sady nástrojov. Túto funkciu možno použiť na zvýšenie navigácie a celkové pochopenie vašej architektúre schematicky.

Ak chcete pridať odkazy na diagrame

1. Uistite sa, že máte existujúce diagram open .

2. Vyberte zodpovedajúcu tvar alebo konektor z diagramu.

3. Kliknite pravým tlačidlom myšina tvarealebo konektor.

4. Vybrať Otvorené Odkazya OdkazyZobrazí sa okno.

5. Kliknite na PridaťIkona a New LinkZobrazí sa okno.

6. Vyberte príslušný Katalóg | Matrix | Diagram| 3D zobrazenie| Grafprepínacie tlačidlá, potom vyberte príslušný katalóg, matice, diagram, 3Dalebo graf Pohľad v súčasnej architektúry z Odkaz nadrop-down menu.

- Alebo -

6. Vyberte Webová stránkaprepínač potom, zadajte príslušnú adresu URL (napr. http: //www.avolutionsoftvér.com /)V poli odkaz na webovú stránku. Platnej adresy URL je potrebné začať s jedným z 5reťazca; http: //, https: //, ftp: //,file:alebo \\, Všetky priestory by mali byť zadané s '% 20'.

- Alebo -

6. Vyberte Absolútna File | Relatívna Súborprepínačs,potom kliknite na '..."Tlačidlá vyhľadajte externého súboru odkazy na diagrame.

7. Kliknite na tlačidlo OKa nový odkaz sa zobrazí v okne odkazy. Poznámka: Okno Links môže byť zväčšená v prípade potreby vidieť celé meno.

8. Opakujte kroky 5-7vytvoriť viac odkazov.

9. Ak chcete na odkaz vytvorený, vyberte príslušný odkaz zobrazí v Odkazyokno a kliknite na tlačidlo Otvoriť odkaz.

Poznámka

Kedy viac anotácie sú uvedené pre tvar alebo konektor odkaz je uvedený na prvom anotáciu v zozname anotácií v dialógu Upraviť anotácie.

Ak chcete sledovať odkazy z diagramu

1. Uistite sa, že máte existujúce diagram open .

2. Vyberte zodpovedajúcu tvar alebo konektor z diagramu.

3. Kliknite na tlačidlona príslušný hypertextový odkaz (modrý podčiarknutý názov komponentu) na tvar alebo konektor v diagrame otvoriť a zobraziť prvý odkaz z tvarualebo konektor.Poznámka: Kurzor by sa mal zmeniť na "ruku", ak je odkaz je pripravený byť klikol.

- Alebo -

3. Vyberte zodpovedajúcu tvar alebo konektor z diagramu.

4. Kliknite pravým tlačidlom myšina tvarealebo konektor.

5. Vybrať Otvorené Odkazya OdkazyZobrazí sa okno.

6. Vyberte príslušný odkaz, ktorý chcete zobraziť.

7. Kliknite na Otvoriť odkaztlačidlo pre otvorenie a zobrazenie na príslušný odkaz.

Ak chcete odstrániť odkazy v diagrame

1. Uistite sa, že máte existujúce diagram open .

2. Vyberte zodpovedajúcu tvaralebo konektorz diagramu.

3. Kliknite pravým tlačidlom myšina tvarealebo konektor.

4. Vybrať Otvorené Odkazya OdkazyZobrazí sa okno.

5. Vyberte príslušného odkazu, ktorý musí byť odstránené.

6. Kliknite na ZmazaťTlačidlo. a väzba je odstránený z Odkazy okno.

Organizovanie odkazy v diagrame

Môžete si vybrať, ktoré súvisia diagram, externý súbor, alebo webové URL sa zobrazí, keď tvar etiketa je Ctrl + kliknutie na obrázku.

1. Uistite sa, že máte existujúce diagram open .

2. Vyberte zodpovedajúcu tvar alebo konektor z diagramu.

3. Kliknite pravým tlačidlom myšina tvarealebo konektor.

4. Vybrať Otvorené Odkazya OdkazyZobrazí sa okno.

5. Ak chcete zmeniť poradie odkazov kliknite na Presunúť hore | Posunúť nadolTlačidlá na pravej strane Odkazyokno.

6. Prvý odkaz, ktorý sa objaví na ľavej strane OdkazyOkno je odkaz, ktorý sa zobrazí, keď vás Ctrl + Clickhypertextovými odkazy tvar alebo konektor Názov.

Pozri tiež

Naplnenie vašej architektúry | Naplnenie vašej architektúry ručne | Analýza Vaše architektúra


Manipulácia Diagramy

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Manipulácia Diagramy

Odoslať pripomienky na túto tému.

Akonáhle je diagram bol vytvorený, prvky, ktoré sa objavujú v ňom môže byť prepracovaný a re-sized ako je požadované.

Ak chcete presunúť komponent v diagrame

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite na tlačidlo a držteakákoľvek zložka sa pohybovať. Ak vybraná zložka má rodičov, bude materská komponenta sa zvýrazní.

3. Vzhľadom k tomu, element jevliekol od svojej materskej komponenty, a nad ostatnými zložkami, "potenciálny" rodičia sa zvýrazní. Farebná schéma používané udáva efekt operácia bude mať na varovanie a chýb s aktuálny projekt a je opísaný v Definovanie a overovanie Obmedzenia , Týmto spôsobom môžete graficky prechádzať hierarchiu z "pôdorysu".

4. Releasetlačidlo myši k poklesu prvok v jeho novom umiestnení.

Poznámka

Môžete tiež použiť klávesnicu znovu polohy prvkov na kresliace plátno. Jednoducho vyberte požadované zariadenie alebo voľnej forme tvar, ktorý chcete presunúť, a pomocou šípok umiestnených na klávesnici pre pohyb tvar na požadované miesto.

Tiež si všimnite, že pri preťahovaní komponentu s myšou nad iné súčasti, "potenciálny" materský zložka je zvýraznený, keď je ľavý horný roh komponenty preťahujete prekrýva ďalšiu súčasť.

Tip

Voľné a Plávajúce tvary možno objednať kliknutí pravým tlačidlom myšia výberu Preniesť do poprediaalebo Preniesť dozaduz menu. Je dôležité poznamenať, že tvary súčasti môžu byť konvertované na voľné formy tvarov kliknutí pravým tlačidlom myšiNa špecifického tvaru komponentov a voľbou Previesť na FreeForm.

Ak chcete zmeniť veľkosť komponenty v diagrame

1. Uistite sa, že máte existujúce diagram open .

2. Click-hold-ťahaťjeden z držadiel tejto komponenty a veľkosť tvar na požadovanú veľkosť.

3. Alternatívne pre zachovanie pomeru strán obrazce, zošliapnite SHIFT + kliknutie-držanie-drag.

Ak chcete presunúť pripojenie v diagrame

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite na tlačidlo a držteakékoľvek spojenie sa pohybovať.

3. Releasetlačidlo myši k poklesu prvok v jeho novom umiestnení.

Poznámka

Môžete sa pohybovať iba pripojenie, ktoré nie sú pripojené k ľubovoľnej súčasti. Ak sú pripojené, môžete presunúť iba na voľný koniecsAlebo presmerúvajú pripojenie .

Odstránenie komponenty a pripojenie

Pri mazaní súčasť alebo spojenie z diagramu, máte možnosť ho odstrániť z celej architektúry. Každá súčasť, ktorá je odstránený z architektúry budú automaticky odstránené z akýchkoľvek iných diagramov, kde sa objaví. Vzhľadom k tomu, freeform inštancie sa len v jednom grafe, mazať neovplyvňuje architektonický model, alebo akékoľvek iné schéma.

Ak chcete odstrániť priečinok alebo pripojenie zo diagramu

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite na tlačidloNa každom súvisiacim pripojenie alebo súčasti, vyberte ho.

3. Stlačte tlačidlo ZmazaťKľúčom k jeho odstránenie z grafu, alebo Shift + Deleteodstrániť z celého modelu.

- Alebo -

2. Pravým tlačidlom myši na ľubovoľný prvok alebo pridružené súčasti. Objaví sa kontextové menu.

3. Vybrať Odstrániť z pohľadualebo Odstrániť z Staviteľstvoz kontextovej ponuky.

Poznámka

V prípade, že prvok, ktorý chcete odstrániť z pohľadu nemá žiadne deti a dochádza len v pohľade, ABACUS sa spýta, či chcete odstrániť prvok z úložiska rovnako.

Pozor

Pri odstránení komponenty z modelu, ktorý má podriadené zložky, deti budú tiež potenciálne vymazaný podľa dialógu varovania.

Zlúčenie Components

Možno budete chcieť zlúčiť dve zložky existujúce na rovnakom diagramu (a v rámci architektúry), To môže byť vykonané z mnohých dôvodov, napríklad, Dva servery existuje v rámci firemného Infraštruktúra: H01 a H02. Tieto dva servery sú reprezentované ako dve samostatné súčasti v rámci architektúry. H01 bol považované za zbytočné, a preto má byť vyradená z prevádzky. Všetky existujúce aplikácie bežiace na H01 sa majú previesť na H02 (ešte v poverení). Táto zmena môže byť potom odráža pôsobením "spájajúcich" dvoch zložiek H01 a H02 v diagrame (a v rámci architektúry).

Pre podrobnejšie diskusiu o zlučovaní nájdete zlučovaných téme položky tu .

Ak chcete zlúčiť dve existujúce komponenty

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite pravým tlačidlom myši, držaťna komponent, ktorý chcete zlúčiť a ťahaťto na komponent chcete zlúčiť s. Uistite sa, že obrys cieľovej zložky je zvýraznená na červeno, čo znamená, že je vybraná.

3. Vybrať Zlúčiť | Zachovať Cieľalebo Prepísať Destinationz menu.

Poznámka

Zachovať Cieľmetóda zachováva hodnoty vlastností cieľového komponenty v prípade, že existujú na zariadenie pre pôvodnú rovnako.

Prepísať Destinationmožnosť prepíše vlastnosti cieľového komponenty s akýmikoľvek spoločných vlastností zo zariadení pôvodu.

Zmena pripojenia

Pripojenia zobrazené v diagrame vždyckyodrážajú štruktúru, ako je definovaná v architektúre samotnej. Kreslenie nástroj umožňuje odpojiť pripojenie z komponentov, presunúť, krivka je, re-cesta je a re-pripojiť ich k ostatných zložiek.

Ak chcete odpojiť / pripojiť spojenie z / do komponenty

1. Uistite sa, že máte existujúce diagram open .

2. Kliknite na tlačidlo a držtena ľubovoľnom pripojenie.

3. Vybraťpripojenie koniec(tj. Source alebo Sink), Ktorý by ste chceli odpojiť / pripojiť. Poznámka: konce pripojenie sú označené s malými bielymi kruhmi a vznášajúce sa nad bielym kruhom na sekundu spôsobí 'tooltip "sa zobrazí s príslušnou rolenázov(tj. buď Source alebo Sink).

4. Dragpripojenie koniec do nového umiestnenia (buď prázdne miesto alebo zložku) a uvoľnite tlačidlo myši.

Poznámka

Ak je koniec spojenia umiestnený nad platnú zložky, obrys cieľovej zložky je zvýraznený prerušovanou obrysom. Farebná schéma používané udáva efekt operácia bude mať na varovanie a chýb s aktuálny projekt a je opísaný v Definovanie a overovanie Obmedzenia , Raz povolený že koniec the pripojenia a zložka sú automaticky spojené(alebo v prílohe), A to sa odráža v architektonickom modelu.

Ak chcete presmerovať pripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Umiestnite kurzor myši nad pripojenie.

3. Držte Smenaklávesa dole a Kliknite na tlačidlotlačidla myši umiestniť spojenie kotviaci bod. Uvoľnite Smena key. Môžete odstrániť kotviaci bod, tým, že robí rovnakú operáciu.

4. Click-a-ťahaťkotviaci bod presmerovať pripojenie.

Tip

PoužiAlt key namiesto SmenaKľúčom k vytvoreniu ortogonálne pripojenie.

K Krivka alebo narovnaťpripojenie

1. Uistite sa, že máte existujúce diagram open .

2. Umiestnite kurzor myši nad pripojenie.

3. Kliknite pravým tlačidlom myšiTon pripojenia a v kontextovom menu, ktoré sa objavia vyberte Krivka, Ortogonálne alebo Rovno.

Tip

Všetky prípojkydaného typu na obrázku je možné nastaviť na zakrivené, ortogonálne alebo Straight pravým kliknutím na pridružený linku pre typ na strane Karta Pripojeniez Okne vzorkovníkaa výberu Curve, ortogonálne alebo Straight.

K zakotviť na konkrétny bod na okraji tvare

1. Uistite sa, že máte existujúce diagram open .

2. Vyberte pripojenie.

3. Umiestnite ukazovateľ myši "Biele dot 'na konci pripojenie.

4. Kliknite pravým tlačidlom myšiTže spojenie koniec a v kontextovom menu, ktoré sa objavia vyberte Ukotvujú koncový bod na tvar.Premiestnenie konca pripojenie do žiadanej lokalite na okraji tvaru.

ALEBO

Držte Ctrlklávesa dole a clízať-a-ťahať koniec spojenia ukázať na túžba umiestnenie na okraji tvaru.

Poznámka

Pripojenie sa prichytí do ohraničovacieho rámčeka tohto tvaru skutočného priesečníku ich pripojeného tvaru miesto.

Pozri tiež

Nástroje na kreslenie | Naplnenie vašej architektúry | Analýza Vaše architektúra


Zlučovanie položiek

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Zlučovanie položiek

Odoslať pripomienky na túto tému.

Kedy by ste zlúčiť položky?

Tie by sa zlúčiť položky, keď máte dve (alebo viac) objekty v modeli, ktoré sú najlepšie reprezentované jednej inštancie. Existuje mnoho situácií, kedy budete chcieť urobiť, vrátane:

· V dôsledku importu novú sadu informácií do modelu ktorá by mohli byť duplicitami alebo nahradí súčasné informácie. Napríklad ak importovať aktualizovanú verziu tabuľky do svojho modelu.

· Postupom času boli vytvorené duplikáty "rovnaké" zložky a chcete vyčistiť tieto duplikáty.

· Ak vykonávate what-if scenáre a položky ste modelovanie skutočne zlúčenie v realite. Napríklad, ak ste zlúčenie dvoch oddelení vo vašej organizácii, alebo ak zlúčenie dvoch serverov.

Čo môže byť zlúčené?

Nasledujúce typy položiek podporujú zlúčené:

· Normy

· Komponentov a typy spojenia

· Komponenty a pripojenie

Ako zlúčiť položky

Ak chcete začať zlúčenie, pomocou pravého tlačidla myši, presuňte jednu položku v Prieskumníkovi na druhú. Položka preťahujete je zdrojom, a položky, ktoré pretiahnete na je cieľ. Po uvoľnení pravé tlačidlo myši, objaví sa vám s menu, z ktorého si môžete vybrať, aby Zlúčiť dve položky. Budete musieť vybrať, či chcete zachovať alebo prepísať ciele. Toto je ďalej vysvetlený nižšie.

Ponuka pravého drag merge

Aký je rozdiel medzi zachovanie a prepísanie cieľ?

Zachovať alebo prepísať možnosť určuje, čo sa stane v prípade, že názov, popis alebo vlastnosti medzi zdrojovou a cieľovou položky stretnutia.

Ak je zvolená Zachovať Destination

· Cieľovom Meno a popis budú zachované.

· Všetky vlastnosti, ktoré existujú len v zdroji sú pridané do cieľa.

Ak Prepísať cieľ je vybraný:

· Cieľového Meno bude prepísaný od zdroja.

· Miesto určenia sa Popis prepíše sa zo zdroja, pokiaľ nemá zdroj v Popis je prázdny.

· Všetky vlastnosti, ktoré existujú len v zdroji sú pridané do cieľa.

· Hodnota a jednotka žiadne vlastnosti, ktoré existujú v oboch zdroj a cieľ bude prepísané zo zdroja, pokiaľ nemá zdroj v Value Unit alebo je prázdne.

Zvláštne prípady

· Druhy: Pri zlučovaní typov, oprávnenia sú zlúčené, v "pesimistické" spôsobom, tak, že v prípade, že oprávnenie na zdroji neexistoval na mieste určenia, že by byť pridané, a ak je to existujú v lokalite, potom v prípade, že jedinec oprávnenia pre skupinu používateľov (vytvárať, čítať, aktualizovať alebo mazať) nezodpovedá (jeden udelené, jeden poprel), potom, že povolenie bude odopreté.

· Komponenty: Pri zlučovaní komponentov, sub-komponenty zdroje sú prenesené na miesto určenia, a sa spojil s sub-zložiek v určení, ak ich mená sú zhodné, Bez ohľadu na ich typ.Okrem toho bude viac sub-komponenty zdroj s rovnakým názvom byť spojené do jednej čiastkové komponenty v cieľovej krajine.

· Pripojenie: Najvyššia úrovni samotné pripojenie musia obaja majú rovnaké prílohy (alebo jeho nedostatok), aby im bolo umožnené byť zlúčené. Pri zlučovaní pripojenie sub-prípojky zdroje sú prenesené na miesto určenia, a sa spojil s čiastkovými pripojenia v určení, ak ich mená sú zhodné Aich prílohy sú identické. Ak prílohy nie sú totožné, bude zdroj čiastkové pripojenie byť pridaná do cieľa, bez toho by sa spájať so zodpovedajúcimi pripojenia už prítomných. To je tak, aby žiadne prílohy sú stratené.


Navigácia v 3D diagram

Navigácia: Analýza vašej architektúry> 3D diagramy>

Navigácia v 3D diagram

Odoslať pripomienky na túto tému.

ABACUS umožňuje ľahko prechádzať vašej architektúry v 3D. Zážitok je podobný lietanie. Existujú dva režimy navigácie:

· Základné ovládacie režim (predvolené); a

· Advanced Control Mode - zmena do tohto režimu zvolením Ovládanie| Mode Control Advanced.

Poznámka

Pre prepínanie medzi základné ovládanie a pokročilé režimy Control, môžete použiť F4klávesové skratky funkcie.

Základný režim ovládania

· Držania ľavého tlačidla a pohybom myšou dopredu alebo dozadu zmení ihrisko;

· Držania ľavého tlačidla a pohybom myši doľava alebo doprava zmení vybočiť;

· Držanie pravého tlačidla a pohybom panvy myš názor;

· Uchopte obe tlačidlá nadol a pohybom myšou dopredu alebo dozadu, priblíži a von z architektúry; a

· Uchopte obe tlačidlá nadol a pohybom myši doľava alebo doprava, rožky doľava a doprava.

- Alebo -

· Stlačením Šípka vľavona klávesnici alebo numerickej klávesnici bude odbočíme vľavo;

· Stlačením Šípka dopravana klávesnici alebo numerickej klávesnici bude odbočiť vpravo;

· Stlačením Šípka horena klávesnici alebo numerickej klávesnici sa priblížite;

· Stlačením Down Arrowna klávesnici alebo numerickej klávesnici sa vzdialite;

· Stlačenie Strana horena klávesnici alebo numerickej klávesnici bude rozteč nahor; a

· Stlačenie O stranu nižšiena klávesnici alebo numerickej klávesnici bude nahadzovať nadol.

Mode Control Advanced

· Sťahovaniemyš dopredu a dozadu a hore a dole, zmení ihrisko a vybočiť (v tomto poradí);

· Stlačenie Walebo Šípka horezväčší (vpred) k architektúre;

· Stlačenie Salebo Down Arrowoddiali (spätne), od architektúry;

· Stlačenie Aalebo Šípka vľavorožky vľavo;

· Stlačenie Dalebo Šípka dopravavalí doprava;

· Stlačenie Qalebo O stranu nižšiepovyšuje názor (znížením výhľadu); a

· Stlačenie Ealebo Strana horeznižuje výhľad (tým, že zvýši perspektívu).

Mode Control Interactive

Stlačením a pridržaním kláves Shiftna klávesnici potlačia aktuálny režim (Basic alebo Advanced) pre vstup do režimu interaktívne ovládanie. V tomto režime je možné, dopĺňa:

· Rollkurzor myši nad komponentu alebo pripojenie k videniu súčasť alebo názov pripojenie je;

· Kliknite na tlačidlona komponenty pre zväčšenie na túto zložku;

· Click-a-ťahaťna komponent otočíte zobrazenie okolo túto zložku; a

· Kliknite pravým tlačidlom myšikomponent alebo pripojenie a vyberte Zobraziť v Prieskumníkovividieť, že komponenty alebo miesto pripojenia v stromu.

Spoločnej kontroly

· Použiť ALT-ENTER / ESCpre prepnutie do režimu celej obrazovky;

· Použiť F2zmeniť režim zobrazenia. To môže byť tiež prístup cez PohľadMenu.

· Použi kolieskom myšialebo +/-pre zmenu rýchlosti. Rýchlosť je označený číslom v ľavom dolnom rohu - zobrazí iba v prípade, že sa mení. 1 je najpomalší a 100 je najrýchlejšia.


Otvorenie diagramy

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Otvorenie diagramy

Odoslať pripomienky na túto tému.

Na kreslenie vzorkovníka a plátno okna sa zobrazí automaticky, ak je diagram otvorenie alebo vytvorenie. Podobne, keď je diagram uzavretý, zodpovedajúce kartami list v okne plátne zmizne a v prípade, žiadne ďalšie výkresy sú otvorené, je okno šablóny je uzavretý.

K vytvoriťnový diagram

1. Skontrolujte, či máteABACUS otvoriť súborobsahujúce Váš obývaný architektúra.

2. Kliknite na Diagramikonu v paneli nástrojov Zobrazenie.

- Alebo -

2. Vybrať Insert| Diagram.

- Alebo -

2. Kliknite pravým tlačidlom myši Diagramyvetva danej Staviteľstvočasť stromu a vyberte Vytvoriť Diagram.

3. Vyberte StaviteľstvoChcete sa zamerať na z roletového menu. Poznámka: architektúra bude už vybraný pre vás, ak ste použili vyššie uvedenom kroku 3 a otvorte nový diagram.

4. Vyberte Hľadisko chcete použiť z rozbaľovacieho menu. Poznámka: zvolená hľadisko bude filtrovať komponenty a zoznamy prípojky byť dostupné k pohľadu len.

5. Voliteľne si vybrať pohľad z Filtrovať podľa Viewpull-down menu, aby predbežne vybrala komponenty a pripojenie z vybraného pohľadu. Poznámka: toto je efektívne využívať vybrané zobrazenie ako uloženého dotazu.

6. Vyberte Dispozície byť buď Paprskovitý alebo Rošt.

7. Vyberte Komponentya Pripojenieže chcete v diagrame podaná okno pre výber štandardným prvkom .

8. Kliknite na tlačidlo OK.

Poznámka

Nové schéma bude pridaná do Diagramyodbor architektúry. To bude mať predvolený názov, ktorý môžete neskôr zmeniť kliknutím pravým tlačidlom myši na neho.Okrem toho bude posledný stav komponentov a výberu pripojenia filtruje byť uložený s schéma účinne uloženie "dopyt", použitý na vytvorenie diagramu.

Ak chcete otvoriť existujúci diagram

1. V konkrétnom obývané architektúry, rozbaľte Diagramyvetva stromu.

2. Dvojité kliknutie diagram, ktorý chcete otvoriť.

Ak chcete uložiť diagram

1. Uistite sa, že máte novú alebo existujúce diagram otvorenýa vy ste vykonali potrebné zmeny. Poznámka: hviezdičku "*" sa zobrazí za názvom pohľadu v záložkách hlavičke sumou, ak dôjde k zmenám, ktoré majú byť uložené.

2. V zobrazení prieskumníka kliknite na Savetlačidlo alebo sa dostal do Súbor| Savealebo zošliapnite Ctrl + Suložiť všetky zmeny v architektúre a zapísať ho do súboru.

Ak chcete uložiť diagram forme hľadisko

1. Uistite sa, že máte existujúce schému vo vašom súbore ABACUS.

2. Kliknite pravým tlačidlom myšiSchéma v Diagramyčasť stromu.

3. Vybrať Uložiť ako Diagram Viewpoint.

4. Zadajte názov pre váš nový diagram hľadiskoa kliknite na tlačidlo OK.

Pozri tiež

Nástroje na kreslenie | Naplnenie vašej architektúry | Analýza Vaše architektúra


Naplnenie pomocou Katalógy

Navigácia: Naplnenie vašej architektúry>

Naplnenie pomocou Katalógy

Odoslať pripomienky na túto tému.

A katalóg vám umožní prezerať a upravovať komponenty alebo pripojenie a ich vlastnosti jednoduchým spôsobom tabuľky.

K vytvoriť nový Katalóg zobraziť v ABACUS

Poznámka

Zatiaľ čo všetci používatelia architekt môže vytvoriť nové Katalógy, uložiť zmeny nastavenia existujúceho Katalóg je užívateľská licencie potrebuje Designer add-on schopnosti. To je "chrániť" konfiguráciu existujúcich katalógov, ktoré môžu byť zdieľané mnoho užívateľov. Avšak, Architekt používa bez Návrhár doplnok môže ešte zvoliť "Uložiť ako" každé nové nastavenie do nového katalógu. A samozrejme všetky licencie Užívateľ si môže vybrať "zbaviť sa" prípadných zmien existujúceho katalógu. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution ak vyžadujete Návrhár doplnok schopnosť. A pamätajte si, to je len nastavenie katalógu, všetky úpravy vykonané na základe údajov v katalógu sú okamžite aplikované na úložisko, bez ohľadu na to.

1. Vyberte Vložiť | Katalóg.

2. V pull-down vyberte architektúru, ktorá obsahuje komponenty alebospoje, ktorú chcete zobraziť.

3. V pull-down vyberte komponent alebo typ pripojenia že si prajete, aby boli prípady, uvedený ako "riadky' v katalógu.

4. katalóg sa vyplní sriadok pre každú inštanciu zvoleného zariadenia alebo typu pripojenia.

Poznámka

Štandardne je najviac vľavo Hierarchie Pathstĺpec (tj hierarchiu materských komponentov alebo spojenie vyššie uvedených vybraných prípadoch) a 2. Názov stĺpec (tj zoznamu zvoleného zariadenia alebo pripojenie inštancie), sú zmrazené na ľavej strane katalógu. Ak chcete zmeniť stĺpec zmrazenie pretiahnite oddeľovač stĺpce napravo od názvu stĺpca. Môžeš re-poradiestĺpce jednoducho pretiahnutím ich hlavičky stĺpcov. Bunky stĺpov s modrým podčiarknutím sú hypertextové odkazy k ďalším prvkom v projekte a hypertextové odkazy môže byť nasledovaný podržaním klávesy Ctrl a kliknutím na nasledujúce odkazy. Stĺpce môžu byť skrytý pravým kliknutím na záhlavie stĺpca a výberom stĺpec | Skryť stĺpec. Skryté stĺpce možno Neskryť kliknutím na tlačidlo paneli nástrojov Stĺpce Konfigurovať a pomocou stĺpca Konfigurovať dialóg, ako je uvedené nižšie, alebo výberom šípky nadol časť tlačidla panela nástrojov Stĺpce Konfigurovať a individuálne výberom skryté stĺpca (y) z oboch generálneho, Vlastnosti alebo prípojky zbierky. Riadky môžu byť zoskupené podľa ich hodnôt stĺpcov pretiahnutím hlavičky stĺpca do modrej zoskupenia riadku v hornej časti katalógu. Kedykoľvek môžete poklepať na Volič katalóg riadoka skok nazodpovedajúce zložkaalebo pripojenieV okne Prieskumníka.Nehnuteľnosti sú hodnoty buniek tučne kde oni sú odlišné od východiskovej hodnoty, a kurzívou kde oni sú len na čítanie. Časovú pečiatku, nehnuteľnosti a Priložené stĺpce zložka môže byť farebný v súlade s hodnotami buniek alebo hodnota pripojené komponenty majetku pravým kliknutím na záhlavie stĺpca a výberom stĺpec | Change Color ... a potom Colour o pečiatku alebo voľbou Colour majetkom, avšak len Zoznam, Integer, desiatkovej, Boolean alebo Dátum / Čas Vlastnosti typ dát bude farbu. Majetkové hodnoty pre pripojené stĺpy zložka môže byť zobrazené pravým kliknutím na záhlavie stĺpca a výberom stĺpec | Zobraziť zariadenia ... a potom možnosť zobraziť zariadenia. A nakoniec, tam, kde sú Požadované obmedzenia nastavenie pre stĺpec vlastností môžu byť tieto zobrazené s string (spolu s farbivami, podľa úrovne ich vymáhanie) pravým kliknutím na záhlavie stĺpca a výberom stĺpec | Zobraziť .

Katalóg

K pridať / zobraziť stĺpce a Katalóg Zobraziť v ABACUS

1. Uistite sa, že máte Katalógové zobrazenie otvorený.

2. Skryté stĺpce môže byť individuálne Neskryť kliknutím na tlačidlo šípka na pravej strane stĺpcov tlačidlo panela nástrojov Konfigurovaťa výberom skrytý stĺpec z buď Všeobecné, Vlastnosti alebo Prílohy zbierky.

Poznámka

Podtržníkom sa zobrazí vedľa aktuálne zobrazené stĺpce pre katalóg.Okrem toho bude k dispozícii v rámci Prílohy iba niektoré prílohy časť v závislosti na obmedzenia ktoré sú definované v projekte. Najmä pre prílohu k dispozícii, ktoré majú byť uvedené v katalógu komponentov schválenie komponentu pre katalóg musí byť zadaný buď ako zdroj, alebo drez (nie je "Akékoľvek") o "spojenie musí byť pripojený" obmedzenia pre pripojenie typu, a musí byť tiež aspoň jeden typ komponentu špecifikovaný buď ako zdroj, alebo drez (nie je "Akékoľvek"), druhého 'end' rovnakého typu pripojenia.

- OR -

2. Viac stĺpcov možno Neskryť (alebo objednať alebo pevné) kliknutím na tlačidlo Konfigurácia Stĺpce tlačidlo panela nástrojova používať Konfigurovať stĺpce dialóg uvedený nižšie.

Poznámka

Práve zobrazené stĺpce sú zobrazené v paneli na pravej strane pomocou dostupných stĺpcov, znázornených na paneli na ľavej strane. Dostupné stĺpce môžu byť filtrované podľa Vyberte Dostupné stĺpcovpull-down a môžu byť pridané ich výberom v paneli na ľavej strane a kliknite na Pridať Tlačidlo inbetween oboma panelmi.

Konfigurácia dialógové okno Stĺpce

K odstrániť / skryť stĺpce z Katalóg Zobraziť v ABACUS

1. Uistite sa, že máte Katalógové zobrazenie otvorený.

2. Pravým tlačidlom myši na nadpis stĺpca pre stĺpec, ktorý chcete odstrániť / skryť a vyberte Stĺpec | Hide Column.

- OR -

2. Viac stĺpcov môžu byť skryté (alebo objednať alebo pevné) kliknutím na tlačidlo Konfigurácia Stĺpce tlačidlo panela nástrojova používať Konfigurovať stĺpce dialóg uvedený vyššie.

Poznámka

Práve zobrazené stĺpce sú zobrazené v paneli na pravej strane pomocou dostupných stĺpcov, znázornených na paneli na ľavej strane. Aktuálne zobrazené stĺpce môžu byť skryté výberom stĺpec v paneli na pravej strane a kliknite na Odstrániť Tlačidlo inbetween oboma panelmi.

K naplneniu pomocou Katalóg Zobraziť v ABACUS

1. K pridať súčasť alebo prípojkazvoleného typu na Katalóg (a projekt), kliknite na tlačidlo Pridať nový komponentný / tlačidlo Pridať nový panel s nástrojmi Connection. Riadok by mal sa objaví a súčasť alebo Pripojenie bude vytvorený na najvyššej úrovni Súčasti alebo Pripojenie zbierka pre zvolený Architecture.

Poznámka

Nové komponenty a spoje sú pridané v predvolenom nastavení na najvyššej úrovni komponentov alebo pripojenie zbierky zvolenej architektúry. Ak chcete zmeniť rodič nových komponentov alebo pripojenia kliknite pravým tlačidlom myši hierarchiu cesta bunky pre nový komponent, alebo pripojenie riadku a vyberte Zmeniť Parent ...a vyberte požadovaný rodičia (ktoré berú na vedomie obmedzenie zvýraznenie ).

Poznámka

Nové riadky / prvky, pridávať priamo do katalógu cez "Pridať nový" tlačidlo, vložiť do katalógu, alebo vytvorené prostredníctvom dovozu do katalógu z MS Excel sú oslobodené od filtrovanie, kým nie je uzavretý katalóg. To je umožniť všetky potrebné úpravy hodnôt stĺpcov, ktoré môžu nespĺňajú existujúce kritériá filtrovania tohto katalógu. Tieto nové prvok riadky sú označené symbolom "+" v voliča riadku bunky na začiatku riadku, ktorý je sfarbený zelená v prípade, že v súčasnej dobe spĺňa element uložené filtrovacie kritériá tohto katalógu (tj zostane v katalógu knižnice, ak re-otvorené), a červená ak to tak nie je.

2. K odobratie súčasť alebo prípojkazvoleného typu z Katalóg (a projekt), vyberte riadok a buď stlačte klávesu Del alebo pravým tlačidlom myši na volič riadku a vyberte Odstrániť z architektúry, riadok by mal zmiznúť z katalógu a to bude vymazaný z projektu.

K filter za použitia Katalóg Zobraziť v ABACUS

1. Uistite sa, že máte Katalógové zobrazenie otvorený.

2. Ak sa filter riadok sa nezobrazuje v hornej časti katalógu potom kliknite na tlačidlo Show Filter záhlavímtlačidlo na paneli nástrojov.

3. V stĺpci chcete pridať filter, dvakrát kliknite na filter riadku bunky, kde sa ukazuje "(všetko)".

4. Pre Časovú pečiatku, hierarchie Path, Menoalebo Popisvšeobecné stĺpca alebo Text, Integer, desiatkovej, Booleanalebo Dátum ČasIzby stĺpce kliknite na tlačidlo ..., ktorý sa zobrazí v pravej časti filtra riadku bunky a zadajte hodnoty buniek, ktoré by mali byť zahrnuté do katalógu.

Poznámka

Prispôsobenie sa vykonáva, ako keby "*" zástupné znaky sú automaticky použité pred a po každej hodnoty reťazca tak, že vstup "mačkou" (bez úvodzoviek) by mali zahŕňať riadky s "bobmačka','mačkažena "alebo" Applemačkaion "atď. Viacnásobné /" alebo "hodnoty môžu byť zapísané na nových tratiach s využitím Ctrl + Enter, Pre Integer a desatinná vlastníctva stĺpcoch "a" môže byť logika zahrnuté použitím "&"(Bez úvodzoviek) a vyšší ako / menej ako etc logiky môžu byť zahrnuté pomocou '> =','>','<"A"<="(Bez úvodzoviek), napr. '> = 50000 & <90000 ". Non-prázdne oceňovaného radu môžu byť zahrnuté zadaním "(Non-Prázdne)"(Bez úvodzoviek) a prázdne riadky v hodnote môžu byť zahrnuté zadaním"(Prázdne)"(Bez úvodzoviek).A napokon, všetky filtre sú v predvolenom nastavení malé a veľké písmená, takže "mačkou" (bez úvodzoviek) by mali zahŕňať riadky s "mačkou", "mačkou" alebo "mačkou" atď pre prípad citlivé vyhovujúce, zadajte "(Case)"(Bez úvodzoviek) pred reťazec napr. "(Rozsudok) Cat" (bez úvodzoviek) by mali zahŕňať len riadky s "mačkou" v nich.

5. Pre Prílohystĺpy, Normy stĺpce alebo Zoznam Izby stĺpce kliknite na tlačidlo so šípkou dole, ktorá sa zobrazí v pravej časti filtra riadku bunky a vyberte hodnoty buniek z políčok, ktoré by mali byť zahrnuté do katalógu.

Poznámka

"(Vybrať všetko)" políčka umožní všetky ostatné zaškrtávacie políčka, v skutočnosti vrátane všetkých dostupných radoch. "(Non-Prázdne)" políčko bude zahŕňať žiadne neprázdne oceňujú riadkov. "(Prázdne)" políčko bude obsahovať žiadne prázdne riadky ocenené. A konečne, zrušením začiarknutia políčka žiadne konkrétne ocenené automaticky odškrtnite "(vybrať všetko)" a "(Non-prázdne miesta)," zaškrtávacích políčok pre konzistenciu.

6. Kliknite na tlačidlo OK použiť filter.

K povoliť / zakázať filtrovanie a Katalóg Zobraziť v ABACUS

1. Uistite sa, že máte Katalógové zobrazenie otvorený s filter aplikovaný.

2. Označte políčko vľavo od filtra riadku.

K odstrániť filter z a Katalóg Zobraziť v ABACUS

1. Uistite sa, že máte Katalógové zobrazenie otvorený s filter aplikovaný.

2. Ak chcete odstrániť jednotlivé stĺpec filter kliknite pravým tlačidlom myši na nadpis stĺpca a vyberte Stĺpec | Clear Filtrovanie.

3. Ak chcete odstrániť všetky filtre kliknite na tlačidlo Možnosti panel nástrojov tlačidlo a vyberte Vymazať nastavenie filtrov.

Zachrániť / uložiť ako aKatalógové zobrazenie

Poznámka

Zatiaľ čo všetci používatelia architekt môže vytvoriť nové Katalógy, uložiť zmeny nastavenia existujúceho Katalóg je užívateľská licencie potrebuje Designer add-on schopnosti. To je "chrániť" konfiguráciu existujúcich katalógov, ktoré môžu byť zdieľané mnoho užívateľov. Avšak, Architekt používa bez Návrhár doplnok môže ešte zvoliť "Uložiť ako" každé nové nastavenie do nového katalógu. A samozrejme všetky licencie Užívateľ si môže vybrať "zbaviť sa" prípadných zmien existujúceho katalógu. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution ak vyžadujete Návrhár doplnok schopnosť.A pamätajte si, to je len nastavenie katalógu, všetky úpravy vykonané na základe údajov v katalógu sú okamžite aplikované na úložisko, bez ohľadu na to.

1. Uistite sa, že máte novú alebo existujúce Katalógové zobrazenie otvorenýa vy ste vykonali potrebné zmeny.

2. V Katalógové zobrazenieúloh kliknite na tlačidlo na Savetlačidlo pre uloženie Katalógové zobrazenie a všetky zmeny formátovania.

Poznámka

Ak nemáte tlačidlo Uložiť na paneli nástrojov Katalógové zobrazenie potom nemáte Návrhár doplnok a ste schopní len Uložiť akožiadne nastavenie sa zmení do nového katalógu, keď idete na zatvorenie existujúceho katalóg.

3. Ak KatalógNázovZobrazí sa dialógové okno (kvôli tomu, že nový katalóg) zadajte názov pre katalóg a stlačte tlačidlo OK.

K export do katalógu MS Excel

1. Uistite sa, že máte Katalógové zobrazenie otvorený.

2. Kliknite na tlačidlo Export do Excelu katalóg tabuľkytlačidlo na paneli nástrojov.

3. Zvoľte názov súboru, ktorý chcete uložiť katalóg MS Excel ako. Kliknite na tlačidlo Save.

Poznámka

V predvolenom nastavení exportovaného MS Excel katalógový filename bude meno katalóg suffixed názvom Architecture v zátvorke, napr "Projekty (2.014 Actual) Xlsx". Môžete zmeniť čokoľvek z toho, vrátane toho, či je formát súboru bude Xlsx alebo XLS. Meno Architektúra je súčasťou upozorniť používateľa, že každý katalóg má konkrétny obsah (tj ID v stĺpci A a riadku 1), ktorý umožňuje, aby bol guľatý, zakopol späť pomocou Importovať z katalógu MS Excel podľa nižšie.

Poznámka

V predvolenom nastavení skryté Stĺpec A v rámci vyváženého katalógu MS Excel obsahuje jedinečný identifikátor pre každý z prvkov v úložisku ABACUS. To umožní, aby zmeny vykonané v MS Excel, ktoré majú byť "uzavreté" s existujúcimi prvkami v rámci ABACUS pri dovoze (pozri nižšie). Avšak, použitie tejto jedinečnej ID na "zladiť" riadkov môže byť vyradený s Externý | IDnehnuteľnosti na prvku. To znamená, že v prípade, že prvok má externú | ID vlastníctva a je zahrnutá do katalógu vývozu sú hodnoty na externom | ID stĺpec bude použitý k zladiť riadkov pri dovoze (pozri nižšie) a jedinečný identifikátor hodnoty v skrytom stĺpci A budú ignorované (a môže byť aj prázdny). Skrytý Stĺpec A sama o sebe musí zostať, však, najmä hodnota v bunke A1. Navyše, pri pridávaní externých id do existujúcej kolekcie ABACUS prvkov odporúčame pridať je ako iný majetok ako prvý, napr Externý | Temp a potom ho premenuje vlastnosť k externému | ID. V opačnom prípade budú pridané duplicitné prvky.

Katalóg formátovanieje exportovaný v predvolenom nastavení, ale pre veľké katalógy to môže mať za následok, že export docela pomalý. V súlade s tým, v Nástroje | Možnosti ...potom na KatalógKarta,ste schopní znížiť množstvo formátovania, ktoré je vyvezený, ako je uvedené na karte katalóg nižšie, čím sa urýchli export.

Katalóg export Možnosti

4. Zobrazí sa dialógové okno Export Dokončené. Kliknite na tlačidlo OK.

Exportovaný do katalógu MS Excel

K import z katalógu MS Excel

Poznámka

V predvolenom nastavení skryté Stĺpec A v rámci vyváženého katalógu MS Excel (pozri vyššie), obsahuje jedinečný identifikátor pre každý z prvkov v úložisku ABACUS. To umožní, aby zmeny vykonané v MS Excel, ktoré majú byť "uzavreté" s existujúcimi prvkami v rámci ABACUS pri dovoze. Avšak, použitie tejto jedinečnej ID na "zladiť" riadkov môže byť vyradený s Externý | IDnehnuteľnosti na prvku. To znamená, že v prípade, že prvok má externú | ID vlastníctva a je zahrnutá v katalógu na vývoze (pozri vyššie), potom hodnoty externého | ID stĺpec bude použitý k zladiť riadky v prípade dovozu a jedinečné hodnoty ID v skrytom stĺpci A budú ignorované (a môže byť aj prázdny). Skrytý Stĺpec A sama o sebe musí zostať, však, najmä hodnota v bunke A1. Navyše, pri pridávaní externých id do existujúcej kolekcie ABACUS prvkov odporúčame pridať je ako iný majetok ako prvý, napr Externý | Temp a potom ho premenuje vlastnosť k externému | ID. V opačnom prípade budú pridané duplicitné prvky.

1. Uistite sa, že máte Katalógové zobrazenie otvorený.

2. Kliknite na tlačidlo Import z Excel katalóg tabuľkytlačidlo na paneli nástrojov.

3. Zvoľte názov súboru, ktorý chcete importovať katalóg MS Excel z. Kliknite na tlačidlo Otvorené.

4. Nové Chyby zistené a / alebo nové chyby / varovania Zistené dialógy sa môžu objaviť na akýkoľvek nový obsah (tj riadky v MS Excel), ktorá bola pridaná. Vezmite na vedomie chýb / varovania a kliknite na tlačidlo OK.

5. Zobrazí sa dialógové dokončení importu sa zobrazí a môže ukázať varovanie v dôsledku dovozu (pozri poznámky nižšie). Kliknite na tlačidlo OK.

Poznámka

U pridelených štandardy alebo pripojených stĺpov Príslušenstvo, nové položky v katalógu cez MS Excel musí zodpovedať presne názov existujúceho štandardu alebo jeho súčasť správneho typu pre postúpenie alebo pripojenie, ktoré sa dopĺňajú. Prvý s názvom Zápas bude použitý a všetky neuzavreté položky bude generovať upozornenia podľa nižšie. Okrem toho, zatiaľ čo varovanie sú uvedené na re-import, prvky sú nie je odstránenýz ABACUS v prípade, že nie sú prítomné v katalógu MS Excel. To je preto, že neexistuje žiadny spôsob, že ABACUS môže vedieť, či je priradený štandardnej alebo pripojené Component existuje v rámci projektu ABACUS, ale neexistuje v katalógu MS Excel, pretože to bola vymazaná z katalógu MS Excel alebo bola pridaná do počítadla projekt od katalógu bol vyvezený. V súlade s tým, ak používatelia chcú ľahko "odhaliť", ktoré boli počas procesu importu pridá pripojenie môžu jednoducho vytvoriť požadovaný majetok na type pripojenia a nastavenie je predvolené, aby prázdne tak, že budú varovaní o všetkých nových pripojení zakaždým, keď sa dovozné je dokončená.

Poznámka

Pri importe katalógu MS Excel môže byť zobrazená rôzne varovania. Po prvé, ak nový stĺpec bol pridaný do programu Excel, ktoré nezodpovedá "syntax" pre vlastnosť alebo pripojené komponenty stĺpec bude ignorovaný. Ďalej bude varovanie riadok po riadku sa zobrazí u všetkých emisií s údajmi o každom riadku katalógu Excel. Tieto varovania začať s číslom riadku v hranatých zátvorkách a ak je to relevantné nadpisu stĺpca (tj "[23, j] ..." pre riadok 23, stĺpec J) a môže odkazovať na zmazaných položiek, neuzavreté noriem alebo pripojených mien Component (čo sú ignorované podľa poznámky vyššie) alebo neplatné alebo prázdne ID týkajúce sa nového riadku / prvku (ktorý bude doplnené). Podrobný článok o vyplnenie Abacus pomocou katalógov Excel nájdete v časti Avolution Community alebo školenie Portfolio Manager.

Poznámka

Nové komponenty a spoje sú pridané v predvolenom nastavení na najvyššej úrovni komponentov alebo pripojenie zbierky zvolenej architektúry. Ak chcete zmeniť rodič nových komponentov alebo pripojenia kliknite pravým tlačidlom myši hierarchiu cesta bunky pre nový komponent, alebo pripojenie riadku a vyberte Zmeniť Parent ...a vyberte požadovaný rodičia (ktoré berú na vedomie obmedzenie zvýraznenie ).

Poznámka

Prvky pridaný priamo do katalógu cez "Pridať nový" tlačidlo, vložiť do katalógu, alebo vytvorené prostredníctvom dovozu do katalógu z MS Excel sú oslobodené od filtrovanie, kým nie je uzavretý katalóg. To je umožniť všetky potrebné úpravy hodnôt stĺpcov, ktoré môžu nespĺňajú existujúce kritériá filtrovania tohto katalógu. Tieto nové prvok riadky sú označené symbolom "+" v voliča riadku bunky na začiatku riadku, ktorý je sfarbený zelená v prípade, že v súčasnej dobe spĺňa element uložené filtrovacie kritériá tohto katalógu (tj zostane v katalógu knižnice, ak re-otvorené), a červená ak to tak nie je.

K porovnať obsah katalógu s inou architektúrou

1. Pozrite sa prosím na tému tu .

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Naplnenie vašej architektúry od aplikácie Visio | Naplnenie vašej architektúry z programu Excel


Naplnenie pomocou Matice

Navigácia: Naplnenie vašej architektúry>

Naplnenie pomocou Matice

Odoslať pripomienky na túto tému.

Matrice vám umožní prezerať a upravovať "priame" prepojenia medzi komponentmi v jednoduchej tabuľkovej spôsoboma tiež zobraziť "nepriamy cestu" medzi zložkami podľa akéhokoľvek sprostredkujúceho zložiek (a spojov).

K vytvoriť pohľad Matrix v ABACUS

Poznámka

Zatiaľ čo všetci používatelia architekt môže vytvoriť Matica s nimi a / alebo ich nastavenie Uložiť užívateľská licencie potrebuje Designer add-on schopnosti. To je "chrániť" konfiguráciu existujúcich matíc, ktoré môžu byť zdieľané mnoho užívateľov. Avšak, Architekt používa bez Návrhár doplnok môže ešte zvoliť "Uložiť ako" každé nové nastavenie do nového Matrix. A samozrejme všetky licencie Užívateľ si môže vybrať "zbaviť sa" prípadných zmien existujúceho Matrix. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

1. Vyberte Vložiť | Matrix.

2. V rchitecture>pull-down vyberte architektúru, ktorá obsahuje komponenty a pripojenie, ktoré chcete zobraziť.

3. V <ZdrojTyp>pull-down vyberte typ komponenty, ktoré chcete mať inštancie uvedené ako "riadky' dole vľavomatrice.

4. V <SinkTyp>pull-down vyberte typ komponenty, ktoré chcete mať inštancie uvedené ako "stĺpce' cez hornúmatrice.

5. V pull-down V zásade existujú dve "režimy" matrice možno definovať ...

Pripojenie "priame" matrice

6. Jednoducho toElect jeden (1) alebo viac prípojka typy Na pravej strane menu, ktoré sa objaví v prípade, Ak chcete vidieť v "bunkách" matrice, ak: an explicitnéSpojenie existuje od Vertikálne/ "riadok"Zložkou matrice do Horizontálne/ "stĺpec"Zložkou matrice.

Poznámka

Iba spojenie s zdrojom koniec pripevnený k Vertikálne/ "riadok"Komponent a umývadlo koniec pripojený k Horizontálne/ "stĺpec"Sa zobrazí zložka. Switch Zdroja Sinkkomponentov výbery typ zobrazenia spojenie v opačnom smere.

7. Matica bude naplnený "X" v bunkách (alebo majetkové hodnoty - pozri poznámku nižšie) ak je spojenie od Vertikálne/ "riadok "zložkou matrice pri The Horizontálne/ "stĺpec"Zložkou matrice.

Poznámka

U veľkých matíc sa zobrazí v dobe, ako je znázornené na 'R' a ukazovateľov 'C' v ľavej hornej bunky hlavičky, respektíve len maximálne 100 riadkov alebo stĺpcov (vrátane zrútených riadkov / stĺpcov). Ak chcete zobraziť ďalšie riadky použite posuvníky. Kedykoľvek môžete poklepať na Vertikálne/ "riadok"Alebo Horizontal / "stĺpec"Dielom nadpisy a skok nazodpovedajúce komponenty v okne Prieskumníka.Rodičia vertikálneho/ "riadok' a Horizontálne/ "stĺpec"Dieloms sú tiež voliteľne zobrazené ako nadpis riadky / stĺpce so šedou titulom čísla. Keď sa zrútil (jediným kliknutím na nadpis buniek), ak deti prílohy existovala potom s "X" sa voliteľne byť zobrazené, ak boli pripojené všetky deti, alebo "O" sa voliteľne byť zobrazené, ak niektoré z detí boli pripojené iba. Bunky môžu byť farebný podľa hodnoty nehnuteľnosti prípojok kliknutím na Options 'ozubeného kolesa "v pravom hornom rohu panela nástrojov matice a výberom Nastavenie farieb ... a potom na tlačidlo Upraviť a výberom Farba pečiatka alebo Colour majetkom voľbu pomocou a voľbou nehnuteľnosť, rozsahu min a Max hodnoty a výbere farieb, avšak iba Zoznam, Integer, desiatkovej, Boolean alebo Dátum / Čas Vlastnosti typ dát bude farbu. Ak sa zrútil bunka bude farebne v závislosti na priemernej hodnoty vlastnosti spojenia. Namiesto toho, aby "X", môže byť majetkové hodnoty pre bunky zobrazené kliknutím na Options 'ozubeného kolesa "v pravom hornom rohu panela nástrojov matice a výberom Zobraziť nastavenie hodnôt ... a potom na tlačidlo Upraviť a vyberiete možnosť Zobraziť zariadenia a výberom nehnuteľnosti.

Priama spojenie matice ukazujúci servery, kde sú aplikácie hostované s sfarbenie a majetku, ktorý je preukázané, namiesto všeobecný "X"

- OR -

"Nepriamou" Pripojenie matice

6. SElectpostupnosť prípojka typy a typy komponentovna pravej a ľavej strane menu, ktoré sa objaví v prípade, Ak chcete vidieť v "bunkách" matrice, ak: an nepriama cesta pripojených komponentovexistujú od Vertikálne/ "riadok"Zložkou matrice do Horizontálne/ "stĺpec"Zložkou matrice.

Poznámka

Akákoľvek platná cesta, ktorá zahŕňa prvky vybrané v ponuke dráhy wzle sa zobrazíbez ohľadu na smer podkladových spojov, však, pri výbere sa dráha najprva Posledná prvky musia byť vybrané typy pripojenia. Okrem toho objednať z prvkov, ktoré boli vybrané je zobrazený s číselné prefixv námestia ("[]") držiaky a daný typ môže byť zahrnutý zahŕňa viac krátv dráhe (ako je uvedené v číselnej prefix). Postupný výber typov komponentov alebo typov pripojenia je interpretovaný ako "Alebo"cesta a hierarchie pripojených komponentov môže byť prípadne zahrnuté zaškrtnutím 'Hľadať tiež príloh rodičia / deti"Začiarkavacie políčko. Switch Zdroja Sinkkomponentov výbery typu zobrazíte Cesty v opačnom smere.

7. Matice sa vyplní scesta / kolekcia komponentovv bunkách, ak je cesta z Vertikálne/ "riadok "zložkou matrice pri The Horizontálne/ "stĺpec"Zložkou matrice.

Poznámka

U veľkých matíc sa zobrazí v dobe, ako je znázornené na 'R' a ukazovateľov 'C' v ľavej hornej bunky hlavičky, respektíve len maximálne 100 riadkov alebo stĺpcov (vrátane zrútených riadkov / stĺpcov). Ak chcete zobraziť ďalšie riadky použite posuvníky. Kedykoľvek môžete poklepať na Vertikálne/ "riadok"Alebo Horizontal / "stĺpec"Dielom nadpisy a skok nazodpovedajúce komponenty v okne Prieskumníka.Rodičia vertikálneho/ "riadok' a Horizontálne/ "stĺpec"Dieloms sú tiež voliteľne zobrazené ako nadpis riadky / stĺpce so šedou titulom čísla. Keď sa zrútil (jediným kliknutím na nadpis buniek), ak nejaké deti cesty existovali potom s "X" sa voliteľne byť zobrazené, ak boli pripojené všetky deti, alebo "O" bude prípadne sa zobrazí iba vtedy, ak niektoré z detí malo cesty. Nepriame zložky môže byť cesta farebný podľa hodnoty nehnuteľnosti zložiek kliknutím na Options 'ozubeného kolesa "v pravom hornom rohu panela nástrojov matice a výberom Nastavenie farieb ... a potom na tlačidlo Upraviť a výberom Farba pečiatka alebo Colour majetkom voľbu pomocou a voľbou nehnuteľnosť, rozsahu min a Max hodnoty a výbere farieb, avšak iba Zoznam, Integer, desiatkovej, Boolean alebo Dátum / Čas Vlastnosti typ dát bude farbu. Hodnoty majetku za nepriame zložiek môže byť cesta zobrazené kliknutím na Options 'ozubeného kolesa "v pravom hornom rohu panela nástrojov matice a výberom Zobraziť nastavenie hodnôt ... a potom na tlačidlo Upraviť a vyberiete možnosť Zobraziť zariadenia a výberom nehnuteľnosti.

Nepriame pripojenie matice ukazuje aplikácie, ktoré implementujú danú službu podľa oddelenia

K filterpohľad Matrix v ABACUS

1. Uistite sa, že máte novú Matrix pohľad otvorený.

2. Kliknite na filter os "lievik" v pravom hornom rohu panela nástrojov matice.

3. O zdrojmi a / alebo kariet Drezové pridať meno, majetku, opis, hierarchie alebo štandardných filtrov kliknutím na tlačidlo Pridať, výberom nehnuteľnosti v prípade potreby a kliknutím OK, Vyberte príslušné voľby v paneli Kľúčové slová / položiek pomocou logiky / syntaxe, ako je popísané v nasledujúcej poznámke. Náhľad panel sa automaticky aktualizuje, aby ukazujú výsledky aktuálnej sady filtrov.

Poznámka

Pre Časovú pečiatku, hierarchie Path, Menoalebo Popisfiltre alebo Text, Integer, desiatkovej, Booleanalebo Dátum ČasIzby filtre zodpovedajúce sa vykonáva, ako keby "*" zástupné znaky sú automaticky použité pred a po každej hodnoty reťazca tak, že vstup "mačkou" (bez úvodzoviek) by mali zahŕňať riadky s "bobmačka','mačkažena "alebo" Applemačkaion "atď. Viacnásobné /" alebo "hodnoty môžu byť zapísané na nových tratiach s využitím Ctrl + Enter, Pre Celé číslo a Desatinné nehnuteľností filtre "a" logika môžu byť zahrnuté pomocou "&"(Bez úvodzoviek) a vyšší ako / menej ako etc logiky môžu byť zahrnuté pomocou '> =','>','<"A"<="(Bez úvodzoviek), napr. '> = 50000 & <90000 ". Non-prázdne oceňovaného radu môžu byť zahrnuté zadaním "(Non-Prázdne)"(Bez úvodzoviek) a prázdne riadky v hodnote môžu byť zahrnuté zadaním"(Prázdne)"(Bez úvodzoviek).Pre Normy alebo Zoznam Vlastnosť Filtre "(Vybrať všetko)" políčka umožní všetky ostatné zaškrtávacie políčka, v skutočnosti vrátane všetkých dostupných prvkov. "(Non-Prázdne)" políčko bude obsahovať všetky non-prázdne nehnuteľnosť ocenia prvky. "(Prázdne)" políčko bude obsahovať žiadne prázdne nehnuteľnosť ocenia prvky. A odškrtnutí žiadna špecifická oceňujú políčka automaticky zrušte výber "(Vybrať všetko)" a "(non-Prázdne)" zaškrtávacie políčka pre konzistenciu. A napokon, všetky filtre sú v predvolenom nastavení malé a veľké písmená, takže "mačkou" (bez úvodzoviek) by mali obsahovať prvky s "mačkou", "mačkou" alebo "mačkou" atď pre prípad citlivé vyhovujúce, zadajte "(Case)"(Bez úvodzoviek) pred reťazec napr. "(Rozsudok) Cat" (bez úvodzoviek) by mali zahŕňať iba prvky s "mačkou" v nich.

K naplneniu pomocou zobrazenia Matrix v ABACUS

Poznámka

Môžete pridať / odobrať pripojenie, kde má jediný typ pripojenia boli použité pre cestu vyššie popísaného.

1. K pridanie pripojeniezvoleného typu medzi A Vertikálne/ "riadok"Komponent a Horizontálne/ "stĺpec"Zložkou matrice, kde" doteraz neexistuje X '(alebo Zobrazená hodnota nehnuteľnosti - pozri poznámku vyššie)Dvakrát kliknite na bunku. By sa mal objaviť "X" (alebo hodnota nehnuteľnosti - pozri poznámku vyššie) a spojenie bude vytvorený na najvyššej úrovni kolekcie pripojenia pre zvolený Architecture.

Poznámka

Názov pripojenia bude Názov typu pripojenia podľa nastavenia typu pripojenia matrice a ak je majetkové hodnoty je zobrazené miesto "X" východiskovú hodnotu pre vlastnosť sa zobrazí.

2. K upraviť zobrazenú hodnotu vlastnostina spojenie medzi a Vertikálne/ "riadok"Komponent a Horizontálne/ "stĺpec"Zložkou matriceDvakrát kliknite na bunku, alebo kliknite pravým tlačidlom myši na bunku a vyberte Upraviť hodnotu ..., a upraviť hodnotu v dialógovom okne Zmeniť hodnoty.

3. K Odobratie pripojeniezvoleného typu medzi A Vertikálne/ "riadok"Komponent a Horizontálne/ "stĺpec"Zložkou matrice, kde" X ", už existuje(alebo Zobrazená hodnota nehnuteľnosti - pozri poznámku vyššie), doprava-kliknite na bunkua vyberte Odpojiť, X by mal zmiznúť a spojenie bude odstránený z projektu.

Zachrániť / uložiť ako aMatrix pohľad

Poznámka

Zatiaľ čo všetci používatelia architekt môže vytvoriť Matica s nimi a / alebo ich nastavenie Uložiť užívateľská licencie potrebuje Designer add-on schopnosti. To je "chrániť" konfiguráciu existujúcich matíc, ktoré môžu byť zdieľané mnoho užívateľov. Avšak, Architekt používa bez Návrhár doplnok môže ešte zvoliť "Uložiť ako" každé nové nastavenie do nového Matrix. A samozrejme všetky licencie Užívateľ si môže vybrať "zbaviť sa" prípadných zmien existujúceho Matrix. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution ak vyžadujete Návrhár doplnok schopnosť.A pamätajte si, to je len nastavenie Matrix, všetky úpravy vykonané na dáta v Matrixe sú okamžite aplikované na úložisko, bez ohľadu na to.

1. Uistite sa, že máte novú Matrix pohľad otvorenýa vy ste vykonali potrebné zmeny.

2. V Matrix pohľadPanel s nástrojmi kliknite na úplne vľavo Save Matricetlačidlo pre uloženie Matrix pohľad a všetky zmeny formátovania.

Poznámka

Ak nemáte tlačidlo Uložiť na paneli nástrojov Matrix pohľadu potom nemáte Návrhár doplnok a ste schopní len Uložiť akožiadne nastavenie sa zmení na novú maticu, keď idete na zatvorenie existujúce matice.

3. Ak MatriceNázovDialóg, ktorý sa objaví (kvôli tomu, že nové matrix) zadajte názov pre maticea stlačte tlačidlo OK.

K Export do MS Excel matice

1. Uistite sa, že máte Matrix pohľad otvorený.

2. Kliknite na tlačidlo Export do Excelutlačidlo na paneli nástrojov.

3. Zvoľte názov súboru pre uloženie matice MS Excel ako. Kliknite na tlačidlo Save.

Poznámka

V predvolenom nastavení exportovaného MS Excel Matrix filename bude názov Matrix suffixed názvom Architecture v zátvorke, napr "Žiadosti hostované na serveroch (v roku 2014 Actual) Xlsx". Môžete zmeniť čokoľvek z toho, vrátane toho, či je formát súboru bude Xlsx alebo XLS.

Formátovanie Matrixje exportovaný v predvolenom nastavení, ale pre veľké matice to môže mať za následok, že export docela pomalý. V súlade s tým, v Nástroje | Možnosti ...potom na MatriceKarta,ste schopní znížiť množstvo formátovania, ktoré je vyvezený, ako je uvedené na karte pod Matrix, čím sa urýchli export.

Export Matrix Možnosti

4. Zobrazí sa dialógové okno Export Dokončené. Kliknite na tlačidlo OK.

Exportovať do MS Excel matice

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Naplnenie vašej architektúry od aplikácie Visio | Naplnenie vašej architektúry z programu Excel


Naplnenie Diagramy

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Naplnenie Diagramy

Odoslať pripomienky na túto tému.

Výkresy v ABACUS sú viac než len ľubovoľných reprezentáciou. Sú prispôsobené pohľady na architektúru, formátované a usporiadané tak, aby ukázať osobitný význam.

Nástroje na kreslenie vynucuje hierarchickú štruktúru architektúry, takže komponenty sú vizuálne vnorené do ďalších komponentov - efektívne dáva "pôdorys" týchto prvkov. Akonáhle je zložka alebo spojenie bola definovaná v architektúre, je možné ho použiť v ľubovoľnom počte rôznych diagramov. Dôležité je, že Prievlak je úzko spojené s architektonického modelu, takže zmeny vykonané buď v jednom, sú vždy prejaví v druhej.

Nástroj funguje tak, že spojením tvary s konkrétnym spojenie a komponentov typov definovaných v časti Typy architektúry. Tieto asociácie sa líšia v závislosti od typu diagramu, že je priťahovaný, a je možné, že jeden typ zložky (či spojenia) môžu mať rôzne reprezentácie v rôznych schémach, v závislosti na kontexte.

Ak chcete nastaviť asociáciu medzi tvarom a súčasť alebo typu pripojenia

1. Uistite sa, že máte nové alebo existujúcej diagram open .

2. Maximalizovať aplikáciu ABACUS, a nakonfigurovať okná proporcie ako si prajete.

3. Vyberte Karta Tvaryalebo Karta Konektory v okne vzorkovníka.

4. V Druhvetva Explorer, vyhľadajte komponentov alebo typ pripojenia, ktorý chcete spojiť s tvarom alebo konektor.

5. Vyberte vybraný typ prvku zo stromu, pretiahnite ju cez na kartu tvarov alebo karte Konektory, a umiestnite ho do tvaru alebo konektoraby ste chceli použiť.

Poznámka

Môžete si overiť, združenia, ktoré ste vytvorili výberom komponentov alebo kartu pripojenia v okne vzorkovníka, ktoré ukazujú aktuálne spojené prvky.

Ak chcete pridať nové tvary diagramov / knižnice

1. Vytvorte diagram aplikácie Visio MS s tvarmi, ktoré chcete pridať do diagramu a importovať schéma MS Visio .

Tip

Je dôležité, akú veľkosť stránky ako hlavný tvar MS Visio, pretože ABACUS plátno je dimenzovaný v pixeloch a iba jednotky Milimetre v MS Visio previesť granularly do pixelov na 4 pixely 1 milimeter pomere. Okrem toho, východiskové Abacus tvary sú typicky 60 pixelov vysoká, takže sa premieta do 15 milimetrov v MS Visio. Považované za vhodné majster veľkosť tvar MS Visioje 25mm široký a 15 mm vysokéako to bude prekladať do 100 pixelov a výškou 60 pixelov v ABACUS.

Tip

Ak chcete mať "ikonu" trochu v ľavom hornom rohu tvaru, potom môžete jednoducho vytvoriť "ikonu" v hlavnom tvare MS Visio pomocou palety MS Visio Drawing Tool (Všimnite si, že iba jednoduché linky, kruhy a obdĺžniky sú podporované a rastrové / bitmapové tvary najmä nie sú podporované). Navyše, ak chcete, aby ikona byť pevná vo veľkosti / meradlev tvare v ABACUS potom môžete zoskupiť "ikona" v hlavnom MS Visio tvaru výberom všetky jej prvky, pravým kliknutím jeden prvok, výber Tvar | Skupina, pravým tlačidlom myši na zoskupené tvar a výber dát | Tvar dáta ..., vyberiete Áno v dialógovom okne, ktoré sa objavia, a potom sa pridá vlastnosť so štítkom nastaveným na LockScale(všimnite si veľké písmeno "L" a "S"), typ nastaviť na Boolean a hodnota nastavený na TRUE (všimnite si, že je všetko v veľkými písmenami).

Tip

Ak chcete mať časť tvaru mrazené od mierky vodorovne alebo zvisle (ako je typický s 'swimlane "tvar), potom môžete kliknúť pravým tlačidlom myši na časť (y) z obrazce MS Visio, ktoré chcete mrazený od mierky a vyberte údaje | Tvar dáta ..., vyberiete Áno v dialógovom okne, ktoré sa objavia, a potom sa pridá vlastnosť so štítkom nastaveným na LockXScalealebo LockYScale (všimnite si veľké písmeno "L" a "S"), typ nastaviť na Boolean a hodnota nastavený na TRUE (všimnite si, že je všetko v veľkými písmenami), za zamknuté vodorovné alebo zvislé mierka, resp.

Tip

Aby bolo možné sfarbenie tvaru v ABACUS po importe skôr než tvar vždy byť pevná farba, je vhodné, aby sa výplň master MS Visio obrazec priehľadný a potom použiť vstavaný schopnosti v ABACUS na farbu pozadia obrazce. To pracuje len s obdĺžnika alebo blízko-obdĺžnika (napr zaoblený obdĺžnik) tvarov, ako celá obdĺžnikové pozadie budú sfarbené.

2. Otvorte zodpovedajúce tému a vyberte Záložka Komponentyv okne vzorkovníka.

3. Pre každý nový tvar, ktorý chcete sprístupniť ostatným diagramy Kliknite pravým tlačidlom myšitvar a vyberte Pridať do Tvary knižnice, To umožní, aby tvar k dispozícii na karte tvary v okne vzorkovníka.

4. Pridružiť príslušný komponentu s novým tvarom z knižnice tvaroch podľa vyššie popísaných krokov.

Poznámka

Iba jednoduchý a "vektorový" tvary sú podporované v ABACUS v okamihu, tj rastre nie sú podporované. Avšak, nástroje ako Vector mágie ( www.vectormagic.com ), Sú k dispozícii, ktoré budú ľahko prevádzať rastrových obrázkov do tvarov na báze vektorov (tj formátu SVG), ktoré je možné otvoriť v programe MS Visio, a preto využívaných v ABACUS podľa vyššie uvedených pokynov.

PridanieKomponenty a pripojenie

Nástroje pre kreslenie umožňuje pridať existujúce komponenty a pripojenie z úložiska alebo vytvárať nové komponenty a pripojenie, ako ste výkresu diagramu. Ako komponenty a spoje sú vytvorené v diagramoch, sú súčasne pridané do sklad, Existujú Tri odporúčané spôsoby pridávanie zložiek do diagramua tri odporúčané spôsoby pridávanie pripojenie ku schéme:

Ak chcete vytvoriť úplne novú zložku alebo pripojenie na diagramez šablóny

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Vyberte Komponentyalebo PripojenieKarta v okne vzorkovníka vidieť súvisiace tvary. Iba tieto tvary môžu byť použité na vytvorenie novej prvky modelu.

3. Kliknite na tlačidlo a pretiahnitejednou z dostupných súvisiacich tvarov na kresliace plátno. Novým prvkom sa objaví na plátne, a vo stromu explorer.

4. Začnite písaťnázov pre nový prvok v dialógovom okne a všetky existujúce prvky, ktoré sú prispôsobené sú navrhnuté a môžu byť zvolené, skôr než pridať nový prvok do architektúry.

5. Kliknite na tlačidlo OK.

6. Ak bol tvar klesla na existujúce komponenty, potom to bude buď stane dieťaťom, že komponent (v prípade, že tvar prišiel z Komponentykarta), alebo bude pripojená k tejto komponente (ak tvar prišiel z Pripojeniekarta).

Poznámka

Niekedy je nutné nastaviť nové komponenty alebo pripojenie na iné miesto v architektonickom hierarchii pomocou prieskumníka.

Ak chcete umiestniť existujúcu zložku alebo pripojenie zo sklad na diagrame

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Uistite sa, že máte obaja nástroje na kreslenie a Windows Explorer zobraziť.

3. V Prieskumníkovi, vyhľadajte zložkaalebo prípojka(element) by ste chceli pridať do diagramu.

4. Kliknite na tlačidlo a pretiahnitezvolený element na diagrame. Tvar zastupujúci prvok objaví na plátne.

Poznámka

Ak je typ zvoleného prvku je už spojený s tvarom, objaví sa na plátne zodpovedajúci tvar. Ak však nie je definovaná asociácie pre daný prvok, zobrazí sa na plátne ibaže A východzí tvar (obdĺžnik) Vynútiť diagram Uhly pohľadu možnosť je v tomto prípade je tvar nebude pridaná do diagramu.

Tip

Keď je súčasť umiestnená na diagram, ktorý je pripojený k inej súčasti už na diagrame, bude Prievlak dotaz, ak si prajete ukazujú pripojenia (y) medzi nimi. Tiež, ak existujú nejaké deti zložky nástroje na kreslenie bude dotaz, či by ste chceli zahrnúť deti, v rekurzívne spôsobom.

K vytvoriť spojenie medzi 2 zložiek alebo pripojeného zariadenia na diagrame pomocou dynamického konektor

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Vznášať sa cez komponent na schéme, ktoré chcete pripojiť k inej súčasti a uvidíte 2 ikony mimo pravej hornej hranice tvaru, ako je uvedené nižšie. Poznámka: Horný Ikona je pre vytvorenie spojenia, kde sa pohybovala zložka má byť zdrojom, ikona dno je pre vytvorenie spojenia, kde sa pohybovala zložka má byť drez.

3. Presunúť kurzor na požadovanú ikonu a kliknite a presuňteikona na viac ako jeden cez ďalšia zložka alebo voľného miesta na plátne, ako je uvedené nižšie.

4. Ak sa chcete pripojiť k existujúcej komponente vybrať Pripojiť k ...položka v pop-up menu a v prípade potreby vstúpili do ponuky vyberte z dostupných typov pripojení.

- Alebo -

4. Ak chcete vytvoriť pripojený komponentov vybral od Nový...položky v rozbaľovacej ponuke a v prípade potreby vstúpili do ponuky vybrať z dostupných typov pripojení, ako je uvedené nižšie. Začnite písaťnázov pre nový prvok v dialógovom okne a všetky existujúce prvky, ktoré sú prispôsobené sú navrhnuté a môžu byť zvolené, skôr než pridať nový prvok do architektúry.

Poznámka

Dostupnosť položiek v menu pop-up a sub-menu je riadené obmedzenia v meta-model.To je len platný zdroj alebo potopiť typy komponentov ako bolo stanovené obmedzenie pripojenia budú prezentované ako Pripojiť k ... a položky Nový ... menu.

K re-otvoriť dialógové okno pre výber prvku a umiestniť existujúce komponenty alebo pripojenie z úložiska na diagram

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Kliknite na tlačidlo Otvorené výberové ElementTlačidlo v paneli nástrojov diagrame. Poznámka: dialóg pre výber element sa otvorí s posledným stavom akýchkoľvek filtrov uložených.

3. Vyberte si akékoľvek ďalšie obsah, ktorý je žiaduce, aby byť pridané do schémy a kliknite na tlačidlo OK, Poznámka: Nový obsah bude pridaná do voľného priestoru na plátne a diagram môže byť dodatočne stanovené znova cez Layout DiagramTlačidlo v paneli nástrojov diagrame.

Použitie zdarmaformulárTvary

Často je žiaduce vytvoriť vizuálne prvky v diagrame z čisto estetických dôvodov. Tieto prvky môžu pomôcť zlepšiť usporiadanie a vzhľadu diagramu, napriek tomu nemajú striktné architektonický význam. Nástroje na kreslenie umožňuje použitie voľných tvarov poskytovať kreslenie flexibilitu.

Ak chcete pridať voľného tvaru tvar diagramu

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Vyberte Tvaryalebo KonektoryKarta v okne vzorkovníka.

3. Kliknite na tlačidlo a pretiahnitejeden z dostupných tvarov alebo konektory na kresliace plátno. Novým prvkom sa objaví na plátne - ale nievo stromu explorer.

Poznámka

Voľné tvary sú "non-spojený 'tvary, pretože nemajú žiadnu spojitosť s konkrétne súčasti alebo pripojenie do architektonického modelu.

K zobrazí úložisko informácií v netradičný tvarS naschéma

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Kliknite pravým tlačidlom myšikreslenie od ruky tvar a vyberte Anotácia | Zobrazenie.

3. Zvoliť zobrazenie buď Diagram Meno, Diagram Opis, Diagram Property, Viewpoint Menoalebo Architektúra Meno.

Poznámka

Text v FreeForm sa automaticky aktualizuje ako podkladové úložisko dátových zmien.Týmto spôsobom je možné vytvoriť schému 'title block "pre, a potom ľahko kopírovať medzi, diagramy.

Použitie Plávajúce tvarov

Plávajúce tvary sú v podstate ďalším spôsobom, ako predstavujú komponenty v diagrame. Zvážte organizáciu s kľúčovými divíziou: generálny riaditeľ, marketing, predaj a rozvoj.

Zobrazenie stromu

Tieto deliace plochy môžu byť vizuálne zastúpený vo vrstvené spôsobom:

Layered View

Alebo môžu byť vizuálne zastúpené v striedavo / Plávajúce spôsobom ukázať hierarchiu:

Potácal / Plávajúce Pohľad

Ten reprezentácie používa koncept plávajúcich tvarov.

Ak chcete previesť vrstveného tvar komponent do plávajúce tvaru

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Vyberte zložkav diagrame chcete reprezentovať ako plávajúce tvar alebo pridružené kondíciu vo KomponentyZáložka okne vzorkovníka chcete, aby všetky inštancie ako plávajúce tvarov.

3. Pravým tlačidlom myši na tvar a vyberte Float Component z kontextového menu, ktoré sa objavia. Všimnite si, že diamant v čele pripojeniez nadradeného priečinka (zložiek) na plávajúce zložky (zložiek).

4. Kliknite na tlačidlo a pretiahnitezložka na požadované miesto. Keď sa plávajúcekomponenta je vybraná bude mať modrý obrys.

Ak chcete previesť plávajúce tvar komponent do vrstvené tvaru

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Vyberte zložkav diagrame, ktorý je v súčasnej dobe znázornený ako plávajúce tvar alebo pridružené tvaru vo KomponentyZáložka okne vzorkovníka, ktorú chcete všetky inštancie ako vrstvené tvary.

3. Kliknite na tlačidlo a pretiahniteplávajúce zložka (y) späť na rodičov (s) (v závislosti na diamant v čele pripojenie). Poznámka: Ak nemáte to potom pri prevode komponent (y) späť k bytiu vrstvené by mohla byť ovplyvnená hierarchie modelu.

4. Pravým tlačidlom myši na tvar a zrušte Float Component z kontextového menu, ktoré sa objavia. Všimnite si, že diamant v čele pripojenieod materskej zložka (y), na plávajúce zložky (zložiek) zmizne.

Repliky

Nástroje pre kreslenie umožňuje pridať rovnaký komponent do diagramu niekoľkokrát s každou ďalšie vizuálne inštancie zložky na diagrame uvedeného ako replika. To je užitočné najmä pre diagramy, kedy sa zložka má veľký počet pripojení k nej pripojené, a je výhodné, aby ukazujú komponent v rôznych miestach bližšie k pôvodu každého pripojenia, alebo pre diagramy, kde vzťah one-to-many komponentu, je vhodnejšie pre zobrazenie pomocou plávajúce funkcie (popísaného vyššie), s komponentom vo viacerých miestach na hornej strane "mnohých" zložky je v súvislosti s.

Poznámka

Je možné pripojiť / odpojiť pripojenie do / z pôvodnej inštancie zložky na diagrame (ako vždy), ale aj na ktorúkoľvek z replík, však, keď sa spojenie automaticky pridané do diagramu sú pripojené k prvej inštancii súčasti na obrázku v predvolenom nastavení.

Poznámka

Repliky môžu byť zlúčené s navzájom Kliknite pravým tlačidlom myši a pretiahnitepotom výberom Zlúčiť replikyAvšak, zlúčenie repliku s inou zložkou bude mať za následok žiadne ďalšie repliky miznú z diagramu.

Poznámka

Neexistuje žiadny vizuálny rozdiel medzi pôvodnou inštanciu súčasti na diagrame a všetky repliky. Okrem toho, pravým tlačidlom myši menu pre pôvodnú zložku na diagrame a akékoľvek replík je zhodný, napríklad s Zobraziť v Prieskumníkoviktorá vás do rovnakej zložky v zobrazení stromu úložiska (aka modelu). Avšak, pravým tlačidlom myši na priečinok v zobrazení stromu úložiska a výberu Ísť doa prezeranie diagramu s replikami bude vždy sa dostanete na "najstarší" inštanciu súčasti na diagrame. Zvyčajne to bude originálne inštancie, ktorá bola pridaná do schémy, ale v prípade, že pôvodná inštancia bola následne odstránená alebo sa spojil s replikou potom ísť do skočí na najstarší zo zostávajúcich replík, ktoré boli pridané.

K Pridanie repliky do A diagram

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Kliknite pravým tlačidlom na existujúcu komponenty v diagrame a vyberte Vytvoriť repliku.Replika zvoleného komponentu bude vytvorený na pravej strane pôvodnej zložka.

- OR -

Vyberte existujúci komponent na diagrame a stlačte Ctrl + Calebo pravým tlačidlom myši na existujúcu komponenty v diagrame a vyberte Kopírovať, Teraz kliknite pravým tlačidlom myši na miesto na schéme, ktoré chcete repliky a vyberte Vložiť ako Replica, Poznámka: Stlačením Ctrl + V (alebo kliknutím pravým tlačidlom myši a vyberiete Vložiť) vytvorí kópiu pôvodného dielu nie replika.

- OR -

Kliknite na tlačidlo a pretiahnitezložku zo stromu Pohľad na úložisko (aka modelu) na grafe, kde je zložka už existuje.

Konfigurácia Connection Čiapky / Končí

Nástroje pre kreslenie umožňuje nastaviť užiť značka na koncoch pripojovacích potrubí buď na pevnej symbol alebo symbol v závislosti na vlastnosti na spojenie samotnej.To je obzvlášť užitočné pre diagramy, kde je požadované smer pripojenia, ktoré majú byť zobrazené, alebo pre diagramy, kde mohutnosť pripojenie (alebo smer) je obsiahnutá v majetku na samotnej pripojenie, napr "One-to-Many" verzus "Many-to-Many" (alebo "Source potopiť" vs "prepadom na zdroj").

K Konfigurácia pripojenie čiapky / končí schéma

1. Uistite sa, že máte nové alebo existujúcej diagram open.

2. Vyberte PripojenieiónyKarta v okne vzorkovníka.

3. Pravým-colizovať Jeden z spojené typy pripojenia a vyberte Konfigurovať Čiapky ....

4. Pre pevné pripojenie CAP / konci buď na zdroj alebo potopiť koniec pripojenia uistite sa, že príslušné Pevná je vybraný prepínač a vyberte symbol ukončenia pripojenia z pull down, napr "Arrow Head" alebo "Diamond".

- OR -

U nehnuteľností založené na spojenie CAP / konci buď na zdroj alebo potopiť koniec pripojenia uistite sa, že príslušné Použitie vlastnosťje vybraný prepínač, potom kliknite na tlačidlo "..." a vyberte požadovanú vlastnosť a potom sa vedľa každého symbolu koncovým pripájacím zadajte majetkové hodnoty, pre ktoré majú špecifický symbol spojenia, ktoré majú byť zobrazené.

Poznámka

Viac majetkové hodnoty pre dané pripojenie koncového symbolu možno zadať oddelené čiarkami.Napr. Nižšie dialóg ukazuje, že ak "údaje | Mohutnosť 'nehnuteľnosť má hodnotu "One-to-Many" potom zdroj koniec spojenia bude mať dve linky ťahy cez to a koniec umývadlá pripojenie bude mať jednu linku mŕtvicu cez to, a potom fan-out dvoch linka ťahy na konci.

Konfigurácia Caps dialóg

Pozri tiež

Nástroje na kreslenie | Naplnenie vašej architektúry | Analýza Vaše architektúra


Naplnenie vašej architektúry

Navigácia: Naplnenie vašej architektúry>

Naplnenie vašej architektúry

Odoslať pripomienky na túto tému.

Proces budovania model vášho architektúry, je známy ako Osadzovanie, Potom, čo ste objavili vašej architektúry a identifikovať vaše požiadavky, ste pripravení na váš model architektúry v ABACUS.

Počas populácie, budete zadať všetky podrobnosti, ktoré poznáte o svojej architektúre a čo je potrebné z toho.

K naplneniu vašej architektúry

1. Skontrolujte, či máte ABACUS otvoriť súbor , Což Zobrazí explorer , A architektúra pridané .

2. Ručné vyplnenie zložky vyššej úrovne a prípojky vašej architektúre. Zvyčajne sa bude jednať o viac abstraktné prvky a spoje.

- Alebo -

2. Graficky naplniť komponenty a spoje, ktoré by ste chceli pozri schematicky, s použitím Prievlak .

Môžete tiež chcieť, aby

3. Naplniť pomocou Katalógy - Si môžete prezrieť a komponenty a pripojenie v jednoduchým spôsobom. tabuľkové

4. Naplniť pomocou Matice - Môžete zobraziť a upraviť prepojenie medzi komponentmi jednoduchým tabuľkové spôsobom.

5. Naplniť z aplikácie Microsoft Access - Môžete importovať architektúru od a export do Microsoft Access.

6. Naplniť z Microsoft Visio - Môžete importovať architektúru od a export do Microsoft Visio.

7. Naplniť z aplikácie Microsoft Excel - Môžete importovať architektúru od a export do Microsoft Excel.

8. Naplniť z Microsoft SharePoint - Môžete importovať architektúru od a export do Microsoft SQL Server.

9. Naplniť z Microsoft SQL Server - Môžete importovať architektúry z Microsoft SQL Server.

10. Import z XML - Môžete importovať architektúry z XML fragmentu ABACUS alebo XML súboru ArchiMate Interchange Jazyk.

Pozri tiež

Naplnenie vašej architektúry ručne | Nástroje na kreslenie | Naplnenie vašej architektúry z aplikácie Microsoft Access | Naplnenie vašej architektúry z aplikácie Microsoft Visio | Naplnenie vašej architektúry z aplikácie Microsoft Excel


Naplnenie vašej architektúry z aplikácie Microsoft Access

Navigácia: Naplnenie vašej architektúry> Naplnenie z produktov spoločnosti Microsoft>

Naplnenie vašej architektúry z aplikácie Microsoft Access

Odoslať pripomienky na túto tému.

Môžete exportovať architektúru do programu Microsoft Access vykonávať výpočty pre všeobecné použitie, manipulácia alebo správy o vašom architektúre. Potom môžete importovať architektúru späť do ABACUS.

Poznámka

Open od Access / Export do databázy funkcia vyžaduje, aby Microsoft Access 2000alebo novší je nainštalovaná v počítači.

Ak chcete exportovať vašej architektúry do programu Microsoft Access

1. Skontrolujte, či máte ABACUS súborotvorený, CestovateľZobrazí, a architektúradodal.

2. Vyberte File | Export | Do databázy.

3. Vezmite na vedomie dialógu varovanie, ako bolo popísané vyššie, a pokračujte kliknutím na tlačidlo Áno.

4. Vyberte umiestnenie a názov súboru pre súbor databázy.

Ak chcete importovať manipulovaný architektúru do ABACUS

1. Skontrolujte, či máte ABACUS otvorený.

2. Vyberte File | Nové a vyberte Od Accessz dialógu, ktorý sa objaví, a kliknite na tlačidlo OK.

3. Vyhľadajte súbor databázy, ktorý chcete importovať.

MS Access Database Schema Abacus '

ABACUS má na svoje srdce An ontológie / meta-meta-modelu skladá z komponentov, pripojenie a obmedzenia. Tento "CCC" prístup bol odvodený z rôznych štandardných prístupov vyvinutých od 1960 roku kulminovať v medzinárodnom štandarde IEEE 1471, ktorý Avolution Zakladatelia prispel k. Nasledujúce primitíva platí;

1. ABACUS Obsahuje Knižnicez Normy(alebo noriem), Zložkaa Typy pripojenia, Obmedzenia, Uhly pohľadu, Šablóny (alebo Vzory) A veľa Architektúry.

2. Normy, Druhya Uhly pohľadu smieťlogicky Zoskupenépre pohodlie.

3. Architektúry môže obsahovaťmnoho potomok Architektúry(alebo Evolutions).

4. Každý Staviteľstvo Obsahujeveľa Komponentya Pripojenieniektorých Druhya rôzne Zobrazenie.

5. Komponentya Pripojenie môže byť rozkladádo Čiastkové komponentya Čiastkové Pripojenie.

6. Každý Zložkaje pripojený kľubovoľný počet Pripojenieale každý Pripojeniemôže byť len pripojený knajviac dve Komponenty.

7. Komponentya Pripojenie môcť mať Normys Vlastnostiako sú informácie, výkon, spoľahlivosť, cena atď.

8. Architektúry, Komponentya Pripojenie môcť maťšpecifický Vlastnostiako sú informácie, výkon, spoľahlivosť, cena atď.

9. Obmedzenia môcť existujú medzi Komponentyalebo Pripojeniealebo proti Vlastnosti.

10. Šablónysú štandardné zloženie Zložkaa Typy pripojenia.

11. Uhly pohľadusú štandardné združenia Zložkaa Typy pripojeniado záznamov.

12. Zobrazeniesú vizuálne reprezentácie Komponentya Pripojenie.

Nasledujúce MS Access Entity Relationship Diagram (ERD) dokumentuje jadroArchitektúry, Evolúcie, Druhy Component / pripojenie (a skupiny), komponenty / Spojovacie a Sub komponentný / pripojenie koncepty.

Schéma databázy Jadro

Poznámka

Referenčná integrita nebola vynútená na vzťah medzi tabuľky Komponenty a tabuľka pripojenia (pre "pripojenie" medzi danou Source alebo Sink komponenty a pripojenie). To je preto, že spojenie môže existovať bez prídavných súčastí. Mohli sme pridali "prílohu" tabuľku, ale v záujme zjednodušenia sa rozhodol proti tomu. Samozrejme to znamená, že akýkoľvek editácia komponentov IDS alebo mazanie komponentov riadkov všetci spolu bude mať za následok nesprávne údaje. ABACUS zvládne akúkoľvek nesprávnosti na dovoze ignorovaním nesprávne údaje.

Nasledujúce MS Access ERD dokumentuje Vlastnostikoncepty pre architektúry, typy Component / pripojenie a komponenty / Pripojenie.

Vlastnosti schéme databázy

Nasledujúce MS Access ERD dokumentuje Normykoncept pre architektúry, typy Component / pripojenie a komponenty / Pripojenie.Poznámka: Tabuľky naďalej používať termín "prevedení" podľa predchádzajúcich verzií ABACUS.

Štandardy schémy databázy

Nasledujúce MS Access ERD dokumentuje Obmedzeniakoncepcia pre komponent typov / pripojenie.

ObmedzeniaSchéma databázy

Nasledujúce MS Access ERD dokumentuje Uhly pohľadu koncepcia Architektúry.Poznámka: Tabuľky naďalej používať termín "TwoDTempl 'podľa predchádzajúcich verzií ABACUS.

Uhly pohľaduSchéma databázy

Nasledujúce MS Access ERD dokumentuje Katalógykoncepcia Architektúry.

KatalógySchéma databázy

Nasledujúce MS Access ERD dokumentuje Maticekoncepcia Architektúry.

MaticeSchéma databázy

Nasledujúce MS Access ERD dokumentuje Diagramykoncepcia Architektúry.Poznámka: Tabuľky naďalej používať termín "TwoD 'podľa predchádzajúcich verzií ABACUS.

Poznámka

Component / Typ pripojenia k vzorkovníka tvar mapovanie a voľného tvaru tvar častí MS Access ERD boli pre prehľadnosť vynechané.

DiagramySchéma databázy

Nasledujúce MS Access ERD dokumentuje 3D Prehliadkykoncepcia Architektúry.

3D PrehliadkySchéma databázy

Nasledujúce MS Access ERD dokumentuje Grafykoncepcia Architektúry.

GrafySchéma databázy

Nasledujúce MS Access ERD dokumentuje Dashboardskoncept.

DashboardsSchéma databázy

Abacus 'MS AccessOtázky

Súčasťou databázy MS Access je niekoľko užitočných otázky takto;

· Comps podľa rekvizity- Tento dotaz uvádza všetky komponenty v projekte (podľa architektúry a typu) a zahŕňa všetky vlastnosti ako stĺpce. Použite tento dotaz s filtrami / kritériami na schválenie komponentu a / alebo architektúry produkovať "typické" tabuľky pre každý typ komponentu sa ich vlastností.

· Pohlavné choroby podľa rekvizity- Tento dotaz uvedené všetky štandardy, ktoré sú v prevádzke, počet výskytov normy a zahŕňa všetky vlastnosti ako stĺpce. Pomocou tohto dopytu ako na štandardoch katalógu.

· Rekvizity podľa druhov- Tento dotaz obsahuje zoznam všetkých komponentov a ich vlastnosti% kompletné každého komponentu, ako stĺpy. Pomocou tohto dotazu na určenie, či sú zachované špecifické vlastnosti.

· Typy podľa rekvizity- Tento dotaz zobrazí všetky typy komponentov a obsahuje kompletné% zo všetkých vlastností ako stĺpce. Pomocou tohto dotazu na určenie, či sú zachované špecifické vlastnosti.

· Typ Count- Tento dotaz zobrazí všetky typy komponentov a zahŕňa počet výskytov každého typu v zostupnom poradí. Pomocou tohto dopytu určiť popularitu každého typu v projekte.

Poznámka k práci s polí typu Memo v MS Access

Komponenty, pripojenie a štandardy mená polí v tabuľkách sú definované ako pole memo umožniť neobmedzený počet znakov, podľa ABACUS. Pre súčasti a spoje Táto spôsobuje niekoľko problémov, pretože majú tiež jedinečné ID pole pre odkazovanie, ale aj pre štandardy to spôsobuje niekoľko problémov pri pokuse o spojenie tabuliek, pretože nemôžete pripojiť memo polí v MS Access. Prípadne môžete nastaviť WHERE kritériá klauzuly dosiahnutie rovnakého účinku, ako je uvedené v Visual Query Builder a zodpovedajúce SQL, ktorý umiestnite nižšie uvedeného zoznamu sa všetky zdedené Štandardy vlastnosti pre všetky komponenty v exportovanom projektu ABACUS.

Memo pole "pripojí" Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Od komponentov INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) AND (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Implementácia INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

WHERE (((ComponentImplementationLinks.Name) = [Implementácia] [názov]).);

Memo pole "pripojí" v SQL

Poznámka k automatické generovanie ID počítadlo v MS Access

Rôzne tabuľky ABACUS MS Access vyžadujú unikátne dlhé celé číslo ID, takže jednoduchá metóda VB sa poskytuje pomoc pri vytváraní týchto. Dve metódy ResetCounter () a GetNextCounter () sú poskytované v rámci Abacus 'MS Access DB a ich použitie je nasledujúci; ResetCounter () nastaví počítadlo späť na 0. GetNextCounter () vráti ďalšie počítadlá v poradí.

Metódy vyťažiť čo najviac z MS Access "vtipek", že aj v prípade, že volanie metódy ResetCounter () pre každý riadok vložku (teda ak ste tiež spustiť funkciu GetNextCounter ()), pretože funkcia ResetCounter (), nemá žiadne parametre, to jednoducho beží to raz, a preto nemá vynulovať počítadlo pre každý riadok vložkou. A tiež preto, že z rovnakého "vtipek", musíte prejsť všetky staré premenné stĺpce funkciu GetNextCounter (), aby oklamať ho do chodu zakaždým.

K dispozícii je tiež trik, aby boli schopní prevádzkovať funkciu v úložnej ResetCounter () do príkazu SQL, pretože nemôžete len mať to sedí tam ako stĺpec na jeho vlastné, ako keby to bol výberový dotaz. Odporúča sa, aby sa ResetCounter () volanie časť jednej z ďalších oblastí, concatenating ju až do konca, ako to vždy vracia null rovnako.

Nižšie je typický SQL použití metód doplniť zoznam typov zložky z tabuľky / dotazu s názvom "Component Type zoznam".

INSERT INTOComponentTypes (id, meno, opis)

SELECT GetNextCounter ([Component Type List] .name)AS Id, [Component Type List] .name ako meno, [Component Type List] .description & ResetCounter ()AS Popis

FROM[Component Type List];

ABACUS ID / Counter generácie SQL

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Naplnenie vašej architektúry od aplikácie Visio | Naplnenie vašej architektúry z programu Excel


Naplnenie vašej architektúry z aplikácie Microsoft Excel

Navigácia: Naplnenie vašej architektúry> Naplnenie z produktov spoločnosti Microsoft>

Naplnenie vašej architektúry z aplikácie Microsoft Excel

Odoslať pripomienky na túto tému.

Môžete importovať architektúru z tabuľky programu Excel (XLS alebo XLSX súbor). Dovozca Excel umožňuje mapovať zoznamy zložky a spojenie s typmi, štandardy, vlastnosti a štandardné vlastnosti výberom stĺpca v tabuľke vašej ktoré obsahujú relevantné dáta.Pritom sa jedná o viac, než je pokročilá technika odporúčaný postuppre import z MS Excel, ktorý je prostredníctvom katalógy ako je popísané tu .

Poznámka

Import z / Export do programu Excel funkcia vyžaduje, aby Microsoft Excel 2003alebo novší je nainštalovaná v počítači.

Hlavnou funkciou dovozca Excel je, aby vám umožní definovať konfiguračný súbor (tj hierarchickej štruktúre vášho architektonického modelu). Konfiguračný súbor ukladá predtým uložený mapovanie zo súboru programu Excel do súboru ABACUS. Akonáhle sa raz určí uložený konfiguračný súbor je neskôr použiť pre ďalšie importu a exportu do XLS.

Poznámka

Kroky uvedené v nasledujúcich kapitolách sú špeciálne pre užívateľov, ktorí majú ešte definovať a uložiť konfiguračný súbor a je import z Excelu prvýkrát. Musíte vytvoriť a uložiť konfiguračný súbor používať Exportovať do programu Excel funkcie.

Ak chcete importovať tabuľky programu Excel do ABACUS

1. Skontrolujte, či máte ABACUS otvorený.

2. Vyberte File | Nový a vyberte Vynikaťz dialógu, ktorý sa objaví, a kliknite na tlačidlo OK.

Poznámka

Ak chcete importovať do existujúceho projektu ABACUS potom buď pravým tlačidlom myši na uzol Súčasti v architektúre, alebo pravým tlačidlom myši na jednotlivé súčasti v rámci architektúry a potom vyberte príkaz Import | Od Excel.

3. Dovoz ExcelZobrazí sa okno

Dovoz Excel okno Tabuľka

4. Kliknite na tlačidlo Otvoriť súbor Excelikonu a vyhľadajte súbor programu Excel, ktorú chcete importovať.

5. Vyberte si Pracovný listAk chcete importovať z rozbaľovacieho zoznamu.

Poznámka

Po otvorení súboru programu Excel, môžete použiť Náhľad dátKarta pre zobrazenie stĺpcov a prvých 25 riadkov vašej tabuľky. Odtiaľ môžete získať čísla stĺpcov potrebné k vyplneniu Komponentya PripojenieTab.

Môžete si tiež vybrať, či chcete alebo nechcete komponenty tabuľkový procesor Excel, ktoré majú byť dovezené s citlivosťou prípadu. Jednoducho zaškrtnite Dovoz sa rozlišovanieMožnosť (v predvolenom nastavení toto je vždy začiarknuté) a tabuľkový procesor bude zodpovedajúcim spôsobom importované.

Ukážkový Excel File

Poznámka

V tomto príklade budeme dovážať jednoduché infraštruktúry a ľudovej architektúry z dát Excelu uvedených vo vyššie uvedenom obrázku. Pripojenie bude vykonané medzi "ľudia zodpovední" a "servery", ktoré títo ľudia spravujú.

K naplneniu na kartu súčasti

Táto sekcia je určená pre definovanie typy komponentov a hierarchickú štruktúru pre konfiguračného súboru.

1. Vyberte KomponentyTab. Premenovať Set IDprepísaním (null)hodnota

Poznámka

Táto funkcia umožňuje definovať úplne inak Súpravypre funkčne oddelených zložiek. Ako je vidieť na nasledujúcom obrázku, možno budete chcieť odlíšiť komponentov infraštruktúry z vašich ľudí komponentov. Ak existujú vzťahy (spojenie) medzi týmito oddelenými súbormi komponentov, ktoré môžu byť definované v rámci PripojenieTab. Neskôr v tomto príklade budeme definovať spojenia typu "spravuje" medzi infraštruktúrou a ľudia Súpravy.

Môžete si tiež vybrať, či chcete alebo nechcete pridať najvyššej úrovne Zoskupeniekomponenta pre všetky prvky súpravy. Jednoducho zaškrtnite Skupina Pod Set IDMožnosť (v predvolenom nastavení je to unticked) a tabuľkový procesor bude zodpovedajúcim spôsobom importované.

Priradenie Set ID

2. Akonáhle je SúpravyBoli definované vybrať NastaviťAk chcete naplniť a rozšíriť kliknutím na [+]podpísať.

3. Vybrať Úrovne komponentov v tejto sadeV rozbalené zoznamu.

4. Súčasť Hierarchia sady: Set IDObjaví sa okno pre to Nastaviť.

Komponenta hierarchie a priradenie hodnôt (Set ID: Infrastructure)

5. Premenovať Level NumberStĺpec prepísaním (null)hodnotu.

Poznámka

Level NumberStĺpec umožňuje priradiť hierarchiu na komponenty. Každá úroveň zodpovedá vrstve vo vašej architektúry, pričom prvá úroveň je najvyššia najviac rodičúrovni. Napríklad úroveň "1" sa zodpovedá najvyššej hierarchickej vrstve, Level číslo "2" je dieťaťom úroveň číslo "1", a tak ďalej.

6. Vyberte a priraďte zodpovedajúce stĺpec z tabuľky programu Excel na sebe Level Numberzadaním pod Komponenta Stĺpecstĺpec.

Poznámka

Môžete si vybrať, vylúčiť určité riadky, ktoré nechcete byť zastúpený v architektúre. Tie môžu byť hlavičky stĺpcov, prázdne riadky, atď Ak chcete vylúčiť riadky použiť Riadky vylúčenia:Textové polia v blízkosti pravom hornom rohu okna. V tomto príklade sme vylúčení riadok 1, pretože obsahuje naše hlavičky stĺpcov.

7. Môžete si vybrať, pridať popisy komponentom prepísaním (null)hodnota v Opis Stĺpec.

Poznámka

Tento opis je to, čo sa objaví v ABACUS pod Všeobecné vlastnostisekcia | Popisterénu.

8. Ak daný tabuľkový stĺpec obsahuje viac ako jednu zložku na bunku (zadať pomocou Alt-Enter alebo CHAR (10) príkaz) a potom označte políčko pod Doprajte nových tratí ako samostatné súčasti, Každý riadok budú importované ako samostatné komponenty.

Tip

Ak chcete importovať "matricu" z kolekcie stĺpcov, kde "X" v danom "matrice" bunky (bunky B2: D2 Say) vyžaduje, aby sa časti stanovená rade (v bunke A2 povedať,) je pripojený na súčasť špecifikovaný stĺpci "hlavičkou" (v riadku 1 Say), jednoduchý vzorec môže byť použitý. Vstup do nasledujúcej vzorec pre každý riadok v kolóne za matrice buniek (stĺpec F povedať); = IF (B2 = "", "", B $ 1 CHAR (10)) a IF (C2 = "", "", C $ 1 CHAR (10)) a IF (D2 = "", "", D $ 1 a CHAR (10)). Potom nastaviť pripojenie nastaviť, ako je popísané nižšie medzi komponentmi špecifikovaných riadku (v stĺpci A hovoriť) a opísané týmto vzorcom (uvedené v stĺpci F povedať). Uistite sa, že skontrolovať Doprajte nových tratí ako samostatné súčastimožnosť, ak sú dovážané komponenty zo vzorca. Pre pokročilejších matrice dovoz vrátane okruhov s niekoľkých vrstiev hierarchie alebo buniek rozličné hodnoty, než len obyčajný "X", obráťte sa prosím Podpora Avolution .

9. Vyplniť vo zvyšku stĺpcov podľa potreby.

Poznámka

Môžete si vybrať, získať typ z radov stĺpcov zaškrtnutím políčka pod Získať typu zo stĺpcastĺpec a zadaním príslušného stĺpec z tabuľky programu Excel v rámci cieľa Súčasť Typ Hodnota alebo Stĺpecstĺpec. To bude importovať všetky komponenty v danom stĺpci a nastaviť na typu definovaného v stĺpci. Alternatívne, a rovnako ako snímku obrazovky nad a pod, môžete si vybrať použiť pevnú / preddefinovaný názov typu zadaním názvu typu v rámci Súčasť Typ Hodnota alebo Stĺpecstĺpec a uistite sa, že políčko je un-skontrolovať.

Komponenta hierarchie a priradenie hodnôt (Set ID: People)

Poznámka

V tomto príklade chceme mať naše siete a ľudia zoskupenie na úrovni 1 architektúry. Na úrovni 2 si prajeme, aby naše servery a osôb zodpovedných za správu týchto serverov. Komponentytab boli vyplnené zodpovedajúcim spôsobom, ako je znázornené v dvoch vyššie uvedených obrazovky. V prvom obrázku vyššie sme definovali 1 (sieťová zoskupovanie) a na úroveň 2 (server) súčasti úrovne pre infraštruktúru Nastaviť, A na obrázku bezprostredne nad sme definovali úrovni 1 (ľudí zoskupenia) a 2 (osoby zodpovedné) komponenty úrovne pre ľudí Nastaviť.

Alternatívne, pre ĽudiaSet, skôr ako používať stĺpec C ako Ľudia zoskupenia, mohli sme používaný Skupina Pod Set IDna karte Súčasti na hornej úrovni, a potom už len vstúpil jeden ľud sub-level z stĺpci D. To je znázornené na nasledujúcom obrázku.

Komponenta hierarchie a priradenie hodnôt pomocou voľby Skupina Podľa Set ID (Nastaviť ID: People)

10. Potom, čo boli identifikované komponenty, vyberte požadovanú úroveň zariadenia, ktoré chcete naplniť vlastnosti a / alebo štandardy a rozšíriť kliknutím na [+]podpísať.

11. Vybrať Vlastnosti komponenty na tejto úrovnialebo Štandardy na tejto úrovni komponentovzo rozšírené zoznamu a do príslušných stĺpcov, koľko je potrebné.

Naplnenie Components

Poznámka

Vlastnosti komponenty na tejto úrovniumožňuje definovať vlastnosti pre komponenty na zvolenej úrovni. Štandardy na tejto úrovni komponentovumožňuje definovať štandardy a ich štandardné vlastnosti pre komponenty na zvolenej úrovni.

12. Opakujte kroky 2-11kým nebudú naplnená všetky úrovne komponenty pre všetky definované Súpravy, Navigovať späť do pomocou šípky späť blízkosti pravom hornom rohu okna Súpravyktorý ste definovali skôr.

K naplneniu na kartu Pripojenie

Táto sekcia je určená pre definovanie typy pripojení a hierarchickú štruktúru pre konfiguračného súboru.

1. Vyberte PripojenieTab. Pre každý súbor spojov je nutné identifikovať komponentu Nastaviťže chcete byť zdrojové komponenty a komponenta NastaviťChcete byť zložky cieľovej.

2. Naspodku Zdroj Component Set IDzadajte Nastaviťnázov, ktorý sa vzťahuje na Nastaviťdefinované skôr vo KomponentyTab. Naspodku Zdroj Component Number Levelzadajte číslo zodpovedajúce úrovni zložky, ktoré chcete pripojiť v zdrojovom konci pripojenia.

3. Teraz si vybrať, ktoré komponenta skupina bude na cieľovom konci spojenia. Naspodku Cieľ Component Set IDzadajte Nastaviťnázov, ktorý sa vzťahuje na Nastaviťdefinované v KomponentyTab. Naspodku Cieľ Component Number Levelzadajte číslo zodpovedajúce úrovni zložky, ktoré chcete pripojiť na cieľovom konci pripojenia.

Poznámka

V tomto príklade chceme spojiť osoby zodpovedné za správu serverov na servery, ktoré spravujú. Ľudia zodpovední boli definované v Čínskej ľudovej republike Nastaviťako úroveň 2 komponenty, zatiaľ čo servery boli definované v infraštruktúry Nastaviťako úroveň 2 komponenty. PripojenieKarta boli vyplnené zodpovedajúcim spôsobom, ako je uvedené v nasledujúcom obrázku.

Pripojenie Tab časť 1 z 2

4. Ak prejdete na pravej strane, nájdete ďalšie možnosti pre import vaše pripojenie. Získať typu zo stĺpcaa Typ pripojenia Hodnota alebo Stĺpecpracovať rovnakým spôsobom ako pre KomponentyTab.

5. V prípade, že Zdroj Component Set IDa Zdroj Component Number Levelsú rovnaké ako Cieľ Component Set IDa Cieľ Component Number Level(napríklad ak sa pripájate rovnaké typy komponentov, ako je napríklad vytváranie pripojenie od serverov do iných serverov), potom musíte mať ďalší stĺpec vo svojej tabuľke, ktorá obsahuje mená tých serverov opakovaných. V tejto situácii by ste dal, že tabuľkový stĺpec v Cieľ Opakované v stĺpcistĺpec. Ak je v tomto tabuľkovom stĺpci ste zadali viac ako jednu pripojené zariadenie na bunku, označte políčko pod Doprajte nových tratí ako samostatné súčasti.

Pripojenie Tab časť 2 z 2

6. Po pripojení sa zistili vyberte pripojenie, ktoré chcete naplniť vlastnosti a / alebo štandardy a rozšíriť kliknutím na [+]podpísať.

7. Vybrať Vlastnosti týchto spojeníalebo Normy pre tieto pripojeniazo rozšírené zoznamu a do príslušných stĺpcov, koľko je potrebné.

Poznámka

Vlastnosti týchto spojeníumožňuje definovať vlastnosti pre vybrané pripojenie skupiny. Štandardy pre tieto spojeumožňuje definovať štandardy a ich štandardné vlastnosti pre vybrané pripojenie skupiny.

8. Opakujte kroky 2-7kým boli definované všetky skupiny spojenie.

9. Po dokončení definovaní skupín pripojenie, kliknite na tlačidlo SkončiťTlačidlo a vaše architektúra bude vytvorený zo súboru importovaného Excel. Vo vyššie uvedenom príklade bude mať za následok architektúry znázornené na obrázku nižšie.

Ukážka Architektúra Dovezený z Excelu

10. Teraz uložte namapovanej konfigurácie do súboru kliknutím na tlačidlo Uložiť konfiguráciuikona. Vaše uložené nastavenia môžu byť vyvolané neskôr kliknutím na Otvorenie konfigurácieikona blízkosti ľavom hornom rohu okna.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Naplnenie vašej architektúry z programu Access | Naplnenie vašej architektúry od aplikácie Visio


Naplnenie vašej architektúry z aplikácie Microsoft SharePoint

Navigácia: Naplnenie vašej architektúry> Naplnenie z produktov spoločnosti Microsoft>

Naplnenie vašej architektúry z aplikácie Microsoft SharePoint

Odoslať pripomienky na túto tému.

Môžeš synchronizovať Vaše architektúra sMicrosoft Zoznamy SharePoint. Synchronizácia znamená buď vytvorením nové zoznamy SharePoint (a ich stĺpce) z typov Abacus, ich vlastnosti a príloh, alebo mapovanie existujúcich zoznamov SharePoint (a ich stĺpce) pre typy Abacus, ich vlastnosti a príloh, potom buď odosielanie obsahu z ABACUS do SharePoint alebo SharePoint k ABACUS.

Poznámka

SharePoint Sync funkcia vyžaduje, aby Microsoft SharePoint 2010, 2013alebo SharePoint Online site je k dispozícii pripojenie a synchronizovať.Zatiaľ čo funkcia SharePoint Sync môžete vytvoriť zoznamy (s stĺpcov) na lokalite SharePoint z akéhokoľvek projektu ABACUS, Avolution môžu tiež poskytovať rôzne šablóny webov SharePoint na podporu štandardných rámcov (napr TOGAF, ArchiMate, ITIL atď), takže prosím kontaktujte Podpora Avolution Ak požadujete túto funkciu.

K vytvoriť nový zoznam SharePoint a mapovať na ABACUS komponentov alebo typu pripojenia

1. Skontrolujte, či máte ABACUS otvorený.

2. Vybrať Nástroje | SharePoint Sync.

3. Kliknite na tlačidlo New mapovanieTlačidlo a mapovanie dialógové okno SharePoint, ako je uvedené nižšie objaví.

4. Zadajte adresu URL webu, užívateľské meno a heslo pre web služby SharePoint a kliknite na tlačidlo Pripojenie.

Poznámka

Platný SharePoint "admin" alebo účtom "prispievateľa" je vyžadované pre synchronizáciu z a do SharePoint a účet "čitateľa" umožňuje len synchronizáciu z SharePoint.

5. Vyberte počítadlo komponentov alebo typ pripojenia k mapovanie od Vyberte typpull-down.

6. Kliknite na tlačidlo Pridať novétlačidlo a potom pre každú ABACUS komponentu alebo typu pripojenia aspekt, ktorý chcete namapovať na zodpovedajúce pole v zozname SharePoint vyberte položku v ľavom paneli av pravom paneli zadajte nový názov zoznamu SharePoint v novom zozname stĺpca (iba prvýkrát) , potom je názov SharePoint stĺpca v stĺpci názov (alebo použite predvolené) a kliknite na tlačidlo Priradiťzakaždým.

Poznámka

Ako minimum umožňujúci synchronizáciu počítadla EEID, Architektúra a mená aspekty budú automaticky mapované na SharePoint číslo a dva (2) jeden riadok textu (aka Text) stĺpcov resp. Tieto nemôžu byť Unassigned. Navyše iba určité aspekty Abacus súčasnej dobe môžu byť mapované na určité stĺpce SharePoint a Stĺpec Typ pull-down sa automaticky nastaví na požadovaný typ stĺpca SharePoint.Menovite;

· Abacus 'Hierarchia Cesta k SharePoint viac riadkov textu (aka Poznámka) stĺpcov (Poznámka: SharePoint jeden riadok textu (aka Textové) stĺpca podporujú len 255 znakov, takže nie sú prednostné),

· Počítadlo "Pripojené komponenty pre SharePoint vyhľadávacie stĺpca (Poznámka: Mapovanie už musí existovať na základe zoznamu pre pripojené komponenty samotných),

· Abakus 'text a Popis vlastnosti na SharePoint viac riadkov textu (aka Poznámka) Stĺpy (Poznámka: SharePoint jeden riadok textu (aka Textové) stĺpca podporujú len 255 znakov, takže nie sú prednostné),

· Počítadlo "desiatkovej alebo Integer vlastnosti na SharePoint Počet stĺpcov,

· Počítadlo "Zoznam vlastností pre SharePoint Choice stĺpca (Poznámka: SharePoint nevynucuje voľba hodnoty, takže nie je potreba typ zoznamu údajov, ktoré majú byť vykonaná v ABACUS),

· Abacus 'dátum / čas vlastnosti na SharePoint viac riadkov textu (aka Poznámka) stĺpcov (Poznámka: SharePoint dátum a čas stĺpce nemožno použiť ako doteraz vzhľadom k nejednotným podpore SharePoint je pre časové pásmo / nastavenie regionalizácie),

· Počítadlo "logické vlastnosti na SharePoint áno / nie (aka Boolean) stĺpcov.

Počítadla prvku súvisiace normy nemôže byť mapované do stĺpcov zoznamu SharePoint doteraz.

7. Vybrať Vytvoriť mapovanie.

K vytvoriť nové mapovanie medzi komponentom ABACUS alebo typ pripojenia a existujúceho zoznamu služby SharePoint

1. Skontrolujte, či máte ABACUS otvorený.

2. Vybrať Nástroje | SharePoint Sync.

3. Kliknite na tlačidlo New mapovanieTlačidlo a mapovanie dialógové okno SharePoint, ako je uvedené nižšie objaví.

4. Zadajte adresu URL webu, užívateľské meno a heslo pre web služby SharePoint a kliknite na tlačidlo Pripojenie.

Poznámka

Platný SharePoint "admin" alebo účtom "prispievateľa" je vyžadované pre synchronizáciu z a do SharePoint a účet "čitateľa" umožňuje len synchronizáciu z SharePoint.

5. Vyberte počítadlo komponentov alebo typ pripojenia k mapovanie od Vyberte typpull-down.

6. Vyberte zoznam lokalít SharePoint mapovať od Vyberte Zoznampull-down.

7. Pre každú ABACUS komponentu alebo typu pripojenia aspekt chcete mapovať do svojho zoznamu stĺpec zodpovedajúce služby SharePoint vyberte položku v ľavom paneli a pravý panel, respektíve a kliknite na tlačidlo Priradiť.

Poznámka

Ako minimum umožnenie potrebovať synchronizácia počítadla EEID, Architektúra a mená aspekty, ktoré majú byť mapované na SharePoint číslo a potom sa pre architektúru a názov buď jeden riadok textu (aka Text), alebo viac riadkov textu (aka poznámky) stĺpcov resp. Do tej doby sa vykonáva na tlačidlo Vytvoriť mapovanie nebude povolená. Navyše iba určité aspekty Abacus súčasnej dobe môžu byť mapované na určité stĺpcov SharePoint.Menovite;

· ABACUS "Architektúra aspekt SharePoint jeden riadok textu (aka Text), alebo viac riadkov textu (aka Poznámka) stĺpcov (to je nutné pre konkrétne mapovanie obsahu, ako je popísané nižšie),

· Abacus 'Hierarchia Cesta k SharePoint jeden riadok textu (aka Text), alebo viac riadkov textu (aka Poznámka) stĺpcov (Poznámka: SharePoint jeden riadok textu (aka Text) oporných stĺpoch len 255 znakov, takže akúkoľvek prípadnú ďalšie znaky budú skrátené, a preto odporúča sa ich previesť na viac riadkov textu (aka Poznámka) stĺpce v SharePoint pred mapovanie),

· Počítadlo "Pripojené komponenty pre SharePoint vyhľadávacie stĺpca (Poznámka: Mapovanie už musí existovať na základe zoznamu pre pripojené komponenty samotných),

· Abakus 'text a Popis vlastnosti na SharePoint jeden riadok textu (aka Text), alebo viac riadkov textu (aka Poznámka) stĺpcov (Poznámka: SharePoint jeden riadok textu (aka Text) oporných stĺpoch len 255 znakov, takže akúkoľvek prípadnú ďalšie znaky budú skrátené a preto je vhodné ich previesť na viac riadkov textu (aka Poznámka) stĺpce v SharePoint pred mapovanie),

· Počítadlo "desiatkovej alebo Integer vlastnosti na SharePoint Počet stĺpcov (Poznámka :. SharePoint Vypočítané stĺpce možno použiť však budú môcť len synchronizované z SharePoint ABACUS Snažím sa synchronizovať" na "výpočtový stĺpec bude mať za následok varovanie podľa nižšie) ,

· Počítadlo "Zoznam vlastností pre SharePoint Choice stĺpy,

· Abacus 'dátum / čas vlastnosti na SharePoint viac riadkov textu (aka Poznámka) stĺpcov (Poznámka: SharePoint dátum a čas stĺpca nemožno použiť vzhľadom k nejednotným podpore SharePoint je pre časové pásmo / nastavenie regionalizácie),

· Počítadlo "logické vlastnosti na SharePoint áno / nie (aka Boolean) stĺpcov.

Počítadla prvku súvisiace normy nemôže byť mapované do stĺpcov zoznamu SharePoint doteraz. A SharePoint je mena, osoba alebo skupina, hypertextový odkaz alebo obrázok, výsledok úloh, externé dáta a riadené stĺpce metadát nemôžu byť mapované na aspekty Abacus doteraz.

8. Vybrať Vytvoriť mapovanie.

K synchronizovaťVaše Microsoft Zoznam (y) SharePointdo ABACUS

1. Skontrolujte, či máte ABACUS otvorený.

2. Vybrať Nástroje | SharePoint Sync.

Poznámka

K synchronizovať zoznam SharePoint sProjekt ABACUS licencie užívateľ potrebuje SharePoint Syncadd-on schopnosti. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

3. Vyberte existujúce mapovanie SharePoint (alebo mapovanie pomocou Klávesom Ctrlalebo Vybrať všetkotlačidlo) z SharePoint mapovaniepanelako je znázornené na vzorke snímke vyššie. Poznámka: Tu ukážeme len "Cieľ (alebo požiadavka)" ABACUS typu konštrukčnej mapovanie do zoznamu služby SharePoint je vybraný tzv Góly.

4. Vyberte Architektúra (y), ktorý chcete synchronizovať obsah s od Synchronizovať obsah z architektúrypanel as je uvedené v ukážkovom snímke vyššie. Poznámka: tu sa ukazujú len "2015 Actual" architektúra sa synchronizujú.

5. Vyberte Sync z SPtlačidlo.

Poznámka

Ak poverovacie SharePoint nie sú "všetky uložené" pre mapovanie (y) potom Prihlásenie do dialógu SharePoint s dotazom pre Site URL, Užívateľské meno a / alebo Heslo.Prosím, zadajte je. Ďalej bude synchronizácia žiadne iné mapovanie, ktoré sú požadované pre pripojené komponenty / vyhľadávacie stĺpca. Akékoľvek ďalšie mapovanie, ktoré sú automaticky zahrnuté budú zobrazené v dialógu podľa nižšie.

6. Na úspešnú synchronizáciu sa objaví dialógové okno Výsledky SharePoint Sync, ako je uvedené nižšie zoznam zmien a varovania. Kliknite na tlačidlo OK.

K synchronizáciu z ABACUS do Vaše Microsoft Zoznam (y) SharePoint

1. Skontrolujte, či máte ABACUS otvorený.

2. Vybrať Nástroje | SharePoint Sync.

Poznámka

K synchronizovať zoznam SharePoint sProjekt ABACUS licencie užívateľ potrebuje SharePoint Syncadd-on schopnosti. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

3. Vyberte existujúce mapovanie SharePoint (alebo mapovanie pomocou Klávesom Ctrlalebo Vybrať všetkotlačidlo) z SharePoint mapovaniepanelako je znázornené na vzorke snímke vyššie. Poznámka: Tu ukážeme len "Cieľ (alebo požiadavka)" ABACUS typu konštrukčnej mapovanie do zoznamu služby SharePoint je vybraný tzv Góly.

4. Vyberte Architektúra (y), ktorý chcete synchronizovať obsah s od Synchronizovať obsah z architektúrypanel as je uvedené v ukážkovom snímke vyššie. Poznámka: tu sa ukazujú len "2015 Actual" architektúra sa synchronizujú.

5. Vyberte Sync pre SPtlačidlo.

Poznámka

Ak poverovacie SharePoint nie sú "všetky uložené" pre mapovanie (y) potom Prihlásenie do dialógu SharePoint s dotazom pre Site URL, Užívateľské meno a / alebo Heslo.Prosím, zadajte je. Ďalej bude synchronizácia žiadne iné mapovanie, ktoré sú požadované pre pripojené komponenty / vyhľadávacie stĺpca. Akékoľvek ďalšie mapovanie, ktoré sú automaticky zahrnuté budú zobrazené v dialógu podľa nižšie.

6. Na úspešnú synchronizáciu sa objaví dialógové okno Výsledky SharePoint Sync, ako je uvedené nižšie zoznam zmien a varovania. Kliknite na tlačidlo OK.

Poznámka

ABACUS bude aktualizovať SharePoint stĺpcov s prázdnymi hodnotami, aj keď "Požadovať, aby tento stĺpec obsahuje informácie" je nastavená na hodnotu Áno v SharePoint. Dôvodom je, že SharePoint nevystavuje toto nastavenie externe. Ak je to potrebné zabrániť je odporúčané, že ABACUS Designer nastaví Požadované obmedzenie na true a uplatňuje danom pozemku pomocou Abacus " nátlak rys .

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Naplnenie vašej architektúry od aplikácie Visio | Naplnenie vašej architektúry z programu Excel


Naplnenie svoju architektúru od Microsoft SQL Server

Navigácia: Naplnenie vašej architektúry> Naplnenie z produktov spoločnosti Microsoft>

Naplnenie svoju architektúru od Microsoft SQL Server

Odoslať pripomienky na túto tému.

Môžete importovať architektúru z databázy Microsoft SQL Server. Máte na výber len importovať tabuľky a vzťahy v skutočnosti dovážajú len všeobecný štruktúru databázy a tabuliek, riadkov a vzťahov, ktoré sa dovážajú nielen štruktúru, ale dáta rovnako.

Poznámka

Od SQL Server funkcia vyžaduje, Microsoft SQL Server 2005, 2008, 2008 R2, 2012 alebo 2014je nainštalovaný v počítači.

Ak chcete importovať databázu servera Microsoft SQL do ABACUS

1. Skontrolujte, či máte ABACUS otvorený.

2. Vyberte File | Nové a vyberte Od SQL Serverz dialógu, ktorý sa objaví, a kliknite na tlačidlo OK.

3. V dialógovom okne Importovať SQL Server, ktorý sa objaví nastaviť "názov_počítača" a hodnoty "SQLINSTANCE 'reťazca pripojenia premenné a hodnota" dbname "v Názov databázy premennej na ich správne hodnoty, ako je uvedené v ukážkovom snímke nižšie.

4. Nastaviť Database názov premennej na rovnakú hodnotu ako je počiatočná katalóg premenné stanovené v kroku vyššie, ako je uvedené vo vzorke snímke nižšie.

5. Stlačte tlačidlo Test spojenia a tabuľky importovať časť dialógu by mal byť naplnený dostupných databázových tabuliek, ako je uvedené v ukážkovom snímke nižšie.

6. Vyberte tabuľky, ktoré chcete importovať buď jednotlivo, alebo pomocou vyberiete All, None a obráťte tlačidiel napravo v dialógu.

Poznámka

Iba kľúčové vzťahy Vonkajší ktoré existujú medzi stolmi, ktoré vyberiete dostane importovaná.

7. Pomocou prepínač Importovať štýl vyberte, či chcete importovať len tie tabuľky a vzťahy medzi nimi, alebo tabuľkách, ich riadky a konkrétnych vzťahoch medzi riadkami.

Poznámka

Prvá možnosť importuje tabuľky ako komponenty typu "tabuľky" a vzťahoch medzi akýmikoľvek dvoma tabuľkami (z cudzej kľúča) sú importované ako spojenia typu "Tabuľka Relation". Jedná sa o klasický "ERD" štýl pohľad systémových tabuliek. Druhá možnosť importuje riadky tabuľky ako jednotlivé čiastkové komponenty typu "riadku tabuľky" s vlastnosťami zodpovedajúcimi jednotlivé stĺpce / polia a vzťahy medzi riadkami tabuľky typu "Tabuľka Relation". Okrem toho, ak je stĺpec / pole s názvom "Meno" potom sa používa pre pomenovanie jednotlivých riadok tabuľky čiastkové komponenty.

8. Vyberte ... tlačidlo Import.

9. Po krátkom čase (s barom pre spätnú väzbu o pokroku), bude nový projekt ABACUS byť vytvorený s tabuľkami, riadky tabuľky (v prípade, že druhá možnosť bola vybraná v kroku vyššie) a vzťahy z databázy Microsoft SQL Server.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Naplnenie vašej architektúry od aplikácie Visio | Naplnenie vašej architektúry z programu Excel


Naplnenie vašej architektúry z aplikácie Microsoft Visio

Navigácia: Naplnenie vašej architektúry> Naplnenie z produktov spoločnosti Microsoft>

Naplnenie vašej architektúry z aplikácie Microsoft Visio

Odoslať pripomienky na túto tému.

Môžete importovať vašej architektúry z aplikácie Microsoft Visio. Obrazcov vo výkrese Visio budú importované ako komponenty do ABACUS. Pripojenie vo výkrese Visio bude importované ako spojenie a kresba samotná budú importované do ABACUS ako diagramu. Okrem toho budú všetky vlastné vlastnosti vo výkrese Visio byť dovezená ako vlastnosti s kľúč triedenia mapované do vlastnosti typu, Label k menu majetku a k hodnote majetku.

Poznámka

Import z funkcie Visio vyžaduje, aby Microsoft Visio 2003alebo novší je nainštalovaná v počítači.

Ak chcete importovať výkresy aplikácie Visio do ABACUS

1. Skontrolujte, či máte ABACUS otvorený.

2. Vyberte File | Nové a vyberte Od Visioz dialógu, ktorý sa objaví, a kliknite na tlačidlo OK.

Poznámka

Ak chcete importovať do existujúceho projektu ABACUS potom buď pravým tlačidlom myši na uzol Súčasti v architektúre, alebo pravým tlačidlom myši na jednotlivé súčasti v rámci architektúry a potom vyberte príkaz Import | Z aplikácie Visio.

3. Vyhľadajte súbor Visio, ktorý chcete importovať.

Poznámka

Nižšie sú uvedené niekoľko jednoduchých pravidiel alebo odporúčaných postupov pri výstavbe (a ich úpravách) MS Visio výkres pre dovoz do ABACUS.

1. Čiary alebo pripojenie musí byť skutočné konektory, nie tvary.

· V opačnom prípade ABACUS bude len importovať ako súčasti, a preto nebudú "pripojené" k ničomu.

· Ak potrebujete urobiť nejaké "múdre" smerovanie (teda iné ako priamke), potom použite Dynamic konektora na základné tvary vzorkovníka, budú ABACUS importovať smerovania / kotevné body v poriadku.

· Snažte sa vyhnúť pomocou "siete Ring" a "Ethernet" tvary zo vzorkovníka siete a periférnych zariadení, ktoré umožňuje mnoho zložiek, ktoré majú byť "pripojený" k tomu. Zatiaľ čo my import prílohy v poriadku, pripojenie k pôvodný tvar je stále "rozšírená", aby odrážal prílohy. Použite oddeliť samostatný "rozbočovač / autobusom" tvar (bez konektora "nohy") a potom explicitne pripájať jednotlivé komponenty do náboja / autobusu so samostatnými konektormi.

· Ak riadok alebo pripojenie sa chová ako tvaru, kliknite pravým tlačidlom na neho a ísť na "Format | Správanie ... "a uistite sa, že interakcia štýl je nastavený na Line (1-rozmerné).

2. Komponenty musia byť tvary NOT konektory.

· V opačnom prípade ABACUS bude len importovať ako spojenie, a preto všetky informácie o tvar budú stratené.

· Ak súčasť chová ako konektor, kliknite pravým tlačidlom na neho a ísť na "Format | Správanie ... "a uistite sa, že interakcia štýl je nastavený na Box (2-rozmerné).

3. Konce konektora musí byť pripojená k tvarom, NOT obiehajúcich v pozadí za tvare.

· Ak nechcete pripojiť konektory tvary potom ABACUS nemá žiadny spôsob, ako vedieť, že ste v úmysle pripojiť daný konektor k tvaru / zložky, a preto to nechám, že koniec pripojenie Un-pripojené.

4. Etikety na tvary by mali byť (pokiaľ možno) vstavaný textový popis pre tvar, nie je samostatným textové pole na výkrese.

· Samostatné textové polia dostane dováža ABACUS ako zložky v ich vlastnej pravý, a zatiaľ čo vy môžete zlúčiť "label" zložku s reálnym komponenty v ABACUS, alebo len previesť "label" komponenty do polygonálny tvar (teda nie zložka sama o sebe) to je najlepšie sa vyhnúť týchto krokov.

5. Použite rovnaký základný tvar pre každú inštanciu rovnakého typu, nebuďte leniví a použiť obdĺžnik a niekedy box iní z rôznych tvarov šablón.

· ABACUS používa tvar základne a jeho základnú farbu, aby jednoznačne identifikovať komponentov a typy spojenia vo výkrese takže "červený obdĺžnik" a "červené pole" dostane dovážané ako dve samostatné typy komponentov. Tieto typy komponentov môžu byť zlúčené v ABACUS, ale to je najlepšie sa vyhnúť týchto krokov.

6. Úplne zapouzdřit "deti" tvary vnútri ich "rodičia", nenechávajte ich visieť cez okraj.

· ABACUS zistí akýkoľvek tvar, ktorý je úplne zapuzdrený v rámci iného tvaru ako dieťa z materskej spoločnosti, takže uistite sa, že celý tvar, vrátane štítku časť, je uzavretá.

7. Neumiestňujte tvar prekrývajúce ďalšie dva tvary.

· Ak tvar prekrýva dve iné tvary, či už je to "zoskupenie" / pozadia obdĺžnik alebo inak, bude dovážaná ABACUS ako súčasť, ktorá je dieťaťom ani o prekrývajúcich sa tvarov, ale akonáhle vyberiete komponent v Abacus 'kresliaceho nástroje , vzhľadom k ľavom hornom rohu sú komponenty referenčný bod, stane sa dieťa po ľavej strane prekrývala tvar / zložku.

8. Snažte sa minimalizovať používanie textových poznámok na výkrese, pretože to dostane importované ako súčasti v ich vlastnej pravý, a budú musieť byť prevedené na voľných tvarov v ABACUS. Premýšľajte o tom, či sú skutočne názov existujúce zložky alebo pripojenie.

9. Kým ABACUS podporuje bohatý / farebné / tvary vektor založené, snaží minimalizovať používanie bitmap, zahraničných tvarov a lepšiu metasúborov pre tvarov ABACUS v súčasnosti robíniepodporujú tieto typy. Budú importované ako jednoduché biele obdĺžniky.

10. Snažte sa vyhnúť carriage vráti (Shift-Return) na štítkoch, ako sú importované a zobrazené ako špeciálny znak "[]" v ABACUS k názvu komponenty.

11. Sa snažia minimalizovať rôzne farby, ktoré sa používajú na tvary rovnakého typu. Ako bolo uvedené vyššie, základné farby a základný tvar jednoznačne identifikuje komponentov a typy spojenia, takže čím viac variácie je tu viac zanikajúce a konsolidácie, ktoré budú musieť byť vykonané po dovoze v ABACUS.

12. Buďte opatrní s vyplnené tvary, pretože ak je tvar naplnil celú cestu do rohov a potom ju sfarbenie neskôr v ABACUS nebude mať žiadny vplyv.

13. Pri zložitejších tvarov linkami musíte použiť polygón, ktorý je vytvorený tým, že riadky začínajúce kde ten predchádzajúci skončí a potom sa nakoniec vracia do východzieho bodu. Ak chcete, môžete použiť výplne a čiary na šírku, aby polygón vyzerať ako "šípka" alebo čokoľvek tvar chcete.

14. Uistite sa, že tvary ID v MS Visio je zmysluplný nielen Shape.xx. To je upraviteľný pomocou pravým tlačidlom myši na "Zobraziť tabuľku s tvarmi", ktorý je k dispozícii v režime MS Visio pre vývojárov (umožnené prostredníctvom Nástroje | Možnosti v MS Visio).

15. Elipsy a oblúkyv rámci tvarovsú podporované v ABACUS ale NURBS a spline sú v súčasnej dobe nie sú podporované.

16. Uistite sa, že celý tvar je zoskupená v MS Visio alebo to dostane importované ako niekoľkých zložiek / typov.

17. Snažte sa minimalizovať používanie otočených tvarov v subshapes, ako budú niekedy nie byť importované správne.

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Naplnenie vašej architektúry ručne | Naplnenie vašej architektúry z programu Access | Naplnenie vašej architektúry z programu Excel


Naplnenie vašej architektúry ručne

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne>

Naplnenie vašej architektúry ručne

Odoslať pripomienky na túto tému.

Komponenty vyššej úrovne a spojenie vašej architektúry bude pravdepodobne musieť byť naplnená manuálne. Zvyčajne sa bude jednať o viac abstraktné prvky a spoje.

Ak chcete manuálne naplnenie vašej architektúry

1. Skontrolujte, či máte ABACUS súborOpen, cestovateľZobrazí, a architektúra pridané .

2. Pridajte komponent. Ak chcete urobiť, Kliknite pravým tlačidlom myšina oblasť stromu chcete naplniť, a vyberte Pridajte Sub-Component ..., Alebo kliknite na New ComponentTlačidlo na Zobraziť panel nástrojov , Komponenty môžu byť pridané len pod konáre súčasti stromu. Chcete, aby vaše strom diagram byť presná reprezentácia vašej architektúre. Keď sa objavil svoju architektúru, budete sa naučili, presne tak, ako to všetko do seba zapadá. Budete potrebovať tieto znalosti, keď pridáte svoje komponenty a pripojenie. Ak pridávate prvý komponenty, budete ho pridať priamo do pobočky Components. Zvyšok vašich komponentov môže byť buď na rovnakej úrovni vo stromu, alebo môžu byť čiastkové komponenty ako prvý.

3. Aktualizujte hodnotyvlastnostikaždej zložky, ako ho pridať. Ak chcete urobiť, cvaknutiena súčasti, a upraviť vlastnosti zobrazené v Okno Vlastnosti(typicky) na pravej strane. Vlastnosti sú všeobecne veci ako požiadavky, spracovateľských kapacít a pod Keď ABACUS vyhodnotí vašej architektúry, bude to počítať niektoré nové vlastnosti, a uložiť ich späť do architektúry. Tieto nové vlastnosti sú údaje sa snažíte analyzovať, ako je využitie, doba odozvy, šírka pásma, atď

4. Pridajte vaše pripojeniea aktualizovaťich vlastnostias you go - rovnako ako vy pre komponenty (ale pod pripojenie vetva stromu).

5. Pripojiťspoje a komponenty. Ak chcete urobiť, vyhľadajte pripojenie, kliknite na jednu z jeho ukončí alebo role , A presuňte ju na komponent. Prípadne kliknite na priečinok a presuňte ju na jednu zo spojenia je role (tj. buď Source alebo Sink), Alebo môžete kliknúť pravým tlačidlom myši a pretiahnite zložku do inej zložky a vyberte Pripojiť k, Alebo jednoducho kliknite pravým tlačidlom myši na priečinok a vyberte Pripojiť ..., Keď pretiahnete pripojenie role, Zistíte, symbol skratku Keď ukážete na súčasť môžete pripojiť k. To znamená, že nie ste robiť kópie, ste len jeho pripojenie. Uistite sa, že ste ho pripojiť k správnej cieľovej zložky. Napríklad, ak je to spojenie je Zdroj role, Jeho pretiahnutím do zdrojovej zariadení (tj súčasť, ktorá je zdrojom toku dát).

Tip

Re-objednať entity priamo vo Vašom architektúry (napr komponenty, pripojenie atď) v cestovateľje pomerne jednoduché. Jednoducho Kliknite na tlačidlo| Držte| Dragpríslušný subjekt, a miesto, kde žiaduce vo vašej architektúre. Funkcia re-usporiadanie tiež umožňuje umiestniť subjekty v rôznych hierarchiou vašej architektúre.

Môžete tiež chcieť, aby

6. Pridať štandardov (prednastavené sady vlastností - predvoľby) na vaše komponenty, pripojenie alebo typy

7. Zmeniť vlastnosti komponentu, pripojenie alebo typu

8. Undo a Redo Operácia

9. Zmeniť typ komponentu alebo spojenie

10. Vytvorenie nového typu alebo typu Group

11. Zmazať komponenta alebo pripojenie

12. Vytvorte, duplicitné alebo vyvíjať architektúra

13. Dovozné typy a štandardy z knižnice

14. Import z iného súboru ABACUS, XML, Excel alebo Visio

15. Kopírovanie a vkladanie časti (alebo všetky) z vašej architektúre

16. Nájsť a nahradiť položky v architektúre

17. Rozbaliť / zbaliť niektoré alebo všetky z uzlov v strome

18. Splynúť položky

19. Definovať a Overiť Obmedzenia obmedziť štruktúru vašej architektúry

20. Evolve vašej architektúry vytvoriť niekoľko architektonických riešení pre porovnanie a základné línie

Pozri tiež

Naplnenie vašej architektúry - Prehľad | Vytvorenie nového súboru


Publikovať na webe

Navigácia: Podávanie správ o vašu architektúru>

Publikovať na webe

Odoslať pripomienky na túto tému.

ABACUS "Publikovať Web funkcia umožňuje architektonické modely, ktoré majú byť videný cez zabezpečené webové stránky. Architektúry sú exportované do formátu HTML a sú navrhnuté tak, aby odrážala vzhľad a dojem z Exploreru v ABACUS. Pohľady (vrátane katalógy, diagramy, 3D a grafy) sú tiež exportované do formátov zobrazovaných pomocou internetového prehliadača.

Poznámka

V súčasnej dobe, názory a Matice nie sú publikované.

Ak chcete publikovať svoje architektonické modely, na web

1. Skontrolujte, či máte príslušné ABACUS súborotvorené, obsahujúci obývaný architektúraktoré chcete publikovať na webe.

2. Vybrať Súbor| Publikovať ....

3. Publikovať na webovej konfigurácieZobrazí sa okno.

Publikovať v sieti WWW Konfigurácia

4. V predvolenom nastavení sú vybrané všetky časti modelu, vrátane Stromový pohľad, The Normy, Druhy, šablóny a architektúra (y). Zrušte zaškrtnutie akejkoľvek časti, ktoré nechcete publikovať na web, vrátane všetkých jednotlivých názorov v rámci architektúry (y).

Tip

Ak chcete skryť určité komponenty, spoje a / alebo ich vlastnosti sa odporúča, aby správca vytvára úlohu "verejného" s použitím Prístup funkcie na základe rolí Abacus ' a potom odstráni povolenie na čítanie z týchto typov komponentov, typov a / alebo vlastnosti pripojenia, ktoré si neželajú byť zverejnené. Potom by mal užívateľ prihlásiť pod týmto rolu a publikovať na web, ako ABACUS zverejní iba na tie prvky, ktoré majú povolenie na čítanie nastavené pre úlohu. Okrem toho môžu používatelia auto-publikovať z príkazového riadku, ako je popísané tu .

Poznámka

Môžete si vybrať všetky časti zobrazené kliknutím na tlačidlo VšetciTlačidlo alebo invertovať vašu voľbu kliknutím na tlačidlo ObrátiťTlačidlo. Môžete tiež kliknúť na tlačidlo ŽiadnyTlačidlo pre vymazanie voľby.

Poznámka

Ak ty zrušte zaškrtnutie položky Tree Viewpotom nie je strom rám (pozri nižšie), budú zverejnené. V súlade s tým, mali by ste zvoliť úvodnú stránku podľa kroku 6 alebo nižšia Po publikovaní budete musieť prispôsobiť buď najvyššej úrovne; a) index.htmlsúbor zmenou "rámu src =" mainPage.html "name =" "'element_details linky priamo odkaz na príslušné HTML stránky v priečinku obsahu, alebo, b) mainPage.htmltým, že poskytuje hypertextový odkaz alebo presmerovať na príslušné HTML stránky v priečinku obsahu.

5. Kliknite na tlačidlo Voľba tlačidlo a nasledujúce Možnosti Vydavateľdialóg sa zobrazí.

UverejniťMožnosti er

6. Svoliť 3D, Diagrama grafy formáty a či sa má zobrazovať názov, popis alebo Vlastnosti Pre výhľadom von z dostupných možností (pozri nižšie poznámku k pripomienkam na rôznych formátoch).

7. Ak si prajete nastaviť úvodnú stránku publikovaného modelu do určitého pohľadu potom skontrolovať Použiť Zobraziť ako úvodnú stránkumožnosť a prejdite do zobrazenia pomocou tlačidla "...", ktorý sa aktivuje.

Poznámka

Len názory vybrané v časti Oblasti podľa kroku 4 vyššie, sú k dispozícii potrebné nastaviť ako predvolený stránku.

8. Ak chcete získať spätnú väzbu na konkrétne stránky v publikovanej modeli uistite sa, že Email Spätná väzbaje vybraná možnosť, zadajte e-mailovú adresu v Emailová adresatextboxa upraviť Tele e-mailuSekcia prípadne, Ak si neželáte, aby spätná väzba poslal následne zrušte zaškrtnutie Email Spätná väzbaVoľba a nechajte textové pole prázdne.

9. Kliknite na OKTlačidlo.

10. Kliknite na BrouzdatTlačidlo.

11. Prechádzať pre priečinkyZobrazí sa okno.

12. Vyberte umiestnenie, ktoré chcete uložiť súbor HTML najvyššej úrovne (a všetky automaticky generované súbory).

Poznámka

Je to dobrý nápad, vytvoriť určitú zložku (typicky volal "Vyšlo") s použitím Vytvoriť novú zložkutlačidlo v dolnej časti dialógového okna na uloženie súboru na najvyššej úrovni a všetky HTML automaticky generované súbory.

13. Kliknite na OKTlačidlo.

14. Cesta zložky sa zobrazí v Adresártextbox.

15. Kliknite na SkončiťTlačidlo.

- Alebo -

15. Zadajte cestu zložku v Adresártextové, kam chcete uložiť súbor vo formáte HTML na najvyššej úrovni (a prípadne automaticky generované súbory).

16. Kliknite na SkončiťTlačidlo.

Poznámka

Export Diagramyveľmi zriedka zlyhá, najčastejšie, keď je počítač nedostatok pamäte (normálne pri použití veľmi veľkých súborov). Neúspešný export sa bude opakovať raz. Tam bude jeden varovanie pre zlyhanie prvý pokus, a druhý výstražný v prípade, že re-pokus zlyhá. Preto, ak sú len varovania sú "počiatočné pokus zlyhal" tých, publikovanie bol úspešný. V prípade, že re-pokus zlyhá, skúste publikovať menšiu časť vášho súboru alebo uvoľniť niektoré systémovej pamäte.

Uložený súbor (y) HTML môže byť teraz pohľad z jeho umiestnenia, alebo skopírovať do zabezpečenej webovej stránky.

Publikovať na webe v programe Internet Explorer10

Akékoľvek hypertextové odkazy ktoré boli vytvorené v pôvodnom modeli bude pretrvával vo zverejnenom modelu a kliknutím na odkaz bude nasledovať odkaz na miesto určenia (ak je to bolo vydávané). Okrem toho budú všetky prvky v publikovaných diagramy, ktoré nie sú už hypertextové odkazy v pôvodnom modeli pomocou odkazom späť na ich zodpovedajúce prvky v pohľade stromu (ak to bolo vydávané) a kliknutím na prvok vo zverejnenom diagrame dôraz bude skočiť späť do príslušné miesto v strome. Táto funkcia je podobná "show v Explorer" kliknite pravým tlačidlom myši funkcie v ABACUS.

Poznámka

Avolution dôrazne odporúča nasledujúci softvér a formáty súborov by mali byť použité k plne využiť Publikovať v sieti WWW funkcie v ABACUS:

1. Internet Explorer (80,0 a vyšší)zobraziť publikovanej zobrazenie Prieskumník. Mozilla Firefox (30,0 alebo novší)Tiež sa odporúča, a plne podporilAvšak, ak používate odporúčaný formáte SVG pre diagramy potom vo Firefoxe 9. môžete použiť len na podporu prehliadača natívne SVG, ktoré bohužiaľ neumožňuje priblíženie alebo ryžovanie.

2. Adobe SVG Viewer 3.0 zapojiť (k stiahnutiu od tu ) a SVGformát súboru pre zverejňovaný diagramy, Formát obrazu SVG pre diagramyOdporúča sa preto, že; SVG je formát obrazu založenú na vektoroch, a preto je "strata-less 'a vyzerá oveľa lepšie, v danom úrovni priblíženia ako ktorákoľvek z iných formátov, SVG možno importovať do MS Visio, SVG možno zväčšovať na akejkoľvek úrovni alebo rozlíšenie , SVG má väzby späť do zobrazenia stromu pre pripojenie (nie len komponenty), SVG vždy tlačí na lepšie rozlíšenie, a SVG je asi polovičná veľkosť súboru z iných formátov. PNG je ďalší odporúčanie, však, ako je to rasterised formát na niektorých úrovniach priblíženie jasnosť toho názoru, budú stratené a kliknutím na tlačidlo pripojenie na diagramy nebude skočiť späť do príslušného umiestnenia v strome. BMP je znechutený pretože aj keď je formát "straty menej" veľkosť súboru je 100x, že z ostatných formátov a 20MB obrázky nie sú neobvyklé.

Trade-off s SVG je, že divák SVG bude musieť byť nainštalovaný a je potrebné uistite sa, že .svg image / svg + xml, ktorý znie typy webového servera MIME. Po inštalácii prehliadača SVG Microsoft Internet Explorer sa vás spýta, prijmite licenčnú zmluvu diváka, a potom by mal fungovať dobre. A zatiaľ čoMozilla Firefox podporuje SVG súbory natívne, Adobe plugin je stále odporúčaaby bolo možné priblížiť diagramy, ak používate Firefox 8 alebo starší (ak používate Firefox 9 nemožno zakázať natívne SVG diváka), Akonáhle je inštalácia pre Adobe plugin bol spustený, tieto kroky sú potrebné používať vo Firefoxe:

· Otvorte Firefox a zadajte "about: config" (bez úvodzoviek) do adresného riadku.

· Prejdite nadol a nájsť nehnuteľnosť svg.enabled(ak používate Firefox 9 potom natívny SVG prehliadanie nemôže byť zakázaný, a táto vlastnosť neexistuje), Dvojitým kliknutím na neho zakázať.

· Teraz tu adresár, kde je nainštalovaný SVG plugin (napr C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Skopírujte súbory NPSVG3dll a NPSVG3.zip a vložiť ich do adresára pluginov Firefox (napr C: \ Program Files \ Mozilla Firefox \ plugins)

· Ukončite všetky inštancie Firefoxu

3. ABACUS 3D Viewer Avolution je (3.1 a vyššie)a Avolution je .abacus3Dformát súboru pre publikované 3D zobrazenie. Kým Cortona VRML Client plug-in (2.0 a vyššie)je k dispozícii na prezeranie VRML verzie publikovaných názorov to nie je zadarmo pre komerčné využitie a stále vyžaduje inštaláciu na strane klienta. 3D Viewer ABACUS je viac rys-bohatý než akýkoľvek prehliadač VRML, a je voľne k dispozícii na stiahnutie tu , V oboch prípadoch sa uistite, pridať .vrml x-svet / X-VRML a .abacus3d application / octet-stream na druhy webového servera MIME.

4. PNGformát súboru pre publikované názory diagramu. Formát obrazu PNG pre zobrazenie grafu je odporúčané, pretože, keď sa jedná o rasterised formát a tam je "strata" trade-off medzi veľkosťou súboru a prehľadnosti grafu je zvyčajne najlepšie. BMP je znechutený, ako keď sa jedná o "stratu menej" formátovať veľkosť súboru je 20x, že z ďalších formátov a 2Mb grafy nie sú neobvyklé.

Ak chcete zmeniť vzhľad a dojem z webových stránok, môžete upraviť súbor predvolenú stránku s názvom mainPage.html a súbor štýlov s názvom abacus.css. Tu nájdete tieto súbory v rovnakom priečinku, kde ste sa rozhodli uložiť súbor HTML najvyššej úrovne. Pre viac informácií o štruktúre a šitie publikované výstupu nájdete v nasledujúcej časti.

Štruktúra ABACUS zverejnený modelov

Počítadlo zverejnila model je štruktúrovaný takto:

1. Zložka najvyššej obsahuje niekoľko súborov a za predpokladu, všetky možnosti sú zahrnuté v ABACUS Publikovať v sieti WWW konfiguračný dialóg, že bude obsahovať index.htmlSúbor zložený z troch snímok; treeView.html, findNode.html a mainPage.html a potom shortcutError.htmlstrana, TreeView.html je naplnený tree.js, tree_items.jsa tree_tpl.js javascript súbory umiestnené v priečinku zahŕňajú (popísané nižšie) a replikuje strom Exploreru z ABACUS. FindNode.html je poháňaný find.js javascript súbor umiestnený pod obsahovať zložku (pozri nižšie), a to bude hľadať vetvy stromu nie iba viditeľné uzly. Ton mainPage.html je statická HTML stránky, ktoré môžu byť prispôsobené s firemné logá a podobnea zobrazí sa, ak nie je počiatočná stranu je vybraný pri publikovaní.A konečne, stránka shortcutError.html je vstupná stránka pre všetky rozbité skratky zo stromu vzhľadom k príslušnej stránky nie sú publikované.

Tip

Môžete preskočiť mainPage.html úplne podľa výberu použiť úvodnú stránku pri publikovaní alebo úprave súboru index.html na bod priamo k danej zobrazenie (povedzme) úpravou rámu src = "mainPage.html" riadku na bod priamo na prvý pohľad v prvom architektúry, typicky "rámec" diagramu.

2. Najvyššej úrovne ajncludezložky obsahujúIngrôzny JavaScript (JS) a kaskádových štýlov (CSS) súbory používané .html súbory celom zverejneného modelu.

3. Zložka Content najvyššej obsahuje, Abecedne;

· A '3D Zobrazenie' Zložka sčíslovanýHTML stránky a súbor VRML alebo abacus3d pre každý z publikovaných 3D zobrazenie, Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· Architektúry zložka s číslované HTML stránky pre každú architektúru, ktorá bola publikovaná. Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· A Katalógy zložka obsahujúca číslovaný HTML stránku, pre každý z publikovaných katalógov. Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· A Grafy Zložka sčíslovanýHTML stránky a PNG, JPG etc pre každý z publikovaných názorov diagramu, Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· A Komponenty priečinok obsahujúcičíslovanýHTML stránky pre každú zo zložiek publikovaných, Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· A Pripojenie priečinok obsahujúcičíslovanýHTML stránky pre každý z publikovaných prípojok, Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· A Diagramy priečinok obsahujúcičíslovanýHTML stránky a PNG, SVG etc pre každú z zverejnila diagramy. Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· Ikony pod-Zložka s rôzne obrazy používané v celom zverejneného modelu.

· A Normy podpriečinok sčíslovanýHTML stránka pre všetky Normyktoré boli publikované. Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

· A Šablóny náhradník-folder so zbierkou číslovaných čiastkových zložiek pre každú šablónu zverejnené z projektu. V rámci každej čiastkovej zložky je Components a zložku Pripojenie a vnútri nich je číslované stránky HTML pre každý komponent a pripojenie šablóny. Pozri poznámku nižšie ohľadom informácií o systéme číslovania zložiek / súborov.

· A Druhy sub-zložka s komponentom aPripojenia sub-zložky sčíslovanýHTML stránky pre všetky komponenty aTypy spojenia, ktoré boli publikovanéa zbierka očíslovaných čiastkových zložiek pre každý typ zverejnené z projektu, ktorý obsahuje HTML stránku pre každý z obmedzenia. Pozri poznámku nižšie ohľadom informácií o systéme číslovania zložiek / súborov.

· A Pohľadbods sub-zložky ačíslovanýHTML stránka pre niektorý z pohľadubods, ktoré boli publikované. Pozri poznámku nižšie pre informácie o schémy číslovania súborov.

Poznámka

Číslovanie stránok HTML (a v niektorých prípadoch obrazové súbory) zodpovedá jedinečný ID pre každý objekt, ktorý bol úložisko nastavený, keď bolo to vytvorilv ABACUS (označované ako EEIDs), Toto číslo sa nemení tak ako diagramy, typy, komponenty etc sú aktualizované oni vôľaako predtým zachovať rovnaké ID. V každom prípade sa daný úložisko objektMeno môže byť nájdený v blízkosti začiatku HTML stránky medzi ... HTML tagy.

Obmedzenie prístupu na určité stránky / Zobrazenie s IIS

Ak používate IIS ako webový server pre zverejneného modelu, môžete byť schopní obmedziť prístup na určité stránky / pohľady využívajúci metódu nižšie:

1. Vytvoriť webové stránky v IIS (iný v prípade, že je súčasný jedným nechcete zasahovať).

2. Zmena Vlastnosti-> Directory Security-> anonymný prístup - Odznačte anonymný prístup a využitie overený prístup.

3. Ak je to len normálne server s žiadnymi domény komplikácií atď, potom by ste mali použiť voľbu "Integrované overovanie systému Windows", ktorá by potom použiť server stroje miestnej používatelia / loginy ako overenie, a len pridať užívateľa do miestneho počítača (byť opatrný že ste si vedomí dôsledkov, bezpečnosti múdry, pridávanie nových užívateľov do zariadení, napríklad v závislosti na tom, či vzdialený prístup je nastavený pre stroj, atď.)

4. Pridať oprávnenia na konkrétne súbory / zložky podľa potreby. Pravým tlačidlom myši na jednotlivé súbory / zložky -> Vlastnosti a upravte povolenia zabezpečenia tak, ako by ste normálne súborov / zložiek.

To sa môže líšiť v závislosti od verzie IIS a aké konkrétne operačný systém Windows je na serveri, a či máte doménu alebo iné odlišné nastavenie.

Pozri tiež

Naplnenie vašej architektúry | Analýza vašej architektúry


Registrácia ABACUS

Navigácia: Referencie>

Registrácia ABACUS

Odoslať pripomienky na túto tému.

Pri prvom spustení počítadlo (alebo po dočasnom licencie vypršala), budete musieť zaregistrovať aplikáciu proti licenčným servera Avolution Používa jedinečný licenčný kľúč poskytované na miestnej správcu ABACUS alebo priamo z Avolution. Ak nemáte licenčný kľúč, prosím kontaktujte svojho miestneho správcu ABACUS alebo Podpora Avolution .

Pre registráciu s licenčným kľúčom

1. Po inštalácii, spustiť počítadlobuď poklepaním na zástupcu na ploche alebo v ponuke Štart systému Windows.

2. V dialógovom okne Registrácia, ktoré sa objavia zadajte 26 znak licenčný kľúčposkytnuté miestneho správcu ABACUS alebo Podpora Avolution , Alebo kliknite na tlačidlo Prechádzať ...a vyberte podpísal .dlsc súbor vrátil z Podpora Avolution podľa poznámke v kroku 4 nižšie. Ak používate správne podpísaný .dlsc súbor ABACUS by mala začať podľa kroku 5 nižšie.

Tip

Môžete vložiť licenčný kľúč do dialógu skopírovaním do schránky Windows a výberom na pozadí dialógu a stlačením Ctrl + V.

Dialóg Registrácia

3. Kliknite na tlačidlo OKa v prípade, že licenčný kľúč je ABACUS platný licenčný kľúčABACUS sa teraz pokúsi kontaktovať licenčný server Avolution na overenie licenčný kľúč.

Poznámka

Ak dostanete Inštalačný kód je neplatnýRegistrácia chyba je veľmi pravdepodobné, že ste zadali nesprávne kód. Skúste skopírovať a vložiť kód podľa tip je uvedené vyššie.

Kontaktovanie licenčný server Avolution

4. Kliknite na tlačidlo OKa po krátkej dobe by mala ABACUS úspešne registrovať.

Úspešné Registrácia

Poznámka

Ak dostanete Nemožno kontaktovať licenčný serverRegistrácia chyba je veľmi pravdepodobné, že brána firewall (alebo iné bezpečnostné opatrenia) vo vašej sieti bráni prístupu k licenčnému serveru Avolution je. Kliknite na tlačidlo OKUložte .dlsc súbor na lokálny počítač a potom buď e-mail súbor .dlsc na Podpora Avolution a čakajú na ďalšie inštrukciealebo sa snaží podpísať licenčný súbor sami pomocou nasledujúcej adresu - http://licensing.avolutionsoftware.com/LicenceSign/ .

Nemožno kontaktovať licenčný server

Otvorte License podpisu webové stránky

Manuálny licencie podpísanie webové stránky

Prípadne, ak sa dostanete Tento kód inštalácie bol použitý na viac systémov, ako povoľuje licenciaRegistrácia chyba je pravdepodobné, že váš miestny stroj bol prestavaný od posledného registrovaný Abacus, alebo sa snažíte zaregistrovať licenčný kľúč iného užívateľa. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution .

Už bol použitý na inštaláciu kód

5. Kliknite na tlačidlo OKa ak je zapísaná úspešne ABACUS by mala otvoriť s Uvítacia obrazovka .

Pozri tiež

Podpora Avolution | Čo ABACUS robiť?


Štandardné výber Element

Navigácia: Analýza vašej architektúry>

Štandardné výber Element

Odoslať pripomienky na túto tému.

Pri vytváraní diagramu, 3D pohľad, Správa,štandardná schémaalebo spustenie simulácie, Štandardné výber prvok okno slúži na výber prvkov, ktoré chcete analyzovať / pohľad.

Okno Štandardné Selection Element

Sťahovanie kladky

· Filter by Výhľadvôľa zahrnúť prvoks z predtým uloženého pohľadu (tj diagram, graf, 3D). Týmto spôsobom môžete vykonávať zložité "pripojiť" otázok ošetrením ďalší pohľad ako uložený "otázku '.

Checkboxes

· Zobraziť Úrovnebude skupina prvok v závislosti na úrovni, ktorá sa vyskytujú vo stromu. Úroveň 1 je najvyššia najviac úrovni.

· Zobraziť Druhybude skupina prvky podľa typov, ktoré sú.

· Rodičia vybranábude obsahovať nadradeného priečinka akýchkoľvek vybraných prvkov. Týmto spôsobom môžete zaistiť, že iba hierarchia vyššie prípadných detí budú zahrnuté na "zdola nahor" výberu.

· Deti vybranábude patriť deťom zložky všetkých vybraných prvkov. Týmto spôsobom môžete zaistiť, že iba hierarchia pod všetkými rodičmi budú zahrnuté na "top-down" výberu.

· Meno zápasy Hodnotabude obsahovať len tie prvky, ktoré majú názov obsahuje zadaný reťazec (Poznámka: zástupné znaky (tj a *), môžu byť použité?). Týmto spôsobom môžete tvoriť "sémantický" dotaz.

· Má Typ nehnuteľnosti / Názov / hodnotabude obsahovať len tie prvky, ktoré majú vlastnosť typ, názov a hodnoty obsahujúce zadaný reťazec a to buď priamo na prvku alebo na jeho štandardoch (Pozor prosím:?.? zástupné znaky (tj a *) je možné využiť napr * v poli Hodnota bude dať všetky prvky, ktoré majú neprázdne hodnoty pre danú nehnuteľností). Týmto spôsobom môžete tvoriť "sémantický" dotaz.

· Má štandardnébude obsahovať len tie prvky, ktoré majú štandardné názov obsahuje zadaný reťazec (Poznámka: zástupné znaky (tj a *) možno použiť napr HP * dám všetky prvky s aspoň jednou Štandardné začínajúce písmenami H a P ?.). Týmto spôsobom môžete tvoriť "sémantický" dotaz.

· Komponenty / Pripojenie pripojená do vybranéhobude zahŕňať všetky pripojené prvkov na tie, ktoré boli vybrané. Týmto spôsobom môže byť vybraná "call-tree" alebo "dopad analýza".

Poznámka

Ak máte obaja Zobraziť Úrovnea Zobraziť Druhyvybraná potom si môžete vybrať, či sa strom zobrazujú úrovne prvej alebo typy najprv tlačidlo, ktoré sa objaví nad dvoma zaškrtávacích políčok.

Tip

Akonáhle je vybraná položka v okne štandardné výber Element, nebude podliehať žiadnym ďalším zmenám filtra, pokiaľ nie je zrušené. Pretože neexistuje žiadny natívny spôsob, ako hľadať dvoma rôznymi súbormi prvkov naraz (napr komponenty sa štandardnou A alebo štandardné B), môžete hľadať najprv v rámci jednej skupiny, vyberte požadované súčasti, a potom vykonať druhú pátranie po druhej sady ,

Tlačidlá

· Všetcivyberie všetky elementy.

· Obrátiťzruší všetky aktuálne vybrané prvky a vyberie všetky tie, ktoré neboli vybrané.

· Žiadnyzruší všetky prvky.

· Pridať filtervyberie výsledný obsah aktuálneho nastavenia filtra a umožňuje výber dodatočného obsahu rovnako účinne An a alebo sa pripojiť filter.

Pozri tiež

Analýza vašej architektúry


Nástroje na kreslenie

Navigácia: Naplnenie vašej architektúry> Použitie výkresov>

Nástroje na kreslenie

Odoslať pripomienky na túto tému.

Nástroje na kreslenie umožňuje vytvorenie širokej škály architektonických schém a diagramov. Architekti tradične používajú rad rôznych kresieb pre záznam a sprostredkovať návrh architektúry. Dvojrozmerné (2D) diagramy sú obvyklý spôsob, ako dokumentovať a komunikovať rôzne časti systému. Typickými kresby používaných v podnikové systémy sú:

· Business procesné modely a diagramy;

· Organizačné schémy;

· Spolupráca diagramy;

· Entity-Relationship (ER) diagramy;

· Data-vývojové diagramy (DFD je);

· Diagramov tried;

· IDEF (zahŕňajúce niekoľko z vyššie uvedených); a

· UML (zahŕňajúce niekoľko z vyššie uvedených).

Tam naozaj nie je žiadny limit na druhy diagramov, ktoré je možné vytvoriť. ABACUS sa snaží vyrovnať flexibilitu diagram pri zachovaní integrity architektúry a jeho foriem reprezentácie.

Kresba prostredie je kartami a ukotvené okno, vo vnútri hlavnej ABACUS aplikáciu. Toto okno obsahuje plátno, kde sa kresba koná, a keď je otvorené okno výkresu druhý ukotvené okno, , Okno šablóny, je viditeľný so súborom výkresu šablón. Panel šablóna má 4 záložky: Prvky, prípojky, tvary a konektory. Plátno sa javí ako biele pozadie s jemnými čiarami (užitočné pre rozvrhnutie).

Komponenty sú reprezentované rozsahu tvarov, pričom spoje sú nakreslené ako namierených liniek. Pripojenie pripojiť k súčasti pomocou role (tj. buď Source alebo Sink) ktoré však nie sú zobrazené z estetických dôvodov.

Tip

Kým diagramysú veľmi užitočné pre zobrazenie rôznych častí systému, ktoré sú vo svojich škálovateľnosti, čo je dôvod, prečo ABACUS používa 3D vizualizáciu zložité štruktúry systému.

Možno budete chcieť

1. Otvorte Diagramov Nástroj

2. Vytvoriť nový diagram na časť vašej architektúre

3. Kopírovať diagram vo vnútri alebo naprieč architektúrach

4. Pridajte komponenty diagramu

5. Vytvorenie nové komponenty a spoje v architektúre (schematicky) pomocou nástroja na kreslenie

6. Odstránenie komponenty z diagramu

7. Pripojiť & manipulovať spoje

8. Zmena vlastnosti zobrazenia súčiastok a spojov.

9. Pomocou odkazov v diagram

10. Vynútiť pridruženia typu a názory tak, aby sa obmedziť typy diagramov, ktoré možno vyvodiť.

Pozri tiež

Naplnenie vašej architektúry | Naplnenie vašej architektúry ručne | Analýza Vaše architektúra


Titulná strana

ABACUS

Disclaimer

Avolution Pty Ltd neposkytuje žiadne vyhlásenia ani záruky, pokiaľ ide o tohto manuálu a, v maximálnej miere povolenej zákonom, výslovne obmedzuje svoju zodpovednosť za porušenie akékoľvek záruky, ktoré môžu byť predpokladané na nahradenie tejto príručky s iným. Ďalej, Avolution Pty Ltd si vyhradzuje právo revidovať túto publikáciu kedykoľvek bez toho, aby jej tým vznikol záväzok upozorňovať akúkoľvek osobu na revíziu.

Autorské práva

Copyright 2001-2015Avolution Pty Ltd. Všetky práva vyhradené.

Ochranné známky

Avolution Pty Ltd urobila všetko úsilie dodávať informácie o ochranných známkach o názvy spoločností, produktov a služieb uvedených v tomto návode. Ochranné známky uvedené nižšie boli odvodené z rôznych zdrojov.

Microsoft Windows, Access, Visio, Excel, SQL Server a Internet Explorersú ochranné známky spoločnosti Microsoft Corporation.

Všeobecná poznámka:

Niektoré názvy produktov použité v tejto príručke sú použité len na účely identifikácie a môžu byť ochrannými známkami príslušných vlastníkov.

December do roku 2015Edition pre Avolution ABACUS verzie 4.5.

Manuálny revízia 1.0

Generated, tlačený, a zviazal v Austrálii.


ABACUS Inštalácia Predpoklady

Navigácia: Referencie>

ABACUS Inštalácia Predpoklady

Odoslať pripomienky na túto tému.

Informácie týkajúce sa aplikácie Visio Excel Import a Import / Export

ABACUS vyžaduje Microsoft Office byť inštalované tak, aby na vykonávanie operácií Excel import / export a Visio Importovať. Overte prosím, že Microsoft Office 2003 alebo novšíje správne nainštalovaný. Ak narazíte na ďalšie problémy, kontakt Podpora Avolution .

Aby bolo možné vykonávať Visio Import a Excel import / export operácie, ABACUS používa Microsoft Office primárnej zostavenie Interop (PIA je). ABACUS v súčasnej dobe je dodávaný s agregátmi potrebné na vykonanie Excel Import / Export a Visio Import.

Informácie týkajúce sa SQL Server importom

ABACUS vyžaduje Microsoft SQL Server 2005, 2008, 2008 R2, 2012 alebo 2014je nainštalovaný, aby mohol začať nový projekt zo servera SQL Server. Overte prosím, že Microsoft SQL Server 2005, 2008, 2008 R2, 2012 alebo 2014je správne nainštalovaný. Ak narazíte na ďalšie problémy, kontakt Podpora Avolution .

Chyby Otvorenie 3D vizualizácie

Ak 3D prehliadač ABACUS nefunguje pre vás, nesmie chýbať v SlimDX DirectX Runtime (inštalovaný ako súčasť plného ABACUS EXE inštalácia). To možno stiahnuť tu , Ak máte 64bit verziu systému Windows, budete možno musieť nainštalovať tento .

Chyby Editácia ABACUS Vlastná Správy

Editácia počítadlo "Custom Reports vyžaduje Report Builder 3.0, ktoré majú byť nainštalované. ABACUS a Report Builder sú postavené na Microsoft .NET Framework 4.0, a zatiaľ čo oba nevyžadujú Microsoft .NET Framework 3.5, Microsoft nesprávne nakonfiguroval Report Builder MSI iba postupovať, ak je nainštalovaný Microsoft .NET Framework 3.5.

V súlade s tým, Avolution má upravenú verziu inštalačného Report Builder MSI súboru, ktorý nevyžaduje Microsoft .NET Framework 3.5, môže to byť stiahnuté tu .

Pôvodný Microsoft Report Builder MSI si môžete stiahnuť tu , Ak ešte nemáte Microsoft .NET Framework 3.5, ktorá bude vyžadovať, môžete si ho stiahnuť tu , Poznámka: Pre viac inštalácií, offline inštaláciu Microsoft .NET Framework 3.5 z tu môže byť vhodnejšie.


Undo a Redo

Navigácia: Naplnenie vašej architektúry> Naplnenie ručne> ďalšie možnosti>

Undo a Redo

Odoslať pripomienky na túto tému.

Rovnako ako mnoho moderných aplikáciách, ABACUS podporuje schopnosť ako späť a opakovať posledný užívateľské zmeny do otvoreného projektu. Ak chcete vziať späť poslednú zmenu, jednoducho aktivovať príkaz Späť. Zmeny, ktoré boli vrátiť späť môže byť prepracovaný aktiváciou príkazu redo; re-použitie naposledy vrátiť späť zmeny.

Výstraha

Undone zmeny nie sú schopní byť znovu, ak sú ďalšie sú vykonané zmeny v projekte, pretože sa vrátiť späť.

Poznámka

Zatiaľ čo drvivá väčšina podporovať zmeny vrátiť späť / vpred v reálnom čase, niektorí diagram vzorkovníka zmeny, ako napríklad vytvorenie nového typu Tvar / združenia alebo zmenu o pridružení farieb atribút, nie sú schopní okamžite vrátiť späť. V týchto prípadoch, modifikovaný Diagram (označené hviezdičkou), musí byť uzatvorený, aby tieto zmeny možno vrátiť späť.

Undo a Redo veliteľských miest

Príkazy Späť a Znovu možno pristupovať z troch rôznych miestach:

· V ponuke Úpravy

· štandardný panel s nástrojmi

· klávesnicu klávesové skratky CTRL + Z(undo) a CTRL + Y(redo)

Tip

UNDO a znovu tlačidiel na paneli nástrojov Štandardné poskytnúť rozbaľovacie zoznamy zobrazujúci 10 posledných zmien, ktoré možno vrátiť späť a boli prerobené, resp. Oni sú tiež praktický spôsob, ako sa vrátiť späť / vpred viac zmien naraz.


Použitie makra

Navigácia: Simulácia vašej architektúry>

Použitie makra

Odoslať pripomienky na túto tému.

Ak urobíte úloha opakovane ABACUS, môžete automatizovať úlohu pomocou makra. V súlade s tým makro ABACUS je zaznamenané radu operácií, ktoré môžu byť prehrávané kedykoľvek.

Záznam makra

1. Vyberte Nástroje | Záznam makraalebo alternatívne stlačiť Alt + F10.

2. Začnite vykonávanie operácií, ktoré chcete nahrávať.

Výstraha

V tomto okamihu, tam sú niektoré známe problémy s makro nahrávania. Prosím, aby na tieto do úvahy pri nahrávaní makier:

· V súčasnej dobe makra len zaznamenávať vaše stlačenia klávesov Microsoft Windows, myš-pohyby a kliknutí myšou. Avšak, vzhľadom na obmedzenia s záznam makier samotné, tam sú niektoré údery, ktoré nie sú vždy zaznamenané. Medzi ne patria:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] až [F12]

· Preto sa odporúča, aby ste si overili, že klávesová skratka je zaznamenaný záznam makra pred záznamu veľkého sled udalostí, ktoré môžu závisieť na tom klávesové skratky prácu.

· V súčasnej dobe vzhľadom na obmedzenia s záznam makier, kontextové ponuky nie sú správne spracované ABACUS, keď sú otvorené žalobou zaznamenaných záznam makier. Keď otvoríte kontextovú ponuku, musíte vykonať jednu z funkcií uvedených v kontextovom menu pomocou kontextového menu, inak sa kontextové menu, môže zostať otvorená počas prehrávania, čo môže viesť k nezamýšľaným akcie alebo akcií, ktoré by mohli spôsobiť chyby pri ABACUS.

· Všimnite si, že normálne metódy zatvorenie kontextové menu (napr stlačením [Esc] na klávesnici, alebo vľavo-klikom inde na obrazovke), môže v skutočnosti nie je ukončená kontextové menu počas prehrávania makra.

Tip

V dialógoch, nie pomocou kliknutia myšou, je odporúčané použiť kláves Tab na prechádzanie dostupných ovládacích prvkov a kurzorových tlačidiel vyberte rozbaľovacej položky ponuky alebo možnosti prepínač a medzerníka select / de-Zaškrtnite boxy.

Pre zastavenie záznamu makra

1. Press Alt + F9alebo alternatívne vyberte Nástroje | Zastaviť Makro.

2. V Uložiť makro ako dialógu prejdite do umiestnenia a vyberte ABACUS makro (.abacusmac súboru) názov súboru a kliknite na tlačidlo Uložiť.

Poznámka

Použitie Nástroje| Zastaviť Makrobude obsahovať túto operáciu v zaznamenanej makro. Preto sa odporúča, aby užívatelia získanie odbornej spôsobilosti v používaní možností kláves Alt + funkcie pre prácu s makrami, aby nedošlo k nechcenej zahrnúť makro operácie v samotných makier.

Tip

Pretože makrá nie sú v súčasnej dobe upravovať je odporúčané zaznamenať zdĺhavé úlohy ako séria samostatných maker klávesmi Alt + F10 / ALT + F9 "pary".

Ak chcete prehrávať zaznamenané makro

1. Vyberte Nástroje | Prehrávanie Makroalebo alternatívne stlačiť Alt + F8.

2. V dialógovom okne Makro Otvoriť prejdite do umiestnenia a vyberte ABACUS makro (.abacusmac súboru) názov súboru a kliknite na tlačidlo Otvoriť.

Výstraha

Pri otváraní makro ABACUS, ak ste double-kliknite na súbor makro z dialógového okna prehliadania otvoriť, makro rekordér môže držať ľavé tlačidlo myši v ľavom klikli stave až do nahraného kliknite ľavým tlačidlom myši prepíše tento štát.

Poznámka

Rýchlosť prehrávania makra možno nastaviť na karte Všeobecné v časti Nástroje| Možnostibuď ako Normal (východiskové nastavenie), rýchlo alebo pomaly. Ako rýchle a pomalé rýchlosti prehrávania sa neodporúča, pretože sa budú prehrávať zaznamenané makrá pri cca 100 časoch a 1 / 100. reálnom čase, resp. Normálna rýchlosť prehrávania bude stále prehrávať makro približne o 30% rýchlejšie ako zaznamenaná rýchlosť, takže sa odporúča pri nahrávaní sa zastaví na krátku dobu po všetky dlhé úloh spracovania, aby zabezpečili, že na prehrávanie ďalšie operácie nie je vykonaný pred úlohu spracovania má dokončená.

Zastavenie prehrávania zaznamenané makro

1. Press Alt + F9.


Zobrazenie 3D diagram

Navigácia: Analýza vašej architektúry> 3D diagramy>

Zobrazenie 3D diagram

Odoslať pripomienky na túto tému.

ABACUS umožňuje zobraziť vašu architektúru ako 3D zobrazenie, kde sú komponenty a pripojenie vlastnosti spojené s farbami, tvary a veľkosti.

Ak chcete zobraziť 3D pohľad na vašej architektúre

1. Uistite sa, že máte otvorte súbor ABACUSobsahujúce Váš obývaný architektúra.

2. Rozbaľte Zobrazenievetva stromu.

3. Rozbaľte 3Dvetva stromu.

4. Dvojité kliknutie Vizualizácia chcete otvoriť.

- Alebo -

1. Uistite sa, že máte otvorte súbor ABACUSobsahujúce Váš obývaný architektúra.

2. Vybrať Insert| 3Dalebo kliknite na tlačidlo na paneli nástrojov.

3. Otvorte existujúcevizualizácia (.abacus3d)

- Alebo -

1. Uistite sa, že máte otvorte súbor ABACUSobsahujúce Váš obývaný architektúra.

2. Vybrať Insert| 3Dalebo kliknite na tlačidlo na paneli nástrojov.

3. Vytvorenie novej vizualizácie:

· Vyberte StaviteľstvoAk chcete zobraziť z rozbaľovacieho menu.

· Vyberte Komponentya PripojenieAk chcete zahrnúť do schémy z okno pre výber štandardným prvkom .

· Pridružené farby, tvary a veľkosti s Component Druhya Vlastnosti.

· Asociačná farby a tvary s Typy pripojeniaa Vlastnosti.

Ak chcete exportovať 3D pohľad

1. Uistite sa, že máte otvoriť existujúci 3D pohľad.

2. U roletových ponúk 3D pohľadu vyberieme Súbor | Exportovať ...a vybral umiestnenie a typ súboru pre súbor vizualizácie (.abacus3d, .vrml alebo .html).

3. Kliknite na tlačidlo Save.

Pozri tiež

Analýza vašej architektúry | Navigácia v 3D | Diagramov Tool


Zobrazenie bublinový graf

Navigácia: Analýza vašej architektúry> Vlastné grafy>

Zobrazenie bublinový graf

Odoslať pripomienky na túto tému.

Bublina graf vám umožňuje porovnať až 5 rozmerov (tj X, Y, veľkosť bublina / polomeru, bublina farieb a bublina hraníc farebných), v jednom pohľade.

Ak chcete zobraziť bublina graf

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Vybrať Insert| Graf| Vlastné ChartsZáložka | Bubble Graf.

3. V Architektúryoddiel, zaškrtnite architektúr (ak existuje), ktorý chcete mapovať, kliknite na tlačidlo Budúci.

4. Vyberte Komponentya Pripojeniektoré chcete v grafe (ak existuje) z okno pre výber štandardným prvkom , Potom kliknite na tlačidlo Budúci.

5. Vyberte X-osmajetok, potom kliknite na tlačidlo Budúci.

Poznámka

Len Integer, desiatkovej, dátum / čas, Boolean a vlastnosti List môže byť použitý pre os X. Okrem toho, Integer, desiatkovej a dátum / čas vlastnosti sú vynesené zľava doprava pozdĺž osi pomere k hodnote majetku, však, logické a Zoznam vlastnosti sú proste vynesené zľava doprava v presnom poradí (alebo v v obrátenom poradí, ak je zaškrtnuté možnosť obrátiť poradie) definované pre vlastnosť bez ohľadu na ich hodnôt. Napr. Nízky | Stredná | Vysoký alebo 1, 2, 4, 8, 16.

6. Vyberte Y-osimajetok, potom kliknite na tlačidlo Budúci.

Poznámka

Len Integer, desiatkovej, dátum / čas, Boolean a vlastnosti List môžu byť použité na osi Y. Okrem toho, Integer, desiatkovej a dátum / čas vlastnosti sú vynesené zdola-to-top pozdĺž osi pomere k hodnote majetku, však, logické a Zoznam vlastnosti sú proste vynesené zdola-to-top v presnom poradí (alebo v v obrátenom poradí, ak je zaškrtnuté možnosť obrátiť poradie) definované pre vlastnosť bez ohľadu na ich hodnôt. Napr. Nízky | Stredná | Vysoký alebo 1, 2, 4, 8, 16.

7. Vyberte Veľkosť bubliny / radiusmajetok, potom kliknite na tlačidlo Budúci.

Poznámka

Len Integer, desiatkovej, Boolean a vlastnosti List môžu byť použité pre bubliny veľkosť / polomeru. Okrem toho, Integer a desatinná vlastnosti vedú k veľkosti bubble / polomeru pomere k hodnote majetku, však, logické a Zoznam vlastnosti vedú v rovnakom kroku zvyšovaní bubliny veľkosť / polomeru v presnom poradí (alebo v opačnom poradí, ak možnosť obrátiť poradie je zaškrtnuté) definované pre vlastnosť bez ohľadu na ich hodnôt. Napr. Nízky | Stredná | Vysoký alebo 1, 2, 4, 8, 16.

8. Vyberte buď pevná bublina farbaalebo spájať nehnuteľnosť s bublinovou farbou, Potom kliknite na tlačidlo Budúci.

Poznámka

Len Integer, desiatkovej, Boolean a vlastnosti List môžu byť použité pre bubliny farbu. Okrem toho, Integer a desatinná vlastnosti vedú v bubline farieb v rámci zvoleného rozsahu pomere k hodnote majetku, však, logické a Zoznam vlastnosti vedú v rovnakom kroku zvyšovaní bubliny farby v rámci zvoleného rozsahu v presnom poradí určenom pre vlastnosť, bez ohľadu na ich hodnôt. Napr. Nízky | Stredná | Vysoký alebo 1, 2, 4, 8, 16.

9. Vyberte buď žiadna bublina hranice farbaalebo pridružiť nehnuteľnosť s bublina hraníc farbou, Potom kliknite na tlačidlo Skončiť.

Poznámka

Len Integer, desiatkovej, Boolean a vlastnosti List môže byť použitý pre bubble hraničné farbu. Okrem toho, Integer a desatinná vlastnosti vyústiť v bublinkovej farbu orámovania v rámci zvoleného rozsahu pomere k hodnote majetku, však, logické a Zoznam vlastnosti vedú v rovnakom kroku zvyšovaní bublina farbu ohraničenia v rámci zvoleného rozsahu v presnom poradí definovaných pre vlastnosť bez ohľadu na ich hodnôt. Napr. Nízky | Stredná | Vysoký alebo 1, 2, 4, 8, 16.

Bubble graf

Ak chcete uložiť bublina graf

Poznámka

Bubble grafy možno uložiť len vtedy, ak obsahujú len komponenty a prípojky, z ktorých všetky musia byť z jednej architektúry v rámci aktuálneho projektu.

1. Uistite sa, že máte novú alebo existujúce bublina graf otvorenýa vy ste vykonali potrebné zmeny.

2. Na paneli s nástrojmi grafu kliknite na úplne vľavo Save ChartTlačidlo pre uloženie graf a všetky zmeny formátovania.

3. V Graf Názovdialógové okno, ktoré sa objavia zadajte názov bublina graf a stlačte OK.

Ak chcete exportovať bublina graf

1. Uistite sa, že máte otvoriť existujúci bubliny graf.

2. V paneli nástrojov graf kliknite na 2. zľava Uložiť ako BMPTlačidlo a vybral miesto pre graf.

3. Kliknite na tlačidlo Save.

Pozri tiež

Analýza vašej architektúry


Zobrazenie schopnosť priestor graf

Navigácia: Analýza vašej architektúry> Vlastné grafy>

Zobrazenie schopnosť priestor graf

Odoslať pripomienky na túto tému.

Schopnosťou Space graf umožňuje zobraziť, či váš architektúra spĺňa požadované schopnosti systému s ohľadom na vlastnosti zistené počas procesu analýzy požiadaviek systému.

Ak chcete zobraziť schopností priestor graf

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra, A že máte hodnotenéVaše architektúra.

2. Vybrať Insert| Graf| Vlastné Charts| Schopnosť Space, (THE Schopnosť Space Graf Configdialóg sa zobrazí.)

3. V Architektúryoddiel, zaškrtnite architektúry, ktoré chcete grafu, potom kliknite na tlačidlo Budúci.

4. V VlastnostiOblasť, zaškrtnite architektonické vlastnosti by ste radi zahrnuté ako osi grafu.

5. V Schopnosťpriestor pre každú majetku zahrnutého z predchádzajúceho kroku, vyberte, či niektorý minimálne alebo maximálne limity schopností existujú a hodnoty týchto limitov. Predvolené hodnoty sú minimálne a maximálne hodnoty vyhodnotené za architektúr, alebo Cieľom pre vlastnosť v prípade, že bol nastavený.

Ak chcete exportovať schopností priestor graf

1. Uistite sa, že máte existujúce Schopnosť priestor grafotvorené.

2. Na paneli s nástrojmi grafu kliknite na úplne vľavo Uložiť ako BMPTlačidlo a vybral miesto pre graf.

3. Kliknite na tlačidlo Save.

Pozri tiež

Analýza vašej architektúry | Zobrazenie doba odozvy graf


Štandardné Správy

Navigácia: Podávanie správ o vašu architektúru>

Štandardné Správy

Odoslať pripomienky na túto tému.

ABACUS " štandard Správy vám umožní získať zoznam prvkov a spojov v jednej alebo viacerých z vašich architektúr. Táto správa obsahuje všetky informácie týkajúce sa súčasťou a spojov, vrátane vybraných informácií o komponente alebo miesta pripojenia v hierarchii typu, štandardy, opis, vlastnosti a ich príloh.

Poznámka

Obsah Správa jekonfigurovateľnýNižšie prostredníctvom dialógovom okne Možnosti správa popísaná, však, to zistiť viac informácií o tom, ako vytvoriť plne konfigurovateľný zákazku Správypoužitie ABACUS vlastné zostavy, Prosím odkazujú na tému tu alebo kontakt Podpora Avolution .

Ak chcete zobraziť štandard správa

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra(s).

2. Vybrať Insert| Štandardná správaalebo kliknite na Vytvoriť štandardné správu tlačidlo na paneli nástrojov. Report Configurationsa zobrazí okno.

Okno Configuration Report

3. Vyberte Architektúry, Komponentya Pripojenieže chcete v správe podaná Okno Configuration Report.Pozrite sa prosím na výber štandardnou súčasťou tu téma pre pomoc.

4. Teraz kliknite na tlačidlo MožnostiTlačidlo a Možnosti správaZobrazí sa okno.

Okno Možnosti Report

5. Môžete si vybrať, na zobrazenie Nová stránka pre každého prvkuSa Dátum vytlačenie, Print Time, Čísla stránoka či obsahovať názov v záhlavísprávy zaškrtnutím / unticking príslušné zaškrtávacie políčka. Môžete tiež prispôsobiť titul a autora editáciou Report Názova Autor textových polí. Môžete si tiež vybrať, aký obsah sa zobrazí na správe zaškrtnutím / unticking zaškrtávacích políčok pod Správa Obsahčasť okna. Po dokončení kliknite na OK.

6. Teraz kliknite na SkončiťV okne Configuration Report.

Vykladať zobraziteľné správu

Príklad generované správy sa krátko vysvetlené

Ak chcete prehľadávať stránok správy, kliknite na ikony [image] umiestnené na paneli nástrojov v ľavom hornom rohu obrazovky.

Poznámka

Môžeš ušetriť správa do rôznych formátov kliknutím na tlačidlo Export Ikona správa [image] Nachádza v panel nástrojov. Môžete si vybrať, pre export do týchto formátov: Vynikať, PDFa Slovo, Prosím, uložte zostavu v požadovanom mieste pre neskoršie použitie. Ak sú vykonané zmeny v architektúre v neskoršej fáze, bude nová správa musí byť vytvorené tak, aby odrážali zmeny.

Pozri tiež

Analýza vašej architektúry


Zobrazenie doba odozvy graf

Navigácia: Analýza vašej architektúry> Vlastné grafy>

Zobrazenie doba odozvy graf

Odoslať pripomienky na túto tému.

Dobou odozvy graf umožňuje zobraziť, či vaše pripojenie sú spracovávané na požadovanej rýchlosti (tj v rámci svojej lehote).

Ak chcete zobraziť dobu odozvy graf

1. Skontrolujte, či máte ABACUS otvoriť súbor obsahujúce Váš obývaný architektúra, A že máte hodnotenéVaše architektúra.

2. Vybrať Insert| Graf| Vlastné Charts| Doba odozvy, (THE Doba odozvy Graf Configdialóg sa zobrazí.)

3. Z Architektúryrozbaľovacom zozname vyberte architektúru, ktorú chcete do grafu.

4. V Pripojenieoblasti, zaškrtnite prepojenia, by radi zahrnuté v tabuľke.

5. Scale Typeoblasť, vyberte Priamočiaryak chcete, aby zvislej osi (doba odozvy), ktorý má byť zobrazený ako lineárny priebeh - každý segment času je pridelený rovnaký podiel osi. Vybrať Logaritmickejak chcete zobraziť ako logaritmickej progresia - každý segment osi predstavuje stále dlhšiu dobu čím vyššia hore osi idete. (Rýchlosť nárastu určí podľa Základnési vyberiete.)

Doba odozvy graf zvislé mierka os

Ak chcete exportovať dobou odozvy graf

1. Uistite sa, že máte existujúce doba odozvy grafotvorené.

2. Na paneli s nástrojmi grafu kliknite na úplne vľavo Uložiť ako BMPTlačidlo a vybral miesto pre graf.

3. Kliknite na tlačidlo Save.

Pozri tiež

Analýza vašej architektúry | Zobrazenie schopnosť priestor graf


Zobrazenie bodový graf vašich vyvinutých architektúr

Navigácia: Analýza vašej architektúry> Vlastné grafy>

Zobrazenie bodový graf vašich vyvinutých architektúr

Odoslať pripomienky na túto tému.

Akonáhle je architektúra bola vyvinula a ciele sú definované, potom možno vizualizovať a v porovnaní s pôvodnou architektúrou pomocou Scatterplot matíc. Táto časť opisuje, ako vytvoriť a pochopiť charakteristiky Scatterplot matice.

Ak chcete zobraziť Scatterplot Matrix vašich vyvinutých architektúr

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Uistite sa, že máte vyvinulia stanovených cieľovpre vašu architektúru, ako je uvedené v Vyvíjajúce vašej architektúry

3. Vybrať Insert| Graf| Vlastné ChartsZáložka | Scatterplot Matrix.

4. Kliknite na SkončiťTlačidlo.

5. Bodový diagrams definovanou vývojom architektúr a cieľov sa zobrazí.

Poznámka

Oblasť na ľavej strane Scatterplot matrice ukazuje nastavenie Scatterplot matice zobrazenej. To zahŕňa architektúru, ktorá bola sa vyvinul (v tomto prípade "ABC Ltd As-Is 2010"), Rovnako ako ciele, ktoré boli stanovené pre túto architektúru. Budete na vedomie, že ciele, ktoré majú podtržníkom vedľa nich sú reprezentované ako X a Y osi Scatterplot matrice (napr KPI- Náklady, KPI - kvalita a KPI - Time). Môžete zrušte zaškrtnutie týchto cieľov na každom okamihu na ich odstránenie z Scatterplot matrice.

Modré bodky, ktoré sa objavia na vašom pozemku v matrici predstavujú normalizovanú hodnotu, ako je stanovené v najlepšie a najhoršie hodnota (uvedených pod Stanovenie cieľov pre váš vyvinul architektúru ). Tieto hodnoty sú zastúpené v Kvalita Space.

Dva stanovené ciele sú porovnávané proti sebe v Scatterplot matrici a celý proces sa opakuje, až sa v porovnaní všetky ciele (napr sa prvý typ matrice vo vyššie uvedenej schéme porovnáva KPI - NákladyCieľom s KPI - Kvalita cieľ. Druhým je Náklady proti Doba a posledná zápletka je Kvalitná proti Doba, Príslušné Bránkové štítky sú zobrazené v hornej a pravej alebo každý riadok pozemkov.).

6. Vyberte Architektúryprepínač, ak chcete zobraziť metriky pre jednotlivé architektúry.

7. Vyberte Evolutionsprepínač, ak chcete zobraziť normalizovaných zmeny z pôvodnej architektúry (napr As-Is 2.010) Na vyvinutú architektúry (y) (napr. To-Be 2011 - Stratégia A a K-Be 2011 - Stratégia B).

Pozri tiež

Analýza vašej architektúry | Zobrazenie doba odozvy graf | Zobrazenie hviezda sprisahania svojich vyvinutých architektúr | Vyvíjajúce vašej architektúry


Zobrazenie štandardné graf

Navigácia: Analýza vašej architektúry> Štandardné grafy>

Zobrazenie štandardné graf

Odoslať pripomienky na túto tému.

Štandardné grafy Abacus 'patrí linka, bar, stĺpec, oblasť, rozptyl, koláč, krivka, Pareto, krok, povrch, radar, kocky, šišky, pyramídy, kontúry a krivka plochy grafov. Akonáhle ste si vybrali typ grafu, ktorý chcete, zvyšok procesu pre prezeranie každý z týchto grafov je rovnaký.

Ak chcete zobraziť štandardné graf vašej architektúre

1. Uistite sa, že máte otvorte súbor ABACUSobsahujúce Váš obývaný architektúra, A že máte hodnotenéVaše architektúra.

2. Vybrať Insert| Grafalebo kliknite na tlačidlo na paneli nástrojov. Grafysa zobrazí okno.

Okno Grafy

3. Vyberte typ grafu, ktorý chcete a nastaviť Možnosti grafu, potom kliknite na tlačidlo Budúci.

Možnosti Graf

o Skladanýukáže vzťah jednotlivých položiek k celku. Môžete použiť skladaný graf, keď máte v pláne na viacerých dátových radov (tj viac vlastností) a ak chcete zdôrazniť celkom.

o Skladaný 100%porovná percento je každá hodnota prispieva k celkovo cez kategórií. Môžete použiť 100% skladaný graf si, keď máte v pláne na viacerých dátových radov (tj viac vlastností) a ak chcete zdôrazniť príspevky do celku, a to najmä v prípade, že celková je rovnaká pre každý prvok.

o 3D grafjednoducho zobraziť dátových bodov vo formáte 3-D pre estetiku. Ak chcete zobraziť dátové rady pozdĺž rozmeru 3rd / os Z a potom použite voľbu Series klastra popísané nižšie.

o Rad majetkomzobrazí rady údajov pre každú vlastnosť, ktorá je nakoniec vybraný. Ak je to Nekontrolovaná potom vlastnosti budú kategórie a rady údajov bude pre každý prvok, ktorý je vybraný.

o Otočiť Chartbude otáčať grafom o 90 stupňov doprava zámenou osí x a y. Táto možnosť je k dispozícii len pre Lines, STEP a Cube grafya je zvlášť vhodný pre výrobu Milestone grafy, ako je popísané v druhom hrotu nižšie, Poznámka: Stĺpec a stĺpcové grafy už 'otáča' verzie navzájom.

o Rad Clusterzobrazí viac dátových radov pozdĺž rozmeru 3rd / os Z. Táto možnosť je k dispozícii len pre stĺpce, bar a Cube grafya je zvlášť vhodný pre výrobu Ganttove štýlu grafy, ako je popísané v prvej Tip nižšie.

Tip

Môžete si vytvoriť Ganttov diagrams vodorovnými pruhmi zobrazujúci čas / dátum vlastnosti rôznych prvkov výberom typu stĺpcový graf a potom vybraním voľby Series Cluster,Okrem toho, akonáhle vytvoril, najviac vľavo bar na grafe môže byť "neviditeľný" sfarbením ju bielou pravým kliknutím na jednu z tyčí, výber farba z ponuky, ktorá sa objaví, a výberom ľavý horný farbu z palety. Navyše hranica pre najviac vľavo bare si môžete byť "neviditeľný" kliknutím pravým tlačidlom myši na jednu z tyčí, výberom vlastnosti ... a na karte radu v dialógovom okne, ktoré sa objavia meniace pohraničnej efektu na Žiadny a Farba na začiatok -left farbu z palety.

Tip

Môžete si vytvoriť Milestone grafs malými tvarmi ukazujúce čas / dátum vlastnosti rôznych prvkov výberom typu grafu Cube a výberom Otočiť Chart a možnosti radu Cluster,Okrem toho, akonáhle vytvoril, kocky možno zmeniť na iných tvarov kliknutím pravým tlačidlom myši na jednu z kociek v danej dátové rady a výberom vlastnosti ... a na karte radu v dialógovom okne, ktoré sa objavia Zmena Bar buď valca alebo kužeľa , Poznámka: Šírka hodnota Gap môže byť tiež použitý na "zmršťovacie" symbolov na grafe znížiť prekrývanie, čím vyššie je číslo, tým menšie prekrývajúce sa bude.

4. V Architektúryoddiel, zaškrtnite architektúra / s, ktorú chcete zmapovať vlastnosti na úrovni architektúry pre, potom kliknite na tlačidlo Budúci.

Poznámka

Voľba vlastností úrovni architektúry je úplne voliteľný krok a mali by sa používať iba v prípade, že chcete explicitne zmapovať sám úrovni architektúry.Architektúra, nemusí byť zvolené tak, aby potom uvádzať komponentov alebo pripojenie vlastnosti v ďalšom kroku.

5. Vyberte Komponentya Pripojeniektoré chcete v grafe, ktorý podal okno pre výber štandardným prvkom , Potom kliknite na tlačidlo Budúci.

6. Vyberte VlastnostiChcete v tabuľke a kliknite na tlačidlo Skončiť.

Možnosti Graf

o Zahrnúť štandardné vlastnostivôľa ukazujú dedené vlastnosti od noriem sú k dispozícii pre výber.

o Súhrnné Propertiesvôľa počítať rozptyl medzi hodnotami radu a zmapovať tieto výsledky na rozdiel od jednotlivých hodnôt sami.Táto voľba je dostupná iba v prípade, bola vybraná rad možností vlastníctva od v kroku 3 vyššie.

Tip

Vlastnosti k dispozícii pre zmapovanie závisí na prvky, ktoré vyberiete.

Ak chcete uložiť graf

Poznámka

Grafy možno uložiť len vtedy, ak obsahujú len komponenty a prípojky, z ktorých všetky musia byť z jednej architektúry v rámci aktuálneho projektu.

1. Uistite sa, že máte novú alebo existujúce graf otvorenýa vy ste vykonali potrebné zmeny.

2. Na paneli s nástrojmi grafu kliknite na úplne vľavo Save ChartTlačidlo pre uloženie graf a všetky zmeny formátovania.

3. V Graf Názovdialógové okno, ktoré sa objavia zadajte názov pre graf a stlačte OK.

Ak chcete exportovať graf

1. Uistite sa, že máte existujúce grafotvorené.

2. V paneli nástrojov graf kliknite na 2. zľava Uložiť ako BMPTlačidlo a vybral miesto pre graf.

3. Kliknite na tlačidlo Save.

Pozri tiež

Analýza vašej architektúry | Zobrazenie doba odozvy graf | Zobrazenie schopnosť priestor graf


Zobrazenie hviezda sprisahania svojich vyvinutých architektúr

Navigácia: Analýza vašej architektúry> Vlastné grafy>

Zobrazenie hviezda sprisahania svojich vyvinutých architektúr

Odoslať pripomienky na túto tému.

Akonáhle je architektúra bola vyvinula a ciele sú definované, potom možno vizualizovať a v porovnaní s pôvodnou architektúry použitie hviezdicových grafmi. Táto časť opisuje, ako vytvoriť a manipulovať s hviezda sprisahania.

Ak chcete zobraziť hviezdy sprisahania svojich vyvinutých architektúr

1. Skontrolujte, či máte ABACUS otvoriť súbor .

2. Uistite sa, že máte vyvinulia stanovených cieľovpre vašu architektúru, ako je uvedené v Vyvíjajúce vašej architektúry

3. Vybrať Insert| Graf| Vlastné ChartsZáložka | Hviezda Plot.

4. Kliknite na SkončiťTlačidlo.

5. Hviezda Plots vyvinutými architektúry a nastavenie sa zobrazí ciele. Poznámka: Osi hviezdy pozemku môže premiestniť kliknutím a ťahaním osí do inej oblasti v medziach hviezdne kvality plot priestoru.

Poznámka

Oblasť na ľavej strane hviezdy pozemku ukazuje nastavenie hviezdy pozemku zobrazenej. To zahŕňa architektúru, ktorá bola sa vyvinul (v tomto prípade "ABC Ltd As-Is 2010"), Rovnako ako ciele, ktoré boli stanovené pre túto architektúru. Budete na vedomie, že ciele, ktoré majú podtržníkom vedľa nich sú reprezentované ako osy hviezdy pozemku (napr KPI- Náklady, KPI - kvalita a KPI - Time). Môžete zrušte zaškrtnutie týchto cieľov na každom okamihu na ich odstránenie z hviezdneho pozemku.

Červená a zelená "bodky", ktoré sa objavia na vašom hviezdy pozemku predstavujú normalizovanú hodnotu, ako je stanovené v najlepšie a najhoršie hodnota (uvedených pod Stanovenie cieľov pre váš vyvinul architektúru ) Pre zvolenú architektúru najvyššej úrovni a na všetkých vývojom toho. Tieto hodnoty sú zastúpené v Kvalita Space.

Ako je uvedené na obrázku vyššie, je jasne vidieť, že pôvodnej architektúry (As-Is 2.010) Má zlú Náklady, Kým prvý vyvinul možnosť (To-Be 2011 - stratégiu pre) Sa presťahovala do kvality priestor pre zlepšenie Náklady, Kvalita a Timecieľov. Alternatívne, druhá možnosť sa vyvinul (To-Be 2011 - Stratégia B), zatiaľ čo to tiež zlepšila Náklady veľkosť zlepšenie je menšia ako u Stratégia A ale oba ciele kvalite a termíne boli zlepšené viac než u stratégie A.V tomto prípade architekt smieť vybrať Stratégiu precez Stratégia Bako ich odporúčaniaa ďalej rozvíjať túto možnosť (To-Be 2012 - Stratégia A).

6. Zrušte Zobraziť Evolutionspolíčko skryť riadok (y), čo predstavuje vývoj (y) medzi pôvodnou (napr As-Is 2.010) A vyvinuli (napr. To-Be 2011 - StratégiaA) architektúra (y).

7. Vyberte Zobraziť Stickspolíčko pre zobrazenie relatívnu veľkosť každého atribútu kvality (ciele, ktoré boli definované na každej osiach) pre každú architektúru.

8. Vyberte Zobraziť Architektúra menáZaškrtnite políčko, ak chcete mená pôvodného a vyvinula sa architektúry (y) sa objaví na hviezdy pozemku.

Pozri tiež

Analýza vašej architektúry | Zobrazenie doba odozvy graf | Zobrazenie Scatterplot maticu vašich vyvinutých architektúr | Vyvíjajúce vašej architektúry


Analýza vašej architektúry

Navigácia: Analýza vašej architektúry>

Analýza vašej architektúry

Odoslať pripomienky na túto tému.

Potom, čo ste obývaný (a voliteľne simulované) vašej architektúry, ste pripravení na použitie Abacus analyzovať. Tým, že analyzuje, môžete zistiť, či váš architektúra bude vyhovovať vašim potrebám.

Možno analyzovať architektúry v mnohých rôznymi spôsobmi:

· Diagram

· 3D pohľad

· štandardné grafy (koláč, riadok, stĺpec, bar, atď.)

· vlastné grafy ( Doba odozvy , Schopnosť priestor , hviezda plot , Scatterplot matice a bublina graf )

· Staviteľstvo Diff

Poznámka

Pri vytváraní diagramu, 3D pohľad, Správa alebo štandardné grafu, okno pre výber štandardným prvkom slúži na výber prvkov, ktoré chcete zobraziť.

Pozri tiež

Naplnenie vašej architektúry | Simulácie vašej architektúry | Diagramov Nástroj


Čo je to architektúra?

Navigácia: Úvod do ABACUS>

Čo je to architektúra?

Odoslať pripomienky na túto tému.

Architektúra je abstraktné pojem- Nie je fyzickou vec, Je to bohatý a úplný opis alebo pochopenie štruktúry systému - zachytenie komponenty a ako sú spojené (interakciu). Vzhľadom k tomu, pojem architektúra je tak všeobjímajúci, to je zásadné pre náklady, dostupnosť, Evolvability, otvorenosti a výkonu systému. Zvuk architektúra je predpokladom zvukového systému.

V ABACUS, modelovať svoju architektúru. Pre jednoduchosť nazývame tento architektonický model architektúra.

Obrázok nižšie ukazuje typickú architektúru 5komponenty (v hierarchii) prepojené 2 pripojenia. Etikety uviesť mená uvedené rôzne časti architektúry v ABACUS.

Jednoduchý architektúra

ABACUS domnieva sa, všetky tieto veci byť súčasťou architektúry:

· Komponentypredstavujú entity vašej architektúre ktoré by ste mohli opísať ako "veci". Pre poisťovne, súčasti by mohli byť systémy pre spracovanie politík, nároky, platby a príjmy.

· Pripojeniepredstavujú vzťahy medzi týmito komponentmi. Napríklad, v poisťovni, príjmy sú generované pre platné politiky, tvrdenie, proti platné politiky, a platné požiadavky vyústi v platbách. Pri premýšľaní architektonicky - obzvlášť pri použití Abacus - spoje sú rovnako dôležité ako zložkami, a oni sú riešené v takmer rovnakým spôsobom.

· Všetko vo stromu môže mať Vlastnosti, Vlastnosti sú veci ako, ako budete potrebovať váš systém plniť, počet riadkov kódu to má, percento týchto liniek, ktoré sú poznámky, atď ABACUS sa domnieva, všetky tieto veci byť súčasťou architektúry.

· Používaním hierarchie(tj. čiastkové komponenty a sub-spoje), Môžete skryť informácie a de-vytvorte architektúru. Počítadlo architektonický model je veľmi flexibilný. Každá zložka na akejkoľvek úrovni môže byť v spojení s akýmkoľvek iným komponente v akejkoľvek inej úrovni akékoľvek spojenie na akejkoľvek úrovni.

· Prílohaje operácia, pri ktorej sa súčasti porty sú viazané na pripojenierole. Porty a Role sú rozhraniasmedzi súčasťami a prípojok. Používajú sa na upevnenie spojenie do zložiek. Pripojenie mať zdroj a umývadlo role(uľahčiť tok dát zo zdrojovej komponenty ku komponentu drezu)a koncepčne, komponenty majú porty. Pre jednoduchosť, však, v ABACUS komponentov porty nie sú zobrazené a spojenia role sú priamo pripojené na samotných komponentov.

· Komponenty a konektory sú určité Druh, To je hlavne pre účely klasifikácie. Napríklad politík, pohľadávky, platby, a príjmy sú súčasťou typu "systém". Platné politiky, platné nároky, atď., Sú spoje typu "transakcie". Type pridelený na súčasti alebo pripojenie poskytuje šablónu pre vlastností a normy to má. Napríklad typ súčasť servera môže mať "značky a modelu" štandarda IP adresy vlastnosť. Na rozdiel od iných pevných nástrojov, sa základné relačnú databázu údajov (RDB) back-end, v ABACUS môžete voľne vytvárať svoje vlastné nové typy a priradiť vlastné kombinácie vlastností a štandardov k nim.

· Štandardné knižnice nehnuteľností môžu byť špecifikované a priradené k niečomu inému v architektúre. Tieto knižnice sú známe ako Normy, Používaním Normy, Len je potrebné zhromaždiť špecifické systémy vlastnosti - štandardné vlastnosti sú už tam. Napríklad štandardný výkonové charakteristiky systému Microsoft Windows 2000 môžu byť priradené na čokoľvek komponenty používajú operačný systém Microsoft Windows 2000.

Pozri tiež

Ako sa architektúra zastúpená v ABACUS? | Čo ABACUS robiť? | Ako to robíte (prehľad) | Vytvorenie nového typu


Práca s Enterprise Server

Navigácia: Správa>

Práca s Enterprise Server

Odoslať pripomienky na túto tému.

ABACUS Enterprise Server je ako "non-blokovací" spoločný prístup, ale o "odpojená" raz tiež. ABACUS je "non-zamykanie" preto, že nie je vynútiť súbor zamknúť jedným užívateľom pre to, aby bol aktualizovaný. Každý užívateľ má svoju vlastnú lokálnu kópiu súboru, a keď oni robia zmeny a zachrániť ich súbor, tieto zmeny sú zaznamenané a uložené, keď si užívateľ želá, aby ich zaviazať sa k serveru.

ABACUS je "odpojená" v tom zmysle, že nemusíte byť pripojení k serveru, potrebujete prístup k sieti a zároveň pracovať na súbore. ABACUS vyžaduje iba prístup k serveru pri vykonávaní operácie, ako je vytvorenie súboru, alebo prevedenie Checkout, spolu s operáciami na existujúci súbor - aktualizácie, spáchať, alebo zobrazenie protokolu o minulosti dopustí. Prístup k serveru nie je nutné pracovať na súbor a vaše zmeny nie sú okamžite odoslaná na server (to vám umožní ľahko zrušiť zmeny, ak urobíte chybu). Pri uložení súboru, ste "len" šetrí vaše kópie lokálne - to nie je až sa zaviazať, že vaše lokálne zmeny (zmeny vykonané od posledného potvrdenie), sú odosielané na server.

Vytvorenie nového súboru Enterprise

Ak chcete vytvoriť nový Enterprise súbor, vyberte Súbor| Nový ...a potom vyberte jednu z prvých dvoch možností v časti Enterprise Model Nový dialóg Project (tj buď prázdny Enterprise súbor, alebo vytvoriť jednu z existujúceho ABACUS súboru). Treťou možnosťou je "K pokladni" Enterprise súbor niekto iný už vytvoril, bude to zahrnuté v ďalšej časti.

Ak sa rozhodnete vytvoriť nový súbor Enterprise, budete mať dialógové okno, ktoré vám umožní prechádzať na miesto, kde na serveri úložisko chcete uložiť súbor. To bude mať tiež existujúcu cestu k súboru a názov vstúpila do vrcholu, ak ste zvolili "Od Existujúci model" v dialógovom okne Nový projekt a dodala súbor.

URL: Toto je URL k vášmu serveru úložisko, kde sú uložené súbory ABACUS Enterprise. Mali by ste sa opýtať na osobu, ktorá spravuje server, čo by malo byť toto URL.

Obrázok hore ukazuje úložisko s štyri (4) existujúcich projektov ABACUS podniku, po zadaní adresy URL a stlačením tlačidla Enter.Vy uvidíte po vytvorení nového Enterprise súbor, na ďalšom snímke pre "K pokladni", bude ďalší zložiek a súborov v rámci tohto úložiska.

Poznámka

Ak používate HTTPS (SSL) servera, a server nemá platný certifikát SSL (spoločné pre intranetové či neverejných serverov kvôli Náklady na certifikáte SSLs), Tam bude ďalší krok, aby sa. Tie budú musieť trvale prijať všetky pripojenia k tomuto serveru v dialógovom okne, ktoré sa objavia (bude to tiež ukázať trochu viac informácií na serveri). Ak chcete urobiť, zadajte "p" (bez úvodzoviek) a stlačte Enter. ABACUS sa pop-up správu pripomínať to pred zobrazením dialógového okna.

Poznámka

Môžete byť vyzvaní na prihlásenie k serveru, v tomto prípade je osoba, ktorá je Riadiaci servermôže poskytnúť užívateľské meno servera a hesla. Tiež prihlasovacie údaje pre všetky servery, ktoré ste pripojili k sú uložené, takže ak z nejakého dôvodu ich treba vymazať to možno vykonať prostredníctvom Nástroje | Možnostia potom na Všeobecné Karta kliknutím Obnoviť Subversion uložené Prihláseniea výberom servera z rozbaľovacieho zoznamu a kliknutím na tlačidlo Clear Prihláseniea výberom OK v dialógovom okne, ktoré sa objavia.

Poznámka

Na rozdiel od snímky je uvedené vyššie, typicky jeden ABACUS projektu je obsiahnutý v každom ABACUS úložisku, pretože ak je vytvorená viac ako 1 ABACUS projekt v jedinom ABACUS úložiska, čísla zmena protokolu Abacus sú zdieľané všetkými Abakus projektov, a to môže zmiasť používateľov.

Preferovaný Názov súboru: To ovplyvní zložku a názov súboru, ktorý bude použitý (ak už nie je zaujatý), pri vytváraní súboru na serveri úložiska. Všimnite si, že je vytvorená nová zložka automaticky na serveri úložisko pre každý súbor (z výkonnostných dôvodov, ABACUS Enterprise súbory sú vytvorené v ich vlastnej zložky na základe umiestnenia prezerali v dialógu).

Uchovávajte pracovnú kópiu v adresári: Keď je vytvorený súbor Enterprise na serveri úložiska, je potrebné vytvoriť na počítači miestne pracovné súbory, takže môžete pracovať na súbore, bez toho, aby bol pripojený k sieti. To je miesto, ktoré budete prechádzať, keď chcete otvoriť / re-otvoriť súbor ABACUS Enterprise.

Pokladňa existujúceho Enterprise súboru

Ak už niekto vytvoril nový Enterprise súbor, môžete "pokladňa" tento súbor, ktorý sťahuje lokálnu kópiu a nastaví potrebné súbory, takže ABACUS rozpozná toto ako súbor Enterprise vám. Dialóg je podobný New Enterprise File dialóg. Zadajte adresu URL úložiska (podadresáre môžu byť zahrnuté do adresy URL), požadovaný súbor a kliknite na tlačidlo OK. S výhradou poznámky pod tže súbor bude otvorený.

Poznámka

Môžete byť vyzvaní na prihlásenie k serveru, v tomto prípade je osoba, ktorá je Riadiaci servermôže poskytnúť užívateľské meno servera a hesla. Tiež prihlasovacie údaje pre všetky servery, ktoré ste pripojili k sú uložené, takže ak z nejakého dôvodu ich treba vymazať to možno vykonať prostredníctvom Nástroje | Možnostia potom na Všeobecné Karta kliknutím Obnoviť Subversion uložené Prihláseniea výberom servera z rozbaľovacieho zoznamu a kliknutím na tlačidlo Clear Prihláseniea výberom OK v dialógovom okne, ktoré sa objavia.

Enterprise súborov Rozdiely

Ak ste vytvorili súbor Enterprise (buď nová, alebo prostredníctvom "pokladnice" zo súboru vytvoreného niekým iným), zložka bude vytvorená pre súbor, a to bude bežne obsahovať tieto 3 hlavné typy súborov:

· File '.abacus "- Ide o súbor ABACUS sám. Zmeny stránky ako lokálne nie sú okamžite ukladané do tohto súboru je napísané len, keď ste spáchať. Tento súbor je "normálne" ABACUS súbor, to môže byť daná užívateľom non-EEako projekt samostatný (bez súboru s príponou LOG), Alebo použité ako východiskový bod pre nový EE súboru.

· File '.changes "- Miestny (nepotvrdené) zmeny vykonané v súbore. Ak tento súbor chýba, to znamená, že neexistujú žiadne lokálne zmeny.

· '.log' Súbor- Tento súbor má iba zmeny, ktoré boli vykonané od posledného užívateľa (obsah .changes užívateľského súboru, keď oni spáchali).

Poznámka

Existujú rôzne ďalšie súbory, ktoré môžu byť vytvorené v priebehu aktualizácie a zaviazať procesov, a to; ‘.changesbefore"File- Tento súbor je kópia súboru .changes po aktualizácia bola vykonaná a slúži k automatickému zmieriť ID konflikty medzi aktualizácie a akýkoľvek miestny (nezáväzné) zmien pred zaviazať; ‘.backup"File- Tento súbor je kópia súboru .changes skôr, ako užívateľ ušetrí viac miestne (nepotvrdené) zmeny v súbore .changes; a ‘.error"File- Tento súbor je kópia .changes súboru, ak tam bol nejaký problém, ktorý spôsobil Abacus zlyhanie otvorte súbor .abacus a užívateľ sa rozhodol vrátiť ich zmeny.Tieto súbory môžu byť ignorované.

Otvorenie súboru

Ak chcete otvoriť súbor, stačí prechádzať na miesto, kde ste sa rozhodli pre uloženie pracovnú kópiu, a otvorte súbor ABACUS, ktorý je tu uložený. Keď ABACUS vidí, že je .log súbor (a možno aj .Zmeny súboru, ak ste vykonali zmeny), to bude považovať súbor ako súbor Enterprise.

Aktualizácie súboru

Prevedenien 'Aktualizovať' skontroluje, či novšie verzie súboru je umiestnený na serveri. Ak áno, bude to zatvorte aktuálny súbor, aktualizujte na novšiu súbor zo servera, a stiahnuť niektoré dočasné súbory, ktoré majú číslo ako rozšírenie - napr 'Demo.125'. Tieto súbory sú staršie verzie súboru s príponou LOG, a slúži na určenie, aké zmeny boli vykonané do súboru od posledného aktualizovaný. To je nutné odhaľovať prípadné konflikty, ku ktorým došlo, takže ich môžete vyriešiť.

Ak Počas procesu aktualizácie akýkoľvek konflikty boli nájdené, Budete musieť vyriešiť skôr, než budete môcť otvoriť súbor znova (môžete zrušiť ale budete vyzvaní k vyriešiť konflikty znovupri ďalšom otvorení súboru).

Uloženie súboru

Pri uložení súboru, to pripojí všetky zmeny, ktoré ste vykonali v súbore .changes. To nie jeupraviť súbor .abacus v tejto fáze - iba vtedy, keď je súbor zaviazala k serveru, bude napísaný cez (alebo keď dostanete aktualizácie zo servera).

Kde je 'Uložiť ako'?

Neexistuje žiadny koncept Uložiť ako pre podnikové súbory. Napriek tomu však môžete skopírovať pracovnú kópiu .abacus súboru, pričom má na pamäti, že je zvyknutý mať svoje lokálne zmeny v ňom.

Riešenie konfliktov

Ak ostatní užívatelia sa dopustili zmeny v súbore v podobnej časti súboru pre vás, môže tam byť nejaké konflikty medzi ich zmien a Vy. Napríklad iný užívateľ môže odstrániť súčasti, ktoré ste mali aktualizovať majetok na, Musíte buď vrátiť späť ich zmenu (ak ste si istí, že ich bynie sa stalo), alebo zrušiť vašu zmenu (môže sa potom vrátiť späť do súboru a znovu vašu zmenu).

Konkrétne existujú 4 triedy konflikty, ktoré môžu nastať;

1. Zmazať - Ak jeden používateľ zmaže objekt, že ďalšie zmeny používateľov. Napr. Užívateľ A vypúšťa komponent, ale užívateľ B zmenila názov komponenty alebo k nemu pripojená, alebo pridaný detskú zložku k nemu atď.

2. Atribút - Keď sa dvaja užívatelia meniť obaja presne rovnaké "atribút" objektu. Napr. Obaja Užívateľ A a užívateľ B zmenila názov danej časti alebo jeho opis alebo hodnotu jedného zo svojich vlastností atď

3. Referenčnej - Keď sa dvaja užívatelia zmení presne rovnaký "referenčné" má objekt na iný objekt. Napr. Obaja Užívateľ A a užívateľ B zmenil typ niektoré komponenty alebo súčasť zdroj / drez pripojený k pripojenie alebo Google pohľadu na diagram atď.

4. Inkaso - Keď sa dvaja užívatelia zmeniť "zber" pre objekt. Napr. Obaja Užívateľ A a užívateľ B presunuté súčasť z jedného rodiča na druhého, alebo re-objednal kolekciu detských komponentov.

Poznámka

Rôzne bezvýznamné konflikty sú vyriešené automaticky ABACUS čím sa znižuje zaťaženie na používateľa.Napríklad všetky konfliktné nastavenia pan-zoom pre schémy sa rozhodli zachovať posledné nastavenie pan-zoom.

Spáchanie zmeny

Ak sa rozhodnete, aby sa zaviazali zmien, súbor ABACUS zo servera je otvorený, vaše miestna sú vykonané zmeny proti tomu, a potom Váš miestny .abacus súbor prepísaný s jedným, ktorý má zmeny v ňom. Zmeny súboru potom prepíše .log, a ako súbor .abacus a .log sú odoslané na server.V prípade, že sa zaväzujú je úspešný Zaviazať sa dialógové okno, ako je uvedené nižšie je poskytovaná na zadanie správu s commit.

Zobrazenie záznam zmien

K zobraziť protokol zmien na Podnik projektVyberte Súbor| View Log...

Maximálna dĺžka záznamu Záznamy: Táto bude predvolený posledných 10 záznamov ale ďalšie vstupy môžu byť vyvolané zmenou hodnoty a kliknutím na tlačidlo Načítať Tlačidlo.

Revízia: ThStĺpec e Revízia uvádza čísla revízií zaviazali Enterprise servera, v predvolenom nastavení, v obrátenom chronologickom poradí.

Poznámka

Čísla revízií nemusí byť kontinuálne, pretože ABACUS dopúšťa bude uvedený iba pri rovnakej Subversion úložiska môže byť používaný pre iné projekty Abacus a / alebo iných kontrolných verzie aplikácií.

Dátum: The Date stĺpec obsahuje dátum, že revízie bol spáchaný na Enterprise servera.

Doba: The Time stĺpec obsahuje čas dňa (v 24-hodinovom formáte), že revízia bol spáchaný na Enterprise servera.

Autor: The Autor stĺpec obsahuje názov Microsoft Windows prihlasovacie pre užívateľov, ktorá vykonala commit nasleduje ich ABACUS užívateľské meno , Alebo "Anonymous" v prípade, že užívateľ nie je overený a anonymný užívatelia boli povolený prístup k Enterprise projektu v dobe COMMIT.

Log Správa: Thstĺpec e Log Zoznamy správ správy komitát, ktorý bol dodaný s revíziou podľa dialógovom okne je uvedené vyššie.

Stiahnite revízie XX ako samostatné ABACUS súboru: Ak vyberiete danú revíziu v tabuľke a potom kliknite na tlačidlo Stiahnuť budete môcť extrahovať zvolenej ABACUS revízii projektu zo servera a uložiť ho ako miestny / samostatného projektu ABACUS.

Poznámka

Ak sa chcete vrátiť k predchádzajúcej revízii, prosím vidieť Avolution článok komunity .

(Správca) Stiahnite súbor XML protokolu pre revíziu XX: Užívatelia s možnosťou Správca ABACUS si vybrať danú revíziu v tabuľke a potom kliknite na tlačidlo Stiahnuť extrahovať zvolený projekt ABACUS spáchať súbor denníka zo servera a uložiť ho ako súbor XML.

Zobrazenie revízny zmien

K zobraziť revízny zmien akéhokoľvek daného prvku (tj zložky, pripojenie, pohľad, deti atď) po dosiahnutí Podnik projekt, kliknite pravým tlačidlom myši na prvok a vybrať Audit Trail..., Nastavte Od a rozsah revízií a kliknite na tlačidlo Hľadať.

Poznámka

Akonáhle je prvok odstránený z projektu, už nie sú schopné prístup k informáciám konkrétneho audit chodník o tento prvok. Môžete však stále prístup "materskú" komponentu (napríklad) a zobraziť informácie audit chodník o vymazanie (v tomto prípade zoznam ID prvku, ktorý bol odstránený).Okrem toho, komponentný / príloha Connection je "majetkom" prípojok takže zmena pripojený komponentov z okna Prieskumník alebo na Diagramy sa objaví na cestu pre audit pripojenie nie je diel a odstránenie pripojenia a vytvorenie nového pripojenia (ako sa stane, keď kliknete pravým tlačidlom myši 'Unattach' a potom 'Connect ... "v katalógoch), bude mať za následok stratu informácií audit trail pre pôvodnú zložku - prílohu spojenie úplne.

Poznámka

Štandardne je pre audit bude rekurzívne kontrolovať zmeny niektorého z detí vybraného prvku. To môže mať za následok dlhou dobou odozvy a podľa toho auditu stopa môže byť obmedzené na samotný prvok odznačením Rekurzívne Možnosť podľa Možnosti AuditTlačidlo "ozubené koleso" Panel nástrojov v dialógovom okne Audit Trail.

Od revízie: Táto sa štandardne nastaví na prvý / najstaršie revízie je k dispozícii pre projekt na Enterprise Server.

Revízií: Táto sa prepne na poslednú / Aktuálne verzii k dispozícii pre projekt na Enterprise Server.

Poznámka

Po nastavení od a do revízie rozsah kliknite na tlačidlo Hľadať načítať žiadne konkrétne zmeny na vybraný prvok.

Revízia: ThStĺpec e Revízia uvádza čísla revízií zaviazali Enterprise servera, v predvolenom nastavení, v predvídavom chronologickom poradí.

Poznámka

Čísla revízie sú nepravdepodobné byť kontinuálne, ako bude zobrazené iba revízie relevantné pre vybraný prvok a len ABACUS zaväzuje bude uvedený zatiaľ čo rovnaký Subversion úložisko môže byť používaný pre iné projekty Abacus a / alebo kontrolu verzie aplikácie.

Dátum: The Date stĺpec obsahuje dátum, kedy bola vykonaná užívateľ akcie.

Poznámka

Dátum uvedené je dátum akcie užívateľa, nie dátum revízie bol spáchaný na Enterprise servera. V súlade s tým, môže byť deň predchádzať zodpovedajúce revíziu potvrdzovanie deň uvedený s Súbor | View Log ...príkaz.

Doba: The Time stĺpec obsahuje čas dňa (v 24-hodinovom formáte), ktorý bol použitý pri akcie užívateľa.

Poznámka

Čas zobrazený je čas akcie užívateľa, nie je čas revízie došlo k Enterprise Server. V súlade s tým doba bude s najväčšou pravdepodobnosťou predchádzať zodpovedajúce revíziu zaviazať zobrazený čas s Súbor | View Log ...príkaz.

Autor: The Autor stĺpec obsahuje používateľa, ktorý vykonal akciu v Microsoft Windows prihlasovacie meno a následne ich ABACUS užívateľské meno , Alebo "Anonymous" v prípade, že užívateľ nie je overený a anonymný užívatelia boli povolený prístup k Enterprise projektu v čase akcie používateľa.

Poznámka

Autor uvedené v Trail dialógu auditu nemusí nutne zodpovedať autor uvedené v dialógovom okne View Log nad za rovnaké revíziu. Je to preto, že dialóg zoznamy View Log prihláseného používateľa v okamihu commit, zatiaľ čo dialóg zoznamy Audit Trail prihláseného používateľa v čase akcie používateľa, a to je možné mať jeden užívateľ vykonávať zmeny a posielať svoje. zmeny súboru inému užívateľovi zaviazať - ako je tomu v prípade, keď externý užívateľ (napríklad Avolution) je pracovať na EE projektu.

Podrobnosti: The Podrobnosti stĺpci sú uvedené presné podrobnosti o zásahu užívateľa ako sú zaznamenané v Enterprise Server.

Tip

Je užitočné skupina podľa stĺpca Revízia (ako je znázornené v dialógu vyššie) a / alebo používateľ stĺpca Akcia na Ľahko klasifikovať zmeny prvok záujmu.

Použitie skriptovanie s Enterprise súbory

Ak používate skriptovanie s Enterprise súbory, mali by ste si byť vedomí toho, ako správne odstrániť objekt z modelu. Všeobecne platí, že keď odstraňujete objekt, budete volať metódu .Delete () na tom, skôr než len vyťahovanie z jeho rodičia.

Napr. keby ste COMP1 ako nadradený comp2 a chcete vymazať comp2 v skripte, mali by ste zavolať comp2.Delete (), skôr než comp1.Components.Remove (comp2).

Môžete použiť odobrať, ak máte v úmysle pridať comp2 objekt na iné miesto v rámci architektúry, ale to by nemal byť použitý v prípade, že zámerom je odstrániť objekt.

Tam je výnimka z tohto, pretože keď chcete odstrániť objekt, ktorý "žije" na inom mieste v modeli. Ak chcete odstrániť štandardné inštanciu z architektúry / komponentu / pripojenie, potom by ste to tým, že odstráni ju z inštancie štandardným zbierka - arch1.Implementácia.Uvolnit (IMP) - preto, že odstránením by sa odstrániť zo všetkých inštancií.

Správne pomocou Odstrániť v skriptov je dôležité, pretože v prípade, že objekt je odobratý z objectmodel a nie znovu pridá, potom to nebude môcť byť umiestnený, ale vzhľadom k tomu, že to nie je špecificky vymasteného, ​​bude konfliktov Detekcia a Resolution nie správne rozpoznať konflikt, ak iný užívateľ mal pokúšať sa používať tento objekt v niektorej z ich zmien, a konečný výsledok bude poškodený súbor zmien pre daného užívateľa.

Pozri tiež

Ako sa architektúra zastúpená v ABACUS?


Práca so súbormi ABACUS

Navigácia: Úvod do ABACUS>

Práca so súbormi ABACUS

Odoslať pripomienky na túto tému.

Súbor ABACUS je kontajner pre model vášho architektúra , V rámci jedného súboru ABACUS, môžete modelovať ľubovoľný počet architektúr ľubovoľný počet časov.

Pri prvom otvorení Abacus, že sú otvorené žiadne súbory. Ak chcete pracovať na vašej architektúre, musíte buď vytvoriť nový súbor, alebo otvoriť existujúci súbor.

Pri otvorení alebo vytvoriť nový súbor, bude strom v okne Explorer automaticky zobraziť. Tento pohľad Explorer ukazuje vašu architektúru k dnešnému dňu. Pri zatvorení súboru, bude strom v okne Prieskumníka tiež zmizne.

Ak chcete vytvoriť nový súbor ABACUS

1. Vybrať Súbor| Nový ...

2. V dialógovom okne Nový projekt, ktorý sa zobrazí (ako je uvedené nižšie) Zvoliťbuď vytvoriť prázdnu modelu, model z A Štandardná ABACUS knižnica , Model z vlastnej ABACUS knižnice, model z XML, MS Access , MS Visio , MS Excel , MS SQL Server , Což Podnik Server Model alebo vlastné ABACUS knižnice (.abacuslib súbor).

3. Kliknite na OKtlačidlo a postupujte podľa dialógy, ktoré sa môžu objaviť.

Tip

Nebudete vyzvaní na zadanie názvu súboru, kým uložiť alebo zatvoriť. Je to dobrý nápad, uložiť súbor, akonáhle si ho vytvoriť. Potom nebudete musieť starať o pomenovanie ju neskôr v procese, keď ste so zameraním na iné zložité veci (ako vyplnenie vašej architektúry).

Vytvoriť nový projekt

ABACUS Štandardné knižnice

ABACUS podporuje viac ako 100 verejná rámcov a zápisy z ktorých niektoré sú uvedené nižšie. Pri výbere pre vytvorenie nového projektu zo štandardnej používatelia knižnice majú rýchly štart do modelovania v rámci stanovenia rámca plne využívať všetky definovaných typov prvkov, atribútov, notácie, názory a šablóny alebo vzory. Ďalšie štandardné knižnice sú voľne k dispozícii prostredníctvom Avolution spoločenstva tu .

Nový projekt zo štandardnej knižnice

Ak chcete uložiť nový súbor ABACUS

1. Vybrať Súbor| Uložiť ako

Tip

Názvy súborov môžu mať ľubovoľnú dĺžku, a môže obsahovať ľubovoľné alfanumerické znaky a medzery. Nemôžu obsahovať vlnovky (~) charakter, potrubia (|) znak otáznik, alebo znaky sa bežne používa pre popis cesty, ako je spätné lomítko (\) - s výnimkou ako súčasť cesty (?).

Ak chcete otvoriť existujúci súbor ABACUS

1. Vybrať Súbor| Otvorené

Poznámka

Ak otvárate súbor zo zdieľaného sieťového umiestnenia, ktoré je už otvorený iným užívateľom, bude ABACUS poskytne prístup len na čítanie. Pri použití Abacus s prístupom len na čítanie, nebudete môcť vykonávať operácie zápisu, ako je naplnenie vašej architektúry a beží hodnotiteľov. Môžete však zobraziť architektúru pomocou zobrazenia Prieskumníka a 3D pohľady.

Pozri tiež

Ako sa architektúra zastúpená v ABACUS?


Práca s Dashboards

Navigácia: Správa>

Práca s Dashboards

Odoslať pripomienky na túto tému.

Projekty Abacus môžu mať akúkoľvek konfiguráciu názory (napr diagramy, Grafy atď) uložené ako palubná doska a tieto uložené dashboardy môžu byť nastaviť ako predvolený spúšťanie "obrazovky" na otvorenie projektu a / alebo priradiť k určitému skupina užívateľov a prezentované na členov tejto skupiny užívateľov, keď sa prihlási do projektu ABACUS.

Poznámka

Ak chcete nakonfigurovať riadiace panely v projekte ABACUS licencie užívateľ potrebuje schopnosť správcu. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

Prehliadanie Dashboards

Príkladom aplikácií Portfólio Management (APM) dashboard

Ak chcete zobraziť uložené Dashboard

1. Vybrať Pohľad| Dashboards

2. Vyberte uloženú prístrojovú dosku zo zoznamu dostupných prístrojových dosiek.

Poznámka

Akonáhle vybrané ABACUS bude stavať názory potrebné pre prístrojovú dosku, a to môže trvať niekoľko sekúnd. Prosím, buďte trpezliví.

Správa Dashboards

Správa Dashboards

Ak chcete vytvoriť nový Dashboard

1. Otvorte požadované názory a zariadiť a dock okná, ako je požadované pre prístrojovú dosku.

2. Vybrať Pohľad| Dashboards| Spravovať Dashboards ...

Poznámka

Ak nevidíte Správa Dashboards položku potom nemáte možnosť správcu. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

3. V dialógovom okne, ktoré sa objaví vyberte VytvoriťTlačidlo a zadajte názov Dashboard v dialógovom okne Vytvoriť nový ovládací panel.

4. Kliknite na OKTlačidlo.

Ak chcete odstrániť existujúce Dashboard

1. Vybrať Pohľad| Dashboards| Spravovať Dashboards ...

2. V dialógovom okne, ktoré sa objaví vyberte Dashboard, ktorú chcete odstrániť zo zoznamu a vyberte ZmazaťTlačidlo.

Poznámka

Odstránenie riadiaceho panela bude tiež odstrániť všetky skupiny užívateľov priradenie k tomuto palubnej dosky.

3. Kliknite na OKTlačidlo.

Ak chcete nahradiť existujúcu Dashboard

1. Otvorte požadované názory a zariadiť a dock okná, ako je požadované za náhradný palubnej dosky.

2. Vybrať Pohľad| Dashboards| Spravovať Dashboards ...

3. V dialógu, ktorý sa objaví vyberte Dashboard, ktorý chcete nahradiť zo zoznamu a vyberte NahradiťTlačidlo.

4. Kliknite na OKTlačidlo pre potvrdenie dialóg Dashboard vymeniť.

Ak chcete priradiť Dashboardako predvolený úvodnej obrazovke

1. Vybrať Pohľad| Dashboards| Spravovať Dashboards ...

2. V dialógovom okne, ktoré sa objavia vyberte Dashboard zo zoznamu, ktorú chcete priradiť ako predvolený úvodnú "obrazovku"a vyberte Priradiť ...Tlačidlo.

3. V dialógovom okne, ktoré sa objaví vyberte vstup do užívateľskej skupiny stĺpcov.

Poznámka

Iba jeden dashboard možno priradiť ako start "obrazovky", aby re-úloha bude odstrániť Projekt zadanie z predchádzajúceho palubnej dosky.Okrem toho, ak sa používateľ prihlási ako člen skupiny užívateľov, ktorá má pridelenú palubnú dosku, potom priradený prístrojová doska sa otvorí namiesto východiskovej projektu palubnej dosky.

4. Kliknite na OKTlačidlo.

Ak chcete priradiť používateľské skupiny na Dashboard

1. Vybrať Pohľad| Dashboards| Spravovať Dashboards ...

2. V dialógovom okne, ktoré sa objavia vyberte Dashboard zo zoznamu, ktorú chcete priradiť skupinu užívateľov pre a vyberte Priradiť ...Tlačidlo.

3. V dialógovom okne, ktoré sa objaví vyberte User Group (alebo skupiny)Ak chcete priradiť palubnej dosky ako na obrazovke pre "do začiatku".

Poznámka

Ak je rovnaký User Group priradená viac dashboardy potom bude použitá ako prvá úloha v zozname.

4. Kliknite na OKTlačidlo.

Ak chcete zrušiť priradenie skupiny užívateľov z Dashboard

1. Vybrať Pohľad| Dashboards| Spravovať Dashboards ...

2. V dialógovom okne, ktoré sa objavia rozbaľte Dashboard zo zoznamu, ktorú chcete zrušiť priradenie skupiny užívateľov z.

3. Vyberte skupinu používateľov, ktorú chcete zrušiť priradenie a vyberte Zrušiť priradenieTlačidlo.

4. Kliknite na OKTlačidlo.

Nastavenie oprávnení

Oprávnenia je možné nastaviť pre riadiace panely, aby bolo možné ich prístrojová doska, aby bola viditeľná, Aktualizovať a / alebo deleteablezadaných používateľských skupín.

Oprávnenie Správa

Ak chcete nastaviť povolenia pre Dashboard

1. Vybrať Pohľad| Dashboards| Spravovať Dashboards ...

2. V dialógovom okne, ktoré sa objavia vyberte Dashboard zo zoznamu, ktorú chcete nastaviť povolenia pre a vyberte Oprávnenia ...Tlačidlo.

3. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

4. V predvolenom nastavení uvidíte, že čítanie, aktualizáciu a odstraňovanie oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

5. Kliknite na OKTlačidlo.

Pozri tiež

Prispôsobenie rozhranie ABACUS | Práca s oprávneniami


Práca s oprávneniami

Navigácia: Správa>

Práca s oprávneniami

Odoslať pripomienky na túto tému.

Projekty ABACUS môžu mať na základe rolíOprávnenia nastaviť pre každý prvok v rámci úložiska. Konkrétne, jemnozrnný Create-Read-Update-Délet (CRUD) Oprávnenie je možné nastaviť na "objekt" (tj zložka alebo pripojenie), zobrazenie a atribútu (tj úrovňou vlastníctva).

Prehľad

Pri práci s ABACUS Enterprise Server , ABACUS ponúka jemnozrnné, založené na rolách CRUD oprávnenie riadiť prístup viac používateľov k úložisku.

Poznámka

Ak chcete nakonfigurovať povolenia v projekte ABACUS licencie užívateľ potrebuje schopnosť správcu. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

Oprávnenia je možné nastaviť pre architektúry, komponentov a pripojenie typy, vlastnosti (prostredníctvom ich typov), šablóny, názory a diagramy, katalógy, matice, grafy a 3Dpohľady, Ak sú oprávnení nastavená pre komponentu alebo typu pripojenia všetky inštancie tohto typu v akomkoľvek architektúrach v tomto projekte "zdedí" tie oprávnenia. Podobne, keď je oprávnenie nastavená pre vlastnosť komponenty alebo typu pripojenia, v danom majetku na komponenty alebo pripojenie prípadoch v akomkoľvek architektúr v tomto projekte "zdedí" tie oprávnenia. V súlade s tým budú niektoré oprávnenia aplikovať na názory, na ktorých existujú tieto prvky. Ak sú oprávnení nastavený na diagrame, zobrazenie a / alebo obsahu pohľadu samotného mať rôzne oprávnenia aplikovaný na to.

Poznámka

V predvolenom nastavení žiadne oprávnenie sú stanovené pre prvky v rámci projektu ABACUS. To je všetky prvky sú vytvořitelný, čitateľné, aktualizovateľný a Deleteable všetci užívatelia. Týmto spôsobom oprávnenia by mali byť považované iba pre daný prvok v úložisku, keď určité povolenie má byť obmedzenýpre určitú skupinu užívateľov. Napríklad, ak boli pridané oprávnenia pre dané skupiny užívateľov k objektu (napríklad typ komponenty), ale vľavo s všetky oprávnenia povolené, potom je funkčne rovnaké, ako v prípade, že užívateľ skupina nebol pridaný k objektu.

Oprávnenie nemôženastaviť pre špecifické inštancie prvkov architektúru je. Napríklad, nemôžete jedna zložka Aplikácia aktualizovať ešte ďalšie nie. Ak chcete tieto "určité domény" oprávnenie účinne dosiahnuť však môže správca nastaviť konkrétne typy prvkov pre dané domény, napr typy komponentov "aplikácie - CRM domény" a "Aplikácia - HR domény", a potom nastaviť povolenia pre každý typ spôsobom. Môžete si vytvoriť konkrétne typy zoskupenie pre každú doménu a potom odstráňte balík oprávnenia pre daný typ skupiny domény špecifické a to obmedzí výtvory vnútri a odstránenie z toho zoskupenia, ale nie je možné aktualizovať z detí. Samozrejme, v prípade, že zoskupenie doména špecifická bol skrytý odobratím povolenia pre čítanie potom deti budú skrytá, a tým non-aktualizovateľný. Prípadne, ak sú použité pohľady (skôr než Exploreru) primárne riadiť / zobraziť úložiska, by mohol byť zavedený určitý pohľad pre každú doménu, a potom správca mohol zodpovedajúcim spôsobom nastaviť povolenia pre každého pohľadu.

Správa užívateľov a skupín

Oprávnenia sú definované na rolealebo skupinaúroveň, na rozdiel od úrovni jednotlivých užívateľov, tak, že zatiaľ čo členov skupín sa môže meniť, oprávnenia môže zostať pevná. Samozrejme, ak chcete, aby konkrétny užívateľ oprávnenie potom stačí, aby boli skupiny, alebo presnejšie vytvoriť skupinu s týmto užívateľom ako jediného spoločníka.

Je potrebné uviesť, že skupiny sú atómový, Že sa nemôžu dediť oprávnenia alebo používateľa od jedného k druhému, a ak používateľ patrí do viacerých skupín potom najviac oprávnenia skupiny "pesimistický" bude mať prednosť prípad od prípadu pre každý jednotlivý povolenia (tj Vytvoriť -Read-Update Delete). Napríklad v prípade, že rovnaký užívateľ je členom skupiny A a skupiny B a Skupina A práve Create-oprávnenie čítanie pre typy komponentov Application zatiaľ čo skupina B bola práve čítanie Aktualizácia oprávnenia pre typy komponentov Application potom užívateľ bude mať len oprávnení pre čítanie inštancie komponenty Application.

Navyše tým, že v predvolenom nastavení, anonymný užívatelia(že je užívatelia, ktorí neboli definované, alebo ktorí nie sú prihlásení) majú plný prístupk projektu. To má zabezpečiť, že je k dispozícii prístup v počiatočnej konfigurácii. Ak chcete blokovať prístup anonymný užívatelia jednoducho zrušte označenie poľa "Povoliť anonymný užívateľ plný prístup k spisu" možnosť v Spravovať užívateľa / skupiny dialóg uvedený nižšie. Pokiaľ nie je nastavený anonymný užívatelia budú môcť vidieť časť normami projektu.

A konečne, v prípade, že "používanie systému Windows Užívateľské meno Vstup" je zaškrtnutá voľba overovanie užívateľské meno je vykonávané proti Windows užívateľské meno prihlásenie na počítači každého používateľa proti užívateľské meno je zadaný podľa nižšie. To je v prípade, že systém Windows Užívateľské meno Prihlásenie k počítači daného užívateľa to existuje ako platný užívateľské meno a potom je vyžadované žiadne heslo a užívateľ je automaticky overený. Poznámka: Toto účinne umožňuje použitie Windows Active Directory (AD) overovania.

Poznámka

Vzhľadom k tomu, že oprávnenie sa definujú len vtedy, keď je potrebné vziať preč (obmedzený) od užívateľov, každý užívateľ, ktorý nie je členom skupiny, alebo akákoľvek skupina, ktorá nemá žiadne oprávnenie definované pre ňu proti všetkým objektom, bude mať plný prístup k projekt.

Používatelia a skupiny užívateľov

Ak chcete vytvoriť nového používateľa

1. Vybrať Súbor| Správa užívateľa / skupiny

Poznámka

Ak nevidíte Spravovať užívateľa / skupiny položky menu potom nemáte možnosť správcu. Obráťte sa na miestneho správcu ABACUS alebo Podpora Avolution Ak vyžadujete túto funkciu.

2. V dialógovom okne, ktoré sa objaví vyberte Pridať užívateľatlačidlo a zadajte užívateľské meno a heslo v dialógovom okne Vytvoriť nového používateľa. Poznámka: Užívateľská mená a heslá sú veľké a malé písmená.

Poznámka

Ak je "používanie Windows Užívateľské meno Vstup" voľba zaškrtnutá, ako je popísané vyššie potom neúčinným heslo môže byť zadaná ako overenie bude vykonané v súlade s operačným systémom Windows, kedy užívateľ Užívateľské meno jediného prihlásenia.

2. V predvolenom nastavení uvidíte, že Užívatelia môžu zmeniť svoje vlastné heslo. Ak je to nutné, správca ABACUS môže odstrániť schopnosť pre užívateľa nastaviť svoje vlastné heslo podľa odškrtnutímzaškrtávacích políčok.

Poznámka

Ak môžu používatelia zmeniť svoje vlastné heslo, ktoré bude mať Súbor | Zmen heslo...položka menu, aby tak urobili.Tiež byť vedomí, že ak viac ľudí používa rovnaké používateľské meno potom jeden používateľ môže zmeniť heslo tak, že žiadne ďalšie osoby môžete prihlásiť neskôr. V súlade s tým, je odporúčané praxi mať single užívateľské meno na fyzické osoby.

4. Voliteľne, zadajte e-mailovú adresu, Umiestnenie a telefónne číslo pre používateľov, pre neskoršie použitie.

5. Kliknite na OKtlačidlo v dialógovom okne Vytvoriť nového používateľa.

6. Kliknite na OKTlačidlo.

Poznámka

Akonáhle ste vytvorili svoj prvý užívateľ, mali by ste uvažovať o blokovanie prístupu anonymnými užívateľmi zrušením začiarknutia "Povoliť anonymný užívateľ plný prístup k spisu" možnosť v dialógovom okne Správa užívateľov / skupín.Tiež, akonáhle užívateľ bol vytvorený (a ak je projekt Enterprise, zmena zaviazala k serveru), nabudúce je projekt otvorený užívatelia budú vyzvaní na Prihlásenie pre overený prístuppodľa dialógovom okne nižšie. V prípade, že Prihlásiť automaticky s týmito detailyje zaškrtnutá voľba potom kombinácia užívateľské meno / heslo bude pripomínaný pre projekt a aplikovať zakaždým pri otvorení. Ak chcete vymazať uložené prihlasovacie select Súbor | Zmazať uložené Prihláseniepo otvorení a budete vyzvaní na prihlásenie nabudúce otvoríte projekt.

Prihlásiť sa

Ak chcete odstrániť existujúce užívateľa

1. Vybrať Súbor| Správa užívateľa / skupiny

2. V dialógovom okne, ktoré sa objavia vyberte užívateľské meno v paneli užívateľov, ktoré chcete odstrániť, a potom vyberte Zmazať užívateľaTlačidlo.

3. Kliknite na OKTlačidlo.

Ak chcete vytvoriť novú skupinu

1. Vybrať Súbor| Správa užívateľa / skupiny

2. V dialógovom okne, ktoré sa objaví vyberte Pridať skupinutlačidlo a zadajte názov skupiny v paneli Skupiny.

Poznámka

Názvy skupín musia byť jedinečné.

3. Kliknite na OKTlačidlo.

K kopírovať existujúceGroup

1. Vybrať Súbor| Správa užívateľa / skupiny

2. V dialógovom okne, ktoré sa objaví vyberte KopírovaťGroupTlačidlo.

Poznámka

Duplicitné skupina bude vytvorená s predponou "Kópia".V predvolenom nastavení sú všetky oprávnenia z skopírované skupiny budú duplikované pre "Kópie" skupiny, vrátane akéhokoľvek pridelenia užívateľa.

3. Premenovať "kópia" skupiny, ako zodpovedajúce použitie Upraviť skupinualebo pomaly poklepanie.

Ak chcete odstrániť existujúce skupiny

1. Vybrať Súbor| Správa užívateľa / skupiny

2. V dialógovom okne, ktoré sa objavia vyberte meno skupiny v paneli skupín, ktoré chcete vymazať, a potom vyberte Zmazať skupinuTlačidlo.

Poznámka

Každý užívateľ, priradenie k skupine budú tiež odstránené.

3. Kliknite na OKTlačidlo.

Ak chcete priradiť užívateľa do skupiny

1. Vybrať Súbor| Správa užívateľa / skupiny

2. V dialógovom okne, ktoré sa objavia vyberte užívateľské meno v paneli užívateľov, ktoré chcete priradiť do skupiny a drag-and-dropto na názov skupiny v paneli Skupiny, ktoré chcete priradiť k.

3. Kliknite na OKTlačidlo.

Poznámka

Skupina (y), že používateľ je priradený sú zobrazené rozbalením Užívateľské meno v paneli Užívateliaa užívatelia, ktoré sú priradené k skupine, sú zobrazené tým, že rozšíri názov skupiny v paneli Skupiny. Napríklad, vo vyššie uvedenom snímke, užívateľ "AS1-Aus" je priradený na tri (3) skupín, a to; "App Support Team 1", "Actual" a "Austrália".

Ak chcete zrušiť priradenie užívateľa zo skupiny

1. Vybrať Súbor| Správa užívateľa / skupiny

2. V dialógovom okne, ktoré sa objavia rozbaľte názov skupiny, ktorá obsahuje zadanie používateľa, ktorý chcete zrušiť priradenie a vyberte užívateľské meno.

3. Kliknite na Zrušiť priradenie UžívateľTlačidlo.

4. Kliknite na OKTlačidlo.

Ak chcete importovať užívateľa a / alebo skupiny (a žiadne zodpovedajúce oprávnenie)

1. Vybrať Súbor| Správa užívateľa / skupiny

2. Kliknite na DovozTlačidlo.

3. V dialógovom okne, ktoré sa objavia Brouzdatpre a otvorte projekt ABACUS obsahujúce užívateľa a / alebo skupiny (a oprávnenie), ktorý chcete importovať do aktuálneho projektu a kliknite na tlačidlo Otvorené, Používateľa a skupiny, importujú a dialóg Importovať Výsledky sa zobrazia sumarizuje dovoz užívateľov a / alebo skupín. Kliknite na OKTlačidlo.

Poznámka

V prípade, že dovážané užívateľov alebo skupín existovala už v aktuálnom projekte potom budú spojené s existujúcimi používateľa alebo skupiny.

4. Kliknite na OKtlačidlo späť v hlavnom dialógového okna Správa užívateľa / skupiny.

5. Ak sa vyskytnú nejaké typy vyhovujúce, vyhliadky, šablóny alebo Architektúry medzi aktuálnym projektu a projekt ABACUS ste dovážajúcej od, kompletný s oprávneniami, ktoré nie sú už existujú v aktuálnom projekte, oprávnenia sú dovezené a druhý dialóg Importovať výsledky zobrazí sa zhrnutie import. Kliknite na OKTlačidlo.

Poznámka

Oprávnenia sú pridané iba na existujúce typy (a ich vlastnosti), pohľady, šablóny alebo architektúr pre skupiny, kde oprávnenie nebolo už pre skupinu existujú. Buď preto, že skupina je nová, alebo skupina existovala už v aktuálnom projekte, ale žiadna oprávnenie bolo pridelené pre túto skupinu, aby danú položku. Neexistuje žiadna "zlúčenie" oprávnenie pre zodpovedajúce položky, kde už existujúce oprávnenia pre skupinu v aktuálnom projekte.

Nastavenie oprávnení

Oprávnenia je možné nastaviť pre architektúry, komponentov a pripojenie typy, vlastnosti (prostredníctvom ich typov), šablóny, názory a diagramy, katalógy, matice, mapujed 3Dpohľady, Ak sú oprávnení nastavená pre komponentu alebo typu pripojenia všetky inštancie tohto typu v akomkoľvek architektúrach v tomto projekte "zdedí" tie oprávnenia. Podobne, keď je oprávnenie nastavená pre vlastnosť komponenty alebo typu pripojenia, v danom majetku na komponenty alebo pripojenie prípadoch v akomkoľvek architektúr v tomto projekte "zdedí" tie oprávnenia. V súlade s tým budú niektoré oprávnenia aplikovať na názory, na ktorých existujú tieto prvky. Ak sú oprávnení nastavený na diagrame, zobrazenie a / alebo obsahu pohľadu samotného mať rôzne oprávnenia aplikovaný na to.

Oprávnenie Správa

Ak chcete nastaviť povolenia pre komponent (alebo pripojenie) Typ

1. Rozbaľte Druhyvetva stromu.

2. Rozbaľte Component (alebo pripojenie) Typyvetva stromu.

3. Rozbaliť Skupinyv prípade potreby.

4. Kliknite pravým tlačidlom myšina Component (alebo pripojenie) TypAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

5. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

6. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

Poznámka

Vytvorte povolenie upravuje aj vtedy, keď je možné kopírovať prvok. V súlade s tým, aby bolo možné kopírovať prvok vyžaduje vytvoriť povolenie pre všetky jeho deti (od skopírovať prvok znamená kopírovať všetko pod ním). Odstránení aktualizácie povolenie od prvku odstraňuje schopnosť modifikovať samotný typ, a to aj v prípade, že užívateľ má Návrhár doplnok a to tiež odstraňuje aktualizácia povolenia pre všetky svoje vlastnosti. Rodič prvok musí mať aktualizácie povolenie, aby mohli Vytvorte nejaké deti prvkov alebo Zmazať IDS existujúce detské prvky. Odstránenie povolenie pre prvok tiež vyžaduje Delete povolenie pre všetky jeho deti. Zmazať povolenie pre komponenty tiež vyžaduje aktualizácia povolenie všetkých pripojených pripojenie.A konečne, odstránenie Delete povolenie od prvku odstráni schopnosť odstrániť samotný typ, a to aj v prípade, že používateľ má Návrhár add-on.

7. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre skupinu zložky (alebo pripojenie) Druhy

1. Rozbaľte Druhyvetva stromu.

2. Rozbaľte Component (alebo pripojenie) Typyvetva stromu.

3. Kliknite pravým tlačidlom myšina Group, Ktorý obsahuje zložka (alebo pripojenie) typy, ktoré chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

6. Kliknite na OKTlačidlo.

7. V dialógovom okne, ktoré sa objavia kliknite na tlačidlo Áno,Tlačidlo.

Ak chcete nastaviť povolenia pre vlastnosť

1. Rozbaľte Druhyvetva stromu.

2. Rozbaľte Component (alebo pripojenie) Typyvetva stromu.

3. Rozbaliť Skupinyv prípade potreby.

4. Vyberte Component (alebo pripojenie), typ, ktorý obsahuje vlastnosť, ktorú chcete nastavené oprávnenia pre.

5. V okne Vlastnosti kliknite pravým tlačidlom myšina NehnuteľnostiAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

6. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

7. V predvolenom nastavení uvidíte, že povolenia Čítať a aktualizácie sú k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

Poznámka

Vlastnosti, ktoré mali povolenie aktualizácie odstránené sú uvedené v kurzívaV okne Vlastnostia ich hodnoty nemôžu byť aktualizované týmto rolí, Ďalej, schopnosť zmeniť údaje o nehnuteľnosti (napr meno, jednotky atď) vyžaduje ako Update oprávnenie na nehnuteľnosti a Návrhár add-on.

8. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre šablóny

1. Rozbaľte Šablónyvetva stromu.

2. Vyhľadajte Šablónaže máte záujem.

3. Kliknite pravým tlačidlom myšina ŠablónaAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení uvidíte, že oprávnenie čítanie je k dispozícii. Odstráňte povolenie podľa odškrtnutímzaškrtávacie políčko.

6. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre Viewpoint

1. Rozbaľte Uhly pohľaduvetva stromu.

2. Rozbaliť Skupinyv prípade potreby.

3. Kliknite pravým tlačidlom myšina HľadiskoAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

6. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre architektúru

1. Rozbaľte Architektúryvetva stromu.

2. Rozbaľte do Staviteľstvože máte záujem.

3. Kliknite pravým tlačidlom myšina StaviteľstvoAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení uvidíte, že oprávnenie čítanie je k dispozícii. Odstráňte povolenie podľa odškrtnutímzaškrtávacie políčko.

6. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre Katalóg

1. Rozbaľte Katalógyodbor architektúry máte záujem.

2. Rozbaliť Skupinyv prípade potreby.

3. Kliknite pravým tlačidlom myšina KatalógAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

6. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre Matrice

1. Rozbaľte Maticeodbor architektúry máte záujem.

2. Rozbaliť Skupinyv prípade potreby.

3. Kliknite pravým tlačidlom myšina MatriceAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

6. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre diagram

1. Rozbaľte Diagramyodbor architektúry máte záujem.

2. Rozbaliť Skupinyv prípade potreby.

3. Kliknite pravým tlačidlom myšina DiagramAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

Poznámka

Aj keď môžete nastaviť povolenia CRUD priamo diagramu, je potrebné poznamenať, že oprávnenie prvkov na schéme môže mať vplyv na oprávnenie pre zobrazenie samotného. Napríklad, ak je treba len jedným prvkom v názore, že má za sebou svoju čítať alebo aktualizovať oprávnenie odstrániť potom diagram bude mať odstránené jeho aktualizácie povolenia. To je preto, že; a) prvky na názore, že mali odobraté ich oprávnenia čítanie, nebudú zobrazené v pohľade opúšťať "biely priestor", kde by ste inak umiestniť niektoré nové prvky v prípade, že výhľad z hotela bol aktualizovať, a b) prvky na názore, že mali ich dovolenia aktualizácia odstránená by potom mohol mať ďalšie prvky, klesol na ne, aby sa stal deti, v prípade, že výhľad z hotela bol aktualizovať. Tiež, vytvárať a aktualizovať oprávnenie pre schému vyžaduje, aby všetky prvky na zobrazenie majú povolenie na čítanie a zložky majú povolenie aktualizácie (to je preto, presunúť zložku do inej zložky, musíte byť schopní ho aktualizovať, pretože bude stať dieťa).

6. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre zobrazenie 3D

1. Rozbaľte 3D Zobrazenieodbor architektúry máte záujem.

2. Rozbaliť Skupinyv prípade potreby.

3. Kliknite pravým tlačidlom myšina 3D zobrazenieAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

6. Kliknite na OKTlačidlo.

Ak chcete nastaviť povolenia pre Graf

1. Rozbaľte Grafyodbor architektúry máte záujem.

2. Rozbaliť Skupinyv prípade potreby.

3. Kliknite pravým tlačidlom myšina GrafAk chcete nastaviť povolenia pre a vyberte Upraviť oprávnenie.

4. V dialógovom okne, ktoré sa objavia kliknite na Pridať ...tlačidlo a vyberte GroupAk chcete pridať buď poklepaním alebo výberom a kliknutím na tlačidlo OKTlačidlo.

5. V predvolenom nastavení budete vidieť, že crude oprávnenia sú všetky k dispozícii. Odstráňte oprávnenia od odškrtnutímpríslušná zaškrtávacie políčka.

6. Kliknite na OKTlačidlo.

Pozri tiež

Ako sa architektúra zastúpená v ABACUS?


Písanie skriptov

Navigácia: Simulácia vašej architektúry>

Písanie skriptov

Odoslať pripomienky na túto tému.

Script Editor je jednoduchý a funkčný nástroj pre písanie a spúšťanie VB alebo C # skript proti V súčasnej dobe otvorený súbor ABACUS(Knižnice nie sú podporované v skriptovanie). To má obvyklý súbor otvoriť, zatvoriť a Uložiť príkazy, takže si môžete uložiť a načítať skripty píšete. Má tiež základné spúšťanie a ladenie zariadení. Script Manager umožňuje ľahko spúšťať rôzne skripty, ktoré ste napísali umiestnením menu položku pre nich priamo v menu Nástroje.

Pre prístup k editoru Script

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Vybrať Nástroje | Script Editora okno Script Editor sa otvorí. Potom buď;

3. Otvorenie existujúceho skriptu cez Súbor | Otvorené v menu dramaturg,

alebo

3. Otvorte Príklad skriptu prostredníctvom Príklad položka v menu dramaturg,

alebo

3. Nastaviť predvolený jazyk buď VB alebo C # prostredníctvom Jazyk položka v menu dramaturg,

alebo

3. Otvorený skriptovací konkrétnu pomoc na Pomoc položka v menu dramaturg

Pri písaní skriptov, musíte dodržiavať buď VB alebo C # syntaxpodľa nastavenia pod položkou jazyka v ponukách dramaturg.

POZNÁMKA:

· Ak chcete použiť štandardné VB funkcií ako MsgBox ()Musí obsahovať Dovoz Microsoft.VisualBasicvyhlásenie na začiatku skriptu. To nebolo nutné pred verzie 3.0 ABACUS.

· Táto pomoc neobsahuje informácie o tom, ako písať VB skript, ani to obsahovať odkaz VB. Neváhajte a písať skripty vo vašom obľúbenom IDE alebo editor, potom skopírovať a vložiť ich do tohto programu.

Pri prvom spustení tohto programu, bude Editor Script byť prázdny. Môžete pristupovať kostry skriptu cez menu príklady. Pri prvom spustení editora, mali by ste spustiť šablónu kostru vidieť, že to funguje. Okrem toho existujú dva príklad skripty, ktoré môžu byť prístupné cez menu príklady.

Ak chcete napísať užitočný skript budete musieť odkazovať ABACUS ObjectModel. Je k dispozícii skriptu by vrátane Dovoz ABACUS.ObjectModelvyhlásenie v čele skriptu. Kompletný odkaz na celý model objektu ABACUS je súčasťou tohto programu. Nájdete ju výberom Nápoveda | Obsahz okna Script Editor.

Editor skript obsahuje mnoho užitočných funkcií pre písanie skriptov, vrátane dokončovania ako je znázornené na nasledujúcom obrázku. Avšak, pre ešte bohatšie užívateľské skúsenosti MS Visual Studio môžu byť integrované s ABACUS a podrobné pokyny sú k dispozícii tu .

Script Editor sa automatické dokončovanie

Ak chcete použiť Správca skriptov

1. Uistite sa, že máte Súbor ABACUS, Obsahujúce Váš obývaný architektúra, otvorený.

2. Vyberte Nástroje | Správca skriptov.

3. Kliknite na PridaťIkona a OtvorenéZobrazí sa okno.

4. Vyhľadajte ABACUS Script (.abacusscript, VB alebo .cs), Súbor, ktorý chcete pridať do ponuky Nástroje.

5. Kliknite na tlačidlo OKa odkaz na skriptu sa zobrazí v okne Script Manager. Zadajte názov skriptu, ako si prajete, aby sa v ponuke Nástroje. Poznámka: Okno Správca skriptov môže byť zväčšená vidieť úplnú cestu v prípade potreby.

6. Opakujte kroky 3-5vytvárať odkazy na viac Abacus skripty.

7. Kliknite na tlačidlo Zavrieťzavrieť Script Manager a Všimnite si, že skript (y) ABACUS teraz zobrazí v ponuke Nástroje.

Ak chcete spustiť skript

Buď;

1. Open, zadajte alebo skopírujte a vložte do skriptu, ktorý chcete spustiť, tak to sa zobrazí v hlavnom okne Script Editor.

2. Kliknite na tlačidlo RunTlačidlo.

3. Ak skript obsahuje chyby, bude chyby Popis sekcie v dolnej časti editora skriptov uvádzať podrobnosti vrátane čísla riadku. POZNÁMKA: Každý jednotlivý chyba v Chyba Opis úseku môže byť poklepanie, aby vás na príslušný riadok v skripte.

- Alebo -

1. Vybrať Nástrojea potom sa Názov ABACUS Script položka menu ako bol vytvorený s Správca skriptov.

2. Ak skript obsahuje chyby, bude editor skript sa otvorí s obsahom skriptu zobrazené v hlavnom okne (zvýraznené na riadku prvej chybe) a Chyba Opis sekcie v dolnej časti editora skriptu vypíše údaje alebo chyba (y), vrátane čísla riadku. POZNÁMKA: Každý jednotlivý chyba v Chyba Opis úseku môže byť poklepanie, aby vás na príslušný riadok v skripte.

Skriptovanie chyby kompilácie

Chybám kompilácie dochádza, keď syntax kódu skriptu nie je správny. Tieto chyby sa zobrazí v dolnej časti okna v časti chýb, s popisom chyby, a číslo riadku. Je to číslo riadku, ktorý odlišuje chybu kompilácie z chyby Runtime (pozri nižšie), ktoré nebudú mať číslo riadku. Chyby kompilácie môže byť poklepanie na skok a zvýrazniť konkrétny riadok v otázke.

Scripting Runtime chyby (Dôležitý)

Runtime chyby dôjsť po kóde skriptu bol úspešne zostavený bez chýb, ale dôjde k chybe pri behu programu (pozri príklady stanoví ďalšie). Runtime chyby sú dôležité, pretože môže dôjsť k poškodeniu modeloch, keď sa objekty vytvorené a odkazované inými objektmi v modeli, nie sú samy o sebe súčasťou modelu (zvyčajne preto, že došlo k chybe runtime pred kódom, ktorý by umiestnil je v modeli Niekde bol popravený).

Ak váš skript vytvára objekty, ktoré sa pridávajú do modelu, môžete sa vyhnúť poškodeniu spôsobené runtime chyba uložením skriptu, zatváranie skriptovanie, a prevedením undo zmien, ktoré boli vytvorené pomocou skriptu (v prípade spustenia skriptu nebola dokončená normálne ). Avšak, existujú aj iné spôsoby, aby sa zabránilo korupcii vyskytujúce (pozri nižšie). Poznámka: Všetky skripty, ktoré iba čítajú z modelu a nepíšte na neho, sú bezpečné a nespôsobí žiadne problémy, bez ohľadu na to, či sa objaví runtime chyby pri ich realizácii.

Aby nedošlo k poškodeniu, pri písaní kódu skriptu, ktorý vytvára objekty a ich pridanie do objektový model, to je navrhol, že objekty sú pridané do modelu čo najskôr, ak sa odkazuje inými objektmi.

Napríklad, ak vytvárate nové pripojenie, a 2 nové zložky, a potom ich pripájanie k sebe, je najlepšie vytvoriť prvú zložku, pridajte ju k modelu, potom druhý a pridajte ju, a potom vytvoriť spojenie a pridať, a nakoniec vytvoriť prílohy. To znamená, že ak by došlo k chybe runtime, ktorý preruší spustenie skriptu, všetky objekty, ktoré sú nutné, aby sa v objectmodel pred vytvorením príloha, sú v modeli. Môže dôjsť k poškodeniu, ak napríklad, bolo pridané iba spojenia, vykonané prílohy, a potom došlo k chybe runtime pred skript nakoniec pridané nové súčasti na model.Corruption môže dôjsť, keď je objekt, na ktorý odkazuje iný objekt v objectmodel, je, že nie je v objectmodel.

Príklad runtime chyby patria:

· Odkaz na objekt nie je nastavený na inštanciu objektu - toto nastane, keď premenná objektu je null referencie, a je používaná metóda alebo vlastnosť k tomuto objektu. Nulové odkazy možno skontrolovať "Ak objectVariable nie je nič Pak ..."

· Index bol mimo hranice poľa - to nastane, keď je pole získavaný s indexom, ktorý je mimo hranice - napr menej ako 0 ° C, alebo sa rovná alebo je väčšia ako dĺžka / Count poľa. Array alebo dĺžky kolekcie možno overiť vlastnosti .Length alebo .Count, resp.

· Bez oprávnenia Výnimka - Nemáte povolenie na ... - toto dochádza, ak nemáte oprávnenie na vykonávanie danej zmeny

· Primárny kľúč Výnimka - Duplicate / chýbajúce Meno / ID - toto dôjde, ak je vykonaná zmena na unikátny atribút, ktorý je v rozpore s iným objektom. Napr. Architektúry musí byť jedinečné menom, podobne so štandardmi.

· Referenčné integrita Výnimka - nastavenie poľa odkaz na objekt, ktorý nie je platný. Napr. pridávanie "nič", alebo null ako dieťa na mnohé zbierok v objectmodel.

· Zero Length Výnimka - to môže dôjsť, ak sa pokúsite sa nastaviť názov objektu na prázdny reťazec. Väčšina objektov vyžadujú, aby ich mená mať aspoň 1 znak.

Dovoz vyhlásenie

Všimnite si, že na začiatku skeletu skriptov sú príkazy, ako sú Dovoz ABACUS.ObjectModel, Tieto vyhlásenia nebude obsahovať DLL, ktorá už nie je odkazovaný skriptom - ich cieľom je poskytnúť "zástupca", aby museli zadať celý názov triedy.

Napríklad, deklarovať premennú typu CKomponentní (reprezentujúcich komponenty v ABACUS), pričom Dovoz ABACUS.ObjectModelvyhlásenie smerom k hornej časti skriptu, by vyžadoval len to, aby bol deklarovaný ako dim comp as CKomponentní, Pretože kompilátor vie, že sa pozrieť v mennom priestore ABACUS.ObjectModel pre triedu CKomponentní. Bez príkazu Imports, musel by byť deklarovaný ako dim comp as ABACUS.ObjectModel.CComponent, Zostava (ako je mscorlib.dll, alebo System.Windows.Forms.dll) môže obsahovať viac ako jeden názvov - vyhlásenie Imports je na týchto odborov názvov, nie je pre samotné zostavy. Zostava ABACUS.ObjectModel.dll má iba jediný ABACUS.ObjectModel menný priestor prístupný prostredníctvom skriptovania.

Automaticky odkazované zostavy

Nasledujúce DLL sú odvolával sa automaticky skriptovanie:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (implicitne odkazuje prekladač)

· ABACUS.ObjectModel.dll

Ak chcete ďalšie odkazy buď inými .NET zostáv, alebo vlastné zostavy, nájdete v nasledujúcej časti na strane #ImportDLL vyhlásenia.

#ImportDLL Vyhlásenia

Od roku ABACUS 3.1, môžete odkaz ďalšie zostavy, ktoré môžete potrebovať pre skriptovanie s užívaním #ImportDLL vyhlásenia. Napríklad, ak ste chceli, aby prístup k vlastnej DLL tvoj a využiť funkcie v ňom, by ho umiestniť do adresára ABACUS a zahŕňajú vyhlásenie ako prvý riadok (y) vo vašom skriptu. Pokiaľ sa jedná o .NET dll, potom normálne nemusíte zadávať celú cestu, len DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.xml.dll

Niektoré ďalšie veci na vedomie:

1. Pretože dll musí byť nájdený pri kompilácii a behu, to obmedzuje vlastnú (ne) .NET dll boli umiestnené iba v priečinku programu ABACUS.

2. #ImportDLL vyhlásenie musí byť prvý riadok (y) zo skriptu - ak máte 5 vyhlásenie, potom by mala byť na prvých 5 riadkov skriptu

3. #Vyhlásenie o ImportDLL umiestnené kdekoľvek, ale Prvé riadky skriptu (napríklad ak bola umiestnená po komentár alebo príkaz Imports) nebude fungovať správne a / alebo môže spôsobiť nesúvisiace chyby kompilátora.

#ImportDLL s Office Zostavy

Ak máte nainštalovaný Microsoft Office, a váš skript vyžaduje zostavy Office Interop, je možné ich odkazovať jednoducho pomocou #ImportDLL s názvom zostavení (ako je uvedené nižšie, napr. #ImportDLL Excel). Pri použití tejto metódy má tú výhodu, že absolútna dll cesta nemá byť použitý, takže skript je prenosný (mal by fungovať ako na Office 2003 a 2007 bez úprav scenár).

Ak použijete túto funkciu, GAC (Global Assembly Cache) je vyhľadaný zostavenie interop, a skript kompiluje s cestou k tomuto zhromaždeniu v prípade nálezu. Ak to nie je nájdený, bude skriptovanie skontrolujte adresár programu ABACUS (ktorý obsahuje Excel a Visio interops iba). V prípade, že požadovaná interop nie je nájdený do tejto doby, zobrazí sa varovný.

Tieto interops zvyčajne nie sú nainštalované v GAC, ak ste nainštalovali balík Microsoft Office pred inštaláciou rozhrania .NET Framework (ktorá je súčasťou úplnej inštalácie ABACUS). Si môžete nainštalovať prevedením Zmeniť voľbu pre balík Microsoft Office z Pridať / Odobrať programy a vyberte voľby programovateľnosti rozhranie .NET. Pre viac informácií, vidieť článok na webe MSDN.

Zostavy, pre ktoré je podporovaný tento zástupca, sú:

· Prístup

· Access.Dao

· Vynikať

· Graf

· MSProject

· Outlook

· OutlookViewCtl

· OWC11

· Power Point

· Nakladateľ

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Slovo

It, nie je celkom jasné, či všetky vyššie uvedené zostavy sú užitočné, izby havebeen zahrnuté v tomto celovečernom regardeless ako niektorí užívatelia Feb majú potrebu i temných zostáv.

Pozri tiež

Simulácie vašej architektúry