Dodajanje prednastavljene lastnosti komponenta A, povezave ali vrsto

Navigacija: Poselitev svojo arhitekturo> Lastnosti>

Dodajanje prednastavljene lastnosti komponenta A, povezave ali vrsto

Pošlji komentarje o tej temi.

Standardne knjižnice lastnosti lahko določena in dodeljena karkoli drugega v arhitekturi. Te knjižnice so znani kot Standardi. Z uporabo StandardiMorate le zbrati posebne lastnosti sistemov - standardne lastnosti so že tam.

Na primer, se standardne značilnosti delovanja operacijskega sistema Microsoft Windows 2000 lahko shranite kotStandardniin dodeljena vsemi komponentami (ali povezave, ne da bi bilo to tipično) uporabljate operacijski sistem Microsoft Windows 2000.

Če želite dodatistandardnasestavnega dela je, povezave ali vrsto

1. Desni klikna sestavnem delu / povezave / vrsto.

2. Izberite Dodeli Standardni.

3. IzberiteStandardniiz seznama.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Spreminjanje lastnosti komponenta A, povezave ali vrsto | Agregatne lastnosti

© 2001-2015 Avolution Pty Ltd. Vse pravice pridržane.


Agregatne lastnosti

Navigacija: Poselitev svojo arhitekturo> Lastnosti>

Agregatne lastnosti

Pošlji komentarje o tej temi.

Operacija "kopičenje Nepremičnine"Vam omogoča, da dodate vrednosti podobnimi lastnostmi skupaj in pisati (ali doda) rezultat v lastnostih izbranem matične element je. Prav tako vam omogoča, da določite obseg združevanja in ali posodobiti lastnosti vseh pod-elementov ali ne.

Združi lastnosti

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Z desnim klikom na element (arhitektura, sestavni del ali povezave), v katerem opraviti agregacijo in izberite Aggregate Lastnosti.

3. Izberite eno od možnosti Agregatni (Traverse vseh podskladov ravnehali Le Direct Sub-Level). Če ste izbrali Traverse vseh podskladov ravneh, Lahko izberete tudi možnost, ali bi Posodobitev Sub-Ravni.

o Traverse vseh podskladov ravnehpomeni, da se bo obseg združevanja vključuje elemente v vseh stopnjah po izbranem elementu.

o Posodobitev Sub-Ravnise lahko opravi le, če ste tako izbrali možnost Traverse vseh podskladov ravneh. To pomeni, da medtem ko združi lastnosti od spodaj navzgor, bo skupni rezultat na vsaki ravni posodobi tudi v vsakega izmed ustreznih elementov.

o Le Direct Sub-Levelpomeni, da se bo le lastnosti elementov neposredno pod izbranega elementa seštevajo.

o Izberite Vključi StandardniNepremičnineče želite, lastnosti, opredeljene v Standardi ki se vključi. V nasprotnem primeru se bodo uporabljali le lastnosti edinstvene za vsako komponento primer.

4. Izberite katere lastnosti želite združiti. So združeni v svoje Vrste.

5. Kliknite Naslednjagumb.

6. Izberite možnost, ali bi Zamenjevanje starih Vrednoteali Dodaj Valuesv izbranem elementu.

o Zamenjevanje starih Vrednotenapisali rezultate neposredno v lastnosti izbranega elementa.

o Dodaj Valuesbodo dodali rezultate obstoječih lastnosti izbranega elementa.

Poglej tudi

Dodajanje prednastavljene lastnosti komponenta A, povezave ali vrsto | Spreminjanje lastnosti komponenta A, povezave ali vrsto | Vrednotenje svojo arhitekturo


Arhitektura Diff in Sync

Navigacija: Analiza svojo arhitekturo>

Arhitektura Diff in Sync

Pošlji komentarje o tej temi.

Ko imate 2 ali več arhitektur, bodisi kot razvoju dogodkov ali izhodiščne arhitektur, lahko vizualno "diff" dve arhitekture uporabo Katalog ali diagram Primerjava ali Arhitektura Diff značilnost. To je še posebej uporabno za odkrivanje / ponovno odkrivajo natančne spremembe, narejene iz enega arhitekture v drugo, kot si razvijajo arhitekture in razviti načrte v ABACUS.

Če želite pokazati "diff" z drugo arhitekturo preko diagrama

1. Zagotovite imate ABACUS odprto datoteko .

2. Vam zagotoviti, imajo vsaj 2 arhitekture v projektu.

3. Odprite diagram, ki jih želite primerjati z drugo arhitekturo.

4. Kliknite na gumb "Primerjajte to shemo z vsebino drugega arhitekture" v orodni vrstici Diagram.

5. Izberite drugo arhitekturo iz spustnega seznama za primerjavo s.

6. Lahko filtrirate kakšne razlike so prikazane s klikom na gumb "razlik" v orodni vrstici Diagram in odznačite možnosti, na primer Spremenili / dodali / neznana in Nedoločena / Sync Priporočamo/ Imejte Priporočamo.

Opomba

Komponente in povezave na diagramu bodo poudarjene v rdeča, green ali vijolična kjer obstajajo razlike med vsebino, ki je vidna na trenutni sliki in vsebino v drugi arhitekture. Red Uporablja se, kadar je priporočljivo, da Sync razlike (glej spodaj), Green Uporablja se, kadar ni priporočljivo sinhronizirati razlike, ki se jih (glej spodaj) voditi in Vijolična Uporablja se, kadar ABACUS ne more narediti priporočilo o sinhronizaciji razlike (glej spodaj). Vidna vsebina na diagramu primerjamo le, če se zaznamba prikazuje vrednost premoženja po skladišču in ta vrednost se spremeni dano komponento ali povezava bo prikazan v šibek rdeča, šibek zelenaali šibek vijolična in "*" simbol prikazan na vrhu levo za sestavne dele, vendar, če neka druga osnovna vrednost sklenjenih poslov lastnina spremenila, da se ne prikazuje na zapisnik, potem bo dano ne kaže. Vsebina, ki se pojavi na trenutni sliki, vendar nobena tekma se nahaja v primerjavo arhitekture bo prikazana v močna rdeča, močna zelenaali močna vijoličnain "+" simbol prikazan v zgornjem levem za sestavne dele. Matching se opravi glede na vrsto in ime takšno, da se bo, če je tip ali ime komponente ali povezavo spremenila v drugi arhitekturi ne ujemajo najti komponento. Ker ni način zanesljivo ugotavljanje, ali bi dodatno vsebino iz druge strukture so prikazane na trenutni sliki (npr dodaten vmesnik med 2 sestavin, kot je prikazano spodaj v diagramu iz primerjave arhitekture na desni strani), te razlike niso prikazano na slikah (so prikazani za katalogov, kot na spodaj). Lebdi nad vsako spremenjeno postavko bo pokazal razliko v namigu. Lebdi nad simbolom "*" v zgornjem levem diagramu podaja povzetek sprememb (ali brez sprememb) med vsebine diagrama in vsebino druge arhitekture.

Barva Legenda

· Green označuje postavke, ki se ne priporoča sinhronizirati razlike, to je, da jih bo.

· Red označuje predmeti, ki se priporoča za sinhronizacijo razlike.

· Vijolična označuje postavke kjer ABACUS ne more priporočilo o sinhronizacijo razlike.

Če želite sinhronizirati ("sinhronizacije") vsebine iz enega arhitekture z drugo preko diagrama

1. Zagotovite imate ABACUS odprto datoteko .

2. Vam zagotoviti, imajo vsaj 2 arhitekture v projektu.

3. Odprite diagram želite primerjati z drugo arhitekturo.

4. Kliknite na gumb 'Primerjaj ta katalog z vsebino drugega arhitekture "v orodni vrstici Diagram.

5. Izberite drugo arhitekturo iz seznama drop-down za primerjavo s.

Opomba

Glej zgoraj za način ABACUS prikazuje "diff" med 2 arhitekture v katalogu. Zlasti, kako Red Uporablja se, kadar jo jePriporočljivo je, da Sync razlike, Green Uporablja se, kadar je to nePriporočljivo sinhronizirati razlike in Vijolična Uporablja se, kadar ABACUS ne more narediti priporočilo o sinhronizacijo razlike.

6. Z desno tipko miške kliknite diagram element (ali elementov z uporabo Shift ali diagram platno za sinhronizacijo vseh), ki kaže na "diff" in izberite menijski element Sync.

Opomba

Morebitne spremembe sinhronizacija se bo uporabljal samo za arhitekturo, da je trenutno v središču pozornosti Katalog pripada. Če želite uporabiti spremembe za drugo arhitekturo morate uporabiti katalog v drugi arhitekturi. Poleg tega bodo uporabniki lahko uporabljajo spremembe sinhronizacijo, če le ti imeti dovoljenje, da to storijo .

Opomba

Odvisno od tega, kje ste z desno tipko miške kliknite element menija se prikaže napotke o tem, kaj natančno se dogaja, da se sinhronizirajo.Npr Z desnim klikom se bo enotno komponento v diagramu sinhronizirati samo to komponento. Ker desnim klikom na diagram platno in izberete Sync Vse bo sinhronizacijo vse trenutno prikazane razlik.

Če želite pokazati "diff" z drugo arhitekturo preko kataloga

1. Zagotovite imate ABACUS odprto datoteko .

2. Vam zagotoviti, imajo vsaj 2 arhitekture v projektu.

3. Odprite katalog, ki jih želite primerjati z drugo arhitekturo.

4. Kliknite na gumb 'Primerjaj ta katalog z vsebino drugega arhitekture "v orodni vrstici katalogu.

5. Izberite drugo arhitekturo iz spustnega seznama za primerjavo s.

6. Lahko filtrirate kakšne razlike so prikazane s klikom na gumb "razlik" v orodni vrstici Diagram in počistite možnosti, na primer Spremenili / dodali / neznana in Nedoločena / Sync Priporočamo/ Imejte Priporočamo.

Opomba

Celice v katalogu, se bo poudarjeno v rdeča, green ali vijolična kjer obstajajo razlike med vsebine v tekočem katalogu in vsebnosti ujemanja v drugi arhitekture. Red Uporablja se, kadar je priporočljivo, da Sync razlike (glej spodaj), Green Uporablja se, kadar ni priporočljivo sinhronizirati razlike, ki se jih (glej spodaj) voditi in Vijolična Uporablja se, kadar ABACUS ne more narediti priporočilo o sinhronizaciji razlike (glej spodaj). Vidne vrstice in stolpci v katalogu so primerjali le, če obstaja razlika v vrsti presegajo trenutno prikazanih vrstic ali vrednosti v koloni, ki se ni prikazana ima razliko, potem bo nobene razlike označeno. Če je vrednost v posamezni celici drugačen z ujemajočo celico v primerjavi arhitekture bodo poudarjene meje celic. Glava in vrstica stolpca izbirnik bo v senci tudi v šibek vijoličnain prikazan s simbolom "*". Te "*" simboli se lahko kliknili, da skočite na naslednjo razliko v stolpcu ali vrstici oz. Vrstice, ki se pojavi v trenutnem katalogu, vendar nobena tekma se najdemo v primerjavi arhitekture bo prikazana s "+" simbol v izbirniku vrstici na levi in ​​mejo celotnega zapored bodo poudarjene. Vrstice, ki bi se pojavile v različici primerjavo arhitekture v kataloga (tj z istimi filtri, itd), vendar nobena tekma se nahajajo v tekočem arhitekture bodo prikazane z "-" simbol v izbirniku vrstici na levi strani, meje celotna vrstica se bo izpostavil in vsebina celotne vrstice celic bo prikazan v šibek vijoličnain udaril skozi, npr 08:00 do 6pm. Matching se opravi glede na vrsto in ime takšno, da se bo, če je tip ali ime komponente ali povezavo spremenila v drugi arhitekturi ne ujemajo najti komponento. Lebdi nad vsako spremenjeno postavko bo pokazal razliko v namigu. Lebdi nad simbolom "*" v zgornjem levem diagramu zagotavlja povzetek sprememb (ali brez sprememb) med vsebnostjo diagrama in vsebina druge arhitekture.

Barva Legenda

· Green označuje postavke, ki se ne priporoča sinhronizirati razlike, to je, da jih bo.

· Red označuje predmeti, ki se priporoča za sinhronizacijo razlike.

· Vijolična označuje postavke kjer ABACUS ne more priporočilo o sinhronizacijo razlike.

Če želite sinhronizirati ("sinhronizacije") vsebine iz enega arhitekture z drugo prek kataloga

1. Zagotovite imate ABACUS odprto datoteko .

2. Vam zagotoviti, imajo vsaj 2 arhitekture v projektu.

3. Odprite katalog, ki jih želite primerjati z drugo arhitekturo.

4. Kliknite na gumb 'Primerjaj ta katalog z vsebino drugega arhitekture "v orodni vrstici katalogu.

5. Izberite drugo arhitekturo iz seznama drop-down za primerjavo s.

Opomba

Glej zgoraj za način ABACUS prikazuje "diff" med 2 arhitekture v katalogu. Zlasti, kako Red Uporablja se, kadar jo jePriporočljivo je, da Sync razlike, Green Uporablja se, kadar je to nePriporočljivo sinhronizirati razlike in Vijolična Uporablja se, kadar ABACUS ne more narediti priporočilo o sinhronizacijo razlike.

6. Z desno tipko miške kliknite celico, stolpec ali vrstico naslova (ali več predmetov z uporabo Shift ali Ctrl + A za vse, kar je), ki prikazuje "diff" in izberite menijski element Sync.

Opomba

Morebitne spremembe sinhronizacija se bo uporabljal samo za arhitekturo, da je trenutno v središču pozornosti Katalog pripada. Če želite uporabiti spremembe za drugo arhitekturo morate uporabiti katalog v drugi arhitekturi. Poleg tega bodo uporabniki lahko uporabljajo spremembe sinhronizacijo, če le ti imeti dovoljenje, da to storijo .

Opomba

Odvisno od tega, kje ste desni klik (tj celica, stolpec ali naslov vrstice a) menijska bo prikazal smernice o tem, kaj natančno se dogaja, da se sinhronizirajo.Npr Z desnim klikom na eno samo lastnost ali priloženi komponentni celico v katalogu sinhronizirati samo to premoženje ali priloženo komponento. Ker desnim klikom na vrstico postavko (ali postavke, ki uporabljajo Shift) bodo sinhronizirali celotno vrstico (ali vrstic). Z desnim klikom na glavo stolpca bo sinhronizirati vse razlike v tem stolpcu.

Za prikaz 'diff'od 2 Celoten arhitekture

1. Zagotovite imate ABACUS odprto datoteko .

2. Vam zagotoviti, imajo vsaj 2 arhitekture v projektu.

3. Izberite Orodja| Arhitektura Diff ....

4. V pogovornem oknu, ki se prikaže, izberite prvi / S in drugi / Za arhitektur za primerjavo.

5. Kliknite na v redugumb.

Arhitektura Diff

Barva Legenda

· Greenpomeni, da je vozlišče dodamo v drugem / z arhitekturo.

· Redkaže, da je vozlišče črta na sekundo / Do arhitekture.

· Bluekaže, da ima vozlišče drugačne lastnosti (na primer lastnosti ali standardov) v drugem / do arhitekture.

· Rumenakaže, da ima vozlišče razlike v svojih otrocih v drugem / V arhitekturi, zato je treba razširiti vozlišče.

Opomba

Lahko z desno tipko miške kliknite in "Show v Raziskovalcu" na vseh vozliščih za prikaz podrobnosti in več informacij je podana na razlike v zbirnem razlike plošče, ko je izbrano vozlišče.

Poglej tudi

Analiziranje svojo arhitekturo | Pregled odzivni čas grafikon | Pregled matriko scatterplot vaših razvijal arhitektur | Razvija svojo arhitekturo


Spreminjanje lastnosti komponenta A, povezave ali vrsto

Navigacija: Poselitev svojo arhitekturo> Lastnosti>

Spreminjanje lastnosti komponenta A, povezave ali vrsto

Pošlji komentarje o tej temi.

Lastnosti so ponavadi sistemske zahteve, ki jih določite, ali se rezultati ocenjevanj Abacus '. (Ko ABACUS opravlja svoje ocene, da piše lastnosti nazaj v datoteki.) Z drugimi besedami, lastnosti so stvari morate vedeti o vašem sistemu, ali stvari, ki jih uporabljate ABACUS izvedeti.

Če želite spremeniti vrednost lastnosti komponente A, povezave ali vrsto

1. Kliknitena sestavnem delu / povezave / tipa (bodo njegove lastnosti prikaže v oknu Properties na desni).

2. Klikniteizpostaviti lastnost, ki jo želite spremeniti.

3. Tipnova vrednost.

Pomembno

Prav tako so številne lastnosti, opredeljene po Standardi . S spreminjanjem nepremičnine v drugoStandardniPa ne le spremeniti trenutno predmet, ga tudi spremenite gospodarja Standardni (pod Standardi nazgornji del drevesa). Pred tem preverite, kaj drugi deli, priključki ali so tipi uporabo StandardniKer sprememba ne sme biti pomembno za njih- Lahko uporabite okno referenc za to.

Nasvet

Lahko spremenite lastnosti vzpostavljena povezava je od znotraj Components veje drevesa (in obratno). Tako, na primer, če iščete kaj povezave so pritrjena na komponento, in se zavedaš, boste morali spremeniti eno, lahko.

Da za sestavni del ali povezavo dodajanje novih lastnosti (po tipu)

Opomba

Lastnosti je mogoče dodati samo na tipe in njihove sestavne dele ali priključkov tipa "podedoval" tiste lastnosti.

1. Kliknitena vrsto (bodo njegove lastnosti prikaže v oknu Properties na desni).

2. Kliknitena gumb Dodaj na vrhu okna Property dodati vrstico na vrhu omrežja objektu za novo lastnost.

3. Dodaj Tipza novo lastnost.

4. Dodaj Nameza novo lastnost.

5. Dodaj Privzeta vrednostza novo lastnost.

6. Dodaj Enotaza novo lastnost.

7. Nastavite Data Typeza novo lastnost.

Opomba

Polje Vrsta podatkov se lahko uporabi za omejevanje veljavne vrednosti, ki so lahko premoženje. To je; Besedilo, Integer, decimalno, datum / čas, Boolean ali Seznam.

o A Besedilolastnost je tista, ki ima neomejeno število znakov in v bistvu nima nobenih omejitev glede vrednosti.Če je vrednost premoženja je pravilno oblikovano hiperpovezave (tj URL-ji morajo začeti z enim od 5godala; http: //, https: //, ftp: //, mapa:ali \\ in vseprostore je treba vpisati z "% 20 '), Potem je povezava klikniti (preko CTRL + klik).

o Integerlastnina mora biti celo število, bodisi pozitiven ali negativenin lahko vsebujejo obdobju prostor, opuščaj ali vejico za mestno skupino glede na projekt je Nastavitve regije od Datoteka | Možnosti projekta.Nastavitve regija in.Net Long.TryParse metoda je uporablja za določanje veljavna Integervrednosti.

o A Decimalnopremoženje lahko vsebuje obdobje ali vejica za decimalni simbol in lahko vsebujejo obdobju prostor, opuščaj ali vejico za mestno skupino glede na projekt je Nastavitve regije od Datoteka | Možnosti projekta.Nastavitve regija in.Net Decimal.TryParse metoda je uporablja za določanje veljavna Decimalno vrednosti.

o A Datum časlastnost omogoča bodisi Datum del ali krajši delovni čas ali oboje. RegijaNastavitvein .Net DateTime.TryParse metoda se uporabljajo predvsem za določitev veljaven datum in / ali časovne vrednosti. Vendar Datum del po potrebi zahteva vsaj dan in mesec (leto bo domneva, da je v tekočem letu) ali mesec in leto deli veljavna. Tj Junij, Q3 2010 ali celo samo 2010 so neveljavne. Medtem ko bo razlikujejo z različnimi regionalnimi nastavitvami, običajno lahko deli Dan, mesec in leto, je treba ločiti s presledkom, z vejico dash ("-") ali poševnico ("/"). Dan del običajno je celo število od 1 do 31. Mesec del je običajno celo število od 1 do 12, veljavna 3 črka kratica za mesece (npr jan, feb, mar) ali ime cel mesec (na primer januar, februar marec). Leto del je običajno 4 mestna pozitivno število, ampak 1, 2 in 3 mestno let so sprejete v skladu z nastavitvami na nadzorni plošča-> Področne in jezikovne Options-> Regionalna Options-> Prilagodi (gumb) -> Date-> Koledar. Značilno se razume kot sledi; 0-29 je razlagati tako, 2000-2029, 30 do 99, kot 1930-1999 in 100-999 kot 100-999. Neveljavni datumi kot 31. junij 2010 in 31/9/2010 bo zaznal. The Time del po potrebi zahteva urah in minutah del in opcijsko Seconds delov. Ure, minute in opcijski deli Seconds so običajno ločeni z dvopičjem (":") in del Seconds se lahko določi z decimalno vejico ("."). Za dodatne informacije o veljavnih formatih najdete v razdelku Opombe na Net DateTime.TryParse metoda .

Nasvet

Priporočljivo je, da uporabljate vsaj 3 črke format mesec imena (tj "julij" ali "julij") za datumskih vrednosti namesto numerično oblikovanja (tj "7" ali "07"), kot je teh vrednot bo preveril čez večini regij, odvisno na projektu je Nastavitve regije od Datoteka | Možnosti projekta.Tj je priporočljivo, da uporabite "15 Jul 2010" namesto "15/7/2010" ali "7/15/2010". V tem primeru, "15/7/2010" ne bi bila uspešna potrditev za "angleščina (Združene države)" in "2010/07/15" ne bi bila uspešna za 'English (United Kingdom) ", vendar" 15. julij 2010 "bi prenesli za oboje.

o A Booleanlastnina je lahko True ali False.To je velikost črk se tako TRUE ali FALSE lahko pa se uporablja tudi da, ne, 1, 0 etc bodo vsi ne nobenih omejitev lastnine.

o A Seznamlastnost omogoča zbirko vnaprej opredeljenih vrednosti, kot so Low | Medium | Visoka ali obdržati | Osvežite | Redesign | Upokojiti in razpon vrednosti prihaja iz področja enote za premoženje bodisi kot vejico ali cevi "|" Vrednosti, ločene. Premoženje se lahko šteje, da je ordinalna (v nasprotju z nominalno, interval ali razmerje), saj, če se uporablja na kartah in obarvati elementov na diagramov in 3DS vrednosti se obravnavajo zgolj v naraščajočem (ali padajočem) naročila. To je vrednosti so narisane na naraščajoče (ali padajoče) odredbo o grafikona osi ali barvnih obsegov.

8. Data Type lahko nastavite, da se Onemogočeno, Opozorilali PrisilnaType polje podatkov za katero koli nastavitev razen Besedilo, ki omogoča vse znake, tako da ne more nikoli biti napačna z desnim klikom.

9. Nastavite Zahtevanazastave za nove nepremičnine.

Opomba

Zahtevana polje se lahko uporablja za označevanje, ali je treba vrednost, ki se vnesejo v nepremičnine. To pomeni, da ne more biti prazna ali prazni. Falseje privzeto in pomeni, da je premoženje je lahko prazna ali prazno, Truepomeni, da mora imeti lastnost vrednost in ne more biti prazna ali prazno. Zahtevana lahko nastavite, da se Onemogočeno, Opozorilali Prisilnazahtevano polje z desnim klikom, če je bila nastavljena na True.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Dodajanje prednastavljene lastnosti komponenta A, povezave ali vrsto | Agregatne lastnosti


Spreminjanje sestavnih delov / povezovalnega Type

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Spreminjanje sestavnih delov / povezovalnega Type

Pošlji komentarje o tej temi.

Sestavni in priključitev tipi so v glavnem uporabljajo za namene razvrstitve. Lahko uporabite vrste kot filtri, ko gledate svojo arhitekturo. Na primer, namesto da gledate na celotno stvar, si lahko ogledate le komponente Application.

Če želite spremeniti sestavnih delov / povezovalnega Type

1. Desni klikna komponento ali povezave.

2. Izberite Spremeni Type.

3. Izberite drugo vrsto s seznama.

Nasvet

Ko spremenite tip, boste morda dobili nekaj novih Standardiali lastnosti (vse, kar je povezanega z vrsto - glej podružnico vrsta drevesa). Vaš obstoječi Standardi in lastnosti, bo ostala nespremenjena. Lahko ustvarite svoje nove vrste in dodelite svoje kombinacije Standardi in lastnosti nanje.

Poglej tudi

Ustvarjanje novega tipa | Poselitev svojo arhitekturo - Pregled | Analiziranje Vaše arhitektura


Spreminjanje nastavitev projekta je Regija

Navigacija: Poselitev svojo arhitekturo> Lastnosti>

Spreminjanje nastavitev projekta je Regija

Pošlji komentarje o tej temi.

Vrednosti nepremičnin zahtevajo nekatere oblikovanje v različnih regijah, da se ujema z nobenim Podatki Tip omejitve za Integer, decimalko in datum / čas lastnosti. Na primer v Avstraliji decimalnih "123456 točka sedem osem devet" je predstavljen kot "123,456.789", medtem ko bi v Nemčiji se represnted kot "123.456,789" in v Franciji, da bi bilo " 123 456789 ".Podobno je v ZDA, "drugi iz decembra 1970", ki je zastopana kot kratek dan kot "12/2/1970", ampak v Združenem kraljestvu je prikazana kot "2/12/1970" in na Poljskem kot "1970-1912 -02 ". Skladno s tem, da delajo s projektom ABACUS po regijah je potreben globalen nastavitev na projekt ABACUS.

Spremeniti Nastavitve projekta Abacus je Regija

1. Zagotovite imate ABACUS datotekaopen.

2. Izberite Datoteka | Možnosti projekta ... in iz pogovornega okna, ki se pojavi izberite Regijain kliknite OK. Opomba: Prosimo, glejte razdelek spodaj za regionalne nastavitve.

Opomba

Če ne vidite Možnosti projekta ... menu itempotem nimate Designer in Administrator dodateksin ne morete spremeniti regijo projekta.Tudi, če se ne Region nastavljena (tj regiji v Možnosti projekta je "Nihče (sistem regija)"), nato pa vsak Nastavitve sedanja kultura uporabnikove MS Windows (tj Regional Settings)se uporablja za potrditev lastnosti.

Regija neplačil

V spodnji tabeli so navedeni privzete nastavitve za vsako regijo, kot je določena skozi Datoteka | Možnosti projekta ...menu item.Za seznam uporabljenih simbolov glejte spodnji tabeli.

Regija | Decimalno Symbol | Digit združenje | Negativni predznak | Kratek čas | Dolgo časa | AM / PM simbol | Kratek Datum | Long Datum
Angleščina (Avstralija) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / llll | dd MMMM llll
Angleščina (Združeno kraljestvo) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / llll | dd MMMM llll
Angleščina (Združene države Amerike) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / llll | dddd, MMMM dd, yyyy
Francoščina (Francija) | , | prostor | - | Hh: mm | HH: mm: ss | | | dd / mm / llll | dddd d MMMM llll
Nemščina (Nemčija) | , | . | - | Hh: mm | HH: mm: ss | | | dd.mm.llll | dddd, d. MMMM llll
Italijanščina (Italija) | , | . | - | Hh: mm | HH: mm: ss | | | dd / mm / llll | dddd d MMMM llll
Španščina (Španija) | , | . | - | H: mm | H: mm: ss | | | dd / mm / llll | dddd, dd 'de' mmmm 'de' llll
Angleščina (Kanada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / mm / llll | MMMM-dd-ll
Francoščina (Kanada) | , | prostor | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM llll
Arabščina (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / llll | dd MMMM, yyyy
Arabščina (Saudova Arabija) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / mm / ll | dd / MMMM / llll
Angleščina (Južna Afrika) | , | prostor | - | hh: mm tt | hh: mm: ss tt | AM | PM | llll / MM / dd | dd MMMM llll
Angleščina (Nova Zelandija) | . | , | - | h: mm tt | h: mm: ss tt | Pred talne | p.m. | d / MM / LLLL | dddd, d MMMM llll
Angleščina (Indija) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd-MM-llll | dd MMMM llll
Nemščina (Švica) | . | ' | - | Hh: mm | HH: mm: ss | | | dd.mm.llll | dddd, d. MMMM llll
Francoščina (Belgija) | , | . | - | Hh: mm | HH: mm: ss | | | d / MM / LLLL | dddd d MMMM llll
Nizozemščina (Belgija) | , | . | - | H: mm | H: mm: ss | | | d / MM / LLLL | dddd d MMMM llll
Češka (Češka) | , | prostor | - | H: mm | H: mm: ss | dop. | odp. | d.M.yyyy | d. MMMM llll
Danščina (Danska) | , | . | - | Hh: mm | HH: mm: ss | | | dd-MM-llll | d. MMMM llll
Grščina (Grčija) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / llll | dddd, d MMMM llll
Finščina (Finska) | , | prostor | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta "yyyy
Madžarščina (Madžarska) | , | prostor | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | llll. MMMM d.
Nizozemščina (Nizozemska) | , | . | - | H: mm | H: mm: ss | | | d-M-llll | dddd d MMMM llll
Norveščina, slovenščina (Norveška) | , | prostor | - | Hh: mm | HH: mm: ss | | | dd.mm.llll | d. MMMM llll
Poljščina (Poljska) | , | prostor | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | d MMMM llll
Ruščina (Rusija) | , | prostor | - | H: mm | H: mm: ss | | | dd.mm.llll | d MMMM yyyy "г."
Švedščina (Švedska) | , | prostor | - | Hh: mm | HH: mm: ss | | | yyyy-MM-dd | "den" D MMMM yyyy
Korejščina (Koreja) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | yyyy-MM-dd | yyyy "년 'M' 월 'd' 일 'dddd
Hebrejščina (Izrael) | . | , | - | Hh: mm | HH: mm: ss | AM | PM | dd / mm / llll | DDDD dd MMMM llll

Naslednji simboli se uporabljajo za določitev, kako so prikazani datumi in ure:

Čas simboli |
h | Ura (hh prikaže uro z vodilno ničlo)
m | Minute (mm prikaže minuto z vodilno ničlo)
s | Drugi (ss prikazuje drugo z vodilno ničlo)
tt | A.M. ali p.m.
h / H | 12 ali 24 urni prikaz časa
Datum simboli |
d, dd | Dan
ddd, dddd | Dan v tednu
M | Mesec
y | Leto

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Spreminjanje lastnosti komponenta A, povezave ali vrsto | Dodajanje prednastavljene lastnosti komponenta A, povezave ali vrsto


Možnosti ukazne vrstice

Navigacija: Reference>

Možnosti ukazne vrstice

Pošlji komentarje o tej temi.

Lahko opravljajo različne operacije ABACUS neposredno v ukazni vrstici z najpogostejša operacija pa odpreti posebno projektno datoteko in jo objavi v HTML.

Natančneje, uporaba ukazni vrstici ABACUS je, kot sledi;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "USER" / pass "PASS"]

Prepir | Opis
ProjectFile | ProjectFile je lahko projekt datoteka ABACUS (.abacus), knjižnica datoteka (.abacuslib), datoteka XML (.xml) ali MS Access DB (.mdb) in izbrana datoteka se bo bodisi odprta (če .abacus ali .abacuslib ) ali nov projekt ustvaril (če .xml ali datoteka .mdb).
OptionalFile | OptionalFile lahko bodisi skript ABACUS (.abacusscript, .vb ali .cs), macro (.abacusmac) ali datoteka knjižnica (.abacuslib) in izbrana datoteka se bo bodisi teči po odprtju ProjectFile (če .abacusscript, .vb ali .cs ali .abacusmac) ali pa enostavno odpreti (če .abacuslib).
/ exitOnCompletion | Bo izhod ABACUS in, če je potrebno prihranite in zavezati vse spremembe odprtih projektov .abacus o zaključku kakršnega koli skripte ali makro. Opomba: Ta zastava je Case Sensitive, tako se prepričajte, da uporabite velike črke "O" in "C" v besedilu, kot je prikazano.
/ dontShowDialogs | Bo preprečilo ABACUS Enterprise Edition (EE) pogovornih obvestil update prikazovali ob odprtju projekta. Opomba: Ta zastava je Case Sensitive, tako se prepričajte, da uporabite velike črke "S" in "D" v besedilu, kot je prikazano.
/ uporabnik "USER" / pass "PASS" | Uporabniško ime uporabnika in geslo, prestati se bodo uporabili za prijavo v projekt s, nujnimi nobene shranjene poverilnice uporabnikov. Opomba: Dvojni narekovaji morajo biti nameščene okoli uporabnika in mimo zastav in dve dvojni narekovaji se lahko uporabi za pobeg dvojne narekovaje v obeh uporabnik ali mimo zastave.

Npr;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / uporabnik "Public" / pass "123456"

kdaj teči od imenika, kjer ABACUS.exe binarni je nahaja bo open Projekt Primer in se prijavite kot uporabniškem javnosti z geslom 123456 (kot je opisano tukaj ), Jo objavi v HTML in nato zaprite projekt vsi ne kažejo nobenih pogovorna okna na poti (na primer "Update uspešno" ali "ni na voljo nobenih posodobitev" za projekte za podjetništvo).

Npr;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalog Excel Import.vb"/ exitOnCompletion / dontShowDialogs

kdaj teči od imenika, kjer ABACUS.exe binarni je nahaja bo open Projekt Primer in uvoz "strežniki (2014 Actual) .xlsx" MS Excel datoteko v katalogu "strežniki" o "2014 Actual" arhitekture projekta, ne kaže nobenih pogovorna okna na poti in nato zapiranje projekta po zaključku. Če je operacija naredi spremembe v projektu nato pri zapiranju so spremembe shranjene lokalno in če projekt Enterprise zavezana Enterprise Server.

Opomba

Bodite prepričani, da uporabite pravilno dvojni narekovaj saj obstaja več v standardnem naboru ASCII znakov in Windows Command Prompt bo pravilno deloval le s pravimi. Pravilna dvojna koda narekovaj je decimalko 34 (šestnajstiški 22).To je tisto, kar se uporablja v primeru zgoraj, zato vas prosimo, da kopirate / prilepite od tam.


Kopiranje in lepljenje

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Kopiranje in lepljenje

Pošlji komentarje o tej temi.

Lahko kopirate del ali vse svoje arhitekture in ga prilepite na drugo mesto v drevesu.

Če želite kopirati

1. Desni klikna postavki želite kopirati.

2. Izberite Kopiraj.

Prilepiti

1. Krmarjenje drevo, da bi našli kraj, ki ga želite prilepiti element.

2. Desni klikna veji želite, da se v okviru prikazani.

3. Izberite Paste.

4. Predmet se kopira s prvotnim imenom (razen, če ga boste kopirali v prvotni vejo - potem pa se bo imenoval "Kopija ...").

Poglej tudi

Kako se arhitektura zastopana v ABACUS


Kopiranje diagrami

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Kopiranje diagrami

Pošlji komentarje o tej temi.

Obstajata 2 osnovni scenariji za kopiranje obstoječo shemo; v arhitekturi, ali čez arhitektur.

Če želite copydiagramv arhitekturi

1. Zagotovite imateABACUS odprto datotekoz vašim naseljeno arhitekturoz vsaj enim diagram.

2. Razširi Diagramipodružnica (in vse potrebno Diagram skupine) za dano ArhitekturaDel drevesa.

3. Izberite diagram želite kopirati, in nato pritisnite Ctrl + Cali desni klikin izberite Kopiraj iz menija.

Opomba

A izvod Shema bo dodana k Diagramipodružnica Enako arhitekture. To bo imelo "Kopija" doda začetku imena, Ki jo lahko kasneje spremenite s pritiskom na F2 ali desni klik na njejin izberete Rename.

Če želite Kopiranje diagram čez arhitektur

1. Zagotovite imateABACUS odprto datotekoz vašim naseljeno arhitekturosz vsaj enim diagram.

2. Razširi Diagramipodružnica (in vse potrebno Diagram skupine) od ArhitekturaDel drevesaza arhitekturo, ki vsebuje diagram, ki ga želite kopirati.

3. Izberite diagram želite kopirati in na Splošni LastnostiOkno Opomba Vaše mnenje da je diagram povezana z (v polju Type).

4. Zdaj, razširiti Diagramipodružnica (in vse potrebno Diagram skupine) od ArhitekturaDel drevesaza druge arhitekture, ki želite kopirati diagram v.

5. Desni klik Diagrami vozlišče (ali Diagram skupina) In izberite Ustvarite diagram .... V pogovornem oknu, ki se prikaže, izberite Vaše mnenje ki je bilo ugotovljeno v koraku 3 zgoraj v spustnem meniju v desnem zgornjem kotu. Pusti vse ostalo, kot je, in kliknite v redu. V pogovornem oknu Slika Ime vnesite ime za (kmalu) kopirali diagram. Opomba: se bo odprla prazna diagram platno v skladu z izbrano vidika.

6. Vrni se na sliki, ki jo želite kopirati, in odpre, da ga Z desnim klikomvozlišče in izbiranje Odpri ali pa preprosto dvoklikga.

7. Izberi ozadje platno diagrama, ki ga želite kopirati, in pritisnite Ctrl + A. To bo izbrati vse elemente na tej sliki. Sedaj pritisnite Ctrl + CKopirajte vsebino v odložišče.

8. Zdaj, se vrnite na slepem diagram v arhitekturi, ki jo želite kopirati vsebine v, izberite ozadjeplatno in bodisi desni klikin izberite Paste ali pa preprosto pritisnete Ctrl + Vprilepiti vsebine. Po kratkem času se bo vsebina vsi prilepiti nov prazen diagram.

Opomba

Elementi, ki jih bodo dodali na najvišji ravni nove arhitekture in bo treba preuredijo ali združila z obstoječo vsebino ustrezno.

Poglej tudi

Orodje za risanje | Poselitev svojo arhitekturo | Analiziranje Vaše arhitektura


Ustvarjanje novega sestavnega dela / povezave ali tipski Group

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Ustvarjanje novega sestavnega dela / povezave ali tipski Group

Pošlji komentarje o tej temi.

Sestavni in priključitev tipi so v glavnem uporabljajo za namene razvrstitve. Lahko uporabite vrste kot filtri, ko gledate svojo arhitekturo. Na primer, namesto da gledate na celotno stvar, si lahko ogledate le komponente Application.

Če želite ustvariti novo komponento / Vrsta povezave

Opomba

Če želite dodati vrst ali skupin tipa v projektu ABACUS licenca uporabnik potrebuje oblikovalca dodatek sposobnosti. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

1. Razširiti Vrsteveja drevesa.

2. Desni klikna Sestavni Vrste(ali Vrste povezava).

3. Izberite Dodaj Component Type(ali Dodaj Vrsta povezave) Ali Ustvari skupino.

Nasvet

Ko ste ustvarili vrsto, bi morali spremeniti svojo ikono (glej spodaj) in dodamo Lastnosti in Standardi z njim za sestavni del ali priključnih primerkov na "podedovali".

Če želite spremeniti ikono sestavnega / Vrsta povezave

Opomba

Če želite spremeniti ikone za tipe v projektu ABACUS licenca uporabnik potrebuje oblikovalca dodatek sposobnosti. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

1. Desni kliko Komponenta Type(ali Vrsta povezave), Ki jo želite spremeniti ikono.

2. Izberite Change Icon.

3. V pogovornem brskanje Izberite ikono na lokacijo in izberite slikovno datoteko in kliknite Odpri.

Opomba

Lahko imaš ikone po meri podobo vseh velikosti, vendar pa bo vedno prilagodi tako, da se prilega na 16x16 pikslov slike v Explorer okno. Torej, če je vaša izvirna ikona po meri slika ni enake višine in širine vaš logo Window Explorer raztegnjena. Zato bi bilo treba slike po meri biti vsaj 16x16 pikslov in če želite ohraniti natančno obliko ikone po meri, se prepričajte, vaš logo meri slika je enaka višina in širina v slikovnih pikah (16x16 ali večje). Prav tako morate biti previdni, ne ob obarvanih "pik" gredo vse do meje z ikono meri podobo, kakor da bo videti slaba v Explorerju oknu s sosednjimi ikone "krvavitev" v drug drugega. Skladno s tem bi morali pustiti vsaj 1 pixel belo obrobo a.

Nasvet

Lahko naredite vaš logo custom slika .ico, .bmp, .gif, .jpg ali .png format datoteke, vendar zaradi omejitev v operacijskem sistemu Windows bo le .ico format predogled v oknu ABACUS Izberite ikono, če imate možnost View Meni nastavljen na karkoli drugega kot Sličice.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Analiziranje Vaše arhitektura


Ustvarjanje ali podvajal arhitekturo

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Ustvarjanje ali podvajal arhitekturo

Pošlji komentarje o tej temi.

Imate lahko poljubno število arhitektur v enem ABACUS datoteko. Značilno je, da bi ustvarili novo arhitekturo vsakič, ko želite, da model in ovrednotiti razvoj vašega sistema.

Če želite ustvariti novo arhitekturo

1. Desni kliko Arhitektureveja drevesa.

2. Izberite New Architecture.

Če želite ustvariti kopijo obstoječe arhitekture

1. Desni klikna arhitekturo.

2. Izberite Kopiraj.

3. Desni kliko Arhitektureveja drevesa.

4. Izberite Paste.

5. Nova arhitektura se bo imenoval "Kopija ...".

Razvijati obstoječo arhitekturo

1. Desni klikna arhitekturo.

2. Izberite Evolve.

3. Nova arhitektura se bo imenoval "... 0,1".

Opomba

Na voljo je podroben opis na razvijajočih arhitekturah tukaj .

Poglej tudi

Kako se arhitektura zastopana v ABACUS | Razvija svojo arhitekturo


Poročila po meri

Navigacija: Poročanje o vaši arhitekturi>

Poročila po meri

Pošlji komentarje o tej temi.

Poročila po meri Abacus 'vam omogočajo, da ustvarite popolnoma prilagodljivih poročil po meri. Poročila lahko vključujejo meri slike in grafike, kot tudi podrobno koli komponente, povezave ali atributov iz odlagališča ABACUS kakor tudi podrobnih analitičnih rezultatov iz različnih simulacij (vključno TCO, zmogljivost in zanesljivost). Poleg tega se lahko poročila vsebujejo diagrame, grafikone, kataloge, matrike / vrtilne tabele, zemljevide, merilniki, sparklines, podatkovne barov in kazalniki (npr prometa luči).

Opomba

Medtem ko se lahko vsak uporabnik odpreti obstoječe poročila po meri, to configure Poročila potrebuje dovoljenje uporabnik Configuration Report sposobnost. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

Za prikaz po meri Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo(i).

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po merise prikaže okno.

Poročila po meriokno

3. Izberiteobstoječe Poročiloki jih želite Za prikaz Iz Razpoložljivi Poročilaoddelek.

4. Kliknite Run Report.Poročilo se bo odprla v Microsoft Poročilo Viewer in to Krmarjenje po straneh poročila, kliknite na ikone [image] ki se nahaja v orodni vrstici na zgornjem levem kotu zaslona.

Opomba

Ti lahko shranite Poročilo v različnih formatih s klikom na Izvoz icon Poročilo [image] nahaja v orodna vrstica. Lahko se odločite za izvoz v naslednjih formatih: Excel, PDFin Beseda. Prosimo, shranite poročilo v želeno mesto za poznejšo uporabo. Če so spremembe na arhitekturi pozneje, bo novo poročilo je treba ustvariti, da odražajo spremembe.

Če želite uredite podatke o skladišču, ki je poslano a po meri Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo(i).

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po meriokno (prikazana zgoraj) bodo prikazani.

Opomba

Medtem ko se lahko vsak uporabnik odpreti obstoječe poročila po meri, to configure podatki, ki se pošlje poročila po meri potrebuje dovoljenje uporabnik Configuration Report sposobnost. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

3. Izberiteobstoječe Poročiloki jih želite Za prikaz Iz Razpoložljivi Poročilaoddelek.

4. Kliknite Kompleti Urejanje podatkov. Data Set Editorse prikaže okno.To okno prikazuje zbirko podatkovnih nizov, ki se trenutno pošiljajo poročila po meri. V spodnjem primeru obstajajo tri (3);

· ApplicationProxy niz podatkov, ki se opredeljuje vse podrobnosti za vse komponente aplikacij, v "2015 Actual" arhitektura (vključno z lastnostmi o svojih standardih in morebitnih vgrajenih komponent),

· podatkovni TwoDViewProxy niz, ki se navede eno ali več diagrami, kjer je ime vžigalice "Application Landscape (Avstralija)",

· TargetProxy niz podatkov, ki se opredeljuje vse podrobnosti za vse ciljne priključkov v "2015 Actual" arhitektura (vključno s priloženimi komponentami).

Data Set Editorokno

Opomba

Query ime bo uporabljeno za ime Nabor podatkov v Microsoft Oblikovalca poročil (glej spodaj). Vključi polje določa, ali je nabor podatkov bodisi en sam element, zbirka elementov, vsi sestavni deli vrste, vse vrste povezav, eno ali več arhitektur, enega ali več diagrami ali eno ali več kart. Za "zbiranje elementov" podatkov določa gumb za Filter je na voljo, ki ob kliku odpre okno element filtra, ki vam omogoča, da uporabljajo več filtrov vrniti le elemente iz določene arhitekture, in / ali določenih vrst, in / ali z nekaterimi standardi in / ali pritrjeni na določenih sestavnih delih in / ali z nekaterimi starši, in / ali v nekaterih diagrami, in / ali v nekaterih Charts in / ali z danimi vrednostmi lastnine. Za druge vrste zastavljenih podatkov je ime polja, če in uporabi gumb Izberi si lahko izberejo predmet (e), ki se vključi s podatkovnim nizom.

Opomba

Podatkovni nizi so shranjeni naData Sets datoteko (.xml)z istim imenom osnovne datoteke kot povezana Poročilo Opredelitev datoteke (.RDL). Če ta datoteka ne obstaja, bo nabor podatkov urejevalnik samodejno zapolnijo z vsemi imeni poizvedbe, ki obstajajo v Poročilo Opredelitev datoteke (.RDL)in nov Data Sets datoteko (.xml)bo ustvarjen, ko je aa veljaven seznam poizvedb opredeljena.

3. Če želite izbrisati obstoječi nabor podatkov, nato izberite Izbriši poizvedbogumb.

4. Če želite dodati nove podatke, določene nato kliknite Dodaj nov Data Setgumb in nastavite nabor podatkov, kot na opombo zgoraj.

Če želite ustvariti nov meri Poročilo(iz predloge)

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo.

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po meriokno (prikazana zgoraj) bodo prikazani.

3. Kliknite New in izberite bodisi A4 - Portret, A4 Landscape, A3 - Portret, A3- Landscape, US Letter - Portret, US Letter - Landscape, US Tabloid - Portretali US Tabloid - Landscapeodvisno od velikosti poročilo orientacije in papirja, ki je zaželen.

4. Brskanje na lokacijo, da shranite Prijavi Definition datoteko (.rdl / .rdlc) in ujemanje Data Set datoteke (.xml) in kliknite Shrani. To bo dodati novo poročilo po meri na voljo rubriki Poročila okna Poročila po meri in ga je mogoče odpreti ali uredili, kot je opisano zgoraj.

Če želite dodati obstoječ meri Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo.

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po meriokno (prikazana zgoraj) bodo prikazani.

3. Kliknite Dodaj in poiščite lokacijo Poročilo Definition datoteke (.rdl / .rdlc) in kliknite Odpri. To bo dodati novo poročilo po meri na voljo rubriki Poročila okna Poročila po meri in ga je mogoče odpreti ali uredili, kot je opisano zgoraj.

Opomba

Predpostavlja se, da obstaja ujemanje Data Set datoteke (.xml) na isti lokaciji kot datoteko Poročilo ločljivosti.

Če želite kopirati obstoječo meri Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo.

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po meriokno (prikazana zgoraj) bodo prikazani.

3. Izberiteobstoječe Poročiloki jih želite kopirati Iz Razpoložljivi Poročilaoddelek.

4. Kliknite Kopiraj in kopijo izbranega poročila (imenovana "Kopija ..."), bo dodana na voljo rubriki Poročila okna Poročila po meri in ga je mogoče odpreti ali uredili, kot je opisano zgoraj.

Opomba

S tem boste ustvarili kopijo poročila je Poročilo Opredelitev mapa (.rdl / .rdlc) kot tudi njene ujemanje Data Set datoteke (.xml)(če obstaja).

Če želite odstraniti obstoječo meri Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo.

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po meriokno (prikazana zgoraj) bodo prikazani.

3. Izberiteobstoječe Poročiloki jih želite odstraniti Iz Razpoložljivi Poročilaoddelek in klik Odstrani.

Opomba

Ko odstranite poročilo ne bo več pojavil na seznamu poročila. Vendar pa to ne bo zbrisati poročila je poročilo Opredelitev mapa (.rdl / .rdlc) ali Data Set mapa(.xml). Če je potrebno, lahko izbrišete te datoteke je treba doseči prek datotečnega sistema.

Če želite preimenovanje obstoječega meri Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo.

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po meriokno (prikazana zgoraj) bodo prikazani.

3. Izberiteobstoječe Poročiloki jih želite preimenovati v Razpoložljivi Poročilaoddelek in klik Preimenovanje.

4. Vnesite novo ime za poročilo.

Opomba

Oba Poročilo Definition datoteka (.rdl / .rdlc) in ujemanje Data Set datoteke (.xml), se bo v skladu s tem preimenovala.

Če želite uredite zasnova po meri Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo.

2. Izberite Insert| Poročilo po meriali pa kliknite Ustvari poročilo po meri orodna vrstica gumb. Poročila po meriokno (prikazana zgoraj) bodo prikazani.

Opomba

Medtem ko se lahko vsak uporabnik odpreti obstoječe poročila po meri, to configure oblikovanje poročil po meri potrebuje dovoljenje uporabnik Configuration Report sposobnost. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.Poleg tega Microsoft Report Builder 3.0 je potreben za oblikovanje poročila in ga lahko prenesete brezplačno iz tukaj .

3. Izberiteobstoječe Poročiloki jih želite Za prikaz Iz Razpoložljivi Poročilaoddelek.

4. Kliknite Uredi poročilo.Poročilo se bo odprla v programu Microsoft Oblikovalca poročil 3.0. Za posebno pomoč in nekaj "nasvetov in trikov" na nekaj več skupnih nalog z oblikovanjem poročila si oglejte v spodnjih oddelkih. Za splošno pomoč pri načrtovanju poročil poglejte za Microsoft Report Builder straneh 3,0 pomoč tukaj .

Dodajanje tabel na vašem poročilu

1. Zagotovite, da imate Poročilo ABACUS meri Opredelitev datoteka (.rdl / .rdlc) odprta v programu Microsoft Oblikovalca poročil 3.0.

2. Izberite Insert Jeziček v "traku" na vrhu, nato kliknite Preglednica Gumbv rubriki Podatki regij in izberite Vstavi tabelo.

3. Zdaj povlecite kazalecdo položaja na poročilu platnu, kjer želite zgornjem levem kotu tabele dajejo. Kliknite na platno. Privzeto se bo tabela dodana z naslovni vrstici in nato skupino podrobnosti (skupina se uporablja, da se organizira pogled na poročilo CCD). Če želite odstraniti skupino, bodisi izbrisati vrstico ali izbrišete skupino Row v orodni vrstici združenje.

Nasvets

Formule / izrazov v celicah tabele so uredili tako, da izberete celico z desno tipko miške kliknete << Expr >> besedilo in izberete Expression .... Sortiranje vrstice v tabeli, se opravi tako, da izberete tabelo in nato brskanje navzdol na drugi strani -> SortExpressions polja v Properties plošči in vstopa izraz. Za skupno zapored na koncu tabele doda vrstico po tem, ko (in zunaj), združevanje in nato uporabite naslednji izraz = Sum (Fields!Name.Value)kjer je "ime", je področje, ki je znašala. Če želite uporabiti barvilo za stolpce uporabiti "IIF" izjavo v nepremičnine BackgroundColor. Če želite dodati širino, kot celico v tabeli najprej vstavite merilnik v celico in nato spustite podatkovna polja, ki se zahtevajo za tirno širino. Pri urejanju višine & širino vrstic tabele, da boste izbrali pravo vrstico, nato pa hover miško okoli sivih linij, dokler ne boste dobili puščico gor / dol kurzor, nato pa velikost.

Dodajanje Charts, da vaše poročilo

1. Zagotovite, da imate ABACUS meri Poročilo Opredelitev datoteka (.rdl / .rdlc) odprta v programu Microsoft Oblikovalca poročil 3.0.

2. Izberite Insert Jeziček v "traku" na vrhu, nato kliknite Graf Gumbv rubriki Podatki regij in izberite Insert Chart.

3. Zdaj povlecite kazalecdo položaja na poročilu platnu, kjer želite zgornjem levem kotu grafikona dajo. Kliknite na platno in potem Izberite grafikonki jo zahteva od možnosti in kliknite v redu.

Nasvets

Za prikaz nepremičnino kot pripombo na kartah, z desnim klikom na grafikonu in izberite Show Oznake podatkov, nato pa izberite eno od oznak, ki so dodane in nastavite Misc -> UseValueAsLabel do False na plošči Lastnosti in dodajte izraz (npr = Name.Value Fields) v Misc -!> Label. Posebej za bubble karte; Bubble grafikoni so prikazani pod postavko v Raztreseni grafikon. Spusti osi X nepremičnine v serijsko polj (ali dodati v serije Properties). Spusti y osi nepremičnine v poljih podatkov (ali dodati v serije Properties). Če želite uporabiti lastnost določiti velikost mehurček, spusti to v polja podatkov (ali dodati v serije Properties). Bubble karte ne morejo prikazati, če je preveč podatkov (200+ Nepregledani prispevki), včasih to povzroča celotno poročilo ne prikaže. Marker Type - Nastavite na krog. Privzeto, ko spustite polja v poljih Podatki, ki jih dodaja s vsota ()formula, tako da odstrani to. Posebej za Zložene karte / Timeline / gantogrami; Za Ganttov grafikon uporabite obseg grafikon in dodajte lastnosti, visokimi in nizkimi vrednostmi v podatkovnih polj. Lahko imaš več "palice" Z dodajanjem več in več obsegov, kjer Nizka vrednost za eno ujema z visoko vrednost za drugo. Posebej za Pie karte; Za agregatnih tortnih grafikonov, spustite podatke v kategorijo področjih in na področjih, podatki, dodajte formulo = CountRows (). Izločijo morebitne 0 vrednosti (na primer pri stroških kartah), drugače pa nalepke za to bo še vedno pojavljajo na grafikonu.

Uporaba izjavo IIF dodati barve tabel in grafikonov

1. Zagotovite, da imate ABACUS meri Poročilo Opredelitev datoteka (.rdl / .rdlc) odprta v programu Microsoft Oblikovalca poročil 3.0.

2. Z desno tipko miške kliknite celico v tabeli, da barve in klik Lastnosti Box besedilo.

3. Izberite Izpolnite in kliknite fxgumb na desni strani nalepke barvo polnila in v sklop izraza za BackgroundColor polje vnesite izraz, npr = IIf (Fields! InformationStatus.Value = "Ohranjanje", "LightGreen", iif (Fields! InformationStatus.Value = "preoblikovanje", "Yellow", iif (Fields! InformationStatus.Value = "Osveži", "Orange", " losos "))). To spremeni barvo ozadja za svetlo zelene za vsako celico, ki vsebuje status "ohranijo", rumena za vsako celico, ki vsebuje Status "prenove", Orange za vsako celico, ki vsebuje status "Refresh" in katera koli druga vrednost statusa bo obarvan v 'Salmon ".

Opomba

Barve se lahko doda za grafikone z izbiro serijo na grafikonu in nato nastavite videz -> Barvna lastnine (ali mehurček grafikone videz -> Marker -> Color lastnina) k izraza podoben zgornji primer.

Stvari je treba imeti v mislih pri oblikovanju poročila po meri

· Ker so vse lastnosti, razen Integer poslana kot niz od ABACUS gledalcu poročila, če želite narediti vse "izraze" z njimi (kot razkorak ene nepremičnine z drugo ali vrsta), jih morate pretvoriti decimalno ali Datum itd Za ozadju , Ta članek je dobra referenca. Npr = CDate (Fields! LifecycleEndDate.Value) Opomba: Prosimo vas, da se poročilo jezik nastavljen na en-GB (kot je opisano v nadaljevanju), da sprejmete dd / mm / llll saj pričakuje format mm / dd / llll privzeto in ustrezno 31/7/2011 bo uspelo konverzijo. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value, 0)

· Če se vam zdi, da ste borijo za hraniti vse tabele in grafi na eni strani, Obstaja nekaj glavnih načinov za upravljanje vašega dokumenta prostor:

· Page Break - Prepričajte se, da je ta nastavitev miza off za vsako tabelo, ki želite biti na isti strani.

· Imejte Skupaj - Zagotoviti je ta nastavitev miza je res za vsako tabelo, ki želite biti na isti strani.

· Ko se gibljejo stvari okoli, da je lažje za pomanjšanje s pomočjo nadzora na spodnji desni strani in nato več izberete predmete in povleci

· Za vrstico slike v tabeli, se prepričajte, da je "Velikost" | Property "VELIKOSTI" je nastavljena na "fit" drugače slike lahko pojavijo prevelika, ali pa se bo močno raztegne.

· Če želite ponovite naslovno vrstico tabele na vsaki straniporočila:

1. Odpri Napredni način v podoknu skupinah. (Kliknite puščico na desni koloni skupin in izberite Napredni način).

2. Na področju Vrstica skupine (ne Stolpec skupine), kliknite na Static skupine, ki poudarja ustrezen učbenik v tablix. Klikajte vsako Statična skupine, dokler se ne izpostavlja najbolj levi glavo stolpca. To je na splošno prva Statična skupina seznamu.

3. V oknu Lastnosti, nastavite lastnost RepeatOnNewPage na True.

4. Prepričajte se, da je nepremičnina KeepWithGroup nastavljena na Po.

· Spreminjanje jezikovne nastavitveV Poročilu o nepremičninah, ki se ujema z podatkovnih formatov, ki jih potrebujete, na primer en-GB za proizvodnjo UK zapisa datuma (dd / mm / llll).

Poglej tudi

Analiziranje svojo arhitekturo


Prilagajanje vmesnika ABACUS

Navigacija: Uvod v ABACUS>

Prilagajanje vmesnika ABACUS

Pošlji komentarje o tej temi.

Lahko spremenite videz in obnašanje vmesnika ABACUS v mnogih pogledih. ABACUS vključuje več vnaprej določenimi nastavitvami kombinacij, ki jih lahko uporabite, da uporablja skupino customisations na vmesnik. Poleg tega si lahko posamezne customisations postavk, kot so okna, orodne vrstice, bližnjic in možnosti različnih zaslonov.

Razporedi in Dock Windows

Imate veliko možnosti za urejanje oken v vmesnik za ABACUS, vključno z naslednjim:

· Tab-dok okna.

· Dock okna do roba okvirja v vmesniku.

· Čim bolj zmanjšati orodje okna vzdolž roba vmesnika.

· Ponastavi postavitev oken na privzeto postavitev.

Docking Windows

Ko je okno sidrati, je mogoče pritrditi na eni strani okvirja znotraj vmesnika ali pa je lahko nameščena na zavihki plošč znotraj okvirja. Vodnik diamond se pojavi, ko povlečete okna iz svoje trenutne lokacije na drugo lokacijo v vmesniku. Vodilo diamant omogoča hitro ponovno pristane okno na enem od štirih straneh okvira ali v centru kot zavihki plošče. Ko je okno razdružitev ali ne sidrati, plava na vrhu drugih oken.

Pristajale okna

1. Kliknite na okno, ki ga želite pristane, da se osredotoči.

2. Na OknoMeni, kliknite Sidrati.

3. Povlecite okno z njegovega trenutnega mesta proti sredini okvirja želite, da ga dock s.

Pojavi se vodnik diamant. Štiri puščice točke diamanta do štirih robovih okvirja in centra predstavlja ploščo jezičkom.

Nasvet

Če želite premakniti sidranimi okno, ne da bi ga pritrdite na svoje mesto, pritisnite CTRL, medtem ko ga povlečete.

4. Ko je okno, ki ga povlečete doseže položaj, kjer želite, da ga priklopite, premaknite kazalec nad ustreznim deležem vodilnega diamant. Oris okna se pojavi v določenem območju.

5. Pristati okno v položaju, ki je naveden, spustite gumb miške.

Na primer, če Explorerje zasidrana na levem robu vmesnika in želite, da pristane na desnem robu, bi povlečete Explorerproti sredini vmesnika, premaknite kazalec na desni strani vodilnega diamant, nato spustite gumb miške.

Zmanjševanje Windows

Windows (ali so orodje Windows - pojavljajo na Poglejmeni, ali Document Windows - pojavljajo na OknoMeni) podpira funkcijo, imenovano Auto Hide. Auto Hide vam omogoča, da vidite več vaše arhitekture naenkrat z zmanjševanjem okna vzdolž robov vmesnika, ko ni v uporabi.

Za vklop Auto Hide

1. Kliknite na okno, ki ga želite skriti, da bi se moral osredotočiti.

2. Na OknoMeni, kliknite Auto Skrij.

- Ali -

2. Kliknite ikono risalni žebljiček v naslovni vrstici okna.

Auto Hide Enabled

Ko okno samodejno skrita izgubil fokus, samodejno zdrsne nazaj v zavihek na robu vmesnika. Medtem ko je okno-auto skrit, njegovo ime in ikona so vidni na zavihek na robu vmesnika. Če želite prikazati okno z avto-skrita, premaknite kazalec nad zavihek. Okno zdrsne nazaj v pogledu in je pripravljena za uporabo.

Opomba

Okno, da je avto-skrita ne more biti zasidrana. Pristajale okno, boste morali izklopiti Auto Hide, kot je opisano v nadaljevanju.

Za izklop Auto Skrij

1. Kliknite na okno, ki ga želite obdržati vidna, da bi se moral osredotočiti.

2. Na OknoMeni, kliknite Auto Skrijda počistite kljukico.

- Ali -

2. Kliknite ikono risalni žebljiček v naslovni vrstici okna.

Auto Skrij Disabled

Nasvet

Windows, ki imajo Auto Skrij omogočeno začasno potisnite v pogledu, ko je okno fokus. Če želite znova skriti okno, izberite element izven trenutnem oknu. Ko okno izgubi fokus, drsi nazaj ven pogleda.

Ponastavitev Windows Postavitve

Lahko se vrnete vmesnik za postavitev privzeto okno uporabo Reset Window Layoutukaz. Ko zaženete ta ukaz, naslednje ukrepe pojavijo:

· Vsa okna so se preselili na njihove privzete položaje.

· Okna, ki so zaprti v zasnovi privzeto okno se zapre z ukazom.

· Okna, ki so odprti pri postavitvi privzeto okno se odpre z ukazom.

· Okna, ki so skrite / vidne v zasnovi privzeti okna so narejeni skrito / vidna z ukazom.

Za ponastavitev umestitev okno na privzeto postavitev

1. Na WindowsMeni, kliknite Reset Window Layout.

Prilagajanje Meniji in orodne vrstice

Lahko spremenite postavitev, položaj in vsebino menijev in orodnih vrstic v vmesniku. Lahko dodate tudi gumbe orodne vrstice in spremeniti dodeljeno ikono za kateri koli gumb.

Ustvarjanje nove orodne vrstice

Če želite ustvariti novo orodno vrstico

1. Na OrodjaMeni, izberite Prilagajanje.

2. V Prilagajanjepogovorno okno, izberite Orodne vrsticetab.

3. Izberite New.

4. V New Orodna vrsticapogovorno okno, vnesite ime v orodni vrstici.

5. Izberite v redu.

Če želite dodati gumb ukaz menija ali orodne vrstice

1. Na OrodjaMeni, izberite Prilagajanje.

2. V Prilagajanjepogovorno okno, izberite Ukazitab.

3. Izberite kategorijo in povlecite ukaz iz pogovornega okna na meniju ali v orodni vrstici.

4. Izberite Zapri.

Nasvet

Držite Alt-ključ vam omogoča, da hitro prilagodite ukaze, kot da bi bil pogovorno okno Prilagodi odprta.

Poglej tudi

Vmesnik ABACUS


Določitev in potrditev Omejitve

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Določitev in potrditev Omejitve

Pošlji komentarje o tej temi.

Struktura in lastnosti arhitekture je mogoče omejiti z uporabo omejitev. Omejitve se lahko uporabljajo za sestavne tipov in vrst priključnih omejiti strukturo arhitekture na dva načina. Prvi način je, da se omejijo Hierarhijaz opredelitvijo "bi morala matična / mora imeti otrok" in "otrok mora / morajo biti starši« odnose. Drugi način je, da omejijo topologijaz opredelitvijo "komponenta moral / morajo biti pritrjeni na povezavi" in "povezava naj bi / je treba priložiti sestavnih" odnosov. Poleg tega se lahko omejitve se uporabljajo za lastnosti tipov sestavnih delov, vrste povezav, predloge, stališča, arhitekture, diagramiin 3D gleda omejiti arhitekturo (e) v dveh dodatnih načinov. Prvi način je, da nastavite vrsta podatkovnepremičnine omejiti veljavne vrednosti, ki ga imajo, in sicer; Besedilo, Integer, decimalno, datum / čas, Boolean ali Seznam. Drugi način je, da nastavite zahtevanoStanje nepremičnine, ki označuje, ali je treba vrednost, ki se vnesejo v nepremičnine (Opomba: Zahtevana omejitve veljajo samo za lastnosti za tipe sestavnih in povezovalnih). Dodatne informacije o omejitvah lastnine je na voljo v Spreminjanje lastnosti komponenta A, povezave ali vrsto help temo. Ko so bile opredeljene omejitve, je mogoče, da bi preverili arhitekturo proti omejitev. ABACUS bo opozoril na morebitne omejitve, ki so bile kršene.

Ključ za določanje, katere omejitev (-e) opredeliti laži v točno jeziku, ki se uporablja za opis omejitev. Hierarhije omejitev so običajno v obliki "samostalnikilahko / naj bi / je treba razčleniti na n samostalniki"Ali"samostalnikilahko / naj bi / je treba združiti s samostalniki"Itd Na primer,"Oddelkitreba razgradi v Moštvi"Ali"Aplikacijese lahko razdelijo Moduli". Za omejitev topologije so običajno v obliki"samostalnikilahko / naj bi / mošta glagol samostalniki". Na primer,"Procesi je lahko izvajalci Moštvi"Ali"Aplikacijesta gostuje na Strežniki. "Sedaj, si lahko ogledate v vsako omejitev obstajajo različni lahko / morale / mošt" kvalifikatorji "in ti so lahko 3 vrste;

· Neobvezno- Te bodo navadno uporabljajo besede / besedne zveze, kot so; "lahko", "mogoče", "lahko", "po izbiri" itd

· Priporočeno- Te bodo navadno uporabljajo besede / besedne zveze, kot so; "naj bi", "priporočljivo", "svetuje", itd

· Obvezno- Te bodo navadno uporabljajo besede / besedne zveze, kot so; "mora", "je", "smo", "ima", "se" itd

Glede na tip omejitve (hierarhiji ali topologije) in kvalifikacijskih uporabljenih pri jo opisujejo treba opredeliti specifična omejitev (y) (glej spodaj). Za zgoraj hierarhije primer "Oddelkitreba razgradi v Moštvi"Bi moral biti eden opredeliti" Parent mora imeti otroka "omejitev in nastavite izvrševanje naj bi se izvršila. Za zgornji primer topologije"Procesi je lahko izvajalci Moštvi. "Bi moral biti eden ustvariti le dva (2)" Priključitev mora biti pritrjena na komponento "omejitev za vsakem koncu po tipu priključka mora opraviti Konkretno se naslednje omejitve priporočljivo, da se opredeli (glej spodaj), za različne možnosti;

· Hierarhija omejitve;

o Samostalniki je lahkorazgradi v Samostalniki BAli Samostalniki B je lahkozdružijo s Samostalnikiali Samostalniki B moral bi bitizdružijo s Samostalniki- Določite "Otrok mora imeti Parent" pritisk s tipom otrok kot Noun B, matična tipa kot Noun A in izvrševanje, kot je opozoril.

Opomba

To pomeni, da če je otrok obstaja, mora imeti matično določene vrste. Če ne, boste dobili opozorilo.

o Samostalniki moral bi bitirazgradi v Samostalniki B- Določite "Parent mora imeti otrok" omejitev z matično vrste kot Noun A, tip otroškega kot Noun B in izvrševanje, kot je opozoril.

Opomba

To pomeni, da če eden od staršev ne obstaja, bi moral imeti otrok določene vrste. Če ne, boste dobili opozorilo.

o Samostalniki mora bitirazgradi v Samostalniki B- Opredeliti "Parent mora imeti otrok" omejitev z matično vrste kot Noun A, tip otroškega kot Noun B in izvrševanja kot prisilna.

Opomba

To pomeni, da če eden od staršev ne obstaja, mora imeti otrok določene vrste. Če ne boste dobili napako.

o Samostalniki mora bitizdružijo s Samostalniki B- Določite "Otrok mora imeti Parent" pritisk s tipom otrok kot Noun A, matična tipa kot Noun B in izvrševanja kot prisilna.

Opomba

To pomeni, da če je otrok obstaja, mora imeti matično določene vrste. Če ne, boste dobili napako.

· Topologija omejitve;

o Samostalniki je lahko glagol Samostalniki B- Določite dve (2) "Priključitev mora biti priložen komponenta" omejitev. Prvo bitje s koncem Vir tipa povezave glagolpritrjena na samostalnik s tipom sestavnega dela in izvršbe, prisilno. Drugi bitje z umivalnikom koncu vrste povezave glagolpritrjena na Noun homologacijo sestavnega dela B in uveljavljanju določil, da prisilna.

Opomba

To pomeni, da če je povezava obstaja, mora povezati komponent nekaterih vrst. Če ne boste dobili napako. Na splošno to zagotavlja, da se lahko ti deli še vedno obstaja in ne med seboj povezani. Vendar pa, če so povezane, se mora uporabiti povezave na desni tipa.

o Samostalniki moral bi biti glagol Samostalniki B- Določite dve (2) "Sestavina mora biti pritrjena na povezavo" omejitev. Prvo bitje z Noun Tip komponenta pritrjena na konec vira glagolvrsta povezave in set izvršba opozorjeni. Drugi bitje z Noun homologacijo sestavnega B pritrjena na Sink konca glagolvrsta povezave in set izvršba opozorjeni. Poleg tega določite dve (2) "Priključitev mora biti priložen komponenta" omejitev. Prvo bitje s koncem Vir tipa povezave glagolpritrjena na samostalnik s tipom sestavnega dela in izvršbe, prisilno. Drugi bitje z umivalnikom koncu vrste povezave glagolpritrjena na Noun homologacijo sestavnega dela B in uveljavljanju določil, da prisilna.

Opomba

To pomeni, da če obstajajo sestavine koli tipa, morajo biti pritrjeni na povezavo določene vrste. Če ne boste dobili opozorilo. Poleg tega to pomeni, da če je povezava obstaja, mora biti povezan s sestavinami določenega tipa. Če ne boste dobili napako. Na splošno to zagotavlja, da če obstajajo komponente teh tipov, boste dobili opozorilo, če niso povezani med seboj.

o Samostalniki mora biti glagol Samostalniki B- Določite dve (2) "Sestavina mora biti pritrjena na povezavo" omejitev. Prvo bitje z Noun Tip komponenta pritrjena na konec vira glagolvrsta povezave in izvrševanje naj bi prisilna. Drugi bitje z Noun homologacijo sestavnega B pritrjena na Sink konca glagolvrsta povezave in izvrševanje naj bi prisilna. Poleg tega določite dve (2) "Priključitev mora biti priložen komponenta" omejitev. Prvo bitje s koncem Vir tipa povezave glagolpritrjena na samostalnik s tipom sestavnega dela in izvršbe, prisilno. Drugi bitje z umivalnikom koncu vrste povezave glagolpritrjena na Noun homologacijo sestavnega dela B in uveljavljanju določil, da prisilna.

Opomba

To pomeni, da če obstajajo komponente dveh vrst, ki jih je treba pritrditi na povezavo določene vrste. Če ne boste dobili napako. Poleg tega to pomeni, da če je povezava obstaja, mora biti povezan s sestavinami določenega tipa. Če ne boste dobili napako. Na splošno to zagotavlja, da če obstajajo komponente teh tipov, boste dobili napake, če niso povezani med seboj.

Če želite določiti omejitev

1. Zagotovite imate ABACUS datotekaodprt in Explorer Windowprikazani.

2. V explorer drevesu razširite Vrste | Sestavni Vrsteali razširitev Vrste | Vrste povezava.

3. Desni kliktip sestavnega dela ali vrsto povezave in izberite Dodaj prisile.

Dodajanje omejitev

Če želite določiti hierarhijo omejitev, kjer mora starš imeli poseben otroka

4. Na Dodaj prisileOkno odkljukati Ustvarite prisilepolje pod Parent Mora imeti otrok prisileobmočje.

5. Izberite homologacije sestavnega delaiz spustnega navzdol, ki ga želite določiti kot otroka tipa sestavnega izbrali v koraku 3.

Opomba

Če je že omogočena "Parent Mora imeti otroka" ovira opredeljena za tip sestavnega dela matične in drugemu tipu sestavnega otrok, potem se bo ta nova omejitev obravnavajo kot "IN". To je tip, mora biti nadrejeno tipa otrok inOtrok tip B, na kateri koli stopnji izvršbe (na primer invalide, Opozorjeno ali prisilno - glejte korak 7), ki je določena za vsako omejitev.

6. Po želji lahko določite minimalno in maksimalno število komponent tipa sestavnega določeno, da morajo biti otroci tipa sestavnega dela desno kliknili v 3. koraku.

7. Izberite, ali želite, da se omejitev, da se Onemogočeno, Opozorilali Prisilna.

Opomba

Invalidne omejitve bodo prezrti od omejitvene potrditve, bo opozoril omejitve proizvajajo Opozorilo v oknu validacije, če se odkrijejo in Prisilna omejitve bo pripravila Napaka v oknu validacije, če se jih odkrije. Poleg tega so vse napake je treba rešiti, preden je Enterprise Server Projekt se lahko storila.

8. Kliknite v redu.

Opomba

Omejitev bo prikazan v raziskovalcu drevesu v skladu s tipom sestavnega dela desno kliknili v koraku 3. puščica označuje smer omejitev in v tem primeru bo točko dol in desno. Ključavnica je obarvana glede na to, ali je omejitev Disabled (siva), Opozorjeno (rumena) ali prisilno (rdeče).

Parent morajo imeti otrok opozoril omejitev

Če želite določiti hierarhijo omejitev, kjer mora otrok imeti posebno staršev

4. Na Dodaj prisileOkno odkljukati Ustvarite prisilepolje pod Otrok mora biti Parent prisileobmočje.

5. Izberite homologacije sestavnega delaiz spustnega navzdol, ki ga želite določiti kot obvladujoče tipa sestavnega dela desno kliknili v 3. koraku.

Opomba

Če je že omogočena "Otrok mora biti starša" omejitev, določeno za tip sestavnega dela otrok in drugemu tipu sestavnega matične potem bo ta nova omejitev obravnavana kot "ali". Da je vrsta mora biti otrok matično tipa A alitip starš B in stopnja izvrševanja (npr Opozorjeno ali prisilno - glej naslednji korak), morajo biti enake drugače uveljavljene omejitve bo vedno prevladati nad opozorjeni narave.

6. Izberite, ali želite, da se omejitev, da se Onemogočeno, Opozorilali Prisilna.

Opomba

Invalidne omejitve bodo prezrti od omejitvene potrditve, bo opozoril omejitve proizvajajo Opozorilo v oknu validacije, če se odkrijejo in Prisilna omejitve bo pripravila Napaka v oknu validacije, če se jih odkrije. Poleg tega so vse napake je treba rešiti, preden je Enterprise Server Projekt se lahko storila.

7. Kliknite v redu.

Opomba

Omejitev bo prikazan v pogledu raziskovalec v skladu s tipom sestavnega dela, izbrane v koraku 5. puščica označuje smer omejitev in v tem primeru bo točko gor in levo. Ključavnica je obarvana glede na to, ali je omejitev Disabled (siva), Opozorjeno (rumena) ali prisilno (rdeče).

Otrok mora imeti matično opozoril omejitev

Če želite določiti omejitev topologija, kjer mora biti sestavni del pritrjen na določeno povezavo

4. Na Dodaj prisileOkno odkljukati Ustvarite prisilepolje pod Komponenta je treba priložiti prisileobmočje.

5. Izberite vrsta povezaveiz spustnega navzdol, ki ga želite določiti kot priloženo povezavo tipa sestavnega dela desno kliknili v 3. koraku (ali izberite homologacije sestavnega delaiz spustnega navzdol, ki ga želite določiti kot priloženi komponento, če v koraku 3 desno-kliknili vrsto povezave.)

Opomba

Če je že omogočena "Komponenta je treba priložiti" ovira opredeljena za tip sestavnega dela in drugega zvezi s tipom se bo potem ta nova omejitev se obravnavajo kot "IN". Da je tip sestavnega dela mora biti priložen tipa priključek A inpovezava tipa B, na kateri koli stopnji izvršbe (na primer invalide, Opozorjeno ali prisilno - glejte korak 7), ki je določena za vsako omejitev.

6. Po želji lahko izberete povezavo Vlogaki ga želite dodati v prisile. Sizvoli posebna Vloga (tj bodisi vir ali ponor) iz spustnega navzdol.

7. Izberite, ali želite, da se omejitev, da se Onemogočeno, Opozorilali Prisilna.

Opomba

Invalidne omejitve bodo prezrti od omejitvene potrditve, bo opozoril omejitve proizvajajo Opozorilo v oknu validacije, če se odkrijejo in Prisilna omejitve bo pripravila Napaka v oknu validacije, če se jih odkrije. Poleg tega so vse napake je treba rešiti, preden je Enterprise Server Projekt se lahko storila.

8. Kliknite v redu.

Če želite določiti omejitev topologija, kjer mora biti povezava pritrjena na posebno komponento

4. Na Dodaj prisileOkno odkljukati Ustvarite prisilepolje pod Priključitev je treba priložiti ogradaobmočje.

5. Izberite vrsta povezaveiz spustnega navzdol, ki ga želite določiti kot priloženo povezavo tipa sestavnega dela desno kliknili v 3. koraku (ali izberite homologacije sestavnega delaiz spustnega navzdol, ki ga želite določiti kot priloženi komponento, če v koraku 3 desno-kliknili vrsto povezave.)

Opomba

Če je že omogočena "Priključitev mora biti priložen" ovira opredeljena za vrsto povezave in drugemu tipu sestavnega dela z isto povezavo Vloga(tj bodisi Vir ali ponor), potem bo ta nova omejitev se obravnavajo kot "ALI". Da je tip povezave morajo biti pritrjeni na komponento tipa A alikomponenta tipa B, in je stopnja izvrševanja (npr Opozorjeno ali prisilno - glejte korak 7) mora biti ista drugače uveljavljene omejitve bo vedno prevladati nad opozorjeni narave. Upoštevajte tudi, da obstaja več omejitve, ki imajo povezavo če Vlogaopredeljeno kot "vse" (v nasprotju z izrecno Izvor ali ponor), potem je treba vsak konec povezave pritrjene na enega od tipov sestavnih delov, navedenih v omejitev.

6. Po želji lahko izberete povezavo Vlogaki ga želite dodati v prisile. Sizvoli posebna Vloga (tj bodisi Vir ali Sink) iz spustnega navzdol.

Opomba

Potrebuje bodisi vir ali ponor vloga, ki se izrecno izbran za Priponka stolpec, da bo avilable, ki bo prikazan v komponenti Katalog .

7. Izberite, ali želite, da se omejitev, da se Onemogočeno, Opozorilali Prisilna.

Opomba

Invalidne omejitve bodo prezrti od omejitvene potrditve, bo opozoril omejitve proizvajajo Opozorilo v oknu validacije, če se odkrijejo in Prisilna omejitve bo pripravila Napaka v oknu validacije, če se jih odkrije. Poleg tega so vse napake je treba rešiti, preden je Enterprise Server Projekt se lahko storila.

8. Kliknite v redu.

V realnem času preverjanje modelov in Omejitevvalidacija

ABACUS vključujerealnem času Model Preverjanje in Validacija značilnost takoj zaslon učinki neka operacija uporabnik bo imel na opozorila in napake pri trenutnem projektu, zaradi katerega koli Hierarhija in topologija omejitve, ki so bile opredeljene. Treba je opozoriti, da morajo biti vsi Napake rešiti, preden je Enterprise Server Projekt se lahko storila.

Funkcija potrjevanje omejitev v realnem času, je najbolj opazna, ko poselitve z diagrami ali neposredno v okno raziskovalec. Zlasti v naslednjih operacijah, je napotek uporabo barvne poudarke glede učinka operacija bo imel na opozorila in napake pri trenutnem projektu;

1. Ko vlečenjem elementov na barvo staršev ali okoli diagram (ali pritrditev) komponento (če obstaja) bo mejni obarvana v skladu s shemo je opisan v nadaljevanju.

2. Pri povezovanju komponent uporabi desno tipko miške kliknite povleci | Povežite Za funkcijo seznam razpoložljivih tipov povezava je obarvan v skladu s shemo je opisan v nadaljevanju.

3. Pri povezovanju komponent na diagramih Uporaba načina Connector bo kazalka spremeni barve v skladu s shemo je opisan v nadaljevanju.

4. Pri dodajanju sub-komponente se seznam razpoložljivih Component Vrste obarvana v skladu s shemo je opisan v nadaljevanju.

Na splošno so naslednje barve uporablja za navajanje učinkov operacija bo uporabnik moral o opozorilih in napakah pri trenutnem projektu;

Črna : Ni vpliva na opozoril ali napak.

Green : Operacija je izrecno v skladu sopredeljeni v hierarhiji in topologija omejitve za projekt.

Red : Operacija je izrecno v nasprotju zopredeljene v hierarhiji in topologija omejitve za projekt in se bo odražalo v opozorilih in / ali napak.

Ozadje preverjanje modelov in Omejitevvalidacija

ABACUS vključuje Funkcija Validacija za prikaz vseh opozoril in napak s trenutnega projekta, zaradi kakršnih koli omejitev, ki so bile opredeljene. Treba je opozoriti, da morajo biti vsi Napake rešiti, preden je Enterprise Server Projekt se lahko storila.

Opomba

Treba Validacija treba ročno zagnati preko "potrditev / Check so projektni ovire" gumb na Glavna orodna vrstica . Okno Potrditev je privzeto skritavendar se bo pojavil, ko je gumb orodne vrstice kliknili. Oglejte si Prilagajanje vmesnika kako ga prikazati in potencialno ga pustite trajno prikazani. Prav tako lahko dvokliknete katerokoli vrstico v oknu za "skok" na ustrezen element v okviru projekta Validation.

Okno Validation

Privzete stolpce v oknu validacije so opisana kot sledi;

Opozorilo ali napaka: Ta stolpec prikaže ikono, ali je kršenje Opozorilo (rumen trikotnik s klicajem) ali Error (rdeč krog s križcem).

Število: Ta stolpec prikazuje število kršitev.

Opomba

Le 200 kršitev, so prikazani v času, in če obstaja več kot 200 kršitev v projektu se Start, Nazaj, Naprej in End vrstic navigatorji v zgornjem desnem kotu okna lahko uporablja za brskanje po dodatnih kršitev.

Opis: To je popoln opis kršitve, vključno z entitet in zadevno omejitev.

Subjekt: Ta stolpec prikazuje subjekta, ki zadevajo kršitve.

Tip: Ta stolpec prikazuje vrsto elementov za podjetje.

Arhitektura: Ta stolpec prikazuje arhitekturo, v katerem je prišlo do kršitve.

Zaznali: Ta stolpec prikazuje čas, ki je bila odkrita kršitev.

Nasvet

Koristno je, da padajoče jih zaznanih stolpcu (kot je prikazano v oknu zgoraj), da se zagotovi zadnje kršitve pojavljajo na "vrhu" seznama.

Obstaja več možnosti, uporabnik spremeni obnašanje validacije modela ozadje. Na primer to spremenite barve, ki se uporabljajo za kršitve omejitev pri nekaj drugega kot privzeto RedKliknite na Orodja | Možnosti ... potem pa pojdite na Validationzanka, in nastavite barve preko Spremeni gumbi.

Validation Možnosti

Če želite ročno potrditi omejitve

1. Desni kliko Arhitekturevozlišče, vsaka arhitektura ali kjerkoli bodisi Komponenteali Povezavedel namenom Raziskovalcu in izberite Preverite Omejitve.

Potrdi omejitve

2. Kliknite Podrobnostigumb na Opozorilaokno, da vidim, če arhitektura krši nobene omejitve, ki so bile opredeljene.

Opomba

Kršitve so prikazane le tiste omejitve, ki so bile določene za Opozorjeno ali prisilno. Poleg tega se bo besedilo opozorila vključujejo "naj bi", če bi bila omejitev samo opozorilo ali "mora", če je bila prisilno.

3. Kliknite v redu.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno


Brisanje komponento ali povezavo

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Brisanje komponento ali povezavo

Pošlji komentarje o tej temi.

Če želite izbrisati komponento ali povezavo

1. Desni klikna komponento ali povezave.

2. Izberite Izbriši.

Pozor

ABACUS vas bo opozoril, ki pogledi bodo vplivale izbris in vas prosimo, da potrdite brisanje. To je zato, ker elementi, ki lahko obstajajo na številnih diagramov ter da se splača preveriti, kaj bo predlagano črtanje vpliva.

Nasvet

Če izbrišete komponento, vse podkomponent tudi bodo izbrisani. Lahko se odločite za brisanje notranjih in zunanjih povezav na komponento. Če se odločite, da jih ne izbrišete, povezave je priložen da bo ostala, vendar pa ne bo več priloženo. Vse komponente in povezave so posebno Tip . Brisanje sestavnega dela / povezavo, nima nobenega vpliva na vrsto (v podružnici vrsta drevesa). Podobno, če je sestavni del / spoj Standardni dodeljena, bo izbris nimajo nobenega vpliva na mojstra v podružnici standarde.

Poglej tudi

Poselitev svojo arhitekturo - Pregled


Diagram Stališča

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Diagram Stališča

Pošlji komentarje o tej temi.

The stališčaznačilnost zagotavlja, da morajo imeti komponente in povezave, ki se dodajajo diagram vrsta združenje definirani prej, preden jih lahko dodamo k diagramu. Ta funkcija omogoča omejitev vrst diagramov, ki se ga lahko črpa z omejevanjem oblik in priključki, ki so povezane z Komponente in PovezaveObstoječa v vašem arhitekture.

Omogočanje ali onemogočanje uveljavljanje diagram Stališča

Sposobnost za izvajanje diagram stališča samodejno privzeto omogočena. Tako onemogočite / omogočite to funkcijo, kliknite na Orodja | Možnosti ...| Diagramzavihek in prekličite / izberite Uveljavite diagram Stališčapotrditveno polje ustrezno.

Opomba

Če ne vidite "Izvajati diagram Stališča"Opcija na zavihku Diagram potem nimate Designer add-on in možnost je privzeto vklopljena.

Ustvarjanje izvršljivo diagram razgledna točka

1. Zagotovite imate ABACUS datoteka open s explorerPogled prikazani.

2. V prikazu raziskovalec z desnim klikom na Poglejtočkasin kliknite na Ustvarjanje Diagram Vaše mnenje

3. Diagram Vaše mnenjese prikaže okno.

4. Dodelite ustrezno ime v diagram razgledna točkain ugotavljajo, da je razgledna točka je shranjen pod Stališčadel raziskovalec.

5. Diagram Vaše mnenjese prikaže okno.

6. Sedaj kliknite in povlecite ustrezne vrste komponent in vrste povezav v vaših arhitektur na razgledne oblike ti hočeš. Sestavni vrsteje treba vleči mirnoOblikav Oblikezanka, medtem vrste povezavje treba vleči na ena od oblik sloga 5 vodovv konektorjitab.

7. Če želite shraniti diagram razgledna točkaki ste jo ustvarili, kliknite na [image] v zgornjem desnem kotu Diagram Vaše mnenjeokno.

Opomba

diagram razgledna točkalahko uredili z desnim klikom na razgledna točka in izbiranje Odpriali dvoklik razgledna točka.

Synchonising posodobljeno stališče z diagrami

1. Zagotovite imate ABACUS datoteka open.

2. Bodisi z desno tipko miške kliknite pogled v Explorer Okno pod Meta model | Stališčain izberite Sinhronizacija Diagram Preslikave ...

- Ali -

3. Zapri odprta in posodobljena razgledna okno in izberite Dav Sinhronizacija na Viewpointpogovorno okno, ki se prikaže.

4. Vaše mnenje SinhronizacijaPogovorno okno se prikaže, kot je prikazano spodaj.

Potrditvena polja

· Dodaj Missing preslikav- , Ki so bili dodani Vsaka nova oblika (za homologacijo sestavnega dela) ali priključek (za vrsto povezave) združenja z vidikabo dodana k ustrezni diagramy (tj njihovihšablonay)da so povezane z vidika.

· Posodobitev obstoječePreslikave- Vse posodobljene vidike obstoječe oblike (na homologacijo sestavnega dela) ali priključek (za vrsto povezave) združenja za gledišče(na primer barva, sloge pisave) bo posodobljen v ustrezni diagramy (tj njihovihšablonay)da so povezane z vidika.

· Odstrani ExtraPreslikave- , Ki so bili dodani Vsaka dodatna oblika (za homologacijo sestavnega dela) ali priključek (za vrsto povezave) združenja k diagrami (tj njihove matrice), vendar niso v razgledna točkabodo odstranjene iz ustrezni diagramy (tj njihovihšablonay)da so povezane z vidika.

· Prepiši lokalnih Nastavitve za dodan ali posodobljen preslikave (razlike Only)- Vse posodobljene vidike obstoječe oblike (na homologacijo sestavnega dela) ali priključek (za vrsto povezave) združenja za gledišče(na primer barva, sloge pisave) se bodo uporabljale za ustrezne elemente na slikah, ki so povezane z vidika.Se uporablja samo posodobljene "razlike" izdelano z vidika, da bodo vse obstoječe lokalne nastavitve v diagramu, ki niso bile posodobljene v vidika ostajajo nespremenjene.

· [image] Pripisi – Kot zgoraj, ampak posebej za opomb.

Poglej tudi

Orodje za risanje | Poselitev svojo arhitekturo | Analiziranje Vaše arhitektura


Risanje Features Tool

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Risanje Features Tool

Pošlji komentarje o tej temi.

Orodje za risanje podpira številne risanje funkcij.

Povečevanje

Lestvica diagrama lahko spremenite s funkcijo povečave.

Če želite zmanjšati obseg ali "zoom"

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Press Ctrlin "=" ključ.

- Ali -

2. Izberite Povečajgumb na Diagramorodna vrstica.

- Ali -

2. Press Ctrland roll miško kolo naprej. Opomba: V tem načinu bo platno povečavo smeri, kjer je miška lebdi nad platnu.

Za povečanje obsega ali "pomanjšati"

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Press Ctrlin "-" ključ.

- Ali -

2. Izberite Pomanjšanjegumb na Diagramorodna vrstica.

- Ali -

2. Press Ctrland roll miško kolo nazaj. Opomba: V tem načinu bo platno povečavo navzven, od koder se z miško lebdi nad platnu.

Auto-layout

Postavitev komponent v diagramu se lahko samodejno spremeni.

Za postavitev vse deli on diagram

1. CLizanje Postavitev Diagramgumb na orodni vrstici Diagram.

2. Izberitebodisi Radial Layout ali Postavitev Grid.

Opomba

Postavitev Radial bo uporabil kar se imenuje "-sile usmerjene" algoritem tako, da so priključene komponente zadrgne pa so nepovezane komponente prisiljeni narazen. Postavitev Grid bo uporabil fiksno širino in višino razmika algoritem. To po eni strani omogoča uporabniku, da izbere splošno diagram razmerja stranic (npr 16: 9, A4 (portret), Letter (ležeče)), nato pa je razmik ob straneh in med stebri in vrstic, kot je prikazano spodaj.Z Grid postavitev morebitne povezave med sestavnimi deli ne vplivajo na izgled, saj preprosto ureja sestavine po abecedi (po imenu) od zgornjega levega do spodnjega desnega platna. Z obema algoritmi so Prostoručni oblike ne premaknejo.

Za postavitev otroci deli v enem matični zon diagram

1. Desni klikkomponenta na visoki ravni, katerih otroci želite samodejno postavitev.

2. Izberite Postavitev Otroci.

Opomba

Privzeto je uporabljena le Radial postavitev algoritem.

Spreminjanje Element Estetika kot Barva, Preglednost, Shadows in Rotation

Vsi diagram elemente estetike, ki se lahko upravlja, kot je želeno. Pri tem povezanih oblik, se lahko nastavi ti vidiki glede na vrstoin v večini primerov tudi na primer. Pri poljubnimi oblik, je mogoče nastaviti te lastnosti na primerna platnu.

Opomba

Vsako na vidike, stopnje, ki so bile določene za pridružene oblik bo "prepišejo", če je isti vidik spremenila za ustrezno vrsto.

Če želite spremeniti barvo pridružene oblike ali prostoročno obliko

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali Prostoručni oblike na platnu.

3. Izberite Sprememba barve.

4. Izberite Fiksna Colourradio gumb (če je primerno).

5. Izberite Basic Colour ali Določite Barva po meri v pogovornem oknu in kliknite v redu.

- Ali -

4. Izberite Gradientradio gumb (če je primerno).

5. Izberite bodisi horizontalno, vertikalno, Forward Diagonal ali nazaj Diagonal za gradient smer v padajočega in klik v redu.

6. Izberite Basic Colour ali Določite Barva po meri v pogovornem oknu za Začetekin Endin kliknite v redu.

Opomba

ABACUS obarva ospredju oblike, če;
a) je "preprost" oblika z enim osnovnim grafičnega elementa (npr kroga, pravokotnika, poligon itd), ali
b) je "kompleksen" oblike s številnimi osnovnimi subshapes, ki so vse enake barve / gradient kot med seboj ali subshapes imajo LockScale = true niz.
Če so navedeni pogoji niso izpolnjeni, potem je ozadje obliki barve.

Če želite nastaviti barvo pridružene oblike glede na lastnino

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna matričnega(NE na risalni površini).

3. Izberite Sprememba barve.

4. Izberite Uporaba Nepremičnineradio gumb.

5. Izberite lastnost, s klikom na "..." gumb na desni strani teksta.

6. Izberite Razpon radio gumb.

7. Prilagajanje Minin MaxVrednosti po želji. Opomba: vsaka vrednost pod minimalno vrednost, se bo pokazala kot barva Min in vsaka vrednost nad največjim bo prikazano kot Max barve. Tudi, ko je s pomočjo Boolean, List ali Date / Time lastnosti so vrednosti pretvorijo v indeks, kot sledi; Boolean (False = 0, True = 1), Seznam (celo vale od 1 do n za vsako veljavno vrednostjo v svojem naraščajočem vrstnem redu, določenem v polju enot), in datum / čas (število dni od 1. januarja 1900 - vključno decimalk za ur, minut, sekund deli - in če je datum je pre-1990 je negativno število).

8. Izberite Basic Colour ali Določite Barva po meri v pogovornem oknu za Minin Maxin kliknite v redu.

Nasvet

Če Green (RGB - 128,255,0) izbrana kot barva Min in Red (RGB - 255,0,0) izbrana kot Max barve za nepremičnine z območjem vrednosti 1da 4potem vrednost 1bo prikazano kot Green, Vrednost 2kot Rumena, 3kot Orangein 4kot Red.

Druga možnost je, za vrsto lastnine 1da 3Vrednost 1bo tako Green, Vrednost 2kot Amberin 3kot Redaka "semaforji" ali statusa RAG.

Za vrsto objektu od 1 do 5, če Blue (RGB - 0,0,255) izbrana kot barva Min in Red (RGB - 255,0,0) izbrana kot obarvate vrednost 1 bo kot Max Blue, Vrednost 2, kakor Aqua, Vrednost 3, kot je Green, Vrednost 4 kot Rumena in vrednosti 5 kakor Red.

Za vrsto objektu od 1 do 6, če Violet (RGB - 255,0,255) izbrana kot barva Min in Red (RGB - 255,0,0) izbrana kot obarvate vrednost 1 bo kot Max Violet, Vrednost 2, kakor Blue, Vrednost 3, kot je Aqua, Vrednost 4 kot Green, Vrednost 5 kakor Rumena in vrednosti 6 kakor Red.

In končno, za vrsto lastnino 1 do 7 bo vrednost 1, so Violet, Vrednost 2, kakor Temno modra, Vrednost 3, kot je Svetlo modra, Vrednost 4 kot Modra Zelena, Vrednost 5 kakor Green, Vrednost 6, kakor Amber in vrednosti 7. kakor Red

Opomba

Glej opombo zgoraj v ospredju primerjavi ozadju obarvanosti.

- Ali -

7. Izberite Specifična vrednostradio gumb.

8. Kliknite Uredi barvegumb.

9. Izberite vsako vrednost v zameno in kliknite Set Barvadoločiti posebno barvo za vsako vrednost.

Opomba

Razpon vrednosti za prisotnih elementov na diagramu bo pre-poseljena.

10. Da bi za tiste pre-poseljena (na primer, ko je bil preuredili razpon lastnina) Kliknite dodajte dodatne barve vrednostjo Dodaj vrednost.

Če želite spremeniti preglednost barvno pridružene oblike ali prostoročno obliko

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali Prostoručni oblike na platnu.

3. Izberite Sprememba barve.

4. V Transparency plošči nastavite zgornji drsnik na želeno preglednostjo za osnovno barvo.

5. Če se uporablja Gradient ali uporabo možnosti lastnine, v Transparency plošči nastavite spodnji drsnik na želeno preglednostjo za drugo barvo.

6. Kliknite v redu.

Pokazati senceza vse povezana oblike v diagramu

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v KomponenteJeziček okna matričnega.

3. Izberite Dodaj Shadows.

Če želite kažejo senco na oblika, sestavni del ali Prostoručni oblika

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Pravkliknemona sestavnem delu ali prostoročno oblike na platnu.

3. Izberite Dodaj Shadows.

Za vrtenje komponent oblik in brezplačne oblike obliki, v diagramih

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Izberite komponento obliko ali prostoročno obliko na platnu, ki ga želite zasukati.

3. Desni kliko obliki in izberite Zavrtiin nato izberite ustrezen kot želite zavrteti obliko s.

Spreminjanje Element Pripombe in Poljubna Besedilna Nalepke

Vse diagram elemente pripisi ki se lahko upravlja, kot je želeno. Pri tem povezanih oblik, se lahko nastavi ti vidiki glede na vrstoin v večini primerov tudi na primer. Pri poljubnimi oblikin priključkiJebesedilo nalepke je možno nastaviti na primerna platnu.Osem (8), različne vrste opomb se lahko prikažejo za diagram elementov (tj ime, tip, Property Value, Property Marker, vgrajene komponente, otroci (le za sestavne dele) Standardi in Timestamps (Ustvaril, Spremenil etc)) v twenty- pet (25) različne položaje (npr Centre - Zunaj Top, Inside levo - center, Zunanji desno - Zunaj dno).

Opomba

Vsako na vidike, stopnje, ki so bile določene za pridružene oblik bo "prepišejo", če je isti vidik spremenila za ustrezno vrsto.Poleg tega, če 2 ali več pripisov zavzemajo enako stališče, se lahko uporablja le eno pisavo, slog pisave, barvo in velikost pisave in separatorjem (npr vejica, prostor, nova linija) mora biti izbran.

Pokazati ime ali tip za povezano sestavino ali povezave

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali priključek na platnu.

3. Izberite Pripisi.

Opomba

Za posamezno povezano obliko ali priključka na platnu, boste morali, da izberete Preglasijo Stencil Pripombepotrditveno polje prvič.

4. Izberite Nov Annotation v orodni vrstici in izberite Name ali Tip.

5. V pogovornem oknu, ki se prikaže, izberite možnosti zaslona, ​​ki so želene vključno z nosilci in slog pisave, pisave, barvo pisave in velikosti. Prav tako, da izberete možnosti postavitve, ki so želene vključno z vodoravne in navpične lege (tj zaznamba položaj) in kot (tj rotacije). Izberite v redu.

Za prikaz nepremičnine vrednost za povezano sestavino ali povezave

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali priključek na platnu.

3. Izberite Pripisi.

Opomba

Za posamezno povezano obliko ali priključka na platnu, boste morali, da izberete Preglasijo Stencil Pripombepotrditveno polje prvič.

4. Izberite Nov Annotation v orodni vrstici in izberite Vrednost nepremičnino.

5. V pogovornem oknu, ki se prikaže, izberite lastnost s klikom na nepremičnine: '... "gumb in izberete nepremičnine v pogovornem oknu Select nepremičninein izberite v redu. Izberite možnosti zaslona, ​​ki so želene vključno z nosilci in slog pisave, pisave, barvo pisave in velikosti. Prav tako, da izberete možnosti postavitve, ki so želene vključno z vodoravne in navpične lege (tj zaznamba položaj) in kot (tj rotacije). Izberite v redu.

Za prikaz nepremičnine dvojno podajo za povezano sestavino ali povezave

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali priključek na platnu.

3. Izberite Pripisi.

Opomba

Za posamezno povezano obliko ali priključka na platnu, boste morali, da izberete Preglasijo Stencil Pripombepotrditveno polje prvič.

4. Izberite Nov Annotation v orodni vrstici in izberite Nepremičnine Marker.

5. V pogovornem oknu, ki se prikaže, izberite lastnost s klikom na nepremičnine: '... "gumb in izberete nepremičnine v pogovornem oknu Select nepremičninein izberite v redu. Nastavite polmer označevalca v pikslih in metodo barvanja z obeh Colour po skupinah ali Colour By lastnino in nastavite barve nalog. Prav tako, da izberete možnosti postavitve, ki so želene vključno z vodoravne in navpične lege (tj zaznamba položaj) in kot (tj rotacije). Izberite v redu.

Pokazati Priloženi deli za povezano sestavino ali povezave

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali priključek na platnu.

3. Izberite Pripisi.

Opomba

Za posamezno povezano obliko ali priključka na platnu, boste morali, da izberete Preglasijo Stencil Pripombepotrditveno polje prvič.

4. Izberite Nov Annotation v orodni vrstici in izberite Pripete Komponente.

5. V pogovornem oknu, ki se odpre, za pripadajoči deli izberete priloženo homologacijo sestavnega s klikom na pritrjeno: gumb '...' in izberete vrsto sestavnega dela v pogovornem oknu Set Component Typein izberite v redu. Izberite priloženo vrsto povezave s klikom na povezan preko: "..." gumb in izberete vrsto povezave v pogovornem oknu Set Connection Typein izberite v redu.Za povezanih povezav izberite konec povezave z izbiro vira ali Sink od konca Connection: pull-down menija. Za obe pripadajoči deli in povezave izberite možnosti zaslona, ​​ki so želene vključno z nosilci in slog pisave, pisave, barvo in velikost pisave. Prav tako, da izberete možnosti postavitve, ki so želene vključno z vodoravne in navpične lege (tj zaznamba položaj) in kot (tj rotacije). Izberite v redu.

Pokazati otroci za pripadajočo komponento

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v KomponenteJeziček okna šablon ali pridruženi oblike na platnu.

3. Izberite Pripisi.

Opomba

Za posameznega povezanega oblike na platnu, boste morali, da izberete Preglasijo Stencil Pripombepotrditveno polje prvič.

4. Izberite Nov Annotation v orodni vrstici in izberite Otroci.

5. V pogovornem oknu, ki se prikaže, izberite možnosti zaslona, ​​ki so želene vključno z nosilci in slog pisave, pisave, barvo pisave in velikosti. Prav tako, da izberete možnosti postavitve, ki so želene vključno z vodoravne in navpične lege (tj zaznamba položaj) in kot (tj rotacije). Izberite v redu.

Pokazati standardi za povezano sestavino ali povezave

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali priključek na platnu.

3. Izberite Pripisi.

Opomba

Za posamezno povezano obliko ali priključka na platnu, boste morali, da izberete Preglasijo Stencil Pripombepotrditveno polje prvič.

4. Izberite Nov Annotation v orodni vrstici in izberite Standardi.

5. V pogovornem oknu, ki se prikaže, izberite možnosti zaslona, ​​ki so želene vključno z nosilci in slog pisave, pisave, barvo pisave in velikosti. Prav tako, da izberete možnosti postavitve, ki so želene vključno z vodoravne in navpične lege (tj zaznamba položaj) in kot (tj rotacije). Izberite v redu.

Pokazati Timestamps za povezano sestavino ali povezave

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Desni klikna pridruženi obliko ali priključka v Komponenteali PovezaveJeziček okna šablon ali pridruženi oblika ali priključek na platnu.

3. Izberite Pripisi.

Opomba

Za posamezno povezano obliko ali priključka na platnu, boste morali, da izberete Preglasijo Stencil Pripombepotrditveno polje prvič.

4. Izberite Nov Annotation v orodni vrstici in izberite Ustvaril, Ustvaril, Created Marker, Modificirani Spremenil ali Spremenjen Marker.

5. V pogovornem oknu, ki se odpre, če ne označevalec, izberite možnosti zaslona, ​​ki so želene vključno z nosilci in slog pisave, pisave, barvo pisave in velikosti. Če označevalec, nastavite polmer označevalca v pikslih in metodo barvanja z obeh Colour po skupinah ali Colour By lastnino in nastavite barve nalog. Prav tako, da izberete možnosti postavitve, ki so želene vključno z vodoravne in navpične lege (tj zaznamba položaj) in kot (tj rotacije). Izberite v redu.

Če želite spremeniti slog pisave za prostoročno oblikeali priključek

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Desni klikna prostoročno obliko ali priključek na platnu. Opomba: Če je priključek Nalepka besedilo se ne pokažejo potem pokazati povezavoali Nalepka besedilo: Desni klikConnectaliin izberite Komentar | Prikaži Annotation.

3. Izberite Spreminjanje pisave.

4. Izberite slog pisave, pisave in v pogovornem oknu in izberite v redu.

Če želite spremeniti pisavo barva za prostoročno oblikoali priključek

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Desni klikna prostoročno obliko ali priključek na platnu. Opomba: Če je priključek Nalepka besedilo se ne pokažejo potem pokazati povezavoali Nalepka besedilo: Desni klikConnectaliin izberite Komentar | Prikaži Annotation.

3. Izberite Spremeni Font Colour.

4. Izberite pisavoBarva (in oblik Link Colour) S klikom na gumb '...' in izberete barvo v pogovornem oknu in izberite v redu.

5. Izberite transparentnosti nalepki besedilno s prilagoditvijo drsnik z 0 pa popolnoma transparentna in 255 pa popolnoma neprosojno.

Če želite zasukati nalepko besedila za prostoročno oblikeali priključek

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Desni klikna prostoročno obliko ali priključek na platnu. Opomba: Če je priključek Nalepka besedilo se ne pokažejo potem pokazati povezavoali Nalepka besedilo: Desni klikConnectaliin izberite Komentar | Prikaži Annotation.

3. Izberite Zavrtiin nato izberite ustrezen kot želite, da zavrtite Nalepka besedilo ga.

Poglej tudi

Orodje za risanje | Poselitev svojo arhitekturo | Analiziranje Vaše arhitektura


Simuliranje skupni stroški lastništva (TCO)

Navigacija: Simuliranje svojo arhitekturo> Simulacije>

Simuliranje skupni stroški lastništva (TCO)

Pošlji komentarje o tej temi.

Ozadje

Skupni stroški lastništva (TCO), je finančna ocena, ki je namenjen za merjenje stroškov življenjskega cikla skupno nastali (od pridobitve do razgradnje / odstranjevanje odpadkov), povezane s sredstvi v lasti. TCO ne odraža le stroškov nakupa, vključuje pa tudi vse druge vidike v nadaljnjo uporabo in vzdrževanje sredstva.

TCO se uporablja za določitev trud in stroški proračuna je potrebno, da preživijo na sistemu. Preprost način modeliranja v ABACUS za TCO je prekinil informacijskega sistema navzdol na komponente. Potem lahko ugotovite, koliko v povprečju stane teči od teh komponent. Po tem smo se lahko potem dejavnik pri različnih stroškov, odvisno od tega, ali je sistem IT evolvable ali odprto itd Če je sistem že vzpostavljen in deluje, je glavni dejavnik, da razmisli, je strošek vzdrževanja in morda stroškov za razgradnjo.

Primer

Shema za Primer izračuna

Komponenta v okviru organizacije ali njenega standarda ima te lastnosti:

· FTE= 100 000 $ / leto

· Podpora Napor= 0,01 EPDČ + 0.001 FTE / leto = 1.000 $ + 100 $ / leto

· Vzdrževanje Stroški= 100 $ - 10 $ / leto

· Capital Stroški= 2000 $

· Namestite napora= 2 FTE / dni = 0,01 FTE / leto = $ 1000

Komponenta okviru Organizacije ima te lastnosti:

· Namestite Horizon= -2 Let (tj bil sistem nameščen 2 let pred sedanjostjo)

· Življenjska doba= 3 leta

Kdaj Namestite Horizon + Življenjska doba <= 0 Ni več stroškov vzdrževanja.

Izračuni

Izračuni so naslednji:

Opomba

TC = strošek na leto. SE = Podpora naporu. MC = stroškov vzdrževanja.

· Začetni stroški = stroški kapitala + Namestite naporu= 2000 + 1000 = 3000 $

· Pri t = -2 (v 1. letniku), TC = Začetni stroški + SE + MC= 3000 + 1000 + 100 = 4100 $

· Pri t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1.190 $

· Pri t = 0, TC = (1000 + 200) + (100-20) = 1.280 $

· Pri t = 1 (končno leto), TC = (1000 + 300) + (100-30) = 1.370 $

Graf za Primer izračuna

TCO je vsota vseh sedanjih in prihodnjih stroškov, dokler razgrajenih sistem.

· Pri t = -2 (v 1. letniku), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Pri t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Pri t = 0, TCO = 1280 + 1370 = 2650 $

· Pri t = 1 (končno leto), TCO = 1370 $

Ključne stroškovnih dejavnikov

Ključni dejavniki stroškov je treba upoštevati pri izračunu TCO sredstva v ABACUS so:

· Strojna oprema Pridobitev- Začetni stroški opreme (stroški kapitala).

· Programska oprema Nakup- Začetni stroški za licence programske opreme (stroški kapitala).

· Namestitev- Stroški, povezani z začetno nastavitvijo.

· Usposabljanje- Stroškov, povezanih z zunanjim izobraževanjem prodajalec po prvi namestitvi.

· Podpora- Stroškov, povezanih z notranjo podporo.

· Vzdrževanje- Stroški za zamenjavo ali nadgradnjo prodajalec je pogodbe za vzdrževanje, material in stroški izterjave katastrofa.

· Infrastruktura- Stroški, povezani s podpornimi sredstvo.

ABACUS Primer Zastopanje ključnih stroškovnih dejavnikov

Tek simulator Cost

Za simulacijo svojo arhitekturo v smislu stroškov

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Izberite Analiza| Strošek.

3. Izberite Arhitektura (s)želite, da pri ocenjevanju vključi.

Opomba

Privzeto bo ABACUS samodejno izbere arhitekturo (-e), za katere se zaradi potreben ponovni simulacija za vse zadevne nepremičnine ali strukturnih sprememb.To poudarjanje je prikazano v Red o Orodna vrstica simulacija .

4. Izberite Valutaod podirajo.

5. Premakni Let za izračundrsnik na število let, potrebnih.

Opomba

Privzeto, če let za izračun je več kot 1 leto, se bodo stroški samodejno izračuna za vsako posamezno leto (in zbirka lastnosti dodal / posodobljena) in nato izračuna tudi kumulativna vrednost za celotno število let. Če se zahteva le kumulativna vrednost nato počistite Izračun stroškov Per-YearMožnost, kot je opisano spodaj shraniti na število lastnosti v projektu.

6. Izberite, ali naj zapusti Izračun stroškov Per-Yearpreveri, ali ga počistite.

7. Kliknite Naslednja.

8. Po želji izberite Povezaveželite pripisati stroške skupaj kot del ocenjevanja.

Opomba

Z uporabo Stroški | Pripisnepremičnina na stroških povezav je lahko pripisati Komponenta, pritrjena na koncu potapljanja priključitev na komponento pritrjena na koncu vira(tj Stroški | Attribution = "Sink na vir«), ali Komponenta, pritrjena na vir Konec priključitev na komponento pritrjena na umivalnik konec(tj Stroški | Attribution = "Source Sink"). Poleg tega ABACUS bo samodejno izbral tiste povezave s ravnanja | Razmerje = "procesov" ali "podpira"in smer pripisovanja bo "Sink na vir". Poleg tega so stroški razdeli po katerem koli ravnanja | % Ali Stroški | % Lastnosti na povezavah ali pa tam, kjer je več povezav iz ponora do mnogih virovali vir mnogih ponorovPo kateremkoli ravnanja | Obdelovalne lastnosti o sestavnih izvornihali potonejo komponent oziroma.

9. Kliknite Finishin boste dobili Opozorilopogovorno okno.

10. Želji raziskati opozorila s klikom Podrobnosti >>.

11. Kliknite Naprej.

Opomba

Na tej točki, bo ABACUS izvesti stane vrednotenje temelji na dejavnostih, arhitekture (-e) in po kratkem času (z bari napredku za povratne informacije), se bo prikazal izračun popolno pogovorno okno.

12. Kliknite v redupriznati oceno.

Nasvet

Za usposabljanj in nadaljnji pomoči na ceno Simulacija se obrnite na Avolution Skupnosti .

Komponenta in / ali Connection Nepremičnine

V spodnji tabeli so navedene komponente in / ali povezava lastnosti, potrebne za ocenitev stroškov.Te lastnosti bodo prikazani v oknu Properties z ikono input lastnina selektorja vrstica ( [image] ) Z namigu "Cost vnosni". Sprememba za katero od teh "vhodnih" lastnosti in raznih strukturnih sprememb v skladišču bo povzročila stroškov simulatorju, ki zahteva ponovno simulacijo, kot je navedeno v Red o Orodna vrstica simulacija .

Tip

Name

Privzeta vrednost

Enota

Data Type

Zahtevana

Opis

Strošek

Namestite Horizon

0

let

Integer

True

Določa, ko je komponenta ali povezava je bilo, ali bo nameščen.

· Vrednost 0 (privzeto) kaže, da komponento ali povezava se namesti v tekočem letu.

· Vrednost manj kot 0 označuje, da komponento ali povezava Nameščena je bila v preteklosti.

· Vrednost večja kot 0 označuje, da komponento ali povezava bo nameščen v prihodnosti.

Strošek

Življenjska doba

0

let

Integer

True

Določa dolžino časa, v katerem je komponenta ali povezava bo ostal v operaciji, po katerem se bo razgraditi.

Strošek

FTE

100.000,00

$ / leto

Decimalno

False

Letni stroški za vsak polni delovni čas.

Če ta lastnost ni bilo mogoče najti v komponentisama ali v primeru povezav komponenta pritrjena na koncu potapljanja povezave, Bo iskali v drugih sestavinah.

Prvič, vsaka "ponor" komponentaskonec a povezava z "podpira" odnos s sestavnim bodo iskali, čemur sledi da starša sestavnega dela "ponor"y.

Če se ne ugotovi, da je nepremičnina FTE, komponenta je matična-components bodo nato iskali. Če se še vedno ne najdemo FTE, je uporabljena privzeta vrednost.

Opomba: FTE je veljavno le vhod nepremičnine na sestavnih delih.

Strošek

Vzdrževanje Cost (fiksna)

0.00

$ / leto

Decimalno

False

Letna fiksni stroški vzdrževanja komponentoali povezava.

Strošek

Vzdrževanje Cost (spremenljivka)

0.00

$ / leto

Decimalno

False

Znesek, za katerega skupni stroški vzdrževanja komponente ali povezava vsako leto se bo spremenilo.

Na primer, vrednost $ -500 kaže, da se celotni stroški vzdrževanja zmanjša za 500 $ vsako leto, medtem ko je vrednost 500 $ pomeni, da skupno povečanje stroškov vzdrževanja po 500 $ vsako leto.

Strošek

Podpora Napor (fiksna)

0.00

FTE / leto

Decimalno

False

Letna določen napor podpiranja komponentoali povezava, Ki je določen v smislu oseb-let.

Strošek

Podpora Napor (spremenljivka)

0.00

FTE / leto

Decimalno

False

Znesek, za katerega je skupno prizadevanje za podpiranje komponento ali povezava vsako leto se bo spremenilo.

Na primer, vrednost -0.01 kaže, da se celotna podpora napor zmanjša za 0,01 osebo vsako leto let, medtem ko je vrednost 0,01 kaže, da povečanje skupne podpora naporu po 0,01 vsako leto.

Strošek

Capital Stroški

0.00

$

Decimalno

False

Začetni strošek nakupa komponentoali povezava.

Strošek

Namestite napora

0.00

FTE

Decimalno

False

Zahteva napor, v oseb-let, namestiti komponentoali povezava.

V spodnji tabeli so navedene komponente in / ali povezava lastnosti, ki se prikaže v TCO ocenjevalca. Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Cost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in na simulatorju stroškov zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Opomba

Kjer morajo biti izhodne lastnosti iz TCO ocenjevalca "zaokrožen" na "Round polovico celo" pristop (imenovan tudi kot "bankirji" zaokroževanja) se uporablja.Ta tehnika se uporablja za bolj enakomerno rešiti vse .5 "tie-odmori 'z rezultatom, ki se zaokroži navzgor ali navzdol na najbližjo celo rezultat, ne pa vedno zaokroži navzgor ali navzdol in nesimetričnosti rezultat. Tj 2,5 zaokroži navzdol na 2, medtem ko je 3,5 se zaokroži navzgor do 4, namesto njih sta se bodisi zaokrožena navzdol na 2 in 3 ali pa se zaokroži na 3 in 4.

Tip | Name | Enota | Data Type | Zahtevana | Opis
Strošek | Skupni stroški z lastnimi - naslednjih x let. | $ | Integer | False | Celotni stroški lastništva nad Naslednja xlet, pri čemer je x dolžina časa, določeno ko teče ocenjevalcu. To vključuje stroške komponenta je ali povezava je standardi, sub-komponenteali sub-povezave(tj otroci) in vse pripisane stroške.
Strošek | Skupni stroški za lastno (lokalni) - naslednji x let. | $ | Integer | False | V nadaljevanju: lokalni "stroški lastništva nad Naslednja xlet, če xje čas določen, ko teče ocenjevalcu. To počne nevključujejo stroške podskupinah komponento za ali sub-povezave povezavi z (tjotroci) ali katere koli pripisani stroški.
Strošek | Skupni stroški za lastno (otroci) - naslednji x let. | $ | Integer | False | Stroški "otroci" lastništva nad Naslednja xlet, pri čemer je x dolžina časa, določeno ko teče ocenjevalcu. To samo vključuje stroške podskupinah komponento za ali sub-povezave povezavi z (tj otroci).
Strošek | Skupni stroški za lastno (pripisana) - naslednji x let. | $ | Integer | False | V nadaljevanju pripisati "stroški lastništva nad Naslednja xlet, pri čemer je x dolžina časa, določeno ko teče ocenjevalcu. To samo vključuje vse pripisane stroške iz priloženih sestavin(ki se seveda lahko vključujejo pripisati stroške iz vseh priloženih priključkov).

V spodnji tabeli so navedene komponente in / ali povezava lastnosti, ki se prikaže v TCO ocenjevalcače Izračunaj Per-Year Stroški možnost je izbrana. Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Cost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in na simulatorju stroškov zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Opomba

Glej opombo zgoraj o možni zaokroževanja izhodnih lastnosti.

Tip | Name | Enota | Data Type | Zahtevana | Opis
Strošek | Skupni stroški z lastnimi - letox. | $ | Integer | False | Celotni stroški lastništva za letnik x, Kjer je x za vsako leto določeno ko teče ocenjevalcu. To vključuje stroške komponenta jeali povezava je standardi, sub-komponente ali sub-povezave (tj otroci) in vse pripisane stroške.
Strošek | Skupni stroški za lastno (lokalni) - letnikx. | $ | Integer | False | V nadaljevanju: lokalni "stroški lastništva za leto x, kje xje za vsako leto določeno ko teče ocenjevalcu. To počne nevključujejo stroške podskupinah komponento za ali sub-povezave povezavi z (tj otroci) ali katere koli pripisani stroški.
Strošek | Skupni stroški za lastno (otroci) - letnikx. | $ | Integer | False | Stroški so "otroci" lastništva za leto x, Kjer je x za vsako leto določeno ko teče ocenjevalcu. To samo vključuje stroške podskupinah komponento za ali sub-Priključek za (tj otroci).
Strošek | Skupni stroški za lastno (pripisana) - letnikx. | $ | Integer | False | V nadaljevanju pripisati 'stroški lastništva za leto x, Kjer je x za vsako leto določeno ko teče ocenjevalcu. To samo vključuje vse pripisane stroške iz priloženih sestavin(ki se seveda lahko vključujejo pripisati stroške iz vseh priloženih priključkov).

Dodatne Lastnosti povezava

V naslednji tabeli dodatna lastnosti povezave, ki so potrebne za TCO ocenjevalca. Te lastnosti bodo prikazani v oknu Properties z ikono input lastnina selektorja vrstica ( [image] ) Z namigu "Cost / Uspešnost input" ali samo "Cost vnosni". Sprememba za katero od teh "vhodnih" lastnosti in raznih strukturnih sprememb v skladišču bo povzročila stroške in / ali Uspešnost simulator zahteva ponovno simulacijo, kot je navedeno v Red o Orodna vrstica simulacija .

Tip | Name | Privzeta vrednost | Enota | Data Type | Zahtevana | Opis
Strošek | Pripis | Potopi Vir | [Source Sink | Potopi Vir] | Iskanje / Seznam | True | Če je "Vir za Sink"Ta povezava bo imajo imajo Stroškispripisati "skupaj" to Iz virkomponenta na umivalnik komponenta. Alternativno, če "Potopi Vir"Ta povezava bo so pripisane "skupaj" to iz hladilnika komponente za komponento vira.
Obnašanje | Razmerje | podpira | [procesov | podpira] | Iskanje / Seznam | False | Če "nosilci", ta povezava pomeni, da je "vir" komponenta podpira "potopi" komponento. Poleg tega, če bodisi "nosilci" ali potem se povezava samodejno izbrani v povezav "postopki", da se njihove pripisane 'skupaj' iz hladilnika komponente za komponento vira.
Strošek | % | 100,0 | % | Decimalno | False | Prikazuje delež stroškov komponent umivalnik, ki bodo pripisane komponento vira. V% vrednosti ni potrebno dodati do 100% in se preprosto uporabljajo za normiranje "skupni stroški z lastnimi -. Naslednjih x let" lastnost (glej zgoraj) s komponento umivalnik kot je pripisati komponento vira.

Lastnosti arhitektura

V spodnji tabeli so navedene lastnosti arhitekture, ki so izhod, ki ga TCO ocenjevalca. Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Cost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in na simulatorju stroškov zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Opomba

Glej opombo zgoraj o možni zaokroževanja izhodnih lastnosti.

Tip | Name | Enota | Data Type | Zahtevana | Opis
Strošek | Skupni stroški z lastnimi - naslednjih x let. | $ | Integer | False | Celotni stroški lastništva celotne arhitekture v naslednjih x let.

V spodnji tabeli so navedene lastnosti arhitekture, ki so izhod, ki ga TCO ocenjevalcače Izračunaj Per-Year Stroški možnost je izbrana. Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Cost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in na simulatorju stroškov zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Opomba

Glej opombo zgoraj o možni zaokroževanja izhodnih lastnosti.

Tip | Name | Enota | Data Type | Zahtevana | Opis
Strošek | Skupni stroški za lastno - letnikx. | $ | Integer | False | Celotni stroški lastništva za celotna arhitektura za leto xv prihodnosti.


Simuliranje Modularnost

Navigacija: Simuliranje svojo arhitekturo> Simulacije>

Simuliranje Modularnost

Pošlji komentarje o tej temi.

Modularnost simulator izračuna število vhodnih in izhodnih povezav za vsako komponento.

Za simulacijo svojo arhitekturo v smislu modularnosti

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Izberite Analiza| Modularnost.

3. Izberite Arhitektura (s)želite, da pri ocenjevanju vključi.

Opomba

Privzeto bo ABACUS samodejno izbere arhitekturo (-e), za katere se zaradi potreben ponovni simulacije vseh osnovnih strukturnih sprememb.To poudarjanje je prikazano v Red o Orodna vrstica simulacija .

4. Kliknite Naslednja.

5. Izberite Vrste Connection (ov)želite, da pri ocenjevanju vključi.

6. Kliknite Naslednja.

7. Po želji prilagodite imena lastnine za rezultate izračunov.

8. Kliknite Finish.

Opomba

Na tej točki, bo ABACUS opravljajo strukturno oceno arhitekture (-e) in po kratkem času (z bari napredku za povratne informacije), se bo prikazal izračun popolno pogovorno okno.

9. Kliknite v redupriznati oceno.

Nasvet

Za usposabljanj in nadaljnji pomoči na modularnosti vrednotenje se obrnite na Avolution Skupnosti .

Lastnosti Component

V spodnji tabeli so navedene sestavne lastnosti, ki so izhod, ki ga modularnost ocenjevalca.Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Modularnost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastarelo zaradi osnovne strukturne spremembe na odlagališču in modularnosti simulator zahteva ponovno simuliranje v skladu s Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Data Type | Zahtevana | Opis
Modularnost | Sklopka, ventilator v (lokalni) | Integer | False | Število priključkov, da ventilator v to komponento.
Modularnost | Coupling fan-out (lokalni) | Integer | False | Število priključkov, da ventilator iz te komponente.
Modularnost | Sklopka, ventilator v | Integer | False | Število povezav, ki ventilator v to komponento, vključno s povezavami, da ventilator v podskupine.
Modularnost | Coupling fan-out | Integer | False | Število povezav, ki fan ven iz te komponente, vključno s povezavami, da ventilator v podskupine.


Simuliranje Odprtost

Navigacija: Simuliranje svojo arhitekturo> Simulacije>

Simuliranje Odprtost

Pošlji komentarje o tej temi.

Odprtost simulator določa stopnjo, do katere so arhitektura in njeni elementi "odprte", to je sposobnost sistema za ravnanje z zamenjavo komponent z minimalnim vplivom.

Za simulacijo svojo arhitekturo v smislu odprtosti

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Izberite Analiza | Odprtost.

3. Izberite Arhitektura (s)želite, da pri ocenjevanju vključi.

Opomba

Privzeto bo ABACUS samodejno izbere prvo arhitekturo, za katero je zaradi potreben ponovni simulacija za vse zadevne nepremičnine ali strukturnih sprememb.To poudarjanje je prikazano v Red o Orodna vrstica simulacija .

4. Kliknite Finishin boste dobili Opozorilopogovorno okno.

5. Želji raziskati opozorila s klikom Podrobnosti >>.

6. Kliknite Naprej.

Opomba

Na tej točki, bo ABACUS opravljajo strukturno oceno arhitekture (-e) in po kratkem času (z bari napredku za povratne informacije), se bo prikazal izračun popolno pogovorno okno.

7. Kliknite v redupriznati simulacijo.

Nasvet

Za usposabljanj in nadaljnji pomoči na odprtosti vrednotenju se obrnite na Avolution Skupnosti .

Komponent in povezave Standardne lastnosti

V spodnji tabeli so navedene standardne lastnosti komponent in povezave, potrebne za oceno odprtosti.Te lastnosti bodo prikazani v oknu Properties z ikono input lastnina selektorja vrstica ( [image] ) Z namigu "Odprtost vnosni". Sprememba za katero od teh "vhodnih" lastnosti v skladišču bo odražalo v odprtosti simulatorju, ki zahteva ponovno simulacijo, kot je navedeno v Red o Orodna vrstica simulacija .

Tip | Name | Privzeta vrednost | Enota | Data Type | Zahtevana | Opis
Odprtost | Standardi-Standard Zapadlost-Organizacija Raven |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Stopnja odgovornega organ za standarde 0:Organizacijska / Lastniška 1:Konzorcij / DEFACTO 2:Državni / Vojaški 3:International
Odprtost | Standardi-Standard Zapadlost-Status |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Raven odobritev dosežena s standardizacijo 0:Osnutek Delovna / odbor 1:Javno Osnutek / Balloted 2:Začasna Osnutek 3:Odobreno
Odprtost | Standardi-Standard Zapadlost-stabilnost |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Je standard, ki bi lahko spremenil? 0:Standardna zastarela 1:Visoko se lahko spremenijo v naslednjem od 1 do 2 let 2:Znane Spremeni / posodobitve obstoječih funkcij 3:Zelo stabilen (ni spremembe v 2 letih)
Odprtost | Standardi-Standard Zapadlost-Vendor podpora |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Vendor podpora 0:Ni izdelkov ali prodajalci podpirati standard 1:Eden ali več ponudniki, ki izvajajo del standarda 2:Več kot en prodajalec z izdelki, ki izpolnjujejo vse dele standarda 3:Veliko več kot en prodajalec z izdelki, ki izpolnjujejo vse dele standarda
Odprtost | Standardi-Standard izrecnost-dokumentacija |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Kakovost standardne dokumentacije 0:Ubogi 1:Fair 2:Dobro 3:Odlično
Odprtost | Standardi-Standard izrecnost-Standard Širina |  |  | Integer | False | Število funkcij. Štetje najnižjih standardnih stopnja značilnosti - Sf
Odprtost | Standardi-Standard izrecnost-Sm |  | % | Decimalno | False | Odstotek skupnega števila funkcij, ki so obvezna
Odprtost | Standardi-Standard izrecnost-So |  | % | Decimalno | False | Odstotek skupnega števila funkcij, ki so neobvezna
Odprtost | Standardi-Standard izrecnost-Sc |  | % | Decimalno | False | Odstotek skupnega števila funkcij, ki so pogojno opredeljena
Odprtost | Profili profil Dokumentacija-dokumentacija |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Kakovost standardne dokumentacije 0:Noben 1:Ubogi 2:Fair 3:Odlično
Odprtost | Profili profil Dokumentacija-Natančnost |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Ali dokumentacija odražajo dejansko zasnovo sistema? Kakšna stopnja značilnosti profilov so v sistemu uporablja? 0:Ni lastnosti 1:Nekatere funkcije 2:Večina funkcij 3:Vse funkcije
Odprtost | Profili profil Dokumentacija-Zapadlost |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Je profil zrel in na voljo? 0:Ad-hoc 1:Projektno 2:Organizacijska 3:Javno
Odprtost | Profili profil izrecnost-Explicit Širina |  |  | Integer | False | Število standardnih funkcij, opredeljenih kot se zahteva v profilu
Odprtost | Profili profil izrecnost-Pm |  | % | Decimalno | False | Odstotek obveznih elementov v profilu
Odprtost | Profili profil izrecnost-Po |  | % | Decimalno | False | Odstotek opcijskih funkcij v profilu
Odprtost | Profili profil izrecnost-Pc |  | % | Decimalno | False | Odstotek pogojno OPREDELJENI funkcije v profilu
Odprtost | Profili profil izrecnost-Zajetje |  | % | Decimalno | False | Odstotek standardne funkcije posebej obravnavana v profilu
Odprtost | Profili-profila Extensions-Razširitev Širina |  |  | Integer | False | Število nestandardnih funkcije, ki jo določi profila
Odprtost | Profili-profila Extensions-Zajetje |  | % | Decimalno | False | Odstotek razširitve podrobno v profilu
Odprtost | Dostopnost izdelki, izdelkov in skladnosti-število izdelkov |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Število izdelkov podpira obvezne značilnosti standarda 0:Ni izdelkov podpirati standard 1:Enega ali več proizvodov izvajanje del standarda 2:Več kot en izdelek izvaja vse dele standarda 3:Veliko več kot en izdelek izvaja vse dele standarda
Odprtost | Dostopnost izdelki, izdelkov in skladnosti-Application skladnosti |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Kaj je stopnja skladnosti se izdelki s standardom? 0:Noben 1:Trdil, 2:Dokazali 3:Certificirani in Pokazale
Odprtost | Dostopnost izdelki, izdelkov in skladnosti-skladnosti kakovosti |  | [0 | 1 | 2 | 3] | Iskanje / Seznam | False | Kakovost za preskušanje 0:Noben 1:In-house testiranje razvijalec izdelkov 2:Neodvisno testiranje (npr NIST) 3:Dokazali v okviru zadevnega proizvoda

Komponenta, povezave in Arhitekturni Lastnosti

V spodnji tabeli so navedene komponente, povezave in arhitektura lastnosti izhodne odprtosti ocenjevalca. Vse naslednje lastnosti oceni, da med nič (0) in tri (3), nič (0), ki je najmanj zaželeno in tri (3), ki je najbolj zaželen.Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Odprtost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi osnovnega spremembo lastnine v skladišču in odprtosti simulatorju zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Data Type | Zahtevana | Opis
Odprtost | Odprtost | Decimalno | False | Splošna ocena odprtosti elementa.
Odprtost | Standardi-Standard Zapadlost | Decimalno | False | Sedanje stanje standarda, kar kaže, ali je bilo odobreno, kako dolgo je že v uporabi in kako dobro sprejet, da je znotraj skupnosti razvijalcev.
Odprtost | Standardi-Standard izrecnost | Decimalno | False | Izrecnost standardov, kar kaže na morebitno dvoumnost v posledičnih standardi
Odprtost | Profili Profil Dokumentacija | Decimalno | False | Obseg, v katerem profil vmesnik dokumentacija je razvil in ali je dokumentacija profil odraža dejansko zasnovo sistema in / ali izvaja sistem
Odprtost | Profili Profil izrecnost | Decimalno | False | Raven podrobnosti, če v profilu / specifikacijo profila
Odprtost | Profili profil Extensions | Decimalno | False | Stopnjo, do katere profil ustreza standardom na katerem temelji
Odprtost | Izdelki-Product Dostopnost in skladnosti | Decimalno | False | Ali ne obstaja odprt standard conformant proizvodi na voljo za uporabo v projektu


Simuliranje Uspešnost

Navigacija: Simuliranje svojo arhitekturo> Simulacije>

Simuliranje Uspešnost

Pošlji komentarje o tej temi.

Ozadje

Arhitekturna Ocenjevalec za uspešnost je diskretni dogodek simulator, ki deluje tako, da simulira pretok sporočil (ali žetonov) po vsej arhitekturi. Teorija za to izhaja iz raziskave, ki jo je University of Technology, Sydney opravljeno, in temelji na Večplastna Queuing omrežni modeli(LQNM), Omeji in Barvne Petri-Nets(TCPN) in Dejavnost Časovni diagrami(ACD).

V simulaciji delovanja ABACUS, je predelava na eni komponenti jih v veliki meri sporočil opravili z njim iz druge komponente. Načela za to tehniko je mogoče razumeti v štirih glavnih delov:

1. sporočilo-centrickomunikacija je oblikovan v ABACUS uporabo logično(ali posredne) povezave. Logične povezave določite vedenje (frekvence in podatkov), sporočil, opravljenih med komponentami. Dober primer logičnih povezav bi bilo zaporedje tokov med dvema (2) poslovnih procesov oziroma logičnih vmesnikov med dvema (2) aplikacij.

2. Logične sporočila se prevažajo v namembni kraj prek Hierarhija(kot swimlanes sredstev) ali neposrednapovezav (kot fizične žic). S tem pa so ti usmerjeni navzgor, čez storiti in nazaj dol hierarhijo (večplastna pristop) slediti neposredno pot.

3. Zvestoba modela se lahko prilagodi. Na primer, postopek razdelimo navzdol do sedaj, tako da ima vsaka osnovna Postopek in funkcija ločena procesna odtis. Lahko pa je dovolj, da ima samo eno vrednost celotnega procesa, ki odražajo povprečnoOdziv predelavo na sporočilo.

4. Dejanska predelavase izvede le s sestavnimi deli, ki imajo (ali so) procesor. Procesor je generično stvar, in je lahko CPU, oseba, organizacijska enota ali karkoli drugega, ki je sposoben izvajati dela. Na primer, poslovni proces, ne naredi nobene dejanske predelave; To naredimo tako, prvega "procesor" se najde v vsaki svoji matični hierarhiji (če se uporabi swimlane zapis) ali njene predelovalne omrežje (če je uporabljena porazdeljeno procesiranje zapis).

Ovrednotenje se izvaja s simulacijo (določeno) prometa v sistemu, tako da je vsaka povezava simulirano vsaj enkrat. Prihod časi sporočil so naključno v zvezi z njihovo določeno frekvenco. Model simulira obdelavo in trditve virov in vrstičenje sporočil, zbiranje statističnih podatkov na poti, kot je različnih izhodnih lastnosti.

Ključne Uspešnost Vhodni dejavniki

1. Frequency- Frekvenca, pri kateri pride do povezave.

2. Predelava- Količina časa izvršitve za dokončanje enega procesa. To je lahko v urah, minutah, dni, operacije itd

3. Speed- Hitrost vira procesorja. To je, koliko ciklov / navodila / dejanja lahko opravlja v eni enoti časa. Pomembno je, da se v skladu z enotami, ki se uporabljajo za obdelavo.

4. Procesorji- Število procesorskih virov. Predelovalci so lahko ljudje, CPU, zunanje organizacije itd

Ključne Uspešnost Izhodni dejavniki

1. Pretovor- Število sporočil na časovno enoto skozi povezava. Ta dejanska vrednost lahko primerjamo s pričakovanimi / teoretične vrednosti (tj frekvence) sklepati nasičenost sistema.

2. Sporočilo Rate- Število sporočil na časovno enoto skozi komponenta. To je vsota vhodnih in izhodnih sporočil vseh komponent.

3. Odgovor- Najmanjši / povprečna / maksimalna latence za to povezava. To je vsota vseh opazovanih latence za povezavo od izvira do ponora in vse čakalne vrste in obdelave (in latence nazaj k izvoru, če dvosmerno).

4. Uporaba- Izkoriščenost komponenta. To bo 0%, če je komponenta ni naprava / procesor (kar pomeni, da nima procesorji in lastnosti Hitro zgoraj).

Medtem ko je diskretno simulacijo dogodka izvedli za izračunavanje različnih izhodnih lastnosti, kot je opisano zgoraj, se lahko naslednja formula se uporablja kot grobo preverjanje rezultatov (kjer se sistem ne nasičenih):

Izkoristek = vsota frekvenc za vse dohodne povezave * Processing / (Speed ​​* procesorji)

Celoten koncept je morda najbolje pokazala upoštevamo naslednje diagram, ki prikazuje dve različni uspešnosti meta modelov. Slog levica je klasična "swimlane" Zapis z nalogami, za obdelavo hierarhično, ki temeljijo na njihovih procesorskih virov. Slog desno roko je "razdeli" Zapis z nalogami obdelave povezani preko procesov povezavo do njihovega procesorja vira. Ta zadnji zapis omogoča številne vire procesorskih za določeno obdelavo nalogo, za razliko od omejenega swimlane zapisu.

Opomba

Prikazano na vsakem meta-modela so vhodni lastnosti (v rdeči barvi) in izhodne lastnosti (v modri barvi):

Uspešnost metamodeli: Swimlane versus Distributed zapisu

Tek Performance simulator

Za simulacijo svojo arhitekturo v smislu izvedbe

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Izberite Analiza| Zmogljivostali kliknite gumb v orodni vrstici.

3. Izberite Arhitekturaželite oceniti iz spustnega menija.

Opomba

Privzeto bo ABACUS samodejno izbere prvo arhitekturo, za katero je zaradi potreben ponovni simulacija za vse zadevne nepremičnine ali strukturnih sprememb.To poudarjanje je prikazano v Red o Orodna vrstica simulacija .

4. Izberite Komponentein Povezaveželite, da oceni, od okno za izbiro standardni element .

5. Nastavite Čas delovanja Faktor lestvicedrsnik.

Opomba

Višje vrednosti bo prinesla več statistično dosledne rezultate, vendar traja dlje časa, da izračun.

Dodatne Potrditveno poljek okno za izbiro standardni element

· Save Transformed Modelbo shranite kopijo RBD predelani obliki projekta v isti mapi kot trenutni projekt in dodajte "_transformed« na ime projekta.Ta preoblikoval projekt se lahko uporabljajo za diagnosticiranje podrobno simulacijo zanesljivosti, ki jih izvajajo ABACUS.

Druge možnosti na okno za izbiro standardni element

· Čas delovanja Faktor lestvice nadzoruje čas simulacije in natančnost z višjo Vrednosti donosingveč statistično dosledne rezultate, vendar ob daljši čas run.

Opomba

Ko ABACUS izračunava čas simulacije bo določila najpočasnejši posredne povezave Frequency, ki je bil izbran, da se simulira in nato "toplo-up" za obdobje (tj 1 nad frekvenco) zvezi s tem (začetek redne generatorje sporočil za vse povezave naključno V tem času toplo-up, ki jim daje vse možnosti za začetek) in potem simulacijo za Run Čas Faktor lestvice kratnemu Obdobje zvezi s tem. Ali (1 / frekvenca) čas toplo-up + (1 / frekvenca) * Čas Delovanja Lestvica Factor čas simulacije. To je zagotoviti, da se, da so vsi priključki začeli pred statistike zbrali in nato je najpočasnejša povezava še simulirane vsaj enkrat v simulaciji. Npr Če ima najpočasnejši posredna povezava s frekvenco 0.033 časovnih enot (ali circa enkrat mesečno, če so časovne enote dni), potem bo čas toplo-up biti 30,3 časovne enote in bo čas simulacije biti 30,3 časovne enote krat čas Run Faktor lestvice.

6. Kliknite Finishin boste dobili Opozorilopogovorno okno.

7. Želji raziskati opozorila s klikom Podrobnosti >>.

8. Kliknite Naprej.

Opomba

Na tej točki, bo ABACUS opravljajo diskretnih dogodkov simulacijo arhitekture in po kratkem času (z bari napredku za povratne informacije), se bo prikazal izračun popolno pogovorno okno.

9. Kliknite v redupriznati simulacijo.

Nasvet

Za tečaje usposabljanja in nadaljnjega pomoč na Uspešnost Simulacija se obrnite na Avolution Skupnosti .

Lastnosti Component

V spodnji tabeli so navedene lastnosti, potrebnih za ovrednotenje uspešnosti. Lastnosti so iskali najprej v komponenti primerih, potem komponento standardi in če ni mogoče najti, se uporabi privzeti.Te lastnosti bodo prikazani v oknu Properties z ikono input lastnina selektorja vrstica ( [image] ) Z namigu "Uspešnost vnosni". Sprememba za katero od teh "vhodnih" lastnosti in raznih strukturnih sprememb v skladišču bo odražalo v Uspešnost simulatorju, ki zahteva ponovno simulacijo, kot je navedeno v Red o Orodna vrstica simulacija .

Tip | Name | Privzeta vrednost | Enota | Data Type | Zahtevana | Opis
Obnašanje | b_pack | 0.0 |  | Decimalno | False | Fiksni čas Storitev za pakiranje v nekaj sekundah. Ta lastnost tipično določena kot standardne vrste in nato uporabljene za več komponent primerkov. Na primer, CORBA ima b_pack = 0,23 ms.
Obnašanje | m_pack | 0.0 |  | Decimalno | False | Spremenljivka čas Storitev za pakiranje v sekundah / bajt. Ta lastnost tipično določena kot standardne vrste in nato uporabljene za več komponent primerkov.
Obnašanje | b_unpack | 0.0 |  | Decimalno | False | Fiksni čas Storitev razpakirajte v nekaj sekundah. Ta lastnost tipičnodoločena kot standardne vrste in nato uporabljene za več komponent primerkov.
Obnašanje | m_unpack | 0.0 |  | Decimalno | False | Spremenljivka čas Storitev razpakirati v sekundah / bajt. Ta lastnost tipičnodoločena kot standardne vrste in nato uporabljene za več komponent primerkov.
Obnašanje | Predelava | 0.0 |  | Decimalno | True | Znesek času izvršitve za dokončanje enega procesa. To je lahko v urah, minutah, dni, operacije itd
Obnašanje | Procesorji | 1 |  | Integer | True | Število procesorskih virov. Predelovalci so lahko ljudje, CPU, zunanje organizacije itd
Obnašanje | Speed | 100 |  | Integer | True | Hitrost vira procesorja. To je, koliko ciklov / navodila / dejanja lahko opravlja v eni enoti časa. Pomembno je, da se v skladu z enotami, ki se uporabljajo za obdelavo.
Obnašanje | k_bkgd | 0.0 |  | Decimalno | False | Obdelavo ozadja na komponento. To se uporablja za prilagajanje rezultatov, da se ujemajo vse fiksne nadomestil za%. To se verjetno lahko zanemari.

V spodnji tabeli so komponentni lastnosti izhod s strani ocenjevalca uspešnosti. Nabor teh sestavnih lastnosti so ustvarjeni za vsako komponento na vsakem uspešnosti vožnjo.Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Uspešnost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in uspešnosti simulatorju zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Enota | Data Type | Zahtevana | Opis
Obnašanje | Sporočilo Rate |  | Decimalno | False | Število sporočil v časovni enoti skozi komponento. To je vsota vhodnih in izhodnih sporočil vseh komponent.
Obnašanje | Bandwidth |  | Decimalno | False | Na splošno pasovna širina skozi element. Vsota tako zaradi dohodnih in odhodnih sporočil.
Obnašanje | Uporaba | % | Decimalno | False | Izkoristek komponento. To bo 0%, če je komponenta ni naprava / predelovalec (tj Nima procesorji in lastnosti hitrosti opredeljeni zgoraj)

Lastnosti povezava

V spodnji tabeli so navedene lastnosti, potrebnih za ovrednotenje uspešnosti. Lastnosti so iskali najprej v primerih za povezavo in nato standardi in, če ni mogoče najti, se uporabi privzeti.Te lastnosti bodo prikazani v oknu Properties z ikono input lastnina selektorja vrstica ( [image] ) Z namig "Uspešnost vhod" ali "Cost / Uspešnost vhod". Sprememba za katero od teh "vhodnih" lastnosti in raznih strukturnih sprememb v skladišču bo odražalo v Uspešnost simulatorju in / ali Stroškovno simulator zahteva ponovno simulacijo, kot je navedeno v Red o Orodna vrstica simulacija .

Tip

Name

Privzeta vrednost

Enota

Data Type

Zahtevana

Opis

Obnašanje

Kind

dvosmerno

[dvosmerno | enosmerno]

Iskanje / Seznam

True

Ali povezavo, je dvosmerna (dvosmerno) ali enosmerno (enosmerno).

Dovoljene vrednosti za to nepremičnino so "dvosmerni" ali "enosmerno".

Dvosmerna pomeni sinhrone sporočil prošnja / odzivne KER enosmerno pomeni eno asinhroni "dogodek".

Obnašanje

Abstrakcija

posredni

[posredna | neposredna]

Iskanje / Seznam

True

Ali je povezava fizično ali logično. Neposredne povezave so fizični "cevi" med dvema komponentama, da logične povezave tečejo skupaj.

Dovoljene vrednosti za to nepremičnino so "neposredni" ali "posredni".

Če je vrednost "neposredna", potem pa se povezava ne potrebujemo nobenih drugih lastnosti (razen za lastnosti vrste in abstrakcija).

Podatki

L_app1

0

Integer

False

Zahtevaj / velikost dogodek v bajtih.

Vsaka povezava bodo imeli posebno vrednost za to. V CORBA, dogodki so dejansko dvosmerno in vedno ima 12 bajt priznati (L_app2). Če je to res, enosmerno povezavo pustite nepremičnine v L_app2.

Podatki

L_app2

0

Integer

False

Odziv / priznavajo velikost v bajtih.

Vsaka povezava bodo imeli posebno vrednost za to. Enosmerno povezava ne bo L_app2.

Obnašanje

Frequency

1

Decimalno

True

Frekvenca, pri kateri pride povezava.

Vsaka povezava bodo imeli posebno vrednost za to. Če je nepremičnina Frequency izpustili, potem se uporabi privzeti.

Obnašanje

Razmerje

procesi

[procesov | podpira]

Iskanje / Seznam

False

Povezave, ki imajo "procesi" lastnost kažejo, da bo komponenta na začetku povezave transformirana je treba obdelati na sestavnem konec povezave. V bistvu je "vir" sestavni preselil, da postane otrok od "potopi" komponente (priložene povezave so tudi "vlekli", s to potezo).

Če "procesi" premoženje obstaja, potem vse druge lastnosti povezave bodo prezrti, razen neobvezni "%" premoženje je opisano v nadaljevanju.

Obnašanje

%

100,0

Decimalno

False

Povezave, ki so na "procesi" premoženja (opisano zgoraj), lahko po želji imeti "%" premoženje, ki označuje delež obdelave, ki bodo pripisane komponento destinacijo. Na ta način se lahko en vir komponenta lahko obdela več komponent destinacija različnih% ih. Na% vrednosti ni potrebno dodati do 100%, in se preprosto uporabljata za normiranje "predelavo" lastnost (glej zgoraj), da se komponenta vira kot je transformirana, da postane otrok sestavine destinacije.

V spodnji tabeli so navedene lastnosti, ki jih povzroča ocenjevalca uspešnosti. Nabor teh lastnosti povezave so ustvarjeni za vsako povezavo na vsakem uspešnosti vožnjo.Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Uspešnost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in uspešnosti simulatorju zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Enota | Data Type | Zahtevana | Opis
Obnašanje | Bandwidth |  | Decimalno | False | Celotna pasovne širine za povezavo. Ta se izračuna samo za posredne povezave in je v bistvu (L_app1 + L_app2) * pretovora.
Obnašanje | Bandwidth 1/2 |  | Decimalno | False | Pasovna širina posebej za odhodne (1) in vhodnih (2) sporočil povezavo. Ta se izračuna samo za posredne povezave in je v bistvu L_app1 * Prepustnost in L_app2 * pretovora.
Obnašanje | Pretovor |  | Decimalno | False | Število sporočil v časovni enoti skozi povezavo. Ta dejanska vrednost lahko primerjamo s pričakovanimi / teoretične vrednosti (tj frekvence) sklepati nasičenost sistema.
Obnašanje | Dopolnil | % | Decimalno | False | Odstotek sporočil, da je uspešno končana obdelave za povezavo. Ta se izračuna samo za posredne povezave in je Prepustnost / frekvence. Občasno Dopolnil vrednost presega 100%, ker je naključnost rezultatov generacije sporočilo v nekoliko višjem generacije sporočilo frekvenco, kot je navedeno.
Obnašanje | Odgovor (Min / Ave / Max) |  | Decimalno | False | Minimalna / povprečna / maksimalna latence. Ta se izračuna samo za posredne povezave in je opazovana latence za povezavo od vira, da se potopi in vse čakalne vrste in predelavo (in latence nazaj k izvoru, če dvosmerno).

Lastnosti arhitektura

V spodnji tabeli so navedene arhitekturne lastnosti celotnega sistema, ki jih povzroča ocenjevalca uspešnosti. Posamezen sklop lastnosti za arhitekturo so "združeni" za vsako uspešnosti vožnjo.Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Uspešnost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in uspešnosti simulatorju zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Enota | Data Type | Zahtevana | Opis
Obnašanje | Sporočilo Rate |  | Decimalno | False | Število sporočil na časovno enoto skozi komponent v zgradbi. To je vsota vhodnih in izhodnih sporočil vseh komponent.
Obnašanje | Pretovor |  | Decimalno | False | Število sporočil na časovno enoto prek povezav v arhitekturi. To je vsota pretoke vseh posrednih povezav "in s tem dejanska vrednost lahko primerjamo s pričakovanimi / teoretične vrednosti (tj frekvenca) sklepati nasičenost sistema.
Obnašanje | Bandwidth |  | Decimalno | False | Celotno pasovno širino. Vsota povezave pasovne širine arhitekture je.
Obnašanje | Uporaba | % | Decimalno | False | Izkoristek vseh sestavin. Sme biti večja od 100%, saj je samo vsota vseh sestavnih koriščenje arhitektura je.
Obnašanje | Odgovor (Min / Ave / Max) |  | Decimalno | False | Minimalna / povprečna / maksimalna latence. Vsota vseh opazovanih latence za povezave arhitektura je iz vira, da se potopi (in nazaj do vira, če dvosmerno).


Simuliranje Zanesljivost in razpoložljivost

Navigacija: Simuliranje svojo arhitekturo> Simulacije>

Simuliranje Zanesljivost in razpoložljivost

Pošlji komentarje o tej temi.

Ozadje

Zanesljivosti Ocenjevalec izračuna zanesljivosti arhitekture s pomočjo komponent vhodnih in povezave.

Za sestavne dele in neposrednih povezav, je zanesljivost temelji na povprečni čas med neuspeh (MTBF). Samo spremenljivke, ki so potrebni za izračun zanesljivosti arhitekturnih elementov, so:

· MTBFvrednost (v letih);

· Povprečni čas za popravila (MTTR)neuspeh (v letih); in

· Opredeljeno časovno obdobje, da preizkusite zanesljivost konec.

Formula za izračun Zanesljivost je podana kot:

Zanesljivost = -e (-y x starost)
Kjer je y = 1 ÷ MTBF

Razpoložljivost komponent in povezav temelji na MTBF in MTTR. Upoštevajte, da razpoložljivost, za razliko od zanesljivosti, ne vpliva na obdobje, za katerega je bilo, ki se preskuša.

Razpoložljivost = MTBF / (MTBF + MTTR)

Medtem metod, ki pretvarjajo Zanesljivost blokovni diagrami(z uporabo preprostih serije in vzporedne konstrukte) daje najbolj natančne rezultate, te metode postanejo zelo impraktična, ko smo poskušali izračunati zanesljivost za službena potovanja v velikih omrežjih tisoč elementov. Poleg tega ti transformacijska pristopi razgraditi za veliko skupnih struktur, kot so omrežja "očes".

Monte Carlometoda omogoča zanesljivost in razpoložljivost sistema poljubne velikosti in zahtevnosti se izračuna. Postopek Monte Carlo simulacijo mnogo scenarijev in fali vsak Scenarij naključno stanje, na voljo ali ni na voljo, Ki je dodeljena vsaki fizični element. Verjetnost danem element pa v razpoložljivem stanju temelji na zanesljivosti / razpoložljivosti sestavine.

Na primer, lahko pričakujemo, da bo na voljo pri približno 90% vseh scenarijih komponenta z razpoložljivostjo 90%. Zanesljivost in razpoložljivost posredni povezavi je bilo zato mogoče oceniti kot delež naključnih scenarios- za katere obstaja pot elementov razpoložljivega izkazih od vira do cilja.

Opomba

Ker se izračun lokalnega zanesljivosti in razpoložljivosti na osnovi različnih parametrov in različnih formul (in s tem tudi za posledico različne vrednosti), je treba dodeliti vsak element dvečlanic, enega za razpoložljivost in enega za zanesljivost. Izračun razpoložljivosti uporablja stanje razpoložljivosti v vsakem scenariju, ker je izračun zanesljivosti uporablja stanje zanesljivosti v vsakem scenariju.

Zanesljivost Ocenjevalec uporablja simulacijske tehnike Monte Carlo izdelati zanesljivost določeno arhitekturo. Arhitektura je dal skozi tisoče posameznih simulacij in rezultati so zbrani v tabeli za izpeljavo ukrepa zanesljivost. Kot je navedeno zgoraj, Monte Carlo je najhitrejša tehnika za simulacijo večje omrežja in bo sodelovala s katero koli kompleksa (tj mrežnimi) strukture.

Ocenjevalec izhodi štiri vrednote:

1. Poslanstvo Zanesljivostže več let;

2. Razpoložljivost od arhitektura;

3. Zanesljivost od lokalna komponentaže več let; in

4. Razpoložljivost od lokalna komponenta.

Ocenjevalec izide verjetnost sestavnega dela ali povezava deluje (tj ne ni), in čas, potreben za popravilo.

Kako standardi s MTBFs in / ali MTTRs se obravnavajo

Če ima element (komponenta ali povezava) standardov z namenskimi MTBF in / ali MTTR vrednosti, se te vrednosti uporabijo tudi pri izračunu lokalno zanesljivost in razpoložljivost elementa kot zaporedne povezave.

Na primer, če je sestavni AZ dodeljenimi standardi B, CIn Dvsak ima MTBF in MTTR vrednost, Local Zanesljivost = R(A)× R(B) × R(C) × R(D), kje R = Izračunana zanesljivost (s pomočjo formule) sestavnih / standardiin Lokalno Na voljoSposobnost = A (A)× A (B) × A (C) × A (D), kje A = Izračunana Na voljosposobnost (z uporabo formule) sestavnega dela / standardi. To pomeni, da če je element tri standarde vsak s MTBF in MTTR vrednostsIn tudi MTBF in MTTR vrednostsza lastnosti elementa je, lokalno zanesljivost in avilability je podana kot vrednost serije vsakega standardov in samega elementa.

Kot drug primer, če je sestavni Aima dodeljene standarde B, CIn Dvendar le standardno Bima tako z napakami in vrednostjo MTTR, medtem ko standardni Cima le vrednost MTBF in standardni Dima le vrednost MTTR, Lokalni Zanesljivost = R (A)× R (B)× R (C), kje R= Izračunana zanesljivost (s pomočjo formule) sestavnih / standardi in lokalno Razpoložljivost = A (A)× A (B)× (C), kje A= Izračunana razpoložljivost (po formuli) sestavnih / standardih vendar pri izračunu (C), ker ima standard le vrednost MTBF je 'iskanja'za vrednost ujemanje MTTR (-e) in bodo dodali vse MTTR vrednosti ugotovi, da je don't imajo same MTBF vrednosti ujemanje, tako da v tem primeru bi bilo uporabiti vrednost MTTR standardnih D. Če je bil drug standard, pravijo E, Samo z vrednostjo MTTR ter nato (C)bi uporaba MTBF za Cz MTTR dne Din Eseštevajo. Če drugega standarda, pravijo FJe imel samo vrednostjo MTBF nato A (F)bi tudi uporabite MTTR z Din Eseštevajo.

Računanje Mission Zanesljivost

Medtem ko je izračun lokalno zanesljivost je stvar uporabo preprosto formulo, izračun posrednih povezav (službena potovanja), ni tako enostavno, še posebej, ko imamo kompleksne in velike mreže prepletenih poteh (priključki), in komponent.

Ob celotno omrežje na račun

Kot posredni povezave ne predstavljajo fizične povezave, moramo izvedeti, kako lahko komponenta vir dobili na svojo destinacijo komponento. In to pomeni gledamo na celotno omrežje in vse različne načine (in poti), naš vir komponenta se lahko sprejmejo za dosego komponento destination (umivalnik).

Opomba

Dokler obstaja vsaj ena popolnapot od vira do cilja, bo misija uspešnain posredno povezavo, označujemo kot zaprte povezave.

Razumevanje Link Matrix

Če želite vedeti, kateri deli / neposredne povezave so povezani s tem, kar moramo artefakt hitro preveriti, ali sta dve bloki povezani v določeno smer. To je funkcija matrike povezavo. Na kratko, matrica povezava je dvodimenzionalni niz logičnih spremenljivk, ki določa, ali lahko komponenta neposredno doseže drugo komponento. Njena velikost je enaka kvadratu skupnega števila sestavnih delov v omrežju.

Enostavno Zanesljivost Block Diagram (RBD)

Podobni Link Matrix za zanesljivost blok diagram (RBD)

Ker so vsi priključki dvosmerna (šlo v obe smeri), je pomembno znal pravilno branje matrike povezavo. V zanesljivosti ocenjevalca, prvi argument je vir in drugi argument je destinacija (umivalnik).

Torej, če povezava matrika (A, B) = true potem to pomeni, da je A lahko dobijo neposredno B (enosmerni). B lahko priti do A če je le, če matrika povezava (B, A) = True. Če je to res, to pomeni dvosmerno povezavo.

V danem primeru nad:

· Vir 1 lahko doseže cilj, 0 (vir 1 in Destinacija 0 daje rezultat true); in

· Vir 0 morejo doseči cilja 1 (vir: 0 in Destination 1 daje rezultat true), kot je povezava med 0 in 1 dvosmerno.

· Vir 2 ne more doseči cilja 1 (vir 2 in Destination 1 daje rezultat False), tudi takrat, ko lahko vir 1 doseže Destination 2 (Vir 1 in Destination 2 daje rezultat true). To pomeni, da je povezava med 1 in 2 uni-directional.

Razumevanje zanesljivosti blok diagram

Diagram zanesljivost blok (RBD) povzema strukturo celotne objektni model v obliki blokov in povezav. Vsak blok predstavlja element, ki ima možnost neuspeha ali uspeha po povezavah / poteh, ki jih povezujejo. Obe deli in povezave lahko postane "blok" v RBD.

Primer RBD Bloki in povezave

Številka Zgoraj predstavlja RBD primer. Črtkana rdeča črta predstavlja eno samo misijo 4 do 1. Opomba kako obstajata samo dve možni poti za misijo 4 do 1.

Menijo trgovca 4 do 3 z 0: 1 in trgovca 4 do 7 do 1. črtkana blokov 2, 5in 6 predstavljata blokov, ki ne vplivajo na neuspeh / Non-neuspeh misije 4 proti 1. To niso in so prezrte. To je pomembno, saj je za večino misij se bo večje število presežnih blokov, ki ne bo vplivala na uspeh zamenjave določenega misije. To je bolj očitno pri večjih omrežjih, pri čemer se bo število presežnih blokov, da rezultati simulacije netočni.

Da bi pospešili čas simulacije, in zagotoviti bolj natančne rezultate, je treba izvleček iz celotnega RBD in uporabljajte le elemente, ki vplivajo na uspeh neke misije.

Opomba

Posamezen pot / pot ne more iti skozi vsako komponento dvakrat.

V tej fazi smo lahko ustvarite matriko povezavo in izvesti simulacijo Monte Carlo.

Računanje Arhitektura Razpoložljivost

Razpoložljivost arhitektura je verjetnost, da bo na voljo vse posredne povezave so na kateri koli točki v času. Razpoložljivost vsak posredni povezavi je določen v vsaki ponovitvi simulacije Monte Carlo, pa ti posredne povezave (običajno) zanašajo na isti nabor fizikalnih elementov. Torej, preprosto združevanje ti posamezni razpoložljivosti bi "dvojno štetje" te un-omogočita, kar pesimistično splošno razpoložljivost arhitekture. Druga možnost je skupna razpoložljivost arhitektura izračuna ga je videti na vsaki ponovitvi in ​​videli, ali so na voljo tudi elementi, ki sodelujejo pri posrednih povezav interesa. In potem združevanje teh rezultatov na koncu simulacije.

Tek zanesljivosti simulator

Za simulacijo svojo arhitekturo v smislu zanesljivosti

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Izberite Analiza| Zanesljivost.

3. Izberite Arhitekturaželite oceniti iz spustnega menija.

Opomba

Privzeto bo ABACUS samodejno izbere prvo arhitekturo, za katero je zaradi potreben ponovni simulacija za vse zadevne nepremičnine ali strukturnih sprememb.To poudarjanje je prikazano v Red o Orodna vrstica simulacija .

4. Izberite Komponentein Povezaveželite oceniti iz okno za izbiro standardni element uporabo "Pokaži neposredne povezave" in "Prikaži procesov povezav" radio-gumb filtrov na spodnji levi strani pogovornega okna za pomoč pri vas izbor.

Dodatne Potrditveno poljek okno za izbiro standardni element

· Save Transformed Modelbo shranite kopijo RBD predelani obliki projekta v isti mapi kot trenutni projekt in dodajte "_transformed« na ime projekta.Ta preoblikoval projekt se lahko uporabljajo za diagnosticiranje podrobno simulacijo zanesljivosti, ki jih izvajajo ABACUS.

Dodatne Radio-Gumbik okno za izbiro standardni element

· Pokaži neposredne povezave samodejno nastavi povezavo Ima filter nepremičnino za nepremičnino Type = vedenja, name = abstrakcije in vrednost = neposredna.Ta možnost je privzeto izbrana in pripomočki za izbor "neposrednih" povezav, kot je opisano zgoraj in spodaj.

· Prikaži procesi Povezave samodejno nastavi povezavo Ima filter nepremičnino za nepremičnino Type = vedenja, ime = Povezava in vrednost = procesov.Ta možnost pomaga pri izbor "neposredne povezave", kot je opisano zgoraj in spodaj.

5. Kliknite Naslednja.

6. Izberite Službena potovanjatj Connections želite v simulaciji vključiti.

7. Nastavite Čas delovanja Faktor lestvicedrsnik.

Opomba

Višje vrednosti bo prinesla več statistično dosledne rezultate, vendar traja dlje časa, da izračun.

Potrditvena polja

· Prikaži Zaprte Povezavebo samodejno filtrira voljo priključke vključiti samo tiste, ki imajo vsaj eno popolno fizično pot od komponente vira do cilja komponente, kot na izboru RBD zgoraj opisano.

· Prikaži posrednimi povezavami samodejno nastavi povezavo Ima filter nepremičnino za nepremičnino Type = vedenja, name = abstrakcije in vrednost = posredni.Ta možnost je privzeto izbrana in pripomočki za izbor "posrednih" ali Mission povezav, kot je opisano zgoraj in spodaj.

Gumbi

· Vsiizbere vse povezave.

· Obrniprekliče izbiro vseh trenutno izbrano povezave in izbere vse tiste, ki niso bili izbrani.

· Nobenprekliče izbiro vseh povezave.

Druge možnosti

· Čas delovanja Faktor lestvice nadzoruje čas simulacije in natančnost z višjo Vrednosti donosingveč statistično dosledne rezultate, vendar ob daljši čas run.

Opomba

Ko ABACUS izračuna število iteracij za simulacijo, ki ga določi najzanesljivejši element, ki ni povsem zanesljiva in nato simulira za Run Čas Faktor lestvice krat 1 nad nedostopnosti navedenega elementa plus 1 ponovitev. Ali (MTBF + MTTR) / MTTR * Čas Delovanja Lestvica Factor + 1. To je zagotoviti, da se ta element še vedno uspe vsaj enkrat v simulaciji. Npr Če ima najzanesljivejši element, ki ni popolnoma zanesljiv je MTBF 10.000 ur in je MTTR 8 ur, nato pa se bo simulacija traja (10.000 + 8) / 8 = 1.251 krat Run čas Lestvica faktorjem + 1 iteracij.

· Let za Ahead Simulacija Določa število let za misije Zanesljivost se izračuna za.

· Numbra nitidetermines število procesnih niti uporabiti za simulacijo Monte Carlo.Ta možnost bo privzeto, da se ujema število razpoložljivih CPU / jeder (vključno večnitna jedra), da se zmanjša celotni čas simulacije.

8. Kliknite Finishin boste dobili Opozorilopogovorno okno.

9. Želji raziskati opozorila s klikom Podrobnosti >>.

10. Kliknite Naprej.

Opomba

Na tej točki, bo ABACUS izvedete Monte-Carlosimulacija arhitekture in po kratkem času (z bari napredku za povratne informacije), se bo prikazal izračun popolno pogovorno okno.

11. Kliknite v redupriznati simulacijo.

Nasvet

Za usposabljanj in nadaljnji pomoči na zanesljivosti simulacije se obrnite na Avolution Skupnosti .

Komponent in povezave Nepremičnine

V spodnji tabeli so navedene komponento in"neposredni"lastnosti povezave potrebno oceniti zanesljivost. Te lastnosti bodo prikazani v oknu Properties z ikono input lastnina selektorja vrstica ( [image] ) Z namigu "Zanesljivost vnosni". Sprememba za katero od teh "vhodnih" lastnosti in raznih strukturnih sprememb v skladišču bo imelo za posledico zanesljivosti simulatorju, ki zahteva ponovno simulacijo, kot je navedeno v Red o Orodna vrstica simulacija .

Tip | Name | Privzeta vrednost | Enota | Data Type | Zahtevana | Opis
Zanesljivost | MTBF | ∞ | let, tednov, dni ali ur | Decimalno | True | Povprečni čas pred porušitvijo elementa. Opomba: Vrednosti se lahko izrazi v enotah let, tednih, dnevih ali urah in se preračunajo po '24 / 7 "koncept je razpoložljivost kot sledi; - 1 leto = 52 tednov ali 365 dni ali 8.760 ur - 1 teden = 7 dni ali 168 ur - 1 dan = 24 ur
Zanesljivost | MTTR | 0 | let, tednov, dni ali ur | Decimalno | True | Povprečni čas do Repair elementa. Opomba: Vrednosti se lahko izrazi v enotah let, tednih, dnevih ali urah in se preračunajo po '24 / 7 "koncept je razpoložljivost kot sledi; - 1 leto = 52 tednov ali 365 dni ali 8.760 ur - 1 teden = 7 dni ali 168 ur - 1 dan = 24 ur

V spodnji tabeli so navedene komponento in"neposredni" lastnosti povezave proizvodnja po zanesljivosti ocenjevalca. Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Zanesljivost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in zanesljivosti simulatorju zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Enota | Data Type | Zahtevana | Opis
Zanesljivost | Zanesljivost - x let |  | Decimalno | False | Verjetnost, da element ne bo uspelo v naslednjih x let. To je vrednost med 0 in 1.
Zanesljivost | Nezanesljivost - x let |  | Decimalno | False | Verjetnost, da se element ne v naslednjih x let. To je vrednost med 0 in 1.
Zanesljivost | Razpoložljivost | % | Decimalno | False | Izračunana razpoložljivost sestavnega dela ali povezave. To je vrednost med 0% in 100%.
Zanesljivost | Nedostopnost | % | Decimalno | False | Izračunana nerazpoložljivost komponente ali povezave. To je vrednost med 0% in 100%.

V spodnji tabeli so navedeni 'posredni'lastnosti povezave proizvodnja po zanesljivosti ocenjevalca. Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Zanesljivost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in zanesljivosti simulatorju zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Enota | Data Type | Zahtevana | Opis
Zanesljivost | Poslanstvo Zanesljivost - x let |  | Decimalno | False | Verjetnost, da posredna povezava ne bo uspelo v naslednjih x let. To je vrednost med 0 in 1.
Zanesljivost | Poslanstvo Nezanesljivost - x let |  | Decimalno | False | Verjetnost, da bo posredna povezava ne v naslednjih x let. To je vrednost med 0 in 1.
Zanesljivost | Razpoložljivost | % | Decimalno | False | Izračunana razpoložljivost posredne povezave. To je vrednost med 0% in 100%.
Zanesljivost | Nedostopnost | % | Decimalno | False | Izračunana nerazpoložljivost posredne povezave. To je vrednost med 0% in 100%.

Lastnosti arhitektura

V spodnji tabeli so arhitektura lastnosti izhodne zanesljivosti ocenjevalca. Te lastnosti bodo prikazani v oknu Properties z ikono izhod lastnina selektorja vrstica ( [image] ) Z namigu "Zanesljivost izhod". Puščica na ikono se bo zasvetila Red ( [image] ), Ko so te lastnosti zastareli zaradi zadevne nepremičnine ali strukturnih sprememb v skladišču in zanesljivosti simulatorju zahteva ponovno simulacijo glede na Red poudarkom na Orodna vrstica simulacija .

Tip | Name | Enota | Data Type | Zahtevana | Opis
Zanesljivost | Razpoložljivost | % | Decimalno | False | Razpoložljivost vseh posrednih povezav, ki so bile vključene v vrednotenje. To pomeni, da je verjetnost, da vseposredne povezave bo na voljo v danem trenutku. To je vrednost med 0% in 100%. Opomba: To ni množenje posameznih priključnih razpoložljivosti saj bi bilo to "dvojnega štetja" un-razpoložljivostjo ustreznih komponent.
Zanesljivost | Nedostopnost | % | Decimalno | False | Nerazpoložljivost posrednih povezav, ki so bile vključene v vrednotenje. To pomeni, da je verjetnost, da vsaj enposredna povezava bo na voljo v danem trenutku. To je vrednost med 0% in 100%. Opomba: To ni množenje posameznih priključnih unavailabilities saj bi bilo to "dvojnega štetja" un-razpoložljivostjo ustreznih komponent.
Zanesljivost | Poslanstvo Zanesljivost - x let |  | Decimalno | False | Verjetnost, da se bo vse posrednih povezav, ki so bile vključene v vrednotenje ni ne v naslednji xlet. To je vrednost med 0 in 1. Opomba: To ni množenje posameznih priključnih reliabilities saj bi bilo to "dvojnega štetja" un-razpoložljivostjo ustreznih komponent.
Zanesljivost | Poslanstvo Nezanesljivost - x let |  | Decimalno | False | Verjetnost, da bo vsaj eden od posrednih povezav, ki so bili vključeni v ovrednotenje ne v naslednjem xlet. To je vrednost med 0 in 1. Opomba: To ni množenje posameznih priključnih unreliabilities saj bi bilo to "dvojnega štetja" un-razpoložljivostjo ustreznih komponent.


Simulira svojo arhitekturo

Navigacija: Simuliranje svojo arhitekturo>

Simulira svojo arhitekturo

Pošlji komentarje o tej temi.

Ko ste poseljena in analizirali svoje arhitekturo, ste pripravljeni za uporabo ABACUS da ugotovi, če bo vaš arhitektura ustrezajo vašim kvantitativne potrebe. To zahteva simulacija. Za simulacijo vaše arhitekturo morate najprej odločiti o vrsti informacij, ki jih želite odkriti. Te vrste informacij se pogosto omenja kot KPI ali ključnih kazalcev uspešnosti. Na primer, hočeš analizirati uspešnost, razvojnostjo in odprtost, ali želite, da zbere metrike kot skupne stroške lastništva. Vse te informacije se lahko pokazala na nek način. Ko imate te podatke, boste lahko, da analizira svoje arhitekture v različnih grafičnih formatih (ali neposredno analizirati nove vrednosti).

Obstajajo tri možnosti za simulacijo vaše arhitekturo:

· Preproste meritve ;

· Pre-zgrajena simulatorji ; ali

· Scripting .

Enostavne Metrics

Vsaka komponenta v arhitekturi ima lastnosti - mnogi, ki so lahko po meri za vašo uporabo ABACUS. Te lastnosti predstavljajo različne lastnosti komponent. V nekaterih primerih pa preprosto zbiranje teh meritev (za izgradnjo KPI) je lahko dovolj, da vam povem pomembne informacije o arhitekturi. Na primer, KLOCS ali tisoče vrstic kode, ki so bili pogosto uporablja kot merilo kompleksnosti. V drugih primerih, boste morda želeli izvoz podatkov in jo analizirali z uporabo drugega orodja. Poleg tega, boste morda želeli zbrati lastnosti po izvedbi drugo vrsto simulacije.

Lastnosti lahko zbirajo skozi proces združevanje . Združevanje dodaja določene sub-lastnosti skupaj, kar se odraža v matični komponento. Združevanje deluje le na sestavnih delih, ki vsebujejo pod-komponent.

Pre-zgrajena Simulatorji

Obstaja pet vnaprej zgrajena simulatorji, ki se lahko uporabljajo z ABACUS. Ti so:

· Zmogljivost;

· Modularnost;

· Skupni stroški lastništva (TCO);

· Odprtost; in

· Zanesljivost.

Opomba

ABACUS bo samodejno označi, kateri od teh simulatorjev treba ponovno zagnati skozi Red poudarkom na Orodna vrstica simulacija .

Scripting

Scripting zagotavlja fleksibilnost za simulacijo vaše arhitekture meri načine. By pisanje skripte lahko izvedete simulacije izven toka vgrajeno zmogljivostjo ABACUS. Celotna ABACUS objektni model je na voljo skriptnega motorja, tako da so omejene le z vašo sposobnost pisanja scenarijev!

Visual Basic script je skriptni jezik, ki ga ABACUS podprl, saj zagotavlja osnovne programske funkcije v razmeroma preprosti obliki.

Poglej tudi

Izvažanje svojo arhitekturo | Agregatne lastnosti | Pisanje skripte


Razvija svojo arhitekturo

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Razvija svojo arhitekturo

Pošlji komentarje o tej temi.

Arhitekture lahko izrecno razvil in hierarhija arhitektur ustvarili. Tako ga razvija svojo arhitekturo v ABACUS, se lahko ustvari številne napredne arhitekturne rešitve, primerjali in baselined. Cilji (ali metrike) se lahko opredeli za poljubno število arhitekturnih lastnosti za obstoječe arhitekture.

Preprost način, da se upošteva razvoj arhitekture je, da se nanašajo na koncept potomec arhitektura. Ko je arhitektura razvila, A copymatične arhitekture je ustvaril. Ta izvod lahko rekli, da je neposredna potomecizvirnika matičnaarhitekture.

Opomba

V tem spletu help dokumentacije in sama ABACUS garnituro, izraz razvijajoje bolj pogosto uporablja kot izraz potomecUpoštevajte, da se oba nanašata na isto funkcionalnost.

Razvijati obstoječo arhitekturo

1. Zagotovite imate ABACUS datotekaodprt in Explorer Windowprikazani.

2. Izberite ustrezno arhitekturo, ki jo želite, da se iz raziskovalec drevesa.

3. Desni kliko arhitekturi in izberite Evolveiz menija.

Razvijajoče izbranem Architecture

4. Sproščeni arhitektura bo pojavilo pod izbrano arhitekturo.

Evolved Architecture

Opomba

Sproščeni arhitektura lahko preimenujete z desnim klikom na arhitekturi in izbiro Preimenovanje.Poleg tega bodo vsi načrti in katalogi v sproščenega arhitekture se samodejno nastavi na "diff" glede na osnovni arhitekturi da je razvila iz.

Postavljanje ciljev za vaše razvil arhitekture

Postavljanje ciljev za vaše razvil arhitektura vam omogoča, da ustvarite merila za ocenjevanje razvoja vaše arhitekture. Cilji se določijo na podlagi vrste lastnine in imeni tistih lastnosti, ki obstajajo v vašem razvil arhitekture. Cilji se lahko tudi ročno opredeljena in dodal, da vas arhitekture. Sledite spodnjim korakom, da nastavite cilje.

Postavljanje ciljev iz obstoječih lastnosti za vaše razvil arhitekturo

1. Zagotovite imate ABACUS datotekaodprt in Explorer Windowprikazani.

2. Izberite Orodja | Zastavljenih ciljevOd glavnem meniju.

3. Cilj vnosaOdprlo se bo prikazal.

Cilj Vhod Window

4. Kliknite na Obstoječegumb.

5. Izberite lastnostOdprlo se bo prikazal.

6. Izberite lastnost, ki jo želite nastaviti kot cilj za vaše razvil arhitekturo in kliknite na gumb v redugumb.

7. Izbrani cilj se bo sedaj pojavil v Cilj vnosaokno.

8. Izberite cilj in kliknite na gumb Uredigumb.

9. Uredi ciljOdprlo se bo prikazal.

Opomba

To okno vam omogoča, da spremenite ime lastnosti in vrsto, da bo cilj razmislek, kot tudi najslabša in najboljša (ali najnižje / najvišje vrednosti) za to lastnost. Te vrednosti se ugotovi s primerjavo vseh arhitektur in iskanju najmanjšo in največjo vrednost v vsaki za to posebno lastnost. Te vrednosti lahko tudi ročno opredeljena. Na primer, če ste bili, da se določi cilj za nepremičnine imenom Odgovor (Ave)in tipa ObnašanjeLahko vaša najhujša in najboljšo vrednost odraža hitrost transakcije, potrebne za optimalno delovanje (najboljše vrednosti) in hitrost transakcij, potrebnega za samo glavnih vlogah, ki se obdelujejo (najslabša vrednost).

10. Ko so bile opredeljene ustrezne vrednosti, izberite v redu.

Postavljanje ciljev iz nove lastnosti za vaše razvil arhitekturo

1. Zagotovite imate ABACUS datotekaodprt in Explorer Windowprikazani.

2. Izberite Orodja | Zastavljenih ciljevOd glavnem meniju.

3. Cilj vnosaOdprlo se bo prikazal.

4. Kliknite na Newgumb.

5. Nov ciljOdprlo se bo prikazal.

Opomba

To okno vam omogoča, da določite ime lastnosti in vrsto, da bo cilj razmislek, kot tudi najslabšo in najboljšo vrednost (ali minimalne / maksimalne vrednosti) za to lastnost. Na primer, če ste bili, da se določi cilj za nepremičnine imenom Odgovor (Ave)in tipa ObnašanjeLahko vaša najhujša in najboljšo vrednost odraža hitrost transakcije, potrebne za optimalno delovanje (najboljše vrednosti) in hitrost transakcij, potrebnega za samo glavnih vlogah, ki se obdelujejo (najslabša vrednost).

6. Ko so bile opredeljene ustrezne vrednosti, izberite v redu.

7. Pogovorno okno za Dodaj na vseh arhitekturahbo prikazal kot spodaj:

8. Kliknite na Dadodati cilj kot lastnino na vseh ustreznih arhitektur. To zagotavlja, da se bo na novo definiran cilj in njene lastnosti doda vseh arhitekture v spisu. Če ne želite vključiti nepremičnine v arhitektur, ki jih lahko s klikom na Ne.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Pregled zvezd parcelo vaših razvijal arhitektur | Pregled razpršenih parcelo vaših razvijal arhitektur


Širi in zrušiti drevo

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Širi in zrušiti drevo

Pošlji komentarje o tej temi.

Ko vozlišče v drevesu podelementi komponente in zbirke, bo imel majhen [image] ali [image] prijavite na svoji levi. Lahko kliknite [image] razširiti vozlišče in videti svoje pod-komponent in povezav. Podobno lahko kliknete [image] na propad vozlišče skriti pod-komponent in povezave (da bi več prostora, ali bi drevo lažje razumeti).

Druga možnost je, lahko razširite celotno vozlišče, v katerem primeru vseh njenih podskupin vozlišč bo razširjen tudi, in njihove podvozlišče in njihova ... itd Podobno lahko strnite celotno vozlišče - zapiranje več ravneh hkrati .

Poleg tega obstajajo možnosti za širitev le arhitekture, elemente (tj komponent in povezave), komponente ali povezav.

Če želite razširiti ali strniti celotno vozlišče (in njene podvozlišče, itd)

1. Desni klikna vozlišču.

2. Izberite Razširi | Vsi aliCollapse.

Če želite razširiti vse arhitekture (ov)

1. Desni klikna Architectures ali arhitekture.

2. Izberite Razširi | Vsi.

Če želite razširiti elemente

1. Desni klikna Architectures ali arhitekture.

2. Izberite Razširi | Elementi.

Če želite razširiti komponente

1. Desni klikna komponente, sestavnega dela ali podskupini.

2. Izberite Razširi | Komponente | Vsi.

Za širitev povezave

1. Desni klikna povezave, povezave ali sub-povezave.

2. Izberite Razširi | Povezave | Vsi.


Izvažanje vaš Architecture

Navigacija: Poročanje o vaši arhitekturi>

Izvažanje vaš Architecture

Pošlji komentarje o tej temi.

ABACUS vam omogoča, daizvoziti svojo arhitekturo MDB (Microsoft Access), MS SQL Server, .abacus (ABACUS datoteka) in .xls (Microsoft Excel) format. Prav tako lahko izvozite vaš diagrams do PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF in BMP formatu in vaših poročil .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) in .rtf (Rich Text Format) format. To vam omogoča, da analizira in si ogledali arhitekturo in svoje podatke na kakršen koli način, ki ga želite.

Če želite izvoziti svojo arhitekturo MDB (Microsoft Access)

1. Zagotovite imate ABACUS datotekaopen.

2. Kliknite na mapamenu.

3. Izberite Izvoz, in potem Za MDB.

4. Upoštevajte opozorila in kliknite v redu.

5. Vnesite ime za datoteko.

6. Kliknite ShraniButton.

Opomba

Oblika izvoz baze podatkov MDB je specifična za ABACUS in morebitnih sprememb shem bo imelo za posledico nezmožnost za ponovni uvoz. Prosimo, glejte Poselitve z MS Access Za opis sheme MS Access.

Če želite izvoziti svojo arhitekturo MS SQL Server

1. Zagotovite imate ABACUS datotekaopen.

2. Kliknite na mapamenu.

3. Izberite Izvoz, in potem MS SQL Server.

4. V pogovornem oknu, ki se prikaže, kliknite Export Blank MDB ...gumb in uvozite v svoj strežnik baze podatkov MS SQL Server.

5. Izpolnite podatke v baze podatkov in povezovalnem nizu.

6. Kliknite IzvozButton.

Opomba

Oblika izvoz MS SQL ServerBaza podatkov je specifična za ABACUS in morebitnih sprememb shem bo imelo za posledico nezmožnost za ponovni uvoz. Prosimo, glejte Poselitve z MS Access Za opis sheme zbirke podatkov.

Če želite izvoziti svojo arhitekturo .xls (Excel datoteka)

1. Zagotovite imate ABACUS odprto datoteko An explorer prikaže , In Arhitektura dodal .

2. Zagotovite imate Excel Import Export Configuration / datoteke opredeljena.

3. Desni klikna arhitekturo v vašem modelu ali kateri koli del Komponentevozlišče (v danem arhitekture), ki jo želite izvoziti v datoteko Excel Configuration.

4. Izberite Izvoz | Če želite Excel ... iz menija.

5. Izberite Excel Import Export Configuration / datoteko za uporabose prikaže okno.

6. Izberite ustrezno konfiguracijsko datoteko za vašo arhitekturnega modela in kliknite na gumb Odprigumb.

7. Če ne avtomatično storili, zemljevid komponente najvišji ravni v vašem trenutnem arhitekture na Set ID(kot je definirano prej) in kliknite Export ....

Primer Top-Level Component Mapping

8. Izberite lokacijo in ime vašega Excelove datoteke in kliknite Shranigumb.

Če želite izvoziti svojo arhitekturo .abacus (ABACUS file)

1. Zagotovite imate ABACUS datotekaopen.

2. Desni klikna Arhitekturnega vozlišču, vsaka arhitektura v vašem modelu ali kateri koli del Components drevesa.

3. Izberite Izvoz | Če želite Mapa...iz menija.

4. Izberite lokacijo in ime datoteke in kliknite Shranigumb.

Opomba

Lahko uvozite datoteko ABACUS nazaj v ABACUS jih naslednjih korakih 1-2zgoraj in nato izbiro Uvoz | Od Mapa.... Ko ste izbrali datoteko, ki jo želite uvoziti, vas bo vprašal, kako bi želeli uvoziti standardov in vrste. Lahko uvozite standarde in tipe kot bodisi novih ali združila standardov in tipov. Privzeta nastavitev je, da se standardi in vrste združiti z obstoječimi standardi in vrst, če že obstaja v vašem Projekt.

Če želite izvoziti svojo arhitekturo .xml

1. Zagotovite imate ABACUS datotekaopen.

2. Desni klikna Architecture vozlišču, vsaka arhitektura v vašem modelu ali kateri koli del komponente drevesa.

3. Izberite Izvoz | Če želite XML ...iz menija. Alternativno lahko kliknete na menu mapa| Izvoz| Če želite XML ...

4. Izberite lokacijo in ime datoteke in kliknite Shranigumb.

Opomba

Lahko uvozite XML datoteko nazaj v ABACUS jih naslednjih korakih 1-2zgoraj in nato izbiro Uvoz | Od XML .... Ko ste izbrali XML datoteko, ki jo želite uvoziti, vas bo vprašal, kako bi želeli uvoziti standardov in vrste. Lahko uvozite standarde in tipe kot bodisi novih ali združila standardov in tipov. Privzeta nastavitev je, da se standardi in vrste združiti z obstoječimi standardi in vrst, če že obstaja v vašem Projekt.

Če želite izvoziti diagram PNG, JPG, SVG, TIFF, GIF ali BMP

1. Zagotovite imate ABACUS datotekaopen.

2. Odprite diagrambi želeli izvažati.

3. Kliknite na Izvoz Diagramgumb na Diagram orodna vrstica.

4. Izvoz Diagramse bo pojavilo okno.

5. Izberite Brskanjegumb, da shranite vizualizacijo na želeni lokaciji.

6. Izberite Shrani kot vrstopull-down menija, da izberete vrsto datoteke.

7. Kliknite Shranigumb.

Če želite izvoziti poročilo .pdf (Adobe Acrobat), .xls (Microsoft Excel)ali.doc (Microsoft Word)

1. Zagotovite imate ABACUS datotekaopen.

2. Ustvarjanje Poročilo bi želeli izvažati.

3. Kliknite na Izvozgumb na orodni vrstici poročila.

4. Izberite Excel, PDF ali besedaiz spustnega navzdol.

5. Počakajte nekaj trenutkov, medtem ko se je izvoz poročila.

6. Izberite lokacijo in ime datoteke in kliknite Shranigumb.


Iskanje in zamenjava artiklov v arhitekturi

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Iskanje in zamenjava artiklov v arhitekturi

Pošlji komentarje o tej temi.

Najdete in zamenjaj specifično komponento, povezave, tip, standard ali lastnost z uporabo ABACUS "Najdi in zamenjaj objekt.

Če želite poiskati element

1. Kliknite vozlišče drevesa, ki ga želite v iskanje.

2. Izberite Uredi| Ugotovijoali pritisnite Ctrl + F.

3. Vnesite besedilo za postavkada bi našli v področju 'ugotovite, kakšna ".

4. Kliknite Najdi Naprej.

Če želite zamenjajte element

1. Kliknite vozlišče drevesa, ki ga želite v iskanje.

2. Izberite Uredi| Zamenjajali pritisnite Ctrl + H.

3. Vnesite besedilo zapostavkada bi našli v "Najdi, kar" polje in besedilo, da ga nadomestiti z v "Zamenjaj z" polje (ali nič, če polje pustite prazno).

4. Kliknite Najdi Naprejda bi našli prvi primerek "Najdi" besedila in klik Zamenjaj da se ta primerek s 'Zamenjaj z' besedila ali klik Zamenjaj vsezamenjati vse primerke.

Imate možnosti, da:

o Match svojo sodno prakso,

o Match celo besedo,

o Iskanje od začetka projekta,

o Ignoriraj arhitekture - da je arhitektura sami vozlišč. Vsa vozlišča beneath arhitekture vozlišč, kot sestavnih delov in priključkov se bodo še iskali,

o Ignoriraj komponente - da je komponenta sami vozlišč,

o Prezreti povezave - da je povezava sami vozlišč,

o Ignoriraj standardov - to je vse standardne vozlišča arhitekture, komponent in povezave ne bodo upoštevani,

o Ignoriraj vrst - da je tip same vozlišča. Kakršne koli prisile vozlišča beneath vozlišč tipa bodo še iskali,

o Ignoriraj predloge in vsebino - da je šablona se vozli, kot tudi vse predloge komponente in povezave vozlišča pod njimi,

o Ignore - to je vse vrste nepremičnin, imena, vrednosti in enote iz vseh elementov modela se ne bodo upoštevani,

o Ignoriraj opise -, da so opisi vseh elementov modela se bo prezrt.

Poglej tudi

Kako se arhitektura zastopana v ABACUS


Pomoč v drugih jezikih

Navigacija: Uvod v ABACUS>

Pomoč v drugih jezikih

Pošlji komentarje o tej temi.

ABACUS pomoč je na voljo v različnih drugih jezikih / prevodov in se lahko prenesete iz spodnje povezave.

Če želite nadomestil sedanji ABACUS datoteko pomočiz prevedeni datoteki pomoči sledite naslednjim korakom:

1. Shranite datoteko pomoči iz ustrezne spodnje povezave.

2. Preimenovati datoteko pomoči do ABACUS.chm.

3. Odprite datoteko, ki jo dvakrat kliknete in če z "Open File - varnostno opozorilo" pogovorno okno se pojavi nato počistite "vedno vprašati, preden odprete datoteko" možnost in kliknite Odpri.

4. Zaprite datoteko.

5. Zamenjajte datoteko ABACUS.chm v mapi Program Files ABACUS, običajno "C: \ Program Files \ Avolution \ ABACUS"Ali"C: \ Program Files(x86)\ Avolution \ ABACUS".

Opomba

Konteksta pomoč bo še naprej sodelovala z prevedenih datotek pomoči.

ABACUS pomoč datoteke v drugih jezikih:

· Arabščina / العربية .

· Bolgarščina / български .

· Kitajščina (poenostavljena) / 中文 (简体) .

· Češčina / Česká .

· Danščina / Dansk .

· Estonščina / Eesti .

· Finščina / Suomen .

· Francoščina / Français .

· Nemščina / Deutsch .

· Madžarščina / Magyar .

· Islandščina / Islandščina .

· Indonezijščina / Indonezija .

· Italijanščina / Italiano .

· Japonski / 日本 の .

· Latvijščina / Latvijas .

· Malezijski / Malezija .

· Malteščina / Slad i .

· Norweigen / Norweigen .

· Poljščina / Po lska .

· Portugalski / Português .

· Ruščina / русский .

· Slovaščina / Slovenski .

· Slovenščina / Slovenski .

· Španščina / Españoles .

· Švedščina / Svenska .

· Turščina / Türk .

· Valižanščina / Cymraeg .

Poglej tudi

Kaj ABACUS storiti?


Kako se arhitektura zastopana v ABACUS?

Navigacija: Uvod v ABACUS>

Kako se arhitektura zastopana v ABACUS?

Pošlji komentarje o tej temi.

V ABACUS, si modelirati svojo arhitekturo. Zaradi enostavnosti, pravimo ta arhitekturni model, arhitektura.

Spodnja slika prikazuje, kako tipično arhitekturo 5deli (v hierarhiji) povezan z 2 povezav bi zastopana v ABACUS.

Kako je preprosta arhitektura zastopana v ABACUS

Imate lahko poljubno število arhitektur v enem ABACUS datoteko.

Prvi arhitektura na drevesu

Značilno je, da bi ustvarili novo arhitekturo, če želite oceniti spremembo. Na primer, da boš modela obstoječo arhitekturo najprej - to bi bilo prvo arhitekturo v drevesu. Morda ga imenujejo "Trenutni".

Drugi

Ko želite modelirati in ovrednotiti spremembo vaše obstoječe arhitekture (npr povečala zahteve), ki ste jo ustvarili novo arhitekturo. Najlažji način za to bi bil, da ustvarite kopijo "Trenutni" in preimenovanje To je evolucija 1 Poskus 1 ". To bi bila druga arhitektura v drevesu. Če so vaši vrednotenja "Evolution 1 Poskus 1 'uspešna, jo lahko preimenujete, da preprosto" Evolution 1'.

Tretji

Če "Evolution 1 Poskus 1" ne izpolnjuje vaše zahteve, lahko ustvarite kopijo, jo preimenujte v "Evolution 1 Poskus 2", in poskusite znova. To bi bila tretja arhitektura v drevesu.

Poglej tudi

Kaj ABACUS storiti? | Kako si to naredil (Pregled) | Kaj je arhitektura? | Delo z ABACUS datotek | Ustvarjanje ali podvajal arhitekturo


Kako uporabljati ABACUS (pregled)

Navigacija: Uvod v ABACUS>

Kako uporabljati ABACUS (pregled)

Pošlji komentarje o tej temi.

Ta tema nudi osnovni pregled nalog, ki se ukvarjajo z uporabo ABACUS.

Naslednji diagram prikazuje proces analize, ki temeljijo na arhitekturo, ki ABACUS predvideva razvijajoče sedanjo arhitekturo na novo ali ciljne arhitekture.

Abacus Process

Za uporabo ABACUS:

1. Revizija - Preden začnete uporabljati ABACUS, morate zbrati vse informacije, ki jih imamo o arhitekturi in njene zahteve.

· Arhitektura - Identificirati potencialne komponente arhitekture in kako med seboj sodelujejo. Treba bi bilo le nekaj komponent na najvišji ravni. To so ti "bistvene sestavine". Tudi najbolj zapletene arhitekture mora imeti manj kot 10 bistvenih komponent. npr Bistvene sestavine arhitekture zavarovalnico, je lahko politika, prejemki, terjatve in plačila.

· Zahteve- Moraš vedeti, kaj se pričakuje od arhitekture, da bi ugotovili, če je zadovoljiva. npr Število transakcij na uro.

· Kje si jo našel? - Te informacije lahko pridejo iz specifikacije zahtev, projektne dokumentacije, razgovore z zainteresiranimi stranmi, iztegnjenem kode, itd V bistvu vsako gradivo, ki je na voljo ponuja ABACUS informacije o arhitekturi.

2. Zapolnijo -Uporabite ABACUS za modeliranje svoj arhitekturo in opredelili zahteve arhitektura se bodo merili.

· Arhitektura - V ABACUS začnete s prazno arhitekture - moraš zapolnijoga. To pomeni, da vnesete vse informacije arhitekture boste zbrali zgoraj. Lahko zapolnijo svojo arhitekturo ročno (s pomočjo menija na desni klik), ali pa jo lahko zapolnijo samodejno (iz Microsoft Visio, Excel, Access, itd). Značilno zgornjem večina ravni (bolj abstraktni) arhitekture bo poseljena ročno, in nižje ravni (bolj konkretni) bo samodejno poseljena.

· Zahteve - Kot ste dodate komponente in povezave, ki ste jo določili njihove lastnosti. V večini primerov bo te lastnosti lahko zahteve arhitekturo. Na primer, če boste imeli 1.250 MIPS vozlišča / grozda, bi dodate vozlišče kot sestavni del, nato dodamo lastnost uspešnosti in dodelite vrednost 1250 MIPS.

3. Analizirajte - Uporabite ABACUS elegantno analizirati in vizualizirati kompleksno strukturo vaše arhitekture.Vi mogoče analizirati arhitekturo na več načinov ali iz številnih stališč, vključno z diagrami, 3D in Explorer. Druga možnost boste morda želeli uporabljati nekatere bolj specifične poglede, kot sledi:

· Graf svojo arhitekturo - da bi dobili zmogljivost (odzivni čas, pasovno širino, itd), stroški (bar, pita, itd), ali razvojnostjo (sposobnost prostora, kompromis, itd) ogledov.

· Ustvarite poročilo o vaši arhitekturi.

4. Simulirati - Uporabite ABACUS simulirati vašega arhitekture je zmogljivost, razpoložljivost, stroški, odprtost, itd

· Če želite to narediti, zaženite eno od simulatorjev. ABACUS oceni vašo Arhitektura proti vašim zahtevamz izvajanjem simulacije. To bere in analizira sedanjo arhitekturo, teče simulacije in izračuna nekaj novih lastnosti. Te lastnosti se nato shrani nazaj v arhitekturi. Nove lastnosti so podatki, ki ga poskušate analizirati, kot izkoriščanje, odzivni čas, pasovno širino, razpoložljivosti%, TCO itd

5. Inženir- Uporaba ABACUS odgovoriti na različne »kaj če« scenarije in nadzorovati razvoj vaše arhitekture. Engineering je proces ponavljanje Zapolnijo - Analizirati - Simulacijacikel.

· Na tej točki,"veverjetno razvili razumevanje tekočega arhitekturo in izpostavil področja, ki jih potrebujete, da se razvijajo. Precej pogosto, vendar pa boste morali ponoviti zapolnijo - Analizirati - simulacija procesa večkrat. To bo verjetno zato, ker lahko traja nekaj iteracij, preden boste našli Target arhitekture. Tudi, če je vaša arhitektura zelo zapletena, boste morda želeli ponoviti postopek za vsako arhitekturno "ravni".

6. PlanPrihodnost vaše arhitekture s pomočjo informacij, ki jih ABACUS.

Opomba

Če ne poskuša razvijati obstoječo arhitekturo, boste morda morali ponoviti nekaj korakov večkrat in v drugačnem vrstnem redu. To je odvisno od tega, kaj skušaš narediti. Na primer, če ste oblikovanju nove arhitekture, boste verjetno le zapolnijo svojo arhitekturo enkrat, nato pa uporabite ABACUS v daljšem časovnem obdobju za usmerjanje prihodnjega razvoja (-e) arhitekture. Po drugi strani pa, če kupujete novo arhitekturo in imajo več alternativ med katerimi lahko izbirate, boste morali Odkrijte in Zapolnijo za vsako od alternativ, in nato Analizirati in simulira vsak eno neodvisno pred izvedbo končnega primerjavo na konec.

Poglej tudi

Kaj ABACUS storiti? | Kaj je arhitektura? | Kako se arhitektura zastopana v ABACUS? | Poselitev svojo arhitekturo | Analiziranje svojo arhitekturo | Simulira svojo arhitekturo


Uvažajo v vaš arhitekturo

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Uvažajo v vaš arhitekturo

Pošlji komentarje o tej temi.

ABACUS vam omogoča, uvoziti Vaše arhitektura mora iz .abacus (ABACUS file), .xml (an ABACUS XML fragment ali ArchiMate Interchange Jezik XML datoteke), .vsd (Microsoft Visio) format, in .xls (Microsoft Excel) format. To vam omogoča, da zgraditi svojo arhitekturo iz zunanjih virov hitro.

Če želite uvoz Vaše arhitektura od.abacus (ABACUS file)

1. Zagotovite imate ABACUS datotekaopen.

2. Desni klikna Arhitekturnega vozlišču, vsaka arhitektura v vašem modelu ali kateri koli del Components drevesa.

3. Izberite Uvoz| Od Mapa...iz menija.

4. Izberite lokacijo in .abacus mapa in kliknite Odprigumb.

Opomba

Ko ste izbrali datoteko, ki jo želite uvoziti, vas bo vprašal, kako bi želeli uvoziti standarde, Vrstein stališča. Lahko uvozite standarde, Vrste in stališča bodisi kot nove ali združila standardi, Vrstein stališča. Privzeta nastavitev je za standarde, Vrste in stališča se združila z obstoječimi standardi, Vrste in stališča če že obstajajo (z istim točno imenom) v vašem Projekt.

Če želite uvozVaše arhitektura od.xml (fragment ABACUS XML ali ArchiMate Interchange Jezik XML datoteka)

1. Zagotovite imate ABACUS datotekaopen.

2. Desni klikna Architecture vozlišču, vsaka arhitektura v vašem modelu ali kateri koli del komponente drevesa.

3. Izberite Uvoz| Od XML ...iz menija.

4. Izberite lokacijo in .xml datoteke in kliknite Odprigumb.

Opomba

ABACUS bo uvoziti le pravilno oblikovan ABACUS XML fragment ali ArchiMate Interchange jezik XML datoteko. Ko ste izbrali XML datoteko, ki jo želite uvoziti, vas bo vprašal, kako bi želeli uvoziti standarde, Vrstein stališča. Lahko uvozite standarde, Vrste in stališča bodisi kot nove ali združila standardi, Vrstein stališča. Privzeta nastavitev je za standarde, Vrste in stališča se združila z obstoječimi standardi, Vrste in stališča če že obstajajo (z istim točno imenom) v vašem Projekt.

Če želite uvozVaše arhitektura od.VSD(Visio mapa)glej tukaj .

Če želite uvozVaše arhitektura od.xls (Excel datoteka)glej tukaj .


Uvažanje vrste in standarde iz knjižnice

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Uvažanje vrste in standarde iz knjižnice

Pošlji komentarje o tej temi.

Lahko uvozite vrste in standarde iz knjižničnega datoteke ABACUS. Lahko tudi izvoz vrste in standarde iz vašega ABACUS datoteke na datoteko s knjižnico ABACUS.

Če želite uvoziti vrste in standarde iz knjižnice v svojo arhitekturo

1. Zagotovite imate ABACUS datotekaodprt in Explorer Windowprikazani.

2. Izberite Datoteka | OdpriČe želite odpreti ABACUS knjižnica datoteka.

3. Abacus knjižnica odpre v drugem jezičku v oknu Explorer in boste morali odsidranje to jezičku da bi lahko povleci-in-spusti iz njega na prvotno ABACUS datoteko.

4. Povleci in spustitipi in standardi iz knjižnice v vašem arhitekture.

- Ali -

1. Izberite Datoteka | New ...

2. Ustvari novo ABACUS datotekatemeljile na časovno ABACUS knjižnica datoteka.

Če želite izvoziti vrste in standarde iz arhitekture v knjižnici

1. Zagotovite imate ABACUS datotekaodprta, Explorer Windowprikaže, An ABACUS knjižnica datotekaodprt in Knjižnica Windowprikazani.

2. Povleci in spustivrste in standardi iz vašega arhitekture v knjižnici.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno


Vmesnik ABACUS

Navigacija: Uvod v ABACUS>

Vmesnik ABACUS

Pošlji komentarje o tej temi.

Ko začnete ABACUS, boste videli glavni zaslon, ki je prazna, razen za menije in orodne vrstice na vrhu, oknu prazno Explorer in naslovno vrstico. Ta zaslon bo središče vašega interakcije z ABACUS.

Glavni elementi so:

· Glavni meniji

· orodne vrstice

· desni klik menija

· Explorer in lastnine okna

· vrstica stanja

Glavni meniji

Meniji so razporejeni v logičnem zaporedju.

Meniji so opisana kot sledi;

· Meni Datoteka- V meniju Datoteka vam omogoča ustvarjanje, odpiranje, zapiranje, shranjevanje, izvoz in objavi ABACUS datotek. Prav tako vam omogoča, da ustvarite, odpiranje, zapiranje in shranjevanje ABACUS knjižnica datotek.

· Edit menu- V meniju Edit ščipanje, kopiraj, prilepi, brisanje, preimenovanje, najti in rešiti elementein undo / redo operacije.

· Poglej meni- V meniju View vam omogoča odpiranje ali zapiranje različnih vmesnika Windows in vrstico stanjaKrmarite naprej in nazaj, pojdite na posebnih stališč in upravljanje namizij.

· Meni Insert- V meniju Insert vam omogoča dodajanje novih Standardi, Predloge, vrste, elementi, pogledtočkas, Katalogi, diagrami, karte, Poročila in matrike.

· Meni analiza- Meni Analiza vam omogoča, da zaženete vrednotenj pred arhitekture, vključno s; učinkovitost, stroški, zanesljivost, modularnost in odprtost.

· Meni Orodja- V meniju Tools omogoča izvajanje skriptov, zastavljenimi cilji za arhitekturoin opravljajo in arhitektura "diff". Prav tako lahko spremenite možnosti programa in prilagodite vmesnik meniju orodja.

· Meni okno- V meniju Window vam omogoča, da priklopite, poskrbi, show in skriti okno imate odprt.

· Menu Pomoč- V meniju Pomoč lahko dostopate ta ABACUS datoteke pomoči. Lahko odprete spletno stran, ogledati si licenca sporazum in si oglejte splošne podatke o ABACUS vključno z različico programske opreme in ABACUS podpore in kontaktne podatke. Lahko zagotovijo povratne informacije prek strani priglasitve vprašanje. Če je potrebno, lahko vnesete ključ za registracijo preko menija Pomoč.

To je vrstni red boste običajno sledijo, ko ste opravljanju svoje naloge;Ko ste ustvarili ali odprta mapa, Boste običajno zapolnijo svojo arhitekturo, nato pa pogledje (v Raziskovalcu, diagrami, 3D, Charts, itd.) Na tej točki, boste bodisi teči OcenjevalecAli boste ponovite postopek z isto arhitekturo ali drugačno arhitekturo. (Glej Kako uporabljati ABACUS (pregled) Za več podrobnosti.)

Have a pogled skozi glavni meni in poskusite predstavljati, kako boste jih uporabljajo za vaš sistem.

Opomba

Ti lahko Prilagodite svoje menije kadarkoli.

Orodne vrstice

Privzeto obstajajo naslednje orodne vrstice;

· Glavni orodna vrstica -

· Simulacija orodna vrstica -

· View orodna vrstica -

· Diagram orodjepalica (če diagram je odprt) -

· Makro Snemanje orodna vrstica -

Have a pogled skozi gumbi na vsaki vrstici s lebdi nad njimi videti orodja konico (bližnjica-ključ).

Opomba

Le nekateri gumbi bo aktiven, odvisno od tega, kaj ste izbrali v oknu Explorer in lahko Prilagodite svoje orodne vrstice kadarkoli.Poleg tega je gumb 'Potrdi / projektna omejitev Preverite na glavni orodni vrstici in gumbi na orodni vrstici Simulation bo zasvetila Red ko sprememba osnovnega skladišču zahteva po ponovnem preverjanju projekta ali ponovne simulacijo tega simulatorja oz. Hover nad gumb, da vidite, katere arhitekture so prizadeti.

Meni desno tipko miške kliknite

Glavni meniji in orodne vrstice so neuporablja za vse, čeprav. To je pogosto bolj priročen za uporabo kontekstni meni z desnim klikom za različne dejavnosti. (Tudi, niso vsi ukazi so na voljo skozi desni klik na voljo prek glavnih menijih, orodne vrstice ali ukazi na tipkovnici.)

Na primer, ko ste ustvarili datoteko in imate drevesni diagram vašega arhitekture, je bolje, da z desno tipko kliknite na Architectures v drevesu dodati novo arhitekturo. Podobno bi morali desno tipko miške kliknite na komponente, da dodate novo komponento. Z desno tipko miške kliknite na nekaj stvari v drevesu, da vidim, kaj lahko narediš.

Nasvet

Na splošno, boste uporabljati glavne menije za opravljanje več nalog na visoki ravni, kot je ocenjevanje vaše arhitekture. Naloge nizki ravni - kot dodajanje posameznih komponent in povezav - so storili s pomočjo orodne vrstice in / ali desni klik menija.

Explorer in lastnosti okna

Ko odprete ali ustvarite datoteko, bo diagram drevo prikaže v oknu Explorer. To je okno v vaše arhitekture. In ko izberete elemente v oknu Explorer tri druga okna; Splošni Lastnosti, Referencein lastnosti okna bo posodobil, da odražajo podrobne informacije o svojem izboru.

Opomba

Splošni Lastnosti, Referencein lastnosti okna so privzeto skriti. Oglejte si Prilagajanje vmesnika kako jih prikazati in jih lahko pusti trajno prikazani.

Medtem ko ste gradnjo vaše arhitekture, raziskovalec in nepremicnine okna so najbolj koristni zastopanje. Ker se lahko propadel in razširjena, kot je potrebno, in ne postanejo okorna.

Okno Explorer ima drevo (in status bar) in okna nepremicnine imajo 5sekcije:

· Tip

· Standardi

· Opis

· Reference

· Nepremičnine

ABACUS meni vse te stvari, da se del arhitekture.

Tree

Ta oddelek ima drevo združene v 3 območja kot sledi:

1. Meta model

· Standardi- Če imajo številni deli enak nabor lastnosti, ki jih lahko opredeli niz up-spredaj, in potem samo ga dodelite komponent. Enako velja tudi za povezovanje in koli drugim elementom. Ta sklop standardnih lastnosti so shranjeni v Standardiveja drevesa. Namesto določanja vsako lastnost za vsako komponento, in vse premoženje za vsako povezavo itd, samo dodelite standardna. Na primer standardne značilnosti Unix-HP / UXlahko shranite kot Standardni in dodeljena vseh komponent ki uporabljajo Unix-HP / UXoperacijski sistem, kot je prikazano za OS01 Strežnik na sliki nad.

· Vrste - Ta veja drevesa je knjižnica vrst komponent in povezav lahko uporabite. Vrste se uporabljajo za opredelitev meta-model za arhitekturo in za razvrščanje in filtriranje, ko gledate svojo arhitekturo. Ti določajo tudi predlogo za kaj Standardi, Lastnosti in omejitve vaših komponent / povezave lahko.

· Stališča- Poglejtočkay je mogoče ustvariti iz obstoječih diagramov in se lahko uporablja za ustvarjanje novih diagramov.So diagram šablone.

· Predloge - Predloge trgovina ponovno uporabna vzorce sestavnih delov in povezave skupaj z načinom, na katerega so zastopane ali opazujemo. Ti si lahko predstavljate kot "mini" arhitekture ali rešitve, ki jih je mogoče namestiti v obstoječe arhitekture.

2. Arhitekture -V Arhitekture podružnica drevesa je, če ste izgradnjo arhitektura (e) za vaš sistem. (To se imenuje poselitev arhitekturo.) Lahko imaš poljubno število arhitektur v enem ABACUS datoteko.

3. Namizij - Podružnica namizij drevesa je, kjer lahko dostopate do katere koli shranjene namizij za projekt.

Opomba

Postavke v Explorer drevesa, ki so imeli svoje Posodobitev dovoljenje odstrani (to so samo za branje) so prikazane v sivi barvi.

Tip

To poglavje označuje specifično komponento ali povezave vrsto trenutno izbranega elementa v drevesu.

Standardi

To poglavje vsebuje seznam Standardi za trenutno izbrani element v drevesu.

Opis

To poglavje vsebuje kratek opis izbranega elementa v drevesu. Vseh povezanih hiperpovezave se lahko doda tudi k temu oddelku. Ti vključujejo spletne strani ali lokalne absolutne poti, ki kažejo na nadaljnje informacije o določenem elementu. Več linije so tudi dovoljeno. Veljavni hiperpovezave morate začeti z enim od 5 nizov; http: //, https: //, ftp: //, file: /// ali mailto :.

Nasvet

Za hiperpovezave s presledki, lahko uporabniki vnesete v URL ali pot, izberite želeno besedilo in Desni klik| Hiperpovezava. To se bo spremenilo nobenih presledkov na % 20tako da bo celoten URL ali pot delovala pravilno.

Ustvaril in s prirejenim

Ti oddelekszagotavljajouporabnik in datum / čas za ustvarjanje, in zadnja sprememba, trenutno izbrani element v drevesu.

Reference

To poglavje vsebuje seznam odhodne in dohodne komponente za trenutno izbrani element v drevesu.Prav tako kaže, diagrami, 3D in poglede grafikon, ki trenutno izbrani element pojavi. Če je izbrana diagram prikazuje stališča, če se uporablja za shemo in poglede na splošno kaže nobenih namizij pogled pojavi. In če standard je izbran v drevesu pa prikazuje uporabo standarda po vrstah, sestavnih delov in povezav.

Nepremičnine

Ta oddelek je, kjer boste opredeliti značilnosti elemente znotraj Vaše arhitektura, kot način, ki ga potrebujejo, da opravlja, število vrstic kode ima, odstotek teh vrstic, da so komentarji, itd

V "vnos" in "output" lastnosti vgrajenega vnaprej simulatorji bo prikazan v oknu Properties z ikono input lastnina selektorja vrstica ( [image] ) In izhod ikona ( [image] ) Oziroma z opisom, navedbo, ki pre-zidava simulator lastnost je povezana, na primer "Modularnost izhod" ali "Uspešnost vhoda". Puščica na izhodnih ikon bo zasvetila Red ( [image] ), Ko je lastnost zastarelo zaradi osnovnega premoženja ali strukturne spremembe v skladišču s simulatorjem zahteva ponovno simuliranje v skladu s Red poudarkom na Orodna vrstica simulacija .

Vrstica stanja

Leve del statusni vrstici prikazuje celotno pot do elementa skladišča trenutno-focus, bodisi izberemo v oknu Explorer ali na diagramplatno. To je tako, da je točen kraj v skladišču hierarhije za dani element vedno mogoče enostavno določiti. Desni del vrstice stanja prikazuje različne operativne sporočil, kot so "Odpri ABACUS Datoteka uspešno" in "izracun stroškov Completed".

Poglej tudi

Kako si to naredil (Pregled) | Prilagajanje vmesnika | Kaj je arhitektura? | Kako se arhitektura zastopana v ABACUS? | Delo z ABACUS datotek


Kaj ABACUS storiti?

Navigacija: Uvod v ABACUS>

Kaj ABACUS storiti?

Pošlji komentarje o tej temi.

Za pomoč v drugih jezikih / prevodi kliknite tukaj .

ABACUS potrebno ugibati-izšlo, ki se ukvarjajo z rešitvami, sistemov, programske opreme, informacij, tehnologij, poslovnih procesov in / ali celotnih podjetij (v nadaljnjem besedilu skupaj arhitekture). To vam lahko pomaga, da pragmatično načrtovanje, spremljanje, simulacijo, analizo in vizualizacijo vaš arhitektura da ga modeliranje, ga analizira v intuitivne načine (npr karte, diagrami in 3D), nato pa ga ocenjevanje proti vaših nefunkcionalnih zahtev.

Opomba

Nefunkcionalne zahteveso tiste zahteve, ki se ne nanašajo neposredno na to, kako izdelek deluje. Namesto, da so zaskrbljeni, kako dobro deluje. Nefunkcionalne zahteve vključujejo stvari, kot so uspešnost, odprtosti, razvojnostjo, kakovost, razširljivost, modularnost, itd (v nasprotju z funkcionalnih zahtev, kot so, vklopite tej luči, ko se ta gumb kliknili). Tradicionalno so nefunkcionalne zahteve, je težko - če ne celo nemogoče - za merjenje. V bistvu, ABACUS je edini proizvod, ki lahko objektivno in količinsko izmeriti prva tri - zmogljivost, odprtostIn razvojnostjo.

Preprosto povedano, vnesete arhitekturo in kaj ga zahteva storiti. ABACUS potem vam pove, če bo to naredil kot je potrebno, in poudarja, slabosti in vrzeli.

ABACUS črpa več kot 20 let raziskav sisteme in še veliko več let, ustanovljenega teorije sistemov. To vam daje merljive, zanesljive, objektivne odgovore, tako da vam ne opira na subjektivno oceno.

ABACUS stoji za Architecture-Based ANALIZA, COMUNIKACIJA in URAZUMEVANJEod Systems. To vam lahko pomaga pri vsakem velikem arhitekturo obsegu, vendar je na splošno uporablja za štiri (4) stvari:

· Razvijajočetok arhitekture. Na primer, če je vaša obstoječa arhitektura nima zmogljivosti, bo ABACUS vizualizirati arhitekturo za vas, prepoznavanje težav (ozka grla, itd), potem vam povem, natančnokako izboljšati arhitekturo.

· Oblikovanjenova arhitektura. Na primer, če boste potrebovali povsem novo arhitekturo, in ti si ga načrtovanju sami, ABACUS vam bo povedal, natančnokatere komponente potrebujete in kako bi jih bilo treba priključiti.

· Purchasingnova arhitektura. Na primer, če ste imenovali za zbiranje ponudb za projektiranje nove arhitekture, in ste izbrali med tremi modeli, ABACUS vam bo povedal, natančnokatera ustreza vašim zahtevam najboljše.

· Združevanjesedanje obstoječe arhitekture. Na primer, če morate združiti dve ali več ločenih arhitekture, ABACUS vas bo vodil.

Poglej tudi

Kako si to naredil (Pregled) | Kaj je arhitektura? | Kako se arhitektura zastopana v ABACUS?


Uporaba povezave v diagramih

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Uporaba povezave v diagramih

Pošlji komentarje o tej temi.

Oblike (brezplačna oblika in sestavni deli) in priključki (prosti obliki ali povezave) znotraj diagramov se lahko poveže z vašimi obstoječimi arhitekturnimi predstavništev v ABACUS, kot tudi zunanjih datotekah / mapah in URL-jev. Te povezave se nato lahko upravlja (ustvarjena, spremenjena in črtan) preko ABACUS toolset. Ta funkcija se lahko uporablja za povečanje navigacijo in splošno razumevanje vašega arhitekture shematično.

Za dodajanje povezav na vašo diagram

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Izberite ustrezno obliko ali priključek iz diagrama.

3. Desni klikod oblikeali priključek.

4. Izberite Odprte Povezavein PovezavePrikaže se okno.

5. Kliknite na Dodajikona in New LinkPrikaže se okno.

6. Izberite ustrezni Katalog | Matrix | Diagram| 3D pogled| Grafradijske gumbe, nato izberite ustrezen Katalog, matrica, diagram, 3Dali grafikon Pogled v tekočem arhitekture iz Link Daspustnega menija.

- Ali -

6. Izberite Spletna stranradio gumb nato vnesite ustrezen URL (npr http: //www.avolutionProgramska oprema.com /)na tem področju, da povezavo do spletne strani. Veljavni URL-ji morajo začeti z enim od 5godala; http: //, https: //, ftp: //, mapa:ali \\. Kakršne koli prostore, je treba vpisati z "% 20 '.

- Ali -

6. Izberite Absolute datoteke | Relativna datotekeizbirni gumby,nato kliknite na '..."Gumb za brskanje za zunanjo datoteko za povezavo do vaše diagram.

7. Kliknite v reduin nova povezava bo prikazana v oknu povezave. Opomba: Okno povezave lahko spreminjate velikost videti polno ime, če je to potrebno.

8. Ponovite korake 5-7ustvariti več povezav.

9. Slediti ustvarjeno povezavo, izberite ustrezno povezavo, prikazano v Povezaveokna in kliknite Odpri povezavo.

Opomba

Kdaj več pripombe, ki so prikazane za oblika ali priključek povezava je prikazana na prvi zaznambe v seznam opomb v pogovornem oknu Edit opombami.

Če želite slediti povezave iz vašega diagram

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Izberite ustrezno obliko ali priključek iz diagrama.

3. Kliknitena ustrezni hiperpovezave (modra poudaril ime komponento) na obliko ali priključek v diagramu, da odprete in si ogledate prvo povezavo iz oblikeali priključek.Opomba: Kazalec je treba spremeniti na "roko", ko je povezava pripravljena za kliknili.

- Ali -

3. Izberite ustrezno obliko ali priključek iz diagrama.

4. Desni klikod oblikeali priključek.

5. Izberite Odprte Povezavein PovezavePrikaže se okno.

6. Izberite ustrezno povezavo, ki jo želite ogledati.

7. Kliknite na Odpri povezavogumb, da odprete in si ogledate ustrezno povezavo.

Če želite izbrisati povezav v vaš diagram

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Izberite ustrezno oblikoali priključekiz diagrama.

3. Desni klikod oblikeali priključek.

4. Izberite Odprte Povezavein PovezavePrikaže se okno.

5. Izberite ustrezno povezavo, ki jo je treba črtati.

6. Kliknite na Izbrišigumb. in je vez odstranjena iz Povezave okno.

Organizacija povezav v vaš diagram

Izberete lahko, kateri povezan diagram, zunanjo datoteko, ali spletni URL se prikaže, ko je nalepka oblika Ctrl + kliknili na sliki.

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Izberite ustrezno obliko ali priključek iz diagrama.

3. Desni klikod oblikeali priključek.

4. Izberite Odprte Povezavein PovezavePrikaže se okno.

5. Če želite spremeniti vrstni red povezav kliknite na Move Up | Premik navzdolgumbi na desni strani Povezaveokno.

6. Prvi člen, ki se pojavi na levi strani PovezaveOkno je link, ki prikazuje, ko vas Ctrl + Kliknitehiperpovezavo oblika ali priključek ime.

Poglej tudi

Poselitev svojo arhitekturo | Poselitev svojo arhitekturo ročno | Analiziranje Vaše arhitektura


Manipulacija diagrami

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Manipulacija diagrami

Pošlji komentarje o tej temi.

Ko je diagram ustvarjena, lahko elementi, ki se pojavljajo v njem, se preuredijo in ponovno velika po želji.

Če želite premakniti komponento v diagramu

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Click-in-držitevsak sestavni del, da ga premaknete. Če ima izbrana komponenta staršev, bo matična komponenta je treba poudariti.

3. Kot je elementvlekli od svoje matične komponente, in več drugih komponent, bo "potencialni" starši postanejo poudaril. Barvna shema uporablja označuje učinek operacija bo imel na opozorila in napake pri trenutnem projektu in je opisan v Določitev in potrditev Omejitve . Na ta način lahko grafično pomikate hierarhijo iz "tloris".

4. Releasegumb miške, da se opusti element v svoji novi lokaciji.

Opomba

Lahko uporabite tudi tipkovnico za ponovno položaja elementov na risalni površini. Preprosto izberite komponento ali prosti obliki obliko, ki jo želite premakniti, in uporabite smerne tipke, ki se nahajajo na tipkovnici, da se premaknete obliko na želeno mesto.

Upoštevajte tudi, da ko povlečete komponento z miško nad drugo komponento, je "potencial" nadrejena komponenta izpostavil, ko je zgornji levi vogal komponento, ki jo vleče prekriva drugo komponento.

Nasvet

Prostoročna in Plavajoči oblike lahko odredi Z desnim klikomin izbiranje Postavi v ospredjeali Pošlji v ozadjeiz menija. Pomembno je omeniti, da je komponenta oblike lahko pretvorimo v poljubne oblike oblik, ki jih Z desnim klikomo posebni obliki in izberete komponento Pretvarjanje za prostoročno.

Če želite spremeniti velikost komponento v diagramu

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Kliknite-hold-povlecieden od ročajev komponento in spremenite njeno obliko na želeno velikost.

3. Druga možnost je, da se ohrani razmerje stranic oblika je, pritisnite Shift + klik-hold-povleci.

Če želite premakniti povezavo v diagramu

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Click-in-držitevsaka povezava, da ga premaknete.

3. Releasegumb miške, da se opusti element v svoji novi lokaciji.

Opomba

Lahko premaknete samo povezave, ki niso vezani na nobeno komponent. Če sta vezana, lahko samo premikanje prosti konecsAli preusmerjajo povezave .

Brisanje Komponente in povezave

Pri brisanju komponento ali povezave iz diagrama, imate možnost, da ga izbrišete iz celotne arhitekture. Kakršna koli sestavina, ki je izbrisana iz arhitekture bo samodejno odstranjena iz vseh drugih diagrami, kjer se pojavi. Ker Prostoručni primeri se pojavljajo samo v enem diagramu, brisanjem jim ne vpliva na arhitekturni model ali kateri koli drug diagram.

Če želite izbrisati komponento ali povezave iz diagrama

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Kliknitena katerem koli povezano povezavo ali sestavnega dela, ki jo izberete.

3. Pritisnite IzbrišiKljuč, da ga izbrišete iz diagrama, ali Shift + Deleteda ga izbrišete iz celotnega modela.

- Ali -

2. Z desno tipko miške kliknite na kateri koli povezanega elementa ali komponente. Pojavilo se bo kontekstni meni.

3. Izberite Izbriši iz Viewali Izbriši od Arhitekturaiz kontekstnega menija.

Opomba

Če ima element, ki ga želite izbrisati iz pogleda brez otrok in se pojavlja samo na tem namenom bo ABACUS vprašal, ali želite izbrisati element iz skladišča, kot dobro.

Pozor

Pri brisanju komponento od modela, ki ima otroka komponent, bodo otroci tudi lahko črta po pogovornem oknu opozarjanja.

Se združujejo Komponente

Morda boste želeli združiti dveh komponent obstoječih na istem diagramu (in v strukturi). To se lahko stori za veliko razlogovNa primer, Dve strežniki obstaja znotraj infrastrukturnimi H družbe01 in H02. Ti dve strežniki so zastopali dveh ločenih komponent v arhitekturi. H01 je bila zdijo nepotrebni, zato je treba razgraditi. Vse obstoječe aplikacije, ki tečejo na H01 se premakne do H02 (še vedno v komisiji). Ta sprememba se nato lahko odraža z delovanjem ", ki se združujejo" dveh komponent H01 in H02 na skici (in v arhitekturi).

Za podrobno razpravo o združevanju glejte Združitev Items to temo tukaj .

Za združitev dveh obstoječih komponent

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Z desno tipko miške kliknite, držitena komponento, ki jo želite spojiti in povlecije na komponento, ki jo želite združiti s. Prepričajte se, da obris komponente destinacijo je poudarjeno rdeče, kar pomeni, da je izbran.

3. Izberite Združi | Ohranimo Destinationali Prepiši Destinationiz menija.

Opomba

Ohranimo Destinationmožnost ohranja vrednote lastnosti namembne sestavnega dela, če obstaja na komponento poreklom, kot tudi.

Prepiši DestinationMožnost prepiše lastnosti namembne komponenta je z vsemi skupnimi lastnostmi iz komponente poreklom.

Spreminjanje povezave

Povezave, prikazane v diagramu vednoodražajo strukturo, kot je definirana v arhitekturi samega. Orodje za risanje vam omogoča, da odstranite povezave s sestavnimi deli, ki jih premikate, jim krivulja, jih ponovno pot in jih ponovno namestite druge komponente.

Če želite odklopiti / priložiti povezavo od / do komponente

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Click-in-držitena kateri koli povezavi.

3. Izberitepovezava konec(t.j. Vir ali ponor), Ki bi radi, da odstranite / namestite. Opomba: konci povezave so označene z majhnimi belimi krogi in lebdi nad belem krogu za sekundo bo povzročila "namig", da nastopijo z zadevno Vlogaime(tj bodisi vir ali ponor).

4. Dragpovezava na koncu na novo lokacijo (bodisi prosto delovno mesto ali komponento) in spustite gumb miške.

Opomba

Ko je konec povezava postavljeno nad veljavno sestavini je obris komponente ciljnem poudarjena s črtkano obris. Barvna shema uporablja označuje učinek operacija bo imel na opozorila in napake pri trenutnem projektu in je opisan v Določitev in potrditev Omejitve . Ko sprosti da konec the povezava in komponenta se samodejno poveže(ali priložen)Je in to se odraža v arhitekturnem modelu.

Naprej pot ponovno povezavo

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Postavite miškin kazalec nad povezavo.

3. Držite Shifttipka dol in Kliknitegumb miške postaviti povezavo sidro točko. Spustite Shift ključ. Lahko odstranite sidrno točko, ki jo počne isto operacijo.

4. Click-in-povlecisidro točko za pot ponovno povezavo.

Nasvet

UporabiteAlt Ključ namesto ShiftKljuč za ustvarjanje pravokotno povezav.

Če želite krivulja ali zravnajtepovezava

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Postavite miškin kazalec nad povezavo.

3. Desni kliktje povezava in v kontekstnem meniju izberite Krivulja, Ortogonalna ali Naravnost.

Nasvet

Vse povezaveo treba dati tip na sliki lahko nastavite na ukrivljen, pravokotnimi ali Naravnost z desnim klikom na povezano linijo za tip na Zavihek Povezave od Stencil oknoin izbiranje Curve, ortogonalno ali Straight.

Če želite zasidrati na določeni točki na robu obliki

1. Prepričajte se, da imate obstoječi diagram odprte .

2. Izbira povezave.

3. Postavite miškin kazalec nad v nadaljevanju: bela pika "na koncu povezava.

4. Desni kliktje konec povezavo in v priročnem meniju izberite Sidro Endpoint za Shape.Premikanje konec povezave do mesta želja na robu oblike.

ALI

Držite Ctrltipka dol in cližejo-in-povleci povezovalnim koncem kaže na lokacija želja na robu oblike.

Opomba

Povezav bo snap z dejanskim prestrezanje njihove priključene oblike namesto Mejni pravokotnik te oblike.

Poglej tudi

Orodje za risanje | Poselitev svojo arhitekturo | Analiziranje Vaše arhitektura


Združevanje predmetov

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Združevanje predmetov

Pošlji komentarje o tej temi.

Ko bi si združiti elemente?

Ti bi elemente združiti, če imate dva (ali več) predmete v vašem modelu, ki so ga v enem primerku najbolje zastopani. Obstaja veliko situacij, ko bi si želeli, da to stori, vključno z:

· Kot rezultat uvaža nov sklop podatkov v model, ki lahko podvajala ali nadomestijo obstoječe podatke. Na primer, če uvozno posodobljeno različico preglednici v vašem modelu.

· Sčasoma so dvojniki za "isto" komponento ustvarjen in želite počistiti teh dvojnikov.

· Če izvedete kaj-če scenarijev in predmeti, ki jih za modeliranje dejansko združujejo v resnici. Na primer, če ste združitvijo dveh oddelkov v vaši organizaciji, ali če ste združitvijo dveh strežnikov.

Kaj lahko združila?

Naslednje vrste predmetov, ki se podpirajo združili:

· Standardi

· Komponent in povezave Vrste

· Komponente in priključki

Kako združiti predmetov

Da sproži spajanja, z desno tipko miške, povlecite en element v Raziskovalcu na drugo. Element, ki ga povlečete je vir in predmet, ki ga povlecite je destinacija. Ob sprostitvi na desni gumb miške vam bo predstavljen z menija, iz katerega se lahko odločite za spajanje dveh predmetov. Boste morali izbrati, ali želite ohraniti ali prepisati destinacijo. To je podrobneje opisan v nadaljevanju.

Meni desno povleci merge

Kakšna je razlika med ohranjanjem in prepisovanju destinacijo?

Domena ali prepisati možnost narekuje, kaj se zgodi, če je ime, opis ali Properties med izvorno in ciljno predmetov tekmo.

Če je izbrana Ohranimo Destination

· Namembni kraj, ime in opis bodo shranjeni.

· Vse lastnosti, ki obstajajo le v viru se dodajo v okolici.

Če Prepiši Destinacija je izbran:

· Ime namembni kraj, se bo prepisana iz vira.

· Namembni kraj, opis bo prepisana iz vira, razen če je vir opis je prazen.

· Vse lastnosti, ki obstajajo le v viru se dodajo v okolici.

· Vrednost in enota za lastnosti, ki obstajajo v obeh vira in cilja bodo prepisane iz vira, razen vira je vrednost ali enota je prazen.

Posebni primeri

· Vrste: Ko združitev vrst, so dovoljenja združili, v "pesimistični" način, tako da če se dovoljenje na viru, ni obstajala v okolici, bi bilo treba dodati, in če se je to obstajajo v okolici, nato pa, če je posameznik dovoljenje za skupino uporabnikov (ustvarjanje, branje, Update ali Delete) ni ujemalo (ena dodeljena, eden zanikal), nato pa bi, da je dovoljenje mogoče zanikati.

· Komponente: Ko združitvijo komponent, sub-komponente vira se selili na destinacijo in se združila z podskupin v namembni kraj, če so njihova imena enakoNe glede na vrsto.Poleg tega bo več pod-komponente vira z enakim imenom treba združiti v en sam delni komponenti v destinaciji.

· Povezave: Najvišji ravni povezave samih morata imeti enake priloge (ali pomanjkanja le-te), da je treba omogočiti, da se združijo. Ob združevanju povezav, so sub-povezave vira selili na destinacijo in se združila z sub-povezave v okolici, če so njihova imena enako INnjihovi priključki so enaki. Če so priključki niso enaki, bodo vir sub-povezave je treba dodati, da v namembni kraj brez združevanja z ujemajočimi povezavami že prisotne. To je tako, da so izgubili nobene priloge.


Navigacija v 3D sliki

Navigacija: Analiza vašo arhitekturo> 3D diagramov>

Navigacija v 3D sliki

Pošlji komentarje o tej temi.

ABACUS vam omogoča enostavno navigacijo skozi arhitekturo v 3D. Izkušnja je podoben letenju. Obstajata dva načina za navigacijo:

· Osnovni način Control (privzeto); in

· Napredno Control Mode - sprememba tem načinu, ki ga izberete Nadzor| Napredni način Control.

Opomba

Če želite preklopiti med Basic nadzor in načinu Napredno Control, ki jih lahko uporabite F4bližnjico na tipkovnici funkcionalnost.

Osnovni način Control

· Držite levi gumb in premaknite miško naprej ali nazaj, se spreminja z igrišča;

· Držite levi gumb in premikanjem miške levo ali desno spremeni odklona;

· Držite desno tipko in premikanje solinah miško pogled;

· Držite obe tipki navzdol in premikom miške naprej ali nazaj, približa in iz arhitekture; in

· Držite obe tipki navzdol in premikanje miške v levo ali desno, zvitki levo in desno.

- Ali -

· S pritiskom na Left Arrowna tipkovnici ali številske tipkovnice bo zavijemo levo;

· S pritiskom na Right Arrowna tipkovnici ali številske tipkovnice bo zavijemo desno;

· S pritiskom na Gorna tipkovnici ali številski tipkovnici povečavo;

· S pritiskom na Puščica dolna tipkovnici ali številske tipkovnice bo pomanjšati;

· Pritiskom Page Upna tipkovnici ali številske tipkovnice bo prevladuje; in

· Pritiskom Stran dolna tipkovnici ali številske tipkovnice bo smola navzdol.

Napredni način Control

· Movingmiš naprej in nazaj ter gor in dol, spreminja igrišča in nihanja (v tem zaporedju);

· Pritiskom Wali Gorpribliža (forward) v arhitekturi;

· Pritiskom Sali Puščica dolpomanjša (nazaj) iz arhitekture;

· Pritiskom Aali Left ArrowValji v levo;

· Pritiskom Dali Right Arrowzvitki na desno;

· Pritiskom Qali Stran dolpovzdigne pogled (z znižanjem perspektivo); in

· Pritiskom Eali Page Upznižuje pogled (s dvižne perspektive).

Način Control Interactive

Pritisnete in držite Ključni premikna tipkovnici preglasi trenutni način (osnovno ali napredno) za vstop v način interaktivnega nadzora. Na ta način je možno naslednje:

· Rollmiškin kazalec nad sestavnega dela ali povezavo, da vidite, sestavnega dela ali ime povezave je;

· Kliknitena komponento, da povečate to sestavino;

· Click-in-povlecina komponenti za vrtenje pogleda okoli tega sestavnega dela; in

· Desni kliksestavni del ali povezavo in izberite Prikaži v Raziskovalcuvideti, da je sestavni del ali lokacijo povezavo v drevesu.

Skupne kontrole

· Uporaba ALT-ENTER / ESCda preklopite celozaslonski način;

· Uporaba F2spremeniti način prikaza. Ta je na voljo tudi v PoglejMenu.

· Uporabite miško koloali +/-za spremembo hitrosti. Hitrost je označena s številko, v spodnjem levem kotu - je prikazano šele, ko se spreminja. 1 je najpočasnejša in 100 je najhitrejši.


Odpiranje diagrami

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Odpiranje diagrami

Pošlji komentarje o tej temi.

Risbo matrice in platno okna se prikaže samodejno, ko je diagram odpreti ali ustvariti. Podobno, kadar je diagram zaprt, ki ustreza jezičku v oknu platnu izgine, in če so na voljo nobene druge risbe potem je okno šablona zaprta.

Če želite ustvaritinovi diagram

1. Zagotovite imateABACUS odprto datotekoz vašim naseljeno arhitekturo.

2. Kliknite na Diagramicon Ogled v orodni vrstici.

- Ali -

2. Izberite Insert| Diagram.

- Ali -

2. Desni klik Diagramiveja dana Arhitekturadel drevesa in izberite Ustvarjanje Diagram.

3. Izberite Arhitekturaželite, da se osredotoči na iz spustnega menija. Opomba: arhitektura bo že izbrali za vas, če ste uporabili Korak 3 zgoraj, da se odpre nov diagram.

4. Izberite Vaše mnenje želite uporabiti iz spustnega menija. Opomba: izbrana razgledna filtrira komponente in povezave seznamov, da bi bili na voljo vidika samo.

5. Po želji izberite pogled od Filter By Poglejpull-down menija za predhodno izbiranje komponent in povezav od izbranega pogleda. Opomba: to je dejansko z izbrano pogled kot shranjeno poizvedbo.

6. Izberite Postavitev da bodisi Radial ali Mreža.

7. Izberite Komponentein Povezaveda želite v diagramu iz okno za izbiro standardni element .

8. Kliknite v redu.

Opomba

Nova shema bo dodana k Diagramiveja arhitekture. To bo imelo privzeto ime, ki ga lahko kasneje spremenite z desnim klikom na njega.Poleg tega bo zadnja država filtrov sestavnih delov ter izbirnih povezava shranjena diagram učinkovito varčevanje "poizvedbo", ki se uporablja za ustvarjanje diagram.

Če želite odpreti obstoječi diagram

1. V posebnem naseljeno arhitekturo, razširiti Diagramiveja drevesa.

2. Dvojni klik diagram želite odpreti.

Če želite shraniti diagram

1. Prepričajte se, da imate novo ali obstoječo shemo openin ste naredili potrebne spremembe. Opomba: zvezdico '*' bo prikazan po imenu pogled na zavihki glavi stanja, če pride do sprememb, ki jih je treba shranjene.

2. V prikazu explorer kliknite na Shranigumb ali got mapa| Shraniali pritisnite Ctrl + Sda shranite vse spremembe v arhitekturi in pisati, da v datoteko.

Če želite shraniti diagram, ko je odlično razgledna točka

1. Prepričajte se, da imate obstoječe diagram v vašem ABACUS datoteki.

2. Desni klikdiagram v Diagramidel drevesa.

3. Izberite Shrani kot Diagram Vaše mnenje.

4. Vnesite ime za svoj novi diagram razgledna točkain kliknite v redu.

Poglej tudi

Orodje za risanje | Poselitev svojo arhitekturo | Analiziranje Vaše arhitektura


Poselitev uporabo Katalogi

Navigacija: Poselitev svojo arhitekturo>

Poselitev uporabo Katalogi

Pošlji komentarje o tej temi.

A Katalog vam omogoča ogled in urejanje komponente ali povezav in njihove lastnosti na enostaven način tabele.

Če želite ustvariti nov katalog ogled v ABACUS

Opomba

Medtem ko lahko vsi uporabniki Arhitekt ustvarjanje novih Katalogi, da shranite spremembe nastavitev nekega obstoječega Katalog je Uporabnik licenca potrebuje Designer dodatek sposobnosti. To je "zaščititi" konfiguracijo obstoječih katalogih da je lahko skupna za mnoge uporabnike. Vendar Arhitekt uporablja brez Designer add-on lahko še vedno odločijo, da "Save As" morebitne nove nastavitve novega kataloga. In seveda se lahko vse uporabniške licence izberite "zavreči" morebitnih spremembah obstoječega kataloga. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora Če potrebujete Designer dodatek sposobnost. In ne pozabite, to je samo nastavitve kataloga, so vsi popravki narejeni s podatki v katalogu takoj uporabijo v skladišču, glede na to.

1. Izberite Vstavi | Katalog.

2. V potegnite navzdol izberite Architecture, ki vsebuje sestavine alipovezave si želite ogledati.

3. V potegnite navzdol izberite komponento ali vrsta povezave da želite, da so primeri navedeni kot "Vrstice' v katalogu.

4. Katalog bo poseljena zvrstico za vsak primer izbranega sestavnega dela ali povezave tip.

Opomba

Privzeto levo-najbolj Hierarhija Potstolpec (tj hierarhiji matičnih komponent ali povezav zgoraj izbranih primerih) in 2. Name stolpec (tj seznama izbrane komponente ali priključevanja primerkov) so zamrznjeni na levi strani katalog. Če želite spremeniti stolpec zamrznitev povlecite ločilo stolpca na desni strani imena stolpca. Ti lahko re-orderstolpci preprosto tako, da povlečete in spustite svoje stolpcev. Celice stolpcih z modro podčrtano so hiperpovezave drugih elementov v projektu in hiperpovezav lahko sledi tako, da držite tipko Ctrl in kliknete povezave. Stolpci lahko skrita z desnim klikom na naslov stolpca in izberete stolpec | Skrij stolpec. Skrite stolpce lahko razkrit s klikom na gumb v orodni vrstici Kolumne Configure in uporabo Konfiguriraj stolpce pogovorno okno, kot je prikazano spodaj, ali tako, da izberete puščico navzdol del gumba orodne vrstice Kolumne Configure in individualno izbiro skrito stolpec (e) bodisi iz generalnega, Lastnosti ali Priponke zbirk. Vrstice lahko združeni njihove vrednosti stolpca z vlečenjem stolpca v vrstici modro združevanja na vrhu kataloga. V vsakem trenutku lahko dvojno kliknite na Izbirnik Katalog vrsticain skok naustrezna komponentaali povezavaV oknu Explorer.Vrednosti celic premoženje so krepko kjer so drugačna od privzete, in ležeče kjer so samo za branje. Časovni žig, lastnine in Attached Component stolpci lahko barvi v skladu z vrednostmi celic ali nepremičnin vrednost priloženo sestavnega dela, ki ga z desnim klikom na naslov stolpca in izberete stolpec | Sprememba barve ... in nato Colour s časovnim žigom oziroma možnosti Colour By lastnino, vendar le, Seznam, Integer, decimalno, Boolean ali datum / čas lastnosti tipa podatkov bo obarvajo. Vrednosti nepremičnin za Attached Component stolpcev lahko prikazano z desnim klikom na naslov stolpca in izberete stolpec | Prikaži Nepremičnine ... in potem možnost Show lastnino. In končno, če obstajajo Zahtevani omejitve nastavljen za stolpec lastnine lahko to prikazano z string (skupaj z barvilom, v skladu z njihovimi ravnmi pregona), z desnim klikom na naslov stolpca in izberete stolpec | Prikaži .

Katalog

Če želite dodaj / pokaži stolpce a Katalog Pogled v ABACUS

1. Prepričajte se, da imate Pogled Katalog open.

2. Skrite stolpce lahko individualno razkrit s klikom na puščico na desni Stolpci gumba na orodni vrstici Configurein izberete skrito stolpec iz bodisi Splošno, Nepremičnine ali Priključki zbirke.

Opomba

Kljukico bo prikazan poleg trenutno prikazanih stolpcev za katalog.Poleg tega bodo le nekateri priključki so na voljo v okviru Priponke oddelek glede na omejitve ki so opredeljeni v vašem projektu. Zlasti za pritrditev na voljo, da se prikaže v katalogu komponenta tipa sestavnega dela za katalog je treba opredeliti bodisi kot vir ali potopi (in ne "Vsaka") o "povezavi je treba priložiti" omejitev za povezavo Tip, pa mora biti tudi vsaj en tip komponenta opredelimo kot vira ali potonejo (NI "Vsako ') drugega' konec 'istega tipa povezave.

- Ali -

2. Več stolpci lahko razkrit (ali naročil ali fiksni), s klikom na Konfigurirati Stolpci gumb orodne vrsticein z uporabo stolpce Konfiguracija pogovornem prikazano spodaj.

Opomba

Trenutno prikazana kolone so prikazani v plošči na desni strani z razpoložljivimi stolpih, prikazanih na plošči na levi strani. Razpoložljive kolone se lahko filtriramo glede na Izberite voljo stolpcepotegnite navzdol in se lahko doda, da jih izberete na plošči na levi in ​​kliknete Dodaj Gumb vmesna dveh plošč.

Konfigurirati okno Stolpci

Če želite odstraniti / skrij stolpce iz Katalog Pogled v ABACUS

1. Prepričajte se, da imate Pogled Katalog open.

2. Z desno tipko miške kliknite naslov stolpca za stolpec, ki ga želite odstraniti / skrivalnice in izberite Kolumna | Skrij stolpec.

- Ali -

2. Več stolpci lahko skrita (ali naročil ali fiksni), s klikom na Konfigurirati Stolpci gumb orodne vrsticein z uporabo stolpce Konfiguracija pogovornem prikazano zgoraj.

Opomba

Trenutno prikazana kolone so prikazani v plošči na desni strani z razpoložljivimi stolpih, prikazanih na plošči na levi strani. Trenutno prikazani stolpci lahko skriti tako, da izberete stolpec v plošči na desni strani in kliknete Odstrani Gumb vmesna dveh plošč.

Zapolnijo z uporabo Katalog Pogled v ABACUS

1. Če želite dodajte sestavnega dela ali povezavaizbranega tipa da Katalog (in projekt) kliknite Add New Component / Dodaj nov gumb orodne vrstice Connection. Vrstica smeli pojavijo in sestavnega dela ali Povezava bo ustvarjena na najvišji ravni, ki je Komponente ali Povezave kolekcija za izbrano arhitekturo.

Opomba

Nove komponente in povezave se dodajo privzeto na najvišji ravni sestavnih delov ali Connections zbiranje izbrano arhitekturo. Če želite spremeniti staršev novih sestavnih delov ali povezave z desno tipko miške kliknite Hierarhija Path celico za novo komponento ali povezav vrstico in izberite Spremeni Parent ...in izberite želeni staršev (ob seznanili z Omejitev poudarjanje ).

Opomba

Nove vrstice / elementi dodajo neposredno katalog preko "Dodaj novo" gumb, prilepiti v katalogu ali ustvaril preko uvoz v katalogu iz MS Excel so oproščeni filtriranje, dokler je katalog zaprt. To je, da vse potrebne urejanje vrednosti stolpca, ki morda ne izpolnjujejo sedanja merila za filtriranje iz kataloga. Te nove vrste elementov so označeni s "+" simbola prestavne vrstica celice na začetku vrstice, ki je obarvano green če je element trenutno izpolnjuje shranjene kriterijev filtriranja iz kataloga (torej bo ostal na katalogu, če ponovno odprejo), in rdeča če se to ne zgodi.

2. Če želite Odstranjevanje sestavnega dela ali povezavaizbranega tipa od Katalog (in projekt) izberite vrstico in bodisi pritisnite tipko Del ali desno tipko miške kliknite izbirnik vrstice in izberite Izbriši od arhitekturo. vrstica bi morala izginiti v katalogu in bodo izbrisani iz projekta.

Če želite filter z uporabo Katalog Pogled v ABACUS

1. Prepričajte se, da imate Pogled Katalog open.

2. Če je vrstica filtra ni prikazan na vrhu katalogu nato na Prikaži Filter naslovni vrsticiorodna vrstica gumb.

3. V stolpcu želite dodati filter, dvokliknite filter vrstico celico, kjer se kaže "(Vsi)".

4. Za Timestamp, Hierarhija Path, Nameali Opissplošna stolpci ali Besedilo, Integer, decimalno, Booleanali Datum časlastnine stolpci kliknite gumb ..., ki se pojavi v desnem kotu vrstice filtra celico in vnesite vrednosti celic, ki jih je treba vključiti v katalogu.

Opomba

Matching se izvede, kot da so '*' nadomestni znaki samodejno uporabljajo pred in po katerikoli niz vrednot, tako da bi vstop "mačka" (brez narekovajev) vključujejo vrstice z "bobmačka','mačkaženska "ali" APPLImačkaion "itd Multiple /" ali "vrednosti, se lahko vpišejo na novih progah, ki uporabljajo Ctrl + Enter. Za Integer in desetinkah stolpcih lastnine "in" se logika lahko vključijo uporabo "&"(Brez narekovajev) in večji kot / manj kot etc logiki se lahko vključijo uporabo"> =','>','<"In"<="(Brez narekovajev), npr '> = 50000 & <90000'. Non-blank cenjene vrstice se lahko vključijo z vnosom "(Non-Blanks)"(Brez narekovajev) in Prazni cenjene vrstice se lahko vključijo z vnosom"(Prazne)"(Brez narekovajev).In končno, vsi filtri so privzeto velikost črk, tako da bi "mačka" (brez narekovajev) vključujejo vrstice z "mačka", "mačka" ali "mačka" itd za sodno občutljivo ujemanja, vnesite "(Case)"(Brez narekovajev) pred nizom npr "(Sodba) Cat" (brez narekovajev) bi vključeval le vrstice z "mačka" v njih.

5. Za Priključkikolone, Standardi stolpci ali Seznam lastnine stolpci kliknite puščico dol, ki se pojavi v desnem kotu vrstice filtra celico in izberite vrednosti celic iz kvadrat, ki jih je treba vključiti v katalogu.

Opomba

V nadaljevanju: (Izberi vse) "polje bo omogočilo vse ostale polja, v smislu, vključno z vsemi razpoložljivimi vrsticah. V nadaljevanju: (Non-Blanks) "polje bo vključila neprazna cenjene vrstice. V nadaljevanju (Prazne) "polje bo vključevala praznih vrednotijo ​​vrstice. In končno, počistite nobenih posebnih vrednotijo ​​polja bo samodejno počistite "(Izberi vse)" in "(Non-surovci)" potrditvena polja za skladnost.

6. Kliknite v redu uporabiti filter.

Če želite onemogočite / omogočite filtriranje a Katalog Pogled v ABACUS

1. Prepričajte se, da imate Pogled Katalog open s filter aplikativna.

2. Kliknite potrditveno polje na levi strani vrstice filtra.

Če želite odstraniti filter iz a Katalog Pogled v ABACUS

1. Prepričajte se, da imate Pogled Katalog open s filter aplikativna.

2. Če želite odstraniti posamezni filter stolpca desno tipko miške kliknite naslov stolpca in izberite Kolumna | Jasno Filtriranje.

3. Če želite odstraniti vse filtre kliknite Možnosti Orodna vrstica gumb in izberite Počisti Settings Filter.

Shraniti / shrani kot aPogled Katalog

Opomba

Medtem ko lahko vsi uporabniki Arhitekt ustvarjanje novih Katalogi, da shranite spremembe nastavitev nekega obstoječega Katalog je Uporabnik licenca potrebuje Designer dodatek sposobnosti. To je "zaščititi" konfiguracijo obstoječih katalogih da je lahko skupna za mnoge uporabnike. Vendar Arhitekt uporablja brez Designer add-on lahko še vedno odločijo, da "Save As" morebitne nove nastavitve novega kataloga. In seveda se lahko vse uporabniške licence izberite "zavreči" morebitnih spremembah obstoječega kataloga. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora Če potrebujete Designer dodatek sposobnost.In ne pozabite, to je samo nastavitve kataloga, so vsi popravki narejeni s podatki v katalogu takoj uporabijo v skladišču, glede na to.

1. Prepričajte se, da imate novo ali obstoječe pogleda kataloga openin ste naredili potrebne spremembe.

2. V Pogled Katalogorodna vrstica kliknite na Shranigumb, da shranite Pogled Katalog in vse morebitne spremembe oblikovanja.

Opomba

Če nimate shrani gumb v orodni vrstici pogleda Katalog potem nimate Designer add-on in ste le sposobni Shrani kotvse nastavitve, se spremeni v novem katalogu, ko greš zapreti obstoječi katalog.

3. Če KatalogNamePrikaže se pogovorno okno (zaradi gre za novo katalog) vnesite ime za Katalog in pritisnite v redu.

Če želite izvoz v MS Excel katalogu

1. Prepričajte se, da imate Pogled Katalog open.

2. Kliknite Izvoz v Excel Katalog preglednicoorodna vrstica gumb.

3. Izberite ime datoteke za shranjevanje MS Excel katalog kot. Kliknite Shrani.

Opomba

Privzeto ime datoteke izvoženih MS Excel katalogu je bilo ime katalog z imenom Architecture suffixed v oklepaju, npr "Projekti (2014 Actual) .xlsx". Lahko spremenite vse to, vključno s tem, je, da bo .xlsx ali .xls format datoteke. Ime Arhitektura je vključen opozoriti uporabnika, da ima vsaka Katalog specifično vsebino (tj ID v stolpcu A in vrstici 1), ki omogočajo, da je okrogla spotaknila nazaj v uporabo Uvozi iz MS Excel katalogu kot na spodaj.

Opomba

Privzeto skrita Stolpec A v izvoženega MS Excel katalog vsebuje enolični ID za vsakega od elementov v skladišču ABACUS. To omogoča, da vse spremembe, ki so narejene v MS Excel, ki se "ujema" obstoječih elementov znotraj ABACUS o uvozu (glej spodaj). Vendar lahko uporaba tega edinstvenega ID za "ujemajo" vrstice povozi z Zunanja | IDlastnost na elementu. To pomeni, da če je element zunanjim | ID nepremičnine in je vključena v katalogu o izvozu so vrednosti zunanjega | ID stolpec bo uporabljen ujemajo vrstic o uvozu (glej spodaj) in edinstven ID vrednosti v skritem stolpcu A, bodo prezrti (in lahko celo prazno). Skrito Stolpec A sama mora ostati pa predvsem vrednost v celici A1. Poleg tega je pri dodajanju zunanjih ID-jev z obstoječo zbirko ABACUS element priporočamo, da jih dodate kot drug nepremičnin prvič, npr Zunanja | Temp in nato preimenovanje nepremičnine na zunanje | ID. V nasprotnem primeru se bo dodana podvojene elemente.

Katalog oblikovanjeizvozi privzeto, vendar pa je za velike kataloge lahko to povzroči izvoz pa precej počasi. Skladno s tem Orodja | Možnosti ...nato pa na Katalogzanka,ste sposobni zmanjšati količino oblikovanja, ki se izvozi, kot je prikazano na kartici katalogu spodaj, kar pospeši izvoz.

Katalog izvoz Možnosti

4. Se prikaže Export Dopolnil pogovorno okno. Kliknite v redu.

Izvažajo v MS Excel katalogu

Če želite uvoz iz MS Excel katalogu

Opomba

Privzeto skrita Stolpec A v izvoženega MS Excel katalogu (glej zgoraj) vsebuje enolični ID za vsakega od elementov v skladišču ABACUS. To omogoča, da vse spremembe, ki so narejene v MS Excel, ki se "ujema" obstoječih elementov znotraj ABACUS o uvozu. Vendar lahko uporaba tega edinstvenega ID za "ujemajo" vrstice povozi z Zunanja | IDlastnost na elementu. To pomeni, da če je element zunanjim | ID nepremičnine in je vključena v katalogu za izvoz (glej zgoraj), nato pa vrednosti zunanjega | ID stolpec bo uporabljen ujemajo vrstice o uvozu in edinstven ID vrednosti v skritem stolpcu A, bodo prezrti (in lahko celo prazno). Skrito Stolpec A sama mora ostati pa predvsem vrednost v celici A1. Poleg tega je pri dodajanju zunanjih ID-jev z obstoječo zbirko ABACUS element priporočamo, da jih dodate kot drug nepremičnin prvič, npr Zunanja | Temp in nato preimenovanje nepremičnine na zunanje | ID. V nasprotnem primeru se bo dodana podvojene elemente.

1. Prepričajte se, da imate Pogled Katalog open.

2. Kliknite Uvoz iz Excel Katalog preglednicoorodna vrstica gumb.

3. Izberite ime datoteke za uvoz kataloga MS Excel iz. Kliknite Odpri.

4. Nove odkritih napak in / ali nove napake / opozorila Zaznana pogovorna lahko pojavi za vsako novo vsebino (tj Vrstice v MS Excel), ki je bil dodan. Upoštevajte napak / opozoril in kliknite v redu.

5. Pogovorno okno Uvoz Opravljena je prikazano, in ga lahko pokažejo opozorila zaradi uvoza (glej opombe spodaj). Kliknite v redu.

Opomba

Za dodeljenih standardi ali priloženih Component stolpcih, je treba novi vnosi prek kataloga MS Excel ujema natanko ime obstoječega standarda ali komponento pravilno vrsto za dodelitev ali povezave, ki se doda. Prvi poimenovali Srečanje se bo uporabljal in vse neizravnane vnosov bo ustvarila opozorilo, kot na spodaj. Poleg tega, pa so opozorila glede na ponovni uvoz, elementi ne izbrišeod ABACUS če niso prisotni v katalogu MS Excel. To je zato, ker ne obstaja način, da se lahko ABACUS vedeti, ali obstaja dodeli Standard ali pritrjena komponenta v projektu ABACUS vendar ne obstaja v katalogu MS Excel, ker je bil izbrisan iz kataloga MS Excel ali je bil dodan k ABACUS je bil izvožen projekt, saj v katalogu. Zato, če uporabniki želijo enostavno "odkriti", ki so bile dodane povezave med uvažanjem jih lahko preprosto ustvarite zahtevano premoženje na vrsto povezave in nastavitev je privzeta za prazno, tako da bodo opozarjali na morebitne nove povezave vsakič, ko se uvozna ni končan.

Opomba

Pri uvozu v MS Excel katalog se lahko prikažejo različne opozorila. Prvič, če je nov stolpec dodan v Excelu, ki se ne ujema z "sintaksa" za nepremičnine ali priložene komponente stolpec bodo prezrti. Dalje, bo prikazana vrstica-by-line opozorila za vsa vprašanja s podatki o vsaki vrsti kataloga Excel. Ta opozorila začnejo s številko vrstice v oglatih oklepajih in če je ustrezno oznako stolpca (tj "[23, J] ..." za vrstico 23, stolpec J) in se lahko nanaša na izbrisane postavke, neizravnane standardov ali priloženih imena komponent (ki so prezrti kot na opombo zgoraj) ali neveljaven ali prazno ID, ki se nanašajo na novo vrstico / element bo (da se doda). Za podroben članek o poselitev ABACUS pomočjo Excelove katalogov najdete na Avolution Skupnosti ali tečaj usposabljanja Portfolio Manager.

Opomba

Nove komponente in povezave se dodajo privzeto na najvišji ravni sestavnih delov ali Connections zbiranje izbrano arhitekturo. Če želite spremeniti staršev novih sestavnih delov ali povezave z desno tipko miške kliknite Hierarhija Path celico za novo komponento ali povezav vrstico in izberite Spremeni Parent ...in izberite želeni staršev (ob seznanili z Omejitev poudarjanje ).

Opomba

Elementi dodajo neposredno katalog preko "Dodaj novo" gumb, prilepiti v katalogu ali ustvaril preko uvoz v katalogu iz MS Excel so oproščeni filtriranje, dokler je katalog zaprt. To je, da vse potrebne urejanje vrednosti stolpca, ki morda ne izpolnjujejo sedanja merila za filtriranje iz kataloga. Te nove vrste elementov so označeni s "+" simbola prestavne vrstica celice na začetku vrstice, ki je obarvano green če je element trenutno izpolnjuje shranjene kriterijev filtriranja iz kataloga (torej bo ostal na katalogu, če ponovno odprejo), in rdeča če se to ne zgodi.

Če želite primerjajo vsebine kataloga z drugo arhitekturo

1. Prosimo, da se nanašajo na to temo tukaj .

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Poselitev svojo arhitekturo iz Visio | Poselitev svojo arhitekturo iz Excela


Poselitev pomočjo matrik

Navigacija: Poselitev svojo arhitekturo>

Poselitev pomočjo matrik

Pošlji komentarje o tej temi.

Matrica omogoča ogled in urejanje "neposredni" povezave med komponentami v preprosti tabelarični načinin, da si ogledate tudi "posredno pot" med komponentami po kakršnih koli vmesnih komponent (in povezave).

Če želite ustvariti pogled Matrix v ABACUS

Opomba

Medtem ko lahko vsi uporabniki Arhitekt ustvariti matrik jih in / ali njihove nastavitve shranite Uporabnik licenca potrebuje Designer dodatek sposobnosti. To je "zaščititi" konfiguracijo obstoječih matrik, ki jih lahko delijo z veliko uporabnikov. Vendar Arhitekt uporablja brez Designer add-on lahko še vedno odločijo, da "Save As" morebitne nove nastavitve novi Matrix. In seveda se lahko vse uporabniške licence izberite "zavreči" morebitnih spremembah obstoječe matrice. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

1. Izberite Vstavi | Matrika.

2. V rchitecture>potegnite navzdol izberite Architecture, ki vsebuje komponente in povezave, ki jih želite ogledati.

3. V <VirVnesite>potegnite navzdol izberite vrsto sestavnega dela, ki ga želite imeti primerke navedene kot "Vrstice' navzdol levomatrike.

4. V <SinkVnesite>potegnite navzdol izberite vrsto sestavnega dela, ki ga želite imeti primerke navedene kot "stolpci' Na vrhumatrike.

5. V pull-dol obstajata v bistvu dve "načini" matrike lahko določite ...

Povezave "neposredni" matrike

6. Preprosto SNovoizvoljeni en (1) ali več povezava Vrste na desni strani v meniju, ki se pojavi, če želite videti v "celice" matrike, če an eksplicitnopovezava obstaja od Vertical/ "vrstica"Komponenta matrice k Horizontalna/ "stolpec"Komponenta matrice.

Opomba

Samo povezave z virom koncu pritrjen na Vertical/ "vrstica"End komponente in umivalnik pritrjen na Horizontalna/ "stolpec"Bo prikazana komponenta. Preklop Virin Sinkizborov homologacije sestavnega dela za ogled povezav v nasprotni smeri.

7. Matrika bo poseljena z "X" v celicah (ali vrednosti premoženja - glej opombo spodaj) če obstaja povezava med Vertical/ "vrstica "komponenta matrice k Horizontalna/ "stolpec"Komponenta matrice.

Opomba

Za velike matric bodo prikazane le največ 100 vrstic ali stolpcev (vključno porušenih vrstic / stolpcev) v času, kot je prikazano z "R" in kazalnikov "C" v zgornjem levem glavi celice oz. Če si želite ogledati dodatne vrstice uporabite drsne trakove. V vsakem trenutku lahko dvojno kliknite na Vertical/ "vrstica"Ali Horizontal / "stolpec"Komponenta Naslovi in skok naustrezne komponente v oknu Explorer.Starši vertikalnega/ "vrstica' in Horizontalna/ "stolpec"Komponentaje tudi opcijsko prikazani kot tarifno vrstic / stolpcev s sivim naslovom naslovom. Ko je propadel (z enim klikom naslov celic), če je obstajal otroci priključki nato pa "X", bo po želji na voljo, če so bili priloženi vsi otroci ali "O", bo po želji na voljo, če so bile priložene le nekateri otroci. Celice lahko barvi glede na vrednost premoženja na povezavah s klikom možnosti "zobnik" v zgornjem desnem kotu orodne vrstice matrike in izberete Colour Settings ... in nato gumb Uredi in izbiranje Colour s časovnim žigom ali Colour By lastnino opcije in izberete lastnost je Min in Max dosega vrednost in izbiri barv, vendar le, Seznam, Integer, decimalno, Boolean ali datum / čas lastnosti tipa podatkov bo obarvajo. Če je propadel, se bo celica obarvana glede na povprečno vrednost nepremičnin priključkov. Namesto, da bi "X", se lahko vrednosti nepremičnin za celicah biti prikazano s klikom na "zobnik" možnosti v zgornjem desnem kotu orodne vrstice matrike in izberete Prikaži Nastavitve Value ... in nato gumb Uredi in izberete možnost Prikaži lastnine in izberete nepremičnine.

Neposredne povezave matrika, ki prikazuje strežnike, kjer so aplikacije gostujejo z barvanjem in lastnine so prikazani namesto generično "X"

- Ali -

"Posredne" povezave matrike

6. SNovoizvoljenizaporedje povezava Vrste in Tipi sestavnihna desni in levi strani menija, ki se pojavi, če želite videti v "celice" matrike, če an posredno pot priključenih komponentobstajajo iz Vertical/ "vrstica"Komponenta matrice k Horizontalna/ "stolpec"Komponenta matrice.

Opomba

Vsako veljavna pot, ki vključuje izbrane v meniju poti w elementebolan prikazanone glede na smer z njimi povezanih priključkov pa pri izbiri potjo Prvain last elementi morajo biti tipi povezav izbran. Poleg tega Da elementov, ki so bili izbrani je prikazana z številčna predponana trgu ("[]") oklepaji in se lahko vključi neka vrsta mutliple kratv sredino (kot je nakazano s številčno predpono). Zaporedno izbor tipov sestavnih delov ali tipov priključnih se razlaga kot "Ali"pot in hierarhija priloženih sestavin lahko po želji vključijo s preverjanjem "Tudi iskanje Attachment starši / otroci"Potrditveno polje. Preklop Virin Sinkizborov homologacije sestavnega dela, da si ogledate Poti v obratni smeri.

7. Matrika bo poseljena zPot / zbiranje komponentv celicah, če obstaja Pot Iz Vertical/ "vrstica "komponenta matrice k Horizontalna/ "stolpec"Komponenta matrice.

Opomba

Za velike matric bodo prikazane le največ 100 vrstic ali stolpcev (vključno porušenih vrstic / stolpcev) v času, kot je prikazano z "R" in kazalnikov "C" v zgornjem levem glavi celice oz. Če si želite ogledati dodatne vrstice uporabite drsne trakove. V vsakem trenutku lahko dvojno kliknite na Vertical/ "vrstica"Ali Horizontal / "stolpec"Komponenta Naslovi in skok naustrezne komponente v oknu Explorer.Starši vertikalnega/ "vrstica' in Horizontalna/ "stolpec"Komponentaje tudi opcijsko prikazani kot tarifno vrstic / stolpcev s sivim naslovom naslovom. Ko je propadel (z enim klikom naslov celic), če je obstajala vse otroke poti, potem je "X", bo po želji na voljo, če so bili priloženi vsi otroci ali "O", bo po želji na voljo, če nekateri otroci imeli le poti. Posredni deli poti lahko barvi glede na vrednost nepremičnin komponent s klikom možnosti "zobnik" v zgornjem desnem kotu orodne vrstice matrike in izberete Colour Settings ... in nato gumb Uredi in izbiranje Colour s časovnim žigom ali Colour By lastnino opcije in izberete lastnost je Min in Max dosega vrednost in izbiri barv, vendar le, Seznam, Integer, decimalno, Boolean ali datum / čas lastnosti tipa podatkov bo obarvajo. Vrednosti nepremičnin za posredne komponent poti lahko prikazano s klikom na "zobnik" možnosti v zgornjem desnem kotu orodne vrstice matrike in izberete Prikaži Nastavitve Value ... in nato gumb Uredi in izberete možnost Prikaži lastnine in izberete nepremičnine.

Posredna povezava matrika prikazuje Aplikacije, ki izvajajo določene storitve s strani ministrstva

Če želite filterpogled Matrix v ABACUS

1. Prepričajte se, da imate novo Pogled Matrix open.

2. Kliknite filtru osi "lijak" v zgornjem desnem kotu orodne vrstice matrike.

3. O viru in / ali jezičkov Sink dodati ime, Nepremičnine, opis, hierarhije ali standardne filtre s klikom na gumb Dodaj, da izberete lastnino, če je potrebno, in s klikom v redu. Izberite ustrezne možnosti v plošči Ključne besede / predmete po logiki / sintakso, kot je opisano v opombi spodaj. Predogled plošča se bo samodejno posodobi pokazati rezultate trenutnega nabora filtrov.

Opomba

Za Timestamp, Hierarhija Path, Nameali Opisfiltri ali Besedilo, Integer, decimalno, Booleanali Datum časlastnine filtri ujemanje se izvede, kot da so '*' nadomestni znaki samodejno uporabljajo pred in po katerikoli niz vrednot, tako da bi vstop "mačka" (brez narekovajev) vključujejo vrstice z "bobmačka','mačkaženska "ali" APPLImačkaion "itd Multiple /" ali "vrednosti, se lahko vpišejo na novih progah, ki uporabljajo Ctrl + Enter. Za Integer in Decimalno lastnine filtri "in" logika se lahko vključijo uporabo "&"(Brez narekovajev) in večji kot / manj kot etc logiki se lahko vključijo uporabo"> =','>','<"In"<="(Brez narekovajev), npr '> = 50000 & <90000'. Non-blank cenjene vrstice se lahko vključijo z vnosom "(Non-Blanks)"(Brez narekovajev) in Prazni cenjene vrstice se lahko vključijo z vnosom"(Prazne)"(Brez narekovajev).Za Standardi ali Seznam nepremičnine filtri "(Izberi vse)" polje bo omogočilo vse ostale polja, v smislu, vključno z vsemi razpoložljivimi elementi. V nadaljevanju: (Non-Blanks) "polje bo vključila neprazna lastnine vrednotijo ​​elemente. V nadaljevanju (Prazne) "polje bo vključeval prazen premoženje oceni elemente. In počistite nobenih posebnih vrednotijo ​​polja bo samodejno počistite "(Izberi vse)" in "(ne s slepimi naboji)" kvadrat za doslednost. In končno, vsi filtri so privzeto velikost črk, tako da bi "mačka" (brez narekovajev) vključuje elemente z "mačka", "mačka" ali "mačka" itd za sodno občutljivo ujemanja, vnesite "(Case)"(Brez narekovajev) pred nizom npr "(Sodba) Cat" (brez narekovajev) bi vključeval le elemente z "mačka" v njih.

Zapolnijo z uporabo pogled Matrix v ABACUS

Opomba

Lahko samo dodati / odstraniti povezav, kjer je bila uporabljena ena vrsta povezave za Pot je opisano zgoraj.

1. Če želite Dodajanje povezaveod izbrane vrste med Vertical/ "vrstica"Komponenta in Horizontalna/ "stolpec"Komponenta matrice, kjer" X "ne že obstajajo(ali prikazana vrednost nepremičnine - glej pojasnilo zgoraj)Dvokliknite celico. Bi morale biti "X" (ali vrednost nepremičnine - glej pojasnilo zgoraj) in povezava bo ustvarjena na najvišji ravni zbirke povezav za izbrano arhitekturo.

Opomba

Ime povezave bo Povezava Ime vrste kot na nastavitev vrste povezave matrice in če je vrednost premoženja, ki je prikazana namesto "X" privzete vrednosti za nepremičnine bodo prikazani.

2. Če želite Urejanje prikazano vrednost nepremičnino povezavi med a Vertical/ "vrstica"Komponenta in Horizontalna/ "stolpec"Komponenta matriceDvokliknite celico, ali desno tipko miške kliknite celico in izberite Edit Value ... in uredite vrednost v pogovornem oknu Spremeni vrednost.

3. Če želite odstraniti povezavood izbrane vrste med Vertical/ "vrstica"Komponenta in Horizontalna/ "stolpec"Komponenta matrice, kjer" X "že obstaja(ali prikazana vrednost nepremičnine - glej pojasnilo zgoraj), prav-kliknite celicoin izberite Disconnect. X morala izginiti in povezava bo izbrisan iz projekta.

Shraniti / shrani kot aPogled Matrix

Opomba

Medtem ko lahko vsi uporabniki Arhitekt ustvariti matrik jih in / ali njihove nastavitve shranite Uporabnik licenca potrebuje Designer dodatek sposobnosti. To je "zaščititi" konfiguracijo obstoječih matrik, ki jih lahko delijo z veliko uporabnikov. Vendar Arhitekt uporablja brez Designer add-on lahko še vedno odločijo, da "Save As" morebitne nove nastavitve novi Matrix. In seveda se lahko vse uporabniške licence izberite "zavreči" morebitnih spremembah obstoječe matrice. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora Če potrebujete Designer dodatek sposobnost.In ne pozabite, to je samo nastavitve Matrix, so vsi popravki narejeni s podatki v matrici takoj uporabijo v skladišču, glede na to.

1. Prepričajte se, da imate novo Pogled Matrix openin ste naredili potrebne spremembe.

2. V Pogled MatrixOrodna vrstica kliknite na skrajno levo Shrani Matrixgumb, da shranite Pogled Matrix in vse morebitne spremembe oblikovanja.

Opomba

Če nimate shrani gumb v orodni vrstici pogleda Matrix potem nimate Designer add-on in ste le sposobni Shrani kotvse nastavitve, ki se spremeni v novo matriko, ko greš, da zaprete obstoječo matrico.

3. Če MatrixNamepogovorno okno, ki se prikaže (zaradi gre za novo matrika) vnesite ime za matrixin pritisnite v redu.

Če želite izvoz v MS Excel matrico

1. Prepričajte se, da imate Pogled Matrix open.

2. Kliknite Izvoz v Excelorodna vrstica gumb.

3. Izberite ime datoteke za shranjevanje MS Excel matriko kot. Kliknite Shrani.

Opomba

Privzeto izvoženih MS Excel Matrix je naziv biti ime Matrix z imenom Architecture suffixed v oklepaju, npr "Vloge gostuje na strežnikih (2014 Actual) .xlsx". Lahko spremenite vse to, vključno s tem, je, da bo .xlsx ali .xls format datoteke.

Oblikovanje Matrixizvozi privzeto, vendar pa je za velike matrik lahko to povzroči izvoz pa precej počasi. Skladno s tem Orodja | Možnosti ...nato pa na Matrixzanka,ste sposobni zmanjšati količino oblikovanja, ki se izvozi, kot je prikazano na kartici Matrix spodaj, kar pospeši izvoz.

Matrix izvoz Možnosti

4. Se prikaže Export Dopolnil pogovorno okno. Kliknite v redu.

Izvažajo v MS Excel matrico

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Poselitev svojo arhitekturo iz Visio | Poselitev svojo arhitekturo iz Excela


Poselitev diagrami

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Poselitev diagrami

Pošlji komentarje o tej temi.

Risbe v ABACUS so več kot le poljubnih predstavništev. Oni so prilagojene poglede na arhitekturo, oblikovano in urejeno pokazati poseben pomen.

Orodje za risanje uveljavlja hierarhično strukturo arhitekture, tako da so sestavni deli vizualno ugnezdeni znotraj drugih komponent - dejansko daje "tloris" elementov. Ko je sestavni del ali povezava definirana v arhitekturi, se lahko uporablja v poljubnem številu različnih diagramih. Pomembno je, da je orodje za risanje tesno povezana z arhitekturne modela, tako da so spremembe narejeno iz ene vedno odraža v drugi.

Orodje deluje s povezovanjem oblike s posebnimi vrstami povezav in sestavnih delov, opredeljenih v poglavju Vrste arhitekture. Ta združenja razlikujejo glede na vrsto diagrama v pripravi, in je mogoče, da imajo en tip komponente (ali povezavo) različne predstavitve v različnih diagramov, odvisno od okoliščin.

Če želite vzpostaviti povezavo med obliko in tip sestavnega dela ali povezave

1. Prepričajte se, da imate novo ali obstoječo diagram odprte .

2. Povečajte aplikacijo ABACUS, in konfiguracijo okenskih razmerja kot si želi.

3. Izberite Kartica Shapesali Kartica konektorji V oknu matričnega.

4. V Tippodružnica Explorer, poiščite vrsto dela ali povezave, ki jo želite povezati z obliko ali priključka.

5. Izberite izbrano vrsto elementa iz drevesa, ga povlecite nad v zavihku Oblike ali zavihku priključki, in ga spustite na obliko ali priključkabi želeli uporabiti.

Opomba

Lahko preverite pridružitvi, ki ste jih ustvarili z izbiro komponent ali zavihek Connections v oknu matrična, ki prikazujejo trenutno povezanih elementov.

Če želite, da vaše diagramov / knjižnico dodati nove oblike

1. Ustvarite MS Visio diagram z oblikami, ki jih želite dodati v diagram in uvozite MS Visio diagram .

Nasvet

Pomembno je, kaj velikost vam bo glavno obliko v MS Visio, ker je ABACUS platno velikosti v pikah in le enote milimetrov v MS Visio pretvoriti granularly za pik na 4 pike na 1 razmerju milimeter. Poleg tega so privzete ABACUS oblike so ponavadi 60 pik visoke, tako da se prevede do 15 milimetrov v MS Visio. Pomen priporočljiva master velikost oblika v MS Visioje 25mm, široka 15mm visoksaj bo to prevesti na 100 pikslov široka 60 slikovnih pik z visoko ABACUS.

Nasvet

Če želite imeti malo "ikono" v zgornjem levem kotu oblike, potem lahko preprosto ustvarjanje "ikono" v glavni MS Visio obliki z uporabo paleto MS Visio Drawing Tool (upoštevajte, da samo preproste linije, krogi in pravokotniki so podprti in rasterized / bitne oblike zlasti niso podprti). Poleg tega, če želite, da se ikona, da se določen v velikosti / lestviciv obliki v ABACUS potem lahko skupina "ikona" v glavni MS Visio obliko tako, da izberete vse svoje elemente, z desno tipko miške kliknete en element, izbiro oblike | Skupina, nato z desno tipko miške kliknete združeni obliko in izbiro podatkov | Shape podatkov ..., da izberete Yes v pogovornem oknu, ki se prikaže, in nato dodal nepremičnino z Label nastavljena na LockScale(bodite pozorni na velike črke "L" in "S"), Type nastavljen na Boolean in vrednosti, naj bi se TRUE (Ugotavljam, da je vse z velikimi črkami).

Nasvet

Če želite imeti del oblike zamrznjene od večanja obsega vodoravno ali navpično (kot je značilno z obliko "swimlane"), potem si lahko z desno tipko miške kliknite odsek (e) glavnega MS Visio obliko, ki jo želite zamrznjeni iz luščenje in izberite Podatki | Shape podatkov ..., da izberete Yes v pogovornem oknu, ki se prikaže, in nato dodal nepremičnino z Label nastavljena na LockXScaleali LockYScale (bodite pozorni na velike črke "L" in "S"), Type nastavljen na Boolean in vrednosti, naj bi se TRUE (Ugotavljam, da je vse z velikimi črkami), za zaklenjena horizontalno ali vertikalno luščenje oz.

Nasvet

Da se omogoči barvanje oblike v ABACUS po uvozu namesto oblika vedno pa fiksna barva je priporočljivo, da se zapolni poveljnika MS Visio obliko je pregleden nato pa uporabite vgrajeno zmožnost v ABACUS na barvo obliko v ozadje. To deluje le s pravokotnika ali bližnji pravokotnika (npr zaobljen pravokotnik) oblik, kot bo obarvana celotna pravokotne ozadje.

2. Odprite ustrezno shemo in izberite Kartica komponenteV oknu matričnega.

3. Za vsako novo obliko, ki jo želite, da dajo na voljo drugi diagrami Desni klikoblika in izberite Dodaj Oblike knjižnici. To bo oblika voljo na zavihku Oblike v oknu matričnega.

4. Povezujejo ustrezne vrste sestavnega dela z novo obliko iz knjižnice Oblike po zgoraj opisanih korakih.

Opomba

Le preprosta in oblike so podprte v ABACUS v trenutku ", ki temelji na vektor", so to bitne slike ne podpira. Vendar pa orodja, kot so Vector Magic ( www.vectormagic.com ) So na voljo, da se bo zlahka pretvoriti bitne slike v vektorskih oblik (tj format SVG), ki jih je mogoče odpreti v MS Visio in zato uporabljene v ABACUS kot po zgornjih navodilih.

DodajanjeKomponente in priključki

Orodje za risanje vam omogoča, da dodajte obstoječe komponente in povezave iz skladišča ali ustvariti nove komponente in povezave kot so risanje diagrama. Ker so komponente in povezave ustvarila v diagramih, so istočasno dodamo v Skladišče. Obstajajo tri priporočljivo načini dodajanje komponent v diagramuin tri priporočljivo načine za dodajanje povezav na diagramu:

Če želite ustvariti popolnoma novo komponento ali povezavo na diagramuiz šablone

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Izberite Komponenteali Povezavezavihek v oknu šablon za prikaz sorodnih oblik. Samo te oblike se lahko uporablja za ustvarjanje novih modela elemente.

3. Kliknite in povleciteeden od razpoložljivih povezanih oblik ostane na risalni površini. Nov element se bo pojavil na platnu in v explorer drevesu.

4. Začnite tipkatiime za novega elementa v pogovornem oknu in vseh obstoječih elementov, ki so izravnanih so predlagali in se lahko izberejo namesto dodal nov element v arhitekturi.

5. Kliknite v redu.

6. Če je bila oblika padla na obstoječe komponente, nato pa bo bodisi postane otrok te komponente (če oblika je prišel iz Komponentezanka) bo, ali je vezan na to komponento (če oblika je prišel iz PovezaveKartica).

Opomba

Včasih je treba prilagoditi novo komponento ali povezavo na drugo mesto v arhitekturnem hierarhiji pomočjo raziskovalca.

Postaviti obstoječo komponento ali povezave iz Skladišče na diagramu

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Bodite prepričani, da imate tako risala in brskalnike viden.

3. V Explorerju poiščite komponentaali povezava(element), ki jo želite dodati v diagram.

4. Kliknite in povleciteizbrani element na sliki. Lik, ki predstavlja element, se bo pojavil na platnu.

Opomba

Če je vrsta izbranega elementa že povezana z obliko, bo ustrezna oblika pojavijo na platnu. Če pa ni opredeljeno združenje za določenega elementa, bo privzeta oblika (pravokotnik) pojavi na platnu, razen če Uveljavite diagram Stališča možnost vključena v tem primeru je oblika ne bo dodan k diagramu.

Nasvet

Ko je komponenta nameščena v diagramu, ki je povezan z drugo komponento že na shemi bo risala poizvedbo če bi želeli prikazati povezavo (-e) med njimi. Tudi, če obstajajo otroci komponento orodja za risanje bo poizvedbo, če bi želeli vključiti otroke v rekurzivnega način.

Če želite ustvariti povezavo med 2 sestavnih delov ali priključene komponente na diagramu z uporabo dinamičnega priključek

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Hover preko komponente na sliki, ki jo želite povezati z drugo komponento in boste opazili, 2 ikone se pojavijo zunaj zgornjem desnem delu meje oblike, kot je prikazano spodaj. Opomba: Zgornji ikona je za ustvarjanje povezave, kjer je, da je vir gibala komponenta, ikona dno je za ustvarjanje povezave, kjer je, da je treba potopiti gibala komponenta.

3. Move kazalec nad želeno ikono in kliknite in povleciteikona za več kot eno nad drugo komponento ali prostega prostora na platnu, kot je prikazano spodaj.

4. Če se želite povezati obstoječe komponente izbrati Priložiti k ...element v pojavnem meniju, in če je potrebno brskaj na podmeni, da izbirajo iz razpoložljivih tipov povezave.

- Ali -

4. Če želite ustvariti povezana komponenta izbral iz New ...postavke v pojavnem meniju in po potrebi poiščite podmeniju, da izberejo eno od razpoložljivih vrste povezav kot je prikazano spodaj. Začnite tipkatiime za novega elementa v pogovornem oknu in vseh obstoječih elementov, ki so izravnanih so predlagali in se lahko izberejo namesto dodal nov element v arhitekturi.

Opomba

Razpoložljivost postavk v meniju pop-up in podmeniju se ureja z omejitve v meta-modela.To je edini veljavni vir ali potopi vrste komponent, kot z omejitvami priključnih določi bodo predstavljeni kot Pritrdite ... in New ... menijskih elementov.

Če želite ponovno odprete pogovorno okno za izbor elementov in postavite obstoječe sestavne dele ali povezav iz skladišča na diagramu

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Kliknite Odpri Element Izborgumb v orodni vrstici Diagram. Opomba: Pogovorno izbor element Odprlo se bo z zadnjim stanjem vseh filtrov shranjenih.

3. Izberite vse dodatne vsebine, ki je želeno, da se doda diagram in klik v redu. Opomba: nova vsebina bo dodan praznega prostora na platnu in diagram lahko naknadno določeno spet preko Postavitev Diagramgumb v orodni vrstici Diagram.

Uporaba FreeObrazecOblike

Pogosto je zaželeno, da se ustvarjajo vizualne elemente v diagramu za povsem estetskih razlogov. Ti elementi lahko pomaga izboljšati postavitev in videz diagrama, ki še nimajo strogo arhitekturno pomen. Orodje za risanje omogoča uporabo poljubne oblike oblik opravljanja risanje prilagodljivost.

Če želite dodati prostoročno obliko diagrama

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Izberite Oblikeali Konektorjizavihek v oknu matričnega.

3. Kliknite in povleciteeno izmed razpoložljivih oblik ali priključkov ostane na risalni površini. Nov element se bo pojavil na platnu - vendar neV raziskovalec drevesu.

Opomba

Prostoručni oblike so "non-povezan" oblike, saj nimajo povezave z vsako posamezno sestavino ali povezavo v arhitekturnem modelu.

Če želite prikaz skladišču informacije v Prostoručni oblikaS odiagram

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Desni klikProstoručni oblika in izberite Komentar | Display.

3. Izberite za prikaz bodisi Diagram Name, Diagram Opis, Diagram nepremičnino, Vaše mnenje Nameali Arhitektura Name.

Opomba

Besedilo v prostoročno bo samodejno posodobi osnovnih repozitorijev sprememb podatkov.Na ta način je mogoče ustvariti diagram "naslov blok", in nato zlahka kopira čez, diagramov.

Uporaba plavajočih Oblike

Plavajoči oblike so v bistvu še en način, da predstavljajo komponente v diagramu. Razmislite organizacijo s ključnimi oddelkov: izvršni direktor za trženje, prodajo in razvoj.

Tree View

Te pregrade lahko vizualno zastopane v slojno način:

Večplastna View

Ali pa jih lahko vizualno zastopa postopno / Plavajoči Način za prikaz hierarhijo:

Opotekel / Floating Poglej

Slednji predstavitev uporablja pojem plavajočih oblik.

Če želite pretvoriti plastovito obliko komponent v plavajoči obliko

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Izberite komponentaV vašem diagram želite zastopa kot plavajoči oblike ali pridružene oblike v KomponenteJeziček okna šablon želite vse primerke kot plavajoče oblik.

3. Z desno tipko miške kliknite obliko in izberite Float Komponenta iz kontekstnega menija, ki se pojavi. Upoštevajte diamond glavo povezaveod matičnega komponento (e) za plavajoče komponento (e).

4. Kliknite in povlecitekomponenta na želeno mesto. Ko plavajočikomponenta je izbran, da bo imel modro oris.

Če želite spremeniti plavajočo obliko sestavnega dela v večplastne oblike

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Izberite komponentav diagramu je, da trenutno prikazan kot plavajoči oblike ali pridružene oblike v KomponenteJeziček okna šablon želite vse primerke kot plastenih oblik.

3. Kliknite in povlecitespremenljiva sestavina (-e) nazaj na starševsko (-e) (po predloženem diamond glavo povezave). Opomba: Če tega ne boste storili, potem ko pretvorite komponento (-e), nazaj pa večplastna hierarhija vaš model bi lahko vplivala.

4. Z desno tipko miške kliknite obliko in opustite Float Komponenta iz kontekstnega menija, ki se pojavi. Upoštevajte, da diamond glavo povezaveod matičnega komponenta (e) za plavajoče komponento (e) izgine.

Replike

Orodje za risanje vam omogoča, da dodamo isti element v diagramu večkrat z vsako nadaljnjo vizualni primer sestavine na diagramu besedilu repliko. To je še zlasti uporabno za diagrami, kjer ima komponenta veliko število priključkov v zvezi z njo, in je prednostno za prikaz komponento na več mestih bliže izvoru vsakega od priključkov, ali diagrami, kjer razmerje ena proti mnogo sestavnega dela je bolje kazati tudi plavajoče funkcijo (opisan zgoraj) s komponento na več mestih na vrhu "veliko" komponent je v povezavi z.

Opomba

Lahko pripisujejo / ločijo povezave v / iz prvotne primer sestavine na sliki (kot vedno), ampak tudi kateremkoli od replik, ko pa povezave avtomatsko dodamo k diagramu sta vezana na prvi stopnji sestavine na diagramu privzeto.

Opomba

Replike lahko združimo s seboj s desno tipko miške in povlecitenato izberete Merge ReplikeVendar združitvijo repliko z drugo komponento se bo odražalo v vseh drugih replike izginjajo iz diagrama.

Opomba

Ni vidna razlika med prvotnim primer komponente na diagramu in vseh replik. Poleg tega meni desni klik za izvirno komponento na diagramu in vse replike je identičen, z na primer Prikaži v Raziskovalcupelje v isti komponenti v Tree Pogled na odlagališča (alias modela). Vendar desnim klikom na komponento v Tree Pogled v skladišču in izberete Pojdi doin bo brskanje na diagramu z replikami vedno peljal na "najstarejši" primerek komponente na sliki. Običajno bo to originalni primerek, ki je bil dodan z diagramom, ampak če je bil, da je izvirni primerek naknadno izbrišejo ali združili z repliko, potem bo šel skočiti najstarejši preostalih replik, ki so bile dodane.

Če želite dodaj repliko k diagram

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Z desno tipko miške kliknite obstoječo komponento na diagramu in izberite Ustvarite Replica.Replika izbrane komponente bo ustvarjena desno od prvotne komponente.

- Ali -

Izberite obstoječo komponento na diagramu in pritisnite Ctrl + Cali desno tipko miške kliknite obstoječo komponento na diagramu in izberite Kopiraj. Zdaj z desno tipko miške kliknite mesto na sliki, ki jo želite repliko in izberite Prilepi kot Replica. Opomba: S pritiskom na Ctrl + V (ali desnim klikom in izbiro Prilepi) bo ustvaril kopijo originalnega komponenta ni replika.

- Ali -

Kliknite in povlecitekomponenta iz Tree Pogled na odlagališča (aka modela) na diagramu, kjer že obstaja komponenta.

Konfiguriranje povezave Kape / konča

Orodje za risanje vam omogoča, da nastaviti simbol, ki se uporablja na koncih veznih linij bodisi fiksno simbol ali simbol odvisne od lastnosti na same povezave.To je še posebej uporabna za diagramov, kjer se zahteva smer povezave, da se prikaže, ali za diagrami, kjer je Kardinalnost povezave (ali smer), vsebovanih v lastnine na same povezave, npr "One-to-many" vs "Veliko-to-many" (ali "Source Sink" vs "Sink na vir).

Če želite konfiguriranje povezave kape / konča diagram

1. Prepričajte se, da imate novo ali obstoječo diagram odprte.

2. Izberite Povežiteionizavihek v oknu matričnega.

3. Desno-cLizanje eden izmed povezana vrste povezav in izberite Konfigurirajte Caps ....

4. Za fiksne zveze CAP / konca na obeh vira ali potonejo konec povezavi zagotoviti ustrezne Fiksna izbirni gumb je izbran, in nato končno povezavo simbol iz potegnite navzdol, npr "Arrow Head" ali "Diamond".

- Ali -

Za temeljijo na objektu povezave CAP / konca na obeh vira ali potonejo konec povezavi zagotoviti ustrezne Uporaba Nepremičnineje izbran radijski gumb, nato kliknite na gumb '...' in izberite želeno lastnost in nato ob vsaki končni povezava simbolom vnesete vrednosti nepremičnin, za katere so značilni simbol povezava, da se prikažejo.

Opomba

Večkratne vrednosti nepremičnin za določen simbol povezave končno se lahko vpišejo ločene z vejicami.Npr pogovorno okno prikazuje, da če je "podatkov | Kardinalnost 'lastnost je vrednost "Individualni Mnogi" potem konec vir povezave imajo dve linije kapi skozenj in konec ponor povezave ima en linije kap skozenj in nato fan-od dveh linija kapi konec.

Pogovorno okno Configure Caps

Poglej tudi

Orodje za risanje | Poselitev svojo arhitekturo | Analiziranje Vaše arhitektura


Poselitev svojo arhitekturo

Navigacija: Poselitev svojo arhitekturo>

Poselitev svojo arhitekturo

Pošlji komentarje o tej temi.

Proces izgradnje model vašega arhitekture je znan kot Poselitev. Ko ste odkrili svojo arhitekturo in opredelila svoje potrebe, ste pripravljeni, da model vašega arhitekturo v ABACUS.

Med prebivalstvom, boste vnesli vse podrobnosti, ki jih vedo o vašem arhitekture in kaj je potrebno za to.

Da zapolnijo svojo arhitekturo

1. Zagotovite imate ABACUS odprto datoteko An explorer prikaže , In Arhitektura dodal .

2. Ročno zapolnijo komponente na višji ravni in povezave vašega arhitekture. Običajno bo to bolj abstraktne komponente in povezave.

- Ali -

2. Grafično zapolnijo komponente in povezave, ki bi želeli glej shematično predstavljena, z uporabo Orodje za risanje .

Morda boste prav tako želeli

3. Zapolnijo z uporabo Katalogi - Si lahko ogledate in sestavni deli in vezava na enostaven način. tabelarni

4. Zapolnijo z uporabo matrik - Si lahko ogledate in uredite povezave med komponentami v preprosti tabelarični način.

5. Zapolnijo z Microsoft Access - Lahko uvozite arhitekturo in izvoz v Microsoft Access.

6. Zapolnijo z Microsoft Visio - Lahko uvozite arhitekturo in izvoz v Microsoft Visio.

7. Zapolnijo z Microsoft Excel - Lahko uvozite arhitekturo in izvoz v Microsoft Excel.

8. Zapolnijo z Microsoft SharePoint - Lahko uvozite arhitekturo in izvoz v Microsoft SQL Server.

9. Zapolnijo z Microsoft SQL Server - Lahko uvozite arhitekture iz Microsoft SQL Server.

10. Uvoz iz XML - Lahko uvozite arhitekturo iz ABACUS XML fragment ali ArchiMate Interchange jezika XML datoteko.

Poglej tudi

Poselitev svojo arhitekturo ročno | Orodje za risanje | Poselitev svojo arhitekturo iz Microsoft Access | Poselitev svojo arhitekturo iz programa Microsoft Visio | Poselitev svojo arhitekturo iz Microsoft Excel


Poselitev svojo arhitekturo iz Microsoft Access

Navigacija: Poselitev svojo arhitekturo> Populating iz Microsoftovih izdelkov>

Poselitev svojo arhitekturo iz Microsoft Access

Pošlji komentarje o tej temi.

Lahko izvozite arhitekture za Microsoft Access opravljati splošno rabo izračunih manipulacije ali poročila o vašem arhitekture. Nato lahko uvozite arhitekturo nazaj v ABACUS.

Opomba

Odprto od dostopa / Izvoz v podatkovno bazo funkcija zahteva, da Microsoft Access 2000ali novejši je nameščen na računalniku.

Če želite izvoziti svojo arhitekturo za Microsoft Access

1. Zagotovite imate ABACUS datotekaodprta, Explorerprikazano, in arhitekturadodal.

2. Izberite Datoteka | Izvoz | Če želite Database.

3. Upoštevam pogovornem oknu opozarjanja, kot je opisano zgoraj in kliknite Da, da nadaljuje.

4. Izberite mesto in ime datoteke za datoteko zbirke podatkov.

Uvoziti manipulira arhitekturo v ABACUS

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Datoteka | Novo in izberite Iz Accessv pogovornem oknu, ki se prikaže, in kliknite V redu.

3. Poiščite datoteko zbirke podatkov, ki jo želite uvoziti.

ABACUS "MS Access Database Schema

ABACUS ima na svojem srcun ontologija / meta-meta-model, ki ga sestavljajo elementi, priključki in omejitev. Ta "CCC" pristop izvira iz različnih standardnih pristopov, razvitih od 1960 dalje, ki se zaključi v mednarodnem standardu IEEE 1471, katerega ustanovitelji Avolution je prispevalo k. Uporabljajo se naslednje primitivnih;

1. ABACUS Vsebuje Knjižniceod Standardi(ali standardih), Komponentain Vrste povezava, Omejitve, Stališča, Predloge (ali Vzorci) In veliko Arhitekture.

2. Standardi, Vrstein Stališča lahkologično Združeniza udobje.

3. Arhitekture lahko vsebujejomnogi potomec Arhitekture(ali Evolutions).

4. Vsak Arhitektura Vsebujeveliko Komponentein Povezavenekaterih Vrstein različne Ogledov.

5. Komponentein Povezave je lahko razgradiv Sub-Komponentein Sub-Povezave.

6. Vsak Komponentaje priloženpoljubno število Povezavetoda vsak Povezavalahko le priložennajveč dva Komponente.

7. Komponentein Povezavelahko imajo Standardis Nepremičninekot Informacije, zmogljivost, zanesljivost, stroške itd

8. Arhitekture, Komponentein Povezavelahko imajospecifična Nepremičninekot Informacije, zmogljivost, zanesljivost, stroške itd

9. Omejitvelahko obstaja med Komponenteali Povezaveali proti Nepremičnine.

10. Predlogestandardne sestavki Komponentain Vrste povezava.

11. Stališčaso standardne združenja Komponentain Vrste povezavada oznak.

12. Ogledovso vizualne reprezentacije Komponentein Povezave.

Naslednji MS Access Entity Razmerje Diagram (ERD) dokumentih JedroArhitekture, Evolutions, Vrste Komponenta / povezavo (skupine), komponente / Connections in Sub koncepti Komponenta / povezave.

Baza podatkov shema Core

Opomba

Referenčne integritete ni bila izvršena na odnos med mizo Komponente in mizo Connections (za "pritrditev" med danem viru ali potonejo komponente in povezave). To je zato, ker se lahko povezava obstajati brez sestavnih prilogami. Lahko bi dodali tabelo "zaplemba", ampak v interesu preprostosti odločili proti temu. Seveda to pomeni, da bo vsak urejanje Component IDS ali brisanje Component vrstic vse skupaj privede do napačnih podatkov. ABACUS bo ročaj koli nepravilnost pri uvozu z ignoriranjem napačne podatke.

Naslednji MS Access ERD dokumentih za Nepremičninekoncepti arhitekture, Vrste Component / povezave in komponente / Connections.

Lastnosti podatkovne baze schema

Naslednji MS Access ERD dokumentih za Standardikoncept arhitekture, Vrste Component / povezave in komponente / Connections.Opomba: Tabele še vedno uporabljajo izraz "izvajanja", kot na prejšnjih različicah ABACUS.

Standardi podatkovne baze schema

Naslednji MS Access ERD dokumentih za Omejitvekoncept za Component Tipi / povezavo.

Omejitvepodatkovne baze schema

Naslednji MS Access ERD dokumentih za Stališča koncept za Arhitekture.Opomba: Tabele še vedno uporabljajo izraz "TwoDTempl" kot na prejšnjih različicah ABACUS.

Stališčapodatkovne baze schema

Naslednji MS Access ERD dokumentih za Katalogikoncept za Arhitekture.

Katalogipodatkovne baze schema

Naslednji MS Access ERD dokumentih za Matrikekoncept za Arhitekture.

Matrikepodatkovne baze schema

Naslednji MS Access ERD dokumentih za Diagramikoncept za Arhitekture.Opomba: Tabele še vedno uporabljajo izraz "TwoD" kot na prejšnjih različicah ABACUS.

Opomba

Komponenta / Priključitev Vnesite da šablona oblike kartiranje in prostoročno glede oblike dele MS Access ERD so bili izpuščeni zaradi jasnosti.

Diagramipodatkovne baze schema

Naslednji MS Access ERD dokumentih za 3D pogledikoncept za Arhitekture.

3D pogledipodatkovne baze schema

Naslednji MS Access ERD dokumentih za Chartskoncept za Arhitekture.

Chartspodatkovne baze schema

Naslednji MS Access ERD dokumentih za Namizijkoncept.

Namizijpodatkovne baze schema

Abacus 'MS AccessPoizvedbe

Vključena v podatkovni bazi MS Access več uporabne poizvedbe, kot sledi;

· Comps po Props- To vprašanje navaja vse sestavne dele v projekt (arhitektura in tip) in vključuje vse lastnosti, kot so stebri. Uporabite ta ukaz s filtri / kriteriji za homologacijo sestavnega dela in / ali arhitekture, da proizvajajo "tipične" tabele za vsako vrsto sestavnega dela s svojimi lastnostmi.

· SPB po Props- Ta izraz našteva vse standarde, ki so v uporabi, število pojavitev standarda in vključuje vse lastnosti, kot so stebri. Uporabite ta ukaz kot standarde katalog.

· Props po vrstah- To vprašanje navaja vse sestavne lastnosti in njihovo% popolne za vsak tip sestavnih delov kot stolpcev. Uporabite ta ukaz, da se ugotovi, ali so posebne lastnosti, ki se ohranja.

· Vrste z Props- Ta izraz našteva vse tipe sestavnih in vključuje% popolno vseh lastnosti, kot so stebri. Uporabite ta ukaz, da se ugotovi, ali so posebne lastnosti, ki se ohranja.

· Vrsta Count- Ta izraz našteva vse tipe sestavnih in vključuje število dogodkov posamezne vrste v padajočem vrstnem redu. Uporabite ta ukaz za določitev priljubljenosti vsake vrste v projektu.

Opomba o delu z memo polja v MS Access

Sestavni deli, Priključki in Ime standardi polja v tabelah so opredeljeni kot pojasnjevalne področjih, da bi za neomejeno število znakov, kot na ABACUS. Za Komponente in Connections to povzroča nekaj težav, ker imajo tudi edinstven ID polje za navajanje, ampak za standarde to povzroča nekaj težav, ko poskušajo pridružiti tabele, ker si ne more pridružiti memo polja v MS Access. Druga možnost je, lahko nastavite, kjer merila klavzulo, da se doseže enak učinek, kot je prikazano v Visual Query Builder in ustrezne SQL odrezke spodaj navedenem seznamu ven vse podedovani Standardi lastnosti za vse komponente v izvoznem projektu ABACUS.

Memo polje "pridruži" v Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

Iz delov, notranjo pridružitev ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) IN (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id) izvedb INNER JOIN ImplementationProperties ON Implementations.Id = ImplementationProperties.Implementation_Id

KJE (((ComponentImplementationLinks.Name) = [izvedb] [Ime]).);

Memo polje "pridruži" v SQL

Opomba samodejno generiranje ABACUS ID v MS Access

Različne mize ABACUS MS Dostop zahtevajo edinstveno dolgo celo število ID tako je preprosta metoda VB pod pogojem, da se pomoč pri ustvarjanju teh. Dve metodi ResetCounter () in GetNextCounter () so na voljo v Abacus 'MS Access DB in njihova uporaba je, kot sledi; ResetCounter () bo postavil števec nazaj na 0. GetNextCounter () bo vrnil naslednji števec v zaporedju.

Metode izkoriščajo MS Access 'domislica', da tudi če pokličete metodo ResetCounter () za vsako vrstico vložka (tj, ko ste tudi zaženete funkcijo GetNextCounter ()), ker je funkcija ResetCounter () nima nobenih parametrov je samo teče je nekoč in zato ne ponastavi števec za vsako vrsto vložka. In tudi zato, ker v isti "Ovinka" moraš opraviti vse stare spremenljivke stolpca funkcijo GetNextCounter (), da se norec v tekmovanje v teku vsakič.

Na voljo je tudi trik, da bi mogli zagnati funkcijo ResetCounter () v vložku v izjavi SQL, ker si ne moremo preprosto jih je sedel tam kot koloni sama, kot če bi bil izberite poizvedbo. Priporočljivo je, da se podajo v ResetCounter () klicno del ene od drugih področjih, tako da ga concatenating do konca, kar je vedno vrne nična nekako.

Spodaj je tipičen SQL uporaba metod dodati seznam sestavnih tipov iz tabele / poizvedbo imenovano "Komponenta Seznam Tip".

INSERT INTOComponentTypes (Id, ime, opis)

SELECT GetNextCounter ([Component Type Seznam] .name)AS Id [Component Type Seznam] .name AS Ime, [Component Type Seznam] .description & ResetCounter ()AS Opis

IZ[Component Type Seznam];

ABACUS ID generacije / Counter v SQL

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Poselitev svojo arhitekturo iz Visio | Poselitev svojo arhitekturo iz Excela


Poselitev svojo arhitekturo iz Microsoft Excel

Navigacija: Poselitev svojo arhitekturo> Populating iz Microsoftovih izdelkov>

Poselitev svojo arhitekturo iz Microsoft Excel

Pošlji komentarje o tej temi.

Lahko uvozite arhitekturo iz Excel (.xls ali .xlsx mapa). Excel uvoznik vam omogoča, da karto sezname komponente in povezave s tipi, standardi, lastnosti in standardnih lastnosti z izbiro stolpcev v preglednici, ki vsebujejo ustrezne podatke.Vendar pa je bolj napredno tehniko od Priporočeni pristopza uvoz iz MS Excel, ki je preko katalogi kot je opisano tukaj .

Opomba

Uvozi iz / Izvozi v Excel funkcija zahteva, da Microsoft Excel 2003ali novejši je nameščen na računalniku.

Glavna funkcija Excel Uvoznik je, da vam omogočajo, da določite konfiguracijsko datoteko (tj hierarhično strukturo vašega arhitekturnega modela). Konfiguracijska datoteka shrani predhodno shranjeno kartiranje iz Excel datoteke z ABACUS datoteko. Ko je opredeljeno, se shrani konfiguracija datoteka pozneje uporabi za nadaljnji uvoz in izvoz v .xls datoteke.

Opomba

Koraki so prikazane v spodnjih oddelkih so posebej za uporabnike, ki imajo še opredeliti in shranite konfiguracijske datoteke in jih uvaža iz excel prvič. Morate ustvariti in shraniti konfiguracijsko datoteko uporabiti izvoz excel funkcijo.

Če želite uvoziti Excel v ABACUS

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Datoteka | Nova in izberite Excelv pogovornem oknu, ki se prikaže, in kliknite V redu.

Opomba

Če želite uvoziti v obstoječi projekt ABACUS potem desno tipko miške kliknite Komponente vozlišče znotraj arhitekturo, ali desno tipko miške kliknite posamezno komponento znotraj arhitekturo in izberite Import | Iz Excela.

3. Uvoz Excel preglednicese bo prikazalo okno

Uvoz Excel preglednice Window

4. Kliknite Odpri Excel datotekeicon in brskanje za Excel datoteko, ki jo želite uvoziti.

5. Izberite Delovni listželite uvoziti iz spustnega navzdol.

Opomba

Po odprtju vašo datoteko Excel, ki jih lahko uporabite Podatki Predogledzavihek za ogled stolpce in prvih 25 vrstic preglednice. Od tu lahko dobijo številke stolpcev, ki so potrebni, da izpolnite Komponentein Povezavetab.

Izberete lahko tudi, ali želite sestavine v excel preglednico, ki se uvažajo z občutljivostjo primera. Preprosto odkljukajte Uvoz z občutljivostjo sodnomožnost (privzeto je to vedno označili) in preglednico bo ustrezno uvožena.

Vzorec Excel datoteke

Opomba

V tem primeru bo uvažamo preprost infrastrukture in ljudje arhitekture iz podatkov, Excel, prikazanih v zgornji sliki. Povezave bodo med "odgovorne osebe" in "strežniki", da ti ljudje upravljajo.

Poseliti zavihek Komponente

Ta oddelek je za opredelitev vrste komponent in hierarhično strukturo za konfiguracijske datoteke.

1. Izberite Komponentetab. Preimenovati Set IDz nujnimi (nič)vrednost

Opomba

Ta funkcija vam omogoča, da določite popolnoma drugačen Kompletiza funkcionalno ločenih komponent. Kot je prikazano na sliki spodaj, boste morda želeli razlikovati svoje infrastrukturne komponente od vaših ljudi komponent. Če so odnosi (povezave) med temi ločenih sklopov sestavnih delov, jih je treba opredeliti v okviru Povezavetab. Kasneje v tem primeru bomo opredelili povezave tipa "upravlja" med infrastrukturo in People Kompleti.

Izberete lahko tudi, ali želite dodati vrhunske Združevanjekomponenta za vse elemente niza. Preprosto odkljukajte Skupina Pod Set IDmožnost (privzeto je to izbrišete kljukice) in preglednico bo ustrezno uvožena.

Dodeljevanje Set ID

2. Ko Kompletiso bili opredeljeni izberite Setželite, da zapolnijo in razširiti s klikom na [+]prijavite.

3. Izberite Ravni komponent v tem sklopuiz razširjenega seznama.

4. Komponenta hierarhija določa: Set IDse bo pojavilo okno za to Set.

Komponenta Hierarhija in pripisovanje vrednosti (Set ID: Infrastructure)

5. Preimenovati Število ravenstolpec z nujnimi (nič)vrednost.

Opomba

Število ravenstolpec vam omogoča, da določite hierarhijo za vaše komponente. Vsaka stopnja ustreza plasti v vašem arhitekture, pri čemer je prva stopnja na vrhu najbolj matičnanivo. Na primer, številka Level "1" ustreza vrhunskih hierarhični plasti, Level številka "2", je otrok ravni številka "1" in tako naprej.

6. Izberite in dodelite ustrezni stolpec iz Excel za vsak Število ravenz njenim vstopom v okviru Komponenta stolpecstolpec.

Opomba

Lahko se odločite, da izključi nekatere vrstice, ki jih ne želite, da je zastopana v arhitekturi. To so lahko stolpec glave, prazne vrstice itd Za izključitev vrstice uporabite Vrstice za izključitev:polje z besedilom v bližini zgornjem desnem kotu okna. V tem primeru smo izključeni vrstico 1, saj vsebuje naše glave stolpcev.

7. Lahko se odločite, da dodate opise vaših komponent, ki jih prepisali (nič)vrednost v Opis stolpec.

Opomba

Ta opis je tisto, kar se bo pojavil v ABACUS pod Splošni Lastnostioddelek | Opispolje.

8. Če ima neka preglednice kolona več kot eno komponento na celico (ki je začel s pomočjo Alt-Enter ali CHAR (10) ukaz), potem označite potrditveno polje spodaj Privoščite novih progah kot ločene sestavne dele. Vsaka vrstica se uvozi kot ločenih komponent.

Nasvet

Če želite uvoziti, matriko 'iz zbirke kolon, kadar "X" v določenem matriko' celice (celice B2: D2 pravijo), pomeni, da (recimo v celici A2) komponenta, ki jo določi zapored je povezan s komponento določeno v stolpcu "naslov" (v vrstico 1 reči), lahko uporabimo preprosto formulo. Vnesite naslednjo formulo za vsako vrstico v stolpcu onkraj matrične celice (stolpec F reči); = IF (B2 = "", "", B 1 $ & CHAR (10)) in IF (C2 = "", "", C 1 $ & CHAR (10)) in IF (D2 = "", "", D 1 $ & CHAR (10)). Nato vzpostaviti povezavo nastavite, kot je opisano v nadaljevanju med komponentami, določenimi z vrstico (v stolpcu A pravijo), in tistimi, ki jih to formulo opisal (v stolpcu F pravijo). Bodite prepričani, da preverite Privoščite novih progah kot ločene sestavne delemožnost, ko so uvoženi komponente iz formule. Za bolj napredne matrični uvozu, vključno s postavkami z več plastmi hierarhije ali celice z različnimi vrednote kot le navaden "X", se obrnite na Avolution Podpora .

9. Izpolnjena ostala kolon, kot je potrebno.

Opomba

Lahko se odločite, da bi dobili vrsto iz vrsticah stolpca tako, da odkljukate polje pod Get Tip iz stolpcastolpec in vstopajo v ustreznem stolpcu iz Excel pod Komponenta Tip Value ali stolpecstolpec. To bo uvoz vseh komponent v tem stolpcu in iz njih, da kakršna je določena v koloni. Druga možnost je, in tako kot pri posnetku zaslona zgoraj in spodaj, lahko izberete z vnosom imena tipa pod uporabiti fiksni / vnaprej določeno ime vrste Komponenta Tip Value ali stolpecstolpec in pazite polje je un-preverjena.

Komponenta Hierarhija in pripisovanje vrednosti (Set ID: People)

Opomba

V tem primeru želimo, da imajo naše mreže in ljudi združenja na ravni 1 arhitekturo. Na 2. stopnji želimo imeti svoje strežnike in osebe, odgovorne za upravljanje teh strežnikov. KomponenteJeziček je izpolnil ustrezno, kot je prikazano na obeh zgornjih zaslona. V prvi sliki zgoraj smo opredelili 1 (omrežna grupiranje), in na raven 2 (Server) komponente ravni za infrastrukturo Set. In na sliki takoj zgoraj smo opredelili na ravni 1 (ljudi združi) in raven 2 (odgovorne osebe) komponente za ljudi Set.

Alternativno, za LjudjeSet, namesto z uporabo stolpec C kot People skupina, smo bi uporabili Skupina Pod Set IDmožnost na kartici vrh komponent nivoja in potem samo vnese eno Ljudje sub-ravni iz stolpca D. To je prikazano na sliki spodaj.

Komponenta Hierarhija in pripisovanje vrednosti prek Group Pod Set ID možnost (Set ID: People)

10. Ko so bile ugotovljene sestavine, izberite ravni komponent želite zapolnijo lastnosti in / ali standardov in razširiti s klikom na [+]prijavite.

11. Izberite Lastnosti komponente na tej ravniali Sestavni Standardi na tej ravniiz razširjenega seznama in zapolnijo ustrezne stolpce, kot je potrebno.

Poselitev Komponente

Opomba

Lastnosti komponente na tej ravnivam omogoča, da določite lastnosti komponent na izbrano stopnjo. Sestavni Standardi na tej ravnivam omogoča, da določite standardov in standardnih lastnosti komponent na izbrano stopnjo.

12. Ponovite korake 2 - 11dokler so bili vsi sestavni deli stopnje za naseljena za vse definirana Kompleti. Uporabite puščico nazaj bližini zgornjem desnem kotu okna za navigacijo nazaj na Kompletiki ste jo določili prej.

Poseliti zavihek Connections

Ta oddelek je za opredelitev vrste povezav in hierarhično strukturo za konfiguracijske datoteke.

1. Izberite Povezavetab. Za vsak sklop povezav boste morali določiti komponento Setda hočeš biti komponente vira in je sestavni del Sethočeš biti komponente destinacija.

2. Pod Vir Component Set IDvpišite Setime, ki ustreza Setprej v definirana Komponentetab. Pod Vir Komponenta Stopnja Številovnesite številko, ki ustreza ravni komponent, ki jo želite priključiti na koncu vir povezave.

3. Sedaj izbrati katerih komponenta skupina bo v ciljnem koncu povezave. Pod Destinacija Component Set IDvpišite Setime, ki ustreza Setopredeljena v Komponentetab. Pod Destinacija Komponenta Stopnja Številovnesite številko, ki ustreza ravni komponent, ki jo želite priključiti na namembnem koncu povezave.

Opomba

V tem primeru želimo povezati ljudi, ki so odgovorni za upravljanje strežnikov do strežnikov, ki jih upravljajo. Ljudje, ki so odgovorni so bili opredeljeni v Ljudje Setkot ravni je bilo 2 komponenti, medtem ko so strežniki opredeljeni v infrastrukturo Set PovezaveJeziček je izpolnil ustrezno, kot je prikazano na sliki spodaj.

Tab povezave Del 1 od 2

4. Če se premaknete na desno, boste našli dodatne možnosti za uvoz vaše povezave. Get Tip iz stolpcain Vrsta povezave vrednost ali stolpecdelujejo na enak način kot za Komponentetab.

5. Če Vir Component Set IDin Vir Komponenta Stopnja Številoso enaki kot Destinacija Component Set IDin Destinacija Komponenta Stopnja Število(na primer, če se povezujete iste vrste komponent, kot je izvedba povezav s strežnikov do drugih strežnikov), potem morate imeti drug stolpec v preglednici, ki vsebuje imena teh strežnikov ponavljajoče. V tem primeru bi si dal to preglednico stolpec v Destinacija Ponavljajoča v kolonistolpec. Če v tem preglednice stolpcu ste vnesli več kot eno priključene komponente na celico, nato pa označite potrditveno polje spodaj Privoščite novih progah kot ločene sestavne dele.

Tab povezave Part 2 of 2

6. Ko so bile ugotovljene povezave izberite povezavo, ki jo želite, da zapolnijo lastnosti in / ali standardov in razširiti s klikom na [+]prijavite.

7. Izberite Lastnosti teh povezavali Standardi za te povezaveiz razširjenega seznama in zapolnijo ustrezne stolpce, kot je potrebno.

Opomba

Lastnosti teh povezavvam omogoča, da določite lastnosti za izbrano povezovalna skupina. Standardi za te povezavevam omogoča, da določite standardov in standardnih lastnosti za izbrano povezovalna skupina.

8. Ponovite korake 2 - 7 letdokler so bile opredeljene vse skupine povezavo.

9. Ko ste končali z opredelitvijo skupine za povezavo, kliknite na Finishgumb in vaša arhitektura se bo ustvarjen iz uvožene datoteke Excel. V zgornji primer se bo odražalo v arhitekturi je prikazano na sliki spodaj.

Vzorec Arhitektura Uvoženo iz Excela

10. Sedaj shranite preslikan konfiguracijo v datoteko s klikom na Save Configurationikona. Vaša shranjena konfiguracija lahko kasneje najdena s klikom na Odprite konfiguracijoicon bližini zgornjem levem kotu okna.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Poselitev svojo arhitekturo iz Access | Poselitev svojo arhitekturo iz Visio


Poselitev svojo arhitekturo iz Microsoft SharePoint

Navigacija: Poselitev svojo arhitekturo> Populating iz Microsoftovih izdelkov>

Poselitev svojo arhitekturo iz Microsoft SharePoint

Pošlji komentarje o tej temi.

Ti lahko sinhronizirate Vaše arhitektura sMicrosoft SharePoint seznami. Sinhronizacija vključuje bodisi z ustvarjanjem novih SharePoint seznamov (in njihovih stolpcev) iz ABACUS vrst, njihovih lastnostih in priloge, ali kartiranje obstoječih SharePoint seznamov (in njihovi stolpci) za tipe ABACUS, njihove lastnosti in priloge, potem pošiljanje vsebine iz ABACUS za SharePoint ali SharePoint da ABACUS.

Opomba

SharePoint Sync funkcija zahteva, da Microsoft SharePoint 2010, 2013ali SharePoint Online Spletna stran je na voljo za povezavo in sinhronizacijo z.Medtem ko lahko funkcija SharePoint Sync ustvarite sezname (s stolpci) na mesto SharePoint iz kakršnega koli projekta ABACUS, lahko Avolution zagotavljajo tudi različne SharePoint stran predloge v podporo standardnih okvirov (npr TOGAF, ArchiMate, ITIL, itd), tako da se obrnite na Avolution Podpora Če potrebujete te sposobnosti.

Če želite ustvariti nov seznam SharePoint in map na komponento ali povezave tipa ABACUS

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Orodja | SharePoint Sync.

3. Kliknite New MappingGumb in pogovorno okno SharePoint Mapping, kot je prikazano v nadaljevanju bodo prikazani.

4. Vnesite URL strani, uporabniško ime in geslo za SharePoint in kliknite Povežite.

Opomba

Veljavno SharePoint "admin" ali račun "vlagateljeva" je potreben za sinhronizacijo iz in v SharePoint in "bralca" račun bo dovolil le sinhronizacijo iz SharePoint.

5. Izberite dela ali povezave vrsto ABACUS da karto pridobi od Select Typepotegnite navzdol.

6. Kliknite Dodaj novogumb in nato za vsak sestavni del ali tipa povezava pogledu ABACUS želite preslikati v ustrezno SharePoint seznam področju izbrati element na levi plošči in na desni strani zaslona vnesite novo ime seznama SharePoint v stolpcu Novi List (samo prvič) , nato ime SharePoint stolpec v stolpcu Ime (ali uporabite privzeto) in kliknite Dodeli vsakič.

Opomba

Kot minimum omogoči sinhronizaciji ABACUS EEID, arhitektura in vidiki Ime se bo samodejno preslika v SharePoint številko in dva (2) enotni vrstico besedila (aka besedilo) stolpcih oz. To ne more biti nezaseden. Poleg tega lahko samo nekatere ABACUS vidiki trenutno se preslikajo v določene SharePoint stolpce in stolpec Type spustnem bo samodejno nastaviti na zahtevano SharePoint tip stolpca.In sicer;

· Abacus 'Hierarhija Pot SharePoint večih vrstic besedila (aka opombo) stolpcih (Opomba: SharePoint enotnega vrstico besedila (aka besedilo) stebri podpirajo le 255 znakov, tako da niso prednostni),

· ABACUS ", priloženem Komponente za SharePoint Lookup stolpcev (Opomba: Preslikava mora že obstajati na seznam za priloženih samih komponent),

· Besedilna in opis lastnosti Abacus 'za SharePoint več vrstic besedila (aka opombo) stebrov (Opomba: SharePoint eno vrstico besedila (aka besedilo) stebri podpirajo le 255 znakov, tako da niso prednostni),

· Decimalna ali Integer lastnosti Abacus 'do SharePoint Število stolpcev,

· ABACUS "Seznam lastnosti za SharePoint Choice stolpcev (Opomba: SharePoint ne uveljavlja vrednote izbire, tako da podatki Seznam tip ne treba izvršiti v ABACUS),

· ABACUS "Datum / čas lastnosti za SharePoint več vrstic besedila (aka opombo) stolpcev (Opomba: SharePoint datum in čas stolpcih se ne sme uporabljati kot še zaradi nedoslednega podporo SharePoint za Timezone / nastavitve regionalizacije),

· Boolove lastnosti Abacus 'do SharePoint da / ne (aka Boolean) stolpcih.

An Abacus element je Associated Standardi se ne more preslikati na SharePoint seznam stolpcev kot še.

7. Izberite Ustvarite Mapping.

Če želite ustvariti nov preslikavo med komponento ABACUS ali vrsto povezave in obstoječi seznam SharePoint

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Orodja | SharePoint Sync.

3. Kliknite New MappingGumb in pogovorno okno SharePoint Mapping, kot je prikazano v nadaljevanju bodo prikazani.

4. Vnesite URL strani, uporabniško ime in geslo za SharePoint in kliknite Povežite.

Opomba

Veljavno SharePoint "admin" ali račun "vlagateljeva" je potreben za sinhronizacijo iz in v SharePoint in "bralca" račun bo dovolil le sinhronizacijo iz SharePoint.

5. Izberite dela ali povezave vrsto ABACUS da karto pridobi od Select Typepotegnite navzdol.

6. Izberite seznam SharePoint stran, da karto pridobi od Izberite Seznampotegnite navzdol.

7. Za vsak sestavni del ali tipa povezava pogledu ABACUS želite preslikati na seznam ustrezna SharePoint stolpcu izberete na levi plošči in desno ploščo zaporedju in kliknite Dodeli.

Opomba

Kot minimum omogoči potrebujete sinhronizaciji ABACUS EEID, arhitektura in vidiki Ime, ki se preslika v SharePoint številko in nato za arhitekturo in ime bodisi enotni vrstica besedila (aka besedilo) ali več vrstic besedila (aka Note) stolpcih oz. Dokler se to ne poteka gumb Mapping Ustvari ne bo omogočen. Poleg tega lahko samo nekatere ABACUS vidiki trenutno se preslikajo v določene SharePoint stolpce.In sicer;

· ABACUS "Arhitektura vidik SharePoint enotnega vrstico besedila (aka besedilo) ali več vrstic besedila (aka Note) Stolpci (ta je potrebna za vsebino posebnega kartiranja, kot je opisano v nadaljevanju),

· Abacus 'Hierarhija Pot SharePoint eno vrstico besedila (aka besedilo) ali več vrstic besedila (aka opombo) stolpcih (Opomba: SharePoint enotnega vrstico besedila (aka besedilo) stolpci podporo le 255 znakov tako morebitni dodatni znaki bo okrnjena in zato je priporočljivo, da jih pretvorite v večih vrstic besedila (aka opombo) stolpcev v SharePoint pred kartiranje),

· ABACUS ", priloženem Komponente za SharePoint Lookup stolpcev (Opomba: Preslikava mora že obstajati na seznam za priloženih samih komponent),

· Besedilna in opis lastnosti Abacus 'za SharePoint eno vrstico besedila (aka besedilo) ali več vrstic besedila (aka opombo) stolpcih (Opomba: SharePoint enotnega vrstico besedila (aka besedilo) stolpci podporo le 255 znakov tako morebitni dodatni znaki bo okrnjena in zato je priporočljivo, da jih pretvorite v večih vrstic besedila (aka opombo) stolpcev v SharePoint pred kartiranje),

· "Decimalna ali celih lastnosti za SharePoint Število stolpcev (Opomba.: SharePoint Izračunana kolone se lahko uporabljajo pa jih bodo lahko le sinhronizirajo od SharePoint na ABACUS Poskus sinhronizirati" Abacus na "izračunanega stolpca se bo odražalo v opozorilo, kot na spodaj) ,

· ABACUS "Seznam lastnosti za SharePoint Choice stolpcih,

· ABACUS "Datum / čas lastnosti za SharePoint več vrstic besedila (aka opombo) stolpcev (Opomba: SharePoint datum in čas stolpcih se ne more uporabljati zaradi nedoslednega podporo SharePoint za Timezone / nastavitve regionalizacije),

· Boolove lastnosti Abacus 'do SharePoint da / ne (aka Boolean) stolpcih.

An Abacus element je Associated Standardi se ne more preslikati na SharePoint seznam stolpcev kot še. In SharePoint je Valuta, oseba ali skupina, Hiperpovezava ali slika, Task Izid, External Data in Upravljane stolpci metapodatki ne more biti razporejena na ABACUS vidikov še.

8. Izberite Ustvarite Mapping.

Če želite sinhroniziratevaš Microsoft SharePoint seznam (-i)v ABACUS

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Orodja | SharePoint Sync.

Opomba

Če želite sinhronizacijo seznam SharePoint zProjekt ABACUS potrebuje dovoljenje uporabnik SharePoint Syncadd-on zmogljivosti. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

3. Izberite obstoječo SharePoint preslikave (ali preslikave uporabo Ctrl-klikali Izberi vseGumb) iz SharePoint Preslikaveploščakot je prikazano na sliki vzorca nad. Opomba: tu kažemo samo 'Goal (ali potrebe) "ABACUS homologacijo sestavnega dela preslikavo na seznamu SharePoint bil izbran imenovani goli.

4. Izberite Architecture (e), ki jo želite sinhronizirati vsebine z od Vsebina Sinhronizacija iz ArchitecturesPlošča prikazano na sliki vzorca nad. Opomba: tu kažemo samo "2015 Dejanski" arhitektura se sinhronizirajo.

5. Izberite Sync Od SPGumb.

Opomba

Če so poverilnice za SharePoint mestu ne "vse shranjene" za kartiranje (-e) izbrano nato Prijava na oknu SharePoint bodo prikazani prosi za URL spletne strani, Uporabniško ime in / ali Geslo.Vnesite ti. Poleg tega bo sinhronizacija vključujejo vse druge preslikave, ki so potrebni za pritrjenih komponent / lookup stolpcev. Morebitne dodatne preslikave, ki so avtomatično vključeni bo prikazana v pogovornem oknu, kot na spodaj.

6. Po uspešni sinhronizaciji se bo pojavilo pogovorno okno z rezultati SharePoint Sync, kot je prikazano spodaj naštete spremembe in vsa opozorila. Kliknite v redu.

Če želite sinhronizirati iz ABACUS do vaš Microsoft SharePoint seznam (-i)

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Orodja | SharePoint Sync.

Opomba

Če želite sinhronizacijo seznam SharePoint zProjekt ABACUS potrebuje dovoljenje uporabnik SharePoint Syncadd-on zmogljivosti. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

3. Izberite obstoječo SharePoint preslikave (ali preslikave uporabo Ctrl-klikali Izberi vseGumb) iz SharePoint Preslikaveploščakot je prikazano na sliki vzorca nad. Opomba: tu kažemo samo 'Goal (ali potrebe) "ABACUS homologacijo sestavnega dela preslikavo na seznamu SharePoint bil izbran imenovani goli.

4. Izberite Architecture (e), ki jo želite sinhronizirati vsebine z od Vsebina Sinhronizacija iz ArchitecturesPlošča prikazano na sliki vzorca nad. Opomba: tu kažemo samo "2015 Dejanski" arhitektura se sinhronizirajo.

5. Izberite Sync Za SPGumb.

Opomba

Če so poverilnice za SharePoint mestu ne "vse shranjene" za kartiranje (-e) izbrano nato Prijava na oknu SharePoint bodo prikazani prosi za URL spletne strani, Uporabniško ime in / ali Geslo.Vnesite ti. Poleg tega bo sinhronizacija vključujejo vse druge preslikave, ki so potrebni za pritrjenih komponent / lookup stolpcev. Morebitne dodatne preslikave, ki so avtomatično vključeni bo prikazana v pogovornem oknu, kot na spodaj.

6. Po uspešni sinhronizaciji se bo pojavilo pogovorno okno z rezultati SharePoint Sync, kot je prikazano spodaj naštete spremembe in vsa opozorila. Kliknite v redu.

Opomba

ABACUS bo posodobil SharePoint stolpce z praznih vrednostih, tudi če "zahteva, da se ta stolpec vsebuje informacije," je nastavljena na Da, v SharePoint. To je zato, ker ne SharePoint ni to nastavitev navzven izpostavi. Če je to, da je treba preprečiti, je priporočljivo, da ABACUS Designer nastavi Zahtevano omejitev na True in prisilnih za določeno nepremičnino uporabo ABACUS " Omejitev Funkcija .

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Poselitev svojo arhitekturo iz Visio | Poselitev svojo arhitekturo iz Excela


Poselitev svojo arhitekturo iz Microsoft SQL Server

Navigacija: Poselitev svojo arhitekturo> Populating iz Microsoftovih izdelkov>

Poselitev svojo arhitekturo iz Microsoft SQL Server

Pošlji komentarje o tej temi.

Lahko uvozite arhitekture iz zbirke Microsoft SQL Server. Imate na izbiro samo uvoziti Mize in Relationships učinkovito uvoznice samo generično strukturo baze podatkov ali tabel, vrstic in razmerjih, ki bo uvozil ne le strukturo vendar podatki, kot tudi.

Opomba

From SQL funkcija Server, zahteva, da Microsoft SQL Server 20052008, 2008 R2, 2012 ali 2014je nameščen na računalniku.

Če želite uvoziti Server baze podatkov Microsoft SQL v ABACUS

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Datoteka | Novo in izberite Iz SQL Serverv pogovornem oknu, ki se prikaže, in kliknite V redu.

3. V pogovornem oknu Server Uvoz SQL, ki se pojavi nastavi "-računalnika" in vrednote "SQLINSTANCE 'povezave godalnega spremenljivke in vrednosti" DBNAME "baze podatkov ime spremenljivke z njihovimi pravimi vrednotami, kot je prikazano na sliki vzorca spodaj.

4. Nastavite Database Name spremenljivko na isto vrednost kot začetno Katalog spremenljivke, določene v zgornjem koraku, kot je prikazano na sliki vzorca spodaj.

5. Pritisnite gumb za preizkus povezave in mize Import del pogovornega okna je treba poseljena z razpoložljivimi tabel baze podatkov, kot je prikazano na sliki vzorca spodaj.

6. Izberite tabele, ki jih želite uvoziti, ki jih bodisi individualno izbiro ali z uporabo Vse, Nič in obrnemo gumbi na desni strani pogovornega okna.

Opomba

Samo Tuji ključnih odnosih, ki obstajajo med tabelami, ki jih izberete se uvozi.

7. Uporaba izbirni gumb Import Style izberite, ali želite uvoziti samo Mize in odnosov med njimi ali tabel, njihovih vrstah in posebnih odnosih med vrsticami.

Opomba

Prva možnost uvozi tabel kot sestavni del tipa "tabeli" in odnosih med katerima koli dvema tabelah (iz tujih tipk) so uvoženi kot povezave tipa "Tabela relacije". To je klasična "ERD" slog pogled sistemskih tabel. Druga možnost uvozi vrstic tabele kot diskretnih podskupinah tipa "Tabela Row" z lastnostmi, ki ustrezajo za vsakega od stolpcev / področjih in z odnosi med vrstice tabele tipa "Tabela relacije". Poleg tega, če je stolpec / polje imenovano "Ime", potem se to uporablja za poimenovanje posameznih vrstic sub-komponent.

8. Izberite ... gumb Uvozi.

9. Po kratkem času (z barom napredku za povratne informacije), bo nov projekt ABACUS biti ustvarjena z tabel, tabela Vrstice (če je bila druga možnost izbrana v koraku zgoraj) in odnosi iz baze podatkov Microsoft SQL Server.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Poselitev svojo arhitekturo iz Visio | Poselitev svojo arhitekturo iz Excela


Poselitev svojo arhitekturo iz programa Microsoft Visio

Navigacija: Poselitev svojo arhitekturo> Populating iz Microsoftovih izdelkov>

Poselitev svojo arhitekturo iz programa Microsoft Visio

Pošlji komentarje o tej temi.

Lahko uvozite arhitekturo iz programa Microsoft Visio. Oblike v vašem Visio risbi bodo uvoženi kot sestavine v ABACUS. Povezave v vašem Visio risbi bodo uvoženi kot povezave in risba sama bodo uvožena v ABACUS kot diagram. Poleg tega bodo vsi Lastnosti po meri v vašem Visio risbi se uvozi kot lastnosti z Sort Key preslikan na Vrsta nepremičnine, Label na ime lastnino in vrednostno lastnino.

Opomba

Uvozi iz Visio funkcijo zahteva, da Microsoft Visio 2003ali novejši je nameščen na računalniku.

Če želite uvoziti Visio risbe v ABACUS

1. Zagotovite, da imate ABACUS odprto.

2. Izberite Datoteka | Novo in izberite Od Visiov pogovornem oknu, ki se prikaže, in kliknite V redu.

Opomba

Če želite uvoziti v obstoječi projekt ABACUS potem desno tipko miške kliknite Komponente vozlišče znotraj arhitekturo, ali desno tipko miške kliknite posamezno komponento znotraj arhitekturo in izberite Import | Od Visio.

3. Brskanje za datoteke Visio, ki jo želite uvoziti.

Opomba

Spodaj je nekaj preprostih pravil ali priporočene prakse pri gradnji (ali spreminjanje) MS Visio risba za uvoz v ABACUS.

1. Morajo biti dejanski priključke, oblikuje linije ali povezave.

· V nasprotnem primeru bo ABACUS samo jih uvozite kot sestavnih delov in zato ne bodo "pritrjena" na karkoli.

· Če boste morali narediti nekaj "pametnih" usmerjanje (tj razen ravne črte), nato pa uporabite Dynamic priključek na osnovnih oblik šablone, bodo ABACUS uvoz usmerjevalno / sidro točk redu.

· Poskusite se izogniti z uporabo "Ring omrežja" in "Ethernet" oblik iz omrežja in periferija matrice, ki omogoča veliko sestavnih delov, ki jih je treba "povezani" z njo. Medtem ko uvažamo priponke v redu, priključkov je prvotna oblika še vedno "razširjena" odražati priloge. Uporabite ločiti ločen "hub / bus" obliko (brez priključka "noge") in nato izrecno povezati vsako komponento pesta / avtobus z ločenimi priključki.

· Če vrstica ali povezava obnaša kot oblike, desno kliknite nanj in pojdite na "Format | Vedenje ... "in se prepričajte, da stil Interaction nastavljen na Line (1-dimenzionalni).

2. Sestavni deli morajo biti oblike NE konektorji.

· V nasprotnem primeru bo ABACUS samo jih uvozite kot povezave in zato se bodo vsi podatki, oblika izgubila.

· Če sestavni del obnaša kot konektorja, desno kliknite nanj in pojdite na "Format | Obnašanje ... "in se prepričajte, da stil Interaction nastavljen na polju (2-dimenzionalni).

3. Potrebujete konci Connector je treba priložiti k oblik, ne plava okoli v ozadju izza oblike.

· Če ne želite priključiti priključke v oblikah, potem ABACUS nima možnosti vedoč, da ste namenjeni za pritrditev dano priključek na obliko / komponente in zato bo pustil, da je konec priključnega-un priloženo.

4. Nalepke za oblikah mora biti (kjer je mogoče) vgrajen nalepka besedilo za obliko, ni ločen polje z besedilom na risbi.

· Škatle ločene besedilne bo dobil uvozil ABACUS kot sestavine v lastnem imenu, in medtem ko lahko združite z "oznako" komponento z realno komponento v ABACUS, ali pa samo spremeniti "oznako" komponento za prostoročno oblike (tj ni komponenta) je najbolje, da bi se izognili tem korakom.

5. Uporabite isto osnovno obliko za vsak primerek iste vrste, ne bodi len in uporabo pravokotnik in včasih box drugim iz različnih oblike šablone.

· ABACUS uporablja osnovno obliko in svojo osnovno barvo za identifikacijo vrst sestavnih in povezovalnih v risbi tako da "rdeči pravokotnik" in "rdeče polje" bo dobil uvoženega kot dve ločeni vrsti komponent. Te vrste sestavni lahko združila v ABACUS, vendar je najbolje, da bi se izognili tem korakom.

6. V celoti zaobjeti "otroci" oblike, v okviru svojih "staršev", NE pustite jim visi čez rob.

· ABACUS bodo odkriti vsako obliko, ki je v celoti nanešeno v druge oblike kot otroka od staršev, zato poskrbite, da celotno obliko, vključno z delom nalepka, je zaprt.

7. NE postavite obliko prekrivanje drugih dveh oblik.

· Če oblika prekriva dveh drugih oblik, bo to "združevanje" / ozadja pravokotnik ali kako drugače, bo uvozil ABACUS kot sestavino, ki je otrok niti prekrivajočih se oblik, ampak takoj, ko izberete komponento v Abacus 'orodje za risanje zaradi top-left čemer so sestavni deli referenčne točke, bo postal otrok levi prekrivali obliko / komponento.

8. Poskusi, da se zmanjša uporaba besedilnih opomb na risbi, saj bodo ti dobili uvožena kot sestavine v lastnem imenu in bo treba pretvoriti v poljubne oblike oblik v ABACUS. Razmislite o tem, ali so res ime obstoječe komponente ali povezave.

9. Medtem ABACUS podpira bogata / obarvani / temeljijo na vektorskih oblik, poskusite zmanjšati uporabo bitnih slik, tujih oblik in Okrepljeno metadatotek za oblikah, kot ABACUS trenutno počnenepodpira te vrste. Bodo uvožena kot preproste bele pravokotnike.

10. Poskusite se izogniti carriage return (shift-povratek) v etiketah so uvoženi in prikazane kot posebni znak "[]" v ABACUS za komponento ime.

11. Poskušali zmanjšati različne barve, ki se uporabljajo za oblik istega tipa. Kot je navedeno zgoraj, Osnovna barva in osnovna oblika enolično identificira vrste sestavnih in povezovalnih tako bolj variacija je bolj združuje, in konsolidacija, da bo treba narediti po uvozu v ABACUS.

12. Bodite previdni z izpolnjenimi oblik, ker če je oblika napolnil vso pot do vogalih nato barvanje kasneje ABACUS bo imela nobenega učinka.

13. Pri kompleksnih oblik, ki temeljijo na resornih morate uporabiti poligon, ki ga je ustvaril ob vrstic se začne, kjer se prejšnja konča, nato pa končno vrača na začetno točko. Če želite, lahko uporabite za polnjenje in postavo širino, da bi poligon videti kot "puščico" ali karkoli oblika hočeš.

14. Poskrbite, da je ID oblike v MS Visio je pomemben ne samo Shape.xx. To je mogoče urejati s pomočjo desno tipko miške kliknite "Pokaži ShapeSheet", ki je na voljo v MS Visio načinu za razvijalce (omogočena preko Orodja | Možnosti v MS Visio).

15. Elipse in lokiv oblikahso podprte v ABACUS vendar NURBS in utori trenutno niso podprti.

16. Prepričajte se, da je celotna oblika je združena v MS Visio, ali pa bo dobil uvozi kot več komponent / tipov.

17. Poskusi, da se zmanjša uporaba zavrti oblik znotraj subshapes saj bo včasih ne bodo pravilno uvoženi.

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Poselitev svojo arhitekturo ročno | Poselitev svojo arhitekturo iz Access | Poselitev svojo arhitekturo iz Excela


Poselitev svojo arhitekturo ročno

Navigacija: Poselitev svojo arhitekturo> Populating ročno>

Poselitev svojo arhitekturo ročno

Pošlji komentarje o tej temi.

Komponente na višji ravni in povezave vašega arhitekture bodo verjetno morali biti naseljena ročno. Običajno bo to bolj abstraktne komponente in povezave.

Za ročno zapolnijo svojo arhitekturo

1. Zagotovite imate ABACUS datotekaodprt, An explorerprikazano, in Arhitektura dodal .

2. Dodaj komponento. Če želite to narediti, Desni klikna območju drevesa želite zapolnijo, in izberite Dodaj podskupini ...Ali pa kliknite New Componentgumb na Ogled orodne vrstice . Komponente se lahko dodajo le pod Components vejo drevesa. Želite, da vaše drevo diagram biti natančen prikaz vaše arhitekture. Ko boste odkrili svojo arhitekturo, boste naučili točno kako se je vse skupaj zmontirano. Boste morali to znanje, ko dodate sestavine in povezave. Če ste dodajanjem tvoje prvo komponento, jo boste dodali neposredno Components vejo. Preostali del vaših komponent lahko bodisi na isti ravni v drevesu, ali so lahko sub-komponente prvi.

3. Posodobite vrednotelastnostivsake komponente, kot ste ga dodali. Če želite to narediti, klikna komponento, in urediti lastnosti prikazane v Lastnosti okno(tipično) v desno. Lastnosti so običajno stvari, kot so zahteve, predelovalne zmogljivosti, itd Ko ABACUS ovrednoti svojo arhitekturo, bo izračunati nekaj novih lastnosti, in jih shranite nazaj v arhitekturi. Nove lastnosti so podatki, ki ga poskušate analizirati, kot izkoriščanje, odzivni čas, pasovno širino, itd

4. Dodate povezavein Posodobitevnjihove lastnostikot greš - tako kot ste storili za sestavne dele (vendar pod vejo Connections drevesa).

5. Priložitepovezave in komponente. Če želite to narediti, poiščite povezavo, kliknite na eno od njenih konca ali Vloge In ga povlecite na komponento. Druga možnost je, kliknite na element in ga povlecite na eno izmed povezava je Vloge (tj bodisi vir ali ponor). Ali lahko z desno tipko miške kliknite in povlecite komponento na drugo komponento in izberite Povežite se. Ali pa preprosto desno tipko miške kliknite element in izberite Priključite .... Ko povlečete povezavo Vloga, Boste opazili simbol za bližnjico, ko opozarjajo na komponento, ki jo lahko pripisujejo. To pomeni, da si ne bi kopijo, ti si samo, da jo pripnete. Prepričajte se, da jo pritrdite na pravilno komponento destinacijo. Na primer, če je Vir vzpostavljena povezava z VlogaPovlecite naredi izvorno komponento (tj sestavino, ki je vir pretoka podatkov).

Nasvet

Re-naročanje subjektov znotraj vašega arhitekture (npr komponente, povezave itd) v explorerje dokaj enostavno. Preprosto Kliknite| Držite| Dragzadevni subjekt in kraj, kjer je zaželena v arhitekturi. Funkcionalnost ponovno naročanje tudi vam omogoča, da se subjekti v različnih hierarhij vaše arhitekture.

Morda boste prav tako želeli

6. Dodaj standarde (prednastavljene sklopov nepremičnin - Prednastavitev) do vaše komponente, povezave ali vrste

7. Spremenite lastnosti komponente a, povezave ali vrsto

8. Razveljavi in ​​Uveljavi Operacije

9. Spremenite Type sestavnega dela ali povezavo

10. Ustvari novo vrsto ali skupina vrst

11. Izbriši sestavni del ali povezava

12. Ustvarjanje, dvojnik ali razvijajo arhitektura

13. Tipi in standardi uvozne iz knjižnice

14. Uvoz iz druge datoteke ABACUS, XML, Excel ali Visio

15. Kopiranje in lepljenje deli (ali vse) vašega arhitekture

16. Najdi in zamenjaj postavke v vaši arhitekturi

17. Razširi / Strni nekatere ali vse vozlišč v drevesu

18. Merge predmeti

19. Določite in Potrdi Omejitve omejiti strukturo vaše arhitekture

20. Razvijajo svojo arhitekturo ustvariti več arhitekturne rešitve za primerjavo in izhodišča

Poglej tudi

Poselitev svojo arhitekturo - Pregled | Ustvarjanje nove datoteke


Objavi na spletu

Navigacija: Poročanje o vaši arhitekturi>

Objavi na spletu

Pošlji komentarje o tej temi.

ABACUS "Objavi spletna funkcija omogoča arhitekturni modeli se gledati preko varne spletne strani. Arhitekture se izvažajo v obliki HTML in so namenjeni odražajo videz in občutek Explorer v ABACUS. Pogledov (tudi kataloge, diagrami, 3D in grafi) izvažajo tudi v formatih knjige, dostopen z uporabo spletnega brskalnika.

Opomba

Trenutno so Stališča in matrike niso objavljeni.

Če želite objaviti svoje arhitekturne modele na spletu

1. Zagotovite, da imate ustrezna ABACUS datotekaodprt, ki vsebuje naseljeno arhitekturoki jih želite objaviti na spletu.

2. Izberite mapa| Objavite ....

3. Objavi na spletni ConfigurationOdprlo se bo prikazal.

Objavi na spletni konfiguracijo

4. Privzeto so izbrani vsi deli modela, vključno z Tree mnenju Standardi, Vrste, Predloge in Architecture (ov). Počistite koli dele ne želite objaviti na spletu, vključno z vsemi posameznimi mnenj v arhitekturi (ov).

Nasvet

Če želite skriti specifične komponente, povezave in / ali njihove lastnosti, je priporočljivo, da skrbnik ustvari vlogo "javnega" uporabo Funkcija, ki temelji vloga Abacus 'dostop in nato odstrani Preberi dovoljenje tiste vrste komponent, vrste povezav in / ali lastnosti, ki jih ne želijo objaviti. Potem mora uporabnik prijaviti v skladu s to vlogo in objavijo na spletu kot ABACUS bo le objaviti elemente, ki so Dovoljenje za branje določene za to vlogo. Poleg tega lahko uporabniki samodejno objavi v ukazni vrstici, kot je opisano tukaj .

Opomba

Izberete lahko vse dele s klikom na prikazane Vsigumb ali invertni vašo izbiro s klikom na Obrnigumb. Kliknete lahko tudi na Nobengumb, da počistite izbiro.

Opomba

Če ti počistite Tree View možnostpotem bo objavljena drevo okvir (glej spodaj). V skladu s tem morate izbrati začetno stran po koraku 6 spodaj, ali po objavi boste morali prilagoditi bodisi na najvišji ravni; a) index.htmlDatoteka s spreminjanjem "okvirja src =" mainPage.html "name =" element_details '"postavo neposredno povezati z ustreznim html strani v mapo z vsebinami, ali b) mainPage.htmlz zagotavljanjem hiperpovezave ali preusmeriti na ustrezno html strani v mapo z vsebinami.

5. Kliknite Možnost gumb in naslednje Možnosti Založnikpogovorno okno se bo prikazal.

ObjaviteMožnosti er

6. Sizvoli 3D, Diagramin Charts formati in ali pokazati naslov, opis ali Properties za poglede od možnosti, ki so na voljo (glejte opombi spodaj za pripombe o različnih oblikah).

7. Če želite nastaviti začetno stran objavljenega modela s posebnim namenom, potem preverite Uporabite Prikaži kot začetna stranmožnost in poiščite pogled preko "..." gumb, da postane omogočen.

Opomba

Zgoraj le izbrani v oddelku področjih, kot so na 4. koraku pogledi so na voljo, da je treba določiti kot začetno stran.

8. Če želite prejeti povratne informacije o določenih strani v objavljenem modelu, potem se prepričajte, da Email Povratne informacijeje izbrana možnost, vnesite e-poštni naslov v Email naslovtextboxin uredite Email Bodyoddelek kot je primerno. Če ne želite, da so povratne informacije pošlje nato Počistite Email Povratne informacijemožnost in pustite učbenik prazna.

9. Kliknite na v redugumb.

10. Kliknite na Brskanjegumb.

11. Brskanje za mapeOdprlo se bo prikazal.

12. Izberite mesto, kamor želite shraniti datoteko HTML z vrhunsko (in katerekoli samodejno generirane datoteke).

Opomba

To je dobra ideja, da ustvari posebno mapo (običajno imenovane "objavljena") z uporabo Ustvari novo mapogumb na dnu pogovornega okna za shranjevanje HTML datoteko na najvišji ravni in katerekoli samodejno generirane datoteke.

13. Kliknite na v redugumb.

14. Mapa Pot bo prikazal v Imeniktextbox.

15. Kliknite na Finishgumb.

- Ali -

15. Vnesite pot do mape, v Imeniktextbox, kamor želite shraniti datoteko HTML z vrhunsko (in katerekoli samodejno generirane datoteke).

16. Kliknite na Finishgumb.

Opomba

Izvoz Diagramizelo redko uspe, najbolj pogosto, ko je računalnik iz spomina (običajno pri uporabi zelo velikih datotek). Neopravljenega izvoza bo retried enkrat. Tam bo eno opozorilo za neuspešnem začetnem poskusu, in drugo opozorilo, če ponovno poskus ne uspe. Torej, če so samo opozorila "začetni poskus ni uspel" tisti je objavila bila uspešna. Če ponovni poskus ne uspe poskusite objavo manjši del vaše datoteke ali prosto do nekaj sistemskega pomnilnika.

Shranjeni HTML datoteka (e) se zdaj lahko pogled od njegove lokacije ali kopirate na varno spletno stran.

Objavi na spletu v Internet Explorerju10

Vsako hiperpovezave ki so bile ustvarjene v originalnem modelu, bodo vztrajali pri objavljenem modela in s klikom na povezavo bo sledite povezavi do njenega cilja (če je bila objavljena). Poleg tega bodo vsi elementi v objavljenih slikah, ki niso že hiperpovezavami v prvotnem modelu, ki ga s hiperpovezavami nazaj na njihovih ustreznih elementov v drevesnem pogledu (če je bila objavljena) in s klikom na element v objavljenem diagramu poudarek bo skočil nazaj ustrezna lokacija v drevo. Ta funkcija je podobna "Show v Raziskovalcu" desni klik funkcijo v ABACUS.

Opomba

Avolution močno priporoča naslednje programsko opremo in datotečne formate je treba uporabiti, da v celoti izkoristijo Objavi na spletno funkcionalnosti v ABACUS:

1. Internet Explorer (80,0 in več)Za ogled objavljeno pogled explorer. Mozilla Firefox (30,0 ali kasneje)Priporočljivo je tudi, in v celoti podpiraVendar, če uporabljate priporočeni format SVG za diagramov nato v Firefox 9 lahko uporabljate samo materni SVG gledalec podporo, ki žal ne omogoča povečave ali izpiranje.

2. Adobe SVG Viewer 3.0 vključiti (prenos iz tukaj ) in SVGoblika datoteke za objavljeno diagrami. Format SVG slike za diagramiPriporočljivo je, ker; SVG je format slike, ki temelji na vektorski in zato je "izguba manj" in izgleda precej bolje, na kateri koli ravni povečave kot kateri koli od drugih formatih, se SVG mogoče uvoziti v MS Visio, se SVG mogoče povečati na nobeni ravni ali resolucije , SVG ima povezave nazaj v drevesnem pogledu za priključke (ne le sestavni deli), SVG vedno natisne na boljši resoluciji in SVG je približno polovica velikost datoteke drugih formatov. PNG je naslednja priporočila, vendar, kot je rasterised format na določenih povečavah jasnost pogleda bodo izgubili in s klikom povezave na slikah ne bo skočil nazaj na ustrezno mesto v drevesu. BMP je poguma, kot pa se je "izguba manj" formatirati velikost datoteke je 100x da drugih formatov in 20Mb slik niso nič nenavadnega.

Kompromis s SVG, je, da bodo potrebovali SVG gledalec, ki se namesti in morate poskrbite, da se doda .svg image / svg + xml Spletni strežnik je MIME vrste. Po namestitvi gledalca SVG bo Microsoft Internet Explorer vas prosim, da sprejmete licenčno pogodbo gledalčevo in potem bi to delovalo v redu. In medtem ko jeMozilla Firefox podpira SVG datotek natively, Adobe plugin je vedno priporočljivoda lahko povečate diagrame, če uporabljate Firefox 8 ali prej (če uporabljate Firefox 9 ne morete onemogočiti materni SVG gledalec). Ko je naprava za Adobe plugin teči naslednji koraki so potrebni ga uporabljate v Firefox:

· Odpreti Firefox in vpišite "about: config" (brez narekovajev) v URL vrstico.

· Pomaknite se navzdol in poiščite lastnost svg.enabled(če uporabljate Firefox 9 nato native SVG gledanja ne more biti invalidi in ta lastnost ne obstaja). Dvakrat kliknite na to, da ga onemogočite.

· Sedaj najdete imenik, kjer je nameščen SVG plugin (npr C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Kopirajte datoteke NPSVG3.dll in NPSVG3zip in jih prilepite v firefox plugins imenik (na primer C: \ Program Files \ Mozilla Firefox \ plugins)

· Zapreti vse primerke firefox

3. Avolution je ABACUS 3D Viewer (3.1 in zgoraj)in Avolution je .abacus3Ddatotečni format za objavljenih mnenj 3D. Medtem ko Cortona VRML Client plug-in (2.0 in zgoraj)je na voljo za ogled VRML različice objavljenih mnenj, da ni brezplačna za komercialno uporabo in še vedno zahteva namestitev na strani odjemalca. Abacus 3D Viewer je več funkcijami bogato kot kateri koli VRML pregledovalnik in je brezplačno na voljo za prenos iz tukaj . V vsakem primeru poskrbite, da boste dodaj .vrml x-svet / x-VRML in .abacus3d application / octet-stream na spletni strežnik je MIME tipov.

4. PNGdatotečni format za objavljenih mnenj Chart. Priporočljivo je format PNG sliko za stališča Chart, ker pa se je rasterised format in je "izguba" kompromis med velikostjo datoteke in jasnosti kart je ponavadi najboljše. BMP je poguma, kot pa se je "izguba manj" formatirati velikost datoteke je 20x, da se od drugih formatov in 2MB kartah ni nič nenavadnega.

Če želite spremeniti videz in občutek na spletnih straneh, lahko uredite datoteko začetna stran z imenom mainPage.html in datoteke slog stanja imenom abacus.css. Boste našli te datoteke v isti mapi, kjer ste se odločili, da shranite datoteko HTML na najvišji ravni. Za več informacij o strukturi in krojenje objavljenih izhoda glejte naslednje poglavje.

Struktura ABACUS objavljeni modeli

Abacus objavljeni model je strukturiran na naslednji način:

1. Mapa na najvišji ravni vsebuje več datotek in ob predpostavki, vse možnosti so vključene v ABACUS Objavi na spletno konfiguracijo pogovorno To bo vključevalo indeks.htmldatoteka sestavljena iz treh okvirov; treeView.html, findNode.html in mainPage.html in potem shortcutError.htmlStran. TreeView.html je poseljena z tree.js, tree_items.jsin tree_tpl.js javascript datoteke, ki se nahajajo pod vključuje mape (obravnavano spodaj) in posnema Explorer drevo iz ABACUS. FindNode.html poganja find.js javascript datoteka nahaja pod vključuje mapo (obravnavano spodaj) in bo poiskal veje drevesa in ne samo vidni vozlišč. Ton mainPage.html je statično HTML stran, ki se lahko meri z korporativne logotipe in podobnoin se bodo pokazale, če je stran start izbrali pri objavi.In končno, stran shortcutError.html je ciljna stran za morebitnih poškodovanih bližnjice iz drevesa zaradi ustreznih straneh ne bodo objavljeni.

Nasvet

Lahko preskočite mainPage.html skupaj s odločijo za uporabo začetno stran pri objavi ali spreminjanje datoteko index.html, da bo usmerjena na določen pogled (recimo) z urejanjem okvirja src = "mainPage.html" postavo, da bo usmerjena na prvi pogled v prvi arhitekturi, običajno "okvirni" diagram.

2. I top-ravnincludeMapa vsebujeingrazličnih javascript (js) in kaskadni slog stanja (.css) datoteke, ki jih .html datoteke, ki se uporabljajo po vsej objavljenem modelu.

3. Mapa Vsebina vrhunski vsebuje, Po abecedi;

· A '3D Ogledov' mapa zoštevilčeneHTML strani in VRML ali abacus3d datoteke za vsako od objavljenih 3D pogledi. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· Arhitekture mapo z oštevilčeno HTML stran za vsak arhitekture, ki je bila objavljena. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· A Katalogi mapa z oštevilčen HTML strani za vsako od objavljenih katalogov. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· A Charts mapa zoštevilčeneHTML strani in PNG, JPG etc datoteke za vsako od objavljenih mnenj Chart. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· A Komponente mapa, ki vsebuje AoštevilčeneHTML stran za vsako od objavljenih komponent. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· A Povezave mapa, ki vsebuje AoštevilčeneHTML stran za vsako od objavljenih povezav. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· A Diagrami mapa, ki vsebuje AoštevilčeneHTML strani in PNG, SVG etc datoteka za vsako objavljeno diagrami. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· Ikone sub-Mapa s Različne slike, ki se uporabljajo v celotnem objavljenem modelu.

· A Standardi sub-mapa zoštevilčeneHTML stran, za katero koli Standardiki so bili objavljeni. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

· A Predloge sub-folder z zbirko oštevilčenih podmap za vsako predlogo, objavljenem iz projekta. Znotraj vsake podmapo je Komponente in mapa Connections in v teh je oštevilčena HTML stran za vsako komponento in priključitev predlogo. Glej opombo spodaj za informacije o sistemu oštevilčenja mape / datoteke.

· A Vrste sub-mapa s komponento inPovezava podmape, katerihoštevilčeneHTML stran za vsako komponento inVrste povezav, ki so bile objavljenein zbiranje oštevilčenih podmap za vsako vrsto objavljena projekta vsebuje HTML stran za vsako od omejitev. Glej opombo spodaj za informacije o sistemu oštevilčenja mape / datoteke.

· A Poglejtočkas podmap inoštevilčeneHTML stran za katerega koli od Viewtočkaov, ki so bili objavljeni. Glej opombo spodaj za informacije o shemi datoteka oštevilčenja.

Opomba

Številčenje strani HTML (in v nekaterih primerih slikovne datoteke) se ujema z Edinstvena ID Za vsako skladišče objekt, ki je bil Nastavitev časa bilo je ustvarilv ABACUS (v nadaljnjem besedilu EEIDs). Ta ID se nikoli ne spremenijo kot diagrami, vrste, deli etc sta posodobljene se bokot prej obdržita isti ID. V vsakem primeru je pomembno Skladišče objektIme je mogoče najti v bližini začetek strani HTML med ... HTML.

Omejitev dostopa do nekaterih strani / Ogledov z IIS

Če uporabljate IIS kot vaš spletni strežnik za objavljenem modela, boste morda lahko, da omejite dostop do določenih strani / mnenj, ki uporabljajo metodo spodaj:

1. Ustvarite spletno stran v IIS (še enega, če že obstaja ena ne želite, da se motijo).

2. Spremenite Properties-> Imenik varnostjo,> anonimni dostop - počistite anonimni dostop in uporabo overjen dostop.

3. Če je to samo običajna strežnik brez domenskih zapletov itd, potem morate uporabiti opcijo "integrirana okna za preverjanje pristnosti", ki bi nato s pomočjo strežnika stroji lokalne uporabniki / prijavljeni kot preverjanje pristnosti, in samo dodati uporabnike v lokalnem računalniku (pri čemer pazite, da ste seznanjeni s posledicami, varnost pametno, dodajanja novih uporabnikov na napravo, na primer glede na to, ali je oddaljeni dostop setup za stroj, itd.)

4. Dodaj dovoljenja za posebne datoteke / mape, kot je potrebno. Desni klik na posamezne datoteke / mape -> Properties, in prilagodite varnostnih dovoljenj kot običajno za datoteke / mape.

To se lahko razlikujejo glede na to, katero različico IIS in kakšni specifični Windows OS je na strežniku, in ali imate domeno ali drugo drugačno nastavitev.

Poglej tudi

Poselitev svojo arhitekturo | Analiziranje svojo arhitekturo


Registriranje ABACUS

Navigacija: Reference>

Registriranje ABACUS

Pošlji komentarje o tej temi.

Ko prvič začnete ABACUS (ali po začasnem dovoljenju je potekla) boste morali registrirati zahtevek zoper licenčni strežnik Avolution je s pomočjo edinstveno licenčni ključ, ki jih vaš lokalni ABACUS Administrator ali neposredno od Avolution. Če nimate licenčnega ključa se obrnite na vašega lokalnega ABACUS Administrator ali Avolution Podpora .

Za registracijo z licenčnega ključa

1. Po namestitvi, začetek ABACUSbodisi z dvojnim klikom na bližnjico na namizju ali v meniju Start operacijskega sistema Windows.

2. V pogovornem oknu za registracijo, ki se odpre, vnesite Ključ 26 znakov licencače vaš lokalni ABACUS skrbnik ali Avolution podpora Ali pa kliknite Browse ...in izberite podpisala .dlsc datoteke vrnil iz Avolution Podpora kot na opombo na koraku 4 spodaj. Če uporabljate pravilno podpisano .dlsc datoteko ABACUS treba začeti kot na korak 5 spodaj.

Nasvet

Lahko prilepite licenčnega ključa v pogovornem oknu, da ga kopirate v odložišče Windows in nato izberete ozadje pogovornega okna in pritiskom na Ctrl + V.

Pogovorno registracija

3. Kliknite v reduin če je licenčni ključ je veljaven ključ ABACUS licencaABACUS bo zdaj poskušal kontaktirati licenčni strežnik Avolution za overjanje licenčnega ključa.

Opomba

Če se pojavi Namestitev koda je neveljavnaNapaka registracija je najbolj verjetno, da ste vnesli napačno kodo. Poskusite kopirate in prilepite kodo kot na Nasvet zgoraj omenjeno.

Kontaktiranje licence Server Avolution

4. Kliknite v reduin po kratkem času naj bi ABACUS uspešno registracijo.

Uspešna registracija

Opomba

Če dobiš Ne morem se obrnite na licenčni strežnikNapaka registracija je najbolj verjetno, da je požarni zid (ali drugi varnostni ukrepi) na vašem omrežju preprečujejo dostop do strežniške licence Avolution je. Kliknite v reduShranite .dlsc datoteko na vašem lokalnem računalniku in potem bodisi pošlji .dlsc datoteko Avolution Podpora in čakajo na nadaljnja navodilaali pa poskusite, da se prijavite licenca vložiti sami po naslednji URL - http://licensing.avolutionsoftware.com/LicenceSign/ .

Ne morem povezati z licenčnim strežnikom

Odprite podpisovanje License spletno stran

Ročno License podpisovanje spletne strani

Druga možnost je, če dobiš Ta namestitev koda je bila uporabljena na več sistemih kot z licenco dovoljeneNapaka registracija je verjetno, da je bil vaš lokalni stroj obnovili, odkar ste nazadnje registriran ABACUS ali pa se trudijo, da se registrirate na ključ drugega uporabnika licence. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora .

Namestitev koda je že bila uporabljena

5. Kliknite v reduin če je registriran uspešno ABACUS mora odpreti z Pozdravni zaslon .

Poglej tudi

Avolution Podpora | Kaj ABACUS storiti?


Standardna Element Izbor

Navigacija: Analiza svojo arhitekturo>

Standardna Element Izbor

Pošlji komentarje o tej temi.

Pri ustvarjanju diagram, 3D pogledPoročilo,standardni grafikonali tek simulacijeJe standard izbirni element okno se uporablja za izbiro elementov, ki jih želite analizirati / pogled.

Standardna Element Izbira Window

Pulldowns

· Filter s pogledombo vključujejo elementje iz predhodno shranjeno pogledu (tj diagram, graf, 3D). Na ta način lahko izvedete kompleks "pridružijo" vprašanja, ki jih obravnava drug pogled kot shranjeno "poizvedbo".

Potrditvena polja

· Prikaži RavniSkupina bo element glede na raven, s katero se pojavljajo v drevesu. Stopnja 1 je na vrhu najbolj raven.

· Prikaži VrsteSkupina bo elementi v skladu z vrstami, ki so.

· Starši izbranabo vključeval matičnih elemente vseh izbranih elementov. Na ta način lahko zagotovite, da bodo vključene samo hierarhija nad vsemi otroki za "od spodaj navzgor" izbor.

· Otroci izbranaVključeval bo otrokom elemente vseh izbranih elementov. Na ta način lahko zagotovite, da bodo vključene samo hierarhija pod katerokoli staršev za "top-down" izbor.

· Ime Tekme vrednostbo vključeval le tiste elemente, ki imajo ime, ki vsebuje določen niz (Prosimo, upoštevajte: Wildcards (tj in *) se lahko uporablja?). Na ta način lahko tvorijo "pomensko" poizvedbo.

· Ima Vrsta nepremičnine / ime / vrednostbo vključeval le tiste elemente, ki imajo nepremičnino obliko, ime in vrednosti, ki vsebujejo določen niz bodisi neposredno na elementu ali o svojih standardih (Prosimo, upoštevajte:?.? Wildcards (tj in *) se lahko uporablja Npr * v polje Value bo dati vse elemente, ki imajo ne-prazno vrednost za dano lastnine). Na ta način lahko tvorijo "pomensko" poizvedbo.

· Ima standardbo vključeval le tiste elemente, ki imajo standardno ime vsebuje določen niz (Prosimo, upoštevajte: Wildcards (tj in *) se lahko uporablja Npr HP * bo dal vse elemente z vsaj enim standard se začne s črko H in P?.). Na ta način lahko tvorijo "pomensko" poizvedbo.

· Komponente / Povezave vezana na izbranobo vključila priključene elemente, za tiste, ki so bili izbrani. Na ta način se lahko izbere "poziv drevo" ali "učinek-analiza".

Opomba

Če imate oboje Prikaži Ravniin Prikaži VrsteIzbran potem lahko izberete, da se raven drevo kažejo prvi ali vrsta najprej gumb, ki se bo pojavil nad dvema kvadrat.

Nasvet

Ko je postavka izbran v oknu Standardni Element izbor, da ne bo predmet nadaljnjih sprememb filtrov, dokler ni izbrana. Ker ni izvirni način za iskanje dveh različnih sklopov elementov naenkrat (npr Sestavine z standarda ali standarda B), lahko poiščete najprej za en sklop, izberite željene komponente in izvedite drugo iskanje za drugi sklop .

Gumbi

· Vsiizbere vse elemente.

· Obrniprekliče izbiro vseh trenutno izbranih elementov in izbere vse tiste, ki niso bili izbrani.

· Nobenprekliče izbiro vse elemente.

· Dodaj filterizbere dobljeno vsebino trenutnih nastavitev filtra in omogoča izbiro dodatnih vsebin, kot učinkovito AN in ali se pridružijo filter.

Poglej tudi

Analiziranje svojo arhitekturo


Orodje za risanje

Navigacija: Poselitev svojo arhitekturo> Uporaba Risbe>

Orodje za risanje

Pošlji komentarje o tej temi.

Orodje za risanje omogoča ustvarjanje različnih arhitekturnih sheme in diagrami. Arhitekti tradicionalno uporabljajo vrsto različnih risb za snemanje in posredovati zasnovo arhitekture. Dvodimenzionalni (2D) diagrami so običajen način dokumentiranja in komuniciranja različne dele sistema. Tipične vrste risbe, ki se uporabljajo v poslovnih sistemih so:

· Poslovni procesni modeli in diagrami;

· Organizacijske sheme;

· Diagrami sodelovanja;

· Entiteta-Razmerje (ER) diagrami;

· Data-Flow diagrami (DFD je);

· Razred diagrami;

· IDEF (ki vključuje več zgoraj); in

· UML (ki vključuje več zgoraj).

Res je, ni omejen na vrste diagramov, ki jih je mogoče ustvariti. ABACUS poskuša uravnotežiti fleksibilnost diagram pa ohranjajo celovitost arhitekture in njenih oblik reprezentacije.

Risba okolje je zavihki in sidrati okno znotraj glavnega ABACUS uporabe. To okno vsebuje platno, kjer se risba poteka in če je okno risanje odprt sekundo sidrati okno Okenski matrico, je viden z nizom črpanja šablon. Podokno šablona ima 4 zavihke: sestavni deli, priključki, oblike in konektorje. Platno se pojavi kot beli podlagi s finimi črtami mreže (koristne za postavitev).

Komponente predstavljajo vrsto oblik, pri čemer so priključki sestavljeni v skladu z navodili linij. Povezave pripisujejo komponent uporabo Vloge (tj bodisi vir ali ponor) čeprav ti niso prikazani zaradi estetskih razlogov.

Nasvet

Medtem ko diagramiso zelo koristne za prikazovanje različne dele sistema, so omejeni v svojih razširljivosti, zato ABACUS uporablja 3D vizualizacijo kompleksnih sistemske strukture.

Morda boste želeli

1. Odprite Diagramov Orodje

2. Ustvariti nov diagram dela za vašo arhitekturo

3. Kopiranje diagram znotraj ali čez arhitektur

4. Dodaj komponent na diagramu

5. Ustvarjanje nove komponente in povezave v arhitekturi (shematsko) z orodjem za risanje

6. Izbriši komponente iz diagrama

7. Pritrdite & manipulirati povezave

8. Spreminjanje Zaslon lastnosti komponent in povezav.

9. Uporaba povezave v diagram

10. Uveljavite združenja tipa in Stališča da se omeji vrste diagramov, ki se jih lahko pridobi.

Poglej tudi

Poselitev svojo arhitekturo | Poselitev svojo arhitekturo ročno | Analiziranje Vaše arhitektura


Naslovna stran

ABACUS

Pogoji

Avolution Pty Ltd ne daje nobenih zagotovil ali jamstev v zvezi s tem priročniku, in v največjem možnem obsegu, ki ga dovoljuje zakonodaja, izrecno omejuje svojo odgovornost za kršitev katere koli garancije, ki se lahko implicitno z zamenjavo tega priročnika z drugo. Nadalje, Avolution Pty Ltd si pridržuje pravico do spremembe tega objavo kadarkoli brez kakršnih obveznost obvestiti kogarkoli za revizijo.

Avtorske pravice

Copyright 2001-2015Avolution Pty Ltd. Vse pravice pridržane.

Blagovne znamke

Avolution Pty Ltd je storila vse, da predloži podatke o blagovnih znamkah glede imena podjetij, izdelkov in storitev, navedenih v tem priročniku. Blagovne znamke, prikazane spodaj, so bili pridobljeni iz različnih virov.

Microsoft Windows, Access, Visio, Excel, SQL Server in Internet Explorerso blagovne znamke družbe Microsoft Corporation.

Splošno obvestilo:

Nekatera imena izdelkov, ki se uporabljajo v tem priročniku se uporabljajo le za namene identifikacije in so lahko blagovne znamke njihovih podjetij.

December 2015Edition za Avolution ABACUS različice 4.5.

Ročno Revizija 1.0

Ustvarjeni, tiskani in vezani v Avstraliji.


ABACUS Namestitev predpogoja

Navigacija: Reference>

ABACUS Namestitev predpogoja

Pošlji komentarje o tej temi.

Informacije v zvezi Visio Uvoz in Excel Uvoz / izvoz

ABACUS zahteva, da se Microsoft Office nameščen za opravljanje Excel uvoz / izvoz in Visio uvoznih poslov. Prosimo, preverite, ali Microsoft Office 2003 ali novejšije pravilno nameščen. Če naletite na dodatne težave, se obrnite na Avolution Podpora .

Za izvedbo Visio Uvoz in Excel Import / izvoznih poslov, ABACUS uporablja Microsoft Office Primary INTEROP skupščin (PIA). ABACUS trenutno prihaja pakirani s sklopi, ki so potrebni za opravljanje Excel uvoz / izvoz in Visio Uvozi.

Informacije o SQL Server Import

ABACUS zahteva, da Microsoft SQL Server 20052008, 2008 R2, 2012 ali 2014je nameščen, da bi začeli nov projekt iz SQL Server. Prosimo, preverite, ali Microsoft SQL Server 20052008, 2008 R2, 2012 ali 2014je pravilno nameščen. Če naletite na dodatne težave, se obrnite na Avolution Podpora .

Napake Odpiranje 3D vizualizacij

Če ABACUS 3D Viewer ne deluje za vas, se boste morda manjka SlimDX DirectX Runtime (nameščen kot del celotnega ABACUS EXE namestiti). To je mogoče prenesti tukaj . Če imate 64bit različico operacijskega sistema Windows, boste morda morali namestiti to .

Napake Urejanje ABACUS Po meri Poročila

Poročila Urejanje Abacus 'po meri zahteva Report Builder 3.0 je treba namestiti. ABACUS in Report Builder so zgrajena na Microsoft .NET Framework 4.0, in medtem ko sta oba ne zahteva Microsoft .NET Framework 3.5, Microsoft je nepravilno nastavljen Prijavi Builder MSI le nadaljuje, če se Microsoft .NET Framework 3.5 nameščen.

Zato, Avolution ima skupaj popravljeno različico Report Builder namestitveno MSI datoteke, ki ne zahteva Microsoft .NET Framework 3.5, se to lahko prenesli tukaj .

Prvotni Microsoft Report Builder MSI je mogoče prenesti tukaj . Če nimate že imate Microsoft .NET Framework 3.5, ki bo potreboval, ga lahko prenesete tukaj . Opomba: Za več naprav, brez povezave namestite Microsofta .NET Framework 3.5 od tukaj morda bolj primerno.


Razveljavi in ​​Uveljavi

Navigacija: Poselitev svojo arhitekturo> Populating ročno> Extra Možnosti>

Razveljavi in ​​Uveljavi

Pošlji komentarje o tej temi.

Kot mnogi sodobnih aplikacij, ABACUS podpira možnost, da tako razveljaviti in redo nedavne uporabniške spremembe na odprtem projektu. Da razveljavite zadnjo spremembo, preprosto aktivirate ukaz undo. Spremembe, ki so bile izničene lahko predelali z aktiviranjem ukaza redo; ponovno uporabo nazadnje razveljavljeno sprememb.

Opozorilo

Razveljaviti spremembe niso mogoče ponovno uporabiti, če so nadaljnje spremembe na projektu, ker se razveljaviti.

Opomba

Medtem ko je podpora je velika večina sprememb undo / redo v realnem času, nekateri diagram matrice spremembe, kot so ustvarjanje novega tipa Shape / Line združenje ali spreminjanje pridružitveni barvno atribut, ne morejo biti takoj razveljaviti. V teh primerih mora spremenjeni Diagram (označeno z zvezdico), se zaprejo, preden se te spremembe mogoče razveljaviti.

Undo in Redo poveljniških mest

Razveljavi in ​​redo ukazov lahko dostopate iz treh različnih lokacijah:

· meni Edit

· Standardna orodna vrstica

· Tipke za bližnjice tipkovnice CTRL + Z(undo) in CTRL + Y(redo)

Nasvet

Razveljavi in ​​redo gumbi na standardni orodni vrstici zagotavljajo spustnega seznama, ki prikazujejo 10 najnovejših sprememb, ki jih je mogoče razveljaviti in so predelali oz. So tudi priročen način, da razveljavite / redo več sprememb naenkrat.


Uporaba makrov

Navigacija: Simuliranje svojo arhitekturo>

Uporaba makrov

Pošlji komentarje o tej temi.

Če izvedete nalogo večkrat v ABACUS, lahko avtomatizira nalogo s pomočjo makra. V skladu s tem ABACUS makro je zabeležena serijo operacij, ki jih je mogoče predvajati eno kadarkoli.

Snemanje makra

1. Izberite Orodja | Record Macroali pa pritisnite Alt + F10.

2. Začnejo izvajati operacije, ki jih želite posneti.

Opozorilo

V tem času, obstajajo nekatere znane težave z makro snemanje. Prosimo, da jih upošteva pri snemanju svoje makre:

· Trenutno Makri pravkar posneti Microsoft Windows tipkanja, miške gibanja in kliki. Vendar pa je zaradi omejitev pri makro snemalnik sam, obstaja nekaj tipkanja, ki niso vedno posneti. Ti vključujejo:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] na [F12]

· Zato je priporočljivo, da se preveri, da je bližnjica tipkovnico zabeleži makro snemalnik pred snemanjem velik zaporedje dogodkov, ki so lahko odvisni od tega bližnjico delo.

· Trenutno zaradi omejitev z makro snemalnik, so priročni meniji ne ravnate pravilno, jo ABACUS, ko so odprli s tožbo, ki jo zabeleži makro snemalnik. Ko odprete kontekstni meni, morate izvesti eno od funkcij, navedenih v preko menija kontekstnega menija, sicer priročni meni lahko odprta med predvajanjem, kar lahko privede do nenamernega dejanja ali dejanj, ki bi lahko povzročila napake v ABACUS.

· Upoštevajte, da običajne metode zapiranja kontekstni meni (na primer pritisnete [Esc] na tipkovnici, ali levo tipko miške kliknete nekje drugje na zaslonu) ne sme dejansko zapre kontekstnega menija med predvajanjem macro.

Nasvet

V pogovornih, namesto z uporabo kliki, je priporočljivo, da uporabite tipko Tab, da se premaknete skozi razpoložljivih kontrol in smerne tipke, da izberete elemente menija potezni ali možnosti za radio gumb in preslednico, da izberete / de-Potrdite škatle.

Stop snemanje makro

1. Press Alt + F9ali pa izberite Orodja | Stop Macro.

2. V Shrani makrom pogovornem prebrskajte do lokacije in izberite ABACUS makro (.abacusmac datoteka) ime datoteke in kliknite Shrani.

Opomba

Uporaba Orodja| Stop Macrobo vključeval to operacijo v knjiženim macro. Zato je priporočljivo, da uporabniki postanejo spretni pri uporabi možnosti tipko Alt + Funkcija za delo z makri, tako da ne vključuje neželene makro operacij v makrov samih.

Nasvet

Ker so makroji trenutno ni mogoče urejati, je priporočljivo zapisati dolgotrajne naloge, kot niz ločenih makrov uporabo Alt + F10 / Alt + F9 "parov".

Za predvajanje posnetega makro

1. Izberite Orodja | Predvajanje Macroali pa pritisnite Alt + F8.

2. V odprtem makro pogovornem prebrskajte do lokacije in izberite ABACUS makro (.abacusmac datoteka) ime datoteke in kliknite Odpri.

Opozorilo

Pri odpiranju ABACUS makro, če dvokliknete na makro datoteko v pogovornem oknu za brskanje, da ga odprete, lahko makro snemalnik držite levi miškin v levem kliknili stanju, dokler posneto Levi klik razveljavitev te države.

Opomba

Hitrost predvajanja makro lahko nastavite na zavihku General pod Orodja| Možnostibodisi kot Normal (privzeto), hitro ali počasi. Oba sta hitre in počasne hitrosti predvajanja ni priporočljivo, saj bodo Replay posnetih makrov na približno 100-krat in 1 / 100. realnem času, oz. Normalna hitrost predvajanja bo še Replay makro približno 30% hitrejši od zabeležene hitrosti, zato je priporočljivo, da med snemanjem, da se ustavite za kratek čas po morebitnih dolgotrajnih nalog obdelave, da se zagotovi, da se na predvajanje naslednji posel se ne izvaja, preden je naloga predelava zaključena.

Stop predvajal posneto makro

1. Press Alt + F9.


Pregled 3D diagram

Navigacija: Analiza vašo arhitekturo> 3D diagramov>

Pregled 3D diagram

Pošlji komentarje o tej temi.

ABACUS vam omogoča, da si ogledate arhitekturo kot 3D pogled, kjer so sestavni in priključitev lastnosti, povezane z barvami, oblikami in velikostmi.

Če si želite ogledati 3D pogled na vaše arhitekture

1. Zagotovite, da imate odprite datoteko ABACUSz vašim naseljeno arhitekturo.

2. Razširiti Ogledovveja drevesa.

3. Razširiti 3Dveja drevesa.

4. Dvojni klik vizualizacija želite odpreti.

- Ali -

1. Zagotovite, da imate odprite datoteko ABACUSz vašim naseljeno arhitekturo.

2. Izberite Insert| 3Dali kliknite gumb v orodni vrstici.

3. Odpiranje obstoječevizualizacija (.abacus3d)

- Ali -

1. Zagotovite, da imate odprite datoteko ABACUSz vašim naseljeno arhitekturo.

2. Izberite Insert| 3Dali kliknite gumb v orodni vrstici.

3. Ustvari novo vizualizacijo:

· Izberite Arhitekturasi želite ogledati iz spustnega menija.

· Izberite Komponentein Povezaveželite v diagramu iz vključevati okno za izbiro standardni element .

· Pridružene barv, oblik in velikosti z Sestavni Vrstein Nepremičnine.

· Pridružene barve in oblike z Vrste povezavain Nepremičnine.

Za izvoz 3D pogled

1. Zagotovite, da imate odpreti obstoječi 3D pogled.

2. V spustnih menijev 3D pogled na izbiro Datoteka | Export ...in izbrali lokacijo in tip datoteke za datoteko vizualizacije (.abacus3d, .vrml ali .html).

3. Kliknite Shrani.

Poglej tudi

Analiziranje svojo arhitekturo | Navigacija v 3D | Diagramming Orodje


Pregled mehurček grafikon

Navigacija: Analiza vašo arhitekturo> karte po meri>

Pregled mehurček grafikon

Pošlji komentarje o tej temi.

Mehurčke grafikon vam omogoča, da primerjajo do 5 dimenzij (tj x, y, velikosti mehurček / radija, barvne mehurček in mehurček barvnih meja), v enem pogledu.

Če si želite ogledati mehurček grafikon

1. Zagotovite imate ABACUS odprto datoteko .

2. Izberite Insert| Graf| Meri Chartstab | Bubble Chart.

3. V Arhitektureoddelek, označite arhitektur (če sploh) želite grafikon, nato pa kliknite Naslednja.

4. Izberite Komponentein Povezaveda želite v grafikonu (če obstaja) od okno za izbiro standardni element , Nato pa kliknite Naslednja.

5. Izberite X-ospremoženje, nato pa kliknite Naslednja.

Opomba

Le Integer, decimalno, datum / čas, Boolean in Seznam lastnosti Lahko se uporablja za X-os. Poleg tega, Integer, Decimalna in datum / čas lastnosti so narisane od leve proti desni vzdolž osi zaplombirati glede na vrednost nepremičnine, pa so logične in Seznam lastnosti preprosto narisan levo-desno, v točno določenem vrstnem redu (ali v v obratnem vrstnem redu, če se preveri možnost, da se obrne vrstni red) definirana za premoženje glede svojih vrednot. Npr Nizka | Medium | Visoka ali 1, 2, 4, 8, 16.

6. Izberite Y-ospremoženje, nato pa kliknite Naslednja.

Opomba

Le Integer, decimalno, datum / čas, Boolean in Seznam lastnosti Lahko se uporablja za Y osi. Poleg tega so Integer, Decimalna in datum / čas lastnosti narisane-dno na-vrh vzdolž osi zaplombirati glede na vrednost nepremičnine, pa Boolove in Seznam lastnosti so preprosto narišemo-dno na-vrh v točno določenem vrstnem redu (ali v v obratnem vrstnem redu, če se preveri možnost, da se obrne vrstni red) definirana za premoženje glede svojih vrednot. Npr Nizka | Medium | Visoka ali 1, 2, 4, 8, 16.

7. Izberite Velikost kroga / polmerpremoženje, nato pa kliknite Naslednja.

Opomba

Le Integer, decimalno, Boolean in Seznam lastnosti Lahko se uporablja za mehurčke velikosti / polmerom. Poleg tega, Integer in Decimalna lastnosti posledico velikosti mehurčkov / polmerom izmerijo glede na vrednost nepremičnine, pa Boolove in Seznam lastnosti povzroči enake poveča koraku mehurček velikosti / radiju v točno določenem vrstnem redu (ali pa v obratnem vrstnem redu, če možnost, da se obrne vrstni red se preveri) definirana za premoženje glede svojih vrednot. Npr Nizka | Medium | Visoka ali 1, 2, 4, 8, 16.

8. Izbira bodisi fiksna barve bubbleali povezujejo nepremičnine z barvo mehurček, Nato pa kliknite Naslednja.

Opomba

Le Integer, decimalno, Boolean in Seznam lastnosti Lahko se uporablja za barvo mehurčka. Poleg tega, Integer in Decimalna lastnosti povzroči barve mehurček v izbranem območju izmerijo glede na vrednost nepremičnine, pa Boolove in Seznam lastnosti povzroči enake poveča korak barve mehurček v izbranem območju v točno določenem vrstnem redu, določenih za premoženje, ne glede na njihove vrednote. Npr Nizka | Medium | Visoka ali 1, 2, 4, 8, 16.

9. Izberite eno no bubble meja barvaali povezujejo nepremičnine z barvo mehurček meja, Nato pa kliknite Finish.

Opomba

Le Integer, decimalno, Boolean in Seznam lastnosti Lahko se uporablja za barvo mehurček meja. Poleg tega, Integer in Decimalna lastnosti povzroči barve bubble meja v izbranem območju izmerijo glede na vrednost nepremičnine, pa Boolove in Seznam lastnosti povzroči enake poveča korak barve mehurček meja znotraj izbranega območja v točno določenem vrstnem redu, določenih za nepremičnino, ne glede svojih vrednot. Npr Nizka | Medium | Visoka ali 1, 2, 4, 8, 16.

Bubble grafikon

Če želite shraniti mehurček grafikon

Opomba

Bubble karte lahko shranite le, če vsebujejo le sestavne dele in povezave, ki so vse mora biti iz enega samega arhitekture v okviru trenutnega projekta.

1. Prepričajte se, da imate novo ali obstoječo mehurček grafikon openin ste naredili potrebne spremembe.

2. V orodni vrstici grafikonu kliknite na skrajno levo Shrani Chartgumb, da shranite grafikon in morebitne spremembe oblikovanja.

3. V Grafikon Namepogovorno okno, ki se prikaže, vnesite ime za grafikona v oblačku in pritisnite v redu.

Za izvoz mehurček grafikon

1. Zagotovite, da imate odpreti obstoječi mehurček grafikon.

2. V orodni vrstici grafikon klikom na 2. od leve Shrani kot BMPgumb in izbral lokacijo za grafikon.

3. Kliknite Shrani.

Poglej tudi

Analiziranje svojo arhitekturo


Pregled po zmogljivosti vesoljske grafikon

Navigacija: Analiza vašo arhitekturo> karte po meri>

Pregled po zmogljivosti vesoljske grafikon

Pošlji komentarje o tej temi.

Sposobnost Vesolje grafikon vam omogoča, da si ogledate, ali je vaša arhitektura izpolnjuje zahtevane zmogljivosti sistema v zvezi z lastnostmi, opredeljenimi v proces analize zahtev sistema.

Če si želite ogledati zmogljivostjo prostora grafikon

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturoIn da imate ocenitivaše arhitekture.

2. Izberite Insert| Graf| Meri Charts| Sposobnost Vesolje. (Na Sposobnost Vesolje Chart Configpogovorno okno prikaže.)

3. V Arhitektureoddelek, označite arhitekture, ki jih želite grafikon, nato pa kliknite Naslednja.

4. V Nepremičnineobmočje, ustrezno arhitekturne lastnosti, ki jih želite vključeni kot osi grafikona.

5. V SposobnostObmočje, za vsako nepremičnino vključeno v prejšnjem koraku izberite, ali katera koli minimalne ali maksimalne omejitve glede zmogljivosti obstajajo in vrednosti teh omejitev. Privzete vrednosti so minimalne in maksimalne vrednosti ocenjene za arhitektur ali Zadetek za nepremičnine če je bil nastavljen.

Če želite izvoziti zmogljivostjo prostora grafikon

1. Zagotovite, da imate obstoječi Zmožnost prostor grafikonopen.

2. V orodni vrstici grafikonu kliknite na skrajno levo Shrani kot BMPgumb in izbral lokacijo za grafikon.

3. Kliknite Shrani.

Poglej tudi

Analiziranje svojo arhitekturo | Pregled odzivni čas grafikon


Standardne Poročila

Navigacija: Poročanje o vaši arhitekturi>

Standardne Poročila

Pošlji komentarje o tej temi.

ABACUS " standardna Poročila vam omogočajo, da pridobijo seznam sestavnih delov in priključkov v enem ali več vaših arhitektur. Poročilo vsebuje vse informacije, povezane z komponent in povezav izbranih, vključno z informacijami o sestavnega dela ali kraj povezava je v hierarhiji, vrste, standardi, opis lastnosti in njenih prilog.

Opomba

Vsebnost poročilo jenastavljivskozi opisano pogovorno okno Možnosti poročilo spodaj, vendar pa to želite izvedeti več informacij o tem, kako ustvariti popolnoma nastavljiv po meri Poročilauporabo ABACUS poročila po meriProsim se nanašajo na to temo tukaj ali kontakt Avolution Podpora .

Za prikaz standardna Poročilo

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturo(i).

2. Izberite Insert| Standardno poročiloali pa kliknite Ustvarite standardno poročilo orodna vrstica gumb. Configuration Reportse prikaže okno.

Okno Report Configuration

3. Izberite Arhitekture, Komponentein Povezaveda želite v poročilu iz Poročilo Configuration Window.Prosimo, da standardni element izbor tukaj tema za pomoč.

4. Sedaj kliknite na Možnostigumb in Možnosti PoročiloOdprlo se bo prikazal.

Poročilo okno Možnosti

5. Lahko se odločite, da se prikaže Nova stran za vsak elementJe Izpisano, Print čas, Številke straniin ali vsebuje naslov v glaviporočila s kljukico / brisanjem kljukice ustrezna potrditvena polja. Morda boste prav tako želeli prilagoditi naslov in avtorja z urejanjem Poročilo Naslovin Avtor polja z besedilom. Izberete lahko tudi kakšna vsebina se prikaže na poročilo, ki ga odkljukate / brisanjem kljukice odkljukajte Poglejte pod Poročilo Contentdel okna. Ko ste končali, kliknite na v redu.

6. Sedaj kliknite na FinishV oknu Report Configuration.

Razlagati viden poročilo

Primer Izdelano poročilo s kratkimi pojasnili

Za pomikanje po straneh poročila, kliknite na ikone [image] ki se nahaja v orodni vrstici na zgornjem levem kotu zaslona.

Opomba

Ti lahko shranite Poročilo v različnih formatih s klikom na Izvoz icon Poročilo [image] nahaja v orodna vrstica. Lahko se odločite za izvoz v naslednjih formatih: Excel, PDFin Beseda. Prosimo, shranite poročilo v želeno mesto za poznejšo uporabo. Če so spremembe na arhitekturi pozneje, bo novo poročilo je treba ustvariti, da odražajo spremembe.

Poglej tudi

Analiziranje svojo arhitekturo


Pregled odzivni čas grafikon

Navigacija: Analiza vašo arhitekturo> karte po meri>

Pregled odzivni čas grafikon

Pošlji komentarje o tej temi.

Odzivni čas grafikon vam omogoča, da si ogledate, ali so vaše povezave obdelujejo na zahtevani stopnji (tj znotraj njihovega roka).

Če si želite ogledati odzivni čas grafikon

1. Zagotovite imate ABACUS odprto datoteko z vašim naseljeno arhitekturoIn da imate ocenitivaše arhitekture.

2. Izberite Insert| Graf| Meri Charts| Odzivni čas. (Na Odzivni čas Chart Configpogovorno okno prikaže.)

3. Iz Arhitekturespustnem seznamu izberite arhitekturo želite grafikon.

4. V PovezaveObmočje, označite povezave ki jih želite vključiti v grafikonu.

5. Lestvica Typeobmočje, izberite LinearČe želite navpično os (odzivni čas), da se prikažejo kot linearno napredovanje - vsak segment časa se dodeli enak delež osi. Izberite Logarithmicče želite, da je prikazan kot logaritemsko napredovanje - vsak segment osi predstavlja čedalje daljših časov Višje osi greš. (Stopnja rasti je določena z Osnovnaizberete.)

Odzivni čas grafikon navpične osi lestvica

Za izvoz odzivni čas grafikon

1. Zagotovite, da imate obstoječi odzivni čas grafikonopen.

2. V orodni vrstici grafikonu kliknite na skrajno levo Shrani kot BMPgumb in izbral lokacijo za grafikon.

3. Kliknite Shrani.

Poglej tudi

Analiziranje svojo arhitekturo | Pregled po zmogljivosti vesoljske grafikon


Pregled razpršenih parcelo vaših razvijal arhitektur

Navigacija: Analiza vašo arhitekturo> karte po meri>

Pregled razpršenih parcelo vaših razvijal arhitektur

Pošlji komentarje o tej temi.

Ko je arhitektura razvijal in cilji so določeni, lahko pa se obarvajo, in v primerjavi s prvotno arhitekturo z uporabo scatterplot matrike. To poglavje opisuje, kako ustvariti in razumeti značilnosti matrike scatterplot.

Če si želite ogledati scatterplot Matrico vaših razvijal arhitektur

1. Zagotovite imate ABACUS odprto datoteko .

2. Zagotovite, da imate razvilin Zastavljeni ciljiza arhitekturo, kot je opisano pod Razvija svojo arhitekturo

3. Izberite Insert| Graf| Meri Chartstab | Scatterplot Matrix.

4. Kliknite na Finishgumb.

5. Scatter Plotz opredeljeno razvoj arhitekture in ciljev bodo prikazani.

Opomba

Področje, na levi strani matrike scatterplot prikazane nastavitve matrike scatterplot vidna. To vključuje arhitekturo, ki se je razvila (v tem primeru "ABC Ltd As-Is 2010") Kot tudi cilji, ki so določeni za to arhitekturo. Opazili boste, da so cilji, ki imajo kljukico zraven so jih zastopali X in Y osi matrice scatterplot (npr KPI- Stroški, KPI - Kakovost in KPI - Čas). Morda boste untick teh ciljev v vsakem trenutku, da jih odstranite iz matrike scatterplot.

Modre pike, ki se pojavijo na vaši parceli v matriki predstavlja normalizirano vrednost, kot je določena z najboljšo in najslabšo vrednostjo (opisana pod Postavljanje ciljev za vaše razvil arhitekture ). Te vrednote so zastopana v Kakovost Vesolje.

Dve opredeljeni cilji so v primerjavi drug proti drugemu v matrici scatterplot in postopek se ponovi, dokler niso vsi cilji primerjavi (npr prvi ploskvi matrike iz zgornjega diagrama primerja KPI - StroškiCilj z KPI - Kakovost cilj. Drugi je Strošek proti Čas in zadnja parcela je Kakovost proti Čas. Ustrezne oznake cilja, so prikazani na vrhu desno ali vsako vrsto parcel.).

6. Izberite Arhitektureradio gumb, če želite prikazati meritve za posamezne arhitekture.

7. Izberite Evolutionsradio gumb, če želite prikazati normiranih razlikuje od prvotne arhitekture (npr As-Is 2010) K razvito arhitekturo (i) (npr To-Be 2011 - Strategija A in do-Be 2011 - Strategija B).

Poglej tudi

Analiziranje svojo arhitekturo | Pregled odzivni čas grafikon | Pregled zvezd parcelo vaših razvijal arhitektur | Razvija svojo arhitekturo


Pregled standardni grafikon

Navigacija: Analiza vašo arhitekturo> Standardni karte>

Pregled standardni grafikon

Pošlji komentarje o tej temi.

Standardne karte Abacus 'vključuje vrstico, vrstico, stolpec, območje, odbojev, pito, curve, Pareto, korak, površino, radar, kocka, krof, piramido, obris in grafikoni krivulja območje. Po izboru vrsto grafikona hočeš, preostali del procesa za pregledovanje vsakega od teh grafih je enak.

Če si želite ogledati standardni grafikon vašega arhitekture

1. Zagotovite, da imate odprite datoteko ABACUSz vašim naseljeno arhitekturoIn da imate ocenitivaše arhitekture.

2. Izberite Insert| Grafali kliknite gumb v orodni vrstici. Chartsse prikaže okno.

Charts okno

3. Izberite vrsto grafikona, ki ga želite, in nastavite Možnosti grafikona, nato pa kliknite Naslednja.

Možnosti chart

o Zloženebo pokazal odnos posameznih postavk v celoti. Lahko uporabite zložene grafikon, če mislite, da imate več serij podatkov (tj več lastnosti) in, če želite, da se poudari skupaj.

o Naložen 100%bo primerjati odstotek vsaka vrednost prispeva k skupni za vse kategorije. Lahko uporabite 100% zložene grafikon, če mislite, da imate več serij podatkov (tj več lastnosti), in želite poudariti prispevke v celoti, še posebej, če je vsota enaka za vsak element.

o 3D Chartbo preprosto prikažete podatkovne točke v formatu 3-D za estetiko. Če želite prikazati niz podatkov vzdolž 3. / z-osi razsežnosti nato uporabite možnost Cluster Series opisano spodaj.

o Serija, ki lastninobo prikazal niz podatkov za vsako premoženje, ki je na koncu izbrali. Če je to nenadzorovano potem bodo lastnosti postanejo kategorije in vrste podatkov, bo za vsak element, ki je izbran.

o Zavrti Chartbodo menjavali grafikonu 90 stopinj v smeri urinega kazalca z zamenjavo x in y osi. Ta možnost je na voljo le za proge, korak in Cube lestvicin je še posebej koristno za izdelavo mejnik karte, kot je opisano v drugem konici spodaj. Opomba: stolpec in Bar karte so že "zavrti" različice med seboj.

o Cluster Seriesbo prikazal več podatkov serije vzdolž 3. / z-osi razsežnosti. Ta možnost je na voljo samo za stolpec, Bar in Cube kartein je še posebej koristno za izdelavo Gantt slog karte, kot je opisano v prvem Nasvet spodaj.

Nasvet

Lahko ustvarite Ganttov diagramz vodoravnimi palicami, ki prikazujejo čas / datum lastnosti za različne elemente, tako da izberete vrsto Bar grafikona in nato izberete možnost Cluster Series.Poleg tega je enkrat ustvarjena, lahko levo-najbolj bar na grafikonu se je "nevidna" in ga pobarvaj bela z desnim klikom na eno od palic, izbiro Barva iz menija, ki se pojavi in ​​izberete zgornji levi barvo iz palete. Poleg tega se meja za skrajni levi strani vrat lahko izvede "nevidne", z desnim klikom na eno od palic, izberete Lastnosti ... in na zavihku serije v pogovornem oknu, ki se pojavi spreminjajo Effect meje do Nič in Barva na vrh -left barvo iz palete.

Nasvet

Lahko ustvarite Milestone grafikonz majhnimi oblike prikazuje čas / datum lastnosti za različne elemente, tako da izberete vrsto Cube grafikona in nato izberete Rotate Chart in Cluster Serija možnosti.Poleg tega je enkrat ustvarjena, kocke mogoče spremeniti z drugimi oblikami z desnim klikom na eno od kock v danem serijo podatkov in izberete Lastnosti ... in na zavihku serije v pogovornem oknu, ki se pojavi spreminjajočem Bar bodisi valja ali Cone . Opomba: Vrednost širina Gap se lahko uporablja tudi za "stiskanju 'simbolov na grafikonu zmanjšati prekrivanje, višje število manj prekrivanje bo prišlo.

4. V Arhitektureoddelek, označite arhitekture / i želite grafikon lastnosti ravni arhitektura, nato pa kliknite Naslednja.

Opomba

Izbira lastnosti ravni arhitektura je povsem neobvezen korak in ga je treba uporabiti samo takrat, ko želite izrecno grafikon lastnosti ravni arhitekture same.Arhitektura ni potrebno, da so izbrani, da potem, vključujejo sestavni del ali povezovalnih lastnosti v naslednjem koraku.

5. Izberite Komponentein Povezaveda želite v grafikonu od okno za izbiro standardni element , Nato pa kliknite Naslednja.

6. Izberite Nepremičnineželite v grafikonu in klik Finish.

Možnosti chart

o Vključi Standardne lastnostibo pokažejo podedovane lastnosti od standardov, ki so na voljo za izbiro.

o Aggregate Lastnostibo štetje varianco med vrednostmi iz serije in grafikon teh rezultatov v nasprotju posameznik same vrednosti.Ta možnost je na voljo le, če je bila izbrana serija, ki jih možnostjo lastnino v koraku 3 zgoraj.

Nasvet

Lastnosti so na voljo za kart je odvisna od elementov, ki ste jih izbrali.

Če želite shraniti grafikon

Opomba

Charts lahko shranite le, če vsebujejo le sestavne dele in povezave, ki so vse mora biti iz enega samega arhitekture v okviru trenutnega projekta.

1. Prepričajte se, da imate novo ali obstoječo tabelo openin ste naredili potrebne spremembe.

2. V orodni vrstici grafikonu kliknite na skrajno levo Shrani Chartgumb, da shranite grafikon in morebitne spremembe oblikovanja.

3. V Grafikon Namepogovorno okno, ki se prikaže, vnesite ime za karte in pritisnite v redu.

Za izvoz grafikon

1. Zagotovite, da imate obstoječi grafikonopen.

2. V orodni vrstici grafikon klikom na 2. od leve Shrani kot BMPgumb in izbral lokacijo za grafikon.

3. Kliknite Shrani.

Poglej tudi

Analiziranje svojo arhitekturo | Pregled odzivni čas grafikon | Pregled po zmogljivosti vesoljske grafikon


Pregled zvezd parcelo vaših razvijal arhitektur

Navigacija: Analiza vašo arhitekturo> karte po meri>

Pregled zvezd parcelo vaših razvijal arhitektur

Pošlji komentarje o tej temi.

Ko je arhitektura razvijal in cilji so določeni, lahko pa se obarvajo, in v primerjavi s prvotno arhitekturo z uporabo zvezdice parcel. To poglavje opisuje, kako ustvariti in manipulirati zvezda parcelo.

Če si želite ogledati zvezdicami parcelo vaših razvijal arhitektur

1. Zagotovite imate ABACUS odprto datoteko .

2. Zagotovite, da imate razvilin Zastavljeni ciljiza arhitekturo, kot je opisano pod Razvija svojo arhitekturo

3. Izberite Insert| Graf| Meri Chartstab | Star Plot.

4. Kliknite na Finishgumb.

5. Star Plotz razvile arhitekture in nastavite bodo prikazani cilji. Opomba: Osi zvezda parceli se lahko premeščajo s klikom in vlečenjem osi na drugo območje v mejah prostora zvezda kakovosti plot.

Opomba

Območje na levi strani zvezdicami parcele so prikazane nastavitve prikazane zvezdicami parceli. To vključuje arhitekturo, ki se je razvila (v tem primeru "ABC Ltd As-Is 2010") Kot tudi cilji, ki so določeni za to arhitekturo. Opazili boste, da so cilji, ki imajo kljukico zraven so jih zastopali osi zvezdicami parceli (npr KPI- Stroški, KPI - Kakovost in KPI - Čas). Morda boste untick teh ciljev v vsakem trenutku, da jih odstranite iz zvezdicami parceli.

Rdeča in zelena "pike", ki se pojavljajo na vašem zvezdicami parceli predstavlja normalizirano vrednost, kot je določena z najboljšo in najslabšo vrednostjo (opisana pod Postavljanje ciljev za vaše razvil arhitekture ) Za izbrano arhitekturo vrhunskega in morebitnih dogajanju v njej. Te vrednote so zastopana v Kakovost Vesolje.

Kot je navedeno v zgornji sliki, je jasno vidno, da je bila prvotna arhitektura (As-Is 2010) Ima slabe Strošek, Medtem ko je prva razvila možnost (To-Be 2011 - strategija), Se je preselil v prostor kakovosti za izboljšanje Strošek, Kakovost in čascilji. Alternativno drugi razvil možnost (To-Be 2011 - Strategija B), medtem ko se je izboljšala tudi Strošek obseg izboljšanju je manjša od Strategija A vendar sta bila oba sta kakovost in čas cilji izboljšalo bolj kot s strategijo A.V tem primeru arhitekt lahko izberite Strategijačez Strategija Bnjihovo priporočiloin nadalje razvijati to možnost (To-Be 2012 - Strategija A).

6. Počistite Prikaži Evolutionspotrditveno polje, da skrijete vrstico (e), kar predstavlja evolucijo (e) med original (npr As-Is 2010) In razvil (npr To-Be 2011 - StrategijaA) arhitektura (y).

7. Izberite Prikaži palčkepotrditveno polje za prikaz relativne velikosti vsakega kakovosti atributa (ciljev, ki so bili opredeljeni na vsaki osi), za vsako arhitekturo.

8. Izberite Prikaži Arhitektura Imenapotrditveno polje, če želite, da imeni originalnega in razvito arhitekturo (-e), ki se pojavijo na zvezdic parceli.

Poglej tudi

Analiziranje svojo arhitekturo | Pregled odzivni čas grafikon | Pregled matriko scatterplot vaših razvijal arhitektur | Razvija svojo arhitekturo


Analiziranje svojo arhitekturo

Navigacija: Analiza svojo arhitekturo>

Analiziranje svojo arhitekturo

Pošlji komentarje o tej temi.

Ko ste poseljena (in neobvezno simulirano) svojo arhitekturo, ste pripravljeni za uporabo ABACUS, da jo analiziramo. Tako, da ga analizira, boste lahko ugotovili, če bo vaš arhitektura ustrezajo vašim potrebam.

Lahko analizirati arhitekturo na različne načine:

· Diagram

· 3D pogled

· standardne karte (pita, vrstica, stolpec, bar, itd)

· custom karte ( odzivni čas , Zmožnost prostor , zvezda plot , scatterplot matrix in bubble chart )

· Arhitektura Diff

Opomba

Pri ustvarjanju diagram, 3D pogledPoročilo ali standardni grafikon se okno za izbiro standardni element se uporablja za izbiro elementov, ki jih želite ogledati.

Poglej tudi

Poselitev svojo arhitekturo | Simulira svojo arhitekturo | Diagramov Orodje


Kaj je arhitektura?

Navigacija: Uvod v ABACUS>

Kaj je arhitektura?

Pošlji komentarje o tej temi.

Arhitektura je abstrakten Koncept- Ne fizično stvar. To je bogat in celovit opis ali razumevanje strukture sistema - zajemanje komponent in kako oni povezani (interakcijo). Ker je pojem arhitekture je tako vseobsegajoča, da je ključnega pomena za stroške, razpoložljivost, razvojnostjo, odprtosti in učinkovitosti sistema. Dobra arhitektura je predpogoj za ozvočenjem.

V ABACUS, si modelirati svojo arhitekturo. Zaradi enostavnosti, pravimo ta arhitekturni model, arhitektura.

Spodnji diagram prikazuje tipično arhitekturo 5deli (v hierarhiji) povezan z 2 povezav. Etikete navesti imena Glede na različne dele arhitekture v ABACUS.

Preprosta arhitektura

ABACUS meni vse te stvari, da se del arhitekture:

· Komponentepredstavljajo subjekti vašega arhitekture kar bi lahko opisali kot "stvari". Za zavarovalnico, lahko komponente biti sistemi za politike obdelave, terjatev, plačil in prejemkov.

· Povezavepredstavljajo odnose med temi sestavnimi deli. Na primer, v zavarovalnici, so prihodki ustvarjeni za veljavnih politik, so zahtevki zoper veljavnih politik in veljavne zahtevke za posledico plačil. Ko razmišljate arhitekturno - zlasti pri uporabi ABACUS - so povezave tako pomembna kot sestavne dele, in jih obravnavajo na skoraj enak način.

· Vse v drevesu lahko Nepremičnine. Lastnosti so stvari, kot na način, ki ga potrebujejo svoj sistem za izvedbo, število vrstic kode ima, odstotek teh vrstic, da so komentarji, itd ABACUS meni vse te stvari, da se del arhitekture.

· Z uporabo hierarhije(t.j. podskupinah in sub-povezave), Lahko skrijete informacije in de-sestavite svojo arhitekturo. Arhitekturna Model ABACUS je izredno prilagodljiv. Vsako komponento na kateri koli ravni je lahko povezana s katero koli drugo komponento na kateri koli drugi ravni s katero koli povezavo na kateri koli ravni.

· Priponkaje postopek, s katerim komponent pristanišča so vezani na zveziVloge. Pristanišča in Vloge so vmesniksmed komponentami in povezav. Uporabljajo se za pritrditev povezave do komponent. Povezave imajo vir in ponor Vloga(olajšati pretok podatkov s komponento vira za komponento umivalnikom)in konceptualno, komponente imajo pristanišči. Zaradi enostavnosti, vendar pa se v ABACUS sestavni vrata niso prikazani in vloge povezava sta neposredno vezana na komponente samih.

· Komponente in povezave so neka Tip. To je predvsem za namene razvrstitve. Na primer politike, terjatve, plačila, in prejemki, ki so sestavni del tipa "sistem". Veljavni politike, ki veljajo terjatve, itd, so povezave tipa "transakcija". Type komponenti dodeljen ali povezavo zagotavlja predlogo za lastnosti in standarde, ki jih ima. Na primer, lahko homologacija sestavnega Server imeti "Znamka in model ' standardnain IP naslov lastnine. Za razliko od drugih togih orodja z osnovnim relacijske baze podatkov (RDB) back-end, v ABACUS lahko prosto ustvarite svoj novi tipi in dodelite svoje kombinacije lastnosti in standarde za njih.

· Standardne knjižnice lastnosti lahko določena in dodeljena karkoli drugega v arhitekturi. Te knjižnice so znani kot Standardi. Z uporabo StandardiMorate le zbrati posebne lastnosti sistemov - standardne lastnosti so že tam. Na primer, se standardne značilnosti delovanja operacijskega sistema Microsoft Windows 2000 lahko dodeljena glede na komponente uporabljate operacijski sistem Microsoft Windows 2000.

Poglej tudi

Kako se arhitektura zastopana v ABACUS? | Kaj ABACUS storiti? | Kako si to naredil (Pregled) | Ustvarjanje novega tipa


Delo z Enterprise Server

Navigacija: Uprava>

Delo z Enterprise Server

Pošlji komentarje o tej temi.

ABACUS Enterprise Server je tako "non-blokiranje" sodelovalni pristop, ampak 'odklopiti' ena tudi. ABACUS je "non-blokiranje" zato, ker je ne prisiliti datoteko, ki naj zaklenil enega uporabnika, da je treba posodobiti. Vsak uporabnik ima svojo lokalno kopijo datoteke, in ker bi spremembe in shranite svojo datoteko, se te spremembe evidentirajo in shranijo, ko želi uporabnik jim zavežejo s strežnikom.

ABACUS se "odklopi" v smislu, da vam ni treba, da je povezan s strežnikom ali potrebujejo dostop do omrežja, medtem ko delate na datoteko. ABACUS zahteva dostop do strežnika samo pri izvajanju operacij, kot je ustvarjanje datoteke, ali opravlja prevzem, skupaj z operacijami na obstoječe datoteke - posodobitev, zavezati, ali pregledovanjem dnevnik iz preteklosti zavezuje. Dostop do strežnika ni potrebno delati na datoteko, in vaše spremembe niso takoj pošlje na strežnik (to vam omogoča, da enostavno zavreči spremembe, če se zmotite). Ko shranite datoteko, ste 'samo' varčevanje vaš copy lokalno - to ni, dokler ste se zavežejo, da bodo vaši lokalni spremembe (spremembe so od vaše zadnje zavezati), se pošljejo na strežnik.

Ustvarjanje datoteke New Enterprise

Če želite ustvariti novo datoteko Enterprise, izberite mapa| New ...in nato izberite eno od prvih dveh možnosti v razdelku Enterprise modelu Pogovorno okno New Project (tj bodisi prazno datoteko Enterprise ali ustvarite iz obstoječega ABACUS datoteko). Tretja možnost je, da "Checkout" datoteka Enterprise nekdo drug je že ustvarili, bo to zajeto v naslednjem poglavju.

Ko se odločite, da ustvarite novo datoteko Enterprise, boste dobili pogovorno okno, ki vam bo omogočilo, da brskanje kje na strežniku skladišča želite shraniti datoteko. Prav tako bo treba obstoječo pot datoteke in ime, vpisano do vrha, če ste izbrali "Iz obstoječega modela" v pogovornem oknu New Project in dobavili datoteko.

URL: To je URL za vaš strežnik skladišč, kjer so shranjene datoteke ABACUS Enterprise. Moral bi vprašati osebo, ki upravlja strežnik, kaj naj bi ta URL.

Zgornja slika prikazuje skladišče s štiri (4) obstoječih projektov ABACUS Enterprise, po vstopu URL in pritisnete Enter.Vi bomo videli, ko ustvarite novo datoteko Enterprise, na naslednji sliki za "Checkout", bo drugo mapo in datoteko na podlagi tega odlagališča.

Opomba

Če uporabljate https (SSL) strežnik in strežnik nima veljavnega potrdila SSL (skupno za intranetne ali ne-javnih strežnikov zaradi Stroški potrdila SSLs), Bo dodaten korak, da sprejme. Boste morali za trajno sprejeti vse povezave do tega strežnika v pogovornem oknu, ki pops up (to bo pokazal tudi malo več informacij o strežniku). Če želite to narediti, tip "p" (brez narekovajev) in pritisnite Enter. ABACUS bo pop up sporočilo, ki vas bo na to opozoril pred prikazuje pogovorno okno.

Opomba

Morda boste morali, da se prijavite na strežnik, v katerem primeru je oseba, ki je upravljanje strežnikalahko zagotovi uporabniško ime in geslo za strežnik. Prav tako so poverilnice za prijavo za vseh strežnikov, ki ste povezani, so shranjene tako, če iz kakršnega koli razloga, ki jih potrebujejo, da se izbil to je mogoče storiti prek Orodja | Možnostiin nato povezavo Splošno Kartica s klikom Reset Subversion Saved Prijavain izbiro strežnika iz spustnega seznama in kliknete Jasno Prijavain izberete OK v pogovornem oknu, ki se prikaže.

Opomba

Za razliko sliki prikazano zgoraj, je običajno ena ABACUS projektov, vključenih v vsako ABACUS Repository, ker če je več kot 1 ABACUS projekt ustvaril v enem ABACUS Repository, so ABACUS dnevnika sprememba številke delijo vseh ABACUS Projekti in to lahko zmedlo uporabnike.

Želeni Ime datoteke: To vpliva tako na mapo in ime datoteke, ki se bo uporabljal (če še ni sprejela), pri ustvarjanju datoteke na strežniku skladišča. Upoštevajte, da se samodejno ustvari nova mapa na strežnik skladišč za vsako datoteko (zaradi uspešnosti, so datoteke ABACUS Enterprise ustvarili v svoji mapi na podlagi lokacije ogledujete, da v pogovornem oknu).

Shranjevanje delovne kopije v imeniku: Ko je datoteka Enterprise ustvarjena na strežniku skladišča, potrebujejo lokalne delovne datoteke, ki se ustvari na računalniku, tako da lahko delate na datoteko, ne da bi bili povezani z omrežjem. To je mesto, ki ga bo brskanje, ko želite odpreti / ponovno odpre datoteko ABACUS Enterprise.

Prevzem obstoječega Enterprise datoteko

Če je nekdo že ustvaril novo datoteko Enterprise, lahko "prevzem" ta datoteka, ki se prenese na lokalno kopijo in vzpostavlja potrebne datoteke, tako ABACUS to priznava kot datoteko Enterprise. Pogovorno okno je podobno New Enterprise Datoteka Dialog. Vnesite skladišča URL (poddirektoriji se lahko vključijo v URL), izberite želeno datoteko in kliknite V redu. V skladu z opombo pod tje vložiti bodo nato odprla.

Opomba

Morda boste morali, da se prijavite na strežnik, v katerem primeru je oseba, ki je upravljanje strežnikalahko zagotovi uporabniško ime in geslo za strežnik. Prav tako so poverilnice za prijavo za vseh strežnikov, ki ste povezani, so shranjene tako, če iz kakršnega koli razloga, ki jih potrebujejo, da se izbil to je mogoče storiti prek Orodja | Možnostiin nato povezavo Splošno Kartica s klikom Reset Subversion Saved Prijavain izbiro strežnika iz spustnega seznama in kliknete Jasno Prijavain izberete OK v pogovornem oknu, ki se prikaže.

Enterprise datotek Razlike

Ko ste ustvarili datoteko Enterprise (bodisi nova, ali prek "blagajno" za datoteke, ki jih je ustvaril nekdo drug), se bo ustvaril mapo za spis, in bo običajno vsebuje teh 3 glavne vrste datotek:

· Datoteka ".abacus"- To je sama ABACUS datoteko. Spremembe, ki jih da na lokalni ravni niso takoj shranjene v to datoteko, je zapisano le, ko ste se zavežejo. Ta datoteka je "normalno" ABACUS datoteka, je mogoče dati uporabnikom non-EEkot samostojen projekt (brez .log datoteko)Ali uporabljajo kot izhodišče za novo EE datoteko.

· Datoteka ".changes"- Lokalne (nevezane) spremembe v datoteko. Če je ta datoteka manjka, to pomeni, da ne obstajajo krajevne spremembe.

· ".log" Datoteka- Ta datoteka ima le spremembe, ki so bile narejene z zadnjo uporabnika (vsebine uporabnikovega .changes datoteke, ko so zagrešili).

Opomba

Obstajajo različne druge datoteke, ki jih lahko ustvarili med posodobitvijo in zavezati procese, in sicer; ‘.changesbefore' mapa- Ta datoteka je kopija datoteke .changes potem ko je bila posodobitev izvedena in se uporablja za samodejno usklajevanje nobene osebne konflikte med posodobitvijo in vsak lokalni (nezavezujoče) sprememb, preden se zavežejo; ‘.backup' mapa- Ta datoteka je kopija datoteke .changes preden uporabnik prihrani več lokalnih (nerazporejenih) spremembe v datoteko .changes; in ‘.error' mapa- Ta datoteka je kopija .changes vložiti, če je šlo za vprašanje, ki ga je povzročil ABACUS, da ne, da odprete datoteko .abacus in uporabnik odločil, da se vrne njihove spremembe.Te datoteke je mogoče prezreti.

Odpiranje datotek

Če želite odpreti datoteko, morate samo za brskanje, kjer ste se odločili za shranjevanje delovno kopijo, in odprite datoteko ABACUS da je tam shranjene. Ko ABACUS vidi, da gre za .log datoteko (in morda .Spremembe datoteke, če ste naredili spremembe), se bo obravnavala datoteko kot datoteko Enterprise.

Posodabljanje datoteko

Performingn 'Update' bo preveril, če je novejša verzija datoteke se nahaja na strežniku. Če je, se bo zaprl svoje trenutne datoteke, posodobite na novejšo datoteko iz strežnika in prenesete nekaj začasne datoteke, ki imajo več kot podaljšek - npr "Demo.125". Te datoteke so starejše različice .log datoteko, in se uporablja za ugotavljanje, katere spremembe so bile narejene v datoteko, odkar ste ga nazadnje posodobljena. To je potrebno, da bi ugotovil morebitne konflikte, ki so se lahko zgodile, tako da jih lahko odpravite.

Če Med postopkom posodobitve koli konfliktiUgotovljeno je bilo, Boste morali, da jih rešiti, preden lahko znova odprete datoteko (lahko prekličete vendar boste morali ponovno reševanje sporovnaslednjič, ko odprete datoteko).

Shranjevanje datoteke

Ko shranite datoteko, ta doda vse spremembe, ki ste jih naredili v datoteki .changes. To nespremenite datoteko .abacus na tej stopnji - samo, če je datoteka zavezala, da bo strežnik se pisno preko (ali ko boste prejeli posodobitev s strežnika).

Kje je "Save As"?

Ni koncept shranite kot datoteke Enterprise. Lahko pa, kopirate delovno kopijo .abacus spisa, ob upoštevanju, da je navada imajo svoje lokalne spremembe v njej.

Reševanje konfliktov

Če imajo drugi uporabniki zavzete spremembe v datoteko v podobnem delu datoteke za vas, se lahko pojavijo konflikti med njihovimi spremembami in tvoje. Na primer, lahko drug uporabnik izbrisati komponento, ki jo je imela posodobitev nepremičnine na. Morate bodisi razveljaviti svojo spremembo (če ste prepričani, da je njihova moralane se je zgodilo), ali zavreči spremembe (lahko nato pa pojdite nazaj v datoteko in uveljavi svojo spremembo).

Natančneje so 4 razredi konfliktov, ki se lahko pojavijo;

1. Izbriši - Ko je eden uporabnik izbriše predmet tega drugega uporabnika sprememb. Npr Uporabnik izbrisan komponento, vendar uporabnik B preimenoval komponento ali z njo povezana ali dodali komponento otroka z njim itd

2. Lastnost - Ko se dva uporabniki obeh spremeniti točno isto "atribut" objekta. Npr Oba Uporabnik A in B Uporabnik preimenoval komponento ali njihovo opis ali vrednost ene izmed njegovih lastnosti itd

3. Sklicevanje - Ko se dva uporabniki spremenite točno isto "sklic" objekt ima na drug objekt. Npr Oba Uporabnik A in uporabniku B spremenilo tip sestavnega dela ali komponenta vir / ponor pritrjena na povezavo ali povezana vidika za diagram itd

4. Zbiranje - Ko se dva uporabniki spremenite "zbiranje" za objekt. Npr Oba Uporabnik A in uporabniku B preselil komponento od enega starša na drugega ali ponovno odredil zbirko otroških komponent.

Opomba

Različne nepomembne konflikti se samodejno rešiti z ABACUS, da se zmanjša režijske stroške za uporabnike.Na primer, so kakršne koli konflikte nastavitve pan-zoom za sheme odločeni obdržati najnovejše nastavitve pan-zoom.

Stori spremembe

Ko se odločite, da spremembe, datoteka ABACUS iz strežnika se odpre, vaš lokalna Spremembe se izvajajoproti njej, in potem vaša lokalna .abacus datoteka prepisana z eno, ki je vaše spremembe v njej. Vaše spremembe datoteke nato prepiše .log datoteko in tako datoteka .abacus in .log datoteke se pošljejo na strežnik.Če zavezati uspešna Spoštovati pogovorno sporočilo, kot je prikazano spodaj, pod pogojem, da vnesete sporočilo z objavo.

Pregled dnevnik sprememb

Če želite ogled dnevnika sprememb na Enterprise ProjektIzberite mapa| View Log...

Največje vpise: Ta bo privzeto zadnjih 10 vnosov, vendar dodatne vnose je mogoče pridobiti s spremembo vrednosti in kliknete Pridobi gumb.

Revizija: Thstolpec e Revizija izpiše številke revizij, storjenih s strežnikom Enterprise, ki ga privzeto, v obratnem kronološkem vrstnem redu.

Opomba

Številke revizije ne sme biti stalna, saj bo ABACUS ta zavezuje treba navesti samo, ko se isti skladišče Subversion lahko uporablja za druge projekte ABACUS in / ali drugih aplikacij za nadzor različic.

Datum: The Datum stolpec navaja datum, ko je bila revizija storjena s strežnikom Enterprise.

Čas: The Čas stolpec navaja čas dneva (v 24-urni obliki), da je bila revizija storjena s strežnikom Enterprise.

Avtor: The Avtor stolpec navaja Microsoft Windows prijavno ime za uporabnika, ki je opravil Odobritev sledi njihovi ABACUS uporabniško ime Ali "Anonymous", če se uporabnik ni potrjen in anonimni uporabniki so dovolili dostop do projekta Podjetništvo v času od objave.

Log Sporočilo: Thstolpec e Log Sporočilo navaja zavežejo sporočilo, ki je bilo predvideno z revizijo, kot na oknu prikazano zgoraj.

Prenos revizija XX kot samostojno ABACUS datoteko: Če izberete določeno revizijo v tabeli in nato kliknite gumb Prenos boste mogli izvleči izbrano ABACUS projekta revizijo iz strežnika in jo shranite kot lokalni / samostojen projekt ABACUS.

Opomba

Roll nazaj na prejšnjo revizijo glej to Avolution članek skupnost .

(Admin) Prenesi Prijavite XML datoteko za revizijo XX: Uporabniki z Administrator zmožnostjo ABACUS lahko izberete določeno revizijo v tabeli in nato kliknite gumb Prenos za pridobivanje izbrani projekt ABACUS zavezati log datoteko s strežnika in ga shranite kot datoteko XML.

Pregled revizijsko sled sprememb

Če želite ogled revizijsko sled sprememb danem elementu (tj sestavnih delov, povezave, pogled, otroke itd), ki je Enterprise Projekt, desno tipko miške kliknite element in izberite Audit Trail..., Nastavite iz in v območju Revizija in klik Iskanje.

Opomba

Ko je element izbrisan iz projekta, ki ga niso več mogli dostopati do določenih podatkov, revizijska sled o tem elementu. Lahko pa še vedno dostop komponento "matično" (na primer) in si oglejte informacije revizijska sled o izbrisu (v tem primeru z navedbo ID elementa, ki je bil izbrisan).Poleg tega, komponentni / navezanost Connection je "premoženje" povezav, tako spreminjajoče priloženo komponento skozi okno Raziskovalca ali diagrami bo pokazal, v revizijske sledi za priključitev ne komponente, ter brisanje povezavo in ustvarjanje nove povezave (kot se zgodi, če z desno tipko miške kliknite "Unattach 'in nato' Connect ..." v katalogih), bo imelo za posledico izgubo podatkov revizijska sled za izvirno komponento - prilogo povezave celoti.

Opomba

Privzeto bo revizijska sled rekurzivno preveri spremembe katerega od otrok izbranega elementa. To lahko povzroči dolgih odzivnih časov in ustrezno revizijsko sled mogoče omejiti na samega elementa, ki ga odznačite Rekurzivna Možnost pod Revizijske Možnosti"zobnik" gumb orodne vrstice v pogovornem oknu Audit Trail.

Iz revizije: Ta bo privzeto prvi / najstarejšo revizijo na voljo za projekt na strežniku Enterprise.

Revizije: Ta bo privzeto zadnje / najnovejših revizijo na voljo za projekt na strežniku Enterprise.

Opomba

Po nastavitvi From in revizije range kliknite gumb Iskanje naložiti nobenih posebnih sprememb izbranega elementa.

Revizija: Thstolpec e Revizija izpiše številke revizij, storjenih s strežnikom Enterprise, ki ga privzeto, v naprej kronološkem vrstnem redu.

Opomba

Številke revizije je malo verjetno, da bo stalna, saj bodo prikazani samo popravki, pomembne za izbrani element in le ABACUS zavezuje, bodo navedene, medtem ko se isti skladišče Subversion lahko uporablja za druge projekte ABACUS in / ali aplikacij za nadzor različic.

Datum: The Datum stolpec navaja datum, ko je bila vložena tožba uporabnik.

Opomba

Datum prikazana je datum ukrep uporabnik, ne datum revizija je bilo storjeno s strežnikom Enterprise. Skladno s tem, se lahko datum pred ustrezno spremembo Odobritev datum prikazan z Datoteka | View Log ...ukaz.

Čas: The Čas stolpec navaja čas dneva (v 24-urni obliki), ki je bila vložena tožba uporabnik.

Opomba

Čas prikazana je čas tožba uporabnik, ni čas revizija je bilo storjeno s strežnikom Enterprise. Zato je čas, se bo najverjetneje pred ustrezno spremembo zavežejo čas prikazano s Datoteka | View Log ...ukaz.

Avtor: The Avtor stolpec navaja uporabnika, da opravljeno akcijskega je Microsoft Windows prijavno ime sledilo njihovo ABACUS uporabniško ime Ali "Anonymous", če se uporabnik ni potrjen in anonimni uporabniki so dovolili dostop do projekta Podjetništvo v času akcije uporabnika.

Opomba

Avtor naveden v Trail pogovornem oknu revizijske ni nujno ujemajo Avtor naveden v pogovornem oknu View Log nad za isto revizijo. To je zato, ker pogovorna seznami View Log prijavljen uporabnik v času od zavezati pogovorna seznami revizijska sled, medtem ko je prijavljeni uporabnik v času akcije uporabnika, in je možno, da ima en uporabnik naredi spremembe in pošljejo svoje. Spremembe datoteko drugemu uporabniku zavezati - kot je to v primeru, ko je zunanji uporabnik (kot Avolution) za delo na projektu EE.

Podrobnosti: The Podrobnosti stolpcu so navedene natančne podrobnosti o ukrepih, ki uporabnika, kot je zapisano na strežniku Enterprise.

Nasvet

Koristno je skupina s kolono dopolnjene (kot je prikazano v oknu zgoraj) in / ali uporabniku Action stolpec da enostavno razvrstiti spremembe element obresti.

Uporaba Scripting z datotekami za podjetništvo

Če uporabljate skriptov z datotekami za podjetništvo, se morate zavedati, kako pravilno zbrisati predmet iz modela. Na splošno, ko ste izbrisali predmet, boš poklical metodo .Delete () na njem, namesto da samo ga vzamete iz njegovega matičnega podjetja.

Npr če bi comp1 kot starša comp2 in želite izbrisati comp2 v vašem scenariju, bi morali poklicati comp2.Delete (), namesto comp1.Components.Remove (comp2).

Uporabite lahko odstranite, če nameravate dodati comp2 predmet na drugo mesto v arhitekturi, vendar se ga ne sme uporabljati, če je njen namen, da izbrišete predmet.

Obstaja izjema, da je to, za takrat, ko želite odstraniti predmet, ki "živi" drugod po modelu. Ko želite odstraniti standardni primerek iz arhitekture / sestavnem delu / zvezi, potem bi to storite tako, da ga vzamete iz primerku običajna zbirka - arch1.Izvedb.Demonta A (imp) - ker ga izbrisali, bi ga odstranili iz vseh primerov.

Pravilno uporabo Delete v skripti je pomembno, ker če je objekt odstrani iz objectmodel in ne ponovno dodal, potem ne bo mogel biti nameščen, ker pa ni bilo posebej "črta", zaznavanje in reševanje konfliktov ne bo pravilno zaznati konflikt, če je bil drug uporabnik, da bi poskušali uporabiti ta predmet v katerem koli od njihovih sprememb, in končni rezultat bo poškodovan sklop sprememb za tega uporabnika.

Poglej tudi

Kako se arhitektura zastopana v ABACUS?


Delo z ABACUS datotek

Navigacija: Uvod v ABACUS>

Delo z ABACUS datotek

Pošlji komentarje o tej temi.

ABACUS datoteka je posoda za model vašega arhitektura . V enem samem ABACUS datoteke, lahko model poljubno število arhitektur poljubno število krat.

Ko prvič odprete ABACUS, ni datoteke odprte. Za delo na vašem arhitekture, boste morali bodisi ustvarite novo datoteko, ali odpreti obstoječo datoteko.

Ko odprete ali ustvarite novo datoteko, se bo drevo v okno raziskovalec samodejno prikaže. Ta pogled explorer vam pokaže svojo arhitekturo na dan. Ko zaprete datoteko, se bo drevo v okno raziskovalec tudi izginejo.

Če želite ustvariti novo ABACUS datoteko

1. Izberite mapa| New ...

2. V pogovornem oknu New Project, ki se pojavi (kot je prikazano spodaj) Izberitebodisi ustvariti prazen modela, model iz standardno knjižnico ABACUS , Model od meri ABACUS knjižnice, model iz XML, MS Access , MS Visio , MS Excel , MS SQL Server An Enterprise Server Model ali po meri ABACUS knjižnica (.abacuslib datoteka).

3. Kliknite na v redugumb in sledite morebitna odprta pogovorna okna, ki se lahko pojavijo.

Nasvet

Vam ne bo vprašal za ime datoteke, dokler ne shranite ali pa ga zaprete. To je dobra ideja, da shranite datoteko takoj, ko ste jo ustvarili. Potem vam ne bo treba skrbeti, da jo poimenujete kasneje v postopku, ko ste se osredotoča na druge zapletene stvari (kot so poselitev svojo arhitekturo).

Ustvari nov projekt

ABACUS Standardne knjižnice

ABACUS podpira več 100 javne okvire in notacije nekateri, ki so prikazani spodaj. Pri izbiri ustvariti nov projekt iz imajo standardno uporabniki knjižnic hiter začetek za modeliranje v okviru vzpostavitve okvira, pri čemer v celoti izkoristiti vseh opredeljenih vrst elementov, atributov, zapiske, stališča in predloge ali vzorce. Dodatne standardne knjižnice so prosto na voljo prek Avolution Skupnosti tukaj .

New Project iz standardne knjižnice

Če želite shraniti novo ABACUS datoteko

1. Izberite mapa| Shrani kot

Nasvet

Imena datotek lahko katero koli dolžino, in lahko vsebujejo nobenih alfanumeričnih znakov in presledke. Oni ne morejo vsebovati Tilda (~) značaj, cev (|) značaj, vprašanje, znamke ali znakov običajno uporablja za opise poti, kot je poševnico nazaj (\) - razen kot del poti (?).

Če želite odpreti obstoječo datoteko ABACUS

1. Izberite mapa| Odpri

Opomba

Če želite odpreti datoteko iz omrežnega mesta v skupni rabi, ki je že odprt za drugega uporabnika, bo ABACUS vam dostop samo za branje. Pri uporabi ABACUS z dostop samo za branje, ne boste mogli izvesti operacije pisanja, kot poselitev svojo arhitekturo in teče ocenjevalcev. Lahko pa si ogledate arhitekturo pomočjo pogled Explorer in 3D pogled.

Poglej tudi

Kako se arhitektura zastopana v ABACUS?


Delo z namizij

Navigacija: Uprava>

Delo z namizij

Pošlji komentarje o tej temi.

Projekti ABACUS ima lahko katero koli konfiguracijo stališč (npr diagrami, Grafikoni itd) privarčevane kot armaturni plošči in te shranjene namizij je lahko nastavljen kot privzeti zagon 'zaslon' na odprtju projekta in / ali dodeljen poseben skupina uporabnikov in predstavili članom te skupine uporabnikov, ko se prijavite v projektu ABACUS.

Opomba

Če želite konfigurirati namizij v projektu ABACUS licenca uporabnik potrebuje sposobnost skrbnika. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

Pregled armaturne plošče

Primer Application Portfolio Management (APM) dashboard

Prikaz shranjenega Dashboard

1. Izberite Poglej| Namizij

2. Izberite shranjeno armaturno ploščo s seznama razpoložljivih namizij.

Opomba

Ko izbrani ABACUS bo gradil stališča, potrebne za armaturno ploščo in to lahko traja nekaj sekund. Prosim, bodite potrpežljivi.

Upravljanje namizij

Upravljanje namizij

Če želite ustvariti nov Dashboard

1. Odprite zahtevane poglede in urediti in dock okna, kot se zahteva za armaturno ploščo.

2. Izberite Poglej| Namizij| Upravljanje namizij ...

Opomba

Če ne vidite menija Upravljanje namizij, potem ne boste imeli sposobnost skrbnika. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

3. V pogovornem oknu, ki se prikaže, izberite Ustvarjanjegumb in vnesite ime Dashboard v pogovornem oknu Create New Dashboard.

4. Kliknite na v redugumb.

Če želite izbrisati obstoječi Dashboard

1. Izberite Poglej| Namizij| Upravljanje namizij ...

2. V pogovornem oknu, ki se prikaže, izberite Dashboard, ki ga želite izbrisati iz seznama in izberite Izbrišigumb.

Opomba

Brisanje armaturno ploščo, boste izbrisali tudi vse uporabniške skupine naloge na tej plošči.

3. Kliknite na v redugumb.

Za nadomestitev obstoječega Dashboard

1. Odprite zahtevane poglede in urediti in dock okna, kot se zahteva za nadomestno armaturno ploščo.

2. Izberite Poglej| Namizij| Upravljanje namizij ...

3. V pogovornem oknu, ki se prikaže izberite Dashboard, ki ga želite zamenjati s seznama in izberite Zamenjajgumb.

4. Kliknite na v redugumb, da potrdite pogovorno okno Dashboard Zamenjano.

Dodeliti Dashboardkot privzeti začetnega zaslona

1. Izberite Poglej| Namizij| Upravljanje namizij ...

2. V pogovornem oknu, ki se prikaže, izberite Nadzorna plošča iz seznama, ki ga želite dodeliti kot privzeti Start "zaslon"in izberite Dodeli ...gumb.

3. V pogovornem oknu, ki se prikaže, izberite vpis v stolpcu Uporabniške skupine.

Opomba

Samo ena Armaturna plošča se lahko dodeli kot začeti "zaslon", tako da bo ponovno dodelitev odstraniti nalogo iz prejšnjega armaturni plošči.Poleg tega, če se uporabnik prijavi v kot člana skupine uporabnikov, ki ima dodeljeno armaturno ploščo, potem bo dodeljena armaturna plošča odprli namesto privzetega projekta armaturni plošči.

4. Kliknite na v redugumb.

Če želite dodeliti User Group na nadzorno ploščo

1. Izberite Poglej| Namizij| Upravljanje namizij ...

2. V pogovornem oknu, ki se prikaže, izberite Nadzorna plošča iz seznama želite dodeliti uporabniško skupino v in izberite Dodeli ...gumb.

3. V pogovornem oknu, ki se prikaže, izberite User Group (ali skupine)želite dodeliti armaturno ploščo kot "start up" zaslonu.

Opomba

Če se ista User Group dodeljena več namizij, potem bo uporabljena prva naloga na seznamu.

4. Kliknite na v redugumb.

Za preklic dodelitve uporabniško skupino iz Dashboard

1. Izberite Poglej| Namizij| Upravljanje namizij ...

2. V pogovornem oknu, ki se pojavi razširite element Dashboard iz seznama želite prekličite skupino uporabnikov iz.

3. Izberite uporabniško skupino, ki jo želite preklic dodelitve in izberite Preklic dodelitvegumb.

4. Kliknite na v redugumb.

Nastavitev dovoljenj

Dovoljenja je mogoče nastaviti za namizij, ki omogoča da je armaturna plošča viden, Ažurirati in / ali deleteablena dane uporabniških skupin.

Dovoljenja za upravljanje

Če želite nastaviti dovoljenja za nadzorno ploščo

1. Izberite Poglej| Namizij| Upravljanje namizij ...

2. V pogovornem oknu, ki se prikaže, izberite Nadzorna plošča s seznama, ki ga želite nastaviti dovoljenja za in izberite Dovoljenja ...gumb.

3. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

4. Privzeto boste videli, da so branje, posodabljanje in brisanje dovoljenja vsem na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

5. Kliknite na v redugumb.

Poglej tudi

Prilagajanje vmesnika ABACUS | Delo z dovoljenji


Delo z dovoljenji

Navigacija: Uprava>

Delo z dovoljenji

Pošlji komentarje o tej temi.

Projekti ABACUS lahko ki temelji na vlogiDovoljenja, določene za vsak element v skladišču. Natančneje, drobnozrnatega Create-Read-Update-DIzbriši (CRUD) Dovoljenja je mogoče nastaviti na "cilj" (tj sestavni del ali povezave), pogled in atribut (tj lastnine) v serumu.

Pregled

Pri delu z ABACUS Enterprise Server , ABACUS zagotavlja drobnozrnatih, ki temelji na vlogo izraze dovoljenja za nadzor dostopa več uporabnikov do skladišča.

Opomba

Če želite nastaviti dovoljenja v projektu ABACUS licenca uporabnik potrebuje sposobnost skrbnika. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

Dovoljenja je mogoče nastaviti za arhitekture, vrste sestavnih in povezovalnih, lastnosti (prek svojih vrstah), predloge, stališča in diagrami, katalogi, matrike, karte in 3Dogledov. Ko so dovoljenja nastavljen za tip sestavnega dela ali povezave vse primerke te vrste v vseh arhitekturah v tem projektu "podedujejo" teh dovoljenj. Prav tako, ko se dovoljenje nastavljen za nepremičnine tip sestavnega dela ali povezave, danega premoženja na primere, ki sestavljajo ali povezave v vseh arhitektur v tem projektu "podedujejo" teh dovoljenj. Skladno s tem bodo nekateri dovoljenja se uporablja za stališč, na katerih obstajajo ti elementi. Ko so dovoljenja določena za shemo, po mnenju in / ali vsebine po mnenju same imajo različne dovoljenja uporabljajo za to.

Opomba

Privzeto so brez dovoljenja določene za elemente v okviru projekta ABACUS. To je vse elementi so Createable, berljivi, ažurirati in Deleteable vsem uporabnikom. Na ta način je treba upoštevati dovoljenja le določen element v skladišču, ko je bila določena dovoljenje omejenaza določeno skupino uporabnikov. Na primer, če dodamo dovoljenja za posamezno skupino uporabniškem do objekta (npr tip sestavnega dela), vendar ostane omogočena vsem dovoljenja, potem je to funkcionalno enako, kot če bi uporabnik stroja Ni bilo doda objekta.

Dovoljenja ne morese določijo za posebne primere elementov arhitekture je. Na primer, ne morete narediti eno komponento Application ažurirati še drugo ne. Za učinkovito doseganje teh "domenskih posebne" dovoljenja pa lahko administrator ustanovi posebne vrste elementov za dane domene, npr Vrste strani komponenta "Application - CRM domena" in "Application - HR domene", nato pa nastavite dovoljenja za vsako vrsto v skladu s tem. Lahko naredite posebne vrste združenje za vsako domeno in nato odstranite posodobitev dovoljenja za vrsto skupine domensko specifični in to bo omejila kreacije znotraj in izbrisi iz navedenega združenja, ne pa posodobiti otrok. Seveda, če je bila skupina domensko specifičnih skrita z odstranitvijo branju dovoljenje, potem bi se otroci skrita in s tem ni mogoče posodobiti. Druga možnost je, če so pogledi (namesto raziskovalec), ki se uporabljajo predvsem za upravljanje / si ogledate skladišče, je treba določiti glede prikaza za vsako domeno, potem pa lahko administrator ustrezno nastaviti dovoljenja za vsak pogled.

Upravljanje uporabnikov in skupin

Dovoljenja so opredeljena na Vlogaali skupinaraven, za razliko od ravni posameznega uporabnika, tako, da medtem ko lahko članstvo skupin spremeniti, lahko pritrdi ostanejo dovoljenja. Seveda, če hočeš posebno uporabnik dovoljenje, nato pa preprosto, da jim skupino, ali natančneje ustvarite skupino s tem uporabniku kot edinega družbenika.

Opozoriti je treba, da so skupine atomska, Da se ta ne more dedovati dovoljenja ali uporabnike, od enega do drugega, in če uporabnik spada v več skupin, potem bo najbolj "pesimistični" skupina dovoljenje prednost od primera do primera za vsako posamezno dovoljenja (tj Ustvari PREBERI-Update-Delete). Na primer, če je isti uporabnik je član skupine A in skupine B in skupine A je pravkar Create-Read dovoljenje za tipe sestavnih aplikacij, medtem ko skupina B je samo za branje Update dovoljenje za tipe komponent Application nato uporabnik bo le prebral dovoljenje za Sestavni Uporaba primerkov.

Poleg tega, ki ga privzeto, anonimni uporabniki(to je uporabnikom, ki niso bili opredeljeni ali ki niso vpisani v) imajo popoln dostopk projektu. To je zagotoviti, da je dostop je na voljo v začetni konfiguraciji. Če želite blokirati dostop anonimnim uporabnikom preprosto počistite "Dovoli anonimni uporabnik poln dostop do spisa" možnost v upravljanje uporabnikov / skupin pogovornem prikazano spodaj. Ko bo nepreverjene anonimni uporabniki lahko videli del standardov koli projekta samo.

Končno, če je možnost "uporabo Windows uporabniško ime Prijava 'preveri uporabniško ime overjanje izvede pred Windows uporabnik Uporabniško ime prepričevalnost na vsakega uporabnika stroj proti uporabniško ime je vpisana kot na spodaj. To je, če je Windows ime Prijava za dano uporabnikovem računalniku obstaja kot veljavno uporabniško ime, potem se ne zahteva geslo in uporabnik se samodejno potrjen. Opomba: ta dejansko omogoča uporabo Windows Active Directory (AD), preverjanje pristnosti.

Opomba

Glede na to, da dovoljenja, so opredeljeni samo takrat, ko jih je treba odvzeti (omejeno) od uporabnika, vsak uporabnik, ki ni član skupine, ali katerakoli skupina, ki nima dovoljenja, določene za to pred vsemi predmeti, bodo imeli popoln dostop do projekt.

Uporabniki in Skupine uporabnikov

Če želite ustvariti novega uporabnika

1. Izberite mapa| Upravljanje Uporabniki / Skupine

Opomba

Če ne vidite Manage Users / Skupine menija potem ne boste imeli sposobnost skrbnika. Se obrnite na lokalnega ABACUS Administrator ali Avolution Podpora če potrebujete te sposobnosti.

2. V pogovornem oknu, ki se prikaže, izberite Dodaj uporabnikagumb in vnesite uporabniško ime in geslo v pogovornem oknu Ustvari novega uporabnika. Opomba: imena in gesla za uporabnike in male črke.

Opomba

Če je možnost "uporabo Windows uporabniško ime Prijava" preveriti, kot je opisano zgoraj, nato pa se izvede navidezni Geslo je lahko vnesena kot avtentikacijo bo izvedena v skladu z uporabnikovo Window ime samo Login.

2. Privzeto boste videli, da je Uporabniki lahko spremenite svoje geslo. Če je potrebno, se lahko ABACUS Administrator odstrani sposobnost za uporabnike, da določijo svoje geslo s Izklop tega poljapotrditvena polja.

Opomba

Če lahko uporabniki spremenijo svoje geslo bodo imeli Datoteka | Spremeni geslo...menu item, da to storijo.Prav tako se zavedamo, da če je več ljudi uporablja isto uporabniško ime, potem lahko en uporabnik spremeniti geslo, tako da ne more priti do drugih ljudi, kasneje prijavim. Skladno s tem se priporoča, da praksa, da imajo single username na dejansko osebo.

4. Želji, vnesite e-poštni naslov, Kraj in Telefonska številka za uporabnike, za poznejšo uporabo.

5. Kliknite na v redugumb v pogovornem oknu Ustvari novega uporabnika.

6. Kliknite na v redugumb.

Opomba

Ko ste ustvarili svoj prvi uporabnik, morate razmisliti blokira dostop anonimnim uporabnikom ga počistite "Dovoli anonimni uporabnik poln dostop do spisa" možnost v pogovornem oknu Manage Uporabniki / Skupine.Tudi, ko je uporabnik ustvaril (in če projekt Enterprise, sprememba zavezala, da bo strežnik), naslednjič, ko je projekt odprt uporabniki bodo pozvani, da Prijava za preverjeni dostopkot na oknu je prikazan spodaj. Če Samodejno prijavo s temi podrobnostmiMožnost se nato preveri uporabniško ime / kombinacija geslo bo spomnil na projekt in uporabi vsakič ob odpiranju. Če želite zbrisati shranjene login select Datoteka | Jasno Shranjeni Prijavapo odprtju in vas bodo pozvani, da prijavo spet naslednjič, ko odprete projekt.

Vpiši se

Če želite izbrisati obstoječe uporabnike

1. Izberite mapa| Upravljanje Uporabniki / Skupine

2. V pogovornem oknu, ki se prikaže, izberite uporabniško ime na plošči uporabnikov, ki ga želite izbrisati, in nato izberite Izbriši uporabnikagumb.

3. Kliknite na v redugumb.

Če želite ustvariti novo skupino

1. Izberite mapa| Upravljanje Uporabniki / Skupine

2. V pogovornem oknu, ki se prikaže, izberite Dodaj skupinogumb in vnesite ime skupine na plošči skupine.

Opomba

Imena skupin morajo biti unikatna.

3. Kliknite na v redugumb.

Če želite Kopiranje obstoječeSkupina

1. Izberite mapa| Upravljanje Uporabniki / Skupine

2. V pogovornem oknu, ki se prikaže, izberite KopirajSkupinagumb.

Opomba

Dvojnik skupina bo ustvarjena predpono "Kopija".Privzeto bodo vsi dovoljenja iz kopiranega skupine podvajajo za "Kopija" skupine, vključno s katero koli nalogo uporabnika.

3. Preimenovati "Kopija" skupine, kot je primerno, s pomočjo Edit Groupali počasi dvokliknite.

Če želite izbrisati obstoječo skupino

1. Izberite mapa| Upravljanje Uporabniki / Skupine

2. V pogovornem oknu, ki se prikaže, izberite ime skupine na plošči skupine, ki ga želite izbrisati, in nato izberite Izbriši skupinogumb.

Opomba

Vsak uporabnik naloge v skupini bo tudi odstraniti.

3. Kliknite na v redugumb.

Za dodelitev uporabnika v skupini

1. Izberite mapa| Upravljanje Uporabniki / Skupine

2. V pogovornem oknu, ki se prikaže, izberite uporabniško ime na plošči uporabnikov, ki ga želite dodeliti skupini in povleci in spustije na ime skupine na plošči skupine, ki ga želite dodeliti.

3. Kliknite na v redugumb.

Opomba

Skupina (i), da se uporabnik dodeli so prikazane z razširitvijo Uporabniško ime na plošči Uporabnikiin uporabniki, ki so jim dodeljene skupini so prikazane z razširitvijo ime skupine na plošči skupine. Na primer, v zgoraj sliki, je "AS1-Aus" uporabnik dodeljena treh (3) skupine, in sicer; "App Support Team 1", "Dejanska" in "Avstralija".

Za preklic dodelitve za uporabnike iz skupine

1. Izberite mapa| Upravljanje Uporabniki / Skupine

2. V pogovornem oknu, ki se pojavi tudi širite ime skupine, ki vsebuje odstop uporabnika, ki ga želite preklic dodelitve in izberite uporabniško ime.

3. Kliknite na Prekličite Uporabnikgumb.

4. Kliknite na v redugumb.

Če želite uvoziti uporabnike in / ali skupin (in vse ujemajoče dovoljenj)

1. Izberite mapa| Upravljanje Uporabniki / Skupine

2. Kliknite na Uvozgumb.

3. V pogovornem oknu, ki se prikaže Brskanjein odprite projekt ABACUS ki vsebuje uporabnike in / ali skupine (in dovoljenja), ki jih želite uvoziti v trenutnem projektu in kliknite Odpri. Uporabniki in skupine bodo uvoženi in se pojavi pogovorno okno Uvoz Rezultati povzema uvoz uporabnike in / ali skupin. Kliknite na v redugumb.

Opomba

Če uvoženi Uporabniki ali Skupine, obstajale že v tekočem projektu bo nato jih združila z obstoječimi uporabnike ali skupine.

4. Kliknite na v redugumb za nazaj v glavni Manage Users okno / Skupine.

5. Če obstajajo tipi ujemanja, Stališča, predloge ali Arhitekture med sedanjega projekta in projekta ABACUS ste uvoznice, skupaj z dovoljenji, ki še ne obstajajo v trenutnem projektu, so dovoljenja uvažajo in pogovorno drugi Uvozna Rezultati Zdi se povzema uvoz. Kliknite na v redugumb.

Opomba

Dovoljenja so dodane le obstoječim vrst (in njihovih lastnosti), Stališča, predloge ali arhitektur za skupine, kjer se dovoljenja ni že obstajajo za skupino. Bodisi zato, ker je Skupina je nov ali je skupina že obstajala v trenutnem projektu, vendar ni Dovoljenja so bila dodeljena za to skupino za to postavko. Ni "združitev" dovoljenj za zadetka kjer dovoljenj že obstajali za skupino v trenutnem projektu.

Nastavitev dovoljenj

Dovoljenja je mogoče nastaviti za arhitekture, vrste sestavnih in povezovalnih, lastnosti (prek svojih vrstah), predloge, stališča in diagrami, katalogi, matrike, karted 3Dogledov. Ko so dovoljenja nastavljen za tip sestavnega dela ali povezave vse primerke te vrste v vseh arhitekturah v tem projektu "podedujejo" teh dovoljenj. Prav tako, ko se dovoljenje nastavljen za nepremičnine tip sestavnega dela ali povezave, danega premoženja na primere, ki sestavljajo ali povezave v vseh arhitektur v tem projektu "podedujejo" teh dovoljenj. Skladno s tem bodo nekateri dovoljenja se uporablja za stališč, na katerih obstajajo ti elementi. Ko so dovoljenja določena za shemo, po mnenju in / ali vsebine po mnenju same imajo različne dovoljenja uporabljajo za to.

Dovoljenja za upravljanje

Če želite nastaviti dovoljenja za komponento (ali Connection) Tip

1. Razširiti Vrsteveja drevesa.

2. Razširiti Komponento (ali povezave) Vrsteveja drevesa.

3. Razširi Skupinekadar je to potrebno.

4. Desni kliko Komponenta (ali Connection) Tipželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

5. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

6. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

Opomba

Ustvarite dovoljenje ureja tudi ko lahko kopirate element. Zato, da bi lahko kopirate element zahteva Ustvarite dovoljenje za vse svoje otroke (od kopirati element pomeni kopiranje vse pod njim). Odstranjevanje Update dovoljenje elementa odpravlja možnost, da spremenite tip sam, tudi če ima uporabnik Designer add-on in ga Prav tako odpravlja Update dovoljenje za vse svoje lastnosti. Staršev element mora imeti Update dovoljenje, da bi lahko Ustvarite nobenih otrok elemente ali Izbriši ITS obstoječe otroci elementi. Izbriši dovoljenje za element zahteva tudi brisati dovoljenje za vse svoje otroke. Izbriši dovoljenje za komponente zahteva tudi posodobitev dovoljenja vseh priloženih priključkov.In končno, odstranjevanje Izbriši dovoljenje z elementa odstrani zmožnost brisanja tip sam, tudi če ima uporabnik Designer dodatek.

7. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za skupino komponente (ali Connection) Vrste

1. Razširiti Vrsteveja drevesa.

2. Razširiti Komponento (ali povezave) Vrsteveja drevesa.

3. Desni kliko Skupinaki vsebuje komponento (ali povezave) vrste, ki jih želite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

6. Kliknite na v redugumb.

7. V pogovornem oknu, ki se prikaže, kliknite Dagumb.

Če želite nastaviti dovoljenja za lastnino

1. Razširiti Vrsteveja drevesa.

2. Razširiti Komponento (ali povezave) Vrsteveja drevesa.

3. Razširi Skupinekadar je to potrebno.

4. Izberite Component (ali Connection) Tip, ki vsebuje lastnost, ki jo želite nastavljenih dovoljenj za.

5. V oknu Lastnosti desni kliko Nepremičnineželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

6. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

7. Privzeto boste videli, da so prebrali in posodabljanje dovoljenj vsem na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

Opomba

Lastnosti, ki so imeli dovoljenje za posodobitev odstranili so prikazani v ležečeV oknu Lastnostiin njihove vrednosti ni mogoče posodobiti s to vlogo. Tudi sposobnost spremenite podrobnosti nepremičnine (na primer ime, enote itd) zahteva tako Update dovoljenje na nepremičnine in Designer add-on.

8. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za predlogo

1. Razširiti Predlogeveja drevesa.

2. Brskanje na Predlogaki vas zanima.

3. Desni kliko Predlogaželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je na voljo za branje dovoljenje. Odstranite dovoljenje, ki ga Izklop tega poljapotrditveno polje.

6. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za Viewpoint

1. Razširiti Stališčaveja drevesa.

2. Razširi Skupinekadar je to potrebno.

3. Desni kliko Vaše mnenježelite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

6. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za arhitekturo

1. Razširiti Arhitektureveja drevesa.

2. Razširiti na Arhitekturaki vas zanima.

3. Desni kliko Arhitekturaželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je na voljo za branje dovoljenje. Odstranite dovoljenje, ki ga Izklop tega poljapotrditveno polje.

6. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za A Katalog

1. Razširiti Katalogiveja arhitekture vas zanima.

2. Razširi Skupinekadar je to potrebno.

3. Desni kliko Katalogželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

6. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za A Matrix

1. Razširiti Matrikeveja arhitekture vas zanima.

2. Razširi Skupinekadar je to potrebno.

3. Desni kliko Matrixželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

6. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za sliki

1. Razširiti Diagramiveja arhitekture vas zanima.

2. Razširi Skupinekadar je to potrebno.

3. Desni kliko Diagramželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

Opomba

Medtem ko lahko nastavite dovoljenja izraze neposredno diagram, je treba opozoriti, da se lahko dovoljenja elementov na diagramu vpliva dovoljenja za pogled sam. Na primer, če je celo samo en element na stališču, da je imel svojo prebere ali ažurira dovoljenje odstranjeno potem bo diagram imela njena Update dovoljenje odstraniti. To je zato, ker; a) elementi, na stališče, da so imeli njihovi Preberite dovoljenje odstranjen ne bo prikazan na prikazu zapusti "presledek", kjer boste lahko drugače postavili nekaj novih elementov, če je pogled posodabljati, in b) elementi na stališču, da so jim Update dovoljenje odstranili lahko potem še druge elemente, padla na njih, da postanejo otroci, če je pogled posodabljati. Tudi Ustvari in Update dovoljenje za diagramu zahteva, da imajo vsi elementi na pogled brati dovoljenje in komponente še dovoljenja Update (to pa zato, ker se premaknete komponento na drugo komponento, morate biti sposobni, da ga dopolni, saj bo postati otroka).

6. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za ogled 3D

1. Razširiti 3D Viewsveja arhitekture vas zanima.

2. Razširi Skupinekadar je to potrebno.

3. Desni kliko 3D pogledželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

6. Kliknite na v redugumb.

Če želite nastaviti dovoljenja za A Graf

1. Razširiti Chartsveja arhitekture vas zanima.

2. Razširi Skupinekadar je to potrebno.

3. Desni kliko Grafželite nastaviti dovoljenja za in izberite Uredi Dovoljenja.

4. V pogovornem oknu, ki se odpre, kliknite na Dodaj ...gumb in izberite Skupinaželite dodati bodisi z dvojnim klikom ali pa ga izberete in kliknete v redugumb.

5. Privzeto boste videli, da je ustvarjanje, branje, posodabljanje in brisanje dovoljenja so na voljo. Odstranite dovoljenja, ki jih Izklop tega poljaustrezna potrditvena polja.

6. Kliknite na v redugumb.

Poglej tudi

Kako se arhitektura zastopana v ABACUS?


Pisanje skript

Navigacija: Simuliranje svojo arhitekturo>

Pisanje skript

Pošlji komentarje o tej temi.

Script Editor je enostaven in funkcionalen pripomoček za pisanje in izvajanje VB ali C # script proti trenutno odprta ABACUS datoteka(Se knjižnice ne podpira skriptni). To je običajno Datoteka odpiranje, zapiranje in Save ukazov, tako da lahko shranite in naložite skripte pišete. Prav tako ima osnovno tek in debug objekt. Script Manager vam omogoča, da enostavno izvesti različne skripte, ki ste jih napisali postavite menija-element za njih neposredno v meniju Orodja.

Za dostop do Script Editor

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Izberite Orodja | Script Editorin okno Script Editor se odpre. Potem;

3. Odprite obstoječi skript preko mapa | Odpri v menijih Script Editor,

ali

3. Odprite Primer scenarij prek Primer postavka v menijih Script Editor,

ali

3. Nastavite privzeti jezik bodisi VB ali C # preko Language postavka v menijih Script Editor,

ali

3. Odpri skriptni posebno pomoč preko Pomaga postavka v menijih Script Editor

Pri pisanju scenarijev, morate držati bodisi VB ali C # sintaksakot na nastavitev v postavki jezika v menijih Script Editor.

OPOMBA:

· Uporabiti standardne VB funkcije, kot so MsgBox ()vam mora vsebovati Uvoz Microsoft.VisualBasicIzjava na začetku skripta. To ni bilo potrebno pred različico 3.0 ABACUS.

· Ta pomoč ne vključuje informacije o tem, kako napisati VB skript, niti ne vsebuje sklicevanja na VB. Vas prosimo, da napišete skript v vaš najljubši IDE ali urednik, nato kopirajte in jih prilepite v urejevalniku scenarija.

Ko prvič zaženete Script Editor, bo Script Editor prazna. Lahko dostop do skelet skript preko menija primerov. Ko prvič zaženete Script Editor, morate zagnati okostje Template videti, da deluje. Poleg tega obstajata dve primer skripte, ki se lahko dostopate preko menija primerov.

Če želite napisati uporabno skripto boste morali reference ABACUS ObjectModel. Narejen je na voljo za vaš scenarij, ki ga vključno z Uvoz ABACUS.ObjectModelIzjava na čelu skripta. Popolna sklicevanje na celotno ABACUS objektni model je vključen v Script Editor. Najdete ga tako, da izberete Pomagaj | Vsebinaiz okna Script Editor.

Urednikom scenarija vključuje številne uporabne funkcije za pisanje scenarijev, vključno Samodokončaj kot je prikazano na sliki spodaj. Vendar pa je za še bogatejšo uporabniško izkušnjo lahko MS Visual Studio biti integrirana z ABACUS in podrobna navodila so na voljo tukaj .

Script Editor z dopolnjevanjem besed

Za uporabo Script Manager

1. Zagotovite, da imate datoteka ABACUS, Ki vsebujejo vaših naseljeno arhitekturo, open.

2. Izberite Orodja | Script Manager.

3. Kliknite na Dodajikona in OdpriPrikaže se okno.

4. Brskanje na ABACUS Script (.abacusscript, .vb Ali .cs) Datoteko, ki jo želite dodati, da v meniju Orodja.

5. Kliknite v reduin sklicevanje na skript bo prikazana v oknu Script Manager. Vnesite ime za scenarij, kot želite, da se pojavi v meniju Orodja. Opomba: Okno Script Manager lahko spreminjate velikost videti celotno pot, če je potrebno.

6. Ponovite korake 5/3ustvariti povezave do več ABACUS skripte.

7. Kliknite Zaprizapreti Script Manager in ugotavlja, da je scenarij (-i) ABACUS sedaj pojavil v meniju Orodja.

Če želite zagnati skript

Bodisi;

1. Odpri, vnesite ali kopirajte in prilepite v scenariju, ki ga želite zagnati, tako da je prikazan v glavnem oknu Script Editor.

2. Kliknite Rungumb.

3. Če je vaš scenarij vsebuje napake, bo Error Opis oddelek na dnu Script Editor naštejejo podrobnosti, vključno s številkami vrstic. OPOMBA: Vsak posameznik napaka v Error Opis oddelku, lahko z dvojnim klikom, da vas popeljejo v ustrezno vrstico v scenariju.

- Ali -

1. Izberite Orodjain potem Ime ABACUS Script element v meniju kot ustvarjena z Script Manager.

2. Če je vaš scenarij vsebuje napake, se bo Script Editor se odpre z vsebino scenarija je prikazan v glavnem oknu (poudarjeno na vrstici prvega napak) in napaka Opis odseka na dnu Script Editor bo izpisal podatke ali napako (-e), vključno s številkami vrstic. OPOMBA: Vsak posameznik napaka v Error Opis oddelku, lahko z dvojnim klikom, da vas popeljejo v ustrezno vrstico v scenariju.

Scripting prevajanjem Napake

Pripravljanja pride do napak, ko je sintaksa kode skript ni pravilna. Te napake bodo prikazani na dnu okna v razdelku napak, z opisom napake, in številko vrstice. To je številka linija, ki ločuje napako kompilacijo iz napaka (glej spodaj), ki pa ne bo imel številko vrstice. Pripravljanja napake lahko dvojno kliknili na skok in poudariti posebno postavko.

Scripting Runtime Napake (Pomembno)

Runtime napake pride, ko je bila koda skripta uspešno pripravijo brez napak, ampak se pojavi napaka na runtime (dalje glej primere navzdol). Runtime napake so pomembne, saj lahko povzroči poškodovane modelih, ko je ustvaril predmetov in se sklicujejo na druge predmete v modelu, same niso del modela (običajno zato, ker je prišlo do napaka pred kodo, ki bi jih dali v modelu nekje je bil izveden).

Če je vaš scenarij ustvarja predmete, ki jih je treba dodati na modelu, se lahko izognete korupcijo runtime napake povzročene z varčevanjem vaš scenarij, zapiranje skriptov, in ki izvaja angl sprememb, ki so jih ustvarili v pisavi (če je izvršitev skripta ni izpolnilo običajno ). Vendar pa obstajajo tudi drugi načini, da se prepreči kakršno koli korupcijo, ki se pojavljajo (glej spodaj). Opomba: Vse skripte, ki le berejo iz modela in ne pišejo z njim, so varna in ne bo povzročal nobenih težav, ne glede na to, ali runtime napake pride med njihovim izvajanjem.

Da bi preprečili korupcijo pri pisanju skriptno kodo, ki ustvarja predmete in jih dodajate v objektni model, se predlaga, da se predmeti dodajo vzorcem v najkrajšem možnem času, če se sklicujemo z drugimi predmeti.

Na primer, če ste ustvarili novo povezavo in 2 novi sestavni deli, in jih nato pritrdite skupaj, je najbolje, da ustvarite prvo komponento, jo dodajte v modelu, nato pa je drugi in ga dodati, in nato ustvarite povezavo in ga dodati, in nato končno ustvariti priloge. To pomeni, da so vsi objekti, ki so potrebni, da se v objectmodel preden se ustvari navezanost, so, če je bilo, da je napaka, da prekine izvajanje skript v modelu. Korupcija se lahko zgodi, če na primer, le povezava je bila dodana, pritrjuje, nato pa je prišlo do napaka, preden je skripta končno dodal nove komponente za model.Corruption lahko pojavi kadar koli predmet, ki se sklicuje drugega predmeta v objectmodel, je sam ne v objectmodel.

Primer runtime napake vključujejo:

· Referenčni objekt ni nastavljen na primerek predmeta - to se zgodi, ko je spremenljivka objekt null referenčna, in se uporablja metoda ali premoženje na ta predmet. Null reference lahko preverite tako: "Če objectVariable Je Nič Potem pa ..."

· Indeks je bil izven meja polja - to se zgodi, ko je matrika, ki dostopate z indeksom, ki je zunaj meja - na primer manj kot 0 ali enaka ali večja od dolžine / Štetje matrike. Array ali dolžina Zbiranje se lahko preveri s strani .Length ali .Count lastnosti oz.

· Ne Dovoljenje Izjema - Nimate dovoljenja za ... - ta pride, če nimate dovoljenja, da bi dano spremembo

· Primarni ključ Izjema - Duplicate / Manjka ime / ID - ta se bo zgodilo, če je sprememba na edinstveno lastnost, da je v nasprotju z drugega predmeta. Npr Arhitekture mora biti edinstven po imenu, prav tako s standardi.

· Referenčna integriteta Izjema - Nastavitev referenčno polje na predmet, ki ni veljaven. Npr dodal "nič" ali null kot otrok do številnih zbirk v objectmodel.

· Zero Dolžina Izjema - to se lahko zgodi, če poskusite nastaviti ime predmeta na prazen niz. Večina predmetov zahteva njihova imena, da imajo vsaj 1 znak.

Uvoz izkazi

Upoštevajte, da na začetku skeleta skripte so izjave, kot so Uvoz ABACUS.ObjectModel. Te izjave ne bo vsebovala dll, ki se že ne z dokazi, ki jih skripta - njihov namen je zagotoviti "bližnjico", da bi morali navesti celotno ime razreda.

Na primer, da razglasi spremenljivko tipa CComponent (ki predstavlja komponento v ABACUS), pri čemer je Uvoz ABACUS.ObjectModelIzjava proti vrhu scenarija, bi bilo treba samo, da se deklarirajo, kakor dim comp kot CComponent, Saj prevajalnik ve, da si v ABACUS.ObjectModel imenskem prostoru za razred CComponent. Brez izjavi uvoza, bi morala biti prijavljena kot dim comp kot ABACUS.ObjectModel.CComponent. Sestav (kot mscorlib.dll ali System.Windows.Forms.dll) lahko vsebuje več kot en imenski prostor - izjava Uvoz je za te imenskih, ne za sklope samih. Skupščina ABACUS.ObjectModel.dll ima samo enotno ABACUS.ObjectModel imenski prostor dostopen preko scripting.

Samodejno se sklicuje sklopi

Naslednje DLL samodejno sklicujejo Scripting:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (implicitno sklicujejo prevajalnik)

· ABACUS.ObjectModel.dll

Narediti dodatne reference bodisi drugih .NET sklopov, ali svojih skupščinah, glejte naslednje poglavje o #ImportDLL izjavo.

#Izjava ImportDLL

Od leta ABACUS 3.1, se lahko sklicujete dodatnih sklopov, ki se lahko zahtevajo za skriptno z uporabo znaka #ImportDLL izjavo. Na primer, če boste želeli dostopati po meri DLL tvoje in izkoristiti uporabnost v njej, bi si ga postavite v imeniku ABACUS in vključujejo izjavo, v prvi vrstici (e) v vašem scenariju. Če je .NET dll, potem običajno vam ni treba vnesti celotno pot, samo DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Nekatere druge stvari, upoštevajte:

1. Ker morajo DLL, ki se je pokazala ob prevajanju in runtime, to omejuje meri (non NET) DLL, da se postavi v samo programsko mapo ABACUS.

2. #ImportDLL izjave mora biti prva vrstica (i) scenarij - če imate 5 izjav, potem bi morali biti na prvih 5 vrstic skript

3. #ImportDLL izjavo postavi kjerkoli vendar prve vrstice scenarija (na primer, če je bilo dano po komentarja ali izjavo uvoza) ne bo delovala pravilno in / ali lahko povzroči nepovezanih napake prevajalnika.

#ImportDLL z Pisarniški skupščin

Če imate Microsoft Office nameščen, in vaš scenarij zahteva sklope Pisarna interoperabilnost Google, je mogoče, da jih reference preprosto z uporabo #ImportDLL z imenom montažo (kot je navedeno spodaj, npr #ImportDLL Excel). Z uporabo te metode ima to prednost, da absolutna dll pot nima, ki se uporablja, tako scenarij je bolj prenosni (bi moral delovati tako na Office 2003 in 2007, ne da bi urejanje skript).

Ko uporabljate to funkcijo, GAC (Svetovni zbor Cache) je iskal za montažo INTEROP in scenarij pripravlja s potjo do tega sklopa, če najdemo. Če je ne najde, bo skriptni preverite mapo programa ABACUS (ki vsebuje Excel in Visio interops samo). Če je zahtevana INTEROP v tem času ni bilo mogoče najti, se prikaže opozorilo.

V interops običajno niso nameščeni v GAC, če imate nameščen Microsoft Office, preden namestite .NET Framework (ki je del polno namestitev ABACUS). Lahko jih namestite z izvršitvijo možnost Change za Microsoft Office iz Dodaj / odstrani programe in izberite .NET možnosti programiranja. Za več informacij si oglejte to članek na MSDN.

Sklopi, za katere se podpira ta bližnjica so:

· Dostop

· Access.Dao

· Excel

· Graf

· MSProject

· Outlook

· OutlookViewCtl

· Owc11

· Power Point

· Založnik

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Beseda

It ni povsem jasno, če so vse zgoraj navedene sklope koristno, sobe havebeen vključeni v to funkcijo regardeless saj imajo nekateri uporabniki feb potrebo po celo prikriti sklopov.

Oglejte si tudi

Simulira svojo arhitekturo