Vad KULRAM göra?

Navigering: Introduktion till ABACUS>

Vad KULRAM göra?

Skicka kommentarer om detta ämne.

Om du behöver hjälp i andra språk / översättningar klicka här .

ABACUS tar gissa-arbete av att hantera lösningar, system, programvara, information, teknik, affärsprocesser och / eller hela företag (gemensamt benämnda arkitekturer). Det kan hjälpa dig att pragmatiskt utforma, övervaka, simulera, analysera och visualisera dina arkitektur genom modellering det, analysera det i intuitiva sätt (t.ex. tabeller, diagram och 3D) och därefter utvärdera den mot dina icke-funktionella krav.

Notera

Icke-funktionella kravär de krav som INTE relaterar direkt till hur en produkt fungerar. Istället är de intresserade av hur väl den fungerar. Icke-funktionella krav omfatta sådana saker som prestanda, öppenhet, utvecklingsförmåga, kvalitet, skalbarhet, modularitet, etc. (i motsats till funktionella krav som, slå på ljuset när den här knappen klickas). Traditionellt har icke-funktionella krav varit svårt - om inte omöjligt - att mäta. I själva verket är ABACUS den enda produkt som objektivt och kvantifierbart kan mäta tre första - prestanda, öppenhet, och utvecklingsförmåga.

Enkelt uttryckt, du anger arkitekturen och vad du behöver det för att göra. ABACUS berättar då du om det kommer att göra som krävs och påpekar eventuella svagheter eller luckor.

ABACUS bygger på över 20 års systemforskning och många fler år av etablerade systemteori. Det ger dig mätbara, tillförlitliga, objektiva svar, så att du inte förlita sig på en subjektiv bedömning.

ABACUS står för Architecture-Based ANALYS, CMEDDELANDET och Understanding av Systems. Det kan hjälpa dig med någon storskalig arkitektur, men det är allmänt används för fyra (4) saker:

· Evolvingen ström arkitektur. Till exempel, om din befintliga arkitekturen saknar prestanda, kommer ABACUS visualisera arkitekturen för dig, att identifiera problem (flaskhalsar, etc.), sedan berätta exakthur man kan förbättra arkitekturen.

· Designen ny arkitektur. Till exempel, om du behöver en helt ny arkitektur, och du skapar det själv, kommer ABACUS berätta exaktvilka komponenter du behöver och hur de ska anslutas.

· Köp aven ny arkitektur. Till exempel, om du har efterlyst anbud om utformningen av en ny arkitektur, och du väljer mellan tre mönster kommer ABACUS berätta exaktvilket som passar dina behov bäst.

· Kombinerandenuvarande befintliga arkitekturer. Till exempel, om du behöver kombinera två eller flera separata arkitekturer kommer ABACUS guida dig.

Se också

Hur du gör det (Översikt) | Vad är arkitektur? | Hur en arkitektur representerat i ABACUS?

© 2001-2015 Avolution Pty Ltd. All rights reserved.


Hur man använder ABACUS (Översikt)

Navigering: Introduktion till ABACUS>

Hur man använder ABACUS (Översikt)

Skicka kommentarer om detta ämne.

Det här avsnittet ger en grundläggande översikt över de uppgifter som ingår med hjälp av ABACUS.

Följande diagram illustrerar arkitekturen baserade analysprocess som ABACUS tillhandahåller utvecklas en ström arkitektur till en ny eller målarkitektur.

ABACUS Processen

Så här använder du ABACUS:

1. Granska - Innan du använder ABACUS, måste du samla all information du har om arkitekturen och dess krav.

· Arkitektur - Identifiera de potentiella komponenterna i arkitekturen och hur de samverkar. Det ska bara vara ett fåtal komponenter på den översta nivån. Dessa kallas "väsentliga delar". Även de mest komplexa arkitekturer bör ha mindre än 10 väsentliga komponenter. t.ex. De väsentliga komponenterna i ett försäkringsbolags arkitektur kan vara politik, kvitton, krav och betalningar.

· Krav- Du måste veta vad som förväntas av arkitekturen för att avgöra om det är tillfredställande. t.ex. Antal transaktioner per timme.

· Var hittar du den? - Denna information kan komma från kravspecifikationer, designdokument, intervjuer med berörda parter, den utvecklade koden, etc. I grund och botten något material som finns tillgängligt ger ABACUS information om arkitekturen.

2. Befolka -Använd ABACUS att modellera din arkitektur och för att specificera kraven arkitekturen kommer att mätas mot.

· Arkitektur - I ABACUS du börjar med en tom arkitektur - du måste befolka Det. Detta innebär in all arkitektur information som du samlat ovan. Du kan fylla din arkitektur manuellt (med hjälp av högerklicksmenyn), eller så kan du fylla den automatiskt (från Microsoft Visio, Excel, Access etc). Typiskt topp flesta nivåer (mer abstrakta) i arkitekturen kommer att befolkas manuellt och de lägre nivåerna (mer betong) kommer att befolkas automatiskt.

· Krav - När du lägger dina komponenter och anslutningar anger du deras egenskaper. I de flesta fall kommer dessa egenskaper att vara kraven i arkitekturen. Till exempel, om du kommer att ha en 1250 MIPS nod / kluster, skulle du lägga till noden som en komponent, sedan lägga till prestanda egendom och tilldela ett värde av 1250 MIPS.

3. Analysera - Använd ABACUS till elegant analysera och visualisera komplexa strukturen på din arkitektur. Dig kan analysera din arkitektur på ett antal sätt eller från ett antal synpunkter, inklusive diagram, 3D och Explorer. Alternativt kan du vill använda några mer specifika synpunkter på följande sätt:

· Diagram din arkitektur - för att få prestanda (svarstid, bandbredd, etc.), kostnad (bar, paj, etc.) eller utvecklingsförmåga (kapacitet utrymme, trade-off, etc.) vyer.

· Skapa en rapport om din arkitektur.

4. Simulera - Använd ABACUS att simulera din arkitektur prestanda, tillgänglighet, kostnad, öppenhet, etc.

· För att göra detta, kör en av simulatorer. ABACUS utvärderar din arkitektur mot dina kravgenom att utföra en simulering. Den läser och analyserar den nuvarande arkitektur, kör simuleringar, och beräknar en del nya egenskaper. Dessa egenskaper sparas sedan tillbaka till arkitekturen. De nya egenskaperna är de uppgifter du försöker analysera, såsom utnyttjande, svarstid, bandbredd,% tillgänglighet, TCO etc.

5. Ingenjör- Använd ABACUS att besvara olika "tänk om" scenarier och kontrollera utvecklingen av din arkitektur. Engineering är en process för att upprepa Fylla - Analysera - Simulera cykel.

· Vid det här laget, du"veförmodligen utvecklat en förståelse för den aktuella arkitektur och lyfte fram de områden du behöver för att utvecklas. Ganska ofta, men måste du upprepa fylla - Analysera - Simulera process ett antal gånger. Detta kommer troligen att bero på att det kan ta ett par iterationer innan du hittar Target Architecture. Dessutom, om din arkitektur är mycket komplex, kan du upprepa processen för varje arkitektoniska "nivå".

6. Planeraframtiden för din arkitektur med hjälp av information från ABACUS.

Notera

Om du inte försöker utveckla en befintlig arkitektur, kan du behöva upprepa några steg ett antal gånger, och i en annan ordning. Det beror på vad du försöker göra. Till exempel, om du designar en ny arkitektur, kommer du förmodligen bara fylla din arkitektur gång, och sedan använda ABACUS under en lång tid för att styra den framtida utvecklingen (er) av arkitekturen. Å andra sidan, om du köper en ny arkitektur och har flera alternativ att välja mellan, du behöver för att upptäcka och Fylla för varje alternativ, och sedan analysera och simulera varje oberoende innan du utför en slutlig jämförelse på avsluta.

Se också

Vad KULRAM göra? | Vad är arkitektur? | Hur en arkitektur representerat i ABACUS? | Fylla din arkitektur | Analysera din arkitektur | Simulera din arkitektur


Vad är arkitektur?

Navigering: Introduktion till ABACUS>

Vad är arkitektur?

Skicka kommentarer om detta ämne.

Arkitektur är en abstrakt begrepp- Inte en fysisk sak. Det är en rik och omfattande beskrivning eller förståelse av strukturen för ett system - fånga komponenter och hur de är anslutna (interagera). Eftersom begreppet arkitekturen är så allomfattande, är det grundläggande för kostnaden, tillgänglighet, utvecklingsförmåga, öppenhet och systemets prestanda. En sund arkitektur är en förutsättning för ett ljudsystem.

I ABACUS, du modell din arkitektur. För enkelhetens skull kallar vi detta arkitektoniska modell en arkitektur.

Diagrammet nedan visar en typisk arkitektur 5 ingående delar (i en hierarki) ansluten med 2 anslutningar. Etiketterna ange namn med tanke på de olika delarna av arkitekturen i ABACUS.

En enkel arkitektur

ABACUS anser alla dessa saker att vara en del av arkitekturen:

· Ingående delarrepresentera enheter din arkitektur som du kan beskriva som "saker". För ett försäkringsbolag, kan komponenterna vara system för behandling av politik, krav, utbetalningar och kvitton.

· Anslutningarrepresenterar förhållandet mellan dessa komponenter. Till exempel i ett försäkringsbolag, är Intäkter för giltiga politik är påståenden mot gällande politik och giltiga fordringar resulterar i betalningar. När man tänker arkitektoniskt - speciellt när du använder ABACUS - anslutningar är lika viktiga som komponenter, och de behandlas på ett nästan identiskt sätt.

· Allt i trädet kan ha Egenskaper. Egenskaper är saker som hur du behöver ditt system för att utföra, antalet rader kod har, den andel av dessa linjer som är kommentarer, etc. ABACUS anser alla dessa saker vara en del av arkitekturen.

· Genom att använda hierarkier(d.v.s. delkomponenter och underanslutningar), Kan du dölja information och de-komponera din arkitektur. ABACUS arkitektoniska modellen är extremt flexibel. Alla komponenter på alla nivåer kan relateras till någon annan komponent på någon annan nivå av någon koppling på alla nivåer.

· Fastsättningär driften av vilka komponenter hamnar är bundna till anslutningroller. Hamnar och Roller är gränssnittetsmellan komponenter och anslutningar. De används för att fästa anslutningar till komponenter. Anslutningar har en källa och en Sink roll(underlätta dataflödet från källkomponenten till sink komponenten)och konceptuellt, komponenter har portar. För enkelhets skull, men i ABACUS komponentportarna visas inte och anslutnings roller direkt knutna till själva komponenterna.

· Komponenter och anslutningar är av en viss Typ. Detta är främst för klassificeringen. Till exempel politik, krav, utbetalningar och intäkter är komponenter av typen "System". De giltiga politik, giltiga anspråk, etc. är anslutningar av typen "Transaktionen". Typ tilldelas en komponent eller anslutning ger en mall för fastigheterna och standarder har. Till exempel kan en typ serverkomponenten har "Gör & modell" standard-och en IP-adress egendom. Till skillnad från andra stela verktyg med en grundläggande relations databas (RDB) back-end i ABACUS kan du fritt skapa dina egna nya typer och tilldela dina egna kombinationer av egenskaper och standarder för dem.

· Standardbibliotek av fastigheter kan anges och tilldelas till något annat i arkitekturen. Dessa bibliotek är kända som Standarder. Genom att använda Standarder, Behöver du bara samla specifika system egenskaper - standardegenskaperna är redan där. Till exempel de vanliga egenskaper hos Microsoft Windows 2000 kan tilldelas till vad komponenter använder Microsoft Windows 2000 operativsystem.

Se också

Hur en arkitektur representerat i ABACUS? | Vad KULRAM göra? | Hur du gör det (Översikt) | Skapa en ny typ


ABACUS gränssnittet

Navigering: Introduktion till ABACUS>

ABACUS gränssnittet

Skicka kommentarer om detta ämne.

När du startar ABACUS, ser du huvudskärmen, vilket är tom med undantag för menyerna och verktygsfältet längst upp, en fönster tom Explorer och titelfältet. Den här skärmen kommer att vara navet i din interaktion med ABACUS.

De viktigaste inslagen är följande:

· huvudmenyerna

· verktygsfält

· högerklicksmenyn

· utforskaren och fastighets fönster

· statusfältet

Huvudmenyerna

Menyerna är ordnade i en logisk ordning.

Menyerna beskrivs på följande sätt;

· Arkiv-menyn- File menyn kan du skapa, öppna, stänga, spara, exportera och publicera ABACUS filer. Du kan också skapa, öppna, stänga och spara ABACUS Library filer.

· Redigera-menyn- Menyn Redigera gör det möjligt att klippa ut, kopiera, klistra in, ta bort, byta namn, hitta och sortera elementoch ångra / göra om verksamheten.

· Visa-menyn- Visa menyn kan du öppna eller stänga de olika gränssnitt Windows och statusfältetNavigera framåt och bakåt, gå till specifika vyer och hantera instrumentpaneler.

· Infoga-menyn- Infoga menyn kan du lägga till nya standarder, Mallar, typ, element, visapunkts, Kataloger, diagram, diagram, Rapporter och matriser.

· Analysmenyn- Analys menyn kan du köra utvärderingar mot en arkitektur inklusive; prestanda, kostnad, tillförlitlighet, modularitet och öppenhet.

· Verktyg-menyn- Menyn Verktyg kan du köra skript, uppsatta mål för arkitekturenoch utföra och arkitektur "diff". Du kan också ändra programmets alternativ och anpassa gränssnittet från verktygsmenyn.

· Fönster-menyn- Fönster menyn kan du docka, ordna, visa och dölja fönster du har öppna.

· Hjälp-menyn- Från Hjälp-menyn kan du komma åt den här ABACUS hjälpfilen. Du kan komma åt webbplatsen, se din licens avtal och visa allmänna uppgifter om ABACUS inklusive version av programvaran och ABACUS stöd och kontaktuppgifter. Du kan ge feedback via sidan frågan anmälan. Vid behov kan du skriva in en registreringsnyckeln via Hjälp-menyn.

Detta är den ordning du kommer oftast följa när du utför dina arbetsuppgifter;När du har skapat eller öppnat en filKommer du normalt fylla din arkitektur, sedan sedet (i Utforskaren, diagram, 3D, diagram, etc). Vid denna punkt, kommer du antingen köra en utvärderare, Eller om du ska upprepa processen med samma arkitektur eller en annan arkitektur. (Se Hur man använder ABACUS (Översikt) för ytterligare information.)

Ta en titt genom huvudmenyerna och försöka föreställa sig hur du ska tillämpa dem på ditt system.

Notera

Du kan Skräddarsy ditt menyer närsomhelst.

Verktygsfält

Som standard finns följande verktygsfält;

· Huvud verktygsfält -

· de Simulering verktygsfält -

· Visa verktygsfält -

· de Diagram verktygbar (om en diagram är öppen) -

· Macro Inspelning verktygsfält -

Ta en titt genom knapparna på varje verktygsfält genom att föra över dem för att se verktygsspetsen (genväg-nyckel).

Notera

Bara vissa knappar kommer att vara aktiv beroende på vad du har valt i Utforskaren och du kan Skräddarsy ditt verktygsfält närsomhelst.Dessutom "Validera / Check Projekt Begränsningar" -knappen på huvudverktygsraden och knapparna på Simulation verktygsfältet kommer att belysa Röd när en ändring till den underliggande förvaret kräver en ny validering av projektet eller en ny simulering av den simulator respektive. Håll muspekaren över knappen för att se vilka arkitekturer påverkas.

Den högerklicksmeny

De viktigaste menyer och verktygsfält är inteanvänds till allt, men. Det är ofta mer praktiskt att använda högerklicksmenyn för olika verksamheter. (Även inte alla kommandon tillgängliga via högerklicka finns tillgängliga via huvudmenyerna, verktygsfält, eller tangentbordskommandon.)

Till exempel, när du har skapat en fil, och du har en träddiagram för din arkitektur, är det bättre att högerklicka på arkitekturer i trädet för att lägga till en ny arkitektur. På samma sätt bör du högerklickar på komponenter för att lägga till en ny komponent. Högerklicka på ett par saker i trädet för att se vad du kan göra.

Dricks

Generellt, kommer du att använda huvudmenyerna att utföra fler uppgifter på hög nivå, som utvärderar din arkitektur. De låg nivå uppgifter - som att lägga enskilda komponenter och anslutningar - görs med hjälp av verktygsfält och / eller högerklicksmeny.

Utforskaren och egenskaper fönster

När du öppnar eller skapar en fil, kommer ett träddiagram visas i Utforskaren. Det finns ett fönster i din arkitektur. Och när du väljer delar inom fönstret Explorer tre andra fönster; de allmänna egenskaperna, Referenseroch Egenskaper fönster kommer att uppdateras för att återspegla detaljerad information om ditt val.

Notera

De allmänna egenskaper, Referenseroch Egenskaper fönstren är dolda som standard. Se Anpassa gränssnittet Information om hur du ta fram dem och eventuellt lämna dem permanent visas.

Medan du bygger din arkitektur, fönstren Explorer och Egenskaper är de mest användbara representation. Eftersom de kan fällas ihop och expanderas efter behov, och att de inte blir besvärligt.

Fönstret Explorer har ett träd (och statusfältet) och egenskaperna fönster har 5sektioner:

· Typ

· Standarder

· Beskrivning

· Referenser

· Egenskaper

ABACUS anser alla dessa saker att vara en del av arkitekturen.

Träd

I detta avsnitt har ett träd grupperade i 3 områden som följer:

1. Meta-modell

· Standarder- Om det genom upprepade komponenter har samma uppsättning av fastigheter, kan du definiera uppsättningen up-front, och sedan bara tilldela den till komponenterna. Samma sak gäller för anslutningar och någon av de andra delarna. Dessa uppsättningar av standardegenskaper lagras i Standardergren i trädet. I stället för att definiera varje fastighet för varje komponent, och varje egenskap för varje anslutning etc, bara tilldela en standard-. Till exempel de vanliga egenskaper Unix-HP / UXkan sparas som en Standard och tilldelas alla komponenter med hjälp av Unix-HP / UXoperativsystem såsom visas för OS01 server i skärmdumpen ovan.

· Typer - Denna gren av trädet är ett bibliotek av de typer av komponenter och anslutningar som du kan använda. Typer används för att definiera den meta-modell för din arkitektur och för klassificering och filtrering när du tittar på din arkitektur. De bestämmer också en mall för vad standarder, Egenskaper och begränsningar dina komponenter / anslutningar kan ha.

· Synpunkter- Sepunkts kan skapas från befintliga scheman och kan användas för att skapa nya scheman.De är diagram schabloner.

· Mallar - Mallar lagra återanvändbar mönster av komponenter och anslutningar tillsammans med det sätt på vilket de representeras eller visas. De kan betraktas som "mini" arkitekturer eller lösningar som kan placeras i befintliga arkitekturer.

2. Arkitekturer -De arkitekturer gren av trädet är där du bygger arkitektur (s) i ditt system. (Detta kallas fylla arkitekturen.) Du kan ha hur många arkitekturer i en enda ABACUS fil.

3. Instrumentpaneler - Den Instrumentpaneler gren av trädet är där du kan komma åt alla sparade instrumentpaneler för projektet.

Notera

Poster i Explorer träd som har haft sina Uppdatera tillstånd avlägsnas (dvs. de är skrivskyddade) visas i grått.

Typ

I det här avsnittet betecknar specifik komponent eller anslutning typen av valda elementet i trädet.

Standarder

Detta avsnitt innehåller en förteckning över de standarder för det valda elementet i trädet.

Beskrivning

I det här avsnittet ges en kortfattad beskrivning av det markerade elementet i trädet. Alla relaterade hyperlänkar kan också läggas till detta avsnitt. Dessa inkluderar webbplatser eller lokala absoluta sökvägar pekar på ytterligare information om den givna elementet. Flera linjer är också tillåtet. Giltiga hyperlänkar måste börja med en av 5 strängar; http: //, https: //, ftp: //, file: /// eller mailto :.

Dricks

För hyperlänkar med mellanslag, kan användarna skriva in webbadressen eller sökvägen, välj önskad text och Högerklick| Hyperlänk. Detta kommer att ändra några utrymmen för % 20så hela URL eller sökvägen att fungera korrekt.

Skapad och Modifierad

Dessa avsnitts förseanvändaren och datum / tid för att skapa, och sista modifiering, det valda elementet i trädet.

Referenser

Detta avsnitt innehåller en förteckning över de utgående och inkommande komponenter för det valda elementet i trädet.Den visar också diagram, 3D och diagram vyer som det valda elementet visas i. Om ett diagram är valt visar Viewpoint i förekommande fall för diagrammet och vyer i allmänhet visar alla instrumentpaneler vyn visas i. Och när en standard väljs i trädet visar användningen av standard typer, komponenter och anslutningar.

Egenskaper

Detta avsnitt är där du definiera egenskaperna hos elementen inom din arkitektur, liksom det sätt du behöver den för att utföra, antalet rader kod har den andel av dessa linjer som är kommentarer, etc.

De "input" och "output" egenskaperna hos den färdiga simulatorer kommer att visas i fönstret Egenskaper med en ikon fastighetsinmatningsraden väljare ( [image] ) Och utgångs ikon ( [image] ) Respektive med ett verktygstips som anger vilka färdiga simulatorn fastigheten är relaterad till, t.ex. "Modularitet Output" eller "Performance Input". Pilen på utgångs ikoner kommer att belysa Röd ( [image] ) När fastigheten är inaktuell på grund av en underliggande egendom eller strukturell förändring av förvaret med simulatorn kräver åter simulering enligt Röd lyfta på Simulering verktygsfält .

Statusraden

Den vänstra delen av statusraden visar den fullständiga sökvägen till förvaret elementet för närvarande i fokus, antingen väljas i fönstret Explorer eller på diagram duk. Det är så att den exakta platsen i förvaret hierarkin för den givna elementet alltid lätt kan bestämmas. Den högra delen av statusfältet visar olika operativa meddelanden som "Öppna ABACUS fil Framgångsrika" och "Kostnadsberäkningen Avslutade".

Se också

Hur du gör det (Översikt) | Anpassa gränssnittet | Vad är arkitektur? | Hur en arkitektur representerat i ABACUS? | Att arbeta med ABACUS filer


Anpassa ABACUS gränssnittet

Navigering: Introduktion till ABACUS>

Anpassa ABACUS gränssnittet

Skicka kommentarer om detta ämne.

Du kan ändra utseendet och beteendet hos ABACUS gränssnittet på många sätt. ABACUS innehåller flera fördefinierade inställningar kombinationer som du kan använda för att tillämpa en grupp anpassningar till gränssnittet. Dessutom kan du göra individuella anpassningar till objekt såsom fönster, verktygsfält, kortkommandon och olika visar alternativ.

Ordna och Dock Windows

Du har många alternativ för att ordna fönster i gränssnittet för ABACUS, bland annat följande:

· Tab-docka fönster.

· Dock fönster till kanten av en ram i gränssnittet.

· Minimera verktygsfönster längs kanten av gränssnittet.

· Återställ fönster placering till standardlayouten.

Docknings Windows

När ett fönster är dockningsbart, kan det fästas på en sida av en ram i gränssnittet eller den kan vara anordnad på flikar rutor inom ramen. En guide diamant visas när du drar fönster från sin nuvarande plats till en annan plats i gränssnittet. Guiden diamant gör att du snabbt åter docka ett fönster på en av de fyra sidorna av ramen eller i mitten som ett flikar rutan. När ett fönster är bortkopplat eller inte dockningsbar, flyter det på toppen av andra fönster.

Docka fönster

1. Klicka på fönstret som du vill docka, för att ge det fokus.

2. På Fönstermeny, klicka på Dockningsbar.

3. Dra fönstret från sin nuvarande plats i mitten av den ram du vill att docka den med.

En guide diamant visas. De fyra pilar diamant pekar mot de fyra kanterna på ramen och centrum representerar flikar rutan.

Dricks

Om du vill flytta en dockningsbar fönster utan att gå den på plats, tryck CTRL medan du drar det.

4. När fönstret du drar når det läge där du vill docka, flytta pekaren över motsvarande del av styr diamant. En översikt av fönstret visas i det angivna området.

5. Om du vill docka fönstret i den position som anges, släpp musknappen.

Till exempel, om Explorerär dockad på den vänstra kanten av gränssnittet och du vill docka den på den högra kanten, skulle du dra Explorermot mitten av gränssnittet, flytta pekaren över den högra sidan av styr diamant, och sedan släpper musknappen.

Minimera Windows

Windows (oavsett om de är verktyget Windows - som förekommer på Semeny, eller ett dokument Windows - som förekommer på Fönstermenyn) stödja en funktion som kallas Auto Hide. Auto Hide gör att du kan se mer av din arkitektur på en gång genom att minimera fönster längs kanterna av gränssnittet när den inte används.

Att slå på Auto Hide

1. Klicka på fönstret som du vill dölja att ge det fokus.

2. På Fönstermeny, klicka på Auto Hide.

- eller -

2. Klicka på ikonen pushpinen i namnlisten i fönstret.

Auto Hide Enabled

När en automatisk dolda fönster förlorar fokus glider automatiskt tillbaka till dess flik på kanten av gränssnittet. Även ett fönster är auto-dolda, dess namn och ikon syns på en flik vid kanten av gränssnittet. Om du vill visa ett automatiskt dolt fönster, flytta pekaren över fliken. Fönstret glider tillbaka i sikte och är klar för användning.

Notera

Ett fönster som är automatiskt dold kan inte dockas. Om du vill docka ett fönster måste du stänga av Auto Hide som beskrivs nedan.

För att stänga av Auto Hide

1. Klicka på fönstret som du vill behålla synligt för att ge det fokus.

2. På Fönstermeny, klicka på Auto Hideför att ta bort markeringen.

- eller -

2. Klicka på ikonen pushpinen i namnlisten i fönstret.

Auto Hide funktionshindrade

Dricks

Windows som har Auto Hide aktiverad tillfälligt glida i sikte när fönstret har fokus. Om du vill dölja fönstret igen, välja en post utanför det aktuella fönstret. När fönstret förlorar fokus, glider tillbaka utom synhåll.

Återställning Windows layouter

Du kan återställa gränssnittet till standardfönsterlayouten med hjälp av Återställ fönsterlayout kommando. När du kör det här kommandot följande åtgärder inträffar:

· Alla fönster är flyttat till sina standardlägen.

· Fönster som är stängda i standardfönsterlayouten stängs av kommandot.

· Fönster som är öppna i standardfönsterlayouten öppnas av kommandot.

· Windows som är dolda / synliga i standardfönsterlayouten görs dolt / synligt av kommandot.

För att återställa fönstret placering till standardlayouten

1. På Windowsmeny, klicka på Återställ fönsterlayout.

Att skräddarsy menyer och verktygsfält

Du kan ändra layout, placering, och innehållet i menyer och verktygsfält i gränssnittet. Du kan också lägga till knappar verktygsfält och ändra den tilldelade ikonen för valfri knapp.

Skapa nya verktygsfält

Om du vill skapa ett nytt verktygsfält

1. På Verktygmenyn, välj Anpassa.

2. I Anpassadialogrutan väljer Verktygsfält flik.

3. Välja Ny.

4. I Ny Verktygsfältdialogrutan skriver du ett namn för verktygsfältet.

5. Välja ok.

För att lägga till en knapp för att en meny eller verktygsfält

1. På Verktygmenyn, välj Anpassa.

2. I Anpassadialogrutan väljer Kommandon flik.

3. Välj en kategori och dra ett kommando från dialogrutan till menyn eller verktygsfältet.

4. Välja På nära håll.

Dricks

Om du håller ned Alt-tangenten kan du snabb anpassa kommandon som om dialogrutan Anpassa var öppen.

Se också

ABACUS gränssnittet


Att arbeta med ABACUS filer

Navigering: Introduktion till ABACUS>

Att arbeta med ABACUS filer

Skicka kommentarer om detta ämne.

En kulram fil är en behållare för en modell av din arkitektur . Inom en enda ABACUS fil kan du modellera valfritt antal arkitekturer många gånger som helst.

När du först öppnar ABACUS finns det inga filer öppna. Att arbeta på din arkitektur, måste du antingen skapa en ny fil eller öppna en befintlig fil.

När du öppnar eller skapa en ny fil, kommer ett träd i utforskarfönster automatiskt visas. Denna explorer uppfattning visar din arkitektur hittills. När du stänger filen, kommer trädet i utforskarfönster också försvinna.

För att skapa en ny ABACUS fil

1. Välj Fil| Ny ...

2. I dialogrutan Nytt projekt som visas (se nedan) Väljaatt antingen skapa en tom modell, en modell från en standard ABACUS bibliotek , En modell från en anpassad ABACUS bibliotek, en modell från XML, MS Access , MS Visio , MS Excel , MS SQL Server , en Företag Server modell eller en anpassad ABACUS bibliotek (.abacuslib fil).

3. Klicka på okknappen och följ alla dialogrutor som kan visas.

Dricks

Du kommer inte att bli ombedd att namnge filen förrän du spara eller stänga den. Det är en bra idé att spara filen så fort du skapar den. Då behöver du inte oroa dig för att namnge den senare i processen när du koncentrera sig på andra komplexa saker (som att fylla din arkitektur).

Skapa ett nytt projekt

ABACUS Klassbibliotek

ABACUS stöder över 100 offentliga ramar och beteckningar varav några visas nedan. När du väljer att skapa ett nytt projekt från en standardbiblioteksanvändare har en snabb start till modellering inom en etablera ramverket för att ta full nytta av några definierade elementtyper, attribut, anteckningar, synpunkter och mallar eller mönster. Ytterligare standardbibliotek är fritt tillgängliga via Avolution Community här .

Nytt projekt från Standard Library

Om du vill spara en ny ABACUS fil

1. Välj Fil| Spara som

Dricks

Filnamn kan vara valfri längd, och kan innehålla alla alfanumeriska tecken och blanksteg. De kan inte innehålla tilde (~) karaktär, röret (|) tecken, frågetecken, eller tecknen som normalt används för väg beskrivningar såsom backslash (\) - utom som en del av sökvägen (?).

Om du vill öppna en befintlig ABACUS fil

1. Välj Fil| Öppna

Notera

Om du öppnar en fil från en delad nätverksplats som redan är öppen till en annan användare, kommer ABACUS ger dig skrivskyddad åtkomst. När du använder ABACUS med skrivskyddad åtkomst, kommer du inte att kunna utföra skrivoperationer, såsom fylla din arkitektur och kör utvärderare. Du kan dock visa din arkitektur med utforskaren vyn och 3D-vyer.

Se också

Hur en arkitektur representerat i ABACUS?


Hur en arkitektur representerat i ABACUS?

Navigering: Introduktion till ABACUS>

Hur en arkitektur representerat i ABACUS?

Skicka kommentarer om detta ämne.

I ABACUS, du modell din arkitektur. För enkelhetens skull kallar vi detta arkitektoniska modell en arkitektur.

Diagrammet nedan visar hur en typisk arkitektur 5 ingående delar (i en hierarki) förbundna med 2 anslutningar skulle vara representerade i ABACUS.

Hur en enkel arkitektur representeras i ABACUS

Du kan ha valfritt antal arkitekturer i en enda ABACUS fil.

Den första arkitekturen i trädet

Normalt skulle du skapa en ny arkitektur när du vill utvärdera en förändring. Till exempel, skulle du modellera din befintliga arkitektur först - detta skulle vara den första arkitekturen i trädet. Du kan kalla det "Aktuellt".

Den andra

När du vill modellera och utvärdera en förändring till din befintliga arkitektur (t.ex. ökad krav) du vill skapa en ny arkitektur. Det enklaste sättet att göra detta skulle vara att skapa en kopia av "Nuvarande" och döp om den "Evolution 1 Försök 1 '. Detta skulle vara det andra arkitekturen i trädet. Om dina utvärderingar av "Evolution 1 Försök 1 'är framgångsrika, kan du döpa om den till bara" Evolution 1'.

Den tredje

Om "Evolution 1 Försök 1 'inte uppfyller dina krav, kan du skapa en kopia av det, döp om den till" Evolution 1 Försök 2 ", och försök igen. Detta skulle vara den tredje arkitektur i trädet.

Se också

Vad KULRAM göra? | Hur du gör det (Översikt) | Vad är arkitektur? | Att arbeta med ABACUS filer | Skapa eller duplicera en arkitektur


Hjälp på andra språk

Navigering: Introduktion till ABACUS>

Hjälp på andra språk

Skicka kommentarer om detta ämne.

KULRAM hjälp finns i olika andra språk / översättningar och kan laddas ner från nedanstående länkar.

Till ersätta den nuvarande ABACUS hjälpfilenmed en översatt hjälpfil Följ de här stegen:

1. Spara hjälpfilen från den aktuella länken nedan.

2. Byt namn på hjälpfilen till ABACUS.chm.

3. Öppna filen genom att dubbelklicka på den och om en "Öppna fil - Säkerhetsvarning" dialogrutan visas sedan avmarkera "Fråga alltid innan du öppnar filen" och klicka på Öppna.

4. Stäng filen.

5. Ersätt ABACUS.chm filen i programfiler mappen ABACUS, typiskt "C: \ Program Files \ Avolution \ ABACUS" eller "C: \ Program Files(x86)\ Avolution \ ABACUS".

Notera

Sammanhangsberoende hjälp kommer att fortsätta att arbeta med de översatta hjälpfiler.

ABACUS hjälpfiler på andra språk:

· arabiska / العربية .

· bulgarisk / български .

· Förenklad kinesiska) / 中文 (简体) .

· tjeck / Česká .

· danska / Dansk .

· estniska / Eesti .

· finsk / Suomen .

· franska / Franska .

· tysk / Deutsch .

· ungerska / magyar .

· isländsk / isländsk .

· indonesisk / indonesien .

· italienska / Italiano .

· japansk / 日本 の .

· lettisk / Latvijas .

· Malaysiskt / malaysia .

· maltesisk / Malt i .

· Norweigen / Norweigen .

· polska / Po lska .

· Portugisiska / Português .

· ryska / русский .

· slovakiska / Slovenski .

· Slovenska / Slovenski .

· spansk / Españoles .

· svenska / Svenska .

· turkiska / Turk .

· walesisk / Cymraeg .

Se också

Vad KULRAM göra?


Fylla din arkitektur

Navigering: Fylla din arkitektur>

Fylla din arkitektur

Skicka kommentarer om detta ämne.

Processen med att bygga en modell av din arkitektur kallas befolka. När du har upptäckt din arkitektur och identifierat dina behov, är du redo att modellera din arkitektur i ABACUS.

Under befolkning, kommer du in alla detaljer du vet om din arkitektur och vad som krävs av det.

För att fylla din arkitektur

1. Se till att du har en ABACUS filen öppen , en explorer visas , Och en arkitektur tillsatt .

2. Manuellt fylla de högre nivåkomponenter och anslutningar för din arkitektur. Typiskt kommer detta att vara mer abstrakta komponenter och anslutningar.

- eller -

2. Grafiskt befolka komponenter och anslutningar som du vill se schematiskt, med hjälp av Ritverktyget .

Du kanske också vill

3. Fylla med användning Kataloger - Du kan visa och komponenter och anslutningar på ett enkelt tabell sätt.

4. Fylla med användning Matriser - Du kan visa och redigera anslutningar mellan komponenterna på ett enkelt tabell sätt.

5. Fylla från Microsoft Access - Du kan importera en arkitektur från och exportera till Microsoft Access.

6. Fylla från Microsoft Visio - Du kan importera en arkitektur från och exportera till Microsoft Visio.

7. Fylla från Microsoft Excel - Du kan importera en arkitektur från och exportera till Microsoft Excel.

8. Fylla från Microsoft Sharepoint - Du kan importera en arkitektur från och exportera till Microsoft SQL Server.

9. Fylla från Microsoft SQL Server - Du kan importera en arkitektur från Microsoft SQL Server.

10. Import från XML - Du kan importera en arkitektur från en kulram XML fragment eller en Archimate Interchange Språk XML-fil.

Se också

Fylla din arkitektur manuellt | Ritverktyget | Fylla din arkitektur från Microsoft Access | Fylla din arkitektur från Microsoft Visio | Fylla din arkitektur från Microsoft Excel


Fylla din arkitektur manuellt

Navigering: Fylla din arkitektur> Fylla manuellt>

Fylla din arkitektur manuellt

Skicka kommentarer om detta ämne.

De högre nivå komponenter och anslutningar för din arkitektur kommer antagligen att behöva befolkas manuellt. Typiskt kommer detta att vara mer abstrakta komponenter och anslutningar.

För att fylla din arkitektur manuellt

1. Se till att du har en ABACUS filöppna, en explorervisas och en arkitektur tillsatt .

2. Lägg till en komponent. Att göra detta, Högerklickpå områdes av trädet som du vill fylla, och väljer Lägg till Sub-komponent ..., Eller klicka på Ny Komponentknappen på Visa verktygsfält . Komponenter kan bara läggas till under Komponenter gren av trädet. Du vill att din träddiagram för att vara en korrekt representation av din arkitektur. När du upptäckt din arkitektur, kommer du att ha lärt dig exakt hur det hela hänger ihop. Du behöver denna kunskap när du lägger dina komponenter och anslutningar. Om du lägger till din första komponenten, ska du lägga till den direkt till Components grenen. Resten av dina komponenter kan vara antingen på samma nivå i trädet, eller de kan vara sub-komponenter i den första.

3. Uppdatera värdena föregenskapernaför varje komponent som du lägga upp den. Att göra detta, klickpå komponenten, och redigera egenskaperna visas i Fönstret Egenskaper(typiskt) åt höger. Egenskaper är i allmänhet saker som krav, bearbetning kapacitet, etc. När ABACUS utvärderar din arkitektur, kommer det att beräkna vissa nya egenskaper, och spara dem tillbaka till arkitekturen. De nya egenskaperna är de uppgifter du försöker analysera, såsom utnyttjande, svarstid, bandbredd, etc.

4. Lägg dina anslutningar och uppdateraderas egenskapernär du går - precis som du gör för komponenter (men under Anslutningar gren av trädet).

5. Bifogaanslutningar och komponenter. För att göra detta, leta upp anslutningen klickar du på en av dess ändar eller roller Och dra den till en komponent. Du kan också klicka på en komponent och dra den till en av anslutningens roller (dvs antingen källa eller Sink). Eller så kan du högerklicka och dra en komponent till en annan komponent och välj Koppla till. Eller helt enkelt högerklicka på en komponent och välj Ansluta.... När du drar en anslutning roll, Kommer du att märka en genväg symbol när du pekar på en komponent som du kan koppla den till. Detta tyder på att du inte gör en kopia, du bara fästa den. Se till att du bifoga det till rätt destination komponenten. Till exempel, om det finns ett samband Source roll, Dra den gör källkomponenten (dvs. komponent som är källan till dataflödet).

Dricks

Åter beställer enheter inom din arkitektur (t.ex. komponenter, anslutningar etc.) i explorerär ganska lätt. Helt enkelt Klick| Håll| Drarelevant enhet och plats där så önskas i din arkitektur. Den omformulering funktion kan du också placera enheter inom olika hierarkier din arkitektur.

Du kanske också vill

6. Lägg Standarder (förkonfigurerade uppsättningar av fastigheter - förinställningar) på dina komponenter, anslutningar eller typer

7. Ändra egenskaperna av en komponent, anslutning eller typ

8. Ångra och Gör om operationer

9. Ändra typ av en komponent eller anslutning

10. Skapa en ny typ eller typ Group

11. Radera en komponent eller anslutning

12. Skapa, kopiera eller utvecklas en arkitektur

13. Import typer och standarder från ett bibliotek

14. Importera från ett annat ABACUS fil, XML, Excel eller Visio

15. Kopiera och klistra delar (eller alla) av din arkitektur

16. Sök och ersätt poster i din arkitektur

17. Expand / Collapse några eller alla av noderna i trädet

18. Sammanfoga objekt

19. Definiera och Bekräfta Begränsningar att begränsa strukturen på din arkitektur

20. Utveckla din arkitektur att skapa flera arkitektoniska lösningar att jämföra och baslinjen

Se också

Fylla din arkitektur - Översikt | Skapa en ny fil


Ångra och Gör om

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Ångra och Gör om

Skicka kommentarer om detta ämne.

Liksom många moderna tillämpningar, ABACUS stöder förmågan att både ångra och göra om de senaste ändringarna användar gjorts i ett öppet projekt. Om du vill ångra den senaste ändringen, helt enkelt aktivera kommandot ångra. Ändringar som har ogjort kan göras om genom att aktivera kommandot redo; åter anbringa den senast ogjort förändring.

Varning

Ångrade ändringar kan inte appliceras på nytt om ytterligare ändringar görs i projektet sedan det ogjort.

Notera

Medan den stora majoriteten av förändringar stödja ångra / gör i realtid, en del diagram stencil förändringar, som att skapa en ny typ Shape / linjeorganisation eller ändra en sammanslutning färgattribut, kan inte ångras omedelbart. I dessa fall måste den modifierade Diagram (anges med en asterisk) stängas innan dessa förändringar kan ångras.

Ångra och Gör om kommandot platser

Ångra och Gör om kommandon kan nås från tre olika platser:

· Redigera-menyn

· verktygsfältet Standard

· tangentbordets kortkommandon CTRL + Z(ångra) och CTRL + Y (göra om)

Dricks

Ångra och göra om knapparna i verktygsfältet Standard ger dropdown listor visar de 10 senaste förändringar som kan ångras och har redone respektive. De är också ett praktiskt sätt att ångra / göra om flera ändringar på en gång.


Ändra en komponent / anslutningens typ

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Ändra en komponent / anslutningens typ

Skicka kommentarer om detta ämne.

Komponent och anslutningstyper används främst för klassificeringen. Du kan använda olika typer som filter när du tittar på din arkitektur. Till exempel, i stället för att visa hela, kan du visa bara applikationskomponenter.

Om du vill ändra en komponent / anslutningens typ

1. Högerklickpå komponenten eller anslutning.

2. Välj Ändra typ.

3. Välj en annan typ från listan.

Dricks

När du ändrar typ, kan du få några nya standardereller egenskaper (vad är associerad med typ - se Typer gren av trädet). Din befintliga standarder och egenskaper kommer att förbli oförändrad. Du kan skapa egna nya typer och tilldela dina egna kombinationer av standarder och egenskaper för dem.

Se också

Skapa en ny typ | Fylla din arkitektur - Översikt | Analysera din arkitektur


Skapa en ny komponent / anslutning eller typ Group

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Skapa en ny komponent / anslutning eller typ Group

Skicka kommentarer om detta ämne.

Komponent och anslutningstyper används främst för klassificeringen. Du kan använda olika typer som filter när du tittar på din arkitektur. Till exempel, i stället för att visa hela, kan du visa bara applikationskomponenter.

Om du vill skapa en ny komponent / anslutning typ

Notera

Om du vill lägga typer eller typgrupper i en kulram projekt användarlicens behöver Designer add-on kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

1. Expandera Typergren i trädet.

2. Högerklick på Komponenttyper (eller Anslutningstyper).

3. Välj Lägg komponent (eller Lägg Anslutningstyp) eller Create Group.

Dricks

När du har skapat en typ, bör du ändra dess ikon (se nedan) och tillsätt egenskaper och standarder till det för komponenten eller anslutnings instanser till "ärva".

Om du vill ändra ikonen för en komponent / anslutning typ

Notera

Om du vill ändra ikoner för olika typer i en kulram projekt användarlicens behöver Designer add-on kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

1. Högerklick på Komponent Typ (eller Anslutningstyp) Du vill ändra ikonen för.

2. Välj Byt ikon.

3. I Välj ikon dialogrutan Bläddra till en plats och välj en bildfil och klicka på Öppna.

Notera

Du kan ha en egen ikon bild av valfri storlek, men det kommer alltid att skalas för att passa till en 16x16 pixlar i Explorer-fönster. Så om din ursprungliga anpassade ikonbild är inte av samma höjd och bredd din Explorer-ikonen Fönstret sträckas. Därför bör egna bilder vara minst 16x16 pixlar och om du vill behålla den exakta formen på egen ikon se till att din egen ikon bild är lika höjd och bredd i pixlar (16x16 eller större). Du bör också vara försiktig med att inte ha färgade "pixlar" gå hela vägen till gränsen av egen ikon bilden som det kommer att se fattiga i Explorer-fönster med angränsande ikoner "blödning" in i varandra. Därför bör du lämna minst en 1 pixel vit kant.

Dricks

Du kan göra din egen ikon image en ICO, bmp, gif, jpg eller png-fil men på grund av en begränsning i Windows endast Ico format kommer att förhandsgranska i dialogrutan ABACUS Välj ikon om du har möjlighet Menyn Visa inställt på något annat än Miniatyrer.

Se också

Fylla din arkitektur - Översikt | Analysera din arkitektur


Ta bort en komponent eller anslutning

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Ta bort en komponent eller anslutning

Skicka kommentarer om detta ämne.

Om du vill ta bort en komponent eller anslutning

1. Högerklickpå komponenten eller anslutning.

2. Välj Radera.

Försiktighet

ABACUS kommer att varna dig vilka åsikter kommer att påverkas av strykningen och ber dig bekräfta raderingen. Detta beror på att element kan finnas på många diagram och det lönar sig att kolla vad den föreslagna strykningen kommer att påverka.

Dricks

Om du tar bort en komponent, kommer alla dess delkomponenter också tas bort. Du kan välja att ta bort interna och externa anslutningar till komponenten. Om du väljer att inte ta bort dem, anslutningarna är det bifogad till kommer att finnas kvar, men de kommer inte längre bifogas. Alla komponenter och anslutningar är av en viss Typ . Radera komponent / anslutning har ingen inverkan på typ (i Typer gren av trädet). På samma sätt, om komponenten / anslutning har en Standard tilldelats kommer radering ha någon inverkan på master i Standards grenen.

Se också

Fylla din arkitektur - Översikt


Skapa eller duplicera en arkitektur

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Skapa eller duplicera en arkitektur

Skicka kommentarer om detta ämne.

Du kan ha valfritt antal arkitekturer i en enda ABACUS fil. Normalt skulle du skapa en ny arkitektur varje gång du vill att modellera och utvärdera en utveckling av systemet.

För att skapa en ny arkitektur

1. Högerklick på Arkitekturergren i trädet.

2. Välj Ny arkitektur.

Om du vill skapa en kopia av en befintlig arkitektur

1. Högerklickpå arkitekturen.

2. Välj Kopiera.

3. Högerklick på Arkitekturergren i trädet.

4. Välj Klistra.

5. Den nya arkitekturen kommer att kallas "Kopia av ...".

För att utveckla en befintlig arkitektur

1. Högerklickpå arkitekturen.

2. Välj Utvecklas.

3. Den nya strukturen kommer att kallas "... 0,1".

Notera

Det finns en detaljerad beskrivning av framväxande arkitekturer här .

Se också

Hur en arkitektur representerat i ABACUS | Evolving din arkitektur


Importera in din arkitektur

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Importera in din arkitektur

Skicka kommentarer om detta ämne.

ABACUS låter dig att importera till din arkitektur från en .abacus (ABACUS fil), .xml (en kulram XML fragment eller en Archimate Interchange Language XML-fil), .vsd format (Microsoft Visio), och .xls (Microsoft Excel). Detta gör att du kan bygga din arkitektur från externa källor snabbt.

Till importera din arkitektur från.abacus (ABACUS fil)

1. Se till att du har en ABACUS fil öppna.

2. Högerklickpå Arkitektur noden varje arkitektur i din modell eller någon del av komponentträdet.

3. Välj Importera| Från Fil...från menyn.

4. Välj en plats och den .abacus fil och klicka på Öppna knapp.

Notera

När du har valt filen du vill importera blir du tillfrågad hur du vill importera standarder, typeroch synpunkter. Du kan importera standarder, typer och synpunkter antingen nya eller sammanslagna standarder, typeroch synpunkter. Standardinställningen är för standarder, typer och synpunkter slås samman med befintliga standarder, typer och synpunkter om de redan finns (med exakt samma namn) i din projekt.

Till importeradin arkitektur från.xml (en kulram XML fragment eller en Archimate Interchange Language XML-fil)

1. Se till att du har en ABACUS fil öppna.

2. Högerklickpå en arkitektur nod varje arkitektur i din modell eller någon del av komponent trädet.

3. Välj Importera| Från XML ...från menyn.

4. Välj en plats och .xml fil och klicka på Öppna knapp.

Notera

ABACUS kommer bara importera en korrekt bildat ABACUS XML fragment eller en Archimate Interchange Språk XML-fil. När du har valt XML-filen du vill importera, kommer du att tillfrågas hur du vill importera standarder, typeroch synpunkter. Du kan importera standarder, typer och synpunkter antingen nya eller sammanslagna standarder, typeroch synpunkter. Standardinställningen är för standarder, typer och synpunkter slås samman med befintliga standarder, typer och synpunkter om de redan finns (med exakt samma namn) i din projekt.

Till importeradin arkitektur från.VSD(Visio fil) se här .

Till importeradin arkitektur frånxls (Excel-fil) se här .


Import av typer och standarder från ett bibliotek

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Import av typer och standarder från ett bibliotek

Skicka kommentarer om detta ämne.

Du kan importera olika typer och standarder från en kulram biblioteksfilen. Du kan också exportera olika typer och standarder från ABACUS fil till en kulram biblioteksfilen.

Om du vill importera typer och standarder från ett bibliotek i din arkitektur

1. Se till att du har en ABACUS filöppen och Explorer-fönstervisas.

2. Välj Arkiv | Öppnaatt öppna ett ABACUS biblioteksfilen.

3. ABACUS bibliotek öppnas i en andra flikar ark i Utforskaren och du kommer att behöva docka detta flikblad för att kunna dra-och-släpp från den till den ursprungliga ABACUS filen.

4. Dra och släpptyper och standarder från biblioteket i din arkitektur.

- eller -

1. Välj Arkiv | Ny ...

2. Skapa en ny ABACUS filbaserad på en ABACUS biblioteksfilen.

Att exportera typer och standarder från din arkitektur i ett bibliotek

1. Se till att du har en ABACUS fil öppna Explorer-fönstervisas, en ABACUS biblioteksfilenöppen och Bibliotek Fönstervisas.

2. Dra och släpptyper och standarder från din arkitektur i biblioteket.

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt


Kopiera och klistra in

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Kopiera och klistra in

Skicka kommentarer om detta ämne.

Du kan kopiera hela eller delar av din arkitektur och klistra in den på en annan plats i trädet.

Att kopiera

1. Högerklickpå objektet du vill kopiera.

2. Välj Kopiera.

Att klistra

1. Navigera trädet för att hitta det ställe där du vill klistra in objektet.

2. Högerklickpå grenen du vill att den ska visas i.

3. Välj Klistra.

4. Objektet kopieras med det ursprungliga namnet (såvida du inte kopiera den till den ursprungliga grenen - då det kommer att kallas "Kopia av ...").

Se också

Hur en arkitektur representerat i ABACUS


Söka och ersätta objekt i din arkitektur

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Söka och ersätta objekt i din arkitektur

Skicka kommentarer om detta ämne.

Du hittar och ersätt en specifik komponent, anslutning, typ, standard eller egendom med hjälp av ABACUS "Hitta och ersätt anläggning.

För att hitta ett objekt

1. Klicka på nod i trädet som du vill söka inom.

2. Välj Redigera| Hittaeller tryck på Ctrl + F.

3. Gå in i text objektetatt hitta i "Hitta det fältet.

4. Klick Sök nästa.

Till byta ut en sak

1. Klicka på nod i trädet som du vill söka inom.

2. Välj Redigera| Byta uteller tryck på Ctrl + H.

3. Gå in i textobjektetatt hitta i "Hitta vad fältet och texten för att ersätta den med i" Ersätt med fältet (eller ingenting om fältet lämnas tomt).

4. Klick Sök nästaför att hitta den första förekomsten av "Hitta vad text och klicka Byta ut att ersätta detta fall med "Ersätt med" text eller klicka Ersätt allaatt ersätta alla förekomster.

Du har alternativ för:

o Matcha sin talan,

o Matcha hela ordet,

o Sök från början av projektet,

o Ignorera arkitekturer - det är arkitekturen noder själva. Alla noder nedanför arkitekturen noder såsom komponenter och anslutningar kommer fortfarande sökas,

o Ignorera komponenter - som är den komponent noder själva,

o Ignorera anslutningar - det vill säga kopplingen noder själva,

o Ignorera standarder - som är alla arkitektur, komponenter och anslutningsstandardnoder ska ignoreras,

o Ignorera typer - det är den typ noder själva. Eventuella tvångs noder nedanför av typen noderna fortfarande sökas,

o Ignorera mallar och innehåll - som är mallen noder själva liksom varje mall komponent och anslutningsnoder under dem,

o Ignorera egenskaper - som är alla fastighetstyper, namn, värden och enheter bestående av alla modellens element kommer att ignoreras,

o Ignorera beskrivningar - det är beskrivningar av alla modellens element kommer att ignoreras.

Se också

Hur en arkitektur representerat i ABACUS


Expandera och komprimera trädet

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Expandera och komprimera trädet

Skicka kommentarer om detta ämne.

När en nod i trädet innehåller delkomponenter och kollektioner, kommer det att ha en liten [image] eller [image] logga på dess vänstra. Du kan klicka på [image] att expandera noden och se dess delkomponenter och anslutningar. På samma sätt kan du klicka på [image] att kollapsa noden att dölja delkomponenter och anslutningar (för att skapa mer utrymme eller göra trädet lättare att förstå).

Alternativt kan du utöka en hel nod, i vilket fall alla dess undernoder också kommer att utökas, och deras under noder, och deras ... etc. På samma sätt kan du komprimera en hel nod - stänger flera nivåer på en gång .

Dessutom finns det möjligheter att expandera endast arkitekturer, element (dvs. komponenter och anslutningar), komponenter eller anslutningar.

Om du vill expandera eller komprimera en hel nod (och dess undernoder, etc.)

1. Högerklickpå noden.

2. Välj Expand | Alla eller Falla ihop.

Om du vill expandera alla en arkitektur (er)

1. Högerklickpå arkitekturer eller en arkitektur.

2. Välj Expand | Alla.

Att expandera element

1. Högerklickpå arkitekturer eller en arkitektur.

2. Välj Expand | Element.

För att utvidga komponenter

1. Högerklickom komponenter, en komponent eller en delkomponent.

2. Välj Expand | Komponenter | Alla.

För att utvidga anslutningar

1. Högerklickpå Connections, en anslutning eller en sub-anslutning.

2. Välj Expand | Anslutningar | Alla.


Sammanslagning objekt

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Sammanslagning objekt

Skicka kommentarer om detta ämne.

När vill du slå samman objekt?

Du skulle slå samman objekt när du har två (eller flera) objekt i din modell som är bäst representeras av en enda instans. Det finns många situationer då du kanske vill göra detta, inklusive:

· Som ett resultat av att importera en ny uppsättning av information i din modell som kan kopiera eller ersätta befintlig information. Till exempel om du importerar en uppdaterad version av ett kalkylblad i din modell.

· Med tiden kopior av "samma" komponent har skapats och du vill rensa upp dessa dubbletter.

· Om du utför en what-if scenario och de objekt du är modellering faktiskt sammanslagning i verkligheten. Till exempel, om du går samman två avdelningar i din organisation, eller om du går samman två servrar.

Vad kan slås samman?

Följande typer av objekt stödja slås ihop:

· Standarder

· Komponent- och Anslutningstyper

· Komponenter och anslutningar

Hur man slår ihop objekt

För att initiera en sammanfogning, med hjälp av höger musknapp och dra ett objekt i Utforskaren till en annan. Objektet som du drar är källan, och objekt som du drar till är målet. När du släpper höger musknapp kommer du att presenteras med en meny där du kan välja att slå ihop de två punkter. Du måste välja om du vill bevara eller skriva destinationen. Detta förklaras närmare nedan.

Sammanfogningen höger dra menyn

Vad är skillnaden mellan att bevara och skriva över destination?

Bevara eller skriva alternativet dikterar vad som händer om Namn, Beskrivning eller egenskaper mellan källan och destinationsposter match.

Om Bevara Destination väljs

· Destinationen namn och beskrivning kommer att hållas.

· Eventuella Egenskaper som bara finns i källan läggs till destinationen.

Om Skriv över Destination väljs:

· Destinationen namn kommer att skrivas över från källan.

· Destinationen beskrivning skrivs över från källan, såvida inte källan beskrivning är tom.

· Eventuella Egenskaper som bara finns i källan läggs till destinationen.

· Värdet och enheten för alla fastigheter som finns i både källa och destination skrivs över från källan, såvida inte källan Value eller enheten är tom.

Specialfall

· Typer: När sammanslagning typer, är behörigheterna slås samman i ett "pessimistiskt" sätt, så att om tillstånd på källan inte fanns på destinationen, skulle det tillsättas, och om det fanns i destinations, sedan om den enskilde tillstånd för en användargrupp (Skapa, läsa, uppdatera eller radera) matchade inte (ett beviljat, en förnekade), så att tillstånd skulle nekas.

· Ingående delar: När sammanslagning komponenter, under beståndsdelar från ursprungs migrerat till destinationen, och slås samman med delkomponenter i målet om deras namn är identiska, Oavsett typ.Dessutom kommer flera delkomponenter hos källan med samma namn kombineras till en enda delkomponent i destinationen.

· Anslutningar: Den översta anslutningar nivå själva måste båda ha samma bilagor (eller brist på sådan) att få slås samman. När sammanslagning anslutningar, under anslutningar källan migrerat till destinationen, och slås samman med underanslutningar i målet om deras namn är identiska OCHbilagor är identiska. Om bilagor inte är identiska, kommer underanslutningar källa läggas till destinationen utan att gå samman med matchande anslutningar som redan finns. Det är så att inga bilagor går förlorade.


Utforma och godkänna Begränsningar

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Utforma och godkänna Begränsningar

Skicka kommentarer om detta ämne.

Struktur och egenskaper av en arkitektur kan begränsas med hjälp av restriktioner. Begränsningar kan tillämpas på komponenttyper och anslutningstyper för att begränsa uppbyggnaden av en arkitektur på två sätt. Det första sättet är att begränsa hierarkigenom att definiera "förälder bör / måste ha barn" och "barn bör / måste ha förälder" relationer. Det andra sättet är att begränsa topologigenom att definiera "komponent bör / ska bifogas anslutning" och "anslutning bör / måste bifogas komponent" relationer. Dessutom kan restriktioner tillämpas på egenskaperna hos komponenttyper, anslutningstyper, mallar, synpunkter, arkitekturer, diagramoch 3D-vyer att begränsa arkitektur (er) i ytterligare två sätt. Det första sättet är att ställa in data typav fastigheten för att begränsa de giltiga värden som det kan ha, nämligen; Text, Integer, Decimal, datum / tid, Boolean eller Lista. Det andra sättet är att ställa in nödvändigstatus av fastigheten för att ange om ett värde behöver skrivas in för fastigheten (Obs: Nödvändiga begränsningar gäller endast för fastigheter för komponent- och anslutningstyper). Ytterligare information om fastighetsbegränsningar är anordnad i Ändra egenskaperna hos en komponent, anslutning eller typ hjälpavsnittet. När begränsningar har definierats, är det möjligt att validera en arkitektur mot begränsningar. ABACUS kommer att varna om eventuella begränsningar som har kränkts.

Nyckeln till att fastställa vilken begränsning (s) för att definiera lögner i exakt språk som används för att beskriva begränsningen. För hierarkin begränsningar de är oftast i formatet "substantivkan / bör / måste delas upp i n substantiv" eller "substantivkan / bör / måste aggregeras av substantiv"Etc. Till exempel,"Avdelningarmåste delas upp i Lag" eller "Tillämpningarkan delas upp i Moduler". För topologi begränsningar de är oftast i formatet"substantivkan / bör / måste verb substantiv". Till exempel, "Processer kan vara utförs av Lag" eller "Tillämpningarär värd på Servrar. "Nu kan du se i varje begränsning finns det olika kan / bör / måste" kval "och dessa kan vara av 3 typer;

· Frivillig- Dessa kommer vanligtvis använda ord / fraser som; "kan", "kan", "skulle kunna", "eventuellt" etc.

· Rekommenderad- Dessa kommer vanligtvis använda ord / fraser som; "bör", "rekommenderas", "rådde" etc.

· Obligatorisk- Dessa kommer vanligtvis använda ord / fraser som; "måste", "är", "är", "har", "skall" etc.

Beroende på vilken typ av tvång (hierarki eller topologi) och kvalet som används för att beskriva det, bör fastställas specifika tvång (s) (se nedan). För ovanstående hierarki exempel på "Avdelningarmåste delas upp i Lag"Bör man definiera en" Förälder måste ha barn "tvång och ställa verkställigheten skall verkställas. För ovanstående topologi exempel på"Processer kan vara utförs av Lag. "Bör man bara skapa två (2)" Anslutning ska bifogas Component "begränsningar för vardera änden av den genomförda av anslutningstypen specifikt följande krav rekommenderas att definieras (se nedan) för de olika alternativen;

· Hierarki begränsningar;

o Substantiv A kan varasönderdelas till Substantiv B, eller Substantiv B kan varaaggregerade av Substantiv A eller Substantiv B borde varaaggregerade av Substantiv A- Definiera en "Child måste ha Parent" begränsning med typen barnet som Noun B, förälder typ som Noun A och verkställande varnad.

Notera

Detta innebär att om ett barn existerar, bör den ha en förälder till en viss typ. Om inte, kommer du att få en varning.

o Substantiv A borde varasönderdelas till Substantiv B- Definiera en "Förälder måste ha barn" begränsning med moder typ som Noun A, barn typ som Noun B och verkställande varnad.

Notera

Detta innebär att om en förälder finns, bör den ha barn av en viss typ. Om inte, kommer du att få en varning.

o Substantiv A måste varasönderdelas till Substantiv B- Definiera en "Förälder måste ha barn" begränsning med moder typ som Noun A, barn typ som Substantiv B och verkställande påtvingade.

Notera

Detta innebär att om en förälder finns, måste den ha barn av en viss typ. Om du inte kommer att få ett felmeddelande.

o Substantiv A måste varaaggregerade av Substantiv B- Definiera en "Child måste ha Parent" begränsning med typen barnet som Noun A, förälder typ som Substantiv B och verkställande påtvingade.

Notera

Detta innebär att om ett barn finns, måste den ha en förälder till en viss typ. Om inte, kommer du att få ett felmeddelande.

· Topologi begränsningar;

o Substantiv A kan vara verb Substantiv B- Definiera två (2) "Anslutning ska bifogas Component" begränsningar. Den första är med käll slutet av anslutningstypen verbbifogas Substantiv En komponenttyp och verkställighet som till påtvingade. Den andra väsen med Sink slutet av anslutningstypen verbbifogas Substantiv B komponenttyp och verkställighet inställd på påtvingade.

Notera

Detta innebär att om anslutning finns, måste den ansluta komponenter i vissa typer. Om du inte kommer att få något fel. Övergripande detta säkerställer att dessa komponenter fortfarande kan existera och inte anslutas till varandra. Men om de är anslutna, måste anslutningar av rätt typ användas.

o Substantiv A borde vara verb Substantiv B- Definiera två (2) "Component ska bifogas Connection" begränsningar. Den första är med Substantiv En komponent typ fäst till källan slutet av verbanslutningstypen och verkställighet inställd på varnad. Den andra väsen med Substantiv B-komponenten typ ansluten till Sink slutet av verbanslutningstypen och verkställighet inställd på varnad. Dessutom definierar två (2) "Anslutning ska bifogas Component" begränsningar. Den första är med käll slutet av anslutningstypen verbbifogas Substantiv En komponenttyp och verkställighet som till påtvingade. Den andra väsen med Sink slutet av anslutningstypen verbbifogas Substantiv B komponenttyp och verkställighet inställd på påtvingade.

Notera

Detta innebär att om komponenter av någon typ finns, bör de vara ansluten till en anslutning av en viss typ. Om du inte kommer att få en varning. Dessutom innebär detta att om anslutningen finns, måste den vara ansluten till komponenter av den specificerade typen. Om du inte kommer att få ett felmeddelande. Sammantaget garanterar att om komponenter av dessa typer finns, får du varningar om de inte är anslutna till varandra.

o Substantiv A måste vara verb Substantiv B- Definiera två (2) "Component ska bifogas Connection" begränsningar. Den första är med Substantiv En komponent typ fäst till källan slutet av verbanslutningstypen och verkställighet som till påtvingade. Den andra väsen med Substantiv B-komponenten typ ansluten till Sink slutet av verbanslutningstypen och verkställighet som till påtvingade. Dessutom definierar två (2) "Anslutning ska bifogas Component" begränsningar. Den första är med käll slutet av anslutningstypen verbbifogas Substantiv En komponenttyp och verkställighet som till påtvingade. Den andra väsen med Sink slutet av anslutningstypen verbbifogas Substantiv B komponenttyp och verkställighet inställd på påtvingade.

Notera

Detta innebär att om komponenter av någon typ finns, måste de vara ansluten till en anslutning av en viss typ. Om du inte kommer att få ett felmeddelande. Dessutom innebär detta att om anslutningen finns, måste den vara ansluten till komponenter av den specificerade typen. Om du inte kommer att få ett felmeddelande. Sammantaget garanterar att om komponenter av dessa typer finns, kommer du att få fel om de inte är anslutna till varandra.

För att definiera en begränsning

1. Se till att du har en ABACUS filöppen och Explorer-fönstervisas.

2. I utforskaren trädet expanderar Typer | Komponenttypereller expandera Typer | Anslutningstyper.

3. Högerklicken komponenttyp eller en typ anslutning och välj Lägg Constraint.

Lägga till en begränsning

För att definiera en hierarki begränsning, där en förälder måste ha en särskild barn

4. På Lägg Constraintfönstret kryssa i Skapa Constraintkryssrutan under Förälder Måste ha barn Constraint område.

5. Välj komponenttypi listrutan som du vill ange som barnet av typen komponent som valts i steg 3.

Notera

Om det redan finns en aktiverad "Förälder måste ha barn" begränsning definierats för moder komponenttyp och ett annat barn komponenttyp då denna nya begränsning kommer att behandlas som en "OCH". Det är den typ måste vara en förälder av typen barn A ochbarn typ B, till vilken verkställighet nivå (t.ex. funktionshindrade, varnas eller verk - se steg 7) anges för varje begränsning.

6. Eventuellt kan du definiera lägsta och högsta antal komponenter i komponenttypen anges som måste vara barn komponenttypen högerklickar i steg 3.

7. Välj om du vill att begränsningen vara Funktionshindrade, Varnade eller Påtvingad.

Notera

Funktionshindrade begränsningar kommer att ignoreras av tvång validering kommer varnas begränsningar producera en varning i validering fönstret om de upptäcks och påtvingade begränsningar kommer att producera något fel i validering fönstret om de upptäcks. Dessutom måste alla fel lösas innan ett Företag Server kan begås projekt.

8. Klick ok.

Notera

Begränsningen kommer att visas i utforskaren trädet under komponenttyp högerklickat i steg 3. Pilen anger riktningen för tvång och i det här fallet kommer att peka nedåt och åt höger. Hänglåset är färgad beroende på om begränsningen är funktionshindrade (grå), varnade (gul) eller påtvingade (röd).

Förälder måste ha barn varnas begränsning

För att definiera en hierarki begränsning, där ett barn måste ha en viss förälder

4. På Lägg Constraintfönstret kryssa i Skapa Constraintkryssrutan under Barn måste ha Parent Constraint område.

5. Välj komponenttypi listrutan som du vill ange som förälder till komponenttypen högerklickar i steg 3.

Notera

Om det redan finns en aktiverad "Barn måste ha förälders begränsning definierats för typen barn komponenten och en annan förälder komponenttyp då denna nya begränsning kommer att behandlas som en" ELLER ". Det är den typ måste vara ett barn moder typ A ellerförälder typ B, och verkställighet nivå (t.ex. varnas eller verk - se nästa steg) bör vara samma annars påtvingade begränsningar kommer alltid att åsidosätta varnade dem.

6. Välj om du vill att begränsningen vara Funktionshindrade, Varnade eller Påtvingad.

Notera

Funktionshindrade begränsningar kommer att ignoreras av tvång validering kommer varnas begränsningar producera en varning i validering fönstret om de upptäcks och påtvingade begränsningar kommer att producera något fel i validering fönstret om de upptäcks. Dessutom måste alla fel lösas innan ett Företag Server kan begås projekt.

7. Klick ok.

Notera

Begränsningen kommer att visas i utforskaren vyn under komponent valts i steg 5. Pilen anger riktningen för tvång och i det här fallet kommer att peka uppåt och åt vänster. Hänglåset är färgad beroende på om begränsningen är funktionshindrade (grå), varnade (gul) eller påtvingade (röd).

Barn måste ha förälder varnas begränsning

För att definiera en topologi tvång, där en komponent måste vara ansluten till en specifik anslutning

4. På Lägg Constraintfönstret kryssa i Skapa Constraintkryssrutan under Komponent skall bifogas Constraint område.

5. Välj anslutningstypi listrutan som du vill ange som bifogat av komponenttypen högerklickar i steg 3. (Eller välj komponenttypi listrutan som du vill ange som den bifogade komponenten om i steg 3 du högerklickat på en anslutningstyp.)

Notera

Om det redan finns en aktiverad "Component ska bifogas" begränsning definierats för komponenttypen och en annan typ av anslutning då denna nya begränsning kommer att behandlas som en "OCH". Det är komponenttypen skall bifogas anslutning typ A ochanslutning typ B, till vilken verkställighet nivå (t.ex. funktionshindrade, varnas eller verk - se steg 7) anges för varje begränsning.

6. Du kan även välja en anslutning rollatt du vill lägga till begränsningen. Svälja den specifika roll (dvs antingen källa eller Sink) från rullgardinsmenyn.

7. Välj om du vill att begränsningen vara Funktionshindrade, Varnade eller Påtvingad.

Notera

Funktionshindrade begränsningar kommer att ignoreras av tvång validering kommer varnas begränsningar producera en varning i validering fönstret om de upptäcks och påtvingade begränsningar kommer att producera något fel i validering fönstret om de upptäcks. Dessutom måste alla fel lösas innan ett Företag Server kan begås projekt.

8. Klick ok.

För att definiera en topologi tvång, där en förbindelse måste vara ansluten till en specifik komponent

4. På Lägg Constraintfönstret kryssa i Skapa Constraintkryssrutan under Anslutning skall bifogas Constraint område.

5. Välj anslutningstypi listrutan som du vill ange som bifogat av komponenttypen högerklickar i steg 3. (Eller välj komponenttypi listrutan som du vill ange som den bifogade komponenten om i steg 3 du högerklickat på en anslutningstyp.)

Notera

Om det redan finns en aktiverad "Connection ska bifogas" begränsning definierats för anslutningstypen och en annan komponent typ som använder samma anslutning roll(dvs antingen Källa eller Sink), då denna nya begränsning kommer att behandlas som en "ELLER". Det är anslutningstypen skall bifogas komponent typ A ellerkomponenttyp B, och verkställighet nivå (t.ex. varnas eller verk - se steg 7) bör vara samma annars påtvingade begränsningar kommer alltid att åsidosätta varnade dem. Observera också, att om det finns flera begränsningar som har samband rollanges som "Alla" (i motsats till specifikt Source eller Sink) sedan varje ände av förbindelsen ska bifogas ett av de komponenttyper som anges i begränsningarna.

6. Du kan även välja en anslutning rollatt du vill lägga till begränsningen. Svälja den specifika roll (dvs antingen Källa eller Sjunka) från rullgardinsmenyn.

Notera

Antingen en källa eller Sink roll måste uttryckligen ut för en Fastsättning kolonn för att vara disponibelt för att visas i en komponent katalog .

7. Välj om du vill att begränsningen vara Funktionshindrade, Varnade eller Påtvingad.

Notera

Funktionshindrade begränsningar kommer att ignoreras av tvång validering kommer varnas begränsningar producera en varning i validering fönstret om de upptäcks och påtvingade begränsningar kommer att producera något fel i validering fönstret om de upptäcks. Dessutom måste alla fel lösas innan ett Företag Server kan begås projekt.

8. Klick ok.

Realtid modell kontroll och tvång godkännande

ABacus innefattar enrealtid Modell Kontroll och Valideringsfunktionen till omedelbart visa effekterna en viss användare operation kommer att ha på varningar och fel med det aktuella projektet, på grund av alla hierarki och topologi begränsningar som har definierats. Det bör noteras att alla fel måste lösas innan ett Företag Server kan begås projekt.

Realtids begränsning valideringsfunktionen är mest märkbara när fylla med diagram eller direkt i Utforskaren. I synnerhet under de följande åtgärder är vägledning ges med färgslingor som effekten operationen kommer att ha på varningar och fel med det aktuella projektet;

1. När du drar element på eller runt ett diagram färgen på moder (eller fästa) komponentens (i förekommande fall) gränsen kommer att färgas enligt schemat nedan.

2. När du ansluter komponenter använder högerklicka dra | Anslut till funktionen listan över tillgängliga Anslutningstyper färgas enligt schemat nedan.

3. När du ansluter komponenter i diagramform som använder Connector läget markören ändra färger enligt schemat nedan.

4. När du lägger delkomponenter listan över tillgängliga Komponenttyper färgas enligt schemat nedan.

I allmänhet följande färger används för att ange vilka effekter användaroperationen kommer att ha på varningar och fel med det aktuella projektet;

Svart : Ingen påverkan på varningar eller fel.

Grön : Funktionen är uttryckligen i enlighet meddefinierad hierarki och topologi begränsningar för projektet.

Röd : Funktionen är uttryckligen i strid medde definierade hierarkin och topologi begränsningar för projektet och kommer att resultera i varningar och / eller fel.

Bakgrund modell kontroll och tvång godkännande

ABACUS innefattar en Validering funktion för att visa alla varningar och fel med det aktuella projektet, på grund av eventuella begränsningar som har definierats. Det bör noteras att alla fel måste lösas innan ett Företag Server kan begås projekt.

Notera

Validering måste manuellt köra via "Validera / Kolla Projekt Begränsningar" -knappen på Verktygsfältet . Validering fönstret döljs som standardmen kommer att visas när knapp i verktygsfältet klickas. Se Anpassa gränssnittet Information om hur du ta fram den och eventuellt lämna det permanent visas. Dessutom kan du dubbelklicka på en rad i validering fönstret till "hoppa" till det aktuella elementet i projektet.

Validering fönster

Standard kolumner i validering fönstret beskrivs på följande sätt;

Varning eller fel: I den här kolumnen visas en ikon för om kränkningen är en varning (gul triangel med ett utropstecken) eller fel (röd cirkel med ett kryss).

Antal: I denna kolumn visas kränkning nummer.

Notera

Endast 200 överträdelser visas vid en tid och om det finns mer än 200 brott i ett projekt på Start, Föregående, Nästa och End rad navigatorer längst upp till höger i fönstret kan användas för att bläddra ytterligare kränkningar.

Beskrivning: Detta är en fullständig beskrivning av brott, inklusive företagets och de berörda Constraint.

Enhet: I denna kolumn visar företagets oro för brott.

Typ: I denna kolumn visar elementtypen för företaget.

Arkitektur: I denna kolumn visar arkitekturen inom vilken överträdelsen begicks.

Detekteras: I den här kolumnen visar den tid som överträdelsen upptäcktes.

Dricks

Det är nyttigt att sortera fallande av Upptäckt kolonn (som visas i dialogrutan ovan) för att säkerställa de senaste kränkningarna visas på "överst" i listan.

Det finns flera användar alternativ för att ändra beteendet hos bakgrunden modell validering. Exempelvis to ändra färger som används för villkors brott till något annat än standard Röd, klick på Verktyg | Alternativ ... sedan gå till de Godkännandefliken, och ställa in färgerna via Ändra knappar.

Godkännande alternativ

För att manuellt validera begränsningar

1. Högerklick på Arkitekturernod kan alla arkitekturer eller någonstans i antingen Ingående delar eller Anslutningardel av utforskaren vyn och välj Kolla Begränsningar.

Validera begränsningar

2. Klicka på Detaljerknappen på Varningarfönstret för att se var arkitekturen bryter några begränsningar som har definierats.

Notera

Överträdelser visas endast för de begränsningar som har fastställts till varnas eller påtvingad. Vidare ordalydelsen i varnings kommer att omfatta "bör" om begränsningen var bara en varning eller "måste" om det genomförs.

3. Klick ok.

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt


Evolving din arkitektur

Navigering: Fylla din arkitektur> Fylla manuellt> Tillval>

Evolving din arkitektur

Skicka kommentarer om detta ämne.

Arkitekturer kan explicit utvecklats och en hierarki av arkitekturer skapas. Således genom att utveckla din arkitektur i ABACUS, kan ett antal avancerade arkitektoniska lösningar skapas, jämföras och baselined. Mål (eller statistik) kan definieras för ett obegränsat antal arkitektoniska egenskaper för befintliga arkitekturer.

Ett enkelt sätt att betrakta utvecklingen av en arkitektur är att relatera den till begreppet ättling arkitektur. När en arkitektur utvecklas, en kopieraav moder arkitekturen skapas. Denna kopia kan sägas vara en direkt ättlingav den ursprungliga förälder arkitektur.

Notera

I denna onlinehjälp dokumentationen och ABACUS verktygen själva termen utvecklasär mer vanligt förekommande än termen ättlingObservera att båda hänvisar till samma funktionalitet.

För att utveckla en befintlig arkitektur

1. Se till att du har en ABACUS filöppen och Explorer-fönstervisas.

2. Välj relevant arkitektur du vill utvecklas från explorer trädet.

3. Högerklickpå arkitekturen och väljer Utvecklasfrån menyn.

Utvecklas den utvalde Architecture

4. Den utvecklade arkitekturen kommer att visas under den valda arkitekturen.

Evolved Architecture

Notera

Den utvecklade arkitekturen kan döpas genom att högerklicka på arkitektur och välja Döpa om.Dessutom kommer alla diagram och katalogerna den utvecklade arkitekturen automatiskt in på "diff" mot baslinjen arkitektur att det utvecklats från.

Sätta upp mål för din utvecklats arkitektur

Sätta upp mål för din utvecklades arkitekturen gör att du kan skapa en kriterier för att bedöma utvecklingen av dina arkitekturer. Mål bestäms av fastighetstyper och namnen på de fastigheter som finns i din utvecklats arkitektur. Mål kan också manuellt definieras och läggs till dig arkitektur. Följ anvisningarna nedan för att sätta upp mål.

Sätta upp mål från befintliga fastigheter för din utvecklats arkitektur

1. Se till att du har en ABACUS filöppen och Explorer-fönstervisas.

2. Välj Verktyg | Uppsatta målFrån huvudmenyfältet.

3. De Mål Ingångfönstret visas.

Mål Ingångsfönstret

4. Klicka på Existerande knapp.

5. De Välj en fastighetfönstret visas.

6. Välj en egenskap som du vill ställa in som ett mål för din utvecklats arkitektur och klicka på ok knapp.

7. Den valda målet visas nu i Mål Ingång fönster.

8. Välj mål och klicka på Redigera knapp.

9. De Redigera Målfönstret visas.

Notera

Det här fönstret låter dig ändra egenskapsnamn och typ att målet kommer att spegla, liksom de värsta och bästa värdet (eller minimum / maxvärden) för den egenskapen. Dessa värden hittas genom att jämföra alla arkitekturer och hitta den minsta och största värdet i varje för den specifika fastighet. Dessa värden kan också manuellt definieras. Till exempel, om du skulle sätta upp ett mål för egenskap med namnet Response (Ave)och av typen Beteende, Din värsta och bästa värde kan återspegla transaktionshastighet som behövs för optimal prestanda (bästa värde) och transaktionen hastighet som behövs för endast huvud ansökningar som skall behandlas (sämsta värdet).

10. När de relevanta värden har definierat väljer ok.

Sätta upp mål från nya egenskaper för evolved arkitektur

1. Se till att du har en ABACUS filöppen och Explorer-fönstervisas.

2. Välj Verktyg | Uppsatta målFrån huvudmenyfältet.

3. De Mål Ingångfönstret visas.

4. Klicka på Ny knapp.

5. De Nya målfönstret visas.

Notera

Det här fönstret kan du ange fastighets namn och typ att målet kommer att spegla, liksom det värsta och bästa värdet (eller minimi / maxvärden) för den egenskapen. Till exempel, om du skulle ställa upp ett mål för egenskap med namnet Response (Ave)och av typen Beteende, Din värsta och bästa värde kan återspegla transaktionshastighet som behövs för optimal prestanda (bästa värde) och transaktionen hastighet som behövs för endast huvud ansökningar som skall behandlas (sämsta värdet).

6. När de relevanta värden har definierat väljer ok.

7. En dialogruta Lägg till alla arkitekturervisar enligt nedan:

8. Klicka på Jaatt lägga målet som en egenskap till alla relevanta arkitekturer. Detta säkerställer att den nyligen definierade mål och dess egenskaper kommer att läggas till alla arkitekturer i filen. Om du inte vill inkludera fastigheten i arkitekturer, kan du klicka på Nej.

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Visning av en stjärna tomt på dina utvecklats arkitekturer | Visning av en punktdiagram av dina utvecklats arkitekturer


Ritverktyget

Navigering: Fylla din arkitektur> Använda Drawings>

Ritverktyget

Skicka kommentarer om detta ämne.

Ritverktyget gör det möjligt att skapa ett brett utbud av arkitektoniska scheman och diagram. Arkitekter traditionellt använda en rad olika ritningar för att spela in och förmedla designen av en arkitektur. Tvådimensionella (2D) diagram är det vanliga sättet att dokumentera och kommunicera olika delar av ett system. Typiska teckningar typer som används i affärssystem är:

· Affärsprocessmodeller och diagram;

· Organisationsplaner;

· Samarbetsdiagram;

· Entity-Relationship (ER) diagram;

· Data-Flow Diagram (DFD s);

· Klassdiagram;

· IDEF (införliva flera av ovanstående); och

· UML (som innehåller flera av ovanstående).

Det finns verkligen ingen gräns för vilka typer av diagram som kan skapas. ABACUS försöker balansera diagram flexibilitet och samtidigt bevara integriteten av arkitekturen och dess representationsformer.

Ritmiljön är en flikar och dockningsbar fönster innanför huvud ABACUS ansökan. Detta fönster innehåller en duk där ritningen sker och när ritningen fönstret är öppet en andra förankringsbara fönster , Schablonen fönstret, är synlig med en uppsättning ritnings schabloner. Schablonen rutan har 4 flikar: Komponenter, Anslutningar, former och kontaktdon. Duken visas som en vit bakgrund med fina rutnätslinjer (hjälp för layout).

Komponenter representeras av en rad olika former, medan anslutningar ritas som riktade linjer. Anslutningar fäster komponenter med hjälp av roller (dvs antingen källa eller Sink) även om dessa är inte visade av estetiska skäl.

Dricks

Medan diagramär mycket användbara för att visa olika delar av ett system, de är begränsade i sin skalbarhet, vilket är anledningen till ABACUS använder 3D för att visualisera komplexa systemstrukturer.

Du kanske vill

1. Öppna Diagramming Verktyg

2. Skapa ett nytt diagram en del av en din arkitektur

3. Kopiera ett diagram inom eller mellan arkitekturer

4. Lägg komponenter till ett diagram

5. Skapa nya komponenter och anslutningar i din arkitektur (schematiskt) med ritverktyg

6. Radera komponenter från ett diagram

7. Fäst & manipulera anslutningar

8. Ändra visningsegenskaper komponenter och anslutningar.

9. Använda länkar i diagram

10. Driva liknande institut och synpunkter i syfte att begränsa de typer av diagram som kan dras.

Se också

Fylla din arkitektur | Fylla din arkitektur manuellt | Analysera din arkitektur


Öppning Scheman

Navigering: Fylla din arkitektur> Använda Drawings>

Öppning Scheman

Skicka kommentarer om detta ämne.

Ritningen stencil och duk fönster visas automatiskt när ett diagram öppnas eller skapas. Likaså försvinner när ett diagram är stängd motsvarande flikbladet i duken fönstret och om inga ytterligare ritningar är öppna sedan schablonen fönstret stängs.

Till skapaett nytt diagram

1. Se till att du har enABACUS filen öppeninnehåller din befolkade arkitektur.

2. Klicka på Diagramikonen i verktygsfältet Visa.

- eller -

2. Välj Föra in| Diagram.

- eller -

2. Högerklick de Diagramgren av en given Arkitekturavsnitt av trädet och väljer Skapa Diagram.

3. Välj Arkitekturdu vill fokusera på från rullgardinsmenyn. Observera: arkitekturen är redan vald för dig om du använt steg 3 ovan för att öppna nya diagrammet.

4. Välj Synpunkt du vill använda från rullgardinsmenyn. Obs: den valda synvinkel kommer att filtrera komponenterna och anslutningar listor bara vara de som är tillgängliga på synvinkel.

5. Eventuellt välja en vy från Filter By Visarullgardinsmenyn för att förvälja komponenter och anslutningar från den valda vyn. Obs: detta är ett effektivt sätt att använda den valda vyn som en sparad fråga.

6. Välj Layout att vara antingen Radiell eller Rutnät.

7. Välj Ingående delar och Anslutningarsom du vill ha i diagrammet från Fönstret för val standardelement .

8. Klick ok.

Notera

Ett nytt diagram kommer att läggas till Diagramgren av arkitekturen. Det kommer att ha en standardnamnet, som du kan ändra senare genom att högerklicka på den.Dessutom kommer det sista tillståndet av komponent och urvals anslutning filter sparas med diagrammet effektivt rädda "query" som används för att skapa diagrammet.

Om du vill öppna ett befintligt diagram

1. I det specifika befolkade arkitektur, expandera Diagramgren i trädet.

2. Dubbelklicka diagrammet som du vill öppna.

Om du vill spara ett diagram

1. Se till att du har en ny eller befintlig diagram öppnaoch du har gjort de nödvändiga ändringarna. Obs: en asterisk "*" kommer att visas efter vynamn i flikbladet huvudet om det sker förändringar som ska sparas.

2. I explorer vyn klickar du på Sparaknappen eller fått Fil| Sparaeller sänka Ctrl + Sför att spara alla ändringar i din arkitektur och skriva till filen.

Om du vill spara ett diagram som en synpunkt

1. Se till att du har en befintlig diagram i ABACUS fil.

2. Högerklickdiagrammet i Diagramdel av trädet.

3. Välj Spara som Diagram Viewpoint.

4. Skriv in ett namn på den nya schema synpunktoch klicka ok.

Se också

Ritverktyget | Fylla din arkitektur | Analysera din arkitektur


Kopiering diagram

Navigering: Fylla din arkitektur> Använda Drawings>

Kopiering diagram

Skicka kommentarer om detta ämne.

Det finns 2 grundläggande scenarier till att kopiera ett befintligt diagram; inom en arkitektur eller över arkitekturer.

Till kopieraett diagraminom en arkitektur

1. Se till att du har enABACUS filen öppeninnehåller din befolkade arkitekturmed åtminstone en diagram.

2. Bygga ut de Diagram gren (och om all nödvändig Diagram grupper) av en given Arkitekturavsnitt av trädet.

3. Välj diagrammet som du vill kopiera och tryck sedan på Ctrl + C eller högerklickoch välj Kopiera från menyn.

Notera

A kopia av den diagram kommer att läggas till Diagramgren av samma arkitektur. Det kommer att ha "Kopia av" bifogat till starten av namnet, Som du kan ändra senare trycka på F2 eller högerklicka på detoch välja Byt namn.

Till kopiera ett diagram över arkitekturer

1. Se till att du har enABACUS filen öppeninnehåller din befolkade arkitektursmed åtminstone en diagram.

2. Bygga ut de Diagram gren (och om all nödvändig Diagram grupper) av de Arkitekturavsnitt av trädetför arkitektur som innehåller diagrammet som du vill kopiera.

3. Välj diagrammet som du vill kopiera på Allmänna egenskaperfönstret OBS Synpunkt att diagrammet är kopplat till (i fältet Typ).

4. Nu, bygga ut de Diagram gren (och om all nödvändig Diagram grupper) av de Arkitekturavsnitt av trädetför andra arkitektur som du vill kopiera diagrammet till.

5. Högerklick de Diagram nod (eller den Diagram grupp) Och välj Skapa diagram .... I dialogrutan som visas väljer du Synpunkt som noterades i steg 3 ovan i rullgardins längst upp till höger. Lämna allt annat som är och klicka ok. I dialogrutan Diagram Namnge ange ett namn för den (snart att vara) kopieras diagram. Anmärkning: En tom schema duk enligt den valda synvinkeln kommer att öppnas.

6. Återgå till diagrammet som du vill kopiera och öppna det genom högerklickanoden och välja Öppna eller bara dubbelklicka Det.

7. Välj bakgrunden duk av diagrammet som du vill kopiera och trycker Ctrl + A. Detta kommer att välja alla element på den diagram. Tryck Ctrl + Catt kopiera innehållet till Urklipp.

8. Nu, tillbaka till den tomma diagrammet i arkitekturen som du vill kopiera innehållet i, välj bakgrundenduk och antingen högerklickoch välj Klistra eller helt enkelt trycka Ctrl + Vatt klistra in innehållet. Efter en kort tid innehållet alla kommer att klistras in i nya tomma diagrammet.

Notera

Element kommer att läggas till den högsta nivån på den nya arkitekturen och måste åter arrangeras eller fusione med befintligt innehåll i enlighet.

Se också

Ritverktyget | Fylla din arkitektur | Analysera din arkitektur


Befolka Diagrams

Navigering: Fylla din arkitektur> Använda Drawings>

Befolka Diagrams

Skicka kommentarer om detta ämne.

Ritningar i ABACUS är mer än bara godtyckliga representationer. De är anpassade vyer av arkitektur, formateras och arrangerade att visa särskild betydelse.

Ritverktyget upprätt den hierarkiska strukturen av arkitekturen, så att komponenter visuellt kapslade i andra komponenter - effektivt ger en "uppifrån" av elementen. När en komponent eller en anslutning har definierats i arkitekturen, kan den användas i ett godtyckligt antal olika diagram. Viktigt är ritverktyget nära knuten till den arkitektoniska modell, så att förändringar görs i den ena är alltid återspeglas i den andra.

Verktyget fungerar genom att associera former med särskilda anslutnings- och komponenttyper som anges i den del av arkitekturen typer. Dessa föreningar varierar beroende på vilken typ av diagram som dras, och det är möjligt att en typ av komponent (eller anslutning) kan ha olika representationer i de olika diagrammen, beroende på sammanhanget.

För att ställa in en association mellan en form och en komponent eller anslutningstyp

1. Se till att du har en ny eller befintlig schema öppen .

2. Maximera ABACUS ansökan, och konfigurera fönster proportionerna som du önskar.

3. Välj Fliken Former eller Fliken Kontaktdon i schablonen fönstret.

4. I Typgren av Utforskaren komponenten eller anslutningstyp du vill associera med en form eller kontakt.

5. Välj den valda typen elementet från trädet, dra den över till fliken former eller fliken kontakter, och släpp den på formen eller anslutningendu vill använda.

Notera

Du kan verifiera en förening som du har skapat genom att välja komponenter eller fliken Anslutningar i Stencil fönstret som visar de aktuella associerade elementen.

För att lägga till nya former för att din scheman / bibliotek

1. Skapa en MS Visio diagram med de former som du vill lägga till ditt diagram och importera MS Visio diagram .

Dricks

Det är viktigt vilken storlek du gör huvud form i MS Visio eftersom ABACUS duken är dimensionerad i pixlar och endast Millimeter enheter i MS Visio konvertera noggranna till pixlar på en 4 pixlar till en Millimeter förhållande. Dessutom standard ABACUS former är vanligtvis 60 pixlar hög så som översätter till 15 millimeter i MS Visio. Vilket är en lämpligt originalform storlek i MS Visio är 25mm bred och 15 mm högeftersom detta kommer att översätta till 100 pixlar bred och 60 pixlar hög i ABACUS.

Dricks

Om du vill ha en lite "ikon" i det övre vänstra hörnet av en form så kan du helt enkelt skapa "ikonen" i master MS Visio form med hjälp av paletten MS Visio Drawing Tool (observera att endast enkla linjer, cirklar och rektanglar stöds och rastrerade / bitmapp former i synnerhet stöds inte). Dessutom, om du vill att ikonen för att vara fastställs i storlek / skalainom formen i ABACUS då kan du gruppera "ikonen" i master MS Visio form genom att markera alla dess delar, högerklicka ett element, välja Shape | Grupp, sedan högerklicka på grupperade formen och välja data | Shape Data ..., väljer Ja i dialogrutan som visas och sedan lägga till en fastighet med Label satt till LockScale(notera versal "L" och "S"), typ inställd på Boolean och värdet inställd på att vara SANN (observera det är alla i versaler).

Dricks

Om du vill ha en del av formen fryst från skalning horisontellt eller vertikalt (som är typiskt med en "swimlane" form) så kan du högerklicka på partiet (er) av befälhavaren MS Visio form som du vill ha fryst från skalning och välj Data | Shape Data ..., väljer Ja i dialogrutan som visas och sedan lägga till en fastighet med Label satt till LockXScale eller LockYScale (notera versal "L" och "S"), typ inställd på Boolean och värdet inställd på att vara SANN (observera det är alla i versaler), för låst horisontell eller vertikal skalning respektive.

Dricks

För att göra det möjligt för färgning av formen i ABACUS efter import snarare än formen alltid är en fast färg det är lämpligt att göra befälhavaren MS Visio form fyllning transparent och sedan använda den inbyggda förmåga i ABACUS att färga en form bakgrund. Detta fungerar bara med rektangel eller nästan rektangel (t.ex. rundad rektangel) former som hela rektangulära bakgrunden kommer att färgas.

2. Öppna motsvarande diagram och välj Fliken Komponenteri schablonen fönstret.

3. För varje ny form som du vill göra tillgängliga för andra diagram Högerklickformen och välj Lägg till Shapes bibliotek. Detta kommer att göra formen finns på fliken Former i schablonen fönstret.

4. Koppla relevant komponenttyp med den nya formen från Former biblioteket enligt de steg som beskrivs ovan.

Notera

Endast enkel och "vektorbaserad" former stöds i ABACUS just nu är alltså bitmappar stöds inte. Men verktyg som Vector Magic ( www.vectormagic.com ) Finns tillgängliga som lätt kommer att konvertera bitmappsbilder till vektorbaserade former (dvs. SVG-format) som kan öppnas i MS Visio och därmed utnyttjas i ABACUS enligt instruktionerna ovan.

LäggaKomponenter och anslutningar

Ritverktyget kan du lägga till befintliga komponenter och anslutningar från förvaret eller skapa nya komponenter och anslutningar som du ritar ett diagram. Som komponenter och anslutningar skapas i diagrammen, de samtidigt läggs in i förvaret. Det finns tre rekommenderas sätt att lägga till komponenter till ett diagramoch tre rekommenderade sätt att lägga till anslutningar till ett diagram:

För att skapa en helt ny komponent eller anslutning på ett diagramfrån stencilen

1. Se till att du har en ny eller befintlig schema öppen.

2. Välj Ingående delar eller Anslutningarflik i stencilen fönstret för att se tillhörande formar. Endast dessa former kan användas för att skapa nya modellelement.

3. Klicka och draen av de tillgängliga associerade former på arbetsyta. Det nya kommer att visas på duken och i explorer trädet.

4. Börja skrivaett namn för det nya elementet i dialog och befintliga element som matchas föreslås och kan väljas i stället för att lägga till ett nytt element i arkitekturen.

5. Klick ok.

6. Om en form droppades på en befintlig komponent, så kommer det att antingen bli ett barn av denna komponent (om formen kom från Ingående delarflik), eller kommer att knytas till den komponenten (om formen kom från Anslutningar flik).

Notera

Det är ibland nödvändigt att justera den nya komponenten eller anslutning till en annan plats i den arkitektoniska hierarkin med hjälp av utforskaren.

För att placera en befintlig komponent eller anslutning från förvaret på ett diagram

1. Se till att du har en ny eller befintlig schema öppen.

2. Se till att du har både ritverktyget och Explorer-fönster kan visas.

3. I utforskaren letar du upp komponent eller förbindelse(element) som du vill lägga till i diagrammet.

4. Klicka och dradet valda elementet på diagrammet. En form som representerar elementet visas på duken.

Notera

Om typen av valda elementet är redan förknippad med en form, kommer motsvarande form visas på duken. Men om det inte finns någon definierad förening för att visst element, kommer en standardform (rektangel) visas på duken, såvida inte Enforce Diagram Synpunkter alternativet är i vilket fall formen inte kommer att läggas till diagrammet.

Dricks

När en komponent placeras på ett diagram som redan är ansluten till en annan komponent i diagrammet, kommer ritverktyget fråga om du vill visa anslutning (s) mellan dem. Även om det finns några barn komponenten ritverktyget kommer att fråga om du vill inkludera barnen i en rekursiv sätt.

Till skapa en anslutning mellan 2 komponenter eller en ansluten komponent på ett diagram med hjälp av dynamisk kontakt

1. Se till att du har en ny eller befintlig schema öppen.

2. Sväva över en komponent i diagrammet som du vill ansluta till en annan komponent och du kommer att märka 2 ikoner visas utanför topp till höger på gränsen av formen som visas nedan. Obs: Den översta ikonen för att skapa en anslutning där svävade komponenten är att vara källan, är botten ikonen för att skapa en anslutning där svävade komponenten är att vara diskhon.

3. Flytta markören över önskad ikon och Klicka och draikonen till över antingen över en annan komponent eller ledigt utrymme på duken som visas nedan.

4. För att ansluta till en befintlig komponent välja Fäst till ...objekt i popupmenyn och vid behov bläddra till undermenyn för att välja bland de tillgängliga anslutningstyper.

- eller -

4. Så här skapar du en ansluten komponent valde från Ny...poster i popupmenyn och om det behövs bläddra till undermenyn för att välja bland de tillgängliga anslutningstyper som visas nedan. Börja skrivaett namn för det nya elementet i dialog och befintliga element som matchas föreslås och kan väljas i stället för att lägga till ett nytt element i arkitekturen.

Notera

Tillgången på objekt i popupmenyn och undermenyn styrs av begränsningar i meta modellen.Det är bara giltig källa eller sjunka komponenttyper som bestäms av anslutningsbegränsningar kommer att presenteras som Bifoga till ... och New ... menyalternativ.

Till åter öppna dialogrutan elementet för val av och placera befintliga komponenter eller anslutningar från förvaret på ett diagram

1. Se till att du har en ny eller befintlig schema öppen.

2. Klick de Öppen Element Urvalknappen i Diagram verktygsfältet. Anmärkning: dialogrutan för val elementet öppnas med den sista tillståndet för eventuella filter sparas.

3. Välj något extra innehåll som önskas läggas till diagrammet och klicka ok. Obs: det nya innehållet kommer att läggas till fritt utrymme på duken och diagrammet kan vara senare anges igen via Plandiagramknappen i Diagram verktygsfältet.

Använda FreeformFormer

Det är ofta önskvärt att skapa visuella element i ett diagram av rent estetiska skäl. Dessa element kan bidra till att förbättra layout och utseende av ett diagram, men de har inte en strikt arkitektoniska betydelse. Ritverktyget tillåter användning av freeform former för att åstadkomma ritning flexibilitet.

Om du vill lägga en fritt formulerad form till ett diagram

1. Se till att du har en ny eller befintlig schema öppen.

2. Välj Former eller Kontaktdonflik i stencilen fönstret.

3. Klicka och draen av de tillgängliga former eller kontakter på arbetsyta. Det nya kommer att visas på duken - men intei explorer trädet.

Notera

Freeform former "icke-associerad" former, eftersom de inte har något samband med någon särskild komponent eller anslutning i den arkitektoniska modell.

Till visa förvarets informationen i freeform formsonett diagram

1. Se till att du har en ny eller befintlig schema öppen.

2. Högerklickden freeform form och välj Notering | Visa.

3. Välj att visa antingen Diagram Namn, Diagram Beskrivning, Diagram Egenskap, Viewpoint Namn eller Arkitektur Namn.

Notera

Texten i freeform uppdateras automatiskt när de underliggande förvars data ändras.På detta sätt kan skapas ett diagram "titelblocket" för, och sedan enkelt kopiera över, diagram.

Använda Flytande former

Flytande former är väsentligen ett annat sätt att representera komponenter i ett diagram. Överväga en organisation med viktiga avdelningar: VD, marknadsföring, försäljning och utveckling.

Trädvy

Dessa indelningar får visuellt representerad i ett skiktat sätt:

Layered Vy

Eller också kan de visuellt representeras på ett förskjutet / flytande sätt att visa hierarki:

Förskjutna / Flytande Se

Den sistnämnda representation använder begreppet flytande former.

Om du vill konvertera en skiktad komponent form till en flytande form

1. Se till att du har en ny eller befintlig schema öppen.

2. Välj komponenti diagrammet du vill representera som en flytande form eller en associerad form i Ingående delarfliken schablonen fönstret du vill att alla instanser som flytande former.

3. Högerklicka på formen och välj Float Komponent från snabbmenyn som visas. Notera diamant headed anslutningfrån moderkomponent (er) till den flytande komponenten (-erna).

4. Klicka och drakomponenten till den önskade platsen. När en flytandekomponenten är vald kommer det att ha en blå kontur.

Om du vill konvertera en flytande komponent form till en skiktad form

1. Se till att du har en ny eller befintlig schema öppen.

2. Välj komponenti diagrammet som för närvarande visas som en flytande form eller en associerad form i Ingående delarfliken schablonen fönstret du vill att alla instanser som skiktade former.

3. Klicka och draden flytande komponenten (-erna) tillbaka till moder (er) (i enlighet med den diamant headed anslutning). Obs: Om du inte gör detta då när du konverterar komponenten (s) tillbaka till att vara lager hierarki din modell kan påverkas.

4. Högerklicka på formen och avmarkera Float Komponent från snabbmenyn som visas. Notera att diamant headed anslutningfrån moderkomponent (er) till den flytande komponenten (-erna) kommer att försvinna.

Repliker

Ritverktyget kan du lägga till samma komponent till ett diagram flera gånger med varje ytterligare visuell instans hos komponent på diagrammet kallas en replika. Detta är särskilt användbart för diagram där en komponent har ett stort antal anslutningar knutna till det och det är att föredra att visa komponent i flera platser närmare ursprunget för var och en av anslutningarna, eller diagram där en en-till-många-relation av en komponent är att föredra att visa med hjälp av flytande funktionen (se ovan) med komponenten på flera platser på toppen av "många" komponenter det är relaterat till.

Notera

Du kan bifoga / ta bort anslutningar till / från den ursprungliga instansen av komponenten på ett diagram (som alltid) men också något av repliker, men när anslutningar automatiskt till ett diagram de är knutna till den första förekomsten av komponenten på diagrammet som standard.

Notera

Repliker kan slås samman med varandra genom högerklicka och drasedan välja Merge replikerMen en sammanslagning en replik med en annan komponent kommer att resultera i några andra repliker försvinner från diagrammet.

Notera

Det finns ingen visuell skillnad mellan den ursprungliga instansen av en komponent på ett diagram och eventuella kopior. Dessutom är högerklicksmenyn för den ursprungliga komponenten på ett diagram och alla repliker identiska, med till exempel Visa i Explorertar dig till samma komponent i trädvyn av förvaret (aka modell). Men högerklicka på komponenten i trädvyn av förvaret och välja Gå tilloch bläddra till ett diagram med repliker kommer alltid att ta dig till "äldsta" instans av komponenten i diagrammet. Vanligtvis kommer detta att vara ursprungliga instansen som har lagts till diagrammet men om det ursprungliga instansen senare tas bort eller slås samman med en replik och sedan gå till kommer att hoppa till den äldsta av de återstående kopior som tillsattes.

Till lägga till en replik till en diagram

1. Se till att du har en ny eller befintlig schema öppen.

2. Högerklicka på en befintlig komponent i diagrammet och välj Skapa replik.En kopia av den valda komponenten kommer att skapas till höger om den ursprungliga komponenten.

- ELLER -

Välj en befintlig komponent på ett diagram och tryck på Ctrl + Celler högerklicka på en befintlig komponent i diagrammet och välj Kopiera. Nu högerklickar du på plats på diagrammet som du vill repliken och välj Klistra in som Replica. Obs! Om du trycker Ctrl + V (eller högerklicka och välja Klistra in) kommer att skapa en kopia av den ursprungliga komponenten inte en replik.

- ELLER -

Klicka och draen komponent från trädvyn av förvaret (aka modellen) på ett diagram där komponenten redan finns.

Konfigurera anslutningslock / Ends

Ritverktyget kan du ange symbol som används vid ändarna av anslutningsledningarna antingen till en fast symbol eller en symbol beroende av en fastighet på själva anslutningen.Detta är särskilt användbart för diagram där det krävs ledning av en anslutning som ska visas, eller för diagram där kardinaliteten av anslutningen (eller riktningen) ingår i en fastighet på själva anslutningen, t.ex. "One-to-Många" vs "Många-till-många" (eller "Source sjunka" vs "Sink att källa").

Till konfigurera anslutningslock / slutar ett diagram

1. Se till att du har en ny eller befintlig schema öppen.

2. Välj Anslutajonerflik i stencilen fönstret.

3. Höger-cslicka en av tillhörande anslutningstyper och välj Konfigurera Caps ....

4. För en fast anslutning lock / slutar vid antingen källan eller sjunka ände av förbindelsen kontrollera den relevanta Fast alternativknappen är markerad och välj sedan anslutningsänden symbolen från pull down, t.ex. "Arrow Head" eller "Diamond".

- ELLER -

För en fastighet baserad anslutning mössa / avsluta på antingen källan eller sjunka i slutet av förbindelsen se till att relevanta Använda Egenskapalternativknappen är markerad, och klicka sedan på "..." knappen och välj önskad egendom och sedan bredvid varje anslutningsänden symbol anger fastighetsvärdena för vilka särskilda anslutningssymbolen ska visas.

Notera

Flera fastighetsvärden för en given anslutning slut symbol kan skrivas in åtskilda med kommatecken. T.ex. dialogrutan nedan visar att om "Data | Kardinalitet "Fastigheten har ett värde av" One-to-Många "då källan slutet av anslutningen kommer att ha två linje stroke genom det och sink slutet av anslutningen kommer att ha en rad slag genom den och sedan en fan-out av två linje stroke i slutet.

Konfigurera dialogrutan Caps

Se också

Ritverktyget | Fylla din arkitektur | Analysera din arkitektur


Manipulera Diagrams

Navigering: Fylla din arkitektur> Använda Drawings>

Manipulera Diagrams

Skicka kommentarer om detta ämne.

När ett diagram har skapats, de element som förekommer i den kan åter arrangeras och återstora enligt önskemål.

Om du vill flytta en komponent i ett diagram

1. Se till att du har en befintlig schema öppen .

2. Klicka och hållvarje komponent för att flytta den. Om den valda komponenten har en förälder, kommer föräldern komponenten markeras.

3. Eftersom elementet ärsläpade från den överordnade komponenten, och över andra komponenter, "potentiella föräldrar kommer att bli markerad. Färgskalan används anger effekten transaktionen kommer att ha på varningar och fel med det aktuella projektet och beskrivs i Utforma och godkänna Begränsningar . På detta sätt kan du grafiskt navigera i hierarkin från en "ovanifrån".

4. Släppmusknappen för att släppa elementet på sin nya plats.

Notera

Du kan också använda tangentbordet för att placera elementen på arbetsyta. Välj bara komponenten eller fri form form du vill flytta och använd piltangenterna på tangentbordet för att flytta formen till önskad plats.

Observera också att när du drar en komponent med musen över en annan komponent är en "potential" moderkomponent markeras när det övre vänstra hörnet av den komponent som du drar överlappar annan komponent.

Dricks

Fri form och Flytande former kan beställas via högerklickaoch välja Längst fram eller Skicka till Backfrån menyn. Det är viktigt att notera att komponentformer kan omvandlas till freeform former genom högerklickapå specifik komponent form och välja Konvertera till frihandsfigur.

För att ändra storlek på en komponent i ett diagram

1. Se till att du har en befintlig schema öppen .

2. Klicka-hold-dragen av komponentens handtag och ändra storlek på formen till önskad storlek.

3. Alternativt att bibehålla formen förhållandet, tryck Shift + Click-hold-drag.

Om du vill flytta en anslutning i ett diagram

1. Se till att du har en befintlig schema öppen .

2. Klicka och hållnågon koppling till flytta den.

3. Släppmusknappen för att släppa elementet på sin nya plats.

Notera

Du kan bara flytta anslutningar som inte är knutna till någon komponent. Om de är bundna, kan du bara flytta den fria ändens, eller omdirigera anslutningen .

Ta bort komponenter och anslutningar

När du tar bort en komponent eller anslutning från ett diagram, kan du välja att ta bort det från hela arkitekturen. Alla komponenter som tas bort från arkitekturen kommer att tas bort automatiskt från andra diagram där det förekommer. Eftersom freeform fall visas endast i ett diagram, ta bort dem påverkar inte den arkitektoniska modell eller någon annan diagram.

Om du vill ta bort en komponent eller anslutning från ett diagram

1. Se till att du har en befintlig schema öppen .

2. Klickpå tillhörande anslutning eller komponent för att välja det.

3. Tryck Raderaknappen för att radera den från diagrammet, eller Skift + Deleteta bort den från hela modellen.

- eller -

2. Högerklicka på tillhörande element eller komponent. En snabbmeny visas.

3. Välj Radera från View eller Ta bort från Arkitekturfrån snabbmenyn.

Notera

Om elementet som du vill ta bort från vyn har inga barn och endast förekommer på denna uppfattning, kommer ABACUS fråga om du vill ta bort elementet från förvaret samt.

Försiktighet

När du tar bort en komponent från den modell som har underordnade komponenter, barnen kommer också att eventuellt tas bort enligt varningsdialogrutan.

Sammanfoga Komponenter

Du kanske vill slå samman två komponenter befintlig i samma diagram (och inom arkitekturen). Detta kan göras av många skäl, till exempel, Två servrar finns inom företagets infrastruktur- H01 och H02. Dessa två servrar representeras som två separata komponenter inom en arkitektur. H01 har bedömts onödigt och därför ska avvecklas. Alla befintliga program som körs på H0En är att skiftas till H02 (fortfarande i provision). Denna förändring kan sedan reflekteras genom verkan av "slå samman" de två komponenterna H01 och H02 på diagrammet (med inom arkitektur).

För en detaljerad diskussion om sammanslagning hänvisas till Sammanslagning Items ämne här .

Att slå ihop två befintliga komponenter

1. Se till att du har en befintlig schema öppen .

2. Högerklicka-hållpå den komponent som du vill slå samman och draden på den komponent som du vill slå ihop den med. Se till konturerna av destinations komponenten är markerad röd för att indikera att den är vald.

3. Välj Merge | Bevara Destination eller Skriv över Destinationfrån menyn.

Notera

De Bevara DestinationAlternativet bevarar värdena för destinations komponentens egenskaper om de finns på komponent den ursprungliga också.

De Skriv över DestinationAlternativet skriver destinations komponentens fastigheter med några gemensamma egenskaper från komponent ursprungs.

Ändra Anslutningar

Anslutningarna som visas i ett diagram alltidåterspegla strukturen som definieras i själva arkitekturen. Ritverktyget kan du ta bort anslutningarna från komponenter, flytta dem, kurva dem, omdirigera dem och åter bifoga dem till andra komponenter.

För att ta bort / bifoga en förbindelse från / till en komponent

1. Se till att du har en befintlig schema öppen .

2. Klicka och hållpå något samband.

3. Välj anslutningen avsluta(d.v.s. Källa eller Sink) Som du vill att lossa / fästa. Obs: anslutningsändar indikeras med små vita cirklar och svävar över den vita cirkeln för en andra kommer att orsaka en "verktygstips" visas med respektive roll namn(dvs antingen källa eller Sink).

4. Draanslutningen avslutas till en ny plats (antingen en ledig plats eller en komponent) och släpp musknappen.

Notera

När en anslutningsände är placerad över en giltig komponent, är konturen av destinationskomponenten markeras med en streckad kontur. Färgskalan används anger effekten transaktionen kommer att ha på varningar och fel med det aktuella projektet och beskrivs i Utforma och godkänna Begränsningar . När utsläppt den ände av the anslutning och komponenten ansluts automatiskt(eller bifogas)Är och detta återspeglas i den arkitektoniska modell.

För att omdirigera en anslutning

1. Se till att du har en befintlig schema öppen .

2. Placera muspekaren över en anslutning.

3. Håll Flyttanedtryckt och Klickmusknappen för att placera en anslutning ankarpunkt. Släpp Flytta nyckel. Du kan ta bort ankarpunkten genom att göra samma operation.

4. Klicka och draankarpunkten för att omdirigera anslutningen.

Dricks

AnvändAlt knapp istället för Flyttanyckel för att skapa ortogonala anslutningar.

Till kurva eller räta en anslutning

1. Se till att du har en befintlig schema öppen .

2. Placera muspekaren över en anslutning.

3. HögerklicktHan anslutning och i snabbmenyn som visas väljer du Kurva, Ortogonal eller Rakt.

Dricks

Alla anslutningarav en viss typ på diagrammet kan ställas in på Böjd, Ortogonal eller Straight genom att högerklicka på tillhörande linje för den typ på Fliken Anslutningar av Stencil fönsteroch välja Kurva, Ortogonal eller Straight.

Till ankare på en specifik punkt på kanten av en form

1. Se till att du har en befintlig schema öppen .

2. Välj en anslutning.

3. Placera muspekaren över den "vita prick" i slutet av en anslutning.

4. Högerklickthan anslutningsände och i snabbmenyn som visas väljer du Förankra Endpoint till Shape.Flytta anslutningsände till en önskan plats på kanten av formen.

ELLER

Håll Ctrlnedtryckt och click-och-dra de anslutningsände peka mot önskan plats på kanten av formen.

Notera

Anslutningar snäpper till själva skärnings deras anslutna form i stället för markeringsramen för denna form.

Se också

Ritverktyget | Fylla din arkitektur | Analysera din arkitektur


Ritverktyget Funktioner

Navigering: Fylla din arkitektur> Använda Drawings>

Ritverktyget Funktioner

Skicka kommentarer om detta ämne.

Ritverktyget stöder ett antal ritfunktioner.

Zoomning

Omfattningen av diagrammet kan ändras med zoomfunktionen.

För att minska storleken på eller "zooma in"

1. Se till att du har en ny eller befintlig schema öppen .

2. Tryck Ctrloch "=" knappen.

- eller -

2. Välj Zooma inknappen på Diagramverktygsfältet.

- eller -

2. Tryck Ctrloch rulla mushjulet fram-. Obs: I detta läge duken zoomar mot där musen svävar över duken.

För att öka omfattningen eller "zooma ut"

1. Se till att du har en ny eller befintlig schema öppen .

2. Tryck Ctrloch "-" knappen.

- eller -

2. Välj Zooma utknappen på Diagramverktygsfältet.

- eller -

2. Tryck Ctrloch rulla mushjulet bakåt. Obs: I detta läge duken zoomar ut från där musen svävar över duken.

Auto-layout

Layouten av komponenterna i diagrammet kan modifieras automatiskt.

Till layout alla ingående delar on ett diagram

1. Cslicka de Plandiagramknappen på Diagram i verktygsfältet.

2. Välj antingen Radiell layout eller Grid layout.

Notera

Den Radial layout kommer att använda vad som kallas en "force riktad algoritm så att anslutna komponenter dras samman medan osammanhängande komponenter tvingas isär. The Grid layout kommer att använda en fast bredd och höjd distans algoritm. Det gör dels att användaren kan välja den totala schemat Aspect Ratio (t.ex. 16: 9, A4 (porträtt), Letter (Liggande)) och sedan avståndet på sidorna och mellan kolumner och rader som visas nedan.Med Grid layout några anslutningar mellan komponenterna inte påverkar layouten som det helt enkelt arrangerar komponenterna alfabetiskt (av deras namn) från det övre vänstra till nedre högra hörnet på duken. Med båda algoritmerna freeform former inte flyttas.

Till layout barn ingående delar i en ensamstående förälder on ett diagram

1. Högerklicken hög nivå komponent vars barn du vill auto-layout.

2. Välj Layout Barn.

Notera

Som standard endast Radial layout algoritm används.

Ändra element Estetik tycka om Färg, Öppenhet, Skuggor och Rotation

Alla diagramelement har estetik som kan manipuleras så önskas. I fallet med associerade former, kan dessa aspekter sättas per typoch i de flesta fall även per instans. I fallet med freeform former, kan dessa egenskaper ställas in per instanspå duken.

Notera

Alla per exempel aspekter som har satts upp för associerade former kommer att "skrivas över" om samma aspekt ändras för motsvarande typ.

Om du vill ändra färgen på en tillhörande form eller en fritt formulerad form

1. Se till att du har en ny eller befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en tillhörande form eller fritt formulerad form på duken.

3. Välj Byt färg.

4. Välj Fast Färgalternativknappen (i förekommande fall).

5. Välj en Basic Colour eller Definiera en anpassad färg i dialogrutan och klicka på ok.

- eller -

4. Välj Lutningalternativknappen (i förekommande fall).

5. Välj antingen Horisontell, Vertikal, Forward Diagonal eller bakåt Diagonal för gradientriktningen i rullgardins och klicka ok.

6. Välj en Basic Colour eller Definiera en anpassad färg i dialogrutan för Start och Avslutaoch klicka ok.

Notera

ABACUS kommer att färga förgrunden av en form om;
a) det är en "enkel" form med en enda underliggande grafiskt element (t.ex. cirkel, rektangel, polygon etc), eller
b) det är en "komplex" form med flera bakomliggande subshapes som alla är i samma färg / gradient som varandra eller subshapes har LockScale = SANT set.
Om ovanstående villkor inte uppfylls då bakgrunden av formen är färgad.

För att ställa in färgen på en tillhörande form enligt en fastighet

1. Se till att du har en ny eller befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarflik av schablonen fönstret(INTE på ritningen duk).

3. Välj Byt färg.

4. Välj Använda Egenskap radioknapp.

5. Välj en egenskap genom att klicka på "..." knappen till höger om textrutan.

6. Välj Räckvidd radioknapp.

7. Justera Min och Maxvärden enligt önskemål. Obs: något värde under minimivärdet kommer att visas som Min färg och något värde över den maximala kommer att visas som Max färg. Även när du använder Boolean, lista eller datum / tid egenskaper värdena omvandlas till ett index som följer; Boolean (falskt = 0, Sann = 1), List (ett heltal vale 1 till n för varje giltigt värde i deras stigande ordning som anges i fältet Enheter) och datum / tid (antal dagar sedan 1 januari 1900 - inklusive decimaler för timmar, minuter, sekunder delar - och om datumet är pre-1990 är ett negativt tal).

8. Välj en Basic Colour eller Definiera en anpassad färg i dialogrutan för Min och Maxoch klicka ok.

Dricks

Om Grön (RGB - 128,255,0) väljs som Min färg och Röd (RGB - 255,0,0) väljs som Max färg för en fastighet med värdeintervall om 1 till 4då ett värde på 1kommer att visas som Grön, Ett värde på 2 som Gul, 3 som Orange och 4 som Röd.

Alternativt, för en egenskap rad 1 till 3ett värde på 1kommer att vara lika Grön, Ett värde på 2 som Bärnsten och 3 som Rödaka "Traffic Lights" eller RAG status.

För en egenskap intervallet ett till 5 om Blå (RGB - 0,0,255) väljs som Min färg och Röd (RGB - 255,0,0) väljs som Max färga ett värde på 1 kommer att vara lika Blå, Ett värde av 2 som Aqua, Ett värde av 3 som Grön, Ett värde av 4 som Gul och ett värde på 5 som Röd.

För en egenskap område av ett till 6 om Violett (RGB - 255.0.255) väljs som Min färg och Röd (RGB - 255,0,0) väljs som Max färga ett värde på 1 kommer att vara lika Violett, Ett värde av 2 som Blå, Ett värde av 3 som Aqua, Ett värde av 4 som Grön, Ett värde på 5 som Gul och ett värde på 6 som Röd.

Och slutligen, för en egenskap område av 1 till 7 ett värde på 1 kommer att vara lika Violett, Ett värde av 2 som Mörkblå, Ett värde av 3 som Ljusblå, Ett värde av 4 som Blå grön, Ett värde på 5 som Grön, Ett värde på 6 som Bärnsten och ett värde på 7 som Röd

Notera

Se anmärkning ovan på förgrunden kontra bakgrundsfärg.

- eller -

7. Välj Specifikt värde radioknapp.

8. Klicka på Redigera Färger knapp.

9. Välj varje värde i taget och klicka Set Färgatt ange en specifik färg för varje värde.

Notera

Utbudet av värden för ämnen som förekommer på diagrammet kommer att ifyllda.

10. För att lägga till ytterligare färger värde dem förifylld (t.ex. efter egendom sortimentet har konfigurerats) klick Lägg till värde.

Om du vill ändra färg insyn i en tillhörande form eller en fritt formulerad form

1. Se till att du har en ny eller befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en tillhörande form eller fritt formulerad form på duken.

3. Välj Byt färg.

4. I panelen Genomskinlighet ställa in övre skjutreglaget till önskad insyn basfärgen.

5. Om Gradient eller med property alternativ används i panelen Genomskinlighet ställa den nedre skjutreglaget till önskad öppenhet för andra färgen.

6. Klick ok.

Att visa skuggor för alla associerad former i ett diagram

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delarflik av schablonen fönstret.

3. Välj Lägg till Skuggor.

Till visar en skugga på en formkomponent eller freeform form

1. Se till att du har en ny eller befintlig schema öppen .

2. Höger-klickpå komponenten eller freeform formen på arbetsytan.

3. Välj Lägg till Skuggor.

Om du vill rotera komponent former och fri form former i diagram

1. Se till att du har en ny eller befintlig schema öppen .

2. Välj komponent form eller en fritt formulerad form på duken du vill rotera.

3. Högerklickpå formen och välj Roteraoch välj sedan relevant vinkel du vill rotera formen av.

Skiftande Element Anteckningar och Freeform textetiketter

Alla diagramelement har annoteringar vilken kan manipuleras enligt önskemål. I fallet med associerade former, kan dessa aspekter sättas per typoch i de flesta fall även per instans. I fallet med freeform formeroch kontakter, detextetiketter kan ställas in per instanspå duken.Åtta (8) olika typer av kommentarer kan visas för diagramelement (dvs. namn, typ, Värde, Fastighetsförmedling Marker, Attached komponenter, barn (för endast komponenter), standarder och tidsstämplar (Skapad, Ändrad av etc)) i tjugo fem (25) olika positioner (t.ex. Centre - Utanför Top Inside vänster - Centre, utanför Höger - Utanför Bottom).

Notera

Alla per exempel aspekter som har satts upp för associerade former kommer att "skrivas över" om samma aspekt ändras för motsvarande typ.Dessutom, där 2 eller flera anteckningar intar samma position en enda typsnitt, teckensnitt, teckenfärg och storlek kan användas och Separator (t.ex. komma, utrymme, ny rad) måste väljas.

Att visa benämning eller typ för en tillhörande komponent eller anslutning

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en associerad form eller kontakt på duken.

3. Välj Anteckningar.

Notera

För en enskild associerad form eller kontakten på arbetsytan måste du välja Åsido Stencil Anteckningarcheckbox första gången.

4. Välj Ny anteckning i verktygsfältet och välj Namn eller Typ.

5. I dialogrutan som visas väljer du visningsalternativ som önskas, inklusive konsoler och Teckensnitt, stil, teckenfärg och storlek. Också välja layoutalternativ som önskas, inklusive horisontell och vertikal justering (dvs anteckning läge) och vinkeln (dvs rotation). Välj ok.

För att visa en egenskap värde för en tillhörande komponent eller anslutning

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en associerad form eller kontakt på duken.

3. Välj Anteckningar.

Notera

För en enskild associerad form eller kontakten på arbetsytan måste du välja Åsido Stencil Anteckningarcheckbox första gången.

4. Välj Ny anteckning i verktygsfältet och välj Egenskap Värde.

5. I dialogrutan som visas väljer du genom att klicka fastigheten: "..." knappen och välja en fastighet i dialogrutan Välj en fastighetoch välj ok. Välj visningsalternativ som önskas, inklusive konsoler och Teckensnitt, stil, teckenfärg och storlek. Också välja layoutalternativ som önskas, inklusive horisontell och vertikal justering (dvs anteckning läge) och vinkeln (dvs rotation). Välj ok.

För att visa en egenskap markör för en tillhörande komponent eller anslutning

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en associerad form eller kontakt på duken.

3. Välj Anteckningar.

Notera

För en enskild associerad form eller kontakten på arbetsytan måste du välja Åsido Stencil Anteckningarcheckbox första gången.

4. Välj Ny anteckning i verktygsfältet och välj Egenskap Marker.

5. I dialogrutan som visas väljer du genom att klicka fastigheten: "..." knappen och välja en fastighet i dialogrutan Välj en fastighetoch välj ok. Ställ in radien av markören i pixlar och färgningsmetoden till antingen Colour By Range eller Colour By egendom och ställa in färgerna uppdrag. Också välja layoutalternativ som önskas, inklusive horisontell och vertikal justering (dvs anteckning läge) och vinkeln (dvs rotation). Välj ok.

Att visa bifogade komponenter för en tillhörande komponent eller anslutning

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en associerad form eller kontakt på duken.

3. Välj Anteckningar.

Notera

För en enskild associerad form eller kontakten på arbetsytan måste du välja Åsido Stencil Anteckningarcheckbox första gången.

4. Välj Ny anteckning i verktygsfältet och välj Bifogade Komponenter.

5. I dialogrutan som visas, för tillhörande komponenter välja den bifogade komponent genom att klicka på Bifogat: "..." knappen och välja en komponenttyp i dialogrutan Set komponentoch välj ok. Välj den bifogade anslutningstyp genom att klicka på ansluten via: "..." knappen och välja en typ av anslutning i dialogrutan Set Anslutningstypoch välj ok.För tillhörande anslutningar väljer anslutnings slutet genom att välja källa eller sjunka från Anslutnings End: rullgardinsmenyn. För både tillhörande komponenter och anslutningar väljer visningsalternativ som önskas, inklusive konsoler och Teckensnitt, stil, teckenfärg och storlek. Också välja layoutalternativ som önskas, inklusive horisontell och vertikal justering (dvs anteckning läge) och vinkeln (dvs rotation). Välj ok.

Att visa barnen för en tillhörande komponent

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delarfliken schablonen fönster eller en tillhörande form på duken.

3. Välj Anteckningar.

Notera

För en enskild associerad form på duken måste du välja Åsido Stencil Anteckningarcheckbox första gången.

4. Välj Ny anteckning i verktygsfältet och välj Barn.

5. I dialogrutan som visas väljer du visningsalternativ som önskas, inklusive konsoler och Teckensnitt, stil, teckenfärg och storlek. Också välja layoutalternativ som önskas, inklusive horisontell och vertikal justering (dvs anteckning läge) och vinkeln (dvs rotation). Välj ok.

Att visa normerna för en tillhörande komponent eller anslutning

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en associerad form eller kontakt på duken.

3. Välj Anteckningar.

Notera

För en enskild associerad form eller kontakten på arbetsytan måste du välja Åsido Stencil Anteckningarcheckbox första gången.

4. Välj Ny anteckning i verktygsfältet och välj Standarder.

5. I dialogrutan som visas väljer du visningsalternativ som önskas, inklusive konsoler och Teckensnitt, stil, teckenfärg och storlek. Också välja layoutalternativ som önskas, inklusive horisontell och vertikal justering (dvs anteckning läge) och vinkeln (dvs rotation). Välj ok.

Att visa tidsstämplarna för en tillhörande komponent eller anslutning

1. Se till att du har en befintlig schema öppen .

2. Högerklickpå en tillhörande form eller kontakt i Ingående delar eller Anslutningarfliken schablonen fönster eller en associerad form eller kontakt på duken.

3. Välj Anteckningar.

Notera

För en enskild associerad form eller kontakten på arbetsytan måste du välja Åsido Stencil Anteckningarcheckbox första gången.

4. Välj Ny anteckning i verktygsfältet och välj Skapad, Skapad av, skapade Marker, Ändrad, Ändrad av eller modifierad Marker.

5. I dialogrutan som visas, om inte en markör väljer du visningsalternativ som önskas, inklusive konsoler och Teckensnitt, stil, teckenfärg och storlek. Om en markör, ange radien av markören i pixlar och färgningsmetoden till antingen Colour By Range eller Colour By egendom och ställa in färgerna uppdrag. Också välja layoutalternativ som önskas, inklusive horisontell och vertikal justering (dvs anteckning läge) och vinkeln (dvs rotation). Välj ok.

Om du vill ändra tecken stil med en fritt formulerad formeller kontakt

1. Se till att du har en ny eller befintlig schema öppen .

2. Högerklickpå freeform form eller kontakt på duken. Obs: Om kontakt textetikett inte visar sedan att visa connecteller textetikett: Högerklickconnectelleroch välj Notering | Visa Notering.

3. Välj Ändra teckensnitt.

4. Välj ett typsnitt, stil och storlek i dialogrutan och välj ok.

Om du vill ändra teckensnitt färg av en fritt formulerad formeller kontakt

1. Se till att du har en ny eller befintlig schema öppen .

2. Högerklickpå freeform form eller kontakt på duken. Obs: Om kontakt textetikett inte visar sedan att visa connecteller textetikett: Högerklickconnectelleroch välj Notering | Visa Notering.

3. Välj Ändra Font Färg.

4. Välj ett typsnittFärg (och formar Link färg) genom att klicka på knappen "..." och välja en färg i dialogrutan och välj ok.

5. Välj Insyn i textetiketten genom att justera reglaget där 0 är helt transparent och 255 är helt ogenomskinlig.

Om du vill rotera textetiketten av en fritt formulerad formeller kontakt

1. Se till att du har en ny eller befintlig schema öppen .

2. Högerklickpå freeform form eller kontakt på duken. Obs: Om kontakt textetikett inte visar sedan att visa connecteller textetikett: Högerklickconnectelleroch välj Notering | Visa Notering.

3. Välj Roteraoch välj sedan relevant vinkel du vill rotera textetikett av.

Se också

Ritverktyget | Fylla din arkitektur | Analysera din arkitektur


Använda länkar i diagram

Navigering: Fylla din arkitektur> Använda Drawings>

Använda länkar i diagram

Skicka kommentarer om detta ämne.

Former (fri form och komponenter) och kontakter (fri form eller anslutningar) inom diagram kan kopplas till din befintliga arkitektoniska representationer i ABACUS, samt externa filer / mappar och webbadresser. Dessa länkar kan sedan styras (skapas, ändras och raderas) via ABACUS verktygen. Denna funktion kan användas för att förbättra navigering och övergripande förståelse för din arkitektur schematiskt.

För att lägga till länkar till ditt diagram

1. Se till att du har en befintlig schema öppen .

2. Välj relevant form eller kontakt från diagrammet.

3. Högerklickpå formeneller kontakt.

4. Välj Öppna Länkaroch en Länkarfönstret visas.

5. Klicka på Lägg tillikon och en Ny länkfönstret visas.

6. Välj aktuell Katalog | Matrix | Diagram| 3D-vy| Diagramradioknappar, välj sedan relevant katalog, matris, diagram, 3Deller diagram utsikt i den nuvarande arkitekturen från Anknyta tillrullgardinsmenyn.

- eller -

6. Välj Webbsajtalternativknappen då, anger du relevant URL (t ex http: //www.avolutionprogramvara.com /)i fältet för att länka till en webbsida. Giltiga webbadresser måste börja med en av 5strängar; http: //, https: //, ftp: //, fil: eller \\. Eventuella mellanslag ska anges med ett "% 20".

- eller -

6. Välj Absolut Arkiv | Relativ fil radioknapps,klicka sedan på "..."-knappen För att leta efter en extern fil att länka till din diagram.

7. Klick okoch den nya länken kommer att visas på länkfönstret. Obs! Länkar fönstret kan ändras för att se det fullständiga namnet om det behövs.

8. Upprepa steg 5-7att skapa fler länkar.

9. För att följa den skapade länken, väljer du relevant länk som visas i Länkarfönstret och klicka Öppen länk.

Notera

När flera kommentarer är visas för en form eller kontaktdon länken visas på första anteckningen i listan över anteckningar i dialogrutan Redigera Anteckningar.

För att följa länkar från diagrammet

1. Se till att du har en befintlig schema öppen .

2. Välj relevant form eller kontakt från diagrammet.

3. Klickpå den relevanta hyperlänken (blå understrukna komponentnamn) på en form eller kontakt i diagrammet för att öppna och visa den första länken från formeneller kontakt.Obs: Markören bör ändras till en "hand" när länken är klar att klickas.

- eller -

3. Välj relevant form eller kontakt från diagrammet.

4. Högerklickpå formeneller kontakt.

5. Välj Öppna Länkar och den Länkarfönstret visas.

6. Välj relevant länk som du vill titta på.

7. Klicka på Öppen länkknappen för att öppna och visa den aktuella länken.

För att ta bort länkar i diagrammet

1. Se till att du har en befintlig schema öppen .

2. Välj relevant formeller kontaktfrån diagrammet.

3. Högerklickpå formeneller kontakt.

4. Välj Öppna Länkar och den Länkarfönstret visas.

5. Välj relevant länk som behöver tas bort.

6. Klicka på Radera knapp. och länken tas bort från Länkar fönster.

Organisera länkar i diagrammet

Du kan välja vilka länkade diagram, extern fil eller webbadress visas när en form etikett är Ctrl + klickade i diagrammet.

1. Se till att du har en befintlig schema öppen .

2. Välj relevant form eller kontakt från diagrammet.

3. Högerklickpå formeneller kontakt.

4. Välj Öppna Länkar och den Länkarfönstret visas.

5. För att ändra ordningen av länkarna klicka på Flytta upp | Flytta nerknapparna på den högra sidan av Länkar fönster.

6. Den första länken som visas på vänster sida av Länkarfönstret är länken som visas när du Ctrl + Klickaen hyperlänkad form eller kontakt namn.

Se också

Fylla din arkitektur | Fylla din arkitektur manuellt | Analysera din arkitektur


Diagram Synpunkter

Navigering: Fylla din arkitektur> Använda Drawings>

Diagram Synpunkter

Skicka kommentarer om detta ämne.

The synpunkterfunktionen ser till att komponenter och anslutningar som tillsätts ett diagram måste ha en typ förening tidigare definierats innan de kan läggas till ett diagram. Denna funktion gör det möjligt att begränsa de typer av diagram som kan dras genom att begränsa former och kontakter som är förknippade med komponenter och Anslutningarexisterande i din arkitektur.

Aktivera eller inaktivera Att hävda diagram synpunkter

Förmågan att genomdriva diagram synpunkter aktiveras automatiskt som standard. För att aktivera / inaktivera den här funktionen klickar du på Verktyg | Alternativ ...| de Diagramfliken och avmarkera / markera Enforce Diagram Synpunkterkryssrutan därefter.

Notera

Om du inte ser "Enforce Diagram Synpunkter"På fliken Diagram då du inte har Designer add-on och alternativet är aktiverat som standard.

Skapa ett verkställbart diagram synpunkt

1. Se till att du har en ABACUS fil öppna med explorerview visas.

2. I explorer vyn högerklickar du på Sepunktsoch klicka på Skapa Diagram Viewpoint

3. De Diagram Viewpointfönstret visas.

4. Tilldela ett relevant namn till schema synpunktoch noterar att synpunkt sparas under Synpunkterdelen av Explorer.

5. De Diagram Viewpointfönstret visas.

6. Nu klicka och dra relevanta komponenttyper och anslutningstyper i din arkitektur på synvinkel former du vill. Komponenttypermåste dras på ett formi formerfliken, medan anslutningstypermåste dras på en av de fem linje stil formeri kontakter flik.

7. Om du vill spara schema synpunktdu har skapat klickar du på [image] på det övre högra hörnet av Diagram Viewpoint fönster.

Notera

De schema synpunktkan redigeras genom att högerklicka på synpunkt och välja Öppna eller dubbelklicka de synpunkt.

Synchonising en uppdaterad synvinkel med diagram

1. Se till att du har en ABACUS fil öppna.

2. Antingen högerklicka på synpunkt i den Explorer fönstret under Meta-model | Synpunkteroch välj Sync Diagram Mapp ...

- eller -

3. På nära håll den öppna och uppdaterade synvinkel fönstret och välj Jai Synkronisera till Viewpointdialogrutan som visas.

4. De Viewpoint Synkroniseringdialogruta visas enligt nedan.

Kryssrutor

· Lägg saknas avbildningar- Varje ny form (till komponent typ) eller kontakt (till anslutningstyp) föreningar som har lagts till synvinkelkommer att läggas till den motsvarande diagramar (dvs deras stencils) att är kopplade till synvinkel.

· Uppdatera befintligaAvbildningar- Eventuella uppdaterade aspekter av den befintliga form (till komponenttyp) eller kontakt (till anslutningstyp) föreningar för synpunkten(t.ex. färg, typsnitt) kommer att uppdateras i motsvarande diagramar (dvs deras stencils) att är kopplade till synvinkel.

· Ta bort ExtraAvbildningar- Eventuella ytterligare form (till komponent typ) eller kontakt (till anslutningstyp) föreningar som har lagts till diagram (dvs deras schabloner) men inte i synpunktkommer att tas bort från motsvarande diagramar (dvs deras stencils) att är kopplade till synvinkel.

· Skriv över Lokala inställningar för extra eller Uppdaterad Mapp (skillnader endast)- Eventuella uppdaterade aspekter av den befintliga form (till komponenttyp) eller kontakt (till anslutningstyp) föreningar för synpunkten(t.ex. färg, typsnitt) kommer att tillämpas på motsvarande element på diagrammen som är kopplade till utsiktsplatsen.Endast uppdaterade olikheter "som gjorts till utsiktsplatsen tillämpas så befintliga lokala inställningar i diagrammet som inte uppdaterats i perspektiv förblir oförändrade.

· [image] Anteckningar – Som ovan men speciellt för kommentarer.

Se också

Ritverktyget | Fylla din arkitektur | Analysera din arkitektur


Fylla använder Kataloger

Navigering: Fylla din arkitektur>

Fylla använder Kataloger

Skicka kommentarer om detta ämne.

A katalog kan du visa och redigera komponenter eller anslutningar och deras egenskaper på ett enkelt tabell sätt.

Till skapa en ny katalog visa i KULRAM

Notera

Medan alla Arkitekt användare kan skapa nya Kataloger, för att spara ändringar i ett befintligt Katalog inställningar i användarlicens behöver Designer add-on kapacitet. Detta för att "skydda" konfigurationen av befintliga Kataloger som kan delas av många användare. Men använder Arkitekt utan Designer add-on kan fortfarande välja att "Spara som" nya inställningar till en ny katalog. Och naturligtvis alla användarlicenser kan välja att göra sig av med alla ändringar av en befintlig katalog. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver Designer add-on förmåga. Och kom ihåg, detta är bara inställningarna för katalogen, alla ändringar som gjorts i uppgifterna i förteckningen omedelbart appliceras på förvaret, oavsett.

1. Välj Infoga | Katalog.

2. I pull-down väljer Arkitektur som innehåller de komponenter elleranslutningar du vill visa.

3. I pull-down välja den komponent eller anslutningstyp som du vill ha de fall anges som "rader' i katalogen.

4. De katalog kommer att befolkas med enro för varje instans av den valda komponenten eller anslutningstyp.

Notera

Som standard längst till vänster Hierarki Pathkolumn (dvs. hierarkin moder komponenter eller anslutningar över de utvalda instanser) och 2: a Namn kolumn (dvs. listan över de valda komponent eller anslutnings instanser) fryses till vänster katalogen. Om du vill ändra kolumn frysning dra kolumn separatorn till höger om namnkolumnen. Du kan re-orderkolumner helt enkelt genom att dra och släppa sina kolumnrubrikerna. Celler från kolonner med en blå understrykning är hyperlänkar till andra delar i projektet och hyperlänkar kan följas genom att hålla nere Ctrl och klicka på länkarna. Kolumner kan vara dold genom att högerklicka på kolumnrubriken och välja Kolumn | Göm kolumn. Dolda kolumner kan göras synliga igen genom att klicka på Konfigurera Kolumner knapp i verktygsfältet och använda Konfigurera kolumner dialogrutan som visas nedan, eller genom att välja nedåtpilen delen av Konfigurera Kolumner knapp i verktygsfältet och individuellt val av dold kolumn (er) från antingen general Egenskaper eller tillbehör samlingar. Rader kan vara grupperade av deras kolumnvärden genom att dra kolumnrubriken i det blå gruppering fältet längst upp i katalogen. När som helst kan du dubbelklicka på katalog rad väljare och hoppa tillden motsvarande komponenteneller anslutningi Utforskaren.Egenskap cellvärden är fetstil där de är olika till standard, och kursiverad skriv-där de. Tidsstämpel, Fastigheter och Attached Komponent kolumner kan vara färgad enligt cellvärden eller en ansluten komponent fastighetsvärde genom att högerklicka på kolumnrubriken och välja Kolumn | Byt färg ... och sedan Colour by Tidsstämpel eller alternativet Colour By Property, dock endast Lista, Integer, Decimal, Boolean eller datum / tid datatyp egenskaper färg. Fastighetsvärden för Bifogade kolumner Komponent kan vara visas genom att högerklicka på kolumnrubriken och välja Kolumn | Visa Property ... och sedan alternativet Visa Property. Och slutligen, där det finns Nödvändiga begränsningar fastställts för en fastighet kolonn dessa kan visas med en string (tillsammans med färgning enligt deras tillsynsnivåer) genom att högerklicka på kolumnrubriken och välja Kolumn | Visa .

Katalog

Till lägg till / visa kolumner till a Katalog view i ABACUS

1. Se till att du har en Katalog vy öppna.

2. Dolda kolumner kan individuellt synliga igen genom att klicka på pil till höger om Konfigurera Kolumner knapp i verktygsfältetoch välja dolda kolumn från antingen Allmän, Egenskaper eller Bilagor samlingar.

Notera

En bock visas bredvid kolumnerna för närvarande visas för katalogen.Dessutom kommer endast vissa bilagor finnas tillgängliga under Bilagor-sektionen enligt begränsningar som definieras i ditt projekt. I synnerhet för en anslutning till finnas tillgängliga för att visas i en komponent katalog komponenttypen för katalogen ska anges antingen som källa eller sjunka (INTE "Alla") av en "anslutning måste bifogas" hinder för en anslutning typ, och det måste också finnas minst en komponent typ anges som antingen källa eller sjunka (INTE "Alla") i den andra änden "av samma typ av anslutning.

- ELLER -

2. Flera kolumner kan göras synliga igen (eller beställas eller fast) genom att klicka på Konfigurera kolumner knapp i verktygsfältetoch med användning av de Konfigurera Kolumner dialog visas nedan.

Notera

De som för närvarande visas kolumner visas i panelen till höger med tillgängliga kolumner som visas i panelen till vänster. De tillgängliga kolumner kan filtreras enligt Välj Tillgängliga kolumner frånpull-down och de kan tillsättas genom att välja dem i panelen till vänster och klicka på Lägg till knapp emellan de två panelerna.

Konfigurera dialogrutan Kolumner

Till ta bort / dölja kolumner från en Katalog view i ABACUS

1. Se till att du har en Katalog vy öppna.

2. Högerklicka på kolumnrubriken för den kolumn du vill ta bort / dölja och välj Kolumn | Göm Kolonn.

- ELLER -

2. Flera kolumner kan döljas (eller beställas eller fast) genom att klicka på Konfigurera kolumner knapp i verktygsfältetoch använda Konfigurera kolumner dialog visas ovan.

Notera

De som för närvarande visas kolumner visas i panelen till höger med tillgängliga kolumner som visas i panelen till vänster. De som för närvarande visas kolumner kan döljas genom att välja kolumn i panelen till höger och klicka på Avlägsna knapp emellan de två panelerna.

För att fylla med hjälp av en Katalog view i ABACUS

1. Till Lägg till en komponent eller förbindelseav den valda typen till de katalog (och projekt) klicka på Lägg till ny komponent / Lägg till ny knapp anslutning verktygsfältet. Raden ska visas och en komponent eller anslutning kommer att skapas på den översta nivån i Komponenter eller Anslutningar kollektion för den valda Architecture.

Notera

Nya komponenter och anslutningar läggs som standard på den översta nivån av komponenter eller anslutningar samling av den valda arkitekturen. Om du vill ändra förälder till de nya komponenter eller anslutningar högerklicka Hierarkin Path cell för den nya komponenten eller anslutningar rad och välj Ändra Förälder ...och välj önskad föräldern (tagit del av begränsning markering ).

Notera

Nya rader / element tillsättas direkt till en katalog via "Lägg till ny" -knappen, klistras in i katalogen, eller skapas via import till katalogen från MS Excel är undantagna från filtrering tills katalogen är stängd. Detta är att möjliggöra att alla nödvändiga redigering av kolumnvärden som inte kan uppfylla de nuvarande filterkriterier i katalogen. Dessa nya elementrader markeras med ett "+" symbol i cellen raden väljaren i början av raden, som är färgad grön Om element som för närvarande uppfyller de sparade filterkriterier katalogen (dvs. kommer att finnas kvar på katalog om åter öppnas), och röd om den inte gör.

2. Till ta bort en komponent eller förbindelseav den valda typen från de katalog (och projekt) markera raden och tryck antingen på Delete-tangenten eller högerklicka på raden väljaren och välj Ta bort från arkitektur. De rad bör försvinna från katalogen och det kommer att tas bort från projektet.

Till filtrera med användning av en Katalog view i ABACUS

1. Se till att du har en Katalog vy öppna.

2. Om filterraden inte visas högst upp i katalogen och klicka sedan på Visa Filter rubrikradknapp i verktygsfältet.

3. I kolumnen som du vill lägga till ett filter, dubbelklicka på filterraden cell där det visar "(Alla).

4. För Tidsstämpel, Hierarki Path, Namn eller Beskrivningallmänna kolonner eller Text, Integer, Decimal, Boolean eller Datum Tidfastighets kolumner klicka på knappen ... som visas till höger i raden cellfiltret och ange cellvärden som ska ingå i katalogen.

Notera

Matchningen utförs som om "*" jokertecken automatiskt tillämpas före och efter varje strängvärden så att markeras med ett "cat" (utan citattecken) skulle omfatta rader med "bobkatt','kattkvinna "eller" tillämpkattion 'etc. Flera /' eller 'värden kan matas in på nya linjer med Ctrl + Enter. För Integer och Decimal fastighets kolumner "och" logik kan ingå med hjälp av "&"(Utan citattecken) och större än / mindre än etc logik kan ingå med hjälp av"> =','>','<' och '<="(Utan citattecken), t.ex. '> = 50 tusen & <90 tusen'. Icke-blank värderade rader kan inkluderas genom att skriva in "(Icke-Blanks)"(Utan citattecken) och Tomma värderade rader kan inkluderas genom att skriva in"(Tomma)"(Utan citattecken).Och slutligen, alla filter är som standard små bokstäver så "katt" (utan citattecken) skulle omfatta rader med "katt", "Katt" eller "CAT" etc. För stora och små bokstäver matchning, ange "(Fall)"(Utan citattecken) före strängen t.ex. "(Mål) Cat" (utan citattecken) skulle endast innehålla rader med "katt" i dem.

5. För Bilagorkolonner, Standarder kolumner eller Lista fastighets kolumner klickar du på nedåtpilen som visas till höger i raden cellfiltret och välj cellvärden från kryssrutorna som bör ingå i katalogen.

Notera

Den "(Markera alla) kryssrutan gör det möjligt för alla andra kryssrutor, i effekt inklusive alla tillgängliga rader. Den "(Non-Tomma) kryss kommer att omfatta alla icke-tomt värderade rader. Den "(Tomma) kryssrutan kommer att innehålla några tomma värderas rader. Och slutligen, avmarkera eventuella särskilda värderas kryssrutor automatiskt avmarkera "(Markera alla)" och "(Non-Tomma) kryssrutorna för konsekvens.

6. Klick ok att applicera filtret.

Till inaktivera / aktivera filtrering på a Katalog view i ABACUS

1. Se till att du har en Katalog vy öppna med en filtrera applicerad.

2. Klicka på kryssrutan till vänster om filterraden.

Till ta bort ett filter från a Katalog view i ABACUS

1. Se till att du har en Katalog vy öppna med en filtrera applicerad.

2. För att ta bort en enskild kolumn filter högerklicka på kolumnrubriken och välj Kolumn | Rensa Filtrering.

3. För att ta bort alla filter klickar du på Val knapp i verktygsfältet och välj Rensa Filterinställningar.

Att spara / spara som aKatalog vy

Notera

Medan alla Arkitekt användare kan skapa nya Kataloger, för att spara ändringar i ett befintligt Katalog inställningar i användarlicens behöver Designer add-on kapacitet. Detta för att "skydda" konfigurationen av befintliga Kataloger som kan delas av många användare. Men använder Arkitekt utan Designer add-on kan fortfarande välja att "Spara som" nya inställningar till en ny katalog. Och naturligtvis alla användarlicenser kan välja att göra sig av med alla ändringar av en befintlig katalog. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver Designer add-on förmåga.Och kom ihåg, detta är bara inställningarna för katalogen, alla ändringar som gjorts i uppgifterna i förteckningen omedelbart appliceras på förvaret, oavsett.

1. Se till att du har en ny eller existerande katalog view öppnaoch du har gjort de nödvändiga ändringarna.

2. I Katalog vyverktygsfältet klicka på Sparaknappen för att spara Katalog vy och eventuella ändringar formaterings.

Notera

Om du inte har en Spara i katalogen visa verktygsfältet då du inte har Designer add-on och du kan bara Spara somnågra inställningar ändras till en ny katalog när du går att stänga den befintliga katalogen.

3. Om de Katalog Namndialogruta (på grund av att en ny katalog) ange ett namn för katalog och tryck ok.

Till export till MS Excel katalog

1. Se till att du har en Katalog vy öppna.

2. Klicka på Exportera till Excel Catalogue kalkylbladknapp i verktygsfältet.

3. Välj ett filnamn att spara MS Excel katalogen som. Klick Spara.

Notera

Som standard den exporterade MS Excel katalog filnamn blir katalogen namn suffix av arkitekturen namnet inom parentes, t.ex. "Projekt (2014 Faktisk) .xlsx". Du kan ändra något av detta, bland annat om filformatet är att vara XLSX eller .xls. Arkitektur namn ingår att påminna användaren att varje katalog har specifikt innehåll (dvs. ID i kolumn A och rad 1) att låta det vara rund trippade tillbaka i att använda Importera från MS Excel katalog enligt nedan.

Notera

Som standard den dolda kolumn A i den exporterade MS Excel katalog innehåller ett unikt ID för varje element i ABACUS förvaret. Detta gör att alla ändringar som görs i MS Excel att "matchas upp" till de befintliga element i ABACUS vid import (se nedan). Emellertid kan användningen av denna unika ID för att "matcha upp" rader åsidosättas med en Extern | IDfastighet på elementet. Det vill säga, om elementet har en extern | ID egendom och det ingår i katalogen på export sedan värdena för yttre | ID kolumnen kommer att användas för att matcha upp raderna vid import (se nedan) och de unika ID-värden i den dolda kolumn A kommer att ignoreras (och kan även vara tomt). Den dolda Kolumn A själv måste kvarstår dock, särskilt värdet i cell A1. Dessutom, när du lägger till externa-ID till en befintlig ABACUS inslag samling vi rekommenderar att du lägger dem som en annan egenskap först, t.ex. Extern | Temp och sedan döpa om fastigheten till yttre | ID. Annars dubbla element kommer att läggas.

Katalog formateringexporteras som standard, men för stora kataloger detta kan resultera i export är ganska långsamt. Följaktligen, Verktyg | Alternativ ...sedan de Katalog flik,du har möjlighet att minska mängden formatering som exporteras som visas på fliken Katalog nedan därigenom påskynda export.

Katalogexport alternativ

4. En Export Avslutade dialogrutan visas. Klick ok.

Exporteras till MS Excel katalog

Till import från MS Excel katalog

Notera

Som standard den dolda kolumn A i den exporterade MS Excel katalog (se ovan) innehåller ett unikt ID för varje element i ABACUS förvaret. Detta gör att alla ändringar som görs i MS Excel att "matchas upp" till de befintliga element i ABACUS vid import. Emellertid kan användningen av denna unika ID för att "matcha upp" rader åsidosättas med en Extern | IDfastighet på elementet. Det vill säga, om elementet har en extern | ID egendom och det ingår i katalogen på export (se ovan) så är värdena för yttre | ID kolumnen kommer att användas för att matcha upp raderna på import och de unika ID-värden i den dolda kolumn A kommer att ignoreras (och kan även vara tomt). Den dolda Kolumn A själv måste kvarstår dock, särskilt värdet i cell A1. Dessutom, när du lägger till externa-ID till en befintlig ABACUS inslag samling vi rekommenderar att du lägger dem som en annan egenskap först, t.ex. Extern | Temp och sedan döpa om fastigheten till yttre | ID. Annars dubbla element kommer att läggas.

1. Se till att du har en Katalog vy öppna.

2. Klicka på Importera från Excel Catalogue kalkylbladknapp i verktygsfältet.

3. Välj ett filnamn att importera MS Excel katalog från. Klick Öppna.

4. Nya fel som upptäckts och / eller nya fel / varningar Upptäckta dialogrutor kan visas för varje nytt innehåll (dvs. rader i MS Excel) som tillsattes. Ta del av de fel / varningar och klicka ok.

5. En Import Avslutade dialogrutan visas och det kan visa varningar på grund av import (se anmärkningar nedan). Klick ok.

Notera

För de tilldelade standarder eller bifogade kolumner Komponent måste nya poster via MS Excel katalogen stämmer exakt namn av en befintlig standard eller komponent av rätt typ för uppdraget eller anslutning som skall tillsättas. Den förstnämnda matchen kommer att användas och eventuella oöverträffade poster kommer att generera en varning enligt nedan. Dessutom medan varningar ges på återimport, elementen raderas intefrån ABACUS om de inte förekommer i MS Excel katalogen. Detta beror på att det inte finns något sätt att ABACUS kan veta om den tilldelade Standard eller fästas Komponent finns i ABACUS projektet, men inte finns i MS Excel katalogen eftersom det har tagits bort från MS Excel katalogen eller har lagts till i ABACUS projektet sedan katalogen exporterades. Följaktligen om användarna vill lätt "upptäcka" vilka anslutningar har tillkommit under importen kan de helt enkelt skapa en önskad fastighet på anslutningstypen och ange att det är standard för tom, så att de varnas för eventuella nya anslutningar varje gång import är avslutad.

Notera

När du importerar en MS Excel katalog olika varningar kan visas. För det första, om en ny kolumn lades till Excel som inte stämmer överens med "syntax" för en fastighet eller fäst komponent kolumnen kommer att ignoreras. Härnäst kommer line-by-line varningar visas för några problem med data på varje rad i Excel katalogen. Dessa varningar börjar med radnumret hakparentes och i förekommande fall kolumnen etiketten (dvs. "[23 J] ..." för rad 23, kolumn J) och kan hänvisa till borttagna objekt, oöverträffade standarder eller namn fästa Komponent (som ignoreras enligt anmärkning ovan) eller en ogiltig eller tom ID gällande en ny rad / element (som kommer att läggas). För en detaljerad artikel om att fylla ABACUS använder Excel kataloger hänvisas till Avolution gemenskapen eller portföljförvaltare utbildningen.

Notera

Nya komponenter och anslutningar läggs som standard på den översta nivån av komponenter eller anslutningar samling av den valda arkitekturen. Om du vill ändra förälder till de nya komponenter eller anslutningar högerklicka Hierarkin Path cell för den nya komponenten eller anslutningar rad och välj Ändra Förälder ...och välj önskad föräldern (tagit del av begränsning markering ).

Notera

Element tillsättas direkt till en katalog via "Lägg till ny" -knappen, klistras in i katalogen, eller skapas via import till katalogen från MS Excel är undantagna från filtrering tills katalogen är stängd. Detta är att möjliggöra att alla nödvändiga redigering av kolumnvärden som inte kan uppfylla de nuvarande filterkriterier i katalogen. Dessa nya elementrader markeras med ett "+" symbol i cellen raden väljaren i början av raden, som är färgad grön Om element som för närvarande uppfyller de sparade filterkriterier katalogen (dvs. kommer att finnas kvar på katalog om åter öppnas), och röd om den inte gör.

Till jämföra innehållet i en katalog med en annan arkitektur

1. Se till ämnet här .

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Fylla din arkitektur från Visio | Fylla din arkitektur från Excel


Fylla med matriser

Navigering: Fylla din arkitektur>

Fylla med matriser

Skicka kommentarer om detta ämne.

En matris kan du visa och redigera 'direkt' anslutningar mellan komponenterna på ett enkelt tabell sättoch även se den "indirekt väg" mellan komponenter enligt mellanliggande komponenter (och anslutningar).

Till skapa en Matrix vy i ABACUS

Notera

Medan alla Arkitekt användare kan skapa matriser för att rädda dem och / eller deras inställningar användarlicens behöver Designer add-on kapacitet. Detta för att "skydda" konfigurationen av befintliga Matriser som kan delas av många användare. Men använder Arkitekt utan Designer add-on kan fortfarande välja att "Spara som" nya inställningar till en ny matris. Och naturligtvis alla användarlicenser kan välja att göra sig av med alla ändringar av en befintlig Matrix. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

1. Välj Infoga | Matris.

2. I rchitecture>pull-down väljer Arkitektur som innehåller komponenter och anslutningar som du vill titta på.

3. I <KällaSkriv>pull-down välja vilken typ komponent som du vill ha de fall som anges som "rader' ner till vänsterav matrisen.

4. I <SjunkaSkriv>pull-down välja vilken typ komponent som du vill ha de fall som anges som "kolonner' överstav matrisen.

5. I dra ner Det finns i huvudsak två "lägen" av matris du kan definiera ...

"Direkt" anslutningar matriser

6. Bara svälja en (1) eller mer förbindelse typer på höger sida av menyn som visas om du vill se i "celler" i matrisen omn uttryckligAnslutningen från Vertikal/ 'rad"Komponent av matrisen till den Horisontell/ 'kolumn"Komponent av matrisen.

Notera

Endast förbindelser med källan ände fäst vid Vertikal/ 'rad"Komponent och handfat ände fäst vid Horisontell/ 'kolumn"Komponent kommer att visas. Växla Källa och Sjunkakomponent typ val att visa anslutningarna i motsatt riktning.

7. Matrisen kommer att befolkas med ett "X" i cellerna (eller ett fastighetsvärde - se nedan) om det finns en förbindelse från Vertikal/ 'rad'komponent i matrisen till Horisontell/ 'kolumn"Komponent av matrisen.

Notera

För stora matriser bara högst 100 rader eller kolumner (inklusive kollapsade rader / kolumner) kommer att visas vid en tidpunkt som framgår av "R" och "C" indikatorer i det övre vänstra rubrikcell respektive. Om du vill visa ytterligare rader använder rullningslisterna. När som helst kan du dubbelklicka på Vertikal/ 'rad' eller Horizontfl / 'kolumn' komponent rubriker och hoppa tillmotsvarande komponenter i fönstret Utforskaren.Föräldrarna till den vertikala/ 'rad' och Horisontell/ 'kolumn' komponents är också valfritt visas som rubrik rader / kolumner med en grå rubrik titel. När kollapsade (genom en enda klick rubriken cell) om barnbilagor fanns då ett "X" kommer eventuellt visas om alla barn fästes eller en "O" kommer eventuellt visas om endast en del av barnen bifogas. Cellerna kan vara färgad enligt ett fastighetsvärde om anslutningarna genom att klicka på Alternativ "kugghjulet" längst upp till höger i matrisen verktygsfältet och välja färginställningar ... och sedan på knappen Redigera och välja Colour by Tidsstämpel eller Colour By Property alternativ och välja fastighet, Min och Max värde räckvidd och välja färger, dock endast Lista, Integer, Decimal, Boolean eller datum / tid datatyp egenskaper färg. Om kollapsade cellen kommer att färgas beroende på den genomsnittliga fastighetsvärde om anslutningarna. I stället för ett "X", kan fastighetsvärdena för cellerna vara visas genom att klicka på Alternativ "kugghjulet" längst upp till höger i matrisen verktygsfältet och välja Visa Value Inställningar ... och sedan på knappen Redigera och välja alternativet Visa egendom och välja en fastighet.

Direkta förbindelser matris visar servrar där Ansökningarna värd med färg och en egendom som visas istället för generiska "X"

- ELLER -

"Indirekt" anslutningar matriser

6. Sväljaen sekvens av förbindelse typer och komponenttyperpå höger och vänster sida av menyn som visas om du vill se i "celler" i matrisen omn indirekt väg anslutna komponenterexisterar från Vertikal/ 'rad"Komponent av matrisen till den Horisontell/ 'kolumn"Komponent av matrisen.

Notera

Alla giltig sökväg som innehåller de element som valts i vägen menyn wsjuk visasoberoende av riktningen för de underliggande anslutningar emellertid när man väljer den väg som först och sista element väljs måste vara anslutningstyper. Vidare beställa av de faktorer som har valts visas med en numerisk prefixi kvadrat ("[]") fästen och kan en viss typ ingå mutliple gångeri vägen (såsom anges av den numeriska prefix). Löpande urval av komponenttyper eller anslutningstyper tolkas som en 'ELLER'bana och rangordning av bifogade komponenter kan eventuellt ingå genom att markera "Sök även Attachment föräldrar / barn"Kryssrutan. Växla Källa och Sjunkakomponent typ val att visa banor i den motsatta riktningen.

7. Matrisen kommer att befolkas med ensökväg / samling komponenteri cellerna om det finns en väg från Vertikal/ 'rad'komponent i matrisen till Horisontell/ 'kolumn"Komponent av matrisen.

Notera

För stora matriser bara högst 100 rader eller kolumner (inklusive kollapsade rader / kolumner) kommer att visas vid en tidpunkt som framgår av "R" och "C" indikatorer i det övre vänstra rubrikcell respektive. Om du vill visa ytterligare rader använder rullningslisterna. När som helst kan du dubbelklicka på Vertikal/ 'rad' eller Horizontfl / 'kolumn' komponent rubriker och hoppa tillmotsvarande komponenter i fönstret Utforskaren.Föräldrarna till den vertikala/ 'rad' och Horisontell/ 'kolumn' komponents är också valfritt visas som rubrik rader / kolumner med en grå rubrik titel. När kollapsade (genom en enda klick rubriken cell) om några barn vägar fanns då ett "X" kommer eventuellt visas om alla barn fästes eller en "O" kommer eventuellt visas om endast en del av barnen hade banor. De indirekta bankomponenter kan vara färgad enligt ett fastighetsvärde av komponenterna genom att klicka på Alternativ "kugghjulet" längst upp till höger i matrisen verktygsfältet och välja färginställningar ... och sedan på knappen Redigera och välja Colour by Tidsstämpel eller Colour By Property alternativ och välja fastighet, Min och Max värde räckvidd och välja färger, dock endast Lista, Integer, Decimal, Boolean eller datum / tid datatyp egenskaper färg. Egenskapsvärden för de indirekta bankomponenter kan vara visas genom att klicka på Alternativ "kugghjulet" längst upp till höger i matrisen verktygsfältet och välja Visa Value Inställningar ... och sedan på knappen Redigera och välja alternativet Visa egendom och välja en fastighet.

Indirekt anslutningar matris visar Program som implementerar en viss tjänst av Institutionen

Till filtreraen Matrix vy i ABACUS

1. Se till att du har en ny Matrisvyn öppna.

2. Klicka på Filter Axlar "tratt" längst upp till höger i matrisen verktygsfältet.

3. På källan och / eller Sink flikarna lägga Namn, Fastighetsförmedling, beskrivning, Hierarki eller standardfilter genom att klicka på knappen Lägg till, välja en fastighet om det behövs och klicka ok. Välj relevanta alternativ i Nyckelord / artiklar panel med hjälp av logik / syntax som beskrivs i not nedan. Förhandsgranskningspanelen uppdateras automatiskt för att visa resultaten av aktuella uppsättningen av filter.

Notera

För Tidsstämpel, Hierarki Path, Namn eller Beskrivningfilter eller Text, Integer, Decimal, Boolean eller Datum Tidfastighets filter matchning utförs som om "*" jokertecken automatiskt tillämpas före och efter varje strängvärden så att markeras med ett "cat" (utan citattecken) skulle omfatta rader med "bobkatt','kattkvinna "eller" tillämpkattion 'etc. Flera /' eller 'värden kan matas in på nya linjer med Ctrl + Enter. För Heltal och Decimal fastighets filter "och" logik kan ingå med hjälp av "&"(Utan citattecken) och större än / mindre än etc logik kan ingå med hjälp av"> =','>','<' och '<="(Utan citattecken), t.ex. '> = 50 tusen & <90 tusen'. Icke-blank värderade rader kan inkluderas genom att skriva in "(Icke-Blanks)"(Utan citattecken) och Tomma värderade rader kan inkluderas genom att skriva in"(Tomma)"(Utan citattecken). För Standarder eller Lista egendom Filter "(Markera alla) kryssrutan gör det möjligt för alla andra kryssrutor, i effekt inklusive alla tillgängliga element. Den "(Non-Tomma) kryssrutan kommer att omfatta alla icke-tomt egendom värderas element. Den "(Tomma) kryss kommer att innehålla en tom fastighet värderas element. Och avmarkera några särskilda värderas kryssrutor automatiskt avmarkera "(Markera alla)" och "(icke-Blanks) kryssrutorna för konsekvens. Och slutligen, alla filter är som standard små bokstäver så "katt" (utan citattecken) skulle omfatta element med "katt", "Katt" eller "CAT" etc. För stora och små bokstäver matchning, ange "(Fall)"(Utan citattecken) före strängen t.ex. "(Mål) Cat" (utan citattecken) skulle endast innehålla element med "katt" i dem.

För att fylla med hjälp av en matris vy i ABACUS

Notera

Du kan bara lägga till / ta bort anslutningar där en enda anslutning typ har använts för Väg som beskrivs ovan.

1. Till lägga till en anslutningav den valda typen mellan en Vertikal/ 'rad"Komponent och en Horisontell/ 'kolumn"Komponent av matrisen, där en" inte redan finns X '(eller ett visas fastighetsvärde - se not ovan), Dubbelklicka på cellen. En "X" ska visas (eller ett fastighetsvärde - se not ovan) och en anslutning skapas på den översta nivån i Anslutningar kollektion för den valda Architecture.

Notera

Anslutnings namn kommer att vara den anslutningstyp namn enligt inställning anslutningstypen av matrisen och om ett fastighetsvärde är visas i stället för ett "X" standardvärdet för fastigheten kommer att visas.

2. Till redigera en visas fastighetsvärdeom sambandet mellan a Vertikal/ 'rad"Komponent och en Horisontell/ 'kolumn"Komponent av matrisen, Dubbelklicka på cellen, eller högerklicka på cellen och välj Redigera värde ... och redigera värdet i förändring Värde dialogrutan.

3. Till ta bort en anslutningav den valda typen mellan en Vertikal/ 'rad"Komponent och en Horisontell/ 'kolumn"Del av matrisen, där en" X "finns redan(eller ett visas fastighetsvärde - se not ovan), höger-Klicka på cellenoch väljer Koppla. X borde försvinna och anslutningen kommer att tas bort från projektet.

Att spara / spara som aMatrisvyn

Notera

Medan alla Arkitekt användare kan skapa matriser för att rädda dem och / eller deras inställningar användarlicens behöver Designer add-on kapacitet. Detta för att "skydda" konfigurationen av befintliga Matriser som kan delas av många användare. Men använder Arkitekt utan Designer add-on kan fortfarande välja att "Spara som" nya inställningar till en ny matris. Och naturligtvis alla användarlicenser kan välja att göra sig av med alla ändringar av en befintlig Matrix. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver Designer add-on förmåga.Och kom ihåg, detta är bara inställningarna för Matrix, alla ändringar som gjorts i data i Matrix är omedelbart appliceras på förvaret, oavsett.

1. Se till att du har en ny Matrisvyn öppnaoch du har gjort de nödvändiga ändringarna.

2. I Matrisvynverktygsfältet klicka på vänstra Spara Matrisknappen för att spara Matrisvyn och eventuella ändringar formaterings.

Notera

Om du inte har en Spara-knappen i Matrix visa verktygsfältet då du inte har Designer add-on och du kan bara Spara somnågra inställningar ändras till en ny matris när du går att stänga den befintliga matrisen.

3. Om de Matris Namndialogrutan som visas (på grund av att en ny matris) ange ett namn för matrisoch tryck ok.

Till export till MS Excel matris

1. Se till att du har en Matrisvyn öppna.

2. Klicka på Exportera till Excelknapp i verktygsfältet.

3. Välj ett filnamn att spara MS Excel matrisen som. Klick Spara.

Notera

Som standard den exporterade MS Excel matris filnamn blir Matrisens namn suffix av arkitekturen namnet inom parentes, t.ex. "Program som erbjuds hos servrar (2014 Faktisk) .xlsx". Du kan ändra något av detta, bland annat om filformatet är att vara XLSX eller .xls.

Matris formateringexporteras som standard, men för stora matriser detta kan resultera i export är ganska långsamt. Följaktligen, Verktyg | Alternativ ...sedan de Matris flik,du har möjlighet att minska mängden formatering som exporteras som visas på fliken Matrix nedan därigenom påskynda export.

Matris exportera alternativ

4. En Export Avslutade dialogrutan visas. Klick ok.

Exporteras till MS Excel matris

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Fylla din arkitektur från Visio | Fylla din arkitektur från Excel


Fylla din arkitektur från Microsoft Access

Navigering: Fylla din arkitektur> Fylla från Microsoft-produkter>

Fylla din arkitektur från Microsoft Access

Skicka kommentarer om detta ämne.

Du kan exportera din arkitektur till Microsoft Access för att utföra kombi beräkningar, manipulationer eller rapporter på din arkitektur. Du kan sedan importera arkitekturen tillbaka till ABACUS.

Notera

Open från Access / Export till Database funktionen kräver att Microsoft Access 2000eller senare är installerat på datorn.

Att exportera din arkitektur till Microsoft Access

1. Se till att du har en ABACUS fil öppna Explorervisas och en arkitektur lade till.

2. Välj Arkiv | Exportera | Till databas.

3. Ta del av dialogen varnings som beskrivits ovan och klicka på Ja för att fortsätta.

4. Välj en plats och filnamn för databasfilen.

För att importera manipulerade arkitektur i ABACUS

1. Se till att du har ABACUS öppen.

2. Välj Arkiv | Nya och välj Från Accessi dialogrutan som visas och klicka på OK.

3. Bläddra fram till databasfilen du vill importera.

ABACUS "MS Access Database Schema

ABACUS har i centrum enn ontologi / meta-meta-modell som består av komponenter, anslutningar och begränsningar. Denna "CCC" tillvägagångssätt härrör från olika standardmetoder som utvecklats från 1960-talet och framåt kulminerar i den internationella standarden IEEE 1471, vilket Avolution grundare har bidragit till. Följande primitiva gäller;

1. KULRAM innehåller Bibliotek av Standarder(eller Standards), Komponent och Anslutningstyper, Begränsningar, Synpunkter, Mallar (eller Mönster) och många Arkitekturer.

2. Standarder, Typer och Synpunkter Majvara logiskt Grupperade för bekvämlighet.

3. Arkitekturer kan innehållamånga ättling Arkitekturer(eller Evolutions).

4. Varje Arkitektur innehåller många Ingående delar och Anslutningarför vissa Typeroch olika Visningar.

5. Ingående delar och Anslutningar kan vara sönderdelas in i Delkomponenter och Underanslutningar.

6. Varje Komponent är fäst tillvalfritt antal Anslutningarmen varje Förbindelsekan endast vara fäst tillhögst två Ingående delar.

7. Ingående delar och Anslutningar Kan ha Standarder med Egenskapersåsom information, prestanda, tillförlitlighet, kostnad etc.

8. Arkitekturer, Ingående delar och Anslutningar Kan ha specifik Egenskapersåsom information, prestanda, tillförlitlighet, kostnad etc.

9. Begränsningar Kan finns mellan Ingående delar eller Anslutningar eller mot Egenskaper.

10. Mallarär standard kompositioner av Komponent och Anslutningstyper.

11. Synpunkterär standard sammanslutningar av Komponent och Anslutningstypertill beteckningarna.

12. Visningarär visuella representationer av Ingående delar och Anslutningar.

Följande MS Access Entity Relationship diagram (ERD) dokumenterar kärnaArkitekturer, Evolutioner, Komponent / Anslutningstyper (och grupper), Komponenter / Anslutningar och under begrepp komponent / Connection.

Core databasschema

Notera

Referens integritet har inte verkställts på relationen mellan komponenter bord och bordet Anslutningar (för "fäste" mellan en viss källa eller Sink Component och en anslutning). Detta beror på att en förbindelse kan existera utan komponent bilagor. Vi kunde ha lagt till ett "fäste" bord men med tanke på enkelhet avvisat det. Naturligtvis innebär detta att varje redigering av komponent Ids eller radering av Komponent rader tillsammans kommer att resultera i felaktiga uppgifter. ABACUS kommer att hantera eventuella felaktig vid import genom att ignorera de felaktiga uppgifterna.

Följande MS Access ERD dokumenterar Egenskaperkoncept för arkitekturer, Component / Anslutningstyper och komponenter / anslutningar.

Egenskaper databasschema

Följande MS Access ERD dokumenterar Standarderkoncept för Architectures, Component / Anslutningstyper och komponenter / anslutningar.Obs: Tabellerna fortfarande använda termen "Genomförande" enligt tidigare versioner av ABACUS.

Standarder databasschema

Följande MS Access ERD dokumenterar Begränsningarkoncept för Komponent / Anslutningstyper.

Begränsningardatabasschema

Följande MS Access ERD dokumenterar Synpunkter koncept för Arkitekturer.Obs: Tabellerna fortfarande använda termen "TwoDTempl" enligt tidigare versioner av ABACUS.

Synpunkterdatabasschema

Följande MS Access ERD dokumenterar Katalogerkoncept för Arkitekturer.

Katalogerdatabasschema

Följande MS Access ERD dokumenterar Matriserkoncept för Arkitekturer.

Matriserdatabasschema

Följande MS Access ERD dokumenterar Diagramkoncept för Arkitekturer.Obs: Tabellerna fortfarande använda termen "TwoD" enligt tidigare versioner av ABACUS.

Notera

Typ Component / Anslutning till Stencil form kartläggning och Freeform form delar av MS Access ERD har utelämnats för tydlighets skull.

Diagramdatabasschema

Följande MS Access ERD dokumenterar 3D-vyerkoncept för Arkitekturer.

3D-vyerdatabasschema

Följande MS Access ERD dokumenterar Diagramkoncept för Arkitekturer.

Diagramdatabasschema

Följande MS Access ERD dokumenterar Instrumentpaneler begrepp.

Instrumentpanelerdatabasschema

ABACUS "MS AccessFrågor

Ingår i MS Access Database finns flera användbara frågor enligt följande;

· Comps från rekvisita- Den här frågan visar alla komponenter i projektet (med arkitektur och typ) och inkluderar alla egenskaper som kolumner. Använd denna fråga med filter / kriterier på komponenttypen och / eller arkitektur för att producera "typiska" tabeller för varje komponenttyp med deras egenskaper.

· Stds från rekvisita- Den här frågan visar alla de normer som är i bruk, antalet förekomster av standard och inkluderar alla egenskaper som kolumner. Använd denna fråga som en standardkatalog.

· Rekvisita från Typer- Den här frågan visar alla komponent egenskaper och deras% färdigt varje komponenttyp som kolumner. Använd denna fråga för att avgöra om specifika egenskaper upprätthålls.

· Typer av Props- Den här frågan visar alla typer komponent och omfattar% färdigt av alla egenskaper som kolumner. Använd denna fråga för att avgöra om specifika egenskaper upprätthålls.

· Typ Antal- Den här frågan visar alla typer komponent och omfattar antalet förekomster av varje typ i fallande ordning. Använd denna fråga att bestämma populariteten för varje typ i projektet.

En anteckning om att arbeta med Memo fält i MS Access

Komponenterna, anslutningar och standarder namn fält i tabellerna definieras som PM-fält för att möjliggöra ett obegränsat antal tecken, enligt ABACUS. För komponenter och anslutningar detta orsakar några problem eftersom de har också ett unikt ID-fält för att referera, men för normerna detta orsakar några problem när de försöker gå tabeller eftersom du inte kan gå med PM-fält i MS Access. Alternativt kan du ställa in en WHERE kriterier för att uppnå samma effekt som visas i Visual Query Builder och motsvarande SQL snuttar under den lista ut alla ärvda Standarder egenskaper för alla komponenter i den exporterade ABACUS projektet.

Memo fält "går" i Visual Query Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

FRÅN Components INNER JOIN ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) och (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), implementeringar INNER JOIN ImplementationProperties PÅ Implementations.Id = ImplementationProperties.Implementation_Id

VAR (((ComponentImplementationLinks.Name) = [implementationer] [namn]).);

Memo fält "går" i SQL

En anteckning automatiskt generera ABACUS ID i MS Access

Olika ABACUS MS Access tabeller kräver unika långa heltal ID så en enkel VB metod tillhandahålls för att hjälpa till vid genereringen av dessa. Två metoder ResetCounter () och GetNextCounter () tillhandahålls inom ABACUS "MS Access DB och deras användning är följande; ResetCounter () kommer att sätta räknaren tillbaka till 0. GetNextCounter () kommer att återvända till nästa räknare i sekvensen.

Metoderna utnyttjar en MS Access "sarkasm" att även om du ringer ResetCounter () metod för varje rad insats (dvs när du också köra GetNextCounter () funktion), eftersom ResetCounter () funktion inte har några parametrar det bara körs den en gång och därför inte nollställa räkneverket för varje rad insats. Och även på grund av samma "sarkasm" du måste passera några gamla kolumn variabel till GetNextCounter () för att lura den till att köra varje gång.

Det finns också ett trick för att kunna köra ResetCounter () funktionen i en insats i SQL-uttryck eftersom du inte bara har det sitter där som en kolumn på egen hand, som om det var en urvalsfråga. Det rekommenderas att göra ResetCounter () call del av en av de andra områden, genom att sammanlänka det till slut, eftersom det alltid returnerar null ändå.

Nedan är en typisk SQL användning av metoder för att lägga till en lista över komponenttyper från en tabell / query kallad Component typlista ".

SÄTT IN IComponentTypes (Id, Namn, Beskrivning)

VÄLJ GetNextCounter ([Component typlista] .name)AS Id [Component typlista] .name AS Namn, [Component typlista] .description & ResetCounter ()AS Beskrivning

FRÅN[Komponent typlista];

ABACUS ID / Counter generation i SQL

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Fylla din arkitektur från Visio | Fylla din arkitektur från Excel


Fylla din arkitektur från Microsoft Visio

Navigering: Fylla din arkitektur> Fylla från Microsoft-produkter>

Fylla din arkitektur från Microsoft Visio

Skicka kommentarer om detta ämne.

Du kan importera din arkitektur från Microsoft Visio. Former i din Visio-ritningen kommer att importeras som komponenter i ABACUS. Anslutningar i din Visio-ritningen importeras som anslutningar och själva teckningen kommer att importeras till ABACUS som ett diagram. Dessutom kommer alla Anpassade egenskaper i din Visio-ritningen importeras som fastigheter med sorterings Key mappas till Fastighets typ, Etikett till fastigheten Namn och värde till fastighetsvärdet.

Notera

Importera från Visio funktionen kräver att Microsoft Visio 2003eller senare är installerat på datorn.

Om du vill importera dina Visio-ritningar i ABACUS

1. Se till att du har ABACUS öppen.

2. Välj Arkiv | Nya och välj Från Visioi dialogrutan som visas och klicka på OK.

Notera

Om du vill importera till en befintlig ABACUS projekt sedan antingen högerklicka på Komponenter nod inom en arkitektur, eller högerklicka på en enskild komponent i en arkitektur och välj sedan Import | Från Visio.

3. Bläddra fram till Visio-filen du vill importera.

Notera

Nedan finns några enkla regler eller rekommenderad praxis när konstruera (eller ändrar) en MS Visio-ritning för import till ABACUS.

1. Linjerna eller anslutningar måste vara faktiska kontakter, INTE former.

· Annars ABACUS kommer bara att importera dem som komponenter och därmed de inte kommer att "knytas" till någonting.

· Om du behöver göra några "smarta" routing (dvs. annat än en rak linje) sedan använda dynamiska kontakten på Basic former schablonen kommer ABACUS importera routing / fästpunkter bra.

· Försök att undvika att använda "Ringnät" och "Ethernet" former från nätverket och kringutrustning stencil som gör massor av komponenter som ska "kopplas" till den. Samtidigt som vi importerar bilagor bra som anslutningar den ursprungliga formen är fortfarande "expanderad" för att återspegla bilagor. Använd separera en separat "hub / buss" form (utan kontakt "ben") och sedan uttryckligen ansluta varje komponent till hubben / buss med separata anslutningar.

· Om en linje eller anslutning beter sig som en form, högerklicka på den och gå till "Format | Beteende ... "och se till att Interaction stil är inställd på linjen (1-dimensionellt).

2. Komponenterna måste vara former INTE kontakter.

· Annars ABACUS kommer bara att importera dem som anslutningar och därmed all form information kommer att gå förlorade.

· Om en komponent beter sig som en kontakt, högerklicka på den och gå till "Format | Beteende ... "och se till att Interaction stil är inställd på Box (2-dimensionell).

3. Connector ändar måste fästas former, inte flyter runt i bakgrunden bakom formen.

· Om du inte ansluter kontakterna till formerna sedan ABACUS har ingen möjlighet att veta att du hade tänkt att fästa den givna kontakten till formen / komponent och följaktligen kommer att lämna den ände av anslutnings un lösa.

4. Etiketter för former bör vara (om möjligt) den inbyggda textetikett för formen, inte en separat textruta på ritningen.

· Separata textrutor kommer att få importeras av ABACUS som komponenter i sin egen rätt och medan du kan sammanfoga komponenten "etikett" med den verkliga komponenten i ABACUS, eller bara omvandla komponenten "etikett" till en freeform form (dvs inte en komponent i sig) är det bäst att undvika dessa steg.

5. Använd samma grundform för varje instans av samma typ, inte vara lat och använda rektangel ibland och box andra från olika form schabloner.

· ABACUS använder basen formen och dess basfärgen att identifiera de komponenttyper och anslutnings på ritningen så en "röd rektangel" och en "röd box" kommer att få importeras som två separata komponenttyper. Dessa komponenttyper kan slås samman i ABACUS men det är bäst att undvika dessa steg.

6. Helt kapsla "barn" former inom sina "föräldrar", INTE lämna dem hängande över kanten.

· ABACUS kommer att upptäcka någon form som helt inkapslad i en annan form som ett barn av den överordnade så se till att hela formen, inklusive etikettdelen, bifogas.

7. Placera inte en form överlappar två andra former.

· Om en form lappar två andra former, oavsett om det är en "gruppering" / bakgrundsrektangel eller på annat sätt, kommer det att importeras av ABACUS som en komponent som är ett barn av varken överlappande former, men så snart du välja den komponent i ABACUS "ritverktyg På grund av det övre vänstra är komponenterna referenspunkt, kommer det att bli ett barn av den vänstra överlappande form / komponent.

8. Försök att minimera användningen av textanteckningar på ritningen eftersom dessa kommer att få importeras som komponenter i sin egen rätt och kommer att behöva omvandlas till freeform formar i ABACUS. Fundera på om de är egentligen namnet på en befintlig komponent eller anslutning.

9. Medan ABACUS stöder rik / färgade / vektorbaserade former, försöka minimera användningen av bitmappar, utländska former och förbättrade metafiler för former som ABACUS gör för närvarandeintestödja dessa typer. De kommer att importeras som enkla vita rektanglar.

10. Försök att undvika vagnreturer (shift-retur) i etiketteras som de importeras och visas som en speciell "[]" karaktär i ABACUS för komponentnamnet.

11. Försök att minimera de olika färgerna som används för former av samma typ. Som nämnts ovan, grundfärg och bas form identifierar komponent och anslutningstyper så ju mer variation finns det mer sammanslagning och konsolidering som kommer att behöva göras efter importen i ABACUS.

12. Var försiktig med fyllda former för om en form fylls hela vägen till hörnen sedan färga det senare i ABACUS har ingen effekt.

13. För komplexa linjebaserade former måste du använda en polygon som skapas genom att ha rader som börjar där den tidigare en klar och sedan slutligen gå tillbaka till startpunkten. Om så önskas kan du använda fyllnings- och linjebredden att göra polygon ser ut som en "pil" eller vilken form du vill.

14. Se till att former ID i MS Visio är meningsfullt inte bara Shape.xx. Detta kan redigeras med hjälp av högerklicka "Visa ShapeSheet" som finns i MS Visio utvecklarläge (aktiveras via Verktyg | Alternativ i MS Visio).

15. Ellipser och bågarinom formerstöds i ABACUS men nurbs och räfflor stöds för närvarande inte.

16. Se till att hela formen är grupperad i MS Visio eller det kommer att få importeras som flera komponenter / typer.

17. Försök att minimera användningen av roterade former inom subshapes eftersom de ibland inte importeras korrekt.

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Fylla din arkitektur från Access | Fylla din arkitektur från Excel


Fylla din arkitektur från Microsoft Excel

Navigering: Fylla din arkitektur> Fylla från Microsoft-produkter>

Fylla din arkitektur från Microsoft Excel

Skicka kommentarer om detta ämne.

Du kan importera din arkitektur från ett Excel-ark (xls eller .xlsx fil). Excel importören kan du kartlägga listor av komponenter och kontakter med olika typer, standarder, egenskaper och standard egenskaper genom att välja kolumnerna i kalkylbladet som innehåller relevanta uppgifter.Det är dock en mer avancerad teknik än den rekommenderade metodenför att importera från MS Excel som är via kataloger som beskriven här .

Notera

Importera från / Exportera till Excel funktionen kräver att Microsoft Excel 2003eller senare är installerat på datorn.

Den huvudsakliga funktionen för Excel importören är att tillåta dig att definiera en konfigurationsfil (dvs. den hierarkiska strukturen på din arkitektonisk modell). Konfigurationsfilen lagrar en tidigare sparad kartläggning från en Excel-fil till en kulram fil. När definierat, är den sparade konfigurationsfilen senare används för ytterligare import och export till xls-filer.

Notera

De steg som visas i nedanstående avsnitt är specifikt för användare som ännu inte definiera och spara en konfigurationsfil och importerar från Excel för första gången. Du måste skapa och spara en konfigurationsfil att använda export till Excel-funktionen.

Om du vill importera ett Excel-ark i ABACUS

1. Se till att du har ABACUS öppen.

2. Välj Arkiv | Nya och välj Från Exceli dialogrutan som visas och klicka på OK.

Notera

Om du vill importera till en befintlig ABACUS projekt sedan antingen högerklicka på Komponenter nod inom en arkitektur, eller högerklicka på en enskild komponent i en arkitektur och välj sedan Import | Från Excel.

3. De Importera Excel kalkylbladfönstret visas

Import Excel-kalkylblad Fönster

4. Klicka på Öppna Excel-filikon och bläddra till den Excel-fil du vill importera.

5. Välj den Kalkylbladdu vill importera från rullgardinsmenyn.

Notera

Efter att ha öppnat din Excel-fil, kan du använda Dataförhandsfliken för att visa kolumnerna och första 25 rader med kalkylbladet. Härifrån kan du få kolumnnummer som behövs för att fylla ut Ingående delar och Anslutningar flik.

Du kan också välja om du vill ha komponenter i ett Excel-ark som skall importeras med skiftlägeskänslighet. Bara markera Import med skiftlägeskänslighetalternativet (som standard detta alltid förkryssat) och kalkylbladet kommer att importeras i enlighet med detta.

Prov Excel-fil

Notera

I det här exemplet kommer vi att importera en enkel infrastruktur och folk arkitektur från Excel-data som visas i ovanstående skärmdump. Anslutningar kommer att göras mellan "ansvariga" och "Servers" som dessa människor administrerar.

För att fylla fliken Komponenter

Detta avsnitt är för att definiera komponenttyper och den hierarkiska strukturen för konfigurationsfilen.

1. Välj Ingående delar flik. Byt namn på Ange IDgenom att åsidosätta (null) värde

Notera

Denna funktion gör att du kan definiera en helt annan Satserfunktionellt separata komponenter. Som framgår av skärmdumpen nedan, kanske du vill skilja dina Infrastrukturkomponenter från dina Människor komponenter. Om det finns relationer (anslutningar) mellan dessa olika uppsättningar av komponenter, kan de definieras i Anslutningar flik. Senare i det här exemplet kommer vi att definiera anslutningar av typen "Förvaltar" mellan infrastruktur och människor Satser.

Du kan också välja om du vill lägga till en toppnivå Grupperingkomponent för alla delar av uppsättningen. Bara markera Koncernen Under Ange IDalternativet (som standard detta inte är markerat) och kalkylbladet kommer att importeras i enlighet med detta.

Tilldela Ange ID

2. När väl Satserhar definierats väljer Uppsättningdu vill fylla och expandera genom att klicka på [+] skylt.

3. Välj Nivåerna av komponenter i detta setfrån den utökade listan.

4. De Komponent Hierarki Ställer: Set IDfönster visas för att Uppsättning.

Komponent Hierarki och Tilldela värden (Set ID: Infrastruktur)

5. Byt namn på Nivå Antalkolumn genom att åsidosätta (null) värde.

Notera

De Nivå Antalkolumn kan du tilldela en hierarki för dina komponenter. Varje nivå motsvarar ett skikt i din arkitektur där den första nivån är den översta förälder nivå. Till exempel, nivånummer "1" motsvarar den översta hierarkiska lager, nivånummer "2" är barn till nivå Number "1" och så vidare.

6. Välj och tilldela relevanta kolumnen från Excel till varje Nivå Antalgenom att ange det under Komponent Kolonn kolumn.

Notera

Du kan välja att utesluta vissa rader som du inte vill vara representerade i din arkitektur. Dessa kan vara kolumnrubriker, tomma rader, etc. För att utesluta rader använder Rader att Uteslut:textrutan nära övre högra hörnet av fönstret. I det här exemplet har vi uteslutna rad 1 eftersom den innehåller våra kolumnrubrikerna.

7. Du kan välja att lägga till beskrivningar till komponenterna genom att skriva över (null)värde i Beskrivning Kolumn.

Notera

Denna beskrivning är vad som kommer att visas i ABACUS under Allmänna egenskaperavsnitt | Beskrivning fält.

8. Om en viss kalkylblad kolumn har mer än en komponent per cell (anges med Alt-Enter eller CHAR (10) kommando) kryssa sedan kryssrutan under Behandla Nya Lines som separata komponenter. Varje linje kommer att importeras som separata komponenter.

Dricks

För att importera en "matris" från en samling kolumner, där en "X" i en viss "matris" cell (cellerna B2: D2 säger) innebär att komponenten som anges av raden (i cell A2 säger) är ansluten till komponent anges av kolumnen "rubriken" (på rad 1 säga), kan man använda en enkel formel. Ange följande formel för varje rad i en kolumn bortom matrixcellerna (kolumn F säga); = OM (B2 = "", "", B $ 1 & CHAR (10)) & OM (C2 = "", "", C $ 1 & CHAR (10)) & OM (D2 = "", "", D $ 1 & CHAR (10)). Sedan ställa in en anslutningsuppsättning som beskrivs nedan mellan komponenterna specificerade av raden (i kolumn A säga) och de som beskrivs i denna formel (i kolumn F säga). Var noga med att kontrollera Behandla Nya Lines som separata komponenteralternativ när komponenterna från formeln importeras. För mer avancerad matris import, inklusive rubriker med flera skikt av hierarki eller celler med olika värden än bara en vanlig "X", vänligen kontakta Avolution Stöd .

9. Fyll i resten av kolumnerna efter behov.

Notera

Du kan välja att få den typ av kolonnraderna genom att kryssa i rutan under Få Typ Från kolumnkolumn och ange relevanta kolumnen från Excel under Komponent Typ Värde eller kolumn kolumn. Detta kommer att importera alla komponenter i den kolumnen och ställa dem till den typ som definieras i kolumnen. Alternativt, och som med skärmdumpen ovan och nedan kan du välja att använda en fast / fördefinierad typnamn genom att ange typ namn under Komponent Typ Värde eller kolumnkolumn och se till att kryssrutan är un kontrolleras.

Komponent Hierarki och Tilldela värden (Set ID: People)

Notera

I det här exemplet vill vi ha våra nätverk och människor grupperingar på nivå 1 av arkitekturen. På nivå 2 vill vi ha våra servrar och personer som ansvarar för att administrera dessa servrar. De Ingående delarFliken har fyllts ut i enlighet med, som visas i de två skärmdumpar ovan. I den första skärmbilden ovan vi har definierat nivån 1 (nätverks gruppering) och nivå 2 (server) komponenter för Infrastruktur Uppsättning. Och i skärmdumpen omedelbart ovanför vi har definierat nivån 1 (personer gruppering) och nivå 2 (personer som är ansvariga) komponenter för folket Uppsättning.

Alternativt, för det PersonerSet, istället för att använda kolumn C som Folk gruppering, vi kunde ha använt Koncernen Under Ange IDpå fliken toppnivå komponenter och sedan bara in ett Människor undernivå från kolumn D. Detta visas i skärmdumpen nedan.

Komponent Hierarki och tilldela värden med hjälp av grup Under Set ID alternativet (Set ID: People)

10. När komponenter har identifierats, väljer komponentnivå du vill fylla egenskaperna och / eller normer för och expandera genom att klicka på [+] skylt.

11. Välj Egenskaper hos komponenter på denna nivå eller Komponent Standarder på denna nivåfrån den utökade listan och fylla de relevanta kolumner efter behov.

Befolka Komponenter

Notera

Egenskaper hos komponenter på denna nivåkan du definiera egenskaper för komponenter på den valda nivån. Komponent Standarder på denna nivåkan du definiera de standarder och deras standard egenskaper för komponenter på den valda nivån.

12. Upprepa steg 2-11tills alla de ingående nivåerna har befolkat för alla definierade Satser. Använd bakåtpilen nära övre högra hörnet i fönstret för att navigera tillbaka till den Satsersom du definierat tidigare.

För att fylla fliken Anslutningar

Detta avsnitt är för att definiera anslutningstyper och den hierarkiska strukturen för konfigurationsfilen.

1. Välj Anslutningar flik. För varje uppsättning anslutningar du måste identifiera komponenten Uppsättningatt du vill vara källkomponenter och komponenten Uppsättningdu vill vara destinations komponenter.

2. Underneath Källa Komponent Ange ID Gå in i Uppsättningnamn som motsvarar Uppsättningdefinierats tidigare i Ingående delar flik. Underneath Källa Component Level Antalange numret som motsvarar den beståndsdel nivå du vill ansluta vid källan slutet av förbindelsen.

3. Välj nu vilken komponent grupp kommer att vara på resmålet slutet av förbindelsen. Underneath Destination Komponent Ange ID Gå in i Uppsättningnamn som motsvarar Uppsättningdefinieras i Ingående delar flik. Underneath Destination Komponentnivå Antalange numret som motsvarar den beståndsdel nivå du vill ansluta till destinationen i slutet av förbindelsen.

Notera

I det här exemplet vill vi ansluta personer som ansvarar för att administrera servrar till servrar som de förvaltar. De ansvariga fastställdes i Folk Uppsättningsom nivå 2 komponenter medan servrarna definierades i infrastruktur Uppsättningsom nivå 2 komponenter. De AnslutningarFliken har fyllts ut i enlighet med vad som anges i skärmdumpen nedan.

Anslutningar Tab Del 1 av 2

4. Om du bläddrar till höger hittar du extra alternativ för att importera dina kontakter. Få Typ Från kolumn och Anslutning Typ Värde eller kolumnfungerar på samma sätt som för den Ingående delar flik.

5. Om Källa Komponent Ange ID och den Källa Component Level Antalär samma som den Destination Komponent Ange ID och den Destination Komponentnivå Antal(till exempel om du ansluter samma komponenttyper, exempelvis att anslutningar från servrar till andra servrar) måste du ha en annan kolumn i kalkylbladet som innehåller namnen på de servrar upprepas. I denna situation skulle du lägga den kalkyl kolumn i Destination upprepas i kolumn kolumn. Om det i detta kalkylblad kolumnen du har skrivit mer än en ansluten komponent per cell kryssa i rutan nedanför Behandla Nya Lines som separata komponenter.

Anslutningar Tab Del 2 av 2

6. När anslutningarna har identifierats välja den anslutning du vill fylla egenskaperna och / eller normer för och expandera genom att klicka på [+] skylt.

7. Välj Egenskaper för dessa anslutningar eller Standarder för dessa anslutningarfrån den utökade listan och fylla de relevanta kolumner efter behov.

Notera

Egenskaper för dessa anslutningarkan du definiera egenskaper för den valda kopplingsgruppen. Standarder för dessa anslutningarkan du definiera de standarder och deras standard egenskaper för den valda kopplingsgruppen.

8. Upprepa steg 2-7tills alla kopplingsgrupper har fastställts.

9. När du är klar med att definiera anslutningsgrupperna, klicka på Avslutaknappen och din arkitektur kommer att skapas från den importerade Excel-fil. Exemplet ovan kommer att leda till arkitekturen som visas i skärmdumpen nedan.

Prov Arkitektur Importerad från Excel

10. Nu spara mappade konfiguration till en fil genom att klicka på Spara konfiguration ikon. Din sparade konfigurationen kan hämtas senare genom att klicka på Öppna en konfigurationsikonen nära övre vänstra hörnet av fönstret.

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Fylla din arkitektur från Access | Fylla din arkitektur från Visio


Fylla din arkitektur från Microsoft Sharepoint

Navigering: Fylla din arkitektur> Fylla från Microsoft-produkter>

Fylla din arkitektur från Microsoft Sharepoint

Skicka kommentarer om detta ämne.

Du kan synkronisera din arkitektur medMicrosoft Sharepoint-listor. Synkronisering innebär antingen att skapa nya Sharepoint-listor (och deras kolumner) från ABACUS typer, deras egenskaper och bilagor, eller kartlägga befintliga Sharepoint-listor (och deras kolumner) Abacus typer, deras egenskaper och bilagor, sedan antingen skicka innehåll från ABACUS till Sharepoint eller Sharepoint Abacus.

Notera

De Point Synk Funktionen kräver att en Microsoft Sharepoint 2010, 2013 eller Sharepoint Online Webbplatsen finns för att ansluta till och synkronisera med.Även Sharepoint Sync-funktionen kan skapa listor (med kolumner) på en Sharepoint-webbplats från någon ABACUS projekt, kan Avolution också ge olika Sharepoint webbplatsmallar till stöd för standardramar (t.ex. TOGAF, Archimate, ITIL etc) så kontakta Avolution Stöd om du behöver den här funktionen.

Till skapa en ny Sharepoint-lista och mappa den till en kulram komponent eller anslutningstyp

1. Se till att du har ABACUS öppen.

2. Välj Verktyg | Point Synk.

3. Klicka på Ny Kartläggningknappen och en Sharepoint-Mapping dialogruta som visas nedan kommer att visas.

4. Ange Webbadress, användarnamn och lösenord för Sharepoint-webbplatsen och klicka Ansluta.

Notera

Ett giltigt Sharepoint "admin" eller "bidrags" konto krävs för att synkronisera från och till Sharepoint och en "läsare" konto kommer endast att tillåta synkronisering från Sharepoint.

5. Välj ABACUS komponenten eller anslutningstyp att kartlägga från Välj typ dra ner.

6. Klicka på Lägg till nyknappen och sedan för varje ABACUS komponent eller anslutningstyp aspekt du vill mappa till en motsvarande Sharepoint listfält välja ett alternativ i den vänstra panelen och i den högra panelen in i nya Sharepoint-listnamnet i Ny lista kolumnen (endast första gången) , då Sharepoint kolumnnamnet i kolumnen Namn (eller använd standard) och klicka på Tilldela varje gång.

Notera

Som ett minimum för att tillåta synkronisering ABACUS EEID, Arkitektur och Namn aspekter kommer automatiskt mappas till en Sharepoint-nummer och två (2) enda textrad (aka Text) kolumner respektive. Dessa kan inte vara lediga. Dessutom kan endast vissa ABACUS aspekter närvarande mappas till vissa Sharepoint kolumner och Column Type rullgardins automatiskt inställd till önskad Sharepoint kolumntyp. Nämligen;

· ABACUS "Hierarki Path to Sharepoint Flera textrader (aka Note) kolonner (Obs: Sharepoint enda textrad (aka text) kolumner stöder endast 255 tecken så att de inte föredragna),

· ABACUS "Bifogade komponenter till Sharepoint Lookup kolonner (Obs: En kartläggning måste finnas en lista för de anslutna komponenterna själva),

· ABACUS "Text och beskrivning egenskaper till Sharepoint flera textrader (aka Note) kolumner (Obs: Sharepoint enda textrad (aka Text) kolumner stöder endast 255 tecken så att de inte föredragna),

· ABACUS 'Decimal eller Integer egenskaper till Sharepoint Antal kolumner,

· ABACUS "Lista fastigheter till Sharepoint Choice kolonner (Not: Sharepoint inte verkställa valet värdena så typen List uppgifter inte behöver verkställas i ABACUS),

· ABACUS "Date / Time fastigheter till Sharepoint Flera textrader (aka Note) kolonner (Obs: Sharepoint Datum och tid kolumner kan inte användas som ännu på grund av Sharepoint inkonsekventa stöd för tidszon / regionaliseringsinställningar),

· ABACUS "Boolean egenskaper till Sharepoint Ja / Nej (aka Boolean) kolumner.

En kulram elements tillhörande standarder kan inte mappas till Sharepoint-listkolumner ännu.

7. Välj Skapa Kartläggning.

Till skapa en ny mappning mellan en kulram komponent eller anslutning typ och en befintlig Sharepoint-lista

1. Se till att du har ABACUS öppen.

2. Välj Verktyg | Point Synk.

3. Klicka på Ny Kartläggningknappen och en Sharepoint-Mapping dialogruta som visas nedan kommer att visas.

4. Ange Webbadress, användarnamn och lösenord för Sharepoint-webbplatsen och klicka Ansluta.

Notera

Ett giltigt Sharepoint "admin" eller "bidrags" konto krävs för att synkronisera från och till Sharepoint och en "läsare" konto kommer endast att tillåta synkronisering från Sharepoint.

5. Välj ABACUS komponenten eller anslutningstyp att kartlägga från Välj typ dra ner.

6. Välj Sharepoint-webbplatsen listan för att kartlägga från Välj Lista dra ner.

7. För varje ABACUS komponent eller anslutningstyp aspekt du vill mappa till dess motsvarande Sharepoint-lista kolumnen välja ett alternativ i den vänstra panelen och den högra panelen respektive och klicka Tilldela.

Notera

Som ett minimum för att tillåta synkronisering ABACUS EEID, Arkitektur och Namn aspekter måste mappas till en Sharepoint-nummer och sedan för arkitektur och namn till antingen enda textrad (aka text) eller flera textrader (aka Note) kolumner respektive. Tills det är gjort Mapping knappen Skapa aktiveras inte. Vidare kan endast vissa ABACUS aspekter närvarande mappas till vissa Sharepoint kolumner. Nämligen;

· ABACUS "Architecture aspekt till en Sharepoint enda textrad (aka text) eller flera textrader (aka Note) kolumner (detta krävs för innehåll specifik kartläggning som beskrivs nedan),

· ABACUS "Hierarki Path to Sharepoint enda textrad (aka text) eller flera textrader (aka Note) kolonner (Obs: Sharepoint enda textrad (aka Text) kolumner stöder endast 255 tecken så några ytterligare tecken kommer att förkortas och därför rekommenderas att konvertera dem till flera textrader (aka Note) kolumner i Sharepoint före kartläggning),

· ABACUS "Bifogade komponenter till Sharepoint Lookup kolonner (Obs: En kartläggning måste finnas en lista för de anslutna komponenterna själva),

· ABACUS "Text och beskrivning egenskaper till Sharepoint enda textrad (aka text) eller flera textrader (aka Note) kolonner (Obs: Sharepoint enda textrad (aka Text) kolumner stöder endast 255 tecken så några ytterligare tecken kommer att förkortas och därför rekommenderas att konvertera dem till flera textrader (aka Note) kolumner i Sharepoint före kartläggning),

· ABACUS 'Decimal eller Integer egenskaper till Sharepoint Antal kolumner (Obs:. Sharepoint beräknade kolumner kan användas men de kommer bara att kunna synkroniseras från Sharepoint till ABACUS försöker synkronisera "till" en beräknad kolumn kommer att resultera i en varning enligt nedan) ,

· ABACUS "Lista fastigheter till Sharepoint Choice kolonner,

· ABACUS "Date / Time fastigheter till Sharepoint Flera textrader (aka Note) kolonner (Obs: Sharepoint Datum och tid kolumner kan inte användas på grund av Sharepoint inkonsekventa stöd för tidszon / regionaliseringsinställningar),

· ABACUS "Boolean egenskaper till Sharepoint Ja / Nej (aka Boolean) kolumner.

En kulram elements tillhörande standarder kan inte mappas till Sharepoint-listkolumner ännu. Och Sharepoint valuta, person eller grupp, Hyperlänk eller bild, Task Utfall, Externa data och lyckades metadata kolumner kan inte mappas till ABACUS aspekter än.

8. Välj Skapa Kartläggning.

Till synkroniseraMicrosoft Point lista (er)in ABACUS

1. Se till att du har ABACUS öppen.

2. Välj Verktyg | Point Synk.

Notera

Till synkronisera en Sharepoint-lista med enABACUS projektet användarlicens behöver Point Synkadd-on kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

3. Välj en befintlig Sharepoint-mappning (eller avbildningar med hjälp av Ctrl-klicka eller Välj allaknappen) från Sharepoint avbildningar panelsåsom visas i prov skärmdump ovan. Obs: Här visar vi bara ABACUS komponent kartläggning till en Sharepoint-lista "Goal (eller Krav) kallas mål väljs.

4. Välj Architecture (er) som du vill synkronisera innehållet med från Synkronisera innehåll från arkitekturerpanelen som visas i prov skärmdump ovan. Obs: Här visar vi bara "2015 Faktisk" arkitektur synkroniseras.

5. Välj Sync från SP knapp.

Notera

Om Sharepoint lägesidentiteter inte är "Alla sparade" för kartläggning (s) väljs sedan en Logga in till dialogSharePoint visas ber om Webbadress, Användarnamn och / eller Lösenord.Ange dessa. Dessutom kommer synkronisering omfatta alla andra mappningar som krävs för anslutna komponenter / lookup kolumner. Eventuella ytterligare mappningar som automatiskt ingår kommer att visas i dialogrutan enligt nedan.

6. På framgångsrik synkronisering en Sharepoint-Sync Resultat dialogruta som visas nedan en förteckning över de ändringar och eventuella varningar. Klick ok.

Till synkronisera från ABACUS till Microsoft Point lista (er)

1. Se till att du har ABACUS öppen.

2. Välj Verktyg | Point Synk.

Notera

Till synkronisera en Sharepoint-lista med enABACUS projektet användarlicens behöver Point Synkadd-on kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

3. Välj en befintlig Sharepoint-mappning (eller avbildningar med hjälp av Ctrl-klicka eller Välj allaknappen) från Sharepoint avbildningar panelsåsom visas i prov skärmdump ovan. Obs: Här visar vi bara ABACUS komponent kartläggning till en Sharepoint-lista "Goal (eller Krav) kallas mål väljs.

4. Välj Architecture (er) som du vill synkronisera innehållet med från Synkronisera innehåll från arkitekturerpanelen som visas i prov skärmdump ovan. Obs: Här visar vi bara "2015 Faktisk" arkitektur synkroniseras.

5. Välj Sync Till SP knapp.

Notera

Om Sharepoint lägesidentiteter inte är "Alla sparade" för kartläggning (s) väljs sedan en Logga in till dialogSharePoint visas ber om Webbadress, Användarnamn och / eller Lösenord.Ange dessa. Dessutom kommer synkronisering omfatta alla andra mappningar som krävs för anslutna komponenter / lookup kolumner. Eventuella ytterligare mappningar som automatiskt ingår kommer att visas i dialogrutan enligt nedan.

6. På framgångsrik synkronisering en Sharepoint-Sync Resultat dialogruta som visas nedan en förteckning över de ändringar och eventuella varningar. Klick ok.

Notera

ABACUS kommer att uppdatera Sharepoint kolumner med tomma värden även om "Kräv att denna kolumn innehåller information" är inställt på Ja i Sharepoint. Detta beror på Sharepoint inte utsätter den här inställningen externt. Om detta ska förhindras rekommenderas att en kulram Designer sätter Obligatorisk begränsningen till True och påtvingade för given egenskap med hjälp av ABACUS " tvång särdrag .

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Fylla din arkitektur från Visio | Fylla din arkitektur från Excel


Fylla din arkitektur från Microsoft SQL Server

Navigering: Fylla din arkitektur> Fylla från Microsoft-produkter>

Fylla din arkitektur från Microsoft SQL Server

Skicka kommentarer om detta ämne.

Du kan importera din arkitektur från en Microsoft SQL Server-databas. Du kan välja att bara importera tabeller och relationer effektivt importerar bara generiska strukturen av databasen eller tabeller, rader och relationer som importerar inte bara strukturen men data samt.

Notera

Från SQL Server kräver att Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014är installerat på datorn.

Så här importerar du Server-databas Microsoft SQL till ABACUS

1. Se till att du har ABACUS öppen.

2. Välj Arkiv | Nya och välj Från SQL Serveri dialogrutan som visas och klicka på OK.

3. I Server dialogrutan Importera SQL som visas anger "datornamn" och "SQLINSTANCE" värden på Connection String variabel och "DBNAME" värde av databasen Namn variabeln till sina korrekta värden som visas i prov skärmdumpen nedan.

4. Ställ in Databasens namn variabel till samma värde som Initial Catalog variabeln i steget ovan som visas i prov skärmdumpen nedan.

5. Tryck på knappen Testa anslutning och tabellerna att importera i dialogrutan ska fyllas i med de tillgängliga databastabeller, som visas i prov skärmdumpen nedan.

6. Markera de tabeller som du vill importera från antingen individuellt välja dem eller använda All, Inga och Invert knapparna till höger i dialogrutan.

Notera

Endast den främmande nyckeln Relationer som finns mellan tabellerna som du väljer kommer att få importeras.

7. Använda alternativknappen Importera Style välja om du vill importera bara tabellerna och relationer mellan dem eller tabellerna, deras rader och de specifika relationer mellan raderna.

Notera

Det första alternativet importerar tabellerna som komponenter av typen "tabell" och relationer mellan två tabeller (från främmande nycklar) importeras som anslutningar av typen "Tabell Relation". Detta är ett klassiskt "ERD" stil syn på systemtabeller. Det andra alternativet importerar tabellrader som diskreta delkomponenter av typen "Table Row" med egenskaper som motsvarar var och en av de kolumner / fält och relationerna mellan tabellrader av typen "Tabell Relation". Dessutom, om det finns en kolumn / fält som kallas "Namn" då detta används för att namnge enskilda tabellrad delkomponenter.

8. Välj Importera ... knappen.

9. Efter en kort tid (med en förloppsindikator för återkoppling) en ny ABACUS projekt kommer att skapas med tabeller, tabellrader (om det andra alternativet valdes i steget ovan) och relationer från Microsoft SQL Server-databas.

Se också

Fylla din arkitektur - Översikt | Fylla din arkitektur manuellt | Fylla din arkitektur från Visio | Fylla din arkitektur från Excel


Lägga förinställda egenskaper till en komponent, anslutning eller typ

Navigering: Fylla din arkitektur> Egenskaper>

Lägga förinställda egenskaper till en komponent, anslutning eller typ

Skicka kommentarer om detta ämne.

Standardbibliotek av fastigheter kan anges och tilldelas till något annat i arkitekturen. Dessa bibliotek är kända som Standarder. Genom att använda Standarder, Behöver du bara samla specifika system egenskaper - standardegenskaperna är redan där.

Till exempel de vanliga egenskaper hos Microsoft Windows 2000 kan sparas som en Standardoch tilldelas alla komponenter (eller anslutningar, inte att det skulle vara typiskt) med hjälp av Microsoft Windows 2000 operativsystem.

Lägga till en standardtill en komponent, anslutning eller typ

1. Högerklickpå komponenten / anslutning / typ.

2. Välj Tilldela Standard.

3. Välj en Standardfrån listan.

Se också

Fylla din arkitektur - Översikt | Ändra egenskaperna hos en komponent, anslutning eller typ | Aggregerade egenskaper


Ändra egenskaperna hos en komponent, anslutning eller typ

Navigering: Fylla din arkitektur> Egenskaper>

Ändra egenskaperna hos en komponent, anslutning eller typ

Skicka kommentarer om detta ämne.

Egenskaper är typiskt systemkraven som du definierar eller resultaten Abacus utvärderingar. (När ABACUS utför sina utvärderingar, skriver det egenskaper tillbaka till filen.) Med andra ord, egenskaper är de saker du vet om ditt system, eller de saker du använder ABACUS att ta reda på.

Om du vill ändra fastighetsvärde av en komponent, anslutning eller typ

1. Klickpå komponenten / anslutning / typ (dess egenskaper kommer att visas i fönstret Egenskaper till höger).

2. Klickför att markera den egenskap som du vill ändra.

3. Typett nytt värde.

Viktig

Dessutom är många egenskaper definieras med hjälp av Standarder . Genom att ändra en fastighet inom en StandardDu inte bara ändra det aktuella objektet, också ändra du befälhavaren Standard (under Standarder påtoppen av trädet). Innan du gör detta, kolla vad andra komponenter, anslutningar eller typer använder Standard, Eftersom förändringen kanske inte är relevant för dem- Du kan använda Referenser fönster för detta.

Dricks

Du kan ändra en anslutningens egenskaper inifrån Components gren av trädet (och vice versa). Så, till exempel, om du tittar på vilka anslutningar är knutna till en komponent, och du inser att du måste ändra en, du kan.

För att lägga till nya egenskaper till en komponent eller anslutning (via typ)

Notera

Egenskaper kan bara läggas till typer och komponenter eller anslutningar av typen "ärver" dessa egenskaper.

1. Klickpå typ (dess egenskaper kommer att visas i fönstret Egenskaper till höger).

2. Klickpå Lägg till knappen längst upp i egenskapsfönstret för att lägga till en rad längst upp i fastigheten nätet för den nya fastigheten.

3. Lägg till en Typför den nya fastigheten.

4. Lägg till en Namnför den nya fastigheten.

5. Lägg till en Standardvärdeför den nya fastigheten.

6. Lägg till en Enhetför den nya fastigheten.

7. Ställ Data typför den nya fastigheten.

Notera

Den datatyp fältet kan användas för att begränsa de giltiga värden som en fastighet kan ha. Det är; Text, Integer, Decimal, datum / tid, Boolean eller Lista.

o A TextFastigheten är en som har ett obegränsat antal tecken och i huvudsak har inga begränsningar på värdet.Om fastighetsvärdet är korrekt formad hyperlänk (dvs. Webbadresser måste börja med en av 5strängar; http: //, https: //, ftp: //, fil:eller \\ och allautrymmen ska anges med ett "% 20 ') Sedan på länken är klickbar (via Ctrl + klick).

o En Heltalegenskap måste vara ett heltal, antingen positivt eller negativtoch kan innehålla en period, utrymme, apostrof eller kommatecken för siffergruppering beroende på projektets Region inställningar från Arkiv | Projekt Alternativ.Regionen inställningar och.Netto Long.TryParse metod är används för att bestämma giltiga Heltalvärden.

o A Decimalegenskapen kan innehålla en period eller kommatecken för decimaltecken och kan innehålla en period, utrymme, apostrof eller kommatecken för siffergruppering beroende på projektets Region inställningar från Arkiv | Projekt Alternativ.Regionen inställningar och.Netto Decimal.TryParse metod är används för att bestämma giltiga Decimal värden.

o A Datum Tidegenskapen kan antingen ett datum del eller Deltid eller båda. Regionen inställningaroch .Net DateTime.TryParse metod används främst för att bestämma giltighetsdatum och / eller tid värden. Men Datum delen i förekommande fall kräver åtminstone dag och månad (året kommer att antas vara innevarande år) eller månad och år delar att gälla. D.v.s. Juni, Q3 2010 eller ens bara 2010 är ogiltiga. Även om det kommer att variera med olika regionala inställningar, vanligtvis dag, månad och år delar kan separeras med ett mellanslag, kommatecken, streck (-) eller snedstreck ("/"). Dagen delen är typiskt ett heltal från 1 till 31. Månaden delen är typiskt ett heltal från 1 till 12, en giltig tre brev förkortning för månaderna (t.ex. Jan, Feb, Mar) eller hela månaden namn (t.ex. januari, februari , Mars). Året delen är typiskt en 4-siffrigt positivt tal, men 1, 2 och 3 siffror år accepteras enligt inställningarna i Kontrollpanelen-> Regionala och språk Options-> Regional Alternativ-> skräddarsy (knapp) -> datum-> Kalender. Vanligtvis de tolkas på följande sätt; 0-29 tolkas som 2000-2029, 30-99 som 1930-1999 och 100-999 som 100-999. Ogiltiga datum såsom 31 Juni 2010 och 31/9/2010 kommer att upptäckas. Time del i förekommande fall kräver en timmar och minuter del och eventuellt en Sekunder del. Timmar, minuter och sekunder valfria delar är typiskt separerade med ett kolon (":") och sekunder delen kan anges med ett decimaltecken ("."). För ytterligare information om giltiga format hänvisas till avsnittet Anmärkningar på .Net DateTime.TryParse metod .

Dricks

Det rekommenderas att använda åtminstone tre brev månadsnamnet format (dvs "Jul" eller "juli") för datumvärden snarare än numerisk formatering (dvs "7" eller "07") som dessa värden kommer att validera över de flesta regioner beroende På projektets Region inställningar från Arkiv | Projekt Alternativ.D.v.s. Det rekommenderas att använda "15 juli 2010" i stället för "15/7/2010" eller "2010/07/15". Med detta exempel, "15/7/2010" skulle misslyckas validering för "English (United States)" och "2010/07/15" skulle misslyckas för "English (United Kingdom), men" jul 15 2010 "skulle passera för både.

o A Booleanegenskapen kan vara antingen sant eller falskt.Det är fallet okänslig så SANT eller FALSKT kan också användas men ja, nej, 1, 0 etc kommer alla misslyckas eventuella fastighets- begränsningar.

o A Listaegenskapen kan en samling fördefinierade värden som låg | Medium | Hög eller Behåll | Uppdatera | Redesign | Pension och de olika värdena kommer från fältet Enhet för fastigheten antingen som kommatecken eller rör "|" separerade värden. Egenskapen kan anses vara ordningstal (i motsats till nominell, intervall eller ratio) eftersom när de används på diagram och färgelement på diagrams och 3ds värdena behandlas bara i en stigande (eller fallande) ordning. Det är värden plottas i stigande (eller fallande) order på diagramaxlar eller färgintervall.

8. Data typ kan ställas in för att vara Funktionshindrade, Varnade eller Påtvingadgenom att högerklicka på datatyp fält för en annan inställning än text, vilket gör det möjligt för alla tecken så aldrig kan vara fel.

9. Ställ Nödvändigflagga för den nya fastigheten.

Notera

Den Obligatoriska fält kan användas för att indikera om ett värde behöver skrivas in för fastigheten. Det är att det inte kan vara tom eller tom. Falskär standard och innebär att fastigheten kan vara tom eller tom, Sanninnebär att fastigheten ska ha ett värde och kan inte vara tomt eller tomt. Det krävs kan ställas in så att Funktionshindrade, Varnade eller Påtvingadgenom att högerklicka på Obligatoriskt fält om den har ställts in på True.

Se också

Fylla din arkitektur - Översikt | Lägga förinställda egenskaper till en komponent, anslutning eller typ | Aggregerade egenskaper


Ändra en projektets Region inställningar

Navigering: Fylla din arkitektur> Egenskaper>

Ändra en projektets Region inställningar

Skicka kommentarer om detta ämne.

Fastighetsvärden kräver viss formatering i olika regioner för att matcha alla Datatyp begränsningar för Integer, Decimal och datum / tid egenskaper. Till exempel i Australien decimal "123.456 punkt sju åtta nio" representeras som "123,456.789", medan det i Tyskland skulle det vara represnted som "123.456,789", och i Frankrike skulle det vara " 123 456.789 ".Även i USA har "andra av December 1970" representeras som en kort datum "1970/12/02", men i Storbritannien är det representeras som "1970/02/12", och i Polen som "1970-1912 -02 ". Följaktligen, för att arbeta med en kulram projekt mellan regioner en global inställning per ABACUS projekt krävs.

Att förändra en kulram projektets Region inställningar

1. Se till att du har en ABACUS fil öppna.

2. Välj Arkiv | Projekt Alternativ ... och i dialogrutan som visas välj Område och Klicka på OK. Obs: Se avsnittet nedan för de regionala standard.

Notera

Om du inte ser Projekt Alternativ ... menyalternativdå du inte har Designer och administratör tilläggs och Du kan inte ändra projektets regionen.Även om ingen region är inställd (dvs. regionen i Project Options är "None (System Region)) sedan varje användarens MS Windows-inställningar nuvarande kultur (dvs. regionala inställningar)används för att validera egenskaper.

Region defaults

Följande tabell listar standardinställningar för varje region som anges genom Arkiv | Projekt Alternativ ...menyalternativ.Se nedan tabellen för en lista över de symboler som används.

Område | Decimal Symbol | Siffergruppering | Negativt tecken | Kort tid | Länge sedan | AM / PM symbol | Kort datum | Lång Datum
Engelska (Australien) | . | , | - | HH: mm | TT: mm: ss | AM | E.M | dd / MM / yyyy | dd MMMM dd
English (United Kingdom) | . | , | - | HH: mm | TT: mm: ss | AM | PM | dd / MM / yyyy | dd MMMM dd
Engelska Förenta Staterna) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | M / d / dd | dddd, MMMM dd, åååå
Franska (Frankrike) | , | utrymme | - | HH: mm | TT: mm: ss | | | dd / MM / yyyy | dddd d MMMM dd
Tyska (Tyskland) | , | . | - | HH: mm | TT: mm: ss | | | dd.mm.åååå | dddd, d. MMMM dd
Italienska (Italien) | , | . | - | HH: mm | TT: mm: ss | | | dd / MM / yyyy | dddd d MMMM dd
Spanska (Spanien) | , | . | - | H: mm | H: mm: ss | | | dd / MM / yyyy | dddd, dd 'de' MMMM 'de' yyyy
English (Canada) | . | , | - | h: mm tt | h: mm: ss tt | AM | PM | dd / MM / yyyy | MMMM-dd-åå
Franska (Kanada) | , | utrymme | - | HH: mm | TT: mm: ss | | | yyyy-MM-dd | d MMMM dd
Arabiska (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / yyyy | dd MMMM, åååå
Arabiska (Saudiarabien) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / dd | dd / MMMM / yyyy
Engelska (Sydafrika) | , | utrymme | - | hh: mm tt | hh: mm: ss tt | AM | PM | yyyy / MM / dd | dd MMMM dd
Engelska (Nya Zeeland) | . | , | - | h: mm tt | h: mm: ss tt | A.M. | p.m. | d / MM / dd | dddd, d MMMM yyyy
Engelska (Indien) | . | , | - | HH: mm | TT: mm: ss | AM | PM | dd-MM-dd | dd MMMM dd
Tyska (Schweiz) | . | ' | - | HH: mm | TT: mm: ss | | | dd.mm.åååå | dddd, d. MMMM dd
Franska (Belgien) | , | . | - | HH: mm | TT: mm: ss | | | d / MM / dd | dddd d MMMM dd
Nederländska (Belgien) | , | . | - | H: mm | H: mm: ss | | | d / MM / dd | dddd d MMMM dd
Czech (Tjeckien) | , | utrymme | - | H: mm | H: mm: ss | dop |. ODP. | d.M.yyyy | d. MMMM dd
Danska (Danmark) | , | . | - | HH: mm | TT: mm: ss | | | dd-MM-dd | d. MMMM dd
Grekiska (Grekland) | , | . | - | h: mm tt | h: mm: ss tt | πμ | μμ | d / M / dd | dddd, d MMMM yyyy
Finska (Finland) | , | utrymme | - | H: mm | H: mm: ss | | | d.M.yyyy | d. MMMM'ta 'dd
Ungerska (Ungern) | , | utrymme | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | yyyy. MMMM d.
Nederländska (Nederländerna) | , | . | - | H: mm | H: mm: ss | | | d-M-dd | dddd d MMMM dd
Norska, bokmål (Norge) | , | utrymme | - | HH: mm | TT: mm: ss | | | dd.mm.åååå | d. MMMM dd
Polska (Polen) | , | utrymme | - | HH: mm | TT: mm: ss | | | yyyy-MM-dd | d MMMM dd
Ryska (Ryssland) | , | utrymme | - | H: mm | H: mm: ss | | | dd.mm.åååå | d MMMM dd 'г.'
Svenska (Sverige) | , | utrymme | - | HH: mm | TT: mm: ss | | | yyyy-MM-dd | "den" d MMMM yyyy
Koreanska (Korea) | . | , | - | tt h: mm | tt h: mm: ss | 오전 | 오후 | yyyy-MM-dd | yyyy "년" M "월 'd' 일 'dddd
Hebreiska (Israel) | . | , | - | HH: mm | TT: mm: ss | AM | PM | dd / MM / yyyy | dddd dd MMMM dd

Följande symboler används för att ange hur datum och tider visas:

Tids symboler |
h | Timme (hh visar timme med en inledande nolla)
m | Minut (mm visar minut med en inledande nolla)
s | Andra (ss visar den andra med en inledande nolla)
tt | A.M. eller P.M.
h / H | 12 eller 24 timmars tidsvisning
Datum symboler |
d, dd | Dag
ddd, dddd | Veckodag
M | Månad
y | År

Se också

Fylla din arkitektur - Översikt | Ändra egenskaperna hos en komponent, anslutning eller typ | Lägga förinställda egenskaper till en komponent, anslutning eller typ


Aggregerade egenskaper

Navigering: Fylla din arkitektur> Egenskaper>

Aggregerade egenskaper

Skicka kommentarer om detta ämne.

Operationen "Aggregate Egenskaper"Ger dig möjlighet att lägga till värden för liknande egenskaper tillsammans och skriva (eller lägga till) resultatet till den valda överordnade elementets egenskaper. Det gör också att du kan definiera omfattningen av sammanläggning och om att uppdatera egenskaperna hos alla under element eller inte.

Att aggregera egenskaper

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Högerklicka på ett element (en arkitektur, en komponent eller en anslutning) på sig att göra aggregering och välj Aggregerade Egenskaper.

3. Välj ett av de Aggregate Alternativ (Traverse alla undernivåer eller Endast Direkt Sub-Level). Om du har valt Traverse alla undernivåerDu kan också välja alternativet om du vill Uppdatera undernivåer.

o Traverse alla undernivåerinnebär att omfattningen av sammanläggning kommer att omfatta elementen i alla nivåer under din valda elementet.

o Uppdatera undernivåerkan endast göras om du även har valt alternativet Traverse alla undernivåer. Detta innebär att när du aggregerar egenskaper nerifrån och upp, det sammanlagda resultatet på alla nivåer kommer också att uppdateras i vart och ett av motsvarande element.

o Endast Direkt Sub-Levelinnebär att endast de egenskaper hos elementen direkt under det valda elementet summeras.

o Välj Omfatta StandardEgenskaperom du vill att egenskaper som definieras i standarder som skall ingå. Annars kommer endast de egenskaper som är unika för varje komponentförekomst kan användas.

4. Välj vilka egenskaper du vill aggregera. De är grupperade i sin Typer.

5. Klicka på Nästa knapp.

6. Välj alternativet om du vill Skriv över Värden eller Lägg till värdentill det valda elementet.

o Skriv över Värdenkommer att skriva resultaten direkt i egenskaperna hos det valda elementet.

o Lägg till värdenkommer att lägga resultatet till befintliga fastigheter för det valda elementet.

Se också

Lägga förinställda egenskaper till en komponent, anslutning eller typ | Ändra egenskaperna hos en komponent, anslutning eller typ | Utvärdera din arkitektur


Analysera din arkitektur

Navigering: Analysera din arkitektur>

Analysera din arkitektur

Skicka kommentarer om detta ämne.

När du har befolkat (och eventuellt simulerade) din arkitektur, är du redo att använda ABACUS att analysera det. Genom att analysera det, kan du avgöra om din arkitektur kommer att uppfylla dina behov.

Du kan analysera din arkitektur i en mängd olika sätt:

· Diagram

· 3D se

· standard diagram (paj, rad, kolumn, bar, etc.)

· anpassade diagram ( respons tid , kapacitet utrymme , stjärn tomt , spridningsdiagram matris och bubbeldiagram )

· Arkitektur Diff

Notera

När du skapar ett diagram, 3D se, Rapport eller standardtabell, den Fönstret för val standardelement används för att välja element som du vill visa.

Se också

Fylla din arkitektur | Simulera din arkitektur | De Diagramming Verktyg


Standard Element Selection

Navigering: Analysera din arkitektur>

Standard Element Selection

Skicka kommentarer om detta ämne.

När du skapar ett diagram, 3D se, rapportera,standardtabelleller kör en simuleringElement val fönster standarden används för att välja element som du vill analysera / visa.

Standard Element Selection Window

Pulldowns

· Filtrera efter View vilja omfatta elementets från en tidigare sparad vy (dvs. diagram, diagram, 3D). På detta sätt kan du utföra komplexa "gå" frågor genom att behandla en annan vy som en sparad "query".

Kryssrutor

· Visa Nivåerkommer gruppen elementet enligt den nivå med vilken de förekommer i trädet. Nivå 1 är den översta nivån.

· Visa Typervilja gruppera element enligt de typer som de är.

· Föräldrar till utvaldakommer att innehålla överordnade element i alla valda element. På detta sätt kan du se till att endast hierarkin ovanför några barn kommer att ingå i ett "bottom-up" val.

· Barn av utvaldakommer att omfatta barn delar av alla markerade element. På detta sätt kan du se till att endast hierarkin under alla föräldrar kommer att ingå i en "top-down" val.

· Namn Matcher Värdekommer att omfatta endast de element som har ett namn som innehåller den angivna strängen (OBS: Jokertecken (dvs. och *) kan användas?). På detta sätt kan du bilda en "semantisk" fråga.

· Har Fastighets typ / namn / värdekommer att omfatta endast de element som har en Fastighets typ, namn och värde som innehåller den angivna strängen antingen direkt på elementet eller i dess Standards (OBS!?.? jokertecken (dvs. och *) kan användas T.ex. * i fältet Värde kommer ge alla element som har en icke-tomt värde för givet Property). På detta sätt kan du bilda en "semantisk" fråga.

· Har Standardkommer att innehålla endast de delar som har ett standardnamn som innehåller den angivna strängen (OBS: Jokertecken (dvs. och *) kan användas T.ex. HP * kommer att ge alla element med åtminstone en Standard börjar med bokstäverna H och P?.). På detta sätt kan du bilda en "semantisk" fråga.

· Komponenter / anslutningar knutna till utvaldakommer att omfatta alla anslutna element till dem som har valts ut. På detta sätt kan väljas en "samtal-träd" eller "slag analys".

Notera

Om du har både Visa Nivåer och Visa Typerväljs så kan du välja att ha träd visar nivåerna första eller typer först med knappen som visas ovanför de två kryssrutorna.

Dricks

När ett objekt väljs i standard Element Selection fönster, kommer det inte att bli föremål för ytterligare filterändringar tills det är avmarkerat. Eftersom det inte finns något inbyggt sätt att söka efter två olika uppsättningar av element på en gång (t.ex. komponenter med standard A eller Standard B), kan du söka först för en uppsättning väljer du de önskade komponenterna, och sedan utföra en andra sökande efter den andra uppsättningen .

Knappar

· Allaväljer alla element.

· Inverteraavmarkerar alla markerade elementen och väljer alla dem som inte valdes ut.

· Ingenavmarkerar alla element.

· Lägg till filterväljer den resulterande innehållet i de aktuella filterinställningar och tillåter val av ytterligare innehåll som effektivt en AND eller GÅ filter.

Se också

Analysera din arkitektur


Visning av en 3D-diagram

Navigering: Analysera din arkitektur> 3D-diagram>

Visning av en 3D-diagram

Skicka kommentarer om detta ämne.

ABACUS kan du visa din arkitektur som en 3D-vy där komponent- och anslutningsegenskaper är förknippade med färger, former och storlekar.

Om du vill visa en 3D-bild av din arkitektur

1. Se till att du har öppna ABACUS fileninnehåller din befolkade arkitektur.

2. Expandera Visningargren i trädet.

3. Expandera 3Dgren i trädet.

4. Dubbelklicka visualisering du vill öppna.

- eller -

1. Se till att du har öppna ABACUS fileninnehåller din befolkade arkitektur.

2. Välj Föra in| 3Deller klicka på knappen i verktygsfältet.

3. Öppna ett existerandevisualisering (.abacus3d)

- eller -

1. Se till att du har öppna ABACUS fileninnehåller din befolkade arkitektur.

2. Välj Föra in| 3Deller klicka på knappen i verktygsfältet.

3. Skapa en ny visualisering:

· Välj Arkitekturdu vill visa från rullgardinsmenyn.

· Välj Ingående delar och Anslutningardu vill inkludera i diagrammet från Fönstret för val standardelement .

· Associerade färger, former och storlekar med Komponenttyper och Egenskaper.

· Associate färger och former med Anslutningstyper och Egenskaper.

Om du vill exportera en 3D-vy

1. Se till att du har öppna en befintlig 3D-vy.

2. I 3D-vyn är rullgardinsmenyer väljer Arkiv | Exportera...och valde platsen och filtyp för visualisering filen (.abacus3d, .vrml eller .html).

3. Klick Spara.

Se också

Analysera din arkitektur | Navigering i 3D | Den diagram av verktyget


Navigering i en 3D-diagram

Navigering: Analysera din arkitektur> 3D-diagram>

Navigering i en 3D-diagram

Skicka kommentarer om detta ämne.

ABACUS kan du enkelt navigera genom din arkitektur i 3D. Upplevelsen liknar flyga. Det finns två typer av navigering:

· Basic Control Mode (standard); och

· Advanced Control Mode - byt till detta läge genom att välja Kontrollera| Advanced Control Mode.

Notera

Om du vill växla mellan Basman och avancerad styrfunktion, kan du använda F4kortkommandon funktionalitet.

Grundläggande Control Mode

· Håll vänster knapp och flytta musen framåt eller bakåt ändrar tonhöjd;

· Håll vänster knapp och flytta musen åt vänster eller höger ändrar backen;

· Håll höger knappen och flytta musen kastruller vyn;

· Håller båda knapparna ned och flytta musen framåt eller bakåt, zoomar in och ut ur arkitekturen; och

· Håller båda knapparna ned och flytta musen åt vänster eller höger, rullar vänster och höger.

- eller -

· Genom att trycka på Vänster pilpå tangentbordet eller numeriska tangentbordet kommer sväng vänster;

· Genom att trycka på Höger pilpå tangentbordet eller numeriska tangentbordet kommer sväng höger;

· Genom att trycka på Pil upppå tangentbordet eller numeriska tangentbordet zoomar in;

· Genom att trycka på Nedåtpilpå tangentbordet eller numeriska tangentbordet zoomar ut;

· Brådskande Sida upppå tangentbordet eller numeriska tangentbordet kommer pitch upp; och

· Brådskande Sida nedpå tangentbordet eller numeriska tangentbordet kommer slå ner.

Advanced Control Mode

· Rör på sigmusen framåt och tillbaka, och upp och ner, ändrar tonhöjd och girning (respektive);

· Brådskande W eller Pil uppzoomar in (framåt) till arkitekturen;

· Brådskande S eller Nedåtpilzoomar ut (bakåt) från arkitektur;

· Brådskande A eller Vänster pilrullar till vänster;

· Brådskande D eller Höger pilrullar till höger;

· Brådskande Q eller Sida nedhöjer vyn (genom att sänka perspektiv); och

· Brådskande E eller Sida uppsänker vyn (genom att höja perspektivet).

Interactive Control Mode

Genom att trycka och hålla Skift-tangentenpå tangentbordet åsidosätter det aktuella läget (Basic eller Advanced) för att öppna den interaktiva styrsätt. I detta läge är följande möjligt:

· Rullamuspekaren över en komponent eller anslutning för att se den komponent eller anslutningens namn;

· Klickpå en komponent för att zooma in på den komponenten;

· Klicka och drapå en komponent för att rotera vyn runt denna komponent; och

· Högerklicken komponent eller anslutning och välj Visa i Exploreratt se att komponent eller anslutning läge i trädet.

Gemensamma kontroller

· Använda sig av ALT-ENTER / ESCatt växla helskärmsläge;

· Använda sig av F2att ändra visningsläge. Detta kan också nås i Se Meny.

· Använd mushjulet eller +/-att ändra hastigheten. Hastigheten visas av ett antal i det nedre vänstra hörnet - visas bara när det håller på att förändras. 1 är långsammast och 100 är snabbast.


Visning av en standardtabell

Navigering: Analysera din arkitektur> Standard diagram>

Visning av en standardtabell

Skicka kommentarer om detta ämne.

ABACUS "standard sjökort är linje, bar, kolumn, område, scatter, paj, kurva, Pareto, steg, yta, radar, kub, munk, pyramid, kontur och kurva ytdiagram. När du har valt vilken typ av diagram du vill, är resten av processen för att visa vart och ett av dessa diagram densamma.

Om du vill visa en standardtabell för din arkitektur

1. Se till att du har öppna ABACUS fileninnehåller din befolkade arkitektur, Och att du har utvärderadedin arkitektur.

2. Välj Föra in| Diagrameller klicka på knappen i verktygsfältet. De Diagramfönstret visas.

Diagram fönster

3. Välj vilken typ av diagram du vill och ställa in Diagramalternativ, och klicka sedan på Nästa.

Diagramalternativ

o Stackedvisar förhållandet mellan enskilda objekt till hela. Du kan använda ett staplat diagram när du planerar att ha flera dataserier (dvs. flera egenskaper) och när du vill framhäva den totala.

o Staplad 100%kommer att jämföra den procentuella varje värde bidrar till totalt över kategorier. Du kan använda en 100% staplat diagram när du planerar att ha flera dataserier (dvs. flera egenskaper) och du vill betona bidragen till det hela, särskilt om den sammanlagda summan är densamma för varje element.

o 3D Diagramkommer helt enkelt att visa datapunkterna i 3-D-format för estetik. Om du vill visa dataserien längs en 3: e / z-axeldimension sedan använda alternativet Cluster-serien beskrivs nedan.

o Serie av Propertykommer att visa en dataserie för varje fastighet som slutligen väljs. Om detta är avmarkerat då fastigheterna blir kategorier och dataserier kommer att vara för varje element som väljs.

o Rotera diagramroterar diagrammet 90 grader medurs genom att byta x- och y-axlarna. Det här alternativet är endast tillgängligt för linjerna intensifiera och Cube diagramoch är särskilt användbar för framställning av Milestone diagram såsom beskrivs i den andra spetsen nedan. Obs: Kolumn och Stapeldiagram är redan "roteras" versioner av varandra.

o Kluster Seriekommer att visa flera dataserier längs en 3: e / z-axeldimension. Det här alternativet är bara tillgängligt för Column, Bar och Cube diagramoch är särskilt användbar för framställning av Gantt stil diagram som beskrivs i första Tips nedan.

Dricks

Du kan skapa en Gantt-schemamed horisontella staplar som visar tid / datum egenskaper för olika delar genom att välja en Bar diagramtyp och sedan välja alternativet Cluster-serien.Dessutom, när skapats kan längst till vänster bar på sjökortet göras "osynligt" genom att färga den vita genom att högerklicka på en av barerna, välja färg på menyn som visas och välja den övre vänstra färg från paletten. Dessutom gränsen för den vänstra bar kan göras "osynligt" genom att högerklicka på en av barerna, välja Egenskaper ... och på fliken Serie i dialogrutan som visas ändra gränseffekten till Ingen och färg till toppen -left färg från paletten.

Dricks

Du kan skapa en Milstolparmed små figurer som visar tid / datum egenskaper för olika delar genom att välja en kub diagramtyp och sedan välja Rotera diagram och Cluster-serien alternativ.Vidare gång skapat, kuberna kan ändras till andra former genom att högerklicka på en av kuberna i en viss dataserie och välja Egenskaper ... och på fliken Serie i dialogrutan som visas ändrar Bar antingen cylinder eller kon . Obs: The Gap breddvärde kan också användas för att "krympa" symbolerna på diagrammet för att minska överlappande, ju högre siffra desto mindre överlappande det kommer att bli.

4. I Arkitektureravsnittet, markera arkitektur / s som du vill kartlägga arkitekturnivån fastigheter för, och klicka sedan på Nästa.

Notera

Välja arkitekturnivå egenskaper är en helt valfritt steg och bör endast användas när du vill uttryckligen kartlägga egenskaper arkitekturnivå själva.En arkitektur behöver inte väljas för att sedan inkludera komponenten eller anslutningsegenskaper i nästa steg.

5. Välj Ingående delar och Anslutningarsom du vill ha i diagrammet från Fönstret för val standardelement Och klicka sedan på Nästa.

6. Välj Egenskaperdu vill ha i diagrammet och klicka Avsluta.

Diagramalternativ

o Inkludera Standard egenskaper vilja visar ärvda egenskaper från standarderna tillgängliga för val.

o Aggregerade Egenskaper vilja räkna variansen mellan de serievärden och kartlägga dessa resultat i motsats till de individuella värdena själva.Det här alternativet är bara tillgängligt om serien vid alternativet Property valdes i steg 3 ovan.

Dricks

De egenskaper som är tillgängliga för kartläggning beror på element som du väljer.

Om du vill spara ett diagram

Notera

Diagram kan bara räddas om de bara innehåller komponenter och anslutningar, som alla måste vara från en enda arkitektur inom det aktuella projektet.

1. Se till att du har en ny eller befintlig diagram öppnaoch du har gjort de nödvändiga ändringarna.

2. I diagrammet verktygsfältet klicka på längst till vänster Spara diagramknappen för att spara diagrammet och eventuella förändringar formaterings.

3. I Diagram Namndialogrutan som visas anger du ett namn för diagrammet och tryck på ok.

För att exportera ett diagram

1. Se till att du har en befintlig Diagram öppna.

2. I klicka diagrammet verktygsfältet på 2: a från vänster Spara som BMPknapp och valde platsen för diagrammet.

3. Klick Spara.

Se också

Analysera din arkitektur | Visning av en svarstid diagram | Visning av en kapacitet rymddiagram


Visning av en kapacitet rymddiagram

Navigering: Analysera din arkitektur> Anpassade diagram>

Visning av en kapacitet rymddiagram

Skicka kommentarer om detta ämne.

En Capability Space diagram kan du visa om din arkitektur uppfyller krävs systemet kapacitet när det gäller fastigheter som identifierats under systemkravanalys process.

Om du vill visa en förmåga rymddiagram

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur, Och att du har utvärderadedin arkitektur.

2. Välj Föra in| Diagram| Anpassade Diagram| Capability Utrymme. (De Capability Rymd Diagram Configdialogruta visas.)

3. I Arkitektureravsnitt, markera i arkitekturer du vill att kartlägga och klicka sedan på Nästa.

4. I Egenskaperområde, markera de arkitektoniska egenskaper du vill ska ingå som axlar i diagrammet.

5. I Förmågaområdet, för varje fastighet ingår från föregående steg, väljer du om någon lägsta eller högsta kapacitet gränser existerar och värdena för dessa gränser. Standardvärdena är de min- och maxvärden utvärderas för arkitekturer eller Målet för fastigheten om det har ställts in.

Om du vill exportera en kapacitet rymddiagram

1. Se till att du har en befintlig kapacitet rymddiagram öppna.

2. I diagrammet verktygsfältet klicka på längst till vänster Spara som BMPknapp och valde platsen för diagrammet.

3. Klick Spara.

Se också

Analysera din arkitektur | Visning av en svarstid diagram


Visning av en svarstid diagram

Navigering: Analysera din arkitektur> Anpassade diagram>

Visning av en svarstid diagram

Skicka kommentarer om detta ämne.

Ett svar tidsschema kan du visa om dina kontakter bearbetas vid den erforderliga hastigheten (dvs. inom deras deadline).

Om du vill visa en svarstid diagram

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur, Och att du har utvärderadedin arkitektur.

2. Välj Föra in| Diagram| Anpassade Diagram| Respons tid. (De Svarstid diagram Configdialogruta visas.)

3. Från Arkitekturerlistrutan väljer arkitekturen som du vill kartlägga.

4. I Anslutningarområde, kryssa anslutningarna du vill ska ingå i diagrammet.

5. De Skala Typområde, välj Linjärom du vill att vertikala axeln (svarstid) som ska visas som en linjär progression - varje segment av tiden tilldelas en lika stor andel av axeln. Välj LogaritmiskOm du vill att det visas som en logaritmisk progression - varje segment av axeln representerar allt längre perioder ju högre upp axeln du går. (Hastigheten av ökningen bestäms av Basdu väljer.)

Reaktionstid diagram vertikala axeln skalan

Om du vill exportera en svarstid diagram

1. Se till att du har en befintlig svarstid diagram öppna.

2. I diagrammet verktygsfältet klicka på längst till vänster Spara som BMPknapp och valde platsen för diagrammet.

3. Klick Spara.

Se också

Analysera din arkitektur | Visning av en kapacitet rymddiagram


Visning av en stjärna tomt på dina utvecklats arkitekturer

Navigering: Analysera din arkitektur> Anpassade diagram>

Visning av en stjärna tomt på dina utvecklats arkitekturer

Skicka kommentarer om detta ämne.

När en arkitektur har utvecklats och målen är definierade, kan det sedan visualiseras och jämföras med den ursprungliga arkitekturen med hjälp av stjärn tomter. I det här avsnittet beskrivs hur du skapar och manipulera en stjärna tomt.

Om du vill visa en stjärna tomt på dina utvecklats arkitekturer

1. Se till att du har en ABACUS filen öppen .

2. Se till att du har utvecklats och uppsatta målför din arkitektur som beskrivs i Evolving din arkitektur

3. Välj Föra in| Diagram| de Anpassade DiagramFliken | Star Plot.

4. Klicka på Avsluta knapp.

5. De Star Plotmed de utvecklade arkitekturer och sätta upp mål kommer att visas. Obs: Axlarna av stjärnan tomten kan flyttas genom att klicka och dra axlarna till ett annat område inom ramen för stjärnan tomten kvalitet utrymme.

Notera

Området på den vänstra sidan av stjärnan tomten visar inställningarna för stjärnan tomt visas. Detta inkluderar den arkitektur som har utvecklats (i detta fall "ABC Ltd As-Is 2010") Samt de mål som har satts upp för den arkitekturen. Ni kommer att märka att de mål som har en bock bredvid sig representeras som axlar stjärnan tomten (t.ex. KPI- Kostnad, KPI - Kvalitet och KPI - Time). Du kan avmarkera dessa mål vid någon tidpunkt att ta bort dem från stjärnan tomten.

De röda och gröna "prickar" som visas på din stjärna tomt representerar ett normaliserat värde, som bestäms av de bästa och sämsta värdet (skiss enligt Sätta upp mål för din utvecklats arkitektur ) För den valda toppnivå arkitektur och eventuella förändringarna av det. Dessa värden är representerade i en Kvalitet Utrymme.

Som framgår av bilden ovan, är det tydligt att den ursprungliga arkitekturen (As-Is 2010) Har dålig Kosta, Medan den första utvecklats alternativet (Till-Be 2011 - Strategi A) Har flyttat inom kvalitet utrymme för att förbättra Kosta, Kvalitet och Tidmål. Alternativt, utvecklades alternativet andra (Till-Be 2011 - Strategi B) samtidigt som det har också förbättrat Kosta storleken av förbättringen är mindre än den hos Strategi A men både kvaliteten och tidsmålen har förbättrats mer än med Strategi A.I detta fall en arkitekt Maj välja Strategi Ett över Strategi Bsom deras rekommendationoch vidareutvecklas det alternativet (To-Be 2012 - Strategi A).

6. Avmarkera Visa Evolutionskryssrutan för att dölja linjen (s) som representerar utvecklingen (s) mellan den ursprungliga (t.ex. As-Is 2010) Och utvecklats (t.ex. Till-Be 2011 - StrategiA) arkitektur (er).

7. Välj Visa Stickskryssrutan för att visa den relativa storleken av varje kvalitet attribut (de mål som har definierats på varje axel) för varje arkitektur.

8. Välj Visa arkitekturnamnkryssrutan om du vill att namnen på de ursprungliga och utvecklade arkitektur (er) visas på stjärnan tomten.

Se också

Analysera din arkitektur | Visning av en svarstid diagram | Visning av en spridningsdiagram matris av dina utvecklats arkitekturer | Evolving din arkitektur


Visning av en punktdiagram av dina utvecklats arkitekturer

Navigering: Analysera din arkitektur> Anpassade diagram>

Visning av en punktdiagram av dina utvecklats arkitekturer

Skicka kommentarer om detta ämne.

När en arkitektur har utvecklats och målen är definierade, kan det sedan visualiseras och jämföras med den ursprungliga arkitekturen med hjälp ScatterPlot matriser. I det här avsnittet beskrivs hur du skapar och förstå egenskaperna hos ett spridningsdiagram matris.

Om du vill visa en spridningsdiagram Matrix av dina utvecklats arkitekturer

1. Se till att du har en ABACUS filen öppen .

2. Se till att du har utvecklats och uppsatta målför din arkitektur som beskrivs i Evolving din arkitektur

3. Välj Föra in| Diagram| de Anpassade DiagramFliken | Scatterplot Matris.

4. Klicka på Avsluta knapp.

5. De Punktdiagrammed den definierade utvecklingen av arkitekturer och mål kommer att visas.

Notera

Området på den vänstra sidan av spridningsdiagram matrisen visar inställningarna för spridningsdiagram matrisen visas. Detta inkluderar den arkitektur som har utvecklats (i detta fall "ABC Ltd As-Is 2010") Samt de mål som har satts upp för den arkitekturen. Ni kommer att märka att de mål som har en bock bredvid sig representeras som X- och Y-axlarna för spridningsdiagram matrisen (t.ex. KPI- Kostnad, KPI - Kvalitet och KPI - Time). Du kan avmarkera dessa mål vid någon tidpunkt att ta bort dem från spridningsdiagram matrisen.

De blå prickar som visas på din tomt i matrisen representerar ett normaliserat värde, som bestäms av de bästa och sämsta värdet (skiss enligt Sätta upp mål för din utvecklats arkitektur ). Dessa värden är representerade i en Kvalitet Utrymme.

Två definierade mål jämförs mot varandra på ett spridningsdiagram matris och processen upprepas tills alla mål har jämförts (t.ex. den första handlingen i matrisen i diagrammet ovan jämför KPI - Kostnadmål med KPI - Kvalitet mål. Det andra är Kosta mot Tid och den sista tomten är Kvalitet mot Tid. De relevanta mål etiketter visas överst och höger eller varje rad av tomter.).

6. Välj Arkitektureralternativknappen om du vill visa statistik för de enskilda arkitekturer.

7. Välj Evolutionsalternativknappen om du vill visa de normaliserade förändringar från den ursprungliga arkitekturen (t.ex. As-Is 2010) Till det utvecklade arkitektur (er) (t.ex. Till-Be 2011 - Strategi A och att vara 2011 - Strategi B).

Se också

Analysera din arkitektur | Visning av en svarstid diagram | Visning av en stjärna tomt på dina utvecklats arkitekturer | Evolving din arkitektur


Visning av en bubbeldiagram

Navigering: Analysera din arkitektur> Anpassade diagram>

Visning av en bubbeldiagram

Skicka kommentarer om detta ämne.

En bubbla diagrammet kan du jämföra upp till 5 dimensioner (dvs. X, Y, bubbla storlek / radie, bubbla färg och bubbelkantfärg) i en vy.

Om du vill visa en bubbeldiagram

1. Se till att du har en ABACUS filen öppen .

2. Välj Föra in| Diagram| de Anpassade DiagramFliken | Bubbeldiagram.

3. I Arkitektureravsnitt, markera i arkitekturer (om någon) du vill kartlägga, och klicka sedan på Nästa.

4. Välj Ingående delar och Anslutningarsom du vill ha i diagrammet (i förekommande fall) från Fönstret för val standardelement Och klicka sedan på Nästa.

5. Välj x-axelegendom, och klicka sedan på Nästa.

Notera

Endast Integer, Decimal, datum / tid, Boolean och lista egenskaper kan användas för X-axeln. Dessutom är Integer, Decimal och datum / tid egenskaper plottade från vänster till höger längs axeln skalas enligt värdet på fastigheten, dock Boolean och lista egenskaper enkelt ritas från vänster till höger i exakt ordning (eller i omvänd ordning om möjligheten att vända på ordningen kontrolleras) definieras för fastigheten oberoende av deras värderingar. T.ex. Låg | Medium | Hög eller 1, 2, 4, 8, 16.

6. Välj y-axelegendom, och klicka sedan på Nästa.

Notera

Endast Integer, Decimal, datum / tid, Boolean och lista egenskaper kan användas för Y-axeln. Dessutom är Integer, Decimal och datum / tid egenskaper ritas botten till toppen längs axeln skalas enligt värdet på fastigheten, men Boolean och lista egenskaper enkelt ritas botten till toppen i exakt ordning (eller i omvänd ordning om möjligheten att vända på ordningen kontrolleras) definieras för fastigheten oberoende av deras värderingar. T.ex. Låg | Medium | Hög eller 1, 2, 4, 8, 16.

7. Välj bubbelstorlek / radieegendom, och klicka sedan på Nästa.

Notera

Endast Integer, Decimal, Boolean och lista egenskaper kan användas för bubbelstorleken / radie. Dessutom Integer och Decimal egenskaper resulterar i en bubbla storlek / radie skalas enligt värdet på fastigheten, men Boolean och lista egenskaper resulterar i lika steg ökningar av bubbelstorleken / radie i exakt ordning (eller i omvänd ordning om möjlighet att vända på ordningen kontrolleras) definieras för fastigheten oberoende av deras värderingar. T.ex. Låg | Medium | Hög eller 1, 2, 4, 8, 16.

8. Välj antingen en fast bubbla färg eller associera en fastighet med bubblan färgOch klicka sedan på Nästa.

Notera

Endast Integer, Decimal, Boolean och lista egenskaper kan användas för bubblan färg. Dessutom Integer och Decimal egenskaper resulterar i en bubbla färg inom det valda intervallet skalas enligt värdet på fastigheten, men Boolean och lista egenskaper resulterar i lika steg ökningar av bubblan färg inom det valda intervallet i exakt ordning som definierats för egendom oberoende av deras värderingar. T.ex. Låg | Medium | Hög eller 1, 2, 4, 8, 16.

9. Välj antingen ingen bubbla kantfärg eller associera en fastighet med bubblan kantfärgOch klicka sedan på Avsluta.

Notera

Endast Integer, Decimal, Boolean och lista egenskaper kan användas för bubblan kantfärg. Dessutom Integer och Decimal egenskaper resulterar i en bubbla kantfärg inom det valda intervallet skalas enligt värdet på fastigheten, men Boolean och lista egenskaper resulterar i lika steg ökningar av bubblan kantfärg inom det valda intervallet i exakt ordning definierade för fastigheten oavsett deras värden. T.ex. Låg | Medium | Hög eller 1, 2, 4, 8, 16.

Bubbeldiagram

Om du vill spara en bubbeldiagram

Notera

Bubbeldiagram kan bara räddas om de bara innehåller komponenter och anslutningar, som alla måste vara från en enda arkitektur inom det aktuella projektet.

1. Se till att du har en ny eller befintlig bubbeldiagram öppnaoch du har gjort de nödvändiga ändringarna.

2. I diagrammet verktygsfältet klicka på längst till vänster Spara diagramknappen för att spara diagrammet och eventuella förändringar formaterings.

3. I Diagram Namndialogrutan som visas anger du ett namn för bubbeldiagram och tryck ok.

För att exportera en bubbeldiagram

1. Se till att du har öppna en befintlig bubbeldiagram.

2. I klicka diagrammet verktygsfältet på 2: a från vänster Spara som BMPknapp och valde platsen för diagrammet.

3. Klick Spara.

Se också

Analysera din arkitektur


Arkitektur Diff och Sync

Navigering: Analysera din arkitektur>

Arkitektur Diff och Sync

Skicka kommentarer om detta ämne.

När du har 2 eller flera arkitekturer, antingen som evolutioner eller baslinjen arkitekturer, du kan visuellt "diff" de två arkitekturerna med hjälp av katalog eller diagram Jämförelse eller Arkitektur Diff funktionen. Detta är särskilt användbart för att upptäcka / återupptäcka de exakta ändringar som gjorts från en arkitektur till en annan som du utvecklas arkitekturer och utveckla färdplaner i ABACUS.

Till visar "diff" med en annan arkitektur via ett diagram

1. Se till att du har en ABACUS filen öppen .

2. Se till att du ha minst 2 arkitekturer i projektet.

3. Öppna diagrammet som du vill jämföra med en annan arkitektur.

4. Klicka på "Jämför detta diagram innehållet i en annan arkitektur" -knappen på Diagram i verktygsfältet.

5. Välj den andra arkitekturen från listrutan att jämföra med.

6. Du kan välja vilka skillnader visas genom att klicka på "Skillnader" -knappen på Diagram i verktygsfältet och avmarkera alternativ, t.ex. Ändrade / Lade / Unknown och Obestämd / Synk Rekommenderade/ Håll Rekommenderade.

Notera

Komponenter och anslutningar på diagrammet kommer att markeras i röd, grön eller lila där det finns skillnader mellan det innehåll som syns på den aktuella diagram och innehållet i den andra arkitekturen. Röd används där det rekommenderas att Synkronisera skillnaderna (se nedan), Grön används där det rekommenderas inte att synkronisera skillnaderna är att hålla dem (se nedan) och Lila används där ABACUS inte kan göra en rekommendation om synkronisering skillnaderna (se nedan). Endast det synliga innehållet i diagrammet jämförs så om en annotering visar ett förvar egenskapsvärde och detta värde ändras den given komponent eller anslutning kommer att visas i svagt röd, svag grön eller svagt lila och en "*" symbolen längst upp till vänster på komponenter, men om någon annan underliggande förvarsfastighetsvärdet ändrats som inte visas i en anteckning då ingen indikation ges. Innehåll som förekommer på den aktuella diagrammet men ingen matchning hittas i jämförelsen arkitekturen kommer att visas i stark röd, stark grön eller stark lilaoch en "+" symbolen visas högst upp till vänster för komponenter. Matchningen sker genom komponenttyp och namn så att om den typ eller namnet på komponenten eller anslutningen har ändrats i den andra arkitekturen ingen match kommer att hittas. Eftersom det finns inget sätt att på ett tillförlitligt sätt att avgöra om ytterligare innehåll från andra arkitekturen skulle ha visats på den aktuella diagrammet (t.ex. en extra gränssnitt mellan 2 komponenter såsom visas nedan i ett diagram från jämförelsen arkitekturen till höger), dessa skillnader är inte visas för diagram (de visas för kataloger enligt nedan). Svävar över varje ändrade objekt ska visa skillnaden i verktygstipset. Hovra över "*" symbol i övre vänstra av diagrammet ger en sammanfattning av de ändringar (eller inga förändringar) mellan diagrammet innehåll och innehållet i den andra arkitekturen.

Färg Legend

· Grön indikerar poster som inte rekommenderas att synkronisera skillnader, det vill säga att hålla dem.

· Röd indikerar poster som det rekommenderas att synkronisera skillnaderna.

· Lila indikerar poster där ABACUS inte kan göra en rekommendation om synkronisering skillnaderna.

Till synkronisera ("synk") innehåll från en arkitektur med varandra via ett diagram

1. Se till att du har en ABACUS filen öppen .

2. Se till att du ha minst 2 arkitekturer i projektet.

3. Öppna diagrammet som du vill jämföra med en annan arkitektur.

4. Klicka på "Jämför denna katalog till innehållet i en annan arkitektur" -knappen på Diagram i verktygsfältet.

5. Välj den andra arkitekturen från listan rullgardins att jämföra med.

Notera

Se ovan för det sätt ABACUS visar "diff" mellan 2 arkitekturer i katalogen. I synnerhet hur Röd används där det ärrekommenderas att Synkronisera skillnader, Grön används där det är interekommenderas att synkronisera skillnaderna och Lila används där ABACUS inte kan göra en rekommendation om synkronisering skillnaderna.

6. Högerklicka på diagrammet elementet (eller element som använder Shift eller diagrammet duken att synkronisera alla) visar en "diff" och välj Sync menyalternativet.

Notera

Eventuella ändringar synkronisering kommer endast att tillämpas på den arkitektur som för närvarande är i fokus katalog tillhör. Att tillämpa ändringar i andra arkitekturen måste du använda en katalog i den andra arkitekturen. Dessutom kommer användare endast att kunna tillämpa synkroniserings förändringar om de har tillåtelse att göra det .

Notera

Beroende på var du högerklicka på menyalternativet visas vägledning om vad exakt kommer att synkroniseras. T.ex. Högerklicka på en enda komponent i diagrammet endast synkroniseras den komponenten. Medan högerklicka på diagrammet canvas och välja Sync Alla synkroniserar alla skillnader som för närvarande visas.

Till visar "diff" med en annan arkitektur via en katalog

1. Se till att du har en ABACUS filen öppen .

2. Se till att du ha minst 2 arkitekturer i projektet.

3. Öppna den katalog du vill jämföra med en annan arkitektur.

4. Klicka på "Jämför denna katalog till innehållet i en annan arkitektur" -knappen på katalogen verktygsfältet.

5. Välj den andra arkitekturen från listrutan att jämföra med.

6. Du kan välja vilka skillnader visas genom att klicka på "Skillnader" -knappen på Diagram i verktygsfältet och avmarkera alternativ, t.ex. Ändrade / Lade / Unknown och Obestämd / Synk Rekommenderade/ Håll Rekommenderade.

Notera

Celler i katalogen kommer att markeras i röd, grön eller lila där det finns skillnader mellan innehållet i den aktuella katalogen och matchande innehållet i den andra arkitekturen. Röd används där det rekommenderas att Synkronisera skillnaderna (se nedan), Grön används där det rekommenderas inte att synkronisera skillnaderna är att hålla dem (se nedan) och Lila används där ABACUS inte kan göra en rekommendation om synkronisering skillnaderna (se nedan). Endast de synliga rader och kolumner i katalogen jämförs så om det finns en skillnad i en rad bortom raderna närvarande visas eller ett värde i en kolumn som inte visas har en skillnad då ingen skillnad kommer att anges. Om värdet i en enskild cell är annorlunda med motsvarande cell i jämförelse arkitekturen cell gränsen markeras. Kolumnrubriken och rad väljare kommer också att skuggas i svagt lilaoch visas med en "*" symbol. Dessa "*" symboler kan klickas för att hoppa till nästa skillnaden i kolumnen eller raden respektive. Rader som förekommer i den aktuella katalogen men ingen match återfinns i jämförelsen arkitekturen kommer att visas med ett "+" symbolen i raden väljaren till vänster och gränsen till hela raden kommer att markeras. Rader som skulle ha ägt rum i jämförelse arkitekturens version av katalogen (dvs med samma filter osv) men ingen match återfinns i den nuvarande strukturen kommer att visas med ett "-" symbolen i raden väljaren till vänster, gränsen hela raden kommer att belysas och hela rader celler innehåll kommer att visas i svagt lilaoch slog igenom, t.ex. 08:00 till 18:00. Matchningen sker genom komponenttyp och namn så att om den typ eller namnet på komponenten eller anslutningen har ändrats i den andra arkitekturen ingen match kommer att hittas. Svävar över varje ändrade objekt ska visa skillnaden i verktygstipset. Hovra över "*" symbol i övre vänstra av diagrammet ger en sammanfattning av de ändringar (eller inga förändringar) mellan diagrammet innehåll och innehållet i den andra arkitektur.

Färg Legend

· Grön indikerar poster som inte rekommenderas att synkronisera skillnader, det vill säga att hålla dem.

· Röd indikerar poster som det rekommenderas att synkronisera skillnaderna.

· Lila indikerar poster där ABACUS inte kan göra en rekommendation om synkronisering skillnaderna.

Till synkronisera ("synk") innehåll från en arkitektur med varandra via en katalog

1. Se till att du har en ABACUS filen öppen .

2. Se till att du ha minst 2 arkitekturer i projektet.

3. Öppna den katalog du vill jämföra med en annan arkitektur.

4. Klicka på "Jämför denna katalog till innehållet i en annan arkitektur" -knappen på katalogen verktygsfältet.

5. Välj den andra arkitekturen från listan rullgardins att jämföra med.

Notera

Se ovan för det sätt ABACUS visar "diff" mellan 2 arkitekturer i katalogen. I synnerhet hur Röd används där det ärrekommenderas att Synkronisera skillnader, Grön används där det är interekommenderas att synkronisera skillnaderna och Lila används där ABACUS inte kan göra en rekommendation om synkronisering skillnaderna.

6. Högerklicka på cellen, kolumn eller rad rubrik (eller flera objekt med hjälp av Skift eller Ctrl + A för allt) visar en "diff" och välj Sync menyalternativet.

Notera

Eventuella ändringar synkronisering kommer endast att tillämpas på den arkitektur som för närvarande är i fokus katalog tillhör. Att tillämpa ändringar i andra arkitekturen måste du använda en katalog i den andra arkitekturen. Dessutom kommer användare endast att kunna tillämpa synkroniserings förändringar om de har tillåtelse att göra det .

Notera

Beroende på var du högerklicka (dvs. en cell, kolumn eller rad rubrik) menyalternativet visas vägledning om vad exakt kommer att synkroniseras. T.ex. Högerklicka på en enda egenskap eller fästas komponent cell i katalogen kommer bara synkronisera den egenskapen eller fäst komponent. Medan högerklicka på en rad rubrik (eller rubriker som använder Shift) synkroniserar hela raden (eller raderna). Högerklicka på en kolumnrubrik synkroniserar alla skillnader i den kolumnen.

Om du vill visa en 'diff'av 2 hela arkitekturer

1. Se till att du har en ABACUS filen öppen .

2. Se till att du ha minst 2 arkitekturer i projektet.

3. Välj Verktyg| Arkitektur Diff ....

4. I dialogrutan som visas väljer du den första / Från och andra / Till arkitekturer för att jämföra.

5. Klicka på ok knapp.

Arkitektur Diff

Färg Legend

· Grönindikerar att noden tillsattes i andra / arkitektur.

· Rödindikerar att noden ströks i den andra / arkitektur.

· Blåindikerar att noden har olika attribut (t.ex. fastigheter eller standarder) i det andra / arkitektur.

· Gulindikerar att noden har skillnader i sina barn i andra / arkitektur så noden bör utökas.

Notera

Du kan högerklicka och "Show i Explorer" på alla noder för att se detaljer och mer information ges om skillnaderna i skillnaderna Sammanfattning panelen när en nod väljs.

Se också

Analysera din arkitektur | Visning av en svarstid diagram | Visning av en spridningsdiagram matris av dina utvecklats arkitekturer | Evolving din arkitektur


Simulera din arkitektur

Navigering: Simulering din arkitektur>

Simulera din arkitektur

Skicka kommentarer om detta ämne.

När du har befolkat och analyserat din arkitektur, är du redo att använda ABACUS för att avgöra om din arkitektur kommer att uppfylla dina kvantitativa behov. Detta kräver simulering. För att simulera din arkitektur måste du först besluta om vilken typ av information som du vill upptäcka. Dessa typer av information är ofta kallas KPI eller Key Performance Indicators. Till exempel vill du analysera resultatet, utvecklingsförmåga och öppenhet, eller vill du samla variabler som till exempel den totala ägandekostnaden. All denna information kan avslöjas på något sätt. När du har denna information kommer du att kunna analysera din arkitektur i en mängd olika grafiska format (eller analysera de nya värdena direkt).

Det finns tre alternativ för att simulera din arkitektur:

· Enkla metrics ;

· Färdiga simulatorer ; eller

· Skript .

Enkla Metrics

Varje komponent i din arkitektur har egenskaper - av vilka många kan vara anpassat till din ansökan Abacus. Dessa egenskaper representerar olika egenskaper hos komponenterna. I vissa fall, helt enkelt samla in dessa mått (att bygga KPI) kan vara tillräckligt för att berätta för dig viktig information om din arkitektur. Exempelvis KLOCS eller tusentals rader av kod, har i stor utsträckning används som ett mått av komplexitet. I andra fall kanske du vill exportera data och analysera den med ett annat verktyg. Dessutom kan du vill samla egenskaper efter att ha utfört en annan typ av simulering.

Egenskaper kan uppsamlas genom processen att aggregering . Aggregation lägger specificerade under fastigheter till en total vilket återspeglas i den överordnade komponenten. Aggregation fungerar bara på komponenter som innehåller delkomponenter.

Färdiga Simulatorer

Det finns fem färdiga simulatorer som kan användas med ABACUS. Dessa är:

· Prestanda;

· Modularitet;

· Total Cost of Ownership (TCO);

· Öppenhet; och

· Pålitlighet.

Notera

ABACUS automatiskt markera vilka av dessa simulatorer måste åter gå igenom Röd markera på Simulering verktygsfält .

Skript

Scripting ger möjlighet att simulera din arkitektur på egna sätt. Av att skriva skript du kan utföra simuleringar utöver den nuvarande inbyggd kapacitet ABACUS. Hela ABACUS objektmodellen är tillgänglig för skriptmotor, så att du begränsas endast av din förmåga att skriva manus!

Visual Basic script är skriptspråk som stöds av ABACUS, eftersom det ger viktiga programfunktioner i en någorlunda enkelt format.

Se också

Exportera din arkitektur | Aggregerade egenskaper | Skriva skript


Skriva skript

Navigering: Simulering din arkitektur>

Skriva skript

Skicka kommentarer om detta ämne.

The Script Editor är en enkel och funktionell verktyg för att skriva och verkställande VB eller C # skript mot för närvarande öppnade ABACUS fil(Bibliotek inte stöds i scripting). Det har den vanliga File Open, Close och spara kommandon, så att du kan spara och hämta skript du skriver. Den har också en grundläggande kör och felsöka anläggning. The Script Manager kan du enkelt utföra olika skript som du har skrivit genom att placera en menyalternativ för dem direkt i Verktyg-menyn.

För att komma åt skriptredigeraren

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Välj Verktyg | Skriptredigerarenoch Skriptredigeraren öppnas. Sedan antingen;

3. Öppna ett befintligt script via Fil | Öppna i Script Editor menyer,

eller

3. Öppna ett exempelskript via Exempel post i Script Editor menyer,

eller

3. Ställ in standardspråket till antingen VB eller C # via Språk post i Script Editor menyer,

eller

3. Öppna skript specifik hjälp via Hjälp post i Script Editor menyerna

När du skriver manus, måste du följa antingen VB eller C # syntaxenligt inställningen under språk objekt i skriptredigeraren menyerna.

NOTERA:

· Om du vill använda standard VB funktioner som MsgBox ()du måste inkludera Import Microsoft.VisualBasicuttalande i början av ditt manus. Detta var inte nödvändig innan version 3.0 av ABACUS.

· Denna hjälp omfattar inte information om hur man skriver VB script, inte heller innehålla en VB referens. Känn dig fri att skriva skript i din favorit IDE eller redaktör, sedan kopiera och klistra in dem i skriptredigeraren.

När du först starta skriptredigeraren, kommer skriptredigeraren vara tom. Du kan komma åt ett skelett script genom exempelmenyn. Första gången du startar din Manusredigerare, bör du köra Mall skelettet för att se att det fungerar. Dessutom finns det två exempelskript som kan nås genom exempelmenyn.

Att skriva ett bra manus måste du referera till ABACUS ObjectModel. Det görs tillgänglig för ditt manus genom att inkludera Import ABACUS.ObjectModeluttalande i spetsen för ditt manus. En fullständig referens till hela ABACUS objektmodellen ingår i skriptredigeraren. Du hittar den genom att välja Hjälp | Innehållfrån skriptredigeringsfönstret.

Manuset redaktör innehåller många användbara funktioner för att skriva manus, inklusive Komplettera automatiskt som visas i skärmdumpen nedan. Men för en ännu rikare användarupplevelse MS Visual Studio kan integreras med ABACUS och detaljerade anvisningar finns här .

Skriptredigeraren med Komplettera automatiskt

För att använda Script Manager

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Välj Verktyg | Script Manager.

3. Klicka på Lägg tillikon och en Öppnafönstret visas.

4. Bläddra till ABACUS Script (.abacusscript, .vb Eller .cs) Fil du vill lägga till i Verktyg-menyn.

5. Klick okoch en hänvisning till manuset kommer att visas i skript Manager-fönstret. Ange ett namn för skriptet som du vill att det ska visas i menyn Verktyg. Obs: Manager fönstret Script kan ändra storlek för att se hela sökvägen om det behövs.

6. Upprepa steg 3-5att skapa länkar till mer ABACUS skript.

7. Klick På nära hållatt stänga Script Manager och notera att ABACUS script (s) visas nu under Verktyg-menyn.

Om du vill köra ett skript

Antingen;

1. Open, skriva in eller kopiera och klistra in skriptet som du vill köra, så det visas i huvudfönstret för Skriptredigeraren.

2. Klicka på Springa knapp.

3. Om skriptet innehåller fel, kommer Fel Beskrivning längst ned i skriptredigeraren lista detaljerna inklusive radnummer. NOTERA: Varje enskild fel i Felbeskrivning sektionen kan vara dubbelklickar för att ta dig till motsvarande rad i skriptet.

- eller -

1. Välj Verktygoch sedan ABACUS Skriptnamn menyalternativ som skapats med Script Manager.

2. Om skriptet innehåller fel, kommer skriptredigeraren öppnas med innehållet i skriptet som visas i huvudfönstret (markerad på raden av det första felet) och Felbeskrivning längst ned i skriptredigeraren kommer att lista de detaljer eller felet (er) inklusive linjenummer. NOTERA: Varje enskild fel i Felbeskrivning sektionen kan vara dubbelklickar för att ta dig till motsvarande rad i skriptet.

Skript kompileringsfel

Kompileringsfel uppstå när syntaxen i skriptkoden inte är korrekt. Felen kommer att dyka upp längst ner i fönstret i avsnittet Error, med en beskrivning av felet, och linjenummer. Det är radnumret som särskiljer en sammanställning fel från en Drifttidsfel (se nedan), som inte kommer att ha ett radnummer. Kompileringsfel kan dubbelklickats att hoppa till och markera den särskilda linjen i fråga.

Scripting Runtime Fel (Viktigt)

Runtime fel inträffar efter skriptkoden har nu sammanställt utan fel, men ett fel uppstår under körning (se exempel ned ytterligare). Runtime fel är viktiga eftersom de kan resultera i skadade modeller när objekt skapas och refereras av andra föremål i modellen, är själva inte är en del av modellen (vanligtvis för att en runtime fel har uppstått innan den kod som skulle ha placerat dem i modellen någonstans, avrättades).

Om skriptet skapar objekt som ska läggas till modellen, kan du undvika korruption som orsakas av en runtime error genom att spara ditt manus, stänga scripting, och utför en ångra av de förändringar som har skapats av skriptet (om skript inte slutföra normalt ). Men det finns även andra sätt att undvika eventuella korruption förekommer (se nedan). Notera: Alla manus som bara läses från modellen och inte skriva till den, är säkra och kommer inte att orsaka några problem, oavsett om runtime fel inträffar under deras genomförande.

För att undvika korruption, när man skriver script som skapar objekt och lägga till dem i objektmodellen, föreslås att föremålen förs in i modellen så snart som möjligt om de refereras av andra objekt.

Till exempel, om du skapar en ny anslutning, och 2 nya komponenter, och sedan fästa dem tillsammans, är det bäst att skapa den första komponenten, lägg till den modellen, sedan den andra och lägga den, och sedan skapa anslutningen och lägga till den, och sedan slutligen skapa bilagor. Detta innebär att om det skulle bli en runtime error som avbryter utförandet manuset, alla objekt som krävs för att vara i objectmodel innan en bifogad fil skapas, är i modellen. Korruption kan uppstå om till exempel endast anslutningen hade tillsatts, bilagor gjorts, och sedan en runtime error inträffat före skriptet slutligen lagt till nya komponenter till model.Corruption kan uppstå när ett objekt som refereras av ett annat objekt i den objectmodel, är i sig inte i objectmodel.

Exempel runtime fel inkluderar:

· Objektreferensen har inte angetts till en instans av ett objekt - detta inträffar när en objektvariabel är en noll referens, och en metod eller egendom på det objektet används. Null referenser kan kontrolleras med "Om objectVariable är ingenting så här ..."

· Index var utanför gränserna för gruppen - detta inträffar när en grupp är nås med ett index som ligger utanför gränserna - t.ex. mindre än 0 eller lika med eller större än längden / Greven av arrayen. Kan kontrolleras Array eller samling längd av .Length eller .Count egenskaper respektive.

· Ingen Tillstånd Undantag - Du har inte behörighet att ... - detta uppstår om du inte har behörighet att göra given förändring

· Primärnyckel Undantag - Duplicera / saknad Namn / ID - detta kommer att inträffa om en ändring görs till en unik egenskap som strider mot ett annat objekt. T.ex. Arkitekturer måste vara unikt med namn, likaså med standarder.

· Referens Integrity Undantag - Ställa in en referensfält till ett objekt som inte är giltig. T.ex. lägga till "ingenting" eller null som ett barn att många av samlingarna i objectmodel.

· Zero Längd Undantag - detta kan inträffa om du försöker att ange namnet på ett objekt till en tom sträng. De flesta objekt kräver deras namn att ha minst 1 tecken.

Import Information

Notera att i början av skelett manus finns uttalanden som Import ABACUS.ObjectModel. Dessa uttalanden kommer inte att omfatta en dll som inte redan refereras av skriptet - Deras syfte är att ge en "genväg" till att behöva ange hela namnet på en klass.

Till exempel, för att deklarera en variabel av typen CComponent (som representerar en komponent i ABACUS), med den Import ABACUS.ObjectModeluttalande mot toppen av skriptet, skulle bara kräva att deklareras som dim comp som CComponent, Eftersom kompilatorn vet att titta i ABACUS.ObjectModel namespace för CComponent klassen. Utan importen uttalande, skulle det behöva deklareras som dim comp som ABACUS.ObjectModel.CComponent. Ett aggregat (t.ex. mscorlib.dll eller System.Windows.Forms.dll) kan innehålla mer än ett namespace - den Import uttalande är för dessa namn, inte för församlingarna själva. Den ABACUS.ObjectModel.dll monteringen har endast enstaka ABACUS.ObjectModel namespace nås via skript.

Automatiskt refererade sammansättningar

Följande DLL automatiskt refereras av skript:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (underförstått refereras av kompilatorn)

· ABACUS.ObjectModel.dll

För att göra ytterligare hänvisningar till antingen andra NET församlingar, eller dina egna församlingar finns i följande avsnitt om #ImportDLL uttalande.

#ImportDLL Uttalande

Från och med ABACUS 3.1 kan du referera ytterligare församlingar som du kan behöva för skript med användning av #ImportDLL uttalande. Till exempel, om du vill få tillgång till en anpassad DLL av era och utnyttja funktionaliteten i det, skulle du placera den i ABACUS katalogen och innehålla följande uppgift som den första raden (er) i skriptet. Om det är en NET dll, då normalt behöver du inte ange hela banan, bara DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Några andra saker att tänka på:

1. Eftersom DLL måste hittas vid kompileringen och körningen begränsar denna beställnings- (icke NET) DLL-filer att placeras i programmappen för ABACUS bara.

2. #ImportDLL uttalanden måste vara den första raden (er) av ett skript - om du har 5 påståenden, då de ska vara på de första 5 rader i skriptet

3. En #ImportDLL uttalande placeras var som helst, men de första raderna i manuset (t.ex. om det placerades efter en kommentar eller en Importen uttalande) kommer inte att fungera på rätt sätt och / eller kan orsaka orelaterade kompileringsfel.

#ImportDLL med Office församlingar

Om du har Microsoft Office installerat, och ditt manus kräver Office Interop församlingar, är det möjligt att hänvisa till dem helt enkelt genom att använda #ImportDLL med monterings namn (enligt nedan, t.ex. #ImportDLL Excel). Med den här metoden har fördelen att en absolut dll banan inte behöver användas, så manuset är mer portabel (bör fungera på både Office 2003 och 2007 utan att redigera skriptet).

När du använder denna funktion, är GAC (Global Assembly Cache) sökte för interop enheten, och manuset samman med sökvägen till att monteringen om de befinns. Om det inte hittas kommer skript kontrollera ABACUS programkatalogen (som innehåller Excel och Visio interops endast). Om den begärda interop inte hittas vid det här laget, är en varning visas.

De interops är normalt inte installeras i GAC om du har installerat Microsoft Office innan du installerar .NET Framework (som är en del av hela ABACUS installation). Du kan installera dem genom att utföra Ändra alternativ för Microsoft Office från Lägg till / ta bort program och välj NET programmerbarhet alternativ. För mer info, se denna artikel på MSDN.

De församlingar som denna genväg stöds är:

· Få tillgång till

· Access.Dao

· Excel

· Graf

· MSProject

· Syn

· OutlookViewCtl

· OWC11

· PowerPoint

· Utgivare

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Ord

It är inte helt klart om alla ovanstående komponenter är användbara, rum havebeen ingår i den här funktionen regardeless som vissa användare feb har ett behov av även de dunkla församlingar.

Se även

Simulera din arkitektur

© 2001-2015 Avolution Pty Ltd. Alla rättigheter reserverade.


Använda makron

Navigering: Simulering din arkitektur>

Använda makron

Skicka kommentarer om detta ämne.

Om du utför en uppgift upprepade gånger i ABACUS, kan du automatisera uppgiften genom att använda ett makro. Följaktligen är en kulram makro en inspelad serie operationer som kan spelas när som helst.

Spela in ett makro

1. Välj Verktyg | Spela in makroalternativt tryck Alt + F10.

2. Börja utföra operationer som du vill spela in.

Varning

Vid denna tid, finns det några kända problem med makroinspelning. Ta hänsyn till dessa när du spelar in dina makron:

· För närvarande makron bara spela in dina Microsoft Windows tangenttryckningar, mus-rörelser och musklick. Men på grund av begränsningar med makro-inspelaren själv, det finns några knapptryckningar som inte alltid registreras. Dessa inkluderar:

· [Flik]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] till [F12]

· Det rekommenderas därför att du kontrollerar att ett kortkommando registreras av makro-inspelaren innan du spelar in en stor sekvens av händelser som kan bero på att kortkommandon fungerar.

· För närvarande på grund av begränsningar med makro-inspelaren, är snabbmenyer inte hanteras på rätt av ABACUS när de öppnas av en åtgärd registreras av makro-inspelaren. När du öppnar en snabbmeny, måste du utföra en av de funktioner som anges i snabbmenyn via snabbmenyn, annars snabbmenyn kan förbli öppen under uppspelning, vilket kan leda till oavsiktliga åtgärder eller åtgärder som kan leda till fel i ABACUS.

· Observera att vanliga metoder för att stänga en snabbmeny (t.ex. trycka på [Esc] på tangentbordet, eller vänsterklicka någon annanstans på skärmen) kan faktiskt inte stänga snabbmenyn under uppspelning av ett makro.

Dricks

I dialogrutor, snarare än att använda musklick, är det rekommenderat att använda Tab för att flytta genom de tillgängliga kontrollerna och piltangenterna för att välja rullgardinsmenyn poster eller alternativknappen alternativ och mellanslagstangenten för att välja / de-select kontroll rutor.

För att stoppa inspelningen ett makro

1. Tryck Alt + F9eller alternativt välj Verktyg | Stoppa Makro.

2. I Spara Makro som dialog bläddra till en plats och välj en kulram makro (.abacusmac fil) filnamn och klicka på Spara.

Notera

Använder sig av Verktyg| Stoppa Makrokommer att inkludera denna operation i det inspelade makrot. Därför rekommenderas det att användarna bli skicklig på att använda Alt + funktionsknappen Alternativ för att arbeta med makron för att inte inkludera oönskade makrofunktioner i makron själva.

Dricks

Eftersom makron är för närvarande inte redigeras rekommenderas det att spela in långa uppgifter som en rad separata makron med hjälp Alt + F10 / Alt + F9 "par".

För att spela upp en inspelad Macro

1. Välj Verktyg | Uppspelnings Makroalternativt tryck Alt + F8.

2. I Open dialogrutan Makro bläddra till en plats och välj en kulram makro (.abacusmac fil) filnamn och klicka på Öppna.

Varning

När du öppnar en kulram makro, om du dubbelklickar på en makrofil från dialogrutan för bläddring för att öppna den, kan makroinspelaren håll vänster musknapp i en vänsterklickade tillstånd tills en inspelade vänsterklicka åsidosätter denna stat.

Notera

Uppspelningshastighet av makrot kan ställas in på fliken Allmänt under Verktyg| Valantingen Normal (standard), snabb eller långsam. Både snabba och långsamma uppspelningshastigheter rekommenderas inte eftersom de kommer att spela de inspelade makron till ungefär 100 gånger och 1/100. Realtid, respektive. Normal uppspelningshastighet kommer fortfarande spela makrot ca 30% snabbare än den uppmätta hastigheten så det rekommenderas under inspelning för att pausa under en kort tid efter det att eventuella långa bearbetningsuppgifter så att man vid uppspelning nästa operation inte utförs innan behandlingen uppgiften har avslutad.

Att sluta spela en inspelad Macro

1. Tryck Alt + F9.


Simula Prestanda

Navigering: Simulering din arkitektur> Simulatorer>

Simula Prestanda

Skicka kommentarer om detta ämne.

Bakgrund

Den arkitektoniska utvärderare för prestanda är en diskret händelse simulator som fungerar genom att simulera flödet av meddelanden (eller tokens) under en arkitektur. Teorin bakom detta härrör från forskning som utförts av University of Technology, Sydney, och är baserad på Layered kö nätverksmodeller(LQNM), Begränsad och färgade Petri-Nets(TCPN) och Aktivitet Cycle Diagram(ACD).

I ABACUS Prestandasimuleringen är bearbetning på en komponent som drivs till stor del av meddelanden som skickas till den från en annan komponent. Principerna bakom denna teknik kan förstås i fyra huvuddelar:

1. De meddelande-centreradkommunikation modelleras i ABACUS använder logisk(eller indirekt) anslutningar. Logiska anslutningar definierar beteendet (frekvens och data) av meddelandena som passerar mellan komponenterna. Ett bra exempel på logiska förbindelser skulle vara sekvensen flöden mellan två (2) affärsprocesser eller logiska gränssnitt mellan två (2) applikationer.

2. Logiska meddelanden transporteras till sin destination via hierarki(såsom resurssimbanor) eller direktanslutningar (t.ex. fysiska trådar). För att göra detta kan de dras upp, över och backa i hierarkin (en skiktad synsätt) för att följa den direkta vägen.

3. Den trohet av modellen kan justeras för att passa. Till exempel kan en process delas ned så långt så att varje elementär processen och funktionen har en separat bearbetnings fotavtryck. Alternativt kan det vara tillräckligt att ha bara ett värde för hela processen, vilket återspeglar den genomsnittbearbetning som svar på ett meddelande.

4. Den faktiska bearbetningutförs endast av komponenter som har (eller är) en processor. En processor är en generisk sak, och kan vara en CPU, en person, en organisatorisk enhet eller något annat som är kapabel att utföra arbetet. Till exempel, inte en affärsprocess inte någon egentlig behandling; detta görs genom den första förare lokaliserar i antingen dess överordnade hierarkin (om en swimlane notation används) eller bearbetning nätverk (om en distribuerad bearbetning notation används).

Utvärderingen utförs genom att simulera (specificerad) trafik i systemet, så att varje anslutning simuleras minst en gång. Ankomsttider för meddelanden genereras slumpmässigt med avseende på deras specificerad frekvens. Modellen simulerar resurs bearbetning och stridigheter och köa meddelanden, samla statistik på vägen som olika utgångsegenskaper.

Key Performance insatsfaktorer

1. Frekvens- Den frekvens vid vilken anslutningen sker.

2. Bearbetning- Mängden exekverings tid att slutföra en process. Detta kan vara i timmar, minuter, dagar, operationer etc.

3. Fart- Hastigheten på processorns resurs. Det vill säga hur många cykler / instruktioner / åtgärder som den kan utföra i en tidsenhet. Det är viktigt att vara konsekvent med de enheter som används för bearbetning.

4. Processorer- Antalet processorresurser. Processorer kan vara människor, CPU, externa organisationer etc.

Nyckelprestanda Output Faktorer

1. Genomströmning- Antalet meddelanden per tidsenhet genom förbindelse. Denna faktiska värdet kan jämföras med de förväntade / teoretiska värdena (dvs. frekvens) för att härleda mättnad av systemet.

2. Meddelande betyg- Antalet meddelanden per tidsenhet genom komponent. Detta är summan av alla komponenternas inkommande och utgående meddelanden.

3. Svar- Det minsta / genomsnitt / maximal latens för detta förbindelse. Detta är summan av alla de observerade latenser för anslutning från källan till diskbänken och alla köer och behandling (och latens tillbaka till källan om dubbelriktad).

4. Utnyttjande- Utnyttjandet av komponent. Detta kommer att vara 0% om komponenten inte är en enhet / processor (dvs det har inte processorer och hastighet egenskaper som definieras ovan).

Medan en diskret händelsestyrd simulering utförs för att beräkna de olika utgångsegenskaper, såsom beskrivits ovan, kan följande formel användas som en grov kontroll av resultaten (där systemet inte är mättad):

Utnyttjande = Summan av frekvens för alla inkommande anslutningar * Processing / (hastighet * processorer)

Det övergripande konceptet är kanske bäst visas genom beaktande av följande diagram, som visar två olika prestanda meta-modeller. Den vänstra stil är den klassiska "swimlane" notation med behandlings uppgifter baserat hierarkiskt inom sina processorresurser. Den högra stil är ett "distribuerat" notation med de uppgifter behandlings anslutna via en processer anslutning till deras processor resurs. Den senare notation gör att flera resurser processor för en viss bearbetning uppgift, till skillnad från den begränsade swimlane notation.

Notera

Visas på varje meta-modellen är ingångs egenskaper (i rött) och utgångs egenskaper (i blått):

Performance meta-modeller: swimlane kontra distribuerad notation

Köra Performance simulator

För att simulera din arkitektur i form av prestanda

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Välj Analys| Prestandaeller klicka på knappen i verktygsfältet.

3. Välj Arkitekturdu vill från rullgardinsmenyn för att utvärdera.

Notera

Som standard kommer ABACUS automatiskt välja den första arkitektur för vilken en ny simulering krävs på grund av någon underliggande egendom eller strukturella förändringar.Denna markering visas i Röd på Simulering verktygsfält .

4. Välj Ingående delar och Anslutningardu vill utvärdera, från Fönstret för val standardelement .

5. Ställ Speltid Skalfaktorreglaget.

Notera

Högre värden kommer att ge mer statistiskt konsekventa resultat, men tar längre tid att beräkna.

Ytterligare Kryssruta till Fönstret för val standardelement

· Save Transformerad Modell vilja spara en kopia av RBD transformerade versionen av projektet i samma mapp som det aktuella projektet och lägga "_transformed" till projektnamnet.Denna transformerade projektet kan användas för att diagnostisera i detalj tillförlitlig simulering utförs av ABACUS.

Andra alternativ till Fönstret för val standardelement

· Speltid Skalfaktor styr tiden simulering och noggrannhet med högre värden utbyteIngmer statistiskt tillförlitliga resultat, men tagande längre tid till springa.

Notera

När ABACUS beräknar simuleringstiden det kommer att avgöra den långsammaste indirekt anslutning Frekvens som valdes simuleras och sedan "warm-up" för perioden (det vill säga en över Frequency) i detta sammanhang (initiera periodiska meddelande generatorer för alla anslutningar slumpmässigt Under denna uppvärmningstid, vilket ger dem alla en chans att inleda) och sedan simulera för Speltid Scale Factor gånger perioden av detta sammanhang. Eller (1 / frekvens) uppvärmningstid + (1 / frekvens) * Speltid Skalfaktor simulering tid. Detta är att se till att att alla anslutningar initieras innan statistiken samlas in och sedan den långsammaste anslutningen fortfarande simuleras åtminstone en gång i simuleringen. T.ex. Om den långsammaste indirekt anslutning har en frekvens av 0,033 tidsheter (eller Circa gång i månaden om de tids enheterna är dagar) då uppvärmningstiden kommer att vara 30,3 tidsheter och simuleringstiden blir 30,3 tids enheter tider Kör tiden Skalfaktor.

6. Klick Avslutaoch du kommer att få en Varning dialog.

7. Eventuellt utforska varningar genom att klicka Detaljer >>.

8. Klick Fortsätt.

Notera

Vid denna punkt, kommer ABACUS utföra en diskret simulering av arkitekturen och efter en kort tid (med förloppsindikatorer för återkoppling) en beräkning komplett dialogruta visas.

9. Klick okatt erkänna simuleringen.

Dricks

För kurser och ytterligare hjälp på Prestandasimulering hänvisas till Avolution gemenskapen .

Egenskaper Komponent

Följande tabell visar de egenskaper som krävs för att utvärdera prestanda. Egenskaper söks först i Komponent fall då Component normer och om inte hittas, standard används.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighetsinmatningsraden väljare ( [image] ) Med verktygstipset "Performance Input". En förändring i någon av dessa "input" egenskaper och olika strukturella förändringar förvaret kommer att resultera i Prestations simulator som kräver en re-simulering som anges i Röd på Simulering verktygsfält .

Typ | Namn | Standardvärde | Enhet | Data typ | Nödvändig | Beskrivning
Beteende | b_pack | 0,0 |  | Decimal | Falsk | Tiden fasta tjänsten att packa på några sekunder. Denna fastighet är typiskt anges som standard typ och sedan användas för flera komponentförekomster. Till exempel har CORBA b_pack = 0,23 ms.
Beteende | m_pack | 0,0 |  | Decimal | Falsk | Tjänsten tidsvariabel att packa på några sekunder / byte. Denna fastighet är typiskt anges som standard typ och sedan användas för flera komponentförekomster.
Beteende | b_unpack | 0,0 |  | Decimal | Falsk | Tiden fasta tjänsten att packa upp på några sekunder. Denna fastighet är typisktanges som standard typ och sedan användas för flera komponentförekomster.
Beteende | m_unpack | 0,0 |  | Decimal | Falsk | Tjänsten tidsvariabel att packa upp i sekunder / bitgrupp. Denna fastighet är typisktanges som standard typ och sedan användas för flera komponentförekomster.
Beteende | Bearbetning | 0,0 |  | Decimal | Sann | Mängden exekverings tid att slutföra en process. Detta kan vara i timmar, minuter, dagar, operationer etc.
Beteende | Processorer | 1 |  | Heltal | Sann | Antalet Processor resurser. Processorer kan vara människor, CPU, externa organisationer etc.
Beteende | Fart | 100 |  | Heltal | Sann | Hastigheten på processorresursen. Det vill säga hur många cykler / instruktioner / åtgärder som den kan utföra i en tidsenhet. Det är viktigt att vara konsekvent med de enheter som används för bearbetning.
Beteende | k_bkgd | 0,0 |  | Decimal | Falsk | Bakgrundsbearbetning på komponenten. Detta används för att justera resultatet att den motsvarar de fasta förskjutningar för%. Detta kan nog ignoreras.

Följande tabell visar komponentens egenskaper utgång genom att utföra utvärderaren. En uppsättning av dessa komponent egenskaper genereras för varje komponent på varje föreställning körning.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Performance Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och Performance simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Beteende | Meddelande betyg |  | Decimal | Falsk | Antalet meddelanden per tidsenhet genom komponenten. Detta är summan av alla komponenternas inkommande och utgående meddelanden.
Beteende | Bandbredd |  | Decimal | Falsk | Övergripande bandbredd genom komponenten. Summan beror på både inkommande och utgående meddelanden.
Beteende | Utnyttjande | % | Decimal | Falsk | Utnyttjandet av komponenten. Detta kommer att vara 0% om komponenten inte är en enhet / processor (dvs. Det behöver inte processorer och fastlagt varvtal egenskaper ovan)

Egenskaper Anslutnings

Följande tabell visar de egenskaper som krävs för att utvärdera prestanda. Egenskaper söks först i Anslutnings fall, då normerna Connection och om inte hittas standard används.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighetsinmatningsraden väljare ( [image] ) Med verktygstipset "Performance Input" eller "Kostnad / prestanda Input". En förändring i någon av dessa "input" egenskaper och olika strukturella förändringar förvaret kommer att resultera i Prestations simulator och / eller Kostnad simulator kräver en ny simulering som anges i Röd på Simulering verktygsfält .

Typ

Namn

Standardvärde

Enhet

Data typ

Nödvändig

Beskrivning

Beteende

Snäll

dubbelriktad

[dubbelriktad | ensriktad]

Lookup / Lista

Sann

Om anslutningen är tvåvägs (dubbelriktad) eller enkelriktad (enkelriktad).

De tillåtna värdena för den här egenskapen är "dubbelriktad" eller "enkelriktad".

Dubbelriktad betyder synkrona begäran / svarsmeddelanden medan enkelriktad sätt en enda asynkron "händelse".

Beteende

Abstraktion

indirekt

[indirekt | direkt]

Lookup / Lista

Sann

Om anslutningen är fysiskt eller logiskt. Direkta anslutningar är fysiska "rör" mellan två komponenter som logiska kopplingar flyter längs.

De tillåtna värdena för den här egenskapen är "direkt" eller "indirekt".

Om värdet är "direkt" då anslutningen inte behöver några andra egenskaper (med undantag för fastigheterna Slag och abstraktion).

Data

L_app1

0

Heltal

Falsk

Request / event storlek i byte.

Varje anslutning har typiskt ett specifikt värde för detta. I CORBA, händelser är faktiskt dubbelriktad och har alltid en 12 byte bekräfta (L_app2). Om det är en sann enkelriktad anslutning sedan lämna ut fastigheten L_app2.

Data

L_app2

0

Heltal

Falsk

Respons / bekräfta storlek i byte.

Varje anslutning har typiskt ett specifikt värde för detta. En enkelriktad anslutning kommer inte att ha L_app2.

Beteende

Frekvens

1

Decimal

Sann

Frekvensen vid vilken anslutningen sker.

Varje anslutning har typiskt ett specifikt värde för detta. Om fastigheten Frekvens lämnas ut då standard används.

Beteende

Relation

processer

[processer | stöder]

Lookup / Lista

Falsk

Anslutningar som har "processer" egendom visar att komponenten vid början av förbindelsen kommer att ändras för att behandlas vid den komponenten i änden av förbindelsen. I själva verket "källa" komponent flyttas till bli ett barn av "sjunka" komponent (bifogade anslutningar även "dras" med detta drag).

Om en "processer" egendom finns sedan alla andra anslutningsegenskaper kommer att ignoreras, utom valfria "%" egendom som beskrivs nedan.

Beteende

%

100,0

Decimal

Falsk

Anslutningar som har "processer" egendom (beskriven ovan) kan valfritt ha en "%" egenskapen att ange den del av den bearbetning som kommer att tilldelas till destinationskomponenten. På detta sätt kan en enda källa komponent kan bearbetas av flera destinations komponenter vid olika% 's. De% värdena behöver inte lägga till upp till 100% och det är helt enkelt för att skala "behandling" egendom (se ovan) för den apparat som det omvandlas att bli ett barn av destinations komponenten.

Följande tabell visar de egenskaper som genereras av prestanda utvärderaren. En uppsättning av dessa anslutningsegenskaper genereras för varje anslutning på varje föreställning körning.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Performance Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och Performance simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Beteende | Bandbredd |  | Decimal | Falsk | Den totala bandbredden för anslutningen. Detta beräknas endast för indirekta anslutningar och är i huvudsak (L_app1 + L_app2) * genomströmning.
Beteende | Bandbredd 1/2 |  | Decimal | Falsk | Bandbredden specifikt för utgående (1) och inkommande (2) budskap anslutningen. Detta beräknas endast för indirekta anslutningar och är i huvudsak L_app1 * genomströmning och L_app2 * genomströmning.
Beteende | Genomströmning |  | Decimal | Falsk | Antalet meddelanden per tidsenhet genom anslutningen. Denna faktiska värdet kan jämföras med de förväntade / teoretiska värdena (dvs. frekvens) för att härleda mättnad av systemet.
Beteende | Avslutad | % | Decimal | Falsk | Procentandelen av meddelanden som framgångsrikt komplett bearbetning för anslutning. Detta beräknas endast för indirekta anslutningar och är genomströmning / frekvens. Ibland Avslutade värdet överstiger 100% eftersom slumpmässigheten meddelande generation resulterar i en något högre meddelande generation frekvens än vad som anges.
Beteende | Response (Min / Ave / Max) |  | Decimal | Falsk | Den lägsta / genomsnitt / maximal latens. Detta beräknas endast för indirekta anslutningar och är den observerade fördröjning för anslutning från källan att sjunka och alla köer och behandling (och latens tillbaka till källan om dubbelriktad).

Arkitektur Egenskaper

Följande tabell visar systemomfattande arkitektoniska egenskaper som genereras av prestanda utvärderaren. En enda uppsättning egenskaper för arkitektur "aggregerade" för varje föreställning körning.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Performance Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och Performance simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Beteende | Meddelande betyg |  | Decimal | Falsk | Antalet meddelanden per tidsenhet genom komponenterna i arkitekturen. Detta är summan av alla komponenternas inkommande och utgående meddelanden.
Beteende | Genomströmning |  | Decimal | Falsk | Antalet meddelanden per tidsenhet genom anslutningarna i arkitekturen. Detta är summan av alla indirekta anslutningar "genomströmning och denna faktiska värde kan jämföras med de förväntade / teoretiska värdena (dvs. frekvens) att härleda mättnad av systemet.
Beteende | Bandbredd |  | Decimal | Falsk | Den totala bandbredd. Summan av arkitekturens anslutnings bandbredd.
Beteende | Utnyttjande | % | Decimal | Falsk | Utnyttjandet av alla komponenter. Kan vara större än 100% eftersom det är bara summan av alla arkitekturens komponent utilisations.
Beteende | Response (Min / Ave / Max) |  | Decimal | Falsk | Den lägsta / genomsnitt / maximal latens. Summan av alla de observerade latenser för arkitekturens anslutningar från källan att sjunka (och tillbaka till källan om dubbelriktad).


Simulera Modularitet

Navigering: Simulering din arkitektur> Simulatorer>

Simulera Modularitet

Skicka kommentarer om detta ämne.

Modularitet simulator beräknar antalet inkommande och utgående anslutningar för varje komponent.

För att simulera din arkitektur när det gäller modularitet

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Välj Analys| Modularitet.

3. Välj den Arkitektur (er)du vill inkludera i utvärderingen.

Notera

Som standard kommer ABACUS automatiskt välja arkitektur (er) för vilken en ny simulering krävs på grund av eventuella underliggande strukturella förändringar.Denna markering visas i Röd på Simulering verktygsfält .

4. Klick Nästa.

5. Välj den Anslutningstyper (er)du vill inkludera i utvärderingen.

6. Klick Nästa.

7. Eventuellt anpassa egenskapsnamnen för beräkningsresultaten.

8. Klick Avsluta.

Notera

Vid denna punkt, kommer ABACUS utföra en strukturell utvärdering av arkitektur (er) och efter en kort tid (med förloppsindikatorer för återkoppling) en beräkning komplett dialogruta visas.

9. Klick okatt bekräfta utvärderingen.

Dricks

För utbildningar och ytterligare hjälp på Modularitet utvärdering hänvisas till Avolution gemenskapen .

Egenskaper Komponent

Följande tabell visar komponent egenskaper som matas ut genom modularitet utvärderaren.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Modularitet Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av en underliggande strukturell förändring till slutförvaret och Modularitet simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Data typ | Nödvändig | Beskrivning
Modularitet | Koppling-fan i (lokal) | Heltal | Falsk | Antal anslutningar som fan i denna komponent.
Modularitet | Koppling-fan ut (lokal) | Heltal | Falsk | Antalet anslutningar som fläkten ur denna komponent.
Modularitet | Koppling-fan i | Heltal | Falsk | Antal anslutningar som fan i denna komponent, inklusive anslutningar som fan i delkomponenter.
Modularitet | Koppling-fläktar ut | Heltal | Falsk | Antalet anslutningar som fan av denna komponent, inklusive anslutningar som fan i delkomponenter.


Simulering av Total Cost of Ownership (TCO)

Navigering: Simulering din arkitektur> Simulatorer>

Simulering av Total Cost of Ownership (TCO)

Skicka kommentarer om detta ämne.

Bakgrund

Total Cost of Ownership (TCO) är en finansiell uppskattning, utformad för att mäta den totala uppkommit livscykelkostnaderna (från förvärv till avveckling / avyttring) i samband med ägda tillgångar. TCO inte bara återspeglar kostnader för inköp, det inbegriper också alla andra aspekter i vidare användning och underhåll av tillgången.

TCO används för att bestämma den ansträngning och budget kostnader som är nödvändiga för att spendera på ett system. Ett enkelt sätt att modellera i ABACUS för TCO är att bryta IT-systemet ner i komponenter. Vi kan sedan ta reda på hur mycket i genomsnitt kostar det att köra en av dessa komponenter. Efter detta kunde vi sedan faktor i olika kostnader beroende på om IT-systemet är evolvable eller öppet etc. Om ett system är redan igång, är den viktigaste faktorn att överväga kostnader för underhåll och kanske kostnaden för att avveckla.

Ett exempel

Diagram för räkneexempel

Komponenten enligt organisationen eller dess standard har dessa egenskaper:

· FTE= 100 000 $ / år

· Stöd försök= 0,01 FTE + 0,001 heltidsekvivalenter / år = 1000 $ + 100 $ / yr

· Underhållskostnad= 100 $ - 10 $ / år

· Kapitalkostnad= 2000 $

· Installera Ansträngning= 2 heltidsekvivalenter / dagar = 0,01 heltidsekvivalenter / år = $ 1000

Komponenten enligt organisationen har dessa egenskaper:

· Installera Horizon= -2 År (dvs. Systemet installerades 2 år innan den nuvarande)

· Livslängd= 3 år

När Installera Horizon + Livslängd <= 0 , Det finns inget mer underhåll Kostnad.

Beräkningar

Beräkningarna är som följer:

Notera

TC = kostnaden per år. SE = Stöd försök. MC = Underhåll Kostnad.

· Initial kostnad = kapitalkostnad + Installera Ansträngning= 2000 + 1000 = 3000 $

· Vid t = -2 (under 1 år) TC = Initial kostnad + SE + MC= 3000 + 1000 + 100 = 4100 $

· Vid t = -1, TC = SE + MC= (1000 + 100) + (100 - 10) = 1190 $

· Vid t = 0, TC = (1000 + 200) + (100 - 20) = 1280 $

· Vid t = 1 (sista år), TC = (1000 + 300) + (100-30) = 1370 $

Diagram för räkneexempel

TCO är summan av alla nuvarande och framtida kostnader tills systemet har lagts ned.

· Vid t = -2 (under 1: a året), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Vid t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Vid t = 0, TCO = 1280 + 1370 = 2650 $

· Vid t = 1 (sista år), TCO = 1370 $

Viktigaste kostnadsfaktorerna

De viktigaste kostnadsfaktorer som skall beaktas vid beräkningen av TCO för en tillgång i ABACUS är:

· Hårdvara Förvärv- Initial kostnaden för utrustningen (kapitalkostnad).

· Mjukvara Förvärv- Initial kostnad av licensen för programvaran (kapitalkostnad).

· Installation- Kostnader i samband med den första installationen.

· Utbildning- Kostnader i samband med extern leverantör utbildning efter den första installationen.

· Stöd- Kostnader i samband med intern support.

· Underhåll- Kostnader för att byta ut eller uppgradera leverantörs underhållskontrakt, varor och indrivningskostnader katastrof.

· Infrastruktur- Kostnader i samband med stöd tillgången.

ABACUS Exempel Representation av Key kostnadsfaktorer

Köra Kostnad simulator

För att simulera din arkitektur i termer av kostnad

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Välj Analys| Kosta.

3. Välj den Arkitektur (er)du vill inkludera i utvärderingen.

Notera

Som standard kommer ABACUS automatiskt välja arkitektur (er) för vilken en ny simulering krävs på grund av någon underliggande egendom eller strukturella förändringar.Denna markering visas i Röd på Simulering verktygsfält .

4. Välj Valutafrån pull down.

5. Flytta År för att beräknareglaget till det antal år som krävs.

Notera

Som standard är mer än ett år de kostnader automatiskt kommer att beräknas för varje enskilt år (och en samling av fastigheter till / uppdateras) och sedan ett kumulativt värde för hela antal år beräknas också om åren att beräkna. Om endast krävs det ackumulerade värdet sedan avmarkera Beräkna Per-Year Kostnaderalternativ som beskrivs nedan för att spara på antalet fastigheter i projektet.

6. Välj om du vill lämna Beräkna Per-Year Kostnaderkontrolleras eller avmarkera den.

7. Klick Nästa.

8. Eventuellt välja Anslutningardu vill tillskriva kostnader tillsammans som en del av utvärderingen.

Notera

Med användning av en Kostnad | Erkännandefastighet på anslutningar kostnaderna kan vara skrivas från komponenten fäst till sink ände av förbindelsen till komponenten fäst vid källänden(dvs. Kostnad | Attribution = "Sink att källan"), eller från komponenten fäst till källa ände av förbindelsen till komponenten fäst till sjunka avsluta(dvs Kostnad | Attribution = "Source att sjunka"). Dessutom, ABACUS kommer automatiskt att välja dessa anslutningar med en Behaviour | Förhållande = "processer" eller "stöd"och riktningen för tilldelning kommer att vara "Sjunk Source". Vidare är kostnaderna fördelas enligt något Beteende | % Eller Kostnad | % Fastigheter på anslutningarna, eller alternativt där det finns flera anslutningar från ett handfat till många källoreller källan till många sänkor, Enligt något Beteende | Bearbetningsegenskaper på källkomponentereller sjunka komponenter respektive.

9. Klick Avslutaoch du kommer att få en Varning dialog.

10. Eventuellt utforska varningar genom att klicka Detaljer >>.

11. Klick Fortsätt.

Notera

Vid denna punkt, kommer ABACUS utföra en aktivitetsbaserad kostnadsberäkning utvärdering av arkitektur (er) och efter en kort tid (med förloppsindikatorer för återkoppling) en beräkning komplett dialogruta visas.

12. Klick okatt bekräfta utvärderingen.

Dricks

För kurser och ytterligare hjälp på simulering hänvisas till Avolution gemenskapen .

Komponent och / eller anslutning Egenskaper

Följande tabell visar komponenten och / eller anslutning egenskaper som krävs för att bedöma kostnaderna.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighetsinmatningsraden väljare ( [image] ) Med verktygstipset "Kostnad Input". En förändring i någon av dessa "input" egenskaper och olika strukturella förändringar förvaret kommer att resultera i kostnadssimulator som kräver en re-simulering som anges i Röd på Simulering verktygsfält .

Typ

Namn

Standardvärde

Enhet

Data typ

Nödvändig

Beskrivning

Kosta

Installera Horizon

0

år

Heltal

Sann

Anger när komponenten eller anslutning har varit eller kommer att installeras.

· Värdet 0 (standard) anger att komponenten eller anslutning installeras under innevarande år.

· Ett värde mindre än 0 anger att komponenten eller anslutning har installerats i det förflutna.

· Ett värde större än 0 anger att komponenten eller anslutning kommer att installeras i framtiden.

Kosta

Livslängd

0

år

Heltal

Sann

Anger den tid i vilken komponenten eller anslutning kommer att finnas kvar i drift, varefter det kommer att avvecklas.

Kosta

FTE

100,000.00

$ / år

Decimal

Falsk

Den årliga kostnaden för varje Heltid Tillsvidare.

Om den här egenskapen inte finns i komponentensjälv eller i fallet av förbindelser komponenten fäst till sink ände av förbindelsenKommer det att sökas i andra komponenter.

För det första, någon "sink" komponents i slutet av a samband med en "bärare" förhållande till komponenten kommer att sökas, följt av att "sjunka" komponent förälders.

Om fastigheten FTE inte hittas, komponentens förälderpåverkar human kommer då sökas. Om FTE fortfarande inte hittas, är standardvärdet som används.

Observera: FTE är bara en giltig ingångs fastighet på komponenter.

Kosta

Underhåll Kostnad (fast)

0,00

$ / år

Decimal

Falsk

Den årliga fasta kostnaderna för att underhålla komponenteneller anslutning.

Kosta

Underhåll Kostnad (variabel)

0,00

$ / år

Decimal

Falsk

Det belopp varmed den totala kostnaden för att upprätthålla komponenten eller anslutning ändras varje år.

Till exempel anger ett värde på -500 $ att den totala underhållskostnaden minskar med $ 500 varje år, medan ett värde på $ 500 indikerar att den totala underhållskostnader ökar med $ 500 varje år.

Kosta

Stöd ansträngning (fast)

0,00

FTE / år

Decimal

Falsk

Den årliga fasta insatser för att stödja komponenteneller anslutning, Anges i termer av årsverken.

Kosta

Support försök (variabel)

0,00

FTE / år

Decimal

Falsk

Det belopp med vilket den totala ansträngningen att stödja komponenten eller anslutning ändras varje år.

Till exempel, indikerar ett värde på -0,01 att det totala stödet ansträngningen minskar med 0,01 årsverken per år, medan ett värde på 0,01 indikerar att den totala stödansträngningen ökar med 0,01 varje år.

Kosta

Kapitalkostnad

0,00

$

Decimal

Falsk

Den initiala kostnaden för att köpa komponenteneller anslutning.

Kosta

Installera Ansträngning

0,00

FTE

Decimal

Falsk

Den ansträngning som krävs i årsverken, för att installera komponenteneller anslutning.

Följande tabell visar komponenten och / eller anslutning egenskaper som matas ut från TCO utvärderare. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Kostnad Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och kostnaden simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Notera

Om utgångs egenskaper från TCO utvärderaren måste vara "rundade" "Round hälften till även" -strategin (även kallat bankirer "avrundning) används.Denna teknik används för att jämnare lösa eventuella 0,5 "tie-breaks" med resultatet avrundas uppåt eller nedåt till närmaste även resultat, snarare än alltid avrundning uppåt eller nedåt och skev resultatet. D.v.s. 2,5 avrundas nedåt till två, medan 3,5 avrundas uppåt till 4, i stället för dem båda är antingen avrundas nedåt till två och tre eller avrundas uppåt till 3 och 4.

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Kosta | Totalkostnad att äga - nästa x år. | $ | Heltal | Falsk | Den totala ägandekostnaden under de kommande xår, där x är den tidslängd som anges när man kör utvärderaren. Detta inkluderar kostnader för komponentens eller anslutningens standarder, sub-komponentereller underanslutningar(d.v.s. barn) och eventuella tillskrivs kostnader.
Kosta | Totalkostnad att äga (lokal) - nästa x år. | $ | Heltal | Falsk | Den "lokala" ägandekostnad under nästa xår, där xär den tid som anges när du kör utvärderaren. Detta gör inteinkludera kostnaden för komponentens delkomponenter eller anslutningens underanslutningar (d.v.s.barn) eller eventuella tillskrivs kostnader.
Kosta | Totalkostnad att äga (barn) - nästa x år. | $ | Heltal | Falsk | Den "barn" ägandekostnad under nästa xår, där x är den tidslängd som anges när man kör utvärderaren. Detta endast inkluderar kostnaden för komponentens delkomponenter eller anslutningens underanslutningar (d.v.s. barn).
Kosta | Totalkostnad att äga (skrivs) - nästa x år. | $ | Heltal | Falsk | Den "tillskrivas" ägandekostnad under nästa xår, där x är den tidslängd som anges när man kör utvärderaren. Detta endast inkluderar alla tillskrivas kostnader från de bifogade komponenter(vilket kan naturligtvis inkluderar skrivas kostnader från alla anslutna anslutningar).

Följande tabell visar komponenten och / eller anslutning egenskaper som matas ut från TCO utvärderarenOm Beräkna Per-Year Kostnader alternativ väljs. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Kostnad Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och kostnaden simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Notera

Se anmärkning ovan om en eventuell avrundning utgångsegenskaper.

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Kosta | Totalkostnad att äga - årX. | $ | Heltal | Falsk | Den totala ägandekostnaden för år x, Där x är för varje år anges när du kör utvärderaren. Detta inkluderar kostnader för komponentenseller anslutningens standarder, sub-komponenter eller underanslutningar (d.v.s. barn) och eventuella tillskrivs kostnader.
Kosta | Totalkostnad att äga (lokal) - årx. | $ | Heltal | Falsk | Den "lokala" ägandekostnad för år x, var x är för varje år anges när du kör utvärderaren. Detta gör inteinkludera kostnaden för komponentens delkomponenter eller anslutningens underanslutningar (d.v.s. barn) eller eventuella tillskrivs kostnader.
Kosta | Totalkostnad att äga (barn) - årx. | $ | Heltal | Falsk | De "barn" ägandekostnad för år x, Där x är för varje år anges när du kör utvärderaren. Detta endast inkluderar kostnaden för komponentens delkomponenter eller anslutning sub-anslutning (d.v.s. barn).
Kosta | Totalkostnad att äga (skrivs) - årx. | $ | Heltal | Falsk | Den "tillskrivas" ägandekostnad för år x, Där x är för varje år anges när du kör utvärderaren. Detta endast inkluderar alla tillskrivas kostnader från de bifogade komponenter(vilket kan naturligtvis inkluderar skrivas kostnader från alla anslutna anslutningar).

Ytterligare Egenskaper Anslutnings

I följande tabell visas ytterligare anslutningsegenskaper som krävs av TCO utvärderare. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighetsinmatningsraden väljare ( [image] ) Med verktygstipset "Kostnad / prestanda Input" eller bara "Kostnad Input". En förändring i någon av dessa "input" egenskaper och olika strukturella förändringar förvaret kommer att resultera i Kostnad och / eller Prestanda simulator kräver en ny simulering som anges i Röd på Simulering verktygsfält .

Typ | Namn | Standardvärde | Enhet | Data typ | Nödvändig | Beskrivning
Kosta | Erkännande | Sjunka till Källa | [Källa till Sink | Sjunka till Source] | Lookup / Lista | Sann | Om "Källa till Sink", Detta sammanhang vilja ha ha kostasskrivas "tillsammans" Det från källakomponent till sjunka komponent. Alternativt, om "Sjunka till Källa", Detta sammanhang vilja har kostnaderna tillskrivas "tillsammans" Det från diskhon komponenten till källkomponenten.
Beteende | Relation | bärare | [processer | stöder] | Lookup / Lista | Falsk | Om "stöd", visar detta sammanhang att "källa" komponent stöds av "sjunka" komponent. Dessutom, om antingen "stöd" eller "processer" sedan anslutningen automatiskt väljas i anslutningarna för att få sina kostnader tillskrivs "längs" från diskhon komponenten till källkomponenten.
Kosta | % | 100,0 | % | Decimal | Falsk | Anger hur stor andel av diskhon komponenter kostnader som ska hänföras till källkomponenten. De% värdena behöver inte lägga till upp till 100% och det är helt enkelt för att skala "Total Cost att äga -. Nästa x år" egendom (se ovan) från diskhon komponenten som det tillskrivs till källkomponenten.

Arkitektur Egenskaper

Följande tabell visar arkitekturen egenskaper som matas ut från TCO utvärderare. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Kostnad Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och kostnaden simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Notera

Se anmärkning ovan om en eventuell avrundning utgångsegenskaper.

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Kosta | Totalkostnad att äga - nästa x år. | $ | Heltal | Falsk | Den totala kostnaden för ägandet av hela arkitekturen under de kommande x åren.

Följande tabell visar arkitekturen egenskaper som matas ut från TCO utvärderarenOm Beräkna Per-Year Kostnader alternativ väljs. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Kostnad Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och kostnaden simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Notera

Se anmärkning ovan om en eventuell avrundning utgångsegenskaper.

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Kosta | Totalkostnad att äga - årx. | $ | Heltal | Falsk | Den totala ägandekostnaden för hela arkitekturen för år xin i framtiden.


Simulera Tillförlitlighet och tillgänglighet

Navigering: Simulering din arkitektur> Simulatorer>

Simulera Tillförlitlighet och tillgänglighet

Skicka kommentarer om detta ämne.

Bakgrund

Tillförlitligheten Utvärderings beräknar tillförlitlig av arkitekturen genom att använda de ingående komponenter och anslutningar.

För komponenter och direkta förbindelser, är tillförlitligheten bygger på Mean Time Between Failure (MTBF). De enda variablerna behövs för att beräkna tillförlitligheten arkitektoniska element är:

· De MTBFvärde (i år);

· De Mean Time To Repair (MTTR)ett misslyckande (i år); och

· Den definierad tidsperiod för att testa Tillförlitlighet över.

Den formel som används vid beräkningen av Tillförlitligheten anges som:

Tillförlitlighet = -e (-y × ålder)
Där y = 1 ÷ MTBF

Tillgängligheten av komponenter och anslutningar är baserad på MTBF och MTTR. Notera att tillgänglighet, till skillnad från tillförlitlighet, är opåverkad av den tidsperiod för vilken den håller på att testas.

Tillgänglighet = MTBF / (MTBF + MTTR)

Även metoder som omvandlar Tillförlitlighet blockdiagram(med hjälp av enkla serie- och parallell konstruktioner) ge de mest exakta resultat, dessa metoder blir mycket impraktiskt när vi försöker beräkna tillförlitligheten för uppdrag inom stora nätverk av tusentals element. Dessutom är dessa transformerande metoder bryta ner många gemensamma strukturer, till exempel nätverks "maskor".

De Monte Carlometod tillåter tillförlitligheten och tillgängligheten av ett system med godtycklig storlek och komplexitet kan beräknas. Monte Carlo-metoden simulerar många scenarier och feller varje scenario en slumpmässig tillstånd, tillgängliga eller inte tillgänglig, Tilldelas varje fysisk element. Sannolikheten för ett visst ämne är i ett tillgängligt tillstånd är baserad på tillförlitlighet / tillgänglighet av komponenten.

Exempelvis kan förväntas en komponent med 90% tillgänglighet för att finnas tillgängliga i ungefär 90% av scenarierna. Den indirekta anslutningens tillförlitlighet och tillgänglighet kan således uppskattas som andelen slump scenarios- som en väg av element finns i en tillgänglig uttalande från källa till destination.

Notera

Eftersom beräkningen av lokal tillförlitlighet och tillgänglighet är baserad på olika parametrar och olika formler (och således resulterar i olika värden), är det nödvändigt att tilldela varje element tvåstater, en för tillgänglighet, och en för tillförlitlighet. Beräkningen av tillgänglighet använder tillgängligheten tillstånd i varje scenario, medan beräkningen av tillförlitligheten använder tillförlitligheten i varje enskilt scenario.

Tillförlitligheten utvärderaren använder Monte Carlo-simulering teknik för att räkna ut tillförlitligheten hos en viss arkitektur. Arkitekturen har genomgått tusentals enskilda simuleringar och resultaten i tabellen för att få fram ett tillförlitlighetsmått. Som nämnts ovan, är Monte Carlo den snabbaste tekniken för att simulera större nätverk och fungerar med alla komplexa (dvs maskor) struktur.

Utvärderaren avger fyra värden:

1. Mission Tillförlitlighetunder ett antal år,

2. Tillgänglighet av arkitektur;

3. Pålitlighet av lokal komponentunder ett antal år, och

4. Tillgänglighet av lokal komponent.

Utvärderaren räknar ut sannolikheten för de komponent eller anslutning bearbetning (d.v.s. inte misslyckas) och den tid det tar att reparera.

Hur standarder med MTBFs och / eller MTTRs behandlas

Om ett element (komponent eller anslutning) har standard med tilldelad MTBF och / eller MTTR värden är dessa värden också används vid beräkningen av den lokala tillförlitlighet och tillgänglighet av ett element som en seriekoppling.

Till exempel, om en komponent A, Med tilldelade standarder B, C, och Dhar vardera en MTBF och en MTTR värde, Lokala Pålitlighet = R(A)× R(B) × R(C) × R(D), var R = Beräknad tillförlitlighet (med formel) av komponent / standarder och Lokal Nyttaförmåga = EN(A)× EN(B) × EN(C) × EN(D), var A = Beräknad nyttaförmåga (med formel) av komponent / standarder. Det är, om ett element har tre standarder varje med MTBF och MTTR värdesOch även MTBF och MTTR värdesför elementets egenskaper, den lokala tillförlitlighet och avilability ges som en serie värde på var och en av standarderna och själva elementet.

Som ett annat exempel, om en komponent Ahar tilldelats standarder B, C, och Dmen bara standard Bhar både en MTBF och MTTR värde, medan standard Char endast ett MTBF värde och standard Dhar endast ett MTTR värde, Lokala Pålitlighet = R (A)× R (B)× R (C), var R= Beräknad tillförlitlighet (med formel) av komponent / standarder och lokala Tillgänglighet = A (A)× A (B)× VÄXELSTRÖM), var A= Beräknad leveranstid (med hjälp av formel) av komponent / standarder men vid beräkning av A (C) eftersom standarden har endast ett MTBF värde den 'sökningar'efter det matcha MTTR värde (n) och kommer att lägga alla MTTR värden den finner att don't själva har ett matchande MTBF värde, så i det här fallet skulle använda MTTR värdet av standard D. Om det fanns en annan standard, säger E, Med bara ett MTTR värde samt då VÄXELSTRÖM)skulle använda MTBF på Cmed MTTR av D och Eadderas. Om en annan standard, säg FHade bara ett MTBF värde sedan A (F)skulle också använda MTTR av D och Eadderas.

Beräkning Mission Tillförlitlighet

Vid beräkning lokal tillförlitlighet är en fråga om att använda en enkel formel är beräkningen av indirekta anslutningar (uppdrag) inte så lätt, särskilt när vi har stora och komplexa nätverk av sammanflätade banor (anslutningar) och komponenter.

Med hela nätverket hänsyn

Eftersom de indirekta anslutningar inte representerar en fysisk anslutning, måste vi ta reda på hur källkomponenten kan komma till sin destination komponent. Och detta innebär att titta på hela nätverket och alla olika sätt (och stigar) vår källa komponent kan vidta för att nå destinationen komponent (sink).

Notera

Så länge som det finns minst en komplettväg från källa till destination, kommer uppdraget att lyckasoch indirekt anslutning benämnes en stängd anslutning.

Förstå Link Matrix

För att veta vilka komponenter / direktkoppling till vad vi behöver en artefakt att snabbt kontrollera om två block är anslutna i en viss riktning. Detta är funktionen hos länkmatrisen. I korthet är länken matrisen en tvådimensionell uppsättning av booleska variabler som anger om en viss komponent kan nå en annan komponent direkt. Dess storlek är lika med kvadraten av det totala antalet komponenter i nätverket.

En enkel tillförlitlighet Blockdiagram (RBD)

Relaterade Link Matrix för tillförlitlighet Blockdiagram (RBD)

Eftersom inte alla anslutningar är dubbelriktade (går i båda riktningarna), är det viktigt vet hur man läser länken matrisen korrekt. I tillförlitligheten utvärderaren är det första argumentet källan och det andra argumentet är destinationen (sink).

Därför, om länk matris (A, B) = sant då betyder det att A kan få B direkt (enkelriktad). B kan komma till A om endast om länk matris (B, A) = sant. Om detta är sant, innebär detta en dubbelriktad anslutning.

I det givna exemplet ovan:

· Källa 1 kan nå destinationen 0 (Källa 1 och Destination 0 ger ett resultat av True); och

· Källa 0 kan nå mål 1 (Källa 0 och Destination 1 ger ett resultat av True), som en länk mellan 0 och 1 är dubbelriktad.

· Källa 2 kan inte nå destinationen 1 (Källa 2 och Mål 1 ger ett resultat av False) även när källan 1 kan nå mål 2 (Källa 1 och mottagare 2 ger ett resultat av True). Detta är innebär att kopplingen mellan 1 och 2 är enkelriktad.

Förstå Tillförlitlighet Blockschema

Tillförlitligheten blockdiagram (RBD) sammanfattar strukturen av hela objektmodellen i form av block och länkar. Varje block representerar ett element som har en möjlighet för misslyckande eller framgång enligt länkar / vägar som förbinder dem. Både komponenter och anslutningar kan bli en "block" i RBD.

Exempel RBD Block och länkar

Figuren ovan utgör ett RBD exempel. Den streckade röda linjen representerar ett enda uppdrag 4 till 1. Notera hur det finns bara två möjliga vägar för uppdraget 4-1.

Tänk på väg 4-3 med 0 till 1, och vägen 4-7 till 1. De streckade blocken 2, 5och 6 representerar block som inte påverkar misslyckandet / icke-misslyckande uppdrag 4 till 1. De är inte beaktas och ignoreras. Detta är viktigt eftersom för de flesta uppdrag kommer det att finnas ett stort antal redundanta block som inte kommer att påverka ett särskilt uppdrag framgång. Detta är mer tydligt i större nät varigenom antalet redundanta block kommer att göra simuleringsresultaten felaktig.

För att påskynda simulering tid och se mer exakta resultat, är det nödvändigt att bortse från hela RBD och använd endast de faktorer som påverkar ett uppdrag framgång.

Notera

En enda väg / sökväg kan inte gå igenom någon komponent två gånger.

I detta skede kan vi skapa en länk matris och utföra en Monte Carlo-simulering.

Beräkning Arkitektur Tillgänglighet

Arkitekturen tillgänglighet är sannolikheten att alla indirekta anslutningar kommer att finnas tillgängliga vid varje tidpunkt. Tillgängligheten av varje indirekt förbindelse bestäms under varje iteration av Monte Carlo-simulering, men dessa indirekta anslutningar (typiskt) är beroende av samma uppsättning av fysiska element. Därför, helt enkelt aggregera dessa enskilda tillgången skulle "dubbelräkning" dessa un-tillgången, vilket ger en pessimistisk övergripande arkitektur tillgänglighet. Alternativt är den övergripande strukturen tillgängligheten beräknas genom att titta på varje iteration och se om de element som ingår i de indirekta anslutningar av intresse föreligger. Och sedan aggregera dessa resultat i slutet av simuleringen.

Köra Tillförlitlighet simulator

För att simulera din arkitektur i fråga om tillförlitlighet

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Välj Analys| Pålitlighet.

3. Välj Arkitekturdu vill från rullgardinsmenyn för att utvärdera.

Notera

Som standard kommer ABACUS automatiskt välja den första arkitektur för vilken en ny simulering krävs på grund av någon underliggande egendom eller strukturella förändringar.Denna markering visas i Röd på Simulering verktygsfält .

4. Välj Ingående delar och Anslutningardu vill från att utvärdera Fönstret för val standardelement med hjälp av "Visa direkta förbindelser" och "Visa processer Anslutningar" radio-knappen filter i nedre vänstra hörnet av dialogrutan för att underlätta med dig val.

Ytterligare Kryssruta till Fönstret för val standardelement

· Save Transformerad Modell vilja spara en kopia av RBD transformerade versionen av projektet i samma mapp som det aktuella projektet och lägga "_transformed" till projektnamnet.Denna transformerade projektet kan användas för att diagnostisera i detalj tillförlitlig simulering utförs av ABACUS.

Ytterligare Radio-Knappar till Fönstret för val standardelement

· Visa direkta förbindelser automatiskt ställa in en anslutning har egendom filter för fastighets Typ = Beteende, Name = abstraktion och värde = direkt.Det här alternativet är valt som standard och hjälper valet av direkta "anslutningar som beskrivits ovan och nedan.

· Visa processer Anslutningar automatiskt ställa in en anslutning har egendom filter för fastighets Typ = Beteende, Namn = Förhållande och värde = processer.Detta alternativ underlättar valet av de kallade direkta anslutningar såsom beskrivits ovan och nedan.

5. Klick Nästa.

6. Välj den Uppdragdvs. anslutningar du vill inkludera i simuleringen.

7. Ställ Speltid Skalfaktorreglaget.

Notera

Högre värden kommer att ge mer statistiskt konsekventa resultat, men tar längre tid att beräkna.

Kryssrutor

· Show Slutna Anslutningar vilja automatiskt filtrera tillgängliga anslutningar endast omfatta dem som har minst en fullständig fysisk väg från källkomponenten till destinationen komponenten enligt den RBD val som beskrivits ovan.

· Visa Indirekta Anslutningar automatiskt ställa in en anslutning har egendom filter för fastighets Typ = Beteende, Name = abstraktion och värde = indirekt.Det här alternativet är valt som standard och hjälper valet av "indirekta" eller Mission anslutningar som beskrivs ovan och nedan.

Knappar

· Allamarkeras all anslutningar.

· Inverteraavmarkerar alla markerade anslutningar och väljer alla dem som inte valdes ut.

· Ingenavmarkerar alla anslutningar.

Andra alternativ

· Speltid Skalfaktor styr tiden simulering och noggrannhet med högre värden utbyteIngmer statistiskt tillförlitliga resultat, men tagande längre tid till springa.

Notera

När ABACUS beräknar antalet iterationer för att simulera det kommer att avgöra den mest pålitliga element som inte är helt tillförlitlig och sedan simulera för Speltid Scale Factor gånger 1 över avsaknaden av detta element plus en iteration. Eller (MTBF + MTTR) / MTTR * Speltid Skalfaktor + 1. Detta är att se till att denna del fortfarande inte åtminstone en gång i simuleringen. T.ex. Om den mest pålitliga element som inte är helt tillförlitlig har ett MTBF 10.000 timmar och en MTTR 8 timmar sedan simuleringen tar (10.000 + 8) / 8 = 1251 gånger Gångtid skalfaktor + 1 iterationer.

· År för att simulera Ahead bestämmer antalet år för uppdraget Tillförlitlighet ska beräknas för.

· Numbra av trådardetermines antalet bearbetnings trådar som ska användas för Monte-Carlo-simulering.Det här alternativet som standard för att matcha antalet tillgängliga processorer / kärnor (inklusive hypergängkärnor) att minimera den totala simuleringstiden.

8. Klick Avslutaoch du kommer att få en Varning dialog.

9. Eventuellt utforska varningar genom att klicka Detaljer >>.

10. Klick Fortsätt.

Notera

Vid denna punkt, kommer ABACUS utföra en Monte Carlosimulering av arkitekturen och efter en kort tid (med förloppsindikatorer för återkoppling) en beräkning komplett dialogruta visas.

11. Klick okatt erkänna simuleringen.

Dricks

För utbildningar och ytterligare hjälp på Tillförlitlighet Simulering hänvisas till Avolution gemenskapen .

Egenskaper komponent- och anslutnings

Följande tabell visar komponenten och 'direkt'anslutningsegenskaper som krävs för att utvärdera tillförlitligheten. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighetsinmatningsraden väljare ( [image] ) Med verktygstipset "Tillförlitlighet Input". En förändring i någon av dessa "input" egenskaper och olika strukturella förändringar förvaret kommer att resultera i tillförlitlighet simulator som kräver en re-simulering som anges i Röd på Simulering verktygsfält .

Typ | Namn | Standardvärde | Enhet | Data typ | Nödvändig | Beskrivning
Pålitlighet | MTBF | ∞ | år, veckor, dagar eller timmar | Decimal | Sann | Mean Time Före Fel i elementet. Obs! Värden kan uttryckas i enheter av år, veckor, dagar eller timmar och omvandlas efter en '24 / 7 'tillgänglighet koncept enligt följande; - 1 år = 52 veckor eller 365 dagar eller 8760 timmar - 1 vecka = 7 dagar eller 168 timmar - 1 dag = 24 timmar
Pålitlighet | MTTR | 0 | år, veckor, dagar eller timmar | Decimal | Sann | Mean Time To Repair av elementet. Obs! Värden kan uttryckas i enheter av år, veckor, dagar eller timmar och omvandlas efter en '24 / 7 'tillgänglighet koncept enligt följande; - 1 år = 52 veckor eller 365 dagar eller 8760 timmar - 1 vecka = 7 dagar eller 168 timmar - 1 dag = 24 timmar

Följande tabell visar komponenten och 'direkt' anslutningsegenskaper utgång av tillförlitlighet utvärderaren. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Tillförlitlighet Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och tillförlitlighet simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Pålitlighet | Tillförlitlighet - x år |  | Decimal | Falsk | Sannolikheten att elementet inte kommer att misslyckas inom de närmaste x år. Detta är ett värde mellan 0 och 1.
Pålitlighet | Opålitlighet - x år |  | Decimal | Falsk | Sannolikheten att elementet kommer att misslyckas inom de närmaste x år. Detta är ett värde mellan 0 och 1.
Pålitlighet | Tillgänglighet | % | Decimal | Falsk | Den beräknade tillgängligheten av komponenten eller anslutningen. Detta är ett värde mellan 0% och 100%.
Pålitlighet | Otillgänglighet | % | Decimal | Falsk | Den beräknade avsaknad av komponenten eller anslutning. Detta är ett värde mellan 0% och 100%.

Följande tabell listar 'indirekt'anslutningsegenskaper utgång av tillförlitlighet utvärderaren. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Tillförlitlighet Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och tillförlitlighet simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Pålitlighet | Mission Tillförlitlighet - x år |  | Decimal | Falsk | Sannolikheten att indirekt anslutning inte kommer att misslyckas inom de närmaste x år. Detta är ett värde mellan 0 och 1.
Pålitlighet | Mission Opålitlighet - x år |  | Decimal | Falsk | Sannolikheten för att indirekt anslutning kommer att misslyckas inom de närmaste x år. Detta är ett värde mellan 0 och 1.
Pålitlighet | Tillgänglighet | % | Decimal | Falsk | Den beräknade tillgängligheten på indirekt anslutning. Detta är ett värde mellan 0% och 100%.
Pålitlighet | Otillgänglighet | % | Decimal | Falsk | Den beräknade avsaknad av indirekt anslutning. Detta är ett värde mellan 0% och 100%.

Arkitektur Egenskaper

Följande tabell visar arkitekturen egenskaper utgång av tillförlitlighet utvärderaren. Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Tillförlitlighet Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde eller strukturell förändring till slutförvaret och tillförlitlighet simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Enhet | Data typ | Nödvändig | Beskrivning
Pålitlighet | Tillgänglighet | % | Decimal | Falsk | Tillgången till alla indirekta anslutningar som har ingått i utvärderingen. Det vill säga, sannolikheten att allaindirekta anslutningar kommer att finnas tillgängliga vid en given tidpunkt. Detta är ett värde mellan 0% och 100%. Obs: Detta är inte multiplikation av de enskilda anslutnings tillgången som detta skulle vara "dubbelräkning" FN-tillgängligheten för de relevanta komponenter.
Pålitlighet | Otillgänglighet | % | Decimal | Falsk | Avsaknad av de indirekta anslutningar som har ingått i utvärderingen. Det vill säga, sannolikheten att minst enindirekt anslutning kommer att vara otillgänglig vid en given tidpunkt. Detta är ett värde mellan 0% och 100%. Obs: Detta är inte multiplikation av de enskilda anslutnings unavailabilities som detta skulle vara "dubbelräkning" FN-tillgängligheten för de relevanta komponenter.
Pålitlighet | Mission Tillförlitlighet - x år |  | Decimal | Falsk | Sannolikheten att alla indirekta anslutningar som har ingått i utvärderingen kommer att inte misslyckas inom de närmaste xår. Detta är ett värde mellan 0 och 1. Obs: Detta är inte multiplikation av de enskilda anslutningstillförlitlig som detta skulle vara "dubbelräkning" FN-tillgängligheten för de relevanta komponenter.
Pålitlighet | Mission Opålitlighet - x år |  | Decimal | Falsk | Sannolikheten att åtminstone en av de indirekta anslutningar som har inkluderats i utvärderingen kommer att misslyckas inom de närmaste xår. Detta är ett värde mellan 0 och 1. Obs: Detta är inte multiplikation av de enskilda anslutnings unreliabilities som detta skulle vara "dubbelräkning" FN-tillgängligheten för de relevanta komponenter.


Simulera Öppenhet

Navigering: Simulering din arkitektur> Simulatorer>

Simulera Öppenhet

Skicka kommentarer om detta ämne.

Öppenheten simulator bestämmer i vilken grad en arkitektur och dess delar är "öppna", det vill säga systemets förmåga att hantera utbyte av komponenter med minimal påverkan.

För att simulera din arkitektur när det gäller öppenhet

1. Se till att du har ABACUS filSom innehåller dina befolkade arkitektur, öppna.

2. Välj Analys | Öppenhet.

3. Välj den Arkitektur (er)du vill inkludera i utvärderingen.

Notera

Som standard kommer ABACUS automatiskt välja den första arkitektur för vilken en ny simulering krävs på grund av någon underliggande egendom eller strukturella förändringar.Denna markering visas i Röd på Simulering verktygsfält .

4. Klick Avslutaoch du kommer att få en Varning dialog.

5. Eventuellt utforska varningar genom att klicka Detaljer >>.

6. Klick Fortsätt.

Notera

Vid denna punkt, kommer ABACUS utföra en strukturell utvärdering av arkitektur (er) och efter en kort tid (med förloppsindikatorer för återkoppling) en beräkning komplett dialogruta visas.

7. Klick okatt erkänna simuleringen.

Dricks

För kurser och ytterligare hjälp om offentlighet Utvärdering hänvisas till Avolution gemenskapen .

Komponent och anslutning Standard Egenskaper

Följande tabell visar komponent och anslutnings standard egenskaper som krävs för att utvärdera öppenhet.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighetsinmatningsraden väljare ( [image] ) Med verktygstipset "Öppenhet Input". En förändring i någon av dessa "input" egenskaper i förvaret kommer att resultera i Öppenhet simulator som kräver en re-simulering som anges i Röd på Simulering verktygsfält .

Typ | Namn | Standardvärde | Enhet | Data typ | Nödvändig | Beskrivning
Öppenhet | Standard Standard Löptid-Organisation Level |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Nivå ansvarar standardiseringsorgan 0:Organisations / Proprietary 1:Consortium / Defacto 2:Nationella / Military 3: Internationell
Öppenhet | Standard Standard Löptid uppföljnings |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Godkännande nivå uppnås med standardiseringsorgan 0:Working / kommittén Utkast 1:Offentlig Utkast / röstas 2:Interims Utkast 3: Godkänd
Öppenhet | Standard Standard Löptid-stabilitet |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Är standarden sannolikt kommer att förändras? 0:Standard föråldrade 1:Mycket komma att ändras i nästa 1 till 2 år 2:Kända förändring / uppdateringar av befintliga funktioner 3:Mycket stabil (ingen förändring inom 2 år)
Öppenhet | Standard Standard Löptid-Vendor Support |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Vendor Support 0:Inga produkter eller leverantörer stödjer standarden 1:En eller flera leverantörer som implementerar en del av standarden 2:Mer än en leverantör med produkter som implementerar alla delar av standarden 3:Många fler än en leverantör med produkter som implementerar alla delar av standarden
Öppenhet | Standard Standard samtycket uttryckligen-Dokumentation |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Kvaliteten på standarddokumentation 0: Fattig 1: Rättvis 2: Bra 3: Excellent
Öppenhet | Standard Standard samtycket uttryckligen-Standard Bredd |  |  | Heltal | Falsk | Antal funktioner. En räkning av de lägsta nivå standardfunktioner - Sf
Öppenhet | Standard Standard samtycket uttryckligen-Sm |  | % | Decimal | Falsk | Andel av totalt antal funktioner som är obligatoriska
Öppenhet | Standard Standard samtycket uttryckligen-So |  | % | Decimal | Falsk | Andel av totalt antal funktioner som är valfria
Öppenhet | Standard Standard samtycket uttryckligen-Sc |  | % | Decimal | Falsk | Andel av totalt antal funktioner som villkorligt definieras
Öppenhet | Profiler-profil Dokumentation-Dokumentation |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Kvaliteten på standarddokumentation 0: Ingen 1: Fattig 2: Rättvis 3: Excellent
Öppenhet | Profiler-profil Dokumentation-Noggrannhet |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Har dokumentation spegla den faktiska systemkonstruktion? Vilken nivå av profil funktioner används i systemet? 0:Inga funktioner 1:Vissa funktioner 2:De flesta funktionerna 3:Alla funktioner
Öppenhet | Profiler-profil Dokumentation förfall |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Är profilen mogna och tillgängliga? 0: Ad hoc 1:Projektbaserad 2:Organisations 3: Offentlig
Öppenhet | Profiler-profil samtycket uttryckligen-Explicit Bredd |  |  | Heltal | Falsk | Antal standardfunktioner som anges enligt kraven i profilen
Öppenhet | Profiler-profil samtycket uttryckligen-Pm |  | % | Decimal | Falsk | Andel av obligatoriska funktioner i profilen
Öppenhet | Profiler-profil samtycket uttryckligen-Po |  | % | Decimal | Falsk | Andel av valfria funktioner i profil
Öppenhet | Profiler-profil samtycket uttryckligen-Pc |  | % | Decimal | Falsk | Andel av villkorligt DEFINIERAD funktioner i profilen
Öppenhet | Profiler-profil samtycket uttryckligen-Täckning |  | % | Decimal | Falsk | Andel av standardfunktioner som särskilt riktar sig i profilen
Öppenhet | Profiler-Profil Extensions-Förlängnings Bredd |  |  | Heltal | Falsk | Antal icke-standardiserade funktioner som anges av profilen
Öppenhet | Profiler-profil Extensions-Täckning |  | % | Decimal | Falsk | Andel av förlängningar som beskrivs i profilen
Öppenhet | Produkter-Product Tillgänglighet och Uppfyllda-nummer Produkt |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Antal produkter som stöder de obligatoriska funktioner i standard 0:Inga produkter stödjer standarden 1:En eller flera produkter implementera en del av standarden 2:Mer än en produkt genomför alla delar av standarden 3:Många fler än en produkt genomför alla delar av standarden
Öppenhet | Produkter-Product Tillgänglighet och Uppfyllda-Application överensstämmelse |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Vilken nivå av överensstämmelse behöver produkter har standarden? 0: Ingen 1:Hävdade 2:Dokumenterad 3:Certifierade och Dokumenterad
Öppenhet | Produkter-Product Tillgänglighet och Uppfyllda-överensstämmelse Kvalitet |  | [0 | 1 | 2 | 3] | Lookup / Lista | Falsk | Kvaliteten på överensstämmelse testning 0: Ingen 1:Egen testning av produktutvecklare 2:Oberoende tester (t ex NIST) 3:Visats i samband med relevanta produkt

Komponent, anslutning och arkitektur Properties

Följande tabell visar komponenten, anslutning och arkitektur egenskaper utgång av öppenhet utvärderaren. Alla följande egenskaper utvärderas till mellan noll (0) och tre (3), noll (0) är den minst önskvärda och tre (3) är den mest önskvärda.Dessa egenskaper kommer att visas i fönstret Egenskaper med en ikon fastighets utmatningsrad väljare ( [image] ) Med verktygstipset "Öppenhet Output". Pilen på ikonen kommer att belysa Röd ( [image] ) När dessa egenskaper är inaktuell på grund av ett underliggande fastighetsvärde ändring av databasen och offentlighet simulatorn kräver re-simulering enligt Röd markera på Simulering verktygsfält .

Typ | Namn | Data typ | Nödvändig | Beskrivning
Öppenhet | Öppenhet | Decimal | Falsk | Övergripande utvärdering av objektets öppenhet.
Öppenhet | Standard Standard Löptid | Decimal | Falsk | Det aktuella läget för standarden, reflekterande om det har godkänts, hur lång tid det har varit i bruk och hur väl accepterat det är inom gemenskapen av utvecklare.
Öppenhet | Standard Standard samtycket uttryckligen | Decimal | Falsk | Explicitn av normerna, vilket återspeglar den potentiella tvetydighet i efterföljande standarder
Öppenhet | Profiler-profil Dokumentation | Decimal | Falsk | I vilken utsträckning gränssnitt profil dokumentation utvecklas och huruvida profildokumentationen återspeglar faktiska systemkonstruktion och / eller implementerade systemet
Öppenhet | Profiler-Profile samtycket uttryckligen | Decimal | Falsk | Nivån på Detaljnivån i en profil / profil specifikation
Öppenhet | Profiler-Profil Extensions | Decimal | Falsk | Den grad i vilken profilen överensstämmer med den standard på vilken den är baserad
Öppenhet | Produkter-produkternas tillgänglighet och överensstämmelse | Decimal | Falsk | Huruvida det finns öppna standard överensstämmande produkter tillgängliga för användning i projektet


Standardrapporter

Navigering: Rapportering om din arkitektur>

Standardrapporter

Skicka kommentarer om detta ämne.

KULRAM' standard- rapporter kan du få en lista över de komponenter och anslutningar i en eller flera av dina arkitekturer. Rapporten innehåller all information om de komponenter och anslutningar utvalda, inklusive information om komponenten eller anslutningens plats i hierarkin, typ, standarder, beskrivning, egenskaper och dess bilagor.

Notera

Innehåll Rapporten ärkonfigurerbargenom dialog Rapportalternativ den beskrivs nedan, dock to Se ytterligare information om hur du skapar helt konfigurerbar anpassade rapporteranvändning ABACUS anpassade rapporter, snälla du finns i avsnittet här eller kontakta Avolution Stöd .

Om du vill visa en standard- rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur(s).

2. Välj Föra in| Standardrapporteller klicka på Skapa standardrapport knapp i verktygsfältet. De Rapportera Konfigurationfönstret visas.

Rapport konfigurationsfönstret

3. Välj Arkitekturer, Ingående delar och Anslutningarsom du vill ha i rapporten från Rapportera inställningsfönster.Se Standard Element Selection här ämne för hjälp.

4. Klicka nu på Valknappen och Rapportalternativfönstret visas.

Rapport Fönstret Alternativ

5. Du kan välja att visa en Ny sida för varje element, de Skriv datum, Utskrifts Tid, Sidnummeroch om inkludera titel i sidhuvudetav rapporten genom att kryssa i / ur de relevanta kryssrutor. Du kanske också vill anpassa titeln och författare genom att redigera Rapportrubrik och Författare textrutor. Du kan också välja vilket innehåll som ska visas i rapporten genom att kryssa i / ur kryssrutorna under Rapportera innehålldelen av fönstret. När du är klar klickar du på ok.

6. Klicka nu på Avslutai rapporten konfigurationsfönstret.

Att tolka den synliga rapport

Exempel genererade rapporten med korta förklaringar

Navigera igenom rapportblad, klicka på ikonerna [image] beläget i verktygsfältet på den övre vänstra hörnet av skärmen.

Notera

Du kan spara rapporten till olika format genom att klicka på Exportera rapport ikon [image] belägen i verktygsfältet. Du kan välja att exportera i följande format: Excel, PDF och Ord. Spara rapporten på önskad plats för senare användning. Om ändringar görs i arkitekturen i ett senare skede kommer en ny rapport måste skapas för att återspegla ändringarna.

Se också

Analysera din arkitektur


Anpassade rapporter

Navigering: Rapportering om din arkitektur>

Anpassade rapporter

Skicka kommentarer om detta ämne.

ABACUS "anpassade rapporter kan du skapa helt konfigurerbara anpassade rapporter. Rapporterna kan innehålla anpassade bilder och grafik samt specificera alla komponenter, anslutningar eller attribut från en kulram förvar samt detaljerade analysresultat från olika simuleringar (inklusive TCO, prestanda och tillförlitlighet). Dessutom kan rapporter innehålla diagram, tabeller, kataloger, matriser / pivottabeller, kartor, mätare, miniatyr, barer data och indikatorer (t.ex. trafikljusen).

Notera

Även om alla användare kan öppna befintliga anpassade rapporter, to configure rapporter användarlicens behöver Rapportera Konfiguration förmåga. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

Om du vill visa en beställnings- rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur(s).

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporterfönstret visas.

Anpassade rapporter fönster

3. Välj existerande Rapporterasom du vill att visa från Tillgängliga rapporter avsnitt.

4. Klick Kör rapport.Rapporten kommer att öppnas i Microsoft Report Viewer och to Navigera igenom rapportblad, klicka på ikonerna [image] beläget i verktygsfältet på den övre vänstra hörnet av skärmen.

Notera

Du kan spara rapporten till olika format genom att klicka på Exportera rapport ikon [image] belägen i verktygsfältet. Du kan välja att exportera i följande format: Excel, PDF och Ord. Spara rapporten på önskad plats för senare användning. Om ändringar görs i arkitekturen i ett senare skede kommer en ny rapport måste skapas för att återspegla ändringarna.

Till redigera datalager som skickas till a beställnings- rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur(s).

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporter fönster (visas ovan) kommer att visas.

Notera

Även om alla användare kan öppna befintliga anpassade rapporter, to configure de data som skickas till en anpassad rapport användarlicens behöver Rapportera Konfiguration förmåga. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

3. Välj existerande Rapporterasom du vill att visa från Tillgängliga rapporter avsnitt.

4. Klick Redigera datamängder. De Data Set Editorfönstret visas.Detta fönster visar insamling av datamängder som håller på att skickas till en anpassad rapport. I exemplet nedan finns det tre (3);

· en ApplicationProxy datamängd som specificerar alla detaljer för alla programkomponenter i "2015 Verklig" arkitektur (inklusive fastigheter på sina standarder och alla anslutna komponenter),

· en TwoDViewProxy datamängd som specificerar en eller flera diagram där namnet matchar "Application Landskap (Australien),

· en TargetProxy datamängd som specificerar alla detaljer för alla Target anslutningar i "2015 Faktisk" arkitektur (inklusive bifogade komponenterna).

Data Set Editor fönster

Notera

Fråge namn kommer att användas för Dataset namn i Microsoft Report Builder (se nedan). Inkludera fältet anger om datamängden är antingen ett enda element, en samling av element, alla komponenttyper, alla anslutningstyper, en eller flera arkitekturer, en eller flera diagram eller en eller flera Diagram. För "samling av element" dataset en knappen Filter tillhandahålls som när du klickar på öppnar Filterfönster Element som låter dig använda flera filter för att återvända endast element från vissa arkitekturer, och / eller vissa typer, och / eller med vissa standarder , och / eller kopplade till vissa komponenter, och / eller med vissa föräldrar, och / eller i vissa diagram, och / eller i vissa diagram och / eller med givna Fastigheternas värde. För övriga uppgifter set skriver ett namn fält tillhandahålls och använder knappen Välj kan du välja objektet (s) som ska ingå i datamängden.

Notera

De datamängder lagras i enData Ställer fil (.xml)med samma namn basfilen som en associerad Rapportera Definition-fil (.RDL). Om det inte finns den här filen datamängden editorn automatiskt fylla med alla frågenamn som finns i Rapportera Definition-fil (.RDL)och en ny Data Ställer fil (.xml)kommer skapas när aa giltig lista av frågor definieras.

3. Om du vill ta bort en befintlig datauppsättning välj sedan Radera Query knapp.

4. Om du vill lägga till en ny datauppsättning och klicka sedan på Lägg till ny Data Setknappen och konfigurera datamängden enligt anmärkningen ovan.

Till skapa en ny anpassad rapportera(från en mall)

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur.

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporter fönster (visas ovan) kommer att visas.

3. Klick Ny och välj antingen A4 - Porträtt, A4- Landskap, A3 - Porträtt, A3- Landskap, US Letter - Porträtt, US Letter - Landskap, US Tabloid - Porträtt eller US Tabloid - Landskapberoende på rapporten orientering och pappersstorlek som önskas.

4. Bläddra till den plats du vill spara rapporten Definition-filen (RDL / .rdlc) och matchande Data Set-fil (.xml) och klicka på Spara. Detta kommer att lägga till en ny anpassad rapport till Available avsnittet Rapporter i Anpassade rapporter fönstret och det kan öppnas eller redigeras som beskrivits ovan.

Till lägga till en befintlig anpassad rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur.

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporter fönster (visas ovan) kommer att visas.

3. Klick Lägg till och bläddra till platsen av rapporten Definition-filen (RDL / .rdlc) och klicka på Öppna. Detta kommer att lägga till en ny anpassad rapport till Available avsnittet Rapporter i Anpassade rapporter fönstret och det kan öppnas eller redigeras som beskrivits ovan.

Notera

Det antas att ett matchande datauppsättning fil (.xml) finns på samma plats som rapporten Definition-filen.

Till kopiera en befintlig anpassad rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur.

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporter fönster (visas ovan) kommer att visas.

3. Välj existerande Rapporterasom du vill att kopiera från Tillgängliga rapporter avsnitt.

4. Klick Kopiera och en kopia av den valda rapporten (som heter "Kopia av ...") kommer att läggas till den tillgängliga avsnittet Rapporter i Anpassade rapporter fönstret och det kan öppnas eller redigeras som beskrivits ovan.

Notera

Genom att göra detta kommer du att skapa en kopia av rapportens Rapportera Definition fil (RDL / .rdlc) såväl som dess matcha Data Set-fil (.xml)(om den finns).

Till ta bort en befintlig anpassad rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur.

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporter fönster (visas ovan) kommer att visas.

3. Välj existerande Rapporterasom du vill att ta bort från Tillgängliga rapportersektion och klicka Avlägsna.

Notera

När du tar bort en rapport som den kommer inte längre att visas på rapportlistan. Men detta kommer inte att radera Rapporten rapport Definition fil (RDL / .rdlc) eller Data Set fil(.xml). Om det behövs, ta bort dessa filer kan uppnås genom filsystemet.

Till byta namn på en befintlig anpassad rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur.

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporter fönster (visas ovan) kommer att visas.

3. Välj existerande Rapporterasom du vill att byta namn på de Tillgängliga rapportersektion och klicka Döpa om.

4. Ange ett nytt namn för rapporten.

Notera

Både rapporten Definition-filen (RDL / .rdlc) och matchande Data Set-fil (.xml) kommer att döpas i enlighet.

Till redigera designen av en beställnings- rapportera

1. Se till att du har en ABACUS filen öppen innehåller din befolkade arkitektur.

2. Välj Föra in| Anpassad rapporteller klicka på Skapa anpassad rapport knapp i verktygsfältet. De Anpassade rapporter fönster (visas ovan) kommer att visas.

Notera

Även om alla användare kan öppna befintliga anpassade rapporter, to configure utformningen av en anpassade rapporter användarlicens behöver Rapportera Konfiguration förmåga. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.Dessutom är Microsoft Report Builder 3.0 som krävs för att utforma rapporter och det kan laddas ner gratis från här .

3. Välj existerande Rapporterasom du vill att visa från Tillgängliga rapporter avsnitt.

4. Klick Uppdatera.Rapporten kommer att öppnas i Microsoft Report Builder 3.0. För specifik hjälp och några tips och tricks "på några av de vanligaste uppgifterna med att utforma rapporter hänvisas till avsnitten nedan. För allmän hjälp med att designa rapporter var god hänvisa till Microsoft Report Builder 3.0 hjälpsidor här .

Lägga tabeller i rapporten

1. Se till att du har en kulram anpassad rapport Definition-fil (RDL / .rdlc) öppet i Microsoft Report Builder 3.0.

2. Välj de Föra in fliken i "band" högst upp, sedan Klicka på Tabell knappi dataområden sektionen och välj Insert Table.

3. Nu dra markörentill läget på rapport duk där du vill att övre vänstra hörnet i tabellen för att placeras. Klicka duken. Som standard tabellen kommer att läggas med en rubrikrad och sedan en mer grupp (en grupp används för att organisera en vy av en rapport dataset). För att ta bort gruppen, antingen ta bort raden eller radera radgrupp i Gruppering verktygsfältet.

Drickss

Formler / Uttryck i tabellceller redigeras genom att markera cellen sedan högerklicka på << Expr >> text och välja Expression .... Sortera rader i en tabell görs genom att välja bordet och sedan bläddra ner till den Andre -> SortExpressions fältet i panelen Egenskaper och ange ett uttryck. För en total rad i slutet av en tabell lägga till en rad efter (och utanför) grupperingen och sedan använda följande uttryck = Sum (Fields!Namn.Värde)där "Name" är det område som summeras. Om du vill använda färg kolumner använda en "IIF uttalande i fastigheten Back. Om du vill lägga till en mätare som en cell i en tabell först sätta mätaren i en cell och sedan släppa datafält som krävs för mätaren. När du redigerar höjden och bredden av tabellrader, se till att du väljer rätt rad, och sedan muspekaren runt grå linjer tills du får Pil upp / ner markören sedan ändra storlek.

Lägga diagram i rapporten

1. Se till att du har en kulram anpassad rapport Definition-fil (RDL / .rdlc) öppet i Microsoft Report Builder 3.0.

2. Välj de Föra in fliken i "band" högst upp, sedan Klicka på Diagram knappi dataområden sektionen och välj Infoga diagram.

3. Nu dra markörentill läget på rapport duk där du vill att övre vänstra hörnet av diagrammet placeras. Klicka duken och då markera diagrammetdu behöver från alternativen och klicka ok.

Drickss

För att visa en egenskap som en anteckning på diagram, högerklicka på diagrammet och välj Visa dataetiketter och välj sedan en av de etiketter som har lagts och ställ in Diverse -> UseValueAsLabel till False i panelen Egenskaper och lägg till uttryck (t.ex. = Fält Name.Value) i Övrigt -> Label. Specifikt för bubbeldiagram; Bubbeldiagram visas under punktdiagram rubriken. Släpp X-axeln egendom i serie fält (eller lägg i Serie Properties). Drop Y-axeln egendom i datafälten (eller lägg i Serie Properties). Om du vill använda en egenskap för att definiera bubbelstorleken, släppa detta till Datafält (eller lägg i Serie Properties). Bubbeldiagram är oförmögna att visa om det är för mycket data (200 + objekt), ibland gör att hela rapporten att inte visa. Marker Typ - Ställ in cirkel. Som standard när släppa fält i datafälten, lägger dem med belopp()formel, så ta bort denna. Specifikt för Staplade diagram / Sök / Ganttscheman; För ett Gantt-schema använda en rad diagram och lägga till egenskaper som höga och låga värden i datafälten. Du kan ha flera "barer" genom att lägga till fler och fler intervall där Lågt värde för en matchar det höga värdet för en annan. Specifikt för Cirkeldiagram; För aggregerade cirkeldiagram, släppa data till Kategori fält och i datafälten, lägger till formeln = CountRows (). Filtrera ut alla 0 värden (t.ex. på kostnads ​​diagram), kommer annars etiketter för dessa fortfarande visas på sjökortet.

Använda en Oom uttalande att lägga till färger till tabeller och diagram

1. Se till att du har en kulram anpassad rapport Definition-fil (RDL / .rdlc) öppet i Microsoft Report Builder 3.0.

2. Högerklicka på cellen i tabellen för att färga och klicka Text Box Egenskaper.

3. Välj Fylla och klicka på fxknappen till höger om fyllningsfärg etiketten och i inställnings ett uttryck för Back fältet anger ett uttryck, t.ex. = IIF (Fields! InformationStatus.Value = "Behåll", "ljusgrön", IIF (Fields! InformationStatus.Value = "Redesign", "Yellow", IIF (Fields! InformationStatus.Value = "Uppdatera", "Orange", " Lax"))). Detta ändrar bakgrundsfärgen till ljusgrön för varje cell som innehåller Status "Behåll", gult för varje cell som innehåller Status "Redesign", Orange för varje cell som innehåller status "Uppdatera" och alla andra statusvärde kommer att färgas i "Salmon".

Notera

Färger kan läggas till för diagram genom att välja serien i diagrammet och sedan ställa in Utseende -> Färga egendom (eller bubbeldiagram Utseende -> Marker -> Färga äganderätt) till ett uttryck som liknar ovanstående exempel.

Saker att tänka på när man utformar anpassade rapporter

· Eftersom alla fastigheter utom Integer skickas som en sträng från ABACUS rapporten betraktaren om du vill göra några ansiktsuttryck "med dem (som klyftan en fastighet med en annan eller sortera) måste du konvertera dem till decimaler eller datum etc. För bakgrunds , Denna artikel är en bra referens. T.ex. = CDate (Fields! LifecycleEndDate.Value) Notera: Vänligen se till att rapporten språket är inställt på en-GB (som beskrivs nedan) för att acceptera dd / mm / yyyy som man förväntar mm / dd / yyyy som standard och följaktligen 31/7/2011 kommer att misslyckas konvertering. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields CostTotalCosttoOwnnext5years.Value!, 0)

· Om du upptäcker att du kämpar för att hålla alla tabeller och diagram på en sida, Finns det några huvudsakliga sätt att hantera dokumentet rymden:

· Sidbrytning - Se till att denna tabell inställningen är avstängd för varje bord som du vill vara på samma sida.

· Hålla ihop - Se här dukningen är sant för varje bord som du vill vara på samma sida.

· När du flyttar runt saker, är det lättare att zooma ut med hjälp av kontroll längst ned till höger på sidan och sedan flera väljer objekt och dra

· För bild rad i en tabell, se till att "Storlek" | "Storleks 'egenskapen är inställd på" Anpassa "annars kan bilden bli för stor, eller kommer det att vara dåligt sträckas.

· Till upprepa en rubrikrad av en tabell på varje sidai rapporten:

1. Öppna Avancerat läge i rutan grupperingar. (Klicka på pilen till höger om kolumngrupper och välj Avancerat läge.)

2. I området radgrupper (ej kolumngrupper), klicka på en statisk grupp, som belyser motsvarande text i Tablix. Klicka vidare varje Statisk grupp tills den markerar den vänstra kolumnrubriken. Detta är i allmänhet den första Statisk gruppen listas.

3. I fönstret Egenskaper, ställa in egenskapen RepeatOnNewPage till True.

4. Se till att fastigheten KeepWithGroup är inställd på After.

· Ändra språkinställningari Rapport egenskaper för att matcha dataformat du behöver, t.ex. sv-SE för att producera UK datumformat (dd / mm / åååå).

Se också

Analysera din arkitektur


Publicera på webben

Navigering: Rapportering om din arkitektur>

Publicera på webben

Skicka kommentarer om detta ämne.

ABACUS "Publicera till webben funktionen kan arkitektoniska modeller ses via en säker webbplats. Arkitekturer exporteras till HTML-format och är utformade för att återspegla utseendet och känslan av Utforskaren i ABACUS. Visningar (inklusive Kataloger, diagram, 3D och diagram) också exporteras till format kan visas med en webbläsare.

Notera

För närvarande är Synpunkter och Matriser inte offentliggjort.

Att publicera dina arkitektoniska modeller på webben

1. Se till att du har relevant ABACUS filöppen, som innehåller det befolkade arkitektursom du vill publicera på webben.

2. Välj Fil| Publicera....

3. De Publicera på webbkonfigurationfönstret visas.

Publicera på webben konfiguration

4. Som standard är alla de delar av modellen väljs inklusive Tree View, den Standarder, Typer, mallar och arkitektur (er). Avmarkera alla delar som du inte vill publicera på webben, inklusive eventuella individuella åsikter inom arkitektur (er).

Dricks

Om du vill dölja specifika komponenter, anslutningar och / eller deras egenskaper är det rekommenderat att en administratör skapar en "Public roll med hjälp av ABACUS 'rollbaserad åtkomst funktion och sedan avlägsnar Läs tillstånd från de komponenttyper, anslutningstyper och / eller egenskaper som de inte vill ska publiceras. Då en användare ska logga in under den rollen och publicera till webben som ABACUS kommer endast att publicera delar som har läsbehörighet in för rollen. Dessutom kan användarna automatiskt publicera från kommandoraden som beskrivs här .

Notera

Du kan välja alla delar som visas genom att klicka på Allaknappen eller invertera ditt val genom att klicka på Invertera knapp. Du kan också titta på Ingenknappen för att rensa ditt val.

Notera

om du avmarkera trädvyn alternativetdå inga träd ram (se nedan) kommer att publiceras. Följaktligen, du ska välja en startsida enligt steg 6 nedan eller efter att ha offentliggjort måste du anpassa antingen den översta nivån; en) index.htmlfil genom att ändra "frame src =" mainPage.html "name =" element_details "'linje att länka direkt till aktuella HTML-sidan i innehålls mapp eller, b) mainPage.htmlgenom att tillhandahålla en hyperlänk eller omdirigera till den aktuella HTML-sidan under Content mappen.

5. Klicka på Alternativ knappen och följande Utgivare Alternativdialogruta visas.

PubliceraER Alternativ

6. Svälja 3D, Diagramoch diagram format och om att visa titel, beskrivning eller Egenskaper för utsikt av de tillgängliga alternativen (se not nedan för kommentarer om de olika format).

7. Om du vill ställa in startsidan i den publicerade modellen till en viss vy kontrollera sedan Använd Visa som startsidaalternativet och bläddra för att se via "..." knapp som aktiveras.

Notera

Endast de synpunkter som valts i avsnittet Områden enligt steg 4 ovan finns tillgängliga för att ställas in som startsida.

8. Om du vill få feedback på specifika sidor i den publicerade modellen sedan se till att E-post Responsalternativ väljs, ange en e-postadress i E-postadresstextboxoch redigera E-post Bodysektion som är lämpligt. Om du inte vill ha synpunkter skickade sedan Avmarkera E-post Responsalternativ och lämna textrutan tom.

9. Klicka på ok knapp.

10. Klicka på Bläddra knapp.

11. De Bläddra efter mappfönstret visas.

12. Välj den plats du vill spara den översta nivån HTML-fil (och eventuella automatiskt genererade filer).

Notera

Det är en bra idé att skapa en särskild mapp (vanligtvis kallad "Publicerat") med hjälp av Skapa ny mappknappen längst ner i dialogrutan för att lagra den översta nivån HTML-filen och eventuella automatiskt genererade filer.

13. Klicka på ok knapp.

14. Vägen mappen visas i Katalogtextbox.

15. Klicka på Avsluta knapp.

- eller -

15. Ange sökväg i Katalogtextruta där du vill lagra den översta nivån HTML-fil (och eventuella automatiskt genererade filer).

16. Klicka på Avsluta knapp.

Notera

Export av Diagrammycket ibland misslyckas, oftast när datorn är slut på minne (normalt när man använder mycket stora filer). En misslyckad export kommer att nytt försök en gång. Det kommer att finnas en varning för ett misslyckat första försök, och en andra varning om åter försöket misslyckas. Därför, om de enda varningar "första försök misslyckades" ettor, publicerings lyckades. Om åter försöket misslyckas försöker publicera en mindre del av din fil eller frigöra en del systemminne.

Den sparade HTML-filen (er) kan nu vara utsikten från dess plats eller kopieras till en säker webbplats.

Publicera på webben i Internet Explorer10

Några hyperlänkar som skapades i den ursprungliga modellen kommer att framhärdade i den publicerade modellen och klicka på länken kommer att följa länken till sin destination (om det offentliggjordes). Dessutom kommer alla element i publicerade diagram som inte redan hyperlänkade i den ursprungliga modellen genom hyperlänk tillbaka till sina motsvarande element i trädvyn (om det publicerades) och genom att klicka på elementet i den publicerade diagrammet kommer fokus att hoppa tillbaka till relevant plats i trädet. Denna funktion liknar "Visa i Utforskaren" högerklicka funktion i ABACUS.

Notera

Avolution rekommenderar starkt följande mjukvara och filformat bör användas för att fullt ut utnyttja den Publicera till webben funktionalitet i ABACUS:

1. Internet Explorer (80,0 och ovan)att visa publicerade explorer vyn. Mozilla Firefox (30,0 eller senare)rekommenderas också och fullt stödMen om du använder den rekommenderade SVG-format för diagram sedan i Firefox 9 du kan bara använda inhemska SVG viewer stöd som tyvärr inte tillåter zoomning eller panorering.

2. Adobe SVG Viewer 3,0 ansluta (ladda ner från här ) och SVGfilformat för den publicerade diagram. SVG bildformatet för diagramrekommenderas eftersom; SVG är ett vektorbaserat bildformat och därför är det "förlust mindre" och ser mycket bättre vid varje given zoomnivå än någon av de andra format, SVG kan importeras till MS Visio, SVG kan zoomas till valfri nivå eller upplösning har SVG länkar tillbaka till trädvyn för anslutningarna (inte bara komponenterna), SVG skriver alltid en bättre upplösning, och SVG är ungefär hälften filstorleken på de andra formaten. PNG är nästa rekommendationen, men eftersom det är en rasterised format vid vissa zoomnivåer klarheten anser kommer att gå förlorade och klicka anslutningar på diagrammen kommer inte hoppa tillbaka till den aktuella platsen i trädet. BMP motverkas som samtidigt som det är en "förlust mindre" formatera filstorleken 100x som de andra formaten och 20MB bilder är inte ovanliga.

Avvägningen med SVG är att en SVG tittaren måste installeras och du behöver se till att .svg image / svg + xml sätts webb serverns MIME-typer. Efter installation av SVG viewer Microsoft Internet Explorer kommer att be dig att acceptera betraktarens licensavtalet och då bör fungera bra. Och samtidigtMozilla Firefox har stöd för SVG-filer inbyggt, Adobe plugin är fortfarande rekommenderasatt kunna zooma diagrammen om du använder Firefox 8 eller tidigare (om du använder Firefox 9 du inte kan stänga av infödda SVG viewer). När installationen för Adobe plugin har körts följande steg krävs använda den i Firefox:

· Öppna Firefox och ange "about: config" (utan citationstecken) i adressfältet.

· Scrolla ner och hitta den egendom svg.enabled(om du använder Firefox 9 då infödda SVG visning kan inte inaktiveras och den här egenskapen inte existerar). Dubbelklicka på den för att stänga av den.

· Nu kan katalogen där SVG plugin är installerad (t.ex. C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Kopiera filerna NPSVG3Dll och de NPSVG3.zip och klistra in dem i firefox plugins (t.ex. C: \ Program Files \ Mozilla Firefox \ plugins)

· Stäng alla instanser av firefox

3. Avolution s ABACUS 3D Viewer (3.1 och senare) och Avolution s .abacus3Dfilformat för de publicerade 3D-vyer. Medan Cortona VRML klient plug-in (2.0 och ovan)finns att se VRML versioner av publicerade åsikter är det inte gratis för kommersiellt bruk och kräver fortfarande en klientsidan installation. ABACUS 3D Viewer är mer funktionsrika än någon VRML viewer och är fritt tillgänglig för nedladdning från här . I båda fallen måste du lägg .vrml x-world / x-VRML och .abacus3d application / oktett-stream på webben serverns MIME-typer.

4. PNGfilformat för de publicerade sjökortsvyer. PNG bildformatet för sjökortsvyer rekommenderas eftersom medan det är en rasterised format och det är "förlust" avvägningen mellan filstorlek och diagram klarhet är vanligtvis bäst. BMP motverkas som samtidigt som det är en "förlust mindre" formatera filstorleken är 20x som de andra formaten och 2MB sjökort är inte ovanligt.

Om du vill ändra utseendet och känslan av webbsidor, kan du redigera startsidan fil med namnet mainPage.html och formatmallen filen abacus.css. Du hittar dessa filer i samma mapp som du valde att spara den översta nivån HTML-fil. För mer information om strukturen och anpassning av den publicerade utgångs se nästa avsnitt.

Strukturen Abacus publicerade modeller

ABACUS publicerade modellen är uppbyggd på följande sätt:

1. Mappen översta nivån innehåller flera filer och förutsatt alla alternativ är inkluderade i ABACUS Publicera till webben inställningsdialogruta kommer att omfatta ett index.htmlfil består av tre ramar; treeView.html, findNode.html och mainPage.html och då shortcutError.html sida. Den treeView.html är befolkat av tree.js, tree_items.js och tree_tpl.js JavaScript-filer som finns under include mapp (diskuteras nedan) och replikerar Explorer trädet från ABACUS. Den findNode.html drivs av de find.js JavaScript-fil som finns under include mapp (diskuteras nedan) och det kommer att söka de trädets grenar snarare än bara de synliga noderna. THan mainPage.html är en statisk HTML-sida som kan skräddarsys med företagslogotyper och liknandeoch kommer att visas om en startsida väljs vid publicering.Och slutligen, är shortcutError.html sidan en landningssida för några brutna genvägar från trädet på grund av de lämpliga sidorna inte är publicerade.

Dricks

Du kan hoppa över mainPage.html helt och hållet genom väljer att använda en startsida när du publicerar eller modifiera index.html filen att peka direkt till en viss vy (exempelvis) genom att redigera ramen src = "mainPage.html" linje för att peka direkt till den första vyn i första arkitekturen, typiskt "ram" diagram.

2. Den översta nivån includemappen innehållerIng olika javascript (.js) och Cascading Style Sheet (CSS) filer som används av de .html-filer hela publicerade modellen.

3. Content översta mappen innehåller, Alfabetiskt;

· EN '3D Visningar' mapp med en numreradHTML-sidan och en VRML eller abacus3d fil för vart och ett av de publicerade 3D-vyer. Se anmärkning nedan för information om filen numreringsschemat.

· En Arkitekturer mapp med en numrerad HTML-sida för varje arkitektur som offentliggjordes. Se anmärkning nedan för information om filen numreringsschemat.

· A Kataloger mapp som innehåller en numrerad HTML-sida för varje publicerade kataloger. Se anmärkning nedan för information om filen numreringsschemat.

· A Diagram mapp med en numreradHTML-sidan och en PNG, JPG etc fil för vart och ett av de publicerade sjökortsvyer. Se anmärkning nedan för information om filen numreringsschemat.

· A Ingående delar mapp som innehåller en numreradHTML-sida för var och en av de publicerade komponenterna. Se anmärkning nedan för information om filen numreringsschemat.

· A Anslutningar mapp som innehåller en numreradHTML-sida för var och en av de publicerade anslutningar. Se anmärkning nedan för information om filen numreringsschemat.

· A Diagram mapp som innehåller en numreradHTML-sidan och en PNG, SVG etc fil för vart och ett av de publicerade diagram. Se anmärkning nedan för information om filen numreringsschemat.

· En ikoner sub-mapp med olika bilder som används i den publicerade modellen.

· A Standarder sub-mapp med en numreradHTML-sida för varje standardersom publicerades. Se anmärkning nedan för information om filen numreringsschemat.

· A Mallar sub-mapp med en samling av numrerade undermappar för varje mall publiceras från projektet. Inom varje undermapp är en Komponenter och anslutningar mapp och inom dessa är en numrerad HTML-sida för varje komponent och anslutning av mallen. Se anmärkning nedan för information om mappen / filen numreringsschema.

· A Typer undermapp med komponent ochAnslutningsundermappar med numreradHTML-sida för varje komponent ochAnslutningstyper som publiceradesoch en samling av numrerade undermappar för varje typ publiceras från projektet som innehåller en HTML-sida för varje begränsningar. Se anmärkning nedan för information om mappen / filen numreringsschema.

· A Sepunkts undermapp och numreradHTML-sidan för någon av Viewpunkts som offentliggjordes. Se anmärkning nedan för information om filen numreringsschemat.

Notera

Numreringen av HTML-sidor (och I vissa fall bildfiler) matchar unik ID För varje förvars objekt som var in när det var skapadinom ABACUS (kallad EEIDs). Detta ID inte förändras så som diagram, typer, ingående delar etc är uppdaterad de viljabehålla samma ID som tidigare. I varje fall, de relevanta förvaret ändamålNamnet kan hittas nära början av HTML-sidan mellan ... HTML-taggar.

Begränsa åtkomsten till vissa sidor / Visningar med IIS

Om du använder IIS som din webbserver för den publicerade modellen, kanske du kan begränsa åtkomsten till vissa sidor / vyer som använder metoden nedan:

1. Skapa en webbplats i IIS (ett annat om det finns en befintlig du inte vill störa).

2. Ändra Egenskaper-> Directory Säkerhet-> Anonym åtkomst - avmarkera anonym åtkomst och användning autentiserad åtkomst.

3. Om detta är bara en vanlig server utan domän komplikationer etc, så ska du använda "integrerade Windows-autentisering" alternativ som då skulle använda servermaskiner lokala användare / inloggningar som autentiserings, och bara lägga till användare till den lokala datorn (var försiktig att du är medveten om konsekvenserna, säkerhet klokt, att lägga till nya användare till maskinen, till exempel beroende på om fjärråtkomst är inställd för maskinen, etc).

4. Lägg behörigheter till de specifika filer / mappar efter behov. Högerklicka på enskilda filer / mappar -> Egenskaper, och justera säkerhetsbehörigheterna som du skulle normalt för filer / mappar.

Detta kan variera beroende på vilken version av IIS och vilka specifika Windows OS är på servern, och om du har en domän eller andra olika inställningar.

Se också

Fylla din arkitektur | Analysera din arkitektur


Exportera din arkitektur

Navigering: Rapportering om din arkitektur>

Exportera din arkitektur

Skicka kommentarer om detta ämne.

ABACUS låter dig tillexportera din arkitektur till MDB (Microsoft Access), MS SQL Server, .abacus (Abacus fil), och .xls (Microsoft Excel). Du kan också exportera din diagrams till PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF och BMP-format och dina rapporter till .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) och rtf (Rich Text Format) format. Detta gör att du kan analysera och visa arkitekturen och dess data på något sätt du vill.

Att exportera din arkitektur till MDB (Microsoft Access)

1. Se till att du har en ABACUS fil öppna.

2. Klicka på Fil meny.

3. Välj Exportera, och då Till MDB.

4. Ta del av varningen och klicka ok.

5. Skriv in ett namn på filen.

6. Klicka på Spara Knapp.

Notera

Export format MDB databasen är specifika för ABACUS och eventuella schemaändringar kommer att resultera i oförmåga att importera. Snälla se Fylla med MS Access för en beskrivning av MS Access schemat.

Att exportera din arkitektur till MS SQL Server

1. Se till att du har en ABACUS fil öppna.

2. Klicka på Fil meny.

3. Välj Exportera, och då Till MS SQL Server.

4. I dialogrutan som visas klickar du på Exportera Blank MDB ...knappen och importera detta i din MS SQL Server databasserver.

5. Fyll i informationsdatabasen och anslutningssträngen.

6. Klicka på Exportera Knapp.

Notera

Export form av MS SQL Serverdatabasen är specifika för ABACUS och eventuella schemaändringar kommer att resultera i oförmåga att importera. Snälla se Fylla med MS Access för en beskrivning av databasschema.

Att exportera din arkitektur till xls (Excel-fil)

1. Se till att du har en ABACUS filen öppen , en explorer visas , Och en arkitektur tillsatt .

2. Se till att du har en Excel Import / Export konfigurationsfil definierats.

3. Högerklickpå en arkitektur i din modell eller någon del av Ingående delarnod (inom en given arkitektur) som du vill exportera till Excel konfigurationsfilen.

4. Välj Exportera | Till Excel ... från menyn.

5. De Välj Excel Import / Export konfigurationsfil att användafönstret visas.

6. Välj relevant konfigurationsfilen för din arkitektur modell och klicka på Öppna knapp.

7. Om inte automatiskt gjort det, karta de toppnivå komponenter i din nuvarande arkitekturen till Ange ID(såsom tidigare definierats) och klicka på Exportera....

Exempel Top-komponentnivå Mapping

8. Välj en plats och filnamn för din Excel-fil och klicka på Spara knapp.

Att exportera din arkitektur till .abacus (ABACUS fil)

1. Se till att du har en ABACUS fil öppna.

2. Högerklickpå Arkitektur noden varje arkitektur i din modell eller någon del av komponentträdet.

3. Välj Export | Till Fil...från menyn.

4. Välj en plats och filnamn och klicka på Spara knapp.

Notera

Du kan importera en ABACUS fil tillbaka till ABACUS genom följande steg 1-2ovan och sedan välja Import | Från Fil.... När du har valt filen du vill importera blir du tillfrågad hur du vill importera normer eller typer. Du kan importera normer eller typer som antingen nya eller sammanslagna normer eller typer. Standardinställningen är för standarder och typer att slås samman med befintliga standarder och typer, om de redan finns i din projekt.

Att exportera din arkitektur att .xml

1. Se till att du har en ABACUS fil öppna.

2. Högerklickpå en arkitektur nod varje arkitektur i din modell eller någon del av komponent trädet.

3. Välj Export | Till XML ...från menyn. Alternativt kan du klicka på menyn Fil| Exportera| Till XML ...

4. Välj en plats och filnamn och klicka på Spara knapp.

Notera

Du kan importera en XML-fil tillbaka till ABACUS genom följande steg 1-2ovan och sedan välja Import | Från XML .... När du har valt XML-filen du vill importera, kommer du att tillfrågas hur du vill importera normer eller typer. Du kan importera normer eller typer som antingen nya eller sammanslagna normer eller typer. Standardinställningen är för standarder och typer att slås samman med befintliga standarder och typer, om de redan finns i din projekt.

Att exportera diagrammet till PNG, JPG, SVG, TIFF, GIF eller BMP

1. Se till att du har en ABACUS fil öppna.

2. Öppna diagramdu vill exportera.

3. Klicka på Export Diagramknappen på Diagram verktygsfältet.

4. De Export Diagramfönstret visas.

5. Välj Bläddraknappen för att spara visualisering på önskad plats.

6. Välj Filformatrullgardinsmenyn för att välja filtyp.

7. Klicka på Spara knapp.

Att exportera rapporten till .pdf (Adobe Acrobat), .xls (Microsoft Excel) eller.doc (Microsoft Word)

1. Se till att du har en ABACUS fil öppna.

2. Skapa en rapportera du vill exportera.

3. Klicka på Exporteraknappen på rapporter verktygsfältet.

4. Välj Excel, PDF eller Wordfrån rullgardinsmenyn.

5. Vänta en liten stund medan rapporten exporten.

6. Välj en plats och filnamn och klicka på Spara knapp.


Arbeta med Enterprise Server

Navigering: Administration>

Arbeta med Enterprise Server

Skicka kommentarer om detta ämne.

ABACUS Enterprise Server är både en "icke-låsning" gemensam strategi, men en "frånkopplad" man också. ABACUS är "icke-låsning" eftersom det inte tvinga den fil som skall låsas med en användare för att det ska uppdateras. Varje användare har sin egen lokala kopia av filen, och när de gör ändringar och spara sina filer, är dessa ändringar registreras och lagras när användaren önskar överlämna dem till servern.

ABACUS är "frånkopplad" i den meningen att du inte behöver vara ansluten till servern eller behöver nätverksåtkomst samtidigt som arbetar på en fil. ABACUS kräver bara tillgång till servern när du utför operationer som att skapa en fil, eller utför en kassan, tillsammans med verksamhet på en befintlig fil - uppdatering, begår eller visa loggen för tidigare begår. Tillgång till servern inte är skyldig att arbeta på filen, och ändringarna inte skickas till servern omedelbart (detta kan du enkelt ignorera ändringar om du gör ett misstag). När du sparar filen, är du "bara" spara kopiera lokalt - det är inte förrän du begår att dina lokala ändringar (ändringar som gjorts sedan den senaste begå), skickas till servern.

Skapa en ny Enterprise-fil

För att skapa en ny Enterprise-fil, välj Fil| Ny ...och välj sedan en av de två första alternativen under Enterprise Model delen av Dialogrutan Nytt projekt (dvs. antingen en tom Enterprise-fil, eller skapa en från en befintlig ABACUS fil). Det tredje alternativet är att "kassan" en Enterprise-fil någon annan har redan skapat, kommer detta att täckas i nästa avsnitt.

När du väljer att skapa en ny Enterprise-fil, kommer du att få en dialogruta som gör att du kan bläddra till var på ett slutförvar server som du vill spara filen. Det kommer också att ha den befintliga filen sökväg och namn in upp upp om du väljer "Från befintlig modell" i dialogrutan Nytt projekt och levererat en fil.

URL: Detta är webbadressen till din förvars server där ABACUS Enterprise filer lagras. Du bör be personen som hanterar servern vad denna webbadress ska vara.

Bilden ovan visar ett slutförvar med fyra (4) befintliga ABACUS Enterprise projekt, efter att webbadressen och trycka på Enter. Dig ser när du skapar en ny Enterprise-fil, på nästa skärmbild för "kassan", kommer det att finnas en annan mapp och fil under detta förvar.

Notera

Om du använder en https (SSL) server, och servern inte har ett giltigt SSL-certifikat (vanligt för intranät eller icke-offentliga servrar på grund av de Kostnaden för SSL-certifikats) Kommer det att finnas ett extra steg att ta. Du kommer att krävas för att permanent ta emot alla anslutningar till servern i dialogrutan som dyker upp (det kommer också att visa lite mer information på servern). För att göra detta, typ "p" (utan citattecken) och tryck på Enter. ABACUS kommer att dyka upp ett meddelande som påminner dig om detta innan visar dialogrutan.

Notera

Du kan bli ombedd att logga in på servern i vilket fall den person som är hantera servernkan ge servern användarnamn och lösenord. Även de inloggningsuppgifter för några servrar som du har anslutit till sparas så om du av någon anledning måste de tas bort kan detta göras via Verktyg | Valoch sedan på Allmän flik genom att klicka Återställ Subversion sparade Inloggningoch välja servern i listrutan och klicka Rensa Loginoch välja OK i dialogrutan som visas.

Notera

Till skillnad från skärmdumpen visas ovan, typiskt en enda ABACUS Project ingår i varje ABACUS Repository därför om mer än 1 ABACUS Project skapas i en enda ABACUS Repository, är ABACUS förändring log nummer delas mellan alla ABACUS projekt och detta kan förvirra användarna.

Föredragna Filnamn: Det här påverkar både mappen och filnamnet som kommer att användas (om det inte redan vidtagit) när du skapar filen på förvaret servern. Observera att en ny mapp skapas automatiskt på förvaret server för varje fil (av prestandaskäl, är ABACUS Enterprise filer som skapats i sin egen mapp under den plats bläddrade i dialogrutan).

Förvara arbetskopian i register: När en Enterprise-fil skapas på ett slutförvar server, lokala arbets filer måste skapas på datorn, så att du kan arbeta på filen utan att vara ansluten till nätverket. Detta är den plats som du kommer att bläddra till när du vill öppna / åter öppna en kulram Enterprise-fil.

Kassan ett befintligt företag fil

Om någon redan har skapat en ny Enterprise-fil, kan "kassan" den här filen, som hämtar en lokal kopia och sätter upp de nödvändiga filerna så ABACUS erkänner detta som ett Enterprise fil som du. Dialogrutan liknar den nya Enterprise File Dialog. Ange förvaret URL (kataloger kan inkluderas i URL), välj önskad fil och klicka på OK. Med förbehåll för noteringen under tHan fil kommer då att öppnas.

Notera

Du kan bli ombedd att logga in på servern i vilket fall den person som är hantera servernkan ge servern användarnamn och lösenord. Även de inloggningsuppgifter för några servrar som du har anslutit till sparas så om du av någon anledning måste de tas bort kan detta göras via Verktyg | Valoch sedan på Allmän flik genom att klicka Återställ Subversion sparade Inloggningoch välja servern i listrutan och klicka Rensa Loginoch välja OK i dialogrutan som visas.

Enterprise File Skillnader

När du har skapat en Enterprise-fil (antingen en ny, eller via "kassan" av en fil som skapats av någon annan), en mapp att skapas för filen, och det kommer ofta innehålla dessa 3 huvudsakliga typer av filer:

· ".abacus" Fil- Detta är den ABACUS själva filen. De ändringar du gör lokalt inte omedelbart sparas i den här filen är det bara skrivit till när du begår. Denna fil är en "normal" ABACUS fil kan den ges till icke-EE-användaresom ett fristående projekt (utan .log)Eller användas som utgångspunkt för en ny EE-fil.

· '.changes' Fil- De lokala (obekräftade) ändringar som gjorts i filen. Om denna fil saknas, innebär det att det inte finns några lokala ändringar.

· '.loggfil- Den här filen har endast de ändringar som gjordes av den sista användaren (innehållet i användarens .changes fil när de begick).

Notera

Det finns olika andra filer som kan skapas under uppdateringen och begår processer, nämligen; ‘.changesbefore' fil- Denna fil är en kopia av .changes filen efter en uppdatering har gjorts och används för att automatiskt förena alla ID konflikter mellan uppdateringen och alla lokala (obekräftade) förändringar innan begå; ‘.säkerhetskopiering' fil- Denna fil är en kopia av .changes filen innan en användare sparar mer lokala (obekräftade) ändringar i .changes fil; och ‘.fel' fil- Denna fil är en kopia av .changes filen om det fanns någon fråga som orsakade ABACUS att öppna .abacus filen för att misslyckas och användaren valde att återgå sina ändringar.Dessa filer kan ignoreras.

Att öppna en fil

Så här öppnar du en fil, behöver du bara bläddra till den plats där du valde att spara arbetskopian, och öppna ABACUS fil som lagras där. När ABACUS ser att det finns en .loggfil (och kanske en .förändringar filen om du har gjort ändringar), det kommer att behandla ärendet som en Enterprise-fil.

Uppdatera en fil

Utföra enn 'Update' kommer att kontrollera om en nyare version av en fil finns på servern. Om det finns, kommer den att stänga den aktuella filen, uppdatera till den nyare filen från servern och ladda ner några temporära filer som har ett nummer som en förlängning - t.ex. 'Demo.125'. Dessa filer är de äldre versionerna av .log-filen, och används för att bestämma vilka ändringar har gjorts i en fil sedan du senast uppdaterade den. Detta behövs för att upptäcka eventuella konflikter som kan ha inträffat så att du kan lösa dem.

Om under uppdateringsprocessen någon konflikter hittades, Du kommer att behöva lösa dem innan du kan öppna filen igen (du kan avbryta men kommer du att bli ombedd att lösa konflikterna igennästa gång du öppnar filen).

Spara en fil

När du sparar en fil, lägger detta eventuella ändringar som du har gjort i .changes filen. Det gör intemodifiera .abacus filen i detta skede - bara när filen har åtagit sig att servern kommer det skrivas över (eller när du tar emot en uppdatering från servern).

Var är "Spara som"?

Det finns inget begrepp om Spara som för Enterprise-filer. Du kan dock kopiera din arbetskopia .abacus fil, med tanke på att det brukar har lokala ändringar i det.

Lösa konflikter

Om andra användare har engagerade ändringar i filen i en liknande del av filen till dig, kan det finnas vissa konflikter mellan sina ändringar och ditt. Till exempel kan en annan användare tar bort en komponent som du hade uppdatera en fastighet på. Du måste antingen ångra deras förändring (om du är säker på att deras skainte har hänt), eller kasta din förändring (du kan sedan gå tillbaka in i filen och gör om dina ändringar).

Specifikt finns 4 klasser av konflikter som kan uppstå;

1. Radera - När en användare tar bort ett objekt som en annan användare förändringar. T.ex. Användare A bort en komponent men användare B bytte komponentens namn eller ansluten till den eller läggas ett barn komponent till det etc.

2. Attribut - När två användare både ändra exakt samma "attributet 'för ett objekt. T.ex. Både Användare A och användare B förändrats en del namn eller dess beskrivning eller värdet av en av dess egenskaper etc.

3. Hänvisa till - När två användare ändra exakt samma referens "ett föremål har ett annat objekt. T.ex. Både Användare A och användare B förändrats komponent typ eller källa / sink-komponent ansluten till en anslutning eller den länkade synpunkt för ett diagram mm

4. Samling - När två användare ändra en "samling" för ett objekt. T.ex. Både Användare A och användare B flyttade en komponent från en förälder till en annan eller åter beställt en samling av barn komponenter.

Notera

Olika obetydliga konflikter automatiskt lösts genom ABACUS att minimera overhead på användarna.Till exempel alla motstridiga pan-zoominställningar för diagrammen är fast beslutna att hålla den senaste pan-zoominställningar.

Begå Förändringar

När du väljer att begå dina ändringar, ABACUS filen från servern öppnas, din lokal förändringar utförs Emot det, och då din lokala .abacus filen skrivs över med en som har dina ändringar i det. Dina ändringar filen sedan skriver .log-filen, och både .abacus filen och .log-filen skickas till servern.Om begå lyckas en Begå dialog meddelande som visas nedan tillhandahålls för att skriva ett meddelande med commit.

Visning av en logg över förändringar

Till se en logg över ändringarna i en Företag projekt, Välj Fil| Visa logg...

Max Log Inlägg: Detta går automatiskt till de senaste 10 posterna, men ytterligare poster kan hämtas genom att ändra värdet och klicka på Hämta knapp.

Revision: The Revision kolumnen listar revisionsnummer åtagit sig att Enterprise Server som standard, i omvänd kronologisk ordning.

Notera

De versionsnummer får inte vara kontinuerlig som endast ABACUS begår kommer att listas medan samma Subversion förrådet kan används för andra ABACUS projekt och / eller andra version kontrolltillämpningar.

Datum: The Datum kolumnen visar det datum då revideringen begicks till Enterprise-server.

Tid: The Time kolumnen anger vilken tid på dygnet (i 24-timmarsformat) att översynen begicks till Enterprise-server.

Författare: The Författare kolumnen listar Microsoft Windows inloggningsnamn för användaren som utförde begå följt av deras ABACUS användarnamn Eller "Anonym" om användaren inte autentiseras och anonyma användare fick åtkomst till Enterprise-projektet vid tidpunkten för commit.

Logga Meddelande: The Log Meddelande kolumnen listar begå budskap som tillhandahölls med revideringen enligt dialogrutan som visas ovan.

Hämta revision XX som fristående ABACUS fil: Om du väljer en viss revidering i tabellen och klicka sedan på knappen Hämta du kommer att kunna extrahera den valda ABACUS projektet revidering från servern och spara den som en lokal / fristående ABACUS projektet.

Notera

Att rulla tillbaka till en tidigare version, se detta Avolution gemenskap artikel .

(Admin) Ladda ner XML loggfilen för revision XX: Användare med ABACUS Administrator kapacitet kan välja en viss revidering i tabellen och klicka sedan på knappen Hämta för att extrahera den valda ABACUS projektet begå loggfilen från servern och spara den som en XML-fil.

Visa en Audit Trail Förändringarnas

Till visa en verifieringskedja för de ändringar till någon givet element (dvs. komponent, anslutning, visa, barn osv) av en Företag projekt, Högerklicka på elementet och Välj Verifieringskedja...Ställer du in Från och Till Revision område och klicka Sök.

Notera

När ett element tas bort från projektet du inte längre kunna komma åt specifik verifieringskedja information om det elementet. Du kan dock fortfarande komma åt "förälder" komponent (till exempel) och se verifieringskedjan information om raderingen (i detta fall notering ID för det element som togs bort).Dessutom är komponentanslutning fäste / a "egendom" av förbindelserna så förändras en bifogad komponent genom fönstret Explorer eller på diagram visas i verifieringskedjan för en anslutning inte komponenten, och ta bort en anslutning och att skapa en ny anslutning (som händer om du högerklickar "Unattach" och sedan "Connect ..." i kataloger) kommer att resultera i förlust av verifieringskedja information för den ursprungliga komponenten - anslutningsfäste helt och hållet.

Notera

Som standard verifieringskedjan kommer rekursivt kontrollera ändringar till någon av barnen i det valda elementet. Detta kan resultera i långa svarstider och följaktligen verifieringskedjan kan begränsas till själva elementet genom att välja bort den Rekursiv alternativ under Gransknings Alternativ"kugghjul" knapp i verktygsfältet i dialogrutan Audit Trail.

Från Omar: Detta återgår till första / äldsta revision för projektet på Enterprise-server.

Till revision: Detta går automatiskt till den sista / senaste översynen för projektet på Enterprise-server.

Notera

När du har ställt Från och Till revidering range klicka på Sök-knappen för att hämta några specifika ändringar av valda elementet.

Revision: The Revision kolumnen listar revisionsnummer åtagit sig att Enterprise Server som standard framåt kronologisk ordning.

Notera

De versionsnummer är osannolikt att vara kontinuerlig eftersom endast de ändringar som är relevanta för den valda elementet visas och endast ABACUS begår kommer att listas medan samma Subversion förrådet kan används för andra ABACUS projekt och / eller versionskontroll applikationer.

Datum: The Datum kolumnen visar det datum som användaren åtgärden gjordes.

Notera

Det datum som anges är användarens åtgärder dagen, inte dagen översynen begicks till Enterprise-server. Följaktligen kan datumet föregå motsvarande översyn begå dag som anges med Arkiv | Visa logg... kommando.

Tid: The Time kolumnen anger vilken tid på dygnet (i 24-timmarsformat) att användaren åtgärden gjordes.

Notera

Tiden som visas är användarens åtgärder tiden inte tid revideringen begicks till Enterprise-server. Följaktligen tiden kommer med stor sannolikhet före motsvarande revidering begå tid som visas med Arkiv | Visa logg... kommando.

Författare: The Författare kolumnen visar användaren som utförde åtgärdens Microsoft Windows inloggningsnamn följt av deras ABACUS användarnamn Eller "Anonym" om användaren inte autentiseras och anonyma användare fick åtkomst till Enterprise-projektet vid tidpunkten för åtgärd från användaren.

Notera

Författaren som anges i Audit Trail dialogrutan kanske inte nödvändigtvis matchar författare som anges i View Log dialogrutan ovan för samma revideringen. Detta beror på att Visa logg dialogruta visas den inloggade användaren vid tidpunkten för commit medan revisions Trail dialogruta visas den inloggade användaren vid tidpunkten för användarens åtgärder, och det är möjligt att ha en användare göra ändringar och skicka sina. förändringar fil till en annan användare att begå - vilket är fallet när en extern användare (t.ex. Avolution) är att arbeta på en EE projekt.

Detaljer: The Detaljer kolumnen anger de exakta detaljerna om användarens åtgärder som registrerats på Enterprise-server.

Dricks

Det är nyttigt att gruppera efter översynen kolumnen (som visas i dialogrutan ovan) och / eller användar kolumnen Åtgärd till lätt klassificera förändringarna i element av intresse.

Användning av skript med Enterprise-filer

Om du använder skript med Enterprise-filer, bör du vara medveten om hur man korrekt ta bort ett objekt från modellen. Generellt, när du tar bort ett objekt, kommer du ringa .Delete () metod på det, snarare än bara ta bort det från sin överordnade.

T.ex. om du hade COMP1 som förälder COMP2 och du vill ta bort COMP2 i ditt manus, bör du ringa comp2.Delete (), snarare än comp1.Components.Remove (COMP2).

Du kan använda ta bort om du tänker lägga till COMP2 objekt till ett annat ställe inom arkitekturen, men det bör inte användas om avsikten är att ta bort föremålet.

Det finns ett undantag från denna, för när du vill ta bort ett objekt som "lever" på andra ställen i modellen. När du vill ta bort en vanlig instans från en arkitektur / komponent / anslutning, då skulle du göra det genom att ta bort den från förekomstens standardkollektion - arch1.Implementeringar.Avlägsna (Imp) - eftersom att ta bort det skulle avlägsna den från alla instanser.

Korrekt användning av Radera i manus är viktigt eftersom om ett objekt tas bort från objectmodel och inte återsätts, då det inte kommer att kunna ligga, men eftersom det var inte särskilt "utgår", Konflikt Detection och upplösning kommer inte korrekt upptäcka en konflikt om en annan användare var att försöka använda objektet i någon av sina ändringar, och slutresultatet kommer att bli en skadad uppsättning förändringar för användaren.

Se också

Hur en arkitektur representerat i ABACUS?


Arbeta med Behörigheter

Navigering: Administration>

Arbeta med Behörigheter

Skicka kommentarer om detta ämne.

ABACUS projekt kan ha rollbaseradbehörigheter in för varje element inom förvaret. Speciellt, finkornig Create-Read-Update-Delete (CRUD) Behörigheter kan ställas in på "objekt" (dvs. komponent eller anslutning), visa och attribut (dvs. fastighets) nivåer.

Översikt

När du arbetar med ABACUS Enterprise Server , ABACUS ger finkorniga, rollbaserade CRUD behörigheter för att kontrollera åtkomsten av flera användare att förvaret.

Notera

För att konfigurera behörigheter i en kulram projekt användarlicens behöver administratörs kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

Behörigheter kan ställas in för arkitekturer, komponenter och anslutningstyper, egenskaper (via deras typer), mallar, synpunkter och diagram, kataloger, matriser, diagram och 3Dvisningar. När behörigheten är angiven för en komponent eller anslutningstyp alla förekomster av denna typ i någon arkitekturer i projektet "ärver" dessa behörigheter. På samma sätt, när ett tillstånd är inställd för en egenskap hos en komponent eller anslutningstyp, den givna fastighet på komponent eller anslutnings instanser i alla arkitekturer i projektet "ärver" dessa behörigheter. Följaktligen kommer vissa behörigheter tillämpas på synpunkter på vilka dessa delar finns. När behörigheten är angiven för ett diagram, utsikten och / eller innehållet i själva vyn har olika behörigheter tillämpas på det.

Notera

Som standard inga behörigheter fastställs för elementen i en kulram projekt. Det är alla element är Createable, läsbar, Kan uppdateras och rader av alla användare. På detta sätt behörigheter endast bör övervägas för ett givet inslag i förvaret när ett visst tillstånd är att vara begränsadför en viss användargrupp. Till exempel, om behörighet för en viss användargrupp sattes till ett objekt (till exempel en komponenttyp), men lämnade med alla behörigheter aktiverade, så är detta funktionellt densamma som om den användargrupp var inte sattes till objektet.

Behörigheter kan ejställas in för specifika fall av en arkitekturens element. Till exempel, kan du inte göra en applikationskomponent uppdaterbar ännu en inte. För att effektivt nå dessa "domänspecifika" behörigheter kan dock administratören inrätta särskilda elementtyper för de givna domäner, t.ex. komponenttyper "Ansökan - CRM-domänen" och "Ansökan - HR domän", och ställ sedan in behörigheterna för varje typ därefter. Du kan göra särskilda Gruppera typer för varje domän och sedan ta bort uppdaterings tillstånd för domänspecifika grupp typ och detta kommer att begränsa skapelser inom och strykningar från denna grupp, men inte uppdatera av barnen. Naturligtvis om domänspecifika Gruppering doldes genom att ta bort läsrättigheter då barnen skulle döljas och därmed icke-uppdateringsbar. Alternativt, om vyer (snarare än explorer) används främst för att hantera / visa din förvaret, en given vy för varje domän skulle kunna inrättas, och sedan administratören kan ställa in behörigheter för varje vy därefter.

Hantera användare och grupper

Behörigheter definieras på roll eller gruppnivå, i motsats till den individuella användarnivå, så att medan medlemskap av grupperna kan förändras, behörighet kan förbli fixerad. Naturligtvis om du vill ha en viss användarbehörighet sedan helt enkelt göra dem till en grupp, eller mer exakt skapa en grupp med användaren som enda medlem.

Det bör noteras att grupper är atom-, Är att de inte kan ärva behörigheter eller användare från en till en annan, och om en användare tillhör flera grupper sedan den mest "pessimistiska" gruppen tillstånd kommer att ha företräde på en bedömning från fall till fall för varje enskild tillstånd (dvs. Skapa -Läs-Update-Delete). Till exempel om samma användare är medlem i grupp A och grupp B och grupp A har just Skapa-Läs tillstånd för typer Application komponent medan grupp B har bara Skriv Uppdatering tillstånd för typer Application komponent då användaren bara har Läs tillstånd för Ansökan komponentförekomster.

Genom standard anonyma användare(som är användare som inte har definierats eller som inte har loggat in) har full tillgångtill projektet. Detta är att se till att finns i den inledande konfigurationen. För att blockera åtkomst av anonyma användare helt enkelt avmarkera "Tillåt anonym användaren full tillgång till handlingarna" alternativet i Hantera användare / grupper Dialogrutan som avbildas nedan. När okontrollerade anonyma användare bara kommer att kunna se Standards del av ett projekt.

Slutligen om "Använd Windows användarnamn inloggning" alternativet är markerat användarnamn autentisering utförs mot Windows Användarnamn Inloggningar på varje användares maskin mot användarnamnet som har angivits enligt nedan. Det är om Windows Användarnamn Logga in för en viss användares dator existerar som ett giltigt användarnamn då ingen lösenord krävs och användaren automatiskt autentiseras. Obs: detta kommer att möjliggöra användning av Windows Active Directory (AD) autentisering.

Notera

Med tanke på att behörigheterna bara definieras när de behöver tas bort (begränsad) från en användare, alla användare som inte är medlem i en grupp, eller någon grupp som inte har några behörigheter som definierats för den mot eventuella föremål, kommer att ha full tillgång till projektet.

Användare och användargrupper

För att skapa en ny användare

1. Välj Fil| Hantera användare / grupper

Notera

Om du inte ser Hantera användare / grupper menyalternativet då du inte har administratörs kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

2. I dialogrutan som visas väljer du Lägg till användareknappen och ange ett användarnamn och lösenord i Skapa ny dialog användaren. Obs: Användarnamn och lösenord är skiftlägeskänsliga.

Notera

Om "Använd Windows användarnamn inloggning" alternativet är markerat som beskrivits ovan sedan en dummy lösenord kan anges som autentisering kommer att utföras i enlighet med användarens fönstrets Användarnamn enda inloggning.

2. Som standard kommer du att se att Användare kan ändra sina egna lösenord. Om så krävs kan ABACUS Administratör avlägsna de möjligheten för användarna att sätta sina egna lösenord av avmarkerakryssrutorna.

Notera

Om användare kan ändra sitt eget lösenord de kommer att ha en Arkiv | Byt lösenord...menyalternativet för att göra det.Också vara medveten om att om flera personer använder samma användarnamn då en användare kan ändra lösenordet så att inga andra personer kan logga in efteråt. Följaktligen rekommenderas det praxis att ha en enda användarnamn per faktisk person.

4. Eventuellt anger e-postadress, Plats och Telefonnummer för användarna för framtida referens.

5. Klicka på okknappen Skapa ny dialog användaren.

6. Klicka på ok knapp.

Notera

När du har skapat ditt första användaren bör du överväga att blockera tillgång anonyma användare genom att avmarkera "Tillåt anonym användaren full tillgång till handlingarna" alternativet Hantera användare / grupper dialogrutan.Dessutom, när en användare har skapats (och om en Enterprise projekt förändringen åtagit sig att servern), nästa gång projektet öppnas användare kommer att uppmanas att Logga in för autentiserad åtkomstenligt dialogrutan som visas nedan. Om Logga in automatiskt med dessa detaljerAlternativet är markerad användarnamn / lösenord kombination kommer bli ihågkommen för projektet och tillämpas varje gång vid öppning. Att rensa sparade inloggning väljer Arkiv | Rensa sparade Inloggningefter att ha öppnat och du blir ombedd att logga in igen nästa gång du öppnar projektet.

Logga in

För att radera en befintlig användare

1. Välj Fil| Hantera användare / grupper

2. I dialogrutan som visas väljer du användarnamn i Användare panelen som du vill ta bort och välj sedan Ta bort användare knapp.

3. Klicka på ok knapp.

För att skapa en ny koncern

1. Välj Fil| Hantera användare / grupper

2. I dialogrutan som visas väljer du Lägg till gruppknappen och ange ett gruppnamn i grupper panelen.

Notera

Gruppnamn måste vara unika.

3. Klicka på ok knapp.

Till kopiera en befintlig Grupp

1. Välj Fil| Hantera användare / grupper

2. I dialogrutan som visas väljer du Kopiera Grupp knapp.

Notera

En dubblett grupp kommer att skapas prefixet "Kopia av".Som standard alla behörigheter från den kopierade gruppen kommer att dupliceras för "Kopia av" grupp inklusive eventuella användartilldelning.

3. Byt namn på "Kopia av" grupp som är lämpligt att använda Redigera gruppeller långsam dubbelklicka.

För att radera en befintlig grupp

1. Välj Fil| Hantera användare / grupper

2. I dialogrutan som visas väljer du gruppnamnet i grupper panelen som du vill ta bort och välj sedan Ta bort grupp knapp.

Notera

Alla användare uppdrag för koncernen kommer också att tas bort.

3. Klicka på ok knapp.

Om du vill tilldela en användare till en grupp

1. Välj Fil| Hantera användare / grupper

2. I dialogrutan som visas väljer du användarnamn i Användare panelen som du vill tilldela till en grupp och dra och släppden på gruppnamnet i grupper panelen som du vill tilldela den till.

3. Klicka på ok knapp.

Notera

Den grupp (er) som en användare är tilldelad visas genom att utvidga Användarnamn i Användare panelenoch de användare som har tilldelats en grupp visas genom att utvidga gruppnamnet i grupper panelen. Till exempel i skärmbilden ovan, är "AS1-Aus" användare som tilldelats tre (3) grupper, nämligen; "App Support Team 1", "Faktiskt" och "Australia".

Att bort tilldelningen en användare från en grupp

1. Välj Fil| Hantera användare / grupper

2. I dialogrutan som visas expandera gruppnamnet som innehåller användaruppgift som du vill ta bort tilldelningen och välj Användarnamn.

3. Klicka på Bort tilldelningen Användare knapp.

4. Klicka på ok knapp.

För att importera användare och / eller grupper (och eventuella matchande behörigheter)

1. Välj Fil| Hantera användare / grupper

2. Klicka på Importera knapp.

3. I dialogrutan som visas Bläddratill och öppna ABACUS projekt som innehåller användare och / eller grupper (och behörigheter) som du vill importera till det aktuella projektet och klicka Öppna. Användare och grupper kommer att importeras och en dialog Importera resultat visas en sammanfattning import av användare och / eller grupper. Klicka på ok knapp.

Notera

Om de importerade användare eller grupper som redan fanns i det aktuella projektet då de kommer att slås samman med de befintliga användare eller grupper.

4. Klicka på okknappen tillbaka i huvud Hantera användare / grupper dialogen.

5. Om det finns några matchande Typer, Synpunkter, mallar eller arkitekturer mellan det aktuella projektet och ABACUS projekt du importerar från, komplett med behörigheter som inte redan finns i det aktuella projektet, är behörigheterna importeras och en andra dialog Importera resultat visas en sammanfattning av importen. Klicka på ok knapp.

Notera

Behörigheter endast läggas till befintliga typer (och deras egenskaper), Utsikt, mallar eller arkitekturer för grupper där behörigheterna inte redan finns i koncernen. Antingen för att koncernen är ny eller koncernen redan fanns i det aktuella projektet, men inga rättigheter hade tilldelats för denna grupp till denna post. Det finns ingen "sammanslagning" av behörigheter för att matcha objekt där behörigheterna redan finns i koncernen i det aktuella projektet.

Ställa in behörigheter

Behörigheter kan ställas in för arkitekturer, komponenter och anslutningstyper, egenskaper (via deras typer), mallar, synpunkter och diagram, kataloger, matriser, diagram ettd 3Dvisningar. När behörigheten är angiven för en komponent eller anslutningstyp alla förekomster av denna typ i någon arkitekturer i projektet "ärver" dessa behörigheter. På samma sätt, när ett tillstånd är inställd för en egenskap hos en komponent eller anslutningstyp, den givna fastighet på komponent eller anslutnings instanser i alla arkitekturer i projektet "ärver" dessa behörigheter. Följaktligen kommer vissa behörigheter tillämpas på synpunkter på vilka dessa delar finns. När behörigheten är angiven för ett diagram, utsikten och / eller innehållet i själva vyn har olika behörigheter tillämpas på det.

Permissions Management

För att ställa in tillstånd för en komponent (eller anslutning) Typ

1. Expandera Typergren i trädet.

2. Expandera Komponent (eller anslutning) Typergren i trädet.

3. Bygga ut Grupperdär så är nödvändigt.

4. Högerklick på Komponent (eller anslutning) Typdu vill ställa in behörigheter för och välj Redigera behörigheter.

5. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

6. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

Notera

Skapa tillstånd styr också när du kan kopiera ett element. Följaktligen för att kunna kopiera ett element kräver Skapa tillstånd för alla sina barn (eftersom att kopiera elementet innebär att kopiera allt under det). Borttagning Uppdatera tillstånd från ett element avlägsnar förmågan att modifiera den typ själv, även om användaren har Designer add-on och det också bort Uppdatering tillstånd för alla sina egenskaper. En förälder element måste ha Update tillstånd för att kunna Skapa några barn element eller Ta bort sin existerande barn element. Ta bort tillstånd för ett element kräver också ta bort tillstånd för alla sina barn. Radera tillstånd för komponenter kräver också Uppdatera tillstånd av alla anslutna anslutningar.Och slutligen, ta bort behörigheten Ta bort från ett element avlägsnar förmågan att ta bort den typ själv, även om användaren har Designer tillägg.

7. Klicka på ok knapp.

För att ställa in tillstånd för en grupp av komponent (eller anslutning) Typer

1. Expandera Typergren i trädet.

2. Expandera Komponent (eller anslutning) Typergren i trädet.

3. Högerklick på Gruppsom innehåller komponenten (eller anslutning) Typer som du vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

6. Klicka på ok knapp.

7. I dialogrutan som visas klickar du på Ja knapp.

För att ställa in tillstånd för en fastighet

1. Expandera Typergren i trädet.

2. Expandera Komponent (eller anslutning) Typergren i trädet.

3. Bygga ut Grupperdär så är nödvändigt.

4. Välj komponent (eller anslutning) Skriv som innehåller den egendom som du vill att ange behörigheter för.

5. I fönstret Egenskaper högerklick på Fast egendomdu vill ställa in behörigheter för och välj Redigera behörigheter.

6. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

7. Som standard kommer du att se att läsa och uppdatera behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

Notera

Egenskaper som har haft Update tillstånd bort visas i kursivi fönstret Egenskaperoch deras värderingar kan inte uppdateras med den rollen. Även förmågan att ändra detaljer om en fastighet (t.ex. namn, enheter etc) kräver både Uppdatering tillstånd på fastigheten och Designer add-on.

8. Klicka på ok knapp.

För att ställa in tillstånd för en mall

1. Expandera Mallargren i trädet.

2. Bläddra till Mallatt du är intresserad av.

3. Högerklick på Malldu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att Läs tillstånd finns. Ta bort tillstånd av avmarkerakryssrutan.

6. Klicka på ok knapp.

För att ställa in tillstånd för en Viewpoint

1. Expandera Synpunktergren i trädet.

2. Bygga ut Grupperdär så är nödvändigt.

3. Högerklick på Synpunktdu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

6. Klicka på ok knapp.

För att ställa in tillstånd för en arkitektur

1. Expandera Arkitekturergren i trädet.

2. Expandera till Arkitekturatt du är intresserad av.

3. Högerklick på Arkitekturdu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att Läs tillstånd finns. Ta bort tillstånd av avmarkerakryssrutan.

6. Klicka på ok knapp.

För att ställa in tillstånd för en Katalog

1. Expandera Katalogergren av arkitektur du är intresserad av.

2. Bygga ut Grupperdär så är nödvändigt.

3. Högerklick på Katalogdu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

6. Klicka på ok knapp.

För att ställa in tillstånd för en Matris

1. Expandera Matrisergren av arkitektur du är intresserad av.

2. Bygga ut Grupperdär så är nödvändigt.

3. Högerklick på Matrisdu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

6. Klicka på ok knapp.

För att ställa in tillstånd för ett diagram

1. Expandera Diagramgren av arkitektur du är intresserad av.

2. Bygga ut Grupperdär så är nödvändigt.

3. Högerklick på Diagramdu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

Notera

Även om du kan ställa in CRUD behörigheterna direkt för ett diagram, bör det noteras att behörigheterna elementen på diagrammet kan påverka behörigheter för själva vyn. Till exempel, om det finns även bara en del på vilken vy som har haft sin Läs eller Uppdatera tillstånd avlägsnas sedan diagrammet kommer att ha sin Update tillstånd bort. Det här är för att; a) elementen på uppfattningen att har haft sin Läs tillstånd bort kommer inte att visas på vyn lämnar "white space" där du annars placera några nya element om vyn var uppdaterings, och b) elementen på uppfattningen att har haft sin Update tillstånd bort kan då ha andra element föll på dem att bli barn om vyn var uppdateringsbar. Dessutom, skapa och uppdatera tillstånd för ett diagram kräver att alla element på vyn har läsrättigheter och komponenterna har Uppdatera tillstånd (detta beror på att flytta en komponent på en annan komponent, måste du kunna uppdatera det eftersom det kommer blir ett barn).

6. Klicka på ok knapp.

För att ställa in tillstånd för en 3D-vy

1. Expandera 3D Översiktergren av arkitektur du är intresserad av.

2. Bygga ut Grupperdär så är nödvändigt.

3. Högerklick på 3D-vydu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

6. Klicka på ok knapp.

För att ställa in tillstånd för en Diagram

1. Expandera Diagramgren av arkitektur du är intresserad av.

2. Bygga ut Grupperdär så är nödvändigt.

3. Högerklick på Diagramdu vill ställa in behörigheter för och välj Redigera behörigheter.

4. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

5. Som standard kommer du att se att skapa, läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

6. Klicka på ok knapp.

Se också

Hur en arkitektur representerat i ABACUS?


Att arbeta med instrumentpaneler

Navigering: Administration>

Att arbeta med instrumentpaneler

Skicka kommentarer om detta ämne.

ABACUS projekt kan ha någon form av vyer (t.ex. diagram, Diagram etc) sparas som en instrumentpanel och dessa sparade instrumentpaneler kan vara inställd som standard börjar "skärm" på att öppna ett projekt och / eller tilldelas en specifik användargrupp och presenteras för medlemmarna i användargruppen när de loggar in på en kulram projekt.

Notera

För att konfigurera instrumentpaneler i en kulram projekt användarlicens behöver administratörs kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

Tittar instrumentpaneler

Ett exempel Application Portfolio Management (APM) instrumentbrädan

Om du vill visa en sparad Dashboard

1. Välj Se| Instrumentpaneler

2. Välj en sparad instrumentpanel från listan över tillgängliga instrumentpaneler.

Notera

När du har valt ABACUS kommer att bygga de synpunkter som krävs för instrumentbrädan och det kan ta några sekunder. Var tålmodig.

Hantera instrumentpaneler

Hantera instrumentpaneler

För att skapa en ny Dashboard

1. Öppna de nödvändiga synpunkter och arrangera och docka windows som krävs för den instrumentbräda.

2. Välj Se| Instrumentpaneler| Hantera instrumentpaneler ...

Notera

Om du inte ser Hantera Instrumentpaneler menyalternativet då du inte har administratörs kapacitet. Kontakta din lokala ABACUS administratör eller Avolution Stöd om du behöver den här funktionen.

3. I dialogrutan som visas väljer du Skapaknappen och ange Dashboard namn i Skapa ny Dashboard-dialogen.

4. Klicka på ok knapp.

För att radera ett befintligt Dashboard

1. Välj Se| Instrumentpaneler| Hantera instrumentpaneler ...

2. I dialogrutan som visas väljer du Dashboard du vill ta bort från listan och välj Radera knapp.

Notera

Radera en instrumentpanel kommer också att ta bort alla användar grupparbeten till det instrumentbräda.

3. Klicka på ok knapp.

Om du vill ersätta en befintlig Dashboard

1. Öppna de nödvändiga synpunkter och arrangera och docka windows som krävs för att ersätta instrumentbräda.

2. Välj Se| Instrumentpaneler| Hantera instrumentpaneler ...

3. I dialogrutan som visas väljer du Dashboard du vill ersätta i listan och välj Byta ut knapp.

4. Klicka på okknappen för att bekräfta Dashboard Ersatt dialogrutan.

Om du vill tilldela en Dashboardsom standard startskärmen

1. Välj Se| Instrumentpaneler| Hantera instrumentpaneler ...

2. I dialogrutan som visas väljer du Dashboard från listan som du vill tilldela som standard start "skärm"och välj Tilldela... knapp.

3. I dialogrutan som visas väljer du inträde i användargrupper kolumnen.

Notera

Endast en instrumentpanel kan tilldela som start "skärm" så åter uppdrag kommer att ta bort uppdrag från tidigare instrumentbrädan.Dessutom, om användaren loggar in som medlem i en användargrupp som har en tilldelad instrumentpanelen då den tilldelade instrumentpanelen öppnas i stället för standardprojektet instrumentbräda.

4. Klicka på ok knapp.

Om du vill tilldela en användargrupp till en Dashboard

1. Välj Se| Instrumentpaneler| Hantera instrumentpaneler ...

2. I dialogrutan som visas väljer du Dashboard från listan som du vill tilldela en användargrupp till och välj Tilldela... knapp.

3. I dialogrutan som visas väljer du User Group (eller grupper)du vill tilldela instrumentpanelen som "startskärmen för.

Notera

Om samma User Group tilldelas flera instrumentpaneler sedan första uppdrag i listan kommer att användas.

4. Klicka på ok knapp.

Att bort tilldelningen en användargrupp från en Dashboard

1. Välj Se| Instrumentpaneler| Hantera instrumentpaneler ...

2. I dialogrutan som visas expandera Dashboard objekt i listan som du vill ta bort tilldelningen en användargrupp från.

3. Välj användargrupp som du vill ta bort tilldelningen och välj Bort tilldelningen knapp.

4. Klicka på ok knapp.

Ställa in behörigheter

Behörigheter kan ställas in för instrumentpaneler för att möjliggöra instrumentbrädan för att vara synlig, Uppdaterbar och / eller raderbaratill givna användargrupper.

Permissions Management

För att ställa in tillstånd för ett Dashboard

1. Välj Se| Instrumentpaneler| Hantera instrumentpaneler ...

2. I dialogrutan som visas väljer du Dashboard från listan som du vill ställa in behörigheter för och välj Behörigheter ... knapp.

3. I dialogrutan som visas klickar du på Lägg till...knappen och välj Gruppdu vill lägga till genom att antingen dubbelklicka på den eller markera den och klicka på ok knapp.

4. Som standard kommer du att se att läsa, uppdatera och ta bort behörigheter är alla tillgängliga. Ta bort behörigheter genom avmarkerarelevanta kryssrutor.

5. Klicka på ok knapp.

Se också

Anpassa ABACUS gränssnittet | Arbeta med Behörigheter


Registrera ABACUS

Navigering: Referens>

Registrera ABACUS

Skicka kommentarer om detta ämne.

När du först starta ABACUS (eller efter en tillfällig licens har gått ut) måste du registrera programmet mot Avolution licensserver med hjälp av en unik licensnyckel från din lokala ABACUS administratör eller direkt från Avolution. Om du inte har en licensnyckel kontakta din lokala ABACUS administratör eller Avolution Stöd .

För att registrera med en licensnyckel

1. Efter installation, starta ABACUSantingen genom att dubbelklicka på genvägen på skrivbordet eller från startmenyn i Windows.

2. I dialogrutan Registrering som visas anger 26 tecken licensnyckelfrån din lokala ABACUS administratör eller Avolution stöd , Eller klicka Bläddra...och välj undertecknade .dlsc filen återvänt från Avolution Stöd enligt anmärkningen i steg 4 nedan. Om du använder en korrekt undertecknad .dlsc fil ABACUS ska börja enligt steg 5 nedan.

Dricks

Du kan klistra in licensnyckeln i dialogrutan genom att kopiera den till Windows Urklipp och sedan välja bakgrunden i dialogrutan och trycka på Ctrl + V.

Dialog Registrering

3. Klick okoch om licensnyckeln är en giltig ABACUS licensnyckelABACUS kommer nu försöka kontakta Avolution licens server för att autentisera licensnyckeln.

Notera

Om du får ett Installation Code är Ogiltigregistreringsfel är det mest troligt att du har skrivit in fel kod. Försök att kopiera och klistra in koden enligt spetsen som nämns ovan.

Kontakta Avolution License Server

4. Klick okoch efter en kort period av tid ABACUS bör registrera framgångsrikt.

Framgångsrik Registrering

Notera

Om du får en Kan inte kontakta licensservernregistreringsfel är det mest troligt att en brandvägg (eller andra säkerhetsåtgärder) i ditt nätverk förhindrar tillgång till Avolution s licensserver. Klick ok, Spara .dlsc filen till din lokala dator och sedan antingen maila .dlsc filen till Avolution Stöd och invänta vidare instruktionereller försöker logga licensen filen själv med hjälp av följande webbadress - http://licensing.avolutionsoftware.com/LicenceSign/ .

Kan inte kontakta licensservern

Öppna Licenstecknandet webbsida

Manuell Licens signering webbsida

Alternativt, om du får Denna installation kod har använts på fler system än tillåtet av licensenregistreringsfel är det troligt att din lokala dator har byggts om sedan du senast registrerad ABACUS eller om du försöker att registrera med en annan användares licensnyckel. Kontakta din lokala ABACUS administratör eller Avolution Stöd .

Installation kod har redan använts

5. Klick okoch om det är registrerat framgångsrikt ABACUS bör öppnas med Välkommen Screen .

Se också

Avolution Stöd | Vad KULRAM göra?


ABACUS Installation Förutsättningar

Navigering: Referens>

ABACUS Installation Förutsättningar

Skicka kommentarer om detta ämne.

Information angående Visio Import och Excel Import / Export

ABACUS kräver att Microsoft Office installeras för att utföra Excel Import / Export och Visio importverksamhet. Kontrollera att Microsoft Office 2003 eller senareär korrekt installerat. Om du upplever ytterligare problem, kontakta Avolution Stöd .

För att kunna utföra Visio Import och Excel Import / Export verksamhet använder ABACUS Microsoft Office Primary Interop Assemblies (PIA: s). ABACUS närvarande kommer packat med aggregaten är nödvändiga för att utföra Excel Import / Export och Visio Import.

Information angående SQL Server Import

ABACUS kräver att Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014installeras för att starta ett nytt projekt från SQL Server. Kontrollera att Microsoft SQL Server 20052008, 2008 R2, 2012 eller 2014är korrekt installerat. Om du upplever ytterligare problem, kontakta Avolution Stöd .

Fel Öppning 3D Visualisations

Om ABACUS 3D Viewer inte fungerar för dig, kan du missa SlimDX DirectX Runtime (installeras som en del av den fullständiga ABACUS EXE installation). Detta kan laddas ner här . Om du har en 64-bitars version av Windows, kan du också behöva installera detta .

Fel Redigering KULRAM Beställnings Rapporter

Redigerar ABACUS "Anpassade rapporter kräver Report Builder 3.0 som ska installeras. ABACUS och Report Builder är byggda på Microsofts .NET Framework 4.0, och medan de båda inte kräver Microsofts .NET Framework 3.5, har Microsoft felaktigt konfigurerad Report Builder MSI till endast fortsätta om Microsofts .NET Framework 3.5 är installerat.

Följaktligen har Avolution en redigerad version av Report Builder installations MSI-fil som inte kräver Microsoft .NET Framework 3.5, kan detta hämtas här .

Den ursprungliga Microsoft Report Builder MSI kan laddas ner här . Om du inte redan har Microsoft .NET Framework 3.5 som det kommer att kräva, kan du ladda ner det här . Obs! För flera installationer, offline installation av Microsofts .NET Framework 3.5 från här kan vara mer lämpligt.


Kommandoradsalternativ

Navigering: Referens>

Kommandoradsalternativ

Skicka kommentarer om detta ämne.

Du kan utföra olika ABACUS operationer direkt från kommandoraden med den vanligaste operationen är att öppna ett specifikt projekt fil och publicera den på HTML.

Närmare bestämt är kommandoraden användning av ABACUS enligt följande;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ användare "USER" / pass "PASS"]

Argument | Beskrivning
ProjectFile | Den ProjectFile kan vara antingen en kulram projekt fil (.abacus), bibliotek fil (.abacuslib), XML-fil (.xml) eller MS Access DB (.mdb) och den angivna filen kommer antingen att öppnas (om .abacus eller .abacuslib ) eller ett nytt projekt skapas (om xml eller MDB-fil).
OptionalFile | Den OptionalFile kan vara antingen en kulram script (.abacusscript, .vb eller .cs), makro (.abacusmac) eller biblioteksfilen (.abacuslib) och den angivna filen kommer antingen köras efter att ha öppnat ProjectFile (om .abacusscript, .vb eller .cs eller .abacusmac) eller öppnas helt enkelt (om .abacuslib).
/ exitOnCompletion | Kommer att lämna ABACUS och vid behov spara och begå några ändringar i öppna .abacus projekt på slutförandet av alla skript eller makro. Obs: Denna flagga är små och stora bokstäver så se till att använda ett versalt "O" och "C" i texten som visas.
/ dontShowDialogs | Kommer att förhindra ABACUS Enterprise Edition (EE) dialoger uppdatering anmälan från att visas när du öppnar ett projekt. Obs: Denna flagga är små och stora bokstäver så se till att använda ett versalt "S" och "D" i texten som visas.
/ användare "USER" / pass "PASS" | Användarnamnet ANVÄNDARE och lösenord PASS kommer att användas för att logga in till projektet med, överskrider alla sparade inloggningsuppgifter. Obs: Dubbla citattecken måste placeras runt användaren och PASS flaggor och två dubbla citattecken kan användas för att undkomma citationstecken i antingen användaren eller PASS flaggor.

T.ex.;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.vb"/ exitOnCompletion / dontShowDialogs / användare "Public" / pass "123456"

när löpa från den katalog där de ABACUS.exe binär är belägen vilja öppna Exempel projektet och logga in som användare Offentligt med lösenord 123456 (såsom beskrivits här ), Publicera den till HTML och stäng sedan projektet alla utan att visa några dialogrutor längs vägen (t.ex. "Update Framgångsrik" eller "Inga uppdateringar tillgängliga" för Enterprise-projekt).

T.ex.;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalog Excel importera.vb"/ exitOnCompletion / dontShowDialogs

när löpa från den katalog där de ABACUS.exe binär är belägen vilja öppna Exempel projektet och importera "Servrar (2014 Faktisk) .xlsx" MS Excel-fil i "Servrar" katalog över "2014 Faktisk" arkitektur för projektet utan att visa några dialogrutor längs vägen och sedan stänga projektet på färdigställandet. Om operationen gör ändringar i projektet sedan när du stänger ändringar sparas lokalt och om en Enterprise projekt åtagit sig att Enterprise Server.

Notera

Var noga med att använda rätt dubbla citattecken eftersom det finns flera i standard ASCII och Windows Kommandotolken kommer bara att fungera korrekt med den rätta. Den korrekta dubbla citatteckenkoden är Decimal 34 (Hexadecimal 22).Detta är vad som används i exemplet ovan så tveka inte att kopiera / klistra in den därifrån.


Titelsida

KULRAM

Disclaimer

Avolution Pty Ltd gör inga utfästelser eller garantier med avseende på den här handboken och i den utsträckning det är tillåtet enligt lag, uttryckligen begränsar dess ansvar för brott mot någon garanti som kan vara underförstått till utbyte av denna handbok med en annan. Vidare, Avolution Pty Ltd förbehåller sig rätten att revidera denna publikation när som helst utan att ådra sig en skyldighet att meddela någon person för översynen.

Upphovsrätt

Copyright 2001-2015Avolution Pty Ltd. All rights reserved.

Varumärken

Avolution Pty Ltd har gjort allt för att leverera varumärkesinformation om företagsnamn, produkter och tjänster som nämns i den här handboken. Varumärken som visas nedan erhölls från olika källor.

Microsoft Windows, Access, Visio, Excel, SQL Server och Internet Explorerär varumärken som tillhör Microsoft Corporation.

Allmänt meddelande:

Vissa produktnamn som används i denna handbok används endast i identifieringssyfte och kan vara varumärken som tillhör respektive företag.

December 2015Edition för Avolution ABACUS Version 4,5.

Manuell Revision 1.0

Genereras, skrivas ut och bunden i Australien.