Bir bileşen, bağlantı veya türüne önceden ayarlanmış özellikler ekleme

Navigasyon: Mimarinizi doldurma> Özellikler>

Bir bileşen, bağlantı veya türüne önceden ayarlanmış özellikler ekleme

Yorum gönder bu konuda.

Özellikleri standart kütüphaneleri belirtilen ve mimaride başka bir şey atanabilir. Bu kütüphaneler şekilde bilinmektedir Standartlar. Kullanarak Standartlar, Yalnızca belirli sistem özellikleri toplamak gerekir - standart özellikler var zaten.

Örneğin, Microsoft Windows 2000 standart performans karakteristikleri olarak kaydedilebilir Standartve herhangi bir bileşeni tahsis (ya da bağlantıları değil, tipik olacağını) Microsoft Windows 2000 işletim sistemi kullanıyorsanız.

Bir eklemek için standartBir bileşen, bağlantı veya türüne

1. Sağ tıkbileşeni / bağlantı / türüne.

2. Seçin Atamak Standart.

3. Seçinbir StandartListeden.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | Bir bileşen, bağlantı veya Çeşidi özelliklerini değiştirme | Agrega özellikleri

© 2001-2015 Avolution Pty Ltd. Tüm hakları saklıdır.


Agrega özellikleri

Navigasyon: Mimarinizi doldurma> Özellikler>

Agrega özellikleri

Yorum gönder bu konuda.

Operasyon "Agrega Özellikler"Seçtiğiniz ana öğenin özelliklerini içine sonucu birbirine benzer özellikler değerleri ekleyin ve yazma (veya eklemek) için izin verir. Ayrıca toplama kapsamını tanımlamak için izin verir ve tüm alt elemanların ya da özelliklerini güncellemek isteyip.

Agrega özelliklerine

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Bir eleman üzerinde toplanmasını yapmak için hangi (bir mimariyi, bir bileşen veya bir bağlantı) sağ tıklayın ve seçin Agrega Özellikleri.

3. (Agrega Seçenekleri birini seçinTüm Alt Düzeyleri Traverse veya Sadece Doğrudan Alt Düzey). Eğer seçtiyseniz Tüm Alt Düzeyleri Traverse, Ayrıca edip seçeneği tercih edebilir Güncelleme Alt Düzeyleri.

o Tüm Alt Düzeyleri Traversetoplama kapsamı seçtiğiniz öğenin altındaki tüm düzeylerinde unsurları içerecektir anlamına gelir.

o Güncelleme Alt DüzeyleriAyrıca seçeneği seçtiyseniz sadece yapılabilir Tüm Alt Düzeyleri Traverse. Bu aşağıdan yukarıya doğru özellikleri bir araya ederken, her düzeyde toplam sonucu da mukabil elemanların her birine güncellenecektir anlamına gelir.

o Sadece Doğrudan Alt Düzeyşirketinden seçilen elemanının aşağıdaki elemanlardan sadece özellikleri toplanır anlamına gelir.

o Seçin İçer StandartÖzelliklerEğer tanımlı özellikleri istiyorsanız Standartlar dahil edilmesi. Aksi takdirde, her bir bileşen örneğine özgü yalnızca özellikleri kullanılacaktır.

4. Eğer toplamak istediğiniz özellikleri seçin. Bunlar halinde gruplandırılmış onların Türleri.

5. Tıkla Sonrakidüğmesine basın.

6. Edip seçeneği seçin Üzerine yazma Değerler veya Değerler ekleSeçili öğe içine.

o Üzerine yazma Değerlerseçilen elemanın özelliklerini doğrudan sonuçları yazacağım.

o Değerler ekleseçilen elemanın mevcut özelliklerine sonuçları katacak.

Ayrıca bakınız

Bir bileşen, bağlantı veya türüne önceden ayarlanmış özellikler ekleme | Bir bileşen, bağlantı veya Çeşidi özelliklerini değiştirme | Senin mimarisi Değerlendirilmesi


Mimarlık Diff ve Eşitleme

Navigasyon: senin mimarisi analiz>

Mimarlık Diff ve Eşitleme

Yorum gönder bu konuda.

Görsel 'diff' iki mimarileri kullanarak yapabilirsiniz, ya evrimler veya bazal mimarileri gibi 2 veya daha fazla mimarileri varsa katalog veya şema Karşılaştırma veya Mimarlık Diff özelliği. Bu keşfetme / yeniden keşfetmek size mimarileri gelişmeye ve ABACUS'te de yol haritalarının geliştirilmesi olarak başka bir mimariye yapılan hassas değişiklikleri için özellikle yararlıdır.

Karşı Bir diyagram üzerinden başka bir mimari ile 'diff' göstermek

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Seni olun var Projede en az 2 mimarileri.

3. Başka bir mimariye karşılaştırmak istediğiniz diyagramı açın.

4. Diyagram araç çubuğunda 'Başka mimari içeriğine bu diyagramı karşılaştırın' butonuna tıklayın.

5. Karşılaştırmak için açılan listeden başka mimari seçin.

6. Sen, örneğin Şeması araç çubuğunda 'Farklar' butonuna tıklayarak ve seçenekleri seçimini kaldırarak gösterilen hangi farklar filtre edebilirsiniz Değişti / Katma / Bilinmeyen ve Belirsiz / Senkronizasyon Tavsiye/ Keep Tavsiye.

Not

Diyagram üzerinde Bileşenler ve bağlantıları vurgulanır kırmızı, yeşil veya mor nerede geçerli diyagram ve diğer mimaride içeriğine görünür içerik arasında farklılıklar vardır. Kırmızı (aşağıda bakınız) farklılıkları senkronize önerilir burada kullanıldığında, Yeşil farklılıkları eşitlemek için tavsiye edilmez nerelerde kullanılır, onları (aşağıya bakınız) tutmak ve Mor ABACUS farklılıklar (aşağıya bakınız) eşitleme hakkında bir öneri yapamaz nerede kullanılır. Sadece diyagram üzerinde görünür içerik bir açıklama, bir depo özelliği değeri gösteriyor bu yüzden eğer karşılaştırılır ve bu değer verilen bileşen değiştirilir veya bağlantı gösterilecektir soluk kırmızı, soluk yeşil veya mor soluk ve gösterilen bir '*' sembolü sol üst diğer bazı temel depo özellik değerinin o zaman hiçbir gösterge verilecek bir açıklama gösterilen varlık değildir değişirse, ancak bileşenleri için. Geçerli diyagram üzerinde oluşur, ancak karşılaştırma mimarisinde bulunan hiçbir maç gösterilecektir İçerik Güçlü kırmızı, güçlü yeşil veya mor güçlüve bir '+' sembolü bileşenleri için üst solda gösterilen. Eşleştirme bileşeni tip ve isim bileşen veya bağlantı türü veya adı başka mimarisinde değişmişse hiçbir maç bulunacak şekilde yapılır. Güvenilir diğer mimarisinden ek içerik geçerli şemasında gösterilen olurdu olmadığını belirleme yolu yoktur gibi (örneğin sağda karşılaştırma mimarisinden bir şemada, aşağıda gösterildiği gibi 2 bileşenleri arasındaki ek arayüz), bu farklar değil (aşağıda başına kataloglar için gösterilmiştir) diyagramları gösterilmiştir. Her değiştirilen öğenin üzerine gelerek araç ipucu farkı gösterecektir. Diyagram üst sol '*' sembolü üzerine gelerek diyagram içeriği ve diğer mimari içeriği arasındaki değişiklikleri (veya değişiklikleri) bir özetini sunar.

Renk Efsane

· Yeşil gösterir farklılıkları eşitlemek için tavsiye edilmez öğeler, onları tutmak için.

· Kırmızı gösterir farklılıkları eşitlemek için tavsiye edilir öğeler.

· Mor gösterir ABACUS farklılıkları eşitleme hakkında bir öneri yapamaz ürün.

Karşı Bir diyagram üzerinden başka bir ile, bir mimariden ('senkron') içeriğini senkronize

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Seni olun var Projede en az 2 mimarileri.

3. Diyagramı açın başka bir mimariye karşılaştırmak istediğiniz.

4. Diyagram araç çubuğunda 'Başka mimari içeriğine bu kataloğu karşılaştırın' düğmesine tıklayın.

5. Karşılaştırmak için açılır listeden başka mimari seçin.

Not

Şekilde ABACUS kataloğunda 2 mimarileri arasındaki 'diff' gösteriyor için yukarıya bakın. Özellikle how Kırmızı nereye kullanıldığı olduğunufarklılıkları Sync tavsiye Yeşil nerede kullanılır değilfarklılıkları eşitlemek için tavsiye ve Mor ABACUS farklılıkları eşitleme hakkında bir öneri yapamaz nerelerde kullanılır.

6. Bir 'diff' gösteren şema elemanını (ya da Shift veya Sync All diyagram tuval kullanarak elemanları) sağ tıklayın ve Eşitleme menü öğesini seçin.

Not

Herhangi bir senkronizasyon değişiklikler yalnızca o anda odak katalog ait mimari uygulanacaktır. Diğer mimarisinde bir katalog kullanmanız gereken diğer mimari değişiklikleri uygulamak için. Ayrıca, kullanıcılar yalnızca eşitleme değişiklikleri uygulamak mümkün olacak onlar Bunu yapmak için izniniz .

Not

Eğer menü öğesini sağ tıklatın yere bağlı olarak tam senkronize olacak ne rehberlik gösterecektir.Örneğin Sağ tıklayarak şemada tek bir bileşen sadece o bileşeni senkronize olacak. Oysa diyagram tuval sağ tıklatıp Sync Tüm anda gösterilen farklılıkları eşitler seçilmesi.

Karşı Bir katalog üzerinden başka bir mimari ile 'diff' göstermek

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Seni olun var Projede en az 2 mimarileri.

3. Başka bir mimariye karşılaştırmak istediğiniz kataloğu açın.

4. Katalog araç çubuğunda 'Başka mimari içeriğine bu kataloğu karşılaştırın' butonuna tıklayın.

5. Karşılaştırmak için açılan listeden başka mimari seçin.

6. Sen Şeması araç çubuğundaki ve unselecting seçenekleri gibi üzerinde 'Farklar' butonuna tıklayarak gösterilen hangi farklar filtre edebilirsiniz Değişti / Katma / Bilinmeyen ve Belirsiz / Senkronizasyon Tavsiye/ Keep Tavsiye.

Not

Katalogda Hücreler vurgulanır kırmızı, yeşil veya mor Geçerli katalogda içerik ve diğer mimaride eşleşen içerik arasında farklılıklar vardır nerede. Kırmızı (aşağıda bakınız) farklılıkları senkronize önerilir burada kullanıldığında, Yeşil farklılıkları eşitlemek için tavsiye edilmez nerelerde kullanılır, onları (aşağıya bakınız) tutmak ve Mor ABACUS farklılıklar (aşağıya bakınız) eşitleme hakkında bir öneri yapamaz nerede kullanılır. Şu anda gösterilen satır ötesinde bir satır veya sonra hiçbir fark belirtilecektir bir fark vardır vizyonda olmayan bir sütununda bir değer bir fark olup olmadığını böylece sadece katalogda görünen satırlar ve sütunlar karşılaştırılmıştır. Tek bir hücrede değer hücre sınır vurgulanır karşılaştırma mimaride eşleşen hücre ile farklı olduğu. Sütun başlığı ve satır seçici de gölgeli olacak mor solukve '*' sembolü ile gösterilir. Bunlar '*' sembolleri sırasıyla sütun veya satırdaki sonraki fark atlamak için tıklandığında olabilir. Geçerli katalogda oluşur ama hiçbir maç karşılaştırma mimarisinde bulunan Satırlar vurgulanır solda ve tüm satırın sınırında satır seçici bir '+' sembolü ile gösterilir. '-' Soldaki satır seçici sembol sınır içinde (aynı filtreler vb yani) katalog karşılaştırılması mimarlığın sürümünde meydana olurdu ama hiçbir maç cari mimarisinde bulunan Satırlar bir ile gösterilir tüm satırı vurgulanır ve tüm satırları hücrelerin içeriği gösterilir mor solukve vurdu-yoluyla, mesela 6 pm 08:00. Eşleştirme bileşeni tip ve isim bileşen veya bağlantı türü veya adı başka mimarisinde değişmişse hiçbir maç bulunacak şekilde yapılır. Her değiştirilen öğenin üzerine gelerek araç ipucu farkı gösterecektir. Değişiklikleri (veya değişiklikleri) diyagram içerik arasında bir özetini ve diğer mimari içeriği diyagramın üst sol '*' sembolü üzerinde sağlar gezinip.

Renk Efsane

· Yeşil gösterir farklılıkları eşitlemek için tavsiye edilmez öğeler, onları tutmak için.

· Kırmızı gösterir farklılıkları eşitlemek için tavsiye edilir öğeler.

· Mor gösterir ABACUS farklılıkları eşitleme hakkında bir öneri yapamaz ürün.

Karşı Bir katalog üzerinden başka bir ile, bir mimariden ('senkron') içeriğini senkronize

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Seni olun var Projede en az 2 mimarileri.

3. Başka bir mimariye karşılaştırmak istediğiniz kataloğu açın.

4. Katalog araç çubuğunda 'Başka mimari içeriğine bu kataloğu karşılaştırın' düğmesine tıklayın.

5. Karşılaştırmak için açılır listeden başka mimari seçin.

Not

Şekilde ABACUS kataloğunda 2 mimarileri arasındaki 'diff' gösteriyor için yukarıya bakın. Özellikle how Kırmızı nereye kullanıldığı olduğunufarklılıkları Sync tavsiye Yeşil nerede kullanılır değilfarklılıkları eşitlemek için tavsiye ve Mor ABACUS farklılıkları eşitleme hakkında bir öneri yapamaz nerelerde kullanılır.

6. Hücre, sütun sağ tıklayın veya 'diff' gösteren başlığı (ya da birden çok öğe her şey için Shift veya Ctrl + A kullanılarak) satır ve Eşitleme menü öğesini seçin.

Not

Herhangi bir senkronizasyon değişiklikler yalnızca o anda odak katalog ait mimari uygulanacaktır. Diğer mimarisinde bir katalog kullanmanız gereken diğer mimari değişiklikleri uygulamak için. Ayrıca, kullanıcılar yalnızca eşitleme değişiklikleri uygulamak mümkün olacak onlar Bunu yapmak için izniniz .

Not

Eğer sağ tıklayın (yani hücre, sütun veya satır başlığı) menü öğesi tam ne olup bittiğini rehberlik gösterecektir Senkronize edilecek yere bağlı.Örneğin Sadece bu özelliği veya ekli bileşeni senkronize olacak katalogda tek bir özellik ya da bağlı bileşen hücreyi sağ tıklayarak. Oysa başlık bir satır sağ tıklayarak (veya Shift kullanarak başlıklar) tüm satır (veya satırları) senkronize olacak. Bir sütun başlığı o sütundaki tüm farklılıkları eşitler sağ tıklayarak.

Bir görüntülemek için 'diff'2 bütün mimarileri

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Seni olun var Projede en az 2 mimarileri.

3. Seçin Araçlar| Mimarlık Diff ....

4. Kimden / birinci ve ikinci / mimarileri için karşılaştırmak için seçin Görüntülenen iletişim kutusunda.

5. Tıklayın tamamdüğmesine basın.

Mimarlık Diff

Renk Efsane

· YeşilDüğüm mimarisi için / ikinci eklendiğini gösterir.

· KırmızıDüğüm mimarisi için / ikinci silindiğini gösterir.

· Mavidüğüm mimarisi için ikinci farklı özelliklerini (örneğin özelliklerini veya standartlara) / sahip olduğunu gösterir.

· Sarıdüğüm yaygınlaştırılmalıdır böylece düğüm ikinci / mimarlık için kendi çocuklarının farklılıkları olduğunu gösterir.

Not

Bir düğüm seçildiğinde detayları ve daha fazla bilgi Farklar Özet panelinde farklılıklara verilen görmek için tüm düğümler üzerine sağ tıklayın ve "Explorer'da göster" olabilir.

Ayrıca bakınız

Senin mimarisi analiz | Bir tepki süresi grafiği görüntüleniyor | Senin gelişti mimarileri bir saçılım matrisi görüntüleme | Senin mimarisi Gelişen


Bir bileşen, bağlantı veya Çeşidi özelliklerini değiştirme

Navigasyon: Mimarinizi doldurma> Özellikler>

Bir bileşen, bağlantı veya Çeşidi özelliklerini değiştirme

Yorum gönder bu konuda.

Özellikler tanımladığınız sistem gereksinimleri veya ABACUS 'değerlendirmelerin sonuçları genellikle bulunmaktadır. (ABACUS değerlendirmelerini gerçekleştirdiğinde, geri dosyaya özelliklerini yazar.) Bir başka deyişle, özellikleri sistem hakkında bildiğiniz şeyler, ya da öğrenmek için ABACUS kullanan şeylerdir.

Bir bileşen, bağlantı veya Çeşidi özellik değerini değiştirmek için

1. Tıklayınbileşeni / Bağlantı / türüne (özellikleri sağ Properties penceresinde görüntülenir).

2. TıklayınDeğiştirmek istediğiniz özelliği vurgulamak için.

3. Tipyeni bir değer.

Önemli

Ayrıca, birçok özellikleri kullanılarak tanımlanır Standartlar . Bir dahilinde bir özellik değiştirerek Standart, Sen sadece geçerli nesneyi değiştirmek, ayrıca usta değiştirmek Standart (altında At StandartlarAğacın üst). Bunu yapmadan önce, diğer bileşenler, bağlantılar veya türleri kullanarak hangi kontrol Standart, Değişim kendileriyle alakalı olmayabilir çünkü- Bunun için Başvurular penceresini kullanabilirsiniz.

Bahşiş

Sen ağaç (ve tersi) Bileşenleri şube içinde bir bağlantının özelliklerini değiştirebilirsiniz. Yani, örneğin, eğer bir bileşene bağlı hangi bağlantıları bakıyoruz, ve sen can, bir tane değiştirmek zorunda biliyoruz.

(Tip) üzerinden bir bileşen veya bağlantı yeni özellikler eklemek için

Not

Özellikler sadece türleri ve bileşenleri veya Çeşidi bağlantıları eklenebilir bu özellikleri 'miras'.

1. Tıklayıntürüne (özellikleri sağ Properties penceresinde görüntülenir).

2. TıklayınMülkiyet pencerenin üst kısmındaki Add butonunu yeni özellik için özellik ızgara üst kısmında bir satır eklemek için.

3. Ekle TipYeni özellik için.

4. Ekle IsimYeni özellik için.

5. Ekle Varsayılan değerYeni özellik için.

6. Ekle ÜniteYeni özellik için.

7. Yı kur Veri tipiYeni özellik için.

Not

Veri türü alanı bir özellik olabilir, geçerli değerleri sınırlamak için kullanılabilir. Yani; Metin, Tamsayı, Ondalık, Tarih / Saat, Boole veya listesi.

o A Metinmülkiyet karakter sınırsız sayıda vardır ve esasen değeri herhangi bir kısıtlama vardır biridir.Özellik değeri düzgün oluşmuş köprü ise (yani URL'ler biriyle başlamak gerekir 5dizeleri; http: //, https: //, ftp: //, dosya:veya \\ herhangi biralanlarda bir '% 20' ile girilmelidir) Daha sonra link) ctrl + tıklama ile (tıklanabilir.

o Bir TamsayıTesiste tam sayı olmalı ya pozitif ya da negatifProje en bağlı basamak gruplandırma için bir dönem, boşluk, kesme veya virgül içerebilir Bölge ayarları itibaren Dosya | Proje Seçenekleri.Bölge ayarları ve.Net Long.TryParse yöntemi olduğunu Geçerli belirlemek için kullanılır Tamsayıdeğerler.

o A OndalıkTesiste içerebilir nokta veya virgül ondalık simgesi ve proje en bağlı basamak gruplandırma için bir dönem, boşluk, kesme veya virgül içerebilir Bölge ayarları itibaren Dosya | Proje Seçenekleri.Bölge ayarları ve.Net Decimal.TryParse yöntemi olduğunu Geçerli belirlemek için kullanılır Ondalık değerler.

o A Tarih / SaatTesiste Tarih bölümünü veya bir kısmını Zaman ya da her ikisi verir. BölgeAyarlarve Net DateTime.TryParse yöntemi öncelikle geçerli tarih ve / veya saat değerlerini belirlemek için kullanılır. Ancak, eğer varsa Tarih bölümü Günü azından gerektirir ve Ay (Yıl cari yıl olarak kabul edilecektir) ya da Ay ve Yıl parçaları geçerli olabilmesi için. Yani Haziran, 2010 3. Çeyrek hatta sadece 2010 geçersizdir. Ya da eğik çizgi ('/') - farklı bölgesel ayarları ile farklılık olsa da, genellikle Gün, Ay ve Yıl parçaları bir boşluk, virgül, tire ('') ile ayrılabilir. Günlük bir kısmı genellikle ay kısmı tipik olarak 1 ila 12 arası bir tam sayı olduğu 1 ila 31. arasında bir tamsayıdır, ay (örneğin, Ocak, Şubat, Mart) ya da tam bir ay adı için geçerli 3 harfli kısaltma (örneğin, Ocak, Şubat , Mart). > Date-> Takvim - Yıl bölüm tipik olarak 4 basamaklı pozitif bir sayı ama 1, 2 ve 3 haneli yıl Denetim Masası-> Bölge ve Dil Seçenekler-> Bölgesel Seçenekler-> özelleştirin (düğme) ayarlara göre kabul edilir olduğunu. Aşağıdaki gibi tipik olarak yorumlanır; 0-29 1930-1999 ve 100-999 olarak 100-999 kadar 99, 2000-2029 olarak 30 yorumlanır. Böyle 31 Haziran 2010 ve 31/9/2010 geçersiz tarihleri ​​tespit edilecek. Varsa Zaman bölümü isteğe bağlı olarak bir Saat ve Dakika parçası ve Saniye parçası gerektirir. (':') Ve Saniye kısmı ondalık noktasının ile belirtilebilir Saat, Dakika ve Saniye isteğe bağlı parçaları genellikle bir iki nokta üst üste ile ayrılmış ('.'). Geçerli formatlar hakkında daha fazla bilgi için .NET üzerinde Açıklamalar bölümüne bakınız DateTime.TryParse yöntemi .

Bahşiş

Bu bağlı çoğu bölgelerde doğrular bu değerler olarak tarih değerleri yerine sayısal biçimlendirme (yani "7" veya "07") için (yani "Temmuz" veya "Temmuz") en az 3 harfli ay adı biçimi kullanılması tavsiye edilir Proje en üstünde Bölge ayarları itibaren Dosya | Proje Seçenekleri.Yani oldukça "15/7/2010" den "15 Tem 2010" ya da "2010/07/15" kullanılması tavsiye edilir. Bu örnekle, "15/7/2010" "2010/07/15" 'English (United Kingdom)' Ancak "15 Tem 2010" için başarısız olur 'İngilizce (ABD)' için doğrulama başarısız olur ve için geçerdi hem.

o A Booleanmülkiyet Doğru veya Yanlış olabilir.Bu duyarsız böylece DOĞRU veya YANLIŞ da Evet, Hayır, 1, 0, vb herhangi bir özellik kısıtlamaları başarısız olur, ancak kullanılabilir olduğunu.

o A Liste| özellik gibi Low olarak önceden tanımlanmış değerlerin bir koleksiyon izin verir Orta | Yüksek ya da Koru | Yenile | Yeniden tasarlamanız | Retire ve değer aralığı ya virgül veya boru gibi özellik için Birim alanına gelen '|' ayrılmış değerler. Özelliği olarak kabul edilebilir sıra grafikler üzerinde kullanılan ve üzerinde elemanları renk çünkü ne zaman (nominal, aralık veya oran aksine) diyagrams ve değerler basitçe artan (ya da azalan) sipariş kabul edilir 3ds. Bu değerler, grafik eksenleri veya renk aralıkları küçükten büyüğe (ya da azalan) çizilmiştir olduğunu.

8. Veri Türü olarak ayarlanabilir Engelli, Uyarıldı veya Zorunluherhangi herhangi bir karakter kadar hiç yanlış olamaz veriyor Metin, başka ayar Veri Türü alanını sağ tıklatarak.

9. Yı kur GerekliYeni özellik için bayrak.

Not

Gerekli alan bir değer özelliği girilmesi gereken belirtmek için kullanılır. Yani boş veya boş olamaz ki. SahteVarsayılan ve mülkiyet boş veya boş olabilir anlamına gelir Gerçeközellik değerine sahip olmalı ve boş ya da boş olamaz anlamına gelir. Gerekli olduğu ayarlanabilir Engelli, Uyarıldı veya ZorunluTrue olarak ayarlanmış olup olmadığını tarafından Gerekli alan sağ tıklayarak.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | Bir bileşen, bağlantı veya türüne önceden ayarlanmış özellikler ekleme | Agrega özellikleri


Bir bileşen / bağlantının türünü değiştirme

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Bir bileşen / bağlantının türünü değiştirme

Yorum gönder bu konuda.

Komponent ve bağlantı türleri ağırlıklı sınıflandırma amaçları için kullanılır. Senin mimarisi izlerken filtre olarak türlerini kullanabilirsiniz. Örneğin, yerine her şeyi görüntüleme, sadece uygulama bileşenlerini görüntülemek olabilir.

Bir bileşen / bağlantının çeşidini değiştirmek

1. Sağ tıkbileşen ya da bağlantısı.

2. Seçin Değişim Tipi.

3. Listeden farklı bir türü seçin.

Bahşiş

Yazım değiştirdiğinizde, bazı yeni alabilirsiniz Standartlarveya özellikler (Tip ile ilişkili olursa olsun - ağacının dalını Türleri bakınız). Mevcut Standartlar ve özellikleri değişmeden kalacaktır. Kendi yeni türleri oluşturmak ve kendi kombinasyonlarını atayabilirsiniz Standartlar ve onlara özellikleri.

Ayrıca bakınız

Yeni Tip oluşturma | Mimarinizi doldurma - Genel Bakış | Analiz senin mimari


Bir Projesi'nin bölge ayarlarını değiştirme

Navigasyon: Mimarinizi doldurma> Özellikler>

Bir Projesi'nin bölge ayarlarını değiştirme

Yorum gönder bu konuda.

Özellik değerleri Farklı bölgelerde gerektiren belirli biçimlendirme herhangi maç Tamsayı, Ondalık ve Tarih / Saat veri türü kısıtlamaları özellikleri. Avustralya'da Örneğin ondalık "123408 dokuz yedi Fifty Six nokta" Almanya'da bu "123.456,789" olarak represnted olacağını ise, "123,456.789" olarak temsil edilir ve Fransa'da o "olacağını İçin 123 456789 ".Benzer şekilde, ABD'nin "Aralık 1970, ikinci" o 1970-1912 "olarak Polonya'da" 2/12/1970 "olarak ve temsil edilir" 12/2/1970 "gibi kısa tarih olarak ancak Birleşik Krallık'ta temsil edilmektedir -02 ". Buna göre, ABACUS proje başına küresel bir ayar gereklidir bölgeler arasında bir ABACUS projesi ile çalışmak.

Değişmek Bir ABACUS projenin Bölge ayarları

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Seçin Dosya | Proje Seçenekler ... ve iletişim kutusundan görünür seçmek Yöre ve Tamam'a tıklayın. Not: Bölgesel varsayılan için aşağıdaki bölüme bakın.

Not

Gördüğünüz yoksa Proje Seçenekler ... menü maddesio zaman Designer yok ve Yönetici Ayriyetens ve Eğer projenin bölgeyi değiştiremezsiniz.Ayrıca, hiçbir Bölge ayarlanırsa sonra her (Proje Seçenekleri Bölge'de yani 'Yok (Sistem Bölgesi)' dır) Kullanıcının MS Windows geçerli kültür ayarları (yani Bölgesel Ayarlar)işletmeyi doğrulamak için kullanılır.

Bölge varsayılan

Aşağıdaki tabloda ile belirtilen her bir bölge için varsayılan Dosya | Proje Seçenekler ... menü maddesi.Kullanılan sembollerin bir listesi için aşağıdaki tabloya bakınız.

Yöre | Ondalık simgesi | Basamak gruplandırma | Eksi işareti | Kısa zaman | Uzun zaman | AM / PM sembolü | Kısa tarih | Uzun tarih
İngilizce (Avustralya) | . | , | - | HH: mm | SS: dd: ss | AM | PM | gg / aa / yyyy | dd MMMM yyyy
English (United Kingdom) | . | , | - | HH: mm | SS: dd: ss | AM | PM | gg / aa / yyyy | dd MMMM yyyy
İnglizce Birleşik Devletler) | . | , | - | h: mm tt | h: dd: ss tt | AM | PM | M / d / yyyy | dddd, MMMM dd, yyyy
Fransızca (Fransa) | , | alan | - | HH: mm | SS: dd: ss | | | gg / aa / yyyy | dddd d AAAA yyyy
Almanca (Almanya) | , | . | - | HH: mm | SS: dd: ss | | | GG.AA.YYYY | dddd d. AAAA yyyy
İtalyanca (İtalya) | , | . | - | HH: mm | SS: dd: ss | | | gg / aa / yyyy | dddd d AAAA yyyy
İspanyolca (İspanya) | , | . | - | H: mm | H: dd: ss | | | gg / aa / yyyy | dddd, dd 'de' mmmm 'de' yyyy
İngilizce (Kanada) | . | , | - | h: mm tt | h: dd: ss tt | AM | PM | gg / aa / yyyy | AAAA-dd-yy
Fransızca (Kanada) | , | alan | - | HH: mm | SS: dd: ss | | | yyyy-AA-gg | d MMMM yyyy
Arapça (U.A.E.) | . | , | - | ss: dd tt | ss: dd: ss tt | ص | م | gg / aa / yyyy | dd MMMM, yyyy
Arapça (Suudi Arabistan) | . | , | - | ss: dd tt | ss: dd: ss tt | ص | م | gg / aa / yy | gg / AAAA / yyyy
İngilizce (Güney Afrika) | , | alan | - | ss: dd tt | ss: dd: ss tt | AM | PM | yyyy / AA / gg | dd MMMM yyyy
İngilizce (Yeni Zelanda) | . | , | - | h: mm tt | h: dd: ss tt | Sabah | p.m. | d / AA / yyyy | dddd, d MMMM yyyy
İngilizce (Hindistan) | . | , | - | HH: mm | SS: dd: ss | AM | PM | dd-MM-yyyy | dd MMMM yyyy
Almanca (İsviçre) | . | ' | - | HH: mm | SS: dd: ss | | | GG.AA.YYYY | dddd d. AAAA yyyy
Fransızca (Belçika) | , | . | - | HH: mm | SS: dd: ss | | | d / AA / yyyy | dddd d AAAA yyyy
Flemenkçe (Belçika) | , | . | - | H: mm | H: dd: ss | | | d / AA / yyyy | dddd d AAAA yyyy
Çek (Çek Cumhuriyeti) | , | alan | - | H: mm | H: dd: ss | dop |. odp. | G.A.YYYY | d. AAAA yyyy
Danimarka (Danimarka) | , | . | - | HH: mm | SS: dd: ss | | | dd-MM-yyyy | d. AAAA yyyy
Yunanca (Yunanistan) | , | . | - | h: mm tt | h: dd: ss tt | πμ | μμ | d / M / yyyy | dddd, d MMMM yyyy
Fince (Finlandiya) | , | alan | - | H: mm | H: dd: ss | | | G.A.YYYY | d. MMMM'ta 'yyyy
Macar (Hungary) | , | alan | - | H: mm | H: dd: ss | de |. du. | yyyy.MM.dd. | yyyy. AAAA g.
Flemenkçe (Hollanda) | , | . | - | H: mm | H: dd: ss | | | D-M-yyyy | dddd d AAAA yyyy
Norveççe, Bokmål (Norveç) | , | alan | - | HH: mm | SS: dd: ss | | | GG.AA.YYYY | d. AAAA yyyy
Lehçe (Polonya) | , | alan | - | HH: mm | SS: dd: ss | | | yyyy-AA-gg | d MMMM yyyy
Rusça (Rusya) | , | alan | - | H: mm | H: dd: ss | | | GG.AA.YYYY | d MMMM yyyy 'г.'
İsveççe (İsveç) | , | alan | - | HH: mm | SS: dd: ss | | | yyyy-AA-gg | 'den' d MMMM yyyy
Kore (Kore) | . | , | - | tt h: mm | tt h: dd: ss | 오전 | 오후 | yyyy-AA-gg | yyyy '년' M '월' d '일' dddd
İbranice (İsrail) | . | , | - | HH: mm | SS: dd: ss | AM | PM | gg / aa / yyyy | dddd dd MMMM yyyy

Aşağıdaki semboller tarihler ve saatler nasıl görüntüleneceğini belirtmek için kullanılır:

Zaman sembolleri |
h | Saat (ss bir sıfır ile saat görüntüler)
m | Dakika (mm başında sıfır dakika görüntüler)
s | İkinci (ss ile ikinci görüntüleyen sıfır)
tt | A.M. veya P.M.
h / H | 12 veya 24 saat zaman göstergesi
Tarih sembolleri |
d, dd | Gün
ddd, dddd | Haftanın günü
M | Ay
y | Yıl

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | Bir bileşen, bağlantı veya Çeşidi özelliklerini değiştirme | Bir bileşen, bağlantı veya türüne önceden ayarlanmış özellikler ekleme


Komut Satırı seçenekleri

Navigasyon: Referans>

Komut Satırı seçenekleri

Yorum gönder bu konuda.

Sen en yaygın operasyon belirli bir proje dosyasını açın ve HTML yayımlamak olmak komut satırından doğrudan çeşitli ABACUS işlemleri gerçekleştirebilirsiniz.

Aşağıdaki gibi Özellikle ABACUS'te komut satırı kullanımıdır;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ user "KULLANICI" / "PASS" pass]

Argüman | Açıklama
ProjectFile | ProjectFile bir ABACUS proje dosyası (.abacus), kitaplık dosyası (.abacuslib), XML dosyası (.xml) veya MS Access DB (.mdb) ve belirtilen dosya (açılacak ya da olabilir, eğer .abacus veya .abacuslib ) ya da oluşturulan yeni bir proje (.xml veya .mdb dosya varsa).
OptionalFile | OptionalFile ya .abacusscript eğer, .vb (ProjectFile açıldıktan sonra çalıştırmak olacaktır bir ABACUS komut dosyası (.abacusscript, .vb veya .cs), makro (.abacusmac) ya da kitaplık dosyası (.abacuslib) ve belirtilen dosya da olabilir veya .cs veya .abacusmac) ya da basitçe (.abacuslib varsa) açıldı.
/ exitOnCompletion | ABACUS çıkmak ve kaydetmek gerekli ve eğer herhangi bir komut dosyası veya makro tamamlanması açık .abacus projelerine herhangi bir değişiklik taahhüt edecektir. Not: Bu bayrak gösterildiği gibi metinde büyük harfle 'O' ve 'C' kullandığınızdan emin olun, böylece Duyarlı Olgu olduğunu.
/ dontShowDialogs | Bir proje açıldığında göstermesini ABACUS Enterprise Edition (EE) güncelleme bildirimi diyaloglar önleyecektir. Not: Bu bayrak gösterildiği gibi metinde bir büyük harf 'S' ve 'D' kullandığınızdan emin olun, böylece Duyarlı Olgu olduğunu.
/ user "KULLANICI" / "PASS" pass | Kullanıcı adınızı KULLANICI ve şifre PASS herhangi kaydedilmiş kullanıcı kimlik bilgilerini geçersiz kılma, projeye oturum açmak için kullanılacaktır. Not: Çift tırnak KULLANICI ve PASS bayrakları etrafına yerleştirilmesi gerekir ve iki çift tırnak ya KULLANICI veya PASS bayraklar çift tırnak kaçmak için kullanılabilir.

Örneğin;

ABACUS.exe "Data \ Example.abacus" "Scripts \PublishExample.fi"/ exitOnCompletion / dontShowDialogs / user "Kamu" / "123456" pass

ne zaman Dizine nerede çalıştırmak ABACUS.exe ikili olduğunu yer irade açık Örnek proje açıklandığı gibi ve (şifre 123456 kullanıcı Kamu olarak oturum İşte ), HTML yayımlamak ve sonra tüm (Enterprise projeleri için 'Hayır güncellemeleri mevcut' örneğin 'Güncelleme başarılı' ya da) yol boyunca herhangi diyaloglar göstermeden projeyi kapatmak.

Örneğin;

ABACUS.exe "Data \ Example.abacus" "Scripts \Katalog Excel İthalat.fi"/ exitOnCompletion / dontShowDialogs

ne zaman Dizine nerede çalıştırmak ABACUS.exe ikili olduğunu yer irade açık Örnek proje ve yol boyunca herhangi diyaloglar gösteren ve daha sonra tamamlanması projeyi kapatmadan MS Excel projesi '2014 Güncel' mimarlık 'Sunucular' katalog dosyasını "(2014 Fiili) .xlsx Sunucular" ithal. Değişiklikler yerel olarak kaydedilir kapanış sırasında ve Kuruluş proje Enterprise Server taahhüt eğer operasyon daha sonra projeye değişiklik yaparsa.

Not

Standart ASCII karakter seti ve yalnızca doğru biri ile düzgün çalışacak, Windows Komut İstemi birkaç olduğu gibi doğru çift tırnak karakteri kullandığınızdan emin olun. Doğru çift tırnak karakter kodu ondalık olan 34 (onaltılık 22).Bu yüzden / kopyalamak için çekinmeyin oradan yapıştırın Yukarıdaki örnekte kullanılan budur.


Kopyalama ve yapıştırma

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Kopyalama ve yapıştırma

Yorum gönder bu konuda.

Sen kısmını veya mimarisinin tüm kopyalayabilir ve o ağacın farklı bir konuma yapıştırın.

Kopyalamak

1. Sağ tıköğenin üzerine kopyalamak istiyorum.

2. Seçin Kopya.

Yapıştırmak

1. Öğeyi yapıştırmak istediğiniz yeri bulmak için ağaç gidin.

2. Sağ tıkşube bunu içinde görünmesini istiyorum.

3. Seçin Yapıştır.

4. (- O 'Kopyala ...' adı verilecek orijinal dalına kopyalamak sürece) madde orijinal adıyla kopyalanır.

Ayrıca bakınız

Nasıl bir mimarlık ABACUS'te temsil edilmektedir


Kopyalama şemaları

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Kopyalama şemaları

Yorum gönder bu konuda.

Varolan diyagramı kopyalama için 2 temel senaryo vardır; bir mimari içinde, ya da mimarileri arasında.

Karşı kopyabir diyagramdırBir mimari içinde

1. Bir olduğundan emin olunABACUS dosya açmasizin yanınızdaki içeren nüfuslu mimarien az bir adet olan diyagram.

2. Expand Diyagramlarışube (ve gerekli Diyagram gruplar) belirli bir MimarlıkAğacın bölümü.

3. Kopyalamak istediğiniz basın ve ardından diyagramı seçin Ctrl + C veya sağ tıkseçin Kopya Menüden.

Not

A kopyası şeması eklenecektir DiyagramlarıŞube aynı mimari. Bu olacak "Kopyası" adının başına eklenir, Sen daha sonra değiştirebileceğiniz presleme F2 ya da Bunun üzerine sağ tıklayarakve Yeniden Adlandır seçme.

Karşı mimarileri arasında bir diyagram kopyalamak

1. Bir olduğundan emin olunABACUS dosya açmasizin yanınızdaki içeren nüfuslu mimarisen az bir adet olan diyagram.

2. Expand Diyagramlarışube (ve gerekli Diyagram gruplar) arasında MimarlıkAğacın bölümükopyalamak istediğiniz diyagramı içeren mimarisi için.

3. Eğer kopyalamak istediğiniz ve şeması seçin Genel ÖzelliklerPencere notu Bakış açısı Bu diyagram (Tip alanında) ile bağlantılıdır.

4. Şimdi, genişletmek Diyagramlarışube (ve gerekli Diyagram gruplar) arasında MimarlıkAğacın bölümüDiğer mimarisi içine diyagramı kopyalamak istediğiniz söyledi.

5. Sağ tık Diyagramları düğüme (veya Diyagram grubu) Seçin ve Diyagramı Oluştur .... Görüntülenen iletişim kutusunda seçin Bakış açısı O sağ üst köşesindeki açılır yukarıdaki 3. adımda not edildi. Olduğu gibi her şeyi bırakın ve tıklayın tamam. Diyagram Ad iletişim kutusunda (yakında olması) kopyalanan diyagram için bir ad girin. Not: seçilen bakış açısına göre bir boş diyagram tuval açılacak.

6. Güvenebileceğiniz anlaşıldı ve açmak istediğiniz diyagram dön sağ tıklayarakdüğüm ve seçme Açık ya da sadece çift ​​tıklayarako.

7. Arka plan seçin kopyalamak istediğiniz diyagram ve basın tuval Ctrl + A. Bu, diyagram üzerinde tüm unsurları seçecektir. Şimdi basın Ctrl + Cpanoya içeriğini kopyalamak için.

8. Şimdi, içine içeriğini kopyalamak istediğiniz mimaride boş şemasına dönmek, arka plan seçintuval ve ya sağ tıkseçin Yapıştır ya da sadece basın Ctrl + Viçeriği yapıştırmak için. Kısa bir süre sonra içeriği yeni boş diyagram yapıştırılır.

Not

Elements yeni mimarinin üst düzey eklenecek ve yeniden düzenlenmiş olması gerekir veya birleşti Mevcut içeriğe göre işlenmiş.

Ayrıca bakınız

Çizim Aracı | Senin mimarisi doldurma | Analiz senin mimari


Yeni bir bileşen / bağlantı türü veya Tip Grubu Oluşturma

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Yeni bir bileşen / bağlantı türü veya Tip Grubu Oluşturma

Yorum gönder bu konuda.

Komponent ve bağlantı türleri ağırlıklı sınıflandırma amaçları için kullanılır. Senin mimarisi izlerken filtre olarak türlerini kullanabilirsiniz. Örneğin, yerine her şeyi görüntüleme, sadece uygulama bileşenlerini görüntülemek olabilir.

Yeni bir bileşen / bağlantı türü oluşturmak için

Not

Kullanıcı lisans Tasarımcı eklenti yeteneği gereken bir ABACUS projesinde türleri veya tip grupları ekleyin. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

1. Expand TürleriAğacın dalı.

2. Sağ tıküzerinde Bileşen Türleri (veya Bağlantı Tipleri).

3. Seçin Bileşen Tipi ekle (veya Bağlantı Tipi ekle) veya Grup oluştur.

Bahşiş

Bir tür oluşturduktan sonra, onun simgesi (aşağıya bakınız) değiştirebilir ve eklemek gerekir özellikleri ve Standartlar ona inherit bileşenin veya bağlantı örnekleri için.

Bir bileşen / bağlantı türü için simgesini değiştirmek için

Not

Kullanıcı lisans Tasarımcı eklenti yeteneği gereken bir ABACUS projesinde türleri için simgeleri değiştirmek. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

1. Sağ tık üzerinde Bileşen Tipi (veya Bağlantı türü) Için simgesini değiştirmek istiyoruz.

2. Seçin Simge Değiştir.

3. Ve bir yerde Seç Simge iletişim gözatarak bir görüntü dosyası seçin ve Aç'ı tıklatın.

Not

Sen her boyuttaki özel bir simge görüntüsünü olabilir ama her zaman Explorer penceresinde bir 16x16 piksel görüntü sığacak şekilde olacaktır. Özgün özel ikon görüntü yüksekliğine eşit değildir ve genişliği Yani sizin Explorer Pencere simge gergin olacaktır. Buna göre, özel görüntülerin en az 16x16 piksel ve özel simgesi tam şeklini korumak istiyorsanız emin özel ikon görüntü piksel (16x16 veya daha fazla) eşit yükseklik ve genişlik olduğunu yapmalıdır. Ayrıca renkli 'piksel' olan bu birbirine bitişik simgeler 'kanama' ile Explorer penceresinde yoksul bakmak gibi özel simge görüntüsünün sınırına kadar tüm yol gitmiyor konusunda dikkatli olmak gerekir. Buna göre, en az 1 piksel beyaz kenarlık bırakmalısınız.

Bahşiş

Sen özel simge resmi bir .ico, .bmp, .gif, .jpg veya .png formatında dosya yapabilir ama sen Görünüm Menüsü seçenek varsa nedeniyle Windows'ta bir sınırlama sadece Ico biçim ABACUS Select Simge iletişim önizleme olacak Minik dışında bir set.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | Analiz senin mimari


Oluşturma veya bir mimari çoğaltarak

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Oluşturma veya bir mimari çoğaltarak

Yorum gönder bu konuda.

Tek bir ABACUS dosyada mimarilerin herhangi bir sayı olabilir. Genellikle, yeni bir mimarisi modelleme ve sistem bir evrimi değerlendirmek istediğiniz her zaman yaratmak istiyorum.

Yeni bir mimari oluşturmak için

1. Sağ tık üzerinde MimarileriAğacın dalı.

2. Seçin Yeni Mimarisi.

Varolan bir mimari kopyasını oluşturmak için

1. Sağ tıkmimaride.

2. Seçin Kopya.

3. Sağ tık üzerinde MimarileriAğacın dalı.

4. Seçin Yapıştır.

5. Yeni mimari 'kopyası ...' adı verilecek.

Varolan mimari gelişmeye

1. Sağ tıkmimaride.

2. Seçin Gelişmek.

3. Yeni mimari '... 0,1' adı verilecek.

Not

Gelişen mimarileri üzerinde ayrıntılı bir açıklama var İşte .

Ayrıca bakınız

Nasıl bir mimarlık ABACUS'te temsil edilmektedir | Senin mimarisi Gelişen


Özel Raporlar

Navigasyon: senin mimarisine Raporlama>

Özel Raporlar

Yorum gönder bu konuda.

ABACUS 'özel raporlar tamamen yapılandırılabilir özel raporlar oluşturmak için olanak sağlar. Raporlar, özel görüntülerini ve grafik gibi tüm bileşenleri, bağlantıları ayrıntılarıyla veya (TCO, Performans ve Güvenilirlik dahil), çeşitli simülasyonlar bir ABACUS deposu yanı sıra ayrıntılı analitik sonuçlardan niteliklerini içerebilir. Ayrıca, raporlar diyagramlar, grafikler, kataloglar, matris / pivot tablolar, haritalar, göstergeleri, sparklines, veri çubukları ve göstergeler (örneğin trafik ışıkları içerebilir).

Not

Herhangi bir kullanıcı mevcut özel raporlar açabilirsiniz iken, to yapılandırmak Raporlar kullanıcı lisansı ihtiyacı Rapor Yapılandırma yeteneği. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

Bir görüntülemek için görenek rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari(s).

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpenceresi görüntülenir.

Özel Raporlarpencere

3. Seçin mevcut Raporİstediğiniz göstermek itibaren Mevcut Raporlar Bölüm.

4. Tıklayın Çalıştır Raporu.Raporda, Microsoft Report Viewer ve t açılacako simgeleri tıklayın, rapor sayfaları arasında gezinin [image] Ekranın sol üst köşesinde araç çubuğunda bulunan.

Not

Yapabilirsin kurtarmak rapor çeşitli biçimlerde üzerine tıklayarak İhracat Rapor simgesi [image] yer içinde Araç çubuğu. Aşağıdaki biçimlerde dışa seçebilirsiniz: Excel, PDF ve Kelime. Daha sonra kullanılmak üzere istenen konuma raporu kaydetmek edin. Değişiklikler daha sonraki bir aşamada mimari yapılırsa, yeni bir rapor değişiklikleri yansıtacak şekilde oluşturulmuş gerekecektir.

Karşı gönderilen depo verileri düzenlemek a görenek rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari(s).

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpencere (yukarıda gösterilen) görüntülenir.

Not

Herhangi bir kullanıcı mevcut özel raporlar açabilirsiniz iken, to yapılandırmak Özel bir rapora gönderilen veriler kullanıcı lisansı ihtiyacı Rapor Yapılandırma yeteneği. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

3. Seçin mevcut Raporİstediğiniz göstermek itibaren Mevcut Raporlar Bölüm.

4. Tıklayın Düzenleme Veri Setleri. Veri Seti Editorpenceresi görüntülenir.Bu pencere şu anda özel bir rapora gönderiliyor veri setlerinin bir koleksiyon gösterir. Örnekte, aşağıda bulunmaktadır üç (3);

· (onların Standartlar ve takılı parçalara özellikleri dahil) '2015 Güncel' mimarisinde tüm uygulama bileşenleri için tüm ayrıntıları belirterek bir ApplicationProxy veri seti,

· adı ile eşleşen bir veya daha fazla Diyagramları belirterek bir TwoDViewProxy veri kümesi 'Uygulama Peyzaj (Avustralya)'

· (takılı bileşenleri dahil) '2015 Güncel' mimarisinde tüm Hedef bağlantıları için tüm ayrıntıları belirterek bir TargetProxy veri seti.

Veri Seti Editorpencere

Not

Sorgu Adı Microsoft Report Builder (aşağıya bakınız) DataSet adı için kullanılacaktır. İçer alan veri kümesi olup olmadığını belirten ya Tek Eleman, Elementlerin bir koleksiyonu, tüm Bileşen Çeşitleri, Tüm Bağlantı Türleri, bir veya birden fazla Mimariler, bir veya birden fazla Diyagramları bir veya daha fazla Grafikler. Veri 'Elements Koleksiyonu' için bir Filtre düğmesi sağlanır belirleyen ve / veya belirli Standartlarına ve / veya belirli Türleri, tıklandığında belirli Mimarilerle yalnızca öğeleri döndürmek için birden çok filtre uygulamak için izin verir Eleman Filtre penceresini açtığında ve / veya belirli bileşenlere bağlı ve / veya / veya belirli Grafikler ve / veya verilen Gayrimenkul değerlere ve bazı ebeveynler ve / veya belirli Diyagramları ile. Diğer veri seti türleri için bir ad alanı sağlanmış ve Seç düğmesine veri seti ile dahil edilecek nesne (ler) seçebilirsiniz kullanıyor.

Not

Veri seti saklanırVeri (Dosyayı ayarlar.xml)Aynı temel dosya adı olarak birlikte birilişkili Rapor Tanımlama dosyası (.rdl). Bu dosya yoksa veri kümesi editörü otomatik var herhangi bir sorgu adları ile dolduracaktır Rapor Tanımlama dosyası (.rdl)ve yeni bir Veri (Dosyayı ayarlar.xml)sorguları aa geçerli liste tanımlanır kez oluşturulur.

3. Varolan bir veri kümesini silmek isterseniz o zaman seçme Sorgu Sildüğmesine basın.

4. Set yeni veri eklemek isterseniz tıklatın Yeni veri kümesi ekledüğme yukarıda Not başı olarak belirlenen verileri yapılandırmak ve.

Karşı Yeni bir özel oluşturmak rapor(bir şablondan)

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpencere (yukarıda gösterilen) görüntülenir.

3. Tıklayın Yeni ve birini seçmek A4 - Portre, A4 Peyzaj, A3 - Portre, A3- Peyzaj, US Letter - Portre, US Letter - Peyzaj, ABD Tabloid - Portre veya ABD Tabloid - Peyzajistenen rapor yönlendirme ve kağıt boyutuna bağlı.

4. Rapor Tanımlama dosyasını (.rdl / .rdlc) ve eşleştirme Veri Seti dosyası (.xml) kaydetmek için konuma gidin ve tıklayın Kaydet. Bu Özel Raporlar penceresinin Mevcut Raporlar bölümüne yeni bir özel bir rapor katacak ve açılan ya da yukarıda anlatıldığı gibi düzenlenebilir olabilir.

Karşı Varolan özel eklemek rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpencere (yukarıda gösterilen) görüntülenir.

3. Tıklayın Eklemek Rapor tanımı dosyasının konumuna (.rdl / .rdlc) taramak ve tıklayın Açık. Bu Özel Raporlar penceresinin Mevcut Raporlar bölümüne yeni bir özel bir rapor katacak ve açılan ya da yukarıda anlatıldığı gibi düzenlenebilir olabilir.

Not

Bir eşleştirme Veri Seti dosyası (.xml) Rapor Tanımlama dosyasıyla aynı konumda varolduğunu kabul edilir.

Karşı Varolan özel kopyalama rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpencere (yukarıda gösterilen) görüntülenir.

3. Seçin mevcut Raporİstediğiniz kopyalamak itibaren Mevcut Raporlar Bölüm.

4. Tıklayın Kopya ve ('Kopyala ...' olarak adlandırılır) seçilen raporun bir kopyası Özel Raporlar penceresinin Mevcut Raporlar bölümüne eklenecektir ve açılabilir ya da yukarıda açıklandığı gibi düzenlenebilir.

Not

Bunu yaparak raporun bir kopyasını yaratacak Rapor tanımı dosya (.rdl / .rdlc) olduğu kadar, bunun eşleşen Veri Seti dosyası (.xml)(varsa).

Karşı Varolan özel kaldırmak rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpencere (yukarıda gösterilen) görüntülenir.

3. Seçin mevcut Raporİstediğiniz ayırmak itibaren Mevcut Raporlarbölüm ve tıklama Kaldır.

Not

Bir rapor kaldırdığınızda artık rapor listesinde görünecektir. Ancak, bu silmez Raporun Rapor tanımı dosya (.rdl / .rdlc) veya Veri Seti dosya(.xml). Gerekirse, bu dosyaları silerek dosya sistemi ile elde edilebilir.

Karşı Varolan özel adlandırmak rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpencere (yukarıda gösterilen) görüntülenir.

3. Seçin mevcut Raporİstediğiniz yeniden adlandırmak Mevcut Raporlarbölüm ve tıklama Rename.

4. Raporun için yeni bir ad girin.

Not

Rapor Tanımlama dosyası (.rdl / .rdlc) ve eşleştirme Veri Seti dosyası (.xml) Her iki doğrultuda adını olacak.

Karşı Bir tasarım düzenleme görenek rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| Özel Raporya tıklayın Özel Rapor Oluştur araç çubuğu düğmesi. Özel Raporlarpencere (yukarıda gösterilen) görüntülenir.

Not

Herhangi bir kullanıcı mevcut özel raporlar açabilirsiniz iken, to yapılandırmak Bir özel raporların tasarımı kullanıcı lisansı ihtiyacı Rapor Yapılandırma yeteneği. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.Ayrıca, Microsoft Report Builder 3.0 raporlar tasarlamak için gerekli olan ve ücretsiz olarak indirebilirsiniz İşte .

3. Seçin mevcut Raporİstediğiniz göstermek itibaren Mevcut Raporlar Bölüm.

4. Tıklayın Düzenleme Raporu.Raporda Microsoft Report Builder 3.0 açılacak. Belirli yardım ve raporlar aşağıdaki bölümlere bakın lütfen tasarımı ile daha yaygın görevlerden bazıları bazı 'ipuçları ve püf noktaları' için. Tasarım raporları genel yardım için bakınız Microsoft Report Builder 3.0 yardım sayfalarına İşte .

Raporunuza Tabloları ekleme

1. Eğer varsa emin olun Microsoft Report Builder 3.0 açık bir ABACUS Özel Rapor Tanımlama dosyası (.rdl / .rdlc).

2. Seçin Ekle Daha sonra üstündeki 'kurdele' sekmesinde, tıkla Tablo düğmeVeri Bölgeleri bölümünde basıp de Tablo Ekle.

3. Şimdi imleci sürükleyinyerleştirilen için tablonun sol üst köşesi istediğiniz rapor tuval üzerine konumuna getirin. Tuvali tıklatın. Varsayılan olarak tablo bir başlık satır ve ardından ayrıntılar grubuna (grup bir rapor dataset bir görünüm düzenlemek için kullanılır) eklenecektir. Grubu kaldırmak, ya satırı silin veya gruplandırma araç çubuğunda Satır Grubu silmek için.

Bahşişs

Formüller / tablo hücrelerindeki ifadeler << İfade >> metni sağ tıklayarak ve Anlatım seçerek ardından hücreyi seçerek düzenlenir .... > SortExpressions Özellikleri panelinde alan ve giren bir ifade - bir tablodaki sıralama satırları tablosunu seçerek ve ardından Diğer aşağı gezen yapılır. Bir masanın sonunda toplam satır için bir satır sonra ekleyin (ve dışında) gruplama ve sonra aşağıdaki ifadeyi kullanın = Sum (Fields!Isim.Value)burada 'Ad' gerçekleşti olan alandır. Sütunlar BackgroundColor özelliğinde bir 'IIf' deyimini kullanmak için boyama uygulamak için. Bir tablodaki bir hücre olarak ölçer eklemek için öncelikle bir hücreye ölçer takmak ve ardından göstergesi için gerekli olan veri alanları bırakın. Yüksekliği ve tablo satırları genişliklerini düzenlerken, doğru satır seçmek sağlamak ve daha sonra yeniden boyutlandırmak, yukarı / aşağı imleç Arrow elde edene kadar o gri çizgiler etrafında fare imlecini.

Raporunuza Charts ekleme

1. Eğer varsa emin olun Bir ABACUS Özel Rapor Tanımlama dosyası (.rdl / .rdlc) Microsoft Report Builder 3.0 açık.

2. Seçin Ekle Daha sonra üstündeki 'kurdele' sekmesinde, tıkla Grafik düğmeVeri Bölgeleri bölümünde basıp de Ekle Tablosu.

3. Şimdi imleci sürükleyinyerleştirilen Sizin grafiğin sol üst köşesi istediğiniz rapor tuval üzerine konumuna getirin. Tuvali tıklatın ve sonra grafiği seçinEğer seçenekler ve tıklama gerektiren tamam.

Bahşişs

Listelerinde bir açıklama olarak bir özellik görüntülemek için, sağ grafik üzerinde tıklayın ve Show Veri Etiketleri seçin, ardından eklenmiş etiket birini seçin ve Çeşitli ayarlamak - (Özellikler panelinde yanlış> UseValueAsLabel ve bir ifade eklemek, örneğin = Misc Alanlar Name.Value) -!> Etiket. Özellikle için kabarcık grafikleri; Kabarcık grafikleri Dağılım grafiği başlığı altında görüntülenir. Serisi alanlara X ekseni özelliği Bırak (ya da Serisi Özellikleri ekleyin). Veri alanlarına Y ekseni özelliği Bırak (ya da Serisi Özellikleri ekleyin). Kabarcık boyutunu tanımlamak için bir özelliği kullanmak için, Veri alanları içine bu damla (ya da Serisi Özellikleri ekleyin). Çok fazla veri (200+ öğe), bazen bu görüntülenmemesi için tüm rapor neden varsa Kabarcık grafikleri görüntülemek mümkün değildir. Marker Türü - daire ayarlayın. Veri alanlarına alanlar bırakarak Varsayılan olarak, bu onları ekler sum ()Formül, bu nedenle bu kaldırmak. Özellikle için Yığılmış grafikler / Timeline / Gantt çizelgeleri; Gantt grafiği için bir aralık grafiği kullanabilir ve veri alanlarında yüksek ve düşük değerler gibi özelliklerini ekleyin. Eğer biri için düşük değer başka yüksek değerle eşleşen daha fazla aralıkları ekleyerek birden çok 'bar' olabilir. Özellikle için Pasta grafikler; Agrega pasta grafikler için, formül ekleyebilir, Kategori alanlarına ve Veri alanlarındaki verileri damla = CountRows (). Herhangi 0 değerlerini Filtre (maliyet listelerinde örneğin), bunlar için aksi etiketleri hala grafikte görünür.

Bir IIF deyimi kullanarak tablo ve grafikler renkler eklemek için

1. Eğer varsa emin olun Bir ABACUS Özel Rapor Tanımlama dosyası (.rdl / .rdlc) Microsoft Report Builder 3.0 açık.

2. Renklendirmek için tablodaki hücre ve tıklama sağ tıklayın Metin kutusu özellikleri.

3. Seçin Doldurmak ve tıklayın fxBackgroundColor alanı için bir ifade Dolgu rengi etiketinin sağında ve Set düğmesine bir ifade girin, örneğin = iif (Fields! InformationStatus.Value = "LightGreen" iif (Fields! InformationStatus.Value = "yeniden tasarlayın" "koru", "Sarı", iif (Fields! InformationStatus.Value = "Yenile", "Turuncu", " Somon"))). Bu Durum 'Redesign' içeren her hücre için sarı Durum 'Koru' içeren her hücre için açık yeşil arka plan rengini değiştirir, Portakal durumunu 'Yenile' ve diğer durum değeri içeren her hücre için renkli olacak 'Salmon' de.

Not

Renkler Görünüm ayarı ardından grafikteki seri seçerek ve grafikler için eklenebilir -> Renk özelliği (veya kabarcık grafikleri için Görünüm -> Marker -> Renk özelliği) Yukarıdaki örneğe benzer bir ifade.

Özel raporlar tasarlarken şeyler akılda tutulması için

· Eğer (bir çeşit başka veya bölme gibi bir özellik) onlarla herhangi bir 'ifadelerini' yapmak istiyorsanız Tamsayı dışındaki tüm özellikler rapor izleyiciye ABACUS'te bir dize olarak gönderilir Çünkü Ondalık veya arka plan için tarihi vb onları dönüştürmek gerekiyor , Bu makale iyi bir referanstır. Örneğin = CDate (Fields! LifecycleEndDate.Value) Not: (Aşağıda açıklandığı gibi) rapor dili varsayılan olarak aa / gg / yyyy biçimini beklediği gibi gg / aa / yyyy kabul etmek tr-TR olarak ayarlanmış olduğundan emin olun ve buna göre 31/7/2011 dönüşüm başarısız olur edin. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (Fields! CostTotalCosttoOwnnext5years.Value 0)

· Eğer mücadele olduğunuzu fark ederseniz tek bir sayfada tablo ve grafikler her tutmakBelgeniz alanı yönetmek birkaç ana yolu vardır:

· Sayfa Sonu - Bu tablo ayarı aynı sayfada olmasını istediğiniz her tablo için kapalı olduğundan emin olun.

· Birlikte tutun - Bu tablo ayarı aynı sayfada olmasını istediğiniz her tablo için doğru olduğundan emin olun.

· Şeyler etrafında taşırken, bu sayfanın sağ alt köşesindeki kontrolü kullanarak uzaklaştırmak için kolay ve daha sonra çoklu öğeleri ve sürükle seçin

· | Bir tablodaki görüntü satır için emin 'Boyut' yapmak 'Haşıl' Mülkiyet çok büyük görünebilir 'Fit' aksi takdirde görüntü ayarlanır, ya da kötü gergin olacaktır.

· Karşı Her sayfada bir tablo bir başlık satırı tekrarlamakRaporun:

1. Gruplama bölmesinde Aç Gelişmiş Mod. (Sütun Grupları sağındaki oka tıklayın ve Gelişmiş Mod'u seçin.)

2. Satır Grupları alanındaki (sütun değil Grupları) olarak tablix karşılık gelen metin kutusu vurgular Statik bir grup, tıklayın. O soldaki sütun başlığını vurgulamaktadır kadar her Statik bir grup tıklayın. Bu genellikle listelenen ilk Statik grubudur.

3. Özellikler penceresinde, true RepeatOnNewPage özelliğini ayarlayın.

4. KeepWithGroup özelliği sonra ayarlanmış olduğundan emin olun.

· Değiştir dil ayarlarıRapor özelliklerinde size, örneğin gerektiren veri formatları maç tr-TR İngiltere tarih formatı (gg / aa / yyyy) üretmek.

Ayrıca bakınız

Senin mimarisi analiz


ABACUS arayüzü özelleştirme

Navigasyon: ABACUS'e Giriş>

ABACUS arayüzü özelleştirme

Yorum gönder bu konuda.

Birçok yönden ABACUS arabiriminin görünümünü ve davranışını değiştirebilir. ABACUS Arayüze özelleştirmeler bir grup uygulamak için kullanabileceğiniz birkaç önceden tanımlanmış ayarları kombinasyonları içerir. Buna ek olarak, bu tür pencereler, araç çubukları, kısayol tuşları ve çeşitli görüntüler seçenekler gibi öğeleri tek tek özelleştirmeleri yapabilirsiniz.

Düzenleyin ve dock, Windows

Aşağıdaki dahil ABACUS'te için arayüz içinde pencereleri düzenlemek için pek çok seçeneğiniz var:

· Sekme dok pencere.

· Arabiriminde bir çerçevenin kenarına rıhtım pencereleri.

· Arayüz kenarında araç pencereleri en aza indirin.

· Varsayılan düzeni pencere yerleşimi sıfırlayın.

Yerleştirme, Windows

Bir pencere yuvalanabilir olduğu zaman, bu arayüz içinde çerçevenin bir tarafına tutturulabilir veya çerçeve içinde sekmeli bölmeleri düzenlenebilir. Arayüzde başka bir konuma mevcut konumdan pencereleri sürükleyin bir kılavuz elmas görünür. Kılavuz elmas hızla çerçevenin dört tarafında birinde veya bir sekmeli bölmesinde olarak merkezde bir pencere yeniden yerleştirmek için izin verir. Bir pencere Yüzen veya dock olmadığı zaman, diğer pencerelerin üstünde yüzer.

Pencereleri sabitlemek için

1. Eğer sabitlemek istediğiniz pencereyi tıklatın da odaklanmak üzere.

2. Üzerinde PencereMenü, tıklayın Takılabilir.

3. Eğer bunu sabitlemek istediğiniz çerçevenin ortasına doğru geçerli konumundan pencereyi sürükleyin.

Bir rehber elmas görünür. Çerçeve ve merkezi dört kenarlara doğru elmas noktasının dört okları sekmeli bölmesini temsil eder.

Bahşiş

Bunu sürüklerken yerde basın CTRL oturtarak olmadan dock pencere taşımak için.

4. Eğer sürüklediğiniz pencere sabitleyin istediğiniz konuma ulaştığında, kılavuz elmas karşılık gelen kısmı üzerine getirin. Pencerenin bir anahat belirlenmiş alanında görünür.

5. Belirtilen konumda pencereyi sabitlemek için fare düğmesini bırakın.

Örneğin, Kâşifarayüzünün sol kenarında demirledi ve sağ kenarına sabitleyebilirsiniz istiyor edilir sürükleyebilirsiniz ediyorum Kâşifarayüzünün ortalarına doğru, rehber elmas sağ tarafında üzerine getirin ve fare düğmesini bırakın.

En Aza, Windows

Pencereler (onlar Aracı Windows olup olmadığını - görünen GörünümMenü, veya Belge, Windows - görünen PencereMenü) Auto Hide adında bir özelliği desteklemesi. Auto Hide kullanılmadığı arayüzünün kenarlarında pencereleri minimize ederek tek seferde mimarisinin daha görmenizi sağlar.

Otomatik Hide açmak için

1. Eğer odak vermek gizlemek istediğiniz pencereyi tıklatın.

2. Üzerinde PencereMenü, tıklayın Otomatik gizleme.

- veya -

2. Pencerenin başlık çubuğunda raptiye simgesini tıklatın.

Auto Hide Etkin

Otomatik gizli pencere odağı kaybettiğinde, otomatik arayüzü kenarında geri sekmeye kayar. Bir pencere otomatik olarak gizli olsa da, onun adı ve simgesi arayüzü kenarında bir sekmede görebilir. Otomatik gizli penceresini görüntülemek için, sekmesinin üzerine getirin. Pencere görünümüne geri slaytlar ve kullanıma hazırdır.

Not

Otomatik gizli olan bir pencere yerleştirilmiş olamaz. Bir pencereyi yerleştirmek için, aşağıda açıklandığı gibi Otomatik gizle kapatmanız gerekecektir.

Otomatik gizle kapatmak için

1. Eğer odak vermek için görünür tutmak istediğiniz pencereyi tıklatın.

2. Üzerinde PencereMenü, tıklayın Otomatik gizlemeonay işaretini temizlemek için.

- veya -

2. Pencerenin başlık çubuğunda raptiye simgesini tıklatın.

Otomatik Devre Dışı gizle

Bahşiş

Pencere odağı olduğunda geçici görünümüne slayt etkin Otomatik gizle olan Windows. Pencereyi tekrar gizlemek için geçerli pencerenin dışında bir öğeyi seçin. Pencere odağı kaybettiğinde sonra geri görüş dışarı çıkar.

Sıfırlama, Windows Düzenleri

Sen kullanarak varsayılan pencere düzeni arayüzü dönebilirsiniz Pencere Düzeni ResetKomut. Bu komutu çalıştırdığınızda, aşağıdaki eylemler gerçekleşir:

· Tüm pencereler varsayılan konumlarına taşınır.

· Varsayılan pencere düzeni kapalı Windows komut ile kapatılır.

· Varsayılan pencere düzeni açık Windows komut tarafından açıldı.

· Varsayılan pencere düzeni görünür gizli Windows / komutu ile görünür / gizli yapılır.

Varsayılan düzeni pencere yerleşimi sıfırlamak için

1. Üzerinde , WindowsMenü, tıklayın Pencere Düzeni Reset.

Özelleştirme Menüler ve Araç Çubukları

Sen arayüzü menüleri ve araç çubukları düzeni, konumunu ve içeriğini değiştirebilirsiniz. Ayrıca araç çubukları düğmeleri eklemek ve herhangi bir düğmeye atanan simgesini değiştirebilirsiniz.

Yeni araç çubukları oluşturma

Yeni bir araç çubuğu oluşturmak için

1. Üzerinde AraçlarMenü, seçim Özelleştirin.

2. İçinde Özelleştirmeiletişim kutusunda, seçmek Araç Çubuklarısekmesi.

3. Seçin Yeni.

4. İçinde Yeni Araç Çubuğuiletişim kutusunda, araç çubuğu için bir ad yazın.

5. Seçin tamam.

Bir menü veya araç çubuğuna bir komut düğmesi eklemek için

1. Üzerinde AraçlarMenü, seçim Özelleştirin.

2. İçinde Özelleştirmeiletişim kutusunda, seçmek Komutlarısekmesi.

3. Bir kategori seçin ve menü veya araç çubuğuna iletişim kutusunun dışında bir komut sürükleyin.

4. Seçin Kapat.

Bahşiş

Alt tuşuna basılı tutarak Özelleştir iletişim açık sanki komutları hızlı değiştirmenizi sağlar.

Ayrıca bakınız

ABACUS arayüzü


Kısıtlamaları tanımlama ve doğrulama

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Kısıtlamaları tanımlama ve doğrulama

Yorum gönder bu konuda.

Bir mimari yapısı ve özellikleri kısıtlamaları kullanılarak kısıtlanabilir. Kısıtlayıcı iki yolla mimari yapısını, bileşen tipleri ve bağlantı tipleri de uygulanabilir. Birinci yol kısıtlamak için hiyerarşitanımlayarak ilişkileri "çocuk / ebeveyn olmalı olmalı" "ebeveyn / çocuk olmalı gerektiği" ve. İkinci yol kısıtlamak için topolojitanımlayarak ilişkiler "bağlantısı / bileşen bağlı olmalıdır gerektiği" "bileşeni / bağlantı monte edilmelidir gerektiği" ve. Ayrıca, kısıtlamaları bileşen tipleri, bağlantı türleri, şablonlar, bakış açılarının, mimarilerinin özelliklerine uygulanabilir, diyagramlar3D iki ek yolla mimarisi (ler) kısıtlamak görüyor. Birinci yol ayarlamak için veri tipimülkiyet o yani, olabilir, geçerli değerleri sınırlamak için; Metin, Tamsayı, Ondalık, Tarih / Saat, Boole veya listesi. İkinci yol ayarlamak için gerekenmülkiyet durumu, bir değer özelliği girilmesi gereken belirtmek için (Not: Gerekli kısıtlar sadece bileşen ve bağlantı türleri için özelliklerine uygulanır). Mülkiyet kısıtlamaları hakkında detaylı bilgiler verilmiştir Bir bileşen, bağlantı veya Çeşidi özelliklerini değiştirme Yardım konusu. Kısıtlamaları tanımlandıktan sonra, bu kısıtlamalar karşı mimari doğrulamak mümkündür. ABACUS ihlal edilmiştir herhangi kısıtlamaları hakkında uyaracaktır.

Belirlenmesinde hangi kısıt (ler) için anahtar kısıtlaması tanımlamak için kullanılan tam dilinde yalan tanımlamak için kullanılır. Hiyerarşi kısıtlamaları için onlar "tipik formu vardırisimler/ n / ayrılmıştır olmalıdır gerektiğini olabilir isimler" veya "isimler/ / tarafından toplanması gereken gerektiğini olabilir isimler"Vb Örneğin,"Bölümlerayrılmıştır olmalıdır Takımlar" veya "Uygulamalarayrılacak olabilir Modüller". Topoloji kısıtlamaları için onlar genellikle formun vardır"isimlercan / should / must fiil isimler". Örneğin, "Süreçler olabilir tarafından gerçekleştirilen Takımlar" veya "Uygulamalarvardır barındırılıyor Sunucular. "Şimdi, çeşitli can / should / must 'elemeleri' vardır her kısıt olarak görebilir ve bu 3 tür olabilir;

· Isteğe bağlı- Bunlar genellikle kelime / cümle gibi kullanacak; "may", "can", "olabilir", "isteğe bağlı" vs.

· Tavsiye edilen- Bunlar genellikle kelime / cümle gibi kullanacak; "Tavsiye" vb "tavsiye" "gerektiği"

· Zorunlu- Bunlar genellikle kelime / cümle gibi kullanacak; "zorunluluk", "shall", vb "var" "olan", "dir"

Kısıtlaması tipi (hiyerarşi ya da topoloji), ve bunu tarif eden kullanılan elemeler bağlı olarak, belirli bir kısıtlama (ler) (aşağıya bakınız) olarak tanımlanmalıdır. "Yukarıda hiyerarşisi ÖrneğinBölümlerayrılmıştır olmalıdır Takımlar"Yukarıdaki topoloji Örneğin. Yürürlüğe edilecek kısıtı ve uygulanmasının set" Ana Çocuk olmalıdır "tek bir tanımlamak gerekir"Süreçler olabilir tarafından gerçekleştirilen Takımlar. Bağlantı bağlantı türü tarafından gerçekleştirilen sonu ya yönelik kısıtlamaları "Bileşen eklenmelidir" Bir iki (2) oluşturmanız gerekir "Özellikle, aşağıdaki kısıtlamalar çeşitli seçenekleri için (aşağıya bakınız) tanımlanması tavsiye edilir;

· Hiyerarşi kısıtlamalar;

o İsimler A olabilirayrıştırılmıştır İsimler B, veya İsimler B olabilirtarafından toplanmış İsimler A veya İsimler B olmalıtarafından toplanmış İsimler A- İsim B, ebeveyn İsim A olarak türü ve Uyarıldı olarak uygulama olarak çocuk türü ile "Çocuk Ebeveyn olmalıdır" kısıtının tanımlanması.

Not

Bu bir çocuk varsa, belli bir türde bir ebeveyne sahip gerektiği anlamına gelir. Eğer değilse, bir uyarı alırsınız.

o İsimler A olmalıayrıştırılmıştır İsimler B- İsim A, çocuk İsim B olarak türü ve Uyarıldı olarak uygulama olarak ana türü ile "Ana Çocuk olmalıdır" kısıtının tanımlanması.

Not

Bu bir ebeveyn varsa, belli bir Çeşidi çocuk sahibi gerektiği anlamına gelir. Eğer değilse, bir uyarı alırsınız.

o İsimler A olmalıdırayrıştırılmıştır İsimler B- Bir İsim A Zorla olarak İsim B ve uygulama olarak çocuk türü olarak üst türüyle kısıtlaması "Veli Çocuk olmalıdır" tanımlayın.

Not

Bu bir ebeveyn varsa, belli bir Çeşidi çocuk sahibi gerektiği anlamına gelir. Eğer değilse bir hata alırsınız.

o İsimler A olmalıdırtarafından toplanmış İsimler B- İsim A Zorla olarak İsim B ve uygulama olarak üst türü olarak çocuk türü ile "Çocuk Ebeveyn olmalıdır" kısıtının tanımlanması.

Not

Bu bir çocuk varsa, belli bir türde bir ebeveyne sahip gerektiği anlamına gelir. Değilse, bir hata alırsınız.

· Topoloji kısıtları;

o İsimler A olabilir fiil İsimler B- İki (2) kısıtlamaları "Bağlantı Bileşeni bağlı olmalıdır" tanımlayın. Bağlantı Çeşidi Kaynak ucu ile birinci olmak fiilZorla olarak ayarlanmış bir bileşen türünü ve uygulanmasını ismin bağlı. Bağlantı Çeşidi Lavabo sonu ile ikinci varlık fiilZorla ayarlanır İsim B bileşeni tipi ve uygulama bağlı.

Not

Bu bağlantı varsa, bazı türleri bileşenleri bağlamak gerektiği anlamına gelir. Eğer değilse bir hata alırsınız. Genel olarak bu, bu bileşenler de mevcut olabilir ve birbirine bağlı değildir sağlar. Bağlı oldukları Ancak eğer sağ tip bağlantıları kullanılmalıdır.

o İsimler A olmalı fiil İsimler B- İki (2) kısıtlamaları "Bileşen Bağlantısı bağlı olmalıdır" tanımlayın. İsmin ile kaynak ucuna bağlı bir bileşen türü olan ilk fiilBağlantı tipi ve uygulama seti ile uyardı. Sink ucuna bağlanmış İsim B bileşeni türü ile ikinci varlık fiilBağlantı tipi ve uygulama seti ile uyardı. Ayrıca, iki (2) kısıtlamaları "Bağlantı Bileşeni bağlı olmalıdır" tanımlar. Bağlantı Çeşidi Kaynak ucu ile birinci olmak fiilZorla olarak ayarlanmış bir bileşen türünü ve uygulanmasını ismin bağlı. Bağlantı Çeşidi Lavabo sonu ile ikinci varlık fiilZorla ayarlanır İsim B bileşeni tipi ve uygulama bağlı.

Not

Bu her iki türdeki bileşenler varsa, belli bir tipte bir bağlantı bağlı olması gerektiği anlamına gelir. Değilse bir uyarı alırsınız. Buna ek olarak, bu bağlantı varsa, belirtilen tür bileşenlerin bağlı olması gerektiği anlamına gelir. Eğer değilse bir hata alırsınız. Genel olarak bu bu tür bileşenleri varsa onlar birbirlerine bağlı değilseniz, uyarıları almak olmasını sağlar.

o İsimler A olmalıdır fiil İsimler B- İki (2) kısıtlamaları "Bileşen Bağlantısı bağlı olmalıdır" tanımlayın. İsmin ile kaynak ucuna bağlı bir bileşen türü olan ilk fiilBağlantı tipi ve uygulama Zorla ayarlanır. Sink ucuna bağlanmış İsim B bileşeni türü ile ikinci varlık fiilBağlantı tipi ve uygulama Zorla ayarlanır. Ayrıca, iki (2) kısıtlamaları "Bağlantı Bileşeni bağlı olmalıdır" tanımlar. Bağlantı Çeşidi Kaynak ucu ile birinci olmak fiilZorla olarak ayarlanmış bir bileşen türünü ve uygulanmasını ismin bağlı. Bağlantı Çeşidi Lavabo sonu ile ikinci varlık fiilZorla ayarlanır İsim B bileşeni tipi ve uygulama bağlı.

Not

Bu her iki türdeki bileşenler varsa, belli bir tipte bir bağlantı bağlanmış olması gerektiği anlamına gelir. Eğer değilse bir hata alırsınız. Buna ek olarak, bu bağlantı varsa, belirtilen tür bileşenlerin bağlı olması gerektiği anlamına gelir. Eğer değilse bir hata alırsınız. Genel olarak bu bu tür bileşenleri varsa onlar birbirlerine bağlı değilseniz, hataları alırsınız sağlar.

Bir kısıtlama tanımlamak için

1. Bir olduğundan emin olun ABACUS dosyasıaçık ve Explorer Penceregösterilir.

2. Kaşif ağacında genişletin Çeşitleri | Bileşen Türleriveya genişletmek Çeşitleri | Bağlantı Tipleri.

3. Sağ tıkBir bileşen türü veya bir bağlantı türü seçin Kısıtlama Ekle.

Bir kısıtlama ekleme

Bir ebeveyn, belirli bir çocuğu olması gerekir hiyerarşi kısıtlaması, tanımlamak için

4. Üzerinde Kısıtlama EklePencere kene Kısıtlama oluşturaltında onay kutusunu Veli Çocuk Constraint Olmalıdıralanı.

5. Seçin bileşen türü3. adımda seçilen bileşen Çeşidi çocuğu olarak belirtmek istediğiniz açılan kutudan.

Not

Zaten varsa bir etkin kısıtlama ana bileşeni tipi ve başka çocuk bileşeni tipi sonra bu yeni bir kısıt bir 'VE' olarak kabul edilecek için tanımlanan 'Veli Çocuk Olmalıdır'. Bu tip çocuk A tipi bir ebeveyn olmak gerekir veÇocuk B tipi ne olursa olsun, uygulama düzeyinde - her kısıt için belirtilen (Uyarıldı veya Zorlanan örneğin Engelli, adım 7).

6. İsteğe bağlı olarak sağ-tıkladığınız 3. adımda bileşen Çeşidi çocukları olmalı Belirtilen bileşen türü bileşenlerinin minimum ve maksimum sayısını tanımlayabilirsiniz.

7. Olmak kısıtlama isteyip istemediğinizi seçin Engelli, Uyarıldı veya Zorunlu.

Not

Onlar tespit edilir ve bunlar tespit edilirse Zorla kısıtlamalar Doğrulama penceresinde bir hata üretecek eğer Engelli kısıtlamalar kısıtlama doğrulama göz ardı edilecek Uyarıldı kısıtlamalar Doğrulama penceresinde bir uyarı üretecektir. Ayrıca, tüm hatalar bir önce çözülmesi gerekir Şirket Sunucu Proje taahhüt edilebilir.

8. Tıklayın tamam.

Not

Kısıt sağ tıkladığınız ok kısıtlaması yönünü gösterir ve bu durumda aşağı gelin ve sağ olacak 3. adımda bileşen türü altında kaşif ağacında görüntülenecektir. Kısıt (sarı) ya da Zorla (kırmızı) Uyarıldı Devre Dışı (gri), olup olmadığını asma kilit göre renklidir.

Ebeveyn çocuğun uyardı kısıtlaması olması gerekir

Bir çocuğun belirli ebeveyn olması gerekir hiyerarşi kısıtlaması, tanımlamak için

4. Üzerinde Kısıtlama EklePencere kene Kısıtlama oluşturaltında onay kutusunu Çocuk Ebeveyn Constraint Olmalıdıralanı.

5. Seçin bileşen türübileşen türü ebeveyni olarak belirtmek istediğiniz açılan kutudan 3. adımda sağ tıkladım.

Not

Zaten varsa bir etkin çocuk bileşeni tipi ve sonra bu yeni kısıtlama bir 'OR' olarak kabul edilecek başka bir ana bileşeni türü için tanımlanan kısıtlaması 'Çocuk Ebeveyn Olmalıdır'. Bu tip ebeveyn A tipi bir çocuk olmak gerekir veyaebeveyn tip B, ve icra düzeyi (örneğin Uyarıldı veya Zorlanan - sonraki adıma bakın) daima uyardı olanları geçersiz kılacaktır aynı aksi zorunlu kısıtlamalar olmalıdır.

6. Olmak kısıtlama isteyip istemediğinizi seçin Engelli, Uyarıldı veya Zorunlu.

Not

Onlar tespit edilir ve bunlar tespit edilirse Zorla kısıtlamalar Doğrulama penceresinde bir hata üretecek eğer Engelli kısıtlamalar kısıtlama doğrulama göz ardı edilecek Uyarıldı kısıtlamalar Doğrulama penceresinde bir uyarı üretecektir. Ayrıca, tüm hatalar bir önce çözülmesi gerekir Şirket Sunucu Proje taahhüt edilebilir.

7. Tıklayın tamam.

Not

Kısıt ok kısıtlaması yönünü gösterir ve bu durumda yukarı gelin ve sol olacak 5. adımda seçilen bileşen türü altında gezgin görünümünde görüntülenir. Kısıt (sarı) ya da Zorla (kırmızı) Uyarıldı Devre Dışı (gri), olup olmadığını asma kilit göre renklidir.

Çocuk ebeveyn uyardı kısıtlaması olması gerekir

Bir bileşen belirli bir bağlantı eklenmelidir bir topoloji kısıtlaması tanımlamak için

4. Üzerinde Kısıtlama EklePencere kene Kısıtlama oluşturaltında onay kutusunu Bileşen kısıtlama Ekli Olmalıalanı.

5. Seçin bağlantı türübileşen türü ekli bağlantı olarak belirtmek istediğiniz açılan kutudan 3. adımda sağ tıklandığında (Ya seçin bileşen türü3. adımda bir bağlantı türü sağ tıklandığında ise ekli bileşen olarak belirtmek istediğiniz açılan kutudan.)

Not

Zaten o zaman bu yeni bir kısıt bir 'VE' olarak kabul edilecektir tipi bileşen türü ve başka bir bağlantı için tanımlanmış bir etkin 'Bileşen Ekli Olmalı' kısıtlama varsa. Bu bileşen türü bağlantı A tipi eklenmelidir olan veBağlantı tipi B, ne olursa olsun uygulama seviyesine - Her kısıt için belirtilen (Uyarıldı veya Zorlanan örneğin Engelli, adım 7).

6. İsteğe bağlı bir bağlantı seçebilirsiniz rolEğer kısıt eklemek istediğiniz. SBelirli seçecek rol (yani kaynak veya lavabo olarak) Açılan kutudan.

7. Olmak kısıtlama isteyip istemediğinizi seçin Engelli, Uyarıldı veya Zorunlu.

Not

Onlar tespit edilir ve bunlar tespit edilirse Zorla kısıtlamalar Doğrulama penceresinde bir hata üretecek eğer Engelli kısıtlamalar kısıtlama doğrulama göz ardı edilecek Uyarıldı kısıtlamalar Doğrulama penceresinde bir uyarı üretecektir. Ayrıca, tüm hatalar bir önce çözülmesi gerekir Şirket Sunucu Proje taahhüt edilebilir.

8. Tıklayın tamam.

Bir bağlantı belirli bir bileşene bağlı olması gereken bir topoloji kısıtlaması tanımlamak için

4. Üzerinde Kısıtlama EklePencere kene Kısıtlama oluşturaltında onay kutusunu Bağlantı kısıtlaması Ekli Olmalıalanı.

5. Seçin bağlantı türübileşen türü ekli bağlantı olarak belirtmek istediğiniz açılan kutudan 3. adımda sağ tıklandığında (Ya seçin bileşen türü3. adımda bir bağlantı türü sağ tıklandığında ise ekli bileşen olarak belirtmek istediğiniz açılan kutudan.)

Not

Aynı bağlantıyı kullanan bağlantı türü ve başka bir bileşen türü için tanımlanmış zaten etkinleştirilmiş 'Bağlantı Ekli Olmalı' kısıtlama varsa rol(diğer bir deyişle, ya Kaynak veya Lavabo), daha sonra bu yeni kısıtlama bir 'OR' olarak kabul edilecektir. Bu bağlantı türü bileşen A tipi eklenmelidir olan veyabileşen türü B ve icra düzeyi (örneğin Uyarıldı veya Zorlanan - adım 7) daima uyardı olanları geçersiz kılacaktır aynı aksi zorunlu kısıtlamalar olmalıdır. Bağlantısı var birden kısıtlamalar varsa o da unutmayın rololarak belirtilen 'Herhangi' ardından bağlantının her uç kısıtlamaları belirtilen bileşen türlerinden birine bağlı olması gerekir (özellikle kaynak veya Lavabo aksine).

6. İsteğe bağlı bir bağlantı seçebilirsiniz rolEğer kısıt eklemek istediğiniz. SBelirli seçecek rol (yani, ya Kaynak veya Lavabo) Açılan kutudan.

Not

Bir kaynak veya Lavabo rolü Ya açıkça bir için seçilmiş olması gerekir Eklenti Sütun bir bileşen gösterilir avilable olduğu katalog .

7. Olmak kısıtlama isteyip istemediğinizi seçin Engelli, Uyarıldı veya Zorunlu.

Not

Onlar tespit edilir ve bunlar tespit edilirse Zorla kısıtlamalar Doğrulama penceresinde bir hata üretecek eğer Engelli kısıtlamalar kısıtlama doğrulama göz ardı edilecek Uyarıldı kısıtlamalar Doğrulama penceresinde bir uyarı üretecektir. Ayrıca, tüm hatalar bir önce çözülmesi gerekir Şirket Sunucu Proje taahhüt edilebilir.

8. Tıklayın tamam.

Gerçek zaman model kontrolü ve sınırlamaonaylama

ABACUS içeren birGerçek zamanlı Model Kontrolü ve Doğrulama özelliği hemen ekran etkileri, belirli bir kullanıcı işlemi üzerinde olacak nedeniyle herhangi bir geçerli proje ile uyarılar ve hatalar, hiyerarşi ve topoloji tanımlanmış olan kısıtlamalar. Tüm hatalar bir önce çözülmesi gerektiğini belirtmek gerekir Şirket Sunucu Proje taahhüt edilebilir.

Diyagramlar ile veya doğrudan Explorer penceresinde doldururken gerçek zamanlı kısıtlaması doğrulama özelliği en belirgindir. Özellikle, aşağıdaki işlemleri sırasında, rehberlik çalışması üzerinde yaratacağı etkiye gibi renk vurguları kullanılarak verilir Geçerli proje ile uyarılar ve hatalar;

1. Ebeveyn renk üzerine veya bir diyagram etrafında elemanları sürükleyerek (veya takılarak) Ne bileşeni sınır aşağıda açıklanan şemaya göre renkli olacak (varsa).

2. Sağ tıklama kullanarak sürükle bileşenleri bağlarken | Aşağıda açıklanan şemaya göre renkli mevcut bağlantı türleri listesini özelliği için bağlayın.

3. Bağlayıcı Modu kullanarak diyagramlar bileşenleri bağlarken imleç aşağıda açıklanan şemaya göre renkleri değişecektir.

4. Alt bileşenler eklerken kullanılabilir Bileşen Türleri listesi aşağıda açıklanan şemaya göre renklidir.

Genel olarak aşağıdaki renklerin kullanıcı işlemi mevcut proje ile uyarılar ve hatalar üzerinde olacak etkisini belirtmek için kullanılır;

Siyah : Uyarılar veya hatalar üzerinde hiçbir etkisi.

Yeşil : Operasyon açıkça bir uyarıncaProje için belirlenen hiyerarşi ve topoloji kısıtlamaları.

Kırmızı : Operasyon açıkça bir aykırıve proje için belirlenen hiyerarşi ve topoloji kısıtlamaları uyarı ve / veya hatalara neden olur.

Geçmiş model kontrolü ve sınırlamaonaylama

ABACUS'ün içeren bir Doğrulama özelliği nedeniyle tanımlanmış herhangi bir kısıtlama mevcut proje ile tüm uyarı ve hataları görüntülemek için. Tüm hatalar bir önce çözülmesi gerektiğini belirtmek gerekir Şirket Sunucu Proje taahhüt edilebilir.

Not

Doğrulama elle düğmesine 'Proje kısıtlamaları kontrol Validate /' yoluyla çalıştırılması gerekiyor Ana araç çubuğu . Doğrulama penceresi varsayılan olarak gizlidirancak araç çubuğu düğmesi tıklandığında görünür. Görmek Arayüzü özelleştirme için nasıl göstermek için ve potansiyel kalıcı görüntülenen bırakın. Ayrıca, projede ilgili elemana 'atlama' olarak Doğrulama penceresinde herhangi bir satırı çift tıklayabilirsiniz.

Doğrulama penceresi

Şöyle Doğrulama penceresinde varsayılan sütunlar tarif edilmiştir;

Uyarı veya Hata: Bu sütun ihlali Uyarı (sarı ünlem işareti ile üçgen) veya Hata (bir haç ile kırmızı daire) olup olmadığını için bir simge görüntüler.

Numara: Bu sütun ihlal sayısını gösterir.

Not

Sadece 200 ihlalleri bir anda gösterilir ve bir projede 200'den fazla ihlalleri varsa, pencerenin sağ üst köşesindeki Başlat, Önceki, Sonraki ve Bitiş sıra navigasyon ek ihlallerini göz atmak için kullanılır.

AçıklamaBu, ilgili İdare ve Kısıtlama dahil ihlal tam bir açıklamasıdır.

Varlık: Bu sütun ihlali endişe Varlık görüntüler.

Tip: Bu sütun İdarece için eleman türünü görüntüler.

Mimarlık: Bu sütun ihlali oluştu, içinde Architecture görüntüler.

Tespit edilen: Bu sütun ihlali tespit edildi zamanı gösterir.

Bahşiş

Bu (yukarıdaki iletişim gösterildiği gibi) En son ihlalleri listenin 'üst' de görünmesini sağlamak algılandı sütuna göre azalan sıralamak için yararlıdır.

Arka plan model doğrulama davranışını değiştirmek için çeşitli kullanıcı seçenekleri vardır. Örnek to Varsayılan dışında bir kısıtlama ihlalleri için kullanılan renklerini değiştirmek KırmızıTıklatın Araçlar | Seçenekler ... Daha sonra gitmek Doğrulamasekmesi ve aracılığıyla renklerini ayarlamanıza Değişim düğmeleri.

Doğrulama seçenekleri

El kısıtlamaları doğrulamak için

1. Sağ tık üzerinde Mimarileriya düğüm, herhangi bir mimari veya herhangi bir yerde Bileşenler veya Bağlantılarkaşif görünümü ve seçme bölümü Kısıtlamaları kontrol.

Kısıtlamaları doğrulayın

2. Tıkla Detaylardüğmesini Uyarılarmimari tanımlanmış olan tüm kısıtlamaları ihlal nereye pencere görmek için.

Not

İhlaller sadece Uyarıldı veya Yürürlüğe için ayarlanmış olan bu kısıtlamaları gösterilmiştir. Ayrıca uyarı ifadeler yer alacak 'gerektiğini' kısıt sadece bir uyarı ya da olsaydı Zorla olsaydı 'zorunluluk'.

3. Tıklayın tamam.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma


Bir bileşeni veya bağlantısını silme

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Bir bileşeni veya bağlantısını silme

Yorum gönder bu konuda.

Bir bileşen veya bağlantısını silmek için

1. Sağ tıkbileşen ya da bağlantısı.

2. Seçin Silmek.

Dikkat

ABACUS Gösterim silme etkilenecek olan sizi uyarır ve silme işlemini onaylamak için size soracaktır. Elemanları birçok diyagramlar üzerinde bulunabilir, çünkü bu olduğunu ve teklif edilen silme etkileyecektir kontrol etmek öder.

Bahşiş

Bir bileşeni silerseniz, alt tüm bileşenleri de silinecektir. Sen bileşene iç ve dış bağlantıları silmeyi seçebilirsiniz. Bunları silmek için seçerseniz, bağlantı bu kadar ekli kalacaktır, ama artık eklenecektir. Tüm bileşenler ve bağlantıları belirli vardır Tip . Bileşen / bağlantısını iptal (ağacın Türleri dalında) Tip üzerinde hiçbir etkisi yoktur. Benzer şekilde, bileşen / bağlantı varsa bir Standart atanmış, silme Standartları dalında master üzerindeki etkisi olmayacaktır.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış


Diyagram Bakış Açıları

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Diyagram Bakış Açıları

Yorum gönder bu konuda.

The bakış açılarıözelliği, bir diyagram ilave edilmeden önce bir diyagram eklenir parça ve bağlantı tipi bir ilişki daha önce tanımlandığı olmalıdır sağlar. Bu özellik Bileşenleri ve ilişkili şekiller ve konnektörleri kısıtlayarak çizilebilir diyagramlar türleri kısıtlama sağlar Bağlantılarsenin mimarisi içindeki mevcut.

Etkinleştirilmesi veya devre dışı bırakma Bağlayıcılığı diyagramı bakış açısı

Uygulamak yeteneği diyagram bakış açıları otomatik varsayılan olarak etkindir. Araçlar bu özellik tıklayın etkinleştirmek / devre dışı bırakmak için | Seçenekler ...| Diyagramsekmesini seçin ve / işaretini kaldırın Diyagram zorla Bakış Açılarıbuna göre onay kutusunu işaretleyin.

Not

Eğer görmüyorsanız 'Diagram zorla Bakış Açıları'Diyagram sekmesinde seçenek ardından Tasarımcı eklenti yok ve seçenek varsayılan olarak açıktır.

Uygulanabilir bir diyagram oluşturma bakış açısı

1. Bir olduğundan emin olun ABACUS dosyası açık kâşifgörünümü görüntülenir.

2. Kaşif görünümünde sağ tıklayın Görünümnoktasve üzerine tıklayın Create Diyagram Bakış Açısı

3. Diyagram Bakış Açısıpenceresi görüntülenir.

4. Bir alakalı ad atayın diyagram bakış açısıve dikkat bakış açısı altında kaydedilir Bakış Açılarıexplorer bölümü.

5. Diyagram Bakış Açısıpenceresi görüntülenir.

6. Şimdi tıklayın ve üzerine mimarileri ilgili bileşen tipleri ve bağlantı türlerini sürükleyin bakış açısı şekilleriİstediğiniz. Bileşen türleriBir sürüklenebilir gerekirşekil içinde şekillersekmesi, iken bağlantı türleriüzerine sürüklenen gerekir 5 çizgi stili şekillerden biri içinde konnektörlerisekmesi.

7. Kaydetmek için diyagram bakış açısıüzerinde tıklayın oluşturduk [image] sağ üst köşesinde sizin Diyagram Bakış Açısıpenceresi.

Not

diyagram bakış açısıüzerinde sağ tıklayarak düzenlenebilir bakış açısı ve seçme Açık veya çift ​​tıklayarak bakış açısı.

Diyagramlar ile güncelleştirilmiş bakış açısı Synchonising

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Ya bakış açısı sağ tıklayın Kâşif altında pencere Meta-Model | Bakış Açılarıseçin Senkronizasyon Şeması Dönüşümler ...

- veya -

3. Kapat açık ve güncel bakış açısı Pencere ve seçme Evet içinde Viewpoint senkronizeGörüntülenen iletişim.

4. Bakış Açısı Senkronizasyoniletişim aşağıda gösterildiği gibi görüntülenecektir.

Kutularını

· Eksik Eşlemeleri'ni ekle- Eklenmiştir dernekler (bağlantı türüne) Herhangi yeni (bileşen türü) şekil veya konektör bakış açısınaeklenecektir karşılık gelen bir diyagramdırs (yani onlarınşablons)o bakış açısına bağlıdır.

· Güncelleme MevcutEşlemeler- Herhangi güncellenmiş (bileşen türü) Mevcut şeklin yönü ya da (bağlantı türüne) konektörü dernekler için bakış açısı(örneğin renk, yazı tipi stilleri) 'de güncellenecektir karşılık gelen bir diyagramdırs (yani onlarınşablons)o bakış açısına bağlıdır.

· Ekstra kaldırEşlemeler- Eklenmiştir dernekler (bağlantı türüne) herhangi bir ek (bileşen türü) şekil veya konektör için diyagramları (diğer bir deyişle bunların şablonlar), fakat olmayan bakış açısıkaldırılacak karşılık gelen bir diyagramdırs (yani onlarınşablons)o bakış açısına bağlıdır.

· Eklendi Local Settings veya Güncelleme Eşlemeler üzerine yaz (Farklar Only)- Herhangi güncellenmiş (bileşen türü) Mevcut şeklin yönü ya da (bağlantı türüne) konektörü dernekler için bakış açısı(örneğin renk, yazı tipi stilleri) bakış açısı ile bağlantılı diyagramlar karşılık gelen elemanlara uygulanacak.Sadece bakış açısı yapılan güncellenmiş 'farklılıklar' yani bakış açısı güncelleme değil şemada mevcut herhangi bir yerel ayarlar değişmeden kalır uygulanır.

· [image] Açıklamalar – Yukarıda ancak özellikle açıklamalar gelince.

Ayrıca bakınız

Çizim Aracı | Senin mimarisi doldurma | Analiz senin mimari


Aracı Özellikleri Çizim

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Aracı Özellikleri Çizim

Yorum gönder bu konuda.

Çizim Aracı çizim özellikleri bir dizi destekler.

Zoom yapma

Diyagram ölçekli zoom fonksiyonu kullanılarak değiştirilebilir.

Ölçek ya da 'zoom in' azaltmak için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Basın Ctrlve '=' tuşuna basın.

- veya -

2. Seçin Yakınlaştırdüğmesini DiagramAraç çubuğu.

- veya -

2. Basın Ctrlve fare tekerleği döndürün ileri. Not: Bu modda tuval fare tuval üzerine gelerek nerede doğru yakınlaştırır.

Ölçeğini artırmak veya 'uzaklaştırma' için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Basın Ctrlve '-' tuşuna basın.

- veya -

2. Seçin Uzaklaştırdüğmesini DiagramAraç çubuğu.

- veya -

2. Basın Ctrlve fare tekerleği döndürün geriye. Not: Bu modda tuval fare tuval üzerine gelerek yerden dışarı doğru yakınlaştırır.

Otomatik düzen

Şemada bileşenlerin düzeni otomatik olarak değiştirilebilir.

Düzen tüm bileşenler on bir diyagramdır

1. Cyalamak Düzen ŞemasıDiyagram araç çubuğundaki düğme.

2. Seçinya Radyal Düzeni veya Izgara Düzeni.

Not

Radyal düzen ilgisiz parçalar birbirinden zorla bağlıyken bileşenler birlikte çizilmiş gibi bir 'zorla yönettiği' algoritması olarak adlandırılan kullanacaktır. Izgara düzeni sabit genişlik ve yükseklik aralığı algoritmasını kullanır. Bu öncelikle kullanıcı genel şeması Aspect Ratio seçmenize olanak verir (örn 16: 9, A4 (Portre), Letter (Yatay)) ve yanlarda ve sütun ve satırlar arasında boşluk sonra aşağıda gösterildiği gibi.Sadece tuval sağ alt üst-soldan (kendi adına) tarafından alfabetik bileşenleri düzenler olarak Izgara düzeni ile bileşenler arasındaki bağlantıların düzenini etkilemez. Her iki algoritmaları ile serbest formlu şekiller taşınmaz.

Düzen çocuklar bileşenler Tek ebeveyn o dan bir diyagramdır

1. Sağ tıkÇocukları Eğer otomatik düzen isteyen üst düzey bir bileşeni.

2. Seçin Düzen Çocuklar.

Not

Varsayılan olarak, yalnızca Radyal düzeni algoritması kullanılır.

Eleman Değiştirme Estetik sevmek Renk, Şeffaflık, Gölgeler ve Rotasyon

Tüm diyagramdır elemanlar, arzu edilen şekilde manipüle edilebilir bir estetiğe sahiptir. Ilgili şekiller halinde, bu yönler ayarlanabilir tipine göreve aynı zamanda bir çok durumda Örneğin başına. Serbest form durumunda, bu özellikleri ayarlanabilir Örneğin başınaTuval üzerinde.

Not

Aynı boy, ilgili türü için değiştirilirse ilgili şekiller için ayarlanmış olan örnek yönleri başına herhangi bir 'üzerine' olacak.

Bir birleşik şekli renk veya serbest biçimli bir şekil değiştirme

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya serbest biçimli şekli.

3. Seçin Change Color.

4. Seçin Sabit Renkradyo düğmesi (varsa).

5. Temel Renk seç veya iletişim kutusunda bir özel Renk tanımlama ve tıklayın tamam.

- veya -

4. Seçin Gradyanradyo düğmesi (varsa).

5. Seçin iki pulldown ve tıklama degrade yön için Yatay, Dikey, İleri Çapraz veya Geri Çapraz tamam.

6. Temel Renk seç ya için iletişim Özel bir Renk tanımlayın Başlangıç ve Sonve tıklayın tamam.

Not

ABACUS bir şeklin eğer ön planda renk olacak;
a) tek bir altta yatan bir grafik elemanı (örneğin daire, dikdörtgen, çokgen vb) bir 'basit' şekli, ya da
b) birbirinin aynı renk / degrade veya subshapes LockScale = TRUE belirledik birden yatan subshapes ile 'karmaşık' şeklidir.
Yukarıdaki koşullar sonra yerine getirilmediği takdirde şekil arka plan renkli.

Bir özelliğine göre ilgili bir şeklin rengini ayarlamak için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme(DEĞİL ) çizim Tuval üzerine.

3. Seçin Change Color.

4. Seçin İşletmeye kullanma Radyo tuşu.

5. Metin sağındaki '...' butonuna tıklayarak bir özellik seçin.

6. Seçin Menzil Radyo tuşu.

7. Ayarlayın Min ve Maksimumdeğerler istediğiniz gibi. Not: Minimum değerin altında herhangi bir değer Min renk olarak gösterilir ve maksimum üzerinde herhangi bir değer Max renk olarak gösterilecektir. Özellikleri Boolean, Liste veya Tarih / Saat kullanırken aşağıdaki gibi Ayrıca, değerler bir indeks dönüştürülür; (Yanlış = 0, true = 1) Boolean, Liste ve Tarih / Saat (1 Ocak 1900 yılından bu yana gün sayısı (her Birimler alanında belirtilen kendi küçükten büyüğe geçerli değeri n 1 bir tamsayı vale) - dahil ondalık için Saat, dakika, saniye bölümlerini - ve tarih) 1990 öncesi negatif bir sayı olduğunu belirtir.

8. Temel Renk seç ya için iletişim Özel bir Renk tanımlayın Min ve Maksimumve tıklayın tamam.

Bahşiş

Eğer Yeşil (RGB - 128,255,0) Min renk olarak seçilir ve Kırmızı (RGB - 255,0,0) değeri aralığında bir özellik Max rengi olarak seçilmiştir 1için 4daha sonra bir değer 1olarak görüntülenir Yeşil, Bir değer 2olarak Sarı, 3olarak turuncu ve 4olarak Kırmızı.

Seçenek olarak ise, bir özelliği aralığında 1için 3Bir değer 1gibi olacaktır Yeşil, Bir değer 2olarak Kehribar ve 3olarak Kırmızıaka 'Trafik Işıkları' ya da RAG durumu.

1 ile 5 arasında bir özellik aralığı ise İçin Mavi (RGB - 0,0,255) Min renk olarak seçilir ve Kırmızı (RGB - 255,0,0) Maksimum 1 değeri gibi olacaktır renk olarak seçilmiştir Mavi2, bir değer olarak Su3, bir değer olarak Yeşil4, bir değer olarak Sarı 5 değeri olarak Kırmızı.

1'den 6'ya kadar bir özelliği aralığı ise İçin Menekşe (RGB - 255,0,255) Min renk olarak seçilir ve Kırmızı (RGB - 255,0,0) Maksimum 1 değeri gibi olacaktır renk olarak seçilmiştir Menekşe2, bir değer olarak Mavi3, bir değer olarak Su4, bir değer olarak Yeşil5 değeri olarak Sarı ve 6 arasında bir değer olarak Kırmızı.

Ve son olarak, 1 ile 7 arasında bir özellik aralığında 1 değeri gibi olacaktır Menekşe2, bir değer olarak Koyu mavi3, bir değer olarak Açık mavi4, bir değer olarak Mavi Yeşil5 değeri olarak Yeşil6, bir değer olarak Kehribar ve 7 değeri olarak Kırmızı

Not

Arka plan boyama karşı ön planda yukarıdaki nota bakın.

- veya -

7. Seçin Belirli değer Radyo tuşu.

8. Tıkla Düzenleme Renklerdüğmesine basın.

9. Sırayla her değer seçin ve tıklayın Renk ayarlamaher değer için belirli bir rengi ayarlamak için.

Not

Diyagram üzerinde bulunan elemanların değerlerinin aralığı önceden doldurulmuş olacaktır.

10. Bu önceden doldurulmuş (mülkiyet aralığı yeniden edildikten sonra örneğin) tıklama için herhangi bir ek değer renkler eklemek için Değer katmak.

Ilişkili bir şekil renk saydamlığı veya serbest form şeklini değiştirmek için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya serbest biçimli şekli.

3. Seçin Change Color.

4. Saydamlık panelinde temel renk için istenen şeffaflık üst kaydırıcıyı ayarlayın.

5. Gradient veya kullanma Mülkiyet seçenekleri kullanılıyorsa, Saydamlık panelinde, ikinci renk için istenen şeffaflık alt sürgüsünü ayarlayın.

6. Tıklayın tamam.

Göstermek için gölgeler için tümü ilişkili Bir şemada şekiller

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenlerşablona penceresinin sekme.

3. Seçin Eklemek Gölgeler.

Karşı üzerinde bir gölge göstermek Bir bileşen şekil veya serbest form şekli

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Sağtuşa tıklayınTuval üzerine bileşen veya serbest biçimli şekli.

3. Seçin Eklemek Gölgeler.

Diyagramlar bileşeni şekilleri ve serbest form şekiller döndürmek için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Bileşen şekli veya döndürmek istediğiniz tuval üzerine serbest biçimli bir şekli seçin.

3. Sağ tıkşekil seçin ve üzerine Döndürve sonra tarafından şekli döndürmek istediğiniz ilgili açıyı seçin.

Değişen Eleman Açıklamalar ve Serbest Metin Etiketleri

Tüm diyagram elemanları var açıklamalar İstenen gibi olan manipüle edilebilir. Ilgili şekiller halinde, bu yönler ayarlanabilir tipine göreve aynı zamanda bir çok durumda Örneğin başına. Serbest form halindeve konektörler,metin etiketleri ayarlanabilir Örneğin başınaTuval üzerinde.Sekiz (8) ek açıklamaları farklı tipte şeması elemanları için görüntülenebilir (yani adı, tipi, Standartlar ve zaman damgaları (düzenlendi, vb) Değiştiren Özellik Değeri, Gayrimenkul Marker, Ekli Bileşenleri, sadece bileşenler için Çocuklar ()) Yirmi içinde beş (25) farklı pozisyonları (örneğin Merkezi - Dış Top, İç bıraktı - Centre, Dış Sağ - Dış Alt).

Not

Aynı boy, ilgili türü için değiştirilirse ilgili şekiller için ayarlanmış olan örnek yönleri başına herhangi bir 'üzerine' olacak.2 veya daha fazla açıklamalar sadece tek Yazı, Yazı stili, yazı tipi rengi ve boyutu kullanılabilir aynı pozisyon ve Ayırıcı işgal nerede Ayrıca, (örneğin virgül, boşluk, yeni satır) seçilmelidir.

Göstermek için isim veya tür ilişkili bir bileşen ya da bağlantı için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya konektör.

3. Seçin Açıklamalar.

Not

Tuval üzerine bir birey ilişkili şekil veya bağlayıcı için size seçmeniz gerekir Stencil Açıklamalar geçersiz kılİlk defa checkbox.

4. Araç çubuğunda Yeni Ek Açıklama Seçin seçin Isim veya Tip.

5. Parantez ve Yazı, Yazı stili, Yazı renk ve Boyutu dahil istenen Ekran seçenekleri seçin Görüntülenen iletişim kutusunda. Ayrıca, Yatay ve Dikey hizalama (yani açıklama pozisyonu) ve Açı (yani dönme) de dahil olmak üzere istenen düzen seçeneklerini belirleyin. Seçin tamam.

Bir özellik göstermek için değer ilişkili bir bileşen ya da bağlantı için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya konektör.

3. Seçin Açıklamalar.

Not

Tuval üzerine bir birey ilişkili şekil veya bağlayıcı için size seçmeniz gerekir Stencil Açıklamalar geçersiz kılİlk defa checkbox.

4. Araç çubuğunda Yeni Ek Açıklama Seçin seçin Mülk değeri.

5. '...' Düğmesini ve Select A Mülkiyet iletişim kutusunda bir özellik seçimi: Mülkiyet tıklayarak özelliği seçin Görüntülenen iletişim kutusundaseçin tamam. Parantez ve Yazı, Yazı stili, Yazı renk ve Boyutu dahil istenen Ekran seçenekleri seçin. Ayrıca, Yatay ve Dikey hizalama (yani açıklama pozisyonu) ve Açı (yani dönme) de dahil olmak üzere istenen düzen seçeneklerini belirleyin. Seçin tamam.

Bir özellik göstermek için işaretleyici ilişkili bir bileşen ya da bağlantı için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya konektör.

3. Seçin Açıklamalar.

Not

Tuval üzerine bir birey ilişkili şekil veya bağlayıcı için size seçmeniz gerekir Stencil Açıklamalar geçersiz kılİlk defa checkbox.

4. Araç çubuğunda Yeni Ek Açıklama Seçin seçin Mülkiyet Marker.

5. '...' Düğmesini ve Select A Mülkiyet iletişim kutusunda bir özellik seçimi: Mülkiyet tıklayarak özelliği seçin Görüntülenen iletişim kutusundaseçin tamam. Piksel işaretleyici ve Renk By Range veya Renk By Mülkiyet birine boyama yöntemi yarıçapı ayarlayın ve renkler atamalarını ayarlayın. Ayrıca, Yatay ve Dikey hizalama (yani açıklama pozisyonu) ve Açı (yani dönme) de dahil olmak üzere istenen düzen seçeneklerini belirleyin. Seçin tamam.

Göstermek için bağlı bileşenler ilişkili bir bileşen ya da bağlantı için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya konektör.

3. Seçin Açıklamalar.

Not

Tuval üzerine bir birey ilişkili şekil veya bağlayıcı için size seçmeniz gerekir Stencil Açıklamalar geçersiz kılİlk defa checkbox.

4. Araç çubuğunda Yeni Ek Açıklama Seçin seçin Ekli Bileşenler.

5. '...' Düğmesine ve Set Bileşeni Türünü iletişim kutusunda bir bileşen türünü seçerek: ilişkili bileşenleri Ekli tıklayarak ekli bileşen türünü seçin için, görüntülenen iletişimseçin tamam. '...' Düğmesine ve Set Bağlantı Tipi iletişim kutusunda bir bağlantı türünü seçmek: Bağlı Via tıklayarak ekli bağlantı türünü seçinseçin tamam.Ilişkili bağlantılarda Kaynak seçerek bağlantı ucunu seçin veya Bağlantı End Sink: pull-down menü. Ilişkili bileşenleri ve bağlantıları hem parantez ve Yazı, Yazı stili, Yazı rengi ve boyutu da dahil olmak üzere istenen Ekran seçeneklerini için. Ayrıca, Yatay ve Dikey hizalama (yani açıklama pozisyonu) ve Açı (yani dönme) de dahil olmak üzere istenen düzen seçeneklerini belirleyin. Seçin tamam.

Göstermek için çocuklar ilişkili bir bileşen için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenlerşablona penceresinin sekme veya tuval üzerine ilişkili şekil.

3. Seçin Açıklamalar.

Not

Tuval üzerine bireysel ilişkili şekli için size seçmeniz gerekir Stencil Açıklamalar geçersiz kılİlk defa checkbox.

4. Araç çubuğunda Yeni Ek Açıklama Seçin seçin Çocuklar.

5. Parantez ve Yazı, Yazı stili, Yazı renk ve Boyutu dahil istenen Ekran seçenekleri seçin Görüntülenen iletişim kutusunda. Ayrıca, Yatay ve Dikey hizalama (yani açıklama pozisyonu) ve Açı (yani dönme) de dahil olmak üzere istenen düzen seçeneklerini belirleyin. Seçin tamam.

Göstermek için Standartlar ilişkili bir bileşen ya da bağlantı için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya konektör.

3. Seçin Açıklamalar.

Not

Tuval üzerine bir birey ilişkili şekil veya bağlayıcı için size seçmeniz gerekir Stencil Açıklamalar geçersiz kılİlk defa checkbox.

4. Araç çubuğunda Yeni Ek Açıklama Seçin seçin Standartlar.

5. Parantez ve Yazı, Yazı stili, Yazı renk ve Boyutu dahil istenen Ekran seçenekleri seçin Görüntülenen iletişim kutusunda. Ayrıca, Yatay ve Dikey hizalama (yani açıklama pozisyonu) ve Açı (yani dönme) de dahil olmak üzere istenen düzen seçeneklerini belirleyin. Seçin tamam.

Göstermek için zaman damgaları ilişkili bir bileşen ya da bağlantı için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıkilişkili bir şekil veya konektörü üzerinde Bileşenler veya Bağlantılarşablona penceresinin sekme veya tuval üzerine ilişkili şekil veya konektör.

3. Seçin Açıklamalar.

Not

Tuval üzerine bir birey ilişkili şekil veya bağlayıcı için size seçmeniz gerekir Stencil Açıklamalar geçersiz kılİlk defa checkbox.

4. Araç çubuğunda Yeni Ek Açıklama Seçin seçin Oluşturuldu Marker, tarafından, düzenlendi, Modifiye, Değiştiren veya Marker Modifiye.

5. Görüntülenen iletişim kutusunda, değilse bir belirteç olarak, parantez ve Yazı, Yazı stili, Yazı renk ve Boyutu dahil istenen Ekran seçeneklerini seçin. Bir marker varsa, piksel işaretleyici ve Renk By Range veya Renk By Mülkiyet birine boyama yöntemi yarıçapı ayarlamak ve renkleri atamalarını ayarlayın. Ayrıca, Yatay ve Dikey hizalama (yani açıklama pozisyonu) ve Açı (yani dönme) de dahil olmak üzere istenen düzen seçeneklerini belirleyin. Seçin tamam.

Bir serbest form şekli yazı stilini değiştirmek içinveya bağlayıcı

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Sağ tıkserbest biçimli şekle veya bağlayıcı Tuval üzerinde. Not: Eğer konnektör Metin etiketi connect göstermek için o göstermek değilveya Metin etiketi: Sağ tıkconnectveyaseçin Ek Açıklama | Göster Açıklaması.

3. Seçin Font değiştir.

4. Iletişim kutusunda bir Yazı, Yazı stili ve Boyut seçin seçin tamam.

Yazı tipini değiştirmek için renk Bir serbest form şekliveya bağlayıcı

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Sağ tıkserbest biçimli şekle veya bağlayıcı Tuval üzerinde. Not: Eğer konnektör Metin etiketi connect göstermek için o göstermek değilveya Metin etiketi: Sağ tıkconnectveyaseçin Ek Açıklama | Göster Açıklaması.

3. Seçin Değişim Yazı Rengi.

4. Bir Yazı SeçinRenk '...' butonuna tıklayarak bir renk seçerek (ve şekiller bağlantı Renk için) iletişim ve seçme de tamam.

5. 0 tamamen şeffaf olmak ve 255 tam opak olmak kaydırıcıyı ayarlayarak metin etiketi Şeffaflık seçin.

Bir serbest form şeklin metin etiketini döndürmek içinveya bağlayıcı

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. Sağ tıkserbest biçimli şekle veya bağlayıcı Tuval üzerinde. Not: Eğer konnektör Metin etiketi connect göstermek için o göstermek değilveya Metin etiketi: Sağ tıkconnectveyaseçin Ek Açıklama | Göster Açıklaması.

3. Seçin Döndürve ardından döndürmek istediğiniz alakalı açısını seçmek Metin etiketi tarafından.

Ayrıca bakınız

Çizim Aracı | Senin mimarisi doldurma | Analiz senin mimari


Mülkiyeti (TCO) ve simülasyonu Toplam Maliyet

Navigasyon: Mimarinizi simulasyonu> Simulatör>

Mülkiyeti (TCO) ve simülasyonu Toplam Maliyet

Yorum gönder bu konuda.

Geçmiş

Mülkiyeti (TCO) Toplam Maliyet sahibi varlıklara ilişkin (devreden çıkarma / bertaraf edilmesinden kaynaklanan) toplam tahakkuk yaşam döngüsü maliyetlerini ölçmek için tasarlanmış bir finansal tahmindir. TCO aynı zamanda varlığın daha kullanımı ve bakımı diğer tüm yönlerini kapsar, satın alma maliyetlerini yansıtan sadece.

TCO çaba belirlemek için kullanılan ve bütçe sistemine geçirmek için gerekli maliyeti. TCO için ABACUS modellemenin basit bir yolu bileşenleri içine aşağı bilişim sistemini kırmaktır. Biz o zaman ortalama bu bileşenlerden biri çalıştırmak için maliyeti ne kadar öğrenebilirsiniz. Biz daha sonra farklı maliyetleri faktör bir sistem zaten ayakta ve çalışıyor ise bilişim sistemi vb evolvable veya açık olup olmadığına bağlı olarak olabilir Bundan sonra, dikkate ana unsur bakım ve decommission belki de maliyet maliyetidir.

Bir örnek

Örnek Hesaplama Şeması

Örgüt veya standart altında bileşen şu özelliklere sahiptir:

· TZE= 100 000 $ / yıl

· Destek Çaba= 0.01 TZE + 0.001 TZE / yıl = 1000 $ + 100 $ / yıl

· Bakım maliyeti= 100 $ - 10 $ / yıl

· Sermaye maliyeti= 2000 $

· Çaba yükleyin= 2 TZE / gün = 0.01 TZE / yıl = 1000 $

Örgüt kapsamında bileşen şu özelliklere sahiptir:

· Horizon yükleyin= -2 Yıl (sistem mevcut önce 2 yıl yüklendiği yani)

· Ömür= 3 yıl

Ne zaman Horizon + Ömrü <= 0 Yükleme , Artık Bakım Maliyeti var.

Hesaplamalar

Şöyle hesaplamalar şunlardır:

Not

TC yılda maliyeti =. SE = Destek Çaba. MC Bakım Maliyeti =.

· Başlangıç ​​maliyeti = Sermaye Maliyeti + Çaba yükleyin= 2000 + 1000 = 3000 $

· T = -2 (1 yıl boyunca), TC = Başlangıç ​​maliyeti + SE + MC+ 100 + 1000 = 3000 = 4100 $

· T = -1 'de, TC = SE + MC= (1000 + 100) + (100-10) = 1190 $

· T = 0 'de, TC = (+ 200 1000) + (100-20) = 1280 $

· T = 1 (son yıl), TC = (+ 300 1000) + (100-30) = 1370 $

Örnek Hesaplama Grafiği

Sistem hizmetten kadar TCO tüm mevcut ve gelecekteki maliyetlerin toplamıdır.

· T = -2 (1 yıl boyunca), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· T = -1 anda, TCO = 1190 + 1280 + 1370 = 3840 $

· T = 0 anında, TCO = 1280 + 1370 = 2650 $

· T = 1 (son yıl), TCO = 1370 $ at

Anahtar Maliyet Faktörleri

Hangi ABACUS'e bir varlığın TCO hesaplarken önemli maliyet faktörleri dikkate alınması gereken:

· Donanım Edinme- Ekipmanlar (sermaye maliyeti) Başlangıç ​​maliyeti.

· Yazılım Toplama- Yazılım (sermaye maliyeti) için lisans Başlangıç ​​maliyeti.

· Kurulum- Ilk kurulum ile ilgili giderler.

· Eğitim- İlk kurulumdan sonra dış satıcı eğitimi ile ilişkili maliyet.

· Destek- İç desteği ile ilişkili maliyet.

· Bakım- Maliyetler değiştirmek veya satıcı bakım sözleşmeleri, gereç ve felaket kurtarma maliyetleri yükseltmek için.

· Altyapı- Ile ilgili maliyetler varlığı desteklemektedir.

Anahtar Maliyet Faktörleri ABACUS Örnek Temsilciliği

Maliyet simülatörü Koşu

Maliyet açısından da mimari simüle etmek

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Seçin Çözümleme| Maliyet.

3. Seç Mimari (ler)Eğer değerlendirmede dahil etmek istiyoruz.

Not

Varsayılan olarak, ABACUS otomatik olarak yeniden simülasyon altta yatan herhangi bir mülkiyet veya yapısal değişiklikler nedeniyle gerekli olduğu mimari (ler) seçecek.Bu vurgulama gösterilir Kırmızı üzerinde Simülasyon araç çubuğu .

4. Seçin Paraaşağı çekme gelen.

5. Taşı Yaşında hesaplamakGerekli yıl sayısına göre kaymak.

Not

Varsayılan olarak, yaşında hesaplamak eğer maliyetler otomatik olarak her yıl için hesaplanan (ve özellikleri bir koleksiyon eklendi / güncellendi) ve daha sonra yıl numaranın tamamı için kümülatif değeri de hesaplanacaktır fazla 1 yıl daha. Sadece kümülatif değer gerekiyorsa o zaman işaretini kaldırın Başına Yıllık Maliyetleri hesaplayınProjenin özelliklerinde sayısına kaydetmek için aşağıda tarif edildiği gibi bir seçenek.

6. Bırakmak seçin Başına Yıllık Maliyetleri hesaplayınkontrol veya işaretini kaldırın.

7. Tıklayın Sonraki.

8. İsteğe bağlı seçim BağlantılarEğer değerlendirmenin bir parçası olarak birlikte maliyetleri atfetmek istiyorum.

Not

Kullanma Maliyet | AtfetmeBağlantılar maliyetleri üzerindeki mülkiyet olabilir atfedilen Kaynak ucuna takılmış bileşene bağlantının lavabo ucuna takılmış bileşeni(yani Maliyet | Atıf = "Lavabo Kaynak için"), ya da bağlı bileşeni kaynak bağlı bileşenin bağlantı ucu lavabo son(yani Maliyet | Atıf = "Kaynak Sink için"). Buna ek olarak, | ABACUS otomatik Davranış olan bağlantıları seçecektir Medeni = "işlemler" ya da "destekler"ve atıf yönü 'Kaynak için Sink' olacak. Bundan başka, maliyeti paylaştırılır | herhangi Davranış göre % Veya Maliyet | Birçok kaynaklarına bir lavabo birden fazla bağlantı vardır alternatif% bağlantıları özellikleri, yaBirçok lavabolara veya kaynakHerhangi bir Davranış uygun | Kaynak bileşenleri İşleme özellikleriveya sırasında bileşenleri lavabo.

9. Tıklayın Finishve sen-ecek almak Uyarıiletişim.

10. İsteğe bağlı tıklayarak uyarıları keşfetmek Detaylar >>.

11. Tıklayın Devam.

Not

Bu noktada, ABACUS mimarisi (ler) bir faaliyet tabanlı maliyetlendirme değerlendirmesini gerçekleştirecek ve kısa bir süre sonra (geri bildirim için ilerleme çubukları ile) hesaplama komple iletişim kutusu görünecektir.

12. Tıklayın tamamdeğerlendirme kabul etmek.

Bahşiş

Eğitim kursları ve Maliyet Simülasyonu ile ilgili daha fazla yardım için başvurun Avolution Topluluk .

Bileşen ve / veya bağlantı Özellikler

Aşağıdaki tabloda bileşenini listeler ve / veya bağlantı özellikler maliyet değerlendirmek için gerekli.Bu özellikler (bir mülk giriş satır seçim simgesi ile Properties penceresinde gösterilir [image] ) Tooltip 'Maliyet Girdi' ile. Belirtildiği gibi bu 'giriş' özelliklerine ve depo çeşitli yapısal değişikliklere herhangi bir değişiklik yeniden simülasyon gerektiren Maliyet simülatörü neden olacaktır Kırmızı üzerinde Simülasyon araç çubuğu .

Tip

Isim

Varsayılan değer

Ünite

Veri tipi

Gerekli

Açıklama

Maliyet

Horizon yükleyin

0

yıl

Tamsayı

Gerçek

Ne zaman bileşeni belirtir veya bağlantı olmuştur, ya da kurulacaktır.

· 0 (varsayılan) değeri bileşeni olduğunu gösterir veya bağlantı cari yıl içinde monte ediliyor.

· 0'dan az bir değer bileşeni olduğunu gösterir veya bağlantı Geçmişte yüklenmiştir.

· 0'dan büyük bir değer bileşeni olduğunu gösterir veya bağlantı Gelecekte kurulacak.

Maliyet

Ömür

0

yıl

Tamsayı

Gerçek

Süreyi belirtir içerisinde komponentin veya bağlantı o görevden olacak bundan sonra, operasyonda kalacaktır.

Maliyet

TZE

100.000,00

$ / yıl

Ondalık

Sahte

Her Tam Zamanlı Çalışan yıllık maliyeti.

Bu özellik bileşeni bulunamazsakendisi ya da bağlantı halinde komponent bağlantı lavabo ucuna bağlanmış, Diğer bileşenlerde aranacaktır.

İlk olarak, herhangi bir 'lavabo' bileşens sonunda a Bir "destekler" ilişki ile bağlantı bileşenine ardından aranacak 'lavabo' bileşenin üst olduğunus.

TZE özelliği bulunmazsa, bileşenin ebeveyn-Bileşenler sonra aranacaktır. TZE hala bulunmazsa, varsayılan değer kullanılır.

Lütfen dikkat: TZE bileşenleri sadece geçerli giriş özelliğidir.

Maliyet

Bakım Maliyeti (sabit)

0.00

$ / yıl

Ondalık

Sahte

Bileşeni sürdürmenin yıllık sabit maliyetveya bağlantı.

Maliyet

Bakım Maliyeti (değişken)

0.00

$ / yıl

Ondalık

Sahte

Miktar hangi bileşenin sürdürmenin toplam maliyeti veya bağlantı Her yıl değişecektir.

Örneğin, $ -500 değeri 500 $ değer olduğunu gösterir iken, toplam bakım maliyeti 500 $ her yıl azalmakta olduğunu gösterir 500 $ her yıl toplam bakım maliyeti artar.

Maliyet

Destek Efor (sabit)

0.00

TZE / yıl

Ondalık

Sahte

Bileşeni destekleyen yıllık sabit çabaveya bağlantı, Kişi-yıl cinsinden belirtilmiş.

Maliyet

Destek Efor (değişken)

0.00

TZE / yıl

Ondalık

Sahte

Miktar hangi bileşenin destekleyen toplam çaba veya bağlantı Her yıl değişecektir.

Örneğin, -0.01 değeri 0.01 değer ifade ederken, toplam destek çabası 0.01 kişi yıllar her yıl azalmakta olduğunu gösterir 0.01 toplam destek çabası artar, her yıl olduğu.

Maliyet

Sermaye maliyeti

0.00

$

Ondalık

Sahte

Bileşeni satın alma başlangıç ​​maliyetiveya bağlantı.

Maliyet

Çaba yükleyin

0.00

TZE

Ondalık

Sahte

Çaba bileşeni yüklemek için, kişi-yıl içinde, gerekliveya bağlantı.

Aşağıdaki tabloda bileşenini listeler ve / veya bağlantı TCO değerlendirici tarafından çıkarılır özellikleri. Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Maliyet Çıktı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Maliyet simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Not

TCO değerlendirici çıkış özelliklerini olması gereken yere kullanılan yaklaşım (aynı zamanda 'bankacılar' yuvarlama olarak anılacaktır) "Hatta Yuvarlak yarısını" 'yuvarlak'.Bu teknik daha eşit herhangi .5 gidermek için kullanılan sonuç 'tie-tatili' yuvarlanır veya en yakın aşağı olması hatta Sonuç, daha doğrusu hep yuvarlama veya aşağı ve sonucu kıvrılıyor daha. Yani 3.5 4'e kadar yuvarlanır iken 2.5 hem 2 ve 3 aşağı yuvarlanır veya 3 ve 4'e kadar yuvarlanır olmak ya ziyade onları daha, 2 aşağı yuvarlanır.

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Maliyet | Sahibi için Toplam Maliyet - Bir sonraki x yıl. | $ | Tamsayı | Sahte | Bir sonraki boyunca toplam sahip olma maliyeti xx değerlendirici çalıştırırken belirtilen süre uzunluğu yıl. Bu bileşen, en maliyetini kapsar veya bağlantı en standartlar, alt bileşenlerveya alt bağlantıları(yani çocuklar) ve herhangi atfedilen maliyetler.
Maliyet | Toplam Maliyet (yerel) Sahibi için - önümüzdeki yıl x. | $ | Tamsayı | Sahte | Bir sonraki üzerinde sahiplik 'Yerel' maliyet xyaş, burada xdeğerlendirici çalıştırırken belirtilen süre uzunluğudur. Bu does değilbileşenin alt bileşenlerinin maliyeti dahil veya bağlantının alt bağlantıları (yaniçocuklar) ya da herhangi bir atfedilen maliyetler.
Maliyet | Bir sonraki x yıl - Toplam Maliyet (çocuk) Sahibi için. | $ | Tamsayı | Sahte | Bir sonraki üzerinde sahiplik 'Çocuk' maliyet xx değerlendirici çalıştırırken belirtilen süre uzunluğu yıl. Bu sadece bileşenin alt bileşenlerinin maliyetini kapsar veya bağlantının alt bağlantıları (yani çocuklar).
Maliyet | Toplam Maliyet (atfedilen) Sahibi için - önümüzdeki yıl x. | $ | Tamsayı | Sahte | Bir sonraki üzerinde sahiplik 'atfedilen' maliyet xx değerlendirici çalıştırırken belirtilen süre uzunluğu yıl. Bu sadece Ekli bileşenlerden herhangi atfedilen maliyetleri içerir(tabii herhangi ekli bağlantılarından maliyetleri atfedilen dahil olabilir).

Aşağıdaki tabloda bileşenini listeler ve / veya bağlantı TCO değerlendirici tarafından çıkarılır özellikleriHesapla Per-Yıl Maliyetleri eğer seçeneği seçildiğinde. Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Maliyet Çıktı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Maliyet simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Not

Çıkış özelliklerinin olası yuvarlama yukarıdaki nota bakın.

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Maliyet | Toplam Maliyet Sahibi için - Yılx. | $ | Tamsayı | Sahte | Toplam sahip olma maliyeti için yıl x, Burada x her yıl için değerlendirici çalıştırırken belirtilmiş. Bu bileşen, en maliyetini kapsarveya bağlantı en standartlar, alt bileşenler veya alt bağlantıları (yani çocuklar) ve herhangi atfedilen maliyetler.
Maliyet | Toplam Maliyet (yerel) Sahibi için - yılx. | $ | Tamsayı | Sahte | Mülkiyet 'Yerel' maliyet yıl x, Burada xolduğunu her yıl için değerlendirici çalıştırırken belirtilmiş. Bu does değilbileşenin alt bileşenlerinin maliyeti dahil veya bağlantının alt bağlantıları (yani çocuklar) ya da herhangi bir atfedilen maliyetler.
Maliyet | Toplam Maliyet (çocuk) Sahibi için - yılx. | $ | Tamsayı | Sahte | Mülkiyet 'Çocuk' maliyet yıl x, Burada x her yıl için değerlendirici çalıştırırken belirtilmiş. Bu sadece bileşenin alt bileşenlerinin maliyetini kapsar veya bağlantının alt bağlantı (yani çocuklar).
Maliyet | Toplam Maliyet (atfedilen) Sahibi için - yılx. | $ | Tamsayı | Sahte | Mülkiyet 'atfedilen' maliyet yıl x, Burada x her yıl için değerlendirici çalıştırırken belirtilmiş. Bu sadece Ekli bileşenlerden herhangi atfedilen maliyetleri içerir(tabii herhangi ekli bağlantılarından maliyetleri atfedilen dahil olabilir).

Ek Bağlantı Özellikleri

Aşağıdaki tabloda, ek TCO değerlendirici tarafından gerekli olan bağlantı özellikleri. Bu özellikler (bir mülk giriş satır seçim simgesi ile Properties penceresinde gösterilir [image] ) Tooltip 'Maliyet / Performans Giriş' ya da sadece 'Maliyet Girdi' ile. Bu 'giriş' özelliklerine ve depo çeşitli yapısal değişikliklere herhangi bir değişiklik Maliyeti neden olur ve / veya Performans simülatörü belirtildiği gibi, bir tekrar-simülasyon gerektiren Kırmızı üzerinde Simülasyon araç çubuğu .

Tip

Isim

Varsayılan değer

Ünite

Veri tipi

Gerekli

Açıklama

Maliyet

Atfetme

Kaynak Sink

[Kaynak Lavabo için | Kaynak Sink]

Arama / Liste

Gerçek

"EğerKaynak Lavabo için"Bu bağlantı irade var var maliyetsatfedilen 'boyunca' o itibaren kaynakBileşen lavabo bileşen. Seçenek olarak ise, eğer "Kaynak Sink"Bu bağlantı irade maliyetler 'boyunca' atfedilen var o Kaynak bileşene lavabo bileşeninden.

Davranış

Ilişki

destekler

[süreçler | ] destekler

Arama / Liste

Sahte

"Destekler" Eğer bu bağlantı "kaynak" bileşen "lavabo" bileşeni tarafından desteklenen olduğunu gösterir.

Ya "destekler" ya da daha sonra bağlantı otomatik bağlantı seçilecektir "işlemler" var, ayrıca, maliyetleri kaynak bileşene lavabo bileşeninden 'boyunca' bağladı.

Maliyet

%

100.0

%

Ondalık

Sahte

Kaynak bileşenin atfedilen edilecek lavabo parçaları maliyetlerin oranını gösterir. % Değerleri% 100 kadar eklemek gerekmez ve sadece ölçeklemek için kullanılan "Sahibi Toplam Maliyet -. Bir sonraki yıl x" lavabo bileşeninden özellik (yukarıya bakınız) kaynak bileşeni atfedilir olarak.

Mimari Özellikleri

Aşağıdaki tabloda, TCO değerlendirici tarafından çıkarılır mimari özelliklerini listeler. Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Maliyet Çıktı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Maliyet simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Not

Çıkış özelliklerinin olası yuvarlama yukarıdaki nota bakın.

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Maliyet | Sahibi için Toplam Maliyet - Bir sonraki x yıl. | $ | Tamsayı | Sahte | Gelecek x yılda tüm mimari toplam sahip olma maliyeti.

Aşağıdaki tabloda, TCO değerlendirici tarafından çıkarılır mimari özelliklerini listelerHesapla Per-Yıl Maliyetleri eğer seçeneği seçildiğinde. Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Maliyet Çıktı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Maliyet simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Not

Çıkış özelliklerinin olası yuvarlama yukarıdaki nota bakın.

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Maliyet | Toplam Maliyet Sahibi için - yılx. | $ | Tamsayı | Sahte | Toplam sahip olma maliyeti için Tüm mimari yıl x geleceğe.


Simülasyon Modüler

Navigasyon: Mimarinizi simulasyonu> Simulatör>

Simülasyon Modüler

Yorum gönder bu konuda.

Modülerlik simülatörü her bir bileşen için gelen ve giden bağlantı sayısını hesaplar.

Modülerlik açısından sizin mimarisi simüle etmek

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Seçin Çözümleme| Modülerlik.

3. Seç Mimari (ler)Eğer değerlendirmede dahil etmek istiyoruz.

Not

Varsayılan olarak, ABACUS otomatik olarak yeniden simülasyon herhangi altta yatan yapısal değişiklikler nedeniyle gerekli olduğu mimari (ler) seçecek.Bu vurgulama gösterilir Kırmızı üzerinde Simülasyon araç çubuğu .

4. Tıklayın Sonraki.

5. Seç Bağlantı Türleri (ler)Eğer değerlendirmede dahil etmek istiyoruz.

6. Tıklayın Sonraki.

7. İsteğe bağlı hesaplama sonuçları için özellik adlarını özelleştirebilirsiniz.

8. Tıklayın Finish.

Not

Bu noktada, ABACUS mimarisi (ler) yapısal bir değerlendirmesini yapacak ve kısa bir süre sonra (geri bildirim için ilerleme çubukları ile) hesaplama komple iletişim kutusu görünecektir.

9. Tıklayın tamamdeğerlendirme kabul etmek.

Bahşiş

Modüler Değerlendirilmesine İlişkin eğitim kursları ve daha fazla yardım için başvurun Avolution Topluluk .

Bileşen Özellikleri

Aşağıdaki tabloda, modülerlik değerlendirici tarafından çıkarılır bileşen özelliklerini listeler.Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Birimsellik Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve modülerlik simülatörü altta yatan yapısal bir değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Veri tipi | Gerekli | Açıklama
Modülerlik | Kaplin-fan (yerel) | Tamsayı | Sahte | Bağlantı sayısı, bu bileşenin içine fan.
Modülerlik | Kavrama-fan çıkışı (yerel) | Tamsayı | Sahte | Bağlantı sayısı, bu bileşenin dışında o hayran.
Modülerlik | Kaplin fan | Tamsayı | Sahte | Bağlantı sayısı o alt bileşenlerine içine fan bağlantıları da dahil olmak üzere, bu bileşeni içine fan.
Modülerlik | Kavrama-fan dışarı | Tamsayı | Sahte | Alt bileşenleri içine fan bağlantıları dahil olmak üzere bu bileşenin, dışarı fanı bağlantı sayısı.


Simülasyon Açıklık

Navigasyon: Mimarinizi simulasyonu> Simulatör>

Simülasyon Açıklık

Yorum gönder bu konuda.

Açıklık simülatörü olduğunu, en az etkisi olan bileşenlerin değiştirilmesi işlemek için sistemin yeteneği, bir mimarlık ve unsurları 'açık' olduğu için derecesini belirler.

Açıklık açısından sizin mimarisi simüle etmek

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Analiz Seçin | Açıklık.

3. Seç Mimari (ler)Eğer değerlendirmede dahil etmek istiyoruz.

Not

Varsayılan olarak, ABACUS otomatik olarak yeniden simülasyon altta yatan herhangi bir mülkiyet veya yapısal değişiklikler nedeniyle gerekli olduğu ilk mimari seçecektir.Bu vurgulama gösterilir Kırmızı üzerinde Simülasyon araç çubuğu .

4. Tıklayın Finishve sen-ecek almak Uyarıiletişim.

5. İsteğe bağlı tıklayarak uyarıları keşfetmek Detaylar >>.

6. Tıklayın Devam.

Not

Bu noktada, ABACUS mimarisi (ler) yapısal bir değerlendirmesini yapacak ve kısa bir süre sonra (geri bildirim için ilerleme çubukları ile) hesaplama komple iletişim kutusu görünecektir.

7. Tıklayın tamamsimülasyon kabul etmek.

Bahşiş

Eğitim kursları ve açıklık Değerlendirilmesine İlişkin daha fazla yardım için başvurun Avolution Topluluk .

Bileşen ve Bağlantı Standart Özellikleri

Aşağıdaki tablo açıklığı değerlendirmek için gerekli bileşen ve bağlantı standart özelliklerini listeler.Bu özellikler (bir mülk giriş satır seçim simgesi ile Properties penceresinde gösterilir [image] ) Tooltip 'Açıklık Girdi' ile. Belirtildiği gibi depodaki bu 'giriş' özelliklerine herhangi bir değişiklik yeniden simülasyon gerektiren Açıklık simülatörü neden olacaktır Kırmızı üzerinde Simülasyon araç çubuğu .

Tip | Isim | Varsayılan değer | Ünite | Veri tipi | Gerekli | Açıklama
Açıklık | Standartlar Standart Olgunluk-Organizasyon Düzeyi |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Sorumlu Standartlar Vücut Düzeyi 0:Tescilli / Organizasyonel 1:Konsorsiyum / Defacto 2:Ulusal / Askeri 3: Uluslararası
Açıklık | Standartlar Standart Olgunluk Durumu |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Onay düzey standartları gövde ile elde 0:Çalışma / Komitesi Taslak 1:Kamu Taslak / Sandıklardan 2:Geçici Taslak 3:Onaylı
Açıklık | Standartlar Standart Olgunluk-Kararlılık |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Standart değişme olasılığı var mı? 0:Eski Standart 1:Bir sonraki 1 ila 2 yıl içinde değiştirmek için son derece tabidir 2:Mevcut özellikler Bilinen değişim / güncellemeler 3:Son derece kararlı (2 yıl içinde değişiklik yok)
Açıklık | Standartlar Standart Olgunluk-Satıcı Desteği |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Satıcı Desteği 0:Hiçbir ürün veya satıcıları standardını destekleyen 1:Standart bir kısmını yerine bir veya daha fazla satıcı 2:Standardın tüm parçaları uygulamak ürünleri ile birden fazla satıcı 3:Daha birçok standardın tüm parçaları uygulamak ürünleri ile satıcı birden
Açıklık | Standartlar Standart anlaşılırlık-Belgeler |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Standart belgelerin Kalite 0:Fakir 1:Fuar 2: İyi 3: Mükemmel
Açıklık | Standartlar Standart anlaşılırlık-Standart Genişlik |  |  | Tamsayı | Sahte | Diğer özelliklerin sayısı. En düşük seviyesi standart özellikleri bir sayım - Sf
Açıklık | Standartlar Standart anlaşılırlık-Sm |  | % | Ondalık | Sahte | Zorunlu özelliklerin toplam sayısının yüzdesi
Açıklık | Standartlar Standart anlaşılırlık-So |  | % | Ondalık | Sahte | Isteğe bağlı özellikler toplam sayısının yüzdesi
Açıklık | Standartlar Standart anlaşılırlık-Sc |  | % | Ondalık | Sahte | Koşullu tanımlanan özelliklerin toplam sayısının yüzdesi
Açıklık | Tercihler-Profil Dokümantasyon-Belgeler |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Standart belgelerin Kalite 0: Hiçbiri 1:Fakir 2:Fuar 3: Mükemmel
Açıklık | Tercihler-Profil Dokümantasyon-Doğruluk |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Dokümantasyon gerçek sistem tasarımını yansıtıyor mu? Profil özelliklerinin hangi düzeyde sisteminde kullanılır? 0:Hiçbir özellik 1:Bazı özellikler 2:En özellikleri 3:Tüm özellikler
Açıklık | Tercihler-Profil Dokümantasyon-Vade |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Profil olgun ve kullanılabilir mi? 0: Geçici 1:Proje bazlı 2:Organizasyonel 3:Kamu
Açıklık | Tercihler-Profil belirginliğinin-Açık Genişliği |  |  | Tamsayı | Sahte | Belirtilen standart özelliklere sayısı profilinde GEREKLİ olarak
Açıklık | Tercihler-Profil belirginliğinin-Pm |  | % | Ondalık | Sahte | Profilinde ZORUNLU özelliklerin yüzdesi
Açıklık | Tercihler-Profil belirginliğinin-Po |  | % | Ondalık | Sahte | OPSİYONEL Yüzde profilinde özellikleri
Açıklık | Tercihler-Profil belirginliğinin-Pc |  | % | Ondalık | Sahte | Profilinde Şartlı yüzdesi TANIMLI özellikleri
Açıklık | Tercihler-Profil belirginliğinin-Kapsama |  | % | Ondalık | Sahte | Standart özellikler yüzdesi özellikle profilinde ele
Açıklık | Tercihler-Profil Uzantıları-Uzatma Genişliği |  |  | Tamsayı | Sahte | Standart dışı sayısı profili tarafından belirlenen özellikleri
Açıklık | Tercihler-Profil Uzantıları-Kapsama |  | % | Ondalık | Sahte | Uzantıları yüzdesi profilinde ayrıntılı
Açıklık | Ürünler-Ürün Durumu ve Ürünleri uygunluk-sayısı |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Standart zorunlu özellikleri destekleyen ürün sayısı 0:Ürün yok standardını destekleyen 1:Bir veya daha fazla ürün standardının bir kısmını uygulamak 2:Birden fazla ürün standardının tüm parçaları uygular 3:Birçok birden fazla ürün standardının tüm parçaları uygular
Açıklık | Ürünler-Ürün Durumu ve Uygunluk Başvuru Uygunluk |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Ürünler standardına uygun ne düzeyde var? 0: Hiçbiri 1:Iddia 2:Kanıtlanmış 3:Sertifikalı ve kanıtlanmış
Açıklık | Ürünler-Ürün Durumu ve Uygunluk-Uygunluk Kalitesi |  | [0 | 1 | 2 | 3] | Arama / Liste | Sahte | Uygunluk testleri Kalite 0: Hiçbiri 1:Ürün geliştirici tarafından In-house test 2:Bağımsız test (örn NIST) 3:İlgili ürünün bağlamında kanıtlanmış

Bileşen, Bağlantı ve Mimarlık Özellikleri

Aşağıdaki tabloda, açıklık değerlendirici tarafından bileşeni, bağlantı ve mimari özellikleri çıkışını listeler. Aşağıdaki özelliklerin tamamı sıfır (0) arzu azından şimdilik ve (0) ve üç (3), sıfır arasında değerlendirmek üç (3) en çok arzu edilen varlık.Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Açıklık Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Açıklık simülatörü altta yatan mülkiyet değişikliğine güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Veri tipi | Gerekli | Açıklama
Açıklık | Açıklık | Ondalık | Sahte | Öğenin açıklık Genel değerlendirme.
Açıklık | Standartlara Standart Olgunluk | Ondalık | Sahte | O kullanım ve ne kadar iyi kabul geliştiriciler topluluğu içinde olmuştur ne kadar uzun, onaylandıktan olup olmadığını yansıtan standardın mevcut durumu,.
Açıklık | Standartlar Standart anlaşılırlık | Ondalık | Sahte | Bunu takip eden standartlar potansiyel belirsizliği yansıtan standartlar anlaşılırlık,
Açıklık | Tercihler-Profil Belgeler | Ondalık | Sahte | Arayüz profil belgeleri ne ölçüde geliştirilmiş ve profil belgeleri gerçek sistem tasarımı yansıtıp yansıtmadığını ve / veya uygulanan sistem
Açıklık | Tercihler-Profil belirginliğinin | Ondalık | Sahte | Bir profil / profil şartnamede verilen detay seviyesi
Açıklık | Tercihler-Profil Uzantıları | Ondalık | Sahte | O dayandığı standarda profil uyan hangi derecesi
Açıklık | Ürünler-Ürün Durumu ve Uygunluk | Ondalık | Sahte | Olsun ya da olmasın projede kullanımı için açık standart uyumluluğunu ürün bulunmamaktadır


Simülasyon Performansı

Navigasyon: Mimarinizi simulasyonu> Simulatör>

Simülasyon Performansı

Yorum gönder bu konuda.

Geçmiş

Performans için mimari değerlendiricinin bir mimariye boyunca mesajların (ya da jeton) akışını simüle ederek çalışır bir ayrık olay simülatörü. Bu arkasındaki teori Technology, Sydney Üniversitesi tarafından yapılan araştırma türetilmiştir ve dayalı Katmanlı Kuyruk Şebeke Modelleri(LQNM), Zamanlı ve Renkli Petri-Nets(TCPN) ve Etkinlik Döngüsü Diyagramları(ACD).

ABACUS performans simülasyonda, bir bileşen üzerinde işlem başka bir bileşen tarafından kendisine iletilen mesajlar büyük ölçüde tahrik edilir. Bu tekniğin ardındaki ilkeler dört ana bölümden anlaşılabilir:

1. mesajı merkezliiletişim kullanarak ABACUS'e modellenmiştir mantıksal(ya da dolaylı) bağlantıları. Mantıksal bağlantı bileşenleri arasında mesajların gönderilme davranışını (frekans ve veri) tanımlar. Mantıksal bağlantı iyi bir örnek dizisi iki (2) iş süreçlerine ya da iki (2) uygulamalar arasındaki mantıksal arayüzler arasında akan olacaktır.

2. Mantıksal mesajlar aracılığıyla hedefe taşınır hiyerarşi(örneğin kaynak swimlanes gibi) veya direkt(örneğin fiziksel teller gibi) bağlantıları. Onlar karşısında yukarı yönlendirilebilir bunu ve doğrudan yolu takip etmek hiyerarşi (katmanlı yaklaşım) geri adım.

3. Modelin aslına uygun olarak ayarlanabilir. Örneğin, bir işlem şu ana kadar böyle her bir temel proses ve fonksiyon ayrı bir işleme alanına sahiptir aşağı ayrılabilir. Alternatif olarak, bu yansıtan, tüm süreç için tek bir değere sahip yeterli olabilir ortalamaBir mesaja cevap işleme.

4. Güncel işlemeSadece bir işlemci (ya da vardır) bileşenleri tarafından gerçekleştirilir. Bir işlemci genel bir şeydir ve CPU, bir kişinin, bir kuruluş birimi veya çalışma yürüten yeteneğine sahiptir başka bir şey olabilir. Örneğin, bir iş süreci herhangi bir fiili işleme yapmaz; bu ilk 'işlemci' it (bir kulvar gösterim kullanılırsa), ya üst hiyerarşisinde bulur ya da (dağıtılmış işlem gösterim kullanılırsa) kendi işlem ağı tarafından yapılır.

Değerlendirme, her bağlantı en az bir kez simüle edilir, öyle ki, sistem (Belirtilen) trafik taklit ederek gerçekleştirilir. Mesajların varış saatleri rastgele onların belirtilen frekans açısından oluşturulacak. Model çeşitli çıkış özellikleri olarak yol boyunca istatistikleri toplamak, kaynak işleme ve çekişme ve mesajların kuyruk simüle eder.

Anahtar Performans Girdi Faktörleri

1. Frekans- Bağlantı meydana geldiği andaki frekans.

2. İşleme- Yürütme zamanı miktarı, bir işlemi tamamlamak için. Bu saat, dakika, gün, operasyonlar vb olabilir

3. Hız- İşlemci kaynak hızı. Yani o zaman bir ünitede gerçekleştirebilirsiniz nasıl devir / talimatlar / eylemler, birçok olduğunu. Bu işleme için kullanılan birimler ile tutarlı olması önemlidir.

4. İşlemciler- Işlemci kaynaklarının sayısı. İşlemciler vb insanlar, CPU, dış kuruluşlar olabilir

Anahtar Performans Çıktı Faktörleri

1. Üretilen- Aracılığıyla zaman birimi başına ileti sayısı bağlantı. Bu gerçek değer sisteminin doygunluğunu anlamak için beklenen / teorik değerler (yani Frekans) ile karşılaştırılabilir.

2. Mesaj Oranı- Aracılığıyla zaman birimi başına ileti sayısı bileşen. Bu, tüm bileşenlerinin 'gelen ve giden mesajların toplamıdır.

3. Tepki- Bunun için asgari / ortalama / maksimum gecikme bağlantı. Bu lavabo ve herhangi bir kuyruk ve işleme kaynaktan bağlantı için tüm gözlenen gecikmeleri toplamıdır (ve kaynağına geri çift yönlü ise gecikme).

4. Kullanım- Yararlanma bileşen. Bileşen, bir cihaz / işlemci değilse bu% 0 olacaktır (yani yukarıda tanımlanan İşlemciler ve Hız özelliklere sahip değildir).

Yukarıda tarif edildiği gibi ayrı bir olay simülasyonu, çeşitli çıkış özelliklerin hesaplanması için gerçekleştirilir birlikte, aşağıdaki formül (Sistem doymuş değildir) sonuç kaba bir doğrulama olarak kullanılabilir:

Kullanım = * İşleme / tüm gelen bağlantılar için Frekans Sum (Hız * İşlemciler)

Genel kavram belki de en iyi iki farklı performans meta-modeller gösterir Aşağıdaki diyagram, göz önünde bulundurularak ortaya konmuştur. Sol tarzı kendi işlemci kaynakları dahilinde hiyerarşik bazlı işlem görevleri ile klasik 'kulvar' bir nottur. Sağ tarzı kendi işlemci kaynağına bir süreçler bağlantısıyla bağlanan işlem görevleri ile bir 'dağıtılmış' bir nottur. Bu ikinci gösterim sınırlı kulvar gösterimde aksine, belirli bir işlem görev için birden fazla işlemci kaynaklarını tanır.

Not

Her meta-model üzerinde giriş özellikleri (kırmızı) ve çıkış özellikleri (mavi) olarak gösterilmiştir:

Performans meta-modeller: Dağıtılmış gösterimde karşı kulvar

Performans simülatörü Koşu

Performans açısından da mimari simüle etmek

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Seçin Çözümleme| Performansveya araç çubuğu düğmesini tıklatın.

3. Seçin MimarlıkEğer açılan menüden değerlendirmek istiyoruz.

Not

Varsayılan olarak, ABACUS otomatik olarak yeniden simülasyon altta yatan herhangi bir mülkiyet veya yapısal değişiklikler nedeniyle gerekli olduğu ilk mimari seçecektir.Bu vurgulama gösterilir Kırmızı üzerinde Simülasyon araç çubuğu .

4. Seçin Bileşenler ve Bağlantılarsizden, değerlendirmek isteyen Standart eleman seçimi penceresi .

5. Yı kur Run Time Ölçek Faktörükaymak.

Not

Yüksek değerler daha istatistiksel tutarlı sonuçlar ancak hesaplamak için uzun zaman alacaktır.

Ek Onay Kutusuiçin Standart eleman seçimi penceresi

· SDönüştürülmüş Model aveirade mevcut proje ile aynı klasörde projenin RBD dönüştürülmüş sürümünün bir kopyasını kaydetmek ve proje adına "_transformed" append.Bu dönüştürülmüş proje ayrıntılı olarak ABACUS'te tarafından üstlenilen güvenilirlik simülasyonu teşhis etmek için kullanılabilir.

Diğer seçenekler Standart eleman seçimi penceresi

· Run Time Ölçek Faktörü daha yüksek simülasyon zamanını ve doğruluğu kontrol değerler verimingdaha tutarlı sonuçlar istatistiksel ama çekici uzun zaman koşmak.

Not

ABACUS simülasyon zamanını hesaplar zaman sonra bu bağlantının (Frekans üzerinde yani 1) Dönem 'ısınmasını' simüle edilmesi seçildi yavaş dolaylı bağlantı Frekans belirlemek ve (rastgele tüm bağlantıları için periyodik mesaj jeneratörleri başlatılması Bu ısınma süresi boyunca, onlara başlatmak) ve daha sonra bu bağlantının Run Time Scale Factor kez Dönemine simüle etmek için tüm bir şans vermek. (1 / Frekans) ısınma süresi + (1 / Frekans) * Run Time Ölçek Faktörü simülasyon zamanı Or. Bu istatistikler toplanır ve daha sonra yavaş bağlantı hala en az bir kez simülasyonda simüle önce tüm bağlantıların başlatılan olduğundan emin olmaktır. Örneğin Yavaş dolaylı bağlantı 0.033 zaman birimlerinin Frekansı (veya bir zamanlar zaman birimleri günler ise bir ay dolaylarında), sonra ısınma süresi 30.3 zaman birimleri olacak ve eğer simülasyon süresi 30.3 zaman birimleri kez olacak Çalışma zamanı Ölçek Faktörü.

6. Tıklayın Finishve sen-ecek almak Uyarıiletişim.

7. İsteğe bağlı tıklayarak uyarıları keşfetmek Detaylar >>.

8. Tıklayın Devam.

Not

Bu noktada, ABACUS mimarisinin bir kesikli simülasyon gerçekleştirecek ve (geri bildirim için ilerleme çubukları ile birlikte) kısa bir süre sonra bir hesaplama komple iletişim kutusu görünecektir.

9. Tıklayın tamamsimülasyon kabul etmek.

Bahşiş

Eğitim kursları ve Performans Simülasyon hakkında daha fazla yardım için başvurun Avolution Topluluk .

Bileşen Özellikleri

Aşağıdaki tablo performansını değerlendirmek için gerekli özellikleri listeler. Bulunmazsa eğer Özellikleri Bileşen durumlarda ilk aranır, sonra da Bileşen Standartlar ve varsayılan kullanılır.Bu özellikler (bir mülk giriş satır seçim simgesi ile Properties penceresinde gösterilir [image] ) Tooltip 'Performans Giriş' ile. Belirtildiği gibi bu 'giriş' özelliklerine ve depo çeşitli yapısal değişikliklere herhangi bir değişiklik yeniden simülasyon gerektiren Performans simülatörü neden olacaktır Kırmızı üzerinde Simülasyon araç çubuğu .

Tip | Isim | Varsayılan değer | Ünite | Veri tipi | Gerekli | Açıklama
Davranış | b_pack | 0.0 |  | Ondalık | Sahte | Sabit hizmet süresi saniye cinsinden paketi. Bu özellik tipik olarak Bir standart tip olarak belirtilen ve daha sonra çok bileşenli örnekleri için kullanılır. Örneğin, CORBA = 0,23 ms b_pack sahiptir.
Davranış | m_pack | 0.0 |  | Ondalık | Sahte | Değişken hizmet süresi saniye / byte paketi. Bu özellik tipik olarak Bir standart tip olarak belirtilen ve daha sonra çok bileşenli örnekleri için kullanılır.
Davranış | b_unpack | 0.0 |  | Ondalık | Sahte | Sabit hizmet süresi saniye cinsinden açmak için. Bu özellik tipik olarakBir standart tip olarak belirtilen ve daha sonra çok bileşenli örnekleri için kullanılır.
Davranış | m_unpack | 0.0 |  | Ondalık | Sahte | Değişken hizmet süresi saniye / byte açmak için. Bu özellik tipik olarakBir standart tip olarak belirtilen ve daha sonra çok bileşenli örnekleri için kullanılır.
Davranış | İşleme | 0.0 |  | Ondalık | Gerçek | Yürütme zamanı miktarı bir işlemi tamamlamak için. Bu saat, dakika, gün, operasyonlar vb olabilir
Davranış | İşlemciler | 1 |  | Tamsayı | Gerçek | İşlemci kaynaklarının sayısı. İşlemciler vb insanlar, CPU, dış kuruluşlar olabilir
Davranış | Hız | 100 |  | Tamsayı | Gerçek | İşlemci kaynak hızı. Yani o zaman bir ünitede gerçekleştirebilirsiniz nasıl devir / talimatlar / eylemler, birçok olduğunu. Bu işleme için kullanılan birimler ile tutarlı olması önemlidir.
Davranış | k_bkgd | 0.0 |  | Ondalık | Sahte | Bileşeni üzerinde Arkaplan işleme. Bu% üzere herhangi bir sabit uzaklıklar eşleştirmek için sonuçlar ayarlamak için kullanılır. Bu muhtemelen göz ardı edilebilir.

Aşağıdaki tabloda performans değerlendirici tarafından bileşen özellikleri çıkışını listeler. Bu bileşen özelliklerin bir dizi her performans kaçak her bir bileşen için oluşturulur.Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Performans Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Performans simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Davranış | Mesaj Oranı |  | Ondalık | Sahte | Bileşeni aracılığıyla zaman birimi başına ileti sayısı. Bu, tüm bileşenlerinin 'gelen ve giden mesajların toplamıdır.
Davranış | Bant genişliği |  | Ondalık | Sahte | Bileşeni aracılığıyla Genel bant genişliği. Gelen ve giden mesajlar hem dolayı toplamı.
Davranış | Kullanım | % | Ondalık | Sahte | Bileşenin kullanımı. Bileşen, bir cihaz / işlemci (yani bu İşlemciler yok ve Hız özellikleri yukarıda tanımlanan) değilse bu% 0 olacak

Bağlantı Özellikleri

Aşağıdaki tablo performansını değerlendirmek için gerekli özellikleri listeler. Özellikler Bağlantı örnekleri, ardından Bağlantı Standartlar ve bulunmazsa eğer, varsayılan kullanıldığı ilk aranır.Bu özellikler (bir mülk giriş satır seçim simgesi ile Properties penceresinde gösterilir [image] ) Tooltip 'Performans Giriş' veya 'Maliyet / Performans Giriş' ile. Bu 'giriş' özelliklerine ve depo çeşitli yapısal değişikliklere herhangi bir değişiklik Performans simülatör neden olur ve / veya Maliyet simülatörü belirtildiği gibi, bir tekrar-simülasyon gerektiren Kırmızı üzerinde Simülasyon araç çubuğu .

Tip

Isim

Varsayılan değer

Ünite

Veri tipi

Gerekli

Açıklama

Davranış

Tür

iki yönlü

[çift yönlü | tek yönlü]

Arama / Liste

Gerçek

Bağlantı İster iki yönlü (çift yönlü) veya tek yönlü (tek yönlü) 'dir.

Bu özellik için izin verilen değerler "çift yönlü" ya da "tek yönlü" dir.

İki yönlü, tek bir asenkron "Olay" tek yönlü yollarla oysa senkron istek / yanıt mesajları demektir.

Davranış

Soyutlama

dolaylı

[dolaylı | direkt]

Arama / Liste

Gerçek

Bağlantı fiziksel veya mantıksal olsun. Doğrudan bağlantı mantıksal bağlantıları boyunca akış iki bileşen arasındaki fiziksel "boru" dir.

Bu özellik için izin verilen değerler "doğrudan" ya da "dolaylı" bulunmaktadır.

Değer "doğrudan" ise, bağlantı (özellikleri Tür ve Soyutlama hariç) herhangi bir diğer özellikleri gerekmez.

Veri

L_app1

0

Tamsayı

Sahte

Bayt Talep / olay boyutu.

Her bağlantı genelde bunun için özel bir değere sahip olacaktır. CORBA, olayları aslında iki yönlü ve her zaman (L_app2) 12 byte kabul var. Gerçek bir tek yönlü bağlantı ise, mülkiyet L_app2 dışarıda bırakın.

Veri

L_app2

0

Tamsayı

Sahte

Tepki / bayt cinsinden boyutunu kabul.

Her bağlantı genelde bunun için özel bir değere sahip olacaktır. Bir tek yönlü bağlantı L_app2 olacak değil.

Davranış

Frekans

1

Ondalık

Gerçek

Bağlantı meydana geldiği andaki frekans.

Her bağlantı genelde bunun için özel bir değere sahip olacaktır. Mülkiyet Frekans sonra dışarı bırakılırsa varsayılan kullanılır.

Davranış

Ilişki

süreçler

[süreçler | ] destekler

Arama / Liste

Sahte

"Işlemler" özelliğine sahip bağlantılar bağlantının başlangıcında komponent bağlantı sonunda bileşeni işlenecek olacağını ifade etmektedir. Aslında "kaynak" bileşen "sink" bileşeni (ekli bağlantıları da bu hareket ile "sürüklenen" olan) bir çocuğun haline taşınır.

Bir "işlemler" özelliği mevcutsa, o diğer tüm bağlantı özellikleri aşağıda açıklanan isteğe bağlı "%" özelliği dışında, göz ardı edilecektir.

Davranış

%

100.0

Ondalık

Sahte

"Süreçler" özelliği (yukarıda açıklanan) olması Bağlantılar isteğe bağlı hedef bileşeni atfedilen edilecektir işleme oranını belirtmek için bir "%" özelliği olabilir. Bu şekilde tek bir kaynak bileşeni çeşitli% 's çoklu hedef bileşenleri tarafından işlenebilir. % Değerleri% 100 kadar eklemek gerekmez ve sadece o hedef bileşeninin çocuk olmaya dönüşür gibi kaynak bileşeni için (yukarıya bakınız) "işleme" özelliği ölçeklemek için kullanılır.

Aşağıdaki tabloda performans değerlendirici tarafından oluşturulan özellikleri listeler. Bu bağlantı özellikleri bir dizi her performans kaçak her bağlantı için oluşturulur.Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Performans Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Performans simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Davranış | Bant genişliği |  | Ondalık | Sahte | Bağlantı için bir bant genişliğine. Bu yalnızca dolaylı bağlantıları için hesaplanan ve (L_app1 + L_app2) * Üretilen esasen almaktadır.
Davranış | Bant genişliği 1/2 |  | Ondalık | Sahte | Bağlantı giden (1) ve gelen (2) mesajları için özel olarak bant genişliği. Bu yalnızca dolaylı bağlantıları için hesaplanan ve esasen L_app1 * Üretilen ve L_app2 * Üretilen mesafesindedir.
Davranış | Üretilen |  | Ondalık | Sahte | Bağlantısı üzerinden zaman birimi başına ileti sayısı. Bu gerçek değer sisteminin doygunluğunu anlamak için beklenen / teorik değerler (yani Frekans) ile karşılaştırılabilir.
Davranış | Tamamlanan | % | Ondalık | Sahte | Bağlantı için mesajların başarıyla tamamlayan işleme oranında. Bu yalnızca dolaylı bağlantıları için hesaplanmış ve Verim / Frekans mesafesindedir. Biraz daha yüksek mesajı nesil frekans mesaj nesil sonuçlarının rastlantısallığı belirtilenden çünkü bazen Tamamlandı değer% 100'ü geçmektedir.
Davranış | Tepki (Min / Ave / Max) |  | Ondalık | Sahte | Asgari / ortalama / maksimum gecikme. Bu yalnızca dolaylı bağlantıları için hesaplanan ve lavabo kaynaktan bağlantısı ve herhangi bir kuyruk ve işleme için gözlenen gecikme (ve çift yönlü ise kaynağına geri gecikme gibi).

Mimari Özellikleri

Aşağıdaki tabloda performans değerlendirici tarafından oluşturulan sistem genelinde mimari özelliklerini listeler. Mimarlık özelliklerini tek bir set her performans çalıştırmak için "toplanan" dir.Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Performans Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Performans simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Davranış | Mesaj Oranı |  | Ondalık | Sahte | Mimarlıkta bileşenleri sayesinde zaman birimi başına ileti sayısı. Bu, tüm bileşenlerinin 'gelen ve giden mesajların toplamıdır.
Davranış | Üretilen |  | Ondalık | Sahte | Mimarlıkta bağlantıları üzerinden zaman birimi başına ileti sayısı. Bu, tüm dolaylı bağlantılardaki throughputs toplamı ve bu gerçek değer sisteminin doygunluğunu anlamak için beklenen / teorik değerler (yani Frekans) ile karşılaştırılabilir.
Davranış | Bant genişliği |  | Ondalık | Sahte | Genel bant genişliği. Mimarlığın bağlantı bant genişlikleri toplamı.
Davranış | Kullanım | % | Ondalık | Sahte | Tüm bileşenlerin kullanımı. Bu mimarlığın bileşen utilisations tüm sadece toplamı olarak% 100'den büyük olabilir.
Davranış | Tepki (Min / Ave / Max) |  | Ondalık | Sahte | Asgari / ortalama / maksimum gecikme. Kaynağından mimarlığın bağlantıları için tüm gözlemlenen gecikmeleri toplamı (kaynağına geri çift yönlü ve eğer) batar.


Güvenilirlik ve fiyatı benzetme

Navigasyon: Mimarinizi simulasyonu> Simulatör>

Güvenilirlik ve fiyatı benzetme

Yorum gönder bu konuda.

Geçmiş

Güvenilirlik Değerlendirici giriş bileşenleri ve bağlantıları kullanarak mimarlık güvenilirliğini hesaplar.

Bileşenleri ve doğrudan bağlantılar için, güvenilirlik Başarısızlık Mean Time Between (MTBF) dayanmaktadır. Mimari elemanların güvenilirliğini hesaplamak için gerekli olan tek değişken vardır:

· MTBF(yıl olarak) değeri;

· Ortalama tamir süresi (MTTR)(yıl olarak) bir başarısızlık; ve

· Zaman tanımlı süre Güvenilirlik üzerinde test etmek.

Güvenirlik hesaplanmasında kullanılan formül ile tanımlanmaktadır:

Güvenilirlik = -e (-y × yaş)
Burada y 1 ÷ MTBF'si =

Olan bileşen ve bağlantı durumu MTBF ve MTTR dayanır. Güvenilirlik farklı olarak, test edilen edildiği süre etkilenmez, bu durumu not edin.

Kullanılabilirlik = MTBF / (MTBF + MTTR)

Dönüşümü yöntemleri iken Güvenilirlik Blok DiyagramlarıEn kesin sonuç verir (basit seri ve paralel yapılar kullanarak), bu yöntemler yüksek olur imPratik biz elementlerin binlerce devasa ağları içinde misyonlar için güvenilirlik hesaplamak çalıştığınızda. Ayrıca, bu dönüşümsel yaklaşımlar, ağ "kafes" olarak pek çok ortak yapılar için yıkmak.

Monte Carloyöntem keyfi büyüklüğü ve karmaşıklığı bir sistemin güvenilirliği ve kullanılabilirliği hesaplanacak verir. Monte Carlo yöntemi, birçok senaryolar simüle ve fya da her bir senaryo rastgele devlet, mevcut veya kullanılamıyorHer bir fiziksel elemanı tayin edilir. Kullanılabilir bir devlet olmanın belirli bir elementin olasılık bileşeninin güvenilirlik / durumu dayanmaktadır.

Örneğin,% 90 kullanılabilirliği ile ilgili bir bileşeni senaryo yaklaşık 90% civarında uygun olması beklenebilir. Dolaylı bağlantının güvenilirliği ve kullanılabilirliği nedenle elemanların bir yol kaynaktan hedefe uygun bir modern terminaller var olan rastgele senaryolarıyla- oranı olarak tahmin edilebilir.

Not

Yerel güvenilirlik ve kullanılabilirlik hesaplanması farklı parametreler ve farklı formüller (ve dolayısıyla farklı değerler sonuçlanır) dayalı olduğundan, her eleman atamak için gerekli ikidevletler, kullanılabilirliği için biri ve güvenilirlik için bir tane. Güvenilirlik hesaplaması her senaryoda güvenilirlik devlet kullanır, oysa kullanılabilirliği hesaplanması, her senaryoda kullanılabilirlik durumu kullanır.

Güvenilirlik değerlendirici belirli bir mimari güvenilirliğini çalışmak için Monte Carlo simülasyonu tekniğini kullanır. Mimari, bireysel simülasyonlar binlerce koymak ve sonuçları bir güvenilirlik ölçüsü türetmek için tablo. Yukarıda belirtildiği gibi, Monte Carlo büyük ağlar simüle etmek için hızlı bir tekniktir ve herhangi bir karmaşık (örneğin, örgülü) yapıyla birlikte çalışacaktır.

Değerlendirici dört değer verir:

1. Misyonumuz GüvenilirlikBirkaç yıl içinde;

2. Kullanılabilirlikarasında mimari;

3. Güvenilirlikarasında Yerel bileşenBirkaç yıl içinde; ve

4. Kullanılabilirlikarasında Yerel bileşen.

Değerlendirici olasılığını çalışır bileşen veya bağlantı çalışma (yani değil başarısız) ve zaman onarmak için kaldırıldı.

Nasıl MTBFs ile standartları ve / veya MTTRs tedavi edilir

Bir eleman (bileşen veya bağlantı) atanır MTBF ile standartları varsa ve / veya MTTR değerleri, bu değerler yerel güvenilirlik hesaplanmasında kullanılan ve kullanılabilirliği bir seri bağlantısı gibi bir elemanın.

Örneğin, bir bileşen, AAtanan standartlara B, C, ve DHer bir MTBF var ve MTTR değer, Yerel Güvenilirlik = R(A)× R(B) × R(C) × R(D), Burada R = Bileşen / standartların (formül kullanılarak) hesaplandı güvenilirlik ve Yerel Yaramakyetenek = A (A)× A (B) × A (C) × A (D), Burada A = Hesaplanan yaramakyetenek bileşeni / standartların (formülünü kullanarak). Bir eleman, üç standartlara sahip bir deyişle, her MTBF ile ve MTTR değersVe aynı zamanda MTBF ve MTTR değerselemanın özellikleri için, yerel güvenilirlik ve avilability standartların her biri bir dizi değeri ve elemanın kendisi olarak verilir.

Başka bir örnek olarak, bir bileşenin Aatanan standartlara sahip B, C, ve Dancak yalnızca standart BStandart sırasında bir MTBF ve MTTR değeri hem de sahiptir CSadece bir MTBF değeri ve standart vardır DYerel sadece MTTR değerine sahip Güvenilirlik = R (A)× R (B)× R (C), Burada R= Bileşen / standartlar ve Yerel (formül kullanılarak) hesaplandı güvenilirlik Kullanılabilirlik = Bir (A)× A (B)× A (C), Burada A= Standart sadece MTBF değeri vardır çünkü (C) hesaplanması (formülünü kullanarak) bileşeni / standartlar ancak hesaplanan kullanılabilirlik o 'aramalar'Eşleştirme MTTR değer (ler) ve tüm katacak MTTR o bulduğu değerleri don'bu durumda, bir standart MTTR değerini kullanmak bu nedenle, kendilerini uygun MTBF'si değerine sahip t D. Başka bir standart varsa, demek E, O zaman da sadece MTTR değeriyle A (C)ve MTBF kullanmak istiyorum Cve MTTR ile D ve Ebirbirine eklenir. Başka bir standart ise, demek FSonra sadece bir MTBF değeri vardı A (F)ayrıca MTTR kullanmak D ve Ebirbirine eklenir.

Misyonumuz Güvenilirlik hesaplanması

Yerel güvenilirlik hesaplamak basit bir formül kullanarak meselesi iken, dolaylı bağlantıları (misyon) hesaplanması biz geçmeli yolları (bağlantıları) ve bileşenlerin karmaşık ve büyük ağları, özellikle bir kez, o kadar kolay değildir.

Dikkate alarak tüm ağı

Dolaylı bağlantıları fiziksel bir bağlantı temsil etmemektedir, biz kaynak bileşeni hedef bileşeni nasıl alabilirim öğrenmek gerekir. Ve tüm bu ağ ve bizim kaynak bileşeni hedef bileşeni (lavabo) ulaşmak için alabilir, tüm farklı şekillerde (ve yollar) bakarak ifade eder.

Not

Sürece olarak orada en azından bir tamKaynaktan hedefe yol misyon başarılı olacaktırve dolaylı bağlantı Kapalı bağlantı olarak anılır.

Bağlantı Matrisi Anlamak

Biz hızla iki blok belirli bir yönde bağlanmış olup olmadığını kontrol etmek için bir eseri ne gerek, bağlı hangi bileşenlerin / direkt bağlantı bilmek. Bu bağlantı matrisinin fonksiyonudur. Kısaca, bağlantı matrisi belirli bir bileşeni doğrudan başka bir bileşen ulaşabilir olmadığını belirten Boole değişkenlerin iki boyutlu bir dizidir. Onun büyüklüğü ağındaki bileşenlerin toplam sayısının karesine eşittir.

Basit Güvenilirlik Block Diagram (RBD)

Güvenilirlik Blok Şeması İlgili Bağlantı Matrisi (RBD)

Tüm bağlantıların çift yönlü olduğundan, önemlidir doğru bağlantı matrisi okumayı biliyorum (her iki yönde gidiş). Güvenilirlik değerlendirici olarak, ilk argüman kaynağıdır ve ikinci argüman hedef (lavabo) 'dir.

Bu nedenle bağlantı matrisi (A, B) = True ise o zaman A, doğrudan B'ye almak anlamına gelir (tek yönlü). Bağlantı matrisi (B, A) = True sadece eğer B A'ya alabilirsiniz. Bu doğru ise, bu iki yönlü bir bağlantı anlamına gelir.

Verilen örnekte yukarıdaki:

· Kaynak 1 hedef 0 ulaşabilir (Kaynak 1 ve Hedef 0 true bir sonuç verir); ve

· 0 ve 1 arasındaki bağlantı iki yönlü olarak, Kaynak 0 hedefe 1. ulaşabilir (Kaynak 0 ve Hedef 1 true bir sonuç verir).

· Kaynak 2 hedef 1 ulaşamaz (Kaynak 2 ve Hedef 1 Yanlış bir sonuç verir) kaynağı 1 hedef 2 ulaşabilir bile (Kaynak 1 ve Hedef 2 true bir sonuç verir). Bu 1 ve 2 arasındaki bağlantı tek yönlü olduğunu ima eder.

Güvenilirlik Blok Şeması Anlamak

Güvenilirlik blok diyagramı (RBD) blokların ve bağlantıların açısından tüm nesne modeli yapısını kapsüller. Her blok hatası veya bunları bağlamak bağlantılar / yollara göre başarı olasılığı olan bir unsurudur. Her iki bileşenler ve bağlantılar RBD bir "blok" olabilir.

Örnek RBD Bloklar ve Linkler

Figür üzerinde bir RBD örneğini oluşturmaktadır. Kesikli kırmızı çizgi 1 misyon 4 sadece iki olası yol vardır nasıl 1. Not tek bir misyon 4 temsil eder.

1, 0 ila 3'e kadar bir yol 4 ve 7 1 noktalı blok 2 ulaşım 4 dikkate 56 Onlar kabul edilmez 1'e misyon 4 başarısızlığı / non-başarısızlık etkilemez ve göz ardı edilir blokları temsil etmektedir. Çoğu görevler için belirli bir misyonun başarısını etkilemez gereksiz bloklar çok sayıda olacak gibi bu çok önemlidir. Gereksiz blok sayısı benzetim sonuçları yanlış yapacak sayede bu büyük ağlarda daha belirgindir.

Simülasyon süresini hızlandırmak ve daha doğru sonuçlar sağlamak için, tüm RBD soyutlamak için gerekli olan ve bir misyonun başarısını etkileyen yalnızca öğelerini kullanabilirsiniz.

Not

Tek yol / yol iki herhangi bir bileşeni ile devam edemez.

Bu aşamada bir bağlantı matrisi oluşturmak ve Monte Carlo simülasyonu gerçekleştirebilirsiniz.

Hesaplama Mimarlık Durumu

Mimari kullanılabilirliği tüm dolaylı bağlantıları zaman içinde herhangi bir noktada satışa sunulacak olasılığıdır. Her dolaylı bağlantı durumu, ancak bu dolaylı bağlantıları (genellikle) fiziksel unsurların aynı sette güveniyor, Monte Carlo simülasyonu her tekrarında sırasında belirlenir. Bu nedenle, sadece bu bireysel mevcutların, "double-sayımı" bu un-mevcutların olur toplayarak karamsar genel mimarisi kullanılabilirliğini vererek. Alternatif olarak, genel mimari kullanılabilirliği her tekrarında bakarak ve ilgi dolaylı bağlantıları dahil unsurlar bulunup bulunmadığını görerek hesaplanır. Ve sonra simülasyonun sonunda bu sonuçları toplayarak.

Güvenilirlik simülatörü Koşu

Güvenilirlik açısından sizin mimarisi simüle etmek

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Seçin Çözümleme| Güvenilirlik.

3. Seçin MimarlıkEğer açılan menüden değerlendirmek istiyoruz.

Not

Varsayılan olarak, ABACUS otomatik olarak yeniden simülasyon altta yatan herhangi bir mülkiyet veya yapısal değişiklikler nedeniyle gerekli olduğu ilk mimari seçecektir.Bu vurgulama gösterilir Kırmızı üzerinde Simülasyon araç çubuğu .

4. Seçin Bileşenler ve Bağlantılarsizden değerlendirmek isteyen Standart eleman seçimi penceresi 'Show Doğrudan Bağlantılar' ve 'Show Süreçleri Bağlantılar' diyalog penceresinin sol alt radyo düğmeli filtreleri kullanarak seçim ile yardım etmek için.

Ek Onay Kutusuiçin Standart eleman seçimi penceresi

· SDönüştürülmüş Model aveirade mevcut proje ile aynı klasörde projenin RBD dönüştürülmüş sürümünün bir kopyasını kaydetmek ve proje adına "_transformed" append.Bu dönüştürülmüş proje ayrıntılı olarak ABACUS'te tarafından üstlenilen güvenilirlik simülasyonu teşhis etmek için kullanılabilir.

Ek Radyo-Düğmeleriçin Standart eleman seçimi penceresi

· Doğrudan Bağlantıları Göster otomatik bir bağlantı kuracak mülkiyet türü = Davranış, Ad = Soyutlama ve Değer = direkt Mülkiyet filtresi var.Bu seçenek varsayılan olarak seçilir ve yukarıda ve aşağıda açıklandığı gibi 'doğrudan' bağlantı seçimi yardım edilir.

· Göster Süreçleri Bağlantılar otomatik bir bağlantı koyacaktır mülkiyet türü = Davranış, Ad = İlişki ve Değer = işlemleri için Mülkiyet filtresi var.Yukarıda ve aşağıda açıklandığı gibi bu seçenek 'doğrudan' bağlantı seçimini yardımcıları.

5. Tıklayın Sonraki.

6. Seç Görevleryani Bağlantıları simülasyon eklemek istiyoruz.

7. Yı kur Run Time Ölçek Faktörükaymak.

Not

Yüksek değerler daha istatistiksel tutarlı sonuçlar ancak hesaplamak için uzun zaman alacak.

Kutularını

· Göster Kapalı Bağlantılarirade Sadece yukarıda açıklanan RBD seçimi başına hedef bileşeni kaynak bileşeninden en az bir tam fiziksel yolu var olanları içerir otomatik mevcut bağlantıları filtre.

· Dolaylı Bağlantıları Göster otomatik bir bağlantı kuracak mülkiyet türü = Davranış, Ad = Soyutlama ve Değer = dolaylı Mülkiyet filtresi var.Bu seçenek varsayılan olarak seçilir ve yukarıda ve aşağıda açıklandığı gibi 'dolaylı' ya Misyon bağlantılarının seçimi yardım edilir.

Düğmeler

· HepsiTüm seçer Bağlantılar.

· InvertTüm Seçili seçimini kaldırır Bağlantılar ve seçili olmadığını tüm bu seçer.

· Hiçbiriseçimini kaldırır tüm Bağlantılar.

Diğer seçenekler

· Run Time Ölçek Faktörü daha yüksek simülasyon zamanını ve doğruluğu kontrol değerler verimingdaha tutarlı sonuçlar istatistiksel ama çekici uzun zaman koşmak.

Not

ABACUS yineleme sayısını hesaplar zaman mükemmel güvenilir değildir en güvenilir unsuru belirler simüle ve o elemanın artı 1 yineleme kullanılamaması üzerine Run Time Scale Factor kez 1 simülasyonu. Ya da (MTBF + MTTR) / MTTR * Çalışma Süresi Ölçek Faktörü + 1. Bu unsuru hâlâ simülasyon en az bir kez başarısız emin olmaktır. Örneğin Mükemmel güvenilir değildir en güvenilir eleman 10.000 saatlik bir MTBF ve 8 saatlik bir MTTR varsa o zaman simülasyon (10.000 + 8) / 8 = 1.251 kez Çalışma zamanı Scale Factor + 1 yineleme alacak.

· Yıl Ahead Benzet Misyon Güvenirlik için yıl sayısı için hesaplanacak belirler.

· NKonular umberdeişlem parçacığı sayısı Monte-Carlo simülasyonu için kullanılacak termines.Bu seçenek, genel simülasyon süresini en aza indirmek için (hiper iş parçacığı çekirdekleri dahil) kullanılabilir CPU / çekirdek sayısını maç için varsayılan olacaktır.

8. Tıklayın Finishve sen-ecek almak Uyarıiletişim.

9. İsteğe bağlı tıklayarak uyarıları keşfetmek Detaylar >>.

10. Tıklayın Devam.

Not

Bu noktada, ABACUS gerçekleştirecek Monte Carlomimari simülasyon ve kısa bir süre sonra (geri bildirim için ilerleme çubukları ile) hesaplama komple iletişim kutusu görünecektir.

11. Tıklayın tamamsimülasyon kabul etmek.

Bahşiş

Güvenilirlik Simülasyon eğitim kursları ve daha fazla yardım için başvurun Avolution Topluluk .

Bileşen ve Bağlantı Özellikleri

Aşağıdaki tabloda bileşenini listeler ve'doğrudan'Bağlantı özellikleri güvenilirliğini değerlendirmek için gerekli. Bu özellikler (bir mülk giriş satır seçim simgesi ile Properties penceresinde gösterilir [image] ) Tooltip 'Güvenilirlik Girdi' ile. Belirtildiği gibi bu 'giriş' özelliklerine ve depo çeşitli yapısal değişikliklere herhangi bir değişiklik yeniden simülasyon gerektiren Güvenilirlik simülatörü neden olacaktır Kırmızı üzerinde Simülasyon araç çubuğu .

Tip | Isim | Varsayılan değer | Ünite | Veri tipi | Gerekli | Açıklama
Güvenilirlik | MTBF | ∞ | yaş, hafta, gün veya saat | Ondalık | Gerçek | Mean Time elemanın Yetmezliği önce. Not: Değerler yaş, hafta, saat ya da gün birimleri cinsinden ifade edilebilir ve aşağıdaki gibi '24 / 7 'durumuna bir konsept dönüştürülür; - 1 yıl = 52 hafta veya 365 gün ya da 8760 saat - 1 hafta = 7 gün veya 168 saat - 1 gün = 24 saat
Güvenilirlik | MTTR | 0 | yaş, hafta, gün veya saat | Ondalık | Gerçek | Mean Time elemanının tamir için. Not: Değerler yaş, hafta, saat ya da gün birimleri cinsinden ifade edilebilir ve aşağıdaki gibi '24 / 7 'durumuna bir konsept dönüştürülür; - 1 yıl = 52 hafta veya 365 gün ya da 8760 saat - 1 hafta = 7 gün veya 168 saat - 1 gün = 24 saat

Aşağıdaki tabloda bileşenini listeler ve'doğrudan' güvenilirlik değerlendirici tarafından bağlantı özellikleri çıktı. Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Güvenilirlik Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Güvenilirlik simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Güvenilirlik | Güvenilirlik - x yıl |  | Ondalık | Sahte | Eleman önümüzdeki x yıl içinde başarısız olmayacak olasılık. Bu 0 ile 1 arasında bir değerdir.
Güvenilirlik | Kaypaklık - x yıl |  | Ondalık | Sahte | Eleman önümüzdeki x yıl içinde başarısız olur olasılık. Bu 0 ile 1 arasında bir değerdir.
Güvenilirlik | Kullanılabilirlik | % | Ondalık | Sahte | Bileşen veya bağlantı hesaplanan fırsat. Bu% 0 ile% 100 arasında bir değerdir.
Güvenilirlik | Kullanılamazlık | % | Ondalık | Sahte | Bileşen veya bağlantı hesaplanmış olmaması. Bu% 0 ile% 100 arasında bir değerdir.

Aşağıdaki tabloda 'dolaylı'güvenilirlik değerlendirici tarafından bağlantı özellikleri çıktı. Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Güvenilirlik Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Güvenilirlik simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Güvenilirlik | Misyon Güvenilirlik - x yıl |  | Ondalık | Sahte | Dolaylı bağlantı önümüzdeki x yıl içinde başarısız olmayacak olasılık. Bu 0 ile 1 arasında bir değerdir.
Güvenilirlik | Misyon Kaypaklık - x yıl |  | Ondalık | Sahte | Dolaylı bağlantı önümüzdeki x yıl içinde başarısız olur olasılık. Bu 0 ile 1 arasında bir değerdir.
Güvenilirlik | Kullanılabilirlik | % | Ondalık | Sahte | Dolaylı bağlantı hesaplanan fırsat. Bu% 0 ile% 100 arasında bir değerdir.
Güvenilirlik | Kullanılamazlık | % | Ondalık | Sahte | Dolaylı bağlantı hesaplanan olmaması. Bu% 0 ile% 100 arasında bir değerdir.

Mimari Özellikleri

Aşağıdaki tabloda, güvenilirlik değerlendirici tarafından mimari özellikleri çıkışını listeler. Bu özellikler (bir mülk kavga çıktı seçici simgesiyle Properties penceresinde gösterilir [image] ) Tooltip ile 'Güvenilirlik Çıkışı'. Simgesine ok vurgular Kırmızı ( [image] ) Bu özellikleri nedeniyle depo ve Güvenilirlik simülatörü altta yatan mülkiyet veya yapısal değişime güncel olduğunuzda göre yeniden simülasyon gerektirir Kırmızı vurgulama Simülasyon araç çubuğu .

Tip | Isim | Ünite | Veri tipi | Gerekli | Açıklama
Güvenilirlik | Kullanılabilirlik | % | Ondalık | Sahte | Değerlendirmeye dahil edilmiştir tüm dolaylı bağlantılarının durumu. Bu olasılığı olduğunu tümDolaylı bağlantılar zaman içinde belirli bir noktada satışa sunulacak. Bu% 0 ile% 100 arasında bir değerdir. Not: Bu, olurdu "double-sayma" ilgili bileşenlerin un durumu gibi bireysel bağlantı mevcutların çarpma değildir.
Güvenilirlik | Kullanılamazlık | % | Ondalık | Sahte | Değerlendirmeye dahil edilmiştir dolaylı bağlantılarının olmaması. Bu olasılığı olduğunu en az birDolaylı bağlantı zaman içinde belirli bir noktada kullanılamaz. Bu% 0 ile% 100 arasında bir değerdir. Not: Bu, olurdu "double-sayma" ilgili bileşenlerin un durumu gibi bireysel bağlantı unavailabilities çarpımı DEĞİLDİR.
Güvenilirlik | Misyon Güvenilirlik - x yıl |  | Ondalık | Sahte | Değerlendirmeye dahil edilmiştir dolaylı bağlantıları her bir sonraki içinde başarısız olmayacaktır olasılık xyıl. Bu 0 ile 1 Not arasında bir değerdir: Bu, olurdu "double-sayma" ilgili bileşenlerin un durumu gibi bireysel bağlantı güvenirliği çarpımı DEĞİLDİR.
Güvenilirlik | Misyon Kaypaklık - x yıl |  | Ondalık | Sahte | Değerlendirmeye dahil edilmiştir dolaylı bağlantı en az bir aşağıdaki içinde başarısız ihtimali xyıl. Bu 0 ile 1 Not arasında bir değerdir: Bu, olurdu "double-sayma" ilgili bileşenlerin un durumu gibi bireysel bağlantı unreliabilities çarpımı DEĞİLDİR.


Senin mimarisi benzetme

Navigasyon: Mimarinizi benzetme>

Senin mimarisi benzetme

Yorum gönder bu konuda.

Eğer doldurulur ve mimari analiz ettikten sonra, sizin mimarisi sayısal ihtiyaçlarını karşılayacak olmadığını belirlemek için ABACUS kullanmaya hazır. Bu gerektiriyor Simülasyon. Mimarinizi simüle etmek için öncelikle keşfetmek istediğiniz bilgi türüne karar vermelisiniz. Bilgi Bu tür genellikle KPI, ya da Anahtar Performans Göstergeleri olarak adlandırılır. Örneğin, performans, evolvability ve açıklık analiz etmek istiyor musunuz, ya da böyle toplam sahip olma maliyeti gibi ölçümleri toplamak istiyoruz. Bu bilgilerin tümü bir şekilde ortaya çıkarılabilir. Bu veri var sonra, grafik çeşitli biçimlerde sizin mimarisi analiz edebilmek (ya da doğrudan yeni değerler analiz) olacaktır.

Mimarinizi simülasyonu için üç seçenek vardır:

· Basit ölçümleri ;

· Önceden inşa simülatörler ; veya

· Scripting .

Basit Ölçümleri

ABACUS'ün uygulama için özel olabilecek birçoğu - senin mimarisinde her bileşeni özellikleri vardır. Bu özellikler bileşenlerinin çeşitli özelliklerini temsil etmektedir. Bazı durumlarda, sadece bu ölçümleri toplayarak size mimarisi hakkında önemli bilgiler anlatmak için yeterli olabilir (KPI oluşturmak için). Örneğin, KLOCS veya Kanunun Hatları Binlerce yaygın karmaşıklık bir ölçüsü olarak kullanılmaktadır. Diğer durumlarda, size isteyebilirsiniz veri ihracat ve başka bir araç kullanılarak analiz. Ayrıca, simülasyon başka bir tür gerçekleştirdikten sonra özelliklerini toplamak isteyebilirsiniz.

Özellikler sürecinde toplanabilir toplanma . Toplama ana bileşeni yansıyan toplam belirtilen alt özelliklerini ekler. Toplama sadece alt bileşenleri içeren bileşenler üzerinde çalışmaktadır.

Önceden inşa Simülatörleri

ABACUS'e ile birlikte kullanılabilir, beş önceden oluşturulmuş simülatörleri vardır. Bunlar:

· Performans;

· Modülerlik;

· Mülkiyeti (TCO) Toplam Maliyet;

· Açıklık; ve

· Güvenilirlik.

Not

ABACUS otomatik aracılığıyla yeniden çalıştırmak gerekir bu simülatörleri hangi vurgulayacak Kırmızı vurgulama Simülasyon araç çubuğu .

Scripting

Scripting özel yollarla mimarisi taklit etmek esneklik sağlar. Tarafından yazma komut dosyaları Eğer ABACUS'e inşa kapasitesi akım ötesinde simülasyonlar gerçekleştirebilirsiniz. Tüm ABACUS nesne modeli betik motoru mevcuttur, bu nedenle yalnızca komut dosyaları yazmak için yeteneği ile sınırlıdır!

Bir makul basit bir biçimde gerekli programlama özellikleri sağlar çünkü Visual Basic komut dosyası, ABACUS'te tarafından desteklenen bir betik dilidir.

Ayrıca bakınız

Senin mimarisi İhracat | Agrega özellikleri | Yazma betikleri


Senin mimarisi Gelişen

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Senin mimarisi Gelişen

Yorum gönder bu konuda.

Mimarileri açıkça gelişti ve mimarileri bir hiyerarşi yaratılabilir. Böylece ABACUS'e sizin mimarisi evrimleşerek gelişmiş mimari çözümler bir dizi yarattı karşılaştırılır ve başlangıç ​​çizgisi olabilir. Hedefleri (ya da ölçümler) mevcut mimariler için mimari özelliklerinin herhangi bir sayı için tanımlanabilir.

Bir mimarlık evrimini dikkate basit bir yolu kavramına ilişkilendirmek için soyundan mimari. Bir mimari gelişti olduğunda, bir kopyaebeveyn mimarisinin oluşturulur. Bu kopya doğrudan olduğu söylenebilir torunorijinalin ebeveynmimari.

Not

Bu çevrimiçi yardım belgelerine ve ABACUS araç kümesi kendisi vadede gelişmekdaha yaygın terim daha kullanılır torun, Her ikisi de aynı işleve bakın lütfen unutmayın.

Varolan mimari gelişmeye

1. Bir olduğundan emin olun ABACUS dosyasıaçık ve Explorer Penceregösterilir.

2. Eğer Explorer ağacından gelişmeye istediğiniz ilgili mimariyi seçin.

3. Sağ tıkMimarlık ve seçme üzerine GelişmekMenüden.

Seçilmiş Mimarlık Gelişen

4. Gelişti mimari seçilen mimarisi altında görünecektir.

Evolved Mimarlık

Not

Gelişti mimari mimarlık ve seçme sağ tıklayarak yeniden adlandırılabilir Rename.Dahası, evrim mimaride tüm diyagramlar ve kataloglar otomatik olarak ayarlanır Bazal mimarisi karşı 'fark' o gelişti edildi.

Senin gelişti mimarisi için hedefler belirleyerek

Senin gelişti mimarisi için hedefler belirleyerek size mimarilerinin evrimini değerlendirmek için bir ölçüt oluşturmak için olanak sağlar. Hedefleri mülkiyet türleri ve gelişti mimarisi mevcut bu özelliklerin isimleri tarafından belirlenir. Gol elle de tanımlanmış ve size mimarisi eklenebilir. Hedefleri belirlemek için aşağıdaki adımları izleyin.

Senin gelişti mimarisi için mevcut özelliklerinden hedefler belirleyerek

1. Bir olduğundan emin olun ABACUS dosyasıaçık ve Explorer Penceregösterilir.

2. Seçin Araçlar | Hedefler belirlemekAna menü çubuğundan.

3. Hedef Girdipenceresi görüntülenecektir.

Hedef Giriş Penceresi

4. Tıklayın Mevcutdüğmesine basın.

5. Bir İşletmeye seçinpenceresi görüntülenecektir.

6. Senin gelişti mimarisi için bir hedef olarak ayarlamak istediğiniz bir özellik seçin ve üzerine tıklayın tamamdüğmesine basın.

7. Seçilen hedef şimdi görünecektir Hedef Girdipenceresi.

8. Hedefe seçin ve üzerine tıklayın Düzenlemedüğmesine basın.

9. Düzenleme Golpenceresi görüntülenecektir.

Not

Bu pencere bu özellik için özellik adını ve türünü gol yansıyacaktır yanı sıra en kötü ve en iyi değeri (ya da minimum / maksimum değerler) değiştirmenize olanak verir. Bu değerler, tüm mimariler karşılaştıran ve belirli özellik için her küçük ve en büyük değeri bularak bulunur. Bu değerler manuel olarak da tanımlanabilir. Örneğin, eğer adlandırılmış özellik için bir hedef belirlemek için Tepki (Ave)ve Çeşidi Davranış, En kötü ve en iyi değeri optimum performans (en iyi değer) ve işlenecek sadece ana uygulamalar için gerekli işlem hızı (kötü değeri) için gerekli işlem hızını yansıtıyor olabilir.

10. İlgili değerler tanımlanmıştır edildikten sonra, seçin tamam.

Senin gelişti mimari için yeni özelliklerinden hedefler belirleyerek

1. Bir olduğundan emin olun ABACUS dosyasıaçık ve Explorer Penceregösterilir.

2. Seçin Araçlar | Hedefler belirlemekAna menü çubuğundan.

3. Hedef Girdipenceresi görüntülenecektir.

4. Tıklayın Yenidüğmesine basın.

5. Yeni Hedefpenceresi görüntülenecektir.

Not

Bu pencere özellik adını ve türünü gol yansıyacaktır yanı sıra bu özellik için en kötü ve en iyi değeri (ya da minimum / maksimum değerler) tanımlamanızı sağlar. Örneğin, eğer adlandırılmış özellik için bir hedef belirlemek için Tepki (Ave)ve Çeşidi Davranış, En kötü ve en iyi değeri optimum performans (en iyi değer) ve işlenecek sadece ana uygulamalar için gerekli işlem hızı (kötü değeri) için gerekli işlem hızını yansıtıyor olabilir.

6. İlgili değerler tanımlanmıştır edildikten sonra, seçin tamam.

7. Bir iletişim kutusu Tüm mimariler ekleaşağıdaki gibi görünecektir:

8. Tıkla Evetilgili tüm mimariler bir özellik olarak hedefe ekleyin. Bu yeni tanımlanan amaç ve özellikleri dosyadaki tüm mimariler eklenecektir sağlar. Eğer mimariler mülk dahil istemiyorsanız, size tıklayabilirsiniz Hayır.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Senin gelişti mimarileri bir yıldız arsa görüntüleme | Senin gelişti mimarileri bir dağılım grafiğini görüntüleme


Genişleyen ve ağaç çöken

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Genişleyen ve ağaç çöken

Yorum gönder bu konuda.

Ağacındaki bir düğüm alt bileşenleri ve koleksiyonları içerdiğinde, bir küçük olacak [image] veya [image] onun solunda imzalamak. Sen tıklayabilirsiniz [image] düğümünü genişletin ve alt bileşenleri ve bağlantıları görmek için. Benzer şekilde, tıklayabilirsiniz [image] (daha fazla yer açmak ya da anlamak için ağaç kolaylaştırmak amacıyla) alt bileşenleri ve bağlantıları gizlemek için düğümü daraltmak için.

Alternatif olarak, bütün bir alt düğümlerin hepsi de genişletilmiş olacak bu durumda düğüm, ve bunların alt düğümleri genişletebilir ve onların ... vb Benzer şekilde, bütün bir düğümü daraltabilirsiniz - bir kerede birden fazla seviyeleri kapanış .

Ayrıca, sadece mimarileri, elementler (örn bileşenleri ve bağlantıları), bileşenler veya bağlantıları genişletmek için seçenekler vardır.

Genişletmek veya tüm düğümü (ve alt düğümleri, vs.) daraltmak için

1. Sağ tıkdüğümde.

2. Seçin Aç | Hepsi veyaCollapse.

Bir mimarideki tüm genişletmek için (ler)

1. Sağ tıkMimarileri veya bir mimari üzerinde.

2. Seçin Aç | Hepsi.

Öğeleri genişletmek için

1. Sağ tıkMimarileri veya bir mimari üzerinde.

2. Seçin Aç | Elemanları.

Bileşenleri genişletmek için

1. Sağ tıkBileşenler, bir bileşen veya bir alt bileşeni üzerinde.

2. Seçin Aç | Bileşenleri | Hepsi.

Bağlantıları genişletmek için

1. Sağ tıkBağlantılar, bir bağlantı veya alt bağlantıda.

2. Seçin Aç | Bağlantılar | Hepsi.


Architecture İhracat

Navigasyon: senin mimarisine Raporlama>

Architecture İhracat

Yorum gönder bu konuda.

ABACUS olanak sağlar için(Microsoft Access) .mdb için mimari ihracat, MS SQL Server, .abacus (ABACUS dosyası) ve .xls (Microsoft Excel) formatında. Ayrıca verebilirsiniz senin diyagramPNG, JPG, SVG (Ölçeklenebilir Vektör Grafikleri), TIFF, GIF ve BMP formatında ve (HTML) .html için raporlar, .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) ve s .rtf (Zengin Metin Biçimi) biçimleri. Bu analiz ve istediğiniz herhangi bir şekilde mimari ve veri görüntülemenize olanak sağlar.

.mdb Için mimariyi aktarmak için (Microsoft Access)

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Tıklayın Dosya menü.

3. Seçin İhracat, ve sonra MDB.

4. Uyarı not alın ve tıklayın tamam.

5. Dosya için bir ad yazın.

6. Tıkla KaydetDüğme.

Not

.mdb Veritabanı ihracat biçimidir ABACUS'e ve herhangi bir şema değişiklikleri özgü re-ithalat için yetersizlik neden olacaktır. Lütfen Gör MS Access ile doldurmamak MS Access şema açıklaması için.

Için mimari vermek için MS SQL Server

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Tıklayın Dosya menü.

3. Seçin İhracat, ve sonra MS SQL Server.

4. Tıklayın Görüntülenen iletişim kutusunda İhracat Boş MDB ...düğmesi ve MS SQL Server veritabanı sunucusuna bu ithal.

5. Veritabanı bilgileri ve bağlantı dizesinde doldurun.

6. Tıkla İhracatDüğme.

Not

Ihracat biçimi MS SQL Serververitabanı ABACUS'e ve herhangi bir şema değişiklikleri özgü re-ithalat için yetersizlik neden olacaktır. Lütfen Gör MS Access ile doldurmamak veritabanı şeması açıklaması için.

.xls Için mimariyi aktarmak için (Excel dosyası)

1. Bir olduğundan emin olun ABACUS dosya açma Bir kaşif Görüntülenen Ve bir mimari eklendi .

2. Bir olduğundan emin olun Excel İthalat / İhracat Yapılandırma Dosyası tanımlandığı gibidir.

3. Sağ tıkmodeliniz bir mimari veya herhangi bir bölümünü Bileşenler(belirli bir mimari içinde) düğüm Excel yapılandırma dosyası ihracat istiyoruz.

4. Seçin İhracat | Karşı Excel ... Menüden.

5. Kullanımı Excel İthalat / İhracat Yapılandırma Dosyası seçinpenceresi görüntülenir.

6. Mimari modeli hakkında yapılandırma dosyasını seçin ve üzerine tıklayın Açıkdüğmesine basın.

7. Otomatik yapmadıysanız, harita için geçerli mimaride üst düzey bileşenler Set Kimliği(daha önce tanımlandığı gibi) ve üzerine tıklayın İhracat....

Örnek Üst Düzey Bileşen Haritalama

8. Bir yer seçin ve Excel dosyası için filename ve tıklayın Kaydetdüğmesine basın.

.abacus Için mimariyi aktarmak için (ABACUS dosyası)

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Sağ tıkMimarlık düğüm üzerinde, modeliniz herhangi mimarlık veya Bileşenleri ağacın herhangi bir bölümü.

3. Seçin İhracat | Karşı Dosya...Menüden.

4. Bir yer seçin ve filename ve tıklayın Kaydetdüğmesine basın.

Not

Aşağıdaki adımlarla geri ABACUS'te içine ABACUS dosyasını alabilirsiniz 1-2ve daha sonra yukarıdaki seçme İthalat | Gönderen Dosya.... Eğer almak istediğiniz dosyayı seçtikten sonra, standartları ve türleri ithal etmek istiyorum nasıl sorulur. Yeni veya birleştirilmiş standartlar ve türleri ya da standartları ve türleri alabilirsiniz. Onlar zaten varsa standartları ve çeşitleri mevcut standartlara ve türleri ile birleştirilecek için varsayılan ayar aşağıdadır proje.

.xml Için mimari vermek için

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Sağ tıkBir Mimarlık düğüm üzerinde, modeliniz herhangi mimarlık veya Bileşen ağacın herhangi bir parçası.

3. Seçin İhracat | Karşı XML ...Menüden. Alternatif menüde tıklayabilirsiniz Dosya| İhracat| Karşı XML ...

4. Bir yer seçin ve filename ve tıklayın Kaydetdüğmesine basın.

Not

Aşağıdaki adımlarla geri ABACUS'te içine bir XML dosyasını içe aktarabilirsiniz 1-2ve daha sonra yukarıdaki seçme İthalat | Gönderen XML .... Eğer almak istediğiniz XML dosyasını seçtikten sonra, standartları ve türleri ithal etmek istiyorum nasıl sorulur. Yeni veya birleştirilmiş standartlar ve türleri ya da standartları ve türleri alabilirsiniz. Onlar zaten varsa standartları ve çeşitleri mevcut standartlara ve türleri ile birleştirilecek için varsayılan ayar aşağıdadır proje.

PNG, JPG, SVG, TIFF, GIF veya BMP diyagramınızı vermek için

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Aç diyagramDışa istiyorum.

3. Tıklayın İhracat Diagramdüğmesini Diyagram Araç çubuğu.

4. İhracat Şemasıpenceresi açılacaktır.

5. Seçin Araştırdüğme istenilen konuma görselleştirme kaydetmek için.

6. Seçin Türü olarak kaydetaçılan menü dosya türünü seçin.

7. Tıkla Kaydetdüğmesine basın.

.pdf (Adobe Acrobat) için rapor ihracat için, .xls (Microsoft Excel) veya.doc (Microsoft Word)

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Oluşturmak rapor Dışa istiyorum.

3. Tıklayın İhracatRaporlar araç çubuğundaki düğmesine tıklayın.

4. Seçin Excel, PDF veya WordAçılan kutudan.

5. Raporda ihracatın ise birkaç dakika bekleyin.

6. Bir yer seçin ve filename ve tıklayın Kaydetdüğmesine basın.


Bulma ve mimarlık öğeleri değiştirme

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Bulma ve mimarlık öğeleri değiştirme

Yorum gönder bu konuda.

Bulabilirsin Değiştir Belirli bir bileşen, bağlantı tipi ABACUS kullanarak, standart veya mülkiyet 'Bul Değiştir tesis.

Bir öğeyi bulmak için

1. Eğer içinde arama yapmak için istediğiniz ağacın düğümünü tıklatın.

2. Seçin Düzenleme| Bulmakbasın veya Ctrl + F.

3. Giriş metin eşya'Ne Bul' alanına bulmak için.

4. Tıklayın Sonrakini bul.

Karşı değiştirmek Bir öğe

1. Eğer içinde arama yapmak için istediğiniz ağacın düğümünü tıklatın.

2. Seçin Düzenleme| Değiştirbasın veya Ctrl + H.

3. Giriş metin eşyabulmak "neyin bul 'alanına ve metin içinde ile değiştirmek için alanın' Değiştir ' (ya da bu alanda eğer bir şey boş bırakılır).

4. Tıklayın Sonrakini bul'Aranan' metin ve tıklama ilk örneğini bulmak için Değiştir 'Değiştir' metin veya tıklama ile bu örneği yerine Hepsini değiştirtüm örneklerini değiştirmek için.

Siz seçenekler var:

o Onun davasını eşleştir,

o Tüm kelimeyi eşleştir,

o Projenin başından itibaren arama,

o Mimarileri yoksay - o mimari kendilerini düğümler olduğunu. Bu tür bileşenler ve bağlantıları gibi mimari düğümler altında herhangi bir düğüm hala aranır,

o Bileşenleri yoksay - bu bileşen kendilerini düğümler ise,

o Bağlantıları yoksay - o bağlantı kendilerini düğümler ise,

o Standartları yoksay - hepsi mimarlık, bileşen ve bağlantı standardı düğümleri göz ardı edilecektir olduğunu

o Türleri yoksay - bu tür kendilerini düğümler olduğunu. Tipi düğümlerinin altında herhangi bir kısıt düğümleri hala aranır,

o Şablonlar ve içeriğini yoksay - kendilerini düğümler şablon yanı sıra herhangi bir şablon bileşeni ve bağlantı düğümleri altlarında olduğunu,

o Özelliklerini yoksay - göz ardı edilecektir tüm Gayrimenkul türleri, isimleri, değerler ve tüm modelin unsurları birimleri olduğunu,

o Açıklamaları yoksay - tüm modelin elemanlarının açıklamaları göz ardı edilecektir olduğunu.

Ayrıca bakınız

Nasıl bir mimarlık ABACUS'te temsil edilmektedir


Diğer dillerde Yardım

Navigasyon: ABACUS'e Giriş>

Diğer dillerde Yardım

Yorum gönder bu konuda.

ABAKÜS Yardım çeşitli diğer diller / çeviriler mevcuttur ve aşağıdaki linklerden indirilebilir.

Karşı Geçerli ABACUS yardım dosyasını değiştirmekBir çevrilmiştir yardım dosyası ile şu adımları takip edin:

1. Aşağıdaki ilgili bağlantıdan yardım dosyayı kaydedin.

2. ABACUS.chm için yardım dosyasını yeniden adlandırın.

3. Bir çift tıklatarak ve eğer dosyayı açın 'Dosya Aç - Güvenlik Uyarısı' iletişim ardından seçeneğini "Her zaman dosyayı açmadan önce sor" ve tıklayın Aç işaretini kaldırın görünür.

4. Dosyayı kapatın.

5. "Tipik ABACUS program dosyalarını klasöründeki ABACUS.chm dosyasını değiştirinC: \ Program Files \ Avolution \ ABACUS" veya "C: \ Program Files(x86)\ Avolution \ ABACUS".

Not

İçerik duyarlı yardım çevrilmiştir yardım dosyaları ile çalışmaya devam edeceğiz.

Diğer dillerde ABACUS yardım dosyaları:

· Arapça / العربية .

· Bulgar / български .

· Basitleştirilmiş Çince) / 中文 (简体) .

· Çek / Česká .

· Danimarkalı / Dansk .

· Estonyalı / Eesti .

· Fince / Suomen .

· Fransızca / Français .

· Almanca / Deutsch .

· Macarca / Macar .

· İzlandaca / İzlandaca .

· Endonezya / Endonezya .

· İtalyan / Italiano .

· Japonca / 日本 の .

· Letonya / Latvijas .

· Malezya / Malezya .

· Malta / Malt i .

· Norweigen / Norweigen .

· Lehçe / Po lska .

· Portekizce / Português .

· Rusça / русский .

· Slovak / Slovenski .

· Sloven / Slovenski .

· İspanyol / Españoles .

· İsveççe / Svenska .

· Türk / Türk .

· Sözünü tutmamak / Cymraeg .

Ayrıca bakınız

ABACUS'ün ne yapar?


Nasıl bir mimarlık ABACUS'te temsil edilir?

Navigasyon: ABACUS'e Giriş>

Nasıl bir mimarlık ABACUS'te temsil edilir?

Yorum gönder bu konuda.

ABACUS'e, sizin mimarisi modeli. Basitlik için, biz bu mimari model bir mimarlık diyoruz.

Aşağıdaki diyagramı nasıl tipik mimarisini göstermektedir 5bileşenler (bir hiyerarşi içinde) 2 bağlantı ile bağlı ABACUS'te temsil olacaktır.

Basit bir mimari ABACUS'te nasıl temsil edildiğini

Tek bir ABACUS dosyada mimarilerin herhangi bir sayı olabilir.

Ağacın ilk mimarlık

Eğer bir değişiklik değerlendirmek istediğinizde Genellikle, yeni bir mimari yaratacak. Örneğin, ilk mevcut mimariyi modellemek istiyorum - bu ağacın ilk mimarlık olacaktır. Sen 'Şu' diyebilirsiniz.

İkinci

Eğer modeli ve mevcut mimarisine bir değişiklik değerlendirmek istediğinizde (örneğin gereksinimleri artan) Eğer yeni bir mimari oluşturmak istiyorum. Bunu yapmanın en kolay yolu 'Şu' bir kopyasını oluşturmak ve 'Evolution 1 Girişimi 1' adlandırmak olacaktır. Bu ağacın ikinci mimarisi olacaktır. 'Evrim 1 Denemesi 1' senin değerlendirmeler başarılı olursa, siz sadece 'Evrim 1' yeniden adlandırabilirsiniz.

Üçüncü

'Evrim 1 çalışıldı 1' ihtiyaçlarınızı tatmin etmez ise, bunun bir kopyasını oluşturmak 'Evrim 1 Girişimi 2' olarak adlandırın ve tekrar deneyebilirsiniz. Bu ağacın üçüncü mimarisi olacak.

Ayrıca bakınız

ABACUS'ün ne yapar? | Eğer (Genel) bunu nasıl | Mimarlık nedir? | ABACUS dosyalarıyla çalışma | Oluşturma veya bir mimari çoğaltarak


ABACUS (Genel) nasıl kullanılır

Navigasyon: ABACUS'e Giriş>

ABACUS (Genel) nasıl kullanılır

Yorum gönder bu konuda.

Bu konu ABACUS kullanarak ilgili görevleri temel bakış sağlar.

Aşağıdaki diyagram ABACUS yeni veya hedef mimarisi için geçerli bir mimari gelişen sağlar mimarisi tabanlı analiz işlemini gösterir.

ABACUS Süreci

ABACUS kullanmak için:

1. Denetim - Abacus kullanmadan önce, tüm mimarisi hakkında ayrıntılı bilgileri ve gereksinimleri toplamak gerekir.

· Mimarlık - Mimarlık potansiyel bileşenlerini belirlemek ve nasıl etkileşimde. Sadece üst düzeyde birkaç bileşenleri olmalıdır. Bu "temel bileşenleri" denir. Hatta en karmaşık mimarileri 10'dan az temel bileşenleri olmalıdır. örneğin Bir sigorta şirketinin mimarisinin temel bileşenleri politikaları, makbuzlar, iddialar ve ödemeler olabilir.

· Gereksinimler- Bunu tatmin olup olmadığını belirlemek amacıyla mimarlık ne beklendiğini bilmek zorunda. örneğin Saatte işlemlerin sayısı.

· Nereye buluyorsunuz? - Bu bilgiler Temelde mevcut herhangi bir malzeme mimarisi hakkında ABACUS bilgi sunar gereksinimleri özellikleri, tasarım dokümanları, paydaşlarla görüşmeler, dağıtılan kod vb gelebilir.

2. Doldurun -Senin mimarisi model ve mimari karşı ölçülecektir gereksinimlerini belirlemek için ABACUS kullanın.

· Mimarlık - ABACUS'e size boş bir mimari ile işe başlamak - Eğer var doldurmako. Bu yukarıda toplanan tüm mimari bilgisini girdikten demektir. Siz (sağ tıklama menüsünü kullanarak) elle mimarisi doldurabilirsiniz veya (Microsoft Visio, Excel, Access vb) otomatik olarak doldurabilirsiniz. Tipik mimari en üstteki düzeyleri (daha soyut) elle doldurulur ve alt düzeyleri (daha somut) otomatik olarak doldurulur.

· Gereksinimler - Eğer bileşenleri ve bağlantıları eklemek gibi, onların özelliklerini belirtin. Çoğu durumda, bu özellikler mimari şartlar olacaktır. Bir 1250 MIPS düğümü / küme olacak Örneğin, sonra, bir bileşen olarak düğüm eklemek performans özelliği ekleyin ve 1250 MIPS bir değer atamak olacaktır.

3. Analiz - Zarif analiz ve mimari kompleks yapısını görselleştirmek için ABACUS kullanın. Sen bir dizi yolla veya diyagramlar, 3D ve Explorer da dahil olmak üzere bakış açıları, bir dizi sizin mimarisi analiz edebilirsiniz. Aşağıdaki gibi Alternatif biraz daha spesifik görünümleri kullanmak isteyebilirsiniz:

· Mimarinizi Grafik - performans (tepki süresi, bant genişliği, vb), maliyet (bar, pasta, vb) veya evolvability (yetenek alanı, ticaret-off, vs.) görünümleri almak için.

· Senin mimarisi üzerine bir rapor oluşturun.

4. Benzetmek - Vb mimarlığın performans, kullanılabilirlik, maliyet, açıklık, simüle etmek ABACUS kullanın

· Bunu yapmak için, simülatörler birini çalıştırın. ABACUS'ün sizin yanınızdaki değerlendirir gereksinimleri karşı mimarisiBir simülasyon yaparak. Bu okur ve mevcut mimari analizleri, simülasyonlar ve bazı yeni özellikler hesaplar. Bu özellikler daha sonra tekrar mimariye kaydedilir. Yeni özellikler gibi, TCO vb kullanımı, tepki süresi, bant genişliği,% kullanılabilirliği olarak analiz etmeye çalışıyoruz veriler vardır

5. Mühendis- Kullanım ABACUS çeşitli "eğer" senaryoları cevap ve mimari gelişimini kontrol etmek. Mühendislik tekrar işlemidir Populate - analiz - Benzetdöngüsü.

· Bu noktada, senziyaretindeMuhtemelen Güncel Mimarlık bir anlayış geliştirmiştir ve gelişmeye gereken alanları vurgulanır. Oldukça sık, ancak, doldurmak tekrarlamanız gerekir - analiz - sürecini birkaç kez simüle eder. Hedef Mimarlık bulmak önce yineleme birkaç sürebilir, çünkü bu muhtemelen olacak. Senin mimarisi çok karmaşık Ayrıca, her mimari "level" işlemi tekrarlamak isteyebilirsiniz.

6. PlanABACUS'e tarafından sağlanan bilgileri kullanarak mimari geleceği.

Not

Varolan bir mimari gelişmeye çalışmıyoruz ediyorsanız, bazı adımları bir kaç kez tekrarlamak gerekir ve farklı bir sırayla olabilir. Bu do çalışıyoruz bağlıdır. Eğer yeni bir mimari tasarımı yapıyorsanız Örneğin, büyük ihtimalle sadece bir kez mimarisi doldurmak gerekir ve daha sonra mimarlık gelecekteki evrimi (ler) rehberlik etmek uzun bir süre boyunca ABACUS kullanın. Eğer yeni bir mimari satın alma ve eğer Öte yandan, bağımsız bir nihai karşılaştırma yapmadan önce her biri keşfedin ve alternatiflerin her biri için doldurmak ve ardından analiz ve simüle gerekir, seçim için çeşitli alternatifler var son.

Ayrıca bakınız

ABACUS'ün ne yapar? | Mimarlık nedir? | Nasıl bir mimarlık ABACUS'te temsil edilir? | Senin mimarisi doldurma | Senin mimarisi analiz | Senin mimarisi benzetme


Senin Mimarlık aktarmak

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Senin Mimarlık aktarmak

Yorum gönder bu konuda.

ABACUS olanak sağlar aktarmak senin mimari Bir den .abacus (ABACUS dosyası), .xml (Bir ABACUS XML parçası veya ArchiMate Değişim Dil XML dosyası), .vsd (Microsoft Visio) formatında ve .xls (Microsoft Excel) formatında. Bu yapmanıza olanak sağlar hızla dış kaynaklardan gelen mimarisi oluşturmak.

Karşı ithalat senin mimari itibaren.abacus (ABACUS dosyası)

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Sağ tıkMimarlık düğüm üzerinde, modeliniz herhangi mimarlık veya Bileşenleri ağacın herhangi bir bölümü.

3. Seçin İthalat| Gönderen Dosya...Menüden.

4. Bir yer seçin ve .abacus dosya ve tıklayın Açıkdüğmesine basın.

Not

Eğer almak istediğiniz dosyayı seçtikten sonra, standartları ithal etmek istiyorum nasıl sorulur, türlerive bakış açıları. Siz standartları alabilirsiniz, türleri ve bakış açıları Yeni veya birleştirilmiş standartlar ya da, türlerive bakış açıları. Varsayılan ayar standartları için, türleri ve bakış açıları Mevcut standartlar ile birleştirilecek, türleri ve bakış açıları onlar zaten varsa (Aynı isimde) içinde senin proje.

Karşı ithalatsenin mimari itibaren.xml (Bir ABACUS XML parçası veya ArchiMate Değişim Dil XML dosyası)

1. Bir olduğundan emin olun ABACUS dosyası açık.

2. Sağ tıkBir Mimarlık düğüm üzerinde, modeliniz herhangi mimarlık veya Bileşen ağacın herhangi bir parçası.

3. Seçin İthalat| Gönderen XML ...Menüden.

4. Bir yer seçin ve .xml dosya ve tıklayın Açıkdüğmesine basın.

Not

ABACUS sadece düzgün oluşturulmuş ABACUS XML fragmanı veya bir ArchiMate Değişim Dil XML dosyasını içe olacak. Eğer almak istediğiniz XML dosyasını seçtikten sonra, standartları ithal etmek istiyorum nasıl sorulur, türlerive bakış açıları. Siz standartları alabilirsiniz, türleri ve bakış açıları Yeni veya birleştirilmiş standartlar ya da, türlerive bakış açıları. Varsayılan ayar standartları için, türleri ve bakış açıları Mevcut standartlar ile birleştirilecek, türleri ve bakış açıları onlar zaten varsa (Aynı isimde) içinde senin proje.

Karşı ithalatsenin mimari itibaren.vsd(Visio dosya) görmek İşte .

Karşı ithalatsenin mimari itibaren.xls (Excel dosyası) görmek İşte .


Bir kütüphaneden türleri ve standartları İthalat

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Bir kütüphaneden türleri ve standartları İthalat

Yorum gönder bu konuda.

Bir ABACUS kitaplık dosyası türlerini ve standartları alabilirsiniz. Ayrıca, bir ABACUS kitaplık dosyası için ABACUS dosyasından türleri ve standartları verebilirsiniz.

Senin mimarisine bir kütüphaneden türleri ve standartları almak için

1. Bir olduğundan emin olun ABACUS dosyasıaçık ve Explorer Penceregösterilir.

2. Dosya Seçin | AçıkBir açma ABACUS kütüphane dosyası.

3. ABACUS Kütüphane Explorer penceresinde ikinci sekmeli sayfasında açılacak ve bunu yapmak zorunda olacak Bu sekmeli sayfayı çıkartıp Orijinal ABACUS'ün dosyasına ondan ve bırak sürüklemek mümkün.

4. Sürükle ve bıraktürleri ve mimarisi içine kütüphaneden standartları.

- veya -

1. Dosya Seçin | Yeni ...

2. Yeni oluştur ABACUS dosyasıBir göre ABACUS kütüphane dosyası.

Bir kütüphaneye mimarisi türleri ve standartları vermek için

1. Bir olduğundan emin olun ABACUS dosyası aç Explorer PencereGörüntülenen bir ABACUS kütüphane dosyasıaçık ve Kütüphane Penceregösterilir.

2. Sürükle ve bıraktürleri ve kütüphaneye mimariden standartları.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma


ABACUS arayüzü

Navigasyon: ABACUS'e Giriş>

ABACUS arayüzü

Yorum gönder bu konuda.

Abacus başlattığınızda, menüler ve araç çubuğu üstündeki boş Explorer penceresi ve başlık-bar haricinde boş ana ekranı göreceksiniz. Bu ekran ABACUS'e ile etkileşim merkezi olacak.

Ana unsurları şunlardır:

· Ana menüler

· araç çubukları

· sağ tıklama menüsü

· kaşif ve mülkiyet pencereler

· Durum çubuğu

Ana menüler

Menüler mantıklı bir sıraya göre düzenlenmiştir.

Menüler aşağıdaki şekilde tarif edilmektedir;

· Dosya menüsü- Dosya menüsünü oluşturmak, yakın, açık, ihracat kaydetmek ve ABACUS dosyalarını yayınlamak için izin verir. Ayrıca, yakın, açık oluşturmak ve ABACUS Kütüphane dosyaları kaydetmenize olanak verir.

· Düzen menüsü- Düzen menüsü kopyalama, yapıştırma, silme, yeniden adlandırma bulmak ve öğeleri sıralamak, kesip sağlarve geri / işlemleri yinelemek.

· Görünüm menüsü- Görünüm menüsü açmak veya çeşitli arayüz, Windows ve durum çubuğunu kapatmak için izin verir, Ileriye ve geriye doğru gezinmek, belirli görüşlere gidin ve panoları yönetmek.

· Ekle menüsü- Ekle menüsü, yeni eklemenizi sağlar Standartlar, Şablonlar, çeşitleri, elemanları, görünümünoktas, Kataloglar, diyagramlar, çizelgeleri, Raporlar ve matrisler.

· Analiz menüsü- Analiz menüsü de dahil olmak üzere bir mimari karşı değerlendirmeler çalıştırmanızı sağlar; performans, maliyet, güvenilirlik, modülerlik ve açıklık.

· Araçlar menüsü- Araçlar menüsü komut çalıştırmanızı sağlar, mimarlık için set hedeflerve performans ve mimarlık 'fark'. Ayrıca programın seçenekleri değiştirmek ve alet menüden arayüzü özelleştirebilirsiniz.

· Pencere menüsü- Pencere menüsü, rıhtım, gösteriyi düzenlemek ve pencereler açık var gizlemek için izin verir.

· Yardım menüsü- Yardım menüsünden bunu ABACUS yardım dosyasına erişebilirsiniz. Sen web sitesine erişebilirsiniz görüntülemek senin lisans Anlaşma ve yazılım ve ABACUS desteği ve iletişim bilgileri de dahil olmak üzere sürümü ABACUS'te hakkında genel ayrıntılarını görüntülemek. Sen sorunu bildirim sayfası üzerinden geri bildirim sağlayabilir. Gerekirse, Yardım menüsü aracılığıyla bir kayıt anahtarı girebilirsiniz.

Bu görevleri yürüten yaparken genellikle takip edeceğiz sipariş;Oluşturduğunuz veya açtıktan sonra bir dosyaNormalde, sonra mimari doldurmak gerekir görünümo (Explorer'da, diyagramlar, 3D, Grafikler, vb.) Bu noktada, ya bir koşacağım DeğerlendiriciVeya aynı mimariye veya farklı bir mimari ile işlemi tekrarlayın edeceğiz. (Görmek ABACUS (Genel) nasıl kullanılır Daha fazla bilgi için.)

Ana menüler arasında bir göz atın ve sizin sisteminize bunları uygulamak gerekir nasıl hayal etmeye çalışın.

Not

Yapabilirsin Menüler özelleştirin her zaman.

Araç çubukları

Varsayılan olarak, aşağıdaki araç çubukları vardır;

· Ana araç çubuğu -

· Simülasyon araç çubuğu -

· Görünüm araç çubuğu -

· Aracı diyagrambar (a ise diyagram açık) -

· Makro Kayıt araç çubuğu -

Alet ucu (kısayol tuşu) görmek için üzerlerine gelerek her araç çubuğundaki düğmeler aracılığıyla görebilirsiniz.

Not

Sadece belirli düğmeleri Explorer penceresinde seçilen ve ne yapabilirsiniz bağlı aktif olacak Araç çubukları özelleştirin her zaman.Ayrıca, Ana araç çubuğunda düğmesine 'Validate / Proje Denetim kısıtlamalarını' ve Simülasyon araç çubuğundaki düğmeleri vurgular Kırmızı Altta yatan deposuna bir değişiklik proje veya sırasıyla o simülatör yeniden simülasyon yeniden doğrulama gerektirir. Etkilenen hangi mimarileri görmek için düğmenin üzerine gezdirin.

Sağ tıklama menüsüne

Ana menüler ve araç çubukları vardır değilolsa da, her şey için kullanılır. Genellikle çeşitli işlemler için sağ tıklama bağlam menüsünü kullanmak daha uygun olur. (Ayrıca, sağ-tıklama ile mevcut tüm komutları ana menüler, araç çubukları veya klavye komutları yoluyla ulaşılabilir.)

Eğer bir dosya oluşturdum, ve size mimarisinin bir ağaç şeması var bir kere Örneğin, bu daha iyidir yeni bir mimari eklemek için ağaç Mimarileri üzerine sağ tıklayın. Benzer şekilde, yeni bir bileşen eklemek için bileşenleri sağ tıklamanız gerekmektedir. Neler yapabileceğinizi görmek için ağacında bir kaç şey üzerinde sağ tıklayın.

Bahşiş

Genellikle, mimari değerlendirmek gibi daha üst düzey görevleri gerçekleştirmek için Ana menülere kullanacağız. Düşük seviyeli görevleri - Bireysel bileşenleri ve bağlantıları ekleme gibi - araç çubukları ve / veya sağ tıklama menüsünü kullanarak yapılır.

Kaşif ve özellikleri pencereler

Açmak veya bir dosyayı oluşturduğunuzda, bir ağaç diyagramı Explorer penceresinde görüntülenecektir. Bu sizin mimarisinin bir pencere. Ve Explorer penceresinde öğeleri seçmek olarak üç diğer pencereler; Genel ÖzelliklerBaşvurularve Özellikleri pencereler seçimi hakkında ayrıntılı bilgi yansıtacak şekilde güncellenir.

Not

Genel ÖzelliklerBaşvurularve Özellikleri Windows, varsayılan olarak gizlidir. Görmek Arayüzü özelleştirme için onları nasıl göstermek için ve potansiyel kalıcı görüntülenen bırakın.

Eğer mimarisi inşa yaparken, Explorer ve Özellikleri pencereleri en kullanışlı temsilidir. Onlar çöktü ve genişletilebilir çünkü gerekli ve onlar hantal olmazlar olarak.

Explorer penceresi bir ağaç (ve Durum çubuğu) sahiptir ve Özellikleri pencereler var 5bölümler:

· Tip

· Standartlar

· Açıklama

· Kaynaklar

· Özellikler

ABACUS tüm bunları mimarinin bir parçası olarak görmektedir.

Ağaç

Bu bölümde bir ağaç vardır 3 alana gruplandırılmış aşağıdaki gibi:

1. Meta-Model

· Standartlar- Çok sayıda bileşenler özellikleri aynı set varsa, önünüzde kümesi tanımlamak, ve sonra sadece bileşenlere atayabilirsiniz. Aynı bağlantıları ve diğer elementlerin herhangi biri için geçerlidir. Standart özellikler bu seti saklanır StandartlarAğacın dalı. Bunun yerine, her bir bileşen için her özellik ve her bağlantı vb her özellik tanımlama, sadece atama standart. Örneğin standart özellikler Unix HP / UXBir olarak kaydedilebilir Standart izlenerek ve herhangi bir bileşeni tahsis Unix HP / UXgösterildiği gibi işletim sistemi OS01 ekran sunucu yukarıdaki.

· Çeşitleri - Ağacın dalı bileşenleri ve kullanabileceğiniz bağlantı türlerinin bir kütüphanedir. Tipleri mimarisi görüntülerken sizin mimarisi ve sınıflandırma ve filtreleme için meta-modeli tanımlamak için kullanılır. Onlar da bir şablon belirlemek neler Standartlar, Özellikleri ve kısıtlamaları Bileşenlerinizi / bağlantıların olabilir.

· Bakış Açıları- Görünümnoktas Mevcut diyagramlar oluşturulabilir ve yeni diyagramlar oluşturmak için kullanılır.Bunlar diyagram şablonlar vardır.

· Şablonlar - Şablonlar mağaza yeniden kullanılabilir bileşenlerin modelleri ve temsil ettikleri veya inceledi edildiği şekilde birlikte bağlantıları. Bunlar mevcut mimariler içine yerleştirilebilir "mini" mimarileri veya solüsyonlar gibi düşünülebilir.

2. Mimariler -Mimarileri şube Eğer inşa nerede ağacın olduğu mimari Sisteminizin (lar). (Bu mimari doldurma denir.) Tek bir ABACUS dosyada mimarilerin herhangi bir sayı olabilir.

3. Panolar - Herhangi bir kaydedilmiş erişebileceğiniz ağacın Panolar dalıdır panoları Proje için.

Not

Oldu Gezgini ağaç kalemler onların Güncelleme izni (onlar salt okunur yani) kaldırıldı gri gösterilir.

Tip

Bu bölüm ağacında seçili elemanın belirli bileşen veya bağlantı türünü gösterir.

Standartlar

Bu bölüm bir listesini sağlar Standartlar ağaçta Seçili öğe için.

Açıklama

Bu bölüm ağacında seçilen elemanın kısa bir açıklama sağlar. İlgili tüm köprüler bu bölüme eklenebilmektedir. Bu web siteleri ya da belirli bir elementin hakkında bilgi ilerletmek için işaret yerel mutlak yollarını içerir. Birden fazla satır da izin verilir. Geçerli köprüler 5 dizeleri biriyle başlamak gerekir; http: //, https: //, ftp: //, file: /// veya mailto :.

Bahşiş

Boşluk köprüler, kullanıcılar URL veya yolunu yazabilirsiniz için gerekli metni seçin ve Sağ tık| Köprü. Bu, herhangi bir boşluk değişecek % 20böylece bütün URL veya yol doğru çalışacaktır.

Oluşturulan ve Modifiye

Bunlar BölümssağlamakKullanıcı ve tarih / zaman yaratılması için, ve son değişiklik, ağaçta Seçili öğe.

Kaynaklar

Bu bölüm bir listesini sağlar gelen ve giden bileşenler ağaçta Seçili öğe için.Ayrıca, seçili eleman göründüğünü diyagramlar, 3D ve Grafik görünümlerini göstermektedir. Bir şema seçilirse diyagram ve genel görünümleri için geçerli bu görünümü görünen herhangi Dashboard gösteriyorsa Viewpoint gösterir. Ve ne zaman bir standart ağaçta seçilir o tipleri, bileşenleri ve bağlantıları ile standardın kullanımını gösterir.

Özellikler

Eğer özelliklerini tanımlar Burası bölümdür içinde elementler senin mimarisi, bunu gerçekleştirmek için gerekli yol, kod satır sayısı gibi, sahip vb yorumlar vardır bu hatların yüzde

Önceden yerleşik 'giriş' ve 'çıkış' özellikleri simülatörler Bir özellik giriş satır seçim simgesi ile Properties penceresinde gösterilir ( [image] ) Ve çıkış simgesi ( [image] ) Sırasıyla gösteren bir araç ipucu ile hangi önceden oluşturulmuş özelliği ile ilgilidir simülatörü, örneğin 'Modüler Çıktı' veya 'Performans Giriş'. Çıktı simgeleri ok vurgular Kırmızı ( [image] ) Özelliği sebebiyle göre yeniden simülasyon gerektiren simülatör ile depoya altta yatan bir özellik veya yapısal değişime güncel olduğunda Kırmızı vurgulama Simülasyon araç çubuğu .

Durum çubuğu

Durum çubuğunun sol kısmı şu anda odak depo elemanı tam yolunu gösterir, ya Explorer penceresinde veya seçili diyagram tuval. Verilen eleman için depo hiyerarşisinde tam yeri her zaman kolayca tespit edilebilir ve böylece budur. Durum çubuğunun sağ kısmı böyle 'Açık ABACUS Başarılı File' ve 'Tamamlandı Maliyetlendirme' gibi çeşitli operasyonel mesajları gösterir.

Ayrıca bakınız

Eğer (Genel) bunu nasıl | Arayüzü özelleştirme | Mimarlık nedir? | Nasıl bir mimarlık ABACUS'te temsil edilir? | ABACUS dosyalarıyla çalışma


ABACUS'ün ne yapar?

Navigasyon: ABACUS'e Giriş>

ABACUS'ün ne yapar?

Yorum gönder bu konuda.

Diğer dillerde yardım için / çeviriler tıklayınız İşte .

ABACUS (topluca mimarileri olarak anılacaktır) çözümleri, sistemleri, yazılım, bilgi, teknoloji, iş süreçleri ve / veya tüm işletmelerin başa dışarı tahmin-iş alır. Bu pragmatik, tasarım monitör, simüle, analiz etmek, yardım ve görselleştirmek edebilirsiniz mimari senin işlevsel olmayan gereksinimler karşı değerlendiren ardından, bu modelleme sezgisel şekillerde analiz (örneğin grafikler, diyagramlar ve 3D) tarafından.

Not

Sigara işlevsel GereksinimleriBir ürünün çalışır NASIL doğrudan ilişkili ETMEYİN bu gereksinimleri vardır. Bunun yerine, onlar nasıl çalıştığını KUYU ile ilgilenirler. (Bu düğme tıklandığında bu ışığı açmak gibi fonksiyonel gereksinimleri aksine) işlevsel olmayan gereksinimler vb performans, açıklık, evolvability, kalite, ölçeklenebilirlik, modülerlik, gibi şeyler yer alıyor. Geleneksel olarak, işlevsel olmayan gereksinimler zor olmuştur - imkansız değilse - ölçmek için. Aslında, ABACUS nesnel ve quantifiably ilk üç ölçebilirsiniz tek üründür - performans, açıklık, ve evolvability.

Basitçe mimarisi ve ne yapmanız gerektirecek girin koydu. ABACUS sonra gerektiği gibi bunu yapmak eğer size söyler ve herhangi zayıflıkları veya boşluklar dikkat çekiyor.

ABACUS sistemleri araştırma ve kurulan sistemler teorisinin daha birçok yıllar 20 yılı aşkın üzerine çekiyor. Size ölçülebilir, güvenilir, objektif cevaplar verir, bu yüzden subjektif değerlendirmesine dayanarak değil.

ABACUS'ün açılımı Architecture-BASED Analysis, Communication ve Understandingarasında Systems. Herhangi bir büyük ölçekli mimarisi ile size yardımcı olabilir, ancak genellikle dört (4) şeyler için kullanılır:

· Gelişenbir akım mimari. Mevcut mimari performans yoksun Örneğin, ABACUS sorunları (darboğazlar, vs.) tanımlanması, sizin için mimari görselleştirmek, sonra size tamnasıl mimarisini geliştirmek.

· TasarımıYeni bir mimari. Eğer tamamen yeni bir mimari gerekir ve bunu kendiniz tasarlarken eğer Örneğin, ABACUS size söyleyecektir tamİhtiyacınız ve nasıl bağlanmalıdır gereken bileşenler.

· SatınalmaYeni bir mimari. Yeni mimari tasarımı üzerinde ihale çağrısında, ve üç tasarımlar arasında seçim yapıyorsanız Örneğin, ABACUS size söyleyecektir tamhangisinin ihtiyaçlarınızı en uygun.

· BirleştirmeGeçerli mevcut mimarileri. Örneğin, iki veya daha fazla ayrı mimarileri birleştirmek gerekirse, ABACUS size rehberlik edecektir.

Ayrıca bakınız

Eğer (Genel) bunu nasıl | Mimarlık nedir? | Nasıl bir mimarlık ABACUS'te temsil edilir?


Diyagramları Kullanımı bağlantılar

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Diyagramları Kullanımı bağlantılar

Yorum gönder bu konuda.

Şekiller (serbest form ve bileşenleri) ve Konnektörler (serbest form veya bağlantılar) diyagramlar içinde ABACUS'te mevcut mimari temsiller, hem de dış dosya / klasörler ve URL'ler ile bağlantılı olabilir. Bu bağlantılar daha sonra ABACUS araç seti aracılığıyla (oluşturulan değiştirilmiş ve silindi) tedavi edilebilir. Bu özellik şematik sizin mimarisinin navigasyon ve genel anlayış geliştirmek için kullanılabilir.

Senin diyagram bağlantı eklemek için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. İlgili şekli seçin veya bağlayıcı senin diyagramdan.

3. Sağ tıkşeklineveya bağlayıcı.

4. Seçin Açık Bağlantılarve Bağlantılarpenceresi görüntülenir.

5. Tıklayın EklemekSimge ve Yeni Bağlantıpenceresi görüntülenir.

6. İlgili Seçin Katalog | Matrix | Diyagram| 3D Görünümü| Grafikradyo düğmeleri, daha sonra ilgili seçin katalog, matris, diyagram, 3Dveya grafik güncel mimaride görünüm Bağlamak Aşağıya doğru açılan menü.

- veya -

6. Seçin Web Sitesiradyo düğmesi, daha sonra ilgili URL'yi girin (örneğin, http: //www.avolutionyazılım.com /)alanında bir web sayfasına link. Geçerli URL'ler biriyle başlamak gerekir 5dizeleri; http: //, https: //, ftp: //, dosya: veya \\. Herhangi bir boşluk, bir '% 20' ile girilmelidir.

- veya -

6. Seçin Mutlak Dosya | Bağıl Dosya Radyo tuşus,sonra 'tıklayın...'Düğmesine diyagram bağlamak için harici bir dosya için göz atın.

7. Tıklayın tamamve yeni bağlantı Linkler pencerede gösterilecektir. Not: Bağlantılar penceresi gerekirse tam adını görmek için boyutlandırılmış olabilir.

8. Adımları tekrarlayın 5-7Daha fazla bağlantılar oluşturmak için.

9. Oluşturulan bağlantıyı takip etmek, görüntülenen ilgili bağlantısını seçin BağlantılarPencere ve tıklama Linki aç.

Not

Ne zaman Birden fazla ek açıklamaları bir için gösterilen edilmektedir şekil veya konnektör Bağlantı Düzenle Açıklamalar iletişim açıklamaları listesinde ilk açıklama gösterilir.

Senin diyagram bağlantıları takip

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. İlgili şekli seçin veya bağlayıcı senin diyagramdan.

3. Tıklayınİlgili köprüyü bir şekli (mavi bileşen adı altı çizili) veya bağlayıcı şemada açın ve şekil ilk bağlantıyı görmek içinveya bağlayıcı.Not: İmleç link tıklandığında hazır bir 'el' olarak değişmesi gerekir.

- veya -

3. İlgili şekli seçin veya bağlayıcı senin diyagramdan.

4. Sağ tıkşeklineveya bağlayıcı.

5. Seçin Açık Bağlantılar ve Bağlantılarpenceresi görüntülenir.

6. Görüntülemek istediğiniz ilgili bağlantısını seçin.

7. Tıklayın Linki açdüğmesine açmak ve ilgili bağlantıyı görüntülemek için.

Senin şemada bağlantıları silmek için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. İlgili şekli seçinveya bağlayıcısenin diyagramdan.

3. Sağ tıkşeklineveya bağlayıcı.

4. Seçin Açık Bağlantılar ve Bağlantılarpenceresi görüntülenir.

5. Silinecek gereken ilgili bağlantıyı seçin.

6. Tıklayın Silmekdüğmesine basın. ve bağlantı kaldırılır Bağlantılar penceresi.

Senin şemada Organizasyon bağlantılar

Sen diyagramı, harici bir dosya bağlantılı ya da bir şekil etiketi Ctrl + diyagramında tıklandığında web URL görüntülenir seçebilirsiniz.

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. İlgili şekli seçin veya bağlayıcı senin diyagramdan.

3. Sağ tıkşeklineveya bağlayıcı.

4. Seçin Açık Bağlantılar ve Bağlantılarpenceresi görüntülenir.

5. Bağlantıların sırasını tıklayınız değiştirmek için Yukarı Taşı | Aşağı TaşıSağ taraftaki düğmeler Bağlantılarpenceresi.

6. Sol tarafında görünür ilk bağlantı BağlantılarPencere sizi görüntüleyen link Ctrl + tıklayınBir köprülü şekil veya bağlayıcı isim.

Ayrıca bakınız

Senin mimarisi doldurma | El mimarisi doldurma | Analiz senin mimari


Kurgulama Diyagramları

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Kurgulama Diyagramları

Yorum gönder bu konuda.

Bir şema oluşturulduktan sonra, o görünen unsurlar yeniden düzenlenebilir ve yeniden boy istediğiniz gibi.

Bir diyagram bir bileşen taşımak için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Tıkla ve-tutunherhangi bir bileşen taşımak için. Seçilen bileşen ebeveyni varsa, ana bileşen vurgulanır.

3. Elemanıdır olaraksürüklenen üst bileşenden ve diğer bileşenler üzerinde, 'potansiyel' anne vurgulanır. Kullanılan renk düzeni çalışması mevcut proje ile uyarılar ve hatalar üzerindeki etkisini gösterir ve tarif edilmiştir Kısıtlamaları tanımlama ve doğrulama . Bu şekilde, size grafiksel bir 'plan görünüşte' dan hiyerarşi gezinebilirsiniz.

4. Serbest bırakmafare düğmesi yeni konumunda eleman düşmesi.

Not

Ayrıca çizim tuval üzerine elemanları pozisyonlu yeniden klavyeyi kullanabilirsiniz. Basitçe taşımak ve istenilen yere şekli taşımak için klavyede bulunan yön tuşlarını kullanmak istediğiniz parça veya serbest form şekli seçin.

Ayrıca başka bir bileşen üzerinde fare ile bir bileşeni sürükleyerek zaman sürüklediğiniz bileşenin sol üst köşesi başka bir bileşen üst üste bindiğinde, bir 'potansiyel' ana bileşeni vurgulanır unutmayın.

Bahşiş

Serbest çalışma ve Yüzer şekiller tarafından sipariş edilebilir sağ tıklayarakve seçme Öne getir veya Geri gönderMenüden. Bu tarafından serbest form dönüştürülebilir bileşen şekiller dikkat etmek önemlidir sağ tıklayarakBelirli bileşen şekil ve seçimi üzerine FreeForm dönüştürme.

Bir diyagram bir bileşen yeniden boyutlandırmak için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Click-hold-dragbileşenin kolları biri olan ve istediğiniz boyuta şekli yeniden boyutlandırmak.

3. Alternatif şeklin boy oranını korumak için, basın + Tıklayın tutma sürükleyin Shift.

Bir diyagram bir bağlantı taşımak için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Tıkla ve-tutunHerhangi bir bağlantı taşımak için.

3. Serbest bırakmafare düğmesi yeni konumunda eleman düşmesi.

Not

Sadece herhangi bir bileşenlere bağlı olmayan bağlantıları taşıyabilirsiniz. Bağlı oldukları, yalnızca serbest ucunu taşıyabilirsinizs, veya Bağlantı rota yeniden .

Bileşenleri ve Bağlantıları silme

Bir bileşen veya bir diyagram bağlantıyı silerken, tüm mimariden silmek için seçeneğiniz vardır. Mimarlık silinir herhangi bir bileşen otomatik olarak görünen başka diyagramlar silinecektir. Serbest biçimli örnekler sadece silerek, tek şemada görünür beri onları mimari model veya başka herhangi bir diyagram etkilemez.

Bir diyagram bir bileşeni veya bağlantısını silmek için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Tıklayınilişkili herhangi bir bağlantı veya bileşeni seçmek için.

3. Basın Silmek, diyagram silmek için tuşuna veya Shift + DeleteTüm modelden silmek için.

- veya -

2. Ilişkili herhangi bir element veya bileşen üzerinde sağ tıklayın. Bir bağlam menüsü görünecektir.

3. Seçin Adlı Sil veya Sil Mimarlıkbağlam menüsünden.

Not

Eğer görünümünden silmek istediğiniz eleman hiç çocuğu vardır ve yalnızca bu görünümde ortaya çıkarsa, ABACUS siz de deposundan eleman silmek isteyip istemediğinizi soracaktır.

Dikkat

Çocuk bileşenlere sahip modelin bir bileşeni silerken, çocuklar da potansiyel uyarı iletişim göre silinecektir.

Birleştirme Bileşenleri

Siz iki bileşen mevcut birleştirmek isteyebilirsiniz Aynı diyagram üzerinde (ve mimari içinde). Bu, birçok nedenden dolayı yapılabilir, Örneğin, Iki sunucu bir şirketin altyapı-H içinde var01 ve H02. Bu iki sunucu bir mimari içinde iki ayrı bileşenler olarak temsil edilir. H01 gereksiz sayılır ve bu nedenle görevden olmaktır edilmiştir. H üzerinde çalışan tüm mevcut uygulamalar01 H ötelenebilir olan02 (hala komisyon). Bu değişiklik ardından "birleştirme" iki bileşenden eylem H tarafından yansıtılabilir01 ve H02 şemasında (ve mimari içinde).

Birleştirilmesi üzerine ayrıntılı bir tartışma için birleştirme Öğeler konuya bakın İşte .

Mevcut iki bileşen birleştirmek için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Sağ tıklayın-tutunbileşeni Birleştirmek istediğiniz ve sürüklemekbu bileşen üzerine siz bunu birleştirmek istiyorum. Hedef bileşenin anahat seçili olduğunu belirtmek için kırmızı vurgulanır emin olun.

3. Seçin Birleştirme | Hedef Koru veya Üzerine yaz HedefMenüden.

Not

Hedef Koruonlar da kaynak bileşeni varsa seçenek hedef bileşenin özelliklerinin değerlerini korur.

Üzerine yaz Hedefseçeneği kaynak bileşeninden herhangi bir ortak özelliklere sahip hedef bileşenin özelliklerini değiştirir.

Bağlantıları değiştirme

Bir çizimde gösterildiği bağlantılar her zamanmimari örneği de tanımlandığı gibi bir yapı göstermektedir. Çizim Aracı, bileşenleri bağlantıları ayırmak, onları taşımanızı sağlar, eğri onları yeniden rota onları ve diğer bileşenlerin bunları yeniden takın.

Bir bileşene / bir bağlantı eklemek / ayırmak için

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Tıkla ve-tutunHerhangi bir bağlantıda.

3. Seçin bağlantı son(yani Kaynak veya Lavabo) Eklemek / ayırmak istiyorum. Not: Bağlantı uçları küçük beyaz dairelerle ile gösterilir ve ilgili görünmesini bir 'ipucu' neden olacak bir saniye beyaz daire üzerinde çırpınırken rolisim(yani kaynak veya lavabo olarak).

4. SürüklemekBağlantı yeni bir konuma (bir boş yer ya da bir bileşen olarak) ve fare düğmesini bırakın bitirmek.

Not

Bir bağlantı ucu geçerli bileşenin üzerine yerleştirilir, hedef bileşenin anahat kesik anahat ile vurgulanır. Kullanılan renk düzeni çalışması mevcut proje ile uyarılar ve hatalar üzerindeki etkisini gösterir ve tarif edilmiştir Kısıtlamaları tanımlama ve doğrulama . Bir kez yayınlandı th bu sone Bağlantı ve bileşen otomatik olarak bağlanıp bağlanmadığını(veya ekli)Ve bu mimari modelde yansıtılır.

Bağlantıyı yeniden rota

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Bir bağlantı üzerine fare imlecini getirin.

3. Tutmak Vardiyatuşunu basılı ve Tıklayınfare düğmesi bir bağlantı çapa noktasını yerleştirmek için. Bırakın Vardiya tuşuna basın. Aynı işlemi yaparak çapa noktasını kaldırmak olabilir.

4. Tıkla ve sürükleBağlantı noktası yeniden rota bağlantı.

Bahşiş

KullanAlt bunun yerine temel VardiyaAnahtar dikey bağlantıları oluşturmak için.

Karşı eğri veya düzeltmek bağlantı

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Bir bağlantı üzerine fare imlecini getirin.

3. Sağ tıktO bağlantı seçin görüntülenen bağlam menüsünde Eğri, Ortogonal veya Düz.

Bahşiş

Tüm bağlantılardiyagram üzerinde belirli bir tip Eğimli, Ortogonal veya düz ayarlanabilir on tipine bağlı çizgi sağ tıklayarak Bağlantılar sekmesinearasında Stencil penceresive seçme Eğrisi, Dik veya Düz.

Karşı Bir şeklin kenarında belirli bir noktaya üzerine çapa

1. Varolan sahip olduğunuzdan emin olun Açık şeması .

2. Bir bağlantı seçin.

3. Üzerine fare imlecini getirin sonunda 'beyaz nokta' bağlantı.

4. Sağ tıktO bağlantı ucu seçin görüntülenen bağlam menüsünde Şekle Endpoint Çapa.Şeklin kenarında arzu konuma bağlantı ucunu hareket ettirin.

VEYA

Tutmak Ctrltuşunu basılı ve cyalamak ve sürükle- bağlantı ucu işaret etmek şeklin kenarında arzu yeri.

Not

Bağlantılar onların bağlı şekil gerçek kesişim yerine o şeklin sınırlayıcı kutusuna yaslanacaktır.

Ayrıca bakınız

Çizim Aracı | Senin mimarisi doldurma | Analiz senin mimari


Öğeleri birleştirme

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Öğeleri birleştirme

Yorum gönder bu konuda.

Ne zaman öğeleri birleştirme olur?

En iyi tek bir örnek tarafından temsil edilir modeliniz iki (veya daha fazla) nesneleri zaman öğeleri birleştirme olacaktır. Eğer, dahil olmak üzere bu yapmak isteyebilirsiniz birçok durum vardır:

· Çoğaltmak veya mevcut bilgileri yerini alabilir senin modele bilgilerin yeni bir dizi ithal sonucunda. Örneğin sizin modele bir elektronik tablo güncelleştirilmiş bir sürümünü alırsanız.

· Zamanla 'aynı' bileşeninin çoğaltmaları oluşturulur ve bu çiftleri temizlemek isteyen oylandı.

· Eğer yapıyorsanız bir ne-eğer senaryo ve aslında gerçekte birleşiyor modellik öğeler. İki sunucu birleştirme eğer Örneğin, kuruluşunuzda iki bölüm birleştirme veya eğer.

Neler birleştirilmiş olabilir?

Aşağıdaki öğe türlerini birleştirilen desteği:

· Standartlar

· Bileşen ve Bağlantı Tipleri

· Bileşenler ve Bağlantılar

Öğeleri birleştirmek için nasıl

Sağ fare düğmesini kullanarak, birleştirme başlatmak için, diğerinin üzerine explorer bir öğe sürükleyin. Eğer sürükleyerek öğe kaynağıdır ve sürüklediğiniz öğeyi yeridir. Sağ fare düğmesini bırakmadan üzerine size iki öğe Birleştirme seçebileceğiniz bir menü ile sunulacak. Sen korumak veya hedef üzerine yazmak isteyip istemediğinizi seçmek zorunda kalacak. Bu, aşağıda daha ayrıntılı açıklanmıştır.

Birleştirme Sağ sürükleyin menüsü

Korunması ve hedef üzerine arasındaki fark nedir?

Korumak veya üzerine seçeneği ne olur dikte kaynak ve hedef öğeleri maçın arasındaki Adı, Açıklama veya Özellikleri.

Koruma Hedef seçilirse

· Hedefin Ad ve Açıklama tutulacaktır.

· Sadece kaynakta mevcut herhangi Properties hedefe eklenir.

Üzerine Yaz Hedef seçilirse:

· Hedefin Adı kaynağından üzerine yazılır.

· Kaynağın Açıklama boş olmadığı sürece hedefin Açıklama kaynaktan üzerine yazılır.

· Sadece kaynakta mevcut herhangi Properties hedefe eklenir.

· Kaynağın Değer veya Birimi boştur sürece hem kaynak hem hedef var herhangi Özelliklerinin Değeri ve Birimi, kaynağından üzerine yazılır.

Özel Durumlar

· Türleri: Tiplerini birleştirme yaparken birey eğer, sonra hedef var eğer, izinleri gibi kaynağa izin hedef olmasaydı eğer, bu ilave edileceği, bir 'kötümser' şekilde, birleşerek ve edilir Bir kullanıcı grubuna (oluşturma, okuma, güncelleştirme veya silme) için izin, o reddedildi olacaktır (bir tek yalanladı, verilen) eşleşmedi.

· Bileşenler: Bileşenlerini birleştirme yaparken, kaynak alt bileşenler hedefe geçirilir ve isimleri aynı ise hedef alt bileşenleri ile birleştirilirNe olursa olsun Çeşidi.Ayrıca, aynı ada sahip kaynağının birden fazla alt bileşenler hedef tek bir alt bileşeni içine kombine olacak.

· Bağlantılar: Üst düzey bağlantıları kendileri de aynı ekleri (veya bunların eksikliği) birleştirilecek izin verilmesi için gereklidir. Bağlantıları birleştirme yaparken, kaynağın alt bağlantıları hedefe geçirilir ve isimleri aynı ise hedef alt bağlantıları ile birleştirilir VEekleri aynıdır. Ekleri aynı değilse, kaynak alt bağlantıları zaten mevcut eşleştirme bağlantıları ile birleştirilmesi olmadan hedefe eklenecektir. Hiçbir ekleri kaybolur, böylece budur.


3D Şeması navigasyon

Navigasyon: senin mimarisi analiz> 3D diyagramları>

3D Şeması navigasyon

Yorum gönder bu konuda.

ABACUS kolayca 3D olarak mimarlık gezinmek için izin verir. Tecrübe uçan benzer. Navigasyon iki mod vardır:

· Temel Kontrol Modu (Varsayılan); ve

· Gelişmiş Kontrol Modu - seçerek bu moda değişiklik Kontrol| Gelişmiş Kontrol Modu.

Not

Temel Kontrol ve İleri Kontrol Modu arasında geçiş yapmak için kullanabileceğiniz F4Klavye kısayolu işlevselliği.

Temel Kontrol Modu

· Sol Düğme Holding ve ileri veya geri fareyi hareket ettirerek sahayı değiştirir;

· Sol Düğme Holding ve fare sol veya sağ yaw değiştirir hareket;

· Sağ Düğme Holding ve fare tavalar görünümünü hareketli;

· , Ve mimari dışında yakınlaştırır aşağı her iki düğmeyi basılı tutup ileri veya geri fareyi hareket ettirerek; ve

· Aşağı hem düğmeleri tutarak ve fare sola veya sağa hareket sol ve sağ yuvarlanıyor.

- veya -

· Basmak Sol okKlavye ya da sola dönecek sayısal tuş takımı üzerindeki;

· Basmak Sağ okKlavye ya da sağa Sayısal tuş takımındaki;

· Basmak Yukarı okKlavye ya da yakınlaştırmak Sayısal tuş takımındaki;

· Basmak Aşağı okKlavye ya da uzaklaştırmak Sayısal tuş takımındaki;

· Basmak Sayfa yukarısıKlavye ya da pitch up Sayısal tuş takımındaki; ve

· Basmak Page Downklavyedeki ya da sayısal tuş takımındaki aşağı sahaya çıkacak.

Gelişmiş Kontrol Modu

· Hareketliileri ve geri, yukarı ve aşağı fare, zift ve yaw (sırasıyla) değiştirir;

· Basmak W veya Yukarı ok(ileri) mimarisine yakınlaştırır;

· Basmak S veya Aşağı okdışarı (geri) mimariden yakınlaştırır;

· Basmak A veya Sol oksola rulo;

· Basmak D veya Sağ oksağa rulo;

· Basmak Q veya Page Down(perspektif düşürerek) görünümünü yükselten; ve

· Basmak E veya Sayfa yukarısı(perspektif yükselterek) görünümü düşürür.

Etkileşimli Kontrol Modu

Tuşunu basılı tutarak değiştirme tuşuklavyede geçerli (Temel veya Gelişmiş) modunda interaktif kontrol moduna girmek için geçersiz kılar. Bu modda şu mümkündür:

· YuvarlanmaBir bileşen veya bağlantısı üzerinden fare imlecini bileşeni veya bağlantının adını görmek için;

· TıklayınBu bileşen yakınlaştırmak için bir bileşeni;

· Tıkla ve sürükleBir bileşeni bu bileşenin etrafında görünümü döndürmek için; ve

· Sağ tıkBir bileşen veya bağlantı seçin Explorer'da gösterBu bileşen veya ağaçta bağlantının yerini görmek için.

Ortak kontroller

· Kullanım / ESC ALT-ENTERTam ekran modu arasında geçiş yapmak;

· Kullanım F2Ekran modunu değiştirmek için. Bu, aynı zamanda erişilebilir Görünüm Menü.

· Kullan fare tekerleği veya +/-hızını değiştirmek için. Hız sol alt köşesinde bir numara ile gösterilir - bu değişiyor ancak gösterilen. 1 yavaş ve 100 hızlı.


Diyagramları Açılış

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Diyagramları Açılış

Yorum gönder bu konuda.

Çizim şablon ve tuval pencereler diyagram açıldığında veya oluşturulduğunda otomatik olarak belirir. Bir şema kapandığında Benzer şekilde, tuval penceresinde ilgili sekmeli sac kaybolur ve başka çizimler, sonra şablon penceresi kapatılır.

Karşı oluşturmakyeni bir diyagram

1. Bir olduğundan emin olunABACUS dosya açmasizin yanınızdaki içeren nüfuslu mimari.

2. Tıklayın DiagramGörünüm araç çubuğunda simgesine.

- veya -

2. Seçin Ekle| Diagram.

- veya -

2. Sağ tık DiyagramlarıVerilen bir dalı MimarlıkAğacın basıp bölümü Create Diyagram.

3. Seçin MimarlıkEğer açılan menüden odaklanmak istiyorum. Not: Yukarıdaki yeni diyagramı açmak için Adım 3 kullanılması durumunda mimarisi zaten sizin için seçilir.

4. Seçin Bakış açısı Eğer açılan menüden kullanmak istiyorum. Not: seçilen bakış açısı bakış açısı yalnızca olacak olanlara bileşenleri ve bağlantıları listeler süzer.

5. İsteğe bağlı bir görünüm seçin Görünüm olarak Filtreaçılan menü seçilen görünümde bileşenleri ve bağlantıları preselect için. Not: Bu etkili bir şekilde kaydedilmiş bir sorgu olarak seçilen görünümünü kullanıyor.

6. Seçin Düzen ya da olmak Radyal veya Izgara.

7. Seçin Bileşenler ve BağlantılarEğer gelen şemada istediğiniz Standart eleman seçimi penceresi .

8. Tıklayın tamam.

Not

Yeni bir diyagramı eklenecek Diyagramlarımimari dalı. Bu üzerine sağ tıklayarak, daha sonra değiştirebileceğiniz varsayılan bir ad, sahip olacaktır.Ayrıca, bileşen ve bağlantı seçimi filtrelerinin son durum diyagramı etkin bir diyagramı oluşturmak için kullanılan 'sorgusu' tasarruf ile kaydedilir.

Varolan diyagramı açmak için

1. Belirli nüfuslu mimarisinde, genişletmek DiyagramlarıAğacın dalı.

2. Çift tıklama diyagram Açmak istediğiniz.

Bir diyagram kaydetmek için

1. Eğer yeni veya mevcut diyagram sahip olduğunuzdan emin olun açıkve gerekli değişiklikleri yaptık. Not: Bir yıldız '*' sekmeli sac başlığındaki görünümü adından sonra gösterilecektir kaydedilecek değişiklikler varsa.

2. Kaşif görünümünde tıklayın Kaydetdüğme veya var Dosya| Kaydetveya bastırmak Ctrl + Ssenin mimarisinde tüm değişiklikleri kaydetmek ve dosya yazmak için.

Bir şekilde bir diyagram kaydetmek için bakış açısı

1. Eğer ABACUS dosyasında varolan diyagram olduğundan emin olun.

2. Sağ tıkdiyagramı DiyagramlarıAğacın parçasıdır.

3. Seçin Farklı kaydet Diyagram Bakış Açısı.

4. Yeni bir ad girin diyagram bakış açısıve tıklayın tamam.

Ayrıca bakınız

Çizim Aracı | Senin mimarisi doldurma | Analiz senin mimari


Kullanarak Kataloglar doldurma

Navigasyon: Mimarinizi doldurma>

Kullanarak Kataloglar doldurma

Yorum gönder bu konuda.

A katalog görüntülemek ve düzenlemek için izin verir bileşenleri bağlantıları ve özellikleri veya Basit bir tablo bir şekilde.

Karşı Yeni Kataloğu oluşturmak görüntülemek ABAKÜS

Not

Tüm Mimar kullanıcılar yeni Kataloglar oluşturabilirsiniz, varolan Catalogue ayarlarında yapılan değişiklikleri kaydetmek için kullanıcı lisans Tasarımcı eklenti yeteneği ihtiyacı var. Bu, birçok kullanıcı tarafından paylaşılan olabilir mevcut Kataloglar yapılandırmasını 'korumak' etmektir. Ancak, Mimar add-on hala 'Farklı Kaydet' Yeni Kataloğu için herhangi bir yeni ayarların seçebilirsiniz Tasarımcı olmadan kullanır. Ve elbette tüm kullanıcı lisansları 'Discard' Varolan Kataloğu herhangi bir değişiklik seçebilirsiniz. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer ihtiyacınız varsa Tasarımcı add-on yeteneği. Ve bu ne olursa olsun, katalog, sadece ayarları Kataloğu verilerde yapılan tüm düzenlemeler anında depo uygulanır olduğunu unutmayın.

1. Ekle Seçin | Katalog.

2. İçinde pull-down bileşenleri içerir Mimarlık seçin veyabağlantıları Görüntülemek istediğiniz.

3. İçinde açılan bileşenini seçin ya da bağlantı türü Eğer örnekleri 'olarak listelenen istediklerinisatır' katalogda.

4. katalog Bir ile doldurulurSeçilen bileşen veya bağlantı türü her örneği için satır.

Not

Varsayılan olarak sol-en Hiyerarşi YoluKolon ve 2. (seçilen örnekler üzerinde ebeveyn bileşenleri veya bağlantıların hiyerarşisinde yani) Isim Kolon (seçilen bileşen veya bağlantı örnekleri listesinde yani) katalog soluna dondurulur. Sütun değiştirmek için dondurma Ad sütununda sağ sütun ayracı sürükleyin. Yapabilirsin yeniden siparişbasitçe sürükleyip ve sütun başlıklarını bırakarak sütunlar. Mavi altı çizilerek sütun hücreleri köprüler Diğer projede elemanları ve köprülere Ctrl tuşunu basılı tutarak ve bağlantılarla takip edilebilir. Sütunlar olabilir gizli tarafından sağ tıklatıp sütun başlığını ve Sütunu seçtikten | Sütunu gizle. Gizli sütunlar, ya da, ya Genel gizli sütun (lar) seçerek tek tek Properties yapılandırma Sütunlar araç çubuğu düğmesinin aşağı ok bölümünü seçerek ve yapılandırma Sütunlar araç çubuğu düğmesine tıklayarak ve aşağıda gösterildiği gibi iletişim yapılandır Kolonlar kullanılarak unhidden edilebilir veya Ekler koleksiyonları. Satırlar olabilir gruplandırılmış katalog üstündeki mavi gruplama çubuğuna sütun başlığını sürükleyerek onların sütun değerleri ile. Herhangi bir zamanda tıklayarak ikiye katlayabilirsiniz Katalog satır seçici ve atlailgili bileşenveya bağlantıExplorer penceresinde.Mülkiyet hücre değerleri kalın Onlar varsayılan farklıdır ve nerede italik Onlar nerede salt okunur. Zaman Damgası, Mülkiyet ve Bağlı Bileşen sütunları olabilir renkli | Hücre değerleri veya sütun başlığını sağ tıklayıp Sütun seçerek iliştirilmiş bir bileşenin özellik değerine göre Change Color ... ve Zaman Damgası veya Renk By Gayrimenkul seçeneği ile daha sonra Renk, ancak, sadece Liste, Tamsayı, Ondalık, Boolean veya Tarih / Saat Veri türü özellikleri renk olacak. Ekli Bileşen sütunlar için Özellik değerleri olabilir gösterilen tarafından sağ tıklatıp sütun başlığını ve Sütunu seçtikten | İşletmeye ... ve ardından Show İşletme seçeneğini göster. Ve son olarak, burada orada Gerekli kısıtlamaları Bir özellik sütun için belirlenen bu bir ile gösterilebilir | dize sütun başlığını tıklatarak sağ tarafından ve Sütun seçerek (birlikte boyama onların icra düzeylerine göre) ile göster.

Katalog

Karşı için / göstermek sütunlar eklemek a Katalog ABACUS'e görünümü

1. Eğer bir sahip olduğunuzdan emin olun Katalog görünümü açık.

2. Gizli sütunlar tek tek tıklayarak unhidden edilebilir Yapılandırma Sütunlar araç çubuğu düğmesinin sağ tarafta okve gizli sütun seçerek ya Genel, Özellikler veya Eklentiler koleksiyonlar.

Not

Bir onay işareti kataloğu için şu anda gösterilen sütunlar yanında gösterilir.Ayrıca, sadece belirli ekleri göre bölüm Ekler altında satışa sunulacak kısıtlamaları Bu projenizde tanımlanır. Özellikle, bir eki için katalog için bileşen türü ya kaynağı olarak belirtilmeyen veya bir bağlantı için bir yorum "bağlantısına takılı olmalıdır" kısıtlaması ('Herhangi' DEĞİL) lavabo gereken bileşen katalogda gösterilecek kullanılabilir olması için tipi, hem de (NOT 'Herhangi') aynı bağlantı türü diğer 'end' en az bir bileşen türü ya kaynağı olarak belirtilmeyen veya lavabo olmalıdır.

- VEYA -

2. Çoklu sütunlar tıklayarak unhidden (ya da sipariş veya sabit) olabilir Sütunlar araç çubuğu düğmesini yapılandırmave Yapılandırma sütunlar kullanılarak aşağıda gösterilen iletişim.

Not

O anda görüntülenen sütunlar soldaki panelde gösterilen mevcut sütunlu sağdaki panelde gösterilir. Mevcut sütunlar göre filtrelenmiş olabilir Gönderen Mevcut Sütunları Seçpull-down ve soldaki panelde bunları seçip tıklayarak eklenebilir Eklemek iki panel inbetween düğmesine basın.

Sütunlar iletişim kutusunu yapılandırın

Karşı Bir sütun gizlemek / kaldır Katalog ABACUS'e görünümü

1. Eğer bir sahip olduğunuzdan emin olun Katalog görünümü açık.

2. Eğer / gizlemek kaldırmak ve seçmek istediğiniz sütun için sütun başlığını sağ tıklayın Sütun | Hide Sütun.

- VEYA -

2. Çoklu sütunlar gizli (ya da sipariş veya sabit) tıklatarak edilebilir Sütunlar araç çubuğu düğmesini yapılandırmave Yapılandırma sütunlar kullanılarak yukarıda gösterilen iletişim.

Not

O anda görüntülenen sütunlar soldaki panelde gösterilen mevcut sütunlu sağdaki panelde gösterilir. O anda görüntülenen sütunlar sağdaki panelde sütununu seçip tıklayarak gizli olabilir Kaldır iki panel inbetween düğmesine basın.

Bir kullanarak doldurmak için Katalog ABACUS'e görünümü

1. Karşı ekle bileşen veya bağlantıSeçilen Çeşidi için katalog (ve proje) / Yeni Bileşen Ekle Yeni Bağlantı araç çubuğu Ekle düğmesini tıklatın. Satır gerekir görünür ve bir bileşen veya Bağlantı üst düzeyinde oluşturulacak Bileşenler veya Seçilen Mimarlık Bağlantılar koleksiyonu.

Not

Yeni bileşenler ve bağlantılar seçilen Mimarlık Bileşenleri veya Bağlantılar koleksiyonu en üst düzeyde varsayılan olarak eklenir. Yeni bileşenler veya bağlantıların üst değiştirmek için yeni bir bileşen veya bağlantıları satır için Hiyerarşi Yol hücreyi sağ tıklatın ve seçin Değişim Veli ...ve istenen üst seçin (not alarak kısıt vurgulama ).

Not

Yeni satır / elemanlar MS Excel katalog aktarmak yoluyla katalog yapıştırılan ya da oluşturulan 'Ekle Yeni' düğmesi ile bir katalog doğrudan ilave katalog kapanana kadar filtreleme muaf tutulurlar. Bu katalog mevcut filtreleme kriterlerine uygun olmayabilir sütun değerleri gerekli düzenleme sağlamaktır. Bu yeni eleman satırlar renkli satırın başında satır seçici hücresinde bir '+' sembolü ile gösterilir yeşil eleman halen katalog kaydedilen filtreleme kriterleri karşılaması durumunda (yani yeniden açarsa katalog kalır) ve kırmızı bunları yapmazsa.

2. Karşı kaldırmak için bileşen veya bağlantıSeçilen Çeşidi itibaren katalog (ve proje) satır ve ya basın Del tuşuna veya satır seçicisini sağ tıklayın ve seçin Mimarlık Sil. sıra kaybolur Katalogdan ve o projeden silinecektir.

Karşı filtre kullanılarak Katalog ABACUS'e görünümü

1. Eğer bir sahip olduğunuzdan emin olun Katalog görünümü açık.

2. Filtre sıra katalog üstündeki görünmüyorsa o tıklayın Göster Filtre Başlık Satırıaraç çubuğu düğmesi.

3. O '(Tümü)' gösterir nerede sütununda bir filtre eklemek isterim, filtre satır hücreyi çift tıklatın.

4. İçin Zaman Damgası, Hiyerarşi Yol, Ad veya AçıklamaGenel sütun veya Metin, Tamsayı, Ondalık, Boolean veya Tarih / Saatmülkiyet sütunları filtre satır hücrenin sağında görünür ... düğmesine tıklayın ve katalogda yer almalıdır hücre değerleri girin.

Not

(Tırnak işaretleri olmadan) 'cat' bir giriş 'bob ile satır yer alacağını, böylece Eşleştirme' * 'joker otomatik öncesinde ve herhangi bir dize değerlerine sonra uygulanır sanki yapılırkedi','kedikadın 'veya' başvurununkediion 'vb Çoklu /' veya 'değerleri kullanarak yeni hatlarda girilebilir Ctrl + Enter. Tamsayı ve ondalık mülkiyet sütunlar 've' mantık 'kullanılarak dahil edilebilir&'(Tırnak işaretleri olmadan) ve daha büyük / vb mantığı daha az kullanılarak dahil edilebilir'> =','>','<' ve '<='(Tırnak işaretleri olmadan), örneğin '> = 50000 & <90000'. Boş olmayan değerli satırlar 'girerek dahil edilebilir(Non-Boşluklar)'(Tırnak işaretleri olmadan) ve Blank değerli satırlar girerek dahil edilebilir'(Boşluklar)'(Tırnak işaretleri olmadan).Ve son olarak, tüm filtreleri yani (tırnak işaretleri olmadan) 'cat' harf duyarlı eşleştirme için 'kedi', 'Cat' veya 'CAT' vb ile satır içerecek duyarsız varsayılan dava ile olan 'girin(Case)'Mesela dize önce (tırnak işaretleri olmadan) (Tırnak işaretleri olmadan) '(Case) Kedi' sadece onları 'Cat' ile satır içerir.

5. İçin Eklentilerkolonlar, Standartlar sütunları ya da Liste mülkiyet sütunları filtre satır hücrenin sağında görünen aşağı ok düğmesini tıklayın ve katalogda dahil edilmelidir onay kutularını hücre değerleri seçin.

Not

'(Tümünü Seç)' onay kutusunu mevcut tüm satırlar da dahil olmak üzere yürürlükte bulunan diğer tüm onay kutularını, sağlayacaktır. '(Non-Boşluklar)' onay kutusunu olmayan herhangi bir boş değerli satırların yer alacak. '(Boşluklar)' onay kutusunu herhangi bir boş değerli satır içerecek. Tutarlılık Ve nihayet, seçimini otomatik olarak herhangi bir spesifik değerli onay kutularını olacak unchecking '(Tümünü Seç)' ve '(Non-Boşluklar)' onay kutularını.

6. Tıklayın tamam Filtreyi uygulamak.

Karşı süzme etkinleştirme / devre dışı bırakma a Katalog ABACUS'e görünümü

1. Eğer bir sahip olduğunuzdan emin olun Katalog görünümü açık Birlikte filtre uygulamalı.

2. Filtre satırın solundaki onay kutusunu tıklatın.

Karşı Bir filtreyi kaldırmak a Katalog ABACUS'e görünümü

1. Eğer bir sahip olduğunuzdan emin olun Katalog görünümü açık Birlikte filtre uygulamalı.

2. Tek bir sütun filtreyi kaldırmak için sütun başlığını sağ tıklatın ve seçin Sütun | Temizle Filtreleme.

3. Tüm filtreleri kaldırmak için tıklayın Seçenekler araç çubuğu düğmesi seçin Temizle Filtre Ayarları.

Kaydetmek / farklı kaydet aKatalog görünümü

Not

Tüm Mimar kullanıcılar yeni Kataloglar oluşturabilirsiniz, varolan Catalogue ayarlarında yapılan değişiklikleri kaydetmek için kullanıcı lisans Tasarımcı eklenti yeteneği ihtiyacı var. Bu, birçok kullanıcı tarafından paylaşılan olabilir mevcut Kataloglar yapılandırmasını 'korumak' etmektir. Ancak, Mimar add-on hala 'Farklı Kaydet' Yeni Kataloğu için herhangi bir yeni ayarların seçebilirsiniz Tasarımcı olmadan kullanır. Ve elbette tüm kullanıcı lisansları 'Discard' Varolan Kataloğu herhangi bir değişiklik seçebilirsiniz. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer ihtiyacınız varsa Tasarımcı add-on yeteneği.Ve bu ne olursa olsun, katalog, sadece ayarları Kataloğu verilerde yapılan tüm düzenlemeler anında depo uygulanır olduğunu unutmayın.

1. Yeni sahip olduğunuzdan emin olun ya Katalog görünümü mevcut açıkve gerekli değişiklikleri yaptık.

2. İçinde Katalog görünümüaraç çubuğu tıklayın Kaydetdüğmesine kaydetmek için Katalog görünümü ve herhangi bir biçimlendirme değişiklikleri.

Not

Eğer Katalog görünümü araç çubuğunda bir Kaydet düğmesini yoksa o zaman Tasarımcı eklenti yok ve sadece mümkün Farklı kaydetVarolan katalog kapatmak için gittiğinizde herhangi bir ayar, yeni bir katalog değişir.

3. Eğer KatalogIsimiletişim kutusu görüntülenir (nedeniyle, yeni bir katalog olmanın) için bir isim girin katalog ve basın tamam.

Karşı MS Excel katalog ihracat

1. Eğer bir sahip olduğunuzdan emin olun Katalog görünümü açık.

2. Tıkla Excel Kataloğu elektronik tabloya aktararaç çubuğu düğmesi.

3. MS Excel kataloğunu kaydetmek için bir dosya adı seçin. Tıklayın Kaydet.

Not

Varsayılan olarak ihraç MS Excel katalog dosya adı parantez içinde Mimarlık adına göre ekli Katalog adı, örneğin olacak 'Projeler (2014 Fiili) .xlsx'. Sen dosya biçimi .xlsx veya .xls olmak olup olmadığını da dahil olmak üzere, bu herhangi birini değiştirebilirsiniz. Mimari adı her katalog geri aşağıda başına MS Excel katalog Al'ı kullanarak yuvarlak takıldı olmasını sağlamak için (sütun A ve satır 1 yani kimlikleri) belirli içeriğe sahip kullanıcı hatırlatmak dahildir.

Not

Varsayılan olarak ihraç MS Excel katalog içinde gizli Sütun A ABACUS depodaki elemanların her biri için benzersiz bir kimlik içerir. Bu, MS Excel içinde yapılan değişiklikler (aşağıya bakınız) ithalatına ABACUS içindeki mevcut elemanlara 'eşleşti' sağlar. Ancak, satır 'maç' için bu eşsiz kimlik kullanımı, bir ile geçersiz kılınabilir Dış | İDelemanın mülkiyet. | Eleman Harici varsa Yani, Kimlik özelliği ve Dış sonra değerleri ihracat katalogda yer almaktadır | Kimlik sütunu (aşağıya bakınız) ithalat satırları maç için kullanılacaktır ve gizli A sütununda benzersiz kimlik değerleri göz ardı edilecektir (ve hatta boş olabilir). Gizli sütunu kendisini, özellikle, ancak, A1 hücresindeki kalmalıdır. Varolan ABACUS eleman toplama dış kimlikleri eklerken Ayrıca, örneğin, ilk farklı bir özellik olarak eklemenizi öneririz Dış | | Temp ve ardından Harici özelliğini yeniden adlandırma İD. Aksi takdirde yinelenen unsurlar eklenecektir.

Katalog biçimlendirmeVarsayılan olarak ihraç edilir, ancak, büyük kataloglar için bu ihracat oldukça yavaş olması neden olabilir. Bu nedenle, bu Araçlar | Seçenekler ...ardından Katalogsekmesi,Eğer böylece ihracat hızlandırılması, aşağıda Katalog sekmesinde gösterildiği gibi dışa biçimlendirme miktarını azaltmak mümkün.

Katalog ihracat seçenekleri

4. İhracat Tamamlandı iletişim kutusu görüntülenir. Tıklayın tamam.

MS Excel katalog ihraç

Karşı MS Excel katalog ithalat

Not

Varsayılan olarak ihraç MS Excel katalog içinde gizli Sütun A (yukarıya bakınız) ABACUS depodaki elemanların her biri için benzersiz bir kimlik içerir. Bu, MS Excel içinde yapılan değişiklikler ithalatına ABACUS içindeki mevcut elemanlara 'eşleşti' sağlar. Ancak, satır 'maç' için bu eşsiz kimlik kullanımı, bir ile geçersiz kılınabilir Dış | İDelemanın mülkiyet. | Eleman Harici varsa Yani, Kimlik özelliği ve ihracat katalogda yer almaktadır sonra Dışsal değerlerini (yukarıya bakınız) | Kimlik sütunu göz ardı edilecektir gizli A sütununda ithalatına satır ve benzersiz kimlik değerlerini maç için kullanılır (ve hatta boş olabilir). Gizli sütunu kendisini, özellikle, ancak, A1 hücresindeki kalmalıdır. Varolan ABACUS eleman toplama dış kimlikleri eklerken Ayrıca, örneğin, ilk farklı bir özellik olarak eklemenizi öneririz Dış | | Temp ve ardından Harici özelliğini yeniden adlandırma İD. Aksi takdirde yinelenen unsurlar eklenecektir.

1. Eğer bir sahip olduğunuzdan emin olun Katalog görünümü açık.

2. Tıkla Excel Kataloğu elektronik tabloya İthalataraç çubuğu düğmesi.

3. MS Excel katalog almak için bir dosya adı seçin. Tıklayın Açık.

4. Yeni Hatalar tespit ve / veya Yeni Hatalar / Uyarılar diyaloglar her yeni içerik için görünür eklendi (MS Excel, yani satır) olabilir algılandı. Hatalar / uyarılar dikkate alın ve tıklayın tamam.

5. Bir İthalat Tamamlandı iletişim kutusu görüntülenir ve ithalat nedeniyle uyarı (aşağıdaki notlara bakın) gösterebilir. Tıklayın tamam.

Not

Standartlar atanmış veya ekli Bileşen sütunları, MS Excel katalog üzerinden yeni girişler tam olarak eşleşmelidir isim atama veya bağlantı için doğru türde varolan Standart veya Bileşen eklenecek. İlk adında maç kullanılacak ve herhangi bir eşsiz girişleri aşağıda başına bir uyarı üretecektir. Uyarılar yeniden ithalat verilmiştir iken Dahası, unsurlardır silinmezABACUS'e dan onlar MS Excel kataloğunda mevcut değilse. ABACUS MS Excel katalog silindi veya ABACUS'te eklenmiştir çünkü Standart atanmış veya ekli Bileşen ABACUS projede var, ancak MS Excel kataloğunda yok olmadığını biliyorsunuz hiçbir yolu yoktur, çünkü bu katalog yana proje ihraç edildi. Buna göre, kullanıcıların kolayca bağlantıları alma işlemi sırasında ilave edildiği 'tespit' isterseniz onlar sadece bağlantı türüne gerekli özellik oluşturabilir ve herhangi bir yeni bağlantıların her zaman ithalat konusunda uyardı olacak böylece boş varsayılan bulunuyor set tamamlandı.

Not

Bir MS Excel katalog alırken çeşitli uyarılar görüntülenebilir. Öncelikle, yeni bir sütun sütun göz ardı edilecektir bir özellik veya ekli bileşen için 'sözdizimi' eşleşmiyor Excel eklendi eğer. Ardından, line-by-line uyarıları Excel katalog her satırda veri ile herhangi bir sorun için görüntülenir. Bu uyarılar (satırda 23 sütun J için '... [23 J]' yani) sütun etiketi köşeli parantez içinde ve ilgili ise satır numarası ile başlar ve (silinmiş öğeler, eşsiz Standartları veya ekli Bileşen isimleri bakın hangi Yukarıdaki not olarak başına ihmal) ya da geçersiz veya boş kimlik, yeni bir satır / elemanına ilişkin olan (yani) eklenecektir. Bakınız Excel katalogları kullanarak ABACUS doldurma detaylı bir makale için Avolution Topluluk veya Portföy Yöneticisi eğitim kursu.

Not

Yeni bileşenler ve bağlantılar seçilen Mimarlık Bileşenleri veya Bağlantılar koleksiyonu en üst düzeyde varsayılan olarak eklenir. Yeni bileşenler veya bağlantıların üst değiştirmek için yeni bir bileşen veya bağlantıları satır için Hiyerarşi Yol hücreyi sağ tıklatın ve seçin Değişim Veli ...ve istenen üst seçin (not alarak kısıt vurgulama ).

Not

Elements MS Excel katalog aktarmak yoluyla katalog yapıştırılan ya da oluşturulan 'Ekle Yeni' düğmesi ile bir katalog doğrudan ilave katalog kapanana kadar filtreleme muaf tutulurlar. Bu katalog mevcut filtreleme kriterlerine uygun olmayabilir sütun değerleri gerekli düzenleme sağlamaktır. Bu yeni eleman satırlar renkli satırın başında satır seçici hücresinde bir '+' sembolü ile gösterilir yeşil eleman halen katalog kaydedilen filtreleme kriterleri karşılaması durumunda (yani yeniden açarsa katalog kalır) ve kırmızı bunları yapmazsa.

Karşı Başka bir mimariye sahip bir katalog içeriğini karşılaştırmak

1. Konuya bakın İşte .

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Visio sizin mimarisi doldurma | Excel sizin mimarisi doldurma


Kullanarak Matrislerinde doldurma

Navigasyon: Mimarinizi doldurma>

Kullanarak Matrislerinde doldurma

Yorum gönder bu konuda.

Bir matris görüntülemek ve düzenlemek için izin verir 'doğrudan' Basit bir tablo bir şekilde parçaları arasındaki bağlantılarınve aynı zamanda, herhangi bir ara bileşenleri (ve bağlantıları) 'e göre bileşenler arasında "dolaylı yolu' görüntülemek.

Karşı oluşturmak ABACUS'e bir Matrix görünümü

Not

Tüm Mimar kullanıcıların Matrisler oluşturabilir iken onları ve / veya ayarları kaydetmek için kullanıcı lisans Tasarımcı eklenti yeteneği ihtiyacı var. Bu, birçok kullanıcı tarafından paylaşılan olabilir mevcut Matris yapılandırmasını 'korumak' etmektir. Ancak, Mimar Tasarımcı olmadan kullandığı add-on hala 'Farklı Kaydet' Yeni Matrix için herhangi bir yeni ayarların seçebilirsiniz. Ve elbette tüm kullanıcı lisansları 'Discard' Varolan Matrix herhangi bir değişiklik seçebilirsiniz. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

1. Ekle Seçin | Matrix.

2. İçinde rchitecture>pull-down görüntülemek istediğiniz bileşenleri ve bağlantıları içeren Mimarlık seçin.

3. İçinde <KaynakTip>pull-aşağı 'olarak listelenen örneklerini sahibi olmak isteyen bileşen türünü seçinsatır' sol taraftamatris.

4. İçinde <LavaboTip>pull-aşağı 'olarak listelenen örneklerini sahibi olmak isteyen bileşen türünü seçinsütunlar' üstündematris.

5. İçinde aşağı çek tanımlayabilirsiniz matris iki 'modu' esasen vardır ...

'Direct' bağlantıları matrisi

6. Basitçe sseçilmiş bir (1) ya da daha fazla bağlantı türleri görünür menüsünün sağ taraftaki Eğer varsa matris 'hücrelerinde' görmek isteyenn açıkBağlantı gelen var Dikey/ 'sıraMatrisin 'bileşeni Yatay/ 'sütunMatrisin 'bileşeni.

Not

Kaynağı ile Sadece bağlantıları bağlı end Dikey/ 'sıra'Bileşeni ve lavabo uç bağlı Yatay/ 'sütun'Bileşeni gösterilecektir. Anahtarı Kaynak ve Lavabobileşen türü seçimleri ters yönde bağlantıları görüntülemek için.

7. Matrix 'X' ile doldurulur hücrelerde (veya özellik değeri - aşağıdaki nota bakınız) bir bağlantı olup olmadığını Dikey/ 'satır 'matrisin bileşeni Yatay/ 'sütunMatrisin 'bileşeni.

Not

Büyük matrisler için 100 satır veya (daraltılmış satır / sütunlarda dahil) bölümlerinden sadece maksimum sırasıyla sol üst başlık hücrede 'R' ve 'C' göstergelerinde görüldüğü gibi bir anda gösterilir. Ek satır kaydırma çubuklarını kullanın görüntülemek için. Herhangi bir zamanda tıklayarak ikiye katlayabilirsiniz Dikey/ 'sıra' veya Horizontal / 'sütun'Bileşeni başlıklar ve atlaExplorer penceresinde karşılık gelen bileşenler.Dikey anne/ 'sıra' ve Yatay/ 'sütun'Bileşenis aynı zamanda isteğe bağlı gri başlık başlığı ile satır / sütun başlığı olarak gösterilir. Çocuklar ekleri sonra 'X' var ise (tek tıklama başlığı hücre) tarafından çöktüğünde tüm çocukların bağlıymış tercihe gösterilir veya sadece bazı çocuklar bağlıymış bir 'O', isteğe bağlı olarak gösterilir. Hücreler olabilir renkli Matris araç çubuğunun sağ üst köşesindeki Seçenekler 'dişli çarkı' tıklayarak ve ardından Düzenle düğmesini ... Renk Ayarları seçme ve ve Zaman Damgası veya Renk By Gayrimenkul seçeneği Renk seçme ve seçerek bağlantıların bir özellik değerine göre Bir özelliği, Min ve Max değer aralığı seçerek renkler, ancak, sadece Liste, Tamsayı, Ondalık, Boolean veya Tarih / Saat Veri türü özellikleri renk olacak. Çökmüş ise hücre bağlantılarının ortalama mülkiyet değerine göre renkli olacak. Bunun yerine bir 'X', hücreler için özellik değerleri olabilir gösterilen Matris araç çubuğunun sağ üst köşesindeki Seçenekler 'dişli çark' tıklayarak ve Düzenle düğmesini ... Show Değeri Ayarları seçip ve Show mülkiyet seçeneğini seçerek ve bir mülk seçerek.

Uygulamalar boyama ve özellik ile barındırılan Sunucuları gösteren Doğrudan bağlantı matrisi yerine vizyonda genel 'X'

- VEYA -

'Dolaylı' bağlantıları matrisi

6. Sseçilmişbir dizi bağlantı türleri ve bileşen tiplerigörünür menünün sağ ve sol taraftaki Eğer varsa matris 'hücrelerinde' görmek isteyenbağlı bileşenlerin n dolaylı yoludan biri Dikey/ 'sıraMatrisin 'bileşeni Yatay/ 'sütunMatrisin 'bileşeni.

Not

Yol menüsünde w seçilen unsurları içeren herhangi geçerli bir yolhasta gösterilirSebep ne olursa olsun bağlantı yönüne Bununla birlikte, yol seçerken ilk ve Son unsurlar bağlantı türleri olmalı seçilen. Ayrıca, sipariş Bir gösterilir seçilmiştir elemanların Sayısal önekimeydanda ('[]') parantez ve belirli bir tip dahil edilebilir mutliple kez(sayısal bir önek ile gösterildiği gibi) yolu. Bileşen tipleri veya bağlantı türlerinin Ardıl seçim bir olarak yorumlanır 'VEYA'yolu ve bağlı bileşenlerin hiyerarşisi isteğe bağlı denetleyerek dahil edilebilir 'Ayrıca Ek anne / çocuk arama'Onay kutusunu işaretleyin. Anahtarı Kaynak ve Lavabobileşen türü seçimleri görüntülemek için yolları ters yönde.

7. Matris ile doldurulurbileşenlerin yolu / toplamahücreleri içinde olup olmadığını yol itibaren Dikey/ 'satır 'matrisin bileşeni Yatay/ 'sütunMatrisin 'bileşeni.

Not

Büyük matrisler için 100 satır veya (daraltılmış satır / sütunlarda dahil) bölümlerinden sadece maksimum sırasıyla sol üst başlık hücrede 'R' ve 'C' göstergelerinde görüldüğü gibi bir anda gösterilir. Ek satır kaydırma çubuklarını kullanın görüntülemek için. Herhangi bir zamanda tıklayarak ikiye katlayabilirsiniz Dikey/ 'sıra' veya Horizontal / 'sütun'Bileşeni başlıklar ve atlaExplorer penceresinde karşılık gelen bileşenler.Dikey anne/ 'sıra' ve Yatay/ 'sütun'Bileşenis aynı zamanda isteğe bağlı gri başlık başlığı ile satır / sütun başlığı olarak gösterilir. Herhangi bir çocuk yolları daha sonra bir 'X' var ise (tek tıklama başlığı hücre) tarafından çöktüğünde tüm çocukların bağlıymış tercihe gösterilir veya sadece çocuklar bazı yollar olsaydı bir 'O', isteğe bağlı olarak gösterilir. Dolaylı yol bileşenleri olabilir renkli Matris araç çubuğunun sağ üst köşesindeki Seçenekler 'dişli çarkı' tıklayarak ve Düzenle düğmesini ... Renk Ayarları seçip ve Zaman Damgası veya Renk By Gayrimenkul seçeneği Renk seçme ve seçerek bileşenlerin bir özellik değerine göre Bir özelliği, Min ve Max değer aralığı seçerek renkler, ancak, sadece Liste, Tamsayı, Ondalık, Boolean veya Tarih / Saat Veri türü özellikleri renk olacak. Dolaylı yol bileşenleri için Özellik değerleri olabilir gösterilen Matris araç çubuğunun sağ üst köşesindeki Seçenekler 'dişli çark' tıklayarak ve Düzenle düğmesini ... Show Değeri Ayarları seçip ve Show mülkiyet seçeneğini seçerek ve bir mülk seçerek.

Bölümü tarafından verilen bir hizmet uygulamak Uygulamaları gösteren Dolaylı bağlantıları matris

Karşı filtreABACUS'e bir Matrix görünümü

1. Yeni sahip olduğunuzdan emin olun Matrix görünümü açık.

2. Matris araç çubuğunun sağ üst köşesindeki Filtre eksenlerini 'huni' tıklayın.

3. Kaynak ve / veya Lavabo sekmelerde gerekli ve tıklayarak eğer bir özelliği, Ekle düğmesine tıklayarak seçerek Adı, Özellik, Açıklama, Hiyerarşi ya da Standart filtreler eklemek tamam. Aşağıdaki notta açıklandığı gibi mantık / sözdizimi kullanarak Anahtar / Öğeler panelinde ilgili seçenekleri belirleyin. Önizleme paneli otomatik filtreler geçerli kümesi sonuçlarını göstermek için güncellenir.

Not

İçin Zaman Damgası, Hiyerarşi Yol, Ad veya Açıklamafiltre veya Metin, Tamsayı, Ondalık, Boolean veya Tarih / Saat(tırnak işaretleri olmadan) 'cat' bir giriş 'bob ile satır yer alacağını, böylece mülkiyet filtreleri eşleştirme' * 'joker otomatik öncesinde ve herhangi bir dize değerlerine sonra uygulanır sanki yapılırkedi','kedikadın 'veya' başvurununkediion 'vb Çoklu /' veya 'değerleri kullanarak yeni hatlarda girilebilir Ctrl + Enter. İçin Tamsayı ve Ondalık mülkiyet filtreleri 've' mantık 'kullanılarak dahil edilebilir&'(Tırnak işaretleri olmadan) ve daha büyük / vb mantığı daha az kullanılarak dahil edilebilir'> =','>','<' ve '<='(Tırnak işaretleri olmadan), örneğin '> = 50000 & <90000'. Boş olmayan değerli satırlar 'girerek dahil edilebilir(Non-Boşluklar)'(Tırnak işaretleri olmadan) ve Blank değerli satırlar girerek dahil edilebilir'(Boşluklar)'(Tırnak işaretleri olmadan). İçin Standartlar veya Liste mülkiyet '(Tümünü Seç)' onay kutusunu mevcut tüm unsurları da dahil olmak üzere yürürlükte bulunan diğer tüm onay kutularını, sağlayacaktır filtreler. '(Non-Boşluklar)' onay kutusunu olmayan boş mülkiyet değerli unsurları içerecektir. '(Boşluklar)' onay kutusunu herhangi bir boş, tesisi değerli unsurları içerecektir. Ve herhangi bir spesifik değerli onay kutularını kaldırarak otomatik tutarlılık için '(Tümünü Seç)' ve '(Non-Boşluklar)' onay kutularını seçimini. Ve son olarak, tüm filtreleri yani (tırnak işaretleri olmadan) 'cat' harf duyarlı eşleştirme için 'kedi', 'Cat' veya 'CAT' vb ile unsurlarını içerecektir duyarsız varsayılan dava ile olan 'girin(Case)'Mesela dize önce (tırnak işaretleri olmadan) (Tırnak işaretleri olmadan) '(Case) Kedi' sadece onları 'Cat' ile elemanları içerir.

ABACUS'e bir Matrix görünümünü kullanarak doldurmak için

Not

Sadece ekleyebilir / tek bir bağlantı türü yukarıda açıklanan Path kullanılmıştır bağlantılarını kaldırabilirsiniz.

1. Karşı Bir bağlantı eklemekBir arasına seçilen Çeşidi Dikey/ 'sıra'Bileşeni ve Yatay/ 'sütun'Matriks bileşeni bir yerde' X 'zaten yok(a gösterilen özellik değeri veya - Yukarıdaki nota bakınız)Çift hücreyi tıklatın. Bir 'X' görünmelidir (Bir özellik değeri veya - Yukarıdaki nota bakınız) ve bir bağlantı seçilen Mimarlık Bağlantıları koleksiyonun en üst düzeyde oluşturulur.

Not

Bağlantı adı olacaktır Bağlantı türü adı Bunun yerine özelliği için bir 'X' varsayılan değeri vizyonda olan bir özellik değeri matris bağlantı türü ayarı başına ve sanki gösterilir.

2. Karşı Bir gösterilen özellik değerini düzenlemekarasındaki bağlantı a Dikey/ 'sıra'Bileşeni ve Yatay/ 'sütunMatris 'bileşeniÇift hücreyi tıklatın veya hücreyi sağ tıklatın ve Değeri Düzenle seçeneğini ... ve Değişim Değeri iletişim değeri düzenleyin.

3. Karşı bir bağlantıyı kaldırmakBir arasına seçilen Çeşidi Dikey/ 'sıra'Bileşeni ve Yatay/ 'sütunX 'zaten var' an matris bileşeni '(a gösterilen özellik değeri veya - Yukarıdaki nota bakınız), sağ-hücreyi tıklayınbasıp kes. X kaybolur ve bağlantı projeden silinecektir.

Kaydetmek / farklı kaydet aMatrix görünümü

Not

Tüm Mimar kullanıcıların Matrisler oluşturabilir iken onları ve / veya ayarları kaydetmek için kullanıcı lisans Tasarımcı eklenti yeteneği ihtiyacı var. Bu, birçok kullanıcı tarafından paylaşılan olabilir mevcut Matris yapılandırmasını 'korumak' etmektir. Ancak, Mimar Tasarımcı olmadan kullandığı add-on hala 'Farklı Kaydet' Yeni Matrix için herhangi bir yeni ayarların seçebilirsiniz. Ve elbette tüm kullanıcı lisansları 'Discard' Varolan Matrix herhangi bir değişiklik seçebilirsiniz. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer ihtiyacınız varsa Tasarımcı add-on yeteneği.Ve ne olursa olsun, Matrix verilerde yapılan tüm düzenlemeler anında depo uygulanan bu Matrix'in sadece ayarları olduğunu unutmayın.

1. Yeni sahip olduğunuzdan emin olun Matrix görünümü açıkve gerekli değişiklikleri yaptık.

2. İçinde Matrix görünümüen soldakinden araç çubuğu tıklayın Kaydet Matrixdüğmesine kaydetmek için Matrix görünümü ve herhangi bir biçimlendirme değişiklikleri.

Not

Matris görünümü araç çubuğunda bir Kaydet düğmesini yoksa o zaman Tasarımcı eklenti yok ve sadece mümkün Farklı kaydetMevcut matrisi kapatmak için gittiğinizde herhangi bir ayar, yeni bir matrise değişiklikleri.

3. Eğer MatrixIsimGörüntülenen iletişim (nedeniyle yeni bir matris olmak üzere) için bir isim girin matrisve basın tamam.

Karşı MS Excel matrisi ihracat

1. Eğer bir sahip olduğunuzdan emin olun Matrix görünümü açık.

2. Tıkla Excel'earaç çubuğu düğmesi.

3. MS Excel matrisi kaydetmek için bir dosya adı seçin. Tıklayın Kaydet.

Not

Varsayılan olarak ihraç MS Excel matris dosya adı parantez içinde Mimarlık adına göre ekli Matrix adı örneğin olacak 'Sunucular (Fiili 2014) barındırılan uygulamalar .xlsx'. Sen dosya biçimi .xlsx veya .xls olmak olup olmadığını da dahil olmak üzere, bu herhangi birini değiştirebilirsiniz.

Matrix biçimlendirmeVarsayılan olarak ihraç edilir, ancak, büyük matrislerin bu ihracat oldukça yavaş olması neden olabilir. Bu nedenle, bu Araçlar | Seçenekler ...ardından Matrixsekmesi,Eğer böylece ihracat hızlandırılması, aşağıda Matrix sekmesinde gösterildiği gibi dışa biçimlendirme miktarını azaltmak mümkün.

Matrix ihracatı seçenekleri

4. İhracat Tamamlandı iletişim kutusu görüntülenir. Tıklayın tamam.

MS Excel matrisi İhraç Edilen

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Visio sizin mimarisi doldurma | Excel sizin mimarisi doldurma


Populating Diyagramları

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Populating Diyagramları

Yorum gönder bu konuda.

ABACUS'e içinde Çizimler sadece keyfi temsilleri daha vardır. Onlar, mimari görüşlerini özelleştirilmiş biçimlendirilmiş ve özellikle anlamını göstermek için düzenlenmiştir.

Etkin bir şekilde unsurların 'plan görünümünü' vererek - bileşenler görsel diğer bileşenler içinde iç içe böylece Çizim Aracı, mimarlık hiyerarşik yapısını zorlar. Bir bileşen ya da bir bağlantı mimarisinde tanımlandıktan sonra, farklı şemalar, herhangi bir sayıda kullanılabilir. Ya birinde yapılan değişiklikler her zaman diğer yansıtılır, böylece Önemli olarak, Çizim Aracı yakın mimari modeline bağlıdır.

Aracı mimari tipleri bölümünde tanımlanan belirli bağlantı ve bileşen türleri şekilleri ilişkilendirerek çalışır. Bu dernekler diyagram tipi çiziliyor bağlı olarak değişebilir ve bu bileşenin (veya bağlantı) bir tür bağlamında bağlı olarak farklı diyagramlar farklı temsiller sahip olması mümkündür.

Bir şekil ve bileşen veya bağlantı türü arasında bir ilişki kurmak için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması .

2. ABACUS uygulamasını en üst düzeye çıkarın ve Pencere oranlarını yapılandırmak İstediğiniz kadar.

3. Seçin Şekiller sekmesi veya Konnektörler sekmesi şablonundaki penceresinde.

4. İçinde TipExplorer dalı, bir şekil veya konnektör ile ilişkilendirmek istiyorum bileşen veya bağlantı türünü bulun.

5. Ağacın seçilen tip öğeyi seçin Şekiller sekmesinden ya da Konnektörler sekmesine bitti sürükleyin, ve şekil veya konnektörü üzerine bırakınKullanmak istiyorum.

Not

Sen şu anda ilişkili unsurları gösterir Stencil penceresinde Bileşenleri veya Bağlantılar sekmesini seçerek oluşturduğunuz dernek kontrol edebilirsiniz.

Senin şemaları / kütüphaneye yeni şekiller eklemek için

1. Eğer diyagram eklemek istediğiniz şekillerle bir MS Visio diyagramı oluşturma ve MS Visio diyagramı ithal .

Bahşiş

Bu ABACUS tuval piksel büyüklüğünde ve MS Visio sadece Milimetre birimleri 1 Milimetre oranı 4 piksel piksel granularly dönüştürmek için MS Visio master şekli ne yapmak boyutu önemlidir. O, MS Visio 15 Milimetre çevirir, böylece Ayrıca, varsayılan ABACUS şekiller 60 piksel yüksekliğinde tipik. Bir tavsiye Anlamı MS Visio ana şekil boyutuolduğunu 25mm genişliğinde yüksek 15mm tarafındanBu ABACUS'e yüksek 60 piksel genişliğinde 100 piksel çevirmek gibi.

Bahşiş

Eğer sadece MS Visio Çizim Aracı paletini kullanarak usta MS Visio şeklinde 'simgesini' oluşturabileceğiniz bir şeklin sol üst köşesinde küçük bir 'simgesi' olmasını istiyorsanız (sadece basit çizgiler, daireler unutmayın ve dikdörtgenler) desteklenir ve özellikle rasterleştirilmiş / bitmap şekiller desteklenmemektedir. İsterseniz Dahası, simge olması boyutu / ölçek sabit| ABACUS'e formunuzu içinde sonra tüm unsurları, seçerek ana MS Visio şeklinde 'simge' Şeklini seçerek bir eleman grubu sağ tıklayarak yapabilirsiniz Grup, daha sonra sağ tıklayıp gruplandırılmış şekil ve Veri seçme | Veri Şekil ... Görüntülenen iletişim kutusunda Evet seçip olarak ayarlanmış Etiketi ile bir özellik ekleyerek LockScale, ayarlandığında Tipi (büyük harf 'L' ve 'S' notu) Boolean ve set değer olması DOĞRU (tüm büyük harf olduğunu unutmayın).

Bahşiş

Eğer yatay veya dikey olarak (bir 'kulvar' şekli ile tipik olduğu gibi) ölçekleme dondurulmuş şeklin bir kısmını olmasını istiyorsanız o zaman ölçekleme dondurulmuş istediğiniz usta MS Visio şekli kısmını (ler) sağ tıklayıp olabilir | ve Veri seçin Veri Şekil ... Görüntülenen iletişim kutusunda Evet seçip olarak ayarlanmış Etiketi ile bir özellik ekleyerek LockXScale veya LockYScale , ayarlandığında Tipi (büyük harf 'L' ve 'S' notu) Boolean ve set değer olması DOĞRU Sırasıyla yatay veya dikey ölçeklendirme kilitli için, (tüm büyük harf olduğunu unutmayın).

Bahşiş

Ithal yerine şekli her zaman usta MS Visio şeklin dolgu yapmak tavsiye edilir sabit bir renk kaldıktan sonra ABACUS içinde şekil boyama izin vermek için şeffaf ve daha sonra bir şeklin arka plan renk ABACUS'te içinde dahili yeteneğini kullanır. Tüm dikdörtgen plan renkli olacak gibi bu sadece dikdörtgen veya yakın dikdörtgen (örneğin yuvarlak köşeli dikdörtgen) şekiller ile çalışır.

2. İlgili diyagramı açın ve seçin Bileşenler sekmesişablonundaki penceresinde.

3. Diğer şemalara kullanılabilir yapmak istediğiniz her yeni şekil için Sağ tıkşekil seçin Şekiller Kütüphanesi ekle. Bu şablon penceresinde Şekiller sekmesinde şekil kullanılabilir hale getirir.

4. Yukarıda açıklanan adımlara göre şekiller kütüphaneden yeni şekli ile ilgili bileşen türü ilişkilendirin.

Not

Sadece basit ve "vektör tabanlı" şekiller şu anda ABACUS desteklenir, yani bitmapler desteklenmez. Ancak, bu tür Vektör Magic gibi araçlar ( www.vectormagic.com ) Kolayca MS Visio açıldı ve dolayısıyla yukarıdaki talimatlara göre ABACUS kullanılabilecek vektör tabanlı şekiller (yani SVG formatında) içine bitmap görüntüleri dönüştürmek olacak mevcuttur.

EklemeBileşenler ve Bağlantılar

Çizim Aracı yapmanıza olanak sağlar deposundan varolan bileşenleri ve bağlantıları eklemek veya Eğer bir şema çizim olarak yeni bileşenler ve bağlantılar oluşturmak. Bileşenleri ve bağlantıları diyagramlar oluşturulur gibi, aynı anda içine ilave edilir depo. Var Üç tavsiye Bir diyagram bileşenleri ekleme yollarıve üç bir diyagram bağlantıları ekleyerek yollarını tavsiye:

Bir diyagram üzerinde tamamen yeni bir bileşen veya bağlantı oluşturmak içinşablonundaki

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Seçin Bileşenler veya Bağlantılarşablonundaki penceresinde sekmesi ilgili şekiller görmek için. Sadece bu şekiller yeni model elemanları oluşturmak için de kullanılabilir.

3. Tıkla ve sürükleçizim tuval üzerine mevcut ilişkili şekillerden biri. Yeni eleman tuval üzerine ve kaşif ağacında görünür.

4. Yazmaya başlayınYeni eleman için bir isim diyalog ve önerilen eşleştirilir ve mimariye yeni bir öğe eklemek yerine seçilebilir varolan herhangi elemanları.

5. Tıklayın tamam.

6. Bir şekil var olan bir bileşen üzerine damlatıldı ise şekil gelen, o zaman ya (bu bileşenin bir alt olacak BileşenlerŞekil gelen sekme) ya da (bu bileşene bağlı olacaktır Bağlantılarsekmesi).

Not

Bu explorer kullanarak mimari hiyerarşi içinde farklı bir yerde yeni bir bileşen veya bağlantıyı ayarlamak için bazen gereklidir.

Varolan bileşeni veya bağlantıyı yerleştirmek için depo bir diyagram üzerinde

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Çizim Aracı ve Explorer pencerelerini görüntülenebilir de var olduğundan emin olun.

3. Gezgini'nde bulun bileşen veya bağlantı(eleman) Eğer diyagram eklemek istiyorum.

4. Tıkla ve sürüklediyagram üzerine seçilen eleman. Ögeyi temsil şekil tuval üzerinde görünecektir.

Not

Seçilen elemanın türü zaten bir şekli ile ilişkili ise, ilgili şekil tuval üzerinde görünecektir. Bununla birlikte, söz konusu öğe için hiçbir tanımlanmış bir ilişki varsa, varsayılan bir şekli (dikdörtgen) sürece tuval görünecektir Diyagram zorla Bakış Açıları seçenek şekli şemasına eklenmez bu durumda açıktır.

Bahşiş

Bir bileşen diyagram üzerinde zaten başka bir bileşene bağlı bir diyagram üzerinde yerleştirildiğinde aralarında bağlantı (lar) göstermek istiyorsanız, Çizim Aracı sorgular. Bileşeninin herhangi bir çocukları vardır eğer çocuklar dahil etmek istiyorsanız Ayrıca, Çizim Aracı yinelemeli şekilde, sorgular.

Karşı Dinamik konnektörü kullanılarak bir diyagram üzerinde 2 bileşenleri veya bağlı bir bileşeni arasında bir bağlantı oluşturmak

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Duraksamak Başka bir bileşene bağlanmak isteyen ve aşağıda gösterildiği gibi 2 simgeler şeklin sınır sağ üst dışında görünür göreceksiniz diyagram üzerinde bir bileşen üzerinde. Not: Üst simge Vurgulanan bileşen kaynak olmaktır bir bağlantı oluşturmak için ise, alt simge Vurgulanan bileşen lavabo olmaktır bir bağlantı oluşturmak için olduğunu.

3. Hareket İstenilen simgesinin üzerine getirin ve tıkla ve sürükleaşağıda gösterildiği gibi simge tuval üzerinde başka bir bileşen veya boş alan üzerinde iki aşmıştır.

4. Varolan bileşeni bağlanmak için tercih Eklemek...Açılır menüde et ve alt menüye gerekli göz mevcut bağlantı türleri arasından seçim eğer.

- veya -

4. Bağlı bileşeni seçti oluşturmak için Yeni...aşağıda gösterildiği gibi alt menüye gerekli browse açılır menüsünden ve eğer öğeler kullanılabilir bağlantı türleri arasından seçilecek. Yazmaya başlayınYeni eleman için bir isim diyalog ve önerilen eşleştirilir ve mimariye yeni bir öğe eklemek yerine seçilebilir varolan herhangi elemanları.

Not

Açılan menüden ve alt menüde öğelerin varlığı tarafından yönetilir kısıtlamaları Meta-modelde.Bu sadece geçerli kaynak veya bağlantı kısıtlamaları tarafından belirlenen için ... takın ve Yeni ... menü öğeleri olarak sunulacak kadar bileşen tipleri batar.

Karşı eleman seçimi iletişim kutusu yeniden açın ve bir diyagram üzerine deposundan bileşenleri veya bağlantıları mevcut yer

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Tıklayın Açık Eleman SeçimiDiyagram araç çubuğundaki düğmesini. Not: eleman seçimi iletişim kaydedilen filtrelerin son durumu ile açılacaktır.

3. Diyagram ve tıklama eklenecek istenen herhangi bir ek içerik seçin tamam. Not: Yeni içerik tuval üzerine açık alana eklenecek ve diyagram sonradan olabilir Yine ortaya koydu üzerinden Düzen ŞemasıDiyagram araç çubuğundaki düğmesini.

Ücretsiz KullanmaformŞekiller

Bu sadece estetik nedenlerle bir diyagram görsel elemanları oluşturmak için genellikle arzu edilir. Bu elemanlar bir diyagram düzenini ve görünümünü iyileştirmek yardımcı olabilir, ama onlar sıkı bir mimari öneme sahip değilsiniz. Çizim Aracı çizim esneklik sağlamak için serbest formlu şekiller kullanımına izin verir.

Bir diyagram bir serbest form şekil eklemek için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Seçin Şekiller veya Konnektörlerşablonundaki penceresinde sekmesi.

3. Tıkla ve sürükleçizim tuval üzerine mevcut şekiller veya bağlayıcı bir. Yeni eleman tuval üzerinde görünecektir - ama değilkaşif ağacında.

Not

Onlar herhangi bir bileşen veya mimari model bağlantısı ile hiçbir ilişkisi olduğu gibi serbest formlu şekiller, şekiller 'olmayan ilişkili' vardır.

Karşı içinde depo bilgileri görüntülemek serbest biçimli şekilüzerinde sbir diyagramdır

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Sağ tıkserbest biçimli şekli ve seçin Ek Açıklama | Ekran.

3. Ya görüntülemek için seçin Diyagram Adı, Şeması Açıklama, Diyagram Mülkiyet, Bakış Açısı Adı veya Mimarlık Adı.

Not

Serbest form metin otomatik olarak altta yatan deposu veri değiştikçe güncellenir.Bu şekilde bir diyagram 'title block' için oluşturulan ve daha sonra kolayca diyagramlar arasında kopyalanabilir.

Yüzer Şekilleri kullanma

Yüzer şekiller aslında bir diyagram bileşenleri temsil etmek başka bir yoludur. CEO, Pazarlama, Satış ve Kalkınma: anahtar tümen ile bir organizasyon düşünün.

Ağaç görünümü

Bu bölümler görsel katmanlı bir şekilde temsil edilebilir:

Katmanlı Görüntüle

Ya da görsel bir şaşırtma temsil edilebilir / yüzer şekilde hiyerarşisini göstermek için:

Staggered / Yüzer Görünüm

İkinci gösterimi yüzen şekil kavramını kullanır.

Kayan şekil katmanlı bir bileşeni şeklinde dönüştürmek için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Seçin bileşensenin şemada bir yüzen şekil ya da ilişkili bir şekil olarak temsil etmek istiyorum Bileşenlerşablona penceresinin sekmesi yüzen şekiller olarak tüm örneklerini istiyorum.

3. Şekli sağ tıklatın ve seçin Bileşen Float görünen bağlam menüsünden. Not elmas bağlantısı başlıYüzer bileşen (ler), ana bileşen (ler) elde edilmiştir.

4. Tıkla ve sürükleistediğiniz yere bileşeni. Zaman yüzerbileşeni mavi anahat olacak seçilir.

Katmanlı bir şekle yüzer bileşeni şekle dönüştürmek için

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Seçin bileşensenin şemada şu anda yüzer şekil veya ilişkili bir şekli olarak gösterilen ediliyor BileşenlerEğer katmanlı şekiller gibi tüm örneklerini istediğiniz şablona penceresinin sekme.

3. Tıkla ve sürüklegeri ebeveyn (ler) için yüzen bileşen (ler) (e göre elmas bağlantısı başlı). Not: Eğer bileşen (ler) dönüştürmek zaman geri modelin hiyerarşisi etkilenebilir katmanlı olmanın o zaman bunu yapmazsanız.

4. Şekil ve unselect sağ tıklayın Bileşen Float görünen bağlam menüsünden. Not elmas bağlantısı başlıKayan bileşen (ler) için ana bileşen (ler) kaybolacaktır dan.

Replikalar

Çizim Aracı yapmanıza olanak sağlar Bir yineleme olarak anılacaktır diyagram üzerinde bileşenin her ek görsel örneği ile bir diyagram birkaç kez aynı bileşeni ekleyin. Bu bileşen, buna bağlı bağlantıları çok sayıda diyagramları için kullanışlı olan ve bu diyagramlar için burada bire çok ilişki yakın bağlantılarının her kökenine birden çok yerde bileşen göstermek için tercih edilir, ya da Bir bileşenin, ilgili olduğu "çok sayıda" bileşenlerin üzerine birden çok yerde bileşen ile (yukarıda tarif edilen) değişken özelliğini kullanarak göstermek için tercih edilir.

Not

Bağlantıları otomatik olarak bir diyagram eklendiğinde Sen / eklemek değil, aynı zamanda kopyaları herhangi (her zaman) bir diyagram üzerinde bileşenin orijinal örneği için / bağlantıları ayırabilirisiniz, ancak, bileşenin ilk örneği eklenir Varsayılan olarak şemasında.

Not

Replikalar birbirleriyle birleştirilebilir sağ tıklayın ve sürükleDaha sonra seçerek Replicas BirleştirmeBununla birlikte, farklı bir bileşeni olan bir kopya birleştirme diyagram kaybolan başka yinelemede neden olur.

Not

Bir diyagram ve herhangi kopyaları üzerinde bir bileşenin orijinal örneği arasında hiçbir görsel fark yoktur. Ayrıca, diyagram ve herhangi bir kopyaları özgün bileşen için sağ tıklama menüsü ile örneğin, aynıdır Explorer'da göster(modele aka) depo Ağacı View aynı bileşene götürüyorum. Ancak, depo Ağacı Görünümü bileşeni sağ tıklayarak ve seçme Gitve kopyaları ile bir şemaya tarama daima diyagram üzerinde bileşenin 'eski' örneğine götürecektir. Genellikle bu özgün örneği akabinde Git eklenmiştir kalan kopyaları eski atlayacaktır bir yineleme ile silinen veya birleşti eğer şemaya ekledi ama orijinal örneği olacaktır.

Karşı Bir bir kopya eklemek diyagram

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Diyagram üzerinde varolan bileşeni sağ tıklayın ve seçin Yineleme oluştur.Seçilen bileşenin bir kopyası orijinal bileşenin sağında oluşturulacaktır.

- VEYA -

Bir diyagram ve basın varolan bileşenini seçin Ctrl + Cveya diyagram üzerinde varolan bileşeni sağ tıklatın ve seçin Kopya. Şimdi çoğaltma istediğiniz diyagram üzerinde konumu sağ tıklayın ve seçin Replica olarak Yapıştır. Not: Ctrl + V (veya sağ tıklayarak ve seçme Yapıştır) basılması, orijinal bileşenin bir kopyasını DEĞİL bir kopya oluşturur.

- VEYA -

Tıkla ve sürüklebileşeni zaten var olan bir diyagram üzerine depo (aka modeli) Tree adlı bir bileşeni.

Bağlantı Caps / Ends Yapılandırılması

Çizim Aracı yapmanıza olanak sağlar bağlantı kendisi bir özellik bağımlı sabit sembol veya sembole bağlantı hatlarının her iki ucunda kullanılan sembol ayarlamak.Bu bağlantı yönü gösterilir gereken ya da bir bağlantı (veya yön) kardinalitesi bağlantısı üzerine, örneğin bir özelliği içerdiği diyagramları için diyagramlardan için özellikle yararlıdır 'Tek-çok' çok-Birçok 'vs (ya da' Kaynak için Sink 'vs' Kaynak Sink için ').

Karşı / sona erer bağlantı kapakları yapılandırmak bir diyagramdır

1. Eğer yeni veya mevcut olduğundan emin olun Açık şeması.

2. Seçin Bağlamakiyonlarışablonundaki penceresinde sekmesi.

3. Sağ-cyalamak Biri bağlantı türlerini ilişkili seçin Caps yapılandır ....

4. Bağlantının sonuna lavabo ya kaynağında sabit bir bağlantı kapağı / ucu için veya ilgili emin olun Sabit radyo düğmesi seçili ve sonra, örneğin aşağı çekme bağlantı ucu sembol seçmek olduğunu 'Ok Başkanı' veya 'elmas'.

- VEYA -

Bağlantının sonuna lavabo ya kaynağında bir özellik tabanlı bağlantı kapağı / ucu için veya ilgili emin olun İşletmeye kullanmaradyo düğmesi seçildiğinde, daha sonra '...' düğmesine tıklayın ve gerekli özelliği seçin ve ardından sonraki her bağlantı ucu sembolü özgü bağlantı sembolü gösterilecek olan için özellik değerlerini girin.

Not

Belirli bir bağlantı ucu sembolü için Çoklu özellik değerleri virgülle ayırarak girilen edilebilir.Örneğin | Aşağıdaki iletişim kutusu 'Veri eğer gösteriyor Önem düzeyi One-çok 'daha sonra bağlantının kaynak sonu iki satır içinden darbeleri ve bağlantı lavabo ucu içinden bir satır inme olacak ve olacak' özelliği bir değere sahiptir 'iki sonra fan-out hat ucundaki okşar.

Yapılandırma iletişim kutusunu Caps

Ayrıca bakınız

Çizim Aracı | Senin mimarisi doldurma | Analiz senin mimari


Senin mimarisi doldurma

Navigasyon: Mimarinizi doldurma>

Senin mimarisi doldurma

Yorum gönder bu konuda.

Senin mimari model inşa süreci olarak bilinir populating. Eğer mimarisi keşfedilen ve ihtiyaçlarınızı tespit ettik sonra, ABACUS'te içinde mimari model hazırız.

Nüfusun sırasında size mimarisi ve ne ondan gerekli oluyor hakkında bilmek tüm ayrıntıları girersiniz.

Mimarinizi doldurmak için

1. Bir olduğundan emin olun ABACUS dosya açma Bir kaşif Görüntülenen Ve bir mimari eklendi .

2. Elle doldurmak yüksek seviyeli bileşenleri ve mimari bağlantıları. Genelde bu daha soyut bileşenler ve bağlantılar olacak.

- veya -

2. Grafiksel doldurmak Eğer istediğiniz bileşenleri ve bağlantıları kullanarak şematik temsil görmek Çizim Aracı .

Ayrıca isteyebilirsiniz

3. Kataloglar kullanarak doldurun - Görüntüleyebilir ve komponentler ve Basit bir tablo bir şekilde bağlantıları.

4. Matris kullanarak doldurun - Görüntüleyebilir ve basit bir tablo bir şekilde bileşenler arasındaki bağlantıları düzenleyebilirsiniz.

5. Microsoft Access gelen doldurma - Eğer bir mimari alabilirsiniz ve ihracat Microsoft Access.

6. Microsoft Visio doldurma - Eğer bir mimari alabilirsiniz ve ihracat Microsoft Visio.

7. Microsoft Excel doldurma - Eğer bir mimari alabilirsiniz ve ihracat Microsoft Excel.

8. Microsoft SharePoint doldurma - Eğer bir mimari alabilirsiniz ve ihracat Microsoft SQL Server.

9. Microsoft SQL Server doldurma - Microsoft SQL Server bir mimari alabilirsiniz.

10. XML içe - Bir ABACUS XML fragmanı veya ArchiMate Değişim Dil XML dosyasından bir mimari alabilirsiniz.

Ayrıca bakınız

El mimarisi doldurma | Çizim Aracı | Microsoft Access sizin mimarisi doldurma | Microsoft Visio sizin mimarisi doldurma | Microsoft Excel sizin mimarisi doldurma


Microsoft Access sizin mimarisi doldurma

Navigasyon:> Mimarinizi doldurma Microsoft ürünleri doldurmamak>

Microsoft Access sizin mimarisi doldurma

Yorum gönder bu konuda.

Sen mimarisine genel amaçlı hesaplamalar, manipülasyonlar ve raporlar gerçekleştirmek için Microsoft Access için mimari verebilirsiniz. Daha sonra ABACUS'e geri mimariyi alabilirsiniz.

Not

Açık Erişim / İhracat gelen Veritabanına özellik gerektirir Microsoft Access 2000ya da daha yeni bilgisayara yüklenir.

Microsoft Access için mimari vermek için

1. Bir olduğundan emin olun ABACUS dosyası aç Kâşifgörüntülenir, ve mimariilave edildi.

2. Dosya Seçin | İhracat | Veritabanına.

3. Yukarıda açıklandığı gibi uyarı diyaloğunun not alın ve devam etmek için Evet'i tıklatın.

4. Veritabanı dosyası için bir konum ve dosya adı seçin.

ABACUS'e içine manipüle mimariyi almak için

1. Eğer ABACUS; açık olduğundan emin olun.

2. Dosya Seçin | Yeni basıp Accessbelirir ve Tamam'a tıklayın iletişim kutusundan.

3. Almak istediğiniz veritabanı dosyası için göz atın.

ABACUS 'MS Access Veritabanı Şeması

ABACUS kalbi a at varn ontoloji / Bileşenleri, Bağlantıları ve Kısıtlar oluşan meta-meta-modeli. Bu "CCC" yaklaşımı 1960 itibaren Avolution kurucuları katkıda uluslararası standart IEEE 1471, sonuçlanan geliştirilmiş çeşitli standart yaklaşımlardan elde edildi. Aşağıdaki ilkel geçerlidir;

1. ABAKÜS içeren Kütüphanelerarasında Standartlar(ya da Standartları), Bileşen ve Bağlantı Tipleri, Kısıtlamalar, Bakış Açıları, Şablonlar (veya Desenler) ve birçoğu Mimarileri.

2. Standartlar, Türleri ve Bakış Açıları Mayısmantıksal olmak Gruplandırılmışkolaylık için.

3. Mimarileri içerebilirBirçok soyundan Mimarileri(veya Gelişmeler).

4. Her Mimarlık içerenbirçoğu Bileşenler ve BağlantılarBelirli Türlerive çeşitli Görünümler.

5. Bileşenler ve Bağlantılar olabilir çürümüşiçine Alt Bileşenleri ve Alt Bağlantılar.

6. Her Bileşenolduğunu bağlanmışherhangi bir sayıda Bağlantılarancak her Bağlantısadece olabilir bağlanmışen fazla iki tanesi Bileşenler.

7. Bileşenler ve Bağlantılarkutu var Standartlar ile Özelliklergibi bilgiler, Performans, Güvenilirlik, Maliyet vb

8. Mimarileri, Bileşenler ve Bağlantılarkutu varbelirli Özelliklergibi bilgiler, Performans, Güvenilirlik, Maliyet vb

9. Kısıtlamalarkutu arasında mevcut olan Bileşenler veya Bağlantılar veya karşı Özellikler.

10. ŞablonlarStandart bileşimlerdir Bileşen ve Bağlantı Tipleri.

11. Bakış AçılarıStandart dernekleri Bileşen ve Bağlantı Tiplerigösterimler için.

12. Görünümlergörsel temsilleri Bileşenler ve Bağlantılar.

Aşağıdaki MS Access Varlık İlişki Diyagramı (ERD) belgelemektedir çekirdekMimariler, Evrim, Bileşen / Bağlantı Türleri (ve Gruplar), Bileşenleri / Bağlantılar ve Alt Bileşen / Bağlantı kavramları.

Çekirdek veritabanı şeması

Not

Tutarlılığını (belirli bir kaynağı veya Lavabo Bileşeni ve bir bağlantı arasındaki 'eki' için) Bileşenler masa ve Bağlantılar tablo arasındaki ilişki üzerine yürürlüğe olmamıştır. Bir bağlantı bileşeni ekler olmadan var olmasıdır. Biz bir 'eki' tablo ekledim ancak basitlik çıkarları buna karşı karar vermiş olabilir. Tabii ki bu Bileşen kimlikleri ya da hep birlikte Bileşen satır silme herhangi düzenleme yanlış veri neden olacağı anlamına gelir. ABACUS hatalı veri görmezden ithalat üzerinde herhangi yanlışlığını idare edecektir.

Aşağıdaki MS Access ERD belgeliyor ÖzelliklerMimarileri için kavramlar, Komponent / Bağlantı Tipleri ve Bileşenleri / Bağlantılar.

Özellikler veritabanı şeması

Aşağıdaki MS Access ERD belgeliyor StandartlarMimarileri için kavram, Komponent / Bağlantı Tipleri ve Bileşenleri / Bağlantılar.Not: tabloları hala ABACUS önceki sürümleri başına terimini 'Uygulaması kullanabilirsiniz.

Standartlar veritabanı şeması

Aşağıdaki MS Access ERD belgeliyor KısıtlamalarKomponent / Bağlantı Türleri kavramı.

Kısıtlamalarveritabanı şeması

Aşağıdaki MS Access ERD belgeliyor Bakış Açıları için kavram Mimarileri.Not: tabloları hala ABACUS önceki sürümleri başına terimini 'TwoDTempl kullanabilirsiniz.

Bakış Açılarıveritabanı şeması

Aşağıdaki MS Access ERD belgeliyor Kataloglariçin kavram Mimarileri.

Kataloglarveritabanı şeması

Aşağıdaki MS Access ERD belgeliyor Matrisleriçin kavram Mimarileri.

Matrislerveritabanı şeması

Aşağıdaki MS Access ERD belgeliyor Diyagramlarıiçin kavram Mimarileri.Not: tabloları hala ABACUS önceki sürümleri başına terimini 'TwoD kullanabilirsiniz.

Not

Bileşen / Bağlantı Türü şekli haritalama ve MS Access ERD Serbest şekil bölümlerini Stencil için açıklık için atlanmış edilmiştir.

Diyagramlarıveritabanı şeması

Aşağıdaki MS Access ERD belgeliyor 3D Görüntülemeiçin kavram Mimarileri.

3D Görüntülemeveritabanı şeması

Aşağıdaki MS Access ERD belgeliyor Grafikleriçin kavram Mimarileri.

Grafiklerveritabanı şeması

Aşağıdaki MS Access ERD belgeliyor Panolarkavram.

Panolarveritabanı şeması

ABACUS 'MS AccessSorgular

Aşağıdaki gibi birçok yararlı sorguları MS Access veritabanı ile dahildir;

· Dikmeler tarafından kompozisyonları- Bu sorgu (mimarlık ve türüne göre) projedeki tüm bileşenleri listeler ve sütunlar gibi tüm özellikleri içerir. Kendi özellikleri ile her bileşen türü için 'tipik' tabloları üretmek için bileşen türü ve / veya mimarisinde filtreleri / kriterleri ile bu sorguyu kullanın.

· Dikmeler CYBH'a- Bu sorgu kullanımda olan tüm standartları, standart oluşum sayısını listeler ve sütunlar gibi tüm özellikleri içerir. Standartlar katalog olarak bu sorguyu kullanın.

· Türlerine Göre Dikmeler- Bu sorgu sütun olarak her bir bileşen türüne göre tam tüm bileşen özelliklerini ve bunların% listeler. Belirli özellikler muhafaza ediliyor olmadığını belirlemek için bu sorguyu kullanın.

· Dikmeler tarafından Çeşitleri- Bu sorgu tüm bileşen türlerini listeler ve sütunlar gibi tüm özelliklerin tam% kapsamaktadır. Belirli özellikler muhafaza ediliyor olmadığını belirlemek için bu sorguyu kullanın.

· Tür Sayımı- Bu sorgu tüm bileşen türlerini listeler ve azalan her tür olayların sayısını içerir. Projede her tür popülerlik belirlemek için bu sorguyu kullanın.

MS Access Not alanları ile çalışma hakkında bir not

Tablolarda Bileşenleri, Bağlantılar ve Standartlar Adı alanları ABACUS'te gereğince, karakter sınırsız sayıda için izin vermek için not alanları olarak tanımlanır. Onlar da referans için benzersiz bir kimlik alanı var çünkü Bileşenleri ve Bağlantıları bu bazı sorunlar neden olur, ancak MS Access not alanları katılamaz çünkü tabloları birleştirmek çalışırken Standartlar bu bir kaç sorunlara neden olmaktadır. Visual Query Builder gösterilen ve bu listenin altındaki SQL parçacıkları dışarı karşılık Alternatif olarak, aynı etkiyi elde etmek için bir yerde fıkra kriterleri ayarlayabilirsiniz tüm kalıtsal Standartlar ihraç ABACUS Projedeki tüm bileşenleri özellikleri.

Not alanı Visual Query Builder 'katıldı'

Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit SEÇ

Bileşenler INNER DAN ComponentImplementationLinks ON JOIN (Components.InternalId = ComponentImplementationLinks.Id) AND (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Uygulamalar İÇ Implementations.Id = ImplementationProperties.Implementation_Id AÇIK ImplementationProperties KATILIN

NEREDE (((ComponentImplementationLinks.Name) = [Uygulamaları] [İsim]).);

Not alanı SQL 'katıldı'

Otomatik MS Access ABACUS kimlikleri üreten Üzerine Bir Not

Basit bir VB yöntemi, bu üretimine yardımcı olmak için temin edilmiştir, böylece çeşitli ABACUS'ün MS Access tabloları, benzersiz bir uzun tamsayı ID'sinin bulunmasını gerektirmektedir. Iki yöntem ResetCounter () ve GetNextCounter () ABACUS 'MS Access DB içinde sağlanan ve aşağıdaki gibi bunların kullanımı vardır; ResetCounter () sırayla sonraki sayacı dönecektir geri 0. GetNextCounter (kadar) sayaç koyacaktır.

ResetCounter () işlevi sadece çalışan herhangi bir parametre olmadığından yöntemleri (ayrıca GetNextCounter () işlevini çalıştırdığınızda yani) her satır ekleme için ResetCounter () yöntemini çağırın bile MS Access 'cilvesi' istismar bir kez ve bu nedenle her satır ekleme için sayacını sıfırlamak değil. Ve aynı zamanda, çünkü aynı 'cilvesi' size her zaman çalışan içine aptal GetNextCounter () işlevine herhangi bir eski sütun değişkeni geçmek zorunda.

Eğer sadece kendi başına bir sütun olarak orada oturan var olamaz çünkü bir seçme sorgusu ise gibi, SQL deyimi içine insert olarak ResetCounter () işlevi çalıştırmak için güçlü olmak için bir hile vardır. O zaman zaten null döndürür olarak, sonuna kadar birleştirerek, diğer alanlarda birinin ResetCounter () çağrısı parçası yapmak için tavsiye edilir.

Aşağıda 'Bileşen Tipi Listesi' adlı bir tablo / sorgu Bileşen türleri listesi eklemek için çeşitli yöntemler tipik bir SQL kullanımıdır.

TAKINComponentTypes (id, Ad, Açıklama)

SEÇ GetNextCounter ([Bileşen Tipi Liste] .name)Id AS, İsim AS [Bileşen Tipi Liste] .name, [Bileşeni Türünü Liste] .Description & ResetCounter ()Açıklama AS

DAN[Komponent Tipi Liste];

SQL ABACUS ID / Sayaç nesil

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Visio sizin mimarisi doldurma | Excel sizin mimarisi doldurma


Microsoft Excel sizin mimarisi doldurma

Navigasyon:> Mimarinizi doldurma Microsoft ürünleri doldurmamak>

Microsoft Excel sizin mimarisi doldurma

Yorum gönder bu konuda.

Sen bir Excel sizin mimarisi alabilirsiniz (.xls veya .xlsx dosya). Excel ithalatçı alakalı verileri içeren tablonuzda sütunları seçerek türleri, standartları, özellikleri ve standart özelliklere sahip bileşenin listeleri ve bağlantıları haritası sağlar.Ancak daha gelişmiş bir tekniktir Önerilen yaklaşımaracılığıyla MS Excel ithal için kataloglar açıklandığı şekilde İşte .

Not

İthalat / İhracat Excel'e özellik gerektirir Microsoft Excel 2003ya da daha yeni bilgisayara yüklenir.

Excel İthalatçı ana fonksiyonu (mimari model hiyerarşik yapıya yani) bir yapılandırma dosyası tanımlamak için izin vermektir. Bir Excel yapılandırma dosyası saklar önceden kaydedilmiş bir eşleme bir ABACUS dosyasına kopyalayın. Tanımlandıktan sonra, kaydedilen yapılandırma dosyası, daha sonra daha fazla ithal kullanılan ve .xls dosyaları ihraç etmektedir.

Not

Aşağıdaki bölümlerde gösterilen adımlar tanımlamak ve bir yapılandırma dosyasını kaydetmek için henüz ilk kez excel ithal ediyoruz kullanıcılar için özel olarak bulunmaktadır. Oluşturabilir ve işlevi excel ihracat kullanmak için bir yapılandırma dosyasını kaydetmek gerekir.

ABACUS'e içine Excel almak için

1. Eğer ABACUS; açık olduğundan emin olun.

2. Dosya Seçin | Yeni ve Dan seçin Excelbelirir ve Tamam'a tıklayın iletişim kutusundan.

Not

Eğer varolan bir ABACUS projeye aktarmak isterseniz ya bir Mimarisi içinde Bileşenleri düğümünü sağ tıklatın veya Al'ı seçin sonra Mimarlık içindeki bireysel bileşeni sağ tıklatın ve | Excel.

3. İthalat Excel elektronik tablopenceresi görüntülenir

İthalat Excel Elektronik Penceresi

4. Tıkla Açık Excel dosyasimgesini ve Excel almak istediğiniz dosya için göz atın.

5. Seç ÇalışmaAçılır kutudan ithal etmek istiyoruz.

Not

Excel dosyasını açtıktan sonra, kullanabilirsiniz Veri ÖnizlemeSekme sütun ve tablonuzun ilk 25 satırları görüntülemek için kullanılır. Buradan doldurmak için gerekli sütun numaralarını elde edebilirsiniz Bileşenler ve Bağlantılarsekmesi.

Ayrıca bir excel elektronik tablodaki bileşenlerin küçük harf duyarlılığı ile ithal edilecek isteyip istemediğinizi seçebilirsiniz. Sadece kene Küçük harf duyarlılığı ile İthalatseçeneği (varsayılan olarak bu her zaman işaretli) ve elektronik tablo buna göre ithal edilecek.

Örnek Excel dosya

Not

Bu örnekte yukarıdaki ekran gösterilen excel verileri basit bir Altyapının ve İnsanlar Mimarlık ithal edecek. Bağlantılar "Sorumlu İnsanlar" ve "Sunucular" bu insanların yönetmek arasındaki yapılacaktır.

Bileşenler sekmesini doldurmak için

Bu bölüm yapılandırma dosyası için bileşen türleri ve hiyerarşik yapısını tanımlamak içindir.

1. Seçin Bileşenlersekmesi. Rename Set IDgeçersiz kılarak (boş)değer

Not

Bu özellik, tamamen farklı tanımlamanızı sağlar Setlerişlevsel ayrı bileşenler için. Aşağıdaki ekran görüntüsünde de görüldüğü gibi, sizin İnsanlar bileşenleri sizin Altyapı bileşenlerini ayırt etmek isteyebilirsiniz. Bileşenlerin bu ayrı kümeler arasındaki ilişkileri (bağlantıları) vardır, bunlar altında tanımlanabilir Bağlantılarsekmesi. Daha sonra bu örnekte biz Altyapı ve İnsanlar arasındaki türü "idare" nin bağlantılarını tanımlayacak Setler.

Ayrıca bir üst düzey eklemek isteyip istemediğinizi seçebilirsiniz Gruplamakümesinin tüm elemanları için bileşen. Sadece kene Grup Altında Seti Kimliğiseçeneği (varsayılan olarak bu unticked) ve elektronik tablo buna göre ithal edilecek.

Set ID atama

2. Bir kere Setlertanımlanmıştır seçin SetEğer doldurmak ve tıklayarak genişletmek istiyorum [+]imzalamak.

3. Seçin Bu Set Bileşenleri Düzeylerigenişletilmiş listeden.

4. Bileşen Hiyerarşi Setleri: Set IDpencere görünecektir Set.

Bileşen Hiyerarşi ve Atama Değerler (Set ID: Altyapı)

5. Rename Seviye Sayısıgeçersiz sütun (boş)değer.

Not

Seviye Sayısısütunu bileşenlerine bir hiyerarşi atamanızı sağlar. Birinci düzey en üst sayede Her seviye için mimarisi içinde bir tabaka karşılık ebeveynseviyesi. Örneğin, Seviye Sayı "1" en üstteki hiyerarşik katmana karşılık, Seviye Sayısı "2" Seviye Sayısı "1" ve benzeri çocuğudur.

6. Seçin ve her Excel elektronik alakalı sütun atamak Seviye Sayısıaltında girerek Bileşen SütunSütun.

Not

Eğer mimarisi temsil edilmek istemiyorum bazı satırları hariç seçebilirsiniz. Bu satırlar kullanmak dışlamak için vb sütun başlıkları, boş satırlar olabilir Satırlar dışla için:Pencerenin sağ üst köşesine yakın metin kutusu. Bu örnekte biz o bizim sütun başlıkları içerdiğinden satır 1 dışlamıştır.

7. Sen üzerine yazarak bileşenleri açıklamalar eklemek için seçebilirsiniz (boş)değeri Açıklama Sütun.

Not

Bu açıklama altında ABACUS görünecektir budur Genel Özelliklerbölüm | Açıklamaalan.

8. Belirli bir elektronik tablo sütun hücre başına birden fazla bileşen varsa o zaman altında onay kutusunu işaretleyin (Alt-Enter veya CHAR (10) komutu kullanılarak girilir) Ayrı Bileşenleri Olarak Yeni Hatları davranın. Her satır ayrı bileşenler olarak ithal edilecektir.

Bahşiş

Belirli bir 'matrix' hücrede bir 'X' (hücre B2: D2 demek) sütun bir koleksiyon, bir 'matris' almak için satırın tarafından belirtilen bileşen (A2 hücresindeki demek) anlamına gelir bileşene bağlı olduğu (satır 1 söz sahibi olarak) sütununda 'başlığı' tarafından belirtilen, basit bir formül kullanılabilir. Matriks hücrelerinden ötesinde bir sütunda her satır için aşağıdaki formülü girin (F sütunu demek); = EĞER (B2 = "", "", B $ 1 & CHAR (10)) ve IF (C2 = "", "", C $ 1 & CHAR (10)) ve (IF D2 = "", "", D 1 $ ve CHAR (10)). Sonra satırda tarafından belirtilen bileşenler arasında aşağıda (A sütununda demek) tanımlanmış ve bu formül ile tarif edilen (sütun F demek) olarak ayarlanmış bir bağlantı kurmak. Kontrol ettiğinizden emin olun Ayrı Bileşenleri Olarak Yeni Hatları davranınformül bileşenleri ithal seçenek. Sadece düz bir 'X' den farklı değerlerle birden hiyerarşi katmanları veya hücreleri ile başlıklar da dahil olmak üzere daha gelişmiş matris ithalat için, lütfen Avolution Destek .

9. Gerektiği gibi sütunların kalanı doldurun.

Not

Sen altında onay kutusunu işaretleyerek sütun sıralarındaki türü almak için seçebilirsiniz Sütun itibaren Tipi AlınKolon ve altında Excel elektronik alakalı sütun giren Bileşen Tip Değer veya SütunSütun. Bu o sütundaki tüm bileşenleri almak ve sütunda tanımlanan türüne bunları koyacaktır. Alternatif olarak, yukarıda ve aşağıda ekran resminde olduğu gibi, altında türü adını girerek sabit / ön tanımlı türü adını kullanmayı tercih edebilirsiniz Bileşen Tip Değer veya SütunKolon ve yapım emin olun onay kutusunun un-kontrol edilir.

Bileşen Hiyerarşi ve Atama Değerler (Set ID: People)

Not

Bu örnekte Mimarlık seviye 1 bizim ağlar ve insanların gruplaşmalar için başvuruyorum. 2 düzeyinde biz bu sunucuları idaresinden sorumlu bizim sunucuları ve insanları için başvuruyorum. BileşenlerYukarıdaki iki ekran gösterildiği gibi sekme, buna göre dolu olmuştur. İlk ekran biz Altyapı için seviye 1 (ağ gruplandırma) ve seviye 2 (sunucu) bileşenleri tanımlanmış yukarıda Set. Ve ekran biz insanlar için seviye 1 (gruplama insanları) ve seviye 2 (insanlar sorumlu) bileşenleri tanımladık hemen üstünde Set.

Buna alternatif olarak, İnsanlarSet, oldukça Kişi gruplaşma olarak C sütunu kullanmak yerine, biz kullanmış olabilir Grup Altında Seti Kimliğiüst düzey bileşenleri sekmesinde seçeneği ve sonra sadece bu aşağıdaki ekran gösterilir Sütun D. biri İnsanlar alt düzey girdi.

Bileşen Hiyerarşi ve Grup Altında Seti Kimliği seçeneğini kullanarak Değerleri Atama (Set ID: People)

10. Bileşenleri tespit edildikten sonra, özelliklerini ve / veya standartlarını doldurmak ve tıklayarak genişletmek istediğiniz bileşen düzeyini seçin [+]imzalamak.

11. Seçin Bu Düzeyinde Bileşenleri Özellikleri veya Bu Düzeyinde Bileşen Standartlarıgerektiği gibi ve genişletilmiş listeden ilgili sütunları doldurmak.

Doldurmamak Bileşenleri

Not

Bu Düzeyinde Bileşenleri Özellikleriseçtiğiniz düzeydeki bileşenlerin özelliklerini tanımlamanızı sağlar. Bu Düzeyinde Bileşen Standartlarıseçtiğiniz düzeyde bileşenler için standartları ve standart özelliklerini tanımlamak için izin verir.

12. Adımları tekrarlayın 2-11Tüm bileşen seviyeleri tanımlanmış için doldurulan kadar Setler. Geri gitmek için pencerenin sağ üst köşesine yakın geri okunu kullanın Setlerhangi daha önce tanımlandığı.

Bağlantılar sekmesini doldurmak için

Bu bölüm yapılandırma dosyası için bağlantı türleri ve hiyerarşik yapısını tanımlamak içindir.

1. Seçin Bağlantılarsekmesi. Bağlantıların her set için bileşeni tanımlamak zorunda Setkaynak bileşenleri ve bileşen olmasını istediğiniz SetHedef bileşenleri olmak istiyorum.

2. Altına Kaynak Bileşen Seti Kimliği giriş Setkarşılık gelen isim SetDaha önce de tanımlandığı Bileşenlersekmesi. Altına Kaynak Bileşeni Seviye SayısıEğer bağlantı kaynağı sonunda bağlamak istediğiniz bileşen düzeyinde karşılık numarasını girin.

3. Şimdi bağlantının hedef sonunda olacak hangi bileşenin grubu seçin. Altına Hedef Bileşen Seti Kimliği giriş Setkarşılık gelen isim Settanımlanmış Bileşenlersekmesi. Altına Hedef Bileşen Seviye SayısıEğer bağlantının hedef sonunda bağlamak istediğiniz bileşen düzeyinde karşılık numarasını girin.

Not

Bu örnekte biz onlar yönetmek sunuculara sunucuları yönetmekten sorumlu insanları bağlamak istiyoruz. Sorumlu insanlar İnsanlar tanımlanan Setdüzeyi sunucuların ederken 2 bileşenleri Altyapı tanımlanan Setdüzeyi olarak 2 parça. BağlantılarAşağıdaki ekran görüntüsünde görüldüğü gibi sekme, buna göre dolu olmuştur.

Bağlantılar Sekmesi Part 1 2

4. Eğer sağa kaydırma, size bağlantıları ithalatı için ekstra seçenekler bulacaksınız. Sütun itibaren Tipi Alın ve Bağlantı Türü Değeri veya Sütunaynı şekilde çalışır Bileşenlersekmesi.

5. Eğer Kaynak Bileşen Seti Kimliği ve Kaynak Bileşeni Seviye Sayısıaynıdır Hedef Bileşen Seti Kimliği ve Hedef Bileşen Seviye Sayısısonra tekrarlanan bu sunucuların adlarını içeren e-tablonuzda başka bir sütun olması gerekir (örneğin bu tür diğer sunuculara sunuculardan bağlantıları yapma gibi, aynı bileşen tipleri bağlıyorsanız). Bu durumda size o elektronik tablo sütunu vereceğini Hedef sütununda TekrarlananSütun. Bu tablo sütununda size hücre başına birden fazla bağlı bileşen girdiyseniz sonra altındaki kutuyu işaretleyin Ayrı Bileşenleri Olarak Yeni Hatları davranın.

Bağlantılar Sekmesi Part 2 2

6. Bağlantıları bağlantıyı seçin belirlendikten sonra size özelliklerini ve / veya standartlarını doldurmak ve tıklayarak genişletmek istiyorum [+]imzalamak.

7. Seçin Bu Bağlantıların Özellikleri veya Bu Bağlantıların için Standartlargerektiği gibi ve genişletilmiş listeden ilgili sütunları doldurmak.

Not

Bu Bağlantıların ÖzellikleriSeçtiğiniz bağlantı grubunun özelliklerini tanımlamanızı sağlar. Bu Bağlantıların StandartlarıSeçtiğiniz bağlantı grubu için standartlar ve standart özelliklerini tanımlamak için izin verir.

8. Adımları tekrarlayın 2-7tüm bağlantı grupları tanımlanmıştır kadar.

9. Bağlantı grupları tanımlayan tamamladığınızda, tıklayın Finishdüğme ve mimari ithal Excel dosyasından oluşturulacaktır. Yukarıdaki örnek aşağıdaki ekran gösterilen mimaride neden olacaktır.

Örnek Mimarlık Excel ithal

10. Şimdi tıklayarak bir dosyaya eşlenen yapılandırmayı kaydetmek Kaydet Yapılandırmasimge. Kaydedilen yapılandırma tıklayarak daha sonra alınabilir Bir Yapılandırma açPencerenin sol üst köşesine yakın simgesine.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Access sizin mimarisi doldurma | Visio sizin mimarisi doldurma


Microsoft SharePoint sizin mimarisi doldurma

Navigasyon:> Mimarinizi doldurma Microsoft ürünleri doldurmamak>

Microsoft SharePoint sizin mimarisi doldurma

Yorum gönder bu konuda.

Yapabilirsin senkronize etmek senin mimari ileMicrosoft SharePoint listeleri. Senkronizasyon ya ABACUS tipleri, özellikleri ve ekleri yeni SharePoint listeleri (ve onların sütunlar) oluştururken, ya da ABACUS türlerine varolan SharePoint listeleri haritalama (ve onların sütunlar), özellikleri ve ekleri, sonra da SharePoint veya SharePoint ABACUS içerik gönderme içerir ABACUS'e için.

Not

SharePoint Sync özelliği olmasını gerektirirbir Microsoft SharePoint 2010, 2013 veya SharePoint Online sitesi bağlanmak ve senkronize kullanılabilir.SharePoint Sync özelliği herhangi ABACUS projesinden SharePoint sitesinde (sütunlu) listeleri oluşturabilirsiniz ederken, Avolution de çok irtibata geçiniz standart çerçevelerin desteği (örneğin TOGAF, ArchiMate, ITIL vb) çeşitli SharePoint sitesi şablonları sağlayabilir Avolution Destek Bu yeteneği gerektiriyorsa.

Karşı yeni bir SharePoint listesi oluşturmak ve bir ABACUS bileşen veya bağlantı türüne eşlemek

1. Eğer ABACUS; açık olduğundan emin olun.

2. Seçin Araçlar | SharePoint Sync.

3. Tıkla Yeni Haritalamadüğmesi görünecektir aşağıda gösterildiği gibi bir SharePoint Eşleme iletişim.

4. SharePoint sitesine Site URL Kullanıcı adı ve Şifre girin Bağlamak.

Not

Geçerli bir SharePoint 'admin' veya 'iştirakçinin' hesap sadece SharePoint'ten senkron sağlayacaktır gelen ve SharePoint ve 'okuyucunun' hesabına eşitlemek için gereklidir.

5. Dan eşlemek için ABACUS bileşen veya bağlantı türünü seçin Seçin Türü aşağı çek.

6. Tıkla Yeni ekledüğmesine basın ve ardından sol paneldeki bir öğeyi seçin ve sağ panelde Yeni Liste sütununda (sadece ilk kez) Yeni SharePoint listesi adı girin karşılık gelen bir SharePoint listesi alanına eşlemek istediğiniz her ABACUS bileşen veya bağlantı türü yönü için sonra SharePoint sütun Sütun Adı adını (veya varsayılan kullanın) ve tıklayın AtamakHer zaman.

Not

Senkronizasyon ABACUS EEID, Mimarlık ve Adı yönleri otomatik olarak SharePoint sayısı ve metin (aka Metin), sırasıyla sütun iki (2) Tek hat eşleştirilir izin Asgari olarak. Bunlar atanmamış olamaz. Ayrıca, yalnızca belirli ABACUS yönlerini şu anda belli SharePoint sütunları eşlenebilir ve Kolon Tipi açılan otomatik olarak gerekli SharePoint sütun türüne ayarlanmış olacak.Yani;

· SharePoint Çoklu Metin satırları (aka Not) sütunlar Abacus 'Hiyerarşi Yolu (Not: Metnin SharePoint Tek hat (onlar tercih değildir bu yüzden aka Metin) sütunlar yalnızca 255 karakter desteği),

· SharePoint Arama sütunları Abacus 'Ekli Bileşenleri (Not: Bir eşleme zaten ekli bileşenleri kendileri için bir liste mevcut olmalıdır),

· : (Metin SharePoint Tek hattı (onlar tercih değildir bu yüzden aka Metin) sütunlar yalnızca 255 karakter destekleyen Not) ABACUS 'Metin ve Açıklama özelliklerini birden fazla metin satırları (aka Not) sütunlar SharePoint

· SharePoint Sayı sütunları Abacus 'Ondalık veya tamsayı özellikleri,

· SharePoint Seçimi kolonlara ABACUS 'Liste özellikleri (Not: Liste veri türü ABACUS'te yılında yürürlüğe olması gerekmez SharePoint seçim değerlerini zorunlu kılmaz),

· SharePoint Çoklu Metin satırları (aka Not) sütunlar Abacus 'Tarih / Saat Özellikleri: (Not SharePoint Tarih ve Saat sütunları nedeniyle dilimi / bölgeselleşme ayarları için SharePoint'in tutarsız desteği henüz kullanılamaz)

· SharePoint Evet / Hayır (aka Boolean) sütunlar Abacus 'Boole özellikleri.

Bir ABACUS öğesinin İlişkili Standartları henüz SharePoint listesi kolonlara eşleştirilmiş edilemez.

7. Seçin Mapping oluştur.

Karşı Bir ABACUS bileşen veya bağlantı türü ve varolan bir SharePoint listesi arasında yeni bir eşleme oluşturmak

1. Eğer ABACUS; açık olduğundan emin olun.

2. Seçin Araçlar | SharePoint Sync.

3. Tıkla Yeni Haritalamadüğmesi görünecektir aşağıda gösterildiği gibi bir SharePoint Eşleme iletişim.

4. SharePoint sitesine Site URL Kullanıcı adı ve Şifre girin Bağlamak.

Not

Geçerli bir SharePoint 'admin' veya 'iştirakçinin' hesap sadece SharePoint'ten senkron sağlayacaktır gelen ve SharePoint ve 'okuyucunun' hesabına eşitlemek için gereklidir.

5. Dan eşlemek için ABACUS bileşen veya bağlantı türünü seçin Seçin Türü aşağı çek.

6. Dan eşlemek için SharePoint site listeyi seçin Seçin Liste aşağı çek.

7. Her ABACUS bileşen veya bağlantı türü yönü için sırasıyla sol paneldeki bir öğeyi sağ panelini seçin ve tıklayın karşılık gelen SharePoint liste sütuna haritasına isteyen Atamak.

Not

Izin asgari olarak senkronizasyon ABACUS EEID, Mimarlık ve Adı yönleri SharePoint sayısı ve sonra Mimarlık ve ismi eşlenmesi gerekir ya metin (aka Metin) veya sırasıyla Çoklu metin satırları (aka Not) kolonların Tek satır. Bu Haritalama Oluştur düğmesi yapılana kadar etkin olmayacaktır. Ayrıca, yalnızca belirli ABACUS yönlerini şu anda belli SharePoint sütunları eşlenebilir.Yani;

· Metin (aka Metin) veya birden fazla metin hatları (aka Not) sütunlar bir SharePoint Tek çizgiye ABACUS 'Mimarlık boy (aşağıda tarif edildiği gibi, bu içerik belirli haritalama için gereklidir),

· Bu nedenle herhangi bir ek karakterler kesildi ve bu nedenle edilecek sütunları yalnızca 255 karakter destekleyen metin (aka Metin) SharePoint Tek hat: ABACUS 'Hiyerarşi Yol metin (aka Metin) veya birden fazla metin hatları (aka Notu) kolonların (Not Tek satır SharePoint bu haritalama önce SharePoint Çoklu metin satırları (aka Not) sütunlar) onları dönüştürmek için tavsiye edilir

· SharePoint Arama sütunları Abacus 'Ekli Bileşenleri (Not: Bir eşleme zaten ekli bileşenleri kendileri için bir liste mevcut olmalıdır),

· Bu nedenle herhangi bir ek karakterler kesilecek sütun yalnızca 255 karakter destekleyen metin (aka Metin) SharePoint Tek hat: ABACUS 'Metin ve Açıklama özelliklerini metin (aka Metin) veya birden fazla metin hatları (aka Notu) kolonların (Not Tek satır SharePoint ve bu nedenle, haritalama önce SharePoint Çoklu metin satırları (aka Not) sütunlar) onları dönüştürmek için tavsiye edilir

· ABACUS 'SharePoint sayısı sütununa Ondalık veya tamsayı özellikleri (Not:. SharePoint Hesaplanan sütunlar senkronize çalışmak ABACUS'te SharePoint senkronize etmek ancak onlar sadece mümkün olacak kullanılabilir' aşağıda başına bir uyarı neden olacaktır hesaplanmış bir sütunda 'için) ,

· SharePoint Seçimi kolonlara ABACUS 'Liste özellikleri,

· SharePoint Çoklu Metin satırları (aka Not) sütunlar Abacus 'Tarih / Saat Özellikleri: (Not SharePoint Tarih ve Saat sütunları nedeniyle dilimi / bölgeselleşme ayarları için SharePoint'in tutarsız destek kullanılamaz)

· SharePoint Evet / Hayır (aka Boolean) sütunlar Abacus 'Boole özellikleri.

Bir ABACUS öğesinin İlişkili Standartları henüz SharePoint listesi kolonlara eşleştirilmiş edilemez. Ve SharePoint Döviz, Kişi veya Grup, Köprü veya Resim, Görev Sonuç, Dış Veri ve Yönetilen Meta sütunları henüz ABACUS yönlerine eşleştirilmiş edilemez.

8. Seçin Mapping oluştur.

Karşı senkronize etmekMicrosoft SharePoint listesi (ler)ABACUS'e içine

1. Eğer ABACUS; açık olduğundan emin olun.

2. Seçin Araçlar | SharePoint Sync.

Not

Karşı Bir ile bir SharePoint listesi eşitlemeABACUS proje kullanıcı lisans ihtiyacı SharePoint Syncadd-on yeteneği. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

3. Varolan SharePoint eşleme seçin (veya dönüşümler kullanarak Ctrl tuşuyla veya Hepsini seçdan düğme) SharePoint DönüşümlerpanelÖrnek ekran görüntüsünde görüldüğü gibi Yukarıda. Not: Biz sadece 'Gol (veya Gereği)' a SharePoint listesine ABACUS'ün bileşen türü eşleştirme gösteriyor burada adlandırılan Hedefler seçilen.

4. Sizden hoşnut eşitlemek istediğiniz Mimarlık (lar) ı seçin Mimarilere Sync İçeriğiPanel olarak Örnek ekran gösterildiği Yukarıda. Not: Burada biz sadece '2015 Güncel' mimari senkronize ediliyor gösteriyor.

5. Seçin SP Gönderen Syncdüğme.

Not

SharePoint sitesi kimlik SharePoint iletişim için bir Girişi soran görünecektir sonra seçilen haritalama (ler) için değil 'Tüm Kayıtlı' ise Site URL'si, Kullanıcı adı ve / veya Parola.Bu giriniz. Ayrıca, senkronizasyon ekli bileşenler / arama sütunlar için gerekli olan herhangi bir başka eşleştirmeleri içerecektir. Otomatik olarak eklenir herhangi bir ek dönüşümler aşağıda başına diyaloğunda gösterilir.

6. Değişiklikleri ve herhangi bir uyarı listeleme aşağıda gösterildiği gibi başarılı senkronizasyon On SharePoint Sync Sonuçları iletişim görünecektir. Tıklayın tamam.

Karşı ABACUS'e dan senkronize Microsoft SharePoint listesi (ler)

1. Eğer ABACUS; açık olduğundan emin olun.

2. Seçin Araçlar | SharePoint Sync.

Not

Karşı Bir ile bir SharePoint listesi eşitlemeABACUS proje kullanıcı lisans ihtiyacı SharePoint Syncadd-on yeteneği. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

3. Varolan SharePoint eşleme seçin (veya dönüşümler kullanarak Ctrl tuşuyla veya Hepsini seçdan düğme) SharePoint DönüşümlerpanelÖrnek ekran görüntüsünde görüldüğü gibi Yukarıda. Not: Biz sadece 'Gol (veya Gereği)' a SharePoint listesine ABACUS'ün bileşen türü eşleştirme gösteriyor burada adlandırılan Hedefler seçilen.

4. Sizden hoşnut eşitlemek istediğiniz Mimarlık (lar) ı seçin Mimarilere Sync İçeriğiPanel olarak Örnek ekran gösterildiği Yukarıda. Not: Burada biz sadece '2015 Güncel' mimari senkronize ediliyor gösteriyor.

5. Seçin Sync To SPdüğme.

Not

SharePoint sitesi kimlik SharePoint iletişim için bir Girişi soran görünecektir sonra seçilen haritalama (ler) için değil 'Tüm Kayıtlı' ise Site URL'si, Kullanıcı adı ve / veya Parola.Bu giriniz. Ayrıca, senkronizasyon ekli bileşenler / arama sütunlar için gerekli olan herhangi bir başka eşleştirmeleri içerecektir. Otomatik olarak eklenir herhangi bir ek dönüşümler aşağıda başına diyaloğunda gösterilir.

6. Değişiklikleri ve herhangi bir uyarı listeleme aşağıda gösterildiği gibi başarılı senkronizasyon On SharePoint Sync Sonuçları iletişim görünecektir. Tıklayın tamam.

Not

ABACUS SharePoint Evet'e ayarlandığında 'bu sütun bilgileri içerdiğini iste' bile boş değerlerle SharePoint sütunları güncelleyecektir. SharePoint dışarıdan bu ayarı göstermiyor olmasıdır. Bu önlenecek ise bir ABACUS Tasarımcısı 'ABACUS kullanılarak verilen mal True ve Zorla için Gerekli kısıtlamayı ayarlar tavsiye edilir sınırlama özellik .

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Visio sizin mimarisi doldurma | Excel sizin mimarisi doldurma


Microsoft SQL Server için mimari doldurma

Navigasyon:> Mimarinizi doldurma Microsoft ürünleri doldurmamak>

Microsoft SQL Server için mimari doldurma

Yorum gönder bu konuda.

Bir Microsoft SQL Server veritabanına gelen mimari alabilirsiniz. Sadece etkin bir veritabanı veya yapı ancak veri de sadece ithal edecek Tablolar, Satırlar ve İlişkiler sadece genel yapısını ithal Tablolar ve İlişkiler almak için seçim var.

Not

SQL itibaren Server özelliği gerektirir Microsoft SQL Server 20052008, 2008 R2, 2012 veya 2014bilgisayarda yüklü.

ABACUS'e içine Microsoft SQL Server veritabanı almak için

1. Eğer ABACUS; açık olduğundan emin olun.

2. Dosya Seçin | Yeni basıp SQL Serverbelirir ve Tamam'a tıklayın iletişim kutusundan.

3. Aşağıdaki örnek ekran görüntüsünde görüldüğü gibi 'machinename' ve Bağlantı dizesi değişken ve doğru değerler Veritabanı adı değişkenin 'dbname' değeri 'SQLinstance değerlerini hazır görünüyor İthalat SQL Server iletişim kutusunda.

4. Aşağıdaki örnek ekran görüntüsünde görüldüğü gibi, yukarıdaki adımda belirlenen Başlangıç ​​Kataloğu değişkeni aynı değere Veritabanı adı değişkeni ayarlayın.

5. Aşağıdaki örnek ekran görüntüsünde görüldüğü gibi iletişim bölümünde, mevcut veritabanı tabloları ile doldurulması gerektiğini Alınacak Test Connection düğmesi ve Tablolar basın.

6. Güvenebileceğiniz ithal etmek isteyen tabloları seçin ya bunları tek tek seçerek veya iletişim kutusunun sağında Tüm Hiçbiri ve Invert düğmelerini kullanarak.

Not

Alınan alacak seçmek Tablolar arasında mevcut Sadece Yabancı anahtar ilişkileri.

7. Sadece Tablolar ve onları ya Masalar, kendi Satırlar ve satırları arasında belirli İlişkiler arasındaki İlişkiler almak isteyip istemediğinizi seçin İthalat Stil radyo düğmesini kullanarak.

Not

İlk seçenek türü 'Tablo İlişkisi' bağlantılarının olarak ithal tip 'Tablo' ve (yabancı anahtarları itibaren) herhangi iki Tablolar arasındaki İlişkilerin bileşenleri olarak Tablolar aktarır. Bu sistem tabloları klasik 'ERD' tarzı görünümüdür. İkinci seçenek sütun / alanların her birine karşılık gelen özelliklere sahip türü 'Tablo satır' ayrık alt bileşenleri olarak ve türü 'Tablo İlişkisi' Tablo Satırlar arasındaki ilişkiler Tablo satırları alır. Üstelik, o zaman bu bireysel Tablo satır alt bileşenlerini adlandırmak için kullanılır 'Adı' adlı bir sütun / alan varsa.

8. İthalat ... düğmesini seçin.

9. (Geribildirim için bir ilerleme çubuğu ile) kısa bir süre sonra yeni bir proje ABACUS Tablolar ile oluşturulur, Masa (İkinci seçenek Yukarıdaki adımda seçildiyse) Satır ve Microsoft SQL Server veritabanı ilişkiler.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Visio sizin mimarisi doldurma | Excel sizin mimarisi doldurma


Microsoft Visio sizin mimarisi doldurma

Navigasyon:> Mimarinizi doldurma Microsoft ürünleri doldurmamak>

Microsoft Visio sizin mimarisi doldurma

Yorum gönder bu konuda.

Microsoft Visio gelen mimari alabilirsiniz. Visio çizim şekiller ABACUS'te içine bileşenleri olarak ithal edilecektir. Visio çizim Bağlantıları bağlantıları gibi ithal edilecek ve çizim kendisi bir diyagram olarak ABACUS ithal edilecektir. Ayrıca, Visio çizim herhangi Özel Özellikleri Sıralama Emlak Tipi eşleştirilmiş Key, Etiket Mülkiyet Adı ve Mülkiyet Değerine Değer ile özellikleri olarak ithal edilecektir.

Not

Visio özelliğinden İthalat gerektirir Microsoft Visio 2003ya da daha yeni bilgisayara yüklenir.

ABACUS'e içine Visio çizimlerini almak için

1. Eğer ABACUS; açık olduğundan emin olun.

2. Dosya Seçin | Yeni basıp Visiobelirir ve Tamam'a tıklayın iletişim kutusundan.

Not

Eğer varolan bir ABACUS projeye aktarmak isterseniz ya bir Mimarisi içinde Bileşenleri düğümünü sağ tıklatın veya Al'ı seçin sonra Mimarlık içindeki bireysel bileşeni sağ tıklatın ve | Visio.

3. Almak istediğiniz Visio dosyasını bulun.

Not

Aşağıda bazı basit kurallar veya tavsiye uygulamaların MS Visio ABACUS ithalatı için çizim inşa (ya da değiştirerek) bulunmaktadır.

1. Çizgiler veya bağlantıları gerçek konnektörleri DEĞİL şekiller olması gerekir.

· Aksi takdirde ABACUS sadece bileşenleri olarak ithal edecek ve buna göre onlar bir şey için "bağlı" olmayacaktır.

· Eğer Temel şekiller stencil Dinamik konektörü kullanan bazı "akıllı" yönlendirme (yani düz bir çizgi haricinde) yapmak gerekirse, ABACUS yönlendirme / çapa noktaları ince ithal edecek.

· "Halka ağ" ve bileşenlerin bir sürü buna "bağlı" izin verir Ağ ve Çevre Birimleri şablon "Ethernet" şekilleri kullanarak önlemek için deneyin. Biz bağlantıları gibi ek ince ithal ederken, orijinal şekil hala ekleri yansıtmak için "genişletilmiş" bir. (Konnektörüne olmadan "bacaklar") ayrı bir "hub / otobüs" şeklinde ayırmak kullanın ve daha sonra açıkça ayrı konnektörleri ile hub / otobüs her bileşeni bağlayın.

· Bir çizgi veya bağlantı şekli gibi davranırsa, onun üzerine sağ tıklayın ve Format 'git | Davranış ... 've Etkileşim tarzı Hattı (1 boyutlu) olarak ayarlanmış olduğundan emin olun.

2. Bileşenleri şekiller DEĞİL konnektörleri olması gerekiyor.

· Aksi takdirde ABACUS sadece bağlantıları gibi onları ithal edecek ve buna göre tüm şekil bilgileri kaybolur.

· Bir bileşen, bir konnektörü gibi davranır ise, onun üzerine sağ tıklayın ve Format 'git | Davranış ... 've Etkileşim tarzı Box (2 boyutlu) olarak ayarlanmış olduğundan emin olun.

3. Bağlayıcı uçları şekil arkasında arka planda etrafında yüzen DEĞİL, şekillere bağlı olması gerekir.

· Eğer şekillere konnektörlerini bağlamak yoksa o ABACUS size şekil / bileşene verilen konektörü takmak için tasarlanmıştır ve buna göre bağlantı un bağlı bu ucunu terk edeceğini bilmenin bir yolu vardır.

4. Şekiller için Etiketler şekli için (mümkünse) dahili metin etiketi DEĞİL çizim üzerinde ayrı bir metin kutusu olmalıdır.

· Ayrı metin kutuları kendi başlarına bileşenleri olarak ABACUS'te tarafından ithal ve ABACUS'te gerçek bileşeni ile "label" bileşeni birleştirme veya süre sadece serbest formlu şekil "label" bileşeni dönüştürmek alacak (yani bir bileşen kendisi) bu adımları kaçınmak en iyisidir.

5. Tembel olmak ve farklı şekil kalıpları bazen dikdörtgen ve kutu diğerlerini KULLANMAYIN, aynı türden her örneği için aynı baz şeklini kullanın.

· ABACUS baz şeklini ve benzersiz yüzden "kırmızı dikdörtgen" ve "kırmızı kutu" iki ayrı bileşen tipleri olarak ithal alacak çizim bileşeni ve bağlantı türlerini tanımlamak için baz renk kullanır. Bu bileşen tipleri ABACUS'te birleşti olabilir ama şu adımları kaçınmak en iyisidir.

6. Tamamen onları kenarına asılı BIRAKMAYIN, onların "ebeveynleri" içinde "çocuklar" şekilleri saklanması.

· ABACUS tamamen böylece etiket kısmı da dahil olmak üzere, emin tüm şekil yapmak ebeveyn çocukken başka şekil içinde kapsüllü herhangi bir şekil, alınmış algılar.

7. Diğer iki şekil çakışan bir şekle getirin ETMEYİN.

· Bir şekil diğer iki şekiller çakışırsa, oa "gruplama" / arka plan dikdörtgen olabilir ya da aksi halde, çakışan şekillerin ne bir çocuktur ama bir bileşen olarak ABACUS'te tarafından ithal edilecek en kısa sürede Abacus 'çizim aracı bileşeni seçin olarak , sol üst bileşenler noktası referans olma, solda bir çocuk haline gelecektir nedeniyle şekil / bileşen çakışan.

8. Bu kendi başlarına bileşenleri olarak ithal alacak ve ABACUS'te içinde serbest formlu şekiller dönüştürülmesi gerekir, çünkü çizim üzerinde metin notları kullanımını en aza indirmeye çalışın. Onlar gerçekten varolan bir bileşen veya bağlantının adını olup olmadığını düşünün.

9. ABACUS zengin desteklerken ABACUS şu yaptığı gibi / renkli / vektör tabanlı şekiller, şekiller için bitmapler, yabancı şekil ve Enhanced Meta kullanımını en aza indirmeye çalışındeğilBu türlerini destekler. Bunlar basit beyaz dikdörtgenler olarak ithal edilecektir.

10. Onlar özel bir karakter "[]" ABACUS'te içinde bileşen adı olarak ithal ve gösterildiği gibi etiketlerde satırbaşları (shift-dönüş) önlemek için deneyin.

11. Aynı tip şekiller için kullanılan farklı renkler en aza indirmek için deneyin. Yukarıda da belirtildiği gibi daha fazla varyasyon ABACUS'te sonrası ithalat yapılması gerekecek fazla birleşme ve konsolidasyon var bu yüzden, temel renk ve taban şekli benzersiz bileşen ve bağlantı türlerini tanımlar.

12. Bir şekil köşelerine tüm yol dolu ise o zaman hiçbir etkisi olmayacaktır ABACUS'te daha sonra bunu renklendirme, çünkü dolu şekiller ile dikkatli olun.

13. Karmaşık çizgi tabanlı şekiller için, bir önceki bitirir nereye başlayan satırları sahip ve sonuçta başlangıç ​​noktasına geri dönüyor tarafından oluşturulan bir çokgen kullanmanız gerekir. İsterseniz, bir 'ok' ya da her türlü şekli istediğiniz gibi çokgen görünmesi için dolgu ve çizgi genişliği kullanabilirsiniz.

14. MS Visio emin şekiller kimliği sadece Shape.xx anlamlı olduğundan emin olun. Bu kullanılarak düzenlenebilir MS Visio geliştirici modunda kullanılabilir 'ShapeSheet Göster' sağ tıklayın (| MS Visio Seçenekleri Araçlar aracılığıyla etkin).

15. Elips ve yaylarşekiller içindeABACUS'e desteklenen ancak NURBS ve kamalar şu anda desteklenmemektedir.

16. Bütün şekil, MS Visio gruplandırılmış veya birkaç bileşenler / türleri olarak ithal alacak emin olun.

17. Bazen doğru içe olmayacak gibi subshapes içinde döndürülmüş şekillerin kullanımını en aza indirmek için deneyin.

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | El mimarisi doldurma | Access sizin mimarisi doldurma | Excel sizin mimarisi doldurma


El mimarisi doldurma

Navigasyon:> Mimarinizi doldurma el doldurmamak>

El mimarisi doldurma

Yorum gönder bu konuda.

Yüksek seviyeli bileşenleri ve mimari bağlantıları muhtemelen elle doldurulması gerekir. Genelde bu daha soyut bileşenler ve bağlantılar olacak.

El mimarisi doldurmak için

1. Bir olduğundan emin olun ABACUS dosyasıaçık, bir kâşifgörüntülenir, ve mimari eklendi .

2. Bir bileşeni ekleyin. Bunu yapmak için, Sağ tıkAğacın alanında size doldurmak istediğiniz seçin Alt Bileşen Ekle ...Ya tıklayın Yeni Bileşendüğmesini Görünüm araç çubuğu . Bileşenler, sadece ağaç bileşenleri dalı altında ilave edilebilir. Sen ağaç diyagramı sizin mimarisinin yansıtmayabilir istiyorum. Eğer mimari keşfetti zaman, hep birlikte uyuyor tam olarak nasıl öğrenmiş olacaktır. Eğer bileşenleri ve bağlantıları eklediğinizde bu bilgiyi gerekir. İlk bileşen ekleyerek ediyorsanız Bileşenleri şubesine doğrudan ekleyeceğiz. Bileşenlerin geri kalanı ağacında aynı seviyede de olabilir, ya da ilk alt bileşenleri olabilir.

3. Değerlerini güncelleştirmeközellikleriHer bileşenin bunu ekleyin olarak. Bunu yapmak için, tıkbileşeni ve görüntülenen özelliklerini düzenleyebilirsiniz Özellikler penceresi(tipik) sağa. Özellikler ABACUS senin mimarisi değerlendirir, bu bazı yeni özellikleri hesaplamak ve geri mimariye onları kurtaracak genellikle vb gereksinimleri, işleme kapasitesi gibi şeylerdir. Yeni özellikler vb kullanımı, tepki süresi, bant genişliği gibi analiz için çalışıyoruz veriler vardır

4. Bağlantılarınızı ekleyin ve güncelleştirmeözelliklerisiz gidin - Sen bileşenleri için (ama ağacın bağlantıları dalı altında) yaptıkları gibi.

5. Iliştirmekbağlantıları ve bileşenleri. Bunu yapmak için, bağlantıyı bulun birine tıklayın onun biter ya rolleri Ve bir bileşeni sürükleyin. Alternatif olarak, bir bileşen üzerine tıklayın ve bağlantı en birinin üzerine sürükleyin rolleri (yani kaynak veya Lavabo ya). Yoksa sağ tıklatın ve başka bir bileşen üzerine bir bileşen sürükle ve seçebilirsiniz Bağlanmak. Ya da sadece bir bileşeni sağ tıklatın ve seçin Bağlayın .... Bir bağlantı sürüklediğinizde rolEğer bunu ekleyebilirsiniz bir bileşeni işaret zaman, bir kısayol sembolü göreceksiniz. Bu size sadece ekleyerek konum, bir kopyasını yapmak değil belirtir. Doğru hedef bileşeni ekleyin emin olun. Örneğin, bir bağlantının Kaynak ise rolBu (veri akışının kaynağı bileşeni yani) kaynak bileşenini yapmak sürükleyin.

Bahşiş

Yeniden sipariş (örneğin Bileşenleri Bağlantıları vs.) mimari içinde yer varlıkları kâşifoldukça kolaydır. Basitçe Tıklayın| Ambar| Sürüklemeksenin mimarisinde istenen ilgili varlık ve yer. Yeniden sipariş işlevselliği de size mimarisinin farklı hiyerarşiler içinde varlıkları yerleştirmek için izin verir.

Ayrıca isteyebilirsiniz

6. Standartları ekle (özelliklerin önceden yapılandırılmış setleri - hazır) senin bileşenleri, bağlantıları veya türlerine

7. Özelliklerini değiştirme Bir bileşen, bağlantı veya Çeşidi

8. Geri al ve Yinele operasyonlar

9. Tip değiştir Bir bileşen veya bağlantı

10. Yeni Tip veya Tip Grup Oluştur

11. Silmek Bir bileşen veya bağlantı

12. Oluşturun çoğaltmak veya evrim Bir mimari

13. İthalat türleri ve standartlar Bir kütüphaneden

14. Başka ABACUS dosyadan içe, XML, Excel veya Visio

15. Kopyala ve yapıştır parçaları (veya tüm) da mimarlık

16. Bul ve Değiştir senin mimarisinde ürün

17. / Genişlet ağacında, bazı veya tüm düğümlerin

18. Birleştirme ürün

19. Tanımlamak ve Doğrula Kısıtlamalar senin mimari yapısını kısıtlamak için

20. Senin mimarisi Evolve Birkaç mimari karşılaştırmak için çözümler ve temel oluşturmak için

Ayrıca bakınız

Mimarinizi doldurma - Genel Bakış | Yeni bir dosya oluşturma


Web'de Yayımla

Navigasyon: senin mimarisine Raporlama>

Web'de Yayımla

Yorum gönder bu konuda.

Web özelliği mimari modeller, güvenli bir web sitesi üzerinden izlenebilir olanak sağlar ABACUS 'yayınlayın. Mimariler HTML formatında ihraç edilmektedir ve görünüm yansıtmak ve ABACUS içinde Explorer'ın hissetmek için tasarlanmıştır. Kataloglar dahil Görünümler (Diyagramlar, 3D ve Grafikler) ayrıca bir internet tarayıcısı kullanarak görüntülenebilir biçimleri içine ihraç edilmektedir.

Not

Şu anda, Bakış Açıları ve Matrisler yayımlanmaz.

Web mimari modeller yayınlamak için

1. Alakalı olduğundan emin olun ABACUS dosyasıAçık içeren nüfuslu mimariWeb'de yayınlamak istediğiniz.

2. Seçin Dosya| Yayınla ....

3. Web Yapılandırması için Yayınlapenceresi görüntülenecektir.

Web Yapılandırması Yayınla

4. Varsayılan olarak modelin tüm bölümleri Ağacı View, dahil seçilir Standartlar, Çeşitleri, Şablonlar ve Mimarlık (lar). Eğer mimarisi (lar) içinde herhangi bir bireysel görünümleri de dahil olmak üzere, web de yayınlamak için istemediğiniz kısımları işaretini kaldırın.

Bahşiş

Belirli bileşenleri, bağlantıları ve / veya bunların özelliklerini gizlemek istiyorsanız bir yönetici kullanarak bir 'ortak' rolünü oluşturur önerilir ABACUS 'rol tabanlı erişim özelliği ve sonra onlar yayınlanacak istemiyorsanız bu bileşen tipleri, bağlantı türleri ve / veya özelliklerinden okuma izni kaldırır. Ardından kullanıcı bu rolü altında giriş ve sadece rol için belirlenen okuma izni olan unsurları sunacağız ABACUS'te olarak web de yayınlamak gerekir. Açıklandığı gibi Dahası, kullanıcıların komut satırından otomatik yayınlayabilirsiniz İşte .

Not

Sen üzerine tıklayarak görüntülenen tüm bölümleri seçebilirsiniz Hepsidüğme veya tıklayarak seçimi tersine Invertdüğmesine basın. Ayrıca tıklayabilirsiniz Hiçbiridüğmesi seçimi temizlemek için.

Not

Eğer sen Ağaç Görünümü seçeneğinin işaretini kaldırınDaha sonra hiçbir ağaç çerçeve (aşağıya bakınız) yayınlanacaktır. Bu duruma göre, Aşağıdaki adım 6 veya uygun bir başlangıç ​​sayfası seçmelisiniz yayımladıktan sonra üst düzey ya da özelleştirmek gerekir; a) index.html'frame src = "mainPage.html" name = "element_details"' hattı değiştirerek dosya doğrudan ya, b) İçerik klasörü altında ilgili html sayfasına link mainPage.htmlBir köprüyü sağlayan veya içerik klasör altında ilgili html sayfasına yönlendirme tarafından.

5. Tıkla Seçenek basın ve aşağıdaki Yayıncı Seçenekleriiletişim gösterecektir.

Yayınlaer Seçenekleri

6. S, 3D seçecek Diyagramve Grafikler formatları ve Unvan, Açıklama veya Properties gösterilip gösterilmeyeceğini Mevcut seçeneklerden dışarı görüşlerine (çeşitli biçimlerde yorumlar için aşağıdaki nota bakınız).

7. Belirli bir görünüme yayınlanan modelin başlangıç ​​sayfasını ayarlamak isterseniz o zaman kontrol Başlangıç ​​sayfası olarak görüntüle kullanseçeneği ve etkin hale gelir '...' düğmesi ile görünümü göz atın.

Not

Adım 4 uyarınca Alanları bölümünde seçilen Sadece görünümleri yukarıdaki başlangıç ​​sayfası olarak ayarlanacak mevcuttur.

8. Yayımlanmış modelde belirli sayfalara hakkında geri bildirim almak istiyorsanız o zaman emin olun E-posta Görüşleriseçeneği seçildiğinde, bir e-posta adresi girin E Metin kutusuve düzenleme E-posta Vücutuygun bölümü. Eğer sahip olmak istemiyorsanız geribildirim işaretini sonra gönderilen E-posta Görüşleriseçeneği ve boş metin kutusunu bırakın.

9. Tıklayın tamamdüğmesine basın.

10. Tıklayın Araştırdüğmesine basın.

11. Klasör için Gözatpenceresi görüntülenecektir.

12. Eğer üst düzey HTML dosyasını (ve herhangi bir otomatik oluşturulan dosyaları) saklamak istediğiniz konumu seçin.

Not

Bu kullanarak belirli bir klasör (genellikle sözde "Yayın") oluşturmak için iyi bir fikirdir Yeni Klasör Oluştur'uİletişim kutusunun alt kısmındaki düğme üst düzey HTML dosyası ve herhangi bir otomatik olarak oluşturulan dosyaları depolamak için.

13. Tıklayın tamamdüğmesine basın.

14. Klasör yolu görüntülenir Dizin Metin kutusu.

15. Tıklayın Finishdüğmesine basın.

- veya -

15. Klasör yolunu girin DizinEğer üst düzey HTML dosyasını (ve herhangi bir otomatik oluşturulan dosyaları) saklamak istediğiniz metin kutusu.

16. Tıklayın Finishdüğmesine basın.

Not

Ihracat DiyagramlarıBilgisayar belleği yetersiz olduğunda çok nadiren çoğunlukla başarısız (normalde çok büyük dosyalar kullanırken). Başarısız bir ihracat kez denenecek. Yeniden deneme başarısız olursa biri başarısız ilk girişimi uyarı ve bir ikinci uyarı olacaktır. Sadece uyarılardır Bu nedenle, olanlar, yayınlama "ilk girişimi başarısız oldu" başarılı oldu. Yeniden girişim başarısız olursa bir küçük dosyanızın bölümünü ya da bazı sistem belleği kadar ücretsiz yayımlamayı deneyin.

Kaydedilen HTML dosya (lar) şimdi bulunduğu yerden görünümü veya güvenli bir web sitesine kopyalanabilir olabilir.

Internet Explorer'da Web Yayınlama10

Herhangi köprüler Orijinal modelde yaratılmış oldukları yayınlanan modelinde ısrar edilecek ve (o yayımlanmıştır varsa) bağlantısını tıklayarak hedefine bağlantıyı takip edecek. Ayrıca, zaten orijinal modelde köprü değil yayımlanmış diyagramlar herhangi elementler (o yayımlandı ise) Ağaç görünümünde karşılık gelen öğelere ve odak geri atlayacaktır yayınlanan şemada elemanı tıklayarak geri köprü oranında artacağı Ağacında ilgili konum. Bu özellik "Explorer'da Show" ABACUS'te sağ tıklama özelliği benzer.

Not

Avolution şiddetle Aşağıdaki program ve dosya formatları tamamen ABACUS'te Web işlevselliği Yayınla yararlanmak için kullanılması gerektiğini önermektedir:

1. Internet Explorer (80,0 ve üstü)yayınlanan kaşif görünümünü görüntülemek için. Mozilla Firefox (30,0 veya üstü)Ayrıca önerilen ve tam olarak desteklenirFirefox 9, sonra diyagramlar için tavsiye edilen SVG biçimini kullanarak eğer, ancak, sadece maalesef yakınlaştırma veya kaydırma izin vermez yerli SVG görüntüleyici desteği kullanabilirsiniz.

2. Adobe SVG Viewer 3,0 fişli (download İşte ) ve SVGyayınlanan için dosya biçimi diyagramlar. SVG resim biçimi diyagramlarÇünkü tavsiye edilir; SVG vektör tabanlı bir görüntü biçimidir ve bu nedenle, SVG herhangi bir düzeyde veya çözünürlüğe uzaklaştırdınız olabilir 'kayıpsız' ve SVG, MS Visio içine alınabilir diğer formatlar herhangi bir daha herhangi bir yakınlaştırma düzeyinde çok daha iyi görünüyor SVG geri bağlantıları için ağaç görünümü (sadece bileşenler) bağlantıları vardır, SVG hep SVG diğer formatlar yaklaşık yarısı dosya boyutu, daha iyi bir çözünürlükte yazdırır ve. Belirli yakınlaştırma seviyelerinde görüş netliği kaybolur ve ağaçtaki ilgili konumuna geri atlamak olmaz diyagramlar bağlantıları tıklayarak olacak bir raster biçimi olarak PNG, ancak bir sonraki tavsiyedir. BMP bir 'kayıp-daha az' biçimlendirmek dosya boyutu diğer formatlar ve 20Mb görüntüleri bu olağandışı değil 100x olduğu ise olarak teşvik edilmektedir.

SVG ile ticaret-off SVG görüntüleyici yüklü olması gerektiğini ve yapmanız gerekenler SVG image / svg + xml web sunucusunun MIME türlerini eklenir emin olun. SVG görüntüleyici yüklenmesinden sonra Microsoft Internet Explorer izleyicinin Lisans sözleşmesini kabul etmek isteyecektir ve daha sonra iyi çalışması gerekir. Ve ikenMozilla Firefox eklentisi Adobe hala tavsiye edilir, doğal SVG dosyalarını desteklerFirefox 8 kullanıyorsanız veya diyagramlar Büyütmek edebilmek için erken (Firefox 9 kullanıyorsanız, yerli SVG görüntüleyici devre dışı bırakamazsınız). Adobe eklentisi için kurulum çalıştırmak edildikten sonra, gerekli Aşağıdaki adımlar Firefox kullanın:

· Firefox açın ve "about: config" girin URL çubuğuna (tırnak olmadan).

· Aşağı kaydırın ve svg.enabled özelliği bulmak(Firefox 9 kullanıyorsanız o zaman yerli SVG inceleyen devre dışı olamaz ve bu özellik yok). Devre dışı bırakmak için üzerine çift tıklayın.

· Şimdi bulabilirsiniz SVG eklentisi yüklü olduğu dizin (örneğin C: \ Program Files \ Common Files \ Adobe \ SVG Viewer 30,0 \)

· Dosyaları kopyalayın NPSVG3.dll ve NPSVG3.zip ve firefox eklentileri dizinine yapıştırın (örn C: \ Program Files \ Mozilla Firefox \ plugins)

· Ateş tüm örneklerini kapatmak

3. Avolution en ABACUS 3D Viewer (3.1 ve üstü) ve Avolution en .abacus3Dyayınlanan 3B görünümleri için dosya biçimidir. Iken Cortona VRML Client plug-in (2.0 ve üstü)hala ticari kullanım için ücretsiz değil ve yayınlanan görüş VRML sürümlerini görüntülemek için kullanılabilir bir istemci tarafı kurulum gerektirir. ABACUS 3D Viewer daha zengin özelliklere sahip herhangi bir VRML görüntüleyici daha ve yüklenebilir serbestçe kullanılabilir İşte . Her iki durumda da size emin olun Web sunucusunun MIME türleri .vrml x dünyayı / x-VRML ve .abacus3d uygulama / sekizli-akışı eklemek.

4. PNGyayınlanan Grafik görünümleri için dosya biçimi. Bir raster formatı ve 'kayıp' trade-off dosya boyutu ve grafik netliği arasında genellikle iyi varken Grafik görünümleri için PNG resim formatı nedeniyle tavsiye edilmektedir. BMP o ise olduğu gibi cesareti olan bir 'kayıp-daha az' dosya boyutu diğer formatlar ve 2Mb çizelgeleri olağandışı olmadığını 20x olduğunu biçimlendirmek.

Eğer görünümünü değiştirmek ve web sayfaları hissetmek istiyorsanız, mainPage.html adlı başlangıç ​​sayfası dosyasını ve abacus.css adlı stil sayfası dosyasını düzenleyebilirsiniz. Eğer üst düzey HTML dosyasını kaydetmek için seçtim nereye aynı klasörde bu dosyaları bulabilirsiniz. Yayınlanan çıktı yapısı ve terzilik hakkında daha fazla bilgi için sonraki bölüme bakın.

ABACUS'e yapısı modellerini yayınladı

Aşağıdaki gibi ABACUS yayımlanan modeli yapılandırılmıştır:

1. Üst düzey klasör bir içerecektir iletişim Web Yapılandırması Yayınla ABACUS'te içerdiği tüm seçenekleri varsayarak birkaç dosya ve içerir indeksi.htmlDosya üç çerçeveden oluşan; treeView.html, findNode.html ve mainPage.html ve sonra shortcutError.html sayfa. TreeView.html tarafından doldurulur tree.js, tree_items.js ve tree_tpl.js dahil klasörünün altında bulunan javascript dosyaları (aşağıda açıklanmıştır) ve ABACUS'e dan Explorer ağacı çoğaltır. FindNode.html tarafından desteklenmektedir find.js javascript klasör (aşağıda açıklanmıştır) dahil altında yer alan dosya ve Ağacın dallarını yerine sadece görünür düğümleri arayacaktır. TO mainPage.html şirket logoları ve benzeri uygun olabilir statik bir HTML sayfasıyayımlarken bir başlangıç ​​sayfası seçilir sürece gösterilir.Ve nihayet, shortcutError.html sayfası nedeniyle değil yayımlanarak uygun sayfalarına ağacından herhangi bir kırık kısayollar için bir açılış sayfası.

Bahşiş

Sen tarafından tamamen mainPage.html atlayabilirsiniz Bir başlangıç ​​sayfayı kullanabilmek için seçerken yayınlama veya index.html dosyasını değiştirerek çerçeve src ilk mimarisinde ilk görünümüne doğrudan işaret etmek = "mainPage.html" satırı, genellikle 'çerçeve' diyagram düzenleyerek, belirli bir görünüme (diyelim ki) doğrudan işaret etmek.

2. Üst düzey includeKlasör içerirlering çeşitli yayınlanan modele boyunca .html dosyaları tarafından kullanılan javascript (.js) ve basamaklı stil sayfası (.css) dosyaları.

3. Üst düzey İçerik klasörü içeren, Alfabetik;

· A '3D Görünümler' Bir klasör sayılıHTML sayfası ve yayınlanan 3B görünümleri her biri için bir VRML veya abacus3d dosyası. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· Bir Mimarileri yayınlandı her mimari için bir numaralı HTML sayfası ile klasör. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Kataloglar yayınlanan kataloglar her biri için bir numaralı HTML sayfası içeren klasör. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Grafikler Bir klasör sayılıHTML sayfası ve PNG yayınlanan Grafik görünümleri her biri için, JPG vb dosya. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Bileşenler Klasör içeren sayılıYayınlanan bileşenlerin her biri için HTML sayfası. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Bağlantılar Klasör içeren sayılıYayınlanan bağlantıların her biri için HTML sayfası. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Diyagramları Klasör içeren sayılıHTML sayfası ve PNG yayınlanan her biri için, SVG vb dosya diyagramlar. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· Bir simgeler altKlasör ile yayınlanan modelde kullanılan çeşitli görüntüler.

· A Standartlar Bir alt-klasör sayılıHerhangi bir HTML sayfası StandartlarBu yayımlandı. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Şablonlar altklasöründe dosyalanır Projeden yayınlanan her şablon için numaralı alt klasörler bir koleksiyon ile. Her alt klasör içinde bir parça ve bir Bağlantılar klasörü ve bunlar içinde her bileşen ve şablonun bağlantısı için numaralı bir HTML sayfası. Klasör / dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Türleri Bileşen alt klasör veBir bağlantı alt klasörler sayılıHerhangi bir bileşen için HTML sayfası veYayınlandı Bağlantı Türlerive kısıtlamaların her biri için bir HTML sayfasını içeren projeden yayınlanan her türü için numaralı alt klasörler bir koleksiyon. Klasör / dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

· A Görünümnoktas alt klasör ve sayılıView herhangi bir HTML sayfasınoktayayınlanmış s. Dosya numaralandırma düzeni hakkında bilgi için aşağıdaki nota bakın.

Not

HTML sayfaları numaralandırma (ve bazı durumlarda resim dosyaları) maçları benzersiz İD olan her nesne için depo ne zaman set öyleydi oluşturulanABACUS'e içindeki (EEIDs olarak anılacaktır). Bu kimlik yüzden değişmez olarak diyagramlar, çeşitleri, bileşenler v.b vardır güncellendi onlar iradedaha önce olduğu gibi aynı kimliği saklayın. Her durumda, ilgili depo nesneadı ... HTML etiketleri arasına HTML sayfasının başlangıcında yakın bulunabilir.

IIS ile Bazı Sayfalar / Gösterim Erişim kısıtlama

Yayımlanmış modeli için web sunucusu olarak IIS kullanarak, aşağıdaki yöntemi kullanan bazı sayfalar / görünümler erişimi kısıtlamak mümkün olabilir:

1. IIS bir web sitesi (eğer müdahale etmek istemiyorum varolan varsa başka bir) oluşturun.

2. Kaldırın anonim erişim ve kullanım erişimi kimlik doğrulaması - Özellikler-> Dizin Güvenlik-> Anonim erişim değiştirin.

3. Bu sadece normal bir sunucu hiçbir etki alanı komplikasyon vb ise, dikkatli olmak (o zaman sonra kimlik doğrulaması gibi sunucu makineleri, yerel kullanıcı / oturumların kullanmak istiyorsunuz 'entegre Windows kimlik doğrulaması' seçeneğini kullanmanız gerekir ve sadece yerel bilgisayara kullanıcı eklemek Eğer vb), örneğin, makineye yeni kullanıcı ekleme uzaktan erişim makine kurulum olup olmadığına bağlı olarak, bilge etkileri, güvenlik farkındayız.

4. Gerektiği gibi belirli dosya / klasör izinleri ekleyin. Sağ tek tek dosyaları / klasörleri tıklayın -> Özellikler ve normalde dosya / klasör için olduğu gibi güvenlik izinlerini ayarlayın.

Bu ne özel Windows işletim sistemi sunucu üzerinde olduğunu ve bir etki alanı ya da diğer farklı kurulum var olup olmadığını nasıl IIS sürümüne ve bağlı olarak değişebilir.

Ayrıca bakınız

Senin mimarisi doldurma | Senin mimarisi analiz


ABACUS kaydediliyor

Navigasyon: Referans>

ABACUS kaydediliyor

Yorum gönder bu konuda.

Ilk ABACUS başlattığınızda (veya geçici lisans sonrası doldu) ne zaman yerel ABACUS Administrator tarafından veya doğrudan Avolution temin benzersiz bir lisans anahtarı kullanarak Avolution lisans sunucusuna karşı uygulamayı kayıt olmanız gerekmektedir. Bir lisans anahtarı yoksa yerel ABACUS yönetici ile irtibata geçiniz veya Avolution Destek .

Bir lisans anahtarı ile kayıt

1. Yükleme tamamlandıktan sonra, ABACUS başlangıçMasaüstünde veya Windows Başlat menüsünden kısayolu çift tıklatarak biri tarafından.

2. Girmek görünen Kayıt diyaloğunda 26 karakter lisans anahtarıYerel ABACUS Administrator tarafından sağlanan ya da Avolution desteği Ya tıklayın Araştır ...ve imzalı .dlsc dosya döndü seçin Avolution Destek Aşağıda Adım 4'te Not başı olarak. Bir doğru imzalanmış .dlsc dosyasını kullanıyorsanız ABACUS aşağıdaki Adım 5 uyarınca başlamalıdır.

Bahşiş

Ctrl + V. Windows panoya kopyalama ve sonra diyalog arka seçip basarak iletişim içine lisans anahtarını yapıştırın

Kayıt iletişim

3. Tıklayın tamamve lisans anahtarı ise bir Geçerli ABACUS lisans anahtarıABACUS şimdi lisans anahtarı kimlik doğrulaması Avolution lisans sunucusuyla iletişim çalışacağız.

Not

Bir alırsanız Kurulum Kodu geçersizkayıt hatası o yanlış kod yazdınız muhtemeldir. Kopyalamayı deneyin ve yukarıda belirtilen İpucu başı olarak kodunuzu yapıştırmak.

Avolution License Server Başvurma

4. Tıklayın tamamve zaman kısa bir süre sonra ABACUS başarıyla kayıt olmanız gerekmektedir.

Başarılı Kayıt

Not

Eğer alırsanız Lisans sunucusu bağlantı kuramıyorkayıt hatası ağınızdaki bir güvenlik duvarı (ya da diğer güvenlik önlemleri) Avolution lisans sunucusuna erişimi engelleyen olması muhtemeldir. Tıklayın tamam, Daha sonra yerel makine ve .dlsc dosyayı ya için .dlsc dosyayı e-posta Avolution Destek ve daha fazla talimat bekliyorveya lisans kendiniz aşağıdaki URL'yi kullanarak dosya oturum açmayı deneyin - http://licensing.avolutionsoftware.com/LicenceSign/ .

Lisans sunucusu bağlantı kuramıyor

Lisans imza sayfasını açın

Manuel Lisans imzalama web sayfası

Alternatif olarak, eğer sen almak Lisansı tarafından izin verilenden daha bu yükleme kodu daha sistemlerde kullanılmaktadırkayıt hatası o son ABACUS kayıtlı beri yerel makine yeniden inşa edildi veya başka bir kullanıcının lisans anahtarı ile kayıt çalıştığınız olasıdır. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek .

Kurulum kodu zaten kullanılmış

5. Tıklayın tamamKayıtlı eğer başarıyla ABACUS ile açılmalıdır Hoş Geldiniz Ekranı .

Ayrıca bakınız

Avolution Destek | ABACUS'ün ne yapar?


Standart Eleman Seçimi

Navigasyon: senin mimarisi analiz>

Standart Eleman Seçimi

Yorum gönder bu konuda.

Bir diyagramı yaratmak 3D görünüm, rapor,Standart grafikveya bir simülasyon çalıştıranStandart eleman seçimi penceresi / görünümü analiz etmek istediğiniz öğeleri seçmek için kullanılır.

Standart Eleman Seçme Penceresi

Pulldowns

· Görünüm Filtreirade dahil elemanÖnceden kaydedilmiş bir görünümden s (yani Diyagram, Grafik, 3D). Bu şekilde karmaşık bir kaydedilmiş 'sorgusu' gibi başka bir görünüm tedavi sorguları 'katılmak' gerçekleştirebilirsiniz.

Kutularını

· Göster Düzeyleriirade grup, ağaçta meydana geldiği göre düzeyine göre eleman. Seviye 1 en üst seviyedir.

· Göster Çeşitleriirade grup olduklarını türlerine göre elemanları.

· Seçilen ebeveynleriSeçilen herhangi öğelerin ana unsurlarını içerecektir. Bu şekilde herhangi bir çocukları üzerinde sadece hiyerarşi bir "aşağıdan yukarıya" seçimi için dahil edilecek emin olabilirsiniz.

· Seçilen ÇocuklarÇocuklara seçilen herhangi elemanların unsurları içerecektir. Bu şekilde herhangi bir ebeveynlerin altında sadece hiyerarşi bir "yukarıdan aşağıya" seçimi için dahil edilecek emin olabilirsiniz.

· Adı Değer MaçlarıBelirtilen dizeyi içeren bir adı var sadece bu unsurları içerecektir (: yani joker karakterler (ve *) kullanılabilir unutmayınız?). Bu şekilde bir "semantik" sorgusu oluşturabilir.

· Emlak Türü / Ad / Değer Has? Lütfen dikkat: (a Emlak Türü, Ad ve Değer doğrudan elemanı ya da Standartları ya da belirtilen dizeyi içeren tek olan unsurları içerecektir.? yani joker karakterler (ve *) kullanılabilir Örn * Değer alanında olacak Verilen Mülkiyet olmayan bir boş değeri olan tüm unsurları) vermek. Bu şekilde bir "semantik" sorgusu oluşturabilir.

· Standart HasBelirtilen dizeyi içeren bir standart isim sadece bu unsurları içerecektir (: yani joker karakterler (ve *) kullanılabilir Örneğin HP * En az bir standart harf H ve P ile başlayan tüm öğeleri verecek unutmayınız?.). Bu şekilde bir "semantik" sorgusu oluşturabilir.

· Bileşenleri / Bağlantılar seçilen bağlıseçilmiştir olanlara takılı elemanları takılacaktır. Bu şekilde, bir "çağrı İndeksi" veya "darbe analizi" seçilebilir.

Not

Eğer her ikisi de varsa Göster Düzeyleri ve Göster ÇeşitleriSeçilen sonra birinci veya türleri ilk iki onay kutularını üstünde görünecektir düğme ile ağaç gösterisi seviyelerini seçebilirsiniz.

Bahşiş

Bir öğe Standart Eleman Seçim Penceresinde seçildiğinde o seçili kadar, herhangi bir başka filtre değişikliklere tabi olmayacaktır. Aynı anda elemanların iki farklı set için (Standart A VEYA Standart B örn Bileşenleri) aramak için hiçbir yerli yolu olmadığı için, istediğiniz bileşenleri seçin, bir set için ilk arama ve sonra ikinci sette için ikinci bir arama yapabilirsiniz .

Düğmeler

· Hepsitüm unsurları seçer.

· InvertTüm Seçili öğelerin seçimini kaldırır ve seçili olmadığını tüm bu seçer.

· Hiçbiritüm öğelerin seçimini kaldırır.

· Filtre EkleGeçerli filtre ayarları çıkan içeriğini seçer ve etkili olarak ek içerik seçimi bir AND veya JOIN filtreyi izin verir.

Ayrıca bakınız

Senin mimarisi analiz


Çizim Aracı

Navigasyon: Çizimler> Mimarinizi doldurma Kullanma>

Çizim Aracı

Yorum gönder bu konuda.

Çizim Aracı mimari şemaları ve diyagramlar çeşitli oluşturulmasını sağlar. Mimarlar geleneksel kayıt ve bir mimari tasarımını iletmek için farklı çizimler bir dizi kullanın. İki boyutlu (2D) diyagramları belgeleyen bir sistemin çeşitli parçaları iletişim olağan yoludur. Kurumsal sistemlerinde kullanılan tipik çizimler türleri şunlardır:

· İş süreç modelleri ve diyagramlar;

· Organizasyon şemaları;

· İşbirliği şemaları;

· Varlık-İlişki (ER) diyagramları;

· Veri Akış Diyagramları (DFD) 'ın;

· Sınıf diyagramları;

· Idef (yukarıda birkaç içeren); ve

· UML (yukarıda birkaç içeren).

Gerçekten oluşturulabilir diyagramları türlü sınırı yoktur. ABACUS mimarisi ve temsil biçimlerinin bütünlüğünü koruyarak diyagram esnekliği dengelemek için çalışır.

Çizim ortamıdır bir Sekmeli ve yuvalanabilir pencere Ana ABACUS uygulama içinde. Bu pencere, bir saniye çizim gerçekleşir ve çizim penceresi açıkken bir tuval içeriyor yuvalanabilir pencere , Şablon penceresi, çizim şablonlar bir dizi görüntülenebilir. Bileşenleri, Bağlantılar, Şekiller ve Konektörler: şablon bölmesi 4 sekme bulunur. Tuval ince ızgara çizgileri (düzen için yararlı) ile beyaz zemin olarak görünür.

Bağlantıları yönlendirilmiş çizgiler olarak çizilir ise Bileşenleri, şekiller bir dizi ile temsil edilir. Bağlantılar kullanarak bileşenlere eklemek rolleri (yani kaynak veya lavabo olarak) Bu her ne kadar estetik nedenlerle gösterilmemiştir.

Bahşiş

Süre diyagramlarBir sistemin farklı parçalarını göstermek için çok yararlıdır, onlar ABACUS karmaşık sistem yapılarını görselleştirmek için 3D kullandığı yüzden onların ölçeklenebilirlik, içinde sınırlıdır.

Sen isteyebilirsiniz

1. Aç Diyagram Aracı

2. Yeni şeması oluşturun a mimarisinin parçası

3. Bir diyagram kopyalayın içinde ya da mimarileri arasında

4. Bileşenleri ekleyin bir diyagram

5. Yeni bileşenler ve bağlantıları oluşturmak çizim aracını kullanarak mimarisi (şematik) 'de

6. Bileşenleri Sil Bir diyagramdan

7. Takın ve bağlantıları manipüle

8. Değiştir Ekran özellikleri bileşenleri ve bağlantıları.

9. Bağlantıları kullanarak diyagram

10. Türü ilişkilerini zorla ve bakış açısı şekilde çizilebilir diyagramlar türlerini kısıtlamak için.

Ayrıca bakınız

Senin mimarisi doldurma | El mimarisi doldurma | Analiz senin mimari


Giriş sayfası

ABAKÜS

Yasal Uyarı

Avolution Pty Ltd açıkça birbirleri ile bu kılavuzun değiştirilmesinden zımni olabilecek garantinin ihlali için sorumluluk sınırlar, yasaların izin verdiği azami ölçüde, bu kılavuzun ilgili ve hiçbir beyanda bulunmaz veya garanti vermez. Dahası, Avolution Pty Ltd revizyon herhangi bir kişiye bildirme yükümlülüğü ödemeden herhangi bir zamanda bu yayını revize etme hakkını saklı tutar.

Telif hakkı

Telif 2001-2015Avolution Pty Ltd. Tüm hakları saklıdır.

Ticari Markalar

Avolution Pty Ltd Bu kılavuzda belirtilen şirket isimleri, ürün ve hizmetler hakkında marka bilgilerini sağlamanız için her türlü çabayı göstermiştir. Aşağıda gösterilen ticari markalar, çeşitli kaynaklardan elde edildi.

Microsoft, Windows, Access, Visio, Excel, SQL Server ve Internet ExplorerMicrosoft Corporation'ın ticari markalarıdır.

Genel Uyarı:

Bu kılavuzda kullanılan bazı ürün isimleri sadece tanıtım amaçlı kullanılmaktadır ve ilgili şirketlerin ticari markaları olabilir.

Aralık 2015Avolution ABACUS Sürüm Sürüm 4,5.

Manuel Revizyon 1.0

Oluşturulan baskılı ve Avustralya'da bağlı.


ABACUS Kurulum Öncesi Koşullar

Navigasyon: Referans>

ABACUS Kurulum Öncesi Koşullar

Yorum gönder bu konuda.

Visio İthalat ve Excel İthalat / İhracat İlişkin Bilgiler

ABACUS, Microsoft Office Excel İthalat / İhracat ve İthalat Visio işlemleri gerçekleştirmek için yüklü olmasını gerektirir. Doğrulayın Microsoft Office 2003 ya da daha yenidoğru takıldığından. Daha fazla sorun yaşarsanız, iletişim Avolution Destek .

Visio İthalat ve Excel İthalat / İhracat işlemleri gerçekleştirmek amacıyla, ABACUS, Microsoft Office Primary ınterop Assemblies (PIA) 'ın kullanır. ABACUS şu anda Excel İthalat / İhracat ve İthalat Visio gerçekleştirmek için gerekli meclisleri ile paketlenmiş olarak geliyor.

Bilgi İlişkin SQL Server alma

ABACUS gerektirir Microsoft SQL Server 2005 olduğunu2008, 2008 R2, 2012 veya 2014SQL Server itibaren yeni bir proje başlatmak için yüklenir. Doğrulayın Microsoft SQL Server 20052008, 2008 R2, 2012 veya 2014doğru takıldığından. Daha fazla sorun yaşarsanız, iletişim Avolution Destek .

Hatalar 3D Visualisations Açılış

ABACUS 3D Viewer sizin için işe yaramazsa, sen SlimDX DirectX Runtime (tam ABACUS EXE parçası olarak yüklemek kurulu) eksik olabilir. Bu indirilebilir İşte . Windows'un 64 bit sürümüne sahipseniz, ayrıca yüklemeniz gerekebilir bu .

Hatalar Kurgu ABAKÜS Görenek Raporlar

Düzenleme ABACUS 'Özel Raporlar Rapor Oluşturucu 3.0 yüklü olması gerekir. ABACUS ve Report Builder Microsoft'un .NET Framework 4.0 üzerine inşa edilir ve her ikisi de Microsoft'un .NET Framework 3.5 gerekmez iken, Microsoft, yanlış Microsoft'un .NET Framework 3.5 yüklü değilse, sadece devam etmek Report Builder MSI yapılandırdı.

Buna göre, Avolution Microsoft'un .NET Framework 3.5 gerektirmez Rapor Oluşturucu yükleme MSI dosyasının düzenlenmiş sürümüne sahip bu indirilebilir İşte .

Orijinal Microsoft Report Builder MSI indirebilirsiniz İşte . Eğer zaten gerektirecek olan Microsoft .NET Framework 3.5 yoksa, sen indirebilirsiniz İşte . Not: Birden kurulumlar için, çevrimdışı Microsoft'un .NET Framework 3.5 yüklemek İşte daha uygun olabilir.


Geri al ve Yinele

Navigasyon:> Ekstra seçenekler> Mimarinizi doldurma el doldurmamak>

Geri al ve Yinele

Yorum gönder bu konuda.

Birçok modern uygulamalar gibi, ABACUS hem geri almak ve açık projeye yapılan son kullanıcı değişiklikleri yinelemek için yeteneğini destekler. En son değişikliği geri almak için, sadece geri alma komutunu etkinleştirmek. Kokan komutunu aktive ederek redone edilebilir geri edilmiştir değişiklikler; yeniden uygulayarak en son geri değişikliği.

Uyarı

Daha fazla değişiklikleri geri varlık beri projeye yapılırsa yapılmamış değişiklikler uygulanamayacağı mümkün değildir.

Not

Değişikliklerin büyük çoğunluğu geri desteği olsa da / gerçek zamanlı olarak bazı yinelemek diyagram Böyle bir yeni Type-Shape / Hat derneği oluştururken veya bir dernek renk niteliğini değiştirmek gibi şablon değişiklikler, derhal geri alınması mümkün değildir. Bu değişiklikler geri alınabilir önce bu durumlarda, (bir yıldız işareti ile belirtilir) modifiye Diyagramı kapalı olmalıdır.

Geri al ve komut yerleri Redo

Geri alma ve yineleme komutları üç farklı yerlerden erişilebilir:

· Düzen menüsü

· Standart araç çubuğu

· Klavye kısayol tuşları CTRL + Z tuşlarına(geri) ve CTRL + Y(yineleme)

Bahşiş

Geri alma ve standart araç çubuğundaki düğmeleri kokan geri alınabilir ve sırasıyla redone 10 en son değişiklikleri görüntüleme açılan listeleri sağlar. Onlar da / geri seferde birden fazla değişiklik yinelemek için kullanışlı bir yoldur.


Makroları Kullanma

Navigasyon: Mimarinizi benzetme>

Makroları Kullanma

Yorum gönder bu konuda.

Eğer ABACUS'e defalarca bir görevi gerçekleştirmek, bir makro kullanarak görevi otomatik hale getirebilirsiniz. Buna göre, bir ABACUS makro herhangi bir zamanda tekrar edilebilir operasyonların kaydedilmiş serisidir.

Makro kaydetme

1. Seçin Araçlar | Kayıt Makroya da seçenek olarak basın Alt + F10.

2. Kaydetmek istediğiniz işlemleri gerçekleştirmek başlayın.

Uyarı

Şu anda, makro kayıt ile bazı bilinen sorunlar vardır. Makrolarınızı kaydederken dikkate bu alınız:

· Şu anda sadece Microsoft Windows tuş vuruşlarını, fare hareketleri ve fare-tıklama kayıt makroları. Ancak, makro kaydedici kendisi kısıtlamaları nedeniyle, her zaman kaydedilmez bazı tuş vuruşlarını vardır. Bunlar şunları içerir:

· [Tab]

· [Ctrl]

· [Alt]

· [ESC]

· [Başlat]

· Için [F1] [F12]

· Bu nedenle, bir klavye kısayolu bu klavye kısayolu çalışma bağlı olabilir olayların büyük bir dizisini kaydetmeden önce makro kaydedici tarafından kaydedilen olduğunu doğrulamak önerilir.

· Onlar makro kaydedici tarafından kaydedilen bir eylem tarafından açıldığında Şu nedeniyle makro kaydedici ile sınırlamaları, bağlam menüleri ABACUS'te düzgün işlenmez. Bir bağlam menüsünü açtığınızda, bağlam menüsü aracılığıyla bağlam menüsünde listelenen işlevlerinden biri gerçekleştirmelisiniz aksi bağlam menüsünü ABACUS'te hatalara neden olabilir istenmeyen eylemler veya eylemlere yol açabilir, oynatma sırasında açık kalabilir.

· Bağlam menüsünü kapatma normal yöntemlerine dikkat edin (örn klavye veya [Esc] tuşuna basarak sol tıklayarak başka bir yere ekranda) aslında bir makro oynatma sırasında bağlam menüsünü kapatmak olmayabilir.

Bahşiş

Diyaloglar yerine fare tıklama kullanarak yerine, / de-select çek seçmek için açılan menü öğelerini veya radyo düğmesi seçenekleri ve Uzay çubuğunu seçmek için kullanılabilir denetimler ve İmleç tuşları ile hareket etmek Sekme tuşunu kullanmanız tavsiye edilir kutuları.

Makro Kaydı durdurmak için

1. Basın Alt + F9veya alternatif Araçlar | Makro Dur.

2. Bir konuma iletişim gözatarak Kaydet Makro ve ABACUS makro (.abacusmac dosyası) dosya seçin ve Kaydet seçeneğini tıklatın.

Not

Kullanımı Araçlar| Makro Durkaydedilen makro bu işlemi içerecektir. Bu nedenle, kullanıcıların makroları kendilerini istenmeyen makro operasyonları dahil etmemek için makrolar ile çalışmak için Alt + İşlev tuşu seçeneklerini kullanarak yetkin hale önerilir.

Bahşiş

Makro anda düzenlenebilir değildir gibi Alt + F10 / ALT + F9 'çiftleri' kullanılarak ayrı makrolar bir dizi olarak uzun görevleri kaydetmek için tavsiye edilir.

Kaydedilmiş bir makro Oynatma için

1. Seçin Araçlar | Oynatma Makroya da seçenek olarak basın Alt + F8.

2. Bir yerde açık Makro iletişim gözatarak ve bir ABACUS makro (.abacusmac dosyası) dosya seçin ve Aç'ı tıklatın.

Uyarı

Bir ABACUS makro açarken açmak için Gözat iletişim kutusunda bir makro dosyasını çift tıklatın, eğer makro kaydedici kaydedilmiş bir sol tıklama geçersiz kılma bu durum kadar sol tıklandığında durumda sol fare tuşunu basılı tutun olabilir.

Not

Makro oynatma hızı Genel sekmesinin altında ayarlanabilir Araçlar| SeçeneklerNormal (varsayılan), Hızlı veya Yavaş ya da. Sırasıyla, yaklaşık 100 kat ve 1/100 gerçek zamanlı olarak kaydedilen makro tekrar olacak hem hızlı ve yavaş oynatma hızları tavsiye edilmez. Tavsiye edilir, böylece herhangi bir uzun işlem görevleri sonra kısa bir süre için duraklatmak için kayıt oynatma o işleme görevi vardır önce sonraki işlem yürütülmez sağlamak için ise normal oynatma hızı hala kaydedilen hızından daha yaklaşık% 30 daha hızlı makro tekrar edecek tamamladı.

Bir kaydedilmiş makro oynarken durdurmak için

1. Basın Alt + F9.


3D diyagramı görüntüleme

Navigasyon: senin mimarisi analiz> 3D diyagramları>

3D diyagramı görüntüleme

Yorum gönder bu konuda.

ABACUS bileşen ve bağlantı özellikleri renkler, şekiller ve boyutlarda ile ilişkili bir 3B görünümünde olarak mimari görüntülemenize olanak sağlar.

Senin mimari 3D görünüm görüntülemek için

1. Eğer varsa emin olun ABACUS dosyasını açınsizin yanınızdaki içeren nüfuslu mimari.

2. Expand GörünümlerAğacın dalı.

3. Expand 3DAğacın dalı.

4. Çift tıklama görselleştirme Açmak istediğiniz.

- veya -

1. Eğer varsa emin olun ABACUS dosyasını açınsizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| 3Dveya araç çubuğu düğmesini tıklatın.

3. Aç bir mevcutgörselleştirme (.abacus3d)

- veya -

1. Eğer varsa emin olun ABACUS dosyasını açınsizin yanınızdaki içeren nüfuslu mimari.

2. Seçin Ekle| 3Dveya araç çubuğu düğmesini tıklatın.

3. Yeni görselleştirme oluşturun:

· Seçin MimarlıkEğer açılan menüden görüntülemek istediğiniz.

· Seçin Bileşenler ve BağlantılarEğer gelen şemada dahil etmek istediğiniz Standart eleman seçimi penceresi .

· Ortak renkler, şekiller ve boyutlarda ile Bileşen Türleri ve Özellikler.

· Ortak renkler ve şekiller ile Bağlantı Tipleri ve Özellikler.

3D görünüm vermek için

1. Eğer varsa emin olun Varolan 3D görünümünü açmak.

2. 3D görünümün açılan menülerden seçmek Dosya | İhracat...ve (.vrml, .abacus3d veya .html) görselleştirme dosyasının konumu ve dosya türünü seçtim.

3. Tıklayın Kaydet.

Ayrıca bakınız

Senin mimarisi analiz | 3D Navigasyon | Diyagram Aracı


Bir kabarcık grafiği görüntüleme

Navigasyon: senin mimarisi analiz> Özel çizelgeleri>

Bir kabarcık grafiği görüntüleme

Yorum gönder bu konuda.

Bir kabarcık grafiği tek bir görünümde 5 boyutları (yani X, Y, kabarcık boyutu / yarıçap, kabarcık renk ve kabarcık sınır renk) kadar karşılaştırmanızı sağlar.

Bir kabarcık grafiği görüntülemek için

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Seçin Ekle| Grafik| Özel Grafiklertab | Kabarcık Grafik.

3. İçinde Mimarileribölümünde, grafik istediğiniz (varsa), ardından mimarileri kene Sonraki.

4. Seçin Bileşenler ve Bağlantılarsizden (varsa) grafikte istediğiniz Standart eleman seçimi penceresi , Ardından Sonraki.

5. Seçin X koordinatımülkiyet, ardından Sonraki.

Not

Sadece Tamsayı, Ondalık, Tarih / Saat, Boole ve Liste özellikleri X-ekseni için kullanılabilir. Ayrıca, Integer, Ondalık ve Tarih / Saat özelliklerini soldan sağa çizilen özelliğinin değerine göre ölçekli eksen boyunca, ancak mantıksal ve Liste özellikleri sadece çizilir tam sırası sağa sola (ya da bakılmaksızın değerlerinin özellik için tanımlanan sırasını tersine çevirmek için bu seçeneği işaretli ise ters sırayla). Örneğin Düşük | Orta | Yüksek ya da 1, 2, 4, 8, 16.

6. Seçin Y-eksenimülkiyet, ardından Sonraki.

Not

Sadece Tamsayı, Ondalık, Tarih / Saat, Boole ve Liste özellikleri Y-ekseni için kullanılabilir. Ayrıca, Integer, Ondalık ve Tarih / Saat özelliklerini özelliğinin değerine göre ölçekli eksen boyunca dip-üst çizilir, ancak mantıksal ve Liste özellikleri sadece kesin sırayla dibe-üst çizilir (ya da vardır bakılmaksızın değerlerinin özellik için tanımlanan sırasını tersine çevirmek için bu seçeneği işaretli ise ters sırayla). Örneğin Düşük | Orta | Yüksek ya da 1, 2, 4, 8, 16.

7. Seçin kabarcık boyutu / yarıçapmülkiyet, ardından Sonraki.

Not

Sadece Tamsayı, Ondalık, Boolean ve Liste özellikleri Kabarcık büyüklüğü / yarıçapı için kullanılabilir. Ayrıca, tamsayı ve ondalık özellikleri özelliğinin değerine göre ölçekli bir kabarcık boyutu / yarıçap neden, ancak mantıksal ve Liste özellikleri ters düzen varsa veya tam sırası kabarcık boyutu / yarıçap eşit adım artar (neden sırasını tersine çevirmek için bir seçenek olursa olsun değerlerinin özellik için tanımlanan) kontrol edilir. Örneğin Düşük | Orta | Yüksek ya da 1, 2, 4, 8, 16.

8. Seçin ya Sabit kabarcık renk veya kabarcık renkli bir özellik ilişkilendirmek, Ardından Sonraki.

Not

Sadece Tamsayı, Ondalık, Boolean ve Liste özellikleri Kabarcık renk için de kullanılabilir. Ayrıca, tamsayı ve ondalık özellikleri özelliğinin değerine göre ölçekli seçilen aralığında bir baloncuk rengi neden, ancak mantıksal ve Liste özellikleri için tanımlanan kesin sırayla seçilen aralığında kabarcık renk eşit adım artar sebep bakılmaksızın değerlerinin özellik. Örneğin Düşük | Orta | Yüksek ya da 1, 2, 4, 8, 16.

9. Seçin ya Hiçbir kabarcık sınır rengi veya kabarcık sınır renkli bir özellik ilişkilendirmek, Ardından Finish.

Not

Sadece Tamsayı, Ondalık, Boolean ve Liste özellikleri Kabarcık sınır renk için de kullanılabilir. Ayrıca, tamsayı ve ondalık özellikleri özelliğinin değerine göre ölçekli seçilen aralıkta bir kabarcık sınır rengi neden, ancak mantıksal ve Liste özellikleri belirlenmiş kesin sırayla seçilen aralığında kabarcık sınır rengi eşit adım artar sebep bakılmaksızın değerlerinin özelliği. Örneğin Düşük | Orta | Yüksek ya da 1, 2, 4, 8, 16.

Kabarcık grafik

Bir kabarcık grafiği kaydetmek için

Not

Onlar sadece mevcut proje içinde tek bir mimari olmalıdır bunların tümü bileşenleri ve bağlantıları içeriyorsa Kabarcık grafikleri yalnızca kaydedilebilir.

1. Eğer yeni veya mevcut kabarcık grafiği olduğundan emin olun açıkve gerekli değişiklikleri yaptık.

2. Grafik araç çubuğunda en soldakinden tıklayın Kaydet Grafikdüğme grafiği ve herhangi bir biçimlendirme değişiklikleri kaydetmek için.

3. İçinde Grafik Adıkabarcık grafik ve basın için bir isim girin Açılan iletişim tamam.

Bir kabarcık grafiği vermek için

1. Eğer varsa emin olun Varolan kabarcık grafiği açmak.

2. 2nd grafik araç çubuğu tıklamayla soldan BMP Kaydetdüğmesi ve grafik için yeri seçti.

3. Tıklayın Kaydet.

Ayrıca bakınız

Senin mimarisi analiz


Bir yetenek uzay grafiği görüntüleniyor

Navigasyon: senin mimarisi analiz> Özel çizelgeleri>

Bir yetenek uzay grafiği görüntüleniyor

Yorum gönder bu konuda.

Bir Yeteneği Uzay grafik senin mimari sistem gereksinim analizi sürecinde belirlenen özelliklerine göre gerekli sistem yeteneği yerine getirip getirmediğini görüntülemenizi sağlar.

Bir yetenek uzay grafiği görüntülemek için

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimariVe sahip oldukları değerlendirilirsenin mimarisi.

2. Seçin Ekle| Grafik| Özel Grafikler| Yetenek Uzay. ( Yetenek Uzay Grafik Yapılandırmailetişim gösterecektir.)

3. İçinde Mimarileribölümünde, grafik isteyen mimarileri kene, ardından Sonraki.

4. İçinde ÖzelliklerAlan, sen grafik eksenleri olarak dahil edilmesini istediğiniz mimari özelliklerini işaretleyiniz.

5. İçinde KabiliyetHerhangi bir Minimum veya maksimum kapasitesi sınırları vardır ve bu sınırlar değerleri olsun alanı, önceki adımdaki dahil her özellik için seçin. Varsayılan değerler mimarileri veya değerlendirildi minimum ve maksimum değerler Emlak hedefi eğer kurulmuştur.

Bir yetenek uzay grafiği vermek için

1. Eğer varsa varolan olun yetenek uzay grafiği açık.

2. Grafik araç çubuğunda en soldakinden tıklayın BMP Kaydetdüğmesi ve grafik için yeri seçti.

3. Tıklayın Kaydet.

Ayrıca bakınız

Senin mimarisi analiz | Bir tepki süresi grafiği görüntüleniyor


Standart Raporlar

Navigasyon: senin mimarisine Raporlama>

Standart Raporlar

Yorum gönder bu konuda.

ABAKÜS' standart raporları, mimarileri bir veya daha fazla bileşen ve bağlantılarının listesini elde edilmesine olanak sağlamaktadır. Rapor bileşen veya hiyerarşi, tip, standartlar, açıklama, özellikleri ve eklerinde bağlantının yere bilgiler de dahil olmak üzere seçilen bileşenlerin ve bağlantıların, ilgili tüm bilgileri içermektedir.

Not

Rapor içeriği olduğunuyapılandırılabilirRapor Seçenekleri iletişim aşağıda açıklanan yoluyla, ancak, to nasıl oluşturulacağı hakkında daha fazla bilgi edinmek tamamen yapılandırılabilir özel RaporlarABACUS Özel Raporları kullanarak, Lütfen konuya bakın İşte veya temas Avolution Destek .

Bir görüntülemek için standart rapor

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimari(s).

2. Seçin Ekle| Standart Raporuya tıklayın Standart Rapor Oluştur araç çubuğu düğmesi. Rapor Yapılandırmapenceresi görüntülenir.

Rapor yapılandırma penceresi

3. Seçin Mimarileri, Bileşenler ve BağlantılarEğer gelen raporda istediğiniz Rapor Yapılandırma Penceresi.Standart Eleman Seçme bakın İşte Yardım için konu.

4. Şimdi tıklayın Seçeneklerdüğmesi ve Rapor Seçenekleripenceresi görüntülenecektir.

Rapor Seçenekleri penceresini

5. Bir görüntülemeyi seçebilirsiniz Her Elemanı için yeni sayfa, Baskı Tarihi, Baskı Zamanı, Sayfa Numaralarıve ister başlığında başlığıİlgili onay kutularını unticking / işaretleyerek raporun. Ayrıca düzenleyerek başlığı ve yazarı özelleştirmek isteyebilirsiniz Rapor Başlığı ve Yazar metin kutuları. Ayrıca altındaki onay kutularını unticking / işaretleyerek rapora görüntülenen hangi içeriği seçebilirsiniz Rapor İçeriğiPencerenin bölümü. Bitirdikten sonra tıklayın tamam.

6. Şimdi tıklayın FinishRapor Yapılandırma penceresinde.

Görüntülenebilir raporunu yorumlamak için

Kısa açıklamalar ile Örnek Oluşturulan Rapor

Rapor sayfalarında gezinin için simgeleri tıklayın [image] Ekranın sol üst köşesinde araç çubuğunda bulunan.

Not

Yapabilirsin kurtarmak rapor çeşitli biçimlerde üzerine tıklayarak İhracat Rapor simgesi [image] yer içinde Araç çubuğu. Aşağıdaki biçimlerde dışa seçebilirsiniz: Excel, PDF ve Kelime. Daha sonra kullanılmak üzere istenen konuma raporu kaydetmek edin. Değişiklikler daha sonraki bir aşamada mimari yapılırsa, yeni bir rapor değişiklikleri yansıtacak şekilde oluşturulmuş gerekecektir.

Ayrıca bakınız

Senin mimarisi analiz


Bir tepki süresi grafiği görüntüleniyor

Navigasyon: senin mimarisi analiz> Özel çizelgeleri>

Bir tepki süresi grafiği görüntüleniyor

Yorum gönder bu konuda.

Bir tepki süresi grafiği size bağlantıları (yani kendi tarihine içinde) gerekli oranda işleniyor olmadığını görmenizi sağlar.

Bir tepki süresi grafiği görüntülemek için

1. Bir olduğundan emin olun ABACUS dosya açma sizin yanınızdaki içeren nüfuslu mimariVe sahip oldukları değerlendirilirsenin mimarisi.

2. Seçin Ekle| Grafik| Özel Grafikler| Tepki Süresi. ( Tepki Süresi Grafiği Yapılandırmailetişim gösterecektir.)

3. Gönderen Mimarileriaşağı açılan listesinde, sen grafik istediğiniz mimariyi seçin.

4. İçinde Bağlantılaralan Grafikte dahil edilmesini istediğiniz bağlantıları işaretleyin.

5. Ölçek TürüAlan seçin DoğrusalEğer doğrusal bir ilerleme olarak görüntülenecek dikey eksen (tepki süresi) - isterseniz zamanın her parçası ekseni eşit pay tahsis edilir. Seçin Logaritmikİsterseniz bir logaritmik ilerlemesi olarak görüntülenen - ekseninin her segment gitmek eksenin daha yukarı zamanın giderek daha uzun süre temsil eder. (Artış oranı ile belirlenir BazEğer seçin.)

Tepki süresi grafiği dikey eksen ölçeği

Bir tepki süresi grafiği vermek için

1. Eğer varsa varolan olun tepki süresi grafiği açık.

2. Grafik araç çubuğunda en soldakinden tıklayın BMP Kaydetdüğmesi ve grafik için yeri seçti.

3. Tıklayın Kaydet.

Ayrıca bakınız

Senin mimarisi analiz | Bir yetenek uzay grafiği görüntüleniyor


Senin gelişti mimarileri bir dağılım grafiğini görüntüleme

Navigasyon: senin mimarisi analiz> Özel çizelgeleri>

Senin gelişti mimarileri bir dağılım grafiğini görüntüleme

Yorum gönder bu konuda.

Bir mimari gelişmiş ve hedefleri tanımlandıktan sonra, o zaman görüntülendi ve saçılım matrisleri kullanarak özgün mimarisi ile mukayese edilebilir. Bu bölüm oluşturmak ve saçılım matrisi özelliklerini anlamak için nasıl özetliyor.

Senin gelişti mimarileri bir saçılım Matrix görüntülemek için

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Eğer varsa emin olun gelişti ve hedefler belirlemeksenin mimarisi altında belirtilen Senin mimarisi Gelişen

3. Seçin Ekle| Grafik| Özel Grafiklertab | Saçılım Matrix.

4. Tıklayın Finishdüğmesine basın.

5. Dağılım grafiğimimarileri ve hedefleri belirlenmiş evrimi ile görüntülenir.

Not

Saçılım matrisinin sol taraftaki alanda görüntülenen saçılım matrisinin ayarlarını gösterir. Bu, bu durumda evrim olmuştur mimarisi (içerir "ABC Ltd As-Is 2010") Yanı sıra bu mimarisi için ayarlanmış olan hedefler. Bunu unutmayın ki onları saçılım matrisi X ve Y eksenleri olarak temsil edilmektedir yanında onay işareti olan hedefler (örneğin KPI- Maliyet, KPI - Kalite ve KPI - Zaman). Sen saçılım matrisinin bunları kaldırmak için zaman herhangi bir noktada bu hedeflere işaretini kaldırın olabilir.

Matris içinde senin arsa üzerinde görünen mavi noktalar normalize değeri temsil, iyi ve en kötü değere göre belirlenen (altında açıklanan Senin gelişti mimarisi için hedefler belirleyerek ). Bu değerler, bir yer almaktadır Kalite Uzay.

İki tanımlanan hedefler bir saçılım matrisi içinde birbirine karşı karşılaştırılır ve tüm hedefleri karşılaştırıldı kadar işlem tekrarlanır (örn yukarıdaki şemada matrisin ilk arsa karşılaştırır KPI - Maliyetile hedef KPI - Kalite hedef. Ikinci Maliyet e karşı Zaman ve son komplo olduğunu Kaliteli e karşı Zaman. İlgili hedef etiketleri üst ve sağ veya parsellerin her satır gösterilir.).

6. Seçin Mimarileriradyo düğmesi bireysel mimariler ölçümlerini görüntülemek isterseniz.

7. Seçin EvrimOrijinal mimarisi normalize değişiklikleri görüntülemek isterseniz radyo düğmesi (örn As-Is 2010) Evrimleşmiş mimarisi (ler) (örneğin Strateji A ve 2011 To-Be - 2011 - To-Be Strateji B).

Ayrıca bakınız

Senin mimarisi analiz | Bir tepki süresi grafiği görüntüleniyor | Senin gelişti mimarileri bir yıldız arsa görüntüleme | Senin mimarisi Gelişen


Standart bir grafik görüntüleme

Navigasyon: senin mimarisi analiz> Standart çizelgeleri>

Standart bir grafik görüntüleme

Yorum gönder bu konuda.

ABACUS 'standart çizelgeleri hattı, bar, sütun, alan, dağılım, pasta, eğri, Pareto, adım, yüzey, radar, küp, çörek, piramit, kontur ve eğri alan grafikler yer alıyor. İstediğiniz grafik türünü seçtikten sonra, bu grafikler her görüntüleme için sürecin geri kalanı aynıdır.

Senin mimari standart bir grafik görüntülemek için

1. Eğer varsa emin olun ABACUS dosyasını açınsizin yanınızdaki içeren nüfuslu mimariVe sahip oldukları değerlendirilirsenin mimarisi.

2. Seçin Ekle| Grafikveya araç çubuğu düğmesini tıklatın. Grafiklerpenceresi görüntülenir.

Grafikler penceresi

3. İstediğiniz grafik türünü seçin ve Grafik Seçenekleri ayarlayın, ardından Sonraki.

Grafik Seçenekleri

o Yığılmıştek tek öğelerin arasındaki ilişkiyi gösterir. Eğer toplam vurgulamak istediğiniz zaman çoklu veri serilerini (yani birden fazla özellikler) ve sahip olmak planlarken bir yığılmış grafik kullanabilirsiniz.

o Yığılmış% 100Her değer kategoriler arasında toplam katkıda yüzdesini karşılaştırmak olacaktır. Birden fazla veri serisi (yani birden fazla özellikler) sahip planlıyorsanız ve toplam her eleman için aynı, özellikle bütün katkıları vurgulamak istediğinizde% 100 yığılı grafik kullanabilirsiniz.

o 3D Grafiksadece estetik için 3-D formatında veri noktaları gösterecektir. Bir 3 / z ekseni boyut boyunca veri serisini göstermek istiyorsanız o zaman aşağıda açıklanan Küme Serisi seçeneğini kullanın.

o Mülkiyet tarafından Serisisonuçta seçilen her özellik için bir veri serisi gösterecektir. Bu işaretlenmemiş ise, özellikleri kategoriler olacak ve veri serileri seçilen her eleman için olacaktır.

o Döndür GrafikChart x ve y eksenlerini değiştirilerek tarafından saat yönünde 90 derece döndürür. Bu seçenek Hatları, Step ve Küp grafikler için kullanılabilirve aşağıdaki ikinci ucu ile tarif edildiği gibi Milestone grafikler yapmak için özellikle yararlıdır. Not: Sütun ve Çubuk grafikler zaten birbirlerine sürümleri 'döndürülmüş' vardır.

o Küme SerisiBir 3 / z ekseni boyutu boyunca birden fazla seri verilerini görüntüler. Bu seçenek Sütun için kullanılabilir, Bar ve Küp çizelgelerive aşağıdaki ucun tarif edildiği gibi Gantt tarzı grafikler yapmak için özellikle yararlıdır.

Bahşiş

Bir oluşturabilirsiniz Gantt şemasıBir Bar grafik türünü seçerek ve sonra Küme Serisi seçeneğini seçerek farklı elemanlar için saat / tarih özelliklerini gösteren yatay çubuklarla.Ayrıca, bir zamanlar oluşturulan grafik üzerinde en sol bar, çubuklardan birini sağ tıklayarak görüntülenen menüden Renk seçiminde ve paletten sol üst renk seçerek beyaz olarak boyama ile 'görünmez' yapılabilir. Ayrıca en soldaki çubuğu için sınır ... Properties seçerek çubuklardan birini sağ tıklatarak ve üstüne Yok ve Renk için Sınır Etkisi değişen görünür iletişim Seri sekmesinde 'görünmez' yapılabilir paletinden -Sol renk.

Bahşiş

Bir oluşturabilirsiniz Milestone grafikKüçük şekiller Küp grafik türünü seçerek farklı unsurları için tarih / saat özellikleri gösteren ve ardından Döndür Grafik seçip Küme Serisi seçenekleri ile.Ayrıca, bir zamanlar yaratılmış, küpler, belirli bir veri serisi içinde küp birini sağ tıklatıp Properties ... seçme ve Bar için Silindir veya Konik ya değişen görünür iletişim Seri sekmesinde diğer şekillerde değiştirilebilir . Not: Gap genişlik değeri de örtüşen azaltmak için grafik üzerinde 'küçültmek' sembolleri için kullanılabilir, yüksek sayı daha az örtüşen olacak.

4. İçinde Mimarileribölüm, mimari kene / sen, ardından mimarlık düzey özelliklerini grafik isteyen s Sonraki.

Not

Mimari düzey özelliklerini seçme tamamen isteğe bağlı bir adımdır ve açıkça mimari düzey özelliklerini kendileri grafik istediğinizde yalnızca kullanılmalıdır.Daha sonra, bir sonraki aşamada bileşen veya bağlantı özelliklerini dahil etmek için bir mimari seçilmesi gerekmez.

5. Seçin Bileşenler ve Bağlantılarsizden grafikte istediğiniz Standart eleman seçimi penceresi , Ardından Sonraki.

6. Seçin ÖzelliklerGrafikte ve tıklama istiyorum Finish.

Grafik Seçenekleri

o Standart özellikleri şunlardırirade Seçim için mevcut Standartlar miras özellikleri gösterir.

o Agrega Özellikleriirade dizi değerleri arasındaki varyansı saymak ve bireysel kendilerini değerleri aksine bu sonuçlar grafik.Mülkiyet seçeneği Serisi yukarıdaki 3. adımda seçtiğiniz eğer bu seçenek kullanılabilir.

Bahşiş

Dövüşüyorsa için kullanılabilir özellikler seçtiğiniz unsurların bağlıdır.

Bir grafiği kaydetmek için

Not

Onlar sadece mevcut proje içinde tek bir mimari olmalıdır bunların tümü bileşenleri ve bağlantıları içeriyorsa Grafikler yalnızca kaydedilebilir.

1. Eğer yeni veya mevcut grafiği olduğundan emin olun açıkve gerekli değişiklikleri yaptık.

2. Grafik araç çubuğunda en soldakinden tıklayın Kaydet Grafikdüğme grafiği ve herhangi bir biçimlendirme değişiklikleri kaydetmek için.

3. İçinde Grafik Adıgrafik ve basın için bir isim girin Açılan iletişim tamam.

Bir grafik vermek için

1. Eğer varsa varolan olun grafik açık.

2. 2nd grafik araç çubuğu tıklamayla soldan BMP Kaydetdüğmesi ve grafik için yeri seçti.

3. Tıklayın Kaydet.

Ayrıca bakınız

Senin mimarisi analiz | Bir tepki süresi grafiği görüntüleniyor | Bir yetenek uzay grafiği görüntüleniyor


Senin gelişti mimarileri bir yıldız arsa görüntüleme

Navigasyon: senin mimarisi analiz> Özel çizelgeleri>

Senin gelişti mimarileri bir yıldız arsa görüntüleme

Yorum gönder bu konuda.

Bir mimari gelişmiş ve hedefleri tanımlandıktan sonra, o zaman görüntülendi ve yıldız araziler kullanarak özgün mimarisi ile mukayese edilebilir. Bu bölüm oluşturmak ve bir yıldız arsa işlemek için nasıl özetliyor.

Senin gelişti mimarileri bir yıldız grafiğini görüntülemek için

1. Bir olduğundan emin olun ABACUS dosya açma .

2. Eğer varsa emin olun gelişti ve hedefler belirlemeksenin mimarisi altında belirtilen Senin mimarisi Gelişen

3. Seçin Ekle| Grafik| Özel Grafiklertab | Yıldız Arsa.

4. Tıklayın Finishdüğmesine basın.

5. Yıldız Arsave gelişmiş mimarileri gol görüntülenir ayarlayın. Not: Yıldız arsa eksenleri tıklayıp yıldız arsa kalite alanı sınırları içinde başka bir bölgeye eksenleri sürükleyerek yeniden konumlandırılmış olabilir.

Not

Yıldız arsa sol taraftaki alanda görüntülenen yıldız arsa ayarlarını gösterir. Bu, bu durumda evrim olmuştur mimarisi (içerir "ABC Ltd As-Is 2010") Yanı sıra bu mimarisi için ayarlanmış olan hedefler. Bunu unutmayın ki onları yıldız arsa eksenleri olarak temsil edilmektedir yanında onay işareti olan hedefler (örneğin KPI- Maliyet, KPI - Kalite ve KPI - Zaman). Sen yıldız arsa bunları kaldırmak için zaman herhangi bir noktada bu hedeflere işaretini kaldırın olabilir.

Yıldızını arsa üzerinde görünen kırmızı ve yeşil "nokta" normalize değeri temsil, iyi ve en kötü değere göre belirlenen (altında açıklanan Senin gelişti mimarisi için hedefler belirleyerek ) Seçilen üst düzey mimarisi ve onun herhangi bir evrimler için. Bu değerler, bir yer almaktadır Kalite Uzay.

Yukarıdaki resimde belirtildiği gibi, açıkça görülebilir özgün mimarisi (As-Is 2010) Kötü vardır Maliyet, Birinci gelişti seçeneği (2011 To-Be - Strateji A) Artırmak için kalite alanı içinde taşındı Maliyet, Kalite ve Zamangol. Alternatif olarak, ikinci seçeneği gelişti (To Be 2011 - Strateji B) aynı zamanda geliştirilmiş iken Maliyet iyileştirme büyüklüğü daha azdır Strateji A ama hem kalite ve Zaman hedefleri Strateji A. ile daha geliştirilmişBu durumda mimar olarak Mayıs seçmek Strateji Aüzerinde Strateji BOnların öneri olarakve bundan başka seçeneği gelişmeye (2012 To-Be - Strateji A).

6. Işaretini kaldırın Göster EvrimOrijinal arasındaki evrimi (ler) temsil eden çizgi (ler) gizlemek için onay kutusunu (örneğin As-Is 2010) Ve gelişti (ör To Be 2011 - StratejiA) mimarisi (lar).

7. Seçin Göster Sticksher bir kalite özelliğinde göreceli büyüklüğünü her mimari için (her eksen üzerinde tanımlanmış hedeflere) görüntülemek için kutuyu işaretleyin.

8. Seçin Göster Mimarlık İsimlerEğer yıldız arsa üzerinde görünmesini özgün ve evrimleşmiş mimarisi (ler) in isimleri istiyorsanız onay kutusunu işaretleyin.

Ayrıca bakınız

Senin mimarisi analiz | Bir tepki süresi grafiği görüntüleniyor | Senin gelişti mimarileri bir saçılım matrisi görüntüleme | Senin mimarisi Gelişen


Senin mimarisi analiz

Navigasyon: senin mimarisi analiz>

Senin mimarisi analiz

Yorum gönder bu konuda.

Eğer mimarisi doldurulur (ve isteğe bağlı olarak simüle) sonra, bunu analiz etmek ABACUS kullanmaya hazır. Senin mimari ihtiyaçlarınızı karşılayacak eğer analiz ederek, belirleyebilirsiniz.

Farklı şekillerde çeşitli Mimarinizi analiz edebilirsiniz:

· Diyagram

· 3D görünüm

· Standart grafikler (pasta, vs. satır, sütun, çubuk,)

· özel çizelgeleri ( Tepki Süresi , yetenek alanı , Yıldız arsa , saçılım matrisi ve kabarcık grafiği )

· Mimarlık Diff

Not

Bir diyagramı yaratmak 3D görünümRapor veya standart grafik, Standart eleman seçimi penceresi Görüntülemek istediğiniz öğeleri seçmek için kullanılır.

Ayrıca bakınız

Senin mimarisi doldurma | Senin mimarisi benzetme | Diyagram Aracı


Mimarlık nedir?

Navigasyon: ABACUS'e Giriş>

Mimarlık nedir?

Yorum gönder bu konuda.

Mimari bir soyut kavram- Fiziksel değil şey. Bileşenleri yakalama ve bağlı olduğunuz nasıl (etkileşim) - Bir sistemin yapısının zengin ve kapsamlı bir açıklama veya anlayış var. Mimarlık kavramı o kadar her şeyi kapsayan olduğundan, sistemin maliyeti, kullanılabilirlik, evolvability, açıklık ve performans için esastır. Bir ses mimarisi bir ses sistemi bir ön koşuldur.

ABACUS'e, sizin mimarisi modeli. Basitlik için, biz bu mimari model bir mimarlık diyoruz.

Aşağıdaki diyagram tipik mimarisini göstermektedir 5bileşenler (bir hiyerarşi içinde) 2 bağlantı ile bağlı. Etiketler ABACUS'e mimari çeşitli yerlerinde verilen isimler gösterir.

Basit bir mimari

ABACUS tüm bunları mimarinin bir parçası olarak görmektedir:

· Bileşenlersenin mimari varlıkları temsil hangi "şeyler" olarak tarif olabilir. Bir sigorta şirketi için bileşenler işleme politikaları, iddialar, ödemeler ve makbuzların sistemleri olabilir.

· BağlantılarBu bileşenlerin arasındaki ilişkileri gösterir. Örneğin, bir sigorta şirketi, makbuzlar geçerli politikalar için oluşturulan, iddiaların geçerli politikalarına karşı yapılır ve geçerli iddialar ödemeler sonuçlanır. ABACUS kullanırken özellikle - - mimari düşünürken bağlantıları bileşenleri kadar önemlidir ve bunlar hemen hemen aynı şekilde ele alınır.

· Ağacın her şey olabilir Özellikler. Özellikler gerçekleştirmek için sistem gerektiren yolu gibi şeylerdir, sahip olduğu kod satır sayısı, ABACUS tüm bu şeyler düşünüyor gibi yorum vardır bu satırların, yüzde mimarisinin bir parçası olmak.

· Kullanarak hiyerarşileri(yani alt bileşenler ve alt bağlantıları), Bilgileri gizleyebilirsiniz ve mimarisi de-oluşturur. ABACUS mimari model son derece esnektir. Herhangi bir düzeyde herhangi bir bileşeni herhangi bir düzeydeki herhangi bir bağlantı tarafından başka bir düzeyde başka bir bileşen ile ilgili olabilir.

· Eklentibu bileşenler bir işlemdir limanlar bağlantısına bağlananrolleri. Limanlar ve Roller arayüz vardırsbileşenleri ve bağlantıları arasında. Onlar bileşenlere bağlantıları eklemek için kullanılır. Bağlantıları Kaynak ve Evye var rol(lavabo bileşene kaynak bileşeninden kolaylaştırılması veri akışı)ve kavramsal bileşenleri bağlantı noktaları var. Yalınlık sağlamak için, ancak, ABACUS'te bileşen bağlantı noktaları gösterilmemiştir ve bağlantı rolleri ile doğrudan bileşenlerin kendilerine bağlıdır.

· Bileşenler ve bağlantıları belirli vardır Tip. Bu sınıflandırma amaçları içindir. Örneğin politikalar, iddialar, ödemeler ve makbuzlar türü 'Sistem' bileşenleridir. Geçerli politikalar, geçerli iddialar, vb türü 'İşlem' bağlantıları vardır. Bir bileşen veya bağlantı atanan Tip sahip olduğu özellikler ve standartlar için bir şablon sağlar. Örneğin, bir sunucu bileşeni türü var 'Marka ve Model' olabilir standartve bir IP Adresi özelliği. Özgürce kendi yeni türleri oluşturmak ve onlara kendi özelliklerinin kombinasyonları ve standartları atayabilirsiniz ABACUS'te temel bir ilişkisel veri tabanı (RDB) back-end, diğer katı araçları aksine.

· Özellikleri standart kütüphaneleri belirtilen ve mimaride başka bir şey atanabilir. Bu kütüphaneler şekilde bilinmektedir Standartlar. Kullanarak Standartlar, Yalnızca belirli sistem özellikleri toplamak gerekir - standart özellikler var zaten. Örneğin, Microsoft Windows 2000 standart performans özellikleri bileşenleri, Microsoft Windows 2000 işletim sistemi kullanıyorsanız ne olursa olsun atanabilir.

Ayrıca bakınız

Nasıl bir mimarlık ABACUS'te temsil edilir? | ABACUS'ün ne yapar? | Eğer (Genel) bunu nasıl | Yeni Tip oluşturma


Şirket Sunucusu ile Çalışma

Navigasyon: Yönetim>

Şirket Sunucusu ile Çalışma

Yorum gönder bu konuda.

ABACUS Kurumsal Sunucu Bir 'olmayan kilitleme' işbirlikçi yaklaşım, aynı zamanda bir 'bağlantısız' biri hem de. ABACUS çünkü o 'kilitsiz' olduğunu değil o güncelleştirilmesi için dosyayı zorla bir kullanıcı tarafından kilitlenmiş olması. Her kullanıcı dosyası kendi yerel kopyasını vardır ve onlar değişiklik yapmak ve dosyayı kaydedin olarak, bu değişiklikler kaydedilir ve kullanıcı sunucuya işlemek istediği zaman için saklanır.

ABACUS sunucuya bağlı veya bir dosya üzerinde çalışıyor iken ağ erişim ihtiyacı olması gerekmez anlamda 'bağlantısız' olduğu. , Güncelleme taahhüt veya geçmişte taahhüt günlüğünü görüntüleme - Bir dosya oluşturarak veya varolan dosya üzerinde operasyonlar ile birlikte, bir ödeme yapmadan gibi işlemleri yaparken ABACUS sadece sunucuya erişimi gerektirir. Sunucuya Access dosyası üzerinde çalışmak için gerekli, ve değişiklikler değil olmadığında hemen sunucuya gönderilen (bu bir hata yaparsanız kolayca değişiklikleri atmak için izin verir). Dosyanızı kaydettiğinizde, 'adil' tasarruf senin kopya Yerel - yerel değişiklikler sunucuya gönderilen (değişiklikler son tamamlama beri yapılan) olduğunu taahhüt kadar değil.

Yeni Kurumsal dosyası oluşturma

Yeni Kurumsal dosyası oluşturmak için seçin Dosya| Yeni ...ve daha sonra Enterprise Model bölümündeki ilk iki seçenekten birini seçin Yeni proje iletişim (yani ya boş Şirket dosyası, ya da mevcut bir ABACUS dosyadan bir tane oluşturun). Üçüncü seçenek başka zaten yarattı Enterprise dosyası birisi, bu sonraki bölümde ele alınacaktır 'Ödeme' etmektir.

Yeni Kurumsal dosyası oluşturmak için seçtiğinizde, size dosyayı saklamak istediğiniz yeri bir depo sunucuda gözatmak sağlayacak bir iletişim verilecektir. Ayrıca varolan dosya yolunu olacak ve New Project iletişim kutusundan 'Model Mevcut Kimden' seçti ve bir dosya sağlanan eğer isim kontör girdi.

URLBu ABACUS Kurumsal dosyalarının saklandığı deponuzu sunucu URL. Bu URL olması gereken sunucu yöneten kişiye sormalısınız.

Yukarıdaki resim bir depo ile gösterir Dört (4) URL'yi girerek ve girin bastıktan sonra, ABACUS Kurumsal projeleri mevcut. Sen Yeni Kurumsal dosyasını oluşturduktan sonra 'Ödeme' için bir sonraki ekran üzerinde, göreceksiniz, bu depo altında başka bir klasör ve dosya olacak.

Not

Bir https (SSL) sunucusu kullanıyorsanız ve sunucu nedeniyle intranet veya kamuya açık olmayan sunucular için ortak geçerli bir SSL sertifikası (yoksa SSL sertifikasının maliyetis) Almak için fazladan bir adım olacaktır. Kalıcı açılan iletişim bu sunucuya tüm bağlantıları kabul etmek gerekecektir (aynı zamanda sunucuda biraz daha fazla bilgi gösterecektir). Bunu yapmak için, yazın (tırnak işaretleri olmadan) 'p' ve Enter tuşuna basın. ABACUS iletişim göstermeden önce bunu size hatırlatan bir mesaj açılır.

Not

Sen kişidir ki bu durumda sunucuya giriş istenebilir sunucu yönetimiSunucu kullanıcı adınızı ve şifrenizi sağlayabilir. Ayrıca, kaydedilen bağlı herhangi sunucular için oturum açma kimlik bilgileri herhangi bir nedenle bu yolu ile yapılabilir temizlenmesi gerekir eğer öyleyse Araçlar | Seçeneklerve daha sonra Genel tıklayarak sekme Subversion Kayıtlı Üye Girişi Resetve açılan listeden ve tıklayarak sunucuyu seçerek Açık Oturum Açmave görünen iletişim kutusunda Tamam seçme.

Not

1'den fazla ABACUS Projesi, tek bir ABACUS Deposu oluşturulur ise, ABACUS değişim günlüğü numaraları tüm ABACUS Projeleri genelinde paylaşılır ve bu kullanıcıların şaşırtmak çünkü yukarıda gösterilen ekran aksine, genellikle tek bir ABACUS Projesi her ABACUS Repository dahildir.

Tercih Dosya Adı: Depo sunucusundaki dosya oluştururken bu (önceden alınmış değilse) kullanılacak klasör ve dosya adını etkiler. Yeni bir klasör her dosya için depo sunucuda otomatik olarak oluşturulur unutmayın (performans nedenleriyle, ABACUS'ün Kurumsal dosyaları iletişim için göz konuma altında kendi klasöründe oluşturulur).

Directory Çalışma Kopyala Mağaza: Enterprise dosyası bir depo sunucuda oluşturulduğunda, yerel çalışma dosyaları bilgisayarınızda oluşturduğunuz gerekir, bu yüzden ağa bağlı olmadan dosya üzerinde çalışabilirsiniz. Bu size açmak / yeniden açık bir ABACUS Kurumsal dosyasını istediğiniz zaman göz olacak yerdir.

Varolan Kurumsal Dosyası çıkış

Birileri yeni bir Kurumsal dosyası yarattı ise, yerel bir kopyasını indirir ve ABACUS bir Enterprise dosyası olarak algılar, böylece gerekli dosyaları kurar 'çıkış' Bu dosyayı, yapamam. Iletişim Yeni Kurumsal dosya iletişim benzer. Depo URL girin (alt dizinleri URL dahil edilebilir), istenen dosyayı seçin ve Tamam 'ı tıklatın. T altındaki nota tabio zaman açılacak dosya.

Not

Sen kişidir ki bu durumda sunucuya giriş istenebilir sunucu yönetimiSunucu kullanıcı adınızı ve şifrenizi sağlayabilir. Ayrıca, kaydedilen bağlı herhangi sunucular için oturum açma kimlik bilgileri herhangi bir nedenle bu yolu ile yapılabilir temizlenmesi gerekir eğer öyleyse Araçlar | Seçeneklerve daha sonra Genel tıklayarak sekme Subversion Kayıtlı Üye Girişi Resetve açılan listeden ve tıklayarak sunucuyu seçerek Açık Oturum Açmave görünen iletişim kutusunda Tamam seçme.

Kurumsal Dosya Farklar

(Ya bir yenisi veya başkası tarafından oluşturulan bir dosyanın 'ödeme' yoluyla), bir klasör dosyası oluşturulur ve yaygın dosyaları bu 3 ana tip içerecek Enterprise dosyasını oluşturduktan sonra:

· '.abacus' Dosyası- Bu ABACUS dosyası kendisidir. Değişiklikler yerel yapmak olmadığında Hemen bu dosyaya kaydedilir, sadece size taahhüt zaman yazılır. Bu dosya 'normal' ABACUS dosyası, non-EE kullanıcılara verilebilir(.log dosyası olmadan) tek başına bir proje olarakYa da yeni bir dosya EE başlangıç ​​noktası olarak kullanılabilir.

· '.changes' Dosyası- Dosyada yapılan yerel (kaydedilmemiş) değişiklikleri. Bu dosya eksikse, bu hiçbir yerel değişiklikler var demektir.

· '.kayıt dosyası- Bu dosyayı son kullanıcı (işledikleri kullanıcının .changes dosyanın içeriğini) tarafından yapılan sadece değişiklikler var.

Not

Güncelleme sırasında oluşturulan ve yani süreçleri işlemeye olabilir diğer çeşitli dosya vardır; ‘.changesbefore' dosya- Bir güncelleme gerçekleştirmeden önce değişiklikleri yapılmıştır ve otomatik güncelleme ve herhangi bir yerel (kaydedilmemiş) arasında herhangi bir kimlik çatışmaları uzlaştırmak için kullanıldıktan sonra bu dosya .changes dosyasının bir kopyasıdır; ‘.backup' dosya- Bir kullanıcı .changes dosyaya daha fazla yerel (kaydedilmemiş) değişiklikleri kaydeder önce bu dosya .changes dosyasının bir kopyasıdır; ve ‘.hata' dosya- Bu dosya .abacus dosyayı açmak için başarısız ABACUS kaynaklanan herhangi bir sorun olup olmadığını .changes bir kopyası dosya ve kullanıcı değişikliklerini geri seçti.Bu dosyalar göz ardı edilebilir.

Dosya açma

Bir dosyayı açmak için, yalnızca çalışma kopyasını depolamak ve orada saklanır ABACUS dosyayı açmak için seçtim nerede gözatmak gerekir. ABACUS bir olduğunu görünce .(log dosyası ve belki .Eğer değişiklik yaptıysanız değişikliklerin bir Kuruluş dosyası olarak tedavi edecek,) dosyası.

Dosya güncelleniyor

Sahne birBir dosyanın daha yeni bir sürümü sunucusunda bulunuyorsa n 'Güncelle' kontrol edecektir. Varsa, bu, mevcut dosyayı kapatın sunucudan yeni dosyaya güncellemek ve bir uzantısı olarak bir dizi var bazı geçici dosyaları indirmek olacak - örneğin 'Demo.125'. Bu dosyalar .log dosyasının eski sürümleri vardır ve son olarak güncellenen beri bir dosyaya yapılmıştır hangi değişikliklerin belirlemek için kullanılır. Bu onları çözebilirsiniz böylece oluşmuş olabilir herhangi bir çatışma tespit etmek için gereklidir.

Eğer Güncelleme işlemi sırasında herhangi bir çatışmalar bulundu, Sen tekrar dosyayı açmak için önce bunları çözmek gerekir (iptal edebilirsiniz ama Tekrar çatışmaları çözmek istenecektirEğer dosyayı açmak dahaki sefere).

Bir dosyayı kaydetme

Bir dosyayı kaydettiğinizde, bu .changes dosyaya yaptığınız değişiklikleri ekler. O değilBu aşamada .abacus dosyasını değiştirmek - dosya sunucusu (sunucudan bir güncelleştirme aldığınızda ya da) olacak bitti yazılması konusunda kararlıdır sadece.

'Farklı Kaydet' nerede?

Kurumsal dosyaları için Save As kavramı yok yoktur. Bununla birlikte, alışkanlık içinde yerel değişiklikler olduğunu akılda tutarak, dosyanın .abacus çalışma kopyasını kopyalayabilirsiniz.

Çözümleme Çatışmalar

Diğer kullanıcıların sizin için dosyanın benzer bir parçası dosyaya kaydedilmiş değişiklikler varsa, onların değişiklikleri ve sizin arasında bazı çatışmalar olabilir. Örneğin, başka bir kullanıcı vardı bir bileşen silebilirsiniz Bir özelliği güncelleştirmek. Onların gerektiği emin iseniz (kendi değişikliği geri almak için ya gerekdeğil (daha sonra tekrar dosyaya gidin ve değişim kokan olabilir)) oldu ya da değişikliği atmak var.

Özellikle oluşabilir çatışmaların 4 sınıfları vardır;

1. Silmek - Bir kullanıcı başka bir kullanıcı değişiklikleri bu bir nesneyi siler. Örneğin Kullanıcı A bileşeni silinmiş ama kullanıcı B bileşenin adını değiştirdi veya ona bağlı ya da vb bir çocuk bileşeni ekledi

2. Özellik - İki kullanıcıları hem bir nesnenin aynı 'özellik' değiştirdiğinizde. Örneğin Hem kullanıcı A ve B kullanıcısı bir bileşenin adını veya açıklamasını veya vb özelliklerinin birinin değerini değiştirdi

3. Referans - İki kullanıcı aynı 'referans' değiştirdiğinizde bir nesne başka bir nesne vardır. Örneğin Hem kullanıcı A ve B kullanıcısı bir bileşenin tipi veya kaynak / lavabo bileşeni şema vb bir bağlantı veya bağlantılı bakış bağlı değişti

4. Koleksiyon - İki kullanıcı bir nesne için bir 'toplama' değiştirdiğinizde. Örneğin Hem kullanıcı A ve B kullanıcısı başka bir ebeveynden bir bileşen taşınır ya da çocuk bileşenleri bir koleksiyon yeniden emretti.

Not

Çeşitli önemsiz çatışmalar otomatik kullanıcılar yükünü en aza indirmek için ABACUS'te çözümlenir.Örneğin diyagramları için çakışan pan-zoom ayarları son pan-zoom ayarları korumak için çözümlenir.

Değişiklikleri işlemek

Yaptığınız değişiklikleri işlemek için seçin ABACUS dosyası sunucudan açıldığında, kayıt yerel değişiklikler yapılmaktadır Buna karşı, ve sonra Yerel .abacus dosya içinde değişiklikleri vardır biri ile yazılır. Yaptığınız değişiklikler daha sonra dosya .log dosyasını üzerine yazar ve .abacus dosyası ve .log dosya hem de sunucuya gönderilir.Taahhüt başarılı olursa aşağıda gösterilen tamamlama ile bir mesaj girmek için sağlanan bir ileti diyalog Commit.

Değişikliklerin bir Oturum Görüntüleme

Karşı Bir değişiklik, bir günlüğünü görüntülemek Şirket projeSeçin Dosya| Günlüğü Görüntüle...

Maksimum Giriş Yazılar: Bu Son 10 girdileri için varsayılan olacaktır, ancak ek girişler değerini değiştirerek ve tıklayarak alınabilir Geri almak düğmesine basın.

Revizyon: The Revizyon sütun ters kronolojik sırayla, varsayılan olarak, Enterprise sunucusu taahhüt revizyon numaralarını listeler.

Not

Sadece ABACUS listelenir taahhüt eder aynı Subversion deposu diğer ABACUS projelerinin ve / veya diğer sürüm kontrol uygulamaları için kullanılan olabilir iken revizyon numaraları sürekli olmayabilir.

Tarih: The Tarih sütunu revizyon Şirket sunucusuna işlendiği tarihi listeler.

Zaman: The Zaman sütun revizyon Enterprise sunucusu kararlı olduğunu (24 saat biçiminde) günün saatini listeler.

Yazar: The Yazar sütun tarafından takip tamamlama gerçekleştirilen kullanıcı için Microsoft Windows oturum açma adını listeleyen onların ABACUS kullanıcı adı Ya da 'Anonim' kullanıcı kimlik doğrulaması ve anonim kullanıcılar taahhüt anda Kurumsal projeye izin verilmiştir eğer.

Log Mesajı: The Günlüğü Mesaj sütun yukarıda gösterilen iletişim başı olarak revizyon ile sağlandı tamamlama mesajı listeler.

İndir revizyon XX tek başına ABACUS dosyası olarak: Tabloda verilen revizyon seçin ve ardından Yükle düğmesini tıklatın Eğer sunucudan seçilen ABACUS proje revizyonu ayıklamak ve yerel / stand-alone ABACUS projesi olarak kaydetmek mümkün olacak.

Not

Bir önceki revizyona geri almak için bu bakınız Avolution topluluk makale .

(Yönetici) revizyon XX XML Günlüğü dosyasını indirin: ABACUS Yönetici yeteneği ile kullanıcılar tablosundaki belirli bir revizyon seçin ve ardından seçilen ABACUS proje sunucusundan günlük dosyasını tamamlama ayıklamak ve bir .xml dosyası olarak kaydetmek için Yükle düğmesini tıklatın olabilir.

Değişikliklerin Denetim Trail görüntüleme

Karşı Bir verilen herhangi bir elemanı değişiklikleri (örneğin bileşen, bağlantı, bakış, çocukların vs.) bir denetim izi görüntülemek Şirket proje, öğeyi sağ tıklatın ve seçmek Denetim Trail...Kimden ve Revizyon aralığı ve tıklama için set Arama.

Not

Bir eleman projeden silindikten sonra artık o elemanın hakkında özel denetim izi bilgilerine erişmek mümkün. Ancak, yine de (örneğin) 'ebeveyn' bileşeni erişmek ve (silindi elemanın kimliğini listeleyen bu durumda) silinmesi ile ilgili bağımsız denetim izi bilgileri görebilir.Ayrıca, Komponent / Bağlantı eki bağlantı DEĞİL bileşeni ve bir bağlantı silme ve yeni bir bağlantı oluşturmak için denetim izi gösterecektir böylece Explorer penceresi üzerinden veya Çizgelerinde ekli bileşeni değişen bağlantıları 'özelliği' (gibidir Bağlantı eki tamamen - Orijinal bileşen için denetim izi bilgilerinin kaybına neden olacaktır) 'Unattach' sağ tıklatın ve sonra da 'bağlayın ...' katalogları olur.

Not

Varsayılan olarak denetim izi özyinelemeli seçilen elemanın çocukların herhangi bir değişiklik için kontrol eder. Bu uzun yanıt süreleri neden olabilir ve buna göre denetim izi seçimini kaldırarak elemanın kendisi ile sınırlı olabilir Recursive altında seçenek Denetim SeçenekleriAudit Trail iletişim kutusunda 'dişli çark' araç çubuğu düğmesine basın.

Revizyon Gönderen: Bu Kurumsal sunucu üzerinde proje için mevcut ilk / eski revizyon varsayılan olacaktır.

Revizyon için: Bu Kurumsal sunucu üzerinde proje için mevcut son / son revizyon varsayılan olacaktır.

Not

Kimden ve revizyon için ayarladıktan sonra seçilen elemanın herhangi bir belirli değişiklikler almak için Arama butonuna tıklayınız aralığı.

Revizyon: The Revizyon sütun ileri kronolojik sırayla, varsayılan olarak, Enterprise sunucusu taahhüt revizyon numaralarını listeler.

Not

Seçili öğe ilgili sadece revizyon gösterileceği gibi revizyon numaraları sürekli olması olası değildir ve sadece ABACUS aynı Subversion deposu diğer ABACUS projelerinin ve / veya sürüm kontrol uygulamaları için kullanılan olabilir sırasında yer alacaktır taahhüt.

Tarih: The Tarih sütun kullanıcı eylemi yapıldığı tarihi listeler.

Not

Gösterilen tarih kullanıcı eylemi tarih değil, revizyon Şirket sunucusuna işlendiği tarihtir. Buna göre, tarih tarih gösterilir tamamlama gelen revizyon önce olabilir Dosya | Oturum görüntüle ...Komut.

Zaman: The Zaman sütun kullanıcı eylemi yapıldığını (24 saat biçiminde) günün saatini listeler.

Not

Gösterilen zaman kullanıcı eylemi zamanı değil, revizyon Şirket sunucusuna işlendiği zamanı. Buna göre, büyük olasılıkla gelen revizyon önce gelecek zaman ile gösterilen zaman taahhüt Dosya | Oturum görüntüle ...Komut.

Yazar: The Yazar sütun eylemin Microsoft Windows oturum açma adı izledi gerçekleştirilen kullanıcı listeleri onların ABACUS kullanıcı adı Ya da 'Anonim' kullanıcı kimlik doğrulaması ve anonim kullanıcılar kullanıcı eylemi sırasında Kurumsal projeye izin verilmiştir eğer.

Not

Audit Trail iletişim listelenen Yazar mutlaka aynı revizyon için yukarıdaki Günlüğü Göster iletişim kutusunda listelenen Yazar uymayabilir. View Log iletişim listeleri Denetim Trail iletişim listeleri kullanıcı eylemi sırasında kullanıcı oturum açmışken taahhüt anda oturum açmış kullanıcı Bunun nedeni olduğunu ve bir kullanıcı değişiklikleri yapmak ve onların göndermek sahip olmak mümkündür. (örneğin Avolution gibi) bir dış kullanıcı bir EE proje üzerinde çalışmak için zaman olduğu gibi - değişiklikler işlemek için başka bir kullanıcıya dosya.

Detaylar: ThKurumsal sunucuda kayıtlı e Detayları sütun kullanıcı eylemi tam ayrıntılarını listeler.

Bahşiş

Bu yararlıdır Revizyon sütuna göre grup (yukarıdaki iletişim gösterildiği gibi) ve / veya Kullanıcı Eylem sütunu için Kolayca ilgi eleman değişiklikleri sınıflandırmak.

Kurumsal dosyaları ile Scripting Kullanımı

Enterprise dosyaları ile komut dosyası kullanıyorsanız, doğru modelin bir nesneyi silmek için nasıl farkında olmalıdır. Bir nesneyi silerken Genellikle, sadece kendi üst çıkarmadan ziyade, üzerinde .Delete () yöntemini çağırır.

Örneğin Eğer COMP2 ebeveyni olarak COMP1 vardı ve sizin komut COMP2 silmek isterseniz, comp2.Delete () yerine comp1.Components.Remove (comp2) çağırmalıdır.

Eğer mimarisi içinde başka bir yere comp2 nesnesi eklemek istiyorsanız kaldırmak kullanabilir, ancak niyeti nesneyi silmek için ise o kullanılmamalıdır.

Bunu başka modelde 'yaşıyor' bir nesneyi kaldırmak istediğiniz zaman bu, bir istisna vardır. Arch1 - Bir mimarlık / bileşen / bağlantıdan standart örneği kaldırmak istiyorsanız, o zaman örneğinin standart toplama çıkarmadan bunu yapardı.Uygulamalar.Gergi (Imp) - silme tüm örneklerini kaldırın çünkü.

Doğru komut Sil'i kullanarak bir nesne objectmodel kaldırılır ve sonra bulunduğu için mümkün olmayacaktır, yeniden ilave edilmez çünkü eğer önemli olduğunu, ama değildi çünkü özellikle 'silindi', Çatışma Algılama ve Çözümü olmaz Doğru başka bir kullanıcı kendi değişikliklerden herhangi nesneyi kullanmaya teşebbüs olsaydı bir çatışma tespit ve sonuçta bu kullanıcı için değişikliklerin bir bozuk kümesi olacaktır.

Ayrıca bakınız

Nasıl bir mimarlık ABACUS'te temsil edilir?


ABACUS dosyalarıyla çalışma

Navigasyon: ABACUS'e Giriş>

ABACUS dosyalarıyla çalışma

Yorum gönder bu konuda.

Bir ABACUS'ün dosyası bir model için bir kap aşağıdadır mimari . Tek bir ABACUS dosyası içinde, mimarileri herhangi sayı kez herhangi bir sayı model olabilir.

İlk ABACUS açtığınızda, hiçbir dosya açık vardır. Senin mimarisi üzerinde çalışmak için, yeni bir dosya oluşturmak veya varolan bir dosyayı açmak için ya var.

Açmak veya yeni bir dosya oluşturduğunuzda, explorer penceresinde bir ağaç otomatik olarak gösterecektir. Bu kaşif görünümü size bugüne kadar mimarisini göstermektedir. Dosyayı kapattığınızda, explorer penceresinde ağaç da yok olacak.

Yeni ABACUS dosyası oluşturmak için

1. Seçin Dosya| Yeni ...

2. Görünen Yeni Proje iletişim kutusunda (aşağıda gösterildiği gibi) Seçinbirine, bir bir model boş bir model oluşturmak Standart ABACUS kütüphanesi Özel bir ABACUS kütüphaneden bir modeli, XML bir model MS Access , MS Visio , MS Excel , MS SQL Server Bir Şirket Sunucu Model veya özel bir ABACUS kitaplığı (.abacuslib dosyası).

3. Tıklayın tamamdüğmesi ve ortaya çıkabilecek diyaloglar izleyin.

Bahşiş

Sen kurtarmak kadar dosyayı adlandırın veya kapatmak için istenmez. Bu en kısa sürede bunu oluşturmak gibi dosyayı kaydetmek için iyi bir fikirdir. Sonra sen (Mimarinizi doldurmamak gibi) diğer karmaşık şeylere konsantre olduğunuz sürece daha sonra adlandırma konusunda endişelenmenize gerek olmayacaktır.

Yeni bir proje oluşturun

ABACUS Standart Kütüphaneler

ABACUS üzerinde destekler 100 kamu çerçeveler ve gösterimler bazıları aşağıda gösterilmiştir. Bir standart kütüphane kullanıcılar herhangi tanımlı eleman tipleri tam yararlanarak bir tesis çerçevesinde modelleme hızlı bir başlangıç ​​yeni bir proje oluşturmak için seçerken, gösterimler, bakış açılarını ve şablonları veya desenler bağlıyor. Ek standart kütüphaneler Avolution Topluluk aracılığıyla serbestçe kullanılabilir İşte .

Standart Kütüphanesi Yeni Proje

Yeni ABACUS dosyayı kaydetmek için

1. Seçin Dosya| Farklı kaydet

Bahşiş

Dosya adları herhangi bir uzunlukta olabilir ve herhangi bir alfa-nümerik karakterleri ve boşluk içerebilir. (?) Gibi ters eğik çizgi (\) olarak normal yol açıklamaları için kullanılan karakteri, soru işareti veya karakterleri - yolunun bir parçası olarak haricinde | () Onlar tilde (~) karakteri, boru içeremez.

Varolan ABACUS dosyasını açmak için

1. Seçin Dosya| Açık

Not

Eğer başka bir kullanıcıya zaten açık olan bir paylaşılan ağ konumuna bir dosya açıyorsanız, ABACUS Read Only erişim sağlayacaktır. Read Only erişim ABACUS kullanırken, örneğin mimari doldurma ve değerlendiriciler çalışan olarak, yazma işlemleri gerçekleştirmek mümkün olmayacaktır. Ancak, kaşif görünümü ve 3D görünümleri kullanarak mimarisini görebilirsiniz.

Ayrıca bakınız

Nasıl bir mimarlık ABACUS'te temsil edilir?


Panolar ile Çalışma

Navigasyon: Yönetim>

Panolar ile Çalışma

Yorum gönder bu konuda.

ABACUS projeleri görünümler herhangi bir konfigürasyona sahip olabilir (örneğin diyagramlar, Grafikler vs.) bir pano olarak kaydedilir ve bu kaydedilen gösterge tabloları olabilir Varsayılan ve / veya Proje açma ile ilgili 'ekranı' başlangıç ​​olarak ayarlanmış Belirli bir atanmış kullanıcı grubu ve onlar ABACUS projeye oturum kullanıcı grubunun üyelerine sunuldu.

Not

Kullanıcı lisans Yönetici yeteneği gereken bir ABACUS projesinde panoları yapılandırın. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

Panolar görüntüleme

Bir örnek uygulama Portföy Yönetimi (APM) pano

Kaydedilmiş bir Dashboard görüntülemek için

1. Seçin Görünüm| Panolar

2. Mevcut panoları listesinden kayıtlı bir pano seçin.

Not

Seçilen ABACUS'e kez pano için gerekli görünümleri inşa edecek ve bu bir kaç saniye sürebilir. Lütfen sabırlı olun.

Panolar Yönetme

Panolar Yönetme

Yeni Dashboard oluşturmak için

1. Gerekli görüşlerini açın ve düzenlemek ve rıhtım Windows pano için gerekli olan.

2. Seçin Görünüm| Panolar| Panolar yönet ...

Not

Yönet Dashboard menü öğesi görmüyorsanız o zaman Yönetici yeteneği yok. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

3. Görüntülenen iletişim kutusunda seçin Createdüğmesine Create New Dashboard iletişim Dashboard adını girin ve.

4. Tıklayın tamamdüğmesine basın.

Varolan Dashboard silmek için

1. Seçin Görünüm| Panolar| Panolar yönet ...

2. Listeden silmek istediğiniz Dashboard seçin ve seçmek görünen iletişim kutusunda Silmekdüğmesine basın.

Not

Bir dashboard silinmesi Ayrıca gösterge tablosuna herhangi bir kullanıcı grubu atamaları silecektir.

3. Tıklayın tamamdüğmesine basın.

Mevcut bir Gösterge Tablosu değiştirmek için

1. Gerekli görüşlerini açın ve düzenlemek ve rıhtım Windows değiştirme tablosu için gerekli olan.

2. Seçin Görünüm| Panolar| Panolar yönet ...

3. Istediğiniz Dashboard seçin Görüntülenen iletişim listeden yerini seçmek için ise Değiştirdüğmesine basın.

4. Tıklayın tamamdüğme Dashboard Değiştirilen diyaloğu kabul etmek.

Bir Dashboard atamak içinvarsayılan Başlat Ekranı olarak

1. Seçin Görünüm| Panolar| Panolar yönet ...

2. Eğer atamak istediğiniz listeden Dashboard seçin Görüntülenen iletişim kutusunda Varsayılan başlangıç ​​'ekranında' olarakseçin Ata ...düğmesine basın.

3. Görüntülenen iletişim kutusunda seçin Kullanıcı Grupları sütununda giriş.

Not

Sadece bir pano önceki gösterge tablosundan 'ekranı' yani yeniden atama kaldıracak atama başlatmak olarak atayabilirsiniz edilebilir.Ayrıca, kullanıcı daha sonra atanan pano varsayılan proje pano yerine açılacak atanmış bir pano sahip bir kullanıcı grubunun bir üyesi olarak oturum açtığında ise.

4. Tıklayın tamamdüğmesine basın.

Bir Dashboard bir Kullanıcı Grubu atamak için

1. Seçin Görünüm| Panolar| Panolar yönet ...

2. Listeden Dashboard seçin Görüntülenen iletişim kutusunda size bir kullanıcı grubu atamak ve seçmek istediğiniz Ata ...düğmesine basın.

3. Görüntülenen iletişim kutusunda seçin Kullanıcı Grubu (veya Gruplar)için 'başlangıç' ekranı olarak gösterge paneli atamak istiyoruz.

Not

Aynı Kullanıcı Grubu daha sonra birden panoları atanmışsa listedeki ilk atama kullanılacaktır.

4. Tıklayın tamamdüğmesine basın.

Bir Dashboard bir Kullanıcı Grubu atamasını için

1. Seçin Görünüm| Panolar| Panolar yönet ...

2. Listeden Dashboard öğesini genişletin Görüntülenen iletişim kutusunda sizden bir kullanıcı grubu atamasını istiyoruz.

3. Eğer atamasını istediğiniz kullanıcı grubunu seçin ve Seçenek Atamasınıdüğmesine basın.

4. Tıklayın tamamdüğmesine basın.

Ayar izinler

İzinler pano görüntülenebilir olmasını sağlamak için gösterge panoları için ayarlanabilir, Güncelleştirilebilir ve / veya bir silinebilirVerilen kullanıcı gruplarına.

İzinler Yönetimi

Bir Pano izni ayarlamak için

1. Seçin Görünüm| Panolar| Panolar yönet ...

2. Eğer izinlerini ayarlamak istediğiniz listeden Dashboard seçin ve seçmek görünen iletişim kutusunda İzinler ...düğmesine basın.

3. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

4. Varsayılan olarak Salt, Update ve Delete izinleri hepsi mevcut olduğunu göreceksiniz. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

5. Tıklayın tamamdüğmesine basın.

Ayrıca bakınız

ABACUS arayüzü özelleştirme | İzinler ile Çalışma


İzinler ile Çalışma

Navigasyon: Yönetim>

İzinler ile Çalışma

Yorum gönder bu konuda.

ABACUS projeleri olabilir Rol tabanlıizinleri depo içindeki her eleman için ayarlayın. Spesifik olarak, ince taneli Create-Read-Update-Delete (REZİL) Izinleri 'nesne' (yani bileşen veya bağlantı), görünümü ve öznitelik (yani mülkiyet) düzeyleri ayarlanabilir.

Genel

Ile çalışırken ABACUS Kurumsal Sunucu ABACUS deposuna birden fazla kullanıcı erişimi kontrol etmek ince taneli, rol tabanlı CRUD izinleri sağlar.

Not

Kullanıcı lisans Yönetici yeteneği gereken bir ABACUS projesinde izinlerini yapılandırın. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

İzinler (türlerine üzerinden) mimarileri, bileşen ve bağlantı türleri, özellikleri için ayarlanabilir, şablonlar, bakış açıları ve diyagramlar, kataloglar, matrisler, grafikler ve 3 boyutluGösterim. Izinleri bu projede herhangi mimariler bir bileşen veya bağlantı türü için bu tür tüm örneklerini ayarlandığında bu izinleri 'miras'. Bir izin, bir bileşen veya bağlantı türü, bu projede herhangi mimarilerinde bileşen veya bağlantı örnekleri verilen mülkün bir özellik için ayarlandığında Benzer şekilde, bu izinleri 'miras'. Buna göre, bazı izinler bu unsurlar var olduğu konusunda görüş uygulanacaktır. Izinleri bir diyagram, görüş ve / veya görünümü kendisi içeriğinden ayarlandığında çeşitli izinler uygulanmış var.

Not

Varsayılan olarak hiçbir izinleri bir ABACUS projesi kapsamında elemanlar için ayarlanır. Bu tüm unsurları tüm kullanıcılar tarafından, Createable Okunabilir, güncellenebilir ve bir silinebilir olmasıdır. Belirli bir izin olmaktır, bu durumda izinleri yalnızca depodaki belirli bir eleman için düşünülmelidir kısıtlıBelirli bir kullanıcı grubu için. Belirli bir kullanıcı grubu için izinleri nesneye (örneğin bir bileşen türü) ilave edildi, tüm izinler etkin örneğin, ama sonra bu işlevsel aynı, sol kullanıcı grubu gibi değildi nesneye eklenir.

İzinler YapamamBir mimarlığın elemanların belirli örnekleri için ayarlanmalıdır. Örneğin, bir uygulama bileşeni güncelleştirilebilir başka değil yapamazsınız. Etkin bir şekilde, ancak bu 'etki belirli izinlerini elde etmek için, yönetici, örneğin verilen etki, özel eleman türlerini kurabilirsiniz bileşen türleri 'Uygulaması - CRM alanı' ve - daha sonra 'Uygulama İK alanı' ve buna göre her tür için izinlerini ayarlamak. Her etki alanı için özel gruplandırma türlerini yapmak ve daha sonra alana özgü grup türü için güncelleme iznini kaldırmak ve bu o gruplandırılması itibaren içinde kreasyonlar ve silme kısıtlamak ama çocuklar güncelleme olmayacak olabilir. Tabii etki özgü gruplandırma okuma izni daha sonra çocukların gizli olacak ve böylece olmayan güncelleştirilebilir kaldırarak gizli olsaydı. Gösterim (yerine kaşif yerine) / yönetmek depo görüntülemek için öncelikle kullanılır Alternatif olarak, eğer her etki alanı için verilen bir görünüm kurulabilir ve sonra yönetici buna göre her görünüm için izinleri ayarlayabilirsiniz.

Kullanıcılar ve Gruplar Yönetme

İzinler de tanımlanır rol veya grupbireysel kullanıcı seviyesine karşı grupların üyeliği değişebilir süre böylece seviyesi, izinler sabit kalabilir. Tabii isterseniz, belirli bir kullanıcı izni daha sonra sadece onlara bir grup yapmak, ya da daha doğrusu tek üyesi olarak bu kullanıcı ile bir grup oluşturun.

Bu gruplar olduğu unutulmamalıdır atomik, Onlar diğerine izinler veya kullanıcıların miras edemez ve bir kullanıcı daha sonra birden çok gruba aitse en 'kötümser' grup izni her izin için bir case-by-case bazında öncelik alacak olan (yani oluştur -Read-Güncelleme-Delete). Örneğin aynı kullanıcı B Grubu sadece uygulama bileşeni türleri için sadece Create-Okuma izni Oku-Güncelleştirme vardır ederken Grup A ve Grup B ve A Grubu üyesi sonra kullanıcı sadece okuma izni olacak Başvuru bileşen türleri için izin ise Uygulama bileşen örnekleri.

Ayrıca, varsayılan olarak, anonim kullanıcılarsahip (yani tanımlı değil veya kimin giriş yapmamışsınız kullanıcımız) Tam erişimProjeye. Bu erişimin bir başlangıç ​​yapılandırması mevcuttur sağlamaktır. Anonim kullanıcılar tarafından erişimi engellemek için sadece aşağıda gösterilen iletişim Kullanıcıları Yönet / Gruplar seçeneği 'anonim kullanıcı tam erişim dosyaya izin ver' işaretini kaldırın. İşaretlenmediğinde anonim kullanıcılar sadece herhangi bir projenin Standartları kısmını görmek mümkün olacaktır.

Son olarak, 'kullanma Windows Kullanıcı Girişi' seçeneğinin işaretli olup olmadığını kullanıcı adı kimlik adı en aşağıda başına girilen karşı her kullanıcının makinesinde, Windows Kullanıcı Logins karşı yapılır. Belirli bir kullanıcının bilgisayarında Windows Kullanıcı Girişi sonra hiçbir parola gereklidir geçerli bir kullanıcı adı olarak varolduğundan ve kullanıcı otomatik kimlik doğrulaması ise budur. Not: Bu etkili bir Windows Active Directory (AD) kimlik kullanımını sağlar.

Not

Verilen izinler sadece bir kullanıcı, bir grubun üyesi, ya da herhangi bir nesnelere karşı bunun için tanımlanmış izinlere sahip herhangi bir grup, tam erişime sahip olmayacak herhangi kullanıcıdan (kısıtlı) götürüldüğünü gerektiğinde tanımlanır olduğunu bu proje.

Kullanıcılar ve Kullanıcı Grupları

Yeni Kullanıcı oluşturmak için

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

Not

Eğer Kullanıcıları Yönet görmüyorsanız / Gruplar menü öğesi sonra Yönetici yeteneği yok. Yerel ABACUS yöneticinize başvurun veya Lütfen Avolution Destek Eğer bu yeteneği gerektiriyorsa.

2. Görüntülenen iletişim kutusunda seçin Kullanıcı Ekledüğmesi ve Yeni Oluştur Kullanıcı iletişim kutusunda bir kullanıcı adı ve şifrenizi girin. Not: Kullanıcı adları ve şifreleri harf duyarlıdır.

Not

Daha sonra bir kukla parola kimlik olarak girilebilir yukarıda anlatıldığı gibi 'Kullanım Windows Kullanıcı Girişi' seçeneği işaretliyse, yalnızca kullanıcının Pencere adı Login göre yapılacaktır.

2. Varsayılan olarak bunu göreceksiniz Kullanıcılar kendi şifrenizi değiştirebilirsiniz. Gerekirse, ABACUS'ün Yöneticisi kaldırabilir Kendi şifre koymak kullanıcılar için yeteneği tarafından öğesinden işareti kaldırarakonay kutularını.

Not

Kullanıcıların kendi şifrenizi değiştirebilirsiniz Eğer onlar olacak Dosya | Şifre değiştir...menü öğesi bunu.Ayrıca, birden fazla kişi aynı kullanıcı adı kullanırsanız o zaman bir kullanıcı hiçbir kişi sonradan giriş yapabilirsiniz şekilde şifresini değiştirmek olabileceğini unutmayın. Buna göre, tavsiye edilir pratik bir var Gerçek kişi başına tek kullanıcı adı.

4. İsteğe bağlı olarak, E-posta adresini girin, Konum Telefon numarası ve Gelecekte başvurmak için kullanıcılar için.

5. Tıklayın tamamYeni Oluştur Kullanıcı iletişim düğmesine basın.

6. Tıklayın tamamdüğmesine basın.

Not

İlk kullanıcı oluşturduktan sonra size işaretini kaldırarak anonim kullanıcılar tarafından erişim engelleme düşünmelisiniz Kullanıcıları Yönet / Gruplar iletişim seçeneği 'anonim kullanıcı tam erişim dosyaya izin ver'.Ayrıca, bir kez kullanıcı yaratılmıştır (ve eğer bir Enterprise projesi, sunucuya taahhüt değişiklik), kullanıcıların istenecektir projenin bir sonraki açılışında Kimliği doğrulanmış erişim için oturumAşağıda gösterilen iletişim başı olarak. Eğer Bu detaylar otomatik oturumseçeneği daha sonra kontrol edilir kullanıcı adı / şifre kombinasyonu projesi için hatırladı ve açılış her zaman uygulanır. Kaydedilen giriş seçme temizlemek için Dosya | Temizle Kayıtlı Üye Girişisonra açılış ve sen projeyi açın tekrar sefere giriş istenir.

Oturum aç

Varolan Kullanıcı silmek için

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

2. Seçmek silin ve isteyen kullanıcılar panelinde kullanıcı adını seçin Görüntülenen iletişim kutusunda Kullanıcıyı Sildüğmesine basın.

3. Tıklayın tamamdüğmesine basın.

Yeni Grup oluşturmak için

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

2. Görüntülenen iletişim kutusunda seçin Grup Ekledüğmesi Grupları panelinde Grup adını girin ve.

Not

Grup adları benzersiz olmalıdır.

3. Tıklayın tamamdüğmesine basın.

Karşı Varolan kopyalamaGrup

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

2. Görüntülenen iletişim kutusunda seçin KopyaGrupdüğmesine basın.

Not

Bir yinelenen grubu "nin Copy" öneki oluşturulan olacak.Varsayılan olarak kopyalanan gruptaki tüm izinleri herhangi bir kullanıcı ataması da dahil olmak üzere grubu "Kopya" için çoğaltılır.

3. Kullanarak uygun olarak grubu "Kopyala" Rename Düzenleme Grubuveya yavaş çift tıklayın.

Varolan Grubu silmek için

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

2. Seçmek silin ve istediğiniz gruplar panelinde Grup adını seçin Görüntülenen iletişim kutusunda Grubu Sildüğmesine basın.

Not

Grubun herhangi bir kullanıcı atamaları da silinecektir.

3. Tıklayın tamamdüğmesine basın.

Bir gruba bir kullanıcı atamak için

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

2. Ve bir gruba atamak istediğiniz kullanıcılar panelinde kullanıcı adını seçin Görüntülenen iletişim kutusunda sürükle ve bırakEğer bunu atamak istediğiniz gruplar panelindeki Grup adı üzerine.

3. Tıklayın tamamdüğmesine basın.

Not

Bir kullanıcı genişleterek gösterilmiştir atanmış olduğu grup (lar) Kullanıcılar panelinde Kullanıcı adıve bir gruba atanan kullanıcılar Gruplar panelinde Grup adını genişleterek gösterilmektedir. Örneğin, yukarıdaki ekran görüntüsünde, "AS1-Aus" kullanıcı olmak üzere üç (3) gruplara atanır; "App Destek Ekibi 1", "Gerçek" ve "Avustralya".

Bir gruba bir kullanıcı atamasını için

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

2. Eğer atamasını ve Kullanıcı adını seçmek istediğiniz kullanıcı atamasını içeren Grup adını genişletin Görüntülenen iletişim kutusunda.

3. Tıklayın Atamasını Kullanıcıdüğmesine basın.

4. Tıklayın tamamdüğmesine basın.

Kullanıcıları ve / veya Gruplar (ve herhangi bir eşleştirme izinler) almak için

1. Seçin Dosya| Kullanıcılar / Gruplar yönetin

2. Tıklayın İthalatdüğmesine basın.

3. Görüntülenen iletişim kutusunda Araştırve Kullanıcıları içeren ABACUS projeyi açın ve / veya Gruplar (ve İzinler) geçerli projeye aktarmak ve tıklayın istediğiniz Açık. Kullanıcılar ve Gruplar ithal ve bir İthalat Sonuçları iletişim Kullanıcıları ve / veya Gruplar ithalatı özetleyen görünecektir. Tıklayın tamamdüğmesine basın.

Not

İthal Kullanıcılar veya Gruplar zaten geçerli projede var sonra onlar varolan Kullanıcılar veya Gruplar ile birleştirilecektir.

4. Tıklayın tamamdüğmesi geri ana Kullanıcılar / Gruplar diyaloğunu yönetin.

5. Zaten geçerli projede var olmayan izinlere sahip komple herhangi bir eşleme türleri, Bakış Açıları, Şablonlar veya mevcut proje ve ithal ediyoruz ABACUS projesi arasında Mimariler varsa, izinler ithal ve ikinci İthalat Sonuçları iletişim vardır ithalat özetleyen görüntülenir. Tıklayın tamamdüğmesine basın.

Not

İzinler yalnızca varolan Türleri (ve onların Özellikleri), Bakış Açısı, Şablonlar veya izinleri zaten Grup yoktu Gruplar için Mimarileri eklenir. Grup yeni olduğundan veya Ya Grup zaten geçerli projede var ama hiçbir izinleri bu öğeye o Grup atanan olmuştu. Izinler zaten geçerli projede Grup var öğeler eşleşen izinleri yok 'birleşmesi' vardır.

Ayar izinler

İzinler (türlerine üzerinden) mimarileri, bileşen ve bağlantı türleri, özellikleri için ayarlanabilir, şablonlar, bakış açıları ve diyagramlar, kataloglar, matrisler, grafikler bird 3DGösterim. Izinleri bu projede herhangi mimariler bir bileşen veya bağlantı türü için bu tür tüm örneklerini ayarlandığında bu izinleri 'miras'. Bir izin, bir bileşen veya bağlantı türü, bu projede herhangi mimarilerinde bileşen veya bağlantı örnekleri verilen mülkün bir özellik için ayarlandığında Benzer şekilde, bu izinleri 'miras'. Buna göre, bazı izinler bu unsurlar var olduğu konusunda görüş uygulanacaktır. Izinleri bir diyagram, görüş ve / veya görünümü kendisi içeriğinden ayarlandığında çeşitli izinler uygulanmış var.

İzinler Yönetimi

Bir Bileşen (veya Bağlantı) izin ayarlamak için yazın

1. Expand TürleriAğacın dalı.

2. Expand Bileşen (veya Bağlantı) ÇeşitleriAğacın dalı.

3. Expand Gruplar Gerektiğinde.

4. Sağ tık üzerinde Bileşen (veya Bağlantı) TipEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

5. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

6. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

Not

Izni oluşturma, bir öğeyi kopyalayabilirsiniz zaman da yönetir. Buna göre, bir eleman kopyalamak için muktedir (eleman kopyalamak için altındaki her şeyi kopyalama anlamına beri) tüm çocuklar için izni oluşturun gerektirir. Bir elemandan Güncelleme izni çıkarma kullanıcı bunu eklenti ve Tasarımcısı olsa bile, türü kendisini değiştirme yeteneğini ortadan kaldırır Ayrıca tüm özelliklerinin için Güncelleştirme izni kaldırır. Bir ana unsuru edebilmek için güncelleştirme izniniz olmalıdır Herhangi bir alt öğeleri oluşturun veya Onun Sil mevcut Çocuklar elemanları. Bir eleman için izin sil da tüm çocuklar için silme iznine gerektirir. Bileşenler için izin sil da bağlı tüm bağlantıların Güncelleme izni gerektirir.Ve nihayet, Sil iznini kaldırmadan bir elementinden Kullanıcı Designer add-on olsa bile, türü kendisini silmek yeteneğini kaldırır.

7. Tıklayın tamamdüğmesine basın.

Bir Bileşen Grubu (veya Bağlantı) izin ayarlamak için Türleri

1. Expand TürleriAğacın dalı.

2. Expand Bileşen (veya Bağlantı) ÇeşitleriAğacın dalı.

3. Sağ tık üzerinde GrupEğer bu sizin için izinlerini ayarlamak ve seçmek istediğiniz Bileşen (veya Bağlantı) Türleri içeriyor Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

6. Tıklayın tamamdüğmesine basın.

7. Tıklayın Görüntülenen iletişim kutusunda Evetdüğmesine basın.

Bir Mülkiyet izni ayarlamak için

1. Expand TürleriAğacın dalı.

2. Expand Bileşen (veya Bağlantı) ÇeşitleriAğacın dalı.

3. Expand Gruplar Gerektiğinde.

4. Bileşen (veya Bağlantı) o sizin için ayarlanan izinler isteyen özellik içerir Tür seçiniz.

5. Özellikler penceresinde sağ tık üzerinde MülkiyetEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

6. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

7. Varsayılan olarak Salt ve Update izinleri hepsi mevcut olduğunu göreceksiniz. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

Not

Kaldırıldı Güncelleme izni vardı Özellikleri gösterilir italik yazıProperties penceresindeve değerleri o rol ile güncellenen olamaz. Ayrıca, yetenek Bir mülkün ayrıntılarını değiştirmek (örneğin isim, birimler vs.) Güncelleme özelliği izni ve hem de gerektirir Tasarımcı add-on.

8. Tıklayın tamamdüğmesine basın.

Şablon izni ayarlamak için

1. Expand ŞablonlarAğacın dalı.

2. Göz atın Kalıpİlgilendiğiniz söyledi.

3. Sağ tık üzerinde KalıpEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak size okuma izni mevcut olduğunu göreceksiniz. Tarafından izin kaldır öğesinden işareti kaldırarakonay kutusu.

6. Tıklayın tamamdüğmesine basın.

Bir Açısından izni ayarlamak için

1. Expand Bakış AçılarıAğacın dalı.

2. Expand Gruplar Gerektiğinde.

3. Sağ tık üzerinde Bakış açısıEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

6. Tıklayın tamamdüğmesine basın.

Bir Mimarlık iznini ayarlamak için

1. Expand MimarileriAğacın dalı.

2. Genişletin Mimarlıkİlgilendiğiniz söyledi.

3. Sağ tık üzerinde MimarlıkEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak size okuma izni mevcut olduğunu göreceksiniz. Tarafından izin kaldır öğesinden işareti kaldırarakonay kutusu.

6. Tıklayın tamamdüğmesine basın.

Bir izni ayarlamak için Katalog

1. Expand Kataloglarmimarlık dalı ilginizi çekiyor.

2. Expand Gruplar Gerektiğinde.

3. Sağ tık üzerinde KatalogEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

6. Tıklayın tamamdüğmesine basın.

Bir izni ayarlamak için Matrix

1. Expand Matrislermimarlık dalı ilginizi çekiyor.

2. Expand Gruplar Gerektiğinde.

3. Sağ tık üzerinde MatrixEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

6. Tıklayın tamamdüğmesine basın.

Bir Şeması izni ayarlamak için

1. Expand Diyagramlarımimarlık dalı ilginizi çekiyor.

2. Expand Gruplar Gerektiğinde.

3. Sağ tık üzerinde DiyagramEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

Not

Bir diyagram doğrudan CRUD izinlerini ayarlayabilirsiniz iken, diyagram üzerinde elementlerin izinleri görünümü kendisi için izinleri etkileyebileceği unutulmamalıdır. Örneğin, daha sonra diyagram kendi Güncelleme izni kaldırılmış olacaktır çıkarılmış Oku veya Update izni etti görünümü bile sadece tek unsur varsa. Bunun nedeni ise; a) Okuma izni kaldırıldı vardı görünümü unsurlar görünümü güncelleştirilebilir olsaydı aksi takdirde bazı yeni unsurlar yer olabilir 'boşluk' bırakarak görünümünde gösterilir ve olmayacak b) görünümü elemanlarının görünümü güncelleştirilebilir olsaydı o zaman diğer unsurları olabilir kaldırıldı kendi Güncelleme izni çocukları olma üzerlerine düştü vardı. Başka bir bileşen üzerine bir bileşen taşımak için çünkü Ayrıca, oluşturma ve bir diyagram için Güncelleştirme izni görünümünde tüm unsurları okuma izni ve takımlar Güncelleme iznine sahip olmasını gerektirir (bu, sen o olacak çünkü güncelleştirmek gerekir ) bir çocuk haline gelir.

6. Tıklayın tamamdüğmesine basın.

3D View iznini ayarlamak için

1. Expand 3D İzlenmemimarlık dalı ilginizi çekiyor.

2. Expand Gruplar Gerektiğinde.

3. Sağ tık üzerinde 3D GörünümüEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

6. Tıklayın tamamdüğmesine basın.

Bir izni ayarlamak için Grafik

1. Expand Grafiklermimarlık dalı ilginizi çekiyor.

2. Expand Gruplar Gerektiğinde.

3. Sağ tık üzerinde GrafikEğer izinlerini ayarlamak ve seçmek istediğiniz Düzenleme İzinleri.

4. Üzerine tıklayın Görüntülenen iletişim kutusunda Ekle ...düğmesine basıp Grupya çift tıklayarak veya seçip tıklayarak eklemek istediğiniz tamamdüğmesine basın.

5. Varsayılan olarak siz oluşturun, o Oku, Güncelle görmek ve Sil olacak izinleri tüm mevcuttur. Izinleri kaldırın öğesinden işareti kaldırarakİlgili onay kutularını.

6. Tıklayın tamamdüğmesine basın.

Ayrıca bakınız

Nasıl bir mimarlık ABACUS'te temsil edilir?


Yazma Scripts

Navigasyon: Mimarinizi benzetme>

Yazma Scripts

Yorum gönder bu konuda.

Script Editor VB yazma ve yürütme için basit ve işlevsel bir araçtır veya C # karşı komut dosyası Şu anda açıldı ABACUS dosyası(Kütüphaneler komut dosyası desteklenmez). Aç, Kapat ve Kaydet komutları zamanki Dosya vardır, böylece tasarruf ve yazdığınız komut alabilirsiniz. Aynı zamanda temel bir çalışma ve hata ayıklama tesisi bulunmaktadır. Senaryo Yöneticisi kolayca Araçlar menüsünden doğrudan onlar için bir menü öğesi-koyarak yazdım çeşitli komut çalıştırmasına izin veriyor.

Script Editor erişmek için

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Seçin Araçlar | Script Editorve Kod Düzenleyicisi penceresi açılacaktır. Sonra ya;

3. Ile mevcut bir komut aç Dosya | Açık Script Editor menülerde,

veya

3. Aracılığıyla Örnek komut açın Örnek Script Editor menülerde kalem,

veya

3. VB veya C # yoluyla ya varsayılan Dil ayarlama Dil Script Editor menülerde kalem,

veya

3. Aracılığıyla Açık betik belirli Yardım Yardım Edin Script Editor menülerinde et

Komut yazarken, uymalıdır ya VB veya C # sözdizimiScript Editor menülerde Dil öğesinin altında ayarı olarak başına.

NOT:

· Gibi standart VB işlevlerini kullanmak için Iletikutusu ()Eğer içermelidir İthalat Microsoft.VisualBasicsenin senaryonun başında beyanı. Bu ABACUS'ün Sürüm 3.0 öncesinde gerekli değildi.

· Bu yardım VB komut dosyası yazmak konusunda bilgi içermez, ne de bir VB başvuru içermiyor. Daha sonra, favori IDE veya editörü içinde komut yazmak kopyalamak ve Script Editör yapıştırın çekinmeyin.

Ilk Script Editor başlattığınızda, komut dosyası düzenleyicisi boş olacaktır. Sen Örnekler menü aracılığıyla bir iskelet komut erişebilirsiniz. Eğer Kod Düzenleyicisi'ni ilk kez başlattığınızda, sen bunun işe yaradığını görmek için Şablon iskeleti çalıştırmanız gerekir. Buna ek olarak, örnekler menü aracılığıyla erişilebilir iki örnek komut dosyaları vardır.

Yararlı bir senaryo yazmak için, ABACUS ObjectModel başvurmak gerekir. Bu içerecek şekilde komut için kullanılabilir yapılır İthalat ABACUS.ObjectModelsenin yazısının başında beyanı. Tüm ABACUS nesne modeline tam referans Script Editor ile birlikte gelir. Sen seçerek bulabilirsiniz Yardım | IçindekilerScript Editor penceresinden.

Dramaturg, senaryo yazmaya aşağıdaki ekran görüntüsünde görüldüğü gibi Otomatik Tamamla dahil olmak üzere birçok yararlı özellik içerir. Ancak, daha da zengin bir kullanıcı deneyimi için MS Visual Studio ABACUS ile entegre edilebilir ve ayrıntılı talimatlar mevcuttur İşte .

Otomatik Tamamlama ile Script Editor

Senaryo Yöneticisi'ni kullanmak için

1. Eğer varsa emin olun ABACUS dosyası, Sizin yanınızdaki içeren nüfuslu mimari, açık.

2. Seçin Araçlar | Senaryo Yöneticisi.

3. Tıklayın EklemekSimge ve Açıkpenceresi görüntülenir.

4. .abacusscript (ABACUS Script göz atın, .vb Veya .cs) Araçlar menüsünden eklemek istediğiniz dosya.

5. Tıklayın tamamve komut dosyası için bir referans Senaryo Yöneticisi penceresinde gösterilecektir. Eğer Araçlar menüsünde görünmesini istedikleri gibi komut adını girin. Not: Komut Yöneticisi penceresi gerekirse tam yolunu görmek için boyutlandırılmış olabilir.

6. Adımları tekrarlayın 3-5Daha fazla ABACUS komut bağlantılar oluşturmak için.

7. Tıklayın KapatSenaryo Yöneticisi'ni kapatmak ve ABACUS komut (lar) artık Araçlar menüsünde altında görünür unutmayın.

Bir komut dosyasını çalıştırmak için

Ya;

1. Aç, yazın veya kopyalayıp çalıştırmak istediğiniz komut yapıştırın, böylece ana penceresinde görüntülenir Script Editor.

2. Tıkla Koşmakdüğmesine basın.

3. Script hataları içeriyorsa, Script Editor altındaki Hata Açıklama bölümünde satır numaraları da dahil olmak üzere ayrıntıları listeler. NOT: Hata Açıklama bölümünde Her bireysel hata çift tıklandığında komut karşılık gelen hat çekmek için olabilir.

- veya -

1. Seçin Araçlarve ABACUS Senaryo adı ile oluşturulan olarak menü öğesi Senaryo Yöneticisi.

2. Script hataları içeriyorsa, Script Editor (ilk hata satırında vurgulanan) ana penceresinde gösterilen senaryonun içeriği ve ayrıntıları listeler Script Editor altındaki Hata Açıklama bölümünde veya açılacak satır numaraları dahil hata (lar). NOT: Hata Açıklama bölümünde Her bireysel hata çift tıklandığında komut karşılık gelen hat çekmek için olabilir.

Scripting Derleme Hataları

Komut kodunun sözdizimi doğru olmadığında Derleme hatalar oluşur. Bu hatalar hata açıklaması, ve bir çizgi numarası ile, Hata bölümünde pencerenin alt kısmında görünecektir. Bir satır numarasını olmayacak bir çalışma zamanı hatası (aşağıya bakınız), bir derleme hatası ayıran çizgi numarasıdır. Derleme hataları çift atlamak ve söz konusu satırını vurgulamak için tıklanabilir.

Scripting Runtime Hatalar (Önemli)

(Başka örnekler aşağı bakın) script kodunu başarıyla hatasız derlenmiş sonra Runtime hataları meydana, ama bir hata zamanında oluşur. Runtime hataları, nesneleri oluşturulur ve modelde başka nesneler tarafından başvurulan zaman bozuk modelleri, neden olabilir kadar önemlidir kendilerini bir çalışma zamanı hatası modeli yerleştirdi olurdu kodundan önce oluştu çünkü genellikle modelin (bir parçası değildir bir yerde,) idam edildi.

Script modeline eklenecek nesneleri oluşturursa, siz, komut tasarrufu scripting kapanış ve betiğin normal tam olmasaydı (komut dosyası tarafından oluşturulan değişikliklerin bir geri alma gerçekleştirerek bir çalışma zamanı hatası nedeniyle bozulmasını önlemek ). Ancak, aynı zamanda ortaya çıkan herhangi bir yolsuzluk (aşağıya bakınız) önlemek için başka yolları da vardır. Not: Sadece modelin okuma ve buna yazmayın herhangi scriptler, güvenli ve bağımsız olarak çalışma zamanı hataları kendi çalışması sırasında meydana olsun, herhangi bir soruna neden olmaz.

Nesneleri oluşturma ve nesne modeli ekleyerek komut dosyası kod yazarken bozulmasını önlemek için, bunların başka nesneler tarafından başvurulan nesneler, en kısa sürede modele eklenen ileri sürülmektedir.

Yeni bağlantı oluşturarak, ve 2 yeni bileşenler ve daha sonra onları bir arada bağlama Örneğin, bu, ilk bileşen oluşturmak daha sonra ikinci, modele ekleyin ve ekleyin ve sonra bağlantı oluşturmak için en iyi ve ekleyin ve sonra nihayet ekleri oluşturun. Bu komut dosyası yürütülmesine kesen bir çalışma zamanı hatası olmak olsaydı, bir eki oluşturulmadan önce objectmodel olması gereken tüm nesneler, modelde olduğu anlamına gelir. Örneğin, sadece bağlantı ekledi vardı, ekler yapılmış, eğer bozulması oluşabilir, ve script nihayet ortaya çıkabilir model.Corruption yeni bileşenler eklenmiş önce sonra bir çalışma zamanı hatası oluştu zaman içinde başka bir nesne tarafından başvurulan bir nesne objectmodel, objectmodel kendisini değil.

Örnek çalışma zamanı hataları şunlardır:

· Bir nesne değişkeni null başvuru olduğunda bu gerçekleşir ve bu nesne üzerinde yöntem veya özellik kullanılıyor - Nesne başvurusu bir nesnenin örneğine ayarlanmadı. Boş referanslar tarafından kontrol edilebilir 'objectVariable hiçbir Sonra mı varsa ...'

· Dizin, dizi sınırlarının dışındaydı - dizi sınırları dışında bir dizin ile erişildiğinde Bu durumda - örneğin 0'dan küçük veya eşit veya dizinin uzunluğu / Kont büyüktür. Dizi veya Koleksiyon uzunluğu sırasıyla .length veya .Count özellikleri tarafından kontrol edilebilir.

· İzin Yok İstisna - Verilen değişiklik yapmak için izniniz yoksa bu bir çıkar - Sen izni için ... yok

· Birincil Anahtar İstisna - çoğaltın / Ad / ID Eksik - bir değişiklik başka bir nesne ile çakışan benzersiz bir özniteliği yapılır eğer bu bir ortaya çıkar. Örneğin Mimarileri aynı şekilde Standartları adıyla benzersiz olmalıdır.

· Tutarlılığına İstisna - geçerli olmayan bir nesneye bir başvuru alanını ayarlama. Örneğin objectmodel koleksiyonları birçok bir çocuk olarak 'hiçbir şey' veya null sözlerine ekledi.

· Sıfır Uzunluk İstisna - Eğer boş bir dizeye bir nesnenin adını ayarlamaya çalışırsanız, bu durum oluşabilir. Çoğu nesneler isimleri en az 1 karakter gerektirir.

İthalat ifadeleri

Iskelet komut başında olduğunu unutmayın gibi ifadeler vardır İthalat ABACUS.ObjectModel. Bu ifadeler zaten komut dosyası tarafından başvurulan olmayan bir dll dahil olmaz - onların amacı bir sınıfın tam adını belirtmek zorunda için 'kısayolu' sağlamaktır.

Örneğin, birlikte, tip CKomponent bir değişken (ABACUS'te bir bileşen temsil eden) ilan İthalat ABACUS.ObjectModelscript üst kısmına doğru beyanı, sadece ilan edilecek gerektirecektir CKomponent olarak loş abone olDerleyici CKomponent sınıfı için ABACUS.ObjectModel ad bakmak bildiği için. Ithalat açıklamada olmadan, o kadar ilan edilmesi gerekir ABACUS.ObjectModel.CComponent olarak comp dim. Bir düzenek (örneğin mscorlib.dll olarak, ya da System.Windows.Forms.dll) birden ad içerebilir - İthalat ifadesi değil meclisleri kendileri için, bu ad içindir. ABACUS.ObjectModel.dll montaj sadece Scripting üzerinden erişilebilir tek ABACUS.ObjectModel ad vardır.

Otomatik başvurulan derlemeler

Aşağıdaki DLL Scripting tarafından otomatik olarak başvurulan:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· (Örtük derleyici tarafından başvurulan) microsoft.visualbasic.dll'de

· ABACUS.ObjectModel.dll

Diğer .NET derlemeler, veya kendi meclisleri ya ek başvurular yapmak için aşağıdaki bölüme bakın #ImportDLL bildirimi.

#ImportDLL Bildirimi

ABACUS'e 3.1 başlayarak, sen kullanımı ile komut dosyası için isteyebilir ek derlemeleri başvuruda bulunabilir #ImportDLL bildirimi. Eğer senin özel bir DLL erişmek ve içinde işlevselliğini kullanmak istiyorsa Örneğin, siz ABACUS dizine koyun ve komut ilk satırına (ler) olarak ifadesi yer alacak. Bir .NET dll ise, normalde yolun tamamını, sadece DLL girmeniz gerekmez.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.xml.dll

Diğer bazı şeyler dikkat:

1. DLL derleme ve zamanında bulunabilir gerektiğinden, bu sadece ABACUS program klasöründe konuyor özel (non NET) dll kısıtlar.

2. #ImportDLL ifadeleri bir komut dosyası ilk satırı (ler) olmalıdır - Eğer 5 ifadeleri varsa, o zaman senaryonun ilk 5 hatları üzerinde olmalıdır

3. Bir #ImportDLL deyimi yere yerleştirilebilir ama (bir açıklama ya da ithalat açıklamasının ardından yerleştirilmiş olsaydı, örneğin) yazısının ilk satırları düzgün çalışamayacak ve / veya alakasız derleyici hataları neden olabilir.

#Ofis Meclisleri ile ImportDLL

Microsoft Office yüklü ve script Ofis birlikte çalışma derlemeleri gerektiriyorsa, bu kullanarak sadece onları başvurmak mümkündür #Aşağıda listelenen (derleme adı ile ImportDLL, örneğin #ImportDLL Excel). Bu yöntemi kullanarak mutlak dll yolu kullanılmak zorunda değildir avantajına sahiptir, böylece komut (komut düzenleme olmadan hem Office 2003 ve 2007 çalışması gerekir) daha taşınabilir.

Bu özelliği kullandığınızda, GAC (Global Assembly Cache) birlikte çalışma derlemesi aranır ve bulursa komut o derleme yolu ile derler. Bulduğu değilse, komut dosyası ABACUS program dizinini kontrol eder (Excel içerir ve Visio sadece interops). İstenen birlikte çalışma bu zamana kadar bulunmazsa, bir uyarı gösterilir.

Eğer (tam ABACUS kurulumunun bir parçası olan) .NET Framework yüklemeden önce Microsoft Office yüklediyseniz interops genelde GAC yüklü değil. Sen Ekle / Microsoft Office için değiştirme seçeneği yaparak bunları yükleyin Program Kaldır ve .NET programlama seçeneklerini seçebilirsiniz. Daha fazla bilgi için, bkz bu makale MSDN.

Bu kısayol desteklendiği için derlemeleri şunlardır:

· Erişim

· Access.Dao

· Excel

· Grafik

· MSProject

· Görünüm

· OutlookViewCtl

· Owc11

· Priz

· Yayımcı

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Kelime

IYukarıdaki tüm montajlar bazı kullanıcılar Şubat bile karanlık montajlar için bir ihtiyaç var gibi Odalar bu özellik regardeless dahil yaptırılmıştır, Faydalı eğer t tam olarak belli değil.

Ayrıca bakınız

Senin mimarisi benzetme