Beth mae ABACUS ei wneud?

Navigation: Cyflwyniad i ABACUS>

Beth mae ABACUS ei wneud?

Anfon sylwadau ar y pwnc hwn.

I gael cymorth mewn ieithoedd eraill / cyfieithiadau cliciwch yma .

ABACUS yn cymryd y dyfalu-gwaith allan o ymdrin â datrysiadau, systemau, meddalwedd, gwybodaeth, technoleg, prosesau busnes a / neu fentrau cyfan (y cyfeirir atynt gyda'i gilydd fel saernïaeth). Gall eich helpu i gynllunio bragmataidd, monitro, efelychu, dadansoddi, a delweddu eich pensaernïaeth drwy fodelu iddo, ei ddadansoddi mewn ffyrdd sythweledol (ee siartiau, diagramau a 3D) ac yna gwerthuso yn erbyn eich anghenion nad ydynt yn swyddogaethol.

Nodyn

Gofynion di-swyddogaetholyn ofynion hynny nad ydynt yn ymwneud yn uniongyrchol â SUT cynnyrch yn gweithredu. Yn hytrach, maent yn ymwneud â pha mor dda y mae'n gweithredu. Gofynion Di-swyddogaethol yn cynnwys pethau fel perfformiad, bod yn agored, evolvability, ansawdd, scalability, modiwlau, ac ati (yn hytrach na gofynion swyddogaethol fel, trowch ar olau hwn pan y botwm hwn ei glicio). Yn draddodiadol, gofynion heb fod yn swyddogaethol wedi bod yn anodd - os nad yn amhosibl - i fesur. Yn wir, ABACUS yw'r unig gynnyrch a all wrthrychol ac yn quantifiably mesur y tri cyntaf - perfformiad, bod yn agored, A evolvability.

Yn syml, byddwch yn mynd i mewn i'r bensaernïaeth a'r hyn yr ydych yn ei gwneud yn ofynnol iddo ei wneud. ABACUS wedyn yn dweud wrthych os bydd yn ei wneud yn ôl y gofyn ac yn nodi unrhyw wendidau neu fylchau.

ABACUS tynnu ar dros 20 mlynedd o waith ymchwil systemau a llawer mwy o theori systemau sefydledig flynyddoedd. Mae'n rhoi mesuradwy ddibynadwy, atebion, gwrthrychol i chi, felly nad ydych yn dibynnu ar asesiad goddrychol.

ABACUS yn sefyll am Architecture-Based Analysis, Cfathrebu a Understandingo Systems. Gall eich helpu gydag unrhyw bensaernïaeth raddfa fawr, ond caiff ei ddefnyddio yn gyffredinol ar gyfer pedwar (4) peth:

· Esblygupensaernïaeth gyfredol. Er enghraifft, os yw eich pensaernïaeth presennol yn brin o berfformiad, bydd ABACUS delweddu bensaernïaeth ar eich cyfer, gan nodi'r problemau (tagfeydd, ac ati), yna yn dweud wrthych yn unionsut i wella y bensaernïaeth.

· Dyluniopensaernïaeth newydd. Er enghraifft, os oes angen pensaernïaeth cwbl newydd, ac rydych yn dylunio eich hun, bydd ABACUS yn dweud wrthych yn unionpa gydrannau rydych ei angen a sut y dylid eu cysylltu.

· Prynupensaernïaeth newydd. Er enghraifft, os ydych wedi galw am dendrau ar y dyluniad o bensaernïaeth newydd, ac rydych yn dewis rhwng tri dyluniad, bydd ABACUS yn dweud wrthych yn unionpa un fwyaf addas i'ch gofynion gorau.

· Cyfunosaernïaeth presennol ar hyn o bryd. Er enghraifft, os oes angen i gyfuno dau neu fwy o saernïaeth ar wahân, ABACUS yn eich arwain.

Gweler Hefyd

Sut y byddwch yn ei wneud (Trosolwg) | Beth yw pensaernïaeth? | Sut mae pensaernïaeth cynrychioli yn ABACUS?

© Cedwir 2001-2015 Avolution Pty Ltd Cedwir pob hawl.


Sut i ddefnyddio ABACUS (Trosolwg)

Navigation: Cyflwyniad i ABACUS>

Sut i ddefnyddio ABACUS (Trosolwg)

Anfon sylwadau ar y pwnc hwn.

Mae'r pwnc hwn yn cynnig gorolwg sylfaenol o'r tasgau sy'n gysylltiedig â defnyddio ABACUS.

Mae'r diagram canlynol yn dangos y broses ddadansoddi ar sail pensaernïaeth-y ABACUS yn darparu ar gyfer esblygu bensaernïaeth presennol i bensaernïaeth newydd neu darged.

Y Broses ABACUS

I ddefnyddio'r ABACUS:

1. Archwilio - Cyn i chi ddefnyddio ABACUS, rhaid i chi gasglu'r holl wybodaeth sydd gennych am y bensaernïaeth, a'i ofynion.

· Pensaernïaeth - Nodi'r cydrannau posibl y bensaernïaeth a sut y maent yn rhyngweithio. Dylid dim ond ychydig o cydrannau ar y lefel uchaf. Gelwir y rhain yn "elfennau hanfodol". Dylai hyd yn oed y saernïaeth mwyaf cymhleth yn cael llai na 10 elfennau hanfodol. e.e. Efallai y bydd y elfennau hanfodol o bensaernïaeth cwmni yswiriant fod polisïau, derbynebau, hawliadau, a thaliadau.

· Gofynion- Mae'n rhaid i chi wybod beth a ddisgwylir gan y bensaernïaeth er mwyn penderfynu os yw'n foddhaol. e.e. Nifer y trafodion yr awr.

· Ble ydych chi'n ei chael hi'n? - Gall y wybodaeth hon yn dod o ofynion manylebau, dogfennau cynllunio, cyfweliadau â rhanddeiliaid, mae'r cod lleoli, ac yn y blaen Yn y bôn unrhyw ddeunydd sydd ar gael yn cynnig gwybodaeth ABACUS am y bensaernïaeth.

2. Boblogi -Defnyddiwch ABACUS i fodelu eich pensaernïaeth ac i nodi'r gofynion y bydd y bensaernïaeth yn cael ei fesur yn erbyn.

· Pensaernïaeth - Yn ABACUS byddwch yn dechrau allan gyda phensaernïaeth gwag - mae gennych i boblogiiddo. Mae hyn yn golygu mynd i mewn yr holl wybodaeth yr ydych pensaernïaeth a gasglwyd uchod. Gallwch boblogi eich pensaernïaeth llaw (gan ddefnyddio'r ddewislen dde-glicio), neu gallwch lenwi yn awtomatig (o Microsoft Visio, Excel, Access ac ati). Yn nodweddiadol, bydd y top-rhan fwyaf o lefelau (mwy haniaethol) o'r bensaernïaeth yn cael ei phoblogaeth â llaw, a bydd y lefelau is (mwy concrit) yn cael ei phoblogaeth yn awtomatig.

· Gofynion - Wrth i chi ychwanegu eich cydrannau a chysylltiadau, eich bod yn nodi eu priodweddau. Yn y rhan fwyaf o achosion, bydd yr eiddo hyn yn gofynion y bensaernïaeth. Er enghraifft, os bydd gennych 1,250 MIPS nod / clwstwr, fyddech chi'n ei ychwanegu y nôd fel elfen, yna ychwanegwch yr eiddo perfformiad, a phennu gwerth o 1250 MIPS.

3. Dadansoddi - Defnyddiwch ABACUS i ddadansoddi gain a delweddu strwythur cymhleth eich pensaernïaeth.Rydych yn Gall dadansoddi eich pensaernïaeth mewn nifer o ffyrdd, neu o nifer o safbwyntiau, gan gynnwys diagramau, 3D a Explorer. Fel arall, efallai y byddwch yn dymuno defnyddio rhai golygfeydd mwy penodol, fel a ganlyn:

· Siart eich pensaernïaeth - i gael perfformiad (amser ymateb, lled band, ac ati), cost (bar, pastai, ac ati) neu evolvability (ofod gallu, masnach-off, ac ati) safbwyntiau.

· Creu adroddiad ar eich pensaernïaeth.

4. Efelychu - Defnyddiwch ABACUS i efelychu perfformiad, argaeledd, cost, bod yn agored eich pensaernïaeth yn, ac ati

· I wneud hyn, yn rhedeg un o'r efelychwyr. ABACUS yn gwerthuso eich pensaernïaeth yn erbyn eich gofyniondrwy berfformio efelychiad. Mae'n darllen ac yn dadansoddi y bensaernïaeth bresennol, yn rhedeg efelychiadau, ac yn cyfrifo rhai eiddo newydd. Yna eiddo hyn yn cael eu cadw yn ôl at y bensaernïaeth. Mae'r eiddo newydd yn y data rydych yn ceisio ei dadansoddi, megis defnyddio, amser ymateb, lled band,% sydd ar gael, TCO etc.

5. Peiriannydd- Defnyddio ABACUS i ateb gwahanol "beth os" senarios a rheoli esblygiad eich pensaernïaeth. Peirianneg yw'r broses o ailadrodd y Boblogi - Dadansoddi - Efelychubeicio.

· Ar y pwynt hwn, byddwch ynI wediyn ôl pob tebyg wedi datblygu dealltwriaeth o'r Pensaernïaeth presennol ac amlygodd yr ardaloedd sydd angen i chi i esblygu. Yn aml iawn, fodd bynnag, bydd angen i chi ailadrodd y boblogi - Dadansoddi - proses Efelychu nifer o weithiau. Mae'n debyg y bydd hyn fod oherwydd gall gymryd ychydig o iteriadau cyn i chi ddod o hyd i'r Pensaernïaeth Targed. Hefyd, os yw eich pensaernïaeth yn gymhleth iawn, efallai y byddwch am ailadrodd y broses ar gyfer pob pensaernïol "lefel".

6. Cynllundyfodol eich pensaernïaeth gan ddefnyddio'r wybodaeth a ddarperir gan ABACUS.

Nodyn

Os nad ydych yn ceisio i ddatblygu pensaernïaeth sy'n bodoli eisoes, efallai y bydd angen i chi ailadrodd rhai camau nifer o weithiau, ac mewn trefn wahanol. Mae'n dibynnu ar yr hyn yr ydych yn ceisio do. Er enghraifft, os ydych yn cynllunio pensaernïaeth newydd, mae'n debyg y byddwch yn unig yn boblogi eich pensaernïaeth unwaith, ac yna defnyddio ABACUS dros gyfnod hir o amser i arwain esblygiad (au) yn y dyfodol y bensaernïaeth. Ar y llaw arall, os ydych yn prynu pensaernïaeth newydd a chael nifer o ddewisiadau eraill i ddewis ohonynt, bydd angen i chi Darganfod a Poblogi gyfer pob un o'r dewisiadau eraill, ac yna Dadansoddi a Efelychu pob un yn annibynnol cyn perfformio cymhariaeth derfynol ar y diwedd.

Gweler hefyd

Beth mae ABACUS ei wneud? | Beth yw pensaernïaeth? | Sut mae pensaernïaeth cynrychioli yn ABACUS? | Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth | Efelychu eich pensaernïaeth


Beth yw pensaernïaeth?

Navigation: Cyflwyniad i ABACUS>

Beth yw pensaernïaeth?

Anfon sylwadau ar y pwnc hwn.

Pensaernïaeth yn haniaethol cysyniad- Nid yn gorfforol beth. Mae'n ddisgrifiad neu ddealltwriaeth gyfoethog a chynhwysfawr o strwythur system - gan ddal y cydrannau a sut y maent yn cysylltu (yn rhyngweithio). Oherwydd bod y syniad o bensaernïaeth mor hollgynhwysol, mae'n hanfodol i gost, argaeledd, evolvability, bod yn agored, a pherfformiad y system. Mae pensaernïaeth sain yn rhagofyniad o system sain.

Yn ABACUS, byddwch yn modelu eich pensaernïaeth. Er hwylustod, rydym yn galw hyn model pensaernïol pensaernïaeth.

Mae'r diagram isod yn dangos pensaernïaeth nodweddiadol o 5cydrannau (Mewn hierarchaeth) cysylltu gan 2 cysylltiadau. Mae'r labeli yn dangos yr enwau a roddwyd i'r gwahanol rannau o'r bensaernïaeth yn ABACUS.

Mae pensaernïaeth syml

ABACUS yn ystyried pob un o'r pethau hyn i fod yn rhan o'r bensaernïaeth:

· Cydrannaugynrychioli endidau eich pensaernïaeth y gallech ddisgrifio fel "pethau". Ar gyfer cwmni yswiriant, efallai y cydrannau fod y systemau ar gyfer polisïau prosesu, hawliadau, taliadau, a derbyniadau.

· Cysylltiadaugynrychioli'r berthynas rhwng cydrannau hyn. Er enghraifft, yn gwmni yswiriant, derbynebau yn cael eu creu ar gyfer polisïau dilys, hawliadau yn cael eu gwneud yn erbyn polisïau dilys, a hawliadau dilys yn arwain at daliadau. Wrth feddwl yn bensaernïol - yn enwedig wrth ddefnyddio ABACUS - cysylltiadau mor bwysig â chydrannau, ac maent yn cael eu trin mewn ffordd bron yn union yr un fath.

· Gall popeth yn y goeden gael Priodweddau. Eiddo pethau fel y ffordd yr ydych ei gwneud yn ofynnol eich system i berfformio, mae nifer o linellau o god ganddo, mae canran y llinellau hyn sy'n cael eu sylwadau, ac ati ABACUS yn ystyried pob un o'r pethau hyn i fod yn rhan o'r bensaernïaeth.

· Trwy ddefnyddio hierarchaethau(H.y. is-cydrannau ac is-gysylltiadau), Gallwch guddio gwybodaeth a dad-cyfansoddi eich pensaernïaeth. Mae'r model pensaernïol ABACUS yn hynod hyblyg. Gall unrhyw gydran ar unrhyw lefel yn gysylltiedig ag unrhyw gydran arall ar unrhyw lefel arall gan unrhyw gysylltiad ar unrhyw lefel.

· Ymlyniadyw gweithrediad y mae cydrannau porthladdoedd yn siwr o gysylltiadrolau. Porthladdoedd ac Rolau yw'r rhyngwynebsrhwng cydrannau a chysylltiadau. Maent yn cael eu defnyddio i atodi cysylltiadau i gydrannau. Cysylltiadau yn cael Ffynhonnell a Sinc rôl(Hwyluso llif data o gydran ffynhonnell i'r gydran sinc)ac yn gysyniadol, cydrannau wedi porthladdoedd. Er hwylustod, fodd bynnag, mewn ABACUS porthladdoedd cydran yn cael eu heb eu dangos a'r rolau cysylltiad ynghlwm yn uniongyrchol i'r cydrannau eu hunain.

· Cydrannau a chysylltiadau sydd o penodol Math. Mae hyn yn bennaf at ddibenion dosbarthu. Er enghraifft, y polisïau, hawliadau, taliadau, a derbyniadau yn elfennau o'r 'System' math. Mae'r polisïau dilys, hawliadau dilys, ac ati yn cael cysylltiadau o'r 'Trafodion' math. Y Math neilltuo i cydran neu gysylltiad darparu templed ar gyfer yr eiddo a'r safonau sydd ganddo. Er enghraifft, efallai y math cydran Gweinyddwr wedi 'Gwneud a Model' safonolac eiddo Cyfeiriad IP. Yn wahanol arfau anhyblyg arall gyda perthynol cronfa ddata sylfaenol (BGY)-pen ôl, yn ABACUS gallwch rhydd greu eich Mathau newydd eich hun a aseinio eich cyfuniadau eich hun o eiddo a safonau iddynt.

· Gall llyfrgelloedd safon eiddo yn cael ei nodi ac yn neilltuo i unrhyw beth arall yn y bensaernïaeth. Mae'r llyfrgelloedd yn cael eu hadnabod fel Safonau. Trwy ddefnyddio Safonau, Dim ond angen i chi gasglu eiddo systemau penodol - y tai safonol eisoes yno. Er enghraifft, gall y nodweddion perfformiad safonol o Microsoft Windows 2000 yn cael ei neilltuo i ba bynnag cydrannau yn defnyddio'r system weithredu Microsoft Windows 2000.

Gweler Hefyd

Sut mae pensaernïaeth cynrychioli yn ABACUS? | Beth mae ABACUS ei wneud? | Sut y byddwch yn ei wneud (Trosolwg) | Creu Math newydd


Mae'r rhyngwyneb ABACUS

Navigation: Cyflwyniad i ABACUS>

Mae'r rhyngwyneb ABACUS

Anfon sylwadau ar y pwnc hwn.

Pan fyddwch yn dechrau ABACUS, byddwch yn gweld y brif sgrîn, sy'n wag ac eithrio ar gyfer y bwydlenni a'r bar offer ar y brig, ffenestr Explorer gwag a rhaid nodi teitl-bar. Bydd y sgrin hon fod yn ganolbwynt eich rhyngweithio gyda ABACUS.

Y prif elfennau yw:

· y prif ddewislenni

· y barrau offer

· y ddewislen clic dde

· ffenestri fforiwr ac eiddo

· y bar statws

Y prif bwydlenni

Mae'r bwydlenni yn cael eu trefnu mewn trefn resymegol.

Mae'r bwydlenni yn cael eu disgrifio fel a ganlyn;

· Ddewislen File- Mae'r ddewislen File eich galluogi i greu, agor, cau, cadw, allforio a chyhoeddi ffeiliau ABACUS. Mae hefyd yn eich galluogi i greu, yn agored, yn agos a chadw ffeiliau Llyfrgell ABACUS.

· Golygu ddewislen- Ddewislen Edit yn eich galluogi i dorri, copïo, past, dileu, ail-enwi, dod o hyd a threfnu elfennaua dadwneud / ail-wneud gweithrediadau.

· Ddewislen View- Mae'r ddewislen View yn eich galluogi i agor neu gau y gwahanol rhyngwyneb Windows a statws bar, Navigate ymlaen ac yn ôl, ewch i safbwyntiau penodol a rheoli dangosfyrddau.

· Mewnosod ddewislen- Mae'r Mewnosod ddewislen caniatáu i chi ychwanegu newydd safonau, Templedi, mathau, elfennau, golygfapwynts, Catalogau, diagramau, siartiau, Adroddiadau a matricsau.

· Dewislen Dadansoddi- Mae'r fwydlen Dadansoddiad eich galluogi i redeg gwerthusiadau yn erbyn pensaernïaeth gan gynnwys; perfformiad, cost, dibynadwyedd, modiwlau a bod yn agored.

· Offer ddewislen- Mae'r ddewislen Tools caniatáu i chi redeg sgriptio, nodau a osodwyd ar gyfer y bensaernïaetha pherfformio a 'diff' pensaernïaeth. Gallwch hefyd addasu opsiynau y rhaglen a customize 'r rhyngwyneb o'r ddewislen offeryn.

· Dewislen Ffenestr- Mae'r fwydlen Ffenestr yn eich galluogi i doc, trefnu, yn dangos a chuddio y ffenestri sydd gennych ar agor.

· Help ddewislen- O'r ddewislen Help gallwch gael mynediad y ffeil help ABACUS. Gallwch gael mynediad i'r wefan, weld eich trwydded cytundeb a gweld manylion cyffredinol am ABACUS gan gynnwys y fersiwn o'r meddalwedd a chefnogaeth a manylion cyswllt ABACUS. Gallwch roi adborth drwy dudalen mater hysbysu. Os bydd angen, gallwch fynd i mewn i allwedd cofrestru trwy'r ddewislen Help.

Mae hyn yn y drefn y byddwch fel arfer yn dilyn pan fyddwch yn cyflawni eich tasgau;Unwaith y byddwch wedi creu neu agor ffeil, Byddwch fel arfer yn boblogi eich pensaernïaeth, yna barn(mewn Explorer, diagramau, 3D, Siartiau, ac ati). Ar y pwynt hwn, byddwch naill ai'n rhedeg gwerthuswr, Neu byddwch yn ailadrodd y broses gyda'r un bensaernïaeth neu bensaernïaeth gwahanol. (Gweler Sut i ddefnyddio ABACUS (Trosolwg) am fanylion pellach.)

Edrychwch drwy'r prif ddewislenni ac yn ceisio dychmygu sut y byddwch yn eu cymhwyso i'ch system.

Nodyn

Gallwch Addaswch eich bwydlenni ar unrhyw adeg.

Mae'r bariau offer

Yn ddiofyn, mae y barrau offer canlynol;

· y Brif bar offer -

· y Efelychu bar offer -

· mae'r View bar offer -

· y Offeryn Diagrambar (os yw diagram yn agored) -

· y Macro Cofnodi bar offer -

Edrychwch drwy'r botymau ar bob bar offer drwy hofran dros nhw i weld y teclyn-tip (shortcut-allweddol).

Nodyn

Bydd Dim ond rhai botymau fod yn weithgar yn dibynnu ar yr hyn yr ydych wedi dewis yn y ffenestr Explorer a gallwch Addasu'ch bariau offer ar unrhyw adeg.Yn ogystal, mae'r 'Validate / Gwirio Cyfyngiadau Prosiect' botwm ar Brif bar offer a bydd y botymau ar y bar offer Efelychu tynnu sylw at Coch pan fydd newid i'r ystorfa sylfaenol yn gofyn am ail-ddilysu y prosiect neu ail-efelychiad o hynny efelychydd yn y drefn honno. Hofran dros y botwm i weld pa saernïaeth yn cael eu heffeithio.

Mae'r fwydlen dde-glicio

Y prif fwydlenni a bariau offer yn Nia ddefnyddir ar gyfer popeth, er. Mae'n aml yn fwy cyfleus i ddefnyddio'r dde-glicio chyd-destun ddewislen ar gyfer gwahanol weithrediadau. (Hefyd, nid yw pob un o'r gorchmynion sydd ar gael drwy dde-glicio ar gael drwy'r prif ddewislenni, bariau offer, neu orchmynion bysellfwrdd.)

Er enghraifft, unwaith y byddwch wedi creu ffeil, ac mae gennych diagram coeden o'ch pensaernïaeth, mae'n well i dde-gliciwch ar Pensaerniaethau yn y goeden i ychwanegu bensaernïaeth newydd. Yn yr un modd, dylech de-gliciwch ar Cydrannau i ychwanegu elfen newydd. Cliciwch y botwm dde ar rai pethau yn y goeden i weld beth y gallwch ei wneud.

Tip

Yn gyffredinol, byddwch yn defnyddio'r prif ddewislenni i gyflawni'r tasgau mwy o lefel uchel, fel gwerthuso eich pensaernïaeth. Mae'r tasgau lefel isel - fel ychwanegu cydrannau a chysylltiadau unigol - yn cael eu gwneud gan ddefnyddio'r toolbars a / neu ddewislen clic-dde.

Mae'r ffenestri fforiwr ac eiddo

Pan fyddwch yn agor neu'n creu ffeil, bydd diagram coeden arddangos yn y ffenestr Explorer. Mae'n ffenestr i mewn i'ch pensaernïaeth. Ac wrth i chi ddewis elfennau o fewn y ffenestr Explorer tri ffenestri eraill; yr Eiddo Cyffredinol, Cyfeiriadaua bydd ffenestri Properties diweddaru i adlewyrchu gwybodaeth fanwl am eich dewis.

Nodyn

Y Properties Cyffredinol, Cyfeiriadaua ffenestri Eiddo yn cael eu cuddio yn ddiofyn. Gweler Addasu'r rhyngwyneb ar sut i Dadguddio hwy ac o bosibl yn gadael eu harddangos yn barhaol.

Tra byddwch yn adeiladu eich pensaernïaeth, y ffenestri Explorer ac Eiddo yw'r gynrychiolaeth fwyaf defnyddiol. Oherwydd gellir eu dymchwel ac ehangu yn ôl y gofyn, ac nid ydynt yn mynd yn feichus.

Mae gan y ffenestr Explorer yn Coed (a bar Statws) a'r ffenestri Properties wedi 5adran:

· Math

· Safonau

· Disgrifiad

· Cyfeiriadau

· Priodweddau

ABACUS yn ystyried pob un o'r pethau hyn i fod yn rhan o'r bensaernïaeth.

Coed

Mae'r adran hon mae coeden grwpio yn 3 ardal fel a ganlyn:

1. Meta-model

· Safonau- Os oes nifer o elfennau yn cael yr un set o eiddo, gallwch ddiffinio set ymlaen llaw, ac yna dim ond neilltuo i'r cydrannau. Mae'r un peth yn wir am gysylltiadau ac unrhyw un o'r elfennau eraill. Mae'r rhain yn set o eiddo safonol yn cael eu storio yn y Safonaucangen o'r goeden. Yn hytrach na diffinio pob eiddo ar gyfer pob cydran, a phob eiddo ar gyfer pob cysylltiad ac ati, dim ond neilltuo safonol. Er enghraifft, mae'r nodweddion safonol Unix-HP / UXgellir ei arbed fel Safon ac ei neilltuo i unrhyw gydrannau sy'n defnyddio'r Unix-HP / UXsystem weithredu fel y dangosir gyfer y OS01 gweinydd yn y screenshot uchod.

· Mathau - Mae'r gangen o'r goeden yn llyfrgell o'r mathau o gydrannau a chysylltiadau y gallwch eu defnyddio. Mathau cael eu defnyddio i ddiffinio'r meta-model ar gyfer eich pensaernïaeth ac ar gyfer dosbarthu a hidlo wrth edrych ar eich pensaernïaeth. Maent hefyd yn penderfynu templed ar gyfer yr hyn safonau, Eiddo a chyfyngiadau eich cydrannau / gall cysylltiadau gael.

· Gwylfannau- ViewpwyntGellir s yn cael eu creu o ddiagramau presennol a gellir ei ddefnyddio i greu diagramau newydd.Maent yn stensiliau diagram.

· Templedi - Storio Templedi y gellir eu hailddefnyddio patrymau cydrannau a chysylltiadau ynghyd â'r modd y maent yn cael eu cynrychioli neu weld. Gellir eu hystyried yn saernïaeth neu atebion "mini" y gellir eu rhoi mewn saernïaeth presennol.

2. Pensaernïaeth -Mae'r Pensaerniaethau gangen y goeden yw lle byddwch yn adeiladu y pensaernïaeth (Au) eich system. (Gelwir hyn yn poblogi'r bensaernïaeth.) Gallwch gael unrhyw nifer o saernïaeth mewn ffeil ABACUS sengl.

3. Dangosfyrddau - Mae cangen Dangosfyrddau y goeden yn lle y gallwch gael gafael ar unrhyw achub dangosfyrddau ar gyfer y prosiect.

Nodyn

Eitemau yn y goeden Explorer sydd wedi cael eu Caniatâd Diweddariad dileu (hy maent yn cael eu darllen yn unig) yn cael eu dangos yn llwyd.

Math

Mae'r adran hon yn dynodi y cydran neu gysylltiad math penodol o elfen a ddewisir ar hyn o bryd yn y goeden.

Safonau

Mae'r adran hon yn rhoi rhestr o'r safonau am yr elfen a ddewiswyd ar hyn o bryd yn y goeden.

Disgrifiad

Mae'r adran hon yn rhoi disgrifiad byr o'r elfen a ddewiswyd yn y goeden. Gall unrhyw hypergysylltiadau cysylltiedig hefyd yn cael eu hychwanegu at yr adran hon. Mae'r rhain yn cynnwys gwefannau neu lwybrau absoliwt lleol pwyntio i wybodaeth bellach am yr elfen a roddir. Llinellau lluosog hefyd yn cael eu caniatáu. Mae angen i hypergysylltiadau dilys i ddechrau gydag un o 5 dannau; http: //, https: //, ftp: //, ffeil: /// neu mailto :.

Tip

Ar gyfer hypergysylltiadau gyda mannau, gall defnyddwyr deipio yn yr URL neu lwybr, dewiswch y testun ei angen ac Right Click| Hyperlink. Bydd hyn yn newid unrhyw leoedd i % 20felly bydd y URL cyfan neu lwybr yn gweithio'n gywir.

Crëwyd a Addaswyd

Mae'r rhain yn adransdarparuy defnyddiwr a'r dyddiad / amser ar gyfer creu, ac addasu olaf i, yr elfen a ddewisir ar hyn o bryd yn y goeden.

Cyfeiriadau

Mae'r adran hon yn rhoi rhestr o'r cydrannau mynd allan ac yn dod i mewn am yr elfen a ddewiswyd ar hyn o bryd yn y goeden.Mae hefyd yn dangos y diagramau, 3D a golygfeydd Siart fod yr elfen a ddewisir ar hyn o bryd yn ymddangos mewn. Os diagram dewisir mae'n dangos y Viewpoint os yn berthnasol ar gyfer y diagram ac am eu barn yn gyffredinol ei fod yn dangos unrhyw Dangosfyrddau y farn yn ymddangos yn. A phan Safon ei ddewis yn y goeden mae'n dangos y defnydd o'r safon erbyn mathau, cydrannau a chysylltiadau.

Priodweddau

Mae'r adran hon yn lle rydych yn diffinio nodweddion yr elfennau o fewn eich pensaernïaeth, fel y ffordd yr ydych ei angen i berfformio, mae nifer o linellau o god ganddo, mae canran y llinellau hyn sy'n cael eu sylwadau, ac ati

Mae'r 'mewnbwn' ac eiddo 'allbwn' y cyn-adeiladu efelychwyr Bydd yn cael ei ddangos yn y ffenestr Properties gydag eicon selector rhes mewnbwn eiddo ( [image] ) Ac icon allbwn ( [image] ) Yn y drefn honno gyda tooltip nodi pa cyn-adeiladu efelychydd yr eiddo yn gysylltiedig â, ee 'Allbwn gyfer modiwlau' neu 'Mewnbwn Perfformiad'. Bydd y saeth ar yr eiconau allbwn yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo wedi dyddio oherwydd eiddo gwaelodol neu newid strwythurol i'r ystorfa gyda'r efelychydd sy'n gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar Bar offer Efelychu .

Mae'r bar statws

Mae'r rhan chwith y bar statws yn dangos y llwybr llawn i'r elfen ystorfa yn-ffocws ar hyn o bryd, naill ai ddewis yn y ffenestr Explorer neu ar y diagramgynfas. Mae hyn yn fel y gall yr union le yn yr hierarchaeth ystorfa ar gyfer yr elfen a roddir yn cael ei benderfynu yn hawdd bob amser. Mae'r rhan llaw chwith y bar statws yn dangos amryw o negeseuon gweithredol megis 'ABACUS Open File llwyddiannus' a 'Cyfrifo Cost Cwblhawyd'.

Gweler Hefyd

Sut y byddwch yn ei wneud (Trosolwg) | Addasu'r rhyngwyneb | Beth yw pensaernïaeth? | Sut mae pensaernïaeth cynrychioli yn ABACUS? | Gan weithio gyda ffeiliau ABACUS


Addasu rhyngwyneb ABACUS

Navigation: Cyflwyniad i ABACUS>

Addasu rhyngwyneb ABACUS

Anfon sylwadau ar y pwnc hwn.

Gallwch newid ymddangosiad ac ymddygiad y rhyngwyneb ABACUS mewn sawl ffordd. ABACUS yn cynnwys nifer o gyfuniadau lleoliadau Rhagosodol y gallwch ei ddefnyddio i wneud cais grŵp o customisations i'r rhyngwyneb. Yn ogystal, gallwch wneud customisations unigol i eitemau fel ffenestri, toolbars, allweddi llwybr brys, ac opsiynau amrywiol arddangosfeydd.

Trefnu a Windows Doc

Mae gennych lawer o opsiynau ar gyfer trefnu ffenestri o fewn y rhyngwyneb ar gyfer ABACUS, gan gynnwys y canlynol:

· Ffenestri tab-doc.

· Ffenestri doc i ymyl ffrâm yn y rhyngwyneb.

· Lleihau ffenestri offeryn ar hyd ymyl y rhyngwyneb.

· Ailosod lleoliad ffenestr i gynllun diofyn.

Ffenestri Tocio

Pan fydd ffenestr yn dockable, gellir ei glymu i un ochr ffrâm o fewn y rhyngwyneb, neu gellir trefnu ar chwareli Tabbed o fewn y ffrâm. Ymddengys Canllaw diemwnt pan fyddwch yn llusgo ffenestri o'u lleoliad presennol i leoliad arall yn y rhyngwyneb. Mae'r diemwnt canllaw yn caniatáu i chi yn gyflym yn ail-doc ffenestr ar un o'r pedair ochr y ffrâm neu yn y canol fel cwarel Tabbed. Pan fydd ffenestr yn thociwyd mo'u neu beidio dockable, mae'n arnofio ar ben y ffenestri eraill.

I doc ffenestri

1. Cliciwch ar y ffenestr ydych am i doc, i roi ffocws.

2. Ar y Ffenestrddewislen, cliciwch Dockable.

3. Llusgwch y ffenestr o'i leoliad presennol tua chanol y ffrâm rydych am ei doc 'i ag.

Canllaw diemwnt yn ymddangos. Y pedwar saethau o'r pwynt diemwnt tuag at y pedwar ymylon y ffrâm ac mae'r ganolfan yn cynrychioli'r cwarel tabbed.

Tip

I symud dockable ffenestr heb clecian i mewn i le, y wasg CTRL tra lusgo.

4. Pan fydd y ffenestr yr ydych yn llusgo yn cyrraedd y sefyllfa lle rydych eisiau i doc iddo, symudwch y pwyntydd dros y rhan cyfatebol y canllaw diemwnt. Amlinelliad o'r ffenestr yn ymddangos yn yr ardal ddynodedig.

5. I doc y ffenestr yn y sefyllfa a nodwyd, rhyddhau'r botwm llygoden.

Er enghraifft, os Exploreryn cael ei docio ar ymyl chwith y rhyngwyneb ac rydych am i doc ar yr ymyl dde, byddech yn llusgo Explorertua chanol y rhyngwyneb, yn symud y pwyntydd dros ochr chwith y canllaw diemwnt, ac yna rhyddhau'r botwm llygoden.

Lleihau Windows

Windows (p'un a ydynt yn Offeryn Windows - ymddangos ar y Viewfwydlen, neu Windows Dogfen - ymddangos ar y Ffenestrddewislen) yn cefnogi yn nodwedd o'r enw Auto Cuddio. Cuddio Auto yn eich galluogi i weld mwy o'ch pensaernïaeth ar un adeg trwy leihau'r ffenestri ar hyd ymylon y rhyngwyneb pan na ddefnyddir hwy.

I droi ar Cuddio Auto

1. Cliciwch ar y ffenestr ydych am guddio i roi ffocws.

2. Ar y Ffenestrddewislen, cliciwch Cuddio Auto.

- Neu -

2. Cliciwch ar yr eicon pushpin ar y bar teitl y ffenestr.

Cuddio Auto Galluog

Pan fydd ffenestr auto-cudd yn colli ffocws, 'n awtomatig sleidiau yn ôl i'w tab ar ymyl y rhyngwyneb. Er bod ffenestr yn auto-cuddio, ei enw a'i eicon i'w gweld ar dab ar ymyl y rhyngwyneb. I arddangos ffenestr auto-cuddio, symudwch eich pwyntydd dros y tab. Mae'r ffenestr sleidiau yn ôl i'r golwg ac yn barod i'w ddefnyddio.

Nodyn

Ni all ffenestr sy'n auto-cudd yn cael ei docio. I doc ffenestr bydd angen i chi droi oddi ar Cuddio Auto fel y disgrifir isod.

I ddiffodd Cuddio Auto

1. Cliciwch ar y ffenestr ydych am gadw weladwy i roi ffocws.

2. Ar y Ffenestrddewislen, cliciwch Cuddio Autoi glirio'r marc siec.

- Neu -

2. Cliciwch ar yr eicon pushpin ar y bar teitl y ffenestr.

Auto Cuddio Anabl

Tip

Ffenestri sydd wedi Auto Cuddio yn galluogi'r llithro dros dro i'r golwg pan fydd y ffenestr yn cael ffocws. I guddio y ffenestr eto, dewiswch eitem y tu allan i'r ffenestr gyfredol. Unwaith y bydd y ffenestr yn colli ffocws, mae'n sleidiau ôl allan o farn.

Ailosod Windows Cynlluniau

Gallwch ddychwelyd i'r rhyngwyneb i gynllun y ffenestr diofyn drwy ddefnyddio y Ailosod Ffenestr Layoutgorchymyn. Pan fyddwch yn rhedeg gorchymyn hwn, mae'r camau gweithredu canlynol yn digwydd:

· Bob ffenestr symud i'w swyddi diofyn.

· Ffenestri sy'n cael eu cau yn y cynllun ffenestr diofyn yn cael eu cau gan y gorchymyn.

· Ffenestri sy'n agored yn y cynllun ffenestr diofyn yn cael eu hagor gan y gorchymyn.

· Ffenestri sy'n cael eu cuddio / gweld yn y cynllun ffenestr rhagosodedig yn cael eu gwneud cudd / gweladwy gan y gorchymyn.

Er mwyn ailosod lleoliad ffenestr i gynllun diofyn

1. Ar y Windowsddewislen, cliciwch Ailosod Ffenestr Layout.

Teilwra Bwydlenni a Toolbars

Gallwch newid y gosodiad, lleoliad, a chynnwys bwydlenni a bariau offer yn y rhyngwyneb. Gallwch hefyd ychwanegu botymau i barrau offer a newid yr eicon a bennwyd ar gyfer unrhyw botwm.

Creu toolbars newydd

I greu bar offer newydd

1. Ar y Offerddewislen, dewiswch Customise.

2. Yn y Addasublwch deialog, dewiswch y Toolbarstab.

3. Dewis Newydd.

4. Yn y Newydd Bar Offerblwch deialog, teipiwch enw ar gyfer y bar offer.

5. Dewis iawn.

I ychwanegu botwm gorchymyn i ddewislen neu bar offer

1. Ar y Offerddewislen, dewiswch Customise.

2. Yn y Addasublwch deialog, dewiswch y Gorchmyniontab.

3. Dewiswch gategori a llusgwch meistrolaeth allan o'r blwch deialog i'r ddewislen neu'r bar offer.

4. Dewis Cau.

Tip

Dal i lawr y Alt-allwedd yn eich galluogi i gyflym addasu gorchmynion fel petai 'r dadl Customize ar agor.

Gweler Hefyd

Mae'r rhyngwyneb ABACUS


Gan weithio gyda ffeiliau ABACUS

Navigation: Cyflwyniad i ABACUS>

Gan weithio gyda ffeiliau ABACUS

Anfon sylwadau ar y pwnc hwn.

Mae ffeil ABACUS yn gynhwysydd ar gyfer model o'ch pensaernïaeth . O fewn un ffeil ABACUS, gallwch fodelu unrhyw nifer o saernïaeth unrhyw nifer o weithiau.

Pan fyddwch yn agor ABACUS gyntaf, nid oes ffeiliau ar agor. I weithio ar eich pensaernïaeth, mae'n rhaid i chi naill ai creu ffeil newydd, neu agor ffeil sydd eisoes yn bodoli.

Pan fyddwch yn agor neu'n creu ffeil newydd, bydd coeden yn y ffenestr fforiwr arddangos yn awtomatig. Mae'r olygfa fforiwr yn dangos i chi eich pensaernïaeth hyd yn hyn. Pan fyddwch yn cau y ffeil, bydd y goeden yn y ffenestr fforiwr hefyd yn diflannu.

I greu ffeil ABACUS newydd

1. Dewiswch Ffeil| Newydd ...

2. Yn yr ymgom Prosiect Newydd sy'n ymddangos (fel y dangosir isod) Dewisnaill ai chreu model gwag, yn fodel o llyfrgell safonol ABACUS , Model o lyfrgell ABACUS arfer, yn fodel o XML, MS Access , MS Visio , MS Excel , MS SQL Server , Mae Menter Gweinydd model neu lyfrgell ABACUS arfer (ffeil .abacuslib).

3. Cliciwch ar y iawnbotwm a dilynwch unrhyw deialogau a all ymddangos.

Tip

Ni fydd gofyn i chi enwi'r ffeil hyd nes y byddwch gynilo neu gau. Mae'n syniad da i gadw eich ffeil cyn gynted ag y byddwch yn ei greu. Yna, ni fydd yn rhaid i chi boeni am enwi yn ddiweddarach yn y broses pan fyddwch yn canolbwyntio ar bethau cymhleth eraill (fel boblogi'r eich pensaernïaeth).

Creu Prosiect Newydd

ABACUS Llyfrgelloedd Safonol

ABACUS yn cefnogi dros 100 fframweithiau cyhoeddus a nodiannau rhai ohonynt yn cael eu dangos isod. Wrth ddewis i greu prosiect newydd o safon o ddefnyddwyr llyfrgelloedd yn cael cychwyn cyflym i fodelu o fewn fframwaith sefydlu manteisio'n llawn ar unrhyw fathau elfen diffiniedig, priodoleddau, nodiannau, safbwyntiau a thempledi neu batrymau. Llyfrgelloedd safonol ychwanegol ar gael yn rhwydd trwy Gymuned Avolution yma .

Prosiect Newydd o Lyfrgell Safonol

I arbed ffeil ABACUS newydd

1. Dewiswch Ffeil| Save As

Tip

Gall enwau ffeiliau fod o unrhyw hyd, a gall gynnwys unrhyw cymeriadau a mannau alffaniwmerig. Ni allant gynnwys y tilde (~) cymeriad, y bibell (|) cymeriad, y marc cwestiwn, neu y cymeriadau a ddefnyddir fel arfer ar gyfer disgrifiadau llwybr fel yr slaes (\) - ac eithrio fel rhan o'r llwybr (?).

I agor ffeil ABACUS presennol

1. Dewiswch Ffeil| Agored

Nodyn

Os ydych yn agor ffeil o leoliad rhwydwaith a rennir sydd eisoes yn agored i ddefnyddiwr arall, bydd ABACUS rhoi mynediad Unig Read. Wrth ddefnyddio ABACUS gyda mynediad Unig Read, ni fyddwch yn gallu cyflawni gweithrediadau ysgrifennu, megis boblogi'r eich pensaernïaeth a rhedeg gwerthuswyr. Gallwch, fodd bynnag, weld eich pensaernïaeth ddefnyddio'r olygfa arloeswr a golygfeydd 3D.

Gweler Hefyd

Sut mae pensaernïaeth cynrychioli yn ABACUS?


Sut mae pensaernïaeth cynrychioli yn ABACUS?

Navigation: Cyflwyniad i ABACUS>

Sut mae pensaernïaeth cynrychioli yn ABACUS?

Anfon sylwadau ar y pwnc hwn.

Yn ABACUS, byddwch yn modelu eich pensaernïaeth. Er hwylustod, rydym yn galw hyn model pensaernïol pensaernïaeth.

Mae'r diagram isod yn dangos sut mae pensaernïaeth nodweddiadol o 5cydrannau (Mewn hierarchaeth) Byddai cysylltu gan 2 o gysylltiadau yn cael eu cynrychioli yn ABACUS.

Sut mae pensaernïaeth syml yn cael ei gynrychioli yn ABACUS

Gallwch gael unrhyw nifer o saernïaeth mewn ffeil ABACUS sengl.

Mae pensaernïaeth cyntaf yn y goeden

Fel arfer, byddech yn creu pensaernïaeth newydd pryd bynnag y byddwch eisiau i werthuso newid. Er enghraifft, byddech yn modelu eich pensaernïaeth presennol cyntaf - byddai hyn yn y bensaernïaeth cyntaf yn y goeden. Efallai y byddwch yn ei alw'n 'cyfredol'.

Mae'r ail

Pan fyddwch eisiau i fodelu a gwerthuso newid eich pensaernïaeth presennol (ee mwy o ofynion) y byddech yn creu pensaernïaeth newydd. Y ffordd hawsaf o wneud hyn fydd creu copi o 'cyfredol' ac yn ail-enwi 'i' Esblygiad 1 Rhoi cynnig 1 '. Byddai hyn yn yr ail bensaernïaeth yn y goeden. Os yw eich gwerthusiadau o 'Esblygiad 1 Rhoi cynnig 1' yn llwyddiannus, gallwch ail-enwi i yn syml 'Esblygiad 1'.

Mae'r trydydd

Os nad yw 'Evolution 1 Rhoi cynnig 1' yn bodloni eich gofynion, gallwch greu copi ohono, ail-enwi i 'Esblygiad 1 Rhoi cynnig 2', a ceisiwch eto. Byddai hyn yn y drydedd bensaernïaeth yn y goeden.

Gweler Hefyd

Beth mae ABACUS ei wneud? | Sut y byddwch yn ei wneud (Trosolwg) | Beth yw pensaernïaeth? | Gan weithio gyda ffeiliau ABACUS | Creu neu dyblygu pensaernïaeth


Help mewn ieithoedd eraill

Navigation: Cyflwyniad i ABACUS>

Help mewn ieithoedd eraill

Anfon sylwadau ar y pwnc hwn.

ABACUS cymorth ar gael mewn sawl iaith / cyfieithiadau eraill, a gellir eu lawrlwytho o'r dolenni isod.

I yn disodli'r ffeil cymorth presennol ABACUSgyda ffeil chymorth gyfieithu os gwelwch yn dda dilynwch y camau hyn:

1. Cadwch y ffeil help gan y ddolen berthnasol isod.

2. Ail-enwi'r ffeil help i ABACUS.chm.

3. Agorwch y ffeil gan dwbl-glicio iddo ac os yw 'Ffeil Agored - Rhybudd Diogelwch', yna deialog yn ymddangos uncheck 'r "Gofynnwch bob amser cyn agor y ffeil" ddewisiad a chliciwch Agored.

4. Caewch y ffeil.

5. Amnewid y ffeil ABACUS.chm yn y ABACUS ffeiliau rhaglen folder, fel arfer "C: \ Program Files \ Avolution \ ABACUS"Neu"C: \ Program Files(X86)\ Avolution \ ABACUS".

Nodyn

Bydd cymorth sensitif Cyd-destun yn parhau i weithio gyda ffeiliau cymorth cyfieithu.

ABACUS ffeiliau cymorth mewn ieithoedd eraill:

· Arabeg / العربية .

· Bwlgareg / български .

· Tseiniaidd (Simplified) / 中文 (简体) .

· Tsiec / Ceska .

· Danish / Dansk .

· Estoneg / Eesti .

· Ffindir / Suomen .

· Ffrangeg / Français .

· Almaeneg / Deutsch .

· Hwngareg / Magyar .

· Islandeg / Islandeg .

· Indonesian / Indonesia .

· Eidaleg / Italiano .

· Siapan / 日本 の .

· Latfieg / Latvijas .

· Malaysian / Malaysia .

· Maltese / Brag i .

· Norweigen / Norweigen .

· Pwyleg / Po lska .

· Portiwgaleg / Português .

· Rwsia / русский .

· Slofaceg / Tags .

· Slovenian / Tags .

· Sbaeneg / Españoles .

· Swedeg / Svenska .

· Turkish / Turk .

· Cymraeg / English .

Gweler Hefyd

Beth mae ABACUS ei wneud?


Poblogi eich pensaernïaeth

Navigation: poblogi eich pensaernïaeth>

Poblogi eich pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

Mae'r broses o adeiladu model o'ch pensaernïaeth cael ei adnabod fel populating. Unwaith y byddwch wedi darganfod eich pensaernïaeth a nodwyd eich anghenion, rydych yn barod i fodelu eich pensaernïaeth yn ABACUS.

Yn ystod y boblogaeth, byddwch yn mynd i mewn i gyd o'r manylion ydych yn gwybod am eich pensaernïaeth a hyn sydd ei angen ohono.

I boblogi eich pensaernïaeth

1. Sicrhewch bod gennych Ffeil ABACUS agored , Mae fforiwr harddangos , Ac mae Ychwanegodd pensaernïaeth .

2. Manually boblogi y cydrannau lefel uwch a chysylltiadau eich pensaernïaeth. Fel arfer bydd hyn yn y cydrannau a chysylltiadau mwy haniaethol.

- Neu -

2. Graffigol boblogi y cydrannau a chysylltiadau yr hoffech weld yn cael ei gynrychioli ar ffurf diagram, gan ddefnyddio'r Arlunio Offeryn .

Efallai y byddwch hefyd am

3. Boblogi gan ddefnyddio Catalogau - Gallwch weld a cydrannau a cysylltiadau mewn ffordd tabl syml.

4. Boblogi gan ddefnyddio matricsau - Gallwch weld a golygu cysylltiadau rhwng cydrannau mewn ffordd tabl syml.

5. Boblogi gan Microsoft Access - Gallwch fewnforio pensaernïaeth o ac allforio i Microsoft Access.

6. Boblogi chan Microsoft Visio - Gallwch fewnforio pensaernïaeth o ac allforio i Microsoft Visio.

7. Boblogi chan Microsoft Excel - Gallwch fewnforio pensaernïaeth o ac allforio i Microsoft Excel.

8. Boblogi gan Microsoft SharePoint - Gallwch fewnforio pensaernïaeth o ac allforio i Microsoft SQL Server.

9. Boblogi gan Microsoft SQL Server - Gallwch fewnforio pensaernïaeth o Microsoft SQL Server.

10. Mewnforio o XML - Gallwch fewnforio pensaernïaeth o darn XML ABACUS neu ffeil XML ArchiMate Cyfnewidfa Iaith.

Gweler Hefyd

Poblogi eich pensaernïaeth llaw | Mae'r Offeryn Arlunio | Poblogi eich pensaernïaeth o Microsoft Access | Poblogi eich pensaernïaeth o Microsoft Visio | Poblogi eich pensaernïaeth o Microsoft Excel


Poblogi eich pensaernïaeth llaw

Navigation: poblogi eich pensaernïaeth> poblogi â llaw>

Poblogi eich pensaernïaeth llaw

Anfon sylwadau ar y pwnc hwn.

Mae'n debyg y bydd angen ei phoblogaeth â llaw y cydrannau a chysylltiadau o'ch pensaernïaeth lefel uwch. Fel arfer bydd hyn yn y cydrannau a chysylltiadau mwy haniaethol.

I manually boblogi eich pensaernïaeth

1. Sicrhewch bod gennych File ABACUSagored, mae fforiwrharddangos, a Ychwanegodd pensaernïaeth .

2. Ychwanegwch gydran. I wneud hyn, Dde-glicioar yr ardal y goeden rydych am ei boblogi, a dewis Ychwanegu Is-Cydran ..., Neu cliciwch ar y Cydran Newyddbotwm ar y Gweld bar offer . Gall cydrannau yn unig yn cael ei ychwanegu o dan y gangen Cydrannau y goeden. Rydych am i'ch diagram coeden i fod yn gynrychiolaeth cywir o'ch pensaernïaeth. Pan fyddwch yn darganfod eich pensaernïaeth, byddwch wedi dysgu yn union sut mae'r cyfan yn ffitio gyda'i gilydd. Bydd angen y wybodaeth hon arnoch pan fyddwch yn ychwanegu eich cydrannau a chysylltiadau. Os ydych yn ychwanegu eich elfen gyntaf, byddwch yn ychwanegu yn uniongyrchol i'r gangen Cydrannau. Gall y gweddill eich gydrannau fod naill ai ar yr un lefel yn y goeden, neu gallant fod yn is-gydrannau o'r cyntaf.

3. Diweddaru gwerthoeddyr eiddopob cydran wrth i chi ychwanegu. I wneud hyn, cliciwchar y gydran, a golygu'r eiddo eu harddangos yn y Ffenestr Properties(Fel arfer) i'r dde. Eiddo yn gyffredinol pethau fel gofynion, gallu prosesu, ac ati Pan ABACUS yn gwerthuso eich pensaernïaeth, bydd yn cyfrifo rhai eiddo newydd, ac yn arbed nhw yn ôl i'r bensaernïaeth. Mae'r eiddo newydd yn y data rydych yn ceisio ei dadansoddi, megis defnyddio, amser ymateb, lled band, ac ati

4. Ychwanegwch eich cysylltiadauac Diweddariadeu heiddowrth i chi fynd - yn union fel chi ei wneud ar gyfer cydrannau (ond o dan y gangen Cysylltiadau y goeden).

5. Atodwchcysylltiadau a chydrannau. I wneud hyn, dod o hyd i'r cysylltiad, cliciwch ar un o'i yn dod i ben neu rolau , A'i lusgo ymlaen i gydran. Fel arall, cliciwch ar cydran a'i lusgo ar un o'r cysylltiad yn rolau (hy naill ai Ffynhonnell neu Sinc). Neu gallwch dde-glicio a llusgo cydran ar elfen arall a dewis Cysylltu I. Neu yn syml dde-glicio cydran a dewis Cysylltu .... Pan fyddwch yn llusgo cysylltiad rôl, Byddwch yn sylwi symbol llwybr byr pan fyddwch yn pwyntio at elfen y gallwch ei atodi at. Mae hyn yn dangos nad ydych yn gwneud copi, eich bod newydd atodi iddo. Gwnewch yn siŵr eich atodi i'r gydran gyrchfan cywir. Er enghraifft, os yw'n Ffynhonnell cysylltiad yn rôl, Ddragia 'wneud y gydran ffynhonnell (hy yr elfen sydd yn ffynhonnell y llif data).

Tip

Ail-archebu endidau o fewn eich pensaernïaeth (ee Cydrannau, Cysylltiadau ac ati) yn y fforiwryn eithaf hawdd. Yn syml, Cliciwch| Cynnal| Llusgwchyr endid a man perthnasol lle a ddymunir yn eich pensaernïaeth. Mae'r ymarferoldeb ail-archebu hefyd yn eich galluogi i osod endidau o fewn gwahanol hierarchaethau eich pensaernïaeth.

Efallai y byddwch hefyd am

6. Ychwanegu Safonau (Setiau cyn-gyflunio o eiddo - presets) at eich gydrannau, cysylltiadau neu fathau

7. Newid priodweddau o gydran, cysylltiad neu fath

8. Dadwneud ac Ail-wneud gweithrediadau

9. Newid y Math o cydran neu gysylltiad

10. Creu Math Grŵp Math newydd neu

11. Dileu cydran neu gysylltiad

12. Creu, dyblygu neu esblygu pensaernïaeth

13. Mathau Mewnforio a safonau o lyfrgell

14. Mewnforio o ffeil arall ABACUS, XML, Excel neu Visio

15. Copi a gludo rhannau (neu bob un) o'ch pensaernïaeth

16. Dod o hyd ac Amnewid eitemau yn eich pensaernïaeth

17. Expand / Collapse rhai neu bob un o'r nodau yn y goeden

18. Cyfuno eitemau

19. Diffinio ac Validate Cyfyngiadau i gyfyngu ar strwythur eich pensaernïaeth

20. Evolve eich pensaernïaeth i greu nifer o atebion pensaernïol i gymharu a llinell sylfaen

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Creu ffeil newydd


Dadwneud ac Ail-wneud

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Dadwneud ac Ail-wneud

Anfon sylwadau ar y pwnc hwn.

Fel llawer o geisiadau modern, ABACUS cefnogi'r gallu i ddadwneud ac ail-wneud y newidiadau defnyddwyr diweddar a wnaed i brosiect agored. Er mwyn dadwneud y newid mwyaf diweddar, yn syml activate 'r gorchymyn dadwneud. Newidiadau Gellir redone trwy weithredu'r 'r archa ail-wneud sydd wedi cael eu dadwneud; ail-cymhwyso'r newid mwyaf dadwneud yn ddiweddar.

Rhybudd

Nid yw newidiadau dadwneud yn gallu cael eu ailgymhwyso os newidiadau pellach yn cael eu gwneud i'r prosiect ers ei dadwneud.

Nodyn

Er bod y mwyafrif helaeth o newidiadau yn cefnogi dadwneud / ail-wneud mewn amser real, mae rhai diagram newidiadau stensil, megis creu Type-Siâp gymdeithas newydd / Line neu newid priodoledd lliw cymdeithas, nid ydynt yn gallu ei ddadwneud ar unwaith. Yn yr achosion hyn, mae'n rhaid i'r Diagram haddasu (a nodir â seren) ar gau cyn y gall y newidiadau hyn gael ei ddadwneud.

Dadwneud ac Ail-wneud lleoliadau gorchymyn

Gellir cyrchu dadwneud ac ail-wneud gorchmynion o dri lleoliad gwahanol:

· ddewislen Edit

· y bar offer Safonol

· yr allweddi llwybr brys bysellfwrdd CTRL + Z(Dadwneud) a CTRL + Y(Ail-wneud)

Tip

Mae'r dadwneud ac ail-wneud botymau ar y bar offer safonol darparu rhestrau dropdown arddangos y 10 newidiadau diweddaraf y gellir ei ddadwneud ac wedi cael eu ailwneud y drefn honno. Maent hefyd yn ffordd hwylus i ddadwneud / ail-wneud newidiadau lluosog ar unwaith.


Newid gydran / Type cysylltiad yn

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Newid gydran / Type cysylltiad yn

Anfon sylwadau ar y pwnc hwn.

Mathau o gydran a chysylltiad yn cael eu defnyddio yn bennaf at ddibenion dosbarthu. Gallwch ddefnyddio mathau fel hidlyddion wrth edrych ar eich pensaernïaeth. Er enghraifft, yn hytrach na gweld yr holl beth, fe allech chi weld y cydrannau cais yn unig.

Er mwyn newid gydran / Type cysylltiad yn

1. Dde-glicioar y gydran neu gysylltiad.

2. Dewiswch Newid Math.

3. Dewiswch fath gwahanol o'r rhestr.

Tip

Pan fyddwch yn newid y Math, efallai y byddwch yn cael rhywfaint newydd safonauneu eiddo (beth bynnag gysylltiedig â'r Type - gweler y gangen Mathau o goeden). Eich presennol safonau a bydd eiddo yn newid. Gallwch greu eich mathau newydd eich hun a aseinio eich cyfuniadau eich hun o safonau ac eiddo iddynt.

Gweler Hefyd

Creu Math newydd | Poblogi eich pensaernïaeth - Trosolwg | Dadansoddi eich pensaernïaeth


Creu cydran / Type cysylltiad newydd neu Math Grŵp

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Creu cydran / Type cysylltiad newydd neu Math Grŵp

Anfon sylwadau ar y pwnc hwn.

Mathau o gydran a chysylltiad yn cael eu defnyddio yn bennaf at ddibenion dosbarthu. Gallwch ddefnyddio mathau fel hidlyddion wrth edrych ar eich pensaernïaeth. Er enghraifft, yn hytrach na gweld yr holl beth, fe allech chi weld y cydrannau cais yn unig.

I greu cydran / Type cysylltiad newydd

Nodyn

I ychwanegu mathau neu grwpiau fath mewn prosiect ABACUS mae angen i'r Dylunydd gallu ychwanegu-ar y drwydded defnyddiwr. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

1. Ehangu'r Mathaucangen o'r goeden.

2. Dde-glicioar Mathau Cydran(Neu Mathau Cysylltiad).

3. Dewiswch Ychwanegu Cydran Math(Neu Ychwanegu Math Cysylltiad) Neu Grwp Creu.

Tip

Unwaith y byddwch wedi creu math, dylech newid ei icon (gweler isod) ac yn ychwanegu eiddo ac safonau iddo am y gydran, neu enghreifftiau gysylltiad 'etifeddu'.

I newid eicon ar gyfer cydran / Type cysylltiad

Nodyn

I newid yr eiconau ar gyfer mathau mewn prosiect ABACUS mae angen i'r Dylunydd gallu ychwanegu-ar y drwydded defnyddiwr. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

1. Dde-glicio ar y Math Cydran(Neu Math Cysylltiad) Hoffech newid yr eicon ar gyfer.

2. Dewiswch Newid Icon.

3. Yn y pori ymgom Dewis Icon i leoliad a dewis ffeil delwedd a chliciwch Agored.

Nodyn

Gallwch gael eicon arfer delwedd o unrhyw faint, ond bydd bob amser yn cael ei raddio i gyd-fynd â delwedd picsel 16x16 yn y Ffenest Explorer. Felly, os nad yw eich eicon arferiad gwreiddiol ddelwedd o uchder cyfartal a lled y bydd eich Explorer icon Ffenestr yn cael ei hymestyn. Yn unol â hynny, dylai delweddau arfer fod o leiaf 16x16 picsel ac os ydych am gadw'r union siâp yr eicon arferiad sicrhau bod eich eicon arferiad ddelwedd yn uchder gyfartal a lled mewn picseli (16x16 neu'n fwy). Dylech hefyd fod yn ofalus ynghylch peidio â chael 'picsel' lliw yn mynd yr holl ffordd at y ffin o'r eicon arferiad ddelwedd fel y bydd yn edrych yn wael yn y Ffenest Explorer gydag eiconau cyfagos 'gwaedu' i mewn i bob eraill. Yn unol â hynny, dylech adael o leiaf border gwyn 1 picsel.

Tip

Gallwch wneud eich icon arfer ddelwedd yn .ico, .bmp, Gif, .jpg neu ffeil fformat .png ond oherwydd cyfyngiad i mewn Ffenestri yn unig .ico fformat rhagolwg yn yr ymgom ABACUS Dewiswch Icon os oes gennych yr opsiwn View Menu gosod i unrhyw beth heblaw bawdlun.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Dadansoddi eich pensaernïaeth


Dileu cydran neu gysylltiad

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Dileu cydran neu gysylltiad

Anfon sylwadau ar y pwnc hwn.

I ddileu cydran neu gysylltiad

1. Dde-glicioar y gydran neu gysylltiad.

2. Dewiswch Dileu.

Rhybudd

Bydd ABACUS rhybuddio chi pa safbwyntiau yn cael eu heffeithio gan y dileu a gofyn i chi gadarnhau dileu. Mae hyn oherwydd y gall elfennau yn bodoli ar lawer o ddiagramau ac mae'n talu i wirio beth fydd y dilead arfaethedig yn effeithio.

Tip

Os fyddwch yn dileu elfen, bydd ei holl is-gydrannau hefyd yn cael eu dileu. Gallwch ddewis i ddileu'r cysylltiadau mewnol ac allanol i'r gydran. Os nad ydych yn dewis dileu, y cysylltiadau 'i' ynghlwm i yn aros, ond byddant bellach yn cael eu ynghlwm. Mae'r holl elfennau a chysylltiadau o ran manylyn Math . Dileu y gydran / cysylltiad yn cael unrhyw effaith ar y math (yn y gangen Mathau o goeden). Yn yr un modd, os bydd y gydran / cysylltiad â Safon neilltuo, bydd dileu yn cael unrhyw effaith ar y meistr yn y gangen Safonau.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg


Creu neu dyblygu pensaernïaeth

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Creu neu dyblygu pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

Gallwch gael unrhyw nifer o saernïaeth mewn ffeil ABACUS sengl. Fel arfer, byddech yn creu pensaernïaeth newydd bob tro y byddwch eisiau i fodelu a gwerthuso esblygiad eich system.

I greu pensaernïaeth newydd

1. Dde-glicio ar y Pensaernïaethcangen o'r goeden.

2. Dewiswch Pensaernïaeth Newydd.

Creu copi o bensaernïaeth sydd eisoes yn bodoli

1. Dde-glicioar y bensaernïaeth.

2. Dewiswch Copi.

3. Dde-glicio ar y Pensaernïaethcangen o'r goeden.

4. Dewiswch Gludo.

5. Bydd y bensaernïaeth newydd yn cael eu galw 'Copi o ...'.

I ddatblygu pensaernïaeth sy'n bodoli eisoes

1. Dde-glicioar y bensaernïaeth.

2. Dewiswch Evolve.

3. Bydd y bensaernïaeth newydd yn cael eu galw '... .1'.

Nodyn

Ceir disgrifiad manwl ar pensaernïaeth sy'n esblygu yma .

Gweler Hefyd

Sut mae pensaernïaeth a gynrychiolir yn ABACUS | Esblygu eich pensaernïaeth


Mewnforio i mewn i'ch Pensaernïaeth

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Mewnforio i mewn i'ch Pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

ABACUS yn caniatáu i chi i fewnforio i mewn eich pensaernïaeth o .abacus (ffeil ABACUS), .xml (mae darn XML ABACUS neu ffeil XML ArchiMate Cyfnewidfa Iaith), .vsd (Microsoft Visio) fformat, a .xls (Microsoft Excel) fformat. Mae hyn yn caniatáu i chi adeiladu eich pensaernïaeth o ffynonellau allanol yn gyflym.

I mewnforio eich pensaernïaeth o.abacus (ffeil ABACUS)

1. Sicrhewch bod gennych File ABACUSar agor.

2. Dde-glicioar y nôd Pensaernïaeth, unrhyw bensaernïaeth yn eich model neu unrhyw ran o'r goeden Cydrannau.

3. Dewiswch Mewnforio| O Ffeil ...o'r ddewislen.

4. Dewiswch leoliad a y .abacus ffeil a chliciwch ar y Agoredbotwm.

Nodyn

Ar ôl i chi wedi dewis y ffeil yr ydych eisiau mewnforio, gofynnir i chi sut yr hoffech i fewnforio safonau, mathaua safbwyntiau. Gallwch fewnforio safonau, mathau a safbwyntiau naill ai fel safonau newydd neu uno, mathaua safbwyntiau. Mae'r lleoliad diofyn ar gyfer safonau, mathau a safbwyntiau i gael ei uno â safonau sy'n bodoli eisoes, mathau a safbwyntiau os ydynt yn bodoli eisoes yn (Gyda'r un union enw) yn eich prosiect.

I mewnforioeich pensaernïaeth o.xml (Mae darn ABACUS XML neu ffeil XML ArchiMate Cyfnewidfa Iaith)

1. Sicrhewch bod gennych File ABACUSar agor.

2. Dde-glicioar nod Pensaernïaeth, unrhyw bensaernïaeth yn eich model neu unrhyw ran o'r goeden Cydran.

3. Dewiswch Mewnforio| O XML ...o'r ddewislen.

4. Dewiswch leoliad a y .xml ffeil a chliciwch ar y Agoredbotwm.

Nodyn

Bydd ABACUS yn unig mewnforio a ffurfiwyd yn briodol darn XML ABACUS neu ffeil XML ArchiMate Cyfnewidfa Iaith. Ar ôl i chi wedi dewis y ffeil XML hoffech fewnforio, bydd gofyn i chi sut yr hoffech i fewnforio safonau, mathaua safbwyntiau. Gallwch fewnforio safonau, mathau a safbwyntiau naill ai fel safonau newydd neu uno, mathaua safbwyntiau. Mae'r lleoliad diofyn ar gyfer safonau, mathau a safbwyntiau i gael ei uno â safonau sy'n bodoli eisoes, mathau a safbwyntiau os ydynt yn bodoli eisoes yn (Gyda'r un union enw) yn eich prosiect.

I mewnforioeich pensaernïaeth o.VSD(Visiofile)gweld yma .

I mewnforioeich pensaernïaeth o.xls (ffeil Excel)gweld yma .


Mewnforio mathau a safonau o lyfrgell

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Mewnforio mathau a safonau o lyfrgell

Anfon sylwadau ar y pwnc hwn.

Gallwch chi fewnforio mathau a safonau o ffeil llyfrgell ABACUS. Gallwch hefyd yn allforio mathau a safonau gan eich ffeil ABACUS i ffeil llyfrgell ABACUS.

I fewnforio mathau a safonau o lyfrgell i mewn i'ch pensaernïaeth

1. Sicrhewch bod gennych File ABACUSagored ac mae'r Ffenestr fforiwrharddangos.

2. Dewiswch Ffeil | Agoredi agor File llyfrgell ABACUS.

3. Bydd y Llyfrgell ABACUS agor mewn ail daflen Tabbed yn y ffenestr Explorer a bydd yn rhaid i chi undock y daflen Tabbed i allu llusgo a gollwng ohono at y ffeil ABACUS wreiddiol.

4. Llusgwch a gollwngmathau a safonau o'r llyfrgell i mewn i'ch pensaernïaeth.

- Neu -

1. Dewiswch Ffeil | Newydd ...

2. Creu newydd File ABACUSyn seiliedig ar File llyfrgell ABACUS.

I allforio mathau a safonau gan eich pensaernïaeth yn llyfrgell

1. Sicrhewch bod gennych File ABACUSagored, mae'r Ffenestr fforiwrharddangos, mae File llyfrgell ABACUSagored ac mae'r Ffenestr Llyfrgellharddangos.

2. Llusgwch a gollwngmathau a safonau gan eich pensaernïaeth i mewn i'r llyfrgell.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw


Copïo a gludo

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Copïo a gludo

Anfon sylwadau ar y pwnc hwn.

Gallwch gopïo rhan neu'r cyfan o'ch pensaernïaeth a'i gludo mewn lleoliad gwahanol yn y goeden.

I gopïo

1. Dde-glicioar yr eitem yr hoffech ei gopïo.

2. Dewiswch Copi.

I bastio

1. Navigate y goeden i ddod o hyd i'r lle yr hoffech ei bastio 'r eitem.

2. Dde-glicioar y gangen rydych am iddo ymddangos yn.

3. Dewiswch Gludo.

4. Bydd yr eitem yn cael ei gopïo gydag enw gwreiddiol (oni bai eich bod copi ohoni i'r gangen gwreiddiol - yna bydd yn cael ei alw 'Copi o ...').

Gweler Hefyd

Sut mae pensaernïaeth a gynrychiolir yn ABACUS


Dod o hyd a gosod eitemau yn eich pensaernïaeth

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Dod o hyd a gosod eitemau yn eich pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

Gallwch ddod o hyd ac Amnewid yn elfen benodol, cysylltiad, math, safonol neu eiddo trwy ddefnyddio ABACUS 'Dod o hyd i ac Amnewid cyfleuster.

I ddod o hyd i eitem

1. Cliciwch ar y nôd y goeden hoffech chwilio o fewn.

2. Dewiswch Golygu| Dod o hyd ineu pwyswch Ctrl + F.

3. Nodwch y destun ar gyfer yr eitemi ddod o hyd yn y 'Canfod beth' cae.

4. Cliciwch Dod o hyd i Next.

I cymryd lle eitem

1. Cliciwch ar y nôd y goeden hoffech chwilio o fewn.

2. Dewiswch Golygu| Amnewidneu pwyswch Ctrl + H.

3. Nodwch y destun ar gyferyr eitemi ddod o hyd yn y 'Dod o hyd i beth yw' cae a'r testun i ddisodli ag ef yn y 'Amnewid gyda' cae (Neu ddim byd os y cae yn cael ei adael yn wag).

4. Cliciwch Dod o hyd i Nexti ddod o hyd y lle cyntaf y testun 'Dewch o hyd i beth' a chliciwch Amnewid i gymryd lle yr achos hwn gyda'r testun 'Amnewid gyda' neu cliciwch Amnewid Pob Uni gymryd lle yr holl achosion.

Mae gennych yr opsiynau i:

o Match ei achos,

o Match y gair cyfan,

o Chwilio o ddechrau'r prosiect,

o Anwybyddwch pensaernïaeth - hynny yw pensaernïaeth nodau eu hunain. Bydd unrhyw nodau o dan y nodau pensaernïaeth megis y cydrannau a chysylltiadau yn dal i gael ei chwilio,

o Anwybyddwch cydrannau - dyna'r gydran nodau eu hunain,

o Anwybyddwch cysylltiadau - hynny yw y cysylltiad nodau eu hunain,

o Anwybyddwch safonau - hynny yw y bydd pob nodau safonol pensaernïaeth, cydran a chysylltiad yn cael ei anwybyddu,

o Anwybyddwch mathau - dyna'r math nodau eu hunain. Bydd unrhyw nodau cyfyngiad o dan y nodau fath yn dal i gael ei chwilio,

o Anwybyddwch templedi a chynnwys - sef y templed nodau eu hunain yn ogystal ag unrhyw elfen templed a nodau chysylltiad oddi tanynt,

o Anwybyddwch eiddo - dyna yr holl fathau o eiddo, enwau, gwerthoedd ac unedau o'r holl elfennau y model yn cael ei anwybyddu,

o Anwybyddwch disgrifiadau - hynny yw y bydd y disgrifiadau o holl elfennau y model yn cael ei anwybyddu.

Gweler Hefyd

Sut mae pensaernïaeth a gynrychiolir yn ABACUS


Ehangu a dymchwel y goeden

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Ehangu a dymchwel y goeden

Anfon sylwadau ar y pwnc hwn.

Pan fydd nod yn y goeden yn cynnwys is-cydrannau a chasgliadau, bydd yn cael bach [image] neu [image] llofnodi ar ei chwith. Gallwch glicio ar y [image] i ehangu'r nôd a gweld ei is-gydrannau a chysylltiadau. Yn yr un modd, gallwch glicio ar y [image] i fyrhau'r nod i guddio yr is-cydrannau a chysylltiadau (er mwyn gwneud mwy o le neu wneud y goeden yn haws i'w deall).

Fel arall, gallwch ehangu yn nod cyfan, ac os felly, bydd ei holl is-nodau hefyd yn cael ei ehangu, ac mae eu is-nodau, ac nhw ... ac ati Yn yr un modd, gallwch cwymp yn nod cyfan - cau lefelau lluosog ar unwaith .

Yn ogystal, mae opsiynau i ehangu dim ond y saernïaeth, elfennau (hy cydrannau a chysylltiadau), cydrannau neu gysylltiadau.

I ehangu neu ddymchwel yn nod cyfan (a'i is-nodau, ac ati)

1. Dde-glicioar y nôd.

2. Dewiswch Expand | All neuCollapse.

I ehangu pob un pensaernïaeth (au)

1. Dde-glicioar Pensaerniaethau neu bensaernïaeth.

2. Dewiswch Expand | All.

I ehangu elfennau

1. Dde-glicioar Pensaerniaethau neu bensaernïaeth.

2. Dewiswch Expand | Elfennau.

I ehangu cydrannau

1. Dde-glicioar Cydrannau, cydran neu is-gydran.

2. Dewiswch Expand | Cydrannau | All.

I ehangu cysylltiadau

1. Dde-glicioar Connections, gysylltiad neu is-gysylltiad.

2. Dewiswch Expand | Cysylltiadau | All.


Cyfuno eitemau

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Cyfuno eitemau

Anfon sylwadau ar y pwnc hwn.

Pryd y byddech yn uno eitemau?

Byddech yn uno eitemau pan fydd gennych ddau (neu fwy) o wrthrychau yn eich model sy'n cael eu cynrychioli orau gan un enghraifft. Mae llawer o sefyllfaoedd pryd efallai y byddwch am wneud hyn, gan gynnwys:

· O ganlyniad i fewnforio cyfres newydd o wybodaeth i mewn i'ch model a allai ddyblygu neu disodli gwybodaeth sy'n bodoli eisoes. Er enghraifft, os byddwch yn mewnforio fersiwn wedi'i ddiweddaru o'r daenlen i mewn i'ch model.

· Dros amser dyblygu o'r 'yr un' cydran wedi cael eu creu ac yr hoffech i lanhau dyblygu hyn.

· Os ydych yn perfformio beth-os senario a'r eitemau yr ydych yn modelu mewn gwirionedd yn uno mewn gwirionedd. Er enghraifft, os ydych yn uno dwy adran yn eich sefydliad, neu os ydych yn uno dau gweinyddwyr.

Beth ellir ei uno?

Mae'r mathau canlynol o eitemau yn cefnogi cael eu huno:

· Safonau

· Cydran a Cysylltiad Mathau

· Cydrannau a Cysylltiadau

Sut i uno eitemau

I gychwyn uno, gan ddefnyddio'r botwm de y llygoden, llusgwch un eitem yn y fforiwr i un arall. Mae'r eitem yr ydych yn llusgo yw'r ffynhonnell, a'r eitem yr ydych yn llusgo ymlaen yw'r gyrchfan. Ar ôl rhyddhau'r botwm de y llygoden, byddwch yn cael ei gyflwyno gyda bwydlen lle gallwch ddewis Cyfuno y ddwy eitem. Bydd rhaid i chi ddewis a ydych am gadw neu ysgrifennu dros y gyrchfan. Esbonnir hyn ymhellach isod.

Mae'r uno ddewislen dde-llusgo

Beth yw'r gwahaniaeth rhwng cadw a trosysgrifo y cyrchfan?

Mae'r opsiwn cadw neu trosysgrifo yn pennu beth fydd yn digwydd os bydd y Enw, Disgrifiad neu Properties rhwng y ffynhonnell a'r eitemau cyrchfan gêm.

Os Cadw Cyrchfan a ddewisir

· Bydd Enw a Disgrifiad y gyrchfan yn cael ei gadw.

· Mae unrhyw eiddo sydd ond yn bodoli yn y ffynhonnell yn cael eu hychwanegu at y gyrchfan.

Os Trosysgrifo Cyrchfan yn cael ei ddewis:

· Bydd Enw y gyrchfan yn cael ei drosysgrifo yn y ffynhonnell.

· Bydd Disgrifiad y gyrchfan yn cael ei drosysgrifo o'r ffynhonnell, oni bai Disgrifiad y ffynhonnell yn wag.

· Mae unrhyw eiddo sydd ond yn bodoli yn y ffynhonnell yn cael eu hychwanegu at y gyrchfan.

· Bydd yr Gwerth ac Uned o unrhyw eiddo sy'n bodoli yn y ffynhonnell a chyrchfan eu trosysgrifo o'r ffynhonnell, oni bai bod Gwerth y ffynhonnell neu Uned yn wag.

Achosion Arbennig

· Mathau: Wrth uno mathau, mae'r caniatâd yn cael eu huno, mewn dull 'besimistaidd', fel bod os nad yw'r caniatâd ar y ffynhonnell yn bodoli ar y gyrchfan, byddai'n cael ei ychwanegu, ac os oedd yn bodoli yn y gyrchfan, yna os yw'r unigolyn Nid yw caniatâd i grŵp defnyddwyr (Creu, Darllen, Diweddariad ai Ddilea) yn cyd-fynd (un ganiataol, un gwadu), yna byddai hynny'n caniatâd yn cael ei wrthod.

· Cydrannau: Wrth uno cydrannau, yr is-gydrannau y ffynhonnell yn cael eu mudo i'r gyrchfan, ac yn cael eu huno ag is-gydrannau yn y gyrchfan os yw eu henwau yn union yr un fath, Waeth beth yw eu math.Ar ben hynny, bydd lluosog is-elfennau o'r ffynhonnell gyda'r un enw yn cael eu cyfuno i mewn i is-gydran sengl yn y gyrchfan.

· Cysylltiadau: Rhaid i'r cysylltiadau lefel uchaf eu hunain yn yr un atodiadau (neu ddiffyg o hynny) i gael yr hawl i gael eu huno. Wrth uno cysylltiadau, yr is-gysylltiadau y ffynhonnell yn cael eu mudo i'r gyrchfan, ac yn cael eu huno ag is-chysylltiadau yn y gyrchfan os yw eu henwau yn union yr un fath Aeu atodiadau yn union yr un fath. Os nad yw atodiadau yn union yr un fath, bydd yr is-cysylltiadau ffynhonnell yn cael ei ychwanegu at y gyrchfan heb uno gyda chysylltiadau paru eisoes yn bresennol. Mae hyn yn fel nad oes unrhyw atodiadau yn cael eu colli.


Diffinio a Dilysu Cyfyngiadau

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Diffinio a Dilysu Cyfyngiadau

Anfon sylwadau ar y pwnc hwn.

Gall y strwythur a nodweddion o bensaernïaeth yn cael ei gyfyngu gan ddefnyddio gyfyngiadau. Gall cyfyngiadau fod yn berthnasol i fathau gydran a mathau cysylltiad i gyfyngu strwythur pensaernïaeth mewn dwy ffordd. Y ffordd gyntaf yw cyfyngu ar y hierarchaethdrwy ddiffinio "Dylai rhiant / Rhaid bod plentyn" a "Dylai plentyn / Rhaid bod rhiant" perthynas. Yr ail ffordd yw i gyfyngu ar yr topolegdrwy ddiffinio "cydran Dylid / Rhaid ynghlwm wrth cysylltiad" a "Dylai cysylltiad / Rhaid ynghlwm wrth cydran" perthynas. Ar ben hynny, gall cyfyngiadau eu cymhwyso at y priodweddau o fathau o gydran, mathau cysylltiad, templedi, safbwyntiau, saernïaeth, diagramaua 3D yn ystyried cyfyngu ar y bensaernïaeth (au) mewn dwy ffordd ychwanegol. Y ffordd gyntaf yw gosod y Math o ddatayr eiddo i gyfyngu ar y gwerthoedd dilys y gall gael, sef; Testun, Cyfanrif, Degol, Dyddiad / Amser, Boolean neu Restr. Yr ail ffordd yw gosod y sy'n ofynnolstatws yr eiddo i nodi a oes angen gwerth i'w gofnodi ar gyfer yr eiddo (Noder: cyfyngiadau Angenrheidiol ond yn berthnasol i eiddo ar gyfer mathau gydran a chysylltiad). Mae gwybodaeth bellach am gyfyngiadau eiddo yn cael ei ddarparu yn y Newid priodweddau gydran, cysylltiad neu fath help pwnc. Unwaith y bydd cyfyngiadau wedi eu diffinio, mae modd dilysu pensaernïaeth yn erbyn y cyfyngiadau. Bydd ABACUS rhybuddio am unrhyw gyfyngiadau sydd wedi cael eu sathru.

Yr allwedd i benderfynu pa cyfyngiad (au) i ddiffinio gorwedd yn yr union iaith a ddefnyddir i ddisgrifio'r cyfyngiad. Ar gyfer cyfyngiadau hierarchaeth maent fel arfer o'r ffurflen "enwauGall / Dylid / Rhaid pydredig i mewn i n enwau"Neu"enwauGall / Dylid / Rhaid ei agregu gan enwau"Ac ati Er enghraifft,"AdrannauRhaid pydredig i mewn Timau"Neu"CeisiadauGellir pydredig i mewn Modiwlau". Ar gyfer cyfyngiadau topoleg maent fel arfer o'r ffurflen"enwaugall / Dylai / Rhaid ferf enwau". Er enghraifft, "ProsesauGall fod yn berfformio gan Timau"Neu"Ceisiadauyn a gynhelir ar Gweinyddwyr. "Yn awr, gallwch weld ym mhob cyfyngiad mae amryw o all / ddylai / rhaid 'rhagbrofol' a gall y rhain fod o 3 math;

· Dewisol- Bydd y rhain fel arfer yn defnyddio geiriau / ymadroddion yn hoffi; "May", "all", "gallai", "ddewisol" ac ati

· A Argymhellir- Bydd y rhain fel arfer yn defnyddio geiriau / ymadroddion yn hoffi; "Dylai", "a argymhellir", "cynghori" ac ati

· Gorfodol- Bydd y rhain fel arfer yn defnyddio geiriau / ymadroddion yn hoffi; "Rhaid", "yn", "yn cael eu", "wedi", "rhaid" ac ati

Yn dibynnu ar y math o cyfyngiad (hierarchaeth neu topoleg) a'r rhagbrofol a ddefnyddir yn ei ddisgrifio, dylai cyfyngiad (au) penodol yn cael eu diffinio (gweler isod). Ar gyfer yr enghraifft uchod hierarchaeth o "AdrannauRhaid pydredig i mewn Timau"Dylai un ddiffinio" "cyfyngiad ac yn gosod y gorfodi i gael ei orfodi. Ar gyfer yr enghraifft uchod topoleg o" Rhiant Mae'n rhaid cael PlentynProsesauGall fod yn berfformio gan Timau. Rhaid i Cysylltiad fod ynghlwm wrth Cydran "cyfyngiadau ar bob pen i'r berfformio gan math o gysylltiad" Dylai un dim ond dau (2) yn creu "Yn benodol, mae'r cyfyngiadau canlynol yn cael eu hargymell i'w ddiffinio (gweler isod) ar gyfer y gwahanol opsiynau;

· Cyfyngiadau Hierarchaeth;

o Enwau A Gall fod ynpydredig i mewn Enwau B, Neu Enwau B Gall fod ynagregu gan Enwau Aneu Enwau B dylai fodagregu gan Enwau A- Diffinio "Rhaid Plentyn wedi Rhiant" cyfyngiad â'r math plentyn fel Noun B, math rhiant fel Noun A a gorfodaeth fel rhybuddio.

Nodyn

Mae hyn yn golygu os yw plentyn yn bodoli, dylai gynnwys rhiant o fath arbennig. Os na, byddwch yn cael rhybudd.

o Enwau A dylai fodpydredig i mewn Enwau B- Diffinio "Rhaid Rhiant gael Child" cyfyngiad gyda'r rhiant math fel Noun A, math plentyn fel Noun B a gorfodaeth fel rhybuddio.

Nodyn

Mae hyn yn golygu os yw rhiant yn bodoli, dylai fod gennych blant o fath arbennig. Os na, byddwch yn cael rhybudd.

o Enwau A rhaid fodpydredig i mewn Enwau B- Diffinio "Rhaid Rhiant gael Child" cyfyngiad gyda'r rhiant math fel Noun A, math plentyn fel Noun B a gorfodaeth fel Gorfodol.

Nodyn

Mae hyn yn golygu os yw rhiant yn bodoli, rhaid iddi gael plant o fath arbennig. Os na fyddwch yn cael gwall.

o Enwau A rhaid fodagregu gan Enwau B- Diffinio "Rhaid Plentyn wedi Rhiant" cyfyngiad â'r math plentyn fel Noun A, math rhiant fel Noun B a gorfodaeth fel Gorfodol.

Nodyn

Mae hyn yn golygu os yw plentyn yn bodoli, rhaid iddo fod â rhiant o fath arbennig. Os na, byddwch yn cael gwall.

· Cyfyngiadau Topoleg;

o Enwau A Gall fod yn ferf Enwau B- Diffinio dau (2) "Rhaid Cysylltiad fod ynghlwm wrth Cydran" cyfyngiadau. Y bod gyntaf gyda'r Ffynhonnell diwedd y math o gysylltiad ferfynghlwm wrth enw Math gydran a gorfodi gosod i Gorfodol. Mae'r ail lles gyda Sinc diwedd y math o gysylltiad ferfynghlwm wrth Noun Math o gydran B a gorfodi gosod i Gorfodol.

Nodyn

Mae hyn yn golygu os bydd y cysylltiad yn bodoli, rhaid iddo gysylltu elfennau o fath penodol. Os na fyddwch yn cael Gwall. Yn gyffredinol mae hyn yn sicrhau y gall y cydrannau hyn yn dal i fodoli ac nid yn cael eu cysylltu â'i gilydd. Fodd bynnag, os ydynt yn cael eu cysylltu, mae'n rhaid i gysylltiadau o'r math iawn yn cael ei ddefnyddio.

o Enwau A dylai fod ferf Enwau B- Diffinio dau (2) "Rhaid Cydran fod ynghlwm wrth Cysylltiad" cyfyngiadau. Y cyntaf bod gyda Noun Mae math cydran ynghlwm wrth y Ffynhonnell ddiwedd y ferfmath o gysylltiad a set gorfodi rhybuddio. Mae'r ail lles gyda Noun Math o gydran B ynghlwm wrth y sinc ddiwedd y ferfmath o gysylltiad a set gorfodi rhybuddio. Yn ogystal, yn diffinio dau (2) "Rhaid Cysylltiad fod ynghlwm wrth Cydran" cyfyngiadau. Y bod gyntaf gyda'r Ffynhonnell diwedd y math o gysylltiad ferfynghlwm wrth enw Math gydran a gorfodi gosod i Gorfodol. Mae'r ail lles gyda Sinc diwedd y math o gysylltiad ferfynghlwm wrth Noun Math o gydran B a gorfodi gosod i Gorfodol.

Nodyn

Mae hyn yn golygu os cydrannau naill fath yn bodoli, dylid eu hatodi at gysylltiad o fath arbennig. Os na fyddwch yn cael rhybudd. Yn ogystal, mae hyn yn golygu os bydd y cysylltiad yn bodoli, rhaid iddo fod yn gysylltiedig â gydrannau o'r fath a bennir. Os na fyddwch yn cael gwall. Yn gyffredinol mae hyn yn sicrhau, os elfennau o'r mathau hyn yn bodoli, byddwch yn cael rhybuddion os nad ydynt yn cael eu cysylltu â'i gilydd.

o Enwau A rhaid fod ferf Enwau B- Diffinio dau (2) "Rhaid Cydran fod ynghlwm wrth Cysylltiad" cyfyngiadau. Y cyntaf bod gyda Noun Mae math cydran ynghlwm wrth y Ffynhonnell ddiwedd y ferfmath o gysylltiad a gorfodi gosod i Gorfodol. Mae'r ail lles gyda Noun Math o gydran B ynghlwm wrth y sinc ddiwedd y ferfmath o gysylltiad a gorfodi gosod i Gorfodol. Yn ogystal, yn diffinio dau (2) "Rhaid Cysylltiad fod ynghlwm wrth Cydran" cyfyngiadau. Y bod gyntaf gyda'r Ffynhonnell diwedd y math o gysylltiad ferfynghlwm wrth enw Math gydran a gorfodi gosod i Gorfodol. Mae'r ail lles gyda Sinc diwedd y math o gysylltiad ferfynghlwm wrth Noun Math o gydran B a gorfodi gosod i Gorfodol.

Nodyn

Mae hyn yn golygu os cydrannau naill fath yn bodoli, mae'n rhaid iddynt fod ynghlwm wrth cysylltiad o fath arbennig. Os na fyddwch yn cael gwall. Yn ogystal, mae hyn yn golygu os bydd y cysylltiad yn bodoli, rhaid iddo fod yn gysylltiedig â gydrannau o'r fath a bennir. Os na fyddwch yn cael gwall. Yn gyffredinol mae hyn yn sicrhau, os elfennau o'r mathau hyn yn bodoli, byddwch yn cael gwallau os nad ydynt yn cael eu cysylltu â'i gilydd.

I ddiffinio yn gyfyngiad

1. Sicrhewch bod gennych File ABACUSagored ac mae'r Ffenestr fforiwrharddangos.

2. Yn y goeden fforiwr ehangu Mathau | Mathau Cydranneu ehangu Mathau | Mathau Cysylltiad.

3. Dde-gliciomath cydran neu fath gysylltiad a dethol Ychwanegu Cyfyngiadau.

Ychwanegu cyfyngiad

I ddiffinio cyfyngiad hierarchaeth, lle mae'n rhaid i riant fod â phlentyn penodol

4. Ar y Ychwanegu Cyfyngiadauffenestr ticiwch y Creu Cyfyngiadaucheckbox o dan y Rhaid Rhiant Cael Cyfyngiadau Plantardal.

5. Dewiswch y Math o gydrano'r blwch cwympo ydych am ei bennu gan fod y plentyn o'r math gydran a ddewiswyd yn gam 3.

Nodyn

Os oes eisoes yn galluogi 'Rhaid Rhiant Cael Plentyn' diffiniedig cyfyngiad ar gyfer y math gydran rhiant a math arall elfen plentyn yna bydd hyn cyfyngiad newydd yn cael ei drin fel 'A'. Hynny yw, rhaid i'r fath fod yn rhiant o'r math plentyn A acMath plentyn B, i ba lefel bynnag gorfodi (ee Anabl, rhybuddio neu Gorfodi - gweler cam 7) wedi ei bennu ar gyfer pob cyfyngiad.

6. Optionally gallwch ddiffinio isafswm ac uchafswm nifer o gydrannau o'r math gydran penodedig y mae'n rhaid eu plant o'r math gydran cywir-glicio yn gam 3.

7. Dewiswch a ydych am i'r cyfyngiad i fod yn Anabl, Rhybuddioddneu Gorfodir.

Nodyn

Bydd cyfyngiadau anabl yn cael eu hanwybyddu gan dilysu gyfyngiad, bydd cyfyngiadau rhybuddio cynhyrchu Rhybudd yn y ffenestr Dilysu os ydynt yn cael eu canfod, a bydd cyfyngiadau Gorfodir cynhyrchu Gwall yn y ffenestr Dilysu os ydynt yn cael eu canfod. Ar ben hynny, mae'n rhaid i bob camgymeriadau yn cael eu datrys cyn i Menter Gweinydd Gall y prosiect fod yn ymrwymedig.

8. Cliciwch iawn.

Nodyn

Bydd y cyfyngiad yn cael ei arddangos yn y goeden fforiwr o dan y math gydran cywir-glicio yng ngham 3. Mae'r saeth yn dynodi cyfeiriad y cyfyngiad ac yn yr achos hwn bydd yn pwyntio i lawr ac i'r dde. Mae'r clo clap wedi'i liwio yn ôl a yw'r cyfyngiad yn Anabl (llwyd), rhybuddio (melyn) neu Gorfodol (coch).

Mae'n rhaid i riant gael plentyn rhybuddio cyfyngiad

I ddiffinio cyfyngiad hierarchaeth, lle mae'n rhaid i blentyn fod â rhiant penodol

4. Ar y Ychwanegu Cyfyngiadauffenestr ticiwch y Creu Cyfyngiadaucheckbox o dan y Rhaid Plentyn Cael Rhiant Cyfyngiadardal.

5. Dewiswch y Math o gydrano'r blwch cwympo ydych am ei bennu fel rhiant y math gydran cywir-glicio yn gam 3.

Nodyn

Os oes eisoes yn galluogi 'Rhaid Plentyn Cael Rhiant' cyfyngiad a ddiffiniwyd ar gyfer y math gydran plentyn ac un arall rhiant math gydran yna bydd hyn cyfyngiad newydd yn cael ei drin fel 'OR'. Hynny yw, rhaid i'r fath fod yn blentyn o fath riant A neurhiant math B, a lefel gorfodi (ee rhybuddio neu Gorfodi - gweler y cam nesaf) fod yr un cyfyngiadau a orfodir neu bydd bob amser yn drech rhai rhybuddio.

6. Dewiswch a ydych am i'r cyfyngiad i fod yn Anabl, Rhybuddioddneu Gorfodir.

Nodyn

Bydd cyfyngiadau anabl yn cael eu hanwybyddu gan dilysu gyfyngiad, bydd cyfyngiadau rhybuddio cynhyrchu Rhybudd yn y ffenestr Dilysu os ydynt yn cael eu canfod, a bydd cyfyngiadau Gorfodir cynhyrchu Gwall yn y ffenestr Dilysu os ydynt yn cael eu canfod. Ar ben hynny, mae'n rhaid i bob camgymeriadau yn cael eu datrys cyn i Menter Gweinydd Gall y prosiect fod yn ymrwymedig.

7. Cliciwch iawn.

Nodyn

Bydd y cyfyngiad yn cael ei arddangos ym marn fforiwr o dan y math gydran a ddewisir yn gam 5. Mae'r saeth yn dynodi cyfeiriad y cyfyngiad ac yn yr achos hwn bydd yn pwyntio i fyny ac i'r chwith. Mae'r clo clap wedi'i liwio yn ôl a yw'r cyfyngiad yn Anabl (llwyd), rhybuddio (melyn) neu Gorfodol (coch).

Rhaid i riant plentyn rhybuddio cyfyngiad

I ddiffinio cyfyngiad topoleg, lle mae'n rhaid cydran fod ynghlwm wrth cysylltiad penodol

4. Ar y Ychwanegu Cyfyngiadauffenestr ticiwch y Creu Cyfyngiadaucheckbox o dan y Rhaid Cydran Byddwch Cyfyngiadau Ynghlwmardal.

5. Dewiswch y math o gysylltiado'r blwch cwympo ydych am ei bennu fel y cysylltiad sydd ynghlwm o'r math gydran cywir-glicio yn gam 3. (Neu dewiswch y Math o gydrano'r blwch cwympo ydych am ei bennu fel yr elfen sydd ynghlwm os yn gam 3 ch dde-glicio math gysylltiad.)

Nodyn

Os oes cyfyngiad 'Cydran rhaid ei chysylltu'n' galluogi ddiffiniwyd ar gyfer y math gydran a chysylltiad arall r math yna bydd hyn cyfyngiad newydd yn cael ei drin fel 'A' yn barod. Hynny yw, rhaid i'r math o gydran fod ynghlwm wrth math o gysylltiad A accysylltiad math B, i ba lefel bynnag gorfodi (ee Anabl, rhybuddio neu Gorfodi - gweler cam 7) wedi ei bennu ar gyfer pob cyfyngiad.

6. Optionally gallwch ddewis cysylltiad rôleich bod eisiau ychwanegu at y cyfyngiad. Sethol y penodol rôl (Hy naill ai Ffynhonnell neu Sinc) o'r blwch a ollyngir i lawr.

7. Dewiswch a ydych am i'r cyfyngiad i fod yn Anabl, Rhybuddioddneu Gorfodir.

Nodyn

Bydd cyfyngiadau anabl yn cael eu hanwybyddu gan dilysu gyfyngiad, bydd cyfyngiadau rhybuddio cynhyrchu Rhybudd yn y ffenestr Dilysu os ydynt yn cael eu canfod, a bydd cyfyngiadau Gorfodir cynhyrchu Gwall yn y ffenestr Dilysu os ydynt yn cael eu canfod. Ar ben hynny, mae'n rhaid i bob camgymeriadau yn cael eu datrys cyn i Menter Gweinydd Gall y prosiect fod yn ymrwymedig.

8. Cliciwch iawn.

I ddiffinio cyfyngiad topoleg, lle mae'n rhaid cysylltiad fod ynghlwm wrth elfen benodol

4. Ar y Ychwanegu Cyfyngiadauffenestr ticiwch y Creu Cyfyngiadaucheckbox o dan y Rhaid Cysylltiad Byddwch Ynghlwm Cyfynguardal.

5. Dewiswch y math o gysylltiado'r blwch cwympo ydych am ei bennu fel y cysylltiad sydd ynghlwm o'r math gydran cywir-glicio yn gam 3. (Neu dewiswch y Math o gydrano'r blwch cwympo ydych am ei bennu fel yr elfen sydd ynghlwm os yn gam 3 ch dde-glicio math gysylltiad.)

Nodyn

Os oes cyfyngiad eisoes yn galluogi 'Rhaid Cysylltiad fod ynghlwm' diffiniedig ar gyfer y math o gysylltiad a math elfen arall gan ddefnyddio'r un cysylltiad rôl(h.y. naill ai Ffynhonnell neu Sinc), yna bydd hyn cyfyngiad newydd yn cael ei drin fel 'OR'. Hynny yw, rhaid i'r math o gysylltiad yn cael ei ynghlwm wrth y math cydran A neucydran math B, a lefel gorfodi (ee rhybuddio neu Gorfodi - gweler cam 7) fod yr un cyfyngiadau a orfodir neu bydd bob amser yn drech rhai rhybuddio. Noder hefyd, os oes cyfyngiadau lluosog sydd â'r cysylltiad rôlnodir fel 'Unrhyw' (yn hytrach benodol Ffynhonnell neu Sinc) yna rhaid i bob pen i'r cysylltiad fod ynghlwm wrth un o'r mathau gydran a nodir yn y cyfyngiadau.

6. Optionally gallwch ddewis cysylltiad rôleich bod eisiau ychwanegu at y cyfyngiad. Sethol y penodol rôl (Hy naill ai Ffynhonnell neu Sinc) o'r blwch a ollyngir i lawr.

Nodyn

Mae angen Naill ai Ffynhonnell neu rôl Sinc i gael eu dewis yn benodol ar gyfer Ymlyniad colofn i fod yn avilable i gael ei ddangos yn elfen Catalog .

7. Dewiswch a ydych am i'r cyfyngiad i fod yn Anabl, Rhybuddioddneu Gorfodir.

Nodyn

Bydd cyfyngiadau anabl yn cael eu hanwybyddu gan dilysu gyfyngiad, bydd cyfyngiadau rhybuddio cynhyrchu Rhybudd yn y ffenestr Dilysu os ydynt yn cael eu canfod, a bydd cyfyngiadau Gorfodir cynhyrchu Gwall yn y ffenestr Dilysu os ydynt yn cael eu canfod. Ar ben hynny, mae'n rhaid i bob camgymeriadau yn cael eu datrys cyn i Menter Gweinydd Gall y prosiect fod yn ymrwymedig.

8. Cliciwch iawn.

Amser iawn gwirio model a cyfyngiaddilysu

ABACUS cynnwysamser real Gwirio Model a Nodwedd Dilysu i ar unwaith arddangos yr effeithiau y bydd llawdriniaeth defnyddiwr a roddir ei gael ar y rhybuddion a gwallau gyda'r prosiect ar hyn o bryd, o ganlyniad i unrhyw hierarchaeth ac topoleg cyfyngiadau sydd wedi eu diffinio. Dylid nodi bod rhaid i bob camgymeriadau yn cael eu datrys cyn i Menter Gweinydd Gall y prosiect fod yn ymrwymedig.

Y nodwedd dilysu cyfyngiad amser real yn fwyaf amlwg wrth poblogi'r gyda diagramau neu'n uniongyrchol yn y ffenestr Explorer. Yn benodol, yn ystod y gweithrediadau canlynol, rhoddir arweiniad ddefnyddio lliw uchafbwyntiau o ran yr effaith a gaiff y llawdriniaeth yn ei gael ar y rhybuddion a gwallau gyda'r prosiect ar hyn o bryd;

1. Wrth llusgo elfennau ar neu o gwmpas ddiagram lliw y rhiant (neu atodi) gydran (os oes rhai) a fydd y ffin yn cael ei lliwio yn ôl y cynllun a ddisgrifir isod.

2. Wrth gysylltu cydrannau defnyddio'r llusgo dde-glicio | Cysylltu Er mwyn cynnwys y rhestr o Mathau Cysylltiad gael yn cael ei liwio yn ôl y cynllun a ddisgrifir isod.

3. Wrth gysylltu cydrannau ar ddiagramau sy'n defnyddio'r Modd Connector, bydd y cyrchwr yn newid lliwiau yn ôl y cynllun a ddisgrifir isod.

4. Pan fyddwch yn ychwanegu is-gydrannau y rhestr o Mathau Cydran gael yn cael ei liwio yn ôl y cynllun a ddisgrifir isod.

Yn gyffredinol y lliwiau canlynol yn cael eu defnyddio i ddangos yr effeithiau y bydd y llawdriniaeth defnyddiwr yn ei gael ar y rhybuddion a gwallau gyda'r prosiect ar hyn o bryd;

Du : Dim effaith ar rybuddion neu wallau.

Gwyrdd : Mae'r llawdriniaeth yn benodol yn unol âcyfyngiadau hierarchaeth a topoleg a ddiffiniwyd ar gyfer y prosiect.

Coch : Mae'r llawdriniaeth yn benodol yn groes iBydd y cyfyngiadau hierarchaeth a topoleg a ddiffiniwyd ar gyfer y prosiect ac yn arwain at rybuddion a / neu wallau.

Cefndir gwirio model a cyfyngiaddilysu

ABACUS cynnwys Nodwedd Dilysu i arddangos yr holl rybuddion a gwallau gyda'r prosiect ar hyn o bryd, o ganlyniad i unrhyw gyfyngiadau sydd wedi'u diffinio. Dylid nodi bod rhaid i bob camgymeriadau yn cael eu datrys cyn i Menter Gweinydd Gall y prosiect fod yn ymrwymedig.

Nodyn

Mae angen dilysu gael ei redeg â llaw trwy'r 'Validate / Gwirio Cyfyngiadau Prosiect' botwm ar y Prif bar offer . Mae'r ffenestr Dilysu wedi ei guddio yn ddiofynond bydd yn ymddangos pan fydd y botwm bar offer ei glicio. Gweler Addasu'r rhyngwyneb ar sut i Dadguddio ac o bosibl adael ei arddangos yn barhaol. Hefyd, gallwch dwbl-gliciwch unrhyw res yn y ffenestr Dilysu i 'neidio' at yr elfen berthnasol yn y prosiect.

Ffenestr Dilysu

Mae'r colofnau rhagosodedig yn y ffenestr Ddilysu yn cael eu disgrifio fel a ganlyn;

Rhybudd neu Gwall: Mae'r golofn hon yn dangos eicon i p'un a yw'r groes yn Rhybuddio (triongl melyn gyda ebychnod) neu Gwall (cylch coch gyda chroes).

Nifer: Mae'r golofn hon yn dangos y rhif groes.

Nodyn

Dim ond 200 o droseddau yn cael eu dangos ar y tro, ac os oes mwy na 200 o droseddau mewn prosiect gall y Start, Prev, Next a llyw-rhes End ar ben-dde o'r ffenestr yn cael ei ddefnyddio i bori y troseddau ychwanegol.

Disgrifiad: Mae hwn yn ddisgrifiad llawn o'r y groes yn cynnwys y Endid a Cyfyngiad dan sylw.

Endid: Mae'r golofn hon yn dangos y Endid sy'n peri pryder i'r groes.

Math: Mae'r golofn hon yn dangos yr elfen math gyfer y Endid.

Pensaernïaeth: Mae'r golofn hon yn dangos y Pensaernïaeth y mae'r groes wedi digwydd.

Canfod: Mae'r golofn hon yn dangos yr amser y bydd y groes ei ganfod.

Tip

Mae'n ddefnyddiol i ddidoli ddisgynnol yn ôl y golofn a ddatryswyd (fel y dangosir yn yr ymgom uchod) i sicrhau bod y troseddau mwyaf diweddar yn ymddangos ar y 'uchaf' y rhestr.

Mae sawl opsiwn defnyddiwr i newid ymddygiad y model cefndir dilysu. Er enghraifft, to newid y lliwiau a ddefnyddir ar gyfer troseddau gyfyngiad i rywbeth arall na 'r ball Coch, Cliciwch ar Tools | Dewisiadau ... yna ewch i y Dilysutab, a gosod y lliwiau drwy gyfrwng y Newid botymau.

Dilysu opsiynau

Er mwyn dilysu â llaw cyfyngiadau

1. Dde-glicio ar y Pensaernïaethnod, unrhyw bensaernïaeth neu unrhyw le naill ai yn y Cydrannauneu Cysylltiadaurhan o'r farn arloeswr a dethol Gwiriwch Cyfyngiadau.

Validate cyfyngiadau

2. Cliciwch y Manylionbotwm ar y Rhybuddionffenestr i weld ble mae'r bensaernïaeth torri unrhyw gyfyngiadau sydd wedi'u diffinio.

Nodyn

Troseddau yn unig yn cael eu dangos am y cyfyngiadau y rhai sydd wedi cael eu gosod i rhybuddio neu Gorfodir. Ar ben hynny, bydd geiriad y rhybudd yn cynnwys 'dylai' os yw'r cyfyngiad yn unig oedd rhybudd neu 'rhaid' pe bai'n cael ei Gorfodir.

3. Cliciwch iawn.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw


Esblygu eich pensaernïaeth

Navigation: poblogi eich pensaernïaeth> poblogi â llaw> Opsiynau ychwanegol>

Esblygu eich pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

Gellir pensaernïaeth gael esblygu yn benodol a hierarchaeth o saernïaeth creu. Felly drwy esblygu eich pensaernïaeth yn ABACUS, gall nifer o atebion pensaernïol uwch yn cael eu creu, cymharu a baselined. Gall Nodau (neu metrigau) eu diffinio ar gyfer unrhyw nifer o eiddo pensaernïol ar gyfer pensaernïaeth sy'n bodoli eisoes.

Ffordd syml i ystyried esblygiad pensaernïaeth yw berthnasu i'r cysyniad o pensaernïaeth disgynnydd. Pan fydd pensaernïaeth yn esblygu, mae copiy rhiant bensaernïaeth yn cael ei greu. Gall hyn copi gellir dweud ei fod yn uniongyrchol ddisgynnyddo'r gwreiddiol rhiantpensaernïaeth.

Nodyn

Yn y dogfennau cymorth ar-lein a toolset ABACUS ei hun, mae'r term esblyguyn fwy cyffredin na'r term ddisgynnydd, Sylwch fod y ddau yn cyfeirio at yr un functionality.

I ddatblygu pensaernïaeth sy'n bodoli eisoes

1. Sicrhewch bod gennych File ABACUSagored ac mae'r Ffenestr fforiwrharddangos.

2. Dewiswch y bensaernïaeth perthnasol yr ydych am i esblygu o'r goeden fforiwr.

3. Dde chleciaar y bensaernïaeth a dethol Evolveo'r ddewislen.

Esblygu yr Dewis Pensaernïaeth

4. Bydd y bensaernïaeth esblygu yn ymddangos o dan y bensaernïaeth dethol.

Esblygu Pensaernïaeth

Nodyn

Gall y bensaernïaeth esblygu cael ei hailenwi drwy dde-glicio ar y bensaernïaeth a dewis Ailenwi.Ar ben hynny, bydd yr holl diagramau a chatalogau yn y bensaernïaeth esblygu cael eu gosod yn awtomatig i 'Diff' yn erbyn y bensaernïaeth llinell sylfaen ei fod yn esblygu o.

Gosod nodau ar gyfer eich pensaernïaeth esblygu

Gosod nodau ar gyfer eich pensaernïaeth esblygu yn eich galluogi i greu meini prawf i asesu esblygiad eich saernïaeth. Nodau yn cael eu pennu gan y mathau o eiddo ac enwau'r eiddo hynny sydd eisoes yn bodoli yn eich pensaernïaeth esblygu. Gellir Nodau hefyd yn cael eu diffinio'n llaw ac ychwanegu at chi pensaernïaeth. Dilynwch y camau isod er mwyn gosod nodau.

Gosod nodau o eiddo presennol ar gyfer eich pensaernïaeth esblygu

1. Sicrhewch bod gennych File ABACUSagored ac mae'r Ffenestr fforiwrharddangos.

2. Dewiswch Tools | Nodau SetO'r brif ddewislen.

3. Y Nod MewnbwnBydd ffenestr arddangos.

Nod Ffenestr Mewnbwn

4. Cliciwch ar y Presennolbotwm.

5. Y Dewiswch A EiddoBydd ffenestr arddangos.

6. Dewiswch eiddo rydych am ei osod fel nod ar gyfer eich pensaernïaeth esblygu a chliciwch ar y iawnbotwm.

7. Bydd y nod a ddewiswyd yn awr yn ymddangos yn y Nod Mewnbwnffenestr.

8. Dewiswch y nod a chliciwch ar y Golygubotwm.

9. Y Golygu NodBydd ffenestr arddangos.

Nodyn

Mae'r ffenestr yn caniatáu i chi newid yr enw eiddo a'r math y bydd y nod yn adlewyrchu, yn ogystal â'r gwerth gwaethaf a'r gorau (neu isafswm / uchafswm gwerthoedd) ar gyfer yr eiddo hwnnw. Mae'r gwerthoedd hyn yn cael eu canfod trwy gymharu pob saernïaeth a dod o hyd i'r gwerth lleiaf a mwyaf yn yr un ar gyfer yr eiddo hwnnw penodol. Gall gwerthoedd hyn hefyd gael eu diffinio llaw. Er enghraifft, pe baech yn gosod nod ar gyfer yr eiddo a enwir Ymateb (Ave)ac o'r math Ymddygiad, Gallai eich gwerth gwaethaf a gorau yn adlewyrchu eu hangen ar gyfer perfformiad gorau posibl (gwerth gorau) ac roedd angen ar gyfer y prif geisiadau yn unig cyflymder trafodiad gael ei brosesu (gwerth gwaethaf) cyflymder trafodiad.

10. Unwaith y bydd y gwerthoedd perthnasol wedi'u diffinio, dewiswch iawn.

Gosod nodau o eiddo newydd ar gyfer eich pensaernïaeth esblygu

1. Sicrhewch bod gennych File ABACUSagored ac mae'r Ffenestr fforiwrharddangos.

2. Dewiswch Tools | Nodau SetO'r brif ddewislen.

3. Y Nod MewnbwnBydd ffenestr arddangos.

4. Cliciwch ar y Newyddbotwm.

5. Y Nod NewyddBydd ffenestr arddangos.

Nodyn

Mae'r ffenestr yn eich galluogi i ddiffinio enw'r eiddo a'r math y bydd y nod yn adlewyrchu, yn ogystal â'r gwerth gwaethaf a'r gorau (neu isafswm / uchafswm gwerthoedd) ar gyfer yr eiddo hwnnw. Er enghraifft, pe baech yn gosod nod ar gyfer eiddo a enwir Ymateb (Ave)ac o'r math Ymddygiad, Gallai eich gwerth gwaethaf a gorau yn adlewyrchu eu hangen ar gyfer perfformiad gorau posibl (gwerth gorau) ac roedd angen ar gyfer y prif geisiadau yn unig cyflymder trafodiad gael ei brosesu (gwerth gwaethaf) cyflymder trafodiad.

6. Unwaith y bydd y gwerthoedd perthnasol wedi'u diffinio, dewiswch iawn.

7. A ymgom i Ychwanegu at bob saernïaethBydd yn arddangos fel isod:

8. Cliciwch ar Ydyi ychwanegu y nod fel eiddo i'r holl saernïaeth perthnasol. Mae hyn yn sicrhau y bydd y nod sydd newydd ei diffinio ac ei eiddo yn cael eu hychwanegu at holl saernïaeth yn y ffeil. Os nad ydych yn dymuno cynnwys yr eiddo yn y saernïaeth, gallwch glicio ar Na.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Edrych llain seren eich saernïaeth esblygu | Edrych llain gwasgariad o'ch saernïaeth esblygu


Mae'r Offeryn Arlunio

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Mae'r Offeryn Arlunio

Anfon sylwadau ar y pwnc hwn.

Mae'r Offeryn Darlun yn caniatáu amrywiaeth eang o schematics pensaernïol a diagramau greu. Penseiri yn draddodiadol yn defnyddio ystod o luniadau gwahanol i gofnodi a chyfleu dyluniad pensaernïaeth. Diagramau (2D) dau ddimensiwn yw'r ffordd arferol o dogfennu a chyfathrebu gwahanol rannau o system. Mathau lluniadau nodweddiadol a ddefnyddir mewn systemau menter yn:

· Busnes modelau proses a diagramau;

· Siartiau Trefniadaeth;

· Diagramau cydweithredu;

· Diagramau endid-perthynas (ER);

· Diagramau Data-Llif (DFD yn);

· Diagramau dosbarth;

· IDEF (yn ymgorffori nifer o'r uchod); ac

· UML (yn ymgorffori sawl un o'r uchod).

Does dim cyfyngiad ar y math o diagramau y gellir eu creu. ABACUS ceisio cydbwyso hyblygrwydd diagram gan gadw cyfanrwydd y bensaernïaeth a'i ffurfiau o gynrychiolaeth.

Mae'r amgylchedd lluniadu yn Tabbed a ffenestri dockable y tu mewn i'r prif gais ABACUS. Mae'r ffenestr yn cynnwys cynfas lle mae'r llun yn digwydd a phryd y ffenestr gan dynnu ar agor ail ffenestr dockable , Y ffenestr stensil, yn weladwy gyda set o stensiliau arlunio. Mae gan y cwarel stensil 4 tabiau: Cydrannau, Cysylltiadau, Siapiau a Connectors. Mae'r cynfas yn ymddangos fel gefndir gwyn gyda llinellau grid mân (defnyddiol ar gyfer cynllun).

Cydrannau yn cael eu cynrychioli gan amrywiaeth o siapiau, tra bod cysylltiadau yn cael eu tynnu fel llinellau cyfarwyddyd. Cysylltiadau roi ar gydrannau gan ddefnyddio rolau (Hy naill ai Ffynhonnell neu Sinc) er bod y rhain yn cael eu dangos am resymau esthetig.

Tip

Tra diagramauyn ddefnyddiol iawn i ddangos gwahanol rannau o'r system, maent yn gyfyngedig yn eu scalability, a dyna pam ABACUS yn defnyddio 3D i ddelweddu strwythurau system gymhleth.

Efallai y byddwch am

1. Agorwch y Diagramau Offeryn

2. Creu diagram newydd o ran o'ch bensaernïaeth

3. Adysgrifia diagram o fewn neu ar draws pensaernïaeth

4. Ychwanegu cydrannau at ddiagram

5. Creu cydrannau a chysylltiadau newydd yn eich pensaernïaeth (diagram) gan ddefnyddio'r teclyn gan dynnu

6. Dileu cydrannau o ddiagram

7. Atodwch & trin cysylltiadau

8. Newid y eiddo arddangos cydrannau a chysylltiadau.

9. Defnyddio cysylltiadau mewn diagram

10. Gorfodi cymdeithasau math a safbwyntiau fel ag i gyfyngu ar y mathau o diagramau y gellir eu tynnu.

Gweler Hefyd

Poblogi eich pensaernïaeth | Poblogi eich pensaernïaeth llaw | Dadansoddi eich pensaernïaeth


Diagramau Agor

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Diagramau Agor

Anfon sylwadau ar y pwnc hwn.

Mae'n ymddangos bod y ffenestri stensil a gynfas gan dynnu yn awtomatig pan diagram ei agor neu ei greu. Yn yr un modd, pan fydd diagram ar gau, y daflen Tabbed cyfatebol yn y ffenestr cynfas yn diflannu ac os nad oes lluniau pellach ar agor, yna y ffenestr stensil ar gau.

I creudiagram newydd

1. Sicrhewch bod gennychFfeil ABACUS agoredyn cynnwys eich pensaernïaeth poblog.

2. Cliciwch ar y Diagramicon yn y View bar offer.

- Neu -

2. Dewiswch Mewnosod| Diagram.

- Neu -

2. Dde-glicioy Diagramaucangen o roi Pensaernïaethadran y goeden a dethol Creu Diagram.

3. Dewiswch y Pensaernïaethydych am ganolbwyntio ar o'r ddewislen tynnu-lawr. Sylwer: bydd y bensaernïaeth eisoes yn cael eu dewis ar eich cyfer os ydych yn defnyddio Cam 3 uchod i agor y diagram newydd.

4. Dewiswch y Viewpoint ydych am eu defnyddio o'r ddewislen tynnu-lawr. Noder: Bydd y safbwynt a ddewiswyd hidlo'r cydrannau a rhestrau cysylltiadau â dim ond rhai sydd ar gael ar y safbwynt.

5. Optionally dewiswch golygfa o'r Hidlo Drwy Viewtynnu-lawr ddewislen i Rhagddewis y cydrannau a chysylltiadau o'r farn ddewiswyd. Nodyn: mae hyn yn effeithiol gan ddefnyddio y farn dewis fel ymholiad gadw.

6. Dewiswch y Layout i fod naill ai Rheiddiol neu Grid.

7. Dewiswch y Cydrannauac Cysylltiadaueich bod am yn y diagram o'r ffenestr dethol elfen safonol .

8. Cliciwch iawn.

Nodyn

Bydd diagram newydd yn cael eu hychwanegu at y Diagramaucangen o'r bensaernïaeth. Bydd yn cael enw diofyn, y gallwch ei newid yn ddiweddarach gan dde-glicio arno.Ar ben hynny, bydd y cyflwr olaf y gydran a dethol cysylltiad hidlwyr yn cael eu cadw gyda'r diagram arbed y 'ymholiad' a ddefnyddir i greu'r diagram yn effeithiol.

I agor Diagram sy'n bodoli eisoes

1. Yn y bensaernïaeth poblog penodol, ehangu'r Diagramaucangen o'r goeden.

2. Double-glicio y diagram eich bod am agor.

I arbed diagram

1. Sicrhewch fod gennych diagram newydd neu bresennol agoredac eich bod wedi gwneud y newidiadau angenrheidiol. Noder: seren '*' yn cael ei ddangos ar ôl y farn enw yn y pennawd ddalen dabio os oes newidiadau i gael eu hachub.

2. Ym marn fforiwr cliciwch ar y Savebotwm neu rhaid i Ffeil| Saveneu gostwng Ctrl + Si achub yr holl newidiadau yn eich pensaernïaeth a'i ysgrifennu i ffeil.

I arbed diagram fel safbwynt

1. Sicrhewch eich bod yn cael diagram sy'n bodoli eisoes yn eich ffeil ABACUS.

2. Dde-glicioy diagram yn y Diagramaurhan o'r goeden.

3. Dewiswch Save As Safbwynt Diagram.

4. Rhowch enw ar gyfer eich newydd safbwynt diagrama chliciwch iawn.

Gweler Hefyd

Mae'r Offeryn Arlunio | Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth


Diagramau Copïo

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Diagramau Copïo

Anfon sylwadau ar y pwnc hwn.

Mae 2 senario sylfaenol i gopïo ddiagram sy'n bodoli eisoes; mewn pensaernïaeth, pensaernïaeth neu ar draws.

I copidiagramo fewn pensaernïaeth

1. Sicrhewch bod gennychFfeil ABACUS agoredyn cynnwys eich pensaernïaeth pobloggydag o leiaf un diagram.

2. Expandy Diagramaugangen (Ac unrhyw gofynnol Grwpiau Diagram) o roi Pensaernïaethadran y goeden.

3. Dewiswch y diagram ydych yn dymuno copïo ac yna pwyswch Ctrl + Cneu dde-glicioa dewis Copi o'r ddewislen.

Nodyn

A copi o'r Bydd diagram yn cael ei ychwanegu at y Diagramaucangen o'r un fath pensaernïaeth. Bydd ganddo "Copi o" ynghlwm wrth ddechrau'r enw, Y gallwch ei newid yn ddiweddarach gan gwasgu F2 neu dde-glicio ar eia dewis Rename.

I copïo diagram ar draws pensaernïaeth

1. Sicrhewch bod gennychFfeil ABACUS agoredyn cynnwys eich pensaernïaeth poblogsgydag o leiaf un diagram.

2. Expandy Diagramaugangen (Ac unrhyw gofynnol Grwpiau Diagram) o y Pensaernïaethadran y goedenam y bensaernïaeth sy'n cynnwys y diagram ydych yn dymuno copïo.

3. Dewiswch y diagram ydych yn dymuno copïo ac ar y Eiddo CyffredinolNodyn ffenestr y Viewpoint bod y diagram yn gysylltiedig â (yn y maes Type).

4. Yn awr, ehanguy Diagramaugangen (Ac unrhyw gofynnol Grwpiau Diagram) o y Pensaernïaethadran y goedenar gyfer y bensaernïaeth arall sy'n ydych yn dymuno copïo y diagram i mewn.

5. Dde-glicioy Diagramau nod (neu'r Grŵp Diagram) A dewis Creu Diagram .... Yn y deialog sy'n ymddangos dewiswch y Viewpoint a gafodd ei nodi yn gam 3 uchod yn y galw-i-lawr ar y dde uchaf. Gadewch popeth arall fel y mae a chliciwch iawn. Yn yr ymgom Diagram Enw rhowch enw ar gyfer y (fuan i fod) diagram copïo. Noder: Bydd cynfas diagram gwag yn ôl y safbwynt a ddewiswyd yn cael ei agor.

6. Ewch yn ôl i'r diagram eich bod yn dymuno copïo ac agor y gan dde-glicioy nôd a dewis Agored neu yn syml dwbl-glicioiddo.

7. Dewiswch y cefndir cynfas o'r diagram ydych yn dymuno copïo a wasg Ctrl + A. Bydd hyn dewiswch yr holl elfennau ar y diagram. Nawr pwyswch Ctrl + Ci gopïo'r cynnwys i clipfwrdd.

8. Yn awr, yn dychwelyd i'r diagram gwag yn y bensaernïaeth ydych yn dymuno copïo cynnwys i mewn i, dewiswch y cefndircynfas a naill ai dde-glicioa dewis Gludo neu yn syml pwyswch Ctrl + Vi bastio 'r cynnwys. Ar ôl cyfnod byr, bydd y cynnwys i gyd yn cael ei gludo i mewn i'r diagram gwag newydd.

Nodyn

Bydd elfennau yn cael eu hychwanegu at y-lefel uchaf y bensaernïaeth newydd a bydd angen ail-drefnu neu cyfuno gyda chynnwys sy'n bodoli eisoes yn unol â hynny.

Gweler Hefyd

Mae'r Offeryn Arlunio | Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth


Diagramau poblogi

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Diagramau poblogi

Anfon sylwadau ar y pwnc hwn.

Darluniau yn ABACUS yn fwy na dim ond sylwadau mympwyol. Maent yn cael eu haddasu barn y bensaernïaeth, fformatio a threfnu i ddangos ystyr penodol.

Mae'r Offeryn Arlunio yn gorfodi strwythur hierarchaidd y bensaernïaeth, fel bod cydrannau yn cael eu nythu ar eu golwg o fewn cydrannau eraill - gan roi 'golwg gynllun' o'r elfennau yn effeithiol. Unwaith y cydran neu gysylltiad wedi ei ddiffinio yn y pensaernïaeth, gellir ei ddefnyddio mewn unrhyw nifer o wahanol ddiagramau. Yn bwysig, mae'r Offeryn Arlunio Mae cysylltiad agos rhwng y model pensaernïol, fel bod newidiadau a wneir yn y naill un bob amser yn cael eu hadlewyrchu yn y llall.

Mae'r offeryn yn gweithio drwy gysylltu siapiau gyda mathau penodol o gysylltiad ac gydran a ddiffinnir yn yr adran Mathau o bensaernïaeth. Mae'r cymdeithasau yn amrywio yn dibynnu ar y math o ddiagram cael ei llunio, ac mae'n bosibl y gall un math o gydran (neu gysylltiad) gwahanol gynrychioliadau yn y gwahanol diagramau, yn dibynnu ar y cyd-destun.

Sefydlu cysylltiad rhwng siâp a cydran neu gysylltiad math

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Manteisio i'r eithaf ar y cais ABACUS, a ffurfweddu'r cyfrannau ffenestr wrth i chi awydd.

3. Dewiswch y Tab Siapiauneu'r Tab Connectors yn y ffenestr stensil.

4. Yn y Mathcangen o'r Explorer, lleoli y gydran neu gysylltiad math hoffech gysylltu gyda siâp neu cysylltydd.

5. Dewiswch yr elfen math a ddewiswyd o'r goeden, ddragia 'drosodd i'r tab Siapiau neu dab Connectors, a gollwng ar y siâp neu cysylltyddyr hoffech eu defnyddio.

Nodyn

Gallwch wirio cymdeithas ydych wedi creu trwy ddewis y Cydrannau neu'r tab Connections yn y ffenestr Stencil, sy'n dangos yr elfennau cysylltiedig ar hyn o bryd.

I ychwanegu siapau newydd at eich diagramau / llyfrgell

1. Creu diagram MS Visio gyda'r siapiau eich bod am ychwanegu at eich diagram a mewnforio y diagram MS Visio .

Tip

Mae'n bwysig pa faint yr ydych yn gwneud y meistr siâp yn MS Visio am fod y cynfas ABACUS ei maint mewn picseli a dim ond unedau milimetr eu MS Visio trosi granularly i picsel ar 4 picsel i 1 gymhareb milimedr. Ar ben hynny, 'r ball siapiau ABACUS fel arfer yn 60 picsel uchel fel eu bod yn cyfateb i 15 milimetr eu MS Visio. Sy'n golygu ddoeth meistr siâp maint yn MS Visioyw 25mm o led a 15mm uchelgan y bydd hyn yn cyfieithu i 100 picsel o led a 60 picsel uchel mewn ABACUS.

Tip

Os ydych am gael ychydig o 'eicon' yn y gornel chwith uchaf o siâp, yna gallwch greu 'eicon' yn y prif MS Visio siâp gan ddefnyddio'r palet MS Visio Arlunio Offeryn (noder y llinellau syml yn unig, cylchoedd a phetryalau yn cael eu cefnogi ac nid siapiau rasterized / didfap yn arbennig yn cael eu cefnogi). Ar ben hynny, os ydych am yr eicon i fod yn sefydlog o ran maint / graddfao fewn y siâp yn ABACUS yna gallwch grŵp y 'eicon' yn y prif MS Visio siâp drwy ddewis ei holl elfennau, dde-glicio un elfen, gan ddewis Siâp | Grŵp, ac yna i'r dde-glicio ar y siâp grwpio a dewis Data | Shape Data ..., gan ddewis Ie yn y deialog sy'n ymddangos ac yna'n ychwanegu eiddo gyda'r Label osod i LockScale(Nodwch y priflythyren 'L' ac 'S'), mae'r Math osod i Boolean ac mae'r Gwerth mynd i fod TRUE (Noder mae'r cyfan yn priflythyren).

Tip

Os ydych am gael cyfran o'r siâp rhewi rhag scaling yn llorweddol neu'n fertigol (fel sy'n nodweddiadol gyda siâp 'colofn cyfrifoldeb') yna gallwch dde-glicio y rhan (nau) o'r meistr siâp MS Visio a 'ch angen rewi o scaling a dewis Data | Shape Data ..., gan ddewis Ie yn y deialog sy'n ymddangos ac yna'n ychwanegu eiddo gyda'r Label osod i LockXScaleneu LockYScale (Nodwch y priflythyren 'L' ac 'S'), mae'r Math osod i Boolean ac mae'r Gwerth mynd i fod TRUE (Noder mae'r cyfan yn priflythyren), ar gyfer cloi graddio llorweddol neu'n fertigol yn y drefn honno.

Tip

Er mwyn caniatáu i'r lliw y siâp yn ABACUS ar ôl mewnforio yn hytrach na siâp bob amser fod yn lliw sefydlog fe'ch cynghorir i wneud llenwad y meistr MS Visio siâp yn tryloyw ac yna defnyddiwch y gallu inbuilt yn ABACUS i liwio cefndir siâp yn. Mae hyn ond yn gweithio gyda siapiau petryal neu'n agos-betryal (ee petryal crwn) gan y bydd y cefndir hirsgwar cyfan yn cael ei lliw.

2. Agorwch y diagram cyfatebol a dewis y Tab Cydrannauyn y ffenestr stensil.

3. Ar gyfer pob siâp newydd yr ydych am ei wneud ar gael i ddiagramau eraill Dde-gliciosiâp a dethol Ychwanegu at Lyfrgell Siapiau. Bydd hyn yn gwneud y siâp sydd ar gael ar y tab Siapiau yn y ffenestr stensil.

4. Cysylltu y math gydran perthnasol gyda'r siâp newydd o'r llyfrgell Siapiau yn ôl y camau a ddisgrifir uchod.

Nodyn

Dim ond syml a siapiau yn cael eu cefnogi yn ABACUS ar hyn o bryd "yn seiliedig fector-", hy bitmaps yn cael eu cefnogi. Fodd bynnag, mae offer fel Vector Magic ( www.vectormagic.com ) Ar gael a fydd yn hawdd trosi delweddau didfap i mewn i siapiau fector sy'n seiliedig (hy fformat SVG) y gellir eu hagor mewn MS Visio ac felly defnyddio yn ABACUS yn ôl y cyfarwyddiadau uchod.

YchwaneguCydrannau a Cysylltiadau

Mae'r Offeryn Arlunio yn caniatáu i chi ychwanegu cydrannau a chysylltiadau presennol o'r storfa neu creu cydrannau a chysylltiadau newydd gan eich bod yn tynnu diagram. Fel cydrannau a chysylltiadau yn cael eu creu mewn diagramau, maent yn cael eu hychwanegu ar yr un pryd i mewn i'r ystorfa. Mae yna tri a argymhellir ffyrdd o ychwanegu cydrannau i ddiagrama thri yn argymell ffyrdd o ychwanegu cysylltiadau at ddiagram:

I greu cydran neu gysylltiad cwbl newydd ar ddiagramoddi wrth y stensil

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Dewiswch y Cydrannauneu Cysylltiadautab yn y ffenestr stensil i weld y siapiau cysylltiedig. Dim ond siapiau hyn gael eu defnyddio i greu elfennau model newydd.

3. Cliciwch a llusgoun o'r siapiau cysylltiedig ar gael ar y cynfas lluniadu. Bydd yr elfen newydd yn ymddangos ar y cynfas ac yn y goeden fforiwr.

4. Dechreuwch deipioenw ar gyfer yr elfen newydd yn yr ymgom ac unrhyw elfennau presennol sy'n cael eu cyfateb yn cael eu hawgrymu a gellir eu dewis yn hytrach nag ychwanegu elfen newydd i'r bensaernïaeth.

5. Cliciwch iawn.

6. Pe siâp ei ollwng ar elfen sydd eisoes yn bodoli, yna bydd yn naill ai yn dod yn blentyn o'r gydran honno (os daeth y siâp gan y Cydrannautab), neu bydd yn cael ei ynghlwm wrth y gydran (os daeth y siâp gan y Cysylltiadautab).

Nodyn

Weithiau bydd angen i addasu y cydran neu gysylltiad newydd yn lle gwahanol yn yr hierarchaeth pensaernïol ddefnyddio'r fforiwr.

I osod cydran neu gysylltiad presennol o'r ystorfa ar ddiagram

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Byddwch yn siwr eich bod yn cael y ddau yr Offeryn Lluniadu a ffenestri Explorer viewable.

3. Yn y Explorer, leoli'r cydranneu cysylltiad(Elfen) yr hoffech eu hychwanegu at y diagram.

4. Cliciwch a llusgoyr elfen a ddewiswyd ar y diagram. Bydd siâp sy'n cynrychioli'r elfen yn ymddangos ar y cynfas.

Nodyn

Os yw'r math o elfen a ddewiswyd eisoes yn gysylltiedig â siâp, bydd ffurf gyfatebol yn ymddangos ar y cynfas. Os, fodd bynnag, nid oes unrhyw gysylltiad diffiniedig i gael yr elfen benodol, bydd siâp diofyn (petryal) yn ymddangos ar y cynfas oni bai bod y Gorfodi Diagram Gwylfannau opsiwn ar ac yn yr achos, ni fydd y siâp yn cael ei ychwanegu at y diagram.

Tip

Pan fydd elfen yn cael ei roi ar ddiagram sydd wedi'i gysylltu â gydran arall sydd eisoes ar y diagram, bydd y Pecyn Arlunio holi os hoffech i ddangos y cysylltiad (au) rhyngddynt. Hefyd, os oes unrhyw blant y gydran, bydd y Pecyn Arlunio holi os hoffech i gynnwys y plant, mewn ffordd ailadroddus.

I creu cysylltiad rhwng 2 cydrannau neu gydran gysylltiedig ar ddiagram gan ddefnyddio cysylltydd deinamig

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Hofran dros elfen ar y diagram yr ydych am gysylltu â gydran arall ac fe sylwch 2 eiconau yn ymddangos y tu allan i'r uchaf ar y dde o'r ffin y siâp fel y dangosir isod. Noder: Mae'r eicon uchaf yn ar gyfer creu cysylltiad lle y gydran hofran yw i fod y ffynhonnell, yr eicon gwaelod ar gyfer creu cysylltiad lle y gydran hofran yw bod yn y sinc.

3. Symud y cyrchwr dros yr eicon a ddymunir ac cliciwch a llusgoyr eicon i dros naill ai dros ofod cydran neu am ddim arall ar y cynfas fel y dangosir isod.

4. I gysylltu cydran sydd eisoes yn bodoli yn dewis y Atodwch at ...eitem yn y ddewislen pop-up, ac os bori ofynnol i'r is-ddewislen i ddewis o'u plith y mathau cysylltiad sydd ar gael.

- Neu -

4. I greu elfen gysylltiedig dewis gan y Newydd ...eitemau yn y ddewislen pop-up, ac os bori ofynnol i'r is-ddewislen i ddewis o'r mathau o gysylltiad sydd ar gael fel y dangosir isod. Dechreuwch deipioenw ar gyfer yr elfen newydd yn yr ymgom ac unrhyw elfennau presennol sy'n cael eu cyfateb yn cael eu hawgrymu a gellir eu dewis yn hytrach nag ychwanegu elfen newydd i'r bensaernïaeth.

Nodyn

Mae argaeledd eitemau yn y ddewislen pop-up ac is-ddewislen yn cael ei reoli gan y cyfyngiadau yn y meta-model.Dyna'r unig ffynhonnell ddilys neu'n suddo fathau cydran gan y bydd pennu gan gyfyngiadau cysylltiad yn cael ei gyflwyno fel y Atodwch at ... ac eitemau Newydd ... fwydlen.

I ail-agor yr ymgom dethol elfen a gosod cydrannau neu gysylltiadau o'r storfa bresennol ar ddiagram

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Cliciwch y Dewis Elfen Agoredbotwm yn y bar offer Diagram. Sylwer: mae'r deialog dethol elfen yn agor gyda'r cyflwr olaf o unrhyw hidlwyr cadw.

3. Dewiswch unrhyw gynnwys ychwanegol sydd dymunir ei ychwanegu at y diagram a chliciwch iawn. Noder: Bydd y cynnwys newydd yn cael ei ychwanegu at ofod clir ar y cynfas a gall y diagram fod yn dilyn hynny gosod allan eto drwy'r Layout Diagrambotwm yn y bar offer Diagram.

Defnyddio Am ddimffurflenSiapiau

Mae'n aml yn ddymunol i greu elfennau gweledol mewn diagram am resymau esthetig yn unig. Gall yr elfennau hyn yn helpu i wella gosodiad a golwg diagram, eto nid oes ganddynt arwyddocâd pensaernïol llym. Mae'r Offeryn Arlunio caniatáu defnyddio siapiau freeform er mwyn darparu gan dynnu hyblygrwydd.

I ychwanegu siâp freeform i ddiagram

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Dewiswch y Siapiauneu Connectorstab yn y ffenestr stensil.

3. Cliciwch a llusgoun o'r siapiau sydd ar gael neu cysylltwyr ar y cynfas lluniadu. Bydd yr elfen newydd yn ymddangos ar y cynfas - ond Niyn y goeden fforiwr.

Nodyn

Siapiau freeform yn cael eu 'heb fod yn gysylltiedig' siapiau, gan nad oes ganddynt unrhyw gysylltiad ag unrhyw elfen neu gysylltiad yn y model pensaernïol penodol.

I arddangos gwybodaeth ystorfa yn siâp freeforms ardiagram

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Dde-gliciosiâp freeform a dethol Anodi | Arddangos.

3. Dewiswch i arddangos naill ai'r Enw Diagram, Disgrifiad Diagram, Diagram Eiddo, Viewpoint Enwneu Pensaernïaeth Enw.

Nodyn

Bydd y testun yn y freeform diweddaru yn awtomatig wrth i'r newidiadau data ystorfa sylfaenol.Fel hyn, gall 'bloc teitl' diagram yn cael ei greu ar gyfer, ac yna yn hawdd copïo ar draws, diagramau.

Defnyddio Siapiau fel y bo'r angen

Siapiau fel y bo'r angen yn y bôn ffordd arall i gynrychioli cydrannau mewn diagram. Ystyriwch sefydliad ag adrannau allweddol: Prif Swyddog Gweithredol, Marchnata, Gwerthu a Datblygu.

Tree View

Gall y rhanbarthau gael eu cynrychioli yn weledol mewn modd haenog:

Haenau View

Neu efallai y byddant yn cael eu cynrychioli yn weledol mewn gwasgarog / Fel y bo'r angen modd i ddangos hierarchaeth:

Groesgam / Fel y bo'r angen View

Mae'r gynrychiolaeth olaf yn defnyddio'r cysyniad o siapiau fel y bo'r angen.

Er mwyn trosi siâp cydran haenog i siâp fel y bo'r angen

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Dewiswch y cydranyn eich diagram eich bod am gynrychioli fel siâp fel y bo'r angen neu siâp cysylltiedig yn y Cydrannautab y ffenestr stensil rydych am bob achos fel siapiau fel y bo'r angen.

3. Dde-gliciwch y siâp a dewis Arnofio Cydran o'r ddewislen cyd-destun sy'n ymddangos. Sylwch ar y dan y pennawd diemwnt cysylltiadoddi wrth y rhiant gydran (au) i'r elfen (nau) fel y bo'r angen.

4. Cliciwch a llusgoy gydran i'r lle a ddymunir. Pan fydd fel y bo'r angencydran yn cael ei ddewis, bydd yn cael amlinelliad glas.

Er mwyn trosi siâp cydran fel y bo'r angen i siâp haenog

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Dewiswch y cydranyn eich diagram sy'n cael ei ddangos ar hyn o bryd fel siâp fel y bo'r angen neu siâp cysylltiedig yn y Cydrannautab y ffenestr stensil rydych am bob achos fel siapiau haenog.

3. Cliciwch a llusgoyr elfen (nau) fel y bo'r angen yn ôl i'r rhiant (rhieni) (yn ôl y dan y pennawd diemwnt cysylltiad). Sylwer: Os na fyddwch yn gwneud hyn, yna pan fyddwch yn newid y gydran (au) yn ôl i gael ei haenog gallai hierarchaeth eich model yn cael ei effeithio.

4. Dde-gliciwch y siâp a dad ddewiswch Arnofio Cydran o'r ddewislen cyd-destun sy'n ymddangos. Noder bod y dan y pennawd diemwnt cysylltiado bydd y rhiant gydran (au) i'r elfen (nau) fel y bo'r angen yn diflannu.

Replicas

Mae'r Offeryn Arlunio yn caniatáu i chi ychwanegwch yr un gydran at diagram sawl gwaith gyda phob achos gweledol ychwanegol o'r elfen ar y diagram cyfeirir ato fel replica. Mae hyn yn arbennig o ddefnyddiol ar gyfer diagramau lle mae gan cydran nifer fawr o gysylltiadau ynghlwm wrtho ac mae'n well i ddangos y gydran mewn lleoliadau lluosog yn nes at y tarddiad pob un o'r cysylltiadau, neu ar gyfer ddiagramau lle mae perthynas un-i-nifer o elfen yn well i ddangos ddefnyddio'r nodwedd fel y bo'r angen (a ddisgrifir uchod) gyda'r elfen mewn lleoliadau lluosog ar ben y cydrannau 'llawer' ei fod yn gysylltiedig â.

Nodyn

Gallwch cysylltu / datgysylltu cysylltiadau i / o y lle gwreiddiol y gydran ar ddiagram (fel bob amser), ond hefyd i unrhyw un o'r replicas, fodd bynnag, pan cysylltiadau yn cael eu hychwanegu yn awtomatig at diagram maent yn cael eu ynghlwm wrth y lle cyntaf y gydran ar y diagram yn ddiofyn.

Nodyn

Gellir replicas eu huno â'i gilydd gan dde-glicio a llusgoyna dewis Cyfuno AtgynyrchiadauFodd bynnag, cyfuno replica gydag elfen gwahanol yn arwain at unrhyw replicas eraill yn diflannu oddi wrth y diagram.

Nodyn

Nid oes gwahaniaeth gweledol rhwng y lle gwreiddiol cydran ar ddiagram ac unrhyw gopïau. Ar ben hynny, mae'r ddewislen dde-glicio ar gyfer y gydran gwreiddiol ar ddiagram ac unrhyw gopïau yn union yr un fath, gyda, er enghraifft Dangos mewn Explorermynd â chi at yr un elfen yn y View Coed y storfa (aka y model). Fodd bynnag, dde-glicio ar yr elfen yn y View Coed y storfa a dewis Ewch ia bydd pori i'r diagram gyda replicas bob amser yn mynd â chi at y lle 'hynaf' y gydran ar y diagram. Fel arfer bydd hyn yn achos gwreiddiol a ychwanegwyd at y diagram, ond os yw'r achos gwreiddiol ei ddileu neu uno wedyn gyda replica, yna bydd Go I neidio i'r hynaf o'r copïau sy'n weddill a gafodd eu hychwanegu.

I ychwanegu replica at diagram

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Cliciwch y botwm dde elfen presennol ar y diagram a dewiswch Creu Replica.Bydd copi o'r gydran a ddewisir yn cael ei greu ar y dde o'r gydran gwreiddiol.

- OR -

Dewiswch gydran presennol ar ddiagram a phwyso Ctrl + Cneu de-gliciwch elfen presennol ar y diagram a dewiswch Copi. Nawr de-gliciwch y lleoliad ar y diagram yr ydych am i'r replica a dewis Gludo fel Replica. Noder: Bydd gwasgu'r Ctrl + V (neu dde-glicio a dewis Bastio) creu copi o'r gydran gwreiddiol NID replica.

- OR -

Cliciwch a llusgoelfen o View Tree y storfa (aka y model) ar ddiagram lle y gydran eisoes yn bodoli.

Ffurfweddu Cysylltiad Capiau / Diwedd

Mae'r Offeryn Arlunio yn caniatáu i chi gosod y symbol a ddefnyddir ar ben y llinellau cyswllt naill ai symbol sefydlog neu symbol sy'n ddibynnol ar eiddo ar y cysylltiad ei hun.Mae hyn yn arbennig o ddefnyddiol i diagramau lle mae angen cyfeiriad cyswllt i'w dangos, neu ar gyfer diagramau lle mae'r cardinality y cysylltiad (neu'r cyfarwyddyd) yn cael ei gynnwys yn eiddo ar y cysylltiad ei hun, ee 'Un-i-lawer' vs 'Mae llawer-i-lawer' (neu 'Source i Sinc' yn erbyn 'Sinc i ddod o').

I ffurfweddu capiau cysylltiad / dod i ben ar diagram

1. Sicrhewch fod gennych newydd neu bresennol diagram agored.

2. Dewiswch y Cysylltuïonautab yn y ffenestr stensil.

3. Dde-clyfuun o'r mathau o gysylltiad cysylltiedig a dewis Ffurfweddu Capiau ....

4. Am gysylltiad sefydlog cap / pen naill ai y ffynhonnell neu sinc diwedd y cysylltiad sicrhau bod y perthnasol Sefydlog botwm radio yn cael ei ddewis ac yna dewiswch y symbol pen cysylltiad gan y tynnu i lawr, ee 'Arrow Pennaeth' neu 'Diamond'.

- OR -

Am gysylltiad cap / diwedd seiliedig ar eiddo-yn naill ai'r ffynhonnell neu sinc diwedd y cysylltiad sicrhau bod y perthnasol Defnyddio Eiddobotwm radio yn cael ei ddewis, yna cliciwch y botwm '...' a dewiswch y eiddo sydd ei angen ac yna wrth ymyl pob symbol pen cysylltiad mynd i mewn i'r gwerth eiddo y mae'r symbol cysylltiad penodol i'w dangos.

Nodyn

Gall gwerth eiddo lluosog ar gyfer cysylltiad a roddwyd symbol diwedd yn cael ei gofnodi gwahanu gan atalnodau.E.e. yr ymgom isod yn dangos os bydd y 'Data | 'Mae gan eiddo werth' cardinality un-i-lawer 'yna bydd y ffynhonnell diwedd y cysylltiad wedi dwy linell strôc drwyddi a bydd y sinc diwedd y cysylltiad yn cael un strôc llinell drwyddo ac yna yn gefnogwr-allan o ddau llinell strôc ar y diwedd.

Ffurfweddu Capiau ymgom

Gweler Hefyd

Mae'r Offeryn Arlunio | Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth


Diagramau Trin

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Diagramau Trin

Anfon sylwadau ar y pwnc hwn.

Unwaith y diagram wedi cael ei greu, mae'r elfennau sy'n ymddangos ynddo yn gallu cael ei ail-drefnu ac ail-maint fel y dymunir.

I symud cydran mewn diagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Cliciwch-a-dalunrhyw elfen i'w symud. Os bydd y cydran a ddewisir gan riant, bydd y rhiant cydran yn cael eu hamlygu.

3. Gan fod yr elfen ynllusgo oddi wrth ei gydran riant, a dros cydrannau eraill, bydd rhieni 'potensial' yn dod yn amlygu. Mae'r cynllun lliwiau a ddefnyddir yn dangos yr effaith a gaiff y llawdriniaeth ei gael ar y rhybuddion a gwallau gyda'r prosiect ar hyn o bryd ac yn cael ei ddisgrifio yn Diffinio a Dilysu Cyfyngiadau . Yn y modd hwn, gallwch graffigol lywio hierarchaeth o 'view cynllun'.

4. Rhyddhauy botwm y llygoden i ollwng yr elfen yn ei leoliad newydd.

Nodyn

Efallai y byddwch hefyd ddefnyddio'r bysellfwrdd i ail-leoli elfennau ar y cynfas lluniadu. Yn syml, dewiswch y cydran neu ffurf rhad ac am ddim siâp ydych am symud ac yn defnyddio'r bysellau saeth lleoli ar y bysellfwrdd i symud y siâp i'r lle a ddymunir.

Noder hefyd bod wrth lusgo elfen gyda eich llygoden dros gydran arall, elfen rhiant 'potensial' yn cael ei hamlygu pan fydd y gornel uchaf-chwith y gydran yr ydych yn ei lusgo gorgyffwrdd elfen arall.

Tip

Rhydd ac Siapiau fel y bo'r angen gellir ei archebu gan dde-glicioa dewis Dewch i Flaenneu Anfon at Backo'r ddewislen. Mae'n bwysig nodi y siapiau gydran gellir eu trosi i siapiau rhydd gan dde-glicioar siâp gydran penodol a dewis Trosi i rhydd.

I newid maint cydran mewn diagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Cliciwch-dal-llusgoun o'r dolenni gydran a newid maint y siâp i faint a ddymunir.

3. Fel arall, er mwyn cynnal cymhareb agwedd y siâp, yn gostwng Shift + Clic-dal-llusgo.

I symud cysylltiad mewn diagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Cliciwch-a-dalunrhyw gysylltiad i'w symud.

3. Rhyddhauy botwm y llygoden i ollwng yr elfen yn ei leoliad newydd.

Nodyn

Gallwch ond symud cysylltiadau nad ydynt ynghlwm wrth unrhyw gydrannau. Os ydynt yn cael eu hatodi, gallwch ond symud y pen am ddims, Neu ail-lwybr y cysylltiad .

Dileu Cydrannau a Cysylltiadau

Wrth dileu cydran neu gysylltiad o ddiagram, mae gennych y dewis i ddileu oddi ar y bensaernïaeth gyfan. Bydd unrhyw elfen sy'n cael ei ddileu o'r bensaernïaeth yn cael ei symud yn awtomatig o unrhyw ddiagramau eraill lle y mae'n ymddangos. Gan achosion freeform dim ond yn ymddangos mewn un diagram, dileu nid yn eu yw'n effeithio ar y model pensaernïol neu unrhyw ddiagram arall.

I ddileu cydran neu gysylltiad o ddiagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Cliciwchar unrhyw gysylltiad cysylltiedig neu gydran i'w ddewis.

3. Gwasgwch y Dileuallweddol er mwyn ddileu oddi ar y diagram, neu Shift + Dileui'w ddileu oddi ar y model cyfan.

- Neu -

2. Cliciwch y botwm dde ar unrhyw elfen neu gydran cysylltiedig. Bydd chyd-destun ddewislen yn ymddangos.

3. Dewiswch Dileu o Viewneu Dileu o Pensaernïaetho'r ddewislen cyd-destun.

Nodyn

Os oes gan yr elfen eich bod yn dymuno dileu o'r farn nad oes plant, a dim ond yn digwydd ar farn honno, bydd ABACUS gofyn a ydych eisiau dileu'r elfen o'r ystorfa hefyd.

Rhybudd

Wrth dileu elfen o'r model sydd cydrannau plentyn, bydd y plant hefyd yn cael eu dileu o bosibl yn ôl y ddeialog rhybudd.

Cyfuno Cydrannau

Efallai y byddwch am i uno dwy ran sydd eisoes yn bodoli ar yr un diagram (ac o fewn y bensaernïaeth). Gellir gwneud hyn am nifer o resymau, er enghraifft, Mae dau gweinyddwyr yn bodoli o fewn y cwmni H infrastructure-01 a H02. Mae'r ddau gweinyddwyr yn cael eu cynrychioli fel dwy elfen ar wahân o fewn pensaernïaeth. H01 wedi cael ei ystyried yn ddiangen ac felly yn cael ei dadgomisiynu. Mae'r holl geisiadau presennol rhedeg ar H01 yn cael eu symud i H02 (dal i fod yn gomisiwn). Yna gall y newid hwn yn cael ei adlewyrchu gan y weithred o "uno" y ddwy gydran H01 a H02 ar y diagram (ac o fewn y bensaernïaeth).

Am drafodaeth fanwl am uno cyfeiriwch at y pwnc Cyfuno Eitemau yma .

I gyfuno dwy elfen sydd eisoes yn bodoli

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Cliciwch y botwm dde-dalar yr elfen rydych am ei uno a llusgomae'n ar y gydran yr ydych am i uno 'i ag. Sicrhewch fod y amlinelliad o'r gydran gyrchfan yn cael ei amlygu goch i ddangos ei fod yn cael ei ddewis.

3. Dewiswch Cyfuno | Cadw Cyrchfanneu Cyrchfan Trosysgrifoo'r ddewislen.

Nodyn

Y Cadw Cyrchfanopsiwn cyffeithiau gwerthoedd eiddo y gydran gyrchfan os ydynt yn bodoli ar y gydran gwreiddiol hefyd.

Y Cyrchfan Trosysgrifoopsiwn overwrites eiddo y gydran cyrchfan gydag unrhyw eiddo cyffredin o'r gydran gwreiddiol.

Newid Cysylltiadau

Mae'r cysylltiadau dangos mewn diagram bob amseradlewyrchu strwythur fel y'i diffinnir yn y bensaernïaeth ei hun. Mae'r Offeryn Arlunio yn eich galluogi i ddatgysylltu cysylltiadau o gydrannau, symud, gromlin iddynt, ail-lwybr iddynt ac yn eu hail-roi ar gydrannau eraill.

Er mwyn datgysylltu / atodi cysylltiad o / i cydran

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Cliciwch-a-dalar unrhyw gysylltiad.

3. Dewiswchy cysylltiad diwedd(H.y. Ffynhonnell neu Sinc) Y byddech yn hoffi i ddatgysylltu / atodi. Sylwer: mae'r cysylltiad yn dod i ben yn cael eu nodi gyda chylchoedd bach gwyn a hofran dros y cylch gwyn am ail yn achosi 'tooltip' i ymddangos gyda'r perthnasol rôlenw(Hy naill ai Ffynhonnell neu Sinc).

4. Llusgwchy cysylltiad i ben i leoliad newydd (naill ai yn lle gwag neu gydran) a rhyddhau'r botwm llygoden.

Nodyn

Pan fydd diwedd cysylltiad yn cael ei roi dros gydran ddilys, amlinelliad y gydran gyrchfan ei amlygu gydag amlinelliad fylchog. Mae'r cynllun lliwiau a ddefnyddir yn dangos yr effaith a gaiff y llawdriniaeth ei gael ar y rhybuddion a gwallau gyda'r prosiect ar hyn o bryd ac yn cael ei ddisgrifio yn Diffinio a Dilysu Cyfyngiadau . Unwaith rhyddhau diben hwnnw o fede cysylltiad a'r gydran yn cael eu cysylltu yn awtomatig(Neu ynghlwm), A chaiff hyn ei adlewyrchu yn y model pensaernïol.

I ail-lwybr cysylltiad

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Gosodwch y pwyntydd y llygoden dros gysylltiad.

3. Daliwch y Shifti lawr allweddol a Cliciwchy botwm y llygoden i osod pwynt angor cysylltiad. Datganiad y Shift allweddol. Gallwch gael gwared ar y pwynt angor drwy wneud yr un llawdriniaeth.

4. Cliciwch-a-llusgopwynt angor i ail-lwybr y cysylltiad.

Tip

Defnyddiwch yAlt allweddol yn hytrach na'r Shiftallwedd i greu cysylltiadau orthogonol.

I gromlin neu sythucysylltiad

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Gosodwch y pwyntydd y llygoden dros gysylltiad.

3. Dde-gliciotefe cysylltiad ac yn y cyd-destun ddewislen sy'n ymddangos dewiswch Cromlin, Orthogonol neu Straight.

Tip

Pob cysylltiado Gall fath a roddir ar y diagram cael eu gosod i crwm, orthogonol neu Straight drwy dde-glicio ar y llinell cysylltiedig ar gyfer y math ar y Tab Connectionsy Ffenestr Stensila dewis Cromlin, orthogonol neu Straight.

I angori ymlaen i bwynt penodol ar ymyl siâp

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dewiswch cysylltiad.

3. Gosodwch y pwyntydd llygoden dros y 'dot gwyn' ar ddiwedd y cysylltiad.

4. Dde-gliciotdiwedd cysylltiad ef ac yn y cyd-destun ddewislen sy'n ymddangos dewiswch Endpoint angori yn Siâp.Symudwch y pen cysylltiad i'r lleoliad awydd ar ymyl y siâp.

NEU

Daliwch y Ctrli lawr allweddol a clyfu-a-llusgoy diwedd cysylltiad pwynt i lleoliad awydd ar ymyl y siâp.

Nodyn

Bydd Cysylltiadau snap at y rhyngdoriad gwirioneddol eu siâp gysylltiedig yn hytrach na'r blwch rwymo hwnnw siâp.

Gweler Hefyd

Mae'r Offeryn Arlunio | Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth


Gan dynnu Nodweddion Offeryn

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Gan dynnu Nodweddion Offeryn

Anfon sylwadau ar y pwnc hwn.

Mae'r Offeryn Arlunio yn cefnogi nifer o nodweddion arlunio.

Chwyddo

Gall maint y diagram yn cael ei newid gan ddefnyddio'r swyddogaeth chwyddo.

I ostwng y raddfa neu 'chwyddo i mewn'

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Wasg Ctrla'r '=' allweddol.

- Neu -

2. Dewiswch y Chwyddo Mewnbotwm ar y Diagrambar offer.

- Neu -

2. Wasg Ctrla rholio'r olwyn y llygoden ymlaen. Sylwer: Yn y modd hwn bydd y cynfas yn chwyddo tuag lle mae'r llygoden yn hofran dros y cynfas.

Cynyddu maint neu 'chwyddo allan'

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Wasg Ctrla'r '-' allweddol.

- Neu -

2. Dewiswch y Zoom Outbotwm ar y Diagrambar offer.

- Neu -

2. Wasg Ctrla rholio'r olwyn y llygoden yn ôl. Sylwer: Yn y modd hwn bydd y cynfas chwyddo tuag allan o'r fan lle y llygoden yn hofran dros y cynfas.

Auto-cynllun

Gall cynllun y cydrannau yn y diagram yn cael ei addasu yn awtomatig.

I gosodiad i gyd cydrannau on diagram

1. Clyfu y Layout Diagrambotwm ar y bar offer Diagram.

2. Dewiswchnaill ai Rheiddiol Layout neu Layout Grid.

Nodyn

Bydd y cynllun Radial yn defnyddio hyn a elwir yn algorithm 'dan gyfarwyddyd-rym' fel bod cydrannau cysylltiedig yn cael eu tynnu at ei gilydd tra cydrannau nad ydynt yn gysylltiedig yn cael eu gorfodi ar wahân. Bydd y cynllun Grid yn defnyddio algorithm lled ac uchder bylchau rhwng sefydlog. Mae'n gyntaf yn caniatáu i'r defnyddiwr i ddewis y diagram cyffredinol Agwedd Cymhareb (ee 16: 9, A4 (Portrait), Llythyr (Tirwedd)) ac yna bydd y gofod yn yr ochrau a rhwng y colofnau a rhesi fel y dangosir isod.Gyda gosodiad Grid nad yw unrhyw gysylltiadau rhwng y cydrannau yn effeithio ar y cynllun gan ei fod yn syml yn trefnu y cydrannau yn nhrefn yr wyddor (yn ôl eu henw) o'r brig-chwith i'r gwaelod-dde o'r cynfas. Gyda'r ddau algorithmau Ni siapiau freeform yn cael eu symud.

I gosodiad plant cydrannau yn rhiant sengl on diagram

1. Dde-glicioelfen lefel uchel y mae eu plant yr ydych yn dymuno auto-cynllun.

2. Dewiswch Plant Layout.

Nodyn

Yn ddiofyn dim ond y algorithm cynllun Radial yn cael ei ddefnyddio.

Newid Elfen Estheteg fel Lliw, Tryloywder, Cysgodion a Cylchdro

Mae'r holl elfennau diagram cael estheteg a all gael eu trin fel y dymunir. Yn achos siapiau cysylltiedig, gall yr agweddau hyn yn cael eu gosod fesul mathac yn y rhan fwyaf o achosion hefyd am bob enghraifft. Yn achos siapiau rhydd, gall yr eiddo hyn gael eu gosod am bob enghraifftar y cynfas.

Nodyn

Bydd unrhyw fesul achos yr agweddau sydd wedi eu gosod ar gyfer siapiau cysylltiedig yn cael eu 'trosysgrifo' os yr un agwedd yn cael ei newid ar gyfer y math cyfatebol.

I newid lliw siâp cysylltiedig neu siâp freeform

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu siâp freeform ar y cynfas.

3. Dewiswch Newid lliw.

4. Dewiswch y Lliw Sefydlogbotwm radio (os yn berthnasol).

5. Dewiswch Lliw Sylfaenol neu Diffinio Lliw Custom yn yr ymgom a chliciwch iawn.

- Neu -

4. Dewiswch y Graddiantbotwm radio (os yn berthnasol).

5. Dewiswch naill ai llorweddol, fertigol, Forward Lletraws neu YnÔl Lletraws gyfer y cyfeiriad graddiant yn y pulldown a chliciwch iawn.

6. Dewiswch Lliw Sylfaenol neu Diffinio Lliw Custom yn yr ymgom ar gyfer Dechrauac Diwedda chliciwch iawn.

Nodyn

Bydd ABACUS lliw y blaendir o siâp os;
a) os yw'n siâp 'syml' gydag elfen graffigol sylfaenol sengl (ee cylch, petryal, polygon ac ati), neu
b) os yw'n siâp 'gymhleth' gyda subshapes gwaelodol lluosog sydd i gyd yn yr un fath lliw / graddiant â'i gilydd neu'r subshapes cael LockScale = set GWIR.
Os na fydd yr amodau uchod yn cael eu bodloni, yna cefndir y siâp wedi ei lliwio'n.

Gosod y lliw o siâp cysylltiedig yn unol â'r eiddo

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil(NID ar y cynfas lluniadu).

3. Dewiswch Newid lliw.

4. Dewiswch y Defnyddio Eiddobotwm radio.

5. Dewiswch eiddo drwy glicio ar y botwm '...' ar y dde o'r blwch testun.

6. Dewiswch y Ystod botwm radio.

7. Addaswch y Minac Maxgwerthoedd fel y dymunir. Sylwer: Bydd unrhyw werth yn is na'r gwerth lleiaf yn cael ei ddangos fel y lliw Min, a bydd unrhyw werth uwchben yr uchafswm yn cael ei ddangos fel y lliw Max. Hefyd, wrth ddefnyddio Boole, Rhestr neu Dyddiad / Amser eiddo gwerthoedd yn cael eu trosi at fynegai, fel a ganlyn; Boolean (Ffug = 0, Gwir = 1), Rhestr (yn vale cyfanrif o 1 i n ar gyfer pob gwerth dilys yn eu trefn esgynnol benodi yn y maes Unedau) a Dyddiad Amser (nifer y diwrnodau ers 1 Ionawr, 1900 / - gan gynnwys degolion am oriau, munudau, eiliad dogn - ac os yw'r dyddiad yn cyn-1990 ei fod yn rhif negyddol).

8. Dewiswch Lliw Sylfaenol neu Diffinio Lliw Custom yn yr ymgom ar gyfer Minac Maxa chliciwch iawn.

Tip

Os Gwyrdd (RGB - 128,255,0) yn cael ei ddewis fel y lliw Min ac Coch (RGB - 255,0,0) yn cael ei ddewis fel y lliw Max ar gyfer eiddo â gwerth ystod o 1i 4Yna, mae gwerth 1Bydd yn cael ei arddangos fel Gwyrdd, Mae gwerth o 2fel Melyn, 3fel Orangeac 4fel Coch.

Fel arall, ar gyfer ystod o eiddo 1i 3gwerth o 1Bydd yr un mor Gwyrdd, Mae gwerth o 2fel Amberac 3fel Cochaka 'Goleuadau Traffig' neu statws RAG.

Am ystod eiddo o 1 i 5 os Blue (RGB - 0,0,255) yn cael ei ddewis fel y lliw Min ac Coch (RGB - 255,0,0) yn cael ei dewis fel y Max lliwio bydd gwerth o 1 fod mor Blue, Mae gwerth o 2 fel Aqua, Mae gwerth o 3 fel Gwyrdd, Mae gwerth o 4 fel Melyn a gwerth o 5 fel Coch.

Am ystod eiddo o 1 i 6 os Violet (RGB - 255,0,255) yn cael ei ddewis fel y lliw Min ac Coch (RGB - 255,0,0) yn cael ei dewis fel y Max lliwio bydd gwerth o 1 fod mor Violet, Mae gwerth o 2 fel Blue, Mae gwerth o 3 fel Aqua, Mae gwerth o 4 fel Gwyrdd, Mae gwerth o 5 fel Melyn a gwerth o 6 fel Coch.

Ac yn olaf, ar gyfer ystod eiddo o 1 i 7, bydd gwerth o 1 fod mor Violet, Mae gwerth o 2 fel Dark Blue, Mae gwerth o 3 fel Glas golau, Mae gwerth o 4 fel Glas Gwyrdd, Mae gwerth o 5 fel Gwyrdd, Mae gwerth o 6 fel Amber a gwerth o 7 fel Coch

Nodyn

Gweler y nodyn uchod ar blaendir yn erbyn lliwio cefndir.

- Neu -

7. Dewiswch y Gwerth Penodolbotwm radio.

8. Cliciwch y Golygu Lliwiaubotwm.

9. Dewiswch pob gwerth yn eu tro a chliciwch Gosod Lliwi osod lliw penodol ar gyfer pob gwerth.

Nodyn

Bydd yr ystod o werthoedd ar gyfer yr elfennau sy'n bresennol ar y diagram ymlaen llaw poblogaeth.

10. I ychwanegu unrhyw liwiau werth ychwanegol at y rhai cyn-poblog (er enghraifft ar ôl yr ystod eiddo wedi cael ei had-drefnu) cliciwch Ychwanegu Gwerth.

I newid tryloywder lliw siâp cysylltiedig neu siâp freeform

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu siâp freeform ar y cynfas.

3. Dewiswch Newid lliw.

4. Yn y panel Tryloywder yn gosod y llithrydd uchaf i'r dryloywder a ddymunir ar gyfer y lliw sylfaen.

5. Os bydd y Graddiant neu ddefnyddio opsiynau eiddo yn cael eu defnyddio, yn y panel Tryloywder yn gosod y llithrydd gwaelod i dryloywder a ddymunir ar gyfer yr ail lliw.

6. Cliciwch iawn.

I ddangos cysgodionar gyfer pob un o'r cysylltiedig siapiau mewn diagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannautab y ffenestr stensil.

3. Dewiswch Ychwanegu Cysgodion.

I dangos cysgod ar siâp cydran neu siâp freeform

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dde-clickar siâp gydran neu freeform ar y cynfas.

3. Dewiswch Ychwanegu Cysgodion.

I gylchdroi siapiau gydran a siapiau ffurf rhad ac am ddim mewn diagramau

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dewiswch y siâp gydran neu siâp freeform ar y cynfas yr ydych am i gylchdroi.

3. Dde-glicioar siâp a dethol Cylchdroiac yna dewiswch yr ongl perthnasol yr ydych am i gylchdroi'r siâp gan.

Newid Anodiadau Elfen a Labeli Testun freeform

Mae'r holl elfennau diagram cael anodiadau a all gael eu trin fel y dymunir. Yn achos siapiau cysylltiedig, gall yr agweddau hyn yn cael eu gosod fesul mathac yn y rhan fwyaf o achosion hefyd am bob enghraifft. Yn achos siapiau freeforma cysylltwyr, Mae'rlabeli testun gellir eu gosod am bob enghraifftar y cynfas.Wyth (8) Caiff gwahanol fathau o anodiadau yn cael eu harddangos ar gyfer elfennau diagram (hy Enw, Math, Gwerth Eiddo, Eiddo Marciwr, Cydrannau Ynghlwm, Plant (ar gyfer cydrannau yn unig), Safonau a timestamps (Crëwyd, Modified Gan etc)) mewn ar hugain pump (25) gwahanol safleoedd (ee Canolfan - Top Y tu allan, gadawodd Y tu mewn - Canolfan, Hawl Y tu allan - Gwaelod Y tu allan).

Nodyn

Bydd unrhyw fesul achos yr agweddau sydd wedi eu gosod ar gyfer siapiau cysylltiedig yn cael eu 'trosysgrifo' os yr un agwedd yn cael ei newid ar gyfer y math cyfatebol.Ar ben hynny, lle mae 2 neu fwy o anodiadau byw yn yr un sefyllfa dim ond Ffont sengl, arddull ffont, lliw ffont a Maint yn cael ei ddefnyddio ac yn Gwahanydd (ee coma, gofod, llinell newydd) gael eu dethol.

I ddangos yr enw neu'r math ar gyfer cydran neu gysylltiad cysylltiedig

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu cysylltydd ar y cynfas.

3. Dewiswch Anodiadau.

Nodyn

Ar gyfer siâp unigolyn cysylltiedig neu cysylltydd ar y cynfas bydd angen i chi ddewis y Diystyru anodiadau Stensilblwch britho y tro cyntaf.

4. Dewiswch New Anodi yn y bar offer a dewis Enw neu Math.

5. Yn y deialog sy'n ymddangos dewiswch yr opsiynau Arddangos sy'n cael eu ddymunir gan gynnwys cromfachau a'r arddull Font, Font, lliw ffont a maint. Hefyd, dewiswch yr opsiynau gosodiad sy'n cael eu ddymunir gan gynnwys aliniad llorweddol a fertigol (hy sefyllfa anodi) a'r Angle (hy cylchdro). Dewiswch iawn.

I ddangos eiddo gwerth ar gyfer cydran neu gysylltiad cysylltiedig

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu cysylltydd ar y cynfas.

3. Dewiswch Anodiadau.

Nodyn

Ar gyfer siâp unigolyn cysylltiedig neu cysylltydd ar y cynfas bydd angen i chi ddewis y Diystyru anodiadau Stensilblwch britho y tro cyntaf.

4. Dewiswch New Anodi yn y bar offer a dewis Gwerth Eiddo.

5. Yn y deialog sy'n ymddangos dewiswch yr eiddo drwy glicio Eiddo: '...' botwm a dewis eiddo yn yr ymgom Dewis A Eiddoa dewis iawn. Dewiswch y dewisiadau Arddangos sy'n cael eu ddymunir gan gynnwys cromfachau a'r arddull Font, Font, lliw ffont a maint. Hefyd, dewiswch yr opsiynau gosodiad sy'n cael eu ddymunir gan gynnwys aliniad llorweddol a fertigol (hy sefyllfa anodi) a'r Angle (hy cylchdro). Dewiswch iawn.

I ddangos eiddo marciwr ar gyfer cydran neu gysylltiad cysylltiedig

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu cysylltydd ar y cynfas.

3. Dewiswch Anodiadau.

Nodyn

Ar gyfer siâp unigolyn cysylltiedig neu cysylltydd ar y cynfas bydd angen i chi ddewis y Diystyru anodiadau Stensilblwch britho y tro cyntaf.

4. Dewiswch New Anodi yn y bar offer a dewis Eiddo Marker.

5. Yn y deialog sy'n ymddangos dewiswch yr eiddo drwy glicio Eiddo: '...' botwm a dewis eiddo yn yr ymgom Dewis A Eiddoa dewis iawn. Gosod radiws y marciwr mewn picseli a'r dull lliwio naill ai Lliw Erbyn Range neu Lliw Erbyn Eiddo a gosod aseiniadau lliwiau. Hefyd, dewiswch yr opsiynau gosodiad sy'n cael eu ddymunir gan gynnwys aliniad llorweddol a fertigol (hy sefyllfa anodi) a'r Angle (hy cylchdro). Dewiswch iawn.

I ddangos cydrannau sydd ynghlwm ar gyfer cydran neu gysylltiad cysylltiedig

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu cysylltydd ar y cynfas.

3. Dewiswch Anodiadau.

Nodyn

Ar gyfer siâp unigolyn cysylltiedig neu cysylltydd ar y cynfas bydd angen i chi ddewis y Diystyru anodiadau Stensilblwch britho y tro cyntaf.

4. Dewiswch New Anodi yn y bar offer a dewis Cydrannau Ynghlwm.

5. Yn y deialog sy'n ymddangos, ar gyfer cydrannau cysylltiedig ddewis y math gydran sydd ynghlwm trwy glicio ar y Atodir: botwm '...' a dewis math cydran yn y Set Cydran Math o ymgoma dewis iawn. Dewiswch y math o gysylltiad sydd ynghlwm drwy glicio ar y Via Connected: '...' botwm a dewis math o gysylltiad yn y Set Math Cysylltiad ymgoma dewis iawn.Ar gyfer cysylltiadau cysylltiedig dewiswch y pen cysylltiad trwy ddewis Ffynhonnell neu Sinc o'r Diwedd Cysylltiad: tynnu-lawr ddewislen. Ar gyfer y ddau cydrannau a chysylltiadau cysylltiedig dewis yr opsiynau Arddangos sy'n cael eu ddymunir gan gynnwys cromfachau a'r arddull Font, Font, lliw ffont a maint. Hefyd, dewiswch yr opsiynau gosodiad sy'n cael eu ddymunir gan gynnwys aliniad llorweddol a fertigol (hy sefyllfa anodi) a'r Angle (hy cylchdro). Dewiswch iawn.

I ddangos y plant ar gyfer elfen cysylltiedig

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannautab y ffenestr stensil neu siâp cysylltiedig ar y cynfas.

3. Dewiswch Anodiadau.

Nodyn

Ar gyfer siâp cysylltiedig unigol ar y cynfas bydd angen i chi ddewis y Diystyru anodiadau Stensilblwch britho y tro cyntaf.

4. Dewiswch New Anodi yn y bar offer a dewis Plant.

5. Yn y deialog sy'n ymddangos dewiswch yr opsiynau Arddangos sy'n cael eu ddymunir gan gynnwys cromfachau a'r arddull Font, Font, lliw ffont a maint. Hefyd, dewiswch yr opsiynau gosodiad sy'n cael eu ddymunir gan gynnwys aliniad llorweddol a fertigol (hy sefyllfa anodi) a'r Angle (hy cylchdro). Dewiswch iawn.

I ddangos safonau ar gyfer cydran neu gysylltiad cysylltiedig

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu cysylltydd ar y cynfas.

3. Dewiswch Anodiadau.

Nodyn

Ar gyfer siâp unigolyn cysylltiedig neu cysylltydd ar y cynfas bydd angen i chi ddewis y Diystyru anodiadau Stensilblwch britho y tro cyntaf.

4. Dewiswch New Anodi yn y bar offer a dewis Safonau.

5. Yn y deialog sy'n ymddangos dewiswch yr opsiynau Arddangos sy'n cael eu ddymunir gan gynnwys cromfachau a'r arddull Font, Font, lliw ffont a maint. Hefyd, dewiswch yr opsiynau gosodiad sy'n cael eu ddymunir gan gynnwys aliniad llorweddol a fertigol (hy sefyllfa anodi) a'r Angle (hy cylchdro). Dewiswch iawn.

I ddangos y timestamps ar gyfer cydran neu gysylltiad cysylltiedig

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dde-glicioar siâp neu cysylltydd cysylltiedig yn y Cydrannauneu Cysylltiadautab y ffenestr stensil neu siâp cysylltiedig neu cysylltydd ar y cynfas.

3. Dewiswch Anodiadau.

Nodyn

Ar gyfer siâp unigolyn cysylltiedig neu cysylltydd ar y cynfas bydd angen i chi ddewis y Diystyru anodiadau Stensilblwch britho y tro cyntaf.

4. Dewiswch New Anodi yn y bar offer a dewis Crëwyd, a grëwyd gan, Marker Created, Modified, Modified By neu Addasedig Marker.

5. Yn y deialog sy'n ymddangos, os nad marciwr, dewiswch y dewisiadau Arddangos sy'n cael eu ddymunir gan gynnwys cromfachau a'r arddull Font, Font, lliw ffont a maint. Os marciwr, yn gosod y radiws y marciwr mewn picseli a'r dull lliwio naill ai Lliw Erbyn Range neu Lliw Erbyn Eiddo a gosod aseiniadau lliwiau. Hefyd, dewiswch yr opsiynau gosodiad sy'n cael eu ddymunir gan gynnwys aliniad llorweddol a fertigol (hy sefyllfa anodi) a'r Angle (hy cylchdro). Dewiswch iawn.

I newid arddull y ffont o siâp freeformneu cysylltydd

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dde-glicioar siâp freeform neu cysylltydd ar y cynfas. Noder: Os yw'r cysylltydd Nid yw label testun yn dangos yna i ddangos y cysylltuneu label testun: Dde-glicioyr cysylltuneua dewis Anodi | Dangos Anodi.

3. Dewiswch Newid Wynebfath.

4. Dewiswch arddull Font, ffont a maint yn yr ymgom a dewis iawn.

Er mwyn newid y ffont lliw o siâp freeformneu cysylltydd

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dde-glicioar siâp freeform neu cysylltydd ar y cynfas. Noder: Os yw'r cysylltydd Nid yw label testun yn dangos yna i ddangos y cysylltuneu label testun: Dde-glicioyr cysylltuneua dewis Anodi | Dangos Anodi.

3. Dewiswch Newid Ffont Lliw.

4. Dewiswch FontLliw (ac ar gyfer siapiau y Lliw Link) drwy glicio ar y botwm '...' a dewis lliw yn yr ymgom a dethol iawn.

5. Dewiswch y Tryloywder y label testun drwy addasu y llithrydd gyda 0 yn gwbl dryloyw a 255 yn gwbl di-draidd.

I cylchdroi y label testun siâp freeformneu cysylltydd

1. Sicrhewch fod gennych newydd neu bresennol diagram agored .

2. Dde-glicioar siâp freeform neu cysylltydd ar y cynfas. Noder: Os yw'r cysylltydd Nid yw label testun yn dangos yna i ddangos y cysylltuneu label testun: Dde-glicioyr cysylltuneua dewis Anodi | Dangos Anodi.

3. Dewiswch Cylchdroiac yna dewiswch yr ongl perthnasol yr ydych am i gylchdroi'r label testun gan.

Gweler Hefyd

Mae'r Offeryn Arlunio | Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth


Gan ddefnyddio cysylltiadau mewn Diagramau

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Gan ddefnyddio cysylltiadau mewn Diagramau

Anfon sylwadau ar y pwnc hwn.

Siapiau (ffurflen a chydrannau am ddim) a Connectors (ffurflen neu gysylltiadau am ddim) o fewn diagramau gellir ei gysylltu â'ch sylwadau pensaernïol presennol yng ABACUS, yn ogystal â ffeiliau / ffolderi a URLs allanol. Yna gellir cysylltiadau hyn yn cael ei reoli (creu, eu haddasu a'u dileu) drwy gyfrwng y toolset ABACUS. Gall hyn nodwedd yn cael ei ddefnyddio i wella'r llywio a dealltwriaeth cyffredinol eich pensaernïaeth diagram.

I ychwanegu dolenni at eich diagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dewiswch y siâp perthnasol neu cysylltydd gan eich diagram.

3. Dde-glicioar siâpneu cysylltydd.

4. Dewiswch Cysylltiadau Agoredac mae Cysylltiadauffenestr yn ymddangos.

5. Cliciwch ar y Ychwaneguicon a Cyswllt Newyddffenestr yn ymddangos.

6. Dewiswch y perthnasol Catalog | Matrics | Diagram| 3D View| Siartbotymau radio, yna dewiswch y perthnasol catalog, matrics, diagram, 3Dneu siart barn yn y bensaernïaeth cyfredol gan y Cyswllt Icwymplen.

- Neu -

6. Dewiswch y Gwefanbotwm radio wedyn, fynd i mewn i'r URL perthnasol (Ee http: //www.avolutionmeddalweddcom /)yn y maes i gysylltu i dudalen we. Mae angen i URLs dilys i ddechrau gydag un o'r 5llinynnau; http: //, https: //, ftp: //,file:neu \\. Dylai unrhyw leoedd yn cael eu cofnodi gyda '% 20'.

- Neu -

6. Dewiswch y Ffeil Absolute | Ffeil Perthynasbotwm radios,Yna, cliciwch ar y '...'Botwm i bori am ffeil allanol i gysylltu â eich diagram.

7. Cliciwch iawna bydd y cyswllt newydd yn cael eu dangos yn y Cysylltiadau ffenestr. Sylwer: Gall y cysylltiadau ffenestr cael ei newid er mwyn gweld yr enw llawn os oes angen.

8. Camau Ailadrodd 5-7i greu mwy o gysylltiadau.

9. I ddilyn y ddolen greu, dewiswch y ddolen berthnasol harddangos yn y Cysylltiadauffenestri a chlecia Link Agored.

Nodyn

Pryd anodiadau lluosog yn cael eu dangos am siâp neu cysylltydd y ddolen i'w weld ar y anodiadau gyntaf yn y rhestr o anodiadau yn yr ymgom Golygu anodiadau.

I ddilyn dolenni oddi wrth eich diagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dewiswch y siâp perthnasol neu cysylltydd gan eich diagram.

3. Cliciwchar yr hypergyswllt perthnasol (glas tanlinellu enw gydran) ar siâp neu cysylltydd yn y diagram i agor a gweld y cyswllt cyntaf gan y siâpneu cysylltydd.Sylwer: Dylai'r cyrchwr yn newid i 'llaw' pan fydd y cysylltiad yn barod i gael ei glicio.

- Neu -

3. Dewiswch y siâp perthnasol neu cysylltydd oddi wrth eich diagram.

4. Dde-glicioar siâpneu cysylltydd.

5. Dewiswch Cysylltiadau Agoredac mae'r Cysylltiadauffenestr yn ymddangos.

6. Dewiswch y ddolen berthnasol y byddech yn hoffi ei weld.

7. Cliciwch ar y Link Agoredbotwm i agor a gweld y ddolen berthnasol.

I ddileu dolenni yn eich diagram

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dewiswch y siâp perthnasolneu cysylltyddoddi wrth eich diagram.

3. Dde-glicioar siâpneu cysylltydd.

4. Dewiswch Cysylltiadau Agoredac mae'r Cysylltiadauffenestr yn ymddangos.

5. Dewiswch y ddolen berthnasol y mae angen ei ddileu.

6. Cliciwch ar y Dileubotwm. a'r cyswllt yn cael ei dynnu oddi ar y Cysylltiadau ffenestr.

Cysylltiadau Trefnu yn eich diagram

Gallwch chi ddewis pa cysylltu diagram, ffeiliau allanol, neu ar y we URL yn cael ei arddangos pan fydd label siâp yn Ctrl + glicio yn y diagram.

1. Sicrhewch fod gennych sy'n bodoli eisoes diagram agored .

2. Dewiswch y siâp perthnasol neu cysylltydd oddi wrth eich diagram.

3. Dde-glicioar siâpneu cysylltydd.

4. Dewiswch Cysylltiadau Agoredac mae'r Cysylltiadauffenestr yn ymddangos.

5. I addasu'r drefn y dolenni cliciwch ar y Symud Up | Symud i Lawrbotymau ar yr ochr dde y Cysylltiadauffenestr.

6. Mae'r cyswllt cyntaf sy'n ymddangos ar ochr chwith y Cysylltiadauffenestr yw'r cyswllt sy'n dangos pan fyddwch yn Ctrl + Clicsiâp hypergysylltu neu cysylltydd enw.

Gweler Hefyd

Poblogi eich pensaernïaeth | Poblogi eich pensaernïaeth llaw | Dadansoddi eich pensaernïaeth


Safbwyntiau Diagram

Navigation: poblogi eich pensaernïaeth> Defnyddio Darluniau>

Safbwyntiau Diagram

Anfon sylwadau ar y pwnc hwn.

The safbwyntiaunodwedd yn sicrhau bod yn rhaid i gydrannau a chysylltiadau sy'n cael eu hychwanegu at diagram ganddynt gysylltiad fath ddiffiniwyd yn flaenorol cyn y gellir eu hychwanegu at diagram. Mae'r nodwedd hon yn caniatáu ar gyfer cyfyngu ar y mathau o diagramau y gellir eu tynnu drwy gyfyngu'r siapiau a cysylltwyr sy'n gysylltiedig â Cydrannau a Cysylltiadausydd eisoes yn bodoli o fewn eich pensaernïaeth.

Galluogi neu analluogi ddiagram Gorfodi safbwyntiau

Y gallu i orfodi safbwyntiau diagram ei alluogi yn awtomatig yn ddiofyn. I analluogi / galluogi nodwedd hon, clicia ar Tools | Dewisiadau ...| y Diagramtab, a dad-ddewis / dewis y Gorfodi Diagram Gwylfannaugwiriwch y blwch yn unol â hynny.

Nodyn

Os nad ydych yn gweld y 'Gorfodi Diagram Gwylfannau', Yna nid oes rhaid i chi ddewis ar y tab Diagram y Dylunydd ychwanegu-ar ac mae'r opsiwn hwn yn ymlaen yn ddiofyn.

Creu diagram gorfodadwy safbwynt

1. Sicrhewch bod gennych File ABACUS agored gyda'r fforiwrfarn ei arddangos.

2. Ym marn fforiwr dde chlecia ar Viewpwyntsa chliciwch ar Creu Safbwynt Diagram

3. Y Safbwynt DiagramBydd ffenestr yn cael ei arddangos.

4. Neilltuo enw sy'n berthnasol i'r safbwynt diagramac yn nodi bod y safbwynt yn cael ei arbed o dan y Gwylfannaurhan o'r fforiwr.

5. Y Safbwynt DiagramBydd ffenestr yn cael ei arddangos.

6. Nawr cliciwch a llusgo y mathau gydran perthnasol a mathau cysylltiad yn eich saernïaeth ar y siapiau safbwyntydych ei eisiau. Mathau CydranRhaid llusgo ymlaen isiâp yn y siapiautab, tra mathau o gysylltiadRhaid llusgo ar un o'r siapiau arddull 5 llinell yn y cysylltwyrtab.

7. I arbed y safbwynt diagramydych wedi creu cliciwch ar y [image] ar y gornel dde ar frig eich Safbwynt Diagramffenestr.

Nodyn

Y safbwynt diagramEfallai ei olygu drwy dde-glicio ar y safbwynt a dewis Agoredneu dwbl-glicioy safbwynt.

Synchonising safbwynt diweddaru gyda diagramau

1. Sicrhewch bod gennych File ABACUS agored.

2. Naill ai de-gliciwch y safbwynt yn y Explorer ffenestr o dan Meta-model | Gwylfannaua dewis Sync Diagram Mapiadau ...

- Neu -

3. Cau safbwynt agored a diweddaru ffenestr a dewiswch Ydy yn y Cysoni i Viewpointdeialog sy'n cael ei arddangos.

4. Y Cydamseru ViewpointBydd deialog yn cael eu harddangos fel y dangosir isod.

Blychau ticio

· Ychwanegu mapiadau Coll- Unrhyw siâp newydd (i'r math cydran) neu cysylltydd (i math o gysylltiad) cymdeithasau sydd wedi cael eu hychwanegu i'r olygfanBydd yn cael ei ychwanegu at y diagram cyfatebols (h.y. eustensils)bod yn gysylltiedig â'r safbwynt.

· Diweddariad PresennolMapiadau- Unrhyw agweddau Diweddarwyd y siâp presennol (i math cydran) neu cysylltydd (i math o gysylltiad) cymdeithasau ar gyfer olygfan(Ee lliw, arddulliau ffont) yn cael ei ddiweddaru yn y diagram cyfatebols (h.y. eustensils)bod yn gysylltiedig â'r safbwynt.

· Tynnu ExtraMapiadau- Unrhyw siâp ychwanegol (i'r math cydran) neu cysylltydd (i math o gysylltiad) cymdeithasau sydd wedi cael eu hychwanegu i'r ddiagramau (hy eu stensiliau) ond nid ydynt yn y safbwyntyn cael eu tynnu oddi ar y diagram cyfatebols (h.y. eustensils)bod yn gysylltiedig â'r safbwynt.

· Ysgrifennu dros Gosodiadau Lleol ar gyfer Ychwanegol neu Mapiadau Diweddarwyd (Gwahaniaethau yn unig)- Unrhyw agweddau Diweddarwyd y siâp presennol (i math cydran) neu cysylltydd (i math o gysylltiad) cymdeithasau ar gyfer olygfan(Ee lliw, arddulliau ffont) yn cael ei gymhwyso i'r elfennau cyfatebol ar y diagramau sydd wedi'u cysylltu â'r safbwynt.Dim ond y 'gwahaniaethau' gwneud i'r safbwynt diweddaru eu cymhwyso felly bydd unrhyw leoliadau lleol presennol yn y diagram na chawsant eu diweddaru yn y safbwynt yn aros yn ddigyfnewid.

· [image] Anodiadau – Fel yr uchod ond yn benodol ar gyfer y anodiadau.

Gweler Hefyd

Mae'r Offeryn Arlunio | Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth


Poblogi gan ddefnyddio Catalogau

Navigation: poblogi eich pensaernïaeth>

Poblogi gan ddefnyddio Catalogau

Anfon sylwadau ar y pwnc hwn.

A Catalog caniatáu i chi weld a golygu cydrannau neu gysylltiadau a'u priodweddau mewn ffordd tabl syml.

I creu Catalog newydd gweld mewn ABACUS

Nodyn

Er y gall yr holl ddefnyddwyr Pensaer creu Catalogau newydd, i arbed y newidiadau i leoliadau yn Catalog presennol y mae angen i'r Dylunydd gallu ychwanegu-ar drwydded defnyddiwr. Mae hyn er mwyn 'amddiffyn' cyfluniad Catalogau presennol y gellir eu rhannu gan nifer o ddefnyddwyr. Fodd bynnag, Pensaer defnyddio heb y Dylunydd ychwanegu-ar yn dal i ddewis 'Save As' i unrhyw leoliadau newydd i Catalog newydd. Ac wrth gwrs, gall pob trwydded defnyddiwr yn dewis 'Taflu' unrhyw newidiadau i Catalog sydd eisoes yn bodoli. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os ydych angen y Dylunydd ychwanegu-ar gallu. A chofiwch, mae hyn yn unig y gosodiadau y Catalog, pob golygiadau a wnaed i'r data yn y Catalog cael eu cymhwyso yn syth i'r gadwrfa, beth bynnag.

1. Dewiswch Mewnosod | Catalog.

2. Yn y tynnu-lawr dewiswch y Pensaernïaeth sy'n cynnwys y cydrannau neucysylltiadau hoffech weld.

3. Yn y tynnu-lawr dewiswch y gydran neu fath gysylltiad eich bod yn dymuno fod wedi yr enghreifftiau rhestru fel 'rhesi' yn y catalog.

4. Y Catalog Bydd yn cael ei phoblogaeth gydarhes ar gyfer pob achos o gydran neu gysylltiad math a ddewiswyd.

Nodyn

Yn ddiofyn y chwith-fwyaf Llwybr Hierarchaethcolofn (hy hierarchaeth o elfennau rhiant neu gysylltiadau uwchben yr achosion a ddewiswyd) a'r 2il Enw colofn (hy y rhestr o'r gydran neu gysylltiad achosion a ddewiswyd) yn cael eu rhewi i'r chwith o'r catalog. I newid y golofn rhewi llusgwch y gwahanydd golofn ar y dde o'r golofn Enw. Gallwch ail-archebucolofnau yn syml drwy lusgo a gollwng eu penawdau colofn. Mae celloedd o golofnau gyda tanlinellu glas yn hypergysylltiadau i elfennau eraill yn y prosiect a'r hypergysylltiadau gellir eu dilyn trwy ddal i lawr Ctrl a chlicio ar y dolenni. Gall Colofnau fod cudd drwy dde-glicio ar y pennawd colofn a dewis Colofn | Cuddio Colofn. Gall colofnau cudd yn cael ei unhidden drwy glicio ar y botwm Colofnau bar offer Ffurfweddu a defnyddio'r Colofnau Ffurfweddu dadl fel y dangosir isod, neu drwy ddewis y saeth i lawr rhan o'r botwm Colofnau bar offer Configure ac yn unigol ddewis y colofn (au) cuddio naill ai o'r Teulu, Eiddo neu gasgliadau Ymlyniadau. Gall fod yn Rhesi grwpio gan eu gwerthoedd colofn drwy lusgo'r pennawd colofn i mewn i'r bar grwpio glas ar frig y catalog. Ar unrhyw adeg, gallwch glicio ddwywaith ar y detholydd rhes catalogac neidio i'ry gydran cyfatebolneu gysylltiadyn y ffenestr Explorer.Gwerthoedd cell eiddo yn bolded lle maent yn wahanol i'r rhagosodiadau, ac italicized lle maent yn cael eu darllen yn unig. Efallai y stamp amser, Eiddo a Ynghlwm colofnau Cydran fod lliw yn ôl y gwerthoedd gell neu werth yr eiddo gydran atodedig drwy dde-glicio ar y pennawd colofn a dewis Colofn | Newid lliw ... ac yna y lliwiau gan stamp amser neu opsiwn Lliw Erbyn Eiddo, fodd bynnag, dim ond Rhestr, Cyfanrif, Degol, Boolean neu Dyddiad / Amser Bydd eiddo math data lliwio. Gall gwerth eiddo ar gyfer colofnau Cydran Ynghlwm fod dangos drwy dde-glicio ar y pennawd colofn a dewis Colofn | Dangos Eiddo ... ac yna opsiwn Sioe Eiddo. Ac yn olaf, lle mae Cyfyngiadau sy'n ofynnol a osodwyd ar gyfer colofn eiddo gall y rhain gael eu dangos gyda llinyn (ynghyd â lliwio yn ôl eu lefelau gorfodi) drwy dde-glicio ar y pennawd colofn a dewis Colofn | Dangoswch .

Catalog

I ychwanegu / sioe colofnau i a Catalog golwg yn ABACUS

1. Sicrhewch fod gennych Golygfa Catalog agored.

2. Gall colofnau cudd yn cael ei unhidden yn unigol drwy glicio ar y saeth ar y dde o'r botwm bar offer Colofnau Ffurfweddua dewis y golofn cuddio oddi wrth naill ai'r Cyffredinol, Priodweddau neu Ymlyniadau casgliadau.

Nodyn

Bydd marc tic yn cael ei ddangos ymyl y colofnau a ddangosir ar hyn o bryd ar gyfer y catalog.Yn ogystal, bydd dim ond rhai atodiadau ar gael o dan yr Atodiadau adran yn ôl y cyfyngiadau sy'n cael eu diffinio yn eich prosiect. Yn arbennig, ar gyfer atodiad i fod ar gael i'w ddangos mewn catalog gydran rhaid i'r math cydran ar gyfer y catalog yn cael ei nodi fel naill ai mae'r ffynhonnell neu sinc (NID y blwch 'Unrhyw') gyfyngiad o "cysylltiad gael ei atodi" ar gyfer cysylltiad math, ac mae rhaid hefyd fod yn o leiaf un math gydran bennu fel naill ai'r ffynhonnell neu sinc (NID y blwch 'Unrhyw') y llall 'pen' o'r un math o gysylltiad.

- OR -

2. Gall colofnau lluosog gael eu unhidden (neu archebu neu sefydlog) drwy glicio ar y Ffurfweddu botwm bar offer Colofnaua defnyddio'r Colofnau Ffurfweddu Deialog a ddangosir isod.

Nodyn

Mae'r colofnau harddangos ar hyn o bryd yn cael eu dangos yn y panel ar y dde gyda'r colofnau sydd ar gael a ddangosir yn y panel ar y chwith. Efallai y bydd y colofnau sydd ar gael yn cael ei hidlo yn ôl y Dewiswch Colofnau Gael Otynnu-lawr ac efallai y byddant yn cael eu hychwanegu trwy eu dewis yn y panel ar y chwith a chlicio ar y Ychwanegu botwm inbetween y ddau banel.

Ffurfweddu Colofnau ymgom

I tynnu / cuddio colofnau o Catalog golwg yn ABACUS

1. Sicrhewch fod gennych Golygfa Catalog agored.

2. Cliciwch y botwm dde y pennawd colofn ar gyfer y golofn yr ydych am ei ddileu / cuddio a dewis Colofn | Cuddio Colofn.

- OR -

2. Gall colofnau Lluosog eu cuddio (neu archebu neu sefydlog) drwy glicio ar y Ffurfweddu botwm bar offer Colofnaua defnyddio'r Colofnau Ffurfweddu Deialog a ddangosir uchod.

Nodyn

Mae'r colofnau harddangos ar hyn o bryd yn cael eu dangos yn y panel ar y dde gyda'r colofnau sydd ar gael a ddangosir yn y panel ar y chwith. Efallai y bydd y colofnau harddangos ar hyn o bryd yn cael ei guddio gan ddewis y golofn yn y panel ar y dde a chlicio ar y Tynnwch botwm inbetween y ddau banel.

I boblogi gan ddefnyddio Catalog golwg yn ABACUS

1. I ychwanegu cydran neu cysylltiado'r math a ddewiswyd iy catalog (a phrosiect) cliciwch ar y Add Cydran Newydd / Ychwanegu botwm bar offer Cysylltiad Newydd. Dylai'r rhes ymddangos a cydran neu Bydd cysylltiad yn cael ei greu ar y lefel uchaf y Cydrannau neu Casgliad Cysylltiadau gyfer y Pensaernïaeth a ddewiswyd.

Nodyn

Cydrannau a chysylltiadau newydd yn cael eu hychwanegu yn ddiofyn ar y lefel uchaf y Cydrannau neu Connections casglu'r Pensaernïaeth a ddewiswyd. I newid y rhiant y cydrannau neu cysylltiadau newydd de-gliciwch y gell Llwybr Hierarchaeth ar gyfer y gydran neu gysylltiadau rhes newydd a dewis Newid Rhiant ...a dewis y rhiant a ddymunir (gan gymryd sylw o'r amlygu cyfyngiad ).

Nodyn

Rhesi newydd / elfennau hychwanegu yn uniongyrchol i'r catalog drwy'r botwm 'Ychwanegu Newydd', ludo i mewn i'r catalog, neu eu creu trwy fewnforio i mewn i'r catalog o MS Excel wedi eu heithrio o hidlo nes i'r catalog ar gau. Mae hyn er mwyn caniatáu i unrhyw olygu angenrheidiol o werthoedd colofn Ni all ateb y meini prawf hidlo presennol y catalog. Mae'r rhain yn elfen rhesi newydd yn cael eu dynodi gan symbol '+' yn y gell dewisydd rhes ar ddechrau'r y rhes, sy'n cael ei lliw gwyrdd os yw'r elfen ar hyn o bryd yn bodloni'r meini prawf hidlo arbedwyd o'r catalog (hy yn aros ar gatalog os ail-agorwyd), a Coch os nad yw'n gwneud hynny.

2. I dynnu cydran neu cysylltiado'r math a ddewiswyd oy catalog (a phrosiect) dewis y rhes a naill ai wasg Del allweddol neu de-gliciwch y dewisydd rhes a dewis Dileu o Pensaernïaeth. Y rhes Dylai ddiflannu o'r catalog ac mae'n yn cael ei ddileu o'r prosiect.

I hidlo gan ddefnyddio Catalog golwg yn ABACUS

1. Sicrhewch fod gennych Golygfa Catalog agored.

2. Os na fydd y rhes hidlydd yn dangos ar frig y catalog, yna cliciwch ar y Dangos Filter Header Rowbotwm bar offer.

3. Yn y golofn yr hoffech ei ychwanegu hidlo, dwbl-gliciwch y gell rhes hidlo lle mae'n dangos '(Pob un)'.

4. Ar gyfer Stamp amser, Llwybr Hierarchaeth, Enwneu Disgrifiadcolofnau cyffredinol neu Testun, Cyfanrif, Degol, Booleanneu Dyddiad / Amsercolofnau eiddo cliciwch y botwm ... sy'n ymddangos yn y dde o'r gell rhes hidlo ac yn mynd i mewn i'r gell gwerthoedd y dylid eu cynnwys yn y catalog.

Nodyn

Paru yn perfformio fel pe bai '*' wildcards yn cael eu cymhwyso yn awtomatig cyn ac ar ôl unrhyw werthoedd llinyn fel y byddai cofnod o 'cath' (heb y dyfyniadau) yn cynnwys rhesi gyda 'Bobcath','cathferch 'neu' applicathion 'ayyb lluosog /' fod gwerthoedd yn cael eu cofnodi ar linellau newydd gan ddefnyddio neu ' Ctrl + Enter. Ar gyfer Cyfanrif a cholofnau eiddo Degol 'ac' Efallai y rhesymeg yn cael ei gynnwys gan ddefnyddio '&'(Heb y dyfyniadau) a mwy na / llai na etc rhesymeg gellir cynnwys gan ddefnyddio'> =','>','<'A'<='(Heb y dyfyniadau) e.e. '> = 50000 & <90000'. Gall rhesi eu gwerthfawrogi nad ydynt yn wag yn cael eu cynnwys drwy nodi '(Di-Blanks)'(Heb y dyfyniadau) a gall rhesi eu gwerthfawrogi gwag yn cael eu cynnwys drwy nodi'(Blanks)'(Heb y dyfyniadau).Ac yn olaf, yr holl hidlwyr yn erbyn achos ball ansensitif felly byddai 'cath' (heb y dyfyniadau) yn cynnwys rhesi gyda 'cath', 'Cat' neu ati 'CAT' Er paru sensitif achos, rhowch '(Achos)'(Heb y dyfyniadau) cyn i'r llinyn e.e. Byddai '(Achos) Cat' (heb y dyfyniadau) yn unig gynnwys rhesi gyda 'Cat' ynddynt.

5. Ar gyfer Ymlyniadaucolofnau, Safonau colofnau neu Rhestr colofnau eiddo cliciwch y botwm saeth i lawr sy'n ymddangos yn y dde o'r gell rhes hidlo a dewis y gwerthoedd gell o'r blychau ticio y dylid eu cynnwys yn y catalog.

Nodyn

Bydd y '(Dewis Popeth)' checkbox galluogi'r holl blychau arall, i bob pwrpas gan gynnwys yr holl rhesi sydd ar gael. Bydd y '(Heb fod yn Blanks)' checkbox gynnwys unrhyw ddiffyg yn wag rhesi eu gwerthfawrogi. Bydd y '(Blanks)' checkbox gynnwys unrhyw wag gwerthfawr rhesi. Ac yn olaf, ddatddewis unrhyw blychau ticio penodol a gwerthfawr fydd yn awtomatig dad ddewiswch y '(Dewis Popeth)' a '(Non-Blanks)' blychau ticio ar gyfer cysondeb.

6. Cliciwch iawn i gymhwyso'r hidlo.

I analluogi / galluogi hidlo ar a Catalog golwg yn ABACUS

1. Sicrhewch fod gennych Golygfa Catalog agored gyda hidlo cymhwysol.

2. Cliciwch y blwch gwirio ar ochr chwith y rhes hidlo.

I tynnu hidlydd oddi a Catalog golwg yn ABACUS

1. Sicrhewch fod gennych Golygfa Catalog agored gyda hidlo cymhwysol.

2. I gael gwared hidlydd colofn unigol de-gliciwch y pennawd colofn a dewis Colofn | Clear Hidlo.

3. I gael gwared ar yr holl hidlwyr cliciwch y Dewisiadau botwm bar offer a dewiswch Gosodiadau Hidlo clir.

I achub / Cadw fel aGolygfa Catalog

Nodyn

Er y gall yr holl ddefnyddwyr Pensaer creu Catalogau newydd, i arbed y newidiadau i leoliadau yn Catalog presennol y mae angen i'r Dylunydd gallu ychwanegu-ar drwydded defnyddiwr. Mae hyn er mwyn 'amddiffyn' cyfluniad Catalogau presennol y gellir eu rhannu gan nifer o ddefnyddwyr. Fodd bynnag, Pensaer defnyddio heb y Dylunydd ychwanegu-ar yn dal i ddewis 'Save As' i unrhyw leoliadau newydd i Catalog newydd. Ac wrth gwrs, gall pob trwydded defnyddiwr yn dewis 'Taflu' unrhyw newidiadau i Catalog sydd eisoes yn bodoli. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os ydych angen y Dylunydd ychwanegu-ar gallu.A chofiwch, mae hyn yn unig y gosodiadau y Catalog, pob golygiadau a wnaed i'r data yn y Catalog cael eu cymhwyso yn syth i'r gadwrfa, beth bynnag.

1. Sicrhewch fod gennych newydd neu bresennol olygfa Catalog agoredac eich bod wedi gwneud y newidiadau angenrheidiol.

2. Yn y Golygfa Catalogcliciwch ar y bar offer Savebotwm i achub y Golygfa Catalog ac unrhyw newidiadau fformatio.

Nodyn

Os nad oes gennych botwm Save ym marn Catalog toolbar yna nid oes gennych y Dylunydd ychwanegu-ar ac rydych ond yn gallu Save Asunrhyw newidiadau i leoliadau catalog newydd pan fyddwch yn mynd i gau'r catalog presennol.

3. Os y CatalogEnwymgom yn ymddangos (Oherwydd ei bod yn catalog newydd) rhowch enw ar gyfer y Catalog ac yn y wasg iawn.

I allforio i gatalog MS Excel

1. Sicrhewch fod gennych Golygfa Catalog agored.

2. Cliciwch y Allforio i Excel Catalog taenlenbotwm bar offer.

3. Dewiswch enw ffeil i achub y catalog MS Excel fel. Cliciwch Save.

Nodyn

Yn ddiofyn, bydd filename catalog MS Excel allforio fydd yr enw Catalog ddodiad gan yr enw Pensaernïaeth mewn cromfachau, ee 'Prosiectau (2014 Gwirioneddol) .xlsx'. Gallwch newid unrhyw ran o hyn, gan gynnwys a yw'r fformat ffeil yw bod yn .xlsx neu Xls. Yr enw Pensaernïaeth ei gynnwys i atgoffa'r defnyddiwr y mae pob catalog wedi cynnwys penodol (hy IDs yng ngholofn A a rhes 1) i'w alluogi i fod yn grwn-baglu yn ôl wrth ddefnyddio Mewnforio o gatalog MS Excel yn unol isod.

Nodyn

Yn ddiofyn y Colofn A cudd o fewn y catalog MS Excel allforio yn cynnwys y ID unigryw ar gyfer pob un o'r elfennau yn y gadwrfa ABACUS. Mae hyn yn caniatáu unrhyw newidiadau sy'n cael eu gwneud o fewn MS Excel i gael eu 'paru' i'r elfennau sydd eisoes yn bodoli o fewn ABACUS ar fewnforio (gweler isod). Fodd bynnag, gall y defnydd o ID unigryw hwn i rhesi 'yn cyd-fynd i fyny' yn cael ei diystyru gyda | Allanol IDeiddo ar yr elfen. Hynny yw, os yw'r elfen yn cael Allanol | Eiddo ID ac mae'n cael ei gynnwys yn y catalog ar allforio, yna y gwerthoedd y Allanol | Bydd colofn ID cael ei ddefnyddio i gyfateb i fyny 'r rhesi ar fewnforio (gweler isod), a bydd y gwerthoedd ID unigryw yn y golofn cudd A ei anwybyddu (a gall hyd yn oed fod yn wag). Mae'r Colofn cudd A rhaid ei hun yn parhau, fodd bynnag, yn enwedig y gwerth mewn cell A1. Ar ben hynny, wrth ychwanegu ID allanol i gasgliad elfen ABACUS presennol rydym yn argymell eu hychwanegu fel eiddo gwahanol yn gyntaf, ee | Allanol Temp ac yna ailenwi'r yr eiddo i Allanol | ID. Fel arall, bydd elfennau dyblyg yn cael eu hychwanegu.

Fformatio Catalogei allforio at ball, fodd bynnag, ar gyfer catalogau mawr hwn arwain yn y allforio yn eithaf araf. Yn unol â hynny, yn Offer | Dewisiadau ...hynny ymlaen y Catalogtab,eich bod yn gallu lleihau faint o fformatio sy'n cael ei allforio fel y dangosir ar y tab Catalog isod, a thrwy hynny gyflymu'r allforio.

Allforio Catalog opsiynau

4. Mae deialog Allforio Cwblhawyd yn cael ei arddangos. Cliciwch iawn.

Allforio i gatalog MS Excel

I mewnforio o gatalog MS Excel

Nodyn

Yn ddiofyn y Colofn A cudd o fewn y catalog MS Excel allforio (gweler uchod) yn cynnwys y ID unigryw ar gyfer pob un o'r elfennau yn y gadwrfa ABACUS. Mae hyn yn caniatáu unrhyw newidiadau sy'n cael eu gwneud o fewn MS Excel i gael eu 'paru' i'r elfennau sydd eisoes yn bodoli o fewn ABACUS ar fewnforio. Fodd bynnag, gall y defnydd o ID unigryw hwn i rhesi 'yn cyd-fynd i fyny' yn cael ei diystyru gyda | Allanol IDeiddo ar yr elfen. Hynny yw, os yw'r elfen yn cael Allanol | Eiddo ID ac mae'n cael ei gynnwys yn y catalog ar allforio (gweler uchod), yna y gwerthoedd y Allanol | Bydd colofn ID cael ei ddefnyddio i gyfateb i fyny 'r rhesi ar fewnforio a'r gwerthoedd ID unigryw yn y golofn A cudd yn cael ei anwybyddu (a gall hyd yn oed fod yn wag). Mae'r Colofn cudd A rhaid ei hun yn parhau, fodd bynnag, yn enwedig y gwerth mewn cell A1. Ar ben hynny, wrth ychwanegu ID allanol i gasgliad elfen ABACUS presennol rydym yn argymell eu hychwanegu fel eiddo gwahanol yn gyntaf, ee | Allanol Temp ac yna ailenwi'r yr eiddo i Allanol | ID. Fel arall, bydd elfennau dyblyg yn cael eu hychwanegu.

1. Sicrhewch fod gennych Golygfa Catalog agored.

2. Cliciwch y Mewnforio o Excel Catalog daenlenbotwm bar offer.

3. Dewiswch enw ffeil i fewnforio catalog MS Excel o. Cliciwch Agored.

4. Gwallau Newydd a ddatryswyd a / neu Camgymeriadau Newydd / Rhybuddion ddatryswyd gall ddeialogau ymddangos am unrhyw gynnwys newydd (hy rhesi yn yr MS Excel) a ychwanegwyd. Cymerwch sylw o'r gwallau / rhybuddion a chliciwch iawn.

5. Mae Mewnforio Cwblhawyd deialog yn cael ei arddangos a gall ddangos rhybuddion oherwydd y mewnforio (gweler y nodiadau isod). Cliciwch iawn.

Nodyn

Ar gyfer y colofnau Cydran neilltuo Safonau neu ynghlwm, mae'n rhaid i geisiadau newydd drwy'r catalog MS Excel yn cyd-fynd yn union yr enw o Safon presennol neu Cydran o'r math cywir ar gyfer yr aseiniad neu gysylltiad i'w hychwanegu. Bydd y gêm gyntaf a enwir yn cael ei defnyddio a bydd unrhyw gofnodion unmatched yn cynhyrchu rhybudd yn unol isod. Ar ben hynny, tra bod rhybuddion yn cael eu rhoi ar ail-fewnforio, elfennau yw Nid yw dileuo ABACUS os nad maent yn bresennol yn y catalog MS Excel. Mae hyn oherwydd nad oes unrhyw ffordd y gall ABACUS gwybod a yw'r Cydran neilltuo Safonol neu ynghlwm yn bodoli yn y prosiect ABACUS ond nid yw'n bodoli yn y catalog MS Excel oherwydd ei fod wedi cael ei ddileu o'r catalog MS Excel neu wedi cael ei ychwanegu at y ABACUS prosiect ers y catalog ei allforio. Yn unol â hynny, os bydd defnyddwyr yn dymuno rhwydd 'canfod' a chysylltiadau wedi eu hychwanegu yn ystod y broses mewnforio gallant yn syml greu eiddo sydd ei angen ar y math o gysylltiad ac yn gosod ei fod yn ball i wag fel y byddant yn cael eu rhybuddio am unrhyw gysylltiadau newydd bob tro y mewnforio ei gwblhau.

Nodyn

Wrth fewnforio catalog MS Excel efallai amrywiol rybuddion yn cael eu harddangos. Yn gyntaf, os colofn newydd yn cael ei ychwanegu at y Excel nad yw'n cyd-fynd â'r 'cystrawen' ar gyfer eiddo neu gydran atodedig, bydd y golofn yn cael ei anwybyddu. Nesaf, bydd llinell wrth linell rhybuddion yn cael eu harddangos ar gyfer unrhyw broblemau gyda'r data ar bob rhes o'r catalog Excel. Mae'r rhain rhybuddion dechrau gyda'r rhif rhes mewn cromfachau sgwâr ac os yn berthnasol y label golofn (hy '[23, J] ...' ar gyfer rhes 23, colofn J) a gall gyfeirio at eitemau dileu, Safonau unmatched neu enwau Cydran ynghlwm (sy'n yn cael eu hanwybyddu fel y nodyn uchod) neu ID yn annilys neu wag yn ymwneud â rhes / elfen newydd (a fydd yn cael ei ychwanegu). Ar gyfer erthygl manwl am boblogi'r ABACUS gan ddefnyddio catalogau Excel cyfeiriwch at y Cymuned Avolution neu'r cwrs hyfforddi Rheolwr Portffolio.

Nodyn

Cydrannau a chysylltiadau newydd yn cael eu hychwanegu yn ddiofyn ar y lefel uchaf y Cydrannau neu Connections casglu'r Pensaernïaeth a ddewiswyd. I newid y rhiant y cydrannau neu cysylltiadau newydd de-gliciwch y gell Llwybr Hierarchaeth ar gyfer y gydran neu gysylltiadau rhes newydd a dewis Newid Rhiant ...a dewis y rhiant a ddymunir (gan gymryd sylw o'r amlygu cyfyngiad ).

Nodyn

Elfennau hychwanegu yn uniongyrchol i'r catalog drwy'r botwm 'Ychwanegu Newydd', ludo i mewn i'r catalog, neu eu creu trwy fewnforio i mewn i'r catalog o MS Excel wedi eu heithrio o hidlo nes i'r catalog ar gau. Mae hyn er mwyn caniatáu i unrhyw olygu angenrheidiol o werthoedd colofn Ni all ateb y meini prawf hidlo presennol y catalog. Mae'r rhain yn elfen rhesi newydd yn cael eu dynodi gan symbol '+' yn y gell dewisydd rhes ar ddechrau'r y rhes, sy'n cael ei lliw gwyrdd os yw'r elfen ar hyn o bryd yn bodloni'r meini prawf hidlo arbedwyd o'r catalog (hy yn aros ar gatalog os ail-agorwyd), a Coch os nad yw'n gwneud hynny.

I cymharu cynnwys catalog â phensaernïaeth arall

1. Cyfeiriwch at y pwnc yma .

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Poblogi eich pensaernïaeth o Visio | Poblogi eich pensaernïaeth o Excel


Poblogi gan ddefnyddio matricsau

Navigation: poblogi eich pensaernïaeth>

Poblogi gan ddefnyddio matricsau

Anfon sylwadau ar y pwnc hwn.

Mae matrics caniatáu i chi weld a golygu'r 'Uniongyrchol' cysylltiadau rhwng cydrannau mewn ffordd tabl symlac i hefyd yn edrych ar y 'llwybr anuniongyrchol' rhwng cydrannau yn ôl unrhyw gydrannau canolradd (a chysylltiadau).

I creu golwg Matrics yn ABACUS

Nodyn

Er y gall yr holl ddefnyddwyr Pensaer greu Matricsau i'w hachub a / neu eu lleoliadau y mae angen i'r Dylunydd gallu ychwanegu-ar drwydded defnyddiwr. Mae hyn er mwyn 'amddiffyn' cyfluniad Matricsau presennol y gellir eu rhannu gan nifer o ddefnyddwyr. Fodd bynnag, Pensaer defnyddio heb y Dylunydd ychwanegu-ar yn gallu dal i ddewis i 'Save As' i unrhyw leoliadau newydd i Matrics newydd. Ac wrth gwrs, gall pob trwydded defnyddiwr yn dewis 'Taflu' unrhyw newidiadau i Matrics sydd eisoes yn bodoli. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

1. Dewiswch Mewnosod | Matrics.

2. Yn y rchitecture>tynnu-lawr dewiswch y Pensaernïaeth sy'n cynnwys y cydrannau a chysylltiadau yr hoffech ei gweld.

3. Yn y <FfynhonnellTeipiwch>tynnu-lawr yn dewis y math gydran eich bod yn dymuno cael yr enghreifftiau a restrwyd fel 'rhesi' i lawr y chwithy matrics.

4. Yn y <SincTeipiwch>tynnu-lawr yn dewis y math gydran eich bod yn dymuno cael yr enghreifftiau a restrwyd fel 'colofnau' ar draws y brigy matrics.

5. Yn y Tynnu i lawr mae dau 'dulliau' o'r matrics gallwch ddiffinio yn eu hanfod yn ...

Matricsau cysylltiadau 'Uniongyrchol'

6. Yn syml sethol un (1) neu fwy cysylltiad mathau ar yr ochr dde o'r ddewislen sy'n ymddangos, os ydych yn dymuno gweld yn y 'celloedd' o'r matrics os ywn benodolcysylltiad yn bodoli o Fertigol/ 'rhes'Elfen o'r matrics i'r Llorweddol/ 'colofn'Elfen o'r matrics.

Nodyn

Dim ond cysylltiadau â'r ffynhonnell diwedd ar ynghlwm wrth y Fertigol/ 'rhes'Pen cydran a sinc sydd ynghlwm wrth y Llorweddol/ 'colofn'Bydd y cydran yn cael ei ddangos. Newid y Ffynhonnellac Sincdewisiadau math cydran i weld y cysylltiadau yn y cyfeiriad arall.

7. Bydd y matrics yn cael ei llenwi â 'X' yn y celloedd (neu werth yr eiddo - gweler y nodyn isod) os oes cysylltiad gan y Fertigol/ 'rhes 'elfen o'r matrics i'r Llorweddol/ 'colofn'Elfen o'r matrics.

Nodyn

Ar gyfer matricsau mawr, dim ond uchafswm o 100 o resi neu golofnau (gan gynnwys rhesi cwympo / golofnau) gael eu dangos ar y tro fel y dangosir gan y dangosyddion 'C' 'R' ac yn y gell header top-chwith yn y drefn honno. I weld rhesi ychwanegol yn defnyddio'r bariau sgrolio. Ar unrhyw adeg, gallwch glicio ddwywaith ar y Fertigol/ 'rhes'Neu Horizontal / 'colofn'Cydran penawdau a neidio i'ry cydrannau cyfatebol yn y ffenestr Explorer.Mae rhieni'r Fertigol/ 'rhes' ac Llorweddol/ 'colofn'CydranMae hefyd yn cael eu dangos yn ddewisol fel pennawd rhesi / colofnau gyda theitl pennawd llwyd. Pan gwympodd (drwy glicio sengl y gell pennawd) os atodiadau plant yn bodoli, yna 'X' yn ddewisol yn cael ei ddangos os yw'r holl blant yn atodedig neu a fydd yn 'O' ddewisol yn cael ei ddangos os mai dim ond rhai o'r plant yn atodedig. Efallai y bydd y celloedd yn lliw yn ôl gwerth eiddo i'r cysylltiadau drwy glicio ar y Options 'gêr olwyn' ar frig-dde o'r bar offer matrics a dewis Lleoliadau Lliw ... ac yna ar y botwm Edit a dewis y lliwiau gan opsiwn stamp amser neu Lliw Erbyn Eiddo a dewis eiddo, yr ystod gwerth Min a Max a dewis lliwiau, fodd bynnag, dim ond Rhestr, Cyfanrif, Degol, Boolean neu Dyddiad / Amser Bydd eiddo math data lliwio. Os cwympo, bydd y gell yn cael ei lliwio yn ôl y gwerth eiddo cyfartalog o'r cysylltiadau. Yn lle 'X', gall gwerth eiddo ar gyfer y celloedd yn dangos drwy glicio ar y Options 'olwyn gêr' ar frig-dde o'r bar offer matrics a dewis Sioe Lleoliadau Gwerth ... ac yna ar y botwm Edit a dewis yr opsiwn Show eiddo a dewis eiddo.

Cysylltiadau uniongyrchol matrics sy'n dangos y Gweinyddwyr lle ceisiadau yn cael eu cynnal gyda lliwio a eiddo yn cael eu dangos yn lle y generig 'X'

- OR -

Matricsau cysylltiadau 'Anuniongyrchol'

6. Setholdilyniant o cysylltiad mathau ac mathau o gydranar yr ochr dde a chwith y ddewislen sy'n ymddangos, os ydych yn dymuno gweld yn y 'celloedd' o'r matrics os ywn lwybr anuniongyrchol o gydrannau cysylltiedigyn bodoli o Fertigol/ 'rhes'Elfen o'r matrics i'r Llorweddol/ 'colofn'Elfen o'r matrics.

Nodyn

Unrhyw lwybr dilys sy'n cynnwys yr elfennau a ddewiswyd yn y ddewislen llwybr wsâl yn cael ei ddangoswaeth beth yw cyfeiriad y cysylltiadau sylfaenol, fodd bynnag, wrth ddewis y llwybr y yn gyntafac elfennau olaf a ddewisir fod yn fathau o gysylltiad. Ar ben hynny, mae'r gorchymyn o'r elfennau sydd wedi cael eu dewis yn cael ei ddangos gyda rhagddodiad rhifiadolmewn sgwâr ('[]') cromfachau ac efallai o fath penodol yn cael eu cynnwys Amseroedd mutlipleyn y llwybr (fel y nodir gan y rhagddodiad rhifol). Detholiad olynol o fathau cydran neu fathau cysylltiad yn cael ei ddehongli fel 'OR'Efallai y llwybr a'r hierarchaeth o elfennau sydd ynghlwm yn cael eu cynnwys yn ddewisol drwy wirio'r 'Hefyd chwilio Ymlyniad rhieni / plant'Blwch gwirio. Newid y Ffynhonnellac Sincdewisiadau math cydran i weld y llwybrau yn y cyfeiriad arall.

7. Bydd y matrics yn cael ei phoblogaeth gydalwybr / casgliad o gydrannauyn y celloedd os oes llwybr oddi wrth y Fertigol/ 'rhes 'elfen o'r matrics i'r Llorweddol/ 'colofn'Elfen o'r matrics.

Nodyn

Ar gyfer matricsau mawr, dim ond uchafswm o 100 o resi neu golofnau (gan gynnwys rhesi cwympo / golofnau) gael eu dangos ar y tro fel y dangosir gan y dangosyddion 'C' 'R' ac yn y gell header top-chwith yn y drefn honno. I weld rhesi ychwanegol yn defnyddio'r bariau sgrolio. Ar unrhyw adeg, gallwch glicio ddwywaith ar y Fertigol/ 'rhes'Neu Horizontal / 'colofn'Cydran penawdau a neidio i'ry cydrannau cyfatebol yn y ffenestr Explorer.Mae rhieni'r Fertigol/ 'rhes' ac Llorweddol/ 'colofn'CydranMae hefyd yn cael eu dangos yn ddewisol fel pennawd rhesi / colofnau gyda theitl pennawd llwyd. Pan gwympodd (drwy glicio sengl y gell pennawd) os bydd unrhyw lwybrau plant yn bodoli, yna 'X' yn ddewisol yn cael ei ddangos os yw'r holl blant yn atodedig neu a fydd yn 'O' ddewisol yn cael ei ddangos os mai dim ond roedd gan rai o'r plant llwybrau. Efallai y bydd y cydrannau llwybr anuniongyrchol yn lliw yn ôl gwerth eiddo i'r cydrannau drwy glicio ar y Options 'gêr olwyn' ar frig-dde o'r bar offer matrics a dewis Lleoliadau Lliw ... ac yna ar y botwm Edit a dewis y lliwiau gan opsiwn stamp amser neu Lliw Erbyn Eiddo a dewis eiddo, yr ystod gwerth Min a Max a dewis lliwiau, fodd bynnag, dim ond Rhestr, Cyfanrif, Degol, Boolean neu Dyddiad / Amser Bydd eiddo math data lliwio. Gall gwerth eiddo ar gyfer y cydrannau llwybrau anuniongyrchol yn dangos drwy glicio ar y Options 'olwyn gêr' ar frig-dde o'r bar offer matrics a dewis Sioe Lleoliadau Gwerth ... ac yna ar y botwm Edit a dewis yr opsiwn Show eiddo a dewis eiddo.

Matrics cysylltiadau anuniongyrchol yn dangos y ceisiadau sy'n gweithredu Gwasanaeth a roddwyd gan yr Adran

I hidlogolwg Matrics yn ABACUS

1. Sicrhewch fod gennych newydd Golygfa Matrics agored.

2. Cliciwch y Echelau Hidlo 'twndis' ar frig-dde o'r bar offer matrics.

3. Ar y Ffynhonnell a / neu'r tabiau Sinc ychwanegu Enw, Eiddo, Disgrifiad, Hierarchaeth neu hidlwyr Safonol drwy glicio ar y botwm Add, ddethol Eiddo os oes angen a chlicio iawn. Dewiswch y dewisiadau perthnasol yn y panel Allweddeiriau / Eitemau gan ddefnyddio'r rhesymeg / cystrawen fel y disgrifir yn y nodyn isod. Bydd y panel rhagolwg yn diweddaru yn awtomatig i ddangos y canlyniadau set bresennol o hidlwyr.

Nodyn

Ar gyfer Stamp amser, Llwybr Hierarchaeth, Enwneu Disgrifiadhidlwyr neu Testun, Cyfanrif, Degol, Booleanneu Dyddiad / Amserparu hidlwyr eiddo yn cael ei berfformio fel pe bai '*' wildcards yn cael eu cymhwyso yn awtomatig cyn ac ar ôl unrhyw werthoedd llinyn fel y byddai cofnod o 'cath' (heb y dyfyniadau) yn cynnwys rhesi gyda 'Bobcath','cathferch 'neu' applicathion 'ayyb lluosog /' fod gwerthoedd yn cael eu cofnodi ar linellau newydd gan ddefnyddio neu ' Ctrl + Enter. Ar gyfer Cyfanrif ac Degol hidlwyr eiddo 'ac' Efallai y rhesymeg yn cael ei gynnwys gan ddefnyddio '&'(Heb y dyfyniadau) a mwy na / llai na etc rhesymeg gellir cynnwys gan ddefnyddio'> =','>','<'A'<='(Heb y dyfyniadau) e.e. '> = 50000 & <90000'. Gall rhesi eu gwerthfawrogi nad ydynt yn wag yn cael eu cynnwys drwy nodi '(Di-Blanks)'(Heb y dyfyniadau) a gall rhesi eu gwerthfawrogi gwag yn cael eu cynnwys drwy nodi'(Blanks)'(Heb y dyfyniadau).Ar gyfer Safonau neu Rhestr eiddo hidlwyr Bydd y '(Dewis Popeth)' checkbox galluogi'r holl blychau arall, i bob pwrpas, gan gynnwys yr holl elfennau sydd ar gael. Bydd y '(Heb fod yn Blanks)' checkbox gynnwys unrhyw elfennau eiddo nad ydynt yn wag gwerthfawrogi. Bydd y '(Blanks)' checkbox gynnwys unrhyw eiddo gwag elfennau gwerthfawr. Ac ddatddewis unrhyw blychau ticio penodol a gwerthfawr fydd yn awtomatig dad ddewiswch y '(Dewis Popeth)' a '(-Blanks Non)' blychau ticio er cysondeb. Ac yn olaf, yr holl hidlwyr yn erbyn achos ball ansensitif felly byddai 'cath' (heb y dyfyniadau) yn cynnwys elfennau gyda 'cath', 'Cat' neu ati 'CAT' Er paru sensitif achos, rhowch '(Achos)'(Heb y dyfyniadau) cyn i'r llinyn e.e. Byddai '(Achos) Cat' (heb y dyfyniadau) yn unig gynnwys elfennau gyda 'Cat' ynddynt.

I boblogi gan ddefnyddio barn Matrics yn ABACUS

Nodyn

Gallwch ond ychwanegu / dileu cysylltiadau lle mae math o gysylltiad sengl wedi cael ei ddefnyddio ar gyfer Llwybr ddisgrifir uchod.

1. I ychwanegwch cysylltiado'r math a ddewiswyd rhwng Fertigol/ 'rhes'Cydran a Llorweddol/ 'colofn'Elfen o'r matrics, lle mae' X 'yn bodoli eisoes yn(Neu werth yr eiddo a ddangosir - gweler y nodyn uchod), Dwbl cliciwch ar y gell. Dylai 'X' yn ymddangos (Neu werth eiddo - gweler y nodyn uchod) a bydd cysylltiad yn cael ei greu ar y lefel uchaf y casgliad Cysylltiadau ar gyfer yr Pensaernïaeth a ddewiswyd.

Nodyn

Bydd yr enw cyswllt fydd y Enw'r math o gysylltiad Bydd yn unol â'r gosodiad math o gysylltiad y matrics ac os yw gwerth yr eiddo yn cael ei ddangos yn hytrach na 'X' y gwerth diofyn ar gyfer yr eiddo yn cael ei ddangos.

2. I golygu a gwerth eiddo a ddangosirar y cysylltiad rhwng a Fertigol/ 'rhes'Cydran a Llorweddol/ 'colofn'Elfen o'r matrics, Dwbl cliciwch y gell, neu de-gliciwch y gell a dewiswch Edit Gwerth ..., a golygu gwerth yn yr ymgom Newid Gwerth.

3. I tynnu cysylltiado'r math a ddewiswyd rhwng Fertigol/ 'rhes'Cydran a Llorweddol/ 'colofn'Elfen o'r matrics, lle mae' X 'yn bodoli eisoes(Neu werth yr eiddo a ddangosir - gweler y nodyn uchod), hawl-cliciwch ar y gella dewiswch Datgysylltu. Dylai'r X yn diflannu a bydd y cysylltiad yn cael ei ddileu o'r prosiect.

I achub / Cadw fel aGolygfa Matrics

Nodyn

Er y gall yr holl ddefnyddwyr Pensaer greu Matricsau i'w hachub a / neu eu lleoliadau y mae angen i'r Dylunydd gallu ychwanegu-ar drwydded defnyddiwr. Mae hyn er mwyn 'amddiffyn' cyfluniad Matricsau presennol y gellir eu rhannu gan nifer o ddefnyddwyr. Fodd bynnag, Pensaer defnyddio heb y Dylunydd ychwanegu-ar yn gallu dal i ddewis i 'Save As' i unrhyw leoliadau newydd i Matrics newydd. Ac wrth gwrs, gall pob trwydded defnyddiwr yn dewis 'Taflu' unrhyw newidiadau i Matrics sydd eisoes yn bodoli. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os ydych angen y Dylunydd ychwanegu-ar gallu.A chofiwch, mae hyn yn unig y gosodiadau y Matrics, pob golygiadau a wnaed i'r data yn y Matrics yn cael eu cymhwyso yn syth i'r gadwrfa, beth bynnag.

1. Sicrhewch fod gennych newydd Golygfa Matrics agoredac eich bod wedi gwneud y newidiadau angenrheidiol.

2. Yn y Golygfa Matricscliciwch bar offer ar y leftmost Save Matricsbotwm i achub y Golygfa Matrics ac unrhyw newidiadau fformatio.

Nodyn

Os nad oes gennych botwm Save ym marn Matrics toolbar yna nid oes gennych y Dylunydd ychwanegu-ar ac rydych ond yn gallu Save Asunrhyw newidiadau i leoliadau matrics newydd pan fyddwch yn mynd i gau'r matrics presennol.

3. Os y MatricsEnwdeialog sy'n ymddangos (Oherwydd ei fod matrics newydd) rhowch enw ar gyfer y matricsac yn y wasg iawn.

I allforio i matrics MS Excel

1. Sicrhewch fod gennych Golygfa Matrics agored.

2. Cliciwch y Allforio i Excelbotwm bar offer.

3. Dewiswch enw ffeil i achub y matrics MS Excel fel. Cliciwch Save.

Nodyn

Yn ddiofyn, bydd filename y matrics MS Excel allforio fydd enw'r Matrics ddodiad gan yr enw Pensaernïaeth mewn cromfachau, ee 'Ceisiadau a gynhelir ar Gweinyddwyr (2014 Gwirioneddol) .xlsx'. Gallwch newid unrhyw ran o hyn, gan gynnwys a yw'r fformat ffeil yw bod yn .xlsx neu Xls.

Fformatio Matricsei allforio at ball, fodd bynnag, i matricsau mawr hwn arwain yn y allforio yn eithaf araf. Yn unol â hynny, yn Offer | Dewisiadau ...hynny ymlaen y Matricstab,eich bod yn gallu lleihau faint o fformatio sy'n cael ei allforio fel y dangosir ar y tab Matrix isod, a thrwy hynny gyflymu'r allforio.

Allforio Matrics opsiynau

4. Mae deialog Allforio Cwblhawyd yn cael ei arddangos. Cliciwch iawn.

Allforio i matrics MS Excel

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Poblogi eich pensaernïaeth o Visio | Poblogi eich pensaernïaeth o Excel


Poblogi eich pensaernïaeth o Microsoft Access

Navigation: poblogi eich pensaernïaeth> poblogi o gynhyrchion Microsoft>

Poblogi eich pensaernïaeth o Microsoft Access

Anfon sylwadau ar y pwnc hwn.

Gallwch allforio eich pensaernïaeth i Microsoft Access i berfformio cyfrifiadau at ddibenion cyffredinol, manipulations neu adroddiadau ar eich pensaernïaeth. Yna, gallwch fewnforio pensaernïaeth yn ôl i ABACUS.

Nodyn

Mae'r agor o Fynediad / Allforio i Gronfa Ddata nodwedd ei gwneud yn ofynnol bod Microsoft Access 2000neu mwy newydd yn cael ei osod ar y cyfrifiadur.

I allforio eich pensaernïaeth i Microsoft Access

1. Sicrhewch bod gennych File ABACUSagored, mae'r Explorerharddangos, a pensaernïaethychwanegodd.

2. Dewiswch Ffeil | Allforio | I Cronfa Ddata.

3. Cymerwch sylw o'r ymgom rhybudd fel y disgrifir uchod a chlicio Do barhau.

4. Dewiswch leoliad a enw ffeil ar gyfer y ffeil gronfa ddata.

I fewnforio bensaernïaeth trin mewn i ABACUS

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Ffeil | Newydd a dethol O Mynediadoddi wrth y deialog sy'n ymddangos a chliciwch OK.

3. Pori ar gyfer y ffeil cronfa ddata yr hoffech fewnforio.

ABACUS 'MS Access Schema Cronfa Ddata

ABACUS Mae wrth ei galonn ontoleg / meta-meta-model sy'n cynnwys Cydrannau, Cysylltiadau a Chyfyngiadau. Mae'r dull "CSC" yn deillio o nifer o ddulliau safonol a ddatblygwyd o'r 1960au ymlaen, gan arwain at IEEE safon ryngwladol 1471, a oedd yn sylfaenwyr Avolution yn cyfrannu at. Mae'r primitives canlynol yn gymwys;

1. ABACUS cynnwys Llyfrgelloeddo Safonau(Neu Safonau), Cydranac Mathau Cysylltiad, Cyfyngiadau, Gwylfannau, Templedi (Neu Patrymau) A llawer Pensaernïaeth.

2. Safonau, Mathauac Gwylfannau Gallfod yn rhesymegol Grwpioer hwylustod.

3. Pensaernïaeth Gall gynnwysllawer o ddisgynyddion Pensaernïaeth(Neu esblygiadau).

4. Mae pob Pensaernïaeth cynnwysllawer Cydrannauac Cysylltiadaupenodol Mathauac amrywiol Barn.

5. Cydrannauac CysylltiadauGall fod yn dadelfennui mewn i Is-Cydrannauac Is-Cysylltiadau.

6. Mae pob Cydranyw ynghlwm wrthunrhyw nifer o Cysylltiadauond mae pob Cysylltiadyn unig fod ynghlwm wrthuchafswm o ddwy Cydrannau.

7. Cydrannauac Cysylltiadaugall cael Safonaugyda Priodweddaumegis Gwybodaeth, Perfformiad, Dibynadwyedd, Cost ac ati

8. Pensaernïaeth, Cydrannauac Cysylltiadaugall caelpenodol Priodweddaumegis Gwybodaeth, Perfformiad, Dibynadwyedd, Cost ac ati

9. Cyfyngiadaugall bodoli rhwng Cydrannauneu Cysylltiadauneu erbyn Priodweddau.

10. Templediyn cyfansoddiadau safonol Cydranac Mathau Cysylltiad.

11. Gwylfannauyn gymdeithasau safonol Cydranac Mathau Cysylltiadi nodiannau.

12. Barnyn cynrychioliadau gweledol Cydrannauac Cysylltiadau.

Mae'r Endid MS Access Perthynas Diagram canlynol (ERD) yn cofnodi'r craiddPensaernïaeth, Esblygiadau, Mathau Cydran / Cysylltiad (a Grwpiau), Components / Cysylltiadau a chysyniadau Is Cydran / Cysylltiad.

Mae'r sgema cronfa ddata Craidd

Nodyn

Nid yw cywirdeb cyfeiriadol wedi cael ei orfodi ar y berthynas rhwng y bwrdd Cydrannau a'r tabl Cysylltiadau (ar gyfer y 'ymlyniad' rhwng Ffynhonnell roddir neu Cydran Sinc a Connection). Mae hyn oherwydd y gall cysylltiad fodoli heb atodiadau gydran. Gallem fod wedi ychwanegu tabl 'ymlyniad', ond er budd symlrwydd penderfynu yn erbyn hynny. Wrth gwrs mae hyn yn golygu y bydd unrhyw olygu o IDs Cydran neu dileu o resi Cydran gyd gyda'i gilydd yn arwain at ddata anghywir. Bydd ABACUS trin unrhyw anghywirdeb ar fewnforio drwy anwybyddu'r data anghywir.

Mae'r MS Access ERD canlynol yn dogfennu'r Priodweddaucysyniadau ar gyfer Pensaerniaethau, Mathau Cydran / Cysylltiad a Chydrannau / Cysylltiadau.

Sgema cronfa ddata Priodweddau

Mae'r MS Access ERD canlynol yn dogfennu'r Safonaucysyniad ar gyfer Pensaerniaethau, Mathau Cydran / Cysylltiad a Chydrannau / Cysylltiadau.Noder: Mae'r tablau yn dal i ddefnyddio'r term 'Gweithredu' yn unol â fersiynau blaenorol o ABACUS.

Sgema cronfa ddata Safonau

Mae'r MS Access ERD canlynol yn dogfennu'r Cyfyngiadaucysyniad ar gyfer Cydran Mathau / Cysylltiad.

Cyfyngiadausgema cronfa ddata

Mae'r MS Access ERD canlynol yn dogfennu'r Gwylfannau cysyniad ar gyfer Pensaernïaeth.Noder: Mae'r tablau yn dal i ddefnyddio'r term 'TwoDTempl' fel y fersiynau blaenorol o ABACUS.

Gwylfannausgema cronfa ddata

Mae'r MS Access ERD canlynol yn dogfennu'r Catalogaucysyniad ar gyfer Pensaernïaeth.

Catalogausgema cronfa ddata

Mae'r MS Access ERD canlynol yn dogfennu'r Matricsaucysyniad ar gyfer Pensaernïaeth.

Matricsausgema cronfa ddata

Mae'r MS Access ERD canlynol yn dogfennu'r Diagramaucysyniad ar gyfer Pensaernïaeth.Noder: Mae'r tablau yn dal i ddefnyddio'r term 'TwoD' fel y fersiynau blaenorol o ABACUS.

Nodyn

Y Math Cydran / Cysylltiad i stensil mapio siâp a ffurf dogn rhydd o MS Access ERD wedi cael eu gadael allan er mwyn eglurder.

Diagramausgema cronfa ddata

Mae'r MS Access ERD canlynol yn dogfennu'r Golygfeydd 3Dcysyniad ar gyfer Pensaernïaeth.

Golygfeydd 3Dsgema cronfa ddata

Mae'r MS Access ERD canlynol yn dogfennu'r Siartiaucysyniad ar gyfer Pensaernïaeth.

Siartiausgema cronfa ddata

Mae'r MS Access ERD canlynol yn dogfennu'r Dangosfyrddaucysyniad.

Dangosfyrddausgema cronfa ddata

ABACUS 'MS AccessYmholiadau

Yn gynwysedig gyda'r Gronfa Ddata MS Access sawl ymholiadau ddefnyddiol fel a ganlyn;

· Comps gan Propiau- Bydd yr ymholiad hwn yn rhestru'r holl gydrannau yn y prosiect (yn ôl pensaernïaeth a math) ac mae'n cynnwys yr holl eiddo fel colofnau. Defnyddiwch y cwestiwn hwn gyda ffilteri / criterias ar y math gydran a / neu bensaernïaeth i gynhyrchu tablau 'nodweddiadol' ar gyfer pob math cydran gyda eu heiddo.

· STDs gan Propiau- Bydd yr ymholiad hwn yn rhestru'r holl safonau sy'n cael eu defnyddio, mae nifer y digwyddiadau o safon ac yn cynnwys yr holl eiddo fel colofnau. Defnyddiwch ymholiad hwn fel catalog safonau.

· Propiau gan Mathau- Bydd yr ymholiad hwn yn rhestru'r holl eiddo cydran a'u% gwblhau erbyn pob math cydran fel colofnau. Defnyddiwch y cwestiwn hwn i benderfynu a eiddo penodol yn cael eu cynnal.

· Mathau gan Propiau- Bydd yr ymholiad hwn yn rhestru'r holl fathau gydran ac yn cynnwys y% cyflawn o'r holl eiddo fel colofnau. Defnyddiwch y cwestiwn hwn i benderfynu a eiddo penodol yn cael eu cynnal.

· Math Cyfrif- Bydd yr ymholiad hwn yn rhestru'r holl fathau gydran ac yn cynnwys y nifer o achosion o bob math mewn trefn ddisgynnol. Defnyddiwch y cwestiwn hwn i bennu poblogrwydd bob math yn y prosiect.

Nodyn ar weithio gyda chaeau Memo yn MS Access

Mae'r Cydrannau, Cysylltiadau a chaeau Enw'r Mae safonau yn y tablau yn cael eu diffinio fel meysydd memo i ganiatáu ar gyfer nifer digyfyngiad o gymeriadau, yn unol ABACUS. Ar gyfer y Cydrannau a Connections hyn yn achosi ychydig o faterion gan eu bod hefyd yn cael cae ID unigryw ar gyfer cyfeirnodi, ond ar gyfer y Safonau hyn yn achosi rhai problemau wrth geisio ymuno tablau oherwydd nad ydych yn gallu ymuno â meysydd memo yn MS Access. Fel arall, gallwch chi osod Lle feini prawf cymal i gyflawni'r un effaith fel y dangosir yn yr Gweledol Ymholiad Builder a cyfatebol pytiau SQL is na rhestr allan yr holl Safonau a etifeddwyd eiddo ar gyfer yr holl Cydrannau yn y prosiect ABACUS hallforio.

Maes Memo 'ymuno' yn Ymholiad Gweledol Builder

SELECT Components.Architecture_Id, Components.Id, Components.Name, ComponentImplementationLinks.Name, ImplementationProperties.Type, ImplementationProperties.Name, ImplementationProperties.Value, ImplementationProperties.Unit

O Cydrannau FEWNOL YMUNO ComponentImplementationLinks ON (Components.InternalId = ComponentImplementationLinks.Id) A (Components.Architecture_Id = ComponentImplementationLinks.Architecture_Id), Gweithrediadau FEWNOL YMUNO ImplementationProperties AR Implementations.Id = ImplementationProperties.Implementation_Id

BLE (((ComponentImplementationLinks.Name) = [Gweithrediadau] [Enw]).);

Maes Memo 'ymuno' yn SQL

Nodyn ar gynhyrchu IDs ABACUS yn awtomatig yn MS Access

Amrywiol dablau ABACUS MS Access yn gofyn am ID cyfanrif hir unigryw, felly dull VB syml yn cael ei ddarparu i gynorthwyo yn y genhedlaeth o hyn. Dau ddull ResetCounter () a GetNextCounter () yn cael eu darparu o fewn ABACUS 'MS Access DB a'u defnydd fel a ganlyn; ResetCounter () yn gosod y cownter yn ôl i 0. GetNextCounter () yn dychwelyd y cownter nesaf yn y dilyniant.

Mae'r dulliau manteisio 'chwiw' yn MS Access, hyd yn oed os byddwch yn ffonio y dull ResetCounter () ar gyfer pob mewnosoder rhes (hy pan fyddwch hefyd yn rhedeg y GetNextCounter () yn) oherwydd nad oes gan y ResetCounter () yn unrhyw baramedrau 'i jyst yn rhedeg unwaith ac felly nid yw'n ailosod y cownter ar gyfer pob mewnosod rhes. A hefyd oherwydd yr un 'chwiw' rhaid i chi basio unrhyw hen newidyn colofn i'r GetNextCounter () yn i dwyllo i mewn i redeg bob tro.

Mae yna hefyd tric i allu rhedeg y ResetCounter () yn mewn mewnosodiad i mewn i ddatganiad SQL oherwydd cant yr ydych newydd ei fod yn eistedd yno fel colofn ar ei ben ei hun, fel pe ei fod yn ymholiad dethol. Argymhellir gwneud y ResetCounter () galwad yn rhan o un o'r meysydd eraill, drwy gydgadwyno'r yn hyd y diwedd, gan ei fod bob amser yn dychwelyd null beth bynnag.

Isod mae defnyddio SQL nodweddiadol o'r dulliau i ychwanegu rhestr o Mathau Elfen o dabl / ymholiad enw 'Elfen Type Rhestr'.

INSERT INTOComponentTypes (Id, Enw, Disgrifiad)

SELECT GetNextCounter ([Cydran Math Rhestr] .name)AS Id, [Cydran Math Rhestr] .name AS Enw, [Cydran Math Rhestr] .description & ResetCounter ()AS Disgrifiad

O[Cydran Math Rhestr];

ABACUS ID cenhedlaeth / Counter mewn SQL

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Poblogi eich pensaernïaeth o Visio | Poblogi eich pensaernïaeth o Excel


Poblogi eich pensaernïaeth o Microsoft Visio

Navigation: poblogi eich pensaernïaeth> poblogi o gynhyrchion Microsoft>

Poblogi eich pensaernïaeth o Microsoft Visio

Anfon sylwadau ar y pwnc hwn.

Gallwch fewnforio eich pensaernïaeth o Microsoft Visio. Bydd Siapiau yn eich llun Visio ei fewnforio fel cydrannau i mewn ABACUS. Bydd cysylltiadau yn eich llun Visio gael ei fewnforio fel cysylltiadau a bydd y llun ei hun yn cael ei fewnforio i ABACUS fel diagram. Ar ben hynny, bydd unrhyw Properties Custom yn eich llun Visio cael ei fewnforio fel eiddo gyda'r Allwedd Trefnu yn mapio i'r Math o Eiddo, Label i'r Enw'r Eiddo a'r Gwerth at y Gwerth Eiddo.

Nodyn

Mae'r Mewnforio o nodwedd Visio ei gwneud yn ofynnol bod Microsoft Visio 2003neu mwy newydd yn cael ei osod ar y cyfrifiadur.

I fewnforio eich lluniau i mewn i Visio ABACUS

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Ffeil | Newydd a dethol O Visiooddi wrth y deialog sy'n ymddangos a chliciwch OK.

Nodyn

Os ydych yn dymuno i fewnforio i mewn i brosiect ABACUS bresennol yna naill ai de-gliciwch y Cydrannau nôd o fewn Pensaernïaeth, neu de-gliciwch elfen unigol o fewn Pensaernïaeth ac yna dewiswch Mewnforio | O Visio.

3. Pori ar gyfer y ffeil Visio ydych yn dymuno i fewnforio.

Nodyn

Isod ceir rhai rheolau neu arferion a argymhellir wrth adeiladu (neu addasu) yn MS Visio gan dynnu ar gyfer mewnforio i mewn i ABACUS syml.

1. Mae angen i'r llinellau neu gysylltiadau i fod cysylltwyr gwirioneddol, NID siapiau.

· Fel arall, bydd ABACUS unig yn eu mewnforio fel cydrannau ac felly ni fyddant yn cael eu "hatodi" at unrhyw beth.

· Os oes angen i wneud rhywfaint o llwybro "call" (hy ar wahân llinell syth) yna defnyddiwch y cysylltydd Dynamic ar y stensil Siapiau Sylfaenol, bydd ABACUS mewnforio y pwyntiau llwybro / angor mân.

· Ceisiwch osgoi defnyddio'r "rhwydwaith Ring" a "Ethernet" siapiau gan y stensil y Rhwydwaith a'r Peripherals sy'n caniatáu llawer o gydrannau i fod yn "gysylltiedig" iddo. Er ein bod yn mewnforio y atodiadau iawn cyn gysylltiadau mae'r siâp gwreiddiol yn dal i "ehangu" i adlewyrchu'r atodiadau. Defnyddiwch wahân yn "both / bws" siâp ar wahân (heb y cysylltydd "coesau") ac yna cysylltu pob cydran benodol at y canolbwynt / bws gyda cysylltwyr ar wahân.

· Os linell neu gysylltiad ymddwyn fel siâp, dde chlecia arni ac ewch i 'Fformat | Ymddygiad ... 'ac yn gwneud yn siŵr bod arddull Rhyngweithio wedi ei osod i Linell (1-dimensiwn).

2. Mae angen y cydrannau fod yn siapiau NID cysylltwyr.

· Fel arall, bydd ABACUS unig yn eu mewnforio fel cysylltiadau ac yn unol â hynny, bydd yr holl wybodaeth siâp yn cael ei golli.

· Os cydran yn ymddwyn fel connector, dde chlecia arni ac ewch i 'Fformat | Ymddygiad ... 'ac yn gwneud yn siŵr bod arddull Rhyngweithio wedi ei osod i Box (2-ddimensiwn).

3. Mae angen ynghlwm wrth siapiau, NID fel y bo'r angen o gwmpas yn y cefndir y tu ôl i'r siâp yn dod i ben cysylltydd.

· Os na fyddwch yn cysylltu y cysylltwyr i'r siapiau yna ABACUS Nid oes ffordd o wybod eich bod yn bwriadu i osod y cysylltydd a roddwyd i'r siâp / cydran ac yn unol â hynny bydd yn gadael ar ddiwedd un y cysylltiad heb ynghlwm.

4. Dylai labeli ar gyfer siapiau fod (lle bo modd) y label testun inbuilt ar gyfer ffurf, NID blwch testun ar wahân ar y lluniad.

· Bydd blychau testun ar wahân yn cael eu mewnforio gan ABACUS fel elfennau ynddynt eu hunain ac er y gallwch gyfuno'r "label" elfen gyda'r elfen go iawn yn ABACUS, neu dim ond newid y "label" cydran i siâp freeform (hy nid yn elfen ei hun) mae'n well osgoi camau hyn.

5. Defnyddiwch yr un siâp sylfaenol ar gyfer pob enghraifft o'r un math, PEIDIWCH bod yn ddiog ac yn defnyddio petryal weithiau a blwch eraill o wahanol stensiliau siâp.

· ABACUS defnyddio'r siâp sylfaenol a'i liw sylfaenol i adnabod y mathau o gydran a chysylltiad unigryw yn y llun, felly yn "petryal coch" a "blwch coch" yn cael ei fewnforio fel dau fath cydran ar wahân. Gall y mathau hyn cydran yn cael eu huno mewn ABACUS ond mae'n well osgoi camau hyn.

6. Yn gyfan gwbl grynhoi siapiau "plant" yn eu "rhieni", PEIDIWCH â gadael iddynt hongian dros yr ymyl.

· Bydd ABACUS canfod unrhyw siâp sy'n cael ei crynhoi yn gyfan gwbl o fewn siâp arall fel plentyn y rhiant felly gwnewch yn siŵr y siâp cyfan, gan gynnwys y rhan label, yn amgaeedig.

7. PEIDIWCH gosod siâp gorgyffwrdd dau siapiau eraill.

· Os siâp yn gorgyffwrdd dau siapiau eraill, boed yn "grwpio" / petryal cefndir neu fel arall, bydd yn cael ei fewnforio drwy ABACUS fel cydran sy'n blentyn o naill na'r llall siapiau gorgyffwrdd ond cyn gynted ag y byddwch yn dewis y gydran yn offeryn darlunio ABACUS ' , oherwydd y top-chwith yn y cydrannau gyfeirio pwynt, bydd yn dod yn blentyn y chwith gorgyffwrdd siâp / cydran.

8. Ceisiwch leihau'r defnydd o nodiadau testun ar y lluniad gan y bydd y rhain yn cael eu mewnforio fel elfennau ynddynt eu hunain a bydd angen eu trosi i siapiau freeform yn ABACUS. Meddyliwch am a ydynt yn wir yn enw elfen neu gysylltiad sy'n bodoli eisoes.

9. Tra ABACUS cefnogi cyfoethog / siapiau lliw / seiliedig ar fector-, ceisiwch leihau'r defnydd o bitmaps, siapiau tramor a metaffeiliau gwell ar gyfer siapiau fel ABACUS yn ei wneud ar hyn o brydNicefnogi'r mathau hyn. Byddant yn cael eu mewnforio fel petryalau gwyn syml.

10. Ceisiwch osgoi dychwelyd cerbyd (sifft-elw) mewn labeli fel y maent yn cael eu mewnforio a'u dangos fel cymeriad arbennig "[]" yn ABACUS am yr enw gydran.

11. Ceisiwch leihau'r gwahanol liwiau sy'n cael eu defnyddio ar gyfer siapiau o'r un math. Fel y soniwyd uchod, siâp lliw sylfaen a sylfaen unigryw nodi mathau gydran a chysylltiad felly mae'r amrywiad mwy ceir y mwyaf o uno ac atgyfnerthu y bydd angen ei wneud ar ôl mewnforio yn ABACUS.

12. Byddwch yn ofalus gyda siapiau lenwi oherwydd os siâp yn cael ei lenwi yr holl ffordd at y corneli, yna liwio yn ddiweddarach yn ABACUS fydd yn cael unrhyw effaith.

13. Ar gyfer siapiau sy'n seiliedig llinell-gymhleth rhaid i chi ddefnyddio polygon sy'n cael ei greu drwy gael llinellau sy'n dechrau lle mae'r un blaenorol yn gorffen, ac yna yn y pen draw yn mynd yn ôl i'r man cychwyn. Os dymunir, gallwch ddefnyddio deunydd llenwi a llinell led i wneud y polygon yn edrych fel 'saeth' neu beth bynnag siâp ydych ei eisiau.

14. Sicrhewch fod y ID siapiau mewn MS Visio yn ystyrlon nid dim ond Shape.xx. Mae hyn yn eu golygu gan ddefnyddio de-gliciwch 'Dangos Shapesheet' sydd ar gael yn y modd datblygwr MS Visio (alluogi drwy Tools | Options yn MS Visio).

15. Ellipses a arcauo fewn siapiauyn cael eu cefnogi mewn ABACUS ond nid nurbs ac splines yn cael eu cefnogi ar hyn o bryd.

16. Sicrhewch fod y siâp cyfan yn cael ei grwpio yn MS Visio neu bydd yn cael ei fewnforio fel sawl elfen / math.

17. Ceisiwch leihau'r defnydd o siapiau cylchdroi o fewn subshapes gan y byddant weithiau nid eu mewnforio yn gywir.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Poblogi eich pensaernïaeth o Mynediad | Poblogi eich pensaernïaeth o Excel


Poblogi eich pensaernïaeth o Microsoft Excel

Navigation: poblogi eich pensaernïaeth> poblogi o gynhyrchion Microsoft>

Poblogi eich pensaernïaeth o Microsoft Excel

Anfon sylwadau ar y pwnc hwn.

Gallwch fewnforio eich pensaernïaeth o daenlen Excel (xls neu .xlsx file). Mae'r mewnforiwr Excel yn eich galluogi i fapio rhestrau o gydran a chysylltiadau â mathau, safonau, eiddo ac eiddo safonol trwy ddewis y colofnau yn eich taenlen sy'n cynnwys y data perthnasol.Fodd bynnag mae'n dechneg mwy datblygedig na'r ymagwedd a argymhellirar gyfer mewnforio o MS Excel sydd trwy catalogau fel y disgrifiwyd yma .

Nodyn

Y nodwedd Mewnforio o / Allforio i Excel yn mynnu bod Microsoft Excel 2003neu mwy newydd yn cael ei osod ar y cyfrifiadur.

Prif swyddogaeth y Mewnforiwr Excel yw eich galluogi i ddiffinio ffeil cyfluniad (hy y strwythur hierarchaidd eich model pensaernïol). Mae'r siopau ffeil cyfluniad mapio arbed yn flaenorol o ffeil Excel i ffeil ABACUS. Unwaith y diffinnir, y ffeil cyfluniad arbedir yn cael ei ddefnyddio yn ddiweddarach ar gyfer mewnforio pellach o ac allforio i ffeiliau .xls.

Nodyn

Mae'r camau a ddangosir yn yr adrannau isod yn benodol ar gyfer defnyddwyr sydd eto i ddiffinio ac arbed ffeil cyfluniad ac yn mewnforio o excel am y tro cyntaf. Mae'n rhaid i chi greu a chadw ffeil cyfluniad i ddefnyddio'r allforio i ragori swyddogaeth.

I fewnforio taenlen Excel i mewn ABACUS

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Ffeil | Newydd a dewiswch From Exceloddi wrth y deialog sy'n ymddangos a chliciwch OK.

Nodyn

Os ydych yn dymuno i fewnforio i mewn i brosiect ABACUS bresennol yna naill ai de-gliciwch y Cydrannau nôd o fewn Pensaernïaeth, neu de-gliciwch elfen unigol o fewn Pensaernïaeth ac yna dewiswch Mewnforio | O Excel.

3. Y Spreadsheet Mewnforio ExcelBydd ffenestr yn cael ei arddangos

Mewnforio Excel Spreadsheet Ffenestr

4. Cliciwch y Agor Ffeil Excelicon a phori ar gyfer y ffeil Excel ydych yn dymuno i fewnforio.

5. Dewiswch y Taflen waithydych yn dymuno i fewnforio o'r blwch a ollyngir i lawr.

Nodyn

Ar ôl agor eich ffeil Excel, gallwch ddefnyddio'r Rhagolwg Datatab i weld y colofnau a 25 rhesi cyntaf eich taenlen. O'r dudalen hon gallwch gael hangen i lenwi'r rhifau golofn y Cydrannauac Cysylltiadautab.

Gallwch hefyd ddewis a ydych am i gydrannau mewn taenlen Excel i gael ei mewnforio gyda sensitifrwydd achos. Yn syml, ticiwch y Mewnforio gyda sensitifrwydd achosdewis (yn ddiofyn hwn yn cael ei dicio bob amser) a bydd y daenlen yn cael ei fewnforio yn unol â hynny.

Sampl Excel Ffeil

Nodyn

Yn yr enghraifft hon, byddwn fewnforio Seilwaith syml a Phobl Pensaernïaeth o'r data Excel a ddangosir yn y screenshot uchod. Bydd cysylltiadau yn cael eu gwneud rhwng "Mae pobl Cyfrifol" a'r "Gweinyddwyr" bod y bobl hynny gweinyddu.

I lenwi'r tab Cydrannau

Mae'r adran hon ar gyfer diffinio mathau cydran a'r strwythur hierarchaidd ar gyfer y ffeil cyfluniad.

1. Dewiswch y Cydrannautab. Ail-enwi y ID Settrwy tra phwysig y (Null)gwerth

Nodyn

Mae'r nodwedd hon yn eich galluogi i ddiffinio hollol wahanol Setiauar gyfer cydrannau swyddogaethol ar wahân. Fel y dangosir yn y screenshot isod, efallai y byddwch am i wahaniaethu eich cydrannau Isadeiledd oddi wrth eich gydrannau Pobl. Os oes perthynas (cysylltiadau) rhwng y setiau gwahanol o gydrannau, gallant gael eu diffinio o dan y Cysylltiadautab. Yn nes ymlaen yn yr enghraifft hon, byddwn yn diffinio cysylltiadau o fath "Yn Gweinyddu" rhwng y Seilwaith a Phobl Setiau.

Gallwch hefyd ddewis a ydych am ychwanegu lefel-uchaf Grwpiocydran ar gyfer yr holl elfennau'r set. Yn syml, ticiwch y Grŵp Dan Set IDdewis (yn ddiofyn hwn yn unticked) a bydd y daenlen yn cael ei fewnforio yn unol â hynny.

Pennu Set ID

2. Unwaith y bydd y Setiauwedi eu diffinio yn dewis y Gosodrydych am ei boblogi ac ehangu drwy glicio ar y [+]llofnodi.

3. Dewiswch Lefelau Cydrannau yn Set hwno'r rhestr estynedig.

4. Y Hierarchaeth Cydran Setiau: Set IDBydd ffenestr yn ymddangos ar gyfer hynny Gosod.

Cydran Hierarchaeth a Gwerthoedd Pennu (ID Set: Isadeiledd)

5. Ail-enwi y Rhif Lefelcolofn trwy tra phwysig y (Null)gwerth.

Nodyn

Y Rhif Lefelcolofn yn eich galluogi i aseinio hierarchaeth i'ch cydrannau. Mae pob lefel yn cyfateb i haen o fewn eich pensaernïaeth lle y lefel gyntaf yw'r uchaf mwyaf rhiantlefel. Er enghraifft, Rhif Lefel "1" yn cyfateb i'r haen hierarchaidd topmost, Rhif Lefel "2" yw'r plentyn Rhif Lefel "1" ac yn y blaen.

6. Dewis a aseinio y golofn perthnasol o'r daenlen Excel i bob Rhif Lefelgan fynd i mewn iddo o dan y Colofn Cydrancolofn.

Nodyn

Gallwch ddewis eithrio rhai rhesi nad ydych am i gael eu cynrychioli yn eich pensaernïaeth. Gall y rhain fod penawdau colofn, rhesi gwag, ac ati I eithrio rhesi yn defnyddio'r Rhesi i Wahardd:blwch testun ger y gornel dde uchaf y ffenestr. Yn yr enghraifft hon, rydym wedi eu heithrio rhes 1 oherwydd ei fod yn cynnwys ein penawdau colofn.

7. Gallwch ddewis i ychwanegu disgrifiadau at eich cydrannau trwy drosysgrifo y (Null)gwerth yn y Disgrifiad Colofn.

Nodyn

Mae'r disgrifiad hwn yn beth fydd yn ymddangos yn ABACUS o dan y Eiddo Cyffredinoladran | Disgrifiadmaes.

8. Os golofn taenlen a roddwyd ganddo fwy nag un gydran pob cell (cofnodi gan ddefnyddio Alt-Enter neu'r CHAR (10) gorchymyn) yna ticiwch y blwch oddi tano Trin Llinellau Newydd Fel Cydrannau ar wahân. Bydd pob llinell yn cael ei fewnforio fel cydrannau ar wahân.

Tip

I fewnforio yn 'matrics' allan o gasgliad o golofnau, lle mae 'X' mewn cell 'matrics' a roddir (celloedd B2: D2 yn dweud) yn awgrymu bod y gydran a bennir gan y rhes (mewn cell A2 yn dweud) wedi'i gysylltu â'r gydran a bennir gan y golofn 'pennawd' (mewn rhes 1 dyweder), gall fformiwla syml yn cael ei ddefnyddio. Rhowch y fformiwla ganlynol ar gyfer pob rhes mewn colofn y tu hwnt i'r celloedd matrics (colofn F dweud); = IF (B2 = "", "", B $ 1 & CHAR (10)) ac OS (C2 = "", "", C $ 1 & CHAR (10)) ac OS (D2 = "", "", D $ 1 & CHAR (10)). Yna sefydlu cysylltiad a osodwyd fel y disgrifir isod rhwng y cydrannau a bennir gan y rhes (yng ngholofn A dweud) a'r rhai a ddisgrifir gan y fformiwla hon (yng ngholofn F yn dweud). Byddwch yn siwr i edrych ar y Trin Llinellau Newydd Fel Cydrannau ar wahânopsiwn pan fydd y cydrannau o'r fformiwla yn cael eu mewnforio. Ar gyfer mewnforio matrics mwy datblygedig, gan gynnwys penawdau gyda haenau lluosog o hierarchaeth neu gelloedd gyda gwahanol gwerthoedd na dim ond 'X' plaen, cysylltwch â Cymorth Avolution .

9. Llenwch y ngweddill y colofnau yn ôl yr angen.

Nodyn

Gallwch ddewis cael y math o resi golofn drwy dicio'r blwch ticio o dan y Cael Math O Colofncolofn a mynd i mewn i'r golofn berthnasol o'r daenlen Excel o dan y Cydran Math Gwerth neu Colofncolofn. Bydd hyn yn mewnforio pob cydran yn y golofn honno ac yn eu gosod i'r math a ddiffinnir yn y golofn. Fel arall, ac fel gyda'r llun sgrin uwchben ac o dan, byddwch yn gallu dewis defnyddio enw math penodol / a ddiffiniwyd ymlaen llaw gan fynd i mewn yr enw math o dan y Cydran Math Gwerth neu Colofncolofn a gwneud yn siŵr y blwch britho heb ei gwirio.

Cydran Hierarchaeth a Gwerthoedd Pennu (Set ID: Pobl)

Nodyn

Yn yr enghraifft hon rydym yn dymuno cael ein rhwydweithiau a grwpiau o bobl ar lefel 1 o'r Pensaernïaeth. Ar lefel 2, rydym yn dymuno cael ein gweinyddion a phobl sy'n gyfrifol am weinyddu gweinyddion hynny. Y Cydrannautab wedi ei llenwi allan yn unol â hynny, fel y dangosir yn y ddwy screenshots uchod. Yn y screenshot cyntaf uchod, rydym wedi diffinio'r 1 (grwpio rhwydwaith) a lefel 2 (gweinydd) cydrannau lefel gyfer y Seilwaith Gosod. Ac yn y screenshot yn union uwchben yr ydym wedi diffinio'r lefel 1 (pobl grwpio) a 2 (yn gyfrifol bobl) cydrannau lefel gyfer y Bobl Gosod.

Fel arall, ar gyfer y PoblSet, yn hytrach na defnyddio colofn C fel grwpio Pobl, gallem fod wedi defnyddio'r Grŵp Dan Set IDopsiwn ar ben tab cydrannau lefel ac yna dim ond mynd i mewn is-lefel un pobl o Ngholofn D. Mae hyn yn cael ei ddangos yn y screenshot isod.

Cydran Hierarchaeth a Neilltuo Gwerthoedd gan ddefnyddio opsiwn Grŵp Dan Set ID (Set ID: Pobl)

10. Unwaith y bydd y cydrannau wedi cael eu nodi, dewiswch y lefel cydran rydych am ei boblogi eiddo a / neu safonau ac ehangu drwy glicio ar y [+]llofnodi.

11. Dewiswch Priodweddau Cydrannau ar Lefel hwnneu'r Safonau Cydran ar Lefel hwno'r rhestr ehangu ac boblogi'r colofnau perthnasol yn ôl yr angen.

Poblogi Cydrannau

Nodyn

Priodweddau Cydrannau ar Lefel hwnyn eich galluogi i ddiffinio eiddo ar gyfer cydrannau ar y lefel a ddewiswyd. Safonau Cydran ar Lefel hwnyn eich galluogi i ddiffinio safonau a'u priodweddau safonol ar gyfer cydrannau ar y lefel a ddewiswyd.

12. Camau Ailadrodd 2-11nes bod yr holl lefelau cydrannol wedi cael eu phoblogaeth gyfer pob diffiniedig Setiau. Defnyddiwch y saeth yn ôl ger y gornel dde uchaf y ffenestr i symud yn ôl i'r Setiauyr ydych ddiffinnir gynharach.

I lenwi'r tab Connections

Mae'r adran hon ar gyfer diffinio mathau cysylltiad a'r strwythur hierarchaidd ar gyfer y ffeil cyfluniad.

1. Dewiswch y Cysylltiadautab. Ar gyfer pob set o gysylltiadau yn rhaid i chi adnabod y gydran Gosodeich bod eisiau bod y cydrannau ffynhonnell a'r gydran Gosodydych am fod y cydrannau gyrchfan.

2. O dan y Ffynhonnell Cydran Set IDmynd i mewn i'r Gosodenw sy'n cyfateb i'r Gosoda ddiffinnir yn gynharach yn y Cydrannautab. O dan y Ffynhonnell Cydran Rhif Lefelmynd i mewn i'r rhif sy'n cyfateb i'r lefel cydran ydych am gysylltu yn y ffynhonnell ddiwedd y cysylltiad.

3. Nawr ddewis pa cydran grŵp ar ddiwedd cyrchfan y cysylltiad. O dan y Cyrchfan Cydran Set IDmynd i mewn i'r Gosodenw sy'n cyfateb i'r Gosoda ddiffinnir yn y Cydrannautab. O dan y Cyrchfan Cydran Rhif Lefelmynd i mewn i'r rhif sy'n cyfateb i'r lefel cydran ydych am gysylltu ar ddiwedd cyrchfan y cysylltiad.

Nodyn

Yn yr enghraifft hon rydym yn dymuno cysylltu â'r bobl sy'n gyfrifol am weinyddu'r gweinyddion i'r gweinyddwyr y maent yn gweinyddu. Roedd y bobl sy'n gyfrifol yn cael eu diffinio yn y Bobl Gosodfel lefel 2 cydrannau tra bod y gweinydd wedi ei ddiffinio yn y Seilwaith Gosodfel lefel 2 cydrannau. Y Cysylltiadautab wedi ei llenwi allan yn unol â hynny, fel y dangosir yn y screenshot isod.

Cysylltiadau Tab Rhan 1 o 2

4. Os ydych yn sgroliwch i'r dde, fe welwch yr opsiynau ychwanegol ar gyfer mewnforio eich cysylltiadau. Cael Math O Colofnac Cysylltiad Math Gwerth neu Colofngweithio yr un ffordd ag ar gyfer y Cydrannautab.

5. Os bydd y Ffynhonnell Cydran Set IDac mae'r Ffynhonnell Cydran Rhif Lefelyr un fath â'r Cyrchfan Cydran Set IDac mae'r Cyrchfan Cydran Rhif Lefel(Er enghraifft, os ydych yn cysylltu â'r un mathau gydran, megis gwneud cysylltiadau o weinyddion i weinyddion eraill) yna mae angen i chi gael golofn arall yn eich taenlen sy'n cynnwys enwau'r rhai a gweinyddion dro ar ôl tro. Yn y sefyllfa hon y byddech yn rhoi'r daenlen colofn yn y Cyrchfan dro ar ôl tro yng Ngholofncolofn. Os ydych wedi rhoi mwy nag un gydran cysylltiedig pob cell yn y golofn honno taenlen yna ticiwch y blwch oddi tano Trin Llinellau Newydd Fel Cydrannau ar wahân.

Cysylltiadau Tab Rhan 2 o 2

6. Unwaith y bydd y cysylltiadau wedi eu nodi dewiswch y cysylltiad rydych am ei boblogi eiddo a / neu safonau ac ehangu drwy glicio ar y [+]llofnodi.

7. Dewiswch Eiddo i'w rhain Cysylltiadauneu Safonau ar gyfer hyn Cysylltiadauo'r rhestr ehangu ac boblogi'r colofnau perthnasol yn ôl yr angen.

Nodyn

Eiddo i'w rhain Cysylltiadauyn eich galluogi i ddiffinio eiddo ar gyfer y grŵp cysylltiad a ddewiswyd. Safonau ar gyfer hyn Cysylltiadauyn eich galluogi i ddiffinio safonau a'u nodweddion safonol ar gyfer y grŵp cysylltiad a ddewiswyd.

8. Camau Ailadrodd 2-7nes bod yr holl grwpiau cysylltiad wedi eu diffinio.

9. Pan fyddwch wedi gorffen diffinio'r grwpiau cysylltiad, cliciwch ar y GorffenBydd y botwm a'ch pensaernïaeth yn cael eu creu o'r ffeil Excel mewnforio. Mae'r enghraifft uchod yn arwain at bensaernïaeth a ddangosir yn y screenshot isod.

Pensaernïaeth Sampl Fewnforir o Excel

10. Nawr arbed cyfluniad mapio i ffeil drwy glicio ar y Save Ffurfweddiadicon. Gall eich ffurfweddiad arbedwyd yn cael ei adfer yn ddiweddarach gan glicio ar y Agor Configurationicon ger y gornel chwith uchaf y ffenestr.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Poblogi eich pensaernïaeth o Mynediad | Poblogi eich pensaernïaeth o Visio


Poblogi eich pensaernïaeth o Microsoft SharePoint

Navigation: poblogi eich pensaernïaeth> poblogi o gynhyrchion Microsoft>

Poblogi eich pensaernïaeth o Microsoft SharePoint

Anfon sylwadau ar y pwnc hwn.

Gallwch Cydamseru eich pensaernïaeth gydaMicrosoft Rhestrau SharePoint. Cydamseru yn golygu naill ai chreu rhestrau SharePoint newydd (a'u colofnau) i fathau ABACUS, eu priodweddau ac atodiadau, neu mapio rhestrau SharePoint cyfredol (a'u colofnau) i fathau ABACUS, eu priodweddau ac atodiadau, yna naill ai anfon cynnwys o ABACUS i SharePoint neu SharePoint i ABACUS.

Nodyn

Y SharePoint Sync nodwedd yn gofyn boda Microsoft SharePoint, 2010, 2013neu SharePoint Ar-lein safle ar gael i gysylltu a cydamseru â.Er y gall y nodwedd SharePoint Sync greu rhestrau (gyda cholofnau) ar safle SharePoint o unrhyw brosiect ABACUS, gall Avolution hefyd ddarparu gwahanol dempledi safle SharePoint i gefnogi fframweithiau safonol (ee TOGAF, ArchiMate, ITIL etc) felly cysylltwch Cymorth Avolution os ydych angen gallu hwn.

I creu rhestr SharePoint newydd a map i cydran neu gysylltiad fath ABACUS

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Offer | SharePoint Sync.

3. Cliciwch y Mapio Newyddbotwm a ymgom Mapio SharePoint fel y dangosir isod yn ymddangos.

4. Rhowch yr URL Safle, Enw Defnyddiwr a'ch Cyfrinair ar gyfer y safle SharePoint a chliciwch Cysylltu.

Nodyn

A SharePoint dilys 'admin' neu fod angen cyfrif 'cyfrannwr' i cydamseru o ac i gyfrif yn 'darllenwr' SharePoint a bydd ond yn caniatáu i cydamseru o SharePoint.

5. Dewiswch y ABACUS cydran neu gysylltiad fath i fapio oddi wrth y Dewiswch Math Tynnu i lawr.

6. Cliciwch y Ychwanegu Newyddbotwm ac yna ar gyfer pob cydran neu fath gysylltiad agwedd ABACUS ydych yn dymuno i fapio i faes rhestr SharePoint cyfatebol dewiswch eitem yn y panel chwith ac yn y panel cywir nodwch enw'r rhestr SharePoint newydd yn y golofn Rhestr Newydd (dim ond y tro cyntaf) , yna enw'r golofn SharePoint yn y Colofn Enw (neu defnyddiwch y rhagosodiad) a chliciwch Neilltuobob tro.

Nodyn

Fel isafswm er mwyn caniatáu bydd cydamseru y ABACUS EEID, Pensaernïaeth ac agweddau Enw eu mapio yn awtomatig i Nifer SharePoint a dau (2) llinell sengl o destun (aka Testun) colofnau yn y drefn honno. Ni all y rhain fod yn ddadneilltuo. Ar ben hynny, dim ond rhai agweddau ABACUS ei fapio ar hyn o bryd i rai golofnau SharePoint a bydd y Math Colofn tynnu-lawr yn cael ei osod yn awtomatig i'r math golofn SharePoint gofynnol.Sef;

· Llwybr Hierarchaeth ABACUS 'i SharePoint llinellau lluosog o destun (aka Nodyn) golofnau (Noder: SharePoint llinell sengl o destun (aka Testun) colofnau ond yn cefnogi 255 chars felly nid ydynt yn ffafrio),

· Cydrannau Ynghlwm ABACUS 'i golofnau SharePoint-edrych (Noder: Rhaid i fapio eisoes yn bodoli i restr ar gyfer y cydrannau sydd ynghlwm eu hunain),

· Testun a Disgrifiad eiddo ABACUS 'i Sharepoint llinellau lluosog o destun (aka Nodyn) golofnau (Noder: SharePoint llinell sengl o destun (aka Testun) colofnau ond yn cefnogi 255 chars felly nid ydynt yn ffafrio),

· Degol neu Cyfanrif eiddo ABACUS 'i SharePoint Rhif colofnau,

· Eiddo Rhestr ABACUS 'i golofnau SharePoint Dewis (Nodyn: Nid yw SharePoint yn gorfodi'r gwerthoedd ddewis felly nid oes angen y math data Rhestr i gael ei orfodi yn ABACUS),

· ABACUS 'Dyddiad eiddo / Amser i SharePoint llinellau lluosog o destun (aka Nodyn) golofnau (Sylwer: Ni all SharePoint Dyddiad ac Amser colofnau yn cael ei ddefnyddio hyd yn hyn o ganlyniad i gefnogaeth anghyson SharePoint i gylchfa amser lleoliadau / rhanbartholi),

· Eiddo Boolean ABACUS 'i SharePoint Do / Naddo (aka Boolean) colofnau.

Ni all elfen ABACUS Safonau Cysylltiedig cael ei fapio i golofnau rhestr SharePoint hyd yn hyn.

7. Dewiswch Creu Mapio.

I creu mapio newydd rhwng cydran ABACUS neu fath gysylltiad a rhestr SharePoint sy'n bodoli eisoes

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Offer | SharePoint Sync.

3. Cliciwch y Mapio Newyddbotwm a ymgom Mapio SharePoint fel y dangosir isod yn ymddangos.

4. Rhowch yr URL Safle, Enw Defnyddiwr a'ch Cyfrinair ar gyfer y safle SharePoint a chliciwch Cysylltu.

Nodyn

A SharePoint dilys 'admin' neu fod angen cyfrif 'cyfrannwr' i cydamseru o ac i gyfrif yn 'darllenwr' SharePoint a bydd ond yn caniatáu i cydamseru o SharePoint.

5. Dewiswch y ABACUS cydran neu gysylltiad fath i fapio oddi wrth y Dewiswch Math Tynnu i lawr.

6. Dewiswch y rhestr safle SharePoint i fapio oddi wrth y Rhestr Ddethol Tynnu i lawr.

7. Ar gyfer pob cydran neu fath gysylltiad agwedd ABACUS ydych yn dymuno i fapio at ei restr colofn SharePoint gyfatebol dewiswch eitem yn y panel chwith a'r dde yn y drefn honno panel a chlicio Neilltuo.

Nodyn

Fel isafswm er mwyn caniatáu angen synchronization i'r ABACUS EEID, Pensaernïaeth ac agweddau Enw i gael ei fapio i Nifer SharePoint ac yna ar gyfer Pensaernïaeth a Enw naill ai llinell sengl o destun (aka Testun) neu linellau lluosog o destun (aka Nodyn) colofnau yn y drefn honno. Hyd nes y gwneir hynny y botwm Mapio Creu ni fydd yn cael ei alluogi. Ar ben hynny, dim ond rhai agweddau ABACUS ei fapio ar hyn o bryd i rai golofnau SharePoint.Sef;

· ABACUS 'Pensaernïaeth agwedd i linell sengl SharePoint o destun (aka Testun) neu linellau lluosog o destun (aka Nodyn) colofnau (mae hyn yn ofynnol ar gyfer mapio benodol gynnwys fel y disgrifir isod),

· Llwybr Hierarchaeth ABACUS 'i Sharepoint llinell sengl o destun (aka testun) neu linellau lluosog o destun (aka Nodyn) golofnau (Noder: SharePoint llinell sengl o destun (aka Testun) colofnau ond yn cefnogi 255 chars felly bydd unrhyw gymeriadau ychwanegol yn cael ei fyrhau ac felly argymhellir i'w troi at linellau lluosog o destun (aka Nodyn) colofnau yn SharePoint cyn mapio),

· Cydrannau Ynghlwm ABACUS 'i golofnau SharePoint-edrych (Noder: Rhaid i fapio eisoes yn bodoli i restr ar gyfer y cydrannau sydd ynghlwm eu hunain),

· Testun a Disgrifiad eiddo ABACUS 'i Sharepoint llinell sengl o destun (aka testun) neu linellau lluosog o destun (aka Nodyn) golofnau (Noder: SharePoint llinell sengl o destun (aka Testun) colofnau ond yn cefnogi 255 chars felly bydd unrhyw gymeriadau ychwanegol yn cael ei fyrhau ac felly argymhellir i'w troi at linellau lluosog o destun (aka Nodyn) colofnau yn SharePoint cyn mapio),

· 'Degol neu Cyfanrif eiddo i golofnau SharePoint Rhif (Noder.: Gall SharePoint Cyfrifir colofnau yn cael eu defnyddio, fodd bynnag, byddant ond yn gallu cydamseru o SharePoint i ABACUS Mae ceisio cydamseru' ABACUS i 'golofn gyfrifir yn arwain at rybudd yn unol isod) ,

· Eiddo Rhestr ABACUS 'i golofnau SharePoint Choice,

· ABACUS 'Dyddiad eiddo / Amser i SharePoint llinellau lluosog o destun (aka Nodyn) golofnau (Sylwer: Ni all SharePoint Dyddiad ac Amser colofnau yn cael ei ddefnyddio oherwydd cefnogaeth anghyson SharePoint i gylchfa amser lleoliadau / rhanbartholi),

· Eiddo Boolean ABACUS 'i SharePoint Do / Naddo (aka Boolean) colofnau.

Ni all elfen ABACUS Safonau Cysylltiedig cael ei fapio i golofnau rhestr SharePoint hyd yn hyn. Ac ni all Arian SharePoint yn, Person neu grŵp, Hyperlink neu Picture, Tasg Canlyniad, Data Allanol a cholofnau Metadata a Reolir yn cael ei fapio i agweddau ABACUS hyd yn hyn.

8. Dewiswch Creu Mapio.

I Cydamserueich Microsoft Rhestr (au) SharePointi mewn ABACUS

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Offer | SharePoint Sync.

Nodyn

I Cydamseru rhestr SharePoint gydaProsiect ABACUS angen y drwydded defnyddiwr y SharePoint Syncychwanegu-ar allu. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

3. Dewiswch mapio SharePoint presennol (neu mapiadau ddefnyddio Ctrl-glicioneu'r Dewis Popethbotwm) oddi wrth y SharePoint Mapiadaupanelfel y dangosir yn y screenshot sampl uchod. Sylwer: dyma ni yn dangos dim ond y 'Goal (neu Gofyniad)' ABACUS Math cydran mapio i rhestr SharePoint o'r enw Nodau cael eu dewis.

4. Dewiswch y Pensaernïaeth (au) yr ydych am eu sync fodlon ar y Cynnwys Sync o saernïaethpanel fel a ddangosir yn y screenshot sampl uchod. Sylwer: dyma ni yn dangos dim ond y 'Gwirioneddol 2015' pensaernïaeth sy'n cael ei synced.

5. Dewiswch y Sync O SPbotwm.

Nodyn

Os nad yw 'All Saved' y cymwysterau safle SharePoint ar gyfer y mapio (au) a ddewisir yna bydd Mewngofnodi i SharePoint deialog yn ymddangos yn gofyn am y URL Safle, Enw defnyddiwr a / neu Cyfrinair.Rhowch y rhain. Ar ben hynny, bydd cydamseru cynnwys unrhyw mapiadau eraill sydd eu hangen ar gyfer cydrannau sydd ynghlwm / colofnau am-edrych. Bydd unrhyw mapiadau ychwanegol sy'n cael eu cynnwys yn awtomatig yn cael ei ddangos yn yr ymgom yn unol isod.

6. Ar synchronization llwyddiannus, bydd Canlyniadau ymgom SharePoint Sync yn ymddangos fel a ddangosir isod rhestru'r newidiadau ac unrhyw rybuddion. Cliciwch iawn.

I cydamseru o ABACUS i eich Microsoft Rhestr (au) SharePoint

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Offer | SharePoint Sync.

Nodyn

I Cydamseru rhestr SharePoint gydaProsiect ABACUS angen y drwydded defnyddiwr y SharePoint Syncychwanegu-ar allu. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

3. Dewiswch mapio SharePoint presennol (neu mapiadau ddefnyddio Ctrl-glicioneu'r Dewis Popethbotwm) oddi wrth y SharePoint Mapiadaupanelfel y dangosir yn y screenshot sampl uchod. Sylwer: dyma ni yn dangos dim ond y 'Goal (neu Gofyniad)' ABACUS Math cydran mapio i rhestr SharePoint o'r enw Nodau cael eu dewis.

4. Dewiswch y Pensaernïaeth (au) yr ydych am eu sync fodlon ar y Cynnwys Sync o saernïaethpanel fel a ddangosir yn y screenshot sampl uchod. Sylwer: dyma ni yn dangos dim ond y 'Gwirioneddol 2015' pensaernïaeth sy'n cael ei synced.

5. Dewiswch y Sync I SPbotwm.

Nodyn

Os nad yw 'All Saved' y cymwysterau safle SharePoint ar gyfer y mapio (au) a ddewisir yna bydd Mewngofnodi i SharePoint deialog yn ymddangos yn gofyn am y URL Safle, Enw defnyddiwr a / neu Cyfrinair.Rhowch y rhain. Ar ben hynny, bydd cydamseru cynnwys unrhyw mapiadau eraill sydd eu hangen ar gyfer cydrannau sydd ynghlwm / colofnau am-edrych. Bydd unrhyw mapiadau ychwanegol sy'n cael eu cynnwys yn awtomatig yn cael ei ddangos yn yr ymgom yn unol isod.

6. Ar synchronization llwyddiannus, bydd Canlyniadau ymgom SharePoint Sync yn ymddangos fel a ddangosir isod rhestru'r newidiadau ac unrhyw rybuddion. Cliciwch iawn.

Nodyn

Bydd ABACUS diweddaru colofnau SharePoint â gwerthoedd wag hyd yn oed os 'Ei gwneud yn ofynnol bod y golofn hon yn cynnwys gwybodaeth' wedi ei osod i Ie yn SharePoint. Mae hyn oherwydd nad SharePoint yn agored gosodiad hwn yn allanol. Os yw hyn yn cael ei atal, argymhellir bod Dylunydd ABACUS yn gosod y cyfyngiad Angenrheidiol i Gwir a Gorfodol ar gyfer yr eiddo a roddir gan ddefnyddio ABACUS ' cyfyngiad nodwedd .

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Poblogi eich pensaernïaeth o Visio | Poblogi eich pensaernïaeth o Excel


Poblogi eich pensaernïaeth o Microsoft SQL Server

Navigation: poblogi eich pensaernïaeth> poblogi o gynhyrchion Microsoft>

Poblogi eich pensaernïaeth o Microsoft SQL Server

Anfon sylwadau ar y pwnc hwn.

Gallwch fewnforio eich pensaernïaeth o gronfa ddata Microsoft SQL Server. Mae gennych y dewis i ychydig mewnforio y Tablau a Pherthnasoedd mewnforio dim ond y strwythur cyffredinol y gronfa ddata neu Tablau, Rhesi a Pherthnasoedd a fydd yn mewnforio nid yn unig strwythur ond mae'r data yn ogystal effeithiol.

Nodyn

Mae'r From SQL Server nodwedd ei gwneud yn ofynnol bod Microsoft SQL Gweinyddwr 20052008, 2008 R2, 2012 neu 2014yn cael ei osod ar y cyfrifiadur.

I fewnforio eich cronfa ddata SQL Server Microsoft i mewn ABACUS

1. Sicrhewch fod gennych ABACUS ar agor.

2. Dewiswch Ffeil | Newydd a dethol O SQL Serveroddi wrth y deialog sy'n ymddangos a chliciwch OK.

3. Yn yr ymgom Server Mewnforio SQL sy'n ymddangos gosod yr 'MACHINENAME' a gwerthoedd 'SQLINSTANCE' o'r Connection Llinynnol amrywiol a gwerth 'DBNAME' o'r newidyn Gronfa Ddata Enw at eu gwerthoedd cywir fel y dangosir yn y screenshot sampl isod.

4. Gosod y newidyn Gronfa Ddata Enw'r i'r un gwerth ag y newidyn Catalog Cychwynnol a osodwyd yn y cam uchod, fel y dangosir yn y screenshot sampl isod.

5. Gwasgwch y botwm Prawf Cysylltiad a'r Tablau i Mewnforio dylai rhan o'r ymgom yn cael ei llenwi â tablau cronfa ddata sydd ar gael, fel y dangosir yn y screenshot sampl isod.

6. Dewiswch y tablau yr ydych yn dymuno i fewnforio naill ai drwy eu dewis yn unigol neu ddefnyddio'r Gyfan, Dim a botymau Invert ar y dde o'r ymgom.

Nodyn

Dim ond y Tramor Perthnasoedd Allweddol sy'n bodoli rhwng y Tablau eich bod yn dewis a fydd yn cael ei fewnforio.

7. Gan ddefnyddio'r botwm radio Mewnforio Arddull dewiswch pa un a ydych eisiau mewnforio dim ond y Tablau a'r perthnasau rhwng nhw neu'r Tablau, eu Rhesi a'r Perthnasoedd penodol rhwng y Rhesi.

Nodyn

Y dewis cyntaf mewnforion y Tablau fel elfennau o'r 'Tabl' math a'r perthnasoedd rhwng unrhyw ddau Tablau (o'r allweddi tramor) yn cael eu mewnforio fel cysylltiadau o'r 'Tabl Perthynas' math. Mae hwn yn 'ERD' view arddull glasurol o'r tablau system. Yr ail opsiwn mewnforio y Rhesi Tabl fel arwahanol is-gydrannau o'r math 'Tabl Row' gydag eiddo sy'n cyfateb i bob un o'r colofnau / caeau a gyda chysylltiadau rhwng y Rhesi Tabl y 'Tabl Perthynas' math. Ar ben hynny, os oes colofn / cae o'r enw 'Enw' yna mae hyn yn cael ei ddefnyddio i enwi is-cydrannau Tabl Row unigol.

8. Dewiswch y Mewnforio ... botwm.

9. Ar ôl cyfnod byr o amser (gyda bar cynnydd ar gyfer adborth) bydd prosiect ABACUS newydd yn cael eu creu gyda'r Tablau, Rhesi Tabl (os yw'r ail opsiwn ei ddewis yn y cam uchod) a Pherthnasoedd o gronfa ddata Microsoft SQL Server.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Poblogi eich pensaernïaeth llaw | Poblogi eich pensaernïaeth o Visio | Poblogi eich pensaernïaeth o Excel


Ychwanegu eiddo preset i gydran, cysylltiad neu fath

Navigation: poblogi eich pensaernïaeth> Nodweddion>

Ychwanegu eiddo preset i gydran, cysylltiad neu fath

Anfon sylwadau ar y pwnc hwn.

Gall llyfrgelloedd safon eiddo yn cael ei nodi ac yn neilltuo i unrhyw beth arall yn y bensaernïaeth. Mae'r llyfrgelloedd yn cael eu hadnabod fel Safonau. Trwy ddefnyddio Safonau, Dim ond angen i chi gasglu eiddo systemau penodol - y tai safonol eisoes yno.

Er enghraifft, gall y nodweddion perfformiad safonol o Microsoft Windows 2000 yn cael eu cadw felSafonac ei neilltuo i unrhyw gydrannau (Neu gysylltiadau, nid y byddai hynny'n nodweddiadol) gan ddefnyddio'r system weithredu Microsoft Windows 2000.

I ychwanegusafonoli gydran, cysylltiad neu fath

1. Dde-glicioar y gydran / cysylltiad / math.

2. Dewiswch Neilltuo Safon.

3. DewiswchaSafonoddi ar y rhestr.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Newid priodweddau gydran, cysylltiad neu fath | Eiddo Aggregate


Newid priodweddau gydran, cysylltiad neu fath

Navigation: poblogi eich pensaernïaeth> Nodweddion>

Newid priodweddau gydran, cysylltiad neu fath

Anfon sylwadau ar y pwnc hwn.

Eiddo yn nodweddiadol gofynion y system yr ydych yn diffinio, neu ganlyniadau gwerthusiadau ABACUS '. (Pan fydd ABACUS yn perfformio ei gwerthusiadau, mae'n ysgrifennu eiddo yn ôl i'r ffeil.) Mewn geiriau eraill, eiddo yw'r pethau yr ydych yn gwybod am eich system, neu'r pethau rydych yn ei ddefnyddio ABACUS i gael gwybod.

Er mwyn newid y gwerth eiddo gydran, cysylltiad neu fath

1. Cliciwchar y gydran / cysylltiad / math (bydd ei eiddo yn arddangos yn y ffenestr Properties ar y dde).

2. Cliciwchi dynnu sylw at yr eiddo rydych am ei newid.

3. Mathgwerth newydd.

Pwysig

Hefyd, mae llawer o eiddo yn cael eu diffinio gan ddefnyddio Safonau . Trwy newid eiddo o fewnSafon, Rydych nid yn unig yn newid y gwrthrych presennol, byddwch hefyd yn newid y meistr Safon (O dan Safonau arben y goeden). Cyn gwneud hyn, gwiriwch pa gydrannau, cysylltiadau neu fathau eraill yn defnyddio'r Safon, Oherwydd efallai na fydd y newid yn berthnasol iddynt- Gallwch ddefnyddio'r ffenestr Cyfeiriadau ar gyfer hyn.

Tip

Gallwch newid priodweddau cysylltiad o o'r tu mewn i'r gangen Cydrannau y goeden (ac i'r gwrthwyneb). Felly, er enghraifft, os ydych yn edrych ar yr hyn y cysylltiadau yn cael eu ynghlwm wrth gydran, ac rydych yn sylweddoli rhaid i chi newid un, gallwch.

I ychwanegu eiddo newydd at cydran neu gysylltiad (drwy'r math)

Nodyn

Gall eiddo ond yn cael eu hychwanegu at y mathau a'r cydrannau neu gysylltiadau o'r math 'etifeddu' eiddo hynny.

1. Cliciwchar y math (bydd ei eiddo yn arddangos yn y ffenestr Properties ar y dde).

2. Cliciwchar y botwm Add ar frig y ffenestr Eiddo i ychwanegu rhes ar ben y grid eiddo ar gyfer yr eiddo newydd.

3. Ychwanegu Mathar gyfer yr eiddo newydd.

4. Ychwanegu Enwar gyfer yr eiddo newydd.

5. Ychwanegu Gwerth diofynar gyfer yr eiddo newydd.

6. Ychwanegu Unedar gyfer yr eiddo newydd.

7. Gosod y Math Dataar gyfer yr eiddo newydd.

Nodyn

Gall y cae Math Data yn cael ei ddefnyddio i gyfyngu ar werthoedd dilys y gall eiddo gael. Hynny yw; Testun, Cyfanrif, Degol, Dyddiad / Amser, Boolean neu Restr.

o A Testuneiddo yn un sydd â nifer digyfyngiad o gymeriadau ac yn ei hanfod nid oes gan gyfyngiadau ar werth.Os yw gwerth eiddo yn hyperddolen a ffurfiwyd yn gywir (hy Mae angen i URLs i ddechrau gydag un o'r 5llinynnau; http: //, https: //, ftp: //,file:neu \\ ac unrhywDylai mannau yn cael eu cofnodi gyda '% 20') Yna bydd y ddolen yn clickable (drwy ctrl + cliciwch).

o Mae CyfanrifMae'n rhaid i eiddo fod yn rhif cyfan naill ai'n gadarnhaol neu'n negyddola gall gynnwys cyfnod, gofod, collnod neu goma ar gyfer grwpio digid dibynnu ar y Prosiect Gosodiadau rhanbarth o Ffeil | Dewisiadau Prosiect.Mae'r gosodiadau Rhanbarth ac y.Net Dull Long.TryParse yw ddefnyddiwyd i benderfynu ar ddilys CyfanrifGwerthoedd.

o A DegolGall eiddo gynnwys cyfnod neu coma am y symbol degol a gall gynnwys cyfnod, gofod, collnod neu goma ar gyfer grwpio digid dibynnu ar y Prosiect Gosodiadau rhanbarth o Ffeil | Dewisiadau Prosiect.Mae'r gosodiadau Rhanbarth ac y.Net Dull Decimal.TryParse yw ddefnyddiwyd i benderfynu ar ddilys Degol Gwerthoedd.

o A Dyddiad / Amsereiddo yn caniatáu naill ai Dyddiad rhannol neu ran amser, neu'r ddau. Yr Ardallleoliadauac mae'r Net Dull DateTime.TryParse yn cael eu defnyddio'n bennaf i bennu Dyddiad ac / neu Amser werthoedd dilys. Fodd bynnag, mae'r rhan Date os yn berthnasol gofyn am o leiaf y Dydd a Mis (bydd y Flwyddyn cymryd yn ganiataol i fod y flwyddyn gyfredol) neu Mis a Blwyddyn rhannau fod yn ddilys. H.y. Mis Mehefin, Ch3 2010 neu hyd yn oed 2010 annilys. Er y bydd yn amrywio gyda gwahanol leoliadau rhanbarthol, fel arfer gall y rhannau Dydd, Mis a'r Flwyddyn yn cael eu gwahanu gyda bwlch, coma, dash ('-') neu slaes ('/'). Mae'r rhan Diwrnod nodweddiadol yn gyfanrif o 1 i 31. Mae'r rhan Mis yn nodweddiadol cyfanrif 1-12, yn ddilys talfyriad 3 llythyr am y mis (ee Ion, Chwefror, Mawrth) neu enw llawn y mis (ee Ionawr, Chwefror , Mawrth). Mae'r rhan Blwyddyn yn nodweddiadol o 4 digid rif gadarnhaol ond 1, blynyddoedd 2 a 3 digid yn cael eu derbyn yn ôl gosodiadau mewn Rheoli Panel-> Rhanbarthol a Opsiynau- Iaith> Opsiynau- Rhanbarthol> Customise (botwm) -> dyddiad hwnnw-> Calendr. Yn nodweddiadol maent yn cael eu dehongli fel a ganlyn; 0-29 yn cael ei ddehongli fel 2000-2029, mae 30 i 99 yn rhai 1930-1999 a 100-999 fel 100-999. Bydd dyddiadau annilys megis ar 31 Mehefin 2010 ac 31/9/2010 cael eu canfod. Mae'r rhan Time os yn berthnasol yn gofyn am Oriau a Chofnodion rhan ac yn ddewisol yn rhan Eiliad. Fel arfer mae'r Oriau, Cofnodion a Seconds rhannau dewisol yn cael eu gwahanu gyda colon (':') a gall y rhan Seconds ei bennu gyda phwynt degol ('.'). Am ragor o wybodaeth am y ffurfiau dilys os gwelwch yn dda cyfeiriwch at yr adran Sylwadau ar y Net Dull DateTime.TryParse .

Tip

Argymhellir defnyddio o leiaf y 3 llythyr fformat Enw'r mis (hy "Gorffennaf" neu "Gorffennaf") ar gyfer gwerthoedd dyddiad yn hytrach na fformatio rhifiadol (hy "7" neu "07") fel y gwerthoedd hyn, bydd dilysu ar draws y rhan fwyaf o ranbarthau yn dibynnu ar y Prosiect Gosodiadau rhanbarth o Ffeil | Dewisiadau Prosiect.H.y. argymhellir i ddefnyddio "Gorffennaf 15, 2010" yn hytrach na "15/7/2010" neu "2010/07/15". Gyda yr enghraifft hon, "15/7/2010" yn methu dilysu ar gyfer 'Saesneg (Unol Daleithiau)' a "2010/07/15" Byddai methu ar gyfer 'English (United Kingdom)', fodd bynnag, "Gorffennaf 15, 2010" yn pasio ar gyfer ddau.

o A BooleanGall eiddo fod naill ai Gwir neu Gau.Mae'n achos ansensitif mor GWIR neu ANWIR Gellir hefyd ei ddefnyddio bynnag Ie, Na, 1, 0 ayb bydd pob yn methu unrhyw gyfyngiadau eiddo.

o A Rhestreiddo yn caniatáu casgliad o werthoedd a ddiffiniwyd ymlaen llaw, megis Isel | Canolig | Uchel neu Cadw | Adnewyddu | Ail-ddylunio | Ymddeol a'r ystod o werthoedd yn dod o'r cae Uned ar gyfer yr eiddo naill ai fel coma neu bibell '|' gwerthoedd wedi'u gwahanu. Gall yr eiddo gael ei ystyried i fod yn trefnol (Yn hytrach na enwol, egwyl neu gymhareb) oherwydd pan gaiff ei ddefnyddio ar siartiau ac i liwio elfennau ar diagramac 3DS gwerthoedd yn cael eu trin yn syml mewn esgynnol (neu i lawr) gorchymyn. Hynny yw gwerthoedd yn cael eu plotio yn esgynnol (neu i lawr) gorchymyn ar echelinau siart neu ystodau lliw.

8. Gall y math Data cael eu gosod i fod yn Anabl, Rhybuddioddneu Gorfodirdrwy dde-glicio ar y cae Type Data ar gyfer unrhyw pennu heblaw Text, sy'n caniatáu i unrhyw gymeriadau felly ni all byth fod yn anghywir.

9. Gosod y Yn eisiaubaner ar gyfer yr eiddo newydd.

Nodyn

Gall y Maes gofynnol yn cael ei ddefnyddio i nodi a oes angen gwerth i'w gofnodi ar gyfer yr eiddo. Hynny yw na all fod yn wag neu wag. Ffugyw 'r ball ac yn golygu y gall yr eiddo fod yn wag neu wag, Gwiryn golygu y dylai'r eiddo fod â gwerth ac ni all fod yn wag neu wag. Gall y Angenrheidiol gael eu gosod i fod yn Anabl, Rhybuddioddneu Gorfodirdrwy dde-glicio ar y Maes gofynnol os yw wedi cael ei osod i Gwir.

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Ychwanegu eiddo preset i gydran, cysylltiad neu fath | Eiddo Aggregate


Newid gosodiadau Rhanbarth Prosiect yn

Navigation: poblogi eich pensaernïaeth> Nodweddion>

Newid gosodiadau Rhanbarth Prosiect yn

Anfon sylwadau ar y pwnc hwn.

Gwerth eiddo ei gwneud yn ofynnol fformatio penodol mewn rhanbarthau gwahanol i gyd-fynd ag unrhyw Math Data cyfyngiadau ar gyfer Cyfanrif, Degol a Dyddiad / Amser eiddo. Er enghraifft, yn Awstralia degol yn "123,456 phwynt saith wyth naw" ei gynrychioli fel "123,456.789", tra yn yr Almaen byddai'n cael ei represnted fel "123.456,789" ac yn Ffrainc y byddai'n " 123 456,789 ".Yn yr un modd, yn yr Unol Daleithiau "ail o Rhagfyr 1970" yn cael ei gynrychioli fel dyddiad byr fel "1970/12/02" ond yn y Deyrnas Unedig y mae'n ei gynrychioli fel "1970/02/12" ac yng Ngwlad Pwyl fel "1970-1912 -02 ". Yn unol â hynny, i weithio gyda phrosiect ABACUS ar draws rhanbarthau mae angen gosodiad byd-eang y prosiect ABACUS.

I newid lleoliadau Rhanbarth prosiect ABACUS yn

1. Sicrhewch bod gennych File ABACUSagored.

2. Dewiswch Ffeil | Prosiect Opsiynau ... ac oddi wrth y deialog sy'n ymddangos dewiswch y Rhanbarthac cliciwch OK. Noder: Cyfeiriwch at yr adran isod ar gyfer yr ddiffygion rhanbarthol.

Nodyn

Os nad ydych yn gweld y Prosiect Opsiynau ... eitem dewislenyna nid oes gennych y Dylunydd a Gweinyddwr ychwanegusac nad ydych yn gallu newid rhanbarth y prosiect.Hefyd, os oes Rhanbarth cael ei osod (hy y Rhanbarth yn Opsiynau Prosiect yw 'Dim (Rhanbarth System)') yna mae pob MS Windows lleoliadau diwylliant presennol defnyddiwr (hy Gosodiadau Rhanbarthol)yn cael eu defnyddio i ddilysu eiddo.

Diffygion rhanbarth

Mae'r tabl canlynol yn rhestru'r rhagosodiadau ar gyfer pob rhanbarth fel y nodir drwy'r Ffeil | Prosiect Opsiynau ...eitem dewislen.Gweler isod y tabl am restr o'r symbolau a ddefnyddir.

Rhanbarth | Degol Symbol | Grwpio Digid | Arwydd Negyddol | Amser Byr | Amser hir | AM / PM symbol | Dyddiad byr | Hir Dyddiad
Saesneg (Awstralia) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / bbbb | dd MMMM bbbb
English (United Kingdom) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / bbbb | dd MMMM bbbb
Saesneg (Unol Daleithiau) | . | , | - | h: tt mm | h: mm: ss tt | AM | PM | M / d / bbbb | dddd, MMMM dd, bbbb
Ffrangeg (Ffrainc) | , | gofod | - | HH: mm | HH: mm: ss | | | dd / MM / bbbb | dddd d MMMM yyyy
Almaeneg (Yr Almaen) | , | . | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM bbbb
Eidaleg (Yr Eidal) | , | . | - | HH: mm | HH: mm: ss | | | dd / MM / bbbb | dddd d MMMM yyyy
Sbaeneg (Sbaen) | , | . | - | H: mm | H: mm: ss | | | dd / MM / bbbb | dddd, dd 'de' MMMM 'de' bbbb
Saesneg (Canada) | . | , | - | h: tt mm | h: mm: ss tt | AM | PM | dd / MM / bbbb | MMMM-dd-bb
Ffrangeg (Canada) | , | gofod | - | HH: mm | HH: mm: ss | | | bbbb-mm-dd | d MMMM yyyy
Arabeg (U.A.E.) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / bbbb | dd MMMM, bbbb
Arabeg (Saudi Arabia) | . | , | - | hh: mm tt | hh: mm: ss tt | ص | م | dd / MM / yy | dd / MMMM / bbbb
Saesneg (De Affrica) | , | gofod | - | hh: mm tt | hh: mm: ss tt | AM | PM | bbbb / MM / dd | dd MMMM bbbb
Saesneg (Seland Newydd) | . | , | - | h: tt mm | h: mm: ss tt | a.m. | p.m. | d / MM / bbbb | dddd, d MMMM yyyy
Saesneg (India) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd-MM-yyyy | dd MMMM bbbb
Almaeneg (Y Swistir) | . | ' | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | dddd, d. MMMM bbbb
Ffrangeg (Gwlad Belg) | , | . | - | HH: mm | HH: mm: ss | | | d / MM / bbbb | dddd d MMMM yyyy
Dutch (Gwlad Belg) | , | . | - | H: mm | H: mm: ss | | | d / MM / bbbb | dddd d MMMM yyyy
Tsiec (Gweriniaeth Tsiec) | , | gofod | - | H: mm | H: mm: ss | Dop |. LlCO. | d.M.yyyy | d. MMMM bbbb
Daneg (Denmarc) | , | . | - | HH: mm | HH: mm: ss | | | dd-MM-yyyy | d. MMMM bbbb
Groeg (Gwlad Groeg) | , | . | - | h: tt mm | h: mm: ss tt | πμ | μμ | d / M / bbbb | dddd, d MMMM yyyy
Ffindir (Y Ffindir) | , | gofod | - | H: mm | H: mm: ss | | | d.M.yyyy | d. Bbbb MMMM'ta '
Hwngareg (Hwngari) | , | gofod | - | H: mm | H: mm: ss | de |. du. | yyyy.MM.dd. | bbbb. MMMM d.
Iseldiroedd (Yr Iseldiroedd) | , | . | - | H: mm | H: mm: ss | | | d-M-yyyy | dddd d MMMM yyyy
Norwyaidd, bokmål (Norwy) | , | gofod | - | HH: mm | HH: mm: ss | | | dd.MM.yyyy | d. MMMM bbbb
Pwyleg (Gwlad Pwyl) | , | gofod | - | HH: mm | HH: mm: ss | | | bbbb-mm-dd | d MMMM yyyy
Rwsieg (Rwsia) | , | gofod | - | H: mm | H: mm: ss | | | dd.MM.yyyy | d MMMM yyyy 'г.'
Swedeg (Sweden) | , | gofod | - | HH: mm | HH: mm: ss | | | bbbb-mm-dd | 'Ffau' d MMMM yyyy
Korean (Korea) | . | , | - | h tt: mm | tt h: mm: ss | 오전 | 오후 | bbbb-mm-dd | bbbb '년' M '월' d '일' dddd
Hebraeg (Israel) | . | , | - | HH: mm | HH: mm: ss | AM | PM | dd / MM / bbbb | dddd dd MMMM bbbb

Y symbolau canlynol yn cael eu defnyddio i nodi sut dyddiadau ac amseroedd yn cael eu harddangos:

Symbolau Amser |
h | Awr (hh dangos yr awr gyda sero arweiniol)
m | Cofnod (mm dangos y funud gyda sero arweiniol)
s | Yn ail (ss yn dangos yr ail gyda sero arweiniol)
tt | A.C. neu p.m.
h / H | Amser arddangos 12 neu 24 awr
Dyddiad symbolau |
d, dd | Dydd
ddd, dddd | Diwrnod o'r wythnos
M | Mis
y | Blwyddyn

Gweler Hefyd

Poblogi eich pensaernïaeth - Trosolwg | Newid priodweddau gydran, cysylltiad neu fath | Ychwanegu eiddo preset i gydran, cysylltiad neu fath


Eiddo Aggregate

Navigation: poblogi eich pensaernïaeth> Nodweddion>

Eiddo Aggregate

Anfon sylwadau ar y pwnc hwn.

Mae'r llawdriniaeth "Cyfun Priodweddau"Caniatáu i chi ychwanegu gwerthoedd eiddo tebyg at ei gilydd ac yn ysgrifennu (neu ychwanegu) canlyniad i mewn i eiddo yr elfen rhiant ddewiswyd yn. Mae hefyd yn caniatáu i chi i ddiffinio cwmpas cydgasglu ac a ddylid diweddaru priodweddau holl is-elfennau neu beidio.

I eiddo cyfanredol

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Cliciwch y botwm dde ar elfen (pensaernïaeth, cydran neu gysylltiad) lle i wneud y agregu a dewis Eiddo Aggregate.

3. Dewiswch un o'r Dewisiadau Cyfun (Traverse Mae pob Is-Lefelauneu Is-Lefel Unig Uniongyrchol). Os ydych wedi dewis Traverse Mae pob Is-Lefelau, Efallai y byddwch hefyd yn dewis yr opsiwn a ddylid Diweddariad Is-Lefelau.

o Traverse Mae pob Is-Lefelauyn golygu y bydd cwmpas agregu gynnwys yr elfennau ym mhob lefel o dan eich elfen a ddewiswyd.

o Diweddariad Is-LefelauGellir ond gwneud hyn os ydych hefyd wedi dewis yr opsiwn Traverse Mae pob Is-Lefelau. Mae hyn yn golygu tra byddwch agregu eiddo o'r gwaelod i fyny, y canlyniad cyfanswm ar bob lefel hefyd yn cael eu diweddaru i mewn i bob un o'r elfennau cyfatebol.

o Is-Lefel Unig Uniongyrcholgolygu mai dim ond y mhriodweddau elfennau uniongyrchol o dan yr elfen a ddewiswyd yn cael ei agregu.

o Dewiswch Cynnwys SafonPriodweddauos ydych am i'r eiddo a ddiffinnir yn y safonau i gael eu cynnwys. Fel arall, dim ond eiddo unigryw i bob achos cydran yn cael ei ddefnyddio.

4. Dewiswch pa eiddo yr ydych yn dymuno i gydgrynhoi. Maent yn cael eu grwpio i mewn i'w Mathau.

5. Cliciwch y Nesafbotwm.

6. Dewiswch yr opsiwn a ddylid Gwerthoedd Trosysgrifoneu Ychwanegu Gwerthoeddi mewn i'r elfen a ddewiswyd.

o Gwerthoedd Trosysgrifoyn ysgrifennu canlyniadau uniongyrchol i mewn i'r eiddo o'r elfen a ddewiswyd.

o Ychwanegu GwerthoeddBydd ychwanegu'r canlyniadau at yr eiddo presennol yr elfen a ddewiswyd.

Gweler Hefyd

Ychwanegu eiddo preset i gydran, cysylltiad neu fath | Newid priodweddau gydran, cysylltiad neu fath | Gwerthuso eich pensaernïaeth


Dadansoddi eich pensaernïaeth

Navigation: Dadansoddi eich pensaernïaeth>

Dadansoddi eich pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

Unwaith y byddwch wedi eu poblogaeth (ac o ddewis ffug) eich pensaernïaeth, rydych yn barod i ddefnyddio ABACUS i'w ddadansoddi. Trwy ddadansoddi y peth, gallwch benderfynu os bydd eich pensaernïaeth cwrdd â'ch anghenion.

Gallwch ddadansoddi eich pensaernïaeth mewn amrywiaeth o wahanol ffyrdd:

· Diagram

· 3D barn

· siartiau safonol (Cylch, llinell, colofn, bar, ac ati)

· siartiau arfer ( amser ymateb , gofod gallu , plot seren , matrics scatterplot ac siart swigen )

· Pensaernïaeth Diff

Nodyn

Wrth greu diagram, 3D barn, Adroddiad neu siart safonol, mae'r ffenestr dethol elfen safonol yn cael ei ddefnyddio i ddethol elfennau rydych am ei weld.

Gweler Hefyd

Poblogi eich pensaernïaeth | Efelychu eich pensaernïaeth | Y Diagramau Offeryn


Elfen Dewis Safonol

Navigation: Dadansoddi eich pensaernïaeth>

Elfen Dewis Safonol

Anfon sylwadau ar y pwnc hwn.

Wrth greu diagram, 3D barn, Adroddiad,siart safonolneu redeg efelychiad, Y ffenestr dewis elfen safonol yn cael ei ddefnyddio i ddethol elfennau yr ydych am i ddadansoddi / golygfa.

Ffenestr Elfen Dewis Safonol

Pulldowns

· Hidlo yn ôl ViewBydd cynnwys yr elfens o safbwynt arbed yn flaenorol (hy Diagram, Siart, 3D). Yn y modd hwn gallwch berfformio cymhleth 'ymuno' ymholiadau trwy drin farn arall fel 'ymholiad' achub.

Blychau ticio

· Dangos LefelauGrŵp ewyllys yr elfen yn unol â lefel y maent yn digwydd yn y goeden. Lefel 1 yw'r mwyaf lefel uchaf.

· Dangos Mathauewyllys grŵp yr elfennau yn ôl y mathau eu bod.

· Rhieni a ddewiswydBydd cynnwys y rhiant elfennau o unrhyw elfennau dethol. Yn y ffordd hon, gallwch sicrhau y bydd dim ond yr hierarchaeth uchod unrhyw blant yn cael eu cynnwys ar gyfer "gwaelod i fyny" dethol.

· Mae plant o ddewisBydd yn cynnwys elfennau o unrhyw elfennau dewis y plant. Yn y ffordd hon, gallwch sicrhau y bydd dim ond yr hierarchaeth isod unrhyw rhieni yn cael eu cynnwys ar gyfer "o'r brig i lawr" dethol.

· Enw Gemau Werthyn cynnwys dim ond yr elfennau hynny sydd â Enw sy'n cynnwys y llinyn penodol (Noder: Caniateir nod-chwilwyr (hy a *) gellir ei ddefnyddio?). Yn y modd hwn, gallwch yn ffurfio gofyniad "semantig".

· Mae gan Math o Eiddo / Enw / Gwerthyn cynnwys dim ond yr elfennau hynny sydd â Math o Eiddo, Enw a Gwerth cynnwys y llinyn a nodir naill ai'n uniongyrchol ar yr elfen neu ar ei Safonau (Sylwer:?.? Caniateir nod-chwilwyr (hy a *) gellir ei ddefnyddio Ee * yn y maes Gwerth bydd rhoi'r holl elfennau sydd â Gwerth heb fod yn wag am Eiddo roddir). Yn y modd hwn, gallwch yn ffurfio gofyniad "semantig".

· Mae gan Safonolyn cynnwys dim ond yr elfennau hynny sydd â enw safonol sy'n cynnwys y llinyn penodol (Noder: Caniateir nod-chwilwyr (hy a *) gellir ei ddefnyddio ee HP * yn rhoi pob elfen gydag o leiaf un Safon gan ddechrau gyda'r H a P llythyrau?.). Yn y modd hwn, gallwch yn ffurfio gofyniad "semantig".

· Cydrannau / Cysylltiadau ynghlwm wrth ddewisbydd yn cynnwys unrhyw elfennau sydd ynghlwm wrth y rhai sydd wedi cael eu dewis. Yn y modd hwn gall "galw-coeden" neu "effaith-ddadansoddiad" yn cael eu dewis.

Nodyn

Os oes gennych ddau Dangos Lefelauac Dangos Mathaua ddewiswyd yna gallwch ddewis cael y lefelau sioe goeden gyntaf neu fathau gyntaf gan y botwm a fydd yn ymddangos uwchben y ddwy blychau ticio.

Tip

Unwaith y bydd eitem yn cael ei ddewis yn y Ffenest Elfen Dewis Safonol, ni fydd yn ddarostyngedig i unrhyw newidiadau hidlo pellach nes iddo gael ei ddad-ddethol. Gan nad oes unrhyw ffordd frodorol i chwilio am ddwy set wahanol o elfennau ar yr un pryd (ee Cydrannau â Safon A NEU Safon B), gallwch chwilio gyntaf am un set, dewiswch y cydrannau a ddymunir, ac yna perfformio chwiliad ail ar gyfer yr ail set .

Botymau

· Allyn dewis yr holl elfennau.

· Gwrthdroideselects holl elfennau a ddewisir ar hyn o bryd ac yn dewis bawb na chafodd eu dethol.

· Dimdeselects holl elfennau.

· Ychwanegu Filteryn dewis y cynnwys sy'n deillio o'r lleoliadau hidlo gyfredol ac yn caniatáu dewis o gynnwys ychwanegol yn effeithiol yn AND neu YMUNO hidlo.

Gweler Hefyd

Dadansoddi eich pensaernïaeth


Edrych diagram 3D

Navigation: Dadansoddi eich pensaernïaeth> diagramau 3D>

Edrych diagram 3D

Anfon sylwadau ar y pwnc hwn.

ABACUS caniatáu i chi weld eich pensaernïaeth fel golygfa 3D lle mae eiddo cydran a chysylltiad yn gysylltiedig â lliwiau, siapiau, a maint.

I weld golygfa 3D ar eich pensaernïaeth

1. Sicrhewch fod gennych agor y ffeil ABACUSyn cynnwys eich pensaernïaeth poblog.

2. Ehangu'r Barncangen o'r goeden.

3. Ehangu'r 3Dcangen o'r goeden.

4. Double-glicio y delweddu eich bod am agor.

- Neu -

1. Sicrhewch fod gennych agor y ffeil ABACUSyn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| 3Dneu cliciwch ar y botwm bar offer.

3. Agor sydd eisoes yn bodolidelweddu (.abacus3d)

- Neu -

1. Sicrhewch fod gennych agor y ffeil ABACUSyn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| 3Dneu cliciwch ar y botwm bar offer.

3. Creu delweddu newydd:

· Dewiswch y Pensaernïaethrydych am ei weld o'r ddewislen tynnu-lawr.

· Dewiswch y Cydrannauac Cysylltiadaurydych am ei gynnwys yn y diagram o'r ffenestr dethol elfen safonol .

· Lliwiau Cyswllt, lliw a llun gyda Mathau Cydranac Priodweddau.

· Lliwiau Cysylltiol a siapiau gyda Mathau Cysylltiadac Priodweddau.

I allforio golwg 3D

1. Sicrhewch fod gennych agor golygfa bresennol 3D.

2. Mewn dewislenni tynnu-lawr y farn 3D yn dewis Ffeil | Allforio ...a dewisodd y lleoliad a'r math ffeil ar gyfer y ffeil delweddu (.abacus3d, .vrml neu html).

3. Cliciwch Save.

Gweler Hefyd

Dadansoddi eich pensaernïaeth | Navigation mewn 3D | Mae'r Offeryn diagramau


Navigation mewn Diagram 3D

Navigation: Dadansoddi eich pensaernïaeth> diagramau 3D>

Navigation mewn Diagram 3D

Anfon sylwadau ar y pwnc hwn.

ABACUS yn eich galluogi i lywio hawdd drwy eich pensaernïaeth mewn 3D. Mae'r profiad yn debyg i hedfan. Mae dau ddulliau mordwyo:

· Rheoli Modd Sylfaenol (Ball); ac

· Rheoli Modd Uwch - newid i'r dull hwn drwy ddewis Rheoli| Rheoli Modd Uwch.

Nodyn

Er mwyn newid rhwng Reoli Sylfaenol a Rheoli Dulliau Uwch, gallwch ddefnyddio'r F4ymarferoldeb llwybr byr bysellfwrdd.

Rheoli Modd Sylfaenol

· Dal y Botwm Chwith a symud y llygoden ymlaen neu yn ôl yn newid y cae;

· Dal y Botwm Chwith a symud y llygoden i'r chwith neu i'r dde yn newid y yaw;

· Dal y botwm dde a symud y llygoden sosbenni y farn;

· Dal y ddau botymau i lawr ac yn symud y llygoden ymlaen neu yn ôl, zooms i mewn ac allan o'r bensaernïaeth; ac

· Dal y ddau botymau i lawr a symud y llygoden i'r chwith neu i'r dde, rholiau chwith ac i'r dde.

- Neu -

· Gwasgu'r Saeth Chwithar y bysellfwrdd neu'r bysellbad rhifol yn troi i'r chwith;

· Gwasgu'r Right Arrowar y bysellfwrdd neu'r bysellbad rhifol yn troi i'r dde;

· Gwasgu'r Up Arrowar y bysellfwrdd neu'r bysellbad rhifol bydd chwyddo i mewn;

· Gwasgu'r Down Arrowar y bysellfwrdd neu'r bysellbad rhifol fydd chwyddo allan;

· Gwasgu Page Upar y bysellfwrdd neu'r bysellbad rhifol bydd cae i fyny; ac

· Gwasgu Page Downar y bysellfwrdd neu'r bysellbad rhifol bydd cae i lawr.

Rheoli Modd Uwch

· Symudy llygoden ymlaen ac yn ôl, ac i fyny ac i lawr, yn newid y traw a yaw (yn y drefn honno);

· Gwasgu Wneu Up Arrowzooms mewn (ymlaen) i'r bensaernïaeth;

· Gwasgu Sneu Down Arrowzooms allan (yn ôl) o'r bensaernïaeth;

· Gwasgu Aneu Saeth Chwithrholiau ar y chwith;

· Gwasgu Dneu Right Arrowrholiau ar y dde;

· Gwasgu Qneu Page Downcodi lefel y farn (drwy ostwng safbwynt); ac

· Gwasgu Eneu Page Upyn gostwng y farn (trwy dyrchafu safbwynt).

Rheoli Modd Rhyngweithiol

Wasgu a dal y fysell shiftar y bysellfwrdd yn bwysicach na'r dull cyfredol (Sylfaenol neu Uwch) i fynd i mewn i'r dull rheoli rhyngweithiol. Yn y modd hwn y canlynol yn bosibl:

· Rolly cyrchwr llygoden dros cydran neu gysylltiad i weld y cydran neu enw gysylltiad yn;

· Cliciwchar elfen i chwyddo i mewn ar y gydran;

· Cliciwch-a-llusgoar elfen i gylchdroi y farn o amgylch y gydran; ac

· Dde-gliciocydran neu gysylltiad a dethol Dangos Yn Exploreri weld bod cydran neu leoliad gysylltiad yn y goeden.

Rheolaethau Cyffredin

· Defnyddio ALT-ENTER / ESCi toggle modd sgrîn lawn;

· Defnyddio F2i newid y modd arddangos. Gall hyn hefyd gael mynediad yn y ViewDewislen.

· Defnyddiwch y olwyn y llygodenneu +/-i newid y cyflymder. Mae'r cyflymder yn cael ei nodi gan nifer yn y gornel chwith isaf - ddangosir dim ond pan fydd yn newid. 1 yw'r arafaf a 100 yn gyflymaf.


Gweld siart safonol

Navigation: Dadansoddi eich pensaernïaeth> siartiau Standard>

Gweld siart safonol

Anfon sylwadau ar y pwnc hwn.

Siartiau safonol ABACUS 'gynnwys llinell, bar, colofn, ardal, gwasgariad, pastai, gromlin, Pareto, cam, wyneb, radar, ciwb, toesen, pyramid, cyfuchlin a siartiau ardal gromlin. Unwaith y byddwch wedi dewis y math o siart yr ydych ei eisiau, gweddill y broses ar gyfer gwylio pob un o'r siartiau hyn yr un fath.

I weld siart safon eich pensaernïaeth

1. Sicrhewch fod gennych agor y ffeil ABACUSyn cynnwys eich pensaernïaeth poblog, A bod gennych gwerthusoeich pensaernïaeth.

2. Dewiswch Mewnosod| Siartneu cliciwch ar y botwm bar offer. Y SiartiauBydd ffenestr yn cael ei arddangos.

Ffenestr Siartiau

3. Dewiswch y math o siart yr ydych am ac yn gosod yr Opsiynau Siart, yna cliciwch Nesaf.

Dewisiadau Siart

o Pentyrruyn dangos y berthynas rhwng eitemau unigol i'r cyfan. Gallwch ddefnyddio siart stacked pan ydych yn bwriadu cael cyfres data lluosog (hy eiddo lluosog) a phan fyddwch am bwysleisio cyfanswm.

o Pentyrru 100%Bydd cymharu canran pob gwerth yn cyfrannu at gyfanswm draws y categorïau. Gallwch ddefnyddio siart pentyrru 100% pan fyddwch yn bwriadu cael cyfres data lluosog (hy eiddo lluosog) ac rydych am bwysleisio cyfraniadau at y cyfan, yn enwedig os yw'r cyfanswm yr un fath ar gyfer pob elfen.

o Siart 3DBydd yn syml yn dangos y pwyntiau data mewn fformat 3-D ar gyfer estheteg. Os ydych yn dymuno arddangos y gyfres data hyd dimensiwn 3ydd / z-echelin yna defnyddiwch yr opsiwn Clwstwr Gyfres disgrifio isod.

o Cyfres gan EiddoBydd yn arddangos cyfres ddata ar gyfer pob eiddo sy'n cael ei ddewis yn y pen draw. Os yw hyn yn unchecked, yna bydd yr eiddo yn dod yn y categorïau a bydd y gyfres data fod ar gyfer pob elfen sy'n cael ei ddewis.

o Siart cylchdroiBydd cylchdroi y siart 90 gradd drwy glocwedd interchanging y echelinau x ac y. Mae'r opsiwn hwn ond ar gael ar gyfer yr Lines, Cam a Cube siartiauac yn arbennig o ddefnyddiol ar gyfer gwneud siartiau Carreg Filltir fel y disgrifir yn yr ail domen isod. Noder: Colofn a siartiau bar eisoes yn 'cylchdroi' fersiynau o'i gilydd.

o Cyfres ClwstwrBydd yn arddangos cyfres data lluosog ar hyd dimensiwn 3ydd / z-echel. Mae'r opsiwn hwn ond ar gael ar gyfer yr Golofn, Bar a Cube siartiauac yn arbennig o ddefnyddiol ar gyfer gwneud siartiau Gantt arddull fel y disgrifir yn y Tip gyntaf isod.

Tip

Gallwch greu Siart Ganttgyda bariau llorweddol yn dangos priodweddau amser / dyddiad ar gyfer gwahanol elfennau trwy ddewis y math Siart bar ac yna dewis yr opsiwn Clwstwr Gyfres.Ar ben hynny, ar ôl ei greu, gall y chwith-fwyaf bar ar y siart yn cael ei wneud 'anweledig' trwy liwio ei gwyn drwy dde-glicio un o'r bariau, gan ddewis lliw o'r ddewislen sy'n ymddangos ac yn dewis y lliw top-chwith o'r palet. Yn ogystal gall y ffin ar gyfer y chwith-y rhan fwyaf o bar yn cael ei wneud 'anweledig' drwy dde-glicio un o'r bariau, gan ddethol Properties ... ac ar y tab Cyfres yn yr ymgom sy'n ymddangos newid y Effaith Border i Dim a Lliw i'r brig lliw -left o'r palet.

Tip

Gallwch greu Siart Carreg Filltirgyda siapiau bach sy'n dangos priodweddau amser / dyddiad ar gyfer gwahanol elfennau trwy ddewis y math siart Cube ac yna dewis y Siart Cylchdroi ac opsiynau Clwstwr Cyfres.Ar ben hynny, a grëwyd ar ôl, y ciwbiau gellir ei newid i siapiau eraill drwy dde-glicio un o'r ciwbiau mewn cyfres o ddata a roddwyd a dewis Properties ... ac ar y tab Cyfres yn yr ymgom sy'n ymddangos newid y Bar naill ai Cylinder neu Cone . Noder: Gall gwerth lled Bwlch hefyd yn cael ei ddefnyddio i 'chrebacha' y symbolau ar y siart i leihau gorgyffwrdd, po uchaf y rhif y lleiaf gorgyffwrdd fydd yna.

4. Yn y Pensaernïaethadran, ticiwch y bensaernïaeth / s ydych yn dymuno olrhain eiddo lefel pensaernïaeth gyfer, yna cliciwch Nesaf.

Nodyn

Dewis eiddo lefel bensaernïaeth yn gam gwbl ddewisol a dylid ond ei ddefnyddio pan fyddwch am i siartio benodol eiddo lefel pensaernïaeth eu hunain.Nid oes angen i gael eu dewis pensaernïaeth i hynny yn cynnwys eiddo cydran neu gysylltiad yn y cam nesaf.

5. Dewiswch y Cydrannauac Cysylltiadaueich bod am yn y siart gan y ffenestr dethol elfen safonol , Yna cliciwch Nesaf.

6. Dewiswch y Priodweddauyr ydych am yn y siart a chliciwch Gorffen.

Dewisiadau Siart

o Cynnwys eiddo SafonolBydd dangos y eiddo a etifeddwyd gan y Safonau ar gael ar gyfer dethol.

o Eiddo AggregateBydd cyfrif y amrywiant rhwng y gyfres gwerthoedd a siartio canlyniadau hynny yn hytrach na'r unigolyn gwerthoedd eu hunain.Mae'r opsiwn hwn ond ar gael os yw'r Gyfres drwy opsiwn Eiddo ei ddewis yn gam 3 uchod.

Tip

Mae'r eiddo ar gael i'w olrhain yn dibynnu ar yr elfennau i chi ddewis.

I arbed siart

Nodyn

Gellir Siartiau dim ond yn cael eu cadw os ydynt ond yn cynnwys cydrannau a chysylltiadau, mae'n rhaid i bob un ohonynt fod o bensaernïaeth sengl o fewn y prosiect cyfredol.

1. Sicrhewch fod gennych siart newydd neu bresennol agoredac eich bod wedi gwneud y newidiadau angenrheidiol.

2. Yn y bar offer siart cliciwch ar y leftmost Save Siartbotwm i achub y siart ac unrhyw newidiadau fformatio.

3. Yn y Siart Enwdeialog sy'n ymddangos rhowch enw ar gyfer y siart a'r wasg iawn.

I allforio siart

1. Sicrhewch fod gennych sy'n bodoli eisoes siartar agor.

2. Yn y bar offer siart, cliciwch ar yr 2il o'r chwith Save Fel BMPDewisodd botwm ac mae'r lleoliad ar gyfer y siart.

3. Cliciwch Save.

Gweler Hefyd

Dadansoddi eich pensaernïaeth | Gweld siart amser ymateb | Gweld siart gofod gallu


Gweld siart gofod gallu

Navigation: Dadansoddi eich pensaernïaeth> siartiau Custom>

Gweld siart gofod gallu

Anfon sylwadau ar y pwnc hwn.

Mae siart Space Gallu caniatáu i chi weld a yw eich pensaernïaeth cyflawni'r gallu system sy'n ofynnol mewn perthynas â eiddo a nodwyd yn ystod y broses dadansoddi gofyniad system.

I weld siart gofod gallu

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog, A bod gennych gwerthusoeich pensaernïaeth.

2. Dewiswch Mewnosod| Siart| Siartiau Custom| Gofod Gallu. (Y Siart Gofod Gallu ConfigBydd deialog arddangos.)

3. Yn y Pensaernïaethadran, ticiwch y saernïaeth ydych yn dymuno siart, yna cliciwch Nesaf.

4. Yn y Priodweddauardal, ticiwch y priodweddau pensaernïol hoffech ei gynnwys fel yr echelinau y siart.

5. Yn y Galluardal, ar gyfer pob eiddo ei gynnwys oddi wrth y cam blaenorol, dewiswch yw unrhyw Isafswm neu derfynau gallu Uchafswm bodoli a gwerthoedd terfynau hynny. Mae'r gwerthoedd diofyn yw gwerthoedd isaf ac uchaf eu gwerthuso ar gyfer y saernïaeth neu'r nod ar gyfer yr eiddo os yw wedi cael ei osod.

I allforio siart gofod gallu

1. Sicrhewch fod gennych sy'n bodoli eisoes siart gofod galluar agor.

2. Yn y bar offer siart cliciwch ar y leftmost Save Fel BMPDewisodd botwm ac mae'r lleoliad ar gyfer y siart.

3. Cliciwch Save.

Gweler Hefyd

Dadansoddi eich pensaernïaeth | Gweld siart amser ymateb


Gweld siart amser ymateb

Navigation: Dadansoddi eich pensaernïaeth> siartiau Custom>

Gweld siart amser ymateb

Anfon sylwadau ar y pwnc hwn.

Mae siart amser ymateb caniatáu i chi weld a yw eich cysylltiadau yn cael eu prosesu ar y gyfradd angenrheidiol (hy o fewn eu terfyn amser).

I weld siart amser ymateb

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog, A bod gennych gwerthusoeich pensaernïaeth.

2. Dewiswch Mewnosod| Siart| Siartiau Custom| Amser ymateb. (Y Ymateb Amser Siart ConfigBydd deialog arddangos.)

3. O'r Pensaernïaethcwymprestr, dewiswch y bensaernïaeth yr hoffech i siartio.

4. Yn y Cysylltiadauardal, ticiwch y cysylltiadau hoffech ei gynnwys yn y siart.

5. Y Math Graddfaardal, dewiswch Llinolos ydych am i'r echelin fertigol (amser ymateb) i gael ei arddangos fel dilyniant llinol - bob segment o amser yn cael ei ddyrannu cyfran gyfartal o'r echelin. Dewiswch LogarithmigOs ydych eisiau iddo arddangos fel dilyniant logarithmig - pob segment o'r echelin cynrychioli gyfnodau cynyddol hwy o amser y uwch i fyny'r echelin i chi fynd. (Mae cyfradd y cynnydd yn cael ei bennu gan y Sylfaenbyddwch yn dewis.)

Siart Amser ymateb ar raddfa echelin fertigol

I allforio siart amser ymateb

1. Sicrhewch fod gennych sy'n bodoli eisoes siart amser ymatebar agor.

2. Yn y bar offer siart cliciwch ar y leftmost Save Fel BMPDewisodd botwm ac mae'r lleoliad ar gyfer y siart.

3. Cliciwch Save.

Gweler Hefyd

Dadansoddi eich pensaernïaeth | Gweld siart gofod gallu


Edrych llain seren eich saernïaeth esblygu

Navigation: Dadansoddi eich pensaernïaeth> siartiau Custom>

Edrych llain seren eich saernïaeth esblygu

Anfon sylwadau ar y pwnc hwn.

Unwaith y bydd pensaernïaeth wedi'i esblygu ac mae'r nodau yn cael eu diffinio, gellir wedyn yn cael ei dychmygu ac yn cymharu â'r bensaernïaeth gwreiddiol gan ddefnyddio lleiniau seren. Mae'r adran hon yn amlinellu sut i greu a thrin plot seren.

I weld llain seren eich saernïaeth esblygu

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Sicrhewch fod gennych esblyguac nodau a osodwydar gyfer eich pensaernïaeth fel yr amlinellir o dan Esblygu eich pensaernïaeth

3. Dewiswch Mewnosod| Siart| y Siartiau Customtab | Seren Plot.

4. Cliciwch ar y Gorffenbotwm.

5. Y Seren Plotgyda'r saernïaeth esblygu ac yn gosod y bydd nodau yn cael eu harddangos. Noder: Efallai y bydd y echelinau o'r plot seren yn cael ei ail-leoli trwy glicio a llusgo'r echelinau i ardal arall o fewn ffiniau'r gofod seren ansawdd plot.

Nodyn

Mae'r ardal ar ochr chwith y plot seren yn dangos y gosodiadau o'r plot seren harddangos. Mae hyn yn cynnwys y bensaernïaeth sydd wedi cael ei esblygu (yn yr achos hwn "ABC Ltd Fel-Is 2010") Yn ogystal â'r nodau sydd wedi eu gosod ar gyfer y bensaernïaeth. Byddwch yn sylwi bod y nodau sydd â marc tic iddynt nesaf i yn cael eu cynrychioli fel echelinau o'r plot seren (ee DPA- Cost, DPA - Ansawdd a KPI - Amser). Efallai y byddwch yn dad-diciwch y nodau hyn ar unrhyw bwynt o amser i gael gwared arnynt gan y plot seren.

Mae coch a gwyrdd "dotiau" sy'n ymddangos ar eich plot seren yn cynrychioli gwerth normaleiddio, fel y pennir gan y gwerth gorau a gwaethaf (a amlinellir o dan Gosod nodau ar gyfer eich pensaernïaeth esblygu ) Ar gyfer y bensaernïaeth lefel uchaf a ddewiswyd ac unrhyw evolutions ohono. Mae'r gwerthoedd hyn yn cael eu cynrychioli mewn Gofod Ansawdd.

Fel yr amlinellwyd yn y llun uchod, mae'n weld yn glir bod y bensaernïaeth gwreiddiol (Fel Is-2010) Mae gan wael Cost, Tra bod y dewis esblygu cyntaf (I-Be 2011 - Strategaeth A) Wedi symud o fewn y gofod o ansawdd i wella'r Cost, Ansawdd ac Amsernodau. Fel arall, yr ail esblygu opsiwn (I-Be 2011 - Strategaeth B) tra mae hefyd wedi gwella'r Cost maint y gwelliant yn llai na hynny o Strategaeth A ond mae'r ddau nodau Ansawdd ac Amser wedi cael eu gwella fwy nag â Strategaeth A.Yn yr achos hwn pensaer Gall dewis Strategaeth Adros Strategaeth Bfel eu hargymhelliadac esblygu yr opsiwn hwnnw bellach (I-Be 2012 - Strategaeth A).

6. Dad-ddewiswch y Dangos esblygiadaugwiriwch y blwch i guddio y llinell (au) sy'n cynrychioli'r esblygiad (au) rhwng y gwreiddiol (ee Fel Is-2010) Ac esblygu (e.e. I-Be 2011 - StrategaethA) pensaernïaeth (au).

7. Dewiswch y Dangos Ffyngwiriwch y blwch i arddangos y maint cymharol pob priodoledd ansawdd (y nodau a ddiffiniwyd ar bob echelinau) ar gyfer pob bensaernïaeth.

8. Dewiswch y Dangos Enwau Pensaernïaethgwiriwch y blwch os ydych am enwau'r bensaernïaeth (au) gwreiddiol ac esblygu i ymddangos ar y plot seren.

Gweler Hefyd

Dadansoddi eich pensaernïaeth | Gweld siart amser ymateb | Edrych matrics scatterplot o'ch saernïaeth esblygu | Esblygu eich pensaernïaeth


Edrych llain gwasgariad o'ch saernïaeth esblygu

Navigation: Dadansoddi eich pensaernïaeth> siartiau Custom>

Edrych llain gwasgariad o'ch saernïaeth esblygu

Anfon sylwadau ar y pwnc hwn.

Unwaith y bydd pensaernïaeth wedi'i esblygu ac mae'r nodau yn cael eu diffinio, gellir wedyn yn cael ei dychmygu ac yn cymharu â'r bensaernïaeth gwreiddiol gan ddefnyddio matricsau scatterplot. Mae'r adran hon yn amlinellu sut i greu a deall nodweddion matrics scatterplot.

I weld Matrics scatterplot o'ch saernïaeth esblygu

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Sicrhewch fod gennych esblyguac nodau a osodwydar gyfer eich pensaernïaeth fel yr amlinellir o dan Esblygu eich pensaernïaeth

3. Dewiswch Mewnosod| Siart| y Siartiau Customtab | Matrics Scatterplot.

4. Cliciwch ar y Gorffenbotwm.

5. Y Plot gwasgariadag esblygiad ddiffiniedig o saernïaeth a nodau yn cael eu harddangos.

Nodyn

Mae'r ardal ar ochr chwith y matrics scatterplot yn dangos y gosodiadau o'r matrics scatterplot harddangos. Mae hyn yn cynnwys y bensaernïaeth sydd wedi cael ei esblygu (yn yr achos hwn "ABC Ltd Fel-Is 2010") Yn ogystal â'r nodau sydd wedi eu gosod ar gyfer y bensaernïaeth. Byddwch yn sylwi bod y nodau sydd â marc tic iddynt nesaf i yn cael eu cynrychioli fel X ac Y echelinau o'r matrics scatterplot (ee DPA- Cost, DPA - Ansawdd a KPI - Amser). Efallai y byddwch yn dad-diciwch y nodau hyn ar unrhyw bwynt o amser i gael gwared arnynt gan y matrics scatterplot.

Mae'r dotiau glas sy'n ymddangos ar eich plot yn y matrics yn cynrychioli gwerth normaleiddio, fel y pennir gan y gwerth gorau a gwaethaf (a amlinellir o dan Gosod nodau ar gyfer eich pensaernïaeth esblygu ). Mae'r gwerthoedd hyn yn cael eu cynrychioli mewn Gofod Ansawdd.

Ddwy gôl a ddiffiniwyd yn cael eu cymharu yn erbyn ei gilydd mewn matrics scatterplot ac mae'r broses yn cael ei hailadrodd nes bod yr holl amcanion wedi cael eu cymharu (ee Mae'r plot cyntaf y matrics yn y diagram uchod yn cymharu'r KPI - Costnod gyda'r KPI - Ansawdd nod. Yr ail yw Cost yn erbyn Amser ac mae'r plot olaf yn Ansawdd yn erbyn Amser. Mae'r labeli gôl perthnasol yn cael eu dangos ar y brig ac i'r dde neu bob rhes o leiniau.).

6. Dewiswch y Pensaernïaethbotwm radio os ydych am ddangos y metrigau ar gyfer y saernïaeth unigol.

7. Dewiswch y Esblygiadaubotwm radio os ydych am ddangos y newidiadau normaleiddio o bensaernïaeth gwreiddiol (ee Fel Is-2010) I'r bensaernïaeth (au) esblygu (e.e. I-Be 2011 - Strategaeth A ac I-Be 2011 - Strategaeth B).

Gweler Hefyd

Dadansoddi eich pensaernïaeth | Gweld siart amser ymateb | Edrych llain seren eich saernïaeth esblygu | Esblygu eich pensaernïaeth


Gweld siart swigen

Navigation: Dadansoddi eich pensaernïaeth> siartiau Custom>

Gweld siart swigen

Anfon sylwadau ar y pwnc hwn.

Mae siart swigen eich galluogi i gymharu hyd at 5 dimensiwn (hy X, Y, maint swigen / radiws, lliw swigen a lliw y ffin swigen) mewn un olygfa.

I weld siart swigen

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Dewiswch Mewnosod| Siart| y Siartiau Customtab | Siart swigen.

3. Yn y Pensaernïaethadran, ticiwch y saernïaeth (os o gwbl) yr hoffech i siartio, yna cliciwch Nesaf.

4. Dewiswch y Cydrannauac Cysylltiadaubod chi eisiau yn y siart (os o gwbl) oddi wrth y ffenestr dethol elfen safonol , Yna cliciwch Nesaf.

5. Dewiswch y X-echeleiddo, yna cliciwch Nesaf.

Nodyn

Dim ond Cyfanrif, Degol, Dyddiad / Amser, Boolean ac eiddo Rhestr Gellir ei ddefnyddio ar gyfer yr echelin-X. Ar ben hynny, eiddo Cyfanrif, Degol a Dyddiad / Amser yn cael eu plotio chwith i'r dde ar hyd yr echelin raddio yn ôl gwerth yr eiddo, fodd bynnag, eiddo Boole a Rhestr eu plotio yn syml chwith i'r dde yn yr union drefn (neu mewn y gorchymyn gwrthwyneb pe bai'r opsiwn i wrthdroi'r y gorchymyn yn cael ei wirio) a ddiffiniwyd ar gyfer yr eiddo beth bynnag yw eu gwerthoedd. E.e. Isel | Canolig | Uchel neu 1, 2, 4, 8, 16.

6. Dewiswch y Y-echeleiddo, yna cliciwch Nesaf.

Nodyn

Dim ond Cyfanrif, Degol, Dyddiad / Amser, Boolean ac eiddo Rhestr Gellir ei ddefnyddio ar gyfer y Y-echel. Ar ben hynny, eiddo Cyfanrif, Degol a Dyddiad / Amser yn cael eu plotio gwaelod-i-ben ar hyd yr echelin raddio yn ôl gwerth yr eiddo, fodd bynnag, eiddo Boole a Rhestr eu plotio yn syml gwaelod-i-ben yn yr union drefn (neu mewn y gorchymyn gwrthwyneb pe bai'r opsiwn i wrthdroi'r y gorchymyn yn cael ei wirio) a ddiffiniwyd ar gyfer yr eiddo beth bynnag yw eu gwerthoedd. E.e. Isel | Canolig | Uchel neu 1, 2, 4, 8, 16.

7. Dewiswch y Maint y swigen / radiwseiddo, yna cliciwch Nesaf.

Nodyn

Dim ond Cyfanrif, Degol, Boolean ac eiddo Rhestr Gellir ei ddefnyddio ar gyfer y swigen maint / radiws. Ar ben hynny, Cyfanrif ac eiddo degol yn arwain at maint swigen / radiws raddio yn ôl gwerth yr eiddo, fodd bynnag, eiddo Boole a Rhestr arwain at gam gynnydd cyfartal o'r swigen maint / radiws yn yr union drefn (neu yn y drefn gwrthwyneb os yr opsiwn i wrthdroi'r y gorchymyn yn cael ei wirio) a ddiffiniwyd ar gyfer yr eiddo beth bynnag yw eu gwerthoedd. E.e. Isel | Canolig | Uchel neu 1, 2, 4, 8, 16.

8. Dewiswch naill ai lliw swigen sefydlogneu cysylltu eiddo gyda lliw swigen, Yna cliciwch Nesaf.

Nodyn

Dim ond Cyfanrif, Degol, Boolean ac eiddo Rhestr Gellir ei ddefnyddio ar gyfer y lliw swigen. Ar ben hynny, Cyfanrif ac eiddo degol yn arwain at liw swigen o fewn yr ystod a ddewiswyd graddio yn ôl gwerth yr eiddo, fodd bynnag, eiddo Boole a Rhestr arwain at gam gynnydd cyfartal o'r lliw swigen o fewn yr ystod a ddewiswyd yn yr union drefn a ddiffiniwyd ar gyfer y eiddo waeth beth yw eu gwerthoedd. E.e. Isel | Canolig | Uchel neu 1, 2, 4, 8, 16.

9. Dewiswch naill ai dim lliw y ffin swigenneu cysylltu eiddo gyda lliw y ffin swigen, Yna cliciwch Gorffen.

Nodyn

Dim ond Cyfanrif, Degol, Boolean ac eiddo Rhestr Gellir ei ddefnyddio ar gyfer y lliw y ffin swigen. Ar ben hynny, Cyfanrif ac eiddo degol yn arwain at liw border swigen o fewn yr ystod a ddewiswyd graddio yn ôl gwerth yr eiddo, fodd bynnag, eiddo Boole a Rhestr arwain at gam gynnydd cyfartal o'r lliw ffin swigen o fewn yr ystod a ddewiswyd yn yr union drefn a ddiffinnir ar gyfer yr eiddo beth bynnag yw eu gwerthoedd. E.e. Isel | Canolig | Uchel neu 1, 2, 4, 8, 16.

Siart swigen

I arbed siart swigen

Nodyn

Gall siartiau Bubble dim ond yn cael eu cadw os ydynt ond yn cynnwys cydrannau a chysylltiadau, mae'n rhaid i bob un ohonynt fod o bensaernïaeth sengl o fewn y prosiect cyfredol.

1. Sicrhewch fod gennych siart swigod newydd neu bresennol agoredac eich bod wedi gwneud y newidiadau angenrheidiol.

2. Yn y bar offer siart cliciwch ar y leftmost Save Siartbotwm i achub y siart ac unrhyw newidiadau fformatio.

3. Yn y Siart Enwdeialog sy'n ymddangos rhowch enw ar gyfer y siart swigen a'r wasg iawn.

I allforio siart swigen

1. Sicrhewch fod gennych agor siart swigen presennol.

2. Yn y bar offer siart, cliciwch ar yr 2il o'r chwith Save Fel BMPDewisodd botwm ac mae'r lleoliad ar gyfer y siart.

3. Cliciwch Save.

Gweler Hefyd

Dadansoddi eich pensaernïaeth


Pensaernïaeth Diff a Sync

Navigation: Dadansoddi eich pensaernïaeth>

Pensaernïaeth Diff a Sync

Anfon sylwadau ar y pwnc hwn.

Pan fydd gennych 2 neu fwy o saernïaeth, naill ai fel esblygiadau neu saernïaeth llinell sylfaen, gallwch eu golwg 'diff' y ddwy saernïaeth ddefnyddio catalog neu ddiagram Cymhariaeth neu'r Nodwedd Pensaernïaeth Diff. Mae hyn yn arbennig o ddefnyddiol ar gyfer darganfod / ail-ddarganfod yr union newidiadau a wnaed o un bensaernïaeth i un arall wrth i chi esblygu pensaernïaeth a datblygu roadmaps yn ABACUS.

I yn dangos y 'diff' gyda phensaernïaeth arall drwy diagram

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Gwnewch yn siŵr eich cael o leiaf 2 pensaernïaeth yn y prosiect.

3. Agorwch y diagram hoffech gymharu'r i bensaernïaeth arall.

4. Cliciwch y botwm 'Cymharwch Diagram hwn i gynnwys y bensaernïaeth arall' ar y bar offer Diagram.

5. Dewiswch y bensaernïaeth arall o'r rhestr a ollyngir i lawr i gymharu â.

6. Gallwch hidlo pa wahaniaethau yn cael eu dangos drwy glicio botwm 'Gwahaniaethau' ar y bar offer Diagram a dad-ddethol dewisiadau, ee Wedi newid / Ychwanegu / Anhysbys a Amhenodol / Sync a Argymhellir/ Cadwch a Argymhellir.

Nodyn

Bydd cydrannau a chysylltiadau ar y diagram yn cael ei amlygu mewn Coch, gwyrdd neu porffor lle mae gwahaniaethau rhwng y cynnwys sy'n weladwy ar y diagram presennol a'r cynnwys yn y bensaernïaeth arall. Coch yn cael ei ddefnyddio pan argymhellir i Sync y gwahaniaethau (gweler isod), Gwyrdd yn cael ei ddefnyddio pan nad argymhellir i cydamseru y gwahaniaethau, hynny yw nhw (gweler isod) cadw a Porffor yn cael ei ddefnyddio lle na all ABACUS wneud argymhelliad ynglŷn syncing y gwahaniaethau (gweler isod). Dim ond y cynnwys yn weladwy ar y diagram ei gymharu felly os nodyn yn dangos gwerth yr eiddo ystorfa a bod gwerth yn cael ei newid y gydran a roddwyd neu a fydd cysylltiad yn cael ei ddangos mewn coch llewygu, gwyrdd fel llewyguneu llewygu porffor ac mae '*' symbol a ddangosir ar y brig-chwith ar gyfer cydrannau, fodd bynnag, os rhywfaint o werth yr eiddo ystorfa sylfaenol eraill wedi newid nad yw'n cael ei ddangos yn nodyn yna bydd unrhyw arwydd yn cael ei roi. Cynnwys sy'n digwydd ar y diagram ar hyn o bryd ond ni fydd unrhyw gêm yn dod o hyd yn y bensaernïaeth cymhariaeth yn cael ei ddangos mewn coch cryf, gwyrdd cryfneu cryf porffora '+' symbol a ddangosir ar y brig-chwith ar gyfer cydrannau. Paru yn cael ei wneud yn ôl y math cydran ac enw o'r fath, os yw'r math neu enw'r gydran neu gysylltiad wedi newid yn y pensaernïaeth arall ni fydd unrhyw gêm yn cael ei ganfod. Gan nad oes unrhyw ffordd o ddibynadwy penderfynu a fyddai cynnwys ychwanegol oddi wrth y bensaernïaeth eraill wedi cael eu dangos ar y diagram ar hyn o bryd (ee rhyngwyneb ychwanegol rhwng 2 cydrannau fel y dangosir isod mewn diagram o'r bensaernïaeth gymhariaeth ar y dde), nid yw'r gwahaniaethau hyn yn a ddangosir ar gyfer diagramau (maent yn cael eu dangos am catalogau yn unol isod). Bydd hofran dros bob eitem sydd wedi newid yn dangos y gwahaniaeth yn y tooltip. Hofran dros y '*' symbol yn y top-chwith y diagram yn rhoi crynodeb o'r newidiadau (neu ddim newid) rhwng cynnwys y diagram a chynnwys y bensaernïaeth arall.

Lliw Legend

· Gwyrdd yn dangos eitemau nad argymhellir i cydamseru y gwahaniaethau, hynny yw eu cadw.

· Coch yn dangos eitemau yr argymhellir i cydamseru y gwahaniaethau.

· Porffor yn dangos eitemau lle na all ABACUS wneud argymhelliad ynglŷn syncing y gwahaniaethau.

I cydamseru ('sync') cynnwys o un bensaernïaeth gydag un arall drwy diagram

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Gwnewch yn siŵr eich cael o leiaf 2 pensaernïaeth yn y prosiect.

3. Agorwch y diagram hoffech gymharu'r i bensaernïaeth arall.

4. Cliciwch y botwm 'Cymharwch Catalog hon at gynnwys o bensaernïaeth arall' ar y bar offer Diagram.

5. Dewiswch y bensaernïaeth arall o'r rhestr a ollyngir i lawr i gymharu â.

Nodyn

Gweler uchod am y ffordd y ABACUS yn dangos y 'diff' rhwng 2 saernïaeth yn y catalog. Yn pa mor benodol Coch yn cael ei ddefnyddio lle mae'n ywhargymell i Sync y gwahaniaethau, Gwyrdd yn cael ei ddefnyddio lle mae'n NiArgymhellir i cydamseru y gwahaniaethau a'r Porffor yn cael ei ddefnyddio lle na all ABACUS wneud argymhelliad ynglŷn syncing y gwahaniaethau.

6. Cliciwch y botwm dde yr elfen diagram (neu elfennau sy'n defnyddio Shift neu y cynfas diagram i Sync Gyfan) yn dangos 'diff' a dewiswch y ddewislen eitem Sync.

Nodyn

Bydd unrhyw newidiadau cydamseru ond yn cael eu cymhwyso at y bensaernïaeth bod y catalog ar hyn o bryd yn canolbwyntio yn perthyn iddo. I wneud cais newidiadau i'r bensaernïaeth arall rhaid i chi ddefnyddio catalog yn y bensaernïaeth arall. Ar ben hynny, bydd defnyddwyr yn unig yn gallu gwneud cais newidiadau cydamseru os ydynt yn gael caniatâd i wneud hynny .

Nodyn

Bydd yn dibynnu ar ble rydych de-gliciwch yr eitem dewislen yn dangos arweiniad ar beth yn union fydd yn cael ei cydamseru.E.e. Dde-glicio, bydd elfen sengl yn y diagram yn unig synchronize y gydran honno. Tra dde-glicio ar y cynfas diagram a dewis bydd Sync pob cydamseru yr holl wahaniaethau a ddangosir ar hyn o bryd.

I yn dangos y 'diff' gyda phensaernïaeth arall drwy gatalog

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Gwnewch yn siŵr eich cael o leiaf 2 pensaernïaeth yn y prosiect.

3. Agorwch y catalog hoffech gymharu'r i bensaernïaeth arall.

4. Cliciwch y botwm 'Cymharwch Catalog hon at gynnwys o bensaernïaeth arall' ar y bar offer Catalog.

5. Dewiswch y bensaernïaeth arall o'r rhestr a ollyngir i lawr i gymharu â.

6. Gallwch hidlo pa wahaniaethau yn cael eu dangos drwy glicio botwm 'Gwahaniaethau' ar y bar offer Diagram a'r opsiynau unselecting, ee Wedi newid / Ychwanegu / Anhysbys a Amhenodol / Sync a Argymhellir/ Cadwch a Argymhellir.

Nodyn

Bydd celloedd yn y catalog yn cael ei amlygu mewn Coch, gwyrdd neu porffor lle mae gwahaniaethau rhwng cynnwys yn y catalog cyfredol a chynnwys cyfateb yn y bensaernïaeth arall. Coch yn cael ei ddefnyddio pan argymhellir i Sync y gwahaniaethau (gweler isod), Gwyrdd yn cael ei ddefnyddio pan nad argymhellir i cydamseru y gwahaniaethau, hynny yw nhw (gweler isod) cadw a Porffor yn cael ei ddefnyddio lle na all ABACUS wneud argymhelliad ynglŷn syncing y gwahaniaethau (gweler isod). Dim ond y rhesi a cholofnau i'w gweld yn y catalog yn cael eu cymharu felly os oes gwahaniaeth mewn rhes y tu hwnt i'r rhesi a ddangosir ar hyn o bryd neu werth mewn colofn nad yw'n cael ei ddangos gan wahaniaeth, yna ni fydd unrhyw wahaniaeth yn cael ei nodi. Lle mae'r gwerth mewn cell unigol yn wahanol gyda'r cell cyfateb yn y pensaernïaeth cymhariaeth, bydd y ffin cell yn cael eu hamlygu. Bydd y pennawd colofn a rhes dewisydd hefyd yn cael ei liwio mewn llewygu porfforac a ddangosir â symbol '*'. Gall y rhain symbolau '*' yn cael clicio i neidio i'r gwahaniaeth nesaf yn y golofn neu res yn ôl eu trefn. Bydd Rhesi sy'n digwydd yn y catalog cyfredol ond ni ei baru yn y bensaernïaeth cymhariaeth yn cael ei ddangos gyda symbol '+' yn y dewisydd rhes ar y chwith a therfyn y rhes cyfan yn cael eu hamlygu. Bydd Rhesi fyddai wedi digwydd yn y fersiwn pensaernïaeth cymhariaeth o'r catalog (hy gyda'r un hidlyddion ac ati) ond ni ei baru yn y bensaernïaeth presennol yn cael ei ddangos gyda '-' symbol yn y dewisydd rhes ar y chwith, derfyn Bydd y rhes cyfan yn cael ei hamlygu, a bydd y cynnwys celloedd rhesi cyfan yn cael ei ddangos yn llewygu porffora taro-drwy, e.e. 08:00-18:00. Paru yn cael ei wneud yn ôl y math cydran ac enw o'r fath, os yw'r math neu enw'r gydran neu gysylltiad wedi newid yn y pensaernïaeth arall ni fydd unrhyw gêm yn cael ei ganfod. Bydd hofran dros bob eitem sydd wedi newid yn dangos y gwahaniaeth yn y tooltip. Hofran dros y '*' symbol yn y top-chwith y diagram yn darparu crynodeb o'r newidiadau (neu ddim newid) rhwng cynnwys y diagram a chynnwys y bensaernïaeth arall.

Lliw Legend

· Gwyrdd yn dangos eitemau nad argymhellir i cydamseru y gwahaniaethau, hynny yw eu cadw.

· Coch yn dangos eitemau yr argymhellir i cydamseru y gwahaniaethau.

· Porffor yn dangos eitemau lle na all ABACUS wneud argymhelliad ynglŷn syncing y gwahaniaethau.

I cydamseru ('sync') cynnwys o un bensaernïaeth gydag un arall drwy gatalog

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Gwnewch yn siŵr eich cael o leiaf 2 pensaernïaeth yn y prosiect.

3. Agorwch y catalog hoffech gymharu'r i bensaernïaeth arall.

4. Cliciwch y botwm 'Cymharwch Catalog hon at gynnwys o bensaernïaeth arall' ar y bar offer Catalog.

5. Dewiswch y bensaernïaeth arall o'r rhestr a ollyngir i lawr i gymharu â.

Nodyn

Gweler uchod am y ffordd y ABACUS yn dangos y 'diff' rhwng 2 saernïaeth yn y catalog. Yn pa mor benodol Coch yn cael ei ddefnyddio lle mae'n ywhargymell i Sync y gwahaniaethau, Gwyrdd yn cael ei ddefnyddio lle mae'n NiArgymhellir i cydamseru y gwahaniaethau a'r Porffor yn cael ei ddefnyddio lle na all ABACUS wneud argymhelliad ynglŷn syncing y gwahaniaethau.

6. Dde-gliciwch y gell, colofn neu res pennawd (neu eitemau lluosog gan ddefnyddio Shift neu Ctrl + A am bopeth) yn dangos 'diff' a dewiswch y ddewislen eitem Sync.

Nodyn

Bydd unrhyw newidiadau cydamseru ond yn cael eu cymhwyso at y bensaernïaeth bod y catalog ar hyn o bryd yn canolbwyntio yn perthyn iddo. I wneud cais newidiadau i'r bensaernïaeth arall rhaid i chi ddefnyddio catalog yn y bensaernïaeth arall. Ar ben hynny, bydd defnyddwyr yn unig yn gallu gwneud cais newidiadau cydamseru os ydynt yn gael caniatâd i wneud hynny .

Nodyn

Yn dibynnu ar ble rydych yn dde-glicio (hy cell, colofn neu res pennawd) bydd yr eitem dewislen yn dangos arweiniad ar beth yn union fydd yn cael ei cydamseru.E.e. Dde-glicio un eiddo neu gell gydran sydd ynghlwm yn y catalog yn unig cydamseru eiddo hwnnw neu gydran ynghlwm. Tra dde-glicio rhes pennawd (neu benawdau gan ddefnyddio Shift) yn cydamseru y rhes cyfan (neu resi). Dde-glicio Bydd pennawd colofn cydamseru yr holl wahaniaethau yn y golofn honno.

I weld 'gwahan'o 2 cyfan pensaernïaeth

1. Sicrhewch bod gennych Ffeil ABACUS agored .

2. Gwnewch yn siŵr eich cael o leiaf 2 pensaernïaeth yn y prosiect.

3. Dewiswch Offer| Pensaernïaeth Diff ....

4. Yn y deialog sy'n ymddangos dewiswch y cyntaf / O ac ail / I pensaernïaeth i gymharu.

5. Cliciwch ar y iawnbotwm.

Pensaernïaeth Diff

Lliw Legend

· Gwyrddyn nodi bod y nod Ychwanegwyd yn yr ail / To pensaernïaeth.

· Cochyn nodi bod y nod ei ddileu yn yr ail / To pensaernïaeth.

· Blueyn dangos bod y nod wedi nodweddion gwahanol (ee eiddo neu safonau) yn yr ail / To pensaernïaeth.

· Melynyn dangos bod y nod wedi gwahaniaethau yn ei phlant yn yr ail / I pensaernïaeth felly dylai'r nod gael ei ehangu.

Nodyn

Gallwch de-gliciwch a "Dangos yn Explorer" ar yr holl nodau i weld y manylion a mwy o wybodaeth yn cael ei rhoi ar y gwahaniaethau yn y panel Cryno Gwahaniaethau pan fydd nod yn cael ei ddewis.

Gweler Hefyd

Dadansoddi eich pensaernïaeth | Gweld siart amser ymateb | Edrych matrics scatterplot o'ch saernïaeth esblygu | Esblygu eich pensaernïaeth


Efelychu eich pensaernïaeth

Navigation: Efelychu eich pensaernïaeth>

Efelychu eich pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

Unwaith y byddwch wedi poblog a'u dadansoddi eich pensaernïaeth, rydych yn barod i ddefnyddio ABACUS i bennu os bydd eich pensaernïaeth cwrdd â'ch anghenion meintiol. Mae hyn yn gofyn efelychu. I efelychu eich pensaernïaeth rhaid i chi benderfynu yn gyntaf ar y math o wybodaeth rydych am ei ddarganfod. Mae'r mathau hyn o wybodaeth yn aml yn cael eu galw'n DPA, neu Ddangosyddion Perfformiad Allweddol. Er enghraifft, ydych chi eisiau i ddadansoddi perfformiad, evolvability, a bod yn agored, neu a ydych am i gasglu metrigau fel cyfanswm cost perchnogaeth. Gall yr holl wybodaeth hon yn cael ei ddatgelu mewn rhyw ffordd. Unwaith y byddwch wedi y data hwn, byddwch yn gallu i ddadansoddi eich pensaernïaeth mewn amrywiaeth o fformatau graffigol (neu dadansoddi'r gwerthoedd newydd yn uniongyrchol).

Mae tri opsiwn ar gyfer efelychu eich pensaernïaeth:

· Metrics Syml ;

· Efelychwyr-adeiladwyd Cyn ; neu

· Sgriptio .

Metrics Syml

Mae gan bob elfen yn eich pensaernïaeth eiddo - gallai llawer ohonynt fod yn arferiad i'ch cais o ABACUS. Mae'r adeiladau hyn yn cynrychioli gwahanol nodweddion y cydrannau. Mewn rhai achosion, yn syml casglu metrigau hyn (i adeiladu DPA) yn gallu bod yn ddigon i ddweud wrth gwybodaeth bwysig am eich pensaernïaeth chi. Er enghraifft, KLOCS, neu miloedd o linellau o god, wedi cael eu defnyddio yn eang fel mesur o gymhlethdod. Mewn achosion eraill, efallai y byddwch am allforio y data a'i ddadansoddi gan ddefnyddio offeryn arall. Yn ogystal, efallai y byddwch am gasglu eiddo ar ôl perfformio fath arall o efelychiad.

Gall eiddo gael ei gasglu trwy'r broses o agregu . Cydgasglu yn ychwanegu is-eiddo penodol i gyfanswm sy'n cael ei adlewyrchu yn y rhiant gydran. Cydgasglu yn gweithio yn unig ar gydrannau sy'n cynnwys is-gydrannau.

Efelychwyr Cyn-adeiladu

Mae pum efelychwyr cyn-adeiladu y gellir eu defnyddio gyda ABACUS. Mae rhain yn:

· Perfformiad;

· Modiwlau;

· Cyfanswm Cost y Perchnogaeth (TCO);

· Bod yn agored; ac

· Dibynadwyedd.

Nodyn

Bydd ABACUS tynnu sylw at awtomatig pa rai o'r efelychwyr hyn mae angen i gael eu hail-rhedeg drwy Coch gan amlygu ar y Bar offer Efelychu .

Sgriptio

Sgriptio darparu'r hyblygrwydd i efelychu eich pensaernïaeth mewn ffyrdd arferiad. Erbyn sgriptiau ysgrifennu gallwch berfformio efelychiadau tu hwnt i'r presennol mewn gallu a adeiladwyd o ABACUS. Mae'r model gwrthrych ABACUS cyfan ar gael i'r injan sgriptio, felly eich bod yn gyfyngedig yn unig gan eich gallu i ysgrifennu sgriptiau!

Sgript Visual Basic yw iaith sgriptio a gefnogir gan ABACUS, gan ei fod yn darparu nodweddion rhaglennu hanfodol mewn fformat weddol syml.

Gweler Hefyd

Allforio eich pensaernïaeth | Eiddo Aggregate | Sgriptiau Ysgrifennu


Sgriptiau Ysgrifennu

Navigation: Efelychu eich pensaernïaeth>

Sgriptiau Ysgrifennu

Anfon sylwadau ar y pwnc hwn.

Mae'r Golygydd Sgript yn cyfleustodau syml ac ymarferol ar gyfer ysgrifennu a gweithredu VB neu C # sgript yn erbyn y ffeil ABACUS agor ar hyn o bryd(Nid yw llyfrgelloedd yn cael eu cefnogi mewn sgriptio). Mae wedi y Ffeil arferol Agored, Close a Save gorchmynion, er mwyn i chi cadw ac adfer sgriptiau i chi ysgrifennu. Mae ganddo hefyd gyfleuster redeg a dadfygio sylfaenol. Mae'r Rheolwr Script yn caniatáu i chi yn hawdd gweithredu gwahanol sgriptiau eich bod wedi ysgrifennu trwy osod bwydlen-eitem ar eu cyfer yn uniongyrchol yn y ddewislen Tools.

I fynd at y Golygydd Sgript

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Dewiswch Offer | Golygydd Sgripta bydd y ffenestr Golygydd Sgript agor. Yna naill ai;

3. Agor sgript sy'n bodoli eisoes drwy Ffeil | Agored yn y bwydlenni Golygydd Sgript,

neu

3. Agor sgript Enghraifft drwy'r Enghraifft eitem yn y bwydlenni Golygydd Sgript,

neu

3. Gosod y diofyn Iaith naill ai i VB neu C # drwy'r Iaith eitem yn y bwydlenni Golygydd Sgript,

neu

3. Help benodol sgriptio Agored drwy'r Help eitem yn y bwydlenni Golygydd Sgript

Wrth ysgrifennu sgriptiau, mae'n rhaid i chi gadw at naill ai'r VB neu C # cystrawenyn unol â'r lleoliad o dan yr eitem Iaith yn y bwydlenni Golygydd Sgript.

NODYN:

· I ddefnyddio swyddogaethau VB safonol fel MsgBox ()mae'n rhaid i chi gynnwys y Mewnforion Microsoft.VisualBasicdatganiad ar ddechrau eich sgript. Nid oedd hyn yn angenrheidiol cyn Fersiwn 3.0 o ABACUS.

· Nid yw'r cymorth hwn yn cynnwys gwybodaeth ar sut i ysgrifennu sgript VB, ac nid yw'n cynnwys cyfeiriad VB. Mae croeso i chi ysgrifennu eich sgriptiau yn eich hoff IDE neu olygydd, copïwch a gludwch nhw i mewn i'r Golygydd Sgript.

Pan fyddwch yn dechrau y Golygydd Sgript gyntaf, bydd y Golygydd Sgript fod yn wag. Gallwch gael mynediad sgript sgerbwd drwy'r ddewislen Enghreifftiau. Y tro cyntaf y byddwch yn dechrau eich Golygydd Sgript, dylech redeg y sgerbwd Templed i weld ei fod yn gweithio. Yn ogystal, mae dau sgriptiau enghraifft y gellir cael mynediad trwy'r ddewislen Enghreifftiau.

Ysgrifennu sgript defnyddiol bydd angen i chi gyfeirio at y ABACUS ObjectModel. Mae'n cael ei wneud ar gael i eich sgript trwy gynnwys y Mewnforion ABACUS.ObjectModeldatganiad ar ben eich sgript. Mae cyfeiriad cyflawn i'r model gwrthrych ABACUS cyfan yn cael ei gynnwys gyda'r Golygydd Sgript. Gallwch ddod o hyd iddo drwy ddewis Help | Cynnwyso'r ffenestr Golygydd Sgript.

Mae'r golygydd sgript yn cynnwys llawer o nodweddion defnyddiol ar gyfer ysgrifennu sgriptiau, gan gynnwys AutoComplete fel y dangosir yn y screenshot isod. Fodd bynnag, ar gyfer profiad y defnyddiwr hyd yn oed yn fwy cyfoethog Gall MS Visual Studio eu hintegreiddio gyda ABACUS a chyfarwyddiadau manwl ar gael yma .

Golygydd Sgript gyda AutoComplete

I ddefnyddio'r Rheolwr Sgript

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Dewiswch Tools | Rheolwr Sgript.

3. Cliciwch ar y Ychwaneguicon a Agoredffenestr yn ymddangos.

4. Porwch i'r ABACUS Sgript (.abacusscript, .vb Neu .cs) Ffeilio ydych am ychwanegu at y ddewislen Tools.

5. Cliciwch iawna bydd cyfeiriad at y sgript yn cael ei ddangos yn y Rheolwr Sgript ffenestr. Rhowch enw ar gyfer y sgript fel y dymunwch iddo ymddangos yn y ddewislen Tools. Sylwer: Gall y ffenestr Rheolwr Sgript cael ei newid i weld y llwybr llawn os oes angen.

6. Camau Ailadrodd 3-5i greu cysylltiadau i fwy o sgriptiau ABACUS.

7. Cliciwch Caui gau'r Rheolwr Sgript ac yn nodi bod y sgript (iau) ABACUS yn awr yn ymddangos o dan y ddewislen Tools.

Rhedeg sgript

Naill ai;

1. Agored, deipio i mewn, neu gopïo a gludo yn y sgript rydych am ei redeg, felly mae'n cael ei arddangos yn y brif ffenestr y Golygydd Sgript.

2. Cliciwch y Runbotwm.

3. Os yw eich sgript yn cynnwys gwallau, bydd yr adran Disgrifiad Gwall ar waelod y Golygydd Sgript rhestru manylion gynnwys y rhifau llinell. NODYN: Gall pob camgymeriad unigol yn y Disgrifiad adran Gwall fod yn ddwbl-glicio i fynd â chi i'r llinell cyfatebol yn y sgript.

- Neu -

1. Dewiswch Offerac yna'r Enw'r ABACUS Sgript eitem dewislen fel creu gyda'r Rheolwr Sgript.

2. Os yw eich sgript yn cynnwys gwallau, bydd y Golygydd Sgript cael ei agor â chynnwys y sgript a ddangosir yn y brif ffenestr (a amlygwyd yn y llinell y gwall cyntaf) ac mae'r adran Disgrifiad Gwall ar waelod y Golygydd Sgript bydd rhestru'r fanylion neu y gwall (au) gan gynnwys rhifau llinell. NODYN: Gall pob camgymeriad unigol yn y Disgrifiad adran Gwall fod yn ddwbl-glicio i fynd â chi i'r llinell cyfatebol yn y sgript.

Gwallau Casglu Sgriptio

Gwallau casgliad yn digwydd pan na fydd y gystrawen y cod sgript yn gywir. Bydd y rhain yn camgymeriadau arddangos i fyny ar waelod y ffenestr yn yr adran Gwall, gyda disgrifiad o'r camgymeriad, ac mae nifer llinell. Dyma'r rhif llinell sy'n gwahaniaethu gwall casgliad o wall Runtime (gweler isod), ni fydd yn cael rhif llinell. Gall camgymeriadau casgliad yn cael ei glicio dwbl i neidio ac yn tynnu sylw at y llinell penodol dan sylw.

Gwallau Runtime sgriptio (Pwysig)

Gwallau Rhedeg yn digwydd ar ôl y cod sgript wedi'i lunio yn llwyddiannus heb gamgymeriadau, ond fo gwall yn digwydd pan mae'n (gweler yr enghreifftiau i lawr ymhellach). Gwallau Rhedeg yn bwysig oherwydd gallant arwain at fodelau llygredig, pan fydd gwrthrychau a grëwyd ac a gyfeirio gan gwrthrychau eraill yn y model, nad ydynt eu hunain yn rhan o'r model (fel arfer oherwydd bod gwall Rhedeg wedi digwydd cyn i'r cod a fyddai wedi eu gosod yn y model rhywle, dienyddiwyd).

Os yw eich sgript yn creu gwrthrychau i'w hychwanegu at y model, gallwch osgoi llygredd a achoswyd gan gamgymeriad Rhedeg drwy arbed eich sgript, cau sgriptio, a pherfformio yn dadwneud y newidiadau a gafodd eu creu gan y sgript (os nad gweithredu sgript yn cwblhau fel arfer ). Fodd bynnag, mae yna hefyd ffyrdd eraill i osgoi unrhyw lygredd sy'n digwydd (gweler isod). Nodyn: Unrhyw sgriptiau sydd ond yn darllen o'r model ac nid ydynt yn ysgrifennu ato, yn ddiogel ac ni fydd yn achosi unrhyw broblemau, ni waeth a gwallau Rhedeg digwydd yn ystod eu gweithredu.

Er mwyn osgoi llygredd, wrth ysgrifennu cod sgript sy'n cael ei creu gwrthrychau ac yn eu hychwanegu at y model gwrthrych, awgrymir bod yr amcanion yn cael eu hychwanegu at y model cyn gynted â phosibl os ydynt yn cael eu gyfeirio gan gwrthrychau eraill.

Er enghraifft, os ydych yn creu cysylltiad newydd, a 2 chydrannau newydd, ac yna yn eu atodi at ei gilydd, y peth gorau i greu'r elfen gyntaf, ychwanegu at y model, yna yr ail a'i ychwanegu, ac yna creu cysylltiad a ychwanegu, ac yna yn olaf creu'r atodiadau. Mae hyn yn golygu, os oedd i fod yn gamgymeriad Rhedeg sy'n torri ar draws gweithredu sgript, pob gwrthrychau sy'n cael eu hangen i fod yn y objectmodel cyn atodiad yn cael ei greu, yn y model. Gall Llygredd ddigwydd os, er enghraifft, dim ond y cysylltiad wedi cael ei hychwanegu, mae'r atodiadau a wnaed, ac yna digwyddodd gwall Rhedeg cyn y sgript yn olaf ychwanegodd y cydrannau newydd i'r model.Corruption Gall ddigwydd pryd bynnag y gwrthrych sy'n cael ei gyfeirio gan wrthrych arall yn y objectmodel, nid yw ei hun yn y objectmodel.

Gwallau enghreifftiol Rhedeg yn cynnwys:

· Cyfeirnod gwrthrych heb ei osod i enghraifft o gwrthrych - mae hyn yn digwydd pan fydd newidyn gwrthrych yn gyfeiriad null, a dull neu eiddo ar y gwrthrych yn cael ei ddefnyddio. Gall cyfeiriadau Null yn cael ei wirio gan 'Os objectVariable A yw Nid oes dim Yna ...'

· Roedd Mynegai tu allan i ffiniau y rhesi - mae hyn yn digwydd pan fydd amrywiaeth yn cael ei gweld gyda mynegai sydd y tu allan i'r ffiniau - ee llai na 0 neu'n hafal i neu'n fwy na'r Hyd / Cyfrif y rhesi. Gall Array neu hyd Casgliad gael ei gwirio gan yr eiddo .Length neu'r .Count yn y drefn honno.

· Dim Eithriad Caniatâd - nid oes rhaid i chi ganiatâd i ... - mae hyn yn un yn digwydd os nad oes gennych ganiatâd i wneud y newid a roddir i chi

· Eithriad Allweddol - Dyblyg / Missing Enw / ID - bydd hyn yn un yn digwydd os bydd newid yn cael ei wneud i priodoledd unigryw sy'n gwrthdaro â'r wrthrych arall. E.e. Rhaid pensaernïaeth fod yn unigryw yn ôl enw, yn yr un modd â Safonau.

· Cyfeiriadol Uniondeb Eithriad - Gosod cae cyfeirio at wrthrych nad yw'n ddilys. E.e. ychwanegu 'dim' neu null fel plentyn i nifer o'r casgliadau yn y objectmodel.

· Zero Eithriad Hyd - gall hyn ddigwydd os ydych yn ceisio gosod enw gwrthrych i llinyn gwag. Mae'r rhan fwyaf gwrthrychau ei gwneud yn ofynnol eu henwau i gael o leiaf 1 cymeriad.

Datganiadau Mewnforion

Nodwch fod ar ddechrau'r y sgriptiau sgerbwd mae datganiadau o'r fath fel Mewnforion ABACUS.ObjectModel. Ni fydd y datganiadau yn cynnwys dll nad yw'n cael ei cyfeiriwyd eisoes gan y sgript - eu pwrpas yw darparu 'llwybr byr' i orfod nodi enw cyfan o ddosbarth.

Er enghraifft, i ddatgan newidyn o'r math CComponent (yn cynrychioli elfen yn ABACUS), gyda'r Mewnforion ABACUS.ObjectModelDatganiad tuag at frig y sgript, dim ond gwneud yn ofynnol iddo gael ei ddatgan fel comp dim fel CComponent, Oherwydd bod y compiler yn gwybod i edrych yn y gofod-enw ABACUS.ObjectModel ar gyfer y dosbarth CComponent. Heb y datganiad mewnforion, byddai'n rhaid iddo gael ei ddatgan fel dim comp fel ABACUS.ObjectModel.CComponent. Gall gwasanaeth (fel mscorlib.dll, neu System.Windows.Forms.dll) yn cynnwys mwy nag un namespace - y datganiad Mewnforion ar gyfer gofod enwau hyn, nid am y gwasanaethau eu hunain. Dim ond gan y cynulliad ABACUS.ObjectModel.dll y namespace ABACUS.ObjectModel sengl gael drwy Sgriptio.

Gwasanaethau y cyfeirir atynt yn awtomatig

Cyfeirir at y DLLs canlynol yn awtomatig gan Sgriptio:

· mscorlib.dll

· System.dll

· System.Drawing.dll

· System.Windows.Forms.dll

· Microsoft.VisualBasic.dll (cyfeirir ymhlyg gan y compiler)

· ABACUS.ObjectModel.dll

I wneud cyfeiriadau ychwanegol at naill ai gwasanaethau NET arall, neu eich cynulliadau eich hun, gweler yr adran ganlynol ar y #Datganiad ImportDLL.

#Datganiad ImportDLL

Gan ddechrau yn ABACUS 3.1, gallwch cyfeirnod gwasanaethau ychwanegol y gallech fod ei angen ar gyfer sgriptio gyda'r defnydd o'r #Datganiad ImportDLL. Er enghraifft, os ydych yn dymuno cael mynediad i DLL arfer o eiddo a ddefnyddio ymarferoldeb ynddo, a fyddech yn ei roi yn y cyfeiriadur ABACUS ac yn cynnwys y datganiad fel y llinell (au) cyntaf yn eich sgript. Os yw'n dll NET, yna fel arfer oes angen i chi fynd i mewn i'r llwybr cyfan, dim ond y DLL.

· #ImportDLL C: \ Program Files \ Avolution \ ABACUS \ YourDLL.dll

· #ImportDLL System.XML.dll

Rhai pethau eraill i'w nodi:

1. Gan fod angen dod o hyd yn llunio ac yn Rhedeg y DLLs, mae hyn yn cyfyngu ar arfer (heb fod yn NET) DLLs i gael ei osod yn y ffolder rhaglen ABACUS yn unig.

2. #Rhaid datganiadau ImportDLL fod y llinell (au) cyntaf o sgript - os oes gennych 5 datganiad, yna dylent fod ar y 5 llinell gyntaf y sgript

3. Mae #Datganiad ImportDLL ei gosod yn unman ond mae'r llinellau cyntaf y sgript (ee os cafodd ei gosod ar ôl sylw neu ddatganiad Mewnforion) ni fydd yn gweithio'n gywir a / neu a all achosi camgymeriadau compiler amherthnasol.

#ImportDLL gyda Chynulliadau Swyddfa

Os oes gennych gosod Microsoft Office, a bod eich sgript yn ofynnol i'r gwasanaethau Swyddfa interop, mae'n bosibl cyfeirio yn syml drwy ddefnyddio #ImportDLL gyda'r enw cynulliad (a restrir isod, e.e. #ImportDLL Excel). Gan ddefnyddio'r dull hwn y fantais nad yw'n cael llwybr dll llwyr i gael ei ddefnyddio, felly mae'r sgript yn fwy cludadwy (dylai weithio ar y ddau Office 2003 a 2007 heb golygu'r sgript).

Pan fyddwch yn defnyddio'r nodwedd hon, mae'r GAC (Global Cache Cynulliad) ei chwilio amdano i'r cynulliad interop, a'r sgript yn llunio gyda'r llwybr at y cynulliad os ceir. Os nad yw'n dod o hyd, bydd sgriptio yn gwirio cyfeiriadur rhaglen ABACUS (sy'n cynnwys y Excel a Visio interops yn unig). Os nad yw'r interop geisir yn cael ei ganfod gan y cyfnod hwn, rhybudd yn cael ei ddangos.

Fel arfer nid yw'r interops yn cael eu gosod yn y GAC os ydych wedi gosod Microsoft Office cyn gosod y Fframwaith NET (sy'n rhan o'r gosodiad ABACUS llawn). Gallwch eu gosod gan berfformio y dewis Newid ar gyfer Microsoft Office gan Add / Remove Programs, a dewis opsiynau Programmability NET. Am fwy o wybodaeth, gweler y erthygl ar MSDN.

Mae'r gwasanaethau y mae llwybr byr hwn yn cael ei gefnogi yw:

· Mynediad

· Access.Dao

· Excel

· Graff

· MSProject

· Outlook

· OutlookViewCtl

· Owc11

· Pwynt Pwer

· Cyhoeddwr

· SmartTag

· Visio

· Visio.SaveAsWeb

· VisOcx

· Word

INid yw t yn gwbl glir os yw'r holl cynulliadau uchod yn ddefnyddiol, ystafelloedd havebeen cynnwys yn y regardeless nodwedd gan fod rhai defnyddwyr yn cael Chwefror angen hyd yn oed y cynulliadau aneglur.

Gweler Hefyd

Efelychu eich pensaernïaeth

© 2001-2015 Avolution Pty Ltd Cedwir pob hawl.


Defnyddio Macros

Navigation: Efelychu eich pensaernïaeth>

Defnyddio Macros

Anfon sylwadau ar y pwnc hwn.

Os ydych yn perfformio tasg dro ar ôl tro yn ABACUS, gallwch automate y dasg drwy ddefnyddio macro. Yn unol â hynny, mae macro ABACUS yn gyfres gofnodwyd o weithrediadau y gellir eu hail ar unrhyw adeg.

Cofnodi Macro

1. Dewiswch Tools | Macro Cofnodneu fel arall pwyswch Alt + F10.

2. Dechrau gweithrediadau eich bod yn dymuno cofnodi perfformio.

Rhybudd

Ar hyn o bryd, mae rhai materion hysbys gyda chofnodi macro. Os gwelwch yn dda yn cymryd hyn i ystyriaeth wrth gofnodi eich macros:

· Ar hyn o bryd dim ond macros cofnodi eich keystrokes Microsoft Windows, llygoden-symudiadau a llygoden chleciau-. Fodd bynnag, oherwydd cyfyngiadau gyda'r recorder macro ei hun, mae rhai keystrokes sydd heb eu cofnodi bob amser. Mae'r rhain yn cynnwys:

· [Tab]

· [Ctrl]

· [Alt]

· [Esc]

· [Start]

· [F1] i [F12]

· Felly, argymhellir eich bod yn gwirio bod llwybr byr bysellfwrdd yn cael ei gofnodi gan y recordydd macro cyn recordio dilyniant fawr o ddigwyddiadau a all ddibynnu ar fod gweithio allweddell shortcut.

· Ar hyn o bryd oherwydd cyfyngiadau gyda'r recorder macro, nid bwydlenni cyd-destun yn cael eu trin yn briodol gan ABACUS pan maent yn cael eu hagor gan weithred gofnodwyd gan y recordydd macro. Pan fyddwch yn agor chyd-destun ddewislen, mae'n rhaid i chi berfformio un o'r swyddogaethau a restrir yn y ddewislen cyd-destun trwy gyfrwng y cyd-destun ddewislen, fel arall efallai y bydd y cyd-destun ddewislen aros ar agor yn ystod chwarae, a allai arwain at gamau neu weithredoedd anfwriadol a allai achosi camgymeriadau yn ABACUS.

· Noder bod y dulliau arferol o gau dewislen cyd-destun (ee pwyso [Esc] ar y bysellfwrdd, neu wedi gadael-glicio rhywle arall ar y sgrin) efallai na mewn gwirionedd yn cau'r chyd-destun ddewislen yn ystod chwarae o macro.

Tip

Yn deialogau, yn hytrach na defnyddio llygoden chleciau-, argymhellir i ddefnyddio'r fysell Tab i symud drwy'r rheolaethau sydd ar gael ac yr allweddi cyrchwr i ddewis eitemau ar y fwydlen tynnu-lawr neu ddewisiadau botwm radio a'r bar gofod i ddewis / dad-ddethol siec blychau.

I Stop recordio Macro

1. Wasg Alt + F9neu fel arall dewiswch Tools | Stop Macro.

2. Yn y Macro Save Fel bori deialog i leoliad a dewis ABACUS macro (ffeil .abacusmac) filename a chliciwch Save.

Nodyn

Defnyddio Offer| Stop Macroyn cynnwys llawdriniaeth hon yn y macro cofnodi. Felly, argymhellir bod defnyddwyr ddod yn hyfedr wrth ddefnyddio'r Alt + Swyddogaeth opsiynau allweddol ar gyfer gweithio gyda macros er mwyn peidio â cynnwys gweithrediadau macro diangen yn y macros eu hunain.

Tip

Gan nad yw'r macros yn eu golygu ar hyn o bryd, argymhellir i gofnodi tasgau hir fel cyfres o macros ar wahân gan ddefnyddio Alt + F10 / 'parau' F9 Alt +.

Er mwyn chwarae yn Macro a gofnodwyd

1. Dewiswch Tools | Playback Macroneu fel arall pwyswch Alt + F8.

2. Yn y pori ymgom Macro Ar agor i leoliad a dewis ABACUS macro (ffeil .abacusmac) filename a chliciwch Agored.

Rhybudd

Wrth agor macro ABACUS, os ydych yn dwbl-gliciwch ar ffeil macro gan yr ymgom bori i'w agor, efallai y bydd y recordydd macro dal y botwm chwith y llygoden-mewn cyflwr chwith-glicio hyd nes y bydd gofnodwyd chwith-glicio gwrthwneud y cyflwr hwn.

Nodyn

Gall y cyflymder chwarae y macro yn cael ei osod ar y tab Cyffredinol o dan Offer| Dewisiadaufel naill ai Normal (rhagosodyn), Fast neu Araf. Mae'r ddau Nid yw cyflymderau playback cyflym a Araf yn cael eu hargymell gan y byddant yn ail-chwarae y macros a gofnodwyd i`r tua 100 gwaith ac 1 / 100fed amser real, yn y drefn honno. Bydd cyflymder chwarae arferol yn dal i ail-chwarae y macro tua 30% yn gyflymach na'r cyflymder a gofnodwyd felly argymhellir tra'n recordio i oedi am gyfnod byr ar ôl i unrhyw dasgau prosesu hir i sicrhau nad ar chwarae nad yw'r llawdriniaeth nesaf ei gyflawni cyn i'r dasg prosesu wedi gwblhau.

I Stop chwarae Macro wedi'i recordio

1. Wasg Alt + F9.


Efelychu Perfformiad

Navigation: Efelychu eich pensaernïaeth> efelychwyr>

Efelychu Perfformiad

Anfon sylwadau ar y pwnc hwn.

Cefndir

Mae'r gwerthuswr pensaernïol ar gyfer perfformiad yn efelychydd ddigwyddiad ar wahân sy'n gweithio trwy efelychu llif o negeseuon (neu docynnau) drwy gydol phensaernïaeth. Y ddamcaniaeth tu ôl i hyn yn deillio o ymchwil a wnaed gan Brifysgol Technoleg, Sydney, ac mae'n seiliedig ar Modelau Rhwydwaith Ciwio Haenau(LQNM), Amseru a Lliw Petri-Rhwydi(TCPN) a Gweithgaredd Diagramau Beicio(ACD).

Yn y efelychiad perfformiad ABACUS, prosesu ar un gydran yn cael ei yrru i raddau helaeth gan negeseuon a ddaeth iddo oddi wrth gydran arall. Gall yr egwyddorion y tu ôl i dechneg hon gael ei ddeall mewn pedair prif ran:

1. Y Neges-ganologcyfathrebu ei fodelu yn ABACUS ddefnyddio rhesymegol(Neu anuniongyrchol) cysylltiadau. Cysylltiadau Rhesymegol diffinio'r ymddygiad (amlder a data) o'r negeseuon a basiwyd rhwng y cydrannau. Byddai enghraifft dda o gysylltiadau rhesymegol fod y dilyniant yn llifo rhwng dau (2) prosesau busnes neu rhyngwynebau rhesymegol rhwng dau (2) ceisiadau.

2. Negeseuon Rhesymegol yn cael eu cludo i'w cyrchfan drwy hierarchaeth(Megis swimlanes adnoddau) neu uniongyrcholcysylltiadau (fel gwifrau corfforol). Er mwyn gwneud hyn gellir eu cyfeirio i fyny, ar draws ac yn ôl i lawr yr hierarchaeth (ymagwedd haenog) i ddilyn y llwybr uniongyrchol.

3. Gall y ffyddlondeb y model yn cael ei addasu i weddu. Er enghraifft, gall proses yn cael ei rannu i lawr hyd yn hyn fel bod pob proses a swyddogaeth elfennol ganddo ôl-troed prosesu ar wahân. Fel arall, efallai y bydd yn ddigon i gael dim ond un gwerth ar gyfer y broses gyfan, gan adlewyrchu cyfartaleddYmateb prosesu i neges.

4. Y gwir prosesucael ei berfformio yn unig gan gydrannau sydd wedi (neu yn cael eu) brosesydd. Mae prosesydd yn beth generig, a gallai fod yn CPU, person, uned sefydliadol neu unrhyw beth arall sy'n gallu gwneud gwaith. Er enghraifft, nid yw proses fusnes yn gwneud unrhyw brosesu gwirioneddol; hyn yn cael ei wneud gan y 'prosesydd' gyntaf mae'n dod o hyd naill ai yn ei riant hierarchaeth (os yw nodiant colofn cyfrifoldeb yn cael ei ddefnyddio) neu ei rwydwaith brosesu (os yw nodiant prosesu a ddosbarthwyd yn cael ei ddefnyddio).

Mae'r gwerthusiad yn cael ei berfformio gan efelychu traffig (penodedig) yn y system, fel bod pob cysylltiad yn cael ei efelychu o leiaf unwaith. Amserau cyrraedd o negeseuon yn cael eu cynhyrchu ar hap o ran eu hamlder penodol. Mae'r model yn efelychu prosesu adnoddau a ymryson a ciwio o negeseuon, gan gasglu ystadegau ar hyd y ffordd wrth i eiddo allbwn amrywiol.

Ffactorau Mewnbwn Perfformiad Allweddol

1. Amlder- Pa mor aml y mae y cysylltiad yn digwydd.

2. Prosesu- Mae faint o amser gweithredu i gwblhau un broses. Gall hyn fod mewn oriau, munudau, dyddiau, gweithrediadau ac ati

3. Cyflymder- Mae cyflymder y prosesydd adnodd. Hynny yw, faint o gylchoedd / cyfarwyddiadau / camau gweithredu y gall ei berfformio mewn un uned o amser. Mae'n bwysig bod yn gyson â'r unedau a ddefnyddir ar gyfer Prosesu.

4. Proseswyr- Mae nifer o adnoddau prosesydd. Gallai Proseswyr fod yn bobl, CPU, yn sefydliadau allanol ac ati

Ffactorau Allbwn Perfformiad Allweddol

1. Trwybwn- Nifer o negeseuon bob uned amser drwy cysylltiad. Gall y gwerth gwirioneddol yn cael ei gymharu â'r gwerthoedd disgwyliedig / damcaniaethol (hy Amlder) i ddiddwytho dirlawnder y system.

2. Cyfradd Neges- Nifer o negeseuon bob uned amser drwy cydran. Mae hyn yn y swm o negeseuon sy'n dod i mewn ac yn mynd allan yr holl gydrannau '.

3. Ymateb- Mae'r isafswm / cyfartaledd / latency uchaf ar gyfer hyn cysylltiad. Mae hyn yn y swm yr holl latencies a welwyd ar gyfer y cysylltiad o'r ffynhonnell i'r sinc ac unrhyw ciwio a phrosesu (a latency yn ôl at y ffynhonnell os deugyfeiriadol).

4. Defnyddio- Mae defnydd y cydran. Bydd hyn yn 0% os nad yw'r gydran yn ddyfais / prosesydd (hy nid oes ganddo'r proseswyr ac eiddo Cyflymder diffiniad uchod).

Er efelychiad digwyddiad ar wahân yn cael ei berfformio i gyfrifo gwahanol briodweddau allbwn, fel y disgrifir uchod, efallai y bydd y fformiwla ganlynol yn cael ei ddefnyddio fel dilysu bras o'r canlyniadau (lle nad yw'r system yn cael ei dirlawn):

Defnyddio = Swm Amlder ar gyfer yr holl gysylltiadau sy'n cyrraedd * Prosesu / (Cyflymder * Proseswyr)

Mae'r cysyniad cyffredinol yn cael ei efallai dangos orau drwy ystyried y diagram canlynol, sy'n dangos dau meta-fodel perfformiad gwahanol. Mae'r arddull llaw chwith yw'r nodiant 'colofn cyfrifoldeb' clasurol gyda thasgau prosesu seiliedig hierarchaidd o fewn eu hadnoddau prosesydd. Mae'r arddull llaw dde yn nodiant 'ddosbarthu' gyda'r tasgau prosesu cysylltu trwy gysylltiad brosesau i'w adnodd prosesydd. Mae'r nodiant olaf yn caniatáu i adnoddau prosesydd lluosog ar gyfer tasg prosesu a roddwyd, yn wahanol i'r nodiant colofn cyfrifoldeb cyfyngedig.

Nodyn

A ddangosir ar bob un meta-model yw'r eiddo mewnbwn (mewn coch) ac eiddo allbwn (mewn glas):

Perfformiad meta-fodelau: colofn cyfrifoldeb yn erbyn nodiant Gwasgaredig

Rhedeg y efelychydd Perfformiad

I efelychu eich pensaernïaeth o ran perfformiad

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Dewiswch Dadansoddiad| Perfformiadneu cliciwch ar y botwm bar offer.

3. Dewiswch y Pensaernïaethydych yn dymuno i werthuso o'r ddewislen tynnu-lawr.

Nodyn

Yn ddiofyn, bydd ABACUS dewiswch y bensaernïaeth cyntaf y mae'n ofynnol ail-efelychiad o ganlyniad i unrhyw eiddo gwaelodol neu newidiadau strwythurol yn awtomatig.Mae'r tynnu sylw at ei ddangos yn Coch ar y Bar offer Efelychu .

4. Dewiswch y Cydrannauac Cysylltiadauydych yn dymuno i werthuso, gan y ffenestr dethol elfen safonol .

5. Gosod y Run Amser Graddfa Factorllithrydd.

Nodyn

Bydd y gwerthoedd uwch yn esgor ar fwy ystadegol canlyniadau cyson ond yn cymryd amser hirach i gyfrifo.

Ychwanegol Blwch ticioi'r ffenestr dethol elfen safonol

· Save Model GweddnewidBydd cadw copi o'r fersiwn RhBA drawsnewid y prosiect yn yr un ffolder wrth i'r prosiect ar hyn o bryd ac yn atodi "_transformed" i'r enw prosiect.Gall y prosiect hwn trawsnewid yn cael ei ddefnyddio i wneud diagnosis yn fanwl yr efelychiad dibynadwyedd a gynhaliwyd gan ABACUS.

Dewisiadau eraill i'r ffenestr dethol elfen safonol

· Run Amser Graddfa Factor rheoli amser efelychu a chywirdeb gyda uwch Gwerthoedd cynnyrchingfwy ystadegol canlyniadau cyson ond cymryd amser hirach i rhedeg.

Nodyn

Pan fydd ABACUS yn cyfrifo'r amser efelychiad bydd yn penderfynu ar y Amlder cysylltiad anuniongyrchol arafaf a ddewiswyd i gael ei efelychu ac yna 'cynhesu' ar gyfer y Cyfnod (hy 1 dros y Amlder) o'r cyswllt hwn (cychwyn generaduron neges cyfnodol ar gyfer yr holl gysylltiadau ar hap yn ystod y cyfnod cynhesu, gan roi pob cyfle i gychwyn) ac yna efelychu ar gyfer amseroedd Rhedeg Amser Graddfa Factor y Cyfnod y cysylltiad hwnnw iddynt. Neu (1 / Amlder) amser cynhesu + (1 / Amlder) * Graddfa Run Amser Ffactor amser efelychu. Mae hyn er mwyn gwneud yn siŵr bod bod y holl gysylltiadau yn cael eu cychwyn cyn ystadegau yn cael eu casglu ac yna y cysylltiad arafaf yn dal ffug o leiaf unwaith yn yr efelychiad. E.e. Os bydd y cysylltiad anuniongyrchol arafaf Mae gan Amlder 0.033-unedau amser (neu tua unwaith y mis os bydd yr amser-unedau diwrnod) yna bydd yr amser cynhesu yn 30.3-unedau amser a bydd yr amser efelychu fod 30.3 amser-unedau gwaith yr Ffactor Graddfa amser Run.

6. Cliciwch Gorffena byddwch yn cael Rhybudddeialog.

7. Optionally edrych ar y rhybuddion drwy glicio Manylion >>.

8. Cliciwch Parhau.

Nodyn

Ar y pwynt hwn, bydd ABACUS perfformio efelychiad arwahanol-ddigwyddiad y bensaernïaeth ac ar ôl cyfnod byr (gyda bariau cynnydd ar gyfer adborth) bydd ymgom cyflawn cyfrifiad yn ymddangos.

9. Cliciwch iawni gydnabod y efelychiad.

Tip

Ar gyfer cyrsiau hyfforddiant a help pellach ar Efelychu Perfformiad cyfeiriwch at y Cymuned Avolution .

Priodweddau Cydran

Mae'r tabl canlynol yn rhestru'r eiddo sy'n ofynnol i werthuso perfformiad. Eiddo eu chwilio amdanynt gyntaf yn yr achosion Cydran, yna bydd y Safonau Cydran ac os na dod o hyd, 'r ball yn cael ei ddefnyddio.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes mewnbwn eiddo ( [image] ) Gyda'r 'Mewnbwn Perfformiad' tooltip. Bydd newid i unrhyw un o'r eiddo 'mewnbwn' ac amryw newidiadau strwythurol i'r ystorfa arwain at efelychydd Perfformiad sy'n gofyn am ail-efelychu fel y nodwyd yn Coch ar y Bar offer Efelychu .

Math | Enw | Default Gwerth | Uned | Math Data | Yn eisiau | Disgrifiad
Ymddygiad | b_pack | 0.0 |  | Degol | Ffug | Mae'r amser y gwasanaeth penodedig i pecyn mewn eiliadau. Eiddo hwn yn nodweddiadol nodir fel math safonol ac yna eu defnyddio ar gyfer achosion gydran lluosog. Er enghraifft, CORBA wedi b_pack = 0.23 ms.
Ymddygiad | m_pack | 0.0 |  | Degol | Ffug | Mae'r amser gwasanaeth amrywiol i pecyn mewn seconds / beit. Eiddo hwn yn nodweddiadol nodir fel math safonol ac yna eu defnyddio ar gyfer achosion gydran lluosog.
Ymddygiad | b_unpack | 0.0 |  | Degol | Ffug | Mae'r amser y gwasanaeth penodedig i ddadbacio mewn eiliadau. Eiddo hwn yn nodweddiadolnodir fel math safonol ac yna eu defnyddio ar gyfer achosion gydran lluosog.
Ymddygiad | m_unpack | 0.0 |  | Degol | Ffug | Mae'r amser gwasanaeth amrywiol i ddadbacio mewn seconds / beit. Eiddo hwn yn nodweddiadolnodir fel math safonol ac yna eu defnyddio ar gyfer achosion gydran lluosog.
Ymddygiad | Prosesu | 0.0 |  | Degol | Gwir | Mae faint o amser gweithredu i gwblhau un broses. Gall hyn fod mewn oriau, munudau, dyddiau, gweithrediadau ac ati
Ymddygiad | Proseswyr | 1 |  | Cyfanrif | Gwir | Mae nifer o adnoddau Prosesydd. Gallai Proseswyr fod yn bobl, CPU, yn sefydliadau allanol ac ati
Ymddygiad | Cyflymder | 100 |  | Cyfanrif | Gwir | Mae cyflymder y prosesydd adnodd. Hynny yw, faint o gylchoedd / cyfarwyddiadau / camau gweithredu y gall ei berfformio mewn un uned o amser. Mae'n bwysig bod yn gyson â'r unedau a ddefnyddir ar gyfer Prosesu.
Ymddygiad | k_bkgd | 0.0 |  | Degol | Ffug | Prosesu Cefndir ar y gydran. Mae hyn yn cael ei ddefnyddio i addasu'r canlyniadau i gyd-fynd ag unrhyw offsets sefydlog ar gyfer%. Gall hyn yn ôl pob tebyg yn cael ei anwybyddu.

Mae'r tabl canlynol yn rhestru'r eiddo allbwn cydran gan y gwerthuswr perfformiad. Mae set o eiddo cydran hyn yn cael eu cynhyrchu ar gyfer pob cydran ar bob rhediad perfformiad.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Perfformiad'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd eiddo gwaelodol neu newid strwythurol i'r gadwrfa a'r efelychydd Perfformiad yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Math | Enw | Uned | Math Data | Yn eisiau | Disgrifiad
Ymddygiad | Cyfradd Neges |  | Degol | Ffug | Mae nifer o negeseuon bob uned amser drwy'r gydran. Mae hyn yn y swm o negeseuon sy'n dod i mewn ac yn mynd allan yr holl gydrannau '.
Ymddygiad | Lled Band |  | Degol | Ffug | Lled band gyffredinol drwy'r gydran. Mae'r swm sy'n ddyledus i'r negeseuon sy'n dod i mewn ac sy'n mynd allan.
Ymddygiad | Defnyddio | % | Degol | Ffug | Y defnydd o gydran. Bydd hyn yn 0% os nad yw'r gydran yn ddyfais / prosesydd (hy nid oes ganddo proseswyr ac eiddo Cyflymder diffiniad uchod)

Priodweddau Cysylltiad

Mae'r tabl canlynol yn rhestru'r eiddo sy'n ofynnol i werthuso perfformiad. Eiddo eu chwilio amdanynt gyntaf yn yr achosion Connection, yna bydd y Safonau Cysylltiad ac os na dod o hyd, 'r ball yn cael ei ddefnyddio.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes mewnbwn eiddo ( [image] ) Gyda'r tooltip 'Mewnbwn Perfformiad' neu 'Cost Mewnbwn / Perfformiad'. Bydd newid i unrhyw un o'r eiddo 'mewnbwn' ac amryw newidiadau strwythurol i'r ystorfa arwain at efelychydd Perfformiad a / neu Efelychydd Cost sy'n gofyn am ail-efelychu fel y nodwyd yn Coch ar y Bar offer Efelychu .

Math

Enw

Default Gwerth

Uned

Math Data

Yn eisiau

Disgrifiad

Ymddygiad

Kind

deugyfeiriad

[Deugyfeiriad | Uncyfeiriad]

Am-edrych / Rhestr

Gwir

P'un a yw'r cysylltiad yn ddwy-ffordd (deugyfeiriadol) neu un-ffordd (Uncyfeiriad).

Mae'r gwerthoedd a ganiateir ar gyfer yr eiddo hwn yn cael eu "deugyfeiriad" neu "Uncyfeiriad".

Deugyfeiriad yn golygu negeseuon cais / ymateb cydamserol tra fodd Uncyfeiriad yn "digwyddiad" unigol asynchronous.

Ymddygiad

Tynnu Dŵr

anuniongyrchol

[Anuniongyrchol | uniongyrchol]

Am-edrych / Rhestr

Gwir

P'un a yw'r cysylltiad yn gorfforol neu'n rhesymegol. Cysylltiadau uniongyrchol yn gorfforol "pibellau" rhwng dwy gydran bod cysylltiadau rhesymegol llifo ar hyd.

Mae'r gwerthoedd a ganiateir ar gyfer yr eiddo hwn yn cael eu "uniongyrchol" neu "anuniongyrchol".

Os yw gwerth yw "uniongyrchol" yna nid oes angen unrhyw eiddo arall y cysylltiad (ac eithrio ar gyfer y Kind a Echdynnu eiddo).

Data

L_app1

0

Cyfanrif

Ffug

Cais / maint ddigwyddiad yn bytes.

Bydd pob cysylltiad â gwerth penodol ar gyfer hyn fel arfer. Yn CORBA, digwyddiadau yn deugyfeiriadol mewn gwirionedd ac yn bob amser yn cael 12 beit cydnabod (L_app2). Os yw'n cysylltiad Uncyfeiriad wir, yna gadewch allan yr eiddo L_app2.

Data

L_app2

0

Cyfanrif

Ffug

Ymateb / cydnabod maint mewn bytes.

Bydd pob cysylltiad â gwerth penodol ar gyfer hyn fel arfer. Ni fydd cysylltiad Uncyfeiriad cael L_app2.

Ymddygiad

Amlder

1

Degol

Gwir

Pa mor aml y mae'r cysylltiad yn digwydd.

Bydd pob cysylltiad â gwerth penodol ar gyfer hyn fel arfer. Os yw'r Amlder eiddo yn cael ei adael allan yna 'r ball yn cael ei ddefnyddio.

Ymddygiad

Perthynas

prosesau

[Prosesau | cefnogi]

Am-edrych / Rhestr

Ffug

Cysylltiadau sydd â'r "prosesau" eiddo yn dangos y bydd y gydran ar ddechrau'r y cysylltiad yn cael ei drawsnewid i gael eu prosesu yn y gydran ar ddiwedd y cysylltiad. I bob pwrpas mae'r "ffynhonnell" cydran yn cael ei symud i fod yn blentyn y "sinc" gydran (y cysylltiadau sydd ynghlwm hefyd yn "llusgo" gyda symudiad hwn).

Os yn "prosesau" eiddo yn bodoli, yna bydd pob eiddo gysylltiad arall yn cael eu hanwybyddu, ac eithrio y "%" dewisol eiddo a ddisgrifir isod.

Ymddygiad

%

100.0

Degol

Ffug

Gall cysylltiadau sydd â'r eiddo "prosesau" (a ddisgrifir uchod) optionally gael "%" eiddo i nodi cyfran y prosesu a fydd yn cael eu priodoli i'r gydran gyrchfan. Fel hyn, gall cydran ffynhonnell sengl yn cael ei brosesu gan cydrannau cyrchfan lluosog mewn amrywiol% 's. Nid oes angen i'r% gwerthoedd i ychwanegu hyd at 100% ac mae'n cael ei ddefnyddio dim ond i raddfa y "prosesu" eiddo (gweler uchod) ar gyfer y gydran ffynhonnell gan ei fod yn cael ei drawsnewid i fod yn blentyn o gydran gyrchfan.

Mae'r tabl canlynol yn rhestru'r eiddo a gynhyrchir gan y gwerthuswr perfformiad. Mae set o eiddo cyswllt hyn yn cael eu cynhyrchu ar gyfer pob cysylltiad ar bob rhediad perfformiad.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Perfformiad'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd eiddo gwaelodol neu newid strwythurol i'r gadwrfa a'r efelychydd Perfformiad yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Math | Enw | Uned | Math Data | Yn eisiau | Disgrifiad
Ymddygiad | Lled Band |  | Degol | Ffug | Mae'r lled band cyffredinol ar gyfer y cysylltiad. Mae hyn yn unig yn cael ei gyfrifo ar gyfer cysylltiadau anuniongyrchol ac yn ei hanfod (L_app1 + L_app2) * Trwybwn.
Ymddygiad | Lled Band 1/2 |  | Degol | Ffug | Mae'r lled band yn benodol ar gyfer mynd allan (1) ac sy'n dod i mewn (2) negeseuon y cysylltiad. Mae hyn yn unig yn cael ei gyfrifo ar gyfer cysylltiadau anuniongyrchol ac yn ei hanfod L_app1 * Trwybwn a L_app2 * Trwybwn.
Ymddygiad | Trwybwn |  | Degol | Ffug | Mae nifer o negeseuon bob uned amser drwy'r cysylltiad. Gall y gwerth gwirioneddol yn cael ei gymharu â'r gwerthoedd disgwyliedig / damcaniaethol (hy Amlder) i ddiddwytho dirlawnder y system.
Ymddygiad | Wedi'i gwblhau | % | Degol | Ffug | Mae cant o negeseuon prosesu sy'n llwyddo i gwblhau ar gyfer y cysylltiad. Mae hyn yn unig yn cael ei gyfrifo ar gyfer cysylltiadau anuniongyrchol ac mae'n Trwybwn / Amledd. O bryd i'w gilydd mae'r gwerth Gwblhawyd yn fwy na 100% oherwydd bod y randomness o ganlyniadau cynhyrchu neges mewn amlder cenhedlaeth neges ychydig yn uwch na'r penodedig.
Ymddygiad | Ymateb (Isafswm / Ave / Max) |  | Degol | Ffug | Y lleiafswm / cyfartaledd / latency mwyaf posibl. Mae hyn yn unig yn cael ei gyfrifo ar gyfer cysylltiadau anuniongyrchol a dyma'r latency a welwyd ar gyfer y cysylltiad o'r ffynhonnell i suddo ac unrhyw ciwio a phrosesu (a latency yn ôl at y ffynhonnell os deugyfeiriadol).

Priodweddau Pensaernïaeth

Mae'r tabl canlynol yn rhestru'r eiddo pensaernïol system gyfan a gynhyrchir gan y gwerthuswr perfformiad. Mae un set o eiddo ar y bensaernïaeth yn cael eu "agregu" ar gyfer pob rhediad perfformiad.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Perfformiad'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd eiddo gwaelodol neu newid strwythurol i'r gadwrfa a'r efelychydd Perfformiad yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Math | Enw | Uned | Math Data | Yn eisiau | Disgrifiad
Ymddygiad | Cyfradd Neges |  | Degol | Ffug | Mae nifer o negeseuon bob uned amser trwy'r cydrannau yn y bensaernïaeth. Mae hyn yn y swm o negeseuon sy'n dod i mewn ac yn mynd allan yr holl gydrannau '.
Ymddygiad | Trwybwn |  | Degol | Ffug | Mae nifer o negeseuon bob uned amser drwy'r cysylltiadau yn y bensaernïaeth. Mae hyn yn y swm o drwygyrch holl gysylltiadau anuniongyrchol 'a gall hyn werth gwirioneddol yn cael ei gymharu â'r gwerthoedd disgwyliedig / damcaniaethol (hy Amlder) i ddiddwytho dirlawnder y system.
Ymddygiad | Lled Band |  | Degol | Ffug | Mae'r lled band cyffredinol. Swm o led band cyswllt y bensaernïaeth yn.
Ymddygiad | Defnyddio | % | Degol | Ffug | Mae'r defnydd o'r holl gydrannau. Gall fod yn fwy na 100% gan ei fod yn unig yw swm yr holl utilisations gydran y bensaernïaeth yn.
Ymddygiad | Ymateb (Isafswm / Ave / Max) |  | Degol | Ffug | Y lleiafswm / cyfartaledd / latency mwyaf posibl. Swm yr holl latencies a welwyd ar gyfer cysylltiadau y bensaernïaeth yn o ffynhonnell i suddo (ac yn ôl i'r ffynhonnell os deugyfeiriadol).


Efelychu gyfer modiwlau

Navigation: Efelychu eich pensaernïaeth> efelychwyr>

Efelychu gyfer modiwlau

Anfon sylwadau ar y pwnc hwn.

Mae'r efelychydd gyfer modiwlau yn cyfrifo nifer y cysylltiadau sy'n dod i mewn ac yn mynd allan ar gyfer pob cydran.

I efelychu eich pensaernïaeth o ran modiwlau

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Dewiswch Dadansoddiad| Modiwlau.

3. Dewiswch y Pensaernïaeth (au)hoffech gynnwys yn y gwerthusiad.

Nodyn

Yn ddiofyn, bydd ABACUS dewis y bensaernïaeth (au) y mae angen ail-efelychiad o ganlyniad i unrhyw newidiadau strwythurol sylfaenol yn awtomatig.Mae'r tynnu sylw at ei ddangos yn Coch ar y Bar offer Efelychu .

4. Cliciwch Nesaf.

5. Dewiswch y Mathau cysylltiad (au)hoffech gynnwys yn y gwerthusiad.

6. Cliciwch Nesaf.

7. Optionally customize 'r enwau eiddo ar gyfer y canlyniadau cyfrifiad.

8. Cliciwch Gorffen.

Nodyn

Ar y pwynt hwn, bydd ABACUS perfformio gwerthusiad strwythurol y bensaernïaeth (au) ac ar ôl cyfnod byr (gyda bariau cynnydd ar gyfer adborth) bydd ymgom cyflawn cyfrifiad yn ymddangos.

9. Cliciwch iawni gydnabod y gwerthusiad.

Tip

Ar gyfer cyrsiau hyfforddiant a help pellach ar Werthuso gyfer modiwlau cyfeiriwch at y Cymuned Avolution .

Priodweddau Cydran

Mae'r tabl canlynol yn rhestru'r eiddo cydran sy'n cael eu cynnyrch gan y gwerthuswr gyfer modiwlau.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn gyfer modiwlau'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd newid strwythurol sylfaenol i'r gadwrfa a'r efelychydd gyfer modiwlau yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Math | Enw | Math Data | Yn eisiau | Disgrifiad
Modiwlau | Cyplysu-fan yn (lleol) | Cyfanrif | Ffug | Nifer y cysylltiadau sy'n gefnogwr i mewn i gydran hon.
Modiwlau | Cyplysu-fan allan (lleol) | Cyfanrif | Ffug | Nifer y cysylltiadau sy'n gefnogwr allan o'r gydran hon.
Modiwlau | Cyplysu-fan yn | Cyfanrif | Ffug | Nifer o gysylltiadau sy'n gefnogwr i mewn i gydran hon, gan gynnwys cysylltiadau sy'n gefnogwr i mewn i is-gydrannau.
Modiwlau | Coupling-fan allan | Cyfanrif | Ffug | Nifer o gysylltiadau sy'n gefnogwr allan o'r gydran hon, gan gynnwys cysylltiadau sy'n gefnogwr i mewn i is-gydrannau.


Efelychu Cyfanswm Cost y Perchnogaeth (TCO)

Navigation: Efelychu eich pensaernïaeth> efelychwyr>

Efelychu Cyfanswm Cost y Perchnogaeth (TCO)

Anfon sylwadau ar y pwnc hwn.

Cefndir

Cyfanswm Cost y Perchnogaeth (TCO) yn amcangyfrif ariannol, a gynlluniwyd i fesur cyfanswm a dynnir costau cylch bywyd (o gaffael i ddadgomisiynu / gwaredu) sy'n gysylltiedig ag asedau sy'n eiddo. TCO nid yn unig yn adlewyrchu costau prynu, mae hefyd yn cynnwys pob agwedd arall yn y defnydd pellach a chynnal yr ased.

TCO cael ei ddefnyddio i benderfynu ar y ymdrech a chostau angenrheidiol gyllideb i wario ar system. Ffordd syml o fodelu mewn ABACUS am TCO yw torri'r system TG i lawr i mewn i gydrannau. Yna gallwn gael gwybod faint ar gyfartaledd mae'n ei gostio i redeg un o'r cydrannau hyn. Ar ôl hyn y gallem wedyn ffactor mewn gwahanol costau yn dibynnu a yw'r system TG yn evolvable neu'n agored ac ati Os system eisoes ar waith, y prif ffactor i'w ystyried yw cost cynnal a chadw ac efallai y gost i ddadgomisiynu.

Enghraifft

Diagram ar gyfer Enghraifft Cyfrifo

Mae gan y gydran dan Sefydliad neu ei safon eiddo hyn:

· FTE= 100 000 $ / yr

· Ymdrech Cymorth= 0.01 FTE + 0.001 FTE / yr = 1,000 $ + $ 100 / yr

· Cost cynnal a chadw= 100 $ - $ 10 / yr

· Cost Cyfalaf= 2,000 $

· Gosod Ymdrech= 2 FTE / dyddiau = 0.01 cyfwerth ag amser llawn / yr = 1,000 $

Mae gan y gydran dan y Sefydliad eiddo hyn:

· Gosod Horizon= -2 Blynedd (hy y system yn gosod 2 flynedd cyn y presennol)

· Hydoes= 3 blynedd

Pryd Gosod Horizon + Hyd Oes <= 0 , Nid oes mwy Cost cynnal a chadw.

Cyfrifiadau

Mae'r cyfrifiadau fel a ganlyn:

Nodyn

TC = y gost fesul blwyddyn. SE = Ymdrech Cymorth. MC = Cost cynnal a chadw.

· Cost gychwynnol cost = Cyfalaf + Gosod Ymdrech= 2000 + 1000 = 3000 $

· Ar t = -2 (yn ystod y flwyddyn 1af), TC = Cost gychwynnol + SE + MC= 3000 + 1000 + 100 = 4100 $

· Ar t = -1, TC = SE + MC= (1000 + 100) + (100-10) = 1190 $

· Ar t = 0, TC = (1000 + 200) + (100-20) = 1280 $

· Ar t = 1 (blwyddyn olaf), TC = (1000 + 300) + (100-30) = 1370 $

Graff ar gyfer Enghraifft Cyfrifo

TCO yw swm yr holl gostau presennol a'r dyfodol nes bod y system wedi cael ei dadgomisiynu.

· Ar t = -2 (yn ystod y flwyddyn 1af), TCO = 4100 + 1190 + 1280 + 1370 = 7940 $

· Ar t = -1, TCO = 1190 + 1280 + 1370 = 3840 $

· Ar t = 0, TCO = 1280 + 1370 = 2650 $

· Ar t = 1 (blwyddyn olaf), TCO = 1,370 $

Ffactorau Cost Allweddol

Y ffactorau cost allweddol i'w hystyried wrth gyfrifo TCO o ased yn ABACUS yw:

· Caledwedd Caffael- Cost gychwynnol yr offer (cost cyfalaf).

· Meddalwedd Caffael- Cost gychwynnol y drwydded ar gyfer meddalwedd (cost cyfalaf).

· Gosod- Costau sy'n gysylltiedig â setup cychwynnol.

· Hyfforddiant- Costau cysylltiedig â hyfforddiant gwerthwr allanol ar ôl setup cychwynnol.

· Cymorth- Costau sy'n gysylltiedig â chymorth mewnol.

· Cynnal a Chadw- Costau i gymryd lle neu uwchraddio werthwr contractau cynnal a chadw, cyflenwadau a chostau adfer mewn argyfwng.

· Isadeiledd- Costau sy'n gysylltiedig â cefnogi'r ased.

Enghraifft ABACUS Cynrychiolaeth Ffactorau Cost Allweddol

Rhedeg y efelychydd Cost

I efelychu eich pensaernïaeth o ran cost

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Dewiswch Dadansoddiad| Cost.

3. Dewiswch y Pensaernïaeth (au)hoffech gynnwys yn y gwerthusiad.

Nodyn

Yn ddiofyn, bydd ABACUS dewis y bensaernïaeth (au) y mae angen ail-efelychiad o ganlyniad i unrhyw eiddo gwaelodol neu newidiadau strwythurol yn awtomatig.Mae'r tynnu sylw at ei ddangos yn Coch ar y Bar offer Efelychu .

4. Dewiswch y Arian cyfredoddi wrth y dynfa i lawr.

5. Symudwch y Blynyddoedd i gyfrifollithrydd at y nifer o flynyddoedd eu hangen.

Nodyn

Yn ddiofyn, os yw'r Blynyddoedd i gyfrifo yn fwy na 1 blwyddyn bydd y costau yn cael ei gyfrifo yn awtomatig ar gyfer pob blwyddyn unigol (a chasgliad o eiddo ychwanegwyd / diweddaru) ac yna mae gwerth cronnus am y nifer cyfan o flynyddoedd hefyd cyfrifo. Os oes angen dim ond y gwerth cronnol yna uncheck 'r Cyfrifwch Costau Fesul-Blwyddynopsiwn fel y disgrifir isod i arbed ar nifer yr eiddo yn y prosiect.

6. Dewiswch a ydych am adael Cyfrifwch Costau Fesul-Blwyddynwirio neu dad-diciwch ef.

7. Cliciwch Nesaf.

8. Optionally yn dewis y Cysylltiadauydych yn dymuno i briodoli costau ynghyd fel rhan o'r gwerthusiad.

Nodyn

Defnyddio Cost | Priodoliadeiddo ar y costau cysylltiadau Gall fod yn priodoli oddi wrth y gydran ynghlwm wrth y sinc ddiwedd y cysylltiad i gydran ynghlwm wrth ben ffynhonnell(Hy Cost | Attribution = "Sinc i ffynhonnell"), neu oddi wrth y gydran sydd ynghlwm wrth y ffynhonnell diwedd y cysylltiad i gydran ynghlwm wrth y sinc diwedd(Hy Cost | Priodoli = "Ffynhonnell i Sinc"). Yn ychwanegol, Bydd ABACUS yn dewis cysylltiadau hynny yn awtomatig gyda Ymddygiad | Perthynas = "prosesau" neu "cefnogi"a bydd cyfeiriad y priodoliad fod yn 'Sinc i ddod o'. Ar ben hynny, mae'r costau'n dosrannu yn unol ag unrhyw ymddygiad | % Neu Cost | Eiddo% ar y cysylltiadau, neu fel arall lle ceir cysylltiadau lluosog o sinc i nifer o ffynonellauneu ffynhonnell i lawer o sinciau, Yn ôl unrhyw Ymddygiad | Eiddo prosesu ar y cydrannau ffynhonnellneu sinc cydrannau yn y drefn honno.

9. Cliciwch Gorffena byddwch yn cael Rhybudddeialog.

10. Optionally edrych ar y rhybuddion drwy glicio Manylion >>.

11. Cliciwch Parhau.

Nodyn

Ar y pwynt hwn, bydd ABACUS perfformio gwerthusiad costio seiliedig ar weithgareddau o bensaernïaeth (au) ac ar ôl cyfnod byr (gyda bariau cynnydd ar gyfer adborth) bydd ymgom cyflawn cyfrifiad yn ymddangos.

12. Cliciwch iawni gydnabod y gwerthusiad.

Tip

Ar gyfer cyrsiau hyfforddiant a help pellach ar Efelychu Cost cyfeiriwch at y Cymuned Avolution .

Cydran a / neu Cysylltiad Priodweddau

Mae'r tabl canlynol yn rhestru'r gydran a / neu gysylltiad eiddo sydd eu hangen i werthuso cost.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes mewnbwn eiddo ( [image] ) Gyda'r 'Mewnbwn Costau' tooltip. Bydd newid i unrhyw un o'r eiddo 'mewnbwn' ac amryw newidiadau strwythurol i'r ystorfa arwain at efelychydd Cost gofyn am ail-efelychu fel y nodwyd yn Coch ar y Bar offer Efelychu .

Math

Enw

Default Gwerth

Uned

Math Data

Yn eisiau

Disgrifiad

Cost

Gosod Horizon

0

flynyddoedd

Cyfanrif

Gwir

Mae hwn yn dynodi pryd y gydran neu gysylltiad wedi, neu yn cael eu gosod.

· Mae gwerth o 0 (y rhagosodiad) yn nodi bod y gydran neu gysylltiad yn cael ei osod yn y flwyddyn gyfredol.

· Mae gwerth llai na 0 yn dynodi bod y gydran neu gysylltiad wedi cael ei osod yn y gorffennol.

· Mae gwerth mwy na 0 yn dynodi bod y gydran neu gysylltiad yn cael eu gosod yn y dyfodol.

Cost

Hydoes

0

flynyddoedd

Cyfanrif

Gwir

Mae hwn yn dynodi hyd yr amser y mae'r gydran neu gysylltiad yn aros mewn grym, ac wedi hynny bydd yn cael ei dadgomisiynu.

Cost

FTE

100,000.00

$ / Blwyddyn

Degol

Ffug

Mae'r gost flynyddol o bob Gweithiwr Llawn Amser.

Os nad yw hyn eiddo i'w gael yn y gydranei hun neu yn achos cysylltiadau gydran ynghlwm wrth y sinc ddiwedd y cysylltiad, Bydd yn cael ei chwilio amdano mewn cydrannau eraill.

Yn gyntaf, unrhyw 'sinc' cydransar ddiwedd y a cysylltiad â pherthynas "cefnogi" at y gydran Bydd ei chwilio, ac yna y rhiant gydran 'sinc's.

Os nad yw'r eiddo FTE i'w gael, y gydran yn rhiantYna bydd -components ei chwilio. Os FTE yn dal yn dod o hyd, mae'r gwerth diofyn yn cael ei ddefnyddio.

Sylwer: dim ond eiddo mewnbwn dilys ar gydrannau FTE yw.

Cost

Cost cynnal a chadw (sefydlog)

0.00

$ / Blwyddyn

Degol

Ffug

Mae cost sefydlog blynyddol o gynnal y gydranneu gysylltiad.

Cost

Cost cynnal a chadw (amrywiol)

0.00

$ / Blwyddyn

Degol

Ffug

Mae'r swm y cyfanswm cost cynnal y gydran neu gysylltiad yn newid bob blwyddyn.

Er enghraifft, mae gwerth o $ -500 dangos bod cyfanswm y gost cynnal a chadw yn gostwng gan $ 500 yr un flwyddyn, tra mae gwerth $ 500 yn dangos bod cyfanswm y cynnydd mewn costau cynnal a chadw gan $ 500 yr un flwyddyn.

Cost

Ymdrech Cymorth (sefydlog)

0.00

FTE / blwyddyn

Degol

Ffug

Mae'r ymdrech sefydlog blynyddol o gefnogi cydranneu gysylltiad, A bennir o ran person-mlynedd.

Cost

Ymdrech Cymorth (amrywiol)

0.00

FTE / blwyddyn

Degol

Ffug

Mae'r swm y mae cyfanswm yr ymdrech o gefnogi'r gydran neu gysylltiad yn newid bob blwyddyn.

Er enghraifft, mae gwerth o -0.01 yn dangos bod cyfanswm yr ymdrech cymorth yn gostwng erbyn 0.01 o flynyddoedd person bob blwyddyn, tra bod gwerth 0.01 yn dangos bod cyfanswm y cynnydd ymdrechion cymorth gan 0.01 bob blwyddyn.

Cost

Cost Cyfalaf

0.00

$

Degol

Ffug

Y gost gychwynnol o brynu'r gydranneu gysylltiad.

Cost

Gosod Ymdrech

0.00

FTE

Degol

Ffug

Mae'r ymdrech sydd ei hangen, yn bersonol-mlynedd, i osod y gydranneu gysylltiad.

Mae'r tabl canlynol yn rhestru'r gydran a / neu gysylltiad eiddo sydd allbwn gan y gwerthuswr TCO. Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Costau'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd eiddo gwaelodol neu newid strwythurol i'r gadwrfa a'r efelychydd Cost yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Nodyn

Ble angen i'r cartrefi allbwn o'r gwerthuswr TCO yn 'talgrynnu' r "hanner Rownd i hyd yn oed" dull (cyfeirir atynt hefyd fel 'bancwyr' talgrynnu) yn cael ei ddefnyddio.Mae'r dechneg yn cael ei ddefnyddio i ddatrys unrhyw .5 fwy cyfartal 'clymu-seibiannau' gyda'r canlyniad yn cael ei dalgrynnu i fyny neu i lawr i'r agosaf hyd yn oed ganlyniad, yn hytrach na bob amser yn talgrynnu i fyny neu i lawr ac yn sgiwio y canlyniad. H.y. 2.5 yn cael ei dalgrynnu i lawr i 2, tra bod 3.5 yn cael ei dalgrynnu i fyny i 4, yn hytrach na'u y ddau yn cael eu naill ai dalgrynnu i lawr i 2 a 3 neu dalgrynnu i fyny i 3 a 4.

Math | Enw | Uned | Math Data | Yn eisiau | Disgrifiad
Cost | Cyfanswm y Gost i Own - x mlynedd nesaf. | $ | Cyfanrif | Ffug | Mae cyfanswm cost perchnogaeth dros y nesaf xflynyddoedd, lle mae x yn hyd yr amser penodedig wrth redeg y gwerthuswr. Mae hyn yn cynnwys cost y gydran neu gysylltiad yn safonau, is-gydrannauneu is-gysylltiadau(h.y. plant) ac unrhyw gostau a briodolir.
Cost | Cyfanswm y Gost i Own (lleol) - nesaf x flynyddoedd. | $ | Cyfanrif | Ffug | Mae cost 'lleol' o berchnogaeth dros y nesaf xflynyddoedd, lle xyw hyd yr amser penodedig wrth redeg y gwerthuswr. Mae hyn yn ei wneud Nicynnwys cost is-gydrannau y gydran neu is-gysylltiadau cysylltiad yn (h.y.plant) neu unrhyw gostau a briodolir.
Cost | Cyfanswm y Gost i Own (plant) - x mlynedd nesaf. | $ | Cyfanrif | Ffug | Mae cost 'plant' o berchnogaeth dros y nesaf xflynyddoedd, lle mae x yn hyd yr amser penodedig wrth redeg y gwerthuswr. Mae hyn yn yn unig cynnwys cost is-gydrannau y gydran neu is-gysylltiadau cysylltiad yn (h.y. plant).
Cost | Cyfanswm y Gost i Own (a briodolir) - nesaf x flynyddoedd. | $ | Cyfanrif | Ffug | Mae cost 'priodoli' o berchnogaeth dros y nesaf xflynyddoedd, lle mae x yn hyd yr amser penodedig wrth redeg y gwerthuswr. Mae hyn yn yn unig yn cynnwys unrhyw gostau a briodolir gan y cydrannau sydd ynghlwm(A all, wrth gwrs, yn cynnwys costau priodoli o unrhyw gysylltiadau sydd ynghlwm).

Mae'r tabl canlynol yn rhestru'r gydran a / neu gysylltiad eiddo sydd allbwn gan y gwerthuswr TCOos yw'r Cyfrifwch Per-Blwyddyn Costau ddewisiad a ddewisir. Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Costau'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd eiddo gwaelodol neu newid strwythurol i'r gadwrfa a'r efelychydd Cost yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Nodyn

Gweler y nodyn uchod ar y talgrynnu posibl o eiddo allbwn.

Math | Enw | Uned | Math Data | Yn eisiau | Disgrifiad
Cost | Cyfanswm y Gost i Own - blwyddynx. | $ | Cyfanrif | Ffug | Mae cyfanswm cost perchnogaeth ar gyfer blwyddyn x, Lle mae x yn ar gyfer pob blwyddyn nodi wrth redeg y gwerthuswr. Mae hyn yn cynnwys cost y gydranneu gysylltiad yn safonau, is-gydrannau neu is-gysylltiadau (h.y. plant) ac unrhyw gostau a briodolir.
Cost | Cyfanswm y Gost i Own (lleol) - blwyddynx. | $ | Cyfanrif | Ffug | Mae cost 'lleol' o berchnogaeth ar gyfer y flwyddyn x, Lle xyw ar gyfer pob blwyddyn nodi wrth redeg y gwerthuswr. Mae hyn yn ei wneud Nicynnwys cost is-gydrannau y gydran neu is-gysylltiadau cysylltiad yn (h.y. plant) neu unrhyw gostau a briodolir.
Cost | Cyfanswm y Gost i Own (plant) - blwyddynx. | $ | Cyfanrif | Ffug | Cost y 'plant' o berchnogaeth ar gyfer y flwyddyn x, Lle mae x yn ar gyfer pob blwyddyn nodi wrth redeg y gwerthuswr. Mae hyn yn yn unig cynnwys cost is-gydrannau y gydran neu is-gysylltiad gysylltiad yn (h.y. plant).
Cost | Cyfanswm y Gost i Own (a briodolir) - blwyddynx. | $ | Cyfanrif | Ffug | Mae cost 'priodoli' o berchnogaeth ar gyfer y flwyddyn x, Lle mae x yn ar gyfer pob blwyddyn nodi wrth redeg y gwerthuswr. Mae hyn yn yn unig yn cynnwys unrhyw gostau a briodolir gan y cydrannau sydd ynghlwm(A all, wrth gwrs, yn cynnwys costau priodoli o unrhyw gysylltiadau sydd ynghlwm).

Ychwanegol Priodweddau Cysylltiad

Mae'r rhestrau tabl canlynol ychwanegol eiddo cysylltiad sy'n ofynnol gan y gwerthuswr TCO. Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes mewnbwn eiddo ( [image] ) Gyda'r 'Input costau / Perfformiad' neu dim ond 'Mewnbwn Cost' tooltip. Bydd newid i unrhyw un o'r eiddo 'mewnbwn' ac amryw newidiadau strwythurol i'r ystorfa arwain at Cost a / neu Efelychydd Perfformiad sy'n gofyn am ail-efelychu fel y nodwyd yn Coch ar y Bar offer Efelychu .

Math

Enw

Default Gwerth

Uned

Math Data

Yn eisiau

Disgrifiad

Cost

Priodoliad

Sinc at Ffynhonnell

[Ffynhonnell i Sinc | Sinc at Ffynhonnell]

Am-edrych / Rhestr

Gwir

Os "Ffynhonnell i Sinc", Cyswllt hwn Bydd cael cael costspriodoli 'hyd' mae'n oddi wrth y ffynhonnellcydran i'r sinc cydran. Fel arall, os "Sinc at Ffynhonnell", Cyswllt hwn Bydd wedi costau priodoli 'hyd' mae'n oddi wrth y gydran sinc i'r gydran ffynhonnell.

Ymddygiad

Perthynas

cefnogi

[Prosesau | cefnogi]

Am-edrych / Rhestr

Ffug

Os "cefnogi", y cyswllt hwn yn dangos bod "ffynhonnell" cydran yn cael ei gefnogi gan y "sinc" cydran.

Yn ogystal, os bydd naill "yn cefnogi" neu "prosesau" yna bydd y cysylltiad yn cael eu dewis yn awtomatig yn y cysylltiadau i gael eu costau priodoli 'hyd' o'r gydran sinc i'r gydran ffynhonnell.

Cost

%

100.0

%

Degol

Ffug

Yn dangos cyfran y costau cydrannau sinc fydd yn cael eu priodoli i'r gydran ffynhonnell. Nid oes angen i'r% gwerthoedd i ychwanegu hyd at 100% ac mae'n cael ei ddefnyddio dim ond i raddfa y "Cyfanswm y Gost i Own -. X mlynedd nesaf" eiddo (gweler uchod) oddi wrth y gydran sinc wrth iddo gael ei briodoli i'r gydran ffynhonnell.

Priodweddau Pensaernïaeth

Mae'r tabl canlynol yn rhestru'r eiddo pensaernïaeth sy'n cael eu cynnyrch gan y gwerthuswr TCO. Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Costau'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd eiddo gwaelodol neu newid strwythurol i'r gadwrfa a'r efelychydd Cost yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Nodyn

Gweler y nodyn uchod ar y talgrynnu posibl o eiddo allbwn.

Math | Enw | Uned | Math Data | Yn eisiau | Disgrifiad
Cost | Cyfanswm y Gost i Own - x mlynedd nesaf. | $ | Cyfanrif | Ffug | Cyfanswm cost perchnogaeth y bensaernïaeth gyfan dros y x mlynedd nesaf.

Mae'r tabl canlynol yn rhestru'r eiddo pensaernïaeth sy'n cael eu cynnyrch gan y gwerthuswr TCOos yw'r Cyfrifwch Per-Blwyddyn Costau ddewisiad a ddewisir. Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Costau'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd eiddo gwaelodol neu newid strwythurol i'r gadwrfa a'r efelychydd Cost yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Nodyn

Gweler y nodyn uchod ar y talgrynnu posibl o eiddo allbwn.

Math | Enw | Uned | Math Data | Yn eisiau | Disgrifiad
Cost | Cyfanswm y Gost i Hun - blwyddynx. | $ | Cyfanrif | Ffug | Mae cyfanswm cost perchnogaeth ar gyfer y bensaernïaeth cyfan ar gyfer y flwyddyn xyn y dyfodol.


Efelychu Dibynadwyedd ac Argaeledd

Navigation: Efelychu eich pensaernïaeth> efelychwyr>

Efelychu Dibynadwyedd ac Argaeledd

Anfon sylwadau ar y pwnc hwn.

Cefndir

Mae'r Dibynadwyedd Gwerthuswr yn cyfrifo dibynadwyedd y bensaernïaeth drwy ddefnyddio'r cydrannau a chysylltiadau mewnbwn.

Ar gyfer cydrannau a chysylltiadau uniongyrchol, dibynadwyedd yn seiliedig ar Amser Cymedrig Rhwng Methiant (MTBF). Yr unig newidynnau hangen i gyfrifo dibynadwyedd elfennau pensaernïol yw:

· Y MTBFwerth (mewn blynyddoedd);

· Y Cymedrig Amser i Atgyweirio (MTTR)methiant (mewn blynyddoedd); ac

· Mae'r cyfnod penodol o amser er mwyn profi Dibynadwyedd drosodd.

Mae'r fformiwla a ddefnyddir i gyfrifo'r Dibynadwyedd yn cael ei roi fel:

Dibynadwyedd = -e (-y × oed)
Lle y = 1 ÷ MTBF

Mae argaeledd cydrannau a chysylltiadau yn seiliedig ar y MTBF a'r MTTR. Sylwch fod argaeledd, yn wahanol i dibynadwyedd, cael ei effeithio gan y cyfnod o amser y mae'n cael ei brofi.

Argaeledd = MTBF / (MTBF + MTTR)

Er bod dulliau sy'n trawsnewid Dibynadwyedd Diagramau Bloc(Gan ddefnyddio cyfres syml ac yn adeiladu cyfochrog) rhoi'r mwyaf union ganlyniadau, mae'r dulliau hyn yn dod yn hynod imymarferol pan rydym yn ceisio i gyfrifo'r dibynadwyedd ar gyfer teithiau o fewn rhwydweithiau enfawr o filoedd o elfennau. Ar ben hynny, dulliau trawsnewidiol hyn yn torri i lawr ar gyfer nifer o strwythurau cyffredin, fel rhwydwaith "rhwyllau".

Y Monte Carlodull yn caniatáu i'r dibynadwyedd ac argaeledd system o faint a chymhlethdod mympwyol i gael eu cyfrifo. Mae'r dull Monte Carlo efelychu nifer o senarios ac fneu bob un senario cyflwr ar hap, ar gael neu ddim ar gael, Yn cael ei neilltuo i bob elfen gorfforol. Mae'r tebygolrwydd o elfen a roddir fod mewn cyflwr sydd ar gael yn seiliedig ar ddibynadwyedd / y gydran sydd ar gael.

Er enghraifft, gellir disgwyl gydran gyda 90% ar gael i fod ar gael mewn tua 90% o'r senarios. Felly, gall dibynadwyedd ac argaeledd y cysylltiad anuniongyrchol yn cael ei amcangyfrif fel y gyfran o'r scenarios- ar hap y mae llwybr o elfennau yn bodoli mewn y wladwriaeth sydd ar gael o'r ffynhonnell i'r gyrchfan.

Nodyn

Ers cyfrifo dibynadwyedd ac argaeledd lleol yn seiliedig ar wahanol paramedrau a gwahanol fformiwlâu (ac felly yn arwain at werthoedd gwahanol), mae angen i neilltuo pob elfen dauyn datgan, Un ar gyfer argaeledd, ac un ar gyfer dibynadwyedd. Mae cyfrifo argaeledd defnyddio'r argaeledd wladwriaeth ym mhob senario, tra bod y cyfrifiad o ddibynadwyedd yn defnyddio'r dibynadwyedd wladwriaeth ym mhob senario.

Mae'r gwerthuswyr dibynadwyedd yn defnyddio'r dechneg efelychu Monte Carlo i weithio allan y dibynadwyedd o bensaernïaeth arbennig. Mae'r bensaernïaeth yn cael ei rhoi drwy filoedd o efelychiadau unigol ac mae'r canlyniadau ar ffurf tabl i ddeillio mesur dibynadwyedd. Fel y soniwyd uchod, Monte Carlo yw'r dechneg gyflymaf i efelychu rhwydweithiau mwy a bydd yn gweithio gydag unrhyw (hy rhwyllog) strwythur cymhleth.

Mae'r gwerthuswr allbynnau pedwar gwerth:

1. Cenhadaeth Dibynadwyedddros nifer o flynyddoedd;

2. Argaeleddy pensaernïaeth;

3. Dibynadwyeddy cydran lleoldros nifer o flynyddoedd; ac

4. Argaeleddy cydran lleol.

Mae'r werthuswr yn cyfrifo y tebygolrwydd o y cydran neu weithio cysylltiad (h.y. Nid yw methu) a'r amser a gymerir i atgyweirio.

Sut mae safonau gyda MTBFs a / neu MTTRs yn cael eu trin

Os oes gan elfen (cydran neu gysylltiad) Safonau gyda MTBF neilltuo a / neu MTTR gwerthoedd, gwerthoedd hyn yn cael eu defnyddio wrth gyfrifo ddibynadwyedd leol ac argaeledd o elfen fel cysylltiad cyfres.

Er enghraifft, os yw cydran A, Gyda safonau a bennwyd B, C, A Dpob un yn cael MTBF ac MTTR gwerth, Lleol Dibynadwyedd = R(A)× R(B) × R(C) × R(D), Lle R = Dibynadwyedd a gyfrifir (gan ddefnyddio'r fformiwla) y gydran / safonauac Lleol Ofergallu = A (A)× A (B) × A (C) × A (D), Lle A = Cyfrifo ofergallu (gan ddefnyddio'r fformiwla) y gydran / safonau. Hynny yw, os oes elfen wedi tair safon pob un gyda MTBF ac MTTR gwerths, Ac mae hefyd yn MTBF ac MTTR gwerthsar gyfer eiddo yr elfen, mae'r dibynadwyedd leol a avilability yn cael ei roi fel gwerth cyfres o bob un o'r safonau a'r elfen ei hun.

Fel enghraifft arall, os cydran AMae gan y safonau a bennwyd B, C, A Dond dim ond safonol BMae gan y ddau â MTBF a gwerth MTTR, tra safonol CDim ond werth MTBF a safon DDim ond gwerth MTTR, Lleol Dibynadwyedd = R (A)× R (B)× R (C), Lle R= Dibynadwyedd a gyfrifir (gan ddefnyddio'r fformiwla) y gydran / safonau a Lleol Argaeledd = A (A)× A (B)× A (C), Lle A= Argaeledd gyfrifo (gan ddefnyddio'r fformiwla) y gydran / safonau, ond wrth gyfrifo A (C) oherwydd dim ond mae gan y safon werth MTBF ei 'chwiliadau'ar gyfer y gwerth (oedd) MTTR paru a bydd yn ychwanegu holl MTTR gwerthoedd y mae'n darganfod bod don't cael gwerth MTBF cyfateb eu hunain, felly yn yr achos hwn y byddai'n defnyddio gwerth MTTR o safon D. Os oedd safon arall, yn dweud E, Gyda dim ond gwerth MTTR yn ogystal, yna A (C)fyddai'n defnyddio'r MTBF o Cgyda'r MTTR o Dac Ehychwanegu at ei gilydd. Os safon arall, yn dweud F, Roedd dim ond gwerth MTBF, yna A (F)Byddai hefyd yn defnyddio'r MTTR o Dac Ehychwanegu at ei gilydd.

Cyfrifo Cenhadaeth Dibynadwyedd

Tra cyfrifo dibynadwyedd lleol yn fater o ddefnyddio fformiwla syml, nid cyfrifo cysylltiadau anuniongyrchol (genhadaeth) mor hawdd, yn enwedig pan fydd gennym rwydweithiau cymhleth a mawr o lwybrau plethog (cysylltiadau) a chydrannau.

Gan gymryd y rhwydwaith cyfan i ystyriaeth

Gan nad yw'r cysylltiadau anuniongyrchol yn cynrychioli cysylltiad corfforol, mae'n rhaid i ni gael gwybod sut y gall y gydran ffynhonnell gyrraedd ei gyrchfan cydran. Ac mae hyn yn awgrymu edrych ar y rhwydwaith cyfan a'r holl ffyrdd gwahanol (a llwybrau) gall ein cydran ffynhonnell cymryd i gyrraedd y gydran cyrchfan (sinc).

Nodyn

Cyn belled ag y mae o leiaf un cwblhaullwybr o'r ffynhonnell i'r gyrchfan, bydd y genhadaeth yn llwyddiannusa'r cysylltiad anuniongyrchol cyfeirir ato fel cysylltiad Ar gau.

Deall y Matrics Link

Er mwyn gwybod pa gydrannau / cysylltiadau uniongyrchol yn gysylltiedig â'r hyn, mae angen arteffact i wirio gyflym a dau floc yn cael eu cysylltu i gyfeiriad penodol. Mae hyn yn swyddogaeth y matrics cyswllt. Yn gryno, mae'r matrics ddolen amrywiaeth dau ddimensiwn o newidynnau Boole sy'n nodi a oes modd gydran benodol cyrraedd gydran arall yn uniongyrchol. Mae ei maint yn hafal i sgwâr o gyfanswm nifer y cydrannau yn y rhwydwaith.

A Dibynadwyedd Syml Bloc Diagram (ABA)

Link Matrics cysylltiedig ar gyfer Dibynadwyedd Bloc Diagram (ABA)

Gan nad yw pob cysylltiad yn bi-gyfeiriadol (mynd y ddwy ffordd), mae'n bwysig gwybod sut i ddarllen y matrics cyswllt yn gywir. Yn y gwerthuswyr dibynadwyedd, y ddadl gyntaf yw'r ffynhonnell a'r ail ddadl yw y gyrchfan (sinc).

Felly, os matrics cyswllt (A, B) = Gwir, yna mae'n golygu bod A yn gallu cael i B yn uniongyrchol (uni-gyfeiriadol). Gall B gyrraedd A os mai dim ond os bydd matrics cyswllt (B, A) = Gwir. Os yw hyn yn wir, mae hyn yn awgrymu cysylltiad bi-cyfeiriadol.

Yn yr enghraifft a roddir uchod:

· Gall Ffynhonnell 1 yn cyrraedd cyrchfan 0 (Ffynhonnell 1 a Cyrchfan 0 yn rhoi canlyniad Gwir); ac

· Gall Ffynhonnell 0 cyrraedd cyrchfan 1 (Ffynhonnell 0 a Cyrchfan 1 yn rhoi o ganlyniad i True), gan fod y cyswllt rhwng 0 ac 1 yn deugyfeiriadol.

· Ni all Ffynhonnell 2 yn cyrraedd cyrchfan 1 (Ffynhonnell 2 a Cyrchfan 1 yn rhoi o ganlyniad i Gau) hyd yn oed pan y gall ffynhonnell 1 yn cyrraedd cyrchfan 2 (Ffynhonnell 1 a Cyrchfan 2 yn rhoi canlyniad Gwir). Mae hyn yn awgrymu bod y cyswllt rhwng 1 a 2 yn uni-gyfeiriadol.

Deall y Dibynadwyedd Bloc Diagram

Mae'r diagram bloc dibynadwyedd (ABA) yn crynhoi strwythur y model gwrthrych cyfan o ran blociau a chysylltiadau. Mae pob bloc yn cynrychioli elfen sydd â posibilrwydd o fethiant neu lwyddiant yn ôl y cysylltiadau / llwybrau sy'n eu cysylltu. Gall cydrannau a chysylltiadau dod yn "bloc" yn ABA.

Enghraifft Blociau ABA a Dolenni

Mae'r ffigur uchod yn enghraifft RBD. Mae'r llinell goch doredig yn cynrychioli un genhadaeth 4 i 1. Nodwch sut y mae dim ond dau lwybr posibl ar gyfer y genhadaeth 4-1.

Ystyriwch y Llwybr 4 at 3 neu 0-1, a'r llwybr 4 i 7 i 1. Mae'r blociau doredig 2, 5a 6 yn cynrychioli blociau nad ydynt yn effeithio y methiant / heb fod yn fethiant o genhadaeth 4 i 1. Nid ydynt yn cael eu hystyried ac yn cael eu hanwybyddu. Mae hyn yn bwysig ag ar gyfer y rhan fwyaf o genadaethau a fydd yna nifer fawr o flociau segur Ni fydd yn effeithio ar lwyddiant genhadaeth penodol yn. Mae hyn yn fwy amlwg mewn rhwydweithiau mwy o faint lle bydd y nifer o flociau segur sicrhau bod y canlyniadau efelychiad anghywir.

Er mwyn cyflymu'r amser efelychu, ac yn sicrhau canlyniadau mwy cywir, mae angen i'r haniaethol o'r ABA cyfan ac yn defnyddio dim ond yr elfennau sy'n effeithio ar lwyddiant genhadaeth yn.

Nodyn

Ni all llwybr / llwybr sengl yn mynd drwy unrhyw elfen ddwywaith.

Ar y cam hwn, gallwn greu matrics cyswllt a pherfformio efelychiad Monte Carlo.

Cyfrifo Argaeledd Pensaernïaeth

Mae argaeledd pensaernïaeth yw'r tebygolrwydd y bydd yr holl gysylltiadau anuniongyrchol fod ar gael ar unrhyw bwynt mewn amser. Mae argaeledd pob cysylltiad anuniongyrchol yn cael ei bennu yn ystod pob iteriad o'r efelychu Monte Carlo, fodd bynnag, cysylltiadau anuniongyrchol hyn (fel arfer) yn dibynnu ar yr un set o elfennau corfforol. Felly, yn syml agregu argaeledd unigol hyn fyddai "dwbl-gyfrif" hyn heb argaeledd, gan roi argaeledd pensaernïaeth cyffredinol besimistaidd. Fel arall, argaeledd pensaernïaeth gyffredinol yn cael ei gyfrifo drwy edrych ar bob iteriad a gweld a yw'r elfennau sy'n ymwneud â'r cysylltiadau anuniongyrchol o ddiddordeb ar gael. Ac yna agregu canlyniadau hyn ar ddiwedd y efelychiad.

Rhedeg y simulator Dibynadwyedd

I efelychu eich pensaernïaeth o ran dibynadwyedd

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Dewiswch Dadansoddiad| Dibynadwyedd.

3. Dewiswch y Pensaernïaethydych yn dymuno i werthuso o'r ddewislen tynnu-lawr.

Nodyn

Yn ddiofyn, bydd ABACUS dewiswch y bensaernïaeth cyntaf y mae'n ofynnol ail-efelychiad o ganlyniad i unrhyw eiddo gwaelodol neu newidiadau strwythurol yn awtomatig.Mae'r tynnu sylw at ei ddangos yn Coch ar y Bar offer Efelychu .

4. Dewiswch y Cydrannauac Cysylltiadauydych yn dymuno werthuso gan y ffenestr dethol elfen safonol gan ddefnyddio'r 'Show Cysylltiadau Uniongyrchol' a 'Dangos Prosesau Cysylltiadau' hidlwyr radio-botwm yn waelod chwith yr ymgom i gynorthwyo gyda chi dewis.

Ychwanegol Blwch ticioi'r ffenestr dethol elfen safonol

· Save Model GweddnewidBydd cadw copi o'r fersiwn RhBA drawsnewid y prosiect yn yr un ffolder wrth i'r prosiect ar hyn o bryd ac yn atodi "_transformed" i'r enw prosiect.Gall y prosiect hwn trawsnewid yn cael ei ddefnyddio i wneud diagnosis yn fanwl yr efelychiad dibynadwyedd a gynhaliwyd gan ABACUS.

Radio- YchwanegolBotymaui'r ffenestr dethol elfen safonol

· Dangos Cysylltiadau Uniongyrchol Bydd yn gosod cysylltiad awtomatig Yn meddu hidlo Eiddo ar gyfer eiddo Math = Ymddygiad, Name = Echdynnu a Gwerth = uniongyrchol.Mae'r opsiwn hwn yn cael ei ddewis yn ddiofyn ac yn cynorthwyo i ddewis y cysylltiadau 'uniongyrchol' fel y disgrifir uchod ac isod.

· Dangos Prosesau Cysylltiadau Bydd yn gosod cysylltiad awtomatig Yn meddu hidlo Eiddo ar gyfer eiddo Math = Ymddygiad, Enw = Perthynas a Gwerth = phrosesau.Mae'r opsiwn hwn yn cynorthwyo i ddewis y cysylltiadau 'uniongyrchol' fel y disgrifir uchod ac isod.

5. Cliciwch Nesaf.

6. Dewiswch y Cenhadaethhy Cysylltiadau hoffech gynnwys yn y efelychiad.

7. Gosod y Run Amser Graddfa Factorllithrydd.

Nodyn

Bydd y gwerthoedd uwch yn cynhyrchu canlyniadau cyson yn fwy ystadegol ond yn cymryd amser hirach i gyfrifo.

Blychau ticio

· Dangos Ar gau CysylltiadauBydd hidlo'r cysylltiadau ar gael yn awtomatig i ddim ond yn cynnwys y rhai sydd ag o leiaf un llwybr ffisegol cyflawn oddi wrth y gydran ffynhonnell i'r gyrchfan gydran yn unol â'r dewis ABA a ddisgrifir uchod.

· Dangos Cysylltiadau Anuniongyrchol Bydd yn gosod cysylltiad awtomatig Yn meddu hidlo Eiddo ar gyfer eiddo Math = Ymddygiad, Name = Echdynnu a Gwerth = anuniongyrchol.Mae'r opsiwn hwn yn cael ei ddewis yn ddiofyn ac yn cynorthwyo i ddewis y cysylltiadau 'anuniongyrchol' neu Cenhadaeth fel y disgrifir uchod ac isod.

Buttons

· All selects all the connections.

· Invert deselects all the currently selected connections and selects all those that weren't selected.

· None deselects all the connections.

Other options

· Run Time Scale Factor controls the simulation time and accuracy with higher values yielding more statistically consistent results but taking longer time to run.

Note

When ABACUS calculates the number of iterations to simulate it will determine the most reliable element that isn't perfectly reliable and then simulate for Run Time Scale Factor times 1 over the Unavailability of that element plus 1 iteration. Or (MTBF + MTTR) / MTTR * Run Time Scale Factor + 1. This is to make sure that that element still fails at least once in the simulation. E.g. If the most reliable element that isn't perfectly reliable has an MTBF of 10,000 hours and an MTTR of 8 hours then the simulation will take (10,000 + 8) / 8 = 1,251 times the Run time Scale Factor + 1 iterations.

· Years to Simulate Ahead determines the number of years for the Mission Reliability to be calculated for.

· Number of Threads determines the number of processing threads to use for the Monte-Carlo simulation. This option will default to match the number of available CPUs / cores (including hyper-threading cores) to minimise the overall simulation time.

8. Click Finish and you will get a Warning dialog.

9. Optionally explore the warnings by clicking Details >>.

10. Click Continue.

Note

At this point, ABACUS will perform a Monte-Carlo simulation of the architecture and after a short time (with progress bars for feedback) a calculation complete dialog will appear.

11. Click OK to acknowledge the simulation.

Tip

For training courses and further help on Reliability Simulation please refer to the Avolution Community .

Component and Connection Properties

The following table lists the component and 'direct' connection properties required to evaluate reliability. These properties will be shown in the Properties window with a property input row selector icon ( [image] ) with the tooltip 'Reliability Input'. A change to any of these 'input' properties and various structural changes to the repository will result in the Reliability simulator requiring a re-simulation as indicated in Red on the Simulation toolbar .

Type | Name | Default Value | Unit | Data Type | Required | Description
Reliability | MTBF | ∞ | years, weeks, days or hours | Decimal | True | The Mean Time Before Failure of the element. Note: Values can be expressed in units of years, weeks, days or hours and are converted following a '24/7' availability concept as follows; - 1 year = 52 weeks or 365 days or 8,760 hours - 1 week = 7 days or 168 hours - 1 day = 24 hours
Reliability | MTTR | 0 | years, weeks, days or hours | Decimal | True | The Mean Time To Repair of the element. Note: Values can be expressed in units of years, weeks, days or hours and are converted following a '24/7' availability concept as follows; - 1 year = 52 weeks or 365 days or 8,760 hours - 1 week = 7 days or 168 hours - 1 day = 24 hours

The following table lists the component and 'direct' connection properties output by the reliability evaluator. These properties will be shown in the Properties window with a property output row selector icon ( [image] ) with the tooltip 'Reliability Output'. The arrow on the icon will highlight Red ( [image] ) when these properties are out of date due to an underlying property or structural change to the repository and the Reliability simulator requires re-simulation according to the Red highlighting on the Simulation toolbar .

Type | Name | Unit | Data Type | Required | Description
Reliability | Reliability - x years |  | Decimal | False | The probability that the element will not fail within the next x years. This is a value between 0 and 1.
Reliability | Unreliability - x years |  | Decimal | False | The probability that the element will fail within the next x years. This is a value between 0 and 1.
Reliability | Availability | % | Decimal | False | The calculated availability of the component or connection. This is a value between 0% and 100%.
Reliability | Unavailability | % | Decimal | False | The calculated unavailability of the component or connection. This is a value between 0% and 100%.

The following table lists the 'indirect' connection properties output by the reliability evaluator. These properties will be shown in the Properties window with a property output row selector icon ( [image] ) with the tooltip 'Reliability Output'. The arrow on the icon will highlight Red ( [image] ) when these properties are out of date due to an underlying property or structural change to the repository and the Reliability simulator requires re-simulation according to the Red highlighting on the Simulation toolbar .

Type | Name | Unit | Data Type | Required | Description
Reliability | Mission Reliability - x years |  | Decimal | False | The probability that the indirect connection will not fail within the next x years. This is a value between 0 and 1.
Reliability | Mission Unreliability - x years |  | Decimal | False | The probability that the indirect connection will fail within the next x years. This is a value between 0 and 1.
Reliability | Availability | % | Decimal | False | The calculated availability of the indirect connection. This is a value between 0% and 100%.
Reliability | Unavailability | % | Decimal | False | The calculated unavailability of the indirect connection. This is a value between 0% and 100%.

Architecture Properties

The following table lists the architecture properties output by the reliability evaluator. These properties will be shown in the Properties window with a property output row selector icon ( [image] ) with the tooltip 'Reliability Output'. The arrow on the icon will highlight Red ( [image] ) when these properties are out of date due to an underlying property or structural change to the repository and the Reliability simulator requires re-simulation according to the Red highlighting on the Simulation toolbar .

Type | Name | Unit | Data Type | Required | Description
Reliability | Availability | % | Decimal | False | The availability of all indirect connections that have been included in the evaluation. That is, the probability that all indirect connections will be available at a given point in time. This is a value between 0% and 100%. Note: This is NOT the multiplication of the individual connection availabilities as this would be "double-counting" the un-availability of the relevant components.
Reliability | Unavailability | % | Decimal | False | The unavailability of the indirect connections that have been included in the evaluation. That is, the probability that at least one indirect connection will be unavailable at a given point in time. This is a value between 0% and 100%. Note: This is NOT the multiplication of the individual connection unavailabilities as this would be "double-counting" the un-availability of the relevant components.
Reliability | Mission Reliability - x years |  | Decimal | False | The probability that all of the indirect connections that have been included in the evaluation will be not fail within the next x years. This is a value between 0 and 1. Note: This is NOT the multiplication of the individual connection reliabilities as this would be "double-counting" the un-availability of the relevant components.
Reliability | Mission Unreliability - x years |  | Decimal | False | The probability that at least one of the indirect connections that have been included in the evaluation will fail within the next x years. This is a value between 0 and 1. Note: This is NOT the multiplication of the individual connection unreliabilities as this would be "double-counting" the un-availability of the relevant components.

© 2001-2015 Avolution Pty Ltd. All rights reserved.


Efelychu yn Agored

Navigation: Efelychu eich pensaernïaeth> efelychwyr>

Efelychu yn Agored

Anfon sylwadau ar y pwnc hwn.

Mae'r efelychydd yn agored yn penderfynu i ba raddau y mae pensaernïaeth a'i elfennau yn 'agored', hynny yw, mae gallu'r system i ddelio amnewid cydrannau sy'n cael effaith fach iawn.

I efelychu eich pensaernïaeth o ran bod yn agored

1. Sicrhewch fod gennych y ffeil ABACUS, Yn cynnwys eich pensaernïaeth poblog, agored.

2. Dewiswch Dadansoddiad | Bod yn Agored.

3. Dewiswch y Pensaernïaeth (au)hoffech gynnwys yn y gwerthusiad.

Nodyn

Yn ddiofyn, bydd ABACUS dewiswch y bensaernïaeth cyntaf y mae'n ofynnol ail-efelychiad o ganlyniad i unrhyw eiddo gwaelodol neu newidiadau strwythurol yn awtomatig.Mae'r tynnu sylw at ei ddangos yn Coch ar y Bar offer Efelychu .

4. Cliciwch Gorffena byddwch yn cael Rhybudddeialog.

5. Optionally edrych ar y rhybuddion drwy glicio Manylion >>.

6. Cliciwch Parhau.

Nodyn

Ar y pwynt hwn, bydd ABACUS perfformio gwerthusiad strwythurol y bensaernïaeth (au) ac ar ôl cyfnod byr (gyda bariau cynnydd ar gyfer adborth) bydd ymgom cyflawn cyfrifiad yn ymddangos.

7. Cliciwch iawni gydnabod y efelychiad.

Tip

Ar gyfer cyrsiau hyfforddiant a help pellach ar Werthuso Bod yn Agored cyfeiriwch at y Cymuned Avolution .

Cydran a Cysylltiad Properties Safonol

Mae'r tabl canlynol yn rhestru'r eiddo safonol gydran a chysylltiad eu hangen i werthuso natur agored.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes mewnbwn eiddo ( [image] ) Gyda'r 'Mewnbwn Bod yn Agored' tooltip. Bydd newid i unrhyw un o'r eiddo 'mewnbwn' yn yr ystorfa yn arwain at y efelychydd yn Agored gofyn am ail-efelychu fel y nodwyd yn Coch ar y Bar offer Efelychu .

Math | Enw | Default Gwerth | Uned | Math Data | Yn eisiau | Disgrifiad
Bod yn Agored | Safonau-safonol Aeddfedrwydd-Sefydliad Lefel |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Lefel y Corff cyfrifol Safonau 0:Sefydliadol / Perchnogol 1:Consortiwm / defacto 2:Cenedlaethol / Milwrol 3:Rhyngwladol
Bod yn Agored | Safonau-safonol Aeddfedrwydd-Statws |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Lefel Cymeradwyo a gyflawnwyd gyda'r corff safonau 0:Drafft y Pwyllgor / Gweithio 1:Drafft / pleidlais gyhoeddus 2:Drafft Interim 3:Cymeradwy
Bod yn Agored | Safonau-safonol Aeddfedrwydd-Sefydlogrwydd |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | A yw'r safon debygol o newid? 0:Safon wedi darfod 1:Yn amodol hynod o newid yn nesaf 1 i 2 flynedd 2:Hysbys newid / diweddariadau i nodweddion presennol 3:Hynod sefydlog (dim newid o fewn 2 flynedd)
Bod yn Agored | Safonau-safonol Cymorth Aeddfedrwydd-Gwerthwr |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Cymorth Gwerthwr 0:Dim cynhyrchion neu werthwyr cefnogi'r safon 1:Un neu fwy o werthwyr sy'n gweithredu cyfran o'r safon 2:Mae mwy nag un gwerthwr gyda chynhyrchion sy'n gweithredu pob rhan o'r safon 3:Mae llawer mwy nag un gwerthwr gyda chynhyrchion sy'n gweithredu pob rhan o'r safon
Bod yn Agored | Safonau-Standard eglurder-Dogfennaeth |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Ansawdd y dogfennau safonol 0:Gwael 1:Ffair 2:Da 3:Rhagorol
Bod yn Agored | Safonau-Standard eglurder-Standard Lled |  |  | Cyfanrif | Ffug | Nifer o nodweddion. Mae cyfrif o'r nodweddion safonol lefel isaf - SF
Bod yn Agored | Safonau-Standard eglurder-Sm |  | % | Degol | Ffug | Canran o gyfanswm nifer o nodweddion sy'n orfodol
Bod yn Agored | Safonau-Standard eglurder-So |  | % | Degol | Ffug | Canran o gyfanswm nifer o nodweddion sy'n ddewisol
Bod yn Agored | Safonau-Standard eglurder-Sc |  | % | Degol | Ffug | Canran o gyfanswm nifer o nodweddion sy'n cael eu diffinio yn amodol
Bod yn Agored | Proffiliau-Proffil Dogfennaeth-Dogfennaeth |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Ansawdd y dogfennau safonol 0:Dim 1:Gwael 2:Ffair 3:Rhagorol
Bod yn Agored | Proffiliau-Proffil Dogfennaeth-Cywirdeb |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | A yw'r dogfennau yn adlewyrchu cynllun y system ei hun? Pa lefel o nodweddion proffil yn cael eu defnyddio yn y system? 0:Dim nodweddion 1:Rhai nodweddion 2:Mae'r rhan fwyaf o nodweddion 3:Mae'r holl nodweddion
Bod yn Agored | Proffiliau-Proffil Dogfennaeth-Aeddfedu |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | A yw'r proffil aeddfed ac ar gael? 0:Ad-hoc 1:Seiliedig ar brosiectau 2:Sefydliadol 3:Cyhoeddus
Bod yn Agored | Proffiliau-Proffil Lled eglurder-clir |  |  | Cyfanrif | Ffug | Nifer o nodweddion safon benodol yn ôl y gofyn yn y proffil
Bod yn Agored | Proffiliau-Proffil eglurder-Pm |  | % | Degol | Ffug | Canran y nodweddion GORFODOL yn y proffil
Bod yn Agored | Proffiliau-Proffil eglurder-Po |  | % | Degol | Ffug | Canran y DEWISOL nodweddion yn y proffil
Bod yn Agored | Proffiliau-Proffil eglurder-Pc |  | % | Degol | Ffug | Canran y AMODOL DIFFINIEDIG nodweddion yn y proffil
Bod yn Agored | Proffiliau-Proffil eglurder-Pwnc o dan sylw |  | % | Degol | Ffug | Canran y nodweddion safonol afael yn benodol yn y proffil
Bod yn Agored | Estyniadau-Estyniad Proffiliau-Proffil Lled |  |  | Cyfanrif | Ffug | Nifer o ansafonol nodweddion a bennir gan y proffil
Bod yn Agored | Proffiliau-Proffil Estyniadau-Pwnc o dan sylw |  | % | Degol | Ffug | Canran y estyniadau a nodir yn y proffil
Bod yn Agored | Argaeledd Cynhyrchion-Cynnyrch a Cydymffurfiaeth-Nifer o Cynhyrchion |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Nifer o gynhyrchion cefnogi nodweddion orfodol o'r safon 0:Dim cynnyrch yn cefnogi'r safon 1:Un neu fwy o gynhyrchion yn gweithredu dogn o safon 2:Mae mwy nag un cynnyrch yn gweithredu bob rhan o'r safon 3:Mae llawer mwy nag un cynnyrch yn gweithredu bob rhan o'r safon
Bod yn Agored | Argaeledd Cynhyrchion-Cynnyrch a Cydymffurfiaeth-Cais Cydymffurfiaeth |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Pa lefel o gydymffurfiad oes cynnyrch wedi i'r safon? 0:Dim 1:Hawliwyd 2:Dangosodd 3:Ardystiedig a Dangos
Bod yn Agored | Argaeledd Cynhyrchion-Cynnyrch a Cydymffurfiaeth Cydymffurfiaeth Ansawdd |  | [0 | 1 | 2 | 3] | Am-edrych / Rhestr | Ffug | Ansawdd y profion cydymffurfiaeth 0:Dim 1:Yn fewnol profi gan ddatblygwr cynnyrch 2:Profion annibynnol (ee NIST) 3:Y dangoswyd yn y cyd-destun o gynnyrch perthnasol

Cydran, Connection ac Eiddo Pensaernïaeth

Mae'r tabl canlynol yn rhestru'r gydran, cysylltiad ac allbwn eiddo pensaernïaeth gan y gwerthuswr yn agored. Mae pob un o'r eiddo canlynol yn gwerthuso i rhwng sero (0) a thri (3), sero (0) yw'r lleiaf dymunol a thri (3) y rhai mwyaf dymunol.Bydd y rhain yn eiddo yn cael eu dangos yn y ffenestr Properties gydag eicon selector rhes allbwn eiddo ( [image] ) Gyda'r tooltip 'Allbwn Bod yn Agored'. Bydd y saeth ar yr eicon yn tynnu sylw at Coch ( [image] ) Pan fydd yr eiddo hyn yn gyfredol oherwydd newid eiddo sylfaenol i'r gadwrfa a'r efelychydd yn Agored yn gofyn am ail-efelychiad yn ôl y Coch gan amlygu ar y Bar offer Efelychu .

Math | Enw | Math Data | Yn eisiau | Disgrifiad
Bod yn Agored | Bod yn Agored | Degol | Ffug | Gwerthusiad cyffredinol o fod yn agored eitem yn.
Bod yn Agored | Aeddfedrwydd Safonau-safonol | Degol | Ffug | Mae cyflwr presennol y safon, gan adlewyrchu ai peidio yw wedi cael ei gymeradwyo, pa mor hir y mae wedi bod yn eu defnyddio a pha mor dda y mae'n ei dderbyn o fewn y gymuned o ddatblygwyr.
Bod yn Agored | Safonau-Standard eglurder | Degol | Ffug | Mae eglurder y safonau, gan adlewyrchu'r amwysedd posibl mewn safonau a ddilynodd
Bod yn Agored | Proffiliau-Proffil Dogfennaeth | Degol | Ffug | Y graddau y mae proffil rhyngwyneb ddogfennaeth yn cael ei ddatblygu ac a yw'r dogfennau proffil yn adlewyrchu'r cynllun y system gwirioneddol a / neu'r system ar waith
Bod yn Agored | Proffiliau-Proffil eglurder | Degol | Ffug | Mae lefel y manylder a ddarperir mewn manyleb proffil / proffil
Bod yn Agored | Proffiliau-Proffil Estyniadau | Degol | Ffug | Y graddau y mae'r proffil yn cydymffurfio â'r safon ar y mae'n seiliedig
Bod yn Agored | Cynnyrch-Cynnyrch Argaeledd a Cydymffurfiaeth | Degol | Ffug | P'un ai peidio mae cynhyrchion conformant safon agored ar gael i'w defnyddio yn y prosiect


Adroddiadau Safonol

Navigation: Adrodd ar eich pensaernïaeth>

Adroddiadau Safonol

Anfon sylwadau ar y pwnc hwn.

ABACUS ' safonol adroddiadau yn eich galluogi i gael rhestr o elfennau a chysylltiadau mewn un neu fwy o'ch saernïaeth. Mae'r adroddiad yn cynnwys yr holl wybodaeth sy'n ymwneud â'r cydrannau a chysylltiadau a ddewiswyd, gan gynnwys gwybodaeth am y cydran neu lle gysylltiad yn yr hierarchaeth, math, safonau, disgrifiad, eiddo a'i atodiadau.

Nodyn

Mae cynnwys yr adroddiad ywconfigurabletrwy yr ymgom Adroddiad Opsiynau a ddisgrifir isod, fodd bynnag, to gael mwy o wybodaeth am sut i greu arfer yn gyfan gwbl ffurfweddu adroddiadaugan ddefnyddio Adroddiadau Custom ABACUS, Os gwelwch yn dda cyfeirio at y pwnc yma neu cysylltu Cymorth Avolution .

I weld safonol adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog(Au).

2. Dewiswch Mewnosod| Adroddiad Safonolneu cliciwch ar y Creu Adroddiad Safonol botwm bar offer. Y Ffurfweddu adroddiadBydd ffenestr yn cael ei arddangos.

Ffenestr Adroddiad Ffurfweddiad

3. Dewiswch y Pensaernïaeth, Cydrannauac Cysylltiadaueich bod am yn yr adroddiad gan y Adroddiad Ffenestr Ffurfweddiad.Cyfeiriwch at yr Elfen Dewis Safonol yma pwnc am help.

4. Nawr cliciwch ar y Dewisiadaubotwm a'r Adroddiad OpsiynauBydd ffenestr arddangos.

Ffenestr Adroddiad Dewisiadau

5. Gallwch ddewis dangos Tudalen newydd ar gyfer pob Elfen, Mae'r Argraffu Dyddiad, Print Amser, Rhifau Tudalenac a ddylid yn cynnwys y teitl yn y pennawdo'r adroddiad drwy roi tic / unticking y blychau gwirio perthnasol. Efallai y byddwch hefyd am addasu'r teitl ac awdur drwy olygu y Teitl yr Adroddiadac Awdur blychau testun. Gallwch hefyd ddewis pa gynnwys ei arddangos ar yr adroddiad drwy roi tic / unticking y blychau gwirio o dan y Adroddiad Cynnwysrhan o'r ffenestr. Ar ôl i chi orffen, cliciwch ar iawn.

6. Nawr cliciwch ar Gorffenyn y ffenestr Adroddiad Configuration.

Dehongli yr adroddiad viewable

Enghraifft Adroddiad Gynhyrchir gyda Esboniadau Brîff

I Navigate drwy'r tudalennau adroddiad, cliciwch ar yr eiconau [image] lleoli ar y bar offer ar gornel chwith uchaf y sgrin.

Nodyn

Gallwch arbed yr adroddiad i wahanol fformatau trwy glicio ar y Allforio Adroddiad icon [image] lleoli yn y bar offer. Gallwch ddewis i allforio yn y fformat isod: Excel, PDFac Word. Os gwelwch yn dda achub yr adroddiad yn y lleoliad a ddymunir i'w defnyddio'n ddiweddarach. Os bydd newidiadau yn cael eu gwneud i'r bensaernïaeth yn nes ymlaen, bydd adroddiad newydd gael eu creu i adlewyrchu'r newidiadau.

Gweler Hefyd

Dadansoddi eich pensaernïaeth


Adroddiadau Custom

Navigation: Adrodd ar eich pensaernïaeth>

Adroddiadau Custom

Anfon sylwadau ar y pwnc hwn.

Adroddiadau arfer ABACUS 'yn eich galluogi i greu adroddiadau arfer yn gyfan gwbl configurable. Gall yr adroddiadau hyn yn cynnwys delweddau a graffeg arfer, yn ogystal â rhoi manylion unrhyw gydrannau, cysylltiadau neu briodoleddau o ystorfa ABACUS yn ogystal â chanlyniadau dadansoddol manwl o wahanol efelychiadau (gan gynnwys TCO, Perfformiad a Dibynadwyedd). Yn ogystal, gall adroddiadau'n cynnwys diagramau, siartiau, catalogau, matricsau / tablau colyn, mapiau, mesuryddion, sparklines, bariau a dangosyddion data (ee traffig-goleuadau).

Nodyn

Er y gall unrhyw ddefnyddiwr agor adroddiadau arfer presennol, to ffurfweddu adroddiadau Mae angen y drwydded defnyddiwr y Ffurfweddu adroddiad gallu. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

I weld arfer adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog(Au).

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau CustomBydd ffenestr yn cael ei arddangos.

Adroddiadau Customffenestr

3. Dewiswch ysydd eisoes yn bodoli Adroddiadbod chi eisiau i arddangos oddi wrth y Adroddiadau ar Gaeladran.

4. Cliciwch Adroddiad Run.Bydd yr adroddiad yn agor yn Microsoft Adroddiad Viewer a to Navigate drwy'r tudalennau adroddiad, cliciwch ar yr eiconau [image] lleoli ar y bar offer ar gornel chwith uchaf y sgrin.

Nodyn

Gallwch arbed yr adroddiad i wahanol fformatau trwy glicio ar y Allforio Adroddiad icon [image] lleoli yn y bar offer. Gallwch ddewis i allforio yn y fformat isod: Excel, PDFac Word. Os gwelwch yn dda achub yr adroddiad yn y lleoliad a ddymunir i'w defnyddio'n ddiweddarach. Os bydd newidiadau yn cael eu gwneud i'r bensaernïaeth yn nes ymlaen, bydd adroddiad newydd gael eu creu i adlewyrchu'r newidiadau.

I olygu'r data storfa sy'n cael ei anfon at a arfer adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog(Au).

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau Customffenestr (A ddangosir uchod) yn cael eu harddangos.

Nodyn

Er y gall unrhyw ddefnyddiwr agor adroddiadau arfer presennol, to ffurfweddu mae'r data sy'n cael ei anfon at adroddiad arferiad Mae angen y drwydded defnyddiwr y Ffurfweddu adroddiad gallu. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

3. Dewiswch ysydd eisoes yn bodoli Adroddiadbod chi eisiau i arddangos oddi wrth y Adroddiadau ar Gaeladran.

4. Cliciwch Setiau Data Golygu. Y Set Ddata GolygyddBydd ffenestr yn cael ei arddangos.Mae'r ffenestr yn dangos y casgliad o setiau data sy'n cael eu hanfon ar hyn o bryd at adroddiad arferiad. Yn yr enghraifft isod, mae tri (3);

· set ddata ApplicationProxy sy'n pennu'r holl fanylion ar gyfer yr holl gydrannau Cais yn y bensaernïaeth '2015 Gwirioneddol' (gan gynnwys yr eiddo ar eu Safonau ac unrhyw gydrannau ynghlwm),

· set ddata TwoDViewProxy sy'n pennu'r un neu ragor o diagramau lle mae'r enw yn cyfateb 'Tirwedd Gais (Awstralia)',

· set ddata TargetProxy sy'n pennu'r holl fanylion am yr holl gysylltiadau Targed yn y bensaernïaeth '2015 Gwirioneddol' (yn cynnwys y cydrannau ynghlwm).

Set Ddata Golygyddffenestr

Nodyn

Bydd y Ymholiad Enw ei ddefnyddio ar gyfer yr enw Set Ddata yn Microsoft Adroddiad Builder (gweler isod). Mae'r cae Dylech gynnwys pennu a yw'r set ddata naill ai'n Elfen Sengl, mae Casgliad o Elfennau, Pob Math Cydran, Pob Math Connection, un neu fwy o Pensaerniaethau, un neu fwy o diagramau neu un neu fwy Siartiau. Ar gyfer y 'Casglu Elfennau' setiau data botwm Filter yn cael ei ddarparu sy'n wrth glicio yn agor ffenestr Filter Elfen sy'n eich galluogi i wneud cais hidlwyr lluosog i ddychwelyd yn unig elfennau o rai saernïaeth, a / neu o fathau penodol, a / neu gyda rhai Safonau , a / neu sydd ynghlwm wrth rai cydrannau, a / neu gyda rhai rhieni, a / neu mewn rhai diagramau, a / neu mewn rhai Siartiau a / neu gyda gwerthoedd Eiddo a roddir. Ar gyfer y mathau eraill set ddata cae Enw yn cael ei ddarparu a defnyddio'r botwm Dewis gallwch ddewis y gwrthrych (au) i'w gynnwys gyda'r set data.

Nodyn

Mae'r setiau data yn cael eu storio mewnData Setiau ffeil (.xml)gyda'r un enw ffeil sylfaen fel maecysylltiedig Adroddiad ffeil Diffiniad (.RDL). Os na fydd y ffeil yn bodoli, bydd y golygydd set ddata boblogi yn awtomatig gydag unrhyw enwau ymholiad sy'n bodoli yn yr Adroddiad ffeil Diffiniad (.RDL)ac mae newydd Data Setiau ffeil (.xml)Bydd yn cael ei greu ar ôl aa rhestr ddilys o ymholiadau yn cael ei ddiffinio.

3. Os hoffech ddileu set ddata sy'n bodoli eisoes ac yna dewiswch y Dileu Ymholiadbotwm.

4. Os ydych yn dymuno ychwanegu osod ddata newydd yna cliciwch y Ychwanegu Set Ddata Newyddbotwm a ffurfweddu y set ddata yn unol â'r Nodyn uchod.

I creu arferiad newydd adroddiad(O templed)

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau Customffenestr (A ddangosir uchod) yn cael eu harddangos.

3. Cliciwch Newydd a dewis naill ai A4 - Portread, A4- Tirwedd, A3 - Portread, A3- Tirwedd, Unol Daleithiau Llythyr - Portread, Unol Daleithiau Llythyr - Tirwedd, Unol Daleithiau Tabloid - Portreadneu Unol Daleithiau Tabloid - Tirweddgan ddibynnu ar yr adroddiad gyfeiriadedd a phapur maint sy'n cael ei ddymunir.

4. Porwch i'r lleoliad i achub y Adrodd y ffeil Diffiniad (.rdl / .rdlc) a'r ffeil paru Set Data (.xml) a chliciwch Save. Bydd hyn yn ychwanegu adroddiad arferiad newydd i'r adran Adroddiadau Ar gael o'r ffenestr Adroddiadau Custom a gall agor neu ei olygu fel y disgrifir uchod.

I ychwanegu arfer sydd eisoes yn bodoli adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau Customffenestr (A ddangosir uchod) yn cael eu harddangos.

3. Cliciwch Ychwanegu a bori at y lleoliad yr Adroddiad ffeil Diffiniad (.rdl / .rdlc) a chliciwch Agored. Bydd hyn yn ychwanegu adroddiad arferiad newydd i'r adran Adroddiadau Ar gael o'r ffenestr Adroddiadau Custom a gall agor neu ei olygu fel y disgrifir uchod.

Nodyn

Tybir y ffeil Set Ddata cyfateb (.xml) yn bodoli yn yr un lleoliad â'r ffeil Adroddiad Diffiniad.

I copïo yn arferiad sy'n bodoli eisoes adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau Customffenestr (A ddangosir uchod) yn cael eu harddangos.

3. Dewiswch ysydd eisoes yn bodoli Adroddiadbod chi eisiau i gopïo oddi wrth y Adroddiadau ar Gaeladran.

4. Cliciwch Copi a bydd copi o'r adroddiad a ddewiswyd (a enwyd 'Copi o ...') yn cael eu hychwanegu at yr adran Adroddiadau Ar gael o'r ffenestr Adroddiadau Custom a gall agor neu ei olygu fel y disgrifir uchod.

Nodyn

Drwy wneud hyn byddwch yn creu copi o'r adroddiad Adroddiad Diffiniad ffeil (.rdl / .rdlc) yn ogystal â'i cyfateb ffeil Set Data (.xml)(Os yw'n bodoli).

I ddileu arfer sydd eisoes yn bodoli adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau Customffenestr (A ddangosir uchod) yn cael eu harddangos.

3. Dewiswch ysydd eisoes yn bodoli Adroddiadbod chi eisiau i gael gwared oddi wrth y Adroddiadau ar Gaeladran a chliciwch Tynnwch.

Nodyn

Pan fyddwch yn cael gwared adroddiad a bydd yn ymddangos mwyach ar y rhestr adroddiad. Fodd bynnag, ni fydd hyn yn dileu'r Adroddiad adroddiad Diffiniad ffeil (.rdl / .rdlc) neu'r Set Ddata ffeil(.xml). Os bydd angen, dileu ffeiliau hyn y gellir ei gyflawni drwy'r system ffeil.

I ail-enwi yn arferiad sy'n bodoli eisoes adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau Customffenestr (A ddangosir uchod) yn cael eu harddangos.

3. Dewiswch ysydd eisoes yn bodoli Adroddiadbod chi eisiau i ail-enwi mewn y Adroddiadau ar Gaeladran a chliciwch Ailenwi.

4. Rhowch enw newydd ar gyfer yr adroddiad.

Nodyn

Bydd y ddau Adroddiad ffeil Diffiniad (.rdl / .rdlc) a'r ffeil Set Ddata paru (.xml) ei ailenwi'n unol â hynny.

I olygu'r dyluniad arfer adroddiad

1. Sicrhewch bod gennych Ffeil ABACUS agored yn cynnwys eich pensaernïaeth poblog.

2. Dewiswch Mewnosod| Adroddiad Customneu cliciwch ar y Creu Adroddiad Custom botwm bar offer. Y Adroddiadau Customffenestr (A ddangosir uchod) yn cael eu harddangos.

Nodyn

Er y gall unrhyw ddefnyddiwr agor adroddiadau arfer presennol, to ffurfweddu dyluniad adroddiadau arfer Mae angen y drwydded defnyddiwr y Ffurfweddu adroddiad gallu. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.Yn ogystal, mae'n ofynnol Microsoft Adroddiad Builder 3.0 i ddylunio adroddiadau a gellir ei lawrlwytho am ddim o yma .

3. Dewiswch ysydd eisoes yn bodoli Adroddiadbod chi eisiau i arddangos oddi wrth y Adroddiadau ar Gaeladran.

4. Cliciwch Golygu Adroddiad.Bydd yr adroddiad yn agor mewn Microsoft Adroddiad Builder 3.0. Am gymorth penodol a rhai 'awgrymiadau a driciau' ar rai o'r tasgau mwy cyffredin gyda dylunio adroddiadau cyfeiriwch at yr adrannau isod. I gael cymorth cyffredinol ar ddylunio adroddiadau cyfeiriwch i'r Microsoft Adroddiad Builder dudalennau 3.0 help yma .

Ychwanegu Tablau i'ch adroddiad

1. Sicrhewch fod gennych ffeil Adroddiad ABACUS Custom Diffiniad (.rdl / .rdlc) ar agor yn Microsoft Adroddiad Builder 3.0.

2. Dewiswchy Mewnosod tab yn y 'rhuban' ar y brig, yna cliciwch y Tabl botwmyn yr adran Rhanbarthau Data a dethol Mewnosod Tabl.

3. Nawr llusgwch y cyrchwrat y sefyllfa ar yr adroddiad cynfas lle rydych am i'r gornel uchaf-chwith y tabl i gosod. Cliciwch ar y cynfas. Yn ddiofyn, bydd y bwrdd yn cael ei ychwanegu gyda rhes pheniad ac yna grŵp manylion (grŵp yn cael ei ddefnyddio i drefnu golwg ar adroddiad CCD). I gael gwared ar y grŵp, naill ai ddileu y rhes neu ddileu Grŵp Row yn y bar offer Grwpiau.

Tips

Fformiwlâu / ymadroddion yn y celloedd y tabl yn cael eu golygu gan ddewis y gell ac yna i'r dde-glicio ar y << Expr >> testun a dewis Mynegiant .... Didoli rhesi mewn tabl yn cael ei wneud drwy ddewis y bwrdd ac yna pori i lawr i'r Arall -> SortExpressions cae yn y panel Properties a mynd i mewn mynegiant. Am rhes cyfanswm ar ddiwedd y tabl yn ychwanegu rhes ar ôl (a thu hwnt) grwpio ac yna defnyddiwch y mynegiad canlynol = Swm (Fields!Enw.Value)lle mae 'Enw' yw'r cae yn cael ei dod i gyfanswm o. I wneud cais lliwio i golofnau defnyddio 'IIF' datganiad yn yr eiddo BackgroundColor. I ychwanegu fesur fel cell mewn tabl gyntaf mewnosoder y medrydd i mewn i gell ac yna gollwng meysydd data sy'n ofynnol ar gyfer y mesur. Wrth olygu uchder a lled o resi bwrdd, sicrhau eich bod yn dewis y rhes cywir, ac yna hofran eich cyrchwr llygoden o amgylch y llinellau llwyd hyd nes y byddwch yn cael y Saeth i fyny / i lawr cyrchwr, yna newid maint.

Ychwanegu Siartiau i'ch adroddiad

1. Sicrhewch fod gennych Adroddiad ABACUS Custom ffeil Diffiniad (.rdl / .rdlc) ar agor yn Microsoft Adroddiad Builder 3.0.

2. Dewiswchy Mewnosod tab yn y 'rhuban' ar y brig, yna cliciwch y Siart botwmyn yr adran Rhanbarthau Data a dethol Mewnosod Siart.

3. Nawr llusgwch y cyrchwrat y sefyllfa ar yr adroddiad cynfas lle rydych am i'r gornel uchaf-chwith y siart i gosod. Cliciwch ar y cynfas ac wedyn dewiswch y siartydych angen o'r opsiynau a chliciwch iawn.

Tips

I arddangos eiddo fel anodiad ar siartiau, dde chlecia acha 'r siart a dewis Labels Sioe Data, yna dewiswch un o'r labeli sydd wedi ei ychwanegu ac yn gosod y Misc -> UseValueAsLabel i Ffug yn y panel Properties ac ychwanegu fynegiad (ee = Fields Name.Value) yn Misc -!> Label. Yn benodol ar gyfer siartiau swigen; Siartiau swigen yn cael eu harddangos o dan y pennawd siart Gwasgariad. Galwch heibio X eiddo echel yn gaeau Cyfres (neu ychwanegu mewn Eiddo Series). Galw Heibio Y eiddo echel yn gaeau Data (neu ychwanegu mewn Eiddo Series). I ddefnyddio eiddo i ddiffinio maint y swigen, galw heibio hyn yn gaeau Data (neu ychwanegu mewn Eiddo Series). Siartiau swigen yn gallu i arddangos os oes gormod o ddata (200+ o eitemau), weithiau mae hyn yn achosi yr adroddiad cyfan i beidio arddangos. Math Marciwr - Gosod yn gylch. Yn ddiofyn, pan yn gollwng caeau i mewn i gaeau Data, mae'n eu ychwanegu gyda'r swm ()fformiwla, felly cael gwared ar hyn. Yn benodol ar gyfer Siartiau stacio / Llinell Amser / siartiau Gantt; Am siart Gantt yn defnyddio siart ystod ac ychwanegu eiddo fel gwerthoedd uchel ac isel yn y meysydd data. Gallwch gael 'bariau' lluosog drwy ychwanegu mwy a mwy o ystodau, lle mae gwerth isel ar gyfer un yn cyfateb i'r gwerth uchel ar gyfer un arall. Yn benodol ar gyfer Siartiau cylch; Ar gyfer siartiau cylch agregau, gollwng y data yn gaeau Categori ac mewn meysydd Data, ychwanegwch y fformiwla = CountRows (). Hidlo allan unrhyw 0 werthoedd (ee ar siartiau cost), bydd fel arall yn y labeli ar gyfer y rhain yn dal i ymddangos ar y siart.

Gan ddefnyddio datganiad IIF i ychwanegu lliwiau i dablau a siartiau

1. Sicrhewch fod gennych Adroddiad ABACUS Custom ffeil Diffiniad (.rdl / .rdlc) ar agor yn Microsoft Adroddiad Builder 3.0.

2. Cliciwch y botwm dde y gell yn y tabl i liw a cliciwch Priodweddau Text Box.

3. Dewiswch Llenwch a chliciwch ar y FXbotwm ar y dde o'r label lliw Fill ac yn y Set fynegiad ar gyfer maes BackgroundColor fynd i mewn fynegiad, ee = IIF (Fields! InformationStatus.Value = "Cadw", "LightGreen", IIF (Fields! InformationStatus.Value = "Ailgynllunio", "Yellow", IIF (Fields! InformationStatus.Value = "Adnewyddu", "Oren", " Salmon "))). Mae hyn yn newid y lliw cefndir i wyrdd golau ar gyfer pob cell sy'n cynnwys y statws 'Cadw', melyn ar gyfer pob cell sy'n cynnwys y statws 'Ailgynllunio', Orange ar gyfer pob cell sy'n cynnwys y statws 'Refresh' ac unrhyw werth statws arall yn cael eu lliw yn 'Salmon'.

Nodyn

Gall lliwiau yn cael ei ychwanegu ar gyfer siartiau drwy ddewis y gyfres ar y siart ac yna gosod y Ymddangosiad -> Lliw eiddo (neu ar gyfer siartiau swigen y Ymddangosiad -> Marciwr -> Lliw eiddo) i fynegiant debyg i'r enghraifft uchod.

Pethau i'w cadw mewn cof wrth ddylunio adroddiadau arfer

· Gan fod holl eiddo ac eithrio Cyfanrif yn cael eu hanfon fel llinyn o ABACUS at yr adroddiad gwyliwr os ydych am wneud unrhyw 'ymadroddion' gyda nhw (fel rhannwch un eiddo gan un arall neu ddidoli) mae angen i chi droi nhw i degol neu'n Dyddiad ac ati I cefndir , yr erthygl hon yn gyfeiriad dda. E.e. = CDate (LifecycleEndDate.Value! Fields) Nodyn: Gwnewch yn siŵr bod yr iaith yr adroddiad wedi ei osod i en-GB (fel y disgrifir isod) derbyn dd / mm / bbbb gan ei fod yn disgwyl i fformat mm / dd / bbbb yn ddiofyn ac yn unol â hynny bydd 31/7/2011 methu trosi. =Round(Convert.ToDecimal(Fields!CostMaintenanceCostfixed.Value)/Convert.ToDecimal(Fields!UsersNumberofUsers.Value)) = FormatCurrency (CostTotalCosttoOwnnext5years.Value Fields!, 0)

· Os byddwch yn dod o hyd i eich bod yn cael trafferth i cadw pob un o'r tablau a siartiau ar un dudalen, Mae yna ychydig o brif ffyrdd o reoli eich gofod dogfen:

· Toriad Tudalen - Sicrhau bod y lleoliad yn y tabl hwn yn i ffwrdd ar gyfer pob tabl eich bod yn dymuno bod ar yr un dudalen.

· Cadwch Gyda'n Gilydd - Sicrhau y gosodiad tabl yn wir ar gyfer pob tabl eich bod yn dymuno bod ar yr un dudalen.

· Wrth symud pethau o gwmpas, mae'n haws i chwyddo allan drwy ddefnyddio'r reolaeth ar y dde waelod y dudalen, ac yna aml ddewis eitemau a llusgo

· Ar gyfer y ddelwedd rhes mewn tabl, gwnewch yn siŵr fod y 'Maint' | Eiddo 'Pennu'r' wedi ei osod i 'Fit' fel arall y llun yn ymddangos yn rhy fawr, neu bydd yn cael ei ymestyn yn wael.

· I ailadrodd rhes pennawd o dabl ar bob tudalenyr adroddiad:

1. Modd Uwch Agored yn y paen Grwpiau. (Cliciwch ar y saeth ar y dde o'r Grwpiau Colofn a dewis Modd Uwch.)

2. Yn yr ardal Grwpiau Row (Grwpiau nid Colofn), cliciwch ar grŵp Statig, sy'n tynnu sylw at y blwch testun cyfatebol yn y tablix. Cliciwch drwy bob grŵp Static nes ei fod yn tynnu sylw at y pennawd colofn leftmost. Mae hyn yn gyffredinol y grŵp Static cyntaf a restrir.

3. Yn y ffenestr Properties, yn gosod yr eiddo RepeatOnNewPage i Gwir.

4. Gwnewch yn siŵr bod yr eiddo KeepWithGroup wedi ei osod i Gofal.

· Newid y gosodiadau iaithmewn eiddo Adroddiad i gyd-fynd â'r fformatau data ei angen arnoch, ee en-GB i gynhyrchu fformat dyddiad y DU (dd / mm / bbbb).

Gweler Hefyd

Dadansoddi eich pensaernïaeth


Cyhoeddi i'r We

Navigation: Adrodd ar eich pensaernïaeth>

Cyhoeddi i'r We

Anfon sylwadau ar y pwnc hwn.

ABACUS 'Cyhoeddi ar y We yn caniatáu i nodwedd modelau pensaernïol gael eu gweld drwy wefan ddiogel. Pensaernïaeth yn cael eu hallforio i fformat HTML ac wedi'u cynllunio i adlewyrchu'r edrych ac yn teimlo y Explorer yn ABACUS. Views (yn cynnwys Catalogau, diagramau, 3D a Siartiau) hefyd yn cael eu hallforio i fformatau viewable gan ddefnyddio porwr rhyngrwyd.

Nodyn

Ar hyn o bryd, nid yw Safbwyntiau a Matricsau yn cael eu cyhoeddi.

I gyhoeddi eich modelau pensaernïol i'r we

1. Sicrhau bod gennych y perthnasol File ABACUSagored, sy'n cynnwys y pensaernïaeth poblogeich bod am gyhoeddi i'r we.

2. Dewiswch Ffeil| Cyhoeddi ....

3. Y Cyhoeddi I Configuration WeBydd ffenestr arddangos.

Cyhoeddi i'r We Ffurfweddiad

4. Yn ddiofyn holl dogn y model yn cael eu dewis gan gynnwys yr View Tree, y Safonau, Mae'r Mathau, Templedi a Phensaernïaeth (au). Dad-diciwch unrhyw rannau nad ydych am i gyhoeddi i'r we, gan gynnwys unrhyw farn unigol o fewn y bensaernïaeth (au).

Tip

Os ydych am i guddio cydrannau, cysylltiadau penodol a / neu eu heiddo, argymhellir bod Gweinyddwr yn creu rôl yn 'Cyhoeddus' gan ddefnyddio Nodwedd mynediad seiliedig ar rôl ABACUS ' ac yna dileu'r caniatâd Darllen oddi wrth y rhai mathau cydran, mathau cysylltiad a / neu eiddo nad ydynt yn dymuno cael eu cyhoeddi. Yna, dylai defnyddiwr fewngofnodi o dan y rôl honno ac yn cyhoeddi i'r we fel ABACUS dim ond cyhoeddi elfennau sydd wedi Darllenwch caniatâd a osodwyd ar gyfer y rôl. Ar ben hynny, gall defnyddwyr auto-gyhoeddi o'r llinell orchymyn fel y disgrifiwyd yma .

Nodyn

Efallai y byddwch yn dewis yr holl y dogn a ddangosir drwy glicio ar y Allbotwm neu gwrthdro eich dewis drwy glicio ar y Gwrthdroibotwm. Gallwch hefyd glicio ar y Dimbotwm i glirio eich dewis.

Nodyn

Os ydych yn dad-diciwch y dewis Tree Viewyna ni fydd unrhyw ffrâm goed (gweler isod) yn cael ei gyhoeddi. Yn unol â hynny, dylech ddewis tudalen cychwyn yn ôl cam 6 isod neu ar ôl cyhoeddi bydd angen i chi addasu naill ai'r lefel uchaf; a) index.htmlffeil drwy newid y 'src ffrâm = "mainPage.html" Enw = "element_details"' llinell i gysylltu'n uniongyrchol at y dudalen html perthnasol o dan y ffolder Cynnwys, neu, b) mainPage.htmltrwy ddarparu hypergyswllt neu ailgyfeirio at y dudalen html perthnasol o dan y ffolder Cynnwys.

5. Cliciwch y Dewis botwm ac mae'r canlynol Dewisiadau CyhoeddwrBydd dadl yn arddangos.

CyhoeddiDewisiadau er

6. Sethol y 3D, Diagrama fformatau Siartiau ac a ddylid dangos y Theitl, Disgrifiad neu Eiddo ar gyfer y golygfeydd allan o opsiynau sydd ar gael (cyfeiriwch at y nodyn isod am sylwadau ar y gwahanol fformatau).

7. Os ydych yn dymuno i osod y dudalen cychwyn y model a gyhoeddwyd i farn penodol, yna edrychwch ar y Defnyddiwch View Fel Dechrau Tudalenopsiwn a phori i'r olygfa drwy'r '...' botwm sy'n dod galluogi.

Nodyn

Dim ond y farn a ddewiswyd yn yr adran Ardaloedd yn unol Cam 4 uchod ar gael i'w gosod fel tudalen cychwyn.

8. Os ydych yn dymuno cael adborth ar dudalennau penodol yn y model a gyhoeddwyd yna gwnewch yn siŵr y E-bost Adborthddewisiad a ddewisir, nodwch gyfeiriad e-bost yn y Cyfeiriad ebosttextboxa golygu'r Corff E-bostadran fel y bo'n briodol. Os nad ydych yn dymuno cael ei anfon adborth yna uncheck 'r E-bost Adborthopsiwn a gadewch y blwch testun gwag.

9. Cliciwch ar y iawnbotwm.

10. Cliciwch ar y Poribotwm.

11. Y Pori gyfer FolderBydd ffenestr arddangos.

12. Dewiswch y lleoliad rydych am i storio'r ffeil HTML lefel uchaf (ac unrhyw ffeiliau yn awtomatig).

Nodyn

Mae'n syniad da i greu ffolder penodol (fel arfer o'r enw "Cyhoeddwyd") gan ddefnyddio'r Gwnewch Ffolder Newyddbotwm ar waelod yr ymgom i storio'r ffeil HTML lefel uchaf ac unrhyw ffeiliau a gynhyrchir yn awtomatig.

13. Cliciwch ar y iawnbotwm.

14. Bydd y llwybr folder harddangos yn y Cyfeiriadurblwch testun.

15. Cliciwch ar y Gorffenbotwm.

- Neu -

15. Rhowch y llwybr folder yn y Cyfeiriadurtextbox lle rydych am i storio'r ffeil HTML lefel uchaf (ac unrhyw ffeiliau yn awtomatig).

16. Cliciwch ar y Gorffenbotwm.

Nodyn

Allforio o Diagramauyn achlysurol iawn yn methu, mae'r rhan fwyaf yn aml pan fydd y cyfrifiadur yn allan o gof (fel arfer wrth ddefnyddio ffeiliau mawr iawn). Bydd yn cael ei allforio methu retried unwaith. Bydd un rhybudd am ymgais gychwynnol methu, ac ail rybudd os bydd yr ail-ymgais yn methu. Felly, os mai'r unig rhybuddion yn cael eu "ymgais gychwynnol wedi methu" rhai, yr gyhoeddi yn llwyddiannus. Os bydd yr ail-ymgais yn methu ceisiwch cyhoeddi cyfran lai o'ch ffeil neu am ddim i fyny rhyw chof system.

Gall y ffeil HTML arbedir (au) nawr yn olygfa o'i leoliad neu eu copïo i safle gwe diogel.

Cyhoeddi i'r We yn Internet Explorer10

Unrhyw hypergysylltiadau a fydd yn cael eu creu yn y model gwreiddiol yn cael eu parhau yn y model cyhoeddi a bydd clicio ar y cyswllt dilynwch y ddolen i ben ei daith (os cafodd ei gyhoeddi). Ar ben hynny, bydd unrhyw elfennau mewn diagramau a gyhoeddwyd nad ydynt wedi eu hypergysylltu eisoes yn y model gwreiddiol gan hypergysylltu yn ôl i'w elfennau cyfatebol yn yr olygfa Coed (os cafodd ei gyhoeddi) a thrwy glicio yr elfen yn y diagram a gyhoeddwyd bydd y ffocws yn neidio yn ôl i y lleoliad perthnasol yn y Coed. Mae'r nodwedd hon yn debyg i'r "Dangos Yn Explorer" nodwedd dde-glicio mewn ABACUS.

Nodyn

Avolution yn argymell yn gryf y dylai'r fformatau meddalwedd a ffeil canlynol yn cael eu defnyddio i wneud defnydd llawn y Cyhoeddi i ymarferoldeb Gwe yn ABACUS:

1. Rhyngrwyd archwiliwr (8.0 Ac uwch)i weld yr olygfa fforiwr cyhoeddi. Mozilla Firefox (3.0 Neu'n ddiweddarach)Argymhellir hefyd ac gefnogi'n llawn, Fodd bynnag, os ddefnyddio'r fformat SVG a argymhellir ar gyfer diagramau yna yn Firefox 9 gallwch ond yn defnyddio'r gefnogaeth gwyliwr SVG brodorol sydd nid yn anffodus yw'n caniatáu chwyddo neu panio.

2. Gwyliwr Adobe SVG 3.0 plug-in (Lawrlwytho o yma ) ac SVGfformat ffeil ar gyfer cyhoeddi diagramau. Y fformat delwedd SVG gyfer y diagramaucael ei argymell oherwydd; SVG yn fformat delwedd sy'n seiliedig ar fector-ac felly mae'n 'colled-llai' ac yn edrych yn llawer gwell ar unrhyw lefel chwyddo a roddir nag unrhyw un o'r fformatau eraill, gall SVG yn cael ei fewnforio i MS Visio, gall SVG yn cael ei chwyddo i unrhyw lefel neu benderfyniad , mae gan SVG cysylltiadau yn ôl at yr olygfa coeden ar gyfer y cysylltiadau (nid dim ond y cydrannau), SVG bob amser yn argraffu ar gydraniad gwell, ac, SVG tua hanner maint y ffeil o'r fformatau eraill. PNG yw'r argymhelliad nesaf, fodd bynnag, gan ei fod yn fformat rasterised ar lefelau chwyddo sicr y bydd eglurder y farn yn cael ei golli a chlicio cysylltiadau ar ddiagramau Ni fydd neidio yn ôl at y lleoliad perthnasol yn y goeden. BMP yn cael ei hannog i beidio ag tra ei fod yn fformat 'colled-llai' maint y ffeil yn 100x un y fformatau eraill a delweddau 20Mb nid yn anghyffredin.

Mae'r fasnach-off gyda SVG yw y bydd angen pecyn gwylio SVG i gael eu gosod ac mae angen iddynt chi gwneud yn siŵr bod delwedd .svg / svg + xml ei ychwanegu mathau y gweinydd gwe yn MIME. Ar ôl gosod y gwyliwr SVG, bydd Microsoft Internet Explorer gofyn i chi dderbyn cytundeb trwydded y gwyliwr ac yna dylai weithio'n iawn. A thraMozilla Firefox yn cefnogi ffeiliau SVG frodorol, yr ategyn Adobe argymhellir o hydi allu chwyddo y diagramau os ydych yn defnyddio Firefox 8 neu'n gynt (os ydych yn defnyddio Firefox 9 nad ydych yn gallu analluoga 'r gwyliwr SVG frodorol). Unwaith y bydd y gosodiad ar gyfer yr ategyn Adobe wedi cael ei rhedeg, mae'n ofynnol i'r camau canlynol ei ddefnyddio yn Firefox:

· Agor i fyny firefox a nodi'r "am: config" (heb y dyfynodau) yn y bar URL.

· Sgroliwch i lawr a dod o hyd i'r eiddo svg.enabled(Os ydych yn defnyddio Firefox 9 yna ni all y gwylio SVG frodorol yn anabl ac nid yw eiddo hwn yn bodoli). Cliciwch ddwywaith ar iddo at analluoga '.

· Nawr yn dod o hyd cyfeiriadur lle mae'r ategyn SVG cael ei osod (ee C: \ Program Files \ Common Files \ Adobe \ Viewer SVG 3.0 \)

· Copïwch y ffeiliau NPSVG3.dll a y NPSVG3.zip a bastio i mewn i'r cyfeiriadur ategion firefox (ee C: \ Program Files \ Mozilla Firefox \ ategion)

· Caewch i lawr i bob enghraifft o firefox

3. Gwyliwr 3D ABACUS Avolution yn (3.1 ac uwch)ac .abacus3D Avolution ynfformat ffeil i weld y golygfeydd a gyhoeddwyd 3D. Er bod y Cortona VRML Cleient plug-in (2.0 ac uwch)ar gael i'w gweld fersiynau VRML o'r safbwyntiau a gyhoeddwyd, nid yw'n rhad ac am ddim ar gyfer defnydd masnachol a hyd yn mynnu gosodiad ar ochr cleientiaid. Y Gwyliwr ABACUS 3D yn fwy nodwedd-gyfoethog nag unrhyw gwyliwr VRML ac mae ar gael am ddim i'w lawrlwytho o yma . Yn y naill achos neu'r llall gwnewch yn siŵr eich ychwanegu .vrml x-byd / x-VRML a gais / wythawd-ffrwd .abacus3d i fathau y gweinydd gwe yn MIME.

4. PNGfformat ffeil i weld y golygfeydd Siart cyhoeddi. Y fformat delwedd PNG am farn Siart cael ei argymell oherwydd er ei bod yn fformat rasterised ac mae 'golled' y cyfaddawd rhwng maint y ffeil ac eglurder siart yw'r gorau fel arfer. BMP yn cael ei hannog i beidio ag tra ei fod yn fformat 'colled-llai' maint y ffeil yn 20x nad yw o'r fformatau eraill a siartiau 2Mb yn anarferol.

Os ydych am newid y golwg a theimlad y tudalennau gwe, gallwch chi olygu y ffeil dudalen cychwyn a enwir mainPage.html a'r ffeil dalen arddull abacus.css enwir. Byddwch yn dod o hyd i ffeiliau hyn yn yr un folder ble rydych yn dewis i gadw'r ffeil HTML lefel uchaf. I gael rhagor o wybodaeth am y strwythur a theilwra allbwn cyhoeddedig gweler yr adran nesaf.

Mae strwythur ABACUS cyhoeddi fodelau

Mae'r model a gyhoeddwyd ABACUS wedi'i strwythuro fel a ganlyn:

1. Mae'r ffolder lefel uchaf yn cynnwys nifer o ffeiliau a chan dybio holl opsiynau yn cael eu cynnwys yn y ABACUS Cyhoeddi i Configuration We ymgom bydd yn cynnwys mynegai.htmlfile cynnwys tri fframiau; treeView.html, findNode.html ac mainPage.html ac wedyn shortcutError.htmldudalen. Mae'r treeView.html cael ei phoblogi gan y tree.js, tree_items.jsac tree_tpl.js Ffeiliau javascript lleoli o dan y cynnwys ffolder (a drafodir isod) ac yn ailadrodd y goeden Explorer o ABACUS. Mae'r findNode.html cael ei bweru gany find.js ffeil javascript lleoli o dan y cynnwys ffolder (a drafodir isod) ac mae'n Bydd chwilio'r y canghennau y goeden yn hytrach na dim ond y nodau gweladwy. Tef mainPage.html yn dudalen HTML statig y gellir eu teilwra gyda logos corfforaethol ac yn y blaena bydd yn cael ei ddangos oni bai dudalen cychwyn yn cael ei ddewis wrth gyhoeddi.Ac yn olaf, mae'r dudalen shortcutError.html yn dudalen glanio ar gyfer unrhyw shortcuts torri oddi wrth y goeden oherwydd y tudalennau priodol ddim yn cael eu cyhoeddi.

Tip

Gallwch hepgor y mainPage.html yn gyfan gwbl gan dewis defnyddio'r dudalen cychwyn wrth gyhoeddi neu addasu'r ffeil index.html i bwynt yn uniongyrchol i farn a roddwyd (dyweder) drwy olygu y src = ffrâm llinell "mainPage.html" i bwynt yn uniongyrchol i'r olygfa gyntaf yn y bensaernïaeth cyntaf, fel arfer y diagram 'fframwaith'.

2. Mae'r ff y lefel uchafncludeffolder yn cynnwysingamrywiol javascript (.js) a dalen arddull rhaeadrol (.css) ffeiliau a ddefnyddir gan y ffeiliau .html trwy gydol y model a gyhoeddwyd.

3. Mae'r ffolder Cynnwys lefel uchaf yn cynnwys, Yn nhrefn yr wyddor;

· A '3D Barn' ffolder gydarhifoDudalen HTML a ffeil VRML neu abacus3d ar gyfer pob un o'r golygfeydd 3D cyhoeddi. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· Mae Pensaernïaeth ffolder gyda thudalen HTML rhifo ar gyfer pob bensaernïaeth a gyhoeddwyd. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· A Catalogau ffolder yn cynnwys tudalen HTML rhifo gyfer pob un o'r catalogau cyhoeddedig. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· A Siartiau ffolder gydarhifoDudalen HTML a PNG, JPG ffeil ac ati ar gyfer pob un o'r golygfeydd Siart cyhoeddi. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· A Cydrannau ffolder sy'n cynnwysrhifoDudalen HTML ar gyfer pob un o'r cydrannau cyhoeddi. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· A Cysylltiadau ffolder sy'n cynnwysrhifoDudalen HTML ar gyfer pob un o'r cysylltiadau a gyhoeddwyd. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· A Diagramau ffolder sy'n cynnwysrhifoDudalen HTML a PNG, SVG ffeil ac ati ar gyfer pob un o'r gyhoeddi diagramau. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· Mae eiconau is-ffolder gyda amrywiol delweddau a ddefnyddir drwy gydol y model a gyhoeddwyd.

· A Safonau is-ffolder gydarhifoDudalen HTML ar gyfer unrhyw safonaua gyhoeddwyd. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

· A Templedi is-folder gyda chasgliad o is-ffolderi rhifo ar gyfer pob templed a gyhoeddwyd o'r prosiect. O fewn pob is-ffolder yn Cydrannau a ffolder Cysylltiadau ac o fewn y rhain yn dudalen HTML rhifo ar gyfer pob cydran a chysylltiad y templed. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffolder / ffeil.

· A Mathau is-ffolder gyda Cydran acCysylltiad is-ffolderi gydarhifoDudalen HTML ar gyfer unrhyw Cydran acMathau Cysylltiad a gyhoeddwyda chasgliad o is-ffolderi rhifo ar gyfer pob math a gyhoeddwyd gan y prosiect sy'n cynnwys dudalen HTML ar gyfer pob un o'r cyfyngiadau. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffolder / ffeil.

· A Viewpwynts is-ffolder arhifoDudalen HTML ar gyfer unrhyw un o'r Viewpwynts a gyhoeddwyd. Gweler y nodyn isod i gael gwybodaeth am y cynllun rhifo ffeil.

Nodyn

Mae rhifau'r tudalennau HTML (a mewn rhai achosion, y ffeiliau delwedd) yn cyfateb i'r unigryw ID ar gyfer pob gwrthrych ystorfa a oedd gosod pryd yr oedd yn creuo fewn ABACUS (y cyfeirir atynt fel EEIDs). Nid yw'r ID yn newid hynny fel diagramau, mathau, cydrannau ac ati yn Diweddarwyd maent Byddcadw'r un ID ag o'r blaen. Ym mhob achos, mae'r perthnasol gwrthrych ystorfaGall enw i'w weld ger dechrau'r dudalen HTML rhwng y ... tagiau HTML.

Cyfyngu Mynediad i Dudalennau rhai / Views gyda IIS

Os ydych yn defnyddio IIS fel eich gweinydd gwe ar gyfer y model a gyhoeddwyd, efallai y byddwch yn gallu i gyfyngu ar fynediad i rai o dudalennau / safbwyntiau gan ddefnyddio'r dull isod:

1. Creu gwefan yn IIS (un arall os oes un sy'n bodoli eisoes nad ydych am i ymyrryd â).

2. Newid y fynedfa Properties-> Cyfeiriadur diogelwch-> Anonymous - mynediad dienw diciwch, a'r defnydd a ddilyswyd mynediad.

3. Os yw hyn yn unig yw gweinyddwr arferol heb unrhyw gymhlethdodau parth ac ati, yna dylech ddefnyddio'r opsiwn 'ffenestri integredig dilysu' a fyddai wedyn yn defnyddio'r peiriannau gweinydd defnyddwyr lleol / mewngofnodi fel y dilysu, a dim ond ychwanegu defnyddwyr at y cyfrifiadur lleol (gan fod yn ofalus eich bod yn ymwybodol o oblygiadau, diogelwch ddoeth, o ychwanegu defnyddwyr newydd i'r peiriant, ee yn dibynnu ar p'un a mynediad o bell yn setup ar gyfer y peiriant, ac ati).

4. Ychwanegwch caniatadau at y ffeiliau / ffolderi penodol yn ôl yr angen. Dde chlecia 'r ffeiliau unigol / ffolderi -> Eiddo, ac addasu'r caniatâd diogelwch fel y byddech fel arfer ar gyfer ffeiliau / ffolderi.

Gall hyn amrywio yn dibynnu ar pa fersiwn o IIS a pha benodol Ffenestri OS yw ar y gweinydd, ac a oes gennych parth neu setup gwahanol eraill.

Gweler Hefyd

Poblogi eich pensaernïaeth | Dadansoddi eich pensaernïaeth


Allforio eich Pensaernïaeth

Navigation: Adrodd ar eich pensaernïaeth>

Allforio eich Pensaernïaeth

Anfon sylwadau ar y pwnc hwn.

ABACUS yn caniatáu i chi iallforio eich pensaernïaeth i .mdb (Microsoft Access), MS SQL Server, .abacus (ffeil ABACUS), a Xls (Excel Microsoft) fformat. Gallwch hefyd yn allforio eich diagrams i PNG, JPG, SVG (Scalable Vector Graphics), TIFF, GIF a fformat BMP a'ch adroddiadau i .html (HTML), .pdf (Adobe Acrobat), .xls (Microsoft Excel), .doc (Microsoft Word) a .rtf (Rich Text Format) fformatau. Mae hyn yn caniatáu i chi i ddadansoddi a gweld y bensaernïaeth ac ei ddata mewn unrhyw ffordd yr ydych ei eisiau.

I allforio eich pensaernïaeth i .mdb (Microsoft Access)

1. Sicrhewch bod gennych File ABACUSar agor.

2. Cliciwch ar y Ffeilfwydlen.

3. Dewiswch Allforio, ac wedyn I MDB.

4. Cymerwch sylw o'r rhybudd a chliciwch iawn.

5. Teipiwch enw ar gyfer y ffeil.

6. Cliciwch y SaveButton.

Nodyn

Mae fformat allforio y gronfa ddata .mdb yn Bydd benodol i ABACUS ac unrhyw newidiadau sgema yn arwain at anallu i ail-fewnforio. Gweler Poblogi gydag MS Access i gael disgrifiad o'r sgema MS Access.

I allforio eich pensaernïaeth i MS SQL Server

1. Sicrhewch bod gennych File ABACUSar agor.

2. Cliciwch ar y Ffeilfwydlen.

3. Dewiswch Allforio, ac wedyn I MS SQL Server.

4. Yn y deialog sy'n ymddangos cliciwch y Allforio Blank MDB ...botwm a mewnforio hwn yn eich gweinyddwr cronfa ddata MS SQL Server.

5. Llenwch y wybodaeth gronfa ddata a llinyn cysylltiad.

6. Cliciwch y AllforioButton.

Nodyn

Mae fformat allforio y MS SQL Servercronfa ddata yn Bydd benodol i ABACUS ac unrhyw newidiadau sgema yn arwain at anallu i ail-fewnforio. Gweler Poblogi gydag MS Access i gael disgrifiad o'r sgema cronfa ddata.

I allforio eich pensaernïaeth i .xls (ffeil Excel)

1. Sicrhewch bod gennych Ffeil ABACUS agored , Mae fforiwr harddangos , Ac mae Ychwanegodd pensaernïaeth .

2. Sicrhewch bod gennych Excel Mewnforio / Allforio Ffurfweddiad Ffeil diffiniedig.

3. Dde-glicioar bensaernïaeth yn eich model neu unrhyw ran o'r Cydrannaunod (o fewn pensaernïaeth a roddwyd) yr hoffech i allforio i'r Ffeil Excel Configuration.

4. Dewiswch Allforio | I Excel ... o'r ddewislen.

5. Y Dewiswch Excel Mewnforio / Allforio Configuration Ffeil i DdefnyddioBydd ffenestr yn cael ei arddangos.

6. Dewiswch y ffeil cyfluniad perthnasol ar gyfer eich model pensaernïol a chliciwch ar y Agoredbotwm.

7. Os nad yw gwneud hynny yn awtomatig, map y cydrannau lefel uchaf yn eich pensaernïaeth cyfredol i'r Set Id(Fel y diffinnir yn flaenorol) a chliciwch ar Allforio ....

Mapio Enghraifft Cydran Top-Lefel

8. Dewiswch leoliad a enw ffeil ar gyfer eich ffeil Excel a chliciwch ar y Savebotwm.

I allforio eich pensaernïaeth i .abacus (ffeil ABACUS)

1. Sicrhewch bod gennych File ABACUSar agor.

2. Dde-glicioar y nôd Pensaernïaeth, unrhyw bensaernïaeth yn eich model neu unrhyw ran o'r goeden Cydrannau.

3. Dewiswch Allforio | I Ffeil ...o'r ddewislen.

4. Dewiswch leoliad a enw ffeil a chliciwch ar y Savebotwm.

Nodyn

Gallwch fewnforio ffeil ABACUS yn ôl i ABACUS gan camau canlynol 1-2uchod ac yna dewis Mewnforio | O Ffeil .... Ar ôl i chi wedi dewis y ffeil yr ydych eisiau mewnforio, gofynnir i chi sut yr hoffech i fewnforio safonau a mathau. Gallwch chi fewnforio safonau a mathau fel naill ai safonau a mathau newydd neu uno. Mae'r lleoliad diofyn ar gyfer safonau a mathau sydd i'w huno â safonau a mathau presennol os ydynt yn bodoli eisoes yn eich prosiect.

I allforio eich pensaernïaeth i .xml

1. Sicrhewch bod gennych File ABACUSar agor.

2. Dde-glicioar nod Pensaernïaeth, unrhyw bensaernïaeth yn eich model neu unrhyw ran o'r goeden Cydran.

3. Dewiswch Allforio | I XML ...o'r ddewislen. Fel arall, gallwch glicio ar y ddewislen Ffeil| Allforio| I XML ...

4. Dewiswch leoliad a enw ffeil a chliciwch ar y Savebotwm.

Nodyn

Gallwch fewnforio ffeil XML yn ôl i ABACUS gan camau canlynol 1-2uchod ac yna dewis Mewnforio | O XML .... Ar ôl i chi wedi dewis y ffeil XML hoffech fewnforio, bydd gofyn i chi sut yr hoffech i fewnforio safonau a mathau. Gallwch chi fewnforio safonau a mathau fel naill ai safonau a mathau newydd neu uno. Mae'r lleoliad diofyn ar gyfer safonau a mathau sydd i'w huno â safonau a mathau presennol os ydynt yn bodoli eisoes yn eich prosiect.

I allforio eich diagram i PNG, JPG, SVG, TIFF, GIF neu BMP

1. Sicrhewch bod gennych File ABACUSar agor.

2. Agorwch y diagramhoffech i allforio.

3. Cliciwch ar y Allforio Diagrambotwm ar y Diagram bar offer.

4. Y Allforio DiagramBydd ffenestr yn ymddangos.

5. Dewiswch y Poribotwm i achub y delweddu yn y lleoliad a ddymunir.

6. Dewiswch y Cadw fel mathtynnu-lawr ddewislen i ddewis y math o ffeil.

7. Cliciwch y Savebotwm.

I allforio eich adroddiad i .pdf (Adobe Acrobat), .xls (Microsoft Excel)neu.doc (Microsoft Word)

1. Sicrhewch bod gennych File ABACUSar agor.

2. Creu adroddiad hoffech i allforio.

3. Cliciwch ar y Allforiobotwm ar y bar offer adroddiadau.

4. Dewiswch Excel, PDF neu Wordo'r blwch a ollyngir i lawr.

5. Arhoswch ychydig eiliadau tra bod y allforion adroddiad.

6. Dewiswch leoliad a enw ffeil a chliciwch ar y Savebotwm.


Gweithio gyda Gweinydd Menter

Navigation: Gweinyddiaeth>

Gweithio gyda Gweinydd Menter

Anfon sylwadau ar y pwnc hwn.

Menter ABACUS Gweinydd yn y ddau 'di-gloi' dull cydweithredol, ond mae un 'datgysylltu' hefyd. ABACUS yw 'heb fod yn cloi' am ei fod yn Nid yw'n grym y ffeil i gael eu cloi gan un defnyddiwr er mwyn iddo gael ei diweddaru. Mae gan bob defnyddiwr eu copi lleol eu hunain o'r ffeil, ac fel y maent yn gwneud newidiadau ac arbed eu ffeil, newidiadau hynny yn cael eu cofnodi a'u storio am pan fydd y defnyddiwr yn dymuno ymrwymo nhw i'r gweinydd.

ABACUS yw 'datgysylltu' yn yr ystyr nad oes angen i chi gael eu cysylltu â'r gweinydd neu os oes angen mynediad i'r rhwydwaith wrth weithio ar ffeil. ABACUS yn unig yn gofyn am fynediad at 'r gweinyddwr wrth berfformio gweithrediadau fel creu ffeil, neu berfformio til, ynghyd â gweithrediadau ar ffeil sy'n bodoli - y wybodaeth ddiweddaraf, ymrwymo, neu'n edrych ar y log yn y gorffennol yn ymrwymo. Nid oes angen mynediad at y gweinydd i weithio ar y ffeil, a bod eich newidiadau Nid yw anfon at y gweinydd ar unwaith (mae hyn yn caniatáu i chi daflu 'ch newidiadau yn hawdd os gwnewch gamgymeriad). Pan fyddwch yn arbed eich ffeil, rydych yn 'gyfiawn' arbed eich copi yn lleol - nid yw'n hyd nes y byddwch yn ymrwymo bod eich newidiadau lleol (newidiadau a wnaed ers eich ymrwymo diwethaf), yn cael eu hanfon at y gweinydd.

Creu Ffeil Menter Newydd

I greu ffeil Menter newydd, dewiswch Ffeil| Newydd ...ac yna dewiswch un o'r ddau opsiwn cyntaf o dan yr adran Model Menter y Deialog Prosiect Newydd (Hy naill ai ffeil Menter wag, neu greu un o ffeil ABACUS presennol). Y trydydd opsiwn yw 'Man Talu' ffeil Menter rhywun arall eisoes wedi creu, bydd hyn yn cael ei gynnwys yn yr adran nesaf.

Pan fyddwch yn dewis i greu ffeil Menter newydd, byddwch yn cael ymgom fydd yn eich galluogi i bori i ble ar weinydd ystorfa hoffech chi storio eich ffeil. Bydd hefyd yn cael y llwybr ffeil sy'n bodoli ac enw mynd i fyny y brig os byddwch yn dewis 'From Model Presennol' o'r deialog Prosiect Newydd a gyflenwir ffeil.

URL: Mae hyn yn y URL at eich gweinydd ystorfa lle mae'r ffeiliau ABACUS Menter yn cael eu storio. Dylech ofyn i'r person sy'n rheoli'r gweinydd hyn y dylai'r URL hwn fod.

Mae'r llun uchod yn dangos ystorfa gyda pedwar (4) Prosiectau ABACUS Menter sy'n bodoli eisoes, ar ôl mynd i mewn i'r URL a gwasgu fynd i mewn.Rydych yn Bydd gweld ar ôl i chi greu ffeil Menter newydd, ar y screenshot nesaf ar gyfer 'Man Talu', bydd yna ffolder a ffeil arall o dan sefydliad.

Nodyn

Os ydych yn defnyddio https (SSL) gweinydd, ac nid oes gan y gweinydd dystysgrif SSL ddilys (cyffredin ar gyfer y fewnrwyd neu heb fod yn gyhoeddus gweinyddion oherwydd y cost tystysgrif SSLs) Bydd yn gam ychwanegol i gymryd. Bydd gofyn i chi dderbyn pob cysylltiad i'r gweinydd yn yr ymgom sy'n pops i fyny yn barhaol (bydd hefyd yn dangos ychydig mwy o wybodaeth ar y gweinydd). I wneud hyn, teipiwch 'p' (heb y dyfyniadau) a gwasgwch Enter. Bydd ABACUS pop i fyny neges yn eich atgoffa o hyn cyn dangos yr ymgom.

Nodyn

Efallai y gofynnir i chi fewngofnodi i'r gweinydd ac yn yr achos y person sy'n rheoli'r gweinyddyn gallu darparu enw defnyddiwr gweinydd a chyfrinair. Hefyd, mae'r cymwysterau mewngofnodi ar gyfer unrhyw gweinyddwyr eich bod wedi cysylltu â yn cael eu cadw felly os am unrhyw reswm mae angen iddynt gael eu clirio gellir gwneud hyn drwy Offer | Dewisiadauac yna ar y Cyffredinol tab drwy glicio Ailosod subversion Saved Mewngofnodia dewis y gweinydd o'r rhestr a chlicio ollyngir i lawr Mewngofnodi clira dewis Iawn yn yr ymgom sy'n ymddangos.

Nodyn

Yn wahanol i'r screenshot a ddangosir uchod, fel arfer Prosiect ABACUS sengl yn cael ei gynnwys ym mhob ABACUS Repository oherwydd os mwy nag 1 y Prosiect ABACUS cael ei greu mewn ABACUS Repository sengl, yn cael eu rhannu rhifau newid log ABACUS ar draws yr holl brosiectau ABACUS a gall hyn ddrysu defnyddwyr.

Ffefrir Enw'r ffeil: Mae hyn yn effeithio ar y ffolder a enw ffeil a ddefnyddir (os nad gymerwyd eisoes) wrth greu y ffeil ar y gweinydd ystorfa. Noder bod ffolder newydd ei chreu yn awtomatig ar y gweinydd ystorfa ar gyfer pob ffeil (am resymau perfformiad, ffeiliau ABACUS Menter yn cael eu creu yn eu ffolder hunain o dan lleoliad pori i yn yr ymgom).

Storiwch Copi Gweithio mewn Directory: Pan ffeil Menter yn cael ei greu ar weinydd ystorfa, mae angen i gael eu creu ar eich cyfrifiadur ffeiliau gwaith lleol, fel y gallwch weithio ar y ffeil heb fod cysylltu â'r rhwydwaith. Mae hyn yn y lle y byddwch yn pori i pan fyddwch eisiau agor / ail-agor ffeil ABACUS Menter.

Checkout yn Enterprise Ffeil Presennol

Os yw rhywun eisoes wedi creu ffeil Menter newydd, gall y ffeil hon 'checkout', sy'n downloads copi lleol ac yn sefydlu ffeiliau angenrheidiol, felly ABACUS yn cydnabod hyn fel ffeil Menter chi. Yr ymgom yn debyg i'r ffeil Menter Newydd Ymgom. Rhowch URL ystorfa (gellir subdirectories eu cynnwys yn y URL), dewis y ffeil ei angen, a chliciwch OK. Yn amodol ar y nodyn isod tiddo ffeilio wedyn yn cael ei hagor.

Nodyn

Efallai y gofynnir i chi fewngofnodi i'r gweinydd ac yn yr achos y person sy'n rheoli'r gweinyddyn gallu darparu enw defnyddiwr gweinydd a chyfrinair. Hefyd, mae'r cymwysterau mewngofnodi ar gyfer unrhyw gweinyddwyr eich bod wedi cysylltu â yn cael eu cadw felly os am unrhyw reswm mae angen iddynt gael eu clirio gellir gwneud hyn drwy Offer | Dewisiadauac yna ar y Cyffredinol tab drwy glicio Ailosod subversion Saved Mewngofnodia dewis y gweinydd o'r rhestr a chlicio ollyngir i lawr Mewngofnodi clira dewis Iawn yn yr ymgom sy'n ymddangos.

Gwahaniaethau Menter Ffeil

Pan fyddwch wedi creu ffeil Menter (naill ai un newydd, neu drwy 'til' o ffeil a grëwyd gan rywun arall), ffolder yn cael ei greu ar gyfer y ffeil, a bydd yn aml yn cynnwys y 3 prif fath o ffeiliau:

· File '.abacus'- Mae hyn yn y ffeil ABACUS ei hun. Newidiadau a wnewch yn lleol Nid yw arbed yn syth i mewn y ffeil, y mae'n ysgrifenedig yn unig i pan fyddwch yn ymrwymo. Mae'r ffeil yn ffeil 'normal' ABACUS, gellir ei roi i ddefnyddwyr nad ydynt yn EEfel prosiect annibynnol (heb y ffeil log), Neu ei ddefnyddio fel man cychwyn ar gyfer ffeil EE newydd.

· File '.changes'- Yr leol newidiadau (heb ei ymrwymo) a wnaed at y ffeil. Os yw hyn yn ffeil ar goll, mae hyn yn golygu nad oes unrhyw newidiadau lleol.

· File 'log'- Mae gan y ffeil hon yn unig y newidiadau a wnaed gan y defnyddiwr olaf (cynnwys y ffeil .changes y defnyddiwr pan fyddant yn ymrwymo).

Nodyn

Mae amryw o ffeiliau eraill a allai gael eu creu yn ystod y diweddariad ac ymrwymo prosesau, sef; ‘.changesbefore'File- Y ffeil yn gopi o'r ffeil .changes ar ôl diweddariad wedi cael ei pherfformio ac fe'i defnyddir i gysoni unrhyw wrthdaro ID rhwng y diweddariad ac unrhyw lleol (heb ei ymrwymo) yn awtomatig newidiadau cyn ymrwymo; ‘.backup'File- Y ffeil yn gopi o'r ffeil .changes cyn defnyddiwr yn arbed newidiadau mwy lleol (heb ei ymrwymo) at y ffeil .changes; ac ‘.error'File- Y ffeil yn gopi o'r .changes ffeil os oedd unrhyw fater a achosodd ABACUS i fethu i agor y ffeil .abacus a dewisodd y defnyddiwr i ddychwelyd eu newidiadau.Gall y ffeiliau hyn yn cael ei anwybyddu.

Agor Ffeil

I Agor ffeil, dim ond angen i bori at ble rydych yn dewis i storio copi gwaith, ac yn agor y ffeil ABACUS sy'n cael ei storio yno. Pan ABACUS yn gweld bod yna .log ffeil (ac efallai .newidiadau ffeilio os ydych wedi gwneud newidiadau), bydd yn trin y ffeil fel ffeil Menter.

Diweddaru Ffeil

Perfformio aBydd 'Diweddaru' n gadarnhau a oes fersiwn mwy diweddar o ffeil wedi ei lleoli ar y gweinydd. Os oes, bydd yn cau eich ffeil cyfredol, diweddaru at y ffeil mwy newydd o'r gweinydd, a llwytho i lawr rhai ffeiliau dros dro sydd â nifer fel estyniad - ee 'Demo.125'. Mae'r ffeiliau hyn y fersiynau hŷn y ffeil log, ac yn cael eu defnyddio i benderfynu pa newidiadau wedi cael eu gwneud i ffeil ers i chi diweddaru ei diwethaf. Mae angen hyn i ganfod unrhyw wrthdaro a allai fod wedi digwydd er mwyn i chi eu datrys.

Os yn ystod y broses diweddaru unrhyw gwrthdaroDarganfuwyd, Bydd angen i chi eu datrys cyn y gallwch agor eich ffeil eto (gallwch ganslo ond cewch eich annog i ddatrys y gwrthdaro etoy tro nesaf y byddwch yn agor eich ffeil).

Arbed Ffeil

Pan fyddwch yn arbed ffeil, mae hyn appends unrhyw newidiadau a wnaethoch i'r ffeil .changes. Mae'n Dim ynaddasu'r ffeil .abacus ar hyn o bryd - dim ond pan fydd y ffeil wedi ymrwymo i'r gweinydd bydd yn cael ei ysgrifennu dros (neu pan fyddwch yn derbyn y wybodaeth ddiweddaraf gan y gweinydd).

Ble mae 'Save As'?

Nid oes cysyniad o Save Fel ar gyfer ffeiliau Menter. Gallwch, fodd bynnag, copi eich copi gweithio .abacus ffeil, gadw mewn cof ei bod wont cael eich newidiadau lleol ynddo.

Gwrthdaro Datrys

Os bydd defnyddwyr eraill yn cael newidiadau ymrwymedig i'r ffeil mewn rhan debyg y ffeil i chi, efallai y bydd rhai wrthdaro rhwng eu newidiadau a chi. Er enghraifft, efallai y defnyddiwr arall ddileu elfen eich bod wedi diweddaru eiddo ar. Mae angen i chi naill ai dad-wneud eu newid (os ydych yn sicr y dylai rhai hwyNi wedi digwydd), neu daflu 'ch newid (efallai y byddwch wedyn yn mynd yn ôl i mewn i'r ffeil ac yn ail-wneud eich newid).

Yn benodol, mae 4 dosbarth o wrthdaro a all ddigwydd;

1. Dileu - Pan fydd un defnyddiwr yn dileu gwrthrych sy'n newid arall defnyddiwr. E.e. Defnyddiwr A dileu elfen, ond Defnyddiwr B newidiodd enw'r gydran neu'n gysylltiedig ag ef neu ychwanegu elfen blentyn iddo etc.

2. Nodwedd - Pan fydd dau ddefnyddiwr y ddau yn newid yr union un peth 'priodoledd' o wrthrych. E.e. Mae'r ddau Defnyddiwr A a B Defnyddiwr wedi newid enw cydran neu ei ddisgrifiad neu werth un o'i eiddo etc.

3. Cyfeirnod - Pan fydd dau ddefnyddiwr newid yr union yr un 'cyfeirio' gwrthrych wedi i wrthrych arall. E.e. Mae'r ddau Defnyddiwr A a B Defnyddiwr wedi newid math gydran neu'r gydran ffynhonnell / sinc sydd ynghlwm wrth cysylltiad neu safbwynt cysylltiedig ar gyfer ddiagram etc.

4. Casglu - Pan ddau ddefnyddiwr newid yn 'gasgliad' ar gyfer gwrthrych. E.e. Mae'r ddau Defnyddiwr A a B Defnyddiwr symudodd cydran gan un rhiant i'r llall neu ail-archebu gasgliad o gydrannau plant.

Nodyn

Mae amryw o wrthdaro ddibwys yn cael eu datrys yn awtomatig gan ABACUS i leihau'r gorbenion ar ddefnyddwyr.Er enghraifft, unrhyw leoliadau ledled chwyddo sy'n gwrthdaro ar gyfer diagramau yn cael eu datrys i gadw'r gosodiadau badell-chwyddo diweddaraf.

Ymrwymo Newidiadau

Pan fyddwch yn dewis i ymrwymo eich newidiadau, y ffeil ABACUS o'r gweinydd yn cael ei hagor, eich lleol newidiadau yn cael eu perfformioyn ei erbyn, ac wedyn eich lleol .abacus ffeil yn cael ei drosysgrifo â un sydd wedi eich newidiadau ynddi. Eich newidiadau ffeil yna overwrites y ffeil log, ac mae'r ddau y ffeil .abacus a'r ffeil log yn cael eu hanfon at y gweinydd.Os bydd y cyflawni yn llwyddiannus yn Ymrwymo ymgom Neges fel y dangosir isod yn cael ei ddarparu i fynd i mewn neges gyda'r ymrwymo.

Gweld Log Newidiadau

I gweld cofnod o'r newidiadau i Menter prosiect, Dewiswch Ffeil| Gweld Log...

Uchafswm Entries Log: Mae hyn yn Bydd ddiofyn at y 10 o geisiadau diwethaf ond gall cofnodion ychwanegol yn cael ei adfer drwy newid y gwerth a chlicio'r Adalw botwm.

Adolygu: Thcolofn e Adolygu rhestru'r rhifau adolygu ymrwymo i'r gweinyddwr Menter, yn ddiofyn, mewn trefn gronolegol.

Nodyn

Efallai na fydd y rhifau adolygu fod yn barhaus gan mai dim ond y ABACUS fydd yn ymrwymo'r cael eu rhestru tra bod yr un ystorfa subversion fod yn cael ei ddefnyddio ar gyfer prosiectau ABACUS eraill a / neu geisiadau rheoli fersiynau eraill.

Dyddiad: The Dyddiad colofn rhestru'r dyddiad y cafodd y diwygiad wedi ymrwymo i'r gweinydd Menter.

Amser: Thcolofn e Amser rhestru'r amser o'r dydd (mewn fformat 24 awr) bod y diwygiad wedi ymrwymo i'r gweinydd Menter.

Awdur: Thcolofn e Awdur rhestru'r Microsoft Windows enw mewngofnodi ar gyfer y defnyddiwr a berfformiodd y yn ymrwymo ac yna eu Enw defnyddiwr ABACUS , Neu 'Anhysbys' os nad yw'r defnyddiwr wedi ei ddilysu a defnyddwyr anhysbys oedd yn cael mynediad i'r prosiect Menter ar adeg yr ymrwymo.

Log Neges: Thcolofn Log e Neges rhestru'r neges yn ymrwymo a ddarparwyd â diwygio yn unol â'r deialog a ddangosir uchod.

Lawrlwytho adolygu XX fel ffeil ABACUS sy'n sefyll ar ei ben ei hun: Os byddwch yn dewis adolygiad yn y tabl ac yna cliciwch y botwm Lawrlwytho byddwch yn gallu i dynnu'r diwygiad prosiect ABACUS dewis o blith y gweinydd a'i gadw fel prosiect lleol / sefyll ar ei ben ei hun ABACUS.

Nodyn

I rolio yn ôl i adolygiad blaenorol, gweler hwn Erthygl cymunedol Avolution .

(Admin) Download file Log XML ar gyfer adolygu XX: Gall defnyddwyr gyda'r gallu Gweinyddwr ABACUS dewiswch diwygiad yn y tabl ac yna cliciwch y botwm Lawrlwytho i dynnu prosiect ABACUS ddewiswyd ymrwymo ffeil log o'r gweinydd a'i gadw fel ffeil .xml.

Gweld Trywydd Archwilio o Newidiadau

I gweld llwybr archwilio o'r newidiadau i unrhyw elfen benodol (hy cydran, cysylltiad, barn ni, plant ac ati) o Menter prosiect, de-gliciwch yr elfen a dewis Trywydd Archwilio..., Yn gosod y From ac i ystod Adolygu a chliciwch Chwilio.

Nodyn

Unwaith y bydd elfen yn cael ei ddileu o'r prosiect rydych bellach yn gallu cael mynediad i wybodaeth trywydd archwilio benodol am yr elfen honno. Gallwch, fodd bynnag, yn dal i gael mynediad at y gydran 'rhiant' (er enghraifft) a gweld gwybodaeth trywydd archwilio am y dileu (yn yr achos hwn yn rhestru'r ID yr elfen a oedd yn dileu).Ar ben hynny, Cydran / ymlyniad Cysylltiad yn 'eiddo' o'r cysylltiadau hynny yn newid gydran ynghlwm drwy'r ffenestr Explorer neu ar diagramau yn dangos yn y trywydd archwilio ar gyfer cysylltiad NID y gydran, a dileu'r cysylltiad a chreu cysylltiad newydd (fel y sy'n digwydd os ydych yn de-gliciwch 'Unattach' ac yna 'Connect ...' mewn catalogau) yn arwain at golli gwybodaeth trywydd archwilio ar gyfer y gydran gwreiddiol - atodiad cysylltiad yn gyfan gwbl.

Nodyn

Yn ddiofyn, bydd y llwybr archwilio recursively gwirio am newidiadau i unrhyw un o'r plant yr elfen dethol. Gall hyn arwain at amseroedd ymateb hir ac yn unol â hynny gall y trywydd archwilio yn cael ei gyfyngu i'r elfen ei hun drwy dad-ddethol y Recursive opsiwn o dan y Dewisiadau ArchwilioBotwm bar offer 'olwyn gêr' yn yr ymgom Trywydd Archwilio.

O Adolygu: Mae hyn yn Bydd ddiofyn i'r cyntaf adolygu / hynaf sydd ar gael ar gyfer y prosiect ar y gweinydd Menter.

I Adolygu: Mae hyn yn Bydd ddiofyn at y diwygiad diwethaf / mwyaf diweddar sydd ar gael ar gyfer y prosiect ar y gweinydd Menter.

Nodyn

Ar ôl gosod y From ac i adolygu amrediad cliciwch y botwm Chwilio i adfer unrhyw newidiadau penodol i'r elfen a ddewiswyd.

Adolygu: Thcolofn e Adolygu rhestru'r rhifau adolygu ymrwymo i'r gweinyddwr Menter, yn ddiofyn, mewn trefn gronolegol ymlaen.

Nodyn

Mae'r niferoedd adolygu yn annhebygol o fod yn barhaus gan y bydd dim ond y diwygiadau perthnasol i'r elfen a ddewiswyd yn cael eu dangos a dim ond y ABACUS yn ymrwymo yn cael eu rhestru tra bod yr un ystorfa subversion fod yn cael ei ddefnyddio ar gyfer prosiectau ABACUS eraill a / neu geisiadau rheoli fersiynau.

Dyddiad: The Dyddiad colofn rhestru'r dyddiad y cafodd y camau defnyddiwr ei wneud.

Nodyn

Y dyddiad a ddangosir yw'r dyddiad gweithredu defnyddiwr, nid y dyddiad y diwygiad wedi ymrwymo i'r gweinydd Menter. Yn unol â hynny, efallai y bydd y dyddiad flaen y diwygiad cyfatebol yn ymrwymo dyddiad a nodir gyda'r Ffeil | Gweld Log ...gorchymyn.

Amser: Thcolofn e Amser rhestru'r amser o'r dydd (mewn fformat 24 awr) bod y camau y defnyddiwr ei wneud.

Nodyn

Mae'r amser a ddangosir yw'r amser gweithredu defnyddiwr, nid yw'r amser y diwygiad wedi ymrwymo i'r gweinydd Menter. Yn unol â hynny, yr amser mwyaf mae'n debyg y bydd yn rhagflaenu y diwygiad cyfatebol yn ymrwymo amser a ddangosir gyda'r Ffeil | Gweld Log ...gorchymyn.

Awdur: Thcolofn e Awdur rhestru'r defnyddiwr a berfformiodd Microsoft Windows enw mewngofnodi y camau yn dilyn gan eu Enw defnyddiwr ABACUS , Neu 'Anhysbys' os nad yw'r defnyddiwr wedi ei ddilysu a defnyddwyr anhysbys oedd yn cael mynediad i'r prosiect Menter ar adeg y camau defnyddiwr.

Nodyn

Efallai na fydd y Awdur restrir yn y Trywydd Archwilio ymgom reidrwydd yn cyd-fynd â'r Awdur restrir yn yr ymgom View Log uchod ar gyfer yr un diwygiad. Mae hyn oherwydd bod y rhestrau View Log ymgom y mewngofnodi defnyddiwr ar adeg yr ymrwymo tra bod y rhestrau Trywydd Archwilio ymgom y mewngofnodi defnyddiwr ar adeg y camau defnyddiwr, ac mae'n bosibl cael un defnyddiwr wneud newidiadau ac yn anfon eu. newidiadau ffeil i ddefnyddiwr arall i ymrwymo - fel sy'n digwydd pan fydd defnyddiwr yn allanol (megis Avolution) yw gweithio ar brosiect EE.

Manylion: The Manylion colofn yn rhestru'r union fanylion y camau gweithredu defnyddiwr fel a gofnodwyd ar y gweinydd Menter.

Tip

Mae'n ddefnyddiol grŵp gan y golofn Adolygu (Fel y dangosir yn yr ymgom uchod) a / neu'r golofn Gweithredu Defnyddiwr i hawdd dosbarthu newidiadau i elfen o ddiddordeb.

Defnydd o Sgriptio gyda ffeiliau Menter

Os ydych yn defnyddio sgriptio gyda ffeiliau Menter, dylech fod yn ymwybodol o sut i ddileu gwrthrych yn gywir o'r model. Yn gyffredinol, pan fyddwch yn dileu gwrthrych, byddwch yn ffonio y dull .Delete () arno, yn hytrach na dim ond cael gwared iddo oddi wrth ei riant.

E.e. os ydych chi wedi comp1 fel rhiant y comp2 a hoffech ddileu comp2 yn eich sgript, dylech ffonio comp2.Delete (), yn hytrach na comp1.Components.Remove (comp2).

Efallai y byddwch yn defnyddio dynnu os ydych yn bwriadu ychwanegu'r gwrthrych comp2 i le arall o fewn y bensaernïaeth, ond ni ddylid ei ddefnyddio os mai'r bwriad yw dileu y gwrthrych.

Mae yna eithriad i hyn, pan fyddwch am gael gwared gwrthrych sy'n 'byw' mewn mannau eraill yn y model. Pan ydych yn dymuno i dynnu enghraifft safonol o bensaernïaeth / cydran / cysylltiad, yna byddech yn gwneud hynny drwy gael gwared rhag y lle yn safonol casgliad - arch1.Gweithrediadau.Remove (Arg) - oherwydd ei dileu y byddai'n ei dynnu o'r mhob achos.

Gywir gan ddefnyddio Dileu mewn sgriptiau yn bwysig oherwydd os yw gwrthrych yn cael ei dynnu oddi ar y objectmodel ac nid ail-ychwanegol, yna ni fydd yn gallu cael eu lleoli, ond gan nad oedd yn benodol 'dileu', nid yw Gwrthdaro Canfod a Datrys bydd canfod yn gywir gwrthdaro os bydd defnyddiwr arall oedd ceisio defnyddio'r gwrthrych mewn unrhyw un o'u newidiadau, a bydd y canlyniad fod yn set llygru o newidiadau ar gyfer y defnyddiwr.

Gweler Hefyd

Sut mae pensaernïaeth cynrychioli yn ABACUS?


Gweithio gyda Caniatadau

Navigation: Gweinyddiaeth>

Gweithio gyda Caniatadau

Anfon sylwadau ar y pwnc hwn.

Gall prosiectau ABACUS gael seiliedig ar rôlcaniatâd a osodwyd ar gyfer pob elfen o fewn y storfa. Yn benodol, dirwy graen- Create-Read-Update-Delete (CRUDGellir) caniatâd yn cael ei osod ar y 'gwrthrych' (hy cydran neu gysylltiad), gweld a priodoledd (lefelau hy eiddo).

Trosolwg

Wrth weithio gyda'r Menter ABACUS Gweinydd , ABACUS yn darparu graen mân, caniatâd CRUD seiliedig ar rôl i reoli mynediad defnyddwyr lluosog i'r ystorfa.

Nodyn

I ffurfweddu caniatadau mewn prosiect ABACUS angen y gallu Gweinyddwr y drwydded defnyddiwr. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

Gall caniatâd gael eu gosod ar gyfer y saernïaeth, mathau cydran a chysylltiad, eiddo (trwy eu math), templedi, safbwyntiau a diagramau, catalogau, matricsau, siartiau a 3Dbarn. Pan fydd caniatâd yn cael eu gosod ar gyfer cydran neu gysylltiad math holl achosion o'r math hwnnw mewn unrhyw saernïaeth yn y prosiect 'etifeddu' caniatadau hynny. Yn yr un modd, pan fo caniatâd yn cael ei osod ar gyfer eiddo o cydran neu gysylltiad fath, yr eiddo a roddir ar y cydran neu gysylltiad achosion mewn unrhyw saernïaeth yn y prosiect 'etifeddu' caniatadau hynny. Yn unol â hynny, bydd rhai caniatâd yn cael eu cymhwyso at y farn ar pa elfennau hynny'n bodoli. Pan fydd y caniatâd yn cael eu gosod ar gyfer diagram, y farn a / neu gynnwys y farn ei hun yn cael gwahanol fathau o ganiatâd yn berthnasol iddo.

Nodyn

Yn ddiofyn dim caniatâd yn cael eu gosod ar gyfer y elfennau o fewn prosiect ABACUS. Dyna'r pob elfen yn Createable, darllenadwy, eu diweddaru a Deleteable gan bob defnyddiwr. Yn y ffordd hon dylai caniatâd ond yn cael eu hystyried ar gyfer elfen a roddir yn yr ystorfa pan fo caniatâd penodol yw bod yn cyfyngedigar gyfer grŵp defnyddwyr penodol. Er enghraifft, os caniatâd i grŵp defnyddwyr a roddwyd yn cael eu hychwanegu at wrthrych (ee math cydran), ond yn gadael gyda phob caniatâd alluogi, yna mae hyn yn swyddogaethol yr un fath ag os y grŵp defnyddwyr Nid oedd ychwanegu at y gwrthrych.

Caniatâd Ni allyn cael eu gosod ar gyfer achosion penodol o elfennau pensaernïaeth yn. Er enghraifft, ni allwch wneud un gydran Cais diweddaru'n arall eto peidio. Er mwyn cyflawni'r rhain caniatadau 'parth penodol yn effeithiol, fodd bynnag, gall y Gweinyddwr sefydlu mathau penodol elfen ar gyfer y parthau a roddir, ee 'Cais - parth CRM' mathau o gydran a 'Cais - parth Adnoddau Dynol', ac yna gosod y caniatâd ar gyfer pob math yn unol â hynny. Gallwch wneud mathau penodol Grwpio ar gyfer pob parth a yna tynnwch caniatâd diweddaru ar gyfer y math grŵp parth-benodol a bydd hyn yn cyfyngu creadigaethau o fewn a dileadau o hynny Grwpio ond nid diweddaru o'r plant. Wrth gwrs os yw'r Grwpio parth-benodol ei guddio drwy gael gwared caniatâd darllen, yna byddai'r plant yn cael eu cuddio a thrwy hynny nad ydynt yn diweddaru'n. Fel arall, os golygfeydd (yn hytrach na fforiwr) yn cael eu defnyddio'n bennaf i reoli / weld eich ystorfa, barn a roddir ar gyfer pob maes gellid sefydlu, ac yna gallai'r Gweinyddwr osod y caniatâd ar gyfer pob golygfa yn unol â hynny.

Rheoli Defnyddwyr a Grwpiau

Caniatâd eu diffinio yn y rôlneu grŵplefel, yn hytrach na'r lefel defnyddiwr unigol, fel bod er y gall aelodaeth o'r grwpiau yn newid, y caniatadau yn gallu aros yn sefydlog. Wrth gwrs, os ydych am gael caniatâd defnyddwyr penodol, yna dim ond yn gwneud grŵp iddynt, neu yn fwy cywir yn creu grŵp gyda y defnyddiwr fel yr unig aelod.

Dylid nodi bod y grwpiau yn atomig, Hynny yw na allant etifeddu caniatâd neu ddefnyddwyr o un i'r llall, ac os yw defnyddiwr yn perthyn i grwpiau lluosog yna bydd y caniatâd y grŵp mwyaf 'besimistaidd' yn cael blaenoriaeth ar sail achos-wrth-achos ar gyfer pob caniatâd unigol (hy Creu -Read-Diweddariad-Delete). Er enghraifft, os yr un defnyddiwr yn aelod o Grŵp A a Grŵp B ac Grwp A newydd Creu-Read caniatâd ar gyfer mathau gydran Cais tra Grŵp B newydd Darllen-Diweddariad ganiatâd ar gyfer mathau gydran Gais yna bydd y defnyddiwr yn unig wedi Darllenwch caniatâd ar gyfer achosion cydran cais.

Ar ben hynny, yn ddiofyn, defnyddwyr anhysbys(Hynny yw ddefnyddwyr nad ydynt wedi'u diffinio neu nad ydynt wedi mewngofnodi) wedi mynediad llawni'r prosiect. Mae hyn er mwyn sicrhau bod mynediad ar gael mewn cyfluniad cychwynnol. I rwystro mynediad gan ddefnyddwyr anhysbys yn syml uncheck 'r' Caniatáu mynediad llawn defnyddiwr anhysbys i ffeilio 'opsiwn yn y Rheoli Defnyddwyr / Grwpiau Deialog a ddangosir isod. Pryd fydd defnyddwyr anhysbys unchecked ond yn gallu gweld y rhan Safonau unrhyw brosiect.

Yn olaf, dilysu enw defnyddiwr os opsiwn 'Use Windows Enw Defnyddiwr Mewngofnodi' yn cael ei wirio yn perfformio yn erbyn y Ffenestri Enw Defnyddiwr mewngofnodi ar beiriant bob defnyddiwr yn erbyn yr enw defnyddiwr yn mynd i mewn yn unol isod. Hynny yw os y Windows Username Login ar gyfer peiriant defnyddiwr penodol yn bodoli fel enw defnyddiwr dilys, yna nid oes angen unrhyw cyfrinair ac mae'r defnyddiwr yn cael ei dilysu'n yn awtomatig. Noder: mae hyn yn effeithiol yn caniatáu defnydd o Windows Active Directory (AD) dilysu.

Nodyn

O ystyried bod caniatâd yn unig yn cael eu diffinio pan fydd angen iddynt gael eu cymryd i ffwrdd (cyfyngedig) gan ddefnyddiwr, unrhyw ddefnyddiwr sydd ddim yn aelod o grŵp, neu unrhyw grŵp sydd heb ganiatâd a ddiffinnir ar ei gyfer erbyn unrhyw wrthrychau, bydd yn cael mynediad llawn at y prosiect.

Defnyddwyr a Grwpiau Defnyddwyr

Creu Defnyddiwr newydd

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

Nodyn

Os nad ydych yn gweld y Rheoli Defnyddwyr / Grwpiau eitem dewislen yna nid oes gennych y gallu Gweinyddwr. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

2. Yn y deialog sy'n ymddangos dewiswch y Ychwanegu Defnyddiwrbotwm a rhoi enw defnyddiwr a chyfrinair yn y Create New ymgom Defnyddiwr. Noder: Enwau Defnyddwyr a chyfrineiriau yn achos sensitif.

Nodyn

Os opsiwn 'Use Windows Enw Defnyddiwr Mewngofnodi' ei wirio fel y disgrifir uchod, yna gall cyfrinair dymi yn cael eu cofnodi fel dilysu yn cael ei berfformio yn ôl Ffenestr y defnyddiwr Enw Login unig.

2. Yn ddiofyn byddwch yn gweld bod y Gall defnyddwyr newid eu cyfrinair eu hunain. Os bydd angen, efallai y bydd y Gweinyddwr ABACUS dynnuy y gallu i ddefnyddwyr osod eu cyfrinair eu hunain gan glirio'r blwchy blychau gwirio.

Nodyn

Os gall defnyddwyr newid eu cyfrinair eu hunain bydd ganddynt Ffeil | Newid cyfrinair...eitem dewislen i wneud hynny.Hefyd, byddwch yn ymwybodol os yw pobl lluosog yn defnyddio'r un enw defnyddiwr yna gall un defnyddiwr newid y cyfrinair fel na all unrhyw bobl eraill mewngofnodi wedyn. Ymarfer Yn unol â hynny, argymhellir i gael sengl enw defnyddiwr y person go iawn.

4. Ddewisol, rhowch y cyfeiriad e-bost, Lleoliad a rhif ffôn ar gyfer y defnyddwyr i gyfeirio atynt yn y dyfodol.

5. Cliciwch ar y iawnbotwm yn y Create New ymgom Defnyddiwr.

6. Cliciwch ar y iawnbotwm.

Nodyn

Unwaith y byddwch wedi creu eich defnyddiwr yn gyntaf dylech ystyried rhwystro mynediad gan ddefnyddwyr anhysbys gan glirio'r blwch 'Caniatáu mynediad llawn defnyddiwr anhysbys i ffeilio' opsiwn yn y Rheoli Defnyddwyr / Grwpiau ymgom.Hefyd, unwaith y bydd defnyddiwr wedi cael ei greu (ac os brosiect Menter, mae'r newid wedi ymrwymo at 'r gweinyddwr), y tro nesaf y caiff y prosiect ei agor bydd defnyddwyr yn cael eu hysgogi i Mewngofnodi ar gyfer mynediad dilysedig ohonyntyn unol â'r deialog a ddangosir isod. Os bydd y Mewngofnodi awtomatig gyda manylion hynopsiwn yn cael ei wirio yna bydd y cyfuniad enw defnyddiwr / cyfrinair yn cael ei gofio ar gyfer y prosiect a chymhwysol bob tro ar agor. I glirio'r mewngofnodi arbed dethol Ffeil | Clear Saved Mewngofnodiar ôl agor a byddwch yn cael eich annog i fewngofnodi ar ôl tro nesaf y byddwch yn agor y prosiect.

Mewngofnodi

I ddileu Defnyddiwr presennol

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

2. Yn y deialog sy'n ymddangos dewiswch y Ffugenw yn y panel defnyddwyr yr hoffech eu dileu, ac yna dewiswch y Dileu Defnyddiwrbotwm.

3. Cliciwch ar y iawnbotwm.

Creu Grŵp newydd

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

2. Yn y deialog sy'n ymddangos dewiswch y Ychwanegu Groupbotwm a rhoi enw Grŵp yn y panel Grwpiau.

Nodyn

Mae'n rhaid i enwau grŵp fod yn unigryw.

3. Cliciwch ar y iawnbotwm.

I copïo sy'n bodoli eisoesGrŵp

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

2. Yn y deialog sy'n ymddangos dewiswch y CopiGrŵpbotwm.

Nodyn

Bydd grŵp dyblyg yn cael ei greu rhagddodi â "Copi o".Yn ddiofyn, bydd pob caniatâd gan y grŵp copïo yn cael eu dyblygu ar gyfer y "Copi o" grŵp gan gynnwys unrhyw aseiniad defnyddwyr.

3. Ailenwi'r "Copi o" grŵp fel y bo'n briodol gan ddefnyddio Golygu Grŵpneu araf dwbl-glicio.

I ddileu Grŵp sy'n bodoli eisoes

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

2. Yn y deialog sy'n ymddangos dewiswch enw'r grŵp yn y panel Grwpiau eich bod am ddileu ac yna dewiswch y Grŵp Dileubotwm.

Nodyn

Bydd unrhyw aseiniadau Defnyddwyr i'r Grwp hefyd yn cael eu dileu.

3. Cliciwch ar y iawnbotwm.

At benodi a Defnyddwyr i Grŵp

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

2. Yn y deialog sy'n ymddangos dewiswch y Ffugenw yn y panel defnyddwyr eich bod yn dymuno neilltuo i'r Grŵp a llusgo a gollwngei enw ar y Grŵp yn y panel Grwpiau yr hoffech ei neilltuo i.

3. Cliciwch ar y iawnbotwm.

Nodyn

Mae'r grŵp (iau) fod defnyddiwr cael ei neilltuo i yn cael eu dangos drwy ehangu Enw defnyddiwr yn y panel Defnyddwyra'r defnyddwyr sy'n cael eu neilltuo i grŵp yn cael eu dangos drwy ehangu yr enw Grŵp yn y panel Grwpiau. Er enghraifft, yn y screenshot uchod, y defnyddiwr "AS1-Aus" cael ei neilltuo i dri (3) grwpiau, sef; "App Cymorth Tîm 1", "Gwir" a "Awstralia".

I unassign Ddefnyddiwr gan Grŵp

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

2. Yn y deialog sy'n ymddangos ehangu yr enw Grŵp sy'n cynnwys yr aseiniad Defnyddwyr ydych yn dymuno ei unassign a dewiswch y Ffugenw.

3. Cliciwch ar y Defnyddiwr Unassignbotwm.

4. Cliciwch ar y iawnbotwm.

I fewnforio Defnyddwyr a / neu Grwpiau (ac unrhyw Caniatâd cyfateb)

1. Dewiswch Ffeil| Rheoli Defnyddwyr / Grwpiau

2. Cliciwch ar y Mewnforiobotwm.

3. Yn y deialog sy'n ymddangos Porii ac agor y prosiect ABACUS sy'n cynnwys y Defnyddwyr a / neu Grwpiau (a Caniatâd) yr hoffech i fewnforio i mewn i'r prosiect cyfredol a chlicio Agored. Bydd y Defnyddwyr a Grwpiau yn cael eu mewnforio ac ymddengys bod deialog Canlyniadau Mewnforio crynhoi mewnforio Defnyddwyr a / neu Grwpiau. Cliciwch ar y iawnbotwm.

Nodyn

Os bydd y Defnyddwyr neu Grwpiau fewnforiwyd yn bodoli eisoes yn y prosiect cyfredol, yna byddant yn cael eu huno â Defnyddwyr neu Grwpiau sydd eisoes yn bodoli.

4. Cliciwch ar y iawnbotwm yn ôl yn y prif Rheoli Defnyddwyr / Grwpiau dadl.

5. Os oes unrhyw Mathau paru, Gwylfannau, Templedi neu Pensaerniaethau rhwng y prosiect cyfredol a'r prosiect ABACUS ydych yn mewnforio o, ynghyd â chaniatadau nad ydynt yn bodoli eisoes yn y prosiect cyfredol, mae'r caniatâd yn cael eu mewnforio ac ail Canlyniadau Mewnforio ymgom Ymddengys crynhoi'r mewnforio. Cliciwch ar y iawnbotwm.

Nodyn

Caniatâd yn unig yn cael eu hychwanegu at Mathau presennol (a'u Priodweddau), Safbwyntiau, Templedi neu Pensaerniaethau i'r Grwpiau lle nad oedd y caniatâd yn bodoli eisoes ar gyfer y Grŵp. Naill ai oherwydd bod y Grŵp yn newydd neu'r Grŵp eisoes yn bodoli yn y prosiect cyfredol ond dim caniatâd wedi cael ei neilltuo i'r y Grŵp hwnnw i'r eitem honno. Nid oes unrhyw 'cyfuno' y caniatadau ar gyfer eitemau lle mae caniatâd eisoes yn bodoli ar gyfer y Grŵp yn y prosiect ar hyn o bryd sy'n cyfateb.

Gosod caniatadau

Gall caniatâd gael eu gosod ar gyfer y saernïaeth, mathau cydran a chysylltiad, eiddo (trwy eu math), templedi, safbwyntiau a diagramau, catalogau, matricsau, siartiau ynd 3Dbarn. Pan fydd caniatâd yn cael eu gosod ar gyfer cydran neu gysylltiad math holl achosion o'r math hwnnw mewn unrhyw saernïaeth yn y prosiect 'etifeddu' caniatadau hynny. Yn yr un modd, pan fo caniatâd yn cael ei osod ar gyfer eiddo o cydran neu gysylltiad fath, yr eiddo a roddir ar y cydran neu gysylltiad achosion mewn unrhyw saernïaeth yn y prosiect 'etifeddu' caniatadau hynny. Yn unol â hynny, bydd rhai caniatâd yn cael eu cymhwyso at y farn ar pa elfennau hynny'n bodoli. Pan fydd y caniatâd yn cael eu gosod ar gyfer diagram, y farn a / neu gynnwys y farn ei hun yn cael gwahanol fathau o ganiatâd yn berthnasol iddo.

Rheoli Caniatadau

I osod y caniatâd ar gyfer Elfen (neu Cysylltiad) Math

1. Ehangu'r Mathaucangen o'r goeden.

2. Ehangu'r Cydran (neu Cysylltiad) Mathaucangen o'r goeden.

3. Expand Grwpiaulle bo angen.

4. Dde-glicio ar y Cydran (neu Cysylltiad) Mathydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

5. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

6. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

Nodyn

Creu caniatâd yn llywodraethu hefyd pryd y gallwch gopïo elfen. Yn unol â hynny, er mwyn gallu copïo elfen yn gofyn Creu caniatâd ar gyfer ei holl blant (ers i copi elfen yn golygu copïo popeth oddi tano). Cael gwared caniatâd Diweddariad gan elfen cael gwared ar y gallu i addasu'r math ei hun, hyd yn oed os bydd y defnyddiwr wedi y Dylunydd ychwanegu-ar ac mae'n hefyd yn cael gwared caniatâd Diweddariad ar gyfer ei holl eiddo. Mae'n rhaid i elfen riant gael caniatâd Diweddariad i allu Creu unrhyw elfennau blant neu Dileu ei sydd eisoes yn bodoli elfennau blant. Dileu caniatâd ar gyfer elfen hefyd yn gofyn Dileu caniatâd ar gyfer ei holl blant. Dileu caniatâd ar gyfer cydrannau hefyd yn gofyn am ganiatâd Diweddariad o'r holl gysylltiadau sydd ynghlwm.Ac yn olaf, cael gwared caniatâd Dileu o elfen cael gwared ar y gallu i ddileu'r math ei hun, hyd yn oed os bydd y defnyddiwr wedi y Dylunydd ychwanegu-ar.

7. Cliciwch ar y iawnbotwm.

Gosod caniatâd ar gyfer Grŵp o Cydran (neu'r Cysylltiad) Mathau

1. Ehangu'r Mathaucangen o'r goeden.

2. Ehangu'r Cydran (neu Cysylltiad) Mathaucangen o'r goeden.

3. Dde-glicio ar y Grŵpsy'n cynnwys y Gydran (neu'r Cysylltiad) Mathau eich bod yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

6. Cliciwch ar y iawnbotwm.

7. Yn y deialog sy'n ymddangos cliciwch y Ydybotwm.

I osod y caniatâd am Eiddo

1. Ehangu'r Mathaucangen o'r goeden.

2. Ehangu'r Cydran (neu Cysylltiad) Mathaucangen o'r goeden.

3. Expand Grwpiaulle bo angen.

4. Dewiswch y Gydran (neu'r Cysylltiad) Teipiwch sy'n cynnwys yr eiddo yr ydych yn dymuno i'r caniatâd a osodwyd ar gyfer.

5. Yn y ffenestr Properties dde-glicio ar y Eiddoydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

6. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

7. Yn ddiofyn byddwch yn gweld bod yr Darllen a Diweddariad caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

Nodyn

Eiddo sydd wedi cael y caniatâd Diweddariad dynnu eu dangos yn llythrennau italigyn y ffenestr Propertiesac ni ellir eu gwerthoedd yn cael eu diweddaru gan y rôl honno. Hefyd, mae'r gallu i addasu'r manylion eiddo (ee enw, unedau ac ati) yn gofyn am ganiatâd Diweddariad ar yr eiddo a y Dylunydd ychwanegu-ar.

8. Cliciwch ar y iawnbotwm.

I osod y caniatâd am Templed

1. Ehangu'r Templedicangen o'r goeden.

2. Porwch at y Templedy mae gennych ddiddordeb ynddo.

3. Dde-glicio ar y Templedydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn byddwch yn gweld bod y caniatâd Read ar gael. Tynnwch y caniatâd gan glirio'r blwchy blwch gwirio.

6. Cliciwch ar y iawnbotwm.

I osod y caniatâd am Viewpoint

1. Ehangu'r Gwylfannaucangen o'r goeden.

2. Expand Grwpiaulle bo angen.

3. Dde-glicio ar y Viewpointydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

6. Cliciwch ar y iawnbotwm.

Gosod caniatâd ar gyfer Pensaernïaeth

1. Ehangu'r Pensaernïaethcangen o'r goeden.

2. Expand i'r Pensaernïaethy mae gennych ddiddordeb ynddo.

3. Dde-glicio ar y Pensaernïaethydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn byddwch yn gweld bod y caniatâd Read ar gael. Tynnwch y caniatâd gan glirio'r blwchy blwch gwirio.

6. Cliciwch ar y iawnbotwm.

I osod y caniatâd am Catalog

1. Ehangu'r Catalogaucangen o'r bensaernïaeth mae gennych ddiddordeb ynddo.

2. Expand Grwpiaulle bo angen.

3. Dde-glicio ar y Catalogydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

6. Cliciwch ar y iawnbotwm.

I osod y caniatâd am Matrics

1. Ehangu'r Matricsaucangen o'r bensaernïaeth mae gennych ddiddordeb ynddo.

2. Expand Grwpiaulle bo angen.

3. Dde-glicio ar y Matricsydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

6. Cliciwch ar y iawnbotwm.

I osod y caniatâd am Diagram

1. Ehangu'r Diagramaucangen o'r bensaernïaeth mae gennych ddiddordeb ynddo.

2. Expand Grwpiaulle bo angen.

3. Dde-glicio ar y Diagramydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

Nodyn

Er y gallwch osod y caniatâd CRUD yn uniongyrchol am diagram, dylid nodi y gall y caniatadau o'r elfennau ar y diagram yn effeithio ar y caniatâd ar gyfer yr olygfa ei hun. Er enghraifft, os oes hyd yn oed un elfen yn unig ar y farn sydd wedi cael ei Read neu ddileu Diweddariad ganiatâd yna bydd y diagram yn cael ei ganiatâd Diweddariad dileu. Mae hyn oherwydd; a) Ni fydd yr elfennau ar y farn sydd wedi cael eu caniatâd Darllen tynnu eu dangos ar y farn gan adael 'gofod gwyn' lle y gallai chi osod fel arall rhai elfennau newydd os y farn oedd diweddaru'n, ac b) yr elfennau ar y farn y wedi cael eu caniatâd Diweddariad tynnu yna gallai gael elfennau eraill ollwng ar iddynt ddod yn blant os y farn oedd diweddaru'n. Hefyd, Creu a chaniatâd Diweddariad am ddiagram yn mynnu bod yr holl elfennau ar y farn yn cael y caniatâd Darllen a cydrannau wedi cael caniatâd Diweddariad (mae hyn oherwydd i symud cydran ymlaen i gydran arall, rhaid i chi allu ei ddiweddaru ers y bydd yn yn dod yn blentyn).

6. Cliciwch ar y iawnbotwm.

I osod y caniatâd am View 3D

1. Ehangu'r 3Golygfeydd Dcangen o'r bensaernïaeth mae gennych ddiddordeb ynddo.

2. Expand Grwpiaulle bo angen.

3. Dde-glicio ar y 3D Viewydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

6. Cliciwch ar y iawnbotwm.

I osod y caniatâd am Siart

1. Ehangu'r Siartiaucangen o'r bensaernïaeth mae gennych ddiddordeb ynddo.

2. Expand Grwpiaulle bo angen.

3. Dde-glicio ar y Siartydych yn dymuno gosod y caniatâd am a dethol Golygu Caniatâd.

4. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

5. Yn ddiofyn, byddwch yn gweld bod y Creu, Darllen, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

6. Cliciwch ar y iawnbotwm.

Gweler Hefyd

Sut mae pensaernïaeth cynrychioli yn ABACUS?


Gweithio gyda Dangosfyrddau

Navigation: Gweinyddiaeth>

Gweithio gyda Dangosfyrddau

Anfon sylwadau ar y pwnc hwn.

Gall prosiectau ABACUS gael unrhyw ffurfweddiad barn (ee diagramau, Siartiau ac ati) harbed fel dangosfwrdd a gall dangosfyrddau arbed y rhain fod yn a osodwyd fel 'r ball dechrau' sgrin 'ar agor prosiect a / neu neilltuo i penodol grŵp defnyddwyr a'i gyflwyno i aelodau'r grŵp hwnnw defnyddiwr pan fyddant yn mewngofnodi i brosiect ABACUS.

Nodyn

I ffurfweddu dangosfyrddau mewn prosiect ABACUS angen y gallu Gweinyddwr y drwydded defnyddiwr. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

Yn Golygu: Dangosfyrddau

Enghraifft Cais Rheoli Portffolio (APM) dangosfwrdd

I weld Dangosfwrdd arbed

1. Dewiswch View| Dangosfyrddau

2. Dewiswch dangosfwrdd achub o'r rhestr o dashboards sydd ar gael.

Nodyn

Unwaith ABACUS a ddewiswyd yn adeiladu safbwyntiau ofynnol ar gyfer y dangosfwrdd a gall hyn gymryd ychydig eiliadau. Byddwch yn amyneddgar.

Rheoli Dangosfyrddau

Rheoli Dangosfyrddau

I greu Dangosfwrdd newydd

1. Agorwch y barnau gofynnol a trefnu a doc ffenestri yn ôl yr angen ar gyfer yr dangosfwrdd.

2. Dewiswch View| Dangosfyrddau| Rheoli Dangosfyrddau ...

Nodyn

Os nad ydych yn gweld yr eitem dewislen Rheoli Dangosfyrddau yna nid oes gennych y gallu Gweinyddwr. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution os oes angen gallu hwn.

3. Yn y deialog sy'n ymddangos dewiswch y Creubotwm a nodwch enw'r Dangosfwrdd yn y Create New Dangosfwrdd ymgom.

4. Cliciwch ar y iawnbotwm.

I ddileu Dangosfwrdd presennol

1. Dewiswch View| Dangosfyrddau| Rheoli Dangosfyrddau ...

2. Yn y deialog sy'n ymddangos dewiswch y Dangosfwrdd hoffech ei ddileu o'r rhestr a dewis y Dileubotwm.

Nodyn

Bydd dileu dangosfwrdd hefyd ddileu unrhyw aseiniadau grŵp defnyddwyr i'r dangosfwrdd.

3. Cliciwch ar y iawnbotwm.

I gymryd lle Dangosfwrdd presennol

1. Agorwch y barnau gofynnol a trefnu a doc ffenestri yn ôl yr angen ar gyfer yr dangosfwrdd newydd.

2. Dewiswch View| Dangosfyrddau| Rheoli Dangosfyrddau ...

3. Yn y deialog sy'n ymddangos dewiswch y Dangosfwrdd yr hoffech i gymryd lle o'r rhestr a dewis y Amnewidbotwm.

4. Cliciwch ar y iawnbotwm i gydnabod y Dangosfwrdd Amnewid ymgom.

At benodi a Dangosfwrddfel 'r ball Start Sgrin

1. Dewiswch View| Dangosfyrddau| Rheoli Dangosfyrddau ...

2. Yn y deialog sy'n ymddangos dewiswch y Dangosfwrdd o'r rhestr hoffech ei aseinio fel 'sgrin' cychwyn rhagosodediga dewis y Neilltuo ...botwm.

3. Yn y deialog sy'n ymddangos dewiswch y cofnod yn y Defnyddwyr Grwpiau golofn.

Nodyn

Dim ond un dangosfwrdd cael ei neilltuo fel y cychwyn 'sgrin' felly bydd ail-aseiniad gael gwared ar y aseiniad o'r dangosfwrdd blaenorol.Ar ben hynny, os bydd y defnyddiwr yn mewngofnodi i mewn fel aelod o grŵp defnyddwyr sydd â dangosfwrdd neilltuo yna bydd y dangosfwrdd neilltuo cael ei agor yn lle y dangosfwrdd prosiect diofyn.

4. Cliciwch ar y iawnbotwm.

At benodi a Grŵp Defnyddwyr i Dangosfwrdd

1. Dewiswch View| Dangosfyrddau| Rheoli Dangosfyrddau ...

2. Yn y deialog sy'n ymddangos dewiswch y Dangosfwrdd o'r rhestr hoffech ei benodi a grŵp defnyddwyr i ac yn dewis y Neilltuo ...botwm.

3. Yn y deialog sy'n ymddangos dewiswch y Grŵp Defnyddwyr (neu Grwpiau)ydych yn dymuno aseinio'r dangosfwrdd fel y sgrin 'cychwyn' ar gyfer.

Nodyn

Os bydd yr un Grŵp Defnyddwyr cael ei neilltuo i dangosfyrddau lluosog, yna bydd yr aseiniad cyntaf yn y rhestr yn cael ei ddefnyddio.

4. Cliciwch ar y iawnbotwm.

I unassign Grŵp Defnyddwyr o Dangosfwrdd

1. Dewiswch View| Dangosfyrddau| Rheoli Dangosfyrddau ...

2. Yn y deialog sy'n ymddangos ehangu'r eitem Dangosfwrdd o'r rhestr hoffech ei unassign grŵp defnyddwyr o.

3. Dewiswch y grŵp Defnyddwyr ydych yn dymuno unassign a dewis y Unassignbotwm.

4. Cliciwch ar y iawnbotwm.

Gosod caniatadau

Gall caniatâd gael eu gosod ar gyfer dangosfyrddau i ganiatáu ar gyfer dangosfwrdd i fod yn viewable, Eu diweddaru a / neu deleteablei grwpiau defnyddwyr penodol.

Rheoli Caniatadau

I osod y caniatâd am Dangosfwrdd

1. Dewiswch View| Dangosfyrddau| Rheoli Dangosfyrddau ...

2. Yn y deialog sy'n ymddangos dewiswch y Dangosfwrdd o'r rhestr hoffech ei osod caniatâd am a dethol y Caniatâd ...botwm.

3. Yn y deialog sy'n ymddangos, cliciwch ar y Ychwanegu ...botwm a dewis y Grŵpydych am ychwanegu naill ai drwy ddwbl-glicio neu ddewis ei a chlicio ar y iawnbotwm.

4. Yn ddiofyn, byddwch yn gweld bod y Read, Diweddaru a Dileu caniatâd i gyd ar gael. Tynnwch y caniatadau gan glirio'r blwchy blychau gwirio perthnasol.

5. Cliciwch ar y iawnbotwm.

Gweler Hefyd

Addasu rhyngwyneb ABACUS | Gweithio gyda Caniatadau


Cofrestru ABACUS

Navigation: Cyfeirnod>

Cofrestru ABACUS

Anfon sylwadau ar y pwnc hwn.

Pan fyddwch yn dechrau y tro cyntaf ABACUS (neu ar ôl trwydded dros dro wedi dod i ben), bydd angen i chi gofrestru ar y cais yn erbyn gweinydd drwydded Avolution gan ddefnyddio allwedd trwydded unigryw a ddarperir gan eich Gweinyddwr ABACUS lleol neu yn uniongyrchol oddi wrth Avolution. Os nad oes gennych allwedd trwydded, cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution .

I gofrestru gydag allwedd trwydded

1. Ar ôl installation, cychwyn ABACUSnaill ai gan dwbl-glicio ar y llwybr byr ar y bwrdd gwaith neu o'r ddewislen Windows Start.

2. Yn yr ymgom Cofrestru sy'n ymddangos fynd i mewn i'r Allwedd trwydded 26 cymeriada ddarperir gan eich Gweinyddwr ABACUS lleol neu Cefnogaeth Avolution , Neu cliciwch Pori ...a dewis y ffeil .dlsc lofnodi ddychwelyd o Cymorth Avolution yn unol â'r Nodyn yng Ngham 4 isod. Os ydych yn defnyddio ffeil .dlsc lofnodi yn gywir dylai ABACUS dechrau fel fesul Cam 5 isod.

Tip

Gallwch bastio yr allwedd trwydded i mewn i'r deialog drwy gopïo i'r clipfwrdd Windows, ac yna dewis y cefndir yr ymgom a gwasgu Ctrl + V.

Deialog Cofrestru

3. Cliciwch iawnac os yw'r allwedd drwydded yn ddilys allwedd trwydded ABACUSBydd ABACUS yn awr yn ceisio cysylltu â gweinydd trwydded Avolution i ddilysu yr allwedd drwydded.

Nodyn

Os ydych yn cael Cod Gosod yn annilysGwall cofrestru mae'n fwyaf tebygol eich bod wedi teipio'r cod yn anghywir. Ceisiwch gopïo a chludo y cod yn unol â'r Tip a grybwyllwyd uchod.

Cysylltu â'r Gweinydd Trwydded Avolution

4. Cliciwch iawnac ar ôl cyfnod byr o amser a ddylai ABACUS gofrestru yn llwyddiannus.

Cofrestru Llwyddiannus

Nodyn

Os ydych yn cael Methu cysylltu â gweinydd trwyddedGwall cofrestru mae'n fwyaf tebygol y wal dân (neu fesurau diogelwch eraill) ar eich rhwydwaith yn atal mynediad at weinydd trwydded Avolution yn. Cliciwch iawn, Gadw'r ffeil .dlsc at eich peiriant lleol ac yna naill ai e-bostio'r ffeil i .dlsc Cymorth Avolution ac aros gyfarwyddiadau pellachneu ceisiwch lofnodi'r drwydded ffeil eich hun gan ddefnyddio'r URL canlynol - http://licensing.avolutionsoftware.com/LicenceSign/ .

Methu cysylltu â'r gweinydd trwydded

Agorwch y dudalen we arwyddo License

Trwydded Llawlyfr arwyddion webpage

Fel arall, os ydych yn cael y Mae'r cod gosodiad wedi cael ei ddefnyddio ar fwy nag systemau a ganiateir gan y drwyddedGwall cofrestru mae'n debygol bod eich peiriant lleol wedi cael ei ailadeiladu ers i chi wedi cofrestru ABACUS diwethaf neu os ydych yn ceisio cofrestru gyda allwedd trwydded defnyddiwr arall. Cysylltwch â'ch Gweinyddwr ABACUS lleol neu Cymorth Avolution .

Cod Gosod eisoes wedi cael ei ddefnyddio

5. Cliciwch iawnac os yw wedi'i gofrestru yn llwyddiannus dylai ABACUS agor gyda'r Croeso Sgrin .

Gweler Hefyd

Cymorth Avolution | Beth mae ABACUS ei wneud?


ABACUS Gosod Rhagofynion

Navigation: Cyfeirnod>

ABACUS Gosod Rhagofynion

Anfon sylwadau ar y pwnc hwn.

Gwybodaeth Ynghylch Visio Mewnforio ac Excel Mewnforio / Allforio

ABACUS ei gwneud yn ofynnol bod Microsoft Office yn cael eu gosod er mwyn perfformio gweithrediadau Excel Mewnforio / Allforio a Mewnforio Visio. Gwiriwch fod Microsoft Office 2003 neu mwy newyddyn cael ei osod yn gywir. Os cewch broblemau pellach, cysylltwch â Cymorth Avolution .

Er mwyn perfformio gweithrediadau Visio Mewnforio ac Excel Mewnforio / Allforio, ABACUS yn defnyddio Microsoft Office Primary interop Cynulliadau (PIA) yn. ABACUS hyn o bryd yn dod pecynnu gyda'r gwasanaethau angenrheidiol i berfformio Excel Mewnforio / Allforio a Mewnforio Visio.

Gwybodaeth Ynghylch SQL Server Mewnforio

ABACUS ei gwneud yn ofynnol bod Microsoft SQL Gweinyddwr 20052008, 2008 R2, 2012 neu 2014ei osod er mwyn dechrau prosiect newydd From SQL Gweinyddwr. Gwiriwch fod Microsoft SQL Gweinyddwr 20052008, 2008 R2, 2012 neu 2014yn cael ei osod yn gywir. Os cewch broblemau pellach, cysylltwch â Cymorth Avolution .

Gwallau Agor Delweddau 3D

Os nad yw'r Gwyliwr ABACUS 3D yn gweithio i chi, efallai y byddwch yn colli'r SlimDX DirectX Runtime (gosod fel rhan o'r ABACUS EXE llawn gorsedda). Gellir lawrlwytho hwn yma . Os oes gennych fersiwn 64bit o Windows, efallai y bydd angen i chi hefyd osod hwn .

Gwallau Golygu ABACUS Custom Adroddiadau

Adroddiadau Custom Golygu ABACUS 'yn gofyn Adroddiad Builder 3.0 i gael eu gosod. ABACUS ac Adroddiad Builder yn cael eu adeiladu ar y Fframwaith NET Microsoft 4.0, ac er nad oes angen Fframwaith NET Microsoft 3.5 y maent yn ddau, Microsoft wedi ffurfweddu yn anghywir Adroddiad Builder MSI i ddim ond fwrw ymlaen os NET Fframwaith 3.5 Microsoft wedi ei osod.

Yn unol â hynny, mae gan Avolution fersiwn wedi'i golygu o'r gosodiad Adroddiad Builder ffeil MSI nad oes angen Fframwaith NET Microsoft 3.5, gall hyn ei lwytho i lawr yma .

Gall y gwreiddiol Adroddiad Microsoft Builder MSI ei lwytho i lawr yma . Os nad oes gennych Microsoft NET Fframwaith 3.5 y bydd yn ei gwneud yn ofynnol, gallwch ei lawrlwytho yma . Sylwer: Ar gyfer gosodiadau lluosog, mae'r all-lein gosod y Fframwaith NET Microsoft 3.5 o yma gallai fod yn fwy priodol.


Opsiynau Archa Bannod

Navigation: Cyfeirnod>

Opsiynau Archa Bannod

Anfon sylwadau ar y pwnc hwn.

Gallwch berfformio gwahanol weithrediadau ABACUS uniongyrchol o'r llinell orchymyn gyda gweithrediad mwyaf cyffredin yw i agor ffeil brosiect penodol a'i gyhoeddi i'r HTML.

Yn benodol, y defnydd archa bannod o ABACUS fel a ganlyn;

ABACUS.exe ProjectFile [OptionalFile] [/ exitOnCompletion] [/ dontShowDialogs] [/ defnyddiwr "DEFNYDDIWR" / pasio "PASS"]

Dadl | Disgrifiad
ProjectFile | Gall y ProjectFile fod naill ai ar ffurf ffeil ABACUS prosiect (.abacus), ffeil llyfrgell (.abacuslib), ffeil XML (.xml) neu MS Access DB (.mdb) a'r ffeil penodedig, bydd naill ai'n cael ei agor (os .abacus neu .abacuslib ) neu brosiect newydd a grëwyd (os .xml neu ffeil .mdb).
OptionalFile | Gall y OptionalFile fod naill ai sgript ABACUS (.abacusscript, .vb neu .cs), macro (.abacusmac) neu ffeil llyfrgell (.abacuslib) a'r ffeil penodedig, bydd naill ai'n cael ei redeg ar ôl agor y ProjectFile (os .abacusscript, .vb neu .cs neu .abacusmac) neu hagor yn syml (os .abacuslib).
/ ExitOnCompletion | A fydd ymadael ABACUS ac os oes angen arbed ac ymrwymo unrhyw newidiadau i'r prosiectau .abacus agor ar gwblhau unrhyw sgript neu macro. Noder: Mae'r faner yn Achos Sensitif felly gwnewch yn siŵr i ddefnyddio 'O' priflythyren ac 'C' yn y testun fel y dangosir.
/ DontShowDialogs | A fydd yn atal Enterprise Edition ABACUS (EE) deialogau diweddaru hysbysiad gan ddangos ar agor prosiect. Noder: Mae'r faner yn Achos Sensitif felly gwnewch yn siŵr i ddefnyddio priflythyren 'S' a 'D' yn y testun fel y dangosir.
/ Defnyddiwr "DEFNYDDIWR" / pasio "PASS" | Bydd y DEFNYDDIWR enw defnyddiwr a chyfrinair PASS cael ei ddefnyddio i fewngofnodi i'r prosiect gyda, gor-redol unrhyw gymwysterau ddefnyddiwr cadw. Sylwer: Rhaid dyfyniadau dwbl yn cael eu gosod o amgylch y DEFNYDDIWR a PASS baneri a gall dau dyfynodau dwbl yn cael ei ddefnyddio i ddianc rhag dyfynodau dwbl naill ai yn y DEFNYDDIWR neu'r PASS baneri.

E.e.;

ABACUS.exe "Data \ Example.abacus" "Sgriptiau \PublishExample.VB"/ ExitOnCompletion / dontShowDialogs / defnyddiwr "Cyhoeddus" / pasio "123456"

pryd rhedeg o'r cyfeiriadur lle y ABACUS.exe deuaidd yw lleoli Bydd agored prosiect Enghraifft a mewngofnodi fel defnyddiwr Cyhoeddus gyda chyfrinair 123456 (fel y disgrifiwyd yma ), Ei gyhoeddi yn HTML ac yna cau'r prosiect i gyd heb ddangos unrhyw deialogau ar hyd y ffordd (ee 'Diweddariad llwyddiannus' neu 'Dim ddiweddariadau ar gael' ar gyfer prosiectau Menter).

E.e.;

ABACUS.exe "Data \ Example.abacus" "Sgriptiau \Excel Mewnforio Catalog.VB"/ ExitOnCompletion / dontShowDialogs

pryd rhedeg o'r cyfeiriadur lle y ABACUS.exe deuaidd yw lleoli Bydd agored prosiect Enghraifft ac yn mewnforio y "Gweinyddwyr (2014 Gwirioneddol) .xlsx" ffeil MS Excel i mewn i'r catalog 'Gweinyddion' o'r '2014 Gwirioneddol' pensaernïaeth y prosiect heb ddangos unrhyw deialogau ar hyd y ffordd ac yna cau'r prosiect ar ôl ei gwblhau. Os bydd y llawdriniaeth yn gwneud newidiadau i'r prosiect yna pan yn cau o newidiadau yn cael eu cadw yn lleol ac os phrosiect Menter ymrwymo i'r Gweinyddwr Menter.

Nodyn

Byddwch yn siwr i ddefnyddio'r dyfyniad cymeriad dwbl gywir gan fod nifer yn y safon set nodau ASCII a'r Prydlon Windows Archa bydd ond yn gweithio yn gywir gyda'r un cywir. Mae'r cod dyfyniad cymeriad dwbl cywir yn Degol 34 (hecsadegol 22).Mae hyn yn hyn a ddefnyddir yn yr enghraifft uchod felly mae croeso i gopïo / gludo oddi yno.


Teitl Tudalen

ABACUS

Ymwadiad

Avolution Pty Ltd yn gwneud unrhyw sylwadau na gwarantau mewn perthynas â llawlyfr hwn ac, i'r graddau eithaf a ganiateir gan y gyfraith, yn cyfyngu'n benodol ar ei atebolrwydd am dorri unrhyw warant y gellir eu oblygedig i amnewid y llawlyfr hwn gydag un arall. Ymhellach, Avolution Pty Ltd yn cadw'r hawl i ddiwygio y cyhoeddiad hwn ar unrhyw bryd heb orfod talu rwymedigaeth i hysbysu unrhyw berson o'r adolygiad.

Hawlfraint

Hawlfraint 2001-2015Cedwir Avolution Pty Ltd Cedwir pob hawl.

Nodau Masnach

Avolution Pty Ltd wedi gwneud pob ymdrech i ddarparu gwybodaeth nod masnach am enwau cwmnïau, cynhyrchion a gwasanaethau a grybwyllir yn y llawlyfr hwn. Nodau Masnach a ddangosir isod yn deillio o amrywiol ffynonellau.

Microsoft Windows, Access, Visio, Excel, SQL Server a Internet Exploreryn nodau masnach Microsoft Corporation.

Hysbysiad Cyffredinol:

Mae rhai enwau cynnyrch a ddefnyddir yn y llawlyfr hwn yn cael eu defnyddio at ddibenion adnabod yn unig a gall fod yn nodau masnach eu cwmnïau eu hunain.

Rhagfyr 2015Argraffiad gyfer Avolution Fersiwn ABACUS 4.5.

Adolygu Llawlyfr 1.0

Gynhyrchir, argraffu, ac yn rhwymo yn Awstralia.